# Table of Contents

## 11 Introduction

- About the Program Versions
- Typographical Conventions

## 12 Part I - Getting into the Details

### 13 Setting Up Your System

- Setting Up Audio
- Setting Up MIDI
- Connecting a Synchronizer
- Setting Up Video

### 22 VST Connections

- VST Connections Window
- Renaming the Hardware Inputs and Outputs
- Adding Input and Output Busses
- Adding Child Busses (Cubase Pro only)
- Presets for Input and Output Busses
- Adding Group and FX Channels
- About Monitoring
- External Instruments and Effects (Cubase Pro only)
- Editing the Bus Configurations

### 43 Project Window

- Toolbar
- Status Line
- Info Line
- Overview Line
- Ruler
- Inspector
- Global Track Controls
- Visibility
- Track List
- Event Display
- Racks
- Zooming in the Project Window
- Snap Function
- Cross-Hair Cursor
- Edit History Dialog

## 67 Project Handling

- Creating New Projects
- Steinberg Hub
- Project Assistant
- About Project Files
- About Template Files
- Project Setup Dialog
- Opening Project Files
- Saving Project Files
- Reverting to the Last Saved Version
- Choosing a Project Location
- Removing Unused Audio Files
- Creating Self-Contained Projects

## 82 Tracks

- Audio Tracks
- Instrument Tracks
- MIDI Tracks
- Arranger Track
- Chord Track
- FX Channel Tracks
- Folder Tracks
- Group Channel Tracks
- Marker Track
- Ruler Track
- Signature Track
- Tempo Track
- Transpose Track
- VCA Fader Track (Cubase Pro only)
- Video Track
- Customizing Track Controls
291  MixConsole
293  Setting Up the MixConsole
293  MixConsole Toolbar
295  Functions Menu
297  Configuring the MixConsole
304  Synchronizing Channel and Track Visibility
305  Finding Channels
305  Linking Channels
308  VCA Faders (Cubase Pro only)
314  Metering (Cubase Pro only)
318  Input Levels
319  Copying and Moving Rack and Channel Settings
320  Fader Section
325  Working with Channel Racks
348  Using Channel Settings
350  Adding Notes to a MixConsole Channel
350  Keyboard Navigation
352  Control Room (Cubase Pro only)
352  Adding Channels to the Control Room
353  Output Routing
353  Exclusive Assignment of Monitor Channels
353  Control Room Channels
356  Control Room Mixer
362  Control Room Setup
365  Setting Up a Cue Mix
366  Adjusting the Overall Cue Send Level
367  Metering
367  Loudness
372  Audio Effects
372  Overview
374  Insert Effects
382  Send Effects
388  Side-Chain Input
391  External Effects (Cubase Pro only)
391  Effect Control Panel
392  Comparing Effect Settings
392  Effect Presets
398  Plug-In Information Window
401  Audio processing and functions
401  Background
401  Audio processing
416  Applying plug-ins (Cubase Pro only)
418  The Offline Process History dialog
420  Freeze Edits
421  Detect Silence
424  The Spectrum Analyzer
426  Statistics
428  About time stretch and pitch shift algorithms
432  Sample Editor
432  Window overview
440  General Functions
452  Warping audio
459  Working with hitpoints and slices
468  VariAudio (Cubase Pro only)
488  Generating Harmony Voices for Monophonic Audio (Cubase Pro only)
489  Flattening realtime processing
492  Audio Part Editor
492  Window Overview
494  Opening the Audio Part Editor
495  Operations
498  Options and Settings
499  Pool
500  Pool Window
504  Working with the Pool
522  MediaBay
523  Working With the MediaBay
523  Setting Up the MediaBay
524  Define Locations Section
525  Scanning Your Content
525  Updating the MediaBay
526  Locations Section
528  Results Section
533  Previewer Section
539  Filters Section
544  Attribute Inspector
550  Loop Browser, Sound Browser, and Mini Browser
550  MediaBay Preferences
552  MediaBay Key Commands
552  Working with MediaBay-Related Windows
555  Working With Volume Databases
558  Surround Sound (Cubase Pro only)
559  Deliverables
559  Available surround configurations
560  Preparations
562  Using the SurroundPanner V5
574  Using the MixConvert V6 plug-in
574  Exporting a surround mix
Automation Curves
Static Value Line
Write/Read Automation
Writing Automation Data
Editing Automation Data
Automation Tracks
Virgin Territory vs. Initial Value (Cubase Pro only)
Automation Panel
MIDI Controller Automation
VST Instruments
VST Instruments Window
Adding VST Instruments
Presets for Instruments
VST Quick Controls
Playing Back VST Instruments
About Latency
Import and Export Options
External Instruments (Cubase Pro only)
Installing and Managing Plug-ins
Installing VST plug-ins
Plug-in Manager
Compiling a New Effects Collection
Track Quick Controls
Assigning Parameters to Quick Controls
Connecting Quick Controls with Remote Controllers
Activating Pick-up Mode for Hardware Controls
Quick Controls and Automatable Parameters
Remote controlling Cubase
Setting Up
Operations
The Generic Remote device
Track Quick Controls
The Remote Control Editor
Apple Remote (Macintosh only)
MIDI realtime parameters and effects
The Inspector – general handling
The Inspector sections
MIDI effects
Using MIDI devices
MIDI devices – general settings and patch handling
About Device panels (Cubase Pro only)
MIDI Processing
MIDI functions vs. MIDI modifiers
What is affected by the MIDI functions?
Transpose
Making your settings permanent
Dissolve Part
Bounce MIDI
Repeat Loop
Other MIDI functions
MIDI Editors
Opening MIDI editors
Changing the Default MIDI Editor
Common MIDI Editor Functions
Key Editor
Key Editor Operations
Basic Score Editor (Cubase Artist only)
Score Editor Operations (Cubase Artist only)
Drum Editor
Drum Editor Operations
List Editor
List Editor Operations
In-Place Editor
SysEx Messages
Expression maps (Cubase Pro only)
Introduction
Using expression maps
Creating and editing expression maps
Note Expression
Introduction
Setting up the Note Expression Inspector tab
Mapping controllers
Recording
Editing Note Expression data
Note Expression and MIDI
HALion Sonic SE
Chord Functions
Chord Track
Chord Events
Scale Events
Voicings
Converting Chord Events to MIDI
Controlling MIDI or Audio Playback using the Chord Track
Assigning Voices to Notes
Extracting Chord Events from MIDI
Recording Chord Events with a MIDI Keyboard
<table>
<thead>
<tr>
<th>Page</th>
<th>Section</th>
</tr>
</thead>
<tbody>
<tr>
<td>836</td>
<td>Chord Pads</td>
</tr>
<tr>
<td>836</td>
<td>Chord Pads Zone</td>
</tr>
<tr>
<td>840</td>
<td>Functions Menu</td>
</tr>
<tr>
<td>841</td>
<td>Preparations</td>
</tr>
<tr>
<td>841</td>
<td>Chord Assistant</td>
</tr>
<tr>
<td>844</td>
<td>Assigning Chords to Chord Pads</td>
</tr>
<tr>
<td>848</td>
<td>Moving and Copying Chord Pads</td>
</tr>
<tr>
<td>848</td>
<td>Playing Back and Recording Chords</td>
</tr>
<tr>
<td>850</td>
<td>Chord Pad Settings – Remote Control</td>
</tr>
<tr>
<td>853</td>
<td>Chord Pad Settings – Players</td>
</tr>
<tr>
<td>856</td>
<td>Chord Pad Settings – Pad Layout</td>
</tr>
<tr>
<td>857</td>
<td>Chord Pads Presets</td>
</tr>
<tr>
<td>858</td>
<td>Creating Events from Chord Pads</td>
</tr>
<tr>
<td>859</td>
<td>The Logical Editor, Transformer, and Input Transformer</td>
</tr>
<tr>
<td>859</td>
<td>Introduction</td>
</tr>
<tr>
<td>860</td>
<td>Opening the Logical Editor</td>
</tr>
<tr>
<td>861</td>
<td>Window overview</td>
</tr>
<tr>
<td>861</td>
<td>Setting up filter conditions</td>
</tr>
<tr>
<td>872</td>
<td>Selecting a function</td>
</tr>
<tr>
<td>873</td>
<td>Specifying actions</td>
</tr>
<tr>
<td>877</td>
<td>Applying the defined actions</td>
</tr>
<tr>
<td>877</td>
<td>Working with presets</td>
</tr>
<tr>
<td>878</td>
<td>The Input Transformer</td>
</tr>
<tr>
<td>881</td>
<td>Project Logical Editor (Cubase Pro only)</td>
</tr>
<tr>
<td>882</td>
<td>Opening the Project Logical Editor</td>
</tr>
<tr>
<td>882</td>
<td>Window overview</td>
</tr>
<tr>
<td>883</td>
<td>Setting up filter conditions</td>
</tr>
<tr>
<td>893</td>
<td>Specifying actions</td>
</tr>
<tr>
<td>896</td>
<td>Selecting a function</td>
</tr>
<tr>
<td>897</td>
<td>Applying Macros</td>
</tr>
<tr>
<td>897</td>
<td>Applying the defined actions</td>
</tr>
<tr>
<td>898</td>
<td>Working with presets</td>
</tr>
<tr>
<td>900</td>
<td>Editing tempo and signature</td>
</tr>
<tr>
<td>900</td>
<td>Background</td>
</tr>
<tr>
<td>901</td>
<td>Tempo and signature display</td>
</tr>
<tr>
<td>904</td>
<td>Editing tempo and signature</td>
</tr>
<tr>
<td>908</td>
<td>Process Tempo (Cubase Pro only)</td>
</tr>
<tr>
<td>909</td>
<td>The Process Bars dialog (Cubase Pro only)</td>
</tr>
<tr>
<td>911</td>
<td>The Beat Calculator</td>
</tr>
<tr>
<td>912</td>
<td>Merge Tempo From Tapping (Cubase Pro only)</td>
</tr>
<tr>
<td>913</td>
<td>The Time Warp tool (Cubase Pro only)</td>
</tr>
<tr>
<td>920</td>
<td>Tempo Detection (Cubase Pro only)</td>
</tr>
<tr>
<td>925</td>
<td>Adjusting the audio to the project tempo</td>
</tr>
<tr>
<td>926</td>
<td>Project Browser (Cubase Pro only)</td>
</tr>
<tr>
<td>926</td>
<td>Window Overview</td>
</tr>
<tr>
<td>928</td>
<td>Editing tracks</td>
</tr>
<tr>
<td>938</td>
<td>Export Audio Mixdown</td>
</tr>
<tr>
<td>938</td>
<td>Introduction</td>
</tr>
<tr>
<td>939</td>
<td>Mixing down to audio files</td>
</tr>
<tr>
<td>941</td>
<td>The Export Audio Mixdown dialog</td>
</tr>
<tr>
<td>946</td>
<td>The available file formats</td>
</tr>
<tr>
<td>954</td>
<td>Synchronization</td>
</tr>
<tr>
<td>954</td>
<td>Background</td>
</tr>
<tr>
<td>955</td>
<td>Timecode (positional references)</td>
</tr>
<tr>
<td>957</td>
<td>Clock sources (speed references)</td>
</tr>
<tr>
<td>958</td>
<td>The Project Synchronization Setup dialog</td>
</tr>
<tr>
<td>964</td>
<td>Synchronized operation</td>
</tr>
<tr>
<td>965</td>
<td>Example Scenarios (Cubase Pro only)</td>
</tr>
<tr>
<td>966</td>
<td>Working with VST System Link</td>
</tr>
<tr>
<td>971</td>
<td>Activating VST System Link</td>
</tr>
<tr>
<td>980</td>
<td>Video</td>
</tr>
<tr>
<td>980</td>
<td>Before You Start</td>
</tr>
<tr>
<td>983</td>
<td>Preparing a Video Project</td>
</tr>
<tr>
<td>986</td>
<td>Playing Back Video</td>
</tr>
<tr>
<td>990</td>
<td>Editing Video</td>
</tr>
<tr>
<td>990</td>
<td>Extracting Audio From a Video File</td>
</tr>
<tr>
<td>991</td>
<td>Replacing the Audio in a Video File</td>
</tr>
<tr>
<td>992</td>
<td>ReWire</td>
</tr>
<tr>
<td>992</td>
<td>Introduction</td>
</tr>
<tr>
<td>993</td>
<td>Launching and quitting</td>
</tr>
<tr>
<td>994</td>
<td>Activating ReWire channels</td>
</tr>
<tr>
<td>994</td>
<td>Using the transport and tempo controls</td>
</tr>
<tr>
<td>996</td>
<td>How the ReWire channels are handled</td>
</tr>
<tr>
<td>996</td>
<td>Routing MIDI via ReWire</td>
</tr>
<tr>
<td>996</td>
<td>Considerations and limitations</td>
</tr>
<tr>
<td>997</td>
<td>Key Commands</td>
</tr>
<tr>
<td>997</td>
<td>Introduction</td>
</tr>
<tr>
<td>998</td>
<td>Setting up key commands</td>
</tr>
<tr>
<td>1003</td>
<td>Setting up tool modifier keys</td>
</tr>
<tr>
<td>1003</td>
<td>The default key commands</td>
</tr>
<tr>
<td>1012</td>
<td>File handling</td>
</tr>
<tr>
<td>1012</td>
<td>Importing audio</td>
</tr>
<tr>
<td>1018</td>
<td>Exporting and importing OMF files (Cubase Pro only)</td>
</tr>
<tr>
<td>1021</td>
<td>Exporting and importing standard MIDI files</td>
</tr>
<tr>
<td>1025</td>
<td>Exporting and importing MIDI loops</td>
</tr>
<tr>
<td>1026</td>
<td>Exporting and importing track archives (Cubase Pro only)</td>
</tr>
<tr>
<td>1028</td>
<td>Customizing</td>
</tr>
<tr>
<td>1028</td>
<td>Workspaces</td>
</tr>
<tr>
<td>1032</td>
<td>Using the Setup options</td>
</tr>
<tr>
<td>1034</td>
<td>Appearance</td>
</tr>
<tr>
<td>1038</td>
<td>Applying colors in the Project window</td>
</tr>
<tr>
<td>1042</td>
<td>Where are the settings stored?</td>
</tr>
<tr>
<td>1045</td>
<td>Optimizing</td>
</tr>
<tr>
<td>1045</td>
<td>Optimizing Audio Performance</td>
</tr>
</tbody>
</table>
1051 Preferences
1051 Preferences Dialog
1053 Appearance
1054 Editing
1063 Event Display
1067 General
1068 MIDI
1073 MediaBay
1074 Metering
1075 Record
1077 Scores (Cubase Pro only)
1080 Transport
1082 VST
1086 VariAudio (Cubase Pro only)
1087 Video
1088 Part II - Score Layout and Printing (Cubase Pro only)
1089 How the Score Editor works
1089 About this chapter
1089 Welcome!
1089 How the Score Editor operates
1090 MIDI notes vs. score notes
1090 Display Quantize
1094 Entering notes by hand vs. recording notes
1095 The basics
1095 About this chapter
1095 Preparations
1096 Opening the Score Editor
1097 The project cursor
1097 Playing back and recording
1097 Page Mode
1099 Changing the zoom factor
1100 The active staff
1100 Making page setup settings
1101 Designing your work space
1105 About the Score Editor context menus
1105 About dialogs in the Score Editor
1106 Setting clef, key, and time signature
1114 Transposing instruments
1115 Printing from the Score Editor
1116 Exporting pages as image files
1117 Working order
1118 Force update

1119 Transcribing MIDI recordings
1119 About this chapter
1119 About transcription
1119 Getting the parts ready
1120 Preparing parts for score printout
1121 Staff settings
1121 Situations which require additional techniques
1122 Inserting Display Quantize changes
1124 The Explode function
1125 Using "Scores Notes To MIDI"

1127 Entering and editing notes
1127 About this chapter
1127 Score settings
1129 Note values and positions
1132 Adding and editing notes
1135 Selecting notes
1137 Moving notes
1140 Duplicating notes
1140 Cut, copy, and paste
1141 Editing pitches of individual notes
1143 Changing the length of notes
1145 Splitting a note in two
1145 Working with the Display Quantize tool
1146 Split (piano) staves
1147 Strategies: Multiple staves
1148 Inserting and editing clefs, keys, or time signatures
1150 Deleting notes

1152 Staff settings
1152 About this chapter
1152 Staff settings
1153 Making settings
1153 Working with staff presets
1154 Staff names
1155 Key and clef
1155 Display Quantize and Interpretation Options
1159 Display Transpose
1160 The Options tab
1162 The Polyphonic tab
1162 The Tablature tab
About this chapter
Background: Polyphonic voicing
Setting up the voices
Strategies: How many voices do I need?
Entering notes into voices
Checking which voice a note belongs to
Moving notes between voices
Handling rests
Voices and Display Quantize
Automatic polyphonic voicing – Merge All Staves
Converting voices to tracks – Extract Voices

Additional note and rest formatting
Setting stem direction
Stem length
Changing the note head shape
Other note details
Coloring notes
Copying settings between notes
Handling beaming
About tied notes
Graphic moving of notes
Cue notes
Grace notes
Tuplets

Working with symbols
About this chapter
Background: The different layers
The Symbols Inspector
Important! – Symbols, staves, and voices
Adding symbols to the score
Selecting symbols
Moving and duplicating symbols
Changing length, size, and shape
Deleting symbols
Copy and paste
Alignment
Symbol details

Working with chords
About this chapter
Inserting chord symbols
Global chord settings

Working with text
About this chapter
Adding and editing text symbols
Different types of text
Text functions

Working with layouts
About this chapter
Background: Layouts
Creating a layout
Opening a layout
Layout operations
Using layouts – an example
Marker Track to Form

Working with MusicXML
Introduction
Importing and exporting MusicXML files

Designing your score: additional techniques
About this chapter
Layout settings
Staff size
Hiding/showing objects
Coloring notes
Multiple rests
Editing existing bar lines
Creating upbeats
Setting the number of bars across the page
Moving bar lines
Dragging staves
Adding brackets and braces
Displaying the Chord Symbols from the Chord Track
Auto Layout
Reset Layout
Breaking bar lines

Scoring for drums
About this chapter
Background: Drum maps in the Score Editor
Setting up the drum map
Setting up a staff for drum scoring
Entering and editing notes
Using “Single Line Drum Staff”

Creating tablature
About this chapter
Creating tablature automatically
Creating tablature manually
Tablature number appearance
Editing
Note head shape
Introduction

About the Program Versions

The documentation covers two different operating systems, Windows and Mac OS X. Some features and settings are specific to one of the platforms.

This is clearly stated in the applicable cases. If nothing else is said, all descriptions and procedures in the documentation are valid for both Windows and Mac OS X.

The screenshots are taken from the Windows version of Cubase.

Typographical Conventions

Many of the default key commands in Cubase use modifier keys, some of which are different depending on the operating system. For example, the default key command for Undo is [Ctrl]-[Z] on Windows and [Command]-[Z] on Mac OS X.

When key commands with modifier keys are described in this manual, they are shown with the Windows modifier key first, in the following way:

- [Win modifier key]/[Mac modifier key]-[key]

For example, [Ctrl]/[Command]-[Z] means “press [Ctrl] on Windows or [Command] on Mac OS X, then press [Z]”.

Similarly, [Alt]/[Option]-[X] means “press [Alt] on Windows or [Option] on Mac OS X, then press [X]”.

NOTE

This manual often refers to right-clicking, for example, to open context menus. If you are using a Mac with a single-button mouse, hold down [Ctrl] and click.
Part I - Getting into the Details
Setting Up Your System

Setting Up Audio

IMPORTANT
Make sure that all equipment is turned off before making any connections.

Simple Stereo Input and Output Setup

If you only use a stereo input and output from Cubase, you can connect your audio hardware, for example, the inputs of your audio card or your audio interface, directly to the input source and the outputs to a power amplifier and speaker.

Once you have set up the internal input and output busses, you can connect your audio source, for example a microphone, to your audio interface and start recording.

Connecting Audio

Your system setup depends on many different factors, for example, on the kind of project that you want to create, on the external equipment that you want to use, or on the computer hardware that is available to you. Therefore, the following sections can only serve as examples.

How to connect your equipment, that is, whether to use digital or analog connections also depends on your setup.
About Recording Levels and Inputs

When you connect your equipment, make sure that the impedance and levels of the audio sources and inputs are matched. Using the correct type of input is important to avoid distortion or noisy recordings. For microphones, for example, different inputs can be used, such as consumer line level (-10 dBV) or professional line level (+4 dBV).

Sometimes, you can adjust input characteristics on the audio interface or on its control panel. For details, refer to the documentation that came with the audio hardware.

IMPORTANT

Cubase does not provide any input level adjustments for the signals that are coming into your audio hardware, since these are handled differently for each card. Adjusting input levels is either done in a special application that is included with the hardware or its control panel.

Word Clock Connections

If you are using a digital audio connection, you may also need a word clock connection between the audio hardware and external devices. For details, refer to the documentation that came with the audio hardware.

IMPORTANT

Set up word clock synchronization correctly, or you may experience clicks and crackles in your recordings.

Selecting a Driver

You must select the correct driver in Cubase to make sure that the program can communicate with the audio hardware.

NOTE

On Windows operating systems, we recommend that you access your hardware via an ASIO driver developed specifically for the hardware. If no ASIO driver is installed, refer to your audio hardware manufacturer about available ASIO driver. You can use the Generic Low Latency ASIO driver if no specific ASIO driver is available.

When you start Cubase, a dialog opens that prompts you to select a driver. You can also select your audio hardware driver in the following way.

PROCEDURE
1. Launch Cubase and select Devices > Devices Setup.
2. In the devices list, select VST Audio System.
3. On the ASIO Driver menu, select your audio hardware driver. The selected driver is added to the devices list.

4. In the devices list, select the driver to open the driver settings for your audio hardware.

5. Open the control panel for the audio hardware in the following way:
   • On Windows operating systems, click the Control Panel button.
   • On Mac OS X operating systems, click the Open Config App button.
   This button is available only for some hardware products. If it is not available in your setup, refer to the documentation of your audio hardware for information on where to make hardware settings.

   **NOTE**
   The control panel is provided by the audio hardware manufacturer and is different for each audio card brand and model. However, control panels for the ASIO DirectX driver and the Generic Low Latency ASIO Driver (Windows only) are provided by Steinberg.

6. Make the settings as recommended by the audio hardware manufacturer.

7. Click **Apply**.

8. Click **OK**.

**RELATED LINKS**
Using Audio Hardware with a DirectX Driver (Windows only) on page 15

**Using Audio Hardware with a DirectX Driver (Windows only)**

A DirectX driver is an alternative to a specific ASIO driver and the Generic Low Latency ASIO driver.

Cubase comes with the ASIO DirectX Full Duplex driver.

• To select the driver, select Devices > Device Setup > VST Audio System and open the ASIO Driver menu.

When the ASIO DirectX Full Duplex driver is selected, you can open ASIO DirectX Full Duplex Driver from the Devices List, and click Control Panel button. On the Control Panel for the driver, the following settings are available:

**Direct Sound Output and Input Ports**
Lists all available Direct Sound output and input ports. To activate/deactivate a port in the list, click the checkbox in the left column.

**Buffer Size**
Allows you to edit the buffer size. Audio buffers are used when audio data is transferred between Cubase and the audio card. Larger buffers ensure that playback occurs without glitches, but larger buffers also increase the latency.

**Offset**
Allows you to adjust the output or input latency time, if a constant offset is audible during playback of audio and MIDI recordings.
Audio Channels
Lists the available audio channels.

Bits Per Sample
Shows the number of bits per sample.

Sync Reference
Shows if the driver is used as sync reference.

NOTE
To take advantage of DirectX Full Duplex driver, the audio hardware must support Windows Driver Model (WDM).

Using Hardware that is Based on an External Clock Source
For proper audio playback and recording, you must set the sample rate of the project to the sample rate of the incoming clock signals. If you are using an external clock source, Cubase must be notified that it receives external clock signals and derives its speed from that source.

PROCEDURE
2. In the devices list, select the page of your audio hardware driver.
3. Activate Externally clocked.

RESULT
Cubase accepts the sample rate mismatch, and playback is therefore faster or slower.

When a sample rate mismatch occurs, the Record Format field on the status line is highlighted in a different color.

Using Several Audio Applications Simultaneously
If you want to use several audio applications simultaneously, you must allow other applications to play back via your audio hardware even though Cubase is running.

PROCEDURE
2. In the devices list, select the VST Audio System page.
3. Activate Release Driver when Application is in Background.

RESULT
The application that is currently active gets access to the audio hardware.
NOTE

Make sure that any other audio application accessing the audio hardware is also set to release the ASIO or Mac OS X driver.

Setting Up Busses

Cubase uses a system of input and output busses to transfer audio between the program and the audio hardware.

- Input busses let you route audio from the inputs of your audio hardware into Cubase. This means that audio is always recorded through one or several input busses.
- Output busses let you route audio from Cubase to the outputs of your audio hardware. This means that audio is always played back through one or several output busses.

Once you understand the bus system and know how to set up the busses properly, you can continue with recording, playing back, mixing, and doing surround work (Cubase Pro only).

RELATED LINKS

VST Connections on page 22

Configuring the Audio Hardware

Most audio cards provide one or more small applications that allow you to customize your hardware.

This includes:

- Selecting which inputs/outputs are active.
- Setting up word clock synchronization (if available).
- Turning on/off monitoring via the hardware.
- Setting levels for each input.
- Setting levels for the outputs so that they match the equipment that you use for monitoring.
- Selecting digital input and output formats.
- Making settings for the audio buffers.

In most cases, the settings for the audio hardware are gathered on a control panel that can be opened from within Cubase or separately, when Cubase is not running. For details, refer to the audio hardware documentation.
Plug and Play Support for ASIO Devices

The Steinberg UR824 hardware series supports plug and play in Cubase. These devices can be plugged in and switched on while the application is running. Cubase automatically uses the driver of the UR824 series and re-maps the VST connections accordingly.

Steinberg cannot guarantee that this works with other hardware. If you are unsure of whether your device supports plug and play, refer to the documentation of your device.

<table>
<thead>
<tr>
<th>IMPORTANT</th>
</tr>
</thead>
<tbody>
<tr>
<td>If a device that does not support plug and play is connected or disconnected while the computer is running, it can get damaged.</td>
</tr>
</tbody>
</table>

Setting Up the Input and Output Ports

Once you have selected the driver for your audio hardware and have set it up, you must specify which inputs and outputs to use.

<table>
<thead>
<tr>
<th>PROCEDURE</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Select Devices &gt; Device Setup.</td>
</tr>
<tr>
<td>2. In the Device Setup dialog, select your driver from the Devices list on the left.</td>
</tr>
<tr>
<td>3. Make your settings.</td>
</tr>
<tr>
<td>4. Optional: To hide a port, click its Visible column.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>IMPORTANT</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hiding a port disconnects it.</td>
</tr>
</tbody>
</table>

Ports that are not visible cannot be selected in the VST Connections window where you set up your input and output busses.

5. Optional: To rename a port, click its name in the Show as column and type in a new name.

6. Click OK.

About Monitoring

In Cubase, monitoring means listening to the input signal while preparing to record or while recording.

The following ways of monitoring are available.

- Externally by listening to the signal before it reaches Cubase.
- Via Cubase.
- By using ASIO Direct Monitoring.

This is a combination of the other methods.
Setting Up MIDI

**IMPORTANT**

Turn off all equipment before making any connections.

**PROCEDURE**

1. Connect your MIDI equipment (keyboard, MIDI interface, etc.) to your computer.
2. Install the drivers for your MIDI equipment.

**RESULT**

You can use your MIDI equipment in Cubase.

### About MIDI Ports

To play back and record MIDI data from your MIDI device, for example, a MIDI keyboard, you need to set up the MIDI ports in Cubase.

Connect the MIDI output port of your MIDI device to the MIDI input port of your computer. This way, the MIDI device sends MIDI data to be played back or recorded inside your computer.

Connect the MIDI input port of your MIDI device to the MIDI output port of your computer. This way, you can send MIDI data from Cubase to the MIDI device. For example, you can record your own playing, edit the MIDI data in Cubase, and then play it back on the keyboard and record the audio that is coming out of the keyboard for a better edited performance.

### Showing or Hiding MIDI Ports

You can specify if a MIDI port is listed on the MIDI pop-up menus in the program.

**PROCEDURE**

1. Select **Devices > Device Setup**.
2. In the **Device Setup** dialog, select **MIDI Port Setup** from the **Devices** list on the left.
3. To hide a MIDI port, deactivate its **Visible** column.
4. Click **OK**.
Setting Up All MIDI Inputs

When you record MIDI, you can specify which MIDI input each recording MIDI track should use. However, you can also record any MIDI data from any MIDI input. You can specify which inputs are included when you select All MIDI Inputs for a MIDI track.

**PROCEDURE**

1. Select Devices > Device Setup.
2. In the Device Setup dialog, select MIDI Port Setup from the Devices list on the left.
3. Activate In ‘All MIDI Inputs’ for a port.

**NOTE**

If you have a MIDI remote control unit connected, make sure to deactivate the In ‘All MIDI Inputs’ option for that MIDI input. This avoids accidental recording of data from the remote control when All MIDI Inputs is selected as input for a MIDI track.

4. Click OK.

**RESULT**

When you select All MIDI Inputs on the Input Routing menu of a MIDI track in the Inspector, the MIDI track uses all MIDI inputs that you specified in the Device Setup dialog.

Connecting a Synchronizer

When using Cubase with external tape transports, you most likely must add a synchronizer to your system.

**IMPORTANT**

Make sure that all equipment is turned off before making any connections.

For information on how to connect and set up your synchronizer, refer to the documentation of your synchronizer.

**RELATED LINKS**

Synchronization on page 954
Cubase plays back video files in a number of formats, such as AVI, QuickTime, or MPEG. QuickTime is used as the playback engine. Which formats can be played back depends on the video codecs that are installed on your system.

There are several ways to play back video, for example, without any special hardware, using a FireWire port, or using dedicated video cards.

If you plan to use special video hardware, install it and set it up as recommended by the manufacturer.

**NOTE**

Before you use the video hardware with Cubase, we recommend that you test the hardware installation with the utility applications that were provided with the hardware and/or the QuickTime Player application.

**RELATED LINKS**
- Video on page 980
- Video Output Devices on page 982
VST Connections

To play back and record in Cubase, you must set up input and output busses in the VST Connections window. Here, you can also set up group and FX channels, external effects, external instruments, and the Control Room (Cubase Pro only).

The bus types that you need depend on your audio hardware, on your general audio setup, for example your surround speaker setup, and on the projects that you use.

VST Connections Window

The VST Connections window allows you to set up input and output busses, group and FX channels, external effects, and external instruments. Furthermore, you can use this window to access and configure the Control Room (Cubase Pro only).

- To open the VST Connections window, select Devices > VST Connections.

Inputs/Outputs Tab

The Input and Output tabs allow you to set up and configure input and output busses.

The following options are available above the bus list:

+- All

  Expands/Collapses all busses in the bus list.

Add Bus

  Opens the Add Input Bus dialog, where you can create a new bus configuration.
VST Connections
VST Connections Window

Presets

Opens the Presets menu, where you can select bus configuration presets. The Store button allows you to save a bus configuration as preset. The Delete button deletes the selected preset.

The following columns are available for the bus list:

Bus Name

Lists the busses. Click the name of a bus to select or rename it.

Speakers

Indicates the speaker configuration (mono, stereo, surround formats (Cubase Pro only)) of each bus.

Audio Device

Shows the currently selected ASIO driver.

Device Port

Shows which physical inputs/outputs on your audio hardware are used by the bus. Expand the bus entry to show all speaker channels. If the bus entry is collapsed, only the first port that is used by this bus is visible.

The Device Port pop-up menu displays how many busses are connected to a given port. The busses are shown in square brackets next to the port name.

Up to three bus assignments can be displayed in this way. If more connections have been made, this is indicated by a number at the end of the port name.

For example, “Adat 1 [Stereo1] [Stereo2] [Stereo3] (+2)” means that the Adat 1 port is already assigned to three stereo busses plus two additional busses.

Click (Outputs tab only)

You can route the metronome click to a specific output bus, regardless of the actual Control Room output, or even when the Control Room is disabled.

Group/FX Tab

This tab allows you to create group and FX channels/tracks and to make output assignments for these.

The following options are available above the bus list:
VST Connections Window

24

+- All
   Expands/Collapses all busses in the bus list.

Add Group
   Opens the Add Group Channel Track dialog, where you can create a new group channel track.

Add FX
   Opens the Add FX Channel Track dialog, where you can create a new FX channel track.

The following columns are available for the bus list:

Bus Name
   Lists the busses. Click the name of a bus to select or rename it.

Speakers
   Indicates the speaker configuration (mono, stereo, surround formats (Cubase Pro only)) of each bus.

Output Routing
   Lets you select the output routing for the corresponding bus.

External FX Tab (Cubase Pro only)

This tab allows you to create send effect or return busses. You can use these to connect external effects which can then be selected via the effect pop-up menus from inside the program.

The following options are available above the bus list:

+- All
   Expands/Collapses all busses in the bus list.

Add External FX
   Opens the Add External FX dialog, where you can configure a new external FX.

Favorites
   Lets you store external effect configurations as favorites that you can recall.

The following columns are available for the bus list:
**Bus Name**

Lists the busses. Click the name of a bus to select or rename it.

**Speakers**

Indicates the speaker configuration (mono, stereo, surround formats (Cubase Pro only)) of each bus.

**Audio Device**

Shows the currently selected ASIO driver.

**Device Port**

Shows which physical inputs/outputs on your audio hardware are used by the bus. Expand the bus entry to show all speaker channels. If the bus entry is collapsed, only the first port that is used by this bus is visible.

The **Device Port** pop-up menu displays how many busses are connected to a given port. The busses are shown in square brackets next to the port name. Up to three bus assignments can be displayed in this way. If more connections have been made, this is indicated by a number at the end of the port name.

For example, “Adat 1 [Stereo1] [Stereo2] [Stereo3] (+2)” means that the Adat 1 port is already assigned to three stereo busses plus two additional busses.

**Delay**

Allows you to enter a value to compensate for an inherent delay (latency) of your hardware effect device during playback. You can right-click the **Delay** column for the effect and select **Check User Delay** to automatically determine the delay value.

**NOTE**

The latency of the audio hardware is handled automatically by Cubase.

**Send Gain**

Allows you to adjust the level of the signal that is sent to the external effect.

**Return Gain**

Allows you to adjust the level of the signal that the external effect sends.

**NOTE**

Excessive output levels from an external effect device can cause clipping in the audio hardware. You cannot use the **Return Gain** setting to compensate for this. You must lower the output level on the effect device instead.

**MIDI Device**

When you click in this column, a pop-up menu opens where you can disconnect the effect from the associated MIDI device, select a MIDI device, create a new device, or open the **MIDI Device Manager** to edit the MIDI device.
Used

Whenever you insert an external effect into an audio track, this column shows a checkmark (x) to indicate that the effect is being used.

External Instruments Tab (Cubase Pro only)

This tab allows you to create input/output busses that can be used to connect external instruments.

The following options are available above the bus list:

+- All
  Expands/Collapses all busses in the bus list.

Add External Instrument
  Opens the Add External Instrument dialog, where you can configure a new external instrument.

Favorites
  Lets you store external instrument configurations as favorites that you can recall.

The following columns are available for the bus list:

Bus Name
  Lists the busses. Click the name of a bus to select or rename it.

Speakers
  Indicates the speaker configuration (mono, stereo, surround formats (Cubase Pro only)) of each bus.

Audio Device
  Shows the currently selected ASIO driver.

Device Port
  Shows which physical inputs/outputs on your audio hardware are used by the bus. Expand the bus entry to show all speaker channels. If the bus entry is collapsed, only the first port that is used by this bus is visible.

The Device Port pop-up menu displays how many busses are connected to a given port. The busses are shown in square brackets next to the port name.
Up to three bus assignments can be displayed in this way. If more connections have been made, this is indicated by a number at the end of the port name.

For example, “Adat 1 [Stereo1] [Stereo2] [Stereo3] (+2)” means that the Adat 1 port is already assigned to three stereo busses plus two additional busses.

**Delay**

Allows you to enter a value to compensate for an inherent delay (latency) of your hardware effect device during playback. You can right-click the Delay column for the instrument and select **Check User Delay** to automatically determine the delay value that is used for delay compensation.

**NOTE**

The latency of the audio hardware is handled automatically by Cubase.

**Return Gain**

Allows you to adjust the level of the signal coming in from the external instrument.

**NOTE**

Excessive output levels from an external effect device can cause clipping in the audio hardware. The Return Gain setting cannot be used to compensate for this. You must lower the output level on the effect device instead.

**MIDI Device**

When you click in this column, a pop-up menu opens where you can disconnect the instrument from the associated MIDI device, select a MIDI device, create a new device, or open the **MIDI Device Manager** to edit the MIDI device.

**Used**

Whenever you insert the external instrument into a VST instrument slot, this column shows a checkmark (x) to indicate that the instrument is being used.

### Studio Tab (Cubase Pro only)

This tab allows you to enable and configure the **Control Room**.

The following options are available above the bus list:
VST Connections
VST Connections Window

+- All
   Expands/Collapses all busses in the bus list.

Add Channel
   Opens a menu where you can select the type of channel that you want to add.
   You can add the following channels:
   • External Input
   • Talkback
   • Cue
   • Headphone
   • Monitor

Presets
   Opens the Presets menu, where you can select bus configuration presets.
   The Store button allows you to save a bus configuration as preset. The Delete button deletes the selected preset.

Control Room
   Activates/Deactivates the Control Room.

Control Room Mixer
   Opens the Control Room Mixer window, where you can set up the Control Room.

Configuration
   Displays the selected channel configuration.

The following columns are available for the bus list:

Bus Name
   Lists the busses. Click the name of a bus to select or rename it.

Speakers
   Indicates the speaker configuration (mono, stereo, surround formats (Cubase Pro only)) of each bus.

Audio Device
   Shows the currently selected ASIO driver.

Device Port
   Shows which physical inputs/outputs on your audio hardware are used by the bus. Expand the bus entry to show all speaker channels. If the bus entry is collapsed, only the first port that is used by this bus is visible.
   The Device Port pop-up menu displays how many busses are connected to a given port. The busses are shown in square brackets next to the port name.
   Up to three bus assignments can be displayed in this way. If more connections have been made, this is indicated by a number at the end of the port name.
For example, “Adat 1 [Stereo1] [Stereo2] [Stereo3] (+2)” means that the Adat 1 port is already assigned to three stereo busses plus two additional busses.

**RELATED LINKS**

- Control Room (Cubase Pro only) on page 352

## Renaming the Hardware Inputs and Outputs

Before you set up busses, you should rename the default inputs and outputs of your audio hardware. This allows transferring projects between different computers and setups.

For example, if you move your project to another studio, the audio hardware may be of a different model. But if you and the other studio owner have agreed on identical names for your inputs and outputs, Cubase corrects inputs and outputs for your busses.

**NOTE**

If you open a project that was created on another computer and the port names do not match or the port configuration is not the same, the Missing Ports dialog appears. This allows you to manually re-route ports that are used in the project to ports that are available on your computer.

**PROCEDURE**

1. Select **Devices > Device Setup**.
2. On the **VST Audio System** page, make sure that the correct driver for your audio hardware is selected.
   
   If this is the case, your audio card is listed in the **Devices** list on the left of the **Device Setup** window.

3. In the devices list, select your audio card.
   
   The available input and output ports on your audio hardware are listed on the right.

4. In the **Show As** column, click on a port name and enter a new name.

5. Repeat the previous step until you have renamed all required ports.

6. Click **OK**.

**RELATED LINKS**

- Re-Routing Missing Ports on page 76
Hiding Ports

You can hide ports that you are not using. Hidden ports are not displayed in the VST Connections window.

**PROCEDURE**
1. Select **Devices > Device Setup**.
2. In the devices list, select your audio card.
3. In the **Visible** column, deactivate the ports that you want to hide.
4. Click **OK**.

Activating and Deactivating Ports (Mac only)

On Mac operating systems, you can specify which input and output ports are active. This allows you to use the microphone input instead of the line input or to deactivate the audio card input or output.

**NOTE**
This function is only available for built-in audio, standard USB audio devices, and a certain number of other audio cards.

**PROCEDURE**
1. Select **Devices > Device Setup**.
2. In the devices list, select your audio card.
3. Click the **Control Panel** button.
5. Click **OK**.

Adding Input and Output Busses

**PROCEDURE**
1. In the **VST Connections** dialog, click the **Inputs** or **Outputs** tab.
2. Click **Add Bus**.
   The **Add Input Bus** dialog opens.
3. Configure the bus.
4. Optional: Enter a name for the bus.
   If you do not specify a name, the bus is named according to the channel configuration.
5. Click **Add Bus**.  
The new bus is added to the bus list.

6. For each of the speaker channels in the bus, click in the **Device Port** column and select a port of your audio hardware.

---

**Setting the Default Output Bus (Main Mix)**

The **Main Mix** is the default output bus to which each new audio, group, or FX channel is automatically routed. If only one bus is available, this bus is automatically used as the default output bus.

**PREREQUISITE**

Add an output bus.

**PROCEDURE**

1. In the **VST Connections** dialog, right-click the output bus that you want to use as default output bus.
2. Select **Set as Main Mix**.

**RESULT**

The selected bus is used as default bus. The **Main Mix** is indicated by a speaker icon next to its name.

---

**Adding Child Busses (Cubase Pro only)**

Child busses allow you to route tracks to particular channels within a bus.

For example, you can route a stereo track to a stereo channel pair within a surround bus. Or you can record a stereo channel pair in the surround bus to a separate stereo track.

**PROCEDURE**

1. On the **Inputs** tab, **Outputs** tab, or **Group/FX** tab, right-click a surround bus.
2. Click **Add Child Bus** and select a channel configuration.

**RESULT**

The child bus is created and can be used for routing.
Presets for Input and Output Busses

For input and output bus configurations, you can use different kinds of presets.

- A number of standard bus configurations.
- Automatically created presets tailored to your specific hardware configuration.
  On startup, Cubase analyzes the physical inputs and outputs that are provided by your audio hardware and creates a number of hardware-dependent presets.
- Your own presets.

Saving a Bus Configuration Preset

You can save your own input and output bus configuration and the studio configuration as presets.

PROCEDURE

1. Select Devices > VST Connections.
2. Set up your bus configuration.
3. Click Store.
   The Type in Preset Name dialog opens.
4. Enter a name.
5. Click OK.

RESULT

The preset is available in the Presets menu.

Deleting a Bus Configuration Preset

PROCEDURE

1. Select Devices > VST Connections.
2. From the Presets menu, select the preset that you want to delete.
3. Click Delete.

RESULT

The preset is deleted.
Adding Group and FX Channels

Group channels and FX channels allow you to group bus configurations.

Adding group and FX channels in the VST Connections window is identical to creating group channel tracks or FX channel tracks in the Project window.

**PROCEDURE**

1. In the VST Connections dialog, click the Group/FX tab.
2. Do one of the following:
   • To create a group channel, click Add Group.
   • To create an FX channel, click Add FX.
3. Configure the channel.
4. Optional: Enter a name for the group channel track.
5. Click Add Track.
   The group channel or FX channel is added to the bus list.
6. For each of the speaker channels in the bus, click in the Output Routing column and select a port of your audio hardware.

**RELATED LINKS**

Audio Effects on page 372

About Monitoring

In the VST Connections window, you can set up the busses that are used for monitoring, activate/deactivate the Control Room, and open the Control Room Mixer.

When the Control Room is disabled on the Studio tab of the VST Connections window, the Main Mix bus is used for monitoring. In this case, you can adjust the monitoring level in the MixConsole.

In Cubase Artist, the Main Mix bus is always used for monitoring.

**RELATED LINKS**

Control Room (Cubase Pro only) on page 352
MixConsole on page 291

External Instruments and Effects (Cubase Pro only)

You can integrate external effect devices and external instruments, for example, hardware synthesizers, into the sequencer signal flow.
Requirements

- To use external effects, you need audio hardware with multiple inputs and outputs. An external effect requires at least one input and one output or input/output pairs for stereo effects in addition to the input/output ports that you use for recording and monitoring.
- To use external instruments, a MIDI interface must be connected to your computer.
- Audio hardware with low-latency drivers. Cubase compensates for the input/output latency and ensures that the audio that is processed through external effects is not shifted in time.

Connecting an External Instrument/Effect

**Prerequisite**

The hardware device has stereo inputs and outputs.

**Procedure**

1. Connect an unused output pair on your audio hardware to the input pair on your external hardware device.
2. Connect an unused input pair on your audio hardware to the output pair on your hardware device.

**Important**

If you select input/output ports for external instruments/effects that are already used, the existing port assignment breaks without warning.

**After Completing This Task**

Once the external device is connected to the audio hardware of your computer, you must set up the input/output busses in Cubase.

Setting Up External Effects

**Procedure**

1. In the VST Connections window, click the External FX tab.
2. Click Add External FX.
3. In the Add External FX dialog, enter a name for the external effect and specify the send and return configurations. Depending on the type of effect, you can specify mono, stereo, or surround configurations.
4. Click Associate MIDI Device and select a MIDI device.
You can also select **MIDI Devices > Create Device** and create a new MIDI device association.

**NOTE**

Delay compensation is only applied for the effect when you use MIDI devices.

5. Click **OK**.
   This adds a new external FX bus.

6. Click in the **Device Port** column for the left and right ports of the send bus and select the outputs of your audio hardware that you want to use.

7. Click in the **Device Port** column for the left and right ports of the return bus and select the inputs of your audio hardware that you want to use.

8. Make additional settings for the bus.
   You can also adjust the settings while using the external effect. This allows you to hear the result.

**RELATED LINKS**

- Using MIDI devices on page 658
- Delay Compensation on page 609

**Adding External Effects**

You can use the external FX bus as an insert effect or as a send effect, which is an insert effect on an FX channel track.

**PREREQUISITE**

Set up your external effects in the **VST Connections** window.

**PROCEDURE**

1. In the **Inspector**, open the **Inserts** panel.
2. Open the **Select Insert** menu.
3. Select an external effect from the **External Plug-ins** submenu. External effects are indicated by an **x** icon in the list next to their names in the **Select Insert** pop-up menu.

RESULT

The external FX bus is loaded into the effect slot. A parameter window opens, showing the Delay, Send Gain, and Return Gain settings for the external FX bus. You can adjust these settings while playing back. The audio signal from the channel is sent to the outputs on the audio hardware, through your external effect device, and back to the program via the inputs on the audio hardware.

**RELATED LINKS**

[Setting Up External Effects on page 34](#)

**External Effect Parameter Window**

This window allows you to make delay and gain settings for the selected external effect.

When you select an external effect from the **Select Insert** menu in the **Inspector**, the **External Effect Parameter** window opens.

![External Effect Parameter Window](image)

**Activate Effect**

Activates/Deactivates the external effect.

**Bypass Effect**

Allows you to bypass the external effect.

**Measure Effect's Loop Delay for Delay Compensation**

If this option is activated, Cubase automatically determines the delay value that is used for delay compensation. This is the same function as the **Check User Delay** option in the **VST Connections** window.

When you have defined a MIDI device for the effect, the corresponding device window opens.

**Delay**

Allows you to adjust the delay for the external effect.
Send Gain
Allows you to adjust the send gain for the external effect.

Return Gain
Allows you to adjust the return gain for the external effect.

Setting Up External Instruments

PROCEDURE
1. In the VST Connections window, click the External Instruments tab.
2. Click Add External Instrument.
3. In the Add External Instrument dialog, enter a name for the external instrument and specify the number of required mono and/or stereo returns. Depending on the type of instrument, a specific number of mono and/or stereo return channels is required.
4. Click the Associate MIDI Device button and select a MIDI device.
5. Click OK.
   This adds a new external instrument bus.
6. Click in the Device Port column for the left and right ports of the return bus and select the inputs of your audio hardware to which you connected the external instrument.
7. Make additional settings for the bus.
   You can also adjust the settings while using the external instrument. This allows you to hear the result.

RELATED LINKS
Using MIDI devices on page 658

Adding External Instruments

PREREQUISITE
Set up your external instruments in the VST Connections window.

PROCEDURE
1. Select Devices > VST Instruments.
   The VST Instruments window opens.
2. Click Add Track Instrument.
   The Add Instrument Track window opens.
3. Select an external instrument from the Instrument pop-up menu.
   External instruments are indicated by an x icon in the list next to their names in the Instrument pop-up menu.
4. Click Add Track.

RESULT
The external instrument is added to the VST instruments list.

A parameter window for the external instrument opens. This can either be the device window, that allows you to create a generic device panel, an OPT editor window, or a default editor.

External Instruments Parameter Window

This window allows you to make delay and gain settings for the selected external instrument.

When you select an external instrument in the VST Instruments window, the External Instrument Parameter Window opens.

Activate External Instrument
Activates/Deactivates the external instrument.

Bypass External Instrument
Allows you to bypass the external instrument.

Delay
Allows you to adjust the delay for the external instrument.

Return Gain
Allows you to adjust the return gain for the external instrument.
Sending MIDI Notes to External Instruments

**PREREQUISITE**
Set up your external instruments in the **VST Connections** window and add a MIDI track.

**PROCEDURE**
1. In the **Inspector**, open the **Output Routing** pop-up menu for the corresponding MIDI track.
2. Select the MIDI device to which the external instrument is connected.

**RESULT**
The instrument plays any MIDI notes that it receives from the track and returns them to Cubase through the return channels that you have set up. Delay compensation is used.

The external instrument behaves like any other VST instrument in Cubase.

**RELATED LINKS**
- [Delay Compensation on page 609](#)

Saving External Instrument and Effect Configurations as Favorites

You can save external instruments and external effects as favorites. Favorites are device configurations that you can recall. They also allow you to save different configurations for the same device, for example, a multi-effect board or an effect that provides both a mono and a stereo mode.

You can save and restore the favorites in the **External Instruments** and **External FX** tabs of the **VST Connections** window.

- To save an external instrument or effect configuration as a favorite, select the **Bus Name**, click **Favorites**, and select **Add Selected Effect to Favorites**.
- To recall a favorite, click **Favorites** and select the configuration that you want to recall.

Freezing External Instruments/Effects

You can freeze external instruments and effects to save processing power.

**NOTE**
You must perform the freeze function in realtime. Otherwise external effects are not taken into account.
When freezing external instruments or effects, you can adjust the corresponding Tail Size value in the Freeze Channel Options dialog.

When the Tail Size is set to 0s, freezing only takes into account the data within the part boundaries.

**RELATED LINKS**
- VST Instruments on page 599
- Audio Effects on page 372
- Freezing Instruments on page 608
- Freezing Insert Effects for a Track on page 381

### Missing Plug-ins

The “Plug-in could not be found” message appears in the following situations:

- When you remove an external device from the VST Connections window although it is used in a saved project.
- When you transfer a project to another computer on which the external device is not defined.
- When you open a project that is created with an earlier version of Cubase.

In the VST Connections window, the broken connection to the external device is indicated by an icon in the Bus Name column.

- To reestablish the broken connection to the external device, right-click the entry for the device in the Bus Name column and select Connect External Effect.

**NOTE**

Busses that are set up for external instruments or external effects are saved globally, that is, for your particular computer setup.

### Editing the Bus Configurations

After you have set up all the required busses for a project you can edit the names and change port assignments. The bus configuration is saved with the project.
Removing Busses

**PROCEDURE**

- In the **VST Connections** window, right-click a bus in the list and select **Remove Bus**.
- You can also select the bus and press [Backspace].

Changing Port Assignments

You can change the port assignment of busses in the **VST Connection** window.

- To change a port assignment, click in the **Device Port** column of a bus and select a new port.
- To assign different ports to the selected busses, open the **Device Port** pop-up menu for the first selected entry, press [Shift], and select a device port.
  - All subsequent busses are automatically connected to the next available port.

**NOTE**

- Cubase Pro only: Exclusive ports, for example, ports that are already assigned to **Control Room** channels, are skipped.

Renaming Multiple Busses

You can rename all the selected busses at once using incrementing numbers or letters.

- To use incrementing numbers, select the busses that you want to rename and enter a new name for one of the busses, followed by a number.
  - For example, if you have eight inputs that you want to be named “In 1, In 2, …, In 8”, you select all the busses and enter the name **In 1** for the first bus. All other busses are then renamed automatically.
- To use letters from the alphabet, select the busses that you want to rename and enter a new name for one of the busses, followed by a space and a capital letter.
  - For example, if you have three FX channels that you want to be named “FX A, FX B, and FX C”, you select all the channels and enter the name **FX A** for the first. All other channels are renamed automatically. The last letter that can be used is Z. If you have more selected entries than there are letters available, the remaining entries are skipped.
NOTE

You can begin renaming from any position in the list. The renaming starts from the bus where you edit the name, goes down the list to the bottom, and then continues from the top until all selected busses have been renamed.

Identifying Exclusive Port Assignments

For certain channel types, the port assignment is exclusive.

Once a port has been assigned to such a bus or channel, it must not be assigned to another bus, otherwise the connection to the first bus will be broken.

The corresponding ports are marked in red in the VST Connections window on the Device Port pop-up menu.
The **Project** window provides an overview of the project, and allows you to navigate and perform large scale editing.

Each project has one **Project** window. The **Project** window is displayed whenever you open or create a new project.

- To open a project, select **File > Open**.
- To create a new project, select **File > New Project**.

The **Project** window is divided into several sections:

1) **Toolbar**
   Holds tools and shortcuts for opening other windows and various project settings and functions.

2) **Status Line**
   Shows the most important project settings.

3) **Info Line**
   Shows information about the currently selected event or part in the Project window.
4) **Overview Line**  
Shows events and parts as boxes and allows you to zoom and navigate in the project.

5) **Inspector**  
Shows controls and parameters for the first selected track.

6) **Global Track Controls**  
Shows the global track controls.

7) **Track List**  
Shows the track types and their controls.

8) **Ruler**  
Shows the timeline and the display format of the project.

9) **Event Display**  
Shows the parts and events of the project.

10) **Racks**  
Shows the VST Instruments and the MediaBay.

---

**Toolbar**

The toolbar holds tools and shortcuts for opening other windows and various project settings and functions.

- To display all toolbar elements, right-click in an empty area of the toolbar and select **Show All**.

The following options are available:

**Activate Project**  
Allows you to activate a project.

**Set up Window Layout**  
Allows you to show or hide the sections Inspector, status line, info line, and overview line.

**Constrain Delay Compensation**  
Allows you to minimize the latency effects of the delay compensation.
Media & MixConsole Windows
These buttons allow you to open or close the MediaBay, the Pool, the MixConsole, and the Control Room Mixer (Cubase Pro only).

State buttons
These buttons show the mute, solo, listen, and automation states.

Automation Mode
Shows the automation mode and allows you to open the Automation panel. Activate Automation Follows Events if you want your automation events to follow automatically when you move an event or part on a track.

Auto-Scroll
Allows you to activate the Auto-Scroll and Suspend Auto-Scroll when Editing options. These determine if the waveform display is scrolled during playback.

Locators
Shows the left and right locator positions.

Transport Buttons
Shows the transport controls.

Arranger Controls
Shows the controls for the arranger track.

Time Display
Shows the time display.

Markers
Shows the marker buttons.

Tool Buttons
Shows the buttons for editing in the Project window.

Color Menu
Allows you to define the Project window colors.

Nudge Palette
Allows you to nudge or trim events or parts.

Project Root Key
Allows you to change the root key of the project.

Snap to Zero Crossings
If this option is activated, it finds zero crossings when you split and size audio events.

Snap
Allows you to restrict horizontal movement and positioning to certain positions.
Quantize

Allows you to move recorded audio or MIDI to musical relevant positions.

Performance Meter

Shows the meters for ASIO time usage and hard disk transfer load.

Toolbox

The toolbox makes the editing tools from the toolbar available at the mouse pointer position. It can be opened instead of the standard context menus in the event display and editors.

- To activate the toolbox function, select **File > Preferences > Editing > Tools** and activate **Pop-up Toolbox on Right-Click**.
- To open the toolbox, right-click in the event display or editor. If **Pop-up Toolbox on Right-Click** it is deactivated, the context menu opens.
- To open the context menu instead of the toolbox, press any modifier key and right-click in the event display or editor. If **Pop-up Toolbox on Right-Click** is deactivated, press any modifier key to open the toolbox instead of the context menu.
- To change the number of rows in which the tools are arranged on the toolbox, keep the right mouse button pressed on the toolbox until the mouse pointer changes to a double arrow, and drag to the bottom or right.

Status Line

The status line shows the most important project settings.

- To show or hide the status line, click **Set up Window Layout** on the toolbar and activate or deactivate **Status Line**.
The following information is shown in the status line:

**Audio Inputs**
Displays the connection state of your audio inputs. Click in this field to open the *VST Connections* dialog.

**Audio Outputs**
Displays the connection state of your audio outputs. Click in this field to open the *VST Connections* dialog.

**Record Time Max**
Displays the remaining time for recording, depending on your project settings and the available hard disk space. Click in this field to display the remaining record time in a separate window.

**Record Format**
Displays the sample rate and the bit resolution used for recording. Click in this field to open the *Project Setup* dialog.

**Project Frame Rate**
Displays the frame rate used in the project. Click in this field to open the *Project Setup* dialog.

**Project Audio Pull**
Displays the audio pull setting used in the project. Click in this field to open the *Project Setup* dialog.

**Project Pan Law**
Displays the current pan law setting. Click in this field to open the *Project Setup* dialog.

---

**Info Line**

The info line shows information about the currently selected event or part in the *Project* window.

<table>
<thead>
<tr>
<th>Name</th>
<th>Start</th>
<th>End</th>
<th>Length</th>
<th>Offset</th>
<th>Note</th>
<th>Lock</th>
<th>Transpose</th>
<th>Global Transpose</th>
<th>Velocity</th>
<th>Root Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>MIDI 1</td>
<td>1.1.1.0</td>
<td>2.2.1.0</td>
<td>1.1.1.0</td>
<td>0.0.0.0</td>
<td>-</td>
<td>-</td>
<td>0</td>
<td>Follow</td>
<td>0</td>
<td>-</td>
</tr>
</tbody>
</table>

- To show or hide the info line, click the *Set up Window Layout* button on the toolbar and activate or deactivate the *Info Line* option.
Editing in the Info Line

You can edit almost all event or part data on the info line using regular value editing. If you select several events or parts, the info line is shown in another color and only the information about the first item in the selection is displayed. The following rules apply:

• Value changes are applied to all selected elements, relatively to the current values.
  For example, you have selected two audio events. The first event has a length of 1 bar, the second of 2 bars. If you change the info line value to 3, the first event is resized to 3 bars and the second event to 4 bars.

• Value changes are applied absolutely to the current values, if you press [Ctrl]/[Command] while modifying the value on the info line.
  In the example above, both events are resized to 3 bars.

• To change the modifier, select File > Preferences > Editing > Tool Modifiers and select a new modifier in the Info Line category.

Overview Line

The overview line allows you to zoom and navigate to other sections in the Project window.

• To show or hide the overview line, click the Set up Window Layout button on the toolbar and activate or deactivate Overview Line.

In the overview line, events and parts are displayed as boxes. A rectangle indicates the section of the project that is currently displayed in the event display.

• To zoom the event display in or out horizontally, resize the rectangle by dragging the edges.

• To navigate to another section of the event display, drag the rectangle to the left or right, or click in the upper part of the overview.

Ruler

The ruler shows the timeline and the display format of the project.

Initially, the Project window ruler uses the display format that is specified in the Project Setup dialog.
To select an independent display format for the ruler, click the arrow button to the right of the ruler and select an option from the pop-up menu.

To set the display format globally for all windows, use the primary display format pop-up on the Transport panel, or hold down [Ctrl]/[Command] and select a display format in any ruler.

**RELATED LINKS**

Project Setup Dialog on page 72

**Ruler Display Formats**

You can select a display format for the ruler.

- To select a new display format for the ruler, click the arrow button to the right of the ruler and select an option from the pop-up menu.

The selection that you make affects the time display formats in the following areas:

- Ruler
- Info line
- Tooltip position values

The following options are available:

**Bars+Beats**

Bars, beats, sixteenth notes, and ticks. By default, there are 120 ticks per sixteenth note, but you can adjust this with the MIDI Display Resolution setting (File > Preferences > MIDI).

**Second**

Hours, minutes, seconds, and milliseconds.

**Timecode**

Hours, minutes, seconds, and frames. The number of frames per second (fps) is set in the Project Setup dialog with the Frame Rate pop-up menu. You can also display subframes by activating Show Timecode Subframes (File > Preferences > Transport).

**Samples**

Samples
fps (User)

Hours, minutes, seconds, and frames, with a user-definable number of frames per second. You can also display subframes by activating Show Timecode Subframes (File > Preferences > Transport). You can also set the number of fps.

Time Linear

Sets the ruler linear to time.

Bars+Beats Linear

Sets the ruler linear to bars and beats.

Inspector

The Inspector shows controls and parameters for the first (topmost) selected track type in the track list.

- To show or hide the Inspector, click the Set up Window Layout button on the toolbar and activate or deactivate Inspector.
Inspection Sections

The Inspector is divided into a number of sections that each contain different controls for the track.

Not all Inspector sections are shown by default. The available sections depend on the selected track type.

- To hide or show sections, click on their names. Clicking the name for a hidden section brings it into view and hides the other sections.

- To hide or show a section without closing the other sections, [Ctrl]/[Command]-click the section name.

Related Links

Audio Track Inspector on page 83
Instrument Track Inspector on page 90
MIDI Track Inspector on page 96
Arranger Track Inspector on page 104
Chord Track Inspector on page 106
Marker Track Inspector on page 121
Signature Track Inspector on page 124
Tempo Track Inspector on page 125
Transpose Track Inspector on page 126
VCA Fader Track Inspector on page 127
Video Track Inspector on page 130

Setting Up Inspector Sections

You can set up the visible Inspector sections for all tracks of the selected track type.

- To open the Audio Track Inspector Settings dialog, click the Open Inspector Settings Dialog button at the bottom right of the Inspector.
**Hidden Items**
This section displays sections currently hidden in the Inspector.

**Visible Items**
This section displays sections currently visible in the Inspector.

**Pin**
Allows you to pin the open/close status of the selected Inspector section.

**Add**
Allows you to move an item selected in the hidden sections list to the list of visible sections.

**Remove**
Allows you to move an item selected in the visible sections list to the list of hidden sections.

**Move Up/Move Down**
Allows you to change the order of an item in the list of visible sections.

**Presets**
Allows you to save Inspector section settings as presets.

**Reset All**
Allows you to restore all default Inspector section settings.

---

**Global Track Controls**

The global track controls area above the track list allows you to manage the tracks in the track list.

1) **Filter Track Types**
   Allows you to determine which track types are shown in the track list.

2) **Number of Visible Tracks**
   Displays how many tracks are hidden. Click this, to show all tracks that are filtered out on the **Visibility** Inspector tab.
NOTE
You cannot undo visibility changes. Tracks that are hidden through the Track Types filter cannot be shown by clicking the number of visible tracks.

3) Add Track
Allows you to add tracks to the track list.

4) Find Tracks
Allows you to find and select a specific track in the track list.

RELATED LINKS
Channel Selector on page 297

Filtering Track Types

PROCEDURE
1. Click Filter Track Types above the track list.
   This opens the track types filter.

2. Click a dot to the left of a track type to hide it.

RESULT
Tracks of the filtered type are removed from the track list and the color of the Filter Track Types button changes to indicate that a track type is hidden.
Finding Tracks

The **Find Tracks** function allows you to find specific tracks. This is useful if you have a large project with many tracks or if you have hidden tracks using the track visibility features.

**PROCEDURE**

1. Click **Find Tracks** above the track list, to open a selector that lists all tracks.
2. In the search field, enter the name of the track. As you type, the selector updates automatically.
3. In the selector, select the track and press [Return].

**RESULT**

The selector closes and the track is selected in the track list.

**NOTE**

If the track was outside the view or hidden, it is now shown. Tracks that are hidden using **Filter Track Types** are not shown.

Visibility

The **Visibility** tab in the **Inspector** allows you to determine which individual tracks are shown in the track list.

- To open the **Visibility** tab, click its tab in the **Inspector**.
Showing/Hiding Individual Tracks

The Visibility tab shows a list of all current tracks. Here you can show and hide individual tracks.

- To show or hide a track in the track list, click a dot to the left of a track.
- To activate or deactivate several tracks at the same time, select them and press [Return].
- To show a hidden track exclusively, [Shift]-click the dot.
- To expand or collapse a folder, click the triangle to the left of a folder track.

Synchronizing Track and Channel Visibility

You can synchronize the track visibility in the Project window with the channel visibility in the MixConsole.

**PROCEDURE**

1. In the Inspector, open the Visibility tab and click the dot to open the Sync Track/Channel Visibility menu.

2. Select Sync Project and MixConsole to synchronize the track visibility with the channel visibility.

**RESULT**

The dot in the Visibility tab changes to indicate that the track and channel visibility are synchronized.

**NOTE**

- You can only synchronize the track visibility in the Project window with the channel visibility of one MixConsole. If you enable Sync Track/Channel Visibility for a second MixConsole, the first link is lost.
- If you divide the track list, the top part of the list is not affected. Likewise, channels in the left or right zones of the MixConsole are not synchronized.
Track List

The track list shows the tracks that are used in the project. When a track is added and selected, it contains name fields and settings for this track.

- To decide which controls are visible for each track type, right-click the track list and open the Track Controls Settings dialog.

Dividing the Track List

You can divide the track list into an upper track list and a lower track list. These track lists can have independent zoom and scroll controls.

Dividing the track list is useful if you are working with a video track and multi-track audio, for example. It allows you to place the video track in the upper track list and to scroll the audio tracks separately in the lower track list, so that they can be arranged with the video.

- To divide the track list, click the Divide Track List button in the top right corner of the Project window below the ruler.

  Video, marker, or arranger tracks are automatically moved to the upper track list. All other track types are moved to the lower track list.

- To move any type of track from the lower track list to the upper and vice versa, right-click it in the track list and select Toggle Track List from the context menu.

- To resize the upper part of the track list, click and drag the divider between the track list sections.

- To revert to a single track list, click Divide Track List again.
Event Display

The event display shows the parts and events that are used in the project. They are positioned along the timeline.

Racks

The racks zone of the project window allows you to display the VST Instruments and the MediaBay.

- To show or hide the rack zone, click the Set up Window Layout button on the toolbar and activate or deactivate Racks.
• Click the **VST Instruments** tab to add and edit VST instruments from within the rack zone of the project window.

• Click the **MediaBay** tab to drag audio events and MIDI parts into project window or to drag audio events and MIDI parts from the project window into the MediaBay and store them as audio or MIDI loops.

### Zooming in the Project Window

You can zoom in the **Project** window according to the standard zoom techniques. Note the following:

• When you are using the **Zoom** tool (magnifying glass), the zooming result depends on the **Zoom Tool Standard Mode: Horizontal Zooming Only** option (File > Preferences > Editing > Tools).

  If this option is activated and you drag a selection rectangle with the **Zoom** tool, the window is only zoomed horizontally, the track height does not change. If the option is deactivated, the window is zoomed both horizontally and vertically.

• When you are using the vertical zoom sliders, the tracks are scaled relatively. If you have made any individual track height adjustments, the relative height differences are maintained.

• If the **Zoom while Locating in Time Scale** option (File > Preferences > Transport) is activated, you can also zoom by clicking in the ruler and dragging up or down with the left mouse button pressed.

  Drag up to zoom out; drag down to zoom in.

• To zoom in on the contents of parts and events vertically, use the waveform zoom slider in the top right corner of the event display.

  This is useful when viewing quiet audio passages.

  ![Waveform Zoom Slider](image)

  **IMPORTANT**

  To get an approximate reading on the level of the audio events by viewing the waveforms, make sure this slider is all the way down. Otherwise, zoomed waveforms may be mistaken for clipped audio.

• If the **Quick Zoom** option (File > Preferences > Editing) is activated, the contents of parts and events are not continuously redrawn when you zoom manually. Instead, the contents are redrawn once you have stopped changing the zoom. Activate the **Quick Zoom** option if screen redraws are slow on your system.
Zoom Submenu

The Zoom submenu contains options for zooming in the Project window.

- To open the Zoom submenu, select Edit > Zoom.

The following options are available:

**Zoom In**
- Zooms in one step, centering on the project cursor.

**Zoom Out**
- Zooms out one step, centering on the project cursor.

**Zoom Full**
- Zooms out so that the whole project is visible. The whole project means the timeline from the project start to the length set in the Project Setup dialog.

**Zoom to Selection**
- Zooms in horizontally and vertically so that the current selection fills the screen.

**Zoom to Selection (Horiz.)**
- Zooms in horizontally so that the current selection fills the screen.

**Zoom to Event**
- This option is available only in the Sample Editor.

**Zoom In Vertically**
- Zooms in one step vertically.

**Zoom Out Vertically**
- Zooms out one step vertically.

**Zoom In Tracks**
- Zooms in on the selected tracks one step vertically.

**Zoom Out Tracks**
- Zooms out the selected tracks one step vertically.

**Zoom Selected Tracks**
- This zooms in vertically on the selected tracks and minimizes the height of all other tracks.

**Undo/Redo Zoom**
- These options allow you to undo/redo the last zoom operation.

**RELATED LINKS**
- **Zooming on page 440**
Zoom Presets

You can create zoom presets that allow you to set up different zoom settings. For example, one where the whole project is displayed in the **Project** window and another with a high zoom factor for detailed editing. The **Zoom Presets** pop-up menu allows you to select, create, and organize zoom presets.

- To open the **Zoom Presets** pop-up menu, click the button to the left of the horizontal zoom control.

The upper part of the menu lists the zoom presets.

- To save the current zoom setting as a preset, open the **Zoom Presets** pop-up menu and select **Add**. In the **Type In Preset Name** dialog that opens, type in a name for the preset and click **OK**.

- To select and apply a preset, select it from the **Zoom Presets** pop-up menu.

- To zoom out so that the whole project is visible, open the **Zoom Presets** pop-up menu and select **Zoom Full**.

  This displays the project from the project start to the length that is set in the **Project Setup** dialog.

- To delete a preset, open the **Zoom Presets** pop-up menu and select **Organize**. In the dialog that opens, select the preset in the list and click the **Delete** button.

- To rename a preset, open the **Zoom Presets** pop-up menu and select **Organize**. In the dialog that opens, select a preset in the list and click the **Rename** button. In the dialog that opens, type in a new name for the preset. Click **OK** to close the dialogs.
Zooming In On Cycle Markers

You can zoom in on the area between cycle markers in the project.

- To zoom in on a cycle marker, click the button to the left of the horizontal zoom control to open a pop-up menu and select a cycle marker.

The middle part of the pop-up menu lists any cycle markers that you have added to the project.

**NOTE**

Only the cycle markers that you create in the current project are available on the menu.

If you select a cycle marker from this menu, the event display is zoomed in to encompass the marker area.

You cannot edit the cycle markers in this pop-up menu.

**RELATED LINKS**

Markers Window on page 283

Zoom History

You can undo and redo zoom operations. This way you can zoom in several steps and then easily go back to the zoom stage at which you started.

You can undo and redo zoom operations in the following ways:

- To undo zoom, select **Edit > Zoom > Undo Zoom** or double-click with the zoom tool (magnifying glass).
- To redo zoom, select **Edit > Zoom > Redo Zoom** or press [Alt]/[Option] and double-click with the zoom tool (magnifying glass).
Snap Function

The Snap function helps you to find exact positions when editing in the Project window. It does this by restricting horizontal movement and positioning to certain positions. Operations affected by Snap include moving, copying, drawing, sizing, splitting, range selection, etc.

- To activate/deactivate Snap, activate/deactivate the Snap icon on the toolbar.

Setting the Snap Point

You can set the snap point at any position of the audio event.

**PROCEDURE**
1. Select an event.
2. Place the project cursor at a position within the selected audio event.
3. Select Audio > Snap Point To Cursor.

**RESULT**
The snap point is set at the cursor position.

The snap point for an event is displayed as a vertical line in the Project window.

**NOTE**
You can also set the snap point in the Sample Editor.

**RELATED LINKS**
Adjusting the snap point on page 443

Snap to Zero Crossing

When splitting and sizing audio events, sudden amplitude changes can cause pops and clicks. To avoid this, you can activate Snap to Zero Crossing to snap to points where the amplitude is zero.

- To activate Snap to Zero Crossing, activate Snap to Zero Crossing on the toolbar.
Snap Types

You can select between different snap types to determine the snap point.

- To select a snap type, open the Snap Type pop-up menu.

The following snap types are available:

Grid

If this option is activated, the snap points are set with the Grid Type pop-up menu. The options depend on the display format that are selected for the ruler.

When you select Seconds as ruler format, the Grid Type contains time-based grid options.

Grid Relative

If this option is activated, events and parts are not magnetic to the grid. Rather, the grid determines the step size for moving the events. This means that a moved event keeps its original position relative to the grid.

For example, if an event starts at the position 3.04.01, snap is set to Grid Relative and the Grid Type pop-up menu is set to Bar, you can move the event in steps of one bar to the positions 4.04.01, 5.04.01, and so on.

NOTE

This only applies when dragging existing events or parts. When you create new events or parts this snap type works like Grid.

Events

If this option is activated, the start and end positions of other events and parts become magnetic. This means that if you drag an event to a position near the start or end of another event, it is automatically aligned with the start or end of the other event.

For audio events, the position of the snap point is also magnetic. This includes marker events on the marker track.
Shuffle

Shuffle is useful when you want to change the order of adjacent events. If you have two adjacent events and drag the first one to the right, past the second event, the two events will change places.

The same principle works when changing the order of more than two events:

| 1 | 2 | 3 | 4 | 5 |

Dragging event 2 past event 4…

| 1 | 3 | 4 | 2 | 5 |

…changes the order of events 2, 3, and 4.

Magnetic Cursor

This grid type lets the project cursor become magnetic. Dragging an event near the cursor causes the event to be aligned with the cursor position.

Grid + Cursor

This is a combination of Grid and Magnetic Cursor.

Events + Cursor

This is a combination of Events and Magnetic Cursor.

Events + Grid + Cursor

This is a combination of Events, Grid, and Magnetic Cursor.

Cross-Hair Cursor

The cross-hair cursor is displayed when working in the Project window and in the editors, facilitating navigation and editing, especially when arranging large projects.

- To set up the cross-hair cursor, select File > Preferences > Editing > Tools.
  You can set up the colors for the line and the mask of the cross-hair cursor, and define its width.
The cross-hair cursor works as follows:

- When the **Object Selection** tool or one of its subtools is selected, the cross-hair cursor appears when you start moving/copying a part/event, or when using the event trim handles.

![Cross-hair cursor when moving an event.](image)

- When the **Object Selection** tool, the **Cut** tool, or any other tool that makes use of this function is selected, the cross-hair cursor appears as soon as you move the mouse over the event display.

- The cross-hair cursor is only available for tools where such a function is of any use. The **Mute** tool, for example, does not use a cross-hair cursor, as you have to click directly on an event to mute it.

### Edit History Dialog

In the **Edit History** dialog, you can undo all actions in the **Project** window as well as in the editors. You can also undo audio processes or applied plug-in effects. However, these are better removed and modified using the Offline Process History. The dialog contains a list of all your edits, with the most recent action at the bottom of the list.

- To open the **Edit History** dialog, select **Edit > History**.

![Edit History dialog in Cubase Pro](image)

The **Action** column displays the name of the action while the **Time** column tells you when this action was performed. In the **Details** column further details are shown. Here you can enter new text by double-clicking in the column.
To undo your actions, move the horizontal, colored line upwards to the desired position. You can only undo your actions in reverse order, for example, the last performed action is the first action to be undone.

To redo an action that was undone previously, move the line down the list again.

**RELATED LINKS**
- The Offline Process History dialog on page 418

## Setting the Number of Maximum Undo Steps

You can limit the number of maximum undo steps. This is useful if you run out of hard disk space, for example.

**PROCEDURE**

1. Select **File > Preferences > General**.
2. Set the number in the **Maximum Undo Steps** field.
Creating New Projects

You can create empty projects or projects that are based on a template.

**PROCEDURE**

1. Select File > New Project.
   
   Depending on your settings, either the Steinberg Hub or the Project Assistant dialog opens.

2. In the location options section, select where to store the new project.
   
   - To use the default location, select Use default location.
   
   - To choose another location, select Prompt for project location, click Create, and set the location in the dialog that opens.

3. Do one of the following:
   
   - To create an empty new project, click Create Empty.
   
   - To create a new project from a template, select a template and click Create.

**RESULT**

A new, untitled project is created. If you selected a template, the new project is based on this template and includes the corresponding tracks, events, and settings.
Steinberg Hub

When you start Cubase or create new projects using the File menu, Steinberg Hub opens. Steinberg Hub keeps you up to date with the latest information and assists you with organizing your projects. It consists of the News and Tutorials section and the Projects section.

News and Tutorials section

The News and Tutorials section displays Steinberg news, tutorial videos as well as links to the user forum, downloads, and Knowledge Base.

**NOTE**

Ensure that you have an active internet connection to access this material.

Projects section

The Projects section lets you create new projects, which can either be empty or based on a template. It lets you specify where to save the projects. It also allows you to access recently opened projects or projects that are stored in other locations. This section offers the same functionality as the Project Assistant dialog.

Category bar

In this section, the available factory templates are sorted into the predefined categories Recording, Scoring, Production, and Mastering.

The Recent category contains a list of the recently opened projects.

The More category contains the default project template and all templates that are not assigned to any of the other categories.
Template list

When you click on one of the category items, the list below the category bar shows the available templates for this category. Any new templates that you create are added at the top of the corresponding list.

Location options

This section allows you to specify where the project is stored.

Open other

This button allows you to open any project file on your system. This is identical to using the Open command on the File menu.

RELATED LINKS

Project Assistant on page 69

Deactivating Steinberg Hub

To start Cubase or to create new projects without Steinberg Hub, you can deactivate it.

PROCEDURE

- Select File > Preferences > General and deactivate Use Steinberg Hub.

RESULT

Cubase starts without opening a project and opens the Project Assistant dialog when you create a new project using the File menu. However, you can still open Steinberg Hub through the Steinberg Hub menu.

Project Assistant

When you deactivate Steinberg Hub and create new projects, the Project Assistant dialog opens. This dialog offers the same functions as the Projects section in Steinberg Hub.

Category bar

In this section, the available factory templates are sorted into the predefined categories Recording, Production, Scoring, and Mastering.

The Recent category contains a list of the recently opened projects.

The More category contains the default project template and all templates that are not assigned to any of the other categories.
Template list

When you click on one of the category items, the list below the category bar shows the available factory templates for this category. Any new templates that you create are added at the top of the corresponding list.

Location options

This section allows you to specify where the project is stored.

Open other

This button allows you to open any project file on your system. This is identical to using the Open command from the File menu.

About Project Files

A project file (extension *.cpr) is the central document in Cubase. A project file contains references to media data that can be saved in the project folder.

NOTE

We recommend to save files only in the project folder, even though you can save them in any other location to which you have access.

The project folder contains the project file and the following folders that Cubase automatically creates when necessary:

- Audio
- Edits
- Images
- Track Pictures

About Template Files

Templates can be a good starting point for new projects. Templates are projects where you can save all settings that you regularly use, such as bus configurations, sample rates, record formats, basic track layouts, VSTi setups, drum map setups, etc.

The following template types are available from within Steinberg Hub:

- Factory templates for specific scenarios. These are listed in the Recording, Scoring, Production, or Mastering categories.
- The default template. This is listed in the More category.
- Any new user templates that you create and save. These are listed in the More category.
Template projects are not saved in project folders and therefore contain no subfolders and no media files.

- To open the location of a specific template, right-click a template in the template list and select Show in Explorer (Win) or Reveal in Finder (Mac).

**Saving a Project Template File**

You can save the current project as a template. When you create a new project, you can select this template as a starting point for your new project.

**PREREQUISITE**

Remove all clips from the Pool before you save the project as a template. This ensures that references to media data from the original project folder are deleted.

**PROCEDURE**

1. Set up a project.
2. Select File > Save As Template.
3. In the New Preset section of the Save As Template dialog, enter a name for the new project template.
4. In the Attribute Inspector section, double-click the Value field of the Content Summary attribute to enter a description for the template.
5. Click the Value field of the Template Summary attribute and select a template category from the pop-up menu.
   - If you do not select a category, the new template will be listed in Steinberg Hub in the More category.
6. Click OK to save the template.
Renaming Templates

**PROCEDURE**

1. In Steinberg Hub or the Project Assistant, right-click a template and select Rename.
2. In the Rename dialog, enter a new name and click OK.

Project Setup Dialog

You can perform general settings for your project in the **Project Setup** dialog.

- To open the Project Setup dialog, select **Project > Project Setup**.
- To open the Project Setup dialog automatically when you create a new project, activate the **Run Setup on Create New Project** option (File > Preferences > General).

**IMPORTANT**

While most **Project Setup** settings can be changed at any time, you must set the sample rate directly after creating a new project. If you change the sample rate at a later stage, you must convert all audio files in the project to the new sample rate to make them play back properly.
The following options are available:

**Author**

Allows you to specify a project author that is written into the file, when you export audio files and activate the Insert iXML chunk option. You can specify a default author in the Default Author Name field (File > Preferences > General > Personalization).

**Company**

Allows you to specify a company name that is written into the file, when you export audio files and activate the Insert iXML chunk option. You can specify a default company in the Default Company Name field (File > Preferences > General > Personalization).

**Start**

Allows you to specify the start time of the project in timecode format. This also determines the sync start position when synchronizing to external devices.

**Length**

Allows you to specify the length of the project.

**Frame Rate**

Allows you to specify the timecode standard and frame rate for the project. When synchronizing to an external device, this setting must correspond to the frame rate of any incoming timecode.

**Get From Video**

Allows you to set the project frame rate to the frame rate of an imported video file.

**Display Format**

Allows you to specify the global display format that is used for all rulers and position displays in the program, except the ruler tracks. However, you can make independent display format selections for the individual rulers and displays.

**Display Offset**

Allows you to specify an offset for the time positions that are displayed in the rulers and position displays to compensate for the Start position setting.

**Bar Offset**

This setting is only used, when you select the Bars+Beats display format. Allows you to specify an offset for the time positions that are displayed in the rulers and position displays to compensate for the Start position setting.

**Sample Rate**

Allows you to specify the sample rate at which records and plays back audio.

- If your audio hardware generates the sample rate internally and you select a non-supported sample rate, this is indicated by a different color. In this case, you must set a different sample rate to make your audio files play back properly.
• If you select a sample rate that your audio hardware supports, but that differs from its current sample rate setting, it is automatically changed to the project sample rate.

• If your audio hardware is externally clocked and receives external clock signals, sample rate mismatches are accepted.

**Bit Resolution**

Allows you to specify the resolution of the audio files that you record in Cubase. Select the record format according to the bit resolution that is delivered by your audio hardware. The available options are 16 Bit, 24 Bit, and 32 Bit float.

**NOTE**

• When you record with effects, consider setting the bit resolution to 32 Bit Float. This prevents from clipping (digital distortion) in the recorded files and keeps the audio quality absolutely pristine. Effect processing and level or EQ changes in the input channel are done in 32 Bit Float format. If you record at 16 or 24 Bit, the audio will be converted to this lower resolution when it is written to a file. As a result, the signal may degrade. This is independent of the actual resolution of your audio hardware. Even if the signal from the audio hardware has a resolution of 16 Bit, the signal will be 32 Bit Float after the effects are added to the input channel.

• The higher the bit resolution, the larger the files and the more strain is put on the disk system. If this is an issue, you can lower the record format setting.

**Record File Type**

Allows you to specify the file type of the audio files that you record in Cubase. The following file types are available:

• **Wave files** are a common file format on the PC platform. For recordings larger than 4 GB, the EBU RIFF standard is used. If a FAT 32 disk is used (not recommended), audio files are split automatically.

• **Wave 64** is a proprietary format developed by Sonic Foundry Inc. Audio-wise it is identical to the Wave format, but the internal file structure allows for much larger file sizes as required by long live recordings.

• **Broadcast Wave Files** are, in terms of audio content, identical with regular Wave files, but with embedded text strings for supplying additional information about the file. These can be set up in the Preferences dialog (Record–Audio–Broadcast Wave).

• **AIFF Files**, Audio Interchange File Format, is a defined standard by Apple Inc. and can be used on most computer platforms. AIFF files can contain embedded text strings. These can be set up in the Preferences dialog (Record–Audio–Broadcast Wave).

• **FLAC Files**, Free Lossless Audio Codec, is an open source format. Audio files recorded in this format are typically 50% to 60% smaller than regular Wave files.
NOTE

If your recorded Wave file is larger than 4 GB and **Use RF64 Format** is activated on the **When Recording Wave Files larger than 4 GB** pop-up menu (File > Preferences > Record > Audio), your recording is saved as an RF64 file. This way, you do not have to worry about the file size during recording. However, keep in mind that this format is not supported by all applications.

Stereo Pan Law

If you pan a channel left or right, the sum of the left and right side is higher (louder), than if this channel is panned center. These modes allow you to attenuate signals panned center. **0 dB** turns off constant-power panning. **Equal Power** means that the power of the signal remains the same regardless of the pan setting.

Volume Max

Allows you to specify the maximum fader level. By default, this is set to +12 dB. If you load projects that were created with Cubase versions older than 5.5, this value is set to the old default value of +6 dB.

HMT Type (MIDI only)

Allows you to specify a mode for Hermode tuning of MIDI notes.

HMT Depth (MIDI only)

Allows you to specify the overall degree of retuning.

Opening Project Files

You can open one or several saved project files at the same time.

IMPORTANT

If you open a project saved with a different program version that contains data for functions that are not available in your version, this data may be lost when you save the project with your version.

PROCEDURE

1. Select **File > Open**.
2. In the file dialog that opens, select the project that you want to open and click **Open**.
3. If there already is an open project, you are asked if you want to activate the new project. Do one of the following:
   - To activate the project, click **Activate**.
   - To open the project inactive, click **No**.
     This reduces load times for projects.
Activating Projects

If you have several projects opened at the same time in Cubase, only one project can be active. The active project is indicated by the lit **Activate Project** button in the upper left corner of the **Project** window. If you want to work on another project, you have to activate the other project.

**PROCEDURE**

- To activate a project, click its **Activate Project** button.

Opening Recent Projects

To open a recently opened project, do one of the following:

- In the category bar of Steinberg Hub or the **Project Assistant** dialog, click **Recent**, select a project from the projects list, and click **Open**.
- Select **File > Recent Projects** and select a recently opened project.

Re-Routing Missing Ports

If you open a Cubase project that was created on a different system with other audio hardware, Cubase tries to find matching audio inputs and outputs for the input/output busses. If Cubase cannot resolve all audio/MIDI inputs and outputs that are used in the project, the **Missing Ports** dialog opens.

This allows you to manually re-route any ports specified in the project to ports that are available in your system.

**NOTE**

To improve the search for matching audio inputs and outputs for the input/output busses, you should use descriptive, generic names for your input and output ports.

**RELATED LINKS**

- Renaming the Hardware Inputs and Outputs on page 29
Saving Project Files

You can save the active project as a project file. To keep your projects as manageable as possible, make sure that you save project files and all related files in the respective project folders.

- To save the project and specify a file name and location, open the File menu and select Save As.
- To save the project with its current name and location, open the File menu and select Save.

**NOTE**

Make sure that the Use File Extension in File Dialog option (File > Preferences > General) is activated. This automatically adds the file name extension when you save a file and keeps your projects compatible with both Windows and Mac OS X systems.

About the Auto Save Option

Cubase can automatically save backup copies of all open project files with unsaved changes.

**NOTE**

Only the project files are backed up. If you want to include the files from the Pool and save your project in a different location, you must use the Back up Project function.

If you activate the Auto Save option (File > Preferences > General), Cubase automatically saves backup copies of all open projects with unsaved changes. These backup copies are named “<project name>-xx.bak” where xx is an incremental number. Unsaved projects are backed up in a similar way as “UntitledX-xx.bak”, with X being the incremental number for unsaved projects. All backup files are saved in the project folder.

- To specify the time intervals in which a backup copy is created, use the Auto Save Interval setting.
- To specify how many backup files are created with the Auto Save function, use the Maximum Backup Files option. When the maximum number of backup files is reached, the existing files are overwritten, starting with the oldest file.
Saving Project Files As a New Version

You can create and activate a new version of an active project file. This is useful if you are experimenting with edits and arrangements and want to be able to go back to a previous version at any time.

• To save a new version of the active project, press [Ctrl]/[Command]-[Alt]/[Option]-[S].

The new file is saved with the same name as the original project and an attached incremental number. For example, if your project is called “My Project,” new versions are called “My Project-01”, “My Project-02”, and so on.

Reverting to the Last Saved Version

You can return to the last saved version and discard all changes that have been introduced.

PROCEDURE
1. Select File > Revert.
2. In the warning message, click Revert.
   If you have recorded or created new audio files since the last version was saved, you are prompted to delete or keep the files.

Choosing a Project Location

In Steinberg Hub and in the Project Assistant, you can specify where to save a project.

• To create a project in the default project location, select Use default location.
  In the Project folder field, you can specify a name for the project folder. If you do not specify a project folder here, the project is saved in a folder named Untitled.

• To change the default project location, click in the path field.
  A file dialog opens that allows you to specify a new default location.

• To create the project in a different location, select Prompt for project location.
  In the dialog that opens, specify a location and a project folder.
Removing Unused Audio Files

You can use the Cleanup function to locate and delete unused audio files in the project folders on your disk.

PREREQUISITE

Make sure that you have not moved or renamed files or folders without updating the project files to use the new paths. Also make sure that the project folder does not contain audio files that belong to projects that are not saved in the project folder.

PROCEDURE

1. Close all projects.
2. Select File > Cleanup.
3. Click the Start button.
   Cubase scans the hard disks for project folders and lists all audio and image files that are not used by any project.

   NOTE
   You can also click the Search Folder button to select a specific folder for the Cleanup function. This is only recommended if you are sure that the folder contains no audio files that are used in other projects.

4. Select the files that you want to delete and click Delete.

Creating Self-Contained Projects

If you want to share your work or transfer it to another computer, your project must be self-contained.

The following functions facilitate this task:

- Select Media > Prepare Archive to verify that every clip that is referenced in the project is located in the project folder, and to take actions if that is not the case.

- Select File > Back up Project to create a new project folder where you can save the project file and the necessary work data. The original project remains unchanged.
Preparing Archives

The Prepare Archive function allows you to gather all files that are referenced by your project to ensure that these are in the project folder. This is useful if you want to move or archive your project.

**PROCEDURE**

1. Select **Media > Prepare Archive**.
   
   If your project references external files, you are prompted if you want to copy them to your working directory. If any processing has been applied, you must decide if you want to freeze edits.

2. Click **Proceed**.

**RESULT**

Your project is ready to be archived. You can move or copy the project folder to another location.

**AFTER COMPLETING THIS TASK**

You must copy audio files that reside within the project folder to the Audio folder or save them separately. You must also move your video clips manually, as videos are only referenced and not saved in the project folder.

Backing Up Projects

You can create a backup copy of your project. Backups only contain the necessary work data. All media files except the files from VST Sound archives are included as a copy.

**PROCEDURE**

1. Select **File > Back up Project**.

2. Select an empty folder or create a new one.

3. Make your settings in the **Back up Project Options** dialog and click **OK**.

**RESULT**

A copy of the project is saved in the new folder. The original project remains unaffected.

**NOTE**

VST Sound content provided by Steinberg is copy-protected and will not be included in the backup project. If you want to use a backup copy that uses VST Sound content on a different computer, make sure that the corresponding content is also available on that computer.
Back up Project Options Dialog

This dialog allows you to create a backup copy of your project.

- To open the Back up Project Options dialog, select File > Back up Project.

Project Name
Allows you to change the name of the backed up project.

Keep Current Project Active
Allows you to keep the current project active after clicking OK.

Minimize Audio Files
Allows you to include only the audio file portions that are actually used in the project. This can significantly reduce the size of the project folder if you are using small sections of large files. It also means that you cannot use other parts of the audio files if you continue working with the project in its new folder.

Freeze Edits
Allows you to freeze all edits and make all processing and applied effects permanent to each clip in the Pool.

Remove Unused Files
Allows you to remove unused files and to back up only the files that are actually used.

Do Not Back up Video
Allows you to exclude video clips on the video track or in the Pool of the current project.
Tracks

Tracks are the building blocks of your project. They allow you to import, add, record, and edit data (parts and events). Tracks are listed from top to bottom in the Track list and extend horizontally across the Project window. Each track is assigned to a particular channel strip in the MixConsole.

If you select a track in the Project window, the controls, settings, and parameters displayed in the Inspector and the track list allow you to control the track.

Audio Tracks

You can use audio tracks for recording and playing back audio events and audio parts. Each audio track has a corresponding audio channel in the MixConsole. An audio track can have any number of automation tracks for automating channel parameters, effect settings, etc.

- To add an audio track to your project, select Project > Add Track > Audio.

RELATED LINKS
Adding Tracks on page 134
Audio Track Inspector

The **Inspector** for audio tracks contains controls and parameters that allow you to edit your audio track.

The top section of the audio track **Inspector** contains the following basic track settings:

**Track name**

Click once to show/hide the basic track settings section. Double-click to rename the track.

**Edit**

Opens the **Channel Settings** window for the track.

**Mute**

Mutes the track.

**Solo**

Solos the track.

**Read Automation**

Allows you to read track automation.

**Write Automation**

Allows you to write track automation.

**Open Device Panels (Cubase Pro only)**

Allows you to create a device panel for the plug-in and device parameters of your track.

**Auto Fades Settings**

Opens a dialog where you can make separate audio fade settings for the track.

**Record enable**

Activates the track for recording.

**Monitor**

Routes incoming signals to the selected output.
Tracks
Audio Tracks

Toggle Time Base
Switches between musical (tempo related) and linear (time related) time base for the track.

Lock
Disables all editing of all events on the track.

Show Lanes
Divides the tracks in lanes.

Freeze Audio Channel
Allows you to freeze the audio channel.

Volume
Allows you to adjust the level for the track.

Pan
Allows you to adjust the panning of the track.

Delay
Allows you to adjust the playback timing of the track.

Load/Save/Reload Track Preset
Loads or saves a track preset or reverts the default presets.

Input Routing
Allows you to specify the input bus for the track.

Output Routing
Allows you to specify the output bus for the track.

Audio Track Inspector sections
Apart from the basic track settings that are always shown, audio tracks provide other Inspector sections. These are described in the following sections.

TrackVersions

Allows you to create and edit TrackVersions.
Tracks
Audio Tracks

Chords Section

Allows you to specify how the track follows the chord track.

Inserts Section

Allows you to add insert effects to the track.

Strip Section

 Allows you to set up the channel strip modules.
Equalizers Section

Allows you to adjust the EQs for the track. You can have up to four bands of EQ for each track.

Sends Section

Allows you to route the track to one or several FX channels.

Cue Sends Section (Cubase Pro only)

Allows you to route cue mixes to Control Room cues.
Tracks
Audio Tracks

Direct Routing Section

Allows you to set up direct routing.

Surround Pan Section (Cubase Pro only)

Shows the SurroundPanner for a track (if used).

Fader Section

Shows a duplicate of the corresponding MixConsole channel.

Notepad Section

Allows you to enter notes about the track.
Device Panel Section (Cubase Pro only)

Allows you to display and use device panels.

Quick Controls Section

Allows you to configure quick controls to use remote devices, for example.

Audio Track Controls

The Track List for audio tracks contains controls and parameters that allow you to edit your audio track.

The track list for audio tracks contains the following controls:

- **Track name**
  - Double-click to rename the track.

- **Edit**
  - Opens the Channel Settings window for the track.

- **Mute**
  - Mutes the track.

- **Solo**
  - Solos the track.

- **Read Automation**
  - Allows you to read track automation.

- **Write Automation**
  - Allows you to write track automation.

- **Record enable**
  - Activates the track for recording.
Tracks

Instrument Tracks

Monitor
Routes incoming signals to the selected output.

Toggle Time Base
Switches between musical (tempo related) and linear (time related) time base for the track.

Lock
Disables all editing of all events on the track.

Show Lanes
Divides the tracks in lanes.

Bypass Inserts
Bypasses the inserts for the track.

Bypass EQs
Bypasses the equalizers for the track.

Bypass Sends
Bypasses the sends for the track.

Channel Configuration
Shows the channel configuration of the track.

Freeze Audio Channel
Allows you to freeze the audio channel.

Instrument Tracks

You can use instrument tracks for dedicated VST instruments. Each instrument track has a corresponding instrument channel in the MixConsole. An instrument track can have any number of automation tracks.

- To add an instrument track to your project, select Project > Add Track > Instrument.
Instrument Track Inspector

The Inspector for instrument tracks contains controls and parameters that allow you to control your instrument track. It shows some of the sections from VST instrument channels and MIDI tracks.

The top section of the instrument track Inspector contains the following basic track settings:

**Track name**

Click once to show/hide the basic track settings section. Double-click to rename the track.

**Edit**

Opens the Channel Settings window for the track.

**Mute**

Mutes the track.

**Solo**

Solos the track.

**Read Automation**

Allows you to read track automation.

**Write Automation**

Allows you to write track automation.

**Open Device Panels**

Allows you to open the instrument panel.

**Input Transformer**

Opens the Input Transformer dialog that allows you to transform incoming MIDI events in realtime.

**Record enable**

Activates the track for recording.

**Monitor**

Routes incoming MIDI to the selected MIDI output. For this to work, activate MIDI Thru Active in the Preferences dialog (MIDI page).
Tracks
Instrument Tracks

Toggle Time Base
Switches between musical (tempo related) and linear (time related) time base for the track.

Lock
Disables all editing of all events on the track.

Freeze Instrument Channel
Allows you to freeze the instrument.

Volume
Allows you to adjust the level for the track.

Pan
Allows you to adjust the panning of the track.

Delay
Allows you to adjust the playback timing of the track.

Show Lanes
Divides the tracks in lanes.

Load/Save/Reload Track Preset
Loads or saves a track preset or reverts the default presets.

Input Routing
Allows you to specify the input bus for the track.

Output Routing
Allows you to specify the output bus for the track.

Edit Instrument
Allows you to open the instrument panel.

Programs
Allows you to select a program.

Drum Map
Allows you to select a drum map for the track.

Instrument Track Inspector Sections
Apart from the basic track settings that are always shown, instrument tracks provide other Inspector sections. These are described in the following sections.
TrackVersions

Allows you to create and edit TrackVersions.

Chords Section

Allows you to specify how the track follows the chord track.

Expression Map Section

Allows you to use the Expression Map features.
**Note Expression Section**

Allows you to work with the **Note Expression** features.

**MIDI Modifiers Section**

Allows you to transpose or adjust the velocity of the MIDI track events in realtime during playback.

**MIDI Inserts Section**

Allows you to add MIDI insert effects.
Instrument Section

Shows the audio-related controls for the instrument.

Notepad Section

Allows you to enter notes about the track.

Device Panel Section (Cubase Pro only)

Allows you to display and use device panels.

Quick Controls Section

Allows you to configure quick controls to use remote devices, for example.
The Track List for instrument tracks contains controls and parameters that allow you to edit your instrument track.

The track list for instrument tracks contains the following controls:

**Track name**
Double-click to rename the track.

**Edit**
Opens the Channel Settings window for the track.

**Mute**
Mutes the track.

**Solo**
Solos the track.

**Read Automation**
Allows you to read track automation.

**Write Automation**
Allows you to write track automation.

**Record enable**
Activates the track for recording.

**Monitor**
Allows you to route incoming MIDI signals to the selected MIDI output. For this to work, activate MIDI Thru Active in the Preferences dialog (MIDI page).

**Toggle Time Base**
Switches between musical (tempo related) and linear (time related) time base for the track.

**Lock**
Disables all editing of all events on the track.

**Show Lanes**
Divides the tracks in lanes.

**Bypass Inserts**
Bypasses the inserts for the track.

**Bypass EQs**
Bypasses the equalizers for the track.
Tracks

MIDI Tracks

You can use MIDI tracks for recording and playing back MIDI parts. Each MIDI track has a corresponding MIDI channel in the MixConsole. A MIDI track can have any number of automation tracks.

- To add a MIDI track to your project, select Project > Add Track > MIDI.

MIDI Track Inspector

The Inspector for MIDI tracks contains controls and parameters that allow you to control your MIDI track. These affect MIDI events in realtime, on playback, for example.
The top section of the MIDI track Inspector contains the following basic track settings:

**Track name**
- Click once to show/hide the basic track settings section. Double-click to rename the track.

**Edit**
- Opens the **Channel Settings** window for the track.

**Mute**
- Mutes the track.

**Solo**
- Solos the track.

**Read Automation**
- Allows you to read track automation.

**Write Automation**
- Allows you to write track automation.

**Open Device Panels**
- Allows you to open the instrument panel.

**Input Transformer**
- Opens the **Input Transformer** dialog that allows you to transform incoming MIDI events in realtime.

**Record enable**
- Activates the track for recording.

**Monitor**
- Routes incoming MIDI to the selected MIDI output. For this to work, activate **MIDI Thru Active** in the **Preferences** dialog (MIDI page).

**Toggle Time Base**
- Switches between musical (tempo related) and linear (time related) time base for the track.

**Lock**
- Disables all editing of all events on the track.

**Show Lanes**
- Divides the tracks in lanes.

**MIDI Volume**
- Allows you to adjust the MIDI volume for the track.

**MIDI Pan**
- Allows you to adjust the MIDI pan for the track.

**Delay**
- Allows you to adjust the playback timing of the track.
Tracks
MIDI Tracks

Load/Save/Reload Track Preset
Loads or saves a track preset or reverts the default presets.

Input Routing
Allows you to specify the input bus for the track.

Output Routing
Allows you to specify the output bus for the track.

Channel
Allows you to specify the MIDI channel.

Edit Instrument
Allows you to open the instrument panel.

Bank Selector
Allows you to set a bank select message that is sent to your MIDI device.

Program Selector
Allows you to set a program change message that is sent to your MIDI device.

Drum Map
Allows you to select a drum map for the track.

MIDI Track Inspector Sections
Apart from the basic track settings that are always shown, MIDI tracks provide other Inspector sections. These are described in the following sections.

TrackVersions

Allows you to create and edit TrackVersions.
Tracks
MIDI Tracks

Chords Section

Allows you to specify how the track follows the chord track.

Expression Map Section

Allows you to use the Expression Map features.

Note Expression Section

Allows you to work with the Note Expression features.
MIDI Modifiers Section

Allows you to transpose or adjust the velocity of the MIDI track events in realtime during playback.

MIDI Inserts Section

Allows you to add MIDI insert effects.

MIDI Sends Section

Allows you to add MIDI send effects.
**MIDI Fader Section**

Shows a duplicate of the corresponding MixConsole channel.

**Notepad Section**

Allows you to enter notes about the track.

**Device Panel Section (Cubase Pro only)**

Allows you to display and use device panels.

**Quick Controls Section**

Allows you to configure quick controls to use remote devices, for example.
MIDI Track Controls

The Track List for MIDI tracks contains controls and parameters that allow you to edit your MIDI track.

The track list for MIDI tracks contains the following controls:

**Track name**
Click once to show/hide the basic track settings section. Double-click to rename the track.

**Edit**
Opens the Channel Settings window for the track.

**Mute**
Mutes the track.

**Solo**
Solos the track.

**Read Automation**
Allows you to read track automation.

**Write Automation**
Allows you to write track automation.

**Record enable**
Activates the track for recording.

**Monitor**
Allows you to route incoming MIDI signals to the selected MIDI output. For this to work, activate MIDI Thru Active in the Preferences dialog (MIDI page).

**Toggle Time Base**
Switches between musical (tempo related) and linear (time related) time base for the track.

**Lock**
Disables all editing of all events on the track.

**Show Lanes**
Divides the tracks in lanes.

**Bypass Inserts**
Bypasses the inserts for the track.

**Bypass Sends**
Bypasses the sends for the track.
Tracks
Arranger Track

Edit In-Place
Allows you to edit MIDI events and parts on the track in the Project window.

Drum Map
Allows you to select a drum map for the track.

Channel
Allows you to specify the MIDI channel.

Output
Allows you to specify the output for the track.

Programs
Allows you to select a program.

Arranger Track

You can use the arranger track for arranging your project by marking out sections and determining in which order they are to be played back.

- To add the arranger track to your project, select Project > Add Track > Arranger.
Arranger Track Inspector

The arranger track Inspector displays the lists of available arranger chains and arranger events.

The arranger track Inspector contains the following settings:

**Track Name**
- Double-click to rename the track.

**Edit**
- Opens the Arranger Editor.

**Select Active Arranger Chain + Function**
- Allows you to select the active arranger chain, to rename it, to create a new one, to duplicate or to flatten it.

**Current Arranger Chain**
- Shows the active arranger chain.

**Arranger Events**
- Lists all arranger events in your project. Click the arrow for an arranger event to play it back and start the live mode.

**Stop**
- Allows you to stop the live mode.
Jump mode

In this pop-up menu you can define how long the active arranger event is played before jumping to the next one.

Arranger Track Controls

The Track List for the arranger track contains controls and parameters that allow you to edit the arranger track.

The track list for the arranger track contains the following controls:

Select Active Arranger Chain

Allows you to select the active arranger chain.

Current Item/Current Repeat

Displays which arranger event and which repeat is active.

Activate Arranger Mode

Allows you to activate and deactivate the arranger mode.

Toggle Time Base

Switches between musical (tempo related) and linear (time related) time base for the track.

Edit

Opens the Arranger Editor for the track.

Chord Track

You can use the chord track for adding chord and scale events to your project. These can transform the pitches of other events.

- To add the chord track to your project, select **Project > Add Track > Chord**.
Chord Track Inspector

The chord track Inspector contains a number of settings for the chord events.

The top section of the chord track Inspector contains the following settings:

**Track name**
Click to show/hide the basic track settings section.

**Mute**
Mutes the track.

**Record enable**
Activates the track for recording.

**Acoustic Feedback**
Allows you to audition the events on the chord track. For this to work, you need to select a track for auditioning in the track list.

**Toggle Time Base**
Switches between musical (tempo related) and linear (time related) time base for the track.

**Lock**
Disables all editing of all events on the track.

**Voicing library**
Allows you to set up a voicing library for the track.

**Voicing library subset**
Allows you to select a library subset.

**Configure voicing parameters**
Allows you to configure your own voicing parameters for a specific voicing scheme.

**Automatic Voicings**
Activate this to set the voicings automatically.

**Automatic Scales**
Activate this to let the program create scale events automatically.
Mapping Offset

Allows you to specify an offset value to make sure that chord events also affect the MIDI notes that have been triggered too early (enter a negative value) or too late (enter a positive value).

Chord Track Inspector Sections

Apart from the basic track settings that are always shown, the chord track provides other Inspector sections. These are described in the following sections.

TrackVersions

Allows you to create and edit TrackVersions.

Notepad Section

Allows you to enter notes about the track.

Chord Track Controls

The Track List for the chord track contains controls and parameters that allow you to edit the chord track.

The track list for chord tracks contains the following controls:

Mute

Mutes the track.

Select Track for Auditioning

Allows you to select a track for auditioning the chord events.
Record Enable
Allows you to record chord events.

Resolve Display Conflicts
Allows you to show all chord events on the track properly, even at low horizontal zoom levels.

Show Scales
Allows you to show the scale lane in the lower part of the chord track.

Lock
Disables all editing of all events on the track.

Toggle Time Base
Switches between musical (tempo related) and linear (time related) time base for the track.

FX Channel Tracks
You can use FX channel tracks for adding send effects. Each FX channel can contain up to eight effect processors. By routing sends from an audio channel to an FX channel, you send audio from the audio channel to the effects on the FX channel. All FX channel tracks are automatically placed in a special FX channel folder in the track list, for easy management. Each FX channel has a corresponding channel in the MixConsole. An FX channel track can have any number of automation tracks.

- To add an FX channel track to your project, select Project > Add Track > FX Channel.

FX Channel Track Inspector
The Inspector for FX channel tracks shows the settings for the FX channel. When you select the folder track instead, the Inspector shows the folder and the FX channels it contains. You can click one of the FX channels shown in the folder to have the Inspector show the settings for that FX channel.

The FX channel track Inspector contains the following basic track settings:

Track name
FX 2-MonoDelay Click once to show/hide the basic track settings section. Double-click to rename the track.
Tracks
FX Channel Tracks

Edit

Opens the **Channel Settings** window for the track.

Mute

Mutes the track.

Solo

Solos the track.

Read Automation

Allows you to read track automation.

Write Automation

Allows you to write track automation.

Toggle Time Base

Switches between musical (tempo related) and linear (time related) time base for the track.

Lock

Disables all editing of all events on the track.

Volume

Allows you to adjust the level for the track.

Pan

Allows you to adjust the panning of the track.

Output Routing

Allows you to specify the output bus for the track.

FX Channel Track Inspector Sections

Apart from the basic track settings that are always shown, FX channel tracks provide other Inspector sections. These are described in the following sections.

Inserts Section

Allows you to add insert effects to the track.
**Strip Section**

Allows you to set up the channel strip modules.

**Equalizers Section**

Allows you to adjust the EQs for the track. You can have up to four bands of EQ for each track.

**Sends Section**

Allows you to route the track to one or several FX channels.
Cue Sends Section (Cubase Pro only)

Allows you to route cue mixes to Control Room cues.

Direct Routing Section

Allows you to set up direct routing.

Surround Pan Section (Cubase Pro only)

Shows the SurroundPanner for a track (if used).
Fader Section

Shows a duplicate of the corresponding MixConsole channel.

Notepad Section

Allows you to enter notes about the track.

Quick Controls Section

Allows you to configure quick controls to use remote devices, for example.
FX Channel Track Controls

The Track List for FX channel tracks contains controls and parameters that allow you to edit the settings for the effect.

The track list for FX channel tracks contains the following controls:

**Track name**

Click once to show/hide the basic track settings section. Double-click to rename the track.

**Edit**

Opens the Channel Settings window for the track.

**Mute**

Mutes the track.

**Solo**

Solos the track.

**Read Automation**

Allows you to read track automation.

**Write Automation**

Allows you to write track automation.

**Mute Automation**

Deactivates the automation read function for the selected parameter.

**Automation parameter**

Allows you to select a parameter for automation.

**Toggle Time Base**

Switches between musical (tempo related) and linear (time related) time base for the track.

**Lock**

Disables all editing of all events on the track.

**Bypass Inserts**

Bypasses the inserts for the track.

**Bypass EQs**

Bypasses the equalizers for the track.

**Bypass Sends**

Bypasses the sends for the track.
Channel Configuration

- Shows the channel configuration of the track.

Folder Tracks

Folder tracks function as containers for other tracks, making it easier to organize and manage the track structure. They also allow you to edit several tracks at the same time.

- To add a folder track to your project, select **Project > Add Track > Folder**.

Folder Track Inspector

The Inspector for folder tracks shows the folder and its underlying track, much like a folder structure in the Windows Explorer or the Mac OS X Finder. When you select the one of the tracks shown under the folder, the Inspector shows the settings for that track.

The folder track Inspector contains the following basic track settings:

**Track name**

- Double-click to rename the track.

**Mute**

- Mutes the track.

**Solo**

- Solos the track.

**Record enable**

- Activates the track for recording.

**Monitor**

- Routes incoming signals to the selected output.

**Group Editing**

- Allows you to activate the group editing mode.

**Lock**

- Disables all editing of all events on the track.
Folder Track Controls

The Track List for folder tracks contains controls and parameters that allow you to edit all tracks in the folder.

The track list for folder tracks contains the following controls:

Expand/Collapse
	Shows/hides the tracks in the folder. Hidden tracks are played back as usual.

Track name
	Double-click to rename the track.

Mute
	Mutes the track.

Solo
	Solos the track.

Record enable
	Activates the track for recording.

Monitor
	Routes incoming signals to the selected output.

Group Editing
	Allows you to activate the group editing mode.

Lock
	Disables all editing of all events on the track.

Group Channel Tracks

You can use group channel tracks to create a submix of several audio channels and apply the same effects to them. A group channel track contains no events as such, but displays settings and automation for the corresponding group channel.

All group channel tracks are automatically placed in a special group track folder in the track list, for easy management. Each group channel track has a corresponding channel in the MixConsole. A group channel track can have any number of automation tracks.

- To add a group channel track to your project, select Project > Add Track > Group Channel.
Group Channel Track Inspector

The Inspector for group channel tracks shows the settings for the group channel.

The group channel track Inspector contains the following basic track settings:

**Track name**
- Click once to show/hide the basic track settings section. Double-click to rename the track.

**Edit**
- Opens the Channel Settings window for the track.

**Mute Automation**
- Deactivates the automation read function for the selected parameter.

**Solo**
- Solos the track.

**Read Automation**
- Allows you to read track automation.

**Write Automation**
- Allows you to write track automation.

**Toggle Time Base**
- Switches between musical (tempo related) and linear (time related) time base for the track.

**Lock**
- Disables all editing of all events on the track.

**Volume**
- Allows you to adjust the level for the track.

**Pan**
- Allows you to adjust the panning of the track.

**Output Routing**
- Allows you to specify the output bus for the track.

---

**NOTE**

When you select the group folder track instead, the Inspector shows the folder and the group channels it contains. You can click one of the group channels shown in the folder, to have the Inspector show the settings for that group channel.
Group Channel Track Inspector sections

Apart from the basic track settings that are always shown, group channel tracks provide other Inspector sections. These are described in the following sections.

Inserts Section

Allows you to add insert effects to the track.

Strip Section

Allows you to set up the channel strip modules.
Equalizers Section

![Equalizers Section](image)

Allows you to adjust the EQs for the track. You can have up to four bands of EQ for each track.

Sends Section

![Sends Section](image)

Allows you to route the track to one or several FX channels.

Cue Sends Section (Cubase Pro only)

![Cue Sends Section](image)

Allows you to route cue mixes to Control Room cues.
**Tracks**
*Group Channel Tracks*

**Direct Routing Section**

![Direct Routing Section](image)

Allows you to set up direct routing.

**Surround Pan Section (Cubase Pro only)**

![Surround Pan Section](image)

Shows the **SurroundPanner** for a track (if used).

**Fader Section**

![Fader Section](image)

Shows a duplicate of the corresponding **MixConsole** channel.

**Notepad Section**

![Notepad Section](image)

Allows you to enter notes about the track.
Quick Controls Section

![Quick Controls](image)

Allows you to configure quick controls to use remote devices, for example.

Group Channel Track Controls

The Track List for group channel tracks contains controls and parameters that allow you to edit the settings for the group.

![Group Tracks](image)

The track list for group channel tracks contains the following controls:

**Track name**
- Double-click to rename the track.

**Edit**
- Opens the Channel Settings window for the track.

**Mute**
- Mutes the track.

**Solo**
- Solos the track.

**Read Automation**
- Allows you to read track automation.

**Write Automation**
- Allows you to write track automation.

**Mute Automation**
- Deactivates the automation read function for the selected parameter.

**Automation parameter**
- Allows you to select a parameter for automation.

**Toggle Time Base**
- Switches between musical (tempo related) and linear (time related) time base for the track.

**Lock**
- Disables all editing of all events on the track.
Bypass Inserts
Bypasses the inserts for the track.

Bypass EQs
Bypasses the equalizers for the track.

Bypass Sends
Bypasses the sends for the track.

Channel Configuration
Shows the channel configuration of the track.

Marker Track

You can use the marker track to add and edit markers that help you to locate certain positions quickly.

- To add the marker track to your project, select **Project > Add Track > Marker**.

Marker Track Inspector

The marker track Inspector displays the marker list.

The marker track Inspector contains the following settings:

**Track name**

Double-click to rename the track.

**Edit**

Opens the **Channel Settings** window for the track.

**Marker attributes**

Shows the markers, their IDs, and time positions. Click in the leftmost column for a marker to move the project cursor to the marker position.

Marker Track Controls

The track list for the marker track contains controls and parameters that allow you to edit the marker track.
Tracks
Ruler Track

Track name

Double-click to rename the track.

Lock

Disables all editing of all events on the track.

Locate

Allows you to move the project cursor to the selected marker position.

Cycle

Allows you to select a cycle marker.

Zoom

Allows you to zoom in a cycle marker.

Add Marker

Allows you to add a position marker at the project cursor position.

Add Cycle Marker

Allows you to add a cycle marker at the project cursor position.

Toggle Time Base

Switches between musical (tempo related) and linear (time related) time base for the track.

Ruler Track

You can use ruler tracks to show several rulers with different display formats for the timeline. This is completely independent from the main ruler, as well as rulers and position displays in other windows.

- To add a ruler track to your project, select Project > Add Track > Ruler.

Ruler Track Controls

In the track list for ruler tracks you can change the display format for the ruler.

Right-click the ruler to open the display format pop-up menu.

The following display formats are available:
Bars+Beats
Activates a display format of bars, beats, sixteenth notes, and ticks. By default there are 120 ticks per sixteenth note, but you can adjust this with the MIDI Display Resolution setting in the Preferences dialog (MIDI page).

Seconds
Activates a display format of hours, minutes, seconds, and milliseconds.

Timecode
Activates a display format of hours, minutes, seconds, and frames. The number of frames per second (fps) is set in the Project Setup dialog with the Frame Rate pop-up menu. You can also display subframes by activating Show Timecode Subframes in the Preferences dialog (Transport page).

Samples
Activates a display format of samples.

fps (User)
Activates a display format of hours, minutes, seconds, and frames, with a user-definable number of frames per second. You can also display subframes by activating Show Timecode Subframes (File > Preferences > Transport). On the Transport page, you can also set the frame rate.

NOTE
Ruler tracks are not affected by the display format setting in the Project Setup dialog.

Signature Track

You can use the signature track to add and edit signature events. The signature track's background always shows bars. This is independent of the ruler display format setting.

• To add the signature track to your project, select Project > Add Track > Signature.
Signature Track Inspector

The signature track Inspector displays a list of all time signature events.

The signature track Inspector contains the following settings:

Signatures list

<table>
<thead>
<tr>
<th>Position</th>
<th>Signature</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>4/4</td>
</tr>
</tbody>
</table>

The signature track Inspector contains the following settings:

Signatures list

- Shows a list of all signature events that allows you to edit signature events and their positions.

Signature Track Controls

The track list for the signature track contains controls and parameters that allow you to edit the signature track.

The track list for signature tracks contains the following controls:

Lock

- Disables all editing of all events on the track.

Current Time Signature

- Allows you to change the time signature at the project cursor position.

Open Process Bars Dialog

- Allows you to open the Process Bars dialog.

Tempo Track

You can use the tempo track to create tempo changes within a project.

- To add a tempo track to your project, select Project > Add Track > Tempo.
## Tempo Track Inspector

The tempo track Inspector displays a list of all tempo events.

![Tempo Track Inspector](image)

The tempo track Inspector contains the following settings:

- **Edit**  
  Opens the Tempo Track Editor.

- **Tempo event list**  
  Shows a list of all tempo events that allows you to edit tempo events and their positions.

## Tempo Track Controls

The track list for the tempo track contains controls and parameters that allow you to edit the tempo track.

![Tempo Track Controls](image)

The track list for tempo tracks contains the following controls:

- **Activate Tempo Track**  
  Allows you to activate the tempo track. In this mode, the tempo cannot be changed on the Transport panel.

- **Lock**  
  Disables all editing of all events on the track.

- **Current Tempo**  
  Allows you to change the tempo at the project cursor position.

- **Open Process Tempo Dialog**  
  Allows you to open the Process Tempo dialog.

- **New Tempo Points Type**  
  Allows you to specify whether the tempo should change gradually (Ramp) or instantly (Jump) from the previous curve point to the new one.

- **Visible Tempo Upper/Lower Limit**  
  Allows you to specify the display range. This changes the display scale of the tempo track, but not the tempo setting.
Transpose Track

You can use the transpose track to set global key changes.

- To add the transpose track to your project, select Project > Add Track > Transpose.

Transpose Track Inspector

The transpose track Inspector contains a number of parameters to control the transpose track.

The transpose track Inspector contains the following settings:

**Keep Transpose in Octave Range**

This feature allows you to keep the transposition in the octave range and ensures that nothing is transposed by more than seven semitones.

**Toggle Time Base**

Switches between musical (tempo related) and linear (time related) time base for the track.

Transpose Track Inspector sections

Apart from the basic track settings that are always shown, the transpose track provides other Inspector sections. These are described in the following sections.

Notepad Section

Allows you to enter notes about the track.
### Transpose Track Controls

The track list for the transpose track contains parameters that allow you to control the transpose track.

The track list for the transpose track contains the following settings:

- **Mute Transpose Events**
  - Mutes the track.

- **Keep Transpose in Octave Range**
  - Allows you to keep the transposition in the octave range and ensures that nothing is transposed by more than seven semitones.

- **Toggle Time Base**
  - Switches between musical (tempo related) and linear (time related) time base for the track.

- **Lock**
  - Disables all editing of all events on the track.

### VCA Fader Track (Cubase Pro only)

You can use a VCA fader track to add VCA faders to your project.

- To add a VCA fader track to your project, select **Project > Add Track > VCA Fader**.

**RELATED LINKS**

- VCA Faders (Cubase Pro only) on page 308
- VCA Fader Automation on page 313
- Automation on page 576

### VCA Fader Track Inspector

The **Inspector** for VCA fader tracks shows the settings for the VCA faders.

The **Inspector** contains the following basic track settings:

- **Mute**
  - Mutes the track.
Tracks
VCA Fader Track (Cubase Pro only)

Solo
Solos the track.

Read Automation
Allows you to read track automation.

Write Automation
Allows you to write track automation.

Toggle Time Base
Switches between musical (tempo related) and linear (time related) time base for the track.

Lock
Disables all editing of all events on the track.

Volume
Allows you to adjust the level for the track.

Fader Section

![Fader Section](image)

Shows a duplicate of the corresponding MixConsole channel.

Notepad Section

![Notepad Section](image)

Allows you to enter notes about the track.
Tracks
VCA Fader Track (Cubase Pro only)

Quick Controls Section

Allows you to configure quick controls to use remote devices, for example.

VCA Fader Track Controls

The track list for VCA fader tracks contains controls and parameters that allow you to edit the settings for the VCA fader.

The track list for VCA fader tracks contains the following controls:

Mute
Mutes the track.

Solo
Solos the track.

Edit
Opens the Channel Settings window for the track.

Channel Configuration
Shows the channel configuration of the track.

Read Automation
Allows you to read track automation.

Write Automation
Allows you to write track automation.

Automation parameter
Allows you to select a parameter for automation.

Mute Automation
Deactivates the automation read function for the selected parameter.

Lock
Disables all editing of all events on the track.

Toggle Time Base
Switches between musical (tempo related) and linear (time related) time base for the track.
Video Track

You can use the video track to play back video events. Video files are displayed as events/clips on the video track, with thumbnails representing the frames in the film.

- To add a video track to your project, select Project > Add Track > Video.

Video Track Inspector

The video track Inspector contains a number of parameters to control the video track.

The video track Inspector contains the following settings:

**Reveal Video Window**
- Opens the Video Player window.

**Mute Video Track**
- Mutes the track.

**Show Frame Numbers**
- Allows you to show each thumbnail with the corresponding video frame number.

**Show Thumbnails**
- Allows you to activate/deactivate the thumbnails of a video track.

**Lock**
- Disables all editing of all events on the track.

Video Track Inspector Section

Apart from the basic track settings that are always shown, the video track provides an other Inspector section. This is described in the following section.

Notepad Section

Allows you to enter notes about the track.
Video Track Controls

The track list for the video track contains a number of parameters to control the video track.

The track list for the video track contains the following settings:

**Mute Video Track**

Mutes the track.

**Show Frame Numbers**

Allows you to show each thumbnail with the corresponding video frame number.

**Show Thumbnails**

Allows you to activate/deactivate the thumbnails of a video track.

**Lock**

Disables all editing of all events on the track.

Customizing Track Controls

For each track type you can configure which track controls are shown in the track list. You can also specify the order of controls and group controls so that they are always shown adjacent to each other.

- To open the Track Controls Settings dialog, right-click a track in the track list and select Track Controls Settings from the context menu, or click Open Track Controls Settings Dialog in the bottom right corner of the track list.
Tracks

Customizing Track Controls

- **Track Type**
  - Allows you to select the track type to which your settings are applied.

- **Hidden Controls**
  - This section displays controls currently hidden in the track list.

- **Visible Controls**
  - This section displays controls currently visible in the track list.

- **Width**
  - If you click in this column, you can set the maximum length for the track name.

- **Group**
  - Displays the group number.

- **Add**
  - Allows you to move an item selected in the hidden controls list to the list of visible controls.

- **Remove**
  - Allows you to move an item selected in the visible controls list to the list of hidden controls. All controls can be removed except the **Mute** and **Solo** buttons.

- **Move Up/Move Down**
  - Allows you to change the order of an item in the list of visible controls.
Tracks
Customizing Track Controls

Group
Allows you to group two or more controls selected in the visible controls list that are adjacent to each other. This ensures that they are always positioned side by side in the track list.

Ungroup
Allows you to ungroup grouped controls in the visible controls list. To remove an entire group, select the first (topmost) element belonging to this group and click the Ungroup button.

Reset
Allows you to restore all default track controls settings for the selected track type.

Controls Area Preview
Shows a preview of the customized track controls.

Controls Area Width
Allows you to determine the width of the track control area for the selected track type. In the Controls Area Preview, this area is shown with a black frame.

Presets
Allows you to save track controls settings as presets. To recall a preset, click the Switch Presets button in the bottom right corner of the track list. The name of the selected preset is shown in the left corner.

Track Name Width (global)
Allows you to determine the global name width for all track types.

Apply
Applies your settings.

Reset All
Allows you to restore all default track controls settings for all track types.
Adding Tracks

**PROCEDURE**

1. Select **Project > Add Track**, or right-click the track list.
2. Do one of the following:
   - Add a track of a specific type.
     For some track types a dialog opens that allows you to insert several tracks at once.
   - To add a track based on a track preset, select **Add Track Using Track Preset**.
     The **Choose Track Preset** dialog opens that allows you to select a track preset. The number and type of added tracks depends on the selected track preset.

**RESULT**

The track is added to the project.

**RELATED LINKS**

Add Track Dialog on page 134
Track Presets on page 160

**Add Track Dialog**

The **Add Track** dialog opens when you add audio, MIDI, group/FX/VCA channel, or instrument tracks.

**Browse**

Expands the dialog and allows you to select a track preset for the track.

**Count**

Allows you to enter the number of tracks that you want to add.
**Configuration**

Allows you to set the channel configuration. Audio-related tracks can be configured as mono, stereo, or surround tracks (Cubase Pro only).

**Speakers**

Shows the speaker names according to the track configuration.

**Track Name**

Allows you to specify a track name.

**Add Track**

Adds the track and closes the dialog.

**RELATED LINKS**

Track Presets on page 160

---

**Removing Tracks**

You can remove selected or empty tracks from the track list.

- To remove selected tracks, select **Project > Remove Selected Tracks** or right-click the track that you want to remove, and from the context menu select **Remove Selected Tracks**.
- To remove empty tracks, select **Project > Remove Empty Tracks**.

---

**Moving Tracks in the Track List**

You can move tracks up or down in the track list.

**PROCEDURE**

- Select a track and drag it up or down in the track list.
Renaming Tracks

**PROCEDURE**

1. Double-click the track name and type in a new name for the track.
2. Press [Return].
   - If you want all events on the track to get the same name, hold down any modifier key and press [Return].

**AFTER COMPLETING THIS TASK**

If the **Parts Get Track Names** option (**File > Preferences > Editing**) is activated, and you move an event from one track to another, the moved event will automatically be named according to its new track.

Coloring Tracks

All new tracks are automatically assigned a color according to the **Auto Track Color Mode** settings. However, you can change the track color manually.

- To change the color for the selected track, use the **Select Colors** pop-up menu on the toolbar.

- You can also use the Track Color Selector. In the **Inspector**, click the arrow to the right of the track name and select a color.

- In the track list, [Ctrl]/[Command]-click in the left area and select a color.

- To control which colors are used for new tracks, select **File > Preferences > Event Display > Tracks** and edit the **Auto Track Color Mode** settings.
Showing Track Pictures

You can add pictures to tracks to recognize your tracks easily. Track pictures are available for audio, instrument, MIDI, FX channel and group channel tracks.

PREREQUISITE

Adjust the track height to at least 2 rows.

PROCEDURE

1. Right-click any track in the track list.
2. From the track list context menu, select Show Track Pictures.

If you move the mouse to the left on a track, a highlighted rectangle appears.

AFTER COMPLETING THIS TASK

Double-click the rectangle to open the Track Pictures Browser and set up a track picture.

RELATED LINKS

Track Pictures Browser on page 137

Track Pictures Browser

The Track Pictures Browser allows you to set up and select pictures that can be shown in the track list and in the MixConsole. Track pictures are useful to recognize tracks and channels easily. You can select pictures from the factory content or add new ones to the user library.

- To open the Track Pictures Browser for a track, double-click in the lower left side of the track list.
Track Handling
Showing Track Pictures

**Factory**
Shows the factory content in the pictures browser.

**Pictures Browser**
Shows the pictures that you can assign to the selected track/channel.

**User**
Shows your user content in the pictures browser.

**Import**
Opens a file dialog that allows you to select pictures in bmp, jpeg, or png format and add them to the user library.

**Remove Selected Pictures from User Library**
Removes the selected picture from the user library.

**Reset Current Picture**
Removes the picture from the selected track/channel.

**Show/Hide Preview**
Opens/Closes a section with further color and zoom settings.

**Track Picture Preview**
Shows the current track picture. When you zoom in the picture, you can drag it with the mouse to change its visible part.

**Track Color**
Opens the **Track Color Selector**. Click the rectangle to change the track color.

**Intensity**
Allows you to apply the track color to the track picture and set the color intensity.
Zoom
Allows you to change the size of the track picture.

Rotate
Allows you to rotate the track picture.

Setting the Track Height

You can enlarge the track height to show the events on the track in detail, or you can decrease the height of several tracks to get a better overview of your project.

- To change the height of an individual track, click its lower border in the track list and drag up or down.
- To change the height of all tracks simultaneously, hold down [Ctrl]/[Command], click the lower border of one track, and drag up or down.
- To set the number of tracks to view in the Project window, use the track zoom menu.
- To set the track height automatically when you select a track, click Edit > Enlarge Selected Track.

Related links
Track Zoom Menu on page 139
Customizing Track Controls on page 131

Track Zoom Menu

The track zoom menu allows you to set the number of tracks and the track height in the Project window.

- To open the track zoom menu in the lower right of the Project window, click the arrow button above the vertical zoom control.
The following options are available:

**Zoom Tracks x Rows**
Zooms all track heights to show the specified number of rows.

**Zoom Tracks Full**
Zooms all tracks to fit in the active Project window.

**Zoom x Tracks**
Zooms the specified number of tracks to fit in the active Project window.

**Zoom N Tracks**
Allows you to set the number of tracks to fit in the active Project window.

**Zoom Tracks Minimal**
Zooms all track heights to the minimum size.

**Snap Track Heights**
Changes the track height in fixed increments when you resize it.

### Selecting Tracks

- To select a track, click on it in the track list.
- To select several tracks, [Ctrl]/[Command]-click several tracks.
- To select a continuous range of tracks, [Shift]-click the first and last track in a continuous range of tracks.

Selected tracks are indicated by a light gray color in the track list.

**RELATED LINKS**
- Track Selection follows Event Selection on page 1056
- Scroll To selected Track on page 1061
- Select Channel/Track on Solo on page 1061
- Select Channel/Track on Edit Settings on page 1061

### Selecting Tracks with Arrow Keys

You can select tracks and events with the up/down arrow keys on the computer keyboard. However, you can make the up/down arrow keys exclusively available for selecting tracks.

- To make the up/down arrow keys exclusively available for selecting tracks, select File > Preferences > Editing and activate Use Up/Down Navigation Commands for selecting Tracks only.
The following applies:

- When this option is deactivated and no event/part is selected in the Project window, the up/down arrow keys on the computer keyboard are used to step through the tracks in the track list.

- When this option is deactivated and an event/part is selected in the Project window, the up/down arrow keys still step through the tracks in the track list – but on the currently selected track, the first event/part will automatically be selected as well.

- When this option is activated, the up/down arrow keys are only used to change the track selection – the current event/part selection in the Project window will not be altered.

**Duplicating Tracks**

You can duplicate a track with all contents and channel settings.

**PROCEDURE**

- Select Project > Duplicate Tracks.

**RESULT**

The duplicated track appears below the original track.

**Disabling Audio Tracks**

You can disable audio tracks that you do not want to play back or process at the moment. Disabling a track zeroes its output volume and shuts down all disk activity and processing for the track.

**PROCEDURE**

- Right-click in the track list and select Disable Track from the context menu.

**RESULT**

The track color changes and the corresponding channel in the MixConsole is hidden.

To enable a disabled track and restore all channel settings, right-click in the track list and select Enable Track.
Organizing Tracks in Folder Tracks

You can organize your tracks in folders by moving tracks into folder tracks. This allows you to perform editing on several tracks as one entity. Folder tracks can contain any type of track including other folder tracks.

- To create a folder track, open the Project menu and in the Add Track submenu select Folder.

- To create new folder track and move all selected tracks into it, open the Project menu and from the Track folding submenu select Move Selected Tracks To New Folder.

- To move tracks into a folder, select them and drag them into the folder track.

- To remove tracks from a folder, select them and drag them out of the folder.

- To hide/show tracks in a folder, click the Expand/Collapse Folder button of the folder track.

- To hide/show data on a folder track, open the context menu for the folder track and select an option from the Show Data on Folder Tracks submenu.

- To mute/solo all tracks in a folder track, click the Mute or Solo button for the folder track.

NOTE

Hidden tracks are played back as usual.

Moving Tracks to Folder Tracks

You can move your tracks to folder tracks to organize them and to perform editing on several tracks as one entity. You can move any type of track including other folder tracks to folder tracks.

PROCEDURE

- Select Project > Track Folding > Move Selected Tracks to New Folder.

RESULT

This creates a new folder and moves all selected tracks into it.

NOTE

You can also drag and drop tracks into or out of a folder track.

RELATED LINKS

Folder Tracks on page 114
Folder Track Controls on page 115
Handling Overlapping Audio

The basic rule for audio tracks is that each track can only play back a single audio event at a time. If two or more events overlap, you will only hear one of them: the one that is actually visible (e.g. the last lap of a cycle recording).

If you have a track with overlapping (stacked) events/regions, use one of the following methods to select the event/region that is played back:

- Open the context menu for the audio event in the event display and select the desired event or region from the To Front or Set to Region submenu. The available options depend on whether you performed a linear or a cycle recording and the record mode you used. When recording audio in cycle mode, the recorded event is divided in regions, one for each take.

- Use the handle in the middle of a stacked event and select an entry from the pop-up menu that appears.

Related links:
Working with Lanes on page 145

Track Folding

You can show, hide, or invert tracks that are displayed in the Project window event display. This allows you to divide the project into several parts by creating several folder tracks for the different project elements and showing/hiding their contents by selecting a menu function or using a key command. You can also fold in automation tracks this way.

- To open the Track Folding menu, select Project > Track Folding.

The following options are available:

Toggle Selected Track
Reverses the fold state of the selected track.

Fold Tracks
Folds in all open folder tracks in the Project window.

Note
The behavior of this function depends on the Deep Track Folding setting in the Preferences dialog.
Track Handling
How Events are Displayed on Folder Tracks

Unfold Tracks
Unfolds all folder tracks in the Project window.

NOTE
The behavior of this function depends on the Deep Track Folding setting in the Preferences dialog.

Flip Fold States
Flips the fold states of the tracks in the Project window. This means that all tracks that were folded in will be unfolded and all unfolded tracks will be folded in, respectively.

Move Selected Tracks to New Folder
Moves all selected tracks to the folder track. This menu option is available, if at least one folder track is available.

NOTE
You can assign key commands for these menu options in the Key Commands dialog in the Project category.

The following option also affects the track folding behavior:

Deep Track Folding
To activate this option, select File > Preferences > Editing > Project & MixConsole.

If this option is activated, any folding settings that you make on the Track Folding submenu of the Project menu also affect the subelements of the tracks. For example, if you fold in a folder track that contains 10 audio tracks, of which 5 have several open automation tracks, all these audio tracks within the folder track will also be folded in.

How Events are Displayed on Folder Tracks

Closed folder tracks can display data of the contained audio, MIDI, and instrument tracks as data blocks or as events.

When you close folder tracks, the contents of the contained tracks are displayed as data blocks or events. Depending on the folder track height, the display of the events can be more or less detailed.
Modifying Event Display on Folder Tracks

You can modify the event display on folder tracks.

**PROCEDURE**

1. Right-click the folder track.
2. On the context menu, select **Show Data on Folder Tracks**.

You have the following options:

- **Always Show Data**
  If this option is activated, data blocks or event details are always displayed.

- **Never Show Data**
  If this option is activated, nothing is displayed.

- **Hide Data When Expanded**
  If this option is activated, the display of events is hidden when you open folder tracks.

- **Show Event Details**
  If this option is activated, event details are displayed. If deactivated, data blocks are displayed.

**NOTE**

To change these settings, select **File > Preferences > Event Display > Folders**.

**RELATED LINKS**

- Event Display - Folders on page 1065

Working with Lanes

The descriptions in the following paragraphs focus on cycle recordings with takes. However, you can also apply lane operations and comping methods on overlapping events or parts that you assemble on one track.

If you perform a cycle recording in the **Keep History** or **Cycle History + Replace** modes (audio) or in the **Stacked** or **Mix-Stacked** modes (MIDI), the recorded cycle laps are shown on the track with the last recorded take active and on top.

The **Show Lanes** mode gives you a good overview of all your takes. If you activate the **Show Lanes** button, the recorded takes are shown on separate lanes.
Lanes are handled differently, depending on whether you work with audio or MIDI:

**Audio**

As each audio track can only play back one single audio event at a time, you only hear the take that is activated for playback, for example, the last lap of a cycle recording.

**MIDI**

Overlapping MIDI takes (parts) can be played back simultaneously. If you recorded in Mix-Stacked mode, you hear all takes from all cycle laps.

Lanes can be reordered, sized, and zoomed like regular tracks.

To solo a lane, you can activate the Solo button for it. This allows you to hear the lane in the project context. If you want to hear the take without the project context, you also have to activate the main track’s Solo button.

### Assembling a Perfect Take

You can play back, cut, and activate takes to combine the best parts of your recording in a final take.

**PROCEDURE**

1. Select the Comp tool or the Object Selection tool.
2. Bring a take to front to select it for playback, and listen to it.
3. Audition different takes to compare them in more detail.
4. If necessary, cut your takes into smaller sections, create new ranges, and bring them to front.
5. Proceed until you are satisfied with the result.

**AFTER COMPLETING THIS TASK**

After assembling your perfect take, you can improve your take.

- To automatically resolve overlaps and remove empty lanes, right-click the track and select Clean Up Lanes.

For audio, proceed as follows:

- Apply auto fades and crossfades to the comped takes.
- To put all takes on a single lane, and remove all takes in the background, select all takes and select Audio > Advanced > Delete Overlaps.
- To create a new and continuous event of all selected takes, select Audio > Bounce Selection.

For MIDI, proceed as follows:

- Open your takes in a MIDI editor to perform fine adjustments like removing or editing notes.
• To create a new and continuous part of all selected takes that is placed on a single lane, select all takes and select MIDI > Bounce MIDI.

• To create a new part and place it on a new track, select MIDI > Merge MIDI in Loop.

Finally, clean up the lanes as follows:

• Right-click a track and select Create Tracks from Lanes. The lane is converted into a new track.

### Assembling Operations

Unless it is clearly stated, all operations can be performed in the Project window and in the Audio Part Editor. Snap is taken into account, and all operations can be undone.

To assemble a perfect take, you can use the Comp tool, the Object Selection tool, or the Range Selection tool.

- The Comp tool modifies all takes on all lanes simultaneously. This is useful if the recorded takes have the same start and end positions.

- The Object Selection tool and the Range Selection tool affect single takes on individual lanes. If this is not what you want, you can either perform your edits on the main track or use the Comp tool.

**NOTE**

If you assemble stacked events on an audio track, select File > Preferences > Editing > Audio, and deactivate Treat Muted Audio Events like Deleted.

The following operations can be performed:

<table>
<thead>
<tr>
<th>Operation</th>
<th>Comp tool</th>
<th>Object Selection/Range Selection tool</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select</td>
<td>Hold down [Shift] and click on a take.</td>
<td>Click on a take.</td>
</tr>
<tr>
<td>Bring to front</td>
<td>Click on a take. Click twice to toggle.</td>
<td>Position the mouse pointer over the middle of the lower border of a take until it changes to a Comp symbol, and click. Click twice to toggle. For MIDI this mutes/unmutes a take.</td>
</tr>
<tr>
<td>(Project window only)</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
## Track Handling

### Working with Lanes

<table>
<thead>
<tr>
<th>Operation</th>
<th>Comp tool</th>
<th>Object Selection/Range Selection tool</th>
</tr>
</thead>
<tbody>
<tr>
<td>Comp (create a new range and bring it to front, <strong>Project</strong> window only)</td>
<td>Click and drag on a lane. All takes are cut at the range start and end. If the audio takes are adjacent without gaps or fades and the material itself matches, the takes are merged within the range.</td>
<td>-</td>
</tr>
<tr>
<td>Audition</td>
<td>Press [Ctrl]/[Command] to activate the <strong>Speaker</strong> tool and click at the position where you want playback to start.</td>
<td>See left.</td>
</tr>
<tr>
<td>Move</td>
<td>Click and drag on the main track.</td>
<td>Click and drag on any lane.</td>
</tr>
<tr>
<td>Resize</td>
<td>Drag the resize handles. All takes with the same start and end positions are affected. Resizing is constrained to the end or start of the adjacent takes. This ensures that you do not create overlaps accidentally.</td>
<td>Drag the resize handles.</td>
</tr>
<tr>
<td>Correct timing (Slip Event)</td>
<td>Select a take, hold down [Alt]/[Option]-[Shift] (the tool modifier for Slip Event) and drag with the mouse.</td>
<td>See left.</td>
</tr>
<tr>
<td>Cut</td>
<td>[Alt]/[Option]-click on a take. If you cut a MIDI part and the cut position intersects one or several MIDI notes, the result depends on the <strong>Split MIDI Events</strong> option (<strong>File &gt; Preferences &gt; Editing &gt; MIDI</strong>).</td>
<td>See left.</td>
</tr>
<tr>
<td>Adjust cuts</td>
<td>Position the mouse pointer over a cut and drag to the left or to the right.</td>
<td>See left.</td>
</tr>
<tr>
<td>Glueing cuts</td>
<td>Bring a new range to front. Select a range spanning all the cuts that you want to glue, and double-click.</td>
<td></td>
</tr>
</tbody>
</table>

**RELATED LINKS**

*Splitting Events on page 184*
Track Handling
Defining the Track Time Base

The time base of a track determines if the events on a track are positioned to bars and beats (musical time base) or to the timeline (linear time base). Changing the playback tempo affects only the time position of events on tracks with a musical time base.

**PROCEDURE**

- In the track list, click **Toggle Timebase** to change the time base.

**RESULT**

Musical time base is indicated by a note symbol, linear time base is indicated by a clock symbol.

Musical track time base

Time linear track time base

**NOTE**

Switching between linear and musical time base results in a very small loss of positioning precision. Therefore you should avoid switching repeatedly between the two modes.

**RELATED LINKS**

- [Editing tempo and signature on page 900](#)
Defining the Default Track Time Base (Cubase Pro only)

You can specify the default track time type for new tracks (audio, group/FX, MIDI, and marker tracks).

PROCEDURE

- Select File > Preferences > Editing and from the Default Track Time Type pop-up menu, select a default track time type.

RESULT

If you selected Follow Transport Main Display, the primary time format setting on the Transport panel is used. When this is set to Bars+Beats, tracks with musical time base are added. When this is set to any of the other options (Seconds, Timecode, Samples, etc.), all new tracks use linear time base.

RELATED LINKS

Default Track Time Type on page 1054

TrackVersions

TrackVersions allow you to create and manage multiple versions of events and parts on the same track.

TrackVersions are available for audio, MIDI, and instrument tracks. You can also have TrackVersions of the chord track, the signature track, and the tempo track.

TrackVersions are useful for the following tasks:

- Starting new recordings from scratch.
- Comparing different takes and compns.
- Managing takes that were recorded in a multi-track recording.

NOTE

TrackVersions are not available for automation tracks.

TrackVersions are included in track archives and project backups.

The TrackVersion key commands can be found in the TrackVersions category of the Key Commands dialog.
TrackVersions Pop-Up Menu

The **TrackVersions** pop-up menu is available for all track types that support TrackVersions. It contains the most important functions for managing TrackVersions and a TrackVersions list.

To open the **TrackVersions** pop-up menu for a track, click the arrow to the right of the track name.

The following options are available:

**TrackVersion List**

Lists all TrackVersions of the track for which you opened the **TrackVersions** pop-up menu and allows you to activate a TrackVersion.

**New Version**

Creates a new, empty TrackVersion for the selected tracks.

**Duplicate Version**

Creates a copy of the active TrackVersion for the selected tracks.

**Rename Version**

Opens a dialog that allows you to change the TrackVersion name for the selected tracks.

**Delete Version**

Deletes the active TrackVersion for the selected tracks.

**Select Tracks with Same Version ID**

Selects all tracks that have a TrackVersion with the same ID.
TrackVersions Inspector Section

The TrackVersions Inspector section allows you to view and manage TrackVersions for a selected track. It is available for audio tracks, MIDI tracks, instrument tracks, and the chord track.

To open the TrackVersions Inspector section for a track, select the track, and in the Inspector, click the TrackVersions tab.

1) Name column
   Shows the version name. Double-click to change it. The name will be changed for all selected tracks.

2) ID column
   Shows the TrackVersion ID.

3) Track Version Indicator
   Indicates that more than one TrackVersion exists.

4) Track Version list
   Lists all TrackVersions and allows you to activate one of them for all selected tracks.

5) New Version
   Creates a new, empty TrackVersion for all selected tracks.

6) Duplicate Version
   Creates a copy of the active TrackVersion for all selected tracks.

7) Delete Version
   Deletes the active TrackVersion for all selected tracks. This function is only available if the track has more than one TrackVersion.
Creating New TrackVersions

You can create new, empty TrackVersions for selected tracks.

**PROCEDURE**

1. In the track list, select the tracks for which you want to create a new TrackVersion.
2. Select **Project > TrackVersions > New Version**.

**NOTE**

You can also use the TrackVersions Inspector (only available for audio tracks, MIDI tracks, instrument tracks, and the chord track) or the TrackVersions pop-up menu in the track list to create a new TrackVersion.

**RESULT**

The event display shows a new, empty TrackVersion. Events of previous TrackVersions are hidden. The track list shows a default version name.

TrackVersion IDs

All TrackVersions are automatically assigned an ID. TrackVersions that are created together get the same TrackVersion ID and can be selected together.

In the TrackVersions Inspector, the TrackVersion ID is shown in the ID column of the TrackVersion list.

In the track list, you can open the TrackVersions pop-up menu to see the TrackVersion ID.

Selecting Tracks by TrackVersion ID

You can simultaneously select all tracks that share the same TrackVersion ID.

**PROCEDURE**

1. Activate the TrackVersion.
2. Select **Project > TrackVersions > Select Tracks with same Version ID**.

**RESULT**

All tracks that have TrackVersions with the same ID are selected.
Assigning a Common ID

TrackVersions on different tracks that were not created together have different TrackVersion IDs. TrackVersions with different IDs cannot be activated together. To do this, you must assign a new version ID to these tracks.

**PROCEDURE**

1. Select the tracks and activate the TrackVersions to which you want to assign a common version ID.
2. Select Project > TrackVersions > Assign Common Version ID.

**RESULT**

A new ID is assigned to all active TrackVersions on the selected tracks. The tracks are now marked as belonging together. You can now activate them together.

**Active TrackVersion**

If you created more than one TrackVersion for a track, you can show the events of a specific TrackVersion in the event display. This process is referred to as activating TrackVersions.

**Activating TrackVersions**

**PROCEDURE**

1. Click the arrow to the right of the track name to open the TrackVersions pop-up menu.
2. Select the TrackVersion that you want to activate.

**RESULT**

The selected version is activated and its events are shown in the event display.

**NOTE**

If you work with audio tracks, MIDI tracks, instrument tracks, or the chord track, you can also use the TrackVersions Inspector to activate a TrackVersion.
Activating TrackVersions on Multiple Tracks

You can simultaneously activate TrackVersions on multiple tracks if these TrackVersions share the same ID.

**PROCEDURE**

1. Select all tracks for which you want to activate a specific TrackVersion.
2. Click the arrow to the right of the track name to open the TrackVersions pop-up menu.
3. Select the TrackVersion that you want to activate from the list.

**RESULT**

The selected TrackVersion is activated for all selected tracks, and the corresponding events are shown in the event display.

**NOTE**

If you work with audio tracks, MIDI tracks, instrument tracks, or the chord track, you can also use the TrackVersions Inspector to activate a TrackVersion.

Duplicating TrackVersions

You can duplicate a TrackVersion by creating a new TrackVersion that contains a copy of the active TrackVersion.

**PROCEDURE**

1. In the track list, select the tracks and activate the TrackVersion that you want to duplicate.
2. Select **Project > TrackVersions > Duplicate Version**.

In the event display, a duplicate TrackVersion is displayed. In the track list, a default version name for the duplicate is shown.

**NOTE**

You can also use the TrackVersions Inspector (audio tracks, MIDI tracks, instrument tracks, and chord track only) or the TrackVersions pop-up menu in the track list to duplicate a TrackVersion.
Deleting TrackVersions

You can delete the active TrackVersions for the selected tracks.

**PROCEDURE**

1. Select the tracks and activate the TrackVersions that you want to delete.
2. Select **Project > TrackVersions > Delete Version**.

**NOTE**

You can also use the **TrackVersions Inspector** (audio tracks, MIDI tracks, instrument tracks, and chord track only) or the **TrackVersions** pop-up menu in the track list to delete the active TrackVersion for selected tracks.

Copying and Pasting Selection Ranges Between TrackVersions

You can copy and paste ranges between different TrackVersions, even across multiple tracks.

**PREREQUISITE**

You have at least 2 TrackVersions.

**PROCEDURE**

1. Select the **Range Selection** tool.
2. Select a range of the TrackVersion that you want to copy.
3. Select **Edit > Copy**.
4. Activate the TrackVersion into which you want to insert the copied range.
5. Select **Edit > Paste**.

**RESULT**

The copied range from the first TrackVersion is pasted to the second TrackVersion at the exact same position.

**NOTE**

If you want to perform more complicated comping tasks, we recommend to select **Project > TrackVersions > Create Lanes from Versions** and proceed with the **Comp** tool.
Copy and Pasting Selected Events between TrackVersions

You can copy and paste selected events between different TrackVersions, even across multiple tracks.

PREREQUISITE

You have at least 2 TrackVersions, and you have split the corresponding events with the Cut tool, for example.

PROCEDURE

1. Select the Object Selection tool.
2. Select the events that you want to copy.
3. Select Edit > Copy.
4. Activate the TrackVersion into which you want to insert the copied events.
5. Select Edit > Functions > Paste at Origin.
   This ensures that the events are inserted at the exact same position.

RESULT

The copied events from the first TrackVersion are pasted to the second TrackVersion at the exact same position.

TrackVersion Names

Each TrackVersion has a default TrackVersion name.

If more than one version is available for the track, the TrackVersion name is shown in the track list and in the TrackVersions Inspector section. By default, TrackVersions are named v1, v2, etc. However, you can rename each TrackVersion to your liking.
Renaming a TrackVersion

**PROCEDURE**

- In the TrackVersions Inspector section, double-click the TrackVersion name and enter a new name.
  
The name is changed. If the available space in the track list is too small, the name is abbreviated automatically.

Renaming TrackVersions on Multiple Tracks

**PROCEDURE**

1. Activate all TrackVersions that you want to rename, and select the corresponding tracks.
2. Select Project > TrackVersions > Rename Version.
3. Enter a new TrackVersion name and click OK.

**RESULT**

In the track list, the new TrackVersion name is shown.
If you want to assign the same ID to TrackVersions, select **Project > TrackVersions > Assign Common Version ID**.

### TrackVersions vs. Lanes

TrackVersions and lanes are individual features that complement each other. Every TrackVersion can have its own set of lanes.

### Creating Lanes from TrackVersions

If your project contains TrackVersions and you want to continue working with lanes, using the **Comp** tool, for example, you can create lanes from TrackVersions.

**PROCEDURE**

1. Select the tracks for which you want to create lanes.
2. Select **Project > TrackVersions > Create Lanes from Versions**.
   
   A new TrackVersion named **Lanes from Version** is added. This TrackVersion contains all TrackVersions on separate lanes. The original TrackVersions are kept. Lanes that you create from MIDI TrackVersions are muted.
3. In the track list or in the **Inspector**, activate the **Show Lanes** button for the track.
4. On the **Project** window toolbar, activate the **Comp** tool and continue as usual.

### Creating TrackVersions from Lanes

If your project contains lanes and you want to continue working with the TrackVersion functions, you can create TrackVersions from lanes.

**PROCEDURE**

1. Select the tracks for which you want to create TrackVersions.
   
   If you only want to convert specific lanes, select these lanes.
2. Select **Project > TrackVersions > Create Versions from Lanes**.

**RESULT**

New TrackVersions are added, one for each separate lane. The original lanes are kept. Any crossfades that you have created between different lanes are discarded.
Track Presets

Track presets are templates that can be applied to newly created or existing tracks of the same type.

You can create them from virtually all track types (audio, MIDI, instrument, group, FX, VST instrument return, input, and output channels). They contain sound and channel settings, and allow you to quickly browse, preview, select, and change sounds, or reuse channel settings across projects.

Track presets are organized in the MediaBay. There, you can categorize them with attributes.

Audio Track Presets

Track presets for audio tracks, group tracks, FX tracks, VST instrument channels, input channels, and output channels include all settings that define the sound.

You can use the factory presets as a starting point for your own editing and save the audio settings that you optimized for an artist that you often work with as a preset for future recordings.

The following data is saved in audio track presets:

- Insert effects settings (including VST effect presets)
- EQ settings
- Volume and pan
- Input gain and phase

NOTE
To access the track presets functions for input and output channels, activate the Write buttons for input and output channels in the MixConsole. This creates input and output channel tracks in the track list.

Instrument Track Presets

Instrument track presets offer both MIDI and audio features and are the best choice when handling sounds of simple, mono-timbral VST instruments.

Use instrument track presets for auditioning your tracks or saving your preferred sound settings, for example. You can also extract sounds from instrument track presets for use in instrument tracks.

The following data is saved in instrument track presets:

- Audio insert effects
- Audio EQ
- Audio volume and pan
Track Handling
Track Presets

- Audio input gain and phase
- MIDI insert effects
- MIDI track parameters
- Input Transformer settings
- The VST instrument used for the track
- Staff settings
- Color settings
- Drum map settings

MIDI Track Presets

You can use MIDI track presets for multi-timbral VST instruments. You can also use them for external instruments.

When creating MIDI track presets you can either include the currently set channel or the currently set patch.

- To ensure that saved MIDI track presets for external instruments will work again with the same instrument, install the instrument as a MIDI device, see the separate PDF document MIDI Devices.

The following data is saved in MIDI track presets:

- MIDI modifiers (Transpose, etc.)
- MIDI insert effects
- Output and Channel or Program Change
- Input Transformer settings
- Volume and pan
- Staff settings
- Color settings
- Drum map settings

Multi-Track Presets

You can use multi-track presets, for example, when recording setups that require several microphones (a drum set or a choir, where you always record under the same conditions) and you have to edit the resulting tracks in a similar way. Furthermore, they can be used when working with layered tracks, where you use several tracks to generate a certain sound instead of manipulating only one track.
If you select more than one track when creating a track preset, the settings of all selected tracks are saved as one multi-track preset. Multi-track presets can only be applied if the target tracks are of the same type, number, and sequence as the tracks in the track preset, therefore, they should be used in recurring situations with similar tracks and settings.

VST Presets

VST instrument presets behave like instrument track presets. You can extract sounds from VST presets for use in instrument tracks.

The following data is saved in VST instrument presets:

- VST instrument
- VST instrument settings

**NOTE**

Modifiers, inserts, and EQ settings are not saved.

VST effect plug-ins are available in VST 3 and VST 2 format.

**NOTE**

In this manual, VST presets stands for VST 3 instrument presets, unless stated otherwise.

Pattern Banks

Pattern banks are presets that are created for the Beat Designer MIDI effect. They behave much like track presets.

**RELATED LINKS**

- Previewing Pattern Banks on page 538
- Track Presets on page 160

Applying Track Presets

When you apply a track preset, all the settings that are saved in the preset are applied.

Track presets can be applied to tracks of their own type only. The only exception are instrument tracks: for these, VST presets are also available.
NOTE

- Once a track preset is applied, you cannot undo the changes. It is not possible to remove an applied preset from a track and return to the previous state. If you are not satisfied with the track settings, you have to either edit the settings manually or apply another preset.

- Applying VST presets to instrument tracks leads to removal of modifiers, MIDI inserts, inserts, or EQs. These settings are not stored in VST presets.

## Loading Track or VST Presets

**PROCEDURE**

1. In the **Project** window, select a track.
2. Do one of the following:
   - In the **Inspector**, click **Load Track Preset**.
   - In the track list, right-click the track and select **Load Track Preset**.
3. In the **Presets** browser, select a track or VST preset.
4. Double-click the preset to load it.

**RESULT**

The preset is applied.

**NOTE**

You can also drag and drop track presets from the MediaBay, the Windows Explorer, or the Mac OS Finder onto a track of the same type.

### RELATED LINKS

[Filters Section on page 539](#)

## Loading Multi-Track Presets

**PROCEDURE**

1. In the **Project** window, select several tracks.

   **NOTE**

   Multi-track presets can only be applied if track type, number, and sequence are identical for the selected tracks and the track preset.

2. In the track list, right-click the track and select **Load Track Preset**.
3. In the **Presets** browser, select a multi-track preset.
4. Double-click the preset to load it.

**RESULT**

The preset is applied.
Loading Inserts and EQ from Track Presets

Instead of loading complete track presets, you can also apply insert or equalizer settings from track presets.

PROCEDURE
1. Select a track, open the Inspector or the Channel Settings window, and click the VST Sound button on the Inserts or Equalizers tab/section.
2. Select From Track Preset.
3. In the Presets browser, select a track preset.
4. Double-click the preset to load the settings.

Extracting the Sound from an Instrument Track or VST Preset

For instrument tracks, you can extract the sound of an instrument track preset or VST preset.

PROCEDURE
1. Select the instrument track to which you want to apply a sound.
2. In the Inspector, click VST Sound.
3. In the Presets browser, select an instrument track preset or VST preset.
4. Double-click the preset to load the settings.

RESULT
The VST instrument and its settings (but no inserts, EQs, or modifiers) on the existing track are overwritten with the data of the track preset. The previous VST instrument for this instrument track is removed and the new VST instrument with its settings is set up for the instrument track.

Creating a Track Preset

You can create a track preset from a single track or from a combination of tracks.

PROCEDURE
1. In the Project window, select one or more tracks.
2. In the track list, right-click one of the selected tracks and select Save Track Preset.
3. In the New Preset section, enter a name for the new preset.
   
   NOTE
   You can also define attributes for the preset.

4. Click OK to save the preset and exit the dialog.
RESULT

Track presets are saved within the application folder in the Track Presets folder. They are saved in default subfolders named according to their track type: audio, MIDI, instrument, and multi.

RELATED LINKS

Attribute Inspector on page 544

Track Quick Control Presets

For audio, instrument, MIDI, FX, and group tracks, you can save and load your own Quick Control assignments as presets or use the factory presets.

Saving/Loading Track Quick Control Assignments as Presets

PROCEDURE

1. In the Inspector for your track, open the Quick Controls section. For instrument tracks, the track quick controls are set to the 8 default VST quick controls of the loaded instrument by default.
2. Click Preset Management in the top right corner of the Inspector section and select one of the presets.

The Track Quick Control assignment changes and gives you access to the channel parameters.

NOTE

You can also make your own assignments and save them as presets and delete, rename, or reset the presets to the default assignments.
Parts and events are the basic building blocks in Cubase.

The tracks in the Project window contain parts and/or events. Different event types are handled differently in the Project window:

- Video events and automation events (curve points) are always viewed and rearranged directly in the Project window.
- MIDI events can always be found in MIDI parts, which are containers for one or more MIDI events. MIDI parts are rearranged and manipulated in the Project window. To edit the individual MIDI events in a part, you have to open the part in a MIDI editor.
- Audio events can be displayed and edited directly in the Project window, but you can also work with audio parts containing several events. This is useful if you have a number of events which you want to treat as one unit in the project. Audio parts also contain information about the time position in the project.

NOTE

If the “Object Selection tool: Show Extra Info” option is activated in the Preferences dialog (Editing–Tools page), a tooltip will be shown for the Object Selection tool, displaying information depending on where you point it. For example, in the Project window event display, the tool will show the current pointer position and the name of the track and event you are pointing at.

The Preferences dialog contains several settings for customizing the display in the Project window.

RELATED LINKS

- Event Display on page 1063
- Event Display - MIDI on page 1065
- Event Display - Chords on page 1066
- Event Display - Tracks on page 1066
Audio Handling

When you work with audio files, it is crucial to understand how audio is handled in Cubase.

When you edit or process audio in the Project window, you always work with an audio clip that is automatically created on import or during recording. This audio clip refers to an audio file on the hard disk that itself remains untouched. This means, that audio editing and processing is “non-destructive”, in the sense that you can always undo changes or revert to the original versions.

Audio Clips

An audio clip does not necessarily refer to just one original audio file!

If you apply some processing to a specific section of an audio clip, for example, this will create a new audio file containing only this section. The processing will then be applied to the new audio file only, leaving the original audio file unchanged. Finally, the audio clip is automatically adjusted, so that it refers both to the original file and to the new, processed file. During playback, the program will switch between the original file and the processed file at the correct positions. You will hear this as a single recording, with processing applied to one section only. This feature makes it possible to undo processing at a later stage, and to apply different processing to different audio clips that refer to the same original file.

Audio Events

An audio event is the object that you place on a time position in Cubase.

If you make copies of an audio event and move them to different positions in the project, they will still all refer to the same audio clip. Furthermore, each audio event has an Offset value and a Length value. These determine at which positions in the clip the event will start and end, i.e. which section of the audio clip will be played back by the audio event. For example, if you resize the audio event, you will just change its start and/or end position in the audio clip – the clip itself will not be affected.

Audio Regions

An audio region is a section within a clip with a length value, a start time, and a snap point.

Audio regions are shown in the Pool and are best created and edited in the Sample Editor.

NOTE

If you want to use one audio file in different contexts, or if you want to create several loops from one audio file, convert the corresponding regions of the audio clip to events and bounce them into separate audio files. This is necessary since different events that refer to the same clip access the same clip information.
Parts

Parts are containers for MIDI or audio events, and for tracks.

RELATED LINKS
Folder Parts on page 171

Creating MIDI Parts

A MIDI part is automatically created when you record. It contains the recorded events. However, you can also create empty MIDI parts and later add events to them.

You can create MIDI parts in the following ways:

- Draw a part on a MIDI track with the Draw tool.
  You can also draw parts by pressing [Alt]/[Option] and using the Object Selection tool.

- Double-click with the Object Selection tool on a MIDI track, between the left and right locator.

Adding Events to a MIDI Part

- To add events to a MIDI part, use the tools and functions in a MIDI editor.

RELATED LINKS
MIDI Editors on page 686

Creating Audio Parts

There is no way of automatically creating audio parts on recording. On recording audio events are created always.

You can create audio parts in the following ways:

- To gather existing audio events into a part, select Audio > Events to Part.
  This creates an audio part containing all selected audio events on the same track.

  To remove the part and make the events appear as independent objects on the track again, select the part and select Audio > Dissolve Part.
Parts and Events
Auditioning Audio Parts and Events

- Draw a part on an audio track with the Draw tool. You can also draw parts by pressing [Alt]/[Option] and using the Object Selection tool.
- Double-click with the Object Selection tool on an audio track, between the left and right locator.

**NOTE**
You can use copy and paste or drag and drop in the Audio Part Editor to add events to existing audio parts.

**RELATED LINKS**
Audio Part Editor on page 492

**Auditioning Audio Parts and Events**

Audio parts and events can be auditioned in the Project window with the Play tool.

**PROCEDURE**
1. Select the Play tool.
2. Click where you want playback to start, and keep the mouse button pressed. Only the track on which you click is played back, starting at the click position.

**NOTE**
When auditioning, audio will be routed directly to the Control Room (Cubase Pro only), if the Control Room is activated. When the Control Room is deactivated, the audio will be routed to the default output bus, bypassing the audio channel’s settings, effects and EQs. In Cubase Artist, the Main Mix bus is always used for monitoring.

3. Release the mouse button to stop playback.

**Adding Events to a Track**

To add events to a track, do one of the following:

- Record.
- Drag and drop files on the track.

You can drag from the following locations: the desktop, the MediaBay and its related windows, the Pool, a library (a pool file that is not attached to a project) (Cubase Pro only), the Find media dialog, another open Project window, the Audio Part Editor, the Sample Editor (press [Ctrl]/[Command] and drag to create an event of the current selection, or click in the left column of the region list and drag to create an event from a region).
• Grab audio CD tracks and convert them to audio files.

• Use Copy and Paste on the Edit menu.
  This allows you to copy all kinds of events between projects. You can also copy events within the project, for example, from the Sample Editor.

• Draw marker or automation tracks.
  For audio, MIDI, and instrument tracks, you can only draw parts.

• Import audio or video files via the File > Import menu.
  When you import a file this way, a clip is created for the file and an event that plays the whole clip is inserted on the selected track, at the position of the project cursor.

• Import audio or video files via the File > Import menu.
  Import only the audio portion of a video file and convert it to an audio file via the File > Import menu.

**RELATED LINKS**
- Basic Recording Methods on page 212
- MediaBay on page 522
- Exporting and importing standard MIDI files on page 1021
- Importing audio CD tracks on page 1013
- About Thumbnails on page 985
- Creating MIDI Parts on page 168
- Creating Audio Parts on page 168

---

**Scrubbing**

Scrubbing can be quite a burden on your system. If playback problems occur, try deactivating the “Use High Quality Scrub Mode” option in the Preferences dialog (Transport–Scrub page). The resampling quality will then be lower, but scrubbing will be less demanding on the processor. This can be useful when scrubbing in large projects.

You can adjust the volume of the Scrub function in the Preferences dialog (Transport–Scrub page).

When scrubbing with the mouse, insert effects are always bypassed.

---

**Using the Scrub Tool**

The Scrub tool allows you to locate positions in MIDI or audio parts and in audio events by playing back, forwards or backwards, at any speed.

**PROCEDURE**

1. Select the Play tool and click a second time on the icon.
   A pop-up menu opens.
2. Select “Scrub”.
3. Click your event or part and keep the mouse button pressed.
The project cursor moves to the position where you click. The mouse pointer is not visible anymore.
4. Drag to the left or right.
The project cursor moves correspondingly and the event or part is played back. The speed and thus the pitch of the playback depend on how fast you move the mouse.

**NOTE**
You can also scrub all audio and video tracks of your project with the Jog wheel and Shuttle Speed control on the Transport panel. In this case, MIDI events are ignored.

---

**Folder Parts**

A folder part is a graphic representation of events and parts on the tracks in the folder. Folder parts indicate the position and length of the events and parts, as well as on which track they are (their vertical position). If part colors are used, these are also shown in the folder part.

**Editing Folder Parts**

Any editing that you perform in the *Project* window to a folder part affects all the events and parts it contains.

You can select several folder parts and edit them at the same time. The editing you can perform includes:

- Moving a folder part.
  This moves its contained events and parts, possibly resulting in other folder parts, depending on how the parts overlap.

- Using cut, copy, and paste.

- Deleting a folder part. This will delete its contained events and parts.

- Splitting a folder part with the **Cut** tool.

- Gluing folder parts together with the **Glue** tool. This will only work if the adjacent folder parts contain events or parts on the same track.

- Resizing a folder part resizes the contained events and parts according to the selected resizing method.

- Muting a folder part. This will mute its contained events and parts.

Tracks inside a folder can be edited as one entity by performing the editing directly on the folder part containing the tracks. You can also edit individual tracks within the folder by showing the contained tracks, selecting parts and opening editors as usual.
To open the editor for the track classes that are present in a folder part, double-click the folder part.

All MIDI parts that are located on the tracks within the folder are displayed as if they were on the same track, just like when opening the Key Editor with several MIDI parts selected.

To be able to discern the different tracks in the editor, give each track a different color in the Project window and use the Part Colors option in the editor.

If the folder contains tracks with audio events and/or audio parts, the Sample and/or Audio Part Editors are opened with each audio event and audio part in a separate window.

 RELATED LINKS
  Coloring Notes and Events on page 690

Render in Place

Render in Place is a function that lets you create new audio files from existing material.

Render in Place allows you to render source material to output files that you can use in other projects or outside Cubase.

You can render the following:

- Audio tracks
- Instrument tracks
- Audio events or parts on audio tracks
- MIDI parts on instrument tracks
- Range selections on audio or instrument tracks
- Range selections on multiple audio or instrument tracks

Before you start rendering, you can specify in the Render Tracks or Render Selection dialogs what happens to the source material and what kind of result you want to achieve. For example, you can specify that the source material is to be removed and that the resulting file must contain channel settings or complete signal paths that include group and send settings.

If you select a track or multiple tracks, rendering will be applied to the tracks. If you select events or parts, rendering will be applied to them. If you select tracks and events or parts, events or parts take priority over tracks. For example, if you select a track and an event, rendering will be applied to the selected event.

After rendering, the rendered file is saved to the default project folder or the folder that you specified in the Render Tracks or Render Selection dialogs. In your track list, the rendered track or selection is placed on a new track.
NOTE
You cannot render tracks that are empty, frozen, disabled, or muted. If you want to render an empty track that contains a plug-in, use the Export Audio Mixdown function.

RELATED LINKS
Creating New Files From Events on page 189
Export Audio Mixdown on page 938

Rendering Tracks

You can render selected tracks either with default settings or with custom settings.

Rendering by selecting Edit > Render in Place > Render takes into account default settings or settings that you have modified before rendering.

Rendering by selecting Edit > Render in Place > Render Setup opens the Render Tracks dialog where you can customize the render settings. All settings in the dialog are optional. When you confirm the settings and start rendering, the modified settings are saved for all following rendering processes.

NOTE
You can define key commands in the Render category of the Key Commands dialog.

PROCEDURE
1. Select one or several audio or instrument tracks.
2. Select Edit > Render in Place > Render Setup.
   The Render Tracks dialog opens. The Render tab is active.
3. Select how you want the tracks to be rendered.
   Specify how the events are rendered:
   • As Separate Events
     This is the default setting. One or more tracks are created. These contain separate events(parts) that are saved as separate audio files.
   • As Block Event
     One or more tracks are created. These contain adjacent events(parts) that are combined to blocks where applicable. Every block is saved as a separate audio file.
   • As One Event
     One or more tracks are created. These contain the events(parts) that are combined to one event/part where applicable. Every combination is saved as a separate audio file.

NOTE
Events that overlap or that are crossfaded are always rendered as one event.

Specify how rendering handles the track settings. All settings allow for the new tracks to sound equal to the source material.
• **Dry (Transfer Channel Settings)**
  If this is activated, channel settings and automation settings are transferred to the new track.

• **Channel Settings**
  This is the default setting. If this is activated, all channel settings, such as insert settings, channel strip settings, and EQ settings are rendered into the resulting files. Routing settings are transferred to the new track.

• **Complete Signal Path**
  If this is activated, the complete signal path is rendered into the resulting files. It includes all channel settings, group channel settings, and FX send channel settings. Rendering is applied at the master output channel. Use this setting if the channel is connected to a group channel or an FX send channel, and you want to render all settings into the resulting file.

• **Complete Signal Path + Master FX**
  If this is activated, the complete signal path including the master bus settings is rendered into the resulting files. This includes all channel settings, group channel settings, FX send channel settings, and master bus settings. Rendering is applied at the master output channel.

4. If you are rendering multiple tracks and want to mix down the tracks to one track, activate **Mix Down to One Track**. This setting is deactivated by default. It creates a single audio track from the selected tracks. This option is only available if you have selected multiple tracks, or if you have selected an instrument or MIDI track with multiple outputs. This option is disabled if the following applies:
   • Only 1 track/channel is available.
   • The channels that you want to mix are routed to different targets.
   • One of the channels has a send.

5. Deactivate the lock symbol next to the **Name** box to enter a custom name for the resulting file.
   If the lock symbol is active, the name is automatically derived from the track and/or event names. An incremental number is added and, depending on the source, a channel name. All created audio files end with (R)_<number>.wav. If **Mix Down to One Track** is activated, you must enter a custom name. Names cannot be derived from several tracks.

6. If required, use the **Tail Size** setting to specify extra length in seconds or bars and beats for the resulting files.

7. Specify what happens to the source tracks after rendering.
   This is useful, for example, if your original tracks include effects, such as reverb or delay that produce sound tails that extend the borders of the last played event or part. This setting is set to **Off** by default.
   • **Keep Source Tracks Unchanged**
     If this is selected, the source tracks remain unchanged.
   
   • **Mute Source Tracks**
     If this is selected, the source tracks are automatically muted. This is the default setting.

   • **Disable Source Tracks**
     If this is selected, the source tracks are disabled and are therefore no longer processed. This option releases CPU and RAM resources and is therefore similar to the **Freeze** function. To re-enable the tracks, right-click the disabled track to open the context menu and select **Enable Track**.
• **Remove Source Tracks**
  
  If this is selected, the source tracks are removed from the track list.

8. If you want to hide the source tracks after rendering, activate **Hide Source Tracks**.
   
   To show the tracks again, reactivate them on the **Visibility** tab in the **Project** window.

9. Select the **File Settings** tab to make further changes.

10. Select a **Bit Resolution** for the resulting file.
    
    You can select between 16 bit, 24 bit, and 32 bit float. The default setting is 32 bit float.

11. Specify a **Path** to which the resulting file is saved.
    
    The default path is the **Audio** folder of the project.

12. Click **OK**.

---

**RESULT**

The tracks are processed and saved to the specified file folder.

**RELATED LINKS**

Freezing Insert Effects for a Track on page 381

Export Audio Mixdown on page 938

---

**Rendering Selections**

You can render selected audio events or MIDI parts either with default settings or with custom settings.

You can render selected audio events or MIDI parts. Select **Edit > Render in Place > Render**. This takes into account default settings or settings that you have modified before rendering.

You can also render selections of events or parts. Select **Edit > Render in Place > Render Setup**. This opens the **Render Selection** dialog where you can customize the render settings. All settings in the dialog are optional. When you confirm the settings and start rendering, the modified settings are saved for all following rendering processes.

**NOTE**

You can define key commands in the **Render** category of the **Key Commands** dialog.

---

**PROCEDURE**

1. Select one or several audio events or MIDI parts.

2. Select **Edit > Render in Place > Render Setup**.
   
   The **Render Selection** dialog opens. The **Render** tab is active.

3. Select how you want the selected events/parts to be rendered.
   
   Specify how the events are rendered:
- **As Separate Events**
  This is the default setting. One or more tracks are created. These contain separate events/parts that are saved as separate audio files.

- **As Block Event**
  One or more tracks are created. These contain adjacent events/parts that are combined to blocks where applicable. Every block is saved as a separate audio file.

- **As One Event**
  One or more tracks are created. These contain the events/parts that are combined to one event/part where applicable. Every combination is saved as a separate audio file.

**NOTE**

Events that overlap or that are crossfaded are always rendered as one event.

Specify how rendering handles the track settings. All settings allow for the new tracks to sound equal to the source material.

- **Dry (Transfer Channel Settings)**
  If this is activated, channel settings and automation settings are transferred to the new track.

- **Channel Settings**
  This is the default setting. If this is activated, all channel settings, such as insert settings, channel strip settings, and EQ settings are rendered into the resulting files. Routing settings are transferred to the new track.

- **Complete Signal Path**
  If this is activated, the complete signal path is rendered into the resulting files. It includes all channel settings, group channel settings, and FX send channel settings. Rendering is applied at the master output channel. Use this setting if the channel is connected to a group channel or an FX send channel, and you want to render all settings into the resulting file.

- **Complete Signal Path + Master FX**
  If this is activated, the complete signal path including the master bus settings is rendered into the resulting files. This includes all channel settings, group channel settings, FX send channel settings, and master bus settings. Rendering is applied at the master output channel.

4. If you are rendering events/parts on multiple tracks and want to mix down the selected events/parts to one track, activate **Mix Down to One Track**.
   This setting is deactivated by default. It creates a single audio file from the selection. This option is only available if you have selected multiple tracks, or if you have selected an instrument or MIDI track with multiple outputs. This option is disabled if the following applies:
   - Only 1 track/channel is available.
   - The channels that you want to mix are routed to different targets.
   - One of the channels has a send.

5. Deactivate the lock symbol next to the **Name** box to enter a custom name for the resulting file.
   If the lock symbol is active, the name is automatically derived from the track and/or event names. An incremental number is added and, depending on the source, a channel name. All created audio files end with (R)_<number>.wav. If **Mix Down to One Track** is activated, you must enter a custom name. Names cannot be derived from several tracks.
6. If required, use the Tail Size setting to specify extra length in seconds or bars and beats for the resulting files.

7. Specify what happens to the source tracks after rendering.
   • Keep Source Events Unchanged
     If this is selected, the source events/parts remain unchanged.
   • Mute Source Events
     If this is selected, the source events/parts are automatically muted. This is the default setting.
     Events/Parts for which the Lock Event Attributes preference is set to Other cannot be muted.
     Send settings that are part of the muted source events/parts are sent to the new track.

8. Select the File Settings tab to make further changes.

9. Select a Bit Resolution for the resulting file.
   You can select between 16 bit, 24 bit, and 32 bit float. The default setting is 32 bit float.

10. Specify a Path to which the resulting file is saved.
    The default path is the Audio folder of the project.

11. Click OK.

RESULT
The events/parts are processed and saved to the specified file folder.

RELATED LINKS
Locking Events on page 188

Editing Parts and Events

This section describes techniques for editing in the Project window. If not explicitly stated, all descriptions apply to both events and parts, even though we use the term “event” for convenience.

When you are using the tools for editing, you can in many cases get additional functions by pressing modifier keys (e.g. pressing [Alt]/[Option] and dragging with the Object Selection tool creates a copy of the dragged event).

NOTE
You can customize the default modifier keys in the Preferences dialog.

RELATED LINKS
Editing - Tool Modifiers on page 1062

Selecting Events

You can select events using any of the following methods:
• Use the **Object Selection** tool.

• Use the **Select** submenu on the **Edit** menu.

• Right-click on a track and select **Select All Events** from the context menu.

• To select ranges, regardless of the event and track boundaries, use the **Range Selection** tool.

• Use the arrow keys on the computer keyboard.

• If the **Auto Select Events under Cursor** option (File > Preferences > Editing) is activated, all events on the selected tracks that are touched by the project cursor are automatically selected. This is helpful when rearranging your project, because it allows you to select whole sections on all tracks by selecting all tracks and moving the project cursor.

**RELATED LINKS**
- Selecting with the Object Selection Tool on page 178
- Select Submenu on page 178
- Range Editing on page 191

### Selecting with the Object Selection Tool

**PROCEDURE**

1. On the **Project** window toolbar, click **Object Selection**.

2. In the event display, click the events or parts that you want to select.
   - The standard techniques apply.

### Select Submenu

• To open the **Select** submenu, select **Edit > Select**.

The following options are available, when the **Object Selection** tool is selected:

- **All**
  - Selects all events in the **Project** window.

- **None**
  - Deselects all events.

- **Invert**
  - Inverts the selection – all selected events are deselected and all events that were not selected are selected instead.

- **In Loop**
  - Selects all events that are partly or wholly between the left and right locator.
From Start to Cursor
Selects all events that begin to the left of the project cursor.

From Cursor to End
Selects all events that end to the right of the project cursor.

Equal Pitch
These are available in the MIDI editors and the Sample Editor.

Select Controllers in Note Range
This is available in the MIDI editors.

All on Selected Tracks
Selects all events on the selected track.

Events under Cursor
Automatically selects all events on the selected track(s) that are touched by the project cursor.

Select Event
This is available in the Sample Editor.

Left/Right Selection Side to Cursor
These two functions are only used for range selection editing.

NOTE
When Range Selection tool is selected, the Select submenu features other functions.

RELATED LINKS
Selection Range Options on page 191

Removing Events
To remove an event from the Project window, do one of the following:

• Click on the event with the Erase tool.

• To delete all following events, but not the event that you clicked and all events before it, press [Alt]/[Option] and click on an event.

• Select the events and press [Backspace], or select Edit > Delete.

Moving Events
You can move events using any of the following methods:

• Use the Object Selection tool.
- Use the **Move to** submenu on the **Edit** menu.
- Select the event and edit the start position in the info line.
- Use the **Nudge** buttons on the toolbar.

**RELATED LINKS**
- Moving with the Object Selection Tool on page 180
- "Move to" Submenu on page 180
- Moving via the Info Line on page 181
- Moving with the Nudge Buttons on page 181

## Moving with the Object Selection Tool

**PROCEDURE**

1. In the **Project** window toolbar, click **Object Selection**.
2. In the event display, click the events or parts you want to move, and drag to a new position.

   **NOTE**
   
   You can only drag events to tracks of the same type.

3. Optional: Hold down `[Ctrl]/[Command]` while dragging to restrict movement either horizontally or vertically.

**RESULT**

All selected events are moved, maintaining their relative positions. If Snap is activated, this determines to which positions you can move the events.

**NOTE**

To avoid accidentally moving events when you click on them in the **Project** window the response when you move an event by dragging is slightly delayed. You can adjust this delay with the **Drag Delay** setting (`File > Preferences > Editing`).

### “Move to” Submenu

- To open the **Move to** submenu, select **Edit > Move to**.

The following options are available:

**Cursor**

Moves the selected event to the project cursor position. If there are several selected events on the same track, the first event will start at the cursor, and the following will be lined up end-to-start after the first one.
Origin

Moves the selected events to their original positions, i.e. the positions at which they were originally recorded.

Front/Back

This function does not actually change the position of the events, but moves the selected events to the front or back, respectively. This is useful if you have overlapping events and want to see one that is partially obscured. For audio events, this is an extra important feature, because only the visible sections of events will be played back. Moving an obscured audio event to front (or moving the obscuring event to back) will allow you to hear the whole event on playback.

Moving via the Info Line

PROCEDURE
1. In the event display, select the event or part that you want to move.
2. In the info line, double-click the Start field and enter a new value for the event start.
   The event is moved accordingly.

Moving with the Nudge Buttons

PROCEDURE
1. Right-click the Project window toolbar and activate Nudge Palette. The nudge buttons become available in the toolbar.
2. In the event display, select the events or parts that you want to move, and use the Move Left/Move Right nudge buttons. The selected events or parts are moved to the left or right.

Renaming Events

By default, audio events show the name of their clip, but you can enter a separate descriptive name for events.

- To rename an event, select the event and type in a new name in the Name field on the info line.
To give all events on a track the same name as the track, change the track name, hold down a modifier key, and press [Return].

Resizing Events

Resizing events means to move their start or end positions individually.

The following resizing modes are available:

- **Normal Sizing**: The contents of the event stay fixed, and the start or end point of the event is moved to "reveal" more or less of the contents.
- **Sizing Moves Contents**: The contents follow the moved start or end of the event (see the figure below).
- **Sizing Applies Time Stretch**: The contents will be time stretched to fit the new event length.

To select one of the resizing modes, select the **Object Selection** tool and then click again on the **Object Selection** tool icon on the toolbar. This opens a pop-up menu from which you can select one of the options.

**IMPORTANT**

When resizing events, any automation data not taken into account.

To resize events, do one of the following:

- Click and drag the lower left or right corner of the event.
  
  If **Snap** is activated, the **Snap** value determines the resulting length. If several events are selected, all will be resized in the same way.
• Use the Trim buttons (Nudge palette) on the toolbar. This will move the start or end position of the selected events by the amount set on the Grid Type pop-up menu. The sizing type currently selected applies to this method too, with the exception of Sizing Applies Time Stretch which is not possible with this method.

• Use the Scrub tool.

• Apply time stretch.

RELATED LINKS
Snap Function on page 62
Resizing Events Using Time Stretch on page 183

Resizing Events Using Time Stretch

Time stretching allows you to resize a part and make its contents fit the new size.

PROCEDURE
1. Click the Object Selection tool on the toolbar and click again to select the Sizing Applies Time Stretch option from the pop-up menu.
2. Point close to the end point of the part you want to stretch.
3. Click and drag left or right.
   When you move the mouse, a tooltip shows the current mouse position and length of the part. Snap is taken into account.
4. Release the mouse button.

RESULT
The part is stretched or compressed to fit the new length.

• For MIDI parts, this means that the note events are stretched (moved and resized).
  Controller data and Note Expression data will be stretched, too.

• For audio parts, this means that the events are moved, and that the referenced audio files are time stretched to fit the new length.
  A dialog shows the progress of the time stretch operation.

RELATED LINKS
Time Stretch on page 414
Splitting Events

You can split events in the Project window in the following ways:

- Click with the Cut tool on the event you want to split.
  If Snap is activated, this determines the exact split position. You can also split events by pressing [Alt]/[Option] and clicking with the Object Selection tool.

- Select Edit > Functions > Split at Cursor.
  This splits the selected events at the position of the project cursor. If no events are selected, all events (on all tracks) that are intersected by the project cursor will be split.

- Select Edit > Functions > Split Loop.
  This splits events on all tracks at the left and right locator positions.

**NOTE**

If you split a MIDI part so that the split position intersects one or several MIDI notes, the result depends on the Split MIDI Events option (File > Preferences > Editing > MIDI). If the option is activated, the intersected notes will be split (creating new notes at the beginning of the second part). If it is deactivated, the notes will remain in the first part, but stick out after the end of the part.

**RELATED LINKS**

Snap Function on page 62

Gluing Events Together

No data will be kept in the clipboard.

The following options are available:

- To glue an event together with the next event on the track, click on an event with the Glue tool. The events do not have to touch one another.
  The result is a part containing the two events, with one exception: If you first split an event and then glue the two sections together again (without moving or editing them first), they become a single event again.

- You can select several events on the same track and click on one of them with the Glue tool.
  A single part is created.

- To glue an event together with all following events on this track, hold down [Alt]/[Option] and click on an event with the Glue tool.
Duplicating

Events can be duplicated in the following ways:

- Hold down [Alt]/[Option] and drag the event to a new position.
  If Snap is activated, this determines to which positions you can copy the events.

  **NOTE**
  If you hold down [Ctrl]/[Command] as well, movement direction is restricted to either horizontal or vertical. That means if you drag an event vertically it cannot be moved horizontally at the same time.

- Select Edit > Functions > Duplicate to create a copy of the selected event and place it directly after the original.
  If several events are selected, all of these are copied “as one unit”, maintaining the relative distance between the events.

  **NOTE**
  When you duplicate audio events, the copies always refer to the same audio clip.

Cutting, Copying, and Pasting Events

You can cut or copy selected events, and paste them in again, using the functions on the Edit menu.

- When you paste an audio event, it is inserted on the selected track, positioned so that its snap point is aligned with the cursor position.
  If the selected track is of the wrong type, the event will be inserted on its original track.

- If you use the Paste at Origin function (Edit > Function), the event is pasted at the position from which you cut or copied it.

- If you use the Paste Relative to Cursor function (Edit > Function), the event is pasted while keeping its relative position to the project cursor.

  **RELATED LINKS**
  Snap Function on page 62

Repeating

Events can be repeated in the following ways:

- Hold down [Alt]/[Option] and click the handle in the lower right corner of the last selected event and drag to the right.

- Select Edit > Functions > Repeat to open a dialog, allowing you to create a number of copies (regular or shared) of the selected events.
Fill Loop

You can create a number of copies between the right and left locators.

- Select **Edit > Functions > Fill Loop** to create a number of copies starting at the left locator and ending at the right locator. The last copy is automatically shortened to end at the right locator position.

Creating Shared Copies

You can create shared copies of audio and MIDI parts. If you edit the contents of a shared copy, all other shared copies of the same part are automatically edited in the same way.

- Hold down [Alt]/[Option]-[Shift] and drag to the right.

**NOTE**
You can convert a shared copy to a real copy by selecting **Edit > Functions > Convert to Real Copy**. This creates a new version of the clip (that can be edited independently) and adds this to the **Pool**.

Sliding the Contents of an Event or Part

You can move the contents of an event or part without changing its position in the Project window.

- To slide an event or part, press [Alt]/[Option]-[Shift], click in the event or part and drag to the left or right.

**IMPORTANT**
When sliding the contents of an audio event, you cannot slide past the start or end of the actual audio clip. If the event plays the whole clip, you cannot slide the audio at all.

Grouping Events

You can treat several events as one unit by grouping them.

- To group events, select the events (on the same or different tracks) and select **Edit > Group**.

Grouped events are indicated by a group icon on the right.
If you edit one of the grouped events in the Project window, all other events in the same group are affected too (if applicable).

Group editing operations include:

- Selecting events.
- Moving and duplicating events.
- Resizing events.
- Adjusting fade-in and fade-out (audio events only).
- Splitting events. Splitting one event will automatically split any other grouped events that are intersected by the split position.
- Locking events.
- Muting events.
- Deleting events.

**RELATED LINKS**

Creating fades on page 247

### Group Editing (Cubase Pro only)

The group editing mode for folders allows you to quickly group events and parts across multiple tracks without having to select all the events or parts. This is useful for multi-track recordings of drum sets, where you often want to edit the different drum tracks (bass drum, snare, toms, etc.) together. Edit groups are also useful if you want to quantize multiple tracks.

- To activate group editing, click the **Group Editing** button for a folder in the track list.

If the group editing mode is activated and you select an event, a part or a range on a track inside the folder track, other events, parts or ranges that have the same start and end time and the same playback priority, are also selected and temporarily grouped.

Temporarily means that on every new selection with the Object Selection or the Range Selection tool, Cubase looks for corresponding events or parts inside the folder and groups them. If you edit the start or end point of a single event or part before activating the = button for group editing, the event or part is excluded from the group.
Edit actions in group editing mode affect all grouped events, parts, or ranges. If you select another take by using the small **To Front** arrow at the right side of one event of an edit group, for example, all other tracks inside the edit group also switch to the corresponding take. This is useful for comparing takes of a multi-track recording.

**NOTE**
The group editing setting overwrites any regular group settings in the edit group.

**RELATED LINKS**
Muting Events on page 189

## Locking Events

If you want to make sure that you do not edit or move an event by accident, you can lock it.

Locking can affect one or any combination of the following properties:

<table>
<thead>
<tr>
<th>Lock Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Position</td>
<td>If this is locked, the event cannot be moved.</td>
</tr>
<tr>
<td>Size</td>
<td>If this is locked, the event cannot be resized.</td>
</tr>
<tr>
<td>Other</td>
<td>If this is locked, all other editing of the event is disabled. This includes adjusting the fades and event volume, processing, etc.</td>
</tr>
</tbody>
</table>

- To specify which of these properties are affected by the **Lock** function, use the **Lock Event Attributes** pop-up menu (**File > Preferences > Editing**).
- To lock events, select them and select **Edit > Lock**. The events will be locked according to the options specified in the **Preferences** dialog.
- The padlock symbol indicates that one or more of the lock options are activated for the event.
- To adjust the lock options for a locked event, select the locked event and select **Edit > Lock**. This opens a dialog in which you can activate or deactivate the desired lock options.
• To unlock an event (turn off all lock options), select the event and select **Edit > Unlock**.

• To lock a whole track, click the padlock symbol in the track list or in the Inspector.
  This disables all editing of all events on the track.

**Muting Events**

You can mute events in the **Project** window. Muted events can be edited as usual (with the exception of adjusting fades), but are not played back.

To mute events, select them and select **Edit > Mute**.

To unmute events, select them and select **Edit > Unmute**.

To mute or unmute a single event, click on it with the **Mute** tool.

To mute or unmute several events, click in an empty area with the **Mute** tool and drag a selection rectangle around several events.
  All selected events are muted.

To change the mute status of selected events, [Shift]-click them.

**Creating New Files From Events**

An audio event plays a section of an audio clip, which in turn refers to one or more audio files on the hard disk. However, you can create a new file that consists only of the section that is played by the event.

**PROCEDURE**

1. Select one or several audio events.
2. Set up fade in, fade out, and event volume.
   These settings will be applied to the new file.
3. Select **Audio > Bounce Selection**.
   You are asked whether you want to replace the selected event or not.
4. Do one of the following:
   • To create a new file that only contains the audio in the original event, click **Replace**.
     A clip for the new file is added to the **Pool**, and the original event is replaced by a new event playing the new clip.
   • To create a new file and add a clip for the new file to the **Pool**, click **No**.
     The original event is not replaced.
NOTE

You can also apply the **Bounce Selection** function to an audio part. In that case, the audio from all events in the part will be combined into a single audio file. If you select **Replace** when asked, the part will be replaced with a single audio event playing a clip of the new file.

**RELATED LINKS**

Creating fades on page 247

---

**Region Operations**

Regions are sections within a clip.

Regions are best created and edited in the **Sample Editor**. However, to access the following options, select **Audio > Advanced**.

**Event or Range as Region**

This function is available when one or several audio events or selection ranges are selected. It creates a region in the corresponding clip, with the start and end position of the region determined by the start and end position of the event or selection range within the clip.

**Events from Regions**

This function is available if you have selected an audio event whose clip contains regions within the boundaries of the event. The function will remove the original event and replace it with events positioned and sized according to the regions.

**RELATED LINKS**

Working with regions on page 448
Editing in the Project window is not restricted to handling whole events and parts. You can also work with selection ranges, which are independent from the event/part and track boundaries.

Creating a Selection Range

- To make a selection range, drag with the Range Selection tool.

  When the Range Selection tool is selected, you can select selection ranges options via Edit > Select.

- To create a selection range that encompasses an event, double-click on an event with the Range Selection tool.

- To create a selection range that encompasses several events, hold down [Shift] and double-click several events in a row.

- To open an encompassed event for editing in the Sample Editor, double-click it.

RELATED LINKS
Selection Range Options on page 191

Selection Range Options

- To open the range selection options menu, select the Range Selection tool and select Edit > Select.

  All
  Makes a selection that covers all tracks, from the start of the project to the end. You can define the track length with the Length setting in the Project Setup dialog.

  None
  Removes the current selection range.
Invert

Inverts the selection. All selected events are deselected, and all events that were not selected are selected. Only used for event selection.

In Loop

Makes a selection between the left and right locator on all tracks.

From Start to Cursor

Makes a selection on all tracks, from the start of the project to the project cursor.

From Cursor to End

Makes a selection on all tracks, from the project cursor to the end of the project.

All on Selected Tracks

Selects all events on the selected track. Only used for event selection.

Select Event

This is available in the Sample Editor.

Left Selection Side to Cursor

Moves the left side of the current selection range to the project cursor position.

Right Selection Side to Cursor

Moves the right side of the current selection range to the project cursor position.

RELATED LINKS

- Project Setup Dialog on page 72
- Selecting Events on page 177
- Select Submenu on page 178

Selecting Ranges for Several Tracks

You can create selection ranges that cover several tracks. It is also possible to exclude tracks from a selection range.

PROCEDURE

1. Create a selection range from the first to the last track.
2. Press [Ctrl]/[Command] and click in the selection range on the tracks that you want to exclude from the selection.
Editing Selection Ranges

Adjusting the Size of Selection Ranges

You can adjust the size of a selection range in the following ways:

- By dragging its edges.
  The pointer takes the shape of a double arrow when you move it over an edge of the selection range.

- By holding down [Shift] and clicking.
  The closest selection range edge will be moved to the position at which you clicked.

- By adjusting the selection range start or end position on the info line.

- By using the trim buttons on the toolbar.
  The left trim buttons move the start of the selection range and the right buttons move the end. The edges are moved by the amount specified on the Grid pop-up menu.

  **NOTE**
  The trim buttons are located on the Nudge Palette, which is not visible on the toolbar by default.

- By using the Move Left and Move Right buttons on the toolbar.
  These move the whole selection range to the left or the right. The amount of movement depends on the selected display format and the value specified on the Grid pop-up menu.

  **IMPORTANT**
  The contents of the selection are not moved. Using the Move Left/Move Right buttons is the same as adjusting the start and end of the selection range at the same time by the same amount.

  **NOTE**
  The move buttons are located on the Nudge Palette, which is not visible on the toolbar by default.

- To crop all events or parts that are partially within the selection range, select Edit > Range > Crop.
  Events that are fully inside or outside the selection range are not affected.

**RELATED LINKS**
  The setup context menus on page 1032
Moving and Duplicating Selection Ranges

- To move a selection range, click and drag it to a new position.
  This will move the contents of the selection range to the new position. If the range intersected events or parts, these are split before moving, so that only the sections within the selection range are affected.

- To duplicate a selection range, hold down [Alt]/[Option] and drag.
  You can also use the duplicate, repeat, and fill loop functions that are available for duplicating events.

RELATED LINKS
Duplicating on page 185

Cutting, Copying, and Pasting Selection Ranges

You can cut or copy and paste selection ranges, using the functions on the Edit menu. You can also use the Cut Time and Paste Time options.

Cut
Cuts out the data in the selection range and moves it to the clipboard. The selection range is replaced by empty track space in the Project window, meaning that events to the right of the range keep their positions.

Copy
Copies the data in the selection range to the clipboard.

Paste
Pastes the clipboard data to the start position and track of the current selection. Existing events on the tracks remain at their original position.

Paste at Origin
Pastes the clipboard data back at its original position. Existing events on the tracks remain at their original position.
This option is available in Edit > Functions.

Cut Time
Cuts out the selection range and moves it to the clipboard. Events to the right of the removed range are moved to the left to fill the gap.
This option is available in Edit > Range.

Paste Time
Pastes the selection range from the clipboard to the start position and track of the current selection. Existing events are moved to make room for the pasted data.
This option is available in Edit > Range.
Paste Time at Origin

Pastes the selection range from the clipboard to its original position. Existing events are moved to make room for the pasted data.

This option is available in Edit > Range.

Global Copy

This copies everything in the selection range.

This option is available in Edit > Range.

Deleting Data in Selection Ranges

You can delete selection ranges as follows:

- To replace data within the deleted selection range with empty track space, select Edit > Delete or press [Backspace].
  Events to the right of the range keep their position.

- To remove the selection range and make the events to the right move to the left to fill the gap, select Edit > Range > Delete Time.

Splitting Selection Ranges

- To split any events or parts that are intersected by the selection range, at the positions of the selection range edges, select Edit > Range > Split.

Inserting Silence

You can insert empty track space from the start of the selection range. The length of the silence equals the length of the selection range.

- To insert silence, select Edit > Range > Insert Silence.
  Events to the right of the selection range start are moved to the right to make room. Events that are intersected by the selection range start are split, and the right section is moved to the right.
Playback and Transport

This chapter describes the methods for controlling playback and transport functions.

RELATED LINKS
Transport on page 1080

Transport Panel

The Transport panel contains the main transport functions as well as many other options related to playback and recording.

- To show the transport panel, select Transport > Transport Panel or press [F2].

Transport Panel Sections

The Transport panel has different sections that you can show or hide by activating the corresponding options on the transport panel context menu.

- To show all Transport panel sections, right-click anywhere in the Transport panel and select Show All.

The following sections are available:

Virtual Keyboard

![Virtual Keyboard Image]

Allows you to play and record MIDI notes by using your computer keyboard or mouse.

Performance

![Performance Image]

Shows the audio processing load and the hard disk transfer rate.
Record Mode

Determines what happens to your recordings and to any existing events on the track when you are recording. This section also contains the automatic MIDI record quantize function.

Locators

Allows you to go to the left or right locator position, and to activate Auto Punch In and Auto Punch Out.

Furthermore, you can set the left and right locator position numerically and specify a pre-roll and a post-roll value.

Jog/Scrub

The outer wheel is the Shuttle Speed control.

The middle wheel is the Jog Wheel.

The Nudge buttons + and - allow you to move the project cursor position to the right or left in steps of 1 frame.

Main Transport

Shows the basic transport controls as well as the time display options.

Arranger

Shows the arranger functions.

Master + Sync

Shows the basic metronome, tempo, and synchronization options.

Marker

Shows the basic marker functions.
MIDI Activity

Allows you to monitor the MIDI input and the MIDI output signals.

Audio Activity

Allows you to monitor the audio input and output signals.

Audio Level Control

Shows clipping indicators and an output level control.

**Related Links**

- Transport on page 1080
- Transport - Scrub on page 1082

**Pre-Roll and Post-Roll**

You can activate pre-roll and post-roll with the corresponding buttons in the Locators section on the Transport panel or by selecting Transport > Use Pre-roll/Use Post-roll.

- By setting a pre-roll value you instruct Cubase to roll back a short section whenever playback is activated.

- By setting a post-roll value you instruct Cubase to play back a short section after automatic punch out before stopping.

**Note**

This is only relevant if Auto Punch Out is activated on the Transport panel and Stop after Automatic Punch Out is activated (File > Preferences > Transport).

**Using Pre-Roll and Post-Roll**

**Procedure**

1. Set the locators to where you want to start and end recording.
2. On the Transport panel, activate Auto Punch In and Auto Punch Out.
4. On the transport panel, click the **Pre-roll Amount** and the **Post-roll Amount** fields and enter the pre-roll and post-roll values.

5. Activate **Use pre-roll** and **Use post-roll**.

6. Activate **Record**.

**RESULT**

The project cursor rolls back by the time specified in the **Pre-roll Amount** field and playback starts. When the cursor reaches the left locator, recording is automatically activated. When the cursor reaches the right locator, recording is deactivated, but playback continues for the time set in the **Post-roll Amount** field before stopping.

### Playing Back with the Shuttle Speed Wheel

The shuttle speed wheel allows you to play back the project at up to four times the playback speed, forwards or backwards. This is a quick way to locate or cue to any position in the project.

- To start playback, turn the shuttle speed wheel to the right. The further you turn the wheel, the faster the playback speed.
- To play the project backwards, turn the wheel to the left. The further you turn the wheel, the faster the playback speed.
- To activate insert effects for scrubbing with the shuttle speed wheel, select **File > Preferences > Transport > Scrub** and activate **Use Inserts While Scrubbing**. By default, insert effects are bypassed.

**NOTE**

You can also access the shuttle speed wheel via a remote control device.

### Project Scrubbing - The Jog Wheel

The jog wheel allows you to move the playback position forwards or backwards, much like scrubbing on a tape deck. This helps you pinpoint exact locations in the project.
Playback and Transport

To move to another playback position, turn the jog wheel to the left or right. The further you turn the jog wheel, the faster the playback speed. The original playback speed is the fastest speed possible. You can turn the jog wheel as many times as needed to move to a location.

If you click the jog wheel during playback, playback automatically stops and scrubbing starts.

- To activate insert effects for scrubbing with the jog wheel, select File > Preferences > Transport > Scrub and activate Use Inserts While Scrubbing.
  By default, insert effects are bypassed.

NOTE
You can also access the jog wheel via a remote control device.

Transport Menu

The Transport menu contains several transport functions as well as many other options related to playback and recording.

Open Function

Transport Panel
  Opens the Transport panel.

Locate Functions

Locators to Selection
  Sets the locators to encompass the selection.

Locate Selection
  Moves the project cursor to the beginning of the selection.

Locate Selection End
  Moves the project cursor to the end of the selection.

Locate Next/Previous Marker
  Moves the project cursor to the closest marker to the right or left.

Locate Next/Previous Hitpoint
  Moves the project cursor to the next or to the previous hitpoint on the selected track.

Locate Next/Previous Event
  Moves the project cursor to the next or to the previous event on the selected track.
Playback Functions

Post-roll from Selection Start/End
Starts playback from the beginning or end of the currently selected range and stops after the time set in the post-roll field on the transport panel.

Pre-roll to Selection Start/End
Starts playback from a position before the start or end of the currently selected range and stops at the selection start or end, respectively. The playback start position is set in the pre-roll field on the transport panel.

Play from Selection Start/End
Activates playback from the beginning or end of the current selection.

Play until Selection Start/End
Activates playback two seconds before the start or end of the current selection and stops at the selection start or end, respectively.

Play until Next Marker
Activates playback from the project cursor and stops at the next marker.

Play Selection Range
Activates playback from the start of the current selection and stops at the selection end.

Loop Selection
Activates playback from the start of the current selection and keeps starting over again when reaching the selection end.

Record Functions

Re-Record Mode
Activates/Deactivates the re-record mode that allows you to reinitiate a recording with a single click.

Start Recording at Left Locator
If this is activated, the project cursor locates to the left locator when you click the record button.

Use Pre-/Post-roll
Activates the pre-roll/post-roll.

Retrospective Record
Allows you to capture MIDI notes that you play in stop mode or during playback. Therefore, you need to enable the Retrospective Record option (File > Preferences > Record > MIDI).
Metronome Functions

**Metronome Setup**
Opens the Metronome Setup dialog.

**Metronome On/Off**
Activates/Deactivates the metronome click.

**Precount On/Off**
Activates/Deactivates the precount.

Synchronization Functions

**Project Synchronization Setup**
Opens the Project Synchronization Setup dialog.

**Use External Sync**
Sets Cubase to be synchronized externally.

Setting the Project Cursor Position

To move the project cursor, do one of the following:

- Use fast forward and rewind.
- Use the jog/shuttle/nudge control on the Transport panel.
- Drag the project cursor in the lower part of the ruler.
- Click in the ruler.
  - Double-clicking in the ruler moves the cursor and starts/stops playback.
  - If Locate when Clicked in Empty Space is activated (File > Preferences > Transport), you can click anywhere in an empty section of the Project window to move the cursor position.
- Change the value in any of the position displays.
- Use the position slider above the transport buttons in the Transport panel.

The range of the slider relates to the length setting in the Project Setup dialog. Hence, moving the slider all the way to the right takes you to the end of the project.

- Use markers.
- Use the playback options.
- Use the arranger function.
Playback and Transport

Left and Right Locators

The left and right locators are a pair of markers that you can use for specifying punch-in and punch-out positions, and cycle boundaries.

Locators are indicated by the flags in the ruler. The area between the locators is highlighted in the ruler and the event display.

If the right locator is positioned before the left locator, the area between the locators is shown in a different color.

Setting the Locators

There are several ways to set the locator positions.

To set the left locator, do one of the following:

- Drag the left handle in the ruler.
- Press [Ctrl]/[Command] and click at the position in the ruler.
- Adjust the Left Locator Position value on the Transport panel.

To set the left locator to the project cursor position, do one of the following:

- Press [Ctrl]/[Command], and on the numeric keypad press [1].
- Press [Alt]/[Option] and click L on the Transport panel.

To set the right locator, do one of the following:

- Drag the right handle in the ruler.
• Press [Alt]/[Option] and click at the position in the ruler.
• Adjust the Right Locator Position value on the Transport panel.

To set the right locator to the project cursor position, do one of the following:
• Press [Ctrl]/[Command] and on the numeric keypad press [2].
• Press [Alt]/[Option] and click R on the Transport panel.

To set both locators, do one of the following:
• Click and drag left or right in the upper half of the ruler.
• Select a range or an event and select Transport > Locators to Selection.
• Double-click a cycle marker.

Auto-Scroll

Auto-Scroll allows the waveform display to scroll during playback, keeping the project cursor visible in the window.

• To activate Auto-Scroll, click the Auto-Scroll button on the toolbar.
• To keep the project cursor in the middle of the screen, select File > Preferences > Transport and activate Stationary Cursors.

NOTE

Auto-Scroll is available in the toolbar of the Project window and in all editors.

Suspend Auto-Scroll when Editing

If you do not want the Project window display to change when editing during playback, you can activate Suspend Auto-Scroll when Editing.

The Suspend Auto-Scroll when Editing button is located to the right of the Auto-Scroll button.

When this option is activated, auto-scrolling is suspended as soon as you click anywhere in the event display during playback. As a visual feedback for that, the Auto-Scroll button turns orange.

As soon as playback stops or when you click the Auto-Scroll button again, Cubase will return to the normal Auto-Scroll behavior.

Time Formats

You can set up different time formats.
Selecting the Primary Time Format

In the **Transport** panel, you can select the primary time format. This is the global display format that is used for all rulers and position displays in the program, except the ruler tracks.

**PROCEDURE**

1. In the main transport section of the **Transport** panel, click **Select Primary Time Format**.
2. Select a time format from the pop-up menu.

You can also select **Project > Project Setup > Display Format** to select the primary time format.

**RESULT**

The time format in the **Transport** panel and all rulers and position displays are updated.

Independent Time Displays

You can show time displays that are independent from the global display format. To select an independent time display, do one of the following:

- In the ruler of the **Project** window or any editor, click the arrow button to the right of the ruler.
- Select **Project > Add Track > Ruler** to add a ruler track, and right-click the ruler.
- In the **Main Transport** section of the **Transport** panel, click **Select Secondary Time Format**.

**RELATED LINKS**

- Ruler on page 48
- Ruler Track on page 122
Switching the Primary and Secondary Time Format

**PROCEDURE**

- In the **Main Transport** section of the Transport panel, click **Exchange Time Format**.

**RESULT**

The primary and secondary time formats are switched and all rulers and position displays are updated.

Locating to Specific Time Positions

You have several possibilities to locate to specific time positions in the Project window.

- In the Transport panel, use the functions in the Main Transport section or in the Jog/Scrub section.
- In the Transport panel, use the position slider above the transport buttons.
- In the ruler, click the time position that you want to locate to. Double-click to start/stop playback.
- In the lower part of the ruler, drag the project cursor.
- Use the following Transport menu functions: Locate Selection/Locate Selection End, Locate Next/Previous Marker, Locate Next/Previous Hitpoint, Locate Next/Previous Event.
- Use markers.
- Use the arranger functions.
- Use locators.
  - On the Transport panel, click **L** to go to the left locator, and click **R** to go to the right locator.

**NOTE**

If Snap is activated, the snap value is taken into account. This is helpful for finding exact positions quickly.
Metronome

You can use the metronome click as a timing reference. The two parameters that govern the timing of the metronome are tempo and time signature.

- To activate the metronome click, activate the Click button on the Transport panel.
  You can also select Transport > Metronome On or use the corresponding key command.

- To activate the precount, click the Precount button on the Transport panel.
  You can also select Transport > Precount On or set up a key command for this.

- To set up the metronome, select Transport > Metronome Setup.

Metronome Setup

You can make settings for the metronome in the Metronome Setup dialog.

- To open the Metronome Setup dialog, select Transport > Metronome Setup.

Metronome Options Section

In the Metronome Options section, the following options are available:

Metronome in Record

Allows you to activate the metronome click during recording.

Metronome in Play

Allows you to activate the metronome click during playback.
Precount Options Section

In the **Precount Options** section, the following options are available:

**Precount Bars**
Allows you to set the number of bars that the metronome counts in before recording starts.

**Use Project Count Base**
Activate this to let the metronome play one click per beat according to the project count base.

**Use Count Base**
Activate this to set the rhythm of the metronome. For example, setting this to 1/8, gives you eighth notes (two clicks per beat).

**Use Time Sign. at Rec. Start Time**
Activate this to let the precount automatically use the time signature and tempo set at the position where recording starts.

**Use Time Sign. at Project Time**
Activate this to let the precount use the time signature set on the tempo track and apply any tempo changes on the tempo track during the precount.

**Use Signature**
Allows you to set a time signature for the precount. In this mode, tempo changes on the tempo track do not affect the precount.

Click Outputs Section

In the **Click Outputs** section, the following options are available:

**Activate MIDI Click**
Allows you to activate the MIDI click.

**MIDI Port/Channel**
Allows you to select a MIDI output and channel for the MIDI click. You can also select a VST instrument previously set up in the **VST Instruments** window.

**Hi Note/Velocity**
Allows you to set the MIDI note number and velocity value for the first beat in a bar, the high note.

**Lo Note/Velocity**
Allows you to set the MIDI note number and velocity value for the other beats, the low notes.

**Activate Audio Click**
Allows you to activate the audio click that sounds via the audio hardware.
Beeps
Allows you to activate beeps generated by the program. Adjust the pitch and level of the beeps for the Hi (first) beat and Lo (other) beats using the sliders below.

Sounds
Allows you to load audio files for the Hi and Lo metronome sounds in the Sound fields below. The sliders set the level of the click.

Chase
Chase is a function that makes sure your MIDI instruments sound as they should when you locate to a new position and start playback. This is accomplished by the program transmitting a number of MIDI messages to your instruments each time that you move to a new position in the project, making sure all MIDI devices are set up correctly with regard to program change, controller messages (such as MIDI Volume), etc.

EXAMPLE
You have a MIDI track with a program change event inserted at the beginning. This event makes a synth switch to a piano sound.

At the beginning of the first chorus you have another program change event which makes the same synth switch to a string sound.

You now play back the song. It begins with the piano sound and then switches to the string sound. In the middle of the chorus you stop and rewind to some point between the beginning and the second program change. The synth now still plays the string sound although in this section it really should be a piano.

The Chase function takes care of that. If program change events are set to be chased, Cubase tracks the music back to the beginning, finds the first program change, and transmits it to your synth, setting it to the correct sound.

The same thing can apply to other event types as well. The Chase Events settings (File > Preferences > MIDI) determine which event types are chased when you locate to a new position and start playback.

Activated event types are chased.

RELATED LINKS
Chase Events on page 1069
Virtual Keyboard

The Virtual Keyboard allows you to play and record MIDI notes by using your computer keyboard or mouse. This is useful if you have no external MIDI instrument at hand and you do not want to draw in notes with the Draw tool.

When the Virtual Keyboard is displayed, the usual key commands are blocked because they are reserved for the Virtual Keyboard. The only exceptions are:

- Save: [Ctrl]/[Command]-[S]
- Start/Stop Record: Num [*]
- Start/Stop Playback: [Space]
- Jump to left locator: Num [1]
- Delete: [Delete] or [Backspace]
- Cycle on/off: Num [/]
- Show/Hide Transport panel: [F2]
- Show/Hide Virtual Keyboard: [Alt]/[Option]-[K]

Recording MIDI With the Virtual Keyboard

PREREQUISITE

You have selected a MIDI or instrument track and activated Record Enable.

PROCEDURE

1. Select Devices > Virtual Keyboard. The Virtual Keyboard is displayed in the Transport panel.
2. On the Transport panel, activate Record.
3. Perform one of the following actions to enter some notes:
   - Click with the mouse on the keys of the virtual keyboard.
   - Press the corresponding key on your computer keyboard.

NOTE

Press several keys simultaneously to enter polyphonic parts. The maximum number of notes that can be played at one time varies between the different operating systems and hardware configurations.
AFTER COMPLETING THIS TASK
Close the virtual keyboard to make all key commands available again.

Virtual Keyboard Options

1)  **Note Velocity Level**
   This slider allows you to adjust the volume of the virtual keyboard. You can also use the up and down arrow keys for this.

2)  **Change Virtual Keyboard Display Type**
   This button allows you to switch between computer keyboard and piano keyboard display mode.
   The computer keyboard mode, you can use the two rows of keys that are displayed on the Virtual Keyboard to enter notes.
   The piano keyboard has a wider range of keys. It allows you to enter more than one voice simultaneously. You can also use the [Tab] key for this.

3)  **Octave Offset**
   These buttons allow you to switch the keyboard range to a lower or higher octave. You have seven full octaves at your disposal. You can also use the left and right arrow keys for this.

4)  **Pitchbend/Modulation Sliders**
   These sliders are only available in piano keyboard mode. They allow you to introduce pitchbend and modulation. You can also click on a key, hold the mouse button pressed until the mouse pointer becomes a cross-hair cursor and drag upwards/downward to introduce modulation or drag left/right to create pitchbend.
Recording

In Cubase, you can record audio and MIDI.

This chapter assumes that you are familiar with certain basic recording concepts and that some initial preparations have been made.

- Set up, connect, and calibrate your audio hardware.
- Open a project and set up the project setup parameters according to your specifications.
  Project setup parameters determine the record format, sample rate, project length, etc. that affect the audio recordings that you make during the course of the project.
- If you plan to record MIDI, set up and connect your MIDI equipment.

**RELATED LINKS**
- Setting Up Audio on page 13
- Setting Up MIDI on page 19

**Basic Recording Methods**

This section describes the general recording methods.

**Record Enabling Tracks**

To be able to record, you must record-enable the tracks on which you want to record.

- To record-enable a track, activate the **Record Enable** button in the track list, in the Inspector, or in the MixConsole.
- To record-enable all audio tracks simultaneously, set up a key command for **Activate Record Enable for all Audio Tracks** in the **Mixer** category of the **Key Commands** dialog and use it.
- To record-enable audio or MIDI tracks on selection, activate the **Enable Record on Selected Audio Track** or the **Enable Record on Selected MIDI Track** option (File > Preferences > Editing > Project & MixConsole).
The exact number of audio tracks that you can record simultaneously depends on your computer CPU and hard disk performance. Activate the Warn on Processing Overloads option (File > Preferences > VST) to show a warning message as soon as the CPU overload indicator lights up during recording.

### Activating Recording

You can activate recording manually or automatically.

#### Activating Recording Manually

- To activate recording, click the **Record** button on the **Transport** panel or on the toolbar. You can also use the corresponding key command, by default [*] on the numeric keypad.

Recording starts from the current cursor position.

**NOTE**

When you start recording in **Stop** mode, you can start recording from the left locator by activating **Start Record at Left Locator** on the **Transport** menu. The pre-roll setting or the metronome count-in will be applied.

#### Activating Recording Automatically

Cubase can automatically switch from playback to recording at a given position. This is useful if you must replace a section of a recording and want to listen to what is already recorded up to the recording start position.

**PROCEDURE**

1. Set the left locator to the position where you want to start recording.
2. Activate the **Punch In** button on the **Transport** panel.
3. Activate playback from any position before the left locator.

   When the project cursor reaches the left locator, recording is automatically activated.
Stopping Recording

- To stop recording and playback, click the Stop button on the Transport panel or use the corresponding key command, by default [0] on the numeric keypad.
- To stop recording and continue playback, click the Record button or use the corresponding key command, by default [*] on the numeric keypad.
- To stop recording automatically when the project cursor reaches the right locator and continue playback, activate the Punch Out button on the Transport panel.

Cycle Recording

You can record in a cycle, that is you can record a selected section repeatedly and seamlessly.

PREREQUISITE
A cycle is set up with the left and right locators.

PROCEDURE
1. Click the cycle button on the Transport panel to activate cycle mode.
2. Activate recording from the left locator, before or within the cycle.
   As soon as the project cursor reaches the right locator, it jumps back to the left locator and continues recording a new lap.

RESULT
The results of cycle recording depend on the selected record mode. They also differ for audio and MIDI.

RELATED LINKS
- Recording MIDI on page 227
- Recording Audio on page 221
Using Pre-Roll and Post-Roll

You can set up a pre-roll and a post-roll for recording.

**PREREQUISITE**
Select **File > Preferences > Transport** and activate the Stop after Automatic Punch Out option.

**PROCEDURE**
1. Set the locators to where you want to start and end recording.
2. On the Transport panel, activate Auto Punch In and Auto Punch Out.
3. Activate Use Pre-roll and Use Post-roll.
4. Specify a Pre-roll Amount and a Post-roll Amount.
5. Click Record.

**RESULT**
The project cursor rolls back and starts playback at the time that has been set as pre-roll amount. When the cursor reaches the left locator, recording is automatically activated. When the cursor reaches the right locator, recording is deactivated, and the playback continues as long as the time that has been set as post-roll amount.

**Common Record Modes**

The Common Record Modes determine what happens if you click the Record button during an audio or MIDI recording.

- In the Transport panel, click the upper part of the Record Modes section to open the Common Record Modes pop-up menu.

**Punch In/Out**
In this mode, the recording is stopped.

**Re-Record**
In this mode, the recording is reinitiated, the events are removed and recording is restarted from the exact same position.

**Start Recording at Cursor**
In this mode, recording starts from the cursor position.

**Start Recording at Left Locator**
In this mode, recording starts from the left locator.
Re-Recording

PROCEDURE
1. Activate Transport > Re-Record.
2. Activate recording.
3. Hit the Record button again to restart recording.

RESULT
The project cursor jumps back to the record start position and recording is
reinitiated. Pre-roll and pre-count settings are taken into account.

NOTE
The previous recordings are removed from the project and cannot be retrieved
using Undo. However, they remain in the Pool.

Monitoring

In Cubase, monitoring means listening to the input signal while preparing to record
or while recording.

The following ways of monitoring are available.

- Via Cubase.
- Externally by listening to the signal before it reaches Cubase.
- By using ASIO Direct Monitoring.
  This is a combination of both other methods.

Monitoring via Cubase

If you use monitoring via Cubase, the input signal is mixed with the audio playback.
This requires an audio hardware configuration with a low latency value.

PROCEDURE
1. In the track list, activate the Monitor button.

2. In the MixConsole, adjust the monitoring level and the panning.
   You can add effects and EQ to the monitor signal using the track’s channel. If you are
   using plug-in effects with large inherent delays, the automatic delay compensation
   function in Cubase will increase the latency. If this is a problem, you can use the
   Constrain Delay Compensation function while recording.
3. Select File > Preferences > VST.
4. Open the Auto Monitoring pop-up menu and select a monitoring mode.

RESULT
The monitored signal will be delayed according to the latency value which depends on your audio hardware and drivers. You can check the latency of your hardware in the Device Setup dialog (Device > Device Setup > VST Audio System).

RELATED LINKS
VST on page 1082

External Monitoring

External monitoring means listening to the input signal before it is sent into Cubase. It requires an external mixer for mixing the audio playback with the input signal. The latency value of the audio hardware configuration does not affect the monitor signal. When using external monitoring, you cannot control the level of the monitor signal from within Cubase or add VST effects or EQ to the monitor signal.

PROCEDURE
1. Select File > Preferences > VST.
2. Open the Auto Monitoring pop-up menu and select Manual.
3. Deactivate the Monitor buttons in Cubase.
4. On your mixing desk or mixer application for your audio hardware, activate the Thru or Direct Thru mode to send the input audio back out again.

ASIO Direct Monitoring

If your audio hardware is ASIO 2.0 compatible, it may support ASIO Direct Monitoring. This feature may also be available for audio hardware with Mac OS X drivers. In ASIO Direct Monitoring mode, the monitoring is done in the audio hardware, and monitoring is controlled from Cubase. The latency value of the audio hardware configuration does not affect the monitor signal when using ASIO Direct Monitoring.

PROCEDURE
1. In the track list, activate the Monitor button.
2. Select Devices > Device Setup.
3. In the **Device Setup** dialog, select your driver in the **Devices** list on the left to display the driver settings for your audio hardware, and activate the **Direct Monitoring** checkbox.
   
   If the checkbox is grayed out, your audio hardware (or its driver) does not support ASIO Direct Monitoring. Consult the audio hardware manufacturer for details.

4. Select **File > Preferences > VST**.

5. Open the **Auto Monitoring** pop-up menu and select a monitoring mode.

6. In the MixConsole, adjust the monitoring level and panning.
   
   Depending on the audio hardware, this might not be possible.

---

**AFTER COMPLETING THIS TASK**

You can monitor the input levels of audio tracks, that is, you can map the input bus metering to monitor-enabled audio tracks and watch the input levels of your audio tracks when working in the **Project** window.

- Select **File > Preferences > Metering** and activate **Map Input Bus Metering to Audio Track (in Direct Monitoring)**.

  As the tracks are mirroring the input bus signal you will see the same signal in both places. When using mapped metering, any functions that you apply to the audio track are not reflected in its meters.

**NOTE**

When using Steinberg hardware (MR816 series) in combination with ASIO Direct Monitoring, monitoring will be virtually latency-free. If you are using RME Audio Hammerfall DSP audio hardware, make sure that the pan law is set to -3dB in the card’s preferences.

**NOTE**

With Direct Monitoring activated, Direct Routing can not be used for routing destinations 2-8. Only the Main bus can be used for Direct Monitoring.

**RELATED LINKS**

- [VST](#) on page 1082

---

**Monitoring MIDI Tracks**

You can monitor everything you play and record though the MIDI output and channel that are selected for the MIDI track.

**PREREQUISITE**

Local Off is activated on your MIDI instrument.

**PROCEDURE**

1. Select **File > Preferences > MIDI**.

2. Make sure **MIDI Thru Active** is activated.
3. In the track list, activate the Monitor button.

RESULT
Incoming MIDI is echoed back out again.

RELATED LINKS
MIDI on page 1068

Audio Recording Specifics

Preparations

Selecting a Record File Format

You can set up the record file format, that is the sample rate, bit resolution, and record file type for new audio files.

PROCEDURE
1. Select Project > Project Setup.
2. Set up the settings for Sample Rate, Bit Resolution, and Record File Type.

IMPORTANT
The bit resolution and file type can be changed at any time while the sample rate of a project cannot be changed at a later stage.

RELATED LINKS
Creating New Projects on page 67

Setting the Audio Record Folder

Each Cubase project has a project folder containing an Audio folder. By default, this is where recorded audio files are stored. However, you can select record folders independently for each audio track if needed.

PROCEDURE
1. In the track list, select all tracks that you want to assign the same record folder.
2. Right-click one of the tracks to open the context menu.
3. Select Set Record Folder.
   A file dialog opens.
4. Navigate to the folder that you want to use as record folder or create a new folder with the New Folder button.
If you want to have separate folders for different types of material (speech, ambient sounds, music, etc.), you can create subfolders within the project Audio folder and assign different tracks to different subfolders. This way, all audio files will still reside within the project folder, which will make managing the project easier.

Getting the Track Ready for Recording

Creating a Track and Setting the Channel Configuration

**PROCEDURE**

1. Select Project > Add Track > Audio.
2. In the Count field, enter the number of tracks that you want to add.
3. Open the Configuration pop-up menu and select a channel configuration.
4. Optional: Enter a track name.
5. Click Add Track.

**RELATED LINKS**
Add Track Dialog on page 134

RAM Requirements for Recording

Each track on which you record requires a certain amount of RAM, and the memory usage increases the longer the recording lasts. For each audio channel, 2.4 MB of RAM are required for MixConsole settings, etc. The memory usage increases with the length of the recording, the sample rate, and the number of tracks you record. Consider the RAM limitation of your operating system when setting up your project for recording.
Selecting an Input Bus for the Track

Before you can record on your track, you must add and set up the required input busses and specify from which input bus the track will record.

**PROCEDURE**

1. In the **Inspector** for the audio track, open the **Input Routing** pop-up menu.

2. Select an input bus.

**RELATED LINKS**

- Setting Up the Input and Output Ports on page 18
- Setting Up Busses on page 17
- Audio Track Inspector on page 83

Recording Audio

You can record audio using any of the basic recording methods.

When you finish recording, an audio file is created in the **Audio** folder within the project folder. In the Pool, an audio clip is created for the audio file, and an audio event that plays the whole clip appears on the recording track. Finally, a waveform image is calculated for the audio event. If the recording was very long, this may take a while.

**NOTE**

The waveform image will be calculated and displayed during the actual recording process. This realtime calculation uses some processing power. If your processor is slow or if you are working on a CPU-intensive project, select **File > Preferences > Record > Audio** and deactivate **Create Audio Images During Record**.

**RELATED LINKS**

- Activating Recording on page 213
- Cycle Recording on page 214
Audio Record Modes

By selecting an **Audio Record Mode** you decide what happens to your recording and to any existing events on the track where you are recording. This is necessary because you will not always record on an empty track. There may be situations where you record over existing events, especially in cycle mode.

- To select an **Audio Record Mode**, click the audio symbol in **Record Mode** section of the **Transport** panel and select a record mode.
- To close the **Audio Record Mode** panel, click anywhere outside the panel.

**Keep History**

Existing events or portions of events that are overlapped by a new recording are kept.

**Cycle History + Replace**

Existing events or portions of events that are overlapped by a new recording are replaced by the new recording. However, if you record in cycle mode, all takes from the current cycle recording are kept.

**Replace**

Existing events or portions of events that are overlapped by a new recording are replaced by the last recorded take.

Recording with Effects

Cubase allows you to add effects and/or EQ directly while recording. This is done by adding insert effects and/or making EQ settings for the input channel in the MixConsole.

**IMPORTANT**

If you record with effects, the effects become part of the audio file itself. You cannot change the effect settings after recording.

When you are recording with effects consider using 32-bit float format. This way, the bit resolution will not be reduced, which means there is no risk of clipping at this stage. Also, this preserves the signal quality perfectly. If you record in 16-bit or 24-bit format, the available headroom is lower, which means clipping can occur if the signal is too loud.
Recording Audio Recording Specifics

Recording a Mix of Separate Tracks

You can create a downmix of separate tracks, bass drum, hi-hats, or snare, for example. This is done by selecting an output bus, a group bus, or an FX channel bus as an input for your recording.

PROCEDURE

1. Set up your separate tracks and add a group track.
2. For each of the drum tracks, open the Output Routing pop-up menu and select the group track as output.
3. Create a new audio track, open the Input Routing pop-up menu for it and select the group track as input for this audio track.
4. Record-enable this audio track and start recording.

RESULT

The output of the group track will be recorded on the new track and you will get a mix of your separate tracks.

NOTE

You can also select an FX channel as recording source. In this case, only the output of the FX channel will be recorded.

RELATED LINKS

Routing on page 325

Undoing Recording

If you decide that you do not like what you just recorded, you can delete it.

- Select Edit > Undo.

This removes the events that you just recorded from the Project window and moves the audio clips in the Pool to the trash folder. To remove the recorded audio files from the hard disk, open the Pool, right-click the Trash icon and select Empty Trash.

RELATED LINKS

Pool Window on page 500

Recovering Audio Recordings

Cubase allows you to recover audio recordings in two situations: if you specified an audio pre-record time when you hit the record button too late and after a system failure during recording.
Specifying an Audio Pre-Record Time

You can capture up to 1 minute of any incoming audio that you play in Stop mode or during playback. This is possible because Cubase can capture audio input in buffer memory, even when not recording.

PROCEDURE

1. Select File > Preferences > Record > Audio.
2. Specify a time (up to 60 seconds) in the Audio Pre-Record Seconds field. This activates the buffering of audio input, making pre-record possible.
3. Make sure that an audio track is record-enabled and receives audio from the signal source.
4. When you have played some audio material that you want to capture (either in Stop mode or during playback), click the Record button.
5. Stop the recording after a few seconds. This creates an audio event that starts where the cursor position was when you activated recording. If you were in stop mode, and the cursor was at the beginning of the project, you may have to move the event to the right in the next step. If you were playing along to a project, you leave the event where it is.
6. Select the Object Selection tool and place the cursor on the bottom left edge of the event so that a double arrow appears. Then click and drag to the left.

RESULT

The event is now extended, and the audio that you played before activating the recording is inserted. This means that if you played along during playback, the captured notes end up exactly where you played them in relation to the project.

RELATED LINKS
Record - Audio on page 1075

Recovering Audio Recordings after System Failure

Cubase allows you to recover audio recordings after a system failure, because of a power cut or other mishap, for example.

When you experience a computer crash during a recording, relaunch the system and check the project record folder. By default, this is the Audio subfolder inside the project folder. It should contain the audio file that you recorded, from the moment when you started recording to the time when your computer crashed.

NOTE

- This feature does not constitute an overall guarantee by Steinberg. While the program itself was improved in such a way that audio recordings can be recovered after a system failure, it is always possible that a computer crash, power cut, etc. might have damaged another component of the computer, making it impossible to save or recover any of the data.
Do not try to actively bring about this kind of situation to test this feature. Although the internal program processes have been improved to cope with such situations, Steinberg cannot guarantee that other parts of the computer are not damaged as a consequence.

MIDI Recording Specifics

Preparations

The preparations described in the following sections mainly focus on external MIDI devices.

MIDI Instruments and Channels

Most MIDI synthesizers can play several sounds at the same time, each on a different MIDI channel. This allows you to play back several sounds (bass, piano, etc.) from the same instrument.

Some devices, such as General MIDI compatible sound modules, always receive on all 16 MIDI channels. If you have such an instrument, there is no specific setting to make in the instrument.

On other instruments, you must use the front panel controls to set up a number of parts, timbres, or similar so that they all receive on one MIDI channel.

For more information, see the manual that came with your instrument.

Naming MIDI Ports

MIDI inputs and outputs are often displayed with long and complicated names. In Cubase, you can rename your MIDI ports to more descriptive names.

**PROCEDURE**

1. Select **Devices > Device Setup**.
2. In the **Devices** list, select **MIDI Port Setup**.
   The available MIDI inputs and outputs are listed. On Windows systems, the device to choose depends on your system.
3. Click in the **Show As** column and type in a new name.
4. Click **OK**.

**RESULT**

The new port names appear on the **MIDI Input** and **Output Routing** pop-up menus.
Setting the MIDI Input

In the Inspector, you set the MIDI input for the track.

**PROCEDURE**

1. In the track list, select the track to which you want to assign a MIDI input.
2. In the topmost Inspector section, open the Input Routing pop-up menu and select an input.
   
   The available inputs on the menu depend on the type of MIDI interface that you are using. If you hold down [Shift]-[Alt]/[Option], the selected MIDI input is used for all selected MIDI tracks.

   **NOTE**

   If you select All MIDI Inputs, the track will receive MIDI data from all available MIDI inputs.

Setting the MIDI Channel and Output

The MIDI channel and output settings determine where the recorded MIDI is routed during playback. They are also relevant for monitoring MIDI in Cubase. You can select the channel and output in the track list or in the Inspector.

**PROCEDURE**

1. In the track list, select the track to which you want to assign a MIDI channel and output.
2. In the topmost Inspector section, open the Output Routing pop-up menu and select an output.
   
   The available outputs on the menu depend on the type of MIDI interface that you are using. If you hold down [Shift]-[Alt]/[Option], the selected MIDI output is used for all selected MIDI tracks.

3. Open the Channel pop-up menu and select a MIDI channel.

   **NOTE**

   If you select the Any MIDI channel, the MIDI material is routed to the channels that are used by your MIDI instrument.
Selecting a Sound

You can select sounds from within Cubase by instructing the program to send Program Change and Bank Select messages to your MIDI device.

PROCEDURE

1. In the track list, select the track to which you want to assign a sound.
2. In the track list or the Inspector, open the Program Selector pop-up menu and select a program.
   Program Change messages give access to 128 different program locations.
3. If your MIDI instruments have more than 128 programs, you can open the Bank Selector pop-up menu and select different banks, each containing 128 programs.

NOTE

Bank Select messages are recognized differently by different MIDI instruments. The structure and numbering of banks and programs may also vary. Refer to the documentation of your MIDI instruments for details.

RELATED LINKS

MIDI Track Inspector on page 96

Recording MIDI

You can record MIDI using any of the basic recording methods.

When you finish recording, a part that contains MIDI events is created in the Project window.

NOTE

If you perform a live recording on a VST instrument, you usually compensate the latency of the audio card by playing earlier. In consequence, the timestamps are recorded too early. If you activate the ASIO Latency Compensation button on the track list, all recorded events are moved by the current latency setting.

The following preferences affect MIDI recording:

- Length Adjustment
- Snap MIDI Parts to Bars
- Solo Record in MIDI Editors
- MIDI Record Catch Range in ms
- ASIO Latency Compensation Active by Default

You can find them on the MIDI and Record–MIDI page of the Preferences dialog.

RELATED LINKS

MIDI on page 1068
Record - MIDI on page 1076
Recording Different Types of MIDI Messages

You can record different types of MIDI messages.

- To specify which event types are recorded, select File > Preferences > MIDI > MIDI Filter and deactivate the options for the type of MIDI message that you want to record.

RELATED LINKS
MIDI - MIDI Filter on page 1073

Recording MIDI Notes

If you press and release a key on your synthesizer or on another MIDI keyboard, the following messages are recorded:

- Note On (key down)
- Note Off (key up)
- MIDI channel

NOTE
Normally, the MIDI channel information is overridden by the MIDI channel setting for the track. However, if you set the track to the Any MIDI channel, the notes will be played back on their original channels.

Recording Continuous Messages

Pitchbend, aftertouch, and controllers, such as modulation wheel, sustain pedal, volume, etc. are considered as MIDI continuous events, as opposed to the momentary key down and key up messages.

You can record continuous messages together or independently from the notes, that is, afterwards or before.

You can record continuous messages on their own tracks, separately from the notes to which they belong. As long as you set the two tracks to the same output and MIDI channel, it will appear to the MIDI instrument as if you made the two recordings at the same time.

Recording Program Change Messages

When you switch from one program to another on your synthesizer or on another MIDI keyboard, a number corresponding to that program is sent out via MIDI as a Program Change message.

You can record Program Change Messages together or independently from the notes, that is, afterwards or before.
You can record Program Change Messages on their own tracks, separately from the notes to which they belong. As long as you set the two tracks to the same output and MIDI channel, it will appear to the MIDI instrument as if you made the two recordings at the same time.

**Recording System Exclusive Messages**

System Exclusive (SysEx) messages are special types of MIDI messages that are used to send data that only makes sense to a unit of a certain make and type.

SysEx can be used to transmit a list of the numbers that make up the settings of one or more sounds in a synth.

**Reset Function**

The **Reset** function sends out note-off messages and resets controllers on all MIDI channels. This is sometimes necessary if you experience hanging notes, constant vibrato, etc. when punching in and out on MIDI recordings with pitchbend or controller data.

- To perform a MIDI reset manually, select **MIDI > Reset**.
- If you want Cubase to perform a MIDI reset on stop, select **File > Preferences > MIDI** and activate **Reset on Stop**.
- If you want Cubase to insert a reset event at the end of a recorded part, select **File > Preferences > MIDI** and activate **Insert Reset Events after Record**.

This resets controller data such as sustain, aftertouch, pitchbend, modulation, and breath control. This is useful if a MIDI part is recorded and the sustain pedal is still held after stopping recording. Usually, this would cause all following parts to be played with sustain, as the pedal off command was not recorded.

**RELATED LINKS**

- MIDI on page 1068

**MIDI Record Modes**

By selecting a **MIDI Record Mode** you decide what happens to any existing parts on the track where you are recording. MIDI tracks can play back all events in overlapping parts. If you record several parts in the same locations or move parts so that they overlap, you will hear the events in all parts.
Recording
MIDI Recording Specifics

• To select a MIDI Record Mode, click the MIDI symbol in the left section of the Transport panel.

• To close the MIDI Record Mode panel again, click anywhere outside the panel.

MIDI Record Mode

New Parts
Existing parts that are overlapped by a new recording are kept. The new recording is saved as a new part.

Merge
Existing events in parts that are overlapped by a new recording are kept. The newly recorded events are added to the existing part.

Replace
Existing events in parts that are overlapped by a new recording are replaced.

MIDI Cycle Record Mode

When you record MIDI in cycle mode, the result not only depends on the MIDI Record Mode, but also on the Cycle Record Mode that is selected in the MIDI Cycle Record Mode section.

Mix
For each completed lap, everything you record is added to what was previously recorded. This is useful for building up rhythm patterns. Record a hi-hat part on the first lap, the bass drum part on the second lap, etc.

Overwrite
As soon as you play a MIDI note or send any MIDI message, all MIDI that you have recorded on previous laps is overwritten from that point. Make sure that you stop playing before the next lap begins. Otherwise, you will overwrite the entire take.
Keep Last

Each completed lap replaces the previously recorded lap. If you deactivate recording or press Stop before the cursor reaches the right locator, the previous take will be kept. If you do not play or input any MIDI during a lap, nothing happens, and the previous take will be kept.

Stacked

Each recorded cycle lap is turned into a separate MIDI part, and the track is divided into lanes, one for each cycle lap. The parts are stacked above each other, each on a different lane. All takes but the last one are muted.

Mix Stacked

Same as Stacked, but parts are not muted.

Quantizing MIDI Recordings

Cubase can automatically quantize MIDI notes on recording.

- To enable automatic quantizing, open the Transport panel and in the Record Mode section, activate Auto Quantize.

The notes that you record are automatically quantized according to the Quantize settings.

**RELATED LINKS**
- Quantizing MIDI and Audio on page 234
- Common Settings on page 238

Recovering MIDI Recordings

Cubase allows you to recover MIDI recordings.
Enabling Retrospective Record

The Retrospective Record setting allows you to capture any MIDI notes that you play in Stop mode or during playback and turn them into a MIDI part after the fact. This is possible because Cubase can capture MIDI input in buffer memory, even when not recording.

PROCEDURE

1. Select File > Preferences > Record–MIDI.
2. Enable Retrospective Record and specify a Retrospective Record Buffer Size.
   This activates the buffering of MIDI input.
3. In the MIDI track list, activate the Record Enable button.
4. Play some MIDI material either in Stop mode or during playback.
5. Select Transport > Retrospective Record.

RESULT

The content of the MIDI buffer is turned into a MIDI part on the record-enabled track, and the captured notes end up exactly where you played them in relation to the project.

RELATED LINKS

Record - MIDI on page 1076

Remaining Record Time

The Record Time Max display lets you see how much time you have left for recording.

The available time depends on the current setup, for example, on the amount of tracks that are record-enabled, the sample rate for your project, and the available hard disk space.

- To open the display, select Devices > Record Time Max.

NOTE

The remaining record time is also shown in the status line above the track list.

If you use individual record folders to store your tracks on different drives, the time display refers to the medium with the least storage space available.
Lock Record

The **Lock Record** function prevents you from accidentally deactivating the record mode.

- Select **File > Key Commands** and in the **Transport** category, assign key commands to the **Lock Record** and **Unlock Record** commands.

If **Lock Record** is activated and you want to enter Stop mode, a dialog opens in which you need to confirm that you want to stop recording. You can also use the **Unlock Record** key command first and then enter Stop mode as usual.

**NOTE**

An automatic punch-out at the right locator position will be ignored in **Lock Record** mode.
Quantizing MIDI and Audio

Quantizing means moving recorded audio or MIDI and positioning it on the nearest grid position that is musically relevant. Quantizing is designed to correct errors, but you can also use it in a creative way.

You can quantize audio and MIDI to a grid or to a groove. You can also quantize multiple audio tracks simultaneously.

Audio and MIDI can be quantized at the same time. However, what exactly happens during quantizing differs for audio and MIDI:

- Audio quantizing affects the audio event starts or the content of your audio.
- MIDI quantizing can affect the starts of MIDI events in a part, the MIDI event lengths, or the MIDI event ends.

**NOTE**

Quantizing is based on the original position of the events. Therefore, you can freely try out different quantize settings without the risk of destroying anything.

The Quantize function is found on the Edit menu. You can also use the key command [Q] or the “Quantize” button on the Quantize Panel.

**RELATED LINKS**

- Quantizing Audio Event Starts on page 234
- AudioWarp Quantize (Cubase Pro only) on page 235
- Quantizing MIDI Event Starts on page 236
- Quantizing MIDI Event Lengths on page 236
- Quantizing MIDI Event Ends on page 236

**Quantizing Audio Event Starts**

If you select audio events or a sliced loop and use the Quantize function, the audio events are quantized based on their snap points or event starts.

The snap points that do not match exact note positions on the selected grid are moved to the closest grid positions. The grid is set up on the Quantize pop-up menu. If no snap points are available, the event start is moved.

**NOTE**

If you use the Quantize function on an audio part, the event starts inside the part are quantized.
AudioWarp Quantize (Cubase Pro only)

If you want to quantize the content of your audio event by applying time stretch, use the “AudioWarp Quantize” function. This function quantizes the audio event by aligning the warp markers to the defined quantize grid.

The following happens:

- Warp markers are created at hitpoint positions. If no hitpoints are available, they are automatically created. Furthermore, warp markers are created at every event start and end.
- The audio sections between the warp markers are stretched or compressed to fit into the time interval set up on the “Quantize Presets” pop-up menu.

AudioWarp quantize prevents warp markers from ending up on the same position. If conflicts occur, only one of the warp markers is quantized. For example, if you use a quantize value of 1/4 on audio that is based on sixteenth notes, the warp markers at the quarter-note positions are quantized to the grid, and the remaining warp markers are moved, keeping the relative distances between the warp markers.

You can also apply AudioWarp quantizing to selection ranges in the Project window and in the Sample Editor. To avoid moving transient positions that lie outside the selection range, additional warp markers are created at the closest hitpoint positions outside the range.

RELATED LINKS
   Working with hitpoints and slices on page 459

Applying AudioWarp Quantizing

PROCEDURE

1. Select the audio event that you want to quantize.
2. On the toolbar, activate the “AudioWarp Quantize” button, open the “Quantize Presets” pop-up menu, and select a preset to determine the quantize grid.
3. Open the Edit menu, and select Quantize.
   You can also use the Quantize Panel for applying AudioWarp quantizing. The Quantize Panel provides more parameters for defining the quantize grid.

RELATED LINKS
   Quantize Panel on page 238
Quantizing MIDI Event Starts

If you select MIDI notes in a part and use the Quantize function on the Edit menu, the MIDI note starts are quantized, that is, the starts of MIDI notes that do not match exact note positions are moved to the closest grid positions. The grid is set up on the Quantize pop-up menu. The note lengths are maintained.

NOTE
If you quantize MIDI parts, all events are quantized, even if none is selected.

Quantizing MIDI Event Lengths

The “Quantize MIDI Event Lengths” function on the Edit menu, Advanced Quantize submenu, quantizes the lengths of MIDI notes without changing their start positions. At its most basic level, this function sets the lengths of the notes to the Length Quantize value on the MIDI editor toolbar by cutting off the note ends.

However, if you have selected the “Quantize Link” option on the “Length Quantize” pop-up menu, the function resizes the notes according to the quantize grid, taking the Swing, Tuplet, and Catch Range settings into account.

Quantizing MIDI Event Ends

The “Quantize MIDI Event Ends” function on the Edit menu, Advanced Quantize submenu, moves the ends of your MIDI notes to the nearest grid positions, taking the Quantize pop-up menu setting into account.

Quantizing Multiple Audio Tracks (Cubase Pro only)

You can quantize multiple audio tracks at the same time. To maintain phase coherence, all tracks have to be sliced at exactly the same start and end positions. Only then the resulting slices can be quantized without risk of getting phase errors.

NOTE
For this to work, the audio tracks must reside in the same folder track and the “=” button for Group Editing must be activated. Furthermore, at least one of the tracks must contain hitpoints.
Quantizing MIDI and Audio

AudioWarp Quantizing Multiple Audio Tracks (Cubase Pro only)

PROCEDURE
1. Create an edit group for the audio tracks that you want to quantize.
2. In the Sample Editor, create hitpoints for at least one of the audio tracks that you want to quantize, and fine-tune the hitpoint detection result with the Threshold slider.
3. Open the Quantize Panel.
4. Set up the parameters in the “Slice Rules” section and click the Slice button.
5. Set up the parameters in the Quantize section and click the Quantize button.
6. Set up the parameters in the Crossfades section and click the Crossfade button to correct for overlaps or gaps in the quantized audio.

AudioWarp Quantizing Multiple Audio Tracks (Cubase Pro only)

Instead of slicing the audio events and using the slices for quantizing, you can use warp markers for quantizing multiple audio tracks.

NOTE

Note that AudioWarp quantizing does not maintain phase coherence.

To quantize multiple audio tracks using the AudioWarp quantize function, proceed as follows:

PROCEDURE
1. Create an edit group for the audio tracks that you want to quantize.
2. In the Sample Editor, create hitpoints for at least one of the audio tracks that you want to quantize, and fine-tune the hitpoint detection result with the Threshold slider.
3. Open the Quantize Panel, activate the “AudioWarp Quantize” button, and set up the parameters in the “Warp Marker Creation Rules” section.
4. Click the Create button.
5. Set up the other parameters on the Quantize Panel, and click the Quantize button.
   AudioWarp quantizing is applied to all tracks in the edit group.
Quantizing MIDI and Audio
Quantize Panel

The Quantize Panel provides further parameters for defining how to quantize audio or MIDI. These parameters allow you to set up a more sophisticated quantization.

Using the Quantize Panel, you can quantize audio or MIDI to the grid or to a groove. Depending on what method you choose, different parameters are shown on the Quantize Panel. There is also a set of common settings.

You can open the Quantize Panel by clicking the corresponding button on the toolbar or by opening the Edit menu and selecting “Quantize Panel”.

Common Settings

Quantize Presets Pop-Up Menu

On this pop-up menu, you can select a quantize or a groove preset.

Save/Remove Preset

The preset controls allow you to save the current settings as a preset, making them available on all “Quantize Presets” pop-up menus. This includes Swing, “Catch Range”, etc.

- To save a preset, click the “Save Preset” button (the plus sign) to the right of the Quantize Presets pop-up menu. A preset name is generated automatically, according to your settings.
- To rename a preset, open the “Quantize Presets” pop-up menu, select “Rename Preset” and enter the new name in the dialog that appears.
- To remove a user preset, select it and click the “Remove Preset” button.

Non-Quantize

This setting allows you to create a safe zone before and after the quantize positions, by specifying a “distance” in ticks (120 ticks = one 16th note). Events that lie within this zone are not quantized. This allows you to keep slight variations when you quantize, but correct notes that are too far away from the grid positions.
Grid Display

In the middle of the Quantize Panel the grid display is shown. The green lines indicate the quantize grid, that is, the positions that audio or MIDI is moved to.

Randomize

This setting allows you to set a distance in ticks, so that your audio or MIDI is quantized to random positions within the specified distance from the quantize grid. This allows for slight variations and, at the same time, prevents your audio or MIDI from ending up too far away from the grid.

MIDI CC

If you activate this button, controllers related to MIDI notes (pitchbend, etc.) are automatically moved with the notes when these are quantized.

Auto Apply

If you activate this button, any changes you make are immediately applied to the selected parts or events. A way of using this feature is to set up a playback loop and adjust the settings until you are satisfied with the result.

iQ Mode and Iterative Strength Setting

If you quantize your audio or MIDI with the “iQ Mode” (iterative quantize) option activated, a “loose” quantization is applied. This means that your audio or MIDI moves only part of the way to the closest quantize grid position. You can specify an “Iterative Strength” value to the right of the “iQ Mode” option. This value determines how close your audio or MIDI moves towards the grid.

NOTE

Iterative quantizing is based on the current, quantized positions and not on the original event positions. This makes it possible to repeatedly use iterative Quantize, gradually moving your audio or MIDI closer to the quantize grid until you have found the right timing.

Reset Quantize

This button is identical with the “Reset Quantize” function on the Edit menu.

IMPORTANT

If you move an audio event manually, the actual event start changes. Therefore, the “Reset Quantize” function has no effect on an event that was moved manually.

Quantize

Clicking this button applies your settings.

RELATED LINKS

Reset Quantize on page 245
Options For Quantizing to a Musical Grid

Grid

On this pop-up menu you can determine the basic value for the quantize grid.

Swing

This parameter lets you offset every second position in the grid, creating a swing or shuffle feel.

This setting is only available when a straight value is selected for the grid and Tuplet is off (see below).

Catch Range

This parameter allows you to specify that quantizing affects only audio or MIDI within a certain distance from the grid lines, the so-called catch range. This allows for complex quantization tasks, for example, if you want to quantize only the heavy beats near each beat, and not the events in-between.

With a value of 0%, all audio or MIDI is affected by quantizing. With higher percentages, wider catch ranges are shown around the green lines in the grid display.

Tuplet

This parameter allows you to create rhythmically more complex grids by dividing the grid into smaller steps, and thereby creating n-tuplets.
Options for Quantizing to a Groove

Groove quantizing is intended for recreating existing rhythmic feels by matching your recorded music to a timing grid generated from a MIDI part or an audio loop.

To extract the groove from a MIDI part, from an audio loop, an audio event with hitpoints, or sliced audio, select the material and drag it onto the grid display in the middle of the Quantize Panel. Alternatively, you can use the “Create Groove Quantize Preset” function.

Position

This parameter lets you determine how much the timing of the groove affects the music. 0% means that the timing of the music remains unaffected, while 100% means that the timing is adjusted to match the groove completely.

Velocity (MIDI Only)

This parameter lets you determine how much the velocity values within the groove affect the music. Note that not all grooves contain velocity information.

Length (MIDI Only)

This parameter lets you specify how much the length of the notes is affected by the groove. This is done by modifying the note-off value.

NOTE

For drums, the Length setting is ignored as drum sounds cannot be sustained.

Pre-Quantize

This pop-up menu lets you quantize your audio or MIDI to a musical grid before groove quantizing. This helps you to get the notes closer to their groove destination.

For example, if you apply a shuffle groove to a 16th-note pattern, you can set up a Pre-Quantize value of 16 to straighten up the timing before applying the groove quantizing.

Max. Move

Here, you can select a note value to specify a maximum distance that the audio or MIDI is moved.
Orig. Position

If you activate this option, the starting point of the quantizing operation is not the first bar of the project, but the original starting position of the audio or MIDI material used to find the groove. This allows you to synchronize material that does not start from bar 1 of the project.

RELATED LINKS
Creating Groove Quantize Presets on page 246

Options for Quantizing Multiple Audio Tracks

In the “Slice Rules” section, you determine how the audio events are sliced at the hitpoints.

Hitpoint Tracks

This column lists all audio tracks of your edit group that have hitpoints.

Priority

In this column, you can define a priority for each track. This specifies which hitpoints are used to slice your audio events. The track with the highest priority defines where the audio is sliced. The audio on all tracks is sliced at all hitpoints of this track.

If you set up the same priority for several tracks, the cutting position is defined by the track that contains the first hitpoint within the specified range. This is decided for each cutting position anew.

- Click and drag to the right or to the left to specify a priority.
  If you drag the mouse to the far left so that no star is shown, the hitpoints on the corresponding track are not taken into account.

If the zoom factor is high enough, cutting positions are marked in the Project window by vertical lines:

- The red lines indicate the cutting positions on the main track, that is, on the track whose hitpoint defines the cutting position.
- The black lines indicate the cutting positions on all other tracks.
Quantizing MIDI and Audio
Quantize Panel

Range
Two hitpoints on different tracks are considered to mark the same beat if they are located within a certain distance from each other. The Range parameter lets you specify this distance. The following rules apply:

• If one of the tracks has a higher priority, its hitpoint is used as the cutting position.
• If the tracks have the same priority, the first hitpoint in the range is used.

Offset
With this parameter, you can determine an offset, allowing for slight variations of the cutting position. The Offset value determines how far before the actual hitpoint position an audio event is sliced. This is useful if you want to create crossfades at the slice positions. Furthermore, it helps to avoid cutting off signals on tracks that do not contain any hitpoints.

AudioWarp Quantize On/Off
Click this button to activate AudioWarp quantizing. This enables the “Warp Marker Creation Rules” section.

Slice
If you click the Slice button, all audio events of the edit group are sliced at exactly the same positions according to your settings. The event snap points are set to the position of the hitpoint with the highest priority.

Reset
Click this button to undo the slicing and restore the original state of the audio events.

RELATED LINKS
Options for AudioWarp Quantizing Multiple Audio Tracks on page 244
The Crossfades Section on page 243

The Crossfades Section
The Crossfades section becomes available after you have sliced the audio events. The functions in this section are designed to correct the overlaps or the gaps that might appear due to the re-positioning of your audio.

Clicking the Crossfade button cuts the end of the first event at the start position of the following event (in case of overlaps), and stretches the second event until it starts at the end of the previous event (in case of gaps).
In some cases, you might want to achieve seamless transitions, applying crossfades after closing the gaps. For this purpose, use the following parameters:

**Open Crossfade Editor**

This opens the Crossfade editor, where you can specify curve kind, length, and other parameters for your crossfades.

**Nudge Crossfade Left/Right**

Clicking these buttons moves the fade area in the audio event to the left or to the right in steps of one millisecond. This is useful if the Offset value in the section “Slice Rules” was not high enough, and you want to avoid that the crossfade cuts an attack.

**Length**

With this parameter you can specify the length of the crossfade area.

**RELATED LINKS**

The Crossfade dialog on page 254

---

**Options for AudioWarp Quantizing Multiple Audio Tracks**

The “Warp Marker Creation Rules” section becomes available when you activate AudioWarp quantizing for multiple audio tracks.

**Priority**

In this column, you can define a priority for each track. The track with the highest priority defines where the warp markers are created.

If you set up the same priority for several tracks, the warp marker position is defined by the track that contains the first hitpoint within the specified range. This is decided for each warp marker position anew.

- Click and drag the mouse to the right or to the left to specify a priority. If you drag the mouse to the far left so that no star is shown, the hitpoints on the corresponding track are not taken into account.
Range

Two hitpoints on different tracks are considered to mark the same beat if they are located within a certain distance from each other. The Range parameter lets you specify this distance. The following rules apply:

- If one of the tracks has a higher priority, its hitpoint is used to create the warp marker.
- If the tracks have the same priority, the first hitpoint in the range is used.

Reset

Click this button to undo the creation of warp markers.

AudioWarp Quantize On/Off

Click this button to deactivate AudioWarp quantizing. This enables the “Slice Rules” section.

Create

If you click the Create button, warp markers are created for all the tracks.

Additional Quantizing Functions

Freezing MIDI Quantizing

The Freeze MIDI Quantize function on the Edit menu, Advanced Quantize submenu, makes the start and end positions of MIDI events permanent. This is useful in situations where you want to quantize a second time, based on the current quantized positions rather than the original positions.

Reset Quantize

This command on the Edit menu reverts your audio or MIDI to its original, unquantized state. This function is independent from the regular Undo History.

NOTE

The Reset function also resets any length changes that you performed using the “Scale Length/Legato” slider.

RELATED LINKS

Options for Quantizing Multiple Audio Tracks on page 242

Length on page 704
Creating Groove Quantize Presets

You can generate a groove quantize map based on hitpoints that you have created in the Sample Editor.

**PROCEDURE**

1. Open the Sample Editor for the audio event from which you want to extract the timing.
2. Create and edit hitpoints.
3. On the Hitpoints tab, click the “Create Groove” button.
   
   The groove is extracted.

**RESULT**

If you open the Quantize pop-up menu on the Project window toolbar, you will find an additional item at the bottom of the list, with the same name as the file from which you have extracted the groove. You can select it as a base for quantizing, just like any other quantize value.

**AFTER COMPLETING THIS TASK**

To save the groove, open the Quantize Panel and save it as a preset.

**RELATED LINKS**

- Working with hitpoints and slices on page 459
- Save/Remove Preset on page 238
Creating fades

There are two types of fade ins and fade outs in audio events in Cubase: event-based fades that you create by using the fade handles and clip-based fades created by processing.

RELATED LINKS
Event-based fades on page 247
Clip-based fades on page 249

Event-based fades

Selected audio events have triangular handles in the upper left and right corners. These can be dragged to create a fade in or fade out, respectively.

The fade handles are visible when you point the mouse at the event.

The fade is automatically reflected in the shape of the event’s waveform, giving you a visual feedback of the result when dragging the fade handle.

Fades created with the handles are not applied to the audio clip as such but calculated in realtime during playback. This means that several events referring to the same audio clip can have different fade curves. It also means that having a large number of fades may require more processing power.

- If you select multiple events and drag the fade handles of one of them, the same fade is applied to all selected events.
- A fade can be edited in the Fade dialog, as described on the following pages. You open the dialog by double-clicking in the area above the fade curve, or by selecting the event and selecting “Open Fade Editor(s)” from the Audio menu (note that this will open two dialogs if the event has both fade in and fade out curves).
If you adjust the shape of the fade curve in the Fade dialog, this shape will be maintained when you later adjust the length of the fade.

• You can make the fade longer or shorter at any time, by dragging the handle. You can do this without selecting the event first, i.e. without visible handles. Just move the mouse pointer along the fade curve until the cursor turns into a bidirectional arrow, then click and drag.

• If the “Show Event Volume Curves Always” option is activated in the Preferences dialog (Event Display–Audio page), fade curves are shown in all events, regardless of whether they are selected or not. If the option is deactivated, the fade curves are shown in selected events only.

• If the “Use Mouse Wheel for Event volume and Fades” option is activated in the Preferences dialog (Editing–Audio page), moving the mouse wheel moves the volume curve up or down. When you press [Shift] while moving the mouse wheel, and position the mouse pointer somewhere in the left half of the event, the fade in end point is moved. When the mouse pointer is in the right half of the event, the fade out start point is moved.

**NOTE**

In the Key Commands dialog (Audio category) you can set up key commands for changing the event volume curve and any fade curves.

**NOTE**

Cubase Pro only: As an alternative to dragging the fade handles, you can use the “Fade In to Cursor” and “Fade Out to Cursor” options on the Audio menu to create fades. Position the project cursor on an audio event where you want a fade in to end or a fade out to begin, and select the appropriate option from the Audio menu. A fade will then be created, ranging from the event’s start or end to the position of the cursor.

**RELATED LINKS**

[Key Commands on page 997](page 997)

### Creating and adjusting fades with the Range Selection tool

Event-based fades can also be created and adjusted with the Range Selection tool.

**PROCEDURE**

1. Select a section of the audio event with the Range Selection tool.
2. Open the Audio menu and select “Adjust Fades to Range”. The result depends on your selection:
   • If you select a range from the beginning of the event, a fade in is created within the range.
Fades, crossfades, and envelopes

Creating fades

- If you select a range that reaches the end of an event, a fade out is created in the range.
- If you select a range encompassing a middle section of the event, but not reaching neither the start nor the end, a fade in is created from the beginning of the event to the beginning of the selected range, and a fade out is created from the end of the selected range to the end of the event.

**IMPORTANT**

You can select multiple audio events on separate tracks with the Range Selection tool, and apply the fade to all of them simultaneously.

About the volume handle

A selected audio event also has a square handle in the top middle: the volume handle. It provides a quick way of changing the volume of an event in the Project window. Note that dragging the volume handle also changes the value on the info line.

The volume change is displayed numerically on the info line.

![Volume handle](image)

The event waveform reflects the volume change.

- Drag the Volume handle up or down to change the volume of the event.

Removing fades

- To remove the fades for an event, select the event and select “Remove Fades” from the Audio menu.
- If you want to remove the fades in a specific range only, select the fade area with the Range Selection tool and select “Remove Fades” from the Audio menu.

Clip-based fades

If you have selected an audio event or a section of an audio event (using the Range Selection tool), you can apply a fade in or fade out to the selection by using the “Fade In” or “Fade Out” function on the Process submenu of the Audio menu. These functions open the corresponding Fade dialog, allowing you to specify a fade curve. Fades created this way are applied to the audio clip rather than to the event.
Fades, crossfades, and envelopes

The Fade dialogs

**IMPORTANT**

The length of the fade area is determined by your selection. In other words, you specify the length of the fade before you open the Fade dialog. You can select multiple events and apply the same processing to all of them simultaneously.

- If you later create new events that refer to the same clip, these will have the same fades.
- You can remove or modify the fades at any time using the Offline Process History.

If other events refer to the same audio clip, you will be asked whether you want the processing to be applied to these events or not.

- Continue will apply the processing to all events that refer to the audio clip.
- New Version will create a separate, new version of the audio clip for the selected event.
- You can also activate the “Please, don’t ask again” option. Regardless of whether you then choose “Continue” or “New Version”, any further processing will conform to the option you select.
  You can change this setting at any time in the Preferences dialog (Editing–Audio page), under “On Processing Shared Clips”.

**RELATED LINKS**

The Offline Process History dialog on page 418

The Fade dialogs

The Fade dialogs appear when you edit an existing fade or use the Fade In/Fade Out functions on the Process submenu of the Audio menu. The picture below shows the Fade In dialog; the Fade Out dialog has identical settings and features.

If you open the Fade dialog(s) with several events selected, you can adjust the fade curves for all these events at the same time. This is useful if you want to apply the same type of fade in to more than one event, etc.
The available options are:

**Curve Kind**

These buttons determine whether the fade curve consists of spline curve segments (left button), damped spline segments (middle button), or linear segments (right button).

**Fade display**

This shows the shape of the fade curve. The resulting waveform shape is shown in dark gray, with the current waveform shape in light gray.

Click on the curve to add points, and click and drag existing points to change the shape. To remove a point from the curve, drag it outside the display.

**Curve shape buttons**

These buttons give you quick access to some common curve shapes.

**Restore button**

This button is only available when editing fades made by dragging the fade handles. Click this to cancel any changes you have made since opening the dialog.

**Fade Length Value**

This parameter is only available when editing fades made by dragging the fade handles. It can be used to enter fade lengths numerically. The format of values displayed here is determined by the Time Display in the Transport panel.

- When you activate the Apply Length option, the value entered in the Fade Length value field is used when clicking Apply or OK.
- When you set the current fade as the default fade, the length value is included as part of the default settings.

**Presets**

In this section you can set up presets for fade in or fade out curves that you want to apply to other events or clips.

- To apply a stored preset, select it from the pop-up menu.
- To rename the selected preset, double-click on the name and type in a new one.
- To remove a stored preset, select it from the pop-up menu and click Remove.

**As Default button**

This button is only available when editing fades made by dragging the fade handles. Click this to save the current settings as the default fade, to be used whenever you create new fades by dragging event handles.
Fades, crossfades, and envelopes
Creating crossfades

Applying a fade

Depending on whether you are editing a fade made with the fade handles or applying a fade using processing, different buttons are shown in the bottom row of the Fade dialog.

The Edit Fade dialogs have the following buttons:

OK
Applies the set fade curve to the event, and closes the dialog.

Cancel
Closes the dialog without applying any fade.

Apply
Applies the set fade curve to the event, without closing the dialog.

The Process Fade dialogs have the following buttons:

Preview
Plays back the fade area. Playback will repeat until you click the button again (the button is labeled “Stop” during playback).

Process
Applies the set fade curve to the clip, and closes the dialog.

Cancel
Closes the dialog without applying any fade.

Creating crossfades

Overlapping audio material on the same track can be crossfaded, for smooth transitions or special effects. You create a crossfade by selecting two consecutive audio events and selecting the Crossfade command on the Audio menu (or by using the corresponding key command, by default [X]).

The result depends on whether the two events overlap or not:

- If the events overlap, a crossfade is created in the overlapping area. The crossfade will be of the default shape (linear, symmetric), but you can change this as described below.
Fades, crossfades, and envelopes

Creating crossfades

NOTE
The default crossfade length and shape are set in the Crossfade dialog.

- If the events do not overlap but are directly consecutive (lined up end-to-start, with no gap) it is still possible to crossfade them – provided that their respective audio clips overlap! In this case, the two events are resized so that they overlap, and a crossfade of the default length and shape is applied.

- If the events do not overlap and cannot be resized enough to overlap, a crossfade cannot be created.

- You can specify the length of the crossfade using the Range Selection tool: make a selection range covering the desired crossfade area and use the Crossfade command on the Audio menu.

   The crossfade is applied to the selected range (provided that the events or their clips overlap, as described above).

NOTE
You can also make a selection range after creating the crossfade and use the function “Adjust fades to Range” on the Audio menu.

- Once you have created a crossfade, you can edit it by selecting one or both crossfaded events, and selecting “Crossfade” from the Audio menu again (or by double-clicking in the crossfade zone).

   This opens the Crossfade dialog.

RELATED LINKS
The Crossfade dialog on page 254

Removing crossfades

To remove a crossfade, proceed as follows:

- Select the corresponding events and select “Remove Fades” from the Audio menu.

- Use the Range Selection tool to select all fades and crossfades you wish to remove, and select “Remove Fades” from the Audio menu.

- Select a crossfade by clicking, and drag it outside the track.
Fades, crossfades, and envelopes
The Crossfade dialog

The Crossfade dialog contains separate, but identical, sections for the fade-in and fade-out curve settings in the crossfade on the left, and common settings on the right:

**Fade curve displays**
These displays show the shape of the fade out and fade in curve, respectively. Click on a curve to add points, click and drag existing points to change their shape, or drag a point outside the display to remove it.

**Curve buttons**
The curve kind buttons determine whether the corresponding fade curve consists of spline curve segments (left button), damped spline segments (middle button) or linear segments (right button).

The curve shape buttons give you quick access to some common curve shapes.

**Equal Gain**
Activate this parameter to adjust the fade curves so that the summed fade in and fade out amplitudes will be the same all along the crossfade region. This is often suitable for short crossfades.

**Equal Power**
Activate this parameter to adjust the fade curves so that the energy (power) of the crossfade will be constant all along the crossfade region.

Equal Power curves have only one editable curve point. You cannot use the Curve kind buttons or the presets when this mode is selected.

**Play buttons**
These buttons allow you to audition the whole crossfade, or the fade out part, or the fade in part. You can set up key commands for this in the following categories of the Key Commands dialog:

- Media category – Preview Start (triggers crossfade playback), Preview Stop (stops crossfade playback).
Fades, crossfades, and envelopes
Auto fades and crossfades

- Transport category – StartStop (triggers global playback), Stop (stops global playback) and StartStop Preview (triggers crossfade playback).

Pre-roll and Post-roll
- Activate pre-roll to start playback before the fade area. Activate post-roll to stop playback after the fade area.
- In the time fields you can enter the desired time (in seconds and milliseconds) for the pre-roll and post-roll length.

Length
- This specifies the length of the crossfade area. Cubase tries to center the crossfade, i.e. the length change will be applied equally to both sides. To be able to resize a crossfade, it must be possible to resize the corresponding event. For example, if the fade out event already plays its audio clip to the end, its end point cannot be moved any further to the right.

Presets section
- Click the Store button to the right of the Presets pop-up menu to store the settings of your crossfade so that you can apply them to other events later.
  - To rename a preset, double-click on the name and type in a new one.
  - To remove a preset, select it on the pop-up menu and click the Delete button.

Default buttons
- Click the As Default button to store the current settings as default. These settings will then be used whenever you create new crossfades.
- Click the Recall Default button to apply the curves and settings of the default crossfade to the Crossfade dialog.

RELATED LINKS
Key Commands on page 997

Auto fades and crossfades

Cubase features an Auto Fade function that can be set both globally, and separately for each audio track. The idea behind the Auto Fade function is to create smoother transitions between events by applying short (1 to 500 ms) fade ins and fade outs.

IMPORTANT
- As event-based fades are calculated in realtime during playback, a higher number of audio events provokes to a higher the demand on the processor when Auto Fades is activated.

NOTE
- Auto fades are not indicated by fade lines!
Making global Auto Fade settings

PROCEDURE

1. To make Auto Fades settings globally for a project, select “Auto Fades Settings…” from the Project menu.
   This opens the Auto Fades dialog for the project.

2. Use the Length value field to specify the length of the Auto Fades or Crossfades (1 to 500 ms).

3. Use the checkboxes in the upper right corner to activate or deactivate Auto Fade In, Auto Fade Out, and Auto Crossfades.

4. To adjust the shapes of Auto Fade In and Auto Fade Out, select the Fades tab and make settings as in the regular Fade dialogs.

5. To adjust the shape of the Auto Crossfade, select the “Crossfades” tab and make settings as in the regular Crossfade dialog.

6. If you want to use your settings in future projects, click the “As Default” button.

7. Click OK to close the dialog.

RELATED LINKS

The Fade dialogs on page 250
The Crossfade dialog on page 254
Making Auto Fade settings for individual tracks

By default, all audio tracks will use the settings you have made in the project's Auto Fades dialog.

However, since Auto Fades use computing power, a better approach may be to turn Auto Fades off globally and activate them for individual tracks, as needed:

**PROCEDURE**

1. Right-click the track in the track list and select “Auto Fades Settings…” from the context menu (or select the track and click the “Auto Fades Settings” button in the Inspector).
   The Auto Fades dialog for the track opens. This is identical to the project’s Auto Fades dialog, with the addition of a “Use Project Settings” option.

2. Deactivate the “Use Project Settings” option.
   Any settings you now make are applied to the track only.

3. Set up the Auto Fades as desired and close the dialog.

Reverting to project settings

If you want a track with individual Auto Fade settings to use the global Auto Fade settings, open the Auto Fades dialog for the track and activate the “Use Project Settings” checkbox.

Event envelopes

An envelope is a volume curve for an audio event. It is similar to the realtime fades, but allows you to create volume changes within the event, not only at the start or end.

To create an envelope for an audio event, proceed as follows:

**PROCEDURE**

1. Zoom in on the event so that you can view its waveform properly.

2. Select the Draw tool.
   When you move the Draw tool over an audio event, a small volume curve symbol is shown next to the tool.

3. To add an envelope point, click in the event with the Draw tool.
   An envelope curve and a curve point appear.
4. Drag the curve point to adjust the envelope shape.
   The waveform image reflects the volume curve.
   • You can add as many curve points as you like.
   • To remove a curve point from the envelope, click on it and drag it outside the event.
   • To remove an event envelope curve from a selected event, open the Audio menu and select the Remove Volume Curve option.
   • The envelope curve is a part of the audio event – it will follow when you move or copy the event.
   
   After copying an event with an envelope, you can make independent adjustments to the envelopes in the original event and the copy.

   **NOTE**

   It is also possible to apply an envelope to the audio clip using the Envelope function on the Process submenu of the Audio menu.

**RELATED LINKS**

- Envelope on page 403
Introduction

The arranger track allows you to work with sections of your project in a non-linear fashion, to simplify arranging to the maximum extent. Instead of moving, copying and pasting events in the Project window to create a linear project, you can define how different sections are to be played back, like a playlist.

For this, you can define arranger events, order them in a list, and add repeats as desired. This offers a different and more pattern-oriented way of working, which complements the usual linear editing methods in the Project window.

You can create several arranger chains, making it possible to save different versions of a song within the project without sacrificing the original version. When you have created an arranger chain that you like, you have the option of “flattening” the list, which creates a normal linear project based on the arranger chain.

You can also use the arranger track for live performances on the stage, in clubs or at parties.

Setting up the arranger track

Let’s say you have prepared a number of audio files that form the base of a typical pop song, with introduction, verse, chorus and bridge. Now you want to arrange these files.

The first step is to create an arranger track. On the arranger track, you define specific sections of the project by creating arranger events. These can be of any length, may overlap and are not bound to the start or end of existing events and parts. Proceed as follows:

**PROCEDURE**

1. Open the project for which you want to create arranger events.
2. Open the Project menu and select Arranger from the Add Track submenu (or right-click the track list and select the corresponding option from the context menu).

   An arranger track is added. There can be only one arranger track in a project, but you can set up more than one arranger chain for this track.
3. On the Project window toolbar, make sure that Snap is activated and that the Snap Type is set to a mode that allows your arranger events to snap to appropriate positions in the project.

   ![Snap to events](image)

   Snap to events is activated, i.e. when drawing in the Project window, new events will snap to existing events.

4. On the arranger track, use the Draw tool to draw an event of the desired length.

   An arranger event is added, called “A” by default. Any following events will be named in alphabetical order.

   You can rename an arranger event by selecting it and changing its name in the Project window info line or by holding down [Alt]/[Option], double-clicking on the name in the arranger chain (see below) and entering a new name.

   You may want to name your arranger events according to the structure of your project, e.g. Verse, Chorus, etc.

5. Create as many events as you need for your project.

   ![Arranger Track](image)

   When arranger events have been created, the music sequence is determined by the arranger events.

   Events can be moved, resized and deleted using the standard techniques. Please note:
   • If you want to change the length of an event, select the Object Selection tool and click and drag the lower corners of the event in the desired direction.
   • If you copy an arranger event (by [Alt]/[Option]-dragging or by using copy/paste), a new event will be created with the same name as the original. However, this new event will be totally independent from the original event.
   • Double-clicking on an arranger event adds it to the current arranger chain.

RELATED LINKS
   Managing arranger chains on page 264

Working with arranger events

You now have a number of arranger events that form the basic building blocks for your arrangement. The next step is to arrange these events using the functions of the Arranger Editor.
Creating an arranger chain

You can set up an arranger chain in the Arranger Editor or in the Inspector for the arranger track. The Arranger Editor is opened by clicking the “e” button in the Inspector or in the track list.

**PROCEDURE**

1. Click the “e” button to open the Arranger Editor.

On the right in the Arranger Editor, the available arranger events are listed, in the order they appear on the timeline. To the left you find the actual arranger chain, which shows in which order the events will be played back, from top to bottom, and how many times they are repeated.

Initially the arranger chain is empty – you set it up by adding events from the list to the chain. There are several ways to add events to the arranger chain:

   - By double-clicking on the name of an event in the window section on the right (or in the Project window).
     When an event is selected in the arranger chain on the left, this will add the event above the selected event. When no events are selected in the arranger chain, the event will be added at the end of the list.
   - By selecting one or more events in the list, right-clicking and selecting “Append Selected In Arranger Chain”.
     This will add the selected events at the end of the list.
   - By dragging and dropping arranger events from the list on the right to the arranger chain on the left.
     A blue insertion line shows you where the dragged event will end up.

An event is dragged into the arranger chain.

   - By dragging arranger events from the Project window into the arranger chain.

If you followed our example, you should now have arranger events arranged in a very basic pop song pattern. However, we have used audio files that are only a few bars
long – to turn our pattern into a “song” (or at least into a basic sketch of the song structure), these files must be looped. This is where the Repeats function comes in. If you want an event to repeat several times, proceed as follows:

- Click in the Repeats field for an event, type in the desired number of repeats and press [Enter].
  
  When playing back the arranger chain, the Counter column indicates which repeat of this event is currently playing.

- Click in the Mode field for an event and select the desired repeat mode.
  
  When you now play back the arranger chain, you will hear the complete arrangement.

2. Make sure that Arranger mode is activated.

   In Arranger mode the project will be played back using the arranger settings.

3. Position the Arranger Editor window so that you can see the arranger track in the Project window, and click in the arrow column for the event at the top of the list.

   You will see the project cursor jump to the beginning of the first event specified in the arranger chain.

4. Activate playback, either from the Arranger Editor or on the Transport panel.

   The events are played back in the specified order.

**RELATED LINKS**

*Arranger Chain Repeat Modes* on page 262

### Arranger Chain Repeat Modes

<table>
<thead>
<tr>
<th>Option</th>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Normal</td>
<td><img src="image" alt="Normal" /></td>
<td>In this mode, the arranger chain will be played back as you set it up.</td>
</tr>
<tr>
<td>Repeat forever</td>
<td><img src="image" alt="Repeat forever" /></td>
<td>In this mode, the current arranger event will be repeated in a loop until you either click on another event in the Arranger Editor or press play once again.</td>
</tr>
<tr>
<td>Pause after Repeats</td>
<td><img src="image" alt="Pause after Repeats" /></td>
<td>In this mode, the playback of the arranger chain will be stopped after having played back all repeats of the current arranger event.</td>
</tr>
</tbody>
</table>
Editing the arranger chain

In the arranger chain on the left, you can do the following:

- Select multiple events by [Ctrl]/[Command]-clicking or [Shift]-clicking as usual.
- Drag events to move them in the list.
- Drag events holding [Alt]/[Option] to create copies of the selected items. The insert location for both move and copy operations is indicated by a colored insertion line. A blue line indicates that the move or copy is possible; a red line indicates that moving or copying events to the current position is not allowed.
- Use the Repeats column to specify how many times each event is to be repeated.
- Click the arrow to the left of an event in the arranger chain to move the playback position to the start of that event.
- To remove an event from the list, right-click on it and select “Remove Touched” from the context menu. To remove several events, select them, right-click and select “Remove Selected”.

Navigating

To navigate between arranger events, you use the arranger transport buttons.

1) Previous chain step
2) Next chain step
3) First repeat of current chain step
4) Last repeat of current chain step

These controls are available in the Arranger Editor, on the Project window toolbar, and on the Transport panel.

In the Arranger Editor, the event that is currently played back is indicated by an arrow in the leftmost column, and the indicators in the Counter column.
Managing arranger chains

You can create several arranger chains. This way, you can create alternative versions for playback.

In the Arranger Editor, the toolbar buttons on the right are used for this:

- Click this to rename the current arranger chain.
- Creates a new, empty arranger chain.
- Creates a duplicate of the current arranger chain, containing the same events.
- Removes the currently selected arranger chain. Only available if you have created more than one arranger chain.

In the Inspector, these functions are accessed from the Arranger pop-up menu (opened by clicking on the Arranger name field).

The arranger chains you create will be listed on the Name pop-up menu, found in the Arranger Editor to the left of the buttons, at the top of the arranger track Inspector, and in the track list. Please note that to be able to select another arranger chain from the pop-up menu, the Arranger mode must be activated.

Flattening the arranger chain

When you have found an arranger chain that suits your purposes, you can “flatten” it, i.e. convert the list into a linear project.

PROCEDURE

1. Click the Flatten button (or select Flatten Chain from the pop-up menu in the Inspector for the arranger track).

   The events and parts in the project are reordered, repeated, resized, moved and/or deleted (if these are not within the boundaries of any used arranger event), so that they correspond exactly to the arranger chain.

   The Flatten button
2. Activate Playback.
   The project will now play back exactly as in Arranger mode, but you can view it and work with it as usual.

**IMPORTANT**

Flattening the arranger chain may remove events and parts from the project. Only use the Flatten function when you know you do not want to edit the arranger track/chain any more. If in doubt, save a copy of the project before flattening the arranger chain.

---

**Flattening options**

Sometimes it might be useful to keep the original arranger events even after flattening the arranger track. By using flattening options you can define which chain is flattened, where it is stored and how it is named together with other options.

**PROCEDURE**

1. Click the Flattening options button.

2. In the window that opens, select the desired options.

3. You can now flatten the arranger track by clicking the Flatten button. If you realize that you want to do further arrangements, you can click the “Go Back” button and make your adjustments. Your Flattening settings will be kept.

4. Click the “Go Back” button to go back to the Arranger Editor or close the window by clicking its Close button.

---

**Flattening options in the Arranger Editor dialog**

In the Source section you can specify which arranger chains are flattened.

**Current Chain**

If you activate this option, only the current chain will be flattened.
Checked Chains…

If you activate this option, you can select the arranger chains you want to flatten in the list to the left.

All Chains

If you activate this option, all arranger chains of the current project will be flattened.

The Destination section allows you to choose where the result of the flattening is saved. The available options are:

Current Project

This is only available if you have selected “Current Chain” as Source. If you activate this option, the result of the flattening of the current chain will be saved in the current project.

New Project

If you activate this option, you can flatten one or several chains in a new project. In this case it might be useful to use naming options. If you activate “Append Chain Name”, the Chain Names will be appended in brackets to the project name. If you activate “Use Chain Name”, the new projects will have the name of the current arranger chains. If you activate “Add Number”, the new projects will be named like the old ones and a number will be appended in brackets.

In the Options section you can make further settings. The available options are:

Keep Arranger Track

If you activate this option, the arranger track will be kept when flattening the arranger chain. Activate “Rename Arranger Events” to append a number to the events, according to their use. For example, if you use arranger event “A” two times, the first occurrence will be renamed “A 1” and the second “A 2”.

Make Real Event Copies

Normally, you will get shared copies when flattening the arranger track. If you activate this option, real copies will be created instead.

Don’t Split Events

If this option is activated, MIDI notes that start before or are longer than the arranger event will not be included. Only MIDI notes that begin and end inside the arranger event boundaries will be taken into account.

Open New Projects

If you activate this option, a new project will be created for every flattened arranger chain. If you activate the “Cascade New Projects” option the opened projects will be cascaded.
Live mode

If you have set up an arranger track and play it back, you have also the possibility to influence the playback order “live”. Note that the Arranger mode has to be activated to be able to use the Live mode.

PROCEDURE

1. Set up an arranger chain in the Inspector or in the Arranger Editor for an arranger track, activate the Arranger mode and play back your project.
   Now you can use your arranger events listed in the lower section of the Inspector to play back your project in Live mode.

2. Switch into Live mode by clicking on the little arrow in the lower list of the Inspector to the left of the arranger event you want to trigger.
   The arranger event will be looped endlessly, until you click on another arranger event. This might be useful, for example, if you want to loop a guitar solo with a flexible length.
   In the Jump Mode pop-up menu, you can define how long the active arranger event will be played, before jumping to the next one.
   • You can stop Live mode by clicking the Stop button or go back to “normal” playback in Arranger mode by clicking on any arranger event in the upper list.
   In the latter case, playback will be continued from the arranger event where you clicked.

RELATED LINKS

Jump Mode options on page 268
Jump Mode options

In the Jump Mode pop-up menu, you can define how long the active arranger event will be played, before jumping to the next one.

The following options are available:

None

Jumps to the next section immediately.

4 bars, 2 bars

When one of these modes is selected, a grid of 4 or 2 bars (depending on the setting) will be placed on the active arranger event. Whenever the respective grid line is reached, playback will jump to the next arranger event. An example:

Let’s say you have an arranger event which is 8 bars long and the grid is set to 4 bars. When the cursor is anywhere within the first 4 bars of the arranger event when you hit the next arranger event, playback will jump to the next event when the end of the fourth bar of the arranger event is reached. When the cursor is anywhere within the last 4 bars of the arranger event, playback will jump to the next event at the end of the event.
When an event is shorter than 4 (or 2) bars and this mode is selected, playback will jump to the next section at the event end.

1 bar
Jumps to the next section at the next bar line.

1 beat
Jumps to the next section at the next beat.

End
Plays the current section to the end, then jumps to the next section.

You can stop Live mode by clicking the Stop button or go back to “normal” playback in Arranger mode by clicking on any arranger event in the upper list.

In the latter case, playback will be continued from the arranger event where you clicked.

Arranging your music to video

The relative time of your arranger track can be taken as a reference instead of the project time. This is useful, if you want to use the arranger track to compose music for video and fill a specific video section with music, by repeating the corresponding number of arranger events.

If you position your external sync master device to a position that does not match the Project Start time, Cubase will jump automatically to the right position in the arranger track and will start playback from there, i.e. the correct relative position and not the absolute project time will be found. The reference for the external timecode can be MIDI or any other timecode that can be interpreted/read by Cubase.

An example:

**PROCEDURE**

1. Set up a project with a MIDI track and three MIDI parts. The first part should start at position 00:00:00:00 and end at position 00:01:00:00, the second should start at position 00:01:00:00 and end at position 00:02:00:00 and the third should start at position 00:02:00:00 and end at position 00:03:00:00.

2. Activate the Sync button on the Transport panel.

3. Add an arranger track and create arranger events that match the MIDI parts.

4. Set up the arranger chain “A-A-B-B-C-C”, activate the Arranger mode and play back your project.

5. Start external timecode at position 00:00:10:00 (within the range of “A”).
In your project, the position 00:00:10:00 will be located and you will hear “A” playing. Nothing special!

Now, let’s see what happens if your external sync master device starts at a position that does not match the Project Start time:
6. Start at 00:01:10:00 (within the range of what originally was “B”).
   In your project, the position 00:01:10:00 will be located and you will hear “A” playing,
   because it plays twice in the arranger track.

7. Start external timecode at position 00:02:10:00 (within the range of what
   originally was “C”).
   In your project, the position 00:02:10:00 will be located and you will hear “B” playing,
   because it plays “later” in the arranger track.

   **NOTE**

   If the Arranger mode is not activated or no arranger track exists, Cubase will work as
   usual.
Cubase offers transpose functions for audio, MIDI and instrument parts and for audio events. These allow you to create variations of your music or change the harmonics of an entire project or separate sections.

Transpose can be applied on three levels:

- To the entire project
  By changing the project Root Key on the Project window toolbar, the whole project will be transposed.

- To sections of the project
  By creating transpose events on the transpose track, you can set transpose values for separate sections of your project.

- To individual parts or events
  By selecting individual parts or events and changing their transpose value in the info line, you can transpose individual parts or events.

**IMPORTANT**

The transpose functions do not change the actual MIDI notes or the audio, but only affect the playback.

Apart from the transpose features described in this chapter, you can also transpose all MIDI notes on the selected track using the MIDI modifiers, selected notes using the Transpose dialog, and MIDI tracks using MIDI effects (see the separate PDF document “Plug-in Reference”).

**RELATED LINKS**

- Transposing an entire project with the root key on page 272
- Transposing separate sections of a project using transpose events on page 275
- Transposing individual parts or events using the info line on page 276
- Transpose on page 647
- Transpose on page 673
Transposing your music

In the following sections we will describe the different possibilities of transposing your music. Note that these can also be combined. However, we recommend you to set the root key first, before recording or changing transpose values on the transpose track.

IMPORTANT
As a general rule, always set the root key first when you work with content with a defined root key.

Transposing an entire project with the root key

The root key you specify for a project will be the reference that audio or MIDI events in your project will follow. You can however exclude separate parts or events from being transposed, e.g. drums or percussion.

Depending on whether you are using events which already contain root key information or not, the procedures differ slightly.

RELATED LINKS
The Global Transpose setting on page 277

If the events already contain root key information

Let’s say you want to create a project based on loops.

PROCEDURE
1. Open the MediaBay and drag some loops into an empty project.
   For this example, import audio loops with different root keys.
2. Open the Root Key pop-up menu on the Project window toolbar and set the project root key.
   If the Root Key pop-up menu is not visible, right-click the toolbar and select the “Project Root Key” option from the context menu. By default, no project root key is specified (“-”).
The entire project will be played back with this root key. To do so, the separate loops are transposed to match the project root key. For example, if you have imported a bass loop in C and the project root key is set to E, the bass loop will be transposed up by 4 semitones.

3. With the root key set, record some audio or MIDI. The recorded events will get the project root key.

4. When you are done, you can change the project root key and your events will follow.

**IMPORTANT**

If you work with drums or percussion, exclude these from being transposed by setting the “Global Transpose” setting on the info line to “Independent”.

**RELATED LINKS**

- Inserting Files into the Project on page 528
- The Global Transpose setting on page 277

**If the events do not contain root key information**

Let’s say you have created a project by recording audio and importing some MIDI loops, and you want to match the root key of the whole project to the register of a certain singer.

**PROCEDURE**

1. Open the Project menu and select “Transpose” from the Add Track submenu (or right-click the track list select the corresponding option from the context menu).

   A transpose track is created. You can only have one transpose track in a project.

2. Set the project to the desired root key by selecting the corresponding option from the Root Key pop-up menu on the Project window toolbar.

3. Right-click the transpose track in the track list and select “Set root key for unassigned events” from the context menu.

   This sets the project root key for all parts or events not containing any root key information. This option is only available, if a project root key has been set.
## Recording with a project root key

Let’s say that you want to record a guitar line for a project that is in D# minor, but your guitar player prefers to play in A minor. In this case, change the project root key to A, so that you can record your guitar.

### Procedure

1. Open your project and set the project root key to A.
   All parts and events will be transposed in order to match the root key.
2. Listen to your project and verify that no drums and percussions have been transposed.
   If drums have been transposed, select them and set their Global Transpose setting to “Independent”.
3. Record your guitar line as desired.
4. When you are done and satisfied with the result, you can change the project root key back to D# minor and your events will follow.

### Important

For recorded audio events and MIDI parts, the “Global Transpose” setting on the info line is automatically set to “Follow”, i.e. the events or parts will get the project root key.

## Changing the root key of single events or parts

If you want to check if an audio event or part has root key information or if you want to change it, proceed as follows:

1) Open the Pool and display the Key column by activating the Root Key option on the View/Attributes pop-up menu.
2) Click in the Key column for the desired audio event and set the root key according to your needs.
   You can also check and assign root keys in the MediaBay.

### Note

If you change the root key of an audio part or event, the corresponding audio file will not change. To save the root key in the audio file, you have to use the “Bounce Selection” function on the Audio menu.
To check or change the root key setting of a MIDI part, proceed as follows:

1) Select your MIDI part in the Project window and check the Project window info line.

![A MIDI part with the root key set to "D"](image.png)

2) Click on the root key value in the info line to open the corresponding pop-up menu and select the desired root key.

**Important**

If you change the project root key after setting the event root key, the events will keep their own root key settings, and will be transposed to match the project root key. If you record an audio or a MIDI part and the project root key is specified, this root key is automatically set.

---

**Transposing separate sections of a project using transpose events**

Sometimes you may want to transpose only certain sections of your project, e.g. to create harmonic variations. This can be done by creating transpose events. Transpose events allow you to add a relative transpose offset by specifying transpose values in semitones.

For example, you can brighten up your loops in C major by transposing them by 5 semitones, so that the subdominant on F major is played back, or you can turn your hit more interesting by transposing the last chorus one semitone upwards.

**Procedure**

1. Open the Project menu and select “Transpose” from the Add Track submenu (or right-click the track list select the corresponding option from the context menu).
   
   A transpose track is created. You can only have one transpose track in a project.

2. Select the Draw tool and click in the transpose track to create a transpose event.
   
   A transpose event will be created from the point where you clicked until the end of the project.
3. To create another transpose event, click with the Draw tool on the first transpose event.
   By default, the transpose value of new transpose events is set to 0.
   You can add more transpose events by clicking with the Draw tool.

4. Click in the transpose value field and enter the transpose value for the transpose event.
   You can enter the desired value with the computer keyboard, use the mouse wheel or [Alt]/[Option]-click on the transpose value to open a value fader. You can specify values between -24 and 24 semitones.

5. Play back your project.
   The parts of your project on the same position as the transpose events will be transposed according to the specified transpose values.

   **NOTE**
   You can also transpose the whole project using the transpose track. This is useful if your singer does not reach a certain pitch, for example. You could then transpose the whole project by -2 semitones, for example. Always remember to verify that the "Global Transpose" setting for drums and percussion is set to "Independent" on the info line.

   You can erase and move transpose events, but you cannot mute, cut or glue them. The “Locators to Selection” option does not apply on transpose events.

**RELATED LINKS**

The Global Transpose setting on page 277

### Transposing individual parts or events using the info line

You can also transpose individual audio and MIDI parts and events using the info line (or the Inspector). This transposition will be added to the global transposition (i.e. the root key or the transpose events).

**PROCEDURE**

1. Select the event that you want to transpose.
2. In the Project window info line, adjust the Transpose value as desired.

   **NOTE**
   A global transpose change will not overwrite individual part or event transpose, but will be added to the transpose value for the part or event. In this case, it might be useful to keep the transposition within the octave range.

**RELATED LINKS**

Keep Transpose in Octave Range on page 279
Other functions

Indicate Transpositions

When you transpose your music using the transpose track, you may sometimes want to visually compare the original sounds and the transposed music. For MIDI parts, you can check this by opening the Key Editor and clicking the “Indicate Transpositions” button.

This will help you to see how your MIDI notes will be transposed. If the button is activated, the Key Editor will show the note pitch you will hear, if it is deactivated, the Key Editor shows the original pitch of the notes in your MIDI part. By default, the “Indicate Transpositions” button is deactivated.

The Global Transpose setting

If you are working with drum and percussion loops or special effects (FX) loops, you will want to exclude these from being transposed. This can be achieved by locking them using the Global Transpose setting.
Proceed as follows:

1) Open your project.

2) Select the desired event or part and set the “Global Transpose” setting on the info line to “Independent”.
   A symbol will be displayed in the upper right corner of the selected part or event, indicating that it will not be transposed neither by changing the root key nor by specifying transpose events.

   ![Global Transpose Independent](image)

   If Global Transpose is set to Independent, the selected part will not be transposed.

3) You can now change the project root key.
   The “Independent” parts or events will not be affected by the root key changes.

**NOTE**
If you import ready-made parts or events that are tagged drums or FX, Global Transpose will be automatically set to Independent.

If you record audio or MIDI, Global Transpose will be set to “Independent”, provided that the transpose track exists and you have specified at least one transpose event (even when the transpose value is not defined). In this case, your recording will sound exactly the way you played it. The transpose events will not be taken into account during recording and the recorded event will not get the project root key.

Have a look at the following example:

1) Set up a project with the root key in C.
2) Add a transpose track and enter transpose events with the values 0, 5, 7 and 0.
3) Record some chords with your MIDI keyboard. For our example, record C, F, G and C.

   The transpose events are not taken into account and the result of your recording will be C, F, G and C. No root key will be set.

**NOTE**
Recorded events are independent from Global Transpose.

If no transpose track exists or if no transpose event has been added, Global Transpose will be set to Follow.

![Global Transpose Follow](image)

If Global Transpose is set to Follow, the selected part will follow all global transpositions.
Locking the transpose track

If you want to prevent your transpose events from being changed by mistake, activate the Lock button on the transpose track. This way, you will not be able to move your transpose events or change their transpose values.

Muting transpose events

Sometimes it might be useful to disable the transpose track, e.g. to hear the original sound of individual tracks. If you activate the mute button on the transpose track, your transpose events will not be taken into account during playback.

Keep Transpose in Octave Range

The “Keep Transpose in Octave Range” button on the transpose track (the button with an up and down arrow in brackets) keeps the transposition in the octave range. This option is activated by default. This way, nothing will be transposed by more than seven semitones. This ensures that your music never sounds unnatural because the pitch was raised too high or too low.

To understand the principle behind this, follow the example below:

**PROCEDURE**

1. Create a MIDI part, enter a C major chord, open the Key Editor and activate “Indicate Transpositions”.
   This way you can observe and understand what happens when you change the transposition.
2. Add a transpose track and create a transpose event.
   By default, the transpose value is set to 0.
3. Make sure that the “Keep Transpose in Octave Range” button is activated on the transpose track and change the transpose value of the transpose event to 7.

Your chord will be transposed accordingly.

If you enter a transpose value of 7, your chord will be transposed by seven semitones upwards. In this example, this would be G3/D4/F#4.

4. Set the transpose value to 8 semitones.

As “Keep Transpose in Octave Range” is activated, your chord will now be transposed to the nearest interval or pitch.

Your chord has been transposed to the nearest pitch, this results in G#2/D#3/G3.

**IMPORTANT**

If you mainly work with audio loops, we recommend activating “Keep Transpose in Octave Range”.

---

280
Markers are used to locate certain positions quickly. There are two types of markers: position markers and cycle markers.

If you often find yourself jumping to a specific position within a project, you should insert a marker at this position. You can also use markers to make range selections or for zooming.

Markers are located on the marker track.

**Position Markers**

Position markers allow you to save a specific position.

Position markers on the marker track are shown as marker events: vertical lines with the marker description (if assigned) and number beside it. If you select a marker track, all its markers are shown in the Inspector.

**Cycle Markers**

By creating cycle markers you can save any number of left and right locator positions as start and end positions of a range and recall them by double-clicking on the corresponding marker.

Cycle markers are shown on marker tracks as two markers bridged by a horizontal line. Cycle markers are ideal for storing sections of a project.

By defining cycle markers for sections of a song, e.g. “Intro”, “Verse”, and “Chorus”, you can quickly navigate to the song sections and repeat the section by activating the Cycle button on the Transport panel.
Setting the Locators Using Cycle Markers

Cycle markers represent ranges in your project. You can use them for moving the left and right locators.

**PROCEDURE**
- To set the left locator to the cycle marker start and the right locator to the cycle marker end, perform one of the following actions:
  - Double-click on a cycle marker.
  - From the Cycle pop-up menu in the track list, select a cycle marker.

**RESULT**
The left and right locators are moved to encompass the cycle marker.

**AFTER COMPLETING THIS TASK**
Now you can move the project cursor position to the start or the end of the cycle marker by moving it to the corresponding locator or use cycle markers to export specific ranges of your project with the **Export Audio Mixdown** dialog.

Editing Cycle Markers

When editing cycle markers on the marker track, snap is taken into account.

- To add a cycle marker, press [Ctrl]/[Command] click and drag on the marker track.
- To change the start/end position of a cycle marker, drag the start/end handle.
- To move a cycle marker to another position, drag the upper border.
- To delete a cycle marker, click with the **Erase** tool.
  If you hold down [Alt]/[Option] when you click, all consecutive markers are deleted.
- To trim a cycle marker, select a range in the cycle marker and press [Ctrl]/[Command]-[X].
- To set the marker start/end of the selected cycle marker to the cursor position, select **Project > Markers** to open the **Markers** window, and select **Functions > Set marker start/end to cursor**.
- To create a selection range spanning all tracks in the project, double-click a cycle marker.
- To set the left and right locators, double-click a cycle marker.
- To zoom in on a cycle marker, press [Alt]/[Option] and double-click the cycle marker.
Markers Window

In the **Markers** window you can view and edit markers. The markers on the marker track are displayed in the marker list in the order in which they occur in the project.

To open the **Markers** window, you have the following possibilities:

- Select **Project > Markers**.
- On the **Transport** panel in the marker section, click **Show**.
- Use a key command (by default [Ctrl]/[Command]-[M]).

1) **Locate arrow**
   Indicates which marker is at the project cursor position.

2) **Functions menu**
   Lists all functions available in the **Marker** window.

3) **Marker type**
   Allows you to specify which marker type is shown in the marker list.

4) **Auto-Scroll with Project Cursor**
   Allows you to keep track of the locate arrow, even if your project contains a large number of markers. When this option is activated, the **Marker** window is automatically scrolled to keep the locate arrow visible.

5) **Markers list**
   Shows the markers in the order in which they occur in the project.

6) **Marker Preferences**
   Shows the marker preferences.
**Editing in the Markers Window**

In the **Markers** window you can select, edit, add, move, and remove markers.

- To select a marker, click on it.
- To edit a selected marker, click on it. Select multiple markers by [Shift] or [Ctrl]/[Command]-clicking them.
- To add a position marker at the cursor position, select **Functions > Insert Marker**.
  
  A position marker is added at the current project cursor position on the marker track.

- To add a cycle marker at the cursor position, select **Functions > Insert Cycle Marker**.
  
  This adds a cycle marker between the left and right locators on the marker track.

- To move a marker to the cursor position, select the marker and select **Functions > Move Markers to Cursor**.
  
  You can also enter the new position numerically in the **Position** column. If a cycle marker is selected, the move operation affects the cycle marker start position.

- To remove a marker, select it and select **Functions > Remove Marker**.

**Navigating in the Marker List**

You can navigate in the marker list using your computer keyboard and select entries by pressing [Enter]. This is a quick and easy way to jump to markers during playback or recording.

- To move to the previous/next marker in the list, press [Up Arrow]/[Down Arrow].

- To jump to the first/last marker, press [Page Up]/[Page Down].

**Sorting and Reordering the Marker List**

You can customize the display of the marker attributes in the marker list by sorting or reordering the columns.

- To sort the marker list by a specific attribute, click on the corresponding column header.

- To reorder the marker attributes, drag and drop the corresponding column headers.
To adjust the width of a column, place the mouse pointer between two column headers and drag left or right.

**NOTE**

No matter by which attribute you sort, the second sort criterion will always be the position attribute.

---

**Marker Preferences**

You can access the marker preferences by clicking the corresponding button in the bottom left corner of the **Markers** window.

**Cycle follows when locating to Markers**

This sets the left and right locators automatically to a position or cycle marker, when locating to this marker. This is useful if you need to set the locators on the fly, e.g. during recording for Punch In/Punch Out.

**Show marker IDs on marker track**

When this option is activated, the marker IDs are shown on the marker track.

**Sync Selection**

When this option is activated, the **Markers** window selection is linked to the selection in the **Project** window.

---

**Marker Attributes**

The following marker attributes are shown in the marker list of the **Marker** window:

**Locate**

An arrow indicates which marker is at the project cursor position (or closest to the project cursor). If you click in this column, the project cursor is moved to the corresponding marker position. This column cannot be hidden.

**ID**

This column shows the marker ID numbers.

**Position**

In this column you can view and edit the markers' time positions (or start positions for cycle markers). This column cannot be hidden.

**End**

In this column you can view and edit the end positions of cycle markers.
Length
In this column you can view and edit the length of cycle markers.

Description
Here you can enter names or descriptions for markers.

RELATED LINKS
Marker IDs on page 287
Cycle Markers on page 281

Editing Attributes

• To edit a marker attribute, select the corresponding marker, click in the desired attribute column, and make your settings.

• To change the attributes of several markers, select the markers and click the checkbox for the desired attribute.
  All selected markers will change their attributes accordingly. Note that this does not work when clicking on a timecode value or a text field.

NOTE
To navigate in the list of marker attributes, you can also use the [Tab] key and the arrow keys.

Sorting and Reordering Columns

You can customize the display of the marker attributes in the marker list by sorting or reordering the columns.

• To sort the marker list by a specific attribute, click on the corresponding column header.

NOTE
No matter by which attribute you sort, the second sort criterion will always be the position attribute.

• To reorder the marker attributes, drag and drop the corresponding column headers.

• To adjust the width of a column, place the mouse pointer between two column headers and drag left or right.
Marker IDs

Each time you add a marker, it is automatically and sequentially assigned an ID number, starting from 1. IDs for cycle markers are shown in brackets and start from [1]. ID numbers can be changed at any time – this allows you to assign specific markers to key commands.

**NOTE**

If you move a marker from one marker track to another by drag & drop in the Project window and the marker ID is already used on this track, the inserted marker automatically gets a new ID.

Reassigning Marker IDs

Sometimes, especially when setting markers on the fly, you may forget or miss to set a marker. When added later, this marker's ID will not correspond to its position on the marker track. Therefore, it is possible to reassign the IDs for all markers on a track.

**PROCEDURE**

1. Open the **Markers** window.
2. Open the **Functions** pop-up menu and select either **Reassign Position Marker IDs** or **Reassign Cycle Marker IDs**.

**RESULT**

The marker IDs of the selected type are reassigned to match the order of markers on the marker track.

Marker Track

The marker track is used for adding and editing markers.

1) **Add Marker**
   Adds a position marker at the cursor position.

2) **Add Cycle Marker**
   Adds a cycle marker at the cursor position.

3) **Locate pop-up menu**
   If you select a position or a cycle marker in this pop-up menu, the corresponding marker in the event display or in the **Markers** window is selected.
Markers
Marker Track

4) **Cycle pop-up menu**
   If you select a cycle marker in this pop-up menu, the left and right locators are set to the corresponding cycle marker.

5) **Zoom pop-up menu**
   If you select a cycle marker in this pop-up menu, the view zooms to the corresponding cycle marker.

6) **Lock**
   Locks the marker track. When a marker track is locked, you cannot edit the track and its markers.

7) **Toggle Time Base**
   Sets the track time base.

8) **Marker event (inactive)**
   Shows an inactive marker event.

9) **Marker event (active)**
   Shows an active marker event.

10) **Cycle marker event (inactive)**
    Shows an inactive cycle marker event.

11) **Cycle marker event (active)**
    Shows an active cycle marker event.

---

**Adding, Moving, and Removing the Marker Track**

- To add the marker track to the project, select **Project > Add Track > Marker**.
- To move the marker track to another position in the track list, click and drag it up or down.
- To remove the marker track, right-click it in the track list and select **Remove Selected Tracks**.
- To remove an empty marker track, select **Project > Remove Empty Tracks**. This also removes any other tracks that are empty.

---

**Editing Markers on the Marker Track**

- To add a position marker, click **Add Marker** or use the **Draw** tool.
- To add a cycle marker, click **Add Cycle Marker** or use the **Draw** tool.
- To select a marker, use the standard techniques.
- To resize a cycle marker, select it and drag the handles. You can also do this numerically on the info line.
• To move a marker, select it and drag it. You can also edit marker positions on the info line.

• To remove a marker, select it and press [Delete] or use the Erase tool.

Using Markers to Select Ranges

Markers can be used in conjunction with the Range Selection tool to make range selections in the Project window. This is useful if you quickly want to make a selection that spans all tracks in the project.

PROCEDURE

1. Set markers at the start and end of the section that you want to move or copy.
2. Select the Range Selection tool and double-click on the marker track between the markers.
   Everything in the project within the marker boundaries is selected. Any functions or processing you perform now affect the selection only.
3. Click on the marker track in the selected range and drag the range to a new position.
   If you hold down [Alt]/[Option] while you drag the range, the selection in the Project window is copied instead.

Importing and Exporting Markers

Markers and marker tracks can be imported and exported.

The following files can contain markers:

• MIDI files
• Track archives (Cubase Pro only)

Importing Markers via MIDI

You can import position markers by importing MIDI files containing markers. This is useful if you want to use your marker tracks in other projects or if you want to share them with other Cubase users. Any markers you have added are included in the MIDI file as standard MIDI file marker events.

• Select File > Preferences > MIDI > MIDI File and make sure Import Markers is activated.

The following settings are imported:

• The start position of position markers and cycle markers

RELATED LINKS

Importing MIDI files on page 1023
Exporting Markers via MIDI

You can export your markers as part of a MIDI file.

- To include any markers in the MIDI file, activate Export Markers in the Export Options dialog.

The following settings are exported:

- The start position of position markers and cycle markers.

**NOTE**

To be able to export markers via MIDI export, your project must contain a marker track.

**RELATED LINKS**

Exporting MIDI files on page 1021

Importing Markers as Part of a Track Archive (Cubase Pro only)

You can import position markers and cycle markers by importing track archives containing a marker track.

The following settings are imported:

- The start and end positions of cycle markers
- The marker IDs

**RELATED LINKS**

Importing tracks from a track archive on page 1026

Exporting Markers as Part of a Track Archive (Cubase Pro only)

If you want to use your marker track in other projects, for example to share it with other users, you can export it as part of a track archive. To do so, select the marker track that you want to export. Then select **File > Export > Selected Tracks**.

The following settings are exported:

- The start and end positions of cycle markers
- The marker IDs

**RELATED LINKS**

Exporting tracks as track archives on page 1026
The **MixConsole** provides a common environment for producing mixes in stereo or surround. It allows you to control level, pan, solo/mute status, etc. for audio and MIDI channels. Furthermore, it is a convenient environment for setting up the input and output routing for multiple tracks or channels at the same time.

To open the **MixConsole**, you have the following options:

- Press [F3].
- Select **Devices > MixConsole**.
- On the **Project** window toolbar, click **Open MixConsole**. This is only visible on the toolbar if the section **Media & MixConsole Windows** is activated.
The **MixConsole** is divided into several sections:

1) **Channel Selector**
   Allows you to set up the visibility and positions of channels in the fader section.

2) **Fader Section**
   The fader section is the heart of the **MixConsole**. It is always visible and shows all channels in the same order as in the track list.

3) **Channel Overview**
   Displays all channels as boxes. If you have more channels than can be displayed in the window, you can use the channel overview to navigate to other channels and select them.

4) **Meter Bridge**
   Allows you to monitor the levels of your channels.
Setting Up the MixConsole

You can show and hide the different sections of the MixConsole. This saves screen space and enables you to display only the information that you need.

**PROCEDURE**

1. Click the **Set up Window Layout** button on the MixConsole toolbar.
2. Activate the checkboxes for the sections that you want to show.

**MixConsole Toolbar**

The toolbar holds tools and shortcuts for settings and functions in the MixConsole.

**Set up Window Layout**

Allows you to activate/deactivate the different sections of the MixConsole.
MixConsole Toolbar

Find Track/Channel
Opens a selector that lists all tracks/channels.

Filter Channel Types
Opens the channel filter that allows you to show/hide all channels of a certain channel type.

Channel Visibility Configurations
Allows you to create configurations that are useful for switching quickly between different visibility setups.

Channel Visibility Agents
Allows you to select channels with specific properties.

Show Channel Racks
Activates/Deactivates the rack selector.

Select Racks
Opens the rack selector that allows you to show/hide specific racks.

Rack Settings
Opens a pop-up menu with settings for the racks.

Locators
Shows the left and right locator positions.

Transport Buttons
Shows the transport controls.

Time Display
Shows the time display.

Markers
Shows the marker buttons.

State Buttons
Shows the mute, solo, listen, and automation states. Here you can also bypass inserts, EQs, channel strips, and sends.

Link Group
Allows you to link channels.

Zoom Palette
Allows you to increase/reduce the channel width and the rack height. You can change the width for all channels from viewable (narrow) to editable (wide), by using the default key commands [G] and [H].

Performance Meter
Shows the meters for ASIO time usage and hard disk transfer load.
Functions Menu

Opens the Functions Menu, that allows you to make settings in the MixConsole.

The Functions menu holds tools and shortcuts for settings and functions in the MixConsole.

- To open the Functions Menu, click the Functions Menu button in the top right corner of the MixConsole.

Scroll to Selected Channel

If this option is activated and you select a channel in the Visibility tab, the selected channel is automatically displayed in the Fader section.

Copy First Selected Channel's Settings

Copies the settings of the first selected channel.

Paste Settings to Selected Channels

Pastes the settings to the selected channels.

Zoom

Opens a submenu where you can increase or reduce the channel width and the rack height.

Open VST Connections

Opens the VST Connections window.

Constrain Delay Compensation

Allows you to activate/deactivate the Constrain Delay Compensation that keeps all channels in perfect sync and automatically compensates any delay inherent in VST plug-ins during playback.

Direct Routing: Summing Mode On/Off

Allows you to feed your signals to several outputs at the same time.

After Fader Listen Mode (Cubase Pro only)

Allows you to enable/disable that the signal of a listen-enabled channel is routed to the MixConsole channel after applying the fader and pan settings.

EQ/Filter Transition

Allows you to change the EQ/Filter Transition mode from Soft to Quick.
Save Selected Channels
Saves the settings for the selected channels.

Load Selected Channels
Loads the settings for the selected channels.

Global Meter Settings
Opens a submenu where you can set up the global meter settings.

Reset MixConsole Channels
Allows you to reset EQ, insert, and send effect settings for all or selected channels. Solo and mute buttons are deactivated, the volume fader is set to 0 dB, and pan is set to the center position.

Link MixConsoles
If you opened more than one MixConsole, you can link them.

**Saving MixConsole Settings**

You can save MixConsole settings for selected audio-related channels in the MixConsole and load them into any project.

**PROCEDURE**

1. Select the channels with the settings that you want to save.
2. Select **Functions > Save Selected Channels**.
3. In the file dialog, specify the file name and location.
4. Click **Save**.

**RESULT**

The settings for the selected channels are saved with the file extension `.vmx`. The input/output routing is not saved.

**Loading MixConsole Settings**

You can load MixConsole settings that have been saved for selected channels.

**PROCEDURE**

1. Select the same number of channels that you selected when you saved your MixConsole settings.

   The loaded MixConsole settings are applied in the same order as originally saved. For example, if you have saved the settings for channels 4, 6, and 8, and apply these settings to channels 1, 2, and 3, the settings saved for channel 4 are applied to channel 1, the settings saved for channel 6 to channel 2, and so on.
2. Select **Functions > Load Selected Channels**.

3. In the **Load Selected Channels** dialog, select the `.vmx` settings file and click **Open**.

**RESULT**

The channel settings are applied to the selected channels.

**NOTE**

When you apply loaded **MixConsole** settings to fewer channels, some of the saved settings are not applied. Since the saved settings are applied from left to right as shown in the **MixConsole**, the settings for the channels furthest to the right are not applied to any channels.

---

### Configuring the MixConsole

You can configure the **MixConsole** exactly to your needs and to your individual workflow.

### Channel Selector

The channel selector contains the **Visibility** tab and the **Zones** tab. These tabs list all channels contained in your project.

#### Visibility Tab

The **Visibility** tab allows you to determine which channels are shown in the **MixConsole**. This is particularly helpful if you organize your tracks in folder or group tracks.

- To show/hide channels, activate/deactivate the dots.
- To collapse/expand groups and folders, click the group or folder name.

#### Zones Tab

The **Zones** tab allows you to determine and lock the position of certain channels.
To lock channels on the left/right of the fader section, activate the left/right dots next to the channel names.
Locked channels are excluded from scrolling and are always visible.

Input Routing Configurations for Mono Channels

- Mono input busses or individual channels within a stereo or surround input bus (Cubase Pro only).
- External inputs configured on the Studio tab of the VST Connections window.
  These can be mono or individual channels within a stereo or surround bus (Cubase Pro only). They can also be routed to the Talkback input.
- Mono output busses, mono group output busses, or mono FX channel output busses.
  These should not lead to feedback.

Related links
Routing on page 325

Input Routing Configurations for Stereo Channels

- Mono or stereo input busses or stereo child busses within a surround bus (Cubase Pro only).
- External inputs that are configured on the Studio tab of the VST Connections window.
  These can be mono input busses or stereo input busses. They can also be routed to the Talkback input.
- Mono or stereo output busses, mono or stereo group output busses, and mono or stereo FX channel output busses.
  These should not lead to feedback.

Related links
Routing on page 325
Configuring the MixConsole

Input Routing Configurations for Surround Channels (Cubase Pro only)

- Surround input busses.
- External inputs that are configured on the Studio tab of the VST Connections window. These must have the same input configuration.
- Output busses. These must have the same input configuration and should not lead to feedback.

Related links
Routing on page 325

Filtering Channel Types

The channel types filter on the MixConsole toolbar allows you to determine which channel types are shown.

Procedure

1. Click Filter Channel Types. This opens the channel types filter.

2. Click a dot to the left of a channel type to hide it.

Result

Channels of the filtered type are removed from the fader section and the color of the Filter Channel Types button changes to indicate that a channel type is hidden.
Rack Selector

The rack selector allows you to activate specific MixConsole functions, such as routing, insert, or send handling, that are organized in racks.

- To activate the rack selector, activate Show Channel Racks.

Channel Racks

You can activate and deactivate the different channel racks in the MixConsole.

- To open the Select Racks pop-up menu, click Select Racks.

Depending on the channel type, you can activate/deactivate the following racks:

Routing
Allows you to set up the input and output routing. For MIDI, you can also select the MIDI channel.

Pre (Filters/Gain)
Contains input filter and gain controls along with Phase and Gain controls for audio-related channels or an Input Transformer control for MIDI channels.

Inserts
Allows you to select insert effects for your channel.

Equalizers (audio-related channels only)
Allows you to set the channel EQ.

Channel Strip (audio-related channels only)
Allows you to integrate channel strip modules, such as Gate, Compressor, EQ, Transformer, Saturator, and Limiter that allow you to enhance your sound.

Sends
Allows you to select send effects for your channel.

Cue Sends (audio-related channels only) (Cubase Pro only)
Allows you to activate and control the level and pan for up to 4 cue sends.

Direct Routing (Cubase Pro only)
Allows you to set and activate outputs for all selected channels at once.

Track Quick Controls
Allows you to add quick controls for instant access.
Device Panels (Cubase Pro only)
Allows you to view the available device panels.

Rack Settings

The Rack Settings pop-up menu allows you to make settings for the racks.

• To open the Rack Settings pop-up menu, click *.

Exclusive Expanded Rack
Shows the selected rack exclusively and collapses the other racks.

Fixed Number of Slots
Shows all available slots for the Inserts, Sends, Cues, and Quick Controls racks.

Link Racks to Configurations
If activated, the rack status is taken into account when you save and load a configuration.

Show Pre/Filters as <Combined Label & Setting>
Select Combined Label & Setting, if you want to show the label and the setting in one line.
Select Separate Label & Setting, if you want to show the label and the setting in separate lines.

Show Inserts as <Plug-in & Preset Names>
Select Plug-in Names, if you want to show the plug-in names only.
Select Plug-in & Preset Names, if you want to show the plug-in and the preset names.

Show All Channel Strip Controls
Shows all available controls on the Channel Strip rack.

Show One Channel Strip Type
Shows only one channel strip type at a time.

Show Sends as <Combined Destination & Gain>
Select Combined Destination & Gain, if you want to show the destination and the gain in one line.
Select Separate Destination & Gain, if you want to show the destination and the gain in separate lines.

Show Quick Controls as <Combined Destination & Value>
Select Combined Destination & Value, if you want to show the destination and the value in one line.
Select Separate Destination & Value, if you want to show the destination and the value in separate lines.
Channel Visibility Configurations

The Channel Visibility Configurations button on the MixConsole toolbar allows you to create configurations that are useful for switching quickly between different visibility setups.

The button displays the name of the active configuration. A list of configurations is shown as soon as you create at least one configuration. To load a configuration, select it from this list. Channel visibility configurations are saved with the project.

Add Configuration
Opens the Add Configuration dialog that allows you to save the configuration and enter a name for it.

Update Configuration
If you change the active configuration, this is indicated by an asterisk after the configuration name. Use this function to save changes to the active configuration.

Rename Configuration
Opens the Rename Configuration dialog that allows you to rename the active configuration.

Delete Configuration
Allows you to delete the active configuration.

Move Configuration to Position
This function becomes available if 2 or more configurations exist. It allows you to change the position of the active configuration on the menu. This is useful as you can assign key commands to the first 8 configurations in the Channel & Track Visibility category of the Key Commands dialog.

Saving Configurations

To quickly switch between different channel setups, you can save configurations. The configurations contain visibility and zone settings as well as the show/hide status of channel types and racks.

PROCEDURE
1. Set up the configuration that you want to save.
2. On the toolbar, click Configurations.
3. From the pop-up menu, select Add Configuration.
4. In the Add Configuration dialog, enter a name for the configuration.
5. Click OK.

RESULT
The configuration is saved and you can return to it at any time.
Channel Visibility Agents

Channel visibility agents allow you to show or hide all channels, selected channels, or channels with certain properties.

To open the Channel Visibility Agents pop-up menu, do one of the following:

- Click the Channel Visibility Agents button on the toolbar.
- In the Channel Selector, open the Visibility tab and right-click to open the context menu.

Showing Channels with Specific Properties

- To open the Channel Visibility Agents pop-up menu, click the Channel Visibility Agents button in the toolbar.

Show all Channels

Shows all channels of your project.

Show Only Selected Channels

Shows only channels that are selected.

Hide Selected Channels

Hides all channels that are selected.

Show Channels for Tracks with Data

Shows all channels for tracks with events or parts.

Show Channels for Tracks with Data at the Cursor Position

Shows all channels for tracks with events or parts at the cursor position.

Show Channels for Tracks with Data between the Locators

Shows all channels for tracks with events or parts between the locators.

Show Channels that are Connected to the First Selected Channel

Shows all channels that are connected to the channel you first selected.

NOTE

You can assign key commands for the channel visibility agents in the Channel & Track Visibility category of the Key Commands dialog.
Undoing/Redoing Visibility Changes

You can undo/redo up to 10 visibility changes.

PROCEDURE
1. In the MixConsole toolbar, click the Channel Visibility Agents button.
2. Select Undo Visibility Change or Redo Visibility Change.

Synchronizing Channel and Track Visibility

You can synchronize the channel visibility in the MixConsole with the track visibility in the Project window.

PROCEDURE
1. In the Channel Selector, open the Visibility tab and move the mouse to the right of the label.
2. Click the dot to open the Sync Track/Channel Visibility menu.
3. Select Sync MixConsole and Project to synchronize the channel visibility with the track visibility.

RESULT
The dot in the Visibility tab changes to indicate that the track and channel visibility are synchronized.

NOTE
Channels in the left or right zones of the MixConsole are not synchronized.

RELATED LINKS
Synchronizing Track and Channel Visibility on page 55
Finding Channels

The **Find Track/Channel** function allows you to find specific channels. This is useful if you have a large project with many channels or if you have hidden channels using the visibility features.

**PROCEDURE**

1. Click **Find Track/Channel** in the **MixConsole** toolbar to open a selector that lists all channels.
2. In the search field, enter the name of the channel. As you type, the selector filters automatically.
3. In the selector, select the channel and press [Return].

**RESULT**

The channel is selected in the channel list.

**NOTE**

If the channel was outside the view or hidden, it is now shown. Channels that are hidden using **Filter Channel Types** are not shown.

Linking Channels

In Cubase Pro, you can link selected channels in the **MixConsole** to form a link group. Any change that is applied to one channel is mirrored by all linked channels, depending on which settings are activated in the link group settings. In Cubase Artist, you can only link selected channels temporarily.

The **Link Group** options on the **MixConsole** toolbar allow you to link channels and to edit links and linking configuration.

**Display Line (Cubase Pro only)**

Whenever you create a link group, a display line is added on top of the fader section in the **MixConsole**.

The display line shows the number and the name of the created link group and provides a pop-up menu that allows you to edit the link group settings.
On the display line, you can change the name of the link group by double-clicking and entering a different name. If you hold down a modifier key and double-click the name, the **Link Group Settings** dialog opens.

**NOTE**

If you use a VCA fader for the link group, the displayed link group name on the fader is also changed.

The pop-up menu provides the following options:

**Unlink Selected Channels**

Only available for a selected link group. Select this option to remove the link between the channels. This removes the link group. If you use a VCA fader, you must specify if you want to revert to the original automation of the linked channels. A VCA fader that controls this link group is not removed.

**Edit Link Group Settings**

Allows you to change the link group settings.

**Included in Link Group: <name of link group>**

Shows the link group to which the selected channel belongs. You can assign the selected channel to a different link group. This removes the channel from the current group. If you only want to remove the selected channel from the link group, select **None**.

**Linked Channels**

Shows which channels are linked in the link group.

**RELATED LINKS**

- Changing the Link Group Settings (Cubase Pro only) on page 307
- Adding Channels to Link Groups (Cubase Pro only) on page 307
- Removing Channels from Link Groups (Cubase Pro only) on page 308

**Creating Link Groups (Cubase Pro only)**

You can link several channels to form a link group.

**PROCEDURE**

1. Select the channels that you want to link.
2. On the **MixConsole** toolbar, click **Link**.
3. In the **Link Group Settings** dialog, activate the parameters that you want to link.
4. Click **OK**.

**RESULT**

The number and name of the link group is indicated above the channel name in the display line.
NOTE
If you link groups, insert and channel strip module linking is applied at the slot level. For example, if you change the settings for insert slot 3 on one channel, these changes are also applied to slot 3 on the other channels. Insert effects in other slots remain unaffected.

Changing the Link Group Settings (Cubase Pro only)

If you change a setting for a channel of the link group, the change is applied to the whole group.

- To change the link settings for an existing link group, select the group, on the MixConsole toolbar, click Edit Link Group Settings, and change the settings in the Link Group Settings dialog.
- To unlink channels, select one of the linked channels and click Link on the MixConsole toolbar.
- To make individual settings and changes for a channel in a link group, activate Sus on the MixConsole toolbar or press [Alt]/[Option].
- To make absolute instead of relative value changes, activate Abs on the MixConsole toolbar.

NOTE
The automation tracks for linked channels are not affected by the Link function.

Adding Channels to Link Groups (Cubase Pro only)

You can add a channel to an existing link group.

PROCEDURE
1. On the display line of the channel that you want to add, open the pop-up menu.
2. Select Included in Link Group: <None> and select the link group.

RESULT
The channel is added to the link group.
Removing Channels from Link Groups (Cubase Pro only)

You can remove a channel from an existing link group.

**PROCEDURE**
1. On the display line of the channel that you want to remove, open the pop-up menu.
2. Select **Included in Link Group: <link group name>** and from the link group list, select **None**.
3. If the channel is controlled by a VCA fader, specify if the channel keeps the combined automation.

**RESULT**
The channel is removed from the link group.

Using Quick Link

You can activate the **Temporary Link Mode** to synchronize all touched parameters of selected channels.

**PROCEDURE**
1. Select the channels that you want to link.
2. On the **MixConsole** toolbar, activate **Q-Link**.

**NOTE**
You can also press [Shift]-[Alt]/[Option] to temporarily link channels. In that case, the link is only active as long as you press the keys.

3. Change the parameters for one of the selected channels.

**RESULT**
The changes are applied to all selected channels until you deactivate **Q-Link**.

VCA Faders (Cubase Pro only)

VCA faders serve as remote controls for groups of channel faders in the **MixConsole**.

VCA stands for Voltage-Controlled Amplifier. VCA faders were originally found on hardware mixing desks and allowed the user to control the volume levels of several mixer channels with only one fader. To assign channel faders to a VCA fader, you must physically connect the respective channels with the VCA fader.
In Cubase, the VCA fader function is based on the same concept. VCA faders are assigned to a group of linked channels, a link group. The VCA faders control the following parameters of the link group: volume, mute, solo, listen, monitor, and record.

When you assign VCA faders, they become part of the link group.

**IMPORTANT**

If a VCA fader controls a link group, it cannot control another link group. If you assign a VCA fader to another group, the VCA fader is automatically removed from the former group.

You can create several VCA faders without assigning them to link groups straight away.

From a technical perspective, moving a VCA fader to a different dB level adds or subtracts the new value to/from the original values of the channels in the link group.

**EXAMPLE**

A channel in a link group has a level of -6 dB, the VCA fader is at the 0 position. If you move the VCA fader to a level of +3 dB, this value is added to level of the linked channel. The linked channel now has a level of -3 dB.

**VCA Fader Settings**

VCA fader channels are different from the default fader channels.

Instead of the panner, the VCA faders display the link group to which they are assigned. The VCA faders also provide a pop-up menu that allows you to change the VCA fader settings.
MixConsole
VCA Faders (Cubase Pro only)

1) Link group number
2) Link group name
3) VCA fader pop-up menu
4) Peak meter that displays the summed up level of all channel meters in the link group
5) Fader cap

The VCA fader pop-up menu provides the following options:

**Edit Link Group Settings**

Allows you to change the link group settings.

**VCA Fader Controls Link Group: <link group name>**

Shows the link group that the VCA fader controls. You can assign the VCA fader to a different link group. This removes the VCA fader from the current group. You can also remove the VCA fader assignment altogether. In this case, select **None**. In all cases, you must specify if you want the linked channels to revert to their original automation.

**Combine Automation of VCA and Linked Channels**

Combines the automation curves of VCA fader and linked channels in the **Project** window. This has the effect that the original automation curves of the linked channels are no longer used. In the **Project** window, the automation of the VCA fader is reset to the static value line. In the **MixConsole**, the VCA fader is reset to the 0 position.

**Linked Channels**

Shows which channels are linked in the link group.

---

**Creating VCA Faders**

You can create VCA faders in several ways.

VCA faders can be created in the **MixConsole** and in the **Project** window.

In the **MixConsole**, you have the following options:

- You can create unassigned VCA faders in the fader section. They are placed at the right end of the fader section and display no fader cap. The VCA faders can be assigned to link groups at a later stage. To create unassigned VCA faders in the **MixConsole**, right-click in the fader section and select **Add VCA Fader**.

- You can create VCA faders while creating link groups. The VCA faders are automatically added to the right of the link groups.

In the **Project** window, you can create VCA fader tracks in the track list. The VCA faders can be assigned to link groups in the **MixConsole** at a later stage.

**Related Links**

- Assigning VCA Faders to Link Groups on page 311
- VCA Fader Track (Cubase Pro only) on page 127
Assigning VCA Faders to Link Groups

You can link channels and assign VCA faders to control them.

**PREREQUISITE**
You have selected channels.

**PROCEDURE**
1. Click **Link** on the **MixConsole** toolbar. The **Link Group Settings** dialog opens.
2. Click in the **Name** field to enter a name for the link group.
3. Activate **Use VCA Fader**. The **Volume** parameter is automatically deactivated.
4. Specify if you want to create a new VCA fader or select an existing VCA fader from the pop-up menu.
5. Click **OK**.

**RESULT**
The channels are now linked to the VCA fader. At the top of the fader section, the display line shows the number and the name of the link group. The VCA fader also displays the link group name.

**NOTE**
- If you want to assign the VCA fader to a different link group, you can open the pop-up menu of the VCA fader, select **VCA Fader Controls Link Group: <name of group>**, and select a different group from the list of available link groups.
- If you want to add a VCA fader quickly, select **Add VCA Fader to Selected Channels**. This automatically creates a VCA fader with a default name.

Removing VCA Faders from Link Groups

You can remove VCA faders from link groups.

**PREREQUISITE**
You have selected the VCA fader that you want to remove.

**PROCEDURE**
1. Click **Edit Link Group Settings** on the **MixConsole** toolbar. The **Link Group Settings** dialog opens.
2. Deactivate **Use VCA Fader**. The **Volume** parameter is automatically reactivated.
3. Click **OK**.

4. Specify if the channels in the link group keep the combined automation.

**RESULT**

The VCA fader is removed from the link group and is deleted from the list of channels.

**NOTE**

You can keep the VCA fader in the fader section. In this case, open the VCA fader pop-up menu, select **VCA Fader Controls Link Group: <name of group>**, and select **None**. This removes only the VCA fader assignment.

---

### Nested VCA Faders

VCA faders can control other VCA faders.

If you use several VCA faders that control different link groups, you can create another VCA fader that controls the VCA faders. This allows you to control the volume level of several link groups at the same time.

**EXAMPLE**

A VCA fader (main fader) controls a nested VCA fader that has been set to -10 dB. The latter VCA fader controls a linked channel that had an original level of -3 dB and that is currently set to -13 dB. If you change the main fader level from 0 to +4 dB, the controlled VCA fader is set to a level of -6 dB, and the linked channel is set to a level of -9 dB.
VCA Fader Automation

VCA fader automation influences the automation of link groups.

When you create VCA faders, their tracks in the Project window contain the static value line that is default for all automation tracks and that turns into an automation curve once you start writing automation.

When you write automation for a VCA fader of a link group, it affects the volume automation of the linked channels. This has different effects:

- If a linked channel has no automation, the VCA fader automation curve is automatically added to the automation tracks of the linked channels. The automation tracks of the linked channels show the automation that is applied through the VCA fader.
- If a linked channel has volume automation, the VCA fader automation modifies the existing volume automation of the linked channel. The VCA fader automation and the linked channel automation are combined. The automation tracks show the original automation and the combined automation of VCA fader and linked channels.

**EXAMPLE**
The VCA fader track automation affects all channels in a link group.

For the linked channels, the original static value line is adjusted by the volume level of the VCA fader track.

**EXAMPLE**
The VCA fader track automation affects an existing volume automation of an audio track.
The lighter static value line displays the VCA fader automation that has not been written yet.

VCA fader track automation
The VCA fader track has a different automation curve that affects the automation of the audio track.

Original audio track automation and combined automation of VCA fader and audio track
The underlying darker automation curve displays the original automation of the audio track. The overlaying lighter automation curve displays the combined automation.

**Example**

The automation of a main VCA fader track affects linked channels and nested VCA faders.

Audio track automation

VCA fader track automation

Combined automation of VCA fader track and audio track

Main VCA fader track

Combined automation of main VCA fader and nested VCA fader

Combined automation of main VCA fader, nested VCA fader, and audio track

If you modify the automation curve of any of the respective tracks, it always has an effect on the combined automation displayed in the audio track.

**Metering (Cubase Pro only)**

The MixConsole features a master meter and a loudness meter that can be shown to the right of the fader section.
Displaying Meters

**PROCEDURE**
1. In the **MixConsole**, click the **Set up Window Layout** button on the toolbar and activate **Control Room/Meter**.
2. Click the **Meter** tab at the top of the **Control Room/Meter** section.
   
   By default, the master meter is displayed.

**Master Meter**

The master meter is a multi-channel true peak meter.

1) **Control Room view**
   Activates the **Control Room** section in the **MixConsole**.

2) **Scales**
   Lets you select a scale according to different broadcast standards (Digital, DIN, EBU, British, Nordic, K-20, K-14, or K-12). The headroom is indicated by red lines in the meter scale.

3) **Alignment level standards**
   Lets you select an alignment level (offset) for your scale. This is unavailable for digital and K-System scales. The broadcast meter scales DIN, EBU, Nordic, and British have a default alignment level of -18dBFS.

4) **Reset RMS and PPM Max**
   Resets the measurement.
MixConsole
Metering (Cubase Pro only)

5) **AES17 standard**
   Activates the AES17 standard that adds an offset of 3dB to the RMS value.

6) **RMS/Peak meter**
   Shows the RMS and peak hold values as blue lines and the peak values as gray lines.

The following parameters are available:

**RMS Max**
   Shows the maximum RMS value.

**Peak Max**
   Shows the maximum peak value.

**RELATED LINKS**
   Control Room (Cubase Pro only) on page 352

### Loudness Meter

The loudness meter complies to the loudness recommendation R 128 of the European Broadcasting Union (EBU). Measurements that correspond to this recommendation consider loudness, loudness range, and maximum true peak level values. Loudness is measured in LUFS (Loudness Unit, referenced to Full Scale) or LU.

- To activate the loudness meter, click the **Loudness** tab at the bottom of the meter display.
1) **Control Room view**
   Activates the **Control Room** section in the **MixConsole**.

2) **Loudness meter**
   Shows the **Momentary Max** value as a green triangle in the left meter scale and the **Integrated** value as a gray triangle in the right meter scale.

3) **Measure Loudness**
   Activates the loudness measurement.

4) **Switch between LUFS and LU**
   Switches the meter scale between LUFS (absolute values) and LU (relative values).

5) **Configure Loudness Settings**
   Lets you specify a threshold value for the **Short-Term**, the **Integrated**, and the **True Peak** clipping indicators. If values above the set thresholds are detected, the corresponding indicators turn red.

   To reset all values on playback start, activate the **Reset on Start** option.

6) **Reset Loudness**
   Resets all loudness values.
The following parameters are available:

**Momentary Max**
Shows the maximum loudness measured over a duration of 400ms.

**Short Term**
Shows the loudness measured over a duration of 3ms.

**Integrated**
Shows the average loudness measured from start to stop. The period of measurement is shown in the **Time** display. The recommended value for the integrated loudness is -23LUFS. This absolute value is the reference point for the relative LU scale where -23LUFS equals 0LU.

**Range**
Shows the dynamic range of the audio measured from start to stop. This value helps you to decide how much dynamic compression you can apply. The range that is recommended for highly dynamic audio such as film music is 20LU.

**True Peak**
Shows the true peak level of the audio. The maximum permitted true peak level in production is -1 dB.

**Time**
Shows the duration of integrated loudness measurement.

**RELATED LINKS**
*Control Room (Cubase Pro only) on page 352*

---

**Input Levels**

When recording digital sound, it is important to set the input levels high enough to ensure low noise and high audio quality. At the same time, you must avoid clipping (digital distortion).

**Setting Input Levels**

**PROCEDURE**

1. **Click** **Filter Channel Types** and activate **Input Channels**.
   In this mode, the input channel level meters show the level of the signal at the input of the bus, before any adjustments, such as input gain, EQ, effects, level, or pan are made. This allows you to check the level of the unprocessed signal coming into the audio hardware.

2. **Select** **Functions > Global Meter Settings > Meter Position** and activate **Input**.
3. Play back the audio and check the level meter for the input channel. The signal should be as loud as possible without exceeding 0dB that is the clipping indicator for the input bus should not light up.

4. If necessary, adjust the input level in one of the following ways:
   • Adjust the output level of the sound source or the external mixer.
   • If possible, use the audio hardware’s own application program to set the input levels. See the documentation for the audio hardware.
   • If your audio hardware supports the ASIO control panel function, it may be possible to make input level settings. To open the ASIO control panel, select Devices > Device Setup and in the list to the left (below VST Audio System), select your audio card. When this is selected, you can open the control panel by clicking the Control Panel button in the settings section to the right.

5. Optional: Select Functions > Global Meter Settings > Meter Position and activate Post-Fader.

   NOTE
   This allows you to check the level of the audio being written to a file on your hard disk which is only necessary if you make any adjustments to the input channel.

6. In the Channel Racks section, in the Inserts rack, click a slot and select an effect, or in the Equalizers rack, make your EQ settings. For some effects you may want to adjust the level of the signal going into the effect. Use the input gain function for this. Press [Shift] or [Alt]/[Option] to adjust the input gain.

7. Play back the audio and check the level meter of the input channel. The signal should be reasonably loud without exceeding 0dB that is the clipping indicator for the input bus should not light up.

8. If necessary, use the input channel fader to adjust the signal level.

---

Clipping

Clipping typically occurs in the audio hardware when an analog signal is too loud and therefore converted to digital in the hardware’s A/D converters.

Clipping can also occur when the signal from the input bus is written to a file on your hard disk. The reason for this is that you can make settings for the input bus, adding EQ, effects, etc. to the signal while it is being recorded. This may raise the level of the signal, which causes clipping in the recorded audio file.

---

Copying and Moving Rack and Channel Settings

You can use drag and drop to copy or move rack and channel settings.

Drag and drop works between different channels or different rack slots on the same channel. When you drag, a blue frame indicates the sections where you can drop your settings.
The following applies:

- To copy the rack settings from one rack to another, drag the rack and drop it on the rack to which you want to copy the settings.
- To move the rack settings from one rack to another, press [Alt]/[Option], drag the rack, and drop it on the rack to which you want to move the settings.
- To copy the channel settings from one channel to another, drag the channel and drop it on the channel to which you want to copy the settings.

You can copy rack and channel settings between different types of channels, provided that the target channels have corresponding settings.

- For example, copying from input/output channels leaves the sends settings in the target channel unaffected.
- Cubase Pro only: For projects with surround sound, any insert effects that are routed to surround speaker channels become muted when the settings are pasted to a mono or stereo channel.

Fader Section

The fader section is the heart of the MixConsole. It shows input and output channels together with audio, instrument, MIDI, group, FX, VCA fader (Cubase Pro only), and ReWire channels that appear in the same order as in the track list.
NOTE
If a channel is deactivated in the channel selector or if its channel type is deactivated, it is not shown in the fader section.

The fader section allows you to do the following:

- Edit link group settings (Cubase Pro only)
- Set the panorama
- Activate mute and solo
- Enable Listen mode
- Open the channel settings
- Set the volume
- Enable automation

RELATED LINKS
Changing the Link Group Settings (Cubase Pro only) on page 307
Using Channel Settings on page 348
Write/Read Automation on page 577

Setting Pan

For each audio-related channel with at least a stereo output configuration, you can find a pan control at the top of the fader section. For MIDI channels, the pan control sends out MIDI pan messages. The result depends on how your MIDI instrument is set to respond to pan.

The pan control allows you to position a channel in the stereo spectrum. Cubase Pro only: This control is different for stereo and surround configurations. Channels with a multi-channel output configuration feature a miniature SurroundPanner control.

- To make fine adjustments, hold down [Shift] when you move the pan control.
- To select the default center pan position, hold down [Ctrl]/[Command], and click the pan control.
- To edit the value numerically, double-click the pan control.

RELATED LINKS
Creating New Projects on page 67
Surround Sound (Cubase Pro only) on page 558

Stereo Balance Panner

The stereo balance panner allows you to control the balance between the left and right channels. It is activated by default.
Stereo Combined Panner (Cubase Pro only)

With the stereo combined panner, the left and right pan controls are linked and keep their relative distance if you move them. It is available for channels with a stereo input and output configuration.

- To activate this panner, open the context menu for a pan control and select **Stereo Combined Panner**.

- To set the pan independently for the left and right channels, hold down [Alt]/[Option] and drag left or right.

- To reverse the left and right channels, pan the left channel to the right and the right to the left.
  The area between the pan controls changes the color to indicate that the channels are reversed.

- To sum two channels, set them to the same pan position (mono).
  Note that this increases the volume of the signal.

- To specify the default stereo panner mode for new audio tracks, select **File > Preferences > VST**.

Panning Bypass

You can bypass the panning for all audio-related channels.

- To activate panning bypass, click the button to the left or press [Ctrl]/[Command]-[Alt]/[Option]-[Shift] and click the pan control.

- To deactivate panning bypass, press [Ctrl]/[Command]-[Shift]-[Alt]/[Option]-[Shift] and click again.

When panning is bypassed for a channel, the following happens:

- Mono channels are panned center.
- Stereo channels are panned hard left and right.
- Cubase Pro only: Surround channels are panned center.

Using Solo and Mute

You can silence one or several channels using the **Solo** and **Mute** buttons.

- To silence a channel, click **Mute**.
  Click again to deactivate the mute state for the channel.

- To mute all other channels, click **Solo** for a channel.
  Click again to deactivate the solo state.
MixConsole
Fader Section

- To deactivate the mute or solo states for all channels simultaneously, click Deactivate All Mute States or Deactivate All Solo States.

- To activate exclusive solo mode, hold down [Ctrl]/[Command] and click Solo for the channel.
  The Solo buttons of all other channels are deactivated.

- To activate solo defeat for a channel, [Alt]/[Option]-click Solo.
  You can also click and hold Solo to activate solo defeat. In this mode the channel is not muted when you solo another channel. [Alt]/[Option]-click again to deactivate solo defeat.

Listen Mode (Cubase Pro only)

The listen mode allows you to quickly check the signal that is coming from selected channels without interrupting and interfering with the actual mix. During a recording session it allows the sound engineer in the control room to attenuate the signal that is coming from one of the musicians while the recording continues undisturbed, for example.

**NOTE**
To enable the listen mode, you need to enable the Control Room.

- To enable the listen mode, click the Listen button for a channel.
  This routes the channel to the Control Room without interrupting the signal flow.

- To turn off listen mode for all channels simultaneously, click Deactivate all Listen States on the MixConsole toolbar.

Setting Volume

Each channel in the fader section of the MixConsole has a volume fader. The fader levels are displayed below the fader, in dB for audio-related channels and as MIDI volume (0 to 127) for MIDI channels.

- To change the volume, move the fader up or down.

- To make fine volume adjustments, press [Shift] while moving the faders.

- To reset the volume on its default value, press [Ctrl]/[Command] and click a fader.

For audio channels, the volume fader controls the volume of the channel before it is routed to an output bus, directly or via a group channel. For output channels the volume fader controls the master output level of all audio channels that are routed to an output bus. For MIDI channels the volume fader controls the volume changes in the MixConsole by sending out MIDI volume messages to the connected instruments that are set to respond to MIDI messages.
Level Meters

The channel meters show the level when you play back audio or MIDI. The **Meter Peak Level** indicator shows the highest registered level.

- To reset the peak level, click the **Meter Peak Level** value.

**NOTE**

Input and output channels have clipping indicators. When they light up, lower the gain or the levels until the indicator is no longer lit.

Channel Meter Options

You can change the meter characteristics for audio channels using the context menu of the channel meter.

**Meter Type - PPM**

Shows a PPM type channel meter.

**Meter Type - Wave**

Shows a waveform type channel meter.

**Meter Peak Options - Hold Peaks**

The highest registered levels are held and shown as static horizontal lines in the meter.

**Meter Peak Options - Hold Forever**

If this option is activated, the peak levels are shown until you reset the meters. If this option is deactivated, you can use the **Meters' Peak Hold Time** parameter (File > Preferences > Metering) to specify for how long the peak levels are held. The peak hold time can be between 500 and 30000 ms.

**Meter Position - Input**

If this option is activated, the meters show input levels for all audio channels and input/output channels. The input meters are post input gain.

**Meter Position - Post-Fader**

If this option is activated, the meters show post-fader levels.

**Meter Position - Post-Panner**

If this option is activated, the meters show post-fader levels and also reflect pan settings.

**Reset Meters**

Resets the meters.
Working with Channel Racks

The Channel Racks section holds specific MixConsole functions, such as routing, insert, or send handling. These are organized in racks.

Routing

The Routing rack allows you to configure input and output routing, that is, setting up input and output busses.

Input busses are used when you record on an audio track. In this case, you must select from which input bus the audio is received.

NOTE

The settings that you make for the input channel will be a permanent part of the recorded audio file.

Output busses are used when you play back an audio, group, or FX channel. In this case, you must route the channel to an output bus.

You can route the outputs from multiple audio channels to a group. For example, to control the channel levels using one fader, and to apply the same effects and equalization to all the channels.

Setting up Routing

PREREQUISITE

Set up busses and group channels in the VST Connections window.

PROCEDURE

1. On the MixConsole toolbar, activate Show Channel Racks.
2. Click Racks and activate Routing to show the Routing rack above the fader section.
3. Click one of the slots of the **Routing** rack to open the input or the output routing pop-up menu for a channel.

4. In the routing selector, select an entry.
   - To set up the routing for multiple selected channels simultaneously, press [Shift]-[Alt]/[Option] and select a bus.
   - To set several selected channels to incrementing busses (the second selected channel to the second bus, the third to the third bus, etc.), press [Shift] and select a bus.
   - To disconnect input or output bus assignments, select **No Bus**.

---

**Input Busses**

The input routing selector only lists busses that correspond to the channel configuration.

**NOTE**

If you select a group channel as input for an audio channel, you can record a downmix.

**Output Busses**

For output busses any assignment is possible.

**Using Group Channels**

You can route the outputs from multiple audio channels to a group. This enables you to control the channel levels using one fader, apply the same effects and EQ to all channels, etc. You can also select a group channel as input for an audio track, to record a downmix of separate tracks, for example.

**PREREQUISITE**

You have created and set up a group channel track in stereo.

**PROCEDURE**

1. Route the group channel track to an output bus.
2. Add effects to the group channel as insert effects.
3. Route the mono audio track to the group channel.

**RESULT**

The signal from the mono audio track is sent directly to the group, where it passes through the insert effect, in stereo.
Pre (Filters/Gain/Phase)

The Pre rack for audio-related channels features a high-cut and a low-cut filter as well as gain and phase settings.

For MIDI channels it allows you to open the Input Transformer.

**NOTE**

You cannot edit the Pre rack settings in the EQ curve display.

**RELATED LINKS**

[About the Input Transformer on page 860](#)
[Equalizer Settings on page 330](#)

Making Filter Settings

Each audio-related channel has separate high-cut and low-cut filters that allow you to attenuate signals with frequencies that are higher or lower than the cutoff frequency.

**PROCEDURE**

1. On the MixConsole toolbar, activate Show Channel Racks.
2. Click Racks and activate Pre (Filters/Gain/Phase) to show the Pre rack above the fader section.
3. Click to the left of the high-cut filter to activate the high-cut filter. You have the following options:
   - Drag the slider to adjust the cutoff frequency.
     The available range spans from 20kHz to 50Hz.
   - Click Select Filter Slope on the right of the high-cut filter to select a filter slope.
     You can choose between 6, 12, 24, 36, and 48dB. The default value is 12dB.
4. Click to the left of the low-cut filter to activate the low-cut filter. You have the following options:
   - Drag the slider to adjust the cutoff frequency.
     The available range spans from 20Hz to 20kHz.
   - Click Select Filter Slope on the right of the low-cut filter to select a filter slope.
     You can choose between 6, 12, 24, 36, and 48dB. The default value is 12dB.

**RESULT**

The changed settings are visible in the curve display. If you deactivate the high-cut and low-cut filters, the filter curves are removed from the display. Bypassed high-cut and low-cut filters are displayed in a different color.
MixConsole Working with Channel Racks

Making Input Gain Settings

The **Pre-Gain** slider allows you to change the level of a signal before it reaches the EQ and the effects section. This is useful as the level going into certain effects can change the way the signal is affected. A compressor, for example, can be driven harder by raising the input gain. Gain can also be used to boost the level of poorly recorded signals.

**PROCEDURE**
1. On the MixConsole toolbar, activate **Show Channel Racks**.
2. Click **Racks** and activate **Pre (Filters/Gain/Phase)** to show the Pre rack above the fader section.
3. Drag the **Gain** slider to the left or to the right to cut or boost the gain.

Making Phase Settings

Each audio-related channel and input/output channel has a **Phase** button that allows you to correct the phase for balanced lines and microphones that are wired backwards or that are out of phase due to their positioning.

**PROCEDURE**
1. On the MixConsole toolbar, activate **Show Channel Racks**.
2. Click **Racks** and activate **Pre (Filters/Gain/Phase)** to show the Pre rack above the fader section.
3. Activate **Phase** to invert the phase polarity for the signal.

Inserts

The Inserts rack for audio-related channels features insert effect slots that allow you to load insert effects for a channel. For MIDI channels you can load MIDI inserts.

For further information, refer to the separate PDF document Plug-in Reference.

**RELATED LINKS**

Audio Effects on page 372

Adding Insert Effects

**PROCEDURE**
1. On the MixConsole toolbar, activate **Show Channel Racks**.
2. Click **Racks** and activate **Inserts** to show the Inserts rack above the fader section.
3. Click one of the insert slots to open the insert selector.
4. Click an insert effect to select it.

RESULT
The selected insert effect is loaded and automatically activated. Its plug-in panel opens.

Moving Inserts to Post-Fader or Pre-Fader Position

For each audio-related channel, you can add 6 pre-fader and 2 post-fader inserts.

PROCEDURE
1. Right-click an insert effect in a pre-fader position.
2. From the context menu, select **Move to Post-Fader Slot**.
   
   To move a post-fader insert to a pre-fader position, open its context menu and select **Move to Pre-Fader Slot**.

Bypassing Insert Effects

- To bypass all inserts, click the bypass button at the top of the **Inserts** rack.
- To bypass a single insert, click the button on the left of the inserts slot.
- To deactivate bypass, click the button again.

Activating Side-Chain for Inserts

Some of the inserts feature side-chain functionality.

PROCEDURE
1. Right-click an insert effect.
2. From the context menu, select **Activate Side-Chain**.
Saving/Loading FX Chain Presets

You can save and load all insert rack settings using FX chain presets. FX chain presets have the file name extension .fxchainpreset.

**PROCEDURE**

- In the top right corner of the Inserts rack, open the Presets pop-up menu and perform one of the following actions:
  - To save the current settings as a preset, select Save FX Chain Preset and name your preset.
  - To load a preset, select Load FX Chain Preset and select a preset.

**NOTE**

You can also apply inserts together with EQ and channel strip settings from track presets. You can load, tag, and save FX chain presets in the MediaBay.

Equalizers (EQ)

The Equalizers (EQ) rack is only available for audio-related channels. It features a built-in parametric equalizer with up to 4 bands for each audio channel.

Activating Equalizer Bands

**PROCEDURE**

1. On the MixConsole toolbar, activate Show Channel Racks.
2. Click Racks and activate Equalizers to show the EQ rack above the fader section.
3. Click Activate Band to activate an EQ band.

Equalizer Settings

You can make equalizer settings for the 4 bands. These have different default frequency values and different Q names. However, they all have the same frequency range (20Hz to 20kHz). You can specify different filter types for each individual module.
MixConsole
Working with Channel Racks

1) **Bypass EQ**
   Click to bypass all EQ bands.

2) **Curve Display**
   Click on the display in a channel to show a larger version. The display is also available in the Inspector and in the Channel Settings dialog. If you activate Equalizer Curve in the Set up Window Layout pane, the curve is removed from the EQ rack and is displayed above the racks.

   Hovering with the mouse over the display shows a cross-hair cursor. The current mouse position shows the frequency, note value, offset, and level at the top or bottom of the display.

   Click and hold to add a curve point and activate the corresponding EQ band. Double-click the curve point to deactivate it. Drag the curve point up or down to adjust the gain. Press [Ctrl]/[Command] to edit only the gain. Drag left or right to adjust the frequency. Press [Alt]/[Option] to edit only the frequency. Press [Shift] while dragging to set the Q-factor. To invert the EQ curve, open the context menu and select Invert EQ Settings.

   The final curve shows the EQ settings as well as active high-cut and low-cut filters of the Pre rack settings. Bypassed filter settings are shown in a different color than the active settings. Disabled filter settings are hidden from the display.

   **NOTE**
   You cannot edit the high-cut and low-cut filters in the curve display. To edit the filters, open the Pre rack.

3) **Select Preset**
   Opens a pop-up menu where you can load/save a preset.

4) **Activate Band**
   Click to activate/deactivate an EQ band.
Band Settings

1) **Activate Band**
   Activates the equalizer band.

2) **Gain**
   Set the amount of cut or boost. The range is ±24 dB.

3) **Frequency**
   Sets the center frequency of the frequency range to be cut or boosted. You can set the frequency either in Hz or as a note value. If you enter a note value, the frequency is automatically displayed in Hz. For example, a note value of A3 sets the frequency to 440 Hz. When you enter a note value, you can also enter a cent offset. For example, enter A5 -23 or C4 +49.

   **NOTE**
   Ensure that you enter a space between the note and the cent offset. Only in this case, the cent offsets are taken into account.

4) **Q-Factor**
   Determines the width of the affected frequency range. Higher values give narrower frequency ranges.

5) **Type**
   Opens a pop-up menu where you can select an EQ type for the band. Bands 1 and 4 can act as parametric, shelving, or high/low-cut filters. EQ bands 2 and 3 are always parametric filters.

**RELATED LINKS**
Making Filter Settings on page 327

Saving/Loading EQ Presets

You can save and load EQ presets.

**PROCEDURE**
- In the top right corner of the EQ rack, open the presets pop-up menu and perform one of the following actions:
  - To save the current settings as a preset, select **Save Preset** and name your preset.
  - To load a preset, select **Load Preset** and select a preset.
NOTE
You can also apply EQ together with insert and channel strip settings from track presets. You can load, tag, and save EQ presets in the MediaBay.

Channel Strips

The Channel Strip rack is only available for audio-related channels. It allows you to load built-in processing modules for separate channels.

Channel Strip Modules

The channel strips allow you to apply modules directly to specific channels. You can change the position of specific modules in the signal flow via drag and drop.

Gate
Allows you to silence audio signals below a set threshold level. As soon as the signal level exceeds the set threshold, the gate opens to let the signal through.

Compressor
Allows you to create smooth compression effects. Drag the compressor up or down to change its position in the signal flow.

EQ
Allows you to make EQ settings.

Tools
Provides various tools.

Sat
Allows you to add warmth to the sound.

Limit
Allows you to avoid clipping even at high levels.

Noise Gate

Noise gating silences audio signals below a set threshold. As soon as the signal level exceeds the threshold, the gate opens to let the signal through.

Threshold (-60 to 0dB)
Determines the level at which Gate is activated. Signal levels above the set threshold trigger the gate to open, and signal levels below the set threshold close the gate.

Side-Chain
Activates the external side-chain.
Release (10 to 1000 ms or Auto mode)

Sets the time after which the gate closes (after the set Hold time). If Auto Release is activated, Gate automatically finds the best release setting for the audio material.

State LED

Indicates whether the gate is open (LED lights up in green), closed (LED lights up in red), or in an intermediate state (LED lights up in yellow).

Attack (0.1 to 1000 ms)

Sets the time after which the gate opens when it is triggered.

Range

Adjusts the attenuation of the gate when it is shut. If Range is set to , the gate is completely shut. The higher the value, the higher the level of the signal that passes through the shut gate.

Filter Frequency (50 to 20000 Hz)

If Side-Chain is activated, this sets the filter frequency.

Q-Factor (0.01 to 10000)

If Side-Chain is activated, this sets the resonance of the filter.

Listen Filter

Allows you to monitor the filtered signal.

Compressor

This channel strip module reduces the dynamic range of the audio, making softer sounds louder or louder sounds softer, or both. Open the pop-up menu to select between Standard Compressor, Tube Compressor, and Vintage Compressor.

Standard Compressor

Allows you to create smooth compression effects. Drag the compressor up or down to change its position in the signal flow.

Threshold (-60 to 0 dB)

Determines the level where the compressor kicks in. Only signal levels above the set threshold are processed.

Side-Chain

Activates the external side-chain.

Ratio (1:1 to 8:1)

Sets the amount of gain reduction that is applied to signals above the set threshold. A ratio of 3:1 means that for every 3 dB the input level increases, the output level increases by 1 dB.
Gain Reduction LED
Indicates the amount of compression of the signal.

Attack (0.1 to 100ms)
Determines how fast the compressor responds to signals above the set threshold. If the attack time is long, more of the early part of the signal passes through unprocessed.

Release (10 to 1000ms or Auto mode)
Sets the time after which the gain returns to the original level when the signal drops below the threshold. If Auto is activated, the compressor automatically finds the best release setting for the audio material.

Make-up (0 to 24dB or Auto mode)
Compensates for output gain loss that is caused by compression. If Auto is activated, the knob becomes dark and the output is automatically adjusted for gain loss.

Tube Compressor
This versatile compressor with integrated tube-simulation allows you to achieve smooth and warm compression effects. The VU meter shows the amount of gain reduction. Tube Compressor features an internal side-chain section that lets you filter the trigger signal.

Input (-24.0 to 48.0dB)
Determines the compression amount. The higher the input gain, the more compression is applied.

Side-chain
Activates the external side-chain.

Output (-12.0 to 12.0dB)
Sets the output gain.

Gain Reduction LED
Indicates the amount of compression of the signal.

Attack (0.1 to 100.0ms)
Determines how fast the compressor responds. If the attack time is long, more of the initial part of the signal passes through unprocessed.

Release (10 to 1000ms or Auto mode)
Sets the time after which the gain returns to the original level. If Auto is activated, Tube Compressor automatically finds the best release setting for the audio material.

Drive (1.0 to 6.0)
Controls the amount of tube saturation.
Mix (0 to 100)
Sets the level balance between the dry signal and the wet signal.

VintageCompressor

VintageCompressor is modeled after vintage type compressors.

Input (-24 to 48 dB)
In combination with the Output setting, this parameter determines the compression amount. The higher the input gain setting and the lower the output gain setting, the more compression is applied.

Side-chain
Activates the external side-chain.

Output (-48 to 24 dB)
Sets the output gain.

Gain Reduction LED
Indicates the amount of compression of the signal.

Attack (0.1 to 100 ms)
Determines how fast the compressor responds. If the attack time is long, more of the early part of the signal passes through unprocessed.

Punch (On/Off)
If this is activated, the early attack phase of the signal is preserved, retaining the original punch in the audio material, even with short Attack settings.

Release (10 to 1000 ms or Auto mode)
Sets the time after which the gain returns to its original level. If Auto is activated, Vintage Compressor automatically finds the best release setting for the audio material.

EQ

You can make equalizer settings for the 4 bands. These have different default frequency values and different Q names. However, they all have the same frequency range (20 Hz to 20 kHz). You can specify different filter types for each individual module.
1) **Activate Band x**
Activates the equalizer band.

2) **Select EQ Band x Type**
Opens a pop-up menu where you can select an EQ type for the band. Bands 1 and 4 can act as parametric, shelving, or high/low-cut filters. EQ bands 2 and 3 are always parametric filters.

3) **Gain**
Sets the amount of cut or boost.

4) **Freq**
Sets the center frequency of the frequency range to be cut or boosted.

5) **Q**
Determines the width of the affected frequency range. Higher values give narrower frequency ranges.

**Tools**

Provides various tools.

**DeEsser**

This channel strip module reduces excessive sibilance, primarily for vocal and speech recordings. Basically, it is a special type of compressor that is tuned to be sensitive to the frequencies produced by the s-sound. Close proximity microphone placement and equalizing can lead to situations where the overall sound is just right, but there is a problem with sibilants.

**Reduction**
Controls the intensity of the de-essing effect.

**Side-Chain**
Activates the internal side-chain filter. The input signal can then be shaped according to the filter parameters. Internal side-chaining can be useful for tailoring how the gate operates.

**Release**
Sets the time after which the de-essing effect returns to zero when the signal drops below the threshold.

**Threshold**
If Auto is deactivated, you can use this control to set a threshold for the incoming signal level above which the plug-in starts to reduce the sibilants.
Auto

Automatically and continually chooses an optimum threshold setting independent of the input signal. The Auto option does not work for low-level signals (< -30 db peak level). To reduce the sibilants in such a signal, set the threshold manually.

Gain Reduction LED

Indicates the amount of compression of the signal.

Low-Frequency

Allows you to set the low frequency band.

High-Frequency

Allows you to set the high frequency band.

Solo

Allows you to solo the frequency band to find the appropriate position and width of that band.

Diff

Allows you to listen to the sounds that the de-esser removes from the signal.

EnvelopeShaper

This channel strip module can be used to attenuate or boost the gain of the attack and release phase of audio material. You can use the knobs to change parameter values. Be careful with levels when boosting the gain and if needed reduce the output level to avoid clipping.

Attack (-20 to 20dB)

Changes the gain of the attack phase of the signal.

SC (Side-Chain)

Activates the external side-chain.

Release (-20 to 20dB)

Changes the gain of the release phase of the signal.

Length (5 to 200ms)

Determines the length of the attack phase.

Output (-24 to 12dB)

Sets the output level.

Sat

Allows you to add warmth to the sound. Open the pop-up menu to select between Magneto II, Tape Saturation, and Tube Saturation.
Magneto II

This channel strip module simulates the saturation and compression of recording on analog tape machines.

**Saturation**
- Determines the amount of saturation and the generation of overtones. This leads to a small increase in input gain.

**Dual Mode**
- Simulates the use of two tape machines.

**Saturation On/Off**
- Activates/Deactivates the saturation effect.

**Output**
- Allows you to adjust the output level.

**Saturation Amount LED**
- Indicates the amount of saturation of the signal.

**Low-Frequency**
- Sets the frequency range of the spectrum band to which the tape effect is applied.
  - To avoid the saturation of lower frequencies, set the value to 200Hz or 300Hz.

**High-Frequency**
- Sets the frequency range of the spectrum band to which the tape effect is applied.
  - To avoid the saturation of very high frequencies, set the Freq Hi parameter to values below 10kHz.

**Solo**
- Allows you to hear only the set frequency range including the tape simulation effect. This helps you to determine the appropriate frequency range.

**HF-Adjust**
- Sets the amount of high frequency content of the saturated signal.

**HF-Adjust On/Off**
- Activates/Deactivates the HF-Adjust filter.

**Tape Saturation**

This channel strip module simulates the saturation and compression of recording on analog tape machines.

**Drive**
- Controls the amount of tape saturation.
MixConsole
Working with Channel Racks

Dual Mode
Simulates the use of two tape machines.

Auto Gain
Adjusts the gain automatically.

Output
Sets the output gain.

Drive Amount LED
Indicates the amount of drive of the signal.

Low-Frequency
This is a low shelving filter with fixed frequency.

High-Frequency
This is a Hi Cut filter. Use the frequency fader to reduce harshness of the output signal.

Tube Saturation

This channel strip module simulates the saturation and compression of recording of analogue tube compressors.

Drive
Controls the amount of tube saturation.

Output Gain
Sets the output gain.

Drive Amount LED
Indicates the amount of drive of the signal.

Low-Frequency
This is a low shelving filter with fixed frequency.

High-Frequency
This is a Hi Cut filter. Use the frequency fader to reduce harshness.

Limit

Allows you to avoid clipping even at high levels. Open the pop-up menu to select between Brickwall Limiter, Maximizer, and Standard Limiter.
Brickwall Limiter

Brickwall Limiter ensures that the output level never exceeds a set limit.

Due to its fast attack time, Brickwall Limiter can reduce even short audio level peaks without creating audible artifacts. However, this channel strip module creates a latency of 1 ms. Brickwall Limiter features separate meters for input, output, and the amount of limiting.

Threshold (-20 to 0 dB)
Determines the level where the limiter kicks in. Only signal levels above the set threshold are processed.

Release (ms)
Sets the time after which the gain returns to the original level when the signal drops below the threshold. If Auto is activated, Brickwall Limiter automatically finds the best release setting for the audio material.

Gain Reduction LED
Displays the amount of gain reduction.

Maximizer

This channel strip module raises the loudness of audio material without the risk of clipping.

Optimize
Determines the loudness of the signal.

Output (-24 to 6 dB)
Determines the maximum output level. Set this to 0 dB to avoid clipping.

Gain Reduction LED
Displays the amount of gain reduction.

Mix (0 to 100)
Sets the level balance between the dry signal and the wet signal.

Standard Limiter

This channel strip module is designed to ensure that the output level does not exceed a set output level, to avoid clipping in following devices. Limiter can adjust and optimize the Release parameter automatically according to the audio material, or it can be set manually. Limiter also features separate meters for the input, output, and the amount of limiting (middle meters).

Input (-24 to 24 dB)
Adjusts the input gain.
Output (-24 to 6dB)
Determines the maximum output level.

Gain Reduction LED
Displays the amount of gain reduction.

Release (0.1 to 1000ms or Auto mode)
Sets the amount of time it takes for the gain to return to its original level. If Auto is activated, Limiter automatically finds the best release setting for the audio material.

Saving/Loading Strip Presets

You can save and load strip presets. Strip presets have the file name extension .strippreset.

PROCEDURE
• In the top right corner of the Channel Strip rack, open the Presets pop-up menu and perform one of the following actions:
  • To save the current settings as a preset, select Save Strip Preset and name your preset.
  • To load a preset, select Load Strip Preset and select a preset.

NOTE
You can also apply channel strip settings together with insert and EQ settings from track presets. You can load, tag, and save strip presets in the MediaBay.

Sends

The Sends rack for audio-related channels features send effect slots that allow you to load send effects and value sliders that allow you to determine the send level for a channel. For MIDI channels the Sends rack features send effect slots that allow you to load send effects.

Adding Send Effects

PROCEDURE
1. On the MixConsole toolbar, activate Show Channel Racks.
2. Click Racks and activate Sends to show the rack above the fader section.
3. Click one of the send slots to open the send selector.
4. Click a send effect to select it.
The selected send effect is loaded.
5. Click on the left of the slot to activate the send.
Bypassing Send Effects

- To bypass all sends, click the bypass button at the top of the Sends rack.
- To deactivate bypass, click the button again.

Adding FX Channels to a Send

PROCEDURE
1. Right-click on the send slot to open the context menu.
2. Select Add FX Channel to Send.
3. In the Add FX Channel Track window, select the effect and configuration.
4. Click Add Track.

RESULT
The FX channel track is added in the Project window, and the send is automatically routed to it.

Cue Sends (Cubase Pro only)

Cue sends allow you to create discrete cue mixes that performers can listen to during recording. Essentially, cue sends are stereo aux sends that are routed to cue channel outputs in the Control Room Mixer.

For every cue channel defined in the VST Connections window, each channel in the MixConsole has a cue send, with level, pan, and pre/post-fader selection.

Adding Cue Sends (Cubase Pro only)

PREREQUISITE
Create a cue channel in the VST Connections window and activate the Control Room.

PROCEDURE
1. On the MixConsole toolbar, activate Show Channel Racks.
2. Click Racks and activate Cue Sends to show the rack above the fader section.
3. Click one of the slots to open the send selector.
   The cue sends are displayed.
4. Click on the left of the slot to activate the cue send.

RESULT
You can now change the level and pan settings.
Direct Routing (Cubase Pro only)

The Direct Routing rack allows you to set and activate outputs for all selected channels at once.

In addition to the main output you can set up 7 routing destinations that are positioned post-fader and post-panner in the signal path. This allows you to switch the destination of channels, and create different mix versions in one go. The direct routing features are available for audio, instrument, FX channel tracks, groups, and output busses.

Setting Up Direct Routing

In the Direct Routing rack you can assign up to 8 routing destinations to each channel.

PROCEDURE

1. On the MixConsole toolbar, activate Show Channel Racks.
2. Click Racks and activate Direct Routing. The Direct Routing rack is shown above the fader section.
3. Select all channels for which you want to set up the same destinations, press [Shift]-[Alt]/[Option] and click in the first slot of the Direct Routing rack.
4. In the routing selector, select the main output for the selected channels.

   NOTE

   We recommend that you choose the same set of destinations for all channels that belong together. The main output should also have the widest channel configuration, since it is used as a reference for all additional output destinations.

5. Click in the next destination slot and select another output.
6. Do this for as many destination slots as required (up to 8). After routing your audio tracks to groups, you can route the groups to output busses.
7. For each channel, you can now activate the appropriate routing destination by clicking on the corresponding slot. The active routing destination lights up in green.

Automating Destination Switches

PROCEDURE

1. Play back your project and take note of the positions where routing changes are necessary.
2. Write-enable the corresponding track.
3. At the right moment, click on the routing destination to which you want to switch. The new destination is now active, and the switch has been recorded as automation data.
4. Continue to record destination changes for your project.

NOTE
To switch destinations for multiple channels simultaneously, select these channels and keep [Shift]-[Alt]/[Option] pressed when activating a different destination.

Feeding Signals to Multiple Destinations

Direct routing offers a summing mode, allowing you to feed your signals to several outputs at the same time. This is useful if you want to apply an effect to several stems at the same time, for example.

PROCEDURE
1. Set up your output busses as routing destinations.
2. In the Direct Routing rack, open the context menu and activate Summing Mode for all channels that you want to sum.

NOTE
To activate this setting for all channels at once use the Link function.

3. Activate all outputs to which you want to route the selected channels.

RELATED LINKS
Setting up Routing on page 325

Automatic Downmixing

The output in the first Direct Routing slot defines the channel width. Since the other destinations are positioned post-panner in the signal path, they have the same channel width to start with, and the signal needs to be converted accordingly by downmixing. Cubase does that automatically.

NOTE
Always select the output with the widest channel configuration in the first slot. It is not recommended to use a setup where the main output has less channels than the direct routing destination even though it is technically possible. Upmixing might lead to unexpected side effects.
When performing an automatic downmix from 5.1 to stereo, the levels are adjusted as follows:

<table>
<thead>
<tr>
<th></th>
<th>L</th>
<th>R</th>
<th>C</th>
<th>Lfe</th>
<th>Ls</th>
<th>Rs</th>
</tr>
</thead>
<tbody>
<tr>
<td>L</td>
<td>0.0</td>
<td>-3.01</td>
<td>-3.01</td>
<td>-6.02</td>
<td></td>
<td></td>
</tr>
<tr>
<td>R</td>
<td>0.0</td>
<td>-3.01</td>
<td>-3.01</td>
<td>-6.02</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Center and Lfe signals are split to L and R channels, Ls and Rs are sent to L and R respectively, but reduced in volume.

When performing an automatic downmix from 7.1 to 5.1 the levels are adjusted as follows:

<table>
<thead>
<tr>
<th></th>
<th>L</th>
<th>R</th>
<th>C</th>
<th>Lfe</th>
<th>Ls</th>
<th>Rs</th>
<th>Lc</th>
<th>Rc</th>
</tr>
</thead>
<tbody>
<tr>
<td>L</td>
<td>0.0</td>
<td>-3.01</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>-3.01</td>
</tr>
<tr>
<td>R</td>
<td>0.0</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>-3.01</td>
<td>-3.01</td>
</tr>
<tr>
<td>C</td>
<td>0.0</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>LFE</td>
<td>0.0</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Ls</td>
<td>0.0</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Rs</td>
<td>0.0</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Lc and Rc signals are split to L/R respectively and the center channel.

**Track Quick Controls**

Track Quick Controls give you instant access to up to 8 different parameters, for example, track, effect, or instrument controls. This saves you from having to click your way through the various windows and sections pertaining to your track.

**Adding Track Quick Controls**

**PROCEDURE**

1. On the MixConsole toolbar, activate Show Channel Racks.
2. Click Racks and activate Track Quick Controls to show the rack above the fader section.
3. Click one of the slots to open the Quick Controls selector.
4. Click a parameter to select it.

**RESULT**

The selected parameter is loaded and automatically activated as Track Quick Control.
Assigning Parameters from Racks or Channel Settings

You can assign several parameters to Quick Control slots directly from within racks or channel settings in the MixConsole.

Some specific racks and channel settings allow you to add several parameters directly to the Quick Controls tab in the Inspector.

- Pre (Filters/Gain/Phase)
- Equalizers
- Channel Strip

You can assign an effect parameter either to the next empty slot or to a specific Quick Control slot.

**NOTE**

These options are only available for VST 3 plug-ins that support this function.

**PROCEDURE**

- Right-click the parameter.
  - To assign the parameter to the next empty slot, select *Add “x” to Quick Controls* (where x is the name of the parameter).
  - To assign the parameter to a specific slot, select *Add “x” to Quick Controls Slot* (where x is the name of the parameter). Then select the slot from the submenu.

**RELATED LINKS**

- [Track Quick Controls on page 618](#)

Device Panels

You can display device panels, for example, for external MIDI devices, audio track panels, or VST insert effect panels.

For information on how to create or import MIDI device panels, see the separate PDF document MIDI Devices.

**RELATED LINKS**

- [About Device panels (Cubase Pro only) on page 668](#)
Using Channel Settings

You can open each **MixConsole** channel in a separate **Channel Settings** window. This allows for better overview and editing of the channel settings.

- To open the channel settings for a specific channel, click **E** in the fader section.

For audio-related channels, the following sections can be shown/hidden by clicking **Set up Window Layout** and activating/deactivating the corresponding options:

- **Channel Inserts**
- **Channel Faders**
- **Channel Sends**

The Channel Strip and Equalizer are always available.

The channel settings are especially suitable for the following actions:

- **Routing inserts**
  This is done on the **Routing** tab in the **Inserts** section.

- **Moving the channel strip to Pre/Post-Inserts position**
  By default, the inserts are positioned before the channel strip in the signal flow. In the **Inserts** section you can change this by clicking the arrow at the top of the **Strip** tab. The tabs are swapped.
MixConsole
Using Channel Settings

- Making EQ settings
  The channel settings feature a large EQ curve display with several modes. By default, the equalizer controls are hidden, but you can click the little green button at the top right corner to show the equalizer controls or the equalizer knob controls below the EQ curve.

- Panning sends
  This is done on the Panning tab in the Sends section.

- Showing the output chain
  If you click Show Output Chain on the toolbar, the output chain is shown in the Channel Faders section. This allows you to keep track of more complicated output routings.

- Browsing through channels

  RELATED LINKS
  Equalizer Settings on page 330
  Using the Routing Editor on page 377

Browsing through Channels

Every channel has its own Channel Settings window, but you can view any channel’s settings from a single window. This allows you to have a single Channel Settings window open in a convenient position on the screen and use it for all your EQ and channel effect settings.

To select a channel in the Channel Settings window, proceed as follows:

- To show the previous/next channel, click Go to Previous/Next Channel.
- To browse through the edited channels, click Go to Last/Next Edited Channel.

  The buttons are only available if at least two channels have been edited.
Adding Notes to a MixConsole Channel

PROCEDURE
1. On the MixConsole toolbar, click Set up Window Layout, and activate Notepad.
   The Notepad section is shown above the fader section.
2. Select the channel for which you want to add notes, click in the notepad section and type in your notes.
3. To close the notepad, press [Esc], or click in another section of the MixConsole.

Keyboard Navigation

The channel selector section, the channel rack section, and the fader section can be controlled with the computer keyboard.

For this, you must activate a section. An activated section is indicated by a frame.

Activating a Section for Keyboard Navigation

PROCEDURE
1. Click with the mouse in an empty area of the section to activate it.
   Activated sections are shown with a white frame.
2. Press [Tab] to activate the next section.
3. Press [Shift]-[Tab] to activate the previous section.
Navigating in a Section

Once you have activated a section, you can use the computer keyboard as described below. In the channel racks section and in the fader section, controls that are selected for keyboard control are indicated by a red frame.

- To navigate through the controls, use the arrow keys.
- To activate or deactivate a switch, press [Return].
- To expand or collapse an active rack, to open or close a value field in a slot, or to open the plug-in panel for a loaded plug-in, press [Return].
- To access the controls in the left zone, press [Ctrl]/[Command]-[Return].
- To access the controls in the middle zone, press [Return].
- To access the controls in the right zone, press [Alt]/[Option]-[Return].
- To close a pop-up menu or a plug-in panel, press [Esc].
- To enable or disable the loaded plug-in, press [Ctrl]/[Command]-[Alt]/[Option]-[Return].
Control Room (Cubase Pro only)

The Control Room allows you to divide the studio environment into the performing area (studio) and the engineer/producer area (control room).

To open the Control Room Mixer you have the following options:

- To open the Control Room in a separate window, select Devices > Control Room Mixer.
- To open Control Room section in the MixConsole, select Devices > MixConsole > Set up Window Layout > Control Room/Meter and activate the Control Room View button.

The Control Room Mixer is divided into 2 sections.

- To open a section, click the tab at the bottom of the mixer.

The Mixer tab contains all controls that you use regularly during recording, mixing, and mastering, for example.

The Setup tab contains settings that you most probably use only once for a project.

Adding Channels to the Control Room

To be able to use the Control Room, you must add the channels that you need first.

**PROCEDURE**

1. Select Devices > VST Connections.
2. Click Studio.
3. Click Add Channel.
   A pop-up menu lists all available channel types and shows how many instances of each type are available.
4. Select a channel type.
   For most channel types, a dialog opens, that allows you to choose the channel configuration.
5. Click the **Audio Device** column to set an audio device for the channel type.
6. Click the **Device Port** column to assign a port for the channel.

**IMPORTANT**

You cannot assign the same device port to a bus or channel and a Control Room channel at the same time.

---

**RESULT**

The Control Room functions are available for use. If you disable the Control Room, the configuration is saved and will be restored when you reenable the Control Room.

---

**Output Routing**

For the Control Room to function correctly, you must assign the Main Mix bus to the set of outputs that contains the mix that you want to hear.

If you only have one output bus, it automatically becomes the Main Mix. All other outputs are not routed through the Control Room Mixer.

---

**Exclusive Assignment of Monitor Channels**

Generally, the port assignment to the Control Room channels is exclusive. However, it can be useful to create monitor channels that share device ports with each other as well as inputs and outputs. This can be helpful if you use the same speakers as a stereo pair and also as the left and right channels of a surround speaker configuration, for example.

Switching between monitors that share device ports is seamless, multi-channel audio is mixed down to stereo as needed. Only one monitor set can be active at a time.

If your scenario does not require you to assign ports to several monitor channels, it is recommended to activate the **Exclusive Device Ports for Monitor Channels** option (File > Preferences > VST > Control Room). This way, you make sure that you do not accidentally assign ports to inputs/outputs and monitor channels at the same time.

**IMPORTANT**

The state of the **Exclusive Device Ports for Monitor Channels** preference is saved together with the Control Room presets. Therefore, if you recall a preset, your current setting in the Preferences dialog might be overwritten.

---

**Control Room Channels**

Each Control Room channel type that you create defines an input or output of the Control Room Mixer.
Monitor Channels

A monitor channel represents a set of outputs that are connected to monitor speakers in the Control Room.

You can create up to 4 monitor channels for a mono, stereo, or surround speaker configuration. Each monitor can have its own custom downmix settings, input gain, and input phase settings.

NOTE

Monitor channels can share hardware inputs or outputs with another bus or channel. When you create the connections for the monitor channels, device ports that are already used for other busses or channels are shown in red on the Device Port pop-up menu. If you select a used port, its previous connection is lost.

Phones Channel

You can use the phones channel in the Control Room to listen to cue mixes.

You can create 1 phones channel for a stereo configuration. It allows you to listen to the main mix or cue mixes or to external inputs on a pair of headphones. You can also use it for previewing.

Cue Channels

You can use cue channels for sending cue mixes, also known as headphone mixes, to performers in the studio during recording.

You can create up to 4 cue channels in mono or stereo for 4 discrete cue mixes. Cue channels have talkback and click functions. They allow you to monitor the main mix, external inputs, or a dedicated cue mix.

EXAMPLE

If you have 2 available headphone amplifiers for performers, you can create 1 cue channel for each cue mix and name them according to their function: vocalist mix, bass player mix, etc.

Cue Channels and Cue Sends

For every cue channel that you define in the VST Connections window, each channel in the MixConsole has a cue send with level, pan, and pre/post-fader selection. These cue sends can be used to create discrete cue mixes that performers can listen to.

- To show the cue sends, open the MixConsole, and activate Racks > Cue Sends.
External Inputs

You can use external inputs for monitoring external devices, such as CD players, multi-channel recorders, or any other audio source.

You can create up to 6 external inputs for a mono, stereo, or surround speaker configuration.

**NOTE**

If you select external inputs as input source of an audio channel, you can record them. In this case, you do not need to assign the device ports to the input channel.

Talkback Channels

You can use talkback channels for communication between the Control Room and performers in the studio.

You can create 1 talkback channel and assign a mono input channel to each one of them.

You can also use talkback channels as input source for audio tracks and record them. You can route them to each cue channel and use different levels.

You can insert effects like a compressor or limiter on talkback channels. This ensures that erratic levels do not disturb performers and that clear communication with everyone is possible.

**NOTE**

The **Auto Disable Talkback Mode** option (File > Preferences > VST > Control Room) allows you to specify how talkback works during playback and recording.

Metering Channel

You can use a metering channel for connecting a hardware metering device.

The metering channel allows you to meter monitoring sources without having the listening volume affect the meter. This channel is a physical ASIO output which feeds the same signal that goes through the meter channel.

**NOTE**

The metering channel does not appear in the project.
Control Room Mixer

The **Control Room Mixer** displays information and controls for the channels that you define on the **Studio** tab in the **VST Connections** window.

The **Control Room Mixer** is divided into a number of sections that you open by clicking their header. To open several sections simultaneously, use [Ctrl]/[Command]-click.

**External**

The **External** section allows you to use external inputs for monitoring external devices. It is only shown if you have added more than one external input in the **VST Connections** window.
To switch to another external input, click the input name and select a new external input from the pop-up menu.

**Cue Channel**

The **Cue Channel** section allows you to set up cue channels for sending cue mixes.

1) **Activate Cue Channel**
   Allows you to activate/deactivate the cue channel.

2) **Source Selectors**
   Allow you to select the source for the cue channel: monitor mix (*Mix*), external inputs (*Ext*), or the cue sends (*Cues*). The signal presence indicators in the upper left corner light up when the source channel is sending data to the cue channel.

3) **Enable Talkback to Cue Channel**
   Allows you to activate talkback for communication between the Control Room and the performers in the studio. You can set the level of the talkback signal with the slider.

4) **Activate Metronome Click**
   Activates the metronome click. Use the *Click Level* and *Click Pan* controls to set the volume and the pan position of the metronome click.

5) **Signal Level**
   Allows you to set the signal level.

**Channels**

The **Channels** section shows the speaker arrangement of the Main Mix bus.

You can use the solo functions to listen to individual channels of the Main Mix. You can also use this to test your multi-channel speaker system and make sure that the correct channels are routed to the speakers.
1) **Solo Left and Right Channels**
 Allows you to solo the left and right channels.

2) **Solo Front Channels**
 Allows you to solo the front channels.

3) **Solo Surround Channels**
 Allows you to solo the surround channels.

4) **Listen to Solo Channels on Center Channel**
 Allows you to listen to all soloed speakers in the center channel. If the center channel is not available, the channels are distributed equally to the left and right.

5) **Listen to Surround Channels on Front Channels**
 Allows you to solo the surround channels and route them to the front speakers.

6) **Solo LFE Channel**
 Allows you to solo the LFE channel.

**Monitors**

The **Monitors** section allows you to select and configure the monitor sets.
Downmix Presets

The Downmix Presets section allows you to configure downmix presets.

1) **Assign Downmix Preset**
   Allows you to configure a downmix preset for the monitor that is selected in the Monitors section.

2) **Select Output Configuration**
   Allows you to select an output channel configuration.

Phones

The Phones section allows you to use the phones channel in the Control Room to listen to cue mixes.

1) **Activate Phones Channel**
   Allows you to activate/deactivate the phones channel.

2) **Activate Metronome Click**
   Activates the metronome click.

3) **Source Selectors**
   Allow you to select the source for the phones channel: monitor mix (Mix), external inputs (Ext), or the cue sends (Cues). The signal presence indicators in the upper left corner light up when the source channel is sending data to the Phones channel.

4) **Signal Level**
   Allows you to set the signal level. [Ctrl]/[Command]-click to set the level to the reference level specified in the Preferences dialog (VST–Control Room page).
5) **Click Level and Click Pan**
   Use the **Click Level** and **Click Pan** controls to set the volume and the pan position of the metronome click.

6) **Enable Listen for Output**
   Enables the listen bus function.

7) **Listen Level**
   Allows you to set the listen level.

### Control Room Channel

The Control Room channel is the representation of the bus that is set up as the Main Mix bus on the **Outputs** tab in the **VST Connections** window.

The following section contains a description of the individual controls.

1) **Activate Control Room Channel**
   Allows you to activate/deactivate the Control Room channel.

2) **Signal Level**
   Allows you to set the volume for the Control Room output. This does not affect the recording input level or the Main Mix level for exporting mixdowns. [Ctrl]/[Command]-click to set the level to the reference level specified in the **Preferences** dialog (**VST–Control Room** page).

3) **Signal Meter**
   Shows the volume for the Control Room output.
1) **Source Selectors**
   Allow you to select the source for the Control Room channel. The available sources depend on the channels that you added to the Control Room. The signal presence indicators in the upper left corner light up when the source channel is sending data to the Control Room channel.

2) **Dim Signal**
   Activate this to lower the Control Room level by a fixed amount. This allows a quick reduction in monitor volume without disturbing the current monitor level. Clicking the DIM button again returns the monitor level to the previous setting.

3) **Use Reference Level**
   Enable this button to set the Control Room level to the reference level specified in the Preferences dialog (VST–Control Room page). The reference level is the level that is used in calibrated mixing environments, such as film dubbing stages.

4) **Activate Metronome Click**
   Activates the metronome click.

---

1) **Monitor Selectors**
   Allow you to select another monitor source.

2) **Downmix Preset Selectors**
   Allow you to select another downmix preset.

3) **Activate Talkback**
   Allows you to activate talkback for communication between the Control Room and the performers in the studio. Click to activate, click and hold for momentary mode.

---

1) **Click Level and Click Pan**
   Use the Click Level and Click Pan controls to set the volume and the pan position of the metronome click for the Control Room channel.
Control Room Setup

The Control Room setup contains additional settings for the channels.

• To open the Control Room setup, click the Setup tab at the bottom right of the Control Room.

The Control Room setup is divided into a number of sections that you open by clicking their headers.
Control Room (Cubase Pro only)
Control Room Setup

Input Gain

Setting up the input gain can be useful in the following situations:
To balance the level of external inputs, for example, CD players and other sources to the Main Mix level, for A/B comparisons.

To balance the level of your monitor systems, so that switching between sets of speakers does not change the playback volume.

**Input Phase**

Reversing the input phase can be useful for external inputs and monitor speaker outputs.

**Insert Effects**

Each Control Room channel has a set of insert effect slots.

- Use the inserts on the Control Room channel for metering and spectral analysis plug-ins.
  
  All solos including the Listen bus will come through the Control Room channel and allow analysis of individual sounds. A brickwall limiter in the last insert slot of the Control Room channel can prevent accidental overloads and damage to speaker systems.

- Use the inserts for the talkback channel to control the dynamics of the talkback microphone.
  
  This helps protect performers' hearing and ensures that everyone can be heard over the talkback microphone.

- Use the monitor inserts for surround decoding or brickwall limiting to protect sensitive monitor speakers.
  
  Each monitor channel has a set of eight inserts, all of which are post Control Room fader.
Setting Up a Cue Mix

You can create a cue mix from the fader and pan levels that are used in the MixConsole and change them to meet the needs of the individual performers.

PROCEDURE

1. In the MixConsole, select the channels from which you want to copy the settings.

2. In the Control Room, do one of the following:
   - To apply the function only to this cue channel, right-click on a cue channel to open the context menu.
   - To apply the function to all cue channels, click anywhere but on a cue channel to open the context menu.

3. Select From selected mixer channels and select one of the functions.

Cue Mix Context Menu

Change Cue Sends Levels

Allows you to adjust multiple send levels at the same time.

Use Current Mix Levels

Allows you to copy the fader levels of the selected tracks to the cue sends. This sets all cue send levels for the selected tracks to the level of the main channel fader. It also changes the cue send status to pre-fader, so that changes in the main mix do not affect the cue sends.

Use Current Pan Settings

Allows you to copy pan information from the main mix to the cue sends of the selected tracks. If the cue send is mono, the pan setting is copied, but the output of the cue send is the sum of the left and right channels.

Enable Cue Sends

Allows you to activate the cue sends of the selected channels. To be able to hear the cue mix for a cue channel, the cue sends must be enabled.

Disable Cue Sends

Allows you to disable the cue sends of the selected channels.
Reset Cue Sends

Allows you to deactivate the cue sends, to change the send level of all selected channels to 0 dB, and to set the signal source to post-fader. This way, any changes to the main mix also change the cue mix. To raise the level of individual cue channels, raise the level on that channel.

Adjusting the Overall Cue Send Level

You can adjust multiple send levels at the same time for the cue send mix, keeping the blend intact while lowering the overall volume. This is sometimes necessary, because the levels in the main mix are often optimized for the loudest possible signal level without clipping.

This means that when you create a “more me” mix, you may find that there is not enough headroom available in the cue send to raise levels without introducing clipping.

PROCEDURE

1. In the MixConsole, select the channels that you want to modify.
2. In the Control Room, right-click a cue channel to open the context menu.
3. Select From selected mixer channels > Change Cue Sends Levels.
4. Activate Relative Mode.

This way, you adjust the existing levels. By deactivating Relative Mode, all cue sends are set to the same absolute level.

5. Adjust the level as necessary.

The level of all selected cue sends is adjusted by the set amount.

6. Click OK.
Cubase allows you to measure the loudness in compliance with the loudness recommendation R128 of the European Broadcasting Union (EBU). Measurements that correspond to this recommendation consider loudness, loudness range, and maximum true peak level values.

**Loudness Measurement**

The following measurements are performed:

- **Integrated Loudness**
  Average loudness that is measured over the whole track in LUFS (Loudness Unit, referenced to Full Scale).

  According to the loudness recommendation R128, audio should be normalized at -23LUFS (±1 LU).

- **Short-Term Loudness**
  Loudness that is measured every second on an audio block of 3 seconds. This gives information about the loudest audio passages.

- **Momentary Loudness**
  Maximum value of all momentary loudness values that are measured every 100ms in an audio range of 400ms.

**Loudness Range**

The loudness range measures the dynamic range over the whole title in LU (Loudness Units). It reports the ratio between the loudest and the quietest non-silent sections. The audio is divided into small blocks. Every second there is one audio block, and each block lasts 3 seconds so that the analyzed blocks overlap.

The top 10% of the quiet blocks and the top 5% of the loud blocks are excluded from the final analysis. The calculated loudness range is the ratio between the loudest and quietest remaining audio blocks. This measurement helps you to decide if and how much compression or expansion you can or should apply to the audio.
True Peaks

When a digital signal is converted to an analog signal, EBU R 128 recommends that you rather measure an estimation of the real peaks instead of relying on digital peaks. This avoids clipping and distortion.

Naming and Units

The EBU R 128 proposes the following naming and units conventions:

- A relative measurement, such as a value that is relative to a reference level, LU as Loudness Unit (1 LU is 1 dB).
- An absolute measurement, LUFS as loudness unit referenced to full scale. 1 LUFS can be understood as 1 dB in the AES-17 scaling.

Loudness Meter

The Loudness meter allows you to analyze, measure, and monitor the loudness of your project in real-time during playback or mixing.

- To open the Loudness Meter, select Devices > Control Room Mixer > Meter > Loudness.

- The green triangle on the left side shows the integrated loudness value.
- The gray triangle on the right side shows the short-term loudness.
The following parameters are available:

1) Measure Loudness
   Allows you to activate the loudness measurement.

2) Switch between LU and LUFS
   Allows you to switch the meter scale between LU (relative values) and LUFS (absolute values).

3) Configure Loudness Settings
   Opens a dialog with further loudness settings.

4) Reset Loudness
   Allows you to reset the loudness measurement.

5) Momentary Max.
   Shows the maximum of all measured momentary loudness values.

6) Short-Term
   Shows the loudness that is measured over a duration of 3s.

7) Integrated
   Shows the average loudness that is measured from start to stop. The period of measurement is shown in the Time display. The recommended value for the integrated loudness is -23LUFS. This absolute value is the reference point for the relative LU scale where -23LUFS equals 0LU.

8) Range
   Shows the dynamic range of the audio that is measured from start to stop. This value helps you to decide how much dynamic compression you can apply. The range that is recommended for highly dynamic audio like film music, for example, is 20LU.
9) **True Peak**
   Shows the true peak level of the audio. The maximum permitted true peak level in production is -1 dB.

10) **Time**
    Shows the duration of the integrated loudness measurement.

**Loudness Settings**

- To open the **Loudness Settings** dialog, select **Devices > Control Room Mixer > Meter > Loudness > Configure Loudness Settings**.

![Loudness Settings](image)

The following parameters are available:

1) **Select Preset**
   Allows you to create, load, and remove loudness presets.

2) **Momentary Max.**
   Allows you to specify a reference value and a tolerance value for the maximum momentary loudness. If higher values are detected, the clipping indicator in the loudness meter turns red.

3) **Short-Term**
   Allows you to specify a reference value and a tolerance value for the short-term loudness. If higher values are detected, the clipping indicator in the loudness meter turns red.

4) **Integrated**
   Allows you to specify a reference value and a tolerance value for the integrated loudness. If higher values are detected, the clipping indicator in the loudness meter turns red.
5) **True Peak**
Allows you to specify a reference value and a tolerance value for the true peak level. If higher values are detected, the clipping indicator in the loudness meter turns red.

6) **Switch between LUFS and LU**
Allows you to switch the meter scale between LUFS (absolute values) and LU (relative values).

7) **Switch between EBU +9 Scale and EBU +18 Scale**
Allows you to switch the meter scale between EBU +9 and EBU +18.

8) **Reset on Start**
Activate this to reset all values on playback start.
Cubase comes with a number of effect plug-ins included. This chapter contains general details about how to assign, use and organize effect plug-ins. The effects and their parameters are described in the separate PDF document “Plug-in Reference”.

**IMPORTANT**

This chapter describes audio effects, i.e. effects that are used to process audio, group, VST instrument, and ReWire channels.

**Overview**

Audio effects can be used as follows:

- **Insert effects**
  These effects are inserted into the signal chain of an audio channel, which means that the whole channel signal passes through the effect. This makes inserts suitable for effects for which you do not need to mix dry and wet sound, e.g. distortion, filters or other effects that change the tonal or dynamic characteristics of the sound.

  You can have up to eight different insert effects per channel (and the same is true for input and output busses – for recording with effects and master effects, respectively).

- **Send effects**
  Each audio channel has eight sends, each of which can be freely routed to an effect (or to a chain of effects).

  Send effects are practical for two reasons: you can control the balance between the dry (direct) and wet (processed) sound individually for each channel using the sends, and several different audio channels can use the same send effect. Send effects are handled by means of FX channel tracks.

- **Offline processing** (Cubase Pro only)
  You can apply effects directly to individual audio events.
VST 3 Standard

The VST 3 plug-in standard offers many improvements over the previous VST 2 standard and yet retains full backwards compatibility.

Cubase is able to run plug-ins originally developed for different platforms: you can use a 32-bit plug-in with the 64-bit version of Cubase under Windows 8 64 bit and Mac OS X 10.8.

**NOTE**

This functionality is provided to allow you to load older projects including their original plug-ins on current computers. However, the plug-ins will require higher CPU performance when compared to their native platform. Therefore, it is recommended to use 64-bit versions of such plug-ins or instruments once available.

Smart Plug-In Processing

The VST 3 standard features smart plug-in processing, i.e., processing by a plug-in can be disengaged if there is no signal present. This can greatly reduce the CPU load, thus allowing for more effects to be used.

This is achieved by activating the “Suspend VST3 plug-in processing when no audio signals are received” option in the Preferences dialog (VST–Plug-ins page).

When this is activated, VST 3 plug-ins will not consume CPU power on silent passages, i.e. when no audio data runs through them.

However, be aware that this can lead to a situation where you added more plug-ins on “transport stop” than the system can handle on playback. Therefore, you should always find the passage with the largest number of events playing simultaneously to make sure that your system offers the required performance.

**NOTE**

Activating this option can increase your system performance a lot in certain projects, but it also makes it more unpredictable whether the project can play back fine on any timecode position of the project.

Side-Chain Inputs

Several VST 3 effects feature side-chain inputs. This means that the operation of the effect can be controlled via external signals routed to the side-chain input. The effect processing is still applied to the main audio signal.

**RELATED LINKS**

Side-Chain Input on page 388
Plug-In Delay Compensation

A plug-in effect may have some inherent delay or latency. This means that it takes a brief time for the plug-in to process the audio fed into it – as a result, the output audio will be slightly delayed. This especially applies to dynamics processors featuring look-ahead functionality.

Cubase provides full plug-in delay compensation throughout the entire audio path. All plug-in delays are compensated for, maintaining the sync and timing of all audio channels.

Normally, you do not have to make any settings for this. However, VST 3 dynamics plug-ins with look-ahead functionality have a “Live” button, allowing you to disengage the look-ahead to minimize latency, if they are to be used during realtime recording (see the separate PDF document “Plug-in Reference”).

You can also constrain the delay compensation, which is useful to avoid latency when recording audio or playing a VST instrument in real time.

RELATED LINKS
Constrain Delay Compensation on page 609

Tempo Sync

Plug-ins can receive timing and tempo information from the host application (in this case, Cubase). Typically, this is used to synchronize certain plug-in parameters (such as modulation rates or delay times) to the project tempo.

- This information is automatically provided to any VST plug-in (2.0 or later) that requests it.
  - You do not have to make any special settings for this.

- You set up tempo sync by specifying a base note value.
  - You can use straight, triplet or dotted note values (1/1 to 1/32).

Please refer to the separate PDF document “Plug-in Reference” for details about the included effects.

Insert Effects

As the name implies, insert effects are inserted into the audio signal path – this means that the audio channel data will be routed through the effect.

You can add up to eight different insert effects independently for each audio-related channel (audio track, group channel track, FX channel track, VST instrument channel or ReWire channel) or output bus.
The signal passes through the effects in series from the top downwards, with the signal path shown below:

As you can see, the last two insert slots (for any channel) are post-EQ and post-fader. Post-fader slots are best suited for insert effects where you do not want the level to be changed after the effect, such as dithering and maximizers – both typically used as insert effects for output busses.

**NOTE**

Applying several effects on several channels may be too much for your CPU to handle! If you want to use the same effect with the same settings on several channels, it may be more efficient to set up a group channel and to apply your effect only once, as a single insert for this group. You can use the VST Performance window to keep an eye on the CPU load.

**RELATED LINKS**

Dithering on page 379

### Routing Through Insert Effects

Insert effect settings are available in the Inserts rack of the MixConsole, the Channel Settings window, and the Inspector.

The examples below show the Channel Settings window, but the procedures are the same for all the inserts sections.

**PROCEDURE**

1. Bring up the Channel Settings window.
   
   The insert slots are found on the Inserts tab.
2. Move the mouse over the first insert slot, click on the arrow symbol that is displayed, and select an effect from the selector.

![Image of insert effects with a selected effect]

RESULT

The effect is loaded and automatically activated and its control panel opens. You can open the control panel for a loaded effect by double-clicking in the middle of the insert slot.

- If the effect has a dry/wet Mix parameter, you can use this to adjust the balance between the dry signal and the effect signal.
- To remove an effect, open the pop-up selector and select “No Effect”.
- You can add up to 8 insert effects per channel this way.
- You can reorder the effects by clicking and dragging.
- You can copy an effect into another effect slot (for the same channel or between channels) by holding down [Alt]/[Option] and dragging it onto another effect slot.
- You can open all plug-ins inserted for a particular track at once by holding [Ctrl]/[Command]-[Shift]-[Alt]/[Option] and clicking the edit button for that track in the Inspector or in the MixConsole. [Shift]-click the edit button to close any insert plug-ins for the track.

Deactivating vs. Bypassing

If you want to listen to the track without having it processed by a particular effect, but do not want to remove this effect completely from the insert slot, you can either deactivate or bypass it.

Deactivating means to terminate all processing, whereas bypassing means to play back only the unprocessed original signal – a bypassed effect is still processing in the background. Bypassing allows for crackle-free comparison of the original (“dry”) and the processed (“wet”) signal.

- To bypass an effect, click the button on the left in the insert slot.
  When an effect is bypassed, the slot turns gray.
To deactivate an effect, hold [Alt]/[Option] and click its Bypass button.

1) This effect is deactivated.
2) This effect is bypassed.
3) This effect is activated.

To bypass all inserts for a track, click the “Bypass Inserts” button. This button can be found on the right of the header of the Inserts section in the Inspector. It lights up in yellow to indicate that one or more inserts of this track are bypassed.

Effects in Multi-Channel Configurations (Cubase Pro only)

Whether an effect plug-in supports mono, stereo, or multi-channel processing depends on the capabilities of the corresponding plug-in.

Regardless of this, all VST 2 and VST 3 plug-ins can be inserted on tracks with a multi-channel configuration. Surround-capable plug-ins are applied to all speaker channels (or a subset of these), while mono or stereo effects can only process one or two channels.

For example, if you insert a plug-in on a 5.1 track, Cubase tries to apply a 5.1 configuration to this plug-in. If the plug-in is surround capable, this is accepted. However, if you insert a stereo insert effect, the first speaker channels of the track (L and R) are routed through the effect’s available channels, and the other channels of the track are left unprocessed.

To apply the effect to other speaker channels, you can use the Routing Editor, which can be opened via the Channel Settings window.

Using the Routing Editor

You can set up the routing for the individual channels.

PROCEDURE

1. Open the Channel Settings window for the track on which the effect is inserted.
2. In the Inserts section, open the Routing tab. A signal diagram is shown for each loaded insert.
3. Double-click on the diagram. The Routing Editor opens.

4. Make your settings by using the arrow buttons, the Link checkbox and by clicking the lines.

Routing Editor

The Routing Editor allows you to freely set up the routing for the individual channels. It shows the channels in the current configuration, with signals passing from top to bottom.

- The gray field in the middle represents the actual effect plug-in.
- The squares above represent inputs to the effect plug-in.
- The squares below represent outputs from the effect plug-in.
- A line represents a bypass connection – the audio on that speaker channel passes the effect without being processed.
  To break the connection, click on the line.

A broken line indicates a broken connection – the audio on that speaker channel will not be sent to the output at all. To create a bypass connection, click the broken connection.

- The upper arrow buttons allow you to change the input assignment of the channels.
- The lower arrow buttons allow you to change the output assignment of the channels.
- If you activate Link, you can move the input and output connections together.
If you move inputs or outputs independently, you create a “cross-connection”.

The audio on the Ls-Rs channels is processed in the plug-in and output on the L-R channels. Since the L-R channels are bypassed, this means the final L-R output will contain both the original L-R signals and the processed Ls-Rs signals.

If a channel is bypassed (a straight line is shown through the plug-in), you can click on the line to break the connection. Click again to replace the broken connection with a bypass.

If you click Reset, the original setup is reset.

NOTE
Changes you make in this editor are audible immediately.

Adding Insert Effects to Busses

You can add insert effects to busses. The easiest way to add insert effects is the Channel settings window.

If you add insert effects to an input bus, the effects will become a permanent part of the recorded audio file.

If you add insert effects to an output bus, all audio routed to that bus is affected.

Dithering

Dithering is a method for controlling the noise produced by quantization errors in digital recordings. The theory behind this is that during low level passages, only a few bits are used to represent the signal, which leads to quantization errors and hence distortion.

For example, when “truncating bits”, as a result of moving from 24 to 16 bit resolution, quantization errors are added to an otherwise immaculate recording. By adding a special kind of noise at an extremely low level, the effect of these errors is minimized. The added noise could be perceived as a very low-level hiss under exacting listening conditions. However, this is hardly noticeable and much preferred to the distortion that otherwise occurs.
When should I use dithering?

- Consider dithering when you mix down to a lower resolution, either in realtime (during playback) or with the Export Audio Mixdown function.
  
  A typical example is when you mix down a project to a 16-bit stereo audio file for audio CD burning.

What is a "lower resolution" then? Well, Cubase uses 32-bit float resolution internally, which means that all integer resolutions (16 bit, 24 bit, etc.) are lower. The negative effects of truncation (no dithering) are most noticeable when mixing down to 8 bit, 16 bit and 20 bit format; whether to dither when mixing down to 24 bits is a matter of taste.

Applying Dithering

**PROCEDURE**

1. Open the Channel Settings window for the output channel by clicking its Edit button in the MixConsole.

2. Open the effect selector for slot 7 or 8.
   
   The two last Insert effect slots (for all channels) are post-fader, which is crucial for a dithering plug-in. The reason is that any master gain change applied after dithering would bring the signal back to the internal 32 bit float domain, rendering the dithering settings useless.

3. Select the included UV22HR plug-in from the selector.

4. Make sure that the plug-in is set to dither to the correct resolution.
   
   This would be the resolution of your audio hardware (on playback) or the desired resolution for the mixdown file you want to create (as set in the Export Audio Mixdown dialog).

5. Use the other parameters in the control panel to set up the dithering to your liking.

**RELATED LINKS**

Export Audio Mixdown on page 938
Adding Insert Effects to Group Channels

You can add insert effects to group channels. This is useful if you have several audio tracks that you want to process through the same effect (e.g., different vocal tracks that you want to be processed by the same compressor).

**PROCEDURE**

1. Create a group channel track and route it to the desired output bus.
2. Add the desired effect to the group channel as an insert effect.
3. Route the audio track to the group channel.

**RESULT**

The signal from the audio track is sent directly to the group, where it passes through the insert effect.

**NOTE**

You can also process mono audio tracks through stereo insert effects.

Freezing Insert Effects for a Track

Freezing insert effects for a track allows you to reduce processor power.

- To freeze a track, click its Freeze button in the Inspector.

- The Freeze Channel Options dialog opens, allowing you to set a “Tail Size” time in seconds. This adds time at the end of the rendered file to allow reverb and delay tails to fully fade out.

- The program now renders the output of the track, including all pre-fader insert effects, to an audio file. This file is placed in the “Freeze” folder within the Project folder.

- The frozen audio track is locked for editing in the Project window. The frozen insert effects cannot be edited or removed and you cannot add new insert effects for the track (except post-fader effects).

- On playback, the rendered audio file is played back. You can still adjust the level and panning in the MixConsole, make EQ settings and adjust the effect sends.

  In the MixConsole, the channel for a frozen track is indicated by a “snow flake” symbol above the channel name.
After freezing the Inserts for a track, you hear the track play back as before but the insert effects do not have to be calculated in real time, easing the load on the computer processor. Typically, you would freeze a track when it is finished and you do not need to edit it anymore.

**NOTE**

You can only freeze audio tracks this way, not group channel tracks or FX channel tracks.

**NOTE**

Post-fader inserts can not be frozen.

- To unfreeze a frozen track, click its Freeze button again.

## Send Effects

Send effects are outside of an audio channel’s signal path, i.e. the audio data to be processed must be sent to the effect.

To this end, Cubase provides FX channel tracks. When you have created such a track, it is added to the track list and can be selected as a routing target in the Send slots of audio channels.

- When selecting an FX channel track in one of the send slots of an audio channel, the audio is sent to the FX channel and through any insert effects set up for it.
  The sends can be routed to different FX channels, and thus different FX channel insert effect configurations. You control the amount of signal sent to the FX channel by adjusting the effect send level.

- If you have added several effects to the FX channel, the signal passes through the effects in series, from the top (the first slot) downward. This allows for “custom” send effect configurations – e.g. a chorus followed by a reverb followed by an EQ and so on.

- The FX channel track has its own channel in the MixConsole. Here you can adjust the effect return level and balance, add EQ and route the effect return to any output bus.

- Each FX channel track can have any number of automation tracks, for automating various effect parameters.

**RELATED LINKS**

Automation on page 576
Adding an FX Channel Track

PROCEDURE

1. Select Project > Add Track > FX Channel.
   A dialog opens.

2. Select a channel configuration for the FX channel track.
   Normally, stereo is a good choice since most effect plug-ins have stereo outputs.

3. Select an effect for the FX channel track.

4. Click Add Track.
   An FX channel track is added to the track list, and the selected effect, if any, is loaded
   into the first insert effect slot for the FX channel (in that case, the lit Inserts tab for the
   FX channel track in the Inspector indicates that an effect has been assigned and
   automatically activated).

RESULT

All FX channel tracks you create will appear in a dedicated “folder” track in the track
list. This makes it easy to manage and keep track of all your FX channel tracks, and
also allows you to save screen space by folding in the FX Channel folder.

FX channel tracks are automatically named “FX 1”, “FX 2” etc., but you can rename
them if you wish. Just double-click the name of an FX channel track in either the
track list or the Inspector and type in a new name.
Adding and Setting Up Effects

You can add a single insert effect when you create the FX channel track. To add and set up effects after the FX channel track is created, you can either use the Channel Settings window or the Inspector for the track.

PROCEDURE

1. In the track list, the MixConsole, or the Inspector, click the Edit button for the FX channel track to open the Channel Settings window. On the left in the window you can find the Inserts section.

2. On the toolbar, open the Output pop-up menu and make sure that the FX channel is routed to the correct output bus.

3. To add an insert effect in an empty slot (or to replace the current effect in a slot), click the slot and select an effect from the selector.

4. In the control panel of the effect, set the wet/dry Mix control to all wet. This is because you control the balance between the wet and the dry signal with the effect sends.

RESULT

The handling and operation of insert plug-ins for FX channels is the same as for audio channels. You can adjust level, pan and EQ for the send in the Channel Settings window, the MixConsole or in the Inspector.

RELATED LINKS

Routing Through Insert Effects on page 375
Routing an Audio Channel to the FX Channel

The next step is to set up a send for an audio channel and route it to the FX channel.

This can be done in the MixConsole, in the Channel Settings window, or in the Inspector for the audio track. The example below shows the Channel Settings window, but the procedure is similar for all the sections:

**PROCEDURE**

1. Click the “e” button for an audio channel to bring up its Channel Settings window.
   
   Each of the sends has the following controls:
   
   • An On/Off button for activating/deactivating the effect
   • A send level slider

2. Click the arrow icon in an empty send slot to open the selector, and select an FX channel track as routing destination.

   • If the first item on this menu (“No Bus”) is selected, the send is not routed anywhere.
   • Items called “FX 1”, “FX 2” etc. correspond to existing FX tracks. If you renamed an FX track, that name will appear on this menu instead of the default.
   • The menu also allows for routing a send directly to output busses, separate output bus channels or Group channels.
   • Cubase Pro only: You can apply or remove a send to or from all the selected channels at once by holding down [Shift]-[Alt]/[Option] and selecting the desired effect from any of the effect slots.

3. Activate the On/Off button for the send.
4. Click and drag the send level slider to determine how much of the signal from the audio channel is routed to the FX channel.

Setting the Send level

You can also double-click and enter a value numerically. If you hold down [Alt]/[Option] when double-clicking, the send destination is shown in the Channel Settings window. If you have routed the send to an FX channel, the plug-in panel opens.

**NOTE**

To determine how much of the signal from the FX channel is sent to the output bus, open the Channel Settings window for the FX track and adjust the effect return level.

**RELATED LINKS**

Adding an FX Channel Track on page 383

**Pre/Post Fader Sends**

Normally you want the effect send to be proportional to the channel volume (post-fader send). However, you can send the signal to the FX channel before the audio channel’s volume fader.

- If you want the signal to be sent to the FX channel before the audio channel’s volume fader in the MixConsole, right-click on a send and select “Move to Pre-Fader”.

The picture below shows where the sends are “tapped” from the signal in pre and post-fader mode:
NOTE

Use the channel’s Mute button to determine whether a send in pre-fader mode is affected. This is done with the “Mute Pre-Send when Mute” option in the Preferences dialog (VST page).

NOTE

Cubase Pro only: The FX channels themselves have sends, too.

Setting Pan for the Sends (Cubase Pro only)

There are several possibilities to set up pan for the sends:

- To position the send signal at center pan in the stereo FX channel (or anywhere you like), route a send from a mono channel to a stereo FX channel track.
- To use the pan control as a crossfader, determining the balance between the stereo sides when the stereo send signal is mixed to mono, route a send from a stereo channel to a mono FX channel track.
- To use the surround panner to position the send signal in the surround image, route a send from a mono or stereo channel to an FX channel track in surround format.

PROCEDURE

1. Open the Channel Settings window for the audio channel. In the Sends section of the Channel Settings window, on the Panning tab, each send is shown with a pan fader. On the Functions menu, you can activate the “Link Panners” option. The send panners will then follow the pan for the channel, making the stereo imaging as clear and true as possible. This behavior can also be set as default for all channels. The corresponding setting is available in the Preferences dialog (VST page).
2. Click and drag the pan control for the desired send(s) in the display. You can reset the pan control to the center position by [Ctrl]/[Command]-clicking on the pan control.

If the FX channel is configured in a surround format, the pan control will be a miniature surround panner.

You can click and drag the “ball” in the miniature panner display to position the send in the surround field, or double-click in the display to bring up the surround panner.

**NOTE**

If both the send (the audio channel) and the FX channel are in mono, the pan control is not available.

---

**RELATED LINKS**

Surround Sound (Cubase Pro only) on page 558

---

**Side-Chain Input**

Many VST 3.0 effects feature a side-chain input. Side-chaining allows you, for example, to lower the music volume when someone is speaking (“ducking”) or to use compression (e.g. on a bass sound) when the drums are hit, thereby “harmonizing” the intensity of the two instruments. Another possibility is to use the side-chain signal as a source for modulation.

Effects from the following categories feature side-chain: Delay, Dynamics, Modulation, and Filter.

**IMPORTANT**

For detailed descriptions of the plug-ins that feature side-chaining, see the separate PDF document “Plug-in Reference”.

**NOTE**

Certain combinations of tracks and side-chain inputs may lead to feedback loops and added latency. If this is the case, the side-chain options will not be available.

---

**Side-chain and Modulation**

Side-chain signals bypass the built-in LFO modulation and instead apply modulation according to the envelope of the side-chain signal. Since each channel will be analyzed and modulated separately, this allows for creating astonishing spatial modulation effects.
About drag & drop

When you drag effects from one insert slot to another (on the same channel or between different channels), the following applies:

- When you move an effect within a channel (e.g. from slot 4 to slot 6), the side-chain connections will be kept.
- When you drag and drop an effect between two channels, the side-chain connections will not be kept.
- When copying an effect into another effect slot (for the same or a different channel), the side-chain connections will not be copied, i.e. they will be lost.

Creating a Ducking Delay

You can silence the delay repeats by side-chain signals exceeding a certain threshold. You can use this feature to create a so-called “ducking delay” for your vocals. Let’s say you want to add a delay effect that is audible only when no signal is present on the vocal track. For this, you need to set up a delay effect which is deactivated every time the vocals start again.

**PROCEDURE**

1. Select the vocal track.
2. On the Project menu, select “Duplicate Tracks”. Now you can use the vocal events on the second track to silence the delay effect.
3. Open the Inserts tab for the first vocal track in the Inspector and select “PingPongDelay” from the effects selector. The control panel for the effect opens.
4. On the control panel for the effect, make the desired effect settings and activate the Side-Chain button. Try out the effect settings to find out which settings will work best with your project. For detailed descriptions of the parameters, see the separate PDF document “Plug-in Reference”.
5. In the track list, select the second vocal track.
6. On the Output Routing selector, locate the Side-Chain node and select the PingPongDelay effect that you set up for the vocal track.

This way, the signals from the second (duplicate) track are routed to the effect (and do not end up in the mix).

RESULT

Now every time the signals on the vocal track exceed the threshold, the delay will be deactivated. Since the threshold for the delay effect is fixed, you may have to adjust the volume of track 2, in this example, to ensure that vocal parts of low or middle volume will also silence the delay effect.

Triggering a Compressor Using Side-Chain Signals

Compression, expansion or gating can be triggered by side-chain signals exceeding a specified threshold. This allows you to lower the volume of one instrument every time another instrument is played. In this example, you lower the volume of the bass guitar during the bass drum hits.

PROCEDURE

1. Select the bass guitar track.
2. In the Inspector, open the Inserts section, and select the Compressor effect found in the Dynamics category.
   The effect is loaded into the effect slot and the effect control panel opens.
3. Activate the Side-Chain button.
4. Select the bass drum track.
5. In the Inspector, open the Sends section, open the effects selector, and from the Side-chains mode, select the Compressor effect you created for the bass guitar track.
6. Adjust the Send level.
   This way, the bass drum signal triggers the compressor on the bass guitar track.

RESULT

When you now play back the project, the bass guitar will be compressed whenever the signals on the bass drum track exceed the threshold.
External Effects (Cubase Pro only)

You can set up external FX busses to make your outboard equipment part of your studio.

An external FX bus is a combination of outputs (sends) and inputs (returns) on your audio hardware, along with a few additional settings.

All external FX busses you have created will appear on the effect pop-up menus and can be selected like the internal effect plug-ins. If you select an external effect as an insert effect for an audio track, the audio will be sent to the corresponding audio output, processed in your hardware effect (provided that you have connected it properly) and returned via the specified audio input.

RELATED LINKS
- VST Connections on page 22
- External Instruments and Effects (Cubase Pro only) on page 33

Effect Control Panel

You can open the control panel for the loaded plug-in by double-clicking the center part of an insert or a send slot. If you edit the parameters for an effect, these settings are saved automatically with the project.

The contents, design and layout of the control panel depend on the selected effect.

1) Activate Effect
2) Bypass Effect
3) Read/Write Automation
4) Switch between A/B Settings
5) Copy A to B
6) Activate Side-Chain
7) Preset selector
8) Functions menu

NOTE

The included effects and their parameters are described in detail in the separate PDF document “Plug-in Reference”.

391
Comparing Effect Settings

You can compare two different parameter settings for an effect.

**PROCEDURE**

1. Adjust the effect parameters for setting A.
2. Click **A/B Setting** to activate setting B.
   As a starting point for setting B, the parameters for setting A are copied.
3. Adjust the parameters for setting B.
4. Click **A/B Setting** to activate setting A and compare both settings.

**RESULT**

You can compare the settings between A and B using the corresponding buttons. Settings A and B are saved with the project.

![Setting A active](image1)

![Setting B active](image2)

Effect Presets

In the MediaBay – or with certain limits in the Save Preset dialog – you can assign attributes to presets which allow you to organize and browse them according to various criteria. Cubase comes with categorized track and VST presets that you can use straight out of the box.

You can also preview effect presets before loading them which considerably speeds up the process of finding the right effect preset.

Effect presets can be divided into the following main categories:

- **VST presets for a plug-in.**
  These are plug-in parameter settings for a specific effect.

- **Inserts presets that contain insert effect combinations.**
  These can contain the whole insert effects rack with settings for each effect.
Presets Browser

The Presets browser contains the Results, the Filters and the Location Tree sections.

1) Location Tree section
   Shows the folder that is searched for preset files.
   To show the Location Tree section, click Set Up Window Layout and activate Location Tree. This is only available if Filters is also active.

2) Filters section
   Shows the available preset attributes for the selected effect.
   To show the Filters section, click Set Up Window Layout and activate Filters.

3) Results section
   Lists the available presets for the selected effect.

Selecting Effect Presets

Most VST effect plug-ins come with a number of useful presets for instant selection.

**PROCEDURE**

1. Load an effect, either as a channel insert or into an FX channel.
   The control panel for the effect is displayed.

2. Perform one of the following actions to open the Presets browser:
   - Click in the preset field at the top of the control panel.
   - Click the button to the right of the preset field and select “Load Preset”.
This opens the Presets browser.

You can also open the Presets browser from the Inspector (Inserts tab) or the Channel Settings window.

3. In the Results section, select a preset from the list.

4. Activate playback to audition the selected preset.
   Step through the presets until you find the right sound. It may be helpful to set up cycle playback of a section to make comparisons between different preset settings easier.

5. When you have found the preset that you want, double-click on it (or click outside the Presets browser).
   The preset is applied.
   • To return to the preset that was selected when you opened the Presets browser, click the “Revert to Last Setting” button.

NOTE

The preset handling for VST 2 plug-ins is slightly different.

RELATED LINKS

Earlier VST Effect Presets on page 396
Saving Effect Presets

You can save your effect settings as presets for further use.

PROCEDURE
1. Open the Preset Management pop-up menu.

2. Select Save Preset.
   The Save Preset dialog opens.
3. In the New Preset section, enter a name for the new preset.
4. Optional: Click the button at the bottom left to open the Attribute Inspector and save attributes for the preset.
5. Click OK to save the preset and exit the dialog.

RESULT
User-defined presets are saved in the following location:

- Windows: \Users\<user name>\My Documents\VST3 Presets\<company>\<plug-in name>
- Mac: /Users/<user name>/Library/Audio/Presets/<company>/<plug-in name>

NOTE
You cannot change the default folders, but you can add further subfolders inside the individual effect preset folders (by clicking the New Folder button).

RELATED LINKS
Attribute Inspector on page 544

Default Effect Presets

You can save a default effect preset with your parameter settings. This is loaded automatically when you open the effect.

- To save a default preset, open the Preset Management pop-up menu, and select Save as Default Preset.
- To recall a default preset, open the Presets browser and select Default. You can also open the plug-in context menu and select Default Preset > Reset to Default Preset.
Copy and Pasting Effect Presets

You can copy a plug-in preset and paste it in another instance of the same plug-in.

**PROCEDURE**

1. Open the plug-in context menu and select **Copy (plug-in name) Setting**.
2. Select another instance of the same plug-in, open the context menu and select **Paste (plug-in name) Setting**.

Earlier VST Effect Presets

Some VST 2.x plug-ins have presets in the old FX program/bank format (.fxp/.fxb).

To use all features, you must convert these presets to VST 3 presets. If you save new presets for the included VST 2 plug-ins, these will automatically be saved in the .vstpreset format.

**IMPORTANT**

All VST 2 presets can be converted to VST 3 presets.

Converting Earlier VST Presets

**PREREQUISITE**

You have created your own .fxp/.fxb presets with a previous version of Cubase (or any other VST 2 application).

**PROCEDURE**

1. Load any VST 2 effect you may have installed, and open the Preset Management pop-up menu.

![Preset Management pop-up menu](image)

2. Select **Import FXB/FXP**.
3. In the file dialog, locate the file and click Open.

   If you load a bank (.fxb), it will replace the current set of all effect programs. If you load a single program, it will replace the currently selected effect program only.
AFTER COMPLETING THIS TASK

You can convert the current program list to VST presets by opening the Preset Management pop-up menu and selecting **Convert Program List to VST Presets**.

After converting, the presets will be available in the Presets browser, and you can use the Attribute Inspector in the MediaBay to add attributes and audition the presets. The converted presets will be stored in the VST 3 Preset folder.

**Saving Insert Presets**

You can save the complete insert effect rack for a channel together with all parameter settings as an inserts preset. Inserts presets can be applied to audio, instrument, FX channel, or group tracks.

**PROCEDURE**

1. In the track list, select the track and in the Inspector, open the Inserts section.
2. Load a combination of insert effects and adjust the parameters (or select effect presets) for each effect.
3. At the top of the Inserts tab, click the Preset Management button to open the pop-up menu for the inserts and select “Save FX Chain Preset”.
   This can also be done from the Channel Settings window using the Preset Management button at the top of the Inserts section.
4. In the dialog that opens, type in a name for the preset.
5. Select the track (audio/group/instrument/FX channel) to which you want to apply the new preset.
6. On the Inserts tab, click the Preset Management button and select “Load FX Chain Preset”.

---

397
7. In the dialog that opens, select the preset that you created. The effects are loaded into the Insert slots of the new track.

**NOTE**

When loading insert combination presets, any plug-ins that were previously loaded for the track will be removed, regardless of whether these slots are used in the preset.

---

**Extracting Insert Effect Settings from Track Presets**

You can extract the effects used in a track preset and load them into your inserts rack.

**PROCEDURE**

1. On the Preset Management pop-up menu, select **From Track Preset**.
2. In the dialog, select an item in the list. The effects used in the track preset are loaded.

**RELATED LINKS**

- Track Presets on page 160

---

**Plug-In Information Window**

The **Plug-in Information** window lists all the available MIDI plug-ins, audio-codec plug-ins, program plug-ins, project import-export plug-ins, and the virtual file system plug-ins.

- To open the **Plug-in Information** window, select **Devices > Plug-in Information**.

![Plug-in Information Window](image)

**Update**

Makes Cubase re-scan the designated plug-in folders for updated plug-in information.
The following columns are available:

**Instances**
- Indicates how many instances of the plug-in are currently used in Cubase.

**Name**
- The name of the plug-in.

**Vendor**
- The manufacturer of the plug-in.

**File**
- The name of the plug-in with extension.

**Path**
- The path and name of the folder in which the plug-in file is located.

**Category**
- Indicates the category of each plug-in.

**Version**
- The version of the plug-in.

**SDK**
- Shows with which version of the VST protocol a plug-in is compatible.

---

**Managing Plug-Ins in the Plug-In Information Window**

- To make it available for selection, activate the checkbox in the left column. Only the enabled plug-ins will appear on the effect selectors.

- To see where a plug-in is used, click in the Instances column. A pop-up opens and shows where each plug-in is used.

NOTE

A plug-in may be in use even if it is not enabled in the left column.

You might for example have opened a project containing effects that are currently disabled on the menu. The left column only determines whether or not the plug-in is visible on the effect selectors.
Exporting Plug-In Information Files

You can save plug-in information as an XML file, for example for archiving purposes or troubleshooting.

- The plug-in information file contains information on the installed/available plug-ins, their version, vendor, etc.
- The XML file can then be opened in any editor application supporting the XML format.

**NOTE**
The export function is not available for program plug-ins.

**PROCEDURE**

1. In the **Plug-in Information** window, right-click on a tab and select **Export**. A file dialog opens.
2. In the dialog, specify a name and location for the plug-in information export file.
3. Click **OK** to export the file.
Audio processing and functions

Background

Audio processing in Cubase can be called “non-destructive”, in the sense that you can always undo changes or revert to the original versions. This is possible because processing affects audio clips rather than the actual audio files, and because audio clips can refer to more than one audio file.

This is how it works:

PROCEDURE

1. If you process an event or a selection range, a new audio file is created in the Edits folder, within your project folder.
   This new file contains the processed audio, while the original file is unaffected.
2. The processed section of the audio clip (the section corresponding to the event or selection range) then refers to the new, processed audio file.
   The other sections of the clip will still refer to the original file.
   • The original, unprocessed audio file can still be used by other clips in the project, by other projects or by other applications.
   • Since all edits are available as separate files, it is possible to undo any processing, at any point and in any order!
   This is done in the Offline Process History dialog.

RELATED LINKS

The Offline Process History dialog on page 418

Audio processing

You apply processing by making a selection and selecting a function from the Process submenu of the Audio menu.

Processing is applied according to the following rules:

• When events are selected in the Project window or the Audio Part Editor, the processing will be applied to these events only.
  Processing will only affect the clip sections that are referenced by the events.
• When an audio clip is selected in the Pool, the processing will be applied to the whole clip.

• When you have made a selection range, the processing will be applied to this range only.

Other sections of the clip are not affected.

If you attempt to process an event that is a shared copy (i.e. the event refers to a clip that is used by other events in the project), you are asked whether you want to create a new version of the clip.

Select “New Version” if you want the processing to affect the selected event only. Select “Continue” if you want the processing to affect all shared copies.

**Common settings and features**

If there are any settings for the selected Audio processing function, these will appear when you select the function from the Process submenu. While most settings are specific for the function, some features and settings work in the same way for several functions.

**The “More…” button**

If the dialog has a lot of settings, some options may be hidden when the dialog opens.

• To reveal these, click the “More…” button.

• To hide the settings, click the button again (now labeled “Less…”).

**The Preview, Process, and Cancel buttons**

These buttons have the following functionality:

**Preview button**

Allows you to listen to the result of the processing with the current settings. Playback will continue repeatedly until you click the button again (the button is labeled “Stop” during Preview playback). You can make adjustments during Preview playback, but the changes are not applied until the start of the next “lap”. Some changes may automatically restart the Preview playback from the beginning.

**NOTE**

To start or stop previewing, you can also press [Space].
Process button

Performs the processing and closes the dialog.

NOTE
To perform the process, you can also press [Enter] or [Return].

Cancel button

Closes the dialog without processing.

Pre/Post-Crossfade

Some processing functions allow you to gradually mix the effect in or out. This is done with the Pre/Post-Crossfade parameters. For example, if you activate Pre-Crossfade and specify a value of 1000ms, the processing is applied gradually from the start of selection, reaching full effect 1000ms after the start. Similarly, if you activate Post-Crossfade, the processing is gradually removed, starting at the specified interval before the end of the selection.

IMPORTANT
The sum of the Pre-Crossfade and Post-Crossfade times cannot be larger than the length of the selection.

Envelope

The Envelope function allows you to apply a volume envelope to the selected audio.

The dialog contains the following settings:

Curve Kind buttons
These determine whether the envelope curve consists of spline curve segments (left button), damped spline segments (middle button) or linear segments (right button).

Envelope display
Shows the shape of the envelope curve. The resulting waveform shape is shown in dark gray, with the current waveform shape in light gray. You can click on the curve to add points, and click and drag existing points to change the shape. To remove a point from the curve, drag it outside the display.
Presets

If you have set up an envelope curve that you may want to apply to other events or clips, you can save it as a preset by clicking the Store button.

- To apply a stored preset, select it from the pop-up menu.
- To rename the selected preset, double-click on the name and enter a new one in the dialog that opens.
- To remove a stored preset, select it from the pop-up menu and click Remove.

Fade In and Fade Out

For a description of these functions, click on the related link.

RELATED LINKS

Fades, crossfades, and envelopes on page 247

Gain

Allows you to change the gain (level) of the selected audio.

The dialog contains the following settings:

Gain

This is where you set the desired gain, between -50 and +20 dB. The setting is also indicated below the Gain display as a percentage.

Clipping detection text

If you use the Preview function before applying the processing, the text below the slider indicates whether the current settings result in clipping (audio levels above 0 dB). If that is the case, lower the Gain value and use the Preview function again.

- If you want to increase the level of the audio as much as possible without causing clipping, use the Normalize function instead.
Pre/Post-Crossfade

Some processing functions allow you to gradually mix the effect in or out. This is done with the Pre/Post-Crossfade parameters. For example, if you activate Pre-Crossfade and specify a value of 1000 ms, the processing is applied gradually from the start of selection, reaching full effect 1000 ms after the start. Similarly, if you activate Post-Crossfade, the processing is gradually removed, starting at the specified interval before the end of the selection.

IMPORTANT

The sum of the Pre-Crossfade and Post-Crossfade times cannot be larger than the length of the selection.

RELATED LINKS
Normalize on page 407

Merge Clipboard

This function mixes the audio from the clipboard into the audio selected for processing, starting at the beginning of the selection.

The dialog contains the following settings:

Sources mix

Allows you to specify a mix ratio between the original (the audio selected for processing) and the copy (the audio on the clipboard).

Pre/Post-Crossfade

Some processing functions allow you to gradually mix the effect in or out. This is done with the Pre/Post-Crossfade parameters. For example, if you activate Pre-Crossfade and specify a value of 1000 ms, the processing is applied gradually from the start of selection, reaching full effect 1000 ms after the start. Similarly, if you activate Post-Crossfade, the processing is gradually removed, starting at the specified interval before the end of the selection.

IMPORTANT

The sum of the Pre-Crossfade and Post-Crossfade times cannot be larger than the length of the selection.
**Noise Gate**

Scans the audio for sections weaker than a specified threshold level and replaces them with silence.

![Noise Gate settings](image)

The dialog contains the following settings:

**Threshold**

The level below which you want audio to be silenced. Levels below this value will close the gate.

**Attack Time**

The time it takes for the gate to open fully after the audio level has exceeded the threshold level.

**Min. Opening Time**

This is the shortest time the gate will remain open. If you find that the gate opens and closes too often when processing material that varies rapidly in level, try raising this value.

**Release Time**

The time it takes for the gate to close fully after the audio level has dropped below the threshold level.

**Linked Channels**

This is available for stereo audio only. When it is activated, the Noise Gate is opened for both channels as soon as one or both channels exceed the Threshold level. When Linked Channels is deactivated, the Noise Gate works independently for the left and right channel.

**Dry/Wet mix**

Allows you to specify a mix ratio between “dry” and processed sound.
Pre/Post-Crossfade

Some processing functions allow you to gradually mix the effect in or out. This is done with the Pre/Post-Crossfade parameters. For example, if you activate Pre-Crossfade and specify a value of 1000 ms, the processing is applied gradually from the start of selection, reaching full effect 1000 ms after the start. Similarly, if you activate Post-Crossfade, the processing is gradually removed, starting at the specified interval before the end of the selection.

IMPORTANT

The sum of the Pre-Crossfade and Post-Crossfade times cannot be larger than the length of the selection.

Normalize

The Normalize function allows you to specify the desired maximum level of the audio. It then analyzes the selected audio and finds the current maximum level. Finally it subtracts the current maximum level from the specified level and raises the gain of the audio by the resulting amount (if the specified maximum level is lower than the current maximum, the gain will be lowered instead). A common use for Normalizing is to raise the level of audio that was recorded at too low an input level.

The dialog contains the following settings:

Maximum

The desired maximum level for the audio, between -50 and 0 dB. The setting is also indicated below the Gain display as a percentage.

Pre/Post-Crossfade

Some processing functions allow you to gradually mix the effect in or out. This is done with the Pre/Post-Crossfade parameters. For example, if you activate Pre-Crossfade and specify a value of 1000 ms, the processing is applied gradually from the start of selection, reaching full effect 1000 ms after the start. Similarly, if you activate Post-Crossfade, the processing is gradually removed, starting at the specified interval before the end of the selection.

IMPORTANT

The sum of the Pre-Crossfade and Post-Crossfade times cannot be larger than the length of the selection.
Phase Reverse

Reverses the phase of the selected audio, turning the waveform “upside down”.

The dialog contains the following settings:

**Phase Reverse on**

When processing stereo audio, this pop-up menu allows you to specify which channel(s) are phase-reversed.

**Pre/Post-Crossfade**

Some processing functions allow you to gradually mix the effect in or out. This is done with the Pre/Post-Crossfade parameters. For example, if you activate Pre-Crossfade and specify a value of 1000 ms, the processing is applied gradually from the start of selection, reaching full effect 1000 ms after the start. Similarly, if you activate Post-Crossfade, the processing is gradually removed, starting at the specified interval before the end of the selection.

**IMPORTANT**

The sum of the Pre-Crossfade and Post-Crossfade times cannot be larger than the length of the selection.

Pitch Shift

This function allows you to change the pitch of the audio with or without affecting its length. You can also create “harmonies” by specifying several pitches or apply pitch shift based on a user specified envelope curve.
When the Transpose tab is selected, the dialog contains the following parameters:

**Keyboard display**

This is a graphic overview of the transposition setting. Here, you can specify the transpose interval in semitones.

- The root note is indicated in red.
  This has nothing to do with the actual key or pitch of the original audio, it just provides a way to display transpose intervals. You can change the root note by using the settings in the Pitch Shift Base section, or by pressing [Alt]/[Option] and clicking in the keyboard display.

- To specify a transpose interval, click on one of the keys.
  The key is indicated in blue, and the program plays test tones in the base pitch and transpose pitch to give you an audible confirmation.

- If “Multi Shift” is activated (see below), you can click on several keys to create “chords”.
  Clicking on a blue (activated) key removes it.

**Pitch Shift settings**

The “Semitones” and “Fine-Tune” settings allow you to specify the amount of pitch shift. You can transpose the audio ±16 semitones, and fine-tune it by ±200 cents (hundredths of semitones).

**Volume/Amplitude**

Allows you to lower the volume of the pitch-shifted sound.

**Multi Shift**

When this is activated, you can add several transpose values, creating multi-part harmonies. This is done by adding intervals in the keyboard display (see above). Note that you cannot use the Preview function in Multi Shift mode.

- If the intervals you add make up a standard chord, this chord is displayed to the right.

  Note, however, that to include the base pitch (the original, untransposed sound) in the processed result, you need to click the base key in the keyboard display as well, so that it is displayed in blue.

**Listen Key/Chord button**

Clicking this button plays a test tone pitched according to the activated interval key on the keyboard display. If “Multi Shift” is activated, this button is called “Listen Chord” and plays all activated intervals as a chord.

**Pitch Shift Base**

This allows you to set the root note (the red key in the keyboard display). It has nothing to do with the actual pitch, but is an aid for setting up intervals and chords.
Algorithm Settings

This is where you can make settings for the MPEX 4 algorithm.

For each quality setting you can choose between the regular setting and a setting where the formants are preserved. If you are processing vocal material, select the Preserve Formant setting in order to preserve the vocal characteristics of the pitch-shifted audio and to avoid a “chipmunk voice” effect.

Time Correction

When this is activated, the pitch shift process will not affect the length of the audio. When this is deactivated, raising the pitch will shorten the audio section and vice versa, much like changing the playback speed on a tape recorder.

Related Links

About time stretch and pitch shift algorithms on page 428

Using envelope based Pitch Shift

When the “Envelope” tab is selected, you can specify an envelope curve on which the pitch shift will be based. This allows you to create pitchbend effects, pitch-shift different sections of the audio by different amounts, etc.

Envelope display

Shows the shape of the envelope curve over the waveform image of the audio selected for processing. Envelope curve points above the center line indicate positive pitch shift, while curve points below the center line indicate negative pitch shift. Initially, the envelope curve will be a horizontal, centered line, indicating zero pitch shift.

- You can click on the curve to add points, and click and drag existing points to change the shape. To remove a point from the curve, drag it outside the display.
Curve Kind

These buttons determine whether the envelope curve consists of spline curve segments (left button), damped spline segments (middle button) or linear segments (right button).

Range

This parameter determines the vertical pitch range of the envelope. If set to “4”, moving a curve point to the top of the display corresponds to pitch shifting by +4 semitones. The maximum range is ±16 semitones.

Transpose and Fine-Tune

These parameters allow you to adjust the value of a curve point numerically:

1) Click on a curve point to select it.
   The selected point is shown in red.
2) Adjust the Transpose and Fine-Tune parameters to change the pitch of the curve point in semitones and cents, respectively.

Pitch Shift Mode

This is where you can make settings for the MPEX 4 algorithm.

For each quality setting you can choose between the regular setting and a setting where the formants are preserved. If you are processing vocal material, select the Preserve Formant setting in order to preserve the vocal characteristics of the pitch-shifted audio and to avoid a “chipmunk voice” effect.
Example

Let’s say that you wish to create a pitchbend effect, so that the pitch is raised linearly by exactly 2 semitones in a specific part of the selected audio.

**PROCEDURE**

1. Remove all curve points by clicking the Reset button.
2. Select a linear curve by clicking the Curve Kind button to the right.
3. Make sure that the Range parameter is set to 2 semitones or higher.
4. Create a point where you want the pitchbend to start by clicking on the envelope line.
   Since this is the starting point for the pitchbend, you want its pitch to be zero (the envelope line should still be straight). If necessary, use the Fine-Tune parameter to set the curve point to 0 cents, because this point governs the start point, where you want the pitch transition to begin.
5. Create a new curve point at the horizontal position where you want the pitchbend to reach the full value.
   This curve point determines the rise time of the pitchbend effect, i.e. the further away from the starting point the new point is positioned, the longer it will take for the pitchbend to reach the full value, and vice versa.
6. With the second point still selected, use the Transpose and Fine-Tune parameters to set the pitch to exactly 2 semitones.
7. Create a new curve point to set the duration of the pitchbend, i.e. the time the pitch will remain transposed by 2 semitones.
8. Finally, create a point where you want the pitchbend to end.
   You do not have to create a new point if you are at the end of the audio file, since there is always an end point at the right side of the waveform display.
9. If necessary, make additional settings in the Pitch Shift Mode section.
10. Click Process.
   The pitchbend is applied according to the specified settings.

**Remove DC Offset**

This function will remove any DC offset in the audio selection. A DC offset is when there is too large a DC (direct current) component in the signal, sometimes visible as the signal not being visually centered around the “zero level axis”. DC offsets do not affect what you actually hear, but they affect zero crossing detection and certain processing, and it is recommended that you remove them.
**Resample**

The Resample function can be used for changing the length, tempo and pitch of an event.

The original sample rate of the event is listed in the dialog. Resample the event to a higher or lower sample rate by either specifying a sample rate or by specifying the difference (as a percentage value) between the original sample rate and the desired new one.

- Resampling to a higher sample rate will make the event longer and cause the audio to play back at a slower speed with a lower pitch.
- Resampling to a lower sample rate will make the event shorter and cause the audio to play back at a faster speed with a higher pitch.
- You can audition the result of the resampling by entering the desired value and clicking “Preview”. The event will then be played back as it will sound after the resampling.
- When you are satisfied with the preview result, click “Process” to close the dialog and apply the processing.

**Reverse**

Reverses the audio selection, as when playing a tape backwards. There are no parameters for this function.

**Silence**

Replaces the selection with silence. There are no parameters for this function.
Stereo Flip

This function works with stereo audio selections only. It allows you to manipulate the left and right channel in various ways.

The dialog contains the following parameters:

**Mode**

This pop-up menu determines what the function does:

- **Flip Left-Right**  
  Swaps the left and right channel.

- **Left to Stereo**  
  Copies the left channel sound to the right channel.

- **Right to Stereo**  
  Copies the right channel sound to the left channel.

- **Merge**  
  Merges both channels on each side for mono sound.

- **Subtract**  
  Subtracts the left channel information from the right. This is typically used as a “Karaoke effect”, for removing centered mono material from a stereo signal.

Time Stretch

This function allows you to change the length and “tempo” of the selected audio without affecting the pitch.
The dialog contains the following parameters:

**Define Bars section**
In this section, you set the length of the selected audio and the time signature:

- **Bars**
  If you use the tempo setting (see below), specify the length of the selected audio here, in bars.

- **Beats**
  If you use the tempo setting, specify the length of the selected audio here, in beats.

- **Sign.**
  If you use the tempo setting, specify the time signature here.

**Original Length section**
This section contains information and settings regarding the audio selected for processing:

- **Length in Samples**
  The length of the selected audio, in samples.

- **Length in Seconds**
  The length of the selected audio, in seconds.

- **Tempo in BPM**
  If you are processing music, and know the actual tempo of the audio, you can enter it here as beats per minute. This makes it possible to time-stretch the audio to another tempo, without having to compute the actual time stretch amount.

**Resulting Length section**
These settings are used if you want to stretch the audio to fit within a specific time span or tempo. The values will change automatically if you adjust the Time Stretch Ratio (see below):

- **Samples**
  The desired length in samples.

- **Seconds**
  The desired length in seconds.

- **BPM**
  The desired tempo (beats per minute). For this to work, you have to know the actual tempo of the audio, and specify this (along with time signature and length in bars) in the Original Length section to the left.

**Seconds Range section**
These settings allow you to set the desired range for the time stretch:

- **Range**
  Allows you to specify the desired length as a range between two time positions.
• **Use Locators**
  Clicking the diamond-shaped button below the Range fields sets the Range values to the left and right Locator positions, respectively.

**Time Stretch Ratio section**
The Time Stretch Ratio determines the amount of time stretch as a percentage of the original length. If you use the settings in the Resulting Length section to specify the amount of time stretch, this value will change automatically.

**Algorithm section**
In this section you can select a time stretch algorithm. The pop-up menu contains various presets sorted into category submenus based on the underlying technology: élastique, MPEX, and Standard.

**RELATED LINKS**
  About time stretch and pitch shift algorithms on page 428

### Applying plug-ins (Cubase Pro only)

You can add plug-in effects in realtime during playback. However, sometimes it is useful to “permanently” apply effects to one or several selected events.

This is done in the following way:

**PROCEDURE**
1. Make a selection in the Project window, the Pool or an editor. Effects are applied according to the same rules as Processing.
2. Select “Plug-ins” from the Audio menu.
3. Select the desired effect from the submenu. The Process Plug-in dialog opens.

**RELATED LINKS**
  Audio Effects on page 372
  Common settings and features on page 402

### About stereo and mono

If you are applying an effect to mono audio material, only the left side of the effect's stereo output will be applied.
The process plug-in dialog

The upper section of the process plug-in dialog contains the effect parameters of the selected plug-in. For details on the parameters of the included plug-ins, see the separate PDF document “Plug-in Reference”.

![The process plug-in dialog for the StudioChorus effect](image)

The process plug-in dialog contains settings for the actual processing. These are common to all plug-ins.

- If the lower section is hidden, click the “More…” button to display it.
  
  Clicking the button again (now labeled “Less…”) will hide the lower section.

The following settings and functions are available in the common, lower section of the dialog:

**Wet mix/Dry mix**

These two sliders allow you to specify the balance between wet (processed) and dry (original) signal in the resulting clip.

Normally the two sliders are “reverse-ganged”, so that raising the Wet mix slider lowers the Dry mix slider by the same amount. However, if you press [Alt]/[Option] and drag a slider, you can move it independently. This allows you to set 80% dry and 80% wet signal, for example. Be careful to avoid distortion.

**Tail**

This parameter is useful if you are applying an effect that adds material after the end of original audio (such as reverb and delay effects). When the checkbox is activated, you can specify a tail length using the slider. The tail time is included when playing back with the Preview function, allowing you to find the appropriate tail length.
Pre/Post-Crossfade

These settings allow you to gradually mix the effect in or out. For example, if you activate Pre-Crossfade and specify a value of 1000 ms, the effect is applied gradually from the start of selection, reaching full effect 1000 ms after the start. Similarly, if you activate Post-Crossfade, the processing is gradually removed, starting at the specified interval before the end of the selection.

**IMPORTANT**

The sum of the Pre-Crossfade and Post-Crossfade times cannot be larger than the length of the selection.

Preview button

Allows you to listen to the result of the processing with the current settings. Playback will continue repeatedly until you click the button again (the button is labeled “Stop” during Preview playback). You can make adjustments during Preview playback, but the changes are not applied until the start of the next “lap”. Some changes may automatically restart the Preview playback from the beginning.

You can change the effect settings during Preview playback if needed.

**NOTE**

To start or stop previewing, you can also press [Space].

Process button

Applies the effect and closes the dialog.

**NOTE**

To perform the process, you can also press [Enter] or [Return].

Cancel button

Closes the dialog without applying the effect.

The Offline Process History dialog

If you want to remove or modify some or all processing from a clip, this can be done in the Offline Process History dialog. Processing that can be modified in the Offline Process History dialog includes the functions on the Process menu, any applied plug-in effects (Cubase Pro only), and Sample Editor operations such as Cut, Paste, Delete and drawing with the Draw tool.

**NOTE**

Due to the clip-file relationship, it is even possible to modify or remove some processing “in the middle” of the Process History, while keeping later processing! This feature depends on the type of processing performed.
Audio processing and functions
The Offline Process History dialog

**PROCEDURE**

1. Select the clip in the Pool or one of its events in the Project window.
   You can see which clips have been processed by checking the Status column in the Pool – the waveform symbol indicates that processing or effects have been applied to the clip.

2. Select “Offline Process History…” from the Audio menu.
   The Offline Process History dialog opens.

   ![Offline Process History dialog](image)

   The left part of the dialog contains a list of all processing you have added to the clip, with the most recent operations at the bottom of the list. The "Start" and "Length" columns indicate which section of the clip was affected by each operation. The "Status" column indicates if the operation can be modified or undone.

3. Locate the operation you want to edit and select it by clicking on it in the list.
   - To modify the settings of the selected processing, click the “Modify” button.
     This opens the dialog for the processing function or applied effect, allowing you to change the settings. This works just as when you applied the processing or effect the first time.
   - To replace the selected operation with another processing function or effect, select the desired function from the pop-up menu and click the “Replace By” button.
     If the selected function has settings, a dialog will appear as usual. The original operation will then be removed and the new processing will be inserted in the Offline Process History.
   - To remove the selected operation, click the “Remove” button.
     The processing is removed from the clip.
   - To undo the selected operation and remove the processing from the clip click the “Deactivate” button.
     The processing is removed from the clip, but the operation remains in the list. To redo the operation and apply the processing again, click the button, now renamed to “Activate”, again.

4. Click “Close” to close the dialog.

**RELATED LINKS**

- Restrictions on page 420
- Status on page 502
Restrictions

- If there are no settings for the processing function, you cannot modify it.
- If you have applied processing that changes the length of the clip (such as Cut, Insert or Time Stretch), you can only remove this if it is the most recent processing in the Offline Process History (at the bottom of the list in the dialog). If an operation cannot be removed or modified, this is indicated by an icon in the “Status” column. Also, the corresponding buttons will be grayed out.

Freeze Edits

The Freeze Edits function on the Audio menu allows you to make all processing and applied effects permanent for a clip:

**PROCEDURE**

1. Select the clip in the Pool or one of its events in the Project window.
2. Select “Freeze Edits…” from the Audio menu.
   - If there is only one edit version of the clip (no other clips refer to the same audio file), the following dialog will appear:

     ![Replace original or create new file dialog]

     If you select “Replace”, all edits will be applied to the original audio file (the one listed in the clip’s Path column in the Pool). If you select “New File”, the Freeze Edits operation will create a new file in the Audio folder within the project folder (leaving the original audio file unaffected).

   - If the selected clip (or the clip played by the selected event) has several edit versions (i.e. there are other clips referring to the same audio file), the following alert will appear:

     ![You selected clips that have more than one version dialog]

     As you can see, you do not have the option to Replace the original audio file in this case. This is because that audio file is used by other clips. Select “New File” to have a new file created in the Audio folder within the project folder.

**IMPORTANT**

After a Freeze Edits, the clip refers to a new, single audio file. If you open the Offline Process History dialog for the clip, the list will be empty.
Detect Silence

The Detect Silence function searches for silent sections in an event and either splits the event, removing the silent parts from the project, or creates regions corresponding to the non-silent sections.

- To open the Detect Silence dialog, select one or several audio events in the Project window or the Audio Part Editor. On the Audio menu, open the Advanced submenu and select “Detect Silence”.
  
  If you select more than one event, the Detect Silence dialog allows you to process the selected events successively with individual settings or to apply the same settings to all selected events at once.

The settings have the following functionality:

**Open Threshold**

When the audio level exceeds this value, the function “opens”, i.e. lets the sound pass. Audio material below the set level is detected as “silence”. Set this value low enough to open when a sound starts, but high enough to remove unwanted noise during “silent” sections.

**Close Threshold**

When the audio level drops below this value, the function “closes”, i.e. sounds below this level are detected as “silence”. This value cannot be higher than the Open Threshold value. Set this value high enough to remove unwanted noise during “silent” sections.

**Linked**

If this checkbox is activated, the Open and Close Threshold values are always set to the same value.

**Min. time open**

Determines the minimum time that the function will remain “open” after the audio level has exceeded the Open Threshold value.

If the audio contains repeated short sounds, and you find that this results in too many short “open” sections, try raising this value.
Audio processing and functions
Detect Silence

Min. time closed
Determine the minimum time that the function will remain “closed” after the audio level has dropped below the Close Threshold value.
Set this to a low value to avoid removing sounds.

Pre-roll
Allows you to cause the function to “open” slightly before the audio level exceeds the Open Threshold value. In other words, the start of each “open” section is moved to the left according to the time you set here.
This is useful to avoid removing the attack of sounds.

Post-roll
Allows you to cause the function to “close” slightly after the audio level drops below the Close Threshold value.
This is useful to avoid removing the natural decay of sounds.

Add as Regions
“Add as Regions” will create regions according to the non-silent sections.
If you activate the “Add as Regions” option, you can specify a name for the regions in the Region Name field. In addition to the name, the regions will be numbered, starting with the number specified in the “Auto Number Start” field.

Strip Silence
“Strip Silence” will split the event at the beginning and end of each non-silent section, and remove the silent sections in between.

Process all selected Events
If you have selected more than one event, you can activate the “Process all selected Events” checkbox to apply the same settings to all selected events.

Compute
The audio event is analyzed, and the waveform display is redrawn to indicate which sections are considered “silent” according to your settings. Above the Compute button, the number of detected regions is displayed.

Auto
If you activate the Auto checkbox next to the Compute button, the audio event is analyzed (and the display is updated) automatically every time you change the settings in the Detection section of the dialog. Deactivate this option when you are working with very long files, as this process might take some time.
Adjustments in the waveform display

The upper part of the dialog displays a waveform image of the selected audio event. In case you have selected several audio events, the waveform of the event that you have selected first is shown.

You can make the following adjustments:

- With the zoom slider below the waveform to the right, zoom in and out on the waveform.
  You can also click in the waveform, keep the mouse button pressed, and move the mouse for zooming. Move the mouse down to zoom in and move it up to zoom out.

- If you have zoomed in on the waveform, it may not be completely visible anymore. In this case, the scrollbar to the left of the zoom slider allows you to scroll through the waveform.
  You can also use the mouse wheel for scrolling through the waveform.

- If the Linked option in the Detection section is deactivated, you can use the green square at the beginning and the red square at the end of the audio file to graphically adjust the Open and Close Threshold values (respectively). When “Linked” is activated, you can use either square to adjust both values. The Open and Close Threshold values in the Detection section reflect these changes.

Making settings and processing

The lower part of the Detect Silence dialog provides settings for the detection and processing of “silent” sections.

**PROCEDURE**

1. Adjust the settings in the Detection section to the left.
2. Click the Compute button.
   The audio event is analyzed, and the waveform display is redrawn to indicate which sections are considered “silent” according to your settings. Above the Compute button, the number of detected regions is displayed.
3. Click “Preview” to listen to the result.
   The event is played back repeatedly in its entire length, but with the “closed” sections silenced.
4. Adjust the settings in the Detection section until you are satisfied with the result.
5. In the Output section, activate the “Add as Regions” or the “Strip Silence” option, or both.
6. Click the Process button. 
The event is split and/or regions are added.

NOTE
If you have selected more than one event and did not activate the “Process all selected Events” option in the Output section, the dialog opens again after processing, allowing you to make separate settings for the next event.

The Spectrum Analyzer

This function analyzes the selected audio, computes the average “spectrum” (level distribution over the frequency range) and displays this as a two-dimensional graph, with frequency on the x-axis and level on the y-axis.

PROCEDURE
1. Make an audio selection (a clip, an event or a range selection).
2. Select “Spectrum Analyzer” from the Audio menu.
A dialog with settings for the analysis appears.

The default values give good results in most situations, but you can adjust the settings if you like:
- **Size in Samples**
  The function divides the audio into “analysis blocks”, the size of which is set here. The larger this value, the higher the frequency resolution of the resulting spectrum.
- **Size of Overlap**
  The overlap between each analysis block.
- **Window used**
  Allows you to select which window type is used for the FFT (Fast Fourier Transform, the mathematical method used for computing the spectrum).
Audio processing and functions
The Spectrum Analyzer

- **Normalized Values**
  When this is activated, the resulting level values are scaled, so that the highest level is displayed as "1" (0dB).

- **From Stereo**
  When analyzing stereo material, there is a pop-up menu with the following options:
  - Mono mix – the stereo signal is mixed to mono before analyzing.
  - Mono left/right – the left or right channel signal is used for analysis.
  - Stereo – both channels are analyzed (two separate spectrums will be displayed).

3. **Click the Process button.**
   The spectrum is computed and displayed as a graph.

![Image of Spectrum Analyzer]

4. **You can adjust the display with the settings in the display window:**
   - **dB**
     When this is activated, the vertical axis shows dB values. When it is deactivated, values between 0 and 1 are shown.
   - **Freq. log**
     When this is activated, frequencies (on the horizontal axis) are displayed on a logarithmic scale. When it is deactivated, the frequency axis is linear.
   - **Precision**
     Indicates the frequency resolution of the graph. This value cannot be changed here, but is governed by the Size in Samples setting in the previous dialog.
   - **Frequency/Note**
     Allows you to select whether you want the frequencies to be displayed in Hertz or with note names.
   - **Min.**
     Sets the lowest frequency shown in the graph.
   - **Max.**
     Sets the highest frequency shown in the graph. By adjusting the Min and Max values, you can take a closer look at a smaller frequency range.
   - **Active**
     When this is activated, the next Spectrum Analysis will appear in the same window. When deactivated, new Spectrum Analysis results will appear in separate windows.

5. **If you move the mouse pointer over the graph, a cross-hair cursor follows the graph curve and the display in the upper right corner shows the frequency/note and level at the current position.**
   To compare the level between two frequencies, move the pointer to one of the frequencies, right-click once and move the pointer to the second frequency. The delta
value (the difference in level between the current position and the right-click position) is displayed in the upper right corner (labeled “D”).

- If you analyze stereo audio and selected the “Stereo” option in the first dialog, the graphs for the left and right channel are superimposed in the display, with the left channel graph in white and the right channel graph in yellow.

The display in the upper right corner shows the values for the left channel – to see the right channel values, hold down [Shift]. An “L” or “R” is displayed to indicate which channel values are shown.

6. You can leave the window open or close it by clicking the “Close” button. If you leave it open and the “Active” checkbox is ticked, the result of the next Spectrum Analysis will be displayed in the same window.

---

**Statistics**

The Statistics function on the Audio menu analyzes the selected audio (events, clips, or range selections) and displays a window with the following information:

**Channel**
- The name of the analyzed channel.

**Min. Sample Value**
- The lowest sample value in dB.

**Max. Sample Value**
- The highest sample value in dB.

**Peak Amplitude**
- The largest amplitude in dB.
True Peak
The maximum absolute level of the audio signal waveform in the continuous time domain.

DC Offset
The amount of DC Offset as a percentage and in dB.

Resolution
The current calculated audio resolution.

Estimated Pitch
The estimated pitch.

Sample Rate
The sample rate.

Average RMS (AES-17)
The average loudness in accordance with the AES-17 standard.

Max. RMS
The highest RMS value.

Max. RMS All Channels
The highest RMS value of all channels.

Integrated Loudness (Cubase Pro only)
The average loudness over the whole title in LUFS (Loudness Unit, referenced to Full Scale) in accordance with EBU R-128 that recommends to normalize audio at -23LUFS (±1LU).

Loudness Range (Cubase Pro only)
The dynamic range over the whole title in LU (Loudness Units). This value allows you to see if dynamic processing is needed.

Max. True Peak Level (Cubase Pro only)
The maximum value of the audio signal waveform in the continuous time domain.

Max. Momentary Loudness (Cubase Pro only)
The maximum value of all momentary loudness values, based on a time window of 400ms. The measurement is not gated.

Max. Short-Term Loudness (Cubase Pro only)
The maximum value of all short-term loudness values, based on a time window of 3s. The measurement is not gated.

RELATED LINKS
Remove DC Offset on page 412
About time stretch and pitch shift algorithms

In Cubase, time stretching and pitch shifting algorithms are used for numerous operations (e.g. the Time Stretch and Pitch Shift offline processes, in the Sample Editor, or by the Flatten function). Depending on the feature, some or all of the following algorithm presets are available.

élastique

The élastique algorithm is suited for both polyphonic and monophonic material. The algorithm has three modes, and there are three presets for each mode.

The following modes are available:

• élastique Pro – This mode offers the best audio quality, without formant preservation.
• élastique Pro Formant – This is the same as the Pro mode, but including formant preservation.
• élastique efficient – This mode requires less computing powers, but has a lower audio quality than the Pro modes.

These modes are available with the following variants:

• Time – Timing accuracy is favored over pitch accuracy.
• Pitch – Pitch accuracy is favored over timing accuracy.
• Tape – The pitch shift is locked to the time stretch (as when playing back a tape with varying speed). Stretching the audio material to a longer duration automatically decreases its pitch. This variant has no effect when used in combination with event transpose or the transpose track.

MPEX

MPEX is an alternative high-quality algorithm.

You can choose between the following quality settings:

MPEX – Preview Quality

Use this mode only for preview purposes.

MPEX – Mix Fast

This mode is a very fast mode for preview. This works best with composite music signals (mono or stereo material).

MPEX – Solo Fast

Use this mode for single instruments (monophonic material) and voice.
MPEX – Solo Musical
Same as above but higher quality.

MPEX – Poly Fast
Use this for processing monophonic and polyphonic material. This is the fastest setting that gives still very good results. You can use this for drum loops, mixes, chords.

MPEX – Poly Musical
Use this for processing monophonic and polyphonic material. This is the recommended MPEX default quality setting. You can use this for drum loops, mixes, chords.

MPEX – Poly Complex
This high quality setting is quite CPU-intensive and should be used only when processing difficult material or for stretch factors above 1.3.

**NOTE**
When applying the Pitch Shift process, you can choose between the regular setting and a setting where the formants are preserved for each quality setting.

---

**Standard**

The Standard algorithm is optimized for CPU efficient realtime processing.

The following presets are available:

**Standard – Drums**
This mode is best for percussive sounds, because it does not change the timing of your audio. Using this option with certain tuned percussion instruments may lead to audible artifacts. In this case, try the Mix mode as an alternative.

**Standard – Plucked**
Use this mode for audio with transients and a relatively stable spectral sound character (e.g. plucked instruments).

**Standard – Pads**
Use this mode for pitched audio with slower rhythm and a stable spectral sound character. This minimizes sound artifacts, but the rhythmic accuracy is not preserved.

**Standard – Vocals**
This mode is suitable for slower signals with transients and a prominent tonal character (e.g. vocals).
Audio processing and functions
About time stretch and pitch shift algorithms

Standard – Mix
This mode preserves the rhythm and minimizes the artifacts for pitched material that does not meet the above criteria (i.e. with a less homogenous sound character).

This preset is selected by default for audio that is not categorized.

Standard – Custom
This preset allows you to manually tweak the time stretching parameters (see below). By default, the settings that are shown when you open the dialog are those of the last preset used (except if the Solo preset has been selected, see below).

Standard – Solo
This mode preserves the timbre of the audio. Only use it for monophonic material (solo woodwind/brass instruments or solo vocals, monophonic synths or string instruments that do not play harmonies).

If you select the “Standard – Custom” option, a dialog opens where you can manually adjust the three parameters that govern the sound quality of the time stretching:

Grain size
The standard time-stretching algorithm splits the audio into small pieces called “grains”. This parameter determines the size of the grains. For material with many transients, use low grain size values for best results.

Overlap
Overlap is the percentage of the whole grain that will overlap with other grains. Use higher values for material with a stable sound character.

Variance
Variance is also a percentage of the whole length of the grains, and sets a variation in positioning so that the overlapping area sounds smooth. A Variance setting of 0 will produce a sound akin to time stretching used in early samplers, whereas higher settings produce more (rhythmic) “smearing” effects but less audio artifacts.

Limitations
Applying time stretching or pitch shifting to audio material can lead to a degradation in audio quality and to audible artifacts. The result depends on many factors, such as the source material, the particular stretch and pitch operations applied, and the selected audio algorithm preset.

As a rule of thumb, smaller changes in pitch or duration cause less degradation. However, there are additional issues one should be aware of when working with time stretching and pitch shifting algorithms.
Audio processing and functions
About time stretch and pitch shift algorithms

**NOTE**

In rare cases, editing warped audio events may cause discontinuities at the edit points. You can then try to move the edit point to a different position or bounce the audio event prior to editing.

**Reverse playback and scrubbing**

Most of the algorithms used for time stretching and pitch shifting only support forward playback. Reverse playback or scrubbing of warped audio events can lead to recurring artifacts in the playback.

**Pitch and stretch factor limitations**

Some algorithms may put limitations on the maximum degree of time stretching or pitch shifting supported.
The Sample Editor allows you to view and manipulate audio by cutting and pasting, removing, or drawing audio data, and by processing audio. This editing is “non-destructive”: The actual file will remain untouched so that you can undo modifications or revert to the original settings at any time.

The Sample Editor also contains most of the realtime time stretching functions in Cubase. These can be used to match the tempo of audio to the project tempo.

Another special feature of the Sample Editor is hitpoint detection. Hitpoints allow you to create audio slices, which can be useful in many situations, for example, if you want to change the tempo without introducing artifacts.

The VariAudio features (Cubase Pro only) allow you to edit monophonic vocal recordings in pitch and time, as easily as editing MIDI in the Key Editor. In these realtime pitch modifications the transitions are kept so that the sound remains natural. The pitch detection and correction is “non-destructive”, i.e. you can always undo modifications or revert to the original versions.
NOTE
The term “loop” is used throughout this chapter and in this context usually means an audio file with a musical time base. That means that the length of the loop represents a certain number of bars and beats at a certain tempo. Playing the loop back at the right tempo in a cycle set to the correct length will produce a continuous loop without gaps.

RELATED LINKS
Audio processing and functions on page 401
Warping audio on page 452
Working with hitpoints and slices on page 459
VariAudio (Cubase Pro only) on page 468

Opening the Sample Editor

To open the Sample Editor, double-click an audio event in the Project window or the Audio Part Editor, or double-click an audio clip in the Pool. You can have more than one Sample Editor window open at the same time.

NOTE
Double-clicking an audio part in the Project window opens the Audio Part Editor, even if the part contains a single audio event only.

RELATED LINKS
Audio Part Editor on page 492

The toolbar

The toolbar contains various tools for selecting, manipulating and playing back audio, as well as options that affect the appearance and behavior of the Sample Editor.

In the Musical Information section at the right of the toolbar, the estimated length of your audio file is displayed in bars and beats (PPQ) together with the estimated tempo and the time signature. These values are important for using Musical Mode.

The Algorithm pop-up menu allows you to select an algorithm for the realtime time stretching.

- You can customize the toolbar by right-clicking it and using the context menu to hide or show items.
Show Audio Event

When the “Show Audio Event” button is activated on the toolbar, the section corresponding to the edited event is highlighted in the waveform display and the Overview. The sections of the audio clip not belonging to the event are shown with a gray background.

- You can adjust the start and end of the event in the clip by dragging the event handles in the waveform display.

**IMPORTANT**

This button is only available if you have opened the Sample Editor by double-clicking an audio event in the Project window or the Audio Part Editor. It is not available if you have opened the audio event from the Pool.

Edit Active Audio Event Only (Cubase Pro only)

The “Edit Active Audio Event Only” button on the toolbar lets you restrict editing operations to the active audio event.

Snap

The Snap function helps you to find exact positions when editing in the Sample Editor by restricting horizontal movement and positioning to certain grid positions. You turn Snap on or off by clicking the Snap button in the Sample Editor toolbar.

**NOTE**

The Sample Editor Snap function is independent of the Snap setting in the Project window toolbar or other editors. It has no effect outside the Sample Editor.

Snap to Zero Crossing

When this option is activated, editing is done at zero crossings (positions in the audio where the amplitude is zero). This helps you to avoid pops and clicks, which might otherwise be caused by sudden amplitude changes.

**NOTE**

The Sample Editor function “Snap to Zero Crossing” is independent of the same setting in the Project window toolbar or other editors. It has no effect outside the Sample Editor.

Auto-Scroll

When the Auto-Scroll option is activated on the Sample Editor toolbar, the waveform display will scroll during playback, keeping the project cursor visible in the editor.

**NOTE**

This setting is independent of the Auto-Scroll setting in the Project window toolbar or other editors.
VariAudio Segment Colors (Cubase Pro only)

You can select a color scheme for VariAudio segments on the “VariAudio Segment Colors” pop-up menu on the toolbar. When working with several audio events, this makes it easier to see which segments belong to which event.

The following options are available:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Auto</td>
<td>This is the default mode. All segments belonging to the same audio event get the same color.</td>
</tr>
<tr>
<td>Event</td>
<td>The segments get the same color as the corresponding event in the Project window.</td>
</tr>
<tr>
<td>Pitch</td>
<td>The segments get different colors depending on their pitch.</td>
</tr>
<tr>
<td>Chord Track</td>
<td>Segments that match the corresponding chord or scale events on the chord track are highlighted in a special color.</td>
</tr>
</tbody>
</table>

**RELATED LINKS**
- Musical Mode on page 451
- Selecting an algorithm for realtime playback on page 451
- Handling Several Audio Events (Cubase Pro only) on page 448
- Chord Functions on page 814
- Using the Setup options on page 1032

**The info line**

The info line is displayed below the toolbar. It shows information about the audio clip, such as the audio format and the selection range.
Initially, length and position values are displayed in the format specified in the Project Setup dialog.

- To show or hide the info line, click the “Set up Window Layout” button on the toolbar and activate or deactivate the Info Line option.

**RELATED LINKS**
Using the Setup options on page 1032

---

**The Sample Editor Inspector**

On the left in the Sample Editor, you will find the Sample Editor Inspector. It contains tools and functions for working in the Sample Editor.

**The Definition tab**

The Definition tab helps you to adjust the audio grid and define the musical context of your audio. This is useful if you have an audio loop or audio file that you want to match to the project tempo. If the Definition tab is open, a second ruler is displayed, showing the musical structure of your audio.

**The AudioWarp tab**

The AudioWarp tab lets you perform timing settings for your audio. This includes applying swing and manually changing the rhythm of the audio by dragging beats to time positions in the grid.

- If you click the “Disable Warp Changes” button, any warp modifications you have made are disabled, allowing you to compare the modified sound with the original sound of your audio.

However, the display does not change. The time stretch applied by the Musical Mode is not disabled by this. “Disable Warp Changes” is deactivated when you reset your warp operations or when you close the Sample Editor. It will not be recalled when reopening the Sample Editor.
The VariAudio tab (Cubase Pro only)

Disable Pitch Changes

On this tab you can edit single notes of your audio file and change their pitch and/or timing, in a way that is similar to the editing of MIDI notes. Furthermore, you can extract MIDI from your audio.

- If you click the “Disable Pitch Changes” button, any pitch modifications you have made are disabled, allowing you to compare the modified sound with the original sound of your audio.

However, the display does not change. “Disable Pitch Changes” is deactivated when you reset your pitch or warp operations or when you close the Sample Editor. It will not be recalled when reopening the Sample Editor.

The Hitpoints tab

On this tab, hitpoints can be marked and edited. Hitpoints allow you to slice your audio and to create groove quantize maps from your audio. You can also create markers, regions, events, and warp markers based on hitpoints.

The Range tab

On this tab you will find functions for working with ranges and selections.
The Process tab

This tab regroups the most important audio editing commands from the Audio and Edit menus.

RELATED LINKS
Inspector on page 50
Warping audio on page 452
Applying swing on page 456
Free Warp on page 457
Understanding the waveform display in VariAudio on page 469
Extracting MIDI on page 486
Working with hitpoints and slices on page 459
Making selections on page 444
Audio processing and functions on page 401

The overview line

The overview line displays the whole clip.

1) Event Start
2) Selection
3) Event End
4) Viewing area
5) Snap Point

The section currently shown in the main waveform display of the Sample Editor (the viewing area) is indicated by a rectangle in the overview line, and the current selection range is also shown. If the “Show Audio Event” button is activated on the toolbar, event start/end and snap point are shown in the overview line.

• To view other sections of the clip, move the viewing area in the overview line. Click in the lower half of the viewing area and drag to the left or right to move it.

• To zoom in or out, horizontally, resize the viewing area by dragging its left or right edge.

• To define a new viewing area, click in the upper half of the Overview and drag a rectangle.
The ruler

The Sample Editor ruler is located between the overview line and the waveform display.

When the Definition tab is open, an additional ruler displays the musical structure of the audio file.

RELATED LINKS
Ruler on page 48

The waveform display and the level scale

The waveform display shows the waveform image of the edited audio clip according to the wave image style set in the Preferences dialog (Event Display–Audio page).

To the left of the waveform display a level scale is shown, indicating the amplitude of the audio.

- You can select whether the level is shown as a percentage or in dB. This is done by opening the level scale pop-up menu at the top of the level scale and selecting an option.
General Functions

Zooming

Zooming in the Sample Editor is done according to the standard zoom procedures, with the following special notes to keep in mind:

- The vertical zoom slider changes the vertical scale relative to the height of the editor window, in a way similar to the waveform zooming in the Project window.
- The vertical zoom will also be affected if the “Zoom Tool Standard Mode: Horizontal Zooming Only” preference (Editing–Tools page) is deactivated and you drag a rectangle with the Zoom tool.

The following options relevant to the Sample Editor are available on the Zoom submenu of the Edit menu or the context menu:

**Zoom In**
Zooms in one step, centering on the position cursor.

**Zoom Out**
Zooms out one step, centering on the position cursor.

**Zoom Full**
Zooms out so that the whole clip is visible in the editor.

**Zoom to Selection**
Zooms in so that the current selection fills the editor display.
Zoom to Selection (Horiz.)

Zooms in horizontally so that the current selection fills the editor display.

Zoom to Event

Zooms in so that the editor shows the section of the clip corresponding to the edited audio event. This is not available if you have opened the Sample Editor from the Pool (in which case the whole clip is opened for editing, not an event).

Zoom In/Out Vertically

This is the same as using the vertical zoom slider (see above).

Undo/Redo Zoom

These options allow you to undo/redo the last zoom operation.

- Cubase Pro only: When the VariAudio tab is active, you can also zoom by holding down [Alt]/[Option] while drawing a selection rectangle around the segments that you want to zoom in on. You can zoom out by holding down [Alt]/[Option] and clicking in an empty area of the waveform.

- The current zoom setting is shown in the info line, as a “samples per screen pixel” value.

**NOTE**

You can zoom in horizontally to a scale of less than one sample per pixel! This is required for drawing with the Draw tool.

- If you have zoomed in to one sample per pixel or less, the appearance of the samples depends on the “Interpolate Audio Images” option in the Preferences dialog (Event Display–Audio page).

  If the option is deactivated, single sample values are drawn as “steps”. If the option is activated, they are interpolated to a “curve” form.

**RELATED LINKS**

VariAudio (Cubase Pro only) on page 468
Drawing in the Sample Editor on page 444
Zooming in the Project Window on page 58

**Auditioning**

While you can use the regular play commands to play back audio when the Sample Editor is open, it is often useful to listen to the edited material only.

**NOTE**

Cubase Pro only: When auditioning, audio is routed to the Control Room (if activated) or to the Main Mix (the default output bus). In Cubase Artist, the Main Mix bus is always used for all auditioning.

Clicking the Audition icon on the toolbar plays back the edited audio, according to the following rules:
- If you have made a selection, this selection will be played back.
- If there is no selection and “Show Event” is deactivated, playback will start at the cursor position.
- If the Audition Loop icon is activated, playback will continue repeatedly until you deactivate the Audition Loop icon. Otherwise, the section will be played back once.

**NOTE**
There is a separate Play button for auditioning regions.

**Using the Speaker tool**
If you click somewhere in the waveform display with the Speaker (“Play”) tool and keep the mouse button pressed, the clip is played back from the position where you click. Playback will continue until you release the mouse button.

**Using Acoustic Feedback**
If you activate the “Acoustic Pitch Feedback” button on the toolbar, the audio will be played back when you edit it vertically, i.e. when you change the pitch. This way you can easily audition your modifications.

**Using key commands**
If you activate the “Playback Toggle triggers Local Preview” option in the Preferences dialog (Transport page), you can start/stop auditioning by pressing [Space]. This is the same as clicking the Audition icon on the toolbar.

The Sample Editor also supports the “Preview start” and “Preview stop” key commands in the Media category of the Key Commands dialog. These key commands stop the current playback, whether you are in normal playback or in audition mode.

**RELATED LINKS**
- Setting up Routing on page 325
- Auditioning regions on page 450

**Scrubbing**

The Scrub tool allows you to locate positions in the audio by playing back, forwards, or backwards, at any speed:

**PROCEDURE**
1. Select the Scrub tool.

2. Click in the waveform display and keep the mouse button pressed.
   The project cursor is moved to the position where you clicked.

3. Drag to the left or right.
   The audio is played back. The speed and pitch of the playback depend on how fast you drag.
**Adjusting the snap point**

The snap point is a marker within an audio event. It is used as a reference position when you move events with snap activated, so that the snap point is “magnetic” to whatever snap positions you have selected.

By default, the snap point is set at the beginning of the audio event, but often it is useful to move the snap point to a “relevant” position in the event, such as a downbeat.

**NOTE**
- If you adjust the snap point with the Scrub tool, the audio is played back.
- You can also adjust the snap point by setting the project cursor at the desired position and selecting “Snap Point To Cursor” on the Audio menu. The snap point will be set to the position of the cursor. This method can also be used in the Project window and the Audio Part Editor.
- It is also possible to define a snap point for a clip (for which there is no event yet).

To open a clip in the Sample Editor, double-click it in the Pool. After having set the snap point, you can insert the clip into the project from the Pool or the Sample Editor with the set snap point position.

**IMPORTANT**
- When you set the grid start on the Definition tab, the snap point is moved to the grid start.
- Events and clips can have different snap points. If you open a clip from the Pool, you can edit the clip snap point. If you open a clip from within the project window, you can edit the event snap point. The clip snap point serves as a template for the event snap point. However, it is the event snap point that is taken into account when snapping.

To adjust the snap point, proceed as follows:

**PROCEDURE**
1. Activate the “Show Audio Event” option on the toolbar, so that the event is displayed in the editor.
2. If needed, scroll until the event is visible, and locate the “S” flag in the event. If you have not adjusted this previously, it is located at the beginning of the event.
3. Click on the “S” flag and drag it to the desired position.
Drawing in the Sample Editor

It is possible to edit the audio clip at sample level by drawing with the Draw tool. This can be useful if you need to manually edit out a spike or click, etc.

PROCEDURE
1. Zoom in to a zoom value lower than 1.
   This means that there is more than one screen pixel per sample.
2. Select the Draw tool.
3. Click at the beginning of the section that you want to correct and draw in the new curve.
   A range selection covering the edited section is automatically applied.

NOTE
Cubase Pro only: The Draw tool cannot be used when the VariAudio tab is open.

Making selections

To select an audio section in the Sample Editor, click and drag with the Range Selection tool.

A selected range

- If “Snap to Zero Crossing” is activated on the toolbar, the selection’s start and end are always at zero crossings.
- You can resize the selection by dragging its left and right edge or by [Shift]-clicking.
- The current selection is indicated in the corresponding fields on the Range tab of the Sample Editor Inspector.
  You can fine-tune the selection by changing these values. Note that the values are relative to the start of the clip, rather than to the project timeline.
Using the Select menu

On the Select menu on the Range tab and on the Select submenu of the Edit menu you find the following options:

**All**
Selects the whole clip.

**None**
Selects no audio (the selection length is set to “0”).

**In Loop**
Selects all audio between the left and right locator.

**Select Event**
Selects only the audio that is included in the edited event. This is grayed out if you have opened the Sample Editor from the Pool (in which case the whole clip is opened for editing, not an event).

Cubase Pro only: If the VariAudio tab is open and your audio file is split into separate segments, all segments that start or end within the event boundaries are selected.

**Locators to Selection (Range tab only)**
Sets the locators to encompass the current selection. This is available if you have selected one or several events or made a selection range.

**Locate Selection (Range tab only)**
Moves the project cursor to the beginning or end of the current selection. For this to be available, you must have selected one or more events or parts, or made a selection range.

**Loop Selection (Range tab only)**
This activates playback from the start of the current selection and keeps starting over again when reaching the selection end.

**From Start to Cursor (Edit menu only)**
Selects all audio between the clip start and the project cursor.

**From Cursor to End (Edit menu only)**
Selects all audio between the project cursor and the end of the clip. For this to work, the project cursor must be within the clip boundaries.

**Equal Pitch - all Octaves/same Octave (Cubase Pro only)**
This function requires that the audio event has been analyzed using the VariAudio features and that one or several notes are selected. These options select all notes of this event that have the same pitch as the currently selected note(s) (in any octave or in the current octave).
**Left Selection Side to Cursor (Edit menu only)**

Moves the left side of the current selection range to the project cursor position. For this to work, the cursor must be within the clip boundaries. This function is not available for VariAudio segments (Cubase Pro only).

**Right Selection Side to Cursor (Edit menu only)**

Moves the right side of the current selection range to the project cursor position (or the end of the clip, if the cursor is to the right of the clip). This function is not available for VariAudio segments (Cubase Pro only).

**NOTE**

Several of these options are also available on the Sample Editor context menu.

**RELATED LINKS**

Segments mode on page 472

---

**Editing selection ranges**

Selections in the Sample Editor can be processed in several ways.

If you attempt to edit an event that is a shared copy (i.e. the event refers to a clip that is used by other events in the project), you are asked whether you want to create a new version of the clip.

- Select “New Version” if you want the editing to affect the selected event only.
- Select “Continue” if you want the editing to affect all shared copies.

**NOTE**

If you activate the “Please, don’t ask again” option in the dialog, any further editing will conform to the selected method (“Continue” or “New Version”). You can change this setting at any time with the “On Processing Shared Clips” pop-up menu in the Preferences dialog (Editing–Audio page).

- Any changes to the clip are shown in the Offline Process History, making it possible to undo them later.

**Cut, Copy, and Paste**

The Cut, Copy, and Paste commands (on the Edit menu, on the Process tab of the Sample Editor Inspector, or on the main Edit menu) work according to the following rules:

- Selecting Copy copies the selection to the clipboard.
- Selecting Cut removes the selection from the clip and moves it to the clipboard.
  The section to the right of the selection is moved to the left to fill the gap.
- Selecting Paste copies the data from the clipboard into the clip. If there is a selection in the editor, this is replaced by the pasted data. If there is no selection, the pasted data is inserted starting at the project cursor. The section to the right of the line is moved to make room for the pasted material.

**Delete**

Selecting Delete (on the Edit menu, on the Process tab of the Sample Editor Inspector, or on the main Edit menu) removes the selection from the clip. The section to the right of the selection is moved to the left to fill the gap.

**Insert Silence**

Selecting “Insert Silence” (on the Edit menu, on the Process tab of the Sample Editor Inspector, or on the Range submenu of the main Edit menu) inserts a silent section with the same length as the current selection, at the selection start.

- The selection is not replaced, but moved to the right to make room.
  - If you want to replace the selection, use the “Silence” function instead.

**Processing**

The Processing features (on the Select Process menu, on the Process tab of the Sample Editor Inspector, or on the Process submenu of the Audio menu) can be applied to selections in the Sample Editor, as well as the effects (on the Select Plug-in menu on the Process tab of the Sample Editor Inspector or on the Plug-ins submenu of the Audio menu).

**RELATED LINKS**

- The Offline Process History dialog on page 418
- Silence on page 413
- Audio processing and functions on page 401

**Creating a new event from the selection using drag & drop**

You can create a new event that plays only the selected range.

**PROCEDURE**

1. Make a selection range.
2. Drag the selection range to an audio track in the Project window.
Creating a new clip or audio file from the selection

You can extract a selection from an event and either create a new clip or a new audio file.

**PROCEDURE**

1. Make a selection range.
2. Open the context menu and select “Bounce Selection” from the Audio submenu.

**RESULT**

A new clip is created and added to the Pool, and another Sample Editor window opens with the new clip. This clip refers to the same audio file as the original clip, but contains the audio corresponding to the selection range only.

Handling Several Audio Events (Cubase Pro only)

When you open the Sample Editor with several events selected, the editor contains a few functions that facilitates working with multiple audio events. These functions are designed to display and edit the VariAudio segments of several audio events in context.

- The “Currently Edited Audio Event” pop-up menu on the toolbar lists all audio events that are opened in the Sample Editor. Here, you can select which audio event is active for editing.

- The “Edit Active Audio Event Only” button on the toolbar lets you restrict editing operations to the active audio event.

**RELATED LINKS**

VariAudio (Cubase Pro only) on page 468

Working with regions

Regions are sections within a clip. One of the main uses for regions is Cycle recording, in which the different “takes” are stored as regions.

You can also use this feature for marking important sections in the audio clip. Regions can be dragged into the Project window from the Sample Editor or the Pool to create new audio events.

**RELATED LINKS**

Cycle Recording on page 214
Creating and removing regions

**PROCEDURE**

1. Select the range that you want to convert into a region.
2. Click the “Set up Window Layout” button and activate the Regions option. The regions list is displayed on the right.

   ![Regions list](image)

3. Click the Add Region button above the regions list (or select “Event or Range as Region” from the Advanced submenu of the Audio menu). A region is created, corresponding to the selected range.
4. To name the region, double-click on it in the list and enter a new name. Using this procedure, regions can be renamed at any time.

**RESULT**

When you click on a region in the regions list, it is instantly displayed in the Sample Editor.

To remove a region from a clip, select it in the list and click the Remove Region button above the list.

Creating regions from hitpoints

If your audio event contains calculated hitpoints, you can choose to automatically create regions from hitpoints. This can be useful to isolate recorded sounds.

**RELATED LINKS**

- Working with hitpoints and slices on page 459

Editing regions

The region selected in the list is displayed in gray in the waveform display and the overview line.
There are two ways to edit the start and end positions of a region:

- Click and drag the region start and end handles in the waveform display (with any tool).
  
  When you move the pointer over the handles, it automatically changes to indicate that you can drag the handles.

- Edit the Start and End positions in the corresponding fields in the regions list.
  
  The positions are shown in the display format selected for the ruler and info line, but are relative to the start of the audio clip rather than the project timeline.

### Auditioning regions

You can listen to a region by selecting it in the list and clicking the Play Region button above the list. The region will play back once or repeatedly, depending on whether the Loop icon on the toolbar is activated or not.

You can also listen to a region by selecting it in the list and clicking the Audition icon on the toolbar. This way you can preview separate regions by clicking on them in the list or by selecting them with the up/down arrow keys on your computer keyboard.

### Making selections from regions

If you select a region in the list and click the Select Region button above, the corresponding section of the audio clip is selected (as if you had selected it with the Range Selection tool) and zoomed. This is useful if you want to apply processing to the region only.

**NOTE**

You can also double-click a region in the Pool to have its audio clip opened in the Sample Editor with the area of the region automatically selected.

### Creating audio events from regions

You can create new audio events from regions using drag & drop.

**PROCEDURE**

1. In the list, click on the region and keep the mouse button pressed.

2. Drag the region to the desired position in the project and release the mouse button.

**RESULT**

A new event is created.
You can also use the “Events from Regions” function from the Advanced submenu of the Audio menu.

RELATED LINKS
Region Operations on page 190

Exporting regions as audio files

If you create a region in the Sample Editor, the region can be exported to disk as a new audio file. This is done from the Pool.

RELATED LINKS
Exporting Regions as Audio Files on page 516

Selecting an algorithm for realtime playback

On the Algorithm pop-up menu on the toolbar you can select the algorithm preset to be applied during realtime playback.

This setting affects warp changes in Musical Mode, FreeWarp, and Swing. Cubase Pro only: For the VariAudio warping and pitching features, the “Standard – Solo” preset must be used and is applied automatically.

The pop-up menu contains various options that govern the audio quality of the realtime time stretching. There are presets for common uses and a Custom option that allows you to manually set warp parameters. The presets are sorted into categories, according to the technology used (élastique or Standard).

RELATED LINKS
About time stretch and pitch shift algorithms on page 428

Musical Mode

You can use the Musical Mode to tempo-match audio loops to the project tempo. Musical Mode allows you to lock audio clips to the project tempo by using realtime time stretching. This is very useful if you want to use audio in your project without worrying too much about timing.

If you want to use Musical Mode, verify that the length in bars corresponds to the audio file you imported. If necessary, listen to your audio and enter the correct length in bars and beats.
When Musical Mode is activated, audio events will adapt to any tempo changes in Cubase, just like MIDI events.

You can activate Musical Mode on the AudioWarp tab, the Definition tab, and the toolbar.

**NOTE**

It is also possible to activate/deactivate Musical Mode from within the Pool by clicking the corresponding checkbox in the Musical Mode column.

**IMPORTANT**

Cubase supports ACID® loops. These loops are standard audio files but with embedded tempo/length information. When ACID® files are imported into Cubase, Musical Mode is automatically activated and the loops will adapt to the project tempo.

---

### Warping audio

Warping is a term used to describe the realtime time stretching of a selected section of audio. Warping is generally used to correct the tempo or timing of audio.

### Adjusting loops to the project tempo using Musical Mode

Audio loops are normally short audio files containing a defined number of bars with straight beats. These loops can be adjusted to the project tempo by using the Musical Mode function.

**PROCEDURE**

1. Import an audio loop into a project and double-click it to open the Sample Editor.

   If you open the Definition tab and take a look at the rulers, you will see that the project tempo grid (upper ruler) and the grid of your audio (lower ruler) do not match.

2. From the Algorithm pop-up menu on the toolbar, select the algorithm preset to be applied during realtime playback.

3. Listen to the loop and, if necessary, correct the Bars and Beats values on the toolbar.
4. Activate the Musical Mode button.
   Your loop is warped and stretched automatically to adapt it to the project tempo.
   The rulers reflect the change.

RESULT

In the Project window, the audio event is now shown with a note symbol and a warp symbol in the upper right corner to indicate that time stretching has been applied.

RELATED LINKS

About time stretch and pitch shift algorithms on page 428

Adjusting complex audio material to the project tempo using Musical Mode

If you want to use an audio file with unknown tempo or if the beat of your audio file is not straight, you have to change the “definition” of this audio file first. This is done with the Auto Adjust function on the Definition tab of the Sample Editor Inspector.

The Auto Adjust function extracts a “local” definition grid that you can then match with the project tempo using Musical Mode.

IMPORTANT

The Auto Adjust function needs to be applied on a section containing complete bars. Therefore you first need to define a range in your audio material that starts and ends at a bar line.

To extract the definition from an audio file, proceed as follows:

PROCEDURE

1. Open an audio clip or audio event in the Sample Editor.
2. Open the Definition tab and select a suitable value from the Grid pop-up menu.
   This determines the grid resolution for your audio.
3. Select a range that is covering one or several bars.
   This selection should cover the section that you want to use in your project. The definition grid will be calculated for this section only.
4. Click the Auto Adjust button. The snap point is moved to the start of the selected range, which is now also the start position of the local definition grid. The lower ruler changes to reflect your edits. The transients, i.e. the bars and beats positions, are marked with vertical lines.

5. Activate the Musical Mode button.

RESULT
Your clip is warped and stretched automatically to adapt it to the project tempo. The rulers reflect the change.

NOTE
You can also apply Auto Adjust directly on an audio event or a clip. If no range selection is defined, the grid is calculated for the audio event. If no range selection and no audio event are defined, the grid is calculated for the entire clip. In both cases you need to make sure that the event or clip starts and ends on a bar line.

Correcting the local definition grid

In some situations, you might not be able to get satisfying results with the “Auto Adjust” function. In this case you can manually modify the grid and tempo of your audio file.

PROCEDURE
2. If the grid start does not correspond with the first main beat, move the mouse pointer to the beginning of the audio clip until the tooltip “Set Grid Start” is displayed.
   The mouse pointer turns into a double arrow.
3. Click and drag the mouse to the right until you reach the first downbeat. Release the mouse button to move the grid start (and snap point).
   The lower ruler (for the local grid) changes to reflect your edits.
4. Audition the file to determine where the second bar in the sample begins.
5. In the upper part of the waveform, move the mouse pointer to the vertical line nearest to the second bar so that the tooltip “Stretch Grid” and a blue vertical line are shown.
“Stretch Grid” allows you to correct the tempo by stretching or compressing the whole grid.

6. Click and drag the blue vertical line to the left or right to the position of the first downbeat in the second bar and release the mouse button.
The beginning of the next bar is set, and all bar positions in the grid are adjusted so that the bars have the same length.

7. Check the positions of the following bars. If you find an incorrect bar position, move the mouse pointer over the grid lines in the lower part of the waveform so that the tooltip “Set Bar Position (Move Following Bars)” and a green vertical line are shown.
“Set Bar Position” allows you to adjust a single bar line, thereby changing the tempo of one bar only. The bars to the right are moved accordingly, but the area to the left remains unaffected.

8. Click and drag the green vertical line to the left or right to the position of the first downbeat of the following bar and release the mouse button.
Repeat the last two steps for all bar lines that need to be corrected.

9. Now have a look at the single beats in between the bars. If you find an incorrect beat position, move the mouse pointer over the corresponding grid line so that the tooltip “Set Beat Position” and a blue vertical line are shown.

10. Click and drag the grid line to align the single beat position with the waveform, and release the mouse button.
11. To remove a misplaced beat edit, press any modifier key so that the Erase tool is shown and click on the adjusted grid line.

NOTE
If you want to hear your changes immediately, you can activate Musical Mode for this procedure. The warping will be recalculated after each edit.

Applying swing

If you find that your audio sounds too straight, for example, after having used the “Auto Adjust” function, you can add swing.

PROCEDURE
1. Activate Musical Mode.
2. On the Algorithm pop-up menu on the toolbar, select the algorithm preset that fits the audio material best.
3. On the AudioWarp tab, select a suitable grid resolution from the Resolution pop-up menu.
   This defines the positions that the swing is applied to. For example, if you select 1/2, the swing is applied in steps of half notes.
4. Move the Swing fader to the right to offset every second position in the grid.

RESULT
This creates a swing or shuffle feel.

Depending on how far you move the fader to the right and what grid resolution you chose, this function offers everything from half-note swing to 64th-note swing.

RELATED LINKS
   About time stretch and pitch shift algorithms on page 428
**Free Warp**

The Free Warp tool allows you to change the timing of individual positions in the audio material. The Free Warp tool snaps to hitpoint positions and/or warp markers.

The Free Warp tool creates warp markers. Warp markers are a kind of marker or anchor that can be attached to musically relevant time positions in an audio event, for example, the first beat of every bar. Warp markers can be dragged to the corresponding time positions in the project, and the audio will be stretched accordingly.

| ![Image of Free Warp tool](image) |

**IMPORTANT**

When you activate or deactivate Musical Mode or select another Resolution value, all your warp modifications are lost.

Warp markers are typically used for creative tempo editing or further tweaking after having activated Musical Mode.

**NOTE**

Warp markers can also be created from hitpoints.

**RELATED LINKS**

Create Warp Markers on page 467

**Correcting the Timing**

You can correct the timing using the Free Warp tool.

**PROCEDURE**

1. Open the audio file that you want to process in the Sample Editor.
2. Activate the “Snap to Zero Crossing” button on the Sample Editor toolbar. When this button is activated, warp markers will snap to zero crossings.
3. If you want to use the Free Warp tool for selective timing corrections, you can define the local definition grid and activate Musical Mode. The next step is to find out where a warp marker needs to be added.
4. On the Transport panel, activate the Click button, and play back your audio clip to determine positions where the beat is not on time with the click. If you find it difficult to pinpoint an exact position in the audio event, you can use the Scrub tool and/or zoom in the view.

5. On the AudioWarp tab, select the Free Warp tool, place the pointer at the position of the beat that you want to adjust, click, and hold. The mouse pointer changes to a clock with arrows on either side and a vertical line in the middle. A new warp marker is inserted.

6. With the mouse button still pressed, drag the warp marker to the new position and release the mouse button. The beat should now be perfectly aligned with the corresponding position in the project. You can also first add warp markers at the relevant musical positions and change their positions later.

**RESULT**

Next to the warp marker handle in the ruler, a number is shown. This number indicates the warp factor, that is the amount of stretch. Warp factors higher than 1.0 indicate that the audio region preceding the warp marker is expanded and will play back slower. Warp factors lower than 1.0 indicate that the audio region preceding the warp marker is compressed and will play back faster.

**RELATED LINKS**

- Editing warp markers on page 458

**Editing warp markers**

- To stretch or compress the audio using a warp marker, select the Free Warp tool and position the pointer on the warp line in the waveform, click and drag.

- To change the position of a warp marker in the audio, click and drag the warp marker handle in the ruler.

  This will change the warping.

- To disable all warp modifications, click the “Disable Warp Changes” button on the AudioWarp tab.

- To delete a warp marker, hold down [Alt]/[Option] so that the pointer becomes an eraser, and click on the warp marker. To delete several warp markers, hold down [Alt]/[Option] while drawing a selection rectangle.
Resetting warp modifications

You can reset your Free Warp edits.

PROCEDURE

- Click Reset on the AudioWarp tab.
  This also resets Disable Warp Changes on the same tab.

NOTE

If Musical Mode is activated, only Free Warp edits are reset.

Working with hitpoints and slices

Cubase can detect hitpoints, musically relevant positions, by analyzing onsets and melodic changes. At these positions a type of marker is added. Hitpoints allow you to create slices, where each slice ideally represents each individual sound or “beat”. Drum or other rhythmic recordings or loops work best with this feature.

Purpose and preparation

Hitpoints are useful to slice up audio to make it fit the project tempo or to create a situation that allows the song tempo to be changed while retaining the timing of a rhythmic audio loop.

When you have successfully detected the hitpoints for an audio file, you can do a number of useful things:

- Change the tempo of the audio material without affecting the pitch and audio quality.
- Extract the timing (a groove map) from a drum loop. The groove map can then be used to quantize other events.
- Use slices to replace individual sounds in a drum loop.
- Extract sounds from loops.

You can further edit these slices in the Audio Part Editor. You can, for example:

- Remove or mute slices.
- Change the loop by reordering, replacing, or quantizing slices.
- Apply processing or effects to individual slices.
- Create new files from individual slices using the “Bounce Selection” function on the Audio menu.
- Transpose in realtime and stretch slices.
- Edit slice envelopes.
Hitpoints can also be used to quantize audio material without creating slices.

**RELATED LINKS**
- Creating Groove Quantize Presets on page 246
- Quantizing MIDI and Audio on page 234

**Which audio files can be used?**

Here are some guidelines as to what type of audio files are suited for slicing using hitpoints:
- Each individual sound should have a noticeable attack. Slow attacks, legato playing, etc. may not produce the expected result.
- Poorly recorded audio might be difficult to slice correctly. In these cases, try to normalize the files or to remove DC Offset.
- The recorded audio should contain as little crosstalk signals as possible. Crosstalk refers to the “bleeding” of a sound into a microphone placed before another instrument during recording.
- There may be problems with sounds drowned in smearing effects, like short delays.

**Adjusting the tempo: warping vs. hitpoints and slices**

Both the warping features and the hitpoint detection can be used to alter the tempo and timing of audio material.

Warping is very useful for continuous audio material without noticeable gaps between the individual sounds, for example, piano or vocal recordings.

Using hitpoints has the advantage that the quality of the sound is not affected and no artifacts are being introduced. The audio is cut up into slices that are then moved on the timeline, making this method especially suited for drums, which contain silence between the individual sounds. Furthermore, hitpoint detection is useful for multi-track drum recordings, because the phase alignment is kept stable. Using hitpoints and slices for continuous audio material is not recommended, as it is difficult to fill the gaps caused by moving the slices.

**Automatic Hitpoint Detection**

When you add an audio file to your project by recording or by importing, Cubase automatically detects hitpoints. This allows you to navigate to hitpoints of an audio file from within the **Project** window.

For long audio files, hitpoint detection may take a while. All operations that are based on hitpoints are disabled during the calculation.
To disable automatic hitpoint detection, select File > Preferences > Editing > Audio and deactivate Enable Automatic Hitpoint Detection.

In the Project window, hitpoints are shown for the selected event, provided that the zoom factor is high enough.

To hide them, select File > Preferences > Event Display > Audio and disable Show Hitpoints on Selected Events.

**Filtering hitpoints**

You can filter hitpoints in the Hitpoints Inspector tab of the Sample Editor.

You can use the following parameters to filter hitpoints:

**Threshold**

This filters hitpoints by their peaks. This allows you to discard hitpoints of quieter crosstalk signals, for example.

**Minimum Length**

This filters hitpoints by the distance between two hitpoints. This allows you to avoid creating slices that are too short.

**Beats**

This allows you to filter hitpoints by their musical position. This allows you to discard hitpoints that do not fit within a certain range of a defined beat value.
Using Hitpoints to Locate Audio Positions in the Project Window

You can navigate through the hitpoints of an audio event in the Project window.

**PREREQUISITE**

Enable Automatic Hitpoint Detection is activated (File > Preferences > Editing > Audio).

**PROCEDURE**

1. Select the audio track that contains the audio event for which you want to locate hitpoints.
2. Press [Alt]/[Option]-[N] to navigate to the next hitpoint, or [Alt]/[Option]-[B] to navigate to the previous hitpoint.

**RESULT**

The project cursor jumps to the respective hitpoint.

**Auditioning and hitpoints**

- You can audition the hitpoint slices, that is the area between two hitpoints, by pointing and clicking in any slice area.
  
  The pointer changes to a speaker icon and the corresponding slice is played back from the beginning to the end.

**Navigating between hitpoints**

- You can navigate between the slices using the arrow keys or by pressing the [Tab] key.

- You can select the next or previous hitpoint marker using the “Locate Next/Previous Hitpoint” commands.
  
  The default key commands for this are [Alt]/[Option]-[N] and [Alt]/[Option]-[B].

**Editing hitpoints**

You can change the state of a hitpoint, insert new hitpoints manually, and move existing hitpoints.

Hitpoints can have three different states: enabled, locked, and disabled. “Enabled” is the normal state a hitpoint has immediately after the detection. Hitpoints can be “disabled” so that they are still visible as gray triangles on the timeline, but will not be taken into account for further operations. “Locking” hitpoints is an easy way to make sure that hitpoints are not accidentally filtered out. Locked hitpoints are not affected by the Threshold slider and Beats pop-up menu.
Disabling and locking hitpoints

After applying the different hitpoint filters, you may find that you want to keep individual hitpoints that were filtered out or disable hitpoints that you do not need. Furthermore, you may want to lock certain hitpoints.

- To lock a hitpoint, move the mouse pointer over the gray triangle on the timeline so that the tooltip “Lock Hitpoint” is shown. Click on the triangle. This way, enabled and disabled hitpoints can be locked.

- To lock a disabled hitpoint, you can also press [Alt]/[Option] and move the mouse over the waveform. At positions where a disabled hitpoint can be locked, a gray hitpoint line and the tooltip “Lock Hitpoint” are shown. Click to lock the hitpoint.

- To lock multiple hitpoints, press [Shift]-[Alt]/[Option] so that the tooltip “Lock multiple hitpoints” is shown and drag a rectangle over the hitpoints. All enabled and disabled hitpoints within the area defined by the rectangle become locked.

- To disable hitpoints, press [Shift] so that the tooltip “Disable Hitpoints” is shown and click on the line of a single hitpoint or drag a rectangle over all the hitpoints that you want to disable. This way, enabled and locked hitpoints can be disabled.

- To disable a locked hitpoint, you can also point the mouse at the blue hitpoint triangle on the timeline so that the tooltip “Disable Hitpoint” is shown. Click on the triangle.
Reseting hitpoints

Sometimes it can be useful to reset hitpoints to their original state, e.g. because you still want them to be affected by the Threshold slider.

**PROCEDURE**

- To reset hitpoints to their original state, press [Ctrl]/[Command]-[Alt]/[Option] so that the tooltip “Enable/Unlock Hitpoints” is shown and drag a rectangle over the hitpoints.

**RESULT**

All disabled and locked hitpoints within the area defined by the rectangle are reset. Note that some of the hitpoints may still appear as disabled due to the Threshold slider and Beats pop-up menu settings.

Inserting hitpoints

If you get too few hitpoints using the filter options, you can insert hitpoints manually.

**PROCEDURE**

- To insert a new hitpoint, press [Alt]/[Option] and click at the position where you want to enter the new hitpoint (i.e. at the start of the sound).
  Manually added hitpoints are locked by default.

Moving hitpoints

If a hitpoint was either placed too far away from the start of the sound or too far into the sound, you can move it.

**PROCEDURE**

- To move a hitpoint, press [Alt]/[Option] and point the mouse at the vertical line of the hitpoint.

**RESULT**

The mouse pointer changes to a double arrow and the tooltip “Move Hitpoint” is shown. You can now drag the hitpoint to its new position.

**NOTE**

Moved hitpoints are locked by default.
Slicing audio

Once you have set up the hitpoints as needed, you can slice the audio by clicking the Create Slices button on the Hitpoints tab. Alternatively, you can select the “Create Audio Slices from Hitpoints” command from the Hitpoints submenu of the Audio menu.

The following happens:

- The Sample Editor closes.
- The audio event is “sliced” so that the sections between the hitpoints become separate events, all referring to the same original file.
- The audio event is replaced by an audio part, containing the slices (double-click the part to view the slices in the Audio Part Editor).

**IMPORTANT**

When you create slices, all events referring to the edited clip are also replaced.

- The audio is automatically adapted to the project tempo, taking the specified tempo or bars and beats values into account: if the event was one bar long, the part is resized to fit exactly one bar in the Cubase tempo, and the slices are moved accordingly, keeping their relative positions within the part.
- In the Pool, the sliced clip is shown with a different icon. Dragging the sliced clip from the Pool to an audio track creates an audio part with the slices adapted to the project tempo, just as above.

The audio should now play back seamlessly at the tempo set in the project!

Slices and the project tempo

The musical time base setting and the project tempo affect how the sliced audio is played back.

Make sure that the “Toggle Time Base” button in the track list or Inspector is set to a musical time base (the button shows a note symbol). This way the loop will follow any further tempo changes.

If the project tempo is slower than the tempo of the original audio event, there may be audible gaps between the slice events in the part. To remedy this, you can apply the “Close Gaps (Timestretch)” function from the Advanced submenu of the Audio menu on the parts containing the slice events. Time stretch is applied to each slice to close the gaps. Depending on the length of the part and the algorithm set in the Preferences dialog (Editing–Audio page), this can take a while.

**NOTE**

If you open the Pool, you will see that new clips were created, one for each slice.

If you decide to change the tempo again after using the “Close Gaps (Timestretch)” function, undo the Close Gaps operation or start over again, using the original, unstretched file.
Also consider activating auto fades for the corresponding audio track – fade-outs set to about 10 ms will help eliminate any clicks between the slices when you play back the part.

If the project tempo is higher than the tempo of the original audio event, the slice events are overlapping. Activate auto crossfades for the track to smooth out the sound. Furthermore, you can select the overlapping events inside the part and apply the “Delete Overlaps” function from the Advanced submenu of the Audio menu.

The slices in the Audio Part Editor. Here, the project tempo was higher than the clip’s original tempo – the slice events overlap.

**RELATED LINKS**
- Defining the Track Time Base on page 149
- Making global Auto Fade settings on page 256
- Making Auto Fade settings for individual tracks on page 257

### Slicing multi-track drum recordings

If you have a multi-track drum recording that you want to quantize using hitpoints, you can put all the tracks belonging to the recording in an edit group, calculate the hitpoints for the relevant tracks (e.g. Kick, Snare, and Hi-hats), and use the “Divide Audio Events at Hitpoints” command on the Audio menu (Hitpoints submenu) to slice all tracks of the recording at once.

**RELATED LINKS**
- Quantizing Multiple Audio Tracks (Cubase Pro only) on page 236

### Other hitpoint functions

On the Hitpoints tab of the Sample Editor Inspector, you will also find the following functions. Many of these functions are also available on the Hitpoints submenu of the Audio menu. If selected on the Audio menu, they can be applied on several events and even range selections at the same time.
Create Groove

You can generate a groove quantize map based on hitpoints that you have created.

RELATED LINKS
Creating Groove Quantize Presets on page 246

Create Markers

If an audio event contains calculated hitpoints, you can click the Create Markers button on the Hitpoints tab to add a marker for each hitpoint. If your project has no marker track, it will be added and activated automatically. Markers can be useful to snap to hitpoints, e.g. for locating hitpoints and for using the Time Warp tool.

RELATED LINKS
Markers on page 281
The Time Warp tool (Cubase Pro only) on page 913

Create Regions

If your audio event contains calculated hitpoints, you can click the Create Regions button on the Hitpoints tab to automatically create regions from hitpoints. This can be useful to isolate recorded sounds.

Create Events

If your audio event contains calculated hitpoints, you can click the Create Events button on the Hitpoints tab to automatically create separate events based on the hitpoints.

Create Warp Markers

If you want to quantize audio based on hitpoints, you can use this option to create warp markers from the calculated hitpoints. This option is identical with using the “Create Warp Markers from Hitpoints” option on the Realtime Processing submenu of the Audio menu.

Create MIDI Notes

You can export your hitpoints to a MIDI part containing a MIDI note for each hitpoint. For example, you can use this function to double, replace, or enrich drum hits by triggering sounds of a VST instrument at the positions of the hitpoints.

To convert the hitpoints into MIDI notes, click the “Create MIDI Notes” button. Make the desired settings in the Convert Hitpoints to MIDI Notes dialog and click OK.
Sample Editor
VariAudio (Cubase Pro only)

The following options are available:

**Velocity Mode/Velocity**
- Dynamic Velocity Value – The velocity values of the created MIDI notes vary, according to the peak levels of the corresponding hitpoints.
- Fixed Velocity Value – The created MIDI notes get the same velocity value. You can set this value using the Velocity field.

**Pitch/Length**
- Hitpoints do not contain any information about pitch or duration. Therefore, all created MIDI notes get the same pitch and note length. Use these fields to specify the desired values.

**Destination**
- First Selected Track – The MIDI part is placed on the first selected MIDI or instrument track. Note that any MIDI parts from previous conversions that are on this track will be deleted.
- New MIDI Track – A new MIDI track is created for the MIDI part.
- Project Clipboard – The MIDI part is copied into the clipboard so that you can insert it at the desired position on a MIDI or instrument track.

---

**VariAudio (Cubase Pro only)**

With the AudioWarp features, editing audio in the time domain has become significantly easier. However, editing pitch was limited to having just one single numeric “transpose” value per event or part.

VariAudio offers completely integrated vocal editing and pitch alteration of individual notes in monophonic vocal recordings and can solve intonation and timing problems with only a few mouse clicks. It was developed and optimized specifically to be used with monophonic vocal recordings. Though the detection and stretching of notes of other monophonic audio recordings, such as those of a saxophone, may work well, the quality of the end result depends greatly on the generic condition and structure of the recording’s texture.

And how does it work? First, the vocal line is analyzed and split into segments shown as graphic representation of the notes sung. After the detection process is complete, the recognized notes can be modified entirely “non-destructively” so that any modifications to the audio material can be undone.
VariAudio allows you to change your audio on the vertical axis and on the horizontal axis.

If you load projects with VariAudio files in Cubase Artist, the original files will be played back and your VariAudio modifications will be ignored. If you want to hear your modifications in Cubase Artist, you will have to bounce the audio files that have been edited with the Cubase Pro VariAudio features.

**RELATED LINKS**
- Changing the pitch on page 476
- Warping segments on page 482

**Understanding the waveform display in VariAudio**

When you open monophonic vocal recordings in the Sample Editor and activate the Segments or the Pitch & Warp tool on the VariAudio tab, your audio is analyzed and segmented to display the tonal portions, i.e. the notes sung or played. This process is called segmentation. The segmentation allows you to easily associate the audio with your lyrics and to introduce pitch and timing changes.

In between the different segments you may find gaps where non-tonal portions have been detected, e.g. caused by breath sounds.

At the beginning of the waveform, you can see a gap where no segment is shown.

1) Gap
2) Audio waveform
3) Segments
NOTE
The audio waveform displayed on the VariAudio tab is always shown as mono, even if you have opened a stereo or multi-channel file.

The piano keyboard to the left of the waveform indicates the pitch positions. By moving a segment vertically, you can change its average pitch.

Note pitches represent the perceived fundamental frequency of a sound. The note A4 is perceived to be of the same pitch as a sine wave of 440 Hz. The notation of pitches is a logarithmic frequency scale. The table below shows the relation between pitch (note name) and frequency in Hz:

<table>
<thead>
<tr>
<th></th>
<th>C4</th>
<th>C#4/Db4</th>
<th>D4</th>
<th>D#4/Eb4</th>
<th>E4</th>
<th>F4</th>
<th>F#4/Gb4</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>261.63</td>
<td>277.18</td>
<td>293.66</td>
<td>311.13</td>
<td>329.63</td>
<td>349.23</td>
<td>369.99</td>
</tr>
<tr>
<td>G4</td>
<td>392.00</td>
<td>415.30</td>
<td>440.00</td>
<td>466.16</td>
<td>493.88</td>
<td>523.25</td>
<td></td>
</tr>
</tbody>
</table>

The average pitch of a segment is calculated from its micro-pitch curve. Micro-pitch curves represent the progression of the pitch for the tonal portion of the audio.

The horizontal position of a segment indicates the time position and the length.

You can navigate through the segments by using the left/right arrow keys on your computer keyboard.

You can zoom in on the segments that you want to edit by holding down [Alt]/[Option] while drawing a selection rectangle. To zoom out, hold down [Alt]/[Option] and click in an empty area of the waveform. If you hold down [Alt]/[Option] and double click in an empty area, the display will be zoomed out to show all segments.
Applying editing, offline processes, and VariAudio

The following offline processes and edits that affect the length of the audio file may lead to the reanalysis of the audio material:

- Options on the Select Process menu, on the Process tab of the Sample Editor Inspector, or in the Process submenu of the Audio menu that can be applied to selections.
- Effect processing using the options on the Select Plug-in menu on the Process tab of the Sample Editor Inspector or in the Plug-ins submenu of the Audio menu.
- Cut, paste, and delete, or drawing notes.

IMPORTANT

Because of the reanalysis any existing VariAudio data becomes invalid. Therefore, you should always apply offline processing or edits before using the VariAudio features.

If you apply editing that affects the audio itself (like cutting portions, etc.) to a file containing VariAudio data, the following warning message is displayed:

- If you click “Proceed”, your edits are applied and you will lose your VariAudio data.
  Click “Cancel” to return to your audio file without applying any changes.

If you apply offline processing to a file containing VariAudio data, the following warning message is displayed:

- If you click “Proceed”, your edits are applied, and you will lose your VariAudio data.
  If you click “Proceed and Keep”, your edits are applied. Any VariAudio data in the audio file is kept.
  Offline processes that may not affect existing VariAudio data are Envelope, Fade In/Out, Normalize, or Silence.
Sample Editor
VariAudio (Cubase Pro only)

- If you activate the “Please don’t display this warning again” option in one of these warning dialogs before proceeding, Cubase will always proceed with the selected option.
  
You can reactivate the warning messages by deactivating the “Inhibit warning when changing the Sample Data” or “Inhibit warning when applying Offline Processes” options in the Preferences dialog (VariAudio page).

RELATED LINKS
Audio processing and functions on page 401
Editing selection ranges on page 446
Drawing in the Sample Editor on page 444

Segments mode

If you activate Segments mode on the VariAudio tab, your audio file is analyzed and split into separate segments.

IMPORTANT

Due to the data gained during this process, the audio and thus the size of your project can increase. Furthermore, the analysis of long audio files might take some time.

When you want to change the pitch of audio that includes non-tonal portions, e.g. consonants or effect sounds like reverberation, you may have to edit the segmentation in order to include the non-tonal portions in the segments. Otherwise, pitch modifications will only affect the tonal portions.

Editing the segmentation includes changing the start and end position of a segment, cutting or gluing segments, and moving or deleting them. Just select the section of the file that you want to change, activate Segments mode, and edit the segmentation for the desired section. If you are not satisfied with your changes, you can go back to the original segmentation.

IMPORTANT

Editing the segmentation always leads to a recalculation of the segment’s pitch. Therefore, it is recommended that you edit the segmentation before changing the pitch.

NOTE

In Segments mode, the segments are shown with a hatched background. You can switch between “Pitch & Warp” and “Segments” mode by pressing the [Tab] key.

The following paragraphs list the corrections that can be performed when Segments mode is activated.

RELATED LINKS
Reset on page 485
Pitch & Warp tool on page 476
Changing the note start or end point

If you find that a note starts or ends too early or too late, e.g. when the reverb of a note or a consonant is not included in the segment, proceed as follows:

**PROCEDURE**

1. On the VariAudio tab activate Segments mode.
2. To change the length of a segment, move the mouse pointer over the start/end of the segment.
   The mouse pointer becomes a double arrow.
3. Click and drag the segment start/end to the left or right.

**RESULT**

The segment length changes accordingly. As the average pitch is recalculated, the segment may jump upwards or downwards. Snap will not be taken into account.

**IMPORTANT**

If the resulting segment pitch cannot be calculated because of an increase in non-tonal data, the segment will be deleted.

**NOTE**

You can drag the segment start/end only until it reaches the start/end of the next segment. Segments cannot overlap each other.

Cutting a segment

If you notice that a segment includes more than one note, proceed as follows:

**PROCEDURE**

1. On the VariAudio tab activate Segments mode.
2. Move the mouse pointer over the lower border of the segment that you would like to cut.
   The mouse pointer becomes a scissor.
3. Click at the desired position to cut the segment.
RESULT
The segment is cut accordingly taking Snap into account.

IMPORTANT
When the resulting segment pitch cannot be calculated because of an increase in non-tonal data, the segment will be deleted.

NOTE
There is a minimum size for a segment. Very short segments cannot be cut.

Gluing segments

IMPORTANT
We recommend to correct the segmentation before pitching. If you glue together segments after changing the pitch (this includes manual pitch modifications, Quantize Pitch, and Straighten Pitch), your modifications are reset and the original pitch will be heard.

If you notice that a single note is spread over two segments, proceed as follows:

PROCEDURE
1. On the VariAudio tab activate Segments mode.
2. Hold down [Alt]/[Option] and move the mouse pointer over the segment that you want to glue to the next.
   The mouse pointer becomes a glue tube.
3. Click to glue the active segment to the next segment.

RESULT
If several segments are selected, they are all glued together. Snap is not taken into account.

IMPORTANT
If the resulting segment pitch cannot be calculated because of an increase in non-tonal data, the segment will be deleted.
Moving segments horizontally

After cutting a segment it may be necessary to move segments horizontally, for example, if you notice that a note is at the wrong position.

**PROCEDURE**

1. On the VariAudio tab activate Segments mode.
2. Move the mouse pointer over the upper border of the segment. The mouse pointer becomes a double arrow.
3. Click and drag the whole segment to the left or right.

**RESULT**

The segment is moved accordingly. If several segments are selected, they are all moved together. Snap is not taken into account.

**IMPORTANT**

If the resulting segment pitch cannot be calculated because of an increase in non-tonal data, the segment will be deleted.

**NOTE**

You can only drag the segment start/end until it reaches the start/end of the next segment. Segments cannot overlap each other.

Deleting segments

Sometimes it might be useful to delete segments. This is the case in situations where you want the original audio to be played back, e.g. for non-tonal portions or consonants.

**PROCEDURE**

- You can delete segments by selecting them in Segments mode and pressing [Backspace].

Saving the segmentation

The corrected segmentation is saved with the project, no additional saving is required.
Pitch & Warp tool

If you activate the Pitch & Warp tool on the VariAudio tab, you can change the pitch and the timing of your audio.

**IMPORTANT**

Before changing the pitch or timing of your segments, make sure that the segments you want to change are correct.

You can edit the pitch and timing of audio segments for corrective purposes but also creatively. VariAudio allows you to experiment freely with note pitches in order to change the melody with or without preserving a natural sound. Furthermore, you can change the timing of the audio.

**NOTE**

- In Pitch & Warp mode, the segments are shown with a plain background. You can switch between “Pitch & Warp” and “Segments” mode by pressing the [Tab] key.
- There are some restrictions concerning the highest and lowest possible note pitch. You cannot choose note pitches above C5 and below E0.

**RELATED LINKS**

Segments mode on page 472

Changing the pitch

You can edit the pitch of a segment.

**PROCEDURE**

1. On the VariAudio tab activate the Pitch & Warp tool.
2. Move the mouse pointer over the segment.
   
   The mouse pointer becomes a hand symbol to indicate that you can change the pitch of the segment. If the zoom factor is high enough, a tooltip indicates the found note pitch and the segment’s deviation from this pitch in percent.
There are three different modes that affect the way in which a note will snap to a certain pitch that can be accessed using the following modifier keys:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
<th>Default modifier</th>
</tr>
</thead>
<tbody>
<tr>
<td>Absolute Pitch Snapping</td>
<td>Pitches the segment to the next semitone.</td>
<td>[Ctrl]/[Command]</td>
</tr>
<tr>
<td>Relative Pitch Snapping</td>
<td>Snaps the segment in relation to its current deviation in cents, i.e. if the segment has a pitch of C3 and a deviation of 22%, and you move it up by one semitone, it will be pitched to C#3 while keeping the deviation of 22%.</td>
<td>None</td>
</tr>
<tr>
<td>No Pitch Snapping</td>
<td>Lets you edit the pitch freely.</td>
<td>[Shift]</td>
</tr>
</tbody>
</table>

**NOTE**
The default modifier key can be changed in the Preferences dialog (Editing–Tool Modifier page).

3. Drag the segment up or down to the desired pitch and release the mouse. However, be careful: The more the pitch deviates from the original pitch, the less likely it is that your audio sounds natural.

**RESULT**
If the Solo algorithm preset is not turned on already, a warning appears informing you that Cubase has selected it automatically. The segment is pitched accordingly. While dragging, the original micro-pitch curve of the segment is shown in orange. If several segments are selected, they are all pitched.

You can also use the up/down arrow keys on your computer keyboard to edit the note pitches.

Proceed as follows:

- Use the up/down arrow keys to change the pitch in semitone steps.
- Hold down [Shift] while using the up/down arrow keys to change the pitch in cent steps.

**IMPORTANT**
If you pitch-shift audio events with the Transpose options, the transposition is added to the pitch modifications that you introduced with the Pitch & Warp tool, even if this is not reflected in the segmentation display.

**RELATED LINKS**

*Transpose Functions on page 271*
Quantize Pitch

You can also quantize the audio pitch upwards or downwards to iteratively reduce the deviation from the nearest semitone position.

**PROCEDURE**

1. Select the segments that you want to quantize.
2. Move the Quantize Pitch slider to the right.

**RESULT**

The selected segments are quantized iteratively.

**NOTE**

You can set up a key command for Quantize Pitch in the Sample Editor category of the Key Commands dialog. When using the key command, the segments are directly quantized to the next semitone position.

**RELATED LINKS**

`Key Commands on page 997`

---

**Tilting the micro-pitch curve**

Sometimes changing the pitch of the whole note segment is not enough. In these cases you will have to modify how the pitch changes inside the segment. This is indicated by the micro-pitch curve.

**Changing the Micro-Pitch Curve**

**IMPORTANT**

The micro-pitch curve displays the progression of the pitch for the tonal portion of the segment. For non-tonal portions of the audio, micro-pitch curves cannot be shown.

**PROCEDURE**

1. On the VariAudio tab, activate the Pitch & Warp tool.
2. To change the micro-pitch of a segment, move the mouse pointer over the top left/right corner of the segment.
   The mouse pointer becomes an up/down arrow.
3. Drag upwards/downwards with the mouse to change the micro-pitch curve.

If the pitch falls at the end of the segment…

…activate the Pitch & Warp tool, point at the top right corner and drag upwards.

---

### Changing the Pitch-Curve for Segment Start or End

If you want to change the pitch modulation only for the segment start or end, you can set an “anchor point” to specify which part of the segment is affected.

**PROCEDURE**

1. Move the mouse pointer over the top border of the segment.
   The mouse pointer becomes an I-beam symbol.
2. Click at the position where you want to set an anchor.
   A vertical line appears at the position where you clicked. A segment can only have one anchor.
3. Move the mouse pointer over the top left/right corner of the segment and drag upwards or downwards to tilt the micro-pitch curve.
   The modulation curve is only changed from the segment border to the anchor.

Move the mouse over the top border and click to set an anchor…

…if you only want to compensate for the descending pitch at the end of the segment.

If you press [Alt]/[Option] while dragging up/down, the tilt anchor is used as an axis around which the micro-pitch curve can be rotated.
If you set a tilt anchor…

…and press [Alt]/[Option], the mouse pointer becomes a diagonal arrow…

…to indicate that you can rotate the micro-pitch curve.

4. Repeat the steps above to set anchors and tilt the micro-pitch curve until you are satisfied with the result.

If you want to remove a tilt anchor from a segment, hold down [Alt]/[Option], position the mouse pointer at the top border of the segment until it turns to a glue tube, and click.

The tilt anchor is deleted.

**RELATED LINKS**

*Understanding the waveform display in VariAudio on page 469*

**Straighten Pitch**

If you want to compensate for the rise and fall of notes, i.e. the deviation of the micro-pitch curve from the representative pitch, you can use the Straighten Pitch slider. This correction comes in handy when a note is played flat (pitch rises) or sharp (the pitch falls) at the end.

**PROCEDURE**

1. Select the segments.

2. Move the Straighten Pitch slider to the right.

This micro-pitch looks a bit off. By moving the Straighten Pitch slider to the right…
...the micro-pitch curve is straightened.
The pitch of the selected segments is straightened.

## Muting Segments

You can mute or unmute individual segments using the Pitch & Warp tool.

**PROCEDURE**

1. Move the mouse pointer over the bottom center of a segment. An x symbol appears.
2. Click the x symbol to mute the segment. The segment is grayed out to indicate that it is muted.
3. To unmute the segment, click the x symbol again.

## MIDI Input

You can change the pitch on the fly by selecting the segment you want to change and pressing a key on your MIDI keyboard or using the Virtual Keyboard.

**PROCEDURE**

1. After having corrected the segmentation, select the segment for which you would like to change the pitch.
2. Activate the Pitch & Warp tool and click MIDI Input. Press a key on your MIDI keyboard or use the Virtual Keyboard to change the pitch of the segment.
3. The pitch of the segment changes according to the note you play.
   The MIDI Input function has two modes: Still mode and Step mode. You can switch between them by [Alt]/[Option]-clicking on the MIDI Input button:
   In Still mode you can select individual segments by clicking on them and change their pitch by pressing a MIDI key. You can also select several segments and press a MIDI key to change the pitch of several segments simultaneously. The pitch of the first selected segment is changed to the pitch of the MIDI note you play. The pitches of the other selected segment are changed by the same amount.
   In Step mode you can step through the segments by selecting the first segment that you would like to change and pressing a MIDI key. The next segment will automatically be selected afterwards. This allows you to work in a more creative way, for example, to develop completely new melody lines via MIDI.
4. When you are done, deactivate the MIDI Input button.

NOTE

MIDI controller data like pitchbend or modulation are ignored.

RELATED LINKS

Virtual Keyboard on page 210

Warping segments

Time correction, i.e. warping at segment level, is useful if you want to align a musical accent to a certain position, or change or quantize the timing of single segments in monophonic vocal recordings. When warping audio segments, warp markers will be created. These are shown on the VariAudio and the AudioWarp tabs of the Sample Editor Inspector.

IMPORTANT

Any correction of the segmentation must be applied before warping segments.

To warp a segment, proceed as follows:

PROCEDURE

1. On the VariAudio tab activate the Pitch & Warp tool.
2. To change the timing of a segment, move the mouse pointer over the start/end of the segment.
   The mouse pointer becomes a double arrow and the warp markers are displayed in the ruler.
3. Drag the start/end of the segment to the desired position.
   If the Snap button is activated, the segment border will snap to the grid. When you drag the segment border, warp markers are shown not only at the border but also at the adjacent segment borders to indicate which portions of the audio are stretched/affected.

NOTE

Warping a segment will also change the timing of the adjacent segments.

NOTE

Timing modifications introduced this way will not adapt to the project tempo. If this is what you want, use Musical Mode.
• You can change the insert position of a warp marker in the audio by clicking and dragging the warp marker handle in the ruler. This will change the warping.

• Hold down [Shift] (by default) to delete warp markers. To delete a warp marker, hold down the tool modifier so that the pointer becomes an eraser and click on the warp handle.

• If you are not satisfied with your changes, you can revert the timing of the selected segments by choosing the “Warp Changes” option from the Reset pop-up menu.

RELATED LINKS

Free Warp on page 457
Musical Mode on page 451
Editing warp markers on page 458
Reset on page 485

Editing Warp markers

In some cases the beginning of the waveform does not correspond to the beginning of a segment, e.g. when the audio starts with non-tonal portions like breath sounds. But when it comes to warping, any changes you wish to make must affect the waveform as a whole.

You can of course change the segmentation to achieve this, but if you want to pitch your audio afterwards, this would affect also any non-tonal portions of the audio. If this is not what you want, proceed as follows:

PROCEDURE

1. Activate the Pitch & Warp tool and activate the Snap button.

In this example the beginning of the segment does not correspond to the beginning of the waveform.
2. Move the mouse pointer over the start of the segment so that it becomes a double arrow and drag the segment start to the beginning of the bar. The segment border snaps to the grid at the exact bar position.

![Segment start adjusted to bar position](image)

Now the beginning of the segment matches the beginning of the bar, but we want the beginning of the waveform to match the beginning of the bar:

3. Point at the warp handle displayed in the ruler so that it turns into a double arrow and drag it to the beginning of the waveform. The background is displayed in orange to indicate which part of the waveform is affected by the change.

![Warp handle adjusted](image)

Now the beginning of the waveform matches the desired bar position.

![Waveform adjusted to bar position](image)

Editing warp markers can also be useful if you change the length of a segment that you have already warped. In this case, editing warp markers can help you synchronize your audio again.

**RELATED LINKS**

*Understanding the waveform display in VariAudio on page 469*
Reset

This pop-up menu at the bottom of the VariAudio tab allows you to reset the modifications you performed with the Pitch & Warp tool. It also lets you reset the changes you made in Segments mode by reanalyzing the audio and returning to the original segmentation. The following options are available:

**Pitch Changes**

If you select this option, pitch changes including micro-pitch modifications with the Tilt Micro Pitches tool are reset either for the selected segments (if available) or for the whole file.

**Warp Changes**

If you select this option, warp changes are reset.

**Pitch + Warp Changes**

If you select this option, pitch, micro-pitch, and warp changes are reset either for the selected segments (if available) or for the whole file.

**Reanalyze Audio**

If you select this option, the audio is reanalyzed and all your segmentation changes are reset.

**NOTE**

You can set up key commands for the reset and the reanalyze function in the Sample Editor category of the Key commands dialog.

**RELATED LINKS**

[Key Commands on page 997](#)

Listening to your modifications

You can listen to the results of your modifications using the following methods:

- By activating Acoustic Feedback on the toolbar.
  The segments are played back so that you can easily audition your pitch modifications while editing.

- By using the Play tool on the toolbar.

- By using the Audition and the Audition Loop tool on the toolbar.

- By using cycle playback in the Project window.
If you want to compare the original to the modified audio (i.e. hear the audio without pitch or warp modifications), you have the following possibilities:

- You can disable your pitch modifications by clicking the Disable Pitch Changes button on the VariAudio tab or by setting up and using the "VariAudio - Disable Pitch Changes" key command in the Key Commands dialog, Sample Editor category.

- You can disable your warp modifications by clicking the Disable Warp Changes button on the AudioWarp tab or by setting up and using the "VariAudio – Disable Warp Changes" key command in the Key Commands dialog, Sample Editor category.

**RELATED LINKS**

Key Commands on page 997

### Extracting MIDI

You can extract a MIDI part from your audio. This is useful if you have an audio event with a certain tune and sound and you want to create an identical second tune with a MIDI instrument or VST instrument.

The extracted MIDI part can also be used to print out notes from within the Score Editor or it can be exported as a MIDI file. Furthermore, you can convert the audio to MIDI notes containing Note Expression data which allows you to adopt the modulation data for individual notes.

**NOTE**

- Before extracting MIDI from your audio you should correct the segmentation. Otherwise, you will have to correct segmentation errors later in the MIDI part. Transition changes, tilting of the micro-pitch curve, Quantize Pitch settings, and pitch corrections will also be taken into account.

- If your audio event references only a section of the audio clip, only this section will be extracted.

The quality of the resulting MIDI data depends on the quality and the characteristics of your audio.

To extract a MIDI part from your audio, proceed as follows:

**PROCEDURE**

1. Open the audio file that you want to extract a MIDI part from in the Sample Editor.
2. Open the VariAudio tab.
3. Activate Segments mode.
4. Click the “Extract MIDI…” button. The “Extract MIDI” dialog opens.
5. On the Pitch Mode pop-up menu, specify which data should be included when extracting the MIDI part. The following options are available:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Just Notes and No Pitchbend Data</td>
<td>Only notes are included in the MIDI part.</td>
</tr>
<tr>
<td>Notes and Static Pitchbend Data</td>
<td>A pitchbend event is created for each segment. Select a pitchbend value from 1 to 24 in the Pitchbend Range field. When you are working with an external MIDI device, it might be necessary to set it to the same value.</td>
</tr>
<tr>
<td>Notes and Continuous Pitchbend Data</td>
<td>Pitchbend events that correspond to the micro-pitch curve are created within the resulting MIDI part. Select a pitchbend value from 1 to 24 in the Pitchbend Range field. The setting should correspond to the value set on your MIDI device or the controlled VST instrument. Note that although the graphic representation of the pitchbend curve is smoothed, all pitchbend data is included.</td>
</tr>
<tr>
<td>Notes and NoteExp Pitchbend Curve</td>
<td>MIDI pitchbend events that correspond to the micro-pitch curve are created as Note Expression data for the resulting MIDI notes.</td>
</tr>
<tr>
<td>Notes and NoteExp VST3 Tuning Curve</td>
<td>VST3 events for the “Tuning” parameter are created as Note Expression data for the resulting MIDI notes. Note that this works only with a connected VST instrument that is compatible with Note Expression.</td>
</tr>
</tbody>
</table>

6. On the Volume Mode pop-up menu, specify how volume information from the audio is extracted to MIDI. The following options are available:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fixed Velocity</td>
<td>All created MIDI notes get the same velocity. Select a velocity value in the Velocity field.</td>
</tr>
<tr>
<td>Dynamic Velocity</td>
<td>Each created MIDI note gets an individual velocity value according to the amplitude of the audio signal.</td>
</tr>
<tr>
<td>Volume Controller Curve</td>
<td>A continuous volume controller curve is created within the MIDI part. You can select the MIDI controller to be used for the curve in the MIDI Controller field.</td>
</tr>
<tr>
<td>NoteExp Volume Controller Curve</td>
<td>MIDI volume controller events are created as Note Expression data for the resulting MIDI notes.</td>
</tr>
<tr>
<td>NoteExp VST3 Volume Curve</td>
<td>A VST3 volume curve is created as Note Expression data for the resulting MIDI notes. Note that this works only with a connected VST instrument that is compatible with Note Expression.</td>
</tr>
</tbody>
</table>

7. On the Destination pop-up menu, specify where the MIDI part will be placed. The following options are available:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>First Selected Track</td>
<td>The MIDI part will be placed on the first selected MIDI or instrument track. Note that any MIDI parts from previous extractions that are on this track will be deleted.</td>
</tr>
</tbody>
</table>
Generating Harmony Voices for Monophonic Audio
(Cubase Pro only)

You can quickly harmonize monophonic audio using the “Generate Harmony Voices” function on the Audio menu.

This function automatically performs a VariAudio analysis, copies your event the specified number of times, and adds the resulting voices on separate tracks in the Project window. If you add a chord track to your project, the pitches of the resulting voices are altered to match the voicing of the chord track.

PROCEDURE

1. Import a monophonic audio file.
2. In the Project window, select the audio event.
3. On the Audio menu, select “Generate Harmony Voices…”.

4. Specify the number of voices that you want to create and enter a value for the vibrato reduction.

RESULT

The new voices follow the soprano, alto, tenor, and bass voices from the chord track voicing.

To open all voices in the Sample Editor, activate the “Open Sample Editor After Completion” option.

This allows you to view and edit the different voices.

NOTE

If you generate harmony voices without the chord track, the generated VariAudio segments of voice number 1 (soprano) are transposed three semitones upwards in relation to the original audio. The segments of voice numbers 2, 3, and 4 (alto, tenor, and bass) are transposed three, six, and nine semitones downwards.

RELATED LINKS

Chord Functions on page 814
Handling Several Audio Events (Cubase Pro only) on page 448

Flattening realtime processing

You can “flatten” realtime processing at any time. This can be done to serve two purposes: to reduce the CPU load and to optimize the sound quality of the processing.

Also use this function before applying any offline processing. When the flatten processing is applied, a copy of the original file is automatically created in the Pool so that the original audio clip remains intact.

The flatten function takes the following into account:

- Warp modifications, even when Bypass is activated. After the flattening, your Warp markers will be lost. However, you can undo this function as usual.

- VariAudio pitch modifications, even when Bypass is activated. After the flattening, your VariAudio data will be lost. However, you can undo this operation.

- Event transpose
PROCEDURE

1. Select the audio events that you want to process.

2. On the Audio menu, open the Realtime Processing submenu and select the Flatten command.
   Provided that the time stretching factor is not outside the range of 0.5 and 2, a dialog opens where you can select an algorithm for the processing.

   ![Flatten Realtime Processing dialog]

   If the audio has been transposed, the dialog also contains the “Formant Correction” option. You can activate this, for example, if you want to avoid a “chipmunk voice” effect.

3. Select an algorithm preset and click OK.
   After the processing, any loop that was previously stretched in realtime or had been pitch shifted will play back exactly the same, but Musical Mode will be deactivated and the realtime pitch shifting will be set to 0.

   **NOTE**

   Instead of the Flatten menu command, you can click the Flatten button on the Process tab of the Sample Editor.

RESULT

The audio clip is now like any standard audio clip before applying realtime processing, i.e. it does not follow tempo changes. The flattening processing function is best used when you have determined the tempo or key of a project. If you want to adapt the audio to a new key or tempo after flattening, it is better to revert to the original audio clip rather than to process the already processed file again.

RELATED LINKS

- Free Warp on page 457
- Warping segments on page 482
- Changing the pitch on page 476
- Transposing individual parts or events using the info line on page 276

**Selecting an algorithm for the flattening**

When you flatten the realtime processing, you can use the MPEX 4 algorithm or the Realtime algorithm to process the audio. The MPEX 4 algorithm may produce better sound quality than the realtime processing. The Realtime algorithm corresponds to the algorithm preset selected on the Sample Editor toolbar.

**NOTE**

If you introduced VariAudio pitch modifications, the MPEX presets will not be available and the algorithm preset “Standard – Solo” is used automatically.
The Realtime presets can be selected from the Algorithm pop-up menu on the Sample Editor toolbar.

In the Pool, you can select an algorithm for several selected clips at a time.

**RELATED LINKS**
- About time stretch and pitch shift algorithms on page 428
- Selecting an algorithm for realtime playback on page 451

## Unstretching audio files

By selecting “Unstretch Audio” from the Realtime Processing submenu of the Audio menu, all realtime time stretching (by sizing or by warp markers) is removed.

**NOTE**

Note that realtime transpose (in the info line) and Musical Mode will not be removed by this.

Whether the “Unstretch Audio” menu item is available depends on whether the time stretching has been applied at event or clip level:

- If you have sized an audio event in the Project window using “Sizing Applies Time Stretch”, you can undo the time stretching by selecting the event in the Project window and then applying “Unstretch Audio”. This removes all time stretching and warp markers.

- When you have entered a tempo and/or length on the toolbar, this information is saved for the source clip. These changes cannot be undone using “Unstretch Audio”.

**RELATED LINKS**
- Resizing Events Using Time Stretch on page 183
Audio Part Editor

The Audio Part Editor allows you to view and edit the events inside audio parts. Essentially, this is the same type of editing that you do in the Project window.

Audio parts are created in the Project window in one of the following ways:

- Select one or several audio events on the same track, and select Audio > Events to Part.
- Glue together two or more audio events on the same track with the Glue tool.
- Draw an empty part with the Draw tool.
- Double-click between the left and right locators on an audio track.

With the last two methods, an empty part is created. You can then add events to the part by pasting, or by using drag and drop from the Pool.

RELATED LINKS
Project Window on page 43

Window Overview

![Audio Part Editor: Harmonized Voices](image)
Audio Part Editor
Window Overview

## Toolbar

The tools, settings, and icons on the toolbar have the same functionality as in the Project window, with the following differences:

- A Solo button.
- Separate tools for auditioning (Speaker) and scrubbing.
- No Line or Glue Tube tools.
- Play and Loop icons and an Audition Volume control.
- Independent Track Loop settings.
- Part List controls for handling several parts: activating parts for editing, restricting editing to active parts only and showing part borders.

**NOTE**

You can customize the toolbar by hiding or reordering its items.

### RELATED LINKS

- Auditioning on page 495
- Scrubbing on page 497
- Setting Up the Independent Track Loop on page 496
- Handling Several Parts on page 497
- Using the Setup options on page 1032

## The Ruler and Info Line

These have the same functionality and appearance as their counterparts in the Project window.

You can select a separate display format for the Audio Part Editor ruler by clicking on the arrow button on the right and selecting an option from the pop-up menu.

### RELATED LINKS

- Ruler Display Formats on page 49
Opening the Audio Part Editor

The Audio Part Editor can display several parts at once, and you can also have more than one Audio Part Editor open at the same time.

PROCEDURE

1. Select one or more audio parts in the Project window.
2. Double-click on any one of them or use the Edit-Open key command, by default [Ctrl]/[Command]-[E].

   Double-clicking on an audio event in the Project window will open the Sample Editor.

RELATED LINKS

Opening the Sample Editor on page 433

About Lanes

Lanes can make it easier to work with several audio events in a part. Moving some of the events to another lane can make selection and editing much easier.

If the Snap function is deactivated and you want to move an event to another lane without accidentally moving it horizontally, press [Ctrl]/[Command] while dragging it up or down.

RELATED LINKS

Track Handling on page 134
Operations

Zooming, selecting and editing in the Audio Part Editor are done just as in the Project window.

NOTE

If a part is a shared copy (i.e. you have previously copied the part by [Alt]/[Option]-[Shift] and dragging), any editing you perform will affect all shared copies of this part.

RELATED LINKS

Project Window on page 43

Auditioning

There are several ways to listen to the events in the Audio Part Editor.

By Using the Speaker Tool

If you click somewhere in the editor’s event display with the Speaker tool and keep the mouse button pressed, the part will be played back from the position where you clicked. Playback will continue until you release the mouse button.

By Using the Audition Icon

Audition and Audition Loop icons

Clicking the Audition icon on the toolbar plays back the edited audio, according to the following rules:

- If you have selected events in the part, only the section between the first and last selected event will be played back.
- If you have made a range selection, only this section will be played back.
- If there is no selection, the whole part will be played back. If the project cursor is within the part, playback starts from the current cursor position. If the cursor is outside the part, playback starts from the beginning of the part.
- If the Audition Loop icon is activated, playback will continue until you deactivate the Audition icon. Otherwise, the section will be played back once.

When auditioning with the Speaker tool or Audition icon, audio will be routed directly to the Control Room (Cubase Pro only) or to the Main Mix (the default output bus) if the Control Room is disabled. In Cubase Artist, the Main Mix bus is always used for auditioning.
By Using Regular Playback

You can of course use the regular playback controls while in the Audio Part Editor. Furthermore, if you activate the Solo Editor button on the toolbar, only the events in the edited part will be played back.

Using Key Commands

If you activate the “Playback Toggle triggers Local Preview” option in the Preferences dialog (Transport page), you can start/stop auditioning by pressing [Space]. This is the same as clicking the Audition icon on the toolbar.

NOTE

The Audio Part Editor also supports the key commands “Preview start” and “Preview stop” in the Media category of the Key Commands dialog. These key commands stop the current playback, no matter if you are in normal playback or in audition mode.

Setting Up the Independent Track Loop

The independent track loop is a sort of mini-cycle, affecting only the edited part. When the loop is activated, the events in the parts that are within the loop will be repeated continuously and completely independent – other events (on other tracks) are played back as usual. The only interaction between the loop and the regular playback is that the loop starts every time the cycle starts over again.

PROCEDURE

1. Turn on the loop by clicking the Independent Track Loop button on the toolbar. If it is not visible, right-click the toolbar and add the Independent Track Loop Settings section.

   When the loop is activated, the cycle is not shown in the editor’s ruler. Now you need to specify the length of the loop.

2. [Ctrl]/[Command]-click in the ruler to set the start and [Alt]/[Option]-click to set the end of the loop.

   NOTE

   You can also edit the loop start and end positions numerically in the fields next to the Loop button.

RESULT

The loop is indicated in purple in the ruler.

NOTE

The events will be looped as long as the Loop button is activated and the Audio Part Editor window is open.
Scrubbing

In the Audio Part Editor, the Scrub tool has a separate icon on the toolbar. Apart from that, scrubbing works exactly as in the Project window.

Handling Several Parts

When you open the Audio Part Editor with several parts selected – all on the same track or on different tracks – they might not all fit in the editor window, which can make it hard to get an overview of the different parts when editing.

Therefore, the toolbar features a few functions to make working with multiple parts easier and more comprehensive:

- The “Currently Edited Part” pop-up menu lists all parts that were selected when you opened the editor, and lets you select which part is active for editing. When you select a part from the list, it is automatically made active and centered in the display.

  ![Currently Edited Part menu]

  **NOTE**
  
  Note that it is also possible to activate a part by clicking on it with the Object Selection tool.

- The “Edit Active Part Only” button lets you restrict editing operations to the active part only.

  If you for example select “All” from the Select submenu of the Edit menu with this option activated, all events in the active part will be selected but not the events in other parts.

  ![Edit Active Part Only]

- You can zoom in on an active part so that it is displayed in its entirety in the window by selecting “Zoom to Event” from the Zoom submenu of the Edit menu.
• The “Show Part Borders” button can be used if you want to see clearly defined borders for the active part. When this is activated, all parts except the active one are grayed out, making the borders easily discernible. There are also two markers in the ruler with the name of the active part, marking its beginning and end. These can be moved freely to change the part borders.

• It is possible to cycle between parts, making them active using key commands. In the Key Commands dialog – Edit category, there are two functions: “Activate Next Part” and “Activate Previous Part”. If you assign key commands to these, you can use them to cycle between parts.

RELATED LINKS
Setting up key commands on page 998

Options and Settings

The following options and settings are available in the Audio Part Editor:

Snap
The Snap functionality in the Audio Part Editor is exactly the same as in the Project window.

Auto-Scroll
When Auto-Scroll is activated on the toolbar, the window will scroll during playback, keeping the project cursor visible in the editor. This setting can be activated or deactivated individually for each window.

Snap to Zero Crossing
When this option is activated, all audio edits are done at zero crossings (positions in the audio where the amplitude is zero). This helps you avoid pops and clicks which might otherwise be caused by sudden amplitude changes.

RELATED LINKS
Snap Function on page 62
Every time that you record on an audio track, a file is created on your hard disk. A reference to this file, a clip, is added to the Pool.

The following rules apply to the Pool:

- All audio and video clips that belong to a project are listed in the Pool.
- Every project has a separate Pool.

The way the Pool displays folders and their contents is similar to the way the Windows Explorer/Mac OS Finder display folders and file lists. In the Pool, you can perform operations that affect files on disk and operations that only affect clips.

**Operations That Affect Files**

- Importing clips (audio files can automatically be copied and/or converted)
- Converting file formats
- Renaming clips (this also renames the referenced files on disk) and regions
- Deleting clips
- Preparing file archives for backup
- Minimizing files

**Operations That Affect Clips**

- Copying clips
- Auditioning clips
- Organizing clips
- Applying audio processing to clips
- Saving or importing complete Pool files
Pool Window

The Pool window allows you to manage the media files of the active project.

You can open the Pool in the following ways:

- On the Project window toolbar, click the Open Pool Window button. If this icon is not visible, you must activate the Media & MixConsole Windows option on the toolbar context menu.
- Select Project > Pool.
- Select Media > Open Pool Window.

The content of the Pool is divided into the following folders:

Audio Folder
Contains all audio clips and regions that are currently in the project.

Video Folder
Contains all video clips that are currently in the project.

Trash Folder
Contains unused clips that have been moved here for later permanent removal from the hard disk.

**NOTE**
You cannot rename or delete these folders, but you can add any number of subfolders.
Pool Window

**Toolbar**

1) **Show Info**
   Activates/deactivates the info line.

2) **Audition**
   If this option is activated and you select a clip in the Pool, it is played back.

3) **Audition Loop**
   If this option is activated, the playback of the selected clip is looped.

4) **Volume**
   Lets you specify the playback volume.

5) **View/Attributes**
   Lets you activate/deactivate which attributes are displayed in the Pool window.

6) **Open/Close all folders**
   Opens/Closes all folders.

7) **Import**
   Lets you import media files to the Pool.

8) **Search**
   Lets you search the Pool and connected disks for media files.

9) **Project Folder**
   Displays the path to the folder of the active project.

10) **Pool Record Folder**
    Displays the path to the record folder of the active project. By default, this is the Audio folder. However, you can create a new Audio subfolder and designate this as your Pool record folder.

**Pool Window Columns**

Various information about the clips and regions can be viewed in the Pool window columns. The columns contain the following information:

**Media**

Contains the Audio, Video, and Trash folders. If the folders are opened, the clip or region names are shown and can be edited.

**Used**

Displays how many times a clip is used in the project. If there is no entry in this column, the corresponding clip is not used.
### Status
Displays various icons that relate to the current Pool and clip status. The following symbols can be displayed:

- ![Record](image)
  - Indicates the current Pool record folder.
- ![ ]
  - Indicates that a clip has been processed.
- ![ ]
  - Indicates that a clip is referenced in the project but missing from the Pool.
- ![ ]
  - Indicates that the file the clip related to is external, for example, located outside the current Audio folder for the project.
- ![ ]
  - Indicates that the clip has been recorded in the currently open version of the project. This is useful for finding recently recorded clips quickly.

### Musical Mode
You can use the Musical Mode to tempo-match audio loops to the project tempo. The checkbox in this column allows you to activate or deactivate Musical Mode. If the Tempo column displays “???” you must enter the correct tempo before you can activate Musical Mode.

### Tempo
Displays the tempo of audio files, if available. If no tempo has been specified, the column displays “???”.

### Sign.
Displays the time signature, for example, “4/4”.

### Key
Displays the root key if one has been specified for the file.

### Algorithm
Displays the algorithm preset that is used if the audio file is processed.

- To change the default preset, click the preset name and select another preset from the pop-up menu.

### Info
For audio clips, this column displays the sample rate, bit resolution, number of channels, and length.

For regions, it displays start and end times in frames.

For video clips, it displays the frame rate, resolution, number of frames, and length.

### Type
Displays the file format of the clip.
Date
Displays the date when the audio file was last changed.

Origin Time
Displays the original start position where a clip was recorded in the project.
As this value can be used as a basis for the Insert into Project option in the Media or context menu, you can change it if the Origin Time value is independent (for example, not for regions).

You can change the value by editing the value in the column, or by selecting the corresponding clip in the Pool, moving the project cursor to the new position and selecting Audio > Update Origin.

Image
Displays waveform images of audio clips or regions.

Path
Displays the path to the location of a clip on the hard disk.

Reel Name
If you have imported an OMF file, it may include this attribute, which is then shown in this column. The Reel Name describes the reel or tape from which the media was originally captured.

Info Line
The info line displays additional information regarding the files in the pool.

- To activate the info line, click the Show Info button at the left of the toolbar.

The info line shows the following information:

Audio Files
The number of audio files in the Pool.

Used
The number of audio files in use.

Total Size
The total size of all audio files in the Pool.

External Files
The number of files in the Pool that do not reside in the project folder (for example, video files).
Customizing the View

You can set up which columns are shown or hidden and rearrange the order of the columns in the Pool.

- To specify which columns are shown or hidden, open the View/Attributes menu on the toolbar, and activate or deactivate items.
- To rearrange the order of columns, drag a column heading to the left or right.

Working with the Pool

NOTE

Most of the Pool-related main menu functions are also available on the Pool context menu.

Renaming Clips or Regions in the Pool

IMPORTANT

Renaming clips or regions in the Pool also renames the referenced files on disk. It is recommended to rename clips or regions in the Pool. Otherwise, the reference from the clip to the file may get lost.

PROCEDURE

1. In the Pool window, select a clip or region, and click the existing name.
2. Type in a new name and press [Return].

RELATED LINKS

About Missing Files on page 510

Duplicating Clips in the Pool

You can create duplicates of clips and apply different processing methods to them.

NOTE

Duplicating a clip does not create a new file on disk, but a new edit version of the clip that refers to the same audio file.

PROCEDURE

1. In the Pool window, select the clip that you want to duplicate.
2. Select Media > New Version.
RESULT
A new version of the clip appears in the same Pool folder. The duplicated clip has the same name as the original but with a version number after it. Regions within a clip are also copied, but keep their name.

Inserting Clips into a Project

To insert a clip into a project, you can either use the insert commands on the Media menu or use drag and drop.

Inserting Clips into a Project Via Menu Commands

PROCEDURE
1. In the Pool window, select the clips that you want to insert into the project.
2. Select Media > Insert into Project and select one of the insert options.
   If several clips are selected, choose whether to insert them on one track or each on a different track.

   NOTE
   The clips are positioned so that their snap points are aligned with the selected insert position. If you want to adjust the snap point before inserting a clip, double-click a clip to open the Sample Editor. Here, you can adjust the snap position and then perform the insert options.

RESULT
The clip is inserted on the selected track or on a new audio track. If several tracks are selected, the clip will be inserted on the first selected track.

RELATED LINKS
Adjusting the snap point on page 443

Inserting Clips into a Project Via Drag and Drop

You can drag a clip from the Pool into the Project window.
Snap is taken into account if the snap option is activated.

While you drag the clip into the Project window, its position is indicated by a marker line and a numerical position box. These indicate the position of the snap point in the clip.

If you position the clip in an empty area in the event display (for example, below existing tracks), a new track is created for the inserted event.

RELATED LINKS
Adjusting the snap point on page 443
Deleting Clips from the Pool

You can delete clips from the Pool with or without deleting the corresponding file from the hard disk.

Removing Clips from the Pool

NOTE
Removing clips from the Pool does not delete the corresponding file from the hard disk.

PROCEDURE
1. In the Pool window, select the clips that you want to remove, and select Edit > Delete
   You can also press [Backspace] or [Delete].
2. Depending on whether the clips are used by an event, you have the following options:
   • If the clips are used by an event, click Remove and then click Remove from Pool.
   • If the clips are not used by an event, click Remove from Pool.

RESULT
The clips are no longer available in the Pool for this project, but the files still exist on the hard disk and can be used in other projects, etc. This operation can be undone.

Deleting Files from the Hard Disk

To delete a file permanently from the hard disk, you must first move the corresponding clips to the Trash folder in the Pool.

IMPORTANT
• Before you permanently delete audio files from the hard disk, make sure that they are not used in another project.
• The following operation cannot be undone.

PROCEDURE
1. In the Pool window, select the clips that you want to delete from the hard disk, and select Edit > Delete
   You can also press [Backspace] or [Delete], or drag the clips into the Trash folder.

NOTE
You can retrieve a clip or region from the Trash folder by dragging it back into an Audio or Video folder.
2. Depending on whether the clips are used by an event, you have the following options:
   • If the clips are used by an event, click **Remove** and then click **Trash**.
   • If the clips are not used by an event, click **Trash**.

3. Select **Media > Empty Trash**.

4. Click **Erase**.

**RESULT**
The files are deleted from the hard disk.

### Removing Unused Clips from the Pool

You can find all clips in the Pool that are not used in the project. This allows you to quickly remove all unused clips.

**PROCEDURE**
1. In the Pool, select **Media > Remove Unused Media**.
2. Do one of the following:
   • To move the clips to the Trash folder, select **Trash**.
   • To remove the clips from the Pool, select **Remove from Pool**.

### Removing Regions from the Pool

**PROCEDURE**

1. In the Pool, select a region and select **Edit > Delete**.

You can also press [Backspace] or [Delete].

**IMPORTANT**
You are not warned if the region is still in use.

### Locating Events and Clips

You can quickly display to which clips the selected events belong to and to which events the selected clips belong to.
Locating Events via Clips in the Pool

You can find out which events in the project refer to a particular clip in the Pool.

PROCEDURE
1. In the Pool window, select one or more clips.
2. Select Media > Select in Project.

RESULT
All events that refer to the selected clips are now selected in the Project window.

Locating Clips via Events in the Project Window

You can find out which clip belongs to a particular event in the Project window.

PROCEDURE
1. In the Project window, select one or more events.
2. Select Audio > Find Selected in Pool.

RESULT
The corresponding clips are located and highlighted in the Pool.

Searching for Audio Files

The search functions help you locate audio files in the Pool, on your hard disk, or on other media. This works much like the regular file search, but with extra features.

PROCEDURE
1. In the Pool window, click the Search button on the toolbar.
   A search pane appears at the bottom of the window, displaying the search functions.

2. Specify the files that you search for in the Name field.
   You can use partial names or wildcards (*).

   NOTE
   Only audio files of the supported formats will be found.
3. Use the **Location** pop-up menu to specify where to search.
   The pop-up menu lists all your local drives and removable media.
   - To limit the search to certain folders, select **Select Search Path**, and in the
     dialog that opens, select the folder in which you want to search.
   The search will include the selected folder and all subfolders.

**NOTE**

Folders that you have recently selected using the **Select Search Path** function
appear on the pop-up menu, so that you can quickly select them again.

4. Click the **Search** button.
   The search is started and the **Search** button is labeled **Stop**.
   - To cancel the search, click **Stop**.
   When the search is finished, the files that are found are listed on the right.
   - To audition a file, select it in the list and use the playback controls to the left
     (Play, Stop, Pause, and Loop). If **Auto Play** is activated, selected files are
     automatically played back.
   - To import a file into the Pool, double-click the file in the list or select it and click
     the **Import** button.

5. To close the search pane, click the **Search** button on the toolbar again.

---

### Using the Extended Search Functionality

Apart from the search criterion Name, additional search filters are available. The
extended search options allow for a detailed search, helping you to master even the
largest sound database.

**PROCEDURE**

1. In the **Pool** window, click the **Search** button on the toolbar
   The Search pane is displayed in the lower part of the Pool window.
2. Click the **Name** text to open the extended search pop-up menu where you
   can select and define a search criterion.

   ![Search Criteria Menu](image)

   The menu also contains the **Add Filter** and **Presets** submenus.

   The search criteria have the following parameters:
   - **Name**: partial names or wildcards (*)
   - **Size**: Less than, More than, Equal, Between (two values), in seconds, minutes,
     hours, and bytes
   - **Bitsize** (resolution): 8, 16, 24, 32
   - **Channels**: Mono, Stereo, and from 3 to 16
   - **Sample Rate**: various values, choose **Other** for free setting
   - **Date**: various search ranges
3. Select one of the search criteria in the pop-up menu.
   The search criteria changes to the selected criteria.
4. Optional: To display more search options, open the extended search pop-up menu, select the Add filter submenu, and select an element.

5. Optional: To save your search filter settings as a preset, open the extended search pop-up menu, select Presets > Save Preset, and enter a name for the preset.
   
   Saved presets are added to the Presets submenu.

6. Optional: To remove a search filter settings preset, open the extended search pop-up menu, select the preset, and then select Remove Preset.

---

**Find Media Window**

The Find Media window is a stand-alone window that offers the same functionality as the Search Media option in the Pool.

- To open the Find Media window, select Media > Search Media.
- To insert a clip or region into the project from the Find Media window, select it in the list, select Media > Insert into Project, and select one of the insert options.

**RELATED LINKS**

Inserting Clips into a Project on page 505

---

**About Missing Files**

When you open a project and one or more files are missing, the Resolve Missing Files dialog opens. If you click Close, the project opens without the missing files.

In the Pool, you can check which files are considered missing. This is indicated by a question mark in the Status column.

A file is considered missing under one of the following conditions:

- The file has been moved or renamed outside the program since you last worked with the project, and you ignored the Resolve Missing Files dialog when you opened the project for the current session.
- You have moved or renamed the file outside the program during the current session.
- You have moved or renamed the folder in which the missing files are located.
Locating Missing Files

**PROCEDURE**

1. Select **Media > Find Missing Files**.
2. In the **Resolve Missing Files** dialog, decide if you want the program to find the file for you (**Search**), if you want to find it yourself (**Locate**), or if you want to specify in which directory the program will search for the file (**Folder**).
   - If you select **Search**, a dialog opens to let you specify which folder or disk will be scanned by the program. Click the **Search Folder** button, select a directory or a disk, and click the **Start** button. If found, select the file from the list and click **Accept**. Afterwards Cubase tries to map all other missing files automatically.
   - If you select **Locate**, a file dialog opens, allowing you to locate the file manually. Select the file and click **Open**.
   - If you select **Folder**, a dialog opens to let you specify the directory in which the missing file can be found. This might be the preferred method if you have renamed or moved the folder containing the missing file, but the file still has the same name. Once you select the correct folder, the program finds the file and you can close the dialog.

Reconstructing Missing Edit Files

If a missing file cannot be found, this is normally indicated with a question mark in the **Status** column in the Pool. However, if the missing file is an edit file (a file that is created when you process audio and stored in the Edits folder within the project folder), it may be possible for the program to reconstruct it by recreating the editing to the original audio file.

**PROCEDURE**

1. In the **Pool** window, locate the clips for which files are missing.
2. Check the **Status** column. If the status of the files is “Reconstructible”, the files can be reconstructed by Cubase.
3. Select the reconstructable clips and select **Media > Reconstruct**.

**RESULT**

The editing is performed and the edit files are recreated.
Removing Missing Files from the Pool

If the Pool contains audio files that cannot be found or reconstructed, you may want to remove these.

**PROCEDURE**

- In the **Pool** window, select **Media > Remove Missing Files**.

**RESULT**

All missing files from the Pool and the corresponding events from the **Project** window are removed.

Auditioning Clips in the Pool

You can audition clips in the Pool using key commands, the **Audition** button, or by clicking in the waveform image for a clip.

- **Key commands**
  
  If you activate the **Playback Toggle triggers Local Preview** option in the Preferences dialog (Transport page), you can use [Space] to audition. This is the same as activating the **Audition** button on the toolbar.

- Select a clip and activate the **Audition** button.
  
  The whole clip plays back. To stop playback, click the **Audition** button again.

- Click in the waveform image for a clip.
  
  The clip plays back from the selected position in the waveform until the end. To stop playback, click the **Audition** button or anywhere else in the **Pool** window.

The audio is routed directly to the Control Room, if activated (Cubase Pro only). When the Control Room is deactivated, the audio is routed to the Main Mix (the default output) bus, bypassing the settings of the audio channel, effects, and EQs. In Cubase Artist, the Main Mix bus is always used for auditioning.

**NOTE**

You can adjust the auditioning level with the miniature level fader on the toolbar. This does not affect the regular playback level.

If you have activated the **Audition Loop** button before you audition, the following happens:

- When you click the **Audition** button to audition a clip, the clip is repeated indefinitely until you stop playback by clicking the **Audition** or **Audition Loop** button again.

- When you click in the waveform image to audition, the section from the selected point to the end of the clip is repeated indefinitely until you stop playback.
Opening Clips in the Sample Editor

The Sample Editor allows you to perform detailed editing on the clip.

- To open a clip in the Sample Editor, double-click a clip waveform icon or a clip name in the Media column.
- To open a certain region of a clip in the Sample Editor, double-click a region in the Pool.

You can use this to set a snap point for a clip, for example. When you later insert the clip from the Pool into the project, the defined snap point allows it to be properly aligned.

RELATED LINKS
Adjusting the snap point on page 443
Sample Editor on page 432

Importing Media

The Import Medium dialog lets you import files directly into the Pool.

To open the dialog, select Media > Import Medium, or click the Import button on the Pool toolbar.

This opens a standard file dialog, where you can navigate to other folders, audition files, etc. The following audio file formats can be imported:

- Wave (Normal or Broadcast)
- AIFF and AIFFC (Compressed AIFF)
- REX or REX 2
- FLAC (Free Lossless Audio Codec)
- SD2 (Sound Designer II) (Mac only)
- MPEG Layer 2 and Layer 3 (MP2 and MP3 files)
- Ogg Vorbis (OGG files)
- Windows Media Audio (Windows only)
- Wave 64 (W64 files)

The following characteristics are possible:

- Stereo or mono
- Any sample rate

**NOTE**

Files that have a different sample rate than the project sample rate are played back at the wrong speed and pitch.

- 8, 16, 24, or 32 bit float resolution
Various video formats

NOTE
You can also use the commands on the Import submenu of the File menu to import audio or video files into the Pool.

RELATED LINKS
- Broadcast Wave files on page 949
- Importing ReCycle files on page 1016
- Importing compressed audio files on page 1017
- Video File Compatibility on page 980

Importing Audio CDs in the Pool

You can import tracks or sections of tracks from an audio CD directly into the Pool. This opens a dialog in which you can specify which tracks are copied from the CD, converted to audio files, and added to the Pool.

- To import an audio CD to the Pool, select Media > Import Audio CD.

RELATED LINKS
- Importing audio CD tracks on page 1013

Import Options Dialog

When you select a file in the Import Medium dialog and click Open, the Import Options dialog opens.

Copy File to Working Directory

If this option is activated, the file is copied to the Audio folder of the project, and the clip refers to this copy.

If the option is deactivated, the clip refers to the original file in the original location and will be marked as “external” in the Pool.
Convert to Project

If you are importing a single audio file, you can convert the sample rate provided that the sample rate is different than the one set for the project. You can also convert the sample size provided that the sample size is lower than the record format that is used in the project.

If you are importing several audio files at once, the Import Options dialog contains a Convert and Copy to Project if needed checkbox instead. When this option is activated, the imported files will be converted only if the sample rate is different or if the sample size is lower than the project sample size.

Split Channels/Split Multi-Channel Files

If this option is activated, the stereo or multi-channel audio files are split into a corresponding number of mono files, one for each channel.

<table>
<thead>
<tr>
<th>NOTE</th>
</tr>
</thead>
<tbody>
<tr>
<td>If this option is activated, the imported files are copied to the Audio folder of the project’s working directory.</td>
</tr>
</tbody>
</table>

If you import files via File > Import, the split files are inserted into the project and into the Pool as separate mono tracks.

If you import files via Media > Import Medium, the split files are only inserted into the Pool.

In all cases, the Split File Name Format pop-up menu lets you specify how the split files are named. This allows for compatibility with other products when exchanging audio files and avoids confusion if the source file contains no stereo or surround material, but poly-mono audio.

Please, don’t ask again

If this option is activated, files will always be imported according to the settings that you have made, without this dialog appearing. This can be reset in the Preferences dialog (Editing > Audio).

<table>
<thead>
<tr>
<th>NOTE</th>
</tr>
</thead>
<tbody>
<tr>
<td>You can also convert files later with the Convert Files or Conform Files options.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>RELATED LINKS</th>
</tr>
</thead>
<tbody>
<tr>
<td>Status on page 502</td>
</tr>
<tr>
<td>Converting Files on page 519</td>
</tr>
<tr>
<td>Conforming Files on page 521</td>
</tr>
</tbody>
</table>
Exporting Regions as Audio Files

If you have created regions within an audio clip, these can be exported as separate audio files. If you have two clips that refer to the same audio file, you can create a separate audio file for each clip.

**PROCEDURE**

1. In the Pool window, select the region that you want to export.
2. Select Audio > Bounce Selection.
3. Select the folder in which you want the new file to be created and click OK.
4. If you are using the Bounce Selection option to create a separate audio file for a clip that refers to the same audio file as another clip, enter a name for the new audio file.

**RESULT**

A new audio file is created in the specified folder. The file has the name of the region and is automatically added to the Pool.

**RELATED LINKS**

- Working with regions on page 448

Changing the Pool Record Folder

All audio clips that you record in the project will end up in the Pool Record folder. The Pool Record folder is indicated by the text Record in the Status column and by a red dot on the folder itself.

By default, this is the main Audio folder. However, you can create a new Audio subfolder and designate this as your Pool Record folder.

**NOTE**

The folders that you create in the Pool are only for organizing your files in the Pool. All files are recorded to the folder that you specified as the Pool Record Folder.

**PROCEDURE**

1. In the Pool, select the Audio folder or any audio clip.

**NOTE**

You cannot designate the Video folder or any of its subfolders as the Pool Record folder.

2. Select Media > Create Folder.
3. Rename the new folder.
4. Select the new folder and select Media > Set Pool Record Folder, or click in the Status column of the new folder.
RESULT

The new folder becomes the Pool Record folder. Any audio recorded in the project will be saved in this folder.

Organizing Clips and Folders

If you accumulate a large number of clips in the Pool, it can be difficult to quickly find specific items. Organizing clips in new subfolders with names that reflect the content can be a solution. For example, you could put all sound effects in one folder, all lead vocals in another, etc.

PROCEDURE

1. In the Pool window, select the type of folder, audio or video, for which you want to create a subfolder.

   NOTE
   
   You cannot put audio clips in a video folder and vice versa.

2. Select Media > Create Folder.
3. Rename the folder.
4. Drag the clips to the new folder.

Applying Processing to Clips in the Pool

You can apply audio processing to clips from within the Pool in the same way as to events in the Project window.

PROCEDURE

1. In the Pool window, select the clips that you want to process.
2. Select Audio > Process and select a processing method.

RESULT

A red and gray waveform symbol indicates that the clips have been processed.

RELATED LINKS

Audio processing and functions on page 401
Undoing Processing

You can undo processing that has been applied to clips.

**PROCEDURE**

1. In the Pool window, select the clip from which you want to remove the processing.
2. Select Audio > Offline Process History.
3. Select the action that you want to remove, and click Remove.

Minimizing Files

You can minimize the audio files according to the size of the audio clips referenced in the project. The files that are produced using this option only contain the audio file portions that are actually used in the project.

This can significantly reduce the size of the project if large portions of the audio files are unused. Therefore, the option is useful for archiving purposes after you have completed a project.

**IMPORTANT**

This operation will permanently change the selected audio files in the Pool. This cannot be undone. If you only want to create the minimized audio files as a copy, leaving the original project untouched, you can use the Back up Project option.

**NOTE**

Minimizing files clears the entire edit history.

**PROCEDURE**

1. In the Pool window, select the files that you want to minimize.
2. Select Media > Minimize File.
3. Click Minimize.
   After the minimizing is finished, the file references in the stored project have become invalid.
4. Do one of the following.
   - To save the updated project, click Save Now.
   - To proceed with the unsaved project, click Later.

**RESULT**

Only the audio portions that are actually used in the project remain in the corresponding audio files in the Pool Record folder.

**RELATED LINKS**

- Backing Up Projects on page 80
Importing and Exporting Pool Files (Cubase Pro only)

You can import or export a Pool as a separate file (file extension ".npl").

- To import a Pool file, select Media > Import Pool. When you import a Pool file, its file references are added to the current Pool.

**NOTE**
Since the audio and video files are only referenced but not saved in the Pool file, the Pool import is only useful if you have access to all referenced files. These files have preferably the same file paths as when the Pool was saved.

- To export a Pool file, select Media > Export Pool. You can also save and open libraries, that is, stand-alone Pool files that are not associated with a project.

**RELATED LINKS**
Working with Libraries (Cubase Pro only) on page 519

Working with Libraries (Cubase Pro only)

You can use libraries to save sound effects, loops, video clips, etc., and transfer media from a library into a project by using drag and drop.

- To create a new library, select File > New Library. You must specify a project folder for the new library in which media files will be stored. The library appears as a separate Pool window.

- To open a library, select File > Open Library.

- To save a library, select File > Save Library.

Converting Files

In the Pool, you can convert files to another format or change file attributes.

**PROCEDURE**
1. In the Pool window, select the files that you want to convert.
2. Select Media > Convert Files.
3. In the Convert Options dialog, make your settings and click OK.
Convert Options Dialog

In this dialog, you can change the file format and attributes of audio files in the Pool.

To open the Convert Options dialog, select a clip in the Pool window, and select Media > Convert Files.

Sample Rate
Allows you to convert to another sample rate.

Sample Width
Allows you to convert to 16Bit, 24Bit, or 32Bit Float.

Channels
Allows you to convert to Mono or Stereo Interleaved.

File Format
Allows you to convert to Wave, AIFF, Wave64, or Broadcast Wave format.

Options
You can use the Options pop-up menu to set one of the following options:

- **New Files**
  Creates a copy of the file in the audio folder and converts this new file according to the chosen attributes. The new file is added to the Pool, but all clip references still point to the original, unconverted file.

- **Replace Files**
  Converts the original file without changing clip references. However, the references are saved with the next save action.

- **New + Replace in Pool**
  Creates a new copy with the chosen attributes, replaces the original file with the new one in the Pool and redirects the current clip references from the original file to the new file. Select the latter option if you want your audio clips to refer to the converted file, but want to keep the original file on disk, for example, if the file is used in other projects.
Conforming Files

You can align the file attributes with the project attributes. This is useful if the attributes of the selected files are different from the project attributes.

PROCEDURE
1. In the Pool window, select the clips that you want to conform.
2. Select Media > Conform Files.
3. Select whether to keep or replace the original unconverted files in the Pool.
   • If you select the Replace option, files in the Pool and in the Audio folder of the project are replaced.
   • If any Keep option is selected, original files remain in the Audio folder of the project and new files are created.

RESULT
The files are conformed. Clip or event references in the Pool are redirected to the conformed files.

Extracting Audio from Video File

You can extract audio from video files. This automatically generates a new audio clip that appears in the Pool Record folder.

NOTE
This function is not available for MPEG-1 video files.

PROCEDURE
1. In the Pool window, select Media > Extract Audio from Video File.
2. Select the video file from which you want to extract audio and click Open.

RESULT
The audio is extracted from the video file. The audio file gets the same file format and sample rate/width as in the current project, and the same name as the video file.
With the MediaBay, you can manage all your media files and presets from multiple sources.

To open the MediaBay, select Media > MediaBay, or press [F5].

The MediaBay is divided into several sections:

1) Define Locations
   Allows you to create presets for locations on your system that you want to scan for media files.

2) Locations
   Allows you to switch between the previously defined locations.
3) **Filters**  
Allows you to filter the results list using a logical or an attribute filter.

4) **Results**  
Displays all found media files. You can filter the list and perform text searches.

5) **Previewer**  
Allows you to preview the files shown in the results list.

6) **Attribute Inspector** (Cubase Pro only)  
Allows you to view, edit, and add media file attributes or tags.

---

**Working With the MediaBay**

When working with many music files, the most important thing is to find the content that you need quickly and easily.

The MediaBay helps you to find and organize your content. After scanning your folders, all media files of the supported formats that have been found are listed in the Results section.

The first thing to do is to set up Locations, that is folders or directories on your system that contain media files. Usually, files are organized in a specific way on your computer. You might have folders reserved for audio content, folders for special effects, folders for combinations of sounds making up the ambience noise that you need for a certain film take, etc. These can all be set as different Locations in the MediaBay, allowing you to limit the files available in the Results list according to context.

Whenever you expand your computer system, you should save the new volumes as Locations or add them to your existing Locations.

By using the search and filter options, you can narrow down the results.

You can insert the files into your project by using drag & drop, by double-clicking, or by using the context menu options.

---

**Setting Up the MediaBay**

You can show and hide the different sections of the MediaBay. This saves screen space and enables you to display only the information that you need.

**PROCEDURE**

1. Click the Set up Window Layout button in the lower left corner of the MediaBay.
A transparent pane appears, containing checkboxes for the different sections.

2. Deactivate the checkboxes for the sections that you want to hide. You can also use key commands for this: use the [Up]/[Down] and [Left]/[Right] arrow keys to step through the checkboxes and press [Space] to activate/deactivate the selected checkbox.

3. When you are done, click outside the pane to exit the setup mode.

**Define Locations Section**

In the **Define Locations** section, you can specify which folders or directories you want to include in the scan for media files. To do so, activate/deactivate the checkboxes for the folders.

The color of the checkmark helps you to identify which folders and subfolders are scanned:

- White indicates that all subfolders are scanned.
- Orange indicates that at least one subfolder is excluded from the scan.

To revert to scanning a complete folder including all subfolders, click on an orange checkmark.

The scanning status for the individual folders is indicated by the color of the folder icons:

- Red indicates that the folder is currently being scanned.
Light blue indicates that the folder has been scanned.
- Dark blue indicates that a folder is excluded from the scan.
- Orange indicates that the scanning process for the folder was interrupted.
- Yellow indicates that a folder has not yet been scanned.

**VST Sound Node**

The VST Sound node is a shortcut to your user content and the factory content files, including the preset folders.

The folders below the VST Sound node represent the directories in which content files and track presets, VST presets, etc. are stored by default.

**Scanning Your Content**

You can specify which folders or directories you want to include in the scan.

- To include a folder in the scan, activate its checkbox.
- To exclude a folder from the scan, deactivate its checkbox.
- To restrict the search to individual subfolders, activate/deactivate their checkboxes.

The scan result is saved in a database file. When you deactivate the checkbox for a folder that has already been scanned, a message appears, allowing you to keep the gathered scan data in this database file or to completely remove the data for this folder from the database file.

- To keep the database entries and exclude the folder from being scanned, select **Keep**.
- To remove the contents from the database, select **Remove**.

All files that are found in the specified folders are shown in the **Results** list.

**Updating the MediaBay**

When you have made changes to the content of media folder or modified attributes, you must update the **MediaBay**. You can update the **MediaBay** by rescanning or by refreshing.
Rescanning

If you have made changes to the content of specific media folders and want those changes to be displayed in the MediaBay you must rescan them.

- To rescan the selected folder and its subfolders, click the Rescan button in the Define Locations section. You can also right-click a folder and select Rescan Disk.

- To rescan only the folders that have changed since the last scan, right-click in the Define Locations section, and select Quick Rescan Disk.

Refreshing

If you have modified attribute values or mapped a new network, you must refresh the corresponding folders.

- To refresh a folder, in the Define Locations section of the MediaBay right-click a folder, and select Refresh Views.

- To display a new network drive, in the Define Locations section of the MediaBay right-click the parent node, and select Refresh Views. You can then scan the drive for media files.

RELATED LINKS

Editing Attributes (Tagging) on page 546

Locations Section

When you open the Select Defined Browse Location pop-up menu and select a location, the media files that are found in that location are shown in the Results list. By switching between the locations you defined, you can quickly browse to the files you are looking for.

1) Previous/Next Browse Location
   Selects the previous/next browse location.

2) Browse Containing Folder
   Opens the parent location of the selected folder.

3) Select Defined Browse Location
   The following location presets are available by default:
   All Media, Local Harddisks, VST Sound, Documents, Desktop, Music, Cubase Projects.
4) **Remove Browse Location Definition**  
Removes the selected browse location.

5) **Deep Results**  
If this option is activated, the media files that are located in the subfolders of the selected location are also displayed in the results list.

---

**Defining Locations**

You can define locations, that is shortcuts to the folders that you want to work with. These are shown in the Locations section.

**PREREQUISITE**
Set up the Define Locations section and scan the content.

**PROCEDURE**

1. In the **Define Locations** section in the **MediaBay**, select the folder that you want to define as a location.
2. Click the **Add** button.
3. Accept the default name or enter a new name.
4. Click **OK**.
   
   The new location is added to the **Select Defined Browse Location** pop-up menu in the **Locations** section.
5. Repeat these steps to add as many locations as you want.

---

**AFTER COMPLETING THIS TASK**

Once you have set up your locations, you can hide the **Define Locations** section from view, to save screen space.

---

**Browsing the Locations**

You can quickly switch between different locations.

- To change the browse location, select another location from the **Select Defined Browse Location** pop-up menu.

  If the available locations do not include the files that you want to display or if the folder that you want to scan for files is not part of any of the locations, define a new location in the **Define Locations** section.

- To select the previous or next folder, click the **Previous/Next Browse Location** buttons. These paths are deleted when you close the **MediaBay**.

- To select the parent folder of the selected folder, click the **Browse Containing Folder** button.
To remove a location from the pop-up menu, select it and click the Remove Browse Location Definition button.

To show the files contained in the selected folder and any subfolders, activate the Deep Results button. When this button is deactivated, only the folders and files contained in the selected folder are shown.

Results Section

The Results list shows all media files that are found in the selected location.

The info field in the top right corner of the Results section shows how many files were found with the current filter settings. As the number of files displayed can be huge, you can use any of the filter and search options in the MediaBay to narrow down the list.

To set the maximum number of files that are displayed in the Results list, specify a new value for Maximum Items in Results List in the MediaBay Preferences.

Search in Progress Indicator

An indicator to the right of the number of files found indicates that a media search is in progress.

Inserting Files into the Project

**PROCEDURE**

- To insert a file into your project, do one of the following:
  - Right-click the file and select one of the Insert into Project options.
  - Double-click the file.
  - Drag it into the project.
RESULT

Depending on the track type, the following happens:

- Audio files, MIDI loops, and MIDI files are inserted on the active track if this matches the file type or onto a new track if no corresponding track is active. The files are inserted at the project cursor position.

- If you double-click a track preset it is applied to the active track if the track type matches the track preset. Otherwise, a new track is inserted, containing the settings of the track preset.

- If you double-click a VST preset, an instrument track is added to the project, containing an instance of the corresponding instrument. For some VST presets, this loads the entire instrument settings, programs, etc. For others, only one program is loaded.

- If you double-click a pattern bank, a new MIDI track is created in the Project window, with an instance of the Beat Designer plug-in as insert effect which is using this pattern.

Setting Up the Results List Columns

For each media type, or for combinations of media types, you can specify the attribute columns that are displayed in the Results list.

PROCEDURE

1. In the Results section of the MediaBay, select the media types that you want to make settings for.

2. Click the Set up Result Columns button and activate or deactivate the options on the submenus.

To exclude a particular category, select Select None on the corresponding submenu.

If Allow Editing in Results List is activated in the MediaBay Preferences dialog, you can also edit attributes in the Results list. Otherwise, this is only possible in the Attribute Inspector.

Managing Media Files in the Results List

- To move or copy a file from the Results list to another location, drag it to another folder in the Define Locations section.
To change the order of the columns in the **Results** list, click on a column header, and drag that header to another position.

To delete a file, right-click it in the list and select **Delete**. The file is permanently deleted from your computer.

---

**IMPORTANT**

If you delete a file using the Windows Explorer/Mac OS Finder, it is still displayed in the **Results** list, although it is no longer available to the program. To remedy this, re-scan the corresponding folder.

---

### Shuffling the Results List

You can display the **Result** list entries in a random order.

- To shuffle the **Results** list, click the **Shuffle Results** button in the **MediaBay**.

### Finding the Location of a File

You can open the Windows Explorer/Mac OS Finder to show the location of a file on your system.

**NOTE**

This function is not available for files which are part of a VST Sound archive.

**PROCEDURE**

- In the **Results** list, right-click a file, and select **Show in Explorer (Win)/Reveal in Finder (Mac)**.

**RESULT**

The Windows Explorer/Mac OS Finder opens and the corresponding file is highlighted.

### Filtering According to Media Type

You can set up the **Results** list to display only a particular media type or a combination of media types.

**PROCEDURE**

1. In the **Results** section, click the **Select Media Types** button.
2. In the **Show Media Types** dialog, activate the media types that you want to be displayed in the **Results** list.

When you have filtered the list to show a particular media type, this is indicated by the corresponding icon to the left of **Select Media Types** button. When you have selected several media types, the **Mixed Media Type** icon is used.

---

**Show Media Types Selector**

You can activate the media types that you want to be displayed in the **Results** list.

The following media types are available:

**Audio Files**

When this option is activated, the list shows all audio files. The supported formats are `.wav`, `.w64`, `.aiff`, `.aifc`, `.rex`, `.rx2`, `.mp3`, `.mp2`, `.ogg`, `.sd2` (Mac only), `.wma` (Win only).

**MIDI Files**

When this option is activated, the list shows all MIDI files (file name extension `.mid`).

**MIDI Loops**

When this option is activated, the list shows all MIDI loops (file name extension `.midiloop`).

**Pattern Banks**

When this option is activated, the list shows all pattern banks (file name extension `.patternbank`). Pattern banks are generated via the MIDI plug-in **Beat Designer**. For more information, see the separate PDF document “Plug-in Reference”.

**Track Presets**

When this option is activated, the list shows all track presets for audio, MIDI, and instrument tracks (file name extension `.trackpreset`). Track presets are a combination of track settings, effects, and **MixConsole** settings that can be applied to new tracks of various types.
Plug-in Presets
When this option is activated, the list shows all VST presets for instrument and effect plug-ins. Furthermore, EQ presets that you save in the MixConsole are listed. These presets contain all parameter settings for a particular plug-in. They can be used to apply sounds to instrument tracks and effects to audio tracks.

Strip Presets
When this option is activated, the list shows all strip presets (file name extension .strippreset). These presets contain channel strip effect chains.

FX Chain Presets
When this option is activated, the list shows all effect chain presets (file name extension .fxchainpreset). These presets contain insert effect chains.

Video Files
When this option is activated, the list shows all video files.

Projects
When this option is activated, the list shows all project files (from Cubase, Nuendo, Sequel): .cpr, .npr, .steinberg-project.

RELATED LINKS
- Previewing Pattern Banks on page 538
- Track Presets on page 160
- Saving/Loading Strip Presets on page 342
- Saving/Loading EQ Presets on page 332
- Saving/Loading FX Chain Presets on page 330
- Video File Compatibility on page 980

Filtering According to Rating

With the Rating Filter, you can filter files according to their rating. This allows you to exclude files from the search according to their quality.

PROCEDURE
1. In the Results section of the MediaBay, drag the Rating Filter to the left or right.
   ![Rating Filter](image)
2. To display all media files regardless of their rating, click the asterisk icon.
Performing a Text Search

You can perform a text search in the **Results** list. If you enter text in the text search field, only media files whose attributes match the entered text are displayed.

The **Search Results** field has the same function as the **matches** operator of the logical filter. However, the search is applied to all file attributes.

- Click in the field and enter the text that you want to find.
  
  For example, if you are looking for all audio loops relating to drum sounds, enter “drum” in the search field. The search results contain loops with names, such as “Drums 01”, “Drumloop”, “Snare Drum”, etc. In addition, all media files with the **Drum&Percussion** category attribute or any other attribute that contains “drum” are found. You can also add apostrophes to find exact matches for the entered words and use boolean operators.

When you enter text in the field, its background becomes red, to indicate that a text search is active for the list.

- To reset the text search, delete the text.

**RELATED LINKS**

- **Logical Filter on page 539**

Resetting the Results List

You can reset all filter settings and filter results.

- To reset the **Results** list, click the **Reset Result Filter** button in the **MediaBay**.

Previewer Section

You can preview individual files in the **Previewer** section to find out which one to use in your project.

The elements visible in this section and their functions depend on the media type.

**IMPORTANT**

The **Previewer** section is not available for video files, project files, and audio track presets. You can preview track presets in the **Presets** browser.
NOTE
Some MediaBay-specific preferences affect the playback of media files.

RELATED LINKS
MediaBay Preferences on page 550

Previewing Audio Files

1) Transport Controls
   Let you start, stop, pause, and cycle the preview.

2) Preview Level Fader
   Lets you specify the preview level.

3) Auto Play New Results Selection
   If this option is activated, the selected file is automatically played back.

4) Align Beats to Project
   If this option is activated, the selected file is played back in sync with the project, starting at the project cursor position. Note that this can apply realtime time stretching to your audio file.

   NOTE
   If you import an audio file into your project for which Align Beats to Project is activated in the Previewer, Musical Mode is automatically activated for the corresponding track.

5) Wait for Project Play
   If this option is activated, the play and stop functions from the Transport panel are synchronized with the play and stop buttons in the Previewer section.

   To use this option to its full extent, set the left locator at the beginning of a bar, then start playing back the project using the Transport panel. The loops that you now select in the Results list will start together with the project in perfect sync.
Previewing MIDI Files

**IMPORTANT**

To preview a MIDI file, you must select an output device from the **Output** pop-up menu.

1) **Transport Controls**
   Let you start and stop the preview.

2) **Preview Level Fader**
   Lets you specify the preview level.

3) **Output**
   Lets you select the output device.

4) **Auto Play New Results Selection**
   If this option is activated, the selected file is automatically played back.

5) **Align Beats to Project**
   If this option is activated, the selected file is played back in sync with the project, starting at the project cursor position. Note that this can apply realtime time stretching to your MIDI file.

**NOTE**

If you import a MIDI file into your project for which **Align Beats to Project** is activated in the **Previewer, Musical Mode** is automatically activated for the corresponding track.

Previewing MIDI Loops

**NOTE**

MIDI loops are always played back in sync with the project.

1) **Transport Controls**
   Let you start and stop the preview.
2) **Preview Level Fader**  
Lets you specify the preview level.

3) **Auto Play New Results Selection**  
If this option is activated, the selected file is automatically played back.

4) **Link Playback to Chord Track**  
If this option is activated, the events of the MIDI loop are transposed to play back in context with the chord track. Note that you need a chord track with chord events for this.

If this option is activated, and you insert a MIDI loop into the project, **Follow Chord Track** is automatically activated for the track.

### Previewing VST Presets and Track Presets for MIDI and Instrument Tracks

To preview track presets for MIDI or instrument tracks and VST presets you need some MIDI notes. These notes can be sent to the track preset via MIDI Input, using a MIDI file, the **Memo Recorder** mode, or via the computer keyboard.

![Virtual keyboard in keyboard display mode.](image)

1) **Transport Controls**  
Let you start and stop the preview.

2) **Previewer Sequence Mode Menu**  
Lets you load a MIDI file to apply the currently selected preset to the MIDI file. You can also select the **Memo Recorder** mode that continually repeats a given sequence of notes as a loop.

3) **Preview Level Fader**  
Lets you specify the preview level.

4) **Virtual Keyboard**  
You can display the virtual keyboard in the keyboard display mode or in the piano display mode.

5) **Computer Keyboard Input**  
If this option is activated, you can use your computer keyboard to preview the presets.

**RELATED LINKS**  
[Previewing Presets Using the Memo Recorder Mode on page 537](#)
Previewing Presets Via MIDI Input

MIDI input is always active, for example, when a MIDI keyboard is connected to your computer and set up properly, you can directly start playing the notes to preview the selected preset.

Previewing Presets Using a MIDI File

**PROCEDURE**

1. On the Previewer Sequence Mode pop-up menu, select Load MIDI File.
2. In the file dialog that opens, select a MIDI file and click Open.
   The name of the MIDI file is displayed on the pop-up menu.
3. Click the Play button to the left of the pop-up menu.

**RESULT**
The notes received from the MIDI file are played back with the settings of the track preset applied.

**NOTE**
The recently used MIDI files are kept on the menu, for quick access. To remove an entry from this list, select it on the menu and then select Remove MIDI File.

Previewing Presets Using the Memo Recorder Mode

The Memo Recorder mode continually repeats a given sequence of notes as a loop.

**NOTE**
You cannot use the Memo Recorder mode when previewing presets using a MIDI file.

**PROCEDURE**

1. On the Previewer Sequence Mode pop-up menu, select Memo Recorder.
2. Activate the Play button.
3. Play some notes on the MIDI keyboard or on the computer keyboard.

**RESULT**
The notes are played back with the preset settings applied.
When you stop playing notes and wait for 2 seconds, the note sequence that you played until this moment is played back in a continuous loop.

To use another sequence, start entering notes again.

**Previewing Presets Via the Computer Keyboard**

**NOTE**

If you activate the *Computer Keyboard Input* button, the computer keyboard is used exclusively for the *Previewer* section. However, you can still use the following key commands: [Ctrl]/[Command]-[S] (Save), Num [*] (Start/Stop Record), [Space] (Start/Stop Playback), Num [1] (Jump to left locator), [Delete] or [Backspace], Num [/] (Cycle on/off), and [F2] (Show/Hide Transport panel).

**PROCEDURE**

1. Activate the *Computer Keyboard Input* button.
2. Play some notes on the computer keyboard.

**Previewing Pattern Banks**

Pattern banks containing drum patterns can be created with the MIDI plug-in *Beat Designer*.

1) **Transport Controls**
   Let you start and stop the preview.

2) **Preview Level Fader**
   Lets you specify the preview level.

3) **Keyboard**
   The keyboard allows you to preview the selected pattern bank. In the *Previewer* section, choose a subbank (the number at the top) and pattern (a key), and click the *Play* button.

   One pattern bank contains 4 subbanks which in turn contain 12 patterns each.

   Subbanks can contain empty patterns. Selecting an empty pattern in the *Previewer* section has no effect. Patterns containing data are indicated by a circle in the upper part of the key in the display.
4) **Auto Play New Results Selection**
   If this option is activated, the selected file is automatically played back.

5) **Link Playback to Chord Track**
   If this option is activated, the events of the MIDI loop are transposed to play back in context with the chord track. Note that you need a chord track with chord events for this.

   If this option is activated, and you insert a MIDI loop into the project, **Follow Chord Track** is automatically activated for the track.

### NOTE

Detailed information on the **Beat Designer** and its functions can be found in the separate PDF document Plug-in Reference in the chapter MIDI effects.

---

**Filters Section**

With the **MediaBay**, you can perform very refined file searches. You have two possibilities: **Logical** or **Attribute** filtering.

**Logical Filter**

The logical filter allows you to set up complex search conditions that must be met to find files.

```
contains
```

The search result must contain the text or number specified in the text field to the right.

```
matches words
```

The search result must match the words specified in the text field to the right.

```
omits
```

The search result must not contain the text or number specified in the text field to the right.
equals
The search result must correspond exactly to the text or number specified in the text field to the right, including any file extension. Text searches are not case-sensitive.

>=
The search result must be higher than or equal to the number specified in the field to the right.

<=
The search result must be lower than or equal to the number specified in the field to the right.

is empty
Use this option to find files for which certain attributes have not been specified yet.

matches
The search result must include the text or number entered in the text field to the right. You can also use boolean operators. Add apostrophes to find exact matches for the entered words, for example ‘drum’ AND ‘funky’. This option allows for a very advanced text search.

in range
If this option is selected, you can specify a lower and an upper limit for the search result in the fields to the right.

Applying a Logical Filter

To quickly find certain audio files, you can search for a specific file attribute value, for example.

PREREQUISITE
In the Locations section, select the location in which you want to search for files.

PROCEDURE
1. In the Filters section, activate the Logical button.
2. Click in the leftmost field, to open the Select Filter Attributes dialog.
3. Select the attributes that you want to use.
   If you select more than one attribute, the files found match either one or the other attribute.
4. Click OK.
5. On the condition pop-up menu, select one of the search operators.

6. Enter the text or number that you want to find in the field to the right.

**NOTE**

If you enter 2 or more strings or filter lines, the files that are found match all strings or filter lines.

- To add more than one string in the text field, enter a [Space] between them.
- To add another filter line, click the + button to the right of the text field. You can add up to seven filter lines in which you can define further search conditions.
- To remove a filter line, click the corresponding - button.
- To reset all search fields to their default settings, click the **Reset Filter** button in the top right corner of the **Filters** section.

**RESULT**

The **Results** list is automatically updated, showing only the files that correspond to your search conditions.

**Advanced Text Search**

You can perform very advanced text searches using boolean operators.

**PREREQUISITE**

In the **Locations** section, select the location in which you want to search for files.

**PROCEDURE**

1. In the **Filters** section, activate the **Logical** button.
2. Select an attribute on the **Select Filter Attributes** pop-up menu or leave the setting on **Any Attribute**.
3. Set the condition to **matches**.
4. Specify the text that you want to search for in the field to the right using boolean operators.

**RELATED LINKS**

[Performing a Text Search on page 533]
About Attributes for Media Files

Attributes for media files are sets of meta data providing additional information on the file.

The different types of media files have different attributes. For example, .wav audio files have attributes like name, length, size, sample rate, etc., while .mp3 files have additional attributes such as artist or genre.

RELATED LINKS

Attribute Inspector on page 544

Attribute Filter

Assigning attribute values to your files makes it easy to organize the media files. With the Attribute filter, you can view and edit some of the standard file attributes found in your media files.

If you click the Attribute button, the Filters section displays all values found for a specific attribute. Selecting one of these values displays a list of files that contain this attribute value.

1) **Attribute columns**
   
   Let you select different attribute categories. If the columns are wide enough, the number of files that match this criteria is displayed to the right of the filter name.

2) **Attribute values**

   Displays the attribute values and how often a certain attribute value is available among your media files.

   **NOTE**

   - Some attributes are directly linked to each other. For example, for each category value, there are certain sub category values available. Changing the value in one of these attribute columns displays different values in the other column.
   - Each attribute column displays only the attribute values found in the currently selected location.

RELATED LINKS

Attribute Inspector on page 544
Applying an Attribute Filter

With the Attribute filter you can quickly find audio files with certain attributes.

• To apply an Attribute filter, click on an attribute value. The Results list is filtered accordingly. Apply more attribute filters to restrict the result even more.

• To find files that match either one or the other attribute, [Ctrl]/[Command]-click different attribute values in the same column.

• To change the displayed attribute values of a column, click on the attribute column and select another attribute.

NOTE

Character attributes always form an AND condition.

Performing a Context Menu Search

You can search for other files with the same attribute as the selected. This way you can easily find all the files that have a value in common, for example, if you want to view all files that were created on the same day.

• In the Results list or the Attribute Inspector, right-click a file, and select the attribute value that you want to search for from the Search for submenu.

The Filters section automatically switches to Logical filtering and the corresponding filter condition line is displayed.

• To reset the filter, click the Reset Result Filters button.
Resetting the Filter

PROCEDURE

• To reset the filter, click the Reset Filter button at the top of the Filters section.

This also resets the Results list.

Attribute Inspector

When you have selected one or more files in the Results list, the Attribute Inspector shows a list of attributes and their values.

In the Attribute Inspector, you can also edit and add new attribute values.

The available attributes are divided into several groups (Media, Musical, Preset, etc.), so as to keep the list manageable and make it easy to find an element quickly.

Dynamic

Displays all available values for the selected files.

Defined

Displays a configured set of attributes for the selected media type regardless of whether corresponding values are available for the selected files.

Configure Defined Attributes

Activates the configuration mode in which you can set up the attributes that are displayed in the Attribute Inspector.
Configuration Mode

When you click the **Configure Defined Attributes** button, the configuration mode is enabled.

Select Media Types

Lets you select one or several media types. You can then manage which attributes are displayed in the **Attribute Inspector** for the selected media types.

+/-

Opens the **Add User Attribute** dialog, where you can add or remove custom user attributes. You can select the **Attribute Type** and the **Display Name**.

Reset to Default

Resets the attribute list to the default settings.

Attribute

Shows the attribute name.

Select

Shows whether an attribute is activated or deactivated.

Type

Shows whether the value for an attribute is a number, text, or a Yes/No switch.

Precision

Shows the number of decimals displayed for number attributes.

**RELATED LINKS**

* About Attributes for Media Files on page 542
* Managing Attribute Lists on page 549
Color Schemes in the Attribute Inspector

The color of an attribute value indicates if and in which form you can edit an attribute.

White
One or more files are selected in the Results list, and they have the same values.

Yellow
Multiple files are selected in the Results list, and their values differ.

Orange
Multiple files are selected in the Results list, with differing values, and which cannot be edited.

Red
One or more files are selected in the Results list, whose values cannot be edited.

Information on the meaning of the colors used in the Attribute Inspector are also displayed in a tooltip when you move the mouse pointer over one of the color icons below the Attribute Inspector.

Editing Attributes (Tagging)

The search functions, especially the attribute filter, are a powerful media management tool when making extensive use of tagging, for example, when adding and editing attributes.

Media files are usually organized in complex folder structures to provide a logical way of guiding the user to certain files, with the folder and/or file names indicating the instrument, style, tempo, etc.

Tags help you finding a particular sound or loop in such a folder structure.

Editing Attributes in the Attribute Inspector

In the Attribute Inspector, you can edit attribute values of the various media files. Attribute values can be chosen from pop-up lists, entered as text or numbers, or set to Yes or No.

NOTE
- Changing an attribute value in the Attribute Inspector permanently changes the corresponding file unless the file is write-protected or part of a VST Sound archive.
Some attributes cannot be edited. If this is the case, the file format probably does not permit changing this value, or changing a particular value makes no sense. For example, you cannot change the file size in the MediaBay.

**PROCEDURE**

1. In the **Results** list, select the file that you want to make settings for.
   
   The corresponding attribute values are displayed in the **Attribute Inspector**. You can also select several files and make settings for them simultaneously. The only exception is the name attribute, which must be unique for every file.

2. In the **Attribute Inspector**, click in the **Value** column for an attribute.
   
   Depending on the selected attribute, the following happens:
   
   - For most of the attributes, a pop-up menu opens from which you can choose a value. This can be a name, a number and an on/off state. Some of the pop-up menus also have a “more…” entry to open a window with more attribute values.
   
   - For the **Rating** attribute, you can click in the **Value** column and drag left or right to modify the setting.
   
   - For the **Character** attribute (Musical group), the **Edit Character** dialog opens. Click a radio button on the left or the right side and then click **OK** to define values for the **Character** attribute.

3. Set the attribute value.

   To remove the attribute value from the selected files, right-click in the corresponding **Value** column and select **Remove Attribute** from the context menu.

---

**Editing Attributes in the Results List**

You can edit attributes directly in the **Results** list. This allows you to assign tags to a number of loop files, for example.

**PREREQUISITE**

**Allow Editing in Results List** must be activated in the **MediaBay Preferences**.

**PROCEDURE**

1. In the **Results** list, select the files that you want to make settings for.

   You can make settings for several files simultaneously. The only exception is the name attribute, which must be unique for every file.

2. Click in the column for the value that you want to change and make the settings.

**RELATED LINKS**

[MediaBay Preferences on page 550](#)
**Editing Attributes of Multiple Files Simultaneously**

You can tag multiple files at the same time. There is no limit as to how many files can be tagged at the same time, but the tagging of a large amount of files in one go can take a while.

The tagging operation is executed in the background, so that you can continue with your work as usual. By looking at the **Attribute Counter** above the **Results** list, you can see how many files still have to be updated.

**Editing Attributes of Write-Protected Files**

Media files can be write-protected due to a number of reasons. The content can be provided by someone who write-protected the files, the file format could restrict write operations by the **MediaBay**, etc..

In the **MediaBay**, the write protection status of files is shown as an attribute in the **Attribute Inspector** and in the **Write Protection** column in the **Results** list.

<table>
<thead>
<tr>
<th>IMPORTANT</th>
</tr>
</thead>
<tbody>
<tr>
<td>You can define attribute values of write-protected files in the <strong>MediaBay</strong>. These changes are not written to disk though and occur in the <strong>MediaBay</strong> only.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>NOTE</th>
</tr>
</thead>
<tbody>
<tr>
<td>If the <strong>Write Protection</strong> and/or the <strong>Pending Tags</strong> columns are not visible, activate the corresponding attributes for the file type in the <strong>Attribute Inspector</strong>.</td>
</tr>
</tbody>
</table>

- To set or remove the write protection attribute for a file, right-click the file in the **Results** list and select **Set/Remove Write Protection**.  
  This is only possible if the file type allows write operations and you have the necessary operation system permission.

- When you specify attribute values for a file that is write-protected, this is reflected in the **Pending Tags** column next to the **Write Protection** column in the **Results** list.  
  If you rescan the **MediaBay** content and a media file on your hard disk has changed since the last scan, the pending tags for this file will be lost.

- If a file has pending tags, and you want to write the corresponding attributes to the file, you must remove the write protection, then right-click the file, and select **Write Tags to File**.

<table>
<thead>
<tr>
<th>NOTE</th>
</tr>
</thead>
<tbody>
<tr>
<td>If you use other programs than Cubase to change the write-protection status of a file, you must rescan the files in the <strong>MediaBay</strong> to reflect these changes.</td>
</tr>
</tbody>
</table>
Managing Attribute Lists

In the Attribute Inspector, you can define which attributes are displayed in the Results list and in the Attribute Inspector itself. For different media types, individual attribute sets can be configured.

PROCEDURE

1. In the Attribute Inspector, click the Defined button.
2. Click the Configure Defined Attributes button to enter configuration mode.

3. Open the Show pop-up menu, activate the media types that you want to display, and click anywhere in the MediaBay.

The Attribute Inspector now shows a list of all attributes available for these media types.

• If you have activated more than one media type, your settings affect all selected types. An orange checkmark indicates that the current display settings for an attribute differ for the selected media types.

• The display settings made for the Mixed Media Types option are applied if you select files of different media types in the Results list or the Attribute Inspector.

4. Activate the attributes that you want to be displayed.
   You can edit several attributes in one go.

5. Click the Configure Defined Attributes button again to exit the configuration mode.

Defining User Attributes

You can define your own attributes and save these in the MediaBay database and the corresponding media files. Cubase recognizes all user attributes that are included in media files.

PROCEDURE

1. In the Attribute Inspector, activate the Defined button.
2. Click the Configure Defined Attributes button to enter configuration mode.

3. Click the + button.
4. In the Add User Attribute dialog, specify the Attribute Type and the Display Name.
   The display name must be unique in the attribute list. The Database Name field indicates if a certain name is valid or not.

5. Click OK.

RESULT

The new attribute is added to the list of available attributes and is displayed in the Attribute Inspector and the Results list.

Loop Browser, Sound Browser, and Mini Browser

The Loop Browser, Sound Browser, and Mini Browser show different views of the MediaBay.

The Loop Browser lets you quickly browse your loops, for example, audio files, MIDI loops, and pattern banks.

The Sound Browser lets you quickly search sounds. By default, it is set to display track presets and plug-in presets.

The Mini Browser is perfect to be placed along instruments like LoopMash or Groove Agent One.

These browser windows offer the same functions as the MediaBay, for example, you can specify different browse locations, define searches, set up the available panes, etc.

MediaBay Preferences

The Preferences dialog in Cubase contains a special MediaBay page where you can set up the MediaBay. These settings are also available from within the MediaBay.

- To display the preferences, click the MediaBay Preferences button in the lower left corner of the MediaBay.
Show Managed Locations Only
If this option is activated, all folders that are not scanned for files are hidden. This keeps the tree view in the Define Locations section less cluttered.

Use Current Selection as Base Location
If this option is activated, only the selected folder and its subfolders are shown.

Scan Folders only when MediaBay is open
If this option is activated, Cubase only scans for media files when the MediaBay window is open.
If this is deactivated, the folders are scanned in the background even when the MediaBay window is closed. However, Cubase never scans folders while playing back or recording.

Maximum Items in Results List
Specifies the maximum number of files that are displayed in the Results list. This avoids unmanageably long lists of files.

NOTE
The MediaBay does not warn you if the maximum number of files has been reached. There might be situations where a certain file you are looking for cannot be found because the maximum number of files was reached.

Allow Editing in Results List
If this option is activated, you can edit attributes in the Results list. If this option is deactivated, attributes can only be edited in the Attribute Inspector.

Show File Extensions in Results List
If this option is activated, file name extensions are displayed in the Results list.

Scan unknown File Types
When scanning for media files, the MediaBay ignores files with an unknown file extension. If this option is activated, the MediaBay tries to open and scan any file in the search location and ignores those files that cannot be recognized.
MediaBay Key Commands

You can display the available MediaBay key commands from within the MediaBay window. This is useful if you want to get a quick overview over the assigned and the available MediaBay key commands.

- To open the key commands pane, click the Key Commands button in the lower left corner of the MediaBay.
- To close the key commands pane, click anywhere outside of the pane.
- To assign or modify a key command, click the corresponding key command.

**RELATED LINKS**

Key Commands on page 997

Working with MediaBay-Related Windows

The MediaBay concept can be found throughout the program, for example, when adding new tracks or when choosing presets for VST instruments or effects. The workflow in all MediaBay-related windows is the same as in the MediaBay.

**Adding Tracks**

If you add a track by selecting Project > Add Track, the following dialog opens:
Click the **Browse** button to expand the dialog to show the **Results** list. Only file types that can be used in this context are shown.

---

**Applying Effect Presets**

If you have added an insert effect to a track, you can choose from a variety of presets via the **Results** browser for the effect slot.

**PROCEDURE**

1. In the **Inserts** tab of the **Inspector**, click the **Select Preset** icon below the preset name.

2. In the **Results** browser, double-click a preset to apply it.
Applying Track Presets

You can choose from a variety of track presets.

**PROCEDURE**
1. In the **Inspector**, click the **Preset Management** icon on the right of the **Inserts** tab.
2. Select **From Track Preset**.
3. In the **Results** browser, double-click a track preset to apply it.

**RELATED LINKS**
- Track Presets on page 160

Applying Instrument Presets

When working with VST instruments, you can choose from a variety of presets via the **Results** browser.

**PROCEDURE**
1. In the track list, right-click the instrument track and select **Load Track Preset**.
2. In the **Results** browser, double-click a preset to apply it.

Instrument Presets Results Browser

The **Results** browser for instrument track presets lets you preview VST presets and apply them to your instrument track.

To open the **Results** browser, right-click an instrument track, and select **Load Track Preset**.
VST presets for instruments can be divided into the following groups:

**Presets**

Presets contain the settings of the entire plug-in. For multi-timbral instruments, this means the settings for all sound slots as well as the global settings.

**Programs**

Programs contain only the settings for one program. For multi-timbral instruments, this means only the settings for one sound slot.

### Working With Volume Databases

Cubase stores all media file information used in the MediaBay, such as paths and attributes, in a local database file on your computer. However, in some cases, it might be necessary to browse and manage this kind of metadata on an external volume.

For example, a sound editor might have to work both at home and in a studio, on two different computers. Therefore, the sound effects are stored on an external storage medium. To be able to connect the external device and directly browse its contents in the MediaBay without having to scan the device, you have to create a volume database for the external device.

Volume databases can be created for drives of your computer or for external storage media. They contain the same kind of information about the media files on these drives as the regular MediaBay database.
NOTE

When you launch Cubase, all available volume databases are automatically mounted. Databases that are made available while the program is running have to be mounted manually.

Rescanning and Refreshing Volume Databases

If you have modified the scan settings on a different system, you must rescan or refresh the MediaBay.

RELATED LINKS

Updating the MediaBay on page 525

Creating a Volume Database

PROCEDURE

• In the Define Locations section, right-click the external storage medium, drive, or partition of your computer system that you want to create a database for, and select Create Volume Database.

IMPORTANT

You must select the topmost level (root) for this. You cannot create a database file for a lower-level folder.

RESULT

The file information for this drive is written into a new database file. When the new database file is available, this is reflected by the symbol to the left of the drive name.

NOTE

If the drive contains a large amount of data, this process may take a while.

Volume databases are automatically mounted when Cubase is launched. They are shown in the Define Locations section and their data can be viewed and edited in the Results list.
Removing a Volume Database

If you have worked on another computer using an external hard disk and return to your own computer and connect the external device again as part of your system setup, you do not need a separate volume database for it any more. Any data on this drive can then be included in the local database file again, by removing the extra database file.

**PROCEDURE**

- In the **Define Locations** section, right-click the volume database and select **Remove Volume Database**

**RESULT**

The metadata is integrated in the local **MediaBay** database file and the volume database file is deleted.

**NOTE**

If the drive contains a large amount of data, this process may take a while.

Mounting and Unmounting Volume Databases

Volume databases that are made available while Cubase is running must be mounted manually.

- To mount a volume database manually, right-click the external storage medium, drive, or partition of your computer system that you want to mount and select **Mount Volume Database**.

- To unmount a volume database, right-click it and select **Unmount Volume Database**.
Surround Sound (Cubase Pro only)

Cubase has integrated surround sound features with support for several formats. This support goes all the way through the audio path: all audio-related channels (i.e. audio and instrument tracks as well as group channels) and busses can handle multi-channel speaker configurations. A channel in the MixConsole can either carry complete surround mixes, or an individual speaker channel which is part of a surround setup.

Cubase offers the following surround-related features:

- Audio-related tracks can be routed freely to surround channels.
- The SurroundPanner V5 plug-in is automatically applied to audio-related tracks with a mono or stereo configuration that are routed to output channels with a multi-channel configuration (other than stereo). It is available in the Inspector and MixConsole and can be used to graphically position channels in the surround field.
- Cubase Pro only: The MixConvert V6 plug-in is used to convert a surround channel into a different format if the corresponding input/output configuration is not handled by the SurroundPanner V5. Cubase places MixConvert V6 automatically where needed. Furthermore, the plug-in is described in detail in the separate PDF document “Plug-In Reference”.
- Cubase supports surround-specific plug-ins, that is, plug-ins with multi-channel support specifically designed for surround sound mixing tasks (the included “Mix6to2” plug-in is an example of this). Furthermore, any VST 3 plug-in features multi-channel support and can therefore be used in a surround configuration, even if it was not specifically designed for surround. All plug-ins are described in the separate PDF document “Plug-in Reference”.
- You configure Cubase for surround sound by defining input and output busses in the desired surround format and specifying which audio inputs and outputs are used for the different channels in the busses.

**RELATED LINKS**

- Using the SurroundPanner V5 on page 562
- Using the MixConvert V6 plug-in on page 574
- Preparations on page 560
- Effects in Multi-Channel Configurations (Cubase Pro only) on page 377
Deliverables

The result of a surround mix in Cubase is either the multi-channel audio sent from the surround output bus to your dubber, or (if you use the Export Audio Mixdown feature) audio file(s) on your hard disk. Exported surround mixes can either be split (one mono file per speaker channel) or interleaved (a single file containing all the surround channels).

Available surround configurations

The following surround configurations are supported in Cubase:

LRCS

LRCS refers to Left Right Center Surround, where the surround speaker is center-rear positioned. This is the original surround format that first appeared as Dolby Stereo in cinema and later as the home cinema format Dolby ProLogic.

5.0

This is the same as 5.1 (see below) but without the LFE channel. The LFE channel is optional in 5.1 and if you do not plan to use it, you might find this option more convenient.

5.1

This format is one of the most popular in cinema and DVD. In its various cinema and DVD encoding implementations (established by different manufacturers) it is referred to as Dolby Digital, AC-3, DTS and MPEG 2 Multichannel. 5.1 has one center speaker (mainly used for speech) and four surround speakers (for music and sound effects). Additionally a subchannel (LFE – Low Frequency Effects) with lower bandwidth is used for special low frequency effects.

LRC

Same as LRCS, but without the surround speaker channel.

LRS

Left-Right-Surround, with the surround speaker positioned at center-rear.

LRC+LFE

Same as LRC but with an LFE subchannel added.

LRS+LFE

Same as LRS but with an LFE subchannel added.
Preparations

Output bus configuration

Before you can start working with surround sound, you have to configure a surround output bus, through which all the speaker channels of the selected surround format are routed.

RELATED LINKS

Adding Input and Output Busses on page 30

Child busses

A child bus is a bus within a (wider) bus. The most obvious application of a child bus is to create stereo busses within your surround bus – this allows you to route stereo tracks directly to a stereo speaker pair within the surround bus. You may also want to add child busses in other surround formats (with fewer channels than the “parent bus”).

Once you have created a surround bus, you can add one or several child busses to it by right-clicking the bus and selecting “Add Child Bus”.

RELATED LINKS

Adding Child Busses (Cubase Pro only) on page 31
Routing

You can use the Routing rack in the MixConsole to route audio-related tracks to output busses or group channels with a surround configuration.

RELATED LINKS
Setting Up Direct Routing on page 344

Routing channels to individual surround channels

If you want to place an audio source in one separate speaker channel, you can route it directly to that speaker channel. This is useful for premixed material or multi-channel recordings that do not require panning.

- To do this, simply select an individual speaker channel in the Routing rack.
- If a stereo audio channel is routed directly to a speaker channel, the left/right channels are mixed to mono.
  The pan control for the audio channel governs the balance between the left and right channel in the resulting mono mix. Center pan will produce a mix of equal proportion.

Routing channels to child busses

If you have added a child bus within a surround bus (see above), it appears as a subentry of the surround bus on the routing selector. Select this option to route a stereo audio channel directly to that stereo speaker pair of the surround bus (e.g. to route a music track directly to the left and right front speakers in a surround channel).
Input bus configuration

To work with surround sound in Cubase, it is often not necessary to configure a surround format input bus. You can record audio files via standard inputs, and easily route the resulting audio channels to surround outputs at any stage. You can also directly import multi-channel files of a specific surround format onto audio tracks of the same format.

You should add a surround input bus in the following circumstances:

- You have existing audio material in a specific surround format, and you wish to transfer this material into Cubase as a single, multi-channel file.
- You wish to record a surround setup “live”.
- You have prepared surround premixes (e.g. stems) that you want to record on a new audio track with a surround configuration.

Using the SurroundPanner V5

Cubase has a special feature for graphically positioning a sound source in the surround field or modifying existing premixes: the SurroundPanner V5. This plug-in distributes the audio from the input channels in various proportions to the output surround channels.

Whether the SurroundPanner V5 can be used for a specific input/output configuration, depends on whether this configuration can be mapped by the panner. The plug-in supports mapping of mono or stereo inputs to any surround configuration, as well as setups where the input and output channels have the same configuration. In all other cases (e.g. 5.1 to stereo), the MixConvert V6 plug-in is used to map the channel configuration.

While you need to open the plug-in panel to access all of the panner features, you can perform basic panning operations also in the following places:

- In the MixConsole, a miniature view of the surround plug-in appears at the top of the fader section.
  You can click and drag directly in the miniature image to move the signal source in the surround field.
In the Inspector, a miniature surround pan control can be displayed in the Surround Pan section. This panner view offers click and drag panning as well as speaker channel icons reflecting the solo/mute and deactivation states.

**NOTE**

In all miniature panner views you can scale down your movements by holding the [Shift] key while moving the sound source. This allows you to make fine adjustments.

**RELATED LINKS**

Using the MixConvert V6 plug-in on page 574
The plug-in panel

Double-click on any of the miniature panner controls to open the plug-in panel in a separate window.

The SurroundPanner V5 plug-in offers numerous possibilities to position a mono or stereo sound source. If you work visually oriented, you can simply drag the sound source around in the pan area. To help you execute very exact movements you can use modifier keys to limit the movement direction (e.g. for straight front/rear panning).

To perform rotating movements that you cannot achieve by dragging the mouse, you can use the powerful rotation and orbit controls below the pan area. Here you will also find parameters for controlling the signal distribution to the different speaker channels and the advanced scaling controls with which you can influence the size of the sound source itself.

To the left and right of the surround field there are volume meters, showing the input and output levels of all speaker channels. For a detailed description of all the panning options available in the SurroundPanner V5, see below.
Positioning signals in the pan area

In the pan area, you see a graphical representation of the sound source, with the left and right channels shown in yellow and red.

Here, you can position the sound source using the mouse:

- By clicking at the desired position in the pan area.
  When you release the mouse button, the sound source jumps to that position (with the positioning handle, i.e. the circle located in the center of the sound source, ending up where you clicked).

- By clicking and dragging the positioning handle.
  Note that you do not have to click exactly on the handle in order to move it. You can click anywhere in the pan area and start moving the mouse, the handle then moves in the same direction as the mouse.

The pan area showing a stereo sound source

1) Left and right channels
2) Positioning handle

The positioning handle can be positioned freely in the pan area and even be moved out of the pan area. The panning balls, though, will never move further out than the edge of the surround field (which is indicated by a gray line). Moving the positioning handle out of the pan area can be useful for extreme panning positions, such as panning all channels hard right.

**NOTE**

For mono channels there is no positioning handle. Click and drag the input channel to position it.
Speaker channels – Solo and Mute vs. Disabling

The speakers that are distributed around the surround field represent the output configuration. You can disable speakers or solo/mute them.

- This speaker is muted.
- This speaker is soloed.
- This speaker is disabled.

- [Alt]/[Option]-click on a speaker symbol to disable that speaker (the speaker symbol is grayed out) so that no audio will be routed to this surround channel. The signal that would otherwise be sent to this speaker is distributed to the other speakers instead. Note that the signal is distributed in such a way that the power level stays constant all the time.

- Click on a speaker symbol to solo that speaker (the speaker symbol turns red). That way you will only hear the signal sent to this speaker. All other speakers are muted (yellow speaker symbol). This can be used for testing purposes, e.g. to make sure that a signal is sent to a specific speaker as intended. Note that you can solo several speakers at the same time by clicking on them one after the other. By [Ctrl]/[Command]-clicking on a speaker symbol, this speaker is soloed exclusively, and all other speakers are muted.

**NOTE**

Solo and Mute cannot be automated!

**RELATED LINKS**

Constant power on page 574

Restricting movement

By default, you can click anywhere in the pan area and drag the mouse to move the sound source. If you want the positioning handle to jump to a specific position, you can click once at that position.

However, you can also limit movement to a specific direction, using the corresponding modifier keys (or the arrow icons above the pan area). That way you can scale down your movements, or have the sound source move along a certain axis (e.g. from bottom left to top right).

- When you press a modifier key (e.g. [Ctrl]/[Command]), the corresponding icon above the pan area is highlighted with a lighter border, indicating that this mode is active. As soon as you release the modifier key, you return to standard mode.
• By clicking on one of the icons above the pan area, the corresponding positioning mode is activated persistently. That way you do not have to keep the corresponding modifier key pressed all the time.

To deactivate the selected positioning mode, switch back to standard mode.

The following modes are available:

<table>
<thead>
<tr>
<th>Icon</th>
<th>Modifier key(s)</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Icon]</td>
<td>![Modifier key(s)]</td>
<td>![Description]</td>
</tr>
<tr>
<td>-</td>
<td>![Modifier key(s)]</td>
<td>![Description]</td>
</tr>
<tr>
<td>![Modifier key(s)]</td>
<td>![Description]</td>
<td></td>
</tr>
<tr>
<td>![Modifier key(s)]</td>
<td>![Description]</td>
<td></td>
</tr>
<tr>
<td>![Modifier key(s)]</td>
<td>![Description]</td>
<td></td>
</tr>
<tr>
<td>![Modifier key(s)]</td>
<td>![Description]</td>
<td></td>
</tr>
</tbody>
</table>

**Panning the left and right channels independently with the mouse**

At the top right of the plug-in window you will find the button for the independent positioning mode. If this is activated, you can adjust the left and right input channels (yellow and red balls) independently by clicking and dragging. This is similar to using the two surround pan joysticks found on some hardware consoles.

1) The right channel is panned independently with the mouse.
2) The independent positioning mode is activated.

**NOTE**

To move one of the panning balls in this mode, you do not have to click directly on them. You will always move the panning ball that is nearer to the position of the mouse pointer.
IMPORTANT

- When panning in independent positioning mode, automation data is written for several parameters. Due to this, special automation rules apply.

- Automation data for the independent positioning mode is always written for the complete sound source, not for individual channels. This means it is not possible to record automation for one stereo channel and then add automation for the other stereo channel in a second go, for example.

RELATED LINKS

Automation on page 573

Overview Mode

When moving the sound source in the pan area, you will notice that the positioning handle can leave the visible pan area (although the channel panning balls cannot). It can be moved so far outside that all channels end up on the perimeter where the positioning handle left the area. If you now use one of the rotation controls, for example, it can be quite hard to understand what is happening, i.e. why the panning balls are moving the way they are.

To get a better understanding of this behavior, you can switch to Overview Mode. Here you can see where the positioning handle is actually located and where the panning balls would be (if they could leave the pan area). These virtual or "ghost" positions are connected to the actual panning balls inside the surround field by a thin line to help you understand complex movements.

1) The left and right channels cannot leave the pan area.
2) “Ghost” images of the panning balls. These are the theoretical positions outside the visible pan area.
3) The positioning handle is located outside the pan area.

- To switch to Overview Mode, click on the eye icon above and to the left of the pan area.
NOTE
The Overview Mode is only used for visualizing the complex scenarios that you can create with the SurroundPanner V5. The actual panning is done in the standard view. Therefore, the speakers are visible in this mode, but cannot be soloed/muted or disabled.

Left-right and front-rear panning

These two controls are used to pan the sound source from left to right and front to rear, and vice versa.

NOTE
This is the same as restricting the movement direction using the [Ctrl]/[Command] and [Ctrl]/[Command]-[Shift] modifiers.

Rotating signals

The Rotate Signal control is used to rotate the source channels around the positioning handle. All input channels circle around the handle (but they cannot move beyond the borders of the surround field).

Orbit controls

The Orbit controls are used to rotate the sound source (including all input channels and the positioning handle) around the center of the surround field.

1) Orbit Center
2) Radius
**Surround Sound (Cubase Pro only)**

**Using the SurroundPanner V5**

**Orbit Center**

This is the main control that allows you to perform the rotation.

**Radius**

When using the Orbit Center control, the Radius encoder allows you to control the distance of the sound source from the center of the surround field (without changing the angle).

An example:

- **a) Radius = 141.4**

- **b) Radius = 116.5**

The gray circle shows the theoretical path of the sound source when orbiting the center. Since the sound source cannot leave the pan area, it moves along the perimeter instead. At the maximum radius setting (a) the theoretical path lies outside the pan area so that the sound source stays on the perimeter all the time; at a smaller setting (b) the circle is smaller and the sound source moves inside the pan area in the corners.

**NOTE**

The Rotate Signal, Orbit Center, and Radius controls are endless rotary encoders so that there is no limit as to how far left or right you can rotate the sound source.

**IMPORTANT**

In terms of automation, the Orbit Center, and Radius controls are not independent parameters as such. Instead, a combination of different automation parameters is used.

**RELATED LINKS**

[Automation on page 573](#)
The LFE encoder

Use the LFE encoder in the plug-in panel to set the signal amount sent to the LFE (Low Frequency Effects) channel.

**NOTE**
The LFE channel is used as a full range channel, no low-pass filtering is applied.

Center Distribution

The Center Distribution control is used to distribute part or all of the center signal to the left and right front speakers.

For example, this can be useful in the following situation: The center signal is panned directly to the center speaker and the Center Distribution is set to 0%. However, the signal is too discrete for your liking, and you want to add part of the signal to the left and right front speakers to widen it. You can do this by raising the Center Distribution value. At 100%, the center source is provided entirely by the phantom image created by the left and right speakers and using a value in between you can distribute the signal to the three speakers.

A blue line at the top of the surround field indicates the distance up to which a phantom signal is added. If you position the source signal inside this range, the signal is sent to all three channels.

**IMPORTANT**
Note that for this to work, the front speaker configuration needs to be symmetrical and there can never be more than 3 speakers involved.

Divergence controls

The three divergence controls (Front, F/R, and Rear) determine the attenuation curves used when positioning sound sources for X-axis front, Y-axis (front/rear), and X-axis back. If all three controls are set to 0%, positioning a sound source on a speaker sets all other speakers to zero level. With higher values, the other speakers receive a percentage of the sound source.
Blue horizontal and vertical lines visualize the effects when changing the divergence settings.

For example, by using the front divergence, you can acoustically intensify the distance from the action on screen as perceived by the audience.

- At 0% the perception is very focused (concentrated in one spot).
- At 100% the perception is very diffuse (hard to locate).

**NOTE**
The Center Distribution value and the front divergence are combined. If the front divergence is set to 100%, the Center Distribution has no effect.

## Scaling

The Scale controls allow you to control the horizontal (Width) and vertical (Depth) expansion of the sound source. 100% corresponds to the complete width or depth of the surround field. If you reduce both values to 0%, the distance is reduced to zero and all source channels are centered in one spot.

These controls influence the perception of spatiality and ambience, as well as the traceability of signals.

- At 100% you get a very transparent, clear sound that conveys much spatiality.
- At 0% the signal is less transparent and movements cannot be traced easily.

**NOTE**
The Depth parameter is only available for configurations with front and rear channels.

## Input and output level meters

The meters to the left and right of the pan area show the volume of all input and output speaker channels, respectively. The numeric values below the meters indicate the peak level that has been measured for any of the channels.
**General plug-in controls**

**The Bypass Effect button**
At the top left of the plug-in panel you will find a button to bypass the SurroundPanner V5. If this is activated, the panner attempts to route the input signals to the appropriate output channels (e.g. the left and right front speakers if panning a stereo signal to a 5.1 configuration).

**Mute/Solo buttons**
At the top of the plug-in panel you will find a Mute and a Solo button that are identical with the channel’s Mute/Solo controls.

**Read/Write buttons**
Like any other effect plug-in, the SurroundPanner V5 has Read and Write buttons at the top of the window to apply and record automation data (see below).

**RELATED LINKS**
* Using Solo and Mute on page 322

**Automation**

Most of the parameters in the SurroundPanner V5 plug-in can be automated just like any other channel or insert parameter.

Recording automation for the Orbit controls and the independent positioning mode is handled differently, however. Automation data for these parameters is written as a combination of the front-rear panning, left-right panning and the Rotate Signal parameters. For the independent positioning mode, Scaling is added. Due to this you cannot easily modify existing automation data since this would involve too many different parameters. If an automation pass did not yield the desired result, simply try again.

**RELATED LINKS**
* Writing Automation Data on page 577

**Resetting all parameters**

[Alt]/[Option]-click the Reset button in the lower right corner of the plug-in panel to reset all controls to their default values.
**Constant power**

“What goes in, must come out again.” This principle can be taken literally with regard to the SurroundPanner V5. It means that the power of a source channel is identical to the power of the corresponding output signal.

The advantage of this is that the overall volume as perceived by the listener (= the power) is always the same, regardless of the signal panning, e.g. when you move the sound source in the pan area, disable specific speaker channels, or use the divergence controls.

**Using the MixConvert V6 plug-in**

MixConvert V6 is a special plug-in that converts one multi-channel audio source into another multi-channel destination. It is most frequently used to “downmix” a multi-channel surround mix into a format with fewer channels, for example, a 5.1 surround mix into a stereo mix.

This plug-in can be used as an insert effect in the MixConsole like other plug-ins but it also has special functions. Cubase automatically inserts MixConvert V6 instead of the SurroundPanner V5 when the channel (audio track, group channel, etc.) is routed to a destination with fewer audio paths. MixConvert V6 is also inserted in place of any cue send panner when the destination has a different audio path than the source.

The MixConvert V6 plug-in is described in detail in the separate PDF document “Plug-in Reference”.

**NOTE**

There is one exception to this behavior. When a stereo channel is routed to a mono destination through the channel routing or a cue send routing, a normal stereo panner will be inserted. However, this panner will control the balance of the left and right channels as they are blended into the mono destination. The center position blends both channels together by equal amounts. With the pan set all the way to the left, only the left channel can be heard, and vice versa.

**Exporting a surround mix**

When you have set up a surround mix, you can choose to export it using the Export Audio Mixdown function.

You have the following export options when working with a surround configuration:

- Export to “split” format, resulting in one mono audio file for each surround channel.
- Export to interleaved format, resulting in a single multi-channel audio file (e.g. a 5.1 file, containing all six surround channels).
On Windows systems, you can also export a 5.1 surround mix to a file in Windows Media Audio Pro format.
This is an encoding format tailored for 5.1 surround.

**RELATED LINKS**
- Export Audio Mixdown on page 938
- Windows Media Audio Pro files (Windows only) on page 951
In essence, automation means recording the values for a particular MixConsole or effect parameter. When you create your final mix, Cubase can adjust this particular parameter control.

**Automation Curves**

Within a Cubase project, the changes in a parameter value over time are reflected as curves on automation tracks.

There are two kinds of automation curves:

1) **Ramp curves**
   Ramp curves are created for any parameter that generates continuous multiple values, such as fader or encoder movements.

2) **Jump curves**
   Jump curves are created for on/off parameters such as mute.

**Static Value Line**

When you open an automation track for the first time, it does not contain any automation events. This is reflected in the event display as a straight horizontal black line, the static value line. This line represents the current parameter setting.

If you manually added any automation events or used write automation for the corresponding parameter and then disable the reading of automation data, the automation curve is grayed-out in the event display and the static value line is used instead.

As soon as **Read** is enabled, the automation curve becomes available.
Write/Read Automation

You can automation enable tracks and MixConsole channels by activating their automation write W and read R buttons.

- If you activate W for a channel, virtually all MixConsole parameters that you adjust during playback for that specific channel are recorded as automation events.
- If R is activated for a channel, all your recorded MixConsole actions for that channel are performed during playback.

The R and W buttons for a track in the track list are the same as the R and W buttons in the MixConsole.

**NOTE**

The R button is automatically enabled when you enable the W button. This allows Cubase to read existing automation data at any time. You can separately deactivate W if you only want to read existing data.

There are also global read and write indicator buttons **Activate/Deactivate Read/Write for All Tracks** on the MixConsole toolbar and at the top of the track list. These buttons light up as soon as there is an enabled R or W button on any channel/track within your project. Furthermore, they can be clicked to activate or deactivate the R/W buttons of all tracks simultaneously.

**NOTE**

R/W buttons are also available on the Automation panel.

**RELATED LINKS**

Read/Write Buttons on page 585

Writing Automation Data

There are two approaches that you can use to create automation curves: manually and automatically.

- Manual writing makes it easy to quickly change parameter values at specific points without having to activate playback.
- Automatic writing lets you work almost as if you were using a real mixer.

With both methods, any applied automation data is reflected in both the MixConsole (a fader will move for example) and in the corresponding automation track curve.

**RELATED LINKS**

Manual Writing of Automation Data on page 578
Automatic Writing of Automation Data

Every action that you perform is automatically recorded on automation tracks which you can later open for viewing and editing.

**PROCEDURE**

1. In the track list, click **Show/Hide Automation** for a track to open its automation track.

2. Click **W** to enable the writing of automation data on this track.

3. Start playback.

4. Adjust the parameters in the **MixConsole**, in the **Channel Settings** window, or in the effect control panel.
   
   The value settings are recorded and displayed as a curve on the automation tracks. When automation data is being written, the color of the automation track changes to red and the delta indicator in the automation track shows the relative amount by which the new parameter setting deviates from any previously automated value.

5. Stop playback and return to the position where you started playback.

6. Click **W** to disable the writing of automation data.

7. Start playback.

**RESULT**

All actions that you recorded are reproduced exactly. When you drag a plug-in to a different insert slot on the same channel, any existing automation data moves with the plug-in. When you drag it to an insert slot on a different channel, any existing automation data is not transferred to the new channel.

Manual Writing of Automation Data

You can add automation events manually by drawing automation curves on an automation track.

**PROCEDURE**

1. In the track list, click **Show/Hide Automation** for a track to open its automation track.

2. Click the automation parameter name and select the parameter from the pop-up menu.

3. Select the **Draw** tool.
4. Click on the static value line.
   An automation event is added, read automation mode is automatically activated, and
   the static value line changes to a colored automation curve.

5. Click and hold to draw a curve by adding many automation events.
   When you release the mouse button, the number of automation events is reduced.

   **NOTE**
   To adjust the thinning out of events, select **File > Preferences > Editing** and change
   the **Automation Reduction Level**.


**RESULT**
The automated parameter changes with the automation curve, and the
 corresponding fader in the MixConsole moves accordingly.

**AFTER COMPLETING THIS TASK**
Repeat the procedure if you are not happy with the result. If you draw over existing
 events, a new curve is created.

**Tools for Drawing Automation Data**

Apart from the **Draw** tool, you can use the following tools to draw automation
 events:

- **Object Selection** tool
  If R is activated and you click on an automation track with the **Object Selection** tool, you can add automation events.

   **NOTE**
   Events that are introduced between two existing events that do not deviate
   from the existing curve are removed as soon as you release the mouse button.

To activate the **Line** tool in any other available mode, click the **Line** tool and click
 again to open a pop-up menu where you can select the mode.

![Line tool modes](image)

The following **Line** tool modes are available:

**Line mode**
If you click on the automation track and drag with the **Line** tool in **Line** mode,
 you can create automation events in a line. This is a quick way to create linear
 fades, etc.
Parabola mode

If you click and drag on the automation track with the Line tool in Parabola mode, you can create more natural curves and fades.

**NOTE**
The result depends on the direction from which you draw the parabolic curve.

Sine, Triangle, or Square mode

If you click and drag on the automation track with the Line tool in Sine, Triangle, or Square mode and snap to grid is activated, the period of the curve (the length of one curve cycle) is determined by the grid setting. If you press [Shift] and drag, you can set the period length manually, in multiples of the grid value.

**NOTE**
The Line tool can only be used for ramp type automation curves.

Editing Automation Data

Automation events can be edited much like other events.

You can cut, copy, paste, and nudge events, etc.

- If you move an event or part on a track and you want the automation events to follow automatically, select **Edit > Automation follows Events**.
  All automation events for the track between the start and end of the event or part are moved. Any automation events at the new position are overwritten.

Selecting Automation Events

- To select an automation event, click it with the **Object Selection** tool.
  The event turns black, and you can drag it in any direction between two events.

- To select multiple events, [Shift]-click the events or drag a selection rectangle with the **Object Selection** tool.
  All events inside the selection rectangle are selected and the automation track editor becomes available.

- To select all automation events on an automation track, right-click the automation track and select **Select All Events** from the context menu.
Removing Automation Events

- To remove an automation event, click on it with the Erase tool.
- To remove multiple automation events, select them and press [Backspace] or [Delete] or select Edit > Delete.
  When Use Virgin Territory is enabled, this creates a gap. When disabled, the events within the range are removed.
- To remove all automation events from the automation track and close the automation track, click the automation parameter name in the track list and select Remove Parameter from the pop-up menu.

**NOTE**

When removing automation events, the curve is redrawn to connect the remaining events.

**RELATED LINKS**

Virgin Territory vs. Initial Value (Cubase Pro only) on page 584

Adjusting Automation Ramp Curves

You can adjust automation ramp curves in the automation track editor.

- To open the automation track editor, activate the Object Selection tool and drag a selection rectangle on a ramp type automation track.

On the borders of the automation track editor, smart controls for specific editing modes are displayed:

- To move the entire curve up or down, click in an empty area on the upper border of the editor. This is useful to boost or attenuate a curve.

- To raise or lower the values in relative amounts, click in the middle of the upper border of the editor.
To tilt the left or the right part of the curve, click in the upper left or right corner of the editor. This is useful if the curve form is exactly the way that you want it, but the start or end needs to be boosted or attenuated a bit.

To compress the left or the right part of the curve instead, [Alt]/[Option]-click in the upper left or right corner of the editor.

To scale the curve around the absolute center, for example, horizontally around the center of the editor, click in the middle of the right border of the editor.

To scale the curve relative to its center instead, [Alt]/[Option]-click in the middle of the right border of the editor.

To stretch the selected curve, click and drag in the lower part of the editor. [Shift]-click on any of the smart controls to scale vertically.

To scale the automation curves on several tracks at the same time, drag a selection rectangle across the corresponding automation tracks, hold down [Ctrl]/[Command], and use the scaling smart controls.

To move the whole selection up/down or left/right, click inside the editor and drag.

To restrict the direction to horizontal or vertical movement, press [Ctrl]/[Command] and drag.

**NOTE**

Snap is taken into account when moving automation curves horizontally.

---

**Automation Tracks**

Most of the tracks in your project have automation tracks, one for each automated parameter.

Automation tracks are hidden by default.
Showing/Hiding Automation Tracks

- Position the mouse pointer over the lower left corner of the track and click the arrow icon (Show/Hide Automation) that appears.
- Right-click the track in the track list and select Show/Hide Automation from the context menu.
- To open another automation track, position the mouse pointer over the lower left corner of an automation track, and click + (Append Automation Track).
- To show all used automation tracks in the track list, right-click any track and select Show All Used Automation from the context menu.
- To open the corresponding automation track on writing automation parameters, select Automation Panel > Automation Settings > Reveal Parameter on Write.

Removing Automation Tracks

- To remove an automation track together with all automation events, click the parameter name and from the pop-up menu, select Remove Parameter.
- To remove all automation tracks from a track that do not contain automation events, select Remove Unused Parameters from any of its automation parameter name pop-up menus.
- To remove automation tracks, you can also select Project > Automation Panel > Functions and select one of the options to delete automation.

Assigning a Parameter to an Automation Track

Default parameters are already assigned to automation tracks when you open them, according to their order in the parameter list.

**PROCEDURE**

1. Open an automation track and click on the automation parameter name.
   A parameter list is shown. The contents depend on the track type.
2. From the pop-up menu, select the parameter or select More to open the Add Parameter dialog that lists all parameters that can be automated, and select the parameter there.
3. Select the Parameter.
   The parameter replaces the current parameter in the automation track.

**NOTE**

The replacing of the automation parameter is non-destructive. If the automation track contains any automation data for the parameter that you just replaced, this data is there, although it is not visible. By clicking on the automation parameter name in the track list, you can switch back to the replaced parameter. On the pop-up menu, all automated parameters are indicated by an asterisk (*) after the parameter name.
Muting Automation Tracks

By muting an automation track you turn off automation for a single parameter.

- To mute individual automation tracks, click their Mute buttons in the track list.

Virgin Territory vs. Initial Value (Cubase Pro only)

For parameter automation, Cubase works either with an initial value or with virgin territory.

When no automation data exists for a particular parameter, the starting point of an automation pass is saved as the initial value. When you punch out of the automation pass, it is this initial value to which the parameter will return. This has one important consequence: As soon as the initial value is set, the corresponding parameter is fully automated for the complete track, at any given timecode position of the project – even if your automation pass lasted only 2 seconds. When you release a control, it returns to the value that is defined by the automation curve – even when in Stop mode.

When you enable Use Virgin Territory, no automation curve is displayed on the automation track, and you find automation data only where you actually perform an automation pass. After an automation pass you will find virgin territory only to the right of the last automation event.

Creating Gaps

Gaps are empty sections between two automation curves. You can create gaps inside a section with automated values.

**PROCEDURE**

1. Select Project > Automation Panel.
2. Click Automation Preferences, and activate Use Virgin Territory.
3. With the Range Selection tool, select a range on an automation track with existing automation data, and press [Delete] or [Backspace].

**RESULT**

A gap is created, and new events at the beginning and the end of the selection range are created. These mark the end point of the automation curve to the left and the start of the next automation curve to the right of the gap.
Defining a Terminator Point

You can define any automation event on the automation curve as the terminator point of this part of the curve. This will automatically delete the line between this event and the next one, creating a gap.

**PROCEDURE**

1. In the automation curve, click the event that you want to define as the last point to select it.
2. In the **Project** window info line set **Terminator** to **Yes**.
   The line between this event and the next one is deleted and a gap is created.

**NOTE**

If you define the last automation event of an automation curve as terminator point, any automation data to the right of this event (as defined by an initial value) is deleted.

Automation Panel

The Automation panel is a floating window, similar to the MixConsole and Transport panel, and can be left open while you work.

To show the Automation panel, do one of the following:

- Select **Project > Automation Panel**.
- On the **Project** window toolbar, click **Open Automation Panel**.
- Press [F6].

Read/Write Buttons

In the upper part of the Automation panel, you will find the **Read** and **Write** buttons. These are used to globally enable or disable the **Read** and **Write** buttons on all tracks.

- To enable all **Read** buttons on all tracks/channels of your project, click **Activate Read for all tracks**.
- To disable all **Read** buttons, click **Deactivate Read for all tracks**.
- To enable all **Write** buttons and, at the same time, all **Read** buttons on all tracks/channels of your project, click **Activate Write for all tracks**.
- To disable all **Write** buttons, click **Deactivate Write for all tracks**. The **Read** buttons will remain enabled.
Automation Modes

Cubase provides three different punch out modes for automation: Touch, Auto-Latch, and Cross-Over. In all three modes, automation data will be written as soon as a parameter control is touched in play mode. They differ in their punch out behavior.

The automation modes are available on the upper part of the Automation panel and on the Project window toolbar on the Global Automation Mode pop-up menu.

You can change the automation mode at any time, for example, in play or stop mode or during an automation pass. You can also assign key commands to the automation modes.

The current automation pass will always punch out as soon as one of the following conditions is met, independent of which automation mode is selected:

- If you disable Write.
- If you stop playback.
- If you activate Fast Forward/Rewind.
- If the project cursor reaches the right locator in Cycle mode.
- If you click in the ruler to move the project cursor. This is user-definable and can be controlled via the Automation panel.

RELATED LINKS
Automation Settings on page 594

Touch

Touch mode is useful in situations where you want to make a change lasting only a few seconds to an already set up parameter.

- Touch writes automation data only for as long as you actually touch a parameter control. Punch out occurs as soon as you release the control.
- After punch out, the control returns to the previously set value.
NOTE
You can set the time it takes for the parameter to reach the previously set value with the Return Time setting in the Automation Preferences.

RELATED LINKS
Automation Settings on page 594

Auto-Latch

Auto-Latch is useful in situations where you want to keep a value over a longer period of time – for example when making EQ settings for a particular scene. In Auto-Latch mode, there is no specific punch out condition other than those that are valid in all modes.

- Once your pass has started, the writing of automation data continues for as long as playback lasts or Write is enabled.
- When you release the control, the last value is kept until you punch out.

NOTE
The automation mode for On/Off switches is always Auto-Latch even if another mode is selected globally or for the track.

Cross-Over

Cross-Over mode allows you to perform a manual return to ensure smooth transitions between new and existing automation settings. For Cross-Over, the punch out condition is crossing over an already existing automation curve after touching the parameter for a second time. The Cross-Over mode can be used in situations where you are not satisfied with an automation curve or with the automatically applied return settings.
• Once your pass has started, the writing of automation data continues for as long as playback lasts or **Write** is enabled.

• When you release the control the automation pass continues, with the value setting remaining the same.

• When you re-touch the fader and move it towards the original value, punch out occurs automatically as soon as you cross the original curve.

**RELATED LINKS**

*Automation Settings on page 594*

---

**Trim**

Trim allows you to modify the automation curve from a previous pass. If you activate **Trim**, a trim curve is positioned in the middle of the automation track.

**NOTE**

Trim works for channel volume and cue send level adjustments.

If you activate **Trim**, all editing and recording affects the trim curve. If you deactivate Trim, it affects the original automation curve instead.

You can edit trim data like any other automation data. It is stored with the project.
• Drag the trim curve up or down and add automation events to it. These increase or decrease the values of the original automation curve, but allow you to preserve the original data.

You can use Trim either in Stop or in Play mode:

• In Stop mode, you can edit the trim curve manually by clicking on it and moving it up or down. The original automation curve is displayed in a lighter color and its values are merged with the trim curve. The resulting automation curve is displayed in a darker color.

• In Play mode, the events of the original automation curve are trimmed as the project cursor passes over them.

Freeze Trim

You can freeze your trim curve automatically or manually. This renders all trim data into a single automation curve.

• To freeze your trim curve automatically whenever a write operation is finished, open the Automation Settings and select On Pass End in the Freeze Trim pop-up menu.

• To freeze your trim curve automatically when Trim mode is switched off, open the Automation Preferences and select On Leaving Trim Mode in the Freeze Trim pop-up menu.

• To freeze your trim curve manually, open the Automation Settings and select Manually in the Freeze Trim pop-up menu. To freeze a specific parameter for the track click the parameter name and from the pop-up menu select Freeze Trim.

To freeze the trim automation for all tracks in the project, open the Automation panel, and in the Functions pop-up menu select Freeze All Trim Automation in Project.

• To freeze the trim automation of all selected tracks, open the Automation panel, and in the Functions pop-up menu select Freeze Trim Automation of Selected Tracks.

Functions

At the top right of the Automation panel, you will find the Functions pop-up menu, which contains a number of global automation commands.

Delete All Automation in Project

Removes all automation data from your project.

Delete Automation of Selected Tracks

Removes all automation data for the selected tracks.
Delete Automation in Range

Deletes all automation data between the left and right locators on all tracks.

Fill Gaps on Selected Tracks

This option is used with virgin territories. Select this to fill any gaps in the automation curves of the selected tracks with a continuous value. The value of the last event (the end point) of a section is used to fill the gap. This value is written across the gap up to one millisecond before the first event of the next automated section. A new event is inserted here; the value will be ramped to the next automated section.

Fill Gaps with Current Value (Selected Tracks)

This option is used with virgin territories. Select this option to fill any gaps in the automation curves of the selected tracks. The gaps are filled with the current value of the corresponding control.

Create Initial Parameter Events

This function creates and stores the initial automation values for each automatable parameter in the MixConsole. For parameters that have not been automated yet, automation events are created at the current parameter position, for example, at value 0. As initial parameter events are created on all channels, all channels will have automation data, even if you did not add automation to them. If this is not what you want, use the Global Snapshot function instead.

Freeze All Trim Automation in Project

Freezes all trim automation for all tracks in the project.

Freeze Trim Automation of Selected Tracks

Freezes all trim automation for the selected tracks.

Global Snapshot: Store

Use this function to save a backup copy of all automatable MixConsole parameters as a snapshot so that you can reapply them later. The snapshot is saved with the project. You can only save one snapshot at a time. By storing a snapshot, a previously stored snapshot may be overwritten.

Global Snapshot: Apply

Applies the stored snapshot.

Global Snapshot: Remove

Removes the stored snapshot.

Fill Options

The Fill options define what happens in a specific section of your project when you punch out of a running automation pass.

The Fill options write one particular value across a defined section of your automation track. Any previously created data within this section is overwritten.

You can also combine the various Fill options.
Activating To Punch

PROCEDURE
1. On the Automation Panel, activate Touch, and activate To Punch as Fill option.
2. Start playback.
3. Move the fader until you have found the volume setting that you need and release the fader to punch out.
   The volume curve is set from the point of punch out back to where you punched in. The values written while moving the fader to find the right value are deleted, and the volume jumps at exactly the right moment from the value set in the first scene to the value found for the second scene.

Activating To Start

PROCEDURE
1. On the Automation Panel, activate Touch, and activate To Start as Fill option.
2. Start playback.
3. Move the fader until you have found the volume setting that you need and release the fader to punch out.
   The automation track is filled from where you punched out to the start of the project.

Activating To End

PROCEDURE
1. On the Automation Panel, activate Touch, and activate To End as Fill option.
2. Start playback and touch the parameter control to punch in the automation pass.
3. Move the fader until you have found the setting that you want and release it.
   This will punch out the writing of automation data. As you let go of the fader, the automation curve takes the found value setting, from where you punched out to the end of the project.
Activating Loop

**PREREQUISITE**

You have set up a loop range with the left and right locators.

**PROCEDURE**

1. On the Automation Panel, activate **Touch**, and activate **Loop** to activate it as Fill option.
2. Start playback.
3. Move the fader until you have found the volume setting that you need and release the fader to punch out.

   The found value is set within the range that is defined by the left and right locators.

One Shot vs Continuous Fill

You can use the **Fill** options in two different ways:

- **One shot**
  
  When you click one of the **Fill** buttons, it is highlighted, and will be enabled during the next automation pass. Afterwards, the option is disabled again.

- **Continuous fill**
  
  If you click a **Fill** button a second time, a lock symbol is displayed on the highlighted button, indicating that you are in continuous fill mode and that the operation can be repeated as many times as you want. Click the button a third time to disable the corresponding **Fill** option.

Drawing Fill Manually

You can use the **Fill** options on the Automation panel in combination with the **Draw** tool. This provides you with a powerful method for writing automation data manually.

**PROCEDURE**

1. Open an automation track and select the **Draw** tool.
2. On the **Automation Panel** select **To End** as a Fill option.
3. Click and draw to create an automation curve.
4. Release the mouse button.

   At the moment of release, a final automation event is created. The automation curve is written from this last event through to the end of the project.

   **NOTE**

   This procedure can be used with all the **Fill** options.
Suspend Options

This section on the Automation Panel allows you to exclude specific parameters from the reading or writing of automation data. This way, you have full manual control of these parameters.

Suspend Read

Suspending Read for a specific parameter during automation gives you full manual control of it.

- To suspend the reading of automation data for a specific parameter, click the corresponding parameter.
- To suspend the reading of automation data for all parameters/parameter groups, click the All button.

**NOTE**
When any of the options in the Suspend Read category are enabled, clicking All will disable these buttons.

**EXAMPLE**
Imagine that you have already automated several tracks. While working on the current track, you want one of the other tracks to be louder, to better identify a particular position in your audio material.

By suspending Read for the Volume parameter, you regain full manual control and can set the volume to the required level.

Suspend Write

Suspending Write for a specific parameter during automation punches this parameter out of the automation pass.

- To suspend the writing of automation data for a specific parameter, click the corresponding parameter.
- To suspend the writing of automation data for all parameters/parameter groups, click the All button.

**NOTE**
When any of the options in the Suspend Write category are enabled, clicking All will disable these buttons.
EXAMPLE

Imagine the following situation: To help you concentrate while working on a particular track, you mute several other tracks. However, because write automations are active on these tracks, this mute state is also automated during the next automation pass – a classic situation in mixing.

To avoid inadvertently excluding whole tracks from your mix in this way, you can exclude Mute from all automation writing. Simply click Mute in the Suspend Write category on the Automation panel.

Show Options

The Show options allow you to open all automation tracks for a specific parameter. This gives you an overview of the automated parameter.

- To open the volume, pan, EQ, sends, or inserts automation tracks for all tracks, click the corresponding parameter. The automation tracks are opened even if no automation data was recorded on these tracks.

- To step through the individual parameter sets of parameter groups, for example Pan, EQ, Sends, and Inserts, click the respective button repeatedly.

- To show only the automation tracks for which automation data has already been written, activate Used Only and click one of the options.

- To show all automation tracks that contain automation data, activate Show Used.

- To hide all open automation tracks, activate Hide All.

NOTE

The Show options on the Automation panel affect all tracks.

Automation Settings

To set up specific automation preferences, click the button in the bottom left of the Automation panel.

Show Data on Tracks

Activate this to show audio waveforms or MIDI events on automation tracks. The events are displayed only if Show waveforms (File > Preferences > Event Display > Audio) is enabled and if Part Data Mode (File > Preferences > Event Display > MIDI) is set to an option other than No data.

Use Virgin Territory

Activate this if you want to use virgin territories.
Automation
MIDI Controller Automation

Continue Writing
If you activate this option, the recording of automation will not be blocked when locating to a new position. This can be used to perform multiple automation passes in Cycle mode or if you are using the arranger functions.

If this option is deactivated and you write automation data and locate to another position in the project, the writing will be stopped until the mouse button is released or until a Stop command is received.

Reveal Parameter on Write
If you activate this option, the corresponding automation track is revealed on writing automation parameters. This is useful if you want to have a visual control of all parameters changed on writing.

Return Time
This determines how fast the automated parameter returns to any previously automated value when you release the mouse button. Set this to a value higher than 0 to prevent sudden jumps in your parameter settings which may lead to crackles.

Reduction Level
When punching out, this function removes all superfluous automation events so that the automation curve contains only the events necessary to reproduce your actions.

Freeze Trim
In this pop-up menu, you can specify how to freeze your trim curve.

• To freeze your trim curve manually, select Manually.
• To perform a freeze whenever a write operation is finished, select On Pass End.
• If you want the trim data to freeze automatically when the trim mode is switched off (globally or individually for a track), select On Leaving Trim Mode.

RELATED LINKS
Virgin Territory vs. Initial Value (Cubase Pro only) on page 584

MIDI Controller Automation

When working with Cubase, it is possible to record automation data for MIDI controllers in two places: as MIDI part data and as data on an automation track.

If you have such conflicting automation data, you can specify separately for every parameter how these will be combined during playback. This is done by selecting an Automation Merge Mode in the track list for the automation track.
Automation Merge Modes

This pop-up menu is only available for controllers that can be recorded both for a part and a track. The settings that you make for a controller are applied to all MIDI tracks that use this controller.

Use Global Settings

When this is selected, the automation track uses the global Automation Merge Mode that is specified in the MIDI Controller Automation Setup dialog.

Replace 1 - Part Range

When this option is selected, the part data has playback priority over the automation track data, for example at the left and right part borders, the automation mode switches abruptly from part to track automation, and vice versa.

Replace 2 - Last Value Continues

Similar to the above, but part automation only begins when the first controller event within the part is reached. At the end of the part, the last controller value is kept until an automation event is reached on the automation track.

Average

When this option is selected, the average values between part and track automation is used.

Modulation

In this mode, the automation track curve modulates the existing part automation, with higher curve points emphasizing the automation values and lower curve points reducing the automation values even further.
MIDI Controller Automation Setup

In the MIDI Controller Automation Setup dialog, you can specify how existing MIDI automation is handled on playback and new automation data is recorded in a MIDI part or as track automation. All settings that you make in this dialog are saved with the project.

Record Destination on conflict (global)

Allows you to determine which destination is used if MIDI controller data is received by Cubase and both the Record and the Write Automation buttons are enabled. Select MIDI Part to record MIDI part automation. Select Automation Track to record the controller data on an automation track in the Project window.

Automation Merge Mode (global)

Allows you to specify the global Automation Merge Mode.

Controller list

Lists all MIDI controllers for which you can specify the record destination and the Automation Merge Mode separately. This gives you full control over the MIDI automation (destination as well as merge mode) in your project.
Record Destination
Click in the **Record Destination** column for a MIDI controller to open the pop-up menu where you can choose where you want recorded data of this particular MIDI Controller to end up.

Automation Merge Mode
Click in the **Automation Merge Mode** column for a MIDI controller to specify what happens with data for this specific controller on playback.

Save As Default
Allows you to save the current settings as default settings. When you create a new project, the default settings is used.

Load Default
Allows you to load the default settings.
VST Instruments

VST instruments are software synthesizers or other sound sources that are contained within Cubase. They are played internally via MIDI. You can add effects or EQ to VST instruments.

Cubase allows you to make use of VST instruments in the following ways:

- By adding an instrument in the **VST Instruments** window.
  This creates a VST instrument channel, which can be played by one or several MIDI tracks routed to it.

- By creating an instrument track.
  This is a combination of a VST instrument, an instrument channel, and a MIDI track. You play and record MIDI note data directly for this track.

**Note**

Some VST instruments are included with Cubase. These are described in the separate PDF document Plug-in Reference.

---

**VST Instruments Window**

The **VST Instruments** window allows you to add VST instruments for MIDI and instrument tracks, giving you an overview of all instruments used in a project. It also offers you access to 8 quick controls for each added instrument.

To open the **VST Instruments** window, select **Devices > VST Instruments**.
The following controls can be found in the **VST Instruments** window:

1) **Add Track Instrument**
   Opens the **Add Instrument Track** dialog that allows you to select an instrument and add an instrument track that is associated to this instrument.

2) **Find Instruments**
   Opens a selector that allows you to find an instrument in the **VST Instruments** window.

3) **Set Remote-Control Focus for VST Quick Controls to Previous/Next Instrument**
   Shows and activates the quick controls for the next/previous instrument in the **VST Instruments** window.

4) **Show/Hide all VST Quick Controls**
   Shows/Hides the default quick controls for all loaded instruments.

5) **Settings**
   Opens the **Settings** menu, where you can activate/deactivate the following modes:

   - **Show VST Quick Controls for One Slot Only** shows the VST Quick Controls exclusively for the selected instrument.

   - **MIDI Channel follows track selection** ensures that the Channel selector follows the MIDI track selection in the Project window. Use this if you work with multitimbral instruments.

   - **Remote-Control Focus for VST Quick Controls follows track selection** ensures that the VST Quick Control remote-control focus follows the track selection.

The following controls are available on each instrument:

1) **Activate Instrument**
   Activates/Deactivates the instrument.

2) **Edit Instrument**
   Opens the instrument panel.
3) **Freeze Instrument**
   Freezes the instrument. This allows you to save CPU power.

4) **Instrument Selector**
   Allows you to select another instrument. Double-click to rename the instrument. The name is shown in the VST Instruments window in the Output Routing pop-up menu for MIDI tracks. This is useful when you work with several instances of the same instrument.

5) **Input Options**
   This lights up when MIDI data is received by the instrument. Click this button to open a pop-up menu that allows you to select, mute/unmute, and solo/unsolo for tracks that send MIDI to the instrument (inputs).

6) **Activate Outputs**
   Allows you to activate one or more outputs for the instrument.

7) **Preset Browser**
   Allows you to load or save an instrument preset.

8) **Load Previous/Next Program**
   Allows you to load the previous/next program.

9) **Select Quick Control Layer**
   Allows you to select a program.

10) **Read/Write Automation**
    Allows you to read/write automation for the instrument parameter settings.

The following controls are available on each rack:

1) **Show/Hide VST Quick Controls**
   Allows you to show/hide the VST Quick Controls for the instrument.

2) **Set Remote-Control Focus for VST Quick Controls**
   Allows you to activate the VST Quick Controls to remote-control the instrument.

**VST Instruments Window Context Menu**

The following functions are available in the VST Instruments window context menu:

**Always on Top**

If this option is activated, the VST Instruments window is always on top.
VST Instruments
Adding VST Instruments

Add Track Instrument
Opens the Add Instrument Track dialog that allows you to select an instrument and add an instrument track that is associated to this instrument.

Add Rack Instrument
Opens a selector that allows you to add a VST instrument.

Instruments Context Menu
The following functions are available in the instruments context menu:

Copy/Paste instrument Setting
Allows you to copy the instrument settings and paste them to another instrument.

Load/Save Preset
Allows you to load/save an instrument preset.

Default Preset
Allows you to define and save a default preset.

Switch to B Setting
Activates the setting B.

Copy A to B
Copies the effect parameters of effect setting A to effect setting B.

Activate Outputs
Allows you to activate one or more outputs for the instrument.

Remote Control Editor
Opens the Remote Control Editor.

Adding VST Instruments

PROCEDURE
2. Right-click on an empty area of the VST Instruments window.
3. From the context menu, select one of the following:
   • Add Track Instrument
   • Add Rack Instrument
4. From the instrument selector, select an instrument.
   • Click Add Track, if you chose to add a track instrument.
   • Click Create, if you chose to add a rack instrument.
RESULT

If you chose Add Track Instrument, the instrument control panel opens, and an instrument track with the name of the instrument is added to your project.

If you chose Add Rack Instrument, the instrument control panel opens, and the following tracks are added to the track list:

- A MIDI track with the name of the instrument. The output of the MIDI track is routed to the instrument.

**NOTE**
In the Preferences dialog (VST–Plug-ins page), you can specify what happens when you load a VST instrument.

- A folder with the name of the instrument that is added within a VST Instruments folder. The instrument folder contains two automation tracks: one for the plug-in parameters, and one for the synth channel in the MixConsole.

Presets for Instruments

You can load and save presets for instruments. These contain all the settings that are required for the sound that you want.

The following presets for instruments are available:

- **VST presets** include the parameter settings of a VST instrument.
  These are available from the VST instruments window, from the instrument control panels, and from the Programs field in the Inspector.

- **Track presets** include the instrument track settings and the settings for the corresponding VST instrument.
  These are available from the Inspector or the track list context menu.

Loading VST Presets

You can load VST presets from the VST instruments window, from the instrument panel, or from the Inspector.

**PROCEDURE**

1. Do one of the following:
   - Select the track that contains the VST instrument and in the Inspector, click the Programs field.
   - In the VST Instruments window, click the Preset Browser button for the instrument, and select Load Preset.
   - In the control panel for the VST instrument, click the Preset Browser button, and select Load Preset.
2. In the preset browser, select a preset from the list and double-click it to load it.

RESULT

The preset is applied. To return to the previously loaded preset, open the preset browser again and click **Revert to Last Setting**.

### Saving VST Presets

You can save your settings on VST instruments as VST presets for further use.

**PROCEDURE**

1. Do one of the following:
   - In the **VST Instruments** window, click the **Preset Browse** button for the instrument, and select **Save Preset**.
   - In the control panel for the VST instrument, click the **Preset Browser** button, and select **Save Preset**.

2. In the **Save <VST instrument name> Preset** dialog, enter a name for the preset.

3. Optional: Click **Show Attribute Inspector** and define attributes for the preset.

4. Click **OK** to save the preset and close the dialog.

### Loading Track Presets

You can load track presets for instrument tracks from the Inspector.

**PROCEDURE**

1. Do one of the following:
   - Select the instrument track and in the Inspector, click the **Load Track Preset** field.
   - Right-click the instrument track and from the context menu, select **Load Track Preset**.

2. In the preset browser, select a preset from the list and double-click it to load it.

**RESULT**

The track preset is applied. To return to the previously loaded preset, open the preset browser again and click **Revert to Last Setting**.
Saving Track Presets

You can save your settings on instrument tracks as Track presets for further use.

**PROCEDURE**

1. Do one of the following:
   - Select the instrument track and in the Inspector, click the **Save Track Preset** button.
   - Right-click the instrument track and from the context menu, select **Save Track Preset**.
2. In the **Save Track Preset** dialog, enter a name for the preset.
3. Optional: Click **Show Attribute Inspector** and define attributes for the preset.
4. Click **OK** to save the preset and close the dialog.

VST Quick Controls

VST Quick Controls allow you to remote-control a VST instrument from within the **VST Instruments** window.

To show the VST Quick Controls on the **VST Instruments** window, activate the **Show/Hide all VST Quick Controls** button.

Connecting Quick Controls with Remote Controllers

Quick Controls become powerful when used in combination with a remote controller.

**PREREQUISITE**

Your remote device is connected to Cubase via MIDI.

**PROCEDURE**

1. Select **Devices > Device Setup**.
2. In the **Devices** list, select **Track Quick Controls** or **VST Quick Controls**. This opens the respective section on the right.
3. From the **MIDI Input** pop-up menu, select the MIDI port on your computer.
   - If your remote controller has its own MIDI input and supports MIDI feedback, you can connect your computer to the device input. Select the corresponding MIDI port in the **MIDI Output** pop-up menu.
   - Alternatively, you can select **All MIDI Inputs**.
4. Click **Apply**.
5. Activate **Learn**.
6. In the **Control Name** column, select **QuickControl 1**.

7. On your remote control device, move the control that you want to use for the first quick control.

8. Select the next slot in the **Control Name** column and repeat the previous steps.

9. Click **OK**.

**NOTE**

In addition to using the Learn function to set up the table in the **Quick Controls** section, you can modify the values manually. The available options are identical to the ones available for the Generic Remote device.

---

**RESULT**

The quick controls are now associated with control elements on your external remote controller. If you move a control element, the value of the parameter that is assigned to the corresponding Quick Control changes accordingly.

The remote controller setup for Quick Controls is saved globally, that is, it is independent of any projects. If you have various remote controllers, you can save and load several Quick Control setups using the **Export** and **Import** buttons.

**RELATED LINKS**

- The Generic Remote device on page 630

---

**Activating Pick-up Mode for Hardware Controls**

**Pick-up Mode** allows you to change configured Quick Control parameters without accidentally modifying their previous values.

Often, the parameter settings of your Quick Controls are initially different from the settings of your hardware controls, for example, when the hardware controls control different Quick Controls on different tracks. In this case, you will notice that moving a hardware control changes the previous value of a parameter in a way that it is initially set to the zero position, before it is changed. Thus, you always lose your previous setting of the parameter.

To avoid this, you can activate **Pick-up Mode**. This has the effect that when you move your hardware control, you can only change the parameter once the control reaches the parameter’s previous value. The control “picks up” the parameter at the value to which it was last set.

**NOTE**

This only applies to hardware controllers whose controls use specific ranges.

**PROCEDURE**

1. Select **Devices > Device Setup**.

2. In the **Devices** list, select **Track Quick Controls** or **VST Quick Controls**.
3. Activate **Pick-up Mode**.
4. Click **OK**.

## Playing Back VST Instruments

After you have added a VST instrument and selected a sound, you can play back the VST instrument using the instrument or MIDI track in your project.

### PROCEDURE

1. In the track list, activate the **Monitor** button for the track that has the VST instrument loaded.
2. Press one or more keys on your MIDI keyboard or use the virtual keyboard. The corresponding sounds are triggered on your VST instrument.
3. Select **Devices > MixConsole** to open the **MixConsole** and adjust the sound, add EQ or effects, assign another output routing, etc.

## VST Instruments and Processor Load

VST instruments can consume a lot of CPU power. The more instruments you add, the more likely you will run out of processor power during playback.

If the CPU overload indicator in the **VST Performance** window lights up or you get crackling sounds, you have the following options:

- **Activate Freeze** for instruments.
  This renders the instrument into an audio file and unloads it.

- **Activate Suspend VST3 plug-in processing when no audio signals are received** for VST 3 instruments.
  This ensures that your instruments do not consume CPU power on silent passages.

### RELATED LINKS

- [Freezing Instruments](#)
- [Suspend VST3 plug-in processing when no audio signals are received](#)
Freezing Instruments

If you are using a moderately powerful computer or a large number of VST instruments, your computer may not be able to play back all instruments in real-time. At this point, you can freeze instruments.

**PROCEDURE**

1. Do one of the following:
   - Select Devices > VST Instruments.
   - Select the instrument track and open the top Inspector tab.

2. Click the Freeze button.

3. In the Freeze Instrument Options dialog, make your settings.

4. Click OK.

**RESULT**

- The instrument is rendered to an audio file and on playback you hear the same sound as before freezing.
- Less CPU load is used.
- The Freeze button lights up.
- The MIDI/instrument track controls are grayed out.
- The MIDI parts are locked.

**NOTE**

To edit the tracks, parameters, or synth channels again, and to delete the rendered file, unfreeze the instrument by clicking the Freeze button again.

**Freeze Instrument Options**

The Freeze Instrument Options dialog opens when you click the Freeze button. It allows you to specify exactly what should happen, if you freeze an instrument.

The following controls can be found in the Freeze Instrument Options dialog:

**Freeze Instrument Only**

Activate this option if you still want to be able to edit insert effects on the synth channel after freezing the instrument.

**Freeze Instrument and Channels**

Activate this option if you do not need to edit the insert effects on your synth channels.

**NOTE**

You can still adjust level, pan, sends, and EQ.
### About Latency

The term latency stands for the time it takes for the instrument to produce a sound when you press a key on your MIDI controller. It can be an issue when using VST instruments in realtime. Latency depends on your audio hardware and its ASIO driver.

In the **Device Setup** dialog (VST Audio System page), the input and output latency values should ideally be a few milliseconds.

If the latency is too high to allow comfortable realtime VST instrument playback from a keyboard, you can use another MIDI sound source for live playback and recording, and switch to the VST instrument for playback.

**RELATED LINKS**

- **Selecting a Driver** on page 14

### Delay Compensation

During playback Cubase automatically compensates any delay inherent in the VST plug-ins you use.

You can specify a Delay Compensation Threshold in the **Preferences** dialog (VST page) so that only plug-ins with a delay higher than this threshold setting are affected.

### Constrain Delay Compensation

To avoid Cubase to add latency when you play a VST instrument in realtime or record live audio, you can activate **Constrain Delay Compensation**. This minimizes the latency effects of the delay compensation, while maintaining the sound of the mix as far as possible.

The Constrain Delay Compensation function is available on the toolbar and in the **MixConsole** on the **Functions** menu.
Activating **Constrain Delay Compensation** turns off VST plug-ins which are activated for VST instrument channels, audio track channels that are record enabled, group channels, and output channels. VST plug-ins which are activated for FX channels are disregarded. After recording or using a VST instrument **Constrain Delay Compensation** should be deactivated again in order to restore full delay compensation.

## Import and Export Options

### Importing MIDI Loops

You can import MIDI loops (file extension .midiloop) in Cubase. These files contain MIDI part information (MIDI notes, controllers, etc.) and all the settings that are saved in instrument track presets. This way, you can reuse instrument patterns in other projects or applications, for example.

**PROCEDURE**

1. Select **Media > MediaBay**.
2. Optional: In the **Results** section, open the **Select Media Types** menu, and activate **MIDI Loops** and **Plug-in Presets**.
3. In the results list, select a MIDI loop and drag it to an empty section in the **Project** window.

**RESULT**

An instrument track is created and the instrument part is inserted at the position where you dragged the file. The **Inspector** reflects all settings that are saved in the MIDI loop, for example, the VST instrument that was used, applied insert effects, track parameters, etc.

**NOTE**

You can also drag MIDI loops onto existing instrument or MIDI tracks. However, this only imports the part information. This means this part only contains the MIDI data (notes, controllers) that is saved in the MIDI loop, but no inspector settings or instrument parameters.

**RELATED LINKS**

- Presets for Instruments on page 603
Exporting MIDI Loops

You can export MIDI loops to save a MIDI part together with its instrument and effect settings. This allows you to reproduce patterns that you created without having to search for the correct sound, style, or effect.

**PROCEDURE**

1. Select an instrument part.
2. Select File > Export > MIDI Loop.
   
   A file dialog opens.
3. In the New MIDI Loop section, enter a name for the MIDI loop.
4. Optional: To save attributes for the MIDI loop, click the button below the New MIDI Loop section at the bottom left.
   
   The Attribute Inspector section opens, allowing you to define attributes for your MIDI loop.
5. Click OK to close the dialog and save the MIDI loop.

**RESULT**

MIDI Loop files are saved in the following folder:

**Windows:** `\Users\<user name>\AppData\Roaming\Steinberg\MIDI Loops`

**Mac:** `/Users/<user name>/Library/Application Support/Steinberg/MIDI Loops/`

The default folder cannot be changed. However, you can create subfolders within this folder to organize your MIDI loops. To create a subfolder, click the New Folder button in the Save MIDI Loop dialog.

Exporting Instrument Tracks as MIDI File

You can export instrument tracks as standard MIDI files.

**NOTE**

As there is no MIDI patch information in an instrument track, this information is missing in the resulting MIDI file.

**NOTE**

If you activate Export Inspector Volume/Pan, volume and pan information of the VST instrument are converted and written into the MIDI file as controller data.

**RELATED LINKS**

Exporting MIDI files on page 1021
External Instruments (Cubase Pro only)

An external instrument bus is an input (return) to your audio hardware, along with a MIDI connection via Cubase and few additional settings. External instrument busses are created in the VST Connections window. All external instrument busses that you have created will appear on the VST Instrument pop-up menus and can be selected in the same way as any VST instrument plug-in.

If you select an external instrument, you play it via MIDI as usual (you have to create a MIDI device to play it) and the sound (synth audio output) will come in to the VST environment where you can apply processing, etc.

RELATED LINKS
- Setting Up External Instruments on page 37
Installing and Managing Plug-ins

Installing VST plug-ins

Cubase supports the VST 2 and VST 3 plug-in standards. You can install effects and instruments that comply with these formats.

A plug-in is a piece of software that adds a specific functionality to Cubase. The audio effects and instruments that are used in Cubase are VST plug-ins.

NOTE

If an effect or instrument plug-in has its own installation application, you should use this. Dragging an already installed plug-in to a different location may lead to problems. As a general rule, always read the documentation or readme files before installing new plug-ins.

Cubase comes with a number of effect plug-ins included. These effects and their parameters are described in the separate PDF document Plug-in Reference.

Installing VST 3 Plug-ins on Mac OS X Systems

To install a VST 3.x plug-in on a Mac OS X system, quit Cubase and drag the plug-in file into one of the following folders:

- /Library/Audio/Plug-Ins/VST3/
  This is only possible if you are the system administrator. Plug-ins that are installed in this folder are available to all users, for all programs that support VST 3.

- /Users/<user name>/Library/Audio/Plug-Ins/VST3/
  <user name> is the name you use to log on to the computer. The easiest way to open this folder is to open your Home folder and use the path /Library/Audio/Plug-Ins/VST3/ from there. Plug-ins that are installed in this folder are only available to you.

When you scan for newly installed plug-ins, or relaunch Cubase, the new effects appear on the effect selectors. In the VST 3 protocol, the effect category, subfolder structure, etc. are built-in and cannot be changed. Therefore, you find the effects in the corresponding category folders.
Installing VST 2 Plug-ins on Mac OS X Systems

To install a VST 2.x plug-in on Mac OS X systems, quit Cubase and drag the plug-in file to one of the following folders:

- Library/Audio/Plug-Ins/VST/
  This is only possible if you are the system administrator. Plug-ins that are installed in this folder are available to all users, for all programs that support VST 2.x.

- user name>/Library/Audio/Plug-Ins/VST/
  &lt;user name&gt; is the name you use to log on to the computer. The easiest way to open this folder is to go to your Home folder and use the path /Library/Audio/Plug-Ins/VST/ from there. Plug-ins that are installed in this folder are only available to you.

When you scan for newly installed plug-ins, or relaunch Cubase, the new effects appear on the effect selectors.

Installing VST 3 Plug-ins on Windows Systems

On Windows systems, VST 3 plug-ins are installed by dragging the files with the extension .vst3 into the VST3 folder in the Cubase application folder. When you scan for newly installed plug-ins, or relaunch Cubase, the new effects appear on the effect selectors. In the VST 3 protocol, the effect category, subfolder structure, etc. are built-in and cannot be changed. Therefore, you find the new effects in the corresponding category folders.

Installing VST 2 Plug-ins on Windows Systems

On Windows systems, VST 2.x plug-ins are installed by dragging the files with the extension .dll into the Vstplugins folder in the Cubase application folder, or into the Shared VST Plug-ins folder (Windows 32 bit only). When you scan for newly installed plug-ins, or relaunch Cubase, the new effects appear on the effect selectors.

Plug-in Manager

The Plug-in Manager provides lists of the effects and VST instruments that are installed on your computer. These lists are used in the selectors for VST instruments and effects.

The Plug-in Manager allows you to do the following:

- You can view lists of all effects and VST instruments that are loaded by Cubase when you launch the program.
The lists of all effects or VST instruments are created automatically every time you start Cubase. You can also initiate a rescan at any time. This ensures that these lists are always up-to-date.

- You can create your own lists of effects or instruments for use in the selectors for effects or instruments. User-defined lists are called collections. Collections allow you to create sub-sets of the available effects or instruments, for example, to give you a better overview of the effects used in a project.

**NOTE**

If an installed effect or instrument cannot be loaded by Cubase, it does not appear in the list of all effects or instruments. Also, the effect or instrument is grayed out in any collections in which it is included. For example, this can happen if a copy-protection dongle required to run the effect or instrument is missing, or after deinstallation of a plug-in.

### Plug-in Manager Window

You can manage your effects and VST instruments in the **Plug-in Manager** window.

- To open the **Plug-in Manager** window, select **Devices > Plug-in Manager**.

The **Plug-in Manager** window shows the following:

**VST Effects/VST Instruments**

Open these tabs to see lists of all VST effects and VST instruments that were loaded by Cubase when you launched the program.
Collection list

By default, the window section to the right shows the Default collection, which contains all effects or VST instruments currently loaded by the program. The Default collection cannot be changed.

You can compile your own collections of effects or VST instruments by clicking New Collection and dragging and dropping items from the list of all effects or VST instruments to the collection list.

Collections are shown in the selectors for effects/VST instruments, and all changes made to collections in the Plug-in Manager are immediately reflected in the selectors.

Enter the name of a plug-in in the search field. The list of all effects or VST instruments is filtered to show only those plug-ins whose names contain the text that you entered.

The Toggle list to show all/show only FX/VSTi not in current collection button allows you to filter the lists of all effects or VST instruments to show either all loaded plug-ins, or only those that are not part of the current collection.

The New Folder button allows you to create a new folder in the current collection.

The Delete button allows you to delete the selected item in the current collection.

The New Collection button allows you to create a new collection.

To create a new, empty list, select Empty. To create a new collection based on the list of all effect, select Add All Plug-ins. To create a new collection based on the current collection, select Add Current Collection.

The User Collections drop-down menu allows you to select a different collection, and to rename or delete the current collection.

To remove unavailable plug-ins from all collections, select Remove Unavailable Plug-ins from All Collections.

The Show Plug-in Information button opens a section at the bottom of the window in which more information about the selected item is shown. If you select several plug-ins, the information for the plug-in that you have selected first is shown. In this section, you can also deactivate selected plug-ins. Deactivated plug-ins are no longer available in collections. This is useful if you have plug-ins installed that you do not want to use in Cubase.
Installing and Managing Plug-ins

Compiling a New Effects Collection

You can create a new collection of effects or VST instruments for use in the plug-in selectors.

PREREQUISITE

A number of effect plug-ins is correctly installed on your computer, and these plug-ins are listed on the VST Effects tab of the Plug-in Manager window.

PROCEDURE

1. In the Plug-in Manager window, click the New Collection button and do one of the following:
   - To create a new collection based on the list of all effects, select Add All Plug-ins.
   - To create a new collection based on the current collection, select Copy Current Collection.

2. Enter a name for the new collection and click OK.

3. Drag items from the list of all effects and drop them to the new collection. A blue line indicates the drop position.
   - Click the New Folder button to create folders and place items directly in them.
   - You can drag items to new positions within the collection.
   - Drag items from the collection list to the list of all plug-ins to delete them, or select items and click Delete.

RESULT

The new collection is saved automatically.

The procedure is the same for compiling collections of VST instruments.

In the plug-in selectors, found, for example, in the Project window > track inspector > Inserts tab, collections are available as tabs at the top of the selector.
Cubase can give you instant access to up to 8 different parameters, for example, track, effect, or instrument controls. This is done with the aid of the Quick Controls, set up on the **Quick Controls** tab in the Inspector for the corresponding track.

The **Quick Controls** tab can be used as a kind of track control center, an area in which your most important parameters are assembled in one place. This saves you from having to click your way through the various windows and sections pertaining to your track.

Cubase also allows you to assign these Quick Controls very quickly to an external remote control device. This does not only give you manual control of your most important track parameters, but also allows you to conveniently use an external MIDI device such as a foot controller to control effect parameters.

- Quick Control assignments are saved with the current project.
- Since Quick Control settings are part of the track setup, you can save them as track presets, allowing you to re-use your settings across different projects.
- You can automate the parameter settings on the **Quick Controls** tab using the Read/Write buttons (R and W).
- You can also assign parameters to Quick Controls in the MixConsole.

**RELATED LINKS**
- Track Presets on page 160
- Automation on page 576
- Channel Racks on page 300
Assigning Parameters to Quick Controls

The Quick Controls tab shows eight slots, one for each quick control. To start with, these slots are empty. Parameters can be assigned manually or retrieved automatically.

1) QC Learn Mode
2) Get default QCs from Plug-in
3) Remove all QC Assignments

Assignment via the Learn Function

Using the QC Learn Mode button on the Quick Controls tab in the Inspector, you can assign a parameter by moving the corresponding control.

This procedure applies to all automatable controls.

**PROCEDURE**

1. In the Inspector for your track, open the Quick Controls tab.
2. Activate QC Learn Mode.
3. Select the slot to which you want to assign a parameter.
4. Use the desired control.

Assignment via Plug-in Panels

You can assign effect parameters to Quick Control slots directly from within plug-in panels.

You can assign an effect parameter either to the next empty slot or to a specific Quick Control slot.

**NOTE**

These options are only available for VST 3 plug-ins that support this function.
Assigning Parameters from Racks or Channel Settings

You can assign several parameters to Quick Control slots directly from within racks or channel settings in the MixConsole.

Some specific racks and channel settings allow you to add several parameters directly to the Quick Controls tab in the Inspector.

- Pre (Filters/Gain/Phase)
- Equalizers
- Channel Strip

You can assign an effect parameter either to the next empty slot or to a specific Quick Control slot.

NOTE

These options are only available for VST 3 plug-ins that support this function.

PROCEDURE

- Right-click the parameter.
  - To assign the parameter to the next empty slot, select **Add “x” to Quick Controls** (where x is the name of the parameter).
  - To assign the parameter to a specific slot, select **Add “x” to Quick Controls Slot** (where x is the name of the parameter). Then select the slot from the submenu.

RELATED LINKS

Track Quick Controls on page 618
Manual Assignment via the Inspector Tab

You can assign track parameters manually.

PROCEDURE
1. In the Inspector for your track, open the Quick Controls tab.
2. On the Quick Controls tab, click on the first Quick Control slot.
   A pop-up menu opens. It lists all parameters currently accessible for this particular track.
3. Double-click the parameter that you want to assign to the first Quick Control slot.
   The parameter name and its value are displayed in the slot. You can change the value by dragging the slider.
   The track’s main volume parameter is assigned to Quick Control 1.
4. Repeat these steps for each Quick Control slot until all slots are associated with track parameters.

RESULT
You can now control the functions most important to you via one single Inspector section.
- To rename a Quick Control, double-click on the name in the slot to select it, enter a new name and press [Enter].
- To replace a parameter assignment with a different parameter, click on the corresponding Quick Control slot and double-click a different parameter.

Automatic Assignment of VST Instrument Parameters

When you create an instrument track or load a VST instrument via the VST Instruments window including creating an associated MIDI track, the main parameters of the instrument are automatically assigned to the slots on the Quick Controls tab in the Inspector.

NOTE
This only works if the VST instrument supports this feature.

If you have changed the parameter assignment or if you manually route a MIDI track to a VST instrument, you can retrieve the default assignments.

PROCEDURE
1. In the Inspector for your track, open the Quick Controls tab.
2. Click Get Default QCs from Plug-in.
Removing Parameter Assignments

- To remove a parameter from a slot, double-click the parameter name to select it and press the [Delete] or [Backspace] key. Confirm by pressing [Return]. Alternatively, you can click in the corresponding slot and select **No parameter** from the pop-up menu.

- To remove the Quick Control assignments for all slots, click the **Remove All QC Assignments** button.

Showing Automated Quick Control Assignments

You can show all Quick Control assignments that have been automated for one track.

**PROCEDURE**

1. Click the track for which you want to show automated Quick Control assignments.
2. In the **Inspector** for your track, open the **Quick Controls** tab.
3. On the **Quick Controls** tab, click **Preset Management**.
4. Select **Show Automated QC Assignments**.

**RESULT**

The automation tracks of the automated Quick Control parameters open for the selected track.

**NOTE**

- If **Volume** is assigned as a Quick Control parameter, it is always shown as automated, independent of whether it is automated or not.

- You can also show automated Quick Control assignments via the **Track Quick Controls** rack in the **MixConsole**.
Saving/Loading Track Quick Control Assignments as Presets

You can save and load your own Quick Control assignments as presets for audio, instrument, MIDI, FX, and group tracks. You can also use the factory presets.

**PROCEDURE**

1. In the Inspector for your track, open the Quick Controls tab. For instrument tracks, the Track Quick Controls are automatically set to the 8 default VST Quick Controls of the loaded instrument by default.

   **NOTE**
   You can also make your own assignments and save them as presets and delete, rename, or reset the presets to the default assignments.

2. On the Quick Controls tab, click **Preset Management**.  
   - To save a preset, click **Save Preset**. Enter a name in the **Type In Preset Name** dialog and click **OK**.  
   - To load a preset, select one of the presets in the upper list of the menu. The Track Quick Control assignment changes and gives you access to the channel parameters.

**RELATED LINKS**
Manual Assignment via the Inspector Tab on page 621

Connecting Quick Controls with Remote Controllers

Quick Controls become powerful when used in combination with a remote controller.

**PREREQUISITE**
Your remote device is connected to Cubase via MIDI.

**PROCEDURE**

1. Select **Devices > Device Setup**.
2. In the Devices list, select **Track Quick Controls** or **VST Quick Controls**. This opens the respective section on the right.
3. From the **MIDI Input** pop-up menu, select the MIDI port on your computer. If your remote controller has its own MIDI input and supports MIDI feedback, you can connect your computer to the device input. Select the corresponding MIDI port in the **MIDI Output** pop-up menu. Alternatively, you can select **All MIDI Inputs**.
4. Click **Apply**.
5. Activate **Learn**.
6. In the **Control Name** column, select **QuickControl 1**.
7. On your remote control device, move the control that you want to use for the first quick control.
8. Select the next slot in the **Control Name** column and repeat the previous steps.
9. Click **OK**.

**NOTE**

In addition to using the Learn function to set up the table in the **Quick Controls** section, you can modify the values manually. The available options are identical to the ones available for the Generic Remote device.

---

**RESULT**

The quick controls are now associated with control elements on your external remote controller. If you move a control element, the value of the parameter that is assigned to the corresponding Quick Control changes accordingly.

The remote controller setup for Quick Controls is saved globally, that is, it is independent of any projects. If you have various remote controllers, you can save and load several Quick Control setups using the **Export** and **Import** buttons.

**RELATED LINKS**

The Generic Remote device on page 630

---

**Activating Pick-up Mode for Hardware Controls**

**Pick-up Mode** allows you to change configured Quick Control parameters without accidentally modifying their previous values.

Often, the parameter settings of your Quick Controls are initially different from the settings of your hardware controls, for example, when the hardware controls control, different Quick Controls on different tracks. In this case, you will notice that moving a hardware control changes the previous value of a parameter in a way that it is initially set to the zero position, before it is changed. Thus, you always lose your previous setting of the parameter.

To avoid this, you can activate **Pick-up Mode**. This has the effect that when you move your hardware control, you can only change the parameter once the control reaches the parameter’s previous value. The control “picks up” the parameter at the value to which it was last set.

**NOTE**

This only applies to hardware controllers whose controls use specific ranges.

**PROCEDURE**

1. Select **Devices > Device Setup**.
2. In the **Devices** list, select **Track Quick Controls** or **VST Quick Controls**.
3. Activate **Pick-up Mode**.
4. Click **OK**.
Quick Controls and Automatable Parameters

You can use Quick Controls not only to access certain parameters of the current track, but also to control all automatable parameters. This makes it possible to use the Quick Controls tab of a dedicated track as a kind of “mini mixer”, controlling parameters on other tracks.

**IMPORTANT**

Use this function with caution, however, as you might accidentally modify parameters on other tracks.

**PROCEDURE**

1. Create a new, empty audio track and open its **Quick Controls** tab.  
   This track has no events or parts.

2. Hold down the [Ctrl]/[Command] key and click on the slot for Quick Control 1.  
   The parameter selection context menu opens, but it lists not the parameters of the current track, but all automatable parameters.

3. Open the **VST Mixer** folder.

   ![VST Mixer](image)

   The pop-up menu lists all channels available in the MixConsole of your current project.

4. Assign a parameter of one particular channel to Quick Control 1, and another parameter of another channel to Quick Control 2.

**RESULT**

The **Quick Controls** tab has become a secondary mixer, dedicated to quick-controlling parameters on other tracks.

**IMPORTANT**

Quick Controls that are assigned that way cannot work when saved as track presets.
Remote controlling Cubase

It is possible to control Cubase via MIDI.

A large number of MIDI control devices is supported. This chapter describes how to set up Cubase for remote control. The supported devices are described in the separate PDF document “Remote Control Devices”.

There is also a Generic Remote Device option, allowing you to use any MIDI controller to remote control Cubase.

RELATED LINKS
The Generic Remote device on page 630

Setting Up

Connecting the remote device

Connect the MIDI output on the remote unit to a MIDI input on your MIDI interface. Depending on the remote unit model, you may also need to connect a MIDI Out on the interface to a MIDI In on the remote unit (this is necessary if the remote unit features “feedback devices” such as indicators, motorized faders, etc.).

If you are recording MIDI tracks, you do not want any MIDI data from the remote unit to be accidentally recorded as well. To avoid this, you should make the following setting:

PROCEDURE
1. Open the Device Setup dialog from the Devices menu.
2. Select “MIDI Port Setup” in the list on the left.
3. Check the table on the right and locate the MIDI input to which you have connected the MIDI remote unit.
4. Deactivate the checkbox in the “In ‘All MIDI Inputs’” column for that input, so that the State column reads “Inactive”.
5. Click OK to close the Device Setup dialog.

RESULT
Now you have removed the remote unit input from the “All MIDI Inputs” group. This means that you can record MIDI tracks with the “All MIDI Inputs” port selected without risking to record the data from the remote unit at the same time.
Selecting a remote device

PROCEDURE

1. Open the Device Setup dialog from the Devices menu.
2. If you cannot find the remote device you are looking for, click on the plus sign in the top left corner and select the device from the pop-up menu. The selected device is added to the Devices list.

NOTE

Note that it is possible to select more than one remote device of the same type. If you have more than one remote device of the same type, these will be numbered in the Devices list. For example, to be able to use a Mackie Control Extender, you must install a second Mackie control device.

3. Select your MIDI control device model from the Devices list. Depending on the selected device, either a list of programmable function commands or a blank panel is shown in the right half of the dialog window.

4. Select the correct MIDI input from the pop-up menu. If necessary, select the correct MIDI output from the pop-up menu.
5. Click OK to close the dialog.

RESULT

You can now use the MIDI control device to move faders and knobs, activate Mute and Solo, etc. The exact parameter configuration depends on which external MIDI control device you are using.

A white stripe in the Project window and in the MixConsole indicates which channels are currently linked to the remote control device.
IMPORTANT

Sometimes communication between Cubase and a remote device is interrupted or the handshaking protocol fails to create a connection. To re-establish communication with any device in the Devices list, select it and click the Reset button in the lower part of the Device Setup dialog. The “Send Reset Message to all Devices” button at the top left of the dialog next to the “+” and “-” buttons will reset every device in the Devices list.

Operations

Global options for remote controllers

In the Device Setup dialog, on the page for your remote device, some (or all) of the following global functions may be available (depending on your remote device):

Bank pop-up menu

If your remote device contains several banks, you can select the bank you want to use.

The bank you select here is used by default when Cubase is launched.

Smart Switch Delay

Some of the Cubase functions (e.g. Solo and Mute) support the so called smart switch behavior: In addition to regular activation/deactivation of a function by clicking a button, you can also activate the function for as long as the button is pressed. Upon releasing the mouse button, the function is deactivated.

This pop-up menu allows you to specify how long a button must be pressed before it goes into smart switch mode. When “Off” is selected, the smart switch function is deactivated in Cubase.

Enable Auto Select

If this option is activated, touching a fader on a touch-sensitive remote control device automatically selects the corresponding channel. On devices without touch-sensitive faders, the channel gets selected as soon as you move the fader.
Writing automation using remote controls

Automating the MixConsole in Touch mode using a remote control device is done in the same way as when you operate on-screen controls in Write mode. In order to replace existing automation data for a control in Touch mode, the computer needs to know how long the user actually "grabbed" or used the control. When doing this “on screen”, the program simply detects when the mouse button is pressed and released. When you are using an external remote control device without touch-sensitive controls, Cubase cannot tell whether you “grab and hold” a fader or simply move it and release it.

Therefore, when you are using a device without touch-sensitive controls and want to replace existing automation data, pay attention to the following:

• If you activate Write mode and move a control on the remote control device, all data for the corresponding parameter is replaced from the position where you moved the control, up to the position where playback is stopped.
  In other words, as soon as you move a control in Write mode, it remains "active" until you stop playback.

• Make sure that you move only the controller you want to replace.

Assigning remote key commands

For some remote devices, you can assign any Cubase function (to which a key command can be assigned) to generic buttons, wheels, or other controls.

**Procedure**

1. Open the Device Setup dialog and select your remote device.
   On the right side of the window you will find a three column table. This is where you assign commands.

2. Use the Button column to locate a remote device control or button to which you wish to assign a Cubase function.

3. Click in the Category column for the control and select one of the Cubase function categories from the pop-up menu.

4. Click in the Command column and select the desired Cubase function from the pop-up menu.
   The available items on the pop-up menu depend on the selected category.

5. Click “Apply” when you are done.
   Click “Reset” to revert to the default settings.

**Result**

The selected function is now assigned to the button or control on the remote device.
A note about remote controlling MIDI tracks

While most remote control devices will be able to control both MIDI and audio channels in Cubase, the parameter setup may be different. For example, audio-specific controls (such as EQ) will be disregarded when controlling MIDI channels.

Accessing device panel parameters via remote control devices (Cubase Pro only)

Cubase allows you to control external MIDI devices through user device panels. When you have assigned project parameters to a device panel to be displayed in the MixConsole (i.e. when creating the panel, you must select the Channel Strip Size option in the Add Panel dialog), you can access these parameters through some of the remote control devices supported by Cubase.

This feature is supported for the following devices:

- Steinberg Houston
- Mackie Control
- Mackie HUI
- Yamaha DM 2000
- CM Motormix
- SAC2K

These remote control devices provide an extra display page in the Inserts section for the selected channel.

This page is called User and is displayed as the 9th insert page for audio channels and as the 5th insert page for MIDI channels. It allows you to control the parameters assigned to your user device panel from your remote control device.

The Generic Remote device

If you have a generic MIDI controller, you can use this for remote control of Cubase by setting up the Generic Remote device:

PROCEDURE

1. Open the Device Setup dialog on the Devices menu.
   If the Generic Remote device is not on the Devices list, you need to add it.
Remote controlling Cubase
The Generic Remote device

2. Click the “+” sign in the top left corner and select the “Generic Remote” device from the pop-up menu.

When the Generic Remote device is added in the Device Setup dialog, you can open the corresponding window by selecting “Generic Remote” from the Devices menu.

3. Select the Generic Remote device in the Devices list to the left.

The settings for the Generic Remote device are displayed, allowing you to specify which control on your device should control which parameter in Cubase.

4. Use the MIDI Input and Output pop-up menus to select the MIDI port(s) to which your remote device is connected.

5. Use the pop-up menu to the right to select a bank.

Banks are combinations of a certain number of channels, and are used because most MIDI devices can control only a limited number of channels at a time (often 8 or 16). For example, if your MIDI control device has 16 volume faders, and you are using 32 MixConsole channels in Cubase, you would need two banks of 16 channels each. When the first bank is selected you can control channel 1 to 16; when the second Bank is selected you can control channel 17 to 32.

6. Set up the table at the top according to the controls on your MIDI control device.

The columns have the following functionality:

<table>
<thead>
<tr>
<th>Column</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Control Name</td>
<td>Double-clicking this field allows you to enter a descriptive name for the control (typically a name written on the console). This name is automatically reflected in the Control Name column in the lower table.</td>
</tr>
</tbody>
</table>
Remote controlling Cubase
The Generic Remote device

If you find that the table at the top holds too many or too few controls, you can add or remove controls with the Add and Delete buttons to the right of the table.

If you are uncertain of which MIDI message a certain controller sends, you can use the Learn function. Select the control in the upper table (by clicking in the Control Name column), move the corresponding control on your MIDI device and click the Learn button to the right of the table. The MIDI Status, MIDI Channel, and Address values are automatically set to those of the moved control.

If you use the Learn function for a control that sends a Program Change value, the “Prog. Change Trigger” option is automatically selected on the “MIDI Status” pop-up menu. This allows you to use the different values of a Program Change parameter to control different parameters in Cubase. If this does not give you the result you want, try using the “Prog. Change” value instead.

7. Use the table at the bottom to specify which Cubase parameters you want to control.

Each row in the table is associated to the controller in the corresponding row in the first table (as indicated by the Control Name column). The other columns have the following functionality:

<table>
<thead>
<tr>
<th>Column</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>MIDI Status</td>
<td>Clicking in this column opens a pop-up menu, allowing you to specify the type of MIDI message sent by the control (e.g. Controller, Prog. Change Trigger). The NRPN and RPN controllers are part of the MIDI specification and present a way to extend the available control messages. The “Ctrl JLCooper” option is a special version of a Continuous Controller where the 3rd byte of a MIDI message is used as address instead of the 2nd byte (a method supported by various JL-Cooper remote devices). For a description of the Ctrl-Houston status value, see the Steinberg Houston hardware manual.</td>
</tr>
<tr>
<td>MIDI Channel</td>
<td>Clicking in this column opens a pop-up menu, allowing you to select the MIDI channel on which the controller is transmitted.</td>
</tr>
<tr>
<td>Address</td>
<td>The Continuous Controller number, the pitch of a note, or the address of a NRPN/RPN Continuous Controller.</td>
</tr>
<tr>
<td>Max. Value</td>
<td>The maximum value the control will transmit. This value is used by the program to “scale” the value range of the MIDI controller to the value range of the program parameter.</td>
</tr>
<tr>
<td>Flags</td>
<td>Clicking in this column opens a pop-up menu, allowing you to activate or deactivate three flags:</td>
</tr>
<tr>
<td></td>
<td>• Receive – activate this if the MIDI message should be processed on reception.</td>
</tr>
<tr>
<td></td>
<td>• Transmit – activate this if a MIDI message should be transmitted when the corresponding value in the program changes.</td>
</tr>
<tr>
<td></td>
<td>• Relative – activate this if the control is an “endless” rotary encoder, which reports the number of turns instead of an absolute value.</td>
</tr>
</tbody>
</table>
Remote controlling Cubase
The Generic Remote device

8. If necessary, make settings for another bank.

**NOTE**
Note that you only need to make settings in the bottom table for this bank. The table at the top is already set up according to the MIDI remote device.

If necessary, you can add banks by clicking the Add button below the Bank pop-up menu.

Clicking the Rename button allows you to assign a new name to the currently selected bank, and you can remove an unneeded bank by selecting it and clicking the Delete button.

9. When you are finished, close the Device Setup window.

Now, you can control the specified Cubase parameters from the MIDI remote device. To select another bank, use the pop-up menu in the Generic Remote window (or use a control on the MIDI remote device, if you have assigned one for this).
Importing and exporting remote setups

The Export button in the top right corner of the Generic Remote Setup window allows you to export the current setup, including the Control configuration (the table at the top) and all banks. The setup is saved as a file (with the file extension “.xml”). Clicking the Import button allows you to import saved remote setup files.

**NOTE**

The last imported or exported remote setup will automatically be loaded when the program starts or the Generic Remote control is added in the Device Setup dialog.

Track Quick Controls

If you have an external remote control device, you can set it up to control up to eight parameters of each audio track, MIDI track or instrument track, using the Track Quick Controls feature in Cubase.

**RELATED LINKS**

- Connecting Quick Controls with Remote Controllers on page 605

The Remote Control Editor

Often, the automatic mapping of plug-in parameters to remote control devices appears rather random, and not very intuitive. The Remote Control Editor allows you to define your own mapping of VST plug-in parameters to the controls of the supported hardware controllers.

- To open the Remote Control Editor, right-click the plug-in panel of the plug-in that you want to remote-control and select “Remote Control Editor”.

![Remote Control Editor](image)
Remote controlling Cubase
The Remote Control Editor

Layout Section

The main area of the editor is the Layout section. Layouts represent the hardware devices that are used to remote-control the plug-in parameters. Like these devices, a layout can have a number of pages. These pages contain a number of cells, which in turn contain controls. The available controls are a text label, a knob, and two switches.

You can perform the following editing operations:

- Change the parameter assignments
- Change the name in the text label
- Set up the cells
- Arrange the order of cells and pages

When you open the editor for the first time, the Standard Layout is shown.

Inspector Section

The Inspector contains the settings and the parameter assignment for the selected cell. The upper section contains settings for the text label. The lower section contains settings for the knob and the switches.
Status Bar

When you position the mouse pointer over an element in the editor window, the status bar shows information on what you can do with this element.

Setting up the Standard Layout

Click the “Set up Cell Layout” button to open the Cell Layout Configuration panel. Here, you can make the following settings:

- Use the pop-up menu to specify the number of cells per page.
- In the lower section, select the switch layout that you want to use for the pages.
  You can specify the number of switches for a cell by activating/deactivating them.

Defining the Controls

You can define the operation for a particular switch or knob. This includes changing the LED ring or changing its behaviour, from continuous value representation to on/off, for example.

Right-click the control and select a new control style in the settings window or select the control and select a style in the inspector.

NOTE

- To be able to make settings for a control, it has to be assigned to a function.
- Not all hardware devices support all control type settings.
Control Type Settings for Knobs

The following control types are available for knobs:

**Standard**
A standard knob with undefined LED style.

**Toggle Switch**
This is best used for parameters with two states, like On/Off buttons.

**LED Ring**
An LED ring is shown around the knob. The setting increases clockwise.

**LED Ring (counter-clockwise)**
An LED ring is shown around the knob. The setting increases counter-clockwise from right to left.

**Center Width**
The LED ring starts at the top center position and when the settings increase, an LED is shown growing in both directions.

**Center Neutral**
The dial starts at the top center position and can be moved left or right, like a pan control, for example.

**Single Dot**
As “LED Ring”, but showing only a dot to indicate the current value.

Control Type Settings for Switches

...
The following options are available for switches:

**Momentary**
The assigned function is active for as long as you keep the switch pressed.

**Increasing Stepwise**
Pressing the switch steps through the available settings until the maximum is reached.

**Decreasing Stepwise**
Pressing the switch steps through the available settings in reverse order until the minimum is reached.

**Increasing Stepwise (cycle)**
Pressing the switch steps through the available settings, starting over with the minimum value when the maximum is reached.

**Decreasing Stepwise (cycle)**
Pressing the switch steps through the available settings in reverse order, starting over with the maximum value when the minimum is reached.

**Smart Switch**
This changes between two states every time you press the switch, like an On/Off button. Furthermore, if you keep the switch pressed, you enter Momentary mode, that is, the corresponding function stays active for as long as the button is pressed.

**Invert Control Value**
This inverts the control state/value.

**Hide Control When Inactive**
Hides plug-in parameters when they are inactive or disabled.

**Assigning Parameters to Controls**

**Procedure**

1. Click the L button on the toolbar to activate Learn mode for the editor.

2. In the editor, select the control that you want to assign to a plug-in parameter. A colored frame around a control shows that this control has the Learn focus.

3. Click on a parameter on the plug-in panel. This assigns that parameter to the control.

You can also double-click on a control in the editor to open the list of available plug-in parameters, and click a parameter to assign it to the control.
4. Click on another control to set the Learn focus to that control and assign a parameter to it.

5. Press [Esc] to end Learn mode.

Removing the Parameter assignment

- To remove the parameter assignment for a cell, activate Learn mode, select the cell, and press [Delete] or [Backspace].
- To remove all assignments, click the “Remove All Assignments” button.

Assignment Status

You can show the current assignment of all cells in a layout by activating the “i” button in the top right corner of the editor. This is useful to get a quick overview of the parameters that are assigned to the available controls.

Editing the Layout

In the Layout section, you can perform a number of editing operations and arrange the pages to your liking.

Making Name Settings for the Cells

The top three text fields in the Inspector can be used to specify the names for a cell. This is useful if you are working with hardware devices that have value fields that only display a limited number of characters, for example. The first text field shows the long name, as it is shown in the cell. In the second field, you can enter a name that can contain up to 8 characters, and up to 4 characters in the third.
Rearranging the order of a page or a cell

- To copy the settings of one cell to another, select a cell, press [Alt]/[Option] and drag it to another cell.
- To move a cell, drag it to an empty cell.
- To swap the contents of two cells, press [Ctrl]/[Command] and drag one cell to the other.

**NOTE**
Drag and drop also works between different pages.

Navigating

- You can use the cursor keys to navigate in all directions.
- When Learn mode is active, pressing [Shift] allows you to step between the controls within the cells.
- To step forwards or backwards through the different layouts, use [Tab] and [Shift]-[Tab].

Adding/Removing Pages

- To add a page to a layout, click the “+” button on the right of a page.
- To remove a page, click the corresponding “-” button.

**NOTE**
A layout always contains at least one page.

Adding/Removing a New Hardware Layout

- To add a hardware layout for a particular hardware type, click the “+” button to the right of the tabs.
- To remove a hardware layout, click the “x” icon of a tab.

Changing the Settings in a Layout

- To modify an existing layout, save the new settings by clicking the Apply button in the top right corner of the editor.
  
  If the hardware supports this function, the changes are immediately reflected on the hardware controllers.
Remote controlling Cubase
Apple Remote (Macintosh only)

Resetting the Layout and Copying Layout Settings between Pages

Click the arrow button in the top right corner of the editor to revert to the default settings for the current layout or to copy the settings of one layout page to another.

Apple Remote (Macintosh only)

Many Apple computers come with an Apple Remote Control, a small hand-held device akin to TV remote controls. It allows you to remotely control certain features in Cubase.

PROCEDURE

1. Open the Device Setup dialog and select Apple Remote Control from the Add Device pop-up menu.
2. In the list on the right, the Apple Remote’s buttons are listed. For each button you can open a pop-up menu from which you can select a Cubase parameter. The parameter you select is assigned to the corresponding button on the Apple Remote.

By default, the Apple Remote always controls the application that currently has the focus on your Macintosh computer (provided that this application supports the Apple Remote).
Remote controlling Cubase
Apple Remote (Macintosh only)

NOTE
When the “Disable when application is not in front” option is not selected, the Apple Remote will control Cubase even if it does not have the focus.
MIDI realtime parameters and effects

For each MIDI track, you can set up a number of track parameters, or modifiers, and MIDI effects. These affect how the MIDI data is played back, “transforming” MIDI events in realtime before they are sent to the MIDI outputs.

On the following pages, the available parameters and effects are described. Keep in mind:

- The actual MIDI events will not be affected – the changes happen “on the fly”.
- Since the modifier settings do not change the actual MIDI data on the track, they will not be reflected in the MIDI editors. To convert the track settings into “real” MIDI events, use the Freeze MIDI Modifiers function or the Merge MIDI in Loop function.

RELATED LINKS
Making your settings permanent on page 674

The Inspector – general handling

The MIDI modifiers and effects are set up in the Inspector (although some settings are available in the MixConsole as well).

- To show the Inspector, click the “Set up Window Layout” button on the toolbar and activate the Inspector option.
  The Inspector is displayed to the left of the track list.

- For MIDI tracks, several sections are available in the Inspector. Which of these are displayed is determined in the setup context menu or the Setup dialog of the Inspector.
MIDI realtime parameters and effects
The Inspector sections

- You can fold or unfold the sections individually by clicking on the section name.
  Clicking the name for a hidden section brings it to view and hides the other sections. [Ctrl]/[Command]-clicking the tab allows you to hide or show a section without affecting other sections. [Alt]/[Option]-clicking a tab shows or hides all sections in the Inspector.

**NOTE**
Folding or hiding (via the Setup dialog) a section does not affect the functionality but merely hides the section from view. This means your settings will still be active even if you fold or hide the Inspector settings.

**RELATED LINKS**
Using the Setup options on page 1032

**The Inspector sections**

**Basic track settings**

The topmost Inspector section contains the basic track settings. These settings either affect the basic functionality for the track (mute, solo, enable record, etc.) or send out additional MIDI data to the connected devices (program change, volume, etc.). The section contains all settings that are available in the track list, with a few additional parameters:

**Load/Save Track Preset button**
Allows you to load or save a track preset.

**Track name field**
Click once to show/hide the topmost Inspector section. Double-click to rename the track.

**Edit button**
This opens the Channel Settings window for the track (a window showing a channel with volume fader and other controls, along with effect settings).

**Mute/Solo buttons**
Mutes or solos the MIDI track.

**Read/Write buttons**
Used for automating the track settings.

**Open Device Panels button**
Cubase Pro only: If the MIDI track is routed to a device with a panel, clicking this button opens the respective panel. For more information, see the separate PDF document “MIDI Devices”.

644
**Input transformer button**
Opens the Input Transformer dialog, allowing you to transform incoming MIDI events in realtime.

**Record enable button**
Activate this to make the track ready for recording.

**Monitor button**
When this is activated (and the "MIDI Thru Active" option is activated in the Preferences dialog, MIDI page), incoming MIDI will be routed to the selected MIDI output.

**Toggle Time Base button**
Switches between musical (tempo related) and linear (time related) time base for the track.

**Lock button**
Activate this to disable all editing of all events on the track.

**Show Lane button**
Allows you to divide the tracks in lanes.

**Volume**
Use this to adjust the level for the track. Changing this setting will move the track’s fader in the MixConsole and vice versa.

**MIDI Pan**
Use this to adjust the panning of the track.

**Delay**
This adjusts the playback timing of the MIDI track. Positive values delay the playback while negative values cause the track to play earlier. The values are set in milliseconds.

**In/Out/Chn pop-up menus**
This is where you select MIDI input, MIDI output, and MIDI channel for the track.

**Edit Instrument button**
If the MIDI track is routed to a VST instrument, clicking this button opens the control panel for the VST instrument.

**Bank and Program Selector pop-up menu**
Allows you to select a sound, see below. (If no bank is available, only the Program selector is shown.)

**Apply Track Preset button**
Allows you to apply a track preset.
MIDI realtime parameters and effects
The Inspector sections

Map pop-up menu

Allows you to select a drum map for the track.

**NOTE**

- Note that the functionality of the Bank and Program selector settings (used for selecting sounds in the connected MIDI instrument) depends on the instrument to which the MIDI output is routed, and how you have set it up in the MIDI Device Manager. The MIDI Device Manager allows you to specify which MIDI instruments and other devices are connected to the various MIDI outputs, thus making it possible to select patches by name.

- Many of the basic track settings are duplicated in the MIDI Fader section of the Inspector.

**RELATED LINKS**

- Track List on page 56
- Using Channel Settings on page 348
- Writing Automation Data on page 577
- The Input Transformer on page 878
- Defining the Track Time Base on page 149
- Applying Track Presets on page 162
- Working with Lanes on page 145
- Setting Volume on page 323
- MIDI Fader section on page 651
- Using MIDI devices on page 658

Expression Map section (Cubase Pro only)

This section is used when working with the Expression Map features.

**RELATED LINKS**

- Expression maps (Cubase Pro only) on page 778

Note Expression section (Cubase Pro only)

This section is used when working with the Note Expression features.

**RELATED LINKS**

- Note Expression on page 792

MIDI Modifiers

The settings on this tab affect the MIDI events on the track in realtime during playback. They will also be in effect if you play “live” with the track selected and record enabled (provided that “MIDI Thru Active” is activated in the Preferences dialog, MIDI page). This makes it possible, for example, to transpose or adjust the velocity of your live playing.
**NOTE**

If you want to compare the result of your modifier settings with the “unprocessed” MIDI, you can use the Bypass button in the MIDI Modifiers section. When this is activated, the MIDI Modifiers settings will be temporarily disabled. A bypassed section is indicated by a yellow Bypass button.

---

**Transpose**

This allows you to transpose all notes on the track in semitones. The available range is -127 to +127 semitones, but remember that the total range of MIDI note numbers is 0 to 127. Furthermore, not all instruments can play back notes over the whole range. Therefore, extreme transpositions can give rather strange and unwanted results.

- You can also transpose individual MIDI parts using the Transpose field in the info line. The transposition in the info line (for the individual part) is added to the transpose value you have set up for the whole track in the Inspector.

**NOTE**

This setting is also affected by the global Transpose settings.

---

**Velocity Shift**

This setting lets you change the dynamics of all notes on the track. The value in this field is added to the velocity of each note message that is sent out (use negative values to lower the velocities). The range is -127 to +127 with 0 representing no change in velocity.

Note that the effect of changing the velocity depends on the sound and instrument.

**NOTE**

You can also adjust the velocity of events in individual MIDI parts using the Velocity field in the info line. The velocity shift in the info line (for the individual part) is added to the velocity shift you have set up for the whole track in the Inspector.
Velocity Compression

This function multiplies the velocity values with the factor you specify. This factor is set using a numerator (left value) and a denominator (right value), resulting in a fractional number (1/2, 3/4, 3/2 etc.). For example, if you set the factor to 3/4, the velocities will be three quarters of their original values. This will also affect the difference in velocity between the notes, thus compressing or expanding the velocity scale. Typically, you would combine this setting with the Velocity Shift parameter.

An example:

Let’s say you have three notes with the velocity values 60, 90 and 120, and wish to “even out” the velocity differences somewhat. If you set the Velocity Compression value to 1/2, the notes will play back with the velocities 30, 45 and 60. By adding 60 in the Velocity Shift field, the notes will play back with the velocities 90, 105 and 120, meaning you have compressed the velocity range.

In a similar way, you can use Velocity Compression values greater than 1/1 together with negative values in the Velocity Shift field, to expand the velocity range.

**IMPORTANT**

Remember that the maximum velocity is always 127 no matter how much you try to expand.

Length Compression

This value adjusts the lengths of all notes on the track. As with Velocity Compression, the value is set with a numerator and denominator. For example, the value 2/1 means that all note lengths will be doubled, while 1/4 means all note lengths will be a quarter of the actual lengths.

Random

The Random settings let you introduce random variations to various properties of MIDI notes. Anything from very subtle variations to dramatic changes can be applied.

Range

The Range function lets you specify a note (pitch) or velocity range and either force all notes to fit within this range, or exclude all notes outside this range from playback. As with the Random function, there are two separate Range settings.

HMT: Follow

Activating this button for a track applies Hermode Tuning to the notes played on this track. Hermode Tuning retunes the notes you play and creates clear frequencies for every fifth and third interval, for example. Retuning only affects individual notes and maintains the pitch relationship between keys and notes. The retuning is a continuous process and takes the musical context into account.
When you apply Hermode Tuning to tracks that use VST 2 instruments, the played notes are retuned with every keystroke. Dynamic retuning while notes are playing is only possible with VST 3 instruments that support Micro Tuning and Note Expression. For VST instruments that support Note Expression, Hermode Tuning also works in MIDI Thru mode.

To activate Hermode tuning, activate the “HMT: Follow” button, and select one of the following tuning types in the “HMT Type” pop-up menu of the Project Setup dialog:

<table>
<thead>
<tr>
<th>Mode</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>None</td>
<td>No tuning is applied.</td>
</tr>
<tr>
<td>Reference (pure 3/5)</td>
<td>Tunes pure thirds and fifths.</td>
</tr>
<tr>
<td>Classic (pure 3/5 equalized)</td>
<td>Tunes pure thirds and fifths. In conflict situations, a slight equalization is applied. This tuning type is suitable for all kinds of music.</td>
</tr>
<tr>
<td>Pop Jazz (3/5/7)</td>
<td>Tunes pure thirds and fifths, and natural sevenths. This tuning type should not be applied to polyphonic music. Try this with pop or jazz.</td>
</tr>
<tr>
<td>Baroque (3/5 adaptive)</td>
<td>Tunes pure thirds and fifths. The degree of purity changes according to the sequence of harmonies. This tuning type is suitable for church organ and polyphonic music.</td>
</tr>
</tbody>
</table>

**NOTE**

It may take a moment until all notes are recalculated and you hear the results of the retuning. Notes that are produced by MIDI plug-ins are not taken into account.

**HMT: Use for Analysis**

If you activate this option, the notes played on the track are used to calculate retuning. Keep this activated when working with Hermode Tuning. On tracks with acoustic piano, we recommend to activate this option, and to deactivate “HMT: Follow”. This excludes the piano from being tuned which would sound unnatural.

**RELATED LINKS**

Transpose Functions on page 271

**Editing Transpose and Velocity for MIDI Parts**

When one or several MIDI parts are selected, the info line contains transpose and velocity fields.

- Adjusting the Transpose field transposes the selected parts in semitone steps.
- Adjusting the Velocity field shifts the velocity for the selected parts. The value that you specify is added to the velocities of the notes in the parts.
NOTE
This transposition does not change the actual notes in the part. It only affects the notes on playback. The transposition that you specify for a part on the info line is added to the transposition set for the whole track.

RELATED LINKS
Transpose Functions on page 271

Setting up random variations

There are two separate “random generators”, set up in the following way:

PROCEDURE
1. Open the Random pop-up menu and select which note property is randomized.
   The options are position, pitch, velocity and length.

   NOTE
   Keep in mind that depending on the content of the track, certain parameter changes might not be immediately noticeable or have any effect at all (as would be the case if applying random length to a percussion track playing “one-shot” samples for example). To best audition the random changes, choose a track with clearly defined rhythm and note content (as opposed to a string pad).

2. Set the desired range of random deviation by entering values in the two number fields.
   The two values govern the limits of the randomization, so that the values will vary between the left value and the right value (you cannot set the left value higher than the right value). The maximum random range for each property is listed in the table below:

<table>
<thead>
<tr>
<th>Property</th>
<th>Range</th>
</tr>
</thead>
<tbody>
<tr>
<td>Position</td>
<td>-500 to +500 ticks</td>
</tr>
<tr>
<td>Pitch</td>
<td>-120 to +120 semitones</td>
</tr>
<tr>
<td>Velocity</td>
<td>-120 to +120</td>
</tr>
<tr>
<td>Length</td>
<td>-500 to +500 ticks</td>
</tr>
</tbody>
</table>

   NOTE
   You can make independent settings for the two random generators.

   To deactivate the Random function, open the Random pop-up menu(s) and select “OFF”.

650
MIDI realtime parameters and effects
The Inspector sections

Setting up ranges

**PROCEDURE**

1. Open the Range pop-up menu and select one of the following four modes:

<table>
<thead>
<tr>
<th>Mode</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Vel. Limit</td>
<td>This function affects all velocity values outside the specified range. Velocity values below the Min setting (the lower limit of the range) are set to the Min value, and velocity values above the Max setting are set to the Max value. Notes with velocity values within the set range are not affected. Use this if you want to force all velocity values to fit within a certain range.</td>
</tr>
<tr>
<td>Vel. Filter</td>
<td>Velocity Filter works by excluding all notes with velocity values outside the specified range. Notes with velocity values below the Min setting or above the Max setting will not be played back. Use this to “isolate” notes with certain velocity values.</td>
</tr>
<tr>
<td>Note Limit</td>
<td>This function allows you to specify a pitch range, and forces all notes to fit within this range. Notes outside the specified range are transposed up or down in octave steps until they fit within the range. Note: If the range is too “narrow”, so that some notes cannot be fit within the range by octave-transposing, these notes will get a pitch in the middle of the range. For example, if you have a note with a pitch of F3, and the range is C4-E4, that note will be transposed to D4.</td>
</tr>
<tr>
<td>Note Filter</td>
<td>Note Filter works by excluding all notes with pitches outside the specified range. Notes lower than the Min setting or higher than the Max setting will not be played back. Use this to “isolate” notes with certain pitches.</td>
</tr>
</tbody>
</table>

2. Use the two fields to the right to set the minimum and maximum values. These values will be shown as numbers (0 to 127) for the velocity modes and as note numbers (C-2 to G8) for the pitch modes.

**NOTE**

Note that you can make independent settings for the two Range functions.

To deactivate the Range function, open the Range pop-up menu(s) and select “OFF”.

MIDI Fader section

This contains a single channel, allowing you to set volume, pan, mute/solo and other parameters for the track, and a panel view of the active sends/inserts. This is a “mirror” of the track’s channel in the MixConsole.

Notepad section

This is a standard notepad, allowing you to enter notes and comments about the track. Each track has its own notepad in the Inspector.
VST Instrument section

If the MIDI track is routed to a VST instrument, a new section will appear at the bottom of the Inspector, labeled with the name of the VST instrument. Clicking this section shows a duplicate of the Inspector settings for the VST instrument channel. This makes it easy to adjust the channel settings for the VST instrument while you are editing the MIDI track.

- If multiple outputs for a VST instrument are activated, there is a setting called “Output” at the top of the VST Instrument section.

New sections will also be added in the following cases:

- When a MIDI track is routed to an external instrument or effect that has an associated MIDI Device. In this case, the new section will get the name of the device.
- When a MIDI track is routed to an effect plug-in that also receives audio data, i.e. that is used as an insert effect for an audio track (e.g. MIDI Gate), a section for this audio track appears in the MIDI track inspector.
- If a MIDI track is routed to a plug-in assigned to an FX channel track, an FX section is added to the Inspector.

NOTE
For an easy way to combine MIDI and VST instruments, check out instrument tracks.

RELATED LINKS
VST Instruments on page 599

Device Panel section (Cubase Pro only)

This allows you to display MIDI device panels, which are control panels for external hardware. This is described in the separate PDF document “MIDI Devices”.

Quick Controls section

This allows you to configure quick controls, e.g. to use remote devices.

RELATED LINKS
Track Quick Controls on page 618

MIDI effects

Cubase comes with a number of MIDI effect plug-ins, capable of transforming the MIDI output from a track in various ways.
MIDI realtime parameters and effects
MIDI effects

Just like the MIDI modifiers, MIDI effects are applied in realtime to the MIDI data played back from the track (or to MIDI you play live “thru” the track).

What are MIDI effects?

Although a MIDI effect can be similar to an audio effect, it is important to remember that you are not processing the sound resulting from MIDI playback, but the MIDI data (the “instructions” for how the music is played back).

A MIDI effect will change properties of the MIDI events (e.g. change the pitch of notes) and/or generate new MIDI events (for example, a MIDI delay may add new MIDI notes, “echoing” the original notes).

NOTE

The included MIDI effect plug-ins are described in the separate PDF document “Plug-in Reference”.

Insert and send effects

As with audio effects, there are two ways to route the MIDI events on a track to an effect:

NOTE

- If you add an insert effect, the MIDI events will be sent to the effect, which will process the data and pass it on to the track’s MIDI output (or to another insert effect). In other words, the MIDI events will be routed “through” the insert effect.
- If you use a send effect, the MIDI events will be sent both to the track’s MIDI output and to the effect. That is, you will get both the unprocessed MIDI events and the output of the MIDI effect. Note that the effect can send its processed MIDI data to any MIDI output – not necessarily to the one used by the track.

There are separate sections in the Inspector for MIDI inserts and MIDI sends.

MIDI Inserts section

This allows you to add up to four MIDI insert effects. The section contains the following items:
**Preset Management button**

Click this to open the Preset Management pop-up menu that allows you to save your settings as preset or to rename or remove the current preset.

**Inserts State indicator and Bypass button**

The symbol on the right of the title bar is blue when an insert effect is activated. You can click the symbol to bypass all insert effects for the track.

**Effect selection pop-up menu (x4)**

Selecting an effect from this pop-up menu automatically activates it and brings up its control panel (which can be a separate window or a number of settings below the insert slot in the Inspector). To remove an insert effect completely, select “No Effect”.

**On button (x4)**

Allows you to turn the selected effect on or off.

**Edit button (x4)**

Click this to bring up the control panel for the selected effect. Depending on the effect, this may appear in a separate window or below the insert slot in the Inspector. Clicking the button again hides the control panel.

**NOTE**

Effects that display their controls in the Inspector can be opened in a separate control panel window by pressing [Alt]/[Option] and clicking the Edit button.

---

**MIDI Sends section**

This allows you to add up to four MIDI send effects. Unlike audio send effects, you can select and activate send effects individually for each track. The section contains the following items:

**Sends State indicator and Bypass button**

The symbol on the right of the title bar is blue when a send effect is activated. You can click the symbol to bypass all send effects for the track.
MIDI realtime parameters and effects

MIDI effects

Effect selection pop-up menu (x4)
Selecting an effect from this pop-up menu automatically activates it and
brings up its control panel (which can be a separate window or a number of
settings below the send slot in the Inspector). To remove a send effect
completely, select “No Effect”.

On button (x4)
Allows you to turn the selected effect on or off.

Pre/Post button (x4)
If this is activated, the MIDI signals will be sent to the send effects before the
MIDI modifiers and insert effects.

Edit button (x4)
Click this to bring up the control panel for the selected effect. Depending on
the effect, this may appear in a separate window or below the sends slot in
the Inspector. Clicking the button again hides the control panel.

Output pop-up menu (x4)
This determines to which MIDI output the effect will send the processed MIDI
events.

Channel setting (x4)
This determines on which MIDI channel the effect will send the processed
MIDI events.

NOTE
Effects that display their controls in the Inspector can be opened in a separate
control panel window by pressing [Alt]/[Option] and clicking the Edit button.

About presets
Several of the MIDI plug-ins come with a number of presets for instant use.
MIDI realtime parameters and effects

MIDI effects

1) MIDI In and Out activity indicators
2) Save and Remove Preset buttons

- To load a preset, select it from the Presets pop-up menu of the plug-in.
- To save your current settings as a preset, click on the “+” button (“Save Preset”) to the right of the Presets menu. You will be asked to specify a name for the preset. The saved preset will then be available for selection from the pop-up menu for all instances of that MIDI plug-in, in all projects.
- To remove a preset, select it and click on the “-” button (“Remove Preset”).

At the left and right borders of the Presets pop-up menu you will also find MIDI In and Out activity indicators. Whenever the plug-in receives or transmits MIDI data, the left or the right indicator will light up, respectively.

Applying a MIDI insert effect – an example

Here is a step-by-step example of how to add a MIDI insert effect to a MIDI track:

**PROCEDURE**

1. Select the MIDI track and open the Inspector.
2. Open the MIDI Inserts tab in the Inspector.
   Alternatively you can use the MixConsole: activate the Channel Racks and select “Inserts”.
3. Click in one of the insert slots to open the MIDI effect pop-up menu.
4. Select the desired MIDI effect from the pop-up menu.
   The effect is automatically activated (the power button for the insert slot lights up) and its control panel appears, either in a separate window or in the MIDI Inserts section below the slot (depending on the effect).
   Now all MIDI from the track will be routed through the effect.
5. Use the control panel to make settings for the effect.

   All included MIDI effects are described in the separate PDF document “Plug-in Reference”.
   • You can bypass the insert effect by clicking its power button (above the insert slot).
   • To bypass all insert effects for the MIDI track, use the bypass button in the MIDI Inserts section in the Inspector, in the MixConsole toolbar or in the track list.
   • To remove an insert effect, click in its slot and select “No Effect”.

Recording a MIDI Insert Effect

You can record the output of a MIDI insert effect, that is, the events are created directly on a MIDI or instrument track.

PROCEDURE

1. Select Project > Add Track > Instrument.
2. In the Add Instrument Track dialog, select a VST instrument.
4. In the Inspector, select MIDI Inserts.
5. Click the first insert effect slot and select a MIDI insert effect.
6. Activate the Record Output to Track button above the insert effect slot.
7. Activate Record and use your MIDI keyboard or the virtual keyboard to play some notes.

   The notes are modified by the MIDI insert effect and recorded directly on the track.

AFTER COMPLETING THIS TASK

You can edit the recorded MIDI events, in the Key Editor, for example.
Using MIDI devices

The MIDI Device Manager allows you to specify and set up your MIDI devices, making global control and patch selection easy.

But the MIDI Device Manager also features powerful editing functions that can be used to create MIDI device panels (Cubase Pro only). MIDI device panels are internal representations of external MIDI hardware, complete with graphics. The MIDI device panel editor provides all the tools you need to create device maps where every parameter of an external device (and even an internal device like a VST instrument) can be controlled and automated from inside Cubase.

For additional information on how to create panels for VST instruments, see the separate PDF document “MIDI Devices”.

RELATED LINKS
About Device panels (Cubase Pro only) on page 668

MIDI devices – general settings and patch handling

On the following pages, we will describe how to install and set up preset MIDI devices, and how to select patches by name from within Cubase. For a description on how to create a MIDI device from scratch, please refer to the separate PDF document “MIDI Devices”.

About Program Change and Bank Select

To instruct a MIDI instrument to select a certain patch (sound), you send a MIDI Program Change message to the instrument. Program Change messages can be recorded or entered in a MIDI part like other events, but you can also enter a value in the Program Selector field in the Inspector for a MIDI track. This way, you can quickly set each MIDI track to play a different sound.

With Program Change messages, you are able to select between 128 different patches in your MIDI device. However, many MIDI instruments contain a larger number of patch locations. To make these available from within Cubase, you need to use Bank Select messages, a system in which the programs in a MIDI instrument are divided into banks, each bank containing 128 programs. If your instruments support MIDI Bank Select, you can use the Bank Selector field in the Inspector to select a bank, and then the Program Selector field to select a program in this bank.
Unfortunately, different instrument manufacturers use different schemes for how Bank Select messages are constructed, which can lead to some confusion and make it hard to select the correct sound. Also, selecting patches by numbers this way seems unnecessarily cumbersome, when most instruments use names for their patches nowadays.

To help with this, you can use the MIDI Device Manager to specify which MIDI instruments you have connected by selecting from a vast list of existing devices or by specifying the details yourself. Once you have specified which MIDI devices you are using, you can select to which particular device each MIDI track is routed. It is then possible to select patches by name in the track list or Inspector.

**Opening the MIDI Device Manager**

Select MIDI Device Manager from the Devices menu to bring up the following window:

MIDI Device Manager dialog in Cubase Pro.
MIDI Device Manager dialog in Cubase Artist.

**Installed Devices**
List of connected MIDI devices. The first time you open the MIDI Device Manager, this list will be empty.

**Install Device/Remove Device**
Use these buttons to install/remove devices.

**Export Setup/Import Setup**
Use these buttons to import/export XML Device setups.

**Open Device (Cubase Pro only)**
This button opens the selected device.

**Output**
Here you specify to which MIDI output the selected device is connected.

**Commands (Cubase Artist only)**
This pop-up menu lets you edit the selected device (provided that “Enable Edit” is ticked). The patch structure for the selected device is shown on the left side of the dialog.

**MIDI Messages (Cubase Artist only)**
This area on the right side of the dialog shows exactly which MIDI messages are sent out to select the patch highlighted in the list to the left.

When you open the MIDI Device Manager for the first time, it will be empty (because you have not installed any devices yet). On the following pages we describe how to add a pre-configured MIDI device to the list, how to edit the settings and how to define a device from scratch.
Note that there is an important difference between installing a preset MIDI device ("Install Device") and importing a MIDI device setup ("Import Setup"):

- The presets do not include any device mapping of parameters and controls and no graphic panels. They are simply patch name scripts. When you install a preset MIDI device, it is added to the Installed Devices list. For more information about patch name scripts, see the separate PDF document “MIDI Devices”.

- A device setup can include device mapping, panels and/or patch information. Device setups are also added to the list of installed devices when imported.

**RELATED LINKS**

About Device panels (Cubase Pro only) on page 668

---

**Defining a new MIDI device (Cubase Pro only)**

If your MIDI device is not included in the list of pre-configured devices (and is not a “plain” GM or XG device), you need to define it manually to make it possible to select patches by name. This is handled slightly differently for Cubase Pro and Cubase Artist.

**PROCEDURE**

1. In the MIDI Device Manager, click the Install Device button. The Add MIDI Device dialog opens.

2. Select “Define New…” and click OK. The “Create New MIDI Device” dialog opens. For a description of the options in this dialog, see the separate PDF document “MIDI Devices”.

3. In the Identical Channels list, activate the MIDI channels you would like the device to use. This means that the device will receive Program Change over any MIDI channel. For a description of Identical and Individual Channels, see the separate PDF document “MIDI Devices”.

4. Enter a name for the device at the top of the dialog, and click OK. The device appears in the Installed Devices list, and the device node structure for the device is automatically shown in a new window.

5. Select Patch Banks from the pop-up menu at the top of the window. As you can see, the list is currently empty.

6. Make sure that the Enable Edit checkbox is activated. Now you can use the functions on the Commands pop-up menu on the left to organize the patch structure of the new device.
Defining a new MIDI device (Cubase Artist only)

If your MIDI device is not included in the list of pre-configured devices (and is not a “plain” GM or XG device), you need to define it manually to make it possible to select patches by name.

**PROCEDURE**

1. In the MIDI Device Manager, click the Install Device button.
   The Add MIDI Device dialog opens.
2. Select “Define New…” and click OK.
   A dialog appears.
3. Enter the name of the device and the MIDI channels you would like the device to use and click OK.
   The device appears in the Installed Devices list.
4. Select the device in the list.
   As you can see, it currently contains only an Empty Bank item.
5. Make sure that the Enable Edit checkbox is activated.
   Now you can use the functions on the Commands pop-up menu on the left to organize the patch structure of the new device.

Installing a preset MIDI device

**PROCEDURE**

1. Click the Install Device button.
   A dialog opens listing all pre-configured MIDI devices. For now we assume that your MIDI device is included in this list.
2. Locate and select the device in the list and click OK.
   If your MIDI device is not included in the list but is compatible with the GM (General MIDI) or XG standards, you can select the generic GM or XG Device options at the top of the list.
   When you select one of these options, a name dialog will appear. Enter a name for the instrument and click OK.
   The device now appears in the Installed Devices list to the left.
3. Make sure that the new device is selected in the list and open the Output pop-up menu.
4. Select the MIDI output that the device is connected to.
5. If you are using Cubase, click the Open Device button.
   A separate window opens for the selected device, showing a node structure in the left half of the window. At the top of this structure is the device itself, and below it the MIDI channels used by the device. For more information about the Device window, see the separate PDF document “MIDI Devices”.

662
6. Select Patch Banks from the pop-up menu at the top of the window.

RESULT

The Patch Banks list in the left half of the window shows the patch structure of the device. This could simply be a list of patches, but it is usually one or several layers of banks or groups containing the patches (much like a folder structure on a hard disk for example).

- You can rename a device in the Installed Devices list by double-clicking and typing – this is useful if you have several devices of the same model, and want to separate them by name instead of by number.

- To remove a device from the Installed Devices list, select it and click Remove Device.

NOTE

Note that if there already exists a panel for the device (Cubase Pro only), opening the device might open this panel first. In this case, click on the Edit ("e") button to open the Device window.

About Patch Banks

Depending on the selected device, you may find that the Patch Banks list is divided in two or more main banks. Typically, these are called Patches, Performances, Drums, etc. The reason for having several patch banks is that different “types” of patches are handled differently in the instruments. For example, while “patches” typically are “regular” programs that you play one at the time, “performances” may be combinations of programs, which could be split across the keyboard, layered, or used for multi-timbral playback, and so on.

Cubase Pro only: For devices with several banks, you will find an additional item labeled “Bank Assignment” in the pop-up menu at the top of the window. Selecting this opens a window in which you can specify for each MIDI channel which bank it should use.
Cubase Artist only: Devices with several banks have an additional tab “Bank Assignment”. Select this tab to specify for each MIDI channel which bank it should use.

The selection here will affect which bank is displayed when you select programs by name for the device in the track list or Inspector. For example, many instruments use MIDI channel 10 as an exclusive drum channel, in which case you would want to select the “Drums” (or “Rhythm Set”, “Percussion”, etc.) bank for channel 10 in this list. This would then let you choose between different drum kits in the track list or Inspector.

Limitations

There is no easy way to import a patch name script into an existing MIDI device. For a complex workaround based on XML editing, see the separate PDF document “MIDI Devices”.

Selecting a patch for an installed device

If you return to the Project window at this point, you will find that the installed device has been added to the MIDI Output menus (in the track list and the Inspector). Now you can select patches by name, in the following way:

PROCEDURE

1. Open the Output menu (in the track list or Inspector) for the track you want to associate the installed device with, and select the device.
   
   This directs the track to the MIDI output specified for the device in the MIDI Device Manager. The Bank and Program Selector fields in the track list and Inspector are replaced by a single Program Selector field that currently reads “Off”.

2. Click the Program Selector field to display a pop-up menu, hierarchically listing all the patches in the device.
   
   The list is similar to the one displayed in the MIDI Device Manager. You can scroll the list up and down (if required), click the plus/minus signs to show or hide subgroups, etc.

   You can also use a filter function here. For this, enter the search term in the Filter field, e.g. “drum”, and press [Return] to display all sounds with “drum” in the name.
3. Click a patch in the list to select it.
   This sends the appropriate MIDI message to the device. You can also scroll the program selection up or down, as with any value.

Renaming patches in a device

The pre-configured devices list is based on the factory-preset patches, i.e. the patches included in the device when you first bought it. If you have replaced some of the factory presets with your own patches, you need to modify the device so that the patch name list matches the actual device:

PROCEDURE
1. In the MIDI Device Manager, select the device in the Installed Devices list.
2. If you are using Cubase, click Open Device.
   Make sure that Patch Banks is selected on the pop-up menu at the top of the window.
3. Activate the Enable Edit checkbox.
   When this is turned off (default), you cannot edit the pre-configured devices.
4. In the Patch Banks list, locate and select the patch you want to rename.
   In many instruments, the user-editable patches are located in a separate group or bank.
5. Click on the selected patch in the Patch Banks list to edit its name.
6. Type in the new name and press [Return].
7. Rename the desired patches in this way, and finish by deactivating Enable Edit again (to avoid modifying the device by accident).

NOTE
You can also make more radical changes to the patch structure in a device (adding or deleting patches, groups or banks), see below. For example, this is useful if you expand your MIDI device by adding extra storage media such as RAM cards.

Patch Structure

Patches are structured as follows:

- Banks are the main categories of sounds – typically patches, performances and drums, as described above.
- Each bank can contain any number of groups, represented by folders in the list.
- The individual patches, performances or drum kits are represented by presets in the list.
The Commands pop-up menu contains the following items:

**Create Bank**

Creates a new bank at the highest hierarchical level of the Patch Banks list. You can rename this by clicking on it and typing a new name.

**New Folder**

Creates a new subfolder in the selected bank or folder. This could correspond to a group of patches in the MIDI device, or just be a way for you to categorize sounds, etc. When you select this item, a name dialog opens, allowing you to name the folder. You can also rename the folder afterwards by clicking it and typing in the list.

**New Preset**

This adds a new preset in the selected bank or folder. You can rename the preset by clicking it and typing a new name.

When the preset is selected, the corresponding MIDI events (Program Change, Bank Select, etc.) are shown in the event display to the right. The default setting for a new preset is Program Change 0 — to change this, proceed as follows:

**IMPORTANT**

For details on which MIDI events are used for selecting patches in the MIDI device, consult its documentation.

- To change which Program Change value is sent out to select the patch, adjust the number in the Value column for the Program Change event.

- To add another MIDI event (e.g. Bank Select) click directly below the last event in the list and select a new event from the pop-up menu. After adding a new event, you need to set its value in the Value column, as with Program Change.

- To replace an event, click on it and select another event from the pop-up menu.

  For example, a MIDI device may require that a Bank Select message is sent first, followed by a Program Change message, in which case you would need to replace the default Program Change message with a Bank Select message and add a new Program Change after that.

- To remove an event, select it and press [Delete] or [Backspace].

**IMPORTANT**

Different devices use different schemes for Bank Select. When you insert a Bank Select event, you should check the device’s documentation to find out whether to choose “CC: BankSelect MSB”, “Bank Select 14 Bit”, “Bank Select 14 Bit MSB-LSB Swapped” or some other option.

**Add Multiple Presets**

This opens a dialog, allowing you to set up a range of presets to be added to the selected bank or folder.
Adding Multiple Presets

**PROCEDURE**

1. **Add** the event types required for selecting a patch in the MIDI device.
   This is done just as when editing the settings for a single event: clicking in the event display brings up a pop-up menu from which you can select an event type.

2. **Use** the Range column to set up either a fixed value or a range of values for each event type in the list.
   This requires some explanation:
   If you specify a single value in the Range column (e.g. 3, 15 or 127), all added presets will have an event of this type set to the same value.
   If you instead specify a value range (a start value and an end value, separated by a dash, e.g. 0–63), the first added preset will have an event set to the start value, the next value will be incrementally raised by one and so on, up to and including the end value.

   ![Table Example](image)

   **NOTE**
   The number of added presets depends on the Range setting.

3. **Specify** a Default Name below the event display.
   The added events will get this name, followed by a number. You can rename presets manually in the Patch Banks list later.

4. **Click** OK.
   A number of new presets have now been added to the selected bank or folder, according to your settings.

**Other editing functions**

- You can move presets between banks and folders by dragging them to the Patch Banks list.
- You can remove a bank, folder or preset by selecting it in the Patch Banks list and pressing [Backspace].
- **Cubase Pro only:** If you specify more than one bank, a Bank Assignment item is added to the pop-up menu at the top of the window. Use this to assign banks to the different MIDI channels.
- **Cubase Artist only:** If you specify more than one bank, a Bank Assignment tab is added next to the Patch Banks tab.

**RELATED LINKS**

- About Patch Banks on page 663
About Device panels (Cubase Pro only)

On the following pages we will describe how to use MIDI Device panels and the powerful MIDI device panel editing features of the MIDI Device Manager.

**NOTE**

We recommend that you first configure the patch banks, then export the device setup before editing the panels. This way, most of your settings will be saved in case of panel configuration problems.

The panels are saved in XML format. For more information, see the separate PDF document “MIDI Devices”.

**Basic concept**

The panel editing features in the MIDI Device Manager can be seen as a separate application or entity within Cubase. It allows you to build device maps complete with control panels, including all parameters controllable from within Cubase. Building more complex device maps requires that you are familiar with SysEx programming (see the separate PDF document “MIDI Devices”). But you can also create simpler panels by assigning MIDI Control Change messages to control objects, which does not require any programming skills.

Although these powerful editing features are there if you need them, you do not have to use them to use MIDI devices.

**Device panels in the program**

In this section we will take a look at a pre-configured MIDI device panel to illustrate how it can be used in Cubase. Several device maps can be found in the Knowledge Base on the Steinberg web site.

**Opening a device setup**

**PROCEDURE**

1. Open the MIDI Device Manager from the Devices menu.
2. Click the “Import Setup” button.
   A file dialog opens.
3. Select a device setup file.
   The Device setup files are saved in XML format, for more information see the separate PDF document “MIDI Devices”.
4. Click Open. The Import MIDI Devices dialog opens where you can select one or several devices for import.
   A device setup file can contain one or several MIDI devices.
5. Select a device and click OK.
The device is added to the list of installed devices in the MIDI Device Manager.

6. Select the correct MIDI output from the Output pop-up menu, select the device in the list and click the Open Device button.
The device panel opens in a separate window. The Edit ("e") button at the top opens the Edit Panel window, see the separate PDF document “MIDI Devices”.

7. Close the Device panel and return to the Project window.

8. Select the device from the “Output Routing” pop-up menu for a MIDI track.
Note that for some devices, you may have to set the MIDI channel to “Any”.

RESULT

Now the Device panel can be opened by clicking the Open Device Panels button in the Inspector or in the channel for the corresponding track in the MixConsole.

NOTE

Note that [Ctrl]/[Command]-clicking the Open Device Panels button allows you to open a subpanel via the panel browser pop-up menu.

Showing panels in the Inspector

PROCEDURE

1. In the Inspector, open the Device Panel section and click on the arrow on the right.
A “Panels” folder is shown with the selected device in a node structure below it. If you open all the folders, you can select any individual panel from the device that “fits” into the Device Panel space.

2. Select a panel from the list.
The panel opens in the Inspector.
NOTE

If you cannot see any panels in the “Panels” folder, although you have successfully set up a MIDI device with several panels, make sure that you selected the correct channel from the Channel pop-up menu, preferably “Any” to see all device panels. Also make sure that the panels fit into the space, otherwise they will not be available in the “Panels” folder.

Showing panels in the MixConsole

PROCEDURE
1. Open the MixConsole and activate the “Show Channel Racks” button.
2. Click Racks to open the rack selector and activate the Device Panels rack.
3. Click the Panel header to expand the Device Panels rack.
4. Click the button at the right of the header.
   The Panels folder is displayed like in the Inspector, but with different available panels. Just like in the Inspector, the panel has to “fit” into the available space to be selectable.
5. Select a panel.
   The panel is shown in the Channel Racks section of the MixConsole.

Automating device parameters

Automation works just like for normal audio and MIDI tracks:

PROCEDURE
1. Open the device panel by clicking the Open Device Panels button in the Inspector.
2. Activate Write automation on the device panel.
   You can automate the device by either moving knobs and sliders on the device panel or by drawing curves on the automation track for a selected parameter.
3. If you now go back to the Project window, there will be a MIDI Device Automation track in the track list.
   If the track is hidden, select “Show All Used Automation” on the Track Folding submenu of the Project menu.
If you click in the name field, all parameters in the device are shown and can be selected for automation.

- To open another automation track for the next parameter on the pop-up menu, click the + button ("Append automation track") at the bottom left of the automation track.

**NOTE**

If you wrote automation but your MIDI device is not yet connected, the panel will not display any parameter changes when playing back the track with the Read button activated.
This chapter describes the various MIDI processing functions available on the MIDI menu. They offer various ways to edit MIDI notes and other events, either in the Project window or from within a MIDI editor.

**MIDI functions vs. MIDI modifiers**

In some cases, the result of a MIDI function can also be obtained by using MIDI modifiers and effects. For example, the operations “Transpose” and “Quantize” are available both as MIDI modifiers and as MIDI functions.

The main difference is that MIDI modifiers and effects do not affect the actual MIDI events on the track in any way, while MIDI functions change the events “permanently” (although recent changes can be undone).

Use the following guidelines to decide which path to choose for operations that are available both as modifiers or effects and as functions:

- If you want to adjust a few parts or events only, use MIDI functions. The MIDI modifiers and effects affect the output of the whole track (although they can be made permanent in a specific area with the Merge MIDI in Loop function).
- If you want to experiment with different settings, use MIDI modifiers and effects.
- MIDI modifiers and effects settings are not reflected in the MIDI editors, since the actual MIDI events are not affected. This can be potentially confusing; if you have transposed notes using modifiers for example, the MIDI editors will still show the notes with their original pitch (but they will play back at their transposed pitch). Therefore, MIDI functions are a better solution if you want to see the effects of your editing in the MIDI editors.

**RELATED LINKS**

- MIDI realtime parameters and effects on page 643
What is affected by the MIDI functions?

Which events are affected when you use a MIDI function depends on the function, the active window and the current selection:

- Some MIDI functions only apply to MIDI events of a certain type. For example, quantization only affects notes, while the Delete Controllers function only applies to MIDI controller events.

- In the Project window, the MIDI functions apply to all selected parts, affecting all events (of the relevant types) in them.

- In the MIDI editors, the MIDI functions apply to all selected events. If no events are selected, all events in the edited part(s) will be affected.

Transpose

The “Transpose Setup...” option on the MIDI menu opens a dialog with settings for transposing the selected notes.

NOTE

You can also use the transpose track for transposing.

Semitones

This is where you set the amount of transposition.

Scale Correction

Scale Correction transposes the selected notes by forcing them to the closest note of the selected scale type. This can be used for creating interesting key and tonal changes, either by itself or in conjunction with the other settings in the Transpose Setup dialog.

- To activate Scale Correction, click the checkbox.
- Select a root note and scale type for the current scale from the upper pop-up menus.
• Select a root note and scale type for the new scale from the lower pop-up menus.

Make sure to select the correct root note if you want to keep the result in the same key as the original notes, or select an entirely different key if you want to experiment.

**Use Range**

When this is activated, transposed notes will remain within the limit that you specify with the Low and High values.

If a note would end up outside this limit after transposition, it is shifted to another octave, keeping the correct transposed pitch if possible. If the range between the upper and lower limit is very narrow, the note will be transposed “as far as possible”, i.e. to notes specified with the Low and High values. If you set Low and High to the same value, all notes will be transposed to this pitch!

**OK and Cancel**

Clicking OK performs the transposition. Clicking Cancel closes the dialog without transposing.

**RELATED LINKS**

Transpose Functions on page 271

---

**Making your settings permanent**

The settings described in the chapter “MIDI realtime parameters” do not change the MIDI events themselves, but work like a “filter”, affecting the music on playback. Therefore, you may want to make them permanent, i.e. convert them to “real” MIDI events, for example to transpose a track and then edit the transposed notes in a MIDI editor. For this, you can use two commands from the MIDI menu: “Freeze MIDI Modifiers” and “Merge MIDI in Loop”.

**RELATED LINKS**

MIDI realtime parameters and effects on page 643

---

**Freeze MIDI Modifiers**

“Freeze MIDI Modifiers” applies all filter settings permanently to the selected track. The settings are “added” to the events on the track, and all modifiers are set to zero. The “Freeze MIDI Modifiers” function affects the following settings for MIDI tracks:

- Several settings on the main tab of the Inspector (program and bank selection and the Delay parameter).
- The settings on the MIDI Modifiers tab (i.e. Transpose, Velocity Shift, Velocity Compression, and Length Compression).
- The settings on the MIDI Inserts tab (for example, if you are using an arpeggiator and want to convert the added notes to real events).
The following settings for MIDI parts are taken into account as well:

- The Transpose and Velocity settings for parts displayed on the info line – the Volume setting is not taken into account.

**Merge MIDI in Loop**

The “Merge MIDI in Loop” function combines all unmuted MIDI events on all unmuted tracks, applies MIDI modifiers and effects, and generates a new MIDI part, containing all the events as you would hear them during playback.

**PROCEDURE**

1. Mute all the tracks that you do not want to include in the merge. Instead of muting whole tracks, you can also mute individual parts.
2. Set up the left and right locators to encompass the area that you want to merge. Only events starting within this area will be included.
3. Select the track on which you want the new part to be created. If you do not select a track, a new MIDI track is created. If several MIDI tracks are selected, the new part is inserted on the first selected track. Existing data on the selected track can be kept or overwritten (see below).
4. On the MIDI menu, select “Merge MIDI in Loop…”. The MIDI Merge Options dialog opens.
5. Activate the desired options and click OK. A new part is created between the locators on the destination track, containing the processed MIDI events.

**NOTE**

If you only want to include events from a single track in the merge operation, you may want to solo the track.

**RELATED LINKS**

**MIDI Merge Options Dialog on page 675**

**MIDI Merge Options Dialog**

The following options are available:

**Include Inserts**

If this is activated, any MIDI insert effects and MIDI modifiers currently activated for the tracks will be applied.

**Include Sends**

If this is activated, any MIDI send effects currently activated for the track(s) will be applied.
MIDI Processing
Making your settings permanent

Erase Destination
If this is activated, any existing MIDI data between the left and right locators on the destination track will be deleted.

Include Chase
If this is activated, events placed outside the selected part but relating to it will be included in the processing, e.g. a Program Change right before the left locator.

Convert VST3
If this is activated, all VST 3 data within the selected area is converted to MIDI data.

RELATED LINKS
Chase on page 209

Applying effects to a single part
Normally, the MIDI modifiers and effects affect a whole MIDI track. This may not always be what you want. For example, you may want to apply some MIDI effects to a single part (without having to create a separate track for that part only). The “Merge MIDI in Loop” function can help:

PROCEDURE
1. Set up your MIDI modifiers and MIDI effects the way you want them for the part.
   This will of course affect the whole track, but focus on the part for now.
2. Set the locators to encompass the part.
   An easy way to do this is to select the part and choose Locators to Selection from the Transport menu (or use the corresponding key command, by default [P]).
3. Make sure that the track holding the part is selected in the track list.
4. On the MIDI menu, select “Merge MIDI in Loop….”
   The MIDI Merge Options dialog opens.
5. Activate the desired options, making sure that “Erase Destination” is activated, and click OK.
   A new part is created on the same track, containing the processed events. The original part is deleted.
6. Turn off or reset all MIDI modifiers and effects, so that the track plays back as before.
Dissolve Part

The Dissolve Part function on the MIDI menu allows you to separate MIDI events according to channels or pitches:

- When you work with MIDI parts (on MIDI channel “Any”) containing events on different MIDI channels, activate the “Separate Channels” option.
- To separate MIDI events according to pitch, activate the “Separate Pitches” option.
  Typical examples are drum and percussion tracks, where different pitches usually correspond to separate drum sounds.

**NOTE**

When dissolving a part into either separate channels or separate pitches, you can automatically remove the silent (empty) areas of the resulting parts by activating the “Optimized Display” checkbox in the Dissolve Part dialog. This option is not available when “Dissolve to Lanes” is activated.

**RELATED LINKS**

Dissolving to lanes on page 679

Dissolving parts into separate channels

Setting a track to MIDI channel “Any” will cause each MIDI event to play back on its original MIDI channel, rather than a channel set for the whole track. There are two main situations when “Any” channel tracks are useful:

- When you record several MIDI channels at the same time.
  You may for example have a MIDI keyboard with several keyboard zones, where each zone sends MIDI on a separate channel. Recording on an “Any” channel track allows you to play back the recording with different sounds for each zone (since the different MIDI notes play back on separate MIDI channels).

- When you have imported a MIDI file of Type 0.
  MIDI files of Type 0 contain only one track, with notes on up to 16 different MIDI channels. If you were to set this track to a specific MIDI channel, all notes in the MIDI file would be played back with the same sound; setting the track to “Any” will cause the imported file to play back as intended.

The Dissolve Part function scans MIDI parts for events on different MIDI channels and distributes the events into new parts on new tracks, one for each MIDI channel found. This allows you to work with each musical part individually.
PROCEDURE
1. Select the parts containing MIDI data on different channels.
2. Select “Dissolve Part” from the MIDI menu.
3. In the dialog that opens, select the “Separate Channels” option.

RESULT
Now, for each MIDI channel used in the selected parts, a new MIDI track is created and set to the corresponding MIDI channel. Each event is then copied into the part on the track with the corresponding MIDI channel. Finally, the original parts are muted.

An example:

This part contains events on MIDI channels 1, 2, and 3.

Selecting “Dissolve Part” creates new parts on new tracks, set to channels 1, 2, and 3. Each new part contains only the events on the respective MIDI channel. The original MIDI part is muted.

Dissolving parts into separate pitches

The Dissolve Part function can also scan MIDI parts for events of different pitches, and distribute the events into new parts on new tracks, one for each pitch. This is useful when the different pitches are not used in a melodic context, but rather for separating different sounds (e.g. MIDI drum tracks or sampler sound FX tracks). By dissolving such parts, you can work with each sound individually, on a separate track.

PROCEDURE
1. Select the parts containing MIDI data.
2. Select “Dissolve Part” from the MIDI menu.
3. In the dialog that opens, select the “Separate Pitches” option.

A new MIDI track is created for each used pitch in the selected parts. The events are then copied into the parts on the track for the corresponding pitch. Finally, the original parts are muted.
Dissolving to lanes

In the lower right section of the Dissolve Part dialog, you will find the “Dissolve to Lanes” option. When this is activated, the part will not be dissolved onto different tracks but onto different lanes of the original track, allowing for a better management of MIDI material that “belongs together”.

This is useful when working with drums for example, as it allows you to split up a part into different drum sounds and edit these independently. When you have made the desired modifications, you can reassemble all your drums into one part using the Bounce MIDI command, see below.

This option is especially handy when working with instrument parts on instrument tracks. “Normal” dissolving would lead to a number of different tracks each routed to a separate instance of the connected VST instrument. When dissolving parts to lanes, the parts will still reside on the same track, with all parts using the same VST instrument instance.

Bounce MIDI

With this function, you can combine MIDI parts on several lanes to a single MIDI part. This can be used to reassemble a drum part that you dissolved onto several lanes for editing, see above. Simply select the MIDI parts on the different lanes that you want to combine and select “Bounce MIDI” on the MIDI menu.

During the bounce process, any muted parts will be removed. If transpose and velocity values were specified for the parts, these are taken into account as well.

Repeat Loop

With this function, the events inside the independent track loops will be repeated until the end of the part, i.e. the notes that were previously only played repeatedly are now actual notes on the MIDI track. Events to the right of the independent track loop (within the same part) will be replaced by this function.

RELATED LINKS

Setting Up the Independent Track Loop on page 496
Other MIDI functions

The following items can be found on the Functions submenu of the MIDI menu:

**Legato**

Extends each selected note so that it reaches the next note.

You can specify a gap or overlap for this function with the “Legato Overlap” setting in the Preferences dialog (Editing–MIDI page).

When using Legato with this setting, each note will be extended to end 5 ticks before the next note.

When you activate “Legato Mode: Between Selected Notes Only”, the length of the note will be adjusted so that it reaches the next selected note, allowing you to apply Legato only to your bass line, for example.

**NOTE**

You can also apply a legato using the “Scale Length/Legato” slider in the MIDI editors.

**RELATED LINKS**

Inspector on page 703

**Fixed Lengths**

This function resizes all selected notes to the length set with the Length Quantize pop-up menu on the MIDI editor toolbar.
**MIDI Processing**

**Other MIDI functions**

**Pedals to Note Length**

This function scans for Sustain pedal on/off events, lengthens the affected notes to match the Sustain pedal off position, and then removes the Sustain Controller on/off events.

**Delete Overlaps (mono)**

This function allows you to make sure that no notes of the same pitch overlap (i.e. that one starts before the other ends). Overlapping notes of the same pitch can confuse some MIDI instruments (a new Note On is transmitted before the Note Off is transmitted). This command can then be used to automatically solve the problem.

**Delete Overlaps (poly)**

This function shortens notes when required, so that no note begins before another ends. This happens regardless of which pitch the notes have.

**Velocity**

This function opens a dialog that allows you to manipulate the velocity of notes in various ways.

The following types of velocity processing are available:

**Add/Subtract**

This simply adds a fixed number to the existing velocity values. You set the value (positive or negative) with the Amount parameter.

**Compress/Expand**

Compresses or expands the “dynamic range” of MIDI notes by scaling the velocity values according to the Ratio setting (0 to 300%). The principle behind this is that multiplying different velocity values with a factor higher than 1 (over 100%) will also make the differences between velocity values greater, while using a factor lower than 1 (under 100%) will make the differences smaller. In short:

- To compress (“even out” velocity differences), use ratio values below 100%. After compression, you would probably want to add a velocity amount (with the Add/Subtract function) to maintain the average velocity level.
• To expand (create greater difference in velocity), use ratio values above 100%.

Before you expand, you may want to adjust the velocity with the Add/Subtract function, so that the average velocity is somewhere in the middle of the range. If the average velocity is high (near 127) or low (near 0), expansion will not work properly, simply because velocity values can only be between 0 and 127!

**Limit**

This function allows you to make sure that no velocity values fall outside a given range (the Lower and Upper values). Any velocity values outside this range are raised/lowered to exactly the Lower/Upper values.

**Fixed Velocity**

This function sets the velocity of all selected notes to the Insert Velocity value on the toolbar in the MIDI editors.

**Delete Doubles**

This function removes double notes, i.e. notes of the same pitch on the exact same position from the selected MIDI parts. Double notes can occur when recording in Cycle mode, after Quantizing, etc.

**Delete Notes**

Allows you to delete very short or weak notes. This is useful for automatically removing unwanted “ghost notes” after recording. Selecting “Delete Notes…” opens a dialog in which you set up the criteria for the function.

![Delete Notes dialog](image)

The parameters have the following functionality:

**Minimum Length**

When the Minimum Length checkbox is activated, the note length is taken into account, allowing you to remove short notes. You can either specify the minimum length (for notes to be kept) in the value field or by dragging the blue line in the graphical length display below.
• The graphical length display can correspond to 1/4 bar, one bar, two bars or four bars.

You change this setting by clicking in the field to the right of the display.

In this case, the whole length display corresponds to two bars, and the Minimum Length is set to 32nd notes (60 ticks).

Minimum Velocity

When the Minimum Velocity checkbox is activated, the velocity of notes is taken into account, allowing you to remove weak notes. You specify the minimum velocity (for notes to be kept) in the value display.

Remove when under

This setting is only available when both Minimum Length and Minimum Velocity is activated. By clicking in this field, you select whether both the length and the velocity criteria must be met for notes to be deleted, or whether one of the criteria will suffice.

OK and Cancel

Clicking OK performs the automatic delete according to the rules set up. Clicking Cancel closes the dialog without deleting notes.

Delete Controllers

This function removes all MIDI controllers from the selected MIDI parts.

Delete Continuous Controllers

This function removes all “continuous” MIDI controller events from the selected MIDI parts. Therefore, “on/off” events such as sustain pedal events are not removed.

Restrict Polyphony

Selecting this item opens a dialog in which you can specify how many “voices” are used (for the selected notes or parts). Restricting the polyphony this way is useful when you have an instrument with limited polyphony and want to make sure all notes will be played. The effect is achieved by shortening notes as required, so that they end before the next note starts.
Thin Out Data

Thins out MIDI data. Use this to ease the load on your external MIDI devices if you have recorded very dense controller curves, etc.

**NOTE**

Cubase Pro only: This also thins out MIDI controller and VST 3 events that form part of Note Expression data.

You can also manually thin out the controller data by using the quantize function in the Key Editor.

Extract MIDI Automation

This is an extremely useful function as it allows you to quickly and easily convert the continuous controllers of your recorded MIDI parts into MIDI track automation data, making them available for editing in the Project window.

**PROCEDURE**

1. Select the desired MIDI part containing the continuous controller data.
2. On the MIDI menu, open the Functions submenu and select “Extract MIDI Automation”.
3. In the Project window, open the automation tracks for the respective MIDI track. You will find that an automation track has been created for each of the continuous controllers in the part.

**RESULT**

**NOTE**

In the MIDI editors, the controller data will automatically be removed from the controller lane.

This function can only be used for continuous controllers. Data such as Aftertouch, Pitchbend, or SysEx cannot be converted to MIDI track automation data.

**NOTE**

MIDI controller automation is also affected by the Automation Merge Mode.

**RELATED LINKS**

MIDI Controller Automation on page 595
Merge Tempo from Tapping (Cubase Pro only) on page 685
Reverse

This function inverts the order of the selected events (or of all events in the selected parts) rhythmically, causing the MIDI music to play backwards. Note that the effect is different from reversing an audio recording. With MIDI, the individual notes will still play as usual in the MIDI instrument – it is only the order of playback that is changed.

Merge Tempo from Tapping (Cubase Pro only)

This function allows you to create a complete tempo track based on your tapping.

RELATED LINKS

Merge Tempo from Tapping (Cubase Pro only) on page 685
There are several ways to edit MIDI in Cubase. You can use the tools and functions in the Project window for large-scale editing or the functions on the MIDI menu to process MIDI parts in various ways. To manually edit your MIDI data on a graphical interface, you can use the MIDI editors.

- The Key Editor is the default MIDI editor, presenting notes graphically in a piano roll-style grid. The Key Editor also allows for detailed editing of non-note events such as MIDI controllers.

- The Score Editor shows MIDI notes as a musical score and provides advanced tools and functions for notation, layout, and printing. Cubase Artist features a basic version of the Score Editor.

- The Drum Editor is similar to the Key Editor, but each key corresponds to a separate drum sound. You can use the Drum Editor to edit drum or percussion parts.

- The List Editor shows all events in the selected MIDI parts as a list and allows you to view and edit their properties numerically. It also allows you to edit SysEx messages.

- The In-Place Editor allows you to edit MIDI parts directly in the Project window so that you can edit MIDI in context with other track types. Cubase Pro only: You can also edit MIDI in the Project Browser.

Related links:
- Key Editor on page 696
- Drum Editor on page 743
- List Editor on page 761
- Basic Score Editor (Cubase Artist only) on page 728
- Project Browser (Cubase Pro only) on page 926
- In-Place Editor on page 771

Opening MIDI editors

Procedure
1. Do one of the following:
   a. Select one or several MIDI parts.
   b. Select a whole MIDI track without selecting parts.
2. Do one of the following:
   • To open the **Key Editor**, select **MIDI > Open Key Editor**.
   • To open the **Score Editor**, select **MIDI > Open Score Editor**.
     In Cubase Artist, select **MIDI > Scores > Open Score Editor**.
   • To open the **Drum Editor**, select **MIDI > Open Drum Editor**.
   • To open the **List Editor**, select **MIDI > Open List Editor**.
   • To open the **In-Place Editor**, select **MIDI > Open In-Place Editor**.
   • To open the default MIDI editor, double-click a part.

RESULT
The selected editor opens and displays the selected parts or tracks. If no parts were selected, all parts on the track are shown.

### Opening a Drum Map in the Drum Editor

You can automatically open a drum map in the **Drum Editor**.

- Select **Preferences > Event Display > MIDI** and activate **Edit as Drums when Drum Map is assigned**.

**RELATED LINKS**

[Selecting a Drum Map for a Track on page 758](#)

### Changing the Default MIDI Editor

When you double-click a MIDI part, the default MIDI editor opens. The **Key Editor** is the default MIDI editor. You can set any MIDI editor as the default MIDI editor.

**PROCEDURE**

1. Click **File > Preferences**.
2. Select **Event Display > MIDI**.
3. From the **Default Edit Action** pop-up menu, select the MIDI editor that you want to use.
4. Click **OK**.
Common MIDI Editor Functions

You can use the tools and functions within the MIDI editors to process MIDI parts in various ways.

Changing the Display Format for the Ruler

By default, the ruler shows the timeline in the display format that is selected on the transport panel.

You can change the display format for the ruler. Click the arrow button to the right of the ruler and select an option from the pop-up menu.

RELATED LINKS
Ruler Display Formats on page 49

Zooming in MIDI Editors

The MIDI editors provide several zooming options:

- Zoom sliders

![Zoom sliders](image)

- **Zoom tool**

  ![Zoom tool](image)

- **Via Edit > Zoom.**

  When you use the **Zoom** tool for zooming, you can determine if you want to zoom horizontal only or horizontal and vertical at a time.

  - To activate/deactivate the corresponding option, select **File > Preferences > Editing > Tools** and activate/deactivate **Zoom Tool Standard Mode: Horizontal Zooming Only**.

Using Cut and Paste

You can use the **Cut**, **Copy**, and **Paste** options from the **Edit** menu to move or copy material within a part or between different parts.

- To insert note events at the project cursor position without affecting existing notes, select **Edit > Paste**.
To insert note events at the project cursor position, move, and if necessary split the existing note events to make room for the pasted notes, select **Edit > Range > Paste Time**.

1) Data on clipboard
2) Cursor position
3) Pasted data at cursor position

**Following the Project Cursor During Playback**

**Auto-Scroll** allows the event display to scroll during playback, keeping the project cursor visible in the window.

Auto-Scroll in MIDI editors is independent of the Auto-Scroll function in the **Project Window**.

- To activate/deactivate Auto-Scroll, click **Auto-Scroll**.

**Soloing a MIDI Editor**

- To only hear the parts of a particular MIDI editor during playback, activate **Solo Editor**.

**Acoustic Feedback**

If **Acoustic Feedback** is activated, individual notes are automatically played back (auditioned) when you move or transpose them, or when you create new notes by drawing. This makes it easier to hear what you are doing.

- To activate acoustic feedback, activate **Acoustic Feedback** on the toolbar.
- To take any MIDI sends or inserts that are used for the track into account when auditioning, select **File > Preferences > MIDI** and activate **Audition through MIDI Inserts/Sends**.

This way, the acoustic feedback of the editors sends the MIDI data to the output that is selected for the track and additionally through any MIDI inserts and MIDI sends that are assigned to it. However, this also means that the MIDI events are sent through any MIDI plug-ins that are assigned to this track.

**RELATED LINKS**

MIDI on page 1068
Handling Note Events

Coloring Notes and Events

You can select different color schemes for the note events in the MIDI editor. The following options are available on the Event Colors pop-up menu on the toolbar:

Velocity
The note events get different colors depending on their velocity values.

Pitch
The note events get different colors depending on their pitch.

Channel
The note events get different colors depending on their MIDI channel value.

Part
The note events get the same color as their corresponding part in the Project window. Use this option when you are working with two or more tracks in an editor, to see which note events belong to which track.

Grid Match
The note events get different colors depending on their time position. For example, this mode enables you to see if the notes of a chord start at the exact same beat.

Sound Slot (Cubase Pro only)
The note events get different colors depending on the articulation that has been assigned to the note in the Expression Map Setup dialog.

Voice
The note events get different colors depending on their voice (soprano, alto, tenor, etc.).

Chord Track
The note events get different colors depending on whether they match the current chord, scale, or both.

For all of the options except Part, the pop-up menu also contains a Setup option. This option opens a dialog in which you can specify the colors that are associated with velocities, pitches, or channels.

RELATED LINKS
Expression maps (Cubase Pro only) on page 778
Common MIDI Editor Functions

Selecting Note Events

The selected MIDI editor determines which of the following methods apply.

Do one of the following:

- Use the Object Selection tool to drag a selection rectangle around the note events that you want to select. You can also click individual events.
- Select Edit > Select and select one of the options.
- To select the previous or next note event, use the left or right arrow keys.
- To select several notes, press [Shift] and use the arrow keys.
- To select all notes of a certain pitch, press [Ctrl]/[Command] and click on a key in the keyboard display to the left.
- To select all the following note events of the same pitch/staff, press [Shift] and double-click a note event.

Selecting Note Events using the Select Submenu

The Select submenu offers you several options to select note events.

To open the Select submenu, select Edit > Select.

All
- Selects all note events in the edited part.

None
- Deselects all note events.

Invert
- Inverts the selection. All selected note events are deselected and all notes that were not selected are selected instead.

In Loop
- Selects all note events that are partially or completely inside the boundaries of the left and right locators (only visible if locators are set).

From Start to Cursor
- Selects all note events that begin to the left of the project cursor.

From Cursor to End
- Selects all note events that end to the right of the project cursor.
**Equal Pitch - all Octaves**

Selects all note events of the highlighted part that have the same pitch (in any octave) as the currently selected note event.

**NOTE**

This function requires that a single note event is selected.

**Equal Pitch - same Octave**

Selects all note events of the highlighted part that have the same pitch (same octave) as the currently selected note event.

**NOTE**

This function requires that a single note event is selected.

**Select Controllers in Note Range**

Selects the MIDI controller data within the range of the selected note events.

**RELATED LINKS**

Deleting Note Events on page 693

---

**Muting Note Events**

You can mute individual note events in a MIDI editor. Muting individual notes allows you to exclude note events from playback.

Do one of the following:

- Click on a note event with the **Mute** tool.
- Drag a rectangle with the **Mute** tool, enclosing all note events that you want to mute.
- Select the note events and select **Edit > Mute**.
- To unmute a note event, click it or enclose it with the **Mute** tool. You can also select a note event and select **Edit > Unmute**.

Muted notes are dimmed in the note display.
**Toggle Selections**

- To toggle selected elements within a selection rectangle, press `[Ctrl]/[Command]` and enclose the same elements within a new selection rectangle.

Once you release the mouse button, the previous selection is deselected and vice versa.

---

**Deleting Note Events**

- To delete note events, click on them with the **Erase** tool or select them and press `[Backspace]`.

---

**Cutting Note Events**

The **Trim** tool allows you to cut off the end or the beginning of note events.

**PROCEDURE**

1. Select the **Trim** tool [ on the toolbar.
2. Do one of the following:
   - To trim the end of a single note event, click on the note event.
   - To trim the beginning of a single note event, press `[Alt]/[Option]` and click the note event.
   - To trim several note events, click and drag with the mouse across the note events.
   - To set the same start and end time for all edited note events, press `[Ctrl]/[Command]` and vertically drag along the note events.

---

**Editing Note Events on the Info Line**

You can move, resize, transpose, or change the velocity of note events on the info line using regular value editing.

- To apply a value change to all selected note events, press `[Ctrl]/[Command]` and change a value on the info line.

- To adjust the pitch or velocity of note events via your MIDI keyboard, click in the **Pitch** or **Velocity** fields on the info line, and play a note on your MIDI keyboard.

If you have several note events selected and change a value, all selected events are changed by the set amount.
Duplicating and Repeating Note Events

You can duplicate and repeat note events in the same way as events in the Project window.

- To duplicate the selected note events, hold down [Alt]/[Option] and drag the note events to a new position.
  If Snap is activated, it determines to which positions you can copy notes.

- To copy the selected note events and place them directly behind the original, select Edit > Functions > Duplicate.
  If several note events are selected, all of them are copied as one unit, maintaining the relative distance between the note events.

- To create a number of copies of the selected note events, select Edit > Functions > Repeat, specify the number, and click OK.
  You can also press [Alt]/[Option] and drag the right edge of the note events to the right to create copies of the note events.

RELATED LINKS
  About snapping on page 918

Finding Exact Positions with Snap

The Snap function restricts horizontal movement and positioning to certain positions. This helps you find exact positions in the note display when editing note events in a MIDI editor. Affected operations include moving, duplicating, drawing, sizing, etc.

- To activate/deactivate snap, click Snap.
  If you select the Bars+Beats display format, the snap grid is set by the quantize value on the toolbar. This makes it possible to snap to straight note values and to swing grids that have been set up in the Quantize Panel.
  If you select any of the other display formats, positioning is restricted to the displayed grid.

Setting Velocity Values

When you draw note events in the MIDI editor, the note events get the velocity value that is set in the Insert Velocity field on the toolbar. There are different methods to set the velocity.
• Use the **Edit Velocity** tool modifier. The cursor changes into a speaker, and next to the note, a field with the Note Velocity slider shows the value. Move the mouse pointer up or down to change the value.

Value changes are applied to all selected notes.

For this, a tool modifier must be assigned for the **Edit Velocity** action. To see or edit the tool modifier, select **File > Preferences > Editing > Tool Modifiers > Select Tool**.

• Open the **Insert Velocity** pop-up menu and select a velocity value.

On this menu, you can also select **Setup** and specify custom velocity values for the pop-up menu.

• Double-click the **Insert Velocity** field on the toolbar and enter a velocity value.

• Assign key commands to **Insert Velocity 1-5** and use them.

This allows you to quickly switch between different velocity values when you enter note events.

**Handling Several MIDI Parts**

• To activate a part for editing, open the **Currently Edited Part** menu and select a part.

When you select a part from the list, it is automatically active and centered in the note display.

• To zoom in on an active part, select **Edit > Zoom > Zoom to Event**.

• To display defined borders for the active part, activate **Show Part Borders**.

If this option is activated, all parts, except the active part, are grayed out.

• To restrict editing operations to the active part, activate **Edit Active Part Only**.

• To change the size of the part, drag the part borders.

The part borders display the name of the active part.
NOTE

If the part that you open for editing is a shared copy, any editing that you perform affects all shared copies of this part. In the Project window, shared copies are indicated by an equal sign in the top right corner of the part.

Looping MIDI Parts

The Independent Track Loop function allows you to loop a MIDI part independent from the project playback.

When you activate the loop, the MIDI events within the loop are repeated continuously while other events on other tracks are played back as usual. Every time the cycle restarts, the independent track loop also restarts.

PROCEDURE

1. Activate Independent Track Loop [ ] on the toolbar.
   If the Independent Track Loop button is not visible, right-click the toolbar and select Independent Track Loop from the menu.
   If you have set up a loop range in the Project window, it is hidden from the ruler in the MIDI editor.
2. [Ctrl]/[Command]-click in the ruler to specify the start of the independent track loop.
3. [Alt]/[Option]-click in the ruler to specify the end of the independent track loop.

RESULT

The independent loop range is indicated in a different color. The start and end of the loop range are displayed on the status line.

AFTER COMPLETING THIS TASK

To repeat the events of the loop range and fill up the active MIDI part select MIDI > Repeat Loop.

Key Editor

The Key Editor is the default MIDI editor. It displays notes graphically in a piano roll-style grid. The Key Editor allows for detailed editing of notes and non-note events, such as MIDI controllers.
1) **Toolbar**
Contains tools and settings.

2) **Status line**
Informs about the mouse time position, mouse note position, and current chord display.

3) **Info line**
Displays note event information about a selected MIDI note.

4) **Ruler**
Displays the time line.

5) **Key Editor Inspector**
Contains tools and functions for working with MIDI data.

6) **Note display**
Contains a grid in which MIDI notes are displayed as boxes.

7) **Controller display**
The area below the note display consists of one or multiple controller lanes.
Toolbar

The toolbar contains tools and settings for the Key Editor.

- To show or hide the toolbar elements, right-click the toolbar and activate or deactivate the elements.

Static Buttons

Set up Window Layout

Allows you to show/hide specific window sections, for example, the Status Line, the Info Line, the Inspector, etc. Which sections are available, depends on the MIDI editor.

Solo Editor

If this button is activated, you hear only the edited MIDI parts during playback.

Acoustic Feedback

If this button is activated, individual notes are automatically played back when you move or transpose them, or when you create them by drawing.

Auto Scroll

Auto Scroll

If this button is activated, the project cursor is always visible in the window.

Tool Buttons

Object Selection

Allows you to select events.

Draw

Allows you to draw events.

Erase

Allows you to delete events.

Trim

Allows you to resize selected events by moving their start or end positions in steps according to the Length Quantize value.

Split

Allows you to split a MIDI event.

Mute

Allows you to mute events.

Glue

Allows you to glue together events of the same pitch.
Zoom  Allows you to zoom in/out. Hold [Alt]/[Option] and click to zoom out.

Line  Allows you to create a series of contiguous events.

Time Warp  Allows you to adjust the tempo track so that material with a musical time base can be matched to material with a linear time base.

Independent Track Loop

Independent Track Loop  Activates/Deactivates the independent track loop for the edited part.

Auto Select Controllers

Auto Select Controllers  If this button is activated and a note is selected in the editor, the corresponding controller data is also automatically selected.

Show Note Expression Data

Show Note Expression Data  If this button is activated, Note Expression data is shown.

Multiple Part Controls

Show Part Borders  If this button is activated, the part borders are shown in the editor.

Edit Active Part Only  If this button is activated, editing operations are applied only to the active part.

Currently Edited Part  This pop-up menu lists all parts that are currently open in the editor. This allows you to select a part for editing.

Indicate Transpositions

Indicate Transpositions  If this button is activated, MIDI notes are displayed according to their transposition settings.

Insert Velocity

Insert Velocity  Allows you to specify a velocity value for new notes.
Nudge Palette

**Trim Start Left**

Increases the length of the selected element by moving its start to the left.

**Trim Start Right**

Decreases the length of the selected element by moving its start to the right.

**Move Left**

Moves the selected element to the left.

**Move Right**

Moves the selected element to the right.

**Trim End Left**

Decreases the length of the selected element by moving its end to the left.

**Trim End Right**

Increases the length of the selected element by moving its end to the right.

Transpose Palette

**Move up**

Transposes the selected event or chord up by a half note.

**Move down**

Transposes the selected event or chord down by a half note.

**Move up more**

Transposes the selected event up by an octave.

**Move down more**

Transposes the selected event down by an octave.

Snap/Quantize

The following options are available on the Snap/Quantize menu:

**Snap On/Off**

Activates/Deactivates the snap function.
Grid
If this option is activated, the snap positions are set with the Grid Type pop-up menu. The available options depend on the display format selected for the ruler.

Grid Relative
If this option is activated, events keep their relative positions to the grid when they are moved.

Events
If this option is activated, the start and end positions of other events and parts are magnetic. This means that if you drag an event to a position near the start or end of another event, it is automatically aligned with the start or end of the other event.

Shuffle
Shuffle allows you to change the order of adjacent events. If you drag the first one to the right, past the second event, the two events change places.

Magnetic Cursor
If this option is activated, the project cursor is magnetic. When you drag an event near the cursor, the event is aligned with the cursor position.

Grid + Cursor
This is a combination of Grid and Magnetic Cursor.

Events + Cursor
This is a combination of Events and Magnetic Cursor.

Grid + Events + Cursor
This is a combination of Events, Grid, and Magnetic Cursor.

Iterative Quantize On/Off
Activates/Deactivates iterative quantize.

Quantize Presets
Allows you to select a quantize or a groove preset.

Apply Quantize
Applies the quantize settings.

Open Quantize Panel
Opens the Quantize Panel.

Step/MIDI Input

Step Input
Activates/Deactivates the Step Input mode.

MIDI Input/Note Expression MIDI Input
Activates/Deactivates MIDI Input modes.
Move Insert Mode
Activates/Deactivates the Move Insert mode. For this function, Step Input must be activated.

Record Pitch
If Step Input is activated, use this button to determine that the pitch is included when you insert notes.

Record NoteOn Velocity
If Step Input is activated, use this button to determine that NoteOn Velocity is included when you insert notes.

Record NoteOff Velocity
If Step Input is activated, use this button to determine that NoteOff Velocity is included when you insert notes.

Event Colors
Event Colors
Allows you to select a color scheme for the events in the editor.

Hide Colors
Allows you to hide the colors.

Edit VST Instrument
Edit VST Instrument
If the track is routed to a VST instrument, use this button to open the VST Instrument panel.

RELATED LINKS
Using the Setup options on page 1032

Status Line
The status line is displayed below the toolbar. It displays important information about the mouse position.

To show or hide the status line, click Set up Window Layout on the toolbar, and activate or deactivate Status Line.

Mouse Time Position
Displays the exact time position of the mouse pointer, depending on the selected ruler display format. This lets you edit or insert notes at exact positions.
Mouse Note Position
Displays the exact pitch of the mouse pointer position. This facilitates finding the right pitch when entering or transposing notes.

Current Chord Display
When the project cursor is positioned over notes that form a chord, the chord is displayed here.

Independent Track Loop
A mini-cycle, affecting only the MIDI part that is being edited. If Independent Track Loop is activated, MIDI events within the loop range are repeated continuously.

RELATED LINKS
Setting Up the Independent Track Loop on page 496

Info Line
The info line shows values and properties of the selected events. If several notes are selected, the values for the first note are displayed in color.

To show or hide the info line, click the Set up Window Layout button on the toolbar, and activate or deactivate Info Line.

<table>
<thead>
<tr>
<th>Start</th>
<th>End</th>
<th>Length</th>
<th>Pitch</th>
<th>Velocity</th>
<th>Channel</th>
<th>Off Velocity</th>
<th>Articulations</th>
<th>Release Length</th>
<th>Voice</th>
<th>Text</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. 2. 1. 0</td>
<td>1. 3. 1. 0</td>
<td>0. 1. 0. 0</td>
<td>A5</td>
<td>100</td>
<td>1</td>
<td>64</td>
<td>None</td>
<td>0. 0. 0. 0</td>
<td>--</td>
<td>--</td>
</tr>
</tbody>
</table>

Length and position values are displayed in the selected ruler display format.

Cubase Pro only: In the Note Expression editor, the info line shows information about the selected Note Expression events.

RELATED LINKS
Editing Note Events on the Info Line on page 693
Changing the Display Format for the Ruler on page 688

Inspector
The Inspector is located to the left of the note display. The inspector contains tools and functions for working with MIDI data.
Expression Map (Cubase Pro only)
Allows you to load an expression map. Expression maps are useful for working with articulations.

Note Expression (Cubase Pro only)
Contains functions and settings related to Note Expression.

Chord Editing
Allows you to enter chords instead of single notes.

Quantize
Allows you to access the main quantize parameters. These are identical with the functions on the Quantize panel.

Transpose
Allows you to access the main parameters for transposing MIDI events.

Length
Contains length-related options, similar to the Functions submenu of the MIDI menu.

- To change the length of the selected MIDI events or all events of the active part if no events are selected, use the Scale Length/Legato slider.
  At the maximum value the notes reach the beginning of the next note.

- To make the new length settings permanent, use the Freeze MIDI Lengths button to the right of the Scale Length/Legato slider.

- To fine-tune the distance between consecutive notes, use the Overlap slider.
  At 0 Ticks, the Scale Legato slider extends each note so that it reaches the next note exactly. Positive values cause the notes to overlap and negative values allow you to define a small gap between the notes.

- To use the Legato function or slider to extend a note until the next selected note, activate Between Selected.
  This is identical with activating the Legato Mode: Between Selected Notes Only option in the Preferences dialog.

Related links
Expression maps (Cubase Pro only) on page 778
Setting up the Note Expression Inspector tab on page 794
Quantize Panel on page 238
Transpose Functions on page 271
Other MIDI functions on page 680
Note Display

The note display is the main area in the **Key Editor**. It contains a grid in which note events are shown as boxes.

The width of a box corresponds to the note length. The vertical position of a box corresponds to the note number (pitch), with higher note events higher up in the grid. The piano keyboard helps you to find the right note number.

Controller Display

The area at the bottom of the **Key Editor** window is the controller display. It contains the controller events.

The controller display consists of one or several controller lanes that show one of the following properties or event types:

- Velocity values of the notes
- **Pitchbend** events
- **Aftertouch** events
- **Poly Pressure** events
- **Program Change** events
- **System Exclusive** events
- Any type of continuous controller event

Velocity values are shown as vertical bars in the controller display. Each velocity bar corresponds to a note event in the note display. Higher bars correspond to higher velocity values.
Events other than velocity values are shown as blocks. The block corresponds to the event values. The beginning of an event is marked by a curve point.

**NOTE**

Unlike note events, controller events have no length. The value of a controller event in the display is valid until the beginning of the next controller event.

---

**Key Editor Operations**

This section describes the principal editing operations within the Key Editor.

**Drawing Note Events with the Draw Tool**

The **Draw** tool allows you to insert single note events in the note display. The horizontal position of the note event corresponds to the time, the vertical position to the pitch.

When you move the cursor inside the note display, its position is indicated on the status line. Its pitch is indicated both on the status line and on the piano keyboard to the left.

- To draw a note, click in the note display.
- The note event has the length that is set on the **Length Quantize** pop-up menu.
• To draw longer note events, click and drag in the note display. The length of the note event is a multiple of the Length Quantize value. If Length Quantize is set to Quantize Link, the note value is determined by the quantize grid. The Snap function is taken into account.

Drawing Note Events with the Line Tool

In the note display, the Line tool allows you to draw a series of contiguous note events along different line shapes.

• To create contiguous note events, click and drag in the note display.
• To restrict movement to horizontal, press [Ctrl]/[Command] and drag. The notes have the same pitch.

If Snap is activated, the note events and controller events are positioned and sized according to the Quantize and Length Quantize values.

RELATED LINKS
The Line Tool Modes on page 707

The Line Tool Modes

The Line tool allows you to create a series of contiguous note events along different line shapes. You can also edit multiple controller events simultaneously.

To select a different line mode, click the Line button and select a mode from the menu.

The following line modes are available:

Line

If this option is activated, you can click and drag to insert note events in the note display along a straight line in any angle. Use this option to edit controller data along a straight line in the controller display.

Parabola, Sine, Triangle, Square

These modes insert note events along different curve shapes.

Paint

This mode allows you to insert note events by painting in the note display.
Moving and Transposing Note Events

There are several options to move and transpose note events.

- To move note events in the editor, select the **Object Selection** tool and drag them to a new position.
  All selected note events are moved, maintaining their relative positions. **Snap** is taken into account.

- To allow only horizontal and vertical movement, hold down [Ctrl]/[Command] while dragging.

- To move note events via the **Nudge Palette** buttons on the toolbar, select the note events and click a **Nudge Palette** button.
  This moves the selected note events by the amount that is set on the **Quantize** pop-up menu.

- To move note events to the project cursor position, select the note events and select **Edit > Move to > Cursor**.

- To move a note event via the info line, select a note event and edit the **Position** or **Pitch** on the info line.

- To transpose note events, select the note events and use the **Transpose Palette** buttons on the toolbar or the up and down arrow keys.
  Transpose is also affected by the global transpose setting.

- To transpose note events via the **Transpose Setup** dialog, select the note events and select **MIDI > Transpose Setup**.

- To transpose note events in steps of one octave, press [Shift] and use the up and down arrow keys.

**NOTE**

- When you move selected note events to a different position, any selected controllers for these note events move accordingly.

- You can also adjust the position of note events by quantizing.

**RELATED LINKS**

- Transpose on page 673

Resizing Note Events

Do one of the following:

- To resize the note event, position the **Object Selection** tool at the start or the end of a note event and drag the mouse cursor to the left or right.
• To apply time-stretching and Note Expression data (Cubase Pro only) to a controller that is associated with the note event that you resize, activate **Sizing Applies Time Stretch** for the **Object Selection** tool before you resize the note.

![Sizing Applies Time Stretch](image)

• To move the start or end positions of the selected notes in steps according to the **Length Quantize** value on the toolbar, use the **Trim Start/End** buttons on the **Nudge** palette.

• Select the note and adjust its length on the info line.

• Select the **Draw** tool and drag left or right within the note display to draw a note.

   The resulting note event length is a multiple of the **Length Quantize** value on the toolbar.

• Select the **Trim** tool and cut off the end or the beginning of note events.

**RELATED LINKS**
- Using the Setup options on page 1032
- Editing in the Info Line on page 48
- Using the Trim Tool on page 709
- Resizing Events Using Time Stretch on page 183

### Using the Trim Tool

The Trim tool allows you to change the length of note events by cutting off the end or the beginning of notes. Using the Trim tool means moving the note-on or the note-off event for one or several notes to a position defined with the mouse.

**PROCEDURE**

1. Select the **Trim** button on the toolbar.

   The mouse pointer changes to a knife symbol.

2. To edit a single note, click on it with the **Trim** tool.

   The range between the mouse pointer and the end of the note will be removed. Use the mouse note info on the status line to find the exact position for the trim operation.

3. To edit several notes, click and drag with the mouse across the notes.

   ![Trim Tool Example](image)

   By default, the Trim tool cuts off the end of notes. To trim the beginning of notes, press [Alt]/[Option] while dragging. When dragged across several notes, a line is displayed. The notes will be trimmed along this line. If you press [Ctrl]/[Command] while dragging, you will get a vertical trim line, allowing you to set the same start or end time for all edited notes. You can change the Trim tool key commands in the Preferences dialog (Editing–Tool Modifiers page).
Splitting Note Events

Do one of the following:

- To split the note at the position that you point, click on a note with the Split tool.
  If several notes are selected, they are all split at the same position. The snap setting is taken into account.

- To split all notes that are intersected by the project cursor position, select Edit > Functions > Split at Cursor.

- To split all notes that are intersected by the left or right locator at the locator positions, select Edit > Functions > Split Loop.

Gluing Note Events

You can glue together note events of same pitch.

- To glue note events, select the Glue tool and click on a note event.
  The note event is glued together with the next note event of the same pitch.
  The result is a long note event that spans from the start of the first note to the end of the second note and with the properties (velocity, pitch, etc.) of the first note event.

Changing the Pitch of Chords

You can use the chord type buttons to change the pitch of chords.

**Procedure**

1. In the Inspector, open the Chord Editing section.
2. In the note display, select the notes that you want to edit.
   If the chord is recognized, the root note, chord type, and tensions are indicated in the Chord Type field. This also works with arpeggiated notes.
3. In the Chord Editing section, activate one of the Triads buttons or 4-Note Chords buttons.
   The selected notes are transposed so that they fit the selected chord type.
4. Use the up or down arrow keys on your computer keyboard to change the pitch of the chord.
Changing the Voicing of Chords

**PROCEDURE**

1. In the **Inspector**, open the **Chord Editing** section.
2. In the note display, select the notes that you want to edit.
3. In the **Chord Editing** section, use the **Inversions** buttons and the **Drop Notes** buttons to change the voicing.

**RESULT**

The selected notes are transposed so that they fit the selected chord type.

**Chord Editing Section**

The **Chord Editing** section in the **Inspector** allows you to insert and edit chords, and change voicings.

![Chord Editing Section Diagram]

**Chord Type**

Shows the chord type of the selected chords.

**Add to Chord Track**

Adds the chord indicated in the **Chord Type** field to the chord track. The chord event is inserted at the position on the chord track that corresponds to the position of the MIDI notes. Any existing chord events at this position are overwritten.

**Match with Chord Track**

Applies the chord events from the chord track to the selected notes in the MIDI editor. The chord event that is effective at the position of the first selected note is applied to the selected notes, which are then transposed. Only the basic chord type is applied. Tensions are not taken into account. Only the first effective chord event is applied.
Triads

Allows you to insert triads to the note display. You can also click one of the Triads buttons to transpose the selected notes so that they fit to the selected chord type.

4-Note Chords

Allows you to insert 4-note chords to the note display. You can also click one of the 4-Note Chords buttons to transpose the selected notes so that they fit to the selected chord type.

Inversions - Move highest note to bottom

Inverts the highest note of a chord. The corresponding notes are transposed by as many octaves as needed.

Inversions - Move lowest note to top

Inverts the lowest note of a chord. The corresponding notes are transposed by as many octaves as needed.

Drop Notes - Move the second highest note an octave lower

Moves the second highest note of a chord down by one octave.

Drop Notes - Move the third highest note an octave lower

Moves the third highest note of a chord down by one octave.

Drop Notes - Move the second and fourth highest notes an octave lower

Moves the second and fourth highest notes of a chord down by one octave.

Make Chords

Performs a chord analysis of the selected notes. If nothing is selected, the whole MIDI part is analyzed.

Inserting Chords

You can use the tools in the Chord Editing section of the Inspector to insert and edit chords.

PROCEDURE

1. In the Inspector, open the Chord Editing section.
2. Select Tool to the right of the chord type that you want to insert.
3. Click in the note display, drag to the left or right to determine the length of the chord. Drag up or down to determine its pitch.

To change the chord type while you insert chords, hold [Alt]/[Option] and drag up or down.

If Acoustic Feedback is activated, you hear the chord while dragging. A tooltip indicates the root note and chord type of the inserted chord. Snap and Length Quantize are taken into account.
Applying Chord Events to Note Events

You can apply chord events from the chord track to notes in the MIDI editor.

**PREREQUISITE**
Create a chord track and add chord events.

**PROCEDURE**
1. Open the MIDI editor.
2. In the Inspector, open the Chord Editing section.
3. Select Match with Chord Track.

**RESULT**
The first chord event of the chord track is applied to the selected notes. Only the basic chord type is applied. Tensions are not taken into account.

**Drum Map Handling**

When a drum map is assigned to a MIDI or instrument track, the Key Editor displays the drum sound names as defined by the drum map. This allows you to use the Key Editor for drum editing, for example, when editing drum note lengths or when editing several parts to identify drum events.

The name of the drum sound is displayed in the following locations:

- On the info line in the Pitch field.
- On the status line in the Mouse Note Position field.
- In the note event if the zoom factor is high enough.
- When dragging a note event.

**Expression Map Handling (Cubase Pro only)**

When an expression map is assigned to a MIDI track, the musical articulations that are defined for that map are displayed in the following locations of the Key Editor:

- On the info line in the Articulations field.
- On the controller lane.
- In the note event if the vertical zoom factor is high enough.

**RELATED LINKS**
Expression Map Handling (Cubase Pro only) on page 713
Note Expression Data (Cubase Pro only)

The **Key Editor** is the main editor for working with Note Expression.

**RELATED LINKS**
- Expression maps (Cubase Pro only) on page 778

**Editing Note Events via MIDI**

Since you can directly hear your editing results. Editing the properties of note events via MIDI can be a quick way to, for example, set the velocity value of a note event.

**PROCEDURE**

1. In the **Key Editor**, select the note event that you want to edit.
2. Click **MIDI Input** on the toolbar.
   
   Editing via MIDI is enabled.
3. Use the note buttons on the toolbar to decide which properties are changed by the MIDI input.
   
   You can enable editing of pitch, note-on and/or note-off velocity. For example, with the following setting, the edited notes get the pitch and velocity values of the notes input via MIDI, but the note-off velocities remain as they are.

   ![MIDI Input Buttons]

4. Play a note on your MIDI instrument.

**RESULT**

The selected note gets the pitch, velocity and/or note-off velocity of the played note. The next note in the edited part is automatically selected, to allow quick editing of a series of notes.

**AFTER COMPLETING THIS TASK**

To try another setting, select the note again and play a note on your MIDI instrument.
Step Input

Step input, or step recording, allows you to enter note events or chords one at a time without worrying about the exact timing. This is useful, for example, when you know the part that you want to record but are not able to play it exactly as you want it.

PROCEDURE

1. On the toolbar, activate the Step Input button.

2. Use the note buttons to the right to determine which properties are included when you insert the note events.
   
   For example, you can include the velocity and/or note-off velocity of the played notes. You can also deactivate the pitch property, in which case all notes get a pitch C3, no matter what you play.

3. Click anywhere in the note display to set the start position of the first note event or chord.
   
   The step input position is shown as a blue line in the note display.

4. Specify the note event spacing and length with the Quantize and Length Quantize pop-up menus.
   
   The note events that you insert are positioned according to the Quantize value and have the length of the Length Quantize value.

   NOTE

   If Length Quantize is set to Quantize Link, the note length is also determined by the Quantize value.

5. Play the first note event or chord on your MIDI instrument.
   
   The note event or chord appears in the editor and the step input position advances by one quantize value step.

   NOTE

   If Move Insert Mode is activated, all note events to the right of the step input position are moved to make room for the inserted note event or chord.

6. Continue in the same way with the rest of the note events or chords.
   
   You can adjust the Quantize or Length Quantize values, to change the timing or note event lengths. You can also move the step input position manually by clicking anywhere in the note display.
   
   To insert a rest, press the right arrow key on the computer keyboard. This advances the step input position by one step.

7. When you are done, click the Step Input button again to deactivate step input.
Using the Controller Display

The Controller Display displays the controller events. By default, the controller display has a single lane that shows one event type at a time. However, you can add as many lanes as you need. The use of several controller lanes allows you to view and edit different controllers at the same time.

Each MIDI track has its own controller lane setup (number of lanes and selected event types). When you create new tracks, they get the last used controller lane setup.

![The controller display with three lanes.](image)

- To add a controller lane, click the Create Controller Lane button or open the Controller Selection and Functions menu and select Create Controller Lane.

- To remove a controller lane, open the Controller Selection and Functions pop-up menu and select Remove this Lane. This hides the lane from view. It does not affect the events in any way.

- If you remove all lanes, the controller display is hidden. To bring it back, click the Create Controller Lane button.

- To show/hide multiple lanes, open the Controller Lane Setup pop-up menu, and select Show/Hide Controller Lanes.

- To reset the controller display to show only the velocity lane, open the Controller Lane Setup pop-up menu, and select Velocity only.

- To automatically show all controller lanes with controller data, open the Controller Lane Setup pop-up menu, and select Show Used Controllers.

Selecting the Event Type

Each controller lane shows one event type at a time. You can select which event type to display on a controller lane.
• To select which type is displayed, open the Controller Selection and Functions pop-up menu and select an event type.

Setting up Available Continuous Controllers

In the MIDI Controller Setup dialog, you can specify which continuous controllers are available for selection.

**NOTE**

The MIDI Controller Setup dialog can be opened from different areas in the program. The settings are global, that is, the setup you choose here affects all areas of the program where MIDI controllers can be selected.

**PROCEDURE**

1. Select Controller Selection and Functions > Setup.

2. In the MIDI Controller Setup dialog, move all the controllers that you need to the list on the left and move the controllers that you do not need to the list on the right.

3. Click OK.
Handling Controller Lane Presets

Once you have made up your controller lane setup, you can save it as a controller lane preset. For example, you can have a preset with one velocity lane and another preset with a combination of several controller lanes, such as velocity, pitchbend, or modulation.

Saving a Controller Lane Setup as Preset

You can save a controller lane setup via the Controller Lane Setup pop-up menu.

PROCEDURE

1. Click the Controller Lane Setup button.
2. Select Add Preset.
   The Type In Preset Name dialog opens.
3. Enter a name for the preset.
4. Click OK.

RESULT
Your controller lane setup is now available as a controller lane preset.

NOTE
To apply a saved preset, open the Controller Lane Setup pop-up menu and select the preset.

NOTE
To remove or rename a preset, open the Controller Lane Setup pop-up menu and select Organize Presets. A dialog opens, where you can remove and rename presets.

Adding Events in the Controller Display

- To create a new event in the velocity controller display, click with the Draw tool or the Line tool in the event display.
- To create a new event for any other event type, click with the Draw tool or the Line tool in the controller display.

Editing Events in the Controller Display

All controller values can be edited with the Draw tool or the Line tool. If you have selected more than one controller event on a controller lane, the controller lane editor is displayed.
To edit events in the velocity controller display, use the **Draw** tool or the **Line** tool and drag the event.

The **Object Selection** tool automatically switches to the **Draw** tool when you move the pointer into the controller display.

When you move the pointer in the controller lane, the corresponding event type value is displayed below the event type name.

In velocity mode, no new controller events are added this way.

To edit the values of any other event type in the controller display, press `[Alt]/[Option]` and drag, or use the **Draw** tool or the **Line** tool and drag.

When you move the pointer inside a controller lane, the event type value changes corresponding to the pointer movement. The event type value is displayed below the event type name, left of the controller display.

If there is more than one note at the same position, their velocity bars overlap on the controller lane. If none of the notes are selected, all notes at the same position are set to the same velocity value when you draw.

To edit the velocity of only one of the notes at the same position, first select the note in the note display.

To select all events on a controller lane, open the **Controller Lane Setup** pop-up menu and select the **Select all Controller Events** option.

To use the **Object Selection** tool to select events in the velocity controller display, press `[Alt]/[Option].`

To cut, copy, and paste events in the controller display select the event and select **Edit > Cut/Copy/Paste.**

When pasting events, the events on the clipboard are added, starting at the project cursor position and maintaining their relative distances. If a pasted event ends up at the same position as an existing event of the same type, the old event is replaced.

**NOTE**

If the speaker icon (Acoustic Feedback) is activated on the toolbar, the notes are played back when you adjust the velocity. This allows you to audition your changes.

**RELATED LINKS**

Controller Lane Editor on page 725
Editing Events in the Controller Display Using the Line Tool

You can draw and edit events in the controller display with the **Line** tool.

### Line Mode

In **Line** mode, you can draw events in a straight line.

- To draw a straight line in the controller display, click where you want the ramp to start and drag the cursor to where you want the ramp to end.

![Line Mode Diagram](image.png)

**NOTE**

If **Snap** is activated the **Length Quantize** value determines the density of created controller curves. For very smooth curves, use a small **Length Quantize** value or deactivate **Snap**. To avoid over-dense controller curves, which can cause MIDI playback to stutter, use a medium-low density.

### Parabola Mode

In **Parabola** mode, you can draw events on a parabola curve. This gives more natural curves and fades. The result depends on the direction from which you draw the parabola.

![Parabola Mode Diagram](image.png)

You can use modifier keys to determine the shape of the parabola curve.

- To reverse the parabola curve, press [Ctrl]/[Command].
- To change the position of the whole curve, press [Alt]/[Option].
- To increase or decrease the exponent, press [Shift].

**NOTE**

If **Snap** is activated the **Length Quantize** value determines the density of created controller curves. For very smooth curves, use a small **Length Quantize** value or deactivate **Snap**. To avoid over-dense controller curves which can cause MIDI playback to stutter, use a medium-low density.
Sine, Triangle, and Square Mode

The Sine, Triangle, and Square modes create events with values that are aligned to continuous curves.

In these modes, the quantize value determines the period of the curve that is the length of one curve cycle and the Length Quantize value determines the density of the events. The lower the Length Quantize note value becomes, the smoother the curve gets.

NOTE

If Length Quantize is set to Quantize Link and you enter data in Sine, Triangle or Square mode, the density of the events depends on the Zoom factor.

You can use modifier keys to determine the shape of the curve.

- To change the phase of the beginning of the curve, press [Ctrl]/[Command].
- To change the position of the whole curve, press [Alt]/[Option]-[Ctrl]/[Command].
- To change the maximum position of the triangle curve or the pulse of the square curve in Triangle and Square mode, press [Shift]-[Ctrl]/[Command]. This creates sawtooth curves.
- You can also set the curve period freely by holding down [Shift] when you insert events in Sine, Triangle, or Square mode. Activate Snap, [Shift]-click and drag to set the length of one period. The period length will be a multiple of the quantize value.

Paint Mode

In Paint mode, you can draw in multiple notes.

The quantize value determines the density of created controller curves. For very smooth curves, use a small quantize value or deactivate Snap. However, this creates a large number of MIDI events, which can cause MIDI playback to stutter in some situations. A medium-low density is often sufficient.

Editing Events using the Draw Tool

You can draw and edit events in the controller display with the Draw tool. The Draw tool has the same functionality as the Line tool in Paint mode.
To change the velocity of a single note, click on its velocity bar and drag the bar up or down.

**NOTE**

When you move the pointer inside a controller lane, the event type value changes corresponding to the pointer movement. The event type value is displayed below the event type name, left of the controller display.

**Editing Articulations (Cubase Pro only)**

You can add and edit musical expressions or articulations in the controller lane.

**RELATED LINKS**

Expression maps (Cubase Pro only) on page 778

**Editing Dynamics (Cubase Pro only)**

Provided that the dynamics mapping is set up and activated for the track, you can insert 12 dynamics symbols in the lower part of the Articulations/Dynamics lane.

- To insert a dynamics symbol, click in the controller lane with the **Draw** tool. A mezzo forte symbol is inserted.

- To select another dynamics symbol for an event, click on the triangle in the upper left corner of the event and select a symbol from the pop-up menu. If several events are selected, the same symbol is applied to all events.

- To step through the available dynamics symbols, use the mouse wheel or the **One down** and **One up** key commands. If several events are selected, they all change in increments, that is relative to the original values.

- To modify the settings for the dynamics symbols, open the **Controller Selection and Functions** pop-up menu and select **Dynamics Mapping Setup**.
Moving and copying dynamics events is identical to working with other events on the controller lane.

**RELATED LINKS**

- Moving Events in the Controller Display on page 726
- Working with mapped dynamics on page 1315

### Using Continuous Controllers

When a continuous controller is selected for a controller lane, additional data is displayed on the controller lane. This is due to the fact that MIDI controller data can be recorded or entered either for an automation track or for a MIDI part.

If automation data already exists for a controller, this is indicated by an asterisk that is displayed next to the controller name on the **Controller Selection and Functions** pop-up menu.

If the automation data is controller data that you have entered in a MIDI editor, the data is displayed on the controller lane. If the controller data was recorded on an automation track in the **Project** window, no events are displayed on the controller lane.

If conflicting controller data exists in two different places, you can specify what happens on playback by making settings for the automation merge mode. The resulting curve is displayed in addition to the curve that you entered on the controller lane.

1) The controller curve before the part starts. This curve depends on the existing controller data and on the selected merge mode.

2) Controller curve entered on the controller lane.

3) Resulting controller curve if controller automation was also recorded on a track. These values depend on the selected automation merge mode.

On the controller lane, you can also see the controller curve that is applied before the part starts. This tells you which controller value is currently being used at the starting point of the part so that you can choose the start value accordingly.

The start value also depends on the automation merge mode.

**RELATED LINKS**

- MIDI Controller Automation on page 595
- Automation Merge Modes on page 596
Poly Pressure Events

Poly Pressure events are events that belong to a specific note number (key). That is, each poly pressure event has two editable values: the note number and the amount of pressure.

When Poly Pressure is selected on the Controller Selection and Functions pop-up menu, there are two value fields to the left of the controller display, one for the note number and one for the amount.

Adding Poly Pressure Events

**PROCEDURE**

1. Open the Controller Selection and Functions pop-up menu and select Poly Pressure.
2. Click on the keyboard display to set the note number. The selected note number is displayed in the upper value field to the left of the controller display.

**NOTE**

This only works for the topmost lane. If you have selected Poly Pressure for several controller lanes, you have to type in the note number directly in the lower value field to the left of each lane.

3. Use the Draw tool to add a new event.

Editing Poly Pressure Events

**PROCEDURE**

1. Open the Controller Selection and Functions pop-up menu and select Poly Pressure.
2. Click on the arrow button next to the note number to the left of the controller lane. A pop-up menu appears and lists all note numbers for which there already are Poly Pressure events.
3. Select a note number from the pop-up menu. The Poly Pressure events for the selected note number are shown in the controller lane.
4. Use the Draw tool to edit the events. To edit events without adding new events, press [Ctrl]/[Command]+[Alt]/[Option] while drawing. Poly Pressure events can also be added and edited in the List Editor.
Controller Lane Editor

The controller lane editor allows you to perform additional scaling operations for selection ranges on existing controller curves.

In the controller lane editor, the following smart controls appear on the borders of the editor:

<table>
<thead>
<tr>
<th>Editing mode</th>
<th>To activate this mode</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Move Vertically</td>
<td>Click in an empty area on the upper border of the editor.</td>
<td>This mode allows you to move the entire curve up or down, which is useful to boost or attenuate an otherwise perfect curve.</td>
</tr>
<tr>
<td>Scale Vertically</td>
<td>Click the smart control in the middle of the upper border of the editor.</td>
<td>Use this mode to relatively scale the curve, that is to raise or lower the values in percent.</td>
</tr>
<tr>
<td>Tilt the left/right part of the curve</td>
<td>Click the smart control in the upper left/right corner of the editor.</td>
<td>These modes allow you to tilt the left or the right part of the curve. This is useful if the curve form is exactly the way you want it, but the start or end needs to be boosted or attenuated a bit.</td>
</tr>
<tr>
<td>Compress the left/right part of the curve</td>
<td>[Alt]/[Option]-click the smart control in the upper left/right corner of the editor.</td>
<td>These modes allow you to compress the left or the right part of the curve.</td>
</tr>
<tr>
<td>Scale Around Absolute Center</td>
<td>Click the smart control in the middle of the right border of the editor.</td>
<td>This mode allows you to scale the curve around the absolute center, i.e. horizontally around the center of the editor.</td>
</tr>
<tr>
<td>Scale Around Relative Center</td>
<td>[Alt]/[Option]-click the smart control in the middle of the right border of the editor.</td>
<td>This mode allows you to scale the curve relative to its center.</td>
</tr>
<tr>
<td>Stretch</td>
<td>Click and drag in the lower part of the editor (not available for velocity lanes).</td>
<td>This allows you to stretch the selected controller events.</td>
</tr>
</tbody>
</table>

Editing Selection Ranges

The controller lane editor allows you to perform additional scaling operations for selection ranges on existing controller curves.

- To open the controller lane editor, use the **Object Selection** tool to create a selection rectangle on the controller lane, encompassing the controller events that you want to edit.
  
  For velocity lanes, press [Alt]/[Option] to get the **Object Selection** tool.
NOTE

- The controller lane editor is not available for Articulation or Dynamics lanes.
- For velocity lanes, the editor also opens if you select multiple MIDI notes in the note display.

- To switch the controller lane editor to vertical scaling mode, press [Shift] and click on any of the smart controls.
- To move the whole selection up/down or left/right, click on a controller event inside the editor and drag the curve.
- To restrict the direction to horizontal or vertical movement, depending on the direction in which you start dragging, press [Ctrl]/[Command] when dragging.

NOTE

Snap is taken into account when moving controller curves horizontally.

Moving Events in the Controller Display

You can move events in a controller lane.

PROCEDURE

1. Select the events that you want to move with the Object Selection tool. You can also click and drag to create a selection rectangle that encompasses the events that you want to move.
2. Click on a curve point inside the selection and drag the events.

RESULT

The events inside the selection are moved to the new position. Snap is taken into account.

NOTE

If Auto Select Controllers is activated in the Key Editor toolbar, selecting notes also selects the corresponding controller events. Moving events in the note display also moves the corresponding controller events.

RELATED LINKS

Selecting Controllers within the Note Range on page 727
Deleting Events in the Controller Display

**IMPORTANT**

If there is more than one note at the same position, there is only one visible velocity bar. Make sure that you delete only the notes that you want to delete.

- To delete events, click on them with the **Erase** tool or select them and press [Backspace].

  You can also delete notes by deleting their velocity bars in the controller display.

  If there is more than one note at the same position, there may still only be one velocity bar visible. Make sure that you delete only the desired notes!

Selecting Controllers within the Note Range

A note range lasts until the start of the next note or the end of the part. Selected controllers for notes are moved when the corresponding notes are moved.

You can select the controllers within the range of the selected notes.

- To always select the corresponding controllers when you select a note event, activate **Auto Select Controllers**.

- To select the controllers within the note range, select **Edit > Select > Select Controllers in Note Range**.

  For this to work, only 2 notes have to be selected.
Basic Score Editor (Cubase Artist only)

The basic Score Editor is available in Cubase Artist. It shows MIDI notes as a musical score. This offers basic score editing and printing.

1) Toolbar
2) Status line
3) Info line
4) Extended toolbar

To open one or several parts in the Score Editor, select one or several tracks or any number of parts, and select MIDI > Scores > Open Score Editor. If you have selected parts on several tracks, you get one staff for each track. The staves are tied together by bar lines and placed in the order of the tracks in the Project window.

To rearrange the staves, close the editor and in the Project window, rearrange the tracks. Then reopen the Score Editor.

Toolbar

The toolbar contains tools and various settings for the Score Editor.

To show or hide the toolbar elements, right-click the toolbar and activate or deactivate the elements.
MIDI Editors
Basic Score Editor (Cubase Artist only)

Tool Buttons

Object Selection
Allows you to select events.

Erase
Allows you to delete events.

Insert Note
Allows you to insert notes in the score display.

Split
Allows you to split a MIDI event.

Glue
 Allows you to glue together events of the same pitch.

Insert Text
Allows you to insert text in the score display.

Arranger

Previous Chain Step
Selects the previous chain step.

Next Chain Step
Selects the next chain step.

First Repeat of Current Chain Step
Selects the first repeat of the current chain step.

Activate Arrange Mode
If this option is activated, playback follows the repeats and project symbols in the score. Sections within repeat symbols are repeated, the playback position jumps to the beginning when encountering a Da Capo symbol, and so on.

Transpose Palette

Move up
Transposes the selected event or chord up by a half note.

Move down
Transposes the selected event or chord down by a half note.

Move up more
Transposes the selected event up by an octave.

Move down more
Transposes the selected event down by an octave.
Display Transpose

Display Transpose
Allow you to transpose events without affecting the way that they are played back. This allows you to record and play back a multi-staff arrangement and still score each instrument according to its own transposition.

Auto Scroll

Auto Scroll
If this button is activated, the project cursor is always visible in the window.

Insert Velocity

Insert Velocity
Allows you to specify a velocity value for new notes.

Snap/Quantize

Snap Type
Allows you to select the snap type.
If Grid is activated, events snap to exact grid positions when they are moved.
If Grid Relative is activated, events keep their relative positions to the grid when they are moved.

Iterative Quantize On/Off
Activates/Deactivates iterative quantize.

Quantize Presets
Allows you to select a quantize or a groove preset.

Apply Quantize
Applies the quantize settings.

Open Quantize Panel
Opens the Quantize Panel.

Length Quantize
Determines the event length for the Length Quantize function.

Step/MIDI Input

Step Input
Activates/Deactivates the Step Input mode.

MIDI Input/Note Expression MIDI Input
Activates/Deactivates MIDI Input modes.
Move Insert Mode
Activates/Deactivates the Move Insert mode. For this function, Step Input must be activated.

Record Pitch
If Step Input is activated, use this button to determine that the pitch is included when you insert notes.

Record NoteOn Velocity
If Step Input is activated, use this button to determine that NoteOn Velocity is included when you insert notes.

Record NoteOff Velocity
If Step Input is activated, use this button to determine that NoteOff Velocity is included when you insert notes.

Event Colors
Event Colors
Allows you to select a color scheme for the events in the editor.

Hide Colors
Allows you to hide the colors.

Paper Background
Background Texture
In Page Mode, you can specify different background textures for the score by selecting an option from the Background Texture pop-up menu on the toolbar.

NOTE
The background texture only affects the display and is not used for printing.

Insert Layer
Insert Layer
Allows you to select the insert layer.

RELATED LINKS
Using the Setup options on page 1032

Status Line
The status line is displayed below the toolbar. It displays important information about the mouse position and the chord displays. Select the notes that form (compose) the chord to make the status line appear in the Current Chord Display.
To show or hide the status line, click **Set up Window Layout** on the toolbar, and activate or deactivate **Status Line**.

**Mouse Time Position**

Displays the exact time position of the mouse pointer, depending on the selected ruler display format. This lets you edit or insert notes at exact positions.

**Mouse Note Position**

Displays the exact pitch of the mouse pointer position. This facilitates finding the right pitch when entering or transposing notes.

**Current Chord Display**

When the project cursor is positioned over notes that form a chord, this chord is displayed here.

**Info Line**

The info line shows values and properties of the selected MIDI notes. If several notes are selected, the values for the first note are displayed in color.

To show or hide the info line, click **Set up Window Layout** on the toolbar, and activate or deactivate **Info Line**.

**RELATED LINKS**

- Changing the Display Format for the Ruler on page 688

**Extended Toolbar**

The extended toolbar contains note value buttons and enharmonic shift buttons.

To show or hide the extended toolbar, click the **Set up Window Layout** button on the toolbar, and activate or deactivate **Tools**.

**Note Value Buttons**

Allows you to select a note value for input. The T and . options are for triplet and dotted note values.

The selected note value is displayed in the Length value field on the toolbar and in the **Insert Note** tool shape.

To resize all selected notes to the same note value, press [Ctrl]/[Command] and click one of the note value buttons.
MIDI Editors
Basic Score Editor (Cubase Artist only)

Enharmonic Shift

Allows you to manually select whether a note is displayed with flat or sharp accidentals. The Off button resets the notes to original display. The other options are double flats, flats, No (no accidentals shown, regardless of pitch), sharps, and double sharps.

RELATED LINKS
Enharmonic Shift on page 740

Score Display

The main area of the Score Editor window shows the notes in the edited parts on one or several staves. Parts on different tracks are shown on different staves.

- If you are editing one or several parts on the same track, as much of them as possible is shown on several staves, comparable with a score on paper.
- If you are editing parts on several tracks, they are put on a grand staff. A grand staff is composed of multiple staves that are tied together by bar lines.
- The number of bars that are displayed on the screen depends on the size of the window and the number of notes in each bar.
- The end of the last part is indicated by a double bar line.

All MIDI input is directed to one of the tracks, which is called the active staff. The active staff is indicated by a blue rectangle to the left of the clef symbol.

- To change the active staff, click on the staff that you want to activate.
Score Editor Operations (Cubase Artist only)

This section describes the principal editing operations within the Score Editor.

Improving the Score Display

When you open the Score Editor for a part that was recorded in real time, the score may not look as legible as you expect. The Score Editor can ignore the minor time variances in performance and make a neater score. To achieve this, the Staff Settings dialog provides settings that determine how the program displays the music.

Staff Settings Dialog

This dialog allows you to change how Cubase displays the music.

**IMPORTANT**

The settings that you make in this dialog are independent for each staff (track), but common for a piano staff that you have created with the Split option.

To open the Staff Settings dialog, double-click in the area to the left of the staff, or select a staff and select MIDI > Scores > Staff Settings.

**NOTE**

The time signature follows the time signatures that are set in the Tempo Track editor. These settings are common to all tracks/staves in the score.

Staff Mode

The Staff Mode determines how the staff is shown.

- In Single mode, all notes in the part are shown in the same staff.
• In Split mode, the part is split on the screen into a bass and treble clef, as in a piano score. The Split Point value determines where you want the split to occur. Notes above and including the split note appear on the upper staff, and notes below the split note appear on the lower staff.

Before and after setting a split at C3.

Display Quantize

This section allows you to change the way Cubase displays scores.

**IMPORTANT**

These display values are only used for the graphical display in the Score Editor. They do not affect the playback.

**Notes**

Determines the smallest note value to be displayed and the smallest position to be recognized and properly displayed. Set this to the smallest significant note position used in your music.

For example, if you have notes on odd sixteenth note positions, set this value to 16. The T values are for triplet note values. This setting is partly overridden by Auto Quantize.

**Rests**

This value is used as a recommendation. Cubase does not display rests smaller than this value, except where necessary. In effect, this setting also determines how the length of notes is displayed. Set this value according to the smallest note value (length) that you want to be displayed for a single note, positioned on a beat.

**Auto Quantize**

Allows you to make your score look as legible as possible. Auto Quantize allows you to mix straight notes with tuplets (triplets) in a part. However, Auto Quantize also uses the (display) quantize value. If there is no appropriate note value for a certain note or group of notes, it uses the set quantize value is used to display it.

Generally, only activate this option if your music contains mixed triplets and straight notes. If the part is imprecisely played and/or complex, Auto Quantize may have a problem figuring out exactly what you mean.
Dev.

If this option is activated, triplets/straight notes are detected even if they are not exactly on the beat. However, if you know that your triplets/straight notes are perfectly recorded, either through quantizing or entered by hand, deactivate this option.

This option is only available if Auto Quantize is activated.

Adapt

If this option is activated, the program guesses that when one triplet is found, there are probably more triplets surrounding it. Activate this option if not all of your triplets are detected.

This option is only available if Auto Quantize is activated.

Clef and Key

In this section, you can set the correct clef and key.

Clef/Key Display

Allows you to select the clef or key via the scrollbar.

Lower Staff

Sets the clef and key to the lower staff.

Auto Clef

If this option is activated, Cubase attempts to guess the correct clef, judging from the pitch of the music.

Display Transpose

In this section, you can specify a separate display transpose setting for each staff (track). This transposes the notes in the score without affecting how the notes are played back. This allows you to record and play back a multi staff arrangement and still score each instrument according to its own transposition.

Semitones

Allows you to manually set a display transpose value.

Instrument

Allows you to select the instrument for which you are scoring.
Interpretation Options

In this section, you can make additional settings on how the score is displayed.

Clean Lengths

If this option is activated, notes that are considered to be chords are shown with identical lengths. Longer notes are displayed shorter than they are. Notes with very short overlaps are also cut off. This is similar to the No Overlap option, but with a more subtle effect.

No Overlap

If this option is activated, one note is never shown as overlapping another, lengthwise. This allows long and short notes that start at the same point to be displayed without ties. The long notes are cut off in the display. This makes the music more legible.

A sample measure with No Overlap deactivated.

A sample measure with No Overlap activated.

Syncopation

If this option is activated, syncopated notes are shown in a more legible way.

A dotted quarter note at the end of a bar when Syncopation is deactivated.

A dotted quarter note at the end of a bar when Syncopation is activated.

Shuffle

If this option is activated and you have played a shuffle beat, the beat is displayed as straight notes, not as triplets. This is very common in jazz notation.

Quantize Value

When you move the mouse pointer over the score, the Mouse Time Position field on the status line tracks your movement and shows the current position in bars, beats, sixteenth notes, and ticks.

The quantize value controls the positioning on screen. If you set the value to 1/8, you can only insert and move notes to eighth note positions, at quarter notes, at half bars, or at bar positions.

It is recommended to set the quantize value to the smallest note value in the piece. This does not stop you from inputting notes at coarser positions. However, if you set the quantize value to a too small note value, it is easier to make mistakes.
With the quantize value set to 1/8, you can only input notes at eighth note positions.

You can also use the Quantize Panel to create other quantize values, irregular grids, etc.

Creating Notes

In the score display, the Insert Note tool allows you to create notes. However, you must first set the note value (length) and spacing.

**PROCEDURE**

1. Set the note value in one of the following ways:
   - Click the note symbols on the extended toolbar.
   - Select an option from the Length Quantize pop-up menu on the toolbar.

2. Select the Insert Note tool.
   If you selected the note value via the extended toolbar buttons, the Insert Note tool is automatically selected.

3. Open the Quantize Presets pop-up menu on the toolbar and select a quantize value.

4. Move the mouse over the staff to find the correct position.
   The position is displayed on the Mouse Time Position display on the status line. The position snaps to the grid that is defined by the quantize value.

5. Move the mouse vertically to find the correct pitch.
   The Mouse Note Position display on the status line shows the pitch at the pointer position.

6. Click in the staff.

**RESULT**

The note appears in the score. The notes get the insert velocity value that is set in the Insert Velocity field on the toolbar.

**NOTE**

If the notes that you enter appear to have the wrong note value you may have to adjust the Display Quantize settings. For example, you enter a 1/32 note that is displayed as a 1/16 note.

**RELATED LINKS**

- Setting Velocity Values on page 694
- Display Quantize on page 735
Moving and Transposing Notes

**PROCEDURE**

1. Open the **Quantize Presets** pop-up menu on the toolbar and select a quantize value.
2. If you want to hear the pitch of the note while moving, activate the **Acoustic Feedback** button on the toolbar.
3. Select the notes that you want to move.
4. Click one of the selected notes and drag it to a new position and/or pitch.
   The horizontal movement of the note is snaps to the current quantize value. The position boxes on the toolbar show the position and pitch for the dragged note.
   To restrict moving to one direction, press [Ctrl]/[Command] while dragging.

Duplicating Notes

**PROCEDURE**

1. Open the **Quantize Presets** pop-up menu on the toolbar and select a quantize value.
2. Select the notes that you want to duplicate.
3. Press [Alt]/[Option] and drag the notes to their new position.
   To restrict moving to one direction, press [Ctrl]/[Command] while dragging.

Changing the Note Length

The displayed note length is not necessarily the actual note length. It also depends on the note values and rest values for **Display Quantize** in the **Staff Settings** dialog. This is important to remember when you change the length of a note.

You can change the length of a note in the following ways:

- Select the notes that you want to change and [Ctrl]/[Command]-click on one of the note icons on the extended toolbar.
  All the selected notes are assigned to the length of the clicked note.

- Select the notes that you want to change and edit the length values on the info line.

**RELATED LINKS**

- Improving the Score Display on page 734
- Editing Note Events on the Info Line on page 693
Splitting and Gluing Note Events

- To split 2 notes that are strung together by a tie, click on the tied note head with the Cut tool.
  The note is divided into two, with the respective length of the main and the tied note.
- To glue a note to the next note with the same pitch, click on a note with the Glue tool.

Enharmonic Shift

You can shift the display of selected notes. For example, an F# (F sharp) is instead shown as a Gb (G flat) and vice versa.

**PROCEDURE**

1. Select the notes that you want to shift.
2. Click one of the enharmonic shift buttons on the extended toolbar.

**RELATED LINKS**

Extended Toolbar on page 732

Flipping Stems

The direction of the note stems is automatically selected according to the note pitches. However, you can change this manually.

**PROCEDURE**

1. Select the notes for which you want to flip the stem direction.
2. Select MIDI > Scores > Flip Stems.

Working with Text

You can use the Text tool to add comments, articulation, or instrumentation advice and other text strings anywhere in the score display.
Adding Text

PROCEDURE
1. On the toolbar, select the Text tool.
2. Click anywhere in the score. A blinking cursor indicates that you can enter text.
3. Enter the text and press [Return].

Editing Text

- To edit existing text, double-click it with the Object Selection tool. This opens the text for editing. Use the arrow keys to move the cursor, delete characters with the [Delete] or [Backspace] keys, press [Return] when you are finished.
- To delete text blocks, select them with the Object Selection tool and press [Backspace] or [Delete].
- To move text blocks, drag them to a new position.
- To duplicate text blocks, press [Alt]/[Option] and drag them to a new position.

Changing the Text Font, Size, and Style

You can change the font, size, and style of the text that you have added to the score display.

PROCEDURE
1. Do one of the following:
   - To change the settings for a specific text block, click on the text with the Object Selection tool.
   - To set the default settings for all new text blocks, unselect any selected text block and change the settings.
2. Select MIDI > Scores > Set Font.
3. In the Font Settings dialog, make your settings.
4. Click Apply.
5. Optional: Select another text block, adjust the settings, and click Apply.
Set Font Dialog

In this dialog, you can change the font, size, and style of the text that you have added to the score display.

To open the Set Font dialog, select MIDI > Scores > Set Font.

Font

Allows you to specify the font for the text. Which fonts are available on the pop-up menu depends on the fonts that you have installed on your computer.

IMPORTANT

Do not use the Steinberg fonts. These are special fonts used by the program, for example, for score symbols, and not suited for common text.

Size

Sets the size of the text.

Frame

Allows you to enclose the text in a rectangular (box) or oval frame.

Font Options

Determine whether the text is formatted bold, italic, and/or underlined.

Printing the Score

PROCEDURE

1. Open the parts that you want to print in the Score Editor.
2. Select File > Page Setup and make sure that all your printer settings are correct.

IMPORTANT

If you change your setting for paper size, scale, and margins now, the score may change its look.

3. Click OK.
4. Select File > Print.
5. In the Print dialog, make your settings.
6. Click Print.
Drum Editor

The **Drum Editor** is similar to the Key Editor, but takes advantage of the fact that with drum parts, each key corresponds to a separate drum sound. This is the editor to use when you are editing drum or percussion parts.

1) **Toolbar**
   Contains tools and settings.

2) **Status line**
   Informs about the mouse time position, mouse note position, and current chord display.

3) **Info line**
   Displays note event information about a selected MIDI note.

4) **Drum Editor Inspector**
   Contains tools and functions for working with MIDI data.

5) **Drum sound list**
   Lists all drum sounds.

6) **Drum map**
   Lets you select the drum map for the edited track or a list of drum sound names.
7) **Ruler**
Displays the time line.

8) **Note display**
Contains a grid in which MIDI notes are displayed as boxes.

9) **Controller display**
The area below the Note display consists of one or multiple controller lanes.

**Toolbar**

The toolbar contains tools and various settings for the **Drum Editor**.

- To show or hide the toolbar elements, right-click the toolbar and activate or deactivate the elements.

**Solo/Feedback**

**Set up Window Layout**

Allows you to show/hide specific window sections, for example, the Status Line, the Info Line, the Inspector, etc. Which sections are available, depends on the editor.

**Solo Editor**

If this button is activated, you hear only the edited MIDI parts during playback.

**Solo Instrument**

If this button is activated, you hear only the selected MIDI part during playback.

**Acoustic Feedback**

If this button is activated, individual notes are automatically played back when you move or transpose them, or create them by drawing.

**Tool Buttons**

**Object Selection**

Allows you to select events.

**Drumstick**

Allows you to draw events.

**Erase**

Allows you to delete events.

**Zoom**

Allows you to zoom in/out. Hold [Alt]/[Option] and click to zoom out.

**Mute**

Allows you to mute events.
**MIDI Editors**

**Drum Editor**

**Line**
- Allows you to create a series of contiguous events.

**Time Warp**
- Allows you to adjust the tempo track so that material with a musical time base can be matched to material with a linear time base.

**Auto Scroll**

**Auto Scroll**
- If this button is activated, the project cursor is always visible in the window.

**Independent Track Loop**

**Independent Track Loop**
- Activates/Deactivates the independent track loop for the edited part.

**Auto Select Controllers**

**Auto Select Controllers**
- If this button is activated and a note is selected in the editor, the corresponding controller data is also automatically selected.

**Multiple Part Controls**

**Show Part Borders**
- If this button is activated, the part borders are shown in the editor.

**Edit Active Part Only**
- If this button is activated, editing operations are applied only to the active part.

**Currently Edited Part**
- This pop-up menu lists all parts that are currently open in the editor. This allows you to select a part for editing.

**Insert Velocity**

**Insert Velocity**
- Allows you to specify a velocity value for new notes.

**Inserted Notes Length**

**Insert Length**
- Allows you to determine the length of an inserted note.
Nudge Palette

Trim Start Left
Increases the length of the selected element by moving its start to the left.

Trim Start Right
Decreases the length of the selected element by moving its start to the right.

Move Left
Moves the selected element to the left.

Move Right
Moves the selected element to the right.

Trim End Left
Decreases the length of the selected element by moving its end to the left.

Trim End Right
Increases the length of the selected element by moving its end to the right.

Transpose Palette

Move up
Transposes the selected event or chord up by a half note.

Move down
Transposes the selected event or chord down by a half note.

Move up more
Transposes the selected event up by an octave.

Move down more
Transposes the selected event down by an octave.

Snap/Quantize

The following options are available on the Snap/Quantize menu:

Snap On/Off
Activates/Deactivates the snap function.
Grid
If this option is activated, the snap positions are set with the Grid Type pop-up menu. The available options depend on the display format selected for the ruler.

Grid Relative
If this option is activated, events keep their relative positions to the grid when they are moved.

Events
If this option is activated, the start and end positions of other events and parts are magnetic. This means that if you drag an event to a position near the start or end of another event, it is automatically aligned with the start or end of the other event.

Shuffle
Shuffle allows you to change the order of adjacent events. If you drag the first one to the right, past the second event, the two events change places.

Magnetic Cursor
If this option is activated, the project cursor is magnetic. When you drag an event near the cursor, the event is aligned with the cursor position.

Grid + Cursor
This is a combination of Grid and Magnetic Cursor.

Events + Cursor
This is a combination of Events and Magnetic Cursor.

Grid + Events + Cursor
This is a combination of Events, Grid, and Magnetic Cursor.

Iterative Quantize On/Off
Activates/Deactivates iterative quantize.

Quantize Presets
Allows you to select a quantize or a groove preset.

Apply Quantize
Applies the quantize settings.

Open Quantize Panel
Opens the Quantize Panel.

Use Global Quantize
If this button is activated, drum notes are quantized according to the global quantize value on the toolbar. If the button is deactivated, the individual quantize values for the drum sounds are used.
Step/MIDI Input

Step Input
Activates/Deactivates the Step Input mode.

MIDI Input/Note Expression
Activates/Deactivates MIDI Input modes.

Move Insert Mode
Activates/Deactivates the Move Insert mode. For this function, Step Input must be activated.

Record Pitch
If Step Input is activated, use this button to determine that the pitch is included when you insert notes.

Record NoteOn Velocity
If Step Input is activated, use this button to determine that NoteOn Velocity is included when you insert notes.

Record NoteOff Velocity
If Step Input is activated, use this button to determine that NoteOff Velocity is included when you insert notes.

Event Colors
Event Colors
Allows you to select a color scheme for the events in the editor.

Hide Colors
Allows you to hide the colors.

Edit VST Instrument
Edit VST Instrument
If the track is routed to a VST instrument, use this button to open the VST Instrument panel.

RELATED LINKS
Using the Setup options on page 1032

Status Line
The status line is displayed below the toolbar. It displays important mouse information.

To show or hide the status line, click Set up Window Layout on the toolbar, and activate or deactivate Status Line.
Mouse Time Position
Displays the exact time position of the mouse pointer, depending on the selected ruler display format. This lets you edit or insert notes at exact positions.

Mouse Note Position
Displays the exact pitch of the mouse pointer position. This facilitates finding the right pitch when entering or transposing notes.

Independent Track Loop
A mini-cycle, affecting only the MIDI part that is being edited. If Independent Track Loop is activated, MIDI events within the loop range are repeated continuously.

RELATED LINKS
Setting Up the Independent Track Loop on page 496

Info Line
The info line shows values and properties of the selected events. If several notes are selected, the values for the first note are displayed in color.

To show or hide the info line, click the Set up Window Layout button on the toolbar, and activate or deactivate Info Line.

<table>
<thead>
<tr>
<th>Start</th>
<th>End</th>
<th>Length</th>
<th>Pitch</th>
<th>Velocity</th>
<th>Channel</th>
<th>Off Velocity</th>
<th>Articulations</th>
<th>Release Length</th>
<th>Vellz</th>
<th>Text</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. 2. 1. 0</td>
<td>1. 2. 1. 0</td>
<td>0. 1. 1. 0</td>
<td>A5</td>
<td>100</td>
<td>1</td>
<td>64</td>
<td>None</td>
<td>0. 0. 0. 0</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Length and position values are displayed in the selected ruler display format.
Cubase Pro only: In the Note Expression editor, the info line shows information about the selected Note Expression events.

RELATED LINKS
Editing Note Events on the Info Line on page 693
Changing the Display Format for the Ruler on page 688

Inspector
The Inspector is located to the left of the note display. The inspector contains tools and functions for working with MIDI data.

Expression Map
Allows you to load an expression map. Expression maps are useful for working with articulations.
Quantize

Allows you to access the main quantize parameters. These are identical with the functions on the Quantize Panel.

Length

Contains length-related options, similar to the Functions submenu of the MIDI menu.

- To change the length of the selected MIDI events or all events of the active part if no events are selected, use the Scale Length/Legato slider.
  At the maximum value the notes reach the beginning of the next note.
- To make the new length settings permanent, use the Freeze MIDI Lengths button to the right of the Scale Length/Legato slider.
- To fine-tune the distance between consecutive notes, use the Overlap slider.
  At 0 Ticks, the Scale Legato slider extends each note so that it reaches the next note exactly. Positive values cause the notes to overlap and negative values allow you to define a small gap between the notes.
- To use the Legato function or slider to extend a note until the next selected note, activate Between Selected.
  This is identical with activating the Legato Mode: Between Selected Notes Only option in the Preferences dialog.

Related Links

Expression maps (Cubase Pro only) on page 778
Setting up the Note Expression Inspector tab on page 794
Quantize Panel on page 238
Transpose Functions on page 271
Other MIDI functions on page 680

Note Display

The note display of the Drum Editor displays notes as diamond symbols.

The vertical position of the notes corresponds to the drum sound list to the left, while the horizontal position corresponds to the note’s position in time.

Note

The diamond symbols do not indicate the length of the notes, since drum sounds most often are "one-shot" samples that disregard note lengths.
**Controller Display**

The area at the bottom of the **Drum Editor** window is the controller display.

It consists of one or several controller lanes that show one of the following properties or event types:

- Velocity values of the notes
- Pitchbend events
- Aftertouch events
- Poly Pressure events
- Program Change events
- System Exclusive events
- Any type of continuous controller event

Velocity values are shown as vertical bars in the controller display. Each velocity bar corresponds to a note in the note display. Higher bars correspond to higher velocity values.

Events other than velocity values are shown as blocks. The block corresponds to the event values. The beginning of an event is marked by a curve point.

When you select a line in the drum sound list, only the velocity controller events that belong to the note events on this line are displayed in the controller display.

If you select more than one line in the drum sound list, the controller lane shows all velocity controller events for all notes on the selected lines. This is useful when you have to adjust the controller values between different drum sounds.
NOTE

Unlike note events, controller events have no length. The value of a controller event in the display is valid until the beginning of the next controller event.

Drum Sound List

The drum sound list lists all drum sounds by name and lets you adjust and manipulate the drum sound setup in various ways.

<table>
<thead>
<tr>
<th>Pitch</th>
<th>Instrument</th>
<th>Quantize</th>
<th>Mute</th>
<th>I-Note</th>
<th>O-Note</th>
<th>Chan</th>
<th>Outpt</th>
</tr>
</thead>
<tbody>
<tr>
<td>C1</td>
<td>Bass Drum</td>
<td>1/1.0</td>
<td>C1</td>
<td>C1</td>
<td></td>
<td>10</td>
<td>Track</td>
</tr>
<tr>
<td>C#1</td>
<td>Slide Stick</td>
<td>1/1.0</td>
<td>C#1</td>
<td>C#1</td>
<td></td>
<td>10</td>
<td>Track</td>
</tr>
<tr>
<td>D1</td>
<td>Acoustic Snare</td>
<td>1/1.0</td>
<td>D1</td>
<td>D1</td>
<td></td>
<td>10</td>
<td>Track</td>
</tr>
<tr>
<td>D#1</td>
<td>Hi-Hat Clap</td>
<td>1/1.0</td>
<td>D#1</td>
<td>D#1</td>
<td></td>
<td>10</td>
<td>Track</td>
</tr>
<tr>
<td>E1</td>
<td>Electric Snare</td>
<td>1/1.0</td>
<td>E1</td>
<td>E1</td>
<td></td>
<td>10</td>
<td>Track</td>
</tr>
<tr>
<td>F1</td>
<td>Low Floor Tom</td>
<td>1/1.0</td>
<td>F1</td>
<td>F1</td>
<td></td>
<td>10</td>
<td>Track</td>
</tr>
<tr>
<td>F#1</td>
<td>Closed Hi-Hat</td>
<td>1/1.0</td>
<td>F#1</td>
<td>F#1</td>
<td></td>
<td>10</td>
<td>Track</td>
</tr>
<tr>
<td>G1</td>
<td>High Floor Tom</td>
<td>1/1.0</td>
<td>G1</td>
<td>G1</td>
<td></td>
<td>10</td>
<td>Track</td>
</tr>
</tbody>
</table>

NOTE

The number of columns in the list depends on whether a drum map is selected for the track or not.

Pitch

Actual note number of the drum sound. This is what links notes on a MIDI track to drum sounds. For example, with the GM Map, all MIDI notes with the pitch C1 are mapped to the Bass Drum sound.

Instrument

Name of the drum sound.

Quantize

This value is used when entering and editing notes.

Mute

Mute drum sounds.

I-Note

Input note for the drum sound. When this MIDI note is sent into Cubase, that is you play it, the note is mapped to the corresponding drum sound and automatically transposed according to the Pitch setting for the sound.

O-Note

Output note, that is the MIDI note number that is sent out every time the drum sound is played back.

Chan

MIDI channel, on which the drum sound is played back.
Output

MIDI output on which, the drum sound is played back. If you set this to Default, the MIDI output selected for the track is used.

RELATED LINKS
Muting Notes and Drum Sounds on page 754

Drum Map and Names Menus

Below the drum sound list are two pop-up menus that are used for selecting a drum map for the edited track or, if no drum map is selected, a list of drum sound names.

RELATED LINKS
Drum Maps on page 755

Drum Editor Operations

This section describes the principal editing operations within the Drum Editor.

Creating and Editing Note Events with the Drum Tool

- To create a note, select the Drumstick tool and click in the Drum Editor. If Snap is deactivated on the toolbar, the note event appears exactly where you clicked.

If you have activated Snap and deactivated Use Global Quantize on the toolbar, the note events snap to positions according to the quantize value set for the sound in the drum sound list. You can set up different quantize values for different drum sounds.

If Snap and Use Global Quantize are activated, the note snaps to positions according to the Quantize setting on the toolbar.

The length of the inserted note is determined by the Insert Length setting on the toolbar. However, if this is set to Drum-Map Link, the note gets the length of the quantize value for the drum sound.

- To remove a note, select the Drumstick tool and click on an existing note.
- To audition the drum sounds, click the leftmost column of the drum sound list.
Moving and Transposing Note Events

There are several options to move and transpose note events.

- To move note events in the editor, select the **Object Selection** tool and drag them to a new position.
  All selected note events are moved, maintaining their relative positions. **Snap** is taken into account.

- To allow only horizontal and vertical movement, hold down [Ctrl]/[Command] while dragging.

- To move note events via the **Nudge Palette** buttons on the toolbar, select the note events and click a **Nudge Palette** button.
  This moves the selected note events by the amount that is set on the **Quantize** pop-up menu.

- To move note events to the project cursor position, select the note events and select **Edit > Move to > Cursor**.

- To move a note event via the info line, select a note event and edit the **Position** or **Pitch** on the info line.

- To transpose note events, select the note events and use the **Transpose Palette** buttons on the toolbar or the up and down arrow keys.
  Transpose is also affected by the global transpose setting.

- To transpose note events via the **Transpose Setup** dialog, select the note events and select **MIDI > Transpose Setup**.

- To transpose note events in steps of one octave, press [Shift] and use the up and down arrow keys.

**NOTE**

- When you move selected note events to a different position, any selected controllers for these note events move accordingly.

- You can also adjust the position of note events by quantizing.

**RELATED LINKS**

- Transpose on page 673

Muting Notes and Drum Sounds

**IMPORTANT**

The mute state for drum sounds is part of the drum map. Therefore, any other tracks using the same map are also affected.

- To mute individual notes, click or enclose them with the **Mute** tool, or select **Edit > Mute**.
If a drum map is selected, the drum sound list has a Mute column. Click in the Mute column for a drum sound to mute that sound.

To mute all drum sounds other than the selected one, click the Solo Instrument button on the toolbar.

RELATED LINKS
Selecting a Drum Map for a Track on page 758

Drum Maps

A drum kit in a MIDI instrument is most often a set of different drum sounds with each sound placed on a separate key. For example, the different sounds are assigned to different MIDI note numbers. One key plays a bass drum sound, another a snare, and so on.

Different MIDI instruments often use different key assignments. This can be troublesome if you have made a drum pattern using one MIDI device and then want to try it on another. When you switch devices, it is very likely that your snare drum becomes a ride cymbal or your hi-hat becomes a tom, etc., because the drum sounds are distributed differently in the two instruments.

To solve this problem and to simplify several aspects of MIDI drum kits, such as using drum sounds from different instruments in the same drum kit, Cubase features drum maps. A drum map is a list of drum sounds, with a number of settings for each sound. When you play back a MIDI track for which you have selected a drum map, the MIDI notes are filtered through the drum map before they are sent to the MIDI instrument. The map determines which MIDI note number is sent out for each drum sound and which sound is played on the receiving MIDI device.

When you want to try your drum pattern on another instrument, you simply switch to the corresponding drum map, and your snare drum sound remains a snare drum sound.

If you want to have the same drum maps included in your projects, you can load these into the template.

NOTE
Drum maps are saved with the project files. If you have created or modified a drum map, use the Save function to save it as a separate XML file to make it available for loading into other projects.

RELATED LINKS
Saving a Project Template File on page 71
Drum Map Setup Dialog

This dialog allows you to load, create, modify, and save drum maps.

To open the Drum Map Setup dialog, select Drum Map Setup from the Map pop-up menu or the MIDI menu.

The list on the left shows the currently loaded drum maps. The sounds and settings of the selected drum map are displayed on the right.

NOTE

The settings for the drum sounds are the same as in the Drum Editor.

Use Head Pairs (Cubase Pro only)

If this option is activated, two head symbols for each drum sound are displayed in the drum sound list.

Edit in Scores (Cubase Pro only)

If this option is activated, you can change the settings for the score drum map directly in the score.

Output

Allows you to select the output for the drum map sounds.

Drum Sound List

Lists all drum sounds and their settings. To audition a drum sound, click the leftmost column.

NOTE

If you audition a sound in the Drum Map Setup dialog and the sound is set to MIDI output Default, the output that is selected on the Output pop-up menu in the lower left corner is used. When auditioning a default output sound in the Drum Editor, the MIDI output selected for the track is used.
The **Functions** pop-up menu contains the following options:

**New Map**

Adds a new drum map to the project. The drum sounds are named “Sound 1, Sound 2, etc.” and have all parameters set to default values. The map is named “Empty Map”.

To rename the drum map, click the name in the list and type in a new name.

**New Copy**

Adds a copy of the currently selected drum map to create a new drum map. You can then change the drum sound settings of the copy and rename the drum map in the list.

**Remove**

Removes the selected drum map from the project.

**Load**

Allows you to load drum maps into your project.

**Save**

Allows you to save the drum map that is selected in the list on disk. Drum map files have the extension `.drm`.

**Edit head pairs**

Allows you to customize the note pairs.

**Init Display Notes**

Allows you to reset the **Display Notes** entry to the original setting, that is the Pitch entry.

**RELATED LINKS**

- Customizing note head pairs on page 1306
- Drum Map Settings on page 757
- Channel and Output Settings on page 758

**Drum Map Settings**

A drum map consists of settings for 128 drum sounds, one for each MIDI note number.

- To get an overview of the drum map settings, open the **Drum Editor** and use the **Map** pop-up menu below the drum sound list to select the **GM Map** drum map.

The GM map is set up according to the General MIDI standard.
You can change all drum map settings except the pitch directly in the drum sound list or in the **Drum Map Setup** dialog. These changes affect all tracks that use the drum map.

**RELATED LINKS**
- Drum Sound List on page 752
- Drum Map Setup Dialog on page 756

**Channel and Output Settings**

You can set separate MIDI channels and/or MIDI outputs for each sound in a drum map. When a drum map is selected for a track, the MIDI channel settings in the drum map override the MIDI channel setting for the track.

You can select different channels and/or outputs for different sounds. This allows you to construct drum kits with sounds from several different MIDI devices, etc.

- To make a drum sound use the channel of the track, set the channel in the drum map to **Any**.
- To make the sound use the MIDI output that is selected for the track, set the MIDI output for a sound in a drum map to **default**.
- To send the sound to a specific MIDI output, select any other option.
- To select the same MIDI channel or MIDI device for all sounds in a drum map, click in the **Channel** column, press [Ctrl]/[Command], and select a channel or output.
- If you make specific MIDI channel and output settings for all sounds in a drum map, you can switch between drum maps to send your drum tracks to another MIDI instrument.

**Selecting a Drum Map for a Track**

- To select a drum map for a MIDI track, open the **Map** pop-up menu in the Inspector or in the **Drum Editor** and select a drum map.
- To deactivate the drum map functionality in the **Drum Editor**, open the **Map** pop-up menu in the Inspector or in the **Drum Editor** and select **No Drum Map**.

Even if you do not use a drum map, you can still separate sounds by name using a name list.

**NOTE**

Initially, the **Map** pop-up menu only contains **GM Map**.
About I-Notes, O-Notes and Pitches

Going through the following theory helps you make the most out of the drum map concept – especially if you want to create your own drum maps.

A drum map is a kind of filter that transforms notes according to the settings in the map. It does this transformation twice; once when it receives an incoming note that is when you play a note on your MIDI controller, and once when a note is sent from the program to the MIDI sound device.

The following example shows a modified drum map with a bass drum sound that has different pitch, I-note, and O-note values.

<table>
<thead>
<tr>
<th>Pitch</th>
<th>Instrument</th>
<th>Quantize</th>
<th>Note</th>
<th>I-Note</th>
<th>O-Note</th>
<th>Chck</th>
</tr>
</thead>
<tbody>
<tr>
<td>C1</td>
<td>Bass Drum</td>
<td>1/16</td>
<td></td>
<td>A1</td>
<td></td>
<td></td>
</tr>
<tr>
<td>C#1</td>
<td>Side Stick</td>
<td>1/16</td>
<td></td>
<td>C#1</td>
<td>C#1</td>
<td>10</td>
</tr>
<tr>
<td>D1</td>
<td>Acoustic Snare</td>
<td>1/16</td>
<td></td>
<td>D1</td>
<td>D1</td>
<td>10</td>
</tr>
</tbody>
</table>

I-Notes (Input Notes)

When you play a note on your MIDI instrument, the program looks for this note number among the I-notes in the drum map. If you play the note A1, the program finds that this is the I-note of the bass drum sound.

This is where the first transformation happens: the note gets a new note number according to the pitch setting for the drum sound. In our case, the note is transformed to a C1 note, because that is the pitch of the bass drum sound. If you record the note, it is recorded as a C1 note.

For example, you can place drum sounds near each other on the keyboard so that they can be easily played together, move sounds so that the most important sounds can be played from a short keyboard, play a sound from a black key instead of a white. If you never play your drum parts from a MIDI controller but draw them in the editor you do not need the I-note setting.

O-Notes (Output Notes)

The next step is the output. This is what happens when you play back the recorded note, or when the note you play is sent back out to a MIDI instrument in realtime (MIDI Thru):

The program checks the drum map and finds the drum sound with the pitch of the note. In our case, this is a C1 note and the drum sound is the bass drum. Before the note is sent to the MIDI output, the second transformation takes place: the note number is changed to that of the O-note for the sound. In our example, the note sent to the MIDI instrument is a B0 note.

The O-note settings let you set things up so that the bass drum sound really plays a bass drum. If you are using a MIDI instrument in which the bass drum sound is on the C2 key, you set the O-note for the bass drum sound to C2. When you switch to another instrument (in which the bass drum is on C1) you want the bass drum O-note set to C1. Once you have set up drum maps for all your MIDI instruments, you can select another drum map when you want to use another MIDI instrument for drum sounds.
Setting Pitches of Notes According to their O-Note Settings

You can set the pitch of notes according to their O-note settings. This is useful if you want to convert a track to a regular MIDI track with no drum map and still have the notes play back the correct drum sound.

It’s a typical use case to export your MIDI recording as a standard MIDI file. If you first perform an O-note conversion, you make sure that your drum tracks play back as intended when they are exported.

- To perform an O-note conversion, select **MIDI > O-Note Conversion**.

**RELATED LINKS**

- Exporting and importing standard MIDI files on page 1021

Drum Name Lists

Drum name lists allow you to use the **Drum Editor** even if no drum map is selected for the edited MIDI track. The drum sound list then consists of the columns **Audition**, **Pitch**, **Instrument (drum sound name)**, and **Quantize**.

This means that you can use the drum sound names in any loaded drum map without using I-notes and O-notes.

In the drum name list mode, the names that are shown in the **Instrument** column depend on the selection on the **Names** pop-up menu at the bottom of the **Drum Editor**. The pop-up menu contains the currently loaded drum maps and **GM Map**.
List Editor

The List Editor shows all events in the selected MIDI parts as a list, allowing you to view and edit their properties numerically. It also allows you to edit SysEx messages.

1) Toolbar
2) Status line
3) Event list
4) Filters bar
5) Ruler
6) Event display
7) Value display

Toolbar

The toolbar contains tools and various settings for the List Editor.

- To show or hide the toolbar elements, right-click the toolbar and activate or deactivate the elements.

Tool Buttons

Object Selection

Allows you to select events.

Draw

Allows you to draw events.
MIDI Editors
List Editor

Erase
Allows you to delete events.

Zoom
Allows you to zoom in/out. Hold [Alt]/[Option] and click to zoom out.

Mute
Allows you to mute events.

Trim
Allows you to resize selected events by moving their start or end positions in steps according to the Length Quantize value.

Auto Scroll

Auto Scroll
If this button is activated, the project cursor is always visible in the window.

Independent Track Loop

Independent Track Loop
Activates/Deactivates the independent track loop for the edited part.

Multiple Part Controls

Show Part Borders
If this button is activated, the part borders are shown in the editor.

Edit Active Part Only
If this button is activated, editing operations are applied only to the active part.

Currently Edited Part
This pop-up menu lists all parts that are currently open in the editor. This allows you to select a part for editing.

Insert Type

Insert Event Type
Is used when creating new events. This is where you determine what type of event to add.

Insert Velocity

Insert Velocity
Allows you to specify a velocity value for new notes.
**Nudge Palette**

**Trim Start Left**
- Increases the length of the selected element by moving its start to the left.

**Trim Start Right**
- Decreases the length of the selected element by moving its start to the right.

**Move Left**
- Moves the selected element to the left.

**Move Right**
- Moves the selected element to the right.

**Trim End Left**
- Decreases the length of the selected element by moving its end to the left.

**Trim End Right**
- Increases the length of the selected element by moving its end to the right.

**Snap/Quantize**

**Snap On/Off**
- Activates/Deactivates the snap function.

**Grid**
- If this option is activated, the snap positions are set with the Grid Type pop-up menu. The available options depend on the display format selected for the ruler.

**Grid Relative**
- If this option is activated, events keep their relative positions to the grid when they are moved.

**Events**
- If this option is activated, the start and end positions of other events and parts are magnetic. This means that if you drag an event to a position near the start or end of another event, it is automatically aligned with the start or end of the other event.

**Shuffle**
- Shuffle allows you to change the order of adjacent events. If you drag the first one to the right, past the second event, the two events change places.

**Magnetic Cursor**
- If this option is activated, the project cursor is magnetic. When you drag an event near the cursor, the event is aligned with the cursor position.

**Grid + Cursor**
- This is a combination of Grid and Magnetic Cursor.
Events + Cursor
This is a combination of Events and Magnetic Cursor.

Grid + Events + Cursor
This is a combination of Events, Grid, and Magnetic Cursor.

Iterative Quantize On/Off
Activates/Deactivates iterative quantize.

Quantize Presets
Allows you to select a quantize or a groove preset.

Apply Quantize
Applies the quantize settings.

Open Quantize Panel
Opens the Quantize Panel.

Length Quantize
Determines the event length for the Length Quantize function.

Step/MIDI Input

Step Input
Activates/Deactivates the Step Input mode.

MIDI Input/Note Expression MIDI Input
Activates/Deactivates MIDI Input modes.

Move Insert Mode
Activates/Deactivates the Move Insert mode. For this function, Step Input must be activated.

Record Pitch
If Step Input is activated, use this button to determine that the pitch is included when you insert notes.

Record NoteOn Velocity
If Step Input is activated, use this button to determine that NoteOn Velocity is included when you insert notes.

Record NoteOff Velocity
If Step Input is activated, use this button to determine that NoteOff Velocity is included when you insert notes.

Event Colors

Event Colors
Allows you to select a color scheme for the events in the editor.

Hide Colors
Allows you to hide the colors.
Edit VST Instrument

If the track is routed to a VST instrument, use this button to open the VST Instrument panel.

RELATED LINKS
Using the Setup options on page 1032

Status Line

The status line is displayed below the toolbar. It displays important information about the mouse position.

To show or hide the info line, click Set up Window Layout on the toolbar, and activate or deactivate Status Line.

Mouse Time Position

Displays the exact time position of the mouse pointer, depending on the selected ruler display format. This lets you edit or insert notes at exact positions.

Current Chord Display

When the project cursor is positioned over notes that form a chord, this chord is displayed here.

Independent Track Loop

A mini-cycle, affecting only the MIDI part that is being edited. If Independent Track Loop is activated, MIDI events within the loop range are repeated continuously.

Filters Bar

The filters bar allows you to hide events from view, based on their type and other properties.

To show or hide the filter bar, click the Set up Window Layout button on the toolbar, and activate or deactivate Filters.

Show Section

The Show section allows you to set up filters.

No Focus

No filter is applied.
Event Types

Only events of the same event type as the selected type will be shown. This is the same as activating event types in the Hide section.

Event Types and Data 1

Only events of the same event type as the selected type and with the same Data 1 value are shown. For example, if a note event is selected, only notes with the same pitch are shown. If a controller event is selected, only controllers of the same type are shown.

Event Channels

Only events with the same MIDI channel value as the selected event are shown.

Setup (Cubase Pro only)

Opens the Logical Editor. Here you can create complex filter settings. When you apply any of the Logical Editor presets or use the Logical Editor to create filter settings yourself, only the events that meet the specified criteria are visible.

Hide Section

The Hide section allows you to hide specific event types from view.

RELATED LINKS
Filtering the Event List on page 769
The Logical Editor, Transformer, and Input Transformer on page 859

Event List

The Event List lists all events in the selected MIDI parts, in the order in which they are played back from top to bottom. The list allows you to perform detailed numerical editing of the event properties.

The following options are available:

> An arrow in this column indicates the event that starts closest before the project cursor position. You can use this column for auditioning when you are editing in the list.

- To move the cursor to the start of the event, click in the auditioning column of an event.
- To move the cursor position and start/stop playback, double-click in the column for an event.

Type

Event type. Cannot be changed.
Start

Starting position of the event, displayed in the format selected for the ruler. Changing it has the same effect as moving the event.

**NOTE**

If you move the event past any other event in the list, the list is resorted. The list always shows the events in the order in which they are played back.

End

Allows you to view and edit the end position of a note event. Editing resizes the note event.

Length

Displays the length of the note event. Changing this resizes the note event and automatically changes the **End** value.

Data 1

*Data 1* or *Value 1* property of the event. Its content depends on the event type. For notes, this is the pitch, for example. Where applicable, the values are displayed in the most relevant form. For example, the *Data 1* value for notes is displayed as a note number in the format that was selected in the *Preferences* dialog.

Data 2

*Data 2* or *Value 2* property of the event. The content of this depend on the event type. For notes, this is the note-on velocity value, for example.

Data 3

The *Data 3* or *Value 3* property of the event. This value is only used for note events, where it corresponds with the note-off velocity.

Channel

MIDI channel of the event. This setting is normally overridden by the channel setting for the track. To make a MIDI event play back on its own channel, set its track to the Any channel in the *Project* window.

Comment

Allows you to add comments to some event types.

**Event Display**

The *Event Display* displays events graphically. The vertical position of an event in the display corresponds to its entry in the list, that is to the playback order, while the horizontal position corresponds to its actual position in the project. In the event display, you can add new parts or events, drag events to another position.
**Value Display**

The value display to the right of the event display is a tool for quick viewing and editing of multiple values, for example, velocities or controller amounts. The values are shown as horizontal bars, with the bar length corresponding to the value.

To show or hide the value display, click **Set up Window Layout** on the toolbar, and activate or deactivate **Value Display**.

![Value Display](image)

The value that is displayed for an event depends on the event type. The following table shows what is displayed and edited in the **Data** columns and the value display:

<table>
<thead>
<tr>
<th>Event type</th>
<th>Data 1</th>
<th>Data 2</th>
<th>Value display</th>
</tr>
</thead>
<tbody>
<tr>
<td>Note</td>
<td>Pitch (note number)</td>
<td>Note-on velocity</td>
<td>Velocity</td>
</tr>
<tr>
<td>Controller</td>
<td>Controller type</td>
<td>Controller amount</td>
<td>Controller amount</td>
</tr>
<tr>
<td>Program Change</td>
<td>Program number</td>
<td>Not used</td>
<td>Program number</td>
</tr>
<tr>
<td>Aftertouch</td>
<td>Aftertouch amount</td>
<td>Not used</td>
<td>Aftertouch amount</td>
</tr>
<tr>
<td>Pitchbend</td>
<td>Bend amount</td>
<td>Not used</td>
<td>Bend amount</td>
</tr>
<tr>
<td>SysEx</td>
<td>Not used</td>
<td>Not used</td>
<td>Not used</td>
</tr>
</tbody>
</table>

**NOTE**

For note events, there is also a value in the **Data 3** column, which is used for note-off velocity.

**NOTE**

For SMF and text events, no values are displayed.

---

**List Editor Operations**

This section describes the principal editing operations within the **List Editor**.

**Drawing Events**

The **Draw** tool allows you to insert single events in the event display.

When you move the cursor inside the event display, its position is indicated on the status line. The snap function is taken into account.
MIDI Editors
List Editor Operations

- To change the event type that you want to draw, select it from the **Insert Event Type** pop-up menu.

- To draw an event, click in the event display. The note event gets the length that is set on the **Length Quantize** pop-up menu. Notes get the insert velocity value set in the **Insert Velocity** field on the toolbar.

- To draw longer note events, click and drag in the event display. The length of the event is a multiple of the **Length Quantize** value. If **Length Quantize** is set to **Quantize Link**, the event value is determined by the quantize grid.

**Filtering the Event List**

You can filter the event list with the **Filters** bar that is displayed below the toolbar in the **List Editor**.

- To filter the event list based on complex criteria, open the **Show** pop-up menu and select a filter.

- To hide an event type, activate the corresponding checkbox on the **Filters** bar.

- To hide all event types except one, press [Ctrl]/[Command] and click the checkbox of the event type that you want to view. If you [Ctrl]/[Command]-click again, all checkboxes are cleared.

**Editing in the Event List**

- To edit the values of several events, select the events and edit the value for one event. The values of the other selected events are also changed. Any initial value differences between the events are maintained.
- To set the values of all selected events to the same value, press [Ctrl]/[Command] and edit the value for one event.

- For SysEx events, you can only edit the Start position in the list. However, when you click the Comment column, the MIDI SysEx Editor opens, in which you can perform detailed editing of system exclusive events.

**NOTE**

When you trim the beginning of a note in the List Editor, the note may move to a different position in the list, since other events may begin earlier than the edited event.

**RELATED LINKS**

- [SysEx Messages on page 773](#)

**Editing in the Event Display**

The event display allows you to edit the events graphically using the tools on the toolbar. You can edit single events as well as several selected events simultaneously.

- To move an event, drag it to a new position.
  
  Moving the event past any other event in the display resorts the list. The list always shows the events in the order in which they are played back. As a result, the vertical position of the event in the display also changes.

- To make a copy of an event, press [Alt]/[Option] and drag it to a new position.

- To resize a note, select it and drag its end point with the Object Selection tool.

- To mute or unmute an event, click on it with the Mute tool.
  
  You can mute or unmute several events simultaneously by enclosing them in a selection rectangle with the Mute tool.

- You can select a color scheme for the events with the Event Colors pop-up menu on the toolbar.

- To delete an event, select it and press [Backspace] or [Delete], or click on it with the Erase tool.

**RELATED LINKS**

- [Coloring Notes and Events on page 690](#)

**Editing in the Value Display**

- To edit values in the value display, click and drag.
  
  The mouse pointer automatically takes on the shape of the Draw tool when you move it over the value display.
In-Place Editor

The In-Place Editor allows you to edit MIDI notes and controllers directly in the Project window, for quick and efficient editing in context with other tracks.

The In-Place Editor expands the MIDI track to show a miniature Key Editor. When you select a MIDI note, the Project window info line shows the same information about the note, as the info line in the Key Editor. You can perform the same editing here as in the Key Editor.

**RELATED LINKS**

*Editing Note Events on the Info Line on page 693*

### Opening the In-Place Editor

- To open the In-Place Editor for the selected tracks, select MIDI > Open In-Place Editor.
- To open the In-Place Editor for a single MIDI track, click the corresponding Edit In-Place button in the track list.

### Toolbar

The toolbar contains tools and settings for the In-Place Editor.

To open the toolbar, click on the gray triangle in the upper right corner of the track list for the edited track.

### Static Buttons

#### Acoustic Feedback

If this button is activated, individual notes are automatically played back when you move or transpose them, or when you create them by drawing.
Multiple Part Controls

**Edit Active Part Only**
If this button is activated, editing operations are applied only to the active part.

**Currently Edited Part**
This pop-up menu lists all parts that are currently open in the editor. This allows you to select a part for editing.

Insert Velocity

**Insert Velocity**
Allows you to specify a velocity value for new notes.

Indicate Transpositions

**Indicate Transpositions**
If this button is activated, MIDI notes are displayed according to their transposition settings.

Auto Select Controllers

**Auto Select Controllers**
If this button is activated and a note is selected in the editor, the corresponding controller data is also automatically selected.

Snap/Quantize

**Length Quantize**
Determines the event length for the **Length Quantize** function.

Event Colors

**Event Colors**
Allows you to select a color scheme for the events in the editor.

List of Parts in Editor

**List of Parts in Editor**
Lists all parts of the selected In-Place Editor.

**Working with the In-Place Editor**

- To zoom or scroll the In-Place Editor, point at the left part of the piano keyboard display so that the pointer changes to a hand. Then drag to the right or left to zoom in or out vertically, and drag up or down to scroll the editor.
MIDI Editors
SysEx Messages

- To add or remove controller lanes, right-click below the controller name field and select an option from the context menu.
- To close the In-Place Editor for one track, click Edit In-Place in the track list or double-click below the controller display in the In-Place Editor.
- To open/close the In-Place Editor for one or several selected tracks, use the Edit In-Place key command.
- You can drag notes from one In-Place Editor to another.

### NOTE
The Snap button and Snap Type pop-up menu on the Project window toolbar control snapping in the In-Place Editor, but the snap grid is set using the Quantize pop-up menu.

---

**SysEx Messages**

SysEx (System Exclusive) messages are model-specific messages for setting various parameters of a MIDI device. This makes it possible to address device parameters that would not be available via normal MIDI syntax.

Every major MIDI manufacturer has its own SysEx identity code. SysEx messages are typically used for transmitting patch data, for example, the numbers that make up the settings of one or more sounds in a MIDI instrument.

Cubase allows you to record and manipulate SysEx data in various ways.

**RELATED LINKS**
Using MIDI devices on page 658

---

**Bulk Dumps**

In any programmable device, the settings are saved as numbers in computer memory. If you change these numbers, you will change the settings. Normally, MIDI devices allow you to dump (transmit) all or some settings in the device’s memory in the form of MIDI SysEx messages.

A dump is therefore, among other things, a way of making backup copies of the settings of your instrument: sending such a dump back to the MIDI device restores the settings.

If your instrument allows the dumping of a few or all of its settings via MIDI by activating some function on the front panel, this dump will probably be recordable in Cubase.
Recording a Bulk Dump

**IMPORTANT**
If your MIDI instrument does not offer a way to initiate a dump, you have to send a Dump Request message from Cubase to start the dump. In that case, use the [MIDI SysEx Editor](#) to insert the specific Dump Request message (see the instrument’s documentation) at the beginning of a MIDI track. When you activate recording, the Dump Request message is played back (sent to the instrument), the dump starts and is recorded.

**PROCEDURE**

1. Do one of the following:
   - On Microsoft Windows, select **File > Preferences**.
   - On Mac, select the Cubase menu, and select **Preferences**.

2. In the **Preferences** dialog, select **MIDI > MIDI Filter**.

3. In the **Record** section, deactivate the **SysEx** checkbox to make sure that the recording of SysEx data is not filtered.
   This way, SysEx messages are recorded but not echoed back to the instrument. This can lead to unpredictable results.

4. Activate recording on a MIDI track and initiate the dump from the front panel of the instrument.

5. When you have finished recording, select the new part and select **MIDI > List Editor**.
   This allows you to check that the SysEx dump was recorded. There should be one or several SysEx events in the part/event list.

Transmitting a Bulk Dump Back to a Device

**PREREQUISITE**
Route the MIDI track with the System Exclusive data to the device. Check your device’s documentation to find details about which MIDI channel should be used, etc.

**PROCEDURE**

1. Solo the track.
2. Make sure that the device is set up to receive SysEx messages.
3. If necessary, put the device in **Standby to Receive System Exclusive** mode.
4. Play back the data.
About Recording and Transmitting Bulk Dumps

- Do not transmit more data than you need. If all you want is a single program, do not send all. Otherwise, it could get too difficult to find the recognized program. Usually, you can specify exactly which data you want to send.

- If you want the sequencer to dump the pertinent sounds to your instrument whenever you load a project, put the SysEx data in a silent count-in before the project itself starts.

- If the dump is very short, which can, for example, be a single sound you can put the dump in the middle of the project to quickly re-program a device. However, you can achieve the same effect by using Program Change. This is definitely preferable, since less MIDI data is sent and recorded. Some devices may be set up to dump the settings for a sound as soon as you select it on the front panel.

- If you create parts with useful SysEx dumps, you can put these on a special muted track. To make use of these parts, drag it to an empty unmuted track and play it back.

- Do not transmit several SysEx dumps to several instruments at the same time.

- Make a note of the current device ID setting of the instrument. If you change this, the instrument may later refuse to load the dump.

Recording SysEx Parameter Changes

Often you can use SysEx to remotely change individual settings in a device, for example, opening a filter, selecting a waveform, changing the decay of the reverb, etc. Many devices are also capable of transmitting changes that are made on the front panel as SysEx messages. These can be recorded in Cubase, and thus incorporated into a regular MIDI recording.

For example: you open up a filter while playing some notes. In that case, you record both the notes and the SysEx messages that are generated when you open the filter. When you play back the recording, the sound changes exactly as it did when you recorded it.

**PROCEDURE**

1. Select File > Preferences.
2. In the Preferences dialog, select MIDI > MIDI Filter and make sure that SysEx is deactivated in the Record section.
3. Make sure that the instrument is set to transmit changes of front panel controls as SysEx messages.
4. Record.

**AFTER COMPLETING THIS TASK**

In the List Editor, check if the events were recorded properly.
MIDI SysEx Editor

While SysEx events are displayed in the List Editor/Project Browser (Cubase Pro only), it is not their entire content, that is displayed. Only the beginning of the message is displayed in the Comment column for the event. The event is not editable. You can only move the event, the same way you would move it in the List Editor.

- To open the MIDI SysEx Editor for a SysEx event, click in the Comments column for the event in the List Editor/Project Browser.

The display shows the entire message on one or several lines. SysEx messages always begin with F0 and end with F7 and a number of arbitrary bytes in between. If the message contains more bytes, so that they do not entirely fit on one line, it continues on the next line. The Address indication to the left helps you find out on which position in the message a certain value is located.

You can edit all values except for the first (F0) and the last ones (F7).

In the MIDI SysEx Editor, the bytes are displayed as follows:

- In the main display, values are shown in hexadecimal format.
- To the right of the main display, values are shown in ASCII format.
- At the bottom of the dialog, the selected value is shown in ASCII, binary, and decimal formats.

Adding and Deleting Bytes

- To add a byte, open the MIDI SysEx Editor and click Insert. The byte is added before the selected byte.
- To delete a byte, open the MIDI SysEx Editor, select a byte, and click Delete.
- To delete the complete SysEx message, select it in the List Editor and press [Delete] or [Backspace].
Editing Byte Values

You can edit the selected byte value in the main display of the MIDI SysEx Editor, or in the ASCII, decimal, and binary displays.

- To edit the selected value, open the MIDI SysEx Editor, click on a byte, and type in the value.

Importing and Exporting SysEx Data

You can import SysEx data from disk and export the edited data to a file.

The file has to be in MIDI SysEx (.syx) binary format. Only the first dump in a SYX file will be loaded.

- To import SysEx data, open the MIDI SysEx Editor and click Import.
- To export SysEx data, open the MIDI SysEx Editor and click Export.

**NOTE**

Do not confuse this format with MIDI files, which have the extension .mid.
Expression maps (Cubase Pro only)

Introduction

About articulations

Musical articulations, or expressions, define how certain notes “sound”, i.e. how they are sung or performed on a given instrument. They allow you to specify that a string instrument is bowed (not plucked), a trumpet muted (not played open), and so on. Articulations also define the relative volume of notes (to play some notes louder or softer than the others) or changes in pitch (create a tremolo).

Articulations can be divided into “Directions” and “Attributes”.

• Directions are valid for all notes from the insert position on, until another direction is scored. This means, they are applied not to single notes, but to a continuous range of notes, or even an entire piece of music.
  An example for a direction is pizzicato, which means that the string instrument is plucked.

• Attributes belong to single notes. They are only applied to the notes for which they are scored.
  Examples for this are accents, where a note is played with an emphasis, and staccato, where a note is played shorter.

<table>
<thead>
<tr>
<th>Direction</th>
<th>Attribute</th>
<th>Attribute</th>
<th>Attribute</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pizzicato</td>
<td>Tenuto</td>
<td>Accent</td>
<td>Staccato</td>
</tr>
</tbody>
</table>

Articulations and MIDI

When working with MIDI, i.e. when you are entering notes via a MIDI keyboard, editing notes in the MIDI editors or using VST instruments, articulations need to be realized as different sounds.
To trigger the necessary sound changes, use the following command and data types:

**Program Change**

Program Change messages can be used to instruct a connected VST instrument to switch from one program to another. Depending on the instrument, this can be used to play a different articulation.

**MIDI channel**

Multi-timbral instruments, such as Steinberg’s HALion, feature programs, usually representing different articulations. These can be accessed via MIDI channel messages.

**Key switches**

Some software samplers, like Steinberg’s HALion Symphonic Orchestra, make use of “key switches”, meaning that certain keys are not used to trigger sounds, but to switch between articulations, for example.

**Expression maps**

When working on a project, you might want to audition a composition including articulations. In Cubase, this can be achieved using expression maps, which can be selected via the Expression Map section in the Inspector for MIDI or instrument tracks. Within these maps, you can specify the sound mapping and characteristics for all your musical expressions, using the methods described in the table above.

When you select an expression map for a MIDI or instrument track, the articulations (sounds) defined in the map are automatically applied during playback. Cubase recognizes the expressions scored for the MIDI part and searches the sound slots in the expression map for a sound that matches the defined criteria.

When a matching sound slot is found, the current note is either modified (e.g. reduced in length or played louder), or the MIDI channel, program change or key switch information is sent to the connected instrument (the instrument selected on the Output Routing pop-up menu for the track), so that a different sound is played. When no sound slot is found that matches the articulations used in the part, the “closest match” is used.

When you enter articulations in a MIDI part, you need to set up an expression map in a way that the right sounds in the connected VST or MIDI instrument are triggered.

Expression maps also allow you to link your articulations with remote keys on a MIDI input device and map these to sounds that can be played by a MIDI device or VST instrument. This way, you can enter notes and articulations using a remote MIDI device and have these automatically be recorded and played back correctly by Cubase.

Expression maps are useful in the following situations:

- When you want to enter musical articulations directly in one of the MIDI editors, especially the Score Editor, without having to record MIDI data first.
• When you want to play/record music in realtime and control articulation changes while playing.

• When you open and edit projects from other users. By using expression maps, you can map the articulation information to a different instrument set or content library quickly and easily.

**NOTE**
You can also use the Note Expression functions to add articulations directly on your MIDI notes in the Key Editor.

**RELATED LINKS**
- Creating and editing expression maps on page 785
- Groups on page 789
- Note Expression on page 792

---

**Using expression maps**

Expression maps and their related functions can be found in different locations in Cubase. To be able to use these functions, an expression map or a track preset containing such a map has to be loaded.

**Loading expression maps**

Expression maps can either be part of track or VST presets, or be saved separately. Depending on this, the way to make them available in Cubase is slightly different.

**Loading expression maps that are part of presets**

Cubase comes with a set of predefined expression maps which are part of the default presets. They are loaded automatically with the presets.

The following applies:

- Included with Cubase are several track presets which are pre-configured for use with expression maps. They contain sounds that make use of key switches and have different articulations. To indicate that these presets can be used in this context, they have the suffix “VX”.

- Track presets for HALion Symphonic Orchestra can also be used with expression maps. The presets are installed automatically with Cubase. However, for them to be available, you have to separately install the VST instrument.
  These track presets begin with “HSO” and end with “VX”.

**RELATED LINKS**
- Track Presets on page 160
Expression maps that were saved separately

You can also define your own expression maps. To load these, proceed as follows:

**PROCEDURE**

1. In the Inspector for the selected track, select the Expression Map section, open the pop-up menu and select “Expression Map Setup…”. The Expression Map Setup window opens.

   **NOTE**

   If the Expression Map section is not shown in the Inspector, right-click on another Inspector section and select “Expression Map” from the context menu.

2. In the Expression Maps section on the left, click the Load button.

   A file dialog appears.

3. Locate and select an expression map and click Open.

   The expression map is added to the Maps list.

4. Repeat the steps for all the maps that you want to make available, and close the dialog.

   ![Expression Map Setup Window](image)

   All loaded maps are available on the Expression Map pop-up menu in the Inspector.

**RELATED LINKS**

Creating and editing expression maps on page 785

Expression maps in the Project window

In the Inspector for MIDI and instrument tracks, the Expression Map section is available. This indicates whether an expression map is used for a track. It also shows the sound slots that are active for playback and for realtime input.

![Expression Map Section in Inspector](image)

1) Indicates that an expression map is used for the track.

2) Shows which remote key is being pressed.

3) Marks the slot that is currently played back.
The possibility to monitor the active slots is especially useful when recording articulations with an external device, such as a MIDI keyboard. This way, you can see whether the correct sound slot, i.e. the right articulation, is used.

**Expression maps in the Score Editor**

In the Score Editor, the articulations that are part of an expression map can be inserted like other symbols. There is a special tab in the Symbols Inspector, containing all articulation symbols of the current expression map.

- To insert a symbol, click on it in the Expression Map tab, and click at the desired position in the note display.

- To delete an articulation symbol from the score, select it and press [Delete] or [Backspace].

  You can also click on it with the Eraser tool.

**NOTE**

In the Preferences dialog (Score–Colors for Additional Meanings page), you can specify a color for Expression Map symbols. This way, you can easily distinguish them from other Score symbols.

Articulation editing in the Score Editor is the same as regular symbol editing.

**IMPORTANT**

In the Score Editor, it is possible to insert symbols for a single note that in fact cannot be combined in a musically meaningful way. So when entering articulations, make sure that they do not conflict with other articulations.

**RELATED LINKS**

[Working with symbols on page 1206](#)

**Expression maps in the Key, Drum, and In-Place Editors**

If an expression map is used for a MIDI or instrument track, its articulations are shown in the note events in the Key Editor display, provided that the vertical zoom factor is high enough. If the horizontal zoom factor is high enough, the attribute description (the text in the Description column) is also shown.
You can insert and edit articulations in the Key, Drum, and In-Place Editors using the controller lane. This is much like regular controller lane editing.

- To display the articulations set up in the selected expression map, open the pop-up menu to the left of the lane and select “Articulations/Dynamics”.

- When “Articulations/Dynamics” is selected for a controller lane, the note beginnings are displayed as thin vertical lines in the controller display.

- All articulations that are specified for the selected expression map are available on the controller lane. They appear on different rows one above the other. The order in which they are listed is the same as in the expression map. The different groups (1 to 4) are also reflected here. They are separated by black lines. Articulations belonging to the same group are shown in the same color.

- Directions are displayed as bars in the controller lane. They begin at the insertion point of a direction and end at the insertion point of the next articulation from the same group (or at the end of the part if no more directions follow). Attributes are inserted at the note beginning.

  You can assign a maximum of one attribute per group to each note.

**RELATED LINKS**

- Editing Articulations on page 788
- Using the Controller Display on page 716
- Editing Dynamics (Cubase Pro only) on page 722
- Groups on page 789

**Editing on the controller lane**

- To insert new directions on the controller lane, select the Draw tool and click at the desired position in the respective row, i.e. where you want the direction to start. Note that you have to click at the exact position of the first note that you want to apply this articulation to or to the left of it.

  Instead of selecting the Draw tool, you can also hold down [Alt]/[Option] and click at the desired position.

- To insert new attributes on the controller lane, select the Draw tool and click at the respective note line in the corresponding row of the controller lane. Instead of selecting the Draw tool, you can also hold down a modifier key (by default [Alt]/[Option]) and click at the desired position.
Expression maps (Cubase Pro only)

Using expression maps

- To remove a direction, click on it with the Erase tool or select it and press [Delete] or [Backspace].
- To remove an attribute, click on it with the Draw tool.
  Note that you cannot select attributes in the controller lane without automatically selecting the corresponding note, too. Therefore, you cannot delete an attribute by selecting it and pressing [Delete] or [Backspace] without deleting the note as well.

NOTE

If several notes are selected, you can use the Draw tool to insert or delete attributes for all of them in one go.

Editing on the info line

When a MIDI note is selected in the note display, the info line contains the “Articulations” option. This displays the note attributes (symbols) specified for the selected note. Click in this section to open the Articulations pop-up menu.

The following applies:

- All note attributes available in the expression map are shown on the pop-up menu, sorted by group.
- To add an attribute to a note, simply select it on the pop-up menu. Attributes that are active for a note are indicated on the menu. If you click on an active attribute again on the menu, it is deleted.
- If you select another attribute from the same group for a note, the attribute replaces the previous attribute.

RELATED LINKS

Groups on page 789

Expression maps in the List Editor

In the List Editor, the Articulations can be viewed and edited in the Comment column. The options are the same as on the Key Editor info line.
Directions can be shown either as Text or as Graphic Symbols (like in the Score Editor). Either way, they are followed by the text “VST Expression” in brackets, so as to be easily recognizable and distinguishable from ordinary Score symbols.

Creating and editing expression maps

Creating an expression map from scratch

PROCEDURE

1. In the Inspector for a MIDI or instrument track, open the Expression Map section, open the pop-up menu and select “Expression Map Setup…”. The Expression Map Setup window opens, allowing you to load and create expression maps.

![Expression Map Setup Window](image)

NOTE

You can also open the Expression Map Setup window by selecting the “Expression Map Setup…” option on the MIDI menu.

2. To create a new map from scratch, click the “+” button at the top of the Maps list in the Expression Maps section of the dialog. A new map named “Untitled” is shown in the Expression Maps section.

3. Click on the map name and enter a meaningful name (e.g. “Cello” to set up an expression map for a cello).
Creating expression maps based on the key switches used in an instrument

You can automatically extract mapping information from your connected VST instruments and convert it into a new expression map. This makes it very easy to set up expression maps for the instruments you often work with.

**PROCEDURE**

1. Load the VST instrument you want to use and assign it to a MIDI or instrument track.
2. Select the track, open the Expression Map section in the Inspector, and select "Import Key Switches" on the pop-up menu. Note that this menu option will only be available when the loaded program contains key switches. The Expression Map Setup window opens.
3. Make the desired settings for the created map and click the Save button. The expression map is saved and can now be loaded via the pop-up menu on the Expression Map section of the Inspector.

**RELATED LINKS**

- Creating an expression map from scratch on page 785

Adding sound slots

Now, you create one sound slot for each articulation that you want to add.

**PROCEDURE**

1. In the Sound Slots section to the right of the Maps list, a sound slot is added automatically when a new map is created. This is the default slot that is used. You can specify an articulation for it or leave it empty, depending on your preferred default setting.
2. Click in the first Articulation column (Art. 1) for the sound slot and select an articulation from the menu. A new entry is added in the Articulations section in the lower right corner of the window.

3. When adding articulations, the name of the sound slot is automatically set to the articulation. To change the name, click in the name field and enter a new name. The names of the sound slots are displayed in the Inspector for the track.

4. To create a complex articulation, made of several different single articulations, click in the other Articulation columns (Art. 2-4) for the sound slot and add the corresponding articulations. For each new articulation, an additional entry is added in the Articulations section.
   - Apart from creating combined articulations, the Articulation columns also allow you to prioritize articulations, by sorting them into different groups. When the program is looking for sounds and no exact match is found, the group setting defines the “closest match”, i.e. the sound which matches most criteria when searching from left to right is used. For example, if two sounds are found which have the same articulation in group 1, the sound that also matches group 2 is preferred and so on. For more information on groups, see below.
   - If you cannot find the articulation that you want to add on the pop-up menu, you can define your own articulations by selecting “Add Custom Articulation”. This adds a default articulation which you can define in the Articulations section, see below.
   - Click in the “Col” column to assign a color to the current sound slot. When working in the MIDI editors, you can color your events according to the color of the sound slots.

5. When you have made the desired settings, click the “+” button again to add another sound slot. Add as many sound slots as you need. In the Remote column, you can specify the key on your external device that triggers this sound slot.

RELATED LINKS
Expression maps in the Project window on page 781
Remote Key Settings on page 789

Output Mapping

When you have added sound slots, you can map them to certain sound characters or expressions of an instrument, e.g. a bowed violin or a pizzicato violin. The available sounds depend on the instrument that is selected for the MIDI or instrument track. Some of the more complex virtual instruments require multiple key switches or combinations of key switches and controllers to select a particular articulation. This can be accomplished by stacking multiple output events to a single sound slot. You can add a new slot by clicking the “+” button above the list.
You can make the following settings for the slots: In the Status column, you can specify a note-on, program change, or controller message. Additionally, you can make settings in the Data 1 and 2 columns (if applicable). If you have an instrument that uses key switches (for example Steinberg’s HALion Symphonic Orchestra), you can specify these key switches here. This allows you to switch between a bowed and a pizzicato violin, or to switch to another program containing a different articulation.

You can also create expressions by editing the incoming MIDI data, for example by changing the note length or velocity. For this, you can make the following settings in the lower part of the Output Mapping section:

**Channel**

Here you can specify the MIDI channel. When using HALion Symphonic Orchestra for example, this allows you to switch to a different program.

**Length**

Here you can specify the note length. This way, you can create staccato or tenuto sounds.

**Velocity**

Here you can specify the desired velocity. This allows you to create accents, for example.

**Min. Velocity**

If you are using an instrument that has different velocity ranges on the same key, you can specify a minimum velocity here, to make sure that the sample mapped to a particular range is used.

**Transpose**

This allows you to specify a transpose value. This can be used to select different articulations in some sample libraries, in which different articulations are located on different octaves, for example.

**Controller 1/2**

These allow you to set MIDI Control Change messages and their values for each sound slot.

**Editing Articulations**

In the Articulations section, the articulations you added for the sound slots are displayed.

The following settings can be made here:

**Art.**

Clicking in this column opens a context menu, where you can choose whether you want to insert a symbol or a text string. If you select Symbol, the dialog with the available symbols opens. If you select Text, you can directly enter the desired text.
Expression maps (Cubase Pro only)

Creating and editing expression maps

Type

In this column you specify whether you want to add an “Attribute” (which only influences a single note, e.g. an accent) or a “Direction” (which is valid from the insertion position until it is replaced by another articulation, e.g. arco and pizzicato).

Description

Here, you can enter a descriptive text. For example, this can be the name of the symbol (e.g. Accent) or the long name of a direction (e.g. pizz and pizzicato).

Group

This column allows you to specify the group, or importance of the symbol, see below.

Groups

You can sort the different articulations you define for an expression map into one to four groups. Groups can be used to combine directions and attributes in more complex musical expressions by choosing articulations from the different groups, for example to play a note arco AND staccato AND with an accent.

The groups themselves are exclusive. This means articulations residing within the same group cannot be used together. Since some of the articulations cannot be combined – for example, a violin cannot be played arco (bowed) and pizzicato (plucked) at the same time – these articulations should be placed in the same group.

Furthermore, the groups represent the musical importance, with group 1 having the highest priority (expressions in group 1 are more important than those in group 2, 3, and 4). This setting is required when the expression map does not find an exact match for your data and tries to identify the closest possible sound. Let’s say you have added a staccato symbol and an accent to a note in an editor. In the expression map, you have specified that staccato is in group 2 and the accent is in group 3. The connected instrument, however, does not have a sample that corresponds to these settings. In this case, the program looks for a staccato sound, disregarding the accent.

Remote Key Settings

The remote keys specify which key on an external device is used to play a certain sound slot, i.e. these keys are then used to insert articulations instead of notes.

The active remote keys (if any) are indicated in the Inspector for the track.

NOTE

If you do not plan to record or trigger articulations via a MIDI input device, you do not need to specify remote keys.

RELATED LINKS

Expression maps in the Project window on page 781
**Latch Mode**

This setting determines whether the remote key function reacts to note-off messages.

- When Latch Mode is deactivated, the key you press on your MIDI input device is valid for as long as the key is held, i.e. the sound slot plays until the key is released.
  On release, the default (first) sound slot is played again.

- When Latch Mode is activated, the key you press is valid until the next key is pressed.

**IMPORTANT**

Note that Latch Mode can only be generally activated/deactivated in Cubase, not for single expression maps.

**Root Note**

Here, you can specify the first key on your external device that you want to use as a remote key. This is useful, since it allows you to automatically adjust existing remote key assignments to suit your needs, for example when you are using a MIDI keyboard with a very wide or very narrow key range.

**Set Remote Keys**

Remote keys can be specified manually for each slot in the Sound Slots section of the window. However, you can also automatically assign a range of keys on your external device to the sound slots in the expression map.

**PROCEDURE**

1. Click the Set Remote Keys button.
   A dialog opens.

2. Use the Start Key field to specify the first key on the MIDI input device that you want to trigger a sound slot.

3. On the Key Mapping pop-up menu, you can specify with which keys on your device you want to trigger the sound slots.
   You can choose whether you want to use all keys on the keyboard as remote keys, or whether only the white or black keys are used.

4. Click OK to close the dialog.
Saving your settings

When you have made the desired settings, you need to save the expression map. To do so, click the Save button in the Expression Maps section of the window, specify a file name and a location for the expression map, and click Save.
Introduction

Note Expression offers a very intuitive way of controller editing in Cubase. As an alternative to working with controller lanes in the Key Editor, controller data can be viewed and edited directly on the associated MIDI note events in the event display.

With Note Expression, a note and its associated controller data are treated as a unit. When you quantize, move, copy, duplicate, or delete notes, all their associated controller information will follow. This allows for a very intuitive and accurate editing of note-related data. The Note Expression values can be edited in various ways. Furthermore, by superimposing the corresponding data curves in the event display, you can view all the Note Expression data for a note simultaneously, which gives you a good overview.

Note Expression curves in the Key Editor

When working with Note Expression, it is important to distinguish between VST 3 controllers and MIDI controllers.

RELATED LINKS

Editing Note Expression data on page 802
VST 3 controllers

VST 3 controllers are provided by the VST instrument. Therefore, different controllers can be available, depending on the instrument.

VST 3 controllers provide articulation information for each individual note. Unlike MIDI controllers (which are channel-specific), VST 3 controllers are note-specific and are suitable for polyphonic contexts. Articulating each note in a chord individually creates a much more natural feel. Furthermore, VST 3 controllers allow for a value range that exceeds the MIDI range of 0 to 127, which offers a more comfortable value editing and fine-tuning.

To be able to work with VST controllers, you need a VST instrument that offers this kind of controller parameters and is capable of playing back these controller messages. Included with Cubase is HALion Sonic SE, which is compatible with Note Expression.

RELATED LINKS
HALion Sonic SE on page 813

MIDI controllers

A major limitation of MIDI is the nature of controller information. With the exception of poly pressure, controller messages are channel-specific messages, i.e., they affect the entire instrument, regardless of whether they are inserted for a part or a note.

Therefore, when using Note Expression with MIDI instruments (hardware or VSTi), it is important to understand that articulation data on one note usually also affects all other notes of the same voice, i.e. any other note playing on the same channel at the same time. This limits the potential of Note Expression for MIDI controller events to monophonic (solo) performances. When using MIDI controllers in polyphonic performances, we recommend using controller lanes in the Key Editor.

However, Note Expression can be useful in the context of standard VST instruments and MIDI hardware instruments.

RELATED LINKS
Using the Controller Display on page 716
Recording MIDI controllers as Note Expression data on page 810
Converting MIDI Controllers into Note Expression data on page 810

Working with Note Expression

When working with Note Expression, start by activating the “Show Note Expression Data” button on the Key Editor toolbar. This will give you a visual feedback of your actions. Use the slider to the right of the button to modify the display size of the Note Expression data in the event display.
If you want to listen to your editing, activate the Acoustic Feedback button on the Key Editor toolbar. Playback is triggered when you enter or change Note Expression data. All controllers that are present at the mouse position will be used during playback.

Note Expression can be used in the following ways:

- You can record notes live into Cubase while attaching some or all of the used controllers as Note Expression events to the notes.
- You can replace the existing Note Expression data of a MIDI part by recording Note Expression events for the MIDI notes during playback.
- You can add Note Expression data to one MIDI note after another using the “Note Expression MIDI Input” button.
- You can draw in Note Expression events for MIDI notes in the Note Expression editor.

**RELATED LINKS**

- Recording on page 799
- Overdubbing on page 800
- Recording Note Expression data via MIDI input on page 801
- Editing Note Expression data on page 802

---

**Setting up the Note Expression Inspector tab**

To be able to work with Note Expression, you have to set up the parameters first. This is done on the Note Expression tab in the Inspector of the Project window or the Key Editor.

The top area of the Note Expression tab shows a list of parameters. The VST 3 controllers are shown first, followed by the MIDI controllers. Which VST 3 controllers are available depends on the instrument that is used. The MIDI controllers can be set up in the MIDI Controller Setup dialog.

**NOTE**

If many controllers are available, you may have to navigate through the list using the scrollbar.

If an asterisk (*) is displayed in front of a parameter name, data for this controller exists. The number to the right of a parameter determines the MIDI controller mapped to the parameter for recording.
1) In the CC column, the controller assignment is shown, if any.
2) VST 3 controllers
3) MIDI controllers
4) Settings for the selected controller
5) Global settings

In the middle section of the tab, you can make settings for the parameter that is selected in the list. The following options are available:

**Parameter name and color selector**

By clicking on the colored square to the right of the parameter name, you can specify which color is used for the parameter in the Inspector and in the note display. You can also define a Note Expression color set.

**MIDI assignment field and pop-up menu**

Here, you can specify the MIDI controller assignment for recording for the selected parameter by either selecting it from the pop-up menu or using the MIDI Learn button.

**MIDI Learn button**

You can assign any control of your external MIDI controller to the selected parameter. Click the MIDI Learn button and move the fader or knob on the external device.

**Parameter range controls (Min/Max)**

If you want to use only a certain value range of the parameter, you can specify it here. Set the range by changing the minimum and maximum values or use the slider below the fields.

Using a parameter range allows you to make finer settings for certain parameters. This is especially useful for the VST 3 parameter “Tuning”. Specify the range you want to use and enter or record the corresponding data.
In the lower part of the Note Expression tab, the following global settings and parameters are available:

**MIDI as Note Expression**

If this button is activated, incoming MIDI controllers will be recorded as Note Expression data.

**Channel Rotation**

If this option is activated, individual MIDI channels are assigned to incoming MIDI notes and their controllers.

**IMPORTANT**

In order to use the *Channel Rotation* mode, the input controller must support channel rotation.

**Overdub**

When this is activated, you can overdub existing Note Expression data.

**Latch Buffer**

With this button, you can activate/deactivate the latch buffer used for overdub recording.

**RELATED LINKS**

- Mapping controllers on page 797
- Selecting the Event Type on page 716
- Project Colors Dialog on page 1040
- Recording MIDI controllers as Note Expression data on page 810
- Channel Rotation on page 800
- Overdubbing on page 800
- Latch mode on page 800

**Showing/hiding controllers**

You can specify which parameters are displayed in the Note Expression editor and in the event display by activating/deactivating them in the leftmost column in the list. When you want to edit a single parameter, it might be best to hide the data for the other parameters.

Activating several parameters allows you to view them in context, giving you a better overview. In the Inspector, visible controllers are shown with a filled rectangle in front of their name. Hidden controllers are shown with an empty rectangle. To show or hide a parameter, click on its rectangle.

This controller is visible.

This controller is hidden.
Filtering the list

If you click on the Parameter column header, a pop-up menu opens, containing the following filter commands:

Show only used Parameters
Select this command to only display the parameters in the list for which data exists.

Make all Parameters visible
Select this command to display all available parameters in the event display.

Make only edited Parameter visible
Select this command to display only the currently edited parameter in the event display.

Bypassing Note Expression

Like for most other Inspector tabs, you can bypass the Note Expression settings by clicking on the button at the top right of the Inspector tab, so that it lights up yellow. If Bypass is activated, all Note Expression data will be bypassed for the track.

Mapping controllers

External keyboards have no controls or faders for VST 3 parameters, which can therefore not be recorded directly. To remedy this, you have the possibility to assign a certain MIDI controller (or Pitchbend and Aftertouch) to any of the Note Expression parameters in the list. The MIDI assignment is shown in the CC column in the Inspector.

The same MIDI controller can be used for several parameters, but only one of these controllers can be active at a time. If the mapping is active, the number for the assigned MIDI controller is displayed (or PB and AT for Pitchbend and Aftertouch, respectively). If a MIDI controller is assigned but inactive, e.g., because the selected parameter uses the same assignment as another parameter, a dot is shown in the CC column.
The VST 3 parameter Tuning is automatically assigned to the pitchbend wheel of your MIDI controller. All other parameters are assigned by default to the first MIDI controller (CC1: Modulation).

To manually specify the record mapping for the parameters, use the MIDI Learn function, or load a mapping preset, see below.

**Manual mapping**

To manually map a MIDI controller to the selected Note Expression parameter, you can select the MIDI controller from the MIDI assignment pop-up menu. If the MIDI controller you are looking for is not on the list, select “MIDI Controller Setup…” and activate it in the dialog. This is the same as selecting which controllers are available for the controller lanes in the Key Editor.

**RELATED LINKS**

- Selecting the Event Type on page 716

**MIDI Learn**

Another way to assign the knobs and faders of your MIDI instrument to Note Expression parameters is using the MIDI Learn function.

**PROCEDURE**

1. Select the parameter to which you want to assign a MIDI controller.
2. Below the list, click the MIDI Learn button to the right of the MIDI assignment pop-up menu.
3. Use the knob or fader on your MIDI device that you want to assign to the selected Note Expression parameter.
   This control is now automatically assigned.
4. Repeat this step for all the parameters you want to control with your MIDI device.

**RESULT**

Now, you can record Note Expression data using the controls on your MIDI device.
**Using mapping presets**

When you have set up the mapping for a connected MIDI device, you can save these settings as mapping presets for future use, e.g. when working again with this device.

**PROCEDURE**

1. Open the Parameter pop-up menu and select “Save MIDI Input Assignment”.
2. In the file dialog that appears, specify a name and a location for the file.
   A file with the extension “*.neinput” is created.

**RESULT**

You can recall the mapping presets you created by using the “Load MIDI Input Assignment” command on the Parameter pop-up menu.

**Recording**

**Recording notes and Note Expression data**

To record MIDI notes together with Note Expression data using an external MIDI device, proceed as follows:

**PROCEDURE**

1. Create an instrument track, e.g. using HALion Sonic SE as VST instrument.
   The Note Expression Inspector tab shows which parameters are available for recording.
   • You can also load one of the available presets. Some presets were created especially for the use with Note Expression. These have the suffix “.NoteExp”.
2. Select a parameter from the list.
3. Set up the record mapping for the parameters.
   You can use the data range controls to use only a subrange of the full parameter range. This allows for finer recording and editing.
4. Record some MIDI notes and use the mapped controls on your MIDI device to record the corresponding Note Expression data.
5. Open the Key Editor and activate the “Show Note Expression Data” button on the toolbar.
   The Note Expression data is shown on the notes for which it was recorded.

**RELATED LINKS**

Mapping controllers on page 797
Channel Rotation

Some input controller can assign individual MIDI channels to incoming MIDI notes and their controllers. Each new MIDI note event gets its own internal MIDI channel and all controller that belong to this note event are created with the same MIDI channel. This allows a 16 voice polyphony, which is sufficient for most performances.

The Channel Rotation mode allows a correct mapping of these data as Note Expression data per note event. This reduces the amount of data in comparison to the MIDI to Note Expression conversion method.

IMPORTANT

In order to use the Channel Rotation mode, the input controller must support channel rotation.

RELATED LINKS

Setting up the Note Expression Inspector tab on page 794

Overdubbing

You can also record or replace Note Expression data for existing notes. This is achieved by overdubbing. To activate this mode, click the Overdub button on the Note Expression Inspector tab. When this is activated, no notes are recorded when you click the Record button. Instead, you can use the controls on your MIDI device to record Note Expression data for the note that is playing.

IMPORTANT

• To be able to record MIDI notes again, you have to deactivate the Overdub button when you have finished recording the Note Expression data.

• If notes are selected when you start overdubbing, controllers will be recorded for these notes only. To record controllers for all notes touched by the position cursor, make sure to deselect all notes in the event display before you start overdubbing.

Latch mode

When Cubase receives controller data from an external MIDI device, this information, i.e. the setting of the faders and knobs on the device, is automatically written to the Latch buffer. By activating Latch mode when overdubbing Note Expression data, you can add the data in the Latch buffer to the notes while these are played back. This can be useful when you want to overdub Note Expression data starting at specific controller values (i.e. at predefined initial knob or fader settings), for example.

To use Latch mode, start by mapping each control to one of the available VST 3 parameters. Then activate the Latch buffer button and set the knobs and faders on the MIDI controller to the desired values.
When you now start overdubbing, the values for all these controls are attached to the notes that are passed during overdub recording, replacing any existing controller data of the same type.

1) Reset Latch Buffer
2) Click here to activate Latch mode

**RELATED LINKS**

Mapping controllers on page 797

**Resetting the Latch buffer**

Whenever data is present in the Latch buffer, the “Reset Latch buffer” button becomes available. If you click this button, all the memorized values are removed from the Latch buffer.

**NOTE**

When you are using Latch mode in combination with cycle recording, the Latch Buffer is automatically reset at the end of the cycle.

**Recording Note Expression data via MIDI input**

An alternative way to enter Note Expression data for existing notes is using Note Expression MIDI input. When you activate the “MIDI Input” and “Note Expression MIDI Input” buttons on the Key Editor toolbar, you can replace the controllers for the selected note.

- To record Note Expression data via MIDI input, select a note and move the active control on your MIDI device.

  The note is played in real time and any manipulation of the controls, i.e. all incoming controller data, is recorded for this note. Recording stops when the end of the note or the end of the release phase is reached, or when you deselect the note.

**RELATED LINKS**

Editing the release phase of a note on page 807
Recording the sustain pedal

When the sustain pedal (MIDI CC 64) of the connected MIDI device is held during recording, the following applies for VST 3 parameters (not for continuous MIDI controllers):

- When a note-off event is received (when the key on the connected keyboard is released), this message is not sent to the VST 3 instrument but is instead created by the program when the sustain pedal is released. This makes it possible for the VST 3 instrument to play back controllers that are sent after a key was released.

- The release phase of the recorded notes ends when the sustain pedal is released.

Editing Note Expression data

In the Key Editor, you can view and edit the Note Expression data for notes in the Note Expression editor. This is opened by double-clicking a note in the event display. In the editor, you can add Note Expression data from scratch. All parameters that are marked as visible in the Inspector are displayed as curves in the editor.

**NOTE**

When several notes are selected in the Key Editor and you double-click any of them, the Note Expression editor opens for all these notes. This is useful if you want to edit all notes in a chord in the same way, for example.

- To adjust the editor size, click and drag the Resize handle (in the center of the lower border of the editor). This allows you to switch between three different window sizes.

- To navigate from note to note while the editor is open, use the left and right arrow keys.
  You can also use the key commands [Tab] and [Shift]-[Tab] to step through the notes.
To make settings in the editor, first select the parameter that you want to make settings for. How to do this depends on whether you want to modify existing data or enter new data from scratch:

- If you want to enter new data from scratch, i.e. create events for a parameter that has not been used yet, you have to select this parameter in the Inspector to make it available in the editor.

- If you want to edit existing data, you specify which parameter to edit in one of the following ways: by clicking on the curve, by selecting the corresponding controller on the Parameter pop-up menu, or by selecting the parameter on the Note Expression Inspector tab.

  The parameter pop-up menu in the lower left corner of the editor lists all parameters that are used for the edited note. If the editor size is big enough, the name of the edited parameter is displayed to the right of the pop-up menu.

- You can close the editor by clicking outside of it in the event display.

  You can also specify a key command for opening and closing the Note Expression editor.

The value display

The value display in the lower right corner of the editor shows the current value at the (vertical) mouse pointer position. The value range differs depending on the parameter type, e.g. 0 to 127 for MIDI controllers or semitones and cents for Tuning.

Selection ranges

You can select a range of controller values by clicking and dragging in the editor with the Object Selection tool.

- If you hold down [Shift] and drag, any previous selection will be kept.

- You can move selections by dragging them in the editor.

- To copy a selection in the editor, click on it, keep the mouse button pressed, then press [Alt]/[Option] and drag.

Editing functions

Drawing in data

You can enter or modify curves using the Draw tool or the line tool. The editing is the same as in the controller lanes. If the Object Selection tool is selected and the editor is open, you can press [Alt]/[Option] to get the Draw tool.
Using Cut, Copy, and Paste

- To cut, copy, and paste Note Expression data for a single parameter in the editor, use the corresponding commands on the Edit menu.

  It is also possible to copy and paste data between different parameters.

  **NOTE**

  Pasting Note Expression data in the editor is restricted to the note (or notes, if they are located at the same time position) for which the editor is open. However, you can copy all Note Expression data from one note to another using a key command.

- To paste all the Note Expression data from one note to other notes, set up the key command “Paste Note Expression” in the Key commands dialog (Note Expression category).

  This pastes all the Note Expression information of one or several notes for which you have used the Copy command into the currently selected notes.

Using the “Paste Note Expression” command, you can copy the settings you made for one note into several other notes, or copy the settings for several selected notes into a number of other notes (which makes it easy to recreate specific drum patterns, for example).

If Note Expression data is copied from several source notes to a number of destination notes, the following applies:

- If the number of the source and destination notes matches, the data of the first “source” note is pasted into the first “destination” note, the data of the second source note into the second destination note, etc.

- If the number of source notes is smaller than the number of destination notes, the source note data will be pasted repeatedly into the destination notes in the order in which they appear.

  When you copy the data from two source notes into four destination notes, for example, the first destination note gets the Note Expression data from the first source note, the second destination note the data of the second source note, the third destination note the data of the first source note and the fourth destination note the data of the second source note.

Deleting Note Expression data

To delete all or the selected Note Expression data, use the Delete command on the Edit menu or press [Backspace].
Moving Note Expression data

- To move all or the selected data of the active parameter, click with the Object Selection tool in the editor (not in the stretch area at the bottom of the window) and drag.

  You can restrict the direction to vertical or horizontal by pressing [Ctrl]/[Command] while dragging. When you hold down [Alt]/[Option] while dragging, the data is copied instead.

Fixed values

- To enter or edit a fixed value (i.e. a straight line), activate “One-Shot Mode” mode by clicking the button in the upper left corner of the window and click with the Draw tool anywhere in the editor to set the value.

  Note that some VST 3 parameters are one-shot only. For these, this mode is automatically activated.

The snap controls

The horizontal snap button in the upper right corner of the editor corresponds to the Snap button in the Project window.

1) Vertical snap (best suited for the Tuning parameter)
2) Horizontal Snap

The Vertical Snap button in the middle of the left border of the editor is especially useful for the Tuning parameter. It allows you to enter the pitch in semitone steps instead of as a continuous curve. This way, it is much easier to create fast pitch modulations.

- To temporarily switch to vertical snapping while editing, hold down [Shift].

RELATED LINKS
Snap Function on page 62
Modifying the data using the smart controls

The editor offers various modes for editing the Note Expression data. Most editing modes are activated by clicking the various smart controls, situated on the editor frame.

1) Smart controls

Which editing is performed is reflected by the shape of the mouse pointer. The following modes are available:

<table>
<thead>
<tr>
<th>Editing mode</th>
<th>To activate this mode…</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Move Vertically</td>
<td>Click in an empty area on the upper border of the editor.</td>
<td>This mode allows you to move the entire curve up or down, which is useful to boost or attenuate a curve.</td>
</tr>
<tr>
<td>Scale Vertically</td>
<td>Click the smart control in the middle of the upper border of the editor.</td>
<td>Use this mode to relatively scale the curve, i.e. to raise or lower the values in percent (not by absolute amounts).</td>
</tr>
<tr>
<td>Tilt the left/right part of the curve</td>
<td>Click the smart control in the upper left/right corner of the editor.</td>
<td>These modes allow you to tilt the left or the right part of the curve, respectively. This is useful if the curve form is exactly the way you want it, but the start or end needs to be boosted or attenuated a bit.</td>
</tr>
<tr>
<td>Compress the left/right part of the curve</td>
<td>[Alt]/[Option]-click the smart control in the upper left/right corner of the editor.</td>
<td>These modes allow you to compress the left or the right part of the curve. You can create a vibrato using the line tool in sinus mode, for example, and then compress its start and end to get a more natural effect.</td>
</tr>
</tbody>
</table>
Editing the release phase of a note

Sometimes it can be necessary to edit the release phase of a note, e.g. to work on the tail of a note which is still sounding after the note-off message was sent. These settings are made in the release section of the editor. To add a release phase, click and drag the release length handle in the lower right corner of the editor.

<table>
<thead>
<tr>
<th>Editing mode</th>
<th>To activate this mode…</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Scale Around Absolute Center</td>
<td>Click the smart control in the middle of the right border of the editor.</td>
<td>This mode allows you to scale the curve around the absolute center, i.e. horizontally around the center of the editor. This is useful for parameters which contain a center value or position, such as Pitchbend or panorama.</td>
</tr>
<tr>
<td>Scale Around Relative Center</td>
<td>[Alt]/[Option]-click the smart control in the middle of the right border of the editor.</td>
<td>This mode allows you to scale the curve relative to its center. This can be used to boost or reduce vibrato, for example.</td>
</tr>
<tr>
<td>Stretch</td>
<td>Click and drag in the lower part of the editor.</td>
<td>This allows you to stretch all or the selected Note Expression data. You can apply the stretching to all visible curves at the same time by keeping [Shift] pressed while dragging.</td>
</tr>
</tbody>
</table>

1) Note
2) Release phase
3) Release length handle

When Note Expression data are displayed in the Key Editor, the release phase of a note is also shown.
Setting the length of the release phase

To determine the length of the release phase, drag the release length handle or enter the value manually on the info line. You can also modify the release length after having edited or recorded controller data. Only the controllers within the specified length will be heard during playback.

**NOTE**

When you have opened the editor for several notes and hold down [Alt]/[Option] while setting the release length for one note, the release phase of all the notes will be changed accordingly, i.e. they will all end at the same time position.

Adding controllers in the release phase

You can add controllers in the release phase by overdubbing or by manually entering Note Expression data in the editor. When you are overdubbing Note Expression data, the length of the existing release phase will be used to associate newly recorded data to the notes. When the sustain pedal of your external device is held during recording, the notes automatically get a corresponding release phase.

Editing multiple notes simultaneously

When you have opened the editor for several notes, any editing (e.g. entering Note Expression data, applying time stretch or modifying the length of the release phase) affects all the notes that are present at the time position where you perform the editing.

Note Expression and MIDI

Making global settings

In the Note Expression MIDI Setup dialog, you can make some global settings for the use of the Note Expression functionality with MIDI. In this dialog, you can specify exactly which MIDI controllers will be used when recording Note Expression data, for example.

**PROCEDURE**

1. On the MIDI menu, open the Note Expression submenu and select “Note Expression MIDI Setup…”.
   The Note Expression MIDI Setup dialog opens.
2. When you have made the desired settings, click OK to close the dialog.
   The settings you made in the Note Expression MIDI Setup dialog will be used every time that you use the “Convert to Note Expression” function or record MIDI controllers as Note Expression data.
The dialog contains the following options:

**Controller**

Activate this option if you want to use MIDI controllers when working with Note Expression. In the table below, activate the MIDI controllers you want to use and deactivate the MIDI controllers that should be disregarded in the Note Expression context.

If MIDI controller data for a deactivated controller is received in Cubase, it will end up on the controller lane.

**Pitchbend**

Activate this option if you want incoming Pitchbend data to be used when working with Note Expression.

**Aftertouch**

Activate this option if you want incoming Aftertouch data to be used when working with Note Expression.
Poly Pressure

Activate this option if you want Poly Pressure data to be used when working with Note Expression.

Controller Catch Range

This allows you to associate controllers with a note, although they were sent slightly before the note-on message. Specify the number of ticks in the value field. For example, this might be necessary when working with some electronic drums for which the drum head position message is sent before the note.

Recording MIDI controllers as Note Expression data

To record Note Expression data using standard MIDI controller messages, activate the “MIDI as Note Expression” button on the Note Expression Inspector tab and enter the notes and controllers using your MIDI device. Afterwards, you can copy, paste and move the notes and the associated controller data will follow.

However, you should not shift individual notes from a chord, because this leads to conflicting controller messages. One way to avoid such conflicts is to record MIDI controllers as Note Expression data for monophonic performances only. Another option is to use a MIDI track set to “Any” channel and to split polyphony to separate channels. This is useful when working with guitar-to-MIDI controllers, where each string sends on a separate MIDI channel.

NOTE

When recording MIDI controllers as Note Expression data, keep in mind that this only works within the limits of standard MIDI controllers. With the exception of Poly Pressure, all MIDI controllers are channel-specific messages and therefore not available for notes.

IMPORTANT

When you are editing the MIDI notes after recording them, it might be necessary to consolidate the controller data.

Converting MIDI Controllers into Note Expression data

You can also convert the MIDI controller data on the controller lanes into Note Expression data.

PROCEDURE

1. Open the MIDI part in the Key Editor.
2. Make sure that the MIDI controllers to be recorded are activated in the “Note Expression MIDI Setup” dialog.
3. On the MIDI menu, open the Note Expression submenu and select “Convert to Note Expression”.

The MIDI data of the types you specified in the Note Expression MIDI Setup dialog is converted from controller lane data into Note Expression data, leaving the corresponding controller lanes empty.

RESULT

During this process, the program searches for notes that are sounding at the same time as the controllers and if several notes are playing at the same time, the same Note Expression parameters will be attributed to them, with the same values.

NOTE

When converting MIDI controllers into Note Expression data, release phases are automatically created where necessary, so that no controller data is lost during this process.

IMPORTANT

When you are editing the MIDI notes after the conversion, it might be necessary to consolidate the controller data.

RELATED LINKS

Editing the release phase of a note on page 807

Consolidating MIDI overlaps

It can be problematic to convert regular MIDI controllers into Note Expression data or to edit MIDI controllers which have been recorded as Note Expression data. For example, when you move notes so that they overlap other notes containing the same controllers (e.g. by moving or quantizing), these controllers are conflicting. This might cause trouble, especially for connected MIDI devices.

You can eliminate such controller conflicts using the “Consolidate Note Expression Overlaps” command on the Note Expression submenu of the MIDI menu. When you select this command, the following happens:

- If notes overlap that contain data for the same controller, the controller values of the second note are used from the beginning of the overlap.

- If a note is moved so that it is positioned entirely within a longer note and if these notes contain controller data for the same controller, the controller values of the longer note are used until the encompassed note starts. The controllers for the “embedded” shorter note are used for the entire length of that note. At the end of the shorter note, the controllers of the longer note are used again.
Distributing notes to different channels

If you do not have a VST 3 instrument, but still want to use the Note Expression functions, proceed as follows:

PROCEDURE
1. Add a multi-timbral instrument, open its control panel, and assign the same sound to different channels.
2. In the Inspector for the corresponding MIDI track, make sure the MIDI output pop-up menu is set to “Any”.
3. Enable the “MIDI as Note Expression” button and record or enter MIDI notes with expression as needed.
4. On the MIDI menu, open the Note Expression submenu and select “Distribute Notes to MIDI Channels”.
   This will distribute the MIDI notes to different channels (starting at channel 1).
5. Edit Note Expression for each note independently without controller conflicts.

Dissolving Note Expression data

- To convert Note Expression data into MIDI controller data on controller lanes, select the “Dissolve Note Expression” option from the Note Expression submenu on the MIDI menu.
  Note that this applies only to Note Expression data that consists only of MIDI controllers (i.e. not the VST 3 controller data).

Removing all Note Expression data

- To delete all the Note Expression data for the current selection, open the MIDI menu and, on the Note Expression submenu, select “Remove Note Expression”.

Trimming Note Expression data

When you reduce the release length of a note after entering Note Expression data for the release phase, some of the data ends up behind the release phase, thereby becoming unused.

- To keep only those Note Expression events that are actually used, select the notes and select “Trim Note Expression to Note Length” from the Note Expression submenu on the MIDI menu.
  This will delete any Note Expression data present after the end of the release phase for the notes.
HALion Sonic SE

HALion Sonic SE is a VST 3-compatible VST instrument. For use with Note Expression, it offers the VST 3 parameters “Tuning” (Pitch), “Volume”, and “Pan”. HALion Sonic SE comes with several presets (with the file name extension “*.NoteExp”) that can be used with Note Expression. Use them to get a quick overview of the possibilities HALion Sonic SE offers when working with Note Expression.

For detailed information about HALion Sonic SE and its parameters, refer to the separate PDF document HALion Sonic SE.

NOTE
You can also open the Project Browser to have all the Note Expression data shown in a list.

RELATED LINKS
Project Browser (Cubase Pro only) on page 926
Chord Functions

The chord functions provide you with many possibilities for working with chords. The chord functions allow you to:

- Build chord progressions by adding chord events to the chord track.
- Convert chord events to MIDI.
- Use the chord track to control audio playback (Cubase Pro only) or MIDI playback.
- Use the chord track voicing to change the pitches of your MIDI.
- Extract chord events from MIDI data to get an overview of the harmonic structure of a MIDI file.
- Record chord events with a MIDI keyboard.

Related links
Chord Editing Section on page 711

Chord Track

The chord track allows you to add chord events and scale events.

Related links
Scale Events on page 824
Chord Events on page 815
Adding the Chord Track

PROCEDURE

- Select **Project > Add Track > Chord**.

RESULT

The chord track is added to your project.

Chord Events

Chord events are representations of chords that control or transpose playback on MIDI, instrument, and audio tracks (Cubase Pro only).

Chord events alter the pitches of MIDI notes and VariAudio segments (Cubase Pro only), if their tracks are set up to follow the chord track.

Chord events have a specific start position. Their end, however, is determined by the start of the next chord event. They can have a root note, a type, a tension, and a bass note:

1) Root note
2) Type
3) Tension
4) Bass note

RELATED LINKS

- Controlling MIDI or Audio Playback using the Chord Track on page 829
Chord Editor

The **Chord Editor** allows you to define or change chord events, and to add new chord events.

- To open the **Chord Editor**, double-click a chord event.

1) **Go to Previous/Next Chord**  
   Allow you to select the previous/next chord on the chord track for editing.

2) **Add Chord**  
   Adds a new undefined chord event on the chord track.

   **NOTE**  
   This works only if the last chord event on the chord track is selected.

3) **Chord definition buttons**  
   Activate these buttons to define a root note, a chord type, a tension, and a bass note for your chord event.

   **NOTE**  
   If you do not select a separate bass note, the setting is linked to the root note, so that no extra bass note is heard.

4) **Keyboard display**  
   Shows the notes of the chord event, considering the current voicing settings.

5) **Define Chord by Text Input**  
   Allows you to define a chord using the computer keyboard.

6) **Activate MIDI Input**  
   Allows you to define a chord by playing a chord on your MIDI keyboard. If the chord is recognized, it is reflected by the chord buttons and the keyboard display.
Adding Chord Events

**PREREQUISITE**
Add the chord track.

**PROCEDURE**
1. Select the **Draw** tool and click in the chord track. An undefined chord event named X is added.
2. Select the **Object Selection** tool and double-click the chord event.
3. In the **Editor**, select a root note.
4. Optional: Select a chord type, tension, and bass note.
5. Do one of the following:
   - To close the **Editor**, click anywhere outside the **Editor**.
   - To add a new undefined chord event, click **Add Chord**.

**RELATED LINKS**
*Adding the Chord Track on page 815*

Defining Chords By Text Input

In the chord **Editor**, you can use the text input field to define a chord with the computer keyboard.

**PROCEDURE**
1. Double-click a chord event to open the chord **Editor**.
2. Click in the text input field at the bottom of the **Editor**.
3. Enter a chord by performing the following actions:
   - Define a root note, for example, C, D, E.
   - Define accidentals, for example, # or b.
   - Define the chord type, for example maj, min, dim, sus, or aug.
   - Define a chord extension, for example 7, 9, or 13.

**NOTE**
If you have activated **Solfège** in the **Note Name** pop-up menu (File > Preferences > Event Display > Chords), you can also enter chords in this format. You must capitalize the first letter and write “Re” instead of “re”, for example. Otherwise, the chord is not recognized.

4. Press [Tab] to add a new chord and define it.
Chord Assistant

The **Chord Assistant** allows you to use a chord as a starting point to get suggestions for the next chord.

- To open the **Chord Assistant**, in the **Chord Editor**, click **Chord Assistant**.

The **Chord Assistant** has the following modes:

- List
- Proximity
- Circle of Fifths
Chord Assistant – List (Cubase Pro only)

The List mode of the Chord Assistant allows you to create harmonic chord progressions based on harmonic rules that can be more or less complex.

1) Go to Previous/Next Chord
   Allow you to select the previous/next chord on the chord track for editing.

2) Add Chord
   Adds a new undefined chord event on the chord track.
   
   **NOTE**
   This works only if the last chord event on the chord track is selected.

3) Suggestions
   Shows suggestions for the next chord. Click a chord suggestion to select it.

4) Complexity Filter
   Allows you to increase the complexity and thus the number of suggestions. The higher the complexity, the more suggestions you get.

5) Gap Mode
   Activate this button to get suggestions for the chords in between two defined chords based on the previous and the next chord.
   Deactivate this button to get suggestions for the next chord based on the previous chord.
   
   **NOTE**
   For this to work you must select all undefined chords in between two defined chords.
6) **Algorithm Mode**
Select **Cadence** to build up a chord progression based on cadences. Select **Common Notes** to build up a progression by specifying how many common notes the chords should share.

7) **Cadence Type**

**NOTE**
This option is only available, if you selected **Cadence** as Algorithm Mode.

Allows you to select a cadence type for the suggestions. This way, only the chords with specific harmonic functions are suggested.

8) **Chord Assistant tabs**
Click the tabs to open one of the chord assistant modes.

**Chord Assistant – Proximity (Cubase Pro only)**

The **Proximity** mode of the **Chord Assistant** takes a set of harmonic rules into account to offer suggestions that match the origin chord.

If you open the **Chord Assistant** for a chord event, the previous event is set as origin chord. This is shown in the bottom center of the **Chord Assistant**. The farther away a suggestion is situated from the origin chord in the graphic, the more complex the suggestion. The suggested chords are triads or 4-note chords.

- To assign a chord to the selected chord event and play it, click it.
  The last three suggested chords that you clicked are shown with a highlighted frame.

- To use a chord as origin for further suggestions, right-click the suggested chord and select **Use as Origin**.

**NOTE**
- If you move the mouse pointer over one of the suggestions in the **Chord Assistant**, a tooltip with suggestions for progressions is shown.
The **Proximity** mode underlies the same rules as the **List** mode.

### Adding Chord Events Based on Suggestions

If you do not know what your chord progression should look like, you can use the **Chord Assistant** to get suggestions for the following chords.

**PREREQUISITE**

Add a chord event on the chord track.

**PROCEDURE**

1. Double-click the chord event
2. Click **Chord Assistant**.
3. Click **Add Chord**.
4. Do one of the following:
   - To display the suggestions in a list, click the **List** tab.
   - To display the suggestions in a graphic, click the **Proximity** tab.
5. Click a suggestion to select it.
RESULT

The suggested chord is added as chord event to the chord track. Repeat the steps above to create as many chord events as required by your harmonic structure.

Chord Assistant – Circle of Fifths

The Circle of Fifths mode of the Chord Assistant shows the chords in an interactive visualization of the circle of fifths.

The origin chord that defines the current key is shown in the center of the Chord Assistant and is marked as tonic (I).

The outer circle shows the twelve major chords ordered in intervals of fifths.

The inner circle displays the corresponding parallel minor chords.

The roman numerals mark the chords of the current key with their scale degree. You can use these chords to create typical chord progressions or you can use the other chords for more creative results.

- To play a chord and assign it to the selected chord event, click it. The last three chords that you clicked are shown with a highlighted frame.
- To define a new key, right-click the chord in the Chord Assistant and select Use as Origin, or use the Rotate Left/Rotate Right controls.
- To select the parallel minor chord and define it as key, click Major/Minor.
Auditioning Chord Events

To hear the chord events on the chord track, you must connect the chord track to the output of an instrument or a MIDI track.

**PREREQUISITE**

Add the chord track and some chord events.

**PROCEDURE**

1. Do one of the following:
   - To add an instrument track, select `Project > Add Track > Instrument`.
   - To add a MIDI track, select `Project > Add Track > MIDI`.
2. Assign a VST instrument to your instrument or MIDI track and select a sound.
3. In the chord track Inspector, activate *Acoustic Feedback*.
4. From the `Select Track for Auditioning` pop-up menu, select the track that you want to use for auditioning.

**RESULT**

The chord events on the chord track now trigger the sound of the assigned instrument on the MIDI or instrument track.

Changing How Chord Events Are Displayed

You can change how chord events are displayed. This is useful, if chord events overlap each other at low zoom levels, or if you do not like the font type.

**PROCEDURE**

1. On the chord track, activate *Resolve Display Conflicts*.
2. Select `File > Preferences > Event Display > Chords` and set up the chord font.
   Here you can also determine the note name and naming format.
Scale Events

Scale events inform you which chord events fit in a specific sequence of notes that belong to a specific root note.

Cubase automatically creates scale events for your chord events.

- To show the scale events, activate Show Scales on the chord track.

- To audition the notes that belong to a scale event, click it.

However, you can also add and edit scale events manually.

Scale events have a specific start position. Their end is determined by the start of the next scale event.

Editing Scale Events

PREREQUISITE

Add the chord track and chord events. Deactivate Automatic Scales in the chord track Inspector.

PROCEDURE

1. On the chord track, activate Show Scales.
   The scale lane is displayed.

2. Select the chord event.
   A scale event is shown on the scale lane.

3. Do one of the following:
   - Click the first scale event on the chord track, and on the info line, select a Root Key and Type.
   - Double-click the scale event, and in the keyboard that appears, select a Root Key and Type of the scale.

The keys that correspond to the scale are highlighted.
Voicings

Voicings determine how chord events are set up. They define the vertical spacing and order of the pitches in a chord, but also the instrumentation and genre of a musical piece.

For example, a C chord can be spread over a wide range of pitches, and a pianist will choose different notes than a guitarist. The pianist may also play completely different pitches for different musical genres.

- You can set up voicing for the entire chord track in the chord track Inspector.
- You can set up voicings for individual chord events on the Voicing pop-up menu on the info line.

**NOTE**
If Adaptive Voicings is activated in the chord track Inspector, you can only change the voicings for the first chord event on the info line.

Setting up Voicings

To set up voicings for the entire chord track, you can use the chord track Inspector.

1) **Voicing library**
   Allows you to select Guitar, Piano, or Basic as a voicing library.

2) **Voicing library subset**
   **NOTE**
   This is only available, if Guitar or Piano is set as voicing library.

   Allows you to select a preset voicing library subset.

3) **Configure voicing parameters**
   Allows you to configure your own voicing parameters for a specific voicing scheme.
4) **Adaptive Voicings**
   Activate this to let Cubase set the voicings automatically. This prevents the individual voices from jumping too much.

5) **Automatic Scales**
   Activate this to let Cubase set the scales automatically.

6) **Mapping Offset**
   If you enter a negative number of ticks, the chord events will affect the MIDI notes that have been triggered too early.

### Configure Voicing Parameters

If you click **Configure Voicing Parameters** in the **Voicings** section of the **Inspector**, you can configure your own voicing parameters for a specific voicing scheme.

**NOTE**

The **Start Voicing** section for piano, guitar, and basic voicings lets you select a start voicing. This is only available for MIDI, instrument, and audio tracks (Cubase Pro only), but not for the chord track, and only if you select **Voicings** in the **Follow Chord Track** pop-up menu.

In the **Style** section for **Piano** voicings, you can set up the following parameters:

**Triads**

  - Sets a triad. Chords with more than three notes are not changed.

**Triads with maj9**

  - Sets a triad with a major ninth, but without root note. Chords with more than three notes are not changed.

**Triads with maj9 and min9**

  - Sets a triad with a major and a minor ninth, but without root note. Chords with more than three notes are not changed.

**4-note chords**

  - Sets a default 4-note chord without root note. Chords with less than three notes are not changed.

**4-note chords (Open Jazz)**

  - Sets a 4-note chord without root note and without fifth. Chords with less than three notes are not changed.

**5-note chords**

  - Sets a 5-note chord with a ninth. Chords with less than four notes are not changed.
In the **Options** section for **Piano** voicings, you can set up the following parameters:

**Add Root Note**
- Adds a root note.

**Duplicate Root**
- Duplicates the root note.

**Fatten up**
- Duplicates the tenor.

In the **Voicing Range** section for **Piano** voicings, you can set up the following parameters:

**Lowest Root Note**
- Sets the limit for the lowest root note.

**Lowest Note**
- Sets the limit for the lowest note, except the root note.

**Highest Note**
- Sets the limit for the highest note, except the root note.

In the **Style** section for **Guitar** voicings, you can set up the following parameters:

**Triads**
- Sets a triad with four, five or six voices.

**4-Note Chords**
- Sets a 4-note chord with four, five or six voices without tensions.

**3-String Triads**
- Sets a three string triad.

**Modern Jazz**
- Sets 4-note, 5-note, and 6-note chords, partly without root note, but with tensions.

For **Basic** voicings only **Octave Offset from C3** is available. This allows you to determine an offset value for the default octave range.
Converting Chord Events to MIDI

You can convert chord events to MIDI for further editing or for printing a lead sheet in the Score Editor.

**PROCEDURE**

1. **Add an instrument track or a MIDI track.**
   - To add an instrument track, select *Project > Add Track > Instrument.*
   - To add a MIDI track, select *Project > Add Track > MIDI.*

2. **Do one of the following:**
   - To convert all chord events to MIDI, select *Project > Chord Track > Chords to MIDI.*
   - To convert only selected chords to MIDI, select the chord events and drag them to the MIDI or instrument track.

**RESULT**

A new MIDI part is created, containing the chords as MIDI events.

Assigning Chord Events to MIDI Effects or VST Instruments

**PREREQUISITE**

Create a chord progression on the chord track and add a MIDI or instrument track to your project.

**PROCEDURE**

1. In the **Inspector** for the MIDI or instrument track, open the **MIDI Inserts** section.

2. **Click an insert slot and select Chorder from the Effect Type pop-up menu.**
   The Chorder effect is activated, and its control panel opens.

3. **On the chord track, select the chord events and drag them to the Chorder control panel.**
   The drop position determines the velocity area and the position of the first chord event. All subsequent chord events are mapped chromatically. Chord events with more than one occurrence are only assigned once.
   To remap the chords, hold down [Alt]/[Option] and drag again.

4. **On your MIDI keyboard, hit the corresponding keys to play back the chords.**
Assigning Chord Events to HALion Sonic SE Pads

PREREQUISITE
Create a chord progression on the chord track and add an instrument track with HALion Sonic SE as VST instrument to your project.

PROCEDURE
1. On the chord track, select the chord events and drag them to the HALion Sonic SE pads.
   The first chord event is mapped to the pad where you dropped it, and all subsequent chord events are mapped to the following pads.
2. Click the corresponding pads on the HALion Sonic SE keyboard to trigger the chords.

Controlling MIDI or Audio Playback using the Chord Track

You can use the chord track to control audio playback (Cubase Pro only) or MIDI playback.

Using Live Transform

Live Transform allows you to transpose the MIDI input live to a chord progression on the chord track. This way, you do not have to worry about what key you hit on your MIDI keyboard as the MIDI input is transposed to match chords or scales on your chord track in realtime.

PROCEDURE
1. Create a MIDI or an instrument track and activate Record Enable.
2. In the Inspector, open the Chords section.
3. Open the Live Transform pop-up menu and do one of the following:
   • To map the MIDI input to chord events, select Chords.
   • To map the MIDI input to scale events, select Scales.
4. Hit some keys on your MIDI keyboard or on the Virtual Keyboard.

RESULT
Any key that you hit is mapped in realtime to the chord or scale events on the chord track.
Using Follow Chord Track

This allows you to match an existing recording to a chord progression on the chord track.

PROCEDURE

1. Select the track that you want to match to the chord track.
2. In the Inspector, click Chords.
3. Open the Follow Chord Track pop-up menu and select a mode.

   NOTE
   If this is the first time that you open this pop-up menu for the track, the Follow Chord Track dialog opens.

4. In the Follow Chord Track dialog, make your settings.
5. Click OK.

RESULT

The events on your track now match the chord progression on the chord track.

NOTE

If you matched your MIDI track to the chord track, some of the original MIDI notes may be muted. To hide these notes in the editors, select File > Preferences > Editing > Chords and activate Hide muted Notes in Editors.

RELATED LINKS

Follow Chord Track Dialog on page 831
Follow Chord Track Modes on page 830

Follow Chord Track Modes

This section of the Inspector allows you to determine how your track follows the chord track.

The following options are available on the Follow Chord Track pop-up menu:

Off

Follow Chord Track is deactivated.
Chords & Scales
This maintains the intervals of the original chord or scale as far as possible.

Chords
This transposes MIDI notes to match the key note and maps them to the current chord.

Scales
This transposes MIDI notes to match the current scale. This allows a bigger variety of notes and a more natural performance.

Root Notes
This transposes MIDI notes to match the root note of the chord event. The effect corresponds to using the transpose track. This option is suitable for bass tracks.

Voicings
This transposes MIDI notes to match the voices of the selected voicing library.

Single Voice
Maps MIDI notes and VariAudio segments (Cubase Pro only) to the notes of a single voice (soprano, tenor, bass, etc.) of the voicing. Use the pop-up menu below to select the desired voice.

**NOTE**
If you apply this mode to a selection of tracks that contain separate voices, you can set up one track as master and the others as voicing slaves. This way, you can change the voicing of the master, and the slaves will follow automatically.

**RELATED LINKS**
Assigning Voices to Notes on page 833

**Follow Chord Track Dialog**

This dialog opens the first time that you select an option on from the Follow Chord Track pop-up menu on the Chords section of the Inspector.
Chord Functions
Controlling MIDI or Audio Playback using the Chord Track

Follow Directly
Activate this if your VariAudio segments (Cubase Pro only) or MIDI notes are already in accordance with the chord track. This is the case if you extracted your chords from the MIDI events on the track by selecting Project > Chord Track > Create Chord Symbols, for example.

Synchronize Track Data with Chord Track First
Activate Analyze Chords if the track data has nothing in common with the chord events. This analyzes the MIDI events and matches the found chords to the chord track. This is only available for MIDI.

Activate Apply a Known Chord if the track data has nothing in common with the chord events and if there are no chord changes. Specify Root Note and Chord Type of your events.

Using Map to Chord Track
This allows you to match individual parts or events to a chord progression on the chord track.

PROCEDURE
1. In the Project window, select the events or parts that you want to map to the chord track.
2. Select Project > Chord Track > Map to Chord Track.
   The Map to Chord Track dialog opens.
3. From the Mapping Mode pop-up menu, select a mapping mode.
   
   NOTE
   If you select Voicings and no voices are found, Auto mode is used instead.

4. Click OK.

RESULT
The chords and scales of each event or part are analyzed and used for mapping. If no chords are found, Cubase assumes that the performance is in “C”. The available mapping modes and voicings correspond to the Follow Chord Track parameters in the Chords section of the Inspector.

RELATED LINKS
Follow Chord Track Modes on page 830
Assigning Voices to Notes

You can transpose MIDI notes to match the voices of a selected voicing library.

**PROCEDURE**

- Select Project > Chord Track > Assign Voices to Notes.

**RESULT**

The note pitches now match the voicing of the chord track and you can still edit the MIDI notes. If you now select a note in the **Key Editor**, you see that **Voice** in the info line is assigned.

---

Extracting Chord Events from MIDI

You can extract chords from MIDI notes, parts, or tracks. This is useful, if you have a MIDI file and want to show its harmonic structure, and use this file as starting point for further experimenting.

**PREREQUISITE**

Add the chord track and create MIDI notes that can be interpreted as chords. Drums, monophonic bass, or lead tracks are not suitable.

**PROCEDURE**

1. In the **Project** window, select a part or one or several MIDI tracks.
   
   You can also select the MIDI tracks, parts, or notes that you want to extract in the **Key Editor**, **Score Editor**, or **In-Place Editor**.
2. Select **Project > Chord Track > Create Chord Symbols**. The **Create Chord Symbols** dialog opens.

3. Make your settings and click **OK**.

**RESULT**

The chord events are added on the chord track.

**NOTE**

*Cubase Pro only:* You can now open the **Chord Assistant** to create variations.

**RELATED LINKS**

Create Chord Symbols Dialog on page 834

---

**Create Chord Symbols Dialog**

This dialog allows you to determine, which MIDI data should be taken into account when extracting chord events from MIDI.

![Create Chord Symbols Dialog](image)

**Include Bass Notes**

Activate this, if you want your chord events to contain a bass note.

**Include Tensions**

Activate this, if you want your chord events to contain tensions.

**Detect Arpeggios**

Activate this, if you want your chord events to contain arpeggiated chords, that is, chords whose notes are played one after another instead of all at once.

**Interpret Sustain Pedal**

Activate this, if you want your chord events to contain sustain pedal chords, that is, notes that are played while the sustain pedal is held.

**Ignore Notes Shorter Than**

Allows you to determine the minimum length of the MIDI events that are taken into account.
Recording Chord Events with a MIDI Keyboard

You can use a MIDI keyboard to record chord events on the chord track.

PREREQUISITE

Your project contains an instrument track with Record Enable or Monitor activated.

PROCEDURE

1. On the chord track, activate Record Enable.
2. On the Transport Panel, activate Record.
3. Play some chords on your MIDI keyboard.

RESULT

All recognized chords are recorded as chord events on the chord track.

NOTE

The chord track uses its own voicing settings. The recorded chord events may therefore sound different.

RELATED LINKS

Creating Events from Chord Pads on page 858
Chord Pads

Chord pads allow you to play with chords, and to change their voicings and tensions. In terms of harmonies and rhythms, they allow for a more playful and spontaneous approach to composition than the chord track functions.

You can:

• Perform with chords in realtime via a MIDI keyboard.
• Record your performance as MIDI events on a MIDI or instrument track or even on the chord track.

**NOTE**

We assume that you have a MIDI keyboard connected and set up.

**RELATED LINKS**

*Voicings on page 825*

---

**Chord Pads Zone**

The chord pads zone at the bottom of the **Project** window holds all functions that you need to work with chord pads.

To open the chord pads zone do one of the following:

• Select **Project > Chord Pads**
• Select a MIDI or instrument track, and in the Inspector, open the **Chords** section and activate **Show/Hide Chord Pads Zone**.
The chord pads zone holds the following controls:

1) **Close Chord Pads Zone**
   Closes the chord pads zone.

2) **Current Player**
   Shows the current player and opens a menu where you can select another player.

3) **Chord Pad**
   Each chord pad can contain a chord symbol. To change it, click the **Open Editor** control on the left edge of the chord pad.

4) **Keyboard**
   Shows which keys are played when you trigger a chord pad. To zoom the keyboard, click a key and drag up or down. To scroll the keyboard, click and drag to the left or to the right.

5) **Trigger Keys**
   The keys highlighted in blue on the keyboard correspond to the keys on your MIDI keyboard that trigger the chord pads. You can define the trigger keys on the **Remote Control** page of the chord pad **Settings**.

6) **Remote Range for Voicings/Tensions/Transpose**
   The keys highlighted in green on the keyboard display correspond to the keys on your MIDI keyboard that change the voicings, tensions, and transpose settings of the pads. You can define these remote keys on the **Remote Control** page of the chord pad **Settings**.

7) **Activate/Deactivate Remote Control for Chord Pads**
   Allows you to activate/deactivate the chord pads zone. If you deactivate remote control for chord pads, your MIDI keyboard no longer triggers the pads.

8) **Functions Menu**
   Opens a menu with specific functions and settings for the chord pads.

9) **Chord Pads Presets**
   Allows you to save and load presets for chord pads and players.
10) **Show/Hide Chord Assistant**
Shows/Hide the **Chord Assistant** that shows suggestions of chords that match the chord that you specified as the origin chord.

11) **Show/Hide Settings**
Shows/Hides the chord settings, where you can configure different players, the pad layout, and the remote assignment.

**RELATED LINKS**
- Chord Pad Settings – Remote Control on page 850
- Players and Voicings on page 854

## Chord Pad Controls

The chord pad controls allow you to edit the chord pads.

- To show the chord pad controls, move the mouse over a chord pad.

![Chord Pad Controls Diagram](image)

1) **Voicing Indicators**
Shows the voicing used for the chord. Voicing indicators can only be displayed, if the horizontal zoom level for the chord pads is high enough.

2) **Open Editor**
Opens the chord **Editor** that allows you to select a chord for the chord pad.

3) **Adaptive Voicing Reference/Use X as Origin for Chord Assistant**
When the active chord pad is set as adaptive voicing reference, its borders are shown in light green. All other chord pads will follow its voicing and are set in a way that they do not get too far away from the reference.

   If the chord pad is set as origin for the **Chord Assistant**, its borders are shown in green. This chord pad is used as a basis for the suggestions in the **Chord Assistant** window.

4) **Assigned Chord**
Shows the chord symbol that is assigned to the chord pad. Each chord pad can contain one chord symbol. If the name of the assigned chord is too long to display it on the chord pad, it is underlined, and the full chord name is shown in a tooltip.
5) **AV (Adaptive Voicing)/L (Lock)**
By default, all chord pads follow the adaptive voicing. This is indicated by an AV symbol. If you change the voicing for a pad manually however, **Adaptive Voicing** is deactivated.

An L symbol indicates that the chord pad is locked for editing.

6) **Voicing**
Allows you to set another voicing for the chord pad.

7) **Tensions**
Allows you to add/remove tensions for the chord.

**Chord Pad Context Menu**

- **Use X as Origin for Chord Assistant**
  Sets the chord of the current pad as an origin chord for the Chord Assistant.

- **Assign Pad from MIDI Input**
  Allows you to assign a chord by pressing keys on your MIDI keyboard.

- **Lock**
  Allows you to lock a chord pad for editing.

- **Adaptive Voicing**
  Sets the current pad as adaptive voicing reference. If set, the automatic voicings for the following pads will be set in a way that they do not get too far away from the reference voicing. Only one pad can be set as adaptive voicing reference.

- **Adaptive Voicings Reference**
  Resets the adaptive voicing reference.

- **Unassign Pad**
  Removes the chord assignment from the current pad.
Functions Menu

- **Show Voicing Indicators**
  Allows you to activate/deactivate the voicing indicators that can be displayed at the bottom of each chord pad.

- **Assign Pads from Chord Track**
  Assigns the chord events from the chord track to the chord pads in the same order as they appear on the chord track. Chord events that have more than one occurrence are only assigned once.

- **Snap Playback to Musical Grid**
  Allows you to delay the playback of a triggered chord pad to the next defined musical position. This is useful, if you work with an arpeggiator or with the Pattern Player.

- **Transpose All Pads**
  Transposes all chord pads by a defined transpose value.

- **Lock All Pads**
  Locks all chord pads for editing.

- **Unlock All Pads**
  Unlocks all chord pads.

- **Unassign All Pads**
  Removes the chord assignment from all pads.
Preparations

Before you can start working with the chord pads, you must add a MIDI or an instrument track with an instrument loaded, and open the chord pads zone.

**PREREQUISITE**

You have installed and set up a MIDI keyboard.

**PROCEDURE**

1. Select **Project > Add Track > Instrument**.
2. In the **Add Instrument Track** dialog, select an instrument, and click **Add Track**.
   An instrument track with the selected instrument loaded is added to your project, and select a sound that is suited for chords.
3. On the instrument track, click **Record Enable**.
4. Select **Project > Chord Pads** to open the **Chord Pads Zone** at the bottom of the **Project** window.

**RESULT**

You can now click the chord pads or press some of the assigned keys on your MIDI keyboard to trigger the preassigned chords.

Chord Assistant

The **Chord Assistant** allows you to use a chord as a starting point for suggestions for the next chord. It assists you in finding the right chords for creating a chord progression for your song.

- Click **Show/Hide Chord Assistant** on the left side of the chord pads area to open the **Chord Assistant**.
The **Chord Assistant** has two modes:

- **Chord Assistant** – Proximity (Cubase Pro only)
- **Chord Assistant** – Circle of Fifths

You must define an origin chord as follows:

- Right-click the chord pad with the chord you want to use as origin and select **Use X as Origin for Chord Assistant**.

The **Chord Assistant** shows suggestions for follow-on chords that you can assign to the chord pads.

### Chord Assistant – Proximity Mode (Cubase Pro only)

The **Proximity** mode of the **Chord Assistant** uses a set of harmonic rules to offer suggestions that match the origin chord.

The origin chord in the bottom center of the **Chord Assistant** marks the tonal center. The farther away a chord suggestion is situated from this chord, the more complex the suggestion. The suggested chords are triads or 4-note chords.

- To play a suggested chord, click it.
  
  The last three suggested chords that you clicked are shown with a highlighted frame.

- To assign a suggestion to the next unassigned chord pad, right-click the suggested chord and select **Assign to Pad**.
  
  You can also drag the suggested chord and drop it on a chord pad.

- To assign a suggestion to the next unassigned chord pad and use this chord as origin for further suggestions, right-click the suggested chord and select **Assign to Pad and Use as Origin**.

**NOTE**

The **Proximity** mode is a different representation of the list in the **Chord Assistant** for the chord track.
Chord Assistant – Circle of Fifths Mode

The Circle of Fifths mode of the Chord Assistant shows the chords in an interactive visualization of the circle of fifths.

The origin chord that defines the current key is shown in the center of the Chord Assistant. The tonic (I) of that key is displayed above the center. The outer circle shows the twelve major chords ordered in intervals of fifths.

The inner circle displays the corresponding parallel minor chords.

The roman numerals mark the chords of the current key with their scale degree. You can use these chords to create typical chord progressions. However, you can also use the other chords for more creative results.

- To play a chord, click it.
  The last three chords that you clicked are shown with a highlighted frame.

- To assign a chord to the next unassigned chord pad, right-click the suggested chord and select Assign to Pad.
  You can also drag the suggested chord and drop it on a chord pad.

- To assign a suggestion to the next unassigned chord pad and use this chord as origin, right-click the chord and select Assign to Pad and Use as Origin.

**NOTE**

The Circle of Fifths is also available in the Chord Assistant for the chord track.

**RELATED LINKS**

Chord Assistant – List (Cubase Pro only) on page 819
Assigning Chords to Chord Pads

Some chords are preassigned to the chord pads. But you can also assign your own chords.

To assign chords to chord pads, you can use:

- The chord Editor
- The Chord Assistant – Proximity (Cubase Pro only)
- The Chord Assistant – Circle of Fifths
- Your MIDI keyboard
- The chord events from the chord track

You can overwrite the preassigned chords, or clear all chord pads first to start from scratch. Proceed as follows:

- To the left of the chord pads zone, open the Functions Menu and select Unassign All Pads.

Assigning Chords with the Chord Editor

If you know exactly which chord you want to assign to a specific chord pad, you can use the chord Editor.

**PROCEDURE**

1. Move the mouse pointer to the left edge of the chord pad, and click Open Editor.
2. In the chord Editor, use the chord definition buttons to define a root note, a chord type, a tension, and a bass note. The new chord is triggered automatically to give an acoustic feedback.

**RELATED LINKS**

Chord Editor on page 816
Assigning Chords with the Chord Assistant – Proximity Mode (Cubase Pro only)

If you have a chord that you want to use as a starting point to find follow-on chords, you can use the Chord Assistant – Proximity mode.

PROCEDURE

1. Right-click the chord pad that you want to use as a starting point and activate Use x as Origin for Chord Assistant.

The Chord Assistant opens, and the borders of the chord pad change their color to indicate that the assigned chord is now used as origin.

2. In the Chord Assistant, click the chord symbols to trigger corresponding chords.

The farther away the chord is from the origin chord that is regarded as the tonal center, the more complex the suggestion becomes.

3. To assign a chord, drag it from the Chord Assistant and drop it on a chord pad.

NOTE

If one of the next chord pads is free, you can also right-click the chord in the Chord Assistant and select Assign to Pad. This assigns the chord to the next free pad.

RELATED LINKS

Chord Assistant – List (Cubase Pro only) on page 819
Assigning Chords with the Chord Assistant – Circle of Fifths Mode

If you have a chord that you want to use as a starting point for a chord progression, but you do not know how to create such a progression, you can use the Chord Assistant – Circle of Fifths.

**PROCEDURE**

1. Right-click the chord pad that you want to use as a starting point and activate **Use x as Origin for Chord Assistant**.

   The Chord Assistant opens, and the borders of the chord pad change their color to indicate that the assigned chord is now used as origin.

   ![Chord Assistant Diagram](image)

   ![Chord Assistant Diagram](image)

2. Click **5th** to switch to the circle of fifths mode.

   The origin chord is displayed in the center, and the chords that belong to the scale are shown above it. The numerals indicate the scale degree of the chords. These help you to create chord progressions.

3. In the Chord Assistant, click the chord symbols to trigger the corresponding chords.

4. To assign a chord, drag it from the Chord Assistant and drop it on the chord pad.

**NOTE**

If one of the next chord pads is free, you can also right-click the chord in the Chord Assistant and select **Assign to Pad**. This assigns the chord to the next free pad.
Assigning Chords with the MIDI Keyboard

If you know which chord you want to assign to a specific chord pad, you can use a MIDI keyboard.

**PREREQUISITE**

You have selected a MIDI track or an instrument track.

**PROCEDURE**

1. Right-click the chord pad that you want to use for the new chord, and select *Assign Pad from MIDI Input*.
   The borders of the chord pad change their color to indicate that it is now ready for recording.

2. On your MIDI keyboard, press the keys for the chord that you want to assign.
   The chord and its voicing is assigned to the chord pad, and you hear an acoustic feedback of the chord.

   **NOTE**
   The assigned voicing can be changed by the *Adaptive Voicing* setting. Therefore, if you want to keep the voicing for that specific pad, right-click the chord pad and select *Lock* from the context menu.

**RELATED LINKS**

[Adaptive Voicing on page 854](#)

Assigning Chords from the Chord Track

You can assign the chord events from the chord track to the chord pads.

**PROCEDURE**

- To the left of the chord pads zone click the *Functions Menu* button, and select *Assign Pads from Chord Track*.
  If chords are already assigned to the chord pads, a warning message informs you that all previous assignments will be overwritten.

**RESULT**

The chord events are assigned to the chord pads in the same order as they appear on the chord track.

**NOTE**

Chord events that have more than one occurrence on the chord track are only assigned once.
Moving and Copying Chord Pads

You can swap the chord assignments between 2 pads or copy a specific chord and its settings from one pad to another.

- To swap the chord pad assignment between 2 pads, click a chord pad and drag it to another chord pad.
  While you drag, the border of the destination chord pad changes its color. When you drop the pad on another, the chord assignments are swapped.

- To copy the chord assignment of one chord pad to another pad, [Alt]/[Option]-click a chord pad and drag it to another chord pad.
  While you drag, the border of the destination chord pad changes its color. When you drop the pad on another, the first pad's assignment is copied to the destination chord pad.

**NOTE**

When you move or copy chord pads, the chord is moved or copied, and all its settings are, except for the Adaptive Voicings Reference.

Playing Back and Recording Chords

Playing Back Chord Pads with your MIDI Keyboard

**PREREQUISITE**

You have connected and set up a MIDI keyboard.

**PROCEDURE**

1. Select Project > Add Track > Instrument.
2. In the Add Instrument Track dialog, select a VST instrument.
3. Click Add Track.
   An instrument track with the selected VST instrument is added to your project.
4. On the instrument track, click Record Enable.
5. Select Project > Chord Pads to open the Chord Pads Zone at the bottom of the Project window.
6. Press some keys on your MIDI keyboard to trigger the chords that are preassigned to the chord pads.

**RELATED LINKS**

[Chord Pad Settings – Remote Control on page 850](#)
[Changing the Pads Remote Range on page 852](#)
Recording Chords on MIDI or Instrument Tracks

You can record the chords that are triggered through the chord pads on MIDI or instrument tracks. This way, you can play back and edit your performance at any time.

**PREREQUISITE**

You have connected and set up a MIDI keyboard, you have opened and set up the chord pads zone, and you have added an instrument or a MIDI track for which a VST instrument is loaded to your project.

**PROCEDURE**

1. On the instrument track, click **Record Enable**.
2. On the **Transport** panel, activate **Record**.
3. On your MIDI keyboard, press the keys that trigger the chord pads.

**NOTE**

Use the keys that are not assigned to play and record other chords.

**RESULT**

The triggered chords are recorded on the track. The note events are automatically assigned to different MIDI channels according to their pitches. Note events that correspond to the soprano voice are assigned to MIDI channel 1, alto is assigned to MIDI channel 2, and so on.

**AFTER COMPLETING THIS TASK**

You can now open the **Key Editor** and fine-tune your recorded MIDI parts using the chord editing functions, for example. You can also use **MIDI > Dissolve Part** to dissolve the recorded chords by pitches/channels.

Recording Chords on the Chord Track

You can record the triggered chords on the chord track. This way, you can easily create chord events for a lead sheet, for example.

**PREREQUISITE**

You have connected and set up a MIDI keyboard, you have opened and set up the chord pads zone, and you have added an instrument or a MIDI track for which a VST instrument is loaded.

**PROCEDURE**

1. On the instrument track, enable **Monitor**.
2. Select **Project > Add Track > Chord** to add the chord track.
3. In the Inspector for the chord track, click **Record Enable**.
4. On the **Transport** panel, activate **Record**.

849
5. On your MIDI keyboard, press the keys that trigger the chord pads.

**NOTE**
Use the keys that are not assigned to play and record other chords.

**RESULT**
The chord events are recorded on the chord track.

**NOTE**
The recorded chord events may sound different from the chord pad playback. This is because the voicing settings for the chord track differ from the chord pad voicings.

**RELATED LINKS**
Chord Functions on page 814
Voicings on page 825

---

**Chord Pad Settings – Remote Control**

On the **Remote Control** tab in the chord pad **Settings**, you can change the default remote control assignments.

- To the left of the chord pads zone, click **Show/Hide Settings** and activate the **Remote Control** tab.

1) **Show/Hide Settings**
   Opens the settings for the chord pads.

2) **Pads Remote Range**
   Allows you to set the start and end note for the remote range.

3) **Voicings/Tension/Transpose**
   Allows you to assign remote keys for changing the voicings, tension, and transposition settings of the last played chord pad. You can also assign continuous controllers to change all chord pads simultaneously.
4) **MIDI Learn**  
Activates/Deactivates the MIDI Learn function to assign MIDI input to the **Pads Remote Range** and to the parameters Voicings, Tensions, and Transpose.

5) **Activate**  
Activates/Deactivates the remote key assignment for the parameters Voicings, Tensions, and Transpose. If this is deactivated, only the remote key assignment for the **Pads Remote Range** is active.

6) **Latch Chords**  
Activate this if you want the chord pad to play back until it is triggered again.

**NOTE**  
If you use MIDI controllers that are already assigned to other remote control features, for example, the Track Quick Controls or the VST Quick Controls, all previous assignments are lost.

**RELATED LINKS**  
Pads Remote Range on page 851

---

**Pads Remote Range**

The **Pads Remote Range** is the range of remote keys that trigger the chords that are assigned to the chord pads. By default, the Range Start is set to C1 and the Range End to B1. This is indicated by the corresponding keys on the keyboard in the chord pads zone being highlighted. You can trigger the chords that are assigned to the chord pads by hitting the keys that correspond to this note range on your MIDI keyboard.

---

**Default Remote Assignment**

By default, the MIDI events C1 to B1 trigger the chords that are assigned to the chord pads. All keys that are not assigned for remote control, by default G#2 and further, can be used for regular playback.

You can change the voicing, tension or transposition of the triggered chord by enabling **Activate** in the lower part of the **Remote Control** tab and using the following default remote notes:

<table>
<thead>
<tr>
<th>Action</th>
<th>Description</th>
<th>Remote Note</th>
</tr>
</thead>
<tbody>
<tr>
<td>Voicings: Previous</td>
<td>Plays back the previous voicing of the last played chord.</td>
<td>C2</td>
</tr>
</tbody>
</table>
Remote Assignments are saved globally.

**NOTE**

If you use the remote keys for voicings, tensions, or transposition after releasing the remote key for the chord pad, the next played chord is affected.

### Changing the Pads Remote Range

You can widen the pads remote range to access more chord pads. If you want to use a wider key range on your MIDI keyboard for regular playing, you can narrow the pads remote range.

**PROCEDURE**

1. Select **Show/Hide Settings > Remote Control** to open the remote control assignments.
2. Do one of the following:
   - Click **MIDI Learn** so that the button lights up, and on your MIDI keyboard, press
     the two keys that you want to assign as range start and range end.
   - Enter a new value in the **Range Start** and **Range End** fields.

RESULT
On the keyboard, the indication for pads remote range is changed.

**Chord Pad Settings – Players**

On the **Players** tab in the chord pad **Settings** you can change the voicing that is used for the chord pads. You can select different players with specific voicing settings that are typical for that kind of player. By default, the **Piano Player** option is active.

- To the left of the chord pads zone, click **Show/Hide Settings** and activate the **Players** tab.

   1) **Show/Hide Settings**
      Opens the settings for the chord pads.

   2) **Legato**
      If this is activated, the common notes of two subsequent chords are connected.

   3) **Player Selection**
      Selects the player, and uses its voicing for the chord pads.

   4) **Plain Chords/Pattern**
      Select **Plain Chords** to trigger all notes of a chord simultaneously, or select **Pattern** to break up the chords into their individual notes.

      In **Plain Chords** mode, you can activate **Legato** to hold the common notes of two subsequent chords instead of triggering them again.
5) **Add Player**

Opens a menu where you can select the player that you want to add. From here, you can also rename or remove the current player.

**RELATED LINKS**

- Players and Voicings on page 854
- Voicings on page 825

---

**Players and Voicings**

Different types of instruments and styles have different voicing libraries. These determine how the chords are played back, and which pitches are played. In the chord pads zone, these voicings are referred to as players.

**RELATED LINKS**

- Voicings on page 825

---

**Adaptive Voicing**

In Cubase, the **Adaptive Voicing** setting ensures that pitches in chord progressions do not change abruptly.

By default, **Adaptive Voicing** is activated and the voicings of the chord pads are determined automatically according to specific voice leading rules.

If you want to set the voicing of a specific chord pad manually, and do not want it changed automatically, you can use the **Voicing** control to the right of a chord pad. When you assign your own voicing, **Adaptive Voicing** is deactivated for that chord pad, so that the pad does no longer follow the voice leading rules of the voicing reference. To activate **Adaptive Voicing** again, right-click the chord pad and activate **Adaptive Voicing**.

To lock the voicing for a chord pad, you can right-click the pad and activate **Lock**. This locks this pad for editing and remote control changes, and deactivates **Adaptive Voicing**. To unlock the chord pad again, right-click the pad and deactivate **Lock**.
Using the Pattern Player

You can determine how the triggered chord is played: as a plain chord, or according to a selected pattern. The pattern player plays the notes that make up the chord one after another (arpeggio).

**PROCEDURE**

1. Select `Show/Hide Settings > Players > Pattern`.

2. Perform one of the following actions:
   - Click `Import MIDI Loop` to select a MIDI loop that you want to use as a pattern.
   - Drag a MIDI part from the event display to the `Drop MIDI Part` field.

   **NOTE**
   
   The loop or part must have between 3 and 5 voices. In the MediaBay, the number of voices is indicated in the `Voices` column of the result list.

   The loop or part is taken as a reference and defines how the chord is played. The `Drop MIDI Part` field displays the name of the selected loop or part.

3. In the `Velocity from:` field, select a velocity source for the notes.
   - Activate `MIDI Keyboard` to determine the velocity values by pressing the keys on your MIDI keyboard harder or softer.
   - Activate `Pattern` to use the velocity values from the MIDI loop or the MIDI part that is selected as a pattern.

**AFTER COMPLETING THIS TASK**

If you have a pattern that you want to use in other projects, you can save it using the presets section in the pattern player.

**RELATED LINKS**

Assigning Voices to Notes on page 833
Setting Up the Results List Columns on page 529

Using Different Players on Multiple Tracks

You can set up different players with different sounds on different tracks. If you record-enable these tracks and play the chord pads, each track uses a dedicated player.

**PROCEDURE**

1. Select `Project > Add Track > Instrument`.

2. In the `Add Instrument Track` dialog, enter the number of tracks in the `Count` field, and select a VST instrument.
3. Click **Add Track**.
The instrument tracks are added to your project.

4. Select **Project > Chord Pads** to open the chord pads zone.

5. To the left of the chord pads zone, activate **Show/Hide Settings** and click **Players**.

![Players](image)

6. Select the first instrument track, select a sound on the VST instrument, and in the chord pads zone, select a player.
For example, select a piano sound and assign a **Piano Player**.

**NOTE**
When setting up the player for a track, make sure that Record Enable or Monitor is only active for this particular track.

7. Select the second instrument track, select a sound on the VST instrument, and set up another player.
For example, select a guitar sound and assign a **Guitar Player**.

8. Select the next instrument track, and proceed as for the other 2 tracks.
For example, select a string sound and assign a **Basic Player**.

9. Select all instrument tracks, and click **Record Enable**.

**RESULT**
You can now play the chord pads and use the remote control parameters for **Tensions** and **Transpose** to change all chord symbols for each player simultaneously. However, if you change the **Voicing**, only the selected player is affected.

**Chord Pad Settings – Pad Layout**

The **Pad Layout** tab in the chord pad **Settings** allows you to change the layout that is used for the chord pads. By default, the keyboard layout is active, but you can change to a grid layout, if you prefer that. After changing the pad layout you may need to adjust the remote setup.

- To the left of the chord pads zone, click **Show/Hide Settings** and activate the **Pad Layout** tab.
Chord Pads

Chord Pads Presets

1) **Show/Hide Settings**
   Opens the settings for the chord pads.

2) **Keyboard**
   Activate this to show the chord pads in a keyboard layout. You can display
   one or two octaves, and you can select if the first chord pad starts with C, A
   or E.

3) **Grid**
   Activate this to show the chord pads in a grid layout. You can display up to 4
   rows and 16 columns.

4) **Layout display**
   Shows how the active chord pad layout is displayed.

Chord Pads Presets

Chord pads presets are templates that can be applied to newly created or to existing chord pads.

Chord pads presets contain the chords that are assigned to the chord pads, as well as the player configurations including any pattern data that you have imported via the MediaBay or by using drag & drop. The chord pads presets allow you to quickly load chords, or reuse player settings. The Chord Pads Presets menu is located to the left of the chord pads zone. Chord pads presets are organized in the MediaBay, and you can categorize them with attributes.

- To save/load a chord pads preset, select Chord Pads Presets > Save/Load Chord Pads Preset.

You can also load only the assigned chords from a chord pads preset, without loading the player configurations. This is useful if you want to use specific chords that you have saved as a preset, but do not want to alter your current player setting.

- To load only the chords of a chord pads preset, select Chord Pads Presets > Load Chords from Preset.

In the same way, you can also load only the player configurations of a chord pads preset. This is useful if you have saved very complex player settings and want to reuse them on other chord pads without changing the currently assigned chords.

- To load only the player settings of a chord pads preset, select Chord Pads Presets > Load Players from Preset.
Saving Chord Pads Presets

If you have set up the chord pads, you can save them as chord pads presets.

**PROCEDURE**

1. To the left of the chord pads zone, select **Chord Pads Preset > Save Chord Pads Preset**.

2. In the **New Preset** section, enter a name for the new preset.

   **NOTE**

   You can also define attributes for the preset.

3. Click OK to save the preset and exit the dialog.

Creating Events from Chord Pads

You can use the chords assigned to the chord pads to create chord events or MIDI parts in the **Project** window.

- To create a chord event, drag a chord pad and drop it on the chord track.
- To create a MIDI part with the length of one bar, drag a chord pad an drop it on a MIDI or instrument track.

**RELATED LINKS**

- Recording Chord Events with a MIDI Keyboard on page 835
The Logical Editor, Transformer, and Input Transformer

Introduction

Most of the time you will perform your MIDI editing graphically in one of the MIDI editors. But there are times when you want more of a “search and replace” function on MIDI data, and that’s where the Logical Editor comes in.

IMPORTANT

The Logical Editor is only available in Cubase Pro. However, the Transformer MIDI effect and the Input Transformer that share many of the functions with the Logical Editor are also available in Cubase Artist.

The principle of the Logical Editor is this:

- You set up filter conditions to find certain elements.
  This can be elements of a certain type, with certain attributes or values or on certain positions, in any combination. You can combine any number of filter conditions and make composite conditions using And/Or operators.

- You select the basic function to be performed.
  The options include Transform (changing properties of the found elements), Delete (removing the elements), Insert (adding new elements based on the found positions of other elements) and more.

- You set up a list of actions, which specify exactly what is done.
  This is not necessary for all functions. For example, the Delete function does not require any additional action specifications – it simply removes all found elements. The Transform function on the other hand requires that you specify which properties are changed and in which way (transpose notes by a certain amount, adjust velocity values, etc.).

By combining filter conditions, functions and the specific actions, you can perform very powerful processing.

To master the Logical Editor, you need some knowledge about how MIDI messages are structured. However, the Logical Editor also comes with a rich selection of presets, allowing you to access its processing powers without delving into its more complicated aspects.
IMPORTANT

Studying the included presets is an excellent way to learn the workings of the Logical Editor! Many of them can also be used as starting points when you set up your own editing operations using the Logical Editor.

RELATED LINKS

Working with presets on page 877

About the Transformer MIDI effect

The Transformer effect is a realtime version of the Logical Editor, allowing you to apply editing to the events played back from a track “on the fly”. The Transformer contains virtually the same settings and functions as the Logical Editor – where there are differences between the two, this is clearly stated on the following pages.

RELATED LINKS

MIDI realtime parameters and effects on page 643

About the Input Transformer

This too is very similar to the Logical Editor. Just like the Transformer effect, the Input Transformer works in realtime. However, the Input Transformer filters out and transforms MIDI data as it is recorded. In other words, the settings you make in the Input Transformer will affect the actual MIDI events you record.

We recommend that you make yourself familiar with the Logical Editor first, since they share many features and principles.

RELATED LINKS

The Input Transformer on page 878

About the Project Logical Editor

There is also a “Project Logical Editor” available via the Edit menu.

RELATED LINKS

Project Logical Editor (Cubase Pro only) on page 881

Opening the Logical Editor

PROCEDURE

1. Select the desired parts or events.
   What will be affected by the operation depends on the current selection.
   • In the Project window, edits using the Logical Editor are applied to all selected parts, affecting all events (of the relevant types) in them.
• In the MIDI editors, edits using the Logical Editor are applied to all selected events. If no events are selected, all events in the edited part(s) will be affected.

You can change the selection while the Logical Editor window is open.

2. Select “Logical Editor…” from the MIDI menu.

Window overview

1) Filter conditions list
2) Action list
3) Function pop-up menu
4) Apply button (not available in the Transformer)

Setting up filter conditions

General procedure

The upper list is where you set up the filter conditions, determining which elements to find. The list can contain one or several conditions, each on a separate line.

• To add a new condition, click the “+” button below the list.
  A new line is added at the bottom of the list. If there are many lines, you may need to use the scrollbar to the right to view them.

• To remove a condition, select it and click the “−” button below the list.
The Logical Editor, Transformer, and Input Transformer
Setting up filter conditions

NOTE
If you have already defined filter conditions and/or applied a preset, but want to start
again from scratch, you can initialize the settings by selecting the Init option from
the Presets pop-up menu.

You set up a filter condition line by clicking in the columns and selecting options
from the pop-up menus that appear. Here is a brief description of the columns:

Left bracket
This is used for “bracketing” several lines together when creating conditions
with multiple lines and the boolean operators And/Or.

Filter Target
Here you select which property to look for when finding elements. Your choice
here affects the available options in the other columns as well, see below!

Condition
This determines how the Logical Editor compares the property in the Filter
Target column to the values in the Parameter columns (see below). The
available options depend on the Filter Target setting.

Parameter 1
Here you set which value the element properties are compared to (depending
on the Filter Target).
For example, if the Filter Target is “Position” and Condition is “Equal”, the
Logical Editor will look for all elements starting at the position you specify in
the Parameter 1 column.

Parameter 2
This column is used if you have selected one of the “Range” options in the
Condition column. This allows you to find all elements with values inside (or
outside) the range between Parameter 1 and Parameter 2.
Furthermore, if you want to find certain VST 3 events (Filter Target set to
“Type is” and Parameter 1 set to “VST3 Event”), you can use the Parameter
2 column to specify the VST 3 parameter that you are searching for, e.g.
Tuning.

Bar Range/Time Base (Logical Editor only)
This column is only used if the Filter Target is set to “Position”. If one of the
“Bar Range” options is selected in the Condition column, you use the Bar
Range/Time Base column to specify “zones” within each bar (for example,
allowing you to find all elements on or around the first beat of every bar). If any
of the other Condition options is selected, you can use the Bar Range/Time
Base column to specify the time base (PPQ, Seconds, etc.).

Right bracket
This is used for “bracketing” several lines together.
### Conditions

Depending on the Filter Target setting, the following options can be selected in the Condition column:

**Equal**

…has the exact same value as set up in the Parameter 1 column.

**Unequal**

…has any value other than the one set up in the Parameter 1 column.

**Bigger**

…has a value higher than the one set up in the Parameter 1 column.

**Bigger or Equal**

…has a value that is the same as or higher than the one set up in the Parameter 1 column.

**Less**

…has a value lower than the one set up in the Parameter 1 column.

**Less or Equal**

…has a value that is the same as or lower than the one set up in the Parameter 1 column.

**Inside Range**

…has a value that is between the values set up in the Parameter 1 and Parameter 2 columns. Note that Parameter 1 should be the lower value and Parameter 2 the higher.

**Outside Range**

…has a value that is not between the values set up in the Parameter 1 and Parameter 2 columns.
Inside Bar Range (Logical Editor only)
...is within the “zone” set up in the Bar Range/Time Base column (Position only), in each bar within the current selection.

Outside Bar Range (Logical Editor only)
...is outside the “zone” set up in the Bar Range/Time Base column (Position only), in each bar within the current selection.

Before Cursor (Logical Editor only)
...is before the song cursor position (Position only).

Beyond Cursor (Logical Editor only)
...is after the song cursor position (Position only).

Inside Track Loop (Logical Editor only)
...is inside the set track loop (Position only).

Inside Cycle (Logical Editor only)
...is inside the set cycle (Position only).

Exactly matching Cycle (Logical Editor only)
...exactly matches the set cycle (Position only).

Note is equal to
...is the note specified in the Parameter 1 column, regardless of octave (Pitch only). For example, lets you find all C notes, in all octaves.

NOTE
The Conditions for the “Property” filter target are different.

Below, the different Filter Targets (and their corresponding Condition and Parameter options) are described in more detail.

RELATED LINKS
Searching for properties on page 868

Searching for elements at certain positions (Logical Editor only)

Selecting “Position” in the Filter Target column lets you find elements starting at certain positions, either relative to the start of the song or within each bar.

• If you select any condition other than the Range or Bar Range options, you set up a specific position (in PPQ, seconds, samples, or frames) in the Parameter 1 column. Use the Bar Range/Time Base column to specify the time base.

Here, the Logical Editor will find all elements at 1.1.1.0 in the project.
• If you select Inside Range or Outside Range in the Condition column, you set the start position of the range in the Parameter 1 column and the end position in the Parameter 2 column. You can also change the time base using the Bar Range/Time Base column. The Logical Editor will then find all elements inside or outside this position range.

• If you select one of the Bar Range options in the Condition column, the Bar Range/Time Base column will show a graphic bar display. You specify the range within the bar by clicking and dragging in the bar display (the specified Bar Range is indicated in blue). The Logical Editor will then find all elements starting inside or outside this Bar Range, in all bars (within the current selection).

<table>
<thead>
<tr>
<th>Filter Target</th>
<th>Condition</th>
<th>Parameter 1</th>
<th>Parameter 2</th>
<th>Bar Range/Time Base</th>
</tr>
</thead>
<tbody>
<tr>
<td>Position</td>
<td>Inside Bar Range</td>
<td>395</td>
<td>491</td>
<td></td>
</tr>
</tbody>
</table>

Here, the Logical Editor will find elements starting around the second beat in each bar.

Searching for notes of certain lengths (Logical Editor only)

Only note events have lengths (actually, a note is made up of separate note-on and note-off events but in Cubase it is considered as a single event with a length). Therefore, the “Length” Filter Target is only valid if you are specifically searching for notes – there has to be another condition line with the Filter Target “Type”, Condition “Equal” and Parameter 1 set to “Note”.

RELATED LINKS
Combining multiple condition lines on page 892

Searching for Value 1 or Value 2

A MIDI event is composed of several values. What is displayed for Value 1 and 2 depends on the type of event:

<table>
<thead>
<tr>
<th>Event type</th>
<th>Value 1</th>
<th>Value 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>Notes</td>
<td>The Note Number/Pitch.</td>
<td>The velocity of the note.</td>
</tr>
<tr>
<td>Poly Pressure</td>
<td>The key that was pressed.</td>
<td>The amount of pressure for the key.</td>
</tr>
<tr>
<td>Controller</td>
<td>The type of Controller, displayed as a number.</td>
<td>The amount of Control Change.</td>
</tr>
<tr>
<td>Program Change</td>
<td>The Program Change number.</td>
<td>Not used.</td>
</tr>
<tr>
<td>Aftertouch</td>
<td>The amount of pressure.</td>
<td>Not used.</td>
</tr>
<tr>
<td>Pitchbend</td>
<td>The “fine-tune” of the bend. Not always used.</td>
<td>The coarse amount of bend.</td>
</tr>
</tbody>
</table>
The Logical Editor, Transformer, and Input Transformer

Setting up filter conditions

**NOTE**

System Exclusive events are not included in the table above, because they do not use value 1 and 2.

Because value 1 and 2 have different meanings for different events, searching for value 2 = 64 would both find notes with the velocity 64 and controllers with the amount 64, etc. If this is not what you want, you can add an additional filter condition line with the Filter Target “Type”, specifying which type of events to find (see below).

**IMPORTANT**

This is particularly useful when searching for note pitch or velocity values, as described below.

The general procedures when searching for value 1 or 2 are:

- If you select any Condition other than the Range options, you set up a specific value in the Parameter 1 column.

  ![Filter Target](image)

  Here, the Logical Editor will find all events with a value 2 less than 80.

- If you select Inside Range or Outside Range in the Condition column, the range consists of the values between Parameter 1 and Parameter 2.

  Note that Parameter 1 should have the lower value.

**RELATED LINKS**

[Action Target on page 893](#)

---

### Searching for note pitch or velocity

If you add another condition line with the Filter Target “Type”, Condition “Equal” and Parameter 1 set to “Note”, the Logical Editor will “know” you are searching for pitch or velocity.

This has the following benefits:

- The Filter Targets Value 1 and Value 2 will be displayed as “Pitch” and “Velocity” respectively, making it easier to grasp the function of the filter condition.

---

**Table**

<table>
<thead>
<tr>
<th>Event type</th>
<th>Value 1</th>
<th>Value 2</th>
</tr>
</thead>
</table>
| VST3 Event | Not used.    | The value of the VST3 Event parameter. The value range of the VST 3 event (0.0 to 1.0) is transformed into the MIDI value range (0-127), i.e., the VST 3 event value 0.5 corresponds to 64. For some operations that require a higher resolution, you can make use of the “VST3 Value Operation” parameter.
• Pitch values in the Parameter columns will be displayed as note names (C3, D#4, etc.). When entering pitch values you can either type a note name or a MIDI note number (0–127).

• When Value 1 (pitch) is selected as Filter Target, an additional option appears in the Condition column: “Note is equal to”. When this is selected, you specify a note name in the Parameter 1 column but without any octave number (C, C#, D, D#, etc.). The Logical Editor can then find all notes of a certain key, in all octaves.

**RELATED LINKS**
Combining multiple condition lines on page 892

### Searching for controllers

There is similar extended functionality when searching for controllers: If you have added an additional “Type = Controller” condition line, the Logical Editor will “know” you are searching for controllers. The Parameter 1 column will then show the names of the MIDI controllers (Modulation, Volume, etc.) when Value 1 is selected as Filter Target.

### Searching for MIDI channels

Each MIDI event contains a MIDI channel setting (1–16). Normally, these settings are not used, since the MIDI event plays back on the MIDI channel set for its track.

However, you can come across MIDI parts with events set to different channels, for example in the following scenarios:

• If you have recorded MIDI from an instrument sending on several different channels (e.g. a master keyboard with different key zones).

• If you have imported a MIDI file of type 0 (with a single track, containing MIDI events with different channel settings).

Searching for MIDI channel values is straightforward; you select a Condition and enter a MIDI channel (1–16) in the Parameter 1 column (and, if you have selected one of the Range Conditions, a higher channel in the Parameter 2 column, creating a value range).

### Searching for element types

Selecting Type as the Filter Target allows you to find elements of a certain type only.

• The Condition column contains only three options: Equal, Unequal and All Types.

• Clicking the Parameter 1 column displays a pop-up menu, listing the available types (Note, Poly Pressure, Controller, etc.).

The Logical Editor will find all elements matching or not matching the selected type (depending on the Condition).
As mentioned above, selecting Type = Note or Type = Controller adds some additional functionality to the Logical Editor. You should make it a habit to add a Type condition when applicable.

Searching for properties

On the Filter Target pop-up menu, you will find an option called Property. This allows you to search for properties that are not part of the MIDI standard but rather Cubase-specific settings.

When the Property option is selected, the Condition column has two options: “Property is set” and “Property is not set”. Which property to look for is selected in the Parameter 1 column. The options are “muted”, “selected”, “empty”, “inside NoteExp”, and “valid VST3”. Some examples:

<table>
<thead>
<tr>
<th>Filter Target</th>
<th>Condition</th>
<th>Parameter 1</th>
<th>Parameter 2</th>
<th>Bar Range/Time Base</th>
</tr>
</thead>
<tbody>
<tr>
<td>Property</td>
<td>Property is set</td>
<td>Event is muted</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Here, the Logical Editor will find all muted events.

<table>
<thead>
<tr>
<th>Filter Target</th>
<th>Condition</th>
<th>Parameter 1</th>
<th>Parameter 2</th>
<th>Bar Range/Time Base</th>
</tr>
</thead>
<tbody>
<tr>
<td>Property</td>
<td>Property is set</td>
<td>Event is selected</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Property</td>
<td>Property is set</td>
<td>Event is muted</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Here, the Logical Editor will find all events that are selected and muted.

Cubase Pro only: Here, the Logical Editor will find all Note Expression data.

<table>
<thead>
<tr>
<th>Filter Target</th>
<th>Condition</th>
<th>Parameter 1</th>
<th>Parameter 2</th>
<th>Bar Range/Time Base</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type is</td>
<td>NoteExp</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Property</td>
<td>Property is set</td>
<td>Event inside NoteExp</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Cubase Pro only: Here, the Logical Editor will find all MIDI controller events that form part of Note Expression data.

Cubase Pro only: Here, the Logical Editor will find all VST 3 events that cannot be played back, because there is no Note Expression compatible VST instrument on the related track.

Searching for event contexts

On the Filter Target pop-up menu, you will find an option called “Last Event”. This can be used to perform context-dependent searches (especially useful in the Input Transformer).

“Last Event” indicates the state of an event which has already passed the Input Transformer/Logical Editor. The condition has to be combined with Parameter 1 and Parameter 2.

Below, you will find a few examples on how the Last Event filter target can be used.
Here, the action will only be performed when the sustain pedal is down:

<table>
<thead>
<tr>
<th>Filter Target</th>
<th>Condition</th>
<th>Parameter 1</th>
<th>Parameter 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>Last Event</td>
<td>Equal</td>
<td>MIDI Status</td>
<td>176/Controller</td>
</tr>
<tr>
<td>Last Event</td>
<td>Equal</td>
<td>Value 1</td>
<td>64</td>
</tr>
<tr>
<td>Last Event</td>
<td>Bigger</td>
<td>Value 2</td>
<td>64</td>
</tr>
</tbody>
</table>

In this example, the action will be performed when the note C1 is pressed (the “Note is playing” condition is only available in the Input Transformer and in the Transformer effect):

<table>
<thead>
<tr>
<th>Filter Target</th>
<th>Condition</th>
<th>Parameter 1</th>
<th>Parameter 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type is</td>
<td>Equal</td>
<td>Note</td>
<td></td>
</tr>
<tr>
<td>Last Event</td>
<td>Equal</td>
<td>Note is playing</td>
<td>36/C1</td>
</tr>
</tbody>
</table>

In this example, the action will be performed after playing the C1 note:

<table>
<thead>
<tr>
<th>Filter Target</th>
<th>Condition</th>
<th>Parameter 1</th>
<th>Parameter 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>Last Event</td>
<td>Equal</td>
<td>Value 1</td>
<td>36/C1</td>
</tr>
</tbody>
</table>

Cubase Pro only: In this example, the action will be performed for Note Expression VST 3 Tuning events that are attached to a C1 note when C1 is pressed:

<table>
<thead>
<tr>
<th>Filter Target</th>
<th>Condition</th>
<th>Parameter 1</th>
<th>Parameter 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type is</td>
<td>Equal</td>
<td>VST3 Event</td>
<td>Tuning</td>
</tr>
<tr>
<td>Last Event</td>
<td>Equal</td>
<td>MIDI Status</td>
<td>144/Note On</td>
</tr>
<tr>
<td>Last Event</td>
<td>Equal</td>
<td>Value 1</td>
<td>36/C1</td>
</tr>
</tbody>
</table>

### Searching for Chords (Logical Editor only)

**NOTE**

A note belongs to a chord, if at least two other notes play at the same time.

The Context Variable option on the Filter Target pop-up menu allows you to search for chords in a MIDI part or on the chord track.

When Context Variable is selected, the Condition column shows the following options: Equal, Unequal, Bigger, Bigger or Equal, Less, Less or Equal, Inside Range, Outside Range.

Parameter 1 allows you to specify which context variable is searched:

<table>
<thead>
<tr>
<th>Parameter 1</th>
<th>Searches for…</th>
</tr>
</thead>
<tbody>
<tr>
<td>Highest/Lowest/Average Pitch</td>
<td>…notes with the highest, lowest or average pitch in the selected MIDI part.</td>
</tr>
</tbody>
</table>
### Setting up filter conditions

For the following values of Parameter 1 you have to specify a Parameter 2:

<table>
<thead>
<tr>
<th>Parameter 1</th>
<th>Parameter 2</th>
<th>Searches for…</th>
</tr>
</thead>
<tbody>
<tr>
<td>Highest/Lowest/Average Velocity</td>
<td>No. of Notes in Chord (Part)</td>
<td>…notes with the highest, lowest or average velocity in the selected MIDI part.</td>
</tr>
<tr>
<td>Highest/Lowest/Average CC Value</td>
<td>No. of Voices (Part)</td>
<td>…controllers with the highest, lowest or average value in the selected MIDI part.</td>
</tr>
<tr>
<td></td>
<td>Position in Chord (Part)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Note Number in Chord (lowest = 0)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Position in Chord (Chord track)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Voice</td>
<td></td>
</tr>
</tbody>
</table>

The Musical Context presets give you an idea of the possibilities of this filter target.

**Related links**
- Conditions on page 863
- Working with presets on page 898

### Combining multiple condition lines

As described above, you can add condition lines by clicking the “+” button below the list. The result of combining condition lines depends on the boolean And/Or operators and the brackets.
The Logical Editor, Transformer, and Input Transformer

Setting up filter conditions

The bool column

By clicking in the “bool” column to the right in the list, you can select a boolean operator: “And” or “Or”.

A boolean operator combines two condition lines and determines the result in the following way:

- If two condition lines are combined with a boolean And, both conditions must be fulfilled for an element to be found.

```
<table>
<thead>
<tr>
<th>Filter Target</th>
<th>Condition</th>
<th>Parameter 1</th>
<th>Parameter 2</th>
<th>Bar Range/Time Base</th>
<th>bool</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type is</td>
<td>Equal</td>
<td>Note</td>
<td></td>
<td></td>
<td>And</td>
</tr>
<tr>
<td>Position</td>
<td>Equal</td>
<td></td>
<td></td>
<td>3.01.01.000</td>
<td></td>
</tr>
</tbody>
</table>
```

The Logical Editor will only find elements that are notes and start at the beginning of the third bar.

- If two condition lines are combined with a boolean Or, one of the conditions (or both) must be fulfilled for an element to be found.

```
<table>
<thead>
<tr>
<th>Filter Target</th>
<th>Condition</th>
<th>Parameter 1</th>
<th>Parameter 2</th>
<th>Bar Range/Time Base</th>
<th>bool</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type is</td>
<td>Equal</td>
<td>Note</td>
<td></td>
<td></td>
<td>Or</td>
</tr>
<tr>
<td>Position</td>
<td>Equal</td>
<td></td>
<td></td>
<td>3.01.01.000</td>
<td></td>
</tr>
</tbody>
</table>
```

The Logical Editor will find all events that are notes (regardless of their position) and all events starting at the beginning of the third bar (regardless of their type).

When you add a new condition line, the boolean setting defaults to And. Therefore, if all you want to do is set up two or more conditions that all must be met for an element to be found, you do not have to think about the boolean column – just add the required lines and make the usual filter settings.

Using brackets

The bracket (parenthesis) columns let you enclose two or more condition lines, dividing the conditional expression into smaller units. This is only relevant when you have three or more condition lines and want to use the boolean Or operator.

This is how it works:

- Without brackets, the conditional expressions are evaluated according to their order in the list.

```
<table>
<thead>
<tr>
<th>Filter Target</th>
<th>Condition</th>
<th>Parameter 1</th>
<th>Parameter 2</th>
<th>Bar Range/Time Base</th>
<th>bool</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pitch</td>
<td>Equal</td>
<td>C3</td>
<td>Or</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Channel</td>
<td>Equal</td>
<td></td>
<td></td>
<td>1</td>
<td></td>
</tr>
</tbody>
</table>
```

In this case the Logical Editor will find all MIDI notes with the pitch C3, as well as all events (regardless of their type) set to MIDI channel 1.

Maybe you wanted to find all notes that either had the pitch C3 or the MIDI channel 1 (but no non-note events)? Then you need to add some brackets:

```
<table>
<thead>
<tr>
<th>Filter Target</th>
<th>Condition</th>
<th>Parameter 1</th>
<th>Parameter 2</th>
<th>Bar Range/Time Base</th>
<th>bool</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type is</td>
<td>Equal</td>
<td>Note</td>
<td></td>
<td></td>
<td>And</td>
</tr>
<tr>
<td>Pitch</td>
<td>Equal</td>
<td>C3</td>
<td>Or</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Channel</td>
<td>Equal</td>
<td></td>
<td></td>
<td>1</td>
<td></td>
</tr>
</tbody>
</table>
```

- Expressions within brackets are evaluated first.

If there are several layers of brackets, these are evaluated “from the inside out”, starting with the innermost brackets.
You add brackets by clicking in the bracket columns and selecting an option. Up to triple brackets can be selected.

**Selecting a function**

The pop-up menu at the bottom of the Logical Editor is where you select the function – the basic type of editing to be performed.

Below, the available options are listed. Note that some options are not available in the Transformer effect.

**Delete**

Deletes all elements found by the Logical Editor. In the case of the Transformer, this function will remove (or “mute”) all found elements from the “output stream” – the actual elements on the track are not affected.

**Transform**

Changes one or several aspects of the found elements. You set up exactly what is changed in the action list.

**Insert**

This will create new elements and insert these into the part(s) (Logical Editor) or the output stream (Transformer). The new elements will be based on the elements found by the Logical Editor’s filter conditions, but with any changes you have set up in the action list applied.

Another way of expressing this is that the Insert function copies the found elements, transforms them according to the action list and inserts the transformed copies among the existing elements.

**Insert Exclusive**

This will transform the found elements according to the action list. Then, all elements that were not found (that did not meet the filter conditions) are deleted (Logical Editor) or removed from the output stream (Transformer).

**Copy (Logical Editor only)**

This will copy all found elements, transform them according to the action list and paste them into a new part on a new MIDI track. The original events are not affected.
The Logical Editor, Transformer, and Input Transformer

Specifying actions

Extract (Logical Editor only)
This works like Copy, but will cut the found events instead. Or in other words, Extract will transform all found events and move them to a new part on a new MIDI track.

Select (Logical Editor only)
This will simply select all found events, highlighting them for further work in the regular MIDI editors.

RELATED LINKS
Specifying actions on page 873

Specifying actions

The lower list in the Logical Editor window is the action list. This is where you specify any changes that are made to the found events (relevant for all function types except Delete and Select).

The handling of the action list is similar to the filter condition list, but without the brackets and booleans. You simply add lines by clicking the “+” button below the list, and fill out the columns as required. To remove a superfluous action line, select it and click the “-” button.

Action Target

This is where you select the property that is changed in the events:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Position (Logical Editor only)</td>
<td>Adjusting this value will move the events.</td>
</tr>
<tr>
<td>Length (Logical Editor only)</td>
<td>Lets you resize the events (notes only).</td>
</tr>
<tr>
<td>Value 1</td>
<td>This adjusts value 1 in the events. What is displayed for value 1 depends on the event type. For notes, value 1 is the pitch.</td>
</tr>
<tr>
<td>Value 2</td>
<td>This adjusts value 2 in the events. What is displayed for value 2 depends on the event type. For notes, value 2 is the velocity value.</td>
</tr>
<tr>
<td>Channel</td>
<td>Allows you to change the MIDI channel setting.</td>
</tr>
<tr>
<td>Type</td>
<td>Allows you to change the event type, e.g. transform aftertouch events to modulation events, or pitchbend events to VST 3 Tuning events.</td>
</tr>
</tbody>
</table>
The Logical Editor, Transformer, and Input Transformer

Specifying actions

**NOTE**

The Position and Length parameters are interpreted via the time base setting in the Bar Range/Time Base column, with the exception of the Random setting, which uses the time base of the affected events.

**RELATED LINKS**

- Searching for properties on page 891
- Searching for Value 1 or Value 2 on page 865

---

**Operation**

This setting determines what to do with the Action Target. The options on this pop-up menu are different depending on the selected Action Target.

Below, all available operations are listed:

**Add**

Adds the value specified in the Parameter 1 column to the Action Target.

**Subtract**

Subtracts the value specified in the Parameter 1 column from the Action Target.

**Multiply by**

Multiplies the Action Target value with the value specified in the Parameter 1 column.

**Divide by**

Divides the Action Target value by the value specified in the Parameter 1 column.

**Cubase Pro only: VST3 Value Operation – Invert (Logical Editor only)**

Inverts Note Expression data containing the specified VST 3 event parameter.
Round by

This “rounds” the Action Target value using the value specified in the Parameter 1 column. In other words, the Action Target value is changed to the closest value that can be divided by the Parameter 1 value.

For example, if the Action Target value is 17 and Parameter 1 is 5, the result of rounding will be 15 (the closest value that can be divided by 5). Another word for this type of operation would be “quantizing”, and it is actually possible to use it for this, by setting the Action Target to “Position” and specifying a quantize value with Parameter 1 (in ticks, with 480 ticks per quarter note).

Set Random Values between

This will set the Action Target value to a random value within the range specified with Parameter 1 and 2.

Set to fixed value

This sets the Action Target to the value specified in the Parameter 1 column.

Set Relative Random Values between

This will add a random value to the current Action Target value. The added random value will be within the range specified with Parameter 1 and 2. Note that these can be set to negative values.

For example, if you set Parameter 1 to -20 and Parameter 2 to +20, the original Action Target value will get a random variation, never exceeding ±20.

Add Length (Logical Editor only)

This is only available when Action Target is set to Position. Furthermore, it is only valid if the found events are notes (and thus have a length). When Add Length is selected, the length of each note event will be added to the Position value. This can be used for creating new events (using the Insert function) positioned relative to the end positions of the original notes.

Transpose to Scale

This is only available when Action Target is set to Value 1, and when the filter conditions are specifically set up to find notes (a “Type = Note” filter condition line has been added). When “Transpose to Scale” is selected, you can specify a musical scale using the Parameter 1 and 2 columns. Parameter 1 is the key (C, C#, D, etc.) while Parameter 2 is the type of scale (major, melodic or harmonic minor, etc.).

Each note will be transposed to the closest note in the selected scale.

Use Value 2

This is only available when Action Target is set to Value 1. If this option is selected, the Value 2 setting in each event will be copied to the Value 1 setting.

This is useful, for example, if you are transforming all Modulation controllers to Aftertouch events (since controllers use Value 2 for their amount, while Aftertouch uses Value 1).
Use Value 1

This is only available when Action Target is set to Value 2. If this option is selected, the Value 1 setting in each event will be copied to the Value 2 setting.

Mirror

This is only available when Action Target is set to Value 1 or Value 2. When this option is selected, the values will be “mirrored” around the value set in the Parameter 1 column.

In the case of notes, this will invert the scale, with the key set in the Parameter 1 column as “center point”.

Linear Change in Loop Range (Logical Editor only)

This will affect events within the loop range (between the left and right locators) only. It will create a linear “ramp” of values (replacing the original values) starting at the value in the Parameter 1 column and ending at the Parameter 2 value.

This can be used for creating linear controller sweeps, velocity ramps, etc.

Relative Change in Loop Range (Logical Editor only)

As with the previous option, this will create a ramp of values, affecting events in the loop range only (i.e. between the locators). However, here the changes are “relative”, meaning that values will be added to the existing values.

In other words, you set up a value ramp starting at Parameter 1 and ending at Parameter 2 (note that the Parameter values can be negative). The resulting value ramp is then added to the existing values for the events within the loop range.

For example, if you apply this to note velocities with Parameter 1 set to 0 and Parameter 2 set to -100, you create a velocity fade-out, keeping the original velocity relations:

Cubase Pro only: NoteExp Operation – Remove Note Expression (Logical Editor only)

This option is only available for notes. It allows you to remove all Note Expression data from a note.

Cubase Pro only: NoteExp Operation – Create One-Shot (Logical Editor only)

This option is only available for notes. It allows you to add Note Expression data for notes in “One Shot” mode, meaning that you add a parameter as Note Expression data. After having added the one-shot parameter, you have to set it to the desired value in a second go.
Cubase Pro only: NoteExp Operation – Reverse (Logical Editor only)

Reverses the Note Expression data.

**RELATED LINKS**

Searching for Value 1 or Value 2 on page 865

---

**Applying the defined actions**

Once you have set up filter conditions, selected a function and set the required actions (or loaded a preset), you apply the actions defined with the Logical Editor by clicking the Apply button.

**IMPORTANT**

In the Logical Editor, processing is not performed until you click the Apply button. When using the Transformer MIDI effect, there is no Apply button – the current settings are automatically applied in realtime during playback or live playing.

Logical Editor operations can be undone just like any other editing.

---

**Working with presets**

The Presets pop-up menu at the top of the window allows you to load, save, and manage Logical Editor presets.

- To load a preset, select it from the Presets pop-up menu. If available, an explanatory text appears to the right of the menu. When setting up your own presets, you can click in this area and enter a description.

- You can also select Logical Presets directly from the MIDI menu. This allows you to apply a preset to the selected MIDI part, without having to open the Logical Editor.

- It is also possible to select and apply Logical Presets from within the List Editor (from the Mask menu).

- It is also possible to set up a key command for a preset. That way you can conveniently apply the same operation to several selected events in one go.

**RELATED LINKS**

Key Commands on page 997
Storing your own settings as a preset

If you have made Logical Editor settings that you want to use again, you can save them as a preset:

**PROCEDURE**
1. Click on the Store Preset button on the right of the Preset menu.
   A dialog for specifying a name for the new preset is displayed.
2. Enter a name for the preset and click OK.
   The preset is stored.
   To remove a preset, load it and click on the Remove Preset button.

Organizing and sharing presets

The Logical Editor presets are stored within the application folder in the Presets\Logical Edit subfolder. While these files cannot be edited “manually”, you can reorganize them (e.g. putting them in subfolders) like any files.

This also makes it easy to share presets with other Cubase users, by transferring the individual preset files.

**NOTE**

The list of presets is read each time the Logical Editor is opened.

The Input Transformer

This function allows you to filter out and change MIDI data coming to a MIDI track before it is recorded. The Input Transformer is very similar to the Transformer MIDI effect, but contains four independent “modules”, for which you can set up different filtering and actions. You can activate any or all of these four modules.

Here are some of the things the Input Transformer allows you to do:

- Set up split keyboard combinations for recording left and right hands separately.
- Turn a controller like a foot pedal into MIDI notes (for playing bass drum the right way).
- Filter out one specific type of MIDI data on one MIDI channel only.
- Turn aftertouch into any controller (and vice versa).
- Invert velocity or pitch.
Opening the Input Transformer

To open the Input Transformer for a MIDI track, select the track and click the Input Transformer button in the Inspector to open the pop-up menu.

- Select Global to make Input Transformer settings that affect all MIDI inputs (and thereby all MIDI tracks).
- Select Local to make Input Transformer settings for this track only.

In both cases, the button lights up and the Input Transformer opens.

Handling the four modules

The Input Transformer is really four separate transformers, or modules.

- You select which module to view and make settings for by clicking the corresponding Module tab.

Module 1 selected for viewing and editing.

- The On/Off buttons next to the Module names determine which module(s) are active.

Here, Module 1 is inactive and Module 2 is active.
The Logical Editor, Transformer, and Input Transformer

The Input Transformer

The Function pop-up menu

The Function pop-up menu contains two options: Filter and Transform.

- In Filter mode, only the filter conditions (the upper list) are taken into account. All events matching the conditions set up will be filtered out (excluded from the recording).
- In Transform mode, events matching the filter conditions will be transformed according to the settings in the action list (the lower list).

Setting up filtering and actions

This is done just like in the Logical Editor. Here is a brief rundown:

- Click the “+” button to add lines to the filter condition list or action list. To remove a line, click it to select it and click the “-” button below the lists.
- Clicking the columns in the filter condition list opens pop-up menus allowing you to specify the conditions to match.
- Clicking the columns in the action list opens pop-up menus allowing you to specify how the found events are transformed (when Transform mode is selected).
- The Input Transformer has no Apply button – the settings are active as soon as you activate the On/Off button of a module. The settings made in the active modules will affect all MIDI data you record on the track.

**NOTE**

Closing the Input Transformer window does not turn it off – you need to deactivate the On/Off buttons of all modules for this! A lit Input Transformer button in the Inspector indicates that one or more modules are active.

**RELATED LINKS**

General procedure on page 883
On the Edit menu you will find the function “Project Logical Editor…”. This opens a Project Logical Editor for the entire project. It works similar to the Logical Editor on the MIDI menu. The most important difference is that the Logical Editor for MIDI works at the event level, whereas the Project Logical Editor works at the project level and is therefore a very powerful tool for “search and replace” functions in your entire project.

NOTE

The MIDI events in the MIDI parts will not be affected by the Project Logical Editor operations. If you want to change MIDI notes or controller data, you have to use the Logical Editor.

With the Project Logical Editor, you can combine filter conditions with actions to create complex procedures, e.g. for special track type operations on tracks that are named identically. You can use its functions to delete all muted MIDI parts or to toggle the open state of all folder tracks in your project, etc.

Included with the Project Logical Editor are a number of presets that give you an impression of the great possibilities that this feature offers. Many of them can also be used as starting points when you set up your own editing operations.

The principle for the Project Logical Editor is this:

- You set up filter conditions to find certain elements.
  This can be elements of a certain type, with certain attributes or values or on certain positions, in any combination. You can combine any number of filter conditions and make composite conditions using AND/OR operators.

- You select the basic function to be performed.
  The options are Transform (changing properties of the found elements), Delete (removing the elements) and Select (selecting the found elements).

- You set up a list of actions, which specify exactly what is done.
  This is not necessary for all functions. For example, the Delete function does not require any additional action specifications – it simply removes all found elements.

- In the Macro pop-up menu you can choose an additional macro that will be executed after the actions you defined.
  Use this to extend the possibilities offered by combining the filter conditions and actions specified in the Project Logical Editor even further.
By combining filter conditions, functions, the specific actions, and additional macros, you can perform very powerful processing.

**IMPORTANT**

The Project Logical Editor allows all kinds of settings that may not always make sense. Experiment a bit before applying your edits to important projects. You can undo the operations by using the Undo command on the Edit menu.

**RELATED LINKS**

Working with presets on page 898
The Logical Editor, Transformer, and Input Transformer on page 859

---

### Opening the Project Logical Editor

**PROCEDURE**

1. **Open the desired project.**
   
   All elements in the project will be affected, you do not have to make any selection.

2. **Select “Project Logical Editor…” from the Edit menu.**

---

### Window overview

To understand the Project Logical Editor, it might be a good idea to start by exploring the included presets. These are found on the Presets pop-up menu at the top of the window.
Setting up filter conditions

General procedure

The upper list is where you set up the filter conditions, determining which elements to find. The list contains one or several conditions, each on a separate line.

- To add a new condition, click the “+” button below the list. The new line is added at the bottom of the list. If there are many lines, you may need to use the scrollbar to the right to view them.

- To remove a condition, select it and click the Delete button (-) below the list.

NOTE

If you have already defined filter conditions and/or applied a preset, but want to start again from scratch, you can initialize the settings by selecting the Init option from the Presets pop-up menu.

You set up a filter condition line by clicking in the columns and selecting options from the pop-up menus that appear. Here is a brief description of the columns:

Left bracket

This is used for “bracketing” several lines together when creating conditions with multiple lines and the boolean operators And/Or.

Filter Target

Here you select which property to look for when finding elements. Your choice here affects the available options in the other columns as well, see below!

Condition

This determines how the Project Logical Editor compares the property in the Filter Target column to the values in the Parameter columns. The available options depend on the Filter Target setting.
Parameter 1

Here you set which value the element properties are compared to (depending on the Filter Target).

For example, if the Filter Target is “Position” and Condition is “Equal”, the Project Logical Editor will look for all elements starting at the position you specify in the Parameter 1 column.

Parameter 2

This column is only used if you have selected one of the “Range” options in the Condition column. Typically, this allows you to find all elements with values inside (or outside) the range between Parameter 1 and Parameter 2.

Bar Range/Time Base

This column is only used if the Filter Target is set to “Position”. If one of the “Bar Range” options is selected in the Condition column, you use the Bar Range/Time Base column to specify “zones” within each bar (allowing you to find all elements on or around the first beat of every bar, for example). If any of the other Condition options is selected, you can use the Bar Range/Time Base column to specify the time base (PPQ, Seconds, etc.).

Right bracket

This is used for “bracketing” several lines together.

bool

This allows you to insert the boolean operators And/Or, when creating conditions with multiple lines.

Below, the different Filter Targets (and their corresponding Condition and Parameter options) are described in more detail.

**RELATED LINKS**

- Searching for elements at certain positions on page 888
- Combining multiple condition lines on page 892

### Searching for Media types

**PROCEDURE**

1. Select “Media Type” in the Filter Target pop-up menu. This allows you to find elements of certain types of media only.
2. Open the pop-up menu in the Parameter 1 column and select the desired option.
3. Open the pop-up menu in the Condition column and select the desired condition.

For example, if you have set up the Project Logical Editor like this…

<table>
<thead>
<tr>
<th>Filter Target</th>
<th>Condition</th>
<th>Parameter 1</th>
<th>Parameter 2</th>
<th>Bar Range/Time Base</th>
</tr>
</thead>
<tbody>
<tr>
<td>Marker Events</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

…it will find all marker events and tracks in the project.
Media type filter

When the Filter Target is set to Media Type, the pop-up menu lists the available media types.

Audio
If no container type is specified, this finds audio events, audio parts and audio tracks.

MIDI
If no container type is specified, this finds MIDI parts and MIDI tracks.

Automation
If no container type is specified, this finds automation events and automation tracks.

Marker
If no container type is specified, this finds marker events and marker tracks.

Transpose
If no container type is specified, this finds transpose events and transpose tracks.

Arranger
If no container type is specified, this finds arranger events and arranger tracks.

Tempo
If no container type is specified, this finds tempo events and tempo tracks.

Signature
If no container type is specified, this finds signature events and signature tracks.

Chord
If no container type is specified, this finds chord events and chord tracks.

Scale Event
If no container type is specified, this finds scale events.

Video
If no container type is specified, this finds video events.

Group
If no container type is specified, this finds group tracks.

Effect
If no container type is specified, this finds FX channel tracks.
For media types, the following options are available:

**Equal**
This finds the Media Type set up in the Parameter 1 column.

**All Types**
This finds all Media Types.

### Searching for Container types

**PROCEDURE**

1. Select Container Type in the Filter Target pop-up menu.
   This allows you to find parts, events or tracks.

2. Open the pop-up menu in the Parameter 1 column and select the desired option.

3. Open the pop-up menu in the Condition column and select the desired condition.
   For example, if you have set up the Project Logical Editor like this…

   ![Filter Target Conditions](image)

   …it will find all Folder tracks in the project.

### Container type filter

When the Filter Target is set to Container Type, the pop-up menu lists the available container types.

**Folder Track**
This finds all folder tracks, included FX Channel and Group Channel folders.

**Track**
This finds all track types.

**Part**
This finds audio, MIDI, and instrument parts. Folder parts will not be found.

**Event**
This finds automation points, markers, as well as audio, arranger, transpose, tempo and time signature events.

For container types, the following options are available:

**Equal**
This finds the Container Type set up in the Parameter 1 column.
All Types
This finds all Container Types.

Combining Media Type and Container Type

The combination of the filter targets Media Type and Container Type represents a versatile tool for logical operations:

Here, the Project Logical Editor will find all MIDI and instrument parts in the project.

Here, the Project Logical Editor will find all automation tracks (not events) in the project whose name contains vol.

Here, the Project Logical Editor will find all MIDI and instrument parts (not tracks) in the project that are muted.

Here, the Project Logical Editor will find all MIDI and instrument parts (not tracks) or all audio events (not parts or tracks) in the project that are muted.

Searching for Names

PROCEDURE
1. Select Name on the Filter Target pop-up menu.
2. Enter the desired name, or a part of a name in the Parameter 1 column.
3. Open the pop-up menu in the Condition column and select the desired condition.
   For names, the following options are available:
   • Equal
     This is the exact same text string as set up in the Parameter 1 column.
   • Contains
     This contains the text specified in the Parameter 1 column.
For example, if you have set up the Project Logical Editor like this…

![Filter Conditions Table]

…it will find all tracks in the project whose name contains “voc”.

**NOTE**

To take maximum advantage of this feature, we recommend using a standard nomenclature in your projects (Drums, Perc, Voc, etc.).

### Searching for elements at certain positions

**PROCEDURE**

1. Select “Position” in the Filter Target pop-up menu.
   
   This allows you to find elements starting at certain positions, either relative to the start of the project or within each bar.

2. Open the pop-up menu in the Condition column and select the desired condition.
   
   • If you select any condition other than the Range, Bar Range, Cursor, Loop or Cycle options, you set up a specific position (in PPQ, seconds, samples, or frames) in the Parameter 1 column. Use the Bar Range/Time Base column to specify the time base. Note that the position for Bar Range is measured in ticks related to the start of the bar.

   ![Filter Conditions Table (Position)]

   Here, the Project Logical Editor will find all elements at the PPQ position 5.1.1. in the project.

   • If you select Inside Range or Outside Range in the Condition column, you set the start position of the range in the Parameter 1 column and the end position in the Parameter 2 column. You can also change the time base using the Bar Range/Time Base column.

   The Project Logical Editor will then find all elements inside or outside this position range.

   • If you select one of the Bar Range options in the Condition column, the Bar Range/Time Base column will show a graphic bar display. You specify the range within the bar by clicking and dragging in the bar display (the specified Bar Range is indicated in blue).

   ![Filter Conditions Table (Bar Range)]

   Here, the Project Logical Editor will find elements starting around the second beat in each bar.

   The Project Logical Editor will then find all elements starting inside or outside this Bar Range, in all bars (within the current selection).
Position filter

For positions, the following options are available:

Equal
…has the exact same value as set up in the Parameter 1 column.

Unequal
…has any value other than the one set up in the Parameter 1 column.

Bigger
…has a value higher than the one set up in the Parameter 1 column.

Bigger or Equal
…has a value that is the same as or higher than the one set up in the Parameter 1 column.

Less
…has a value lower than the one set up in the Parameter 1 column.

Less or Equal
…has a value that is the same as or lower than the one set up in the Parameter 1 column.

Inside Range
…has a value that is between the values set up in the Parameter 1 and Parameter 2 columns. Note that Parameter 1 should be the lower value and Parameter 2 the higher.

Outside Range
…has a value that is not between the values set up in the Parameter 1 and Parameter 2 columns.

Inside Bar Range
…is within the “zone” set up in the Bar Range/Time Base column, in each bar within the current selection.

Outside Bar Range
…is outside the “zone” set up in the Bar Range/Time Base column, in each bar within the current selection.

Before Cursor
…is before the song Project position.

Beyond Cursor
…is after the song Project position.

Inside Track Loop
…is inside the set track loop.
Inside Cycle
…is inside the set cycle.

Exactly Matching Cycle
…exactly matches the set cycle.

RELATED LINKS
Setting Up the Independent Track Loop on page 496

Searching for elements of certain lengths

PROCEDURE
1. Select Length in the Filter Target pop-up menu.
   This allows you to find elements of a certain length only. The Length parameter is interpreted via the time base setting in the Bar Range/Time Base column, i.e. in PPQ, seconds, samples, or frames.
2. Open the pop-up menu in the Condition column and select the desired condition.
   Here, the Project Logical Editor will find all audio parts and events in the project with a length smaller than 200 samples.
   If you select any condition other than the Range options, you set up a specific position in the Parameter 1 column.

Lengths filter

For lengths, the following options are available:

Equal
…has the exact same value as set up in the Parameter 1 column.

Unequal
…has any value other than the one set up in the Parameter 1 column.

Bigger
…has a value higher than the one set up in the Parameter 1 column.

Bigger or Equal
…has a value that is the same as or higher than the one set up in the Parameter 1 column.

Less
…has a value lower than the one set up in the Parameter 1 column.
Less or Equal

...has a value that is the same as or lower than the one set up in the Parameter 1 column.

Inside Range

...has a value that is between the values set up in the Parameter 1 and Parameter 2 columns. Note that Parameter 1 should be the lower value and Parameter 2 the higher.

Outside Range

...has a value that is not between the values set up in the Parameter 1 and Parameter 2 columns.

Searching for properties

**PROCEDURE**

1. Select “Property” on the Filter Target pop-up menu.
2. Open the pop-up menu in the Condition column and select the desired condition.
   When the Property option is selected, the Condition column has two options: “Property is set”, and “Property is not set”.
3. Open the pop-up menu in the Parameter 1 column and select the desired option.
   This sets which property will be searched.
   Three examples:

   ![Example 1](image1.png)
   Here, the Project Logical Editor will find all muted MIDI and instrument parts.

   ![Example 2](image2.png)
   Here, the Project Logical Editor will find all elements that are selected but not muted.

   ![Example 3](image3.png)
   Here, the Project Logical Editor will find all selected audio parts that are empty.

**NOTE**

Note that “event” in this context refers to all the Project window elements that can be modified, e.g. MIDI parts, audio events and parts, or transpose, arranger, and automation events.
Combining multiple condition lines

As described above, you can add condition lines by clicking the “+” button below the list. The result of combining condition lines depends on the boolean And/Or operators and the brackets.

The bool column

By clicking in the “bool” column to the right in the list, you can select a boolean operator: “And” or “Or”. A boolean operator combines two condition lines and determines the result in the following way:

- If two condition lines are combined with a boolean And, both conditions must be fulfilled for an element to be found.

  The Project Logical Editor will only find MIDI tracks.

- If two condition lines are combined with a boolean Or, at least one of the conditions must be fulfilled for an element to be found.

  The Project Logical Editor will find all parts or events that match exactly the cycle.

IMPORTANT

When you add a new condition line, the boolean setting defaults to And. Therefore, if all you want to do is set up two or more conditions that all must be met for an element to be found, you do not have to think about the boolean column – just add the required lines and make the usual filter settings.

Using brackets

The bracket (parenthesis) columns let you enclose two or more condition lines, dividing the conditional expression into smaller units. This is only relevant when you have three or more condition lines and want to use the boolean Or operator.

You add brackets by clicking in the bracket columns and selecting an option. Up to triple brackets can be selected.

- Without brackets, the conditional expressions are evaluated according to their order in the list.

  Here, the Project Logical Editor will find all audio parts and events whose name contains perc as well as other parts and events (e.g. MIDI parts) whose name contains drums.
Maybe you want to find all audio parts and events that either contain the name perc or the name drums, but no other parts or events that contain the name drums? Then you need to add some brackets:

Here, all audio parts or events will be found whose name contains perc or drums.

**NOTE**

Expressions within brackets are evaluated first.

If there are several layers of brackets, these are evaluated “from the inside out”, starting with the innermost brackets.

### Specifying actions

The lower list in the Project Logical Editor window is the action list. This is where you specify any changes that are made to the found elements, relevant for the function type Transform.

You can perform two different kinds of actions: track-based actions (such as Track Operation, Name) and event-based actions (such as Position, Length, Name). There are also actions that only take effect on automation data (Trim).

The handling of the action list is similar to the filter condition list, but without the brackets and boolean operators. You simply add lines by clicking the “+” button, and fill out the columns as required. To remove a superfluous action line, select it and click the “-” button.

### Action Target

This is where you select the property that is changed. The Operations determine what to do with the Action Target. Below, all available operations are listed:

#### Position

Adjusting this value will move the elements. This parameter is interpreted via the time base setting in the Bar Range/Time Base column, with the exception of the Random setting, which uses the time base of the affected events:

**Add**

Adds the value specified in the Parameter 1 column to the Position.
**Subtract**
Subtracts the value specified in the Parameter 1 column from the Position.

**Multiply by**
Multiplies the Position value with the value specified in the Parameter 1 column.

**Divide by**
Divides the Position value by the value specified in the Parameter 1 column.

**Round by**
This “rounds” the Position value using the value specified in the Parameter 1 column. In other words, the Position value is changed to the closest value that can be divided by the Parameter 1 value.

For example, if the Position value is 17 and Parameter 1 is 5, the result of rounding will be 15 (the closest value that can be divided by 5). Another word for this type of operation would be “quantizing”, and it is actually possible to use it for this, by specifying a quantize value with Parameter 1 (in ticks, with 480 ticks per quarter note).

**Set relative Random Values between**
This will add a random value to the current Position value. The added random value will be within the range specified with Parameter 1 and 2. Note that these can be set to negative values.

For example, if you set Parameter 1 to -20 and Parameter 2 to +20, the original Position value will get a random variation, never exceeding ±20.

**Set to fixed value**
This sets the Position to the value specified in the Parameter 1 column.

**Length**

Lets you resize the elements. This parameter is interpreted via the time base setting in the Bar Range/Time Base column, with the exception of the Random setting, which uses the time base of the affected events:

**Add**
Adds the value specified in the Parameter 1 column to the Length.

**Subtract**
Subtracts the value specified in the Parameter 1 column from the Length.

**Multiply by**
Multiplies the Length value with the value specified in the Parameter 1 column.

**Divide by**
Divides the Length value by the value specified in the Parameter 1 column.
Round by
This “rounds” the Length value using the value specified in the Parameter 1 column. In other words, the Length value is changed to the closest value that can be divided by the Parameter 1 value.

Set to fixed value
This sets the Length to the value specified in the Parameter 1 column.

Set Random Values between
This will add a random value to the current length. The added random value will be within the range specified with Parameter 1 and 2.

Track Operation
This lets you change the track status.

Folder
Opens, closes or toggles folders.

Record
Enables, disables or toggles the record enable status.

Monitor
Enables, disables or toggles the monitor status.

Solo
Enables, disables or toggles the solo status.

Mute
Enables, disables or toggles the mute status.

Read
Enables, disables or toggles the read enable status.

Write
Enables, disables or toggles the write enable status.

EQ Bypass
Enables, disables or toggles the EQ bypass status.

Inserts Bypass
Enables, disables or toggles the inserts bypass status.

Sends Bypass
Enables, disables or toggles the sends bypass status.

Lanes Active
Enables, disables or toggles the lanes active status.
**Hide Track**

Enables, disables or toggles the track visibility status.

**Name**

This lets you rename the found elements.

**Replace**

Replaces names with the text specified in the Parameter 1 column.

**Append**

Names will be appended with the string specified in the Parameter 1 column.

**Prepend**

The name will be prepended with the string specified in the Parameter 1 column.

**Generate Name**

The name will be replaced by the text specified in the Parameter 1 column, followed by the number set with Parameter 2. The number will be increased by 1 for every found element.

**Replace Search String**

You can specify a search string under Parameter 1 that is replaced by the text specified in the Parameter 2 column.

**Trim**

This Action Target is used for automation only and lets you trim the found elements.

**Multiply by**

Multiplies the Trim value with the value specified in the Parameter 1 column.

**Divide by**

Divides the Trim value by the value specified in the Parameter 1 column.

**Set Color**

This lets you set the color for an element. For this Action Target the only Operation available is “Set to fixed value”. To use this, insert the name of a track color in the Parameter 1 column, e.g. “Color 7” to use dark green as track color.

**Selecting a function**

The left pop-up menu at the bottom of the Project Logical Editor is where you select the function – the basic type of editing to be performed.
The available options are:

**Delete**

Deletes all elements found by the Project Logical Editor.

**NOTE**

When you delete automation tracks and undo this operation by selecting Undo from the Edit menu, the automation tracks will be restored, but the tracks will be closed.

**Transform**

Changes one or several aspects of the found elements. You set up exactly what is changed in the action list.

**Select**

This will simply select all found elements, highlighting them for further work in the Project window.

### Applying Macros

In the Macro pop-up menu you can select a macro that will be executed automatically after completing the actions defined using the Filter and Action lists. This is useful if you would like to extend the already powerful Project Logical Editor features even further.

To use this, you set up the macro that you need in the Key Commands dialog and then select it in the Project Logical Editor from the Macro pop-up menu.

For example, you can use the filter conditions to select all tracks that contain automation data for a certain automation parameter (such as "volume") and use the macro “Select all on Track + Delete” to remove the automation events from these tracks (without deleting the tracks themselves).

**RELATED LINKS**

- Setting up key commands on page 998

### Applying the defined actions

Once you have set up filter conditions, selected a function and set the required actions (or loaded a preset), you apply the actions defined with the Project Logical Editor by clicking the Apply button.
Project Logical Editor operations can be undone just like any other editing.

**Working with presets**

The Presets section in the upper left section of the window allows you to load, save and manage Project Logical Editor presets. A preset contains all settings in the window, which means you can simply load a preset, edit the settings (if necessary) and click Apply.

- To load a preset, select it from the Presets pop-up menu. If available, an explanatory text appears to the right of the menu. When setting up your own presets, you can click in this area to enter a description.
- You can also open the Edit menu and select Presets directly from the “Process Project Logical Editor” submenu. This allows you to apply a preset directly, without having to open the Project Logical Editor.

**RELATED LINKS**

- [Key Commands on page 997](#)

**Storing your own settings as a preset**

If you have made Project Logical Editor settings that you want to use again, you can save them as a preset:

**PROCEDURE**

1. Click the Store Preset button to the right of the Presets pop-up menu. A dialog for specifying a name for the new preset is displayed.
2. Enter a name for the preset and click OK. The preset is stored.

**NOTE**

To remove a preset, load it and click the Remove Preset button.

**Organizing and sharing presets**

The Project Logical Editor presets are stored within the application folder in the Presets\Logical Edit Project subfolder. While these files cannot be edited manually, you can reorganize them (e.g. putting them in subfolders) like any files.

This also makes it easy to share presets with other Cubase users, by transferring the individual preset files.

**NOTE**

The list of presets is read each time the Project Logical Editor is opened.
Setting up key commands for your presets

If you have stored Project Logical Editor presets, you can set up key commands for them:

**PROCEDURE**

1. Open the File menu and select “Key Commands…”.
   The Key Commands dialog opens.
2. Use the list in the Commands column to navigate to the category “Process Project Logical Editor” and click the “+” sign to display the items in the folder.
3. In the list, select the item to which you wish to assign a key command, click in the “Type in Key” field and enter a new key command.
4. Click the Assign button above the field.
   The new key command appears in the Keys List.
5. Click OK to exit the dialog.

**RELATED LINKS**

Key Commands on page 997
Editing tempo and signature

Background

Whenever you create a new project, Cubase will automatically set the tempo and time signature for this project. The tempo and signature settings can be displayed in two ways: either on dedicated tracks in the Project window or in the Tempo Track Editor.

Tempo modes

Before we go into detail about tempo and signature settings, you should understand the different tempo modes.

For each track in Cubase that can make use of this function, you can specify whether it is time-based or tempo-based. For tempo-based tracks, the tempo can either be fixed throughout the entire project (this is called “fixed tempo mode”) or follow the tempo track (this is called “tempo track mode”), which may contain tempo changes.

• To switch between fixed tempo mode and tempo track mode, use the Tempo button on the Transport panel:

![Tempo button](image)

When the Tempo button is lit (and the text “Track” is shown), the tempo follows the tempo track; when it is deactivated (and the text “Fixed” is shown), a fixed tempo is used. You can also switch the tempo mode with the Activate Tempo Track button on the Tempo Track Editor toolbar.

In tempo track mode, the tempo cannot be changed on the Transport panel, i.e. the tempo information here is for display purposes only.

Signature events are always active, regardless of whether fixed tempo mode or tempo track mode is selected.

RELATED LINKS

- Defining the Track Time Base on page 149
- Setting the fixed tempo on page 907
A note about tempo-based audio tracks

For tempo-based tracks, the start position of audio events on the timeline depends on the current tempo setting. However, it is important to realize that the actual audio ("within" the events) will play back as recorded, regardless of any tempo changes you make. Therefore, it is good practice to make the proper tempo and time signature settings before you start recording tempo-based audio.

- To make an already recorded audio track follow the tempo changes, you can use the Tempo Detection Panel or the Sample Editor.
- To adapt the tempo track to time-based material, you can use the Time Warp tool.
  This allows you to adjust the tempo track so that tempo-based material (e.g. positions in music) coincides with time-based material (positions in narration, video, etc.).

RELATED LINKS
- Tempo Detection (Cubase Pro only) on page 920
- Sample Editor on page 432
- The Time Warp tool (Cubase Pro only) on page 913

Tempo and signature display

You can view the current tempo and signature settings of your project in a number of ways:

- On the Transport panel.
- By displaying the tempo track and the signature track in the Project window.
  Open the Project menu, select Add Track and the Signature and/or Tempo options.
- In the Tempo Track Editor.
  Open the Project menu and select Tempo Track, or [Ctrl]/[Command]-click the Tempo button on the Transport panel.

RELATED LINKS
- Transport Panel on page 196

About the tempo and signature tracks

The tempo track and the signature track allow you to view and edit tempo and signature data in the project context.
The Inspectors for these tracks show the positions and values of individual tempo curve points or signature events.

The signature track’s background always shows bars. This is independent of the ruler display format setting.

In the track list for the tempo track, on the far right, you can specify the display range by clicking on the numbers at the top or bottom and dragging up or down.

Note that this does not change the tempo setting, but changes the display scale of the tempo track.

You can lock the tempo track and the signature track to prevent unintentional editing.

Simply click the lock symbols in the track list to lock/unlock the tracks.

### About the Tempo Track Editor

1) Time Signature area
2) Tempo curve display

If you do not want to display two extra tracks in the Project window, you can also open the Tempo Track Editor to view and edit tempo and signature information.

The Tempo Track Editor has a toolbar, info line, and ruler just like other editors in Cubase, plus an area for the display of time signature events and a tempo curve display.
The toolbar

The toolbar contains various tools and settings:

1) Activate Tempo Track
2) Show Info
3) Tools
4) Auto-Scroll
5) Suspend Auto-Scroll when Editing
6) Snap on/off
7) Snap value
8) The selected tempo
9) Curve type for new tempo events
10) Tempo recording slider (Cubase Pro only)
11) Open Process Tempo dialog (Cubase Pro only)
12) Open Process Bars dialog (Cubase Pro only)

- The tools for Object Selection, Erase, Zoom and Draw are used in the same way as in other editors. The Snap and Auto-Scroll functions also work exactly like in the Project window.
  Note that in the Tempo Track Editor, the Snap function affects tempo events only. Time signature events always snap to the beginning of bars.

- The info line in the Tempo Track Editor allows you to change settings for selected time signature events, and the type and tempo of selected tempo curve points.

- The ruler in the Tempo Track Editor shows the timeline, and is similar to the ruler in the Project window.

- The area below the ruler shows time signature events.

- The main display shows the tempo curve (or, if fixed tempo mode is selected, the fixed tempo). To the left of the display you will find a tempo scale to help you quickly locate the desired tempo.
  Note that the vertical “grid lines” in the tempo curve display correspond to the display format selected for the ruler.

Related links

Ruler on page 48
Setting the fixed tempo on page 907
Editing tempo and signature

You can use the options of the Tempo Track Editor or the tempo and signature tracks to edit tempo and signature settings. The descriptions given below are valid in both cases. The only exception is the tempo recording slider, which is available only in the Tempo Track Editor.

RELATED LINKS
Recording tempo changes (Cubase Pro only) on page 907

Editing the tempo curve

IMPORTANT
This section assumes that you are working in tempo track mode, i.e. the Tempo button must be activated on the Transport panel.

Adding tempo curve points

PROCEDURE
1. Use the “Type of New Tempo Points” pop-up menu (on the toolbar of the Tempo Track Editor) or the “Type of New Tempo points” pop-up menu in the track list for the tempo track to select whether you want the tempo to change gradually from the previous curve point to the new one (“Ramp”) or change instantly to the new value (“Jump”).
   You can also set this to Automatic. In this case, the types of existing tempo curve points will be used when inserting new points at the same position.
2. Select the Draw tool.
3. Click and drag in the tempo curve display to draw a tempo curve.
   When you click, the tempo display on the toolbar shows the tempo value. If Snap is activated on the toolbar, this determines at which time positions you can insert tempo curve points.
You can also click on the tempo curve with the Object Selection tool. This adds a single point with each click.

**NOTE**

Tempo values can also be automatically inserted by the Beat Calculator.

**RELATED LINKS**

The Beat Calculator on page 911
Snap Function on page 62

**Selecting tempo curve points**

Curve points can be selected as follows:

- Using the Object Selection tool.
  The standard selection techniques apply.

- Using the Select submenu of the Edit menu.
  The options are:

  **All**
  Selects all curve points on the tempo track.

  **None**
  Deselects all curve points.

  **Invert**
  Inverts the selection – all selected curve points are deselected and all curve points that were not selected are selected instead.

  **In Loop**
  Selects all curve points between the left and right locator.

  **From Start to Cursor**
  Selects all points to the left of the project cursor.

  **From Cursor to End**
  Selects all points to the right of the project cursor.

- You can also use the left and right arrow keys on the computer keyboard to go from one curve point to the next.
  If you press [Shift] and use the arrow keys, you can select several points at the same time.
**Editing tempo curve points**

Curve points can be edited in the following ways:

- By clicking and dragging horizontally and/or vertically with the Object Selection tool.
  
  If several points are selected, all of them are moved. If Snap is activated on the toolbar, this determines to which time positions you can move curve points.

- By adjusting the tempo value in the tempo display on the Tempo Track Editor toolbar, in the Inspector, or on the info line.

**NOTE**

Selecting several points and changing the tempo value in the info line leads to a relative adjustment of the tempo values.

**IMPORTANT**

We recommend using the Bars+Beats display format when editing tempo curves. Otherwise, you may get confusing results. This is because moving a point will change the relationship between tempo and time. If you move a tempo point to the right and drop it at a certain time position, the mapping between tempo and time will be adjusted. Since you have changed the tempo curve, the moved point will appear at another position.

**RELATED LINKS**

- [Snap Function on page 62](#)

**Adjusting the curve type**

You can change the curve type of a tempo curve segment at any time, using the following method:

**PROCEDURE**

1. With the Object Selection tool, select all curve points within the segment you want to edit.

2. In the info line, click below the word “Type” to switch the curve type between “Jump” and “Ramp”.

   The curve sections between the selected points are adjusted.
Removing tempo curve points

To remove a curve point, either click on it with the Erase tool or select it and press [Backspace]. The first tempo curve point cannot be removed.

Recording tempo changes (Cubase Pro only)

The Tempo Recording slider on the toolbar of the Tempo Track Editor allows you to record tempo changes “on the fly”: simply start playback and use the slider to raise or lower the tempo at the desired positions. This is useful for creating natural sounding ritardandos, etc.

Setting the fixed tempo

When the tempo track is deactivated, the tempo track curve is grayed out (but still visible). Since the tempo is fixed throughout the whole project, there are no tempo curve points. Instead, the fixed tempo is displayed as a horizontal black line in the tempo curve display.

To set the tempo in fixed mode:

- Adjust the value numerically in the tempo display on the Tempo Track Editor toolbar or in the track list.
- On the Transport panel, click on the tempo value to select it, enter a new value and press [Enter].

Adding and editing time signature events

- To add a time signature event, click with the Draw tool in the time signature area or time signature track. This adds a default 4/4 time signature event at the closest bar position.
- To edit the value of a time signature event, select it and adjust the value on the info line, or double-click the event and enter a new value. Note that there are two controls for the signature display; the left one adjusts the numerator and the right one adjusts the denominator.
Editing tempo and signature

Process Tempo (Cubase Pro only)

- To move a time signature event, click and drag it with the Object Selection tool.
  Note that you can [Shift]-click to select multiple events. Also note that time signature events can only be positioned at the start of bars. This is also true if Snap is deactivated.

- To remove a time signature, either click on it with the Erase tool or select it and press [Backspace] or [Delete].
  The first time signature event cannot be removed.

Exporting and importing tempo tracks (Cubase Pro only)

You can export the current tempo track for use in other projects by selecting “Tempo Track” from the “Export” submenu of the File menu. This allows you to save the tempo track information (including time signature events) as a special XML file (file extension “.smt”).

To import a tempo track, select “Tempo Track” from the Import submenu of the File menu. Note that this replaces all tempo track data in the current project (although the operation can be undone if needed).

Process Tempo (Cubase Pro only)

Process Tempo allows you to define a specific length or end time for a set range, and the tempo track will automatically set a tempo that will fit the range in the specified time.

PROCEDURE

1. Specify a region or range that you wish to process by setting the left and right locators, either in the Tempo Track Editor or in the Project window.

2. Click on the Process Tempo button (either in the Tempo Track Editor or on the tempo track).
  The Process Tempo dialog opens.
3. In the Process Range fields, the specified range is shown, in Bars and Beats (PPQ) and in a time format, which can be selected from the Time Display Format pop-up menu.

The range defined in step 1 will already be set, but you can edit the range by adjusting the values in the Process Range fields if you wish.

Now you can either specify a new range length or a new range end time. What to choose depends on whether the range should have a specific length or whether it should end at a specific time position.

4. Enter the desired End or Length in the corresponding fields of the New Range section.

You can select a time format for the new range in the Time Display Format pop-up menu.

5. Click Process.

Now the tempo track is automatically adjusted, and the range will have the specified duration.

---

The Process Bars dialog (Cubase Pro only)

The Process Bars dialog (opened from the Tempo Track Editor or the signature track) uses the global “Insert Silence” and “Delete Time” functions from the Range submenu of the Edit menu. However, the necessary ranges (or parameters) are calculated using a musical “bars+beats-based” environment. The function also ensures that the time signatures stay “in sync” after these operations. This allows for a much more intuitive approach when inserting, deleting or replacing “time” while working with a project set to the Bars+Beats time type.

The dialog contains the following elements:

**Bar Range**

The Bar Range display shows the bar range within the project as well as its length. Click on the right edge of the green indicator and drag it to the right to enlarge the range. You can also use the Start and Length value fields (see below).

The arrow pair in this section marks the length of the current project. The area to the right marks the bar range that can be added (10,000 bars max.).

**Bar Range – Start**

This is where you specify the start position for the bar range. Click on the arrows to raise/lower the value or click directly in the value field to enter the value manually.
Bar Range – Length

This is where you specify the length of the bar range. Click on the arrows to raise/lower the value or click directly in the value field to enter the value manually.

Action – Insert Bars

When you select this action, clicking the Process button will insert the specified number of empty bars with the set time signature at the start position specified above.

Action – Delete Bars

When you select this action, clicking the Process button will delete the specified number of bars, beginning at the start position specified above.

Action – Reinterpret Bars

When you select this action, clicking the Process button will reinterpret the bar range to fit the specified time signature. This is very special in the sense that both bars+beats positions of the notes and the tempo are being changed to fit the new time signature, but the playback of the notes will stay just the same.

For example, if you want to reinterpret a bar with the time signature 3/4 so that it gets the time signature 4/4, quarter notes will become half note triplets. If you reinterpret a bar with the time signature 4/4 to attain 3/4, you will get quadruplets.

Action – Replace Bars

When you select this action, clicking the Process button will cause the time signature of the specified bar range to be replaced by the one you specify in this dialog.

Action – Signature

This lets you specify the time signature for the action you select on the Action pop-up menu (except for the Delete Bars action).

Process

Click on this button to apply your changes to the specified bar range.

Close

Clicking this button without clicking on “Process” first will close the dialog without applying your settings.
The Beat Calculator

The Beat Calculator is a tool for calculating the tempo of freely recorded audio or MIDI material. It also allows you to set the tempo by tapping.

Calculating the tempo of a recording

**PROCEDURE**

1. In the Project window, make a selection that covers an exact number of beats of the recording.
3. In the Beats field, enter the number of beats that the selection encompasses. The corresponding tempo is calculated and displayed in the BPM field. If you need to adjust the selection, you can go back to the Project window, leaving the Beat Calculator open. To re-calculate the tempo after adjusting the selection, click Refresh.
4. You can also insert the calculated tempo into the tempo track by clicking one of the buttons in the lower left corner of the Beat Calculator window. Clicking “At Tempo Track Start” will adjust the first tempo curve point, while “At Selection Start” will add a new tempo curve point at the selection’s start position, using the “Jump” curve type.

**IMPORTANT**

If fixed tempo mode is selected when you insert the calculated tempo, the fixed tempo will be adjusted, regardless of which button you click.

Related links

- Adding tempo curve points on page 904

Using Tap Tempo

The Tap Tempo function allows you to specify a tempo by tapping:

**PROCEDURE**

1. Open the Beat Calculator.
2. If you want to tap the tempo to some recorded material, activate playback.
3. Click the Tap Tempo button.
The Tap Tempo window appears.

4. Tap the tempo on the Spacebar of the computer keyboard or with the mouse button.
The tempo display will update the calculated tempo between each tap.

5. Click OK to close the Tap Tempo dialog.
The tapped tempo is now shown in the Beat Calculator's BPM display. You can insert it into the tempo track as described above.

---

**Merge Tempo From Tapping (Cubase Pro only)**

This function allows you to create a complete tempo track based on your tapping. Typically, you would use this if you have an audio file with no tempo mapping and want to be able to add other material afterwards, etc.

**PROCEDURE**

1. Create an empty time-based MIDI track and, while playing back your audio material, tap the new tempo on your MIDI keyboard and record the created notes onto the new MIDI track.
   Note that you must create note events – pedal events cannot be used for this function.

2. Play back the audio and check that the timing of the MIDI notes corresponds to that of the audio.
   If necessary, edit the MIDI notes in an editor.

3. Select the MIDI part (or the individual notes in an editor) that you want to use for the calculation.

4. Select “Merge Tempo From Tapping” from the Functions submenu of the MIDI menu.
   A dialog opens.

5. In the dialog, specify what type of note (1/2, 1/4, etc.) you tapped during the recording.
   If you activate the “Begin at Bar Start” option, the first note will automatically start at the beginning of a bar when calculating the new tempo curve.

6. Click OK.
The project’s tempo is adjusted to the tapped notes.
7. Open the Project menu and select “Tempo Track” to check that the new tempo information is reflected in the tempo curve.

NOTE

Another way of creating a tempo map for freely recorded audio would be to use the Time Warp tool, see below.

The Time Warp tool (Cubase Pro only)

The Time Warp tool lets you adjust the tempo track so that “musical time-based” material (positions related to the tempo) matches “linear time-based” material (positions in time). Some typical applications:

- When you have recorded music (audio or MIDI) without tempo reference or metronome click, the Time Warp tool can be used for creating a tempo map that fits the recording (allowing you to rearrange or add other material).
- When you are creating music for a movie and want to match certain positions in the video with certain positions in the music.

The Time Warp tool makes use of the fact that tracks can be based on time positions (linear time base) or positions related to tempo (musical time base).

RELATED LINKS

Defining the Track Time Base on page 149

Basic procedure

You use the Time Warp tool to drag a musical position (a position in bars+beats format) to a certain position in time. This can be done in the Project window or in an editor, as described below. Here is the general procedure:

PROCEDURE

1. Make sure tempo track mode is active. You cannot use the Time Warp tool in fixed tempo mode.
2. Select the Time Warp tool.

Bars+Beats format is automatically selected for the ruler in the active window, and the ruler is shown in brown.

3. Click in the window at a musical position and drag it so that it matches a position in the material you are editing – e.g. the start of an event, a certain “hit” within an audio event, a frame in a video clip, etc.

When you click with the Time Warp tool, it snaps to the grid in the window.
Editing tempo and signature
The Time Warp tool (Cubase Pro only)

Dragging the start of the bar to the start of the audio event.

While you are dragging, the track(s) you are editing are temporarily switched to linear time base. This means that the contents of the tracks remain at the same time positions regardless of the tempo (there is an exception to this in the Project window, see below).

4. When you release the mouse button, the musical position you clicked on matches the time position you dragged it to.

This is because the Time Warp tool changed the last tempo event on the tempo track (and/or added new ones, depending on window and usage), thereby scaling the tempo track to fit.

Rules

- When you use the Time Warp tool, the tempo value of the last tempo event (before the click position) is adjusted.
- If later tempo events exist, a new tempo event will be created at the click position. This way, the later tempo event(s) will not be moved.
- When you click with the Time Warp tool, it snaps to the tempo grid in the window.
- When you drag the tempo grid to a new position, it can be magnetic to events in the window.

   In the Project window, this requires that Snap is activated and “Events” is selected on the Snap Type pop-up menu – the grid will then snap to the start and end of events or parts, and to markers. In the Sample Editor, this requires that Snap is activated – the grid will then snap to hitpoints (if any). In the MIDI editors, this requires that Snap is activated – the grid will then snap to the start and end of notes.
- The function will create tempo values up to 300bpm.

Viewing and adjusting tempo events

When you select the Time Warp tool, the ruler of the active window is shown in brown. Existing tempo events are shown in the ruler as “flags” with the tempo values displayed.
Editing tempo and signature
The Time Warp tool (Cubase Pro only)

This helps you see what’s going on, but you can also use this for editing the tempo track:

• If you press the create/erase modifier key (by default [Shift]) and click on a tempo event in the ruler, it is deleted.
  [Shift] is the default modifier for this – you can adjust this in the Preferences dialog (Editing–Tool Modifiers page).

• You can click on a tempo event in the ruler and drag to move it.
  This automatically edits the tempo value in the event so that elements to the right keep their positions.

• If you press [Alt]/[Option] and move (or delete) a tempo event in the ruler, the tempo value is not adjusted – this means elements to the right will be moved.
  This is the default modifier key for this – you can adjust it in the Preferences dialog (Editing–Tool Modifiers page).

Using the Time Warp tool in the Project window

In the Project window, there are two modes for the Time Warp tool. To select the desired option, click on the Time Warp tool and click again to open a context menu.

The available options are:

• Warp Grid
  This is the default mode. If you use it, all tracks are temporarily switched to linear time base. This means that all tracks will keep their absolute time positions when you adjust the tempo track.

• Warp Grid (musical events follow)
  If you use this mode, no tracks are switched to linear time base. This means that all tracks that are not set to linear time base will follow the changes you make to the tempo track.
Matching a musical score to video

Here’s an example of how to use the Time Warp tool in “musical events follow” mode. Let’s say you are creating the music for a film. You have a video track, an audio track with a commentary and some audio and/or MIDI tracks with your music. Now you want to match the position of a musical cue to a position in a video film. The musical cue is located in bar 33. There are no tempo changes in the project (yet).

**PROCEDURE**

1. Make sure tempo track mode is selected on the Transport panel.

2. Now you need to locate the position in the video. If you do not need very high precision, you can simply locate it by looking at the thumbnails on the video track – otherwise you can pinpoint the exact position and add a marker to the marker track (to which you can snap later).

   You can also make a note of the exact position and add an extra ruler track set to show the timecode (Cubase Pro only).

3. Make sure that the correct tracks are set to linear time base or musical time base, respectively.

   In our example, we want the video track and the audio track with a commentary voice-over to be linear time-based (as well as the marker track, if used). All other tracks should be set to musical time base. You change this by clicking the time base button in the track list or Inspector.

   ![Musical time base selected](image1)

   ![Linear time base selected](image2)

4. Set up the Grid Type pop-up menu as desired.

   When you click with the Time Warp tool, it snaps to the selected grid. In this case, you will find the musical cue at the start of bar 33, so we can set the grid to “Bar”.

   Note that this affects the snapping to the ruler (tempo grid) when you click! In addition, the tool can be “magnetic” to events in the Project window when you drag – for this, you need to activate the Snap function, open the Snap Type pop-up menu, and select “Events”.

   In our example, this would be useful if you created a marker at the desired position in the video – when you drag the grid (see below), it will snap to the marker.

5. Click on the Time Warp button and click again to open a pop-up menu.

6. Select the “Warp Grid (musical events follow)” mode.
7. Click in the event display at the start of bar 33 and drag to the desired position in the video.

As mentioned above, this can mean dragging to a position indicated by the thumbnails on the video track, to a marker on the marker track or to a time position on an additional ruler track (Cubase Pro only).

When you drag, the ruler is scaled – and the music tracks will follow.

8. Release the mouse button.

If you look in the ruler at the beginning of the project, you will see that the first (and only) tempo event has been adjusted.

9. Try playing back.

The musical cue should now happen at the correct position in the video.

Let’s say you need to match another cue to another position later on in the video. If you simply repeat this procedure, you will find that the first cue gets out of sync – since you are still changing the first (and only) tempo event on the tempo track!

You need to create a “lock point” – a tempo event at the first cue position:

10. Press [Shift] and click with the Time Warp tool in the event display at the cue position.

In our case, this is bar 33.

A tempo event (with the same value as the first one) is added at that position.

11. Now match the second musical cue to the correct video position by dragging the musical position to the desired time position as before.

The new tempo event is edited – the first tempo event is unaffected and the original cue is still matched.

If you know you are going to match several cues this way, make it a habit to press [Shift] each time you use the Time Warp tool to match positions.

This adds a new tempo event – that way, you do not have to add tempo events afterwards as described above.
About snapping

If Snap is activated in the Project window and “Events” is selected on the Snap Type pop-up menu, the Time Warp tool will be magnetic to events when you drag the tempo grid. This makes it easier to snap a tempo position to a marker, the start or end of an audio event, etc.

Using the Time Warp tool in an audio editor

Using the Time Warp tool in the Sample Editor or Audio Part Editor is different from using it in the Project window, in the following ways:

- When you use the Time Warp tool, a tempo event is automatically inserted at the beginning of the edited event or part. This tempo event will be adjusted when you warp the tempo grid with the tool.
  This means that material before the edited events will not be affected.

- Only the default mode for the Time Warp tool is available.
  This means that when you use the tool, the edited track is temporarily switched to linear time base.

Making a tempo map for a “free” recording

The following example shows how to use the Time Warp tool in the Sample Editor to create a tempo map matching freely recorded music. Let’s say you have recorded a drummer, playing without a metronome – this typically means the tempo varies ever so slightly. To be able to add more material and easily rearrange the recorded audio, you want the tempo in Cubase to match the recorded drum track:

**PROCEDURE**

1. If necessary, move the recorded event.
   Move it so that the first downbeat (“one”) happens at the start of the bar – zoom in if needed.

2. Open the drum recording in the Sample Editor and make sure Hitpoint mode is not selected.
   The Time Warp tool cannot be used in Hitpoint mode. However, if you have calculated hitpoints already, these will be visible when the Time Warp tool is selected (see below).

3. Set the zoom so that you can see the individual drum hits clearly.
   To achieve this type of “visual” beat matching, it is important to have a fairly clean recording, such as the drum track in this example.

4. Select the Time Warp tool.
   You have already matched the first downbeat with the start of a bar. However, if the recording starts before the first downbeat (with a fill, some silence, etc.), you want to “lock” the first downbeat so that it stays in position:
1. Press \([\text{Shift}]\) and click in the event at the position of the first downbeat (the start of the bar).

When you press \([\text{Shift}]\), the pointer turns into a pencil. Clicking adds a tempo event at the first downbeat – when you later adjust the tempo with the Time Warp tool, the first downbeat will stay in place. Note that if the event starts exactly on the first downbeat (no audio before the “one”), you do not need to do this. This is because a tempo event is automatically added at the start of the edited event.

2. Now, locate the start of the next bar in the ruler.

3. Click at that position in the event display and drag to the downbeat of the second bar in the recording.

When you click, the pointer will snap to the ruler grid.

By dragging the grid, you changed the tempo value in the tempo event at the first downbeat. If the drummer held a fairly consistent tempo, the following bars should now match pretty well, too.

4. Check the following bars and locate the first position where the audio drifts from the tempo.

Now, if you simply adjusted that beat in the tempo grid to match the beat in the recording, the tempo event at the first downbeat would be changed – this would ruin the match in the previous bars! We need to lock these by inserting a new tempo event.

5. Locate the last beat that is in sync.

This would be the beat just before the position where the audio and tempo drift apart.

6. Press \([\text{Shift}]\) and click at that position to insert a tempo event there.

This locks this matched position. The material to the left will not be affected when you make adjustments further along.

7. Now match the tempo grid to the next (unmatched) beat by clicking and dragging with the Time Warp tool.

The tempo event you inserted in step 10 will be adjusted.

8. Work your way through the recording this way – when you find that the recording drifts from the tempo, repeat steps 9 to 11 above.

Now the tempo track follows the recording and you can add more material, rearrange the recording, etc.

**Matching to hitpoints**

If you have calculated hitpoints for the audio event you are editing, these will be shown when the Time Warp tool is selected.

- The number of hitpoints shown depends on the Hitpoint Sensitivity slider setting you have made in Hitpoint mode.

- If you activate the Snap to Zero Crossing button on the toolbar, the Time Warp tool will snap to hitpoints when you drag the tempo grid.

- You can use the Create Markers from Hitpoints function (on the Hitpoints submenu of the Audio menu) to create markers at the hitpoint positions. This can be useful when using the Time Warp tool in the Project window, as the tool will be magnetic to markers (if the Snap Type is set to Events).
Using the Time Warp tool in a MIDI editor

This is very similar to using the tool in an audio editor:

- When you use the Time Warp tool, a tempo event is automatically inserted at the beginning of the edited part – this tempo event will be adjusted when you warp the tempo grid with the tool. Material before the edited part will not be affected.
- Only the default mode for the Time Warp tool is available. So when you use the tool, the edited MIDI track is temporarily switched to linear time base.
- The rulers in the MIDI editors can be set to “Time Linear” or “Bars+Beats Linear” mode – the Time Warp tool requires Time Linear mode. If necessary, the ruler mode will be switched when you select the Time Warp tool.
- If Snap is activated on the toolbar in the MIDI editor, the tool will snap to the start and end of MIDI notes when you drag the tempo grid.

Typically, you would use the Time Warp tool in a MIDI editor to match the Cubase tempo to freely recorded MIDI material (much like the audio example above).

RELATED LINKS
Changing the Display Format for the Ruler on page 688

Tempo Detection (Cubase Pro only)

Cubase offers a powerful tempo detection algorithm that can be used on any rhythmic musical content, even if it has not been recorded to a metronome click and/or contains tempo drift. This feature serves two main purposes:

- Analyzing the tempo of freely recorded material so that other (audio or MIDI) tracks can follow this tempo.
- Adjusting freely recorded material to the project tempo, which can be fixed or variable.

Requirements

- The audio event or MIDI part has to be at least 7 seconds long.
- The material must have discernible beats or rhythms.
- Audio events must be set to musical mode.
The Tempo Detection Panel

The Tempo Detection Panel contains the functions for analyzing the tempo of an audio event or MIDI part. It is opened via the Project menu.

In the top section of the panel, the name of the selected event or part is shown. Below the name, the Analyze button is located. Click this button to start the tempo detection.

The middle section contains several functions for correcting and fine-tuning the detected tempo curve.

The arrow buttons at the bottom right let you change the direction in which the algorithm will analyze the material during a manual correction operation. To work backwards, i.e. to reanalyze the beginning of the tempo curve, activate the left arrow button.

With the Reset button at the bottom left you can delete the complete analysis data and start again from scratch.

NOTE

The Tempo Detection Panel has to be opened specifically for the material that you want to analyze.

RELATED LINKS

Correcting and fine-tuning the detected tempo map on page 922
The beginning of the tempo curve needs to be corrected on page 924
Detecting the basic tempo of an audio event/MIDI part

**Procedure**

1. In the Project window, select the audio event/MIDI part that you want to analyze.
2. On the Project menu, select “Tempo Detection…”.
   The Tempo Detection Panel opens.
3. Click the Analyze button.

**Result**

- A rough tempo map based on the beat analysis is created for the selected audio clip.
- A tempo and a signature track are added to the project.
- The project will get a 1/4 signature, because the tempo detection only calculates a tempo based on beats, regardless of a musical signature. The signature can be modified later.
- The Time Warp Tool is selected for fine-tuning or adjusting the newly generated tempo map.

Depending on the rhythmic quality of the source material, the tempo analysis may directly lead to a perfect result. However, if this is not the case, you can apply the correction and fine-tuning functions. To find out whether such actions are necessary, activate the metronome click and play back the project.

Correcting and fine-tuning the detected tempo map

If the metronome click does not match the material perfectly, perform any of the following operations, depending on the situation.

**The detected tempo is too fast or too slow**

- To double or halve the detected tempo, use the “Multiply by 2” and “Divide by 2” buttons.
- To adjust the detected tempo with a factor of 3/4 or 4/3, use the “Multiply by 4/3” and “Multiply by 3/4” buttons.

Examples:

- If your material is twice as fast as the detected tempo, you can apply the “Multiply by 2” function.
- If your material contains dotted notes or triplets and the algorithm detects 3 beats where 4 are expected, you can apply the 4/3 conversion.
- If the actual signature is 2/4 and the algorithm detected 6/8 beats or vice versa, you can apply a 3/4 conversion combined with the “Multiply by 2” function.
The detected tempo has jumps and spikes although it should be steady

If you get the message that the algorithm has detected irregular tempo changes, even though you know that the material has a more or less steady tempo, you can use the “Smooth Tempo” function.

- To retrigger the tempo analysis based on the assumption that the material has a steady tempo, click the “Smooth Tempo” button.
  Irregular spikes or tempo changes are removed during this analysis.

The detected tempo is off by half a beat

In some cases, the offbeat of a rhythm might be dominant enough to confuse the beat detection algorithm resulting in an offset. In that case it is necessary to shift the tempo events.

- To shift the detected tempo events by half a beat, click the “Offbeat Correction” button.

The tempo was not detected properly for the whole event/part

Sometimes it is impossible for the algorithm to properly detect the tempo for the whole audio event/MIDI part because it contains sections played in a different tempo or has special rhythmic characteristics. Manual adjustments are then necessary to create a perfect tempo track.

To manually correct tempo events, proceed as follows:

**PROCEDURE**

1. With the Tempo Detection Panel still open, play the track from the beginning and listen to the click.
   It is useful to zoom in on the waveform so that the transients are visible. Using the stationary cursor could be useful as well.

2. Locate the first tempo event that is off. Use the Time Warp Tool to move this tempo event to the correct position.
   The material to the right of the corrected event or part will be reanalyzed and the tempo recalculated.

3. Continue listening to the audio or MIDI until you reach the next misplaced tempo event and repeat the manual correction procedure until you reach the end of the song.
The beginning of the tempo curve needs to be corrected

When you edit a tempo event, the tempo curve by default is reanalyzed from the point of editing towards the right. However, if the detection did not produce proper results at the beginning of the event or part, you can change the direction in which the algorithm works.

**PROCEDURE**

1. At the bottom of the Tempo Detection Panel, activate the left arrow button to change the direction of reanalysis.
2. Locate the first correct tempo event at the beginning of the audio/MIDI and use the Time Warp tool to move the corresponding tempo event slightly back and forth to trigger a backwards detection.

   The tempo at the beginning of the audio event/MIDI part is corrected and new tempo events are added where necessary.

The material contains sections with different tempos

In some cases, a track may include multiple sections with different tempo and the tempo detection might stop at the position of a tempo change or pause.

If the manual adjustment of individual tempo events does not give you the desired results for files with varying tempo, you can cut them at each major tempo change and perform the tempo detection for each of the resulting sections independently.

**NOTE**

Remember that each cut needs to have a length of at least 7 seconds.

Finishing

Once the tempo map is correct, close the Tempo Detection Panel. You can now set up signature events with the correct time signature.
Adjusting the audio to the project tempo

If you want freely recorded audio to follow a fixed tempo or a different project tempo, you can use the Set Definition From Tempo dialog to save the tempo information from the tempo track in the corresponding audio clips.

**PROCEDURE**

1. Select the audio events that you want to have follow the project tempo. For example, this could be the individual tracks in a multi-track drum session.
2. On the Audio menu, open the Advanced submenu and select the “Set Definition From Tempo…” option. The Set Definition From Tempo dialog opens.

   ![Set Definition From Tempo dialog](image)

   - Select whether you want to save the tempo information in the project file only or in the selected audio clips.
     Writing the definition into the audio files allows you to use these in other projects, complete with tempo information.
   - Select if you want to set all tracks to musical time base.
     If you do not activate this option, only the tracks containing the selected events are set to musical time base.
   - Click OK.
     The tempo information is now copied into the selected audio clips and the tracks are set to musical time base. Furthermore, Musical Mode is activated for the audio events.

   **IMPORTANT**
   If you have placed audio events referring to the same audio clip at different positions on the timeline and you apply the “Set Definition From Tempo” function simultaneously to these events, new audio files are written for all the events except the first.

**RESULT**

The audio tracks will now follow any tempo changes in the project. Therefore, you can disable the tempo track and set a fixed tempo for your project or edit the tempo track for a new tempo map.

Warping is applied to the events to match the tempo. By default, the “élastique Pro Time” time shifting algorithm is applied, which should lead to the best-quality results.

**RELATED LINKS**

*About time stretch and pitch shift algorithms on page 428*
Project Browser (Cubase Pro only)

Window Overview

The Project Browser window provides a list based representation of the project. This allows you to view and edit all events on all tracks by using regular value editing in a list.

1) Project Structure list
2) Time Format pop-up menu
3) Add pop-up menu and Add button
4) Filter pop-up menu
5) Event display
Opening the Project Browser

You open the Project Browser by selecting “Browser” from the Project menu. The Browser window can be open while you are working in other windows; any changes made in the Project window or an editor are immediately reflected in the Project Browser and vice versa.

Navigating in the Browser

You use the Project Browser much like you use the Windows Explorer/Mac OS Finder for browsing folders on your hard disk.

- Click on an item in the Project Structure list to select it for viewing. The contents of the item are shown in the event display.

- Items with hierarchical substructures can be folded out by clicking the “+” symbols or the “closed folder” symbols in the Project Structure list. When the substructure of an item is revealed, a “−” symbol or an “open folder” symbol is shown instead – click this to hide the substructure.

- To reveal or hide all substructures in the Project Structure list, use the buttons “(+) All” and “(−) All” above the list.

- The actual editing is done in the event display, using regular value editing techniques.
  There is one exception: You can rename items in the Project Structure list by clicking on a selected name and typing.

Customizing the view

You can drag the divider between the Project Structure list and the event display. Furthermore, the event display can be customized in the following ways:

- You can change the order of the columns by dragging the column headings to the left or right.

- You can resize columns by dragging the dividers between the column headings.
• To select a display format for all position and length values, use the Time Format pop-up menu.

• You can sort events in the display by columns, by clicking the column heading. For example, if you want to sort events by their start positions, click that column heading. An arrow appears in the column heading, indicating that events are sorted by that column. The direction of the arrow indicates whether the events are sorted in ascending or descending order. To change the direction, click the column heading again.

**Importing files via the MediaBay**

You can also import audio, video and MIDI files into the Project Browser via the MediaBay using drag and drop.

**NOTE**

You can only import into existing tracks. This means, for example, that a video track has to exist in the Project window prior to importing a video file in the Project Browser.

**RELATED LINKS**

- MediaBay on page 522

**About the Sync Selection option**

If the “Sync Selection” checkbox is activated (on the Project Browser toolbar), selecting an event in the Project window automatically selects it in the Project Browser, and vice versa. This makes it easy to locate events in the two windows.

**Editing tracks**

**Editing audio tracks**

Audio tracks can have two “subitems”: Track Data and Automation.

• The Automation item corresponds to the automation track in the Project window, and contains the track’s automation events.

• The Track Data item corresponds to the actual audio track in the Project window. It contains audio events and/or audio parts, which in turn can contain audio events.

Note that if you have not performed any automation or opened an automation track, the Browser will only contain the audio data.
The following parameters are available for the different items:

**RELATED LINKS**

[Editing automation tracks on page 934](#)

### The list columns for audio events

**Name**

Allows you to change the name of the event. Double-clicking the waveform image to the left of it opens the event in the Sample Editor.

**File**

The name of the audio file referenced by the event's audio clip.

**Start**

The start position of the event. If the event belongs to an audio part, you cannot move it outside the part.

**End**

The end position of the event.

**Snap**

The absolute position of the event's snap point. Note that adjusting this value will not change the position of the snap point within the event – instead it is another way of moving the event!

**Length**

The length of the event.

**Offset**

This determines “where in the audio clip” the event starts. Adjusting this value is the same as sliding the contents of the event in the Project window.

You can only specify positive Offset values, because the event cannot start before the start of the clip. Likewise, it cannot end after the end of the clip. If the event already plays the whole clip, the Offset cannot be adjusted at all.

**Volume**

The volume of the event, as set with the Volume handle or on the info line in the Project window.

**Fade In/Fade Out**

The length of the fade-in and fade-out areas respectively. If you use these settings to add a fade (where there previously was none), a linear fade will be created. If you adjust the length of an existing fade, the previous fade shape will be maintained.
Mute

Click in this column to mute or unmute the event.

Image

Displays a waveform image of the event inside a gray box corresponding to the clip. The image is scaled according to the width of the column.

The list columns for audio parts

Name

The name of the part. Double-clicking on the part symbol to the left of it opens the part in the Audio Part Editor.

Start

The start position of the part. Editing this value is the same as moving the part in the Project window.

End

The end position of the part. Editing this value is the same as resizing the part in the Project window.

Length

The length of the part. Editing this value is the same as resizing the part in the Project window.

Offset

This adjusts the start position of the events within the part. Adjusting this value is the same as sliding the contents of the part in the Project window.

Setting a positive Offset value is the same as sliding the contents to the left, while a negative Offset corresponds to sliding the contents to the right.

Mute

Click in this column to mute or unmute the part.

Creating audio parts

When the “Audio” item of an audio track is selected in the Project Structure list, you can create empty audio parts on the track by clicking the Add button on the toolbar. This will insert a part between the left and right locator.

Editing MIDI tracks

Just like audio tracks, MIDI tracks can have two “subitems”: Track Data and Automation.

- The Track Data item corresponds to the actual MIDI track in the Project window and can contain MIDI parts (which in turn can contain MIDI events).
The Automation item corresponds to the automation track in the Project window, and contains the track’s automation events.

**NOTE**

If you have not performed any automation or opened an automation track, the Browser will only contain the MIDI data.

When editing the Track Data, the following parameters are available:

**The list columns for MIDI events**

**Type**

The type of MIDI event. This cannot be changed.

**Start**

The position of the event. Editing this value is the same as moving the event.

**End**

This is only used for note events, allowing you to view and edit the end position of a note (thereby resizing it).

**Length**

This is only used for note events. It shows the length of the note – changing this resizes the note and automatically changes the End value as well.

**Data 1**

The property of this value depends on the type of MIDI event:

- For notes, this is the note number (pitch). This is displayed and edited as a note name and an octave number, with the values ranging between C-2 and G8.
- For controller events, this is the type of controller, displayed in words. Note that you can edit this by entering a number – the corresponding controller type is automatically displayed.
- For pitchbend events, this is the fine adjustment of the bend amount.
- For poly pressure events, this is the note number (pitch).
- For VST 3 events, this is the event parameter (e.g. Volume).
- For other event types, this is the value of the event.

**Data 2**

The property of this value depends on the type of MIDI event:

- For notes, this is the note-on velocity.
- For controller events, this is the value of the event.
- For pitchbend events, this is the coarse bend amount.
- For poly pressure events, this is the amount of pressure.
Project Browser (Cubase Pro only)

Editing tracks

- For VST 3 events, this is the value of the event parameter, with a range of 0.0 to 1.0.
- For other event types, this is not used.

**Channel**

The event’s MIDI channel.

**Comment**

This column is used for some event types only, providing an additional comment about the event.

### The list columns for MIDI parts

**Name**

The name of the part.

**Start**

The start position of the part. Editing this value is the same as moving the part.

**End**

The end position of the part. Changing this is the same as resizing the part (and will automatically affect the Length value as well).

**Length**

The length of the part. Changing this resizes the part and automatically changes the End value.

**Offset**

This adjusts the start position of the events within the part. Adjusting this value is the same as sliding the contents of the part in the Project window.

Setting a positive Offset value is the same as sliding the contents to the left, while a negative Offset corresponds to sliding the contents to the right.

**Mute**

Click in this column to mute or unmute the part.

---

**NOTE**

For SysEx (system exclusive) events, you can only edit the position (Start) in the list. However, clicking the Comment column opens the SysEx Editor, in which you can perform detailed editing of system exclusive events.

---

**RELATED LINKS**

- Editing automation tracks on page 934
- SysEx Messages on page 773
Editing Note Expression data in the Project Browser

In the Project Browser, you can view and edit the MIDI controller events or VST 3 events of a MIDI note with Note Expression data.

To view and edit the Note Expression data content of a MIDI note, proceed as follows:

**PROCEDURE**

1. In the Project Structure list, select the Note Expression subitem of the MIDI note that you want to view or edit.
   
   In the event display, all MIDI controllers or VST 3 events within the Note Expression data are listed.

2. In the event display, view and edit the parameter values.
   
   This allows you to move an event by entering a different Start value, for example. You can also delete single events to “thin out” the Note Expression data content by selecting them and pressing [Delete].

**RELATED LINKS**

- Note Expression on page 792

Filtering MIDI events

When you are editing MIDI in the Project Browser, the large number of different MIDI events displayed can make it hard to find the events you want to edit. The Filter pop-up menu allows you to select a single event type for display.

When this option is selected, only Controller events will be shown in the event display. To show all event types, select the top item (“---”) from the menu.

Creating MIDI parts

When a MIDI track is selected in the Project Structure list, you can create empty MIDI parts on the track by clicking the Add button. This will insert a part between the left and right locator.
Creating MIDI events

You can use the Project Browser to create new MIDI events.

**PROCEDURE**

1. Select a MIDI part in the Project Structure list.
2. Move the project cursor to the desired position for the new event.
3. Use the Add pop-up menu above the event display to select which type of MIDI event to add.
4. Click the Add button.

   An event of the selected type is added to the part, at the project cursor position. If the cursor is outside the selected part, the event is added at the beginning of the part.

**NOTE**

It is not possible to add MIDI controller events or VST 3 events to Note Expression data.

Editing automation tracks

All kinds of Cubase automation (the automation tracks for MIDI, instrument, audio, group, and FX channel tracks, or the individual automation tracks for VST instruments, ReWire channels, or input (Cubase Pro only) and output busses) are handled in the same way in the Project Browser.

Each Automation item in the Project Structure list will have a number of subentries, one for each automated parameter. Selecting one of these parameters in the Project Structure list shows its automation events in the list:

You can use the two columns in the list to edit the position of the events and their values.
Editing the video track

When the video track is selected in the Project Structure list, the event display lists the video events on the track, with the following parameters:

Name
The name of the video clip that the event refers to.

Start
The start position of the event. Editing this value is the same as moving the event.

End
The end position of the event. Editing this value is the same as resizing the event, and will automatically change the Length value as well.

Length
The length of the event. Editing this value is the same as resizing the event, and will automatically change the End value as well.

Offset
This determines “where in the video clip” the event starts.
Note that the event cannot start before the start of the clip, or end after the end of the clip. Thus, if the event already plays the whole video clip, the Offset cannot be adjusted at all.

Editing the marker track

Marker events have the following parameters:

Name
The name of the marker. This can be edited for all markers except the left and right locator.

Start
The position of “regular” markers or the start position of cycle markers.

End
The end positions of cycle markers. Editing this value is the same as resizing the cycle marker, and will automatically change the Length value as well.

Length
The length of cycle markers. Editing this value is the same as resizing the marker, and will automatically change the End value as well.
ID

The number of the marker. For regular (non-cycle) markers, this corresponds to the key commands used for navigating to the markers. For example, if a marker has ID 3, pressing [Shift]-[3] on the computer keyboard will move the song position to that marker. By editing these values, you can assign the most important markers to key commands.

Note that you cannot edit the “L” and “R” marker IDs (left and right locator) or assign IDs 1 and 2 to markers (since these are reserved for the locators).

You can insert markers on the marker track by selecting “Marker” or “Cycle Marker” from the Add pop-up menu and clicking the Add button. Regular markers will be added at the current project cursor position while cycle markers will be added between the current left and right locator positions.

NOTE

The Project Browser only displays the default attributes.

RELATED LINKS

Using Markers to Select Ranges on page 289

Editing the tempo track

When the tempo track is selected in the Project Structure list, the event display shows the events on the tempo track, with the following parameters:

Position

The position of the tempo event. You cannot move the first event on the tempo track.

Tempo

The tempo value of the event.

Type

This indicates whether the tempo jumps to the value of the event (“Jump” type) or whether it changes gradually from the previous tempo event, creating a ramp (“Ramp” type).

You can add new tempo events by clicking the Add button. This creates a jump-type event with the value 120bpm at the project cursor position. Make sure that there is no other tempo event at the current cursor position.

RELATED LINKS

Editing the tempo curve on page 904
Editing time signatures

When “Signature track” is selected in the Project Structure list, the event display shows the time signature events in the project:

**Position**

The position of the event. Note that you cannot move the first time signature event.

**Signature**

The value (time signature) of the event.

You can add new time signature events by clicking the Add button. This creates a 4/4 event, at the beginning of the bar closest to the project cursor position. Make sure that there is no other time signature event at the current cursor position.

Deleting events

The procedure for deleting events is the same for all different track types:

**PROCEDURE**

1. Click on an event (or a part) in the Event display to select it.
2. Select Delete from the Edit menu or press [Delete] or [Backspace].

**IMPORTANT**

Note that you cannot delete the first tempo event or the first time signature event.
Export Audio Mixdown

Introduction

The Export Audio Mixdown function in Cubase allows you to mix down audio from the program to files on your hard disk in a number of formats. In the Channel Selection section, you can choose which channels (or busses) to export.

Cubase Pro only: By activating the “Channel Batch Export” option you can choose to mix down several channels in one go. For each channel, an individual file will be created.

The following channel types are available:

- Output channels
  For example, if you have set up a stereo mix with tracks routed to a stereo output bus, mixing down that output bus will give you a mixdown file containing the whole mix. Similarly, you can mix down a complete surround bus, either to a single multi-channel file or to one file per surround channel (by activating the Split Channels option) (Cubase Pro only).

- Audio track channels (Cubase Pro only)
  This will mix down the channels for the tracks, complete with insert effects, EQ, etc. This can be useful for turning a number of events into a single file, or to convert tracks with insert effects into audio files (that are less CPU-intensive). Simply export the track and re-import the file into the project.

- Any kind of audio-related MixConsole channel (Cubase Pro only)
  This includes VST instrument channels, instrument tracks, effect return channels (FX channel tracks), group channels, and ReWire channels. There are many uses for this – for example, you can mix down an effect return track or turn individual ReWire channels into audio files.

Please note the following:

- The Export Audio Mixdown function mixes down the area between the left and right locators.

- When you mix down, you get what you hear – mutes, MixConsole settings, record enable, and insert effects are taken into account.

Note though that you will only include the sound of the channels you select for mixdown.
• MIDI tracks are not included in the mixdown!
To make a complete mixdown containing both MIDI and audio, you first need to record all your MIDI music onto audio tracks (by connecting the outputs of your MIDI instruments to your audio inputs and recording, as with any other sound source).

Mixing down to audio files

PROCEDURE

1. Set up the left and right locators to encompass the section you want to mix down.

2. Set up your tracks so that they play back the way you want.
   This includes muting unwanted tracks or parts, making manual MixConsole settings and/or activating the R (Read) automation buttons for some or all MixConsole channels.

3. Open the File menu and select “Audio Mixdown…” from the Export submenu.
   The Export Audio Mixdown dialog opens.

4. In the Channel Selection section to the left, select the channels you want to mix down. The list contains all output and audio-related channels available in the project.
   Cubase Pro only: Activate the Channel Batch Export option if you want to mixdown several channels at once.
5. In the File Location section at the top, you can set up the naming scheme for the exported files and select a path for the mixdown files.

6. Select an entry from the File Format pop-up menu and make additional settings for the file to be created.
   This includes codec settings, meta data, sample rate, bit depth, etc. The available options depend on the selected file format.

7. In the Audio Engine Output section, specify whether you want to export all subchannels of a multi-channel bus as separate mono files (Split Channels), downmix all subchannels to one mono file (Mono Downmix), or export only the left and right channels of a multi-channel bus to a stereo file (L/R Channels).

8. Activate Real-Time Export if you want the export to happen in realtime.

9. If you want to automatically import the resulting audio files back into Cubase, activate any of the checkboxes in the "Import into Project" section.

10. If you activate Update Display, the meters will be updated during the export process.
    This allows you to check for clipping, for example.

11. Click Export.
    A dialog with a progress bar is displayed while the audio files are being created.
    To cancel the operation, you can click the Abort button.
    - Cubase Pro only: During the realtime export of a single channel, the Audition Volume fader is displayed in the progress dialog. It allows you to adjust the Control Room volume.
      Note that this fader is only available if the Control Room is activated.
    - If the “Close Window after Export” option is activated, the dialog will be closed automatically.
    - If the “Deactivate External MIDI Inputs” option is activated, any MIDI inputs that are performed on external devices during the export process are ignored.

**IMPORTANT**

If you set the export range in such a way that the effects applied to a preceding event (e.g. reverb) reach into the next, these will be heard in the mixdown (even though the event itself is not included). If you do not want this, you need to mute the first event before exporting.

- If you have activated any of the options in the “Import into Project” section, the mixdown files will be imported back into the same or a new project.
  When playing back the reimported file in the same Cubase project, mute the original tracks so that you only hear the mixdown.

**RELATED LINKS**

- About the Channel Selection section on page 941
- About the File Location section on page 941
- The available file formats on page 946
- About the Audio Engine Output section on page 944
- About the Import into Project section on page 945
The Export Audio Mixdown dialog

Below you will find detailed descriptions of the different sections of the dialog and the corresponding functions.

About the Channel Selection section

The Channel Selection section shows all output and audio-related channels available in the project. These channels are organized in a hierarchical structure that allows you to easily identify and select the channels you want to export. The different channel types are listed below each other, with channels of the same type being grouped in a node (e.g. instrument tracks).

- You can activate/deactivate channels by clicking on the checkboxes in front of the channel names.
- Cubase Pro only: If Channel Batch Export is activated, you can also activate/deactivate all channels of the same type by clicking on the checkbox in front of the channel type entry.
- Cubase Pro only: If Channel Batch Export is activated, you can select/deselect several channels in one go using the [Shift] and/or [Ctrl]/[Command] modifiers and then clicking on any of the checkboxes for the highlighted channels.
  
  Note that this toggles the activation status of a channel, i.e. all selected channels that were previously activated will be deactivated and vice versa.

If your project contains a large number of channels, it might get difficult to find the desired channels in the Channel Selection section.

- To simplify the process of selecting several channels, you can filter the display. Simply type in the desired text (e.g. “voc” to show all tracks containing vocals) in the Filter field below the tree view.

About the File Location section

In the File Location section you can specify a name and a path for the exported files. Furthermore, you can define the naming scheme for the exported files.

At the right of the Name and the Path fields there are two pop-up menus with a number of options:
Export Audio Mixdown
The Export Audio Mixdown dialog

Naming Options

- Select “Set to Project Name” to set the Name field to the project name.
- Activate the “Auto Update Name” option to add a number to the specified file name every time you click the Export button.

Path Options

- Select “Choose…” to open a dialog in which you can browse for a path and enter a file name. The file name will automatically be shown in the Name field.
- Select an entry from the Recent Paths section to reuse a path specified for a previous export. This section is only shown after an export has been completed. With the “Clear Recent Paths” option you can delete all entries from the Recent Paths section.
- Activate the “Use Project Audio Folder” option to save the mixdown file in the project’s Audio folder.

Naming Scheme

Clicking the “Naming Scheme…” button opens a separate pop-up window. Here, you can choose a number of elements that will be combined to form the file name. Depending on the settings in the Channel Selection section, different elements are available.

The elements are defined as follows:

Name
   The name that you entered in the Name field (in the File Location section).

Mixer Index
   The number of the MixConsole channel.

Channel Type
   The type of audio-related channel that is being exported.
Channel Name
The name of the exported channel.

Project Name
The name of the Cubase project.

Counter (Cubase Pro only)
This is only available for batch export. Use this to include an incrementing number in the generated files names in order to create unique file names.

NOTE
By combining the available naming elements, you can make sure that all the files of a batch are exported with unique names. If you have set up a naming scheme that would result in identical file names, a warning message appears when you click the Export button.

- To add an element, press the "+" button on the far right, and to remove an element from the naming scheme click the corresponding "-" button.
  You can also remove an element by dragging it out of the Elements section.
- To rearrange the sequence, simply click on an element and drag it to a different position.
- To choose a different element for a certain position, click on the element name and select a new entry from the pop-up menu.
  Each element can only be used once in a naming scheme. The pop-up menu therefore shows only those elements that are still available.

Below the Elements section, you will find some additional options:

Separator
Allows you to enter any character sequence to be used as a separator between the naming elements (e.g. a hyphen enclosed in spaces).

Leading Zeros
This controls how many leading zeros the Counter and Mixer Index components will have. For example, if you set this to "2", the numbers from 1 to 10 will be written as 001 to 010.

Counter Start Value
Here you can enter a number that is used as the first Counter value.

The field below these options shows a preview of what the resulting file names will look like.

NOTE
To close the Naming Scheme pop-up window, simply click anywhere outside the pop-up window. The generated name will now also be shown to the right of the "Naming Scheme..." button.
About the File Format section

In the File Format section, you can select the file format for your mixdown files and make additional settings that are different for each file type.

**RELATED LINKS**

The available file formats on page 946

About the Audio Engine Output section

The Audio Engine Output section contains all the settings related to the output of the Cubase audio engine. The following options are available:

**Sample Rate (uncompressed file formats only)**

This setting determines the frequency range of the exported audio – the lower the sample rate, the lower the highest audible frequency in the audio. In most cases, you should select the sample rate set for the project, since a lower sample rate will degrade the audio quality (mainly reducing the high frequency content) and a higher sample rate will only increase the file size, without adding to audio quality. Also consider the future usage of the file: If you plan to import the file into another application, for example, you should select a sample rate supported by that application.

If you are making a mixdown for CD burning, you should select 44.100kHz, since this is the sample rate used on audio CDs.

**Bit Depth (uncompressed file formats only)**

Allows you to select 8, 16, 24bit or 32bit (float) files. If the file is an "intermediate mixdown" that you plan to re-import and continue working on in Cubase, we recommend that you select the 32bit (float) option.

32bit (float) is a very high resolution (the same resolution as used internally for audio processing in Cubase), and the audio files will be twice the size of 16bit files.

If you are making a mixdown for CD burning, use the 16bit option, as CD audio is always 16bit.

In this case, we recommend dithering.

Activate the UV-22HR dithering plug-in (see the separate PDF document "Plug-in Reference" for details). This reduces the effects of quantization noise and artifacts from being introduced when converting the audio down to 16bit. 8bit resolution should only be used if required, since it results in limited audio quality. 8bit audio may be suitable in some multimedia applications, etc.

**Mono Downmix**

In Cubase Artist, activate this if you want to downmix the two channels of a stereo bus to a single mono file. In Cubase Pro, activate this if you want to downmix all the subchannels of a stereo or surround channel or bus to a single mono file.
To avoid clipping, the following summing rules are applies:

Stereo: The panning law as defined in the Project Setup dialog is applied.
Surround (Cubase Pro only): The channels are summed and then divided through the number of channels used (in case of a 5.1. channel = \((L+R+C+LFE+Ls+Rs)/6\)).

Split Channels
Activate this if you want to export all subchannels of a multi-channel bus as separate mono files.

L/R Channels
Activate this if you want to export only the left and right subchannels of a multi-channel bus into a stereo file.

Real-Time Export
Activate this if you want the export to happen in realtime, in which case the process will take at least the same time as regular playback.

Some VST plug-ins, external instruments and effects require this in order to have enough time to update correctly during the mixdown – consult the plug-in manufacturers if uncertain.

Cubase Pro only: When Realtime Export is activated, the exported audio will be played back via the Control Room.

Depending on the CPU and disk speed of your computer, it may not be possible to export all channels simultaneously if Real-Time Export is activated. If an error occurs during the realtime export, the program will automatically stop the process, reduce the number of channels and start again. Afterwards the next batch of files is exported. This is repeated as often as needed to export all selected channels. Due to this splitting of the export process in "runs", the realtime export might take longer than the actual playback would.

RELATED LINKS
Dithering on page 379

About the Import into Project section

In this section you will find several options for importing the resulting mixdown files back into the existing or into a new project:

- If you activate the Pool checkbox, the resulting audio file will automatically be imported back into the Pool as a clip.
  Use the Pool Folder option to specify in which Pool folder the clip will reside.

- If you activate the Audio Track option as well, an audio event that plays the clip will be created and placed on a new audio track, starting at the left locator.
  If you activate the Audio Track option, the Pool option will automatically be activated as well, and deactivating the Pool option also deactivates the Audio Track option.
If you activate the “Create New Project” option, a new project is created that contains one audio track for each of the exported channels, as well as the signature and tempo track of the original project. Note that if this is activated, the Pool and Audio Track options are disabled.

The tracks will have the corresponding mixdown file as audio event. The track names will be identical with the export channel names. Note that the new project will be the active project.

NOTE

The Create New Project option is only available if you have selected an uncompressed file format and the Use Project Audio Folder option is deactivated.

RELATED LINKS

Importing Media on page 513

About the Import Options dialog

If you activate any of the options in the “Import into Project” section, the Import Options dialog will open for each exported channel when the export is complete.

RELATED LINKS

Importing Media on page 513

About the Post Process section

In the Post Process section, you can select a process that you want to execute after mixing down your audio file.

• If WaveLab 7.0.1 or higher is installed on your computer, you can select “Open in WaveLab” to open you mixdown file in this application after export.

• You can select “Upload to SoundCloud” to launch SoundCloud, connect to your user account, and upload your mixdown.

The available file formats

• AIFF files
• AIFFC files
• Wave files
• Wave 64 files
• Broadcast Wave files
• FLAC files
• MP3 files
Export Audio Mixdown
The available file formats

- Ogg Vorbis files
- Windows Media Audio Pro files (Windows only)

**IMPORTANT**
Note that the Wave 64 file format is the only format that allows you to export files with a resulting size of more than 2GB.

**NOTE**
Most of the settings described below for AIFF files are available for all file types. Where this is not the case, you will find additional information in the corresponding section.

**RELATED LINKS**
- AIFF files on page 948
- AIFC files on page 949
- Wave files on page 949
- Wave 64 files on page 949
- Broadcast Wave files on page 949
- FLAC files on page 950
- MPEG 1 Layer 3 files on page 950
- Ogg Vorbis files on page 950
- Windows Media Audio Pro files (Windows only) on page 951

**MP3 Export (Cubase Artist only)**

This version of Cubase Artist provides a function for exporting your audio mixdown as MP3 files. This function is limited to 20 trial encodings or a trial period of 30 days from the installation date (whichever ends first). After this period, the function will be disabled until you purchase the MP3 encoder for Cubase Artist.

- When the MP3 format is selected and you click the Export button, a window opens showing you how many trial encodings you have left. You can upgrade to an unlimited MP3 export function by clicking the "Go to Online Shop" button in the dialog.
  
  This will take you to Steinberg's online shop where you can purchase the upgrade. Note that a working internet connection is required.
AIFF files

AIFF stands for Audio Interchange File Format, a standard defined by Apple Inc. AIFF files have the extension .aif and are used on most computer platforms. For AIFF files the following options are available:

Insert Broadcast Wave Chunk

This allows you to include information about the date and time of creation, a timecode position (allowing you to insert exported audio at the correct position in other projects, etc.) along with author, description, and reference text strings in the exported file. Some applications may not be able to handle files with embedded info – if you get problems using the file in another application, deactivate the option and re-export.

Edit button

By clicking this button, the Broadcast Wave Chunk dialog opens, where you can enter additional information that will be embedded in the exported files. If you activate the Use this Timecode checkbox in this dialog, the timecode position that is specified in the Timecode field will be used instead of the timecode position that is automatically derived from the left locator.

NOTE

In the Preferences dialog (Record–Audio–Broadcast Wave page) you can enter default text strings for author, description, and reference that will automatically be displayed in the Broadcast Wave Chunk dialog.

Insert iXML Chunk

This allows you to include additional project-related metadata, for example, project name, author, and project frame rate in the exported file. Some applications may not be able to handle files with embedded info. If you get problems using the file in another application, deactivate the option and re-export.

NOTE

In the Project Setup dialog you can find the Author and Company fields that you can use to include the corresponding data in the iXML chunk. These fields are also available in the Preferences dialog (General–Personalization page).

Insert Tempo Definition

This option is only available if Insert iXML Chunk is activated. When Insert Tempo Definition is activated, tempo information from the tempo track or the Definition tab of the Sample Editor is included in the iXML chunk of exported files. This is useful if you want to use the files in other projects where they need to adapt to the project tempo.
AIFC files

AIFC stands for Audio Interchange File Format Compressed, a standard defined by Apple Inc. These files support compression ratios as high as 6:1 and contain tags in the header. AIFC files have the extension “.aifc” and are used on most computer platforms.

AIFC files support the same options as AIFF files.

Wave files

Wave files have the extension “.wav” and are the most common file format on the PC platform.

Wave files support the same options as AIFF files and have one additional option:

• Don’t Use Wave Extensible Format

The Wave Extensible format contains additional metadata, such as the speaker configuration. It is an extension to the normal Wave format that some applications may not be able to handle.

If you get problems using the Wave file in another application, activate this option and re-export.

Wave 64 files

Wave 64 is a proprietary format developed by Sonic Foundry Inc. In terms of audio quality, Wave 64 files are identical to standard Wave files, but in the file headers Wave 64 files use 64-bit values for addressing where Wave files use 32-bit values. The consequence of this is that Wave 64 files can be considerably larger than standard Wave files. Wave 64 is therefore a good file format choice for really long recordings (file sizes over 2 GB). Wave 64 files have the extension “.w64”.

Wave 64 files support the same options as AIFF files.

Broadcast Wave files

Broadcast Wave files are Wave files with additional meta data. To create a Broadcast Wave file, select either Wave or Wave 64 as the file format and activate the Insert Broadcast Wave Chunk option. Click Edit if you wish to edit the chunk information, otherwise the defaults as specified in the Preferences dialog (Record–Audio–Broadcast Wave page) will be used.

Broadcast Wave files have the extension “.wav”.

Broadcast Wave files support the same options as Wave files.
FLAC files

Free Lossless Audio Codec files are audio files that are typically 50 to 60% smaller than regular Wave files, for example. FLAC is an open source format.

Use the Compression Level fader to select the compression level for the FLAC file. Since FLAC is a lossless format, the level has more influence on the encoding speed than on the file size.

MPEG 1 Layer 3 files

MPEG1 Layer 3 files have the extension “.mp3”. By use of advanced audio compression algorithms, MP3 files can be made very small, yet maintaining good audio quality. In the File Format section, the following options are available for MPEG1 Layer 3 files:

Bit Rate fader
By moving this fader, you can select a bit rate for the MP3 file. As a rule, the higher the bit rate, the better the audio quality and the larger the file. For stereo audio, 128kBit/s is often considered to result in “good” audio quality.

Sample Rate pop-up menu
On this pop-up menu you can select a Sample Rate for the MP3 file.

High Quality Mode option
When this is activated, the encoder will use a different resampling mode, which can give better results depending on your settings. In this mode, you cannot specify the Sample Rate, but only the Bit Rate for the MP3 file.

Insert ID3 Tag option
This allows you to include ID3 Tag information in the exported file.

Edit ID3 Tag button
When you click this, the ID3 Tag dialog opens, in which you can enter information about the file. This additional information will be embedded as text strings in the file, and can be displayed by most mp3 playback applications.

Ogg Vorbis files

Ogg Vorbis is an open source, patent-free audio encoding and streaming technology, offering compressed audio files (extension “.ogg”) of small size, but with comparatively high audio quality.

In the File Format section you will find only one setting: the Quality fader. The Ogg Vorbis encoder uses variable bit rate encoding, and the Quality setting determines between which limits the bit rate will vary. Generally speaking, the higher the Quality setting, the higher the sound quality but also the larger the files.
Windows Media Audio Pro files (Windows only)

This is a continuation of the Windows Media Audio format developed by Microsoft Inc. Due to the advanced audio codecs and lossless compression used, WMA Pro files can be decreased in size with no loss of audio quality. Furthermore, WMA Pro features the possibility of mixing down to 5.1 surround sound. The files have the extension “.wma”.

When you select “Windows Media Audio File” as the file format, you can click the “Codec Settings…” button to open the “Windows Media Audio File Settings” window.

![Windows Media Audio File Settings](image)

Note that the configuration options may vary, depending on the chosen output channels.

General Tab

In the Input Stream section, you set the sample rate (44.1, 48 or 96kHz) and the bit resolution (16 bit or 24bit) of the encoded file. Set these to match the sample rate and bit resolution of the source material. If no value matches that of your source material, use the closest available value that is higher than the actual value. For example, if you are using 20bit source material, set the bit resolution to 24bit rather than 16bit.

- The setting in the Channels field depends on the chosen output and cannot be changed manually.

  The settings in the Encoding Scheme section are used for defining the desired output from the encoder, e.g. a stereo or a 5.1 surround file.

  Make settings appropriate for the intended use of the file. If the file will be downloaded or streamed on the internet, you might not want too high bit rates, for example. See below for descriptions of the options.

- Mode pop-up menu

  The WMA Pro encoder can use either a constant bit rate or a variable bit rate for encoding to 5.1 surround, or it can use lossless encoding for encoding to stereo.

  The options on this menu are as follows:
**Constant Bitrate**

This will encode to a 5.1 surround file with a constant bit rate (set in the Bit Rate/Channels menu, see below).

Constant bit rate is preferably used if you want to limit the size of the final file. The size of a file encoded with a constant bit rate is always the bit rate times the duration of the file.

**Variable Bitrate**

Encodes to a 5.1 surround file with a variable bit rate, according to a quality scale (the desired quality is set in the Bit Rate/Quality menu, see below).

When you encode with variable bit rates, the bit rate fluctuates depending on the character and intricacy of the material being encoded. The more complex passages in the source material, the higher the bit rate – and the larger the final file.

**Lossless**

Encodes to a stereo file with lossless compression.

- **Bit Rate/Quality pop-up menu**

This menu allows you to set the desired bit rate. The available bit rate settings vary depending on the selected mode and/or output channels (see above). If the Variable Bitrate mode is used, the menu allows you to select from various levels of quality, with 10 being the lowest and 100 the highest. Generally, the higher the bitrate or quality you select, the larger the final file will be.

The menu also shows the channel format (5.1 or stereo).

**Advanced tab**

- **Dynamic Range Control**

These controls allow you to define the dynamic range of the encoded file. The dynamic range is the difference in dB between the average loudness and the peak audio level (the loudest sounds) of the audio. These settings affect how the audio is reproduced if the file is played on a Windows computer with a player from the Windows Media series, and the “Quiet Mode” feature of the player is activated to control the dynamic range.

The dynamic range is automatically calculated during the encoding process, but you can specify it manually as well.

To manually specify the dynamic range, first put a checkmark in the box to the left by clicking in it, and then enter the desired dB values in the Peak and Average fields. You can enter any value between 0 and -90dB. Note, however, that it is usually not recommended to change the Average value, since this affects the overall volume level of the audio and therefore can have a negative effect on the audio quality.
The Quiet Mode in a Windows Media player can be set to one of three settings. Below, these settings are listed together with an explanation of how the Dynamic Range settings affect them:

- Off: If Quiet Mode is off, the dynamic range settings that were automatically calculated during the encoding will be used.

- Little Difference: If this is selected and you have not manually changed the dynamic range settings, the peak level will be limited to 6 dB above the average level during playback. If you have manually specified the dynamic range, the peak level will be limited to the mean value between the peak and average values you specified.

- Medium Difference: If this is selected and you have not manually changed the dynamic range settings, the peak level will be limited to 12 dB above the average level. If you have changed the dynamic range, the peak level will be limited to the peak value you specified.

- Surround Reduction Coefficients

Here you can specify which amount of volume reduction, if any, is applied to the different channels in a surround encoding. These settings affect how the audio is reproduced on a system incapable of playing back the file in surround, in which case the surround channels of the file will be combined into two channels and played back in stereo instead.

The default values should produce satisfactory results, but you can change the values manually if you wish. You can enter any value between 0 and -144 dB for the surround channels, the center channel, the left and right channels and the LFE channel, respectively.

**Media tab**

In these fields you can enter a number of text strings with information about the file – title, author, copyright information and a description of its contents. This information will then be embedded in the file header and can be displayed by some Windows Media Audio playback applications.

**RELATED LINKS**

*Surround Sound (Cubase Pro only) on page 558*
Background

What is synchronization?

Synchronization is the process of getting two or more devices to play back together at the same exact speed and position. These devices can range from audio and video tape machines to digital audio workstations, MIDI sequencers, synchronization controllers, and digital video devices.

Synchronization basics

There are three basic components of audio/visual synchronization: position, speed, and phase. If these parameters are known for a particular device (the master), then a second device (the slave) can have its speed and position “resolved” to the first in order to have the two devices play in perfect sync with one another.

Position

The position of a device is represented by either samples (audio word clock), video frames (timecode), or musical bars and beats (MIDI clock).

Speed

The speed of a device is measured either by the frame rate of the timecode, the sample rate (audio word clock) or by the tempo of the MIDI clock (bars and beats).

Phase

Phase is the alignment of the position and speed components to each other. In other words, each pulse of the speed component should be aligned with each measurement of the position for the most accuracy. Each frame of timecode should be perfectly lined up with the correct sample of audio. Put simply, phase is the very precise position of a synchronized device relative to the master (sample accuracy).

Machine control

When two or more devices are synchronized, the question remains: how do we control the entire system? We need to be able to locate to any position, play, record, and even jog and scrub the entire system using one set of controls.
Machine control is an integral part of any synchronization setup. In many cases, the device simply called “the master” will control the whole system. However, the term “master” can also refer to the device that is generating the position and speed references. Care must be taken to differentiate between the two.

Master and slave

Calling one device the “master” and another the “slave” can lead to a great deal of confusion. The timecode relationship and the machine control relationship must be differentiated in this regard.

In this document, the following terms are used:

- The “timecode master” is the device generating position information or timecode.
- The “timecode slave” is any device receiving the timecode and synchronizing or “locking” to it.
- The “machine control master” is the device that issues transport commands to the system.
- The “machine control slave” is the device receiving those commands and responding to them.

For example, Cubase could be the machine control master, sending transport commands to an external device which in turn sends timecode and audio clock information back to Cubase. In that case, Cubase would also be the timecode slave at the same time. So calling Cubase simply the master is misleading.

NOTE

In most scenarios, the machine control slave is also the timecode master. Once it receives a play command, that device starts generating timecode for all the timecode slaves to synchronize to.

Timecode (positional references)

The position of any device is most often described using timecode. Timecode represents time using hours, minutes, seconds, and frames to provide a location for each device. Each frame represents a visual film or video frame.

Timecode can be communicated in several ways:

- LTC (Longitudinal Timecode) is an analog signal that can be recorded on tape. It should be used for positional information primarily. It can also be used for speed and phase information as a last resort if no other clock source is available.
- VITC (Vertical Interval Timecode) is contained within a composite video signal. It is recorded onto video tape and is physically tied to each video frame.
- MTC (MIDI Timecode) is identical to LTC except that it is a digital signal transmitted via MIDI.
**Timecode standards**

Timecode has several standards. The subject of the various timecode formats can be very confusing due to the use and misuse of the shorthand names for specific timecode standards and frame rates. The reasons for this confusion are described in detail below. The timecode format can be divided into two variables: frame count and frame rate.

**Frame count (frames per second)**

The frame count of timecode defines the standard with which it is labeled. There are four timecode standards:

- **24fps Film (F)**
  
  This frame count is the traditional count for film. It is also used for HD video formats and commonly referred to as “24 p”. However, with HD video, the actual frame rate or speed of the video sync reference is slower, 23.976 frames per second, so timecode does not reflect the actual realtime on the clock for 24p HD video.

- **25fps PAL (P)**
  
  This is the broadcast video standard frame count for European (and other PAL countries) television broadcast.

- **30fps non-drop SMPTE (N)**
  
  This is the frame count of NTSC broadcast video. However, the actual frame rate or speed of the video format runs at 29.97 fps. This timecode clock does not run in realtime. It is slightly slower by 0.1 %.

- **30fps drop-frame SMPTE (D)**
  
  The 30 fps drop-frame count is an adaptation that allows a timecode display running at 29.97 fps to actually show the clock-on-the-wall-time of the timeline by “dropping” or skipping specific frame numbers in order to “catch the clock up” to realtime.

Confused? Just remember to keep the timecode standard (or frame count) and frame rate (or speed) separate.

**Frame rate (speed)**

Regardless of the frame counting system, the actual speed at which frames of video go by in realtime is the true frame rate.

In Cubase the following frame rates are available:

- **23.9fps (Cubase Pro only)**
  
  This frame rate is used for film that is being transferred to NTSC video and must be slowed down for a 2-3 pull-down telecine transfer. It is also used for the type of HD video referred to as “24 p”. 
Synchronization
Clock sources (speed references)

24fps
This is the true speed of standard film cameras.

24.9fps (Cubase Pro only)
This frame rate is commonly used to facilitate transfers between PAL and NTSC video and film sources. It is mostly used to correct for some error.

25fps
This is the frame rate of PAL video.

29.97fps
This is the frame rate of NTSC video. The count can be either non-drop or drop-frame.

30fps
This frame rate is not a video standard anymore but has been commonly used in music recording. Many years ago it was the black and white NTSC broadcast standard. It is equal to NTSC video being pulled up to film speed after a 2-3 telecine transfer.

59.98fps (Cubase Pro only)
This rate is also referred to as “60 p”. Many professional HD cameras record at 59.98 fps. While 60 fps could theoretically exist as a frame rate, no current HD video camera records at a full 60 fps as a standard rate.

Frame count vs. frame rate
Part of the confusion in timecode stems from the use of “frames per second” in both the timecode standard and the actual frame rate. When used to describe a timecode standard, frames per second defines how many frames of timecode are counted before one second on the counter increments. When describing frame rates, frames per second define how many frames are played back during the span of one second of realtime. In other words: Regardless of how many frames of video there are per second of timecode (frame count), those frames can be moving at different rates depending on the speed (frame rate) of the video format. For example, NTSC timecode (SMPTE) has a frame count of 30fps. However, NTSC video runs at a rate of 29.97fps. So the NTSC timecode standard known as SMPTE is a 30fps standard that runs at 29.97 realtime.

Clock sources (speed references)
Once the position is established, the next essential factor for synchronization is the playback speed. Once two devices start playing from the same position, they must run at exactly the same speed in order to remain in sync. Therefore, a single speed reference must be used and all devices in the system must follow that reference. With digital audio, the speed is determined by the audio clock rate. With video, the speed is determined by the video sync signal.
Synchronization
The Project Synchronization Setup dialog

Audio clock

Audio clock signals run at the speed of the sample rate used by a digital audio device and are transmitted in several ways:

Word clock

Word clock is a dedicated signal running at the current sample rate that is fed over BNC coaxial cables between devices. It is the most reliable form of audio clock and is relatively easy to connect and use.

AES/SPDIF Digital Audio

An audio clock source is embedded within AES and SPDIF digital audio signals. This clock source can be used as a speed reference. Preferably, the signal itself does not contain any actual audio (digital black), but any digital audio source can be used if necessary.

ADAT Lightpipe

ADAT Lightpipe, the 8-channel digital audio protocol developed by Alesis, also contains audio clock and can be used as a speed reference. It is transmitted via optical cables between devices.

NOTE

Do not confuse the audio clock embedded in the Lightpipe protocol with ADAT Sync, which has timecode and machine control running over a proprietary DIN plug connection.

MIDI clock

MIDI clock is a signal that uses position and timing data based on musical bars and beats to determine location and speed (tempo). It can perform the same function as a positional reference and a speed reference for other MIDI devices. Cubase supports sending MIDI clock to external devices but cannot slave to incoming MIDI clock.

IMPORTANT

MIDI clock cannot be used to synchronize digital audio. It is only used for MIDI devices to play in musical sync with one another. Cubase does not support being a MIDI clock slave.

The Project Synchronization Setup dialog

Cubase’s Project Synchronization Setup dialog provides a central place to configure a complex synchronized system. In addition to settings for timecode sources and machine control settings, project setup parameters are available along with basic transport controls for testing the system.

To open the Project Synchronization Setup dialog, proceed as follows:
- On the Transport menu, select the “Project Synchronization Setup...” option.
- On the Transport panel, [Ctrl]/[Command]-click the Sync button.

The dialog is organized into sections separating related groups of settings. The arrows shown between the various sections of the dialog indicate how settings in one section influence settings in another section. In the following, the available sections are described in detail.

The Cubase Section

At the center of the Project Synchronization Setup dialog is the Cubase section. It is provided to help you visualize the role that Cubase takes in your setup. It shows which external signals enter or leave the application.

Timecode Source

The Timecode Source setting determines whether Cubase is acting as timecode master or slave.

- **Internal Timecode**: Cubase generates timecode based on the project timeline and project setup settings. The timecode will follow the format specified in the Project Setup section.
- **MIDI Timecode**: Cubase acts as a timecode slave to any incoming MIDI timecode (MTC) on the port(s) selected in the MIDI Timecode section, to the right of the Timecode Source section.

When set to “Internal Timecode”, Cubase is the timecode master, generating all position references for any other device in the system. The other options are for external timecode sources. Selecting any of these, makes Cubase a timecode slave when the Sync button is activated.

**Internal Timecode**

Cubase generates timecode based on the project timeline and project setup settings. The timecode will follow the format specified in the Project Setup section.

**MIDI Timecode**

Cubase acts as a timecode slave to any incoming MIDI timecode (MTC) on the port(s) selected in the MIDI Timecode section, to the right of the Timecode Source section.

Selecting “All MIDI Inputs” allows Cubase to sync to MTC from any MIDI connection. You can also select a single MIDI port for receiving MTC.
ASIO Audio Device
This option is only available with audio cards that support ASIO Positioning Protocol. These audio cards have an integrated LTC reader or ADAT sync port and can perform a phase alignment of timecode and audio clock.

VST System Link
VST System Link can provide all aspects of sample-accurate synchronization between other System Link workstations.

RELATED LINKS
Working with VST System Link on page 966

Timecode Preferences
When MIDI Timecode is selected, additional options become available in the Cubase section, providing several options for working with external timecode.

Lock Frames
This setting determines how many full frames of timecode it takes for Cubase to try and establish sync or “lock”. If you have an external tape transport with a very short start-up time, try lowering this number to make lock-up even faster. This option can only be set to multiples of two.

Drop Out Frames
This setting determines the amount of missed timecode frames it takes for Cubase to stop. Using LTC recorded on an analog tape machine can result in some amount of drop outs. Increasing this number allows Cubase to "free-wheel" over missed frames without stopping. Lowering this number causes Cubase to stop sooner once the tape machine has stopped.

Inhibit Restart ms
Some synchronizers still transmit MTC for a short period after an external tape machine has been stopped. These extra frames of timecode sometimes cause Cubase to restart suddenly. The “Inhibit Restart ms” setting allows you to control the amount of time in milliseconds that Cubase will wait to restart (ignoring incoming MTC) once it has stopped.
Auto-Detect Frame-Rate Changes

Cubase can notify the user when the frame rate of timecode changes at any point. This is helpful in diagnosing problems with timecode and external devices. This notification will interrupt playback or recording. Deactivating this option will avoid any interruption in playback or recording.

**IMPORTANT**

If there is a discrepancy between the project frame rate in Cubase and incoming timecode, Cubase might still be able to lock to the incoming timecode. If the user is unaware of these differences, problems can arise later in postproduction.

Machine Control Output Destination

When the Sync button on the Transport panel is activated, all transport commands (including movements of the cursor in the Project window) are translated into machine control commands and routed according to the settings made in the “Machine Control Output Destination” section.

MC Master Active

When this option is activated, transport commands are routed or sent to any device while sync is enabled. Additional routing options become available, see below. Deactivating this option does not affect the operation of the individual MMC Device panels. They can still function regardless of the machine control destination.

MMC Input and Output

The MMC Input and MMC Output settings determine which MIDI port in your system will send and receive MMC commands. Set both the input and output to MIDI ports that are connected to the desired MIDI device.

MMC Device ID

The MMC device ID should be set to the same number as the receiving device. You can also set the device ID to “All” if more than one machine is receiving MMC commands or if the device ID is not known.

**NOTE**

Some devices can only listen to their specific IDs. Therefore, using the All option will not work with such devices.
Number of Audio Tracks (Cubase Pro only)

The number of audio tracks should be set to match the amount of available audio tracks in the destination device. This setting determines how many record-enable buttons are shown in the MMC Master panel (see below).

MMC Master panel

The MMC Master panel can be opened from the Devices menu. In order to use the MMC Master panel, proceed as follows:

- Open the Preferences dialog, select the MIDI Filter section and make sure SysEx is activated in the Thru section. This is necessary since MMC uses two-way communication (the tape recorder “replies” to the MMC messages it receives from Cubase). By filtering out SysEx Thru, you ensure that these MMC System Exclusive replies are not echoed back to the tape recorder.
- On the MMC Master panel, activate the Online button to use the transport buttons on the panel to control the transport of the device. It is not necessary to have this activated in order to synchronize with the MMC device. It only affects operation of the MMC Master panel.
- You can use the buttons to the left on the MMC Master panel to arm tape tracks for recording.
- The “A1, A2, TC, VD” items refer to additional tracks usually found on video tape recorders. Refer to the manual of your VTR device to see if these tracks are supported.

Machine Control Input (Cubase Pro only)

Cubase can respond to machine control commands from external MIDI devices. Cubase can follow incoming transport commands (locate, play, record) and respond to record-enabling commands for audio tracks. This allows Cubase to easily integrate into larger studio systems with centralized machine control and synchronization such as theatrical mixing stages.

MMC Slave Active

When this option is activated, several settings become available in the Machine Control Input section:
Synchronization
The Project Synchronization Setup dialog

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>MMC Input</td>
<td>Set this to the MIDI input that is connected to the master machine control device.</td>
</tr>
<tr>
<td>MMC Output</td>
<td>Set this to the MIDI output that is connected to the master machine control device.</td>
</tr>
<tr>
<td>MMC Device ID</td>
<td>This determines the MIDI ID number that is used to identify the machine in Cubase.</td>
</tr>
</tbody>
</table>

**IMPORTANT**
The MMC protocol involves polling devices (requesting information) for their status which requires two way communication. While some functions may work with only one way communication, it is best to connect both MIDI ports (input and output) of MMC devices.

**MIDI Timecode Destinations**
Cubase can send MTC to any MIDI port. Use this section to specify the MIDI ports to which MTC is routed. Devices that can lock to MTC will chase Cubase's timecode position.

**NOTE**
Some MIDI interfaces send MTC over all ports by default. If this is the case, only select one port of the interface for MTC.

**MIDI Timecode Follows Project Time**
Activate this option to ensure that the MTC output follows Cubase's time position at all times including looping, locating, or jumping while playing. If not, MTC will continue on without changing locations at a loop or jump point until playback stops.

**MIDI Clock Destinations**
Some MIDI devices like drum machines can match their tempo and location to incoming MIDI clock. Select any MIDI ports that you wish to output MIDI clock.
Synchronization
Synchronized operation

MIDI Clock Follows Project Position
Activate this option to ensure that the MIDI clock device follows Cubase when looping, locating, or jumping while playing.

NOTE
Some older MIDI devices might not respond well to these positioning messages and could take some time synchronizing to the new location.

Always Send Start Message
MIDI clock transport commands include Start, Stop, and Continue. However, some MIDI devices do not recognize the Continue command. By activating the “Always Send Start Message” option, you can avoid this problem with specific MIDI devices.

Send MIDI Clock in Stop Mode
Activate this option if you are working with a device that needs MIDI clock to run continuously in order to operate arpeggiators and loop generators.

Synchronized operation

Once you have connected all the devices that will be synchronized, it is important to understand how Cubase operates in Sync mode. Sync mode is enabled by activating the Sync button on the Transport panel.

Sync mode

When you activate the Sync button, the following happens:

- Cubase Pro only: Transport commands are routed to the machine control destination output as specified in the Project Synchronization Setup dialog. Locate, Play, Stop, and Record commands will now be sent to an external device.

- Cubase awaits incoming timecode from the chosen timecode source defined in the Project Synchronization Setup dialog in order to play.
Cubase will detect incoming timecode, locate to its current position, and start playback in sync with the incoming timecode.

Cubase Pro only: In a typical scenario, an external tape machine (e.g. a VTR) has its timecode output connected to Cubase. Cubase is sending machine control commands to the deck. When Sync is activated and you click Play on the Transport panel, a play command is sent to the VTR. The VTR in turn starts playback, sending timecode back to Cubase. Cubase then synchronizes to that incoming timecode.

## Example Scenarios (Cubase Pro only)

To better understand how synchronization options can be utilized, an example scenario is provided.

### Personal music studio

In a personal music studio, the user might have the need of synchronizing with an external recording device such as a portable hard disk recorder used for live remote recordings.

In this example, MIDI will be used for timecode and machine control while the audio clock will be handled by Lightpipe digital audio connections.

- When the Sync button is activated, Cubase sends MMC commands to the hard disk recorder.
  - Cubase can remotely start playback of the recorder.

- The hard disk recorder is using audio clock from Cubase's audio interface as the speed reference.
  - It is also possible for Cubase to use the audio clock from the recorder. The audio clock is carried over the Lightpipe digital audio connection that also carries audio signals.

- The hard disk recorder sends back MTC to Cubase.
  - When the recorder begins playing, MTC is sent back to Cubase which will sync to that timecode.

### Sync settings for personal music studio

To synchronize the devices in this example scenario, proceed as follows:

<table>
<thead>
<tr>
<th>Procedure</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Make the connections as shown in the diagram above.</td>
</tr>
<tr>
<td>In this simple example, any device that uses MTC can be substituted.</td>
</tr>
</tbody>
</table>
2. Open the Project Synchronization Setup dialog and select “MIDI Timecode” as the timecode source.
When recording from the hard disk recorder into Cubase, Cubase will be the machine control master and the timecode slave, locking to incoming MTC.
3. In the “Machine Control Output Destination” section, select the “MIDI Machine Control” option.
Cubase will now send MMC commands to the hard disk recorder to locate and start playback.
4. In the “Machine Control Output Settings” section, assign the MIDI input and output ports that are connected to the hard disk recorder.
Since MMC uses two-way communication, both MIDI ports should be connected. Be sure the MIDI filter does not echo SysEx data.
5. On the Transport panel, activate the Sync button.
This routes transport commands to the hard disk recorder via MIDI and sets Cubase as the timecode slave.
6. On the hard disk recorder, enable MMC and MTC.
Follow the instructions on how to set up the unit to receive MMC commands and transmit MTC.
7. In Cubase, click the Play button.
The hard disk recorder should start playback and send MTC to Cubase. Once Cubase syncs to MTC, the status on the Transport panel should read “Lock” and show the current frame rate of incoming MTC.

Working with VST System Link

VST System Link is a network system for digital audio that allows you to have several computers working together in one large system. Unlike conventional networks it does not require Ethernet cards, hubs, or CAT-5 cables; instead it uses the kind of digital audio hardware and cables you probably already possess in your studio.

VST System Link has been designed to be simple to set up and operate, yet give enormous flexibility and performance gains in use. It is capable of linking computers in a “ring” network (the System Link signal is passed from one machine to the next, and eventually returns to the first machine). VST System Link can send its networking signal over any type of digital audio cable, including S/PDIF, ADAT, TDIF, or AES, as long as each computer in the system is equipped with a suitable ASIO compatible audio interface.

Linking up two or more computers gives you vast possibilities:

- Dedicate one computer to running VST instruments while recording audio tracks on another.
- If you need lots of audio tracks, you may simply add tracks on another computer.
- You could have one computer serve as a “virtual effect rack”, running CPU-intensive send effect plug-ins only.
• Since you can use VST System Link to connect different VST System Link applications on different platforms, you can take advantage of effect plug-ins and VST instruments that are specific to certain programs or platforms.

Requirements

The following equipment is required for VST System Link operation:

• Two or more computers. These can be of the same type or use different operating systems – it does not matter. For example, you can link an Intel-based PC to an Apple Macintosh without problems.

• Each computer must have audio hardware with specific ASIO drivers.

• The audio hardware must have digital inputs and outputs. To be able to connect the computers, the digital connections must be compatible (i.e. the same digital formats and connection types must be available).

• At least one digital audio cable must be available for each computer in the network.

• A VST System Link host application must be installed on each computer. Any VST System Link application can connect to another.

Additionally, use of a KVM switchbox is recommended.

Using a KVM switchbox

Whether you want to set up a multi-computer network or a small network in a limited space, it is a good idea to invest in a KVM (Keyboard, Video, Mouse) switchbox. With one of these you can use the same keyboard, monitor, and mouse to control each computer in the system, and you can switch between computers very rapidly. If you decide not to go this route, the network will function just the same, but you may end up doing a lot of jumping from one machine to the other while setting up!
Making connections

Below, we assume that you are connecting two computers. Should you have more than two computers, it is still best to start with two and add the others one by one once the system is working – this makes troubleshooting easier if you run into problems. For two computers, you will need two digital audio cables, one in each direction:

**PROCEDURE**

1. Use the first digital audio cable to connect the digital output of computer 1 to the digital input of computer 2.
2. Use the other cable to connect the digital output of computer 2 to the digital input of computer 1.
   
   If a card has more than one set of inputs and outputs, choose whichever one that suits you – for simplicity usually the first set is best.

Synchronization

Before you proceed, you need to make sure that the clock signals on your ASIO cards are synchronized correctly. This is essential when cabling any kind of digital audio system, not just VST System Link.

**IMPORTANT**

All digital audio cables by definition always carry a clock signal as well as audio signals, so you do not have to use a special word clock input and output for this (although you may find that you get a slightly more stable audio system if you do, especially when using multiple computers).

The clock mode or sync mode is set up in the ASIO control panel of the audio hardware. Proceed as follows:

**PROCEDURE**

1. From the Devices menu, open the Device Setup dialog.
2. On the VST Audio System page, select your audio interface from the ASIO Driver pop-up menu.
   
   In the Devices list, the name of the audio interface now appears as a subentry to the “VST Audio System” entry.
3. In the Devices list, select your audio interface.
4. Click the Control Panel button.
   
   The ASIO control panel appears.
5. Open the ASIO control panel on the other computer as well.
   
   If you are using another VST System Link host application on that computer, check its documentation for details on how to open the ASIO control panel.
6. Now you need to make sure that one audio card is set to be the clock master and all other cards are set to be clock slaves (i.e. they listen for the clock signal coming from the clock master).

The naming and procedure for this differs depending on the audio hardware – consult its documentation if required. If you are using Steinberg Nuendo ASIO hardware, all cards default to the AutoSync setting. In this case you must set one of the cards (and only one) to “Master” in the Clock Mode section of the control panel.

**RESULT**

Typically, the ASIO control panel for an audio card contains some indication of whether or not the card receives a proper sync signal, including the sample rate of that signal.

This is a good indication that you have connected the cards and set up clock sync properly. Check your audio hardware’s documentation for details.

**IMPORTANT**

It is very important that only one card is the clock master, otherwise the network cannot function correctly. Once you have set this up, all the other cards in the network will take their clock signal from this card automatically.

The only exception to this procedure is if you are using an external clock – from a digital mixing desk or a special word clock synchronizer, for example. In that case you must leave all your ASIO cards in clock slave or AutoSync mode and make sure that each of them is listening for the signal coming from the synchronizer. This signal is usually passed through your ADAT cables or word clock connectors in a daisy chain fashion.

**VST System Link and latency**

The general definition of latency is the amount of time it takes any system to respond to whatever messages are sent to it. For example, if your system's latency is high and you play VST instruments in realtime, you will get a noticeable delay between when you press a key and when you hear the sound of the VST instrument.

Nowadays, most ASIO-compatible audio cards are capable of operating with very low latencies. Also, all VST applications are designed to compensate for latency during playback, making the playback timing tight.

However, the latency time of a VST System Link network is the total latency of all the ASIO cards in the system added together. Therefore it is extra important to minimize the latency times for each computer in the network.

**IMPORTANT**

The latency does not affect the synchronization – it is always perfectly in time. But it can affect the time it takes to send and receive MIDI and audio signals, or make the system seem sluggish.
To adjust the latency of a system, you adjust the size of the buffers in the ASIO control panel – the lower the buffer size, the lower the latency. It is best to keep to fairly low latencies (buffer sizes) if your system can handle it – about 12 ms or less is usually a good idea.

**Setting up your software**

Now it is time to set up your programs. The procedures below describe how to set things up in Cubase. If you are using another program on the other computer, please refer to its documentation.

**Setting the sample rate**

The projects in both programs must be set to use the same sample rate. Select “Project Setup...” from the Project menu and make sure that the sample rate is the same in both systems.

**Streaming digital audio between applications**

**PROCEDURE**

1. Create input and output busses in both applications and route these to the digital inputs and outputs.
   The number and configuration of the busses depend on your audio hardware and on your needs. If you have a system with eight digital i/o channels (such as an ADAT connection), you could create several stereo or mono busses, a surround bus together with a stereo bus, or any combination you need. The important thing is that you should have the same configuration in both applications – if you have four stereo output busses on computer 1, you want four stereo input busses on computer 2, etc.

2. Set things up so that computer 1 plays back some audio.
   For example, you could import an audio file and play it back in Cycle mode.

3. In the Inspector or MixConsole, make sure that the channel containing the audio material is routed to one of the digital output busses.

4. On computer 2, open the MixConsole and locate the corresponding digital input bus.
   The audio being played back should now “appear” in the program running on computer 2. You should see the input bus level meters moving.

5. Reverse this procedure so that computer 2 plays back and computer 1 “listens”.

**RESULT**

Now you have verified that the digital connection works as it should.

**NOTE**

From this point on in this chapter, we refer to the busses connected to the digital inputs and outputs as “VST System Link busses”.

970
Settings for the audio hardware

When you exchange VST System Link data between computers, it is important that the digital information is not changed in any way between the programs. Therefore, you should open the control panel (or additional application) for your audio hardware and make sure that the following conditions are met:

- If there are additional “format settings” for the digital ports that you use for VST System Link data, make sure that these are turned off.
  For example, if you are using an S/PDIF connection for VST System Link, make sure that “Professional format”, Emphasis, and Dithering are turned off.
- If your audio hardware has a mixer application allowing you to adjust the levels of digital inputs and outputs, make sure that this mixer is disabled or that the levels for the VST System Link channels are set to ±0 dB.
- Similarly, make sure no other forms of DSP (pan, effects, etc.) are applied to the VST System Link signal.

Notes for Hammerfall DSP users

If you are using RME Audio Hammerfall DSP audio hardware, the Totalmix function allows for extremely complex signal routing and mixing in the audio hardware. This can in some situations lead to “signal loops” in which case the VST System Link will not work. If you want to make absolutely sure this will not cause any problems, select the default or “plain” preset for the Totalmix function.

Activating VST System Link

Before you proceed, you need to make sure that VST System Link is set as the timecode source in the Project Synchronization Setup dialog and that the desired Sync options are activated.

After setting up the inputs and outputs, you now need to define which input/output will carry the actual VST System Link information.

The VST System Link networking signal is carried on only one bit of one channel. This means that if you have an ADAT-based system which normally carries eight channels of 24-bit audio, once you activate VST System Link you will have seven channels of 24-bit audio and one channel of 23-bit audio (the least significant bit of this last channel will be used for networking). In practice this makes no discernible difference to the audio quality, since you will still have around 138 dB headroom on this channel.
To set things up, open the VST System Link panel:

**PROCEDURE**

1. From the Devices menu, open the Device Setup dialog.
2. In the Devices list to the left, select the “VST System Link” entry. The VST System Link settings are shown to the right of the Devices list.
3. Use the ASIO Input and ASIO Output pop-up menus to define which channel is the networking channel.
4. Activate the Active checkbox at the top left of the panel.
5. Repeat the steps above for every computer in the network.

**RESULT**

As the computers are made active, you should see the Sending and Receiving indicators flashing on each active computer, and the name of each computer should appear in the list at the bottom of the pane. Each computer is assigned a random number – do not worry about this, it is just so the network knows internally which one is which.

- You can double-click on the name in bold (which is the name of the computer you are currently working on) and set it to whatever other name you wish. This name will appear in the VST System Link window of every computer on the network.

**NOTE**

If you do not see the name of each computer appearing once you have made it active, you need to check your settings. Go through the procedure above again and make sure that all ASIO cards are listening to the digital clock signals correctly, and that each computer has the correct inputs and outputs assigned to the VST System Link network.

**RELATED LINKS**

- Timecode Preferences on page 960
Putting the network online

After each computer’s name you will see whether it is online or not. When a computer is online, it will receive transport and timecode signals, and its sequencer application can be started and stopped by remote control. If it is off-line, it can only be started from its own keyboard – it is effectively an independent machine, although it is still on the network.

NOTE

Note that any computer can control any and all of the others – VST System Link is a peer-to-peer network and there is no absolute “master” computer.

To put all computers online, proceed as follows:

PROCEDURE

1. For all computers, activate the Online checkbox on the VST System Link page.
2. Start playback on one computer to check that the system is working – all computers should start almost instantly and play perfectly in time, with sample-accurate precision.
   • The Offset Samples setting allows you to adjust whether one machine will play slightly ahead or behind the rest.
     This is normally not needed, but occasionally with some hardware you may find that the lock is a few samples out. For now, leave it set to 0 – it will most likely be what you want.
   • The Transfer Bits setting allows you to specify whether you want to transfer 24 or 16 bits. This allows you to use older audio cards which do not support transfer of 24 bits.

RESULT

VST System Link sends and understands all transport commands (such as play, stop, fast forward, rewind, etc.). This allows you to control the entire network from one computer without a problem – try it! If you jump to a locator point on one machine, all other machines will also instantly jump to that locator point.

IMPORTANT

Make sure that all computers have their tempos set to the same value, otherwise your synchronization will be seriously skewed.
Synchronization
Activating VST System Link

Scrubbing via VST System Link

You can scrub on one computer and have the video and audio on another computer scrub along. However, the playback on the linked systems may not be perfectly in sync while scrubbing and there are some further restrictions you should bear in mind when scrubbing via VST System Link:

- Use the jog/shuttle control on the Transport panel or a remote controller for scrubbing.
  Scrubbing with the Scrub tool does not work over a VST System Link connection.

- Always use the system where you started scrubbing to control the scrubbing, e.g. change the scrub speed or stop scrubbing.
  Changing the scrub speed on a remote system will only change the speed on the local system.

- You can start playback on all systems.
  This stops scrubbing and enters playback on all systems in sync.

Using MIDI

As well as supplying transport and sync control, VST System Link also supplies up to 16 MIDI ports, with 16 channels each.

PROCEDURE

1. Use the MIDI Inputs and MIDI Outputs value fields to specify the number of MIDI ports you need.
   The default value is 0 MIDI In and 0 MIDI Out ports.

2. In the Project window, create a MIDI track and open the Inspector (top section).

3. If you now open the Input or Output Routing pop-up menu, you will find the specified System Link ports added to the list of MIDI inputs or outputs.
This allows you to route MIDI tracks to VST instruments running on another computer, as described in the application examples.

**RELATED LINKS**

Using one computer for VST instruments on page 978

### The “Use Selected ASIO Ports for Data only” setting

If you are sending huge amounts of MIDI data at once, there is a small possibility that you might run out of bandwidth on your VST System Link network. This will manifest itself by notes “choking” or timing becoming erratic.

If this happens, you can devote more bandwidth to MIDI by activating the “Use Selected ASIO Ports for Data only” option on the VST System Link page of the Device Setup dialog. When this is activated, the VST System Link information will be sent on the entire channel instead of just one bit, more than enough for all the MIDI you could ever hope to use. The downside is that you can no longer use this ASIO channel for audio transfer (do not connect it to a speaker!), thus leaving you with only 7 audio channels in our ADAT cable example. Depending on how you work, this might be a reasonable compromise.

### Hearing the network audio

If you are using an external mixing desk, hearing your audio really is not an issue – just plug the outputs of each computer into the desired channels on the external mixing desk, start playback on one of the computers, and you are good to go.

However, many people prefer to mix internally inside the computer and just use a desk for monitoring (or maybe not use any external mixer at all). In this case you will need to select one computer to be your “main mix computer” and send the audio from your other computers into this.
In the following example, we assume you are using two computers, with computer 1 as your main mix computer and computer 2 running two additional stereo audio tracks, an FX channel track with a reverb plug-in and a VST instrument plug-in with stereo outputs.

**PROCEDURE**

1. Set things up so that you can listen to the audio playback from computer 1. In other words, you need an unused set of outputs, e.g. an analog stereo output, connected to your monitoring equipment.

2. On computer 2, route each of the two audio tracks to a separate output bus. These should be busses connected to the digital outputs – let’s call them Bus 1 and 2.

3. Route the FX channel track to another VST System Link bus (Bus 3).

4. Route the VST instrument channel to yet another bus (Bus 4).

5. Go back to computer 1 and check the corresponding four VST System Link input busses. If you start playback on computer 2, the audio should “appear” on the input busses on computer 1. However, to mix these audio sources you need actual mixer channels.

6. Add four new stereo audio tracks on computer 1 and route these to the output bus you use for listening, e.g. to the analog stereo outputs.

7. For each of the audio tracks, select one of the four input busses. Now, each computer 2 bus is routed to a separate audio channel on computer 1.

8. Activate monitoring for the four tracks.

**RESULT**

If you now start playback, the audio from computer 2 will be sent “live” to the new tracks on computer 1, allowing you to hear them together with any tracks you play back on computer 1.

---

**Adding more tracks**

What if you have more audio tracks than you have VST System Link busses (physical outputs)? Then you just use the computer 2 mixer as a submixer: Route several audio channels to the same output bus and adjust the output bus level if needed.

**NOTE**

If your audio cards have multiple sets of input and output connections, you can link up multiple ADAT cables and send audio via any of the busses on any of the cables.
Internal mixing and latency

One problem with mixing inside the computer is the latency issue we mentioned earlier. The VST engine always compensates for record latencies, but if you are monitoring through computer 1 you will hear a processing delay while you listen to signals coming from your other computers (not on your recording!). If your audio card in computer 1 supports ASIO Direct Monitoring you should definitely turn this on. You can find the setting on the VST Audio System device panel for your hardware. Most modern ASIO cards support this function. If yours does not, you may want to change the Offset Samples value on the VST System Link page to compensate for any latency issues.

RELATED LINKS
ASIO Direct Monitoring on page 217

Setting up a larger network

Setting up a larger network is not much more difficult than a two-computer network. The main thing to remember is that VST System Link is a daisy chain system. In other words, the output of computer 1 goes to the input of computer 2, the output of computer 2 goes to the input of computer 3, and so on around the chain. The output of the last computer in the chain must always go back into the input of computer 1, to complete the ring.

Once you have done this, the transmission of all the transport, sync, and MIDI information to the whole network is handled pretty much automatically. However, where you may run into confusion in a large network is in the transmission of audio signals back to a central mix computer.

If you have lots of hardware inputs and outputs on your ASIO cards, you do not have to send audio via the chain at all, but can transmit it directly to the master mix computer via one or more of its other hardware inputs. For example, if you have a Nuendo Digiset interface or 9652 card on computer 1, you could use ADAT cable 1 for networking, ADAT cable 2 as a direct audio input from computer 2, and ADAT cable 3 as a direct audio input from computer 3.

You can also transmit audio via the ring system if you do not have enough hardware I/Os for direct audio transmission. For example, in a four-computer scenario you could send audio from computer 2 into a channel in the mixer in computer 3, from there to a channel in the mixer in computer 4, and from there back to the master mixer in computer 1. This can certainly be tricky to set up, so for complex networks it is generally recommended to use ASIO cards with at least three separate digital I/Os.
Application examples

Using one computer for VST instruments

In this example, one computer will be used as main record and playback machine, and another computer as a virtual synth rack.

PROCEDURE
1. Record a MIDI track into computer 1.
2. Once you have finished recording, route the MIDI output of that track to VST System Link MIDI port 1.
3. On computer 2, open up the VST Instruments window and assign an instrument to the first slot in the rack.
4. Route the VST instrument channel to the desired output bus.
   If you are using computer 1 as your main mixing computer, this would be one of the VST System Link output busses, connected to computer 1.
5. Create a new MIDI track in the Project window of computer 2 and assign the MIDI output of the track to the VST instrument you created.
6. Assign the MIDI input of the track to be VST System Link port 1.
   Now, the MIDI track on computer 1 is routed to the MIDI track on computer 2, which in turn is routed to the VST instrument.
7. Now activate monitoring for the MIDI track on computer 2, so that it will listen and respond to any MIDI commands coming in.
   In Cubase, click the Monitor button in the track list or Inspector.
8. Start playback on computer 1.
   It will now send the MIDI information on the track to the VST instrument loaded on computer 2.

RESULT
Even with a slow computer you should be able to stack a whole bunch of extra VST instruments this way, expanding your sound palette considerably. Do not forget that VST System Link MIDI is also sample-accurate, and thus has much tighter timing than any hardware MIDI interface ever invented!

Creating a virtual effect rack

The effect sends for an audio channel in Cubase can either be routed to an FX channel track or to any activated group or output bus. This allows you to use a separate computer as a “virtual effect rack”.

PROCEDURE
1. On computer 2 (the machine you will use as effect rack), add a new stereo audio track.
   You cannot use an FX channel track in this case, since the track must have an audio input.
2. Add the desired effect as an insert effect for the track. Let's say you add a high-quality reverb plug-in.

3. In the Inspector, select one of the VST System Link busses as input for the audio track. You want to use a separate VST System Link bus, which will only be used for this purpose.

4. Route the channel to the desired output bus. If you are using computer 1 as your main mixing computer, this would be one of the VST System Link output busses, connected to computer 1.

5. Activate monitoring for the track.

6. Go back to computer 1 and select a track to which you want to add some reverb.

7. Bring up the effect sends for the track in the Inspector or the MixConsole.

8. Open the Send Routing pop-up menu for one of the sends and select the VST System Link bus assigned to the reverb in step 3.

9. Use the Send slider to adjust the amount of effect as usual.

RESULT

The signal will be sent to the track on computer 2 and processed through its insert effect, without using any processor power on computer 1.

You can repeat the steps above to add more effects to the “virtual effect rack”. The number of effects available this way is only limited by the number of ports used in the VST System Link connection (and of course by the performance of computer 2, but given that it will not have to handle any recording or playback, you should be able to use quite a lot of effects).

Getting extra audio tracks

All computers on a VST System Link network are locked with sample-accuracy. Therefore, if you find that the hard drive on one computer is not fast enough to run as many audio tracks as you need, you can record new tracks on one of the other computers instead. This would create a “virtual RAID system”, with several disks all operating together. All tracks will remain locked together just as tightly as if they were all running on the same machine. This means that you effectively have an unlimited track count! Need another 100 tracks? Just add another computer.

Dedicated Video Playback

Playback of high-resolution video can be taxing on a system's CPU. By dedicating one computer for video playback via System Link, you can free up resources on your main CPU for audio and MIDI processing. Since all transport commands will respond on the VST System Link computers, scrubbing video is possible even when it is coming from another computer.
Cubase supports the integration of video files in your project.

You can play back video files in various formats and via different output devices from within Cubase, edit your music to the video, extract the audio material from a video file, and replace the audio later with different audio material.

Before You Start

When working on a project involving a video file, you first need to set up your system according to your equipment and your demands.

The following sections provide some general information about video file formats, frame rates, and video output devices.

Video File Compatibility

Because there are many types of video files, it can be difficult to determine if one will work on your system.

There are two ways to figure out if Cubase can play back a certain video file:

- Open the video file with QuickTime 7.1 or higher, because Cubase uses QuickTime for playing back video files.
- Check the file information of a video file in the Pool. If the information reads "Invalid or not supported file!", the video file is either corrupt or the format is not supported by the available codecs.

**NOTE**

If you are not able to load a certain video file, you must use an external application to convert the file into a compatible format or install the required codec.

**RELATED LINKS**

- Codecs on page 981
Video Container Formats

Video and other multi-media files come in a container format.

This container holds various streams of information including video and audio, but also metadata such as synchronization information required to play back audio and video together. Data regarding creation dates, authors, chapter markings, and more can also be held within the container format.

The following container formats are supported by Cubase:

<table>
<thead>
<tr>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>MOV</td>
<td>This is a QuickTime movie.</td>
</tr>
<tr>
<td>QT</td>
<td>This is also a QuickTime movie, but it is only used on Windows systems.</td>
</tr>
<tr>
<td>MPEG-1</td>
<td>This is the first standard of the Moving Picture Experts Group for video and audio compression, used for making video CDs. Files of this container format can have the extensions &quot;.mpg&quot; or &quot;.mpeg&quot;.</td>
</tr>
<tr>
<td>MPEG-4</td>
<td>This format is based on the QuickTime movie standard, can contain various metadata for streaming, editing, local playback, and interchange of content. Its file extension is &quot;.mp4&quot;.</td>
</tr>
<tr>
<td>AVI</td>
<td>This format is a multimedia container format introduced by Microsoft.</td>
</tr>
<tr>
<td>DV</td>
<td>This is a video format used by camcorders.</td>
</tr>
</tbody>
</table>

Cubase supports all these container formats, but problems may arise when the computer does not have the correct software to decode compressed video and audio streams within the container file. You must also know the type of codec that was used to create the video file.

Codecs

Codecs are methods of data compression used to make video (and audio) files smaller and more manageable for computers.

In order to play back a video file, your computer must have the correct codec installed in the operating system to decode the video stream.

<table>
<thead>
<tr>
<th>IMPORTANT</th>
</tr>
</thead>
</table>

The names of codecs and container formats can be confusing. Because many container formats have the same names as the codecs they use within the file, make sure to differentiate the container format or file type, for example .mov or .dv, from the codec used within it.

If you are not able to load a certain video file, the required codec is probably not installed on your computer. In this case, you can search the internet (e.g. the Microsoft or Apple web sites) for video codecs.
Frame Rates

Cubase is capable of working with different types of video and film frame rates.

**RELATED LINKS**

Frame rate (speed) on page 956

Video Output Devices

Cubase supports several ways to play back video files.

Viewing video files onscreen in the Video Player window may work just fine for many applications, but often it is necessary to display video in a large format for viewing small details and so others involved in the session can also see the video. Cubase provides the ability to use several types of video output devices to accomplish this.

Multi-Head Video Cards

One of the most common methods is the use of a multi-head video card installed in the computer.

Multi-head video cards allow you to connect more than one computer monitor to the card, in some cases up to four. If you direct the video output of Cubase to one of these outputs, the video file is displayed in full screen mode on a computer monitor or HD television screen.

**NOTE**

You can also use more than one video card to achieve the same result.

Different video cards support different types of outputs including standard VGA, DVI, S-Video, HDMI, and component video. These options allow you to choose the type of monitor you use for video. HD televisions and digital projectors provide the largest viewing screens, but a normal computer monitor can function as a very high-quality video monitor as well.

Dedicated Video Cards

The use of a dedicated video card is also supported in Cubase.

These cards are normally used in video editing systems to capture video to disk and display it while editing. They usually have a high resolution and take some strain off the host CPU by providing video compression and decompression processing on the card.

**NOTE**

The Decklink cards by Blackmagic Design are automatically recognized by Cubase. Video will be sent directly to its output.
FireWire DV Output

You have the option to use FireWire ports on the computer to output DV video streams to external converters such as various camcorders and standalone FireWire to DV conversion units.

These units can be connected to a television or projector for large format viewing. The FireWire protocol is capable of transporting data at high speed and is the most common standard for communicating with video-related peripheral equipment.

IMPORTANT

On Windows systems, it is important that you connect your device to the FireWire port before launching Cubase. Otherwise it may not be detected properly by Cubase.

Preparing a Video Project

The following sections describe the basic operations necessary for preparing a Cubase project involving video.

It is advisable to save your video files on a separate hard drive from your audio files. This can help prevent data streaming problems when using high-resolution video with many audio tracks.

Importing Video Files

Importing a video file into your project is very straight forward once you know that you have a compatible video file.

Video files are imported in the same manner as audio files:

- By using the File menu (Import–Video File).
  In the Import Video dialog, you can activate the “Extract Audio From Video” option. This imports any embedded audio streams to a newly created audio track positioned below the video track. The new track and the clip will get the name of the video file. The new audio event will start at the same time as the video event, so that they are in sync with each other.

  NOTE

  If you try to import a non-supported video file with the Import Video option, the Import Video dialog displays the text “Invalid or not supported file!”.

- By importing to the Pool first and then dragging to the Project window.
- By using drag and drop from the MediaBay, the Pool, the Windows Explorer, or the Mac OS Finder.
When importing video files via the Pool or by using drag and drop, Cubase can automatically extract the audio from a video file. Whether this happens, depends on the “Extract Audio on Import Video File” setting in the Preferences dialog (Video page).

When importing video, Cubase automatically creates a thumbnail cache file. The generated file is stored in the same folder as the video file and gets the name of the file with the suffix ".vcache”.

**IMPORTANT**

In Cubase, you may work with multiple video files of differing frame rates and formats on the same video track. Assuming you have the proper codecs installed, all video files can be played back in one project, but note that proper synchronization of audio and video events is ensured only if the frame rate of the video file matches the project frame rate.

**RELATED LINKS**

- Pool on page 499
- Extracting Audio From a Video File on page 990

### Adopting the Frame Rate

When using video files within Cubase, it is important to adjust the project’s frame rate to that of the imported video. This ensures that the time displays of Cubase correspond to the actual frames in the video. If the frame rate of an imported video file differs from the frame rate set for the project, the video event shows a warning.

In order to match the two frame rates, you have to adjust the frame rate in the Project Setup dialog.

**PROCEDURE**

1. Open the Project menu and select “Project Setup...”.
2. In the Project Setup dialog, click the “Get From Video” button.

   Provided that the video file has a frame rate supported by Cubase, it is automatically detected and applied to the project. If the project contains several video files with different frame rates, the project frame rate is adjusted to the frame rate of the first video event on the upper video track.

**RESULT**

The project frame rate setting will change to that of the video file and the project start time will be altered to reflect the change in frame rate if needed.
For example, when the project frame rate is switched from 30fps to 29.97fps, the start time is changed so that all the events currently in the project remain at the same positions in relation to realtime. If you want the project start time to remain the same, you must manually change it back after clicking the “Get From Video” button. In this case, it is important that the video event is snapped to the timeline to ensure proper positioning and synchronization within the project.

**NOTE**

- Cubase can only detect the supported frame rates (these are the frame rates listed in the Frame Rate pop-up menu in the Project Setup dialog). Video files with non-supported frame rates can be played back, but the time displays are not correct in this case and proper positioning is not guaranteed. Furthermore, audio and video may not be in sync. Therefore, we recommend that you use an external application to convert the video file to a frame rate supported by Cubase.

- If you have more than one video file in a project, it is advisable that all video files have the same frame rate consistent with the project frame rate. Nevertheless, you can work with multiple video files of differing frame rates, but in this case you should always change the project frame rate to the frame rate of the video file that you are editing at the moment. This is done in the Project Setup dialog by selecting the correct frame rate from the Frame Rate pop-up menu.

**About Thumbnails**

The individual thumbnail images are positioned exactly at the beginning of the corresponding frame.

When you zoom in and there is enough space between the frames, the thumbnail is repeated as many times as there is free space available. Thus, you can always see a thumbnail regardless of how much you zoom in.

**Thumbnail Memory Cache Size**

In the Preferences dialog on the Video page, you can enter a value for the “Thumbnail Memory Cache Size”. This determines how much memory is available for displaying “real” thumbnails. The currently shown image is buffered in the thumbnail memory cache. Whenever you move to another image and there is no memory capacity left, the “oldest” picture in the cache is replaced by the current one. If you have long video clips and/or work with a large zoom factor, you may have to raise the “Thumbnail Memory Cache Size” value.

**About thumbnail cache files**

When importing video, Cubase automatically creates a thumbnail cache file. The cache file is used in situations where the processor load is very high and the correct redrawing or realtime calculation of thumbnails might use system resources necessary for editing or processing. When you zoom in on the thumbnails, you see
that they are in a lower resolution, i.e. the pictures are not as clear as when they are calculated. When the processes that rely heavily on the computer CPU are finished, the frames are automatically recalculated, i.e. the program automatically switches between realtime calculation of the pictures and using the cache file.

**NOTE**

There are situations where no thumbnail cache file can be generated, e.g. if you import a video file from a folder that is write-protected. If you have access to the host folder at a later stage, you can generate a thumbnail cache file manually.

**Manually Generating Thumbnail Cache Files**

If no thumbnail cache file could be generated during import or if you have to “refresh” a thumbnail cache file of a certain video file, because the file has been edited with an external video editing application, you have the possibility to generate the thumbnail cache file manually.

To create a thumbnail cache file manually, you have the following possibilities:

- In the Pool, right-click on the video file that you want to create a thumbnail cache file for and select the “Generate Thumbnail Cache” option from the context menu.
  
  A thumbnail cache file is created, or, in case there already existed a thumbnail cache file for the video file, it is “refreshed”.

- In the Project window, open the context menu for the video event, and select “Generate Thumbnail Cache” from the Media submenu.

- Open the Media Menu and select “Generate Thumbnail Cache”.

**NOTE**

- “Refreshing” an already existing thumbnail cache file can be done only from within the Pool.

- The thumbnail cache file is generated in the background so that you can continue working with Cubase.

**Playing Back Video**

Video is played back together with all other audio and MIDI material, using the Transport controls.

**IMPORTANT**

- For playing back video files, you must have QuickTime 7.1 or higher installed on your computer. There is a freeware version and a “pro” version, which offers additional video conversion options. The player engine is the same in both versions, so for mere playback in Cubase there is no need to purchase the "pro" version.
Video
Playing Back Video

- You need a video card that supports OpenGL (version 2.0 recommended) for proper video playback. A card with OpenGL 1.2 can also be used, but might put restrictions on the video functionality.

To check if your video equipment is capable of playing back a video from within Cubase, open the Video Player page in the Device Setup dialog. If your system does not meet the minimum video requirements, a corresponding message will be displayed.

Device Setup

In the Device Setup dialog you determine which device is used for playing back video files.

![The Video Player page in the Device Setup dialog](image)

You can switch between different output devices during playback.

Setting Up a Video Output Device

**PROCEDURE**

1. Open the Devices Menu and select “Device Setup...” to open the Device Setup dialog, and select the Video Player page.

2. In the Active column, activate the checkbox for the device that you want to use for playing back video.
   
   All devices in your system that are capable of playing back video are listed. The Onscreen Window device serves for playing back the video file on your computer monitor.

3. From the pop-up menu in the Format column, select an output format.
   
   For the Onscreen Window output, only a “fixed” format is available. For the other output devices, you can select different output formats for playback depending on the device.

4. Adjust the Offset setting to compensate for processing delays.
   
   Due to delays while processing video, the video image may not match with the audio in Cubase. By using the Offset parameter, you can compensate for this effect. The Offset value indicates how many milliseconds the video will be delivered earlier in order to compensate for the processing time of the video material. Each hardware setup can have different processing delays, so you must try out different values to determine which value is appropriate.

**NOTE**

- The Offset value can be set individually for each output device. It is saved globally for each output device and is independent of the project.
• The offset is only used during playback. It is defeated in stop and scrub mode so that you always see the correct video frame.

AFTER COMPLETING THIS TASK

If the quality of the video image is not a critical factor or if you are experiencing performance problems, try lowering the value on the Video Quality pop-up menu. Although higher quality settings make the video display sharper and smoother, they also lead to an increased processor load.

RELATED LINKS

Video Output Devices on page 982

Improving Video Performance

Sometimes, video problems, such as stutters during playback, are caused by codecs that do not support multi-threading. This can be the case for video files that use single-threaded decoding, such as Motion-JPEG, Photo-JPEG, and QuickTime DV codecs. These types of video files are typically created when capturing video with Decklink/AJA cards.

To compensate for this, you can activate the “Boost Video (Reduces Audio Performance)” option on the Video Player page in the Device Setup dialog. This excludes one of the available CPU cores from audio processing and reserves it for video tasks like decoding and playback. However, this may reduce the audio performance.

NOTE

For this option to have an effect, you must also activate the Multi Processing option in the Device Setup dialog (VST Audio System page).

Video Player

The Video Player window is used for playing back video on your computer screen.

• To open the Video Player window, open the Devices menu and select the “Video Player” option.

Setting the Window Size and Video Quality

To resize the Video Player window and/or change the playback quality of the video, select the appropriate option on the context menu of the Video Player window.

Fullscreen Mode

The window is enlarged to occupy the whole (computer) screen. If you are working with more than one monitor, you can move the Video Player window to an extra monitor. Thus, you can work with Cubase on one monitor and let the video play back on another monitor. You can exit full screen mode via the window’s context menu or by pressing [Esc] on your computer keyboard.
Quarter Size
The window size is reduced to a quarter of the actual size.

Half Size
The window size is reduced to half the actual size.

Actual Size
The window size corresponds to the size of the video.

Double Size
The window is enlarged to twice the actual size.

Video Quality
This submenu allows you to change the quality of the video image.

NOTE
- To resize the Video Player window, you can also drag the borders.
- The higher the resolution, the more processing power is needed for playback. If you need to reduce the processor load, you can reduce the size of the Video Player window, or lower the value on the Video Quality submenu.

Setting the Aspect Ratio

Resizing the Video Player window by dragging its borders may lead to a distorted image. To prevent this, you can set an aspect ratio for video playback.

From the Aspect Ratio submenu of the Video Player context menu, select one of the following options:

None
The aspect ratio of the video is not kept when resizing the window. The image is enlarged/reduced to occupy the whole Video Player window.

Internal
The Video Player window can be resized at will, but the aspect ratio of the video is kept and black borders are displayed around the video image to fill the window.

External
The resizing of the Video Player window is limited according to the aspect ratio of the video image, i.e. the video image always fills the full window and its aspect ratio is kept.

NOTE
When the video is played back in full screen mode, the aspect ratio of the video is always kept.
**Scrubbing Video**

You can scrub video events, i.e. play them back forwards or backwards at any speed. This is done by clicking in the Video Player window and moving the mouse to the left or to the right. You can also use the Scrub controls on the Transport panel or a jog wheel on a remote controller for scrubbing video events.

**RELATED LINKS**
- Project Scrubbing - The Jog Wheel on page 199
- Playing Back with the Shuttle Speed Wheel on page 199

**Editing Video**

Video clips are played back by events just as audio clips are.

You can use all the basic editing operations on video events, just as with audio events. You can take a single event and copy it many times for the creation of mix variations. A video event may also be trimmed using the event handles to remove a countdown for instance. Furthermore, you can lock video events just like other events in the Project window, and you can edit video clips in the Pool.

It is not possible to fade or crossfade video events. Furthermore, you cannot use the Draw, Glue, and Mute tools with a video event.

**NOTE**

Windows only: If you find that you are unable to edit a video file copied from a CD, this might be due to the fact that files copied from CD are write-protected by default. To remove the write-protection, in the Windows Explorer, open the Properties dialog and deactivate the “Read-Only” option.

**RELATED LINKS**
- Pool on page 499

**Extracting Audio From a Video File**

If a video file contains audio, the audio stream can be extracted.

As always when importing audio material, a dialog is displayed allowing you to select different import options.

There are several ways to extract audio from a video file:

- By activating the “Extract Audio From Video” option in the Import Video dialog.
- By using the “Audio from Video File” option on the Import submenu of the File menu.

This will insert an audio event starting at the project cursor position on the selected audio track. If no audio track is selected, a new one will be created.
Replacing the Audio in a Video File

Once you have edited all audio and MIDI data to the video and created a final mix, you will need to put the new audio back with the video. You can do this by embedding the audio in another stream within the video container file.

**PROCEDURE**

1. Place the left locator at the start of the video file in Cubase. This will ensure that your audio and video streams are synchronized.

2. Open the File menu and select the Audio Mixdown option from the Export submenu to export the audio file you wish to insert into the video container file.

3. From the File menu, select “Replace Audio in Video File…”.
   A file dialog opens prompting you to locate the video file.

4. Select the video file and click Open.
   Next, you are prompted to locate the corresponding audio file.

5. Select the audio file and click Open.
   The audio is added to the video file, replacing its current audio stream.

**AFTER COMPLETING THIS TASK**

Once the process is completed, open the video file in a native media player and check for proper synchronization.

**RELATED LINKS**

- Export Audio Mixdown on page 938
Introduction

ReWire is a special protocol for streaming audio between two computer applications.

Developed by Propellerhead Software and Steinberg, ReWire provides the following possibilities and features:

- Realtime streaming of up to 256 (Cubase Artist: 128) separate audio channels, at full bandwidth, from the “synthesizer application” into the “mixer application”.
  
  In this case, the “mixer application” is of course Cubase. An example of a “synthesizer application” is Propellerhead Software’s Reason.

- Automatic, sample accurate synchronization between the audio in the two programs.

- The possibility to have the two programs share one audio card and take advantage of multiple outputs on that card.

- Linked transport controls that allow you to play, rewind, etc., either from Cubase or from the synthesizer application (provided it has some kind of transport functionality).

- Automatic audio mixing functions of separate channels as required.
  
  In the case of Reason, for example, this allows you to have separate channels for the different devices.

- Additionally, ReWire offers the possibility to route MIDI tracks in Cubase to the other application, for full MIDI control.
  
  For each ReWire compatible device, a number of extra MIDI outputs will be made available in Cubase. In the case of Reason, this allows you to route different MIDI tracks in Cubase to different devices in Reason, with Cubase serving as the main MIDI sequencer.

- The overall load on your system is much reduced, compared to when using the programs together in the conventional way.
Launching and quitting

When using ReWire, the order in which you launch and quit the two programs is very important.

Launching for normal use with ReWire

**PROCEDURE**

1. First launch Cubase.
2. Enable one or several ReWire channels in the ReWire Device dialog for the other application.
3. Launch the other application.
   It may take slightly longer for the application to start when you are using ReWire.

**RELATED LINKS**

Activating ReWire channels on page 994

Quitting a ReWire session

When you are finished, you also need to quit the applications in a special order.

**PROCEDURE**

1. First quit the synthesizer application.
2. Then quit Cubase.

Launching both programs without using ReWire

We cannot think of any scenario, in which you would need to run Cubase and the synthesizer application simultaneously on the same computer, without using ReWire, but you can.

**PROCEDURE**

1. First launch the synthesizer application.
2. Then launch Cubase.

**NOTE**

Please note that the two programs now compete for system resources such as audio cards, just as when running either with other, non-ReWire audio applications.
Activating ReWire channels

ReWire supports streaming of up to 256 (Cubase Artist: 128) separate audio channels. The exact number of available ReWire channels depends on the synthesizer application. Using the ReWire Device panels in Cubase, you can specify which of the available channels you want to use.

**PROCEDURE**

1. Open the Devices menu and select the menu item with the name of the ReWire application. All recognized ReWire compatible applications will be available on the menu.
   The ReWire panel appears. This consists of a number of rows, one for each available ReWire channel.
2. Click on the power buttons to the left to activate/deactivate the desired channels.
   The buttons light up to indicate activated channels. Please note that the more ReWire channels you activate, the more processing power is required.
   For information about exactly what signal is carried on each channel, see the documentation of the synthesizer application.
3. If desired, double-click on the labels in the right column, and type in another name.
   These labels will be used in the Cubase MixConsole to identify the ReWire channels.

Using the transport and tempo controls

**IMPORTANT**

This is only relevant if the synthesizer application has some sort of built-in sequencer or similar.

Basic transport controls

When you run ReWire, the transports in the two programs are completely linked. It does not matter in which program you play, stop, fast forward or rewind. However, recording (if applicable) is still completely separate in the two applications.

Loop settings

If there is a loop or cycle facility in the synthesizer application, that loop will be completely linked to the cycle in Cubase. This means that you can move the start and end point for the loop or turn the loop on or off in either program, and this will be reflected in the other.
Tempo settings

As far as tempo goes, Cubase is always the master. This means that both programs will run in the tempo set in Cubase.

However, if you are not using the tempo track in Cubase, you can adjust the tempo in either program, and this will immediately be reflected in the other.

**IMPORTANT**

If you are using the tempo track in Cubase (i.e. the Tempo button is activated on the Transport panel), you should not adjust the tempo in the synthesizer application, since a tempo request from ReWire will automatically deactivate the tempo track in Cubase!

How the ReWire channels are handled

When you activate ReWire channels in the ReWire Device panels, they will become available as channels in the MixConsole.

The ReWire channels have the following properties:

- ReWire channels may be any combination of mono and stereo, depending on the synthesizer application.
- ReWire channels have the same functionality as regular audio channels. This means you can set volume and pan, add EQ, insert effects and sends, and route the channel outputs to groups or busses. However, ReWire channels have no monitor buttons.
- All channel settings can be automated using the Read/Write buttons. When you write automation, channel automation tracks will automatically appear in the Project window. This allows you to view and edit the automation graphically, just as with VST instrument channels, etc.
- You can mix down the audio from ReWire channels to a file on your hard disk with the Export Audio Mixdown function. You can export the output bus to which you have routed the ReWire channels. Cubase Pro only: You can also export individual ReWire channels directly – “rendering” each ReWire channel to a separate audio file.

**RELATED LINKS**

- Mixing down to audio files on page 939
Routing MIDI via ReWire

When using Cubase with a ReWire-compatible application, additional MIDI outputs will automatically appear on the MIDI Output pop-up menus for MIDI tracks. This allows you to play the synthesizer application via MIDI from Cubase, using it as one or several separate MIDI sound sources.

The MIDI outputs for a Reason song. Here, each output goes directly to a device in the Reason rack.

- The number and configuration of MIDI outputs depends on the synthesizer application.

Considerations and limitations

Sample rates

Synthesizer applications may be limited to audio playback in certain sample rates. If Cubase is set to a sample rate other than those, the synthesizer application will play back at the wrong pitch. Consult the documentation of the synthesizer application for details.

ASIO drivers

ReWire works well with ASIO drivers. By using the Cubase bus system you can route sounds from the synthesizer application to various outputs on an ASIO compatible audio card.
Key Commands

Introduction

Most of the main menus in Cubase have key command shortcuts for certain items on the menus. In addition, there are numerous other Cubase functions that can be performed via key commands. These are all default settings.

You can customize existing key commands to your liking, and also add commands for many menu items and functions that currently have no key command assigned.

You can find out for which functions key commands can be assigned by looking in the Key commands dialog (see below), or by checking the tooltip for a particular interface element. If a tooltip shows [!] at the end, you can assign a key command to this function. Assigned key commands are shown in the tooltips in square brackets.

IMPORTANT

You can also assign tool modifier keys, i.e. keys that change the behavior of various tools when pressed. This is done in the Preferences dialog.

RELATED LINKS

Setting up tool modifier keys on page 1003

How are key commands settings saved?

Every time you edit or add any key command assignment, this is stored as a global Cubase preference – not as part of a project. If you edit or add a key command assignment, any subsequent projects that you create or open will use these modified settings. However, the default settings can be restored at any time by clicking the Reset All button in the Key Commands dialog.

In addition, you can save key commands settings as a "key commands file", which is stored separately and can be imported into any project. This way you can quickly and easily recall customized settings, when moving projects between different computers, for example. The settings are saved in an XML file on the hard disk.

RELATED LINKS

Saving key commands presets on page 1001
Setting up key commands

Adding or modifying a key command

In the Key Commands dialog you will find all main menu items and a large number of other functions, arranged in a hierarchical way similar to the Windows Explorer and Mac OS Finder. The function categories are represented by a number of folders, each containing various menu items and functions.

When you open a category folder by clicking the “+” sign beside it, the items and functions it contains are displayed with the currently assigned key commands.

To add a key command, proceed as follows:

**PROCEDURE**

1. Open the File menu and select “Key Commands…”.
   The Key Commands dialog opens.
2. In the Commands list on the left, choose a category.
3. Click the “+” sign to open the category folder and display the items it contains.
   Note that you can also click the “global” “+” and “-” signs in the top left corner to open and close all category folders at once.
4. In the list, select the item to which you want to assign a key command.
   Already assigned key commands are shown in the Keys column as well as in the Keys section in the top right corner.
5. Alternatively, you can use the search function in the dialog to find the desired item. For a description of how to use the search function, see below.

6. When you have found and selected the desired item, click in the “Type in Key” field and enter a new key command. You can choose any single key or a combination of one or several modifier keys ([Alt]/[Option], [Ctrl]/[Command], [Shift]) plus any key. Just press the keys you want to use.

7. If the key command you enter is already assigned to another item or function, this is displayed below the “Type in Key” field. You can either ignore this and proceed to assign the key command to the new function instead, or you can select another key command.

8. Click the Assign button above the field. The new key command appears in the Keys List.

**IMPORTANT**

If the key command you enter is already assigned to another function, you will get a warning message asking if you really want to reassign the command to the new function.

9. Click OK to exit the dialog.

**NOTE**

You can set up several different key commands for the same function. Adding a key command to a function that already has another key command will not replace the key command previously defined for the function. If you wish to remove a key command, see below.

---

**Searching for key commands**

If you want to know which key command is assigned to a certain function in the program, you can use the Search function in the Key Commands dialog.

**PROCEDURE**

1. Click in the search text field at the top left of the dialog and type in the function for which you want to know the key command. This is a standard word search function, so you should type the command as it is spelled in the program. Partial words can be used; to search for all quantize related commands, type “Quantize”, “Quant”, etc.

2. Click the Search button (the magnifying glass icon). The search is conducted and the first matching command is selected and displayed in the Commands list below. The Keys column and the Keys list show the assigned key commands, if any.

3. To search for more commands containing the word(s) you entered, click the Search button again.

4. When you are done, click OK to close the dialog.
Removing a key command

PROCEDURE
1. Use the list of categories and commands to select the item or function for which you wish to remove a key command.
   The key command is shown in the Keys column and the Keys list.
2. Select the key command in the Keys list and click the Delete button (the trash icon).
   You are asked whether you really want to remove the key command.
3. Click Remove to remove the selected key command.
4. Click OK to close the dialog.

Setting up macros

A macro is a combination of several functions or commands to be performed in one go. For example, you can select all events on the selected audio track, remove DC offset, normalize the events and duplicate them, all with a single command.

Macros are set up in the Key Commands dialog as follows:

PROCEDURE
1. Click the Show Macros button.
   The macro settings are shown in the lower part of the dialog. To hide these from view, click the button (now renamed Hide Macros) again.
2. Click New Macro.
   A new, unnamed macro appears in the Macros list. Name it by typing the desired name. You can rename a macro at any time by selecting it in the list and typing in a new name.
3. Make sure that the macro is selected, and use the categories and commands in the upper half of the dialog to select the first command you want to include in the macro.
4. Click Add Command.
   The selected command appears in the list of commands in the Macros section.
5. Repeat the procedure to add more commands to the macro.
   Note that commands are added after the currently selected command in the list. This allows you to insert commands “in the middle” of an existing macro.
A macro with three commands

- To remove a command from the macro, select it in the Macros list and click Delete.
- Similarly, to remove an entire macro, select it in the Macros list and click Delete.

After you have closed the Key Commands dialog, all macros you have created appear at the bottom of the Edit menu in the Macros submenu, available for instant selection.

You can also assign key commands to macros. All macros you have created appear in the upper section of the Key Commands dialog under the Macros category – just select a macro and assign a key command as with any other function.

### Saving key commands presets

As mentioned above, any changes made to the key commands are automatically stored as a Cubase preference. However, it is also possible to save key commands settings separately. This way, you can save any number of different key command settings as presets for instant recall.

**PROCEDURE**

1. Set up the key commands to your liking.
   When setting up key commands, remember to click “Assign” to make the changes.
2. Click the Save button next to the Presets pop-up menu.
   A dialog opens, allowing you to type in a name for the preset.
3. Click OK to save the preset.
   Your saved key commands settings are now available on the Presets pop-up menu.

### Loading key command presets

To load a key command preset, simply select it from the Presets pop-up menu.

**NOTE**

The key command settings you load will replace the current key command settings for the same functions (if any). If you have macros of the same name as those stored in the preset you load, these will be replaced too. If you want to be able to revert to your current settings again, make sure to save them first, as described above!
Loading earlier key commands settings

If you have saved key commands settings with an earlier program version, it is possible to use them in this Cubase version, by using the “Import Key Command File” function, which lets you load and apply saved key commands.

**PROCEDURE**

1. Open the Key Commands dialog.
2. Click the “Import Key Command File” button to the right of the Presets pop-up menu.
   A standard file dialog opens.
3. In the file dialog, use the “Files of type” pop-up menu to specify if you want to import a key commands file (”.key”) or a macro commands file (extension “.mac”).
   When you have imported an older file, you might want to save it as a preset (see above) to be able to access it from the Presets pop-up menu in the future.
4. Navigate to the file you want to import and click “Open”.
   The file is imported.
5. Click OK to exit the Key Commands dialog and apply the imported settings.
   The settings in the loaded key commands file or macros file now replace the current settings.

About the Reset and Reset All functions

These two buttons in the Key Commands dialog will both restore the default settings. The following rules apply:

- “Reset” will restore the default key command setting for the function selected in the Commands list.
- “Reset All” will restore the default key commands for all commands.

**IMPORTANT**

Note that the “Reset All” operation will cause any changes made to the default key commands to be lost! If you want to be able to revert to these settings again, make sure to save them first!
Setting up tool modifier keys

A tool modifier key is a key you can press to get an alternate function when using a tool. For example, clicking and dragging an event with the Object Selection tool normally moves it – holding down a modifier key (by default [Alt]/[Option]) while dragging will copy it instead.

The default assignments for tool modifier keys can be found in the Preferences dialog (Editing–Tool Modifiers page). Here, you can also edit them:

**PROCEDURE**

1. Open the Preferences dialog and select the Editing–Tool Modifiers page.
2. Select an option in the Categories list, and locate the action for which you want to edit the modifier key.
   For example, the “Copy” action mentioned above resides in the category “Drag & Drop”.
3. Select the action in the Action list.
4. Hold down the desired modifier key(s) and click the Assign button.
   The current modifier keys for the action are replaced. If the modifier keys you pressed are already assigned to another tool, you will be asked whether you want to overwrite them. If you do, this will leave the other tool without any modifier keys assigned.
5. When you are done, click OK to apply the changes and close the dialog.

The default key commands

Below, the default key commands are listed according to category.

**NOTE**

When the Virtual Keyboard is displayed, the usual key commands are blocked because they are reserved for the Virtual Keyboard. The only exceptions are: [Ctrl]/[Command]-[S] (Save), Num [*] (Start/Stop Record), [Space] (Start/Stop Playback), Num [1] (Jump to left locator), [Delete] or [Backspace] (Delete), Num [/] (Cycle on/off), [F2] (Show/Hide Transport panel), and [Alt]/[Option]-[K] (Show/Hide Virtual Keyboard).
### Audio category

<table>
<thead>
<tr>
<th>Option</th>
<th>Key command</th>
</tr>
</thead>
<tbody>
<tr>
<td>Adjust Fades to Range</td>
<td>[A]</td>
</tr>
<tr>
<td>Auto-Grid</td>
<td>[Shift]-[Q]</td>
</tr>
<tr>
<td>Crossfade</td>
<td>[X]</td>
</tr>
</tbody>
</table>

### Automation category

<table>
<thead>
<tr>
<th>Option</th>
<th>Key command</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open Panel</td>
<td>[F6]</td>
</tr>
<tr>
<td>Read Automation for All Tracks On/Off</td>
<td>[Alt]/[Option]-[R]</td>
</tr>
<tr>
<td>Write Automation for All Tracks On/Off</td>
<td>[Alt]/[Option]-[W]</td>
</tr>
</tbody>
</table>

### Chords

<table>
<thead>
<tr>
<th>Option</th>
<th>Key command</th>
</tr>
</thead>
<tbody>
<tr>
<td>Chord Pads</td>
<td>[Ctrl]/[Command]-[Shift]-[C]</td>
</tr>
</tbody>
</table>

### Devices category

<table>
<thead>
<tr>
<th>Option</th>
<th>Key command</th>
</tr>
</thead>
<tbody>
<tr>
<td>MixConsole</td>
<td>[F3]</td>
</tr>
<tr>
<td>Video</td>
<td>[F8]</td>
</tr>
<tr>
<td>Virtual Keyboard</td>
<td>[Alt]/[Option]-[K]</td>
</tr>
<tr>
<td>VST Connections</td>
<td>[F4]</td>
</tr>
<tr>
<td>VST Instruments</td>
<td>[F11]</td>
</tr>
<tr>
<td>VST Performance</td>
<td>[F12]</td>
</tr>
</tbody>
</table>

### Edit category

<table>
<thead>
<tr>
<th>Option</th>
<th>Key command</th>
</tr>
</thead>
<tbody>
<tr>
<td>Auto-Scroll On/Off</td>
<td>[F]</td>
</tr>
<tr>
<td>Copy</td>
<td>[Ctrl]/[Command]-[C]</td>
</tr>
<tr>
<td>Cut</td>
<td>[Ctrl]/[Command]-[X]</td>
</tr>
<tr>
<td>Cut Time</td>
<td>[Ctrl]/[Command]-[Shift]-[X]</td>
</tr>
<tr>
<td>Delete</td>
<td>[Delete] or [Backspace]</td>
</tr>
<tr>
<td>Delete Time</td>
<td>[Shift]-[Backspace]</td>
</tr>
<tr>
<td>Duplicate</td>
<td>[Ctrl]/[Command]-[D]</td>
</tr>
<tr>
<td>Option</td>
<td>Key command</td>
</tr>
<tr>
<td>---------------------------------------------</td>
<td>--------------------------------------------------</td>
</tr>
<tr>
<td>Edit In-Place</td>
<td>[Ctrl]/[Command]-[Shift]-[I]</td>
</tr>
<tr>
<td>Group</td>
<td>[Ctrl]/[Command]-[G]</td>
</tr>
<tr>
<td>Insert Silence</td>
<td>[Ctrl]/[Command]-[Shift]-[E]</td>
</tr>
<tr>
<td>Left Selection Side to Cursor</td>
<td>[E]</td>
</tr>
<tr>
<td>Lock</td>
<td>[Ctrl]/[Command]-[Shift]-[L]</td>
</tr>
<tr>
<td>Move to Cursor</td>
<td>[Ctrl]/[Command]-[L]</td>
</tr>
<tr>
<td>Move to Front (Uncover)</td>
<td>[U]</td>
</tr>
<tr>
<td>Mute</td>
<td>[M]</td>
</tr>
<tr>
<td>Mute Events</td>
<td>[Shift]-[M]</td>
</tr>
<tr>
<td>Mute/Unmute Objects</td>
<td>[Alt]/[Option]-[M]</td>
</tr>
<tr>
<td>Open Default Editor</td>
<td>[Ctrl]/[Command]-[E]</td>
</tr>
<tr>
<td>Open Score Editor</td>
<td>[Ctrl]/[Command]-[R]</td>
</tr>
<tr>
<td>Open/Close Editor</td>
<td>[Return]</td>
</tr>
<tr>
<td>Paste</td>
<td>[Ctrl]/[Command]-[V]</td>
</tr>
<tr>
<td>Paste at Origin</td>
<td>[Alt]/[Option]-[V]</td>
</tr>
<tr>
<td>Paste Time</td>
<td>[Ctrl]/[Command]-[Shift]-[V]</td>
</tr>
<tr>
<td>Primary Parameter: Decrease</td>
<td>[Ctrl]/[Command]-[Shift]-[Down Arrow]</td>
</tr>
<tr>
<td>Primary Parameter: Increase</td>
<td>[Ctrl]/[Command]-[Shift]-[Up Arrow]</td>
</tr>
<tr>
<td>Record Enable</td>
<td>[R]</td>
</tr>
<tr>
<td>Redo</td>
<td>[Ctrl]/[Command]-[Shift]-[Z]</td>
</tr>
<tr>
<td>Repeat</td>
<td>[Ctrl]/[Command]-[K]</td>
</tr>
<tr>
<td>Right Selection Side to Cursor</td>
<td>[D]</td>
</tr>
<tr>
<td>Secondary Parameter: Decrease</td>
<td>[Ctrl]/[Command]-[Shift]-[Left Arrow]</td>
</tr>
<tr>
<td>Secondary Parameter: Increase</td>
<td>[Ctrl]/[Command]-[Shift]-[Right Arrow]</td>
</tr>
<tr>
<td>Select All</td>
<td>[Ctrl]/[Command]-[A]</td>
</tr>
<tr>
<td>Select None</td>
<td>[Ctrl]/[Command]-[Shift]-[A]</td>
</tr>
<tr>
<td>Snap On/Off</td>
<td>[J]</td>
</tr>
<tr>
<td>Solo</td>
<td>[S]</td>
</tr>
<tr>
<td>Split At Cursor</td>
<td>[Alt]/[Option]-[X]</td>
</tr>
<tr>
<td>Split Range</td>
<td>[Shift]-[X]</td>
</tr>
<tr>
<td>Edit Group on Selected Tracks On/Off</td>
<td>[K]</td>
</tr>
<tr>
<td>Undo</td>
<td>[Ctrl]/[Command]-[Z]</td>
</tr>
<tr>
<td>Ungroup</td>
<td>[Ctrl]/[Command]-[U]</td>
</tr>
<tr>
<td>Unlock</td>
<td>[Ctrl]/[Command]-[Shift]-[U]</td>
</tr>
<tr>
<td>Unmute Events</td>
<td>[Shift]-[U]</td>
</tr>
<tr>
<td>Write</td>
<td>[W]</td>
</tr>
</tbody>
</table>
### Key Commands

The default key commands

#### Editors category

<table>
<thead>
<tr>
<th>Option</th>
<th>Key command</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show/Hide Editors</td>
<td>[Ctrl]/[Command]-[Alt]/[Option]-[E]</td>
</tr>
<tr>
<td>Show/Hide Info Line</td>
<td>[Ctrl]/[Command]-[I]</td>
</tr>
<tr>
<td>Show/Hide Inspector</td>
<td>[Alt]/[Option]-[I]</td>
</tr>
<tr>
<td>Show/Hide Overview</td>
<td>[Alt]/[Option]-[O]</td>
</tr>
<tr>
<td>Show/Hide Rack</td>
<td>[Alt]/[Option]-[T]</td>
</tr>
<tr>
<td>Toggle Rack Tabs</td>
<td>[Ctrl]/[Command]-[Alt]/[Option]-[T]</td>
</tr>
</tbody>
</table>

#### File category

<table>
<thead>
<tr>
<th>Option</th>
<th>Key command</th>
</tr>
</thead>
<tbody>
<tr>
<td>Close</td>
<td>[Ctrl]/[Command]-[W]</td>
</tr>
<tr>
<td>New</td>
<td>[Ctrl]/[Command]-[N]</td>
</tr>
<tr>
<td>Open</td>
<td>[Ctrl]/[Command]-[O]</td>
</tr>
<tr>
<td>Quit</td>
<td>[Ctrl]/[Command]-[Q]</td>
</tr>
<tr>
<td>Save</td>
<td>[Ctrl]/[Command]-[S]</td>
</tr>
<tr>
<td>Save As</td>
<td>[Ctrl]/[Command]-[Shift]-[S]</td>
</tr>
<tr>
<td>Save New Version</td>
<td>[Ctrl]/[Command]-[Alt]/[Option]-[S]</td>
</tr>
</tbody>
</table>

#### Inspector

<table>
<thead>
<tr>
<th>Option</th>
<th>Key command</th>
</tr>
</thead>
<tbody>
<tr>
<td>Toggle Inspector Footer Tabs</td>
<td>[Ctrl]/[Command]-[Alt]/[Option]-[Shift]-[T]</td>
</tr>
<tr>
<td>Toggle Inspector Tabs</td>
<td>[Ctrl]/[Command]-[Shift]-[T]</td>
</tr>
</tbody>
</table>

#### Media category

<table>
<thead>
<tr>
<th>Option</th>
<th>Key command</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open MediaBay</td>
<td>[F5]</td>
</tr>
<tr>
<td>Open Mini Browser</td>
<td>[F7]</td>
</tr>
<tr>
<td>Preview Cycle On/Off</td>
<td>[Shift]-Num [/]</td>
</tr>
<tr>
<td>Preview Start</td>
<td>[Shift]-[Enter]</td>
</tr>
<tr>
<td>Preview Stop</td>
<td>[Shift]-Num [0]</td>
</tr>
<tr>
<td>Search MediaBay</td>
<td>[Shift]-[F5]</td>
</tr>
<tr>
<td>Toggle Attribute Inspector</td>
<td>[Ctrl]/[Command]-[Alt]/[Option]-Num [6]</td>
</tr>
<tr>
<td>Toggle Filters</td>
<td>[Ctrl]/[Command]-[Alt]/[Option]-Num [5]</td>
</tr>
</tbody>
</table>
### Key Commands

The default key commands

<table>
<thead>
<tr>
<th>Option</th>
<th>Key command</th>
</tr>
</thead>
<tbody>
<tr>
<td>Toggle Location Tree</td>
<td>[Ctrl]/[Command]-[Alt]/[Option]-Num [4]</td>
</tr>
<tr>
<td>Toggle Locations</td>
<td>[Ctrl]/[Command]-[Alt]/[Option]-Num [8]</td>
</tr>
<tr>
<td>Toggle Previewer</td>
<td>[Ctrl]/[Command]-[Alt]/[Option]-Num [2]</td>
</tr>
</tbody>
</table>

#### MIDI category

<table>
<thead>
<tr>
<th>Option</th>
<th>Key command</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show/Hide Controller Lanes</td>
<td>[Alt]/[Option]-[L]</td>
</tr>
</tbody>
</table>

#### Navigate category

<table>
<thead>
<tr>
<th>Option</th>
<th>Key command</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add Down: Expand/Undo selection in the Project window to the bottom/Move selected event in the Key Editor down 1 octave</td>
<td>[Shift]-[Down Arrow]</td>
</tr>
<tr>
<td>Add Left: Expand/Undo selection in the Project window/Key Editor to the left</td>
<td>[Shift]-[Left Arrow]</td>
</tr>
<tr>
<td>Add Right: Expand/Undo selection in the Project window/Key Editor to the right</td>
<td>[Shift]-[Right Arrow]</td>
</tr>
<tr>
<td>Add Up: Expand/Undo selection in the Project window to the top/Move selected event in the Key Editor up one octave</td>
<td>[Shift]-[Up Arrow]</td>
</tr>
<tr>
<td>Bottom: Select bottom track in the track list</td>
<td>[End]</td>
</tr>
<tr>
<td>Down: Select next in the Project window/Move selected event in the Key Editor one semitone down</td>
<td>[Down Arrow]</td>
</tr>
<tr>
<td>Left: Select next in the Project window/Key Editor</td>
<td>[Left Arrow]</td>
</tr>
<tr>
<td>Right: Select next in the Project window/Key Editor</td>
<td>[Right Arrow]</td>
</tr>
</tbody>
</table>
### Key Commands

**The default key commands**

<table>
<thead>
<tr>
<th>Option</th>
<th>Key command</th>
</tr>
</thead>
<tbody>
<tr>
<td>Top:</td>
<td>[Home]</td>
</tr>
<tr>
<td>Select top track in the track list</td>
<td></td>
</tr>
<tr>
<td>Toggle Selection</td>
<td>[Ctrl]/[Command]-[Space]</td>
</tr>
<tr>
<td>Up:</td>
<td>[Up Arrow]</td>
</tr>
<tr>
<td>Select next in the Project window/ Move selected event in the Key Editor one semitone up</td>
<td></td>
</tr>
</tbody>
</table>

### Nudge category

<table>
<thead>
<tr>
<th>Option</th>
<th>Key command</th>
</tr>
</thead>
<tbody>
<tr>
<td>End Left</td>
<td>[Alt]/[Option]-[Shift]-[Left Arrow]</td>
</tr>
<tr>
<td>End Right</td>
<td>[Alt]/[Option]-[Shift]-[Right Arrow]</td>
</tr>
<tr>
<td>Left</td>
<td>[Ctrl]/[Command]-[Right Arrow]</td>
</tr>
<tr>
<td>Right</td>
<td>[Ctrl]/[Command]-[Right Arrow]</td>
</tr>
<tr>
<td>Start Left</td>
<td>[Alt]/[Option]-[Left Arrow]</td>
</tr>
<tr>
<td>Start Right</td>
<td>[Alt]/[Option]-[Right Arrow]</td>
</tr>
</tbody>
</table>

### Project category

<table>
<thead>
<tr>
<th>Option</th>
<th>Key command</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open Browser</td>
<td>[Ctrl]/[Command]-[B]</td>
</tr>
<tr>
<td>Open Markers</td>
<td>[Ctrl]/[Command]-[M]</td>
</tr>
<tr>
<td>Open Pool</td>
<td>[Ctrl]/[Command]-[P]</td>
</tr>
<tr>
<td>Open Tempo Track</td>
<td>[Ctrl]/[Command]-[T]</td>
</tr>
<tr>
<td>Remove Selected Tracks</td>
<td>[Shift]-[Delete]</td>
</tr>
<tr>
<td>Setup</td>
<td>[Shift]-[S]</td>
</tr>
</tbody>
</table>

### Quantize category

<table>
<thead>
<tr>
<th>Option</th>
<th>Key command</th>
</tr>
</thead>
<tbody>
<tr>
<td>Quantize</td>
<td>[Q]</td>
</tr>
</tbody>
</table>

### Tool category

<table>
<thead>
<tr>
<th>Option</th>
<th>Key command</th>
</tr>
</thead>
<tbody>
<tr>
<td>Draw tool</td>
<td>[8]</td>
</tr>
<tr>
<td>Drumstick tool</td>
<td>[0]</td>
</tr>
<tr>
<td>Erase tool</td>
<td>[5]</td>
</tr>
</tbody>
</table>
### Key Commands

#### The default key commands

<table>
<thead>
<tr>
<th>Option</th>
<th>Key command</th>
</tr>
</thead>
<tbody>
<tr>
<td>Glue tool</td>
<td>[4]</td>
</tr>
<tr>
<td>Mute tool</td>
<td>[7]</td>
</tr>
<tr>
<td>Next Tool</td>
<td>[F10]</td>
</tr>
<tr>
<td>Play tool</td>
<td>[9]</td>
</tr>
<tr>
<td>Previous Tool</td>
<td>[F9]</td>
</tr>
<tr>
<td>Range tool</td>
<td>[2]</td>
</tr>
<tr>
<td>Object Selection tool</td>
<td>[1]</td>
</tr>
<tr>
<td>Split tool</td>
<td>[3]</td>
</tr>
<tr>
<td>Zoom tool</td>
<td>[6]</td>
</tr>
</tbody>
</table>

### Transport category

<table>
<thead>
<tr>
<th>Option</th>
<th>Key command</th>
</tr>
</thead>
<tbody>
<tr>
<td>Auto Punch In</td>
<td>[I]</td>
</tr>
<tr>
<td>Auto Punch Out</td>
<td>[O]</td>
</tr>
<tr>
<td>Cycle</td>
<td>[+] (Win)/[/] (Mac)</td>
</tr>
<tr>
<td>Exchange Time Formats</td>
<td>[.</td>
</tr>
<tr>
<td>Fast Forward</td>
<td>[Shift]-Num [+</td>
</tr>
<tr>
<td>Fast Rewind</td>
<td>[Shift]-Num [-</td>
</tr>
<tr>
<td>Forward</td>
<td>Num [+</td>
</tr>
<tr>
<td>Input Left Locator</td>
<td>[Shift]-[L]</td>
</tr>
<tr>
<td>Input Position</td>
<td>[Shift]-[P]</td>
</tr>
<tr>
<td>Input Right Locator</td>
<td>[Shift]-[R]</td>
</tr>
<tr>
<td>Insert Marker</td>
<td>[Insert] (Win)</td>
</tr>
<tr>
<td>Locate Next Event</td>
<td>[N]</td>
</tr>
<tr>
<td>Locate Next Hitpoint</td>
<td>[Alt]/[Option]-[N]</td>
</tr>
<tr>
<td>Locate Next Marker</td>
<td>[Shift]-[N]</td>
</tr>
<tr>
<td>Locate Previous Event</td>
<td>[B]</td>
</tr>
<tr>
<td>Locate Previous Hitpoint</td>
<td>[Alt]/[Option]-[B]</td>
</tr>
<tr>
<td>Locate Previous Marker</td>
<td>[Shift]-[B]</td>
</tr>
<tr>
<td>Locate Selection</td>
<td>[L]</td>
</tr>
<tr>
<td>Locators to Selection</td>
<td>[P]</td>
</tr>
<tr>
<td>Loop Selection</td>
<td>[Alt]/[Option]-[P]</td>
</tr>
<tr>
<td>Metronome On/Off</td>
<td>[C]</td>
</tr>
<tr>
<td>Nudge Cursor Left</td>
<td>[Ctrl]/[Command]-Num [-]</td>
</tr>
<tr>
<td>Nudge Cursor Right</td>
<td>[Ctrl]/[Command]-Num [+]</td>
</tr>
<tr>
<td>Panel (Transport panel)</td>
<td>[F2]</td>
</tr>
</tbody>
</table>
### Key Commands
The default key commands

<table>
<thead>
<tr>
<th>Option</th>
<th>Key command</th>
</tr>
</thead>
<tbody>
<tr>
<td>Play Selection Range</td>
<td>[Alt]/[Option]-[Space]</td>
</tr>
<tr>
<td>Record</td>
<td>Num [*]</td>
</tr>
<tr>
<td>Retrospective Record</td>
<td>[Shift]-Num [*]</td>
</tr>
<tr>
<td>Return to Zero</td>
<td>Num [,] or Num [,] or Num [;]</td>
</tr>
<tr>
<td>Rewind</td>
<td>Num [-]</td>
</tr>
<tr>
<td>Set Left Locator</td>
<td>[Ctrl]/[Command]-Num [1]</td>
</tr>
<tr>
<td>Set Marker 1</td>
<td>[Ctrl]/[Command]-[1]</td>
</tr>
<tr>
<td>Set Marker 2</td>
<td>[Ctrl]/[Command]-[2]</td>
</tr>
<tr>
<td>Set Right Locator</td>
<td>[Ctrl]/[Command]-Num [2]</td>
</tr>
<tr>
<td>To Left Locator</td>
<td>Num [1]</td>
</tr>
<tr>
<td>To Marker 1</td>
<td>[Shift]-[1]</td>
</tr>
<tr>
<td>To Marker 2</td>
<td>[Shift]-[2]</td>
</tr>
<tr>
<td>To Right Locator</td>
<td>Num [2]</td>
</tr>
<tr>
<td>Use External Sync</td>
<td>[T]</td>
</tr>
</tbody>
</table>

### Windows category

<table>
<thead>
<tr>
<th>Option</th>
<th>Key command</th>
</tr>
</thead>
<tbody>
<tr>
<td>Inline: Key Commands</td>
<td>[Shift]-[F4]</td>
</tr>
<tr>
<td>Inline: Settings</td>
<td>[Shift]-[F3]</td>
</tr>
<tr>
<td>Inline: View Layout</td>
<td>[Shift]-[F2]</td>
</tr>
</tbody>
</table>

### Workspaces category

<table>
<thead>
<tr>
<th>Option</th>
<th>Key command</th>
</tr>
</thead>
<tbody>
<tr>
<td>New</td>
<td>[Ctrl]/[Command]-Num [0]</td>
</tr>
<tr>
<td>Reset</td>
<td>[Alt]/[Option]-Num [0]</td>
</tr>
<tr>
<td>Update Workspace</td>
<td>[Alt]/[Option]-U</td>
</tr>
<tr>
<td>Workspace 1-9</td>
<td>[Alt]/[Option]-Num [1-9]</td>
</tr>
<tr>
<td>Workspace X</td>
<td>[Ctrl]/[Command]-[Alt]/[Option]-Num [0]</td>
</tr>
</tbody>
</table>
### Zoom category

<table>
<thead>
<tr>
<th>Option</th>
<th>Key command</th>
</tr>
</thead>
<tbody>
<tr>
<td>Zoom Full</td>
<td>[Shift]-[F]</td>
</tr>
<tr>
<td>Zoom In</td>
<td>[H]</td>
</tr>
<tr>
<td>Zoom In Tracks</td>
<td>[Ctrl]/[Command]-[Down Arrow]</td>
</tr>
<tr>
<td>Zoom Out</td>
<td>[G]</td>
</tr>
<tr>
<td>Zoom Out Tracks</td>
<td>[Ctrl]/[Command]-[Up Arrow]</td>
</tr>
<tr>
<td>Zoom to Event</td>
<td>[Shift]-[E]</td>
</tr>
<tr>
<td>Zoom to Selection</td>
<td>[Alt]/[Option]-[S]</td>
</tr>
<tr>
<td>Zoom Tracks Exclusive</td>
<td>[Ctrl]/[Command]-[Alt]/[Option]-[Down Arrow]</td>
</tr>
</tbody>
</table>
File handling

Importing audio

In Cubase audio can be imported in a variety of different formats. For example, you can import tracks from audio CDs, or import audio files saved in different formats (compressed and uncompressed).

RELATED LINKS
Importing Media on page 513

Audio file import options

When you are importing audio files, there are a number of options concerning how the files should be treated by Cubase:

• You can choose to copy the file into the Audio folder of the project and have the project make reference to the copied file rather than the original file. This helps you keep your project “self-contained”.

• You can choose to split stereo and multi-channel files into a number of mono files.

• You can set all files in the project to the same sample rate and sample size (resolution).

Using the “On Import Audio Files” pop-up menu in the Preferences dialog (Editing–Audio page), you can define what Cubase does when importing an audio file. The available options are described in the following.

Open Options Dialog

An Options dialog appears when you import, allowing you to select whether you want to copy the files to the Audio folder and/or convert them to the project settings. Please note the following:

• When importing a single file of a format other than the project settings, you can specify which properties (sample rate and/or resolution) are changed.
When importing multiple files at the same time, you can select to convert the imported files automatically if necessary, i.e. if the sample rate is different than the project’s or the resolution is lower than the project setting.

**NOTE**

When you import 5-channel interleaved files that do not have the speaker arrangement metadata (“BEXT”), Cubase always considers them as 5.0 format.

### Use Settings

No Options dialog will appear when you import. Instead, you can select standard actions from the list below the pop-up menu that are performed automatically each time you import audio files:

**Copy Files to Working Directory**

If files are not already in the project’s audio folder, they are copied there before being imported.

**Convert and Copy to Project If Needed**

If files are not already in the project’s audio folder, they are copied there before being imported. Furthermore, if the files have a different sample rate or a lower resolution than the project settings, they are automatically converted.

**Split channels/Split multi-channel files**

Activate this option to split stereo or multi-channel audio files into a corresponding number of mono files – one for each channel. Note that if you use this option, the imported files are always copied to the Audio folder of the project's working directory.

If you import files using the Import option on the File menu, the split files are inserted into the project and into the Pool as separate mono tracks.

If you import the files using the Import Medium option on the Media menu, the split files are only inserted into the Pool.

In all cases, the “Split File Name Format” pop-up menu lets you specify how the split files are named. This allows for compatibility with other products when exchanging audio files and avoids confusion if the source file contains no stereo or surround material, but poly-mono audio.

### Importing audio CD tracks

You can import audio from audio CDs into Cubase projects in two ways:

- To import the CD tracks directly into project tracks, choose the “Audio CD…” option from the Import submenu of the File menu.

  The imported audio CD track(s) are inserted on the selected audio track(s) at the project cursor position.
To import the CD tracks into the Pool, select “Import Audio CD…” from the Media menu.

This might be the preferred method if you want to import several CD tracks in one go.

Selecting one of the Import Audio CD menu items brings up the following dialog:

1) Play
2) Stop
3) Play from Left Marker
4) Play to Right Marker
5) Start of selection handle
6) End of selection handle

To import one or more tracks, proceed as follows:

**PROCEDURE**

1. If you have more than one CD drive, select the correct one from the Drive pop-up menu at the top left.

   On opening the CD, the program tries to retrieve the track names from CDDB (a CD database). If no connection to CDDB can be established or the CD track names are not found, you can manually change the generic track name in the Default Name field.
2. Windows only: Activate the “Secure Mode” option if you want to use a Secure Read mode.
   Use this if you encounter problems when trying to import an audio CD. Error checking and correction will be done during the process. Note that this mode will take more time.

3. In the Windows version, select the data transfer speed from the Speed pop-up menu.
   While you normally want to use the fastest possible speed, you may have to select a slower speed for flawless audio extraction.

4. Activate the Copy checkbox for every audio file you want to import.
   You can also select a copy section for every file, see below.

5. Click on the Copy button to create a local copy of the audio file(s) or section(s).
   The copied files are listed at the bottom of the dialog. By default, imported audio CD tracks will be stored as Wave files (Windows) or AIFF files (Mac) in the Audio folder of the current project. To change the folder, click Destination Folder and select a different folder from the dialog. During copying, the Copy button is labeled “Stop”; click it to stop the process.

6. Click OK to import the copied audio files into the project, or click Cancel to stop the import and discard the copied files.
   If you import more than one audio file into project tracks, a dialog opens in which you have to choose whether to insert the tracks on one track or on different ones.
   The new track(s) are displayed in the Project window. New audio clips are created and added to the Pool.
   The columns in the “Import from Audio CD” dialog have the following functionality:

<table>
<thead>
<tr>
<th>Column</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Copy</td>
<td>Activate the checkbox in this column for the track you want to copy/import. To activate more than one checkbox, click and drag over the checkboxes (or press [Ctrl]/[Command] or [Shift] and click).</td>
</tr>
<tr>
<td>#</td>
<td>This is the track number.</td>
</tr>
<tr>
<td>CD Track</td>
<td>When you import an audio CD track, the file is named according to this column. The names are pulled automatically from CDDB, if possible. You can rename a track by clicking in the CD Track column and typing a new name. You can also apply a generic name to all audio CD tracks, if no name was available in CDDB.</td>
</tr>
<tr>
<td>Length</td>
<td>The length of the audio CD track in minutes and seconds.</td>
</tr>
<tr>
<td>Size</td>
<td>The file size of the audio CD track in MB.</td>
</tr>
<tr>
<td>Copy Start</td>
<td>You can copy a section of a track if you like. This indicates the start of the section to be copied in the track. By default, this is set to the start of the track (0.000) but you can adjust this on the copy selection ruler, see below.</td>
</tr>
<tr>
<td>Copy End</td>
<td>Indicates the end of the section to be copied in the track. By default, this is set to the end of the track but you can adjust this on the copy selection ruler, see below.</td>
</tr>
</tbody>
</table>

By default, complete tracks are selected.
• If you want to copy and import a section of an audio CD track only, select the track in the list and specify the start and end of the selection to be copied by dragging the handles in the copy selection ruler.

**NOTE**

Note that you can import sections of several audio CD tracks by selecting them in turn and adjusting the selection. The start and end settings for each track are displayed in the list.

• You can audition the selected audio CD track by clicking the Play button. The track will be played back from selection start to selection end (or until you click the Stop button).

• The Play from left Marker (down arrow) and Play to Right Marker (up arrow) buttons allow you to audition the start and end of the selection only. The down arrow button will play a short snippet beginning at the start of the selection, while the up arrow button will play a snippet starting just before the end of the selection.

• To open the CD drive, click on the Eject button at the top of the dialog.

---

**Importing Audio from video files**

While you can automatically extract the audio when importing a video file, it is also possible to import the audio from a video file without importing the video itself:

**PROCEDURE**

1. Open the File menu, open the Import submenu and select “Audio from Video File…”.

2. In the file dialog that opens, locate and select the video file and click Open. The audio in the selected video file is extracted and converted to a Wave file in the project’s Audio folder.
   A new audio clip is created and added to the Pool. In the Project window, an event referencing the audio file is inserted on the selected track at the project cursor position. If no track was selected, a new track is created.

This works just like importing regular audio files.

**RELATED LINKS**

- Extracting Audio From a Video File on page 990
- Importing Video Files on page 983

---

**Importing ReCycle files**

ReCycle by Propellerhead Software is a program designed especially for working with sampled loops. By “slicing” a loop and making separate samples of each beat, ReCycle makes it possible to match the tempo of a loop and edit the loop as if it was built of individual sounds. Cubase can import two file types created by ReCycle:

• REX files (export file format of the first versions of ReCycle, extension “.rex”).
- REX 2 files (file format of ReCycle 2.0 and later, extension ".rx2")

**IMPORTANT**

For this to work, the REX Shared Library needs to be installed on your system.

**PROCEDURE**

1. Select an audio track and move the project cursor to where you want the imported file to start.
   
   You probably want to import REX files to tempo based audio tracks, since this will allow you to change the tempo later on (having the imported REX file automatically adjust).

2. Select “Audio File…” from the Import submenu of the File menu.

3. On the file type pop-up menu in the file dialog, select REX File or REX 2 File.

4. Locate and select the file you want to import, and click Open.

   The file is imported and automatically adjusted to the current Cubase tempo.

   Unlike a regular audio file, the imported REX file will consist of several events, one for each “slice” in the loop. The events will automatically be placed in an audio part on the selected track and positioned so that the original internal timing of the loop is preserved.

5. If you now open the part in the Audio Part Editor, you can edit each slice separately by muting, moving and resizing events, adding effects and processing, etc.

   You can also adjust the tempo and have the REX file automatically follow (provided that its track is tempo based).

**NOTE**

You can achieve similar results by using Cubase’s own loop slicing features.

**RELATED LINKS**

[Working with hitpoints and slices on page 459](#)

---

**Importing compressed audio files**

Cubase can import several common audio compression formats. The procedure is the same as when importing any non-compressed audio file, with one important thing to note:

For most compressed file formats, Cubase creates a copy of the file and converts this to Wave format (Windows) or AIFF format (Mac OS X) before importing it. The original compressed file will not be used in the project.

The imported file is placed in the designated project Audio folder.

**IMPORTANT**

The resulting Wave/AIFF file is several times larger than the original compressed file.
The following file types are supported:

**FLAC files**

FLAC is an open source format and stands for Free Lossless Audio Codec. Audio files in this format are typically 50 to 60% smaller than regular Wave files. FLAC files are not converted to Wave files on import.

**MPEG audio files**

MPEG, which stands for Moving Picture Experts Group, is the name of a family of standards used for encoding audio-visual information (e.g. movies, video, music) in a digital compressed format.

Cubase can read two types of audio MPEG files: MPEG Layer 2 (*.mp2) and MPEG Layer 3 (*.mp3). Currently, mp3 is the most common of these formats, while the mp2 format is mostly used in broadcast applications.

**Ogg Vorbis files**

Ogg Vorbis is an open and patent-free format that offers very small audio files maintaining comparatively high audio quality. Ogg Vorbis files have the extension ".ogg".

**Windows Media Audio files (Windows only)**

Windows Media Audio is an audio format developed by Microsoft, Inc. Due to advanced audio compression algorithms, Windows Media Audio files can be made very small, maintaining good audio quality. The files have the extension ".wma".

RELATED LINKS

Export Audio Mixdown on page 938

**Exporting and importing OMF files (Cubase Pro only)**

Open Media Framework Interchange (OMFI) is a platform independent file format intended for the transfer of digital media between different applications. Cubase can import and export OMF files (file extension ".omf"), allowing you to use Cubase in conjunction with other audio and video applications.
Exporting OMF files

When exporting tracks and files as OMF, you should consider setting up your project to use mono tracks and mono files, to allow compatibility with audio applications that provide limited support for interleaved audio files.

**PROCEDURE**

1. Open the File menu, open the Export submenu and select “OMF…”. The Export Options dialog opens.

2. Use the track list to the left to select the tracks that you want to include in the exported file.
   
   To select all tracks, click the “Select All” button. Normally, the whole project is included – to export the range between the locators only, activate “From Left to Right Locator”.
   
   When referencing media files (see below), you can set the referenced output path by entering it in the “Media Destination Path” field or by clicking on “Browser…” and choosing it in the file dialog that opens.

   All file references will be set to this path. You can create references to media destinations that do not exist on the system you are currently working with, making it easy to prepare files for use in projects on another system or in a network environment.

3. If you want to create copies of all the media files, choose the “Copy Media” option.

   By default, the copied audio files are placed in a subdirectory in the export destination folder. To specify a different location for the copied files, use the “Media Destination Path” field.
4. If you want to copy only the portions of audio files that are used in the project, activate “Consolidate Events”.
   You can also define handle lengths in milliseconds to include audio outside each event boundary for later fine tuning. If you do not have any handles when consolidating audio files, you will not be able to adjust fades or edit points when the project is imported in another application.

5. Select “1.0 File” or “2.0 File”, depending on which OMF version is supported by the application in which you plan to import the file.
   Select whether you want to include all audio data in the OMF file (“Export All to One File”) or use references only (“Export Media File References”).
   If you choose “Export All to One File”, the OMF file will be totally “self-contained”, but possibly very large. If you choose “Export Media File References”, the file will be small, but the referenced audio files must be available for the receiving application.

6. If you selected the “2.0 File” option above, you can choose whether to include the volume settings and fades for the events (as set up with the event volume and fade handles) as well as the clip names – to include these in the OMF file, activate “Export Clip Based Volume”, “Use Fade Curves” and/or “Export Clip Names”.

7. Specify a sample size (resolution) for the exported files (or use the current project settings).

8. If you activate “Quantize Events to Frames”, the event positions in the exported file will be moved to exact frames.

9. Click OK, and specify a name and location in the file dialog that opens.
   The exported OMF file will contain (or reference) all audio files that are played in the project (including fade and edit files). It will not include unused audio files referenced in the Pool, or any MIDI data. Video files are not included.

---

**Importing OMF files**

**PROCEDURE**

1. Open the File menu, open the Import submenu and select “OMF…”.

2. In the file dialog that opens, locate the OMF file and click Open.
   If there is already an open project, a dialog opens in which you can select whether a new project is created for the file.
   If you select “No”, the OMF file will be imported into the current project.

3. If you choose to create a new project, a file dialog opens in which you can select the project folder.
   Select an existing project folder or create a new one.

4. The Import Options dialog opens, allowing you to choose a track for the import.
   - Activating the “Import all media files” option allows you to import media that is not referenced by events.
   - Activating the “Import Clip Gain as Automation” option imports volume automation and envelopes of the Volume Automation Track of each track.
• “Import at Timecode Position” will insert the elements contained in the OMF file at their original timecode positions. This is useful when you want to position every imported element at its exact timecode position, i.e. as it was saved in the OMF file. This way, the elements will end up at their correct time positions even when Cubase uses a different frame rate than the OMF file. This is usually required in a picture-related context.
• “Import at Absolute Time” will insert the elements contained in the OMF file starting at the timecode position saved in the file and keeping the relative distances between the elements. This is required when the relative positioning of the elements inside the OMF file needs to be maintained after importing it into the Cubase timeline (even if Cubase is set to a different frame rate than the OMF file). This is usually required in music contexts, where the timing between objects has highest priority.
• If the OMF file contains video event information, you are asked whether you want to create Markers at the start position of the video events. This allows you to manually import the video files, using the Markers as position references.

A new, untitled project is created (or tracks are added to the existing project), containing the audio events of the imported OMF file.

Exporting and importing standard MIDI files

Cubase can import and export standard MIDI files, which makes it possible to transfer MIDI material to and from virtually any MIDI application on any platform. When you import and export MIDI files, you can also specify whether certain settings associated with the tracks are included in the files (automation tracks, volume and pan settings, etc.).

Exporting MIDI files

To export your MIDI tracks as a standard MIDI file, open the File menu and select “MIDI File…” from the Export submenu. A regular file dialog opens, allowing you to specify a location and name for the file.

When you have specified a location and a name for the file, click “Save”. The Export Options dialog opens, allowing you to specify a number of options for the file, e.g. what is included in the file, its type and its resolution (see below for a description of the options).
You will also find most of these settings in the Preferences dialog (MIDI–MIDI File page). If you set these up in the Preferences dialog, you only need to click OK in the Export Options dialog to proceed.

The dialog contains the following options:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Export Inspector Patch</td>
<td>If this is activated, the MIDI patch settings in the Inspector – Bank Select and Program Select (used for selecting sounds in the connected MIDI instrument) are included as MIDI Bank Select and Program Change events in the MIDI file.</td>
</tr>
<tr>
<td>Export Inspector Volume/Pan</td>
<td>If this is activated, Volume and Pan settings made in the Inspector are included as MIDI Volume and Pan events in the MIDI file.</td>
</tr>
<tr>
<td>Export Automation</td>
<td>If this is activated, the automation data (as heard during playback) are converted to MIDI controller events and included in the MIDI file. This also includes automation recorded with the MIDI Control plug-in (see the separate PDF document “Plug-in Reference”). Note that if a continuous controller (e.g. CC7) has been recorded but the Read button is deactivated for the automation track (i.e. the automation is effectively switched off for this parameter), only the part data for this controller will be exported. If this option is deactivated and the Automation Read button is activated, no Continuous Controllers are exported. If the Read button is deactivated, the Controller data of the MIDI part are exported (these will now be handled like “regular” part data). In most cases it is recommended to activate this option.</td>
</tr>
<tr>
<td>Export Inserts</td>
<td>If this is activated and you are using MIDI modifiers or any MIDI plug-ins as insert effects, the modifications to the original MIDI notes that occur as a result of the effect(s) will be included in the MIDI file. A MIDI delay, for example, will produce a number of repeats to a MIDI note by actually adding additional, “echoing” notes at rhythmic intervals – these notes will be included in the MIDI file if the option is activated.</td>
</tr>
<tr>
<td>Export Sends</td>
<td>If this is activated and you are using any MIDI plug-ins as send effects, the modifications to the original MIDI notes that occur as a result of the effect(s) will be included in the MIDI file.</td>
</tr>
<tr>
<td>Export Markers</td>
<td>If this is activated, any markers you have added will be included in the MIDI file as standard MIDI file marker events.</td>
</tr>
</tbody>
</table>
### File handling

#### Exporting and importing standard MIDI files

- **NOTE**
  - The MIDI file will include the tempo information of the project (i.e., it will include the tempo and time signature events of the Tempo Track Editor or, if the tempo track is deactivated on the Transport panel, the current tempo and time signature).

- **NOTE**
  - Inspector settings other than those specified in the Export options are not included in the MIDI file! To include these, you need to convert the settings to “real” MIDI events and properties by using the Merge MIDI in Loop function for each track.

### Option and Description

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Export as Type 0</td>
<td>If this is activated, the MIDI file will be of type 0 (all data on a single track, but on different MIDI channels). If you do not activate this option, the MIDI file will be of Type 1 (data on separate tracks). Which type to choose depends on what you want to do with the MIDI file (in which application or sequencer it should be used, etc.).</td>
</tr>
<tr>
<td>Export Resolution</td>
<td>You can specify a MIDI resolution between 24 and 960 for the MIDI file. The resolution is the number of pulses, or ticks, per quarter note (PPQ) and determines the precision with which you will be able to view and edit the MIDI data. The higher the resolution, the higher the precision. Choose the resolution depending on the application or sequencer with which the MIDI file will be used, though, since certain applications and sequencers may not be able to handle certain resolutions.</td>
</tr>
<tr>
<td>Export Locator Range</td>
<td>If this is activated, only the range between the locators will be exported.</td>
</tr>
<tr>
<td>Export includes Delay</td>
<td>If this is activated, the delay of the MIDI track will be included in the MIDI file.</td>
</tr>
<tr>
<td>Song name for Type 0</td>
<td>You can use this text field to change the name of the MIDI file as displayed when loading this file in a keyboard.</td>
</tr>
</tbody>
</table>

### RELATED LINKS

- Automation on page 576
- Markers on page 281
- Basic track settings on page 644
- Merge MIDI in Loop on page 675

### Importing MIDI files

To import a MIDI file from disk, proceed as follows:

**PROCEDURE**

1. Select “MIDI File…” from the Import submenu of the File menu.
2. If there is already an open project, a dialog opens in which you can select whether a new project is created for the file.
   - If you select “No”, the MIDI file will be imported into the current project.
3. Locate and select the MIDI file in the file dialog that opens and click Open. If you choose to create a new project, select the project folder. Select an existing project folder or create a new one.

RESULT

The MIDI file is imported. The result depends on the contents of the MIDI file and the Import Options settings in the Preferences dialog (MIDI–MIDI File page). The Import Options are as follows:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Extract First Patch</td>
<td>If this is activated, the first Program Change and Bank Select events for each track are converted to Inspector settings for the track.</td>
</tr>
<tr>
<td>Extract First Volume/Pan</td>
<td>If this is activated, the first MIDI Volume and Pan events for each track are converted to Inspector settings for the track.</td>
</tr>
<tr>
<td>Import Controller as Automation Tracks</td>
<td>If this is activated, MIDI controller events in the MIDI file will be converted to automation data for the MIDI tracks. If this is deactivated, controller data for the MIDI Parts will be imported.</td>
</tr>
<tr>
<td>Import to Left Locator</td>
<td>If this is activated, the imported MIDI file will be placed so that it starts at the position of the left locator – otherwise it will start at the beginning of the project. Note that if you choose to have a new project created automatically, the MIDI file will always start at the beginning of the project.</td>
</tr>
<tr>
<td>Import Markers</td>
<td>If this is activated, standard MIDI file markers in the file will be imported and converted to Cubase markers.</td>
</tr>
<tr>
<td>Import dropped File as single Part</td>
<td>If this is activated and you drag and drop a MIDI file into the project, the whole file will be placed on a single track.</td>
</tr>
<tr>
<td>Ignore Master Track Events on Merge</td>
<td>If this is activated and you import a MIDI file into the current project, tempo and signature track data in the MIDI file are ignored. The imported MIDI file will play according to the current tempo and signature tracks in the project. If this option is deactivated, the Tempo Track Editor will be adjusted according to the tempo information in the MIDI file.</td>
</tr>
<tr>
<td>Auto Dissolve Format 0</td>
<td>If this is activated and you import a MIDI file of type 0 into the project, the file will automatically be “dissolved”: For each embedded MIDI channel in the file, a separate track will be inserted in the Project window. If this is deactivated, only one MIDI track will be created. This track will be set to MIDI Channel “Any”, allowing all MIDI events to play back on their original channels. You can also use the “Dissolve Part” function on the MIDI menu to distribute the events onto different tracks with different MIDI Channels at a later stage.</td>
</tr>
</tbody>
</table>
Exporting and importing MIDI loops

Cubase allows you to import MIDI loops (file extension ".midiloop") and to save instrument parts as MIDI loops. MIDI loops are handy, as they contain not only MIDI notes and controllers, but also the number of voices, the associated VST instrument and instrument track preset settings.

**Related links**

- VST Instruments on page 599

Support for the Yamaha XF data format

Cubase supports the Yamaha XF format. XF is an extension of the standard MIDI file format that allows you to save song-specific data with a MIDI file of type 0.

When importing a MIDI file containing XF data, this data is placed in parts on separate tracks called “XF Data”, “Chord Data”, or “SysEx Data”. You can edit such a part in the List Editor (e.g. to add or change lyrics).

**Important**

Do not change the order of events within the XF data or the event data itself, unless you have a lot of experience with XF data.

Cubase can also export XF data as part of a MIDI file of type 0. If you do not want to export the XF data together with the MIDI data, mute or delete the tracks containing the XF data.

Exporting and importing MIDI loops

Cubase allows you to import MIDI loops (file extension ".midiloop") and to save instrument parts as MIDI loops. MIDI loops are handy, as they contain not only MIDI notes and controllers, but also the number of voices, the associated VST instrument and instrument track preset settings.

**Related links**

- VST Instruments on page 599
Exporting and importing track archives (Cubase Pro only)

You can export Cubase tracks (audio, FX, group, instrument, MIDI, and video) as track archives for import into other Cubase (or Nuendo) projects. All the information associated with the tracks will be exported (channel settings, automation tracks, parts and events, etc.). If you select the “Copy” option (see below), a separate “media” folder will be created, containing copies of all referenced audio files.

**NOTE**

Project-specific settings (such as tempo) are not part of the exported track archives.

**RELATED LINKS**

Track Presets on page 160

Exporting tracks as track archives

**PROCEDURE**

1. Select the tracks you wish to export.
2. Open the File menu, open the Export submenu and choose “Selected Tracks…”.
3. When exporting audio or video tracks, you are prompted to choose between two options:
   - Click Copy to include copies of the media files in the export.
     A file dialog opens in which you can choose an existing empty folder or create a new folder for saving the track archive (as XML file) and its media subfolder, which will contain any associated audio or video files. Click OK to save the track archive.
   - Click Reference to include merely a reference to the files in the export.
     A file dialog opens in which you can choose an existing folder for saving the track archive (as single XML file).
4. Enter a name for the track archive and click Save.

Importing tracks from a track archive

The Import Track Archive function lets you import tracks exported from another Cubase (or Nuendo) project.

**NOTE**

Note that the sample rates of the active project and the track archive have to match. If necessary, you have to convert the sample rate, see below.
PROCEDURE
1. Open the File menu, open the Import submenu and select “Track Archive…”.
2. In the file dialog that opens, select the XML file and click Open.
   The Import Options dialog opens.

   ![Import Options dialog](image)

   In the Project Settings area, you can see a comparison between the settings of the track archive and the active project.

3. Click in the Import column on the left to select the desired track(s) or click “Select All Tracks”.
   A checkmark is shown for all selected tracks.
4. Choose which media files to use.
   - Select “Use Media Files From Archive” if you want to import the track without copying the media files into your project folder.
   - Select “Copy Media To Project Folder” if you want to import the media files into your project folder.
     For the “Perform Sample Rate Conversion” option, see below.
5. Click OK.
   The tracks are imported, complete with all contents and settings.

Sample rate conversion on track archive import

A track archive may contain media files with a sample rate that is different from the sample rate of your currently active project. You can see the sample rate difference in the Project Settings area.

- To convert the sample rate of a track archive to the sample rate used in the active project on import, select the “Copy Media To Project Folder” option and then “Perform Sample Rate Conversion”.

Unconverted files with another sample rate than the one used in the project will play back at the wrong speed and pitch.
Workspaces

Workspaces in Cubase allow you to organize windows and specific dialogs for your common work routines.

A workspace saves the size, position, and layout or setting of important windows and dialogs, such as the Project window, MixConsole, or Transport panel. You can define several workspaces. This allows you to quickly switch between different working modes, either through the Workspaces menu or by using key commands.

You can define different workspace types that are either available for all projects on your computer or specific for one project. However, when you open a project, its last saved view is opened. A view is the window layout and setting that you defined for your project. The last saved view can either be a workspace view or a view that you saved without having any workspace selected. When you open an external project, the last used view on your computer is used.

The Workspaces Organizer and the Workspaces menu allow you to create and modify workspaces.

NOTE

You can also work without workspaces. In this case, the last used view of the former project will be used when you create a new project.

Workspace Types

You can create different workspace types.

Global workspace

Allows you to save a specific layout of dialogs and windows for all projects on your computer. Global workspaces are indicated by the letter G on your Workspaces menu.

Project workspace

Allows you to save a specific layout of dialogs and windows that is saved with your current project. This allows you to open your project layout on other computers. Project workspaces are indicated by the letter P on your Workspaces menu.
**Workspace Templates**

Cubase provides sample templates that you can use as a starting point for your own workspaces.

The templates are made for screens with a resolution of 1280x800 px (minimal) or for screens with a resolution of 1920x1080 px (HD). You can change these templates according to your needs.

**IMPORTANT**
- Deleting and overwriting templates cannot be undone.
- If you have already used global workspaces in earlier Cubase versions, the sample templates are not installed.

The following workspace templates are provided on the Workspaces menu:

- **Project (minimal)**
  Displays the Project window with minimal resolution.

- **Project + MixConsole (minimal)**
  Displays the Project window and MixConsole with minimal resolution.

- **Project (HD)**
  Displays the Project window with HD resolution.

- **Project + MixConsole + Channel Settings (HD)**
  Displays the Project window, MixConsole, and Channel Settings window with HD resolution.

  **NOTE**
  To see the Channel Settings window, you must select an audio, MIDI, instrument, FX channel, or group channel track before you select the template.

- **Project + MixConsole + Racks (HD)**
  Displays the Project window, MixConsole, and Racks with HD resolution.

**Workspaces for External Projects**

You can determine the view of external projects when you open them in Cubase.

When you open external projects, which are projects that have been created on other computers, the window and dialog settings that you last used on your computer are applied by default. This can either be the last used view that was saved on your computer or one of your specified global workspaces.
If you want to open the project’s original layout setting, you have the following options:

- Select the project’s original layout from the project workspaces on the Workspaces menu or in the Workspace Organizer.
- Deactivate the Open External Projects in Last Used View setting in File > Preferences > General. This opens all external projects in their original layout. However, this may lead to a modification of your own custom layout.

To return to the view that you last saved without any workspace assigned, select No Workspace on the Workspaces menu.

Creating Workspaces

To save your current dialog and window setting for future use, you can create a new workspace.

**PROCEDURE**

2. In the Name field, enter a workspace name.
3. Select the type of workspace that you want to create.
   - Global Workspace
   - Project Workspace
4. Click OK.

**RESULT**

The workspace is saved and added to the Workspaces menu.

Editing Workspaces

You can modify your created workspaces.

**NOTE**

To change a global workspace to a project workspace and vice versa, you must save it as a different workspace type.

**PROCEDURE**

1. On the Workspaces menu, select the workspace that you want to modify.
2. Make your changes as required.
3. On the **Workspaces** menu, select one of the following:
   - To update your current workspace, click **Update Workspace**.
   - To save your workspace as a different workspace or workspace type, click **Add Workspace**.

**RELATED LINKS**

Creating Workspaces on page 1030

### Workspaces Organizer

The **Workspaces Organizer** allows you to manage the existing workspaces.

To open the **Workspaces Organizer**, click **Workspaces > Organize**.

The **Workspaces Organizer** displays the global workspaces and the project workspaces in separate lists. Every workspace has an assigned key command that lets you switch views quickly. Moving or deleting workspaces within the lists changes the key command assignments. When you change the position of a workspace, the key command assignments remain in their original list position. You can click a key command of a selected workspace to open the respective key command assignment in the **Workspace** category of the **Key Commands** dialog.

To organize your workspace, you have the following options:

**Move Up**
- Moves up a workspace by one position.

**Move Down**
- Moves down a workspace by one position.

**Delete**
- Deletes a selected workspace.

**Add**
- Allows you to create a new workspace using the **New Workspace** dialog.
Using the Setup options

You can customize the appearance of the following elements:

- Transport panel
- Info line
- Toolbars
- Inspector

The setup context menus

If you right-click the Transport panel, the toolbars, the info lines, or the Inspector, the respective setup context menu opens.

The following general options are available on the setup context menus:

- “Show All” makes all items visible.
- “Default” resets the interface to the default setting.
- “Setup…” opens the Setup dialog, see below.

If presets are available, they can be selected on the lower half of the menu.
The Setup dialogs

If you select “Setup…” from the setup context menus, the Setup dialog opens. This allows you to specify which elements are visible/hidden and to set the order of the elements. You can also save and recall setup presets in this dialog.

The dialog is divided into two sections. The left section displays the currently visible items and the right section displays the currently hidden items.

- You can change the current show/hide status by selecting items in one section and then use the arrow buttons in the middle of the dialog to move them to the other section.

Changes are applied directly.
By selecting items in the “Visible Items” list and using the Move Up and Move Down buttons, you can reorder the items list. Changes are applied directly. To undo all changes and revert to the standard layout, select “Default” on the setup context menu.

If you click the Save button (disk icon) in the Presets section, a dialog opens, allowing you to name the current configuration and save it as a preset.

To remove a preset, select it on the presets pop-up menu and click the trash icon.

Saved configurations are available for selection from the Presets pop-up menu in the Setup dialog or directly from the setup context menu.

### Appearance

In the Preferences dialog, the appearance of Cubase can be changed on the Appearance (Colors) and on the Metering (Appearance) page. The following subpages are available on the Appearance–Colors page:

- **General**
  Allows you to adjust the default colors for the general interface of the program.

- **Track Type Defaults**
  Allows you to adjust the default colors for the different track types.

- **Project**
  Allows you to adjust the default colors in the Project window.

- **Editors**
  Allows you to adjust the default colors in the editors.

- **MixConsole Faders**
  Allows you to adjust the default colors for the level faders of the channel types in the MixConsole.

- **MixConsole Racks**
  Allows you to adjust the default colors for the racks in the MixConsole.

- **MixConsole Channel Strip**
  Allows you to adjust the default colors for the channel strips in the MixConsole.
Appearance–Colors

The Appearance–Colors page features several subpages that allow you to change the default color of the Cubase desktop, the track types, the Project, Editor elements, and MixConsole elements.

To change a color, proceed as follows:

PROCEDURE

1. Select a subpage and click the color field of the element to which you want to assign a new color.
   A color selector pane opens.

2. Use the tools in the color selector pane to select a new color.
   The current and the new color are shown at the bottom of the pane.

3. Click outside the color selector pane to confirm your settings and apply your changes.
   Note that you must restart the application for some changes to take effect.
• To copy a color and paste it on another element, even on another subpage, open the context menu in the color selector pane and select “Copy Color” and “Paste Color”.

You can also copy colors on the same subpage using drag and drop.

• To edit the colors numerically, open the context menu in the color selector pane, and select “Show Color Values”.

• To select any color in Cubase as new color, open the color selector pane, hold down [Alt]/[Option], and click anywhere in the application. The selected color is displayed in the “New Color” field.
Metering–Appearance

Cubase allows for precise color assignment of level meter values. On the Metering–Appearance page you can specify colors for quick identification of what levels are being reached.

You can adjust the colors for the Channel Meter or the Master Meter. For the Master Meter you can only make changes for the Digital Scale scaling mode. Changes take effect when you click Apply or OK.

To adjust the levels and colors, activate the Channel Meter or Master Meter option and proceed as follows:

- To specify the level for a color change, double-click a handle to the right of the meter scale and enter the level (dB) value.
  
  Note that for dB values less than zero, you must add a minus sign before the entered number.
  
  You can also click a handle and drag it to a specific level. Press [Shift] for more accurate positioning. Alternatively, you can nudge with the Arrow Up/Down keys. Press [Shift] for faster positioning.

- To assign a color, click the upper or lower part of a handle so that a black frame is shown, and use the color selector pane to select a color (see above).
  
  Selecting the same color for the upper and lower part of the handle results in a meter that changes its colors gradually, while separate colors indicate level changes even more precisely.

- To add more color handles, click the Add button, or [Alt]/[Option]-click at a level position to the right of the meter scale. Each new handle is automatically associated with a default color.

- To remove a handle, select the handle and click the Remove button, or [Ctrl]/[Command]-click the handle.
Applying colors in the Project window

You can use color scheming for an easier overview of tracks and events in the Project window. Colors can be applied individually to tracks and events/parts. If you color a track, the corresponding events and parts are displayed in the same color. However, you can also color events and parts differently, "overriding" the applied track color.

In the following sections you will learn how to set up preferences to color tracks automatically, how to color parts or events manually, how to determine whether you want to color the events themselves or their background, and how to customize the color palette for selecting colors.

Colorize Track Controls

In the Preferences dialog (Event Display–Tracks page), you can find the “Colorize Track Controls” slider that allows you apply the track color to the track controls.

Colorize Folder Track Controls Only

You can restrict the effect of the Colorize Track Control function to folder tracks only. This is useful in projects with a large number of tracks and folder tracks.

**PROCEDURE**

1. Select File > Preferences > Event Display > Tracks.
2. Drag the Colorize Track Controls slider to the right.
3. Activate Colorize Only Folder Track Controls.
4. Click OK.
5. In the track list, select the folder track that you want to colorize.
6. In the Project window toolbar, select the Color Tool and click again to select a color.

**RESULT**

Only the folder track controls are colorized.

Applying track colors automatically

In the Preferences dialog (Event Display–Tracks page), you can find the “Auto Track Color Mode” option.
This offers you several options for automatically assigning colors to tracks that are added to the project. The following options are available:

**Use Default Track Color**

The default color (gray) is assigned.

**Use Previous Track Color**

Analyzes the color of the selected track and uses the same color for the new track.

**Use Previous Track Color +1**

Analyzes the color of the selected track and uses the color that comes next in the color palette for the new track.

**Use Last Applied Color**

Uses the color that is selected in the Select Colors pop-up menu.

**Use Random Track Color**

Uses the color palette as a basis to assign track colors randomly.

### Coloring Tracks, Parts, or Events Manually

The Color tool on the Project window toolbar allows you to color each track, part, or event individually.

**Procedure**

1. In the Project window, do one of the following:
   - To change the color of an event or part, select it.
   - To change the color of a track, select the track and deselect all its events or parts.
2. On the toolbar, select the **Color** tool, click again, and select a color from the pop-up menu.

RESULT

The color is applied to the selected item. If you change the color of a track, the new color is used for all events on the track and for the corresponding channel in the MixConsole.

**NOTE**

If you assign a different color to individual parts or events, they no longer follow color changes of the track.

---

**Resetting the Default Color**

You can reset the color of a track, part, or event to the default color.

**PROCEDURE**

1. In the **Project** window, select the event or part that you want to reset to the default color.

2. On the toolbar, select the **Color** tool, click again, and select **Default Color** from the pop-up menu.

---

**Project Colors Dialog**

The **Project Colors** dialog allows you to set up a different set of colors for items in the **Project** window.

- To open the **Project Colors** dialog, select the **Color** tool in the **Project** window toolbar. Click again to open a pop-up menu and select **Project Colors**.
Applying colors in the Project window

Color fields
Click a field to open a color selector pane that allows you to specify a new color.

Click Options for the following options.

Append New Color
Adds a new color button at the bottom of the color list.

Insert New Color before Selection
Adds a new color button above the selected color button.

Remove Selected Color
Removes the selected color.

Reset Selected Color
Resets the selected color to the factory settings.

Increase/Reduce Intensity of all Colors
Increases or reduces the intensity of all colors.

Increase/Reduce Brightness of all Colors
Increases or reduces the brightness of all colors.

Save Current Set as Program Defaults
Saves the current set of colors as default.

Load Program Defaults to Current Set
Applies the default set of colors.

Reset Current Set to Factory Settings
Returns to the standard color palette.
Adding and editing individual colors

In the Project Colors dialog, you can fully customize the color palette. To add new colors to the color palette, proceed as follows:

**PROCEDURE**

1. Add a new color by clicking the Insert New Color button.
2. In the Project Colors section, click the newly created color field to activate the new color for editing.
3. Use the Standard Colors or Modify Color sections to specify a new color. To do this, pick a different color from the color palette, drag the cursor in the color circle, move the handle in the color meter, or enter new RGB values as well as values for hue, saturation, and luminosity manually.
4. Click the Apply button. The color setting is applied to the selected color field in the Project Colors section.

**NOTE**

Every color in the Project Colors section can be edited this way.

Setting intensity and brightness

To increase or decrease the intensity and the brightness of all colors, use the corresponding buttons in the Project Colors section.

- ![Increase/decrease intensity for all colors](image)
- ![Increase/decrease brightness for all colors](image)

Where are the settings stored?

As you have seen, there are a large number of ways in which you can customize Cubase. While some of the settings you make are stored with each project, others are stored in separate preference files.

If you need to transfer your projects to another computer (e.g. in another studio), you can bring all your settings along by copying the desired preference files and installing them on the other computer.

**NOTE**

It is a good idea to make a backup copy of your preference files once you have set things up the way you want! This way, if another Cubase user wants to use his or her personal settings when working on your computer, you can restore your own preferences afterwards.
Customizing
Where are the settings stored?

- On Windows systems, preference files are stored in the following location: “\Users\<user name>\AppData\Roaming\Steinberg\<program name>\". On the Start menu, you will find a shortcut to this folder for easy access.

- On Mac OS X systems, preference files are stored in the following location: “/Library/Preferences/<program name>/” under your home directory. The full path is: “/Users/<user name>/Library/Preferences/<program name>/”.

**NOTE**
The RAMpresets.xml file, which contains various presets settings (see below), is saved when exiting the program.

**NOTE**
Program functions (e.g. crossfade) or configurations (e.g. panels) not used in the project will not be stored.

Some of the preferences are not stored in the default preferences folder. A list can be found in the Steinberg Knowledge Base.

To open the Knowledge Base, browse to the Steinberg web site, click “Support” and choose “Knowledge Base” in the list on the left.

**Updating from a Previous Version of Cubase**

When you are updating from Cubase 6 or higher, the customized settings of your previous installation are used for the new Cubase version.

When your previous Cubase version is older than Cubase 6, its settings are discarded, and the default settings of the new version of Cubase are used.

**Disabling the Preferences**

Sometimes you might experience odd program behaviour that can be due to inconsistent preferences settings. In such a case, you should save your project and relaunch Cubase. You can disable or delete the current preferences settings, and load the factory defaults instead.

**PROCEDURE**

1. Quit Cubase.
2. Launch Cubase, and when the splash screen appears, hold down [Shift]-[Ctrl]/[Command]-[Alt]/[Option].
3. Select one of the following options in the dialog that appears:
   - **Use current program preferences**
     Opens the program with the current preference settings.
Customizing
Where are the settings stored?

- **Disable program preferences**
  Disables the current preferences, and opens the program with the factory default settings instead.

- **Delete program preferences**
  Deletes the preferences and opens the program with the factory default settings instead. This process cannot be undone. Note that this affects all versions of Cubase installed on your computer.

**RELATED LINKS**
Preferences on page 1051
Optimizing Audio Performance

This section gives you some hints and tips on how to get the most out of your Cubase system, performance-wise. Some of this text refers to hardware properties and can be used as a guide when upgrading your system. Look for details and current information on the Cubase web site.

Performance Aspects

Tracks and Effects

The faster your computer, the more tracks, effects, and EQ you are able to play. Exactly what constitutes a fast computer is almost a science in itself, but some hints are given below.

Short Response Times (Latency)

Another aspect of performance is response time. The term “latency” refers to the buffering, that is the temporary storing of small chunks of audio data during various steps of the recording and playback process on a computer. The more and larger those chunks, the higher the latency.

High latency is most irritating when playing VST instruments and when monitoring through the computer, that is when listening to a live audio source via the Cubase MixConsole and effects. However, very long latency times (several hundred milliseconds) can also affect other processes like mixing, for example, when the effect of a fader movement is heard only after a noticeable delay.

While Direct Monitoring and other techniques reduce the problems associated with very long latency times, a system that responds fast will always be more convenient to work with.

- Depending on your audio hardware, it may be possible to trim your latency times, usually by lowering the size and the number of buffers.
- For details, refer to the audio hardware documentation.
System Factors That Affect Performance

**RAM**

The more RAM is installed in your computer, the better.

---

**IMPORTANT**

On computers running a Windows 32-bit operating system, a running application can address a maximum of 2 GB of RAM. On a Macintosh computer running 32-bit Mac OS X, this limit is 4 GB. The 64-bit versions of Windows and Mac OS X are able to assign considerably more than 4 GB of RAM to a running 64-bit application.

The RAM limitation is imposed by the operating system, and it is independent of the amount of RAM that you may have installed in your computer.

Some program functions may use all the available memory, for example, recording, the use of effect plug-ins, and the pre-loading of samples.

---

**IMPORTANT**

When a function has used up all the memory made available by the operating system, the computer will crash.

Always keep in mind the RAM limitation of your operating system when setting up your projects.

**RELATED LINKS**

- RAM Requirements for Recording on page 220
- Smart Plug-In Processing on page 373

**CPU and Processor Cache**

The faster the computer processor, the better. But there are a number of factors that affect the apparent speed of a computer: the bus speed and type (PCI is strongly recommended), the processor cache size and of course, the processor type and brand. Cubase relies heavily on floating point calculations. When shopping for a processor, make sure that you get one that is powerful in calculating floating point arithmetics.

Cubase features full support for multi-processor systems. If you own a computer system with more than one processor, Cubase can take advantage of the total capacity and evenly distribute the processing load to all available processors.

**RELATED LINKS**

- Multi Processing on page 1048
Hard Disk and Controller

The number of hard disk tracks that you can record and play back at the same time also depends on the speed of your hard disk and hard disk controller. If you use E-IDE disks and controllers, make sure that the transfer mode is DMA Busmaster. Under Windows, you can check the current mode by launching the Windows Device Manager and looking for properties of the IDE ATA/ATAPI controller’s primary and secondary channel. DMA transfer mode is enabled by default, but may be turned off by the system in case of hardware problems.

Audio Hardware and Driver

The hardware and its driver can have some effect on regular performance. A badly written driver can reduce the performance of your computer. But where the hardware driver design makes the most difference is with latency.

**NOTE**

We recommend that you use audio hardware for which there is a specific ASIO driver.

This is especially true when using Cubase for Windows:

- Under Windows, ASIO drivers written specifically for the hardware are more efficient than the Generic Low Latency ASIO Driver or a DirectX driver and produce shorter latency times.
- Under Mac OS X, audio hardware with properly written Mac OS X (Core Audio) drivers can be very efficient and produce very low latency times.

However, there are additional features currently only available with ASIO drivers, such as the ASIO Positioning Protocol.

Settings That Affect Performance

Audio Buffer Settings

Audio buffers affect how audio is sent to and from the audio hardware. The size of the audio buffers affects both the latency and the audio performance.

Generally, the smaller the buffer size, the lower the latency. On the other hand, working with small buffers can be demanding for the computer. If the audio buffers are too small, you may get clicks, pops or other audio playback problems.

- To adjust the buffer size settings under Mac OS X, select Devices > Device Setup, and select the Device Setup dialog. You may also find buffer settings in the control panel for the audio hardware.
- To adjust the buffer size settings under Windows, select Devices > Device Setup, select the driver page, and click Control Panel.
Multi Processing

When Multi Processing is activated and there is more than one CPU in your system, the processing load is distributed evenly to all available CPUs, allowing Cubase to make full use of the combined power of the multiple processors.

- To activate Multi Processing, select Devices > Device Setup, select VST Audio System, and activate Multi Processing.

VST Performance Window

This window shows the audio processing load and the hard disk transfer rate. This allows you to verify that you do not run into performance problems when adding effects or plug-ins, for example.

- To open the VST Performance window, select Devices > VST Performance.

Average load

Shows how much of the available CPU power is used for audio processing.

Real-time peak

Shows the processing load in the realtime path of the audio engine. The higher this value, the higher the risk that dropouts occur.

Overload indicator

The overload indicator to the right of the real-time peak indicator and the average load indicator displays overloads of the average or real-time indicator.

If it lights up, decrease the number of EQ modules, active effects, and audio channels that play back simultaneously. You can also activate the ASIO-Guard.

Disk

Shows the hard disk transfer load.

Disk overload indicator

The overload indicator to the right of the disk indicator lights up if the hard disk does not supply data fast enough.

If it lights up, use Disable Track to reduce the number of tracks playing back. If this does not help, you need a faster hard disk.
NOTE
You can show a simple view of the performance meter on the Transport panel and on the Project window toolbar. These meters only feature the average and the disk indicator.

ASIO-Guard

The ASIO-Guard allows you to shift as much processing as possible from the ASIO realtime path to the ASIO-Guard processing path. This results in a more stable system.

The ASIO-Guard allows you to preprocess all channels as well as VST instruments that do not need to be calculated in realtime. This leads to less dropouts, the ability to process more tracks or plug-ins, and the ability to use smaller buffer sizes.

ASIO-Guard Latency

High ASIO-Guard levels lead to an increased ASIO-Guard latency. When you adjust a volume fader, for example, you will hear the parameter changes with a slight delay. The ASIO-Guard latency, in contrast to the latency of the audio hardware, is independant from live input.

Restrictions

The ASIO-Guard cannot be used for:

- Realtime-dependent signals
- External effects and instruments
- Plug-ins that have a different bit version than the operating system

NOTE
If you select Devices > Plug-in Manager and click Show Plug-in Information, you can deactivate the ASIO-Guard option for selected plug-ins.

If you activate the monitoring for an input channel, a MIDI or a VST instrument channel, the audio channel and all dependent channels are automatically switched from ASIO-Guard to realtime processing and vice versa. This results in a gentle fade out and fade in of the audio channel.

Activating the ASIO-Guard

PROCEDURE
1. Select Devices > Device Setup.
2. In the Device Setup dialog, open the VST Audio System page.
3. Activate the **Activate ASIO-Guard** option.

**NOTE**

This option is only available, if you activate **Multi Processing**.

4. Select an **ASIO-Guard Level**.

The higher the level, the higher the processing stability and audio processing performance. However, higher levels also lead to an increased ASIO-Guard latency and memory usage.
The **Preferences** dialog provides options and settings that control the global behavior of the program.

**Preferences Dialog**

The Preferences dialog is divided into a navigation list and a settings page. Clicking one of the entries in the navigation list opens a settings page.

- To open the **Preferences** dialog, select File > Preferences.
In addition to the settings, the dialog provides the following options:

**Preference Presets**
- Allows you to select a saved preference preset.

**Store**
- Allows you to save the current preferences as a preset.

**Rename**
- Allows you to rename a preset.

**Delete**
- Allows you to delete a preset.

**Store marked preferences only**
- Allows you to select which pages are included in the preset.

**Help**
- Opens the dialog help.

**Defaults**
- Resets the options on the active page to their default settings.

**Apply**
- Applies any changes that you have made without closing the dialog.

**OK**
- Applies any changes that you have made and close the dialog.

**Cancel**
- Closes the dialog without saving any changes.

---

**Saving a Preference Preset**

You can save complete or partial preference settings as presets.

**PROEDURE**

1. Select **File > Preferences**.
2. In the **Preferences** dialog make your settings.
3. Click the **Store** button in the lower left section of the dialog.
4. Enter a preset name and click **OK**.

**RESULT**

Your settings are now available on the **Preferences Presets** pop-up menu.
Saving Partial Preferences Settings

You can save partial preferences settings. This is useful when you have made settings that only relate to a certain project or situation, for example. When you apply a saved partial preference preset you only change the saved settings. All other preferences will be left unchanged.

PROCEDURE
1. Select File > Preferences.
2. In the Preferences dialog make your settings.
3. Activate Store marked preferences only.
   In the preferences list a Store column is shown.
4. Click in the Store column of the preference pages that you want to save.
5. Click Store in the lower left section of the dialog.
6. Enter a preset name and click OK.

RESULT
Your settings are now available from the Preferences Presets pop-up menu.

Appearance

Colors

This page features subpages that allow you to change the default color settings.

General
   Allows you to adjust the default colors for the general interface of the program.

Track Type Defaults
   Allows you to adjust the default colors for the different track types.
Preferences

Project
Allows you to adjust the default colors in the Project window.

Editors
Allows you to adjust the default colors in the editors.

MixConsole Faders
Allows you to adjust the default colors for the level faders of the channel types in the MixConsole.

MixConsole Racks
Allows you to adjust the default colors for the racks in the MixConsole.

MixConsole Channel Strip
Allows you to adjust the default colors for the channel strips in the MixConsole.

Editing

Default Track Time Type
This allows you to specify the default track time type for new tracks. When you change this setting, all new tracks will use the selected time type.

- **Musical**
  All added tracks are set to musical time type. The respective button shows a note symbol.

- **Time Linear**
  All new audio tracks use linear time base, that is the button shows a clock symbol.

- **Follow Transport Main Display**
  New tracks use the primary time format setting on the transport panel. When this is set to **Bars+Beats**, tracks with musical time base will be added. When this is set to any of the other options (**Seconds**, **Timecode**, **Samples**, etc.), all new tracks will use linear time base.

Select Track on Background Click
This allows you to select a track by clicking in the event display background.

Auto Select Events under Cursor
If this option is activated, all events in the Project window or in an editor that are currently touched by the project cursor are automatically selected. This can be helpful when you rearrange your project, because it allows you to select whole sections (on all tracks) simply by moving the project cursor.
Cycle Follows Range Selection

If this is activated, range selections that you make in the Sample Editor will be mirrored in the Project window as well. This lets you audition a range in the Sample Editor as a loop with the main transport controls, rather than with the Audition and Audition Loop controls in the Sample Editor.

Delete Overlaps

If this is activated and you move, size, or nudge an event so that it partly overlaps another event, the other event is automatically resized so that the overlapped (hidden) section is removed. Hold [Shift] while moving to override this setting.

Link Editors

When this is activated, the parts or events shown in the open editor windows will follow the selection that you make in the Project window.

Parts Get Track Names

If this is activated and you move an event from one track to another, the moved event will automatically be named according to its new track. Otherwise, the event will retain the name of the original track.

Lock Event Attributes

This setting determines which properties are affected when you lock an event (by selecting Lock from the Edit menu). You can select any combination of the following three options:

• Position
  If this is locked, the event cannot be moved.

• Size
  If this is locked, the event cannot be resized.

• Other
  If this is locked, all other editing of the event is disabled. This includes adjusting the fades and event volume, processing, etc.

Quick Zoom

If this option is activated, the contents of parts and events will not be continuously redrawn when you zoom manually. Instead, the contents are redrawn once you have stopped changing the zoom – activate this if screen redraws are slow on your system.

Use Up/Down Navigation Commands for Selecting Tracks only

• When this option is deactivated and no event/part is selected in the Project window, the up/down arrow keys on the computer keyboard are used to step through the tracks in the track list.

• When this option is deactivated and an event/part is selected in the Project window however, the up/down arrow keys still step through the tracks in the track list. Only on the currently selected track, the first event/part will also be selected.
• When this option is activated, the up/down arrow keys are only used to change the track selection — the current event/part selection in the Project window will not be altered.

Track Selection follows Event Selection

If this option is activated and you select an event in the Project window, the corresponding track is also automatically selected.

Automation follows Events

If you activate this option, automation events will automatically follow when you move an event or part on the track.

This facilitates setting up automation that is related to a specific event or part, instead of a specific position in the project. For example, you can automate the panning of a sound effect event (having the sound pan from left to right, etc.) — if you need to move the event, the automation will automatically follow. The rules are:

• All automation events for the track between the start and end of the event or part will be moved. If there are automation events in the position to which you move the part or event, these will be overwritten.

• If you duplicate an event or part (by holding [Alt]/[Option] and dragging or by using the Duplicate or Repeat functions) the automation events will also be duplicated as well.

• This function also affects copying and pasting.

Drag Delay

When you click and drag an event, this setting determines the delay before the event is moved. This helps you avoid accidentally moving events when you click on them in the Project window.

Editing - Audio

Treat Muted Audio Events like Deleted

If you have two overlapping audio events in your project and you mute the top one (the event you hear during playback), playback of the other (obscured) event will still only start at the end of the overlapping section.

If this is not what you want, Treat Muted Audio Events like Deleted allows you to immediately play the obscured event when muting the top event.

Use Mouse Wheel for Event Volume and Fades

• If this is activated, you can use the mouse wheel to move the event volume curve up or down.

• When you hold down [Shift] while moving the mouse wheel, the fade curves will be affected. To move the end point of the fade in, position the mouse in the left half of the event. To move the start point of the fade out, position the mouse in the right half of the event.
On Import Audio Files

This setting determines what happens when importing an audio file into a project:

- **Open Options Dialog**
  An Import Options dialog opens when you import, allowing you to select whether you want to copy the file to the audio folder and/or convert it to the project settings.

- **Use Settings**
  Allows you to set the following standard actions:
  - **Copy Files to Working Directory** copies the files to the project’s audio folder before import.
  - **Convert and Copy to Project If Needed** copies the files to the project’s audio folder before import and converts them if the files have a different sample rate or a lower resolution than the project settings.
  - **Split channels/Split multi-channel files** copies the files to the project’s audio folder and splits stereo or multi-channel audio files into a corresponding number of mono files – one for each channel. Use the **Split File Name Format** pop-up menu to specify how the split files are named. This allows for compatibility with other products when exchanging audio files and avoids confusion if the source file contains no stereo or surround material, but poly-mono audio.

Enable Automatic Hitpoint Detection

If this is activated, and you add an audio file to your project by recording or by importing, Cubase automatically detects its hitpoints. This allows you to navigate to hitpoints of an audio file from within the **Project** window.

Remove Regions/Hitpoints on all Offline Processes

If this is activated and you perform offline processing on an audio range that contains regions, these will be removed.

On Processing Shared Clips

This setting determines what happens when you apply processing to a shared clip, that is a clip that is used by more than one event in the project:

- **Open Options Dialog**
  An Options dialog appears, allowing you to select whether you want to create a new version of the clip or apply the processing to the existing clip.

- **Create New Version**
  A new editing version of the clip is automatically created, and the processing is applied to that version (leaving the original clip unaffected).

- **Process Existing Clip**
  The processing is applied to the existing clip (which means that all events playing that clip will be affected).

Default Warping Algorithm

Determines which warp algorithm is used for new audio clips in the project.
Time Stretch Tool Algorithm

Use this option to select a default algorithm that is applied when using the Object Selection tool in Sizing Applies Time Stretch mode. This mode allows you to resize parts and events in the Project window and apply time stretch to their contents in the process, so that the audio material is adjusted to fit the new length of the part or event. The following settings are available:

- **Realtime**
  This algorithm is much quicker and allows for better CPU performance than MPEX, but produces a lower sound quality.

- **MPEX – Preview Quality**
  Use this mode only for preview purposes.

- **MPEX – Mix Fast**
  This mode is a very fast mode for preview. This works best with composite music signals (mono or stereo material).

- **MPEX – Solo Fast**
  Use this mode for single instruments (monophonic material) and voice.

- **MPEX – Solo Musical**
  Same as above but higher quality.

- **MPEX – Poly Fast**
  Use this for processing monophonic and polyphonic material. This is the fastest setting that still provides very good results. You can use this for drum loops, mixes, or chords.

- **MPEX – Poly Musical**
  Use this for processing monophonic and polyphonic material. This is the recommended MPEX default quality setting. You can use this for drum loops, mixes, or chords.

- **MPEX – Poly Complex**
  This high quality setting produces high CPU load. Use this setting when processing difficult material or for stretch factors above 1.3.

Editing - Controls

Many Cubase parameters are shown as rotary encoders, sliders, and buttons that emulate hardware interfaces. Others are edited numerically in value fields. This page allows you to select the preferred ways of controlling encoders, sliders, and value fields.

Value Box/Time Control Mode

The menu contains the following options:

- **Text Input on Left-Click**
  In this mode, clicking a value box will open it for editing by typing.
• **Increment/Decrement on Left/Right-Click**
  In this mode, you can click with the left or right mouse button to decrease or increase the value. To edit values by typing in this mode, please double-click. Under Mac OS X, right-clicking is the same as [Ctrl]/[Command]-clicking. We recommend that you use a two-button mouse and set up the right button to generate a [Ctrl]/[Command]-click.

• **Increment/Decrement on Left-Click and Drag**
  In this mode, you can click and drag up or down to adjust the value (much like dragging a vertical fader). Double-click to enter values manually.

**Knob Mode**

The menu contains the following options:

• **Circular**
  To move an encoder, click on it and drag in a circular motion, such as turning a real encoder. When you click anywhere along the encoder’s edge, the setting is immediately changed.

• **Relative Circular**
  Works like the **Circular** option, but clicking does not automatically change the setting. This means you can make adjustments to the current setting by clicking anywhere on an encoder and dragging. There is no need to click on the exact current position.

• **Linear**
  To move an encoder, click on it and drag up or down (or left or right) with the mouse button pressed – as if the encoder was a vertical (or horizontal) slider.

**Slider Mode**

The menu contains the following options:

• **Jump**
  In this mode, clicking anywhere on a slider will make the slider handle instantly move to that position.

• **Touch**
  In this mode, you have to click on the actual slider handle to adjust the parameter. This reduces the risk of accidentally moving sliders.

• **Ramp**
  In this mode, clicking anywhere on a slider (but not on the actual handle) and keeping the mouse button pressed causes the handle to move smoothly to the new position.

• **Relative**
  In this mode, clicking on a slider will not immediately change the setting. Instead you click and drag up or down – the setting will be changed according to how far you drag, not according to where you click.
Editing - MIDI

Select Controllers in Note Range: Use Extended Note Context

When this is activated and you move notes together with their controllers, for example, in the Key Editor, the extended note context will be taken into account. This means that controllers between the last selected note and the following note (or the end of the part) will also be moved. When this is deactivated, only the controllers between the first and the last selected note will be moved.

Legato Overlap

Determines the result of the Legato function on the MIDI menu.

- If **Legato Overlap** is set to 0 Ticks, the Legato function extends each selected note so that it reaches the next note exactly.

- Setting **Legato Overlap** to a positive value causes the notes to overlap by the specified number of ticks.

- Setting **Legato Overlap** to a negative value makes the Legato function leave a slight gap between the notes.

Legato Mode: Between Selected Notes Only

When this is activated, the length of selected notes will be adjusted so that they reach the next selected note, allowing you to apply Legato only to your bass line, for example.

Split MIDI Events

If you split a MIDI part in the **Project** window (with the **Cut** tool or one of the split functions) so that the split position intersects one or several MIDI notes, the result depends on this setting.

- If **Split MIDI Events** is activated, the intersected notes are split. This creates new notes at the beginning of the second part.

- If **Split MIDI Events** is deactivated, the notes will remain in the first part, but stick out after the end of the part.

Split MIDI Controllers

If you split a MIDI part containing controllers, the result depends on this setting:

- If **Split MIDI Controllers** is activated and the part contains a controller with a value other than zero at the split position, a new controller event (of the same type and value) will be inserted at the split position (at the start of the second part).

- If **Split MIDI Controllers** is deactivated, no new controller events will be inserted.
NOTE

If you just split a part and play back the result, it will sound the same regardless of this setting. However, if you split a part and delete the first half or move the second half to a different position in the project, you may want to activate **Split MIDI Controllers** to make sure all controllers have the correct value at the beginning of the second part.

**Editing - Project & MixConsole**

**Select Channel/Track on Solo**

When you activate this option, a track in the track list or a channel in the **MixConsole** automatically gets selected when the **Solo** button is activated. Deactivating this option always keeps the current selection status, regardless of the solo setting for the tracks.

**Select Channel/Track on Edit Settings**

When you activate this option, a track in the track list or a channel in the **MixConsole** automatically gets selected when you click the respective edit button (e). Deactivating this option always keeps the current track/channel selection.

**Scroll To selected Track**

If you activate this option, selecting a **MixConsole** channel automatically scrolls the track list to display the respective track.

**Sync Selection in Project Window and MixConsole**

If this is activated, and you select a track in the **Project** window, the corresponding channel is automatically selected in the **MixConsole** and vice versa.

This can be a very handy feature when making detailed settings for audio and MIDI channels: open the **Channel Settings** window for a track by clicking its edit “e” button, and position it so that it can remain open without obstructing the view. Then you can simply select the track for which you want to make settings in the **Project** window. The **Channel Settings** window will automatically change to show the settings for the selected track.

**Enable Record on Selected Audio Track**

When this is activated, selected audio tracks are automatically record enabled.

**Enable Record on Selected MIDI Track**

When this is activated, the selected MIDI tracks are automatically record enabled.

**Enable Solo on Selected Track**

When this is activated, the selected tracks are automatically soloed.
Deep Track Folding

If this option is activated, any folding settings that you make on the Track Folding submenu of the Project menu also affect the subelements of the tracks. For example, if you fold in a folder track that contains 10 audio tracks, of which 5 have several open automation tracks, all these audio tracks within the folder track will also be folded in.

Enlarge Selected Track

Activate this option to enter a mode where the selected track in the Project window will be enlarged. You can adjust the size directly in the track list if the default enlargement factor does not suit you. When you select another track in the track list, this track is automatically enlarged, and the previously selected track is displayed in its previous size.

Editing - Tool Modifiers

On this page you can specify which modifier keys are used for additional functionality when using tools.

**PROCEDURE**

1. Select an option in the Categories list.
2. Select the action for which you want to edit the modifier key in the Action list.
3. On your computer keyboard, hold down the modifier keys and click Assign.

**RESULT**

The current modifier key(s) for the action is replaced. If this tool already has assigned modifier key(s), you will be asked whether you want to replace them.

Editing - Chords

‘X’ Chords Mute Notes on Tracks That are in Follow Chord Track Mode

This determines what happens when you play back a track that follows the chord track and the cursor reaches an undefined chord event (X chord). Activate this option to mute playback. Deactivate this option to continue playback of the last defined chord event.

Disable ‘Acoustic Feedback’ during Playback

If you activate this option, Acoustic Feedback is automatically disabled on playback. This ensures that chord events are not triggered twice.

Hide muted Notes in Editors

If you set up a MIDI track to follow the chord track by activating one of the Follow Chord Track options, some of the original MIDI notes may be muted. Activate this option to hide these notes in the editors.
Editing - Tools

Select Tool: Show Extra Info

Activate this to show a tooltip for the Object Selection tool in the Project window event display. This tooltip indicates the current pointer position and the name of the track and event at which you are pointing.

Warn before switching Display Domain (Timewarp Tool) (Cubase Pro only)

If this is activated, a warning opens if you select the Timewarp tool and the ruler is not set to Bars and Beats.

Zoom Tool Standard Mode: Horizontal Zooming Only

This affects the result when using the Zoom tool (magnifying glass).

If this is activated and you drag a selection rectangle with the Zoom tool, the window is only zoomed horizontally and the track height does not change. If this option is deactivated, the window is zoomed both horizontally and vertically.

Pop-up Toolbox on Right-Click

If this is activated, the toolbox opens on right-click in the event display and editors. You can change the number of rows in which the tools are arranged on the toolbox. Keep the right mouse button pressed until the mouse pointer changes to a double arrow and drag to the bottom or right.

- To open the context menu instead of the toolbox, press any modifier key when right-clicking.

Cross-Hair Cursor

This allows you to set up a cross-hair cursor when working in the event display and editors, facilitating navigation and editing, especially when arranging in large projects. You can set up the colors for the line and the mask of the cross-hair cursor, and define its width. The cross-hair cursor works as follows:

- If the Selection tool (or one of its subtools) is selected, the cross-hair cursor appears when you start moving or copying a part/event or when you use the event trim handles.
- If the Draw tool, the Cut tool, or any other tool that makes use of this function is selected, the cross-hair cursor appears as soon as you move the mouse over the event display.
- The cross-hair cursor is only available for tools where such a function is of any use.

Event Display

The Event Display section contains several settings for customizing the display in the Project window.
Show Event Names
Determine whether the names of parts and events are shown.

Hide Truncated Event Names
When zooming or resizing elements, the events can become very small so that
the name is no longer completely visible. The name gets truncated. If this
option is activated, event names are hidden if they do not fit into the event.

Show Overlaps
When events overlap, this setting allows you to specify when the overlapping
areas are displayed.

Grid Overlay Intensity
Increases or decreases the overlay intensity of the displayed grid lines.

Event Handling Opacity
Increases or decreases the opacity of an overlying event background when
you move it.

Smallest Track Height To Show Data
Specifies from which track height the track contents are displayed.

Smallest Track Height To Show Name
Specifies from which track height the track names are displayed.

Event Display - Audio

Interpolate Audio Waveforms
If you have zoomed in to one sample per pixel or less, the appearance of the
samples depends on this setting. If the option is deactivated, single sample
values are drawn as steps. If the option is activated, the sample values are
interpolated to form curves.

Show Event Volume Curves Always
If activated, event volume curves, as created by the fade and volume handles,
are shown for all events, regardless of whether they are selected or not. When
the option is deactivated, volume curves are only shown for selected events.
However, note that you can still adjust fades and volumes for events that are
not selected, by clicking and dragging the top left, middle, or right edge
respectively.

Show Waveforms
If activated, audio waveforms are displayed for audio events.

Show Hitpoints on Selected Events
If activated, hitpoints are displayed for audio events.

Waveform Brightness
Increases or decreases the brightness of the displayed waveforms.
Waveform Outline Intensity

Increases or decreases the intensity of the waveform outline.

Fade Handle Brightness

Increases or decreases the brightness of the set fade lines within audio events.

Background Color Modulation

When this is activated, the backgrounds of audio waveforms reflect the waveform dynamics. This is especially useful to get an overview when working with small track heights.

Event Display - Folders

Show Event Details

If this option is activated, event details are displayed. If deactivated, data blocks are displayed.

This setting depends on the Show Data on Folder Tracks setting.

Show Data on Folder Tracks

Determines in which case data blocks or event details are displayed on folder tracks.

- Always Show Data
  If this option is activated, data blocks or event details are always displayed.

- Never Show Data
  If this option is activated, nothing is displayed.

- Hide Data When Expanded
  If this option is activated, the display of events is hidden when you open folder tracks.

Event Display - MIDI

Default Edit Action

Determines which editor is opened when you double-click a MIDI part or when you select it and press [Ctrl]/[Command]-[E]. Note that this setting is overwritten for tracks with drum maps if the Edit as Drums when Drum Map is assigned option is activated.

Part Data Mode

Determines if and how events in MIDI parts are shown: not shown, as lines, as score notes, as drum notes, or as blocks. Note that this setting is overwritten for tracks with drum maps if the Edit as Drums when Drum Map is assigned option is activated.
Show Controllers
Governs whether non-note events such as controllers, etc. are shown in MIDI parts.

Note Brightness
Increases or decreases the brightness of note events.

Controller Brightness
Increases or decreases the brightness of controller events.

Edit as Drums when Drum Map is assigned
If this is activated, parts on MIDI tracks to which drum maps are assigned are shown with drum note symbols. The parts will automatically open in the Drum Editor on double-click. This overwrites the Default Edit Action setting.

Event Display - Chords

Pitch Notation
- The Note Name pop-up menu lets you select between three ways of displaying chords.
- The Naming Format pop-up menu lets you determine how MIDI note names (pitches) are displayed in editors, etc.
- The options Display ‘Bb’ as ‘B’ and Display ‘B’ as ‘H’ allow you to change the corresponding pitch names.

Chord Font
Allows you to specify a font for all chord symbols.

Chord Symbols
There are several ways of indicating chord types, for example, major and minor chords. These options allow you to select your preferred display method for major 7th chords, minor chords, half-diminished chords, diminished chords, and augmented chords.

Event Display - Tracks

Colorize Track Controls
This slider allows you apply the track color to the track controls. Drag the slider to the right to intensify the color.

Colorize Only Folder Track Controls
Activate this to restrict the effect of the Colorize Track Control function to folder tracks only. This is useful in projects with a large number of tracks and folder tracks.
Default Track Name Width
Allows you to determine the default name width for all track types.

Auto Track Color Mode
This offers you several options for automatically assigning colors to tracks that are added to the project:

• **Use Default Track Color**
  New tracks get the default event color.

• **Use Previous Track Color**
  New tracks get the same color as the track above them in the track list.

• **Use Previous Track Color + 1**
  This is similar to the **Use Previous Track Color** option, except that the new tracks get the next color in the color palette.

• **Use Last Applied Color**
  New tracks get the color that you last applied to an event/part.

• **Use Random Track Color**
  Inserted tracks get random track colors.

---

**General**

The **General** page contains general settings that affect the program user interface. Set these according to your preferred work methods.

**Language**
Allows you to select which language is used in the program. After switching the language, you must restart the program for the change to take effect.

**Auto Save**
If this is activated, Cubase automatically saves backup copies of all open projects with unsaved changes. These are named **Name.bak**, where name is the name of the project, and are saved in the project folder. Backup copies of unsaved projects are named **#UntitledX.bak** where X is an incremental number, to allow multiple backup copies in the same project folder.

**Auto Save Interval**
Allows you to specify how often a backup copy is created.

**Maximum Backup Files**
Allows you to specify how many backup files will be created with the **Auto Save** function. When the maximum number of backup files is reached, the existing files will be overwritten (starting with the oldest file).

**Show Tips**
If this is activated and you position the pointer over an icon or button in Cubase, an explanatory tooltip is displayed after a second.
Maximum Undo Steps

Allows you to specify the number of undo levels.

Run Setup on Create New Project

If this is activated, Cubase automatically displays the Project Setup dialog every time you create a new project. This allows you to specify the basic project configuration.

Open External Projects in Last Used View

If this option is activated and you open a project that has been created on a different computer, the window and dialog settings that you last used on your computer is applied to the project. This can either be the last used view that was saved on your computer or one of your specified global workspaces. If you deactivate this setting, external projects are always opened in their original layout.

Use Steinberg Hub

Activate this option to open Steinberg Hub when you start Cubase or create a new project using the File menu.

General - Personalization

Default Author Name

Allows you to specify an author name that is used by default for new projects. This will be included as metadata when exporting audio files with an iXML chunk.

Default Company Name

Allows you to specify a company name that is used by default for new projects. This will be included as metadata when exporting audio files with an iXML chunk.

MIDI

This page contains settings that affect MIDI recording and playback.

MIDI Thru Active

If this is activated, all MIDI tracks that are record enabled or have monitoring activated will “echo” incoming MIDI data, sending it back out on their respective MIDI outputs and channels. This allows you to hear the correct sound from your MIDI instrument during recording.

NOTE

If you use MIDI Thru, select Local Off mode on your MIDI instrument to prevent each note from sounding twice.
Preferences
MIDI

Reset on Stop

If this is activated, Cubase sends out MIDI Reset messages (including noteoff and controller resets) on stop.

Never Reset Chased Controllers

If this is activated, controllers are not reset to 0 when you stop playback or move to a new position in the project.

Length Adjustment

This allows you to enter a length adjustment value in ticks by which the notes that have the same pitch and MIDI channel are adjusted. This ensures that there is always a short time between the end of one note and the start of another. By default, there are 120 ticks per 1/16 note, but you can adjust this with the MIDI Display Resolution setting.

Chase Events

Event types for which an option is activated are chased when you locate to a new position and start playback. This makes your MIDI instruments sound as they should when you locate to a new position and start playback.

If Chase not limited to Part Boundaries is activated, MIDI controllers are also chased outside the part boundaries, and the chase is performed on the part touched by the cursor as well as on all the parts to the left of it. Deactivate this for very large projects, as it slows down processes such as positioning and soloing.

MIDI Display Resolution

This allows you to set the display resolution for viewing and editing MIDI data. This only affects how MIDI events are displayed and not how they are recorded.

Insert Reset Events after Record

If this is activated, a reset event is inserted at the end of each recorded part. This resets controller data, such as Sustain, Aftertouch, Pitchbend, Modulation, Breath Control. This is useful if you stop recording before the note off command is sent, for example.

Audition through MIDI Inserts/Sends

If this is activated, the layering of MIDI instruments (by MIDI sends) is also active within the MIDI editors. This way, the acoustic feedback of the editors sends the MIDI data not only to the output selected for the track, but additionally through any MIDI inserts and MIDI sends assigned to it. Note, however, that this also means that MIDI events will be sent through any MIDI plug-ins assigned to this track.

MIDI Max. Feedback in ms

This allows you to set the maximum length of the notes when using Acoustic Feedback in MIDI editors.
MIDI - MIDI File

Export Options

These options allow you to specify what data is included in exported MIDI files.

Export Inspector Patch

If this is activated, the MIDI patch settings in the Inspector - Bank Select and Program Select (used for selecting sounds in the connected MIDI instrument) are included as MIDI Bank Select and Program Change events in the MIDI file.

Export Inspector Volume/Pan

If this is activated, Volume and Pan settings made in the Inspector are included as MIDI Volume and Pan events in the MIDI file.

Export Automation

If this is activated, the automation data (just as it is heard during playback) is converted to MIDI controller events and included in the MIDI file. This also includes automation recorded with the MIDI Control plug-in.

Note that if a continuous controller (e.g. CC7) has been recorded but the Read button is deactivated for the automation track (i.e. the automation is effectively switched off for this parameter), only the part data for this controller will be exported.

If this option is deactivated and the Read Automation button is activated, no continuous controllers will be exported. If the Read button is deactivated, the controller data of the MIDI part are exported (these will now be handled like "regular" part data).

It is recommended to activate the "Export Automation" option.

Export Inserts

If this is activated and you are using MIDI modifiers or any MIDI plug-ins as insert effects, the modifications to the original MIDI notes that occur as a result of the effect(s) will be included in the MIDI file. A MIDI delay, for example, will produce a number of repeats to a MIDI note by actually adding additional, "echoing" notes at rhythmic intervals - these notes will be included in the MIDI file if the option is activated.

Export Sends

If this is activated and you are using any MIDI plug-ins as send effects, the modifications to the original MIDI notes that occur as a result of the effect(s) will be included in the MIDI file.

Export Markers

If this is activated, any markers you have added will be included in the MIDI file as Standard MIDI File Marker events.
Export as Type 0
If this is activated, the MIDI file will be of Type 0 (all data on a single track, but on different MIDI channels). If you do not check this option, the MIDI file will be of Type 1 (data on separate tracks). Which type to choose depends on what you want to do with the MIDI file (in which application or sequencer it is to be used).

Export Resolution
You can specify a MIDI resolution between 24 and 960 for the MIDI file. The resolution is the number of pulses, or ticks, per quarter note (PPQ) and determines the precision with which you will be able to view and edit the MIDI data. The higher the resolution, the higher the precision. The resolution should be chosen depending on the application or sequencer with which the MIDI file will be used though, because certain applications and sequencers may not be able to handle certain resolutions.

Export Locator Range
If this is activated, only the range between the left and right locator will be exported.

Export includes Delay
If this is activated, any delay settings you have made in the Inspector will be included in the MIDI file.

NOTE
To include other Inspector settings, you must convert the settings to real MIDI events and properties by using the Merge MIDI in Loop function for each track.

NOTE
Exported MIDI files include the tempo and time signature events of the Tempo Track Editor or, if the tempo track is deactivated, the current tempo and time signature.

Import Options
These options allow you to specify what data is included in imported MIDI files.

Extract First Patch
If this is activated, the first Program Change and Bank Select events for each track are converted to Inspector settings for the track.

Extract First Volume/Pan
If this is activated, the first MIDI Volume and Pan events for each track are converted to Inspector settings for the track.
Import Controller as Automation Tracks

If this is activated, MIDI controller events in the MIDI file will be converted to automation data for the MIDI tracks. If this is deactivated, controller data for the MIDI parts will be imported.

Import to Left Locator

If this is activated, the imported MIDI file will be placed so that it starts at the position of the left locator - otherwise it will start at the beginning of the project. Note that if you choose to have a new project created automatically, the MIDI file will always start at the beginning of the project.

Import Markers

If this is activated, Standard MIDI File Markers in the file will be imported and converted to Cubase markers.

Import dropped File as single Part

If this is activated and you drag and drop a MIDI file into the project, the whole file will be placed on a single track.

Ignore Master Track Events on Merge

If this is activated and you import a MIDI file into the current project, tempo track data in the MIDI file is ignored. The imported MIDI file will play according to the current Tempo track in the project.

If this option is deactivated, the Tempo Track Editor will be adjusted according to the tempo information in the MIDI file.

Auto Dissolve Format 0

If this is activated and you import a MIDI file of type 0 into the project, the file will automatically be “dissolved”: For each embedded MIDI channel in the file, a separate track will be inserted in the Project window.

If this is deactivated, only one MIDI track will be created. This track will be set to MIDI Channel “Any”, allowing all MIDI events to play back on their original channels. You can also use the “Dissolve Part” function on the MIDI menu to distribute the events onto different tracks (or lanes) with different MIDI Channels at a later stage.

Destination

This allows you to specify what happens when you drag a MIDI file into the project:

- Select **MIDI Tracks** to create MIDI tracks for the imported file.

- Select **Instrument Tracks** to create instrument tracks for each MIDI channel in the MIDI file and let the program automatically load appropriate presets.

- Select **HALion Sonic SE multi-timbral** to create several MIDI tracks, each routed to a separate instance of HALion Sonic SE in the VST Instruments window and load the appropriate presets.
**Import Karaoke Lyrics as Text**

Activate this to convert karaoke lyrics in the MIDI file to text that can be displayed in the Score Editor. If this is deactivated, lyrics are only shown in the List Editor.

**MIDI - MIDI Filter**

This page allows you to prevent certain MIDI messages from being recorded and/or echoed by the MIDI Thru function (thruput). The page is divided into four sections:

**Record**

Activating any of these options prevents the corresponding type of MIDI message from being recorded. It will, however, be thruput, and if already recorded, it will play back normally.

**Thru**

Activate any of these options to prevent the corresponding type of MIDI message from being thruput. It will, however, be recorded and played back normally.

**Channels**

If you activate a Channel button, no MIDI messages on that MIDI Channel will be recorded or thruput. Already recorded messages will however be played back normally.

**Controller**

Allows you to prevent certain MIDI controller types from being recorded or thruput.

To filter out a controller type, select it from the list at the top of the section and click “Add”. It will appear in the list below.

To remove a controller type from the list (allow it to be recorded and thruput), select it in the lower list and click “Remove”.

**MediaBay**

**Scan unknown File Types**

Activate this to open and scan any file in the search location and ignore files that cannot be recognized.

**Maximum Items in Results List**

This allows you to specify the maximum number of files that are displayed in the Results list. This helps you to avoid unmanageably long lists of files in the Results list.
Allow Editing in Results List
Activate this to edit attributes also in the Results list. Otherwise, editing can only be done in the Attribute Inspector.

Show File Extensions in Results List
Activate this to display file name extensions in the Results list.

Scan Folders only when MediaBay is open
Activate this to scan Cubase for media files when the MediaBay window is open. Otherwise, the folders are scanned in the background even when the MediaBay window is closed.

NOTE
During playing back or recording no folder scans are performed.

Metering

Map Input Bus Metering to Audio Track (in Direct Monitoring)
This allows you to map the input bus metering to monitor-enabled audio tracks, giving you the opportunity to watch the input levels of your audio tracks when working in the Project window. For this to work, activate Direct Monitoring in the Device Setup dialog.

- If this option is activated, audio tracks show the metering signal from the input bus to which they are routed as soon as the track is monitor-enabled. Note that the tracks are mirroring the input bus signal, that is, you will see the same signal in both places. When using mapped metering, any functions, such as trimming, that you apply to the audio track are not reflected in its meters.

- If this option is not activated, metering works as usual.

Meters’ Peak Hold Time
This allows you to specify for how long the peak levels are held in the meters. For this to work, deactivate Meters - Hold Forever in the MixConsole.

Meters’ Fallback
This allows you to specify how quickly the meters in the MixConsole return to lower values after signal peaks.

Metering - Appearance
On this page you can assign colors to level meter values to quickly identify what levels are reached. You can adjust the colors for the channel meter or the master meter. For the master meter you can only make changes for the Digital Scale scaling mode. Changes take effect when you click Apply or OK.
To adjust the levels and colors, activate the channel meter or master meter option and proceed as follows:

- To specify the level for a color change, double-click a handle to the right of the meter scale and enter the level (dB) value. Note that for dB values less than 0, you must add a minus sign before the entered number. You can also click a handle and drag it to a specific level. Press [Shift] for more accurate positioning. Alternatively, you can nudge with the Arrow Up/Down keys. Press [Shift] for faster positioning.

- To assign a color, click the upper or lower part of a handle so that a black frame is shown, and use the color selector pane to select a color. Selecting the same color for the upper and lower part of the handle results in a meter that changes its colors gradually, while different colors indicate level changes even more precisely.

- To add more color handles, click the Add button, or [Alt]/[Option]-click at a level position to the right of the meter scale. Each new handle is automatically associated with a default color.

- To remove a handle, select the handle and click the Remove button, or [Ctrl]/[Command]-click the handle.

**Record**

This page contains settings related to audio and MIDI recording. Select one of the available entries.

**Record - Audio**

**Audio Pre-Record Seconds**

This allows you to specify for how many seconds any incoming audio you play is captured in buffer memory during playback or in stop mode.

**When Recording Wave Files larger than 4GB**

This allows you to specify what happens if you record Wave files that are larger than 4GB.

- To split the Wave file, activate Split Files. Use this, if you work on a FAT32 file system that supports only file sizes up to 4 GB.

- To save the Wave file as RF64 file, activate Use RF64 Format. RF64 files use the .wav extension. However, they can only be opened with an application that supports the RF64 standard.
Create Audio Images During Record

If this option is activated, Cubase calculates the waveform image and displays it during the actual recording process.

NOTE

This realtime calculation uses some extra processing power.

Record - Audio - Broadcast Wave

This page allows you to specify the Description, Author, and Reference text strings that are embedded in recorded Broadcast Wave files. The settings you make here also appear as default strings in the Broadcast Wave Chunk dialog when you export files to certain formats (not only Broadcast Wave files can contain embedded information, but also Wave, Wave 64, and AIFF files).

Record - MIDI

Record-Enable allows MIDI Thru

Activate this option if you do not want record-enabled MIDI or instrument tracks to echo incoming MIDI data. This prevents hearing doubled notes on record-enabled tracks to which a VST instrument is assigned.

Snap MIDI Parts to Bars

Activate this to lengthen recorded MIDI parts automatically to start and end at whole bar positions. If you are working in a Bars+Beats-based context, this can make editing (Moving, Duplicating, Repeating, etc.) easier.

Solo Record in MIDI Editors

Activate this to automatically Record Enable a track when you open a part for editing in a MIDI editor. For all other MIDI tracks Record Enable is deactivated until you close the editor again.

This makes it easier to record MIDI data when you edit a part – you will always be sure the recorded data ends up in the edited part and not on any other track.

MIDI Record Catch Range in ms

When you record starting at the left locator, this setting helps you make sure that the very start of the recording is included. If you raise the Record Catch Range, Cubase will catch the events played just before the recording start point, eliminating this problem.

Retrospective Record

When this is activated, the program captures MIDI input in buffer memory, even when not recording. The contents of the buffer memory can then be retrieved and turned into a MIDI part on a record enabled MIDI track. This therefore allows you to capture any MIDI notes you play in stop mode or during playback and later turn them into a recorded MIDI part.
Use the “Retrospective Record Buffer Size” setting to determine how much MIDI data can be captured in the buffer.

**ASIO Latency Compensation Active by Default**

This determines the initial state of the “ASIO Latency Compensation” button in the track list for MIDI or instrument tracks.

If you record live on a VST instrument, you usually compensate the latency of your audio card by playing too early. In consequence, the timestamps are recorded too early. By activating this option, all recorded events are moved by the current latency, and playback sounds like during the recording situation.

**Replace Recording in Editors**

This affects the result of recording in a MIDI editor when Replace Mode is selected (Linear Record Mode on the Transport panel):

- **None**
  Nothing is replaced, even though Replace Mode is selected.

- **Controller**
  Only controller data is replaced, not notes.

- **All**
  Replace mode works as usual - notes and controllers are replaced when recording.

---

**Scores (Cubase Pro only)**

This page allows you to make settings for the Score Editor. Please select one of the available entries.

**Scores - Colors for Additional Meanings**

Here, you can specify different colors to identify non-standard elements in the score.

- Click in the **Active** column to activate this function for the respective element.
- Click in the color field to the right to specify the desired color.

**Scores - Editing**

**Display Object Selection tool after Inserting Symbol**

When this is activated, as soon as you add a symbol, the program switches back to the Object Selection tool. When this is deactivated, the Draw tool remains active after inserting a symbol.
Preferences
Scores (Cubase Pro only)

Double-Click Symbol to get Draw tool
When this is activated, you need to double-click with the Object Selection tool in a Palette to activate the Draw tool. When this is deactivated, a single click is enough to bring out the Pencil.

Keep Crescendo Symbols “Horizontal”
When this is activated, crescendo symbols are never “slanted”.

Keep moved Notes within Key
When this is activated, and you move notes vertically (to transpose them), you will be restricted to pitches within the current key.

Tied Notes selected as Single Units
When this is activated, and you click on either note in a tied note pair, both notes will be selected.

Global Staff Spacings with [Alt-Gr + Ctrl] (Win)/[Option]-[Command] (Mac)
When this is activated, pressing [Alt-Gr + Ctrl] (Win) or [Option]-[Command] (Mac) and adjusting the spacing of staves applies the spacing to all staves on the current page and on all the following pages. When this is deactivated, the spacing is only applied to the current page.

Auto Layout: Don't hide first staff
This option affects the Auto Layout functions “Hide Empty Staves” and “Optimize All”. When “Don’t hide first staff” is activated, staves in the very first grand staff will not be hidden, even if they are empty.

Show Braces in Edit Mode
Normally, braces are only shown in Page Mode. With this option activated they will also be visible in Edit Mode.

“Apply” closes Property Windows
Normally, when you open a Property window or any non-modal score dialog (e.g. Set Note Info or Score Settings), you can adjust the settings and click Apply to apply the changes without closing the window. When this option is activated, clicking Apply closes the window.

Show Position Cursor
When this is activated the Project cursor position is shown as a vertical line in the score. You can click and drag the line to move the cursor or hold down [Ctrl]/[Command] and click anywhere in the score to move the cursor directly there.

Show pitch when inserting notes
If this is activated the pitch of inserted notes is indicated.

Show Note Info by the Mouse
When this is activated and you insert or drag a note in the score, a tooltip will appear below the pointer, showing the current pitch and position. If you feel screen redraws are too slow, you may want to turn this feature off.
Preferences
Scores (Cubase Pro only)

Snap Slurs when dragging
When this is activated, the endpoints of slurs will snap to notes when you draw or move them.

Unlock Layout when editing single parts
If there are more than one part on a track, and you open score edit for one of these parts, the other parts are displayed as “empty space” to preserve the layout. If this option is activated, this empty space is avoided, so you can print this single part without endless rests.

NOTE
Note that this option will erase the layout for the whole track! The next time you open the entire track, the previous layout will be overwritten with the layout settings you made for the single edited part.

Double-click on staff flips between full score/part
When this option is activated, double-clicking on a staff will switch between display of either the whole track or the current part.

NOTE
Note that in this case, the Score Settings dialog will only open if you select the “Settings...” option on the Scores menu.

Layout Tool Compatibility Mode
The behavior of the Layout tool was different in older versions of Cubase. Activate this option if you have an old project in which the Layout tool was used to ensure that the project is displayed as expected.

Hide Notes beyond limits
When this option is activated, any notes outside the Note Limits range set in the Score Settings dialog (Staff page - Options tab) will be hidden.

Default Number of Bars per Staff
This is used in two cases:
• In Edit Mode to set how many bars are shown across the page.
• In Page Mode to decide how many bars there are shown across the page in a new layout.

NOTE
When using the Auto Layout function, you will be asked for the maximum number of bars across the page, overriding this setting.
Scores - Note Layer

If you are moving and editing notes, you might accidentally move other objects nearby. To avoid this, you can assign different types of objects to different Note Layers (up to three) and instruct Cubase to lock one or two of these layers, making them unmovable.

This page is where you specify to which layer each object type belongs. The actual locking of layers is done on the extended toolbar of the Score Editor.

Transport

This page contains options related to playback, recording and positioning.

Playback Toggle triggers Local Preview

When this option is activated, you can use the [Space bar] on your keyboard to start/stop “local” playback of the selected file in the Sample Editor or the Pool.

When the Sample Editor is not open or when there is no audio file selected in the Pool, the [Space bar] still toggles the “global” project playback.

If this option is deactivated, the [Space bar] is used to start/stop playback of the project.

Zoom while Locating in Time Scale

If this option is activated, you can zoom in or out by clicking in the Ruler and dragging down or up.

Cursor Width

Adjusts the width of the Project Cursor line.

Return to Start Position on Stop

If this option is activated and you stop playback, the project cursor automatically returns to the position where recording or playback last started.

If this option is deactivated and you stop playback, the project cursor remains at the position where you stop playback.

If you click Stop again, the project cursor returns to the position where recording or playback last started.

Deactivate Punch In on Stop

If this is activated, Punch In on the Transport panel is automatically deactivated whenever you enter Stop mode.
Stop after Automatic Punch Out

If this is activated, playback will automatically stop after automatic Punch Out (when the Project Cursor reaches the Right Locator and Punch Out is activated on the Transport panel). If the Post-roll value on the Transport panel is set to a value other than zero, playback will continue for the set time before stopping.

Stop playback while winding

You can use the winding functions during playback. When this option is activated, audio playback is stopped as soon as you click the Rewind or Fast Forward buttons on the Transport panel.

When this option is deactivated, audio playback will continue until you release the Rewind or Fast Forward button.

Wind Speed Options

These options affect the fast forward/rewind speed.

- If **Adjust to Zoom** is activated, the wind speed will be adapted to the horizontal zoom factor.

  If you zoom in very close for detailed editing, you probably do not want to have a high fast forward/rewind speed. Because of this, the **Speed Factor** does not have any effect in this mode. The **Fast Wind Factor** still applies though.

- If **Fixed** is activated, the wind speed will always be the same regardless of the horizontal zoom factor.

- Use the **Speed Factor** option to set the wind speed. You can set a value between 2 and 50. The higher the value, the faster the wind speed will be.

  If **Adjust to Zoom** is activated, this has no effect.

- Use the **Fast Wind Factor** to set the wind speed multiple for fast winding.

  If you press [Shift] while fast forwarding or rewinding, the wind speed will increase. The increase in speed is a multiple of the **Speed Factor**. Meaning that if you set the **Fast Wind Factor** to 2, the wind speed will be twice as fast. If you set it to 4, the wind speed will be four times as fast, etc. You can set a value between 2 and 50.

Show Timecode Subframes

If this is activated, all frame based display formats (".fps" and ".dfps") will also show subframes. There are 80 subframes per frame.

User-definable Frame Rate

This is where you set the frame rate (the number of frames per second) for the Display format "User". This frame rate will then be used in every ruler for which you select the User display format.

Stationary Cursors

If this option is activated, the Project cursor will be positioned in the middle of the screen (if possible), and the window will scroll continuously during playback (instead of moving from one "page" to the next).
Locate When Clicked in Empty Space
When this is activated, you can move the Project Cursor by clicking anywhere in an “empty” area of the Project window.

Transport - Scrub

Scrub Volume
This lets you set the playback volume for the Scrub function in the Project window and audio editors.

Use High Quality Scrub Mode
When you activate this option, effects are enabled for scrubbing and the resampling quality is higher. However, scrubbing will be more demanding on the processor.

Use Inserts While Scrubbing
When you activate this option, you can activate insert effects for scrubbing with the shuttle speed control. By default, insert effects are bypassed.

VST
This page contains settings for the VST audio engine.

Connect Sends automatically for each newly created Channel
When this option is enabled, creating a new audio or group channel will automatically connect the send routing for existing FX channels. Note that this option is disabled by default to save memory resources.

Instruments use Automation Read All and Write All
If you deactivate this option, the Read and Write automation status in VST instrument panels are not affected by the “Activate/Deactivate Read for All Tracks” and “Activate/Deactivate Write for All Tracks” automation switches.

Mute Pre-Send when Mute
If this is activated, sends set to “Pre-fader” mode will be muted if you mute their channels.

Default Send Level
This allows you to specify a default level for your send effects.

Group Channels: Mute Sources as well
By default, when you mute a group channel no audio will pass through the group. However, other channels that are routed directly to that group channel will remain unmuted. If any of those channels have cue sends routed to other group channels, FX channels or output busses, those will still be heard.
If **Group Channels: Mute Sources as well** is activated, muting a group channel will cause all other channels directly routed to it to be muted as well. Pressing mute again will unmute the group channel and all other channels directly routed to it. Channels that were muted prior to the group channel being muted will not remember their mute status and will be unmuted when the group channel is unmuted.

**NOTE**

**Group Channels: Mute Sources as well** does not affect how mute automation is written. Writing mute automation on a group channel only affects the group channel and not channels routed to it. When writing the automation you will see the other channels being muted when this option is checked. However, upon playback, only the group channel will respond to the automation.

**Delay Compensation Threshold (for Recording)**

Cubase features full delay compensation - any delay inherent in the VST plug-ins you use will automatically be compensated for during playback. However, when you play a VST instrument in realtime or record live audio (with monitoring through Cubase activated), this delay compensation may result in added latency. To avoid this, you can click the Constrain Delay Compensation button on the Project window toolbar. This function tries to minimize the latency effects of the delay compensation, while maintaining the sound of the mix as far as possible.

The Delay Compensation Threshold setting is a kind of “tolerance” setting for the Constrain Delay Compensation function - only plug-ins with a delay higher than this threshold setting will be affected by the Constrain Delay Compensation function. By default, this is set to 0.0 ms, which means that all plug-ins will be affected (e.g. turned off) when you activate Constrain Delay Compensation. If you feel that a little latency is acceptable, you can raise this threshold value.

**Default Stereo Panner Mode (Cubase Pro only)**

This allows you to specify the default pan mode for inserted audio tracks (Stereo Balance Panner, Stereo Dual Panner or Stereo Combined Panner).

**Activate ‘Link Panners’ for New Tracks (Cubase Pro only)**

Activate this to activate Link Panners by default for new tracks so that the channel sends section always mirrors the Pan settings made in the channel fader section.

**Auto Monitoring**

Determines how Cubase handles monitoring (listening to the input signal during recording). The following options are available:

- **Manual**
  
  This option allows you to turn input monitoring on or off by clicking the monitor button in the track list, Inspector, or MixConsole.

- **While Record Enabled**
  
  With this option you will hear the audio source connected to the channel input whenever the track is record enabled.
• **While Record Running**
  This option switches to input monitoring only during recording.

• **Tapemachine Style**
  This option emulates standard tapemachine behavior: input monitoring in Stop mode and during recording, but not during playback.

**NOTE**

The automatic monitoring options apply when you are monitoring through Cubase, or when you are using ASIO Direct Monitoring. If you are monitoring externally (listening to the input signal from an external mixer, for example), select the “Manual” mode and keep all audio monitor buttons turned off in Cubase.

**Warn on Processing Overloads**

When you activate this option, a warning message is displayed as soon as the CPU overload indicator (on the Transport panel) lights up during recording.

---

**VST - Plug-ins**

**Warn Before Removing Modified Effects**

If this is activated, a dialog will appear whenever you remove an effect plug-in for which you have made parameter changes, asking for confirmation as to whether you really want to remove the effect.

If you do not want this dialog to appear and modified effects to be removed without confirmation, leave this option deactivated.

**Open Effect Editor after Loading it**

When this is activated, loading an effect or VST instrument (e.g. in one of the plug-in slots of the Send or Insert sections) will automatically open the control panel for the plug-in.

**Create MIDI track when loading VSTi**

This pop-up menu allows you to what specify happens when you add a VSTi in the VST Instruments window. The following options are available:

• **Always**
  When this is selected, a corresponding MIDI track will always be created when you add a VST instrument.

• **Do not**
  When this is selected, no MIDI track will be created when you add a VSTi in the VST Instruments window. This is the behavior from earlier versions of Cubase.

• **Always ask to**
  When this is selected, you will be asked whether a corresponding MIDI track is created when you add a VSTi in the VST Instruments window.
Suspend VST3 plug-in processing when no audio signals are received

When this is activated, VST plug-ins will not consume any CPU power during "silent" passages, i.e. when no audio is passing through them. This can improve system performance noticeably.

**NOTE**

Note however that this might lead to situations where you loaded more plug-ins in Stop mode than the system will be able to play back simultaneously. As a safety measure, try playing back the part of your project which contains the largest number of audio events to make sure that your computer system can handle the current number of VST plug-ins.

Synchronize Plug-in Program Selection to Track Selection

If you route multiple MIDI tracks to multi-timbral instruments and activate this option, track selection and plug-in program selection are synchronized.

Plug-in Editors “Always on Top”

When this is activated, the control panels for effect plug-ins and VST instruments will always be shown on top of other windows.

VST - Control Room (Cubase Pro only)

This page contains settings for the Control Room.

Show Control Room Volume in Transport Panel

When this is activated, the Transport panel will display the Control Room Volume if the Control Room is enabled. If the Control Room is disabled, the volume of the Main Mix bus will be shown in the Transport panel.

Auto Disable Talkback Mode

Allows you to specify, if Talkback is disabled during recording, during playback and recording, or not at all.

**NOTE**

Set the Talkback DIM level to 0 dB so as not to radically change the mix level when punching in and out of record mode.

Use Phones Channel as Preview Channel

When this is activated, the Phones channel will be used for monitoring. When this is deactivated, the Monitor channel in the Control Room will be used.

Dim Cue during Talkback

When this option is activated, the cue mix heard in a studio will be dimmed (by the amount set in the Talkback Dim Level field in the Control Room) for as long as the Talkback channel is used. When this option is deactivated, the cue mix level remains the same during Talkback.
**Exclusive Device Ports for Monitor Channels**

When activated, the port assignment for Monitor channels is exclusive. If your scenario does not require you to assign ports to several Monitor channels, it is recommended to activate this option. This way you can make sure that you do not accidentally assign ports to inputs/outputs and Monitor channels at the same time.

**NOTE**

This setting is saved with the Control Room presets.

---

**Reference Level**

The reference level is the level that is used in calibrated mixing environments, such as film dubbing stages. Use this option to specify the reference level that can be assigned to the Control Room level.

**NOTE**

You can also manually adjust the reference level in the Control Room settings.

---

**Main Dim Volume**

Use this to set the amount of gain reduction applied to the Control Room channel when the DIM button is activated.

---

**VariAudio (Cubase Pro only)**

**Inhibit warning when changing the Sample Data**

When you are modifying audio material that is used in several places in the project in the Sample Editor, a warning message is shown. This message can be deactivated: If you activate the Please, don’t ask again checkbox, the message will not be displayed in the future (when editing the pitch or time of audio material that is used several times in one project).

To display this message again, and thus be informed whether the audio is used in other places, deactivate this option.

**Inhibit warning when applying Offline Processes**

When you are applying offline processes (e.g. with the Envelope or Normalize functions) to audio material that is used in several places in the project, a warning message is shown. This message can be deactivated: If you activate the Please, don’t ask again checkbox, the message will not be displayed in the future.

To display this message again, and thus be informed whether the audio is used in other places, deactivate this option.
Preferences
Video

Video

Extract Audio on Import Video File

If this option is activated and you import a video file, the audio data of the video is automatically extracted and saved as a separate audio clip.

Thumbnail Memory Cache Size

The value entered here determines how much memory is available for displaying thumbnails. The currently shown image of a video is buffered in the thumbnail memory cache. Whenever you move to another image and there is no memory capacity left, the “oldest” picture in the cache is replaced by the current one. If you have long video clips and/or work with a large zoom factor, you may have to raise this value.
Part II - Score Layout and Printing (Cubase Pro only)
How the Score Editor works

About this chapter

In this chapter you will learn:

- How the Score Editor and MIDI data relate.
- What Display Quantize is and how it works.

Welcome!

Welcome to scoring in Cubase! The Score Editor has been created to allow you to get any possible piece of music displayed as a score, complete with all the necessary symbols and formatting. It allows you to extract parts out of a full orchestra score, to add lyrics and comments, create lead sheets, score for drums, create tablature, etc. In other words: just about any type of notation you could ever desire!

There are a few basic principles to how the Score Editor works, which you have to understand to make full use of it.

How the Score Editor operates

The Score Editor does the following:

- Reads the MIDI notes in the MIDI parts.
- Looks at the settings you have made.
- Decides how the MIDI notes are displayed according to the settings.

The Score Editor takes MIDI data and settings as input and produces a score as output.

The Score Editor does all this in realtime. If you change some of the MIDI data (for example by moving or shortening a note) this is immediately reflected in the score. If you change some of the settings (for example the time signature or key signature) this is also immediately apparent.
Do not think of the Score Editor as a drawing program, but rather as an “interpreter” of MIDI data.

**MIDI notes vs. score notes**

MIDI tracks in Cubase hold MIDI notes and other MIDI data. As you may know, a MIDI note in Cubase is only defined by its position, length, pitch and velocity. This is not nearly enough information to decide how the note is to be displayed in a score. The program needs to know more: What type of instrument are we talking about, Drums? Piano? What key is the piece in? What is the basic rhythm? How should the notes be grouped under beams? You provide this information by making settings and working with the tools available in the Score Editor.

**An example of the MIDI/score relationship**

When Cubase stores a MIDI note's position, it makes the measurement in an absolute value, called ticks. There are 480 ticks to a quarter note. Have a look at the example below:

A quarter note at the end of a 4/4 measure

The note is on the fourth beat of the measure. Now, let’s say you change the time signature to 3/4. This shortens the length of a “measure” to only three quarter notes – 1440 ticks. Suddenly our quarter note is in the next measure:

The same note in 3/4

Why? Since you are not changing the MIDI data in the track/part (that would ruin your recording!) by changing the time signature, the note is still at the same absolute position. It is just that now each “measure” is shorter, which effectively moves the note in the score.

What we are trying to get across here is that the Score Editor is an “interpreter” of the MIDI data. It follows rules that you set up by making settings in dialogs, on menus, etc. And this interpretation is “dynamic”, or in other words, it is constantly updated whenever the data (the MIDI notes) or the rules (the score settings) change.

**Display Quantize**

Let’s say you used the Project window to record a figure with some staccato eighth notes. When you open the Score Editor, these notes are displayed like this:
How the Score Editor works

Display Quantize

This does not look anything like what you intended. Let’s start with the timing – obviously, you were off at a couple of places (the third, fourth and last note all seem to be a 32nd note late). You can solve this by quantizing the figure, but this would make the passage sound too “stiff”, and not fit in the musical context. To resolve this problem the Score Editor employs something called “Display Quantize”.

Display Quantize is a setting which is used to tell the program two things:

- How precise the Score Editor is to be when displaying the note positions.
- The smallest note values (lengths) you want displayed in the score.

In the example above, the Display Quantize value seems to be set to 32nd notes (or a smaller note value).

Let’s say we change the Display Quantize value to sixteenth notes in the example:

With Display Quantize set to sixteenth notes

OK, now the timing looks right, but the notes still do not look like what you intended. Maybe you can understand that from a computer’s point of view, you did play sixteenth notes, which is why there are a lot of pauses. But that’s not how you meant it. You still want the track to play back short notes, because it is a staccato part, but you want something else “displayed”. Try setting the Display Quantize value to eighth notes instead:

With Display Quantize set to eighth notes

Now we have eighth notes, as we wanted. All we have to do now is to add staccato articulation which can be done with one simple mouse click using the Draw tool or using musical articulations.

How did this work? By setting the Display Quantize value to eighth notes, you give the program two instructions that would sound something like this in English: “Display all notes as if they were on exact eighth note positions, regardless of their actual positions” and “Don’t display any notes smaller than eighth notes, regardless of how short they are”. Please note that we used the word “display”, which leads us to one of the most important messages of this chapter:

**IMPORTANT**

Setting a Display Quantize value does not alter the MIDI notes of your recording in any way, as regular quantizing does. It only affects how the notes are displayed in the Score Editor (and nowhere else)!

**RELATED LINKS**

- Working with symbols on page 1206
- Expression maps (Cubase Pro only) on page 778
Choose your Display Quantize values with care

As explained above, the Display Quantize value for notes puts a restriction on the smallest note value that can be displayed. Let’s see what happens if we set it to quarter notes:

<p>| | | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

With Display Quantize set to quarter notes

Oops, this doesn’t look too good. Well of course it doesn’t! We have now instructed the program that the “smallest” note that occurs in the piece is a quarter note. We have explicitly told it that there are no eighth notes, no sixteenths, etc. So when the program draws the score on screen (and on paper) it quantizes the display of all our eighth notes to quarter note positions, which makes it look like above. But again, please note that when you hit Play, the passage still plays as it originally did. The Display Quantize setting only affects the score image of the recording.

IMPORTANT

Even if you manually enter notes in the score using perfect note values, it is very important that you have your Display Quantize settings right! These values are not just used for MIDI recordings! If you for example set the Display Quantize value for notes to quarter notes and start clicking in eighth notes, you get eighth notes in the track (as MIDI data), but still only quarter notes in the display!

Using Rests as Display Quantize setting

Above we used Display Quantize for notes. There is a similar Display Quantize setting called “Rests” which is used to set the smallest rest to be displayed. Often, this setting is very effective.

Let’s start with the following note example:

<p>| | | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

As you see, the first note appears one sixteenth note late. If we change the Display Quantize value for notes to eighth notes, the score is displayed like this:

<p>| | | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

With Display Quantize: Notes set to eighth notes

Unfortunately, this moves the first note to the same position as the second, since sixteenth note positions are not allowed. We can solve this by inserting extra Display Quantize values within the bar with the Display Quantize tool, but there is a much easier way: Change the Display Quantize value for notes back to sixteenths, but set the value for rests to eighth notes! This tells the program not to display any rests smaller than eighth notes, except when necessary. The result looks like this:

<p>| | | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

With Display Quantize: Notes set to sixteenth notes, but Rests set to eighth notes.
How the Score Editor works
Display Quantize

How did this work? Well, you instructed the program not to display any rests smaller than eighth notes, except when “necessary”. Since the first note appeared on the second sixteenth note position, it was necessary to put a sixteenth rest at the beginning of the figure. All other rests can be hidden by displaying the notes as eighth notes, and were therefore not “necessary”.

This leads us to the following general guidelines:

- Set the Notes value according to the “smallest note position” you want to be shown in the score (e.g. if you have notes on odd sixteenth note positions, set the Notes to sixteenth notes).
- Set the Rests value according to the smallest note value (length) you want to be displayed for a single note, positioned on a beat.

Common Display Quantize settings would be to have Notes set to 16 (sixteenth notes) and Rests set to 4 (quarter notes).

RELATED LINKS
Inserting Display Quantize changes on page 1122

Handling exceptions

Unfortunately, the guidelines above do not work perfectly in every situation. You may for example have a mix of straight notes and tuplets of different types, or you may wish to display equally long notes with different note values depending on the context. There are several methods you can try:

Automatic Display Quantize

If your score contains both straight notes and triplets, you can use Auto Quantize. When this is activated, Cubase tries to “understand” whether the notes should be display quantized to straight notes or triplets.

RELATED LINKS
If your music contains mixed straight notes and triplets on page 1157

Using the Display Quantize tool

With the “Q” tool, you can insert new Display Quantize values anywhere in the score. Inserted Display Quantize values affect the staff from the insertion point onwards.

RELATED LINKS
Inserting Display Quantize changes on page 1122
Permanent alteration of MIDI data

As a last resort, you can resize, quantize or move the actual note events. However, this would result in the music not playing back like it originally did. Often it is possible to get the score to look the way you want without altering any MIDI data.

Summary

This closes our discussion on the basic concept of display quantizing. There are a number of other special situations which require more advanced techniques described in the next chapters. The interpretation options which work along the same lines as Display Quantize are also explained.

Entering notes by hand vs. recording notes

Sometimes you enter and edit notes by hand (or rather using the mouse and/or the computer keyboard) and at other times you record them from a MIDI keyboard. Most of the time, you do a combination of both. In real life, even if you have recorded the piece perfectly, you often have to do some permanent editing to your recording before printing.

RELATED LINKS

Transcribing MIDI recordings on page 1119
Entering and editing notes on page 1127
About this chapter

In this chapter you will learn:

- How to open the Score Editor.
- How to switch between Page Mode and Edit Mode.
- How to set up the page size and margins.
- How to hide and show the Symbols Inspector, the toolbar, and the extended toolbar.
- How to set up the ruler.
- How to set a zoom factor.
- How to make initial settings for clef, key, and time signature.
- How to transpose instruments.
- How to print and export your score.

Preparations

**PROCEDURE**

1. In the Project window, create a MIDI track for each instrument.
   You can prepare a piano (split) staff from a single track, i.e. there is no need to create one track for the bass clef and one for the treble clef.

2. Name each track after the instrument.
   This name can later be used in the score if you like.

3. Record on the tracks or create empty parts on all tracks.
   You can make very long parts that cover the entire project, or you can start out with shorter parts to begin with. If you choose the latter option, you can always go back later and add new parts or copy existing parts.
Opening the Score Editor

Editing one or several parts

To open one or several parts in the Score Editor, select the parts (on the same or on different tracks) and select “Open Score Editor” from the MIDI menu or “Open Selection” from the Scores menu. The default key command for this is [Ctrl]/[Command]-[R].

• You can also select the Score Editor as your default editor, allowing you to open it by double-clicking parts.
   This is done with the Default Edit Action pop-up menu in the Preferences dialog (Event Display–MIDI page).

Editing whole tracks

When preparing a score for printing, you probably want to open whole MIDI tracks in the Score Editor. To do this, select the track(s) in the track list and make sure no parts are selected – then open the Score Editor as described above.

Editing parts on different tracks

If you have selected parts on two or more tracks (or several entire tracks – no parts) and open the Score Editor, you get one staff for each track (although you can split a staff in two, e.g. when scoring for piano). Think of the Project window as an overview of your entire score and the tracks as representing one instrument each.

Editing predefined combinations of tracks

You can open the Score Editor for a certain combination of tracks that you edited before.

RELATED LINKS
   Layout operations on page 1271

Displaying single voices or the complete score

When the Double-click on staff flips between full score/part option is activated in the Preferences dialog (Scores–Editing page), double-clicking on the blue rectangle to the left of a staff switches between display of either the whole score or the current voice.
The basics
The project cursor

The project cursor appears as a vertical line across the staff. When you open the Score Editor, the view is automatically scrolled so that the project cursor is visible in the window. This means you do not always see the beginning of the edited part when you first open the Score Editor.

- Hold down [Alt]/[Option] and [Shift] and click anywhere in the score to move the project cursor there.
  This is handy when the project cursor is not visible. This is not possible if Computer Keyboard Input mode is activated.

Related links
- Entering notes using the computer keyboard on page 1132

Playing back and recording

You can play back and record MIDI in the Score Editor using the standard transport commands, just like in the other MIDI editors.

Related links
- MIDI Editors on page 686

Page Mode

When you are preparing a score for printout, you should set the Score Editor to Page Mode. This is done by selecting Page Mode from the Scores menu. When Page Mode is activated, a checkmark appears next to this menu option.

In Page mode, the window switches to display one page at a time, as it appears on printout.

Page Mode vs. Edit Mode

When Page Mode is not activated, the Score Editor is in Edit Mode. All you can do in Edit Mode, you can also do in Page Mode. But Page Mode offers lots of additional features which are directly related to how the score is displayed and printed.
This section of the manual assumes you are in Page Mode. It is mentioned explicitly if something in this text specifically relates to Edit Mode.

Changing the Background in Page Mode

In Page Mode, you can specify different background textures for the score by selecting an option from the Background Texture pop-up menu on the toolbar.

NOTE

The background texture only affects the display and is not used for printing.

Using the scrollbars in Page Mode

In Page Mode, the scrollbars are used to scroll the image of the page inside the window.

Moving between pages in Page Mode

If your score takes up more than one page, you use the page number indicator in the lower right corner to move to another page in your score. The number can be adjusted using the standard editing techniques.

The page number indicator – adjust it to move to another page.

Also, if Auto-Scroll is activated on the toolbar, the score display follows the project cursor position. This way you can scroll the score by using fast forward or rewind.

Editing individual parts in Page Mode

When you view a single part in Page Mode, the bars before and after the part is normally shown as empty measures in the Score Editor. This is to preserve the layout of the track, i.e. the spacing between staves and bar lines, number of bars per staff, etc.

If you want to view and print a single part, without any surrounding empty bars, activate the “Unlock Layout when editing single parts” option in the Preferences dialog (Scores–Editing page). Note, however, that if you adjust the layout when editing the part in this mode, this erases the layout for the whole track!
Changing the zoom factor

There are two ways to change the zoom in Page Mode: by setting a zoom factor on the zoom pop-up menu or by using the Zoom tool (magnifying glass).

Using the Zoom pop-up menu

Above the vertical scrollbar to the right you can find a pop-up menu allowing you to set the zoom factor.

- If you select “Fit Page”, the zoom factor is adjusted according to the window size so that the whole page becomes visible.
- If you select “Fit Width”, the zoom factor is adjusted according to the window width so that the full width of the page becomes visible.

**NOTE**
This pop-up menu can also be opened by right-clicking in the ruler.

Using the Zoom tool

The Zoom tool in the Score Editor works much like in the Project window:

- Click once with the Zoom tool to zoom in one step.
- Hold down [Alt]/[Option] and click once with the Zoom tool to zoom out one step.
- Drag a rectangle with the Zoom tool to set a custom zoom factor. The section encompassed by the rectangle is zoomed to fill the window.
• Hold down a modifier key and right-click with the Zoom tool to open the Zoom context menu, and select the desired Zoom setting.

**Using the Mouse wheel**

You can also zoom by holding down [Ctrl]/[Command] and moving the mouse wheel. The mouse position is kept (if possible) when zooming in or out.

**The active staff**

One thing to note when you are working with multiple staves is the “active” staff. Only one staff at a time can be active, and it is indicated by a blue rectangle to the left of the clef symbol.

![active staff](image)

This staff is active.

**NOTE**

To make a staff active, click anywhere on it. By default, you can also use the up and down arrow keys on the computer keyboard to step between staves.

**Making page setup settings**

Before preparing the score for printout, you have to make some page settings for your project. This does not have to be the first thing you do, but it is a good working habit, because it also affects the on-screen display of the score.

**PROCEDURE**


   The Page Setup dialog appears. This is the regular operation system Page Setup dialog, described in detail in your system’s documentation. The only things that Cubase adds to this are the margin settings.

2. Select the preferred printer, paper size, orientation, etc.
The basics
Designing your work space

3. If you need to, change the margins by setting the left, right, top and bottom settings.
To make the settings permanent, save the project.
If you want new projects to always start with certain page setup settings, you can create project templates.

RELATED LINKS
Saving a Project Template File on page 71

Designing your work space

You can design your work space according to your needs by showing/hiding different areas using the Window Layout function and by showing/hiding different options of these areas using the Setup options dialogs. Which areas and options to show or hide depends on what kind of project you are working on, how large your monitor is, and so on.

Window layout

1) Status line
2) Info line
3) Extended toolbar
4) Filter bar
5) Symbols Inspector
Configuring the window layout

PROCEDURE

1. On the toolbar, click the “Set up Window Layout” button.

2. Activate the desired options.

The status line

The status line features the Mouse Time and the Mouse Note Position displays as well as the Current Chord Display, which helps you identify chords in the Score Editor note display. It can be hidden/displayed using the “Status Line” option in the “Set up Window Layout” pane.

The status line has its own Setup dialog where you can specify exactly which properties you want to see.

- Right-click on the status line and select “Setup…” from the context menu.
  In the dialog that appears you can configure where the separate items will be placed and save/recall different setup configurations.

The info line

The info line displays information about the selected note. It can be shown and hidden using the “Info Line” option in the “Set up Window Layout” pane.

The info line has its own setup dialog where you can specify exactly which properties are shown.

- Right-click on the info line and select “Setup…” from the context menu.
  In the dialog that appears you can configure where the separate items will be placed and save/recall different setup configurations.

The extended toolbar

The extended toolbar contains additional tools for your score. It can be hidden/displayed using the Tools option in the “Set up Window Layout” pane.
The filter bar

This area contains checkboxes determining which indicators, handles, and other non-printed elements are shown in the score. It can be hidden/displayed using the Filters option in the “Set up Window Layout” pane.

Showing and hiding elements

Some of the elements in the score are not printed, but rather serve as indicators for layout changes, handles, etc. These elements can be hidden or shown in any combination by using the Filters options.

The following options are available:

**Bar Handles**
Displays the bar handles, used for copying bars.

**Hidden Notes**
Displays any notes you might have hidden.

**Hide**
Displays markers in the score for each hidden element (except notes).

**Quantize**
Displays markers in the score where you have made Display Quantize "exceptions".

**Layout Tool**
Displays markers in the score where you have made adjustments with the Layout tool.

**Grouping**
Displays markers in the score where you have made beam groupings.

**Cutflag**
Displays markers in the score where you have inserted cutflag events.

**Split Rests**
Displays markers in the score wherever you have split multiple rests.

**Stems/Beams**
Displays markers in the score where you have made any stem or beam adjustments.

**Related links**
Moving and duplicating with the bar handles on page 1229
Hiding/showing objects on page 1283
Inserting Display Quantize changes on page 1122
Graphic moving of notes on page 1198
Grouping on page 1188
The basics
Designing your work space

The Cut Notes tool on page 1197
Splitting multi-rests on page 1286
Setting stem direction on page 1178
Manual adjustment of beams on page 1195

The Symbols Inspector

This area contains symbol tabs, which are used to add symbols to the score. It can be hidden/displayed using the Symbols option in the “Set up Window Layout” pane.

The symbol tabs can also be opened as free-floating palettes by opening them, right-clicking any of the buttons and selecting “Open as Palette” from the context menu. This way you can move symbol palettes around on the screen by clicking and dragging their title bars. Right-clicking on a symbol palette brings up a pop-up menu:

- Select “Toggle” to switch between a vertical or horizontal view of the palette.
- Select one of the options on the pop-up menu to bring up the corresponding palette instead of the current palette.
- Hold down [Ctrl]/[Command] and select a palette from the pop-up menu to open the selected palette in a new window (without closing the existing one).
- Click the close button to close a symbol palette.

In the Symbols Inspector setup dialog you can specify exactly which symbol tabs are shown.

RELATED LINKS
The Symbols Inspector Setup dialog on page 1208
Working with symbols on page 1206

The ruler

In the Score Editor there are no meter/time position rulers as in the other editors. Instead, there are horizontal and vertical “graphic rulers” in Page Mode. These help you to position symbols and graphical objects in the score.

- To specify which units to show on the rulers, open the Zoom pop-up menu and select one of the options.

You can choose between points, inches, and centimeters.
About the Score Editor context menus

Many functions and settings of the Score Editor can be accessed via context menus, opened by right-clicking on certain elements of the score. For example, if you choose a note, the note context menu opens, listing note-related functions.

If you open the context menu on an empty area of the score, it lists all available tools (allowing you to quickly switch between tools) and it contains many functions of the main menus.

About dialogs in the Score Editor

There are two types of dialogs available in the Score Editor:

- **Non-modal dialogs** can remain open while you continue working in the score. In a non-modal dialog, clicking the Apply button applies the settings in the dialog to the selected objects in the score. This means you can select different elements in the score and change their settings, without having to close the dialog in between.

  The dialog is closed by clicking the standard close button in the window title bar. The Score Settings dialog is an example for a non-modal dialog.

---

The Position Info window

To help you when positioning objects in the score, the Page Mode has a special Position Info window, in which you can view and adjust object positions numerically, in the unit selected for the ruler. To display the Position Info window, click in the ruler.

---

- To hide the rulers, select “Off” from the pop-up menu.
• Regular dialogs have an OK button instead of an Apply button. Clicking OK applies the settings you have made and closes the dialog. You cannot continue working in the score (or select other objects) until you close the dialog.

NOTE
If the “Apply closes Property Windows” option is activated in the Preferences dialog (Scores–Editing page), clicking the Apply button in a non-modal dialog closes the dialog. In other words, this makes a non-modal dialog work a bit more like a regular dialog.

Setting clef, key, and time signature

When preparing to enter notes into a score, you probably want to start out by setting the desired clef, key, and time signature for the staff. The text below assumes you are working on one track only. If you have multiple staves, you either make this setting independently for each staff or for all staves at once.

Normally, all these symbols appear at the beginning of each staff. However, you can control this by using the Real Book option and by hiding objects.

When entering or editing keys, there is one important thing to note:

IMPORTANT
In the Score Settings dialog on the Project–Notation Style subpage (Keys category) you can find the “Key Changes for the entire Project” option. When this option is activated, all changes made to the key always affect every staff in the project, i.e. it is not possible to define different keys for different staves.

RELATED LINKS
Staff settings on page 1152
Real Book on page 1281
Hiding/showing objects on page 1283

Using the Symbols Inspector to set the initial clef, key, and time signature

PROCEDURE
1. Click the “Set up Window Layout” button on the toolbar and activate the Symbols option.
   The Symbols Inspector is displayed.
2. Open the Clefs tab of the Inspector and click on the symbol for the clef that you want to use in your score.
3. Click anywhere in the first bar of the staff to set the clef for this track.
4. Select the Keys tab and click on the symbol for the key that you want to use.

5. Click anywhere in the first bar of the staff to set the key for the track.

6. Open the Time Signature tab of the Inspector and click on the symbol for the time signature value that you want to use. If you cannot find the desired time signature, you can use the Edit Time Signature dialog (see below).

**AFTER COMPLETING THIS TASK**

The settings you have made so far are valid for the entire track. If you want to further edit these settings, or if you need different settings for different bars of your track, proceed as described in the next section.

**Editing the time signature**

**PROCEDURE**

1. Double-click on the time signature symbol at the beginning of the staff. A dialog opens.

2. If the project is in 4/4 or 2/2, you can select common time/cut time directly by clicking one of the two symbols on the right. This sets the time signature to 4/4 or 2/2, respectively and also inserts a common/cut time symbol on the staff.

3. If the project is in any other time, set the numerator and denominator above and below the line, respectively. The numerator can consist of several numbers for composite time signatures. However, if the project is in a simple time signature you only need to fill in the first number above the line. The more advanced options are described below.
4. Click OK or press [Return].

**IMPORTANT**

All tracks share the time signature! In other words, when you set the time signature, you do this for all tracks in the project.

If you need to enter half a bar somewhere (for example) you have to make a time signature change (e.g. from 4/4 to 2/4 and back again).

**RELATED LINKS**

- By using the Pickup Bar feature on page 1288
- Inserting and editing clefs, keys, or time signatures on page 1148

### Composite time signatures and the For Grouping Only option

For composite signatures, the numerator can be made up of up to four groups. For example, “4+4+3+7” on the upper line and 8 on the lower means the time signature is 11/8.

The reason for dividing the numerator into several numbers is to get beaming and tied notes displayed correctly automatically. This does not affect the metronome or anything else, only beams and ties.

If “For Grouping Only” is not activated, the numerator shows all the numbers entered. If it is activated, it shows the sum of the numbers entered, as for “simple” time signatures.

![Image](1108)

“For Grouping Only” off and on

Note that Cubase tries to preserve the denominator when you insert a composite signature with “For Grouping Only” activated. This means that if you have a 4/4 time signature, and change it to a composite value (3+3+2 eighths for example), the time signature still is displayed as 4/4 instead of 8/8.

**RELATED LINKS**

- Handling beaming on page 1188

### Setting the time signature on the Transport panel

You can also set the time signature directly on the Transport panel. Please note that you cannot create composite time signatures from the Transport panel.
Setting the time signature using the signature track/Tempo Track Editor

You can also add, edit and delete time signatures using the signature track or the Tempo Track Editor.

Please note the following:

- The score always shows the time signature events set in the signature track/Tempo Track Editor, regardless of whether or not the Tempo button is activated. Likewise, any time signatures you create in the Score Editor are shown in the signature track/Tempo Track Editor.

- You cannot create composite time signatures using the signature track/Tempo Track Editor.

RELATED LINKS
Editing tempo and signature on page 904

Editing the clef

On the clef context menu

When you right-click on a clef symbol, a context menu with a list of all available clefs opens. This menu also contains the following options:

- Display Clef Changes as Small Symbols
  If you activate this option and insert a clef change in the score, the clef is displayed with a smaller symbol.

- Warnings for new Clefs at Line Breaks
  If you activate this option and insert a new clef at a line break, the Clef change symbol is inserted in the last bar before the staff break. When this is deactivated, the symbol is inserted in the first bar of the next staff line.

- Hide
  If you select this function, the clef is hidden.

- Properties
  If you select this function, the Edit Clef dialog opens.

In the Edit Clef dialog

PROCEDURE
1. Double-click on the current clef.
   A dialog appears.
Setting clef, key, and time signature

2. Use the scrollbar to select a clef.

**IMPORTANT**

This does not work if Auto Clef is activated on the Staff page of the Score Settings dialog, see below.

3. Repeat the steps above for all staves in the system.

**On the Staff page of the Score Settings dialog**

**PROCEDURE**

1. Click on a staff to make it the active staff.

2. On the Scores menu, select “Settings…” to open the Score Settings dialog. Select the Staff page at the top to open the Main tab, showing the current settings for the active staff.

You can also double-click to the left of a staff to make it active and bring up the Score Settings dialog in one go (if this does not work, the "Double-click on staff flips between full score/part" option in the Preferences dialog (Scores–Editing page) may be activated.

3. In the Clef/Key section, use the scrollbar on the left to select one of the available clefs.
4. Click Apply.

**NOTE**
You can select another staff in the score and make settings for it without having to close the Score Settings dialog first.

**RELATED LINKS**
- Displaying single voices or the complete score on page 1096
- Inserting and editing clefs, keys, or time signatures on page 1148

### In a split system

If you have a split system you can set different clefs for the upper and lower staff.

**PROCEDURE**
1. Open the Score Settings dialog on the Staff page.
2. Select a clef for the upper staff.
3. Activate the “Lower Staff” checkbox.
4. Set a clef for the lower staff.

**RELATED LINKS**
- Split (piano) staves on page 1146
- Strategies: How many voices do I need? on page 1168

### Using Auto Clef

On the Staff page of the Score Settings dialog you also find the Auto Clef option. If this is activated, the program automatically selects a treble clef or a bass clef for the staff, depending on the range of the notes in the part.

### Editing the key

**IMPORTANT**
In the Score Settings dialog on the Project–Notation Style subpage (Keys category), you can find the “Key Changes for the entire Project” option. When this is activated, all changes made to the key always affect every staff in the project, i.e. it is impossible to define different keys for different staves (other than the relative display transpose settings for instruments made on the Staff page). Furthermore, on the Staff page, any staff (e.g. a drum staff) can be set to not show key signatures.
Therefore, when you want to edit the key, decide if you want the key change to apply to the entire project, or if you want to use different keys on different staves:

- If the key set at the beginning of the track is to be used on all staves, and if any subsequent key changes are also valid for all staves, then leave the “Key Changes for the entire Project” option activated.
- If you want to use different keys on different staves, make sure that the “Key Changes for the entire Project” option is deactivated.

**On the key context menu**

When you right-click on a key symbol, a context menu with a list of all available keys opens. This menu also contains the following options:

- **Key Changes for the entire Project**
  
  If this option is activated, all changes made to the key always affects the entire project, so that it is not possible to define different keys for different staves.

- **Hide**
  
  If you select this, the key is hidden.

- **Properties**
  
  If you select this, the Edit Key dialog opens.

**In the Edit Key dialog**

If the current key is anything but C major/A minor (no accidentals), you can set the key directly in the score:

**PROCEDURE**

1. Double-click on the accidentals at the beginning of a staff.
   
   The “Edit Key” dialog opens.

   ![Double-click here…](image)

   Double-click here…

   …to open the Edit Key dialog.

2. Use the scrollbar to select a key and click OK.

**RELATED LINKS**

*Transposing instruments on page 1114*
The basics
Setting clef, key, and time signature

On the Staff page of the Score Settings dialog

**PROCEDURE**

1. Make the desired staff active, open the Score Settings dialog and select the Staff page.

![The Clef/Key section on the Staff page](image)

2. Use the right scrollbar in the Clef/Key section to select the desired key.

3. Click Apply.

**NOTE**

You can select other staves in the score and make settings for these, without having to close the Score Settings dialog.

Setting the key for a split system

If you have a split system with two staves you can set different keys for the upper and lower staff.

**PROCEDURE**

1. Click in the system to make one of its staves the active staff.

2. Open the Score Settings dialog on the Staff page.

3. Set a key for the upper staff.
   
   This automatically sets the lower staff to the same key.

4. If you need to set a different key for the lower staff, activate the “Lower Staff” checkbox and set a key for this.

**RELATED LINKS**

- Split (piano) staves on page 1146
- Strategies: How many voices do I need? on page 1168
Setting a local key

You can also set a different key for the selected staff only. This is useful for instruments like oboe and English horn that change display transpose and therefore also the key.

**PROCEDURE**

1. Make the desired staff active, open the Score Settings dialog and select the Staff page.
2. Activate the “Local Keys” option on the Main subpage in the Clef/Key section.

**NOTE**

This option is only available if “Key Changes for entire Project” is activated in the Score Settings dialog, on the Project–Notation Style subpage (Keys category).

3. Use the scrollbar to the right to set the desired key.
4. Click Apply to set the selected key for the staff.

Transposing instruments

Scores for some instruments, for example a lot of brass instruments, are written transposed. Therefore, the Score Editor provides a Display Transpose function. With this function notes are transposed in the score without affecting the way they are played back. This allows you to record and play back a multi-staff arrangement, and still score each instrument according to its own transposition.

**Setting Display Transpose**

**PROCEDURE**

1. Make the desired staff active, open the Score Settings dialog and select the Staff page.
2. In the Display Transpose section, select your instrument from the Transpose pop-up menu or adjust the value directly in the Semitones field.

**IMPORTANT**

Display Transpose does not affect MIDI playback!
Display Transpose in the Edit Key dialog

If you want to change the Display Transpose setting in the middle of the score, you can do this by inserting a key change. In the Edit Key dialog, which is opened by double-clicking a key symbol, you can find a Transpose field, in which you can enter a transposition value in semitones. This is useful if you are for example writing a saxophone part and want the player to switch from alto to tenor saxophone.

NOTE

Note that you enter an absolute Display Transpose value that is used from this point on. In other words, this setting is not relative to any Display Transpose settings you made on the Staff page of the Score Settings dialog.

RELATED LINKS

Inserting and editing clefs, keys, or time signatures on page 1148

Disabling Display Transpose

You can also disable Display Transpose by deactivating the “Display Transpose” button on the Score Editor toolbar. This can be useful if you work with transposing instruments and want to show the concert key and not the scored key.

Printing from the Score Editor

When you have made all necessary changes to the score display and are satisfied with the result, you can go ahead and print your score, e.g. to hand out note sheets.

PROCEDURE

1. On the Scores menu, activate “Page Mode”.
   Printing is only possible from within Page Mode.
2. Select Page Setup from the File menu and make sure all your printer settings are correct. Close the dialog.

   IMPORTANT

   If you change your setting for paper size, scale, and margins now, the score may change its look.

3. Select Print from the File menu.
4. A standard print dialog appears. Fill out the options as desired.
5. Click Print.
Exporting pages as image files

You can export a section of a page or a complete page in various file formats. This allows you to import your scores into desktop publishing and drawing applications.

Selecting a section of a page for exporting

If you only want to export a part of a certain page, proceed as follows:

**PROCEDURE**

1. Make sure that you are in Page Mode.
2. Select the Export tool (“Select Export Range”).
   The pointer turns into a cross-hair cursor.
3. Drag over the section of the score you want to include.
   The area is indicated by a black rectangle
   - You can adjust the size of the rectangle by clicking and dragging its handles with the Object Selection tool.
   - You can move the rectangle to another position in the score by clicking and dragging.

To export the selected range, you have two possibilities:
   - Double-click inside the rectangle while it is selected.
     This opens the Export Scores dialog, where you can make settings for the file to be created (see below).
   - Use the Export Scores function, see below.

Exporting

To export the score, proceed as follows:

**PROCEDURE**

1. Make sure that you are in Page Mode.
2. Select the page that you want to export.
3. Open the File menu, open the Export submenu and select “Export Scores…”.
   The Export Scores dialog appears.
4. Select a picture format.
5. Specify a resolution for the file.
   This determines the accuracy with which the image is created. 300 dpi, for example, is the resolution many laser printers use for printing. If the image file is only displayed on screen in other programs, select 72 or 96 (depending on screen resolution) and it has the same size as it had in Cubase.
6. Specify name and location for the file and click Save. The page of the score is exported and saved as a file. It can now be imported into any program supporting the selected file format.

# Working order

When you prepare a score, we suggest you do things in the following order, since this minimizes the time needed if you make a mistake somewhere and need to redo a step.

- Preferably work on copies of recorded tracks.
  If the parts are fairly complex you might have to change them permanently, after which they do not play back as they originally did.

- If memory is an issue, break the score up into segments.
  You might for example use the Split Loop function from the Functions submenu on the Edit menu to split the parts across all tracks.

- Arrange the tracks in the Project window in the order you want them displayed in the score.
  You cannot rearrange the order of systems in the Score Editor. However, you can go back and change the order in the Project window at any time.

- When opening the Score Editor, begin with the adjustments described above.
  You should always begin by setting page margins, etc.

- If you have recorded music into tracks already, try adjusting the graphic display of the score as much as possible without permanently editing the notes.
  Use the Score Settings, Display Quantize, Grouping, etc.

- If the tracks are empty, make basic staff settings, enter the notes and then make detailed adjustments, add Display Quantize, etc.

- If needed, use polyphonic voicing to resolve overlapping notes, create piano systems, handle crossing voices, etc.

- When all this is done, decide if you need to perform “destructive” editing.
  You might for example have to permanently alter the length or position of some of the recorded notes.

- Hide unwanted objects and add note-dependent and note-related symbols.
  This includes accents, dynamic symbols, crescendo, slurs, lyrics, “graphic rests”, etc.

- Work through the score and adjust the number of bars across the page.

- Adjust the vertical spacing between staves and grand staves.
The last two steps can be performed automatically by the program using the Auto Layout features.

- Add layout symbols like endings, page text, etc.
- Print or export the score.
- Go back and create alternative layouts, e.g. to extract voices.

**Force update**

If for some reason the screen is not redrawn properly (as a result of the computer’s recalculation of the appearance of the page), you can select “Force Update” from the Functions submenu on the Scores menu or click the Force Update button on the extended toolbar. This forces a redraw of the whole page.
About this chapter

In this chapter you will learn:

- How to prepare your parts for score printouts.
- How to use the Display Quantize tool to handle “exceptions” in the score.
- How to resolve parts that contain mixed notes and triplets.

About transcription

This chapter assumes you have a MIDI recording that you want to transform into a printable score. However, if the parts are fairly complicated, you probably need to perform some manual editing of the notes.

**IMPORTANT**

Before starting, make sure that you understand the basic principles behind the score notes/MIDI notes relationship and also what Display Quantize is.

**RELATED LINKS**

- Entering and editing notes on page 1127
- How the Score Editor works on page 1089

Getting the parts ready

**PROCEDURE**

1. Record the music.
   
   You must definitely play in time with the click.

2. Play back to check that the music was recorded as intended.
   
   If not, you might need to re-record or perform some editing.
3. Decide how much permanent alteration to the recording you can accept to make the score look good.
   If the answer is "none", you should prepare your score from a copy of the track. See the section below.

4. Select all parts (on all tracks) that you want to work on.

5. Open the Score Editor.

6. Activate Page Mode.

Preparing parts for score printout

Below follow a few tips to note when preparing a score for printout:

- If a part is complex, you may have to do some manual editing of notes, like moving them or changing their lengths. This means that the recording does not play back exactly as it originally did. If this is a problem, we suggest you work on a copy of the recording. Use the Duplicate Track function on the Project menu to create a version of the track for scoring. Rename the track and mute the original track while you are preparing the score. You can of course also work on a copy of the entire project file.

- For reasons described in the previous chapter, quantizing the track might be a good idea. This reduces the amount of detailed adjustments needed in the Score Editor.

- If you need to quantize, always play back your tracks afterwards to make sure timing was not disrupted due to inappropriate quantize settings. You might have to quantize some sections with one value and others with another.

- If the project contains many repetitions, it might be quicker to record just one instance of each to start with. If you then finish the score work on each section, you can assemble the entire project by working with parts in the Project window. This might save you some time since the detailed adjustments to each section have to be performed only once.

- A similar approach can also be used when you create sections where several instruments play the same rhythm, a horn section for example. Record the first instrument and make adjustments so that it looks like it should in the Score Editor. Then copy the part to the other tracks, and change the pitches of the notes using MIDI input. Finally, go through the copied parts and make fine adjustments, change display transpose settings, etc. This can be a very fast way to create polyphonic parts with complicated rhythms.

- There also may be situations when the quickest way to record a part for several instruments is simply to record it in one go, by playing the chords on your MIDI instrument. If you later want to split the recording into separate tracks or polyphonic voices, you can use the Explode function.

Related links
   - Entering and editing notes on page 1127
   - The Explode function on page 1124
Staff settings

The first thing to do after opening the Score Editor is to make initial staff settings. This is done in the Score Settings dialog, on the Staff page.

There are three ways to open the Score Settings dialog:

• Make the staff active, open the Scores menu and select “Settings…”.

• Double-click on the blue rectangle to the left of the staff.
  If this does not work, the “Double-click on staff flips between full score/part” option may be activated in the Preferences dialog (Scores–Editing page).

• Make the staff active and click the “i” button on the extended toolbar.
  For this to work, make sure no notes or symbols are selected – otherwise, clicking the “i” button may open a dialog with settings for the selected object instead.

Click the Staff button to open the Staff page of the Score Settings dialog. The Staff page shows the current settings for the staff on four tabs.

RELATED LINKS
  Displaying single voices or the complete score on page 1096
  Staff settings on page 1152

Situations which require additional techniques

The notes may not always appear in the score as you expect them to, initially. This is because there are a number of situations which require special techniques and settings.

Below you can find a list of some of these and where to find more information about handling them:

• Notes at the same position are considered to be part of a chord. To get independent voicing e.g. notes with different stem directions, such as for vocal material, you need to use the polyphonic voicing feature.

![Without and with polyphonic voicing](image)

• If two notes beginning at the same position have different lengths, the longer one is displayed as a number of tied notes. To avoid this, you can either use the No Overlap feature or polyphonic voicing.

• One note is often displayed as two notes with a tie. Please note that this is merely the way the program displays this note; only a single note is “stored”.

1121
Transcribing MIDI recordings

Inserting Display Quantize changes

This single note in the Key Editor is displayed as two tied notes in the Score Editor.

- Normally the program adds ties where necessary (if a note stretches over a beat), but not always. For a “modern” notation of syncopated notes (less ties) use the Syncopation feature.

![Notation examples](image)

The same note, without and with syncopation

- If you find that you want a long note to be displayed as two or more tied notes, you can achieve this with the Cut Notes tool.

- If two notes on the same position are too close to each other or if you want their order in the part reversed, you can do this without affecting playback.

- If a note has the wrong accidental, this can be changed.

- Stem direction and length are automatic, but you can change them manually if you wish.

- If you need a split staff (e.g. when you are scoring for piano), there are special techniques for this.

**RELATED LINKS**

- Polyphonic voicing on page 1320
- No Overlap on page 1158
- Syncopation on page 1157
- The Cut Notes tool on page 1197
- Graphic moving of notes on page 1198
- Accidental and enharmonic shift on page 1181
- Background: Note stems on page 1177
- Split (piano) staves on page 1146

### Inserting Display Quantize changes

Some situations may require different staff settings on different sections of the track. The staff settings are valid for the entire track, but you can insert changes wherever you like:

**PROCEDURE**

1. Select the Display Quantize tool on the toolbar or the context menu.
   
   The Display Quantize dialog opens.
Select the Display Quantize tool to open the Display Quantize dialog.

2. Activate the flags you need and set the quantize values as desired.

3. If you want to restore the settings to the ones used in the Score Settings dialog (Staff page), click the “Restore To Staff” button.

4. Move the mouse over the staff where you want to insert a new Display Quantize value.
   Use the Mouse Time Position display in the status line to find the exact location. The vertical position is of no relevance as long as you click somewhere in the staff.

5. Click the mouse button to insert a Display Quantize event.

RESULT

The new quantize settings are now inserted into the staff at the position where you clicked. The settings are valid until a new change is inserted. Display Quantize events is always inserted for all voices.

If you are using polyphonic voices, you can insert a Display Quantize event for all voices by pressing [Alt]/[Option] and clicking with the tool.

If the “Display Quantize Tool affects all Voices” option is activated in the Score Settings dialog on the Project page (Notation Style subpage, in the Miscellaneous category), Display Quantize events is always inserted for all voices.

RELATED LINKS

- Display Quantize and Interpretation Options on page 1155
- The status line on page 1102
- Polyphonic voicing on page 1320

Viewing and Editing Display Quantize Changes

If you activate the “Quantize” checkbox on the filter bar, a marker is shown under the staff for each Display Quantize setting you have entered with the tool.

This allows you to edit your settings in the following ways:

- To edit a Display Quantize change event, double-click on its marker.
  This opens the Display Quantize dialog again – adjust the settings and click Apply.
Transcribing MIDI recordings
The Explode function

- If the Display Quantize dialog is already open, you can select any Display Quantize change event, adjust its settings in the dialog and click Apply.
- To remove a Display Quantize change, either click its marker to select it and press [Backspace] or [Delete], or click on it with the Erase tool.

**RELATED LINKS**
Showing and hiding elements on page 1103

**Adding Display Quantize changes**

Very often, the score is fine except for a few bars somewhere. To remedy the problem, insert two Display Quantize changes with the tool (one at the beginning of the section, one after it to restore to the current staff settings).

If you have mixed triplets and straight notes, it can be tempting to insert many Display Quantize changes. Before you do so, try the Auto Quantize options and their additional settings.

**RELATED LINKS**
If your music contains mixed straight notes and triplets on page 1157

**The Explode function**

This function allows you to “split” the notes on a staff into separate tracks. It is also possible to use this function to convert a polyphonic staff into polyphonic voices.

**IMPORTANT**
Create a copy of the original track first, because it will be changed by the operation.

**PROCEDURE**

1. Open the Scores menu, open the Functions submenu and select “Explode”. The Explode dialog opens.

![Explode dialog](image)

2. Make sure that “To New tracks” is selected at the top of the dialog.
3. Enter the desired number of new tracks.

Note that this is the number of new tracks to be created! For example, if you have a three-part polyphonic section and want to split this into three separate tracks, you must specify 2 new tracks, since the original track holds one of the parts.
4. Use the options in the bottom section to set up the criteria for the split. Choose from the following options:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Split Note</td>
<td>Use this to move all notes below a certain pitch to another track. When this is selected, it is pointless to specify more than 1 new track.</td>
</tr>
<tr>
<td>Lines To tracks</td>
<td>Use this when you want all musical “lines” to be put on one track each. The notes with the highest pitch remains on the original track, the notes with the second highest pitch are put on the first new track, and so on.</td>
</tr>
<tr>
<td>Bass To Lowest Voice</td>
<td>When this is activated, the lowest notes always end up on the lowest track.</td>
</tr>
</tbody>
</table>

5. Click OK.

RESULT
A number of new tracks are now added to the score and the Project window.

RELATED LINKS
Automatically – the Explode function on page 1170

Using "Scores Notes To MIDI"

For very complicated scores, there may be situations where you have tweaked the parameters for Display Quantize and Interpretation as best you can, and you still cannot get the score exactly as you want it. Perhaps one setting works fine in one section of the track and another is needed for another section.

In such a case, “Scores Notes To MIDI” helps you out. It changes the lengths and position of some or all the MIDI notes in the edited parts so that they have exactly the values currently shown on screen.

PROCEDURE
1. For safety, go back to the Project window and make a copy of the track.
2. Open the part(s) again in the Score Editor.
   If you only want some sections of your score to be “converted”, make sure to only open those parts.
3. Make sure that the notes you want to affect are not hidden.
4. Select “Scores Notes To MIDI” from the Functions submenu on the Scores menu.
   The notes are now "converted".

5. Make whatever adjustments are needed to make the score read as intended.

RESULT

Now that the notes have the exact lengths and positions that were previously only displayed, you can probably deactivate many of the options on the Staff page of the Score Settings dialog and delete Display Quantize settings, etc.

If you find the operation did not give you the result you were after, you can undo your settings or go back to the original track, make a copy of that, and start over.

RELATED LINKS
   Hiding/showing objects on page 1283
Enter and editing notes

About this chapter

In this chapter you will learn:

• How to make various settings for how notes are displayed.
• How to enter notes.
• How to use tools and settings to make the score as legible as possible.
• How to set up a split (piano) staff.
• How to work with multiple staves.

Score settings

Before you start entering notes, you need to make some initial staff settings.

There are three ways to open the Score Settings dialog:

• Make the staff active, open the Scores menu and select “Settings…”.
• Double-click on the blue rectangle to the left of the staff.
  If this does not work, the “Double-click on staff flips between full score/part” option may be activated in the Preferences dialog (Scores–Editing page).
• Make the staff active and click the “i” button on the extended toolbar.
  For this to work, make sure no notes or symbols are selected – otherwise, clicking the “i” button may open a dialog with settings for the selected object instead.

The Score Settings dialog shows the current settings for the active staff.

RELATED LINKS

The basics on page 1095
How the Score Editor works on page 1089
Displaying single voices or the complete score on page 1096
Staff settings on page 1152

1127
Applying settings and selecting other staves

To make settings for another staff, simply make it active in the score (by clicking anywhere in the staff or by using the up/down arrow keys on the computer keyboard).

**NOTE**

Always click Apply before making another staff active – otherwise your settings are lost!

Staff presets

When you want to reuse settings made for one track in other tracks, you can save some time by creating a staff preset.

**NOTE**

There are a number of staff presets available, set up to suit various instruments, etc. These are accessed via the Presets pop-up menu on the Staff page of the Score Settings dialog, or from the Staff context menu, opened by right-clicking on the blue rectangle to the left of the staff. Use them as they are, or as starting points for your own settings.

**RELATED LINKS**

[Working with staff presets on page 1153](#)

Suggested initial settings

When you start out entering notes, your staff settings should make your score display the notes as entered. We suggest the following:

- **Display Quantize: Notes**
  
  64

- **Display Quantize: Rests**
  
  64

- **Auto Quantize**
  
  Activated

- **Syncopation**
  
  Off

- **Consolidate Rests**
  
  Off
Clean Lengths
   Off

No Overlap
   Off

Shuffle
   Off

Key
   As required

Clef
   As required

Auto Clef
   Activate this if you want the program to select a treble or bass clef automatically.

Display Transpose value
   0

Options tab settings
   As is

Polyphonic tab settings
   Staff Mode: Single

Tablature tab settings
   Tablature Mode deactivated

NOTE
It is very important that you understand how the Display Quantize values for notes and rests interact with the score. If you select too large a notes/rests value, the notes you “click in” may not appear as intended.

RELATED LINKS
   Split (piano) staves on page 1146
   How the Score Editor works on page 1089
   Display Quantize and Interpretation Options on page 1155

Note values and positions

Two of the most important settings for entering notes are the length of the note (the note value) and the minimum spacing between notes (the Quantize value).
Selecting a note value for input

You can choose the length for entering notes as follows:

- By clicking the note symbols on the extended toolbar.
  You can select any note value from 1/1 to 1/64 and activate/deactivate the
dotted and triplet options by clicking the two buttons to the right.

![Note Symbols](image)

The selected note value is displayed in the Length Quantize field on the toolbar and
also reflected by the cursor shape of the Insert Note tool.

- By selecting an option from the Length Quantize pop-up menu on the toolbar.

![Length Quantize](image)

- By assigning key commands to the different length values.
  This is done in the Key Commands dialog (in the category “Set Insert Length”).

About unusual note values

Not all note values can be selected directly, for example double dotted notes. Such
notes are created by changing the length of the note after you have entered it, by
gluing notes together or by using the Display Length feature.

RELATED LINKS

- Changing the length of notes on page 1143
- Lengthening a note by gluing two notes together on page 1144

Selecting a Quantize value

When you move the mouse pointer over the score the Mouse Time Position display
in the status line tracks your movement and shows the current position in bars,
beats, sixteenth notes, and ticks.

Positioning on screen is controlled by the current Quantize value. If you set this to
1/8, for example, you can only insert and move notes to eighth note positions, at
quarter notes, at half bars or at bar positions. It is a good strategy to set the
Quantize value to the smallest note value in the project. This does not stop you from
inputting notes at “coarser” positions. However, if you set the Quantize value to too
small a note value, it is easier to make mistakes.

With the Quantize value set to 1/8, you can only input notes at eighth note positions.
The Quantize value is set on the toolbar on the “Quantize Presets” pop-up menu:

- You can also assign key commands to the different Quantize values. This is done in the Key Commands dialog (in the category “MIDI Quantize”).
- Just like in the other MIDI editors, you can use the Quantize Panel to create other Quantize values, irregular grids, etc.
  However, this is not often used when inputting score notes.

The mouse position info

While you often use the graphical position in the actual score to determine where the notes go, there are instances when you want to verify the position numerically using the mouse position info displayed in the status line.

The Mouse Note Position display shows the pitch according to the vertical position of the pointer in a staff. The Mouse Time Position display shows the “musical position” in bars, beats, sixteenth notes, and ticks:

- The relation between beats and bars depends on the time signature: In 4/4 there are 4 beats to a bar. In 8/8 there are eight, in 6/8 there are six, etc.
- The third number is the sixteenth note within the beat. Again, the time signature determines the number of sixteenth notes to each beat. In a quarter note based time signature (4/4, 2/4, etc.) there are four sixteenth notes to each beat, in an eighth note based time signature (3/8, 4/8, etc.), there are two sixteenth notes, etc.
- The last value is in ticks, with 480 ticks per quarter note (and thus 120 ticks per sixteenth note).

The figures below show some note positions and their corresponding position values:

### Eighth note positions

<table>
<thead>
<tr>
<th>Time Signature</th>
<th>2/2</th>
<th>4/4</th>
<th>8/8</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>1.1.1.0</td>
<td>1.1.3.0</td>
<td>1.1.1.0</td>
</tr>
<tr>
<td></td>
<td>1.1.5.0</td>
<td>1.2.1.0</td>
<td>1.2.1.0</td>
</tr>
<tr>
<td></td>
<td>1.1.7.0</td>
<td>1.2.3.0</td>
<td>1.2.3.0</td>
</tr>
<tr>
<td></td>
<td>1.2.5.0</td>
<td>1.3.1.0</td>
<td>1.4.1.0</td>
</tr>
<tr>
<td></td>
<td>1.2.7.0</td>
<td></td>
<td>1.4.3.0</td>
</tr>
</tbody>
</table>

### Eighth note triplet positions

<table>
<thead>
<tr>
<th>Time Signature</th>
<th>2/2</th>
<th>4/4</th>
<th>8/8</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>1.1.1.0</td>
<td>1.1.3.0</td>
<td>1.1.1.0</td>
</tr>
<tr>
<td></td>
<td>1.1.3.0</td>
<td>1.2.1.0</td>
<td>1.2.1.0</td>
</tr>
<tr>
<td></td>
<td>1.1.7.0</td>
<td>1.2.3.0</td>
<td>1.2.3.0</td>
</tr>
<tr>
<td></td>
<td>1.5.1.0</td>
<td>1.6.1.0</td>
<td>1.7.1.0</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>1.8.1.0</td>
</tr>
</tbody>
</table>
Entering and editing notes

Adding and editing notes

Entering notes using the computer keyboard

A quick and easy way to enter notes, without having to decide on the pitch, position and note value first is using the computer keyboard. To enter a note, proceed as follows:

**PROCEDURE**

1. On the toolbar, activate the “Computer Keyboard Input” button.
   Now you can enter notes using the computer keyboard.

2. Hold down \[Alt]/[Option].
   A note with the note value specified in the extended toolbar appears. By default, the insert position is the first position of the bar and the pitch is C3. You can however change this using the computer keyboard.
   - You can change the pitch of the note by using the up and down arrow keys.
     To transpose the note in octave steps, use the Page Up/Page Down keys.
   - To change the insert position of the note, use the right and left arrow keys.
     Note that for position changes, the Quantize value is taken into account.
   - To change the length of the note, hold down [Shift] and use the right and left arrow keys.
     This changes the note value step by step, passing from one Quantize value to the next.

3. To insert the note, press \[Return\].
   The note with the specified pitch and note value is inserted at the selected position and the insert position for the next note changes according to the Quantize value. If you press [Shift]-[Return], the insert position does not change, allowing you to enter chords.
Entering notes with the mouse

To add a note to the score, proceed as follows:

**PROCEDURE**

1. **Make the staff active.**
   Notes are always inserted on the active staff.

2. **Select the desired note value.**

3. **If you select the note value by clicking on a symbol on the extended toolbar, the Insert Note tool is automatically selected** – otherwise select the Insert Note tool on the toolbar or context menu.

4. **Select a Quantize value.**
   The Quantize value determines the spacing between notes. If you set Quantize to 1/1 you only can add notes at downbeats. If you set Quantize to 1/8, you can add notes at eighth note positions, etc.

5. **Click in the staff and keep the mouse button pressed.**
   The Insert Note tool changes into a note symbol (showing the note exactly as it would be inserted in the score).

6. **Move the mouse horizontally to find the correct position.**

7. **Move the mouse vertically to find the correct pitch.**

   ![Accidental](image)
   Accidentals are shown beside the note to indicate the current pitch.

   **NOTE**

   If the "Show Note Info by the Mouse" option is activated in the Preferences dialog (Scores–Editing page), the position and pitch of the note is also shown in a “tooltip” next to the pointer while you are dragging. If you find that screen redraws are too sluggish, you may want to deactivate this option.

8. **Release the mouse button.**
   The note appears in the score.

   **IMPORTANT**

   If you activate the “Animate Note Cursor” option in the Preferences dialog (Scores–Editing page), you do not need to keep the mouse button pressed to see the note as it would be inserted in the score.

**RELATED LINKS**

- The active staff on page 1100
- Selecting a note value for input on page 1130
Adding more notes

**PROCEDURE**

1. If you want the next note to have a different length value, select the corresponding note symbol.
2. If you need finer positioning, or if the current value is too fine, change the Quantize value.
3. Move the mouse to the desired position, and click.
   Notes input at the same position are automatically interpreted as chords, see below.

**About the interpretation**

The notes may not always appear in the score as you initially expect them to. This is because there are a number of situations that require special techniques and settings. Below you can find a list of some of these and where to find more information about handling them:

- Notes at the same position are considered parts of a chord. To get independent voicing (for example notes with different stem directions), such as for vocal material, you need to use polyphonic voicing.
  
  ![Without and with polyphonic voicing](image)

- If two notes beginning at the same position have different lengths, the longer is displayed as a number of tied notes. To avoid this, you can either use the “No Overlap” feature or polyphonic voicing.

- One note is often displayed as two notes with a tie. This is only how the program displays the note, there is still only a single note “stored”.
  
  ![This single note in the Key Editor is displayed as two tied notes in the Score Editor](image)

- Generally the program adds ties where necessary (if a note stretches over a beat), but not always. For more “modern” notation of syncopated notes (less ties), you need to use the syncopation feature.

  ![The same note, without and with Syncopation](image)

- If you want a long note to be displayed as two (or more) tied notes, you can use the Cut Notes tool for this.

- If a note has the wrong accidental, this can be changed.
Selecting notes

In the operations described in the rest of this chapter, you often work on selected notes. The text below describes how to select notes:

By clicking

To select a note, click on the note head with the Object Selection tool. The note head gets colored to indicate that it is selected.

- To select more notes, hold down [Shift] and click on them.
- To deselect notes, hold down [Shift] and click on them again.
- If you hold down [Shift] and double-click on a note, this note and all the following notes in the same staff are selected.

Using a selection rectangle

**PROCEDURE**

1. Click in an empty area in the score with the Object Selection tool and keep the mouse button pressed.
2. Drag the mouse pointer to create a selection rectangle.
Entering and editing notes

Selecting notes

You can drag to select notes on several voices or staves if you wish.

3. Release the mouse button.

All notes with note heads inside the rectangle are selected.

If you want to deselect one or more of the notes, hold down [Shift] and click on them.

Using the keyboard

By default, you can step through (and select) the notes in the staff using the left and right arrow keys. If you press [Shift], you can select a series of notes as you step through them.

- If you are working with polyphonic voices, you step through the notes on the current track, i.e. in a split system, you step through the staves.
- If you want to use other keys for selecting notes, you can customize the settings in the Key Commands dialog (in the Navigate category).

Selecting tied notes

Longer notes are often displayed in the score as one note with a tie. If you intend to select the entire note (e.g. for deleting), you should select the first note, not the tied note.

**IMPORTANT**

There is a setting for this in the Preferences dialog (Scores–Editing page): If you activate “Tied Notes selected as Single Units”, the whole note is selected, even if you click on one of the tied notes.

Deselecting everything

To deselect everything, simply click in an empty area of the score with the Object Selection tool.
Moving notes

In the following, you can find descriptions of the various methods to move notes, as well as related features.

Moving by dragging

**PROCEDURE**

1. Set the Quantize value.
   The Quantize value restricts your movement in time. You cannot place notes on positions smaller than the Quantize value.

2. Select the note(s) you want to move.
   You can select notes across several staves if you wish.

3. Click one of the selected notes and drag it to a new position.
   The horizontal movement of the note is “magnetically attracted” to the current Quantize value. The Mouse Time Position and Mouse Note Position displays in the status line show the new position and pitch for the dragged note.

**NOTE**

If the “Show Note Info by the Mouse” option is activated in the Preferences dialog (Scores–Editing page), the position and pitch of the note is also shown in a “tooltip” next to the pointer while you are dragging. If you find that screen redraws are too sluggish, you may want to deactivate this option.

4. Release the mouse button.
   The notes appear at their new position.
   • If you press [Ctrl]/[Command] and drag, movement is restricted to vertical or horizontal (depending on the direction in which you drag).
   • If you move notes vertically and the “Keep moved Notes within Key” option is activated in the Preferences dialog (Scores–Editing page), the notes are transposed within the current key only.

**RELATED LINKS**

*Selecting a Quantize value on page 1130*

Moving by using key commands

Instead of dragging the note with the mouse, you can assign key commands for this:

• The corresponding commands can be found in the Nudge category in the Key Commands dialog.

• When moving notes to the left or right using key commands, the notes are moved in steps according to the Quantize value. The keys assigned for up/down nudging transpose notes in semitone steps.
Moving across staves – the Lock button

If you are editing several tracks, you may want to move notes from one staff to another.

PROCEDURE

1. Make the desired Quantize settings and select the notes. Make sure to only select notes on the same staff.

2. Make sure that the “L” (Lock) button on the extended toolbar is deactivated. When this button is activated, you cannot move notes and other objects from one staff to another, which is handy if you need to transpose a note very high or low, for example.

   ![The "L" Lock button is deactivated.](image)

3. Click on one of the notes and drag them to the new system. The active staff rectangle indicates on which staff the dragged note(s) appears.

The Snap mode

The notes you move (or copy) snap to positions defined by the note length and Quantize values. Using the Snap Type pop-up menu on the Score Editor toolbar you can select the Snap mode used when moving or copying notes:

- When using the “Grid” mode, notes you move (or copy) always snap to exact grid positions.
- When using the “Grid Relative” mode, a note with a certain position relative to a grid line always maintains that relative position to the grid when moved (or copied).

Acoustic Feedback

To hear the pitch of the note while moving, activate the speaker icon (Acoustic Feedback) on the toolbar.
About the lock layers

When you are moving and editing notes in the score, you might accidentally move other objects nearby. To avoid this, assign different types of objects to different “lock layers” (up to three) and instruct Cubase to “lock” one or two of these layers, making them unmovable.

There are two ways to set up which type of object should belong to which lock layer:

- Open the Preferences dialog from the File menu and select the Scores–Note Layer page. This page lets you adjust the layer setting for each object type.

- Right-click one of the layer buttons, (1-2-3), on the extended toolbar to bring up a pop-up menu, showing which object types are associated with that layer. A checkmark for an object type means it belongs to that layer. If no checkmark is shown, you can select the object type on the menu to move it to that layer.

To lock a layer, click the corresponding layer button, so that it is disabled not highlighted. You can only select or move objects whose Layer button is activated.

**NOTE**

There are also “L” and “P” layer buttons, for the layout and project layer. Clicking these buttons allows you to lock the layout and project layers.

**RELATED LINKS**

- Using the lock layers on page 1225
- Background: The different layers on page 1206

Displaying layers

To see which score objects you assigned to which layer, you can activate and deactivate the Layer buttons on the extended toolbar.

To display all the score objects that you assigned to the different note layers, activate layers 1, 2, or 3.
• To display all the score objects that are associated with the layout layer, activate the Layout Layer (L) button.
• To display all the score objects that are associated with the project layer, activate the Project Layer (P) button.
• To get an overview of all layers, activate the Colorize Layer (A) button. This deactivates all other layer buttons and displays the score objects in different colors, where each color stands for a specific type of layer.

Duplicating notes

To duplicate notes in the score, proceed as follows:

PROCEDURE

1. Set the Quantize value and select the desired notes.
   You can duplicate any block of notes, even on several systems at the same time. The Snap mode applies.
2. Press [Alt]/[Option] and drag the duplicate notes to their new position.
   • If you want to restrict movements to one direction, press [Ctrl]/[Command].
     This works just as for moving, as described above.
   • If you want to restrict the pitch to inside the current key only, make sure that the “Keep moved Notes within Key” option is activated in the Preferences dialog (Scores–Editing page).
3. Release the mouse button to insert the notes.
   [Alt]/[Option] is the default modifier key for copying/duplicating. If you like, you can change this in the Preferences dialog (Editing–Tool Modifiers page).
   The entry for this is found in the Drag & Drop category (“Copy”).

   NOTE
   You can also move or copy whole bars by dragging the bar handles.

RELATED LINKS
The Snap mode on page 1138
Moving and duplicating with the bar handles on page 1229

Cut, copy, and paste

• To cut notes, select them and choose Cut from the Edit menu (or use a key command, by default [Ctrl]/[Command]-[X]).
  The notes are now removed from the score and put on the clipboard.
• To copy notes, select them and choose Copy from the Edit menu (or use a key command, by default [Ctrl]/[Command]-[C]).
A copy of the notes is made, and put on the clipboard. The original notes remain where they were.

**IMPORTANT**

The clipboard can only hold one set of notes. If you cut or copy and then cut or copy again, the notes copied to the clipboard first are lost.

### Inserting notes from the clipboard to the score

Notes that you have put on the clipboard by cutting or copying can be inserted into the score again as follows:

**PROCEDURE**

1. Activate the desired staff.
2. Move the project cursor to the position where you want the first note to appear.
   This is done by holding down [Alt]/[Option] and [Shift] and clicking at the desired position in the score.
3. Select Paste from the Edit menu (or use a key command, by default [Ctrl]/[Command]-[V]).
   The notes are pasted in, beginning at the project cursor. If the cut or copied notes come from different staves, they are also inserted on different staves. Otherwise, the notes are inserted on the active staff. They keep the pitch and relative positions they had when you cut or copied them.

### Editing pitches of individual notes

**By dragging**

The simplest way to edit the pitch of a note is to drag it up or down. Remember to hold down [Ctrl]/[Command] to avoid moving the note sideways as well.

- If the “Keep moved Notes within Key” option is activated in the Preferences dialog (Scores–Editing page), notes are transposed within the current key only.
- To avoid accidentally moving the note into another staff, activate the Lock button.
- When you drag the mouse up and down before releasing the button, accidentals are shown beside the note to indicate the current pitch. This helps you verify the vertical position for the note.

**RELATED LINKS**

[Moving across staves – the Lock button on page 1138](#)
Using the Transpose Palette

The Transpose Palette on the toolbar contains buttons for transposing the selected notes up or down in steps of one semitone or one octave.

- To show the Transpose Palette, right-click the toolbar and activate "Transpose Palette" on the context menu.

Using key commands

Instead of transposing the note with the mouse, you can assign key commands for this.

- The commands for which you can assign key commands are found in the Nudge category in the Key Commands dialog. Transpose commands are, for example, “Up” (transpose one semitone up) and “Down” (transpose one semitone down).

Using the info line

You can use the info line to change the pitches (and other properties) of one or several notes numerically.

- If you have several notes selected and change the pitch on the info line, the changes are relative. That is, all selected notes are transposed by an equal amount.

- If you have several notes selected, hold down [Ctrl]/[Command] and change the pitch on the info line, the changes are absolute. That is, all selected notes are set to the same pitch.

**RELATED LINKS**
- Info Line on page 47

Via MIDI

**PROCEDURE**

1. On the toolbar, activate the MIDI Input button and the Record Pitch button to the right.

   If you also want to change the note-on and/or note-off velocity of the notes via MIDI, this can be done by also activating the corresponding velocity buttons.

   To edit notes via MIDI (pitches only), set up the buttons like this.

2. Select the first note that you want to edit.
3. **Press a key on your MIDI keyboard.**
   The note takes on the pitch of the key you pressed. The program then selects the next note.

4. **To change the pitch of the next selected note, simply press the desired key.**
   In this manner you can change the pitches of as many notes as you wish, by simply pressing the relevant keys. You can also use key commands (by default the left and right arrow key) to pass from one note to the other. For example, if you make a mistake, you can step back to the previous note by pressing the left arrow key.

**RELATED LINKS**

MIDI Editors on page 686

---

**Changing the length of notes**

When it comes to note lengths, the Score Editor is special in that it does not necessarily display the notes with their actual length. Depending on the situation, you may want to change the “physical length” of the notes or the “display length”.

**Changing the “physical” length**

This changes the actual length of the notes. The change is audible when you play back the music.

**IMPORTANT**

Remember that the appearance of notes and rests in the score is determined by the Display Quantize settings on the Staff page of the Score Settings dialog. Depending on the Notes and Rests values, notes may be displayed as if they were longer than they really are.

**RELATED LINKS**

Display Quantize on page 1090

---

**By using the extended toolbar**

Using the extended toolbar is another quick way to set a number of notes to the same length:

**PROCEDURE**

1. Select the notes that you want to change.

2. Hold down [Ctrl]/[Command] and click on one of the note icons on the extended toolbar.
   All the selected notes now get the note value on which you clicked.
By using the info line

You can also edit length values numerically on the info line. The same rules apply as when changing the pitch of notes.

RELATED LINKS
Using the info line on page 1142

Lengthening a note by gluing two notes together

You can create unusual note length values by gluing notes of the same pitch together.

PROCEDURE
1. Insert the notes that you want to glue together (if they do not already exist).
2. Select the Glue tool on the toolbar or context menu.
3. Click on the first note.
   This note is now tied to the first following note with the same pitch.
   IMPORTANT
   Make sure that you have Display Quantize values for notes and rests that allow you to display notes of the created note value.
4. If you want to glue more notes, click again.
   By gluing together a quarter note, an eighth note and a sixteenth note…

…you get a double dotted quarter note.

Changing the display length

If you want to change the displayed length of notes without affecting how they play back, the first thing to try is to adjust Display Quantize, either for the whole staff or for a separate section, using the Display Quantize tool.

But you can also make display length adjustments to individual notes in the Set Note Info dialog:

PROCEDURE
1. Double-click on the note.
   The Set Note Info dialog opens.
2. Locate the “Length” setting.
   By default, this is set to “Auto”, which means that the note is displayed according to its actual length (and the Display Quantize settings).

3. Double-click in the value field and enter a new length value (displayed in bars, beats, sixteenth notes, and ticks).
   To set the display length to “Auto” again, scroll the value down to zero.

4. Click Apply and close the dialog.
   The note is now displayed according to its display length setting. However, the Display Quantize settings still apply!

RELATED LINKS
Inserting Display Quantize changes on page 1122

Splitting a note in two

If you have two notes strung together by a tie, and click on the “tied” note head with the Split tool, the note is divided into two, with the length of the “main” and the tied note, respectively.

Before and after splitting a tied note

Working with the Display Quantize tool

There are instances when you want different staff settings for different sections of the track. The settings on the Staff page of the Score Settings dialog are valid for the entire track, but by using the Display Quantize tool you are able to insert changes and exceptions wherever you like.

RELATED LINKS
Inserting Display Quantize changes on page 1122
Split (piano) staves

Setting up the split staff

**Procedure**

1. Make a staff active.
2. Open the Score Settings dialog on the Staff page and select the Polyphonic tab.
3. From the Staff Mode pop-up menu, select Split.
4. Set the Split Point value to a suitable note.
   All notes below this note value are put on the lower clef, all above are put on the upper clef.
   Split mode selected.
   If the default piano clef settings for the upper and lower staff are not what you want, you can adjust these settings now (or you can make key and clef adjustments directly in the score).
5. Make whatever additional staff settings you need.
   These apply to both the upper and lower staves of the split system.
6. Click Apply.

![Before and after setting a split at C3](image)

**Related Links**

Setting clef, key, and time signature on page 1106

Changing the split point

**Procedure**

1. Make sure that the system you are working on is active.
2. Open the Score Settings and select the Staff page.
3. Select the Polyphonic tab.
4. Change the Split Point value.
5. Click Apply.

RESULT
Now, some notes that were previously on the lower staff are on the upper, or vice versa.

Strategies: Multiple staves

As described above, when you have parts on several tracks selected in the Project window, these are put on one staff each, when you open the Score Editor. This allows you to work on several staves in parallel.

Working with several staves is not much different from working with one. Below follow some guidelines that apply specifically to working with multiple staves.

Score settings dialog, Staff page

The settings on the Staff page of the Score Settings dialog are local to each staff. You can have the Score Settings dialog open and select each staff in turn to make settings – just remember to click Apply before selecting another staff, otherwise your changes are lost.

If several staves share settings, you can save some time by using staff presets. Set up the staff settings for the first staff, and save them as a preset. This preset can then be applied to any of the other staves, one at a time.

RELATED LINKS
  Working with staff presets on page 1153

Selecting notes

You can select notes from one or several staves at the same time, using any of the selection methods.

RELATED LINKS
  Selecting notes on page 1135
Adding notes

This is done just as on a single system. Please note the following:

- When you enter a note, use the Mouse Note Position display (in the status line) to determine the pitch. Whether it ends up on the upper or lower staff has nothing to do with where you aim with the mouse. The Split Point setting always decides if a note goes on the upper or lower staff. If you change the split point, this affects existing notes, see below.

- Sometimes a fixed split point is not good enough. You might want to put two notes with the same pitch on different staves in different parts of the score. To achieve this you need to use polyphonic voicing.

- You can add notes to any staff by clicking on it with the Insert Note tool. The active staff rectangle moves to the staff where you input the note.

- If you need to enter a note with a very high or low pitch, which makes it wind up on the wrong staff when you click, first enter a note with the wrong pitch, and then edit its pitch.

RELATED LINKS

Adding and editing notes on page 1132
Polyphonic voicing on page 1163
Editing pitches of individual notes on page 1141

Inserting and editing clefs, keys, or time signatures

It is possible to insert a change of clef, key, or time signature anywhere in the score.

Inserting a symbol on one staff

PROCEDURE

1. In the Symbols Inspector, open the “Clefs etc.” tab.
   This contains clef, key, and time signature symbols.

2. Select the symbol that you want to insert.
   When you move the mouse over the score display, the pointer takes on the form of a pencil.

3. Move the mouse over the staff where you want to insert a new symbol.
   Use the Mouse Time Position display in the status line to find the exact location. The Mouse Note Position, i.e. the vertical position is of no relevance as long as you click somewhere in the staff. Time signature changes can only be inserted at the beginning of a bar.
4. Click the mouse button to insert the symbol.

**IMPORTANT**

Inserting a symbol at position 1.1.0 is the same as changing the staff settings which are stored in the track. Inserting anywhere else adds the change to the part.

**RELATED LINKS**

*About the Draw tool on page 1212*

**Inserting a symbol on all staves**

If you hold down [Alt]/[Option] when you insert a symbol with the Draw tool, it is inserted at this position on all staves currently being edited in the Score Editor.

- Time signature changes are always inserted on all tracks in the score.  
  Or rather, they are inserted on the signature track, which affects all tracks.

- For key changes, Display Transpose is taken into account.  
  This allows you to set all staves to a new key and the staves set to Display Transpose still show the correct key after the key change.

**NOTE**

If some of the staves are bracketed (straight brackets only, as set up in the Score Settings dialog on the Layout page), inserting a symbol for one of these staves inserts it for all other staves within the bracket. Staves outside the bracket are not affected.

**RELATED LINKS**

*Adding brackets and braces on page 1296*

**Editing clefs, keys, and time signatures**

If you double-click on a symbol, a dialog appears allowing you to change the settings for it.

If you hold down [Alt]/[Option] when double-clicking, all symbols at the same position are changed accordingly. With key signatures, the Display Transpose value is taken into account as described above.

- In the Score Settings dialog on the Project page (Notation Style subpage), you can find several options for how clef, key, and time signature changes are displayed.
  You can also adjust the automatic spacing between these symbols in the Spacings subpage. See the dialog help for details.
Moving clefs

Clefs inserted into the score have an effect on how notes are displayed. If you for example insert a bass clef in the middle of a treble staff, the staff switches to show bass pitches. Therefore it is very important where you insert the clef.

If you want to move the clef graphically, without disturbing the relation between the clef and the notes, proceed as follows:

PROCEDURE
1. Select the Layout tool on the toolbar or context menu.
   Note that this tool is available in Page Mode only.

2. Click on the clef and drag it to the desired position.
   Note that this tool is available in Page Mode only.

NOTE
When you insert a clef change in the score, you can decide whether this has the same size as the first (default) clef symbol or whether it is displayed with a smaller symbol. Simply right-click the symbol and activate or deactivate “Display Clef Changes as Small Symbols”.

NOTE
When “Warnings for new Clefs at Line Breaks” is activated on the Clef context menu and you inserted a clef change at a line break in the score, the Clef change symbol is inserted in the last bar before the staff break. When this is deactivated, the symbol is inserted in the first bar of the next staff line.

Deleting notes

Using the Erase tool

PROCEDURE
1. Select the Erase tool on the toolbar or context menu.
2. One at a time, click on the note(s) you want to erase, or enclose them in a selection rectangle, and click on any of the notes.
Using the Delete menu option or the keyboard

**PROCEDURE**

1. Select the notes that you want to delete.
2. Select Delete from the Edit menu, or press [Delete] or [Backspace] on the computer keyboard.
About this chapter

In this chapter you will learn:

- How to make staff settings.
- How to work with staff presets.

Staff settings

Below follows a run-through of all staff settings, more detailed information about the ones already described and references to other places in the manual for some options.

The Staff page has four tabs – here, the Main tab is selected.
Making settings

**PROCEDURE**

1. Open the Score Settings and select the Staff page.
2. With the dialog open, make the desired staff active.
   
   Click anywhere in a staff to make it active, or use the up and down arrow keys to step from staff to staff.
3. Select the desired tab and make all necessary settings.
   
   The settings for regular staves are found on the Main and Options tab, the Polyphonic tab contains settings for split systems and polyphonic voices while the Tablature tab lets you set up tablature scores.
4. When you have made the desired settings, click Apply.

**NOTE**

If the “Apply closes Property Windows” option is activated in the Preferences dialog (Scores–Editing page), clicking Apply also closes the dialog.

To make settings for another staff, simply make it active in the score (by clicking anywhere in the staff or by using the up/down arrow keys on the computer keyboard).

However, please note that you need to click Apply before making another staff active – otherwise your settings are lost!

**IMPORTANT**

Staff settings can be saved in the track presets.

**RELATED LINKS**

Track Presets on page 160

---

**Working with staff presets**

Making staff settings for your scores can be time-consuming. Staff presets allow you to reuse those settings whenever you work with a staff similar to one you have worked on before. A staff preset contains all the settings from the Staff page of the Score Settings dialog, except for the key.

- To save the current settings (including the settings on the Options tab, see below) click the Store button in the Presets section of the Staff page.

  Enter a name for the preset in the name dialog that appears, and click OK. The preset is now available on the Presets pop-up menu (in all projects).
There are a number of staff presets available, set up to suit various instruments, etc. The presets are accessed from the Presets pop-up menu on the Staff page of the Score Settings dialog or from the staff context menu, opened by right-clicking on the blue rectangle to the left of a staff.

Use them as they are, or as starting points for your own settings. Note that this loads the settings in the preset into the dialog – to apply these to a staff you must click the Apply button as usual. You can also apply staff presets directly in the score – see below.

To remove a preset, select it from the pop-up menu and click the Remove button.

Applying a preset directly in the score

If you right-click on the blue rectangle to the left of a staff, a context menu appears, listing all available presets. Select one to apply it to the staff.

How staff presets are stored

The staff presets are stored as individual files in the Presets–Staff Presets folder within the Cubase program folder. The presets are available for selection in any project you create or edit.

Staff names

These fields allow you to specify a “long” and a “short” name for the staff. The long name is shown for the very first system for this staff in the score (at the start of the project), while the short name is shown for the remaining systems.

Whether the names are shown at all is set in the Score Settings dialog on the Layout page.

If you only want the “long name” to be shown (i.e. if you do not want a name shown for each system in the score), simply delete the short name.

If the “Show Long Staff Names on new Pages” option is activated in the “Staff Names” section of the Score Settings dialog (Project page), the long name is shown at the beginning of each new page.

You can also specify two separate subnames by double-clicking the staff name and entering them in the upper and lower text entry fields in the dialog that appears.
Note that this is only displayed correctly, if you are in Page Mode and if “Show Staff Names to Left of Staff” is activated in the Score Settings dialog, on the Project–Notation Style subpage (Staff Names category).

**Related Links**
- Staff names on page 1265

### Key and clef

The basic key and clef settings are described in detail in another section (see below). There is also a Lower Staff checkbox which is only used in conjunction with split (piano) staves and polyphonic voicing.

- If you want to set a different key symbol, e.g. when scoring for French horn, activate the “Local Keys” option.

**Related Links**
- Setting clef, key, and time signature on page 1106
- In a split system on page 1111

### Display Quantize and Interpretation Options

These two sections of the dialog contain a number of settings used to determine how the notes are interpreted. While these settings are more critical to making MIDI recorded music appear as legible as possible it is still important to have them set correctly when entering notes using the mouse. Below you can find descriptions of the settings.

There are “fixed” Display Quantize values plus an “Auto” option which should only be used when your music contains mixed straight notes and triplets.

**Related Links**
- Adding Display Quantize changes on page 1124
- Display Quantize on page 1090
Display Quantize values

Notes and Rests

- Generally, the Notes value should be set to a value equal to, or smaller than, the “smallest note position” that you want to be shown in the score.

- The Rests value should be set to a value equal to, or smaller than, the smallest note value (length) you want to be displayed for a single note, positioned on a beat.

- If the score contains only triplets, or mostly triplets, select one of the Triplet options.

Auto Quantize

- If the project contains no triplets or only triplets, deactivate this option.

- If the project contains mixed triplets and straight notes, activate this option (see below).

Deviation and Adapt

- When Deviation is activated, triplets/straight notes are detected even if they are not exactly “on the beat”. However, if you know your triplets/straight notes are perfectly recorded (quantized or entered by hand), deactivate this option.

- When Adapt is activated, the program “guesses” that when one triplet is found, there are probably more triplets surrounding it. Activate this option if not all of your triplets are detected.

If your music only contains “straight” notes or triplets

PROCEDURE

1. Specify a Notes value.
   For example, if you have notes on odd sixteenth note positions, the Notes value should be set to 16 (sixteenth notes). The “T” values on the pop-up menu are for triplets.

2. Specify a Rests value.
   For example, if you want a single short note on a beat (quarter note position) to be displayed as a quarter note, set the Rests value to 4 (quarter notes).

3. Deactivate the Auto Quantize option.
4. Set all the Interpretation Options. These are described in detail below.
5. Examine the score.
6. If necessary, use the Display Quantize tool to insert “exceptions” to the staff settings.

**RELATED LINKS**

Inserting Display Quantize changes on page 1122

### If your music contains mixed straight notes and triplets

**PROCEDURE**

1. Examine the score and decide if it mainly contains triplets or mainly “straight” notes.
2. Set the Notes value accordingly.
   - If the score is mainly triplets, select the smallest triplet note position used in the score.
   - If it is mainly straight notes, select the smallest “ordinary” note position.
3. Set the Rests value as described above.
4. Activate the Auto Quantize option.
5. Activate the Deviation and Adapt flags if you need them.

### Interpretation Options

![Interpretation Options](image)

**Syncopation**

Activate Syncopation when the program adds more ties to notes crossing beats and bar lines than you prefer. The following options are available:

**Relax**

When Syncopation is “relaxed”, the program applies syncopation in a number of common cases.

**Full**

Syncopation is on.
Off

Syncopation is off, with no exceptions.

For a "modern" notation of syncopated notes, activate Syncopation.

Without and with Syncopation

Again, without and with Syncopation

Note that you can insert "exceptions" to the Syncopation setting in the Score Settings dialog on the Staff page, by using the Display Quantize tool. You can also create tied notes in various combinations by using the Cut Notes tool.

Consolidate Rests

Activate this when you want small consecutive rests joined into one (an eight note rest and a sixteenth note rest joined to a dotted eighth note rest for example).

Consolidate Rests deactivated and activated

Clean Lengths

When this option is activated, the program interprets the length of your notes differently. A note's length (in the display only) might be extended to the beginning of the next note or to the next Rests "position" for Display Quantize. An example:

- If a note is too short, you may get a rest just after it.
- When Clean Lengths is activated, the rest disappears.

A slightly short eighth note without and with “Clean Lengths”.

If using Clean Lengths does not help in a particular situation, you can manually resize the offending note(s) or use the Display Quantize tool.

RELATED LINKS

Inserting Display Quantize changes on page 1122

No Overlap

When notes starting at the same position have different lengths, the program tends to add more ties than you may want. This can be avoided by using No Overlap.
This recording in the Key Editor…

...is displayed like this when No Overlap is deactivated…

...and like this when No Overlap is activated.

You can insert “exceptions” to the No Overlap setting on the Staff page of the Score Settings dialog, by using the Display Quantize tool.

**IMPORTANT**

Please note that there may be situations when neither of these alternatives is ideal. If you run into such a situation, it can probably be resolved by using polyphonic voicing.

**RELATED LINKS**

*Polyphonic voicing on page 1163*

**Shuffle**

In jazz it is very common to score a shuffled beat as straight notes, simply to make it more legible.

When the Shuffle flag is activated, the program searches for eighth note or sixteenth note pairs where the second note is played late (with a “swing feel” or as the third note in a triplet). Such pairs are displayed as regular eighth or sixteenth notes instead of triplet-based figures.

Without and with Shuffle

**Display Transpose**

This is used when preparing parts for instruments that are not scored at the actual concert key. For example, if you want the note C3 to be played by an alto sax, you have to score it as an A3 – nine semitones up. Luckily, the Display Transpose setting takes care of this for you:

- Use the pop-up menu to select the instrument for which you are scoring.
- If the pop-up menu does not list your instrument, you can set the desired transposition with the Semitones value field.
NOTE

The Display Transpose setting does not affect playback or the actual pitch of the notes – it only changes how they are displayed and printed.

You can also insert Display Transpose changes anywhere in the score, by inserting a key change symbol and using the Transpose setting in the Edit Key dialog.

- In the Score Settings dialog, on the Project page (“Chord Symbols” subpage), deactivate the “Use Display Transpose” option if you do not want the chord symbols to be affected by the Display Transpose setting.
- You can disable Display Transpose by deactivating the “Display Transpose” button on the toolbar of the Score Editor.

RELATED LINKS

Display Transpose in the Edit Key dialog on page 1115
Chord Symbols on page 1250
Transposing instruments on page 1114

The Options tab

Clicking the Options tab in the dialog brings up another page with additional settings. Below follows a brief description of these, with references to more detailed explanations.

Switches

This section allows you to make beam settings.

Flat Beams

Activate this when you want the beams over notes to be flat (as opposed to slanted).
No Beams
Activate this when you do not want any beaming at all on the staff (for example for vocal scoring).

Beam Subgroups
Use this when you want sixteenth notes displayed under a beam to be divided into groups of four notes.

Without and with Beam Subgroups.

16th Subgroups
Use this when you want even smaller subgroups of sixteenth notes. This setting has no effect if Beam Subgroups is deactivated.

As above, but with 16th Subgroups activated.

RELATED LINKS
Beam appearance and slant settings on page 1194
Turning beaming on/off on page 1188
Handling beam groups on page 1194

System Sizes
This section allows you to set the number of system lines and to control spacing between the lines:

System Lines
The number of lines in a system. For regular scoring, this should be set to 5.

Add Space
Allows you to increase or decrease the space between the lines in a system.

Size
Allows you to set a size for the systems, as a percentage (with 100% being the default value). In effect, this setting scales the score vertically.

Score Drum Map
When scoring for drums, you can assign a unique note head to each pitch. There is even the possibility to set up different note heads for different note values!

RELATED LINKS
Scoring for drums on page 1303
Fixed Stems

Activate this if you want all note stems to end at the same vertical position. This feature is perhaps most often used when scoring for drums.

![A drum pattern with Fixed Stem length activated](image)

The Up and Down parameters determine which position (relative to the top of the staff) is used for up and down stems, respectively. The graphical display helps you get your settings right.

RELATED LINKS

Setting up a staff for drum scoring on page 1307

Note Limits

Use the Low and High fields to specify a note range. In the active staff, any notes outside this range are displayed in a different color. When writing a score for a specific instrument, this makes it easy to find notes that are outside of this instrument’s note range.

NOTE

If the "Hide Notes beyond limits" option is activated in the Preferences dialog (Scores–Editing page), any notes outside the Note Limits range are hidden.

The Polyphonic tab

This is where you activate and set up split (piano) systems or polyphonic voices (several independent score lines in the same staves).

RELATED LINKS

Polyphonic voicing on page 1163

The Tablature tab

This tab contains settings for creating tablature scores.

RELATED LINKS

Creating tablature on page 1309
Polyphonic voicing

About this chapter

In this chapter you will learn:

- How to decide when to use polyphonic voicing.
- How to set up voices.
- How to automatically convert your score to polyphonic voicing.
- How to enter and move notes into voices.

Background: Polyphonic voicing

Polyphonic voicing allows you to resolve a number of situations impossible to score properly otherwise:

- Notes starting at the same position, but with different lengths. Without polyphonic voicing you get unnecessary amounts of ties.

Without and with polyphonic voicing

- Vocal scoring and similar. Without polyphonic voicing, all notes starting at the same position are considered parts of a chord. With polyphonic voicing you can give each voice a stem direction, you can have individual rest handling for each voice, etc.

Without and with polyphonic voicing

- Complicated piano systems. Without polyphonic voicing, you have to resort to a fixed split note setting to decide which notes go on which clef. With polyphonic voicing, the split point can be “floating”. The program can even automatically put a bass line on the lower clef for you.
How voices are created

Cubase allows for up to eight voices. The first thing you do is to set them up. This includes “telling” the program which voices belong to the upper clef and which belong to the lower, how you want rests displayed for each voice, etc.

The second thing you do is to move or enter notes into the voices. If you have a recording done already, the program can do much of this work for you, automatically. You might then want to fine-tune by moving one or more notes into another voice, or you might want to add notes to a certain voice.

IMPORTANT
Each voice is polyphonic. In other words, one voice can contain chords.

RELATED LINKS
Adding and editing notes on page 1132

Overlapping notes

Throughout this chapter you encounter the term “overlapping notes”. Two notes are considered overlapping when they are on the same staff and:

• They start at the same position, but have different note values (for example whole note and a quarter note both at the beginning of a bar), or…

\[\text{Notes starting at the same position, without and with polyphonic voices.}\]

• One note starts before another has ended. For example a half note at the beginning of a bar and an eighth note at the second beat.

\[\text{A note that starts before another has ended, without and with polyphonic voices.}\]

Voices and MIDI channels

Internally the program organizes the notes into voices by changing their MIDI channel values. Normally you set it up so that notes with MIDI channel 3 belong to voice 3 etc. Most of the time the link between MIDI channels and voices is totally transparent to you as a user. Sometimes you can take advantage of this relationship, as described later in this chapter.
There are also a few important things to note:

**NOTE**

When you make a note part of a voice, you are in fact changing its MIDI channel value. However, when you change the voice’s MIDI channel values in the setup dialog, this does not affect the notes’ MIDI channel setting. This can lead to serious confusion, since the relationship between the notes and the voices is affected. It might even make notes disappear (the program warns if this happens). In other words, do not change the MIDI channels on the Polyphonic tab of the Staff page in the Score Settings dialog after you have put your notes into voices, unless you are absolutely sure of what you are doing.

**NOTE**

When you open a part that contains notes on different MIDI channels, these notes are in fact already assigned to voices (since notes are assigned to voices using their MIDI channel setting). While this fact can be put to good use, it can also create confusion, and even disappearing notes, as described above.

---

## Setting up the voices

To set up your score for polyphonic voicing, proceed as follows:

**PROCEDURE**

1. Make sure that the desired staff is active.
2. Open the Score Settings dialog and select the Staff page.
3. Select the Polyphonic tab.
4. Open the Staff Mode pop-up menu and select Polyphonic.

This makes the voice list in the lower part of the dialog available. It consists of eight rows, one for each voice. They are numbered and therefore we refer to them as voices 1 to 8.

**IMPORTANT**

Do not confuse the voice numbers with the MIDI channel setting for each voice.
Polyphonic voicing
Setting up the voices

To activate a voice, click in its “On” column, so that a checkmark appears. There are four voices on each staff, for a total of eight. If you activate one “upper” voice and one “lower” voice, you get a split (piano) staff.

If you have particular reasons to use specific MIDI channels, change the “Chan” settings for the voices. The program automatically sets each voice to a different MIDI channel. If you do not have good reasons to make changes, leave the settings as they are.

IMPORTANT
If two voices are set to the same MIDI channel, the lower voice is treated as if it were turned off.

Click in the “Rests–Show” column to decide for which voices you want rests displayed. A checkmark indicates that rests are shown for a voice. Often you only want rests to be shown for one voice per staff, see below.

If you have activated “Rests–Show” for a voice, but do not want rests to be shown in empty bars, click in the “Rests–Reduce” column for that voice. This is especially useful for cue voices.

Click in the “Rests–Center” column to determine at which vertical positions rests are shown (for voices with “Rests–Show” activated). When this option is activated for a voice, the rest is put in the vertical center of the staff, when it is not, the rest gets a vertical position based on the pitch of the notes.

Decide on a stem direction for each voice, by selecting from the pop-up menu in the Stems column. If you select Auto, the program makes decisions about which stems go in which direction (just as when not using polyphonic voices). You can always force stem direction for individual notes by using the Flip Stem function.

IMPORTANT
There is a special stem feature for voice 1: If you set this to Auto, the stem direction depends on the pitch of the note as usual – except if there are voice 2 notes in the bar, because then the voice 1 stems are automatically set to Up!

If you want the notes in a voice to be smaller than regular notes, put a checkmark in the Cue column for the voice.

Click Apply. The staff is changed to polyphonic voicing, and the program distributes the existing notes into voices according to their MIDI channel values. At this point you may want to use the Explode function to automatically move notes into the proper voices.

RELATED LINKS
Cue notes on page 1199
Flipping the stem of one or several notes on page 1178
Automatically – the Explode function on page 1170
If the “Some Notes Do Not Belong To Voices…” dialog appears

When you click Apply, a warning may appear saying “Some notes do not belong to any voice and may be hidden. Correct these notes?”. This warning appears when the staff contains notes with MIDI channel settings which do not match any of the active voices.

If you click the “Correct” button, these notes are moved to active voices. If you click “Ignore”, nothing is changed, and some notes are hidden. However, they are not lost, they appear in all other editors and can be made to appear again in the Score Editor if you change the channel settings for the notes or voices, activate more voices, etc.

About the polyphonic presets

The Presets pop-up menu on the Polyphonic tab (below the list of voices) contains three very useful setups. Instead of making settings by hand, you can select one of the presets, saving some time. The presets are:

Variable Split

This sets up the dialog for two voices, one on each staff, each with auto stem direction. This is a good starting point for a piano staff when the fixed split option does not suffice.

Optimize Two Voices

In this preset, only voices 1 and 2 are activated, and set up like this:

<table>
<thead>
<tr>
<th>Staff 1</th>
<th>Staff 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>Num: 1</td>
<td>Num: 2</td>
</tr>
<tr>
<td>On: 1</td>
<td>On: 2</td>
</tr>
<tr>
<td>Chain:</td>
<td>Chain:</td>
</tr>
<tr>
<td>Show:</td>
<td>Show:</td>
</tr>
<tr>
<td>Center:</td>
<td>Center:</td>
</tr>
<tr>
<td>Reduce:</td>
<td>Reduce:</td>
</tr>
<tr>
<td>Up:</td>
<td>Down:</td>
</tr>
</tbody>
</table>

This way the first voice behaves as in single staff mode, but if there are notes in the second voice, the stems of the first one are set to Up.

Optimize Four Voices

This is like “Optimize Two Voices”, but with two staves. Voices 5 and 6 are activated as well, with the same settings as voices 1 and 2. This is the recommended way to write piano music.
Strategies: How many voices do I need?

Well, it depends

- If you are scoring for vocals, you simply need one voice for each voice, so to speak.

- If you use voices for resolving the problem of overlapping notes, for example when scoring for piano, you need two voices each time two notes overlap. If three notes overlap, you need three voices. In other words you need to check for the “worst case” (largest number of overlapping notes at a certain position) and activate that many. If you do not know how many notes you need when starting out to prepare a score, do not worry, you can add more voices later.

- Voices 1 and 2 on the upper staff and 5 and 6 on the lower are special. These handle “collisions” (notes with small intervals, accidentals that otherwise would come too close, etc.) automatically which the other voices do not. Always use these voices first!

An example: in the situation below, three voices are required. The lowest note overlaps both the “melody” and the chords, so it cannot share a voice with the chords. The chords overlap the melody, so they cannot share a voice either.

Related links

Overlapping notes on page 1164

Entering notes into voices

When you add new notes, you need to decide which voice they go into:

**PROCEDURE**

1. Make sure that the extended toolbar is visible.
2. Select the Object Selection tool.
3. If you have a split system, check the voice Insert buttons.
   These are displayed after the text “Insert” on the left side on the extended toolbar. Only the voices that are activated on the Polyphonic tab are shown. If the upper staff is active, the voice Insert buttons are numbered 1, 2, etc., otherwise they are numbered 5, 6, etc.
4. If you need to switch the voice icons to the right “clef”, click somewhere in the system you want to insert notes in.
5. Select one of the voices by clicking on the corresponding button.
   Any notes you enter from now on are inserted into that voice.
Polyphonic voicing
Checking which voice a note belongs to

Voice 3 activated for insertion

6. Insert the notes as usual.
7. To switch to another voice, click the corresponding button.
8. To insert notes into a voice on the other clef, click on that clef and then select a voice using the buttons.

RELATED LINKS
Adding and editing notes on page 1132

Symbols and voices

Later in this manual you will learn about symbols that can be added to the score. Many of these symbols must also be put into a particular voice.

RELATED LINKS
Important! – Symbols, staves, and voices on page 1212

Checking which voice a note belongs to

When you select one single note, the corresponding voice button on the extended toolbar is selected. This allows you to quickly find out which voice a certain note is in (after you have used the Move To Voice function, for example).

- When you step through the notes using the arrow keys, you only step through the notes in one voice at a time.
  This can be used as a quick way to check which notes belong to the same voice as some other note.

Moving notes between voices

Manually

To manually move notes to another voice, proceed as follows:

PROCEDURE
1. Select the note(s) you want to move to a particular voice.
2. Right-click on one of the notes and select “Move to Voice” from the context menu.
3. On the submenu, select the voice to which you want to move the notes. Only the activated voices are available on the menu. You can also press [Ctrl]/[Command] and click a voice Insert button on the extended toolbar to move the selected notes to the corresponding voice. You can also assign key commands for this in the Score Functions category of the Key Commands dialog on the File menu.

Automatically – the Explode function

The Explode function distributes notes, either onto new tracks or into polyphonic voices:

**PROCEDURE**

1. Open the Scores menu and select “Explode” from the Functions submenu.

   ![The Explode dialog, set to create polyphonic voices.](image)

2. Make sure that “To Polyphonic Voices” is selected at the top of the dialog.

3. Use the options in the lower half of the dialog to set up the criteria for the split. Choose from the following options:
Polyphonic voicing
Moving notes between voices

4. Click OK.
The notes are distributed to different voices.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Split Note</td>
<td>Use this to move all notes below a certain pitch to another voice.</td>
</tr>
<tr>
<td>Lines To Tracks</td>
<td>Use this when you want all musical “lines” to be put in one voice each. The notes with the highest pitch goes to the first voice, the notes with the second highest pitch goes to the second, and so on.</td>
</tr>
<tr>
<td>Bass To Lowest Voice</td>
<td>When this is activated, the lowest notes always ends up in the lowest voice.</td>
</tr>
</tbody>
</table>

**Related links**
The Explode function on page 1124

**Alternative ways of handling voices**

Below we suggest further “advanced” ways of putting notes into voices. This is based on the relation between voices and MIDI channels, so please make sure that you understand how this connection works.

- **Cubase Pro only:** You can use the Logical Editor to put notes into voices, based on other more complex criteria, like for example their pitch and length. This is done by setting up the Logical Editor so that the notes that meet the criteria get their MIDI channel changed to that of their voice.
- When you enter notes using step input you can change the MIDI channel on your input device and directly enter notes into separate voices.
- You can play back each voice on a different MIDI channel, simply by setting the track to Any. This can be used as a convenient way of “proof-hearing” each voice separately.
- You can use the Input Transformer to assign a certain key range to a MIDI channel, and thereby automatically put notes into voices when recording.
- For brass and vocals, you might record each voice on its own track, and use the “Merge All Staves” function to automatically copy each recording to a separate voice on a new track.
- When you have assigned parts to voices, you can use the Extract Voices function to create one track out of each voice.

**Related links**
The Logical Editor, Transformer, and Input Transformer on page 859
Automatic polyphonic voicing – Merge All Staves on page 1175
Converting voices to tracks – Extract Voices on page 1176

1171
Handling rests

With polyphonic voices, you often get more rest symbols than desired.

- If a voice does not need any rests at all, you can deactivate rests separately for this voice on the Polyphonic tab of the Staff page in the Score Settings dialog.

- If you only need rests from one voice on a staff, activate Rests–Center for that voice (this is done in the same dialog). If two or more voices have rests, deactivate Rests–Center. The program then automatically makes sure the rests do not “collide” in the score, by adjusting their vertical position.

- To avoid having several rests displayed in empty bars, you can activate the Rests–Reduce option for all voices (that have rests) except one. This option causes the program to hide rests in empty bars.

- You can use the Hide feature to totally remove individual superfluous rests from the score.

- You can use the Object Selection tool to manually move rests up/down or sideways to adjust the “picture”.

- If needed you can add “rest symbols” (rests that do not affect the playback data in any way) by using the symbols.

RELATED LINKS
Hiding/showing objects on page 1283

Voices and Display Quantize

When you insert Display Quantize changes, you can either apply the settings to all voices (by [Alt]/[Option]-clicking with the tool) or to the current voice only.

IMPORTANT
If “Display Quantize Tool affects all Voices” is activated in the Score Settings dialog on the Project–Notation Style subpage (Miscellaneous category), the Display Quantize settings always affects all voices (even if you do not press [Alt]/[Option] and click).

Making Display Quantize settings for one single voice allows you to do two things:

- Make each voice have its own Display Quantize settings by inserting a Display Quantize event for each voice, at the beginning of the staff. This is valid for the entire staff, until another Display Quantize event is inserted.
Polyphonic voicing
Creating crossed voicings

- Insert Display Quantize “exceptions” anywhere in the score, independently for each voice.

PROCEDURE
1. Make sure that the “Display Quantize Tool affects all Voices” option is deactivated.
2. Select the voice for which you want to insert a Display Quantize event.
   This is done by clicking at the corresponding voice button on the extended toolbar as described above, or by selecting a note that belongs to this voice.
3. Select the Display Quantize tool.
4. Click at the position at which you want to insert the event.
   The Display Quantize dialog appears.
5. Fill out the dialog.
6. Click Apply.

RELATED LINKS
Inserting Display Quantize changes on page 1122
Display Quantize and Interpretation Options on page 1155

Creating crossed voicings

Often, for example in vocal scoring, you have crossed voicings on one system. You can of course move notes manually into voices to get the stem direction and other note properties right, but there is a quicker way. Let’s explain how to do this by example. Without using polyphonic voicing, you have entered this:

PROCEDURE
1. Open the Score Settings dialog on the Staff page and select the Polyphonic tab.
2. From the Staff Mode pop-up menu, select Polyphonic.
3. Activate voice 1 and 2 only, and make settings for them as in the picture below.
4. Click Apply.  
The staff is in Polyphonic staff mode, but all notes are still in the same voice.

5. Open the Scores menu and select “Explode” from the Functions submenu.

6. In the dialog that appears, select the “To Polyphonic Voices” option and activate “Lines To Tracks”.
   Leave the other options off.

7. Click OK.  
The notes have now been split in two “lines”, each in a separate voice. However, from the middle of the bar, notes that are in voice 1 should be in voice 2 and vice versa.

8. Select the two notes that you want to be moved from voice 1 to voice 2.

9. Move the notes to voice 2.  
The quickest way to do this is to press [Ctrl]/[Command] and click the voice Insert [2] button on the extended toolbar.

10. Select the two notes that you want to be moved to voice 1 and move them, too.

RESULT  
The voicing is now correct, as you can tell from the stem directions. However, there is still some work to do on the notes graphical positions and the display of stems and beams for some of the notes. When you have made those adjustments, the score may look like this:
Automatic polyphonic voicing – Merge All Staves

If you have already created some tracks which look and play back as they should, and you want to combine these into one track with polyphonic voices, there is a special function on the Scores menu for this:

PROCEDURE
1. Open the tracks (up to four) in the Score Editor.
2. Open the Scores menu and select “Merge All Staves” from the Functions submenu.

Now a new track is created and shown in the score. The track has polyphonic voices activated, and the four original tracks are assigned to one voice each (voices 1, 2, 5 and 6 are used).

Furthermore, all non-linked symbols that belong to the staff that become the first polyphonic voice in the merged staff are copied. They have the same positions as the original symbols.

IMPORTANT
When you later play back the music, you need to mute the four original tracks, or you get double notes.
Converting voices to tracks – Extract Voices

This function does the opposite of “Merge All Staves” – it extracts polyphonic voices from an existing track and creates new tracks, one for each voice.

**Procedure**

1. Open a track containing 2 to 8 polyphonic voices in the Score Editor.
2. Open the Scores menu and select “Extract Voices” from the Functions submenu.

   A number of new tracks is created and added to the display of the Score Editor. Each track contains the music from one polyphonic voice. If there were non-linked symbols in the original track, each new track gets a copy of these symbols.

**IMPORTANT**

When you later play back the music, you need to mute the original track (the one with polyphonic voices), or you get double notes.
About this chapter

In this chapter you will learn:

- How to control stem direction.
- How to control beaming, and create cross-staff beaming.
- How to make detailed adjustments to note appearance.
- How to perform “graphic moving” of notes.
- How to create grace notes.
- How to create tuplets.

Background: Note stems

The direction of stems is governed by five things:

- How notes are grouped under beams.
- Any manual manipulation of beams.
- The Flip Stems function.
- How the note information is set for each note.
- How the Polyphonic tab on the Staff page of the Score Settings dialog is set up (if you use polyphonic voices).

The order of this list corresponds to the priority of the settings, i.e. on conflict, the grouping under beams has the highest priority and the settings made on the Polyphonic tab the lowest.

IMPORTANT

If you have edited the stem length of a note and then flip it, the stem is reset to default length.
IMPORTANT

If you have activated the “Fixed Stems” option on the Staff page of the Score Settings dialog (Options tab), a lot of the automatic stem length settings are ignored. However, you can still edit the stem length and direction of individual notes.

RELATED LINKS

Fixed Stems on page 1162

Setting stem direction

In polyphonic voices

In the Score Settings dialog, on the Staff page (Polyphonic tab), the stem direction can be set separately for each voice.

Using Flip Stems

Flipping the stem of one or several notes

**PROCEDURE**

1. Select the notes.
2. Click the Flip icon on the extended toolbar.
   
   All the stems in the selection are now flipped. Those that pointed up now point down and vice versa.

   ![The Flip icon](image)

   You can also assign a key command for this. In the Key Commands dialog on the File menu, the command is called “Flip” and is found in the Score Functions category. You can also right-click a note or a selection of notes and select the Flip option from the context menu.
Flipping the stems of notes grouped under a beam

**PROCEDURE**

1. Select any note in the group.
2. Invoke Flip as described above.
   The entire group is now flipped.

Before and after the flip. No matter which note you select, the entire group is flipped.

**IMPORTANT**

This does not work if you have adjusted the slanting of the beam by dragging. If you have, you must first reset the beam.

**RELATED LINKS**

- Stem length on page 1180

Independent stem direction under a beam

If you need stems attached to the same beam to go in different directions, this is achieved by dragging the beam's start and end points. This feature is available in Page Mode only.

Independent stem direction under a beam

**RELATED LINKS**

- Manual adjustment of beams on page 1195

Stem direction in the Set Note Info dialog

The Set Note Info dialog can be opened by double-clicking on a note head. In its lower left corner you can find a pop-up menu for setting stem direction.
**Stem length**

**Adjusting stem length (Page Mode)**

**PROCEDURE**

1. Click on the end of the stem so that a handle appears.

2. If you want to change the lengths of several stems at the same time, hold down [Shift] and select these stems as well.

3. Drag the stem handle (on one of the selected stems) up or down. All selected stems are lengthened or shortened by the same amount.

**Resetting stem length and beam slants**

**PROCEDURE**

1. Make sure that the filter bar is visible.

   If the filter bar is not visible, click the “Set up Window Layout” button on the toolbar and select the Filters option.
2. Make sure that the “Stems/Beams” checkbox is activated on the filter bar. Now, below the notes where stems have been changed or beam slant adjusted manually, the word “Stem” appears.

3. Click on the “Stem” text to select it.

4. Press [Backspace] or [Delete] to remove it.

Before and after deleting the “Stem” item.

---

## Accidentals and enharmonic shift

### Making global settings

In the Score Settings dialog, on the Project page (Accidentals subpage), you can find a number of options for how accidentals are displayed in the score. Once set, these are valid for all tracks in the project. Proceed as follows:

**PROCEDURE**

1. Open the Score Settings dialog on the Project page and select the Accidentals subpage from the Pages list.

You have the following options:

- **Activate the “Courtesy Acc Distance” option and enter a value in the Bars field.**
  
  This determines after how many measures courtesy accidentals are shown. If you set this to “0”, notes outside the scale get accidentals and no courtesy accidentals are shown.

- **Activate one of the following options:**

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Force</td>
<td>Notes outside the scale get accidentals, and accidentals are repeated even within the same bar.</td>
</tr>
<tr>
<td>Force all</td>
<td>Every single note in the score gets an accidental.</td>
</tr>
</tbody>
</table>
2. In the “Outside the Scale” area, you can decide how five of the most common intervals outside the scale are displayed, as sharps or as flats.

**IMPORTANT**

If you activate the “Accidentals for Each Note” option in the Score Settings dialog, on the Project–Notation Style subpage (in the “H.W. Henze Style” category), all notes are displayed with accidentals (even tied notes).

**IMPORTANT**

If you activate “Use Chord Track for Accidentals”, the chord track is used to determine the accidentals.

**RELATED LINKS**

Chord Functions on page 814

---

**Enharmonic Shift**

If one or several notes are not displayed with the accidentals that you want, you can perform an Enharmonic Shift operation on them.

**PROCEDURE**

1. Select the notes to be shifted.
2. Click the desired option on the extended toolbar.
3. If you want the enharmonic shift to be repeated in the whole bar, activate the “Enharmonic shift for entire bar” option in the Score Settings dialog (Project–Accidentals subpage).

---

**Extended Toolbar**

![Buttons]

Use these buttons when you want regular Enharmonic Shifting (select one option).

![Button]

Use this button when you want to deactivate Enharmonic Shifting for the notes.

![Button]

Use this button when you want to hide the accidental completely.

![Button]

Use this button when you want to create a “help accidental” for the selected notes only.
Use this button when you want to enclose the accidental in parentheses. To remove these, select “off”.

Changing the note head shape

PROCEDURE
1. Select the notes for which you want to change the note head shape.
   Make sure not to select the stems, only the note heads.
2. Open the Set Note Info dialog.
   To do so, double-click one of the notes, click the “i” button on the extended toolbar,
   or right-click on a note head and select “Properties” from the context menu.
3. Open the “Note Head” pop-up menu in the top left corner of the dialog.
   The pop-up menu contains all the available head shapes and an “Auto” option, which
   selects the normal default shape for the note.
4. Select one of the note heads.
5. Click Apply.
   The settings are applied to the selected notes.
6. If you like, select other notes and make settings for them.
7. When you are done, close the dialog.

Other note details

Each note has a number of settings in the Set Note Info dialog.
The Set Note Info dialog contains the following settings:

**Note Head**
Used for selecting custom note head shapes.

**Tablature on/off and number**
Used for creating or editing tablature. This feature can be used for individual notes or together with the automatic tablature function.

**Bows**
Used for adding bow up/bow down articulation. When selecting “Off”, bow symbols are not displayed for the selected notes.

![Bow up and down](image)

**Length**
This allows you to change the displayed length of notes, without affecting playback. Note that the display quantize settings still apply. To reset this value to “Auto” (so that notes are displayed according to their actual length), scroll the value down to zero.

**Accidental Distance**
Use this to specify how far from the note, horizontally, you want the accidental. The higher the number the greater the distance.

**No Ledger Lines**
Turns off ledger lines for notes with high or low pitches.

![With and without ledger lines](image)

**No Stem**
Hides the note stem completely.

**No Dot**
Hides the dot from a dotted note.
No Flag/Beam
Activate this to hide the flags or beams of the selected notes.

Bracket Head
When this is activated, notes are displayed with brackets:

Bracket Head on and off

X Stem (Spoken)
When this option is activated for a note, it is displayed with an x across its stem. This is normally used to indicate spoken words.

Hide Note
Activating this checkbox hides the selected notes.

Stem
Determines the stem direction.

Tie
Determines the direction of ties. When this is set to “Auto”, the program chooses a tie direction depending on the stem direction of the tied notes.

Type
Determines the note type. There are four options:
- Normal. This is how notes usually are displayed.
- Grace. When this is selected, notes are displayed as grace notes.
- Cue. When this is selected, notes are displayed as cue notes (smaller notes, often used as “guide notes” or optional lines).
- Graphic. These are special notes, useful for example for guitar notation (pull-offs) and trills (as “help notes”, indicating which notes to trill between). In both these cases the “No Stems” option could be useful. Graphic notes are not included in the “automated cutting”. They are positioned after the notes they “belong to” (as opposed to grace notes).

Crossed
Activate this option, when you want the stem to be crossed by a slanted line (to indicate that the note is a grace note).

Grace note options
These options are available when Grace is selected on the Type pop-up menu.

RELATED LINKS
Changing the note head shape on page 1183
Creating tablature on page 1309
Display Quantize values on page 1156
Using Flip Stems on page 1178
Coloring notes

You can assign colors to notes using the Event Colors pop-up menu on the toolbar.

PROCEDURE

1. Simply select the notes for which you want to use colors, open the Event Colors pop-up menu on the toolbar and pick a color.
   
   Only the note heads are colored. Note that the color is only visible once the notes have been deselected.

2. On the far right in the Score Editor toolbar you can find the Hide Colors button.
   
   If you assigned colors to some or all of the notes in your score, this button allows you to switch between display of colored or uncolored notes. This may help you to find selected notes among other colored notes.
Scores Colors for Additional Meanings

If the Preferences dialog (Scores–Colors for Additional Meanings page) you can specify different colors for elements in the score in order to indicate that they are “special” in any way. You can for example choose a color for a “Moved Graphic” or a “Moved Slur”. These objects are colored accordingly when they are moved from their default positions.

**PROCEDURE**

1. Open the Preferences dialog (Scores–Colors for Additional Meanings).

2. Click in the Active column to activate this function for the corresponding element.

3. Click in the Color field to the right to select a color.

   When color-printing a score, you get the colors you selected for the notes. When you are using a black-and-white printer, the notes appear in black (notes that have not been assigned a color) and different shades of gray (depending on how bright/dark a color was used for the note).

**RELATED LINKS**

Moving note symbols on page 1231
Copy settings between notes

If you have made various settings in the Set Note Info dialog for a note, and want to use these settings for other notes as well, there is an easy way to do this:

**PROCEDURE**

1. **Set up the first note as desired.**
   This includes the settings in the Set Note Info dialog, but also any note-related symbols such as accents, staccato, articulation, etc.

2. In the score, select the note and select “Copy” from the Edit menu.

3. Select the notes to which you want to copy the attributes.

4. Right-click the notes to which you want to copy the attributes, and select “Paste Attributes” from the context menu.
   The selected notes now get the attributes of the first, copied note, but their pitches and note values remain unchanged.

**RELATED LINKS**

*Adding note symbols on page 1213*

Handling beaming

Turning beaming on/off

Beaming is enabled/disabled independently for each staff.

**PROCEDURE**

1. On the Staff page in the Score Settings dialog, click the Options tab.

2. To turn off beaming, activate No Beams and click Apply.
   Even if beaming is deactivated for the staff, you can put some notes under beams, as described below.

Grouping

When beaming is on, the program automatically groups notes under beams. However, there are a number of ways to determine how notes are grouped.
Using the Edit Time Signature dialog

The time signature for the score naturally affects grouping. But you can control this yourself by creating a composite time signature used only for grouping:

**PROCEDURE**

1. Open the Edit Time Signature dialog by double-clicking the time signature symbol for the staff.
2. Set up the numerator with the grouping you desire.
   If you for example want eighth notes in two groups of three and one group of two, enter 3+3+2.
3. Set the denominator, if necessary.
4. Activate “For Grouping Only”.
5. Click OK.

**IMPORTANT**

Note that the “For Grouping Only” setting only affects the way the numerator is divided. Any changes you make to the “sum” of the numerator number or the denominator result in a change of actual time signature in the project. If you need a grouping which cannot be entered in the current time signature, you have to group notes manually, see below.

Regular grouping of a number of eighth notes or smaller (“Beam”)

If the grouping the program assigns is not the one you want, you can put any selection of eighth notes or smaller under a beam:

**PROCEDURE**

1. Select at least two notes, where you want the beam to begin and end.
   All notes between these two notes are grouped under a beam.
2. Click the Group Notes icon on the extended toolbar or right-click on one of the notes to be grouped and select “Beam” from the “Group/Ungroup” submenu of the context menu.

The Group Notes icon
Handling beaming

Before and after grouping

Double-clicking on the “Grouping” text opens the Grouping dialog, allowing you to adjust the “note value” for the symbols.

Grouping quarter notes or larger under a beam (“Brillenbass”)

It is also possible to use the grouping feature for notes that are not displayed with beams (quarter notes, half notes, etc.). The result are so called “Brillenbass” symbols, commonly used for indicating repeated accompaniment patterns, etc.

Double-clicking on the “Grouping” text opens the Grouping dialog, allowing you to adjust the “note value” for the symbols.

Grouping notes using Repeats

To show Repeats for the grouped notes, proceed as follows:

**PROCEDURE**

1. Make sure that the filter bar is visible in the Score Editor.
   
   If the filter bar is not visible, click the “Set up Window Layouts” button on the toolbar and select the Filters option.

2. Activate the “Grouping” checkbox in the filter bar.
   
   Now, you see the text “Grouping” below all groups you have created.

3. Select the desired notes.

4. Right-click on one of the notes and from the Group/Ungroup submenu, select “Repeat...”

5. In the dialog that appears, use the radio buttons to select the desired note value for the repeats.

In this example, the “Repeat” feature is used to display two pairs of sixteenth notes as two eighth notes with “repeat bars”. Note that the second and fourth sixteenth note have only been hidden – playback is not affected!
6. Click OK to close the dialog. Double-clicking on the “Grouping” text opens the Grouping dialog, allowing you to adjust the “note value” for the symbols.

Creating an accelerando/ritardando

To create an accelerando/ritardando, proceed as follows:

PROCEDURE

1. Select the notes as described above and select “Accelerando” from the Group/Ungroup submenu. A dialog appears.

2. Use the radio buttons to select the desired combination (i.e. define whether you want an accelerando or a ritardando and specify the desired note values) and click OK to close the dialog.

Example for accelerando (left) and ritardando (right)

Double-clicking on the “Grouping” text opens the Grouping dialog, allowing you to select another combination.

The Grouping dialog

As described above, the Grouping dialog can also be opened by double-clicking an existing grouping text in the score.

- Which Grouping dialog appears depends on the grouping option you used for the notes (Beam, Repeats or Accelerando, see above).
Removing groups

If you have created a group as described above and want to remove it, proceed as follows:

**PROCEDURE**
1. Make sure that the “Grouping” checkbox is activated in the display filter bar.
2. Select a group by clicking on its “Grouping” text.
3. Press [Backspace] or [Delete].
   The grouping is removed.

![Grouping example](image)

If you need to remove all groups from the score, hold down [Shift] and double-click on the first “Grouping” text.
This selects all “Grouping” symbols, so you can delete them all at once by pressing [Backspace] or [Delete].

Removing a note from a group

There is no dedicated “ungroup” command, simply because it is not needed. A group can consist of one note if you wish. In other words...

- To remove one note at the end of a group, select it and proceed with grouping as above.
- If you select notes in the middle of a beam and then group, three groups are created.

![Grouping examples](image)

Automatic grouping

The program can also go through the selected notes and automatically create grouping for you, where it is deemed suitable.

**PROCEDURE**
1. Select the notes that you want checked for auto-grouping.
   Typically, you would select all notes on the track by using the Select All command on the Edit menu.
2. Right-click on one of the notes and select “Auto Group Notes” from the context menu.
Handling beaming

In 4/4 you get for example two groups of eighth notes per bar, in 3/4 you get one group per bar, etc.

Cross-staff beaming

To create a beam that extends from one staff to another, proceed as follows:

**PROCEDURE**

1. Set up a split or polyphonic voicing system or open the Score Editor with more than one track.
2. Set up a beam of notes (using the group command) and adjust their pitches so that they are correct even though some of the notes are on the wrong staff. Use the info line to edit the pitches if they are very low or high.
3. Select the notes that should appear on the other staff.
4. Select “Display in Staff” from the context menu for a selected note and select a staff from the submenu.

   ![Context Menu Example](image)

   The notes are “graphically” moved to the selected system, but keep their actual pitch.

5. If needed, adjust the beam appearance.

   ![Beam Adjustment Example](image)

   Cross-staff beaming with the beam in the middle

   This does not move the affected notes to another track, but merely displays them as if they belonged to the other staff.

**RELATED LINKS**

- Manual adjustment of beams on page 1195
Handling beam groups

There are two settings for groups under a beam, Beam Subgroups and 16th Subgroups, both found on the Options tab on the Staff page of the Score Settings dialog. If “Beam Subgroups” is activated, the program displays subgroups after four sixteenth notes under a beam. If you also activate “16th Subgroups”, subgroups appear after only two sixteenths.

Beam Subgroups off

Beam Subgroups on

On with 16th Subgroups activated

Beam appearance and slant settings

Global settings

In the Score Settings dialog, on the Project page (Notation Style subpage), you can find the following three options for beam appearance in the Beams category:

- **Thick Beams.**
  Activate this if you want beams to be displayed as thick lines.

- **Show Small Slants as Flat Beams.**
  When this is activated, beams that would be only slightly slanted are displayed flat.

- **Slanted Beams only Slightly Slanted.**
  Activate this if you only want a slightly slanted beam even though there might be a significant pitch difference between the notes under the beam.
Staff settings

In the Score Settings dialog, on the Options tab of the Staff page, you can find a couple of settings for beams as well:

**Flat Beams**
Activate this when you do not want any slant at all, no matter the pitch difference of the notes under the beams.

**No Beams**
Activate this when you do not want any beams at all.

Manual adjustment of beams

For very detailed control you can manually adjust the beam slant:

**PROCEDURE**

1. Group and flip notes and adjust the settings described above until the beams are as close as possible to how you want them.
2. Click on the corner made up by the beam and the stem.
   A handle appears on the corner of beam and stem.
   ![A beam handle](image)
3. Drag the handle up or down.
   The slant of the beam changes.
   ![Dragging a handle and the effect it has.](image)

**NOTE**
You can adjust the distance between notes and their beam without changing the beam slant. Select both handles of a beam (by pressing the [Shift] key while selecting the second handle) and drag one of the handles up or down.
Mixed stem direction

By dragging the beam handles you can put the beam between the note heads:

Putting the beam between the notes

About tied notes

Sometimes, notes are displayed as two or more notes tied together. Generally, there are three different occasions when this happens:

- When a note is of an “uneven” length that cannot be displayed without tying together two or more notes of different note values.
- When a note crosses a bar line.
- When a note crosses a “group line” within a bar.

The last case requires some explanation: Cubase uses a “cutting mechanism” that automatically creates tied notes depending on the length and position of the notes. For example, a quarter note is cut in two and tied if it crosses a half note beat, and an eighth note is cut in two and tied if it crosses a quarter note beat:

1) This quarter note is cut.
2) This eighth note is cut.

However, this is not always what you want. There are three ways to affect the cutting mechanism:

Syncopation

When the Syncopation option is activated on the Main tab of the Staff page in the Score Settings dialog, Cubase is less prone to cut and tie notes. For example, the second quarter note in the figure above would not have been cut if syncopation had been activated.

The Syncopation setting affects the whole track, but you can also make syncopation settings for separate sections in the score, by inserting display quantize events.

RELATED LINKS

Inserting Display Quantize changes on page 1122
Time signature changes

By inserting time signature changes, you can change the way notes are cut. This is done in the same way as when you specify how beamed notes are grouped.

\begin{music}
\begin{musicnotes}
\bar{\musicclef{c}\musicstaff{1}}
\musicnote{1}\musicnote{1}\musicrest{1}\musicnote{1}\musicnote{1}
\end{musicnotes}
\end{music}

With a regular 4/4 time signature

\begin{music}
\begin{musicnotes}
\bar{\musicclef{c}\musicstaff{1}}
\musicnote{1}\musicnote{1}\musicnote{1}\musicnote{1}\musicnote{1}\musicnote{1}\musicnote{1}\musicnote{1}\
\end{musicnotes}
\end{music}

With a composite time signature (3+2+3 eighth notes)

RELATED LINKS

Grouping on page 1204

The Cut Notes tool

By using the Cut Notes tool, you can disable the automatic cutting mechanism in a bar, and insert manual cuts at any given position in the score.

PROCEDURE

1. Select the Cut Notes tool.

2. Select a suitable quantize value from the “Quantize Presets” pop-up menu. As usual, this determines where you can click.

3. When you are using polyphonic voices, select the voice you want to make settings for.

4. Click in the bar containing the notes that you want to cut manually, at the position you want them cut.

   This inserts a cutflag event in the bar at the position you clicked. If you hold down [Alt]/[Option], a cutflag event is inserted for all voices in a polyphonic staff.

   A half note, placed at 2.1.3. This is by default cut at 2.3.1 (the middle of the bar).

   When you click at the position 2.2.1, a cutflag event is inserted.

\begin{music}
\begin{musicnotes}
\bar{\musicclef{c}\musicstaff{1}}
\musicnote{1}\musicnote{1}\musicnote{1}\musicnote{1}\
\end{musicnotes}
\end{music}

As a result, the regular cutting mechanism is disabled and the note is cut at the position you clicked instead.

The following rules apply to cutflag events:

- If a bar contains a cutflag event, the automatic cutting mechanism is disabled within that bar.
- All notes or rests that start before and end after a cutflag event are cut at the position of the event.
- To display cutflag events, make sure that “Cutflag” is activated on the filter bar.
- To remove a cutflag event, either click again with the Cut Notes tool at the same position, or select it and press [Backspace] or [Delete].
Other options for tied notes

Tie direction

You can set the direction of the tie manually in the Set Note Info dialog.

RELATED LINKS
Other note details on page 1183

Flat ties

If you prefer ties to be displayed as flat lines, rather than regular “curved” ties, activate the “Flat Ties” option in the Score Settings dialog, on the Project–Notation Style subpage (H.W. Henze Style category).

Graphic moving of notes

There might be instances where the “graphical” order of the notes is not the one you want. In this case, you can move notes without affecting the score or playback in any way. This can be done with the Layout tool or using your computer keyboard.

By using the Layout tool

PROCEDURE
1. Select the Layout tool in the Score Editor toolbar.
2. Click again on the tool button to open the Mode pop-up menu and select the desired option.
3. Click on the note and drag it to the desired position.
   Note that movement is restricted to horizontally only.

NOTE
You can also automatically select all notes making up a chord, by holding down [Alt]/[Option] and clicking on one of the notes with the Layout tool.

Modes for the Layout tool

The following modes are available:

Move Single Object

In this mode, only the object you move with the Layout tool is affected (moved). Use this if you want to “correct” the position of one single note in the score, for example.
Move Notes and Context

In this mode, other score objects are moved accordingly when you move a note with the Layout tool. Use this mode if you want to correct the display of all score objects within a bar rather than modifying single note positions.

By using the computer keyboard

You can assign key commands for moving objects graphically. In the Key Commands dialog on the File menu, the commands are found under the Nudge category and called Graphical Left, Graphical Right, Graphical Bottom, and Graphical Top (only the Graphical Left and Graphical Right commands apply to notes).

After assigning key commands, you select the notes that you want to move and press the assigned keys to adjust their graphical position.

Cue notes

You can create cue notes by using voices or by converting individual notes into cue notes.

Setting a voice to display cue notes

PROCEDURE

1. Open the Score Settings dialog on the Staff page and select the Polyphonic tab.
2. Click in the “Cue” column for the voice, so that a checkmark appears.
3. Decide how to handle rests for the voice.
   You might for example leave “Rests–Show” activated and activate “Reduce”. If you do, you get rests in this voice, but not as many as otherwise. Empty bars, for example, do not have any rests at all.
4. Close the dialog.
5. Move the notes into the cue voice.

An example of a cue note voice
A quick example

Let’s say you have a flute part and want some cue notes for it:

**PROCEDURE**

1. Switch on polyphonic voices and activate voice 1 and voice 2.
2. Set voice 2 to “Auto” stem direction and centered rests.
3. Set up voice 1 to be a cue voice, with hidden rests and stems pointing up.
4. Insert the cue notes into voice 1.

Turning individual notes into cue notes

**PROCEDURE**

1. Select one or several notes.
2. Double-click one of the notes.
   The Set Note Info dialog appears. You can also click the “i” button on the extended toolbar, or right-click on a note head and select “Properties” from the context menu to open this dialog.
3. Select Cue from the Type pop-up menu.
4. Click Apply.
   The settings are applied to the selected notes.
5. Close the dialog.

Grace notes

You can turn any note into a grace note. Grace notes are considered to be notes without lengths. This means that once a note is turned into a grace note it does not affect the rest of the score display in any way.
Before and after converting to grace notes. Note that after the conversion, the grace notes no longer “interfere” with the interpretation of the other notes.

NOTE
Grace notes are always positioned just before the next note on the staff. If there is no note after a grace note on the staff, the grace notes are hidden!

Creating grace notes manually

PROCEDURE
1. Locate the note for which you want a grace note.
2. Insert one or more new notes just before it.
   The note value and exact position of the note is not important. However, the pitch of course is.
   From here on there are two ways to go:
   • Select the notes and open the Set Note Info dialog, either by double-clicking on one of the note heads or by clicking the “i” icon on the extended toolbar.
     In the dialog, select the Grace note type.
   • Right-click on one of the notes and select “Convert to Grace Note” from the context menu.
     This turns the note into a grace note without opening any dialog.

Grace notes and beaming

If two grace notes are at exactly the same position (the same tick), they are put onto the same stem, as a chord. If multiple grace notes in front of the same note are put on different positions (even if they are only one tick apart), they are grouped under a beam.

It is possible to have beamed grace notes overlapping a beam of regular notes, as in the example below:

Grace notes in the middle of a group of regular notes
Editing a grace note

**PROCEDURE**

1. Select one or several grace notes and open the Set Note Info dialog.

2. Select a note value for the stem.

3. Activate Crossed, if needed.
   
   When this is activated, the stem is crossed by a slanted line, to further indicate that the note is a grace note.

4. Click Apply.
   
   The settings are applied to the selected notes.

5. Close the dialog.

Converting grace notes to normal notes

**PROCEDURE**

1. Select the notes that you want to convert.
   
   If you want to make sure that all notes in the score are normal notes, you can select all notes (using the Select All command on the Edit menu).

2. Double-click on one of the selected grace notes.
   
   The Set Note Info dialog appears.

3. Select “Normal” from the “Type” pop-up menu.

4. Click Apply.

Tuplets

The regular Display Quantize values do not apply to any other divisions than triplets. To create quintuplets, septuplets, etc., follow the instructions below.

There are two methods for creating tuplets:

- With permanent alteration to the MIDI data. This is the “drawing” mode to use when you want to build the tuplet from scratch. It does not put any demand on the notes’ positions before the tuplet is created.
• As display quantize. This is the method you use when the tuplet is recorded and plays back as you want it, but is not displayed correctly.

Actually, in the first case, you make permanent alterations and set display quantize settings, all in one go. In the second case you only make display quantize settings.

**With permanent change to MIDI data**

**PROCEDURE**

1. Insert as many notes as the tuplet consists of.
   This would typically be 5, 7 or 9. If the tuplet contains rests, simply leave space for those, but make sure that the current Display Quantize value allows them to be shown.

   ![Five sixteenth notes, about to be converted to a quintuplet.](image)

2. Select all the notes that make up the tuplet.

   The Tuplets dialog appears.

4. Set the type of tuplet in the Type field.
   “5” means a quintuplet, “7” means a septuplet, etc.

5. Set the length of the entire tuplet using the “Over” field.

6. Activate Change Length, if needed.
   If you do, the program alters the length of all notes so that they are exactly the note value the tuplet indicates. If you do not, the lengths of the existing notes is not affected in any way.

7. If you want any other text than the standard above the tuplet, enter it into the “Text” field.
   The standard text is simply the number in the type field. If the tuplet is put under a beam the text is put just above it. If there is no beam, the text is found in the middle of a bracket.

8. Click Build.
   The tuplet appears. The notes have now been moved to the tuplet positions and their length might have changed.

9. If needed, edit the lengths and pitches of the notes in the tuplet.
   You can also make various settings for the appearance of the tuplet – see below.
Without permanent change to MIDI data

**PROCEDURE**

1. Select the notes in the tuplet group.
   In this case, the notes play back correctly but are not displayed as a tuplet (yet).
2. Select “Build N-Tuplet…” from the Scores menu to bring up the Tuplets dialog.
3. Make settings in the dialog, as described above.
4. Click Quantize.
   Now the tuplet is displayed correctly. You can make additional settings for how the tuplet should appear, as described below.
5. If necessary, adjust the notes.

**IMPORTANT**

Lengths and positions in a tuplet group are probably best edited using the info line.

Editing tuplet settings

**PROCEDURE**

1. Double-click on the text above the Tuplet group to bring up the Tuplets dialog.

![Tuplet symbol]

2. Adjust the Text setting.
3. Click Apply.
   The changes are applied to the tuplet, without affecting the tuplet type or length.

Grouping

If the Tuplet is a quarter note long or shorter, the notes are automatically grouped under a beam. If it is longer you have to perform the grouping manually.

**RELATED LINKS**

Grouping on page 1188

Tuplet display options

In the Score Settings dialog, on the Project–Notation Style subpage (Tuplets category), you can find the following settings for tuplets:
Tuplet Brackets

There are three possible settings for this option:

- None: Tuplets never have brackets.
- Always: Tuplets always have brackets.
- …by the head: Brackets are shown only when the tuplets are displayed on the “head side”.

Display Tuplet values by the Beams

When this is activated, tuplets are displayed on the “beam side” of the notes instead of on the note head side.

Suppress Recurring Tuplets

When this is activated, and you have several tuplets of the same type in the same bar, only the first of these is displayed as a tuplet.

Show Tuplet Brackets as “Slurs”

When this is activated, the tuplet brackets are “slur-like” (rounded).
About this chapter

In this chapter you will learn:

• What the different types of symbols are.
• How to insert and edit symbols.
• Details about special symbols.

Background: The different layers

A score page is always made up of three layers – the note layer, the layout layer and the project layer. When you add symbols, these are inserted into one of these layers, depending on the type of symbol. The symbols that have a relation to notes – accents, dynamic markings, slurs, lyrics, etc. – are put in the note layer. Other symbols, such as some types of text, can be inserted either on the layout layer (which is individual for each layout) or on the project layer (common for all layouts). You can change the layer type by right-clicking the symbol and selecting the layer type from the context menu.

1) Layout layer symbols
2) Note layer symbols

Note layer symbols

Let’s look at the note layer symbols first.

• Note symbols. These are each tied to a single note. Examples of note symbols are accents and lyrics. When you move the note, the symbol moves with it. The same is true if you cut the note and then paste; the symbol is cut and pasted together with the note.
Working with symbols
Background: The different layers

- Note-dependent symbols. Only a few symbols belong to this category, for example the arpeggio lines. In one way, these behave just like grace notes. They always precede a note or chord. If there is no note “after them” on a staff, they disappear.

- All other note layer symbols (tempo, dynamics, chords, etc.). Their position is related to the bar. (Whichever way you edit the notes, these symbols remain unaffected.) However, their positions are fixed within a measure. If you for example change the spacing of the bars across the page, this affects the symbols positions.

RELATED LINKS
Setting the number of bars across the page on page 1289
Grace notes on page 1200

Layout layer symbols

Now let’s examine the layout layer symbols. The layout layer is not stored individually for each track, as the other symbols are. Instead it is common to a “set of tracks”. Let's illustrate this with an example:

You have four tracks that make up a string quartet. You edit them all at the same time and add symbols to the score, both note layer symbols and layout layer symbols.

Now you close the Score Editor and open only one of the tracks for editing. All your note layer symbols are there just as you left them, but the layout layer symbols have disappeared! Don’t worry, close the editor again, and open all four tracks for editing and the symbols are back.

This is due to the fact that the layout layer symbols are part of a “bigger entity” called “layout”. And a layout is something that is stored not per track, but for a group of tracks. Each time you open the same combination of tracks for editing, you get the same layout.

RELATED LINKS
Working with layouts on page 1269

Project layer symbols

Project layer symbols are layout symbols that are present in all layouts.

Using project layer symbols in conjunction with the Arranger mode, you can have playback in the program follow the score – repeats, Da Capos, and endings are played back properly allowing you to hear your compositions as they would be played back by live players.
Why three layers?

There are several reasons for this division into layers:

- Many of the symbols that are in the layout layer can be stretched to span over several staves, or for other reasons make more sense to think of as belonging to a certain group of tracks.
- The layout layer is only one part of the bigger concept of layouts. Layouts allow you to easily extract parts from a full score and perform automatic formatting.
- Typically, you want to display some symbols – repeat bar lines, endings, score titles, etc. – for all layouts in a score. To achieve this, insert them on the project layer.

Related links
- Working with layouts on page 1269
- The available symbols on page 1210

The Symbols Inspector

To display the Symbols Inspector, click the “Set up Window Layout” button on the toolbar and activate the Symbols option.

Customizing the Symbols Inspector

You can customize the appearance of the Symbols Inspector by showing/hiding tabs and by specifying their order in the Inspector.

Showing/Hiding Symbols Inspector tabs

If you right-click on any tab in the Inspector, a context menu appears. On this menu, you can directly check (show) or uncheck (hide) elements of the Inspector as desired.

You can also select different preset configurations from the lower half of the menu. To display all Symbols Inspector tabs, select “Show All”.

The Symbols Inspector Setup dialog

If you right-click on any closed tab in the Symbols Inspector and select “Setup…” from the context menu, a dialog appears. In this dialog you can configure where the separate tabs are placed in the Inspector and save/recall different configurations of the Inspector.
Working with symbols
The Symbols Inspector

The dialog is divided into two columns. The left column displays the currently visible tabs in the Inspector, and the right column displays the currently hidden tabs.

- You can change the current show/hide status by selecting items in one column and using the arrow buttons in the middle of the dialog to move them to the other column. The changes are reflected directly in the editor.

- You can change the order of the (visible) tabs in the Symbols Inspector with the “Move Up” and “Move Down” buttons. The changes are reflected directly in the Score Editor.

A customized Symbols Inspector

- If you click the Save button (disk icon) in the Presets section, you can name the current configuration and save it as a preset.

- To remove a preset, select it and click the trash icon.

- Saved configurations are available for selection from the Presets pop-up menu in the dialog or directly from the Inspector context menu.

- To revert back to the default Inspector settings, right-click on any of the tabs and select “Default” from the context menu.
Working with symbol palettes

You can open any of the Symbols Inspector sections as separate symbol palettes.

Opening tabs as palettes

**PROCEDURE**

1. In the Symbols Inspector, open the desired symbols tab.
2. Right-click on any of the symbols of the tab. Note that you have to right-click on a symbol. Right-clicking on a tab header opens a different context menu instead.
3. Select “Open As Palette” from the context menu.

![Palettes example]

The selected tab is shown as palette.

Moving and handling palettes

Palettes are handled as any window, which means that you can:

- Move a palette to another position by dragging its title bar.
- Close a palette by clicking its close button.

In addition, you can select whether the palette is shown horizontally or vertically, by right-clicking and selecting “Toggle” from the context menu.

The available symbols

The following symbols palettes/tabs are available:

- Quick Staff Setup
- Favourites
- Keys
- Clefs
- Time Signature
- Chord Symbols
- Guitar Symbols
- Cubase Pro only: Expression Map
- Dynamics Mapping
Working with symbols
The Symbols Inspector

- Clefs etc.
- Note Symbols
- Dynamics
- Line/Trill. Note that the arpeggios, hand indication and strum symbols are all "note-dependent"!
- Other
- Form Symbols. These symbols can be selected for the note layer, the layout layer, and the project layer.
- Words
- User Symbols

When you place the mouse pointer on a symbol, a tooltip shows you information about the function.

RELATED LINKS
Expression maps (Cubase Pro only) on page 778
Working with mapped dynamics on page 1315
The Words tab on page 1264
User Symbols on page 1242
Symbol details on page 1234

Setting up the Favourites tab

In the Symbols Inspector, you can find a tab called Favourites. Cubase allows you to fill this tab with a selection of symbols from other tabs. This way, you have instant access to the symbols you use often:

PROCEDURE
1. Open the Favourites tab.
   If it is the first time you are using this tab, it is empty.
2. Open the tab from which you want to copy a symbol.

   NOTE
   Not all symbols can be placed on the Favourites tab.

3. Right-click on the symbol that you want to add to the Favourites tab and select “Add to Favourites” on the context menu.
   You can also add a symbol to the Favourites tab by [Alt]/[Option]-clicking on it.
4. Repeat this procedure for other symbols that you want to add to the Favourites tab.
   To remove a symbol from the Favourites tab, select “Remove from Favourites” from the context menu or hold down [Alt]/[Option] and click on it.
Important! – Symbols, staves, and voices

Most symbols belong to a staff when inserted. Only note symbols, slurs and ties are an exception. They belong to notes and therefore to voices.

It is extremely important that the correct staff is active when you insert a symbol (if you are editing multiple staves).

If you for example insert a symbol while the wrong staff is active, the symbol might later “disappear” because you edit another configuration of tracks (the track you actually inserted the symbol on might not be opened for editing).

The same is true for note symbols and their relation to voices. Make sure that the correct voice is active when inserting symbols or they might wind up at the wrong position, fermatas may be turned upside down, etc.

Layout symbols work slightly differently. Instead of belonging to a certain staff or voice, they belong to a layout. Since different track combinations use different layouts, this means that if you insert a layout symbol in the score when you are editing two tracks (for example a trumpet and a saxophone part), it is not there when you view each track by itself in the Score Editor. If you want the same symbols to appear in other layouts as well, you can copy the form of one layout to another. If you want a symbol to appear in all layouts, use the Project layer.

Adding symbols to the score

Making space and handling margins

- If you find there is not enough space between staves to add symbols (like for example text), you can separate the staves.
- If you find the score looks crammed after adding symbols, you can use the options in the Auto Layout dialog.

IMPORTANT

Symbols you add outside the margins are not printed!

RELATED LINKS
- Dragging staves on page 1293
- Auto Layout on page 1297

About the Draw tool

Unlike the other MIDI editors, the Score Editor toolbar does not contain a Draw tool. Instead, the Draw tool is “automatically” selected when you insert symbols. The following applies:
Working with symbols
Adding symbols to the score

- Normally, the Draw tool is automatically selected when you click on a symbol in the Inspector. However, if the “Double-Click Symbol to get Draw Tool” option is activated in the Preferences dialog (Scores–Editing page), you need to double-click the symbol to get the Draw tool.

- On the same page of the Preferences dialog, you can find an option called “Display Object Selection tool after Inserting Symbol”. When this is activated, the Object Selection tool is automatically selected after you have inserted a symbol.

If you want to insert a lot of symbols with the Draw tool, you may want to deactivate this option.

Adding note symbols

Adding a symbol to one note

**PROCEDURE**

1. In the Symbols Inspector, open the Note Symbols tab.
2. Click (or double-click) on the desired symbol on the tab.
   
   As mentioned above, the “Double-Click Symbol to get Draw Tool” preference determines whether you need to double-click. In either case, the Draw tool is selected.

3. Either click on the note or above or below it.
   
   If you click on the note, the symbol is put in at a predefined distance from the note. If you instead click “above or below” the note, you decide for a vertical position yourself. In either case, the symbol is aligned horizontally with the note. It can later be moved up/down.

   ![Example image]

   Clicking on a note inserts the note symbol (in this case a tenuto) at a predefined distance from the note head.

   There are three options in the Accents category of the Score Settings dialog (Project page–Notation Style subpage) that affect the vertical positioning of note symbols:

   - **Accents above Stems**
     
     When this is activated, accent note symbols are displayed at the stem side of notes instead of the note head.

   - **Accents above Staves**
     
     When this is activated, accent note symbols are displayed above the staff, regardless of the stem direction of the notes. This setting overrides the “Accents above Stems” option.

   - **Center Note-Linked Symbols on Stems**
     
     When this is activated, accents are centered on stems and not on note heads.
Working with symbols
Adding symbols to the score

Adding a symbol to several notes using the Draw tool

You might for example want to add a staccato symbol to all notes within a few measures.

**PROCEDURE**
1. In the Symbols Inspector, open the Note Symbols tab.
2. Select the notes to which you want to apply the symbol.
3. In the Symbols Inspector, click on the desired symbol.
4. Click on one of the notes.

![Symbol added to notes](image)

The symbol is added to each selected note, at a predefined distance. The symbols can be moved later.

Adding a symbol without tying it to a note

Note-dependent symbols can be entered freely, too. This allows you to add a fermata to a rest symbol for example.

**PROCEDURE**
1. Make sure that the correct staff is active.
2. Click the symbol so that the Draw tool is selected, as described above.
3. Hold down [Ctrl]/[Command] and click where you want to add the symbol.

Adding other symbols

**PROCEDURE**
1. In the Symbols Inspector, open the desired symbol tab.
2. Click on the symbol that you want to add.
3. Click once or click and drag somewhere in the score.

The symbol appears. For many symbols with a length, you can drag to set the length of the symbol directly. The symbol appears with its handles selected (if it uses handles) so that you can change its size directly if you wish.

![Symbols with handles](image)

Press the mouse button – drag – and release!

You can change the size of most of the note symbols and dynamics in a score by right-click on the corresponding object and selecting the desired option from the Size submenu on the context menu.
About note-dependent symbols

Note-dependent symbols like arpeggios and strum directions must be put in front of a note or they belong to the following note instead (if there is no following note, the symbols are not inserted at all).

Adding text

There are special methods for working with text.

Adding slurs and ties

Slurs can be drawn in manually or inserted automatically for a group of notes. Ties are usually added by the program but can also be drawn in as "graphic" symbols.

NOTE

There are two types of slurs – “regular” slurs and Bezier slurs (with which you have full control over thickness, curve shape, etc.).

Slurs, ties, and the Display Quantize value

Since a slur or tie “musically” always spans from one note (or chord) to another, the beginning and end of a slur/tie in Cubase is always related to two notes in the score.

When you draw in a tie or slur, the program uses the Quantize value to find the closest two notes to “attach” the symbol to. In other words, if you want to add the slur/tie to a note at a sixteenth note position, make sure Quantize is set to 1/16th notes or smaller (this is only true for manual drawing in of slurs and ties).

Please note that this does not necessarily mean that the symbol has to start or end exactly above/below two notes. Instead, what it means is that when you use the Layout tool to move the note graphically to adjust the look of the bar, the slur/tie moves with it. The same is true if you adjust the width of the measure – the slur/tie is adjusted accordingly.

NOTE

If you want the end points of the slurs to snap to exact note positions, activate the “Snap Slurs when dragging” option on the context menu or in the Preferences dialog (Scores–Editing page).
Drawing the slur/tie

PROCEDURE
1. Set the Quantize value depending on the positions of the two notes that the slur/tie should span.
   For example, if one of them is at a quarter note position and the other at an eighth note position, set Quantize to 1/8 note or a smaller note value.
2. Click on the correct slur/tie in the Symbols Inspector, so that the Draw tool is selected.
3. Position the mouse close to the first note and drag to a position close to the second note.
   The end points of the slur/tie snap to their default positions – holding down [Ctrl]/[Command] allows you to move the end points freely.
   There are two special functions for inserting a slur or tie that automatically spans from one note to another.

Adding a slur/tie between two notes

PROCEDURE
1. Select two notes.
2. Click the correct slur/tie symbol in the Inspector, so that the Draw tool is selected.
3. Hold down [Ctrl]/[Command] and [Shift] and click on one of the two notes.
   The slur/tie is added between the two selected notes.

Inserting a slur over a selection of notes

PROCEDURE
1. Select a span of notes.
2. Open the Scores menu and select “Insert Slur”.
   A slur is created, starting at the first selected note and ending at the last.
The Bezier slur

The Bezier slur is a special slur symbol, found on the Dynamics symbol tab. Unlike the regular slur, this symbol is made up of a bezier curve, allowing you to create more advanced curve shapes.

To add a Bezier slur, click on the symbol in the Inspector so that the Draw tool is selected, and click or drag in the score. Clicking creates a Bezier slur of the default length and shape, while dragging creates a straight line.

The default Bezier slur has four curve points – one at each end and two along the curve.

- To move the slur, click on it (but not on a curve point) and drag.
- To resize the slur, click and drag the end points.
- To change the shape of the slur, click on one of the middle curve points and drag in any direction.

Right-clicking on a curve point brings up a context menu with the following options:

Add Points/Reduce Points

Adds another pair of curve points to the Bezier slur. This allows you to create very complex slur shapes. After adding points, there is an additional menu item “Reduce Points” – selecting it removes the additional curve points.

Add Thickness

Makes the Bezier slur thicker.

Reduce Thickness

Makes the Bezier slur thinner.

Hide

This hides the slur symbol.

RELATED LINKS

Hiding/showing objects on page 1283
Creating trills

If you have recorded or entered a trill, Cubase can help you display this properly:

**PROCEDURE**

1. Select the notes that make up the trill.
2. Right-click on one of the notes and select “Build Trill…” from the context menu.
3. Select an option from the dialog that appears.
   - The radio buttons determine how the trill should look. Activate the “Help Note” option if you want an extra note to indicate between which notes the trill should be played.
4. Click OK.

**RESULT**

- All notes except the first one (and possibly the second) are hidden.
- The first note automatically gets a display length matching the length of the whole trill.
- If you choose to include a help note, the second note is converted to a “Graphic” note, with brackets but without stem. Otherwise, the second note is hidden, too.
- The trill symbols you selected in the dialog are inserted.

![Trill Symbol](image)

**Inserting symbols across staves**

If you hold down [Alt]/[Option] while adding a symbol to one staff in a grand staff, this symbol is put in at corresponding positions on all staves. This allows you for example to insert rehearsal marks, repeats, etc. for all instruments at the same time.

**Adding a keyboard symbol**

The Other tab contains a piano keyboard symbol, useful in educational scores, for example. The symbol has the following properties:
• To insert the keyboard symbol, select it from the Inspector, click with the Draw tool at the desired position and drag a box to specify the approximate size of the keyboard.

• After you have inserted the keyboard symbol, you can drag its edges to resize it vertically or horizontally.

• If you right-click on an inserted keyboard symbol and select “Properties” from the context menu, a dialog opens allowing you to specify further properties for the symbol. You can also double-click on an inserted keyboard symbol to open this dialog.

![Edit Keyboard dialog]

Size
Govern the width of the keys.

Start Note
This is the leftmost note in the keyboard symbol.

Show Note Names
When this is activated, each C key is displayed with note name and octave (C1, C2, etc.).

White/Black Keys transparent
Activate these if you want the white and/or black keys to be transparent.

Adding guitar chord symbols

A fretboard symbol of a guitar chord can be inserted anywhere in the score.

Guitar symbols are found on the “Guitar Symbols” tab and the Other tab in the Symbols Inspector.

• The Guitar Symbols tab contains all Guitar symbols of the current guitar library. If the symbol that you want to insert is among these, select it and insert it as you would any other symbol, see above.
To insert a guitar symbol not present in the guitar library, proceed as follows:

**PROCEDURE**

1. Open the other tab.
2. Click on the guitar chord symbol, so that the Draw tool is selected.
3. Click in the score, at the position where you want the symbol to appear. The Guitar Symbol dialog appears.

- To put a black dot on any fret and string, click on it.
  
  To remove it, click again.

- To add a symbol just above the string, outside the fretboard, click there. Consecutive clicks allow you to select between a ring (open string), a cross (do not play this string) and no symbol.

- To add a capodaster number, click to the left of the symbol. Consecutive clicks allow you to step through the possibilities.

- You can also add a capodaster symbol (a line over the strings), by setting the “Capo String” parameter to a value higher than 0.
  
  By adjusting the Capo End and Start values, you can create capodaster symbols that span fewer strings.

- Use the “Size” value field to adjust the size of the chord symbol.

- If you want the symbol to be horizontal, activate the “Horizontal” checkbox.

- To display more or fewer frets than the default six, change the “Frets” value.

4. Click Apply.

The guitar symbol appears in the score.

- Clicking the Insert Notes button inserts the actual notes in the chord into the score.
  
  You can also right-click on a guitar symbol and select “Insert Notes” from the context menu.

  You can edit the symbol at any time by double-clicking it, changing the settings in the dialog and clicking Apply. Note that you can also access the symbols that you defined in the guitar library by right-clicking a guitar symbol – see below.

**NOTE**

If you select “Make Chord Symbol” from the context menu, the corresponding chord symbol is displayed above the guitar symbol. This function is very useful when writing lead sheets, for example.
Using the guitar library

The above method is fine if you only want to add a few chord symbols to your score. If you need a lot of chord symbols, or if you are using chord symbols in a lot of different scores, you can gather all your chord symbols in a “guitar library” instead. This way you do not have to recreate the same chord symbol over and over again.

Defining chord symbols

**PROCEDURE**

1. In the Symbols Inspector, double-click on one of the symbols on the Guitar Symbols tab to open the guitar library.
   Alternatively, you can open the Score Settings dialog on the Project page and select the “Guitar Library” subpage.

2. To add a guitar chord symbol to the library, click the New button. A chord symbol appears in the list to the left.

3. To edit the chord symbol, double-click it in the list. This opens the Guitar Symbol dialog, as when editing a chord symbol in the score.
   - The symbol you create is also “interpreted” and its name is displayed to the right of the fretboard symbol.
     This can also be edited by double-clicking if you like.
   - To sort the available symbols in the library according to their root notes, click the Sort button.
   - To remove a symbol from the library, select it in the list and click Remove.
   - To save the current library as a separate file, select “Save…” from the Functions pop-up menu.
     A file dialog appears, allowing you to specify a name and location for the file.
To load a guitar library file, select “Load Current Pane…” from the Functions pop-up menu. In the file dialog that appears, locate and open the desired guitar library file.

**IMPORTANT**

Loading a guitar library file replaces the current library!

There are also two additional checkboxes in the Guitar Library dialog:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use for Make Chord Symbols</td>
<td>When this is activated, and you use the “Make Chord Symbol” function, the program inserts guitar symbols as well as regular chords (if any fitting guitar symbols can be found). If there are several guitar symbols for a certain chord in the guitar library, the first one is used.</td>
</tr>
<tr>
<td>Small Display</td>
<td>If this is activated, the chord symbols in the list is displayed in the size they get in the score. If it is deactivated, the symbols are displayed in a larger size, for easier editing.</td>
</tr>
</tbody>
</table>

**RELATED LINKS**

Using Make Chord Symbols on page 1248

**Inserting symbols from the library**

Apart from the “Use for Make Chord Symbols” option above, there are two ways to insert symbols from the guitar library into the score:

- Use the Functions pop-up menu on the Project–Guitar Library subpage in the Score Settings dialog, when creating or editing guitar symbols.
- Right-click on a guitar symbol in the score and select a chord symbol from the Presets submenu on the context menu.

**Adding an image file**

You can insert image files as symbols into the Score. This allows you to import logos, copyright symbols, images of finger positions, etc.

**PROCEDURE**

1. In the Symbols Inspector, open the Other tab.
   Image files can be inserted on all three layers.
2. Click the Image File button to select the Draw tool. Click in the score at the position where you want to insert the file. A file dialog opens.

3. Locate and select the image file you want to insert. The lower section of the Import dialog contains the following settings:
   - To copy the referenced file into the Project folder, activate the “Copy to Project folder” option. This is recommended as it makes it easier to manage all files used in a project.
   - If you modify your score, by adding staves for example, the position of an inserted image file changes. If this is not what you want, activate “Stick to Page” to keep it at a fixed position in your staff.
   - The Transparency parameter allows you to set the desired transparency of the image.

4. Click Open to insert the file.

RESULT

The image file is inserted. Its size depends on the printer resolution. However, you can scale the image by dragging its handles. To restore the printer resolution, right-click on the image to open the context menu and select “Snap to Printer Resolution”.

You can modify the settings you made on import by right-clicking the image and selecting “Properties” on the context menu, to open the Image Properties dialog.

RELATED LINKS

Background: The different layers on page 1206

Using layout symbols

Layout symbols and texts are inserted on the layout layer. When you are editing a layout containing several tracks, you can have inserted layout symbols and texts automatically copied to any combination of tracks in the layout. You decide which staves should display layout symbols and texts by ticking their “L” column in the Score Settings dialog, on the Layout page.
Working with symbols

Selecting symbols

- Any editing you perform to layout symbols and texts is automatically duplicated in the other tracks.
- The display of layout symbols and texts for different tracks can be deactivated at any time.
- Layout symbols and texts can be copied between layouts, by using the Get Form function on the Functions pop-up menu on the Layout page of the Score Settings dialog.

One example of how to use layout symbols and texts:

Let’s say you are editing a full orchestra score, and want rehearsal marks inserted for more than one staff (typically, above each instrument group – brass, strings, percussion, etc.). Now all you need to do is insert the rehearsal marks for one of the tracks. To do so, open the Score Settings dialog on the Layout page, tick the “L” column for the desired tracks/staves, and click Apply.

Using Project symbols

Project symbols are part of the project layer and therefore appear in all layouts. The project layer also contains changes to bar lines (e.g. repeats and double bar lines) and bar number offsets. Typically you use Project symbols when you know you want these shown for all combinations of tracks.

**NOTE**

You can also use Project symbols in combination with the Arranger mode to have the program play back according to the score, e.g. repeats, Da Capos and endings.

**RELATED LINKS**

Scores and the Arranger mode on page 1314

Selecting symbols

Almost all symbols can be selected by clicking on them. For symbols that have a length or size, one or more handles appear.
Working with symbols
Selecting symbols

A selected crescendo

An exception to this are the slurs and ties which can be selected by clicking on the end points or by drawing a selection rectangle.

Using the lock layers

Sometimes it can be very hard to click on a symbol or other object in the score without accidentally selecting other symbols nearby. To remedy this, you can assign different types of objects to different “lock layers” (up to three) and instruct Cubase to “lock” one or two of these layers, making them “unmovable”. Furthermore, you can lock the layout and project layers separately if needed.

Setting up the lock layers

PROCEDURE

1. Open the Preferences dialog and select the Scores–Note Layer page.

![Scores-Note Layer](image)

2. Assign each event type to a layer (1, 2, or 3).
   It is a good idea to specify different layers for event types that might conflict "graphically". For example, you might want to assign bar numbers and note symbols to different layers, if you find that you accidentally move bar numbers when editing note symbols and vice versa.

3. Click OK to close the dialog.
   Alternatively, you can right-click on one of the Layer buttons (1-2-3) on the extended toolbar to bring up a pop-up menu, showing which object types are associated with that layer.

![Layer](image)

A checkmark for an object type means it belongs to that layer. If no checkmark is shown, you can select the object type from the pop-up menu to move it to that layer.
Locking a layer

To “lock” a layer, click on its lock layer button.

![Layer Lock Button](image)

In this figure, layer 2 is locked. Event types assigned to layer 2 cannot be selected, moved, or deleted.

Visual indication of the layers

Objects belonging to locked note layers are “grayed out” in the score. This makes it very easy to find out which object belongs to which layer – perhaps especially useful for the layout and project layers. For example, to quickly spot all objects in the layout layer, lock all other layers by clicking their buttons. Now, only layout layer objects are shown normally; all other objects are grayed out.

Moving and duplicating symbols

There are four ways to move and duplicate symbols:

- By dragging them with the mouse (see below).
- By using the computer keyboard (moving only).
- By using the bar handles.
- By using the Paste Attributes function (duplicating note symbols only).

**Related links**

- Moving by using the computer keyboard on page 1229
- Moving and duplicating with the bar handles on page 1229
- Copying settings between notes on page 1188

Moving and duplicating by using the mouse

This is done much as with other objects in Cubase. The following rules apply:

- Note symbols and note-dependent symbols move with the notes/chords they belong to. In other words, if you move the note/chord, the symbols move with it/them.
- Note symbols (like accents and lyrics) can only be moved vertically. Other symbols (like braces and brackets) can only be moved horizontally.
- All other symbols without handles can be moved freely. If you hold down [Ctrl]/[Command], movement is restricted to one direction only.
- If the symbol has one or more handles when it is selected, do not drag it by the handles, or you change its shape instead of moving it.
• Slurs and ties are an exception, as they can only be moved by first dragging one handle and then the other. However, if you use the Layout tool to move the notes they belong to, or if you change the measure width, they are adjusted automatically.

• Duplicating is done by moving with [Alt]/[Option] pressed, as always in Cubase. Slurs, ties, and bar lines cannot be duplicated with this method.

There are two features to help you position symbols (and other score objects) correctly: the rulers and the Position Info window.

RELATED LINKS
Graphic moving of notes on page 1198

The rulers

Unlike other editors, the Score Editor does not have a meter/time position-based ruler. Instead, its rulers are “graphical”, i.e. they indicate the actual x-y position of objects (with “zero” at the upper left corner).

- The current pointer position is indicated by thin lines in the rulers.
- To hide the rulers, right-click on a ruler and select “Off”. This pop-up menu can also be found above the scrollbar at the far right.
- To display the ruler again, open the pop-up menu above the scrollbar at the far right and select one of the units (inches, centimeters, or points). This setting also affects the units used in the Position Info window (see below).

The Position Info window

If you need to fine-tune the graphical positions of symbols and other objects, you should use the Position Info window. This makes positioning easier in two ways:

- You get a numerical indication of the exact position of the mouse pointer (and any object you are dragging).
- You can move objects or staves by typing in position values.

You display the Position Info window by clicking in the ruler.
The window contains the following settings and values:

**Measure in**
Click this label to change units for the Position Info window. You can toggle between Inch, cm, and pt. This choice also affects the units used in the rulers.

**Abs. Pos./Rel. Pos**
Click this label to select whether X-Y position values are “absolute” (referring to the upper left corner of the current page) or “relative” (referring to the upper left corner of the active staff).

**X, Y**
When a single object is selected, these values show the horizontal and vertical position of this object.
When no objects or several objects are selected, these values show the current horizontal and vertical position of the pointer.
When a single object is selected, you can click on these values and type in a new position for the object.

**dX, dY**
When you are moving an object, these values indicate the horizontal and vertical distance you have moved it.
You can click and type in values to move the object(s) by the specified distances.

**Sel. Staff**
If “Abs. Pos” is selected (see above), this value shows the distance from the top of the score page to the top of the active staff.
You can click and type in a value to move the active staff. If “Rel. Pos” is selected, this value is always 0, since vertical positions are related to the top of the active staff!

**To Prev Staff**
The distance between the active staff and the staff above it. Clicking and typing in a value moves the active staff.

**To Next Staff**
The distance between the active staff and the staff below it. Clicking and typing in a value moves the staves below the active staff.

### Dragging symbols across staves

If you drag a symbol across the staves, you can see how the “active staff” indicator to the left follows the mouse pointer. Use this as an indication to make sure that symbols end up in the correct staff.

- If you are editing several tracks at the same time, and want to make sure that a symbol is not accidentally moved to another track when you drag it vertically, activate the Lock “L” button on the extended toolbar.
When this is activated, you cannot move symbols across staves by dragging.

Moving by using the computer keyboard

In the Key Commands dialog, you can assign key commands for moving symbols, notes, or rests graphically. The commands are found in the “Nudge” category and are called “Graphical Left”, “Graphical Right”, “Graphical Top”, and “Graphical Bottom”.

Selecting an object and using one of these commands is the same as dragging them with the Layout tool, but this method offers higher precision.

Moving and duplicating with the bar handles

This function allows you to move or copy the contents of a whole bar to one or several other bars. You can select which elements in the bar will be included in the operation.

PROCEDURE

1. Make sure that the filter bar is visible.
   If the filter bar is not visible, click the “Set up Window Layout” button on the toolbar and activate the Filters option.

2. On the filter bar, make sure that the “Bar Handles” option is activated.
   Now, each bar in the score is shown with a handle in the upper left corner.

3. Double-click on the handle of the bar from which you want to copy or move symbols.
   The Bar Copy dialog appears.

4. Make sure that only the symbol types that you want to move/copy are checked.
5. If you have several subsequent bars to which you want to copy symbols, set the “Repeats” value to this number of bars.
   If you only want to copy symbols from one bar to another, make sure that “Repeats” is set to 1. This option is only available for copying, not for moving.

6. If you want this dialog to appear every time you perform the move/copy operation, activate “Show Dialog”.

7. Click OK to close the dialog.

8. To copy the specified event types to another bar, hold down [Alt]/[Option], click on the bar handle of the first bar and drag it to the “target” bar.
   To move the event types instead of copying them, drag the bar handle without holding down [Alt]/[Option].
   If you activated “Show Dialog”, the Bar Copy dialog appears, allowing you to confirm your settings.
   Click OK to close the dialog and perform the operation.

RESULT

If you activated “Note Symbols”, the note symbols are copied from the “source” bar and pasted onto notes at the same positions in the “target” bar. If there is a note symbol for a certain note in the “source” bar, but no note at the corresponding position in the “target” bar, the symbol is ignored.

The actual positions of notes are used as a basis for this operation – not the displayed positions.

If you copy the note symbols from the first bar to the second bar…

…only symbols that find corresponding note positions in the second bar are copied.

- If you activated other types of symbols, these are simply moved to the same graphical position in the “target” bar.
- If you set “Repeats” to a number larger than 1, the same symbols are pasted into that number of bars (starting from the one you drag the bar handle to).
- If you do not hold down [Alt]/[Option] when dragging the bar handle, the symbols (and other event types specified in the dialog) are removed from the “source” bar.

IMPORTANT

If there already are symbols (or other objects) of the specified types in the “target” bars, these are removed.
**Moving note symbols**

Note symbols, slurs and ties all have “default positions”. This determines the vertical distance between the note head(s) and the symbol.

- You can manually adjust the vertical positions of individual symbols, but if you move or transpose their notes, the symbols are automatically reset to their default positions.
  
  This also ensures that note symbols and slurs are positioned sensibly when you change the Display Transpose settings.

- To reset the vertical positions of note symbols and slurs in a score, right-click on the corresponding object and select “Default position” from the context menu.

**Changing length, size, and shape**

You can change the shape of any symbol that has a length.

**Changing the length of a symbol**

**PROCEDURE**

1. Select the symbol.
   - The handles appear.
   - Symbols with a length have two handles when selected.
2. Drag one of the handles.
   - You may be restricted to vertically or horizontally only, depending on the type of symbol.

**IMPORTANT**

In the Preferences dialog (Scores–Editing page), there is a preference called “Keep Crescendo Symbols Horizontal”. When this is activated, crescendo and diminuendo symbols are never slanted.

**Resizing note symbols and dynamics**

**PROCEDURE**

1. Right-click on a dynamic or note symbol.
2. Select the desired option from the Size submenu.
Altering the shape and direction of slurs and ties

This section describes how to alter the “regular” slur and tie symbols.

There are two types of slurs and ties in the Symbols Inspector. The up/down variation of each actually represent the same symbol but with different initial direction. You can perform the following editing to slurs and ties:

- By dragging the middle handle up/down and left/right you can change the shape of the curve.

- By selecting a slur or a tie and clicking the “Flip” symbol on the extended toolbar or by selecting “Flip Position” on the context menu, you can change the direction and positioning of the slur or tie.

Actually, there are three “modes” for a slur or tie. You step through these three modes by clicking the button.

- By dragging the end points of a slur or tie, you can change its shape without affecting its “relation” to the notes it belongs to.

In other words, the end point of the slur/tie keeps its relative distance to that note when the note is moved with the Layout tool or when the measure width is adjusted.

- By holding down [Ctrl]/[Command] and dragging the end points of a slur or tie, it can be detached from the notes it belonged to.

**NOTE**

To restore the default shape of a symbol, right-click on it and select “Default position” from the context menu.
Working with symbols
Deleting symbols

To change the default shape and spacing of slurs and ties, open the Score Settings dialog on the Project–Spacings subpage and edit the “Slur’s Start & End Distance from Note Head” and “Slur’s Middle Distance from Note Head” settings.

These settings are used for all new slurs and ties you create, as well as for all existing slurs for which you have not manually changed the shape.

**RELATED LINKS**
The Bezier slur on page 1217
Moving note symbols on page 1231

Deleting symbols

This is done as with all other objects in Cubase, either with the Erase tool or by selecting it and pressing [Delete] or [Backspace].

Copy and paste

All symbols except those on the Layout and Project layers can be copied and pasted just as any other object in Cubase. The following applies:

- Symbols that were tied to notes (e.g. accents) become “free-floating” objects when pasted.
  That is, they are not tied to any note any more. If this is not what you want, consider copying with the bar handles.

**RELATED LINKS**
Moving and duplicating with the bar handles on page 1229

Alignment

Symbols can be aligned as in drawing programs.

**PROCEDURE**
1. Select all objects that you want to align.
2. Open the Scores menu and select an option from the Align Elements submenu.
IMPORTANT

Note symbols like staccato and accents can only be aligned horizontally.

The “Dynamics” option is a special function for aligning dynamic symbols.

RELATED LINKS

- Aligning dynamics on page 1237

Symbol details

This section further describes some of the symbol tabs.

The Quick Staff Setup tab

This tab combines the basic settings for Display Quantize, staff mode, as well as staff presets for quick access.

RELATED LINKS

- Display Quantize values on page 1156
- Setting up the voices on page 1165
- About the polyphonic presets on page 1167
The “Clefs etc.” tab

Clefs
You can insert a clef symbol anywhere in the score. This has an effect on the notes, just as the first clef on the staff has. And just as with the first clef, the type is selected from the Edit Clef dialog that appears when you select the Clef symbol and click in the Score.

When you double-click on an existing clef, the Edit Clef dialog appears again, allowing you to change the type. When you right-click on a clef, you can change the type from the context menu.

Keys
Inserting a key change is similar to inserting a new clef (see above).

NOTE
In the dialog that appears when you insert a key change, you can also insert Display Transpose changes.

Time signatures
You can insert a time signature symbol at the beginning of any bar. Inserting a new time signature inserts a change on the signature track.

When you select the Time Signature symbol and click in the score, the Edit Time Signature dialog opens, allowing you to specify the time signature. When you double-click on an existing time signature symbol, the same dialog appears, allowing you to change the type. When you right-click on a time signature, you can change the type on the context menu.

- You can select a font and size for time signatures in the “Font Settings” subpage of the Score Settings dialog (Project page).
  The default font for this is the included “Steinberg Notation” font.

RELATED LINKS
Inserting and editing clefs, keys, or time signatures on page 1148
Setting clef, key, and time signature on page 1106
Editing the key on page 1111
Editing the time signature on page 1107

The Dynamics tab

There are dynamic symbols ranging from ffff to pppp, plus “special” dynamic symbols such as sforzando, fortepiano, etc.

- By selecting a dynamic symbol and clicking the “+” and “-” buttons on the extended toolbar, you can quickly edit dynamics in the score.
Use this feature to step between pppp, pp, p, mp, mf, f, ff, fff, and ffff.

- You can also right-click on a symbol and select “One up” or “One down” on the context menu.

As above, these commands can be used to step between pppp, pp, p, mp, mf, f, ff, fff, and ffff.

- To change the size of a dynamic symbol, right-click on it and in the context menu, select an option from the Size submenu.

- In the Line/Trill tab you can find a line symbol which allows you to create the following type of change in dynamics:

```
ppp  ______________ ff
```

**Crescendo and diminuendo (decrescendo)**

In the Dynamics tab, there are three kinds of crescendo symbols: regular crescendo, regular diminuendo and a “double” crescendo (diminuendo–crescendo).

- To insert a crescendo (<) or diminuendo (>) symbol, select the corresponding symbol from the tab and drag from left to right.

- If you draw a crescendo symbol from right to left, the result is a diminuendo symbol, and vice versa.

- To insert a crescendo-diminuendo (<>) symbol, select the double crescendo symbol from the tab and drag from left to right.

- To insert a diminuendo-crescendo (><) symbol, select the double crescendo symbol from the tab and drag from right to left.

- When you have inserted a crescendo or diminuendo symbol, you can move it and resize it by dragging its handles.

- The “dynamic crescendo/diminuendo” symbol (p < f) is special in that it actually affects the velocity of the notes as they are played back.

- If the “Keep Crescendo Symbols ‘Horizontal’” option is activated in the Preferences dialog (Scores–Editing page), crescendo/diminuendo symbols are never slanted when you draw them, but stay horizontal.

  Also, this option prevents you from accidentally dragging an endpoint up or down when moving the symbol.

- It is also possible to “flip” crescendo symbols, by selecting the option in the context menu or by clicking the Flip button on the extended toolbar.

**RELATED LINKS**

- Working with mapped dynamics on page 1315
Aligning dynamics

There is a special command for aligning dynamic symbols (including crescendos) horizontally. Unlike the regular align function, aligning dynamics takes the "baseline" of the dynamic letters into account, aligning them as text rather than as graphic symbols.

PROCEDURE
1. Select the dynamic symbols that you want to align, e.g. pp and a crescendo.
2. Right-click on a selected symbol and select the “Align” function on the context menu.
   This aligns all selected dynamics (except slurs and bezzers) horizontally.
   You can also align the dynamic objects by opening the Scores menu and selecting “Dynamics” from the Align Elements submenu.

RELATED LINKS
   Alignment on page 1233

The Line/Trill tab

Octave Symbols

The octave symbols (8va and 15va) act as a “local display transpose” – they shift the display of the score one/two octaves down.

- By dragging the end of the dotted line, you can specify exactly which notes are affected by the octave symbol.
  Only notes beneath the dotted line are display transposed.

- You can also right-click on the octave symbol and select the “Extend (+)” or “Reduce (-)” command to extend it to the next chord or to reduce it.

RELATED LINKS
   Transposing instruments on page 1114

Tuplet group symbols

These are "graphical" tuplet group symbols, as opposed to the “real” tuplets.

- After inserting a tuplet group symbol, you can double-click on its number and enter any number from 2 to 32.
• In the Score Settings dialog (Project page–Notation Style subpage) you can specify globally how tuplets are displayed.
You can also select a font and size for the tuplet numbers in the Font Settings subpage.
• You can also right-click on the tuplet group symbol and select the “Extend (+)” or “Reduce (-)” command to extend it to the next chord or to reduce it.

Vertical symbols

The vertical symbols in the Line/Trill tab are “note-dependent”. This means that they must be inserted in front of a note.

RELATED LINKS
Note layer symbols on page 1206
Grace notes on page 1200

The Other tab

RELATED LINKS
Working with text on page 1251
Inserting chord symbols on page 1246

Pedal down and up symbols

When you insert a Pedal down or up symbol, you also insert an actual MIDI event (damper pedal, control change 64) at that position. Similarly, inserting or recording a damper pedal event in another editor displays a pedal down/up symbol in the score.
• If the “Hide Pedal Markers” option is activated in the Score Settings dialog, Project–Notation Style subpage (Miscellaneous category), all pedal markers are hidden.
Use this if you have recorded a lot of damper pedal messages, but do not want these to show in the score (for example if you are writing for an instrument other than piano).
A pedal down/up symbol combination can be displayed as “Two Symbols”, “Ped.” + Bracket” or as “Bracket only”. Just right-click on the pedal symbol and choose an option from the context menu. You can also set this in the Score Settings dialog, on the Project–Notation Style subpage (Miscellaneous category).

Repeats

Repeat signs (one and two bars) have a special feature: if you hold down [Shift]-[Ctrl]/[Command] when entering them, notes in the bars they relate to are automatically hidden.

RELATED LINKS
Hiding/showing objects on page 1283

Box (rectangle) symbol

This is a “generic” box symbol, which may be useful for different purposes. If you double-click on a box, a dialog opens in which you can specify whether the box is transparent or not, and whether the border is visible. This dialog can also be opened by selecting “Properties” from the context menu.

The box symbol is available on the “Other” and “Layout” tabs.

The keyboard symbol

The Other tab contains a piano keyboard symbol, useful in educational scores, for example.

RELATED LINKS
Adding a keyboard symbol on page 1218

Additional symbols

If you click the “Other Symbol” button and then into the score, the “Select Symbol” dialog opens. Here you can choose note heads, accidentals and rests that work only as drawing elements, i. e. they do not insert any note data into the track. They do not affect MIDI playback! You can set the desired symbol font size directly in the Font Size field.
The Form Symbols tab

Rehearsal marks

The following types of rehearsal marks are available: numbers and letters.

When you place the first of these in the score, it is labeled 1 or A (depending on which you choose on the tab), the second is then automatically labeled 2 or B, the next 3 or C, etc. If you delete one, the labeling of the others is shifted automatically so that they always make up a complete series of numbers or letters.

- You can select a font and size for rehearsal marks on the Project Text tab of the Project–Font Settings subpage in the Score Settings dialog.
  Use the Frame option to add a box or an oval around the rehearsal mark.

- Rehearsal marks can be added automatically at the start position of each Marker in the project with the “Marker track to Form” function.

Da Capo and Dal Segno symbols

The “D.C.”, “D.S.”, and “Fine” symbols provide a quick way to insert some common play directions into the score. The symbols are text symbols – you can adjust which font is used on the Project page (Font Settings subpage) of the Score Settings dialog.
• To have these symbols actually affect playback, insert them on the Project layer and use the Arranger mode.

RELATED LINKS
Settings for other fixed text elements on page 1268
Scores and the Arranger mode on page 1314

Endings

There are two types of endings, closed ("1") and open ("2"). Both can be stretched to any length or height by dragging the handles. You can also double-click or right-click the existing number and enter any text you like.

You can insert endings in all layers. Which one to choose depends on the score; while it is handy to insert endings once and for all as Project symbols, this does not allow you to make individual adjustments for the different parts.

• You can right-click an ending symbol and select the “Extend (+)” or “Reduce (-)” command to extend the symbol to the next chord or to reduce it.

Tempo Indicator symbol

This symbol allows you to insert the current tempo according to the tempo track. In other words, to make this symbol display a certain tempo, insert the value on the tempo track.

Normally this symbol shows the number of beats (quarter notes) per minute, but if you double-click or right-click it, you can select any note value. The number then changes accordingly.

Tempo change according to note values symbol

This symbol allows you to specify a tempo change as a change from one note value to another. The example above would mean “lower the tempo by a third”.

To change the note value for either symbol, double-click or right-click it and select the desired note value from the context menu.
User Symbols

The User Symbols tab lets you create your own graphic symbols and use these in the score.

Creating a user symbol

Initially, the User Symbols tab is empty. To create symbols you use the User Symbols editor:

PROCEDURE
1. Double-click on the empty symbol field on the tab.
   The User Symbols editor opens. You can also right-click on an empty symbol field and select “Edit…” to open the same dialog.

2. Open the Functions pop-up menu and select the desired zoom factor from the View submenu.
   Often you want to work at a reasonably high zoom factor when drawing and editing symbols.

3. Use the tools and functions to draw a symbol.
   The available tools are listed in the table below.
   When you are finished, you can close the editor and insert the symbol into the score, or you can create more symbols:

4. Select “New Symbol” from the Functions pop-up menu.
   An empty symbol field appears in the section to the left of the drawing area – this section corresponds to the actual User Symbols tab, showing all symbols that you have created.

5. Click the new empty symbol field on the left to make sure that it is selected.
   The drawing area is cleared.

6. Continue creating new symbols this way.
• You can edit existing symbols at any time by selecting them to the left and using the tools and functions. Any changes you make are automatically stored in the User Symbols tab for the project. You can also export symbols for use in other projects, see below.

• To insert a user symbol into the score, click on it on the tab and then click at the desired position in the score.

The User Symbols editor – tools and functions

The toolbar contains the following tools and settings, from left to right:

Object Selection
Use this to select objects – press [Shift] to select more than one. Click and drag to move objects – press [Ctrl]/[Command] to drag vertically or horizontally only or press [Alt]/[Option] to copy.

To delete an object, select it and press [Backspace] or [Delete].

Line
Draws a straight line.

Rectangle
Creates a rectangle. You can fill this with the Fill button if needed.

Polygon
Creates a polygon – click where each corner of the polygon should be and close the figure by clicking outside the drawing area.

Circle
Creates a circle. You can fill this with the Fill button if needed.

Ellipse
Creates an ellipse. You can fill this with the Fill button if needed.

Arc
Creates an arc.

Text
Allows you to insert text objects. Clicking with this tool in the drawing area opens a dialog where you enter the text, specify font, style, etc.

You can double-click on a text object you have inserted to change its text or settings.

Symbol
Clicking with this tool brings up a dialog where you can select any of the existing score symbols and incorporate this (at the desired font size) into your own symbol.
Set Color of Frame
When this is selected, the Color pop-up menu is used to select the color for
the object frame.

Set Color of Fill
When this is selected, the Color pop-up menu is used to select the fill color
for objects (if Fill is selected).

Fill
Click this if you want the object to be filled — you can then select a Fill Color
for it from the Color pop-up menu.

Don't Fill
Click this if you do not want the object to be filled.

Color
Selects Frame or Fill Color for objects. The “Select Colors…” menu item
brings up a standard color dialog.

Line Width
Allows you to change the line width used for the selected object.

The Note Linked pop-up menu lets you create symbols linked to note positions. This
affects the whole symbol, not a selected graphic object:

Not Linked
The symbol is not linked to notes.

Linked/Left
The symbol is linked to a note, appearing to the left of the note.

Linked/Center
The symbol is linked and centered to a note.

Linked/Behind
The symbol is linked to a note, appearing to the right of the note.

The Functions pop-up menu contains the following items (some of these can also
be accessed on the context menu for the User Symbols tab):

New Symbol
Adds a new empty symbol to the tab (and to the symbol list to the left in the
editor).

Delete Symbol
Deletes the current symbol from the tab.

Export User Symbols…
Allows you to save the current tab with all available symbols as a separate file
on disk.
Import User Symbols…
   Loads settings for a complete tab from disk. Note that this replaces the
current settings.

Export/Import Symbol…
   Lets you save or load individual symbols to/from disk. Importing a symbol
replaces the current symbol on the tab.

Delete
   Deletes the selected object(s).

Select All
   Selects all objects in the current symbol.

Transform – Scale Symbol
   Lets you scale (resize) the selected object by specifying a percentage.

Transform – Mirror horizontal/vertical
   Mirrors the selected object along the horizontal or vertical axis.

Transform – Flip ±90
   Rotates the selected object by + or − 90 degrees.

Draw – Group
   Groups the selected objects so that they are treated as one.

Draw – Ungroup
   Ungroups the selected group.

Draw – Bring To Front/Send To Back
   These items let you arrange the objects by moving them to the front or the
back.

Align – Left/Right/Top/Bottom/Center Vertically/Center Horizontally
   Aligns the selected objects to each other.

Display
   Sets the zoom factor for the drawing area.
Working with chords

About this chapter

In this chapter you will learn:

- How to enter chord symbols manually and automatically using the “Make Chord Symbols” feature.
- Which settings can be made for chord symbols.

Inserting chord symbols

To insert chord symbols in the score, you can insert them manually by using the Chord Symbol button in the Inspector. You can also let Cubase analyze an existing recording and create the chord symbols.

Manually

To specify and enter a chord symbol, proceed as follows:

PROCEDURE

1. Open the Other tab and select the Chord Symbol button.
2. Click in the score at the position where you want to insert the chord symbol. The Edit Chord Symbol dialog opens.
3. Enter the root note in the Root Note field. You can either type in a chord letter or step through the chord letters using the up/down arrows to the right.
4. In the “Chord Type” field, specify a chord type.
   You can either enter it directly (for example, by typing a “7”) or select an option from
   the pop-up menu (click the arrow button to open it).

5. If you wish, specify a tension in the Tension field.
   Again, this can be done by typing or by using the pop-up menu. However, there are
   some special display options which you can only get by typing (see the table below).
   You might also want to add some text here (such as “no third”). You can also select
   the basic tensions from the pop-up menu, and then add special options by typing.

6. If you want to have a special bass note (e.g. a C major with a D bass note),
   set the Bass Note pop-up menu to this note (this cannot be the same as the
   root note).
   The program “remembers” the relation between root and bass note, so that if you
   change the root note, the bass note follows.

7. If you want the root note to be displayed in lower case, activate the “Root Note
   in Lower Case” checkbox.

8. If needed, activate the “Enharmonic Shift” option.

9. Click Apply.
   The chord symbol appears in the score.
   To open the Edit Chord Symbol dialog for an existing chord, double-click the symbol.
   You can also right-click the symbol and select “Properties” on the context menu to
   open the dialog.

---

**Tension Field**

<table>
<thead>
<tr>
<th>Character</th>
<th>Description</th>
<th>Example</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>()</td>
<td>The tensions are enclosed in brackets.</td>
<td><img src="#" alt="Example" /></td>
<td>C9(#5)</td>
</tr>
<tr>
<td>/</td>
<td>The tensions are separated by a slash sign.</td>
<td><img src="#" alt="Example" /></td>
<td>C9#5</td>
</tr>
<tr>
<td></td>
<td></td>
<td>The tensions are placed above one another.</td>
<td><img src="#" alt="Example" /></td>
</tr>
</tbody>
</table>

You can also combine several options. This is a combination of two options, along with a space to put the “9” above the “5”. Note that only one “(“ sign is needed when the “|” option is used.
Using Make Chord Symbols

If you have already recorded the chords for a project, Cubase can analyze them and create chord symbols:

**PROCEDURE**

1. Open the recording in the Score Editor.
   If you want the chords to be inserted on another track, you can create an empty part on that track and open it along with the recording.

2. If you like, make display settings for the chords. These settings are available in the Score Settings dialog, on the Project page (Chord Symbols subpage). You can change all these settings after you inserted the chords as well.

3. Select the notes for which you want chord symbols to be created.
   If you want chord symbols to be created for all chords on the track, use the Select All function on the Edit menu.

4. Use the arrow keys to make the desired staff active.
   This should be the staff on which you want the chord symbols to end up.

5. On the Scores menu, select “Make Chord Symbols”.
   The chords appear. They can be moved, duplicated and deleted as any other symbol.
   You can also double-click on a chord symbol to edit it in the Edit Chord Symbol dialog (in the same way as when creating chords manually – see above).

![A staff after using Make Chord Symbols.](image)

Instead of using the “Make Chord Symbols” menu item, you can click the “Make Chord Symbols” button on the extended toolbar.

If the “Use for Make Chord Symbols” option is activated on the Project–Guitar Library subpage of the Score Settings dialog, guitar chord symbols are added as well (if the guitar library contains any guitar symbols that match the chords).

**RELATED LINKS**

Adding guitar chord symbols on page 1219

About the analysis

The MIDI chords are expected to be played in their most basic inversion. If not, an extra bass note is added. For example, the notes CEG are interpreted as C major, but GCE is interpreted as C major with a G bass note. If you do not want any interpretation of the inversion (i.e. no added bass notes) hold down [Ctrl]/[Command] while selecting Make Chord Symbols.
All selected notes on all staves are taken into consideration. Whenever there is any change on any staff, the notes are reinterpreted and a new chord symbol is added. This means you should probably avoid having the melody track in the Score Editor when you use Make Chord Symbols, or you get a lot more chords than you expect, possibly with strange tensions.

In addition to the above, the Quantize value is used. At the most, there is a new chord at each quantize position.

There must be at least three notes at a certain position for the program to interpret it as a chord. Also some combinations of notes simply do not make any sense to the program and do not produce any chords.

The analysis method is not perfect since the same set of notes can be interpreted differently depending on context. Some editing may be required. If you record the track solely to create chords automatically, play the chord as simple as possible, in the correct inversion, without added octaves, etc.

### The Current Chord Display

Cubase features a handy chord recognition function that helps you identify chords in the Score Editor note display. To find out which chord is formed by simultaneously played notes, place the project cursor over the notes. All notes currently “touched” by the project cursor are analyzed and the Current Chord Display in the status line shows you which chord the notes form.

### Global chord settings

In the Score Settings dialog on the Project page (Chord Symbols subpage), there are several global settings that affect how chords are displayed. These settings affect all chords in the project.

**NOTE**

There are several options in the Preferences dialog (Event Display–Chords) that also affect how chords are displayed.
Chord Symbols

Chord Symbols Font

- Use the four size value fields to select sizes for the root, the type, the tension, and the bass of a chord.

You can type in values or use the pop-up menus. Normally, you would want the “Root” size to be the largest and the “Tension” size to be the smallest.

Options

- If you want the root note to be aligned with the bass note, so that they are both displayed at the same vertical position, activate “Align Bass Note”.

- If you want the tensions to be displayed at the same vertical position as the root note (rather than a bit above the root note), activate “Tension Bottom”.

- If you want to scale a staff by using the Size setting on the Options tab of the Staff page in the Score Settings dialog and want the chords to be scaled accordingly, activate “Scale Chords”.

- If you want the chord symbols to be affected by the Display Transpose setting on the Staff page of the Score Settings dialog, activate “Use Display Transpose”.

1250
About this chapter

In this chapter you will learn:

• Which different types of text are available.
• How to enter and edit text.
• How to set font, size, and style.
• How to enter lyrics.

Adding and editing text symbols

This section describes the general procedure for adding and editing text symbols. There are several different types of text symbols, but the basic procedures are the same (except for block text symbols and page text symbols).

RELATED LINKS
Different types of text on page 1256
Block Text on page 1259
Page Text on page 1261

Inserting a text symbol

**PROCEDURE**

1. Make sure that the correct staff is active.
2. If you wish, select a font, size, and style for the text (or select a text attribute). You can also change these settings after you inserted the text.
3. In the Symbols Inspector, open a symbol tab. The different text symbols are found on the Other tab.
4. Right-click the text symbol on the tab to select the layer for which you want to add text.
   Not all text symbols are available for all layers.
5. Click the text symbol and click in the score at the position where you want the text to appear.
   If you are adding lyrics, you should click above or below a note (lyrics are centered around each note and positioned vertically to where you clicked).

6. Enter the text in the text box that appears.
   You can use [Backspace] to delete letters, and move the cursor with the arrow keys.

7. When you are done, press [Return].
   The text appears. You can move, duplicate or delete it as with any symbol.

**RELATED LINKS**

Selecting font, size, and style for the text on page 1253
Lyrics on page 1257

---

**Importing Karaoke Lyrics as Text**

If you activate the “Import Karaoke Lyrics as Text” option in the Preferences dialog (MIDI–MIDI File page), karaoke lyrics from MIDI files are converted to text on import. You can edit it in the same way as regular text.

**About the melisma lines**

When you add a text symbol, you can find a handle at the right edge of the text. By dragging this handle to the right, you can extend a “melisma line” from the text. This has several uses:

- If you are adding lyrics and want to indicate that a syllable should be sung over several notes:

- If the text is an advice about articulation or playing style, and you want it to apply to a certain musical phrase only:

- If the text is an advice about articulation or playing style, and you want it to apply from that point on in the score:
In the Score Settings dialog (Text tab), you can find two settings that determine the appearance of the melisma lines for text symbols:

- The Melisma Style pop-up menu is where you specify whether the line is solid or dotted.
- The Melisma End pop-up menu allows you to choose whether the end of the line is plain, has an arrow, or forms a “bracket” up or down.

Making space

Dragging staves is a way to edit distances within staves or between grand staves. Auto Layout makes the program "go through" the score and makes adjustments to measure widths, staff distances, etc.

RELATED LINKS
- Dragging staves on page 1293
- Auto Layout on page 1297

Editing the text

If you made a mistake when typing or for some other reason want to change text, double-click on a text block with the Object Selection tool, edit the text and press [Return] to close it.

- It is also possible to replace all occurrences of a certain word in the score, without having to edit the texts manually.

RELATED LINKS
- Find and replace on page 1265

Selecting font, size, and style for the text

PROCEDURE
1. Select the text that you want to make settings for.
   If nothing is selected, the settings you make are the "default settings". The next time you insert text, these settings are used.
2. Open the Score Settings dialog and select the Text page.
3. Select a font from the Font pop-up menu. How many and which fonts appear depends on what typefaces you have installed on your computer.

**IMPORTANT**

For regular text you should avoid the “Steinberg” fonts. These are the fonts Cubase uses for all scoring symbols, etc.

4. Select a text size from the Size pop-up menu (or enter one manually in the text field).

5. You can also add one or several font options using the checkboxes and pop-up menus.

6. Click Apply to apply the settings to the selected text. Note that you can select other text blocks while the dialog remains open – the dialog is updated to reflect the settings of the currently selected text.

7. When you are done, close the Score Settings dialog.

---

**Special style options**

Most of the options are common text style variations such as bold, italic, underline, etc. But there are also a few special style options:

**Frame**

Allows you to put the text in a rectangular (“Box”) or oval frame.

**Melisma options**

These determine the appearance of the “melisma line”.

**Positioning**

Allows you to select which side of the text block (left or right) is used for calculating its position. This has an effect in situations where that text block is moved automatically (as a result of an Auto Layout function, when you move bar lines manually, etc.). If, for example, the text block appears just in front of a note (to the left of it), it appears in a more sensible position after the adjustment, if the “Right” option is selected.

**Alignment: Left/Center/Right**

Allows you to specify the alignment of the text. These options are only valid for texts with more than one line.

**Related links**

*About the melisma lines on page 1252*
Text attribute sets

A text attribute set can be seen as a “preset” containing all font, size, and style settings. By creating text attribute sets for the settings you use most often, you can save a lot of time.

Creating a text attribute set

**PROCEDURE**

1. Open the Score Settings dialog on the Project page and select the Font Settings subpage.
2. Open the Attribute Sets tab.
3. On the Font Set pop-up menu, select the “Empty” set.
4. Select a font, specify a size, and add style options using the checkboxes. The options are the same as when you make font settings on the Text page in the Score Settings dialog (see above).
5. Click in the text field of the Font Set pop-up menu and enter a name for the new text attribute set.
6. Click Store to save the new text attribute set.

Using text attribute sets

To apply the settings in the text attribute set to one or several text blocks, select them, select the set from the Font Set pop-up menu on the Text page in the Score Settings dialog and click Apply. You can also apply a text attribute set to a text block directly in the score by right-clicking it and selecting the set from the context menu.

- If you select a text attribute set on the Text page when no text is selected in the score, the settings are used the next time you insert some text.

**NOTE**

After you have selected a set for a text block, there is a “link” between the text and the attribute set. Any changes to the attribute set affects all texts that use it (see below). You can still edit any font settings manually (on the Project–Font Settings subpage) but then the “link” to the attribute set is removed.
Editing text attribute sets

If you edit the settings in a text attribute set, all texts using this particular set are affected. This is very practical, since it allows you to use the same number of “generic” sets for all your projects (for titles, comments, lyrics, etc.), and simply change the fonts, sizes, etc. for a different project if necessary. This also makes it easier to move projects between computers (which may not have the same fonts installed).

**PROCEDURE**

1. In the Score Settings dialog on the Project–Font Settings subpage, select the Attribute Sets tab.
2. From the Font Set pop-up menu, select the attribute set that you want to edit.
3. Change the settings as desired.
   This includes the name of the set.
4. Click Apply.

Different types of text

You can add various types of text to the different layers of the score. The selected layer specifies which type of text is available.

Regular text

This type of text is inserted by selecting Text in the Other tab. You can insert this type of text on all layers.

![Regular text symbol]

The text is tied to the bar and staff position. If you move the bar or the entire staff, it moves with it.

Pasting text

You can paste text (e.g. from another program) into a text symbol in the score. To do this, select the text symbol and right-click it. Then, select “Text From Clipboard” from the context menu. This option is also available on the Functions submenu of the Scores menu.
Similarly, you can copy selected text by using the “Text To Clipboard” option from the context menu.

**Lyrics**

This type of text is inserted by selecting Lyrics on the Other symbol tab. You can insert this type of text only on note layers.

When you insert lyrics, you should click below or above the note the syllable belongs to. The text then appears horizontally centered around the note and vertically positioned to where you clicked. You can later move it up or down, as with any symbol.

Lyrics are tied to the note position. If you move the note, the text moves with it. The spacing between notes is also adjusted to make the lyrics fit.

**Inserting lyrics for a number of notes**

**Procedure**

1. With lyrics selected, click below or above the first note with the Draw tool.

   ![Example Note with Lyrics]

2. A text input field opens. Enter the text (the word or syllable) for that note.

3. Press the [Tab] key.
   The program moves on to the next note.

4. Input text for this note and press [Tab] again.

5. Proceed until the last note and then press [Return] or click outside the text box.

When you insert lyrics this way, the positions of the notes are automatically adjusted so that no lyric “block” overlaps another. If this is not what you want, you can activate the “Don’t Sync Lyrics” option in the Score Settings dialog on the Project–Notation Style subpage (Lyrics category). If this is activated, the note positions are not affected, which may be preferable.

When entering words with several syllables you normally separate the syllables with a dash (−). By default, the dash signs are automatically centered between the syllables.
Lyrics and measure widths

When you first enter lyrics, the result may look crammed, since the words take up more space than the notes (the lyrics are also selected just after entering the last word, which makes them look a bit odd when overlapping). To remedy this, use the auto layout function to automatically adjust the measure widths.

RELATED LINKS
Auto Layout on page 1297

Adding a second verse

To insert a second line of lyrics, proceed as follows:

PROCEDURE
1. Enter the new lyrics above or below the existing verse.
2. Select all the words that should be in the new verse.
3. Right-click the selected words to open the context menu.
4. Select the appropriate verse from the Move To Verse submenu (Verse 1–6). This assigns the selected lyrics to the selected verse.
   To indicate that the words belong to another verse, they are automatically displayed in another color. However, all verses are printed in black as usual.
   • To select all words in one verse only, press [Shift] and double-click on the first word in that verse.
     This selects all following words in the verse.

Inserting lyrics into voices

Each voice can have its own lyrics. If you have a vocal arrangement with several voices, you can add lyrics to them, one by one.

PROCEDURE
1. Make sure that the correct voice is selected (on the extended toolbar).
2. In the Symbols Inspector, open the Other tab and click on the Lyrics symbol.
3. Click on the first note in the selected voice.
4. Enter the lyrics for this voice, using the [Tab] key to move from note to note, as described above.
5. Start over, by activating the next voice, clicking on the first note in that voice and proceeding as with the first voice.
6. If needed, adjust the position of the lyrics for each voice (see below).
Moving lyrics

If you want to move the lyrics up or down, for example to make room for a second verse, proceed as follows:

**PROCEDURE**

1. Hold down [Shift] and double-click on the first word in the lyrics. All lyric “blocks” are selected.
2. Drag one of the lyric blocks up or down. All selected lyric blocks are moved accordingly.

Adding lyrics from the clipboard

If you want to prepare your lyrics in another program, you can import them into Cubase the following way:

**PROCEDURE**

1. Create the lyrics in another program. Separate words with space as usual, syllables within words with dash signs (-).
2. Copy the text.
3. In Cubase, select the first note to which the lyrics will be added.
4. Open the Scores menu and select "Lyrics from Clipboard" from the Functions submenu. The lyrics are added, starting at the selected note.

Block Text

Block Text allows you to import text from a file on disk or from the clipboard. Proceed as follows:

**PROCEDURE**

1. Click the Block Text symbol on the Other tab to activate the Draw tool. You can insert block text on the project layer (for text that should appear on all pages, for example, the score title), on the layout layer (to print a title only for a particular track layout, for example, for a particular instrument), or on the note layer (this text only appears in the score for a particular part).
2. Click in the score where you want to insert the text. A regular file dialog appears.
3. Select a file (TXT or RTF) to import.
4. Click Open.  
The text in the file is inserted into the score.

Options for inserted Block Text

Right-clicking on inserted Block Text brings up a pop-up menu with the following options:

Settings  
Brings up the RTF Settings dialog. You can also open this by double-clicking the Block Text.

Import Text  
Imports text from a text file or RTF file. The imported text replaces any text currently inserted at the position of the Block Text.

Update Text  
Reloads the text from the file.

Text From Clipboard  
Pastes the text from the clipboard into the Block Text.

Text To Clipboard  
Copies the Block Text to the clipboard.

Hide/Show  
Hides the inserted block text. To make the text visible again, activate the Hide checkbox in the filter bar and select “Hide/Show” on the context menu.

Properties  
Brings up the RTF Settings dialog.

The RTF Settings dialog

Selecting “Settings” from the context menu (or double-clicking the Block Text) brings up a dialog with settings for the Block Text. These are:

Font  
Lets you select the font to use for the Block Text. If “No Change” is selected, the font in the original file (if applicable) is used.

Size  
The text size, as a percentage.

Draw Frame  
When this is activated, a frame is shown around the Block Text.
Word wrap
When this is activated, line breaks are used to fit the text in the Block Text symbol.

Replace mode
In this mode, the Block Text box is opaque, covering what’s under it.

Trans mode
In this mode, the Block Text box is transparent.

Lay Text

The Lay Text symbol allows you to insert layout text for multiple staves. This is available only on the layout layer.

To hide or show the inserted text for different staves in the layout, deactivate or activate the “L” column for the corresponding tracks on the Layout page of the Score Settings dialog. The text appears in all staves for which you have activated the “L” column. This means that the text is tied to the bar and staff position. If you move the bar or the entire staff, the text moves with it.

To enter layout text, proceed as follows:

PROCEDURE
1. In the Project window, select the tracks for which you want to enter text.
2. Open the Score Editor.
3. On the Other tab of the Symbols Inspector, activate the Lay Text symbol and click at the position in the score where you want to insert the text.
4. Enter the text that you want to display for the Layout.
   As with regular text, you can copy and paste text from external sources to this symbol.

RELATED LINKS
Regular text on page 1256

Page Text

The page text symbols are found on the Other tab. If you insert page text on the project layer, it is part of the project layout and appears in all layouts.

The position of page text is not tied to a note, bar or staff position. In other words, it does not matter if you move other objects on the page, the page text stays where you inserted it. Typically, it is used for score titles, page numbers, copyright information and other text elements that you want displayed with all parts (on all pages if you like).
### Entering page text

**PROCEDURE**

1. Open the Other tab of the Symbols Inspector.
2. Click the Page Text symbol and click in the score. 
   It does not matter where you click – the positioning is specified in the Page Text dialog.
3. Enter the text that you want displayed in the field at the top of the dialog. 
   You can use special characters to add “variables” such as page numbers – see below.
4. Adjust the positioning settings for the text.
5. Select a text attribute set for the text, or make manual settings for font, size, and style.
6. Click OK. 
   The text is inserted. You can adjust the positioning manually by dragging the text block.

### Text adjustment options

**Show on all Pages**

When this is activated, the text is shown on all pages. The “Except First” checkbox allows you to exclude the very first page.

**Show on First Page**

When this is selected, the text is only shown on the first page.

**Line**

This determines how the text is aligned. For example, if you place several texts on “Top/Left”, you can sort them by entering the desired number of lines.

**Toggle Position**

When the Left or Right position option is selected to the right, activating this checkbox makes the text alternate between left and right alignment on even/odd pages.

**Position buttons**

Determines where on the page you want the text, vertically (Top/Bottom) and horizontally (Left, Center, Right).

### Inserting variables

When you enter the text, you can also insert special characters or “place holders” for different attributes. When the text is displayed, these characters are replaced by their actual values (e.g. page numbers). The following variables are available:
Working with text

Different types of text

The current page number.

The long staff name.

The short staff name.

The name of the project.

For example, if you enter the text “%l, %r, Page %p”, these variables might be shown as “1st Violin, Quartet No.2, Page 12” in the score.

Using the Score Settings (Text page)

In the Score Settings dialog on the Text page, you can find a number of text-related settings. The symbol buttons correspond to the symbols found on the Other tab of the Symbols Inspector.

- On the Layer pop-up menu, select the layer that you want to use. The text symbols available for this layer are displayed to the left of the pop-up menu.

- You can use the text symbols in the same way as you would use symbols from the Inspector or a symbol palette. When you select a text symbol and move the mouse pointer over the score, the pointer changes to a pencil, and you can enter text at the position you click on.

Related links

Symbol details on page 1234

The Notepad tab and the Selection tab

Below the text symbols and the Layer pop-up menu, you can find two tabs with large text entry fields.

- Use the Notepad tab to enter longer text passages. When you are happy with the text in terms of wording and length, select all or part of the text, and select a note in the score. Now, the Insert Lyrics button below the Notepad tab becomes available.

  When you click Insert Lyrics, the selected text is entered into the score, starting from the note you selected.
• When you select text in the score and open the Selection tab, the selected words are shown in the text field. You can now change the wording of the text, and use the text format options to the left to change the appearance of the selected text. When you are done, click Apply to apply your changes to the selected text in the score.

Text functions

In addition to the text symbols that you can add to the different layers, you have other text functions at your disposal that support you while working on the score. These are described in the following sections.

The Words tab

If you have certain words that you use a lot, you can save these as dedicated symbols on the Words tab. This saves time, since you do not have to type the same word over and over again.

Storing a word

PROCEDURE

1. Open the Words symbol tab.
   This tab is hidden by default.
2. Type in the desired word(s) in the text field at the top of the dialog.
3. Specify the text type (regular text or lyrics) with the Type pop-up menu.
4. Make settings for font, size, and style.
   You can also use a text attribute set if you like.
5. Click Exit to close the dialog.
   The words that you entered appear in the selected symbol field on the Words tab.

   Right-clicking one of the fields opens a context menu with a number of options:
   • Select "Edit" to open the Custom Text Editor dialog.
   • Select "New" to add a new empty symbol to the Words tab.
   • Select "Remove" to delete any unwanted symbols from the Words tab.
   • Select "Open As Palette" to open the Words symbol palette.

RELATED LINKS

Showing/Hiding Symbols Inspector tabs on page 1208
Inserting a word

You insert words from the Words tab as you would insert any regular symbol, by selecting the appropriate word and clicking in the score. However, you can edit the word after inserting it, just as with text inserted by typing.

Find and replace

This function allows you to replace all occurrences of a certain word or group of words, with another word or group of words. The replacement is done once and for all, for all text symbol types, regardless of font, size, and style settings.

PROCEDURE

1. Open the Scores menu and select “Find and Replace” from the Functions submenu.
   The Find and Replace dialog opens.

2. In the Find value field, enter the words to replace.

3. If you want all instances of the words to be replaced, regardless of upper/lower case, deactivate the “Case Sensitive” option.

4. If you do not want to replace the words if they are a part of another word, activate the “Entire Word” option.
   For example, if you want to replace the word “string” but not the word “stringendo”, you should activate “Entire Word”.

5. In the “Replace” field, enter the words that are to be used as replacement.

6. Click OK.
   Now all occurrences of the “Find” words are replaced with the “Replace” words.

Staff names

You can make settings for staff names in several places:

- In the Score Settings dialog on the Layout page, you specify whether the staff names are shown at all and whether to use the names of the actual edited tracks in the score.
  In a multi-track layout, you can choose for which tracks the staff names are shown by clicking in the “N” column for each track.
• You specify a long and short staff name in the Score Settings dialog, on the Staff page (Main tab).

These are used if you do not use the “From Tracks” option on the Layout page of the Score Settings dialog. The long name is displayed for the first system only, and the short name for the following systems. If you want a name at the top of the page only, leave the “Short” name field empty.

**IMPORTANT**

If the “Show Long Staff Names on new Pages” option is activated in the Score Settings dialog on the Project–Notation Style subpage (Staff Names category), the long name is displayed for the first system on every page.

### Selecting a font for staff names

**PROCEDURE**

1. Open the Score Settings dialog on the Project page and select the Font Settings subpage.
2. Select the Project Text tab.
3. Use the “Font For” pop-up menu to select “Staff Names”.
4. Select font, size, and styles for the staff names (or use a text attribute set).
5. Click Apply and close the Score Settings dialog.

### Additional staff name settings

• If you activate the “Show Staff Names to Left of Staff” option in the Score Settings dialog on the Project–Notation Style subpage (Staff Names category), the staff names are shown to the left of the staves, instead of above them.

• You can define separate subnames for the upper and the lower staff in a polyphonic or split system.

• You can fine-tune the vertical and horizontal position of staff names with some of the options on the Project–Spacings subpage of the Score Settings dialog.

**RELATED LINKS**

- Staff names on page 1265

### Bar Numbers

Bar Number settings can be made in several places as well.
General settings

PROCEDURE
1. Open the Score Settings dialog on the Project page and select the Notation Style subpage.
2. Scroll down the list to the “Bar Numbers” category.
3. Use the “Show every” setting to specify how often bar numbers are shown. The options are “First Bar” (bar numbers shown for the first bar on each staff), “Off” (no bar numbers shown) and any number. Click in the State column and use the mouse wheel to select the desired option.
4. If you like, activate the “Show Range with Multi-Rests” option. When this is activated, and you have a multi-rest, the bar number at the beginning of the multi-rest shows a range, indicating the length of the multi-rest.
5. If you want the bar numbers to be displayed below the bar lines, activate the “Below Bar Lines” option.
6. Click Apply and close the Score Settings dialog.

Font settings

As with many of the other fixed text elements, you can select a font, size, and style for bar numbers in the Score Settings dialog, on the Project–Font Settings subpage.

Spacing

On the Project–Spacings subpage of the Score Settings dialog, you can find four settings that relate to bar numbers:

First Bar Number – Horizontal Offset
Sets the horizontal distance between the bar number and the bar line for the first bar on each staff.

First Bar Number – Vertical Offset
Sets the vertical distance between the bar number and the bar line for the first bar on each staff.

Other Bar Numbers – Horizontal Offset
Sets the horizontal distance between the bar number and the bar line for all other bars.

Other Bar Numbers – Vertical Offset
Sets the vertical distance between the bar number and the bar line for all other bars.
Offsetting bar numbers

If you double-click on a bar number, a dialog appears, allowing you to skip a number of bars in the otherwise continuous bar numbering.

This is used for example when a section repeats. Say, you have a repeat of bar 7 and 8, and want the first bar after the repeat to have the number 11, not 9. To achieve this, you double-click on the “9” and insert an offset of “2”.

It is also useful if the score starts with an upbeat, and you want the first “real” bar to be numbered 1. In that case you would specify an offset of “-1” for the second bar, and make sure that the bar number for the upbeat bar is hidden.

- Bar number offsets belong to the Project layer and are shown for all tracks and layouts.

Settings for other fixed text elements

You can make settings for virtually all text and numbers that appear in the score.

**PROCEDURE**

1. Open the Score Settings dialog on the Project page and select the Font Settings subpage.
2. Select the Project Text tab.
3. Use the “Font For” pop-up menu to select a text type to make settings for.
4. Use the options in the dialog to change the settings.
5. Click Apply to apply the settings to all elements of the selected type.

To close the dialog, click the close button at the top right of the dialog window.

Bar Numbers before and after changing their font settings.

You can also define text attribute sets on the Font Settings subpage, as a means to quickly change text.

Note that you can select a defined attribute set from the context menu opened when right-clicking on a text element.

**RELATED LINKS**

Text attribute sets on page 1255
About this chapter

In this chapter you will learn:

• What layouts are and what they contain.
• How to create layouts.
• How to use layouts for opening combinations of tracks.
• How to apply, load, save and delete layouts.
• How to import and export layouts.
• An example of how layouts can be used.

Background: Layouts

Layouts can be viewed as “presets” containing settings for the layout layer: staff spacing, bar lines, layout symbols, etc.

When to use layouts

• You need to format the score differently when you print the entire score and when you extract parts for single instruments (or groups of instruments). Layouts allow you to keep different sets of “looks” for the same track or set of tracks. You might for example have one layout for each single instrument and one for the entire score.
• By selecting another layout on the Layout page of the Score Settings dialog, you can switch to another combination of tracks without having to leave the Score Editor.

What makes up a layout?

A layout contains the following items and properties:

• The inserted Layout symbols.
Creating a layout

Layouts are created automatically when you edit a single track or a combination of tracks. They are an integral part of the specific track combination, which means you do not have to save them separately.

Creating a layout

Layouts are created automatically when you open a new combination of tracks for editing.

Each track may have been edited before, individually or together with other tracks, it does not matter. What matters is that you open precisely these tracks. For example, to create a layout for a string quartet, select parts on the corresponding tracks and press [Ctrl]/[Command]-[R].

IMPORTANT

The order of the tracks does not matter – you can reorder them in the Project window without removing the layout. However, the spacing of the staves in the layout is related to the order of the tracks.

Opening a layout

The “Open Layout” command on the Scores menu opens a dialog listing all available layouts for the Project.

Select the desired layout in the list and click OK to open the tracks contained in the layout in the Score Editor.

This is a quick way for opening several tracks in the Score Editor directly from the Project window.
Layout operations

The Score Settings dialog contains a Layout page, where you can make settings for the different layouts. To the left of the dialog, all existing layouts in the project are listed (this is the same list as in the Open Layout dialog, see above). The layout currently used is highlighted in the list.

Opening the tracks in a layout

To select another combination of tracks for editing, select the corresponding layout in the list.

- You can keep the dialog open while you are editing, and use this function for selecting which tracks to edit.

Importing layout symbols

By selecting another layout and selecting “Get Form” from the Functions pop-up menu below the list, you import all Layout symbols (inserted from the Layout section in the Symbols Inspector) from the selected layout into the current layout.

Managing layouts

- To rename a layout, select it in the list and enter the desired name in the Name field to the right in the dialog.
  Initially, a layout gets the name of one of the edited tracks – it may be a good idea to give each layout a more informative name.
- To remove a layout you no longer need, select it in the list and select “Remove” on the Functions pop-up menu.
• To remove all layouts for which there no longer are track combinations, select “Clean Up” on the Functions pop-up menu.

Importing and exporting layouts

By selecting a layout and selecting “Export” or “Import” from the Functions pop-up menu below the list, you can export or import a Layout. Note that all Staff settings are taken into account, when exporting or importing a layout.

Working with Display Transpose

You can specify for each staff in a layout whether it should use Display Transpose. In the Score Settings dialog on the Layout page, click in the D column to activate or deactivate the option. Note that this setting affects this layout only.

Using layouts – an example

The following text outlines the basic steps for extracting a musical part from a full score.

PROCEDURE

1. Prepare the entire score, including all formatting.
   This might include inserting project layer block text for the score title, setting the bar line type, etc.

2. Open the Score Settings dialog on the Layout page and enter the desired name in the Name field (for example “Full Score”).

3. Close the Score Editor.

4. Open a single track, for example a woodwind part.
   The Project layer settings automatically appear in the new single track layout.

5. Prepare a layout for the woodwind part.
   You might for example move bar lines, add endings, activate multiple rests, etc.
   You can also import all layout symbols from the “Full Score” layout, by opening the Score Settings dialog on the Layout page, selecting the “Full Score” layout in the list to the left, and selecting “Get Form” from the Functions pop-up menu.

   IMPORTANT
   Be careful not to change any of the properties which are not part of the layout. This modifies the “Full Score”, too.

6. Enter the desired name for the new layout in the Name field on the Layout page of the Score Settings dialog and click “Apply”.

RELATED LINKS
Importing layout symbols on page 1271
Marker Track to Form

If you have created markers in the Project window which denote the start of each new “section” in your music (verse, bridge, chorus, etc.), you can automatically transfer these markers into the current layout.

PROCEDURE
1. Open the Scores menu, open the Advanced Layout submenu and select “Marker Track to Form”.
   Now, rehearsal marks and double bar lines are inserted in the score, at the position of each marker.
2. If you want the names of the markers shown as well, open the Advanced Layout submenu again and select “Display Markers”.
Working with MusicXML

Introduction

MusicXML is a music notation format developed by Recordare LLC in 2000 based primarily on two academic music formats. It allows the representation of scores in the current symbolic representation of western music notation, used since the 17th century. With Cubase you can now import and export MusicXML files created with version 1.1. This makes it possible to share and exchange sheet music with people who are using score writing programs such as Finale and Sibelius.

NOTE
As MusicXML is supported to various degrees by different programs, you always have to do manual adjustments.

What is MusicXML used for?

The MusicXML file format can be used for the following purposes:
- Representation and printing of sheet music
- Exchange of sheet music between various score writing programs
- Electronic distribution of musical scores
- Storage and archiving of scores in an electronic format

Notational representation vs. musical performance

MusicXML is a music notation file format, that means it deals especially with the layout of music notation and the correct graphical representation, i.e. how a piece of music should look.

However, MusicXML music data also contains elements that define how a piece of music should sound. For example, these are used when creating a MIDI file from MusicXML. This means that MusicXML has things in common with MIDI.

MIDI is a music interchange format for performance applications like Cubase or other sequencers. The MIDI file format is designed for playback, i.e. the main focus of the MIDI file format lies in the performance, not in the notation.
Is MusicXML better than MIDI?

The following sections inform you about the advantages of MusicXML and MIDI regarding note representation and sound.

Advantages of MusicXML

MIDI tracks hold MIDI notes and other MIDI data. A MIDI note in Cubase is only defined by its position, length, pitch and velocity. This is not enough to decide how the note will be displayed in a score. For a correct representation, Cubase also needs the following information:

- Stem direction, beaming.
- Expression marks (staccato, accent, ties and slurs).
- Information about the instrument in the score.
- Key and basic rhythm of the piece.
- Grouping of notes, etc.

MusicXML can save a great part of this information. However, you have to adjust the scores with the tools available in the Score Editor.

Advantages of MIDI

Although MusicXML has obvious advantages in the representation of musical scores, there are also restrictions in sound. This is due to the fact that MusicXML as a music notation format has a graphical background and is designed for exchanging representation, not sound.

When playing back MusicXML files in Cubase, the following parameters, among others, are not considered:

- On and Off velocities
- Dynamics
- Controller data
- SysEx
- Standard MIDI file meta events
- Audio
- All Cubase-specific data like automation, MIDI effects, Input Transformer, etc.
Importing and exporting MusicXML files

Cubase can import and export MusicXML files, which makes it possible to transfer musical scores to and from applications that support this file format. However, there are some restrictions concerning the parameters supported by Cubase.

Importing and exporting Notes

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Export</th>
<th>Import</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pitch</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Length</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Staves</td>
<td>Yes</td>
<td>Up to two per staff</td>
</tr>
<tr>
<td>Voices</td>
<td>Yes</td>
<td>Up to four per staff</td>
</tr>
<tr>
<td>Accidentals</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Ties</td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td>Dots</td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td>Stem</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Beams</td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td>Grace Notes</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Rests</td>
<td>Yes</td>
<td>Yes</td>
</tr>
</tbody>
</table>

Importing and exporting Layouts

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Export</th>
<th>Import</th>
</tr>
</thead>
<tbody>
<tr>
<td>Page Size</td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td>Page margins</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Page scaling</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Page breaks</td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td>System breaks</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Distance between staves and systems</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Left/right Inset</td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td>Distance between measures</td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td>Hidden staves</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>x and y positions of symbols</td>
<td>Yes</td>
<td>Yes</td>
</tr>
</tbody>
</table>
## Importing and exporting Symbols

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Export</th>
<th>Import</th>
</tr>
</thead>
<tbody>
<tr>
<td>Keys</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Clefs</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Time Signature</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Dynamics</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Ornaments</td>
<td>Yes / incomplete</td>
<td>Yes / incomplete</td>
</tr>
<tr>
<td>Articulations</td>
<td>Yes / incomplete</td>
<td>Yes / incomplete</td>
</tr>
<tr>
<td>Technicals</td>
<td>Yes / incomplete</td>
<td>Yes / incomplete</td>
</tr>
<tr>
<td>Lyrics</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Chord Symbols</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Damper Pedal</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Dynamics</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Rehearsals</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Text</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Layout Text</td>
<td>Yes</td>
<td>N.A.</td>
</tr>
<tr>
<td>Project Text</td>
<td>Yes</td>
<td>“Credits”</td>
</tr>
<tr>
<td>Dashes</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Endings</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Octave Shift</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Bar line types</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Slurs</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Hammer-on/pull-off</td>
<td>No</td>
<td>No</td>
</tr>
</tbody>
</table>

## Importing and exporting Formats

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Export</th>
<th>Import</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display Transpose</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Drum notation</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Short / long staff names</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Program changes</td>
<td>Yes</td>
<td>N.A.</td>
</tr>
<tr>
<td>Music font</td>
<td>Yes (if Jazz font)</td>
<td>Yes</td>
</tr>
<tr>
<td>Tablature (including String tunings)</td>
<td>Yes</td>
<td>Yes</td>
</tr>
</tbody>
</table>
Importing MusicXML files

PROCEDURE
1. Open the File menu and open the Import submenu.
2. On the submenu, select “MusicXML…”.
3. In the file dialog that opens, locate and select the MusicXML file and click “Open”.
4. Another file dialog opens in which you can select the project folder for the new project.
   Select an existing project folder or create a new one by clicking “Create” and entering a name in the dialog.
5. A new project is created with the name of the MusicXML file.

Exporting MusicXML files

PROCEDURE
1. Set up the score the way you want it in the Score Editor of Cubase.
2. Open the File menu and open the Export submenu.
3. On the submenu, select “MusicXML…”.
   Note that this option is only available when the Score Editor is open.
4. A file dialog opens in which you can choose an existing empty folder or create a new folder for saving the MusicXML file (with the extension “.xml”).
Designing your score: additional techniques

About this chapter

In this chapter you will learn:

- How to change the staff size.
- How to create multi-rests.
- How to add and edit bar lines.
- How to create upbeats.
- How to set measure spacing and the number of bars across the page.
- How to control staff and grand staff spacing.
- How to use the Auto Layout dialog.
- How to use the Reset Layout function.
- How to break bar lines.

IMPORTANT

Before you start designing the score page layout, you should open the Page Setup dialog on the File menu, and make settings for paper size, print scale and margins!

Layout settings

The Layout page of the Score Settings dialog contains a number of settings that affect the display of the current layout.
The track list

The track list lists the tracks included in the layout and allows you to make the following settings:

**Brackets**

These two columns allow you to add braces or brackets, encompassing any number of staves in the layout.

**T**

This is relevant if the “Modern Time Sign.” option is activated to the right. In that case, you use this column to specify for which tracks the time signature is shown – see below.

**N**

This option lets you specify for each staff in a layout whether the staff name is shown.

**L**

If this is activated, any layout symbols are shown; otherwise they are hidden. For example, this allows you to have rehearsal marks shown for the top staff only in a multi-staff layout.

**D**

This option lets you specify for each staff in a layout whether it should use Display Transpose.

**C**

This option lets you specify which staff should show the chord track symbols. The chord track symbols can only be shown on one staff.

**RELATED LINKS**

Adding brackets and braces on page 1296  
Displaying the Chord Symbols from the Chord Track on page 1296
Equal Spacing

Activate this option when you want a note to take up space according to its note value. When Equal Spacing is activated, two sixteenth notes take up as much space as one eighth note, for example.

Size

Changes the size of all staves.

RELATED LINKS
Staff size on page 1282

Multi-Rests

Whenever more than one-bar rests occur, the program can replace these with a multi-rest symbol. This parameter allows you to set how many empty bars are “allowed” before Cubase collects them into a multi-rest. “Off” means “never”.

RELATED LINKS
Multiple rests on page 1285

Real Book

When this option is activated, clef symbols are not set out at the beginning of each staff, only on the first staff on each page.

Staff Separators

When this option is activated, separator symbols are inserted at the beginning of each grand staff.

A staff separator between two systems

Modern Time Signature

When this is activated, time signatures are shown above the staves rather than in them. You can set the size of the modern time signature in the Time Sign section on the Project–Notation Style subpage of the Score Settings dialog. When modern time signature is selected, you use the “T” column in the track list in the Layout page to specify for which tracks time signatures are displayed.
Designing your score: additional techniques

Staff size

You can set the staff size as a percentage value of the normal size.

For one staff

To set the staff size for one staff, proceed as follows:

PROCEDURE
1. Make sure that the staff you want to edit is active.
2. Open the Score Settings dialog on the Staff page and select the Options tab.
3. Adjust the Size parameter in the System Sizes section.
   The values range from 25% up to 250% of the normal size.
4. Click Apply.

For all tracks in a layout

To set the staff size for all tracks in a layout, proceed as follows:

PROCEDURE
1. Open the Score Settings and select the Layout page.
2. Change the Size parameter.
   The values range from 25% up to 250% of the normal size.
3. Click Apply.

RESULT
All staves now get the desired size. Staves that have individual size settings (see above) still are proportionally smaller/larger.

This setting is part of the layout and can be used when printing a full score slightly smaller than the parts for each instrument, for example.
Hiding/showing objects

Any object on a page can be hidden, including notes, rests, symbols, clefs, bar lines, even entire staves.

This can be useful in the following situations:

Printing scales

If you want to create scale examples, enter the notes and hide time signatures, bar lines and other unwanted objects.

A scale created with hidden bar lines, time signatures, etc.

Graphic notation

By hiding bar lines, you can produce graphic notation.

Hiding notes meant for playback only

If you have recorded your music, you may have added glissandos, falls, etc. that sound fine but result in a lot of unnecessary notes. You probably want to hide those notes and insert the suitable symbols instead.

Hiding

To hide items, proceed as follows:

**Procedure**

1. Select all the items you want to hide.
2. Select “Hide/Show” from the Score menu or click on the “H” (Hide) button on the extended toolbar.

   Notes can also be hidden by selecting them, clicking the “i” button on the extended toolbar and ticking the Hide Note checkbox in the Set Note Info dialog.

   **Important**

   If the Hide option in the filter bar is activated, hidden objects are shown in gray so that they are still visible and you can select them.

**Related Links**

Other note details on page 1183
Hiding in the current layout only

If you want the hiding to be “local” to the current layout, hold down [Ctrl]/[Command] when selecting “Hide/Show” as described above.

**IMPORTANT**

This is not possible when hiding notes, only other symbols.

**NOTE**

You can also move hidden objects to the layout by right-clicking the “Hide” marker and selecting “Move to Layout”.

Viewing hidden objects

The filter bar (shown by clicking the “Set up Window Layout” button on the toolbar and activating the Filters option) contains two options related to hidden objects:

- If you activate the “Hidden Notes” option, all hidden notes in the score are shown. Deactivating “Hidden Notes” hides the notes again.
- If you activate the “Hide” option, all hidden objects (except notes) are indicated by a “Hide” text marker.

Showing one object

**PROCEDURE**

1. Make sure that “Hide” is activated on the filter bar.
2. Click on the “Hide” text marker below the object you want to display again. The text is selected.
3. Press [Backspace] or [Delete].
   The object appears. Undo is available if you change your mind.

Showing all objects

If you select “Hide/Show” from the Scores menu again, all hidden objects are displayed.

- You can also use the Reset Layout function to permanently display hidden notes and objects.

**RELATED LINKS**

Reset Layout on page 1300
**Showing a hidden note**

While all hidden notes can be made visible by ticking the Hidden Notes checkbox on the filter bar, you may want to make some of them “permanently” visible again:

**PROCEDURE**
1. Activate the Hidden Notes checkbox on the filter bar.
2. Select the notes that you want to “un-hide”.
   In the Preferences dialog (Scores–Colors for Additional Meanings) you can set the color for hidden notes.
3. Double-click one of the notes.
4. Deactivate the Hide Note option in the Set Note Info dialog and click Apply.

**Coloring notes**

You can use the color pop-up menu on the toolbar to colorize selected notes, e.g. for educational purposes.

**RELATED LINKS**
- Coloring notes on page 1186

**Multiple rests**

Multiple consecutive rests can be automatically displayed as multi-rests.

```
3
```
A multi-rest over three bars

**PROCEDURE**
1. Open the Score Settings and select the Layout page.
2. Set the Multi-Rests option to the number of empty bars that are “allowed” before Cubase displays them as a multi-rest.
   For example, a value of 2 means that three or more consecutive empty bars are displayed as a multi-rest. If you set this to “Off”, multi-rests are not used.
3. Click Apply and close the dialog.

**RESULT**
The multi-rests now appear in the score.
Splitting multi-rests

To divide one long multiple rest into several shorter ones, proceed as follows:

**PROCEDURE**

1. Double-click on the multi-rest symbol.
   The Split Multi-Rest dialog appears:

   ![Split Multi-Rest dialog]

2. In the dialog, enter the bar number where you want the first split.
3. Click OK.
   If you need more splits, double-click on any multi-rest symbol and proceed as above.

**IMPORTANT**

The program automatically splits multi-rests at time signature changes, double bar lines, repeat signs and rehearsal marks.

Multi-rest appearance

The Project page in the Score Settings dialog contains several subpages, on which you can make settings for multi-rests:

- The subpage “Notation Style” contains the following settings concerning multi-rests:

  **Multi-Rests – Church Style**

  When this is activated, multi-rests are shown in “church style” (vertical bars), rather than with the regular, horizontal symbols.

  **Multi-Rests – Numbers above Symbol**

  When this is activated, the numbers are shown above the multi-rest symbol, instead of below it.

  **Multi-Rests – Snap Rests moved with the Layout tool**

  When this is activated, rests automatically snap to “intelligent” positions in the score (i.e. positions used in regular notation) when moved with the layout tool. If this is deactivated, rests can be positioned freely.

  **Bar numbers – Show Range with Multi-Rests**

  When this is activated, and bar numbers are displayed, the bar numbers of a multi-rest are shown as a range.

  - On the Spacings subpage of the dialog, you can adjust the height and width of multi-rest symbols.
Designing your score: additional techniques

Editing existing bar lines

For each bar line, you can choose whether you want a regular, single bar line, a double bar line, a repeat sign, etc.:

PROCEDURE

1. Double-click on the bar line for which you want to edit the settings.
   A dialog appears with a number of bar line types.

2. If you want the bar line to be shown with “brackets”, activate the Brackets checkbox.
   This is only relevant for repeat signs.

3. Click on the desired bar line type.
   The dialog closes and the bar line type is changed.

4. If you do not want to display bar lines at the beginning of the parts, open the Score Settings dialog on the Project–Notation Style subpage (Bar Lines category) and activate the “Hide First Bar line in Parts” option.

NOTE

The bar line types are part of the Project layer – any changes you make are reflected in all layouts.

Creating upbeats

The following methods describe how you can create upbeats in the Score.
By using the Pickup Bar feature

With this method, the upbeat actually contains exactly the number of beats displayed. That is, if you have an upbeat of one beat, your project starts with one bar in 1/4 time.

**PROCEDURE**

1. Change the time signature of the first bar to the length of the upbeat.
2. Insert a time signature of the correct kind (the time signature used throughout the project) in the second bar.
   To insert a time signature, select it in the “Time Signature” section in the Symbols Inspector and click in the Score with the Draw tool.
3. Enter the notes in the upbeat into the first bar.
   ![First bar with notes]
   The first bar before making any adjustments
4. Double-click the time signature for the upbeat bar.
   The Edit Time Signature dialog appears.
5. Activate the “Pickup Bar” option and click OK.
   ![Edit Time Signature dialog]
   Now, the time signature of the first bar takes on the look of the second bar’s signature, while the time signature in the second bar is hidden.
   ![Second bar with notes]
6. If you use bar numbers, double-click on the first bar number and enter an offset of -1.
7. Adjust the display of bar numbers and hide the “0” in the first measure.
By hiding rests

With this method, the first bar actually gets the same time signature as the following bars – it only looks like an upbeat bar:

**PROCEDURE**

1. Enter the notes in the upbeat into the first bar.

   \[
   \begin{array}{c}
   \text{The first bar before making any adjustments}
   \end{array}
   \]

2. Hide the rests that precede the notes.

3. Drag the bar line between measure one and two to adjust the width of the bar.

   \[
   \begin{array}{c}
   \text{After hiding the rest and dragging the bar line}
   \end{array}
   \]

4. If you like, move the notes in the upbeat measure, using the Layout tool.

5. If you use bar numbers, adjust them as described in the previous example.

   \[
   \begin{array}{c}
   \text{The final upbeat}
   \end{array}
   \]

Setting the number of bars across the page

You can specify how many bars you want to display across the page.

**Automatically**

- When you open a new combination of tracks for editing, the number of bars across the page is determined by the “Default Number of Bars per Staff” setting in the Preferences dialog (Scores–Editing page).

- In the Auto Layout dialog, you can set the maximum number of bars across the staff.

**RELATED LINKS**

*Auto Layout on page 1297*
Manually

In Page Mode, you have full control over the number of bars appearing across the page, by using the Number of Bars dialog or the tools.

**NOTE**

If you want to use the “Max. number of Bars” option in the Auto Layout dialog, you should do this before you adjust the number of bars manually.

**RELATED LINKS**

[Auto Layout on page 1297](#)

Using the Number of Bars dialog

**PROCEDURE**

1. Make a staff active in the system where you want to make changes.
   This means that if everything looks fine until for example the fifth system, activate one of the staves in this system.
2. Open the Scores menu and select “Number Of Bars” from the Advanced Layout submenu.
   The Number of Bars dialog opens.
3. Set the desired number of bars across the page.
   - To change the number of bars for the active staff only, click “This Staff”.
   - To change the number of bars for the active staff and all following staves, click “All Staves”.
   In other words, to set all systems on all pages to the same number of bars, make the very first staff active and use the All Staves option.

Using the tools

- To make a bar “fall down” on a new staff, use the Split tool to click on its bar line.

Before and after moving the third bar one staff down
Moving bar lines

The following operations can be made using the regular Object Selection tool or the Layout tool.

Moving a bar line

If you drag a bar line to the left or right, the surrounding bars are adjusted proportionally.

Moving bar lines on all staves

If you hold down [Alt]/[Option] when dragging a bar line, all bar lines below the one you drag are moved accordingly.

Moving a single bar line separately

If you hold down [Ctrl]/[Command] while dragging a bar line, the widths of the surrounding bars are not affected.
Making an indent on one line

- To create an indent, simply drag the first or last bar line on a staff. The sizes of all measures are adjusted proportionally.

Before and after dragging the first bar line on the first staff

Making indents on several lines

If you hold down [Alt]/[Option] and drag the first or last bar line in a system, all following systems get the same indent. If you want all lines on all pages to be modified in the same way, hold down [Alt]/[Option] and drag the appropriate bar line on the first system of the score.

The last bar line in the score

Cubase attempts to move the last bar line and space the bars on the last line in a sensible way. But you can change this manually by dragging the last bar line, if you like. To change the type of the last bar line, double-click it and select the desired type.

Resetting bar spacing

To reset the bar spacing to standard values for several lines, proceed as follows:

**PROCEDURE**
1. Locate the first line for which you want to reset the bar spacing, and make one staff in that system active.
2. Select “Number of Bars” from the Advanced Layout submenu on the Scores menu.
3. Specify the number of bars that you already have on the line.
4. Click on “This Staff”.
   Clicking “All Staves” resets the lines of all staves in the score.
5. Close the dialog.
   The bar spacing is reset for the currently selected staff and all following staves.

**RELATED LINKS**
- Using the Number of Bars dialog on page 1290
Dragging staves

For the following operations, you can use the Object Selection tool or the Layout tool.

**NOTE**

Dragging staves can only be done in Page Mode.

**Adding space between two grand staves**

**PROCEDURE**

1. Locate the first staff in the lower of the two systems that you want to spread apart.
2. Click just to the left of the first bar line and keep the mouse button pressed. The entire staff is selected.
3. Drag downwards until you have reached the desired distance between the staves and release the mouse button.

Before…

...and after dragging the upper system
Setting the same distance between all grand staves

**PROCEDURE**
1. Hold down [Alt]/[Option] and drag the first staff of the second system, until you have reached the desired distance between this and the first system.
2. Release the mouse button.
   The distances between all the systems are adjusted accordingly.

**IMPORTANT**
This operation affects the system you drag and all following systems.

Setting the distance between staves within a grand staff

**PROCEDURE**
1. Locate the lower staff in the grand staff that you want to spread apart.
2. Click just to the left of its first bar line and keep the mouse button pressed.
   The entire staff gets selected.
3. Drag downwards or upwards and release the mouse button.

![](image)

Dragging apart the staves in a piano system.
The new distance is set for the two staves.

Setting the same distance between staves in several systems

**PROCEDURE**
1. Hold down [Alt]/[Option] and drag the desired staff as described above.
2. Release the mouse button.
   The corresponding staves in all following systems are moved accordingly.
Moving one staff only

You may want to move one staff without affecting any other staff in any way:

PROCEDURE
1. Hold down [Ctrl]/[Command].
2. Drag any staff as described above.

Moving staves between pages

By using the “Move to Next/Previous Page” commands on the Staff context menu, you can quickly edit the page breaks.

Moving staves to the next page

PROCEDURE
1. Locate and activate the staff you want to move to the top of the next page. This can be any staff except the first staff on the page.
2. Right-click on the blue rectangle to the left of the staff, and select “Move to Next Page” from the context menu. The active staff (and any following staves on the page) are moved to the next page.

Moving staves to the previous page

PROCEDURE
1. Make the staff at the top of the page the active staff. If any other staff is active, the “Move to Previous Page” option cannot be used. Also, the function does not work for the first staff on the first page.
2. Right-click on the blue rectangle to the left of the staff, and select “Move to Previous Page” from the context menu. The active staff, and as many of the following staves as there are room for, are moved to the previous page. If the previous page is already “full”, nothing happens.
Adding brackets and braces

Brackets and braces are added on the Layout page of the Score Settings dialog. The settings you make are specific for the current layout, i.e., you can have different brackets or braces set up for different track configurations.

**PROCEDURE**

1. Open the Score Settings and select the Layout page. In the track list, you can find columns for braces ( { ) and brackets ( [ ).

2. Click in one of the columns and drag downwards in the list to encompass the desired staves. The column indicates graphically which staves are encompassed by the brace or bracket.

   ![Image of track list with brackets and braces]

   Click at the first staff for which you want a bracket or brace…

   ![Image of track list with brackets and braces, showing checkboxes]

   …and drag downwards in the list to enclose the desired staves.

3. Close the dialog. The score is displayed with brackets or braces according to the settings you made.

   - You can edit brackets and braces in the dialog by dragging the ends of the indicator in the list.
   - To remove a bracket or brace, click on its indicator in the list.

   You can automatically get broken bar lines based on the brackets you have added.

   If the “Show Braces in Edit Mode” option is activated in the Preferences dialog (Scores–Editing page), brackets and braces are shown in Edit Mode as well.

**RELATED LINKS**

- [Breaking bar lines on page 1301](#)

Displaying the Chord Symbols from the Chord Track

You can display the chord symbols from the chord track. Chord symbols can be viewed, edited, and printed out in Page Mode.

**PROCEDURE**

1. To show the Chord Track symbols, open the Scores menu, and from the Advanced Layout submenu select “Show Chord Track”.

   On the Layout page of the Score Settings dialog you can specify which staff should display the chord track.
2. To edit a chord symbol, double-click it.

**NOTE**

Moving chord symbols in the staff only affects the display. The position of the chords on the chord track remains unaffected.

**RELATED LINKS**

- Layout settings on page 1279
- Chord Functions on page 814

**Auto Layout**

This item on the Scores menu brings up a dialog with several options. Activating one of these makes the program “go through” the score and make adjustments to measure widths, staff distances, etc. Exactly which parts and properties of the score are affected depends on which option you activate/deactivate.

**IMPORTANT**

The automatic layout adjustments are done just as if you yourself had made them manually. This means that if there is something you do not like, you can always change it manually, as described above.

**NOTE**

You can also open the Auto Layout dialog by clicking the Auto Layout button on the extended toolbar.
Move Bars

This option looks at the currently active grand staff, and attempts to adjust the measure widths, so that all notes and symbols get as much room as possible. The number of bars on the staff is not affected.

• You can perform this function for several staves in one go, by dragging a selection rectangle over their left edges, and then selecting Move Bars.

Move Staves

This changes the measure width (as with Move Bars) but also the vertical staff distance, of the active staff and all following staves.

Spread Page

This corrects the vertical layout of the staves on the current page, so that they “fit onto the page”. In other words, this removes white space at the bottom of the page.

Hide Empty Staves

This hides all empty staves, from the active staff to the end of the score. Note that polyphonic/split staves are in this case treated as one entity, if the clef in the upper system differs from that in the lower system. That is, a piano staff is considered “empty” only if there are no notes on either staff.

• If you have activated the “Hidden” option on the filter bar, hidden staves are indicated by a marker with the text “Hide:Name” (where “Name” is the staff name).
  To display hidden staves, delete their “Hide” markers.

• If you activate the “Auto Layout: Don’t hide first staff” option in the Preferences dialog (Scores–Editing page), staves in the very first grand staff are not hidden, even if they are empty.
  This is useful for example if you are creating an orchestra score, and want to show the complete “layout” of the orchestra on the first page of the score, without hiding anything.

All Pages

Activate this if you want to apply the options above to all pages. Please note that this setting is applied to the active staff and onwards. If you want all pages in the score to be affected, you have to make the very first staff (the first staff on the first page) the active staff.
Move Bars and Staves

This is a combination of “Move Bars”, “Move Staves”, and “All Pages”, plus automatic calculation of the number of bars across the page – the function tries to optimize the number of bars across the page for each staff (with the maximum number of bars as set in the dialog).

Optimize All

All of the above in one fell swoop. This procedure might take some time but usually yields great results.

Other functions

In the lower part of the dialog, the following options are available:

Auto Space/Page Mode

The higher the value, the more space is allowed for each element in the score (and thus, the fewer the bars across the page).

Minimum Distance between Staves

When you use an Auto Layout function that moves staves (changes the vertical staff distance), this setting determines the minimum distance between the staves.

Minimum Distance between Grand Staves

This sets the minimum distance between Grand Staves in the same way.

Add to Auto Layout Distance

This number is added to the distance between staves that is added when you use any of the Auto Layout functions. The higher the number, the larger the distance between staves.

‘Spread Page’ Bottom Distance

This is added to the white space that appears on the bottom of a page when using the Spread Page functions.

Max. Number of Bars

This allows you to specify the maximum number of bars per staff when using the “Bars and Staves” or “Optimize All” functions.

NOTE

The functions “Move Bars” and “Move All Bars” (“Move Bars” + “All Pages”) can also be accessed via the Staff context menu (opened by right-clicking on the blue rectangle to the left of the active staff).
Reset Layout

This function allows you to delete invisible layout elements, which in effect restores the score to default settings.

PROCEDURE

2. Activate the items you want to delete or reset to standard settings.
3. Click on “This Staff” to clean up the active staff only, or on “All Staves” to clean up all staves in the score.

Reset Layout Options

Hidden Notes
Makes all hidden notes permanently visible again.

Hidden
Makes all other hidden objects permanently visible again.

Quantize
Deletes all Display Quantize elements.

Layout Tool
Resets all positions of notes, clefs, slurs and ties altered using the Layout tool.

Grouping
Resets the grouping under beams to standard values.

Cutflag
Deletes all cutflag events.

Stems/Beams
Resets the length of all stems and reset the slant of beams that have been manually adjusted.
Designing your score: additional techniques

Breaking bar lines

Sometimes you may not want a bar line to stretch all the way across a grand staff. If this is the case, you have the possibility to “break it”.

Manually

You can break the bar lines in one grand staff or in several grand staves and re-connect them.

Breaking bar lines in one grand staff

**Procedure**

1. Select the Erase tool.
2. Click on a bar line connecting the two staves.

Before and after splitting the bar lines between two staves.

All bar lines between these two staves (except the first and last) are broken. To break the first or last bar line in a grand staff, you need to click directly on these.

Breaking bar lines in several grand staves

If you hold down [Alt]/[Option] and click on a bar line as described above, the corresponding bar lines are broken in all following grand staves.
Re-connecting broken bar lines

If you have broken the bar lines, you can use the Glue tool to connect them again.

**PROCEDURE**

1. Select the Glue tool.
2. Click on one of the bar lines in the staff above the broken bar lines.
   All bar lines between these staves in this grand staff are connected.
   To re-connect bar lines in several grand staves, hold down [Alt]/[Option] and click with the Glue tool.
   The bar lines between the corresponding staves are connected in all following grand staves.

Automatically

If you have added brackets for some staves on the Layout page of the Score Settings dialog, you can have bar lines broken between each bracketed “section”, giving a clearer indication of which staves belong together:

**PROCEDURE**

1. Open the Score Settings dialog from the Score menu and, on the Project page, select the “Notation Style” subpage.
2. In the Bar Lines section, locate and activate the “Break Bar Lines with Brackets” option.
   The option Break Last Brackets determines whether the breaking of bar lines should also apply to the bar line at the end of each row.

**RELATED LINKS**

Adding brackets and braces on page 1296
Scoring for drums

About this chapter

In this chapter you will learn:

- How to set up the drum map.
- How to set up a staff for drum notes.
- How to enter and edit drum notes.
- How to use a single line drum staff.

Background: Drum maps in the Score Editor

When scoring for drums, you can assign a unique note head to each pitch. There is even the possibility to set up different note heads for different note values!

However, to be able to fully use this function, you need to understand a bit about drum maps, and the use of these in the Score Editor.

About drum maps

Cubase handles drum editing by means of drum maps. In the Score Editor, the drum map displays different note heads for different pitches.

You access the drum map by selecting “Drum Map Setup” from the MIDI menu.
Scoring for drums
Setting up the drum map

1. Open the Score Editor for the drums track. This should be a MIDI track to which you have assigned a drum map.
2. Open the Score Settings dialog and select the Staff page.
3. Select the Options tab and activate the “Use Score Drum Map” option.

RELATED LINKS
MIDI Editors on page 686

Use Score Drum Map on/off

For the drum map settings to be used in the score, you need to activate the “Use Score Drum Map” option in the Score Settings dialog on the Staff page (Options tab).

Setting up the drum map

To set up the drum map, proceed as follows:
5. Make settings for the sounds/MIDI notes you need.

**IMPORTANT**

Please note that many different drum maps can be created for a project. Which one you get depends on which drum map is assigned to the edited track. These drum maps are totally independent of one another, i.e. each pitch can have different settings in different drum maps.

---

**Score related options**

**Pitch**

This corresponds to the I-note of the sound in the drum map, and cannot be edited here.

**Instrument**

The name of the drum sound in the map.

**Display Note**

The display pitch, i.e. the pitch at which the note is shown in the score. For example, you typically want all three hi-hat sounds to be shown on the same system line in the score (but with different symbols). Therefore, you set these to the same display pitch.

**Head Symbol**

Clicking in this column opens a window in which you can select a note head symbol for the sound. If “Use Head Pairs” is activated in the dialog, you can select a note head pair instead.

**Voice**

This allows you to make all notes with this pitch belong to a certain voice, so that they get a common rest handling and stem direction, for example.

---

**Initializing the display pitches**

If you select “Init Display Notes” from the Functions pop-up menu in the top left corner of the Drum Map Setup dialog, all display pitch values are reset, so that actual pitch and display pitch are the same for each sound/note.

---

**Using note head pairs**

Not only can you have different drum sounds displayed with different note heads, you can also display different note heads for different note values:

**PROCEDURE**

1. Activate the “Use Head Pairs” checkbox.

The “Head Symbol” column now shows two head symbols for each drum sound.
Scoring for drums
Setting up the drum map

All head symbols are arranged in pairs – by default an “empty” head and a “filled” head. Just as with regular notes, the “empty” note heads are used with half notes and larger note values, and the “filled” heads are used with quarter notes and smaller note values.

2. To select a head pair for a drum sound/note, click in the Head symbol column to open the pop-up menu and choose the new head pair.

Customizing note head pairs

If you do not like the default pairs of note heads, you can edit these:

**PROCEDURE**

1. On the Functions pop-up menu, select “Edit head pairs”.

2. To change a symbol in a pair, click on it and select a new symbol from the pop-up menu.

3. When you are done, click Exit to close the dialog.

Editing the drum map in the score

If you activate the “Edit in Scores” option in the Drum Map Setup dialog, you can change the settings for the score drum map directly in the score:

- Transposing a note changes the display pitch of its drum sound – the actual note is not transposed.

- Double-clicking a note allows you to make note head settings for that drum sound.
Using the “Move to Voice” function changes the voice assignment of the drum sound.

**NOTE**

This requires that you leave the Drum Map Setup dialog open – closing the dialog automatically deactivates this option, allowing you to perform normal editing.

---

### Setting up a staff for drum scoring

**PROCEDURE**

1. Open the Score Settings dialog on the Staff page and select the Options tab.
2. Make sure that “Use Score Drum Map” is activated.
3. If you want a single line drum staff, activate the corresponding option.
4. If you want flat beams, activate the corresponding option.
5. If you want all stems to end at the same position, activate Fixed Stems and set a length for up/down stems.

You may also want to use polyphonic voices to handle rest and stem separately. However, you can still activate the “Fixed Stems” option if you like.

---

**RELATED LINKS**

- Using “Single Line Drum Staff” on page 1308
- Polyphonic voicing on page 1320
- Handling beaming on page 1188

---

### Entering and editing notes

This is like entering notes on a normal note system. However, Notes are edited using their display pitch when the drum map is used. This means that when you move a note vertically, you move it to another display pitch. What actual pitch it gets depends on which pitch uses the display pitch you now “dropped it on”.

**NOTE**

If the drum map contains two notes with the same pitch (for example open and closed hi-hat), you can get the second note by holding [Ctrl]/[Command].
Using “Single Line Drum Staff”

When this option is activated on the Options tab of the Staff page in the Score Settings dialog, there is only one line in the system. Furthermore, notes can only appear below the line, on the line and above the line.

To decide which notes go where, proceed as follows:

**PROCEDURE**

1. Open the Score Settings dialog on the Staff page and select the Options tab.
2. Activate “Use Score Drum Map” and “Single Line Drum Staff”.
3. Set up the two pitch values to decide which pitches go on the line.
   Notes below this range automatically wind up below the line and notes above wind up above the line.

**IMPORTANT**

When you enter and edit the pitch of notes on a single line drum staff, the best way is to drag the note up or down while watching the Mouse Note Position display in the status line.
About this chapter

In this chapter you will learn:

- How to create tablature, automatically and manually.
- How to control the appearance of the tablature notes.
- How to edit tablature.

Cubase is able to produce score in tablature format. This can be done automatically, by "converting" recorded MIDI information. You can also create a tablature staff from scratch and enter the notes “by hand”.

IMPORTANT

Even though we use the term “converting” in this chapter, please note that tablature is a mode. You can switch between regular notation and tablature at any time.

Creating tablature automatically

This assumes you have a regular score on screen already. We also suggest you perform basic editing like quantizing to make the score as legible as possible as regular notes before converting into tablature.

PROCEDURE

1. Make sure that the notes in the score are inside the range of the instrument. Notes with a pitch lower than the open tuning of the lowest string cannot be converted.

2. Open the Score Settings dialog on the Staff page and select the Tablature tab.
Creating tablature automatically

3. Activate “Tablature Mode”.

4. Select one of the predefined instruments from the pop-up menu.
   • If you are not using one of the predefined instruments, set the open tuning of each string using the value fields.
     You can create tablature for up to 12 strings. To disable a string, set it to Off, the lowest value.

5. If you want to use a capodaster, e.g. on the forth fret, enter the corresponding value in the Capo field.
   The tablature changes accordingly.

6. Make the desired settings for “No Stems/Rests” and “MIDI Channel 1–6”.
   No Stems/Rests gives you a score where the notes have no stems and where all the rests are hidden. The "MIDI Channel 1–6" feature is described below.

7. Click Apply.
   The tablature appears. You get as many note lines as you have activated strings. All the notes now have a fret number instead of their regular note heads.

8. Edit the score, if needed.
   You can make Display Quantize settings, add symbols, etc. as usual. However, editing the actual notes is a bit different from regular note editing, see below.

Using “MIDI Channel 1–6”

This feature makes notes automatically appear on the correct string according to their MIDI channel value.
Creating tablature

Creating tablature manually

Normally, the program automatically decides on which string to display a note, by looking at the pitch and then putting the note at the lowest possible string. You can then either manually move a note to the correct string, or use the “MIDI Channel 1–6” option to let the program move the notes automatically.

PROCEDURE

1. Many guitar synthesizers are able to transmit each string on a different MIDI channel. If you have such an instrument, set it up so that the high E string transmits on MIDI channel 1, the B string transmits on MIDI channel 2, etc. This feature can be used for MIDI string instruments with up to six strings.
2. Record the project. Quantize and edit it as desired.
3. Make sure that the “MIDI Channel 1–6” option is activated and convert the notes into tablature, as described above.
4. The notes are automatically placed on the right strings.
   For example if you played a “B” on the low E-string, it appears as a “7” on that string, not as a “2” on the A-string.

Creating tablature manually

To set up an empty system for inputting tablature, proceed as follows:

PROCEDURE

1. Double-click on the clef symbol in the score to open the Edit Clef dialog.
2. Change the clef to the tablature symbol.
3. Open the Score Settings dialog on the Staff page and select the Options tab.
4. Set the “System Lines” to as many strings as the instrument you are scoring for has.
5. Raise the Add Space value to 1 or 2.
   You need a little extra space between note lines to make room for the numbered note heads.
6. On the Tablature tab, activate “Tablature Mode”.

Suggested system line settings for guitar tablature
7. Set up whatever other parameters you need in the dialog, and click Apply.
8. Select the Insert Note tool and move the pointer over the score.
9. Press the mouse button and drag up and down until the note appears on the desired string with the correct fret number (you can also verify the pitch on the toolbar, as usual).

When you drag up and down, the program automatically selects the lowest possible string. If you want a fret number higher than 4 on a guitar tablature, for example, you have to use “Move To String”, see below.

![Mouse Note Position](example.png)

Setting the correct pitch. Use the Mouse Note Position display in the status line as an additional guide.

10. Release the mouse button.
The note is displayed.

---

**Tablature number appearance**

In the Score Settings dialog on the Project–Font Settings subpage, you can find settings for the tablature numbers. In the “Font For” pop-up menu, select “Tablatures” and then select the desired font, size, and style for the number note heads.

**Editing**

Tablature can be edited like any other score. You can move notes, handle beaming, stem direction, etc.

**Moving notes to another string**

If you want for example a “C” to appear as an “8” on the low E-string rather than a “3” on the A-string on a guitar, proceed as follows:

**PROCEDURE**

1. Select one note or a number of notes that you want to move to a new string.
2. Right-click on one of the selected notes and, from the “Move to String” submenu, select the desired string.

The Fret number is automatically adjusted according to the tuning of the instrument (as set up on the Tablature tab of the Staff page in the Score Settings dialog).
Moving notes

Moving notes in pitch in a tablature score is working the same way as entering notes manually, see above.

Editing on the info line

You can change the pitch of notes on the info line as usual. The string and fret number are updated automatically in the score.

Note head shape

If you only want to enter a fret number for your notes (Tablature mode off), you can use the Set Note Info dialog on regular notes.

**PROCEDURE**

1. Double-click on the head of a note.
   The Set Note Info dialog appears.
2. Activate the Tablature option and set a fret number in the value field to the right.
3. Click Apply.
The score and MIDI playback

About this chapter

In this chapter you will learn:

• How to use the Arranger mode to have the playback follow the structure of the score.

• How to use the “mapped” Dynamics symbols.

NOTE

Cubase Pro only: You can also play back articulations in the Score using the Expression Map and Note Expression functions.

RELATED LINKS

Expression maps (Cubase Pro only) on page 778
Note Expression on page 792

Scores and the Arranger mode

Repeats (bar lines) appear in all layouts, as well as Project symbols like Segnos, Codas, Da Capo, endings, etc. To have the playback in Cubase follow these directions, proceed as follows:

PROCEDURE

1. Add the desired repeats and project symbols to the score.

2. Right-click the toolbar in the Score Editor and make sure that “Arranger” is ticked.
   This adds the Arranger buttons to the toolbar.

3. Click the “Activate Arranger Mode” button on the toolbar and start playback.
   Playback follows the repeats and Project symbols in the score – sections within repeat symbols are repeated, the playback position jumps to the beginning when encountering a Da Capo symbol, and so on.
Working with mapped dynamics

Apart from the dynamics symbols found on the Dynamics tab, you can also use 12 “mapped” Dynamics symbols. These make use of the Note Expression functionality in Cubase. Mapped Dynamics symbols can be played back using three different methods: by modifying the velocity values in percentages, by sending volume controller messages or by sending additional generic controllers. These methods can also be combined.

RELATED LINKS
Note Expression on page 792

Setting up the symbols

You can make settings for the symbols in the Dynamics Mapping Setup dialog. On the left in the upper section, the available symbols are listed.

- To open the dialog, right-click on one of the symbols on the Dynamics Mapping tab in the Symbols Inspector and select “Dynamics Mapping…”.

When mapped dynamics symbols have been added to the score, you can also double-click on a symbol to open the dialog.
In the dialog, you can make the following settings:

**Change Velocities**

You can create dynamics by defining different velocities for the different symbols.

**PROCEDURE**

1. Activate the “Change Velocities” checkbox in the lower section of the dialog.
2. Set up a percentage value (positive or negative) in the Velocity column to specify by how much the corresponding symbol will raise or reduce the current velocity value of a note.

**Send Volume**

You also have the possibility to define the dynamics by sending Volume controller values.

**PROCEDURE**

1. Activate “Send Volume” in the lower section of the dialog, and select whether you want to use the MIDI controllers 7 or 11 or the VST 3 parameter Volume (if the instrument you are using is compatible with VST 3).
2. Set up a percentage value (positive or negative) in the Volume column to specify by how much the corresponding symbol will raise or reduce the current volume of a note.

**NOTE**

When “Send Volume” is activated and set to VST 3 Volume, the VST 3 volume events in the notes are being merged with the volume specified for the Dynamics symbols, according to the Merge Mode setting, see below. However, make sure that the edited part does not contain events for MIDI controller 7 (Main Volume) or 11 (Expression) on the controller lane.

**The Merge modes**

When you use the parameter VST 3 Volume in the notes and for the dynamics symbols, the result depends on the Merge Mode. The following modes are available:

**Average**

When this is selected, the average of the two volume messages will be used for the notes.

**Merge**

When this is selected, the VST 3 Volume setting for the Dynamics symbols modulates the existing VST 3 Volume setting of the notes. Higher settings increase the volume and low settings decrease the volume set for the note.
Send Controller

You can also send an additional MIDI controller (except MIDI controllers 7 and 11, which are used for the “Send Volume” function).

If you combine this with the “Send Volume” function, you can set up a sound which gets brighter as it gets louder, which is useful when working with strings or woodwind and brass instruments.

PROCEDURE
1. Activate “Send Controller” and specify the controller you want to use in the pop-up menu.
   You can select any of the available MIDI controllers, but also VST 3 parameters (except Volume, Pan, and Pitch).
2. Set up a percentage value (positive or negative) in the Controller column to specify by how much the corresponding symbol will raise or reduce the controller value of a note.

Initializing the Dynamic Range

You can specify the dynamic range for the work with mapped dynamics symbols using the pop-up menu in the middle section of the dialog.

If you select “pp-ff”, the extreme Dynamics symbols (pppp, ppp, ffff, and fff) do not have an effect. If you select “pppp-ffff”, the whole dynamic range will be used.

Using dynamics symbols in the Score Editor

Once you have set up the dynamics as desired, you can use the symbols in the Score Editor.

Inserting dynamics symbols

When you insert dynamics symbols, note the following:

- Select the desired symbol on the Inspector tab and click at the position in the Score Editor at which you want to insert the symbol.
  Note that the “mapped” dynamics symbols have a different color scheme than the regular dynamics symbols.

- Crescendi and Decrescendi are updated intelligently, i.e. when you have inserted a crescendo between two dynamics symbols and the order of these symbols is reversed, the decrescendo automatically becomes a crescendo.
• When you insert a crescendo symbol which is not preceded by a Dynamic symbol, the “assumed” start value is mezzo forte (mf).

• Likewise, if a crescendo symbol is not followed by a dynamic symbol, an end value will be calculated automatically.
  For a crescendo, this is one value above the start value, and for a decrescendo one value below the start value.

Modifying/Editing dynamics symbols

You can change the settings for the dynamics symbols at any time in the Dynamics Mapping Setup dialog, as described above.

• You can step between the available dynamics symbols by using the commands “One up” and “One down” on the context menu, by using the corresponding key commands, or by clicking the “+” and “-” buttons on the toolbar.
  When several dynamics symbols are selected, they will all be modified accordingly.
Overview

This chapter provides useful information about editing techniques and answers to a number of questions that might arise when you use the Score Editor. For more information about the functions referred to, please use the index and check the previous chapters.

Useful editing techniques

Use this section to find out more about some editing techniques that help you to use the score functions more efficiently.

Moving a note without transposing it

If you hold down [Ctrl]/[Command] while moving a note (or several notes), only horizontal movements are possible, so that you do not have to worry about the notes being transposed. You can also set up a key command for this. This is done in the Key Commands dialog (Nudge category).

Moving and spacing several staves

If you have a number of staves that you want displayed with an equal distance (for example, all strings of a grand staff in a full orchestra score), this can be done using the Position Info window:

**PROCEDURE**

1. Open the Preferences (Scores–Editing page) and deactivate the “Global staff Spacing with [Alt]/[Option]–[Ctrl]/[Command]” option.
2. In the score, select the staves you want to set to an equal distance.
3. Open the Position Info window by clicking on the ruler.
4. Use the To Previous Staff or To Next Staff settings to specify the desired
distance between the staves.
All selected staves are spaced according to your settings.
If you do this when the “Global staff Spacing with [Alt]/[Option]-[Ctrl]/[Command]”
option is activated, all staves in the score are affected.

Polyphonic voicing

If you are working on a full score with more than one instrument in one staff (2 flutes,
2 trumpets, etc.), you should use polyphonic voices. And even if both instruments
play the same notes, you should insert notes for both instruments (you can mute the
notes of the second voice, if playback is an issue). If you do this, it is much easier
to extract single parts later by using the “Extract Voices” command.

Using the bar handles

Double-clicking a bar handle opens the Bar Copy dialog. This function is great for
copying accents, but you can also use it for copying drum phrases, etc.

• If you hold down [Shift] and double-click on a bar handle, this and the next bar
  are selected.
  This is handy when copying phrases of two or more bars in one go.

RELATED LINKS
Moving and duplicating with the bar handles on page 1229

Copying a section with “invisibles”

If you want to copy and paste a section which contains hidden elements, adjusted
beams and stems, etc., there are two ways to proceed:

• Use the filter bar to make indicators appear in the score. Then select these
  indicators together with the notes before you copy.
  This ensures the notes are copied with their formatting, etc.

• Double-click the bar handle of one of the bars, and make sure all relevant
  event types are activated in the dialog. Then select the bars you want to copy
  by clicking their bar handles, and copy them by [Alt]/[Option]-dragging the bar
  handles.

RELATED LINKS
Moving and duplicating with the bar handles on page 1229
Using “Scores Notes To MIDI”

This function converts the score data, as displayed, into MIDI data. Let’s say for example that you have set up the score so that it is displayed to 99% the way you want it to be. Yet, that last 1% forces you to deactivate some of the Staff Settings (like Clean Lengths, No Overlap, or Auto Quantize), which makes other parts of the score illegible. In this case, try using the “Scores Notes To MIDI” function. Note that you should work on a copy of the track!

RELATED LINKS
Using "Scores Notes To MIDI" on page 1125

Optimizing rests

If you have a number of consecutive empty bars, you can replace them with one multiple rest.

RELATED LINKS
Multi-Rests on page 1281

Zero system lines

Having no system lines at all might seem like a stupid idea to start with. But this option allows you to create chord sheets really quickly.

![A lead sheet created by specifying “0” system lines](image)

RELATED LINKS
Using Make Chord Symbols on page 1248

Examples and scales

If you are creating scale examples and similar, you can use the Real Book option and manually hide all symbols at the beginning of the first staff to make the score appear like separate unconnected “lines”.

Remember you can also hide the bar lines.

![An example scale without bar lines](image)
Controlling the order and appearance of grace notes

Normally, grace notes are beamed. Their order under the beam is controlled by their order in the track. It is enough to put a grace note one tick before the next grace note to make them appear in the desired order under the beam.

Initially the grace notes are put in with a 32nd note beam. By double-clicking the note and changing the “flag” type in the Set Note Info dialog, you can change this.

![Complex grace notes](image)

Speeding up inserting key changes

If you have a grand staff with many instruments, inserting key changes one by one can take a lot of time.

In this case, activate “Key Changes for the entire Project” on the Key context menu or in the Score Settings dialog, on the Project–Notation Style subpage (Keys category). This way, all changes made to the key always affect the entire project.

Speeding up inserting staccato and accents

Symbols linked to notes can also be put in for a number of notes at the same time, even on different staves.

**RELATED LINKS**

Adding a symbol to several notes using the Draw tool on page 1214

Setting the distance between staves in a piano score

Drag the first bass staff on the first page. This copies the spacing to all staves. Please note that this can only be done in Page Mode.

Frequently asked questions

In this section, you can find some answers to questions concerning adding and editing of notes as well as the handling of symbols and layouts.
I enter a note with one value and it is shown as a note with another value.

Set the Rests value for Display Quantize to a smaller note value. Try deactivating Auto Quantize, especially if you do not have any triplets or triplets only.

Notes are not displayed at the correct positions.

Try changing the Notes value for Display Quantize.

There are a number of short rests after my notes.

Your Rests value for Display Quantize might be set to too small a note value. Raise it. Also check the “Clean Lengths” setting.

When I change the length of a note, nothing happens.

This is because the Display Quantize value puts a restriction on what note values can be displayed. Check that Display Quantize is set to the smallest note value you have in your project.

I have adjusted Display Quantize and the other staff settings best I can. The notes are still shown with the wrong values.

You might need to use one of these three features: inserting Display Quantize events, using polyphonic voicing, or applying “Scores Notes To MIDI”.

In the Score Settings dialog, I change the Display Quantize settings on the Staff page (Main subpage) and nothing happens.

Did you remember to click Apply? Maybe you have already inserted Display Quantize events in the score? These override the staff settings.

Suddenly many Display Quantize events appear in the score.

This is not a malfunction. If you had Auto Quantize on and start inserting Display Quantize events, the auto quantizing is automatically transformed into Display Quantize events.
One long note is shown as many tied notes.

Do other notes occur at the same positions but with different lengths? Then you need to use polyphonic voicing. Are the note(s) syncopated? Then you should try the syncopation feature.

Even though I've tried the above, notes are not tied as I want them.

The way notes are tied in Cubase follows basic notation rules. You may need to make exceptions to these rules, by using the Cut Notes tool.

I have an unnecessarily large amount of rests.

Especially with polyphonic voicing, superfluous rests may be created. Try deactivating rests for one or more voices. You might also leave the rests activated in the Score Settings dialog on the Staff page (Polyphonic tab) and then hide the rests you do not need, one by one.

When using polyphonic voices, a number of rests are drawn on top of each other.

As above, you should try hiding rests in the Score Settings dialog on the Staff page (Polyphonic tab), center rests and possibly manually moving or hiding rests.

In polyphonic voices, notes that are on the same musical position are not displayed exactly vertically above each other.

This is not a malfunction. Cubase has built-in automatic algorithms for making the score as legible as possible. Sometimes this includes adjustments of the “graphic” position of notes, especially with small intervals like seconds. You can always move the notes using the Layout tool.

When using polyphonic voices, notes with small intervals “collide”.

As described above, Cubase tries to avoid this, but only for voices 1 and 2 in the upper staff and voices 5 and 6 in the lower. For other voices, please use the Layout tool to manually move the notes.
Tips and Tricks
Frequently asked questions

When I select a note, nothing is shown on the info line.

The note is probably tied to another note. This means that the second note does not really exist, it is just a graphic indication that the main note is long. Try selecting the main note instead.

Symbols from the Layout Symbols tab are sometimes invisible when I open the score.

This is not a malfunction. Those symbols are part of a layout. If you open the score with another layout, for example because you open another combination of tracks, you can see another layout which might not contain any Symbols at all.

**RELATED LINKS**

- Working with layouts on page 1269

I can’t select an object on the screen, or I can’t select an object without selecting another object.

Drag a selection rectangle around the objects. Then hold down [Shift] and deselect all the objects you do not want included, by clicking on them. You should also check out the lock layer function.

Symbols have disappeared.

Are they layout symbols? Then maybe they belong to another layout than the one you are editing now.

If that is not the reason, maybe you have inserted the symbol into the wrong staff.

**RELATED LINKS**

- Important! – Symbols, staves, and voices on page 1212

A symbol doesn’t move with its staff. Auto Layout produces far too wide spacing.

Maybe you have inserted the symbol into the wrong staff.

**RELATED LINKS**

- Important! – Symbols, staves, and voices on page 1212
A note symbol appears too far from the note I wanted it inserted on.

Do you have activated the correct voice? Note symbols are inserted into voices, just like notes.

The note I recorded is displayed with the wrong length. For example, I recorded a sixteenth and got a quarter note.

You probably have the wrong Display Quantize value set. Open the Score Settings dialog and select the Staff page. If Auto Quantize is activated, deactivate it, unless you have mixed triplets and regular notes. Also check the Notes and Rests Display Quantize values. If the settings are too “coarse”, change them to a smaller note value. If you for example need the program to display an eighth note rest, Rests Display Quantize must be set to “8” or a smaller value. If No Overlap is activated, you might want to turn it off.

**RELATED LINKS**
How the Score Editor works on page 1089

There is a pause after a note that I don’t want.

You probably added a note with the wrong note value. Either lengthen the note (physically or graphically) or delete the one you have and add a new one with the correct note value. If this problem occurs a lot in your score, try selecting a larger Rests Display Quantize value.

**RELATED LINKS**
Changing the length of notes on page 1143
Deleting notes on page 1150
Using Rests as Display Quantize setting on page 1092

There is no pause after the note although there should be one.

Either the note is too long (use Clean Lengths or change the current note’s length), or Rests Display Quantize is set to too high a value. Open the Score Settings, select the Staff page and lower the value.
The note has an accidental when it shouldn’t, or it doesn’t when it should.

Maybe the note is simply of the wrong pitch? Click on it (using the Object Selection tool) and look at the info line. Move it to the correct pitch. If this is not the reason, maybe you have the wrong key set? And finally, you can also use enharmonic shifting.

**RELATED LINKS**
- The info line on page 1102
- Editing pitches of individual notes on page 1141
- Accidentals and enharmonic shift on page 1181

Notes are not grouped under beams the way I want it.

Normally the program groups eighth notes, sixteenths, etc. under beams. This can be deactivated. There is also detailed control of which notes are grouped under a beam.

**RELATED LINKS**
- Handling beaming on page 1188

If you wish you had a faster computer

Here are some tips for those who find some operations slower than they would like:

- Work on a smaller section of the score at a time. Break the project up into parts and work on those parts individually until the final layout stage.
- Switch on multi-rests as late as possible.
- When working in Edit Mode, set Default Bars Across The Staff to a small value, for example 2.
- In Edit Mode, resize the window so that only one grand staff at a time is visible.
- Consider upgrading your computer hardware.
Index

A
Accelerando 1191
Accents
Above stems 1213
Accidentals
About 1181
Distance from note 1183
ACID® loops 451
Acoustic feedback 689
Sample Editor 441
Score Editor 1138
VariAudio 485
Activate 'Link Panners' for New Tracks 1082
Activate Project 76
Activate Read/Write for all tracks 585
Active TrackVersion 154
Adapt (Display Quantize) 1157
ADAT Lightpipe 957
Add Track 134
Add Track dialog 134
Adding chords 817, 821
AES/SPDIF Digital Audio 957
AES17
Meters 315
AIFF files 948
Algorithms
Limitations 430
Sample Editor 451
Time stretching 428
Aligning
Dynamics 1237
Text 1253
Aligning file and project attributes
Pool 521
Alignment level (Meters) 315
All MIDI Inputs 20
Allow Editing in Results List 1073
Appearance
Colors 1053
Metering 1074
Applying Track Presets 162
Archive
Prepare 79
Arranger mode 1314
Arranger track 103
Arranger tracks
Adding 259
Creating a chain 260
Flattening 264
Renaming events 259
Articulations 778
Adding sound slots 786
Auditioning with expression maps 779
Editing 722
Editing on the controller lane 783
Editing on the info line 784
Mapping sound slots 787
Remote key settings 789
Sorting in Groups 789
ASCII display
Editing byte values 777
ASIO
Direct Monitoring 18
ASIO devices
Plug and play support 18
ASIO Direct Monitoring 217
ASIO driver
DirectX setup 15
ASIO Latency Compensation
Active by Default 1076
ASIO ports
Using for data only 975
ASIO-Guard 1049
Aspect ratio
Video Player window 988
Attributes
About 544
Defining 549
Editing in the MediaBay 546
Managing lists 549
Audio
Detecting the tempo 920
Handling 167
Overlapping 143
Slicing 465
Audio channels
Mixing down to file 938
Audio clips
About 167, 401
Audio clock
About 957
Audio effects
Applying 416
Surround 558
Using VST System Link 978
Audio events
About 167
Auditioning 169
Creating from regions 450
Editing in Project Browser 929
Editing in Sample Editor 433
Editing selections 446
Fade handles 247
Making selections 444
Showing in Sample Editor 433
Slicing 465
Volume handles 249
Audio files
Adjusting to the project tempo 453
Exporting 938
Removing unused 79
Audio hardware 1047
Connections 13
Externally clocked 16
Audio loops
Musical Mode 452
Tempo matching 452
Audio parts
Auditioning 169
Creating 168
Editing in Audio Part Editor 492
Editing in Project Browser 930
Audio performance
Optimizing 1045
Audio Pre-Record Seconds 1075
Audio processing
Pool 517
Audio Record Modes 222
Audio Recording 221
Preparations 220
Pre-Record Time 224
RAM Requirements 220
Record File Format 219
Record Folder 219
Record Modes 222
Recording a downmix 223
Recording with Effects 222
Recovering 224
Recovering recordings 223
Undo 223
Audio regions
About 167
Audio tracks 82
Render in Place 172
AudioWarp
Unstretching audio 491
Audition chords 823
Audition through MIDI
Inserts/Sends 1068
Auditioning
Acoustic feedback 441
Audio events 169
Audio Part Editor 495
Audio parts 169
Sample Editor 441
Speaker tool 441
Using key commands 441, 495
Auditioning key commands
Pool 512
Auto Disable Talkback Mode 1085
Auto fades
Global settings 256
Track settings 257
Auto layout
About 1297
Hiding empty staves 1298
Moving bars 1298
Moving staves 1298
Auto Layout - Don’t hide first staff 1077
Auto Monitoring 1082
Auto Punch In 215
Auto Punch Out 215
Auto Quantize 1157
Auto Save 1067
Auto save 77
Auto Save Internal 1067
Auto Select Events under Cursor 1054
Auto Track Color Mode 1066
Automatable parameters
Controlling with Quick Controls 625
Automatic scales 824
Automatic voicings 825
Automatically generating new audio clips
Pool 521
Automation
About 576
Activating Loop 592
Activating To End 591
Activating To Punch 591
Activating To Start 591
Continuous fill 592
Drawing Fill manually 592
Editing in Project Browser 934
Fill options 590
Freeze Trim 589
Functions pop-up menu 589
Initial value 584
Jump curves 576
One Shot 592
Ramp curves 576
Read 577
Show options 594
Static value line 576
SurroundPanner V5 573
Suspense options 593
Suspend Read 593
Tempo 907
Trim 588
Virgin territory 584
Write 577
Automation data
Adjusting curves 581
Editing 580
Removing 581
Selecting 580
Automation follows Events 1054
Automation Merge Modes 596
Automation modes
About 586
Auto-Latch 587
Cross-over 587
Touch 586
Automation panel
About 585
Read buttons 585
Write buttons 585
Automation tracks
About 582
Assigning parameters 583
Hiding 583
Muting 584
Removing 583
Showing 583
Auto-Scroll
Crossfades 254
Sample Editor 433
Score Editor 1098
B
Back up Project 79
Background Color
Modulation 1064
Bank assignments 663
Bar handles 1229, 1320
Bar lines
Breaking 1301
Indenting 1292
Moving 1291
Selecting type 1287
Bar numbers
Offsetting 1268
Settings 1266
Spacing 1267
Bars
Moving 1298
Moving to next/previous staff 1290
Number across page 1289
Resetting spacing 1292
Basic chord types
Applying to selected notes 713
Batch export
Audio channels 938
Beams 1189
Across staves 1193
Appearance 1194
Group settings 1194
Grouping 1188
Manual adjustment 1195
On/Off 1188
Slant 1194
Stem direction 1178
Beat Calculator 911
Bezier slurs 1217
Binary display
Editing byte values 777
Block text 1259
Bounce (Export Audio) 938
Bounce MIDI 679
Bounce Selection 189
Sample Editor 448
Box symbol 1239
Braces 1296
Bracket heads 1183
Brackets 1296
Brillenbass 1190
Broadcast Wave Files
Embedded information 1076
Broadcast Wave files
Exporting 949
Buffer
Settings 1047
Busses
  Adding 30
  Child busses 31
  Mixing down to file 938
Bypass
  AudioWarp 485
  Pitch changes 485
  SurroundPanner V5 573
Byte values
  Editing in ASCII display 777
  Editing in binary display 777
  Editing in decimal display 777
C
  Cadence mode
  Chord Assistant 819
  Complexity filters 819
Changing styles 741
Channel linking 307
Channel names
  Searching 305
Channel overview
  MixConsole 291
Channel racks 300, 325
  EQ 330
  Filters 327
  Gain 328
  Inserts 328
  Phase 328
  Pre 327
  Routing 325
  Sends 342
  Strips 333
Channel Rotation 800
Channel settings 348
  Assigning Quick Control parameters 347, 620
  Copying 319
Channel strip rack 333
  Compressor 333
  EQ position 333
  Gate 333
  Limiter 333
  Presets 342
  Saturation 333
  Transformer 333
Channel types
  MixConsole 299
Channels
  Adding to link groups 307
  Controlling with VCA faders 308
  Linking 305
  Removing from link groups 308
Chase Events 1068
Chase events 209
Child busses 31
  In surround configuration 560
Chord Assistant 818, 841
  Assigning Chords to Chord Pads 845, 846
  Cadence mode 819
  Circle of Fifths 841, 843
  Common notes mode 819
  Complexity 819
  Gap mode 819
  Proximity 841, 842
Chord Editor
  Assigning Chords to Chord Pads 844
Chord editor 816
  Adding chords 821
  MIDI Input 818
Chord events 815
  Adding 817
  Assigning to MIDI effects or VSTis 828
  Auditioning 823
  chord type 815
  Converting to MIDI 828
  Editing 817
  Extracting from MIDI 833
  Getting suggestions 821
  Mapping offset 825
  Resolving Display Conflicts 823
  Tension 815
  Voicings 825
Chord Font 1066
Chord Pad Controls 838
Chord Pad Settings
  Pad layout 856
  Players 853
  Remote Control 850
Chord Pads 836, 841
  Adaptive voicing 854
  Assigning Chords from the Chord track 847
  Assigning Chords to Chord Pads 844
  Assigning Chords with the Chord Assistant 845, 846
  Assigning Chords with the Chord Editor 844
  Assigning Chords with the MIDI keyboard 847
  Changing the pads remote range 852
  Context menu 839
  Controls 841
  Creating events from chord pads 858
  Default remote assignment 851
  Functions menu 840
  Moving and Copying 848
  Pads remote range 851
  Pattern player 855
  Players 854
  Playing back with a MIDI keyboard 848
  Preparations 841
  Presets 857
  Recording chords on MIDI or instrument tracks 849
  Recording chords on the Chord track 849
  Saving presets 858
  Setting up 841
  Using different players on multiple tracks 855
  Voicings 854
  Zone 841
Chord Pads Zone 836, 838, 839, 840
Chord Symbols 1066
Chord symbols
  Global settings 1249
  Inserting manually 1246
Chord track 105
  About 814
  Assign Pads 847
  Controlling MIDI or audio playback 830
  Live transform 829
Chord voicing
  Changing 711
Chords
  Changing pitch 710
  Changing voicing 711
  Editing 711
  Inserting 712
Cleanup 1012
Clefs
  Editing 1149
  Inserting 1148
Moving 1150
  Selecting automatically 1111
  Setting initial 1106
Clip editing
  Pool 513
Clock sources 957
Coloring
  Events 690
  Note events 690
Coloring tracks 136
Colorize Only Folder Track
  Controls 1066
Colorize Track Controls 1066
Colors
  Assigning to MIDI notes 1186
  Customizing 1035
  Preferences 1053
Colors for Additional Meanings
  Scores 1077
Common notes mode
  Chord Assistant 819
  Complexity filters 819
Complexity filters
  Cadence mode 819
  Common notes mode 819
Compressor
  Strip module 333
Connect Sends automatically for each newly created Channel 1082
Connecting
  Audio 13
  MIDI 19
Constrain Delay
  Compensation 609
Contiguous note events 707
Continuous controllers
  Controller display 717
  Controller lane 723
Continuous Fill
  Fill options 592
  Control link 305, 307
Control Room 352
  Adding channels 352
  Channels section 357
  Control Room channel 360
  Cue channels 357
  Downmix Presets section 359
  Exclusive port assignment 353
  External section 356
  Input gain 362
  Input phase 362
  Insert effects 362
  Main mix output 353
  Mixer 356
  Monitors section 358
  Opening 352
  Outputs 353
  Phones section 359
  Routing 353
  Setup pane 362
Control Room channels 353, 357
  Adding 352
  Cues 354
  External inputs 355
  Metering 355
  Monitors 354, 362
  Phones 354
  Talkback 355, 362
Controller Brightness 1065
Controller curves
  Smart controls for scaling 725
Controller display 716
  Adding events 718
  Continuous controllers 717
  Deleting events 727
  Drum Editor 751
  Editing events 718
  Editing events with Draw tool 721
  Editing events with Line tool 720
  Key Editor 705
  Line tool 720
  Moving events 726
Controller lane
  Continuous controllers 723
  Editing articulations 783
  Editor 725
  Selecting event types 716
  Setting up as preset 718
Controller lane editor
  Opening 725
Controller lane presets 718
Controllers
  Selecting 727
Convert to Real Copy 186
Converting chord events to MIDI 828
Copying
  Notes in score 1140
  Symbols in score 1233
Create Audio Images During Record 1075
Create MIDI track when loading VSTi 1084
Creating gaps
  Automation 584
Crescendo
  Drawing 1236
  Flipping 1236
  Keeping horizontal 1236
Crossfades
  Auto Zoom 254
  Auto-Scroll 254
  Creating 252
  Editing in dialog 254
  Equal Gain 254
  Equal Power 254
  Presets 254
  Removing 253
  Simple Crossfade Editor 254
  Symmetric Fades 254
Cross-Hair Cursor 1063
Cross-hair cursor 64
Cue Mix
  Setting up 365
  Cue notes 1199
  Cue Sends 366
  Adjusting the volume 366
  Cue mix 365
Cursor Width 1080
Customizing
  Appearance 1034
  Colors 1035
  Info line 1032
  Inspector 1032
  Toolbars 1032
  Transport panel 1032
Cut Notes tool 1197
Cut tool
  Score Editor 1145
  Cutflag events 1197
Cutting
  Notes in score 1140
Cycle Follows Range
  Selection 1054
Cycle markers
  About 281
  Editing with tools 282
  Using 282
  Zooming 282
Cycle recording 214
D
  Damper pedal symbols 1238
Index

DC Offset
- Removing 412
Deactivate Punch In on Stop 1080
Deactivate Read/Write for all tracks 585
Decimal display
- Editing byte values 777
Deep Track Folding 1061
Default Author Name 1068
Default Company Name 1068
Default Edit Action 1065
Default MIDI editor 687
Default Number of Bars per Staff 1077
Default Send Level 1082
Default Stereo Panner Mode 1082
Default Track Area Width 1066
Default Track Name Width 1066
Default Track Time Type 1064
Default Warping Algorithm 1056
Delay compensation
- Constraining 609
Delay Compensation Threshold (for Recording) 1082
Delete Overlaps 1054
Deleting
- Continuous Controllers 683
- Controllers 683
- Doubles 682
- MIDI controllers 683
- Notes 682
- Notes in score 1150
- Score symbols 1233
Deleting Overlaps
- Mono (MIDI) 681
- Poly (MIDI) 681
Designating a new pool record folder
- Pool 516
Detect Silence 421
Deviation (Display Quantize) 1157
Device panels
- About 688
- Selecting for busses 30
Dim Cue during Talkback 1085
Diminuendo
- Drawing 1236
- Keeping horizontal 1236
Disable 'Acoustic Feedback' during Playback 1062
Disable Track 141
Display format
- Ruler 48
Display line
- Fader section 305
Display Object Selection tool after Inserting Symbol 1077
Display Quantize 1090
- Auto 1157
- In polyphonic voices 1172
- Rests 1092
- Tool 1093, 1122
Display Transpose
- About 1159
- Disable 1115
Dithering
- About 380
- Applying 380
- Effects 379
Double-click on staff flips between full score/part 1077
Double-Click Symbol to get Draw tool 1077
Drag Delay 1054
Draw tool
- Drawing note events 706
- Editing controller display events 721
- Editing events 721
- Score Editor 1212
Drawing
- In Sample Editor 444
Driver 1047
Drum Editor 743
- Controller display 751
- Info line 703, 749
- Note display 750
- Status line 748
- Toolbar 744
Drum maps
- Editing in score 1306
- Key Editor 713
- Opening automatically 687
- Selecting 753
- Setting up 756, 757
Drum notes
- About 1303
- Adding and editing 1307
- Head pairs 1305
- Setting up staves 1307
- Single line 1308
Drum patterns
- On different instruments 755
Drum sound setup
- Drum sound list 752
Drum sounds
- From different instruments 755
- Settings 757
- Drum tool 753
Dump request messages
- MIDI SysEx Editor 774
Dumping sounds to instrument 775
Duplicate
- Notes in score 1140
- Duplicate tracks 141
- Duplicating
- Note events 739
- Duplicating events 185
Dynamics
- Editing 722
- Dynamics symbols
  - Adding 1235
E
- Edit Active Audio Event Only 433
- Edit as Drums when Drum Map is assigned 1065
Edit button
- MIDI track Inspector 644
Edit History dialog 65
Editing events
- Group editing 187
Editing MIDI notes and controllers
- In-Place Editor 771
Edits folder 401
Effect parameters
- Quick Controls 619

1332
<table>
<thead>
<tr>
<th>Effects</th>
<th>EQ presets 332</th>
</tr>
</thead>
<tbody>
<tr>
<td>About 372</td>
<td>Equal Gain</td>
</tr>
<tr>
<td>Comparing settings 392</td>
<td>Crossfades 254</td>
</tr>
<tr>
<td>Control panel 391</td>
<td>Equal Power</td>
</tr>
<tr>
<td>Converting earlier presets 396</td>
<td>Crossfades 254</td>
</tr>
<tr>
<td>Copying presets 396</td>
<td>Equalizer curve</td>
</tr>
<tr>
<td>Default presets 395</td>
<td>MixConsole 291</td>
</tr>
<tr>
<td>Dithering 379</td>
<td>Erase tool 693</td>
</tr>
<tr>
<td>Earlier presets 396</td>
<td>Breaking bar lines in score 1301</td>
</tr>
<tr>
<td>Exporting plug-in information files 400</td>
<td>Deleting notes in score 1150</td>
</tr>
<tr>
<td>External effects 391</td>
<td>Event display 767</td>
</tr>
<tr>
<td>Extracting insert effect settings from track presets 398</td>
<td>About 57</td>
</tr>
<tr>
<td>Insert effects 372, 374</td>
<td>Editing events 770</td>
</tr>
<tr>
<td>Managing plug-ins 399</td>
<td>Folder tracks 144</td>
</tr>
<tr>
<td>Multi-channel configuration 377</td>
<td>Modifying on folder tracks 145</td>
</tr>
<tr>
<td>Offline 372</td>
<td>Value display 768</td>
</tr>
<tr>
<td>Pasting presets 396</td>
<td>Event Handling Opacity 1063</td>
</tr>
<tr>
<td>Plug-in delay compensation 374</td>
<td>Event lengths 792</td>
</tr>
<tr>
<td>Plug-in information window 398</td>
<td>Changing with Trim tool 709</td>
</tr>
<tr>
<td>Pre/Post fader sends 386</td>
<td>Event list 766</td>
</tr>
<tr>
<td>Presets 392</td>
<td>Editing events 769</td>
</tr>
<tr>
<td>Presets browser 393</td>
<td>Filtering events 769</td>
</tr>
<tr>
<td>Routing 377, 385</td>
<td>Event types 769</td>
</tr>
<tr>
<td>Saving insert presets 397</td>
<td>Selecting in controller lane 716</td>
</tr>
<tr>
<td>Saving presets 395</td>
<td>Envelope 257</td>
</tr>
<tr>
<td>Selecting Presets 393</td>
<td>Gluing 184</td>
</tr>
<tr>
<td>Send effects 372, 382</td>
<td>Group editing 187</td>
</tr>
<tr>
<td>Setting up 384</td>
<td>Grouping 186</td>
</tr>
<tr>
<td>Side-chain input 388</td>
<td>Hiding in List Editor 765</td>
</tr>
<tr>
<td>Side-chain inputs 373</td>
<td>Locking 188</td>
</tr>
<tr>
<td>Tempo sync 374</td>
<td>Moving 179</td>
</tr>
<tr>
<td>VST 3 373</td>
<td>Moving in controller display 726</td>
</tr>
<tr>
<td>élastique algorithm</td>
<td>Muting 189</td>
</tr>
<tr>
<td>About 428</td>
<td>Poly Pressure 724</td>
</tr>
<tr>
<td>Enable Automatic Hitpoint Detection 1056</td>
<td>Renaming 181</td>
</tr>
<tr>
<td>Enable Record on Selected Audio Track 1061</td>
<td>Render in Place 172</td>
</tr>
<tr>
<td>Enable Record on Selected MIDI Track 1061</td>
<td>Render setup 175</td>
</tr>
<tr>
<td>Enable Solo on Selected Track 1061</td>
<td>Repeating 185</td>
</tr>
<tr>
<td>Enable Track 141</td>
<td>Resizing 182</td>
</tr>
<tr>
<td>Enharmonic Shift Manual 1182</td>
<td>Selecting 177</td>
</tr>
<tr>
<td>Enharmonic shift 740</td>
<td>Showing in List Editor 765</td>
</tr>
<tr>
<td>Enlarge Selected Track 139, 1061</td>
<td>Sliding the contents 186</td>
</tr>
<tr>
<td>Envelope Process 403</td>
<td>Splitting 184</td>
</tr>
<tr>
<td>Realtime 257</td>
<td>Exclusive Device Ports for Monitor Channels 1085</td>
</tr>
<tr>
<td>EQ Channel racks 330</td>
<td>Explode 1124</td>
</tr>
<tr>
<td>Presets 332</td>
<td>Export audio mixdown 938</td>
</tr>
<tr>
<td>EQ position</td>
<td>Audio engine settings 944</td>
</tr>
<tr>
<td>Strip module 333</td>
<td>Channel selection 941</td>
</tr>
<tr>
<td></td>
<td>File naming 941</td>
</tr>
<tr>
<td></td>
<td>In realtime 944</td>
</tr>
<tr>
<td>Events</td>
<td>Exporting</td>
</tr>
<tr>
<td>About 166</td>
<td>MIDI files 1021</td>
</tr>
<tr>
<td>Adding in controller display 718</td>
<td>OMF 1018</td>
</tr>
<tr>
<td>Coloring 690</td>
<td>Score as image files 1116</td>
</tr>
<tr>
<td>Copying and Pasting 185</td>
<td>Selected tracks 1026</td>
</tr>
<tr>
<td>Creating from hitpoints 467</td>
<td>Tempo track 908</td>
</tr>
<tr>
<td>Creating new files from events 189</td>
<td>Exporting markers 289</td>
</tr>
</tbody>
</table>
## Index

<table>
<thead>
<tr>
<th>Expression maps</th>
<th>Creating 785</th>
<th>Drum Editor 782</th>
<th>In-Place Editor 782</th>
<th>Inspector 781</th>
<th>Key Editor 782</th>
<th>List Editor 784</th>
<th>Loading 780</th>
<th>Score Editor 782</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>External effects</th>
<th>About 33, 391</th>
<th>Favorites 39</th>
<th>Freezing 39</th>
<th>Missing plug-ins 40</th>
<th>Setting up 34</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>External instruments</th>
<th>About 33</th>
<th>Favorites 39</th>
<th>Freezing 39</th>
<th>Missing plug-ins 40</th>
<th>Setting up 37</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>External monitoring</th>
<th>217</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Extract Audio on Import Video</th>
<th>File 1087</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Extracting</th>
<th>Audio from video 990, 1016</th>
<th>Audio to MIDI (VariAudio) 486</th>
<th>MIDI Automation 684</th>
<th>Voices 1176</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Extracting chord events from MIDI</th>
<th>833</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>F</th>
<th>Fade Handle Brightness 1064</th>
<th>Fade handles 247</th>
<th>Fade In/Out functions 249</th>
<th>Fader section (MixConsole) 320</th>
<th>Fades</th>
<th>Auto fades 255</th>
<th>Creating 247</th>
<th>Editing in dialog 250</th>
<th>Presets 250</th>
<th>Processing 249</th>
<th>Removing 249</th>
<th>With Range Selection tool 248</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>G</th>
<th>Gain 404</th>
<th>Gap mode</th>
<th>Chord Assistant 819</th>
<th>Gate</th>
<th>Strip module 333</th>
<th>Generic remote device 630</th>
<th>Global track controls 52</th>
<th>Global workspaces 1028</th>
<th>Gluing</th>
<th>Notes 740</th>
<th>Gluing events 184</th>
<th>Gluing staves 1290</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Grace notes</th>
<th>Converting to normal 1202</th>
<th>Creating manually 1201</th>
<th>Order of 1322</th>
<th>Settings 1202</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Grid Overlay Intensity 1063</th>
<th>Groove quantizing 246</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Group Channel tracks 115</th>
<th>Group channels</th>
<th>Adding insert effects 381</th>
<th>Routing 326</th>
<th>Setting up 33</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Group Channels - Mute Sources as well 1082</th>
<th>Group editing 187</th>
<th>Grouping</th>
<th>Removing in score 1192</th>
<th>Repeats 1190</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Grouping events 186</th>
<th>Grouping notes</th>
<th>Accelerando 1191</th>
<th>Beam 1189</th>
<th>Brillenbass 1190</th>
<th>Ritardando 1191</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Guitar chord symbols 1219</th>
<th>Guitar library 1221</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>H</th>
<th>Hardware controls</th>
<th>Activating pick-up mode 606, 624</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Hardware setup</th>
<th>Control panel 14</th>
<th>Hermode tuning 646</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Hide muted Notes in Editors 1062</th>
<th>Hide Notes beyond limits 1077</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Hide Truncated Event Names 1063</th>
<th>Hiding</th>
<th>Empty staves 1298</th>
<th>Objects 1283</th>
<th>Pedal markers 1238</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Hitpoints</th>
<th>About 459</th>
<th>Beats pop-up menu 461</th>
<th>Creating events 467</th>
<th>Creating markers 467</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Creating regions 449, 467</th>
<th>Slicing audio 465</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>HMT</th>
<th>Follow 646</th>
<th>Use for Analysis 466</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>I</th>
<th>Image files</th>
<th>Inserting in Score Editor 1222</th>
</tr>
</thead>
</table>

---

1334
Index

Importing
  Audio from video files 1016
  MIDI files 1021
  MPEG files 1017, 1018
  Ogg Vorbis files 1018
  OMF files 1018
  REX files 1016
  Tempo track 908
  Track archives 1026
  Video files 983
  WMA files 1018
Importing markers 289
Independent track loop
  Audio Part Editor 496
Indicate Transpositions 277
Info line
  Changing note lengths 1144
  Drum Editor 703, 749
  Editing articulations 784
  Editing note pitches 1142
  Key Editor 703, 749
  Project window 47
  Sample Editor 435
  Score Editor 732, 1102
Inhibit warning when applying
  Offline Processes 1086
Inhibit warning when changing the
  Sample Data 1086
Initial value
  Automation 584
I-notes (Input notes) 759
In-Place Editor
  Editing controllers 771
  Editing MIDI notes 771
  Toolbar 771
Input busses
  Adding 30
  Renaming 29
  Routing 326
Input gain
  MixConsole 328
Input levels 14
Input ports 18
Input Transformer 878
Inputs
  Meter position options 324
Insert Effects
  Adding to busses 379
  Adding to Group channels 381
Insert effects 372
  About 374
  Bypass 376
  Deactivate 376
  Freezing 381
  Routing 375
Insert Reset Events after
  Record 1068
Insert Silence
  Sample Editor 446
Inserting and finding media
  Pool 510
Inserts
  FX chain presets 330
  MIDI 653
  MixConsole 328
  Monitor channels 362
  Talkback channel 362
Inspector
  About 50
  Assigning Quick Controls 621
  Expression maps 781
  Key Editor 703
  MIDI tracks 643
  Subpanels 652
  Synchronizing track and channel visibility 55
  Visibility 54
  Instrument Freeze 608
  Instrument tracks 89
  Render in Place 172
  Instruments
    Display Transpose 1114
    Instruments use Automation Read All and Write All 1082
    Interpolate Audio Waveforms 1064
    Interpretation Options 1157
J
  Jog wheel 199
K
  Keep Crescendo Symbols "Horizontal" 1077
  Keep moved Notes within Key 1077
  Key (Score Editor)
    Editing 1149
    Inserting changes 1148
    Setting initial 1106
    Setting local keys 1114
  Key commands
    About 997
    Default 1003
    Importing 1002
    Loading 1001
    Modifying 998
    Removing 1000
    Resetting 1002
    Saving 1001
    Searching for 999
  Key Editor 696
    Controller display 705
    Cut and paste 688
    Info line 703, 749
    Inspector 703
    Note display 705
    Note expression data 714
    Status line 702
    Toolbar 698
Keyboard navigation
  MixConsole 350
Keyboard symbols
  Adding 1218
Knob Mode 1058
L
  Lanes 145
    Assembling a perfect take 146
    Assembling operations 147
    Audio Part Editor 494
  Language (Preferences) 1067
  Latency
    Optimizing 1045
    VST System Link 969
  Lay text 1261
  Layout settings
    About 1279
    Equal spacing 1281
    Modern time signature 1281
    Multi-Rests 1281
    Real Book 1281
    Size 1281
    Staff separators 1281
  Layout tool
    Moving clefs 1150
  Layout Tool Compatibility Mode 1077
  Layouts
    About 1269
    Creating 1270
    Exporting 1272
    Importing 1272
    Opening 1270
    Using 1271
  Learn mode
    Quick Controls 619
  Ledger lines 1183
  Legato 680
  Legato Mode - Between Selected Notes Only 1060
  Legato Overlap 1060
  Length
    Compression 646
    Length Adjustment 1068
    Level meters (MixConsole) 324
    Level scale
      Half-level axis 439
      Sample Editor 439
LFE
SurroundPanner V5 571

Limiter
Strip module 333

Line tool 707
Drawing note events 707
Editing controller display events 720
Editing events 720

Link Editors 1054
Link groups 305
Adding channels 307
Assigning VCA faders 311
Changing settings 307
Creating 306
Q-Link 308
Removing channels 308
Removing VCA faders 311
Unlink 307

List Editor 761
Editing events 769, 770
Editing operations 768
Hiding events 765
Inserting events 768
Showing events 765
Status line 765
Toolbar 761

Listen
MixConsole 323

Live transform
Chord track 829
Loading Multi-Track Presets 163
Loading Track Presets 163
Locate When Clicked in Empty Space 1080

Locators
Setting 203
Lock Event Attributes 188, 1054
Lock layers 1225
Lock Record 233
Logical Editor
About 859
Actions 873
Filter conditions 861
Functions 872
Opening 860
Presets 877

Loop
Audio Part Editor 496
Fill options 592
Looping
MIDI parts 696

Loudness
About 367
LU 316
LUF 316
Meter 316, 368
Settings 370
Units 367

Lyrics
About 1257
In voices 1258
Inserting manually 1257
Verse 1258

M
Mac OS X
Port activation 30
Port selection 30
Machine control
About 954
Input source 962
Output destinations 961

Macros 1000
Main Dim Volume 1085
Main mix
Output 353
Setting up 31
Make Chords 833
Managing media files
Pool window 500
Map Input Bus Metering to Audio Track 1074
Map pop-up menu 757
Mapping offset 825
Marker attributes 285
Marker IDs 287
Marker preferences 285
Marker track 121, 287
Marker window
About 283
Functions 284
Marker list 284

Markers
About 281
Converting to score layout 1273
Creating from hitpoints 467
Cycle markers 281
Editing in Project Browser 935
Exporting 289
Exporting markers as track archive 290
Exporting via MIDI 290
Importing 289
Importing markers as track archive 290
Importing via MIDI 289
Position markers 281

Maximum Backup Files 1067

Maximum Items in Results
List 1073
Maximum Undo Steps 1067

MediaBay
About 522
Attribute filtering 542
Attribute Inspector 544
Defining locations 524, 527
Defining user attributes 549
Editing attributes 546
Filtering 539
Hiding sections 523
Key commands 552
Preferences 550
Previewing 533
Scanning operations 524
Selecting locations 527
Showing sections 523
Viewing results 528
Volume databases 555
VST Sound node 525

Melisma lines 1252
Merge Clipboard (function) 405
Merge MIDI in Loop 675
Merge Tempo from Tapping 912

Meter peak options 324
Hold forever 324
Hold peaks 324

Meter position options 324
Input 324
Post-Fader 324
Post-Panner 324

Meters
AES/17 315
Alignment level 315
Peak meter display 315
RMS display 315
Scale standards 315
Settings 324

Meters' Fallback 1074
Meters' Peak Hold Time 1074

MIDI
Disolve parts 677
Extracting from audio 486

MIDI channel
Send effects 654

MIDI channels
Separating for drum map sounds 758
MIDI clock
Destinations 963
Synchronization 957
MIDI Controller Automation 595

Setting up 597
MIDI devices
- Defining new for patch selection 661, 662
- Device Manager 659
- Editing patches 665
- Installing 662
- Selecting patches 664

MIDI Display Resolution 1068

MIDI Editor
- Defining new for patch selection 661, 662
- Editing patches 665
- Installing 662
- Selecting patches 664

MIDI effects
- About 652
- Inserts 653
- Presets 655
- Sends 654

MIDI Export Options 1070

MIDI files 1021

MIDI Filter 1073

MIDI Import Options 1070

MIDI Input
- Chord editor 818
- Input function
  - Sample Editor 481
  - Score Editor 1142
- Input Transformer 878

MIDI Inputs
- Setting up 226
- Insert effects
- Recording 657

MIDI interface
- Connecting 19
- Max. Feedback in ms 1068
- Modifiers 646
- Note numbers 755, 757

MIDI notes
- Assigning colors 1186
- Display length 1144
- Duplicating 1140
- Grouping automatically 1192
- Grouping in score 1188
- Head shape 1183
- Ledger lines 1183
- Moving 1137
- Moving graphically 1198
- Selecting in score 1135
- Splitting 1145
- Transpose (function) 673

MIDI outputs
- Send effects 654
- Parts
  - Editing in Project Browser 930

MIDI parts
- Adding events 168
- Creating 168
- Handling several 695
- Looping 696
- Processing 688
- Render in Place 172
- Render setup 175

MIDI Port Setup 225

MIDI ports
- Setting up 19
- Record Range in ms 1076

MIDI Record Mode 229

MIDI Recording
- Channel and Output 226
- Instruments and channels 225
- Input setting 226
- Naming MIDI ports 225
- Preparations 225
- Record mode 229
- Recording continuous messages 228
- Recording different types of messages 228
- Recording notes 228
- Recording Program Change Messages 228
- Recording System Exclusive Messages 229
- Recovering recordings 231
- Reset 229
- Retrospective Record 232
- Sound selection 227

MIDI recordings
- Exporting to MIDI file 760
- SysEx Editor
- Dump request messages 774
- Thru Active 1068
- Monitoring 218
- Timecode
- Destinations 963
- Tracks 96
- Expression Maps 713
- Modifiers 646
- Routing to device 774
- Settings 644

MixConsole 291
- Assigning Quick Control parameters 347, 620
- Channel linking 305
- Channel overview 291
- Channel racks 300
- Channel selector 297
- Channel types 299
- Configuring 293
- Creating VCA faders 310
- Display line 305
- EQ presets 332
- Equalizer curve 291
- Fader section 320
- FX chain 330
- Hiding channels 293
- Level meters 324
- Listen 323
- Meter section 314
- Mute 322
- Notepad 350
- Opening 291
- Panning 321
- Pre rack 327
- Racks 325
- Sections 291
- Set up window layout 293
- Setting volume 323
- Solo 322
- Solo Defeat 322
- Strip presets 342
- Visibility agents 303
- Visibility tab 297
- Zones tab 297
- Zoom tools 293

MixConvert
- In surround setups 574
- Modifier keys 1003
- Monitoring 216
- About 18
- ASIO Direct Monitoring 217
- External 217
- MIDI 218
- Via Cubase 216
- Mouse information 748
- Mouse Note Position display 1131
- Mouse Time Position display 1131

Moving
- MIDI notes in score 1137
- Objects graphically 1199
- Staves 1293
- Using key commands 1137
- Moving tracks 135

MP3 files
- Exporting 950
- Importing 1017, 1018

MPEG files 1017, 1018
<table>
<thead>
<tr>
<th>Index</th>
</tr>
</thead>
<tbody>
<tr>
<td>MPEX algorithm</td>
</tr>
<tr>
<td>About 428</td>
</tr>
<tr>
<td>Pitch Shift 408</td>
</tr>
<tr>
<td>Multi processing 1047</td>
</tr>
<tr>
<td>Multi-channel tracks</td>
</tr>
<tr>
<td>Export 938</td>
</tr>
<tr>
<td>Multi-Rests</td>
</tr>
<tr>
<td>Creating 1285</td>
</tr>
<tr>
<td>Option 1281</td>
</tr>
<tr>
<td>Settings 1286</td>
</tr>
<tr>
<td>Splitting 1286</td>
</tr>
<tr>
<td>Musical expressions</td>
</tr>
<tr>
<td>Editing 722</td>
</tr>
<tr>
<td>Musical Mode</td>
</tr>
<tr>
<td>About 451</td>
</tr>
<tr>
<td>Adjusting audio loops 452</td>
</tr>
<tr>
<td>Pool 451</td>
</tr>
<tr>
<td>Musical track time base 149</td>
</tr>
<tr>
<td>MusicXML</td>
</tr>
<tr>
<td>About 1274</td>
</tr>
<tr>
<td>Exporting 1278</td>
</tr>
<tr>
<td>Importing 1278</td>
</tr>
<tr>
<td>Mute</td>
</tr>
<tr>
<td>MixConsole 322</td>
</tr>
<tr>
<td>Surround channels 566</td>
</tr>
<tr>
<td>Mute Pre-Send when Mute 1082</td>
</tr>
<tr>
<td>Muting events 189</td>
</tr>
<tr>
<td>N</td>
</tr>
<tr>
<td>Navigating</td>
</tr>
<tr>
<td>MixConsole 350</td>
</tr>
<tr>
<td>Never Reset Chased Controllers 1068</td>
</tr>
<tr>
<td>Noise Gate 406</td>
</tr>
<tr>
<td>Normalize</td>
</tr>
<tr>
<td>Audio effect 407</td>
</tr>
<tr>
<td>Note Brightness 1065</td>
</tr>
<tr>
<td>Note display</td>
</tr>
<tr>
<td>Drum Editor 750</td>
</tr>
<tr>
<td>Key Editor 705</td>
</tr>
<tr>
<td>Shifting 740</td>
</tr>
<tr>
<td>Note events</td>
</tr>
<tr>
<td>Adding in controller display 718</td>
</tr>
<tr>
<td>Changing the velocity 721</td>
</tr>
<tr>
<td>Coloring 690</td>
</tr>
<tr>
<td>Creating 753</td>
</tr>
<tr>
<td>Creating in Score Editor 738</td>
</tr>
<tr>
<td>Cutting 693</td>
</tr>
<tr>
<td>Deleting in controller display 727</td>
</tr>
<tr>
<td>Drawing with Draw tool 706</td>
</tr>
<tr>
<td>Drawing with Line tool 707</td>
</tr>
<tr>
<td>Duplicating 694, 739</td>
</tr>
<tr>
<td>Editing 693</td>
</tr>
<tr>
<td>Editing via MIDI 714</td>
</tr>
<tr>
<td>Editing with Draw tool 720</td>
</tr>
<tr>
<td>Excluding from playback 692</td>
</tr>
<tr>
<td>Gluing 710, 740</td>
</tr>
<tr>
<td>Moving 708, 754</td>
</tr>
<tr>
<td>Moving in controller display 726</td>
</tr>
<tr>
<td>Muting 692</td>
</tr>
<tr>
<td>Repeating 694</td>
</tr>
<tr>
<td>Resizing 708</td>
</tr>
<tr>
<td>Selecting 691</td>
</tr>
<tr>
<td>Setting values 738</td>
</tr>
<tr>
<td>Setting with Snap 694</td>
</tr>
<tr>
<td>Splitting 710, 740</td>
</tr>
<tr>
<td>Transposing 708, 754</td>
</tr>
<tr>
<td>Note Expression</td>
</tr>
<tr>
<td>About 792</td>
</tr>
<tr>
<td>Channel Rotation 800</td>
</tr>
<tr>
<td>Editing data 802</td>
</tr>
<tr>
<td>MIDI controllers 793, 794</td>
</tr>
<tr>
<td>Overdubbing 800</td>
</tr>
<tr>
<td>Recording 799</td>
</tr>
<tr>
<td>Recording via MIDI 801</td>
</tr>
<tr>
<td>VST 3 controllers 793</td>
</tr>
<tr>
<td>Note expression data</td>
</tr>
<tr>
<td>Key Editor 714</td>
</tr>
<tr>
<td>Note Layer</td>
</tr>
<tr>
<td>Scores 1080</td>
</tr>
<tr>
<td>Note layer symbols 1206</td>
</tr>
<tr>
<td>About 1206</td>
</tr>
<tr>
<td>Adding 1213</td>
</tr>
<tr>
<td>Note length</td>
</tr>
<tr>
<td>Changing in Score Editor 1143</td>
</tr>
<tr>
<td>Note lengths</td>
</tr>
<tr>
<td>Changing 739</td>
</tr>
<tr>
<td>Note stems</td>
</tr>
<tr>
<td>Flipping the direction 740</td>
</tr>
<tr>
<td>Note symbols</td>
</tr>
<tr>
<td>Adding 1213</td>
</tr>
<tr>
<td>Resizing 1231</td>
</tr>
<tr>
<td>Note values</td>
</tr>
<tr>
<td>Setting 738</td>
</tr>
<tr>
<td>Notepad</td>
</tr>
<tr>
<td>MixConsole 350</td>
</tr>
<tr>
<td>Notes</td>
</tr>
<tr>
<td>Editing via MIDI 1142</td>
</tr>
<tr>
<td>Nudge key commands 1129</td>
</tr>
<tr>
<td>Nudging notes 1137</td>
</tr>
<tr>
<td>O</td>
</tr>
<tr>
<td>Octave symbols 1237</td>
</tr>
<tr>
<td>Offline Process History 418</td>
</tr>
<tr>
<td>Offline processing</td>
</tr>
<tr>
<td>VariAudio 471</td>
</tr>
<tr>
<td>Ogg Vorbis files</td>
</tr>
<tr>
<td>Exporting 950</td>
</tr>
<tr>
<td>Importing 1018</td>
</tr>
<tr>
<td>OMF files 1018</td>
</tr>
<tr>
<td>On Import Audio Files 1056</td>
</tr>
<tr>
<td>On Processing Shared Clips 1056</td>
</tr>
<tr>
<td>One Shot</td>
</tr>
<tr>
<td>Fill options 592</td>
</tr>
<tr>
<td>O-notes (Output notes) 759</td>
</tr>
<tr>
<td>Open Effect Editor after Loading it 1084</td>
</tr>
<tr>
<td>Open External Projects in Last Used View 1067</td>
</tr>
<tr>
<td>Organizing files in subfolders</td>
</tr>
<tr>
<td>Pool 517</td>
</tr>
<tr>
<td>Output busses</td>
</tr>
<tr>
<td>Adding 30</td>
</tr>
<tr>
<td>Default 31</td>
</tr>
<tr>
<td>Mixing down to file 938</td>
</tr>
<tr>
<td>Renaming 29</td>
</tr>
<tr>
<td>Routing 326</td>
</tr>
<tr>
<td>Surround 560</td>
</tr>
<tr>
<td>Output ports 18</td>
</tr>
<tr>
<td>Overlapping Audio 143</td>
</tr>
<tr>
<td>Overview line Project window 48</td>
</tr>
<tr>
<td>P</td>
</tr>
<tr>
<td>Page text 1261</td>
</tr>
<tr>
<td>Panning</td>
</tr>
<tr>
<td>Bypass 322</td>
</tr>
<tr>
<td>MixConsole 321</td>
</tr>
<tr>
<td>Part Data Mode 1065</td>
</tr>
<tr>
<td>Parts</td>
</tr>
<tr>
<td>About 166, 168</td>
</tr>
<tr>
<td>Displaying in score 733</td>
</tr>
<tr>
<td>Dissolving (MIDI) 677</td>
</tr>
<tr>
<td>Editing 177</td>
</tr>
<tr>
<td>Folder 171</td>
</tr>
<tr>
<td>Sliding the contents 186</td>
</tr>
<tr>
<td>Parts Get Track Names 1054</td>
</tr>
<tr>
<td>Paste at Origin 185</td>
</tr>
<tr>
<td>Paste Relative to Cursor 185</td>
</tr>
<tr>
<td>Pasting</td>
</tr>
<tr>
<td>Note attributes 1188</td>
</tr>
<tr>
<td>Notes in score 1140</td>
</tr>
<tr>
<td>Symbols in score 1233</td>
</tr>
<tr>
<td>Patch Banks 663</td>
</tr>
<tr>
<td>Pattern banks</td>
</tr>
<tr>
<td>---------------</td>
</tr>
<tr>
<td>Peak meter display</td>
</tr>
<tr>
<td>Pedal symbols</td>
</tr>
<tr>
<td>Pedals</td>
</tr>
<tr>
<td>Performance</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td>Phase</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td>Piano staves</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td>Piano voicings</td>
</tr>
<tr>
<td>Pitch</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td>Pitch Notation</td>
</tr>
<tr>
<td>Pitch Shift</td>
</tr>
<tr>
<td>Limitations</td>
</tr>
<tr>
<td>Pitch shifting</td>
</tr>
<tr>
<td>Pitch&amp;Warp tool</td>
</tr>
<tr>
<td>Pool</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td>Clip editing</td>
</tr>
<tr>
<td>Designating a new pool record folder</td>
</tr>
<tr>
<td>Polyphonic voicing</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td>Reference file</td>
</tr>
<tr>
<td>Resolve missing files dialog</td>
</tr>
<tr>
<td>Show/hide columns</td>
</tr>
<tr>
<td>Transferring media from a library to a project</td>
</tr>
<tr>
<td>Pool Window</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td>Preferences</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td>Pre-Record time</td>
</tr>
<tr>
<td>Pre-roll</td>
</tr>
<tr>
<td>Presets</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td>Presets browser Effects</td>
</tr>
<tr>
<td>Printing</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td>Processing</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td>Project Assistant</td>
</tr>
<tr>
<td>Project Browser</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td>Project Logical Editor</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td>Project scrubbing</td>
</tr>
<tr>
<td>Project Setup Dialog</td>
</tr>
<tr>
<td>Project window</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td>Project workspaces</td>
</tr>
</tbody>
</table>
Quick Controls
Assigning effect parameters 619
Assigning from channel settings 347, 620
Assigning from Inspector 621
Assigning from MixConsole 347, 620
Assigning from Plug-ins 619
Assigning from racks 347, 620
Assigning parameters 619
Automatable Parameters 625
Automatic assignment 621
Connecting with Remote Controllers 605, 623
Learn mode 619
Removing assignments 622
Showing automated assignments 622
Quick Zoom 1054

Rack settings 301
Copying 319
Racks
Assigning Quick Control parameters 347, 620
MixConsole 325
RAM
Recording 220
Range Editing 191
Range Selection tool 191
Creating fades 248
Range selections
Render in Place 172
Read automation 577
Realtime algorithm
About 429
Realtime export 939
Recent projects 76
Record File Format Audio 219
Record Folder Audio 219
Record Time Max 232
Record-Enable allows MIDI Thru 1076
Recording
About 212
Activating 213
Common Record Modes 215
Cycle 214
Levels 14
Lock Record 233
Pre-roll and post-roll 215
Remaining Record Time 232
Stopping 214
Tempo changes 907

Recording with Effects 222
Recovering audio recordings 223
Recovering MIDI recordings 231
ReCycle files 1016
Reducing the project size Pool 518
Reference file Pool 499
Reference Level 1085
Regions
About 190, 448
Auditioning 450
Creating 449
Creating from hitpoints 449, 467
Creating with Detect Silence 423
Editing 449
Event or Range as Region 190
Events from Regions 190
Exporting as audio files 451
Removing 449
Rehearsal Marks 1240
Remote control
Key commands 629
Setting up 626
Writing automation 629
Remote Controllers
Connecting with Quick Controls 605, 623
Remove Empty Tracks 135
Remove Regions/Hitpoints on all Offline Processes 1056
Remove Selected Tracks 135
Rename object 181
Renaming events 181
Renaming tracks 136
Render setup
Events 175
MIDI parts 175
Tracks 173
Repeat
Loop 679
Repeat events 185
Replace Recording in Editors 1076
Re-Record
Activating 216
Common Record Modes 215, 216
Reset
Layout 1300
Quantize 238, 245
VariAudio 485
Reset on Stop 1068
Resizing events 182
Index

Rests
- Consolidating 1158
- Creating multi-rests 1285
- Display Quantize 1092
- In polyphonic voices 1165, 1172

Retrospective Record 1076

MIDI 232

Return to Start Position on Stop 1080

Reverse (audio processing) 413

Reverse (MIDI function) 685

ReWire
- About 992
- Activating 994
- Channels 995
- Routing MIDI 996

REX files 1016

Ritardando 1016

RMS display
- Meters 315

Root key
- Setting for unassigned events 273

Routing
- For surround setup 561
- Group channels 326
- Input busses 326
- MixConsole 325
- Output busses 326

Routing Editor 377

Routing through insert effects 375

Ruler 1104, 1227
- Display format 48
- Sample Editor 439
- Timeline 688
- Ruler track 122

Run Setup on Create New Project 1067

S

Sample Editor
- Audio clip information 435
- Audition 441
- Auto Adjust 453
- Auto-Scroll 433
- Free Warp 457
- Info line 435
- Inspector 436
- Manual Adjust 454
- MIDI Input function 481
- Musical Mode 451
- Opening 433
- Overview line 438
- Regions 448
- Ruler 439
- Show Audio Event 433
- Snap function 433
- Tempo matching audio 452
- Toolbar 433
- Zooming 440

Samplerate
- Externally clocked 16

Saturation
- Strip module 333

Save As Template 71

Save partial preferences settings 1053

Save Track Preset 164

Scale events
- About 824
- Adding 824
- Auditioning 824
- Automatic scales 824
- Changing 824
- Follow Chord Track 831
- Showing 824

Scale standards
- Meters 315

Scan Folders only when MediaBay is open 1073

Scan unknown File Types 1073

Score 1159, 1290
- Adding notes 1132
- Bows 1183
- Composite signatures 1108
- Creating chord symbols 1248
- Deleting notes 1150
- Display markers 1273
- Displaying 733
- Ending symbols 1241
- Explode function 1124, 1170
- Extended toolbar 1102
- Force screen redraw 1118
- Gluing notes 1144
- Grouping signatures 1189
- Hiding stems 1183
- Lay text 1261
- Layers 1206
- Layout layer symbols 1207
- Lock (L) button 1138
- Locking layers 1225
- Merging staves 1175
- No Flag/Beam 1183
- No Overlap 1158
- Notes to MIDI 1125
- Offsetting bar numbers 1268
- Page number indicator 1098
- Page setup 1100
- Page text 1261
- Repeating note groups 1190
- Repeating symbols 1239
- Selecting note values 1129
- Set Note Info dialog 1179
- Setting the number of bars 1289
- Staff spacing 1319
- Stem length 1180
- Sys text 1261

Score display 734

Score Drum Map
- About 1303
- Initializing 1305
- Setting Up 1304

Score Editor 728
- Adding image files 1222
- Box symbol 1239
- Context menus 1105
- Edit mode 1097
- Filter bar 1103
- Find/Replace 1265
- Info line 732
- MIDI Input function 1142
- Mouse position 1131
- Page Mode 1097
- Staff settings 734
- Status line 731
- Toolbar 728

1341
Index

Score settings
- About 1127
- Switching staves 1128
- Values for note input 1128

Score symbols
- Adding 1214
- Adding to notes 1213
- Aligning 1233
- Creating 1242
- Deleting 1233
- Duplicating 1226
- Guitar chords 1219
- In palettes 1210
- Length 1231
- Moving 1226
- Moving with keyboard 1229
- Note layer symbols 1206
- Note-dependent 1206
- Relation to staves/voices 1212
- Resizing 1231
- Selecting 1224

Score texts
- Adding 741
- Changing fonts 741, 742
- Changing sizes 741, 742
- Changing styles 742
- Editing 741

Scores
- Printing 742
- Scroll to selected Track 1061
- Scrolling during playback 689
- Scrub Volume 1082
- Scrubbing 170
- Events in Sample Editor 442
- Project 199
- Scrub tool 170

Segments
- Changing note start/end point 473
- Cutting segments 473
- Deleting 475
- Gluing 474
- Moving horizontally 475
- Saving the segmentation 475
- VariAudio 472

Select Channel/Track on Edit Settings 1061

Select Channel/Track on Solo 1061

Select Controllers in Note Range - Use Extended Note Context 1060

Select Tool - Show Extra Info 1063

Select Track for Auditioning 823

Select Track on Background Click 1054

Selecting
- MIDI notes in score 1135
- Selecting tracks 140
- Selection Ranges
  - Creating 191
  - Editing 193
- Selection ranges
  - Editing in controller lane editor 725
- Send effects 372
  - About 382
  - Adding FX channel tracks 383
  - Setting pan 387
- Sends
  - MixConsole 342
- Set Note Info dialog 1183
- Setup
  - Selection rendering 175
  - Track rendering 173
- Shared Copies
  - Convert to Real Copy 186
  - Creating 186
- Shifting
  - Note display 740
  - Show Braces in Edit Mode 1077
  - Show Control Room Volume in Transport Panel 1085
  - Show Controllers 1065
  - Show Data in Results List 1073
  - Show Hitpoints on Selected Events 1064
  - Show Note Info by the Mouse 1077
  - Show Overlaps 1063
  - Show pitch when inserting notes 1077
  - Show Position Cursor 1077
  - Show Scales 824
  - Show TIMECODE Subframes 1080
  - Show Tips 1067
  - Show Track Pictures 137
  - Show Waveforms 1064
  - Show/hide columns
    - Pool 504
    - Shuffle 1159
- Side-Chain
  - Inserts rack 329
- Side-chain
  - Ducking delay 389
  - Trigger signals 390

Side-chain inputs 373

Signature track 123

Silence 413

Inserting 195

Simple Crossfade Editor 254

Single Voice
  - Follow Chord Track 830

Slices
- About 459
  - Creating 465
- Slider Mode 1058
- Slurs
  - Adding 1215
  - Bezier slurs 1217
  - Direction 1232
  - Inserting 1216
  - Sha pe 1232

Smallest Track Height To Show Data 1063

Smallest Track Height To Show Name 1063

Snap 694
  - About 62
  - Sample Editor 433
  - Zero crossings (Sample Editor) 433

Snap MIDI Parts to Bars 1076

Snap modes 1138

Snap point
  - Setting 62
  - Setting in Sample Editor 443

Snap Point To Cursor 62

Snap Slurs when dragging 1077

Snap to Zero Crossing
  - Audio Part Editor 498

Snap to zero crossings
  - About 62

Snap type
  - Selecting 63

Solo
  - Audio Part Editor 495
  - MixConsole 322
  - Surround channels 566

Solo Defeat
  - MixConsole 322

Solo Record in MIDI Editors 1076

Soloing
  - MIDI editors 689

Sound sources
  - Position in surround field 565
  - Speaker icon
    - Score Editor 1138
## Index

<table>
<thead>
<tr>
<th>Thumbnails</th>
</tr>
</thead>
<tbody>
<tr>
<td>About 985</td>
</tr>
<tr>
<td>Thumbnail cache files 985</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Tied Notes selected as Single Units</th>
</tr>
</thead>
<tbody>
<tr>
<td>1077</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Ties</th>
</tr>
</thead>
<tbody>
<tr>
<td>About 1134, 1196</td>
</tr>
<tr>
<td>Adding as symbols 1215</td>
</tr>
<tr>
<td>Cut Notes tool 1197</td>
</tr>
<tr>
<td>Direction 1183, 1232</td>
</tr>
<tr>
<td>Dynamics 1231</td>
</tr>
<tr>
<td>Flat 1198</td>
</tr>
<tr>
<td>Shape 1232</td>
</tr>
<tr>
<td>Splitting 1145</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Time Base</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default track time base 150 Tracks 149 Time display 204 Time linear track time base 149 Time signatures</td>
</tr>
<tr>
<td>Composite 1108 Editing 907, 1149 For grouping 1108 Inserting 1148 Modern 1281 Setting initial 1106 Signature track/Tempo Track Editor 1109 Time stretch 414 Algorithms 428 Limitations 430 Time Stretch Tool Algorithm 1056 Time Warp tool 913 Timecode</td>
</tr>
<tr>
<td>Standards 956 Synchronization 955 Timeline</td>
</tr>
<tr>
<td>Ruler 688 To End</td>
</tr>
<tr>
<td>Fill options 591 To Punch</td>
</tr>
<tr>
<td>Fill options 591 To Start</td>
</tr>
<tr>
<td>Fill options 591 Tool modifier keys 1003 Tool Modifiers 1062 Toolbar</td>
</tr>
<tr>
<td>Audio Part Editor 493 Drum Editor 744 In-Place Editor 771 Key Editor 698 List Editor 761 Project window 44 Sample Editor 433 Score Editor 728 Toolbox</td>
</tr>
<tr>
<td>Project window 46 Track archives</td>
</tr>
<tr>
<td>Importing 1026 Track Controls Settings 131 Track Folding 143 Track Height 139 Track list</td>
</tr>
<tr>
<td>About 56 Dividing 56 Track Pictures 137 Track Pictures Browser 137 Track Presets</td>
</tr>
<tr>
<td>About 160 Applying 162 Audio 160 Creating 164 Extracting Sounds 164 Instrument 160 Loading 163 Loading Inserts and EQ 164 MIDI 161 Multi-Track 161 Pattern Banks 162 Saving Track Quick Control Assignment Presets 165 Track Quick Controls 165 VST Presets 162 Track Quick Control Presets 165 Track Quick Controls 634</td>
</tr>
<tr>
<td>About 618 Assigning parameters 621 Renaming 621 Replacing 621 Saving Assignments as Presets 165 Saving assignments as presets 623 Track Selection follows Event Selection 1054 Track Time Base 149 Track Zoom 139</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Tracks</th>
</tr>
</thead>
<tbody>
<tr>
<td>About 82 Adding 134 Arranger 103 Audio 82 Chord 105 Coloring 136 Customizing track controls 131 Disabling audio tracks 141 Duplicating 141 Folder 114 FX Channel 108 Group Channel 115 Importing/Exporting 1026 Instrument 89 Marker 121 MIDI 96 Moving 135 Removing 135 Renaming 136 Render setup 173 Ruler 122 Selecting 140 Signature 123 Tempo 124 Transpose 126 VCA fader 127 Video 130 TrackVersion IDs 153 TrackVersions</td>
</tr>
<tr>
<td>About 150 Activating 154 Copying and Pasting selected events 157 Copying and Pasting Selection Ranges 156 Creating 153 Creating from lanes 159 Creating lanes from TrackVersions 159 Deleting 156 Duplicating 155 Names 157 Renaming 158 Renaming on multiple tracks 158 Transcription 1119 Transformer</td>
</tr>
<tr>
<td>Strip module 333 Transformer (MIDI effect) 860 Transport menu</td>
</tr>
<tr>
<td>Functions 200 Playback options 200</td>
</tr>
<tr>
<td>Index</td>
</tr>
<tr>
<td>------------------------------</td>
</tr>
<tr>
<td>Transport panel</td>
</tr>
<tr>
<td>Display format</td>
</tr>
<tr>
<td>Hiding</td>
</tr>
<tr>
<td>Overview</td>
</tr>
<tr>
<td>Sections</td>
</tr>
<tr>
<td>Showing</td>
</tr>
<tr>
<td>Transpose</td>
</tr>
<tr>
<td>MIDI function</td>
</tr>
<tr>
<td>MIDI Modifier</td>
</tr>
<tr>
<td>Transpose track 126</td>
</tr>
<tr>
<td>About</td>
</tr>
<tr>
<td>Transposing</td>
</tr>
<tr>
<td>Instruments 1114</td>
</tr>
<tr>
<td>Transit notes 1114</td>
</tr>
<tr>
<td>Treat Muted Audio Events like Deleted 1056</td>
</tr>
<tr>
<td>Trills</td>
</tr>
<tr>
<td>Creating</td>
</tr>
<tr>
<td>Trim</td>
</tr>
<tr>
<td>Automation 588</td>
</tr>
<tr>
<td>Trim tool</td>
</tr>
<tr>
<td>Changing event lengths 709</td>
</tr>
<tr>
<td>Tuplets 1202</td>
</tr>
<tr>
<td>Display options 1204</td>
</tr>
<tr>
<td>Group symbols 1237</td>
</tr>
<tr>
<td>N-Tuplets 1204</td>
</tr>
<tr>
<td>Quantizing 240</td>
</tr>
<tr>
<td>U</td>
</tr>
<tr>
<td>Undo</td>
</tr>
<tr>
<td>Edit history 65</td>
</tr>
<tr>
<td>Maximum undo steps 66</td>
</tr>
<tr>
<td>Processing 418</td>
</tr>
<tr>
<td>Undoing Recording Audio 223</td>
</tr>
<tr>
<td>Unlock Layout when editing single parts 1077</td>
</tr>
<tr>
<td>Unstretching audio 491</td>
</tr>
<tr>
<td>Upbeats 1287</td>
</tr>
<tr>
<td>Use High Quality Scrub Mode 1082</td>
</tr>
<tr>
<td>Use Inserts While Scrubbing 1082</td>
</tr>
<tr>
<td>Use Mouse Wheel for Event</td>
</tr>
<tr>
<td>Volume and Fades 1056</td>
</tr>
<tr>
<td>Use Phones Channel as Preview Channel 1085</td>
</tr>
<tr>
<td>Use Steinberg Hub 1067</td>
</tr>
<tr>
<td>Use Up/Down Navigation</td>
</tr>
<tr>
<td>Commands for Selecting Tracks only 1054</td>
</tr>
<tr>
<td>User-definable Frame Rate 1080</td>
</tr>
<tr>
<td>V</td>
</tr>
<tr>
<td>Value Box/Time Control Mode 1058</td>
</tr>
<tr>
<td>Value display</td>
</tr>
<tr>
<td>Editing in List Editor 770</td>
</tr>
<tr>
<td>Hiding 768</td>
</tr>
<tr>
<td>Showing 768</td>
</tr>
<tr>
<td>VariAudio</td>
</tr>
<tr>
<td>About 468</td>
</tr>
<tr>
<td>Applying editing 471</td>
</tr>
<tr>
<td>Auditioning 485</td>
</tr>
<tr>
<td>Bypassing 485</td>
</tr>
<tr>
<td>Changing the pitch 476</td>
</tr>
<tr>
<td>Changing the timing 482</td>
</tr>
<tr>
<td>Editing segments 472</td>
</tr>
<tr>
<td>Extracting MIDI 486</td>
</tr>
<tr>
<td>Quantize Pitch 478</td>
</tr>
<tr>
<td>Reseting 485</td>
</tr>
<tr>
<td>Segments 469</td>
</tr>
<tr>
<td>Straighten pitch 480</td>
</tr>
<tr>
<td>Tilting micro-pitch curves 478</td>
</tr>
<tr>
<td>Waveform display 469</td>
</tr>
<tr>
<td>VCA faders 308</td>
</tr>
<tr>
<td>Assigning to link groups 311</td>
</tr>
<tr>
<td>Automation 313</td>
</tr>
<tr>
<td>Creating 310</td>
</tr>
<tr>
<td>Nesting 312</td>
</tr>
<tr>
<td>Removing from link groups 311</td>
</tr>
<tr>
<td>Settings 309</td>
</tr>
<tr>
<td>Velocity</td>
</tr>
<tr>
<td>Changing for note events 721</td>
</tr>
<tr>
<td>MIDI function 681</td>
</tr>
<tr>
<td>Velocity compression 646</td>
</tr>
<tr>
<td>Velocity shift 646</td>
</tr>
<tr>
<td>Verses (Lyrics) 1258</td>
</tr>
<tr>
<td>Video</td>
</tr>
<tr>
<td>Bi-level signals 957</td>
</tr>
<tr>
<td>Codecs 981</td>
</tr>
<tr>
<td>Device Setup 987</td>
</tr>
<tr>
<td>Editing 990</td>
</tr>
<tr>
<td>Extracting audio from 990</td>
</tr>
<tr>
<td>Formats 981</td>
</tr>
<tr>
<td>Importing 983</td>
</tr>
<tr>
<td>Output devices 982</td>
</tr>
<tr>
<td>Playback 986</td>
</tr>
<tr>
<td>Replacing audio 991</td>
</tr>
<tr>
<td>Scrubbing 988</td>
</tr>
<tr>
<td>Synchronization 957</td>
</tr>
<tr>
<td>Thumbnails 985</td>
</tr>
<tr>
<td>Tri-level signals 957</td>
</tr>
<tr>
<td>Video Player window 988</td>
</tr>
<tr>
<td>Aspect ratio 988</td>
</tr>
<tr>
<td>Setting video quality 988</td>
</tr>
<tr>
<td>Setting window size 988</td>
</tr>
<tr>
<td>Video track 130</td>
</tr>
<tr>
<td>Editing in Project Browser 935</td>
</tr>
<tr>
<td>Virgin territory</td>
</tr>
<tr>
<td>Automation 584</td>
</tr>
<tr>
<td>Creating gaps 584</td>
</tr>
<tr>
<td>Defining a terminator point 585</td>
</tr>
<tr>
<td>Virtual Keyboard</td>
</tr>
<tr>
<td>About 210</td>
</tr>
<tr>
<td>Computer keyboard 211</td>
</tr>
<tr>
<td>Modulation 211</td>
</tr>
<tr>
<td>Note velocity level 211</td>
</tr>
<tr>
<td>Octave offset 211</td>
</tr>
<tr>
<td>Options 211</td>
</tr>
<tr>
<td>Piano keyboard 211</td>
</tr>
<tr>
<td>Pitchbend 211</td>
</tr>
<tr>
<td>Recording MIDI 210</td>
</tr>
<tr>
<td>Visibility</td>
</tr>
<tr>
<td>MixConsole 297</td>
</tr>
<tr>
<td>Synchronizing track and channel visibility 55</td>
</tr>
<tr>
<td>Visibility Inspector</td>
</tr>
<tr>
<td>About 54, 55</td>
</tr>
<tr>
<td>Voices</td>
</tr>
<tr>
<td>About 1163</td>
</tr>
<tr>
<td>Converting to tracks 1176</td>
</tr>
<tr>
<td>Display Quantize 1172</td>
</tr>
<tr>
<td>Moving notes to 1169</td>
</tr>
<tr>
<td>Voicing</td>
</tr>
<tr>
<td>Changing for chords 711</td>
</tr>
<tr>
<td>Voicings 825</td>
</tr>
<tr>
<td>Automatic voicings 825</td>
</tr>
<tr>
<td>Configuring parameters 825</td>
</tr>
<tr>
<td>Library 825</td>
</tr>
<tr>
<td>Library subset 825</td>
</tr>
<tr>
<td>Octave offset 825</td>
</tr>
<tr>
<td>Piano 825</td>
</tr>
<tr>
<td>Range 825</td>
</tr>
<tr>
<td>Volume</td>
</tr>
<tr>
<td>MixConsole 323</td>
</tr>
<tr>
<td>Volume curve 257</td>
</tr>
<tr>
<td>Volume handle 249</td>
</tr>
<tr>
<td>VST</td>
</tr>
<tr>
<td>Input ports 18</td>
</tr>
<tr>
<td>Output ports 18</td>
</tr>
<tr>
<td>VST 3</td>
</tr>
<tr>
<td>Suspend plug-in processing 607</td>
</tr>
<tr>
<td>VST 3 Standard 373</td>
</tr>
<tr>
<td>VST Audio System 14</td>
</tr>
<tr>
<td>VST Connections 22</td>
</tr>
<tr>
<td>About 22</td>
</tr>
<tr>
<td>Editing 40</td>
</tr>
<tr>
<td>Exclusive port assignment 353</td>
</tr>
<tr>
<td>Presets 32</td>
</tr>
<tr>
<td>VST instrument parameters</td>
</tr>
<tr>
<td>Assigning to Quick Controls 621</td>
</tr>
<tr>
<td>VST instruments</td>
</tr>
<tr>
<td>Freezing 608</td>
</tr>
<tr>
<td>Presets 603</td>
</tr>
<tr>
<td>Saving presets 604</td>
</tr>
<tr>
<td>Setting up 599</td>
</tr>
<tr>
<td>Using VST System Link 978</td>
</tr>
</tbody>
</table>

1345
Index

VST plug-ins
  Installing 613
VST Presets
  Loading 163
VST System Link
  About 966
  Activating 971
  Connections 968
  Latency 969
  MIDI 974
  Putting computers online 973
  Requirements 967
  Setting up sync 968
  Settings 970

W
  Warn Before Removing Modified Effects 1084
  Warn before switching Display Domain (Timewarp Tool) 1063
  Warn on Processing Overloads 1082
  Warp markers
    Editing 458
    Resetting 459
  Warping segments
    VariAudio 482
  Wave 64 files 949
  Wave files 949
  Waveform Brightness 1064
  Waveform display
    Sample Editor 439
  Waveform Outline Intensity 1064
  When Recording Wave Files larger than 4 GB 1075
  Wind Speed Options 1080
  Windows Media Audio files
    Exporting 951
    Importing 951, 1018
    Surround format (Pro) 951
  Word clock
    About 957
  Working with MIDI data
    Tools and functions for 749
  Workspaces
    Adding 1030
    Creating 1030
    Editing 1030
    Modifying 1030
    Of external projects 1029
    Organizing 1031
    Saving 1030
    Templates 1029
    Types 1028
    Updating 1030
  Workspaces Organizer 1031
  Write automation 577
  Writing automation
    Automatically 577, 578
    Manually 577, 578
    Tools 579
  Z
  Zero crossings
    Snap function 433
  Zones
    MixConsole 297
  Zoom
    Project window 58
    Zoom Tool Standard Mode - Horizontal Zooming Only 1063
    Zoom while Locating in Time
      Scale 1080
  Zooming 1099
    Mouse wheel 1100
    Sample Editor 440
    To cycle markers 282
    Tool 1099
  Zooming tracks 139