After you start Sound Forge for the first time, the registration wizard will appear. This wizard offers easy steps that enable you to register Sound Forge online with Sonic Foundry. Alternatively, you may register Sound Forge online at www.sonicfoundry.com at anytime.

Registering your product will provide you with exclusive access to a variety of technical support options, notification of product updates, and special promotions exclusive to Sound Forge registered users.

Registration Assistance

If you do not have access to the Internet, registration assistance is available. Please contact our Customer Service Department.

Registration assistance is currently available during regular business hours by dialing the following numbers:

<table>
<thead>
<tr>
<th>Telephone/Fax</th>
<th>Country</th>
</tr>
</thead>
<tbody>
<tr>
<td>1-800-577-6642 (toll-free)</td>
<td>US, Canada, and Virgin Islands</td>
</tr>
<tr>
<td>+800-000-76642 (toll-free)</td>
<td>Australia, Denmark, France, Germany, Italy,</td>
</tr>
<tr>
<td></td>
<td>Sweden, UK, Netherlands, and Japan</td>
</tr>
<tr>
<td>+608-204-7703</td>
<td>for all other countries</td>
</tr>
<tr>
<td>1-608-250-1745 (Fax)</td>
<td>All countries</td>
</tr>
</tbody>
</table>
Customer Service/Sales

For a detailed list of Customer Service options, we encourage you to visit www.sonicfoundry.com. For Customer Service during normal office hours:

**Telephone/Fax/E-mail** | **Country**
--- | ---
1-800-577-6642 (toll-free) | US, Canada, and Virgin Islands
+800-000-76642 (toll-free) | Australia, Denmark, France, Germany, Italy, Sweden, UK, Netherlands, and Japan
+608-204-7703 | for all other countries
1-608-250-1745 (Fax) | All countries
customerservice@sonicfoundry.com

Technical Support

For a detailed list of Technical Support options, we encourage you to visit www.sonicfoundry.com/support.

- To listen to your support options, please call 608-256-5555.
- Customers who have purchased the full version of Sound Forge receive 60 days of complimentary phone support. This complimentary support begins when the product is registered. (Registration is required to receive this complimentary support.) Please call (608) 204-7704 if you need assistance with your full version of Sound Forge. This offer does not apply to Sound Forge XP users.

Sonic Foundry, Inc.
1617 Sherman Avenue
Madison, WI 53704
USA

The information contained in this manual is subject to change without notice and does not represent a commitment on the part of Sonic Foundry. The software described in this manual is provided under the terms of a license agreement or non-disclosure agreement. The software license agreement specifies the terms and conditions for its lawful use. No part of this manual may be reproduced or transmitted in any form or by any means for any purpose other than the purchaser's personal use, without written permission from Sonic Foundry, Inc.

Sonic Foundry and Sound Forge are registered trademarks of Sonic Foundry, Inc. The brands and products named here are the trademarks or registered trademarks of Sonic Foundry, its affiliates, or their respective holders.

© 2001 Sonic Foundry, Inc.
# Table of Contents

## Introduction
- Introducing Sound Forge .................................................. 21
- Using This Manual .............................................................. 21
- Full version of Sound Forge versus Sound Forge XP ...................... 22
- Shortcuts ........................................................................... 23
- Installation .......................................................................... 23
  - To install Sound Forge ......................................................... 23

## What’s New? ........................................................................ 25
- Extended bit-depth and sample rate support ................................. 25
  - Bit-depth ........................................................................ 25
  - Sample rate .................................................................... 26
- Acoustic Mirror .................................................................... 26
- Built-in DirectX FX Plug-Ins .................................................... 26
- CD Writing .......................................................................... 26
- CD Ripping ......................................................................... 26
- Wave Hammer ..................................................................... 27
- Repair tools ........................................................................ 27
- Bit-Depth Converter ............................................................. 27
- MP3 Plug-In ........................................................................ 27
TABLE OF CONTENTS

Sonic Foundry Perfect Clarity Audio (.pca) format ................. 27
New registration procedure ........................................... 27

Optimization .......................................................... 29
Hard drive defragmentation ............................................ 29
Windows 9x/Me default settings ...................................... 30
Direct mode .............................................................. 30
   Opening a file in direct mode .................................... 31
   Peak files ............................................................. 31
Faster file saving ....................................................... 31
   Relocating the temporary storage folder ....................... 31
The Sound Mapper ...................................................... 32
   Preventing audio breakup ....................................... 32
Total Buffer Size ...................................................... 32
   Editing the total buffer size ................................... 33
Preload Size ............................................................ 33
   Changing the preload size ...................................... 33
Forced Write-Through During Record (Windows 9x and Me only) .. 33
   Disabling Forced Write-Through During Record ............... 34
Playback cursor and record counter ................................ 34
   Turning off the playback cursor and record counter ....... 34
Meters ................................................................. 34
   Turning off the play (output) meters ......................... 34
   Turning off the record meters .................................. 34
Passive updating for video and time displays ..................... 35
   Enable passively updated time displays ...................... 35
   Enable passively updated video displays ..................... 35
Scan for external monitor ........................................... 35
   Turning off scan for external monitor ....................... 35
Background processing ........................................ 35
Running multiple applications ............................ 35

Controls .......................................................... 37
Using the mouse ................................................ 37
Using the mousewheel ....................................... 38
The main screen .................................................. 39
Main screen components ................................. 40
The data window ................................................. 40
Data window components .............................. 41
Displaying data window components ........ 42
The Playbar ....................................................... 42
Toolbars .......................................................... 43
Available toolbars ............................................. 44
Displaying a toolbar ..................................... 44
The Standard toolbar .................................. 45
The Transport toolbar .................................. 46
Navigation toolbar ....................................... 47
Views toolbar ..................................................... 48
Status/Selection toolbar .................................. 49
Regions/Playlist toolbar ................................ 50
Process toolbar ............................................. 51
The Effects toolbar ......................................... 53
The Tools toolbar ............................................ 55
The Levels toolbar ......................................... 56
ACID Loop Creation Tools toolbar ........ 57
ToolTip .......................................................... 58
Command descriptions .................................. 58
Controls .......................................................... 58
Vertical faders and horizontal sliders .......... 59
Edit box spinner ............................................. 60
## TABLE OF CONTENTS

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Drop-down lists</td>
<td>61</td>
</tr>
<tr>
<td>Radio buttons</td>
<td>61</td>
</tr>
<tr>
<td>Check boxes</td>
<td>61</td>
</tr>
<tr>
<td>Envelope graphs</td>
<td>62</td>
</tr>
<tr>
<td>Displaying the waveform on an envelope graph</td>
<td>64</td>
</tr>
<tr>
<td><strong>Stereo files</strong></td>
<td>64</td>
</tr>
<tr>
<td>Working with stereo files</td>
<td>65</td>
</tr>
<tr>
<td>Selecting data in stereo files</td>
<td>65</td>
</tr>
<tr>
<td><strong>Getting Help within Sound Forge</strong></td>
<td>68</td>
</tr>
<tr>
<td>Online Help</td>
<td>68</td>
</tr>
<tr>
<td>What's This? Help</td>
<td>71</td>
</tr>
<tr>
<td>Help on the Web</td>
<td>71</td>
</tr>
<tr>
<td><strong>Fundamentals</strong></td>
<td>73</td>
</tr>
<tr>
<td>Opening a file</td>
<td>73</td>
</tr>
<tr>
<td>The Open dialog</td>
<td>74</td>
</tr>
<tr>
<td>Playing a file</td>
<td>76</td>
</tr>
<tr>
<td>File position indicators</td>
<td>76</td>
</tr>
<tr>
<td>Playing a file from a specified point</td>
<td>77</td>
</tr>
<tr>
<td>Playing an audio selection</td>
<td>78</td>
</tr>
<tr>
<td>Selection status fields</td>
<td>78</td>
</tr>
<tr>
<td>Viewing selection statistics</td>
<td>79</td>
</tr>
<tr>
<td>Creating a new data window</td>
<td>80</td>
</tr>
<tr>
<td>Active data windows vs. inactive data windows</td>
<td>80</td>
</tr>
<tr>
<td>Copying data to a new file</td>
<td>81</td>
</tr>
<tr>
<td><strong>Saving a file</strong></td>
<td>81</td>
</tr>
<tr>
<td>The Save As dialog</td>
<td>82</td>
</tr>
<tr>
<td>Saving all open audio files</td>
<td>83</td>
</tr>
<tr>
<td>Saving/opening the workspace</td>
<td>84</td>
</tr>
<tr>
<td>E-mailing audio files</td>
<td>84</td>
</tr>
<tr>
<td><strong>Audio editing</strong></td>
<td>85</td>
</tr>
<tr>
<td>Editing tutorial</td>
<td>85</td>
</tr>
<tr>
<td>Section</td>
<td>Page</td>
</tr>
<tr>
<td>---------------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>Copy</td>
<td>86</td>
</tr>
<tr>
<td>Copying data to the clipboard</td>
<td>86</td>
</tr>
<tr>
<td>Paste</td>
<td>88</td>
</tr>
<tr>
<td>Pasting data in an existing data window</td>
<td>88</td>
</tr>
<tr>
<td>Pasting in a new data window</td>
<td>88</td>
</tr>
<tr>
<td>Cut</td>
<td>89</td>
</tr>
<tr>
<td>Cutting data from a window</td>
<td>89</td>
</tr>
<tr>
<td>Previewing a Cut</td>
<td>90</td>
</tr>
<tr>
<td>Delete (Clear)</td>
<td>90</td>
</tr>
<tr>
<td>Trim/Crop</td>
<td>91</td>
</tr>
<tr>
<td>Trimming/cropping an audio selection</td>
<td>91</td>
</tr>
<tr>
<td>Mix</td>
<td>92</td>
</tr>
<tr>
<td>Mixing audio</td>
<td>92</td>
</tr>
<tr>
<td>Undo/redo an edit operation</td>
<td>94</td>
</tr>
<tr>
<td>Undo/Redo History window</td>
<td>95</td>
</tr>
<tr>
<td>Using the Undo/Redo History window</td>
<td>95</td>
</tr>
<tr>
<td>Status formats</td>
<td>98</td>
</tr>
<tr>
<td>How status formats work</td>
<td>98</td>
</tr>
<tr>
<td>Configuring the frames format</td>
<td>99</td>
</tr>
<tr>
<td>Configuring the Measures &amp; Beats format</td>
<td>100</td>
</tr>
<tr>
<td>Zoom and magnify</td>
<td>100</td>
</tr>
<tr>
<td>Time Ruler (horizontal) zooming</td>
<td>101</td>
</tr>
<tr>
<td>Level Ruler (vertical) zooming</td>
<td>103</td>
</tr>
<tr>
<td>Zoom tricks</td>
<td>105</td>
</tr>
<tr>
<td>Magnify tool</td>
<td>106</td>
</tr>
<tr>
<td>Using the Magnify Tool</td>
<td>107</td>
</tr>
<tr>
<td>Crash recovery</td>
<td>109</td>
</tr>
<tr>
<td>Recover</td>
<td>109</td>
</tr>
<tr>
<td>Delete</td>
<td>109</td>
</tr>
<tr>
<td>Ignore</td>
<td>109</td>
</tr>
</tbody>
</table>
# Types, Formats, and Attributes

- File attributes .......................................................... 111
  - Editing file attributes ............................................. 112
- Sample rate ............................................................. 112
  - Editing the sample rate ........................................... 113
- Bit Depth ................................................................. 113
  - Step-up conversion ................................................ 113
  - Step-Down Conversion ............................................ 114
  - Minimizing quantization error ................................. 116
- Channels ................................................................. 117
  - Mono-to-stereo conversion ...................................... 117
  - Stereo-to-mono conversion ..................................... 118
  - Channel Converter ................................................. 119
- Converting file formats ............................................ 119
  - Save as type ........................................................ 119
  - Format ............................................................... 119
  - Attributes ........................................................... 120
- Summary information ................................................ 120
  - Viewing and editing summary information .................... 120
  - Viewing extended summary information ....................... 120
  - Editing extended summary information ....................... 121
  - Saving summary information ................................... 122
  - Additional embedded information .............................. 122

# Markers, Regions, and the Playlist/Cutlist

- Why use markers, regions, and the Playlist? ....................... 123
  - Rapid navigation .................................................. 123
  - Destructive vs. nondestructive editing ....................... 123
  - MIDI synchronization and triggering .......................... 124
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Markers</td>
<td>124</td>
</tr>
<tr>
<td>Creating a marker</td>
<td>124</td>
</tr>
<tr>
<td>Creating markers using the ruler shortcut menu</td>
<td>125</td>
</tr>
<tr>
<td>Creating markers during playback</td>
<td>126</td>
</tr>
<tr>
<td>Creating markers during recording</td>
<td>126</td>
</tr>
<tr>
<td>Changing the marker position</td>
<td>126</td>
</tr>
<tr>
<td>Using markers to create regions</td>
<td>127</td>
</tr>
<tr>
<td>The Regions List</td>
<td>127</td>
</tr>
<tr>
<td>Displaying the Regions List</td>
<td>128</td>
</tr>
<tr>
<td>Understanding the Regions List</td>
<td>128</td>
</tr>
<tr>
<td>Creating regions</td>
<td>130</td>
</tr>
<tr>
<td>Creating regions using menu commands</td>
<td>130</td>
</tr>
<tr>
<td>Creating regions using drag-and-drop operations</td>
<td>131</td>
</tr>
<tr>
<td>Creating regions using the ruler shortcut</td>
<td>132</td>
</tr>
<tr>
<td>Creating regions using the keyboard</td>
<td>132</td>
</tr>
<tr>
<td>Creating regions automatically</td>
<td>132</td>
</tr>
<tr>
<td>Creating regions while recording</td>
<td>132</td>
</tr>
<tr>
<td>The Auto Region tool</td>
<td>133</td>
</tr>
<tr>
<td>Using the Auto Region tool with rapid sound attacks</td>
<td>133</td>
</tr>
<tr>
<td>Active parameters</td>
<td>133</td>
</tr>
<tr>
<td>Using the Auto Region Tool with musical time intervals</td>
<td>134</td>
</tr>
<tr>
<td>The Markers to Regions command</td>
<td>135</td>
</tr>
<tr>
<td>Editing a region</td>
<td>135</td>
</tr>
<tr>
<td>Editing regions in the data window</td>
<td>136</td>
</tr>
<tr>
<td>Editing regions using the marker/region shortcut menu</td>
<td>136</td>
</tr>
<tr>
<td>Editing regions in the Regions List</td>
<td>136</td>
</tr>
<tr>
<td>Editing regions using the Regions List shortcut menu</td>
<td>137</td>
</tr>
<tr>
<td>The Extract Regions tool</td>
<td>138</td>
</tr>
</tbody>
</table>
The Playlist ....................................................... 139
Displaying the Playlist ........................................ 139
Adding regions to the Playlist ................................ 139
Adding regions to the Playlist using menu commands .... 140
Adding regions to the Playlist using drag-and-drop operations .... 140
Region display in the Playlist .................................. 141
Playing from the Playlist ........................................ 142
Arranging the Playlist .......................................... 142
Replicating a region in the Playlist ......................... 143
Stop points ...................................................... 143
Deleting a region from the Playlist ......................... 144
Creating a new file from the Playlist ...................... 145
The Cutlist ..................................................... 145
Enabling the Cutlist ........................................... 146
Using the Cutlist .............................................. 146

Recording, Ripping, and Writing ......................... 149
Protecting existing audio during recording ............... 149
  Recording in Direct mode ................................. 149
Record dialog ................................................ 149
  Displaying the Record dialog with no open data windows .... 149
  Displaying the Record dialog with open data windows ........ 150
Record dialog features ..................................... 150
Displays ........................................................ 150
  Title bar .................................................... 150
  Recording attributes .................................... 151
  Recording time ......................................... 151
Recording modes ..................................................... 151
  Automatic retake (automatically rewind) ....................... 152
  Multiple takes creating Regions .................................. 152
  Multiple takes (no Regions) ..................................... 152
  Create a new window for each take ............................... 153
  Punch-In (record a specific length) ............................. 153
DC adjust ............................................................. 154
  Calibrating the DC adjust ....................................... 155
Record dialog buttons ................................................ 156
  The New button .................................................... 156
  The Close button .................................................. 156
  The Remote button ............................................... 157
  The Help button .................................................... 158
  The Go To button .................................................... 158
  The Selection button .............................................. 159
  The Window button ............................................... 160
  The Sync button .................................................... 161
Record meters ........................................................ 163
  Viewing record levels .............................................. 163
  Scaling the record meters ....................................... 163
Record level ........................................................... 164
  Setting the record level ......................................... 164
Record dialog toolbar ............................................... 165
  The Prepare button ............................................... 165
  The Record button .................................................. 166
  The Drop Marker button ......................................... 166
Other features ....................................................... 166
  Gap detection ....................................................... 166
  Automatic labeling ................................................ 167
  Blinking status ..................................................... 167
Extracting data from CD ........................................... 168
- Create regions for each track ................................. 169
- Create markers for each index change ..................... 169
- Previewing CD tracks .......................................... 169
- Refreshing the Extract Audio from CD dialog .......... 169

Writing to CD ..................................................... 169
- Sample rates, bit-depths, and CD writing ................. 170
- Writing mono tracks to CD .................................. 170
- Adding a track to CD ........................................ 170
- Closing the CD ................................................ 171

Advanced Editing ................................................. 173
- Pre-roll to Cursor .............................................. 173
  - Using Pre-roll to Cursor .................................. 173
- Go To dialog .................................................... 173
  - Displaying the Go To dialog ............................... 174
  - Using the Go To dialog ................................... 174
- Using the Set Selection dialog .............................. 175
  - Creating a selection ....................................... 175
  - Other Set Selection dialog controls ..................... 175
- Using Mark In/Mark Out .................................... 176
  - Creating selections during playback ..................... 176
- Fine-tuning selection points ................................. 177
  - Tuning a selection with the mouse ....................... 177
  - Auto snaps .................................................. 177
  - Tuning a selection with the keyboard ................... 178
  - Restoring a selection ...................................... 179
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>The Overview</td>
<td>180</td>
</tr>
<tr>
<td>Understanding the Overview</td>
<td>180</td>
</tr>
<tr>
<td>Navigating in the Overview</td>
<td>182</td>
</tr>
<tr>
<td>Playback in the Overview</td>
<td>182</td>
</tr>
<tr>
<td>Audio event locator</td>
<td>183</td>
</tr>
<tr>
<td>Views</td>
<td>183</td>
</tr>
<tr>
<td>Displaying the Views toolbar</td>
<td>183</td>
</tr>
<tr>
<td>Creating views</td>
<td>184</td>
</tr>
<tr>
<td>Paste Special</td>
<td>184</td>
</tr>
<tr>
<td>Crossfade</td>
<td>185</td>
</tr>
<tr>
<td>Overwrite</td>
<td>185</td>
</tr>
<tr>
<td>Replicate</td>
<td>186</td>
</tr>
<tr>
<td>Drag and drop operations</td>
<td>188</td>
</tr>
<tr>
<td>Dragging mono selections into stereo destinations</td>
<td>188</td>
</tr>
<tr>
<td>Snapping to events in drag-and-drop operations</td>
<td>188</td>
</tr>
<tr>
<td>Drag-and-drop pasting</td>
<td>189</td>
</tr>
<tr>
<td>Drag-and-drop mixing</td>
<td>190</td>
</tr>
<tr>
<td>Drag-and-drop crossfading</td>
<td>191</td>
</tr>
<tr>
<td>Mix/Paste/Crossfade toggle</td>
<td>192</td>
</tr>
<tr>
<td>Creating a new window with drag-and-drop operations</td>
<td>192</td>
</tr>
<tr>
<td>Finding and repairing audio glitches</td>
<td>192</td>
</tr>
<tr>
<td>Using the Find tool to locate glitches</td>
<td>193</td>
</tr>
<tr>
<td>Repairing audio using Copy Other Channel</td>
<td>194</td>
</tr>
<tr>
<td>Repairing audio using Interpolate</td>
<td>195</td>
</tr>
<tr>
<td>Repairing audio using Replace</td>
<td>196</td>
</tr>
<tr>
<td>Repairing audio with the Pencil tool</td>
<td>197</td>
</tr>
<tr>
<td>Audio Plug-In Chainer</td>
<td>198</td>
</tr>
<tr>
<td>Using the Audio Plug-In Chainer</td>
<td>198</td>
</tr>
</tbody>
</table>
### Processes

Presets .................................................. 207
- Using a preset ........................................... 207
- Creating presets ....................................... 208
- Deleting presets ....................................... 209
- Using the Preset Manager ............................ 209

Preview an operation .................................. 210

Previews ................................................ 210
- Storing preview parameters ........................... 210
- Preview parameters .................................... 211
- The Bypass check box ................................ 212

Repeating an operation ................................ 212

Sound Forge processes ................................ 213

Auto Trim/Crop .......................................... 213
- Using Auto Trim/Crop ................................ 213
- Auto Trim/Crop controls .............................. 214

Bit-Depth Converter .................................. 215
- Converting a file’s bit-depth ......................... 216

Channel Converter .................................... 218
- Using the Channel Converter ....................... 218
- Channel Converter controls ......................... 219

DC Offset .............................................. 220
- DC Offset controls ................................... 220

EQ ......................................................... 221
<table>
<thead>
<tr>
<th>Feature</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fade</td>
<td>222</td>
</tr>
<tr>
<td>Graphic Fade</td>
<td>222</td>
</tr>
<tr>
<td>Creating a graphic fade</td>
<td>222</td>
</tr>
<tr>
<td>Creating a custom graphic fade</td>
<td>223</td>
</tr>
<tr>
<td>Graphic Fade Controls</td>
<td>223</td>
</tr>
<tr>
<td>Fade In</td>
<td>224</td>
</tr>
<tr>
<td>Fade Out</td>
<td>224</td>
</tr>
<tr>
<td>Insert Silence</td>
<td>225</td>
</tr>
<tr>
<td>Inserting silence into a file</td>
<td>225</td>
</tr>
<tr>
<td>Insert Silence controls</td>
<td>225</td>
</tr>
<tr>
<td>Invert/Flip</td>
<td>226</td>
</tr>
<tr>
<td>Inverting an audio selection</td>
<td>226</td>
</tr>
<tr>
<td>Mute</td>
<td>226</td>
</tr>
<tr>
<td>Muting an audio selection</td>
<td>226</td>
</tr>
<tr>
<td>Normalize</td>
<td>227</td>
</tr>
<tr>
<td>Normalizing Audio</td>
<td>227</td>
</tr>
<tr>
<td>Normalize Controls</td>
<td>228</td>
</tr>
<tr>
<td>Pan/Expand</td>
<td>232</td>
</tr>
<tr>
<td>Creating a pan</td>
<td>232</td>
</tr>
<tr>
<td>Creating a custom pan</td>
<td>233</td>
</tr>
<tr>
<td>Pan/Expand controls</td>
<td>234</td>
</tr>
<tr>
<td>Resample</td>
<td>235</td>
</tr>
<tr>
<td>Downsampling audio</td>
<td>236</td>
</tr>
<tr>
<td>Upsampling audio</td>
<td>236</td>
</tr>
<tr>
<td>Resample controls</td>
<td>237</td>
</tr>
<tr>
<td>Reverse</td>
<td>238</td>
</tr>
<tr>
<td>Smooth/Enhance</td>
<td>238</td>
</tr>
<tr>
<td>Time Compress/Expand</td>
<td>238</td>
</tr>
<tr>
<td>Volume</td>
<td>239</td>
</tr>
<tr>
<td>Increasing the volume of a selection</td>
<td>240</td>
</tr>
<tr>
<td>Volume control</td>
<td>241</td>
</tr>
</tbody>
</table>
# TABLE OF CONTENTS

## Acoustic Mirror and Wave Hammer ........................................... 243

- What is Acoustic Mirror? ..................................................... 243
- The acoustic signature ....................................................... 243
- Adding an acoustic signature to an audio file. ....................... 244
- Adjusting the acoustic signature ......................................... 245
- Acoustic Mirror dialog ....................................................... 245
  - Acoustic Mirror dialog controls ......................................... 245
  - General tab controls ....................................................... 245
  - Envelope tab controls ..................................................... 247
  - Summary tab controls ..................................................... 249
  - Recover tab controls ..................................................... 250
- Creating Impulse Files ....................................................... 252
  - What you need to create custom impulses ........................... 252
  - Recording the impulse in an acoustic space ....................... 253
  - Recording the impulse through an electronic device .......... 254
  - Recovering the impulse .................................................. 254
  - Trimming the impulse file .............................................. 256
  - Adding summary information to your impulse file ............. 256
  - Using the new impulse file ............................................. 257
- Using impulse files in creative ways ................................... 257
  - Processing individual audio elements ............................... 258
  - Adding realistic stereo to mono recordings ....................... 258
  - Creating special effects ................................................ 258
  - Recreating spaces for foley effects and dialog replacement ... 259
  - Panning with head-related transfer functions .................... 259
- Troubleshooting .............................................................. 260
  - Stuttering during real-time previewing .............................. 260
  - Impulses do not recover properly .................................... 261
  - The recovered impulse is too noisy .................................. 261
  - Descriptions of Error Messages ...................................... 261
# TABLE OF CONTENTS

What is Wave Hammer? .............................................. 262
- Displaying Wave Hammer ........................................... 262
- Compressor tab ......................................................... 262
- Volume Maximizer tab .............................................. 265

## MIDI/SMPTE ................................................................. 267

- What is MIDI? .......................................................... 267
- The Virtual MIDI Router ............................................ 267
- Installing the Virtual MIDI Router ................................. 268
  - Installing the VMR in Windows 98 or Me ...................... 268
  - Installing the VMR in Windows 2000 .......................... 268
- Configuring the Virtual MIDI Router ............................. 269
  - Configuring the VMR for Windows 98 and Me ................. 270
  - Configuring the VMR for Windows 2000 ....................... 271

- MIDI triggers ......................................................... 271
  - Playback Versus Triggered Playback ......................... 271
  - MIDI-triggered playback ......................................... 272
  - Triggered region playback ....................................... 274
- Additional internal/external MIDI devices ...................... 276
- Advantages of external MIDI controllers ....................... 276

- Sound Forge and MIDI Timecode synchronization ............ 277
  - Playing regions using MTC from a sequencer ................. 278
  - Playing regions using MTC from an external device ....... 279
  - Using Sound Forge to generate MTC for a MIDI sequencer .. 279
  - Using Sound Forge to generate MTC for an external device 280

## Sampling ............................................................... 281

- Samplers .............................................................. 281
  - External samplers .................................................. 281
  - Internal samplers ................................................. 282
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>The Sampler dialog</td>
<td>282</td>
</tr>
<tr>
<td>Displaying the Sampler dialog</td>
<td>282</td>
</tr>
<tr>
<td>Configuring the Sampler Tool</td>
<td>283</td>
</tr>
<tr>
<td>The Sampler Configuration dialog</td>
<td>283</td>
</tr>
<tr>
<td>Displaying the Sampler Configuration dialog</td>
<td>283</td>
</tr>
<tr>
<td>Creating a sampler configuration</td>
<td>283</td>
</tr>
<tr>
<td>Saving sampler configurations</td>
<td>286</td>
</tr>
<tr>
<td>Sending and receiving samples.</td>
<td>286</td>
</tr>
<tr>
<td>Sending a sample</td>
<td>286</td>
</tr>
<tr>
<td>Receiving a sample</td>
<td>287</td>
</tr>
<tr>
<td>MIDI unity note and Fine tune</td>
<td>287</td>
</tr>
<tr>
<td>The MIDI Keyboard</td>
<td>288</td>
</tr>
<tr>
<td>Displaying the MIDI Keyboard</td>
<td>288</td>
</tr>
<tr>
<td>Turning the MIDI Keyboard on</td>
<td>288</td>
</tr>
<tr>
<td>Configuring the MIDI Keyboard output port and channel</td>
<td>288</td>
</tr>
<tr>
<td>MIDI Keyboard troubleshooting</td>
<td>289</td>
</tr>
<tr>
<td>Specifying instruments</td>
<td>289</td>
</tr>
<tr>
<td>Generating chords</td>
<td>289</td>
</tr>
<tr>
<td>MIDI/SDS hardware setup</td>
<td>290</td>
</tr>
<tr>
<td>MIDI/SDS troubleshooting with open loop</td>
<td>290</td>
</tr>
<tr>
<td>SCSI/SMDI hardware and setup</td>
<td>290</td>
</tr>
<tr>
<td>SCSI/SMDI troubleshooting</td>
<td>291</td>
</tr>
<tr>
<td>Conflicting SCSI IDs</td>
<td>291</td>
</tr>
<tr>
<td>Periodic transfer failures</td>
<td>291</td>
</tr>
<tr>
<td>The sampler is recognized but does not transfer reliably</td>
<td>292</td>
</tr>
<tr>
<td>Looping</td>
<td>295</td>
</tr>
<tr>
<td>Section</td>
<td>Page</td>
</tr>
<tr>
<td>------------------------------------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>Loops</td>
<td>295</td>
</tr>
<tr>
<td>Sustaining and release loops</td>
<td>296</td>
</tr>
<tr>
<td>Creating a sustaining loop</td>
<td>296</td>
</tr>
<tr>
<td>Creating a sustain loop with a release loop</td>
<td>297</td>
</tr>
<tr>
<td>Looping techniques</td>
<td>298</td>
</tr>
<tr>
<td>Match endpoint amplitudes</td>
<td>299</td>
</tr>
<tr>
<td>Match endpoint waveform slope</td>
<td>299</td>
</tr>
<tr>
<td>Match endpoint sound levels</td>
<td>300</td>
</tr>
<tr>
<td>Avoid very short loops</td>
<td>300</td>
</tr>
<tr>
<td>Editing loops</td>
<td>300</td>
</tr>
<tr>
<td>Editing a loop without the Loop Tuner</td>
<td>300</td>
</tr>
<tr>
<td>Editing a loop with the Loop Tuner</td>
<td>301</td>
</tr>
<tr>
<td>The Crossfade Loop tool</td>
<td>305</td>
</tr>
<tr>
<td>Using the Crossfade Loop tool</td>
<td>305</td>
</tr>
<tr>
<td>Looping and ACID</td>
<td>306</td>
</tr>
<tr>
<td>Displaying the ACID Loop Creation Tools toolbar</td>
<td>306</td>
</tr>
<tr>
<td>ACID Toolbar functions</td>
<td>307</td>
</tr>
<tr>
<td>Editing ACID properties</td>
<td>307</td>
</tr>
<tr>
<td>Loop halving /doubling</td>
<td>309</td>
</tr>
<tr>
<td>Shift selection left/right</td>
<td>309</td>
</tr>
<tr>
<td>Rotate Audio</td>
<td>310</td>
</tr>
<tr>
<td>Loop tempo</td>
<td>311</td>
</tr>
<tr>
<td>Saving loop points</td>
<td>312</td>
</tr>
<tr>
<td>Disabling the loop points</td>
<td>312</td>
</tr>
<tr>
<td>Working with AVI Files</td>
<td>313</td>
</tr>
<tr>
<td>Opening an AVI file</td>
<td>313</td>
</tr>
<tr>
<td>Multiple streams</td>
<td>314</td>
</tr>
<tr>
<td>AVI navigation</td>
<td>314</td>
</tr>
<tr>
<td>Navigating the video strip</td>
<td>314</td>
</tr>
<tr>
<td>Displaying/hiding the video strip</td>
<td>315</td>
</tr>
</tbody>
</table>
Attaching video to an audio file ........................................ 316
Saving an AVI file .......................................................... 317
  Specifying the audio and video streams ............................. 318
  Compressing the video .................................................. 318
  Compressing the audio .................................................. 320
Using the Playlist with AVI files ........................................ 321
  Editing with the Playlist ............................................... 321
Streaming Media ............................................................ 323
  Optimizing files .......................................................... 323
Creating RealMedia files .................................................. 324
  RealMedia requirements ................................................ 324
  Setting the RealMedia Summary fields .............................. 324
  Saving files as RealMedia .............................................. 325
  Creating custom RealMedia templates ................................ 325
Creating Microsoft Windows Media Format files ................. 327
  Windows Media requirements ......................................... 328
  Creating Windows Media files ....................................... 328
  Adding markers and script commands ............................... 328
  Navigation markers ..................................................... 328
  Creating custom Windows Media 7 templates ...................... 330
  Creating custom Windows Media (.asf) templates ............... 331
Spectrum Analysis .......................................................... 333
  Working in the frequency domain .................................... 333
  Fast Fourier Transform ............................................... 334
  Spectrum graph vs. sonogram ....................................... 334
Spectrum graph ................................................................. 335
  Displaying a spectrum graph ....................................... 335
  Monitoring playback .................................................. 335
  Monitoring an input source ......................................... 335
  Displaying frequency and amplitude values .................... 336
  Displaying frequency and pitch ................................... 336
  Stereo files ................................................................... 336
  Updating a spectrum graph .......................................... 337
  Viewing multiple spectrum graphs ................................ 337
Spectrum Settings dialog .................................................. 338
  Saving spectrum settings ............................................. 340
Navigating a spectrum graph ............................................. 340
  Displaying a frequency range ...................................... 340
  Displaying an amplitude range ..................................... 341
  Displaying an amplitude and frequency range .................. 341
  Displaying ranges using the Spectrum Settings dialog ...... 342
  Grab/Pan mode ............................................................. 342
  Overview window ....................................................... 343
  Sonogram ................................................................... 343
  Displaying a sonogram ................................................ 344
  Displaying frequency and amplitude values .................... 344
  Updating a sonogram ................................................... 344
  Tuning a sonogram ...................................................... 344
  Returning to a spectrum graph ..................................... 345

Shortcuts ........................................................................ 347
General Keyboard Shortcuts ............................................. 347
  Waveform Display Keyboard Shortcuts ......................... 349
  Navigation and Playback .............................................. 351
  Regions List and Playlist Keyboard Shortcuts ................. 352
  ACID Loop Creation Tools Shortcuts ............................. 352
  Additional Mouse Shortcuts .......................................... 353
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Microsoft Audio Compression Manager</td>
<td>355</td>
</tr>
<tr>
<td>Audio Data Compression and Decompression</td>
<td>355</td>
</tr>
<tr>
<td>Transparent Playback and Recording of Non-hardware Supported Audio Files</td>
<td>356</td>
</tr>
<tr>
<td>SMPTE Timecode</td>
<td>359</td>
</tr>
<tr>
<td>SMPTE 24 Film Sync</td>
<td>359</td>
</tr>
<tr>
<td>SMPTE 25 EBU</td>
<td>359</td>
</tr>
<tr>
<td>SMPTE 30</td>
<td>359</td>
</tr>
<tr>
<td>SMPTE Non-Drop</td>
<td>359</td>
</tr>
<tr>
<td>SMPTE Drop</td>
<td>360</td>
</tr>
<tr>
<td>RIFF Wave Chunks</td>
<td>361</td>
</tr>
<tr>
<td>tlst (Trigger List) Chunk</td>
<td>362</td>
</tr>
<tr>
<td>Markers, Regions, and Playlist Entries as Used by Sound Forge</td>
<td>365</td>
</tr>
<tr>
<td>Object Linking and Embedding</td>
<td>367</td>
</tr>
<tr>
<td>Introduction to Object Linking and Embedding (OLE)</td>
<td>367</td>
</tr>
<tr>
<td>Using OLE with Sound Forge</td>
<td>367</td>
</tr>
<tr>
<td>Tips and Limitations</td>
<td>369</td>
</tr>
<tr>
<td>Using CSOUND, MTU, IRCAM, BICSF, and EBICSF Files</td>
<td>371</td>
</tr>
<tr>
<td>Opening and Saving files</td>
<td>371</td>
</tr>
<tr>
<td>Index</td>
<td>i</td>
</tr>
</tbody>
</table>
Introducing Sound Forge

Thank you for purchasing Sound Forge and for your continued support of the Sonic Foundry family of products. Sound Forge will provide you with the powerful features you have come to expect, as well as a number of new features designed to make digital audio editing quick and easy.

Using This Manual

This manual is separated into seventeen chapters, each dedicated to a specific aspect of using Sound Forge.

<table>
<thead>
<tr>
<th>Chapter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Introduction</td>
<td>Includes brief overview of manual as well as information and the procedure needed to install Sound Forge.</td>
</tr>
<tr>
<td>What's New</td>
<td>Describes Sound Forge's new features and functions.</td>
</tr>
<tr>
<td>Optimization</td>
<td>Provides procedures and tips for getting optimum system performance when using Sound Forge.</td>
</tr>
<tr>
<td>Controls</td>
<td>Provides detailed overview of all of the application's toolbars and controls.</td>
</tr>
<tr>
<td>Fundamentals</td>
<td>Describes the basics of digital audio editing.</td>
</tr>
<tr>
<td>Types, Formats, and Attributes</td>
<td>Describes and explains working with audio file configurations including bit depth, sample rate, channels, and summary information.</td>
</tr>
<tr>
<td>Markers, Regions, and the Playlist/Cutlist</td>
<td>Describes using these Sound Forge tools to identify, isolate, and arrange selections within an audio file.</td>
</tr>
<tr>
<td>Recording, Ripping, and Writing</td>
<td>Describes recording in Sound Forge, including all available recording modes as well as ripping data from and recording music to CD.</td>
</tr>
<tr>
<td>Advanced Editing</td>
<td>Describes techniques and functions that will allow you to take full advantage of Sound Forge’s digital audio editing capabilities.</td>
</tr>
<tr>
<td>Processes</td>
<td>Describes all Sound Forge features located in the Process menu. Explains use of presets and Preset Manager.</td>
</tr>
</tbody>
</table>
In addition to these chapters, seven appendices and an index are provided to assist you in mastering Sound Forge and quickly locating information within the manual. The following tables briefly describes the content of all appendices.

<table>
<thead>
<tr>
<th>Chapter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Acoustic Mirror and Wave Hammer</td>
<td>Provides an in-depth description of Sound Forge’s Acoustic Mirror feature, including procedures for creating custom impulse files. Also discusses the Wave Hammer feature.</td>
</tr>
<tr>
<td>MIDI/SMPTE</td>
<td>Explores MIDI, the Sonic Foundry Virtual MIDI Router, MIDI Triggers, and using MIDI/MTC synchronization.</td>
</tr>
<tr>
<td>Sampling</td>
<td>Examines the use of samplers and the Sound Forge Sampler Tool. Provides troubleshooting information and tips for sampling.</td>
</tr>
<tr>
<td>Looping</td>
<td>Describes creating loops in Sound Forge, including use of ACID Loop Creation tools.</td>
</tr>
<tr>
<td>Working with AVI Files</td>
<td>Describes using Sound Forge to add audio to and work with .avi files.</td>
</tr>
<tr>
<td>Streaming Media</td>
<td>Describes using Sound Forge to prepare files for streaming delivery over the Internet. Includes explanation of creating custom streaming media templates.</td>
</tr>
<tr>
<td>Spectrum Analysis</td>
<td>Describes using Sound Forge’s Spectrum Analysis tools to evaluate and edit audio files.</td>
</tr>
</tbody>
</table>

Full version of Sound Forge versus Sound Forge XP

This manual is provided to assist users of the full version of Sound Forge as well as Sound Forge XP users. For this reason, product features exclusive to the full version of Sound Forge are identified throughout the manual using the following icon:

In addition, Sound Forge XP-only issues are identified and described where appropriate.
Shortcuts

As experienced users of Sound Forge products know, there are often several methods of executing a command, including menus, shortcut menus, and keystrokes. Throughout this manual, the typical method of executing a command is identified in the procedure and alternate methods are identified in a section indicated by the following icon: 

Installation

The install utility, setup.exe, located on the Sound Forge CD-ROM, creates necessary folders and copies all files required to operate Sound Forge.

**Note:** Sound Forge requires Microsoft DirectX Media 6.0 or later and Internet Explorer 4.0 or later. The setup program will alert you if either is not detected on your system and prompt their installation from the Sound Forge CD-ROM.

To install Sound Forge

1. Place the Sound Forge CD-ROM in your system’s CD-ROM drive. AutoPlay launches the Setup menu.

   **Note:** If AutoPlay is not enabled, click the Start button and choose Run. Type “D:\setup.exe”, where D is the drive letter of your CD-ROM drive.

2. Click Install, and follow the instructions in the dialogs to complete the installation.
What’s New?

This chapter is intended for experienced Sound Forge users. It simply addresses the question on everyone’s mind: “What’s new in this version of Sound Forge?”

Extended bit-depth and sample rate support

Probably the most exciting enhancements in Sound Forge are its improved bit-depth and sample rate capabilities.

Bit-depth

This release of Sound Forge can open and save audio files with any of the following bit depths:

- 8-bit
- 16-bit
- 24-bit integer
- 32-bit float

Specifying bit-depth

The bit-depth value for new or existing audio files can be specified in any of the following locations:

- The New Window dialog. For more information, see Creating a new data window on page 80.
- The Save As dialog. For more information, see The Save As dialog on page 82.
- The Format tab of the Properties dialog. For more information, see Editing file attributes on page 112.
- The bit-depth shortcut menu (right-click the bit-depth display in the data window’s status bar). For more information, see Editing file attributes on page 112.
Sample rate

Sound Forge will now support all integral sample rates from 2 kHz to 192 kHz.

Specifying sample rate

The sample rate value can be specified or changed in any of the following locations:

- The New Window dialog. For more information, see Creating a new data window on page 80.
- The Resample dialog. For more information, see Resample on page 235.
- The Format tab in the Properties dialog. For more information, see Editing file attributes on page 112.
- The sample rate shortcut menu (right-click the sample rate display in the status bar). For more information, see Editing file attributes on page 112.

Acoustic Mirror

This release of the full version of Sound Forge includes Sonic Foundry’s Acoustic Mirror™. Acoustic Mirror allows you to add realistic reverb to audio projects by simulating acoustic wave responses of actual environments and electronic equipment. For more information, see Acoustic Mirror and Wave Hammer on page 243.

Built-in DirectX FX Plug-Ins

Sonic Foundry’s XFX packages 1, 2, and 3 are now included with the full version of Sound Forge. Where applicable, they replace the native plug-ins that did not offer real-time previews. The effects in XFX are located on the Effects and Process Sound Forge menus in place of the native plug-ins in an attempt to maintain usability for experienced Sound Forge users. Sound Forge XP includes Sonic Foundry’s ExpressFX 1, 2, and 3.

CD Writing

Sound Forge now allows track-at-once CD writing. Audio tracks can be written to CD over a period of time and, once closed, the CD can be played in an audio CD player.

CD Ripping

Sound Forge allows you to extract audio tracks from a CD and open them in Sound Forge. You can select how the audio is extracted: by track, by CD, or by a time range.
Wave Hammer

This release of Sound Forge features Wave Hammer™, an all-in-one digital audio mastering tool that includes a high-quality vintage compressor and look-ahead volume maximizer. For more information, see Acoustic Mirror and Wave Hammer on page 243.

Repair tools

Sound Forge now features three unique tools for removing glitches from digital audio files: Channel, Interpolate, and Replace. These tools are located in the Repair submenu of the Tools menu. For more information, see Finding and repairing audio glitches on page 192.

Bit-Depth Converter

The expanded bit-depth support of Sound Forge renders the previous Convert to 8-Bit function obsolete. Decreasing (or increasing) the bit-depth of a file as well as masking the resulting quantization noise is now accomplished using the new Bit-Depth Converter function located in the Process menu. For more information, see Bit-Depth Converter on page 215.

MP3 Plug-In

An MP3 plug-in is available to users of Sound Forge from the Save As dialog. If you are using Sound Forge XP, you will be limited to 20 free encodes with the MP3 plug-in until you register your product. Once you register Sound Forge XP, you will have unlimited use of the plug-in.

Sonic Foundry Perfect Clarity Audio (.pca) format

Sound Forge now supports Sonic Foundry's Perfect Clarity Audio™ (.pca) format. This format compresses files without the audio degradation that typically results from compression/decompression algorithms. Because of this, files saved in this format can be endlessly re-edited without signal degradation. In addition, the Perfect Clarity Audio codec will typically render audio files 20% to 60% smaller than the original.

New registration procedure

Registering Sound Forge is now easier and requires less user input.
This chapter contains information on configuring your system to optimize the performance of Sound Forge.

**Hard drive defragmentation**

Sound Forge is a disk-based digital audio editor that allows editing operations to be performed on the system's hard drive rather than in memory. Because of this, Sound Forge is able to edit large files as well as retain extensive undo/redo information and clipboard data. This also means that the hard drive specified for temporary storage must have sufficient free space to store large quantities of data.

With time and usage, hard drives become fragmented, leading to discontiguous files and slow access. This is particularly true for older hard drives. Since Sound Forge is hard drive intensive, faster disk access equates better performance. Therefore, the initial step in improving system performance is hard drive defragmentation. The computer's operating system is typically equipped with a defragmenting program that should be run prior to using Sound Forge for the first time.
Windows 9x/Me default settings

System configuration settings deviating from Windows 98/Me defaults may result in reduced performance from Sound Forge.

1. From the Start menu, choose Settings, and then choose Control Panel from the submenu.
2. Double-click the System icon. The System Properties dialog is displayed.
3. Click the Performance tab and verify that File System and Virtual Memory are set to 32-bit.
4. In the Advanced settings window, click the File System button. The File System Properties dialog is displayed.
5. Click the Hard Disk tab and verify that the Read-ahead optimization slider is set to Full.
6. Click the Troubleshooting tab and verify that all check boxes are cleared.
7. Click OK to return to the System Properties dialog.
8. Click the Graphics button in the Advanced settings window. The Advanced Graphics Settings dialog is displayed.
9. Verify that the Hardware acceleration slider is set to Full and click OK.

Note: If dropouts are detected in playback, experiment with different Hardware acceleration settings.

Direct mode

When you open a file in Sound Forge, a backup copy is created to preserve the original file until it is resaved. However, you have the option of opening files in direct mode, which will open an audio file without creating a backup copy. If the application's defaults are active, the waveform of a file opened in direct mode will be colored red (normal mode waveforms are blue).

Direct mode makes opening files quicker and requires less disk space, but there are drawbacks. Only files stored in the uncompressed .wav or .aiff format can be opened in direct mode. In addition, since no backup file is created, only the modified file remains if the application is suddenly terminated.
Opening a file in direct mode

1. From the File menu, choose Open. The Open dialog is displayed.
2. Select a .wav or .aiff file.
3. Select the Operate directly on the file check box and click Open.

**Note:** Once the Operate directly on the file check box is selected, all subsequent applicable files are opened in direct mode. To disable direct mode, clear the Operate directly on the file check box.

Peak files

When a file is initially opened in direct mode, Sound Forge scans the entire file and creates a peak file. The peak file is stored with the same name and in the same location as the .wav file, but it is given an .sfk extension. Sound Forge automatically updates this peak file whenever the original file is edited.

If a file is modified in an application other than Sound Forge, the peak file should be regenerated by choosing Rebuild Peak Data from the Special menu.

Faster file saving

When a new file is created, Sound Forge automatically creates a temporary file containing the new audio data. When the file is saved, Sound Forge copies this temporary data to the file. If the audio data is saved as an uncompressed .wav file, Sound Forge can accelerate this saving process by physically moving the temporary data to the file, instead of copying it. To accommodate this, the new file must be saved on the same drive as the temporary storage folder. This may require you to relocate the temporary storage folder.

Relocating the temporary storage folder

1. From the Options menu, choose Preferences. The Preferences dialog is displayed.
2. Click the Perform tab.
3. Click the Browse button and browse to the new temporary storage folder location.
4. Click OK.
The Sound Mapper

Sound Forge allows you to specify any installed Windows-compatible sound card for playback and recording. In addition, you can specify the Sound Mapper. The Sound Mapper will automatically select the appropriate sound card for playing audio. If this is not possible, the Sound Mapper converts the audio into a usable format.

Preventing audio breakup

Be aware that Sound Mapper format conversions occasionally introduce overhead which may lead to audio signal breakup. To prevent this, do either of the following:

- Verify that the system’s sound card supports the selected format.
- Specify playback/record devices other than the Sound Mapper whenever possible.

**Note:** If the application is able to play and record audio using the actual sound card’s wave driver, the Sound Mapper is not causing signal breakups.

If the Sound Mapper is the only option and signal breakups are detected, convert the audio to a format directly supported by the system's sound card. This will remove the overhead required to convert the audio data for the sound card.

It is also acceptable to use the Sound Mapper when the audio data format is directly supported by the sound card. In this case, the Sound Mapper passes the data to the sound card, which requires negligible overhead.

For more information, see Microsoft Audio Compression Manager on page 355.

Total Buffer Size

The total buffer size value determines the amount of RAM used for recording to/playing from the hard drive. A total buffer size of 512kb is recommended, but increased buffering may be necessary if gaps are detected during playback.

**Drawbacks to increasing the buffer size**

Increasing the total buffer size requires additional memory. Combined with a large preload size, this may result in a delay when starting and stopping playback. For more information, see Preload Size on page 33.
Editing the total buffer size

1. From the Options menu, choose Preferences. The Preferences dialog is displayed.
2. Click the Wave tab.
3. Use the Total buffer size slider to configure an appropriate buffer size value and click OK.

Preload Size

The preload size value determines how much sound data Sound Forge prepares and loads into the sound card driver prior to starting playback. Preloading is performed between the time the Play ( ) button is clicked and the first sound of playback.

Increasing preload size may eliminate the dropouts evident at the beginning of playback that are characteristic of slow and/or fragmented hard drives. The trade-off for increasing the preload size is a delay prior to the start of playback. The length of the delay is proportional to the size of the preload.

Changing the preload size

1. From the Options menu, choose Preferences. The Preferences dialog is displayed.
2. Click the Wave tab.
3. Use the Preload size slider to configure an appropriate preload size value and click OK.

Note: Certain Windows sound drivers do not support this option. If noise or dropouts are detected at the start of playback and the system’s sound drivers do not support preloading, disable this option by setting the Preload size to 0.

Forced Write-Through During Record (Windows 9x and Me only)

When using a Windows 9x or Me operating system, Sound Forge implements a forced write-through during recording option. This lessens the occurrence of dropouts, but results in an overactive hard drive.
Disabling Forced Write-Through During Record

1. From the Options menus, choose Preferences. The Preferences dialog is displayed.
2. Click the General tab.
3. Clear the Forced write-through on record check box and click OK.

Note: Disabling this feature is not recommended.

Playback cursor and record counter

The playback cursor and record counter options determine whether these displays are updated during recording and playback. If dropouts and skipping are detected at high sample rates (greater than 44,100 Hz), these displays should be turned off to minimize processing overhead.

Turning off the playback cursor and record counter

1. From the Options menus, choose Preferences. The Preferences dialog is displayed.
2. Click the Perform tab.
3. Clear the Show the position of the playback cursor and Show the record counter while recording check boxes and click OK.

Meters

Sound Forge's play and record meters use a small amount of processing overhead during recording and playback. However, if dropouts are detected during recording or playback and previous fixes have failed, these meters can be turned off.

Turning off the play (output) meters

Choose Play Meters from View menu. The check mark adjacent to the command is cleared, indicating that the play meters are turned off.

Turning off the record meters

1. From the Special menu, choose Record. The Record dialog is displayed.
2. Clear the Monitor check box and click OK.
Passive updating for video and time displays

Passive update options lower the priority of repainting the video and time displays during playback. When these options are enabled, the displays are updated only if there is ample time. Frequently this goes unnoticed, and enabling these options minimizes playback overhead with little or no inconvenience.

Enable passively updated time displays

From the Options menu, choose Time Display, and choose Passive Update from the submenu. A check mark is displayed next to the command to indicate that this option is enabled.

Enable passively updated video displays

Go to the Options menu, choose Video, and choose Passive Update from the submenu. A check mark is displayed next to the command to indicate that this option is enabled.

Scan for external monitor

Sound Forge allows .avi files to be viewed on an external video monitor. By default, the application scans for an external video monitor each time an .avi is opened. This feature should be turned off if the system is not equipped with an external video monitor.

Turning off scan for external monitor

1. From the Options menus, choose Preferences. The Preferences dialog is displayed.
2. Click the Video tab.
3. Select the Disable scan for External Monitor support check box and click OK.

Background processing

When Sound Forge is performing extensive editing or processing operations, a progress meter is displayed in the bottom-left corner of the status bar. If the progress meter is visible, Sound Forge is processing and the current operation can be cancelled by clicking the Cancel button or pressing Esc.

Running multiple applications

All processing performed by Sound Forge is done in the background. This means that other applications can be used while Sound Forge is working. However, using additional applications while editing digital audio may negatively affect processing time.
This chapter provides a detailed overview of the application's toolbars and controls.

### Using the mouse

The following table defines the mouse-related terms used throughout this manual.

<table>
<thead>
<tr>
<th>Term</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pointing</td>
<td>Moving the mouse pointer over an item.</td>
</tr>
<tr>
<td>Clicking</td>
<td>Pointing to an item and quickly pressing and releasing the left mouse button. If there is no left or right specification, left-clicking is implied.</td>
</tr>
<tr>
<td>Right-clicking</td>
<td>Pointing to an item and quickly pressing and releasing the right mouse button. Right-clicking is frequently used to display shortcut menus.</td>
</tr>
<tr>
<td>Double-clicking</td>
<td>Identical to clicking, but instead of pressing and releasing the mouse button once, it is done twice in quick succession. Double-clicking always indicates the left mouse button.</td>
</tr>
<tr>
<td>Triple-clicking</td>
<td>Identical to clicking, but instead of pressing and releasing the mouse button once, it is done three times in quick succession. Triple-clicking always indicates the left mouse button.</td>
</tr>
<tr>
<td>Toggle-clicking</td>
<td>Clicking the right mouse button while holding down the left mouse button. This is used to toggle options and is a shortcut for drag and drop editing and specifying the Magnify tool's mode.</td>
</tr>
<tr>
<td>Shift-clicking</td>
<td>Holding down the Shift key on the keyboard while clicking the mouse. Shift-clicking is typically used to skip dialogs and quickly repeat operations.</td>
</tr>
<tr>
<td>Ctrl-clicking</td>
<td>Holding down the Ctrl key on the keyboard while clicking the mouse. Ctrl-clicking is used to modify the operation of a normal click.</td>
</tr>
<tr>
<td>Dragging</td>
<td>Holding down the left mouse button while moving the mouse pointer. Dragging is used to quickly move sections of data between windows, as well as to adjust sliders, scrollbars, and faders.</td>
</tr>
<tr>
<td>Slow-dragging</td>
<td>Holding down the right and left mouse buttons while adjusting sliders and faders increases the resolution of the movement. This is useful when making fractional adjustments to parameters.</td>
</tr>
<tr>
<td>Dropping</td>
<td>After dragging an item, releasing the left mouse button on top of another area is known as dropping. Dragging and dropping are used to speed up operations such as mixing or moving regions within the Playlist.</td>
</tr>
</tbody>
</table>
Note: Once familiar with the application’s basics, you may want to begin using the shortcuts provided by the mouse and keyboard. For more information, see Shortcuts on page 347.

Using the mousewheel

Sound Forge now allows you to use your mousewheel to navigate audio files. The following table briefly describes the available mousewheel functionality.

<table>
<thead>
<tr>
<th>Action</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Wheel Up</td>
<td>Zoom in (horizontal)</td>
</tr>
<tr>
<td>Wheel Down</td>
<td>Zoom out (horizontal)</td>
</tr>
<tr>
<td>Ctrl+Wheel Up</td>
<td>Zoom in (vertical)</td>
</tr>
<tr>
<td>Ctrl+Wheel Down</td>
<td>Zoom out (vertical)</td>
</tr>
<tr>
<td>Shift+Wheel Up</td>
<td>Scroll left (in 10ths of screen width)</td>
</tr>
<tr>
<td>Shift+Wheel Down</td>
<td>Scroll right (in 10ths of screen width)</td>
</tr>
<tr>
<td>Ctrl+Shift+ Wheel Up</td>
<td>Cursor left or current selection point left (if there is a selection)</td>
</tr>
<tr>
<td>Ctrl+Shift+ Wheel Down</td>
<td>Cursor right or current selection point right (if there is a selection)</td>
</tr>
</tbody>
</table>
The main screen

When you start Sound Forge, the main screen is displayed. The main screen's workspace is where all audio editing is performed.
Main screen components

The following table describes the major components of the main screen.

<table>
<thead>
<tr>
<th>Component</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Menu bar</td>
<td>Displays the menu headings for the available functions. When no data windows are open, the Process, Effects, and Tools menus are not available because these menus contain commands that require an open data window.</td>
</tr>
<tr>
<td>Status bar</td>
<td>Help and processing information is displayed on the left-hand side. The fields on the right-hand side display the playback sample rate, bit depth, channel configuration (mono/stereo), length of the active data window, and total free storage space. With the exception of the free storage space field, these fields can be edited by double-clicking or right-clicking them. When no data windows are open, only the free storage space field contains a value.</td>
</tr>
<tr>
<td>Workspace</td>
<td>This is the area located behind the data windows. Sections dragged to the workspace automatically become new data windows.</td>
</tr>
<tr>
<td>Play meters</td>
<td>Display the level of the output audio signal. These meters can be toggled on/off by choosing Play Meters from the View menu. Right-clicking the play meters displays a shortcut menu that allows you to precisely configure the appearance of the meters.</td>
</tr>
</tbody>
</table>

The data window

Data windows contain audio data (as a waveform) as well as a number of controls and commands used to edit and process audio.
# Data window components

The following table describes the data window components:

<table>
<thead>
<tr>
<th>Component</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Title Bar</td>
<td>Displays the file name. If a title information is included in the summary of a .wav file, it is displayed here instead of the file name. Double-click to maximize and restore the window.</td>
</tr>
<tr>
<td>Level Ruler</td>
<td>Displays the amplitude of the waveform. Right-click to display the level ruler shortcut menu. Drag to shift the view up/down when zoomed in vertically.</td>
</tr>
<tr>
<td>Time Ruler</td>
<td>Displays the current location in the data window as well as ruler tags. Right-click to display the time ruler shortcut menu. Drag to scroll the data window.</td>
</tr>
<tr>
<td>Ruler Tags</td>
<td>Indicate the position of region end points, loop end points, and markers. Right-click a tag to display the ruler tag shortcut menu. Drag to edit a tag's position. Double-click anywhere within a region to select it.</td>
</tr>
<tr>
<td>Edit Tool Selector</td>
<td>Toggles through the Edit, Magnify, and Pencil tools. The Pencil tool requires a zoom ratio between 1:1 and 1:16 to be used.</td>
</tr>
<tr>
<td>Playbar</td>
<td>Contains the following audio transport buttons: Go to Start, Go to End, Stop, Play Normal, Play Loop, and Play as Sample.</td>
</tr>
<tr>
<td>Selection Status Fields</td>
<td>Display the beginning, end, and length of a selection. If no selection exists, only the cursor position is displayed. Double-click on the left-most field to display the Go To dialog. Double-click on either of the other two fields to display the Set Selection dialog. Right-click to display the status format shortcut menu.</td>
</tr>
<tr>
<td>Waveform Display</td>
<td>Displays a graphical representation of an audio file. The horizontal axis represents time, and the vertical axis represents amplitude. Right-click within this display to access the waveform display shortcut menu.</td>
</tr>
<tr>
<td>Position Scroll Bar</td>
<td>Scrolls forward/backward through an audio file to display sections of the file not visible in the current area of the waveform display.</td>
</tr>
<tr>
<td>Overview</td>
<td>Allows for quick navigation and playback of any part of an audio file. The overview also indicates the portion of the waveform currently depicted in the waveform display, as well as the selected region. Click to move the cursor. Double-click to center the cursor in the waveform display. Right-click to start or pause playback. Drag to activate the audio event locator.</td>
</tr>
<tr>
<td>Time Zoom Resolution</td>
<td>Specifies the number of samples of data represented by each horizontal point on the screen. This determines the length of time displayed in the data window. Smaller resolution values (1:1, 1:2, 1:4) will display less time.</td>
</tr>
<tr>
<td>Time Zoom In/Out</td>
<td>Changes the zoom resolution for the time (horizontal) axis.</td>
</tr>
<tr>
<td>Level Zoom In/Out</td>
<td>Changes the zoom resolution for the level (vertical) axis.</td>
</tr>
<tr>
<td>Maximize Width</td>
<td>Resizes the data window to maximize its size within the workspace.</td>
</tr>
<tr>
<td>OLE Drag Source</td>
<td>Drag from this section of the data window into another application such as Microsoft Word to link an audio file to a document.</td>
</tr>
</tbody>
</table>
Displaying data window components

Sound Forge allows you to customize the appearance of individual data windows.

1. Choose Properties from the File menu or press **Alt+Enter**. The current file's Properties dialog is displayed.

2. Click the Display tab.

3. Display/hide specific components by selecting/clearing the corresponding check box(es).

4. Select the Save as default for all new windows check box if you want to set the new configuration as the default data window display.

5. Click OK.

The Playbar

The Playbar is located in the bottom left-hand corner of a data window and contains six buttons. Using the Playbar, audio files can be navigated and played in a variety of ways.

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Go to Start</strong></td>
<td>Moves the cursor to the start of the audio file. If there is no selection, audio is played from the cursor to end of the file. If there is a selection, audio is played from the beginning of the selection to the end of the selection.</td>
</tr>
<tr>
<td><strong>Go to End</strong></td>
<td>Moves the cursor to the end of the audio file. If there is no selection, the entire audio file is played in an infinite loop. If there is a selection, the selection is played in an infinite loop.</td>
</tr>
<tr>
<td><strong>Stop</strong></td>
<td>Stops playback and returns the cursor to its position prior to playback. The file is played with the sustaining and release loops repeating the specified number of times.</td>
</tr>
<tr>
<td><strong>Play Normal</strong></td>
<td>Play as Sample or Cutlist</td>
</tr>
</tbody>
</table>
Current playback mode

When an audio file is played from the Playbar, a small horizontal line is displayed beneath the selected Play button's icon ( mù). This indicates Sound Forge's current playback mode, which is the mode used when the Transport toolbar's Play ( mù) button is clicked. For more information, see The Transport toolbar on page 46.

Changing the current playback mode

To change the current play mode, click a Playbar button or press Ctrl + Space.

Toolbars

Sound Forge's toolbars contain buttons used to quickly execute many of the program's commands and functions. Toolbars can be dragged throughout the workspace, docked, resized, and hidden.

Docking a toolbar

When a floating toolbar is dragged to any edge of the main screen, it docks on that edge.

Floating a toolbar

When a docked toolbar is dragged away from an edge, it becomes a floating toolbar.
Available toolbars

1. Choose Preferences from the Options menu. The Preferences dialog is displayed.
2. Click the Toolbars tab. A list of available toolbars is displayed.

Displaying a toolbar

To display a toolbar, select the corresponding check box and click OK.
The Standard toolbar

The Standard toolbar is displayed by default when Sound Forge is started. It contains buttons that allow you to quickly access and execute many common application commands.
The following table briefly describes each Standard toolbar button.

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Create Data Window" /></td>
<td>Creates a new data window.</td>
</tr>
<tr>
<td><img src="image" alt="Play" /></td>
<td>Plays the audio on the clipboard.</td>
</tr>
<tr>
<td><img src="image" alt="Display Open Dialog" /></td>
<td>Displays the Open dialog.</td>
</tr>
<tr>
<td><img src="image" alt="Remove Unselected Data" /></td>
<td>Removes all data from the audio file that is not currently selected. This command has no effect if there is no selected data. This command does not copy data to the clipboard.</td>
</tr>
<tr>
<td><img src="image" alt="Save Current Audio" /></td>
<td>Saves the current audio data.</td>
</tr>
<tr>
<td><img src="image" alt="Save Current File" /></td>
<td>Reverses the last edit operation.</td>
</tr>
<tr>
<td><img src="image" alt="Remove Selection" /></td>
<td>Removes selected audio data and places it on the clipboard. This command has no effect if there is no selection.</td>
</tr>
<tr>
<td><img src="image" alt="Re-Perform Undo" /></td>
<td>Re-performs the previously undone edit operation.</td>
</tr>
<tr>
<td><img src="image" alt="Copy Selection" /></td>
<td>Copies selected audio data to the clipboard. This command has no effect if there is no selection.</td>
</tr>
<tr>
<td><img src="image" alt="Select Editing Tool" /></td>
<td>Selects the Editing tool.</td>
</tr>
<tr>
<td><img src="image" alt="Insert Clipboard Data" /></td>
<td>Inserts a copy of the clipboard data at the current insertion point. If there is a selection, this command replaces the selected data with the clipboard data.</td>
</tr>
<tr>
<td><img src="image" alt="Select Zoom Tool" /></td>
<td>Selects the Zoom tool.</td>
</tr>
<tr>
<td><img src="image" alt="Mix Clipboard Data" /></td>
<td>Mixes a copy of the clipboard data with the current audio file. The mix start point is either the cursor point or the start or end of the selection in the destination data window.</td>
</tr>
<tr>
<td><img src="image" alt="Select Pencil Tool" /></td>
<td>Selects the Pencil tool. The Pencil tool can only be used when viewing an audio file at zoom ratios between 1:1 and 1:16.</td>
</tr>
</tbody>
</table>

**The Transport toolbar**

The Transport toolbar is also displayed by default and contains basic audio transport buttons.
The following table briefly describes the Transport toolbar buttons.

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>🎧</td>
<td>Records data to a new or existing data window.</td>
</tr>
<tr>
<td>🔊</td>
<td>Plays the entire audio file from beginning to end, regardless of cursor position, selection, or playlist.</td>
</tr>
<tr>
<td>🔽</td>
<td>Moves the cursor to the start of the file.</td>
</tr>
<tr>
<td>🔽</td>
<td>Plays the file in current playback mode (Normal, Looped, or Sample).</td>
</tr>
<tr>
<td>🔽</td>
<td>Moves the cursor backwards, take by take, in the current audio file.</td>
</tr>
<tr>
<td>🔽</td>
<td>Pauses playback and maintains the cursor at its current position.</td>
</tr>
<tr>
<td>🔽</td>
<td>Plays the file in current playback mode (Normal, Looped, or Sample).</td>
</tr>
<tr>
<td>🔽</td>
<td>Moves the cursor forward, take by take, in the current audio file.</td>
</tr>
<tr>
<td>🔽</td>
<td>Moves the cursor to the end of the file.</td>
</tr>
<tr>
<td>🔽</td>
<td>Stops playback and returns the cursor to its prior position.</td>
</tr>
</tbody>
</table>

### Navigation toolbar

The Navigation toolbar contains buttons used to navigate within the current data window.
The following table briefly describes the Navigation toolbar buttons.

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Magnify" /></td>
<td>Magnifies the selected area to a 1:1 ratio.</td>
</tr>
<tr>
<td><img src="image" alt="Center" /></td>
<td>Centers the display with the cursor displayed in the center of the data window.</td>
</tr>
<tr>
<td><img src="image" alt="Reset" /></td>
<td>Resets the audio data to its original magnification.</td>
</tr>
<tr>
<td><img src="image" alt="Maximize" /></td>
<td>Moves the cursor to the beginning of the selection.</td>
</tr>
<tr>
<td><img src="image" alt="Drop" /></td>
<td>Maximizes the selection vertically and horizontally.</td>
</tr>
<tr>
<td><img src="image" alt="Move In" /></td>
<td>Moves the cursor to the end of the selection.</td>
</tr>
<tr>
<td><img src="image" alt="In" /></td>
<td>Drops a marker at the current cursor position.</td>
</tr>
<tr>
<td><img src="image" alt="Move Out" /></td>
<td>Moves the cursor to the beginning of the sustaining loop.</td>
</tr>
<tr>
<td><img src="image" alt="Out" /></td>
<td>Marks the “in” point of a new selection.</td>
</tr>
<tr>
<td><img src="image" alt="Mark" /></td>
<td>Moves the cursor to the end of the sustaining loop.</td>
</tr>
<tr>
<td><img src="image" alt="Deselect" /></td>
<td>Marks the “out” point of a new selection.</td>
</tr>
<tr>
<td><img src="image" alt="Display" /></td>
<td>Moves the cursor to the beginning of the release loop.</td>
</tr>
<tr>
<td><img src="image" alt="Set View" /></td>
<td>Displays the Go To dialog and allows you to quickly move the cursor to a specific point in a file.</td>
</tr>
<tr>
<td><img src="image" alt="Move Out" /></td>
<td>Moves the cursor to the end of the release loop.</td>
</tr>
</tbody>
</table>

### Views toolbar

The Views toolbar contains buttons used to store and retrieve data window views.

<table>
<thead>
<tr>
<th>Set View #</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Set" /></td>
<td>Toggles views 1-8 between setting and restoring.</td>
</tr>
<tr>
<td><img src="image" alt="Store" /></td>
<td>Stores and recalls specific selection views.</td>
</tr>
</tbody>
</table>

---

CHP. 4  CONTROLS
Status/Selection toolbar

The Status/Selection toolbar contains buttons used to specify the file’s status format and perform the application’s Snap To functions.

The following table briefly describes the Status/Selection toolbar buttons:

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Samples" /></td>
<td>Changes the status format to samples.</td>
</tr>
<tr>
<td><img src="image" alt="Time" /></td>
<td>Changes the status format to time.</td>
</tr>
<tr>
<td><img src="image" alt="Frames" /></td>
<td>Changes the status format to frames.</td>
</tr>
<tr>
<td><img src="image" alt="Measures &amp; Beats" /></td>
<td>Changes the status format to measures:beats:quarter notes.</td>
</tr>
<tr>
<td><img src="image" alt="SMPTE" /></td>
<td>Changes the status format to SMPTE.</td>
</tr>
<tr>
<td><img src="image" alt="AutoSnap to Time" /></td>
<td>Aligns selections to the nearest zero-crossing as defined by the Editing tab of the Preferences dialog.</td>
</tr>
<tr>
<td><img src="image" alt="AutoSnap to Zero" /></td>
<td>Aligns selections to the nearest whole time division.</td>
</tr>
</tbody>
</table>
Regions/Playlist toolbar

The Regions/Playlist toolbar contains Regions List and Playlist buttons as well as buttons corresponding to synchronization commands and status displays.

The following table briefly describes the Regions/Playlist toolbar buttons.

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Regions List" /></td>
<td>Displays the Regions List.</td>
</tr>
<tr>
<td><img src="image" alt="Playlist" /></td>
<td>Displays the Playlist.</td>
</tr>
<tr>
<td><img src="image" alt="MIDI Input Sync/Trigger" /></td>
<td>Configures Sound Forge to be triggered by MIDI commands received through the MIDI input port. The MIDI input port is specified on the MIDI/Sync tab in the Preferences dialog.</td>
</tr>
<tr>
<td><img src="image" alt="MIDI Output Sync" /></td>
<td>Configures Sound Forge to send MIDI time code through the MIDI output port. The MIDI output port is specified on the MIDI/Sync tab of the Preferences dialog.</td>
</tr>
</tbody>
</table>

Playlist position display

Displays the current playback position of an audio file being played from the Playlist. Right-clicking on this field displays a shortcut menu that allows you to specify a new format.

Sync status display

Allows you to monitor the status of incoming/outgoing MIDI commands.
Process toolbar

The Process toolbar contains buttons corresponding to all commands located in the application's **Process** menu.

- Auto Trim
- Channel
- EQ-Graphic
- EQ-Parametric
- EQ-Paragraphic
- Bit-Depth Converter
- DC Offset
- Mute
- Normalize
- Invert
- Insert Silence
- Fade Out
- Fade In
- EQ-Graphic
- EQ-Paragraphic
- EQ-Parametric
- Resample
- Reverse
- Smooth/Enhance
- Time Compress/Expand
- Volume
The following table briefly describes the Process toolbar buttons.

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1" alt="Icon" /></td>
<td>Removes silence from an audio file and automatically fades in/out the end-points of each phrase.</td>
</tr>
<tr>
<td><img src="image2" alt="Icon" /></td>
<td>Inserts user-configurable silence into audio files.</td>
</tr>
<tr>
<td><img src="image3" alt="Icon" /></td>
<td>Converts between mono and stereo formats. Can also be used to intermix the left and right channels of a stereo file to create panning effects.</td>
</tr>
<tr>
<td><img src="image4" alt="Icon" /></td>
<td>Inverts (or flips) the current selection.</td>
</tr>
<tr>
<td><img src="image5" alt="Icon" /></td>
<td>Converts a file to a lower bit depth.</td>
</tr>
<tr>
<td><img src="image6" alt="Icon" /></td>
<td>Mutes the current selection.</td>
</tr>
<tr>
<td><img src="image7" alt="Icon" /></td>
<td>Changes the baseline of an audio file.</td>
</tr>
<tr>
<td><img src="image8" alt="Icon" /></td>
<td>Normalizes the loudness of an audio file.</td>
</tr>
<tr>
<td><img src="image9" alt="Icon" /></td>
<td>Launches Sonic Foundry's XFX Graphic EQ.</td>
</tr>
<tr>
<td><img src="image10" alt="Icon" /></td>
<td>Creates custom pans, expands, and mixes.</td>
</tr>
<tr>
<td><img src="image11" alt="Icon" /></td>
<td>Launches Sonic Foundry's XFX Paragraphic EQ.</td>
</tr>
<tr>
<td><img src="image12" alt="Icon" /></td>
<td>Creates a copy of the audio file with a new sample rate.</td>
</tr>
<tr>
<td><img src="image13" alt="Icon" /></td>
<td>Launches Sonic Foundry's XFX Parametric EQ.</td>
</tr>
<tr>
<td><img src="image14" alt="Icon" /></td>
<td>Reverses the current selection.</td>
</tr>
<tr>
<td><img src="image15" alt="Icon" /></td>
<td>Creates user-configurable fades.</td>
</tr>
<tr>
<td><img src="image16" alt="Icon" /></td>
<td>Launches Sonic Foundry's XFX Smooth/Enhance tool.</td>
</tr>
<tr>
<td><img src="image17" alt="Icon" /></td>
<td>Fades-in the selection.</td>
</tr>
<tr>
<td><img src="image18" alt="Icon" /></td>
<td>Launches Sonic Foundry's XFX Time Compress/Expand tool.</td>
</tr>
<tr>
<td><img src="image19" alt="Icon" /></td>
<td>Fades-out the selection.</td>
</tr>
<tr>
<td><img src="image20" alt="Icon" /></td>
<td>Adjusts the volume of an audio file.</td>
</tr>
</tbody>
</table>
The Effects toolbar

If you are using a full version of Sound Forge, the Effects toolbar contains buttons corresponding to all Sound Forge’s built-in XFX.
The following table briefly describes the Effects toolbar buttons.

| ![icon]  | Applies a sinusoidal or square shaped periodic gain to the input signal. |
| ![icon]  | Simulates multiple audio sources from a single sound. |
| ![icon]  | Creates a delay with up to eight delay-taps spaced anywhere within 2.5 seconds of the original sound. |
| ![icon]  | Adds a delayed copy of the audio signal to the file. |
| ![icon]  | Simulates the overloading of an amplifier. |
| ![icon]  | Applies compression, expansion, and limiting to affect the dynamic range of an audio file. |
| ![icon]  | Allows compression and limiting to be placed on up to four different frequency bands. |
| ![icon]  | Forces the amplitude envelope of a waveform to match a specified envelope shape. |
| ![icon]  | Mixes a modulated delay signal with the original signal. |
| ![icon]  | Removes/inserts sections of silence at regular intervals to create unusual effects. This effect is only available if you are using the full version of Sound Forge. |
| ![icon]  | Removes signals below a set amplitude threshold. |
| ![icon]  | Creates a modified sound envelope that corresponds to increasing or decreasing the pitch of a sound file over time. |
| ![icon]  | Changes the pitch of a selection with or without preserving the duration of the file. |
| ![icon]  | Simulates the acoustics of different environments. |
| ![icon]  | Creates periodic pitch modulation in an audio file. |
The Tools toolbar

The Tools toolbar contains buttons corresponding to all commands in the application’s Tools menu.
The following table briefly describes the Tools toolbar buttons.

<table>
<thead>
<tr>
<th>icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1" alt="icon" /></td>
<td>Writes selected audio track to CD.</td>
</tr>
<tr>
<td><img src="image2" alt="icon" /></td>
<td>Links multiple DirectX plug-ins into a single processing chain.</td>
</tr>
<tr>
<td><img src="image3" alt="icon" /></td>
<td>Replaces selected audio data with previous adjacent data.</td>
</tr>
<tr>
<td><img src="image4" alt="icon" /></td>
<td>Allows you to transfer samples to/from Sound Forge.</td>
</tr>
<tr>
<td><img src="image5" alt="icon" /></td>
<td>Performs spectrum analysis on the current file or selection.</td>
</tr>
<tr>
<td><img src="image6" alt="icon" /></td>
<td>Displays statistics corresponding to the current file or selection.</td>
</tr>
<tr>
<td><img src="image7" alt="icon" /></td>
<td>Generates dial tones used by telephone companies.</td>
</tr>
<tr>
<td><img src="image8" alt="icon" /></td>
<td>Uses frequency modulation and additive synthesis to create complex sounds from simple waveforms.</td>
</tr>
<tr>
<td><img src="image9" alt="icon" /></td>
<td>Generates a simple waveform of a given shape, pitch, and length.</td>
</tr>
<tr>
<td><img src="image10" alt="icon" /></td>
<td>Extracts all file regions and saves them as individual files.</td>
</tr>
<tr>
<td><img src="image11" alt="icon" /></td>
<td>Searches for clicks and pops, volume levels, or silent breaks in an audio signal.</td>
</tr>
<tr>
<td><img src="image12" alt="icon" /></td>
<td>Used to back up and transfer user-configured presets from all effects, processes, tools, and plug-ins.</td>
</tr>
<tr>
<td><img src="image13" alt="icon" /></td>
<td>Replaces selected audio with a corresponding selection from the opposite channel.</td>
</tr>
<tr>
<td><img src="image14" alt="icon" /></td>
<td>Replaces selected audio with interpolated audio data based on the selection's beginning and end samples.</td>
</tr>
</tbody>
</table>

**The Levels toolbar**

The Levels toolbar displays the audio levels in the left and right channels in the user-specified format.

*For more information, see Status/Selection toolbar on page 49.*
ACID Loop Creation Tools toolbar

The ACID Loops Creation Tools toolbar contains buttons corresponding to commands used when creating audio loops for Sonic Foundry’s ACID products.

The following table briefly describes the ACID Loop Creation Tools toolbar buttons.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Edit ACID Properties" /></td>
<td>Displays the Edit ACID Properties dialog.</td>
</tr>
<tr>
<td><img src="image" alt="Shift Selection Left" /></td>
<td>Shifts the current selection to the left so the current start point becomes the end point.</td>
</tr>
<tr>
<td><img src="image" alt="Shift Selection Right" /></td>
<td>Shifts the current selection to the right so the current end point becomes the start point.</td>
</tr>
<tr>
<td><img src="image" alt="Double Selection" /></td>
<td>Doubles the size of the current selection.</td>
</tr>
<tr>
<td><img src="image" alt="Halve Selection" /></td>
<td>Divides the current selection in half.</td>
</tr>
<tr>
<td><img src="image" alt="Tempo Window" /></td>
<td>Calculates the musical tempo (beats per minute) based upon the current selection.</td>
</tr>
<tr>
<td><img src="image" alt="Toggles selection grid line display on/off" /></td>
<td>Toggles the selection grid line display on/off.</td>
</tr>
</tbody>
</table>

Tempo window

The ACID Loop Creation Tools toolbar also contains a Tempo window. This window calculates and displays the ACID project’s tempo as if the current selection represents a complete measure.

For more information, see Looping and ACID on page 306.
ToolTips

Hovering the mouse pointer over a button or status bar field for longer than one second will display a small text box adjacent to the pointer. This text, called a ToolTip, is a brief description of the button or field’s function. Using ToolTips is an effective way to quickly familiarize yourself with Sound Forge.

![Tooltip](image)

Turning off ToolTips

1. Choose Toolbars from the View menu. The Toolbar Preferences dialog is displayed.
2. Clear the Show ToolTips check box and click OK.

Command descriptions

When a button in a toolbar is clicked and held or a menu item is selected and held, a brief description of the command is displayed in the lower left-hand corner of the status bar. If you release the mouse button outside of the toolbar or menu item, the command is not executed.

Controls

A major step in mastering Sound Forge is becoming familiar with all controls used to set and adjust feature parameters, including the following:

- Faders and sliders
- Edit boxes
- Drop-down lists
- Buttons
- Radio buttons
- Check boxes
- Envelope graphs
Vertical faders and horizontal sliders

Vertical faders and horizontal sliders are frequently used to edit effect and process parameters. To use either control, drag the control's thumb to the desired position and release.

Fine-tuning fader and slider values

A fader or slider value can be fine-tuned by doing any of the following:

- Holding both mouse buttons while dragging the thumb.
- Holding `Ctrl` while dragging the thumb. For more information, see Using the mouse on page 37.
- Clicking on the hash marks incrementing the thumb's range-of-travel.

Resetting fader and trackbar values

Double-click the thumb to return the control to its default value.

Fader and slider shortcuts

There are numerous keyboard shortcuts available when using faders and sliders.

- `↑`, `↓`, `←`, and `→` change the value in small increments.
- `Page Up` and `Page Down` change the value in larger increments.
- `Home` and `End` set the control to its maximum and minimum values respectively.
Edit box spinner

Spinners are used to set edit box values.

The spinner provides three options for editing parameter values:
- Click in the edit box and enter a numeric value from the keyboard.
- Click the small arrow buttons to increment the value.
- Use the spinner to set the value.

Using the spinner

The spinner is the small rectangular button positioned between the control's arrow buttons.

1. Click and hold the spinner.
2. Drag the mouse up/down to increase/decrease the value.
3. Release the mouse button to set the value.

Fine-tuning spinner values

Spinner values can be fine-tuned by doing either of the following:
- Holding the both mouse buttons while dragging the spinner.
- Holding `Ctrl` while dragging the spinner. For more information, see Using the mouse on page 37.

Spinner shortcuts

Keyboard shortcuts are also available when using spinners.
- `↑` and `↓` change the value in small increments.
- `[Page Up]` and `[Page Down]` change the value in larger increments.
Drop-down lists

Drop-down lists typically contain presets. In addition, you can save custom settings as presets and they will appear in drop-down lists. For more information, see Presets on page 207.

Specifying a preset from a drop-down list
To specify a preset from a drop-down list, click on the list's arrow button and select an item from the list.

Navigating a drop-down list
The scroll bar and the arrow keys are used to navigate lengthy drop-down lists. Notice that while scrolling through presets, the dialog's controls are positioned to reflect the parameters of the current selection. This is useful for getting a feel for how various parameters are used to create specific effects.

Radio buttons
Radio buttons appear in groups of two or more and function like the station selector on a car radio; select one and all others are deselected.

Check boxes
A check box, as the name implies, is a square box that can be selected or cleared to turn a feature on/off.
Envelope graphs

Envelope graphs are used to configure the shape of frequency or amplitude envelopes applied to audio waveforms.

Understanding the envelope graph

To use the envelope graph, you must first understand what it represents. In the previous example, the horizontal axis represents time, with the left-most point representing the start of the selection and the right-most point representing the end of the selection. The vertical axis represents either amplitude or frequency, depending upon the operation.

Moving an envelope point

1. Click an envelope point.
2. Drag the point to a new position.
3. Release the mouse button. The point is repositioned and the envelope is adjusted accordingly.
Moving multiple envelope points

1. Click in an unused area of the envelope graph.

2. Drag the mouse to create a selection box containing all points to be moved.

3. Release the button. The selected envelope points are displayed in red.

4. Click any of the selected envelope points. The pointer is displayed as a multi-directional arrow.

5. Drag the envelope point to the desired position. All selected points are moved accordingly.

6. Release the mouse button. The entire envelope graph is adjusted accordingly.

Selecting all envelope points

Press \texttt{Ctrl+A} to select all envelope points.

Adding an envelope point

1. Place the mouse pointer on the envelope. The pointer is displayed as \textbullet.

2. Click the mouse. A point is added to the envelope graph and can now be positioned as needed. \textit{For more information, see Moving an envelope point on page 62.}
Deleting an envelope point

1. Place the pointer on the point to be deleted. The cursor is displayed as 

2. Double-click or right-click the mouse. The point is deleted and the envelope is adjusted accordingly.

Delete all points

Delete all envelope points by clicking the **Reset Envelope** button.

Displaying the waveform on an envelope graph

Certain envelope graphs (such as in the Graphic Fade dialog) allow you to view the audio waveform on the graph. If the selection is small, the waveform is automatically displayed. Otherwise, selecting the **Show wave** check box will display the waveform.

Displaying stereo waveforms

The **Show Wave** drop-down list allows you to specify how stereo files are displayed in the envelope graph.

Stereo files

Stereo files require you to work with two channels of data. When a stereo file is displayed in a data window, the left channel is represented in the upper data window and the right channel in the lower.
Working with stereo files

When playing, editing, or processing stereo files, you are able to select the left channel, the right channel, or both channels. However, certain processing cannot be performed upon an individual channel of a stereo file. For more information, see Single-channel editing on page 67.

Selecting data in stereo files

When editing a stereo file, the waveform display is divided into three logical sections and the mouse pointer location determines what channel (or channels) will be selected.

- The upper quarter of the data window selects the left channel.
- The lower quarter of the data window selects the right channel.
- The middle half of the data window selects both channels.

1. Open a stereo .wav file.
2. Select the Edit tool by choosing Tool from the Edit menu and Edit from the submenu.
3. Position the tool near the top of the left channel and notice its appearance. The tool is displayed as $\text{Cursor to select the left channel only}$. This indicates that only audio data in the left channel will be selected.

4. Position the tool in the middle portion of the data window and notice its appearance. The tool is displayed as a standard cursor. This indicates that it will select a mono file or both channels of a stereo file.

5. Position the tool near the bottom of the right channel and notice its appearance. The tool is displayed as $\text{Cursor to select the right channel only}$. This indicates that only audio data in the right channel will be selected.
**Toggling channel selections**

Once the cursor is placed or a selection created in a stereo file, you can cycle through channel options (left, right, both) by pressing Tab.

**Previewing channels**

The single channel selection option allows you to preview channels in a stereo file individually.

1. Open a stereo .wav file and select all data.
2. Click Play. The file is played in stereo.
3. Press Tab. The left channel is selected.
4. Click Play. Only the mono left channel is played.
5. Press Tab. The right channel is selected.
6. Click Play. Only the mono right channel is played.

**Single-channel editing**

Stereo files are held together by the nature of their stereo format. Because of this, certain editing operations (such as Cut or Paste) cannot be performed on a single channel of a stereo file. Attempting to alter the duration of a single channel of a stereo file will result in an error message.

Channel lengths must remain equal in stereo files. Frequently, this issue can be “side-stepped” by copying a single channel of a stereo file to the clipboard. Once this mono selection is located on the clipboard, you can do any of the following:

- Paste it into a mono file.
- Paste it in both channels of a stereo file.
- Mix it into a single channel of a stereo file.
- Mix it into both channels of a stereo file.

---

**Note:** When mixing mono clipboard data to a stereo file, the Mono to Stereo dialog prompts you to mix it to the right, left, or both channels.
Getting Help within Sound Forge

You are able to access two varieties of help within Sound Forge:

- Online help
- What’s This? help (also referred to as context-sensitive help)

Online Help

To view online help, Internet Explorer 4.0 or later must be installed on your system.

Accessing Online Help

To access online help, choose Contents from the Help menu.

To access online help, press F1.

Help Topics dialog

The Sound Forge online help dialog contains four tabs used to locate information within Online Help: Contents, Index, Search, and Favorites.

The Contents tab

The Contents tab provides a categorized listing of available Help topics.
Using the Contents tab
To use the Contents tab to browse for information:

1. Double-click the book (ं) to be browsed. The topic pages appropriate to the selected book are displayed.

2. Select the topic page (ः) corresponding to the desired information. The topic page is displayed in the information pane.

The Index tab
The Index tab provides a complete listing of available help topics.

Using the Index tab
1. Scroll through the list of available index entries or enter a word in the Type in the keyword to find edit box.

2. Select an index entry and click Display. The topic is displayed in the information pane.
The Search tab

The Search tab allows you to enter any keyword and display all topics in online help containing that specified keyword.

Using the Search tab

1. Enter a keyword in the Type in word(s) to search for: edit box and click the List Topics button. Appropriate topics are displayed in the Select topic area.

2. Select a topic and click Display. The topic is displayed in the information pane.
The Favorites tab

The Favorites tab allows you to archive frequently accessed help topics for quick retrieval.

Using the Favorites tab

1. Locate a help topic using any of the previously described methods.
2. Click the Favorites tab. The current topic is listed in the Current topic edit box.
3. Click Add. The topic is added to the Favorites tab and can be retrieved in the future by clicking Display.

What’s This? Help

What’s This? help allows you to view pop-up descriptions of the application’s dialog boxes.

Accessing What’s This? Help in a dialog

1. Click in the upper right-hand corner of the dialog.
2. Click a dialog item. Appropriate What’s This? help is displayed.

Help on the Web

Additional Sound Forge information is available on the Sonic Foundry Web site. From the Help menu, choose Sonic Foundry on the Web, and choose the desired location from the submenu. Sound Forge starts your system’s browser and attempts to connect to the appropriate page on the Sonic Foundry Web site.
Fundamentals

Sound Forge is a state-of-the-art digital audio editing tool with users from all musical backgrounds. It is an extremely deep program, containing features that may only be required by the most advanced or specialized users. Nonetheless, a firm grasp of Sound Forge basics is essential. This chapter is designed to provide you with information on the Sound Forge fundamentals.

Opening a file

1. From the File menu, choose Open. The Open dialog is displayed. For more information, see The Open dialog on page 74.

   ![Click the Open ( ) button.](image)

2. Select the Tutor1.wav file (the application searches for .wav files by default).

   ![Note: This file is located in the same folder as the application.](image)

3. Click Open. Sound Forge opens the audio file and displays a data window containing the waveform.

   ![File is Displayed in the Data Window](image)
The Open dialog

The Open dialog contains several features that allow you to locate audio files.

File of type
The Files of type drop-down list is used to specify the file format the application will search for in the system. Sound Forge supports several popular file formats.

Recent
The Recent drop-down list contains recently accessed folders.

Auto play
Selecting the Auto play check box configures Sound Forge to automatically preview .wav files as they are selected in the Open dialog.

Note: You can also preview .wav files by selecting the file and clicking Play.
File information display

If the application recognizes the format of the selected file, information regarding its format, length, and attributes is displayed in the lower pane of the Open dialog. The following table describes each of these values.

<table>
<thead>
<tr>
<th>File type</th>
<th>Indicates the type of the selected file.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Format</td>
<td>Indicates the format of the selected file.</td>
</tr>
<tr>
<td>Unity note</td>
<td>If the selected file is a sample, this is the MIDI note that will trigger a sampler to play the sound file at its original pitch.</td>
</tr>
<tr>
<td>SMPTE</td>
<td>Displays the SMPTE offset for the selected file if an offset has been defined.</td>
</tr>
<tr>
<td>Length</td>
<td>Indicates the length of the select file in seconds and samples.</td>
</tr>
<tr>
<td>Attributes</td>
<td>Indicates the bit depth, sample rate, and channels value of the selected file.</td>
</tr>
<tr>
<td>Loop(s)</td>
<td>Displays information about loops that have been defined in the selected file.</td>
</tr>
<tr>
<td>Rgns/Playlist</td>
<td>Indicates if the file contains regions on its Regions List or Playlist.</td>
</tr>
<tr>
<td>Comments</td>
<td>Displays any comments included in the file.</td>
</tr>
</tbody>
</table>
Playing a file

After a file is opened, it can be played by clicking the Play All (   ) button on the Transport toolbar. For more information, see The Transport toolbar on page 46.

File position indicators

As a file is played, the current playback position is indicated in the data window using three methods:

- A pointer travels across the visible portion of the data window.
- The current playback position in relation to the entire file is represented in the Overview.
- The first selection status field in the playbar displays the current position in the user-specified format. For more information, see Status formats on page 98.
Playing a file from a specified point

Sound Forge also allows you to begin playback from any point in a file.

1. Click, but do not drag, the mouse pointer in the data window. A flashing cursor (spanning the height of the waveform display) is displayed.

2. Click the Play ( ) button on the Transport toolbar. The file is played from the cursor position.

If no playback is heard, a small selection may inadvertently have been created. To determine if a selection was created, examine the status fields in the bottom right-hand corner of the data window's status bar.

- If only the first field contains a value, there is no selection.
- If all three fields contain values, a selection has been created. The selection can be cleared by clicking anywhere in the data window.

For more information, see Selection status fields on page 78.
Playing an audio selection

Specific portions of audio data can be played by creating selections in the waveform display.

1. Drag the mouse within the data window. Notice that the waveform is selected as the mouse is dragged.

2. Click the Play ( ) button. Only the selection is played.

Selection status fields

When a selection exists, the selection status fields in the bottom right-hand corner of the data window contain values. These values indicate the start, end, and length of the selection.

Status field format

You are able to display status field values in any format supported by Sound Forge. For more information, see Status formats on page 98.
Viewing selection statistics

Choosing Statistics from the Tools menu will display a Statistics dialog corresponding to the current selection. The following table describes all statistical categories displayed in the Statistics dialog.

<table>
<thead>
<tr>
<th>Category</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cursor Position</td>
<td>The cursor position (in samples) from the start of the audio file.</td>
</tr>
<tr>
<td>Sample Value at Cursor</td>
<td>The actual number stored by a single sample. The maximum allowed sample value is often referred to as 100% or 0 dB.</td>
</tr>
<tr>
<td>Maximum/Minimum Sample Position and Sample Value</td>
<td>The maximum and minimum sample values and the locations (in samples) where they occur. These values may help determine if clipping will occur in the audio file. These values can also be used to determine the noise level of a signal for use with a Noise Gate. For example, to determine the noise amplitude of a file, run Statistics on a region of noisy silence.</td>
</tr>
<tr>
<td>RMS Power</td>
<td>The Root Mean Square of the sample values relative to the RMS value of a maximum-amplitude square wave (the loudest possible recording). On short intervals, this value relates to the volume level of the audio file. If used on a large selection with large volume variation, this value becomes less meaningful.</td>
</tr>
<tr>
<td>Average Value (DC Offset)</td>
<td>The sum of all sample values in the selected region divided by the number of samples. If this value is not zero, it usually indicates a DC offset in the recording process.</td>
</tr>
<tr>
<td>Zero-Crossings</td>
<td>The number of times per second that the waveform fluctuates from a negative to a positive value. This value can be used as a rough estimate of the frequency of the audio data for very simple waveforms.</td>
</tr>
</tbody>
</table>

**Note:** If Statistics is run without a selection, statistics are displayed for the entire file.
Creating a new data window

Before a new file can be created, its attributes must be configured in a data window.

1. From the File menu, choose New. The New Window dialog is displayed.

   ![New Window dialog]

2. Choose a sample rate from the Sample rate drop-down list.
3. Choose a bit depth from the Bit depth drop-down list.
4. Select the desired Channels radio button and click OK. A new data window with the specified attributes is created and displayed.

   For more information, see File attributes on page 111.

Active data windows vs. inactive data windows

When multiple data windows are displayed on the workspace, only the window currently being edited is active, and all operations affect this window exclusively.

Activating a window

To activate a data window, click anywhere within it. The title bar changes to the color defined as the active window color and the previously active window is deactivated.

**Note:** Choosing Focus to Data Window from the View menu will also result in the focus being returned to the current data window.
Copying data to a new file

New audio files can be created by copying data to a new data window.

1. Open an audio file and create a selection.
2. From the Edit menu, choose Copy. The selection is copied to the clipboard.
   - Click the Copy (button in the Transport toolbar
3. Create a new data window. For more information, see Creating a new data window on page 80.
4. From the Edit menu, choose Paste. The selected data is pasted in the new data window.

Saving a file

1. From the File menu, choose Save.
   - When saving a new file, the Save As dialog is displayed. If the file was previously saved, choosing Save automatically saves the file without your input.
2. In the File name box, enter a name for the file and click Save. Sound Forge adds the .wav extension and saves the file.
The Save As dialog

The Save As dialog allows you to save an audio file with a new name, in an alternate format, or with new attributes.

**Save as type**
The Save as type drop-down list allows you to choose any format supported by Sound Forge.

**Recent**
The Recent drop-down list allows you to access frequently used folders.

**Format**
The Format drop-down list is used to choose the format in which the data is saved. Audio files are typically saved in the FCM format; however, other formats are available for compression purposes.

**Attributes**
The Attributes drop-down list is used to specify the file’s sample rate, bit depth, and channels (mono or stereo) values.
Regions/Playlist

The Regions/Playlist drop-down list is used to specify options for saving Regions List/Playlist information.

Save Summary Information in file

Selecting the Save Summary Information in File check box allows summary information to be saved in applicable file formats. For more information, see Summary information on page 120.

Creating Custom Templates

If the file type you select supports it, you can create custom templates for saving files by clicking the Custom button.

Note: If a file type supports custom templates, a Custom button displays next to the Template drop-down list after you choose the file type.

Once you click the Custom button, a Custom Settings dialog appears. You can choose your own template name and properties. When you are finished editing the template properties, click the OK button. Your template name will display in the Template drop-down on the Save As dialog.

Note: For information about specific controls in each file type’s Custom Settings dialog, click the What’s This? button and click the item.

Saving all open audio files

Choosing Save All from the File menu will automatically prompt you to save all open audio files on the current workspace before closing them.

Note: Holding Shift while choosing the Save All command will automatically save and close all open files without your input.
Saving/opening the workspace

Complex audio editing projects often consist of numerous data windows in various stages of completion. To accommodate large projects, Sound Forge allows you to save the entire workspace as an alternative to saving individual files. Workspaces are saved as Sound Forge Workspace files (.sfw) and when opened, restore all files to their previous sizes, positions, and views.

Saving the current workspace

1. From the **File** menu, choose **Workspace**, and choose **Save As** from the submenu. The Save Workspace dialog is displayed.
2. Browse to the folder where the file will be saved.
3. Enter a name for the file in the **File name** box and click **Save**.

Opening a workspace

1. From the **File** menu, choose **Workspace**, and choose **Open** from the submenu. The Open Workspace dialog is displayed.
2. Browse to the folder containing the desired .sfw file.
3. Select the desired file and click **Open**.

E-mailing audio files

Choosing **Send** from the **File** menu allows you to send the current audio file via electronic mail by launching your e-mail program, opening a new message, and embedding the active audio file in it. Using this feature, all contents of the audio file are inserted into the message and any changes that have been made to the file must be saved before the message can be sent.
Audio editing

New Sound Forge users should remember that even the most complex editing is derived from a few simple operations: Copy, Paste, Cut, Clear/Delete, Trim/Crop, and Mix. The following table provides a brief description of Sound Forge's basic editing operations.

<table>
<thead>
<tr>
<th>Operation</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Copy</td>
<td>Copies data from the window to the clipboard.</td>
</tr>
<tr>
<td>Paste</td>
<td>Inserts the contents of the clipboard into the window at the current cursor position. If a selection exists in the data window, the pasted data replaces the current selection.</td>
</tr>
<tr>
<td>Cut</td>
<td>Deletes data from the window and copies it to the clipboard.</td>
</tr>
<tr>
<td>Clear/Delete</td>
<td>Deletes data from the window, but does not copy it to the clipboard.</td>
</tr>
<tr>
<td>Trim/Crop</td>
<td>Deletes all data in the window, with the exception of the selection.</td>
</tr>
<tr>
<td>Mix</td>
<td>Mixes data from the clipboard with the data in the current window, starting at the current cursor position or the start of the current selection.</td>
</tr>
</tbody>
</table>

Editing tutorial

The following procedures will familiarize you with Sound Forge's basic editing operations. These procedures use files which are located in the same folder as the application. While working through these procedures, these files should remain open and be modified as described.
Copy

Audio data can be copied from a data window to the clipboard without changing the original file. Once on the clipboard, data can be pasted into existing files or used to create new ones.

Copying data to the clipboard

1. Open the Tutor1.wav file.
2. Create a selection containing “Wow.”
3. From the Edit menu, choose Copy. The selected data is copied to the clipboard.

   ![Image of audio editing software showing selection and clipboard actions]

   - **Create a selection in the waveform**
   - **Choose Copy from the Edit menu**
   - **Data is copied to the clipboard, but the waveform is unchanged**

   ![Image of audio editing software with copied selection]

   - **Click the Copy (렵) button or press Ctrl+C.**
Previewing clipboard contents

To preview the contents of the clipboard, choose Clipboard from the View menu, and choose Play from the submenu.

---

Note: Detailed information regarding the size and attributes of the clipboard contents can also be displayed by choosing Clipboard from the View menu and Contents from the submenu.

---

Recycling clipboard contents

Once on the clipboard, data can be pasted or mixed into an infinite number of windows. Data remains on the clipboard until it is replaced by new data.
Paste

Once on the clipboard, data can be pasted or mixed into an existing data window or used to create a new data window.

Pasting data in an existing data window

1. Move the cursor to the beginning of the Tutor1.wav file by clicking the Go To Start button in the Playbar. For more information, see The Playbar on page 42.

2. From the Edit menu, choose Paste. The clipboard data is inserted into the file and the data for “Wow” is displayed on the left-hand side of the waveform.

3. To confirm that the data has been pasted into the file, click Play. “Wow, Wow. Sound editing just gets easier and easier,” is played.

Pasting in a new data window

To use data from the clipboard to create a new data window, go to the Edit menu, choose Paste Special, and choose Paste to New from the submenu. A new window containing the clipboard data is created in a single step.
Cut

The Cut command allows you to remove a section of audio data from a data window and store it on the clipboard until it is pasted or mixed into another file. When deciding between Cut and Copy, consider the following:

- Copying data has no effect on the original file.
- Cutting data modifies the original file (also referred to as a destructive edit).

Cutting data from a window

1. Create a selection containing the second “Wow” (there should be two if the examples are being followed) in Tutor1.wav.

2. From the Edit menu, choose Cut. The selected data is removed from file and placed on the clipboard.

   ![Create a selection]

   Choose Cut from the Edit menu

   ![Selection is removed from the data window and placed on the clipboard]

   Click the Cut (\[ \]) button or press Ctrl + X.

3. Click Play. “Wow. Sound editing just gets easier and easier,” is played.
Previewing a Cut

Even with *Undo* capabilities, a cut is a destructive edit. For this reason, Sound Forge allows you to preview cuts prior to performing the edit. This allows you to determine if the selection was made accurately and the results are desirable.

1. Create a selection anywhere in Tutor1.wav.

2. Choose *Preview Cut/Cursor* from the *Edit* menu. Sound Forge ignores the selection, playing the audio before and after the selection to allow you to preview the cut.

Configuring cut pre-roll and post-roll lengths

Frequently, the default pre-roll and post-roll lengths are insufficient to evaluate the accuracy of an edit. For this reason, Sound Forge allows you to configure pre-roll and post-roll lengths.

1. From the *Options* menu, choose *Preferences*. The Preferences dialog is displayed.

2. Click the *Other* tab.

3. Configure the Pre-roll and Post-roll values in the Cut preview configuration area of the dialog and click *OK*.

Delete (Clear)

Delete permanently removes the selection without replacing the data currently residing on the clipboard. To delete data, choose *Delete (Clear)* from the *Edit* menu.

Press Delete.
Trim/Crop

The Trim/Crop command allows you to retain a selection while deleting all surrounding data.

Trimming/cropping an audio selection

1. Create a selection containing “Wow, sound editing just gets easier” in Tutor1.wav, but do not select the second “easier.”

2. Choose Trim/Crop from the Edit menu. Only “Wow, sound editing just gets easier” remains in the data window.
Mixing is a powerful editing function that allows two sounds to be combined into a single waveform.

Mixing audio

1. Open and play the Tutor2.wav file. A snare drum and crash cymbal are heard.

   **Note:** Tutor2.wav is located in the same folder as the application.

2. Verify that the Tutor1.wav window is active and choose Select All from the Edit menu. The entire waveform is selected.

3. Choose Copy from the Edit menu.

   To copy audio data, click or press Ctrl+C.

4. Activate the Tutor1.wav data window and click the Go To Start ( ) button on the Playbar. The cursor is moved to the start of the file.
5. From the **Edit** menu, choose **Paste Special**, and choose **Mix** from the submenu. The Mix dialog is displayed.

![Mix dialog image]

Click  

6. Verify that the **Source** and **Destination** Volume faders are set to 0 dB and click **OK**. The drum hit is mixed equally with the spoken passage and is displayed accordingly.

![Waveforms combined image]

Both waveforms are combined.

Preview the file and notice that, unlike **Paste**, mixing does not change the length of the file.
Undo/redo an edit operation

Sound Forge encourages experimentation by allowing you to easily undo/redo edit operations.

- Any newly performed edit operation can be undone by choosing Undo from the Edit menu.
- Any newly undone edit operation can be redone by choosing Redo from the Edit menu.

Click the Undo (.undo) button on the Standard toolbar or press Ctrl + Z.

Click the Redo (redo) button on the Standard toolbar or press Ctrl + Shift + Z.

Disabling Undo/Redo

Maintaining an Undo/Redo History for a file requires disk space, processing power, and a negligible amount of time. When working on large files, it is often advantageous to turn off the Undo/Redo History feature. This feature must be turned off on a per-file basis. Be aware however, that turning off this feature results in the Undo and Redo commands being unavailable for all operations performed on that file.

To turn off the Undo/Redo History, choose Disable Undo/Redo from the Edit menu. A check mark is displayed adjacent to the command to indicate that the feature is turned off. In addition, the title bar of the file's data window indicates that the feature is turned off. To turn on this feature, choose Disable Undo/Redo from the Edit menu a second time.

Note: The application does not modify the original file unless it is opened in direct or mode. Therefore, until the file is re-saved, it can be recovered by re-opening it. However, saved changes are permanent.
Undo/Redo History window

The Undo/Redo History window may seem confusing at first, but you will find it invaluable once you have mastered it. This window allows the audio file to be auditioned in various versions by undoing/redoing multiple operations. To display the Undo/Redo History window, choose Undo/Redo History from the View menu.

Using the Undo/Redo History window

1. Verify that the Tutor1.wav data window is active and choose Undo/Redo History from the View menu. The Undo/Redo History window is displayed. If the previous procedures have been performed, it should appear as follows:

![Current Undo/Redo History window]

Notice that the Mix operation is displayed at the top of the Undo pane. The most recent operations are always displayed at the top of the appropriate list.
2. In the **Undo** pane, click the « corresponding to the Mix operation. The audio file is played without the drum track.

3. Select the **Mix** operation and choose **Undo** from the **Edit** menu. The drum track is extracted from the Tutor1.wav data window and the Mix operation is moved to the **Redo** pane.

4. In the **Redo** pane, click the « corresponding to the Mix operation. The audio file is played with the mixed drum track.

5. Select the **Mix** operation again and choose **Redo** from the **Edit** menu. The drum track is remixed into the Tutor1.wav waveform and the Mix operation is returned to the **Undo** pane.

6. Select the **Trim/Crop** operation in the **Undo** pane and click «. Only the Mix operation is undone and moved to the **Redo** pane. This is due to the fact that operations can only be undone or redone in the order originally performed.
7. Double-click on the Cut operation in the Undo pane. The Cut and Trim/Crop operations are both undone in the waveform and moved to the Redo pane.

![Double-click the Cut operation]

To view the Undo/Redo History window, press `Alt + 8`. To quickly undo/redo operations in the Undo/Redo History window, double-click on the operation.

### Clearing the Undo/Redo History for the current file

Clearing the current file's Undo/Redo History will free up disk space by deleting the file's temporary undo/redo files. However, deleting these temporary files will prevent you from undoing changes made to the file since it was last saved. To clear the Undo/Redo History for the current file, go to the **Special** menu, choose **Undo/Redo History**, and choose **Clear** from the submenu.

### Clearing the Undo/Redo History for all open files

Sound Forge also allows you to simultaneously clear the Undo/Redo History for all open files. Once again, however, you will not be able to undo any previous changes once these histories are deleted. To clear the Undo/Redo History for all open files, go to the **Special** menu, choose **Undo/Redo History**, and choose **Clear All** from the submenu.
Status formats

The status format determines how the application displays a file’s position and length information. The following table briefly describes status formats that Sound Forge supports:

<table>
<thead>
<tr>
<th>Samples</th>
<th>Number of samples</th>
</tr>
</thead>
<tbody>
<tr>
<td>Time</td>
<td>Hours, minutes, seconds, and milliseconds</td>
</tr>
<tr>
<td>Seconds</td>
<td>Seconds and fractions of seconds</td>
</tr>
<tr>
<td>Time &amp; Frames</td>
<td>Hours, minutes, seconds, and frames, as defined by the Edit Frame Rate command (located on the Special menu)</td>
</tr>
<tr>
<td>Absolute Frames</td>
<td>Frames and fractions of frames</td>
</tr>
<tr>
<td>Measures &amp; Beats</td>
<td>Measures, beats and 1/4's of a beat</td>
</tr>
<tr>
<td>SMPTE Non-Drop</td>
<td>SMPTE at 30 or 29.97 frames per second (fps) non-drop</td>
</tr>
<tr>
<td>SMPTE Drop</td>
<td>SMPTE at 30 fps with drop frames</td>
</tr>
<tr>
<td>SMPTE EBU</td>
<td>SMPTE at 25 fps</td>
</tr>
<tr>
<td>SMPTE Film Sync</td>
<td>SMPTE at 24 fps</td>
</tr>
</tbody>
</table>

How status formats work

The Tutor1.wav file can be used to demonstrate how status formats affect values in the status display fields.

1. Open the Tutor1.wav file.

2. From the Options menu, choose Status Format, and choose Samples from the submenu.

3. Select all data in the Tutor1.wav window by choosing Select All from the Edit menu. Notice the selection status fields.

   0  220,506  220,507  OLE

   - The first selected sample is sample 0.
   - The last selected sample is 220,506.
   - The total number of samples in the selection is 220,507.

4. From the Options menu, choose Status Format, and choose Time from the submenu. Notice that status values change from samples to hours, minutes, and seconds.

   00:00:00.000  00:00:05.000  00:00:05.000  OLE

5. From the Options menu, choose Status Format, and choose SMPTE Non-Drop from the submenu. Notice that status values change to hours, minutes, seconds, and frames.

   00:00:00.00  00:00:05.00  00:00:05.00  OLE
5. Experiment with each status format and make note of how each format is displayed.

Note: Selecting a new format changes the status format for the current data window only.

To quickly change a file's status format, right-click on any of the data window's status fields and choose a new format from the shortcut menu.

![Choose a format from the shortcut menu](image)

Configuring the frames format

Choosing either of the Frames status formats allows you to specify a frames per second value.

1. Choose Edit Frame Rate from the Special menu. The Edit Frame Rate dialog is displayed.

2. Choose a new frames per second rate from the drop-down list or enter a value in the Frames per second box and click OK.

Changing the default frames per second rate

The previous procedure changes the frames per second rate for the current audio file only. To change the application's default frames per second rate:

1. From the Options menu, choose Preferences. The Preferences dialog is displayed.

2. Click the Status tab.

3. Enter a new Default frames per second value and click OK.
Configuring the Measures & Beats format

Specifying the *Measures & Beats* format allows you to specify the beats per minute and beats per measure values used to calculate measures and beats.

**Changing a file's beat values**

1. Choose *Edit Tempo* from the *Special* menu. The Edit Tempo dialog is displayed.
2. Enter an appropriate value in the *Tempo in Beats per minute* box.
3. Enter an appropriate value in the *Number of Beats in a measure* box and click **OK**.

**Changing the default beat values**

The previous procedure changes the beat values for the current audio file only. To change the application's default beat values:

1. Choose the *Preferences* option from the *Options* menu. The Preferences dialog is displayed.
2. Click the *Status* tab.
3. Enter an appropriate value in the *Default beats per measure* box.
4. Enter an appropriate value in the *Default beats per minute* box and click **OK**.

**Zoom and magnify**

Since there are considerably more samples in a sound file than horizontal points (pixels) on the screen, many data samples must be represented by each horizontal point when audio data is displayed in the data window. Depending upon the editing operation, you may want to view the entire file at once or a small portion of data in greater detail. For this reason, Sound Forge allows you to utilize two varieties of zooming: Time Ruler zooming and Level Ruler zooming.
Time Ruler (horizontal) zooming

The current Time Ruler magnification ratio is displayed in the lower right-hand corner of the data window, above the status fields.

Zoom ratio

The zoom ratio determines the number of audio data samples represented by each horizontal point on the screen. The zoom ratio is a value of 1:XX, where XX is the number of samples represented by each horizontal point. If the ratio is 1:1, each point on the screen represents one sample. At this zoom ratio, a brief but detailed selection of time is displayed.

Conversely, if the zoom ratio is 1:1024, 1,024 samples are represented by each point on the screen and a greater length of time is displayed.
Changing the zoom ratio

To edit the zoom ratio, use the Zoom In/Out spin control located adjacent to the zoom ratio display.

- Clicking the magnifying glass buttons increases/decreases the zoom ratio by single-step increments.
- Clicking and holding the spin control while dragging the mouse increments the zoom ratio quickly in the corresponding direction.

Right-clicking on the waveform display allows you to quickly access Time Ruler zoom commands from the shortcut menu.

![Using the Time Zoom shortcut](image)

**Note:** When Sound Forge opens a file, the horizontal magnification is set to the value specified by the Normal zoom ratio setting in the Display tab in the Preferences dialog.

Zoom Time menu commands

If you prefer using menu commands to control your view of the data window, Sound Forge allows you to control the time magnification from the application’s shortcut menus. The following table briefly describes the four available Zoom Time menu commands. These commands are accessed from the View menu by choosing Zoom Time and the desired command from the submenu.

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>In Full</td>
<td>Increases the zoom ratio to represent each audio sample with one screen pixel.</td>
</tr>
<tr>
<td>Normal</td>
<td>Returns the file to its default zoom ratio.</td>
</tr>
<tr>
<td>Out Full</td>
<td>Changes the zoom ratio to display the entire file within the data window.</td>
</tr>
<tr>
<td>Selection</td>
<td>Changes the zoom ratio to maximize the display and center the selection within the data window.</td>
</tr>
</tbody>
</table>
Level Ruler (vertical) zooming

Zooming along the Level Ruler displays a larger vertical waveform and allows for more precise editing at low audio amplitudes.
Changing the level zoom

To edit the Level Ruler zoom, use the Zoom In/Out spinner control located above the Playbar.

- Clicking the magnifying glass buttons increases/decreases the Level Ruler zoom by single step increments.
- Clicking and holding the spin control while dragging the mouse increments the Level Ruler zoom quickly in the corresponding direction.

At high zoom levels, only low-level samples are visible. This is due to the fact that the peaks of the waveform move beyond the vertical scope of the data window. Consider the following data windows.

Both data windows are displaying the same audio file at a 1:1 zoom ratio. The upper window is displayed with the Level Ruler zoomed to its maximum out position. The lower window is displayed with the Level Ruler zoomed to its maximum in position. Notice that wave peaks clearly visible in the upper window are clipped in the lower window.
Zoom Level menu commands

If you prefer using menu commands to control your view of the data window, Sound Forge allows you to control the level magnification from the application’s shortcut menus. The following table briefly describes the three available Zoom Level menu commands. These commands are accessed from the View menu by choosing Zoom Level and the desired command from the submenu.

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Out Full</td>
<td>Decreases the zoom level to minimize the display of the file’s amplitude.</td>
</tr>
<tr>
<td>Window</td>
<td>Changes the level zoom to display the entire waveform amplitude in the data window.</td>
</tr>
<tr>
<td>Selection</td>
<td>Maximizes the display of the selection (vertically and horizontally) in the data window.</td>
</tr>
</tbody>
</table>

Formatting the level ruler

The Level Ruler can be configured to display in decibels or percent by right-clicking on the ruler and choosing Label in Percent or Label in dB from the shortcut menu.

Zoom tricks

Zoom Selection

1. Create a selection. If no selection is created, this function is not available.

2. Right-click anywhere on the waveform and choose Zoom Selection from the shortcut menu. Sound Forge calculates the minimum zoom ratio that allows the full selection to be displayed in the window, then zooms and centers the selection in the data window.

To reverse this function, right-click on the waveform, choose Zoom, and choose Out Full from the submenu.

Zoom Window

1. Create a selection. If no selection is created, the entire file is processed.

2. Right-click in the Level Ruler and choose Zoom Window from the shortcut menu. Sound Forge calculates the maximum zoom level allowing the loudest portion of the selection to be displayed in the window and adjusts the entire sound file accordingly.

To reverse this function, right-click in the Level Ruler and choose Zoom Out Full from the shortcut menu.
Zoom Out Full
To quickly display all data in a data window, right-click on the waveform, choose Zoom, and choose Out Full from the submenu. This command sets the zoom ratio and zoom level to the lowest values required to display all data in the window.

To reverse this function, go to the View menu, choose Zoom Time, and choose Normal from the submenu.

Zoom In Full
To quickly set the zoom factor to its maximum magnification (1:1), right-click on the waveform and choose Zoom In Full from the shortcut menu. This displays the actual waveform oscillations that correspond to the physical sound waves.

To reverse this function, right-click on the waveform and choose Zoom Normal from the shortcut menu.

Optimizing Time and Ruler Scaling
To optimize both the Time Ruler and Level Ruler display of a selection, double-click on the Level Ruler. Double-clicking on the Level Ruler a second time restores both displays to their default levels.

Magnify tool
The Magnify tool provides an additional way to magnify a section of an audio file. The Magnify tool can be activated in three ways:

- From the Edit menu, choose Tool, and choose Magnify from the submenu.
- Click on the Standard toolbar.
- Click the tool selector in the upper left-hand corner of the data window until the Magnify tool is displayed.

The Magnify tool can be temporarily accessed by holding Ctrl while creating a selection.
Using the Magnify Tool

When the Magnify tool is selected, the application's cursor is displayed as ☰ and used to create a selection field indicating how audio data will be magnified. By using the Magnify tool and toggle-clicking the mouse, you can toggle between time zoom, level zoom, and simultaneous time/level zoom.

For more information, see Using the mouse on page 37.

Note: The Magnify tool must be exchanged for the Edit tool prior to performing edit operations.

Time Zoom with the Magnify Tool

1. Place the Magnify tool on the waveform, adjacent to the audio data to be magnified.
2. Toggle-click the mouse until the selection field is displayed as two vertical lines.
3. Hold the left button and drag the mouse to create a selection.
4. Release the button. The zoom ratio of the selection is increased.
Level Zoom with the Magnify Tool
1. Place the Magnify tool on the waveform, adjacent to the audio data to be magnified.
2. Toggle-click the mouse until the selection field is displayed as two horizontal lines.
3. Hold the left button and drag the mouse to create a selection.
4. Release the button. The level zoom of the selection is increased.

Time/Level Zoom with the Magnify Tool
1. Place the Magnify tool on the waveform, adjacent to the audio data to be magnified.
2. Toggle-click the mouse until the selection field is displayed as a box.
3. Hold the left button and drag the mouse to create a selection.
4. Release the button. The level zoom and time zoom of the selection are increased.
Crash recovery

If Sound Forge is terminated improperly, all open and unsaved audio files not opened in direct or read-only mode are recoverable. When a file is opened normally, Sound Forge automatically creates a temporary file (.tmp) that is used to save any changes made to the file and the original file is allowed to remain unchanged until it is saved. If improper termination of Sound Forge occurs, the temporary file remains on your hard drive and can be reopened to recover any unsaved changes made prior to the crash.

When Sound Forge is started, any temporary files detected in the specified temporary file directory will indicate that an improper termination has occurred. All temporary files are then listed in the Crash Recovery dialog and the application provides you with three options for dealing with the files: Recover, Delete, or Ignore.

Recover

This option changes detected .tmp files to .wav files, which can then be opened using the Open command. The folder used to store temporary files is specified on the Perform tab of the Preferences dialog, which is displaying by choosing Preferences from the Options menu.

Delete

This option deletes all the temporary files in the Crash Recovery dialog should be used only when you are positive you do not want to recover any of the files.

Ignore

This option allows you to ignore the temporary files without deleting them from your hard drive. However, it is typically recommended that recover or delete the files, as they are using disk space on your system.
This chapter deals with the audio file types, formats, and attributes Sound Forge supports. In addition, file summary information is also discussed.

**File attributes**

When a file is opened or created, its attributes are displayed in the first three fields of the status bar at the bottom of the main screen. The file attributes are sample rate, bit depth, and channels (mono or stereo).

<table>
<thead>
<tr>
<th>Sample rate</th>
<th>Bit depth</th>
<th>Channels</th>
<th>File length</th>
<th>Free storage available</th>
</tr>
</thead>
<tbody>
<tr>
<td>44,100 Hz</td>
<td>16-bit</td>
<td>Mono</td>
<td>00:00:09.12</td>
<td>9089.4 MB</td>
</tr>
</tbody>
</table>
Editing file attributes

File attributes can be edited from the Properties dialog.

1. From the **File** menu, choose **Properties**. The Properties dialog is displayed.
2. Click the **Format** tab.

3. Edit the file attributes as needed and click **OK**.

The Properties dialog can also be displayed by doing any of the following:

- Double-clicking on a format field.
- Right-clicking on the waveform display and choosing **Properties**.
- Pressing **Alt**+**Enter**.

Attribute editing shortcut

Individual file attributes can be quickly edited by right-clicking on the status field to be changed and choosing a new value from the shortcut menu.

Sample rate

Sample rate is the number of samples per second, measured in hertz, used to record audio. When creating a new file, you can specify sample rates from 2,000Hz to 192,000Hz. Typical sample rates are stored as presets in the **Sample rate** drop-down list. In addition, Sound Forge can be used to increase or decrease the sample rate of an existing audio file.
Editing the sample rate

1. Open and play the Tutor1.wav file.

   Note: This file is located in the same folder as the application.

2. Right-click the Sample Rate status field and choose 96,000 from the shortcut menu.
3. Play the file. Notice that the pitch is higher and the duration is shorter.
4. Right-click the Sample Rate status field and choose 8,000 from the shortcut menu.
5. Play the file. Notice that the pitch is lower and the duration is longer.

   Changing the sample rate of a file also results in the pitch and duration changing. To change the sample rate of a file while preserving its duration and pitch, you must use the Resample command. For more information, see Resample on page 235.

Bit Depth

Bit depth refers to the number of bits used to represent a sound. You can use Sound Forge to increase or decrease a file's bit depth.

Step-up conversion

Increasing the bit depth will not improve the quality of a file, but will allow subsequent processing to be performed with increased precision.

1. Open a file with a small bit depth.
2. From the Process menu, choose Bit-Depth Converter. The Bit-Depth Converter dialog is displayed.
3. In the Bit-depth pane, select a radio button corresponding to a larger bit depth and click OK.

   Note: When increasing a file's bit depth, the Dither and Noise shaping controls should be set to None and Off respectively.
Step-Down Conversion

To maximize storage space, 24 and 16-bit sound files are frequently converted to smaller (16 and 8-bit) files using Sound Forge. However, representing a sound file at a decreased bit depth will result in audible distortion referred to as quantization error.

**Note:** There are no rules regarding maintaining audio quality when decreasing bit depth. For this reason, you should always experiment with the Dither and Noise shaping controls to determine the optimum settings for each audio file.

1. Open a file with a bit depth of 24 bits.
2. Choose Bit-Depth Converter from the **Process** menu. The Bit-Depth Converter dialog is displayed.
3. In the Bit-depth pane, select a radio button corresponding to a smaller bit depth.
4. If desired, specify a dither from the **Dither** drop-down list. *For more information, see Dither on page 114.*
5. If desired, specify a Noise shaping type. *For more information, see Noise shaping on page 115.*
6. Click **OK**.

**Dither**

Allows you to determine the randomness of the dither (generated noise) used to mask quantization distortion resulting from conversion to a lower bit depth. This drop-down list requires you to select from several shapes, each of which roughly describes the pattern that would be produced if you plotted a graph with the dither amplitude on the X-axis and the probability of the dither values on the Y-axis.
As is frequently the case when working with audio, experimentation will dither values will yield the best results; however, the following information should be kept in mind:

- **Rectangular** will eliminate distortion products caused by conversion to a lower bit depth, but the noise level is more likely to be dependent on the signal.
- **Triangular** will eliminate the distortion products as well as any noise floor modulation, but results in a slightly higher noise level. The option typically works well in conjunction with noise shaping. *For more information, see Noise shaping on page 115.*
- **Highpass Triangular** will behave like triangular dither, but will shift its noise into higher frequencies. This is typically the best option when used in conjunction with noise shaping. *For more information, see Noise shaping on page 115.*
- **Gaussian** will not perform as well as Rectangular and Triangular dither, but may be suitable for certain audio.

### Noise shaping

Determines the aural positioning of quantization noise. Using this control, you are able to shift the noise into audio registers that are less perceptible to human hearing. This lowers the perceived noise floor and creates the illusion of cleaner audio.

- **Type 1 (high-pass contour)** noise shaping attempts to push all quantization noise and error into high frequencies.
- **Type 2 (equal-loudness contour)** noise shaping attempts to push the noise under an equal-loudness-type of curve.

### Noise shaping dangers

Noise shaping places quantization noise near the audio’s Nyquist frequency, a value equal to one-half of the file’s sample rate. Consider the following:

- A file with a sample rate of 44.1kHz has a Nyquist frequency of 22.05kHz (at the high end of human hearing). Applying noise shaping to this file will result in audio perceived to be cleaner than it actually is.
- A file with a sample rate of 22kHz has a Nyquist frequency of 11kHz (well within the sensitive range of human hearing). Applying noise shaping to this file will result in audio that is perceived to be noisier than it actually is. Ironically, this defeats the entire purpose of the Noise shape control.

For this reason, we do not recommend using noise shaping on files with sample rates less than 44.1kHz.
Minimizing quantization error

There are at least three methods of minimizing quantization error when decreasing a file’s bit depth: noise gating, compression, and normalization. However, these methods must be exercised prior to actually decreasing the bit depth.

Noise gating
Frequently, low-level signals become noise when a file’s bit depth is decreased. For this reason, it is preferable to have complete silence between sounds in an audio file.

1. Choose Sonic Foundry Noise Gate from the Effects menu. The Noise Gate dialog is displayed.

2. Specify a noise gate preset in the Name drop-down list and click OK. A noise gate is applied to the audio, negating its low-level signals.

Compression
Decreasing the dynamic range of a sound file makes it easier to represent with decreased bit depth.

1. From the Effects menu, choose Dynamics, and choose Graphic from the submenu. The Graphic Dynamics dialog is displayed.

2. Specify a preset with a small amount of compression (2:1 or less) in the Name drop-down list and click OK.
Normalization

Normalizing a file prior to decreasing its bit depth ensures that the entire dynamic range is used. In addition, normalization lowers the signal-to-noise ratio.

1. Choose Normalize from the Process menu. The Normalize dialog is displayed.
2. Select the Peak level radio button.
3. Set the Normalize to fader to 0 dB (peak) and click OK.

Applying compression and normalization simultaneously

1. From the Process menu, choose Normalize. The Normalize dialog is displayed.
2. Select the Average RMS power radio button.
3. Specify Apply dynamic compression in the If clipping occurs drop-down list and click OK.

Channels

The Channels setting indicates whether a file contains one (mono) or two (stereo) channels. Sound Forge can be used to convert mono files to stereo or stereo files to mono.

Mono-to-stereo conversion

1. Open the Tutor1.wav file.

   Note: This file is located in the same folder as the application.

2. Right-click the Channel status field and choose Stereo from the shortcut menu. The Mono to Stereo dialog is displayed.
3. Select the Left Channel radio button and click OK. The application places the mono data in the upper half of the data window (left channel) and silence in the right channel.

   For more information, see Destination radio buttons on page 118.
4. Play the file. “Wow, sound editing just gets easier and easier” is heard in only the left channel.

**Note:** If your sound card supports only mono data, stereo files can be played by specifying the Sound Mapper as the playback device. To do this, choose Preferences from the Options menu. Click the Wave tab and specify Microsoft Sound Mapper from the Playback drop-down list.

**Destination radio buttons**

The Destination radio buttons allow you to specify where the mono audio data will be placed in a stereo file. The following list describes the available data destinations.

<table>
<thead>
<tr>
<th></th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Left Channel</td>
<td>The mono data is placed in the left channel. The right channel is set to silence.</td>
</tr>
<tr>
<td>Right Channel</td>
<td>The mono data is placed in the right channel. The left channel is set to silence.</td>
</tr>
<tr>
<td>Both Channels</td>
<td>The mono data is copied into both channels.</td>
</tr>
</tbody>
</table>

**Stereo-to-mono conversion**

1. Open the Saxriff.wav file.

**Note:** This file is located in the same folder as the application.

2. Right-click the Channel status field (indicating Stereo) and choose Mono from the shortcut menu. The Stereo to Mono dialog is displayed.

3. Select the Mix Channels radio button and click OK. The left and right channels are combined into a mono channel.

For more information, see Source radio buttons on page 119.
Source radio buttons

The Source radio buttons allow you to specify what stereo data is used to create the mono file. The following list describes the available data sources.

<table>
<thead>
<tr>
<th>Source</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Left Channel</td>
<td>Mono data is taken only from the left channel of the stereo file.</td>
</tr>
<tr>
<td>Right Channel</td>
<td>Mono data is taken only from the right channel of the stereo file.</td>
</tr>
<tr>
<td>Mix Channels</td>
<td>Mono data is created by mixing both channels of the stereo file.</td>
</tr>
</tbody>
</table>

Channel Converter

The Channel Converter, located in the Process menu, can also be used to convert files between mono and stereo formats. Using the Channel Converter provides the added flexibility of independent level settings for each channel, thereby allowing you to inter-mix the channels of a stereo file to create pan effects.

Converting file formats

The previous sections have described converting a file's sample rate, bit depth, and channel configuration. Using Sound Forge, it is also possible to convert a file's delivery type, format, and attributes.

To demonstrate this, open the Tutor1.wav file and choose Save As from the File menu. Notice the Save as Type, Format, and Attributes drop-down lists.

Save as type

When the Save As dialog is displayed, the Save as type drop-down list is defaulted to the file's original format. However, using the Save as type drop-down list, you can specify any file type supported by Sound Forge.

Format

The Format drop-down list is used to specify the format of the audio file's data. The default format, PCM (Pulse Code Modulation), is the standard format for noncompressed audio. However, the Format drop-down list contains all formats appropriate to the specified file type. For more information, see File type support on page 120.
Attributes

The Attributes drop-down list displays the sample rate, bit depth, and channels values to be saved in the audio file. You are able to specify new file attributes using this drop-down list. Again, the listed attributes are dependent upon the specified file type. For more information, see File type support on page 120.

When using the Attributes drop-down list to change mono files to stereo, audio data is copied to both channels. When using this list to change stereo files to mono, the stereo data is mixed to a single channel.

File type support

When specifying different file types, you may notice that the available presets in the Format and Attributes drop-down lists change. This is due to the fact that not all file types support the same data. For example, the Dialogic .vox format only supports 16-bit mono Dialogic ADPCM files. This means that stereo 8-bit data cannot be stored in this file type.

If you attempt to save to an unsupported format, Sound Forge will automatically convert the file to the nearest compatible format.

Summary information

Specific audio file types allow you to store text fields of summary information in addition to the audio and video data. File types offering this feature include .wav, .avi, .asf, and .rm. Sound Forge supports the viewing and editing of these text fields.

Viewing and editing summary information

The Summary tab is used to view and edit the summary information stored in the file.

1. From the File menu, choose Properties. The Properties dialog is displayed.
2. Click the Summary tab. The Summary dialog is displayed.
3. Edit the summary information as needed and click OK.

Viewing extended summary information

1. From the File menu, choose Properties. The Properties dialog is displayed.
2. Click the Summary tab. The Summary dialog is displayed.
3. Click the Extended button. The Extended Summary dialog is displayed with its two major components; the Fields pane and the Contents pane.
The **Fields pane**

The Fields pane displays the following components for each available field:

- An **Enable/Disable** check box.
- The abbreviation of the field type.
- A short description of the field.
- An indication of the field's current status.

### Contents Window

Located immediately below the Fields pane, the Contents pane displays the current contents of the selected field.

### Editing extended summary information

1. Select the field to be edited in the Fields pane. Its contents are displayed in the Contents pane.

2. Enter the new information in the Contents pane and click **OK**.

### Enabling/disabling summary fields

Adjacent to each field in the Fields pane is a check box that is used to enable or disable the corresponding field when saving files in applicable formats.

**Note:** If a field is **enabled**, but contains no information, it is not saved with the file.
The Default button

Clicking the **Default** button in the Extended Summary dialog saves the text in the summary fields with the default fields that are automatically entered when creating a new .wav file.

---

**Note:** The Creation date field (ICRD) is always filled with the current date for new files.

---

Saving summary information

Files containing summary information that have been edited in Sound Forge can be saved with or without summary information.

1. From the **File** menu, choose **Save As**. The Save As dialog is displayed.
2. Select the **Save Summary Information in file** check box and click **OK**.

---

**Note:** Clearing this check box saves the file without summary information.

---

Additional embedded information

The Microsoft .wav and .avi file formats allow non-text data (such as embedded bitmaps and metafiles) to be embedded in files. If a file containing data created in another application is edited in Sound Forge, the embedded data is tracked and placed back in the file when it is saved in its original format.

Add/remove additional embedded information

To add or remove additional embedded information, choose **Save As** from the **File** menu. You will be alerted to the presence of additional data and prompted to choose if it will be copied to the new file.

- Clicking **Yes** includes the embedded information in the new file.
- Clicking **No** disregards the embedded information when saving the file.

---

**Note:** Sound Forge prompts you regarding this type of data only if it exists.
Markers, Regions, and the Playlist/Cutlist

This chapter describes the use of markers, the Regions List, and the Playlist/Cutlist in Sound Forge. These tools allow you to tag and organize audio data and make audio editing in Sound Forge more efficient. Any audio file saved in the .wav format or to an external playlist file contains a dedicated Regions List and Playlist stored along with the audio data.

Why use markers, regions, and the Playlist?

There are at least three reasons for you to master the use of these features:

- Rapid navigation
- Destructive vs. nondestructive editing
- MIDI synchronization and triggering

Rapid navigation

The most obvious use of the Regions List is for dissecting an audio file into multiple defined regions. Once created, regions can be selected and played in the data window. You are also able to tag important time positions with markers. This allows you to navigate large files and locate important audio events.

Destructive vs. nondestructive editing

When edits are performed on an audio file using the Cut and Paste commands, Sound Forge literally rearranges the audio data on the hard drive. Depending upon the size of the file, this may require substantial time and processing. However, creating regions in the Regions List and arranging them in the Playlist affects only the playback order. This is referred to as nondestructive editing since no data is actually moved within or removed from the file.

Another advantage of nondestructive editing is that changes can be auditioned immediately. In addition, regions organized in the Playlist can be quickly saved as a new file based on the finished arrangement.
MIDI synchronization and triggering

Regions created in Sound Forge can be triggered using MIDI or SMPTE timecode. This feature is used for synchronizing audio files to sequencers, MIDI controllers, or any other time-based media. For example, a MIDI trigger can be assigned to an audio file in Sound Forge and triggered by a sequencer along with other MIDI instruments.

It is also possible to assign SMPTE times to special effect audio files. This allows you to match audio to the action on the screen.

For more information, see Triggered region playback on page 274.

Markers

A marker is a tag placed in an audio file that used as a reference point. Markers make navigating a file easier and more efficient.

Creating a marker

1. Place the mouse pointer in the waveform and click to display the cursor.
2. From the Special menu, choose Drop Marker. A marker is placed in the waveform at the exact location of the cursor.

Press M.

Select drop marker from the special menu

Marker is placed in the waveform
Naming a marker

Markers should be named to make them identifiable.

1. Right-click the marker and choose Edit from the shortcut menu. The Edit Marker/Region dialog is displayed.

2. Enter a name or description for the marker in the Name box and click OK. The marker is named in the waveform display.

Creating markers using the ruler shortcut menu

The ruler shortcut menu allows you to create and name a marker in a single step.

1. Place the cursor in the waveform.

2. Right-click in the ruler and choose Marker/Region from the shortcut menu. The Add Region/Marker dialog is displayed.

3. Enter a name for the marker in the Name box and click OK. A marker is created in the waveform and named accordingly.
Creating markers during playback

To create markers in real time during playback or recording, press M.

Creating markers during recording

To create markers during recording, click in the Record dialog. For more information, see Record dialog on page 149.

Changing the marker position

A marker’s position can be changed in two ways:

• Using drag-and-drop.
• Using the Edit Marker/Region dialog.

Changing the marker position using drag and drop

1. Drag the marker to a new position on the data window ruler.

2. Release the mouse button. The marker is dropped at its new location.
Editing markers using the Edit Marker/Region dialog

The previous procedure allows you to quickly change the position of a marker, but its accuracy is limited.

1. Right-click a marker and choose Edit from the shortcut menu. The Edit Marker/Region dialog is displayed.

2. Enter a new marker position value in the Start box and click OK. The marker position is updated.

Using markers to create regions

Once placed in a waveform, markers can be used to automatically create regions. For more information, see The Markers to Regions command on page 135.

The Regions List

Prior to creating regions, it is helpful to examine the Regions List. Audio files edited in Sound Forge contain a dedicated Regions List when saved in the .wav file format or to an external playlist file. The Regions List contains information pertaining to all regions in the current data window.
Displaying the Regions List

1. Open the Tutor1.wav file.
2. Choose Regions List from the View menu. The Regions List for Tutor1.wav is displayed.

To display the Regions List, press Alt + 2.

Understanding the Regions List

By default, the Regions List displays the following for each region in the current data window:

- A small Play ( ) button dedicated to the region.
- The name of the region.
- The region’s start point.
- The region’s end point.
Configuring the Regions List display

If you do not wish to use the default display of the Regions List, you can specify alternate display options.

1. From the **Options** menu, choose **Preferences**. The Preferences dialog is displayed.
2. Click the Playlist tab.

3. Specify a display format from the Regions List display format drop-down list and click **OK**. The Regions List display format is updated.

Changing the region order

By default, the Regions List displays regions in alphabetical order by name, but you may also specify an alternate order:

1. From the **Options** menu, choose **Preferences**. The Preferences dialog is displayed.
2. Click the Playlist tab.
3. Clear the **Sort the Regions List alphabetically** check box and click **OK**. You are prompted to restart Sound Forge to apply the new sort parameter.
4. Click **OK** and restart Sound Forge. Following restarting, regions are listed in the order that they appear in the original file.

Saving a Regions List file

You can save a file’s Regions List to an external file. This offers the flexibility of using multiple Regions Lists for the same audio file.

1. From the **Special** menu, choose **Regions List**, and choose **Save As** from the submenu.
   - Right-click the Regions List and choose **Save As** from the shortcut menu.

2. Use the Save Regions/Playlist dialog to specify a folder and filename.
3. If you want to save the Regions List in a format to be used in an application other than Sound Forge, select a file type from the Save as Type drop-down list:
   - Choose Session 8 File (.prm) to maintain regions edited in both Session 8 and Sound Forge.
   - Choose Windows Media Script File (.txt) to save markers and regions in a Windows Media Format script table.

4. Click Save.

Opening a Regions List file

Importing a Regions List file offers the flexibility of using multiple regions files for the same audio file. Opening a new regions file will clear the current Regions List. Make sure you have saved the current Regions List before continuing.

1. From the Special menu, choose Regions List, and choose Open from the submenu.
   ▶️ Right-click the Regions List and choose Open from the shortcut menu.

2. Use the Open Regions/Playlist dialog to locate an existing regions file.

3. Specify the type of regions you want to import from the Files of Type drop-down list:
   - Choose Playlist File (.sfl) to import a Sound Forge regions/playlist file.
   - Choose Session 8 File (.prm) to import a file that supports both Session 8 and Sound Forge regions.
   - Choose Windows Media Script File (.txt) to import a Windows Media Format script table.
   - Choose Wave File (.wav) to import markers and regions from another audio file.

4. Click Open.

Creating regions

Sound Forge offers multiple methods of creating regions including menus, drag-and-drop, the time ruler shortcut, and the keyboard. The following sections briefly describe the methods of creating regions. To work through these procedures, use the Tutfill.wav file. This file is located in the Sound Forge folder.

Creating regions using menu commands

1. Open the Tutfill.wav file and display the Regions List. For more information, see Displaying the Regions List on page 128.

2. Create a selection containing the final drum hit near the end of the waveform display.
3. From the **Special** menu, choose **Regions List**, and choose Add from the submenu. The Add Marker/Region dialog is displayed.

4. Enter a name for the region in the **Name** box and click **OK**. The selection is added to the Regions List.

   In addition, notice that region tags are now displayed in the data window. These tags indicate the region's name and position within the original file.

**Creating regions using drag-and-drop operations**

   One of the easiest ways to create a regions is to drag a selection from a data window into the Regions List.

   1. Create a selection containing the opening drum roll in Tutfill.wav.
2. Drag the selection from the data window to the Regions List. The Add Marker/Region dialog is displayed.

3. Name the region and click OK.

Creating regions using the ruler shortcut

1. Create another selection in the waveform display.

2. Right-click the time ruler and choose Add Marker/Region from the shortcut menu. The Add Marker/Region dialog is displayed.

3. Name the region and click OK.

Creating regions using the keyboard

1. Create a selection in the waveform display.

2. Press the F key. The Add Marker/Region dialog is displayed.

3. Name the region and click OK.

Creating regions automatically

In addition to the previously described region creation methods, you can also create regions automatically using the Auto Region tool or the Markers to regions command.

Creating regions while recording

The most efficient way of creating regions is to do it while recording your audio. This is especially useful when working on a project that will be pieced together from multiple takes. To create regions while recording, specify Multiple takes creating Regions from the Mode dropdown list in the Record dialog. For more information, see Multiple takes creating Regions on page 152.
The Auto Region tool

The Auto Region tool automatically creates regions in an audio file. You can select from two automatic methods of region creation: using rapid sound attacks or using a selected musical time interval.

**Note:** All regions created using the Auto Region tool are automatically added to the Regions List and Playlist.

Using the Auto Region tool with rapid sound attacks

1. Open the Tutfill.wav file.
2. From the Tools menu, choose Auto Region. The Auto Region dialog is displayed.
3. Clear the Build regions using current tempo check box.
4. Specify a preset from the Name drop-down list or configure a new setting using the dialog’s active parameters. For more information, see Active parameters on page 133.
5. Click OK. Regions are created in the audio file based on the dialog parameters.

Active parameters

The following parameters determine exactly how the Auto Region tool will create regions based on rapid sound attacks.

**Attack sensitivity**
Determines the sensitivity of the attack-detection algorithm to rapid volume increases.

**Release sensitivity**
Determines the minimum decrease in sound level required to create a region end point.
Minimum level
Determines the threshold audio level required to create a new region.

Minimum beat duration
Specifies the minimum length, in seconds, that must elapse before a new region can be created.

Use release point for end of region
Requires a region end when the sound level drops by the factor specified by the Release sensitivity value.

Using the Auto Region Tool with musical time intervals
When the Build regions using the current tempo check box is selected, regions are created according to the current Beats per minute setting. For more information, see Changing the Beats per minute setting on page 135.

1. Open the Tutmusic.wav file.

   Note: This file is located in the same folder as the application.

2. From the Tools menu, choose Auto Region. The Auto Region dialog box is displayed.
3. Select the Build regions using current tempo check box. The Measures and Beats boxes are activated.
4. Enter desired values in the Measures and Beats boxes. For more information, see Measures/Beats on page 134.
5. Click OK. Regions are created in the data window based on the Measures value, the Beats values, and the current Beats per minute setting.

Measures/Beats
These parameters determine the musical time interval between regions according to the specified number of beats in a measure.

- To create a region on every beat, set Measures to 0 and Beats to 1.
- To create a region at every measure, set Measures to 1 and Beats to 0.
Changing the Beats per minute setting

1. From the **Special** menu, choose **Edit Tempo**. The Edit Tempo dialog is displayed.
2. Enter a new value in the **Tempo in Beats per minute** box and click **OK**. The Beats per minute value is updated.

The Markers to Regions command

The **Markers to Regions** command creates regions by using all markers in the audio file as region boundaries. Regions created this way are added to the Regions List, but not to the Playlist.

1. Open the Tutfill.wav file.
2. Play the file and drop several markers using the **M** key.

   ![Markers created in data window](image)

3. From the **Special** menu, choose **Regions List**, and choose **Markers to Regions** from the submenu. You are prompted to verify whether the markers should be used to create regions.
4. Click **Yes**. Sound Forge creates regions and adds them to the Regions List.

Editing a region

This section describes editing regions. Sound Forge allows you to edit regions from the data window or the Regions List.
Editing regions in the data window

1. Drag the desired region tag to a new position. Both associated region tags are highlighted and the name of the region is displayed in the lower-left corner of the status bar.

2. Release the mouse button. The region's values are updated in the Regions List.

Editing regions using the marker/region shortcut menu

Right-clicking a region tag displays a shortcut menu that provides you with the following commands: Select, Delete, Edit, Split, Update.

- **Select**
  Selects the entire region.

- **Delete**
  Deletes the region, but leaves the audio data intact.

- **Edit**
  Displays the Edit Marker/Region dialog.

- **Split**
  With the cursor placed within a region, this command splits the region into two new regions at the cursor and updates the Regions List.

- **Update**
  Edits the region tags to correspond with the current waveform selection.

Editing regions in the Regions List

Regions can also be edited by double-clicking the region name in the Regions List. This displays the Edit Marker/Region dialog, which also allows you to specify triggers. For more information, see MIDI triggers on page 271.
Editing regions using the Regions List shortcut menu

Right-clicking anywhere in the Regions List displays a shortcut menu containing many commands previously discussed, as well as Replicate and Copy onto Clipboard.

**Replicate**

Duplicates the selected region and places the copy in the Regions List.

**Copy onto Clipboard**

Copies the selected region’s information onto the clipboard, allowing it to be pasted into text editors such as Notepad.
The Extract Regions tool

The Extract Regions tool allows you to quickly create a new file from each region in a file. The file name given to each region is created by appending a numerical value to a user-specified prefix.

1. Open an audio file and create several regions in it.
2. Choose Extract Regions from the Tools menu. The Extract Regions dialog is displayed and all current regions are listed in the Regions to extract pane.

3. Select the regions to be extracted.
4. If the path in the Destination folder box is not appropriate, click the Browse button and browse to the desired destination folder.
5. Enter the desired prefix in the File name prefix box.
6. If desired, clear the Use Long File Names for destination file names check box and enter an appropriate numeric value in the Start file counter index box.

Note: Clearing this check box forces file names to conform to the 8.3 naming convention.

7. Click OK.
The Playlist

Once regions are created, they can be arranged in the Playlist. Unlike the Regions List, which displays its contents in alphabetical or chronological order, the Playlist displays and plays its regions in a user-specified arrangement. In addition, regions can be rearranged and auditioned endlessly in the Playlist without performing a destructive edit. Every audio file contains a dedicated Playlist when saved in the .wav file format or to an external playlist file.

Displaying the Playlist

1. Open the Tutor1.wav file.
2. Choose Regions List from the View menu. The Regions List for Tutor1.wav is displayed.
3. Choose Playlist/Cutlist from the View menu. The Playlist for Tutor1.wav is displayed.

Notice that the file contains regions, but the Playlist is empty. Regions must be manually added to the Playlist before they can be arranged.

To display the Playlist, press **Alt+3**.

Adding regions to the Playlist

Regions must be individually added to the Playlist using the menu commands or drag-and-drop.
Adding regions to the Playlist using menu commands

1. Select a region in the Regions List.

2. From the Special menu, choose Playlist/Cutlist, and choose Add from the submenu. The region is added to the Playlist.

Adding regions to the Playlist using drag-and-drop operations

1. Select a region in the Regions List.
2. Drag the region into the Playlist.
3. Release the mouse button.

Adding regions directly from the data window to the Playlist

Selections can be added to the Playlist directly from the data window using the previous two methods. When a selection is added directly to the Playlist, it is automatically placed in the Regions List as well.
Region display in the Playlist

When a region is added to the Playlist, its appearance is similar to its appearance in the Regions List, with the exception of the Count (Cnt) column.

<table>
<thead>
<tr>
<th>Cnt</th>
<th>Name</th>
<th>Start Time</th>
<th>End Time</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>intro</td>
<td>00:00:00.00</td>
<td>00:00:18.34</td>
</tr>
<tr>
<td>4</td>
<td>riff</td>
<td>00:04:33.02</td>
<td>00:04:33.02</td>
</tr>
<tr>
<td>2</td>
<td>verse</td>
<td>00:05:06.03</td>
<td>00:05:06.03</td>
</tr>
<tr>
<td>4</td>
<td>refrain</td>
<td>00:07:36.09</td>
<td>00:07:36.09</td>
</tr>
<tr>
<td>1</td>
<td>bridge</td>
<td>00:07:36.09</td>
<td>00:07:41.12</td>
</tr>
</tbody>
</table>

Count

Located to the left of the Name column, the Count (Cnt) column displays the number of times the corresponding region is played before the Playlist proceeds to the next region.

1. Right-click a region in the Playlist and choose Edit from the shortcut menu. The Edit Playlist dialog is displayed.

2. Enter a new value in the Play count box and click OK. The selected region's Count column is updated.

To change the Count value quickly, select a region and use the + and - keys to increment/decrement the value.

To display the Edit Playlist dialog, double-click on a region.
Changing the Playlist display

Like the Regions List, you can specify what values are displayed in the Playlist.

1. From the **Options** menu, choose **Preferences**. The Preferences dialog is displayed.
2. Click the **Playlist** tab.
3. Specify a display from the Playlist display format drop-down list and click **OK**. The Playlist display format is updated.

Playing from the Playlist

The Playlist displays the sequential order in which regions will be played. To play a region, click the corresponding **Play ( )** button. Playback begins with the selected region and continues through the end of the Playlist, playing a region multiple times when instructed by the Count value.

**Note:** Playback is interrupted if a stop point is present. For more information, see Stop points on page 143.

Arranging the Playlist

Once regions are added to the Playlist, they can be arranged using drag-and-drop operations.
Replicating a region in the Playlist

A major advantage of arranging with the Playlist is its ability to repeat a region in multiple places without actually copying the audio data. This feature is referred to as replicating.

1. Right-click the region to be replicated and choose Replicate from the shortcut menu. The region is replicated in the Playlist.

2. Drag the replicated region to its new position in the Playlist.

Stop points

Stop points can be attached to regions in the Playlist. When a stop point is encountered during playback, the corresponding region is repeated the number of times specified by the Count value and playback is halted.

Creating a stop point

1. Select a region in the Playlist.

2. Right-click the mouse and choose Stop Point from the shortcut menu. A check mark is placed adjacent to the command in the shortcut menu and a stop point (indicated by a red circle) is displayed in the Playlist. In the following illustration, playback will stop after the “Sound editing just get easier . . . “ region is played once.
Deleting a stop point

Right-click a region in the Playlist and choose **Stop Point** from the shortcut menu. The corresponding check mark is cleared from the shortcut menu and the stop point is deleted from the Playlist.

A stop point can quickly be added to/removed from the Playlist by selecting a region and pressing `[`.

Deleting a region from the Playlist

Regions can be deleted from the Playlist without affecting the audio file by right-clicking the region and choosing **Delete** from the shortcut menu.

To delete a region from the Playlist, select the region and press `Delete`. 
Creating a new file from the Playlist

After all regions in the Playlist are auditioned and arranged, Sound Forge can create a new file based on the Playlist arrangement. To create a new file from the Playlist, right-click the Playlist and choose Convert to New from the shortcut menu.

**Note:** Sound Forge creates a new data window and Regions List based on the Playlist arrangement.

The Cutlist

When trimming lengthy recordings, configuring the Playlist as a Cutlist can greatly decrease editing time. In Cutlist mode, Sound Forge plays the original file, but ignores all regions placed on the Cutlist.
Enabling the Cutlist

1. From the **View** menu, choose **Playlist/Cutlist**. The Playlist is displayed.

2. Right-click the Playlist and choose **Treat as Cutlist** from the shortcut menu. A check mark is displayed adjacent to the command in the shortcut menu and the Cutlist is displayed.

Using the Cutlist

1. Open the Tutor1.wav file and the Cutlist.

2. Select the “Silence” region and drag it to the Cutlist. The region is added to the Cutlist and the selection area in the waveform display is greyed-out.
3. Click the Play As Cutlist ( ) button on the data window’s Playbar. The file is played with the cutlisted region(s) omitted.

To add a selected region to the Cutlist, press Delete.

Creating a new file from the Cutlist
Once all superfluous regions are placed in the Cutlist, a new audio file and Regions List can be generated from the remaining regions by right-clicking the Cutlist and choosing Convert to New from the shortcut menu.

Deleting all Cutlist regions
To delete all regions in the Cutlist, right-click the Cutlist and choose Delete Cut Regions from the shortcut menu.

Reverting to Playlist function
To use the Cutlist as a Playlist again, right-click the Cutlist and choose Treat as Cutlist from the shortcut menu. The check mark is cleared from the corresponding command in the shortcut menu and the Playlist function is restored.

Saving a Playlist/Cutlist file
You can save a file's Playlist/Cutlist to an external file. This offers the flexibility of using multiple playlists for the same file.

1. From the Special menu, choose Playlist/Cutlist, and choose Save As from the submenu.

Right-click on the Playlist/Cutlist and choose Save As from the shortcut menu.

2. Use the Save Regions/Playlist dialog to specify a folder and filename.

3. Click Save.
Opening a Playlist file

Importing a Playlist file offers the flexibility of using multiple playlists for a file. Opening a new playlist file will clear the current Playlist. Make sure you have saved the current Playlist before continuing.

1. From the Special menu, choose Playlist/Cutlist, and choose Open from the submenu.

   Right-click on the Playlist/Cutlist and choose Open from the shortcut menu.

2. Use the Open Regions/Playlist dialog to browse to an existing regions file.

3. Specify the type of regions you want to import from the Files of Type drop-down list:
   - Choose Playlist File (.sfl) to import a Sound Forge regions/playlist file.
   - Choose Session 8 File (.prm) to import a file that supports both Session 8 and Sound Forge regions.
   - Choose Windows Media Script File (.txt) to import a Windows Media Format script table.
   - Choose Wave File (.wav) to import markers and regions from another sound file.

4. Click Open.
This chapter describes recording audio in Sound Forge and writing audio to CD. Sound Forge features several audio recording modes and options, including: recording new data, recording over existing data, and remote recording. In addition, this chapter presents a detailed description of Sound Forge’s track-at-once CD writing capabilities.

Protecting existing audio during recording

Prior to recording digital audio, you must understand that the Record and Record Remote dialogs are destructive and contain no Undo capabilities. To avoid accidentally recording over valuable audio data, all incoming audio should be recorded into a new data window and subsequently pasted into the desired data window.

Recording in Direct mode

To protect existing audio data, Sound Forge automatically creates a new window if you attempt to record audio while the current audio file is opened in Direct mode. For more information, see Direct mode on page 30.

Record dialog

Sound Forge’s Record dialog contains all controls relevant to recording incoming audio.

Displaying the Record dialog with no open data windows

To display the Record dialog when there are no open data windows, choose Record from the Special menu or click the Record (ether) button on the Transport toolbar.
Displaying the Record dialog with open data windows

To display the Record dialog when there are open data windows, go to the **Special** menu, choose **Transport**, and choose **Record** from the submenu or click the **Record ( )** button on the Transport toolbar.

To display the Record dialog:
- Right-click the workspace and choose **Record** from the shortcut menu.
- Press **Ctrl+R**.

Record dialog features

The Record dialog allows you to control and configure the application’s numerous recording parameters and features. The following section dissects the Record dialog to help you better understand and use the application’s recording features.

Displays

The Record dialog contains three informational displays: title bar, recording attributes, and recording time.

Title bar

The title bar displays the name of the data window into which incoming audio will be recorded.
Recording attributes

The upper-left corner of the Record dialog displays the current Recording attributes values: sample rate, bit depth, and channels. For more information, see File attributes on page 111.

Recording time

The lower portion of the dialog displays the Time recorded and Time left on drive fields.

Recording status

During recording, the Time Recorded value increases as the Time left on drive value decreases. Be especially aware of the Time left on drive value if your system’s storage space is limited.

Working with limited drive space

If the Time left on drive field is limited, you should attempt to create space on the current hard drive or select an alternate drive for the application to store temporary files.

Recording modes

You are able to specify any of five recording modes in the Record dialog’s Mode drop-down list. Sound Forge recording modes include the following:

• Automatic retake (automatically rewind).
• Multiple takes creating Regions.
• Multiple takes (no Regions).
• Create a new window for each take.
• Punch-In (record a specific length).
Automatic retake (automatically rewind)

Automatic retake mode is the easiest method of recording. Recording begins at the position displayed in the Start field when \(\text{REC} \) is clicked and continues until \(\text{STO} \) is clicked. Any existing data between the recording start and stop points is replaced. When recording is stopped, the start position is reset to the beginning of the take, allowing for immediate review and retake.

**Note:** Automatic Retake is the default mode when recording into an empty data window and when recording with no data selected in the current data window.

Multiple takes creating Regions

Multiple takes creating Regions mode allows several takes to be recorded with each take defining a region in the Regions List. Recording begins at the position displayed in the Start field when \(\text{REC} \) is clicked and continues until \(\text{STO} \) is clicked. Any existing data located between the recording start and stop points is replaced. When recording is stopped, the stop position becomes the start position for the next take, which can be recorded immediately. For more information, see *The Regions List* on page 127.

Multiple takes (no Regions)

Multiple takes (no Regions) mode also allows several takes to be recorded without these takes being defined as regions. Like the previous mode, recording starts at the position displayed in the Start field when \(\text{REC} \) is clicked and continues until \(\text{STO} \) is clicked. Any existing data located between the recording start and stop points is replaced. When recording is stopped, the stop position becomes the start position for the next take, which can be recorded immediately.
Create a new window for each take

Create a new window for each take is similar to Multiple takes creating Regions, but creates a new data window for each take. This is useful when recording audio data in which each take will be saved as an individual file.

Punch-In (record a specific length)

Punch-In mode is used to record over a specific selection in an existing data window. Specifying Punch-In activates the Start, End, and Length boxes. Recording begins at the position displayed in the Start box when \( \text{Start} \) is clicked and continues until one of the following occurs:

- The Stop (\( \text{Stop} \)) button is clicked.
- The cursor in the data window reaches the position displayed in the End box.
- The length of the recorded data equals the value in the Length box.

Punch-In mode makes it possible to record over a specific section of audio without the risk of affecting the remainder of the audio file. To assist you in determining punch-in values, the punch-in region can be previewed by clicking \( \text{Monitor} \).

**Note:** Punch-In is the default mode when recording with a selection in the data window.
Using pre/post-roll with Punch-In mode

Once a punch-in is recorded, you can audition it with user-configured pre-roll and post-roll to evaluate the performance.

1. Select the Review pre/post-roll check box. The two corresponding boxes are activated.
2. Enter appropriate pre-roll and post-roll values in their respective boxes.

3. Click \( \square \). The punch-in segment is played within the configured pre-roll and post-roll.

**Note:** Regardless of the data window’s current status format, pre-roll and post-roll values are measured in seconds.

**DC adjust**

DC adjust instructs the application to compensate for DC offsets generated by your system’s sound card during recording. A DC offset of approximately 30 dB is not uncommon for sound cards, even with very low noise floors and this is displayed in the record meter as -60 dB. This does not mean that the system is losing 30 dB of resolution, but for the meters to accurately display ranges to -90 dB, the DC adjust must be calibrated.
Calibrating the DC adjust

Prior to using the DC adjust feature, it must be calibrated for the selected recording device.

1. Select the DC adjust check box. The Calibrate button is activated along with displays labeled Left and Right.

2. Click the Calibrate button. Sound Forge listens to the selected recording device, calculates the offset, and displays the Left and Right offset values in sample amplitude.

Recalibration

In multiple sound card systems, DC adjust should be recalibrated each time a new recording device is selected. Certain sound cards must also be recalibrated each time the sample rate changes or when switching between mono and stereo recording.

**Note:** Recalibration can be performed at any time, even during recording. However, it is preferable to perform recalibration with silence at the record inputs.
Record dialog buttons

The Record dialog contains eight buttons located along its right-hand side.

The New button

Clicking the New button displays the New Window dialog and allows you to configure a new data window.

1. Click the New button.
2. Choose the sample rate from the Sample rate drop-down list. For more information, see Sample rate on page 112.
3. Select the desired Bit depth radio button. For more information, see Bit Depth on page 113.
4. Select the desired Channels radio button. For more information, see Channels on page 117.
5. Click OK. A new data window and Record dialog are created with the updated recording attributes.

The Close button

Clicking the Close button closes the Record dialog.
The Remote button

Clicking the **Remote** button places Sound Forge into Remote Recording mode. In this mode, the application's workspace is hidden and replaced with the Record Remote dialog. The Remote Record dialog remains the topmost window regardless of the number of open applications. Remote recording is particularly useful when using an application that controls the input source, such as a mixer, CD audio, or MIDI sequencing.

The Record Remote dialog is a condensed, fully functional version of the Record dialog.

**Accessing record features**

All features accessible from the Record dialog are available in the Remote Record dialog by right-clicking the title bar.

**Returning to the Sound Forge workspace**

Click the **Back** button to return to the Sound Forge workspace and the Record dialog.
The Help button
Clicking the Help button displays a Help window dedicated to the Record dialog.

The Go To button
Clicking the Go To button displays the Go To dialog and allows you to precisely specify the record Start position in a file.

1. Click the Go To button.
2. Establish the record Start position using one of the following methods:
   - Choose a preset from the Go To drop-down list.
   - Choose a format from the Input format drop-down list and enter an appropriate value in the Position box.

3. Click OK. The record Start position is established in the data window and displayed in the Start box.

Note: If there is not an active data window, the Go To button is not available.
The Selection button

The Selection button is only available in Punch-In mode and is used to fine-tune the punch region. When the Selection button is clicked, the Set Selection dialog is displayed.

![Set Selection dialog](image)

The Set Selection dialog features many of the same controls as the Record dialog, as well as a few that users may not be familiar with.

**Play**
Clicking the Play button plays the current selection.

**Play Loop**
Selecting the Play looped check box loops the current selection. Clearing this check box breaks the loop, turning the selection in a one-shot.

**Snap Time**
Clicking the Snap Time button forces the Start and End values of the selected area to a whole time division as designated by the markings on the data window's Time Ruler.

**Snap Zero**
Clicking the Snap Zero button forces the Start and End values of the selected area to the next zero-crossing of the waveform.
Zero-Crossing Preference
When using a Snap-Zero command, you can configure the application to snap to positive slope, negative slope, or either slope zero-crossings.

1. From the Options menu, choose Preferences. The Preferences dialog is displayed.
2. Click the Editing tab.
3. Choose the desired slope from the Snap to zero-crossing slope drop-down list and click OK.

The Window button
Clicking the Window button allows you to record to a data window other than the one currently displayed in the Record dialog title bar.

1. Click the Window button.
2. Choose the desired target data window from the Record destination window drop-down list and click OK.
The Sync button

Clicking the *Sync* button displays the Record Synchronization dialog and allows you to configure synchronization options for Sound Forge recording in conjunction with other devices or applications that respond to MIDI/SMTPE time code.

![Record Synchronization dialog](image)

Verifying the input and output devices

Prior to attempting synchronized recording, you must verify that the correct input and output devices are configured in Sound Forge.

1. From the *Options* menu, choose *Preferences*. The Preferences dialog is displayed.
2. Click the *MIDI/Sync* tab.
3. Verify that the correct input and output devices are selected in the *Input* and *Output* dropdown lists and click *OK*.

Selecting the SMPTE format

To configure the SMPTE format used in the Record Synchronization dialog, choose *Status Format* in the *Options* menu, and choose the desired format from the submenu.

Sending MTC/SMPTE to an output device

1. Select the *Enable MTC/SMPTE Output Synchronization* check box. The corresponding *Start* and *Pre-roll* check boxes are activated.
2. Select the *Start* check box and enter the starting value of the SMPTE code in the corresponding box.
3. If necessary, select the Pre-roll check box and use the corresponding box to specify how much SMPTE output will be generated prior to the recording start point.

4. Click the Back button. The Record dialog is displayed and Sound Forge is ready to record and output MTC/SMPTE code.

**Note:** When recording tracks from a tape deck that can perform a chase lock, the Pre-roll value can be used to compensate for the time the deck needs to rewind and begin chasing prior to the synchronization start time.
Receiving MTC/SMPTE from an input device

1. Select the Enable MTC/SMPTE Input Synchronization check box. The corresponding Start and End check boxes are activated.

2. Select the Start check box and enter the desired start recording time in the corresponding box.

3. Select the End check box and enter the desired end recording time in the corresponding box.

4. Click the Back button. The Record dialog is displayed.

5. Click the Prepare button. Sound Forge is armed and waiting for the record signal from the input device.

Record meters

The record meters allows you to verify and if necessary adjust the level of the input source prior to and during recording.

Viewing record levels

To view record levels, select the Monitor check box on the Record dialog. The meters illuminate in relation to the level of the incoming signal. For recording purposes, the incoming audio should remain primarily in the yellow, only occasionally entering the red. For more information, see Record level on page 164.

Scaling the record meters

Like the play meters, the record meters can be scaled to various dynamic ranges by right-clicking the meters and choosing the desired range from the shortcut menu. For typical recording situations, the -42 to 0 dB range is the most practical. However, when recording very low-level audio signals, you should consider the -90 to 0 dB range. Scaling the record meter to this range is also a good method of gauging the noise level in the system.
Show Labels
Choosing Show Labels from the shortcut menu toggles the record meter dB markings on/off.

Hold Peaks/Hold Valleys
You can also configure the Hold Peaks and Hold Valleys features in the shortcut menu.
- Choosing Hold Peaks displays a marker on the meters to indicate the highest reading.
- Choosing Hold Valleys displays a marker on the meters indicate the lowest reading.

For more information, see Record level on page 164.

Aggressive Update
Choosing Aggressive Update from the shortcut menu increases the priority of updating the meters. This results in more accurate metering, but increased CPU usage.

Record level

The peak values displayed above the record level meters are useful for maximizing the input level during recording. It is particularly important to record input signals as loud as possible when planning to decrease the bit depth. This maximizes the dynamic range.

However, the input signal must never exceed the range of values that can be recorded digitally. When the input signal exceeds the safe digital recording range, the waveform peaks are clipped, resulting in audible digital distortion.

Setting the record level
1. On the Record dialog, select the Monitor check box. Sound Forge begins listening to the recording device.
2. Apply the input signal to be recorded. The meters display levels relative to the input signal.
3. Slowly increase the level of the input signal until the peak value is the -6 dB range. If the peak reaches 0 dB, the wave is clipped and a Clip indicator is displayed above each meter.

If clipping occurs
1. Decrease the level of the input signal.
2. Right-click the meters and choose Reset Clip from the shortcut menu.
3. Repeat the previous procedure until the record level is maximized without clipping.
Record dialog toolbar

The Record dialog features a toolbar that allows you to navigate within the current record window.

Most of these buttons are familiar. The following table describes each briefly.

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Prepare</td>
<td>Prepares Sound Forge to begin recording. See “The Prepare button” on page 165.</td>
</tr>
<tr>
<td>Record</td>
<td>Begins recording incoming audio.</td>
</tr>
<tr>
<td>Drop Marker</td>
<td>Stops recording.</td>
</tr>
<tr>
<td>Play</td>
<td>Plays the file from the current position.</td>
</tr>
<tr>
<td>Go To Start of Take</td>
<td>Moves the Start position to the beginning of a take.</td>
</tr>
<tr>
<td>Go To End of Take</td>
<td>Moves the Start position to the end of a take.</td>
</tr>
<tr>
<td>Go To End of File</td>
<td>Moves the Start position to the end of the file.</td>
</tr>
<tr>
<td>Go To Start of File</td>
<td>Drops a marker. See “The Drop Marker button” on page 166.</td>
</tr>
</tbody>
</table>

The Prepare button

When is clicked, recording does not begin immediately. Sound Forge must perform a number of important functions prior to recording the input signal. The Prepare button is used to ready the application, allowing it to begin recording the instant is clicked. When the Prepare button is clicked the recording device is opened and all recording buffers are loaded. This ensures that the time lapse between clicking and actual recording is minimized.

Note: This feature is recommended when recording punch-ins. For more information, see Punch-In (record a specific length) on page 153.
The Record button

Clicking \( \text{ } \) initiates the recording of an incoming audio signal. When \( \text{ } \) is clicked, the following occur:

- \( \text{ } \) toggles to \( \text{ } \).
- A Recording message is displayed to the right of the toolbar. For more information, see Blinking status on page 167.
- The Time recorded value increments in the specified status format.
- Audio data is recorded into the data window indicated in the title bar.

Stop recording

Sound Forge records the incoming audio source until one of the following occurs:

- \( \text{ } \) is clicked.
- 2 Gb of data is recorded.

The Drop Marker button

Clicking \( \text{ } \) drops a marker in the data window during recording. The Markers to Regions function can then be used to convert these markers into regions. For more information, see The Markers to Regions command on page 135.

Other features

Gap detection

During recording, Sound Forge is continually listening for gaps (or drop-outs) that occasionally occur when working with digital audio. Depending upon the gap detection mode, Sound Forge will ignore the gap and continue recording, mark the gap and continue recording, or stop recording.
Configuring gap detection
To configure the gap detection mode, right-click the Record dialog, choose Gap Detection, and choose the desired gap detection mode (Ignore, Mark, or Stop) from the submenu.

Automatic labeling
The automatic labeling feature allows you to create custom window labeling and values and save them as defaults.

Displaying the Automatic Labeling dialog
To display the Automatic Labeling dialog, right-click the Record dialog and choose Automatic Labeling from the shortcut menu.

New window title prefix/New take prefix
The text in these boxes determines the labels displayed on new windows and takes. By default, the application labels new windows “Sound” and new takes “Take.”

Custom counter start value
The value in this box determines the starting numeric value used in conjunction with the prefix to identify windows and takes. By default, the application begins numbering with 1.

Insert leading zeros into field width of
The value in this box determines the number of zeros added in front of the window or take value. By default, the application adds two zeros prior to the counter value.

Blinking status
The Recording and Pre-Roll messages located to the right of the toolbar can be displayed within a flashing or solid red frame.
Changing the blinking status

To toggle between the blinking status settings, right-click the Record dialog and choose Blinking Status from the shortcut menu. A check mark displayed adjacent to the command indicates that the frame is configured to flash.

Extracting data from CD

Sound Forge allows you to extract 44,100Hz, 16-bit, stereo data from CD.

1. Insert a CD in the CD-ROM drive.

2. Choose Extract Audio from CD from the Tools menu. Sound Forge identifies the system’s CD-ROM drive(s). If the system is equipped with multiple CD-ROM drives, the desired drive must be selected from the Drive drop-down list.

   After the drive is selected, the Extract Audio from CD dialog is displayed and all tracks are listed.

   3. Specify the audio to be extracted using any of the following methods:
      - Select the Read by tracks radio button and select all desired tracks.
      - Select the Read entire CD radio button to extract all tracks.
      - Select the Read by range radio button and enter appropriate values in the Start and End (or Length) boxes.

   4. Select the Create regions for each track check box if desired. For more information, see Create regions for each track on page 169.
5. Select the Create markers for each index change check box if desired. For more information, see Create markers for each index change on page 169.

6. Click OK. Sound Forge begins extracting data from the CD and displays a progress meter.

**Note:** Upon completion, each extracted track is displayed in a unique data window at a zoom ratio of 1:1.

**Create regions for each track**

Selecting this option automatically adds each extracted track to that file's unique Regions List.

**Create markers for each index change**

Selecting this option automatically places markers in the extracted file at all points where indices occur in the original track.

**Previewing CD tracks**

Selecting a track and clicking **Play** allows you to preview tracks prior to extracting them from the CD. To stop the preview, click **Stop**.

**Refreshing the Extract Audio from CD dialog**

The **Refresh** button allows you to insert a new CD in the system's CD-ROM drive and view its contents without closing and re-opening the Extract Audio from CD dialog.

**Writing to CD**

Sound Forge allows you to write audio to CD without leaving the application if your system is configured with a supported CD-R/RW drive and the necessary drivers. Audio is written to CD using the track-at-once method, meaning that additional tracks can be added to the CD over a period of time. Once all desired tracks are added, the CD must be closed before it can be played in a consumer CD player. However, once a CD is closed, tracks can no longer be added.
Sample rates, bit-depths, and CD writing

Sample rates deviating from 44,100 Hz will cause CD track lengths to be miscalculated. When attempting to write a file to CD that deviates from the 44,100 Hz sample rate, Sound Forge will prompt you to change the sample rate. Selecting Yes will automatically resample audio to 44,100 Hz.

In addition, the Resample tool can be used to change the sample rate of a file prior to choosing the Create CD command. For more information, see Resample on page 235.

Writing mono tracks to CD

When attempting to write mono audio tracks to CD, Sound Forge will prompt you to create a stereo file by copying the mono data to both channels.

Adding a track to CD

You should always save your audio files prior to writing them to CD.

1. From the Tools menu, choose Create CD, and choose Add Track from the submenu. The Create CD dialog displays the length of the current audio file and the amount of time remaining on the CD currently in the CD-R/RW.

   **Note:** If there is no CD in the drive, only the Cancel button is available in this dialog. If a disc is inserted after this dialog is displayed, it will take a moment for Sound Forge to recognize the disc and make all options available.

2. Click the Add Audio button. Sound Forge begins writing audio to the CD and displays a progress meter in the dialog.

   **Note:** Clicking Cancel after the application begins writing to CD will render the CD unusable.

   After Sound Forge writes the audio to CD, the CD Operation dialog indicates whether the writing was successful.

3. Click OK.
Closing the CD

Closing the CD allows you to listen to it in an audio CD player. However, no additional tracks can be added to a CD once it is closed.

1. From the Tools menu, choose Create CD, and choose Close Disc from the submenu. The Create CD dialog displays the length of time remaining on the CD currently in the drive.

2. Click the Close Disc button. Sound Forge begins closing the CD and displays a progress meter in the dialog.

   After Sound Forge closes the CD, the CD Operation dialog indicates whether the closing was successful.

3. Click OK.
This chapter introduces some of Sound Forge's advanced editing and navigation features.

**Pre-roll to Cursor**

Many audio editing operations depend upon accurate placement of the cursor in the data window. The *Pre-roll to Cursor* command allows you to preview audio data leading up to the current cursor position. This command is extremely useful when recording punch-ins.

**Using Pre-roll to Cursor**

1. Place the cursor anywhere in the data window.
2. Choose *Pre-roll to Cursor* from the *Edit* menu or press `Ctrl + Shift + P`. Playback of the file starts at its beginning and stops at the cursor.

**Go To dialog**

The *Go To* command will display the Go To dialog and allow you to move the cursor to a specific point in an audio file and center it in the data window.
Displaying the Go To dialog

To display the Go To dialog, choose Go To from the Edit menu or do any of the following:

- Right-click the waveform display, choose Cursor, and choose Go To from the submenu.
- Double-click the left-most selection status field.
- Press Ctrl + G.

Using the Go To dialog

1. Display the Go To dialog.
2. Set the cursor position using one of the following methods:
   - Choose a preset from the Go To drop-down list.
   - Choose a format from the Input format drop-down list and enter an appropriate value in the Position box.
3. Click OK. The cursor is placed at the specified position in the data window.
Using the Set Selection dialog

For the sake of accuracy, it is often preferable to create selections by entering specific start and end point values. The Set Selection dialog allows you to create selections in this way or by choosing a preset selection from the Selection drop-down list.

Creating a selection

1. From the Edit menu, choose Selection, and choose Set from the submenu or press Ctrl+D. The Set Selection dialog is displayed.

2. Choose the format to be used for creating the selection from the Input format drop-down list. The values in the Start, End, and Length boxes are changed to reflect the specified format.

3. Configure the selection by entering appropriate values in the Start and End or the Start and Length boxes.

4. If you are working with a stereo file, choose Left, Right, or Both from the Channel drop-down list.

5. Click OK.

Other Set Selection dialog controls

The following sections briefly describe additional controls located in the Set Selection dialog.

Play

Clicking Play will play the current selection.
Play Looped
Selecting the Play looped check box loops the current selection. Clearing this check box breaks the loop, turning the selection into a one-shot.

Snap Time
Clicking Snap Time forces the Start and End values of the selected area to a whole time division as designated by the markings on the data window’s Time Ruler.

Snap Zero
Clicking Snap Zero forces the Start and End values of the selected area to the next zero-crossing of the waveform.

Zero-Crossing Preference
When using a Snap-Zero command, you can configure the application to snap to positive slope, negative slope, or either slope zero-crossings.

1. From the Options menu, choose Preferences. The Preferences dialog is displayed.
2. Click the Editing tab.
3. Choose the desired slope from the Snap to zero-crossing slope drop-down list and click OK.

Using Mark In/Mark Out

Sound Forge allows you to create selections during playback using the Mark In and Mark Out commands. These commands place temporary virtual markers in the data window, which are then used to create the selection. They can be placed by choosing Mark In and Mark Out from the Special menu, however their keyboard equivalents are more useful.

Creating selections during playback

1. Play the audio file in the current data window.
2. During playback, press ⊞ (Mark In). An In point is placed in the data window.
3. Press ⊠ (Mark Out). An Out point is placed in the data window and a selection is created using the In and Out points.

Note: The In and Out points can be placed during separate playbacks.
Fine-tuning selection points

After creating a selection, you may discover that the start or end point has not been positioned properly. In cases like this, you can try to reselect the data, but it difficult to accurately create selection points. For this reason, Sound Forge provides a number of tools designed to help you fine-tune selections.

Tuning a selection with the mouse

Selection start and end points can be fine-tuned using the mouse by dragging the edge of the selection to a new location.

1. Open a .wav file and create a selection in the waveform.
2. Position the mouse pointer over one of the selection edges. The pointer is displayed as a bi-directional arrow.
3. Drag the selection edge to a new position.
4. Release the mouse button. The selection is automatically updated.

Auto snaps

If, when extending a selection, the end points seem to “jump” to a different position, one of the application’s Auto Snap option is turned on.

Auto Snap to Time

Auto Snap to Time ensures that all start and end points reside on whole time divisions. To turn on/turn off this option, choose Auto Snap to Time from the Options menu. A check mark is displayed adjacent to the menu command to indicate that the option is turned on.
Auto Snap to Zero

Auto Snap to Zero ensures that all start and end points reside on zero-crossings. To turn on/turn off this option, choose Auto Snap to Zero from the Options menu. A check mark is displayed adjacent to the menu command to indicate that the option is turned on.

To enable/disable Auto Snap to Zero, press Ctrl+B.

Current selection Auto Snap to Zero

To temporarily force a selection to snap to zero-crossings, go to the Edit menu, choose Selection, and choose Snap to Zero from the submenu.

To temporarily turn on Auto Snap to Zero, press Z.

Disabling Auto Snap to Zero at high magnifications

When editing an audio file displayed at a high magnification, you may wish to turn off the Auto Snap to Zero option. This allows you to position a selection’s start and end points exactly where you choose.

1. From the Options menu, choose Preferences. The Preferences dialog is displayed.
2. Click the Editing tab.
3. Select the Disable auto-snapping below 1:4 zoom ratios check box and click OK.

Tuning a selection with the keyboard

Using the keyboard, you can quickly and accurately select data or update a selection. The following tables describe various keyboard commands for selecting data.

<table>
<thead>
<tr>
<th>Press...</th>
<th>To select from the cursor to...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Shift + →</td>
<td>The next screen pixel.</td>
</tr>
<tr>
<td>Shift + ←</td>
<td>The previous screen pixel.</td>
</tr>
<tr>
<td>Shift + End</td>
<td>The last sample visible in the waveform display.</td>
</tr>
<tr>
<td>Shift + Home</td>
<td>The first sample visible in the waveform display.</td>
</tr>
</tbody>
</table>
If there are regions, markers, or loops in the data window:

<table>
<thead>
<tr>
<th>Press...</th>
<th>To select...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Shift + Page Up</td>
<td>10% of the current view past the cursor position.</td>
</tr>
<tr>
<td>Shift + Page Down</td>
<td>10% of the current view prior to the cursor position.</td>
</tr>
<tr>
<td>Shift + Ctrl + [</td>
<td>2% of the current view past the cursor position.</td>
</tr>
<tr>
<td>Shift + Ctrl + [</td>
<td>2% of the current view prior to the cursor position.</td>
</tr>
<tr>
<td>Shift + Numpad [</td>
<td>The next sample. Note: this shortcut will not work in Windows 95 or 98</td>
</tr>
<tr>
<td>Shift + Numpad [</td>
<td>unless the “Num Lock” indicator on the keyboard is illuminated.</td>
</tr>
<tr>
<td>Shift + Ctrl + Numpad +</td>
<td>10 samples past the current position.</td>
</tr>
<tr>
<td>Shift + Ctrl + Numpad -</td>
<td>10 samples prior to the current position.</td>
</tr>
</tbody>
</table>

If there are regions, markers, or loops in the data window:

<table>
<thead>
<tr>
<th>Press...</th>
<th>To select from cursor to...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Shift + Ctrl + [</td>
<td>The next region start/end or marker.</td>
</tr>
<tr>
<td>Shift + Ctrl + [</td>
<td>The last region start/end or marker.</td>
</tr>
</tbody>
</table>

**Restoring a selection**

If during editing, a selection is lost, it can be restored by choosing **Toggle Selection** from the **Special** menu or by pressing [S].
The Overview

When navigating or editing a file, the appearance of the data window's Overview changes to reflect the current position in the file.

![Overview Diagram]

The Overview represents the length of the entire file, zoomed out to its maximum position. By observing the Overview, you can determine the following:

- The section of the audio file currently displayed in the data window.
- The location and size of a selection in relation to the audio file and data window.
- The current cursor location.

Understanding the Overview

1. Open the Tutor1.wav file and verify that the waveform display is zoomed completely out (1:512 in this case).

![Waveform Display]

Notice that the entire Overview is bracketed, indicating that the entire file is displayed in the data window.
2. Place the mouse pointer over the word “Wow,” and click. A small vertical marker, representing the cursor, is displayed in the Overview.

3. Create a selection containing the word “Wow.” A shaded block, sized in relation to the size of the selection within the entire audio file, is displayed in the Overview.

4. Click the Zoom In ( ) button twice. The bracketed area in the Overview becomes incrementally smaller as less of the waveform is displayed in the data window.

However, the selection remains the same size and does not move. This allows you to quickly locate a selection, even when another section of an audio file is displayed.
Navigating in the Overview

1. Open the Tutor1.wav file.
2. Zoom in to a 1:32 zoom ratio.
3. Click outside the bracketed region in the Overview.

The cursor position changes, but the actual cursor is located beyond the scope of the data window.

4. Double-click anywhere in the Overview.

The cursor position is updated and centered in the data window.

Playback in the Overview

To make navigating a file from the Overview easier, Sound Forge allows you to start audio playback from the Overview.

1. Open the Tutor1.wav file.
2. Right-click in the Overview. Playback of the file begins from the cursor location.
3. Right-click again in the Overview. Playback is paused.
4. Right-click in the Overview once more and immediately left-click at several random positions in the Overview. Each time the mouse is clicked in the Overview during playback, the cursor jumps to the new location and playback continues. The feature is useful for quickly navigating a file and locating general events.
Audio event locator

Dragging the mouse within the Overview initiates playback of small audio loops adjacent to the cursor position. This is not technically a scrub function, but it serves a similar purpose. It allows you to audition brief segments of audio and quickly locate specific events within a file.

Editing the audio event locator loop

1. From the Options menu, choose Preferences. The Preferences dialog is displayed.
2. Click the Other tab.
3. Edit the Pre-roll and Loop time values as desired and click OK.

Views

Views are used to save and recall selections, zoom ratios, and waveform display positions. Sound Forge is able to retain eight different views for any audio file, each containing the following elements:

- A selection.
- Cursor position.
- Magnification.
- Position scroll bar placement.

Note: Views are discarded when the file is saved or closed.

Displaying the Views toolbar

1. From the View menu, choose Toolbars.
2. Select the Views check box and click OK. The Views toolbar is displayed.
Creating views

1. Open the Tutor1.wav file and create a selection containing “Wow.”

2. Click SET on the Views toolbar. A view can now be created.

3. Click 1. The selection is saved as view 1 and 1 is underscored to indicate that a view was created.

4. Create a new selection anywhere in the audio file, preferably at an increased magnification.

5. Click SET followed by 2. The selection is saved as view 2.

6. Click 1. The view 1 selection is displayed.

7. Click 2. The view 2 selection is displayed.

Paste Special

Earlier in this manual, the Paste and Mix commands were described as ways of adding clipboard contents to the current data window. As your audio editing projects become more elaborate, you may discover the need for three more sophisticated Paste commands: Crossfade, Overwrite, and Replicate.
Crossfade

Crossfading is a variation on pasting that is used to join two selections of audio data that would be awkward or distracting if pasted together. In crossfading, the destination data decreases in volume (fades out) as the source data increases in volume (fades in). Think of the crossfade as the audio equivalent of the filmmaker’s dissolve.

1. Open the Tutor1.wav and Tutmusic.wav files.
2. Select all data in the Tutor1 data window.
3. Place the cursor at the approximate middle of the Tutmusic data window. This is where the crossfade will begin.
4. From the Edit menu, choose Paste Special, and choose Crossfade from the submenu. The Crossfade dialog is displayed.

   ![Crossfade](image)

   The Crossfade dialog can also be displayed by right-clicking on the data window and choosing Crossfade or by pressing Ctrl+P.

5. Choose Normal crossfade from the Name drop-down list and click OK.
6. Play the Tutmusic.wav file. Notice that the volume of the music bed decreases while the voice-over volume increases.

Overwrite

The Overwrite command allows you to replace the current selection with the contents of the clipboard. The application performs overwriting with two basic guidelines:

- If the selection is longer than the clipboard contents, data is overwritten from the beginning of the selection for the length of the clipboard contents only. The remainder of the selection will remain in the data window.
- If the clipboard contents are equal to or longer than the selection, data is overwritten for the length of the selection only.

Overwriting a selection

1. Open the Tutor1.wav file.
2. Create a selection containing the “Wow.”
3. Copy the selection. The data is placed on the clipboard.
4. Create a selection of approximately the same length containing the final “…and easier.”

5. From the **Edit** menu, choose **Paste Special**, and choose **Overwrite** from the submenu or right-click the data window and choose **Overwrite** from the shortcut menu. The selection is overwritten with the clipboard contents.

   ![Copy the selection](image1)
   ![Create a second selection](image2)
   ![Overwrite the selection](image3)

**Note:** If any of the selection data remains, it is because the length of the clipboard contents was less than the length of the selection.

**Replicate**

The **Replicate** command allows you to overwrite a selection with several copies of the clipboard contents. When using the **Replicate** command, you must specify whether Sound Forge will use partial copies of the clipboard contents or only complete copies.

- Allowing the application to use partial copies of the clipboard content will completely overwrite the selected area.
- Forcing the application to use complete copies of the clipboard content will prevent a portion of the selection from being overwritten unless the selection length is an exact multiple of the length of the clipboard contents.
Replicating a selection

1. Open the Tutor1.wav file.
2. Create a selection containing the “Wow.”
3. Copy the selection. The data is placed on the clipboard.

4. Create a selection containing “Sound editing just get easier...”
5. Choose Paste Special from the Edit menu and choose Replicate from the submenu. The Replicate dialog is displayed.
6. Select the Copy partials radio button and click OK. The selection is overwritten with multiple copies of the clipboard contents. A partial copy of the clipboard contents is used where appropriate.
Drag and drop operations

Up to this point in the manual, audio editing operations were described using menu commands and toolbars. Once familiar with the program's editing capabilities, you should begin to take advantage of the application's drag-and-drop operations. Drag-and-drop operations make controlling Sound Forge faster and more intuitive. In addition, they allow for increased editing power. The three major drag-and-drop editing operations are Paste, Mix, and Crossfade.

Dragging mono selections into stereo destinations

When pasting, mixing, or crossfading a mono selection into a stereo file, you can mix the selection to both channels by dropping it on the destination data window's centerline. Otherwise, the selection will be mixed into the left or right channel exclusively.

Snapping to events in drag-and-drop operations

A major advantage of drag-and-drop editing is the ability to snap to markers, regions, time increments, or other events in the destination window. All drag-and-drop operations can be configured to snap (or align) to points in the destination file based on the events established within that file.

The following table describes all events that drag-and-drop selections will snap to in the destination file.

<table>
<thead>
<tr>
<th>Event Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cursor</td>
<td>Start of block snaps to cursor position.</td>
</tr>
<tr>
<td>Selection</td>
<td>Start of block snaps to start or end points of a selection.</td>
</tr>
<tr>
<td>Start</td>
<td>Start of block snaps to start of file.</td>
</tr>
<tr>
<td>End</td>
<td>Start of block snaps to end of file.</td>
</tr>
<tr>
<td>Markers</td>
<td>Start of block snaps to marker.</td>
</tr>
<tr>
<td>Regions Start and End Markers</td>
<td>Start of block snaps to region start or end.</td>
</tr>
<tr>
<td>Time, Measures, etc.</td>
<td>Start of block snaps to labeled divisions on Time Ruler.</td>
</tr>
<tr>
<td>Video Frames</td>
<td>Start of block snaps to the start of video frames appearing in the video strip.</td>
</tr>
</tbody>
</table>
Drag-and-drop pasting

1. Open the Tutor1.wav and Tutor2.wav files.
2. Select all audio data in Tutor2.wav.

3. Hold the **Alt** key and drag the selection to the Tutor1 data window.
   - A vertical dotted line representing the leading edge of the source selection is displayed in the destination window.
   - The letter “P” is displayed in the box adjacent to the pointer.

4. Use the mouse to position the shaded region in the destination window where the source data will be pasted.
5. Release the mouse button. The selection is pasted into the destination window and all data is adjusted accordingly.

Drag-and-drop mixing

1. Open the Tutor1.wav and Tutor2.wav audio files.
2. Select all audio data in the Tutor2 data window.
3. Drag the selection to the Tutor1 data window.
   - A shaded region representing the source selection is displayed in the destination window.
   - An “M” is displayed in the box adjacent to the pointer.

4. Position the leading edge of the shaded region in the Tutor1 data window where the mixing of the selection will begin.
5. Release the mouse button. The Mix dialog is displayed.
6. Verify that both Volume levels are set to 0 dB and click OK.
Drag-and-drop crossfading

1. Open the Tutor1.wav and Tutmusic.wav files.
2. Select all data in the Tutor1 data window.
3. Hold the Ctrl key and drag the selection to the destination window.
   - A shaded cross (or bowtie) region representing the source selection is displayed in the destination window.
   - A “C” is displayed in the box adjacent to the pointer.
4. Align the right edge of the shaded region with the right edge of the data in the destination window.
5. Release the mouse button. The Crossfade dialog is displayed.
6. Specify the desired crossfade in the Name drop-down list and click OK. The selection is crossfaded into the destination data and the file is adjusted accordingly.
Mix/Paste/Crossfade toggle

An alternative way of specifying a Mix, Paste, or Crossfade is the mouse toggle method.

1. Open the Tutor1.wav and Tutor2.wav files.
2. Select all audio data in the Tutor2 data window.
3. Drag the selection to the Tutor1 data window.
   - A shaded region representing the source selection is displayed in the destination window.
   - A letter is displayed in the box adjacent to the pointer.
4. Continue holding the left mouse button while clicking the right mouse button. The letter in the box and the appearance of the selection region change to indicate the current drag-and-drop mode.
5. Release the left mouse button. The source audio data is pasted, mixed, or crossfaded into the destination data and the file is adjusted accordingly.

Creating a new window with drag-and-drop operations

Drag-and-drop operations also allow you to easily create a new data window from a selection.

1. Open the Tutor1.wav file.
2. Create a selection containing the word “Wow.”
3. Drag the selection to an empty area of the Sound Forge workspace and drop it. A new data window containing the selection data with the attributes of the original file is created.

Finding and repairing audio glitches

Glitches are commonly the result of analog audio editing, analog to digital transfer, or electronic noise. Sound Forge provides you with a tool for locating audio glitches and three distinct tools for repairing them: Channel, Interpolate, and Replace. In addition, you can also use the Sound Forge’s Pencil tool to manually repair audio glitches.
Using the Find tool to locate glitches

The Find tool allows you to quickly locate glitches, specific volume levels, or silence in a file. The Find tool's glitch algorithm locates glitches by examining the file for instances where the waveform matches the specified Threshold slope and Sensitivity criteria. The cursor is then moved to the location of the glitch to allow you to repair it. This tool will only locate one glitch at a time. Therefore, it may be necessary to execute this command several times on a file to locate all glitches.

1. Open any audio file containing glitches.
2. Choose Find from the Tools menu. The Find dialog is displayed.
3. Choose Glitch from the Find drop-down list. The Threshold slope and Sensitivity faders are available.
4. Use the Threshold slope fader to configure the minimum slope that will constitute a glitch.
   • A high value will detect only glitches with steep slopes.
   • A lower value will detect glitches with both steep and more gradual slopes.
5. Use the Sensitivity fader to determine the sensitivity of the detection algorithm.
   • A high value will result in any part of the waveform with a slope greater than the Threshold slope being detected as a glitch.
   • A lower value will force the algorithm to verify that the slope is indeed a glitch, and not simply a portion of the smooth waveform.
6. Click OK. The Find tool locates the first glitch in the file and marks its location with the cursor.

Note: If you can hear glitches in the audio, but the Find tool cannot locate them, decrease the Threshold slope and increase the Sensitivity.
Repairing audio using Copy Other Channel

The Copy Other Channel tool allows you to repair glitches in a single channel of a stereo file. This is accomplished by replacing the glitched section of damaged channel with the corresponding data from the “good” channel.

1. Open the stereo file containing the glitch.
2. Create a selection in the channel containing the glitch, three or four times longer (maximum 50 ms) than the glitch itself.
3. From the Tools menu, choose Repair, and choose Copy Other Channel from the submenu. The selected data is replaced with the corresponding data from the “good” channel. In addition, rapid crossfades are created at the beginning and end of the replacement selection to prevent a new glitch from being created.

Note: If this method fails to repair the glitch, undo it and apply Copy Other Channel again, this time using a longer selection.
Repairing audio using Interpolate

This is the most basic method of repairing glitches. The application simply interpolates new audio data based on the data at the beginning and end of the selection. This method results in a straight line being created to connect the beginning and end of the selection. Interpolation should only be used to repair small (less than 2ms) glitches.

1. Open the file containing the glitch.
2. Right-click on the data window and choose **Zoom In Full** from the shortcut menu. The file is displayed at a 1:1 zoom ratio.
3. Create a selection containing the glitch.
   
   **Note:** To improve the accuracy of this feature, the selection should be made as small as possible while still containing the glitch.

4. From the **Tools** menu, choose **Repair**, and choose **Interpolate** from the submenu. The application replaces the glitch data with interpolated data.
Repairing audio using Replace

The Replace tool allows you to repair audio files by replacing the damaged data with the data immediately preceding it. This repair method is useful for repairing longer glitches such as needle drops and scratches.

1. Open the file containing the glitch.
2. Create a 5 to 50 ms selection containing the damaged audio.

   **Note:** The maximum allowed replace time is 0.5 seconds.

3. From the Tools menu, choose Repair, and choose Replace from the submenu. The selection is replaced with the selection of identical length immediately preceding the damaged data. In addition, rapid crossfades are created at the beginning and end of the replacement selection to prevent a new glitch from being created.
Repairing audio with the Pencil tool

The Pencil tool is provided for users who prefer to repair their audio glitches manually. This tool allows you repair waveform glitches by redrawing the damaged waveform section. However, the Pencil tool can only be used when a file’s waveform is displayed at a zoom ratio between 1:1 and 1:16.

1. Open the file containing the glitch.
2. Right-click the data window and choose **Zoom In Full** from the shortcut menu. The file is displayed at a 1:1 zoom ratio.
3. Select the **Pencil** tool using any of the following methods:
   - From the **Edit** menu, choose **Tool**, and choose **Edit** from the submenu.
   - Click the **Pencil** button in the **Standard** toolbar.
   - Click the tool icon in the top-left corner of the data window until the **Pencil** tool is displayed.
4. Place the **Pencil** tool in the waveform, prior to the glitch in the audio.
5. Use the mouse to draw a new waveform section.
6. Release the mouse button. The new section is integrated into the original waveform, replacing the section containing the glitch.
Audio Plug-In Chainer

The Audio Plug-in Chainer is a DirectX plug-in that allows you to create a chain of multiple DirectX plug-ins. In addition, each plug-in in the chain can be previewed simultaneously in real time as long as your computer has adequate processing power.

Using the Audio Plug-In Chainer

1. Open an audio file and select the data to be processed.
2. From the Tools menu, choose Audio Plug-In Chainer. The Audio Plug-In Chainer dialog is displayed.
3. Choose the desired preset from the Name drop-down list or add the desired plug-ins to a custom chain. For more information, see Adding a plug-in to a chain on page 199.
4. Configure the parameters of each plug-in.
5. Click OK.
Adding a plug-in to a chain

1. Click ![Plug-In Chooser](image). The Plug-In Chooser dialog is displayed, listing all available DirectX plug-ins installed on your system.

2. Select the desired plug-in(s).

3. Click ![Add](image). The selected plug-ins are added to the chain and can be configured and arranged as needed.

   ![Double-click the desired plug-in to add it to a chain](image)

Arranging plug-ins on a chain

From the Plug-In Chooser, you can rearrange the chain by selecting a plug-in and clicking ![Forward](image) and ![Backward](image) to move it forward/backward in the chain.

---

**Note:** The order that plug-ins are placed on a chain can have a dramatic effect on the final product of audio signal processing.

---

Bypassing a plug-in on a chain

To bypass a plug-in, clear its check box in the Plug-In Chainer dialog. A bypassed plug-in does not process the audio signal, thereby allowing you to preview the effect of the remaining plug-ins.

---

**Note:** Multiple plug-ins can be bypassed.
Soloing a plug-in on a chain
To solo a specific plug-in, bypass all other plug-ins on the chain.

Deleting plug-ins from a chain
To delete a specific plug-in from a chain, select it and click \( \text{X} \). The selected plug-in will be removed and the remaining plug-ins adjusted accordingly.

Configuring chained plug-ins
To configure the parameters of specific plug-in, select it from the chain. The plug-in’s dialog will be displayed, allowing you to adjust all controls as needed.

Saving a plug-in chain
1. Click Save As. The Save Preset dialog is displayed.
2. Enter a name for the preset and click OK.

Audio synthesis
Sound Forge allows you to generate custom tones and waveforms for use in your audio projects. The Synthesis submenu of the Tools menu contains the application’s three audio synthesis features: DTMF/MF Tones, FM, and Simple.
DTMF/MF Tones

Choose Synthesis from the Tools menu, and choose DTMF/MF from the submenu to display the DTMF/MF Tone dialog. This dialog is used to generate standard dial tones used by telephone companies.

1. From the Tools menu, choose Synthesis, and choose DTMF/MF from the submenu. The DTMF/MF Tones dialog is displayed.

2. Enter the phone number to be generated in the Dial string edit box, including pause characters.

   Note: Unknown characters will be ignored.

3. Use the Amplitude fader to set the peak level of the waveform.

4. Select the Tone style to generate radio button corresponding to the tone to be generated.
   - DTMF (Dual Tone Multi-Frequency) signals are used by standard push-button telephones and are generated using combinations of 679-, 770-, 852-, 941-, 1209-, 1336-, 1477-, and 1633-Hz sine waves.
   - MF signals are used internally by the telephone networks and are generated with a combination of 700-, 900-, 1100-, 1300-, 1500-, and 1700-Hz sine waves.

5. Specify the output length (in seconds) of each tone in the Single tone length box.

6. Specify the length (in seconds) of silence between tones in the Break length box.

7. Specify the pause length (in seconds) that will be inserted when the pause character is encountered in the Pause length box.
8. Specify the pause character in the Pause character box.
9. Select the Fade the edges of each tone check box to help prevent glitching.
10. Use the Insert new tone sequence at drop-down list to specify where the generated tone will be placed in the audio file.
11. Click OK.

**FM**

Sound Forge's FM Synthesis feature can be used to create complex sounds from simple waveforms using frequency modulation (FM). Choose Synthesis from the Tools menu, and choose FM from the submenu to display the FM Synthesis dialog.

In frequency modulation, the frequency of a waveform (carrier) is modulated by the output of another waveform (modulator) to create a new waveform. If the frequency of the modulator is low, the carrier will be detuned slowly over time. If the frequency of the modulator is high, the carrier will be modulated so quickly that numerous additional frequencies (or sidebands) will be created.

Using the FM Synthesis tool, up to four waveforms (operators) can be used in a variety of configurations. Depending on the configuration, a waveform can be a carrier, a modulator, or a simple, unmodulated waveform.
Generating a waveform

1. From the **Tools** menu, choose **Synthesis**, and choose **FM** from the submenu. The FM Synthesis dialog is displayed.

2. Specify the length (in seconds) of the generated waveform in the **Total output waveform length** box.

3. Use the **Configuration** slider to configure the arrangement and number of operators used to generate the waveform. For more information, see Specifying the number and arrangement of operators on page 204.

4. Modify individual operators as needed. For more information, see Modifying an operator on page 204.

5. Choose a position from the **Insert waveform at** drop-down list to determine where the generated waveform will be placed in the file.

6. Click **OK**.
Specifying the number and arrangement of operators

Dragging the Configuration slider changes the graphical representation of the arrangement and number of operators used to generate the waveform. When configuring your waveform, keep the following guidelines in mind:

- The outputs of horizontally joined operators are simply mixed. The outputs of the bottom operators are mixed to form the final output. Mixing unique simple waveforms is referred to as additive synthesis.
- Operators joined vertically are FM carrier-modulator pairs. The bottom operator is the carrier and the top operator is the modulator.
- Operators without other operator directly above are simple waveform generators.
- When three or more operators are stacked, the top operator modulates the operator below it, which modulates the following operator, and so on.

Modifying an operator

1. Select the Current operator radio button corresponding to the operator to be modified.
2. Use the envelope graph to modify the amplitude of the operator over time. For more information, see Envelope graphs on page 62.
3. Choose a waveform shape from the Operator shape drop-down list.
4. Specify the frequency of the operator in the Frequency box.

**Note:** When Noise is chosen from the Operator shape drop-down list, the Frequency value determines the high-frequency content of the noise. For full-bandwidth (white) noise, set Frequency to its highest possible setting.

5. Use the Feedback slider to determine the amount of the operator’s output that is used to modulate itself. If the operator is also being modulated by another waveform, the feedback path and the modulator output are mixed together to modulate the carrier.
6. Use the Amplitude fader to determine the output gain that will be applied to the current operator after the amplitude envelope.

**Note:** If the operator is a modulator, this control (along with the envelope) determines the amount of frequency modulation applied to the carrier. If the amplitude of a modulator is high, harsh audio may result.
Simple Synthesis tool is used to generate simple waveforms of a given shape, pitch, and length. Choose Synthesis from the Tools menu, and choose Simple from the submenu to display the Simple Synthesis dialog.

Generating a simple waveform

1. From the Tools menu, choose Synthesis, and choose Simple from the submenu. The Simple Synthesis dialog is displayed.

2. Choose a shape from the Waveform shape drop-down list to specify the shape of a single period of the current operator's waveform.

3. In the Length box, specify the length (in seconds) of the generated waveform.

4. In the Frequency box, specify the frequency of the waveform.

5. Use the Amplitude fader to set the peak level of the waveform.

Note: When Noise is specified in the Waveform shape drop-down list, the amplitude is affected by the specified cutoff frequency.

6. Choose a position from the Insert new waveform at drop-down list to determine where the waveform will be placed in the data window.

7. Click OK.
This chapter provides descriptions of function presets and previews as well as an overview of all functions in the Sound Forge Process menu.

Presets

Many of the application's dialogs contain drop-down lists of presets used to quickly apply processes and effects. Presets are especially useful when learning Sound Forge, as they allow you to hear the results as well as view the control settings used to produce these results.

Note: All information regarding presets in this chapter is applicable to Sound Foundry’s DirectX Plug-Ins.

Using a preset

1. Open the Tutor1.wav file.
2. From the Process menu, choose Fade, and choose Graphic from the submenu. The Graphic Fade dialog is displayed.
3. Choose the -20dB exponential fade out preset from the Name drop-down list. Notice that the dialog's controls are changed to reflect the -20dB exponential fade out.
4. Click the Preview button. The following occur:
   • The Preview button changes to a Stop button.
   • The effect is previewed on a brief selection of audio.

For more information, see Previewing an operation on page 210.
5. Choose the -3dB exponential fade out preset from the Name drop-down list. Notice that the dialog's controls are updated to reflect the new preset and it is automatically previewed.
6. Select the Bypass check box. The original audio, with effects removed, is previewed. For more information, see The Bypass check box on page 212.

7. Clear the Bypass check box and click OK. The -3dB exponential fade out preset is applied to the audio file.

---

Note: An effect or process is not applied to the audio data until OK is clicked.

Creating presets

You can also create custom effects and save them as presets.

1. Open the Tutor1.wav file.

2. From the Process menu, choose Fade, and choose Graphic from the submenu. The Graphic Fade dialog is displayed.

3. Choose the -3db exponential fade out preset from the Name drop-down list. The dialog's controls are changed to reflect the preset.

4. Drag any of the graphic fade points to a new position.

5. Click Save As. The Save Preset dialog is displayed.

6. Enter a name for the preset and click OK. The new preset is saved and will now be available in the dialog's drop-down list.
Deleting presets

To delete a preset, choose it from a drop-down list and click Delete.

Resetting parameters

To reset all dialog controls to their default settings, right-click the dialog and choose Reset All from the shortcut menu.

Using the Preset Manager

Sound Forge's Preset Manager allows you to save, back up, and transfer presets from any of the effects, processes, tools and plug-ins installed in the application. To display the Preset Manager, choose Preset Manager from the Tools menu.

Viewing available presets

The Preset pane contains tree views of all presets in your Sound Forge installation. Presets are organized by menu, followed by function. Clicking + will expand a list, while clicking − will collapse a list.

Opening a preset package

To open a preset package, click Open and import the presets from an existing preset package (.sfz) file into your installation of Sound Forge.

Editing presets

Double-clicking a preset or selecting a preset and clicking Settings will open a temporary dialog for the selected function which can be used to edit and create presets.
Adding a preset to a package
To add a preset to a package, select the desired preset in the Presets pane and click the Add button. The preset is added to the Preset package contents pane and will be saved in the preset package (.sfz) file.

Deleting a preset from a package
To remove a preset from a package, select the desired preset in the Preset package contents pane and click the Delete button. The preset is removed from the package and will not appear after you save the preset package (.sfz) file.

Saving a preset package
To save all presets in the Preset package contents pane as a preset package (.sfz) file, click Save As. Preset package files can be transported to other installations of Sound Forge or backed up for future use.

Previewing an operation
The effect a process will have on a file can be previewed using the Preview button. This button is found in most audio processing dialogs. Previews are used to fine-tune effect parameters without leaving the dialog and more importantly, they reduce wasted processing time.

Previews
Previews feature editable parameters designed to satisfy your editing preferences.

Storing preview parameters
Prior to editing preview parameters, you must first decide if the new parameters will be used only for the current function or stored and used for all functions.

Current preview editing
1. Right-click the dialog and choose Configuration from the shortcut menu. The Preview Configuration dialog is displayed.
2. Edit the preview parameters as desired. For more information, see Preview parameters on page 211.
3. Click OK. The preview parameters are updated and retained until the current dialog is closed.
Permanent Preview Editing

1. From the **Options** menu, choose **Preferences**. The Preferences dialog is displayed.

2. Click the **Previews** tab.

3. Edit the preview parameters as desired. *For more information, see Preview parameters on page 211.*

4. Click **OK**. The preview parameters are updated for all effects and saved.

Preview parameters

The following sections briefly describe the configurable parameters located in the **Previews** tab.

**Limit previews to**
Selecting the **Limit previews to** check box allows you to specify the preview length by entering a value in the corresponding box.

**Pre-roll**
Selecting the **Pre-roll** check box allows you to specify how many seconds of unprocessed audio are played prior to the processed selection.

**Post-roll**
Selecting the **Post-roll** check box allows you to specify how many seconds of unprocessed audio are played following the processed selection.

---

**Note:** **Pre-roll** and **Post-roll** can be toggled on/off by right-clicking the dialog and choosing the appropriate command from the shortcut menu.

---

**Fade out last 10 milliseconds**
Selecting the **Fade out last 10 milliseconds** check box fades the last 10 milliseconds of a preview. This will typically eliminate the pops that occasionally accompany the end of a preview buffer.

**Loop preview continuously**
Selecting the **Loop preview continuously** check box plays the preview in an infinite loop.
Reactive previewing

Selecting the Reactive previewing check box allows you to update previews in real time by manipulating the dialog's controls.

**Note:** When Reactive Previewing is active, holding **Shift** while editing parameters suspends automatic preview generation until the key is released.

The Bypass check box

You are also able to A/B test an effect by using the Bypass check box to switch between previewing the processed and unprocessed audio file.

- When the Bypass check box is selected, Sound Forge plays the unprocessed audio file when you click the **Preview** button.
- When the Bypass check box is cleared, Sound Forge plays the processed audio file when you click the **Preview** button.

Repeating an operation

Once a function is applied to an audio file, it can be quickly reapplied with the exact parameters by choosing **Repeat** from the **Edit** menu.

**Note:** In the **Edit** menu, the Repeat command is displayed in conjunction with the name of the previous function.

Repeat an operation by holding **Shift** while choosing the function from its menu or by pressing **Ctrl+Y**.
Sound Forge processes

The remainder of this chapter describes the functions located in the Process menu.

Auto Trim/Crop

Auto Trim/Crop removes silence from an audio file. In addition, this function will automatically fade the endpoints of a phrase.

Using Auto Trim/Crop

1. Open the Tutor1.wav file.
2. Choose Auto Trim/Crop from the Process menu. The Auto Trim/Crop dialog is displayed.
3. Choose Phrase Concatenator 1 from the Name drop-down list and click OK. You will be prompted to approve the deletion of the current Regions List.
4. Click Yes. The Auto Trim/Crop function deletes silence in the file and creates new regions based on the preset’s parameters. For more information, see Auto Trim/Crop controls on page 214.
Auto Trim/Crop controls

Function drop-down list
The Function drop-down list contains four presets.

Keep edges outside of the selection
Removes silence within the selection, but retains all data outside of the selection.

Remove edges outside of the selection
Removes silence within the selection and deletes all data beyond the selection.

Remove silence between phrases (creates regions)
Removes silence within the selection and creates regions from individual phrases. For more information, see Minimum inter-phrase silence on page 215.

Remove data beyond loop points
Removes all data beyond the selected loop. For more information, see Minimum length following loop end on page 215.

Parameters
The following additional controls are located in the Auto Trim/Crop dialog.

Attack threshold
Determines the threshold level for detection of the trim/crop start point: -Inf. indicates complete silence, and 0 dB indicates maximum amplitude level.

Release threshold
Determines the threshold level for detection of the trim/crop end point: -Inf. indicates complete silence, and 0 dB indicates maximum amplitude level.

Fade in
Determines the length (in milliseconds) of the fade applied to a section of audio prior to the detected trim/crop start point.

Fade out
Determines the length (in milliseconds) of the fade applied to a section of audio following the detected trim/crop end point.
Minimum inter-phrase silence
When the Remove silence between phrases function is specified, the Minimum inter-phase silence value determines the minimum amount of silence needed between phrases for a new region to be created.

Minimum length following loop end
When the Remove data beyond loop points function is specified, the Minimum length following loop end value determines the number of samples that must follow a loop.

Bit-Depth Converter
The Bit-Depth Converter is used to increase/decrease the bit-depth of a file, while concealing the resulting quantization noise.

- Decreasing a file's bit-depth decreases the overall size of the file, but results in added quantization noise, which can be masked using dither and noise shaping.
- Increasing a file's bit-depth—while not improving the quality of the audio—allows subsequent audio processing to be performed with greater accuracy and resolution.

Prior to decreasing a file's bit-depth, the audio should be optimized for conversion. For more information, see Minimizing quantization error on page 116.

Note: There are no rules regarding maintaining audio quality when decreasing bit-depth. For this reason, you should always experiment with the Dither and Noise shaping controls to determine the optimum settings for each file.
Converting a file’s bit-depth

1. Open the Tutmusic.wav file.
2. From the Process menu, choose Bit-Depth Converter.
3. Choose the desired bit-depth from the Bit depth drop-down list.
4. If necessary, use the Dither drop-down list to specify the type of dither that will be used to mask the quantization noise the results from lowering a file’s bit-depth. For more information, see Dither on page 216.
5. If desired, use the Noise shaping drop-down list to specify any noise shaping to be applied to the file. For more information, see Noise shaping on page 217.

---

Note: When increasing a file’s bit-depth, the Dither and Noise shaping controls should be set to None and Off respectively.

---

Dither

This control allows you to specify the randomness of the dither (generated noise) used to mask quantization distortion resulting from conversion to a lower bit-depth. You are able to select from several shapes, each roughly describing the pattern that would be produced if you plotted a graph with the dither amplitude on the X-axis and the probability of the dither values on the Y-axis.

As is frequently the case when working with audio, experimentation will dither values will yield the best results; however, the following information should be kept in mind:

- Rectangular will eliminate distortion resulting from conversion to a lower bit-depth, but the noise level is more likely to be dependent on the signal.
- Triangular will eliminate distortion products as well as any noise floor modulation, but results in a slightly higher noise level. The option typically works well in conjunction with noise shaping. For more information, see Noise shaping on page 217.
- Highpass Triangular will behave like triangular dither, but will shift its noise into higher frequencies. This is typically the best option when used in conjunction with noise shaping. For more information, see Noise shaping on page 217.
- Gaussian will not perform as well as Rectangular and Triangular dither, but may be suitable for certain audio.
Noise shaping

Determines the aural positioning of quantization noise. Using this control, you are able to shift the noise into audio registers that are less perceptible to human hearing. This lowers the perceived noise floor and creates the illusion of cleaner audio.

- Type 1 (high-pass contour) noise shaping attempts to push all quantization noise and error into high frequencies.
- Type 2 (equal-loudness contour) noise shaping attempts to push the noise under an equal-loudness-type of curve.

Noise shaping dangers

Noise shaping places quantization noise near the audio’s Nyquist frequency, a value equal to one-half of the file’s sample rate. Consider the following:

- A file with a sample rate of 44.1kHz has a Nyquist frequency of 22.05kHz (at the high end of human hearing). Applying noise shaping to this file will result in audio perceived to be cleaner than it actually is.
- A file with a sample rate of 22kHz has a Nyquist frequency of 11kHz (well within the sensitive range of human hearing). Applying noise shaping to this file will result in audio that is perceived to be noisier than it actually is. Ironically, this defeats the entire purpose of the Noise shape control.

For this reason, we do not recommend using noise shaping on files with sample rates less than 44.1kHz.
The Channel Converter is used to convert audio files between mono and stereo formats. In addition to this basic function, the Channel Converter allows independent level settings for each channel and can therefore be used to intermix the channels of a stereo file to create pan effects.

**Using the Channel Converter**

1. Open the Tutor1.wav file. Notice that this is a mono file.

2. Choose Channel Converter from the Process menu. The Channel Converter dialog is displayed.

3. Choose Mono to Stereo-100% from the drop-down list and click OK. The mono file is converted to stereo with equal levels mixed to the left and right channels.
Channel Converter controls

The following controls are located in the Channel Converter dialog.

Output channels
These radio buttons determine the number of channels (mono or stereo) in the output file.

New left channel pane
The following three controls are located in the New left channel pane of the Channel Converter dialog.

From left
Determines the amount of the original left channel data mixed into the new left channel.

From right
Determines the amount of the original right channel data mixed into the new left channel.

Invert left channel mix
Selecting the Invert left channel mix check box reverses the polarity of the new left channel.

New right channel pane
The following three controls are located in the New right channel pane of the Channel Converter dialog.

From left
Determines the amount of the original left channel data mixed into the new right channel.

From right
Determines the amount of the original right channel data mixed into the new right channel.

Invert right channel mix
Selecting the Invert right channel mix check box reverses the polarity of the new right channel.

Convert to specified output channels only (no custom mixing)
Selecting the Convert to specified output channels only check box makes all of the dialog’s controls unavailable and results in the following:

- When converting from mono to stereo, each new stereo channel is an exact copy of the original mono file.
- When converting from stereo to mono, the new mono channel consists of both of the original stereo channels mixed at 50% volume.
Audio that is not centered around the zero baseline in the waveform display is said to have a DC offset. DC offsets are typically caused by electrical conflicts between the sound card and input device. The **DC Offset** function is used to change the baseline of an audio file by adding a constant value to each sample to compensate for offsets.

### Estimating DC Offset
The approximate DC offset of an audio file can be obtained by choosing **Statistics** from the **Tools** menu.

![DC Offset dialog]

**Average DC offset:**

- **Average value (DC Offset):** 1.287 (-29.11 dB, 3.92 %)

### DC Offset controls

The following controls are located in the DC Offset dialog.

- **Automatically detect and remove**
  Calculates and corrects the DC offset for each channel individually.
Adjust DC offset by
Allows you to manually specify a DC offset value.

-2147483648 to 2147483647 for 32-bit data
-8388608 to 8388607 for 24-bit data
-32768 to 32,767 for 16-bit data
-128 to 127 for 8-bit data

Compute DC offset from first 5 seconds only
Selecting the Compute DC offset from first 5 seconds only check box specifies that only the first five seconds of a file are analyzed when measuring the DC offset. Be aware that five seconds is not sufficient if a long fade-in or mute has been applied at the beginning of the file.

EQ

The EQ options available in the Process menu depend upon whether you are using the full version of Sound Forge or the XP version.

If you are working with the full version of Sound Forge, you have three options in the EQ submenu: Graphic, Paragraphic, and Parametric. Each of these options will launch the appropriate Sonic Foundry XFX effect. For more information on using the XFX EQ effects, refer to the application's Online Help.

If you are using Sound Forge XP, you have two ExpressFX options in the EQ submenu: Simple EQ and Graphic EQ. Simple EQ allows you to boost or attenuate the signal in three general ranges (bass, mid, and treble) as well as configure the mix of dry and wet signals. ExpressFX Graphic EQ allows you to boost or attenuate the signal at ten pre-determined frequencies as well as configure the Output gain.
Fade

Fades are used to increase or decrease audio volume level over a period of time. Sound Forge provides you with three varieties of fades: graphic fades, linear fade-ins, and linear fade-outs.

Graphic Fade

Graphic Fade allows you to create custom fade envelopes to apply to audio data. Up to sixteen envelope points can be used to create complex graphic fades.

Creating a graphic fade

1. Open the Tutmusic.wav file.
2. From the Process menu, choose Fade, and choose Graphic from the submenu. The Graphic Fade dialog is displayed.
3. Select the Show wave check box. The Tutmusic.wav waveform is displayed in the graph. For more information, see Show wave on page 223.
4. Choose -6dB exponential fade out from the Name drop-down list. The fade's envelope is displayed in relation to the waveform in the graph.
5. Click OK. The specified fade is applied to the file.
Creating a custom graphic fade

1. Open the Tutmusic.wav file.

2. From the Process menu, choose Fade, and choose Graphic from the submenu. The Graphic Fade dialog is displayed.

3. Select the Show wave check box. The Tutmusic.wav waveform is displayed in the graph.

4. Edit the fade envelope using the following controls:
   - Click the envelope to create a new point.
   - Drag a point to move it to a new position.
   - Double-click or right-click a point to delete it.

5. Click OK. The custom graphic fade is applied to the audio file.

Graphic Fade Controls

The following controls are located in the Graphic Fade dialog.

Show wave

Selecting the Show wave check box draws the current selection's waveform on the envelope graph. This function is enabled automatically on small selections.

---

Note: When working with stereo files, use the adjacent drop-down list to specify the display of the left channel, right channel, or a mix of the both channels.

---

Reset Envelope

Clicking the Reset Envelope button clears the envelope of all points except the original two.
Fade In

The **Fade In** command is used to linearly fade a selection from a volume of \(-\text{Inf.}\) to a volume of 0 dB. The size of the selection determines the length of the fade.

1. Open the Tutmusic.wav file and select all audio data.
2. From the **Process** menu, choose **Fade**, and choose **In** from the submenu. The fade is applied, and volume increases over the length of the entire file.

![Audio file fades in from -Inf. to 0 dB](image)

Fade Out

The **Fade Out** command is used to linearly fade a selection from a volume of 0 db to a volume of \(-\text{Inf.}\). The size of the selection determines the length of the fade.

1. Open the Tutmusic.wav file and select all audio data.
2. From the **Process** menu, choose **Fade**, and choose **Out** from the submenu. The fade is applied, and the volume decreases over the length of the entire file.

![Audio file fades out from 0 dB to -Inf.](image)
Insert Silence

The Insert Silence command allows you to place sections of silence in audio files.

Note: Silence cannot be inserted into a single channel of a stereo file.

Inserting silence into a file

1. Open the Tutmusic.wav file.
2. Choose Insert Silence from the Process menu. The Insert Silence dialog is displayed.
3. Choose 2 second standard CD pause length at start of file from the Name drop-down list and click OK. Two seconds of silence is inserted at the start of the file.

Insert Silence controls

The following controls are located in the Insert Silence dialog.

Insert
Determines the length of the silent sections.

At
Allows you to specify where the silence is inserted in the audio file.
Invert/Flip

The Invert/Flip command inverts the audio selection at its baseline, in effect reversing its polarity. Inverting a file, while creating no audible difference, is occasionally useful for matching sample transitions when executing certain pastes, mixes, or loops.

Inverting an audio selection

1. Create a selection in the data window.
2. From the Process menu, choose Invert/Flip. The selection is inverted.

Mute

The Mute command forces the selection to a volume of -Inf. dB (silence).

Muting an audio selection

1. Create a selection in the data window.

2. From the Process menu, choose Mute. The selection is muted.
Normalize

The Normalize command maximizes the overall volume of a file without inducing clipping. When Normalize is applied to a file, Sound Forge scans the entire file and applies a constant gain to raise the file's level to a specified value.

Normalizing Audio

1. Open the Tutmusic.wav file.

![Pre-normalized file]
2. From the Process menu, choose Normalize. The Normalize dialog is displayed.

3. Choose Normalize RMS to -16 dB from the Name drop-down list and click OK. The file is normalized and its overall “loudness” increased.

Normalize Controls

The following controls are located in the Normalize dialog.

Normalize using Peak level
This radio button normalizes the audio file using the maximum (instantaneous) sample values detected. A constant gain is then applied to the audio.

Normalize using Average RMS power (loudness)
This radio button normalizes the audio file using the detected average RMS value of the audio file. This is helpful for matching the apparent loudness of a number of individual recordings. For more information, see Scan settings pane on page 229.
Normalize to

- With Peak level, if the peak level is -10 dB and the Normalize to value is -3 dB, a constant boost of 7 dB is applied to the entire file.
- With Average RMS power, normalizing to 0 dB means boosting the signal until it has the same apparent loudness as a 0 dB square wave. This will result in all dynamic range of the signal being flattened and all peaks being either clipped or seriously compressed. For more information, see If clipping occurs on page 231.

Note: As a rule, normalizing using Peak levels to 0 dB is acceptable, but normalizing using Average RMS power to anything above -6 dB is not recommended.

Scan settings pane

The controls in this pane allow you to determine the response of the RMS power scan to the dynamics in the file.

Ignore below
The Ignore below fader determines the level of audio data included in the RMS calculation. Data below the threshold is ignored, effectively eliminating silent sections from RMS calculation. The Ignore below fader should be set a few dB above perceived silence.

If Ignore below is set to -Inf., all audio data is used. However, if the value is set too high (above -10 dB) the RMS value may never rise above the threshold. In this case, normalization cannot occur. For this reason, the threshold should be evaluated using Scan Levels. For more information, see Scan Levels on page 230.

Attack time
Determines how quickly the scan responds to transient peaks.

Release time
Determines how quickly the scan should cease using transient peak material after it begins to drop in level. Slower release times will result in more data being included in RMS calculation.
Use equal loudness contour

Selecting the Use equal loudness contour check box allows the scan to compensate for the Fletcher-Munson Equal Loudness Contours. The Fletcher-Munson Equal Loudness Contours basically illustrate that very low- and high-frequency audio is less perceptible to the human ear than mid-range audio. Therefore, selecting this option forces the scan to factor this into RMS calculation.

Scan Levels

Clicking Scan Levels initiates Peak and RMS scans on the audio and displays the RMS level and the highest peak level detected. When previewing a Normalize, the entire file must be scanned to preview a even small selection. Clicking Scan Levels saves the current Peak and RMS values and allows you to preview different Normalize to settings without re-scanning the entire file.

Current Peak and RMS levels

An asterisk adjacent to a level value indicates that the value is not current. This occurs when the selection is updated or the dialog is initially opened. To update values, click Scan Levels.

Noncurrent Peak and RMS levels

If values have never been calculated, two dashes are displayed. Click Scan Levels to calculate values.

Nonexistent Peak and RMS levels

Note: If the RMS level never reaches the Ignore below threshold, a value of -96 dB is displayed. If this occurs, you should decrease the Ignore below threshold level and rescan.
Use current scan levels (do not scan selection)
When the Use current scan levels check box is selected, the current scan levels are used without initiating a new scan. This is useful when applying scan levels from a different selection or file to the current selection, thereby allowing identical gains to be applied to multiple files. This option can also be used to scan a selection of an audio file containing the loudest or most constant levels and then apply that scan to normalize the entire file.

If clipping occurs
The If clipping occurs drop-down list is used to specify how the normalize function will handle clipping that may occur when an audio file is processed using the RMS option.

Apply dynamic compression
When Apply dynamic compression is specified, peaks that will result in clipping are limited below 0 dB using non-zero attack and release times to minimize distortion. This mode is useful for getting loud and clear audio during mastering.

Normalize peak value to 0 dB
When Normalize peak value to 0 dB is specified, the selection’s peak amplitude level is normalized to 0 dB, thereby allowing the maximum possible constant gain without clipping the selection. However, less gain is applied than would be necessary to achieve the Normalize to RMS level.

Ignore (saturate)
When Ignore is specified, audio is permitted to clip and distort.

Stop processing
When Stop processing is specified, audio peaks that will result in clipping force the normalize function to cease processing and alert you that clipping will occur at the current level.

Note: When using normalize on stereo audio, normalization is computed on the loudest sample value found in either channel and identical gain is applied to both channels. If a single channel is selected in a stereo file, normalization processes only that channel.
Pan/Expand

Pan/Expand allows you to create panning effects and stereo compression/expansion in selections.

Creating a pan

A pan is used to control the apparent position of a sound between the left and right channels of a stereo file.

1. Open the Tutmusic.wav file.

2. From the Process menu, choose Pan/Expand. The Pan/Expand dialog is displayed.

3. Select the Show wave check box. The Tutmusic.wav waveform is displayed on the graph. For more information, see Show wave on page 234.

4. Choose Left to right (linear) from the Name drop-down list. The pan envelope is displayed on the graph.
5. Click OK. The file is automatically converted to stereo and configured with a left-to-right pan.

6. Play the file. The audio source seems to move from the left channel to the right channel during playback.

Note: A pan, by nature, cannot be created in a mono file.

Creating a custom pan

Sound Forge allows you to create complex custom panning effects using up to sixteen envelope points.

1. Open the Tutmusic.wav file.

2. From the Process menu, choose Pan/Expand. The Process dialog is displayed.

3. Select the Show wave check box. The waveform is displayed on the graph along with its pan envelope.

4. Configure the pan envelope using the following controls:
   • Click the envelope to create a new point.
   • Drag a point to move it to a new position.
   • Double-click or right-click a point to delete it.

5. Click OK. The custom pan is applied to the file.
Pan/Expand controls

The following controls are located in the Pan/Expand dialog.

Process mode drop-down list
The Process mode drop-down list contains the following four options.

Pan (preserve stereo separation)
Applies the pan effect without mixing the channels, thereby simulating the spectral positioning of stereo recordings.

Pan (mix channels before panning)
Mixes the left and right channels prior to applying panning effects.

Stereo expand
Allows you to contract or expand the image of stereo audio from dead center (mono) to completely panned wide (no center channel).

Mix mid-side (MS) recording to left and right channels
Simulates a recording technique in which one microphone is pointed directly at the source and used to record the center (mid) channel, and a second microphone is pointed 90 degrees away from the source (side) and used to record the stereo image.
For proper playback on most systems, MS recordings must be converted to standard left/right orientation.
To convert an MS-recorded track to a left/right track in Sound Forge, first ensure that the center channel is in the left track and the side channel on the right. The MS mix function is then used to set the width of the stereo image for the converted track.

Output gain
Determines the amount of gain applied to the signal following pan/expand processing.

Show wave
Selecting the Show wave check box draws the current selection's waveform on the envelope graph. When working with stereo files, you must use the corresponding drop-down list to specify whether the left channel, right channel, or a mix of both channels will be displayed.

Reset Envelope
Clicking the Reset Envelope button clears all but the two original envelope points.
- For the pan modes, these two points prevent unintended panning.
- For the Stereo expand and Mix Mid-Side, these points two prevent unintended expansion.
The **Resample** command allows you to change the sampling rate of a file without altering its pitch or duration.

- Resampling to a lower sample rate results in less frequent samples and a decreased file size, but adds aliasing noise to the audio. *For more information, see Apply an anti-alias filter during resample on page 237.*
- Resampling to a higher sample rate results in extra samples being created through interpolation and an increased file size. Like increasing bit-depth, up-sampling does not improve the quality of an audio file, but permits subsequent audio processing to be performed with greater precision.
Downsampling audio

1. Open the Tutmusic.wav file.
2. Right-click the data window and choose Properties from the shortcut menu. The Properties dialog is displayed. Notice that this file has 44,100 Hz sample rate and a file size of 0.85 MB.
3. Click OK.
4. Choose Resample from the Process menu. The Resample dialog is displayed.
5. Choose 8,000 Hz with anti-alias filter from the Name drop-down list and click OK. The audio is resampled at 8,000 Hz.
6. Save the resampled file with a new name and close it.
7. Open the resampled file and view its Properties dialog. The sample rate is lower (8,000 Hz) and the file size is substantially decreased.

Note: Use this file to perform the following up-sampling procedure.

Upsampling audio

1. With the file created in the previous procedure active, choose Resample from the Process menu. The Resample dialog is displayed.
2. Choose 48,000 Hz with anti-alias filter from the Name drop-down list and click OK. The audio is resampled at 48,000 Hz.
3. Save the resampled file with a new name and close it.
4. Open the new file and view its Properties dialog. Notice that the sample rate is higher (48,000 Hz) and the file size is substantially increased (0.92 MB).
5. Play the file. Notice that resampling to a higher sample rate produces an audio quality at 48,000 Hz that is indistinguishable from the quality at 8,000 Hz.
Resample controls

The following controls are located in the Resample dialog.

New sample rate
Determines the sample rate (in Hz) at which the file will be resampled.

Note: Processing is quicker when downsampling by an even multiple (such as when going from 44 kHz to 22 kHz).

Interpolation accuracy
The Interpolation accuracy value determines the complexity of the interpolation method used during resampling. Interpolation accuracy is most apparent in high frequencies, but the audible difference between the values is subtle and often undetectable without the use of test tones.

- A value of 1 is suitable for general-purpose audio.
- Values of 2 and 3 are good for high-end audio applications.
- A value of 4 results in professional-quality audio, but requires substantial processing.

Note: In the Name drop-down list, presets with an asterisk use an Interpolation accuracy value of 4. Presets without an asterisk use an Interpolation accuracy value of 2.

Apply an anti-alias filter during resample
Selecting this check box applies an anti-aliasing filter during the resampling process. Remember that the maximum frequency that can be represented by a sample rate is one-half of the sampling rate (the Nyquist frequency). Therefore, high frequencies cannot be accurately represented when downsampling. The anti-aliasing filter prevents high frequencies from becoming low-frequency distortion.

Note: It is also advisable to apply an anti-aliasing low-pass filter to an audio file prior to resampling to a lower sample rate.
Set the sample rate only (do not resample)
If the Set the sample rate only check box is selected, the playback rate is changed without resampling the data. This means that the pitch of the original file is not preserved. For this reason, this option is only useful for quickly converting between two similar sample rates.

Reverse
The Reverse command reverses the audio selection.
1. Open the Tutmusic.wav file and select all data.

2. From the Process menu, choose Reverse. The audio data is reversed and displayed in the data window.

Smooth/Enhance
If you are working with the full version of Sound Forge, choosing Smooth/Enhance from the Process menu will start Sonic Foundry’s XFX Smooth/Enhance function. For more information on using XFX Smooth/Enhance, refer to the application’s Online Help.

If you are using Sound Forge XP, choosing Smooth/Enhance from the Process menu will start the application’s native version of the effect.

Time Compress/Expand
If you are working with the full version of Sound Forge, choosing Time Compress/Expand from the Process menu will start Sonic Foundry’s XFX Time Compress/Expand function. For more information on using the XFX Time Compress/Expand, refer to the application’s Online Help.

If you are using Sound Forge XP, choosing Time Compress/Expand from the Process menu will start the ExpressFX Time Compress/Expand function. This tool allows you to adjust the length of an audio file using a single control, the Final length slider.
Volume

The Volume command alters the volume of an audio selection.
Increasing the volume of a selection

1. Open the Tutor1.wav file.

2. Create a selection containing the word “Wow.”

3. From the Process menu, choose Volume. The Volume dialog is displayed.

4. Choose 6dB boost from the Name drop-down list and click OK. The specified boost is applied to the selection.

5. Play the file. The “Wow” data clips and distorts upon playback.

You must exercise caution when using the Volume command. Unlike Normalize, Volume performs no pre-processing scans and offers no options for clipping audio data.

**Note:** Once audio data is clipped, it cannot be restored by performing a second Volume operation. The initial Volume operation must be undone.
Volume control

The Volume dialog contains only one control, Gain.

Gain
Determines the new volume of a selection. Negative decibel values decrease the selection’s volume, while positive decibel values increase the selection’s volume.

Note: A value of -Inf. corresponds to a mute (0%).
This chapter is designed to familiarize you with Sound Forge’s Acoustic Mirror and Wave Hammer functions. Acoustic Mirror is a powerful digital signal processing tool that allows you to add environmental coloration to your existing recordings. Wave Hammer is an audio mastering tool that features a classic compressor and volume maximizer. Please be aware that Acoustic Mirror and Wave Hammer are only available when using the full version of Sound Forge.

What is Acoustic Mirror?

Acoustic Mirror represents an advance in reverb technology in that it incorporates the acoustical responses of a given environment or venue into your audio files. You may never play Carnegie Hall, but that does not mean your that recordings can’t sound like it. Taking this concept even further, Acoustic Mirror allows you to simulate the signal response of vintage musical equipment. Image the money you’ll save not having to buy those paired U-47s.

The acoustic signature

Acoustic Mirror creates its effects through the use of the environment’s acoustic signature, or impulse response. These acoustic signatures are saved as impulse files and given the extension .wav or .sfi. To get you started, Acoustic Mirror includes an extensive library of high-quality impulse files. In addition, Acoustic Mirror allows you to collect your own acoustic signatures and create custom impulse files.
Adding an acoustic signature to an audio file

1. Open and play the saxriff.wav file.

   **Note:** Acoustic Mirror cannot be started until there is an active file on the Sound Forge workspace.

2. From the **Effects** menu, choose Acoustic Mirror. The Acoustic Mirror dialog is displayed.

3. Click **Browse** and locate the Impulses folder.

4. Double-click the Impulses folder. Several impulse subfolders are displayed.

5. Double-click the Large venues folder. Several impulse files are displayed.

6. Double-click Stadium, Camp Randall 50 yrd line.sfi. This impulse file’s acoustic signature is added to the saxriff.wav file and you are returned to the Acoustic Mirror dialog.

7. Click **Preview**. The processed file is played and the sax riff is virtually placed in a football stadium-sized venue.

8. Select or clear the **Bypass** check box to toggle between the processed and unprocessed audio.
Adjusting the acoustic signature

Once an acoustic signature is added to a file, you are able to use the controls of the Acoustic Mirror dialog to precisely configure the reverb effect. More importantly, you can preview configuration changes as quickly as you make them.

1. Open a .wav file and display the Acoustic Mirror dialog.
2. Verify that Real-time check box is selected.
3. Choose the desired impulse file from the Impulse drop-down list and click Preview. The processed audio file is played. Notice that all dialog controls are set to their default values.
4. Drag the Dry Out fader up. Notice the audible change in output as the balance between the Wet Out and Dry Out values changes.

Note: If you are experiencing difficulty previewing processing in real-time, decrease the Quality/speed value.

5. Drag the Response delay slider to the right. Notice the audible change in the reverb’s delay.

For more information, see Acoustic Mirror dialog controls on page 245.

Acoustic Mirror dialog

1. Open the saxriff.wav file.
2. From the Effects menu, choose Acoustic Mirror. The Acoustic Mirror dialog is displayed. Notice that the dialog contains the preset and preview controls found in all of the application’s process and effect dialogs. For more information, see Presets on page 207.

Acoustic Mirror dialog controls

The Acoustic Mirror dialog contains four tabs: General, Envelope, Summary, and Recover. Each tab contains controls that allow you to precisely configure the effect as well as recover custom impulses.

General tab controls

The following sections describe all controls located in the General tab.
Impulse
The Impulse drop-down menu allows you to specify an impulse file from a list of those previously used. Clicking **Browse** displays the Open Impulse File dialog and allows you to locate an impulse file from your local system or network.

Response Width
The Response Width slider can be used to create some simple stereo expansion and stereo collapsing effects. This control’s default setting of 50 represents normal stereo operation and is recommended to maintain the stereo field of the impulse response. A higher setting will expand the stereo field, but may result in an unnatural sounding effect. Lowering this setting will narrow the stereo field. A setting of 0 is essentially mono.

Response delay
The Response Delay slider controls the time, in milliseconds, that will elapse between the dry signal and the processed output. This control can be used to create interesting effects and add new dimensions to an acoustic signature. Configuring this control with a positive value will result in the processed output following the dry output. A negative value results in the processed output preceding the dry signal, or a pre-delay.

Pan (left to right)
The Pan slider controls the balance between the left and right channels in stereo files. The default value is 0 and indicates a typical center position.

Dry Out
The Dry Out fader controls the amount of unprocessed signal mixed into the output.

Wet Out
The Wet Out fader controls the amount of processed signal mixed into the output.

Apply envelope and limit decay to (seconds)
When this check box is selected, the length of the impulse will be limited to the time specified in the adjacent box. Limiting the length of an impulse file will shorten the decay of the reverberation and decrease the amount of processing required.

In addition, selecting this check box results in the impulse being faded according to the Envelope Graph configured on the dialog’s Envelope tab. *For more information, see Envelope Graph on page 248.*
Low-shelf start frequency/High-shelf start frequency

*Acoustic Mirror* offers high- and low-shelving filters to allow you to tailor the frequency response of the impulse. Notice that the cutoff frequency and boost/attenuation of each filter can be independently adjusted.

Convert mono to stereo

Selecting the *Convert mono to stereo* check box will convert a mono signal to stereo output. If the impulse file is in stereo, selecting this check box will impart a pseudo-stereo effect on the mono input.

Quality/speed

The *Quality/Speed* slider allows you to strike a balance between the quality and speed of the audio processing. Lowering this value will immediately affect the frequency response of the impulse. You will notice that the processed signal sounds dull and that high frequencies sound unnatural. At very low values, the length of the impulse will actually be shortened. When this control is set to a high value, the audio quality will be excellent, but the processing will take longer.

If you are experiencing difficulty previewing processing in real-time, decrease the *Quality/speed* value. However, you must return this value to 5 prior to actually processing the file to output the highest possible quality.

Envelope tab controls

The following sections describe all controls located on the *Envelope* tab.
Impulse
This control is identical to the Impulse drop-down list on the General tab. This allows you to view the envelope graphs for the specified impulse file. For more information, see Impulse on page 246.

Dry Out
This control is identical to the Dry Out fader on the General tab. For more information, see Dry Out on page 246.

Wet Out
This control is identical to the Wet Out fader on the General tab. For more information, see Wet Out on page 246.

Apply envelope and limit decay
This control is identical to the Apply envelope and limit decay check box on the General tab. For more information, see Apply envelope and limit decay to (seconds) on page 246.

Envelope Graph
Selecting the Apply envelope and limit decay check box enables the Envelope Graph. This control is used to decrease the length of the specified impulse file, which consequently decreases the reverberation decay time and processing time. This control can also be used to apply fades to the specified impulse file.

![Envelope Graph](image)

The horizontal axis of the graph represents the time of the impulse file and the vertical axis represents peak amplitude in dB. Specifying an impulse file from the Impulse drop-down list automatically displays its envelope in the graph.

**Note:** If the impulse file is greater than 6 seconds in length, it will not be displayed in the envelope graph.
Envelope points

Envelope points are used in the Envelope Graph to specify a fade curve. The fade amount can vary from 0% to 100%. Envelope points can be created, deleted, and arranged just as they are in all of the application’s envelope graphs. For more information, see Envelope graphs on page 62.

Note: The fade value at any point in curve does not use the same vertical logarithmic (dB) scale used for displaying the impulse file.

Adjusting the impulse length

Drag the vertical Envelope Endpoint line to the desired location. The Envelope Endpoint is repositioned and the length of the impulse adjusted accordingly.

Reset

Clicking this button resets the envelope points to 100%, indicating no fade.

Package Impulse into Preset

Clicking this button creates a link between the current preset and the selected impulse file, along with encoding the impulse information. Using the Preset Manager, presets and the accompanying impulse files can be shared between computers without losing information. For more information, see Using the Preset Manager on page 209.

Summary tab controls

The following section describes all controls located on the Summary tab.

Impulse

This control is identical to the Impulse drop-down list on the General tab. For more information, see Impulse on page 246.
Dry Out
This control is identical to the Dry Out fader on the General tab. For more information, see Dry Out on page 246.

Wet Out
This control is identical to the Wet Out fader on the General tab. For more information, see Wet Out on page 246.

Quality/speed
This control is identical to the Quality/speed check box on the General tab. For more information, see Quality/speed on page 247.

Recover tab controls
You will only be using the Acoustic Mirror dialog’s Recover tab if you plan on creating your own impulse files. For more information, see Creating Impulse Files on page 252. The following section describes all controls located on the Recover tab.

Recorded file
The Recorded file box allows you to select the file containing the test tone recorded in the field. You can enter the path directly into the box or click Browse to display the Select Recorded File dialog, which allows you to locate and select a file.

Test file used
The Test file used box allows you to select the file that was used as a test tone. You can enter the path directly into the box or click Browse to display the Select Test Tone File dialog, which allows you to locate and select a file.

Note: You should use one of the test files included in the test tone folder on the Sound Forge CD-ROM.

Impulse output file
The Impulse output file box allows you to specify where the recovered impulse response file will be saved. You can enter the path directly into the box or click Browse to display the Select Destination File dialog, which allows you to locate and select a folder.
Remove very low frequencies
When this check box is selected, very low frequencies (which are typically comprised of noise) are removed from the impulse response. This increases the impulse response's signal-to-noise ratio.

Recover Impulse
Clicking the Recover Impulse button starts the impulse recovery process. After the process is complete, an impulse file is automatically created and saved in the folder specified in the Impulse output file box.

Impulse recovery mode
You are able to choose from three Impulse recovery mode options to determine the method Acoustic Mirror will use to recover the impulse: Use the start and end of the recorded file as timing spikes, Auto-detect timing spikes, or Do not use timing spikes. Each of these modes is described below.

Use the start and end of the recorded file as timing spikes
This option specifies that the beginning and end of the recorded file will be used as timing spikes. This option is recommended for the best results during impulse recovery.

The file must be trimmed as close to the timing spikes as possible for this method of recovery to work most effectively. The first sample of the file should contain the start of the first spike and the last sample of the file should contain the start of the second spike. Therefore, most of the second spike will be deleted.

Auto-detect timing spikes
This option specifies that the timing spikes exist near the start and end of the recorded file and that they should be auto-detected. Timing spikes are used to correct for clock or tape speed mismatches. If you have not trimmed the recorded file so that the timing spikes are at the very beginning and end, select this option for the best results.

With this option, you need only ensure that the first spike occurs within one second of the start of the file and that the second spike exists in the file. To improve detection accuracy, you can also boost the level of the start and end spikes in the recorded file.

Note: If the spike's level is close to the noise floor, select the Use the beginning and end of the recorded file as timing spikes option.
Do not use timing spikes

This option specifies that no timing spikes will be used. This is the least desirable option as no timing information will be used. To use this option, the recorded file must be trimmed so that the test tone starts and ends at the start and end of the file, with no blank audio before or after. This option should only be used if the timing spikes are lost in the recording or if you are certain that the play and record clocks are synchronized (such as when using an ADAT).

Creating Impulse Files

Impulse responses can be obtained from anything that will accept test tone input and support recording the output. This includes physical spaces as well as electronic audio equipment. Creating custom impulse files requires planning, work, and additional audio equipment.

---

**Note:** Impulses derived from electronic devices that produce nonlinear effects such as overdrives, distortion pedals, pitch shifters, harmonic enhancers, chorus pedals, or flange pedals cannot be modeled in Acoustic Mirror. While they will produce interesting effects, the acoustic signature will not be correctly replicated.

---

What you need to create custom impulses

The equipment required to create custom impulses depends upon whether you want to create the impulse from a physical acoustic space or from a piece of equipment. Regardless of the method, you will need a playback device that will reproduce test tones and a recording device that has microphone or line-level inputs. You should understand that the quality of the impulse is directly affected by the quality of your playback and recording devices. The flatter your system's response, the more accurate the impulse response.

**Recovering an impulse from an acoustic space**

If you want to recover an impulse from an acoustic space, you will need the following equipment:

- A playback device and speakers.
- A stereo pair of microphones to record the test tone.
- A recording device for recording the signal captured by the microphones.
Recovering an impulse from an electronic device

If you want to recover an impulse from an electronic device, you will need the following equipment:

- A playback device that will connect to the device’s inputs.
- A recording device that will connect to the device’s outputs.

Recording the impulse in an acoustic space

Once you have assembled the required equipment, you are ready to begin recording the impulse. The following sections describe the typical impulse recording procedure.

Transferring the test tone

The first step in recording the impulse is to transfer the desired test tone to your playback device. The Sound Forge CD-ROM contains two test tones: a 24-second test tone and a 48-second test tone. We typically recommend that you use the 24-second tone because longer tones result in greater signal-to-noise ratios. The 48-second tone should be used in particularly noisy environments or when the decay time of the acoustic space is greater than six seconds.

Note: There are spikes at the beginning and end of each test tone. These should be included in the recording to simplify the recovery of the impulse in the latter stages of the process.

Equipment placement

When recording the test tone in an acoustic space, you must determine where to place your playback system, speakers, microphones, and recording system to produce optimal results. Microphone placement is crucial to the quality of the impulse. The distance between the speakers and the microphone will be the perceived distance of audio processed with the impulse you create. For example, if you record the test tone with the speakers positioned 100 feet from the microphones, all sounds processed with the resulting impulse will sound as if they are originating 100 feet from the listener.

Setting levels

After the devices are positioned, you should begin playback of the test tone. The test tone should be played as loudly as possible (or practical) to produce the best signal-to-noise ratio. With the test tone playing at optimum volume, set the levels on the recording device.
Recording devices levels should also be set as high as possible, but not permitted to clip or distort. Safe levels will be determined by whether you are recording to an analog or digital medium.

**Recording the test tone**

Begin recording on the recording device and begin playback of the test tone. Remember to include the spikes at the beginning and end of the test tone. Record the test tone several times using the initial setup, then move the microphones and record the test tones several more times. Continue moving the microphones and recording until you have exhausted the space's acoustic possibilities. Recording impulses in this manner will provide you with several distinct impulses for each space.

**Recording the impulse through an electronic device**

The recording process is similar if you are recording the output of an electronic device, but there are no speakers or microphones to be placed.

Using the appropriate cables, connect the playback system's outputs to the electronic device's inputs and the electronic device's outputs to the recording system's inputs. Once the devices are connected, play the test tone through the electronic device and record its output on the recording system.

**Other impulses**

Any number of methods can be used to create an impulse, including starter pistols, clap boards, or even a sharp hand clap. The drawback of these “impulse generators” is that they add their own coloration to the sound. For best results, we recommend using the test tones included on the CD-ROM.

**Recovering the impulse**

Once you have recorded your test tones, they must be processed and converted into impulse responses. The following sections describe the typical impulse recovery procedure.

**Trimming the test tone**

1. Open your test tone file (the “room processed” output test tone) in Sound Forge.
2. Locate the first timing spike and delete all audio before it. Cut as close to the beginning of the timing spike as possible, but do not delete the spike itself.
3. Locate the second timing spike and delete all data from the start of the second spike to the end of the file. Again, cut as close to the start of the timing spike as possible.

You should now have an audio file with a spike at the beginning, a test tone, and silence.
4. Save the test tone file.

Naming, configuring, and recovering the impulse

1. From the Effects menu, choose Acoustic Mirror. The Acoustic Mirror dialog is displayed.
2. Click the Recover tab.

3. Enter the name and path of your impulse file in the Recorded File box or click Browse and locate the file.
4. Enter the name of the original test tone file in the Test file used box.
5. Enter the desired name for the impulse response file to be created in the Impulse output file box. If necessary, click Browse and specify the folder in which the impulse file will be saved.
6. Select the Remove very low frequencies check box.
7. If the recorded file was trimmed exactly to the start and end spikes using the procedure described previously, choose Use start and end of the recorded file as timing spikes from the Impulse recovery mode drop-down list. For more information, see Trimming the test tone on page 254.
8. Click the Recover Impulse button to begin recovering the impulse.

After processing is complete, you can open the impulse file in Sound Forge and perform any necessary trimming or editing. For more information, see Trimming the impulse file on page 256.
Trimming the impulse file

After the impulse file is recovered, it may still require minor trimming. In general, you should try to make the impulse response as short as possible to increase processing speed when using Acoustic Mirror. Impulse files greater than 131,071 samples (about 3 seconds) in length will require substantial processing time. When possible, trim the impulse response to less than 65,535 samples (about 1.5 seconds). In addition, we recommend fading the tail of the impulse. Of course, this is not always an option when dealing with spaces that produce extended reverberations.

1. Open the recovered impulse file in Sound Forge and play it.
2. Delete any silence or low-level noise that occurs before or after the actual audio data. Typically there are between 900 and 1100 samples of data at the beginning of the impulse that should be removed.
3. Save the trimmed impulse response file using the standard .wav format.

**Note:** To prevent phase problems when mixing the dry and wet signals, you may also want to verify the phase of the impulse file. The file should begin by going positive (above the centerline). If the impulse file has a negative (below the centerline) phase, choose Invert/Flip from the Process menu.

Adding summary information to your impulse file

If you plan on sharing impulses with other Sound Forge users, we recommend adding summary information and .bmp images to your files.

1. Open the impulse file in Sound Forge.
2. From the File menu, choose Properties. The Properties dialog is displayed.
3. Click the Summary tab.
4. Enter the appropriate information in each box.
5. Click the Picture button. The Open Picture dialog is displayed.
6. Locate the desired image and click Open. The image is linked to the impulse file.
7. Click OK.

**Note:** If you are using a palletized display setting (256 colors or less) and attach a bitmap to an impulse file, the bitmap colors will be distorted when viewed in Acoustic Mirror. This is because Sound Forge converts the bitmap using the default palette at the time of attachment, which is not optimal. For this reason, you should set the display settings to at least a 16-bit palette prior to attaching bitmaps to impulse files.

**Using the new impulse file**

To use your new impulse file, open the Acoustic Mirror dialog and choose it from the Impulse drop-down list as you would any other impulse file. If the previous procedures were performed properly, the custom impulse file should realistically recreate the reverberation characteristics of the electronic device or acoustic space.

**Using impulse files in creative ways**

Now that you understand the use and creation of impulse files, you may want to begin using Acoustic Mirror in more interesting ways than simply applying an impulse to an audio file. The following sections describe some creative and advanced uses for Acoustic Mirror technology that will contribute to the professionalism of your work.
Processing individual audio elements

Instead of applying an impulse file to an entire song, try applying an impulse to individual elements of the song. Applying an impulse to specific notes, chords, riffs, or phrases can quickly change the dynamics of a song. This technique is possible because Acoustic Mirror will automatically mix the tail of processed audio with the adjacent unprocessed audio.

Note: In Sound Forge, this option located in the Previews tab of the Preferences dialog and is enabled by default.

Adding realistic stereo to mono recordings

Mono recordings can given realistic stereo characteristics by selecting the Convert mono to stereo check box in the General tab of the Acoustic Mirror dialog when applying the specified impulse file. The stereo image produced using this method will be virtually indistinguishable from an actual stereo recording.

If you choose to use Acoustic Mirror for stereo simulation, you may find the output too reverberant. If this is the case, decrease the Apply envelope and limit decay value. Frequently, setting this value to as little as 0.1 seconds will provide stereo realism without adding a distracting amount of reverb.

Creating special effects

Processing an audio file using a non-impulse .wav file can produce any number of unexpected and interesting special effects. To demonstrate this concept, create several short (less than 12 seconds) audio files using the FM Synthesis tool and save them as individual .wav files. Now choose any of these files from the Impulse drop-down list and preview the results.

We have included several short files on the Sound Forge CD-ROM to allow you to experiment with this technique. After some experimentation, you should begin to notice a few general rules regarding this use of Acoustic Mirror:

- Impulse files that cover the entire frequency spectrum will prevent the output from sounding too filtered.
- Using a frequency sweep as an impulse will create a frequency-dependent delay effect.
- Panning within the impulse will cause the stereo image of the output to flutter between channels.
- Using staccato sounds (such as drum hits) will create a variety of echo effects.
Recreating spaces for foley effects and dialog replacement

Frequently, dialogue recorded in the field is rendered unusable by ambient noise. If you are shooting in the field and realize that overdubbing will be necessary, you should create an impulse in each filming location. This will allow you to overdub dialog during post-production that is indistinguishable from dialog recorded on location.

If you intend to use Acoustic Mirror as a film/video post-production tool, there are some factors to keep in mind:

- Distance information is determined by the distance between the source and the microphone when creating the impulse. Record multiple impulses at various distances for each location to create realistic dialog effects when matching audio processing to approximate camera positioning.
- The frequency response of the human ear changes as the volume of a sound increases. As a result, impulses created from a significant distance may sound unusual at high volumes.
- Placing a microphone off center allows you to create directional information in the recovered impulse. For example, placing a microphone to the left of the speaker will produce an impulse that approximates a source located on the left side of the screen.

Panning with head-related transfer functions

A head-related transfer function (HRTF) contains the frequency and phase response information required to make a sound seem to originate from a specific direction in a three-dimensional space. There is an hrtf folder on the Sound Forge CD-ROM that contains a collection of impulse files that contain directional cues.

To achieve optimal results using these impulse files, the original file should be mono and playback should be monitored using headphones. To begin, convert the mono file to stereo by replicating the mono signal in each channel. After the audio is converted to stereo, choose an impulse file from the hrtf folder. You will notice that the hrtf folder is further divided into Left and Right directories. Opening the desired folder will display the available impulse files, all of which are named based on their elevation (up or down) and azimuth (left or right) angles in degrees. The following table provides some examples:

<table>
<thead>
<tr>
<th>File Name</th>
<th>Impulse positioning</th>
</tr>
</thead>
<tbody>
<tr>
<td>0E000L</td>
<td>Straight ahead</td>
</tr>
<tr>
<td>0E090L</td>
<td>Far left</td>
</tr>
<tr>
<td>0E090R</td>
<td>Far right</td>
</tr>
<tr>
<td>90E000L</td>
<td>Directly above your head</td>
</tr>
<tr>
<td>0E180L</td>
<td>Directly behind you</td>
</tr>
<tr>
<td>-20E120L</td>
<td>Below, behind, and to your left</td>
</tr>
</tbody>
</table>

Note: Refer to readme.txt in the hrtf folder for more information.
Troubleshooting

The following sections describe problems that may be encountered when working with Acoustic Mirror.

Stuttering during real-time previewing

It is not uncommon to experience problems when previewing Acoustic Mirror’s processing in real-time. The following sections contain several suggestions to remedy the situation.

Lower the Quality/speed setting

Lower the value of the Quality/speed control on the General page. When previewing lengthy impulse responses, a setting of 1 or 2 may be necessary; however, the quality will suffer. This setting should always be returned to 5 prior to processing to maintain effect quality.

Increase the DirectX buffering size

1. Open the Acoustic Mirror dialog.
2. Right-click in the dialog and choose Configuration from the shortcut menu. The Real-Time Preview Configuration dialog is displayed.
3. Reconfigure the Buffers to process per second and Total playback buffers controls. Typically, lowering the Buffers to process per second value and increasing the Total playback buffers value will reduce gapping during real-time previewing.

Close all memory-intensive applications

Real-time previewing may be limited by any additional applications operating on the desktop. To avoid this situation, close all memory-intensive applications, such as Microsoft Office, prior to using Acoustic Mirror.

Add additional RAM to the system

We recommend at least 24MB of RAM to operate Sound Forge and its related tools.

Add a faster floating point arithmetic processor

Many high-speed processors are still lacking in speed when processing floating point arithmetic. We recommend using high-speed processors that will provide exceptional floating point arithmetic for reliable real-time previewing.
Impulses do not recover properly

If you experience problems recovering custom impulse recordings, verify each of the following:

- Verify that you have trimmed the recorded test tone based on the mode chosen from the Impulse recovery mode drop-down list. For more information, see Trimming the test tone on page 254.
- Verify that the second spike is present in the recorded test tone if the Auto-detect timing spikes options is specified.
- Verify that the file specified in the Test file used box is the exact test tone used to make the field recording and that neither its length or data has been changed.
- If the impulse still will not recover properly in Auto-detect timing spikes mode, use Sound Forge to normalize the spikes in the recorded test tone file. This should aid the auto-detect algorithm in detecting the timing spikes and recovering the impulse.

The recovered impulse is too noisy

To maximize the impulse’s signal-to-noise ratio, you should verify that the field recording’s noise floor is not too high. When recording in noisy environments, increase the test tone’s amplitude until the test tone is at least 25dB louder than the noise floor. At least 40 dB of signal-to-noise is recommended for optimal impulses. If you cannot avoid noise when recording in the field, Sonic Foundry’s Noise Reduction can salvage a session.

Speaker nonlinear distortion can also cause noisy impulses. The most common source of nonlinear distortion is loudspeaker harmonics. Most speakers display substantial harmonic distortion at low frequencies. For example, when you play a 60 Hz tone, the speaker vibrates at 60 Hz, but also outputs lower-level audio at multiples of 60 Hz (120, 180, etc.). The impulse recovery method greatly minimizes these low-frequency distortions; however, inexpensive tweeters often display substantial high-frequency distortion that can disrupt the recovery process. When possible, use high-quality components and do not overdrive the speakers.

Descriptions of Error Messages

The following sections briefly describe error messages that may be encountered when using Acoustic Mirror.

The selected file is not a valid test file

The file specified in the Test file used box is not a test tone file included on the Sound Forge CD-ROM.
The level of the first spike is low. Do you wish to use it as a timing spike?
This typically means that no actual timing spike was detected. Verify that the first spike is within one second of the start of the recorded file. If the recording is noisy and the spike is not very pronounced, you can aid detection by muting the audio immediately before and after the spike.

An error occurred reading the test tone file
Either the test tone file was not found or is not a valid test tone file. Always use a test tone file provided on the Sound Forge CD-ROM.

The selected Recorded file is much smaller than the test tone size
This may indicate that the test tone or the recorded file specified in the Recover tab is not correct. Verify that the length of the recorded file roughly the same size as the test tone file.

The end spike was not found
Verify that the spike following the test tone is present in the recorded file when recovering impulses in Auto-detect timing spikes mode

What is Wave Hammer?
Sonic Foundry's Wave Hammer DirectX plug-in is an audio mastering tool consisting of a classic compressor and a volume maximizer.
Wave Hammer can be used in any Microsoft DirectX-compatible host application (for example, Sound Forge and ACID Pro), and the quality and functionality of Wave Hammer is the same in each host application; however, the method of previewing effects is different. Consult your host application’s documentation to determine the available previewing methods.

Displaying Wave Hammer
To display Wave Hammer, choose Wave Hammer from the Effects menu.

Compressor tab
The controls on the Compress tab are used to compress the audio signal. When applied properly, compression will reduce the dynamic range of audio and allow you increase its overall loudness. Compression has various uses. For example, applying heavy compression at a low threshold to electric guitar will produce distortion.
Threshold

The Threshold fader is used to adjust the audio level at which compression will be applied. Audio with levels higher than the Threshold value will be compressed, while audio at levels lower than this value will pass through the compressor uninterrupted.

Ratio

The Ratio slider determines the amount of compression applied to audio signals surpassing the threshold. A ratio of 1:1 applies no compression to audio surpassing the threshold, while a ratio of 2:1 requires a 2dB increase in actual volume to raise the processed volume 1 db. A ratio of Inf:1 is considered a limiter.

Output gain

The Output gain fader allows you to determine how much the audio signal will be boosted following its compression.

Attack time

The Attack time slider allows you to determine how soon after rising above the threshold the audio signal will be attenuated.

Release time

The Release time slider allows you to determine how soon after falling below the threshold the audio signal attenuation will be interrupted.
Smart release

The Smart Release slider allows you to configure the compressor to automatically increase the release time for sustained notes and decrease the release time for sharp transients. Setting this value higher will increase the internal variability of the specified Release value. Generally, louder overall audio levels can be achieved with lower Release values. However, low Release values can also lead to an increase in “pumping” artifacts. Configuring a Smart Release value will increase the release time during sustained sounds, thereby preventing release changes from occurring too rapidly.

Scan mode

The Scan mode radio buttons allow you to specify whether Peak or RMS mode is used to determine the loudness of an audio file, which in turn determines the amount of compression that will be applied. When compressing in Peak mode, the compressor will apply compression where it detects audio signal peaks that will surpass the threshold.

However, when compressing using RMS mode, the compressor processes the audio using the detected average RMS value of the entire file. The Root Mean Square (RMS) of audio is a measure of its intensity over a period of time. Therefore, the RMS power of audio corresponds to the loudness perceived by a listener when measured over small intervals of time. As a result, rapid transient peaks may not be processed when compressing in RMS mode.

Auto gain compensate

When the Auto gain compensate check box is selected, the compressor output will be boosted by a constant amount derived from the Threshold and Ratio settings. This option prevents a loss in overall level when compressing audio.

Note: When using the Auto gain compensate option, the Output gain fader should be used to fine tune the signal output level.

Use longer look-ahead

When the Use longer look-ahead check box is selected, the compressor will scan farther ahead in the incoming audio to determine how much compression will be needed. This results in compression being applied before the threshold-surpassing audio actually occurs, thereby allowing for a slower Attack time value. However, the pre-compression effect (fades that occur prior to attacks) of this option may be distracting.
Smooth saturation
Selecting the Smooth saturation check box lowers the amount of distortion caused when applying heavy compression. When this option is enabled, the compressed audio will sound warmer and not overly bright.

Input/Output meter
This meter allows you to monitor the level of the incoming and outgoing signals. When the Input button is displayed, the meters are displaying the incoming signal level. Clicking Input will toggle the button to an Output button and display the outgoing signal level. Clicking Output will return you to the incoming signal display.

Attenuation meter
This meter allows you to monitor the audio signal attenuation derived from the current settings.

Volume Maximizer tab
The controls on the Volume Maximizer tab are used to limit the peak amplitude of an audio file or to boost the overall level without clipping the waveform and distorting the audio.
Threshold
The Threshold fader is used to adjust the audio level at which the volume maximizer will be activated. Audio with levels higher than the Threshold value will be affected, while audio at levels lower than this value will pass through the volume maximizer uninterrupted.

Output level
The Output level fader allows you to determine the level to which peaks above the Threshold setting will be boosted or cut.

Release time
The Release time slider allows you to determine how soon after falling below the threshold the audio signal attenuation will be interrupted.

Use longer look-ahead
When the Use longer look-ahead check box is selected, the volume maximizer will scan farther ahead in the incoming audio to determine the amount of limiting that will be needed. This results in limiting being applied before the threshold-surpassing audio actually occurs. However, the pre-limiting effect (fades that occur prior to attacks) of this option may be distracting.

Input/Output meter
This meter allows you to monitor the level of the incoming and outgoing signals. When an Input button is displayed, the meters are displaying the incoming signal level. Clicking Input will toggle the button to an Output button and display the outgoing signal level. Clicking Output will return you to the incoming signal display.

Attenuation meter
This meter allows you to monitor the audio signal attenuation derived from the current settings.
This chapter describes using Sound Forge in conjunction with internal and external MIDI devices. Please be aware that MIDI/SMPTE features are only available when using the full version of Sound Forge.

What is MIDI?

The musical instrument digital interface (MIDI) is a set of commands or a language that music software and hardware use to communicate. The most common way to utilize MIDI is to have a master device (a MIDI sequencer) generating and sending MIDI commands to a slave device (a synthesizer).

The Virtual MIDI Router

Sonic Foundry's Virtual MIDI Router (VMR) is a software-only driver used to synchronize MIDI operations. A MIDI router simply transfers MIDI data between ports. Sonic Foundry's VMR driver does exactly this, but without hardware. For more information, see Configuring the Virtual MIDI Router on page 269.

MIDI device naming

Since the VMR allows several MIDI devices to be connected to it, naming conventions of these devices are critical to avoid confusion. When dealing with multiple devices, the first character of the device name is a number ranging from 1 to 4.

Note: The device number is placed at the beginning of the name for compatibility with sequencer software that typically displays device names on small screens which reveal only the leading characters.
Installing the Virtual MIDI Router

The Sonic Foundry Virtual MIDI Router is included on the Sound Forge CD-ROM. To install the VMR, follow the instructions appropriate to your operating system.

Installing the VMR in Windows 98 or Me

1. From the **Start** menu, choose **Settings**, and choose **Control Panel** from the submenu.
2. Double-click the **Add New Hardware** icon and follow the Wizards until prompted to allow Windows to search for new hardware.
3. Select the No, I want to select hardware from a list radio button and click **Next**.
4. Double-click the **Sound, video, and game controllers** icon. Windows compiles a database of available drivers.
5. In the Manufacturer and Model dialog, click the **Have Disk** button.
6. Place the Sound Forge CD in the CD-ROM drive.
7. In the box, enter \D:\Extra\Virtual MIDI Router\Wim9x (where “D” represents the CD-ROM drive) and click **OK**.
8. Select the Sonic Foundry Virtual MIDI Router from the Models list and click **OK**.
9. Click **Finish**, specify the number of VMR ports to be made available to MIDI capable applications, and click **OK**.
10. When prompted, click **Yes** to restart Windows.

Installing the VMR in Windows 2000

1. From the **Start** menu, choose **Settings**, and choose **Control Panel** from the submenu.
2. Double-click the **Add/Remove Hardware** icon in the Control Panel window. The Add New Hardware Wizard is displayed.
3. Click **Next**. The Add/Remove Hardware Wizard prompts you to specify the hardware task.
4. Select the **Add/Troubleshoot a device** radio button.
5. Click **Next**. The Add/Remove Hardware Wizard displays a list of the system’s current hardware devices.
6. Choose **Add a new device** and click **Next**. The Add/Remove Hardware Wizard prompts you to let Windows automatically detect new hardware.
7. Select the No, I want to select the hardware from a list radio button and click **Next**.
8. In the Hardware types list, select Sound, video, and game controllers and click Next.

9. Click Have Disk and place the Sound Forge CD in the CD-ROM drive.

10. In the box, enter D:\Extras\Virtual MIDI Router\WinNT\x86\Oemsetup.inf (where “D” represents the CD-ROM drive) and click OK.

11. In the Models list, select Sonic Foundry Virtual MIDI Router and click OK.

12. Click Next to advance through the next two dialogs.

13. Specify the number of ports to enable from the Virtual MIDI Routing Ports list.

14. When prompted, click Yes to restart Windows.

Configuring the Virtual MIDI Router

Once the VMR is installed, a new MIDI device (named Sonic Foundry MIDI Router) is automatically created. You must now specify how many devices the VMR will be configured to support.

---

**Note:** When only one routing device is configured, the name of the driver is displayed as the Sonic Foundry MIDI Router. When multiple ports are used, each port is numbered to identify specific connections.

---

The following procedures describe configuring the number of VMR devices under Windows 98, Me, and Windows 2000.
Configuring the VMR for Windows 98 and Me

1. From the menu, choose Settings, and choose Control Panel from the submenu.
2. Double-click the Multimedia icon.
3. Click the Devices tab.
4. Double-click the MIDI Devices and Instruments list to expand it.
5. Select the Sonic Foundry MIDI Router and click Properties. The General dialog is displayed.
6. In the General dialog, click Settings. The Configure Sonic Foundry VMR dialog is displayed.
7. Choose the number of ports to be enabled from the Virtual MIDI Routing Ports drop-down list and click OK.
8. Click OK in all dialogs and restart Windows.

Potential Windows 98 and Me problems

If numerous MIDI devices are configured to the system or a multi-port MIDI board is used, problems may be experienced during installation of additional VMR MIDI interface ports. Windows typically experiences problems if more than eleven MIDI devices are installed. If frequent system errors or crashes are encountered after installing the VMR, do one of the following:

- Reduce the number of ports used by the VMR.
- Remove the VMR.
- Reduce the number of MIDI devices in the system.
Configuring the VMR for Windows 2000

1. From the Start menu, choose Settings, and choose Control Panel from the submenu.
2. Double-click the Sounds and Multimedia icon.
3. Click the Hardware tab.
4. Select Sonic Foundry Virtual MIDI Router from the list of devices and click Properties.
5. Click the Properties tab.
6. Double-click the MIDI Devices and Instruments icon.
7. Select the Sonic Foundry Virtual MIDI Router and click Properties.
8. Click Settings.
9. In the Configure Sonic Foundry VMR dialog, specify the number of ports to be enabled in the Virtual MIDI Routing Ports drop-down list and click OK.
10. Click OK in all dialogs and restart Windows.

MIDI triggers

Numerous internal and external devices can be used to generate MIDI commands and trigger audio playback in Sound Forge.

Playback Versus Triggered Playback

Procedures in this section use the Sound Forge MIDI Keyboard as the MIDI device for triggering audio playback.

For more information, see The MIDI Keyboard on page 288.

Simple playback

When a Play button is clicked in the Transport toolbar or Playbar, playback of the audio file in the active data window is initiated and you hear the audio. MIDI is not involved.
Triggered playback

When playback of the same file is triggered by the MIDI Keyboard, the following occur:

- The MIDI Keyboard transmits MIDI commands to the VMR.
- The VMR transmits the MIDI commands to the application's MIDI input port.
- Playback of the audio file starts

---

Note: In the case of triggered playback, MIDI commands may come from any software or hardware device that generates MIDI.

---

MIDI-triggered playback

Using the MIDI Keyboard or any other MIDI device to trigger audio playback in Sound Forge involves three separate procedures:

- Configuring the MIDI device (in this case, the MIDI Keyboard).
- Enabling MIDI input synchronization.
- Configuring the MIDI trigger.

Configuring the MIDI device

1. From the View menu, choose Keyboard. The MIDI Keyboard is displayed.

2. Open the Tutor1.wav file.
3. Click 🎵 and choose Sonic Foundry MIDI Router from shortcut menu.

4. Set the keyboard’s Output channel value to 1. The MIDI device is configured.

**Enabling MIDI input synchronization**

1. From the **Options** menu, choose **Preferences**. The Preferences dialog is displayed.
2. Click the MIDI/Sync tab.
3. Choose Sonic Foundry MIDI Router from the Input drop-down list and click **OK**.

**Configuring the MIDI trigger**

1. From the **Options** menu, choose **MIDI Triggers**. The MIDI Triggers dialog is displayed.
2. Select **Play All** from the Event list box.
3. In the Trigger section, select the Note radio button. The Channel and Note boxes are activated.
4. Enter **1** in the Channel box.
5. Enter **C4** in the Note box and click **OK**.

Sound Forge is now configured to play the Tutor1.wav file when it receives a C4 Note-On command on MIDI Channel 1.
Starting playback

1. From the **Options** menu, choose **MIDI Input Sync/Trigger**. A check mark is displayed adjacent to the command, indicating that it is active and Sound Forge is ready to receive MIDI commands.

2. Click the C4 key on the MIDI Keyboard.

The Tutor1.wav file is played in its entirety.

Resetting MIDI triggers

Once enabled, MIDI triggers are not permanent. They can be edited or deleted as needed.

1. Choose **MIDI Triggers** from the **Options** menu. The MIDI Triggers dialog is displayed.

2. Choose **Reset all triggers to (none)** from the **Name** drop-down list and click **OK**.

Triggered region playback

Frequently, it is preferable to use a MIDI device to control the triggering of the individual regions within a file. As in previous examples, the MIDI Keyboard will be used to demonstrate this function.

---

**Note:** Before performing this procedure, reset all triggers. For more information, see **Resetting MIDI triggers on page 274.**
Configuring region playback triggers

1. Display and configure the MIDI Keyboard. For more information, see Configuring the MIDI device on page 272.

2. Enable the MIDI input synchronization. For more information, see Enabling MIDI input synchronization on page 273.

3. Open the Tutor1.wav file and display its Regions List.

4. Double-click the “Wow” region. The Edit Marker/Region dialog is displayed.

   - Choose MIDI: Note - On Play from the Trigger drop-down list.
   - Enter 1 in the Channel box and C4 in the Note box.
   - Click OK. A small musical note is displayed adjacent to the “Wow” region in the Regions List to indicate that a trigger has been configured.

5. Choose MIDI: Note - On Play from the Trigger drop-down list.

6. Enter 1 in the Channel box and C4 in the Note box.

7. Click OK. A small musical note is displayed adjacent to the “Wow” region in the Regions List to indicate that a trigger has been configured.

8. Repeat steps 4 through 7, providing each region with a unique MIDI trigger.
Using region playback triggers

1. Choose MIDI Input Sync/Trigger from the Options menu. A check mark is displayed adjacent to the command, indicating it is active and Sound Forge is ready to receive MIDI commands.

2. Click C4 on the MIDI Keyboard. The “Wow” region is played.

3. Click other trigger keys on the MIDI Keyboard and observe how this feature can be used to play regions on cue or quickly rearrange an audio file.

   **Note:** Sound Forge can play only one region at any given time. Overlapping causes the active region’s playback to be interrupted and the new region’s playback to begin.

Additional internal/external MIDI devices

The basic concepts of MIDI routing and triggering from the Sound Forge MIDI Keyboard described in previous sections apply to any hardware or software device capable of generating MIDI commands.

Using internal/external MIDI controllers with Sound Forge

- Install and configure the MIDI controller (refer to the product-specific documentation for installation procedures).
- Enable MIDI input synchronization. For more information, see Enabling MIDI input synchronization on page 273.
- Configure the MIDI triggers to respond to the corresponding controls on the controller. For more information, see Configuring the MIDI trigger on page 273.

Advantages of external MIDI controllers

In addition to simple playback, MIDI commands can be used to control a wide array of Sound Forge’s navigation and editing functions. In fact, a quick look at the Event drop-down list in the MIDI Triggers dialog will provide you with an idea of the power of MIDI commands used in conjunction with Sound Forge.
External MIDI controller presets

Sound Forge comes equipped with system presets supporting the sequencer, cursor, dial, and function buttons on the following external MIDI controllers:

- Roland MCR-8 Multi-Controller.
- JLCooper Media Control Station 2

The system presets for these controllers allow you to do the following:

- Move the cursor using the controller’s dial.
- Drop markers by clicking the dial.
- Zoom in and out of the waveform using the cursor keys (vertically and horizontally).
- Start and stop audio playback using the sequencer controls.

---

**Note:** Users of the aforementioned external MIDI controllers need not limit themselves to Sonic Foundry’s default configurations.

---

Dropping markers/creating regions with an external MIDI controller

When triggering Sound Forge with an external MIDI controller, you should disable the Always ask for Region and Loop names option. This allows the application to label these units with defaults and prevents playback from being interrupted by dialogs.

1. From the Options menu, choose Preferences. The Preferences dialog is displayed.
2. Click the General tab.
3. Clear the Always ask for Region and Loop names check box and click OK.

Sound Forge and MIDI Timecode synchronization

MIDI Timecode (MTC) is a method of using SMPTE timing signals to synchronize multiple devices. Although MIDI Timecode is typically used to synchronize audio and video, it can also be used to synchronize playback devices. Sound Forge also has the ability to synchronize to external MTC or generate MTC for other devices to follow. For more information, see SMPTE Timecode on page 359.

With Sound Forge you can also specify start times of regions in the Regions List to synchronize digital audio with additional timed events. For example, if a MIDI sequencer generates SMPTE timecode, Sound Forge can synchronize to it with its own SMPTE timecode and initiate region playback at specified times.
MTC synchronization versus Note-On MIDI triggering

Synchronizing to MTC is similar to synchronizing to other MIDI events and can be used in many of the same situations. The major advantage of MTC synchronization is that it allows for accurate SMPTE start times to be specified within the application. However, MTC synchronization requires more of your system's processing power.

When triggering a limited number of sounds in Sound Forge from a sequencer, it is preferable to use Note-On MIDI Triggering. For more information, see MIDI-triggered playback on page 272.

Playing regions using MTC from a sequencer

Triggering region playback in Sound Forge from a sequencer using MTC involves three procedures:

- Configuring the regions.
- Enabling MIDI input synchronization.
- Configuring the sequencer.

Configuring the regions

1. Open the Tutor1.wav file and view the Regions List and Playlist.
2. Select the “Wow” region in the Regions List and drag it to the Playlist. The “Wow” region is added to the Playlist.
3. Double-click the “Wow” region in the Playlist. The Edit Playlist dialog is displayed.
4. Choose SMPTE: Play at Time from the Trigger drop-down list. The SMPTE time box is activated.
5. Enter an appropriate SMPTE start time using the hours:minutes:seconds:frames format and click OK. A small musical note is displayed adjacent to region in the Playlist to indicate that a start time for this region’s playback is configured.
Enabling MIDI input synchronization
1. From the Options menu, choose Preferences. The Preferences dialog is displayed.
2. Click the MIDI/Sync tab.
3. Specify the MIDI input that corresponds to the output port of the sequencer and click OK.
4. From the Options menu, choose MIDI Triggers. The MIDI Triggers dialog is displayed.
5. Choose Reset all triggers to (none) from the Name drop-down list. This will prevent other MIDI commands from creating additional triggers.
6. Click OK.
7. From the Options menu, choose MIDI Input Sync/Trigger. A check mark is displayed adjacent to the command to indicate that the application is ready and waiting for synchronization to MTC.

Configuring the sequencer
1. Set the sequencer’s MIDI output port to correspond with the application’s MIDI input port.
2. Enable the sequencer’s MTC output. If the sequencer supports generating MTC, it is now ready to sync.
3. Press the sequencer’s Play button. Sound Forge’s MIDI In status box displays the same SMPTE time as the sequencer’s SMPTE time. At the specified SMPTE time, Sound Forge starts playback of the region without interrupting the sequencer’s output to other devices.

Playing regions using MTC from an external device
When using a hardware device that generates MTC, the configuration procedure is basically the same as outlined above. Simply specify the device’s MTC output driver as Sound Forge’s MIDI input port in the Preferences dialog’s MIDI/Sync tab.

Using Sound Forge to generate MTC for a MIDI sequencer
Sound Forge can also be used as a tool to generate MTC for other devices to follow. However, it is important to understand that Sound Forge only generates MTC while playing a file or from a Playlist. Using the application to generate MTC involves two procedures:

- Configuring Sound Forge.
- Configuring the sequencer.
Configuring Sound Forge

1. Open an audio file.
2. From the Options menu, choose Preferences. The Preferences dialog is displayed.
3. Click the MIDI/Sync tab.
4. Specify the Sound Forge MIDI output that corresponds to the input port of the sequencer and click OK.
5. From the Options menu, choose MIDI Triggers. The MIDI Triggers dialog is displayed.
6. Choose Reset all triggers to (none) from the Name drop-down list. This will prevent other MIDI commands from creating additional triggers.
7. Click OK.
8. From the Options menu, choose MIDI Output Sync. A check mark is displayed adjacent to the MIDI Output Sync command, indicating that Sound Forge is ready to generate MTC.

Configuring the sequencer

1. Specify the sequencer's MIDI input port that corresponds to Sound Forge's MIDI output port.
2. Set the sequencer's SMPTE offset time value as needed.

*Note:* Sound Forge uses 00:00:00:00 as its output start point, but certain sequencers recommend a SMPTE offset time of at least four seconds to ensure synchronization.

3. Enable the sequencer's MTC input.
4. If required by the sequencer, press the Play button. The sequencer does not begin playback, but switches to “Waiting for MTC” mode.
5. Start playback of the file in Sound Forge. When the SMPTE offset time is satisfied, the sequencer locks to and follows the application-generated MTC.

Using Sound Forge to generate MTC for an external device

To use Sound Forge to send MTC to an external device, follow the previous instructions, but configure Sound Forge's MIDI output port to send directly to the device's MIDI driver.
Used in conjunction with the Sampler Tool, Sound Forge’s powerful editing capabilities allow you to create, edit, and transfer samples between external and internal samplers. This chapter describes the procedures used to transfer (dump) samples between the computer and sampler with the Sampler Tool.

**Samplers**

Samplers are devices that produce on-demand playback of audio samples at varying pitches. For the purposes of this manual, we will concentrate on two basic varieties of samplers: external samplers and internal samplers.

**External samplers**

External samplers are typically capable of recording samples or transferring prerecorded samples into their memory. There are two methods of transferring samples to external samplers supported by the Sound Forge Sampler Tool:

- MIDI Sample Dump Standard (SDS)
- SCSI MIDI Device Interface (SMDI)

**MIDI Sample Dump Standard (SDS)**

The MIDI SDS is used to send and receive digital samples using normal MIDI hardware and cable connections. Due to the limited bandwidth of the MIDI protocol and the large amount of data required by digital samples, a MIDI SDS transfer can be time consuming. Furthermore, SDS is limited to mono samples, though certain samplers do allow two mono samples to be joined as a stereo sample.
SCSI MIDI Device Interface (SMDI)

The SCSI MIDI Device Interface (SMDI) allows music hardware and software to communicate using SCSI hardware and cables. Because SCSI hardware has a greater bandwidth than MIDI, SMDI transfers are considerably faster than SDS transfers. In addition, SMDI supports mono and stereo sample transfers.

Internal samplers

Internal samplers are cards installed in your system that, unlike typical sound cards, actually allow sounds to be downloaded into memory and played at varying pitches to simulate a musical instrument.

Using an unsupported internal sampler

If you have an internal sampler not directly supported by the Sampler Tool, you have two options:

- Use the MIDI SDS transfer protocol.
- Use an open loop transfer.

Note: Users with Windows-compatible internal samplers should contact the manufacturer about supporting SDS in Windows drivers.

The Sampler dialog

Once the sampler hardware is installed and functioning correctly, the Sampler Tool must be configured to properly send and receive samples. The Sampler dialog allows you to do any of the following:

- Specify a preset sampler configuration.
- Set the logical send/receive sample number.
- Send and receive samples.

Displaying the Sampler dialog

To display the Sampler dialog, choose Sample from the Tools menu. At least one data window must be open to display the Sampler dialog.
Configuring the Sampler Tool

Configuring the Sampler Tool is fairly straightforward, especially if the desired configuration exists in the list of presets.

1. From the **Tools** menu, choose **Sampler**. The Sampler dialog is displayed.

2. Choose the desired configuration from the **Configuration** drop-down list. If the desired configuration is not listed, it must be created in the Sampler Configuration dialog. *For more information, see The Sampler Configuration dialog on page 283.*

3. Enter a value in the **Logical send/receive sample number** box.
   
   This value determines the number that the sampler will use as its location reference when sending or receiving samples. This number can be biased for specific samplers with the **Sample bias** option in the Sampler Configuration dialog. *For more information, see Creating a sampler configuration on page 283.*

4. Begin the process of sending or receiving samples. *For more information, see Sending and receiving samples on page 286.*

The Sampler Configuration dialog

The Sampler Configuration dialog allows you to create new sample configurations that can be saved as presets and accessed from the Sampler dialog. Creating new custom configurations requires you to specify the sampler and sample transfer mode.

Displaying the Sampler Configuration dialog

To display the Sampler Configuration dialog, click **Configure** in the Sampler dialog.

Creating a sampler configuration

All custom sampler configurations require you to specify the sample and transfer protocol. However, the process of creating a custom sampler configuration differs based on which transfer protocol is used.

1. From the **Tools** menu, choose **Sample**. The Sampler dialog is displayed.

2. Click the **Configure** button. The Sample Configuration dialog is displayed.

3. Choose the appropriate sampler from the **Sampler model** drop-down list. If the desired sampler is not included in the drop-down list, choose the **Generic SMDI or SDS capable sampler** option. If the sampler supports the specified protocol, the Sampler Tool should interface with the sampler.
4. Specify input/output settings for the sampler:
   
   - If your sampler uses MIDI/SDS transfer, click the MIDI radio button and choose input and output ports in the MIDI Out and MIDI In boxes.
   - If your sampler uses SCSI/SMDI transfer, click the SCSI radio button and select your sampler in the Sampler box.

   **Note:** The Sampler box will list all devices connected to the selected SCSI host, including devices that are not samplers.

5. If desired, enter a value in the Sample bias box. Sample bias is a user-specified value that is added to the logical sample number to determine the actual sample number used for sending or receiving.

   Additionally, sample bias can be used to define unique bases for multiple projects. For example, when composing multiple pieces using different samples, it is possible to create unique sampler configurations for each project. Simply establish a unique sample bias to segregate the samples within the sampler.

6. Enter a value in the MIDI channel box to specify which MIDI channel (1-16) will be used when transferring samples.

7. Select the Open loop check box if you want to send SDS sample data immediately upon clicking the Send Sample button. This is an unconditional transfer of sample data (no handshake).

8. Select the Send request when retrieving samples check box if you want the Sampler tool to send a request for the sample to the sampler when Get Sample is clicked.

   Clearing the Send request check box requires that the sample transfer be initiated from the sampler, even after Get Sample is clicked. Typically, pressing the appropriate button on the sampler satisfies this request.

9. Select the Wait for request check box if you want the Sampler tool to wait for the sampler to request the sample transfer before sending the sample, even after Send Sample is clicked. Typically, pressing the appropriate button on the sampler satisfies this request.

   Clearing the Wait for request check box configures the Sampler Tool to send the sample as soon as Send Sample is clicked.
Open loop versus closed loop

Open loop describes a unidirectional communication protocol. When the Open loop check box is selected, the source transmits all data to the destination without listening for instruction from the destination. The destination has no control over how the data is sent and cannot ask for information to be repeated. This lack of feedback makes open-loop transfers prone to error.

If the Open loop check box is cleared, the communication protocol is referred to as closed loop. A closed-loop allows information to flow in both directions. Using closed loop transfers, data is sent from the source in small packets and the destination, upon receiving the packet, either retains the data or discards the packet and requests the data to be resent. Using closed-loop protocol, the source will not send the next packet of data until the destination requests it. This makes closed-loop transfers more reliable than open-loop transfers.

In addition to being less reliable, open-loop transfers are slower than closed-loop transfers, especially when sending samples using the Sampler Tool. This is due to intentional delays placed between data packets to compensate for varying sampler speeds. Closed-loop transfers typically guarantee the most efficient timing between packets.

If possible, avoid using an open loop to receive samples from a sampler. The Sampler Tool cannot control the flow of data packets and there is a high probability that data will be missed.

Note: Open-loop transfers can be useful when you do not have enough cables to connect both the MIDI input and MIDI output ports.
Saving sampler configurations

Once a sampler configuration is completed, it can be saved as a preset and quickly accessed in the future.

1. From the Sampler Configuration dialog, click Save As. The Save Preset dialog is displayed.

2. Enter a descriptive name in the New preset name box and click OK. The new configuration is saved and can now be chosen from the Configuration drop-down list in the Sampler dialog.

   Note: To delete a preset, choose it from the Name drop-down list and click Delete.

Sending and receiving samples

Once the sampler setup is accurately configured, samples can be sent and received using the Send Sample and Get Sample buttons in the Sampler dialog.

Sending a sample

1. From the Tools menu, choose Sampler. The Sampler dialog is displayed.

2. Choose the sampler configuration from the Configuration drop-down list.

3. Enter the sample number to be sent in the Logical send/receive sample number box. The Sampler Tool takes into account the configuration’s sample bias and displays values for the Actual send sample number and Actual receive sample number. For more information, see Creating a sampler configuration on page 283.

4. Click Send Sample. Sample transfer is started and its progress indicated by a meter in the status bar. A transfer can be cancelled at any time by clicking Cancel or pressing Esc.
Receiving a sample

1. From the Tools menu, choose Sampler. The Sampler dialog is displayed.

2. Choose the sampler configuration from the Configuration drop-down list.

3. Enter the sample number to be received in the Logical send/receive sample number box. The Sampler Tool takes into account the configuration’s sample bias and displays values for the Actual send sample number and Actual receive sample number. For more information, see Creating a sampler configuration on page 283.

4. Click Receive Sample. Sample transfer is started and its progress indicated by a meter in the status bar. A transfer can be cancelled at any time by clicking Cancel or pressing Esc.

MIDI unity note and Fine tune

Once a configuration is specified in the Sampler dialog, the Sampler area near the bottom of the dialog display all relevant sampler configuration information.

The bottom pane of the dialog contains two additional parameters: MIDI unity note and Fine tune.

| MIDI unity note | C4 (60) | Fine tune (cents) | 0.000 |

MIDI unity note

The MIDI unity note value indicates the pitch to which the sample is tuned.

Fine tune

The Fine tune value indicates any minor tuning differences (measured in cents) in the sample.

Editing MIDI unity note and Fine tune

Both values can be edited and used with samplers that support tuning information by choosing Edit Sample from the Special menu.

Note: Sound Forge does not use this information.
The MIDI Keyboard

With the MIDI Keyboard, you can control internal/external synthesizers and samplers from Sound Forge. The MIDI Keyboard can also be used to listen to the sounds on a synthesizer or in the synthesis section of the sound card.

Displaying the MIDI Keyboard

To display the MIDI Keyboard, choose Keyboard from the View menu. The keyboard can be resized, moved, or docked within the workspace.

Turning the MIDI Keyboard on

Clicking any key turns the keyboard on. If no sound is heard, verify that the output is connected to the MIDI Output device.

Configuring the MIDI Keyboard output port and channel

1. Click and choose an output device from shortcut menu.

2. Choose Send Program Changes from the shortcut menu if the keyboard will be used to choose instrument voices. A check mark is displayed adjacent to the command to indicate that this option is enabled.
3. Configure the MIDI input channel of the selected device to correspond to the keyboard's output channel.

**Note:** Most MIDI devices are configurable to accept MIDI commands on any channel.

**MIDI Keyboard troubleshooting**

If after configuration, the keyboard fails to produce sound, check the following:

- Verify that the output velocity of the keyboard is set to a value greater than 100.
- Verify that the MIDI input channel in the sound module is set to the same channel as the keyboard.
- Verify that the device is configured to receive MIDI input.
- Verify the device output volume level.
- Verify external MIDI connections, if applicable.

**Specifying instruments**

1. Choose **Send Program Changes** from the shortcut menu. A check mark is displayed adjacent to the command to indicate that this option is enabled. If this option is not enabled, patches cannot be switched.

2. Choose the new voice from the **Voice** drop-down list and click any key.

**Note:** Patch names are arranged as specified in the General MIDI Standard. For synthesizers not using the General MIDI convention, use the patch number instead of the instrument name.

**Generating chords**

You can also generate chords instead of single notes by choosing a chord structure from the keyboard’s **Note/Chord** drop-down list. Chords are generated using the specified note as the root of the chord or interval.
MIDI/SDS hardware setup

To use the MIDI/SDS protocol with an external sampler that supports MIDI/SDS, a MIDI card with MIDI input and output ports must be installed in the system.

1. Using a MIDI cable, connect the MIDI output port of the sampler to the MIDI input port of the MIDI card.

2. Connect the MIDI input port of the sampler to the MIDI output port of the card.

Note: This is the same configuration used to connect a MIDI keyboard to a computer for sequencing.

Internal samplers do not require a MIDI card and MIDI cables; however, an open-loop protocol may be required when sending samples to an internal sampler. The sampler’s documentation should specify the requirements for performing SDS transfers if it is supported.

MIDI/SDS troubleshooting with open loop

Open-loop transfers, while not recommended for sending or receiving samples, can assist you in troubleshooting SDS hardware setup problems. If the Sampler Tool does not transfer data to (or from) the sampler, select the open-loop option and attempt single cable transfers. If open-loop transfers are successful, but closed-loop transfers are not, any of the following may be the cause:

• The sampler does not support closed-loop transfers (handshaking).
• One or more of the MIDI cables or connections is faulty.
• The MIDI card is not receiving MIDI input (send) or sending MIDI output (receive).
  Interrupt conflicts are common for MIDI input.

SCSI/SMDI hardware and setup

To use the SCSI/SMDI protocol with an external sampler that supports the SCSI/SMDI protocol under Windows 98, Me, or 2000, only a compatible SCSI adapter is needed. The computer and sampler must be powered-down prior to connecting or disconnecting SCSI cables to prevent damage to the computer and/or hardware.
SCSI/SMDI troubleshooting

A brief description of some common problems encountered with SCSI and samplers follows.

Conflicting SCSI IDs

When connecting devices on a SCSI chain, each device must have a unique device identifier (ID). SCSI allows for up to eight unique ID values, numbered 0 to 7. Typically, device ID 7 is used for the internal SCSI controller card, leaving ID 0 through 6 for other devices.

---

**Note:** The ID of a bootable SCSI hard drive must be set to 0.

---

The following table describes a typical SCSI configuration:

<table>
<thead>
<tr>
<th>ID</th>
<th>Device(s)</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>Hard Drive</td>
</tr>
<tr>
<td>1</td>
<td>CD-ROM Drive</td>
</tr>
<tr>
<td>2-6</td>
<td>Samplers</td>
</tr>
<tr>
<td>7</td>
<td>SCSI Controller Card</td>
</tr>
</tbody>
</table>

Periodic transfer failures

Messages such as “The SCSI Device is not responding” or “A problem was encountered while transferring the sample” may indicate a problem with a SCSI bus.

1. Choose Sampler from the Tools menu. The Sampler dialog is displayed.
2. Click Configure. The Sampler Configuration dialog is displayed.
3. Repeat the selection of the SCSI host. This causes a series of SCSI commands to be executed that may settle the bus.
   - If the problem persists, power-down and restart all equipment.
The sampler is recognized but does not transfer reliably

The following are possible causes of unreliable SCSI transfers.

**Synchronous transfer mode**

Select samplers (the Kurzweil K2000 among them) do not operate properly if there is a SCSI device set to synchronous transfer mode on the same SCSI chain. SCSI hard drives and CD-ROMs often have the option of using a synchronous transfer mode. If there is a host versus device synchronous transfer option, select the host option. Refer to the SCSI device’s documentation for more information.

**SCSI termination**

If the SCSI chain is not properly terminated, unreliable SCSI transfers may be experienced. Refer to the SCSI card and SCSI device documentation for more information.

**Long or faulty SCSI cables**

SCSI cables that are very long or not properly shielded may not operate reliably. In addition, do not use cables that are not certified SCSI cables.

**Adaptec 1540/1542CF does not recognize a sampler**

If the Adaptec 1540/1542CF does not recognize the sampler, a change may be required in the configuration of the Adaptec controller. Some samplers do not operate when the Reset SCSI Bus at Power-On option of the Adaptec controller is turned on. This is the default operation for the 1540/1542CF and must be turned off to allow the system to work with the sampler.

---

**Note:** Turning off the Reset SCSI Bus at Power-On option may keep other devices on the SCSI chain from resetting correctly when using the system’s soft boot feature. Other systems may freeze temporarily. To guarantee that devices are reset when rebooting with this option turned off, use the system’s reset button or power-down and up to reset the system.
The SCSI/SMDI-compatible menu is not displayed under Windows 98 and Me

Verify proper SCSI termination and check for multiple devices on the SCSI chain using the same SCSI ID. If this fails to solve the problem, Adaptec SCSI card users may need to update the system's mini-port drivers. Adaptec has a series of updated mini-port drivers available for Windows 98 and Me on CompuServe and the Web.

After the file is downloaded, a temporary directory or folder must be created on the system and program WIN95MPD.EXE must be run. Follow the directions in the readme.txt file to update the drivers for the Adaptec SCSI card.
Sound Forge is an excellent tool for creating loops and provides the perfect compliment to Sonic Foundry's revolutionary ACID™ line of loop-based music creation tools.

Creating loop regions in files is useful only when you intend to transfer the files to a hardware sampler that supports the loop regions.

**Loops**

A loop is a sample or region in an audio file that is repeated during playback. Samples are finite and frequently very short in length. Therefore, they must be repeated (or looped) to create longer or sustaining sounds.

**Note:** Loops can also be used to repeat entire sections of music in Sound Forge, although the Playlist is better suited to this purpose.
Sustaining and release loops

A sound envelope contains four elements: attack, decay, sustain, and release.

Typically, the sustain portion of the envelope is looped to lengthen the duration of a sound. This is referred to as the sustaining loop.

While sustaining loops are useful, it is frequently necessary to create a second loop, taken from later in the envelope. This allows you to reproduce longer, more complex sounds, such as a piano chord struck with the sustain pedal depressed. This second type of loop is referred to as the release loop.

Creating a sustaining loop

1. Open the Tutor2.wav file and create a selection containing the snare hit at the beginning of the waveform.

2. From the Special menu, choose Edit Sample. The Edit Sample dialog is displayed.

3. In the Edit Sample dialog, select the Sustaining radio button. The controls in the middle pane of the dialog are activated.
4. Select the Loop count radio button. The edit box is activated.

5. Enter a value of 10 in the Loop count box and click OK. The data window displays the appropriate tags in the ruler to specify the loop's start and end points.

6. Click on the Playbar. The looped snare selection is repeated ten times before the cymbal crash is heard.

Creating a sustain loop with a release loop

To add a release loop to the sustain loop created in the previous procedure, you must reconfigure the dialog and rearrange the loop tags in the data window.

Configuring the dialog

1. Right-click either of the loop tags and chose Edit from the shortcut menu. The Edit Sample dialog is displayed.
2. In the Edit Sample dialog, select the Sustaining with Release radio button and click OK.
3. Verify that the Release radio button is selected in the Loop to edit pane of the dialog.
4. Select the Loop count radio button. The edit box is activated.
5. Enter a value of 5 in the Loop count box and click OK. The dialog is now configured with both loop varieties.
Arranging the loop tags

Once the dialog is properly configured to support a release loop, release loop tags are created in the data window beneath the sustaining loop tags. The sustaining and release loops temporarily contain identical data.

1. Drag the sustaining loop end tag toward the left-hand side of the data window to reveal the release loop end tag.

2. Drag the sustaining loop start tag toward the left-hand side of the data window. This will reveal the release loop start tag.

3. Arrange the loop tags so that the snare hit is contained within the sustaining loop and the cymbal crash is contained within the release loop.

4. Click in the Playbar. The entire file is played with the snare hit repeated ten times followed by the cymbal crash five times.

Looping techniques

Depending upon the source material, creating a natural-sounding loop can be a difficult task. Many factors beyond your control may produce distracting pops and glitches, thereby calling unwanted attention to the loop. Looping skill is largely the product of practice and experimentation, but here are some guidelines.
Match endpoint amplitudes

One of the easiest ways to minimize the occurrence of glitches when creating loops is to select loop endpoints that have an amplitude of zero. These points are known as zero-crossings. For more information, see Zero-Crossing Finders on page 304.

Match endpoint waveform slope

Another technique for reducing loop glitches is to avoid matching loop endpoints of where the waveform slope does not match. If the waveform slope changes drastically, a pop will be heard when the sample is looped.
Match endpoint sound levels

The overall amplitude (or loudness) approaching the loop’s endpoints should be as similar as possible to prevent distracting glitches. Unfortunately, it is frequently difficult to avoid this problem, particularly with rapidly decaying source material. For more information, see Loop amplitude on page 303.

Avoid very short loops

If the loop is shorter than ~50 ms (1/20 Hz) the pitch of the loop may not equal the sample pitch. Pitch-tuning a loop is accomplished by creating short loops with a length equal to 1/frequency. For example, a sample of pitch 440 Hz corresponds to A5 on the keyboard, meaning the loop can be pitch-tuned 2.27 ms. However, pitched loops do not sound like the original sample.

Editing loops

You will quickly discover that the loop initially created in any situation is rarely perfect. Frequently, loops require some degree of editing before they are usable.

Editing a loop without the Loop Tuner

Once a loop is created, its beginning and end (and subsequently its length) can be quickly edited by dragging the markers to a new location. However, this method frequently does not provide the control required to create seamless loops. In this case, the loop should be edited using the Loop Tuner.
Editing a loop with the Loop Tuner

The Loop Tuner allows you to precisely edit loop points in order to prevent distracting audio glitches. This is accomplished by greatly magnifying the waveform and displaying the loop tags in relation to one another.

The left-hand side of the Loop Tuner window displays the end of the loop, while the right-hand side displays the start of the loop. This arrangement allows you to fine-tune loops by viewing a graphical representation of the junction between the end and the start of a loop.

In addition, the Loop Tuner contains several tools designed to assist you in creating professional-sounding loops.

Displaying the Loop Tuner

1. Open the Tutorsmp.wav file.

2. From the View menu, choose Loop Tuner. The Loop Tuner is displayed containing the waveform of the file’s loop.
Playing loops using the Loop Tuner

The Loop Tuner contains three playback buttons: Play Pre-Loop, Play Loop, and Play Post-Loop.

- Click Play Pre-Loop to start playback of a file from its beginning and stops playback at the loop start tag.
- Click Play Loop to start playback of the looped region. The number of times the loop is played is dependent upon the Loop count value in the Edit Sample dialog. The loop should be auditioned for pops and glitches using this button. For more information, see Creating a sustaining loop on page 296.
- Click Play Post-Loop to start playback immediately following the loop end point and continue through the end of the file.

**Note:** The Play as Sample button in the Playbar can still be used to audition the entire sample with configured loops.

Switching between the sustain and release loops

When working with a file that contains sustain and release loops, you can quickly toggle between the loops by clicking the Loop Select button.

When working with a file containing two loops, this button indicates which loop is active.

- indicates that the sustaining loop is active.
- indicates that the release loop is active.

**Note:** If separate sustain and release loops are not present, the Loop Select button is not available.

Loop amplitude

The sample amplitude at the loop’s start and end points is displayed in the lower right-hand corner of the Loop Tuner.

![Start Loop Amplitude: 514, End Loop Amplitude: -896](image)

Although it is dependent upon the specific waveform, a good rule of thumb is that the closer these two amplitude values are, the more natural sounding the resulting loop.
Zero-Crossing Finders
The Loop Tuner’s Zero-Crossing Finders are used to locate zero-crossings adjacent to the current loop tag location.

The Loop Tuner contains two Zero-Crossing Finders for each of the loop points.
- The left button in each pair locates the zero-crossing to the left of the current location.
- The right button in each pair locates the zero-crossing to the right of the current location.

To use the finders, click the desired button. By experimenting with different locations and repositioning the start and end points, seamless loops can be created. You are also able to configure the Zero-Crossing Finders to locate positive slope crossings, negative slope crossings, or all zero-crossings.

Configuring the Zero-Crossing Finders
1. From the Options menu, choose Preferences. The Preferences dialog is displayed.
2. Click the Editing tab.
3. Choose the desired slope from the Snap to zero-crossing slope drop-down list and click OK.

Fine-tuning loop points
Using the Loop Tuner, three methods are available for fine-tuning loop points:
- To move loop points by small amounts, use the Start point and End point arrow buttons. Clicking the up or down arrow increments the loop point by one sample.
- To move loop points by larger amounts, use the mouse to drag the spinner up or down.
- To move loop points by very large amounts, use the mouse to drag the ruler at the top of the Loop Start or Loop End display.
Lock Loop Length

The **Lock Loop Length** button allows you to freely move the start and end points of a loop without altering its length. When the button is selected, any editing that moves a loop point affects both loop points, thereby keeping the loop length constant.

Clicking a second time turns off this feature and allows loop points to be edited independently with no regard for the loop's original length.

**Note:** The **Lock Loop Length** button has the same function as the **Lock Loop/Region Length** command in the Options menu.

The Crossfade Loop tool

The **Crossfade Loop** tool can be used to loop audio from difficult source material. It allows the end of a loop to be crossfaded with the beginning of the loop in order to create a smoother, more natural-sounding transition. In addition, the **Crossfade Loop** tool can be configured to crossfade the beginning of the audio loop with the beginning of the post-loop audio on the loop's final pass. This will smooth the occasionally awkward transition from looped to non-looped audio.

Using the Crossfade Loop tool

1. Open the Tutorsmp.wav file.
2. From the **Tools** menu, choose **Crossfade Loop**. The Crossfade Loop dialog is displayed.
3. Drag the **Loop** slider to configure the percentage of the loop to be crossfaded.
4. If desired, select the Post-Loop check box and drag slider to configure the percentage of the loop to be crossfaded into the post-loop audio.

5. Choose the preview from the Preview mode drop-down list to specify how the Preview button operates: Loop the Loop, Play Loop through Post-Loop, or Play as One Shot.

6. Preview and tune the crossfade until the loop transitions cannot be detected.

7. Click OK.

Looping and ACID

Sound Forge is an excellent tool for creating and editing loops to be imported into any of the ACID family of products.

Displaying the ACID Loop Creation Tools toolbar

1. From the Options menu, choose Preferences. The Preferences dialog is displayed.
2. Click the Toolbars tab.
3. Select the ACID Loop Creation Tools check box and click OK.
ACID Toolbar functions

The following sections describe the functions available to you on the ACID toolbar.

Editing ACID properties

Clicking the Edit ACID Properties button displays the Edit ACID Properties dialog and allows you to specify the type of ACID sample to be created.

Note: The Edit ACID Properties dialog can also be displayed by choosing Edit ACID Properties from the Special menu.

Creating an ACID one-shot

One-shots are samples that do not stretch with tempo or change pitch to match the key of the ACID project. This behavior makes one-shots particularly suited for samples such as cymbal crashes, sound effects, and short vocal lines.

1. Open the Tutor1.wav file.
2. Create a selection containing the “Wow” and drag it to the workspace. A new data window is created containing the “Wow” audio data.
3. Click . The Edit ACID Properties dialog is displayed.
4. From the Special menu, choose Edit ACID Properties.
5. Select the One-Shot radio button and click OK.
6. Choose Save As from the File menu and save the sample with a descriptive name.

Creating an ACID loop

Loops are musical building blocks and are by far the most common type of sample used in ACID. Loops stretch and contract with an ACID project’s tempo and can be configured to change pitch. When creating ACID samples in Sound Forge, the Edit ACID Properties dialog defaults to the loop setting.

1. Open the Tutor1.wav file.
2. Create a selection containing the “And easier” and drag it to the workspace. A new data window is created containing the “And easier” audio data.
3. Click . The Edit ACID Properties dialog is displayed.
4. Select the Loop radio button. The Number of beats and Root note for transposing boxes are activated.

5. In the Number of beats box, specify the length of the loop, in beats. The default value is four beats.

6. If the loop should be transposed when inserted in an ACID project, choose its root note from the Root note for transposing drop-down list.

   If the sample should not be transposed in an ACID project, choose Don’t transpose from the drop-down list.

7. Click OK.

8. Choose Save As from the File menu and save the sample with a descriptive name.

Creating an ACID disk-based sample

Disk-based samples can stretch and contract to comply with an ACID project’s tempo, but require that the sample’s original tempo be specified upon configuration. If the original tempo is not specified in the Edit ACID Properties dialog, no stretching or contracting will occur. Disk-based samples are typically used in ACID for extended vocal tracks.

1. Open the Tutor1.wav file and select the entire waveform.

2. Click . The Edit ACID Properties dialog is displayed.

3. Select the Disk-Based radio button. The Tempo check box is activated.

4. If the sample should be stretched/contracted to match the ACID project’s tempo, select the Tempo check box. The Tempo box is activated.

5. Specify the sample’s original tempo (60-240 bpm) in the Tempo box and click OK. For more information, see Loop tempo on page 311.

6. Choose Save As from the File menu and save the sample with a descriptive name.
Loop halving /doubling

These commands allow you to quickly change the size of a selection.

To cut a selection in half, do any of the following:

- Click on the ACID Loop Creation Tools toolbar.
- From the Special menu, choose ACID Looping Tools, and choose Halve Selection from the submenu.
- Press .

To double the size of a selection, do any of the following:

- Click on the ACID Loop Creation Tools toolbar.
- From the Special menu, choose ACID Looping Tools, and choose Double Selection from the submenu.
- Press .

Shift selection left/right

The shift selection commands allow you to quickly create a new selection adjacent to the current selection while maintaining the size of the original.

To create a new selection to the left of the current selection, do any of the following:

- Click on the ACID Loop Creation Tools toolbar.
- From the Special menu, choose ACID Looping Tools, and choose Shift Selection Left from the submenu.
- Press .

To create a new selection to the right of the current selection, do any of the following:

- Click on the ACID Loop Creation Tools toolbar.
- From the Special menu, choose ACID Looping Tools, and choose Shift Selection Right from the submenu.
- Press .
Rotate Audio

To move the beginning of a sample to the end, or the end of a sample to the beginning, do any of the following:

• Click on the ACID Loop Creation Tools toolbar
• From the Special menu, choose ACID Looping Tools, and choose Rotate Audio from the submenu.
• Press .

If no audio is selected, Rotate Audio transfers the first 25% of the sample to the end of the sample.

**Note:** If the selected audio does not originate from the start or end of a sample, Rotate Audio has no effect.

- If audio is selected from the start of a sample, Rotate Audio transfers the selection to the end of the sample.

Using the Rotate Audio function with no selection

Using the Rotate Audio function with a selection at the start of a sample
• If audio is selected from the end of a sample, Rotate Audio transfers the selection to the start of the sample.

Loop tempo

The Edit Tempo dialog allows you to calculate, and if necessary edit, the tempo of your loops. Loop tempo is especially important if the loop will be used for building a project in any ACID product. For more information, see Looping and ACID on page 306.

Calculating loop tempo
1. Select the loop.
2. From the Special menu, choose Edit Tempo. The Edit Tempo dialog is displayed.
3. Specify the number of beats the loop represents in the Selection Length in Beats box.
4. Click the mouse pointer in the Tempo in Beats per minute box. The loop tempo is calculated and displayed.

Calculating loop tempo using the ACID Loop Creation Tools toolbar
To calculate loop tempo using the ACID Loop Creation Tools toolbar, select the looped audio in the data window. The tempo pane indicates the loop tempo based on the current Beat Length value.
Saving loop points

Loop points are automatically saved when the file is saved in .wav, .sds, .smp, .dig, .pat, and .aif file formats.

Disabling the loop points

When saving audio files to the .wav format, you can turn off the loop point saving feature.

1. From the File menu, choose Save As.
2. Choose Wave from the Save as type drop-down list.
3. Clear the Save Sampler Information check box.
4. Click Save.
Sound Forge supports opening and saving Microsoft Audio and Video Interleave (AVI) files. Using Sound Forge, you can edit an AVI file’s audio track with single-frame accuracy.

Opening an AVI file

1. From the **File** menu, choose **Open**. The Open dialog is displayed.
2. Choose **Video for Windows (*.avi)** from the **Files of type** drop-down list.
3. Select an AVI file and click **Open**. The file is opened based on the streams saved in the file:
   - If the file contains only one video stream and one audio stream, these streams are active when the file is opened.
   - If the file contains no audio stream, the file is opened and a silent audio stream is created.
   - If the file contains multiple audio or video streams, you are prompted to specify the audio and video stream that will be active when the file is opened. For more information, see **Multiple streams** on page 314.
Multiple streams

An AVI file may contain multiple audio and video streams, each containing a unique version of the video or audio track. For example, a file may contain one video stream and multiple audio streams, each consisting of the same voiceover in a different language. In this case, the AVI player detects which language version of Windows the system is using and selects the appropriate audio stream.

When editing a file that contains more than one audio or video stream, you must specify which stream will be active in Sound Forge. The active stream is specified in the Video Stream dialog. However, this dialog is displayed only when a multiple-stream AVI is opened.

To specify a stream, click to the left of the desired stream. A ◆ is displayed, indicating that the stream is selected. Once streams are selected, click OK to open the file.

AVI navigation

Navigating the video strip

Though Sound Forge does not perform video editing, the video strip display allows you to navigate AVI files.
Displaying/hiding the video strip

If the video strip is not displayed, right-click the data window’s tool display and choose Video from the shortcut menu. A check mark is displayed adjacent to the command and the video strip is displayed. To hide the video strip, choose Video from the shortcut menu again.

Frame animation

When playing an AVI, you are able to specify if frames are animated or displayed as still frames. To turn on frame animation, right-click the video strip and choose Animate from the shortcut menu. A check mark is displayed adjacent to the command to indicate this feature is turned on.

Using the cursor to select a frame

When Frame Animation is enabled, clicking anywhere within the audio portion of the data window displays the corresponding video frame in the video strip. This is a convenient method of viewing many individual frames, but does little to achieve frame-accurate synchronization.

Zooming in and out

When attempting to synchronize audio and video, you will typically want to take a closer look at the AVI than is provided by keyframes and cursor control.

1. Open an AVI file and display the video strip.
2. Right-click the video strip and choose Number Frames from the shortcut menu. The video frames are numbered.
3. Using the data window’s zoom ratio controls, zoom in/out on the waveform several times and observe the numbering of the video frames.
Video preview

To view a larger version of the AVI, choose Video Preview from the View menu during editing or playback. The current frame is displayed in Video Preview window.

An asterisk displayed adjacent to the frame number indicates that the current frame is a keyframe. For more information, see Keyframes on page 319.

To display the Video Preview screen, press Alt + 1.

Attaching video to an audio file

Once an audio file is edited to your satisfaction, it can be attached to a video file and saved as an AVI.

1. Open an audio file in Sound Forge.
2. From the File menu, choose Properties. The Properties dialog is displayed.
3. Click the Video tab.
4. Click Attach. The Attach Video dialog is displayed.
5. Select an AVI file and click **OK**. The Video Properties dialog is displayed, listing all audio and video streams in the AVI.

![Select the streams to be saved](image)

- The check boxes to the left of the streams are used to select which streams are saved with the AVI. Selecting a check box saves the corresponding stream. Clearing the check box results in the stream being discarded when the AVI is saved.
- The ◆ icons located to the right of the check boxes indicate which streams are active in Sound Forge when the AVI is attached to the .wav file.
- Click ✯ to display the stream’s properties.

6. Specify the active streams and the streams to save in the AVI file and click **OK**.

**Note:** The file must be saved as an AVI to permanently attach the video. For more information, see Saving an AVI file on page 317.

---

**Saving an AVI file**

Saving an AVI in Sound Forge is essentially a three-step process that involves doing the following:

- Specifying the audio and video streams to be saved.
- Compressing the video.
- Compressing the audio.
Specifying the audio and video streams

1. From the **File** menu, choose **Save As**. The Save As dialog is displayed.
2. Choose Video for Windows from the Save as type drop-down list.
3. Name the file in the **File name** box and click **Save**. The Video Save Options dialog is displayed.
4. Select the check box(es) corresponding to the audio and video streams to be saved in the AVI file.
5. Choose the desired video frame size from the **Re-size video frames to** drop-down list and click **OK**. The Compression Options dialog is displayed. *For more information, see Compressing the video on page 318.*

Compressing the video

After you click the **OK** button on the Video Save Options dialog, the Compression Options dialog is displayed to allow you to compress the video and audio streams.

1. Choose a video stream to compress from the **Choose a stream** drop-down list.
2. Click **Options**. The Video Compression dialog is displayed. In this dialog, you can specify the following items:
   - The compressor (See “Compression algorithms” on page 319.).
   - Keyframe frequency (See “Keyframes” on page 319.).
   - Data rate (See “Data rate” on page 320.).
3. Choose a compressor from the **Compressor** drop-down list.
4. If applicable, enter appropriate **Key Frame** and **Data Rate** values.

*Note:* Only certain compressors allow keyframe frequency and data rate values.
Compression algorithms

When using compression algorithms, you must strike a balance between video quality, size reduction, and compression/decompression processing time. Applying extreme compression to video often results in visual artifacts, such as jumpy or grainy video.

When saving an AVI in Sound Forge, you can specify any of the compressors installed in the system from the Video Compression dialog. Numerous compressors are available for use with Windows.

Keyframes

Keyframes are frames in a video stream that are not compressed. Certain compressors use keyframes to derive compressed frames and—while fewer keyframes results in a smaller file sizes—additional time is required to display the file.

When editing AVI files in Sound Forge, the display speed suffers when there is only one keyframe in a file. In such cases, the program must scan all preceding data to render each frame.

1. With an AVI file open on the workspace, choose Save As from the File menu. The Save As dialog is displayed.
2. Choose Video for Windows from the Save as type drop-down list.
3. Name the file in the File name box and click Save. The Video Save Options dialog is displayed.
4. Select the streams to be saved and click OK. The Compression Options dialog is displayed.
5. Choose the video stream to be compressed from the Choose a stream drop-down list and click Options.
6. Choose a compression method that allows keyframes from the Compressor drop-down list. The Key Frame Every and Data Rate check boxes are activated.
7. Select the Key Frame Every check box.
8. Enter a keyframe frequency value in the Key Frame Every box and click OK.
Data rate
For compressors that use keyframes, you can also specify the data rate of the video. This value directly relates to the size of the file and is also set in the Video Compression dialog. Individual compressors use this value differently because it is only an expected value. Unless you are dealing with limited playback data rates, such as encountered with a single-spin CD-ROM, this check box should be cleared.

1. Select the Data Rate check box.
2. Enter an appropriate value in the KB/sec box and click OK. The Compression Options dialog is displayed again.

**Note:** Before clicking OK, the video quality can be audition by clicking Preview.

Interleaving
Interleaving refers to the process of “weaving” together the audio and video streams. This improves playback performance when using storage devices that are most efficient at providing data sequentially, such as CD-ROM drives.

The Frames setting on the Compression Options dialog determines the interval between the video and audio segments. The default value is 1 for CD-ROM drives, but it can be increased when working using high-performance media.

Compressing the audio
1. On the Compression Options dialog, choose the audio stream to be compressed from the Choose a stream drop-down list and click Options. The Sound Selection dialog is displayed. From this dialog, you can specify custom audio formats and attributes.

2. Choose the target audio quality from the Name drop-down list. The format and attributes are automatically selected to produce the desired audio quality.
3. Click OK. The Compression Options dialog is displayed.
4. If desired, select the Interleave every _ Frames check box and enter a value in the box. For more information, see Interleaving on page 320.

5. Click OK. Sound Forge saves the file.

    **Note:** If the video is long and/or the selected compression scheme is slow, saving the file may take an extended period of time.

---

Using the Playlist with AVI files

Like audio files, you can divide an AVI file into regions and arrange them in the Playlist. Playing AVI regions from the Playlist maintains synchronization between the audio and video and using this method, the Playlist can perform basic video edits.

Editing with the Playlist

Editing AVI files using the Playlist involves four steps:

- Setting up the workspace.
- Creating regions.
- Assembling the Playlist.
- Creating a new AVI file from the Playlist.

Setting up the workspace

1. Open an AVI file and specify the appropriate audio and video streams.

2. From the **View** menu, choose the following commands:
   - Regions List
   - Playlist/Cutlist
   - Video Preview

3. Arrange the windows on the workspace so they are easily viewed and accessed.

Creating Regions

Regions allow you to create the individual shots used to assemble a final edited AVI. Just as when working with audio, AVI regions are created in the Regions List. For more information, see *The Regions List* on page 127.
Assembling the Playlist

Regions from the Regions List can now be assembled in the Playlist. Once placed in the Playlist, regions can be rearranged and previewed ad infinitum. For more information, see The Playlist on page 139.

Creating a new AVI file from the Playlist

Once the regions are arranged in the Playlist, a new AVI file can be created based on the new arrangement.

1. From the Special menu, choose Playlist/Cutlist, and choose Convert to New from the submenu. The Save As dialog is displayed.
2. Enter a name for the AVI in the File name box.
3. Click Save and follow the instructions in the dialogs. For more information, see Saving an AVI file on page 317.

When creating a new AVI file . . .

When a new AVI file is created from the Playlist, each region's start and end points must align to a frame boundary. If the regions do not align, they are automatically aligned by Sound Forge in the following manner:

• Region start points are moved backward.
• Region end points are moved forward.
• Silence is used to fill the new area.

Note: This auto-alignment may result in an AVI file that is longer than the playback time displayed in the Playlist.

To ensure that the Convert to New function creates an accurate file from the Playlist, verify that all the region endpoints are frame aligned. There are two ways to accomplish this:

• Use the Time & Frames or Absolute Frames status format option when creating regions.
• From the Options menu, choose Auto Snap to Time.
Sound Forge supports two streaming formats for playback over networks such as the Internet: RealMedia (.rm) and Microsoft's Windows Media Format (.asf, .wma, and .wmv). Streaming files can be played while they are downloading. This chapter describes saving files into streaming formats using Sound Forge's built-in encoding templates. In addition, this chapter describes creating custom encoding templates.

Optimizing files

Before creating a streaming media file, the original file should be optimized for encoding using normalization and compression.

Normalizing the file

Normalizing the file maximizes its volume while preventing the audio from distorting. This is accomplished by scanning the entire file and applying a gain to raise its level to a specified value. For more information, see Normalize on page 227.

Compressing the file

Compressing the file increases the overall volume and intelligibility of audio.

1. From the Effects menu, choose Dynamics, and choose Graphic from the submenu. The Graphic Dynamics dialog is displayed.

   Note: The following compression procedure contain control setting values. Realize that these are merely suggestions and that experimentation with the settings will ultimately yield the best results.

2. Select the Auto Gain Compensate check box.

3. Set the Attack slider to 1.0 milliseconds.
4. Set the Threshold slider to -10.00 dB.
5. Set the Release slider to 300.0 milliseconds.
6. Set the Ratio slider to 2.0:1 and click OK.

Creating RealMedia files

Sound Forge allows you to save audio and video files in the RealMedia format and provides the tools to maximize the quality of streaming audio. Whether the file will contain only audio or audio and video determines the procedure used to create the file. The following sections explain how to save files in RealMedia format.

RealMedia requirements

To play RealMedia files, the RealPlayer must be installed. This, in turn, installs all necessary audio and video codecs for playing RealMedia files. RealPlayer can be downloaded from the RealMedia Web page (www.real.com).

Setting the RealMedia Summary fields

The Summary tab of the Custom Settings dialog allows you to select specific media playback options as well as enter information regarding the title, author, and copyright of the file.
1. From the File menu, choose Save As. The Save As dialog is displayed.
2. Enter a name for the file in the File name box.
3. Choose RealMedia from the Save as type drop-down list and click Custom. The Custom Settings dialog is displayed.
4. Click the Summary tab.
5. In the Media clip options pane, select the check box(es) corresponding to the desired playback option(s).
   - Selecting the Enable perfect play check box allows users connected with standard modems to download a higher-quality version of the file, normally associated with ISDN or LAN connections. The file is played from the system's hard drive once the download is complete.
   - Selecting the Allow mobile play check box allows users to play the file on mobile audio playback devices.
   - Selecting the Allow recording check box allows users to save the streaming file.
6. Enter Title, Author, Copyright, and Comments information in the appropriate boxes. The information is now ready to be saved in the RealMedia file.
Saving files as RealMedia

Sound Forge offers a number of RealMedia templates, each optimized for a specific bandwidth.

1. In the Custom Settings dialog, click the Encode Settings tab.
2. Choose an appropriate template from the Template drop-down list. A brief description of the selected template is displayed in the pane below the list.
3. Click OK. The file is saved in the RealMedia format and a dialog is displayed prompting you to audition the newly created file using the RealPlayer installed on your system.
4. If RealPlayer is installed, click Yes to play the file.

Creating custom RealMedia templates

When encoding files to RealMedia, you are not limited to using the provided presets. Sound Forge also allows you to create custom RealMedia templates.

Creating a custom RealMedia template involves the three individual procedures:

- Configuring the encoding type.
- Configuring additional video settings (only required for video templates).
- Configuring any advanced video settings (only required for video templates).

Configuring the encoding type

1. Click the Encode Settings tab of the Custom Settings dialog.
2. In the Target Audience pane, choose the desired media player from the Player compatibility drop-down list.
3. Select the check box(es) appropriate to the connection type(s) you want to support.

Note: If G2 RealPlayer is selected in the Player compatibility drop-down list, only a single connection type can be selected.

4. Choose the appropriate audio format from the Audio format drop-down list.
5. If the template will include a video stream, choose the desired quality from the Video quality drop-down list.
6. If G2 RealPlayer was chosen in the Player compatibility drop-down list, select the desired radio button in the File type pane.

**Note:** If RealMedia 5, RealMedia 4, or RealMedia 3 was specified in the Player compatibility drop-down list, the SureStream radio button is selected by default.

7. If the template will resize a file’s video stream, choose the desired size from the Re-size video frames to drop-down list, or choose Custom and enter appropriate values in the New width and New height boxes.

8. If desired, click the **Advanced** button and configure additional encoding parameters for the selected media.

**Configuring additional video settings**

If the custom template is being created to encode media that contains a video stream, the Video tab offers four additional video encoding options.

1. Click the Video tab of the Custom Settings dialog.
2. Select the check box(es) corresponding to the desired encoding options.
   - Selecting the Enable 2-Pass Encoding check box forces the template to process the source video twice. The first pass gathers information, while the second pass encodes the streams. Two-pass encoding works best when the Enable Variable Bit Rate Encoding check box is also selected.
   - Selecting the Enable Variable Bit Rate Encoding check box varies the encoding bitrate in relation to the difficulty of the data. This option typically results in video quality that is superior to that achieved with constant bitrate (CBR) encoding.
   - Selecting the Enable Loss Protection check box adds error-correction data to media streams that helps them maintain quality in lossy environments.
   - Selecting the Emphasize Video Quality check box allows the template to sacrifice the playback quality of the audio stream to maintain the video playback quality when the bandwidth is high.
Configuring advanced video settings

If the custom template is being created to encode media that contains a video stream, the Advanced Video tab offers additional video encoding options.

1. Click the Advanced Video tab of the Custom Settings dialog.
2. Choose the desired codec from the Video codec drop-down list.
3. In the middle pane, select any of the check boxes corresponding to the advanced video features of the template.
   - Selecting the Inverse-Telecine check box applies a filter designed for transferring 24 fps motion pictures to NTSC video by duplicating frames to achieve the NTSC standard of 30 fps.
   - Selecting the De-interlace check box applies a filter that minimizes the jaggedness of interlaced video; however, this filter is only useful for interlaced source video that is at least 240 lines high.
   - Selecting the High quality resize filter check box applies a resizing filter that performs high-quality resize; however, this option works only when decreasing the size of source video.
   - Selecting the Noise filter check box applies a filter that will minimize the appearance of noise distortion that is typically the result of signals received over an antenna. Selecting this check box requires you to choose between the Low quality and High quality radio buttons.
4. In the lower pane, configure the VBR maximum startup latency value to determine the maximum amount of buffering that will occur prior to the beginning of playback.
5. Configure the Maximum time between keyframes value to determine the maximum time between keyframes in the file, which will determine the keyframe frequency. Configuring these parameters incorrectly will degrade the quality of the encoded video.

Creating Microsoft Windows Media Format files

This section describes creating Windows Media Format (.asf, .wma, and .wmv) files using Sound Forge. Windows Media files are used for streaming information using the Microsoft Windows Media Player. In addition to their streaming properties, these files can be used to deliver multimedia content, open Web pages, and deliver scripting commands to client computers.

Sound Forge supports saving .wav and .avi files, along with their associated markers and script commands, as Windows Media files. Once created, Windows Media files can be played from a local drive, streamed from an HTTP server, or streamed from a Windows Media server.
Windows Media requirements

To play Windows Media files, the Microsoft Windows Media Player must be installed. This, in turn, installs all necessary audio and video codecs for saving Windows Media files. The Windows Media Player is included on the Sound Forge CD-ROM and can also be downloaded from the Microsoft Windows Media Web page (www.microsoft.com/windows/windowsmedia/).

Creating Windows Media files

Sound Forge contains a number of templates for creating Windows Media files.

1. Open a .wav or .avi file.
2. From the File menu, choose Save As. The Save As dialog is displayed.
3. Choose an appropriate Windows Media template from the Template drop-down list or click Custom to create a new template. See “Creating custom Windows Media 7 templates” on page 330.

Note: If you’re saving an .asf file, the Template drop-down list is unavailable. The Save to Windows Media dialog is displayed after you click the Save button. Use this dialog to choose a template, create custom templates (See “Creating custom Windows Media (.asf) templates” on page 331.), and generate a redirector file. For more information, see Generating a redirector file for an .asf file on page 332.
4. Click Save. The Windows Media file is created and you are prompted to audition the file using the Windows Media Player installed on your system.
5. If the Windows Media Player is installed, click Yes.

Adding markers and script commands

Sound Forge can also be used to embed markers in files. These markers, in turn, can be used to navigate files or as script commands.

Navigation markers

Navigation markers allow viewers to quickly access specific sections of an .asf file.
Creating a navigation marker
1. Open a .wav or .avi file.
2. Place the cursor anywhere in the audio waveform and press . A marker is placed in the file.
3. Right-click the marker and choose Edit from the shortcut menu. The Edit Marker/Region dialog is displayed.
4. Enter a name for the marker in the Name box and click OK. The marker is named.

Script commands
Markers are also used to store script commands embedded in Windows Media files. There are numerous script commands and this section describes the creation of the URL flip. When the marker is reached during playback, your Web browser is started and the specified URL is displayed.

Note: Although the following sections describe creating a URL flip, all script commands follow the same basic procedures.

1. Open an .avi file and place the cursor anywhere in the audio waveform.
2. From the Special menu, choose ASF Markers/Commands, and choose Add Command from the submenu. The Add Marker/Region dialog is displayed.
   Notice that the Name box defaults to the appropriate syntax for a URL flip.
3. Following the provided syntax, enter an appropriate URL address and click OK. A script command marker is inserted in the file's data window.
Creating custom Windows Media 7 templates

When encoding files to Windows Media version 7, you are not limited to using the provided presets. Sound Forge also allows you to create custom encoding templates.

Creating a custom template involves the four individual procedures:

- Configuring audio settings.
- Configuring video settings (only required for video templates).
- Configuring bitrate settings (only required for video templates).
- Entering summary information.

Configuring audio settings

1. Click the Audio tab of the Custom Settings dialog.
2. Choose the appropriate audio format from the Format drop-down list.
3. Choose a setting from the Attributes drop-down list to specify the bitrate and sample rate for the audio in your file.

Configuring video settings

If the custom template is being created to encode media that contains a video stream, the Video tab offers additional video encoding options.

1. Click the Video tab of the Custom Settings dialog.
2. Choose a video codec from the Format drop-down list.
3. Enter a number in the Frames/Second box to specify the frame rate of the video stream. The frame rate determines the speed at which individual images are displayed during playback. Higher frame rates result in smoother motion.
4. Enter a number in the Second/ I-Frame box to specify the interval (in seconds) between consecutive I-frames. I-frames contain all the data to draw a complete video frame.
5. Select the Override default compression buffer check box and enter a value if you want to specify how long a media player should buffer before starting playback.
6. Choose a setting from the Image Size drop-down list to specify the size of the encoded video frames, or choose Custom and enter values in the Width and Height boxes.
7. Drag the Quality slider to adjust the quality of your encoded video. Zero is the default setting. Increasing this setting will increase the time it takes to encode your file.

Configuring bitrate settings

The Bitrate tab allows you to specify the target bandwidths for which you want to encode your file. You can enter a bitrate for each target to override the default.
Entering summary information
The Summary tab allows you to enter summary information that can be displayed by the Windows Media Player.

Creating custom Windows Media (.asf) templates
Using Sound Forge, custom Windows Media Format (.asf) templates can be created and saved. Two varieties of custom templates can be created:

- Single bitrate video templates.
- Multiple bitrate video templates.

Creating an .asf template
1. In the Save to Windows Media dialog, click Custom. The Windows Media Services Encoder Template wizard is launched.
2. Enter a name and description for the custom template and click Next.
3. Select the Use single bit rate video or the Use multiple bit rate video radio button and click Next.
4. Select the desired Network Bandwidth(s) and click Next.

   **Note:** A video stream cannot be saved with a bandwidth selection of 14.4 due to the amount of bandwidth required for video.

5. If necessary, select the Resample prior to encode check box and choose a value from the Resample rate drop-down list, then click Next.
6. Choose the appropriate audio compression codec and format from the Codec and Format drop-down lists.
7. If the file contains video, select the Use Video check box and choose an appropriate video compression codec from the Codec drop-down list.
8. Click Finish.

Redirector files
A redirector file is a metafile that provides information to the media player regarding streaming media files. To start a streaming media presentation, a Web page will include a link to a redirector file, which allows the media file to stream. If a redirector file is not present, the media file must be downloaded before it is played.
Generating a redirector file for an .asf file

If you choose Windows Media (.asf) from the Save as type drop-down list, you are able to create a redirector file by selecting the Generate redirector files check box.

1. Select the Generate redirector files check box.

2. Click the ASX Settings button. The ASX Settings dialog is displayed.

3. In the ASF server path box, specify the path where the Windows Media Format file will be stored on the server. This is the directory path where you will transfer your media file with an FTP program.

4. Select the Use alternate destination folder for ASX files check box if your redirector file will be stored in a different folder than your media file.

5. Click Browse to specify a folder.

6. Specify the amount of the file that you want the redirector file to play back. If the Play start position and Play length settings are set to 0 (default), the entire file will be played.

---

**Note:** By specifying a Play start position and a Play length in a redirector file, you may create multiple playback options using a single encoded file. For example, one redirector link on an HTML page might play a ten-second preview of a video, while another link plays the entire file.

---

7. Click OK.
This chapter will introduce you to the concept of frequency and describe Sound Forge’s Spectrum Analysis tools. Please be aware that Spectrum Analysis is only available when using the full version of Sound Forge.

**Working in the frequency domain**

Unlike the waveform display, which represents audio in the time domain (amplitude vs. time), Spectrum Analysis allows you to examine audio recordings in the frequency domain.

Consider the following graphic, which depicts the same audio event as a waveform and as a spectrum graph.

---

**Waveform display**

**Spectrum graph**
Data displayed in the frequency domain (whether in the form of a spectrum graph or sonogram) depicts the amplitudes and frequencies of sine waves that, if mixed, would sound much like the original audio. Since it is relatively easy to remember what a sine wave sounds like at a specific frequency, it is possible to imagine what simple waveforms will sound like by examining their spectrum.

Learning to “read” the frequency components of a sound in conjunction with their corresponding amplitudes makes it possible to determine the fundamental frequency of a sound, as well as its overtones. Similarly, unwanted noise can be identified, thereby allowing filtering to be applied where needed.

Fast Fourier Transform

A Fourier transform is computationally intensive and for this reason it is common to use a technique referred to as a Fast Fourier Transform (FFT) to perform spectral analysis. The FFT utilizes mathematical shortcuts to reduce the processing time at the expense of putting limitations on the analysis size.

The analysis size, also referred to as the FFT size, indicates the number of samples from the audio signal used in analysis and also determines the number of discrete frequency bands. When a large number of frequency bands are used, the bands have a smaller bandwidth and this provides for more accurate frequency readings.

However, since complex sounds have a rapidly changing spectrum, a large analysis size can blur the time-changing frequencies of a sound. For example, when performing FFT analysis of an audio file sampled at 44,100 Hz using an analysis size of 4096, almost 100 milliseconds (44,100/4096) of sound are analyzed. If the sound is not constant for those 100 milliseconds, it is impossible to focus on the instantaneous spectrum at smaller time intervals. This is the trade-off between time resolution and frequency resolution encountered when analyzing audio signals.

Spectrum graph vs. sonogram

Two unique methods are used to display spectral data in Sound Forge’s Spectrum Analysis: the spectrum graph and the sonogram.
Spectrum graph

In the spectrum graph, the horizontal axis represents frequency in Hertz (Hz), while the vertical axis represents amplitude in decibels (dB).

Displaying a spectrum graph

1. Open an audio file.

2. From the **Tools** menu, choose **Spectrum Analysis**. The file is analyzed and the Spectrum Analysis dialog is displayed.

3. From the Spectrum Analysis dialog's **Display** menu, choose **Normal Display**. A check mark is displayed adjacent to the **Normal Display** command (indicating that it is active) and the file's spectrum graph is displayed.

   The spectrum graph displays the amplitude (in dB) of each frequency component from 0 Hz (DC) to the Nyquist frequency.

Monitoring playback

Choosing **Monitor Playback** from the **Options** menu configurations the spectrum graph to update in real time as Sound Forge plays a file. The response of the graph will depend upon the current FFT size and the speed of your computer.

Monitoring an input source

Choosing **Monitor Input** from the **Options** menu configurations the spectrum graph to update in real time to any input at the currently selected sound card. This feature makes it possible to perform real-time analysis of room acoustics and equalize accordingly.
Displaying frequency and amplitude values

From the **Options** menu, choose **Show Position** and place the pointer at any position in the graph to measure the frequency and amplitude values of the audio at that point.

Displaying frequency and pitch

From the **Options** menu, choose **Show Notes** and place the pointer at any position in the graph to display frequency and pitch information.

Stereo files

When viewing a spectrum graph for a stereo file, an individual graph is displayed for each channel, and each channel's parameters can be set independently.

1. Open a stereo file.
2. From the **Tools** menu, choose **Spectrum Analysis**. The Spectrum Analysis dialog, containing two unique graphs, is displayed.
3. Select the upper graph (left channel) by clicking on it. The upper graph's border is highlighted to indicate the left channel is active.
4. Right-click the Spectrum Analysis dialog and choose **Normalize dB** from the shortcut menu. The left channel is normalized, but the right channel remains unchanged.
Sync graphs

If performing an operation on one channel changes the appearance of both graphs, the Sync Graphs option is turned on. To toggle the Sync Graphs option, right-click in the Spectrum Analysis dialog and choose Sync Graphs from the shortcut menu. A check mark is displayed adjacent to the command in the shortcut menu to indicate that the option is turned on.

Toggling Graphs

To toggle between graphs (channels), click on the desired graph or press Tab.

Updating a spectrum graph

1. Position the file’s data window and Spectrum Analysis dialog on the workspace so both are visible.
2. Create a new selection in the data window.
3. Click Update in the Spectrum Analysis menu bar. The new selection is analyzed and an updated spectrum graph is displayed.

Note: If there is no selection, clicking Update performs analysis on the samples immediately following the current cursor position.

Viewing multiple spectrum graphs

Once a selection is created in the data window, up to 64 individual spectrum graphs, each representing a specific point in time, can be displayed.

1. Open an audio file.
2. From the Tools menu, choose Spectrum Analysis. The Spectrum Analysis dialog is displayed.
3. From the Spectrum Analysis dialog’s Options menu, choose Settings. The Spectrum Settings dialog is displayed. For more information, see Spectrum Settings dialog on page 338.
4. Enter a value in the Slices displayed box. The Forward and Backward radio buttons are activated.
5. Select the Forward or Backward radio button.
   - Selecting the Forward radio button displays the first slice of the selection in the foreground of the spectrum graph.
   - Selecting the Backward radio button displays the last slice of the selection in the foreground of the spectrum graph.
6. Click OK.

7. Use the Slice slider to add/remove slice graphs in the Spectrum Analysis dialog.

Spectrum Settings dialog

From the Spectrum Analysis **Options** menu, choose **Settings** to display the Spectrum Settings dialog. The following sections explain the role of each control in audio spectrum analysis.

**FFT size**

Choose a value from the **FFT size** drop-down list to determine the size (in samples) of the analysis window and number of discrete frequencies analyzed. Higher **FFT size** values produce higher frequency resolution at the expense of lower time resolution and slower processing.

**FFT overlap**

The value in the **FFT overlap** box determines the amount of overlap between FFT analysis windows. Lower values decrease the number of distinct analysis functions performed, which also decreases processing time. Higher values provide more analysis, but result in slower processing.
Smoothing window
Choose a setting from the Smoothing window drop-down list to determine the window function that will be applied to the input data prior to analysis. This option influences the sharpness of peaks in an FFT graph and the leakage into neighboring frequencies.

- Choose Rectangle to apply no window. This results in a very sharp peak, but high leakage.
- Choose Triangle (also referred to as a Bartlett or Parzen window) to apply a window that results in less leakage than the rectangle window.
- Hamming, Hanning, and Blackman windows are commonly used in audio applications.

**Note:** Choosing Blackman-Harris results in the least sideband leakage of the six options. The major drawback of Blackman-Harris is rounded graph peaks.

Slices displayed
The Slices displayed value determines the number of FFT slices created for the selection.

Forward/Backward
When displaying multiple slices in the spectrum graph, slices are displayed chronologically forward or backward based on which of these radio buttons is selected.

Set sonogram resolution
The Set sonogram resolution value determines the number of FFT samplings used in a sonogram. This will keep the processing time and graph resolution constant. Increasing this value increases the horizontal graph resolution, but requires more processing time.

When this check box is cleared, the resolution value is determined by the length of the selection and the FFT overlap value.

Logarithmic graphing
Select the Logarithmic graphing check box to display the x-axis in logarithmic mode instead of linear mode. This results in more graph area being devoted to lower frequencies.

**Note:** This option is available in Normal display only.

Frequency minimum
Determines the lowest frequency displayed in a graph when Zoom to Range is selected.
Frequency maximum
Determines the highest frequency displayed in a graph when Zoom to Range is selected.

Ceiling
Determines the highest amplitude level displayed in a graph when Zoom to Range is selected.

Floor
Determines the lowest amplitude level displayed in a graph when Zoom to Range is selected.

Hold peaks during monitoring
Selecting this option results in the highest value of each frequency bin being indicated on the spectrum graph with a small horizontal line. The length of time (in seconds) that the peak is held is determined by the value entered in the edit box.

Maintain last monitored view
Selecting this check box “freezes” the appearance of the spectrum graph when playback is stopped. Clearing this check box results in the graph resetting to the cursor position when playback is stopped.

Saving spectrum settings
After this set of controls is configured, you are able to save the settings by clicking Save As.

Navigating a spectrum graph
A spectrum graph contains tools that allow you to isolate particular frequency and/or amplitude ranges.

Displaying a frequency range
1. Open an audio file.
2. From the Tools menu, choose Spectrum Analysis. The spectrum graph is displayed.
3. Click the mouse in the area of the frequency range to be examined. The cursor is displayed as \( \text{Select a frequency range} \).
4. Toggle-click the mouse until the selection range is displayed as two parallel vertical lines.

5. Create a selection containing the desired frequency range and release the button. The spectrum graph magnifies the selected area and the frequency axis is updated to display the selected frequencies.

6. Use the Range slider to scroll the selected range through the frequency spectrum.

7. Right-click the Spectrum Analysis dialog and choose Zoom Out Full from the shortcut menu. The entire spectrum graph is displayed.

**Displaying an amplitude range**

1. Open an audio file.

2. From the Tools menu, choose Spectrum Analysis. The spectrum graph is displayed.

3. Click the mouse in the area of the amplitude range to be selected. The cursor is displayed as \[\text{\textbullet}\].

4. Toggle-click the mouse until the selection range is displayed as parallel horizontal lines.

5. Create a selection containing the desired amplitude range and release the button. The spectrum graph displays only the selected amplitude range.

**Displaying an amplitude and frequency range**

1. Open an audio file.

2. From the Tools menu, choose Spectrum Analysis. The spectrum graph is displayed.

3. Click the mouse in the area of the amplitude and frequency range to be selected. The cursor is displayed as \[\text{\textbullet}\].

4. Toggle-click the mouse until the selection range is displayed as a dotted box.

5. Create a selection containing the desired amplitude and frequency range and release the button. The spectrum graph displays the selected amplitude and frequency range.
Displaying ranges using the Spectrum Settings dialog

Specific amplitude and/or frequency ranges can also be displayed using the Spectrum Settings dialog by doing the following:

1. Open an audio file.
2. Choose Spectrum Analysis from the Tools menu. The spectrum graph is displayed.
3. From the spectrum graph's Options menu, choose Settings. The Spectrum Settings dialog is displayed.
4. Choose a preset from the Name drop-down list or enter the desired Display Range parameters and click OK. The spectrum graph displays the specified range.

For more information, see Spectrum Settings dialog on page 338.

Grab/Pan mode

After a spectrum graph is displayed, Grab/Pan mode allows you to scroll vertically and horizontally.

Turning on Grab/Pan
To turn on Grab/Pan mode, right-click the Spectrum Analysis dialog and choose Grab/Pan from the shortcut menu.

The cross-hair cursor is now displayed as a multi-directional cursor that allows the selected region to be dragged throughout the graph.

Turning off Grab/Pan
To turn off Grab/Pan mode, choose Grab/Pan from the shortcut menu again or press Esc.
Overview window

Located in the lower-left corner of the Spectrum Analysis dialog, the Overview window indicates what section of the file is being viewed in relation to the entire spectrum graph. The dotted rectangle represents the region currently displayed in the Spectrum Analysis graph.

Sonogram

The sonogram is another way of displaying spectral data variations over time. In a sonogram, the horizontal axis represents time, and the vertical axis represents frequency.

The amplitude of each frequency component in the sonogram is represented by the color intensity of each point in the graph. This method of displaying spectral information is useful for identifying distinctive spectral patterns created from sounds such as speech, musical instruments, and ambient noise.
Displaying a sonogram

1. Open an audio file and select approximately one second of audio.

2. From the **Tools** menu, choose **Spectrum Analysis**. The Spectrum Analysis dialog is displayed.

3. From the Spectrum Analysis dialog’s **Options** menu, choose **Settings**. The Spectrum Settings dialog is displayed.

4. Choose **Sonogram 1** from the **Name** drop-down list and click **OK**.

5. From the **Display** menu, choose **Sonogram (Color)**. A colored sonogram of the selected audio is displayed.
   
   If no selection is created in the waveform display window, the sonogram analyzes the sound data from the current cursor position to the end of the file.

Displaying frequency and amplitude values

As with the spectrum graph, you can measure the frequency and amplitude values of the audio at any point in the sonogram by placing the mouse pointer at any position on the graph.

Updating a sonogram

A sonogram is updated in the same method as a spectrum graph. *For more information, see Updating a spectrum graph on page 337.*

Tuning a sonogram

It is frequently necessary to experiment with the control parameters in the Spectrum Settings dialog to produce the best possible sonogram.

*For more information, see Spectrum Settings dialog on page 338.*

**Improving the graph’s contrast**

To improve the contrast of the sonogram, decrease the frequency and amplitude ranges as much as possible.

**Smoothing the graph’s display**

If the graph appears too pixelated, raise the **Set sonogram resolution** value to 200 samplings.

**Improving the frequency resolution**

For greater frequency resolution, choose a higher value from the **FFT size** drop-down list.
Reducing the processing time

To reduce processing time, decrease the Set sonogram resolution value and/or choose a lower value from the FFT size drop-down list.

Adjusting color intensity

The sonogram’s color intensity can be adjusted using the Color slider located directly beneath the sonogram. Notice that the bottom pane of the dialog depicts the color scale in dB.

Note: This function may be fairly slow if the system lacks a palletized driver and Video for Windows is not installed.

Returning to a spectrum graph

To return to the spectrum graph, right-click the sonogram and choose Normal Display from the shortcut menu.
## Shortcuts

### General Keyboard Shortcuts

#### File Commands

<table>
<thead>
<tr>
<th>Press</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alt + Enter</td>
<td>Displays the Properties dialog for the active data window.</td>
</tr>
<tr>
<td>Ctrl + N</td>
<td>Creates a new data window.</td>
</tr>
<tr>
<td>Ctrl + O</td>
<td>Opens a sound file into a new data window.</td>
</tr>
<tr>
<td>Ctrl + S</td>
<td>Saves modified sound data back to the file.</td>
</tr>
<tr>
<td>Ctrl + W</td>
<td>Closes the active data window.</td>
</tr>
<tr>
<td>Alt + F4</td>
<td>Exits Sound Forge.</td>
</tr>
</tbody>
</table>

#### Edit Commands

<table>
<thead>
<tr>
<th>Press</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl + A</td>
<td>Selects all data in the active window.</td>
</tr>
<tr>
<td>Ctrl + C</td>
<td>Copies the selected data onto the clipboard.</td>
</tr>
<tr>
<td>Ctrl + E</td>
<td>Pastes the clipboard contents into a new data window.</td>
</tr>
<tr>
<td>Ctrl + F</td>
<td>Crossfades data from the clipboard with the active window.</td>
</tr>
<tr>
<td>Ctrl + K</td>
<td>Previews Cut or Clear in the active window.</td>
</tr>
<tr>
<td>Ctrl + Shift + R</td>
<td>Plays to cursor with pre-roll.</td>
</tr>
<tr>
<td>Ctrl + I</td>
<td>Mixes data from the clipboard with the active window.</td>
</tr>
<tr>
<td>Ctrl + U</td>
<td>Trims (crop) to the current selection.</td>
</tr>
<tr>
<td>Ctrl + T</td>
<td>Toggles Undo buffer creation for the active window.</td>
</tr>
<tr>
<td>Ctrl + V</td>
<td>Pastes data from the clipboard into the active window.</td>
</tr>
<tr>
<td>Ctrl + X</td>
<td>Moves (cut) the selected data onto the clipboard.</td>
</tr>
<tr>
<td>Ctrl + Y</td>
<td>Repeats last process, effect, or tool.</td>
</tr>
<tr>
<td>Ctrl + Z</td>
<td>Undoes the last action.</td>
</tr>
<tr>
<td>Ctrl + Shift + Z</td>
<td>Redo the last undone action.</td>
</tr>
<tr>
<td>delete</td>
<td>Clears (delete) the selected data; nothing is placed on the clipboard.</td>
</tr>
</tbody>
</table>
### Data Window Management Commands

<table>
<thead>
<tr>
<th>Press</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alt + 0</td>
<td>Set focus to the data window.</td>
</tr>
<tr>
<td>Alt + 1</td>
<td>Set focus to Play Meter window.</td>
</tr>
<tr>
<td>Alt + 2</td>
<td>Set input focus to the Regions List.</td>
</tr>
<tr>
<td>Alt + 3</td>
<td>Set input focus to the Playlist/Cutlist.</td>
</tr>
<tr>
<td>Alt + 4</td>
<td>Set focus to the Time Display window.</td>
</tr>
<tr>
<td>Alt + 5</td>
<td>Set focus to the Video Preview window.</td>
</tr>
<tr>
<td>Alt + 6</td>
<td>Set focus to the Play Meters window.</td>
</tr>
<tr>
<td>Alt + 7</td>
<td>Set input focus to the Undo/Redo History window.</td>
</tr>
<tr>
<td>Alt + F5</td>
<td>Restore the Sound Forge application window.</td>
</tr>
<tr>
<td>Alt + F10</td>
<td>Maximize the Sound Forge application window.</td>
</tr>
<tr>
<td>Ctrl + F5</td>
<td>Restore the active data window.</td>
</tr>
<tr>
<td>Ctrl + F6</td>
<td>Go to the next data window.</td>
</tr>
<tr>
<td>Ctrl + F11</td>
<td>Maximize the active data window.</td>
</tr>
<tr>
<td>Ctrl + Shift + F6</td>
<td>Go to the previous data window.</td>
</tr>
<tr>
<td>Shift + F2</td>
<td>Tile the data windows vertically.</td>
</tr>
<tr>
<td>Shift + F3</td>
<td>Cascade the data windows.</td>
</tr>
</tbody>
</table>

### Misc. View, Option, and Special Commands

<table>
<thead>
<tr>
<th>Press</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>S</td>
<td>Toggle current selection on and off.</td>
</tr>
<tr>
<td>Ctrl + B</td>
<td>Toggle Auto Snap to Zero on and off for the active data window.</td>
</tr>
<tr>
<td>Ctrl + Enter</td>
<td>Maximize the width of the active data window.</td>
</tr>
<tr>
<td>Ctrl + D</td>
<td>Show the Set Selection dialog.</td>
</tr>
<tr>
<td>Ctrl + G</td>
<td>Show the Go To dialog.</td>
</tr>
<tr>
<td>Ctrl + L</td>
<td>Show the Loop Tuner for the active data window.</td>
</tr>
<tr>
<td>Ctrl + R</td>
<td>Record new data into a data window.</td>
</tr>
<tr>
<td>Esc</td>
<td>Stop or cancel the current action (including playback).</td>
</tr>
<tr>
<td>F1</td>
<td>Open the Sound Forge Help file.</td>
</tr>
<tr>
<td>F11</td>
<td>Make the menu bar active.</td>
</tr>
<tr>
<td>Shift + F10</td>
<td>Display a shortcut menu.</td>
</tr>
<tr>
<td>F5</td>
<td>Toggle playback scrolling on and off.</td>
</tr>
<tr>
<td>Shift + F8</td>
<td>Toggle smooth playback scrolling on and off.</td>
</tr>
<tr>
<td>F7</td>
<td>Toggle Drag and Drop Snapping on and off.</td>
</tr>
<tr>
<td>Ctrl + F7</td>
<td>Turn on MIDI Input Sync/Trigger.</td>
</tr>
<tr>
<td>F7</td>
<td>Turn on MIDI Output Sync.</td>
</tr>
</tbody>
</table>
Waveform Display Keyboard Shortcuts

Cursor Movement

<table>
<thead>
<tr>
<th>Press</th>
<th>Cursor Moves To</th>
</tr>
</thead>
<tbody>
<tr>
<td>▶️</td>
<td>The next screen pixel.</td>
</tr>
<tr>
<td>▼️</td>
<td>The previous screen pixel.</td>
</tr>
<tr>
<td>End</td>
<td>The last sample visible in the waveform display.</td>
</tr>
<tr>
<td>Home</td>
<td>The first sample visible in the waveform display.</td>
</tr>
<tr>
<td>Ctrl + End</td>
<td>The last sample in the data window.</td>
</tr>
<tr>
<td>Ctrl + Home</td>
<td>The first sample in the data window.</td>
</tr>
<tr>
<td>Page Up</td>
<td>10% of the current view prior to the cursor position.</td>
</tr>
<tr>
<td>Page Down</td>
<td>10% of the current view past the cursor position.</td>
</tr>
<tr>
<td>Ctrl + Page Up</td>
<td>100% of the current view prior to the cursor position.</td>
</tr>
<tr>
<td>Ctrl + Page Down</td>
<td>100% of the current view past the cursor position.</td>
</tr>
<tr>
<td>Ctrl + ▶️</td>
<td>10 pixels past the cursor position.</td>
</tr>
<tr>
<td>Ctrl + ▼️</td>
<td>10 pixels prior to the cursor position.</td>
</tr>
<tr>
<td>▼️</td>
<td>The next sample.</td>
</tr>
<tr>
<td>▲️</td>
<td>The previous sample.</td>
</tr>
<tr>
<td>Ctrl + ▼️</td>
<td>10 samples past the current cursor.</td>
</tr>
<tr>
<td>Ctrl + ▲️</td>
<td>10 samples prior to the current cursor.</td>
</tr>
</tbody>
</table>

When Regions, Loops or Markers Exist in the File

<table>
<thead>
<tr>
<th>Press</th>
<th>Cursor Moves To</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl + ▼️</td>
<td>The previous region, loop or marker boundary.</td>
</tr>
<tr>
<td>Ctrl + ▶️</td>
<td>The next region, loop or marker boundary.</td>
</tr>
</tbody>
</table>
## Selecting Data

<table>
<thead>
<tr>
<th>Press</th>
<th>To Select From Cursor To</th>
</tr>
</thead>
<tbody>
<tr>
<td>Shift + →</td>
<td>The next screen pixel.</td>
</tr>
<tr>
<td>Shift + ←</td>
<td>The previous screen pixel.</td>
</tr>
<tr>
<td>Shift + End</td>
<td>The last sample visible in the waveform display.</td>
</tr>
<tr>
<td>Shift + Home</td>
<td>The first sample visible in the waveform display.</td>
</tr>
<tr>
<td>Ctrl + Shift + End</td>
<td>The last sample in the data window.</td>
</tr>
<tr>
<td>Ctrl + Shift + Home</td>
<td>The first sample in the data window.</td>
</tr>
<tr>
<td>Shift + Page Up</td>
<td>10% of the current view prior to the cursor position.</td>
</tr>
<tr>
<td>Shift + Page Down</td>
<td>10% of the current view past the cursor position.</td>
</tr>
<tr>
<td>Ctrl + Shift + Page Up</td>
<td>100% of the current view prior to the cursor position.</td>
</tr>
<tr>
<td>Ctrl + Shift + Page Down</td>
<td>100% of the current view past the cursor position.</td>
</tr>
<tr>
<td>Ctrl + Shift +</td>
<td>10 pixels past the cursor position.</td>
</tr>
<tr>
<td>Ctrl + Shift +</td>
<td>10 pixels prior to the cursor position.</td>
</tr>
<tr>
<td>Shift + →</td>
<td>The next sample. This shortcut is not available in Windows98 and Me when [Num Lock] is on.</td>
</tr>
<tr>
<td>Shift + ←</td>
<td>The previous sample. This shortcut is not available in Windows98 and Me when [Num Lock] is on.</td>
</tr>
<tr>
<td>Ctrl + Shift + +</td>
<td>10 samples past the current cursor. This shortcut is not available in Windows98 and Me when [Num Lock] is on.</td>
</tr>
<tr>
<td>Ctrl + Shift + -</td>
<td>10 samples prior to the current cursor. This shortcut is not available in Windows98 and Me when [Num Lock] is on.</td>
</tr>
</tbody>
</table>

### When Regions, Loops or Markers Exist in the File:

<table>
<thead>
<tr>
<th>Press</th>
<th>To Select From Cursor To</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl + Shift +</td>
<td>The previous region, loop or marker boundary.</td>
</tr>
<tr>
<td>Ctrl + Shift +</td>
<td>The next region, loop or marker boundary.</td>
</tr>
</tbody>
</table>
Navigation and Playback

<table>
<thead>
<tr>
<th>Press</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Ctrl</strong> + &lt;Number&gt;</td>
<td>Save a view in cell &lt;Number&gt; where &lt;Number&gt; ranges from 1 to 8.</td>
</tr>
<tr>
<td>&lt;Number&gt;</td>
<td>Restore a view using cell &lt;Number&gt; where &lt;Number&gt; ranges from 1 to 8.</td>
</tr>
<tr>
<td>↑</td>
<td>Increase time magnification (zoom in closer to data).</td>
</tr>
<tr>
<td>↓</td>
<td>Decrease time magnification (zoom out farther from data).</td>
</tr>
<tr>
<td><strong>Shift</strong> + ↑</td>
<td>Increase level magnification.</td>
</tr>
<tr>
<td><strong>Shift</strong> + ↓</td>
<td>Decrease level magnification.</td>
</tr>
<tr>
<td><strong>Ctrl</strong> + ↑</td>
<td>Zoom Selection if a selection exists, Zoom In Full if no selection.</td>
</tr>
<tr>
<td><strong>Ctrl</strong> + ↓</td>
<td>Zoom Normal (zooms to default zoom ratio set in Preferences).</td>
</tr>
<tr>
<td><strong>Alt</strong> + <strong>Shift</strong> + ↑</td>
<td>Pan data window up if zoomed in vertically.</td>
</tr>
<tr>
<td><strong>Alt</strong> + <strong>Shift</strong> + ↓</td>
<td>Pan data window down if zoomed in vertically.</td>
</tr>
<tr>
<td>5 (on number pad)</td>
<td>Switch cursor to opposite end of selection.</td>
</tr>
<tr>
<td><strong>Tab</strong></td>
<td>Cycle stereo selection from left channel to right channel to both</td>
</tr>
<tr>
<td><strong>Shift</strong> + <strong>Tab</strong></td>
<td>channels.</td>
</tr>
<tr>
<td>[ or ]</td>
<td>Cycle stereo selection from both channels to right channel to left</td>
</tr>
<tr>
<td>[ or ]</td>
<td>channel.</td>
</tr>
<tr>
<td>[ or ]</td>
<td>Center the cursor in the waveform display.</td>
</tr>
<tr>
<td>Space</td>
<td>Play or stop the current data window in default mode.</td>
</tr>
<tr>
<td><strong>Shift</strong> + Space</td>
<td>Play all or pause the current data window.</td>
</tr>
<tr>
<td><strong>Ctrl</strong> + Space</td>
<td>Switch play mode between Normal, Looped and As Sample.</td>
</tr>
<tr>
<td>Enter</td>
<td>Pause playback; keep the cursor at the current position.</td>
</tr>
<tr>
<td><strong>Esc</strong></td>
<td>Stop playback of the current data window.</td>
</tr>
<tr>
<td><strong>Ctrl</strong> + F</td>
<td>Preview Cut (skip selection on playback with pre-roll).</td>
</tr>
<tr>
<td><strong>Ctrl</strong> + <strong>Shift</strong> + [</td>
<td>Play to cursor with pre-roll.</td>
</tr>
</tbody>
</table>
Regions List and Playlist Keyboard Shortcuts

Regions List Shortcuts

<table>
<thead>
<tr>
<th>Press</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>Space</td>
<td>Play or Stop the active marker or region.</td>
</tr>
<tr>
<td>Enter</td>
<td>Edit the active marker or region.</td>
</tr>
<tr>
<td>Delete</td>
<td>Delete the active marker or region.</td>
</tr>
<tr>
<td>`</td>
<td>Cycle through the Regions List display formats.</td>
</tr>
<tr>
<td>R</td>
<td>Create region from the current selection.</td>
</tr>
<tr>
<td>Shift+R</td>
<td>Create region without bringing up dialog.</td>
</tr>
<tr>
<td>L</td>
<td>Create loop from the current selection.</td>
</tr>
<tr>
<td>Shift+L</td>
<td>Create loop without bringing up dialog.</td>
</tr>
</tbody>
</table>

Playlist Shortcuts

<table>
<thead>
<tr>
<th>Press</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>Space</td>
<td>Play (stop) from the active Playlist entry.</td>
</tr>
<tr>
<td>Enter</td>
<td>Edit the active Playlist entry.</td>
</tr>
<tr>
<td>Delete</td>
<td>Delete the active Playlist entry.</td>
</tr>
<tr>
<td>+</td>
<td>Add one to the active Playlist entry play count.</td>
</tr>
<tr>
<td>-</td>
<td>Subtract one from the active Playlist entry play count.</td>
</tr>
<tr>
<td>#</td>
<td>Add or remove a Stop Point on the active Playlist entry.</td>
</tr>
<tr>
<td>/</td>
<td>Toggle pre-roll on and off for the Playlist.</td>
</tr>
<tr>
<td>&lt;</td>
<td>Cycle through the Playlist display formats.</td>
</tr>
</tbody>
</table>

ACID Loop Creation Tools Shortcuts

<table>
<thead>
<tr>
<th>Press</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>&lt;</td>
<td>Shift current selection to the left by the length of the selection.</td>
</tr>
<tr>
<td>&gt;</td>
<td>Shift current selection to the right by the length of the selection.</td>
</tr>
<tr>
<td>`</td>
<td>Cut the current selection length in half.</td>
</tr>
<tr>
<td>'</td>
<td>Double the current selection length.</td>
</tr>
<tr>
<td>:</td>
<td>Rotate audio.</td>
</tr>
</tbody>
</table>
Mousewheel Shortcuts.

<table>
<thead>
<tr>
<th>Shortcuts</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Wheel Up</td>
<td>Zoom in horizontally.</td>
</tr>
<tr>
<td>Wheel Down</td>
<td>Zoom out horizontally.</td>
</tr>
<tr>
<td>+Wheel Down</td>
<td>Zoom in vertically.</td>
</tr>
<tr>
<td>-Wheel Down</td>
<td>Zoom out vertically.</td>
</tr>
<tr>
<td>Ctrl+Wheel Up</td>
<td>Scroll left (in 10ths of screen width).</td>
</tr>
<tr>
<td>Ctrl+Wheel Down</td>
<td>Scroll right (in 10ths of screen width).</td>
</tr>
<tr>
<td>Shift+Wheel Up</td>
<td>Cursor left or current selection point left</td>
</tr>
<tr>
<td>Shift+Wheel Down</td>
<td>(if there is a selection).</td>
</tr>
<tr>
<td>Ctrl+Shift+Wheel Up</td>
<td>Cursor right or current selection point right</td>
</tr>
<tr>
<td>Ctrl+Shift+Wheel Down</td>
<td>(if there is a selection).</td>
</tr>
</tbody>
</table>

Additional Mouse Shortcuts

Select All
Double-click the waveform display to select the entire sound file. Triple-click when regions, loops, or markers are present.

Note: The triple-click feature must be enabled on the General tab of the Preferences dialog.

Zoom Time and Level
Double-click the level ruler to zoom the current selection vertically and horizontally. If no selection exists, all waveform data is zoomed. Double-click again to Zoom Out Full vertically and Zoom Normal horizontally.

Magnify Mode
To zoom in to a section, select an area while holding Ctrl. Sound Forge is placed into Magnify mode and zooms selection to fill the window.

Return Control Value to Default
Double-click on a slider, fader, or spinner to return the control to its default value.

Fine-Tune Control Value
To fine-tune a slider, fader, or spinner, hold the right and left mouse buttons (or hold Ctrl) while dragging.
Preview
Hold Shift and click the Preview button to hear the original audio. This is equivalent to selecting the Bypass check box.

Hold Ctrl and click the Preview button to display the Preview Configuration dialog.

Main Status Bar
Double-click the Sample Rate, Bit-Depth, or Channels (Stereo/Mono) field to display the Properties dialog.

Selection Status Bar
Double-click the left-most status selection field to display the Go To dialog. Double-click the remaining two fields to display the Set Selection dialog.

Go To Marker
Double-click a marker tag in the ruler to move the cursor to the position of the marker.

Set Selection to Region/Loop
Double-click a region or loop tag in the ruler to change the current selection to the region or loop end points.

Edit Region or Marker
Double-click a region or marker in the Regions List to display the Edit Region/Marker dialog.

Edit Playlist
Double-click a Playlist entry to display the Edit Playlist dialog.

Play Normal Button
Hold  and click to preview a Cut operation. Hold  and click to play to the cursor with pre-roll.

Slow and Fast Selection Scroll Toggle
To create a selecting extending past the start or end of the waveform display, hold the left mouse button while clicking the right mouse button to toggle between fast and slow scrolling.
The Microsoft Audio Compression Manager (ACM) is a standard interface for audio compression in Windows. This interface allows applications such as Sound Forge to use compression algorithms provided by other companies.

Sound Forge fully supports audio compression through the ACM. This enables you to use any ACM-compatible compression. Sound Forge transparently opens compressed .wav files and provides all available compression formats for .wav files in the Save As dialog.

There are two major components to the ACM:

- Audio data compression and decompression
- Transparent playback and recording of non-hardware supported audio files

Audio Data Compression and Decompression

The first component of the ACM allows audio data to be compressed and decompressed. Audio compression is used to decrease the amount of data required to represent a sound and results in smaller sound files. However, there are drawbacks to using audio compression on sound files:

- Most audio compression algorithms will degrade sound quality. This is referred to as lossy compression since information contained in the sound is lost when it is compressed. The amount of sound degradation is dependent upon the algorithm.
- Compressed audio requires more processing time than uncompressed data. The amount of processing time is dependent on the algorithm, as well as the system's hardware. Typically, opening and saving compressed files will take longer than uncompressed files.
- Compressed files are not as portable as uncompressed files. To distribute .wav files in a compressed format, you must verify that the audience can use them. Also, not all audio software can use compressed .wav files, which may make using other applications with Sound Forge difficult.
In Sound Forge, any compressed .wav file can be opened if a compatible ACM driver is installed and enabled. If no compatible ACM driver is available for a compressed .wav file, Sound Forge alerts you of the problem.

Saving compressed .wav files is as simple as specifying the compression algorithm in the Format drop-down list of the Save As dialog. Once a compressed file is saved, Sound Forge will automatically save updates to the file using the selected compression algorithm. The compression format can be changed later—or reverted to an uncompressed format—using the Save As dialog.

**Transparent Playback and Recording of Non-hardware Supported Audio Files**

The second component of the ACM is called the Sound Mapper, and it allows playback and recording of audio data formats that are not directly supported by the sound card. The Sound Mapper may be selected as the Playback and Record device Wave tab of the Preferences dialog. Additional configuration of the Sound Mapper is performed from the Windows Control Panel.

The Sound Mapper functions as follows. When faced with a sound file recorded at an unusual sample rate such as 22,257 Hz and a sound card that supports 22,050 Hz, the sound file normally cannot be played. The sample rate of the file must be changed to 22,050 Hz before it can be played back, but changing the sample rate without resampling causes a pitch shift. However, the Sound Mapper will play this file without resampling by mapping the sound to the best format possible and performing the resampling in real time.

In addition, the Sound Mapper will play compressed sound files, even on sound cards that do not support compression directly. A file compressed with Microsoft ADPCM or The DSP Group’s TrueSpeech will play on any sound card without first decompressing the file.

The Sound Mapper can, under the right circumstances, record compressed sound files. Compressing sound data can be computationally expensive, and the amount of time required is dependent upon the specific compression algorithm and how it is implemented. Decompressing sound data is typically faster than compressing the same sound data.

It should be noted, however, that Sound Forge does not play and record compressed sound files directly. Rather, all compression and decompression is performed while opening and saving the files. This limitation is fairly insignificant, and Sound Forge saves compressed sound files using the best possible quality—something that cannot always be done in real time. Compressed sound files saved with Sound Forge will typically sound better than those recorded with audio compression.
Notes on Sound Forge's sound file compression support:

- The Open dialog allows you to preview compressed .wav files if an appropriate ACM driver is installed. However, the Sound Mapper must be specified as the Playback device.
- After saving uncompressed audio data to a compressed format from the Save As dialog, the file should be auditioned. Sound Forge performs compression and decompression during opening and saving; therefore, the compressed file is not accurately represented until it has been saved and reopened.
The Society of Motion Picture and Television Engineers (SMPTE) timecode may be one of the most misunderstood concepts among individuals within the music industry. The problem with SMPTE timecode formats is that they may mean different things to people in the audio and video fields. What follows is a brief description of each SMPTE timecode format:

**SMPTE 24 Film Sync**

This SMPTE code runs at 24 fps (frames per second) and is also known as SMPTE Film Sync. This rate matches a nominal film rate of 24 fps, which corresponds to the slowest speed possible for apparent continuous motion.

**SMPTE 25 EBU**

This SMPTE code runs at 25 fps and is also known as SMPTE EBU (European Broadcasting Union) because European television systems run at 25 fps.

**SMPTE 30**

In the United States, the 60 Hz power system makes it convenient to generate the 30-fps timecode rate common to audio environments. This rate is exactly 30 fps and is commonly used when synchronizing audio applications such as multitrack recorders or MIDI sequencers.

**SMPTE Non-Drop**

In video, the frame rate of exactly 30 fps is never used. Instead, the timecode runs at a rate of 29.97 fps. This leads to a discrepancy between real time (as you would see on a clock) and the SMPTE time. SMPTE Drop was created to compensate for this discrepancy.
SMpte Drop

This format runs at 29.97 fps, just like SMPTE Non-Drop. However, to keep the SMPTE clock from drifting from real time, certain frame numbers have been removed from the counting system. The time is adjusted forward by two frames on every minute boundary except 0, 10, 20, 30, 40, and 50. Thus, when SMPTE Drop time increments from 00:00:59.29, the next value will be 00:01:00.02. In SMPTE Non-Drop, the time would indicate 00:01:00.00, but it would be two frames behind real time.

When synchronizing audio to video, it is crucial that the SMPTE timecode format used in the sequencer or digital audio workstation is the same as the SMPTE timecode striped onto the video. This guarantees that the SMPTE times on the video screen and computer monitor synchronize during playback.
The following section provides an overview of the defined RIFF Wave File chunks that Sound Forge stores and recognizes. Although Microsoft recommends that audio data be stored after all other chunks, the only chunks stored by Sound Forge prior to the data are the fmt, fact, and PAD chunks.

The reasoning proposed for storing the data after all other chunks is that if the data is modified, the other chunks do not have to be rewritten to disk. However, since the auxiliary chunks are usually much smaller than the data, the associated time to rewrite them is usually negligible. For example, if a Playlist chunk is modified to add a new region, the complete contents of the data must be rewritten to insert the new Playlist chunk. However, if it is stored at the end of the data, only the Playlist chunk and any subsequent chunks must be rewritten. To illustrate this, three minutes of 44,100 Hz stereo data will require a rewrite of 30 megabytes of data to insert 1 region change. The auxiliary chunks, on the other hand, are typically less than 100k, so only the 100k with changes would need to be moved.

<table>
<thead>
<tr>
<th>Chunk</th>
<th>Use</th>
</tr>
</thead>
<tbody>
<tr>
<td>PAD</td>
<td>Used by Sound Forge to align the DATA chunk on a sector boundary for use with products such as Digidesign's Session 8.</td>
</tr>
<tr>
<td>fact</td>
<td>Used to specify the length of audio data in samples when data is stored in a format other than PCM.</td>
</tr>
<tr>
<td>cue</td>
<td>Used to specify the start of markers and regions.</td>
</tr>
<tr>
<td>plist</td>
<td>Used to specify a Playlist within a single wave file.</td>
</tr>
<tr>
<td>adtl</td>
<td>Used to specify region lengths and to provide text names for regions and markers.</td>
</tr>
<tr>
<td>smpl</td>
<td>Used to specify information for files used with samplers. Includes information on Release and Sustaining loops.</td>
</tr>
</tbody>
</table>
tlst (Trigger List) Chunk

The following tlst (Trigger List) chunk has not been registered with Microsoft, but is used to save trigger information in .wav files created by Sound Forge.

Added: ??
Author: Sonic Foundry
Defined for: .WAV form

The <tlst-ck> trigger list chunk specifies a list of triggers which can be used to trigger playback of a series of cue points or Playlist entries. The <tlst-ck> is defined as follows:

```
|<tlst-ck>|          () tlst(          <dwTriggers:DWORD>     //     count of triggers
               <trigger(s)>...)                      // trigger table
```

```
<trigger>    struct
{            
    FOURCC fccListReference;
    DWORD dwName;
    DWORD dwType;
    DWORD dwTriggerOn;
    DWORD dwFunction;
    DWORD cbExtra;
}            
```
The `<trigger>` chunk:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
</table>
| `fccList` | Reference Specifies the list which this entry references. A trigger can reference either the `<cue-ck>` or the `<plst-ck>`.
| `DwName` | When the trigger references the `<cue-ck>` this field specifies the cue point name. This value must match one of the names listed in the `<cue-ck>` cue-point table. When the trigger references the `<plst-ck>` this field references a Playlist entry by index. This value must be less than the total count of `<plst-ck>` entries.
| `DwType` | Specifies the type of trigger.  
|         | 0 - SMPTE Trigger  
|         | 1 - MIDI Command Trigger.  
|         | 2 - MIDI SysEx Trigger. (System Exclusive message) |
**dwTriggerOn**

Specifies the value that will cause a trigger to be generated. This value will change value depending on the type of trigger.

**For triggers of type SMPTE (0)**

Specifies a SMPTE time offset for the cue. The format of this value is 0xhhmmssff. hh is an unsigned Hours value [0..23], mm is an unsigned Minutes value [0..59], ss is an unsigned Seconds value [0..59], ff is an unsigned Frames value [0..numFrames].

**For triggers of type MIDI Command (1)**

Specifies a MIDI Command. Specified as:

<table>
<thead>
<tr>
<th>Channel</th>
<th>Command</th>
<th>Param1</th>
<th>Param2</th>
</tr>
</thead>
<tbody>
<tr>
<td>Byte 0</td>
<td>Byte 1</td>
<td>Byte 2</td>
<td>Byte 3</td>
</tr>
</tbody>
</table>

Where Byte 0 is the MSB and Byte 3 is the LSB.

For channels a value of FF signals trigger on all channels.
For any other param other than the MIDI command byte FF signals a do not care value.

**For triggers of type MIDI Sysex (2)**

Unused, should be set to 0.

**DwFunction**

Specifies the function of this trigger.

<table>
<thead>
<tr>
<th>Value</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>Play</td>
</tr>
<tr>
<td>1</td>
<td>Stop</td>
</tr>
<tr>
<td>2</td>
<td>Queue</td>
</tr>
</tbody>
</table>

Trigger functions that are unsupported or unknown should be ignored.
Examples:

Play when any MIDI note on is received:

FF 90 FF FF

Play when MIDI note 60 is received on Channel 1:

00 90 3C FF

Play when MIDI note 60 is received on Channel 1, stop when note off received for same note:

00 90 3C FF

00 80 3C FF

Queue when MIDI note 60 is received on Channel 2, Play when note off received for same note:

01 90 3C FF

01 80 3C FF

Markers, Regions, and Playlist Entries as Used by Sound Forge

When creating and reading markers, regions, and playlist entries in .wav files, the RIFF documentation can be confusing. The following section is intended to provide software developers a better idea of how to deal with these chunks.

Markers

Markers are a position within a .wav file that can also have an associated text name. Each marker in Sound Forge is stored as an entry within the <cue> chunk. The entry within the <cue> chunk stores the position, as well as a DWORD name field. The name field is used to reference the text name entry, which can be found within the <adtl> chunk. For example, with a marker at 0 named Start, there is an entry within the <cue> chunk with a sample offset of 0 and a name entry of 0x0001. Within the <adtl> chunk there is an entry of type <labl> (label chunk) with a name of 0x0001 and a text field of Start.
Regions
Regions are similar to markers, but include an associated length in addition to the start position and text name. Regions are stored as an entry within the <cue> chunk, which stores the position as well as a DWORD name field. Again, the name field is used to reference the text name entry found within the <adtl> chunk.

The difference between the marker and the region is that instead of using a <labl> chunk in the <adtl> chunk, a <ltxt> chunk, which allows a length to be stored in addition to the text name, is used. For example, a region at 0 with a length of 1000 samples and a name of Beat 1 has an entry within the <cue> chunk with a sample offset of 0 and a name entry of 0x0001. Within the <adtl> chunk, there is an entry of type <ltxt> with a Name of 0x0001, a text field of Beat 1, and a length of 1000. Within the <ltxt> chunk, there is also a field of type FOURCC specifying the purpose of the entry. For all regions in Sound Forge the FOURCC type is set to rgn.

Playlist Entries
Playlist regions are stored differently. They specify a reference to a <cue> for the start of each playlist region as well as a length and number of loops for each entry. Thus, playlist entries may have lengths differing from those stored within the Regions List. To accommodate this, every playlist entry has a corresponding region of the same length when a wave file is created in Sound Forge. A Playlist containing the previous example is stored with a name field of 0x0001, a length of 1,000 samples, and a loop count of 4.
Object Linking and Embedding

Sound Forge supports Microsoft's Object Linking and Embedding (OLE) technology for improved integration with other applications. This section discusses the implementation details and different uses for the OLE technology as supported by Sound Forge.

Introduction to Object Linking and Embedding (OLE)

Object Linking and Embedding (OLE) is a technology developed by Microsoft to allow independent applications to behave as though they are integrated. By taking advantage of OLE support in Sound Forge, digital audio files used from Sound Forge can be embedded into documents used by other applications. Once a digital audio file is embedded into a document, it can be edited in Sound Forge by activating the embedded object, usually by double-clicking on it.

Using OLE with Sound Forge

Sound Forge is an OLE server, which means that it can create OLE objects to be embedded into applications that are OLE containers.

The OLE objects created by Sound Forge are called Sound Forge Audio objects, and are simply links to a sound file on a hard drive or network server. Therefore, when a Sound Forge Audio object is embedded, only a link to the sound file is inserted. For more information, see Tips and Limitations on page 369.

There are three methods of creating Sound Forge Audio objects:

- Drag a link from the OLE Drag Source control in Sound Forge to an OLE container. For more information, see Drag-and-Drop Operations on page 368.
- From the Edit menu, choose Copy Object Link to place an object link onto the clipboard. This object link can be pasted into an OLE container, usually with the Paste Special command. For more information, see Copy Object Link on page 368.
- Choose the Insert Object command from an OLE container and select Sound Forge Audio object from the list. For more information, see Insert Object on page 369.
Drag-and-Drop Operations

The most convenient method of embedding a Sound Forge Audio object into a document is to drag a link from the OLE Drag Source control in Sound Forge and drop the link on the appropriate document.

Note: The application that an OLE object is dropped on must be OLE 2.0 compatible.

To embed a Sound Forge Audio object into Microsoft WordPad using drag-and-drop operations, do the following:

1. Start WordPad.
2. Start Sound Forge and open a .wav file.
   
   A sound file must be saved before the object can be dragged to an OLE container. If a sound file is not saved, you will be prompted to save it when the OLE Drag Source control is clicked.
3. Position the Sound Forge window so at least a portion of WordPad is visible while Sound Forge is open.
4. Drag OLE Drag Source control, located in the lower right-hand corner of the data window, to the WordPad window. A Sound Forge Audio object is embedded in the document.

Copy Object Link

A second method for creating a Sound Forge Audio object is to use the Copy Object Link command.

To embed a Sound Forge Audio object into WordPad using the Copy Object Link command, do the following:

1. Start Sound Forge and open a .wav file.
2. From the Edit menu, choose Copy Object Link. The Sound Forge Audio object is copied to the clipboard and ready to be pasted into a document.
Insert Object

The final method for creating a Sound Forge Audio object is to use the Insert Object command from the container application.

To embed a Sound Forge Audio object into WordPad using the Insert Object command, do the following:

1. Start WordPad.
2. From the Insert menu, select Object.
3. From the Object Type list, choose Sonic Foundry Sound Forge Audio.
4. Select the Create New radio button and click [OK]. Sound Forge creates a new object, linking WordPad to Sound Forge.
5. Double-click the Sound Forge icon and create the appropriate sound data.
6. Save the file and close Sound Forge. A Sound Forge Audio object is embedded in the document.

Note: Once the Sound Forge Audio object is created and embedded into the document, it can be edited in Sound Forge by double-clicking on the object.

Tips and Limitations

As previously stated, Sound Forge Audio objects are implemented as links to existing sound files on hard drives or network servers. Unfortunately, this results in limitations when using the Sound Forge's OLE support.
Links Can be Broken, but Not Mended

The most important rule to bear in mind when using OLE with Sound Forge is that links can be broken, but not mended. When a Sound Forge Audio object is created, it is only a link to the sound file. Sound Forge uses links because sound files can be very large.

Because Sound Forge uses object links, moving, renaming, or deleting the sound file associated with a Sound Forge Audio object breaks the link. Attempting to edit the object in the document will fail as Sound Forge is not able to locate the corresponding sound file.

To replace a broken link, delete the Sound Forge Audio object from the document and create a new object using the correct sound file.

To move a sound file that is linked to a document, double-click the Sound Forge Audio object and choose Save As from the File menu to save the file in a new location. The object link is automatically updated.

Sound Files do not Travel with your Documents

When a document containing Sound Forge Audio objects is copied to another computer, the sound files linked to the objects are not copied. If a document must be copied to another computer, all sound files associated with it must also be copied. In addition, the sound files must exist in the same folder on the new system as on the previous computer.

Using a Network Server

To ease problems associated with moving or sharing documents between computers, use a network server to store sound files that are embedded in documents.

There are two methods of ensuring a common network server will work with shared documents:

- The first method is to make sure all users and computers use the same drive letter when connecting to the network server.
- The second, preferred method, is to use Universal Naming Convention (UNC) paths when embedding Sound Forge Audio objects into documents. A UNC name appears as follows: \\server\share\<folder and file name>

To use this method, open sound files stored in Sound Forge using UNC path names rather than a drive letter. Instead of using a drive letter when browsing in the File Open dialog, select Network Neighborhood in the Look In box and browse to the appropriate network folder containing your sound files.

Sound Forge is not an OLE Container

Although Sound Forge can create OLE objects to embed in other applications, the inverse is not true, and OLE objects created by applications such as Microsoft Word or Excel cannot be embedded into sound files open in Sound Forge.
Using CSOUND, MTU, IRCAM, BICSF, and EBICSF Files

Although Sound Forge supports a large number of sound file formats directly, it does not support the CSOUND, MTU, IRCAM, BICSF or EBICSF file types. However, by using the Raw File Type capabilities of Sound Forge, sound data from these file types can be extracted.

**IRCAM Files**

The IRCAM or IRCAM-Gross format consists of a 1024 byte header prior to the audio data. This header contains standard information like the number of channels, sampling rate, and data format, but can also contain the name of the sample and comments. This format is used by the MTU system and these files are frequently referred to as MTU files. IRCAM files support two types of data formats: 16-bit linear PCM and floating point data.

**BICSF and EBICSF Files**

BICSF and EBICSF files (Berkeley/IRCAM/CARL Sound File or Extended BICSF) are extensions of the IRCAM format. Instead of using the standard IRCAM header, these files replace the first 28 bytes of the header with a standard NeXT/Sun header. This allows the IRCAM format to store additional information in its 1024 byte header, while also allowing the files to be read by software that supports the NeXT/Sun file format, such as Sound Forge.

**Opening and Saving files**

**BICSF and EBICSF Files**

When reading BICSF and EBICSF files, Sound Forge identifies them as NeXT/Sun files. This is because the header of the BICSF file has been modified to allow it to be read as a NeXT/Sun file. Sound Forge will read these files as long as they are in one of the supported NeXT/Sun data formats.
IRCAM, CSOUND and MTU files

To read these formats, users must import them as Raw data files. This is best accomplished by configuring the parameters in the Raw File Type dialog and saving them as presets. The Raw File import function allows these files to be opened providing they stored in 16-bit linear format. Sound Forge will not open floating point format IRCAM files.

Opening an IRCAM file

To open an IRCAM sound file in Sound Forge, do the following:

1. From the File menu, select Open. The Open dialog is displayed.
2. Specify Raw File from the Files of type drop-down list.
3. Select an IRCAM file to open and click OK. The Raw File Type dialog is displayed.
4. Configure the following parameters:
   - Specify a sample rate from the Sample rate drop-down list
   - In the Sample type area, select the 16-bit PCM radio button
   - In the Format area, select the Signed radio button
   - Select the appropriate Channels radio button
   - Select the appropriate Byte order radio button
   - Set the Header value to 1024 bytes
   - Set the Trailer value to 0 bytes
5. Click Save As. The Save Preset dialog is displayed.
6. Enter a name for the preset in the New preset name edit field and click OK. The preset is saved and the Raw File Type dialog is displayed.
7. Click OK. The file is opened.

Remember that the Byte order of files generated by CSOUND is not constant. CSOUND executables for PC generate files that use Little Endian byte ordering, while CSOUND for other platforms tends to generate files with Big Endian ordering. In addition, MTU files use Big Endian byte ordering. Sonic Foundry recommends initially trying a file in Big Endian.

Note: Users may want to save presets for byte ordering, as well as mono/stereo, when receiving CSOUND files from a number of source computers.
Saving Files with Sound Forge

Users are not able to save previous files in their original format, but rather, must select a file format supported by Sound Forge.

Users wishing to save files for use with software that supports the BICSF/EBICSF format should use the NeXT/Sun format. This format does not save the additional information found in BICSF/EBICSF files, but allows the data to be read as a NeXT/Sun file.
Index

A
ACID
Loops for, 306
ACID Loop Creation Tools toolbar, 57, 306
Acoustic Mirror, 26, 243
  Adjusting impulse length, 249
  Apply envelope and limit decay to, 246
  Envelope tab, 247
  Error messages, 261
  Head-related transfer functions, 259
  Impulse, 246
  Impulse recovery mode, 251
  Package Impulse into Preset, 249
  Quality/speed, 247
  Recover Impulse, 251
  Recover tab, 250
  Response delay, 246
  Response width, 246
  Summary tab, 249
  Test file used, 250
  Troubleshooting, 260
  Using, 244
Acoustic signature, 243
  Adjusting, 245
Active data windows, 80
Adding a track to CD, 170
Adding regions to the Playlist, 139
Additional embedded information, 122
Arranging the Playlist, 142
ASF files, 327
  Custom templates, 331
  Redirector files, 332
Attaching video to an audio file, 316
Attributes, 111
  Editing, 112
Audio
  Compression, 320
  Spectrum analysis, 333
Audio editing
  Basic, 85
  Copy, 86
  Cut, 89
  Delete, 90
  Mixing, 92
  Paste, 88
  Trim/Crop, 91
  Undo/Redo, 94
Audio extraction, 26
Audio files
  Saving all open, 83
  Sonic Foundry Perfect Clarity Audio, 27
Audio glitches
  Finding and repairing, 192
Audio Plug-In Chainer, 198
Adding a plug-in, 199
Arranging plug-ins, 199
Bypassing plug-ins, 199
Deleting a plug-in, 200
Saving a chain, 200
Soloing a plug-in, 200
Audio synthesis, 200
DTMF/MF Tones, 201
FM, 202
Simple, 205
Auto Region tool, 133
Musical time intervals, 134
Rapid sound attacks, 133
Auto Snap to Time, 177
Auto Snap to Zero, 178
Current selection, 178
Auto Trim/Crop, 213
Keep edges outside of the selection, 214
Minimum inter-phrase silence, 215
Minimum length following loop end, 215
Remove data beyond loop points, 214
Remove edges outside of the selection, 214
Remove silence between phrases, 214
Automatic labeling, 167
Automatic retake, 152
AVI files, 313
Attaching video to audio, 316
Compressing audio, 320
Creating from the Playlist, 322
Creating regions in, 321
Data rate, 320
Frame animation, 315
Interleaving, 320
Key frames, 319
Multiple streams, 314
Navigation, 314
Opening, 313
Saving, 317
Specifying streams, 318
Using the Playlist, 321
Video compression, 318
Video preview, 316
Video strip, 315
Background processing, 35
Basic audio editing, 85
BICSF, 371
Bit Depth, 113
Bit-depth
CD writing, 170
Specifying, 25
Bit-Depth Converter, 27, 215
Dither, 216
Noise shaping, 217
Using, 216
Blinking status, 167
Built-in XFX Plug-Ins, 26
Calculating loop tempo, 311
Calibrating DC adjust, 155
CD
Extract data from, 168
CD ripping, 26
INDEX
CD writing, 26, 169
   Add Track, 170
   Bit-depth, 170
   Close Disc, 171
   Sample rate, 170
CD, audio extraction, 26
Changing the region order, 129
Channel Converter, 119, 218
   Convert to specified output channels only, 219
   Invert left channel mix, 219
   Invert right channel mix, 219
   New left channel, 219
   New right channel, 219
   Output channels, 219
   Using, 218
Channel repair, 194
Channels, 117
Closing a CD, 171
Command descriptions, 58
Compressing audio, 320
Compressing video, 318
Compression, 116
Configuring gap detection, 166
Configuring the MIDI Keyboard, 288
Configuring the Regions List display, 129
Configuring the Virtual MIDI Router, 269
Controlling Sound Forge, 37, 58
Controls, 58
   Check boxes, 61
   Drop-down lists, 61
   Edit boxes, 60
   Envelope graphs, 62
   Faders and slider, 59
   Radio buttons, 61
   Spin controls, 60
   Using the mouse, 37
Convert to New, 145
Converting file formats, 119
Copy, 86
Count, 141
Crash recovery, 109
   Delete, 109
   Ignore, 109
   Recover, 109
Create a new window for each take, 153
Create markers for each index change, 169
Create regions for each track, 169
Creating
   An AVI from the Playlist, 322
   ASF templates, 331
   Automatic regions, 132
   AVI regions, 321
   CDs, 169
   Custom RealMedia templates, 325
   Graphic fade, 222
   Impulse files, 252
   Markers, 124
   Markers during playback, 126
   Markers during recording, 126
   New data window, 80
   New file from the Playlist, 145
   Pans, 232
   Presets, 208
   Regions, 130
   Regions from markers, 127
   Release loops, 297
   Sampler configuration, 283
   Selection, 175
   Selections on the fly, 176
   Stop points, 143
   Sustaining loops, 296
   Views, 184
   Windows Media files, 327, 328
Crossfade, 185
   Drag-and-drop, 191
Crossfade Loop tool, 305
CSOUND, 371
Custom graphic fade, 223
Custom templates
  ASE, 331
  RealMedia files, 325
Cut, 89
  Previewing, 90
Cutlist, 145
  Adding files, 147
  Enabling, 146
  Return to Playlist, 147
  Using, 146
Cutlist files
  Saving, 147

D
Data rate, 320
Data window, 40
  Components, 41
  Overview, 180
DC adjust, 154
  Calibrating, 155
  Recalibration, 155
DC Offset, 220
  Adjust DC offset by, 221
  Automatically detect and remove, 220
  Compute DC Offset From First 5 Seconds Only, 221
Delete, 90
Deleting a preset, 209
Deleting a region from the Playlist, 144
Deleting a stop point, 144
Destination radio buttons, 118
Direct mode, 30
  Opening a file, 31
  Peak files, 31
  Recording, 149
DirectX
  Plug-In Chainer, 198
Disabling scan for external monitor, 35
Disabling Undo/Redo, 94

Displaying
  Playlist, 139
  Regions List, 128
  Sonogram, 344
  Video strip, 315
Displaying WaveHammer, 262
Dither, 114, 216
Drag-and-drop a new window, 192
Drag-and-drop crossfading, 191
Drag-and-drop editing, 188
  Mono selections to stereo destinations, 188
  Snapping to events, 188
Drag-and-drop mixing, 190
Drag-and-drop pasting, 189
Drop Marker button, 166
Drop-down lists, 61
Dropping markers during recording, 166
DTMF/MF Tones, 201

E
EBICSF, 371
Edit boxes, 60
Editing
  Drag-and-drop, 188
  Presets, 209
  Regions, 135
  Regions in the Regions List, 136
  Sample rate, 113
  Sample size, 114
  Summary information, 120
Editing loops, 300
Effects toolbar, 53
E-mailing files, 84
Embedded information, 122
Enabling the Cutlist, 146
Envelope graphs, 62
EQ, 221
Error messages
  Impulse files, 261

Extended bit-depth, 25
Extended sample rate, 26
Extended summary information
  Viewing, 120

External MIDI devices, 276
External samplers, 281
Extract data from CD, 168
  Create markers for each index change, 169
  Create regions for each track, 169

Extract Regions, 138

Fade, 222
  Graphic, 222
  In, 224
  Out, 224
Fade In, 224
Fade Out, 224
Faders and sliders, 59
Fast Fourier Transform, 334
Faster file saving, 31
FFT, 334

File attributes, 111
Files
  Attributes, 111
  Channels, 117
  Converting, 119
  Creating from the Playlist, 145
  E-mailing, 84
  Opening, 73
  Playing, 76
  Sample rate, 112
  Saving, 81
Find tool, 193
Finding and repairing audio glitches, 192

Fine-tuning selections
  Keyboard methods, 178
  With the mouse, 177
FM synthesis, 202
Forced write-through, 33
  Disabling, 34
Format conversion, 119
Frame animation, 315
Frames
  Configuring, 99

Gap detection, 166
Generating MTC with Sound Forge, 279

Glitches
  Find, 193
  Repair using Channel, 194
  Repair using Interpolate, 195
  Repair using Replace, 196

Go To dialog, 173
Grab/Pan mode, 342
Graphic Fade, 222
  Custom, 223
  Reset Envelope button, 223
  Show wave, 223

Halving/doubling loops, 309
Hard disk defragmentation, 29
Hardware setup
  MIDI/SDS, 290
  SCSI/SMDI, 290
Help
  On the Web, 71
  What's This?, 71
  Hiding the video strip, 315
Measures and Beats
   Configuring, 100

Media
   RealMedia files, 324
   Streaming, 323

Media files
   Navigation markers, 328

Meters
   Disabling, 34
   Record, 163

MIDI, 267
   Conflicting SCSI IDs, 291
   Device configuring, 272
   Device naming, 267
   Devices, 276
   Fine-tune, 287
   Initiating playback, 274
   Input synchronization, 273
   Keyboard, 288
   Open loop versus closed loop, 285
   Periodic transfer failures, 291
   Playback and triggered playback, 271
   Resetting triggers, 274
   Trigger configuring, 273
   Triggered playback, 272
   Triggers, 271
   Unity note, 287

MIDI Keyboard, 288
   Configuring, 288
   Displaying, 288
   Generating chords, 289
   Specifying instruments, 289
   Troubleshooting, 289
   Turning on, 288

MIDI Sample Dump Standard, 281

MIDI Time Code
   Generating, 279
   Playing regions with, 278

MIDI Time Code synchronization, 277

MIDI Triggers, 271

MIDI/SDS
   Hardware setup, 290
   Troubleshooting, 290

MIDI/SMPTE, 267
   Minimizing quantization error, 116

Mix
   Drag-and-drop, 190

Mixing, 92

Modes
   Recording, 151

Mono to stereo conversion, 117

Moving markers, 126

MP3 Plug-In, 27

MTC sync, 277

MTU, 371

Multiple stream AVI files, 314

Multiple takes (no Regions), 152

Multiple takes creating regions, 152

Musical time intervals, 134

Mute, 226

Naming a marker, 125

Navigating AVI files, 314

Navigating in the Overview, 182

Navigating the spectrum graph, 340

Navigation toolbar, 47
New Features
Acoustic Mirror, 26
Bit-Depth Converter, 27
CD writing, 26
Extended bit-depth, 25
Extended sample rate, 26
MP3 Plug-in, 27
Perfect Clarity Audio, 27
Repair functions, 27
WaveHammer, 27
XFX Plug-ins, 26

Opening
Files, 73
Playlist files, 148
Preset package files, 209
Regions List files, 130
Workspaces, 84

Opening a file in Direct mode, 30
Opening an AVI file, 313

Optimization
Background processing, 35
Direct mode, 30
Faster file saving, 31
Hard disk defragmentation, 29
Meters, 34
Passive update, 35
Playback cursor and record counter, 34
Preload size, 33
Scan for external monitor, 35
Sound Mapper, 32
Total buffer size, 32
Windows 9x/Me default settings, 30

Optimizing RealMedia files, 323

Overview, 180
Navigating, 182
Playback, 182
Using, 180

Overwrite, 185

Pan/Expand, 232
Mix mid-side (MS), 234
Pan (mix channels before panning), 234
Pan (preserve stereo separation), 234
Stereo expand, 234

Passive updating of displays, 35

Paste, 88
Drag-and-drop, 189
In a new data window, 88
In an existing data window, 88

Normalizing audio, 227

Normalize, 227
Apply dynamic compression, 231
Attack time, 229
Ignore (saturate), 231
Ignore below, 229
Normalize peak value to 0dB, 231
Normalize to, 229
Normalize using Peak level, 228
Normalize using Average RMS power, 228
Release time, 229
Scan Levels, 230
Stop processing, 231
Use equal loudness contour, 230

Normalization, 117

Noise gate, 116
Noise shape type, 115
Noise shaping, 217

Noise gate, 116
Noise shape type, 115
Noise shaping, 217

Normalizing audio, 227
Normalize, 227
Apply dynamic compression, 231
Attacxh time, 229
Ignore (saturate), 231
Ignore below, 229
Normalize peak value to 0dB, 231
Normalize to, 229
Normalize using Peak level, 228
Normalize using Average RMS power, 228
Release time, 229
Scan Levels, 230
Stop processing, 231
Use equal loudness contour, 230

Normalizing audio, 227

Normalize, 227
Apply dynamic compression, 231
Attack time, 229
Ignore (saturate), 231
Ignore below, 229
Normalize peak value to 0dB, 231
Normalize to, 229
Normalize using Peak level, 228
Normalize using Average RMS power, 228
Release time, 229
Scan Levels, 230
Stop processing, 231
Use equal loudness contour, 230

Normalizing audio, 227

Object linking and embedding, 367
OLE, 367

Open dialog, 74

Playing, 71

Playlist files, 148

Preset package files, 209

Regions List files, 130

Workspaces, 84

Opening
Files, 73
Playlist files, 148
Presets package files, 209
Regions List files, 130
Workspaces, 84

Opening a file in Direct mode, 30
Opening an AVI file, 313

Optimization
Background processing, 35
Direct mode, 30
Faster file saving, 31
Hard disk defragmentation, 29
Meters, 34
Passive update, 35
Playback cursor and record counter, 34
Preload size, 33
Scan for external monitor, 35
Sound Mapper, 32
Total buffer size, 32
Windows 9x/Me default settings, 30

Optimizing RealMedia files, 323

Overview, 180
Navigating, 182
Playback, 182
Using, 180

Overwrite, 185

Pan/Expand, 232
Mix mid-side (MS), 234
Pan (mix channels before panning), 234
Pan (preserve stereo separation), 234
Stereo expand, 234

Passive updating of displays, 35

Paste, 88
Drag-and-drop, 189
In a new data window, 88
In an existing data window, 88
INDEX

Paste Special, 184
  Crossfade, 185
  Overwrite, 185
  Replicate, 186

Pencil tool, 197

Perfect Clarity Audio, 27

Playback in the Overview, 182

Playbar, 42
  Current playback mode, 43

Playing a file, 76

Playing a file from a specific point, 77

Playing a selection, 78

Playing from the Playlist, 142

Playlist, 139
  Adding regions, 139
  Arranging, 142
  AVI files, 321
  Count, 141
  Creating a new file from, 145
  Cutlist, 145
  Deleting a region, 144
  Displaying, 139
  Playing from, 142
  Replicating regions, 143
  Stop points, 143

Playlist files
  Opening, 148
  Saving, 147

Playlist/Cutlist, 123

Plug-In Chainer, 198

Preload size, 33

Prepare button, 165

Pre-roll to cursor, 173

Preset Manager, 209

Preset package files
  Adding a preset, 210
  Deleting a preset, 210
  Opening, 209
  Saving, 210

Presets, 207
  Creating, 208
  Deleting, 209
  Using, 207

Previewing a cut, 90

Previewing an operation, 210

Previews, 210
  Bypass, 212
  Fade out last 10 milliseconds, 211
  Limit previews to, 211
  Loop preview continuously, 211
  Parameters, 210
  Post-roll, 211
  Pre-roll, 211
  Reactive previewing, 212

Process
  Auto Trim/Crop, 213
  Bit-Depth Converter, 215
  Channel Converter, 218
  DC Offset, 220
  EQ, 221
  Fade, 222
  Fade In, 224
  Fade Out, 224
  Insert Silence, 225
  Invert/Flip, 226
  Mute, 226
  Normalize, 227
  Pan/Expand, 232
  Resample, 235
  Reverse, 238
  Smooth/Enhance, 238
  Time Compress/Expand, 238
  Volume, 239

Process toolbar, 51

Processes, 207

Punch-In
  Pre/Post-roll, 154

Punch-In (record a specific length), 153
INDEX

Q
Quantization error
  Minimizing, 116

R
Radio buttons, 61
Rapid sound attacks, 133
RealMedia files, 324
  Custom templates, 325
  From WAV and AVI files, 325
  Optimizing, 323
  Summary fields, 324
Receiving a sample, 287
Record
  DC adjust, 154
  Levels, 164
Record button, 166
Record dialog, 149
  Close button, 156
  Drop Marker button, 166
  Go To button, 158
  Help button, 158
  New button, 156
  Prepare button, 165
  Record button, 166
  Remote button, 157
  Selection button, 159
  Sync button, 161
  Toolbar, 165
  Window button, 160
Record meters, 163
  Scaling, 163
Recording, 149
Recording attributes, 151
Recording modes, 151
  Automatic retake, 152
  Create a new window for each take, 153
  Multiple takes (no Regions), 152
  Multiple takes creating Regions, 152
  Punch-In, 153
  Recording the test tone, 254
  Recording time, 151
  Recover, 109
  Recovering the impulse, 254
Redirector files
  ASF, 332
  Windows Media, 331
Region playback using MTC, 278
Regions, 123
  Auto Region tool, 133
  Creating, 130
  Creating automatically, 132
  Creating from markers, 127
  Editing, 135
  Extracting, 138
  Regions List, 127
Regions List, 127
  Changing the region order, 129
  Configuring the display, 129
  Displaying, 128
  Editing regions, 136
  Saving Regions List files, 129
Regions List files
  Opening, 130
Regions/Playlist toolbar, 50
Release loops, 296
  Creating, 297
Relocating the temporary storage folder, 31
Remote button, 157
Remote recording, 157
Repair
  Channel, 194
  Interpolate, 195
  Replace, 196
  Repair using Pencil tool, 197
  Repeating an operation, 212
  Replace, 196
  Replicate, 143, 186
Replicating regions, 143
Resample, 235
   Apply an anti-alias filter during resample, 237
   Downsampling, 236
   Interpolation accuracy, 237
   New sample rate, 237
   Set the sample rate only (do not resample), 238
   Upsampling, 236
Restoring a selection, 179
Reverse, 238
RIFF Wave chunks, 361
Ripping data from CD, 168
Ripping, CD, 26
Rotate audio, 310

S
Sample rate, 112
   CD writing, 170
   Editing, 113
Sample size
   Editing, 114
Sampler configuration
   Saving, 286
Sampler Configuration dialog, 283
   Displaying, 283
Sampler dialog, 282
   Displaying, 282
Sampler Tool, 283
Samplers, 281
   External, 281
   Internal, 282
Samples
   Receiving, 287
   Sending, 286
Sampling, 281
Save All, 83
Save As, 119
Save As dialog, 82, 119

Saving
   All open files, 83
   AVI files, 317
   Files, 81
   Loop points, 312
   Playlist/Cutlist files, 147
   RealMedia files, 325
   Regions List files, 129
   Summary information, 122
   Workspaces, 84
Saving sample configurations, 286
Scaling Record meters, 163
Scan Levels, 230
Script commands, 328, 329
SCSI MIDI Device Interface, 282
SCSI/SMDI
   Hardware setup, 290
   Troubleshooting, 291
Selection status fields, 78
Selections
   Auto snap to, 177
   Creating on the fly, 176
   Fine-tuning, 177
   Restoring, 179
   Set Selection dialog, 175
   Statistics, 79
Sending
   Samples, 286
   Set Selection dialog, 175
Setting record levels, 164
Shift selection left/right, 309
Simple synthesis, 205
Smooth/Enhance, 238
SMPTPE, 267, 359
Sonogram, 343
   Displaying, 344
   Displaying frequency and amplitude, 344
   Tuning, 344
   Updating, 344
<table>
<thead>
<tr>
<th>Sound Forge</th>
<th>Spectrum graph, 335</th>
</tr>
</thead>
<tbody>
<tr>
<td>Command descriptions, 58</td>
<td>Ceiling, 340</td>
</tr>
<tr>
<td>Control, 37</td>
<td>Displaying, 335</td>
</tr>
<tr>
<td>Controls, 58</td>
<td>Displaying amplitude range, 341</td>
</tr>
<tr>
<td>Crash recovery, 109</td>
<td>Displaying an amplitude and frequency range, 341</td>
</tr>
<tr>
<td>Data window, 40</td>
<td>Displaying frequency and amplitude values, 336</td>
</tr>
<tr>
<td>Full-version features, 22</td>
<td>Displaying frequency and pitch, 336</td>
</tr>
<tr>
<td>Installation, 23</td>
<td>Displaying frequency range, 340</td>
</tr>
<tr>
<td>Introduction, 21</td>
<td>Displaying stereo files, 336</td>
</tr>
<tr>
<td>Main screen, 39</td>
<td>FFT overlap, 338</td>
</tr>
<tr>
<td>Playbar, 42</td>
<td>FFT size, 338</td>
</tr>
<tr>
<td>Status formats, 98</td>
<td>Floor, 340</td>
</tr>
<tr>
<td>Toolbars, 43</td>
<td>Hold peaks during monitoring, 340</td>
</tr>
<tr>
<td>ToolTips, 58</td>
<td>Logarithmic graphic, 339</td>
</tr>
<tr>
<td>Sound Mapper, 32</td>
<td>Maintain last monitored view, 340</td>
</tr>
<tr>
<td>Source radio buttons, 119</td>
<td>Monitoring an input source, 335</td>
</tr>
<tr>
<td>Specifying audio and video streams, 318</td>
<td>Monitoring playback, 335</td>
</tr>
<tr>
<td>Specifying bit-depth, 25</td>
<td>Navigating, 340</td>
</tr>
<tr>
<td>Spectrum analysis, 333</td>
<td>Overview window, 343</td>
</tr>
<tr>
<td>FFT, 334</td>
<td>Set sonogram resolution, 339</td>
</tr>
<tr>
<td>Grab/Pan mode, 342</td>
<td>Slices displayed, 339</td>
</tr>
<tr>
<td>Sonogram, 343</td>
<td>Smoothing window, 339</td>
</tr>
<tr>
<td>Spectrum graph, 335</td>
<td>Sync graphs, 337</td>
</tr>
<tr>
<td>Spectrum Settings dialog, 338</td>
<td>Updating, 337</td>
</tr>
<tr>
<td></td>
<td>Viewing multiple, 337</td>
</tr>
<tr>
<td>Statistics, 79</td>
<td>Spectrum Settings dialog, 338</td>
</tr>
<tr>
<td>Status fields, 78</td>
<td>Spin controls, 60</td>
</tr>
<tr>
<td>Status formats, 98</td>
<td>Standard toolbar, 45</td>
</tr>
<tr>
<td>Status/Selection toolbar, 49</td>
<td>Statistics, 79</td>
</tr>
<tr>
<td>Step-down conversion, 114</td>
<td>Status fields, 78</td>
</tr>
<tr>
<td>Step-up conversion, 113</td>
<td>Status formats, 98</td>
</tr>
<tr>
<td>Stereo files</td>
<td>Status/Selection toolbar, 49</td>
</tr>
<tr>
<td>Previewing data, 67</td>
<td>Step-down conversion, 114</td>
</tr>
<tr>
<td>Selecting data, 65</td>
<td>Step-up conversion, 113</td>
</tr>
<tr>
<td>Single channel editing, 67</td>
<td>Stereo files</td>
</tr>
<tr>
<td>Working with, 64</td>
<td>Previewing data, 67</td>
</tr>
<tr>
<td>Stereo-to-mono conversion, 118</td>
<td>Selecting data, 65</td>
</tr>
</tbody>
</table>
Stop points
  Creating, 143
  Deleting, 144
Streaming media, 323
  Navigation markers, 328
  RealMedia, 324
  Script commands, 328
  Windows Media, 327
Summary information, 120
  Editing, 120
  Saving, 122
  Viewing, 120
Sustaining loops, 296
  Creating, 296
Sync button, 161
Sync graphs, 337
Synchronization
  MIDI Time Code, 277
Synthesis, 200

T
Tempo
  Loops, 311
Test tone
  recording, 254
  Transferring, 253
Time Code
  SMPTE, 359
Time Compress/Expand, 238
Time Ruler, 101
Tools, 43
  ACID Loop Creation Tools, 57, 306
  Displaying, 44
  Effects, 53
  Levels, 56
  Navigation, 47
  Process, 51
  Record dialog, 165
  Regions/Playlist, 50
  Standard, 45
  Status/Selection, 49
  Tools, 55
  Transport, 46
  Views, 48
Tools toolbar, 55
ToolTips, 58
Total buffer size, 32
Transferring the test tone, 253
Transport toolbar, 46
Triggered playback, 272
Triggered region playback, 274
Triggers, 271
  Resetting, 274
Trim/Crop, 91
Trimming the impulse file, 256
Troubleshooting
  MIDI/SDS, 290
  SCSI/SMDI, 291
Troubleshooting Acoustic Mirror, 260
Tuning a sonogram, 344
INDEX

U

Undo/Redo, 94
  Disabling, 94
  History window, 95
Unity note, 287
Updating a sonogram, 344
Updating a spectrum graph, 337
Using
  Accoustic Mirror, 244
  Audio Plug-In Chainer, 198
  Bit-Depth Converter, 216
  Channel Converter, 218
  Crossfade Loop tool, 305
  Cutlist, 146
  Envelope graphs, 62
  Go To dialog, 174
  Invert/Flip, 226
  Loop Tuner, 300
  Magnify tool, 107
  Mute, 226
  OLE with Sound Forge, 367
Overview, 180
Preset Manager, 209
Presets, 207
Set Selection dialog, 175
Status formats, 98
The mouse, 37
Volume, 240
Using Pre-roll to cursor, 173
Using the Cutlist, 145

V

Video
  compression, 318
  Date rate, 320
  Key frames, 319
Video preview, 316
Video strip, 315
  Frame animation, 315
  Navigating, 314
Viewing extended summary information, 120
Viewing presets, 209
Views, 183
  Creating, 184
  Views toolbar, 48
Virtual MIDI Router, 267
  Configuring, 269
  Installing, 268
VMR, 267
Volume, 239

W

WaveHammer, 27, 262
  Compress tab, 262
  Displaying, 262
  Limit tab, 265
What’s This? Help, 71
  Using, 71
Window button, 160
Windows 9x/Me Default Settings, 30
Windows Media
  Creating, 328
  Navigation markers, 328
  Script commands, 329
Windows Media files, 327
  Markers and script commands, 328
Windows Media Redirector files, 331
WMA files, 327
WMV files, 327
Working with AVI files, 313
Working with stereo files, 64
Workspaces, 84
Writing to CD, 169

Z

Zero-crossing preference, 160, 176
Zoom and magnify, 100
Zoom ratio, 101
Zoom tricks, 105

Zooming
   Level Ruler, 103
   Time Ruler, 101