# Table of Contents

- **Preface** ................................................................. 9
- About this manual .................................................. 9
- Conventions used in this book ................................. 10

## Introduction .......................................................... 11

- About SONAR .......................................................... 12
  - Publish ............................................................. 12
  - Music Composition and Exploration .................. 12
  - Remixing .......................................................... 12
  - Game Sound Development .................................. 12
  - Sound Production and Engineering ................. 13
  - Web Authoring .................................................. 13
  - Film and Video Scoring and Production .......... 13
  - Publishing Music on the Internet ................. 13
  - Burning Audio CDs .......................................... 13
  - Flexibility ....................................................... 14
- Computers, Sound, and Music .................................. 14
  - MIDI ................................................................. 14
  - Digital audio .................................................. 15
- Setup ................................................................. 16
  - Audio connections ........................................... 17
  - MIDI Connections ............................................ 19
  - Changing I/O devices ....................................... 20
- Starting SONAR ...................................................... 23

## SONAR basics ......................................................... 26

- SONAR file types .................................................. 27
- Opening a file .................................................... 28
- Views ................................................................. 28

- Flexibility .......................................................... 14
- Computers, Sound, and Music .................................. 14
- MIDI ................................................................. 14
- Digital audio .................................................. 15
- Setup ................................................................. 16
- Audio connections ........................................... 17
- MIDI Connections ............................................ 19
- Changing I/O devices ....................................... 20
- Starting SONAR ...................................................... 23
- SONAR basics ......................................................... 26
- SONAR file types .................................................. 27
- Opening a file .................................................... 28
- Views ................................................................. 28
Working on a project ................................................................. 46
Windows taskbar indicators .................................................... 46
Screen colors and wallpaper .................................................... 47
  Color presets ...................................................................... 48
Installing SONAR .................................................................... 51
Starting to use SONAR ............................................................. 52

Tutorial 1 – Creating, playing, and saving projects .................... 53
  Creating a new project .......................................................... 54
  Opening project files ............................................................ 56
  Playing project files ............................................................. 58
    Configuring your sound device ............................................ 58
    Setting the tracks outputs ................................................ 59
    Playing the project ........................................................... 61
  Looping project files ........................................................... 62
  Saving project files ............................................................. 63

Tutorial 2 – Using the Media Browser ....................................... 65
  Finding and previewing audio loops ...................................... 68
    Previewing MIDI groove clips .......................................... 69
    Adding loops to your project ............................................. 70

Tutorial 3 – Recording vocals and musical instruments ............... 71
  Troubleshooting ................................................................ 74

Tutorial 4 – Playing and recording software instruments ............. 77
  Adding an instrument track to your project ......................... 78
  Recording MIDI .................................................................. 80
  Manually entering MIDI notes ............................................ 80

Tutorial 5 – Working with music notation .................................. 85
  Printing your notation ......................................................... 92
## Tutorial 6 – Editing your music

- Selection .................................................. 93
- Moving clips ............................................. 95
- Splitting Clips .......................................... 95
- Cropping Clips ......................................... 96
- Undo and Redo ........................................ 97

## Tutorial 7 – Mixing and adding effects

- Volume and pan ........................................ 100
- Adding effects (FX) ................................... 101
- Using Automation ..................................... 105

## Tutorial 8 – Working with video

- Importing video ....................................... 107
- What if I don’t see the Video Thumbnail pane or Video view? .............. 110
- Changing the video properties .......................... 110
- Working with markers ................................ 112
- Exporting your video .................................. 114

## Tutorial 9 – Exporting, CD burning and sharing

- Burning an audio CD ................................. 117
- Cakewalk Publisher .................................. 119

## New features in SONAR 8.5

- PX-64 Percussion Strip ............................... 123
- VX-64 Vocal Strip ..................................... 124
- Session Drummer 3 .................................... 125
- Alias Factor ............................................. 126
- Classic Phaser .......................................... 126
- HF Exciter .............................................. 127
- Mod Filter ................................................ 127
- Multivoice Chorus/Flanger ......................... 127
- Para-Q. ................................................... 128
- Stereo Compressor/Gate ............................ 128
- Stereo Delay ........................................... 129
- Studioverb2 ............................................ 129
New Impulse Responses for Perfect Space .............................................. 129
Step Sequencer 2.0 ................................................................. 130
Integrated arpeggiator ............................................................... 131
Support for more MIDI ports ...................................................... 131
Matrix view ............................................................................. 132
REX file import ................................................................. 133
Freeze and Archive buttons in Track view .................................... 133
New Freeze option ............................................................... 134
Solo track/bus from plug-in window ............................................. 134
Insert Send Assistant enhancements ........................................... 135
DC offset meter in Analyst ....................................................... 136
AudioSnap 2.0 ................................................................. 137
TAB to transients ............................................................... 138
Auto Scroll Lock in Clips pane ................................................. 138
Clips pane vertical grid lines ..................................................... 138
Draggable Now Time marker ..................................................... 138
Change I/O devices without restarting SONAR ............................ 139
VST plug-in compatibility options ................................................ 139
Media Browser enhancements .................................................. 140

Troubleshooting ............................................................................. 141
Audio dropouts or crash when playing back large files at maximum latency. 142
When I Play a File, I Don’t Hear Anything ..................................... 143
I Can’t Record from My MIDI Instrument .................................... 144
When I Play a File Containing Audio, the Audio Portion Doesn’t Play. 145
I Can’t Record Any Audio ........................................................... 146
The Music Is Playing Back with the Wrong Instrument Sounds ....... 146
My Keyboard Doubles Every Note I Play ...................................... 147
I Don’t See the Clips Pane in the Track View ................................ 147
Why Can’t SONAR Find My Audio Files? ..................................... 147
Why Do I Get Errors from the Wave Profiler? ............................... 148
My Track or Bus Fader is Maximized, But There’s No Sound or Level 148
How Do I Use SONAR to Access All the Sounds on My MIDI Instrument? 149
I Hear an Echo When I Record ..................................................... 149
Dropouts Happen in High Bit-depth or High Sample Rate Audio ....... 150
Patching an Effect into SONAR Causes a Dropout ........................ 150
SONAR User’s Guide is designed to help you learn and use SONAR. This book explains how SONAR works and how to use it to create, edit, produce, and perform. The SONAR User’s Guide is task-oriented, with lots of cross-references, so that you can find the information you need. The User’s Guide book also includes a comprehensive index that you can use to find information on any specific topic.

About this manual

This manual provides basic information about how to install and set up SONAR make initial settings and system setup. It also provides tutorials to help you get started as well as a glossary of terms used in this manual.

Using the online Help

SONAR also includes complete documentation in an HTML-based online Help system. SONAR’s online Help provides detailed information about each feature in the program, including menu commands, windows, dialogs, keyboard shortcuts and common procedures. You can get context-sensitive help at any time by pressing the F1 key.

Need more info?

In addition to the User’s Guide and the online Help, you can also find more help in the following places:

- The ReadMe file contains information that was not available at the time of this printing. On SONAR’s Help menu, click View README.RTF.
- Visit the peer-to-peer Cakewalk forums at http://forum.cakewalk.com/default.asp.
- Visit the SONAR Support page at http://www.cakewalk.com/Support/SONAR/DEFAULT.ASP.
# Conventions used in this book

The following table describes the text conventions in this book:

<table>
<thead>
<tr>
<th>Convention</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Bold</strong></td>
<td>Text that appears in bold is a command in SONAR. For example: Click <strong>OK</strong>.</td>
</tr>
<tr>
<td>Right guillemet</td>
<td>A right guillemet is a menu item separator and represents a level in the menu hierarchy. For example: <strong>File &gt; Open</strong> means to click on the <strong>File</strong> menu and select the <strong>Open</strong> command.</td>
</tr>
<tr>
<td>Monospace font</td>
<td>A monospace font is used for file names, directory paths and code examples. For example: Locate the project named <strong>SONAR_AudioDemo1.cwp</strong>.</td>
</tr>
<tr>
<td>Plus sign (+)</td>
<td>A plus sign (+) is used between the keys to be pressed in a key combination. For example: CTRL+A means hold down the CTRL key and press the A key.</td>
</tr>
</tbody>
</table>
Introduction

SONAR is a professional tool for authoring sound and music on your personal computer. It’s designed for musicians, composers, arrangers, audio and production engineers, multimedia and game developers, and recording engineers. SONAR supports Wave, MP3, ACIDized waves, WMA, AIFF and other popular formats, providing all the tools you need to do professional-quality work rapidly and efficiently.

SONAR is more than an integrated MIDI and digital audio authoring software package—it’s an expandable platform that can function as the central nervous system of your recording studio. With drivers for common high-end audio hardware, full support for audio plug-ins, software synthesizers, MFX MIDI plug-ins, and MIDI Machine Control (MMC) of external MIDI gear, SONAR can handle your most demanding projects.

In This Chapter

- About SONAR .......................................................... 12
- Computers, Sound, and Music ................................. 14
- Setup ...................................................................... 16
- Starting SONAR ....................................................... 23
- SONAR basics .......................................................... 26
- Windows taskbar indicators ...................................... 46
- Screen colors and wallpaper ...................................... 47
- Installing SONAR ..................................................... 51
About SONAR

SONAR lets you work with music on your own level. Here are some of the ways you can make music with SONAR:

Publish

Publishing usually means printing your music; it’s one way to share your finished product with other performers. After you’ve recorded and arranged a song in SONAR, you can produce printed lead sheets and small scores with lyrics for sharing. You can also share the music files themselves. SONAR will save your music in a format that you can put on a web site or email to other people.

SONAR is the flagship product of the Cakewalk line of integrated MIDI and digital audio sequencers for the Windows platform. SONAR has a comprehensive feature set that makes it the single most productive tool for sound and music authoring. Here are some of the ways you can use SONAR.

Music Composition and Exploration

SONAR is a powerful music-composition application, providing tools to record your own musical performances; enhance or improve the quality of those performances; and edit, arrange, and experiment with the music. With a few simple clicks of the mouse, you can arrange, orchestrate, and audition your composition. Fully integrated sequencing allows you to combine the convenience and flexibility of MIDI composition with the high-quality sound and subtlety of digital audio sound recording and reproduction. Change the feel of a piece by locking it to a musical groove, or add delicate delays, anticipations, or echoes that add richness to the music.

SONAR displays and lets you edit your music using standard musical notation and guitar tablature, so you can adjust individual notes, add performance markings, and print individual parts or full scores. You can graphically draw tempo and volume changes, or add lyrics to display on-screen or to include with printed scores.

Remixing

SONAR’s Groove clips allow you to import, create, export and edit loops, making it possible to quickly change tempos and keys for an entire project. The Media Browser view lets you preview loops in the project’s tempo and key before dragging and dropping them onto a track.

Game Sound Development

There’s no better tool than SONAR for composing music for electronic games. Clip-based sequencing lets you create and reuse musical themes freely, so you can associate musical sections with game characters, locations, objects, and actions. Your creations can be saved and replayed using the compact MIDI file format, which adapts its sound automatically to the target hardware for the best possible sound reproduction.
Sound Production and Engineering

If you want to produce music CDs or master tapes, SONAR has virtually everything you need from recording to mixing and mastering. Multichannel recording lets you capture studio or live performances track by track. Reconfigurable buses provide full control over your mix. Real-time stereo effects like chorus, flange, reverb, and delay/echo can be applied as track inserts, in effects loops, or to the master mix. SONAR supports 44.1 KHz sampling for CD-quality sound, 24-bit/96 kHz sound for DVD-quality sound, and lets you choose from lower or higher sample rates as well. All audio effects are 32-bit floating point for faster processing and high-quality sound reproduction. Many effects now support 64-bit processing for pristine quality.

Web Authoring

SONAR is the ideal tool for developing and producing music and sound for the World Wide Web, because it lets you save your work in the formats that are most commonly used on web sites: MIDI, MP3, and Windows Media Advanced Streaming Format. Any SONAR project—musical composition, audio clip, commercial spot, jingle with voice-over—can be stored in a web-compatible format with a few simple mouse clicks.

Film and Video Scoring and Production

SONAR has many of the tools you need to execute audio post-production projects quickly and efficiently. SONAR provides chase lock sync to time code for frame-by-frame accuracy when synchronizing audio or MIDI to film or video. Or, you can turn chase lock off to conserve CPU power. SONAR provides high-quality time stretching and sample-accurate editing with zero-crossing detection so you can make the fine adjustments you need very quickly and easily. In addition, SONAR’s support for video files gives you convenient synchronized access to digitized video, making film and video scoring easier than ever.

Publishing Music on the Internet

Cakewalk Publisher allows you to easily present and share your music online. With Cakewalk Publisher, you can create a customized streaming music player with a playlist of your music, upload it to your personal or band’s website, and embed it in any other website. You can also update your playlist with album art, links (URLs), and artist, track, & album information.

Burning Audio CDs

SONAR has integrated Audio CD burning, which allows you to write your audio tracks to an audio CD that can be played in any standard CD player.
Flexibility

SONAR works the way you want to work—you can customize screen layouts, toolbars, and audio and MIDI system configurations to make your work more efficient. SONAR integrates with other sound editing tools so you can access them in an instant without leaving SONAR. There are custom software modules to support specialized audio devices from Roland and Yamaha. SONAR’s unique StudioWare technology provides software interfaces for common studio hardware.

Computers, Sound, and Music

This section provides some background on the different ways that computers store and play sound and music. Computers work with sound and music in two different forms: MIDI and digital audio.

MIDI

MIDI (short for Musical Instrument Digital Interface) is the way computers communicate with most sound cards, keyboards, and other electronic instruments. MIDI refers to both the type of cables and plugs used to connect the computers and instruments, and to the language those computers and instruments use to talk to each other. The MIDI standard is accepted and used worldwide. Almost any electronic instrument you buy today will have MIDI connectors and can be used with other MIDI instruments and with your computer’s MIDI interface. To record MIDI in SONAR, you have to have a MIDI cable connecting the MIDI OUT port on your MIDI instrument to a MIDI IN port on either your sound card or your MIDI interface. You must also make sure that you have installed the software MIDI driver that came with your sound card or MIDI interface.

The MIDI language conveys information and instructions, both from the computer to the instrument and from the instrument to the computer. For example, if your computer wants your keyboard to play a note, it sends a MIDI “Note On” message and tells the keyboard which note to play. When your computer wants the keyboard to stop playing that note, it sends another message that stops the note from playing.

The MIDI language has many other instructions, such as messages to change the sound that is used to play the notes (the bank and patch), messages that enable working with the sustain pedal and the pitch-bend wheel, and others. By sending the right messages at the right times, your computer can control your electronic instrument and make it play music.

MIDI information can be sent on 16 different channels. You can set up your MIDI equipment to listen for messages on all channels or on only a few.

MIDI files contain all the MIDI messages and timing information that are needed to play a song. MIDI files can be read and played by many different programs, including SONAR, and can even be played by programs on other types of computers. MIDI files have the extension .mid.
There are several important advantages of the MIDI format:

- Large amounts of music can be stored in a very compact form
- Different parts of a piece can easily be assigned to any instrument you can imagine
- The music contains information on notes, tempos, and key signatures that makes it possible to display and edit the piece using standard musical notation

The primary disadvantage of MIDI is that the quality of the sound a listener hears will vary depending on the MIDI equipment the listener is using. For example, MIDI usually sounds much better on an expensive synthesizer than it does on an inexpensive sound card.

**Digital audio**

Digital audio (frequently referred to here as just “audio”) is a simple way to record and play sounds of any type. It works like a tape recorder—you record something, then later play it back. Digital audio stores the sound as a long series of numbers. To record audio in SONAR, you have to have an audio cable connecting the audio output of your electronic instrument to the audio input on your sound card or audio hardware. If you’re recording vocals or an acoustic instrument, you need to connect a microphone to the audio input on your sound card or audio hardware.

**Sound Waves**

Sound waves are vibrations in the air. Sound waves are generated by anything that vibrates; a vibrating object causes the air next to it to vibrate, and the vibration is passed through the air in all directions. When the vibrating air enters your ear, it makes your eardrum vibrate, and you hear a sound. Likewise, if the vibrating air hits a microphone, it causes the microphone to vibrate and send electrical signals to whatever it’s connected to.

These vibrations are very fast. The slowest vibration frequency you can hear is about 20 vibrations per second, and the fastest is around 16,000 to 20,000 vibrations per second.

**Recording digital audio**

To record digital audio, your computer monitors the electrical signal generated by a microphone, an electric guitar, or another source. At equal intervals of time (for CD-quality sound, this means 44,100 times a second), the computer measures and saves the strength of the electrical signal from the microphone, on a scale from 0 to 65,535.

That's it. Digital audio data is just a long series of numbers. The computer sends these numbers, in the form of electrical signals, to a speaker. The speaker then vibrates and generates the same sound that was recorded.

The primary advantage of digital audio is the quality of the sound. Unlike MIDI, a digital audio recording is very rich, capturing all the nuances, overtones, and other characteristics of the sound exactly as performed. The main drawback of digital audio is that it takes up a lot of disk space. To record a 1-minute segment of stereo, CD-quality digital audio, you need about 10 megabytes of disk space.

On the PC, digital audio is usually stored in Wave files (extension .wav). There are many programs available that let you create, play, and edit these files. SONAR reads, writes, and lets you edit Wave files.
Setup

You can install SONAR on any computer that runs Windows XP or x64 and has a sound card or built-in sound module. If you want to hook up other devices, like a MIDI keyboard, an electric guitar, or a microphone, you need the right cables, and you need to find the right connectors on your computer.

Before you install SONAR, take a minute to register the software so we can let you know when updates become available and provide you with technical support. To register anytime log onto www.cakewalk.com/register, or call 888-CAKEWALK (U.S.) or +(617)-423-9004 (outside the U.S.) between 9 AM and 8 PM Eastern Standard Time. If you live outside of North America, please visit our distributor’s page at www.cakewalk.com/Dealers/International.asp to get the telephone number of your local distributor. You’ll need to supply your serial number, your name, and a valid email address.

To connect a MIDI keyboard to your computer, you need standard MIDI cables or a MIDI adapter cable (joystick connector), such as the one available in Cakewalk’s PC Music Pack. One end of the adapter cable should have two 5-pin DIN connectors that connect to your keyboard or other MIDI device. At the other end, you need a 15-pin connector to connect to a sound card through its MIDI/joystick port.

A. MIDI to 15 Pin Connector  B. 15-pin connector (DB15)

If you have a dedicated MIDI interface, lots of electronic music gear, or work with many different music software packages, see the online help topic “Hardware Setup.”

Before you attach or detach any cables from your computer, you should shut down your computer and turn off the power to all your equipment. This greatly reduces the chance of electrical damage to your equipment while plugging and unplugging cables.
User accounts

Previous versions of SONAR required a user to have Windows Administrator status. This is no longer the case. Any level of user can now install and run SONAR. Only one copy of SONAR per machine is necessary for multiple users to run SONAR with each user’s personal settings.

When you first install SONAR, all application data files and .ini files are installed to the system-specified “all users” application data folders:

Windows XP:
C:\Documents and Settings\All Users\Application Data\Cakewalk

Windows Vista:
C:\ProgramData\Cakewalk

When you launch SONAR for the first time, all content files (such as track templates and project templates) will be copied from the global application data folder (All Users) to the user application data folder (User Account), before the program launches.

If you install a SONAR patch on top of the original installation, any updated content files in the patch will not overwrite existing content files in your personal user application data folder. However, you can force SONAR to update the default content files in your personal user data folder.

Warning: The following action will overwrite any SONAR data files such as track templates and project templates that you may have customized. A message box will prompt you if you wish to continue or cancel. Only proceed if you are certain that you will not overwrite any important customized files.

To force SONAR to update and overwrite any default content files, hold down the CTRL key while starting SONAR.

Data in the Program Files folder will be common to all users.

Audio connections

There are several types of audio interfaces (soundcards). CardBus (PCI), USB/USB2 and FireWire are the most common. Laptops can use an audio PCMCIA card. Many audio interfaces also have MIDI inputs and some have built in MIDI synthesizers as well. This section covers the various audio connection options.

Analog and digital Inputs

There are two basic types of audio inputs, analog and digital. Analog inputs allow you to connect a guitar, mic or other instrument to your computer directly. The audio interface converts the analog input to digital. Digital inputs allow other digital devices to connect directly to your computer. Common digital inputs include external analog to digital converters, popular guitar processors like the Line 6 POD, and other digital recording systems like the ADAT decks. Analog inputs are very common, and are standard in virtually all consumer sound cards (the ones that come with your PC). Digital inputs are becoming more popular and are very common on professional and mid-level, “prosumer” interfaces. Analog inputs allow you to record a mono or stereo signal (assuming you
have a stereo input) while digital inputs allow you to record 1 to 8 signals depending on the type of
digital connection.

The following table describes the various analog inputs and outputs.

<table>
<thead>
<tr>
<th>Type of analog input/output</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Balanced (XLR, phono or RCA)</td>
<td>A mono input/output</td>
</tr>
<tr>
<td>Unbalanced (TRS)</td>
<td>A stereo or mono input/output</td>
</tr>
</tbody>
</table>

Table 1.

The following table describes the various digital inputs and outputs.

<table>
<thead>
<tr>
<th>Type of digital input/output</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>S/PDIF</td>
<td>Sony/Philips Digital Interface capable of carrying a stereo signal, S/PDIF is transmitted via RCA, Toslink or more rarely BNC jacks (single-pin cable-TV connections).</td>
</tr>
<tr>
<td>ADAT Lightpipe</td>
<td>Up to 8 channels of simultaneous transfer. If you want to import your old ADAT material without any signal degradation, this is the connection you should use.</td>
</tr>
<tr>
<td>TDIF</td>
<td>Tascam Digital Interface up to 8 channels of simultaneous transfer.</td>
</tr>
<tr>
<td>AES/EBU</td>
<td>Often referred to as simply AES, this type of digital connection uses a modified XLR cable to transfer a stereo signal.</td>
</tr>
</tbody>
</table>

Table 2.

Read your hardware documentation carefully to determine what kind of digital connections, if any, you have on your audio interface.

**To connect an electric guitar or keyboard to your computer**

- If your sound card has a 1/8 inch input jack (built-in sound cards that come with your PC usually do), plug your 1/4 inch mono guitar or audio cable into a 1/8 inch stereo adapter, and then plug the 1/8 inch adapter into the microphone input or line input jack on your computer sound card. If you are connecting a keyboard, the audio cable must go from the keyboard’s audio out or line out jack to the sound card input jack. 1/8 inch stereo adapters are available at consumer electronic supply stores.
  
  Or

- If you use a professional or “prosumer” sound card, there is probably a 1/4 inch input jack on your sound card or audio hardware interface that you can plug your guitar cable or audio cable into.
To connect a microphone to your computer

- If your sound card has a 1/8 inch input jack (built-in sound cards that come with your PC usually do), and your microphone cable has a 1/4 inch plug on the end, plug the mic cable into a 1/8 inch stereo adapter, and then plug the 1/8 inch adapter into the microphone input jack on your computer sound card. 1/8 inch stereo adapters are available at consumer electronic supply stores.

- If you use a professional or “prosumer” sound card, there is probably a 1/4 inch input jack on your sound card or audio hardware interface that you can plug your mic cable into.

- If your mic has a cable with an XLR plug on the end, and your sound card or audio hardware interface has a 1/4 inch input jack, plug the mic cable into an XLR-to-quarter inch adapter, and then plug your mic cable into your audio hardware. If your audio hardware has an XLR input, of course it’s better to use that.

- You can also plug your mic into a mixer or pre-amp, and connect the mixer or pre-amp to an input jack on your audio hardware. This is usually the best method.

That’s it! Now that your instruments are all set to go, you can restart your computer and turn on your keyboard, guitar, and microphone.

For a complete description of audio input options, see the online help topic “Hardware Setup.”

MIDI Connections

There are three types of MIDI cables in common use. Here’s how to connect each of the three types:

- **USB cable.** This is extremely common. Many electronic keyboards and stand-alone MIDI interfaces use this type of connection. To use this type of connection, simply plug one end of the USB cable into the USB jack on your MIDI keyboard or stand-alone MIDI interface, and plug the other end into your computer. If you are using a stand-alone USB MIDI interface, you then need to connect standard MIDI cables between your MIDI keyboard and your stand-alone MIDI interface (see the next procedure, below). If you haven’t already installed the software MIDI driver that came with your keyboard or interface, make sure you do so.

- **Standard MIDI cable.** This is also very common. MIDI keyboards usually have jacks for these cables even if they have a USB connection. You need two of these cables. To use this type of cable, use one cable to connect the MIDI OUT jack on your MIDI instrument to the MIDI IN jack on your stand-alone MIDI interface or sound card, and one to connect the MIDI IN jack on your MIDI instrument to the MIDI OUT jack on your stand-alone MIDI interface or sound card. Many stand-alone MIDI interfaces and audio interfaces use this type of connector.
• **Joystick connector.** This is becoming less common. This is the type of connection seen on older SoundBlaster type sound cards. To use this type of connection, find the end of one of the MIDI cables that is labeled OUT. Plug this connector into the MIDI IN jack on your electronic keyboard. The other 5-pin connector on the MIDI cable is labeled IN. Plug this connector into the MIDI OUT jack on your electronic keyboard. Plug the 15-pin connector on the MIDI cable into the MIDI/joystick port on your sound card. If you have a joystick, unplug it, plug in the MIDI cable, and plug the joystick into the pass-through connector on the MIDI cable.

**Figure 2. Joystick connector—use this if your MIDI interface is the joystick port on your sound card.**

A. Insert this MIDI IN plug into the MIDI OUT port on your MIDI instrument  
B. Insert this MIDI OUT plug into the MIDI IN port on your MIDI instrument  
C. Insert this plug into the joystick port on your sound card

### Changing I/O devices

You can add or remove USB/FireWire audio and MIDI devices while SONAR is running, and the audio and MIDI engines will dynamically respond to any changes.

When a device is added or removed, SONAR prompts you to confirm or cancel the change. If you click **Yes**, playback stops and the audio and MIDI engines reload.

**Preserve selected audio devices on device changes**

Enabled inputs and outputs are persisted per device and per driver mode. This prevents audio ports from shifting around and causing unwanted devices to become selected as active audio inputs and outputs. You can add a device back at any time and SONAR will remember the last set of enabled inputs and outputs for that device.

You can freely add or remove devices without impacting the current working set of enabled devices. Adding a device back will remember its last selected inputs and outputs. You can also switch driver
modes and the existing enabled devices will be remembered for the next time when you switch back to that mode.

**Loading a project after changing audio devices**

When loading a project after changing audio devices, SONAR will attempt to automatically remap any missing device to an equivalent new device. If an equivalent match is not found, the **Missing Audio Outputs** dialog appears, allowing you to manually reassign any unresolved output ports.

The **Missing Audio Outputs** dialog will suggest default assignments for any missing devices. You can click **OK** to accept the assignments, or click **Cancel** to preserve the original missing device assignments. You can also preserve the original missing device by selecting **[Unassigned]** from the **Available Devices** list. If you choose not to reassign a missing device, the **Output** port selection in SONAR will show the missing device name prefixed by **MISSING**.

![Missing Audio Outputs Dialog](image1)

**Note:** The **Missing Audio Outputs** dialog is not shown if there is only a single missing output port and only one available output port. In this case, SONAR will automatically assign the missing output port to the available output port.
Remapping using friendly driver names

When Use friendly names to represent audio drivers is selected in Options > Audio > Drivers, SONAR can intelligently remap devices across different hardware configurations or driver models by using your assigned friendly driver names, even if the hardware names do not match.

This can be very useful if you switch driver modes and load projects you worked on earlier in another driver mode, or if you collaborate with other people who have different hardware configurations. As long as you set up friendly names that match, all outputs will be automatically remapped.

Note: Remapping with friendly names takes precedence over the actual hardware device names.

Automatic MIDI port remapping for control surfaces

SONAR persists the names of MIDI ports that are assigned to control surfaces. This ensures that the correct MIDI ports are assigned to control surfaces, even if you add or remove other MIDI devices.
Starting SONAR

There are many different ways to start SONAR. Here are a few:

- Double-click the SONAR icon on your desktop.
- Click the Start button, and choose Programs > Cakewalk > SONAR 8.5 (Studio or Producer) > SONAR 8.5 (Studio or Producer).
- Click the Start button, point to Documents, and choose a SONAR project from the menu.
- Double-click the SONAR program or any SONAR document from the Windows Explorer or the Find menu.

When starting SONAR, you will see the Quick Start dialog box.

**Figure 3.** The Quick Start dialog

![Quick Start dialog](image)

The Quick Start dialog box has several options:

<table>
<thead>
<tr>
<th>Option</th>
<th>How to use it</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open a Project</td>
<td>Choose a project from the Open File dialog box to open it</td>
</tr>
<tr>
<td>Open a Recent Project</td>
<td>Select a project from the list, and click this button to open it</td>
</tr>
<tr>
<td>Create a New Project</td>
<td>Click here to create a new project.</td>
</tr>
<tr>
<td>Online Videos and more</td>
<td>Click this link to view our tutorial videos online. An active Internet</td>
</tr>
<tr>
<td></td>
<td>connection is needed in order to access this content.</td>
</tr>
<tr>
<td>Getting Started</td>
<td>Click here to view the Getting started topic in the Help file. This topic has</td>
</tr>
<tr>
<td></td>
<td>links to a glossary of terms, as well as some basic procedures.</td>
</tr>
</tbody>
</table>

Table 3.
If you don’t want to see the Quick Start dialog box in the future, uncheck the box at the bottom of the dialog box, and click Close. You can see the Quick Start dialog box later by choosing Help > Quick Start.

**RIFF/MID will not launch SONAR when double-clicked**

**Note:** Double-clicking RIFF MIDI files and Standard MIDI files will fail to launch SONAR even if these file types are associated with SONAR.

**Migrating preferences**

If you have a previous version of Cakewalk installed, SONAR will detect it and give you the option of migrating certain preferences from a single earlier version.

When you choose to migrate preferences, SONAR migrates the following settings from an earlier Cakewalk version:

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Global Options</td>
<td>Settings in the Global Options dialog. Open by selecting Options &gt; Global.</td>
</tr>
<tr>
<td>Key Bindings</td>
<td>Your customized key bindings for controlling SONAR using your MIDI keyboard or computer keyboard.</td>
</tr>
<tr>
<td>Instrument Definitions</td>
<td>Files used to control specific MIDI instruments.</td>
</tr>
<tr>
<td>Audio data directory (WaveData folder) and Picture Cache directory locations</td>
<td>SONAR uses the Data directory and Picture Cache directories from the previous Cakewalk version for storing project wave files and their waveform image files.</td>
</tr>
</tbody>
</table>

**Running Wave Profiler**

The first time you start SONAR, it automatically runs the Wave Profiler utility. Wave Profiler determines the proper MIDI and Audio timings for your sound card and writes them to a file that SONAR refers to when using the card. Wave Profiler does not change the sound card’s DMA, IRQ, or port address settings.

Wave Profiler detects the make and model of your sound card, which determine the card’s audio characteristics. If Wave Profiler finds a card that has a WDM driver, it only profiles that card. If you want to use more than one sound card at a time, and they don’t both have WDM drivers, you must force the one with the WDM driver to use that driver as an older, MME driver. It is not necessary to run the Wave Profiler for a sound card using an ASIO driver. For more information about Wave Profiler, WDM, and MME, see the online help topic The Wave Profiler.
When Wave Profiler determines the kind of card you have, always accept the default settings.

**Note:** You can run the Wave Profiler again at a later time (for example, if you install a new sound card or driver) by choosing the Options > Audio General tab command and clicking Wave Profiler.

### Setting up the MIDI In and MIDI Out devices

When you start SONAR for the first time, it checks your computer to find all the MIDI input and output devices you have installed (such as sound cards and MIDI interfaces). However, sometimes you need to tell SONAR exactly which devices you want it to use. If you’re not getting sound from your sound card or MIDI keyboard, or if you just want to change the MIDI outputs and devices that you are using, follow the steps in this section.

Choose Options > MIDI Devices to open a dialog box in which you select the MIDI In and MIDI Out devices that SONAR will use. Each item in the list is a MIDI Input or MIDI Output from drivers installed using the Windows Control Panel.

1. Select Options > MIDI Devices. You will see the MIDI Devices dialog box, which lets you choose instruments on MIDI inputs and outputs.

   **Figure 4.** The MIDI Devices dialog

   ![MIDI Devices dialog box](image)

2. Look at the top window. Notice that it shows devices on MIDI Inputs; make sure that all devices in this window are checked. If a device isn’t checked, click on it once to select it for MIDI Input.

3. Look at the window on the bottom. Notice that it shows devices on MIDI Outputs. SONAR numbers its MIDI Outputs by the order of the devices in this window. The device on top is on Output 1, the one below it is on Output 2, and so on.
4. Check one device at a time in the Outputs window and click Move Selected Devices to Top to change its order. Then check all the devices that appear in the window to select them for output.

Tip: Be sure to enable (check) MIDI output devices in the MIDI Devices dialog (use the Options > MIDI Devices command). If you don’t do this, you won’t hear any of your MIDI instruments when you play songs in SONAR.

Using MIDI devices after making driver changes

If you later add or remove drivers using the Drivers icon of the Windows Control Panel, SONAR reacts in the following way:

- If you remove a Control Panel driver, SONAR will not use the device it belongs to the next time you run the program. Any other devices you had selected using the Options > MIDI Devices command will remain selected.
- If you add a driver through the Control Panel, SONAR does not automatically use it. You must use the Options > MIDI Devices command to enable the new driver in SONAR’s list.

Note: After you add or remove a driver with the Drivers icon in the Windows Control Panel, you must restart Windows for the change to take effect.

Defining your MIDI instrument or sound card

Once you have selected your MIDI Input and Output devices, SONAR, by default, plays back MIDI sequences using a General MIDI instrument definition. If you are using a synthesizer or sound card that does not adhere to the General MIDI standard, you may want to define that instrument. See the online help topic: Instrument Definitions for more information.

---

SONAR basics

SONAR’s menus and toolbars give you quick access to all the features of SONAR. Some menu choices and tools display dialog boxes that let you choose among various options, or type in the values you want. If you click in most views, in time rulers, or on certain other items with the right mouse button, you see a pop-up menu that provides quick access to many common operations.

The project is the center of your work in SONAR. If you’re a musician, a project might contain a song, a jingle, or a movement of a symphony. If you’re a post-production engineer, a project might contain a 30-second radio commercial or a lengthy soundtrack for a film or videotape production. By default, every project is stored in a file (known as a project file). The normal file extension for a SONAR work file is .cwp.

SONAR organizes the sound and music in your project into tracks, clips, and events.
Tracks are used to store the sound or music made by each instrument or voice in a project. For example, a song that is arranged for four instruments and one vocalist may have 5 tracks—one for each instrument and one for the vocals. Each project can have an unlimited number of tracks. Some of these tracks may be used in your finished project, while others can hold alternate takes, backup tracks, and variations that you might want to keep for future use. Each track can be made up of one or many clips.

Clips are the pieces of sound and music that make up your tracks. A clip might contain a horn solo, a drum break, a bass or guitar riff, a voice-over, a sound effect like the hoot of an owl, or an entire keyboard performance. A track can contain a single clip or dozens of different clips, and you can easily move clips from one track to another.

Groove clips are audio clips which have tempo and pitch information embedded within them, allowing them to follow changes to the project tempo or project pitch. You can click on either edge of a Groove clip and drag out repetitions in the track.

Events are MIDI data (in MIDI tracks) or automation data.

**SONAR file types**

Projects in SONAR can be saved as a project file with the extension .cwp or as a Bundle file with the extension .cwb.

For a complete description of the differences between project files and bundle files, see the online help topic Project Files and Bundle Files.

**Other types of files**

SONAR lets you create and work with several other types of files, in addition to project (.cwp) and bundle (.cwb) files that store your projects:

<table>
<thead>
<tr>
<th>File type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>MIDI files (extension .mid)</td>
<td>Standard MIDI files.</td>
</tr>
<tr>
<td>Template files (extension .tpl)</td>
<td>Templates for new files you create</td>
</tr>
<tr>
<td>StudioWare (extension .CakewalkStudioware)</td>
<td>To control external MIDI devices from SONAR</td>
</tr>
<tr>
<td>OMF (extension .omf)</td>
<td>Open Media Framework format files.</td>
</tr>
</tbody>
</table>

Table 5.
Opening a file

Use the following procedure to open a file.

To open a file in SONAR

1. If you haven’t already done so, start SONAR.
2. Choose File > Open.
3. In the Open dialog box, navigate to the directory where the project you want to open is located and select it.
4. Click the Open button.
5. If you are opening an OMF file, the Unpack OMF dialog appears. Set the initial tempo and specify the directory where you want to save the file and its audio. For more information about opening OMF files, see Unpack OMF dialog in the online help.

SONAR loads the project.

Views

SONAR displays your project in windows on the screen that are known as views. You can have many views open at once, all showing the same project. When you edit a project in one view, the other related views are updated automatically.

The Track View

Track view is the main window that you use to create, display, and work with a project. When you open a project file, SONAR displays the Track view for the project. When you close the Track view for a project, SONAR closes the file.

The Track view is divided into several sections: toolbars (at the top), the Navigator pane, the Video Thumbnails pane, the Track pane, the Track/Bus Inspector, the Clips pane, and the Bus pane. You can change the size of the panes by dragging the vertical or horizontal splitter bars that separate them.
All of the current track’s controls, plus a few that are only available in the Console view, are contained in the Track/Bus Inspector which is an expanded version of the current track’s controls located on the far left side of the Track view. You can hide or show the Track/Bus Inspector by pressing I on your keyboard (see “Track/Bus Inspector” on page 31, for more information).

The Track pane lets you see and change the initial settings for each track. By default, the current track is displayed in gold. To change the current track, move the highlight using the mouse or the keyboard as follows:

<table>
<thead>
<tr>
<th>What it does</th>
<th>Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Moves the highlight to the next or previous control.</td>
<td>LEFT/RIGHT ARROW</td>
</tr>
<tr>
<td>Moves to the same control in the adjacent track, or the next track of the same type if the control only applies to a specific track type (for example, the Patch control only applies to MIDI tracks).</td>
<td>UP/DOWN ARROW</td>
</tr>
<tr>
<td>Displays the next page of tracks.</td>
<td>PAGE DOWN</td>
</tr>
<tr>
<td>Displays the previous page of tracks.</td>
<td>PAGE UP</td>
</tr>
</tbody>
</table>

Table 6.
The current track’s controls are contained in the **Track/Bus Inspector**.
The **Clips** pane shows the clips in your project on a horizontal timeline called the Time Ruler that helps you visualize how your project is organized. Clips contain markings that indicate their contents. The **Clips** pane lets you select, move, cut and copy clips from place to place to change the arrangement of music and sound in your project.

The **Bus** pane shows the buses in the project, and also shows any editing views that are in tabbed (docked) format. The **Show/Hide Bus pane** button allows you to show or hide the Bus pane at the bottom of the Track view.

The **Navigator** pane displays a large part of your project so you can see an overview of your song. The **Navigator** pane displays all of your project’s tracks.

The Track view makes it easy to select tracks, clips, and ranges of time in a project. These are the most common selection methods:

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select tracks</td>
<td>Click on the track number, or drag over several track numbers</td>
</tr>
<tr>
<td>Select clips</td>
<td>Click on the clip, or drag a rectangle around several clips</td>
</tr>
<tr>
<td>Select time ranges</td>
<td>Drag in the Time Ruler, or click between two markers</td>
</tr>
<tr>
<td>Select partial clips</td>
<td>Hold down the ALT key while dragging over a clip</td>
</tr>
</tbody>
</table>

**Table 7.**

As with most other Windows programs, you can also use the SHIFT-click and CTRL-click combinations when selecting tracks and clips. Holding the SHIFT key while you click adds tracks or clips to the current selection. Holding the CTRL key while you click lets you toggle the selection status of tracks or clips.
**Track/Bus Inspector**

The Track/Bus Inspector makes it easy to adjust the current track’s (or bus’s) controls, because it’s a greatly expanded version of the current track’s controls that is located on the left side of the Track pane.

In addition to the controls that a track or bus displays in the Track view, the Track/Bus Inspector also contains a built-in 4-band EQ. See the online help topic “Using the Per-track EQ” for more information.

The following graphic shows most of the Track/Bus Inspector’s controls (there may not be room to display all of a track’s controls on the Track/Bus Inspector, depending on the resolution of your monitor):

**Figure 6. The Track/Bus Inspector**

Track/Bus Inspector for an audio track

Track/Bus Inspector for a MIDI track

Most controls can be shown or hidden.

A. Audio icon  B. Output routing  C. Track name  D. Display menu  E. Module menu  F. MIDI icon  G. Output routing  H. Track name  I. Display menu  J. Module menu
You can hide or show any of the Track/Bus Inspector's controls, and use it to display the controls from any track or bus. The following table shows you how.

<table>
<thead>
<tr>
<th>To do this</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hide or show the Track/Bus Inspector</td>
<td>Press I on your keyboard.</td>
</tr>
<tr>
<td>Display a certain track's or bus's controls in the Track/Bus Inspector</td>
<td>Click the track or bus to make it current, or choose the track or bus in the track/bus drop-down menu that’s at the bottom of the Track/Bus Inspector.</td>
</tr>
<tr>
<td>Hide or show any of the Track/Bus Inspector’s controls</td>
<td>Click the Display menu or Module menu, and choose Options. Note: you can not display a MIDI track's Time + or Key + controls in the Track/Bus Inspector.</td>
</tr>
<tr>
<td>Reassign MIDI controller sliders in a MIDI Track’s Fx bin</td>
<td>Right-click the slider you want to reassign and choose Reassign Control from the pop-up menu, choose the new parameter, and click OK.</td>
</tr>
<tr>
<td>Display the parameters of a different automatable effect</td>
<td>Click the name of the effect you want to select.</td>
</tr>
<tr>
<td>Assign a control to a group, arm it for automation, take an automation snapshot, or set up remote control</td>
<td>Right-click the control and choose options from the pop-up menu.</td>
</tr>
<tr>
<td>Bypass the FX bin</td>
<td>Right-click the FX bin and choose Bypass Bin from the pop-up menu.</td>
</tr>
</tbody>
</table>

Table 8.

**The Console View**

The Console view is where you can mix the sounds on all the different tracks to create the final mix of your project. While the Track view provides most of the same controls, you may want to use the more familiar interface of the Console view for mixing.

You use the Console view to adjust the levels of sound for the different tracks in your project, to change the stereo panning, and to apply real-time effects to an individual track, combinations of tracks, or the final mix.

The Console view contains several groups of controls. There is one module for each track in your project, and one module for each bus. You can use bus sends to direct certain tracks to special modules that are known as *buses*. 
As in the Track view, you can change track settings or record new music or sound in the Console view. You may choose to use one view or the other, or the choice you make may depend on which project you are working on.

**Other views**

SONAR has a number of other views you can use to display and work on your project. To display these views, select one or more tracks, by CTRL-clicking their track numbers and:

- Click the icon for the view in the **Views** toolbar
- Or
- Choose the view you want from the **View** menu

The **Piano Roll view** shows the notes from a MIDI track or tracks as they would appear on a player-piano roll. You can move the notes around, make them longer or shorter, and change their pitches by just dragging them with the mouse. You can also use the Piano Roll view to display and edit MIDI velocity, controllers, and other types of information. The Piano Roll view also contains the Drum Editor, which allows you to “paint” drum patterns using the **Pattern Brush** tool and play different drum modules from a single track.
The Staff view displays the notes from one or more MIDI tracks using standard music notation, similar to the way the notation would appear on a printed page. You can add, edit, or delete notes; create percussion parts; add guitar chords and other notation markings; display guitar tablature; display the Fretboard pane; and print whole scores or individual parts to share with other musicians.

Figure 9. The Staff view

A. Dynamics and markings  B. Time and pitch locator  C. Editing tools  D. Zoom out  E. Zoom in  F. Snap to Grid  
G. Show/hide track pane  H. Fretboard display  I. Track list pane  J. Fretboard pane
The Loop Construction view allows you to create and edit Groove clips (SONAR loops that “know” the tempo and key in which they were recorded), and export these clips as ACIDized files.

**Figure 10. The Loop Construction view**

The Media Browser view allows you to preview ACIDized files and other Wave files; and drag and drop them into your project.

**Figure 11. The Media Browser view**

The Event List view displays the events in a project individually, so that you can make changes at a very detailed level.

**Figure 12. The Event List view**

SONAR has several other views that are used for very specific purposes:
<table>
<thead>
<tr>
<th>View</th>
<th>How you use it</th>
</tr>
</thead>
<tbody>
<tr>
<td>Meter/Key</td>
<td>To change the meter (time signature) or key signature, or to insert changes in the meter or key signature at specific times in a project.</td>
</tr>
<tr>
<td>Big Time</td>
<td>To display the Now time in a large, resizable font that you can read more easily.</td>
</tr>
<tr>
<td>Markers</td>
<td>To add, move, rename, or delete labels for parts of your project that make it easier to move from one point to another.</td>
</tr>
<tr>
<td>Lyrics</td>
<td>To add and display lyrics for a track.</td>
</tr>
<tr>
<td>Video</td>
<td>To display a loaded video file.</td>
</tr>
<tr>
<td>Synth Rack</td>
<td>Manage your soft synths</td>
</tr>
<tr>
<td>Navigator</td>
<td>Manage the Now Time in a project</td>
</tr>
<tr>
<td>Surround Panner (Producer version only)</td>
<td>Pan a surround track</td>
</tr>
<tr>
<td>Sysx</td>
<td>To create, display, store, and edit System Exclusive MIDI messages used to control instruments and other gear that are MIDI capable.</td>
</tr>
<tr>
<td>Tempo</td>
<td>To view and edit the project's tempo changes.</td>
</tr>
<tr>
<td>Step Sequencer</td>
<td>Lets you compose patterns by clicking cells in a grid to turn notes on or off. For details, see the “Step Sequencer View” online Help topic.</td>
</tr>
<tr>
<td>Matrix</td>
<td>Lets you trigger multiple audio and MIDI patterns, either with a mouse or via MIDI remote control. For details, see the “Matrix view” online Help topic.</td>
</tr>
</tbody>
</table>

Table 9.
Zoom controls

Many of the views contain Zoom tools that let you change the horizontal and vertical scale of the view.

Figure 13.  Zoom controls

A. Zoom Clips pane out vertically  B. Vertical Zoom fader for Clips pane  C. Zoom Clips pane in vertically  
D. Zoom Bus pane out vertically  E. Vertical Zoom fader for Bus pane  F. Zoom in horizontally  G. Horizontal zoom fader  H. Zoom out horizontally

The Track view toolbar contains the Zoom tool: 

The Zoom tools are used as described in the following table:

<table>
<thead>
<tr>
<th>Tool</th>
<th>How you use it</th>
</tr>
</thead>
<tbody>
<tr>
<td>Zoom out (Clips pane or Bus pane)</td>
<td>Click to zoom out incrementally, or press SHIFT and click to zoom all the way out</td>
</tr>
<tr>
<td>Zoom in (Clips pane or Bus pane)</td>
<td>Click to zoom in incrementally, or press SHIFT and click to zoom all the way in</td>
</tr>
<tr>
<td>Zoom fader</td>
<td>Click and drag to zoom continuously</td>
</tr>
<tr>
<td>Zoom tool</td>
<td>Click to arm, then click and drag in the view to select the zoom area. Click the drop-down arrow to display a menu of zoom and view options.</td>
</tr>
</tbody>
</table>

Table 10.
You can also zoom with the keyboard:

<table>
<thead>
<tr>
<th>Key</th>
<th>What it does</th>
</tr>
</thead>
<tbody>
<tr>
<td>CTRL+UP ARROW</td>
<td>Zoom out vertically</td>
</tr>
<tr>
<td>CTRL+DOWN ARROW</td>
<td>Zoom in vertically</td>
</tr>
<tr>
<td>CTRL+RIGHT ARROW</td>
<td>Zoom in horizontally</td>
</tr>
<tr>
<td>CTRL+LEFT ARROW</td>
<td>Zoom out horizontally</td>
</tr>
<tr>
<td>G</td>
<td>Go to (center) the Now time, without zooming</td>
</tr>
<tr>
<td>Hold down Z</td>
<td>Arm the Zoom tool</td>
</tr>
<tr>
<td>U</td>
<td>Undo the current zoom</td>
</tr>
<tr>
<td>F</td>
<td>Fit tracks to window</td>
</tr>
<tr>
<td>A</td>
<td>Show all tracks</td>
</tr>
<tr>
<td>SHIFT+F</td>
<td>Fit project to window</td>
</tr>
<tr>
<td>SHIFT+double-click a clip</td>
<td>Maximize track height</td>
</tr>
</tbody>
</table>

Table 11.

Docking views

You can dock any view other than the Console view in the lower-right corner of the Track view by enabling a view’s **Enable Tabbed** option. You can have as many views open in tabbed format as you want. You can toggle through the different views by clicking the tab of the view you want to see (or use the CTRL+SHIFT+LEFT/RIGHT ARROW shortcut). You can also maximize the pane to do detailed work in a view, or drag the splitter bar at the top of the view to enlarge the tabbed view area. For step-by-step instructions, see the procedures below.

![Docking views diagram]

A. Maximize pane  B. Scroll left or right to view tabs  C. Active view  D. Tabs
SONAR basics

Locking views

By default SONAR allows only one instance of each view, but you can lock the contents of most views, preserving the current view by forcing a new instance of the view to appear if necessary. Locking views is the only way you can have multiple instances of the same view open. Only the Track and Console views cannot be locked.

To lock a view, just click the Lock button at the top right of the view. An unlocked view looks like this, and a locked view looks like this. A view can be locked automatically by pressing the CTRL key when opening the view.

Table 12.

<table>
<thead>
<tr>
<th>To do this</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display a view in tabbed format</td>
<td>Click the upper left corner of a view, and choose Enable Tabbed from the pop-up menu</td>
</tr>
<tr>
<td>Disable tabbed format for a view</td>
<td>Right-click the view’s tab, and choose Disable Tabbed from the pop-up menu</td>
</tr>
<tr>
<td>Enable or disable tabbed format for all open views</td>
<td>Use the View &gt; Enable Tabbing for Open Views command.</td>
</tr>
<tr>
<td>Maximize a tabbed view</td>
<td>Click the Maximize/Restore button that’s just to the left of the tabs.</td>
</tr>
<tr>
<td>Restore tabbed view</td>
<td>Click the Restore button that’s in the lower left corner of the view that you’re restoring.</td>
</tr>
<tr>
<td>Close a view that is in tabbed format</td>
<td>Right-click the view’s tab, and choose Close from the pop-up menu</td>
</tr>
</tbody>
</table>

Floating views

When a view is float enabled, you can move it outside of the confines of SONAR. This is particularly useful if you take advantage of SONAR’s dual monitor support. Using dual monitor support, you can keep the Track or Console view on one monitor and “float” other views to the other monitor by dragging them to the second screen.

For more information, see the online help topic “Floating Views and Dual Monitor Support.”

X-Ray windows

The X-Ray Windows feature eliminates the need to constantly minimize, move, or close windows in order to work in other windows. It works by decreasing the opacity of the current window enough so that you can see and work with the window that’s behind the current window. You activate the feature by pressing a keyboard shortcut (default shortcut is SHIFT+X) when the mouse cursor is over a window you want to x-ray. You can choose to X-Ray whichever window is underneath the mouse cursor, or automatically X-Ray all FX/synth property pages in one step (Note: the mouse cursor does not need to be over any plug-in property pages).
The X-Ray Windows feature works on the following windows:

- AudioSnap palette
- Synth Rack
- Piano Roll view (when float-enabled)
- Snap To Grid dialog
- Plug-in effects and synths
- Controller/Surface plug-ins

To select key bindings for X-Ray windows

1. Use the Options > Key Bindings command to open the Key Bindings dialog.
2. If you want to use currently unassigned keys or key combinations, scroll through the options in the Key window until the Global Key Assignment field that is just under the window reads Unassigned. It's a good idea to find two unassigned options that are next to each other or easy to remember.

   Note: For best results with X-Ray Windows, avoid using ALT key combinations.

3. Once you've decided on two keys or key combinations that you want to use, select Global Bindings in the Bind Context field, and scroll to the bottom of the list of commands that are in the window below that field.
4. In the Key window, highlight the key or key combination that you want to use for the X-Ray command, then highlight X-Ray in the function column of the list of commands, then click the Bind button to bind them together.
5. Now highlight the key or key combination that you want to use for the X-Ray All FX/Synths command, then highlight X-Ray All FX/Synths in the function column of the list of commands, then click the Bind button to bind them together.
6. Click OK to close the dialog.

To use X-Ray windows

1. Use the Options > Global command to open the Global Options dialog, and on the General tab, make sure that the Enable X-Ray check box is enabled.
2. Make sure that the view windows you want to X-Ray are in the Floating-enabled state: to check this, click the view or fx icon that's in the upper left corner of a window, and select Enable Floating from the drop-down menu. If Disable Floating is in the menu, then the Floating option is already enabled.

   Note: All FX/Synth/Control surface property pages are float-enabled by default.
3. To X-Ray or un-X-Ray a single window, move the mouse cursor over the window, and press the keyboard shortcut (default is SHIFT+X) for the X-Ray command. The window does not need to have focus (does not need to be the highlighted window).

4. To X-Ray or un-X-Ray all plug-in windows at once, press the key binding for the X-Ray All FX/Synths command.

**Note:** If a window has focus, and the window’s **Give All Keystrokes To Plug-in button** is enabled, X-Ray keyboard commands won’t work.

**To Adjust X-Ray Windows Options**

1. Use the Options > Global command to open the Global Options dialog.

2. On the General tab, you can adjust these options:
   - **Enable X-Ray.** Enable or disable this check box to turn the X-Ray Windows feature on or off.
   - **Opacity.** Adjust this value by typing in a value, or by clicking and holding the + or - button to adjust the final opacity percentage value that an X-Rayed window reaches.
   - **Fade Out Time.** Adjust this value by typing in a value, or by clicking and holding the + or - button to adjust the amount of time that an X-Rayed window takes to reach its final opacity percentage value.
   - **Fade In Time.** Adjust this value by clicking and holding the + or - button to adjust the amount of time that an X-Rayed window takes to restore its original opacity.

3. Click OK to close the dialog and accept your changes.

**To exclude a plug-in from X-Ray capability**

Some plug-ins (very few) use DirectDraw to create their windows. These windows appear jittery when x-rayed.

To exclude a plug-in from X-Ray capability, follow these steps:

1. Open the Cakewalk Plug-in Manager: use the Tools > Cakewalk Plug-in Manager command.

2. In the Plug-in Categories window, select the category that the plug-in you want to exclude is in.

3. In the Registered Plug-ins window, select the plug-in that you want to exclude.

4. If the plug-in is a DirectX effect or an MFX, write down (or select and copy) the CLSID value that’s in the CLSID field at the bottom of the dialog.

5. If the plug-in is a VST or VSTi, write down the VST ID value that’s in the VST ID field at the bottom of the dialog.

6. Close the Plug-in Manager dialog.

7. Open the Xrayexclude.ini file that’s in your SONAR program folder (use Notepad).
8. At the end of the file, find the [EffectProps View] section.

You will see entries such as the following:

; Waves SSL EQ Stereo
XRayExclude11=1397510483
XRayExclude12={E451379E-F7E1-4E82-98D9-BEB87AC45E90}

9. Exclude your plug-in by creating a blank line below the last entry in the [EffectProps View] section, and then typing:

; [name of your plug-in, but without brackets]
XRayExclude[the next available number in XRayExclude list, but without brackets]=[VST ID number, with no brackets, or CLSID number, with curly braces at start and finish]

For example, if the last entry in the [EffectProps View] section was:

; Waves SSL EQ Stereo
XRayExclude11=1397510483
XRayExclude12={E451379E-F7E1-4E82-98D9-BEB87AC45E90}

And you wanted to exclude the Cakewalk FxDelay from the X-Ray Windows feature, after creating a blank line you would type:

; Cakewalk FxDelay
XRayExclude13={985DAF67-589F-4B8D-8BBC-D7AD651B9022}

If there was also a VST version of the Cakewalk FxDelay, you would add another line:

XRayExclude14=[some VST ID number, with no brackets]

10. Save and close the Xrayexclude.ini file, and restart SONAR to implement your changes.

Customizable menus

All main menus and context menus are customizable. You can fine-tune your workflow by hiding menu items that are rarely used and reordering commands that you use frequently. You can even design and save menu layouts specific to different tasks.

**Caution:** You can move commands completely out of their default menus. For example, you can move commands out of the Edit menu into the Process menu. Keep in mind that this manual describes commands by their original menu locations, so if you’re looking for help about the Process > Nudge command, and you’ve moved the Nudge command to the Edit menu, the documentation for this command will still refer to the command as Process > Nudge. You can always load the default menu layout to restore the original command structure.

- To open the Menu Editor dialog, choose Options > Menu Editor.
- In the Menu Editor dialog, to choose a menu to edit, select one from the Menu drop-down list.
<table>
<thead>
<tr>
<th>To do this</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hide items in a menu</td>
<td>Click a menu Item (CTRL-click to select multiple items) and press the <strong>Hide</strong> button. The hidden command(s) will only be visible in the submenu that is automatically created at the bottom of the menu. You can display the submenu by clicking one of the arrows at the bottom of the menu.</td>
</tr>
<tr>
<td>Show items in a menu</td>
<td>Click a menu Item (CTRL-click to select multiple items) and press the <strong>Show</strong> button. The command(s) will reappear in its original location.</td>
</tr>
<tr>
<td>Reorder items in a menu</td>
<td>Click and drag menu Items up or down to change their position in the menu order. <strong>Note:</strong> You can also click and drag Menu Items in and out of submenus.</td>
</tr>
<tr>
<td>Create a new submenu</td>
<td>Right-click an item in the Menu Items list and select <strong>Create Submenu</strong>. That item will now appear in its own new submenu. Or Select one or more items from the list and press the <strong>Create New</strong> button in the <strong>Submenus</strong> section of the dialog.</td>
</tr>
<tr>
<td>Rename a menu item or submenu</td>
<td>Right-click a menu Item or submenu and select <strong>Rename</strong>, then enter a new name. Or Select a menu Item and press F2, then enter a new name.</td>
</tr>
<tr>
<td>Create a new separator bar</td>
<td>Right-click a menu item and select <strong>Insert Separator</strong>. The separator bar will appear above the menu item you right-clicked.</td>
</tr>
<tr>
<td>Remove a submenu or separator bar</td>
<td>Right-click the submenu or separator and select <strong>Remove Submenu</strong> or <strong>Remove Separator</strong>.</td>
</tr>
<tr>
<td>Save a new menu layout</td>
<td>Enter a new name into the <strong>Menu Layout</strong> field and press the <strong>Save</strong> button.</td>
</tr>
<tr>
<td>Delete an existing menu layout</td>
<td>Select the menu layout you wish to delete and press the <strong>Delete</strong> button</td>
</tr>
<tr>
<td>Edit a menu layout</td>
<td>Launch the Menu Editor and choose the menu layout you wish to edit from the drop-down menu, then make your changes.</td>
</tr>
<tr>
<td>Load a different menu layout</td>
<td>Launch the Menu Editor and choose a different <strong>Menu Layout</strong> from the drop-down menu, then close the dialog. OR Use the <strong>Options &gt; Menu Layouts</strong> command, and select a layout from the available options.</td>
</tr>
</tbody>
</table>

*Table 13.*
Altering your menus may affect your menus’ hotkeys, which allow you to navigate through the application’s menus without using a mouse. You can view the hotkeys in your menus by pressing ALT and observing the underlined letters. Pressing the underlined letter on your keyboard will launch that menu command. In order to ensure you have no duplicates hotkeys in your customized menu, do the following.

1. Launch the Menu Editor and select the menu or submenu you wish to check for duplicate hotkeys. Right-click the menu item and select **Check Hotkeys**. The Menu Editor will then report back if duplicate hotkeys are found, or if a command has no hotkey at all.

   **Note:** The **Check Hotkeys** command examines only commands on the menu that you right-clicked, at the menu level that you right-clicked. It does not examine submenus of that menu.

2. If missing or duplicate hotkeys are found, right-click again and select **Generate Hotkeys**. New non-duplicate hotkeys will be assigned for each item in that menu or submenu (but only on the menu level where you right-clicked, not on any submenus of the menu or submenu that you right-clicked).

   **Note:** Hotkeys are indicated within the Menu Editor by ampersands (“&”) in each menu item’s name. The ampersand is placed directly before the letter that represents the menu item’s hotkey. If you wish to assign hotkeys manually, you can do so by when you rename a hotkey by placing the ampersand before your preferred hotkey letter for that command or submenu.

3. If necessary, re-save your layout to preserve these changes.

**Customizable toolbars**

You can customize each toolbar in SONAR. You can hide or reorder each component of a toolbar, or add buttons to a toolbar from other toolbars. You can create up to three new toolbars from components of other toolbars. You can also hide or show all toolbars with a single command, and dock toolbars vertically if you want.

- To choose what toolbars you want to see, use the **View > Toolbars** command, and check the toolbars that you want to see in the dialog box.

- To hide or show all toolbars, use the **View > Show Toolbars** command. This command is available in the **Key Bindings** dialog (**Options > Key Bindings** command).
To customize a toolbar:
1. Right-click the toolbar that you want to customize, and choose Customize from the pop-up menu to open the Customize Toolbar dialog.
2. In the Available Toolbar Buttons field, select a component that you want to see in the toolbar, and click the Add button to move the component to the Current Toolbar Buttons field.
3. Repeat step 2 for any additional components you would like to display.
4. In the Current Toolbar Buttons field, select a component that you do not want to see in the toolbar, and click the Remove button to move the component to the Available Toolbar Buttons field.
5. Repeat step 4 for any additional components you would like to remove.
6. If you would like to move a toolbar component to a different location in the toolbar, select the component in the Current Toolbar Buttons field, and click the Move Up button or the Move Down button to change the button’s location in the toolbar.
7. Repeat step 7 for any additional components.
8. If you want to restore the toolbar to its default appearance, click the Reset button.
9. Click Close when you want to close the dialog.

To create a toolbar:
1. Use the View > Toolbars command, and check one of the User “n” options.
   A toolbar appears, with a default set of controls.
2. Right-click the toolbar, and choose Customize from the pop-up menu to open the Customize Toolbar dialog.
3. Customize the toolbar the in the same way as the previous procedure.

To rename a toolbar:
1. Right-click the toolbar, and choose Rename from the pop-up menu to open the Rename Toolbar dialog.
2. Fill in the New Name field, and click OK.

Now when you open the Toolbars dialog, the name you chose is listed in the dialog.

To dock or undock a toolbar:
• To dock a toolbar horizontally, drag it to the top or bottom of the interface.
• To dock a toolbar vertically, drag it to the left or right side of the interface.
• To undock a toolbar, drag it to the part of the interface where you want it, or entirely away from the interface.

Layouts
You may spend a lot of time making sure that all the views are laid out on the screen just the way you want. When you save your work, you can save the screen layout along with it. You can also save the layout by itself and then use the layout with other projects. For more information, see the online help topic “Layouts.”
Working on a project

Much of your time in SONAR is spent recording and listening to your project as it develops. The Transport toolbar, shown below, contains the most important tools and other pieces of information you’ll need to record and play back your project.

Every project has a current time, known as the Now time. As you record or play back a project, the Now time shows your current location in the project. When you create a project, the Now time is set to the beginning of the project. The current Now time is saved with your project.

You control recording and playback using tools on the Large Transport toolbar (press F4 to show or hide), which work a lot like the ones on your tape deck or CD player:

Figure 14. The Large Transport toolbar

As you work with a project, you can use SONAR’s mute and solo features to choose which tracks are played, or you can create loops to play a particular section over and over again. You can also create markers, which are named time points you add to your project to make it easy to jump to a particular location.

Windows taskbar indicators

When SONAR is running, you’ll normally see two indicators in your Windows taskbar, right next to the clock.

The MIDI activity monitor contains two lights that indicate MIDI input and output. When you play your MIDI keyboard, the first light flashes when each note is pressed, and it flashes again when each note is released. When you play back a project that contains MIDI, the second indicator lights up.

The volume control is used to control the playback and record volumes on your sound card. Double-click on this indicator to open a dialog box that lets you control the levels for audio, MIDI, CD playback, and record.

The volume control is available only if your sound card is using a native Windows driver. If your sound card does not use a native Windows driver, no volume control will be displayed in the taskbar.
In this case, your sound card probably came with a separate program to control input and output levels. See your sound card documentation for more information.

**Screen colors and wallpaper**

SONAR lets you customize the colors that are used for virtually all parts of the program using the **Options > Colors** command. This command also lets you change the background bitmap that is displayed in the SONAR window.

For any SONAR screen element, you can assign a color in two ways:

- Choose one of the colors that is part of your Windows color scheme.
- Assign a custom color.

**To Assign Custom Colors**

1. Choose **Options > Colors** to display the **Configure Colors** dialog box.
2. Choose the screen element whose color you want to change from the **Screen Element** list.
3. Assign a color to the screen element in one of two ways:
   - To use a color from the Windows color scheme, choose one of the options in the **Follow System Color** list
   - To use a custom color, check **Use Specific Color**, click the **Choose Color** button, and select the color you want
4. To save these changes from session to session, check the **Save Changes for Next Session** box.
5. Click **OK** when you are done.

SONAR uses the colors you have chosen.

**To restore the default colors**

1. Choose **Options > Colors** to display the **Configure Colors** dialog box.
2. In the **Screen Elements** window, select the elements that you want to restore; you can CTRL-click or SHIFT-click to select multiple elements.
3. Click the **Defaults** button.
4. Click **OK**.

SONAR uses the default colors for all selected screen elements.
To change the wallpaper

1. Choose Options > Colors to display the Configure Colors dialog box.
2. Choose the desired wallpaper according to the table:

<table>
<thead>
<tr>
<th>To do this</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use the default wallpaper</td>
<td>Check Default in the Wallpaper list</td>
</tr>
<tr>
<td>Not use any wallpaper</td>
<td>Check None in the Wallpaper list</td>
</tr>
<tr>
<td>Use a custom bitmap</td>
<td>Check Custom, choose a bitmap, and click Open</td>
</tr>
</tbody>
</table>

Table 14.

3. Click OK when you are done.

Color presets

Once you create a color arrangement that you like, you can save it as a preset, and then load it whenever you want to use that arrangement. You can also load any of the many factory presets, some of which duplicate the colors of earlier versions of SONAR. You can also import and export color arrangements in the form of .clr files so that SONAR users can share color layouts. And you can back up or export all of your presets with a single command, and import a group of presets that you or another SONAR user created.

**Note:** Both single color presets, and collections of presets use the file extension .clr, so when you export either the current color arrangement, or all of your presets at once, give the exported file a name that clearly labels it as either a single preset, or as a collection of presets.
Figure 15. The *Configure Colors* dialog

A. Presets menu  B. Import and Export buttons

**To load a color preset**

1. Open the *Configure Colors* dialog by using the *Options > Colors* command.
2. Click the drop-down arrow on the *Presets* menu to display the list of presets, then click the name of the preset you want to load.

**To save a color preset**

1. Open the *Configure Colors* dialog by using the *Options > Colors* command.
2. Adjust the color settings you want to save.
3. Type a name for your preset in the *Presets* menu.
4. Click the floppy disk icon that's next to the *Presets* menu to save your preset.
To export the current color arrangement

1. Open the Configure Colors dialog by using the Options > Colors command.
2. Arrange or load the color arrangement you want to export.
3. Click the Export Colors button in the Configure Colors dialog.
   The Export Color Set dialog appears.
4. Navigate to the folder where you want to store your new color set file.
5. Type a name for your color set file in the File Name field.
6. Make sure that the Export Current Color Set check box is enabled.
7. Click the Save button.

To import one or more color presets

1. Open the Configure Colors dialog by using the Options > Colors command.
2. Click the Import Colors button in the Configure Colors dialog.
   The Import Color Set dialog appears.
3. Navigate to the folder where the color set file you want to import is. Both single presets and groups of presets are stored in color set files, which use the .clr file extension.
4. Click the file that you want to import.
5. Click the Open button.
6. If your Preset menu in SONAR already contains a preset that is included in the preset collection file you are importing, SONAR asks you if you want to overwrite the file. This happens for each file that has the same name as a preset in the preset collection you are importing. Click Yes or No for each file in question, or Yes All or No All to either overwrite or protect all of your current preset files.

To export all your color presets

1. Open the Configure Colors dialog by using the Options > Colors command.
2. Click the Export Colors button in the Configure Colors dialog.
   The Export Color Set dialog appears.
3. Navigate to the folder where you want to store your the exported file. This file will contain all or your color presets.
4. Type a name for your file in the File Name field. Use a file name that you will recognize as a collection of presets, rather than as a single color arrangement.
5. Make sure that the Export Color Presets check box is enabled.
6. Click the Save button.

Note: A file of color presets can be large, and might take a minute or so to export.
Installing SONAR

SONAR is easy to install. All you need to do is choose the folder where the program and sample project files should be stored. Before you start, make sure you have your serial number handy. Your serial number is located on the back of your DVD case.

**Note:** If you choose to not install the Sample files, you will not have the necessary content to use the tutorials in Chapter 2.

To install SONAR

1. Start your computer.
2. Close any open programs you have running.
3. Place the SONAR installation disc in your disc drive.
   
   If you have autorun enabled, the SONAR AutoRun menu opens automatically, showing you a dialog box with several buttons. If autorun is not enabled, you can open the SONAR AutoRun menu by selecting Start > Run and entering `d:\AutoRun.exe` (where d:\ is your disc drive).
4. Click the Install SONAR button.

   **Note:** If you exit Setup without completing the installation, choose Start > Run, type `D:\AutoRun.exe` (where D:\ is your DVD drive), and click OK. This will reopen the AutoRun window, and you can click Install to start installation again.

5. Follow the installation instructions on the screen.

   You can also install SONAR by choosing Start > Run and running the application named SETUP.EXE from the DVD.

Uninstalling SONAR

When you installed SONAR, the setup program placed an Uninstall icon in the Start menu. To uninstall SONAR, click the Start button and choose Programs > Cakewalk > SONAR 8.5 (Studio or Producer) > Uninstall SONAR 8.5 (Studio or Producer).
Starting to use SONAR

This chapter has provided you with an overview of SONAR and basic information on how to install the software and configure your system.

The following tutorials will give you some hands-on practice in playing, recording, and mixing your projects. If you have not already done so, you may want to refer to “SONAR basics” on page 26 to get the most out of these tutorials.

Note: If, during installation, you chose in the Select Components dialog not to install the Tutorials folder (part of the Sample files), you will not have access to the sample tutorial files needed to follow the tutorials in this chapter. If you didn’t install these files, insert your product disc and copy the files to your hard drive.

Tutorial 1 – Creating, playing, and saving projects .................. 53
Tutorial 2 – Using the Media Browser .................................. 65
Tutorial 3 – Recording vocals and musical instruments .......... 71
Tutorial 4 – Playing and recording software instruments ........ 77
Tutorial 5 – Working with music notation .............................. 85
Tutorial 6 – Editing your music ........................................... 93
Tutorial 7 – Mixing and adding effects .................................. 99
Tutorial 8 – Working with video .......................................... 107
Tutorial 9 – Exporting, CD burning and sharing .................... 115
Tutorial 1 – Creating, playing, and saving projects

Understanding and managing project files is central to your work flow in SONAR. In this tutorial, we are going to cover the basics of getting started with project files and some of the operations that can be performed with them. Whenever you write or record music in SONAR, you are writing it to be saved into a project. A project can contain a variety of elements, including:

- Audio tracks
- MIDI tracks
- Instrument tracks
- DirectX and VST audio effects
- Project settings such as Tempo, Key and Meter changes
- Lyrics
Creating a new project

There are several ways to get started with a project in SONAR. When SONAR is opened, you will be greeted with the Quick Start dialog. Let’s take a look at the options available in this dialog.

Open a Project. Opens a standard File Open dialog, which lets you select the project that you want to open.

Open a Recent Project. The drop-down list shows the most recent projects that have been opened in SONAR. Select the desired project from the list and click the button to the left of the list to open the project.

Create a New Project. Click this button to open the New Project File dialog, which lets you create a new project based on any available template.

Online Videos and more. Click this link to view our tutorial videos online. An active Internet connection is needed in order to access this content.

Getting Started. Click this button to open the SONAR online Help.

Show this at Startup. Clear this check box if you don’t want the Quick Start dialog to launch the next time you start SONAR.

Close. Use this button to close the Quick Start dialog.

For this tutorial, we want to create a new project.

• Click the Create a New Project button .

Tip: You can also perform this same operation by clicking File > New from the main menu across the top of SONAR’s screen.
The **New Project File** dialog appears. Whenever you create a new project, you will be presented with this dialog.

Let’s explore some of the things you can do in this window.

**Name.** Type the name of your project in the **Name** box. For this exercise, let's name your project **Tutorial 1**.

**Location.** Use the **Location** box to specify where the project should be saved. Click to browse to a specific location. For this tutorial, use the default, as shown in the preceding figure.

**Audio Path.** Use the **Audio Path** box to specify where to save audio recordings for your project. Click to browse to a specific location.

**Store Project Audio in its own Folder.** Select this check box if you want to store the project's audio files in a separate folder. It is recommended that you select this option.

**Template.** This list shows all available pre-made templates that are included with SONAR. This list will also include any custom templates that you create. Your **Template** list may vary from the preceding figure. For this tutorial, select the template named **Normal**.

**OK.** Click **OK** to create a new project based on the specified settings.

**Cancel.** Click **Cancel** to close the **New Project File** dialog.

**Help.** Click **Help** to open the online Help topic for the **New Project File** dialog.

Click **OK** now to move forward with this tutorial.

Congratulations, you have just created a new project in SONAR!
Next we are going to talk about opening existing project files. There are two ways this can be done in SONAR:

- Click the Open a Project button in the Quick Start dialog that is first presented when SONAR starts.
- Select File > Open from the menu bar across the top of SONAR’s screen.

Let’s go ahead and try one of the above methods. Either of them will bring you to the Open dialog as shown in the following figure. The Open dialog functions like any other file browsing dialog in Microsoft Windows.

- The vertical navigation buttons let you jump to popular locations on your computer’s hard disk.
- The browsing pane lists all the project files and folders that are available in the selected folder.
- The Go to Folder dropdown list allows you to quickly move to commonly used folders for project files in SONAR. Typically, you can get to your projects by selecting Project Files.
- For more detailed information about all of the options and functions in this dialog, click Help.

For this tutorial we want to open one of the sample project files that are included with SONAR. To do so, select Template Files in the Go to Folder list. This option appears when clicking on the little arrow to the right of the dropdown list.
This will refresh the browsing pane to display all the files and folders in the Template Files directory. Double-click on the Tutorials folder to open it and then Locate the project named SONAR_AudioDemo1.cwp.

You can load project files into SONAR in one of two ways:

- Select a file by clicking on it so that it is selected, then click Open.
- Double-click the file from the browsing pane.

Let's now use one of these methods to open the project file SONAR_AudioDemo1.cwp. When the project opens, the File Information window appears. This window can be used for storing notes, comments, credits and other helpful information about a project. For now, close File Information window by clicking the Close button in the upper right corner of the window.
Playing project files

For this next section we are going to configure the project named SONAR_AudioDemo1.cwp for playback in SONAR. If you have not opened the project yet using the steps from the previous section Opening project files, do so before continuing.

Configuring your sound device

Before we can get any sound, we need to ensure that SONAR is communicating with your computer’s sound card or audio interface. To do so, click on the Options menu across the top of SONAR’s screen and choose Audio. For this tutorial, there are two pages of this window we are concerned with. The first is the Drivers tab shown in the following image. To get to this page, click the Drivers tab. Before you can hear any sound play in SONAR, you have to ensure that the devices you want to use are selected. An Edirol audio interface is used in the following example, so all the Input Drivers and Output Drivers check boxes for the Edirol device are selected. Your device list will most likely be different from the following image.

After you have selected the desired Input and Output devices that you plan to use with SONAR, click the General tab. In the Playback Timing Master list, select the audio output device that you want SONAR to treat as the default or main output device. This should be the output on your sound card that has either speakers or headphones connected to it. In the Record Timing Master list, select the input on your sound card that you plan to plug devices into, such as a microphone, keyboard or other instrument.
If you are having trouble with any of the steps in the last section thus far, we have created a helpful set-up guide on our web site that provides step-by-step instructions for configuring your audio hardware. You can find it here: www.cakewalk.com/Support/hardwaresetup.

Setting the tracks outputs

The next important step is telling SONAR which output on your sound device you would like audio tracks to play on. In some cases, it is desirable to have tracks playing different outputs (such as if you are using external hardware processing for effects). In this scenario, you’ll want to set all of the audio tracks to the same output.

Let’s start with the Bass track. Locate the track named Upright Bass in the project. Let’s take a closer look at a few of the track’s controls. If the track controls are not all visible, you may need to expand the track to see them all.

To expand a track to make all of its controls visible

1. Point the cursor to the bottom edge of the track.
2. Click and drag down to reveal all track controls.

Tip: If you find the number of track controls overwhelming, you can show/hide specific types of track controls by using the tabs located at the bottom of the Track view.

<table>
<thead>
<tr>
<th>Control</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>M</td>
<td>This is the Mute button. It is used to silence a track during playback. Any tracks that are muted will not be heard.</td>
</tr>
<tr>
<td>S</td>
<td>This is the Solo button. It is used to silence every track except the one that is soloed. This can be handy for isolating a particular performance or recording for monitoring or mixing purposes. SONAR allows you to solo multiple tracks simultaneously.</td>
</tr>
<tr>
<td>Control</td>
<td>Description</td>
</tr>
<tr>
<td>---------</td>
<td>-------------</td>
</tr>
<tr>
<td><img src="image" alt="Arm" /></td>
<td>This is the <strong>Arm</strong> or <strong>Record Enable</strong> button, which must be enabled on any track that you want to record onto. For more details, see <em>Tutorial 3 – Recording vocals and musical instruments.</em></td>
</tr>
<tr>
<td><img src="image" alt="Input Echo" /></td>
<td>This is the <strong>Input Echo</strong> or <strong>Input Monitor</strong> button. When clicked, this enables the track’s input to be heard directly through its output. For more details, see <em>Tutorial 3 – Recording vocals and musical instruments.</em></td>
</tr>
<tr>
<td><img src="image" alt="Write Automation" /></td>
<td>This is the <strong>Write Automation</strong> button. When enabled, changes to adjustable track parameters during playback are recorded. For more details, see <em>Tutorial 7 – Mixing and adding effects.</em></td>
</tr>
<tr>
<td><img src="image" alt="Freeze" /></td>
<td>This is the <strong>Freeze</strong> button. It is used to temporarily convert a synth or instrument track into an audio track to conserve CPU power.</td>
</tr>
</tbody>
</table>

Locate the dropdown list for **Output** and click the small arrow to show all available outputs. Select the output that your speakers or headphones are connected to. If you can’t find the **Output** dropdown list, make sure you have expanded the track fully by dragging it down.

![Dropdown list](image)

**Note:** Your options will be different from the preceding image. Select the output that corresponds to your sound card or audio device.

Next, you will want to repeat the above process for all of the tracks in your project.

**Tip:** If you need to change multiple outputs simultaneously, you can also do it by clicking *Edit > Select > All* and then *Tracks > Property > Outputs*. This will bring up a dialog that will allow you to change the Audio and MIDI outputs of all selected tracks.
Playing the project

Now that all of the track’s outputs are set to the appropriate device, the next step is to play the project to make sure it can be heard and sounds right.

Locate the Transport tool bar at the top of SONAR’s screen. If you can’t find this toolbar, press F4 to show the Large Transport toolbar.

The transport contains many useful functions related to projects in SONAR. For now, simply click the Play button to hear the project.

Experiment with the Mute and Solo buttons on each track. If you solo multiple tracks you will hear all of the soloed tracks. If you mute any tracks, they will not be heard.

Tip: You can also use your keyboard’s SPACEBAR key to start and stop playback in SONAR.

Once you are done listening, click the Stop button.
Looping project files

SONAR features a really handy tool that allows you to repeat specified sections of a project file. You may want to do this for many reasons, such as to rehearse a part or phase or to listen closely to a specific section. Perhaps you might set up a loop just because it’s your favorite part of the song and you want to hear it over and over again. For all of the above, you will need to loop a section of the song.

You may have noticed this demo file is an example of swing or jazz music. Let’s pretend for a second that you are the guitar player and you wanted to practice your solo section right before the Violin soloist begins. This requires you do two things:

1. Create a looped section of the Bass and Rhythm Guitar for you to practice with.
2. Mute the existing Solo Guitar track.

To enable looping in SONAR is easy. Simply click the Loop button in the Loop/Auto Shuttle toolbar. You can also find this button in the Large Transport toolbar by pressing F4. When enabled, the Loop button is lit.

Take note of the measure numbers displayed in the preceding image. The first number (2:01:000) indicates the start of the loop region and second number (38:01:000) indicates the end of the loop region.

When looping is enabled, the time ruler across the top of SONAR’s track view displays yellow flag markers that indicate where the loop region starts and ends. If you want to change the loop region, you can drag the loop markers to a new location. Drag the loop start marker to measure 25 and the loop end marker to measure 37. This will create a 12 bar loop.

Finally, mute both the Solo Guitar and Violin tracks and click Play to audition the loop region. You will now hear only the Upright Bass and Rhythm Guitar tracks so that you, the guitarist in our scenario, can practice your solo section.
Saving project files

SONAR offers you many options for saving your work. To investigate these options, click on the File menu and choose Save As. This opens the Save As dialog. Before doing anything in this window, the first thing you should do is select Project Files in the Go to Folder list. Even if it already says Project Files, click it anyway.

You will notice this window looks very familiar to the Open dialog we looked at earlier in this tutorial. The Save As dialog navigates files much in the same way as Windows does. If you would like to read the finer points and in-depth information about using this window, click the Help button. For this exercise, we are going to look at the different types of project files you can save with SONAR.
Take a look at the dropdown list labeled **Save as type**. Click the **Save as type** arrow to see a list of supported file formats. Let's look at these different files formats now:

- **Normal.** This is the first option listed and the most common format used for saving project files. Choosing this will create a Cakewalk Project file with the .cwp file extension. It is important to remember that Cakewalk Project files *do not* actually store any audio data, but rather reference audio files from where they are saved on your computer’s hard drive.

- **Template.** Template files are used as a starting point for new projects. Templates can store layout information about your project, such as how many audio and MIDI tracks there are and which Output ports they are assigned to. Detailed information about using templates can be found in SONAR’s help topic *Templates*.

- **Cakewalk Bundle.** This format is typically only used when transferring projects to other people or other computers. Cakewalk Bundle files use the .cwb file extension and are similar to Cakewalk Project files. The main difference is that Cakewalk Bundle files actually contain all of a project’s audio data. Cakewalk Bundle files are much larger in size than regular Cakewalk Project files because they contain all of the audio data for a project, so try to avoid using this format unless you need to move a project between computers. When opening a Cakewalk Bundle file, SONAR will “unpack” the embedded audio data and save it to a new audio folder on your computer.

- **MIDI.** This option lets you save a standard MIDI file of your project. MIDI files do not contain any embedded audio or references to external audio files, so any audio data in a project will be discarded when you save a MIDI file. MIDI files can be either Format 0 or Format 1. Format 0 combines all the MIDI events into a single track. This is compatible with many older sequencers and keyboards. MIDI Format 1 files can store up to 7256 tracks and are a better choice if you plan on using your MIDI file with another computer-based sequencing application. Although not as common, SONAR also allows you to save in the RIFF MIDI format. Unless you are positive that the playback system requires a RIFF MIDI file, you will want to use the MIDI format.

In most cases, the best choice for saving your files is **Normal**. To save this project, do the following:

1. In the **Go to Folder** list, select **Project Files**. Even if **Project Files** is already selected, select it again for good practice.

2. In the **Save as type** list, select **Normal**.

3. Type a name in the **File Name** box.

4. Click **Save** to save the project.

This completes the tutorial.
Tutorial 2 – Using the Media Browser

New to SONAR is the enhanced *Media Browser* view; designed to improve workflow and make working with audio loops and MIDI groove clips simple. When you open a project in SONAR, the Media Browser will open underneath the track view. It is outlined in the image below.

To show or hide the Media Browser, click the the **Media Browser View** button located to the left of the Transport controls in the top of SONAR’s screen, or press ALT+1.

Now that we know how to show and hide the Media Browser view, let’s take a closer look at some of its features, starting with the toolbar that spans across the top of the Media Browser view. Locate the section on your computer screen that looks like the following image.
First, let's review the controls on the left side of the toolbar.

<table>
<thead>
<tr>
<th>Control</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Move up button" /></td>
<td>This is the <strong>Move up</strong> button. It is used to open the folder one level above the active folder.</td>
</tr>
<tr>
<td><img src="image" alt="Refresh button" /></td>
<td>The <strong>Refresh</strong> button is used to refresh the active folder. This is helpful if you move new loops into the folder and want SONAR to be able use/see them.</td>
</tr>
<tr>
<td><img src="image" alt="Windows Explorer button" /></td>
<td>This is the <strong>Windows Explorer</strong> button. Click to open Windows Explorer at the same directory being viewed in the Media Browser view.</td>
</tr>
<tr>
<td><img src="image" alt="Stop button" /></td>
<td><strong>Stop</strong> is used to stop playback of the selected loop.</td>
</tr>
<tr>
<td><img src="image" alt="Play button" /></td>
<td><strong>Play</strong> is used to listen to the currently selected loop.</td>
</tr>
<tr>
<td><img src="image" alt="Auto Preview button" /></td>
<td>When enabled, the <strong>Auto Preview</strong> button automatically previews loops and files when you click on them in the Media Browser view.</td>
</tr>
<tr>
<td><img src="image" alt="Views button" /></td>
<td>Clicking the <strong>Views</strong> button allows you to choose how files are displayed in the list view. For more details on this check out the online help topic “The Media Browser View”</td>
</tr>
</tbody>
</table>

The Content Location drop down box shown below allows you to quickly jump to popular locations on your hard drive.

![Content Location: SONAR 8.5 Producer](image)

The **Audio Preview Bus** drop down box shown below allows you to select the output device used to listen to loops and files from the Media Browser view.

![Audio Preview Bus: SoundMAX HD Audio](image)
The next three controls are used for software synths.

<table>
<thead>
<tr>
<th>Control</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Insert Soft Synth" /></td>
<td>The <strong>Insert Soft Synth</strong> button allows you to add an instrument track to your project so you can preview MIDI groove clips directly from the Media Browser.</td>
</tr>
<tr>
<td><img src="image" alt="Delete Soft Synth" /></td>
<td>This is the <strong>Delete Soft Synth</strong> button, which is used to remove the selected synth from the <strong>Preview Synth</strong> list from your project.</td>
</tr>
<tr>
<td><img src="image" alt="Properties" /></td>
<td>Click the <strong>Properties</strong> button to open up the property page for the selected synth.</td>
</tr>
</tbody>
</table>

Table 15.

Below the toolbar, the Media Browser is split into two or three panes. From left to right they are the **Preview Synth** list, the **Folders** pane and the **Explorer** pane.

**Note:** The folders list can be hidden using the **Views** button.
Finding and previewing audio loops

Now that we have a general idea of how the Media Browser is laid out, let's find some of the content that is included with SONAR and give it a listen.

1. Make sure the Media Browser view is open and visible. If it is not, click the Media Browser view button or press ALT+1.

2. Click on the Views button and make sure that the option for Folders is selected and that the bullet point is set to Details.

3. In the Folders list, locate the My Documents directory. Click the little triangle to the left of my documents to expose all of the folders inside of it.

4. Using the same process, navigate to the following directory:
   My Documents\Cakewalk\SONAR\Sample Content\PowerFX\DowntempoDub\. You can open folders by double-clicking on them.

   Tip: You can quickly jump to the Sample Content folder by selecting Sample Content from the Content Location drop-down list.

Your folders list should look something like the image below.

![Folders List](image)

Notice that when you click on the Funky folder all of the contents of that folder are displayed in the Explorer pane to the right.

5. Click on the file named DrumLoop1.wav.
6. Click the **Play** button in the Media Browser toolbar. The selected file is previewed.

If you don’t hear anything, revisit the settings of your **Audio Preview Bus**, as discussed above, and ensure that it is set to the audio device that your headphones or speakers are connected to.

If you need to preview a lot of loops quickly, enable the **Auto-Preview** function. When enabled, an audio loop will start playing as soon as you select it.

**Previewing MIDI groove clips**

In addition to audio loops, the Media Browser view also allows you to preview **MIDI groove clips**. Let’s try this now with one of the clips included with SONAR. Unlike audio loops, MIDI groove clips require a soft synth or instrument track to play through.

1. Click the **Insert Soft Synth** button, point to **Soft Synths** and select **Cakewalk TTS-1**.

The **Insert Soft Synth Options** dialog appears.

2. Clear all of the check boxes except for **Single Track Instrument**, **Recall Assignable Controls**, and **Ask This Every Time**.

3. Click **OK**.

Cakewalk TTS-1 is added to your project.

Now that we have a synth in our project that we can preview MIDI groove clips with, let’s find some and give them a listen.

1. Using the same process we did to find audio loops, use the **Folders** and **Explorer** panes to browse to **My Documents\Cakewalk\SONAR\Sample Content\Smart Loops**.

2. Locate the MIDI groove clip named **Bangin 10.mid**.

   Before we can preview a MIDI groove clip, we need to tell SONAR what instrument or synth we would like to preview it with.

3. In the **Preview Synth pane**, select **Cakewalk TTS-1**.
4. Now that SONAR knows what synth to play MIDI groove clips through, select the groove clip named **Bangin 10.mid** just as you did with the audio loop previously.

5. Click the **Play** button in the Media Browser toolbar.

Just like with audio loops, you can set MIDI groove clips to auto-preview by clicking the **Auto-PREVIEW** button.

In addition to using soft synths to preview MIDI groove clips, soft synths also have many other useful and powerful features. For more details and instructions on using them, see “Tutorial 4 – Playing and recording software instruments” on page 77.

**Adding loops to your project**

Once you have found an audio loop or MIDI groove clip that you would like to use in your project, the next important step is to add it to your project. Adding loops is easy with SONAR’s intuitive drag and drop interface.

To add a loop to your project, do the following:

1. Locate the loop you would like to use in the Browser pane of the Media Browser view.

2. Drag the loop to a track. If you are selecting an audio loop, you must drag it to an audio track. If you would like to use a MIDI groove clip, be sure you drag it to a MIDI track.

   You should also notice that, as you drag the file, your mouse pointer changes to an arrow with a plus sign.

3. When you drag a loop or groove clip into a project, it will only show one repetition. You can extend how long a loop is by pointing the mouse pointer to the clip’s right edge, then drag the clip edge to the desired duration. When you point the mouse pointer to the right clip edge, a blue vertical line appears and the mouse pointer looks like this.

This completes the tutorial. You should now be able to drag loops into your projects and loop them.
Tutorial 3 – Recording vocals and musical instruments

One of the most important aspects of creating music in SONAR is digital audio recording. This is the process of taking the sound from a microphone or an instrument and recording it to an audio track. Once this step is completed you can edit and mix the song to prepare it to share with the world. This tutorial will walk you through the steps involved and provide you with some insight on how to get the best possible audio recordings.

Adding an audio track

In Tutorial 1, you learned about opening project templates. Let's open a blank project for this tutorial:

1. On the File menu, click New.
2. Select the Blank (no tracks or buses) template and click OK.
   
   A new blank project is created.

With the blank project open, you can insert new tracks as you need them. For the task of recording digital audio you'll need a new audio track. Follow these steps to insert one:

1. Do one of the following:
   • Click Insert and then click Audio Track.
   • Right-click on the Tracks pane and select Insert Audio Track on the pop-up menu.
   
   A new audio track is added to your project.

2. In the new audio track, expand the track to expose all of its controls (for details, see “To expand a track to make all of its controls visible” on page 59).
   
   The track's controls are exposed.

3. Click the Input drop-down menu to select the track’s input.
   
   The available inputs for the track are displayed.
4. Select the physical jack that you're instrument is plugged in to. If you know, for instance, that your guitar is plugged into input 1, click the Input control and select the first option. Some audio interfaces refer to their stereo inputs as pairs, like 1/2, 3/4 or 5/6. Most often left channels are represented by odd numbers and right channels are represented by even numbers.

**Note:** Most microphones and guitars are mono, so you'll want to select either the left or right channel accordingly.

5. Click the Output drop-down menu to select the track's output.

   The available outputs for the track are displayed.

6. Select the output port that you want the audio track to play through during playback. This is how you ultimately route the audio to your speakers. You will usually choose 1 and 2, because these are most commonly the outputs that speakers or audio monitors are connected to.

7. Click the track's Record Enable button.

   **Note:** SONAR only allows recording to tracks that have been record enabled. This is necessary since SONAR allows for multi-track recording. This tells SONAR what track you want your new material recorded to. Otherwise, every track would be recorded to during every take.

8. Click the Input Echo button if you want to hear the input during recording. Many sound cards and audio interfaces have an option to do this automatically on the hardware level. If you can already hear the input signal, simply move on to the next section.

**Getting ready to record**

At this point, we need to check the input levels to make sure they are sufficient and not distorting. Perform as you would if you were recording and watch the meter on the track respond to the sounds you produce.

If the meter never even comes close to the maximum, increase the input level. If the meter even occasionally reaches the maximum, decrease the input level.

Input levels are usually adjusted via a knob next to the input jack on the sound card, but features like this may vary slightly between devices. So, if you have never recorded an instrument or microphone with your sound card, you may want to read about doing so in the device's manual.

**Figure 16.** The record meter shows the input level

![Input Levels Diagram](image1.png)  
**Input may be too low**

![Input Levels Diagram](image2.png)  
**Input is too loud**
Recording your performance

Now that everything is set up, let's record something!

1. On the Options menu, select Project and then click the Metronome tab.

2. Set the metronome for a 2 measure count-in.
   
   • Click Use Audio Metronome, select the Recording check box and set Record Count-in to 2 Measures. For details about each metronome option, click Help.

3. Make sure the track has been record enabled by clicking the track's Record Enable button. The Record Enable button on the track should be lit in red like this:  
   
   Again, if you don't arm a track, SONAR will not know where to put the audio and the transport Record button will be disabled.

4. On the Transport, click Record, or press R on your computer keyboard.

5. You'll hear two measures counted in by the metronome and then recording will begin. Start performing at the beginning of the third count.

6. When you finish recording, click the Stop button or press the SPACEBAR.
   
   A new audio clip appears.

   Press Play to play back the project. If you would like to redo the take, go to Edit > Undo to undo the previous recording, then repeat steps 3, 4 and 5 above until you get a perfect take.

Now that your first track has been recorded, you can “over-dub” another part. To do so, disable recording on track 1 and repeat the steps in this tutorial. After repeating the steps, you will have recorded to track 2. Both recorded tracks will play during playback. Each will also have its own exclusive volume and pan control, FX chain and can be muted or soloed. You'll learn more about this in future tutorials.
Troubleshooting

If you weren't able to record successfully by following this tutorial, please check the following:

**I only get one side of my guitar/microphone recorded**

You may be recording a mono signal through a stereo input. Guitars and microphones produce mono signals. Right-click the track and select Track Properties from the popup menu. This opens the Track Properties dialog, where you can specify the desired input port. Select the appropriate side of your stereo pair, either left or right as opposed to stereo.

Also make sure you don't have a mono adapter going into the Line-in and that you have the Left side of your sound card (mono) chosen for input in SONAR.

**Previously recorded tracks are mixed into my new recordings**

This can happen when your soundcard is set to record everything that comes out of your computer speakers.

1. Click on the Windows Start button and go to All Programs > Accessories > Entertainment > Volume Control.
   
   The Volume Control window appears.

2. On the Options menu, click Properties.
   
   The Properties dialog appears.

3. In the Adjust Volume For section, click Recording.

4. Click OK to close the Properties dialog.
   
   The Record Mixer appears.

5. Make sure What You Hear or Stereo Mix (exact name various depending on the sound card manufacturer) is not selected. If this option is enabled, click the Select check box below the desired input (normally Line In or Mic).

This problem can also occur when you are using an analog mixer in your setup. Carefully follow all of your signal paths to ensure that your sound cards audio output is not being looped back into itself.

You should also consider the possibility of your microphone picking up the signal from your speakers or headphones.

**Only a flat line/silence is recorded**

In Windows XP, click the Start button and go to Programs > Accessories > Entertainment > Volume Control to open the Windows Mixer.

The Windows Mixer controls the volume levels of your sound card inputs and can also mute any input or output device.
The Windows Mixer looks like this:

![Windows Mixer](image)

When you open the Windows Mixer it may be labeled **Play Control** or **Recording Control**. We want to see the recording controls.

**To view the recording controls in Windows XP:**

1. On the **Options** menu, click **Properties**.
   
   The **Properties** dialog appears.

2. In the **Adjust Volume For** section, click **Recording**.

3. In the **Show the Following Volume Controls** section, click **Line-in** and **Microphone**.

4. Click **OK** to close the **Properties** dialog.
   
   The recording controls appear in the Windows Mixer.

5. Click the **Select** check box under the input you wish to use (normally **Line In** or **Mic**).

**To view the recording controls in Windows Vista:**

1. Go to the Windows **Start** Menu and type the word **SOUND** in the **Start Search** box.

2. The search results appear.

3. Click **Sound** to open the Windows Sound Control Panel.

4. Click the **Recording** tab.
   
   All available input devices are listed along with a meter for each device.

5. Play your instrument or speak into the microphone.
   
   Meter activity is visible on one of the input devices.

6. Right-click the input device that has meter activity and select **Set As Default** from the popup menu.
Tutorial 4 – Playing and recording software instruments

Software instruments, which are also referred to as *soft synths*, are a major part of computer music. Our goal in this tutorial is to add a software instrument to a project. We'll explore a few different ways they can be used with SONAR and look at some options to really make the most of them.

**Note:** *Feel free to skip to the next section if you want to start using synths right away.*

A brief history

For our purposes, a synth has two basic functions:

- Receive a digital message
- Make a sound based on the information contained in that message

In the early 1980's, all of the major manufacturers of keyboards and drum machines got together to decide on a way for their products to work well with each other. Since they all operated under some version of the two functions listed above, it was a simple goal.

They needed to standardize what messages were used to represent particular expressions. For example; if it was a drum machine, everyone would need to use the C note for the bass drum, the D note for the snare drum and so on. That way, messages sent from one drum machine can be fed to another made by a different company. It will play the same beat, but using the drum sounds from the different module.

The standard they established is known as MIDI (usually pronounced [mid-ee]). As soon as computers entered the scene, it was clear that there could (and should) be a way to connect a synth and send MIDI messages to it from a software sequencer. That's how Cakewalk was born. Our first application was a DOS program that would allow a user to edit the MIDI data in detail, and play it out to a connected synth. You could also record the events from a performance into the computer.

Things have evolved a lot since then. As computers have grown more powerful, the capabilities of Cakewalk software have expanded. Computers are now so fast that software companies are able to make synths and drum machines that are completely software-based. They are essentially the guts of a keyboard in a computer program.
Adding an instrument track to your project

Adding instrument tracks to your project is easy and something you’ll find yourself doing often, so let’s explore some of the basics. For this exercise, we’ll start with a blank project:

1. On the File menu, click New.
2. Select the Blank (no tracks or buses) template and click OK.

A new project opens.

3. Click Insert >Soft-Synths.

A menu lists all available software synths that are installed on your computer.

4. Click DropZone.

The Insert Soft Synth Options dialog appears.

5. Select the following options:
   • Simple Instrument Track
   • Synth Property Page
   • Recall Assignable Controls
   • Ask This Every Time

A new track is inserted in your project. This track is a combination of the two types of tracks you have learned about in the previous tutorials. It holds MIDI data and accepts a MIDI input, but it outputs the sound of the synth, like an audio track would. The DropZone window may also open. If not, you can open it manually by double-clicking on the track icon.

Note: You can always launch a given software instrument’s window by double-clicking its track icon.
Let's take a quick look at DropZone.

One of the first things you'll typically need to do is choose a sound. In DropZone and most other Cakewalk synths, a sound preset is referred to as a program.

1. In DropZone's Program window, click Empty Program.
   The Program Browser appears.

   **Note:** It may take a minute the first time the Program Browser opens. This is because DropZone is building a list of all available sounds. Once the list has been built, the Program Browser will open faster the next time.

2. Select a program by double-clicking its name. For this tutorial we'll use Acid Quinda from the Basses section.
   DropZone loads the program and displays the program name.

3. Click the keyboard image to hear what the program sounds like.

   **Note:** Each soft synth uses a different method of choosing and auditioning sounds. This is often outlined in the synth's documentation. You can press the F1 key to open the online help for a synth.

Now that we have inserted an instrument and selected one of its sounds we can make use of these sounds in our project. This is where you can get creative. You have the option of recording a performance that you play on a MIDI keyboard (also referred to as a controller) or manually entering notes and events to play out to the software synth. We'll explore each method in the following sections.
**Recording MIDI**

First, we’ll try recording. This only works if you have a MIDI controller. If you do not have a MIDI controller, skip ahead to the next section of this tutorial.

For recording, you don't need the DropZone window open. You can close an instrument by clicking in the upper right corner. This doesn't cause the synth to stop functioning—it will continue to work in the background.

**Note:** *If you need to see the DropZone window again, just double-click the track icon.*

In the Track view, we can assign the input port. If you only have one MIDI keyboard this should be set up already. Try playing some notes to see if it works. If not, go to Options > MIDI Devices and make sure your keyboard is enabled in the Input Port list.

The next step is arming the track for recording. Click the track's Record Enable button . This enables recording on the track.

Now, click the Record button in the Transport toolbar. The Now Time cursor starts to roll. Play some notes and click the Stop button when you’re done.

You have just recorded your first MIDI performance through a software instrument. Press the Play button to hear it play back.

**Manually entering MIDI notes**

Using this method, you can manually draw notes on a grid called the Piano Roll View (often referred to as the PRV). This is the preferred method if you’re not much of a keyboard player or don’t have access to a MIDI controller. It allows you to edit every detail of a performance.

To get to the PRV, you first need to select the track you would like to see in it. Simply click the track icon once so that it changes color. Next, go to Views > Piano Roll to open the PRV.
The ruler at the top of this view represents musical measures and beats. The keyboard image on the left represents what notes are being played.

Click on the Draw tool . You can also enable this tool by pressing the D key on your computer keyboard. The Draw tool allows you to click on the grid to create a note.

To create a note, click on the grid at measure 1.

If you click on various sections of a note, the Draw tool performs a different function:

- **Left edge.** Adjusts the start time.
- **Right edge.** Adjusts the end time or the duration.
- **Top.** Adjusts the velocity of the note, which indicates how hard the note is played.
- **Bottom.** Allows you to move the note to another location on the PRV grid.

Try to create a melody using this technique. You might find that you can only create 16th notes or longer. If you want 32nd notes or triplets, click the Snap To Grid options button .

This will open the Snap To Grid dialog box where you can set the resolution to 32nd notes.
Click OK. You can now draw notes at shorter distances from each other.

**What if I already have a project that contains MIDI tracks?**

If you already have a MIDI track that you would like to play through a software instrument, the steps are a bit different.

Let's start by opening a sample project.

1. On the **File** menu, click **Open**.
2. Navigate to **My Documents/Cakewalk/SONAR/Sample Content/Tutorials**.
3. Click on the file named **Latin.cwp** and click **OK**.

If you press **Play**, you are not likely to hear anything. That's because this project does not contain a software synth for the MIDI tracks to play through. Since there are 11 tracks in this project, it would be best to use one synth track and route them all to the same instrument. Some instruments, such as the Cakewalk TTS-1 can output more than one type of sound. These instruments are known as **multi-timbral** synths. They know what notes are played through each sound based on the MIDI channel they are sent over. If you examine the **Track Properties** dialog of each track in this project, you'll notice that each one is set to its own channel. No two tracks share the same channel.

Let's insert the Cakewalk TTS-1:

1. Go to **Insert > Soft Synths > Cakewalk TTS-1**.
   
The **Insert Synth Options** dialog appears.
2. In the **Create These Tracks** area, click **First Synth Audio Output**.
3. In the **Open These Windows** area, click **Synth Property Page**.

   **Note:** *If you would like a detailed explanation of each option, click Help.*

4. Click **OK**.

   A new synth track is inserted in your project.

On some computers, the tracks may play back through the TTS-1 at this point. However, on computers that have hardware MIDI outputs available, you may need to specify the TTS-1 as each track's output. Here's a fast way to do that:

1. Hold down the CTRL key and click each track to select them.

   The tracks are highlighted to indicate they are selected.

2. Go to **Tracks > Property > Output**.

   The **Track Outputs** dialog appears.

3. In the **MIDI Outputs** list, select **Cakewalk TTS-1**.

   Press **Play** to play back the project. If you’d like to add your own track to play through the TTS-1, you can click on the **New Track** button again. This time select **MIDI Track**. On your new MIDI track, set the output to TTS-1. Remember, it needs to be on its own discreet MIDI channel. In this project, MIDI channels 1-11 are already used, so let's assign this track to channel 12. You can also select the sound via the track's Patch control. Then use one of the methods described above to create MIDI data. You can also add MIDI data to your new track from the Media Browser. See Tutorial 2 for details about the Media Browser. Another option is using the Staff view as an alternative to the Piano Roll view. That will be covered in the next tutorial: Tutorial 5 - Working with music notation.
Tutorial 5 – Working with music notation

A great way to compose in SONAR is by using the Staff view. The Staff pane displays MIDI note events as musical notation. For some musicians, this may be the most familiar and comfortable view in which to work. The Staff pane provides many features that make it easy for you to compose, edit, and print music. You can add notes to your composition with simple point-and-click techniques.

This tutorial will introduce you to the tools and features that SONAR provides for working with notation.

Let’s start by opening the Staff view in a new project:

1. On the **File** menu, click **New**.
   
   The **New Project File** dialog appears.

2. Select the **Normal** template, specify a project name and save location, then click **OK**.
   
   SONAR loads the new project, which contains two audio tracks and two MIDI tracks.

3. Click on track 3 labeled “MIDI 1”.

4. On the **Views** menu, click **Staff**.
   
   The Staff view opens.
Next we need to configure the Staff View tools for the purpose of this tutorial:

1. Change the **Display Resolution** to the smallest note value.

2. Disable **Fill Durations** and **Trim Durations**.

3. Select the **Draw tool**.

For this tutorial we will also change the time signature to ¾, the key to G and the staff layout to display a treble and bass clef.

1. On the **Insert** menu, click **Meter/Key Change**.

   The **Meter/Key Signature** dialog appears.

2. Change **Beats per Measure** to 3 and **Key Signature** to 1 Sharp (G), then click **OK** to close the **Meter/Key Signature** dialog.

3. In the Staff view, click the **Layout** button.

   The **Staff View Layout** dialog appears.
4. In the **Clef** list, select **Treble/Bass**, then click **OK** to close the **Staff View Layout** dialog.

The Staff View now looks like this:

Now that you know how to set up the Staff View, it's time to play! You can either record a MIDI track in this project or manually add notes. The rest of this tutorial will provide you with a basic overview of the notation tools. For more in depth information about all the features and functionality of the Staff View, including using the Fretboard and the Lyrics View, check out the online help in SONAR.

**Selecting the note value**

Simply select any of the note value buttons found in the center of the Staff view. You can also create a dotted note or triplet by clicking the appropriate buttons found just to the right.

**Adding a note**

To add a note:

1. Click the Draw tool.
2. Click at the point where you want to add a note.

A note event is inserted.
**Selecting notes**

To select notes:

1. Click the Select tool.

2. Do one of the following:
   - To select a single note, click the note head.
   - To select multiple adjacent notes, click outside the first note you want to select and drag the mouse to draw a rectangle around the desired notes.
   - To select discontiguous notes, hold down the CTRL key and click the desired notes.

**Moving Notes (Change timing or pitch)**

To move notes:

1. Click the Select tool.

2. Select the note or notes that you want to move.

3. Click on any selected note and drag the mouse left or right to change timing or up and down to change pitch.

**Copying notes**

To copy notes:

1. Press and hold the CTRL key down while you click the desired note(s).

2. While still holding the CTRL key and the left mouse button, drag the note(s) to the desired location, then release the mouse button.

   The note(s) is copied.

**Changing the duration of a note**

You can change the duration of a note while using either the Draw tool or the Select tool.

1. Right click the note head to open the *Note Properties* dialog.

2. In the *Duration* field, enter in the number of ticks you want for the note, then click *OK* to close the *Note Properties* dialog.
The following table shows the relationship between note durations and ticks (with the default timebase of 960 ticks per quarter note).

<table>
<thead>
<tr>
<th>Note</th>
<th>Duration in ticks</th>
</tr>
</thead>
<tbody>
<tr>
<td>Whole</td>
<td>4:000</td>
</tr>
<tr>
<td>Half</td>
<td>2:000</td>
</tr>
<tr>
<td>Quarter</td>
<td>1:000</td>
</tr>
<tr>
<td>Eighth</td>
<td>480</td>
</tr>
<tr>
<td>Sixteenth</td>
<td>240</td>
</tr>
<tr>
<td>Thirty-second</td>
<td>120</td>
</tr>
</tbody>
</table>

**Deleting a note**

Select the Erase tool and click the note you want to delete.
**Adding lyrics**

To add a lyric event below a note:

1. Click the Draw tool 🎨.
2. Enable the Lyric button 🍊.
3. Position the pointer just below the note and click. A box appears where lyrics can be typed.

4. Press the space bar to quickly jump to the next note.

**Adding chord symbols**

To add a chord symbol above a note:

1. Click the Draw tool 🎨.
2. Enable the Chord button 🎤.
3. Position the pointer above the note you want to add the chord to and click. A chord symbol is added above the note.

4. To change the chord properties or show a guitar chord grid, right-click the chord name. The Chord Properties dialog appears.
Adding expressions

1. Click the Draw tool.
2. Enable the Expression button.
3. Position the pointer just below a note and click.
   A box appears where expressions can be entered.

\[ \text{Note: Hairpin events are ornamental only and do not affect playback.} \]

Adding a crescendo or decrescendo/diminuendo

1. Click the Draw tool.
2. Enable the Hairpin button.
3. Position the pointer just below a note and click.
   A hairpin event (crescendo or decrescendo) is inserted.

4. To change the hairpin type and duration, right-click the hairpin event.
   The Hairpin Properties dialog appears.
Adding pedal marks (sustain)

1. Click the Draw tool.
2. Enable the Pedal button.
3. Position the pointer below the staff and click.

Pedal down and Pedal up marks are inserted.

4. Click and drag to move the marks to a new time if needed.

Printing your notation

Once you are finished entering and editing notes you can print out the score or individual parts.

1. Select the MIDI track or tracks you want to print the notation for.
2. On the Views menu, click Staff.
   The Staff view opens.
3. On the File menu, click Print Preview.
   The Print Preview window opens, allowing you to see how the printed score will look.
4. To change the rastral size of the score, click Configure.
   The Staff View Print Configure dialog appears. For more information about the different rastral sizes, see the “Printing” topic in the SONAR online help.
5. To print the score, click Print.

Tip: To change the title, composer and copyright information, select File > Info to open the File Info window.
Tutorial 6 – Editing your music

While working on your music, you are likely to find that editing is a major part of the song creation process. Before people started making music on computers, all of the editing was done by cutting tape with a razor blade and piecing it together. You can imagine how difficult it could become. In SONAR, you can actually select a part of your music with the mouse and delete/copy/paste/move it all very easily. This Tutorial will introduce SONAR's tools for making some common edits and offer a few tips to make it faster and more fun.

Selection

One of the most important things to understand in order to edit your music successfully is selection. Once you become familiar with selecting, the rest is easy. You typically need to have the appropriate parts selected in order to make edits on them.

There are two aspects of selection:

• Time Range
• Tracks

Let's say you'd like to delete the second measure of a certain track. The time range specifies that the edit will need to occur between measures 2 and 3. The track selection specifies what track's clips will be deleted, while leaving its surrounding tracks unchanged.

Let's explore some different ways to do this in a sample project. All of the tools described are available in the Track View toolbar, which is located directly above the tracks in the Track View. For a complete description of all of the tools in the Track view toolbar, see “Track View Toolbar” on page 1444.

Note: If you would like to try both of the following methods, select Edit > Undo after completing the first method. Doing so will revert the project to its previous state.
Method 1:
1. Select the track that you want to delete measure two from.

   **Tip:** *Click in the Tracks pane on the left, not the Clips pane on the right.*

2. Drag in the time ruler from measure 2 through measure 3.
   The selected time range is highlighted.

3. Press DELETE or select **Edit > Delete**.
   Measure two is deleted from the selected track.

Method 2:
1. Select the Free Edit tool.
2. Click in the center of the clip and drag to select the section you want to delete.
   The selected section is highlighted.

3. Press DELETE or select **Edit > Delete**.

You might have noticed that you're only able to select full measures. What if you need to edit a smaller amount of time? You'll need to turn off Snap To Grid. To do so, click the **Snap to Grid** button.

With this button disabled, you will be able to make finer selections. You can also choose different Snap To Grid options. Press SHIFT+N to open the Snap To Grid window and try different options. For information about each option, click **Help**.
Moving clips

From time to time, you may need to move clips around. If you understand selection, you’re half way there already.

1. Select the section you want to move.

2. With the Free Edit tool, click the top or bottom of the selection and drag the clip to the desired location.

   ![Drag and Drop Options](image)

   The Drag and Drop Options dialog appears, which lets you specify what to do with any existing data in the target location. You can either replace the existing data or blend the old and new data.

Splitting Clips

In some cases, you might want to split a clip. As described later in this tutorial, it can be beneficial to have clip borders at different points on a track. You can split a clip with the Split tool.

To split a clip, do one of the following:

- To split a clip in two, click the desired position on the clip.
- To split a clip at two separate points, click the first split position and drag to the second split position.

**Note:** The Split tool obeys the Snap to Grid settings. If a split does not occur exactly where you click, disable Snap to Grid and try again.

**Tip:** You can also use the Free Edit tool to click the desired position on the clip, then press the S key to split.
Cropping Clips

You can crop a clip by using a gesture called slip editing. Slip editing lets you “roll out” the beginning or the end of a clip to different places without changing the position of the music. Imagine that the clips are “windows” that allow you to see and hear pieces of audio or MIDI. You can change the size of that window so that less of the data is visible. If it's not visible, it won't be heard during playback. The data still exists, so you can enlarge the “window” by slip editing the clip. The visible data will then be audible.

Click the Select tool to enable slip editing.

Now, if you point to the left or right clip edge, the cursor changes and you can drag the clip edge to a new location.

Fading Clips

You can also fade individual clips by using the Select tool. Drag the upper left corner of a clip to create a fade-in. Drag the upper right corner of a clip to create a fade-out.

To change the fade characteristics, right-click an existing fade and select the desired fade type from the popup menu.
**Undo and Redo**

While editing a project, you might make mistakes or experiment with an idea that doesn't produce the desired results. SONAR has unlimited Undo for such occasions. You can undo one step at a time by selecting **Edit > Undo** or by pressing CTRL+Z. You can also look at your edit history and select a time to go back to. To do so, go to **Edit > History**, choose the edit you'd like to return to and click **OK**.

**Note:** *When you close a project, the undo history is erased.*

If you change your mind and want to revert to the previous undo state, select **Edit > Redo** or press CTRL+SHIFT+Z.

This tutorial has shown you how to use different tools to shape your recordings into well-organized and great sounding projects. The next step is mixing, which is covered in “Tutorial 7 – Mixing and adding effects” on page 99.
Tutorial 7 – Mixing and adding effects

Mixing is an important part of recording that can really help the music you create in SONAR sound its best. Mixing involves placing different instruments and sounds in layers of the frequency spectrum, adjusting levels so that tracks blend nicely, spreading them across the stereo field and adding effects where appropriate.

There are many important decisions to make when mixing; things that are sometimes not considered while writing a song. The choices you make can have a major effect on how pleasurable the listening experience is for your audience.

In this tutorial, we'll discuss some general guidelines. But, it's important to remember that there are no rules. This is another artistic stage of song creation.

We'll start by opening the MixingTutorial project:

1. Go to File > Open and select the file named MixingTutorial.cwp.

   Note: Tutorial files are located in the My Documents/Cakewalk/SONAR/Sample Content/Tutorials folder. You can jump to this folder by selecting Template Files from the Go to folder drop-down list in the Open dialog.

2. Go to File > Save As and save it under a new name. This way, you can save your work without overwriting the original, in case you'd like to start over.

   In the same folder is a file named MixingTutorial-Complete.cwp, which is a copy of the same project, but after the tutorial has been completed. You can use this project as a reference to which you can compare settings and levels.
Volume and pan

Adjusting volume and pan is always a good place to start when mixing. One of the biggest benefits of SONAR's Console view is that you can easily see the volume and pan controls for many tracks simultaneously, in addition to large meters. Some people also enjoy working in the Console view because it doesn't offer a graphical representation of what the music “looks like”. Since the final outcome will be an audio file, the listener will not be distracted by the visual cues that are shown in the project's Track view. You may find that you are better able to focus on the actual sound when not seeing the clips.

To open the Console view

- Do one of the following:
  - Click the Console view button in the Views toolbar.
  - Click Views > Console.
  - Press ALT+3.

Here, we'll be shaping the song's foundation. If you listen to the project as it is, you'll probably notice that it sounds pretty "muddy" and bland. This usually happens because all of the instruments are fighting each other for space in the frequency spectrum and stereo field. They're all trying to be heard at the same level in the same location.

Normally, when recording a track, it is common to try to get a relatively loud signal. This is done to achieve the best signal-to-noise ratio and knowing that you will eventually adjust levels during the mixing stage.

Some people like to begin this process by turning down every track and then gradually turning up one track at a time, starting with the rhythm section. Begin by increasing the volume of the bass drum to the desired level. Continue with the snare, the rest of the drums and finally the bass guitar—moving on in order of importance. If there is a lead vocal in the song, that would come last, so that it sits on top of the instrumental foundation you've established.

Other people approach mixing the opposite way, turning things down a bit one at a time. If one method doesn't seem more appealing than the other, try both to see which one is more comfortable for you.

**Important:** Pay close attention to the main meter while mixing. You never want the main meter to reach the very top, which will result in undesirable audible noise. This is called clipping.

**Note:** You can find the Mains meters on the far right side in the Console view. If you don't see the Mains meters it, click the Mains button.
The next thing we'll try is panning. As with mixing in general, there are no rules when it comes to panning. Be creative, trying different ideas to see how they sound. One important thing to consider is that when you pan two tracks that share the same frequency range away from each other they will become clearer. This especially applies to instruments that have been double-tracked. Try it with the two tracks labeled **Cymbals Left** and **Cymbals Right**. Notice how you can hear more definition and detail in the two tracks as you pan them away from each other. When panning double-tracked instruments, try to avoid panning them all the way to the left or right. Doing so may cause the tracks to sound too “separated”, which can take away from the fullness of the sound.

**Adding effects (FX)**

At this point, you should have a basic mix. Everything is generally where you want it to be and it's time to use some audio effects to tweak it all to perfection. Effects placed directly on an audio track are called *inserts*.

Choose an audio track you would like to start with:

1. In the Console view, locate the FX bin for the track you’d like to work with. If you don’t see the FX bin, click the **FX** button to ensure FX bins are not hidden.

2. Right-click the FX bin to open the pop-up menu.

3. Point to **Audio FX**, then point to **Sonitus:fx** and choose any one of the available effects.

   The selected effect is inserted into the track's FX bin.

4. Experiment with the controls on the plug-in while the music is playing back. You will hear noticeable changes to the sound.

5. Right-click on the effect and choose **Delete** to remove the effect.

Each of the effect plug-ins listed is designed to change the sound in some specific way. Here’s a quick list of some of the included plug-ins and what they're typically used for:

**Compressor/Gate.** This plug-in affects the loudness of the sound. It can limit how loud a sound can get. It can also limit how soft a sound can get before it's completely turned off.
EQ.  EQ can accentuate or turn down a certain frequency range in a sound. For example, if you have an unwanted high-pitched buzz on one of your tracks, an EQ may be able to turn that high frequency down without affecting the sound of the instrument.

Reverb.  Reverb creates an artificial space. It produces echoes that are similar to the natural echoes that happen when a sound bounces off the walls in a room.

Delay.  Delay plug-ins have the ability to create an echo. However, it's typically more distinct than that of a reverb. It makes a sound repeat, often in a rhythmic, musical manner.

These are the effects we'll be focusing on in this tutorial. However, other effects are available and you should experiment with each one to discover how they can be used in your mixes. To get online Help for a particular plug-in, simply click one of its controls and press the F1 key on your computer keyboard.

**Compression and EQ**

While adjusting track levels in a song, you might notice that some tracks are too dynamic. Sometimes they're too loud, other times too soft. In most modern music, the important elements in a mix are focused in a specific volume range. This is done with a **compressor**.

The purpose of a compressor is to limit the dynamic range of music or sound. Compression will make the loud parts of the signal quieter, resulting in a more or less even level. That even level can then be increased to fit more specifically in the mix.

Many compressors have an option to allow that loud peak to remain untouched for a certain time, which can add some "punch".

Let's try it on the bass drum:

1. Add the Compressor plug-in to the track labeled **Kick**.
2. Adjust the Threshold. The threshold value represents the dB level at which compression starts to take place.
3. Adjust Attack. The attack value represents the time the compressor takes to respond to an increase in the input audio's level once the threshold level has been reached.
4. Adjust the Level to the desired output volume.

This approach can be applied to any track you like. It's especially useful when trying to get vocals to stand out in a mix.

Now, we can apply some EQ. One of the primary uses for EQ is to prevent different instruments from stepping on each other in the frequency spectrum. One instrument might be intended for a certain frequency range, but extends into another instrument's frequency range. If you turn down the overlapping frequency range for one of the instruments, it will allow the other instrument to stand out better in the mix.

Let's give it a try:

1. Solo the tracks named **Tension Climbing** and **Chirpy Synth**.
2. Add the Sonitus:fx Equalizer plug-in to the **Tension Climbing** track.
   
   The Sonitus:fx Equalizer interface appears.
3. Grab one of the numbered nodes and drag it around. Boost the selected band until you find the frequency range that interferes with Chirppy Synth. When you find it, turn down the selected band by dragging the node downward.

**Tip:** Try to cut the band around 1kHz.

Experiment with the other controls on the EQ to get the best possible results. As with the compressor plug-in, this approach can be applied to any track you like.

**Reverb and Delay**

Next, we'll add some space to the song. This is done by using time-based effects.

The first thing we'll do is add a delay effect. A delay effect can really enhance an instrument. In our tutorial project, we will add the Delay effect to the track name Chirppy Synth, which sounds very dry and lifeless. Applying a delay might give it more depth.

1. Add the Delay plug-in to Chirppy Synth.
2. Configure the controls as follows:
   - Tempo Sync = Host
   - Factor = 1/2 (set for both Left & Right channels)

This is a good starting point. Sometimes the best way to familiarize yourself with a new effect plug-in is to dig in and start tweaking.

Next, we'll apply some reverb to the project. Think of a reverb effect as an artificial room. We could add a separate reverb to each track, but when multiple reverbs are running at the same time it can sound “cloudy”. This might be because our ears are used to hearing sounds bounce of walls naturally. A reverb on each track would sound like you have one instrument in one room, another instrument in another room, and so on.

Instead, we will add a single reverb effect to a bus, then send each track to that bus, at varying levels. This is where SONAR’s advanced mixing environment offers a lot of flexibility. We will add a control to each track, which adjusts how loud a copy of the track's sound is sent to the bus. This will sound more natural since it's similar to the behavior of an actual acoustic space. All of the different sounds can interact with each other in the “virtual room” we're creating with the reverb.

Follow these steps to create your reverb send from the Console View:

1. We want to add this send to all tracks, so go to **Edit > Select > All** to select all tracks.
2. Right-click on one of your tracks in the Sends section of the strip and choose **Insert Send Assistant**. If you don’t see this section in your Console View click the **SEND** button to ensure it is not hidden.
   The Insert Send Assistant appears.
3. Configure the Send Assistant as follows:
   - Click **New Bus**. This will create a new reverb bus instead of routing the tracks to an existing bus.
   - Select **Stereo**
   - In the **Name** box, type **Reverb**.
   - Click **Choose Effect** and select **Audio Effects > Sonitus:fx > Reverb**.
   - Make sure **Pre Fader** is not selected.
   - Select the **Show Effects Property Page** check box.
   - In the **Bus Output** list, select **Master**.

4. Click **OK**.
   The Reverb property page appears.

5. Set the **Reverb** control to **0.0 dB** and the **Dry** control to **-Inf.**.
   Notice that a send control named Reverb has been added to each track. To enable or disable a send, click the **On/Off** button located on each track’s **Send** control.
When a send is enabled, you will hear the reverb effect during playback. To adjust how much reverb is applied to each track, use the send's LEVEL control.

Enable the send control for each track that you want reverb on. You'll probably want at least a little reverb on every track except for the kick drum and the bass guitar.

**Using Automation**

Another feature that is important to mixing is *automation*. Automation lets you record changes to almost any parameter in SONAR, including track parameters, effects, synths and buses. SONAR makes this very easy.

1. Click a track's **Write Automation** button  to enable automation recording for that track.

2. Press **Play** to start playback.

3. During playback, simply make the changes to the parameters in realtime, using either your mouse or a control surface.

4. To disable automation recording, stop playback and click the track's **Write Automation** button  again.

When you play back, the parameters will update automatically.
Automation allows you to make gradual or sudden changes to make your song more dynamic. For example, in the tutorial project, you might find that **Whiney Synth** should become lower in volume at measure 25, when the drums and bass change. Try it:

1. Click the **Write Automation** button on the **Whiney Synth** track.

2. Click **Play** or press SPACEBAR to start playback.
3. At measure 25, turn the track volume down to the desired level.
4. At measure 33, turn the track volume back up.

5. Press **Stop** to stop playback.
6. Disable **Write Automation** by clicking the button again.

7. Press **Play** and notice how the track volume changes automatically.

Repeat this process with any other automation you feel the project needs.

That concludes this tutorial. But don’t stop here. Continue to experiment by adding different effects, adding loops through the Media Browser view, etc.

Be creative and listen closely to the mix details in your favorite songs and albums. It's sure to provide you with inspiration for your own projects. There are also many books available on the topic, as well as thousands of add-on plug-ins that can expand your arsenal of FX. For more information, visit www.cakewalk.com:

FX: [www.cakewalk.com/Products/instruments.asp](http://www.cakewalk.com/Products/instruments.asp)

Books/Videos: [www.cakewalk.com/Products/Books/Mixing.asp](http://www.cakewalk.com/Products/Books/Mixing.asp)
Tutorial 8 – Working with video

SONAR allows you to add music and sound to your videos. This tutorial will guide you through the basics of working with video inside SONAR. If you are new to SONAR, it is highly recommended you review “Tutorial 1 – Creating, playing, and saving projects” on page 53 before going any further.

Importing video

Before you can start working with video, you first need to import a video file. Let’s try this out with a new project.

1. On the File menu, click New to open the New Project File dialog.

2. Select the Normal template, give your project a name and then click OK.

   If you are having trouble with this, please refer to “Tutorial 1 – Creating, playing, and saving projects” on page 53.

3. On the File menu, point to Import and select Video.

   The Import Video dialog appears.
Let’s explore some of the options in the **Import Video** dialog.

The first thing you will notice is that this dialog is very similar to the **Open** dialog that was discussed in Tutorial 1. The **Import Video** dialog functions in very much the same way with the exception of two sections.

First, outlined in the image above is the drop down box **Files of type**. Making a selection here will determine which video formats are displayed in the dialog. SONAR supports the following digital video formats:

- Windows Media (*.wmv and *.asf)
- Video For Windows (*.avi)
- MPEG Video (*.mpg)
- QuickTime Video (*.mov)

The file we are interested in for this tutorial is a *Windows Media* file, so let’s select *Windows Media* (*.wmv, *.asf) in the **Files of type** list.

Next, outlined in the above image you will see the **File info** area on the left and three options on the right. Let’s review what each of these options do.
For now, let’s leave the **Import Audio Stream** and **Show file info** check boxes selected. Just as you would with the **Open** dialog, navigate to the following location:

```
My Documents/Cakewalk/SONAR/Sample Content/Tutorials
```

Locate and import the file named **Boarding.wmv**. You can open it by either double-clicking on it or highlighting it and then clicking the **Open** button.

**Tip:** You can quickly get to the My Documents folder by clicking on its button along the left side of the Import Video dialog.

Notice that SONAR imported any audio that is a part of the video as well. If the video does not have any audio already associated with it, then SONAR will create a silent audio track like in our example.

You should now see the **Boarding** video in the Video view as well as the Video Thumbnail pane in the Track view.

<table>
<thead>
<tr>
<th>Option</th>
<th>What it does</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show file info</td>
<td>When selected, this tells SONAR to display video information about the selected file in the <strong>File info</strong> area of the dialog.</td>
</tr>
<tr>
<td>Import Audio Stream</td>
<td>Select this option if you want to import the video file’s embedded audio into a new audio track in SONAR.</td>
</tr>
<tr>
<td>Import as mono tracks</td>
<td>Select this option if you want to import the video file’s embedded audio data as one or more mono tracks.</td>
</tr>
</tbody>
</table>

Table 16.
What if I don’t see the Video Thumbnail pane or Video view?

To show or hide the Video Thumbnail pane, drag the splitter bar that separates the Video Thumbnail pane from the Clips pane.

To restore the Video Thumbnail pane, point the mouse pointer over the splitter bar (the mouse pointer will look like ☰ ), then drag the splitter bar down to restore and resize the Video Thumbnail pane to your liking.

If you closed the Video view, or if it did not open automatically when you imported the video, you can open it by selecting Views > Video or pressing ALT+6.

Changing the video properties

SONAR allows you to make some useful changes to a video's settings for film scoring purposes. To access these settings, simply right-click in the Video view and choose Video Properties from the popup menu to open the Video Properties dialog.

The Video Properties dialog has three tabs: the Video Settings tab, the Info tab and the Render Quality tab. For detailed information about all of these options and settings, see the online help topic “Video Properties dialog”. For this tutorial, we are only going to look at the tools on the Video Settings tab.
There are three options on this tab that are very important to understand and extremely helpful when working with video. Let’s take a closer look at them

<table>
<thead>
<tr>
<th>Option</th>
<th>What it does</th>
</tr>
</thead>
<tbody>
<tr>
<td>Start Time</td>
<td>The time in your SONAR project at which you want the video file to start playing.</td>
</tr>
<tr>
<td>Trim-in Time</td>
<td>The time in the video file at which you want video playback to start, this is useful if you don’t want to see the opening credits or the first few scenes. This is expressed in SMPTE time code.</td>
</tr>
<tr>
<td>Trim-out Time</td>
<td>The time in the video file at which you want video playback to stop, this is also expressed in SMPTE time code.</td>
</tr>
</tbody>
</table>

Let’s change the **Start Time** value to measure 2. To do this, enter the number 2 in the **Start Time** box.

Now, click the **RTZ** button in the transport and then click Play. Notice how the video doesn’t start playing until measure 2 in your project.
Working with markers

When syncing up audio events to film cues or video, it is common to use markers. Markers are a powerful feature in SONAR that helps to simplify the task of identifying major events in a song or video. They can be used to clarify where a verse or chorus begins in a rock tune or, in the case of film scoring, they can be used to identify hit points (points in the film where you want a musical event to synchronize with a visual event). Before we get started on this next exercise, return to the Video Properties dialog and click the Video Settings tab. Set Start Time to 1:01:000, Trim-in Time to 00:00:00:00 and Trim-out Time to 00:00:44:23.

Let’s say we want our music to start at the beginning of the video right when the sun comes out. This occurs about 4 seconds into the movie. Taking a closer look, this happens at 4 seconds and 10 frames into the clip, which, expressed in SMPTE time code, is 00:00:04:10.

There are two ways to add markers in SONAR:

- Place the Now Time at the location where you would like a marker, then select Insert > Marker or press F11.
- Click the Add Marker button in the Markers view.

Let’s open the Markers view by selecting Views > Markers.

The Markers view is very handy when working with events in a film. The first thing we want to do is add a new marker to the project, indicating the start of the project. To do this, click the Insert Markers button to open the Marker dialog.
From this dialog you can do a lot of very important things. First let's name this marker by typing **Intro** in the **Name** field.

Next, select the **Lock to SMPTE (Real World) Time** check box. This option is very important when working with video. If a marker is not locked to SMPTE time, its position in relation to events on the video will change with tempo and meter changes in the project.

You might also notice that the **Time** value changes to the SMPTE format after you selected the check box. This determines where the location of the marker will be. We know in the video that the sun comes out at about four seconds and ten frames into the video. Let's set the **Time** value to **00:00:04:10**.

Click **OK** to insert the marker and close the **Marker** dialog. You can place as many markers as you need for a project to sync up all of your events.

The Markers view will now display the marker you just created, with the name **Intro** assigned to it.

The Marker view toolbar contains the following commands that apply to selected markers.

<table>
<thead>
<tr>
<th>Control</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Delete Marker" /></td>
<td>Click the <strong>Delete Marker</strong> button to delete the currently selected marker.</td>
</tr>
<tr>
<td><img src="image" alt="Change Marker Properties" /></td>
<td>Click the <strong>Change Marker Properties</strong> button to open the <strong>Marker</strong> dialog for the selected marker. This is useful if you want to change the location of a marker.</td>
</tr>
<tr>
<td><img src="image" alt="Lock/Unlock Marker" /></td>
<td>Click the <strong>Lock/Unlock Marker</strong> button to lock or unlock the marker to SMPTE time.</td>
</tr>
</tbody>
</table>

Table 18.

Close the Markers view now and take a look at the time ruler in SONAR, which spans the top of the Clips pane in the Track view. You will notice there is now an orange flag named **Intro** indicating where your new marker is in the project.
Exporting your video

Once you have finished with all of your music and have your video synced up as you would like it, you’ll want to mix it down to a video file that you can share with the world.

1. Select everything in the project that you want to export. If you want to export the entire project, simply select Edit > Select > All or press CTRL+A.

2. On the File menu, point to Export and click Video.

The Export Video dialog opens. You will notice this is very similar to both the Save As and Export Audio dialogs that were explored in Tutorial 1 and Tutorial 9.

3. Similar to saving project files, you will first want to give your video a name by typing one into the File name field.

4. Choose the desired video format by selecting it from the Save as type list.

Clicking the Encoding Options button at the bottom will allow you to explore some advanced settings for your video. From this dialog you will be able to change the quality and size of your video. This is particularly important if you plan to upload your video to the web. Some codecs work better than others and are more appropriate for different scenarios. Click the Help button in this dialog for more specific details about different formats.

The Audio Mixdown Options button will bring up settings specific to the audio in your project. Click the Help button for detailed instructions on how to use these settings.

5. Specify the location you wish to save the file to and click Save to export it.
Tutorial 9 – Exporting, CD burning and sharing

Once your SONAR project is complete, you will want to share it with the world or burn a CD. SONAR offers many tools to help you do this. In this tutorial, we are going to explore some of the basics of these tools.

Before we get started, let’s open one of the example audio projects included with SONAR. If you have your own project that already contains audio, you can load that instead. However, your screen will look different from the images in this tutorial.

1. On the File menu, click Open.
   The Open dialog appears.

2. In the Go to Folder list, select Template Files and then open the Tutorials folder.

3. Browse to the project named SONAR_AudioDemo1.cwp and click Open to load the project.

   Note: You may have to rename the file if you saved it with the same name during Tutorial 1.

   Now that you have opened the demo project (or your own audio project) click the Play button or press SPACEBAR listen to it. If you do not hear any audio, review the steps in Tutorial 1 to ensure SONAR and your audio device are configured correctly.

   Cakewalk Project Files are different from the audio you hear on a CD in that they are often multi-track. In this example, you will notice that there are four audio tracks. In order to burn this mix to a CD or prepare it for distribution, we need to export or mix it down to a stereo track.

   First, we need to click File > Export > Audio.

   This will bring us to the Export Audio dialog. This has many useful functions. Let’s explore some of them in detail.
You should notice that the top half of this window is very similar to the **Open** and **Save** dialogs that were discussed in “Tutorial 1 – Creating, playing, and saving projects” on page 53. This is used to navigate to locations on your computer’s hard drive and tell SONAR where you want to store the exported audio.

For this Tutorial, we are only going to explore some of the more common settings. If you would like to read about all of the options and settings click the **Help** button.

<table>
<thead>
<tr>
<th>Control</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Channel Format</td>
<td>Specifies if the audio should be exported as stereo or mono.</td>
</tr>
<tr>
<td>Sample Rate</td>
<td>Allows you to set the sample rate of your export. 44100 Hz is used for CD quality audio.</td>
</tr>
<tr>
<td>Bit-Depth</td>
<td>Allows you to set the bit-depth of your export. 16-bit is used for CD quality and 24-bit is often used for DVD quality audio.</td>
</tr>
<tr>
<td>Add to Cakewalk Publisher</td>
<td>Select this option to send your file to Cakewalk Publisher, which is used to put your music on the Internet.</td>
</tr>
</tbody>
</table>

Table 19.
If you would like to burn an audio CD of your music

1. Click File > Export > Audio to open the Export Audio dialog.
2. In the Channel Format list, select Stereo.
3. In the Sample Rate list, select 44100.
4. In the Bit-Depth list, select 16.
5. Enter a name for your mix in the File name box.
6. In the File type list, select Wave.
7. Specify where you want to save the file. Make note of this location, because you will need to use it later.
8. Click Export.

A progress bar appears across the bottom of SONAR’s screen while a CD quality audio file is exported. When the progress bar disappears, SONAR has finished exporting your project.

Now we need to burn our mix to a CD. SONAR features a powerful built-in CD burning application that can do this for us. Let’s open Audio Creator LE and briefly explore its features and how to use it.

**Burning an audio CD**

Select Tools > Burn Audio CD to open the Audio CD Burner dialog.

**Figure 19. The Audio CD Burner dialog**

Simply browse to the audio files you wish to burn and click the Add Track button. You can also drag audio files into the Burner tracklist.

**Note:** Any files that are not in 16 bit, 44.1kHz wav files will automatically be converted to the proper CD format.
Depending on the type of blank CD you are using, you can fit up to 80 minutes of audio on one CD. Make note of the **Space Available** and **Space Used** fields; these will let you know how many more tracks you can fit on your CD. For the best compatibility with most consumer CD players, you should use a CD-R disc. CD-RW discs, while compatible with some newer CD players, may not play back in all systems.

Once you have finished adding all the songs you would like to burn to a CD, the final step is to burn your disc. To do so, do the following:

1. Insert the writable CD into the CD-R drive.
   - The drive containing the writable CD should automatically be detected. If for some reason it isn’t detected, manually select the drive letter of your CD Burner from the **Target Drive** drop down list.

2. Click **Burn CD**.

**If you would like to share your music on the internet**

*Note: Due to licensing restrictions, your Cakewalk software only includes a 30 day free trial of the MP3 encoder. If your 30 day trial period has expired, a full license can be purchased for unlimited use from the Cakewalk web store.*

1. Click the **Export Audio** button to open the **Export Audio** dialog.

2. In the **Channel Format** list, select **Stereo**.

3. In the **Sample Rate** list, select **44100**.

4. In the **Bit-Depth** list, select **16**.

5. Select the **Add to Cakewalk Publisher** check box.

6. Enter a name for you mix in the **File name** box.

7. In the **File type** list, select **MP3**.

8. Click **Export**.
   - The **MP3 Export Options** dialog appears. For detailed information about the different options, click **Help**.

9. For our exercise, accept the default settings by clicking **OK**.
   - A progress bar appears across the bottom of SONAR’s screen. When the progress bar disappears, SONAR has finished exporting your project.
Cakewalk Publisher

SONAR includes Cakewalk Publisher, which is a powerful tool to share your music, artwork and playlists on the Internet. A detailed description of Publisher is beyond the scope of this tutorial, but let’s take a quick look at its basic features and how it integrates with SONAR.

To open Publisher, select Tools > Publish to Web.

Figure 20. Publisher

Notice that your recently exported project is already listed in the Track list. This is because you selected the Add to Cakewalk Publisher check box in the Export Audio dialog.
The following table describes a few of the buttons in the publisher interface. If you would like to explore all of the features in Publisher, click the button labeled HELP in the upper right corner of the Publisher window.

<table>
<thead>
<tr>
<th>Control</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>CONFIGURE PLAYERS</td>
<td>Used to configure the player and generate the HTML code for pasting into your web site.</td>
</tr>
<tr>
<td>CHANGE IMAGE</td>
<td>Lets you associate an image with the selected track. This is useful if you want to include album artwork when you upload your music.</td>
</tr>
<tr>
<td>ADD TRACK</td>
<td>Adds new tracks to the current playlist.</td>
</tr>
<tr>
<td>DELETE TRACK</td>
<td>Deletes selected tracks from the current playlist.</td>
</tr>
<tr>
<td>PUBLISH</td>
<td>Once your player has been configured and your playlist is put together, click Publish to upload your files to the Internet.</td>
</tr>
</tbody>
</table>

Table 20.
New features in SONAR 8.5

SONAR 8.5 has many new features (some features are in SONAR Producer only). The following is a list and description of each new feature.

**New sound shaping effects:**

- PX-64 Percussion Strip .................................................. 123
- VX-64 Vocal Strip ......................................................... 124
- Session Drummer 3 ....................................................... 125
- Alias Factor ................................................................. 126
- Classic Phaser .............................................................. 126
- HF Exciter ................................................................. 127
- Mod Filter ................................................................. 127
- Multivoice Chorus/Flanger ............................................. 127
- Para-Q ................................................................. 128
- Stereo Compressor/Gate ................................................ 128
- Stereo Delay ............................................................... 129
- Studioverb2 .............................................................. 129
- New Impulse Responses for Perfect Space ..................... 129

**MIDI enhancements:**

- Step Sequencer 2.0 ................................................... 130
- Integrated arpeggiator .................................................... 131
- Support for more MIDI ports ........................................ 131
Recording and mixing enhancements:

Matrix view ................................................................. 132
REX file import .......................................................... 133
Freeze and Archive buttons in Track view ....................... 133
New Freeze option ......................................................... 134
Solo track/bus from plug-in window ............................... 134
Insert Send Assistant enhancements ............................... 135
DC offset meter in Analyst ............................................. 136

Editing enhancements:

AudioSnap 2.0 ............................................................... 137
TAB to transients .......................................................... 138
Auto Scroll Lock in Clips pane ...................................... 138
Clips pane vertical grid lines ........................................ 138

Transport enhancements:

Draggable Now Time marker ........................................ 138

Miscellaneous enhancements:

Change I/O devices without restarting SONAR .................. 139
VST plug-in compatibility options .................................. 139
Media Browser enhancements ...................................... 140
**PX-64 Percussion Strip**

**Note:** The PX-64 Percussion Strip plug-in is only available in SONAR Producer.

---

**Figure 21. PX-64 Percussion Strip**

*PX-64 Percussion Strip* is a multi-functional plug-in that combines a series of effects specifically optimized and streamlined for drum and percussion processing. Combining transient shaping, compression, expansion, equalization, delay and tube saturation in one convenient plug-in, *PX-64 Percussion Strip* is designed to make it fast and easy to enhance any drum or percussion track.

For more information, see the *PX-64 Percussion Strip* online Help.
VX-64 Vocal Strip

Note: The VX-64 Vocal Strip plug-in is only available in SONAR Producer.

Figure 22. VX-64 Vocal Strip

VX-64 Vocal Strip is a multi-functional plug-in that combines a series of effects specifically optimized and streamlined for vocal processing. Combining compression, expansion, equalization, deessing, doubling, delay and tube saturation in one convenient plug-in, VX-64 Vocal Strip is designed to make it fast and easy to enhance any vocal track.

VX-64 Vocal Strip features include:

- 5 professional quality effect modules, each with its own bypass toggle.
- All modules are specifically tuned for vocal processing.
- Advanced tube saturation modeling available on input, output and EQ modules.
- Deesser with switchable center frequency and threshold.
- Configurable effect chain routing.
- Smooth, zipperless automatable parameters.
- Library of presets.

For more information, see the VX-64 Vocal Strip online Help.
Session Drummer 3

**Note:** The Session Drummer 3 synth is only available in SONAR Producer.

**Figure 23.** Session Drummer 3

Session Drummer 3 is a professional drum sampler and pattern player. It features Cakewalk’s patented Expression Engine technology, an anti-aliased, real-time sound production system for multisample audio playback. Session Drummer 3 accurately replicates the sound of its real-world counterpart and features a highly-detailed user interface as well as simple but powerful controls. You can load single samples (Wave or AIFF files), or multisamples (SFZ files) which already contain key mapping and velocity switching assignments. You can load samples in any bit depth and sample rate, in mono or stereo, in looped or unlooped format. Wave and AIFF files can be loaded directly, or as a sample inside an SFZ definition file.

Samples can be of any bit depth (8 to 32-bit), any sample rate, and either mono or stereo. Each sample in a multisample can be a standard PCM Windows Wave file (.wav), an Apple audio format (.aiff) or a compressed file in the standard, high-quality, open and royalty-free ogg-vorbis format (.ogg).

Alternatively, it is possible to open multisample definition files (.sfz) or individual samples by dragging them to an instrument pad.

Session Drummer 3 features include:

- MIDI pattern playback.
- Multi-velocity acoustic and electronic drum kits.
- A comprehensive collection of presets and MIDI-based loop files, providing you with a creative jump-start.
• An animated user interface (UI).
• Controls for volume, pan and tuning of each drum kit piece.

For more information, see the Session Drummer 3 online Help.

---

**Alias Factor**

**Figure 24. Alias Factor**

*Alias Factor* combines bit crushing and low pass filtering in a unique way, allowing you to decimate your audio to create tones as varied as vintage samplers, cell phones, or old video games. Decimator effects are nothing new, but *Alias Factor* generates this effect using a special technique that generates aliasing without the unwanted harsh effects provided by other options, offering sounds that are grainy in a “smooth” and organic way. *Alias Factor* also allows for further creation of attention grabbing new timbres by linking a low pass resonant filter to the decimator for a new means of tweaking your sound.

For more information, see the *Alias Factor* online Help.

---

**Classic Phaser**

**Figure 25. Classic Phaser**

This is a classic phaser effect that uses a modulating notch filter with a feedback loop. The “Quadra” mode provides extra wide imaging and animation.

For more information, see the *Classic Phaser* online Help.
**HF Exciter**

*Figure 26.  HF Exciter*

*HF Exciter* lets you enhance the higher end of the frequency spectrum. This produces the psycho-acoustic affect that the signal is brighter and clearer. This is done by adding harmonic content that is not present in the original signal.

For more information, see the *HF Exciter* online Help.

---

**Mod Filter**

*Figure 27.  Mod Filter*

*Mod Filter* produces a dynamic filtering effect, in that the actual filter can respond to incoming signal or follow the cycle of a tempo-synchronized LFO. The filter itself is a low-pass filter type, which filters out higher frequencies.

For more information, see the *Mod Filter* online Help.

---

**Multivoice Chorus/Flanger**

*Figure 28.  Multivoice Chorus/Flanger*

*Chorus/Flanger* lets you add depth and thickness to the signal. The EQ section in the feedback path allows you to create some truly unique sounds.

For more information, see the *Multivoice Chorus/Flanger* online Help.
Para-Q

Figure 29. Para-Q

Para-Q is a two-band true parametric EQ that can be used to boost or attenuate generally high or low bands of the signal. It consumes very little processing power, which allows you to use it on many tracks simultaneously.

For more information, see the Para-Q online Help.

Stereo Compressor/Gate

Figure 30. Stereo Compressor/Gate

Stereo Compressor/Gate combines a compressor and a gate into a single effect, so you can increase the overall dynamic level of an audio signal, without distorting the loud parts, and without excessively boosting low-level noise. You can manually trigger the gate via MIDI, which makes it simple to produce stuttering effects.

For more information, see the Stereo Compressor/Gate online Help.
Stereo Delay

Figure 31. Stereo Delay

Stereo Delay produces a tempo-synchronized echo on whichever channel it is patched to. The three-band EQ section in the feedback path allows you to create some truly unique sounds.

For more information, see the Stereo Delay online Help.

Studioverb2

Figure 32. StudioVerb2

Studioverb2 provides very dense and warm reverberation with 32-bit floating point implementation. This eliminates the digital grunge and harshness that occurs even in the best studio reverberation systems, which are implemented using less advanced fixed point processing. The Studioverb2 provides extremely high efficiency, typically using half of the CPU load of other premium reverb plug-ins.

For more information, see the StudioVerb 2 online Help.

New Impulse Responses for Perfect Space

SONAR 8.5 includes many new impulse responses for Perfect Space. For information about using impulse responses, see the Perfect Space online Help.
Step Sequencer 2.0

The enhanced Step Sequencer makes it easier than ever to compose patterns using a grid. New enhancements include:

- The Step Sequencer interface has been streamlined to be more efficient and powerful.
- The Step Sequencer is no longer dependent on drum maps, and rows can be assigned directly to the track output, or any available software instrument.
- Option to preserve the original timing of note events when converting a MIDI clip to a step sequencer clip.
- Per note flam and time offset.
- Style settings, such as Duration, Swing, Time offset, Flam, and Slide/Portamento can be adjusted per row.
- Velocity is now displayed as a vertical bar inside the step.
- Ability to edit multiple rows simultaneously.
- All modulation controls are per row.
- Dedicated **Step Recording** button.
- Preview Step Sequencer patterns in the Media Browser view.

**Figure 33.** Step Sequencer

Some of the editing gestures have changed slightly, so be sure to read the “Step Sequencer View” online Help topic for complete details.
Integrated arpeggiator

Each MIDI and instrument track has its own integrated arpeggiator, visually located in the Track view. The arpeggiator lets you play intricate patterns of notes that would otherwise be extremely difficult or impossible to play manually and at speeds and octave ranges that exist beyond the physical limitations of the player or keyboard range.

Arpeggiated events are new events that are based on notes that you play on your controller keyboard. The new events are rhythmically and harmonically specified by the arpeggiator’s preset, allowing you to “play” an endless variety sophisticated musical passages with simple key pressing.

The most significant capability of the arpeggiator is its ability to apply algorithmic variations on your input as well as MIDI-based patterns.

Figure 34. Each MIDI and instrument track has an integrated arpeggiator.

For details, see the “Arpeggiator” online Help topic.

Support for more MIDI ports

The maximum number of MIDI ports that can be used simultaneously has been increased from 64 to 256.
Matrix view

The Matrix view is only available in SONAR Producer.

The Matrix view lets you trigger individual or multiple audio and MIDI patterns, either with a computer keyboard, mouse or via MIDI remote control. The Matrix view consists of a grid, with unlimited rows and columns. You can drag audio, MIDI Groove Clips, Step Sequencer patterns and Project5 patterns to cells in the grid, and each row can be routed to any track in your project. You can record the Matrix performance to the Clips pane.

The Matrix view can be used as a stand-alone pattern trigger, or it can be synchronized with your project during playback.

There are many uses for the Matrix view, including:

- Experiment with different arrangements or combinations of loops, then record the performance into the Clips pane.
- Trigger any combination of loops in real-time

Figure 35. The Matrix view

For details, see the “Matrix view” online Help topic.
REX file import

**Note:** REX file import is currently not supported under SONAR x64.

Like ACIDized WAVE files, REX files are audio files that are designed to be looped and follow the project’s tempo. The time stretching technology that REX files use is well suited for percussive sounds, such as drums.

You can import REX files into a SONAR project. Once imported, you can work with REX files just as if they were regular Groove Clips (see Working Groove Clip audio).

For details, see the “Working with REX files” online Help topic.

Freeze and Archive buttons in Track view

SONAR 8.5 makes it easier than ever to archive and freeze tracks by providing per-track Archive and Freeze buttons in the Track view.

You can also right-click any Freeze button to open the Freeze Options dialog.

**Figure 36.** Freeze and Archive buttons have been added to the Track view

A. Archive button   B. Freeze button

For details, see the “To archive or unarchive tracks” and “Freeze Tracks and Synths” online Help topics.
# New Freeze option

The **Freeze Options** dialog has a new **Track FX** option, which allows you to either include or exclude track FX bins during freeze operations.

When freezing AudioSnap clips in order to conserve CPU resources, it is often desirable to not render track FX bins.

## Solo track/bus from plug-in window

When tweaking an effect, it is often desirable to only hear the audio that is passing through the effect.

A **Solo** button is available on all plug-in property pages, which allows you to quickly solo the track or bus that the effect is inserted on while adjusting the plug-in. The **Solo** button functions the exact same way as the **Solo** button on the source track/bus.

**Figure 37.** A **Solo** button is available on each plug-in property page

![A Solo button is available on each plug-in property page](image)

**A. Solo button**

**Note:** If you solo a software instrument in the Synth Rack, the **Solo** button will also affect all associated MIDI and audio tracks.
Insert Send Assistant enhancements

The **Insert Send Assistant** dialog has an improved layout and a new **Match Track’s Pan and Gain** option that makes it easier to create headphone mixes.

**Figure 38. The Insert Send Assistant dialog**

When **Match Track’s Pan and Gain** is selected, the newly created send will have Gain and Pan settings that match those of the strip’s Main Gain and Pan. As a result, the headphone mix matches the main mix, and from there you can adjust the headphone mix as desired.

**Note:** The **Match Track’s Pan and Gain** setting does not affect sends that are assigned to surround buses.

For details, see the “Insert Send Assistant (DD2; new S8.5)” online Help topic.
The DC offset meter is a bi-directional bargraph meter that lets you detect DC offset in audio. There are various ways DC offset can be introduced into a mix. DC offset can come from recording sources, software instruments, or it could be present in imported wave files. Although the effect of DC offset is normally impossible to hear, it can produce some very unwanted side-effects, including:

- Loss of apparent loudness in mix. Because the audio in the final mix is skewed positive or negative, you run out of headroom sooner and must reduce gain to compensate.
- Loss of quality when using mastering compression. Because the waveform is off-center, a compressor will asymmetrically alter the waveform producing low frequency harmonic distortion.
- The DC is essentially sub-sonic information that will affect the lowest band of any multi-band processing.

To check your audio for DC offset in real-time before exporting/mastering, patch Analyst in a mix bus. Ideally, the DC offset meter should appear as a small dot in the middle of the scale. As the DC offset in the input signal moves away from 0dB, the DC offset meter bar lengthens up or down, indicating either a positive or negative DC offset. As the DC offset becomes larger, the color of the meter bar changes from blue to red. The scale of the meter is -50% to +50% dbFS.

For information about removing DC offset, see the “Removing DC Offset” online Help topic.
AudioSnap 2.0

AudioSnap 2.0 provides simplified workflow and introduces many enhancements that make it easier to fix timing problems in audio and align audio with the project tempo.

AudioSnap 2.0 highlights include:
• Audio clips are always ready to be processed via AudioSnap, without having to first enable AudioSnap on clips.
• A dedicated Transient tool that makes it easier to select and edit transient markers.
• A streamlined AudioSnap palette.
• Each audio clip has an internal tempo map that can be edited.
• Synchronize audio to the project tempo in one simple step.
• Synchronize the project tempo to an audio clip’s tempo map in one simple step.
• Simplified workflow for fixing multi-track audio while maintaining phase relationships.
• Enhanced TAB to transients.
• Improved real-time stretching algorithms.
• Ability to stretch multiple transients proportionally.
• You can snap edits to any transient marker (no longer limited to the Pool).

For more information about AudioSnap, see the “AudioSnap” online Help topic.
**TAB to transients**

You can use the TAB and SHIFT+TAB keys to jump to audio transients, and MIDI Note events. In SONAR 8.5, TAB to transients is always available when the transport is idle, and is no longer dependent on AudioSnap.

TAB to transients is now selection-based, which means tabbing will go to the next/previous transient amongst all selected clips. If there is no selection, tabbing operates on the current track.

To move the Now Time to the next transient, press TAB.

To move the Now Time to the previous transient, press SHIFT+TAB.

For details, see the “TAB to transients” online Help topic.

**Auto Scroll Lock in Clips pane**

While editing, you can prevent the Clips pane from scrolling horizontally during playback. This allows you to focus on the edit location without worrying that the screen will eventually scroll away from the edit location.

When the **Left Click Locks Scroll** option is enabled (default behavior), the Clips pane will not scroll if you click any object in the Clips pane. When you are done with the edit and want the Clips pane to scroll again during playback, click in the background of the Clips pane to clear auto scroll lock.

For more information, see the online Help topic “Auto Scroll Lock in Clips pane”.

**Clips pane vertical grid lines**

Vertical rules in the Clips pane can be hidden, shown behind clips or shown in front of clips.

For more information, see the online Help topic “To show/hide vertical grid lines”.

**Draggable Now Time marker**

You can drag the Now Time marker during playback. When the mouse button is released, the transport immediately jumps to the new location.

**Note:** You can only drag the Now Time marker during playback, not while recording.
Change I/O devices without restarting SONAR

You can add or remove USB/FireWire audio and MIDI devices while SONAR is running, and the audio and MIDI engines will dynamically respond to any changes.

When a device is added or removed, SONAR prompts you to confirm or cancel the change. If you click Yes, playback stops and the audio and MIDI engines reload.

For more information, see the online Help topic “Changing I/O devices”.

VST plug-in compatibility options

The Cakewalk Plug-in Manager has two new per plug-in properties to address some common VST operational and performance issues:

- **Always suspend on play.** When Always suspend on play is selected, the plug-in will reset when playback starts. Select this option for any VST instruments that have problems with stuck notes when stopping the transport. The Always suspend on play property is also useful for effects that generate a tail, such as delays and reverb. The effect is that you will hear the tails when the transport stops, but not when the transport rolls again. Always Suspend on play is disabled by default.

- **Serialize Host Access.** When Serialize Host Access is selected, communications with the plug-in are serialized as far as possible. The default behavior is OFF, which allows asynchronous calls to the plug-in.

  When Serialize Host Access is disabled, SONAR’s audio engine runs more efficiently and allows the UI thread to interact independently with the plug-in GUI without impacting the audio engine.

  The only reason to enable Serialize Host Access would be for a plug-in that has thread safety problems leading to crashes or glitches when changing plug-in presets.

BitBridge enhancements

Cakewalk’s BitBridge technology allows you to use 32-bit VST effects and instruments when using the x64 version of SONAR.

Earlier versions of SONAR x64 could load only up to 4GB worth of 32 bit plug-ins. SONAR can now use all addressable RAM in your computer.

BitBridge now also supports VST’s that generate MIDI.
**jBridge support**

Similar to BitBridge, jBridge allows you to use 32-bit VST effects and instruments when using the x64 version of SONAR, as well as use 64-bit plug-ins when using the x86 version of SONAR. jBridge can also bridge 32-bit plug-ins in the x86 version of SONAR, allowing your computer to overcome the memory limitations of a single 32bit process.

To enable jBridge, select the **Load using jBridge wrapper** check box in the **VST Plug-In Properties** dialog. This check box is only enabled on systems where jBridge is installed.

For information about adjusting VST settings, see the online Help topic “To set options for individual VST plug-ins (DD2; new S8.5)” and the Cakewalk Plug-in Manager online Help.

---

**Media Browser enhancements**

**Note:** *The Loop Explorer view is now called the Media Browser view.*

The Media Browser view has the following new enhancements:

- You can preview Project5 patterns (.ptn), step sequencer patterns (.ssp) and REX loops (.rex).
- You can preview MIDI and audio files simultaneously.
- You can simultaneously preview multiple files in different folders.
- You can save and recall Content Location presets to quickly access your favorite folders.
- You can drag video files to the Video Thumbnail pane.

For more information, see the online Help topic “Media Browser enhancements (DD3; new S8.5)”.
Troubleshooting

If you’re having a problem with SONAR, don’t panic. This chapter lists some common problems and how to solve them.

If you don’t find an answer here, there are two other important places to look for help:

• Check the ReadMe file that came with your software. It contains additional information that wasn’t available when this User’s Guide was printed. To view the Readme file, select Help > View README.RTF.

• Visit our website at www.cakewalk.com, where you’ll find answers to frequently asked questions, tech support documents, program patches and updates, and more.

Frequently Asked Questions

Audio dropouts or crash when playing back large files at maximum latency 142
When I Play a File, I Don’t Hear Anything ................................. 143
I Can’t Record from My MIDI Instrument ................................ 144
When I Play a File Containing Audio, the Audio Portion Doesn’t Play . 145
I Can’t Record Any Audio. .......................................................... 146
The Music Is Playing Back with the Wrong Instrument Sounds......... 146
My Keyboard Doubles Every Note I Play ...................................... 147
I Don’t See the Clips Pane in the Track View ............................... 147
Why Can’t SONAR Find My Audio Files? ..................................... 147
Why Do I Get Errors from the Wave Profiler? ............................... 148
My Track or Bus Fader is Maximized, But There’s No Sound or Level . 148
How Do I Use SONAR to Access All the Sounds on My MIDI Instrument? 149
I Hear an Echo When I Record .................................................. 149
Dropouts Happen in High Bit-depth or High Sample Rate Audio ....... 150
Patching an Effect into SONAR Causes a Dropout ....................... 150
Audio dropouts or crash when playing back large files at maximum latency

**Symptom:** after several seconds of playback the audio begins to cut out, although the transport appears to keep rolling. If the project file is loaded with several plug-ins you may experience a crash.

**Solution:** if you ever set the Buffers Size field on the General tab of the Audio Options dialog so that the buffer size exceeds the disk buffer size, audio won't play properly. If you want latency that high you must also increase the disk buffer size: in the Audio Options dialog, on the Advanced tab, try increasing the I/O Buffer Size (KB) field by blocks of 128 KB.
When I Play a File, I Don’t Hear Anything

Open a project (.cwp) and click the Play button. If you don’t hear any music, try the following suggestions:

<table>
<thead>
<tr>
<th>Possible problem</th>
<th>What to do</th>
</tr>
</thead>
<tbody>
<tr>
<td>Your speakers aren’t connected properly or the volume is turned down.</td>
<td>Make sure your speakers are on and the volume is turned up.</td>
</tr>
<tr>
<td>Your sound card isn’t hooked up correctly.</td>
<td>See if other programs play sound correctly through your speakers. A good program to try is the Media Player ([Start &gt; Programs &gt; Accessories &gt; Entertainment &gt; Windows Media Player]). If other programs do not work, check your sound card documentation to make sure the card is properly installed and configured.</td>
</tr>
<tr>
<td>You don’t have Bank and Patch settings in your MIDI track</td>
<td>Check the Bank and Patch settings for each track. Make sure that each track has a Bank and Patch assigned to it.</td>
</tr>
<tr>
<td>You don’t have an Output setting</td>
<td>Check Output settings for each track. Make sure that each MIDI track is assigned to a MIDI output which is connected to a MIDI device capable of playback. Make sure each audio track is assigned to an output that is connected to your speaker system.</td>
</tr>
<tr>
<td>No MIDI output device is selected.</td>
<td>Choose Options &gt; MIDI Devices, and check the Output device list. Make sure that your computer sound card is highlighted and at the top of the list. If this doesn’t work, try choosing different output devices, one at a time, to see if any of them produces sound.</td>
</tr>
<tr>
<td>Your sound card or MIDI interface is not set up correctly.</td>
<td>Make sure you have installed and tested each card according to the manufacturer’s instructions.</td>
</tr>
<tr>
<td>You may have too many MIDI drivers.</td>
<td>Make sure you only install the drivers that you need, and remove any old or unused drivers. To access the driver list, choose Start &gt; Settings &gt; Control Panel, then double-click Multimedia and click on the Advanced tab.</td>
</tr>
<tr>
<td>Your MIDI driver is incorrect or outdated.</td>
<td>Make sure that the driver you have installed is the correct driver for your hardware. Also try downloading and installing the latest driver release from your hardware manufacturer.</td>
</tr>
<tr>
<td>Your MIDI driver is configured incorrectly.</td>
<td>Make sure the driver’s IRQ and port address settings match the physical settings on the card.</td>
</tr>
</tbody>
</table>

Table 21.

If none of these suggestions works, check our website for additional suggestions or contact technical support.
I Can’t Record from My MIDI Instrument

If you are unable to record music from your electronic keyboard, synthesizer, or other MIDI instrument, first test to see if you are able to play back a project through the keyboard. Then try the following:

<table>
<thead>
<tr>
<th>Possible problem</th>
<th>What to do</th>
</tr>
</thead>
<tbody>
<tr>
<td>No MIDI input device is selected.</td>
<td>Choose <strong>Options &gt; MIDI Devices</strong>, and check the Input device list.</td>
</tr>
<tr>
<td></td>
<td>Make sure that the MIDI input on your computer sound card is highlighted.</td>
</tr>
<tr>
<td>Your MIDI cables are reversed.</td>
<td>Make sure that the MIDI Out plug is connected to the MIDI In jack on your keyboard and that the MIDI In plug is connected to the MIDI Out jack on your keyboard.</td>
</tr>
<tr>
<td>SONAR is not receiving MIDI data.</td>
<td>Check the MIDI Input/Output Activity monitor 📊 on the Windows Status bar. Check to see if the left LED is flashing red. If not, then SONAR is not receiving MIDI data. Check your connections and try again.</td>
</tr>
<tr>
<td>You have not set up SONAR to record.</td>
<td>Make sure that 1) you have chosen an input for the track; 2) you have armed the track for recording; and 3) you have pressed the <strong>Record</strong> button, and not the <strong>Play</strong> button.</td>
</tr>
</tbody>
</table>

If none of these suggestions works, check our web site for additional suggestions or contact technical support.
When I Play a File Containing Audio, the Audio Portion Doesn’t Play

Open a bundle file (.cwb) and click the Play button. Do you hear the audio tracks in the project (there may be MIDI tracks in the bundle file, so you must mute them). If not, try the following:

<table>
<thead>
<tr>
<th>Possible problem</th>
<th>What to do</th>
</tr>
</thead>
<tbody>
<tr>
<td>Your speakers aren’t connected properly, or the volume is turned down.</td>
<td>Make sure your speakers are connected properly and the volume is turned up.</td>
</tr>
<tr>
<td>Your sound card isn’t hooked up correctly.</td>
<td>Run the Microsoft Sound Recorder (Start &gt; Programs &gt; Accessories &gt; Entertainment &gt; Sound Recorder). Open any wave file and see if it plays sound correctly through your speakers. If not, check your sound card documentation to make sure the card is properly installed and configured.</td>
</tr>
<tr>
<td>The volume setting is turned down on your software mixer.</td>
<td>Double-click on the yellow speaker icon in the Windows task bar to display the mixer, and make sure all the volume settings are turned up and that none are muted.</td>
</tr>
<tr>
<td>Your audio tracks are assigned to the wrong output.</td>
<td>Check the output assignment for your audio tracks in the Track pane.</td>
</tr>
<tr>
<td>SONAR doesn’t recognize your sound card.</td>
<td>Choose Options &gt; Audio, click the General tab, and then click the Wave Profiler button to test your audio hardware. Then, re-open the bundle file and try again.</td>
</tr>
</tbody>
</table>

Table 23.

If none of these suggestions works, check our website for additional suggestions or contact technical support.
I Can’t Record Any Audio

If you are unable to record audio through your sound card, try the following suggestions:

<table>
<thead>
<tr>
<th>Possible problem</th>
<th>What to do</th>
</tr>
</thead>
<tbody>
<tr>
<td>The track is not set up to receive audio input.</td>
<td>Make sure that the input for the track you are recording (in the Track view) is set to an Audio input before recording.</td>
</tr>
<tr>
<td>The software mixer is not set up properly.</td>
<td>Double-click on the speaker icon in the Windows task bar to display the mixer. Choose Options &gt; Properties, select Adjust Volume for Recording, and click OK. Make sure the appropriate Select boxes have checkmarks and the input volume is turned up.</td>
</tr>
<tr>
<td>Your sound card isn’t hooked up correctly.</td>
<td>Try recording audio using the Microsoft Sound Recorder (Start &gt; Programs &gt; Accessories &gt; Entertainment &gt; Sound Recorder). If it fails, check your sound card documentation to make sure it is properly installed and configured.</td>
</tr>
<tr>
<td>You have not set up SONAR to record.</td>
<td>Make sure that 1) you have chosen an input for the track; 2) you have armed the track for recording; and 3) you have pressed the Record button, and not the Play button.</td>
</tr>
</tbody>
</table>

Table 24.

If these suggestions don’t work, check our website for additional suggestions or contact technical support.

The Music Is Playing Back with the Wrong Instrument Sounds

If the tracks in your project are assigned to the same MIDI output and channel, the same sound will be used for all of them. To fix this problem, simply assign each track to a different channel (using the Channel control in the Track view), and then choose the sound (or patch) you want to use for each one. If you are playing songs through your MIDI keyboard or synthesizer, you need to 1) check that your instrument is able to receive MIDI data on multiple channels, and 2) configure your instrument to play a different patch on each channel (this is called Multi Mode on many instruments). See the documentation for your instrument for more information.

Another possibility is that you are playing back a GM (General MIDI)-authored MIDI file on a non-GM compatible device.
My Keyboard Doubles Every Note I Play

When your keyboard doubles the notes, each note seems heavier or thicker than usual, as if two notes of the same pitch are emitted when you press the key. Also, you may find that you can play only half as many notes at one time before some of the held notes drop out.

This can occur when MIDI echo is enabled. The keyboard plays the note for the key you’ve pressed. At the same time, the note is sent through the MIDI interface and echoed back to the keyboard, where it is played a second time.

The best way to resolve the problem is to disable Local Control on the keyboard, following the instructions that came with the keyboard. This stops the keyboard from playing independently. The keys you play still produce sound on the keyboard because they are echoed back by the MIDI interface. In many cases, SONAR disables local control automatically when the program is started, but this is not always possible.

It’s also possible that your keyboard is transmitting information on two channels at once. To see if this is so, create a new project and record two notes from the keyboard. Then look at what you’ve recorded in the Event list view. If you see four notes displayed instead of two, then your keyboard is transmitting on two channels. See the documentation for your keyboard to learn how to correct the problem.

I Don’t See the Clips Pane in the Track View

The splitter bar may be so far to the right that the Track pane fills the entire Track view. Here’s how to solve the problem:

1. Place your cursor over the splitter bar. It is located on the far right side of the Track view, just to the left of the vertical scroll bar. When you place the cursor over the splitter it changes to a double-headed arrow.

2. Click and drag the splitter bar to the left. You should be all set.

Why Can’t SONAR Find My Audio Files?

SONAR looks for all audio data in a certain directory or folder, called the Data Directory, in Cakewalk Projects (or the WaveData Directory in previous versions of Cakewalk products). If you have renamed or moved either SONAR or the Data Directory, SONAR may not be able to find your audio files. If you know where the audio files are stored, choose Options > Audio, click Advanced and enter the full path name of the directory in the Data Directory box. If you don’t know where the audio data are stored, choose Start > Find > Files or Folders and search for files named *.wav.

For more information about the wavedata folder, see the online Help topic “Audio File Management”.
Why Do I Get Errors from the Wave Profiler?

Audio devices such as voice modems or speakerphone devices can cause an error message when running the Wave Profiler. Sometimes these errors are harmless; on other occasions you need to disable the voice modem or speaker-phone device before running the Wave Profiler. To do so:

1. Choose Options > Audio and click the Drivers tab.
2. Make sure that the voice modem or speaker-phone device is not selected in both the Input and Output device lists.
3. Click OK.
4. Choose Options > Audio, click the General tab, and run the Wave Profiler again.

My Track or Bus Fader is Maximized, But There’s No Sound or Level

SONAR has two modes that govern how fader levels function: Envelope Mode and Offset Mode. In Envelope Mode, any envelopes in the track or bus control the level, and ignore any movements you make to the fader. In Offset mode, any envelopes in the track or bus add their level to any level that the fader contributes. For example, the level you see in the Vol field of a track’s properties combines with the levels that any volume envelope in that track produces as the track plays. When you switch back to Envelope mode, any level that the Vol field displays while in Offset mode continues to combine with any envelope in the track, but does not show in the Vol field while you’re in Envelope mode. So, if you have a large negative value such as -INF in the Vol field, even though the volume envelope is at its maximum level, the sum of the two values is still inaudible because the negative value is so large.

Whenever you have mysterious levels in a track or bus, click the Envelope/Offset Mode button that is in the Automation toolbar to switch modes (or press O in the Track or Console views), and then look in the track or bus property fields to see what values show. Change the values to neutral ones if you don’t want them to affect your levels.
How Do I Use SONAR to Access All the Sounds on My MIDI Instrument?

SONAR is normally set up to access the 128 sounds that are part of the General MIDI standard. SONAR also includes custom instrument definitions that match the sounds on many popular instruments. To use a custom instrument definition:

1. Choose Options > Instruments to display the Assign Instruments dialog box.
2. Click the Define button to display the Define Instruments and Names dialog box.
3. Click Import, and then choose the file for the manufacturer of your instrument.
4. Choose your instrument from the list and click OK.
5. Click Close to return to the Assign Instruments dialog box.
6. Select from the Output/Channel list all the outputs and channels that are being sent to that instrument.
7. Click on the instrument in the Uses Instrument list.
8. Click OK when you are done.

If your manufacturer or instrument doesn’t appear, check our web site to see if an updated instrument definition is available. You can also create your own instrument definition. For more information about instrument definitions, see the online help topic: Instrument Definitions.

I Hear an Echo When I Record

If you have input monitoring enabled, when you play an instrument that is plugged into your sound card, you hear the direct signal that goes straight through your sound card, and an instant later you hear the sound that is processed by SONAR, including any plug-in effects you may be using. Only the processed sound is recorded.

You can eliminate the echo in either of two ways:

• Mute the direct signal so you only hear the sound that is processed by SONAR. If you choose this method, you may hear too much of a lag between the time you play your instrument and the time you hear it, depending on the latency of your system (using WDM audio drivers is a great way to achieve lower latency).

• Disable input monitoring so you only hear the raw signal that’s coming through your sound card. If you choose this method, you won’t hear any plug-in effects you may be using.

To disable input monitoring:

• On the track where you want to disable input monitoring, click the track’s Input Echo button so that it is in the off position:
To mute your sound card’s direct sound:

1. Open the software mixer that controls your sound card. If your sound card uses the Windows mixer, open the mixer by using the Start > Programs > Accessories > Entertainment > Volume Control command, or by double-clicking the speaker icon on the Windows taskbar.

2. In the Play Control window of the mixer, check the Mute check box in the Line-In column, or in the column of whatever jack your instrument is plugged into, and close the mixer window.

---

**Dropouts Happen in High Bit-depth or High Sample Rate Audio**

If you are hearing consistent dropouts/clicks in your audio and if your project contains high bit depth (32/64 bit) or high sample rate audio (88.2K or higher), it may be indicative of a too small I/O buffer size. If so try a higher I/O buffer size like 256 or 512. If audio problems persist, reset to 128 and try a different remedy.

Use the Options > Audio command to open the Audio Options dialog, click the Advanced tab, and in the I/O Buffer Size (KB) field, enter 256 or 512.

---

**Patching an Effect into SONAR Causes a Dropout**

You may have simply reached the maximum number of tracks and effects your CPU can handle. However, if your CPU meter doesn’t appear to be maxed out, or other plug-ins seem to work, you may need to address the problem by editing a line in the Aud.ini file.

Using Notepad, open the Aud.ini located in the directory where you installed SONAR. The default value of the ExtraPluginBufs variable is 0. Try changing that value to 1, saving Aud.ini and patching in the effect that caused the dropout. If it still causes a dropout, try changing the value in ExtraPluginBufs to 2. Continue to double the value in this variable until you reach 128 (4, 8, 16, 32). If a value of 128 does not fix the problem, it is time to try something else. See Dropouts and Other Audio Problems in the online help for more information about potential reasons for dropouts.
I Can’t Open My Project

Your project may have become corrupted. You can attempt to open the project using Safe Mode.

To Use Safe Mode

- If you are opening a file from the Most Recently Used files list in the File menu, hold down the SHIFT key while selecting file name.
- If you are opening the file from the Open dialog, select the file in the dialog and hold down the SHIFT key while clicking the OK button.

Safe Mode does the following:
- Opens only the Track view.
- Prompts you if you want to open the plug-ins saved with your project. Each plug-in gets a prompt, so you can open some and not open others.

Audio Distorts at Greater than 16 Bits

There are several settings in the Audio Options dialog box (Options > Audio command) you need to set before using audio formats greater than 16. See “System Configuration” on page 847.
No Sound from My Soft Synth

Use the following table to troubleshoot problems hearing a synth in SONAR:

<table>
<thead>
<tr>
<th>Possible problem</th>
<th>What to do</th>
</tr>
</thead>
<tbody>
<tr>
<td>Synth doesn’t sound when a recorded MIDI track is sent to it.</td>
<td>• Make sure you select a MIDI channel in the MIDI track’s <strong>Output</strong> field; you may also need to select a <strong>Patch</strong> and <strong>Bank</strong>.</td>
</tr>
<tr>
<td></td>
<td>• Make sure that neither the MIDI track nor the audio track that contains the synth are muted.</td>
</tr>
<tr>
<td></td>
<td>• Make sure the MIDI notes are in the right range for the synth’s patch.</td>
</tr>
<tr>
<td>Synth patched into a main out or bus doesn’t sound.</td>
<td>• Make sure that at least one audio track is configured to send data to that bus.</td>
</tr>
<tr>
<td></td>
<td>• Make sure that the <strong>Audio Engine</strong> button in the <strong>Transport</strong> toolbar is depressed.</td>
</tr>
<tr>
<td>Soft synth doesn’t sound when you play a MIDI controller.</td>
<td>• Make sure that the <strong>Audio Engine</strong> button in the <strong>Transport</strong> toolbar is depressed.</td>
</tr>
<tr>
<td></td>
<td>• Make sure that the MIDI track that has the focus lists the soft synth in its <strong>Output</strong> field.</td>
</tr>
<tr>
<td></td>
<td>• If you patched the soft synth into an audio track, make sure that track is not muted.</td>
</tr>
<tr>
<td></td>
<td>• If you patched the soft synth into a bus, make sure that at least one audio track is configured to send data to that bus.</td>
</tr>
<tr>
<td></td>
<td>• Make sure you’re playing in the right range for the soft synth’s patch.</td>
</tr>
<tr>
<td>I hear more than one sound when I play a soft synth.</td>
<td>• Make sure your MIDI controller is set to local off.</td>
</tr>
</tbody>
</table>

Table 25.
My Pro Audio 9 Files Sound Louder/Softer When I Open Them in SONAR

Pro Audio 9 has a setting in the Audio Options dialog box called MIDI Volume Mapping. This setting determines how many dB that a movement of a volume fader produces. This setting is not stored in each project file, so SONAR can’t tell precisely what dB scale was used to produce the file you’re opening. If the volume sounds incorrect:

1. Open SONAR’s Aud.ini file (find it in your SONAR folder and double-click it).
2. Change the line that says VolMethod=n. If n=1, change n to 0; if n=0, change n to 1.
3. Save the file and close it.
4. Reopen the Pro Audio file in SONAR. If the volume sounds correct, save the file in SONAR. If other Pro Audio 9 files were opening correctly in SONAR, change the VolMethod=n line in SONAR’s Aud.ini file back to what it originally was, and re-save the file.

SONAR Can’t Find the Wavetable Synth or MPU401

Follow this procedure:

1. Open the Audio Options dialog (Options > Audio command), and on the Advanced tab, check the Always Use MME Interface, Even When WDM Drivers Are Available option.
2. Click OK to close the dialog.
3. Close SONAR and reopen it.
4. Use the Options > MIDI Devices command to open the MIDI Devices dialog.
5. Highlight the Wavetable synth and/or the MPU401 (or whatever synth your sound card contains).
6. Click OK to close the dialog.

Now your sound card synth and/or the MPU401 should appear in the drop-down menus of the Output fields of your MIDI tracks.

I Get an Error Message When I Change a Project to 24-bit Audio

Some audio devices, especially USB devices that use WDM drivers, can not operate in 24-bit mode unless a variable in SONAR’s Aud.ini file is set to 1. The variable is Use24BitExtensible=<0 or 1>, which goes in the [name of your audio device (‘n’ in, ‘n’ out)] section.

For more information, see the Initialization File topics in the online help.
Bouncing Tracks Takes a Long Time

By default, SONAR uses a buffer for bouncing tracks that is the same size as the Mixing Latency value that you set in the Audio Options dialog. But with some projects, especially ones that use certain soft synths, the bounce buffer needs to have its own value. You can set the value in the Aud.ini file with the BounceBufSizeMsec=0 line in the Wave section. At a value of 0, the bounce buffer is the same size as the Mixing Latency value that you set in the Audio Options dialog. You can set the bounce value to 100, or some value between 0 and 350 so that the bounce buffer will use a more efficient size for bouncing, which has different requirements from normal playback latency.

For more information, see the Initialization File topics in the online help.

The GUI is not Smooth During Playback

If the GUI does not update smoothly during playback, press the Pause key to make sure you didn’t inadvertently put SONAR in CPU conservation mode. If the Pause key has been pressed, SONAR will display the letter P in the status bar.

For more information, see “Reduce GUI updates to improve playback performance” on page 859.

Plug-in windows flicker or don't display properly

X-Ray Windows is not compatible with plug-ins that use DirectDraw to create their windows, such as many recent plug-ins by Waves. If a plug-in is not compatible with X-Ray, the plug-in’s window will either flicker or not display properly. If you have any plug-ins that are affected by this, you can exclude the plug-in(s) from X-Ray by following the instructions below:

1. Open the Cakewalk Plug-in Manager (Tools > Cakewalk Plug-in Manager).
2. In the Plug-in Categories window, select the category that the plug-in you want to exclude is in.
3. In the Registered Plug-ins window, select the plug-in that you want to exclude.
4. If the plug-in is a DirectX effect or an MFX, write down (or select and copy) the CLSID value that’s in the CLSID field at the bottom of the dialog.
5. If the plug-in is a VST or VSTi, write down the VST ID value that’s in the VST ID field at the bottom of the dialog.
6. Close the Plug-in Manager dialog.
7. Use Notepad to open the XRayExclude.ini file that's in your SONAR program folder 
(C:\Documents and Settings\<username>\Application Data\Cakewalk\SONAR 8 Producer Edition).

   **Note:** If you use SONAR Studio, substitute “Producer” with “Studio”.

8. At the end of the file, find the [EffectProps View] section.
   You will see entries such as the following:
   
   ; Waves SSL EQ Stereo
   XRayExclude11=1397510483
   XRayExclude12={E451379E-F7E1-4E82-98D9-BEB87AC45E90}

9. Exclude your plug-in by creating a blank line below the last entry in the [EffectProps View] 
   section, and then typing:
   
   ;[name of your plug-in, but without brackets]
   XRRayExclude[type the next available number in XRayExclude list, but 
   without brackets]=[VST ID number, with no brackets, or CLSID number, 
   with curly braces at start and finish]

   For example, if the last entry in the [EffectProps View] section was:
   
   ; Waves SSL EQ Stereo
   XRayExclude11=1397510483
   XRayExclude12={E451379E-F7E1-4E82-98D9-BEB87AC45E90}
   
   If you wanted to exclude the Cakewalk FxDelay from the X-Ray Windows feature, after creating a 
   blank line you would type:
   
   ; Cakewalk FxDelay
   XRRayExclude13={985DAF67-589F-4B8D-8B8D-8B87AC45E90}

   If there was also a VST version of the Cakewalk FxDelay, you would add another line:
   
   XRRayExclude14=[some VST ID number, with no brackets]

10. Save and close the XRayExclude.ini file, and restart SONAR to implement your changes.
File Recovery mode

SONAR 5 introduced a special diagnostic mode called Safe Mode to fix problems with project files that would not open. Safe mode is activated when you open a file while the SHIFT key is pressed. In certain rare circumstances, on attempting to open a project file you may see the following error message:

“This file you are trying to open is not compatible with this version of SONAR”.

This message indicates that SONAR detected errors in the project file and was unable to open it. This normally indicates that your project file has data corruption.

Data corruption on a DAW can occur due to various reasons, a few of which are listed below:

- Your hard drive might suffer data loss.
- Windows delayed writes might fail leading to data corruption.
- Many hard disks have a “write through cache” buffer for efficiency. Occasionally this write through buffer might not get flushed due to a driver error or system crash. In such cases data might not be flushed to your hard drive causing corrupt files (SONAR requests Windows to flush this buffer after a file save operation).
- A plug-in can corrupt the SONAR's memory space causing invalid data to be written to disk when the project is saved.
- During a file save the system can crash. In such situations you will have a truncated file on disk.

You save a “recovery file” through SONAR's crash exception dialog. When a crash occurs in SONAR you are presented with this dialog allowing you to attempt to save a recovery file. While this works most of the time, occasionally SONAR may be in a compromised state due to memory corruption. Under these circumstances, saving a file might cause a crash or the file might contain invalid data.

In general, the best insurance against the data corruption scenarios above is to follow standard safe computing practices to guard against data loss (keep regular backups, use autosave with versioning, etc.). However, occasionally you may be faced with a situation where you do not have a backup copy of a critical project that now fails to open.

SONAR's File Recovery Mode offers a means to help recover data from damaged project files.

To use File Recovery mode

Do one of the following:

- If you are opening a file from the Most Recently Used files list in the File menu, hold down the SHIFT key while selecting file name.
- If you are opening the file from the Open dialog, select the file in the dialog and hold down the SHIFT key while clicking the OK button.
What does File Recovery mode do?

File Recovery Mode applies the following behavior when opening a project file:

• Opens only the Track view, skipping all other opened views in the project including effects windows, Console View etc.

• Prompts you if you want to open the plug-ins saved with your project. Each plug-in gets a prompt, so you can open some and not open others.

**Important:** If you choose to not open a plug-in, that plug-in is stripped out of the project, so resaving the file will cause a loss of any project specific settings for that plug-in.

• Ignores various strict error checks that would normally prevent a file from loading (only applies when the original project fails to load normally).

• Detects corrupt data and skips over "chunks" that are found to be invalid. E.g., if a track/event is detected to contain invalid data, SONAR will attempt to skip over that track/event and proceed to load the next track/event (only applies when the original project fails to load normally).

In many cases, File Recovery Mode may be able to open damaged projects with minimal data loss. However, the level of success depends on the nature and extent of the data corruption, so the results are not predictable. As a result of this, after opening a damaged project in File Recovery Mode, you must carefully observe whether your settings have been retained or if the project exhibits other problems. If you notice problems you should copy and paste the critical data from the recovered file into a brand new empty project to start clean.

**Important:** Since File Recovery Mode ignores many critical error checks while loading a file, depending on the nature of the data corruption in the file, it is possible that opening a file with File Recovery Mode might cause SONAR to crash or become unresponsive. Please ensure that you save all your current work and close all open projects before attempting to open a file with File Recovery Mode.

After loading a file with File Recovery Mode, it is recommended that you resave the file—preferably with a new name—and then shut down and restart SONAR before proceeding.
Glossary

**Aftertouch**
MIDI property controlling how much pressure is applied after sending a Note On message. See “Channel aftertouch (ChanAft)” on page 160 and “Key aftertouch (KeyAft)” on page 164.

**AIFF**
Short for *Audio Interchange File Format*, the audio file format on the Macintosh platform. Files in this format have the extension .aif or .aiff.

**Archive**
Silence and suppress the processing of a track. Archived tracks are not loaded into RAM, so they can’t be unmuted in real time. Use the archive command to reduce the demand on your CPU. See “Mute” on page 166.

**Arm**
Enable a track for recording.
See the online Help topic.

**Audio clip**
A visual reference to a portion of, or an entire, recorded audio file. This is represented graphically as a wave form which can be edited and manipulated in a variety of manners.

**Audio track**
An audio track is a reference point for playing and recording a single digital audio file stored on your computer's hard drive. The inputs of the audio track are where you would like to record a signal from and the outputs are where you would like to send this signal to monitor.

**Audition**
Preview audio effects before applying them to a track.
See the online Help topic Basic Audio Processing.
Automation
Ability to change controllable parameters over the length of a track. This is achieved by referencing “snapshots” or “nodes” assigned to specific parameter values in relation to their position on the timeline and is achieved with envelopes.
See the online Help topic Quick Automation Guide.

Bank
A means of categorizing sounds. A “bank” can store up to 128 “patches”.

Bit depth
The amount of data allocated to reproducing a sound wave of digital audio file. Closely related to the dynamic range of the audio file. 1-bit typically represents 6dB of dynamic range when converting an analog signal to a digital signal. Thus, the greater the bit depth, the greater the dynamic range.

Broadcast wave
A wave file with the following embedded information: description, originator, origination date, origination time, and SMPTE time reference.

Bundle file
A single file that incorporates all project information and audio data. Bundle files are useful for creating backups of your work or for moving projects from one computer to another.

Cakewalk Application Language (CAL)
An event-processing language that extends Cakewalk with custom editing commands. Useful for applying quantization, humanization, or other instant changes to MIDI events.
See the online Help topic Running CAL Programs.

Channel
Path through which MIDI transmits information. MIDI devices typically send data over 1 of 16 channels, or over all channels simultaneously (Omni).

Channel aftertouch (ChanAft)
MIDI property regulating the pressure applied to all the notes of the instrument on the specified channel.

Chord
Three or more notes played simultaneously. Typically represented by a single letter representing its root, numbers representing additional notes, and symbols representing its quality. On the guitar chord grid, the notes are shown on the neck of a guitar.
See the online Help topic Adding Chord Symbols.

Chord symbol
The c among the expression marks on the staff view. Put one above the notes where you want to define a guitar chord grid.
See the online Help topic Chords and Marks.
Clip
A reference to a portion or entire audio or MIDI file stored on your computer. Clips can be edited, moved, linked, copied etc. as a means of creating your project.

Clone
A command that allows you to copy a track along with its properties. You can choose to copy the clips or events or both. You can choose the destination track for the copy.

Controllers
Pedals, knobs, and wheels on your electronic instrument that you can use to change the sound while you're playing.
See the online Help topic Controllers, RPNs, NRPNs, and Automation Data.

Controls
Sliders, faders, knobs, and buttons on the console or your on-line equivalent of Controllers.
See the online Help topic Mixing.

Crescendo
A passage of music during which the volume gradually increases.

Crossfade
One clip fading in while another fades out. You can create destructive or non-destructive crossfades.
For more information, see the online Help topic Fades and Crossfades.

dB
The abbreviation for Decibel.
See the online Help topic The Decibel Scale.

Decibel
A logarithmic unit used to measure loudness; abbreviated dB.
See the online Help topic The Decibel Scale.

Decrescendo
Also referred to as a diminuendo, is a passage of music during which the volume gradually decreases.

Digital audio
Music or sound recorded digitally, as on a compact disk as opposed to an analog signal recorded to tape.

DMA
Direct Memory Access. DMA settings determine how your computer's sound card communicates with Cakewalk.
See the online Help topic The Wave Profiler for information about how to change DMA settings.
**DRM (Dump Request Macro)**
Utility for getting synthesizer data into a bank.

**Duration**
In SONAR's **Step Record** dialog box, duration means the actual length of time that a note sounds, as opposed to the notated value of the note, which could be different. If you check the **Follow Step Size** option in the dialog box, the notated value and the duration are the same.

**Echo**
Enables real-time monitoring of the associated track's inputs through the outputs of your sound device.

**Effects (audio effects)**
Systematic changes you can make to parts or all of the music, like reverb, chorus, and delay.
See the online Help topics Audio Effects (Audio Plug-ins) and Using Real-Time Effects.

**Envelopes**
Reflects the changes in value for a specified parameter (volume, for example) over a period of time. Also refers to the graph of the change—same as vector.
See the online Help topic Automation.

**Event**
Note, MIDI action, or audio clip.

**Expression**
Chord symbol, text of any sort (like ff or con amore), hairpin, or pedal marks.

**Expression marks**
Dynamic markings and other musical instructions (like decrescendo, con amore, etc.) in the Staff view.
See the online Help topic Adding Expression Marks.

**Fade**
Gradual increase or decrease in volume.
See the online Help topics Fades and Crossfades and Automation.

**Fade-in**
A gradual increase in volume from absolute silence.
See the online Help topics Fades and Crossfades and Automation.

**Fade-out**
A gradual decrease in volume toward absolute silence.
See the online Help topics Fades and Crossfades and Automation.
Frame
One of the many single photographic images in a motion picture or video. It the smallest unit used for SMPTE synchronization.
See the online Help topic SMPTE/MIDI Time Code Synchronization.

Frame rate
Indicates the number of frames displayed per second.

From time
The beginning of a selection. Set it in the Select toolbar.
See “Now time” on page 166.

Full-duplex
The ability to stream data in two directions simultaneously. Sound cards that support full-duplex allow for simultaneous recording and playback of audio.
See the online Help topic Recording audio.

Global layout
The arrangement of your views as the appear in Cakewalk. You can save layouts to use with other projects.
See the online Help topic Layouts, Templates and Key Bindings.

Groove clip
Audio clip that contains pitch and tempo information that allows SONAR to automatically adjust the pitch and tempo of the clip to that of the project you insert it into.

Groove pattern
Piece of music used as a template for the groove quantize command.
See the online Help topic To Use the Groove Quantize Command.

Groove quantize
Lets you lay a grid over your groove pattern, then adjust time, duration, and velocity of selected notes so they line up with the grid.
See the online Help topic To Use the Groove Quantize Command.

Group
An entity consisting of multiple controls or buttons and specifying relationships between or among them.

Guitar chord grid
Displays chord symbols as well as the fingerings on the fret board of a guitar above the Staff View.
See the online Help topic Chords and Marks

H:M:S:F
Short for Hours, Minutes, Seconds, and Frames, which is the time format used for SMPTE time.
Hairpin symbol
Crescendo or decrescendo mark.
See the online Help topic Chords and Marks

Input
The selection for which channel of a device you wish to receive signal from.
See the online Help topic Choosing an input.

Input monitoring
Hearing real-time playback of a track's input as it is being sent to, or recorded, in SONAR. You can enable input monitoring with a track's Input Echo button.

Inspector menu (same as context menu)
Menu appropriate for a particular location or item. Display a context menu by right-clicking on the location or item.

Instrument definitions
A file that contains information necessary to communicate settings about banks, patches, controllers, and other features of an instrument.
See the online Help topic Creating Instrument Definitions.

Key aftertouch (KeyAft)
MIDI property regulating the pressure applied to an individual note.

Key offset
The number of half-steps by which to transpose the track. A value of 12 raises the notes an octave. You can transpose all note in a track on playback by setting this value (Key+) in the Tracks pane.

Key signature
Key of the piece, how many sharps or flats it has, and how the music displays in the various views.

Latency
Often referred to as “buffer size” is a measurement of the time it takes, in samples, for audio to travel from its source, through a sound card's drivers and converters, into SONAR, and back through the sound card to your speakers.

Layout
Current arrangement of all views in a particular project.
See the online Help topic Layouts, Templates and Key Bindings.

Linked clips
Clips so specified that any change made to one applies to all.
See the online Help topic Splitting and Combining Clips.
**Live mode**
Temporary condition of a project with all automation turned off. You can toggle back and forth between live mode and regular mode by clicking the **Live Mode** button.

**Locked (SMPTE) time**
Locks a marker to a specified time from the start of the music. Not affected by changes in tempo or time signature.
See the online Help topic Creating and Using Markers.

**Looping**
Repetition of a part of the whole piece of music.

**Loops**
Small pieces of audio data, suitable for being repeated back to back, such as a single drum beat or measure.

**Lyrics**
Words to go along with music.
See the online Help topic Working with Lyrics.

**Marker**
Flag marking a specific time in the music.

**MBT**
Short for Measure, Beat and Tick number which is the time format used for beats.
9:04:0060 is the 60th tick of the fourth beat of the ninth measure.

**MCI command (Media Control Interface command)**
Special event in the Event List view that lets you control other multimedia hardware and software.

**Meter**
The meter, or time signature, divides time into rhythmic pulses. Specifies the number of beats per measure and the note value of each beat.
See the online Help topic Setting the Meter and Key signatures.

**Metronome**
A feature that plays a regularly recurring audible beat which aids in accurate performances. Can be observed in playback or recording. The rate is set by the tempo of the project.
See “Tempo” on page 170.
MIDI
Musical Instrument Digital Interface. The means by which computers communicate with most sound cards, keyboards, and other electronic instruments.

Note:  *MIDI data does not contain any audio data.*

Mixdown
Combination of two or more audio tracks into a stereo submix. See the online Help topic Routing and Mixing Digital Audio.

MMC (MIDI Machine Code)
A protocol that controls an MMC-equipped remote device through MIDI. See the online Help topic MIDI Machine Control (MMC).

MME
Multi Media Extensions—the name of Windows' built-in audio and multimedia software that was originally developed for Windows 3.0, and is still used by many sound card drivers. WDM drivers offer much better performance.

MTC Sync
MIDI Time Code sync. Messages are received in SMPTE/MTC format from an external MIDI device and generate MTC. See “SMPTE” on page 169.

Mute
Silences a track to not be heard during playback or recording.

Normal template
A default project template which includes a predetermined amount of tracks and/or buses.

Now time
The current time in a project or where you are in the music. This is Represented by a vertical line which travels throughout the timeline. See the online Help topic The Now time and how to use it.

NRPN
Non-Registered Parameter Numbers. See the online Help topic Controllers, RPNs, NRPNs, and Automation Data.

Offline
Not in real time. When you apply an effect to a track offline, you permanently alter the data in that track; then you play the track to hear the effect. When you add an effect to a track in real time, you start the track playing, and you add the effect while the track plays. The data in the track does not change, but the sound of it coming through the effect does.
Offset
Shift (time, key, velocity) by a specified number of units. For example, you could offset the start of a track by two measures.

Overload
Loss of audio information caused by the audio level exceeding 0 db.

Pan
Degree to which a sound or piece of music comes from the left or right speaker. This control is commonly used to adjust the level of a signal in different channels. In a stereo mix, the level is adjusted between the left and the right speakers.

Patch
Particular sound in an electronic device. Patches are stored in banks, in groups of 128.

Pedal mark
Expression mark indicating when the player should hold down the pedal and release it.

Phase
Frequency dependent time delay. All frequencies experience phase, but as a whole this is not noticeable as they are affected uniformly. If frequencies fall out of phase, however, they interfere with each other constructively or destructively. This can be measured by calculating the period length, as well as amplitude and magnitude values of a recorded wave form. If two frequencies fall 180 degrees out of phase, they will endure destructive interference and thus completely cancel each other out.

Pitch bend
Controller that changes the pitch of a MIDI note.

Pitch marker
A marker in the Time Ruler which transposes the root note pitch of all groove clips and ACIDized loops in a project.

Pitch wheel
Controller that changes the pitch of a MIDI note.

Port
Computer connector for sending or receiving data.

PPQ
Abbreviation for Parts per Quarter Note. MIDI sequencers divide each beat into fractions of a beat (called ticks) for timing and editing purposes. You can place events in precise timing locations, up to the sequencer’s current PPQ. PPQ is adjustable on most sequencers, up to about 960 PPQ. PPQ values of 96, 120, and 480 are common.
**Project pitch**
Also known as the default project pitch. The project pitch is the pitch that all groove clips and ACIDized loops in your project follow if there are no pitch markers in the project. You can set the project pitch in the **Markers** toolbar.

**Property**
Any attribute or value belonging to an object. Often you can see these by right-clicking on the object. For example, right-clicking on a clip and choosing **Properties** from the resulting menu, displays the **Clip Properties** dialog box, which lists its properties as its name, start time, length, and color.

**Quantize**
Correct human imperfection in start and duration of selected notes so they line up with a specified time grid.

**Quantize resolution**
Used to set how precise (in notes or ticks) you wish applying quantization to be.

**Quantize strength**
Measure of how close you wish quantized notes to be in relation to the quantize resolution.
See the online Help topic To Use the Groove Quantize Command

**Record**
To capture audio to a digital audio file or store incoming MIDI data in a MIDI track.

**RIFF wave**
The standard digital audio format used under Windows and for CD's, with a file extension of .wav.

**RMS**
Short for Root Mean Square. A method of measuring an average of the amplitudes that occur in a complete cycle of a frequency. RMS is a little over seventy per cent of peak level.

**RPN**
Registered Parameter Numbers.
See the online Help topic Controllers, RPNs, NRPNs, and Automation Data.

**Ruler**
Bar showing evenly-spaced measure intervals. It appears in the Track, Staff, and Piano Roll views.

**Sampling rate**
The number of samples per second a digital audio file is recorded at. A higher sampling rate typically increases the fidelity recordings, as it helps to avoid phase shifting and aliasing artifacts. A higher sampling rate will yield larger audio files and more hard drive space used.

**Scrub**
A tool used for previewing audio. The scrub tool allows you to playback audio faster or slower as a useful auditioning tool.
Sensitivity (window)
Distance from a timing grid a note has to be to be unaffected, or affected less, by quantizing.

Shape
An automation envelope created in the Track view or Console view.

Size
The number of events in a track, listed in the Size column of the Tracks window. This number changes every time you add or delete events to or from that track.

Slip editing
Non-destructive editing process that allows the start and/or end time of an audio or MIDI clip to be trimmed by simply dragging the front or back end of the clip.

SMPTE
Society of Motion Picture and Television Engineers. SMPTE format measures time in hours, minutes, seconds, and frames.

Snapshot
Collection of automation settings that become active at a specific time. When the Now Time reaches that time, all of those particular settings take effect.

Solo
Silences all tracks except for those that are soloed during playback and recording. Multiple tracks can be soloed at once.

Split point
In the Staff view, the point at which you split a track into treble and bass staves. Notes at or above the split point go into the treble staff, those below into the bass staff.

Staff
A set of horizontal lines developed for music notation.

Striping
Recording an analog time code signal onto a track.

Submix
A grouping of specific tracks with similar qualities and/or effects (such as a submix of guitars or vocals). Creating submixes, by sending groups of tracks to a group specific buses for example, allows for quick adjustments when it comes to mixing, such as muting or applying reverb to all the vocals.
See the online Help topic Routing and Mixing Digital Audio.

Swing
Systematic uneven spacing of notes on a timing grid, to give music a swing feel.
Sysx
Short for System Exclusive, refers to MIDI messages that only a specific device can use and understand. Cakewalk's System Exclusive library, which can store, record, and display for viewing or editing 256 banks, each holding any number of patches.
See the online Help topic System Exclusive Data.

Sysx bank
A Sysx bank is a storage area plus some associated parameters such as a destination output and an optional description. Each bank can hold any number of messages; the amount of data it can hold is limited only by available memory. The banks are saved in the Cakewalk song file. Each bank can also be saved as a .syx file in the format used by the public domain MIDIEX utility.

Take
A single pass of recording a part or a song. Multiple “takes” are often used in the studio as a means of editing the best of each take for the final production.

Template
A file which stores specific project layouts, such as numbers of tracks and/or plug-in assignments, but does not store any audio or MIDI data. Useful for creating new projects which might require a similar layout.
See the online Help topic Layouts, Templates and Key Bindings.

Tempo
The speed at which the project or selection of music is played at. Measured in rhythmic beats per minute.
See “Metronome” on page 165.

Thru time
Time up to which the music is to be played back or recorded. Set it in the Select toolbar.

Ticks
Subdivisions of quarter notes. MIDI projects often use a resolution of 480 parts per quarter note (PPQ); each part is also called a tick.

Time
In Cakewalk, Now time, from time, or thru time. When an event takes place in the music.

Time offset
Adjustment of all track events by a specified amount of time.
See the online Help topic Adjusting the time alignment of a MIDI track (Time+).

Time ruler
Bar showing evenly-spaced intervals. It appears in the Track, Staff, and Piano Roll views. You can use the Time Ruler to change the Now Time, make a time selection, and insert markers. For more about the Time Ruler, see the online Help topic The Time ruler.
Timebase
Same as PPQ. Timing resolution, measured in pulses (ticks) per quarter note. Determines how finely you can specify notes.
See the online Help topic Setting the MIDI timing resolution.

TPQ
Same as timebase or PPQ. Short for Ticks Per Quarter note.

Track
Cakewalk's representation of one or more lines of music with shared properties, for example, music played by one instrument.

Transients
Peaks of loudness in an audio clip. Used to determine where the beats lie in audio clips.

Vector
The graph of the change of a parameter’s value. In audio programs, some parameters can be changed by drawing vectors; means the same as drawing Envelopes.

Velocity
A measurement taken when recording MIDI note events of how fast a key is struck. A MIDI notes velocity will dictate how loud the note will sound during playback.

Volume
Loudness of a sound or piece of music.

WASAPI
WASAPI (short for Windows Audio Session Application Programming Interface) is a new driver model available in SONAR that allows it to communicate with the new audio features in Windows Vista.

WDM
Windows Driver Model—low-latency audio driver that bypasses the operating system’s audio streaming software so that the driver can communicate directly with the sound card and the audio application.

Widget
A graphical element of a StudioWare panel (such as a knob or slider) that controls a parameter on a MIDI instrument or runs a CAL program.

Wipe
Deletes a track's clips and events, but leaves its properties. You can undo a wipe, but not paste it.

xRPN
RPN and NRPN.
Index

.clr 48
.cwp files 26
24-bit problems 153

A
Audio
digital 15
recording See Recording audio
Audio data
playback problems 145
recording problems 146

B
Big Time view 36
Bouncing tracks
takes too long 154
Bus pane
docking views in 38
Buses 32

C
Cakewalk Publisher 119
Clips 27
selecting 30
selecting partial 30
Clips pane
not visible 147
Color
screen 47–48
Color presets
import and export 48
Color set files
importing and exporting 48
Colors 47
Commands
missing 42
Connecting
electric guitar 18
microphone 19
Console view
overview 32
Customizable menus 42
Customizable toolbars 44

D
Defining instruments 26
DMA settings 24
Docking views 38

E
Echo
eliminating during recording 149
Electric Guitar
connecting 18
Errors
  Wave Profiler 148
Event List view 35

F
FAQs 141
File
  opening 28
File extensions
  .cwp 26
File menu
  Open 28
File Recovery Mode 156
Files
  StudioWare 27
Floating views
  dual monitor support 39

G
Game sound 12
Groove clips 27

H
Help menu
  Quick Start 24

I
Input monitoring
  disabling 149
Installing 16
Instrument sound
  wrong, on playback 146
Instruments
  accessing all sounds on 149
  problems recording from MIDI 144
Interrupt request (IRQ) settings 24

K
Keyboard
  connecting MIDI 16–20
  connecting to computer 18
  notes doubling on 147

L
Layouts 45
Locking views 39
Loop Construction view 35
Lyrics view 36

M
Markers 46
Markers view 36
Media Browser view 35
Menu commands
  missing 42
Menus
  customizing 42
Meter/Key
  view 36
Meter/Key view 36
Microphone
  connecting 19
MIDI
  advantages of 15
  connecting keyboard 16–20
  how it works 14
  setting up in and out devices 25
  See also Controllers
MIDI Devices 25
MIDI drivers
  changing 26
MIDI In and Out devices
  driver changes 26
Missing menu commands 42
N
Notation
  working with 85
Notes
  doubling 147
Now time 46

O
Options menu
  Colors 47
  MIDI Devices 25

P
Partial clips
  selecting 30
Patches
  downloading 141
Piano Roll view 33
  overview 33
Playback
  controlling using transport toolbar 46
  problems 143
Port Address settings 24
Preferences
  migrating from previous version of Cakewalk 24
Project
  definition of 26
  opening 23, 28
Project file 26
Projects
  working on 46
Publisher 119

R
Recording
  audio
    definition
    troubleshooting 145
  controlling using Transport toolbar 46
digital audio See Recording audio
  eliminating echo 149
  problems 144, 146

S
Safe Mode 156
Scoring
  film and video 13
Screen colors 47–48
Settings
  migrating from previous version of Cakewalk 24
SONAR
  features of 11–14
  installing 16
  uninstalling 51
Staff view
  overview 34
Sysx view 36
  purpose of 36

T
Tabbed views 38
Taskbar indicators 46
Tempo view 36
Time ranges
  selecting 30
Toolbars
  creating 45
  customizing 44
  docking and undocking 45
  hiding and showing 44
  renaming 45
Track view 28–30
  clips pane not visible in 147
  keyboard shortcuts in 29
Track/Bus Inspector 31
Tracks 154
  See also Recording; Track Properties
Transport toolbar 46
Troubleshooting 141
Tutorial 5
  Working with Music Notation 85

U
Uninstalling SONAR 51
Updates 141
USB audio
  24 bit problems 153

V
Views 28–45
  allowing multiple instances of the same 39
docking in bus pane 38
floating 39
Lyrics 36
Markers 36
Meter/Key 36
Sysx 36
Tempo 36

W
Wallpaper 47–48
Wave Device Profiler
  errors 148
Wave Profiler
  using 24
World Wide Web
  authoring 13

X
X-Ray Windows 39

Z
Zoom
  keyboard shortcuts 38
Zoom Controls 37
Cakewalk, Inc.

LICENSE AGREEMENT

YOU SHOULD CAREFULLY READ ALL OF THE FOLLOWING TERMS AND CONDITIONS BEFORE USING THIS PRODUCT. INSTALLING AND USING THE PRODUCT INDICATES YOUR ACCEPTANCE OF THESE TERMS AND CONDITIONS. IF YOU DO NOT AGREE WITH THEM, YOU SHOULD PROMPTLY RETURN THE PRODUCT UNUSED AND YOUR MONEY WILL BE REFUNDED.

1. GRANT OF LICENSE. In consideration of payment of the license fee, Cakewalk, Inc. ("Cakewalk" or the "Licensor") grants to you, the Licensee, a nonexclusive license to have one person use the enclosed Cakewalk software product (the "Product") on one personal computer at a time. If you want to use the Product on more than one personal computer at a time, or if you want to network the Product, you must obtain separate licenses from Cakewalk by calling (617)423-9004. This license does not grant you any right to any enhancement or update to the Product. Enhancements and updates, if available, may be obtained by you at Cakewalk's then current standard pricing, terms and conditions.

2. OWNERSHIP OF THE PRODUCT. Portions of the Product incorporate certain material proprietary to third parties. Cakewalk and licensors of Cakewalk own and will retain all title, copyright, trademark and other proprietary rights in and to the Product. This License is NOT a sale of the Product or any copy of it. You, the Licensee, obtain only such rights as are provided in this Agreement. You understand and agree as follows:

2.1. You may NOT make any copies of all or any part of the Product except for archival copies of the computer software components of the Product as permitted by law.

2.2. You may NOT reverse compile, reverse assemble, reverse engineer, modify, incorporate in whole or in part in any other product or create derivative works based on all or any part of the Product.

2.3. You may NOT remove any copyright, trademark, proprietary rights, disclaimer or warning notice included on or embedded in any part of the Product.

2.4. You may NOT transfer the Product. If transferred, in whole or in part, the original and subsequent owners forfeit all rights to use the software.

2.5 You may not use the documentation for any purpose other than to support your use of the SOFTWARE PRODUCT.

2.6 You may not perform engineering analyses of the SOFTWARE PRODUCT, including performance analyses, or benchmark analyses, without the written permission of Cakewalk.

3. INSTRUMENT CONTENT

3.1 The audio samples, recorded sounds, programs, MIDI patterns used by any instrument ("instrument content") included with the Product remain the property of Licensor and are licensed, not sold, to you for use on your computer.

3.2 The Licensee may modify the instrument content. LICENSEE MAY USE THE INSTRUMENT CONTENT FOR COMMERCIAL PURPOSES WITHIN MUSICAL COMPOSITIONS.

3.3. This license expressly forbids resale, re licensing or other distribution of the instrument content, either as they exist on these discs, or any modification thereof: You cannot sell, loan, rent, lease, assign or transfer all or any of the enclosed sounds to another user, or for use in any competitive product.

4. DEMO or THIRD PARTY DEMO CONTENT RESTRICTIONS. Unless specified elsewhere in your product package, the following restrictions apply to all digitally recorded sounds, MIDI or Cakewalk-format song files or rhythm patterns, and printed or digitally reproduced sheet music contained in the product package (the "demo content"): All demo content is protected by copyright and owned by Cakewalk or other parties that have licensed these works to Cakewalk. Any duplication, adaptation, or arrangement of the demo content without written consent of the owner is an infringement of U.S. or foreign copyright law and subject to the penalties and liabilities provided therein. You may not synchronize the demo content with any videotape or film, or print the demo content in the form of standard music notation, without the express written permission of the copyright owner. The demo content may not be used for broadcast or transmission of any kind. You may not resell or redistribute the demo content "as is" (i.e., stand alone) in any way, including for use in sampling or sample playback units, or in any sound library product, or in any radio or television broadcast, soundtrack, film or other commercial product in any media, whether the works remain in their original form or are reformatted, mixed, filtered, re-synthesized or otherwise edited.

5. LICENSEE’S RESPONSIBILITIES FOR SELECTION AND USE OF THE PRODUCT. Cakewalk hopes the Product will be useful to your business or personal endeavors. HOWEVER, CAKEWALK DOES NOT WARRANT THE OPERATION OF THE PRODUCT OR THE ACCURACY OR COMPLETENESS OF ANY INFORMATION CONTAINED IN THE PRODUCT. You, and not Cakewalk, are responsible for all uses of the Product.

6. WARRANTY.

6.1. Limited Warranty. Subject to the other provisions in Articles 4 and 5 of this Agreement, Cakewalk warrants to you, the original licensee, that the media on which the Product is recorded will be free of defects in material and workmanship under normal use for a period of thirty (30) days from purchase, and that the Product will perform substantially in accordance with the user guide for a period of thirty (30) days from purchase. Cakewalk's sole responsibility under this warranty will be, at its option, (1) to use reasonable efforts to correct any defects that are reported to it within the foregoing warranty period or (2) to refund the full purchase price. Cakewalk does not warrant that the Product will be error free, nor that all program errors will be corrected. In addition, Cakewalk makes no warranties if the failure of the Product results from accident, abuse or misapplication. Outside the United States, these remedies are not available without proof of purchase from an authorized international source. All requests for warranty assistance shall be directed to Cakewalk at the following address:

Cakewalk, 268 Summer Street, Boston, MA 02210 U.S.A. 617/423-9004
6.2. Limitations on Warranties. THE EXPRESS WARRANTY SET FORTH IN THIS ARTICLE 4 IS THE ONLY WARRANTY GIVEN BY CAKEWALK WITH RESPECT TO THE ENTIRE PRODUCT; CAKEWALK MAKES NO OTHER WARRANTIES, EXPRESS, IMPLIED OR ARISING BY CUSTOM OR TRADE USAGE, AND SPECIFICALLY DISCLAIMS THE IMPLIED WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS FOR ANY PARTICULAR PURPOSE. CAKEWALK SHALL NOT BE HELD RESPONSIBLE FOR THE PERFORMANCE OF THE PRODUCT NOR FOR ANY LIABILITY TO ANY OTHER PARTY ARISING OUT OF USE OF THE PRODUCT.

SOME STATES DO NOT ALLOW LIMITATIONS ON HOW LONG AN IMPLIED WARRANTY LASTS, SO THE ABOVE LIMITATION MAY NOT APPLY TO YOU. THIS WARRANTY GIVES YOU SPECIFIC LEGAL RIGHTS, AND YOU MAY ALSO HAVE OTHER RIGHTS WHICH VARY FROM STATE TO STATE.

7. LIMITATIONS ON REMEDIES. Cakewalk's liability in contract, tort or otherwise arising in connection with the Product shall not exceed the purchase price of the Product. IN NO EVENT SHALL CAKEWALK BE LIABLE FOR SPECIAL, INCIDENTAL, TORT OR CONSEQUENTIAL DAMAGES (INCLUDING ANY DAMAGES RESULTING FROM LOSS OF USE, LOSS OF DATA, LOSS OF PROFITS OR LOSS OF BUSINESS) ARISING OUT OF OR IN CONNECTION WITH THE PERFORMANCE OF THE PRODUCT, EVEN IF CAKEWALK HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF INCIDENTAL OR CONSEQUENTIAL DAMAGES SO THE ABOVE EXCLUSION OR LIMITATION MAY NOT APPLY TO YOU.

8. U.S. GOVERNMENT RESTRICTED RIGHTS. If you are a government agency, you acknowledge that the Product was developed at private expense and that the computer software component is provided to you subject to RESTRICTED RIGHTS. The rights of the government regarding its use, duplication, reproduction or disclosure by the Government is subject to the restrictions set forth in subparagraph (c)(1)(ii) of the rights in Technical Data and Computer Software clause at DFARS 252.227-7013, and (c)(1) and (2) of the Commercial Computer Software -- Restricted Rights clause at FAR 52.227-19. Contractor is Cakewalk, Inc.

9. TERMINATION. This License Agreement will terminate immediately if you breach any of its terms. Upon termination, you will be required promptly to return to Cakewalk or to destroy all copies of the Product covered by this License Agreement.

10. MISCELLANEOUS.

10.1. Governing Law. The terms of this License shall be construed in accordance with the substantive laws of the United States and/or Commonwealth of Massachusetts, U.S.A.

10.2. No Waiver. The failure of either party to enforce any rights granted hereunder or to take any action against the other party in the event of any breach hereunder shall not be deemed a waiver by that party as to subsequent enforcement of rights or subsequent actions in the event of future breaches.

10.3. Litigation Expenses. If any action is brought by either party to this Agreement against the other party regarding the subject matter hereof, the prevailing party shall be entitled to recover, in addition to any other relief granted, reasonable attorneys' fees and litigation expenses.

10.4. Unenforceable Terms. Should any term of this License Agreement be declared void or unenforceable by any court of competent jurisdiction, such declaration shall have no effect on the remaining terms hereof.

YOU ACKNOWLEDGE THAT YOU HAVE READ THIS LICENSE AGREEMENT, UNDERSTAND IT AND AGREE TO BE BOUND BY ITS TERMS AND CONDITIONS. YOU FURTHER AGREE THAT IT IS THE COMPLETE AND EXCLUSIVE STATEMENT OF THE LICENSE AGREEMENT BETWEEN YOU AND CAKEWALK WHICH SUPERSEDES ANY PROPOSALS, OR PRIOR AGREEMENT, ORAL OR WRITTEN, AND ANY OTHER COMMUNICATIONS BETWEEN YOU AND CAKEWALK RELATING TO THE SUBJECT MATTER OF THIS LICENSE AGREEMENT.