A Guide to Quark Publishing Platform 9.5.1
Índice

**Introduction**................................................................................................... 8  
Where we’re coming from................................................................. 8  
Conventions in this book................................................................. 8

**About Quark Publishing Platform**............................................... 10  
Platform concepts............................................................................. 11  
Platform components........................................................................ 12  
Platform architecture.......................................................................... 13  
Platform features................................................................................ 14

**Configuration**.................................................................................. 16  
Administration client........................................................................ 16  
System area....................................................................................... 17  
Content Model area.......................................................................... 17  
Workflow area................................................................................... 17  
Users and Groups area..................................................................... 17  
Configuring storage options........................................................... 17  
Adding repositories.......................................................................... 18  
Deleting repositories........................................................................ 18  
**Working with content types**......................................................... 18  
Working with collection types......................................................... 20  
**Working with attributes**............................................................... 20  
Defining attributes........................................................................... 20  
Adding constraints to attributes...................................................... 26  
**Working with relationships**.......................................................... 28  
Creating a workflow......................................................................... 29  
Working with statuses...................................................................... 30  
**Working with forms**.................................................................... 31  
Defining Roles and Privileges......................................................... 32  
Roles and Privileges....................................................................... 32  
Creating and deleting users.............................................................. 33  
Managing user lists with LDAP....................................................... 34  
Creating and deleting groups......................................................... 38  
Configuring Redline colors.............................................................. 39

**Maintenance and asset management**.......................................... 41  
Monitoring user activity and logging off users.............................. 41
Deleting assets...........................................................................................................................................42
Archiving assets........................................................................................................................................42
Restoring assets.........................................................................................................................................43

User interface..................................................................................................................................................45
Roles, views, and content structure overview..........................................................................................45
The Workspace Browser window...............................................................................................................45
Workspace Browser window.......................................................................................................................45
Workspace toolbar.......................................................................................................................................47
View display options....................................................................................................................................51
Icon columns..................................................................................................................................................56
Preview pane..................................................................................................................................................57
Menus (Quark Publishing Platform Client)..................................................................................................58
Quark Publishing Platform Client menu (Mac OS only)..............................................................................59
File menu.....................................................................................................................................................59
Edit menu....................................................................................................................................................59
View menu...................................................................................................................................................60
Actions menu...............................................................................................................................................60
Go To menu..................................................................................................................................................61
Search menu..................................................................................................................................................61
Window menu (Mac OS)...............................................................................................................................62
Help menu...................................................................................................................................................62
Menus (QCD)..................................................................................................................................................62
QuarkCopyDesk menu (Mac OS only).........................................................................................................62
Platform menu.............................................................................................................................................62
Menus (QXP)..................................................................................................................................................63
QuarkXPress menu (Mac OS only).............................................................................................................63
Utilities menu.............................................................................................................................................63
Window menu.............................................................................................................................................64
Platform menu.............................................................................................................................................64

Client tasks ....................................................................................................................................................66
Understanding how Quark Publishing Platform works............................................................................66
Quark Publishing Platform Server and Quark Publishing Platform client applications..........................66
Administering a Quark Publishing Platform workflow.............................................................................66
Using XML Author with Quark Publishing Platform..................................................................................66
Assigning and managing assets from QXP...................................................................................................67
Routing and tracking....................................................................................................................................71
Automating output and export....................................................................................................................71
Archiving and restoring..............................................................................................................................71
Logging on.....................................................................................................................................................72
Creating assets (QCD and QXP)..................................................................................................................73
Working with collections.............................................................................................................................73
Working with collection templates.............................................................................................................73
Creating a collection.....................................................................................................................................74
Editing collections........................................................................................................................................81
ÍNDICE

Duplicating a collection.................................................................82
Deleting a collection......................................................................82
Appending content (QCD and QXP)....................................................83
Checking in assets........................................................................83
Check In command........................................................................83
Check In Other command ..............................................................85
Check in multiple assets................................................................85
Check In Project With Pictures (QXP only).....................................86
Assigning assets........................................................................86
Assigning assets: Quark Publishing Platform Client......................87
Assigning assets: QXP..................................................................88
Performing a search......................................................................88
Using the Quick Search feature.....................................................90
Performing a nested search............................................................91
Performing a full-text search.........................................................92
Performing a collection search......................................................93
Search from here........................................................................94
Working with saved searches.........................................................94
Managing searches......................................................................94
Specifying search result display options .....................................95
Checking out assets......................................................................95
Checking out an asset: Quark Publishing Platform Client...............96
Checking out an asset: QCD............................................................96
Checking out an article or project: QXP........................................96
Checking out a project with attachments: QXP...............................96
Checking out and editing pictures: QXP & QCD..............................97
Using Advanced search: QCD and QXP........................................97
Cancelling a Checkout ..................................................................98
Working with templates...............................................................98
Attaching content to layouts.........................................................98
Primary and secondary attachments............................................99
Attaching article components by dragging.................................100
Attaching articles by dragging.....................................................100
Attaching articles by assigning....................................................102
Attaching text files to layouts......................................................102
Attaching pictures to layouts.......................................................103
Attaching App Studio assets.........................................................103
Attaching multimedia assets to reflow articles.........................103
Tracking attachments.................................................................103
Detaching components...............................................................104
Attaching digital assets to layouts.................................................104
Replacing article geometry.........................................................105
Working with libraries...............................................................105
Using Read-Only to view an asset.................................................106
Publishing assets.........................................................................106
Viewing and editing attribute information..................................107
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Saving a revision of an asset</td>
<td>108</td>
</tr>
<tr>
<td>Customizing the search results pane</td>
<td>108</td>
</tr>
<tr>
<td>Setting Quark Publishing Platform Client preferences</td>
<td>109</td>
</tr>
<tr>
<td>General pane</td>
<td>109</td>
</tr>
<tr>
<td>Workspace pane</td>
<td>111</td>
</tr>
<tr>
<td>Startup Mode pane</td>
<td>112</td>
</tr>
<tr>
<td>Archive pane</td>
<td>113</td>
</tr>
<tr>
<td>Setting Quark Publishing Platform preferences: QXP</td>
<td>114</td>
</tr>
<tr>
<td>QXP preferences: General pane</td>
<td>114</td>
</tr>
<tr>
<td>QXP preferences: Workspace pane</td>
<td>116</td>
</tr>
<tr>
<td>QXP preferences: Project and Attachments pane</td>
<td>118</td>
</tr>
<tr>
<td>QXP preferences Article pane</td>
<td>119</td>
</tr>
<tr>
<td>QXP preferences Alerts pane</td>
<td>119</td>
</tr>
<tr>
<td>Setting Quark Publishing Platform preferences: QCD</td>
<td>121</td>
</tr>
<tr>
<td>QCD preferences: General pane</td>
<td>121</td>
</tr>
<tr>
<td>QCD preferences: Workspace pane</td>
<td>124</td>
</tr>
<tr>
<td>QCD preferences: Article pane</td>
<td>125</td>
</tr>
<tr>
<td>QCD preferences: Alerts pane</td>
<td>126</td>
</tr>
<tr>
<td>Redlining</td>
<td>127</td>
</tr>
<tr>
<td>Using Redline controls</td>
<td>127</td>
</tr>
<tr>
<td>Notes</td>
<td>129</td>
</tr>
<tr>
<td>Working with notes</td>
<td>129</td>
</tr>
<tr>
<td>Opening and closing notes</td>
<td>129</td>
</tr>
<tr>
<td>Showing and hiding notes</td>
<td>129</td>
</tr>
<tr>
<td>Deleting notes</td>
<td>129</td>
</tr>
<tr>
<td>Converting between notes and text</td>
<td>130</td>
</tr>
<tr>
<td>Viewing notes by author, date, name, or color</td>
<td>130</td>
</tr>
<tr>
<td>Moving and resizing notes</td>
<td>130</td>
</tr>
<tr>
<td>Printing notes</td>
<td>130</td>
</tr>
<tr>
<td>Notes in PDFs</td>
<td>130</td>
</tr>
<tr>
<td>Web Client</td>
<td>131</td>
</tr>
<tr>
<td>Logging on with Quark Publishing Platform Web Client</td>
<td>131</td>
</tr>
<tr>
<td>Changing password</td>
<td>132</td>
</tr>
<tr>
<td>Customize search results display</td>
<td>132</td>
</tr>
<tr>
<td>Searching in Web Client</td>
<td>133</td>
</tr>
<tr>
<td>Archiving and Restoring in Web Client</td>
<td>133</td>
</tr>
<tr>
<td>Using display options</td>
<td>133</td>
</tr>
<tr>
<td>Previewing assets with Quark Publishing Platform Web Client</td>
<td>135</td>
</tr>
<tr>
<td>Using the Publish features</td>
<td>135</td>
</tr>
<tr>
<td>Editing asset attributes</td>
<td>135</td>
</tr>
<tr>
<td>Viewing asset revisions</td>
<td>136</td>
</tr>
<tr>
<td>Viewing relationship information</td>
<td>137</td>
</tr>
<tr>
<td>Topic</td>
<td>Page</td>
</tr>
<tr>
<td>------------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>Creating articles in Quark Publishing Platform Web Client</td>
<td>137</td>
</tr>
<tr>
<td>Creating projects from templates in Quark Publishing Platform Web Client</td>
<td>138</td>
</tr>
<tr>
<td>Editing articles in Quark Publishing Platform Web Client</td>
<td>138</td>
</tr>
<tr>
<td>Editing text components</td>
<td>139</td>
</tr>
<tr>
<td>Editing picture components</td>
<td>141</td>
</tr>
<tr>
<td>Managing components</td>
<td>141</td>
</tr>
<tr>
<td>Finding and replacing text in articles</td>
<td>142</td>
</tr>
<tr>
<td>Adjusting background color for editing</td>
<td>143</td>
</tr>
<tr>
<td>Changing text size for editing</td>
<td>144</td>
</tr>
<tr>
<td>Working with Rubi</td>
<td>144</td>
</tr>
<tr>
<td>Working with Grouped Characters</td>
<td>145</td>
</tr>
<tr>
<td>Using notes in articles</td>
<td>146</td>
</tr>
<tr>
<td>Editing projects in Quark Publishing Platform Web Client</td>
<td>146</td>
</tr>
<tr>
<td>Callouts in Quark Publishing Platform Web Client</td>
<td>146</td>
</tr>
<tr>
<td>Checking in Other files</td>
<td>146</td>
</tr>
<tr>
<td>Editing Other Files</td>
<td>147</td>
</tr>
<tr>
<td>Using the Web Client Preview pane</td>
<td>147</td>
</tr>
<tr>
<td>Setting Quark Publishing Platform Web Client preferences</td>
<td>147</td>
</tr>
<tr>
<td>Script Manager</td>
<td>150</td>
</tr>
<tr>
<td>Quark Publishing Platform Script Manager configuration</td>
<td>150</td>
</tr>
<tr>
<td>Working with Quark Publishing Platform Script Manager</td>
<td>150</td>
</tr>
<tr>
<td>Logging on with Quark Publishing Platform Script Manager</td>
<td>151</td>
</tr>
<tr>
<td>Creating a script</td>
<td>152</td>
</tr>
<tr>
<td>Importing a script</td>
<td>152</td>
</tr>
<tr>
<td>Deleting and exporting scripts</td>
<td>153</td>
</tr>
<tr>
<td>Writing, editing, and triggering a script</td>
<td>154</td>
</tr>
<tr>
<td>Accessing Quark Publishing Platform Server objects</td>
<td>154</td>
</tr>
<tr>
<td>Loading a script in a script</td>
<td>154</td>
</tr>
<tr>
<td>Logging and debugging scripts</td>
<td>154</td>
</tr>
<tr>
<td>Using utility methods in scripts</td>
<td>155</td>
</tr>
<tr>
<td>Triggering a script</td>
<td>156</td>
</tr>
<tr>
<td>Quark Publishing Platform event-based script example</td>
<td>157</td>
</tr>
<tr>
<td>Executing a script manually</td>
<td>158</td>
</tr>
<tr>
<td>Privileges</td>
<td>159</td>
</tr>
<tr>
<td>Content privileges</td>
<td>160</td>
</tr>
<tr>
<td>Content privileges: General</td>
<td>160</td>
</tr>
<tr>
<td>Content privileges: Edit Attributes</td>
<td>161</td>
</tr>
<tr>
<td>Content privileges: Job Jackets</td>
<td>161</td>
</tr>
<tr>
<td>Content privileges: Edit Redlining</td>
<td>162</td>
</tr>
<tr>
<td>Content privileges: Article Components</td>
<td>162</td>
</tr>
<tr>
<td>Content privileges: Edit Pictures</td>
<td>162</td>
</tr>
<tr>
<td>Content privileges: Editing</td>
<td>162</td>
</tr>
<tr>
<td>Application privileges</td>
<td>163</td>
</tr>
<tr>
<td>Application privileges: Administration</td>
<td>163</td>
</tr>
</tbody>
</table>
ÍNDICE

Application privileges: Workspace.................................................................163

Glossary.............................................................................................................165

Legal notices.................................................................................................175
Introduction

Quark® Publishing Platform™ is a collection of networked applications for creative workgroups. This Guide provides a high-level introduction to the Quark Publishing Platform Client application and the functionality Quark Publishing Platform adds to QuarkXPress® and QuarkCopyDesk®. You can use this Guide to learn what each feature is, what it's for, how you can put it to work for you, and where you can find it. For information about using Quark Publishing Platform with XML Author, see the Quark XML Author for Quark Publishing Platform documentation.

Where we're coming from

This book assumes you are familiar with your computer and know how to:

- Launch an application
- Open, save, and close files
- Use menus, dialog boxes, and palettes
- Use the mouse, keyboard commands, and modifier keys

If you need help performing any of these tasks, consult the documentation resources (user or reference guides) provided with your computer.

Conventions in this book

Formatting conventions in this guide highlight information to help you quickly find what you need.

- Bold type style: The names of all dialog boxes, fields, and other controls are set in bold type. For example: "Click Storage in the Administration pane."
- References: In descriptions of features, parenthetical references guide you in accessing those features. For example: "The System Storage controls (Administration pane) let you designate asset storage."
- Arrows: You will often see arrows (>), which map the path to a feature. For example: "Choose Administration > User Profiles to add a user."
- Icons: Although many tools and buttons are referenced by name, which you can see by displaying ToolTips, in some cases icons are shown for easy identification.
- Cross-platform issues: Some labels, buttons, key combinations, and other aspects of Quark Publishing Platform client applications differ between Mac OS® and Windows® because of user interface conventions or other factors. In such cases, both the Mac OS and Windows versions are presented, separated by a slash, with the Mac OS version presented first. For example, if the Mac OS version of
a button is labeled Select, and the Windows version is labeled Browse, you are directed to "Click Select/Browse." More complex cross-platform differences are mentioned in notes or parenthetical statements.

Notes provide helpful information about particular features and general techniques for using the software.
About Quark Publishing Platform

Quark Publishing Platform is a highly configurable solution for complete, automated, end-to-end multichannel publishing. Quark Publishing Platform is purpose-built to support end-to-end publishing needs, from complete manual publishing systems to highly automated workflows.

The Platform consists of a set of core modules that can be combined in various ways and integrated with third-party systems to accommodate almost any workflow. Its capabilities can be described in terms of content creation, management, publishing, and delivery.

Create
Quark Publishing Platform lets you:

• Design professional templates for different publications
• Author structured content in the familiar Microsoft Word environment
• Integrate content from databases with other forms of content
• Utilize multimedia content such as video, audio, and slideshows

Manage
Quark Publishing Platform provides:

• Workflow and collaboration tools
• Task and update notifications
• Component management
• Automated checks
• Version control

Publish
With Quark Publishing Platform, you can:

• Automatically assemble components of various types from various sources into sophisticated layouts
• Automatically publish those layouts in a variety of formats for a variety of devices

Deliver
The automation features built into Quark Publishing Platform make it easy for you to deliver content to your content consumers in both public and secure environments.
Platform concepts

In order to use Quark Publishing Platform effectively, you should understand some of the key concepts that it uses.

**Assets**: An asset is a unit of independent content. Quark Publishing Platform stores, tracks, and manages assets along with their metadata. The Platform also provides version control of assets, with both major and minor versions. Versioning policy can be configured for each content type within a collection. The Platform also supports multiple renditions of assets (such as previews, thumbnails, XML representations, and so forth), storing renditions along with each version of their original assets. Assets are stored in a configurable repository; the default repository on a file server, but pluggable third-party repositories are also supported.

**Content types**: Every asset has a content type. The content type concept is a unified mechanism for associating metadata, workflows, relationships, privileges, and rendering and publishing actions with different types of content. The Platform can automatically detect a variety of different content types, including pictures, QuarkXPress projects, DITA topics, and DITA for Business Documents. Assigning content types to assets allows the Platform to apply different lifecycles, workflows, and publishing requirements to different types of content. Content types are hierarchical, with child content types inheriting from their parents, for easy and logical configuration. Child content types can be fine-tuned by associating specific metadata and publishing activities with them. In addition to the standard set of content types, the Platform allows you to define your own and provides an auto-detection mechanism for so that they can be automatically recognized.

**Attributes**: Assets can have attributes, which are containers for metadata that model the intrinsic properties of those assets. The selection of attributes for an asset is determined by its content type. You can use attributes to drive custom workflows and publishing processes, and to reflect system-managed state. Attributes are created globally and can be applied to one or more content types.

**Relationships**: A relationship links two assets with one another, with one asset being the parent and the other being the child, and has some associated metadata. There are different types of relationships, with different sets of associated metadata. Relationships can be specific to a particular version of a child asset, or can apply to all versions. Relationships enable component-content management use cases. There are predefined relationships between QuarkXPress projects and article components, and between QuarkCopyDesk article components and pictures, and there is a predefined relationship for XML component references. You can also create your own relationships.

**Component management and referencing** features are available both for XML content and for QuarkXPress/QuarkCopyDesk components. In this context, an asset can be a single topic, a concept, an image, or a media file. Aggregated documents (including DITA maps and QuarkXPress layouts) are also modeled as assets. The content type of an asset determines its role.

The Platform uses asset relationships to model content-component references. For cases of content reuse, the Platform creates multiple relationships, which define such things as a component’s location, its update status, and so forth. You can selectively burst content when you check it into the Platform, for easy reuse. You can pin content to a particular version, or be automatically updated when the master version of the content changes.

**Collections**: A collection is a generic hierarchy that you can use to organize assets. You can model departmental hierarchies, folders, or jobs. You can then map one or more workflows to each collection, and the assets in each collection will follow that collection’s workflow. Collections also have users associated with them, and different users can have different roles in different collections. You can apply collection-specific routing rules and revision control settings, and assign collection-specific...
attributes, and search on a collection-specific basis. A collection’s Job Jackets file defines the resources available for the projects and articles in that collection.

**Workflows:** A workflow helps you to manage the lifecycle of assets by providing a named, ordered set of statuses for those assets to move through. A status-based auto-routing feature helps keep everything on track. You can create different workflows for different content types, use different forms to present attributes in different workflows, and color-code the statuses in a workflow for easy identification. Each workflow can have its own QuarkXPress/QuarkCopyDesk redlining settings and Job Jacket rule evaluations, and you can apply status-based constraints for each attribute.

**Publishing Services:** The Publishing Service Framework is a server-side framework that automates publishing and delivery tasks. You can create configurable and extensible publishing processes that use a variety of renderers, including third-party renderers.

- A **Publishing Process** is a pipeline consisting of re-usable Activities that encapsulate common tasks such as resolving XML component references and QuarkXPress attachments, applying transformations, submitting content to the appropriate rendering engine, packaging and collecting the output, and delivering the rendered output to a CMS or via FTP or HTTP.

- A **Publishing Channel** is a specific configuration of a publishing process that can be mapped to specific content types. The Platform ships with a library of commonly required Activities and several pre-configured Publishing Channels.

- An SDK for developing custom Activities is also available.

**Platform components**

Quark Publishing Platform consists of a set of core modules that can be combined in various ways with each other and with other systems. Depending on the needs of your organization, you may choose to use some or all of these modules.

**Quark Publishing Platform Server:** The heart of Quark Publishing Platform. The Server manages content, controls and coordinates workflows, provides a hierarchical scheme for organizing assets and tracks the relationships between those assets, implements automated versioning, and lets you keep track of users and their permissions. A Web-based administrative interface lets you control and configure the Server.

**Quark Publishing Platform Clients:** A Platform client is any application that can talk to Quark Publishing Platform Server. Available clients include QuarkXPress for Quark Publishing Platform, Quark XML Author for Quark Publishing Platform, Quark Publishing Platform Web Client, QuarkCopyDesk for Quark Publishing Platform, and desktop client for Mac and Windows. You can also implement and integrate your own clients with the Quark Publishing Platform SDK. A sample client for iOS “Gateway Starter App” is also included with the SDK.

- Quark XML Author for Platform: For XML content authoring and reuse in Microsoft Word.
- QuarkXPress: For template development, custom layout, content authoring, and layout and content review.
- QuarkCopyDesk: For content authoring and review.
- Quark Publishing Platform Web Client: For content authoring and review in a Web browser.
- Quark Publishing Platform Client: A generic desktop client, available for Windows and Mac OS.
**Work-in-Progress Repository**: A repository that provides versioning and component management capabilities for XML assets, QuarkXPress assets, and QuarkCopyDesk assets. Once a publication is finalized, the published files can be archived in a system of record.

**Quark Publishing Platform Renderer**: QuarkXPress Server, an engine that produces published files from component assets. QuarkXPress Server can produce output in a variety of formats, including PDF, ePb, and AVE (for deployment to the iPad and other devices).

**DITA Open Toolkit**: An engine that produces published files from XML content that uses the DITA schema. Working with an XSL-FO processor such as Antenna House, the DITA Open Toolkit can produce output in PDF, HTML, RTF, and HTML Help formats.

**Quark Publishing Platform Script Manager**: A scripting engine that allows you to build sophisticated custom functionality into Quark Publishing Platform Server without having to know a programming language.

**Quark Publishing Platform SDK and REST interface**: Robust interfaces that allow you to easily develop your own custom Quark Publishing Platform clients.

In addition to the clients listed above, Quark Publishing Platform can support custom mobile client applications. The Platform includes the source code for a sample mobile application called the Gateway iOS Starter App, which demonstrates how to create a custom Platform client for iPhone or iPad.

### Platform architecture

Quark Publishing Platform is built using open industry standards such as SOA and the Spring framework, to allow easy integration with existing business systems. The architecture of Quark Publishing Platform is shown in the following diagram.

![Quark Publishing Platform architecture](image)

At the center is Quark Publishing Platform Server, which is a Spring-based Java application running in a Web container. This application has a number of services, hosted using the Spring framework,
which it uses to perform various operations such as querying, honoring privileges, and maintaining metadata. You can also write your own custom services for business system integration.

The Publishing Service provides a component-aware publishing framework that can integrate with multiple renderers and delivery systems to publish content in multiple formats, including PDF, eBooks, iPad content, RSS feeds, syndications, and so forth.

At the top of the diagram are the Quark Publishing Platform client applications. These include desktop applications (such as QuarkXPress, QuarkCopyDesk, and Quark XML Author), Web applications (including the Web client and Web administrator), and mobile clients such as the Gateway iOS Starter App. Such client applications can communicate with Quark Publishing Platform Server via SOAP or the REST interface, whichever is a better fit.

Also within the Web container are any adapters that are necessary for Quark Publishing Platform Server to talk to the Work-in-Progress repository or databases. Other adapters connect Quark Publishing Platform Server with output technologies such as the DITA Open Toolkit and the Antenna House XSL-FO formatter.

The Web container also hosts Quark Publishing Platform Renderer, which provides output in a variety of formats (shown in the boxes around the lower left corner). The Renderer includes a load balancer called Server Manager and some number of subrenderers running separately to handle requests as efficiently as possible.

Messaging within the system is handled with Java Message Service (JMS) messages, managed by ActiveMQ.

The Platform can securely communicate with external resources such as LDAP servers using either Kerberos or NTLM encryption. This enables the Platform to support single sign-on and domain users.

Platform features

In addition to the features already discussed, Quark Publishing Platform offers the following.

- **Powerful content reuse features**: You can easily use and reuse assets and XML content in an interface that allows you to preview your changes as they will look at outlook without leaving Microsoft Word. For more information, see the documentation for Quark XML Author for Quark Publishing Platform.

- **Versatile automation features**: Using the Quark Publishing Platform publishing framework, you can create publishing channels (for automatically building output) and delivery channels (for delivering published content to its destination).

- **Workflow management**: Quark Publishing Platform lets you construct workflows that can automatically route files to the appropriate parties based on their statuses, notify those parties of their assigned tasks, add comments to drafts of document, track and review changes, and divide the work on a single document so that different users can work on it simultaneously.

- **Collections hierarchy**: The Work-in-Progress repository can be organized into whatever kind of hierarchy works for your organization.

- **Sophisticated query engine**: Quark Publishing Platform clients can take advantage of a powerful query engine, including metadata search and full-text search, using an intuitive user interface. Queries can be named, saved, and shared among users.
• **Server-side scripting:** Quark Publishing Platform Server comes pre-configured with the Rhino scripting engine for JavaScript. Scripting is implemented using the Apache Bean Scripting Framework (BSF). All services, data transfer objects (DTOs), and JMS messages are available to the script engines. Scripts are executed on the server in a separate thread of the server process for maximum safety and efficiency. Scripts can be triggered manually, by a schedule, or by a server-side event. For more information, see "[Script Manager](#)."

• **Directory server integration:** You can import users from LDAP servers to enable single sign-on. For more information, see "[Managing user lists with LDAP](#)."
Configuration

Users with the Administration role can configure and maintain a Quark Publishing Platform workgroup’s workflow. In addition to establishing structure for users and the content they generate, Administrators control security, set defaults, specify storage locations, and customize the parameters for tracking every asset in their workflow.

Administration client

To administer Quark Publishing Platform Server, navigate to the following URL in a Web browser:

http://[IP address of Platform Server computer]:61400/admin

You can also display the administration from the home page, which is http://[IP address of Platform Server computer]:61400

The Quark Publishing Platform Web Administrator displays.

When you select User Activity, the admin client displays the list of all logged-on users, including each user's name, the time and date each user logged on, each user's machine name, and each user's application. If you need to log off a user, select the user's name in the list and click Log Off Users.

You can also log off users and send a message to a logged-on user.
System area

The System area includes the following controls:

- **Storage**: Use this control to specify one or more storage folders for assets and to establish rules for storing different file types. For more information, see "Configuring storage options."

- **User Activity**: Lets you view logged-on users. For more information, see "Administration client."

Content Model area

The Content Model area includes the following controls:

- **Content Types**: Use these controls to specify which types of content the Platform is managing. For more information, see "Working with content types."

- **Attributes** (also called "metadata" or "headers"): Use these controls to create and configure attributes that can be associated with assets, article components, collection types, and layout types. For example, you could create an attribute called "Image approved" for picture file types. When a user approves an image, he or she can check "Image approved" for the picture. When another user searches for approved pictures, the user can include the "Image approved" attribute in the search criteria and limit the search results to approved images. For more information, see "Defining attributes."

- **Relations**: Use these controls to configure the relationships available between Platform assets. For more information, see "Working with relationships."

Workflow area

The Workflow area includes the following controls:

- **Workflow Definition**: Use these controls to create and configure workflows. For more information, see "Working with workflows."

Users and Groups area

The Users and Groups area includes the following controls:

- **Roles and Privileges**: Use these controls to create, delete, rename, and modify roles and their associated privileges. For details about setting privileges, see "Privileges." For example, you can create a role called "Editorial," and assign this role to your writers and editors. All users with this role will have the same privileges to perform editorial functions.

- **User Profiles**: Use these controls to create a user, assign a role to the user, assign a password, and enable or disable the user's ability to log on. You can also delete, rename, and modify user accounts.

- **Groups**: Use these controls to combine user profiles into groups to which assets can be routed. When you route an assignment to a group, that asset appears in the assignments for everyone in that group. The first person in the group who checks out the asset gains control of that asset. You can also delete, rename, and modify groups.

- **Redline**: Use these controls to specify default redline tracking colors for each user.

Configuring storage options

In versions of Quark Publishing Platform prior to 9.5, you could set up separate repositories for different file types. In version 9.5 and later, you can simply set up a single repository for all asset
types. You can add additional repositories if you need additional space, and change the priority of your repositories to control which one new assets are written into.

To configure storage options, click **Storage**.

### Adding repositories

To add a storage repository:

1. Click the **Repository** tab in the **Administration: Storage** window.

2. Click + to display the **New Repository** dialog box.

3. Enter a name for the repository in the **Name** field.

4. To specify a specific file system directory, choose **fileRepositoryAdapter** and then specify a URL in the **URL** field (for example: /Users/Name/QPP Repository for Mac OS, or C:\QPP Repository for Windows).

   For information about creating a SharePoint repository, see the **Quark Publishing Platform SharePoint Adapter ReadMe**.

   The storage location must include read/write permissions.

### Deleting repositories

To remove a storage repository, click the **Repository** tab in the **Administration: Storage** window, select the repository you want to remove, then click – (minus sign). A warning message prompts you to confirm the deletion.

### Working with content types

Quark Publishing Platform supports a variety of different types of content, including QuarkXPress projects, QuarkCopyDesk articles, picture files, multimedia files, and XML files. The **Content Types**
pane lets you control the way in which information about each of these content types display in Quark Publishing Platform user interfaces.

**Content Types pane**

Different types of content have different attributes. For example, the list of attributes for a picture includes values for "Pixel width," "Pixel height," and "Resolution," and the list of attributes for a text component includes values for "Word count" and "Line count." Some attributes, such as "Checked out duration," are relevant only to Quark Publishing Platform, and are stored only in Quark Publishing Platform.

For XML files that adhere to the DITA and BusDocs schemas, Quark Publishing Platform provides access to specific file-level element and attribute values. For example, you can use the Quark Publishing Platform user interface to view the values of a DITA XML file's `<title>` and `<author>` elements without having to open the file.

By default, Quark Publishing Platform is configured to provide access to a variety of attributes for four categories of content types:

- Article components
- Assets (of various types)
- Quark Publishing Platform collection types (for more information, see "Working with collection types")
- QuarkXPress layouts

You can create new content types for asset, text components, and picture components. You can also create new collection types. To add a new content type, select an eligible parent content type, then click the plus button under the content type list on the left.

You can add new attributes to any content type. These can be existing attributes from the Attributes pane, or entirely new attributes.

- To add an existing attribute to the selected content type, click the plus button under the attribute list on the right and choose Select from Existing.
- To create a new attribute, click the plus button under the attribute list on the right and choose Create New. (For more information, see "Understanding attribute types.") Any new attributes you create are automatically added to the attribute list displayed in the Attributes pane.
There are two ways to disassociate an attribute from a content type:

- To permanently delete the attribute, select it, click the minus button under the attribute list on the right, and choose Delete.
- To disassociate the attribute from the selected content type but leave it in the attribute pool, select the attribute, click the minus button under the attribute list on the right, and choose Remove Mapping.

**Working with collection types**

A collection type is similar to an asset type in that it has a particular set of attributes. By applying a collection type to a collection, you enable users to view and edit attributes for that collection and create a form for editing those attributes.

To configure a collection type, expand the **Collection** category in the content type tree and select the collection type you want to configure.

![Configuring a collection type](image)

For more information, see “*Working with collection types.*”

**Working with attributes**

Each content type has its own set of attributes. For convenience, all attributes are listed in the **Attributes** pane. You can assign attributes to content types in the **Content Types** pane. For more information, see “*Working with content types.*”

**Defining attributes**

Each asset in Quark Publishing Platform has a corresponding set of attributes that describes the asset and its status in the Quark Publishing Platform workflow. Each content type can have its own set of attributes. These attributes include system-generated information such as the date and time of the last modification, default Quark Publishing Platform attributes such as **Checked Out By**, and any custom attributes you create to meet the needs of your workflow. For example, you could create an attribute called **Image approved** for picture file types. When a user approves an image, he or she could check **Image approved** for the picture. When another user searches for approved pictures, the user could include the **Image approved** attribute in the search criteria and limit the search results to approved images.
You can create eight kinds of attribute types: **Text, Date, Time, Number, Measurement, Check Box, Drop-down Menu, and Date Time**. Each attribute type can have a default value. For each attribute, you can limit access so that only users with the privileges to edit "limited-access" fields can edit the attribute values. Attributes are defined at the server level, so each attribute can be used by multiple asset types and collection types.

To create, delete, and modify attributes, click **Attributes** in the navigation pane. The right pane displays the list of attributes available in the system.

Use the **Attributes** pane to create, edit, and delete attributes that help identify Quark Publishing Platform assets.

**Creating an attribute**

To create an attribute:

1. Click + (plus sign) to display the **Create Attribute** dialog box.
Specify the attribute name and type in the **Create Attribute** dialog box.

2. Choose an attribute type from the **Type** drop-down menu. (For more information about attribute types, see "Understanding attribute types.")

3. Enter a name for the attribute in the **Name** field.

4. To allow only users with the "Edit normal- and limited-access fields" privilege to access the attribute, check "Limited Access." For more information, see "Defining Roles and Privileges."

5. Configure the remaining controls. These controls vary depending on which attribute type is selected. For more information, see "Understanding attribute types."

6. To control which content types the attribute is applicable to, check the appropriate boxes in the **Applicable Types** list.

**Understanding attribute types**

There are eight kinds of attributes: **Text, Date, Time, Number, Measurement, Check Box, Drop-down Menu, and Date Time.**

**Text**

Use the **Text** attribute type to create text attributes.

- Enter a default value in the **Default Text** field.
- To indicate the maximum length of text in the field, enter a value in the **Maximum Length** field.

**Date**

Use the **Date** attribute type to create date attributes.

- Enter a default date in the **Default Date** field.
• To constrain users to a particular date range, enter a starting date in the **Start Date** field and an ending date in the **End Date** field.

**Time**

Use the **Time** attribute type to create attributes where users can enter times.

• Enter a default time in the **Default Time** field.

• To constrain users to a particular time range, choose a starting time from the **Start Time** drop-down menu and an ending time from the **End Time** drop-down menu.

> Time values are determined by the Quark Publishing Platform user's locale setting.

**Number**

Use the **Number** attribute type to create attributes where users can enter only numbers.

• Enter a default number in the **Default Value** field.

• To constrain users to a particular numeric range, enter a minimum number in the **Minimum Value** field and a maximum value in the **Maximum Value** field.

**Measurement**

Use the **Measurement** attribute type to create attributes where users can enter only measurements.

• Enter a default number in the **Default Value** field.

• Use the **Units** drop-down menu to specify the unified unit of measure (for example, **Picas** or **Millimeters**).

• To constrain users to a particular measurement range, enter a minimum value in the **Minimum Value** field and a maximum value in the **Maximum Value** field.

**Check box**

Use the **Check Box** attribute type to create check box attributes. To display the attribute with a checkmark by default, check **Checked by Default**.

**Drop-down Menu**

Use the **Drop-down Menu** attribute type to create drop-down menu attributes.
Choose **Drop-down Menu** from the **Type** drop-down menu to create a **Drop-down Menu** attribute type.

Drop-down menu attributes can display lists of values called *attribute domains*. For example, if you create a drop-down menu attribute that requires the list of users on your system, you can use the existing list of users with the attribute rather than entering all the names manually.

1. To assign an attribute domain to a drop-down menu attribute, choose the attribute domain from the **Select Domain** drop-down menu. The attribute domain's contents display in the **Menu Items** list.

2. To create a custom attribute domain, click … to the right of the **Select Domain** drop-down menu. The **Attribute Domain** dialog box displays.
Use the controls in the **Attribute Domain** dialog box to create and view lists that you can add to drop-down menu attributes.

The **Domain Name** list includes the available attribute domains. The **Domain Values** column lists the values for the selected attribute domain.

3 To add an attribute domain, click + (plus sign) below the **Domain Name** column.

4 To enable users to add entries to the drop-down menu attribute, check the box in the **Allow Expansion** column.

5 To warn users when they add an entry to the drop-down menu attribute, check the box in the **Display Warning** column.

6 To alphabetically sort items in the drop-down menu attribute, check the box in the **Sort Items** column.

7 To rename the domain name, double-click its name.

8 To add values to the selected attribute domain, click + (plus sign) below the **Domain Values** column.

9 Click **Done** to close the **Attribute Domain** dialog box and continue creating your drop-down menu attribute.

**Date Time**

Use the **Date Time** attribute type to create attributes for tracking both dates and times.

- Enter a default date and time in the **Default Date** field.
- To constrain users to a particular date/time range, enter a starting date and time in the **Start Date** field and an ending date and time in the **End Date** field.

Time values are determined by the Quark Publishing Platform user's locale setting.
**Setting priority search attributes**

Priority search attributes display at the top of the list of search criteria in the search controls. After the priority search attributes, all search attributes display alphabetically.

![Priority Search Attributes dialog box](image)

**Priority Search Attributes** dialog box

To designate priority search attributes, click Attributes in the navigation pane, and then click Priority Search Attributes. The Priority Search Attributes dialog box displays. To add an attribute to the list, select it in the list on the left and then click the right arrow button.

**Adding constraints to attributes**

Users can edit asset attributes when they check in an asset, when they save a revision, and by selecting an asset and clicking Edit Attributes. Constraints let a Quark Publishing Platform administrator place some controls on how users edit attributes at these times. For example, if you want users with the Editor role to explicitly approve an asset when it reaches Final status, you can use the Require Value constraint to require these users to indicate that the asset is approved or not approved. If a user does not enter a value, "Errors found" displays in red at the bottom of the Check In, Save Revision, or Edit Attribute dialog box. The attribute is also highlighted in red, and the user cannot proceed until he or she provides a value.

Only user-modifiable attributes can be constrained. In addition, you cannot constrain the Workflow and Collection attributes because privileges determine whether these attributes can be modified.

To constrain an attribute for a particular workflow:

1. Click Workflows. The Workflows pane displays.
2. Select a workflow in the Workflow Name list.
3. Click the Attribute Constraints tab.
4. Select the attribute you want to constrain and click Add Constraints. The Add Constraints dialog box displays.
Add Constraints dialog box

5 Choose an option from the View as drop-down menu. This value controls how the information in the list of statuses and roles displays while you establish a constraint. Options include:

- **Status then Role**: Displays a hierarchical list with statuses as main headings and roles as subheadings. You can apply the constraint to individual roles at specific statuses.
- **Role then Status**: Displays a hierarchical list with roles as main headings and statuses as subheadings. You can apply the constraint to individual statuses for specific roles.

If you change the View as option, the active setting will be retained, but will display according to the View as drop-down menu hierarchy.

6 Check the box for the status or user role the constraint is for.

7 When you check a role or status in the list, the constraint types become available for the selected line in the list. There are three kinds of constraints:

- **Prevent Change**: Prevents users from altering the attribute's value.
- **Require Value**: Prevents users from leaving an attribute's value unspecified.
- **Require Change**: Forces users to change the attribute value.

8 To display the status only, check Select All. You can apply the constraint to all or none of the roles at specific statuses. Unchecking Select All displays the roles only.

Constraints are applied based on the user's role and the asset's status at the time the Check in, Save Revision, or Edit Attribute dialog box is displayed. The constraints in effect in these dialog boxes remain the same even if you change the value of the Status drop-down menu.

You can use constraints to enforce automatic routing according to status. For example, you can set up automatic routing for a collection at the status level and use Prevent Change (in the Add Constraints dialog box) to disable modifications of the Route to drop-down menu in the Check In dialog box. This will cause assets to be rerouted when their status changes and prevent users from changing the routing of the asset.
Working with relationships

A relationship is an object that stores the metadata for the association between two objects. Whenever you assign an article from a QuarkXPress layout, drag a picture into a layout, or create an interactive object with App Studio, a relationship object is created to store information about the link you've just created.

For example, if you drag a picture into a QuarkXPress layout, a relationship is created. Among other things, that relationship stores the IDs of both the picture and the layout. This makes it easy to find out which layouts are using a given picture, or how many pictures are attached to a given layout.

There are six types of relationship:

- **Primary attachment**: Stores information about a primary attachment.
- **Secondary attachment**: Stores information about a secondary attachment.
- **Overlay attachment**: Stores an information about an App Studio or ePub attachment.
- **Article component reference**: Stores information about the association between an article component and a linked asset such as a picture.
- **XML component reference**: Stores information about a reference from one XML file to another.
- **Custom**: Developers can create their own relationship types for custom applications.

For more information about attachments, see “Primary and secondary attachments.”

Administrators can view the fields assigned to each type of relationship in the **Relations** pane.

Relations pane

Administrators can also add custom relationship types and assign attributes to them. To view or edit the attributes associated with a relationship type, double-click the relationship type.

In Quark Publishing Platform Web client, users can view the relationships for an asset by displaying that asset in **List View with Relationship Status**. Other Platform clients can view relationships with **Relationship View**.
Working with workflows

In Quark Publishing Platform terminology, a workflow is a set of steps that helps you to publish a document. You define workflows at the server level and then apply them to collections.

Each workflow has the following characteristics:

- A name.
- A list of the asset types to which it applies.
- A set of statuses, in a particular order. The order of the statuses reflects the order of the steps necessary for completing the workflow. For example, you might specify that assets begin with a status called "Assigned," followed by "In Progress," "In Review," and "Completed." You can specify that an asset with the "Completed" status automatically routes to an editor for final approval (for more information, see "Setting up auto routing"). You can also enable or disable Redline tracking, check-in layout evaluation, and output layout evaluation for each status.
- A list of asset attributes. Attributes are defined at the server level, so you can use an attribute in any number of workflows. You can define constraints for some attributes at the workflow level.
- An attribute form for each asset type. (The attribute form displays when you check an asset in.)

Creating a workflow

To create a workflow:


   ![Administration: Workflows screen](image)

   Administration: Workflows screen

2. To create a workflow, click + under the Name list. The Add Workflow dialog box displays.
Add Workflow dialog box

3 Enter a name for the workflow in the Name field.

4 Under Asset Types, check the asset types you want this workflow to be available for.

5 Click OK.

For information on configuring a workflow, see the following topics.

Working with statuses

Each workflow has its own sequence of statuses. To work with a workflow's statuses:

1 Click Workflows. The Workflows pane displays.

2 Select a workflow in the Workflow Name list.

3 Click the Status tab.

4 To add a status, click + in the Status tab. The Create Status dialog box displays.

Create Status dialog box

5 Enter a name for the status in the Name field.

6 Use the Color control to associate a color with the status. This color displays in the Status icon column in the Workspace window.

7 To enable redline tracking for articles with this status in this workflow, check Enable Redline Tracking.
To automatically evaluate layouts with this status in this workflow when their projects are checked in, check **Check In Layout Evaluation**.

To automatically evaluate layouts with this status in this workflow when they are sent to output, check **Output Layout Evaluation**.

You can give a status an associated set of privileges based on the role privileges defined at the server level, or you can custom design a set of privileges for the status.

- You can specify that a status grants the privileges defined for a particular role at the server level by choosing an option from the **Role** drop-down menu and checking **Use Server-level Privileges**.
- You can choose an option from the **Role** drop-down menu and then modify the settings in the **Privileges** list. This does not affect the role privileges settings at the server level; rather, it creates an exception for privileges when assets reach the chosen status.

Click **OK**.

Use the arrows at the bottom right of the **Status** area to set up the statuses so that they occur in the proper order (from top to bottom).

To delete a status, select it in the **Status** tab and click `−`

To edit a status, double-click its name in the **Status** tab.

To duplicate a status, Option+click/right-click the status and choose **Duplicate** from the context menu.

**Working with forms**

The **Asset Form** tab of the **Forms** pane lets you edit the asset forms for each of the content types. The **Collection Form** tab lets you edit the forms associated with the various collection types. To configure a form:

1. Click **Forms** in the navigation pane. The **Forms** pane displays.
2 Click the Asset Form or Collection Form tab.

3 Select a content type or collection type in the tree on the left and click Form Designer. The Form Designer dialog box displays.

![Form Designer dialog box]

4 To display all attributes in a default layout, check Use the Default View for All Fields. To add individual attributes, drag them from the Attribute Name list to the grid. To remove an attribute, click its close box at the upper left. Use each attribute's handles to move and resize the attribute in the grid.

5 Click Save.

Defining Roles and Privileges

All users must belong to a role. A role defines the Quark Publishing Platform privileges for its members.

Roles and Privileges

A role specifies a set of privileges for working within Quark Publishing Platform applications. Each Quark Publishing Platform user belongs to at least one role. To create, delete, rename, and modify roles and their associated privileges, click Roles and Privileges.
Define classifications for different workgroup members in the Administration: Roles and Privileges area.

- To add a role, click + (plus sign). A new role displays in the Roles column. The role's content-type privileges display in a tree in the Content Privileges tab, and the role's available application-specific privileges display in a tree in the Application Privileges tab. Check privileges to enable them, and uncheck privileges to disable them. For detailed descriptions of the available resources, see "Privileges."

- To change the name of a role, Control+click/right-click the role, then choose Rename Role from the context menu. You can also use the toolbar or the contextual menu to rename a role.

- To make a copy of a role, Control+click/right-click the role, then choose Duplicate from the context menu.

- To delete a role, click – (minus sign). An alert asks you to confirm the deletion. If users are assigned to the role, you can assign them to a different role at this time.

Creating and deleting users

To create and delete user profiles, click User Profiles.

Use the Administration: User Profiles window to add and delete users and override user-role settings.
To create a user profile, click +. In the Create User Profile dialog box, enter a user name and password, enter the user's last name and first name, choose a role, and enter the user's e-mail address and phone number. To prevent the user from logging on (for example, if the user is on extended leave), check Disable Log On.

Specify a user's name, role, password, and access in the Create User Profile dialog box.

You can edit a user name by double-clicking it or using the contextual menu.

When you add users, you can pull them from your Lightweight Directory Application Protocol (LDAP) list. See "Managing user lists with LDAP" for instructions. You can add Quark Publishing Platform users in addition to users you manage through the LDAP service.

To delete a user profile, select the profile and click – (minus sign). An alert prompts you to confirm the deletion. If the user had assets routed to him or her, you can reroute the assets at this time.

To duplicate a user profile, select the user profile and choose Duplicate from the contextual menu.

Managing user lists with LDAP

Many system administrators use directory services to manage users on an enterprise network, such as Lightweight Directory Application Protocol (LDAP). The LDAP protocol provides global management over user names and passwords. Quark Publishing Platform administrators are not required to use LDAP, but if they rely on LDAP for other systems, such as e-mail, then Quark Publishing Platform can be configured so that Quark Publishing Platform users can log on to Quark Publishing Platform Server with the same domain username and password they use for other systems on their enterprise network.

The LDAP service must exist within the same domain as your Quark Publishing Platform Server.

Quark Publishing Platform Server is the only Quark Publishing Platform application that maintains communication with the LDAP service.

Quark Publishing Platform Server works with LDAP v3, and X.500 DAP is not required for or supported by this implementation.
Refer to the *Quark Publishing Platform Administration Guide* and *Quark Publishing Platform ReadMe* for more information about integrating LDAP and Quark Publishing Platform Server.

Before you can integrate Quark Publishing Platform Server with an LDAP Directory Server, you must create an LDAP profile and map the LDAP attributes to Quark Publishing Platform user attributes. The topics below explain how to do this.

**Managing LDAP profiles**

Before you can import LDAP users into Quark Publishing Platform, you must create an LDAP profile. An LDAP profile lets you supply the Active Directory Server credentials that are necessary to allow you to import LDAP users.

To create an LDAP profile:

1. Click **User Profiles**.
2. Click **Manage LDAP Profiles**. The **Manage LDAP Profile** dialog box displays.

![Manage LDAP Profile dialog box](image)

3. Click the + button under the **LDAP Profiles** list to create a new LDAP profile.
4. Enter a name for the LDAP profile in the **Profile Name** field.
5. Choose the LDAP server's authentication method from the **Authentication Type** drop-down menu. Valid values include **Kerberos**, **Digest-MD5**, and **Simple**.
6. Enter the realm name in the **Realm** field.
   - The convention is to enter realm names in upper-case letters.
   - Each profile must have a unique realm name.
Enter the user name and password of a user who has read access to the Directory Server (that is, the designated name in the Directory Server). This user authentication will be used to retrieve the list of users from the Directory Server.

To add an LDAP server to the profile, click the + button under the Servers list.

Click Apply.

Click Done.

Mapping LDAP attributes

Before you can import LDAP users into Quark Publishing Platform, you must map the LDAP attributes to Quark Publishing Platform user attributes.

To map LDAP attributes:

1. Click User Profiles.
2. Click LDAP Attribute Mapping. The LDAP Attribute Mapping dialog box displays.

For each field in the dialog box, specify the corresponding LDAP field.

Click OK.

Importing LDAP users

To import users from your LDAP service:

1. Click User Profiles.
2. Click Import Users From LDAP. The Import Users From LDAP dialog box displays.
Use the **Import Users From LDAP** dialog box to add users to your Quark Publishing Platform user list.

3. The search controls at the top of the dialog box let you specify which users you want to be able to import. To create a search:

- Choose the name of the appropriate LDAP profile from the **Profile Name** drop-down menu.
- Enter the search criteria in the **Search Criteria** field. For example, to import all LDAP users that meet the criteria `samaccountname=*`, enter `samaccountname=*`
- Enter the base string in the **Base String** field. In this string, `ou` is an abbreviation for "organizational unit" and `dc` is short for "domain component." This string represents the search base used to search for users in the Active Directory server computer's hierarchy.
- Click **Save** to save the search and provide a name for the search in the dialog box that displays.

4. Choose the search to execute. The matching users are listed on the left.

5. Select one or more names from the **LDAP Users** list on the left and click the right arrow to add selected users to the **Platform Users** list on the right. The **Assign Role** dialog box displays.
Use the Assign Role dialog box to assign a Quark Publishing Platform user to a role.

6. Choose a role from the Role drop-down menu in the Assign Role dialog box and then click OK.

   You can change the search criteria, execute more searches, and continue to add users until you click OK in the Import Users from LDAP dialog box.

7. Click OK. The users in the list on the right are imported.

   If you duplicate a Quark Publishing Platform user that you imported from your LDAP service, the duplicated user is not connected to your LDAP service (that is, it's like creating a new user).

   You cannot have two Quark Publishing Platform users with the same name. If you attempt to add a user name that is the same as an existing user name, you will not be allowed to add the duplicate user name.

   A Quark Publishing Platform administrator must have the "Manage LDAP Users" privilege for the Import Users from LDAP functionality to be available.

Creating and deleting groups

If you combine users into groups, you can route an asset to a group, and any user in that group can check out the asset and work on it. To create and delete groups, click Groups.
Use the **Administration: Groups** screen to create, edit, and delete groups of users.

- To create a group, click + (plus sign). In the resulting dialog box, enter a group name. Use the -> arrow to add users to the group and the <-> arrow to delete users from the group.

Specify group members through the **Create Group** dialog box.

You can edit a group name by double-clicking it, using the toolbar, or using the contextual menu.

- To delete a group, select the group and click – (minus sign). An alert prompts you to confirm the deletion.
- To edit a group, double-click the group name.

**Configuring Redline colors**

For users with redline privileges, administrators specify colors that identify each user's changes.

To specify redline colors:

1. Click **Redline**. The **Redline** pane displays.
The Redline screen lets you assign redline colors to users.

2 Select a user from the User Name list, then click the box in the Redline Color list to display the Colors dialog box. Use the controls in the Colors dialog box to specify a specific color to be applied to text when the user enters text with redlining enabled.

Alternatively, you can check Display All Redline Deletions in One Color to use a single color for identifying deletions by all users.

3 Click Apply.

QuarkXPress and QuarkCopyDesk users can specify default redline colors and styles to differentiate insertions and deletions in WYSIWYG, Full Screen, and Galley views. However, when a QuarkXPress or QuarkCopyDesk user is logged on to Quark Publishing Platform and working on an article tracked by Quark Publishing Platform, the colors assigned by the administrator override the colors specified in the Preferences dialog box. See A Guide to QuarkCopyDesk for information about using the Redline feature outside of a Quark Publishing Platform workflow.

You can turn the Redline feature on and off on a status-by-status basis. For more information, see "Working with statuses."
Maintenance and asset management

Quark Publishing Platform provides remote server monitoring and other tools to promote effective server maintenance. Using the Quark Publishing Platform Client, administrators perform asset management functions to archive completed projects, restore archives, and so forth. This chapter explains how to use these tools.

Monitoring user activity and logging off users

When you select the server name in the Quark Publishing Platform Web Administrator, information about Quark Publishing Platform Server and the users logged on to it displays. To use this information:

1. Click User Activity. The displayed list includes the number of users who are currently logged on to Quark Publishing Platform Server, their names, the time and date each user logged on, each user's machine name, and each user's application (including Quark Publishing Platform Script Manager).

![User Activity pane](image)

2. To log off a user, select the user and click Log Off Users. You can select multiple users to log off more than one at a time.
Deleting assets

You can delete assets using Quark Publishing Platform Client, QuarkCopyDesk, QuarkXPress, or Quark Publishing Platform Web Client. Your preference settings determine how the deletion process for checked-out and attached assets works for each application.

To specify how Quark Publishing Platform Client, QuarkCopyDesk, QuarkXPress, or Quark Publishing Platform Web Client responds when you attempt to delete checked-out assets and assets attached to QuarkXPress projects, use the Checked-out Assets and Attached Assets drop-down menus in the Asset Deletion Options area of the respective Preferences dialog box. The controls are identical for both options. Choose Delete Asset Without Warning to delete checked-out or attached assets without displaying a warning. Choose Never Allow Deletion to prevent the deletion of checked-out or attached assets. Choose Ask Before Deleting to display an alert so you can decide each time you delete a checked-out or attached asset.

To delete assets:

1. Display the search results pane and select one or more assets you want to delete.
2. Click Delete in the Quark Publishing Platform Client Workspace toolbar. If the selected assets are not checked out or attached to a QuarkXPress project, they are deleted. If the selected assets are checked out or attached, the delete process continues according to your preference settings.

Archiving assets

You can use Quark Publishing Platform Client to archive Quark Publishing Platform assets when you're finished with them, and Quark Publishing Platform provides a restore mechanism if you need to reintroduce these assets to your Quark Publishing Platform workflow. Archiving assets requires the “Enable Asset Archiving” privilege.

To archive assets:

1. Display the Workspace pane and select one or more assets to archive.
2. Choose Actions > Archive or click Archive in the Quark Publishing Platform Client Workspace toolbar. The Archive dialog box displays.
3. Specify a folder for storing the archives, enter an archive name, and then click Archive/Save.
4. The selected assets are copied to the location you specify, and the attribute information for these assets is combined in a single XML file.

If you check Delete Assets Afterwards in the Archive pane of the Preferences dialog box (Quark Publishing Platform Client > Preferences), Quark Publishing Platform asks you if you want to delete the assets after a successful archive operation. If Delete Assets Afterwards is unchecked, the original assets remain on Quark Publishing Platform Server.

Quark Publishing Platform confines an archive file and its corresponding XML file to a single folder. When you name the XML file and the folder that contains it, you can identify archive characteristics, such as the date the archive was created. Using descriptive names will help you identify the archive if you need to restore the assets later.
Your archive preferences are stored on Quark Publishing Platform Server, so your user log-on name determines the archive preferences, regardless of the workstation you use to archive assets. However, archive log files are stored in the same folder where you store archive files.

### Restoring assets

You can restore Quark Publishing Platform assets that have been archived if you have the "Enable Asset Archiving" privilege.

In versions 9 and later of Quark Publishing Platform, restoring a project also restores the corresponding versions of all assets attached to that project, and all of those assets are attached to the project. However, if you revert to a previous version of a project, any attached assets are detached.

To restore assets:

1. Display the *Workspace* pane and choose *Actions > Restore* or click *Restore* in the Quark Publishing Platform Client *Workspace* toolbar. The *Restore* dialog box displays.

2. On Mac OS, you can add the *Restore* button to your *Workspace* toolbar.

Use the *Restore* dialog box to locate the archive file you want to restore.

1. Select the XML file that corresponds to the archived assets you want to restore, then click *Restore*.

Using descriptive names for the archive folder and XML file when you create the archive will help you identify assets for restoration.

If one or more of the attributes for the archived assets are no longer part of the server configuration, you can choose alternative attributes in many cases. However, when switching attributes is not possible, the restore process skips to the next archived file. You will need to re-create the missing attribute to restore these skipped assets.

If an asset with the same name and file type is already checked in to Quark Publishing Platform Server, an error occurs and identifies the asset in the log file.
Your "Restore" log files are stored in the same folder where you store archive files. If you do not have write access to the folder where you store archive files, Quark Publishing Platform Server will prompt you to specify a location.
User interface

Users can access their Quark Publishing Platform workflow through the Quark Publishing Platform Client application, Quark Publishing Platform Web Client, and (using XTensions® software) QuarkCopyDesk and QuarkXPress. This chapter provides an overview of the Quark Publishing Platform user interface on both Mac OS and Windows. To learn how to perform application-specific tasks, see the other chapters in this document.

Roles, views, and content structure overview

Before you can use Quark Publishing Platform, you must log on to the server. By default, the Platform includes an existing user named "Admin" with a case-sensitive password of "Admin." Administrators use this name and password to log on for the first time, and Quark recommends enhancing administrative security by changing the password the first time you log on.

For all users, the name and password you use to log on are associated with a particular role. This role determines which privileges you have and which functions are available to you. Consequently, your view of the Quark Publishing Platform user interface may be different from someone else's.

See "Privileges" to learn about specific privileges for a role.

The Workspace Browser window

The Workspace Browser window displays when you log on to Quark Publishing Platform from any Quark Publishing Platform client application.

Workspace Browser window

You can use the Workspace navigation pane to work with files in Quark Publishing Platform.
Workspace pane

You can control what displays in the main area on the right by clicking items in the Workspace navigation pane on the left.

- **Quick Search**: Use the Quick Search field to search for Quark Publishing Platform assets according to asset name, text within an asset, or a combination of asset name and text content.

- **Favorites**: Drag frequently used collections and searches to this area, and they will be available in every Quark Publishing Platform client you use. (In Quark Publishing Platform Web Client, you can Option+click/right-click an asset and use the context menu to add it to or remove it from the Favorites area.)

- **Assignments**: Displays all assets that are routed to you.

- **Attachments** (QuarkXPress only): Displays all assets that are attached to the active layout.

- **Depth** (QuarkXPress only): Displays articles with text components that can fit in the selected text box (within a certain range). For more information, see "QXP preferences: Workspace > Workspace Browser."

- **My Searches**: Displays all of your searches. Click a search to see its results in the search results pane. To duplicate, delete or reload a search, Option+click/right-click it and choose Duplicate Search, Delete Search or Reload Search. You can also Option+click/right-click a search and choose Manage Searches in order to edit, share, duplicate, rename and delete searches.

- **Shared Searches**: Displays all of the shared searches that you have access to. Click a search to see its results on the search results pane.

- **Unsaved Searches**: Displays all unsaved searches that you have created. To delete an unsaved search, Option+click/right-click it and choose Delete Search.

- **Collections**: Displays, in tree format, all of the collections that the active user has access to. You can add an asset to a collection by dragging the asset onto the collection from elsewhere in the collections hierarchy, from the search results area, or from the file system.

The options for Quark Publishing Platform Web Client are slightly different. For more information, see "Quark Publishing Platform Web Client."
Workspace toolbar

The **Workspace** toolbar provides the commands listed in this section. The overflow menu on the right side of the toolbar includes many other commands.

On Windows, the controls in the **Workspace** toolbar are presented using the Windows ribbon interface. This provides additional features, including the **Quick Access Toolbar** feature.

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Assign</td>
<td>Use the <strong>Assign</strong> drop-down menu to display the assignment options: <strong>Text File</strong>, <strong>Graphic</strong>, <strong>QuarkCopyDesk Article</strong>, <strong>QuarkCopyDesk Article Template</strong>, <strong>QuarkXPress Project</strong>, and <strong>QuarkXPress Project Template</strong>. <strong>QuarkCopyDesk Article</strong> displays a submenu with options to create an assignment based on an existing article or based on default specifications from your Quark Publishing Platform Server.</td>
</tr>
<tr>
<td>Check Out</td>
<td>Click this button to open and display the asset selected in the <strong>Workspace Browser</strong> window. The button accommodates different conditions. If you select a checked-in asset, this button checks the asset out. If you select an asset that you have checked-out, this button opens it. If you select an asset that you have open, this button brings that asset's window to the front. When you check out a file, Quark Publishing Platform automatically copies the asset to your computer, stores it in a folder that you have designated for storing checked-out assets (or, if this is your first checkout, prompts you to designate the folder), and opens the asset.</td>
</tr>
<tr>
<td>Cancel Checkout</td>
<td>Click <strong>Cancel Checkout</strong> to cancel an asset checkout without updating Quark Publishing Platform Server with a revision. However, if you made any changes, an alert notifies you that your changes might be lost. If you saved a revision of the asset on Quark Publishing Platform Server, the revision becomes the current version.</td>
</tr>
<tr>
<td>Read Only</td>
<td>Click <strong>Read Only</strong> to display an asset with read-only access. You can view the asset's contents, but you cannot change the asset.</td>
</tr>
<tr>
<td>Get</td>
<td>Click <strong>Get</strong> to move a copy of the selected asset to your computer. If you have the privilege to check in new files, you can rename the asset and check it in.</td>
</tr>
<tr>
<td>Get Collection</td>
<td>Click <strong>Get Collection</strong> to move a copy of the selected collection to your computer.</td>
</tr>
<tr>
<td>Check In</td>
<td>Click <strong>Check In</strong> to check in a checked-out asset selected in the search results pane.</td>
</tr>
</tbody>
</table>
| Check In Other  | *(MAC OS client)* Click **Check In Other** to display the **Check In Other File** dialog box. This dialog box lets you navigate to one or more assets stored locally or on a network. You can specify an asset's attributes before checking in the asset. This dialog also lets you choose folders on the disk to be checked in along with its content and any sub folders and their contents.  
*(Windows client)* Use the **Check In Other** drop-down menu to display the options: **Check In File** and **Check In Folder**. Click **Check In File** to display the **Check In Other File** dialog box. This dialog box lets you navigate to one or more assets stored locally or on a network. You can specify an asset's attributes before checking in the asset. Click **Check In Folder** to check in a folder and all of its subfolders. |
<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Save Revision" /></td>
<td>Click <strong>Save Revision</strong> to display the <strong>Save Revision</strong> dialog box and update Quark Publishing Platform Server with the most current content from the selected asset.</td>
</tr>
<tr>
<td><img src="image" alt="Publish" /></td>
<td>Click <strong>Publish</strong> to publish the selected asset in one of a variety of formats.</td>
</tr>
<tr>
<td><img src="image" alt="Publish as PDF" /></td>
<td>Click <strong>Publish as PDF</strong> to publish the selected asset in PDF format.</td>
</tr>
<tr>
<td><img src="image" alt="Publish as SWF" /></td>
<td>Click <strong>Publish as Adobe Flash</strong> to publish the selected asset in SWF (Flash) format.</td>
</tr>
<tr>
<td><img src="image" alt="Publish as ePUB" /></td>
<td>Click <strong>Publish as ePUB</strong> to publish the selected asset in ePUB format.</td>
</tr>
<tr>
<td><img src="image" alt="Publish as AVE" /></td>
<td>Click <strong>Publish as AVE</strong> to publish the selected asset in AVE (App Studio) format.</td>
</tr>
<tr>
<td><img src="image" alt="Publish as Rich Text Format" /></td>
<td>Click <strong>Publish as Rich Text Format</strong> to publish the selected asset in RTF format.</td>
</tr>
<tr>
<td><img src="image" alt="Publish as HTML" /></td>
<td>Click <strong>Publish as HTML</strong> to publish the selected asset in HTML format.</td>
</tr>
<tr>
<td><img src="image" alt="Publish as QuarkXPress Project" /></td>
<td>Click <strong>Publish as QuarkXPress Project</strong> to publish the selected asset as a QuarkXPress project.</td>
</tr>
<tr>
<td><img src="image" alt="Publish as App Studio Article" /></td>
<td>Click <strong>Publish as App Studio Article</strong> to publish the selected asset as an HTML5 article. Note that you must supply App Studio Publishing Portal credentials in QuarkXPress Server in order to be able to upload App Studio articles to the Portal; for more information, see <em>A Guide to QuarkXPress Server</em>.</td>
</tr>
<tr>
<td><img src="image" alt="Refresh" /></td>
<td>When you click <strong>Refresh</strong>, Quark Publishing Platform performs the active search again and refreshes the search results pane.</td>
</tr>
<tr>
<td><img src="image" alt="Edit Attributes" /></td>
<td>Click <strong>Edit Attributes</strong> to display the <strong>Edit Attributes</strong> dialog box for the asset selected in the window. Attributes are known as metadata in other systems, and they were called &quot;headers&quot; in earlier versions of Quark Publishing Platform. If you have the privilege and an attribute is available, you can change the attribute value in this dialog box and then click <strong>Update</strong>.</td>
</tr>
<tr>
<td><img src="image" alt="Displays" /></td>
<td>Use the <strong>Displays</strong> drop-down menu to control how assets display in the search results pane. For more information, see “View display options.” For users who have the &quot;Enable Enhanced Search Displays in Workspace Browser&quot; privilege, this menu also includes <strong>Project</strong>, <strong>Project and Page</strong>, <strong>Collections</strong>, and <strong>Relationships</strong> options for asset searches. Also, the dialog box that displays when you choose <strong>Custom</strong> includes <strong>Group By</strong> and <strong>Attachment</strong> tabs.</td>
</tr>
<tr>
<td><img src="image" alt="New Search" /></td>
<td>Click <strong>New Search</strong> to create a search with new search criteria.</td>
</tr>
</tbody>
</table>
### USER INTERFACE

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Saved Searches</td>
<td>Use the <strong>Saved Searches</strong> drop-down menu to execute saved searches. The <strong>Saved Searches</strong> list also includes shared searches from other users. Choose <strong>Manage</strong> to display the <strong>Manage Saved Searches</strong> dialog box, which lets you add, edit, share, duplicate, and delete search operations.</td>
</tr>
<tr>
<td>Preview</td>
<td>Click <strong>Preview</strong> to display a large preview of the selected image, QuarkCopyDesk article, or QuarkXPress project. The preview window also displays navigation controls for previewing different pages of the asset. By default, Quark Publishing Platform asset previews include the first five pages of a PDF and the first 20 pages of a QuarkXPress project or QuarkCopyDesk article. Quark Publishing Platform administrators can adjust the number of pages in a preview by editing configuration files. See <em>A Guide to Quark Publishing Platform Administration</em> for details.</td>
</tr>
<tr>
<td>Selection</td>
<td>Information Click <strong>Selection Information</strong> to display the <strong>Selection Information</strong> dialog box. This dialog box contains information about the selected asset or assets, such as whether you can check out the assets or delete components.</td>
</tr>
<tr>
<td>Relationship</td>
<td>Information Click <strong>Relationship Information</strong> to view the primary attachments, secondary attachments (if any), and revision number for the asset selected in the window. For files, the <strong>Relationship Information</strong> dialog box also displays <strong>Layout Name</strong>, <strong>Page Name</strong>, <strong>Page Index</strong>, and <strong>Component Name</strong>. For QuarkCopyDesk files, it displays <strong>Component Name</strong>. For XML files, it displays <strong>XPath</strong>.</td>
</tr>
<tr>
<td>View Revisions</td>
<td>Click <strong>View Revisions</strong> to display the <strong>Revisions</strong> dialog box. This dialog box contains information about the revisions tracked by Quark Publishing Platform Server for the selected asset. You can print a revision, open a read-only copy of a revision, delete a revision, or revert to an earlier version to designate a revision as the current version.</td>
</tr>
<tr>
<td>Index Again</td>
<td>Click <strong>Index Again</strong> to receive updated previews from QuarkXPress Server for articles and projects.</td>
</tr>
<tr>
<td>Delete</td>
<td>Click <strong>Delete</strong> to remove the selected asset from Quark Publishing Platform Server.</td>
</tr>
<tr>
<td>Asset Information</td>
<td>Click <strong>Asset Information</strong> to display the <strong>More Info</strong> window, which lists all the attributes and values for the selected asset.</td>
</tr>
<tr>
<td>View Slideshow</td>
<td>Click <strong>View Slideshow</strong> to display a slideshow of the selected assets.</td>
</tr>
<tr>
<td>Duplicate Item</td>
<td>Click <strong>Duplicate Item</strong> to create a copy of the selected asset on Quark Publishing Platform Server.</td>
</tr>
<tr>
<td>Button</td>
<td>Description</td>
</tr>
<tr>
<td>---------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Export Search Results</td>
<td>You can export the results of a search as an HTML file, an XML file, a tab-delimited file, or a comma-delimited file.</td>
</tr>
<tr>
<td>Archive</td>
<td>Click Archive to display the Archive dialog box to choose the archive location for the selected asset. For more information, see &quot;Archiving assets&quot; and &quot;Restoring assets.&quot;</td>
</tr>
<tr>
<td>Restore</td>
<td>Click Restore to display the Restore dialog box to restore one or more archived assets. For more information, see &quot;Archiving assets&quot; and &quot;Restoring assets.&quot;</td>
</tr>
<tr>
<td>Print</td>
<td>Click Print to print the search results.</td>
</tr>
<tr>
<td>Print Preview</td>
<td>(Windows only) Click Print Preview to display a preview of printed output.</td>
</tr>
<tr>
<td>Customize</td>
<td>On Mac OS, click Customize to display the Workspace toolbar icon controls. Clicking Customize has the same effect as control-clicking the Workspace toolbar and choosing Customize Toolbar.</td>
</tr>
</tbody>
</table>

**Compact View (Mac OS only)**

Click Compact View to reduce the size of the Workspace Browser window and include fewer controls. Many of the other controls automatically move to the overflow menu, and the window identifies the name of the active application. For example, if you choose Compact View and then switch to TextEdit, the Quark Publishing Platform Client window displays the name of the active application and provides buttons for checking in assets, checking out assets, viewing revisions of assets, and searching for other assets.

**Customizing the Workspace toolbar**

You can customize your display on Mac OS by control-clicking the Workspace toolbar and choosing Customize Toolbar. A window displays that allows you to add an icon by dragging it to the toolbar or remove an icon by dragging it from the toolbar. You can add the Customize icon to more quickly access this window. You can also add spacing and dotted-line separators to the Workspace toolbar.

On Mac OS, use the Show drop-down menu at the bottom of the window to display controls (such as the Check In button) with text and icons, text only, or icons only. You can also control the size of the icons.

On Windows, you can add a command to the Quick Access Toolbar by right-clicking the command.
If you decrease the size of the **Workspace Browser** window, increase the size of icons, and display icons and text, the **Workspace** toolbar automatically generates an overflow menu that displays on the right side of the palette to include the controls that don't fit on the toolbar.

**View display options**

View display options let you control how assets display in the workspace. These options are available from the **View** menu *(Mac OS only)* and from the icons above the workspace area in the **Workspace Browser** window.

**Name view**

The **Name** submenu includes the following options.

Choose **List View** to display assets in a list format.

In list views, you can show and hide all columns except the **Name** column.

- To sort (or reverse sort) the search results according to a column, click the column title.
- To show or hide a column, Control+click/right-click the column title and choose the attribute.
- To show or hide multiple attributes, Control+click/right-click the column title and choose **Customize Current View**. The **Configure Columns** tab includes all the attribute fields for you to show or hide.

You can add the **Thumbnails** column to display thumbnail asset previews.

- To reposition a column, click and drag the column title.
- To resize a column, click and drag the column edge.

Quark Publishing Platform assets that match your search criteria but are not attached to projects are listed below **Unattached**. Quark Publishing Platform assets that match your search criteria but are attached to projects that have never been checked in to the Platform Server are listed below **Attached to other projects**. Attached assets can display below multiple projects if they are attached to multiple projects.

Choose **Relationship View** to display the relationships between assets. This lets you determine which assets are used by other assets.
Relations view

Choose **Thumbnails** to display small previews of assets. You can display the color of an asset's status in the border of the thumbnail preview by checking the **Show Status Color around Thumbnails** preference (Quark Publishing Platform Client > Preferences > Workspace). The status color border displays when you choose **Thumbnails**, **Filmstrip**, or **Detailed Thumbnails View** from the Displays > Name submenu.

Thumbnails view

Choose **Filmstrip** to display a large preview of the selected asset with all other assets below it.
Filmstrip view

Choose Snippet View to display a thumbnail preview for each asset, with a thumbnail preview and other asset information to the right of the preview.

Snippet view

Project view

Project view displays search results in a hierarchical structure with QuarkXPress projects at the top. Articles and pictures attached to each project are listed below their respective projects.
Project and Page view

Project and Page view displays search results in a hierarchical structure with QuarkXPress projects at the top. Each page is listed below its respective layout. Articles and pictures in the layout are listed below their respective pages.

If one item attached to a layout matches the search, the project and all the other attachments of the project also display.

An article or picture can display below more than one page if it is attached to multiple pages in a project.

Collections view

Collections view displays search results in the hierarchical structure of the collections tree.

If you are browsing collections, use List View with Attachments to see the assets attached to a project.

Custom view

Custom view displays search results in a hierarchical structure based on four levels of attributes you specify. Choosing Custom displays a window with three tabs: Configure Columns, Group By, and Explore By.
Use the **Configure Columns** tab to specify the attributes you want to display as columns in the search result.

Use the **Group By** tab to specify up to four hierarchical groups within which you can group your search results. This option is not available in Quark Publishing Platform Web Client.
Use the Explore By tab to display QuarkXPress projects and attached assets or to display assets in the collections hierarchy. This option is not available in Quark Publishing Platform Web Client.

**List View with Relationships**

List View with Relationships displays assets in a list view where you can expand projects to see their relationships, and expand articles to see their components.

**List View with Relationship Status**

List View with Relationship Status displays assets in a list view where you can expand projects to see their relationships and view their statuses.

**Icon columns**

In Quark Publishing Platform Client and QuarkCopyDesk, the Workspace Browser window displays four icon columns that provide information about each asset. The Workspace Browser window in QuarkXPress displays a fifth icon column called Local Attachment. These icons display in columns on the left side of the Search Results list in all extended views and List View, as well as under each asset's icon in Thumbnails View and Filmstrip View. In order from left to right, the icons are as follows:

- **Clear Diamonds**: A diamond indicates each asset's status, relative to the last search performed in the Workspace Browser window. A green diamond ◈ indicates the asset has been added to the list since the current search was executed. A white diamond ◇ indicates that an asset's attributes have been updated since the current search was executed, but the asset still meets the search criteria. A gray diamond ◇ and gray shade to the line indicate that another user changed the asset's attributes and the attributes no longer match the search criteria. However, if you made the same change to the asset's attributes, the asset would simply be removed from the Workspace Browser window. If you
click the **Clear Diamonds** icon at the top of the column, all diamonds are removed, the **Workspace Browser** window is updated, and the assets no longer matching the search are removed from the display.

Press Option/Alt while clicking the **Clear Diamonds** icon at the top of the column to lock or unlock the **Clear Diamonds** column. When the **Clear Diamonds** column is locked, asset attribute changes do not display in the **Clear Diamonds** column.

Clicking the diamond next to an asset name removes the diamond for that asset, but the rest of the **Clear Diamonds** column in the **Workspace Browser** window does not change.

- **Global Attachment**: A symbol indicates whether each asset is attached to a QuarkXPress project as a primary or secondary attachment. Select an attachment in the **Workspace Browser** window and click **Attachment Information** to determine attachment status. You can also position your mouse over the **Global Attachment** icon for the asset to display a tooltip (for example, "Indirect Picture Attachment" and "Secondary Global Attachment").

- **Local Attachment** (QuarkXPress only): A symbol indicates any local attachments for the active project (that is, "local" project). Select an attachment in the **Workspace Browser** window and click **Attachment Information** to determine attachment status. You can also position your mouse over the **Local Attachment** icon to display a tooltip (for example, "Unattached Secondary Attachment" and "Secondary Local Attachment").

- **Checked Out**: A symbol indicates whether assets are checked out. If an asset is checked out by the logged-on user, a green checkmark displays. If an asset is checked out by another user, a red checkmark displays. If the logged-on user cannot check out the asset, a red X displays.

- **Status**: A color-coded circle indicates the Quark Publishing Platform status for the selected asset. Your Quark Publishing Platform administrator defines these statuses and associates a color with each status. A tooltip for each color-coded circle displays the status name.

**Preview pane**

The **Preview** pane on the right side of the **Workspace** window displays additional information about the selected asset.
USER INTERFACE

Preview pane

The Preview area displays a preview of the selected asset. If the asset is a project or article, the Preview area displays a spread preview of all pages. If the asset is a project, the Preview area can display a preview of every layout in the project. If the project has multiple Print, Interactive, and/or App Studio layouts, a tab displays at the top for each layout.

You cannot preview projects that contain Web layouts in the Preview area.

Beneath this area are the following tabs:

- **Asset Preview Info**: Displays an overview of the asset's attributes.
- **Asset Information**: Displays all of the asset's attributes.
- **Relationship Information**: Displays information about the asset's attachments.
- **Selection Information**: Displays information about what you can and cannot do with the asset.
- The Revisions area displays the number of asset revisions. Click Revisions to display the Revisions dialog box. This dialog box allows you to see the full list of revisions, view a read-only copy of a revision, revert to a previous revision, or print the asset revision list.

If articles or projects do not display in the Preview Pane, select the assets and click Index Again in the Workspace toolbar to receive updated asset previews from QuarkXPress Server.

Menus (Quark Publishing Platform Client)

The commands in the Quark Publishing Platform Client application window's menus vary depending on the active application, the user's role, and the pane selected on the left side of the window.
Only the Mac OS version of the Quark Publishing Platform Client application has menus. On Windows, use the ribbon interface.

Quark Publishing Platform Client menu (Mac OS only)

The Quark Publishing Platform Client menu includes the following commands:

- **About Quark Publishing Platform Client**: Displays information about Quark Publishing Platform Client, including the version number.
- **Preferences**: Enables you to specify default settings and customize the way Quark Publishing Platform Client performs on your workstation.
- **Log On/Log Off**: The Log On command displays the Log On dialog box. The Log Off command logs off the user but does not exit the application.
- **Quit Quark Publishing Platform Client**: Exits the application.

If you click the close icon in the upper-left corner of the Quark Publishing Platform Client window on Mac OS, the window closes. Click the Quark Publishing Platform Client icon in the Dock to open a new window.

This menu also contains some commands supplied by Mac OS.

File menu

The File menu provides commands for printing the Quark Publishing Platform Client window on Mac OS and Windows, as well as the Quit and Log Off commands on Windows.

- **New Window**: Displays a new Workspace Browser window.
- **Page Setup**: Lets you configure the printed version of the active window.
- **Print**: Prints the active window.
- **Close**: Closes the active Workspace Browser window.
- **Export Search Results**: Lets you export the search results displayed in the search results pane as an HTML file, an XML file, a tab-delimited file, or a comma-delimited file.

Edit menu

The Edit menu includes the following commands:

- **Undo <Last Operation>**: Reverses the last operation performed on content.
- **Redo <Last Operation>**: Reverses the last Undo command performed on content.
- **Cut**: Removes the selected content and stores it on the Clipboard.
- **Copy**: Copies the selected content and stores it on the Clipboard.
- **Paste**: Pastes the Clipboard content at the text insertion point.
- **Select None**: Deselects all the contents of the active document, Workspace window, or field.
- **Select All**: Selects all the contents of the active document, Workspace window, or field.
- **Rename**: Lets you rename the selected item.
**Add**: Adds a new instance of the selected item.

**Edit**: Lets you edit the selected item.

**Duplicate**: Makes a copy of the selected item.

**Program Language**: Lets you change the language of the Quark Publishing Platform interface.

**Delete Selection**: Removes the selected content or item.

**Special Characters**: Displays the **Character Palette** with the character options for available fonts.

### View menu

The **View** menu includes the following commands:

- **Displays** submenu: Use this submenu to control how assets display. For more information, see "View display options."
- **Compact**: Use this command to change the **Workspace** display from **Expanded View** to **Compact View**.
- **Navigation Pane**: Use this command to show or hide the navigation pane on the left.

### Actions menu

The **Actions** menu includes the following commands: for assigning assets, checking assets in and out, opening copies of assets, opening read-only versions of assets, viewing asset information, viewing asset revisions, editing asset attributes, and checking in assets in third-party file formats that cannot be opened with **File > Open** in QuarkXPress or QuarkCopyDesk.

- **Assign**: Use the **Assign** drop-down menu to display six assignment options: **Text File**, **Graphic**, **QuarkCopyDesk Article**, **QuarkCopyDesk Article Template**, **QuarkXPress Project**, and **QuarkXPress Project Template**. **QuarkCopyDesk Article** displays a submenu with options to create an assignment based on an existing article or based on default specifications from your Quark Publishing Platform Server.
- **Check In**: Click **Check In** to check in a checked-out asset selected in the **Workspace Browser** window.
- **Check In Other**: Click **Check In Other** to display the **Check In Other File** dialog box. This dialog box lets you navigate to one or more assets stored locally or on a network. You can specify an asset's attributes before checking in the asset.
- **Check Out**: Click **Check Out** to open and display the asset selected in the **Workspace Browser** window.
- **Read Only**: Click **Read Only** to display an asset with read-only access. You can view the asset's contents, but you cannot change the asset.
- **Get**: Click **Get** to move a copy of the selected asset to your computer. If you have the privilege to check in new files, you can rename the asset and check it in.
- **Publish > Publish as ePUB**: Click **Publish as ePUB** to create an ePUB document from a layout's **Reflow view**.
- **Publish > Publish as App Studio Article**: Click **Publish as App Studio Article** to create an HTML5 App Studio article from a layout and upload it to the App Studio Publishing Portal. Note that you must supply App Studio Publishing Portal credentials in QuarkXPress Server in order to be able to upload App Studio articles to the Portal; for more information, see *A Guide to QuarkXPress Server*. 
• Publish > Publish as Adobe® Flash®: Click Publish as Adobe® Flash® to create a SWF (Flash) version of a layout.

• Publish > Publish as PDF: Click Publish as PDF to create a PDF version of an article or layout.

• Publish > Publish as AVE: Click Publish as AVE to create an App Studio issue from a layout.

• Publish > Publish as QuarkXPress Project: Click Publish as QuarkXPress Project to create a QuarkXPress project from a layout.

• Publish > Publish as RTF: Click Publish as RTF to create an RTF file from a layout.

• Cancel Checkout: Click Cancel Checkout to cancel an asset checkout without updating Quark Publishing Platform Server with a revision. However, if you made any changes, an alert notifies you that your changes might be lost. If you saved a revision of the asset on Quark Publishing Platform Server, the revision becomes the current version.

• Edit Attributes: Click Edit Attributes to display the Edit Attributes dialog box for the asset selected in the window. Attributes are known as metadata in other systems, and they were called “headers” in earlier versions of Quark Publishing Platform. If you have the privilege and an attribute is available, you can change the attribute value in this dialog box and then click Update.

• View Revisions: Click View Revisions to display the Revisions dialog box. This dialog box contains information about the revisions tracked by Quark Publishing Platform Server for the selected asset. You can print a revision, open a read-only copy of a revision, or revert to an earlier version to designate a revision as the current version.

• Asset Information: Click Asset Information to display the More Info window, which lists all the attributes and values for the selected asset.

• Edit Collection Template: Click Edit Collection Template to edit collection templates.

• Restore: Click Restore to display the Restore dialog box to restore one or more archived assets.

• Archive: Click Archive to display the Archive dialog box to choose the archive location for the selected asset.

Go To menu
When the Workspace pane is selected, you can choose Go To > Assignments to display all assets routed to you.

If you have administrator privileges, you can use the Go To menu to navigate to the various administration panes.

Search menu
The Search menu includes the following commands:

• New Search: Creates a search.

• Saved Searches submenu: Choose a search from the Saved Searches submenu to perform a search with predefined criteria. Choose Manage to display the Manage Saved Searches dialog box. This dialog box lets you view and modify saved searches, as well as view and share searches.

• Shared Searches: Choose a search from the Shared Searches submenu to use searches that have been shared with you. The name of the user who shared the search displays in parentheses.
Window menu (Mac OS)

The Window menu includes the following commands:

- **Minimize**: Stores the active window in the dock.
- **Zoom**: Displays the active window on your entire monitor.
- **Bring All to Front**: Brings all active Quark Publishing Platform Client windows to the front.
- The area at the bottom of the Window menu identifies the active window with a checkmark and lists all other open windows.

Help menu

The Help menu displays the Quark Publishing Platform Help file.

Menus (QCD)

See *A Guide to QuarkCopyDesk* for a detailed explanation of QuarkCopyDesk menu commands. The information below applies only to QuarkCopyDesk in a Quark Publishing Platform environment.

When you Control+click/right-click in the layout or on an item, the Platform submenu makes it easy to get to the commands that are appropriate in the current setting.

QuarkCopyDesk menu (Mac OS only)

The QuarkCopyDesk menu is a part of QuarkCopyDesk for Mac OS. This menu includes the following Quark Publishing Platform related commands:

- **Preferences > Quark Publishing Platform**: Enables you to specify default settings and customize the way QuarkCopyDesk works on your computer. Use the Quark Publishing Platform area to specify Quark Publishing Platform specific parameters. See "Setting Quark Publishing Platform preferences — QuarkCopyDesk" for more information.

Platform menu

The Platform menu displays when you install the Quark Publishing Platform XTensions software module in the "XTensions" folder in your QuarkCopyDesk application folder. This menu includes the following commands:

- **Check Out Article**: Displays the Check Out dialog box. This dialog box allows you to check out a QuarkCopyDesk article, article template, or compatible third-party asset.
- **Check In Article**: Displays the Check In dialog box. This dialog box allows you to check in a QuarkCopyDesk article.

You can check in a QuarkCopyDesk template by choosing QuarkCopyDesk Template from the Content Type drop-down menu in the Check In dialog box.

- **Cancel Article Check Out**: Removes a checked-out asset from your computer and makes it available for others to check out. An alert displays, allowing you to save or discard any changes made since your checkout. Also, if you saved a revision on Quark Publishing Platform Server, it becomes the current version when you cancel a checkout.
• **Save Article Revision:** Displays the *Save Revision* dialog box. This dialog box allows you to update Quark Publishing Platform Server to reflect recent changes while leaving the article open for more editing.

• **Attach Picture:** Displays a dialog box that makes it easy for you to attach a picture to the selected checked-out picture component or direct attachment. By default, all pictures routed to you display, but you can also browse and search for other pictures.

• **Replace Picture:** Displays a dialog box that makes it easy for you to replace the picture in the selected checked-out picture component or direct attachment with a new picture. By default, all pictures routed to you display, but you can also browse and search for other pictures.

• **Edit Article Attributes:** Displays the *Edit Article Attributes* dialog box. This dialog box allows you to view and change attribute information for the active QuarkCopyDesk article.

• **View Revisions > Article:** If you have an article checked out and displayed on screen, this command displays the *Revisions* dialog box. This dialog box allows you to display a read-only version of the article, revert the article to an earlier revision, and print the contents of the *Revisions* dialog box.

• **View Revisions > For All Articles:** If you have the privilege and no checked-out articles are displayed on screen, this command displays the *Revisions* dialog box. This dialog box allows you to view article names, display read-only versions of articles, revert an article to an earlier revision, and print the contents of the *Revisions* dialog box.

• **Workspace Browser:** Displays or hides the *Workspace Browser* window.

• **Log On/Log Off:** Logs the user on to or off of a Quark Publishing Platform Server.

---

**Menus (QXP)**

See *A Guide to QuarkXPress* for a detailed explanation of QuarkXPress menu commands. The information below applies only to QuarkXPress in a Quark Publishing Platform environment.

When you Control+click/right-click in the layout or on an item, the *Platform* submenu makes it easy to get to the commands that are appropriate in the current setting.

**QuarkXPress menu (Mac OS only)**

The *QuarkXPress* menu is a part of QuarkXPress for Mac OS. This menu includes the following Quark Publishing Platform related commands:

• **Preferences > Quark Publishing Platform:** Enables you to specify default settings and customize the way Quark Publishing Platform-related tasks are performed within QuarkXPress on your computer. Use the *Quark Publishing Platform* area to specify Quark Publishing Platform specific parameters.

**Utilities menu**

If Quark Publishing Platform XTensions software is installed in the "XTensions" folder in your QuarkXPress application folder, the *Utilities* menu includes the following command.

• **Redline:** Displays the *Redline* palette. For more information, see "Redlining."
### Window menu

If Quark Publishing Platform XTensions software is installed in the "XTensions" folder in your QuarkXPress application folder, the **Window** menu includes the following command:

- **Article**: Displays the Articles palette.
- **Project Attachments**: Displays the Project Attachments palette, which lists the assets attached to the active layout.

### Platform menu

If Quark Publishing Platform XTensions software is installed in the "XTensions" folder in your QuarkXPress application folder, the **Platform** menu displays in QuarkXPress. This menu includes the following commands:

- **Check Out > Project**: Displays the Check Out dialog box. This dialog box allows you to search for and check out a QuarkXPress project or template (or open a read-only version of a QuarkXPress project or template).
- **Check Out > Article**: Lets you check out the article selected in the layout.
- **Check Out > Picture**: Lets you check out the picture attached to the selected picture box.
- **Check Out > Library**: Lets you check out a library.
- **Check In > Project**: Displays the Check In Project dialog box. This dialog box allows you to check in the active QuarkXPress project.

If you also have one or more attached articles checked out when you choose **Check In Project**, all articles are checked in along with the project.

You can check in a QuarkXPress template by choosing **Project Template** from the **Content Type** drop-down menu in the Check In dialog box.

- **Check In > Project With Pictures**: Displays the Check In dialog box with attached and imported pictures displayed in a list on the left. This dialog box allows you to check in the active QuarkXPress project and its pictures.
- **Check In > All Local Pictures**: Lets you check in all pictures that have been locally imported into the active layout. The pictures are not attached to the layout.
- **Check In > Article**: Lets you check in the article selected in the layout.
- **Check In > Picture**: Lets you check in the picture attached to the selected picture box.
- **Check In > Library**: Lets you check in the frontmost library.
- **Cancel Checkout > Project, Cancel Checkout > Article, Cancel Checkout > Picture, Cancel Checkout > Library**: Removes the asset from your computer and makes it available for others to check out.
- **Save Revision > Project, Save Revision > Article**: Updates Quark Publishing Platform Server with your most current changes while leaving the project or article open for more editing.
- **Save Revision > Picture**: Saves a revision of the picture attached to the selected picture box.
- **Save Revision > Library**: Saves a revision of the frontmost library (if it has been checked out from Quark Publishing Platform).
• **Assign as Article**: Assigns the selected text and/or picture boxes as an article.

• **Assign as Picture**: Assigns the picture in the selected box as a direct attachment.

• **Attach Picture**: Displays a dialog box that makes it easy for you to attach a picture to the selected picture box or checked-out picture component. By default, all pictures routed to you display, but you can also browse and search for other pictures.

• **Replace Picture**: Displays a dialog box that makes it easy for you to replace the picture in the selected checked-out picture component or direct attachment with a new picture. By default, all pictures routed to you display, but you can also browse and search for other pictures.

• **Detach**: Detaches any articles or pictures assigned to the selected boxes.

• **Add Component**: To add a new component to an article in the active layout, select one or more boxes and choose this option. If the layout contains more than one article, the **Select Article** dialog box lets you choose which article you want to add to.

• **Edit Attributes > Project, Edit Attributes > Article, Edit Attributes > Picture**: Displays the **Edit <Project/Article/Picture> Attributes** dialog box. This dialog box allows you to view and change attribute information for the active QuarkXPress project, QuarkCopyDesk article, or picture.

• **View Revisions > Project, View Revisions > Article**: If you have the privilege, this command displays the **Revisions** dialog box. This dialog box allows you to view project names or article information, display read-only versions of projects or the active article, revert a project or article to an earlier revision, and print the contents of the **Revisions** dialog box.

• **View Revisions > Picture**: If you have the privilege, this command displays the **Revisions** dialog box for the picture attached to the active picture box.

• **View Revisions > For All Projects**: If you have the privilege and no checked-out projects are displayed on screen, this command displays the **Revisions** dialog box. This dialog box allows you to view project names, display read-only versions of projects, revert a project to an earlier revision, and print the contents of the **Revisions** dialog box.

• **Update > Update All**: Updates all content and geometry in the active project.

• **Update > Content**: Updates all the content in the active box or boxes to include the current content of attached assets stored on Quark Publishing Platform Server.

• **Update > All Content**: Updates all the content in the active QuarkXPress project to include the current content of attached assets stored on Quark Publishing Platform Server.

• **Update > Geometry**: Updates Quark Publishing Platform Server to include the current page geometry of the active box or boxes. This enables a QuarkCopyDesk user who is working on an article attached to the active box or boxes to have exact copyfit information for the assignment.

• **Update > All Geometry**: Updates Quark Publishing Platform Server to include the current page geometry of the active QuarkXPress project.

• **Workspace Browser**: Displays and hides the **Workspace Browser** window.

• **Log On/Log Off**: Logs the user on to or off of Quark Publishing Platform.
Client tasks

Many Quark Publishing Platform operations work the same way in all Quark Publishing Platform client applications. Following a brief overview of the Quark Publishing Platform workflow concepts, this chapter explains how to log on to a Quark Publishing Platform Server, change your password, check assets in and out, assign assets, search for assets, get read-only copies of assets, save revisions of assets, and set application preferences.

Understanding how Quark Publishing Platform works

Quark Publishing Platform provides the tools for teams of people to integrate their writing, designing, and editing skills and produce content for audiences to view and read. This section describes how Quark Publishing Platform works in practice.

An ideal publishing workflow looks like a linear progression from start to finish. But in truth, the process often requires changes, and Quark Publishing Platform accommodates these changes.

Quark Publishing Platform Server and Quark Publishing Platform client applications

The full Quark Publishing Platform software suite includes a Quark Publishing Platform Server that tracks all assets and a collection of client applications for writers, designers, artists, editors, and managers to work on assets. Quark Publishing Platform users transfer assets to one another using client applications, and Quark Publishing Platform Server dynamically maintains a record of this activity for all Quark Publishing Platform users to see.

Administering a Quark Publishing Platform workflow

The Quark Publishing Platform administrator defines the workflows for Quark Publishing Platform, creates the list of users, and assigns each user to a specific role that governs the privileges available to that user. The Quark Publishing Platform administrator also controls where assets are stored, the progression of steps in each workflow, default specifications for new assets, and the attributes (descriptive metadata fields such as name and due date) that are attached to every asset in Quark Publishing Platform. All Quark Publishing Platform users can track assets based on these attributes.

Using XML Author with Quark Publishing Platform

With the Quark XML Author for Quark Publishing Platform, you can create XML content in the familiar Microsoft Word interface, and use the Platform to store it and generate output. You can also break your content down into components and reuse them, as needed, for maximum efficiency. For more information, see the XML Author for Quark Publishing Platform documentation.
Assigning and managing assets from QXP

A Quark Publishing Platform workgroup for a brochure might include a QuarkXPress user responsible for page layout, a QuarkCopyDesk user who writes the brochure copy, a graphic artist who uses an image-editing application, and a remote editorial manager who uses Quark Publishing Platform Web Client to work on text through a Web browser.

Quark Publishing Platform users with an alternate workflow might rely almost entirely on Quark XML Author.

Quark Publishing Platform Server is the central repository of Quark Publishing Platform. Quark Publishing Platform users connect to Quark Publishing Platform Server from Quark Publishing Platform clients, which include Quark Publishing Platform Client, QuarkXPress (with Quark Publishing Platform XTensions software), QuarkCopyDesk (with Quark Publishing Platform XTensions software), XML Author (with the XML Author Quark Publishing Platform Adapter), and a Web browser with Quark Publishing Platform Web Client and Quark Publishing Platform Web Admin.

Let's consider a sample workflow. Note that this is only a sample; different organizations set up their Quark Publishing Platform workflows in different ways. In this workflow, the QuarkXPress user often works as the content manager through which all other work flows.

The layout artist uses QuarkXPress to create the page layout by drawing boxes for text and graphics. Once the layout artist has created the page, he or she checks it in to Quark Publishing Platform Server. The layout is now backed up on the server, and every time the layout artist checks it out and back in, a new revision is created.

The layout artist checks in the layout.

Using Quark Publishing Platform, the layout artist assigns articles to QuarkCopyDesk users and picture boxes to artists working in image-editing applications. The writers and artists receive notification of these assignments, which can also include instructions and other useful information.
in the attributes for the asset. Here, a designer has been assigned to create a picture asset, and a writer has been assigned to write the brochure text.

The designer receives the picture assignment, and the writer checks out the article in QuarkCopyDesk. It is important to note that an article created from a layout comes with geometry, which is a description of the article's size and shape within the layout. Geometry tells the writer exactly how much space he or she has to fill.

Having received their assignments, writers and artists can now do their part to complete the layout. The designer creates the picture, and the writer writes the text.

The designer creates a picture to the layout artist's specifications, and the writer writes an article of the appropriate length.

Next, the designer and writer check in their work to update Quark Publishing Platform Server. Now, like the layout, the picture and article are backed up in a central location, and revisions of the assets will be saved. When the layout artist refreshes the layout, the layout updates to show the work of the designer and the writer.
Once checked in, pictures and articles can be viewed in the layout with which they are associated.

So far we've been looking at a linear workflow. However, workflows are not always linear. For example, what happens if the layout artist decides that the picture should be larger and the text should be shorter? If a layout artist changes the size of a text box in an assigned article, Quark Publishing Platform can automatically update the page geometry to reflect the new size of the box. The writer can then add or remove text to fit the updated page design.

The layout artist updates the layout in Quark Publishing Platform. This automatically updates the geometry in the article. Quark Publishing Platform notifies the writer of the change.

The writer updates the text to fit the available space, checks in the article, and all is well.
The writer updates the text to match the updated geometry and checks in the article. The layout updates to show the updated text.

Now, let's assume the copy editor assigned to fact checking is in another location, and does not have access to the network where Quark Publishing Platform Server is running. The copy editor can simply launch a Web browser, log in through Quark Publishing Platform Web Client, check out the story, and do the copyediting. And because Quark Publishing Platform Web Client is aware of article geometry, the copy editor knows exactly how much space is available.

The remote editor copy edits the article using Quark Publishing Platform Web Client.

As mentioned above, this layout-driven workflow is only one option. An organization might instead choose to use a content-driven workflow, where the designer and writer do their work first, and the layout artist then designs the layout to fit the content. In such a workflow, the designer creates a picture and checks it in with Quark Publishing Platform Client, and the writer creates an article from scratch in QuarkCopyDesk and then checks it in with the Quark Publishing Platform XTensions software.

When this is done, the layout artist creates a layout and attaches the picture to the layout by dragging the file icons from the Workspace Browser window to a picture box, thus creating a relationship between the layout and the picture. The layout artist can use the same method to attach the text of the article to a text box.
In addition, QuarkXPress users can attach the same article in separate QuarkXPress projects. The first attachment is called the "primary attachment," or and all other attachments are "secondary attachments." If the article content changes, all instances are updated.

While working on an assignment, a Quark Publishing Platform user can update the entire workgroup with the status of that assignment by using the Save Revision command. This command updates Quark Publishing Platform Server with the most current version of the assignment. For example, if a QuarkCopyDesk user finishes four of five sections in a brochure assignment and then chooses Save Revision, the editor can open a read-only copy of the text and preview it before the assignment is complete.

Routing and tracking

Many Quark Publishing Platform workflows include a sequence of hand-offs from one team member to another. In Quark Publishing Platform, this is called routing. For example, when a QuarkCopyDesk user completes an assignment, he or she might route the asset to an editor who reads first drafts. Using Quark Publishing Platform Web Client or QuarkCopyDesk, this first-draft editor might finish the job and route the asset to a copy editor, who in turn might route it to a managing editor. As the asset moves from workgroup member to workgroup member, other team members can track the asset's movement using the Quark Publishing Platform search interface.

The Quark Publishing Platform Copytasting feature lets users view the first 255 characters in a QuarkCopyDesk article in the Workspace Browser window. Users can also view a list of all revisions of an asset, open a read-only copy of any revision, open a read-only copy of any current asset, and Get (retrieve) a fully editable copy of any asset tracked by Quark Publishing Platform.

Automating output and export

Organizations often report that the final step in the publishing process — output — requires too much time and money to accommodate last-minute changes. Quark Publishing Platform users can streamline much of the output process by using the Quark Job Jackets controls within QuarkXPress and Quark Publishing Platform Server to eliminate problems before the output stage.

For final output, Quark Publishing Platform provides three ways to automate tasks.

- Within QuarkXPress and QuarkCopyDesk, users can create output styles that specify every aspect of output. With an output style, a single action can trigger output for one or more assets.

- Working with Automation Services or the Quark Publishing Platform Script Manager application for Quark Publishing Platform Server, administrators can write automation profiles or scripts that automate output based on conditions within the Quark Publishing Platform workflow. For example, when a user changes the status of a QuarkXPress project to "Ready for Output," an automation profile or script can output or export the project in any of the supported formats (PostScript®, PDF, PDF/X–1a, PDF/X–3, SWF, PPML, XML, or native QuarkXPress or QuarkCopyDesk format). Automation Services can also transform content from one format to another and upload content to a Web server.

- If an organization requires more automation, the open architecture of Quark Publishing Platform allows third-party developers to fine-tune the output process with XTensions software.

Archiving and restoring

When a project is complete, all the assets can be gathered for archiving within the file system. If the designer needs to revise the brochure or create a similar project in the future, he or she can use the
**Logging on**

You must log on to a Quark Publishing Platform Server to access assets on that server.

The **Log On** dialog box displays when you launch the Quark Publishing Platform Client application, QuarkCopyDesk, or QuarkXPress. Quark Publishing Platform Web Client users log on through the Quark Publishing Platform Welcome screen that displays in the Internet browser window when the user enters the correct URL. If you do not log on at launch, note that **Log On** displays in the **Quark Publishing Platform Client** menu for Quark Publishing Platform Client, the **Platform** menu for QuarkXPress and QuarkCopyDesk, and the Welcome screen of Quark Publishing Platform Web Client.

![Log On dialog box](image)

Use the **Log On** dialog box to access your Quark Publishing Platform Server and, if necessary, change your password.

- The values in the **User Name** and **Password** field are defined for each user by the Quark Publishing Platform administrator. For Quark Publishing Platform sites that use Lightweight Directory Application Protocol (LDAP) to manage user lists, Quark Publishing Platform users log on with their network user names and passwords. Log-on passwords may or may not be case-sensitive, depending on the Quark Publishing Platform administrator's specifications.

- The **Server Name** drop-down menu displays **Enter the Server Name** by default. But after you have logged on to one or more Quark Publishing Platform Servers, the **Server Name** drop-down menu displays the machine names and IP addresses of separate Quark Publishing Platform Servers (if your site runs more than one Quark Publishing Platform Server). Choose an option from the drop-down menu or enter the Quark Publishing Platform Server's IP address and port number in the fields that display.

- The **Protocol** controls let you choose whether to use HTTP or HTTPS for communication with Quark Publishing Platform Server. If you're not sure which to use, ask your Quark Publishing Platform administrator.

- To automatically enter your user name and password the next time you log on, check **Remember Me**.
To bypass the Log On dialog box the next time you log on, check Do Not Show This Dialog Box Again and Remember Me. If you want the Log On dialog box to display again the next time you choose the command, choose Quark Publishing Platform Client > Preferences, click the Startup Mode icon, and uncheck Do Not Display Log On Dialog Box.

To change your password, click the Change Password button. Enter your old password, your new password, and confirmation of your new password.

Creating assets (QCD and QXP)

In addition to creating QuarkCopyDesk articles and QuarkXPress projects according to application defaults (File > New), QuarkCopyDesk and QuarkXPress users who are logged on can create assets with default settings defined in Quark Publishing Platform Server. For QuarkCopyDesk, the command is File > New > Article From Server Ticket. For QuarkXPress, the command is File > New > Project from Server Ticket.

When you choose either of these commands, a New Article/Project from Server Ticket dialog box displays. Choose the collection where you want to store the asset from the Collection drop-down menu, then choose the Job Ticket that should define the characteristics of the new article or project. If there is more than one Job Jackets file associated with the collection, you can select the Job Jackets file and Job Ticket template you want to use. (The default Job Jackets file for the collection displays in bold.) When you're finished, click Continue. Quark Publishing Platform creates an article or project using the Job Ticket template you select.

When creating a new article from Job Ticket, QuarkCopyDesk uses the dimensions and margins defined in that Job Jackets file's default Print Layout resource. (Resources that are not required for article creation are ignored.) If there is no such resource, QuarkCopyDesk displays a dialog box where you can specify page dimensions and margins. In any case, only one master page is used.

You can also create projects and articles from templates in Quark Publishing Platform. For more information, see "Working with templates."

In QuarkXPress and QuarkCopyDesk, you can also create Quark Publishing Platform assets by attaching or importing text or picture content and updating the Quark Publishing Platform Server.

If you want to create a file based on a checked-out article or project, choose File > Save As to create an asset outside of Quark Publishing Platform. If you want to check in the asset, you must have the privilege to check in new files.

Working with collections

A collection is a group of related assets. Each collection can have one or more associated workflows (optionally with automatic routing rules), a set of Job Jackets, a number of associated users and groups, and revision settings for each asset type. A Quark Publishing Platform server contains a hierarchy of collections.

Working with collection templates

Collection templates make it easier to create and maintain collections. For example, assume you have several publications, and each publication needs its own identically configured "Images" subcollection. Rather than creating each "Images" collection manually from scratch, you can create
an "Images Template" collection template, then create each "Images" collection from that template. If you later need to add a user or make a change to the auto routing rules used by the "Images" subcollections, you can simply make the change to the "Images Template" collection template, and the change is automatically applied to all collections that use that collection template.

To create a collection template, Option+click/right-click a collection and choose New Collection Template, then configure the template the way you want it (for more information, see "Creating a collection").

Collection template icons are different from collection icons.

To create a collection from a collection template, Option+click/right-click a collection and choose New Collection From Template, then choose a collection template in the New Collection From Template dialog box and click Continue. Quark Publishing Platform creates a collection from the template you indicate, as a child of the collection you clicked. Note that you cannot change any of the settings of the new collection (except for the name), because the collection pulls all of its settings from the collection template.

To determine which collection template a collection is based on, look at its Collection Template attribute. To see which collections are based on a collection template, click that collection template in the collection tree. The collections based on that collection template display in the Collections pane.

To break the link between a collection and its collection template, Option+click/right-click a collection and choose Edit Collection, then uncheck Link to Collection Template and click OK. The collection retains all of the template's settings, but loses its link to the collection template. Any changes you make to the collection template after this will not be applied to the collection.

There is no way to relink a collection with a collection template.

It's generally a good idea to create a collection named "Collection Templates" at the root level of your collections hierarchy, and store all of your collection templates in that collection.

You cannot check assets into a collection template.

Creating a collection

To create a new collection, Control-click/right-click the new collection's parent and choose New Collection from the context menu. The New Collection dialog box displays. Enter a name for the collection in the Collection Name field, then choose a collection type from the Collection Type drop-down menu. The attribute form for the selected collection type displays. (For more information, see "Working with collection types.") The new collection will be inserted as a child of the collection you click.
Use the **New Collection** dialog box to set up a collection.

By default, a new collection inherits all of the characteristics of its parent collection except for its name and attributes. However, you can change these characteristics if you want.

To edit an existing collection, Control-click/right-click a collection and choose **Edit Collection**.

**Adding workflows to a collection**

Each collection can have one or more workflows. You can use the same workflow for all assets in a collection, or use different workflows for different asset types. Users can switch an asset to a different workflow at any time.

Only users with the appropriate privileges can add workflows to a collection or change an asset to a different workflow. For more information, see "Privileges."

To add workflows to a collection:

1. Control+click/right-click the collection and choose **Edit Collection**. The **Edit Collection** dialog box displays.

2. Click **Workflows** in the list on the left. The **Workflows** pane displays.
Workflows pane

3 To add a workflow, click +. The Workflow Mapping dialog box displays.

Workflow Mapping dialog box

4 To add a workflow to the collection, select it in the list on the left and then click the right arrow button. To remove a workflow from the collection, select it in the list on the right and then click the left arrow button.

5 Click OK.

Adding users to a collection

Each collection can have its own list of users. To add users to a collection:

1 Control+click/right-click the collection and choose Edit Collection. The Edit Collection dialog box displays.
2 Click **User Profiles** in the list on the left. The **User Profiles** pane displays.

![User Profiles pane](image)

3 To add a user, click +. The **User Mapping** dialog box displays.

![User Mapping dialog box](image)

4 To add a user to the collection, select it in the list on the left and then click the right arrow button. To remove a user from the collection, select it in the list on the right and then click the left arrow button.

5 Click **OK** to return to the **Edit Collection** dialog box.

6 To change a user's role within this collection, choose a different user role for that user from the drop-down menu in the **Role** column.

7 Click **OK**.
Adding groups to a collection

Each collection can have its own list of groups. To add groups to a collection:

1. Control+click/right-click the collection and choose Edit Collection. The Edit Collection dialog box displays.

2. Click Groups in the list on the left. The Groups pane displays.

Groups pane

3. To add a group, click +. The Manage Groups dialog box displays.

Manage Groups dialog box

4. To add a group to the collection, select it in the list on the left and then click the right arrow button. To remove a group from the collection, select it in the list on the right and then click the left arrow button.

5. Click OK.
**Setting up auto routing**

Routing rules let you automatically route assets to a particular user or group when those assets reach a certain status.

You must create workflows, users and/or groups, and statuses before you can specify workflow routing.

To set up automatic routing:

1. Control+click/right-click the collection and choose **Edit Collection**. The **Edit Collection** dialog box displays.
2. Click **Auto Routing** in the list on the left. The **Auto Routing** pane displays.
3. You can use this pane to set up auto routing for any of the workflows associated with this collection. Choose the workflow you want to configure from the **Workflow** drop-down menu. The sequence of statuses for that workflow displays.
4. Select a status name and click the **Destination** column to choose the user or group to whom assets with this status should be routed.
   - To specify that these assets should retain their current **Route to** value from the previous status, choose **No Auto Routing**.
   - To specify that these assets should not be routed to a specific user or group, choose **No Group or User**.
   - To specify that these assets should be routed to a specific group, choose the group name.
   - To specify that these assets should be routed to a specific user, choose the user name.
5. Click **OK**.
**Setting up Job Jackets**

A Job Ticket is a package of QuarkXPress resources (preferences, style sheets, colors, and so forth). A Job Jackets file is a container for Job Tickets. In QuarkXPress, you can pre-configure a new project by creating that project from a Job Ticket that contains the desired resources.

In Quark Publishing Platform, you can use a Job Jackets file to define a Job Ticket with a collection of default resources for each collection.

Job Jackets files must be created in QuarkXPress. For more information, see *A Guide to QuarkXPress*.

When you are configuring resources (for example, style sheets, colors, and H&Js) at the collections level, make sure you do not have more than 80 resources per Job Ticket. A larger number of resources can hinder performance in QuarkCopyDesk, QuarkXPress, and Quark Publishing Platform Web Client. If you require more than 80 resources per Job Ticket, you can improve performance by adding unique resources through separate Job Tickets for each collection.

To assign Job Jackets:

1. Control-click/right-click the collection and choose **Edit Collection**. The **Edit Collection** dialog box displays.

2. Click **Job Jackets** in the list on the left. The **Job Jackets** pane displays.

   ![Job Jackets pane](image)

   **Job Jackets pane**

3. To import a Job Jackets file, click +, navigate to the target Job Jackets file, and then click **Open**.

4. To specify which Job Jackets file to use with the collection, select the Job Jackets file.

5. To specify which Job Ticket to use with the collection, expand its Job Jackets file and then select the Job Ticket.
Controlling asset revision handling

To specify asset revision parameters for a collection:

1. In the Workflow navigation pane, Control-click/right-click the collection and choose Edit Collection. The Edit Collection dialog box displays.

2. Click Revision Controls. The Revision Controls pane displays.

3. You can specify different parameters for different file types. For example, you might choose to retain all versions of text files because they have relatively small file sizes, but you might save only the original picture and the most recent revision for larger picture files. Choose an option from the Asset Type drop-down menu.

4. To control the default versioning for asset check-in, click Major or Major and Minor under Create a Version.

5. Configure revision settings for the chosen asset type:
   - To retain every revision of the chosen asset type, click Keep All.
   - To limit automatic revision retention to a specific number of early and recent versions, click By Number and then enter values in the Keep first and keep last fields.
   - To limit automatic revision retention to a specific number of days, click By Days and then enter values in the Keep first and keep last fields.

Editing collections

To edit a collection, Control-click/right-click the collection in the Workspace navigation pane and choose Edit Collection from the context menu. The Edit Collection dialog box displays. This dialog box is very similar to the New Collection dialog box (see "Creating a collection").
All of the panes in the **Edit Collections** dialog box include the **Apply settings to child Collections** drop-down menu.

![Apply settings to child Collections drop-down menu](image)

**Apply settings to child Collections** drop-down menu

You can use the options in this drop-down menu to control how the changes you make in each pane affect the active collection’s child collections.

- **None**: No changes are made to child collections.
- **Merge**: This option adds the parent collection’s settings to all of its child collections. Only settings that are not already present in child collections are added to the child collections. For example, if a child collection has a workflow named “W1,” and you assign a workflow named “W2” to the parent collection, then after the operation the child collection has both the “W1” and “W2” workflows. If a user has different roles assigned in the child collection and the parent collection, the role assignment for the child collection is not changed.
- **Override**: This option overrides all settings for child collections with the new settings for the parent collection. For example, if a child collection has a workflow named “W1,” and you assign a workflow named "W2" to the parent collection, then after the operation the child collection has only the "W2" workflow.

If someone make changes to a collection, an asterisk displays in the label for the **Collections** area in the **Workspace** navigation pane, and the collection’s name displays in italics for everyone except the user who made the change. To update the collection, Control-click/right-click the collection in the **Workspace** navigation pane and choose **Refresh Collection** from the context menu.

If you want to change a collection that is based on a collection template, you must change the collection template or unlink the collection from the collection template. For more information, see "Working with collection templates."

**Duplicating a collection**

When you duplicate a collection, Quark Publishing Platform creates a duplicate of that collection, but not of the assets the collection contains. You can specify whether you want to simply duplicate the collection or also duplicate the hierarchy inside the collection.

To duplicate a collection, Control-click/right-click the collection in the **Workspace** navigation pane and choose **Duplicate Collection** from the context menu.

**Deleting a collection**

To delete a collection, Control-click/right-click the collection in the **Workspace** navigation pane and choose **Delete Collection** from the context menu.

You cannot delete a collection if it or any of its subfolders contains assets.
Appending content (QCD and QXP)

In QuarkXPress and QuarkCopyDesk, you can use the **Append Content** button in the **Workspace Browser** window toolbar to add text from an article component to an article component or a QuarkXPress text box. To use the **Append Content** button:

1. Select a text box in QuarkXPress or text component in QuarkCopyDesk.
2. Select a text component or article in the **Workspace Browser** window.
3. Click the **Append Content** button in the **Workspace Browser** toolbar. The text flows into the text box or text component.

*(Mac OS only)* If the **Append Content** button is not visible, add it to the toolbar. For more information, see "Customizing the Workspace toolbar."

If you are working in QuarkXPress and select an article that contains multiple components in step 5, the **Select Text Component** dialog box displays, which allows you to select a text component. If you are working in QuarkCopyDesk, text in all the components is appended. Picture components are not appended.

The appended text is no longer linked to the article component from which it was appended. If you change the text in the original article component, the change is not updated in the text box or text component.

If you selected text before clicking **Append Content**, the appended content replaces the selected text.

Checking in assets

Although the fields in the **Check In** dialog box may vary, the check-in process is fundamentally the same for all Quark Publishing Platform client applications. The steps vary slightly if you are checking in an asset you have checked out or if you are checking in an asset for the first time. You can also use the **Check In Other** command to check in new QuarkCopyDesk articles, QuarkXPress layouts, and files in third-party formats.

**Check In command**

The **Check In** command is available as a menu command and an icon.

1. Open the asset you want to check in to Quark Publishing Platform Server.
2. Choose **Actions > Check In** or select the checked-out asset in the Quark Publishing Platform Client toolbar and click the **Check In** button. The **Check In** dialog box displays.
Use the **Check In** dialog box to add an asset to Quark Publishing Platform Server (or return a checked-out asset to Quark Publishing Platform Server control).

The **Name** list on the left shows all of the components that will be checked in along with this asset. For example, if you're checking in an article with a picture component and two text components, the **Name** list displays an item for the article, plus two child items for the text components, plus a child item for the picture component. In addition, the picture component has a child item for the picture in the picture component.

You can supply different attribute values for each item. If you do not specify values for the child items, the child items inherit the values specified for the parent item.

3. Choose a target collection from the **Collection** drop-down menu.

![Image](image1.png)

- You can use the search field to find a collection quickly. Mouse over each search result to see its collection path.

4. Choose a workflow from the **Workflow** drop-down menu.

5. To indicate the asset's current status, choose an option from the **Status** drop-down menu.

6. To send the asset to a particular user or group, choose an option from the **Route to** drop-down menu. (Note that if your workflow relies on automatic status-based routing, the **Route to** drop-down menu value might change automatically when you choose an option from the **Status** drop-down menu.)

   - If you do not choose any name from the **Route to** drop-down menu when you check in an asset for the first time, the asset is routed to the active user.

7. To specify whether the asset is saved with a major or minor version number, click **Major** or **Minor** under **Revision**.

   - Access to the **Minor** option is controlled by privileges.

8. Use the **Revision Comment** field to enter a revision comment for the version of the asset you are checking in. The revision comment will be stored with the asset. Depending on the preference setting of the user who checks out the asset, the revision comment displays during the check-out process. The revision comment also displays when you view revisions of the asset.

9. Modify any other available attribute fields as appropriate. Note that access to these attribute fields is determined by your privileges.
10 Click OK. Depending on your preferences, when the check-in process completes, Quark Publishing Platform Server may delete the local copy of the asset.

Check In Other command

The Check In Other command lets you check in new QuarkCopyDesk articles, QuarkXPress layouts, and files in third-party formats.

(MAC OS client) To use the Check In Other command, click the Check In Other button. (Quark Publishing Platform Client users can also choose Actions > Check In Other). Then navigate to the target asset and follow the procedure in the "Check In command" section. Click Check In Folder to check in a folder and all of its subfolders.

(Windows client) To use the Check In Other command, click the Check In Other and the drop-down menu displays the options: Check In File and Check In Folder. Click Check In File to display the Check In Other File dialog box. Then navigate to the target asset and follow the procedure in the "Check In command" section. Click Check In Folder to check in a folder and all of its subfolders.

The Last Modified and Last Modifier attributes indicate the name of the user who checks in a file, as well as the time and date the file is checked in.

Check in multiple assets

You can check in multiple assets in one check-in process with Quark Publishing Platform Client, QuarkXPress, and QuarkCopyDesk. The process is different if you are checking in assets you have checked out or if you are using the Check In Other command to check in new assets.

1 To check in new assets using Quark Publishing Platform Client, (MAC OS client) Click Check In Other or choose Actions > Check In Other. (Windows client) Use the Check In Other drop-down menu to display the options: Check In File and Check In Folder. In QuarkCopyDesk and QuarkXPress, display the Workspace Browser window and click Check In Other. A directory dialog box displays for you to select one or more assets.

2 You can select a range of assets or non-consecutive assets in the list. To select a range of assets, press Shift, select the first asset in the range, select the last asset in the range, then click Open. To select non-consecutive assets in the list, press Command/Ctrl, select an asset, select one or more other assets you want to check in, then click Open.

![Check In dialog box](image)

The Check In dialog box lists the assets on the left. Articles, pictures, and other files are listed in separate groups.
Select an asset in the list on the left, and modify the attribute information on the right.

The asset selection on the left determines the attribute options on the right. You can specify attributes once for multiple assets in a group.

After you specify attributes for the assets, click OK.

To check in multiple assets you have checked out, select the assets in the Workspace Browser window and click Check In. The Check In dialog box displays sequentially for each asset. If Quark Publishing Platform Client users select checked-out QuarkXPress projects or QuarkCopyDesk articles in addition to other checked-out files, the articles and projects are not included in the sequence of Check In dialog box displays. See "Check In command" for more information about the Check In dialog box.

In Quark Publishing Platform Client, QuarkXPress, and QuarkCopyDesk, you can also check assets into a collection by dragging the assets from the file system to the collection's icon in the Workspace Browser window.

Check In Project With Pictures (QXP only)
If a checked-out project contains imported pictures, you can attach the pictures and check them in when you check in the project by choosing Platform > Check In Project With Pictures. This command allows you to specify Quark Publishing Platform attributes for each imported picture. See "Check in multiple assets" for more information about the Check In dialog box for multiple assets.

In QuarkXPress, open a project that contains at least one imported picture.

Choose Platform > Check In Project With Pictures. The Check In dialog box displays with the project name and picture names in separate groups on the left. If the project contains only one imported picture, the picture name displays below the layout name.

Click the project name at the top of the list. The available attributes apply to the project.

Click one or more pictures in the Pictures group. The available attributes apply to the pictures.

Follow the instructions in the "Check In command" section to check in the project and its imported pictures.

Assigning assets
Assignments make it easy for each user to know which jobs they should be working on. When you check in an asset, you can assign it to a particular user or group, or to No One. When you assign an asset, the following things happen:

- A dialog box displays for the user to whom the asset is routed, indicating that the asset is assigned to them.
- The asset is listed in the Assignments area in the Workflow navigation pane for the user to whom the asset is routed.

If the asset is routed to a group, the above is true for every user in that group.
Each user can view the assets assigned to them from any Quark Publishing Platform client in the Assignments area in the Workflow navigation pane.

Assignments displayed in the Workspace Browser window

Assigning assets: Quark Publishing Platform Client

Quark Publishing Platform Client users can make seven kinds of assignments from the Actions > Assign submenu.

To make an assignment from Quark Publishing Platform Client:

1. Click Workspace in the Quark Publishing Platform Client window.
2. To assign a text file, choose Text File.
3. To assign a graphic file, choose Graphic.
4. To assign a QuarkCopyDesk article based on Quark Publishing Platform Server default settings, choose QuarkCopyDesk Article > From Defaults.
5. To assign a QuarkCopyDesk article based on an existing QuarkCopyDesk article, choose QuarkCopyDesk Article > From Article.
6. To assign a QuarkCopyDesk article based on a QuarkCopyDesk template, choose QuarkCopyDesk Article Template.
7. To assign a QuarkXPress project based on an existing QuarkXPress project, choose QuarkXPress Project.
8. To assign a QuarkXPress project based on an existing QuarkXPress template, choose QuarkXPress Project Template.

You can click the Assign button in the Workspace toolbar to access the Assign submenu.

When you create a graphic assignment, Quark Publishing Platform Client checks in a placeholder image that can be opened in an image-editing application and replaced with picture content.

The Content Creator field is empty when you check in a placeholder.
Assigning assets: QXP

When you route an asset to another user, you effectively assign it to that user. But Assign is also a specific command in the Workspace Browser window. To assign an asset from QuarkXPress:

1. Open or display a QuarkXPress project.
2. Draw a box.
3. Display the Workspace Browser window (Platform menu).
4. Do one of the following things:
   • With the box selected, click the Workspace Browser window and choose Assign. (If you are assigning from picture boxes, you can select more than one.)
   • Choose Platform > Assign as Article or Platform > Assign as Picture.
   • Control+click/right-click the box and choose Platform > Assign as Article or Assign as Picture from the context menu.
   • Click Assign in the Project Attachments palette.
5. If you choose Assign as Picture, the Assign Picture Options dialog box displays with options to assign a picture asset or a picture component of a QuarkCopyDesk article. Choose an option and click OK. The Check In dialog box displays.

   If you selected a box containing text before choosing Assign, the Check In dialog box displays. Follow the instructions for "Check In command."

   You can enter asset attribute information in the Check In dialog box.

   You can assign an article as a QuarkCopyDesk article or a QuarkCopyDesk article template by choosing an option from the Content Type drop-down menu in the Check In dialog box.

   To display the Assign Picture dialog box when you drag a picture from the Workspace Browser window to a box in a QuarkXPress project, uncheck Attaching a picture under Do not show Assign dialog box when in the Attachments tab of the Alerts pane in the Preferences dialog box.

   If you duplicate a picture box that contains an attached picture, the picture attachment displays as two separate attachments in the Project Attachments palette after you save a revision of the project or check it in.

   To see which projects and articles are assigned to you, choose Platform > Workspace Browser.

Performing a search

You can use a variety of methods to search for assets and collections in Quark Publishing Platform. You can click Assignments in the Workspace navigation pane to display all assets routed to you. You can click New Search to specify parameters for a new search. And you can choose from predefined search operations that you have created or that other users have shared with you.

To create a search:
1. In the Quark Publishing Platform Client, click the **Workspace** navigation pane.

2. Click **New Search** in the toolbar. Alternatively, you can Option+click/right-click a saved search in the **Workspace** navigation pane and choose **New Search** from the context menu.

3. Use the drop-down menus at the top of the window to specify search criteria.

   - Choose a file type and collection from the two drop-down menus in the **Find Items** search criteria row. To search the subcollections of the selected collection as well as the selected collection itself, check the box on the right end of the row.
   - Use the controls in the **Where** row to narrow the search. To add a row of search options and further narrow the search, click +.
   - To specify inclusive or exclusive criteria, choose **And** or **Or**. Choosing **And** narrows your search. Choosing **Or** widens your search.
   - To delete a row, click the – (minus symbol) button for that row.

   When you finish defining your search criteria, you can click **Count** to see how many assets match the criteria.

   - If the **Count** value is too high, you can refine your search and save time by displaying a smaller search.

4. If you plan to save this search and use it to search for different values, you can use the Ask feature. To use this feature, choose an attribute from the drop-down menu, then click the gray **Ask** icon.

   - The **Ask** icon displays orange.

   When someone executes the search, the **Ask** dialog box will display.
Ask dialog box

5 To add a saved search to the conditions of a search, click New Search, add a row in the search criteria, choose Asset matches search or Asset does not match search from the attribute drop-down menu, and then choose a saved search from the drop-down menu to the right of the attribute drop-down menu. You can add as many conditions as you want on subsequent rows.

- If you choose Asset matches search or Asset does not match search, searches that contain an "Ask" parameter are not included in the list.

6 To execute the search, click Go.

- To save a search for future use, click Save and specify a name for the search. The search name is added to the My Searches area of the Workspace navigation pane and the Search drop-down menu.

- To execute a search again, Control+click/right-click the search in the Workspace navigation pane and choose Reload Search from the context menu or click Refresh in the toolbar.

- In QuarkXPress and QuarkCopyDesk, if you add the Save as PDF button to the Workspace Browser toolbar, you can create a PDF of your search results display. See "Customizing the Workspace toolbar" to learn how to add the Save as PDF button.

Using the Quick Search feature

You can quickly find Quark Publishing Platform assets with the Quick Search feature, regardless of the active application. To use the Quick Search feature, click the magnifier icon at the top of the Workspace navigation pane.

Use the Quick Search control to search for assets according to text contained in the assets. Choose an option from the drop-down menu.
• Choose Name to search according to asset name exclusively.
• Choose Content to search according to asset content exclusively.
• Choose Name and Content to search according to asset name and content.

Performing a nested search
You can narrow a search by creating a nested hierarchy of search conditions. In the example below, the search uses a nested search to look for all assets routed to Tracy or Pat.

1. Click New Search.
2. To add a row of search options, click +.
3. To add a nested condition, choose Asset matches condition from the Where drop-down menu. The Asset matches condition dialog box displays.

![Asset matches condition dialog box]

4. Specify an attribute and choose a condition. You can click + in the Asset matches condition dialog box to combine multiple conditions.

You can also click the Ask icon in the Asset matches condition dialog box to display a prompt when a user performs a conditional search.

5. After you specify parameters in the Asset matches condition dialog box, click Join.

![Nested search]

CLIENT TASKS
Performing a full-text search

The Quick Search control lets you search for assets according to text contained in the assets.

1. Click the Quick Search control to display the Quick Search drop-down menu.

Use the Quick Search control to search for assets according to text contained in the assets.

2. Choose Content to search according to asset content exclusively. Choose Name and Content to search according to asset name and content.

3. Enter text in the Quick Search field and press Enter. The Workspace Browser window displays the results of your Quick Search. The search is also displayed in the Unsaved Searches area in the Workspace navigation pane.

By default, only assets with all the text you enter in the Quick Search field are returned.

4. To refine your full-text search, you can use the following in the Quick Search field:

   • **Phrase search**: You can specify exact wording for more than one word by enclosing your phrase in quotation marks, such as "Bike History." A space between words in a phrase functions like the "AND" operator, and all the words in quotation marks must be together to display in the search results.

   • **Proximity search**: Use "~<number of words>" after a phrase search to specify the number of words that can exist between the words in your phrase. For example, if you enter "Bike History" ~10, the search will find instances of "Bike" and "History" within 10 words of each other.

   • **Wildcard search** (single character): Use "?" to specify a search with a single wildcard character, such as "r?de" to find "ride" and "rode."

   • **Wildcard search** (multiple characters): Use "*" to specify a search with multiple wildcard characters, such as "ride*" to find "rider" and "riders."

   • **Fuzzy search**: Use "~" to specify a search with a range of possibilities for a single word, such as "gearing~" to find "hearing," "gears," and "gearing."

   • **Boolean operators** (AND): You can narrow a search by using the "AND," "&&," and "+" operators to search for exact word combinations. For example, you can search for "Bike" and "History" by entering Bike AND History in the Quick Search field. Use "+" before search terms to search for one mandatory term and another possible term. For example, use +Bike History to find instances where "Bike" exists and "History" might or might not exist.

   Boolean operators must be entered in ALL CAPS.
• **Boolean operators** (OR): You can expand a search by using the "OR" operator to search for one or more words. For example, if you enter "Bike" OR "History" in the Quick Search field, the results can include one or both words.

By default, a space between search terms works like the "AND" operator.

• **Boolean operators** (NOT): You can limit a search by excluding certain words after "NOT" in the Quick Search field. For example, if you enter "Bike History" NOT "History of Skiing," the search results will not include the "History of Skiing" text string combinations.

You can use "!" or "-" instead of "NOT."

You cannot use the "NOT" operator with a single term, such as NOT "Bike History."

**Performing a collection search**

You can use a collection search to locate a collection that has specific attributes. To perform a collection search:

1. Click the Workspace navigation pane.
3. In the Find Items drop-down menu, click Collections to make collection options available.
4. To search a particular collection, choose the collection's name from the following drop-down menu. You can also type the collection's name in the Quick Search field.
5. To search the selected collection's subcollections, check the box at the end of the first row.
6. Use the drop-down menus at the top of the window to specify search criteria.
   - Use the controls in the Where row to narrow the search. To add a row of search options and further narrow the search, click +.
   - To specify inclusive or exclusive criteria, choose And or Or. Choosing Or widens your search. Choosing And narrows your search.
   - To delete a row, click the – (minus symbol) button for that row.

When you finish defining your search criteria, you can click Count to see how many collections match the criteria.

If the Count value is too high, you can refine your search and save time by displaying a smaller search.

7. To execute the search, click Go.

Not all view options are available for the results of collection searches.

To save a search for future use, click Save and specify a name for the search. The search name is added to the My Searches area of the Workspace navigation pane and the Search drop-down menu.
To execute a search again, Control+click/right-click the search in the Workspace navigation pane and choose **Reload Search** from the context menu or click Refresh in the toolbar.

In QuarkXPress and QuarkCopyDesk, if you add the **Save as PDF** button to the Workspace Browser toolbar, you can create a PDF of your search results display. See "Customizing the Workspace toolbar" to learn how to add the **Save as PDF** button.

**Search from here**
To create a search that starts from a particular collection, Option+click/right-click that collection and choose **Search from Here**. Quark Publishing Platform creates an unsaved search in that collection and includes its subcollections.

You can limit the search to that particular collection by unchecking **Search this Collection and its Subcollections** (on the right end of the first row in the search interface).

**Working with saved searches**
To save the active search for future use, click **Save** and specify a name for the search. The search name is added to the **My Searches** area of the Workspace navigation pane and the **Search** drop-down menu.

To return to an unsaved search, click the search in the **Unsaved Searches** area in the Workspace navigation pane. Unsaved searches are named "New Search XX," where XX is a number.

To execute a saved search, click the search in the **Saved Search** area in the Workspace navigation pane. To re-execute a saved search, Control+click/right-click the search and choose **Reload Search** from the context menu.

**Managing searches**
Use the **Manage Saved Searches** dialog box to create, edit, share, duplicate, rename, and delete searches. To display this dialog box, click **Saved Searches** in the Workspace toolbar and choose **Manage** (Mac OS only) or choose **Search > Saved Searches > Manage**.

Use the **Manage Saved Searches** dialog box to create, modify, duplicate, share, and delete searches.
To create a search, click **New**. The **Edit Search** dialog box displays. Enter a name in the **Search Name** field, and then specify search criteria according to the instructions for "Performing a search." Click **Save**, then click **Done** to close the **Manage Saved Searches** dialog box.

To edit an existing search, select a search in the **Manage Saved Searches** dialog box and click **Edit**. The **Edit Search** dialog box displays. Update the criteria, then click **Save**. Click **Done** to close the **Manage Saved Searches** dialog box.

To share a search with other members of your Quark Publishing Platform workgroup, select the search name and click **Share**. Then use the controls in the **Select the Users to share the saved searches with** dialog box to choose the users with whom you want to share the search.

To duplicate a search, select the search name and click **Duplicate**. A new search with the word "Copy" added to the name displays in the **Saved Searches** area.

To rename a search, select the search name and click **Rename**. The search name becomes editable.

To delete a search, select the search name and click **Delete**.

Only the user who shares a search can modify it. Other users can delete the shared search from their lists, but they cannot edit the search.

**Specifying search result display options**

Use the **View > Displays** submenu (Mac OS only), the **Display** drop-down menu in the **Workspace** window, or the buttons at the top of the pane to specify how search results display. For more information about asset display options, see "View display options."

Some of these options are not available for collections searches. For more information, see "Performing a collection search."

Quark Publishing Platform assets that match your search criteria but are attached to QuarkXPress projects that have never been checked in to the Platform are listed under the **Attached to other projects** attribute (in the **Name** attribute column). Attached assets can display under multiple projects if they are attached to multiple projects.

If an item attached to a project matches the search, the project and all the other assets attached to the project also display.

An article or picture can display under more than one page if it is attached to multiple pages in a project.

If you change the view display options for a saved search or collection, the new options are saved for you for that particular collection or search.

**Checking out assets**

To check out an asset, use one of the following methods.
Checking out an asset: Quark Publishing Platform Client

To check out an asset in Quark Publishing Platform Client, click the Check Out icon in the Quark Publishing Platform Client Workspace toolbar or choose the Check Out command in the Actions menu.

Checking out an asset: QCD

To check out an article in QuarkCopyDesk, display the article in the Workspace Browser window and click Check out, Open, or Display. Or, you can choose Platform > Check Out Article. The Check Out dialog box displays with the user's assignments displayed by default.

Select the search and asset options in the Check Out dialog box.

Choose a saved search from the My Searches area. Then select the asset in the list and click Check Out.

You can select an article in the Workspace Browser window, and click Read-Only to open a read-only copy of the article.

Checking out an article or project: QXP

To check out an article in QuarkXPress, you begin by checking out the project to which the article is attached. You can select the text box in the active project that contains the article and choose Check Out Article (Platform menu) or Control-click/right-click the box and choose Platform > Check Out Article. You can also click the Check Out button in the Workspace Browser window.

To check out a project in QuarkXPress, choose Check Out > Project (Platform menu). Then select the target project asset in the Check Out dialog box and click Check Out. You can also click the Check Out, Open, or Display button in the Workspace Browser window.

You can select a project and click Read-Only to open a read-only copy of the project.

Checking out a project with attachments: QXP

When you check out a project, you can check out the project's attachments at the same time with a single operation.

1. Display a Workspace Browser window in QuarkXPress.

2. Click the Check Out with Attachments icon and drag it to the toolbar of the Workspace Browser window.
3 Select a project in the **Workspace Browser** window that contains attachments and click **Check Out with Attachments**. The project and its attachments are checked out.

**Checking out and editing pictures: QXP & QCD**

You can check out and edit attached pictures in QuarkXPress by choosing **Platform > Check Out Picture**. After a picture is checked out, it is located in the folder you specify for storing checked-out files (**QuarkXPress/Edit > Preferences > Quark Publishing Platform > General**). If QuarkVista XTensions software is installed, you can choose **Window > Picture Effects** to display the **Picture Effects** palette and apply picture effects to the attached picture.

If the Edit Original XTensions software is installed, you can also check out and edit attached pictures. Double-click a box that contains an attached picture to display the **Edit Original** dialog box and check out the picture in the background.

You can also Control-click/right-click a picture box that contains an attached picture and choose **Edit Original** from the context menu.

> Whether you use Edit Original or **Platform > Check Out Picture**, you must check in the picture or save a revision to update Quark Publishing Platform Server.

You can also choose **Platform > View Picture Revisions** to view revisions of the image or revert to a previous version.

In QuarkXPress, you can also check out pictures that are not attached to a layout. When you check out such a picture, it opens in the default image-editing application.

**Using Advanced search: QCD and QXP**

You can create a search by choosing **Advanced Search** from the drop-down menu attached to the Quick Search field. You can use this search once, or you can save it with your other searches.

1 Choose **Advanced Search**. The advanced search interface displays.

![](image)

Use the advanced search mode to specify search criteria.

2 To save the search, enter a name in the **Search Name** field, specify search criteria, and click **Save** to execute and save the search. If you do not want to save the search, click **Go** after you specify criteria.
3 Select a file and click **Check Out**.

** Cancelling a Checkout **

To cancel a checkout of an asset, select the asset in the **Workspace** window and click **Cancel Checkout**. The asset is removed from your computer and any changes made since checkout are discarded. However, if you made any changes, an alert notifies you that your changes may be lost. If you saved a revision of the asset on Quark Publishing Platform Server, the revision becomes the current version.

** Working with templates **

In order to maintain consistency in your workgroup, you can create articles from article templates and create projects from project templates.

- To create an article template, design an article in QuarkCopyDesk, choose *File > Save As*, and choose **Article Template** from the **Type** drop-down menu before you click **Save**. QuarkCopyDesk article templates have a suffix of .qct.

- To create a project template, design a layout in a QuarkXPress project, choose *File > Save As*, and choose **Project Template** from the **Type** drop-down menu before you click **Save**. QuarkXPress project templates have a suffix of .qpt.

You can check article templates and project templates into Quark Publishing Platform like you would articles and projects.

To create a new project from a template in QuarkXPress, choose *File > New > Project from Server Template*. In the dialog box that displays, you can choose any project template available to you in Quark Publishing Platform.

To create a new article from a template in QuarkCopyDesk, choose *File > New > Article from Server Template*. In the dialog box that displays, you can choose any article template available to you in Quark Publishing Platform.

You can use Quark Publishing Platform article templates to create and replace geometry in QuarkXPress layouts. For more information, see "**Attaching articles by dragging.**"

** Attaching content to layouts **

In some workflows, content is created in QuarkCopyDesk or another application, and then added to a layout by a layout artist. In other workflows, the layout is created first, and then boxes in the layout are assigned to content contributors as articles. Both adding content from Quark Publishing Platform to a layout and assigning articles from a layout are examples of **attaching** content to a layout.

When you attach an asset to a layout, the **Assign** dialog box may display, depending on whether the asset is attached as a primary or secondary attachment to the layout (see "**Primary and secondary attachments**"). You can use this dialog box to make any necessary changes to the asset's metadata. For example, you might change the status to indicate that it is now in layout, or add to the revision comment.

To see which assets are attached to the active layout in QuarkXPress, click **Attachments** in the **Workspace** navigation pane of the **Workspace Browser** palette.
If you attach an asset to a layout in a project that has not yet been checked in to Quark Publishing Platform, that asset is referred to as a *local asset*. Once you have checked the project in, the asset is referred to as a *global asset*.

**Primary and secondary attachments**

There are two kinds of attachments: *primary attachments* and *secondary attachments*. An article can be a secondary attachment to layouts in multiple projects, but can be a primary attachment for only one layout. The layout that has an article as a primary attachment determines the article's geometry. You cannot edit secondary attachments directly, but you can update them to reflect changes to the contents of the primary attachment.

If an article is a primary attachment for a layout, Quark Publishing Platform sends notifications when certain modifications are made to that article.

- When a layout artist alters the geometry of such an article and then chooses Platform > Update All Geometry, an alert displays for the QuarkCopyDesk user who is working on the text of the article, allowing that person to update the article with the latest geometry from the layout. This allows the QuarkCopyDesk user to respond to any changes in component size. Geometry is also updated at check-in and check-out when the QuarkXPress user checks in the project if *Auto update geometry on: Check In* and *Auto update geometry on: Check Out* are checked in the *Project and Attachments* preferences pane in QuarkXPress.

- If a layout artist updates the geometry for an article, but then cancels the checkout of the project, the geometry is updated to restore it to its original settings if your preferences allow it to.

- If a QuarkCopyDesk user updates the content of such an article and then saves a revision, *Content Differs* displays in the Update State column of the Workspace Browser window for that article. A QuarkXPress user can then update the content by Control+clicking/right-clicking the article and choosing Update Content, clicking the Update Content button in the toolbar of the Workspace Browser window, or double-clicking the asset's icon in the Attachments view in the Workspace Browser window. This allows the QuarkXPress user to respond to any changes in text or picture content. Article content is automatically updated when you check out a project if *Auto update content on: Check-Out* is checked in the *Project and Attachments* preferences pane in QuarkXPress. Article content is automatically updated when you save a revision of a project, check in a project, or output a project if *Auto update content on: Check-Out Check-In/Save Revision/Output* is checked in the same pane.

Pictures are always secondary attachments, because they do not have geometry. Unlike articles, though, pictures can be attached multiple times in the same layout.

A QuarkXPress user can also update geometry with the Update Geometry drop-down menu icon in the Workspace Browser window and by Control+clicking/right-clicking the asset icon and choosing an option from the Update Geometry submenu.

When a layout artist updates an article's geometry, Geometry Differs displays in the Update State column of the Workspace Browser window for that article.

To override an article or component's primary attachment, press Shift and then drag the article or component to a layout. This makes the article or component a primary attachment to the current layout, and converts the old primary attachment into a secondary attachment.
Attaching article components by dragging

To attach a single article component by dragging, drag the article component from the Workspace Browser window to a text or picture box. If the type of the target box does not match the component type, you can press Command/Ctrl to force the box to accept the content.

To attach multiple components, drag them from the Workspace Browser window to a blank part of the page.

You can also drag and drop multiple components by dragging them to a group of boxes. A dialog box allows you to map the components to the appropriate boxes.

When you attach a component to a layout, Quark Publishing Platform assigns the component's type and name to the component's box (whether or not the component has geometry). QuarkXPress users can view a box's component information in the Component tab of the Modify dialog box (Item menu).

Attaching articles by dragging

You can attach an article by dragging either an article or an article template to a layout. The topics below explain how.

To cancel a drag-and-drop operation, press Escape before you release the mouse button.

Dragging articles

The following table explains what happens when you drag an article to various targets in a layout.

<table>
<thead>
<tr>
<th>Target</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>Blank area on the page</td>
<td>Quark Publishing Platform creates boxes for all of the components in the article. If the article has geometry, Quark Publishing Platform uses that geometry (including any relative geometry) when it creates the boxes for the components. If the article has text or pictures, they are added to the layout. Text box links are maintained. The Assign dialog box displays. The list on the left side of the Assign dialog box lets you change the attributes of all of the components from a single dialog box. When you click OK, the entire article is attached to the layout.</td>
</tr>
<tr>
<td>One of two or more selected boxes without attachments</td>
<td>Quark Publishing Platform attempts to map the components in the article to the selected boxes based on content type, component type, and component name. If it cannot, it displays the Map Components to Boxes dialog box (see below) so that you can manually map the content to the boxes. The Assign dialog box displays. The list on the left side of the Assign dialog box lets you change the attributes of all of the components from a single dialog box. When you click OK, the mapped components are attached to the layout. If you press Option/Alt, the existing box is ignored and everything works as if you had dragged the article to a blank area on the page.</td>
</tr>
<tr>
<td>Box without attachment</td>
<td>If the article has one component, Quark Publishing Platform attempts to map the component to the box. If the article has multiple components, Quark Publishing Platform displays the Select Component dialog box so that you can specify which component should be mapped to the box. The Assign dialog box displays. When you click OK, the component is attached to the layout. If you press Option/Alt, the existing box is ignored and everything works as if you had dragged the article to a blank area on the page.</td>
</tr>
<tr>
<td>Box with attachment</td>
<td>Nothing happens. If you press Option/Alt, the existing box is ignored and everything works as if you had dragged the article to a blank area on the page.</td>
</tr>
</tbody>
</table>
Map Components to Boxes dialog box

In the Map Components to Boxes dialog box, the list on the left shows the component names of the boxes in the article, and the list on the right shows the component names of the boxes in the layout. To map a component to a box, choose the component's name from the Component drop-down menu, choose the box's name from the Box drop-down menu, and then click +. Repeat this procedure until all desired components have been mapped, then click OK. You do not have to map every component to a box.

To remove a mapping, select the mapping and click Remove Mapping.

If you map a text component to a picture box or a picture component to a text box, the box type changes to accommodate the component content.

If you drag a multipage article or article template with geometry into a layout, and there are enough pages in the layout to accommodate the content from the article or article template, Quark Publishing Platform places the first page's content at the drop point and then places each remaining page of content on a subsequent page. If there are not enough pages in the layout, Quark Publishing Platform stacks the content from any remaining pages in front of the content on the last page.

Dragging article templates

The following table explains what happens when you drag an article template to various targets in a layout.

<table>
<thead>
<tr>
<th>Target</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>Blank area on the page</td>
<td>Quark Publishing Platform creates boxes for all of the components in the article template. If the article template has geometry, Quark Publishing Platform uses that geometry (including any relative geometry) when it creates the boxes for the components. If the article template has text or pictures, they are added to the layout. Text box links are maintained. Quark Publishing Platform also automatically creates an article from the template and displays the Assign dialog box. The list on the left side of the Assign dialog box lets you change the attributes of all of the components from a single dialog box. When you click OK, the new article is attached to the layout.</td>
</tr>
</tbody>
</table>
If you drag a multipage article or article template with geometry into a layout, and there are enough pages in the layout to accommodate the content from the article or article template, Quark Publishing Platform places the first page's content at the drop point and then places each remaining page of content on a subsequent page. If there are not enough pages in the layout, Quark Publishing Platform stacks the content from any remaining pages in front of the content on the last page.

### Attaching articles by assigning

To attach an article to a layout by assigning:

1. Create one or more text boxes and picture boxes for the article.
2. Select all of the boxes that should be in the article.
3. In the **Workspace Browser** window, click the Assign button 🎨. You can also Option+click/right-click the box and choose **Platform > Assign as Article**. If the box is a picture box, you can choose **Platform > Assign as Picture** to create a direct attachment.
4. A dialog box displays. Fill out any desired fields. For example, you would probably want to set a status and route the article to someone.
5. Click **OK**.

### Attaching text files to layouts

You can attach text files in the following formats to a layout:

- Microsoft Word .doc
- Microsoft Word .docx
- RTF
- Plain text

To attach a text file to a layout, drag it to a text box or to a blank area on the page. (You can also press Command/Ctrl and drag the file to a picture box or no-content box.) Quark Publishing Platform treats a text file as an article with a single text component and no geometry or page picture.

After you attach a text file to a layout, you can check the text file out in QuarkXPress, QuarkCopyDesk, or Quark Publishing Platform Client and make changes. (Note, however, that you cannot do this when using Quark Publishing Platform with InDesign and InCopy.)

In QuarkXPress and QuarkCopyDesk, you can check out an attached text file, make changes to the content in QuarkXPress or QuarkCopyDesk, and then check it back in as a new revision.
Similarly, a Quark Publishing Platform Client user can check out a text file that is attached to a layout, make changes to the content in a text editing application, and check it back in. In any QuarkXPress layout or InDesign document that has the text file as an attachment, the Update State column in the Workspace Browser window displays Content Differs, and you can choose Update Content to get the latest version of the text file's contents.

Attaching pictures to layouts
There are two types of picture attachments: Direct attachments and component attachments. In a direct attachment, you attach only the picture to the layout. In a component attachment, you attach a new article with one picture component (and the picture it contains) to the layout.

To attach a picture asset to a layout, drag the picture file to a picture box or to a blank area on the page. (You can also press Command/Ctrl and drag the file to a text box or no-content box.) The Assign Picture dialog box displays, allowing you to change the picture's attributes.

You can attach a picture to an anchored picture box, but only as a direct attachment.

Attaching App Studio assets
In Print and App Studio layouts, you can attach pictures, videos, and sound files that have been checked into Quark Publishing Platform to boxes using the App Studio palette. In an App Studio layout, if you attach an asset to a box that is shared between multiple layouts in a layout family, the asset is listed in Quark Publishing Platform as being attached multiple times. In the QuarkXPress Usage dialog box (Utilities menu), App Studio assets added from Quark Publishing Platform are identified with a Platform in the Source column.

You can attach a picture asset and one or more App Studio assets to the same box. For example, if you want a picture box to display a static picture until the user taps it, and then you want it to display a slideshow when tapped, you must attach not only the static picture but all of the pictures in the slideshow to that picture box. To accomplish this, attach the picture asset to the box the usual way, then attach the App Studio asset or assets to the box using the App Studio palette. In the Workspace Browser palette, the box will show that multiple assets are attached to it.

For more information about App Studio, see "App Studio" in A Guide to QuarkXPress.

If you use the Workspace Browser window to detach an article that is attached to a box that is shared between multiple layouts in a layout family, the asset is detached only from the active layout.

Attaching multimedia assets to reflow articles
When you are working with a reflow article in QuarkXPress, you can associate picture, audio, and video Quark Publishing Platform assets with picture boxes, for display in exported ePUB e-books. To use a Quark Publishing Platform audio or video asset in a reflow article, add an audio or video component as described in A Guide to QuarkXPress. When the Interactive Attributes dialog box displays, click the Quark Publishing Platform button instead of the Attach button.

Tracking attachments
Attachments make it easy for an administrator to determine which assets are being used in which layouts. Administrators can get information about asset usage in the following ways:
In the Workspace Browser window, Control+click/right-click an article or component and choose Relationship Information. The Relationship Information dialog box shows which projects the component is used in. If an article has an attached picture, the Refers to tab shows the picture as having a relationship with the article. For each project, the dialog box indicates which layout and page number the component occurs on.

Relationship Information dialog box

You can view the same information in the tabs at the bottom of the Preview pane.

Choose Project and Page from the Display Mode drop-down menu, then expand the projects in the palette to see which components are attached to them. For each project, the dialog box indicates which layout and page number the component occurs on.

Detaching components

When you detach a component from a layout, Quark Publishing Platform handles the detachment differently depending on the component type.

- When you detach a picture component, a dialog box lets you choose to delete the picture from the layout or save a linked local copy of the picture file.

- When you detach a text component, the text box and content remain in the layout by default. To delete them during the detach process, press Option/Alt before you click the Detach button. You can also delete and detach an item by pressing Shift-Delete or by selecting the item, pressing Delete, and then clicking Continue if necessary. (By default, the Do not show alert when: Deleting a box with a server attachment preference is checked, so you may not need to press Continue.)

To detach a component, select it in the layout and choose Platform > Detach, or Control+click/right-click the component in the layout and choose Detach from the context menu.

Attaching digital assets to layouts

When Quark Publishing Platform XTensions software for QuarkXPress is installed, you can attach picture, video, and audio Quark Publishing Platform assets to HTML5 object using the HTML5 palette. In general, such assets are referred to as digital assets.

To add a Quark Publishing Platform asset to an HTML5 object, click Quark Publishing Platform in the HTML5 palette, then click Browse Quark Publishing Platform.
Once you have checked in or saved a revision of the project, the **Workspace Browser** will show that multiple assets are attached to the box. (Digital assets that are attached to a layout are referred to as *overlay assets*, and are identified with an icon.)

In the QuarkXPress Usage dialog box (Utilities menu), digital assets added from Quark Publishing Platform are identified with a **Platform** in the Source column.

All asset-related privileges under are honored for audio and video assets.

For more information about App Studio, see *A Guide to App Studio*.

Attachments that have been attached through the HTML5 palette do not display in the **Project Attachments** palette.

For information on creating AVE issues with QPS, see *A Guide to QPS*.

### Replacing article geometry

In QuarkXPress, you can replace an attached article's geometry with the geometry from an article template. To do so, drag the article template to a box that is part of the existing attached article. Quark Publishing Platform attempts to automatically map the article template components to the appropriate boxes based on content category, component type, and component name.

In order for Quark Publishing Platform to map the components automatically, the content types, component types, and component names in the article template must exactly match the content types, component types, and component names in the article.

### Working with libraries

You can check a QuarkXPress library into and out of Quark Publishing Platform, route it, change its status, and so forth, just like any other type of asset.

To check an open library into Quark Publishing Platform from within QuarkXPress, open the library and then choose **Platform > Check In Library**. If more than one library is open, the frontmost library is checked in.

By default, double-clicking a library in the **Workspace Browser** window opens a read-only copy of that library. To change what happens when you double-click a library, use the controls in the QuarkXPress/Edit > Preferences > Quark Publishing Platform > Workspace > Mouse Settings tab > QuarkXPress Libraries area.

When working with libraries, remember:

- Libraries created on Mac OS cannot be opened on Windows, and libraries created on Windows cannot be opened on Mac OS.
- You cannot see previews of libraries in the **Workspace Browser** window.

Libraries have the same metadata as QuarkXPress projects.

You cannot attach a library to a layout.
Libraries and picture components
If you drag a picture box that contains an attached picture into a library, then check the library into Quark Publishing Platform, the picture attachment is maintained. If you drag the picture box out of the library into a different layout, a new picture attachment is created in the new layout. So if you then update the picture in Quark Publishing Platform, the picture in the new layout is updated.

The same is not true for text boxes, however; when you drag a text box with an attached article from a library to a layout, Quark Publishing Platform simply creates a copy of the text box with no links to Quark Publishing Platform.

Using Read-Only to view an asset
To open a read-only version of an asset, select it in the Workspace window and click Read-Only. The read-only asset is copied to your Quark Publishing Platform local files folder and the asset opens in read-only mode.

If you want to create a file based on a read-only copy, choose File > Save As to create an asset. If you want to check in the asset, you must have the privilege to check in new files.

In QuarkCopyDesk and QuarkXPress, you can click the Read-Only button in the Check Out dialog box to open an asset in read-only mode.

Publishing assets
To publish a Quark Publishing Platform asset and store the published copy on your workstation, select it in the Workspace Browser window and click Publish. The Save/Browse for Folder dialog box displays. Use this dialog box to specify where you want the file to be stored on your computer while you work on it. A copy of the asset with no ties to Quark Publishing Platform is created in the folder you specify.

To publish a layout in one of the supported formats, Control+click or right-click the project file or layout in the Workspace Browser window and choose one of the following commands:

- Get: This option downloads a copy of the asset with no ties to Quark Publishing Platform.
- Publish > Publish as ePUB: This option creates an ePUB file from a reflow article in a Print or App Studio layout. This option is available only if the layout includes a reflow article. (For more information, see "Working with Reflow view" in A Guide to QuarkXPress.) You can specify which layout and which export settings to use.
- Publish > Publish as Adobe® Flash®: This option creates a SWF (Flash) version of an Interactive layout. You can specify which layout and which export settings to use.
- Publish > Publish as PDF: This option creates a PDF rendering of a Print or App Studio layout in a QuarkXPress project. You can specify which layout and which PDF output style to use.
- Publish > Publish as Quark App Studio Article: This option creates an App Studio article from an App Studio layout in a QuarkXPress project. (For more information, see A Guide to App Studio.) Note that you must supply App Studio Publishing Portal credentials in QuarkXPress Server in order to be able to upload App Studio articles to the Portal; for more information, see A Guide to QuarkXPress Server.
- Publish > Publish as AVE: This option creates an AVE version of a print or App Studio layout.
For information on creating AVE issues with QPS, see *A Guide to QPS 9.2*.

**Viewing and editing attribute information**

You can view and edit an asset's attributes in the **Check In**, **Save Revision**, and **Edit Attribute** dialog boxes. If you want to view and edit attributes without opening an asset, use the **Edit Attribute** command in the **Workspace Browser** window.

To use **Edit Attribute**:

1. Select the asset in the **Workspace** window and click **Edit Attribute**. The **Edit Attributes** dialog box displays.

   ![Edit Attributes dialog box](image)

   Use the **Edit Attributes** dialog box to view and edit an asset's attributes without checking out the asset.

   - Non-editable attributes are either automatically maintained by the application or restricted based on user privileges or status. You can view all attributes, but you might not be able to edit all of them.

   - Changing an asset's status can change the **Route to** value if an automatic rule applies. A change in status can change the Quark Publishing Platform constraints specified for the asset type.

2. When you finish editing attributes, click **OK**.

   - This feature is particularly useful if you want to route an asset to a different user without checking out the asset and creating another revision.

   - This dialog box also displays when you drag an asset from one collection to another. If the asset cannot be moved to the target collection, you can use the dialog box to edit the asset's other attributes.
Saving a revision of an asset

To update Quark Publishing Platform Server with your most recent changes to an asset, use the **Save Revision** command.

- To save a revision of the active article in QuarkCopyDesk, choose **Platform > Save Article Revision**.
- To save a revision of the checked-out and active article or project in QuarkXPress, choose **Platform > Save Article Revision** or **Platform > Save Project Revision**.
- To save a revision of the active asset in Quark Publishing Platform Client, click **Save Revision** in the Quark Publishing Platform Client toolbar.

Customizing the search results pane

To specify the columns you want to display in the search results pane, Control-click/right-click any column header and choose **Customize Current View**. The **Configure Columns** tab displays.

Use the **Configure Columns** tab to choose which attribute columns display in the Quark Publishing Platform Client window.

- Check the attribute columns you want to display, and uncheck the attribute columns you want to hide. You can check and uncheck the individual columns you want to show and hide, or use the **Select All** check box to select all or none of the attributes.

  You can add the **Thumbnails** column to display thumbnail asset previews.

- Check **Remember Column Changes** to maintain the column display.

  If you have the **Enable Enhanced Search Displays in Workspace Browser** privilege, the **Group By** and **Explore By** tabs display.

  Use the **Group By** tab to group the results by attribute values.

  Use the **Explore By** tab to control attachment display:

  - **Show Relationship Information**: Lets you expand projects to see their attachments.
    - **Show Asset Usage (Project Mode)**: Displays projects and their attachments first, followed by assets that are attached to other layouts and then unattached assets.
• **Show Related Assets**: Lets you expand projects to see their attachments.

• **Show Layout and Page**: Lets you expand projects to see their layouts and pages, and indicates which layout and page each attachment is attached to.

• **Show Collections Hierarchy**: Displays assets in the collections hierarchy.

**Setting Quark Publishing Platform Client preferences**

To set Quark Publishing Platform Client preferences, choose Quark Publishing Platform Client > Preferences. Use the dialog box to specify workspace and alert display options, file management rules, and other defaults. Most preferences are stored on Quark Publishing Platform Server, so they apply to the user name you enter when you log on, regardless of the workstation settings.

**General pane**

The General pane includes three tabs: Basic, Notification, and Mouse Settings.

**Basic tab**

The Basic tab of the General pane includes basic Quark Publishing Platform Client preferences.

- Uncheck **Delete the Original File from the Local System on Check In Other** to always retain original files when you use the Check In Other command. If you check **Delete the Original File from the Local System on Check In Other**, a warning message displays every time you use the Check In Other command, enabling you to retain or delete the selected file.
CLIENT TASKS

- Check Global Warning: Always Warn Before Deleting Any Asset to display a warning each time you delete a Quark Publishing Platform asset in Quark Publishing Platform Client.

- To specify how Quark Publishing Platform Client responds when you attempt to delete checked-out assets and assets attached to QuarkXPress projects, use the Checked-out Assets and Attached Assets drop-down menus in the Asset Deletion Options area. The controls are identical for both options. Choose Delete Asset Without Warning to delete checked-out or attached assets without displaying a warning. Choose Never Allow Deletion to prevent the deletion of checked-out or attached assets. Choose Ask Before Deleting to display an alert so you can decide each time you delete a checked-out or attached asset.

- To specify where checked-out and read-only assets are stored temporarily while you work on them, click Browse in the Location Options area and choose a location. The path will display in the Checked-out Assets field.

- To specify the horizontal and vertical measurements units used for your Quark Publishing Platform workflow, choose options from the Horizontal Units and Vertical Units drop-down menus (Inches, Inches Decimal, Picas, Points, Millimeters, Centimeters, Ciceros, Agates, and Q).

- Check Apply Status-based Privilege Changes to Subsequent Statuses to maintain privilege settings specified at the status level when subsequent statuses are selected for an asset.

**Notification tab**

The Notification tab of the General pane includes notification-related Quark Publishing Platform Client preferences.

- To specify how you want to be notified of assets routed to you while you're logged on, use the controls in the Assignment Notification area. Check Audio Alerts to hear a sound when an asset is routed to you. Check Dialog Box Alerts to display a dialog box that identifies the asset (or assets) routed to you.
Mouse Settings tab

To specify what happens when you double-click an asset in the Workspace window, click the drop-down menu in the Double-click Options area and choose Check Out, Edit Attributes, or Read Only.

If you choose Check Out, double-clicking a checked-out asset in a Workspace Browser window displays the Check In dialog box.

Mouse Settings tab of General pane of Preferences dialog box

Workspace pane

The Workspace pane includes controls for how revision comments, asset previews, and text in the Workspace window display.
Workspace pane of Workspace dialog box

- To specify the font and font size displayed for assets in the Workspace window, choose options from the drop-down menus in the Font Options area.

  On Mac OS, if you choose a font that does not have a bold version, the enhanced search displays show all headings in plain text. For example, if you choose the Issue and Page display option, Unattached and <Collection Name> do not display in bold.

- To specify how revision comments are displayed when you check out an assignment, choose Always, Never, or New Assignments Only from the drop-down menu in the Revision Comments area.

- To control the size of thumbnail previews of assets in the Workspace window, adjust the slider in the Asset Thumbnail Size area.

- Check Show Status Color around Thumbnails to display the color of an asset's status in the border of the thumbnail preview that displays when you choose Thumbnails, Filmstrip, or Detailed Thumbnails View from the Displays > Name submenu.

Startup Mode pane

The Startup Mode pane provides controls for logging on when you launch Quark Publishing Platform Client.
Startup Mode pane of Preferences dialog box

- If you checked Remember Me in the Log On dialog box, you can check Do Not Display Log On Dialog Box to automatically log on to Quark Publishing Platform when you launch Quark Publishing Platform Client. This check box is also included at the bottom of the Log On dialog box.

- Choose an option in the Default Startup Mode area to specify how Quark Publishing Platform Client starts the next time you launch the application. Options include Remember the Last Mode and Do Not Remember My Last Mode.

Archive pane

The Archive pane provides controls for handling revisions and deleting assets when archiving assets.
Setting Quark Publishing Platform preferences: QXP

You can use the Quark Publishing Platform panes in the Preferences dialog box (QuarkXPress/Edit menu) to specify default behaviors for handling assets, assignments, and search parameters. Except for the Use Default Path for Asset Check-out and Do not Display Log-On Dialog Box preferences, all other Quark Publishing Platform preferences are stored on Quark Publishing Platform Server. Preference settings apply to the user name you enter when you log on, regardless of the workstation settings.

QXP preferences: General pane

The General pane of the Preferences dialog box includes three tabs: Basic, Notification, and Auto Log On/Off.

QXP preferences: General > Basic

To specify how the application responds when you attempt to delete checked-out assets and assets attached to QuarkXPress projects, use the controls in the Asset Deletion Options area in the Basic tab.

• Uncheck Delete the Original File from the Local System on Check In Other to always retain original files when you use the Check In Other command. If you check Delete the Original File from the Local System on Check In Other, a warning message displays every time you use the Check In Other command, enabling you to retain or delete the selected file.

• Check Global Warning: Always Warn Before Deleting Any Asset to display a warning each time you delete a Quark Publishing Platform asset.

• The controls are the same in the Checked-out Assets and Attached Assets drop-down menus. Choose Delete Asset Without Warning to delete checked-out or attached assets without displaying a warning. Choose Never Allow Deletion to protect against deleting checked-out or attached assets. Choose Ask Before Deleting to display an alert each time you delete a checked-out or attached asset.

To specify where you temporarily store assets while you work on them, click Browse in the Location Options area. Navigate to the folder and click Choose/OK.

To control when revision comments display, choose an option from the Choose drop-down menu in the Display Revision Comments area.
Basic tab of the General pane of the Preferences dialog box

QXP preferences: General > Notification

The Notification tab lets you determine how you want to be notified of assets routed to you while you're logged on. Check Audio Alerts to hear a sound when an asset is routed to you. Check Dialog Box Alerts to display a dialog box that identifies the asset (or assets) routed to you.
**QXP preferences: General > Auto Log On/Off**

The **Auto Log Off Settings** area lets you specify the interval of inactivity that must pass before you are automatically logged off. Check **Warn Before Logging Off** to receive a warning message before you are automatically logged off.

If you want to bypass the **Log On** dialog box the next time you log on to a Quark Publishing Platform Server, check **Do Not Show This Dialog Box Again** and **Remember Me** in the **Log On** dialog box. If you want the **Log On** dialog box to display again the next time you choose the command, uncheck **Do Not Display Log-On Dialog Box** in the **Auto Log Off Settings** area.

![Auto Logoff tab of the General pane of the Preferences dialog box](image)

**QXP preferences: Workspace pane**

The **Workspace** pane of the **Preferences** dialog box includes two tabs: **Workspace Browser** and **Mouse Settings**.

**QXP preferences: Workspace > Workspace Browser**

The **Workspace Browser** tab lets you choose the font and font size to display in the **Workspace Browser** window's search results pane and whether or not to show status colors around thumbnails.

Use the fields in the **Depth Search** area to specify parameters for a default **Fit to Text Box–Depth** search in QuarkXPress. When you select a text box and choose **Quark Publishing Platform > Saved Searches > Fit to Text Box–Depth**, Quark Publishing Platform calculates the length of the entire text chain (which might include multiple linked text boxes) and then compares this available space with the values in the **Longer by** and **Shorter by** fields.

- The value in the **Longer by** field and the available space in the selected text chain equal the maximum article length to be displayed in the **Workspace Browser** window when you choose the **Depth** search. For example, if the **Longer by** value is two inches and the text chain length is four inches, the search returns articles that are no longer than six inches (the combination of the **Longer by** setting and the available space).
The available space in the selected text chain minus the value in the **Shorter by** field equals the minimum article length to be displayed in the **Workspace Browser** window when you choose the **Depth** search. For example, if the **Shorter by** value is two inches and the text chain length is four inches, the search returns articles that are no shorter than two inches (the available space value minus the **Shorter by** setting).

**Workspace Browser** tab in the **Search Palette Settings** pane of the **Preferences** dialog box

**QXP preferences: Workspace > Mouse Settings**

The **Mouse Settings** tab of the **Workspace** pane lets you specify what happens when you double-click an asset in the **Workspace Browser** window. For projects, templates, and libraries, you can choose **New Project**, **Check Out**, **File Information Dialog Box**, or **Read-only**.
Mouse Settings tab in the Workspace pane of the Preferences dialog box

QXP preferences: Project and Attachments pane

The Project and Attachments pane lets you control auto update settings.

To automatically update content, check Auto update content on: and then check the events on which you want to automatically update content.

To automatically save a revision of a project after its content is updated, check Save New Revision of Project after Auto Update Content.

To automatically update geometry, check Auto update geometry on: and then check the events on which you want to update geometry.

The Auto update Page Pictures on Check In preference allows a user to send the latest page Pictures to QCD Users while performing Save Project Revision or Project Check in.

This preference allows user to send latest page Pictures to QCD Users while performing Save Project Revision or Project Check in

To synchronize the "Issue" attribute of any attached items with that of the project to which they are attached, check Change the issue of the attached items to match the project.

To retain geometry in detached articles, check Retain article geometry after detaching articles.

To automatically restore an article's geometry to its previous state when the checkout of the project to which it is attached is cancelled, check Restore original article geometry after cancelling project checkout.
**Project and Attachments pane of the Preferences dialog box**

**QXP preferences Article pane**

The Article pane lets you set the User Preferences for configuring the Article Page Picture options while assigning articles from Projects.

**Article pane of the Preferences dialog box**

**QXP preferences: Alerts pane**

The Alerts pane lets you control when project- and attachment-related alerts display.
QXP preferences: Alerts > Project

The Project tab of the Alerts pane lets you control when project-related alerts display.

To suppress the alert that normally displays when you save a Platform project as a non-Platform project, check Do not show alert while saving a server project as a non-server project.

To save local copies of attached assets when you save a Platform project as a non-Platform project, check Save server assets when saving a server project as a non-server project and then indicate where to save them.

To suppress the alert that normally displays when you check out a Platform project that has attachments that are checked-out, check Do not show alert for checked-out articles when checking out a project with attachments.

To control when Job Jackets resources are updated, choose an option from the Choose drop-down menu in the Update Job Jacket Resources area.

QXP preferences: Alerts > Attachments

The Attachments tab of the Alerts pane lets you control when attachment-related alerts display.

To suppress alerts in specific situations, check options under Do not show alert when.

To automatically save local copies of assets when they are detached, check Save a local copy of detached assets and then indicate where to save them.

To suppress the display of the Assign dialog box when attaching an article or picture, check the appropriate options under Do not show Assign dialog box when.
Setting Quark Publishing Platform preferences: QCD

You can use the Quark Publishing Platform panes in the Preferences dialog box (QuarkCopyDesk/Edit menu) to specify default behaviors for handling Quark Publishing Platform assets, assignments, and search parameters. Except for the Location Options and Do Not Display Log-On Dialog Box preferences, all other Quark Publishing Platform preferences are stored on Quark Publishing Platform Server. Preference settings apply to the user name you enter when you log on, regardless of the workstation settings.

QCD preferences: General pane

The General pane of the Preferences dialog box includes three tabs: Basic, Notification, and Auto Log On/Off.

QCD preferences: General > Basic

To specify how the application responds when you attempt to delete checked-out assets and assets attached to QuarkXPress projects, use the controls in the Asset Deletion Options area in the Basic tab.

- Uncheck **Delete the Original File from the Local System on Check In Other** to always retain original files when you use the Check In Other command. If you check **Delete the Original File from the Local System on Check In Other**, a warning message displays every time you use the Check In Other command, enabling you to retain or delete the selected file.
- Check **Global Warning: Always Warn Before Deleting Any Asset** to display a warning each time you delete a Quark Publishing Platform asset.
- The controls are the same in the **Checked-out Assets** and **Attached Assets** drop-down menus. Choose **Delete Asset Without Warning** to delete checked-out or attached assets without displaying a warning. Choose **Never Allow Deletion** to protect against deleting checked-out or attached assets.
Choose **Ask Before Deleting** to display an alert each time you delete a checked-out or attached asset.

To specify where you temporarily store assets while you work on them, click **Browse** in the **Location Options** area. Navigate to the folder and click **Choose/OK**.

To control when revision comments display, choose an option from the **Choose** drop-down menu in the **Display Revision Comments** area.

![Preferences dialog box](image)

**Basic** tab of the **General** pane of the **Preferences** dialog box

**QCD preferences: General > Notification**

The **Notification** tab lets you determine how you want to be notified of assets routed to you while you're logged on. Check **Audio Alerts** to hear a sound when an asset is routed to you. Check **Dialog Box Alerts** to display a dialog box that identifies the asset (or assets) routed to you.
**Notification** tab in the **General** pane of the **Preferences** dialog box

**QCD preferences: General > Auto Log On/Off**

The **Auto Log Off Settings** area lets you specify the interval of inactivity that must pass before you are automatically logged off. Check **Warn Before Logging Off** to receive a warning message before you are automatically logged off.

If you want to bypass the **Log On** dialog box the next time you log on to a Quark Publishing Platform Server, check **Do Not Show This Dialog Box Again** and **Remember Me** in the **Log On** dialog box.

If you want the **Log On** dialog box to display again the next time you choose the command, uncheck **Do Not Display Log-On Dialog Box** in the **Auto Log Off Settings** area.

**Auto Logoff** tab of the **General** pane of the **Preferences** dialog box
QCD preferences: Workspace pane

The Workspace pane of the Preferences dialog box includes two tabs: Workspace Browser and Mouse Settings.

QCD preferences: Workspace > Workspace Browser

The Workspace Browser tab lets you choose the font and font size to display in the Workspace Browser window's search results pane and whether or not to show status colors around thumbnails.

QCD preferences: Workspace > Mouse Settings

The Mouse Settings tab of the Workspace pane lets you specify what happens when you double-click an asset in the Workspace Browser window. For both articles and templates, you can choose New Article, Check Out, Edit Attributes, or Read-only.
QCD preferences: Article pane

The Article pane lets you control initial article views, invisible characters, and page pictures.

To specify the initial article view when you check out, open, or display a QuarkCopyDesk article, click Keep Last Setting, WYSIWYG, Galley View, or Full Screen.

To automatically show invisible characters when you check out, open, or display a QuarkCopyDesk article, check Show Invisibles.

To display a graphic representation of the QuarkXPress layout page to which a QuarkCopyDesk article is attached, check Retrieve Page Picture.

The Auto update page picture preference allows user to update only the page picture of an article without updating the geometry.
Article pane of the Preferences dialog box

QCD preferences: Alerts pane

The Alerts pane lets you control alerts and Job Jackets updates.

To control when alerts display, use the checkboxes in the Do not show alert when area.

To control when Job Jackets resources are updated, choose an option from the Choose drop-down menu in the Update Job Jacket Resources area.
Redlining

Using the Redline XTensions software, users of QuarkXPress, QuarkCopyDesk, and Quark Publishing Platform Web Client can track changes to text in projects and articles. In a Quark Publishing Platform workflow, additions, deletions, and changes can all be tracked, and changes can be accepted or rejected. Outside of Quark Publishing Platform, users can use redlining to track changes to shared projects and articles. To learn how to use the full list of redlining controls in QuarkCopyDesk, refer to A Guide to QuarkCopyDesk. This chapter covers redline controls in a Quark Publishing Platform workflow.

In order to be able to use the Redlining feature, a user must have the necessary privileges. For more information, see "Content privileges: Edit Redlining."

Using Redline controls

The commands in the Redline submenu (Utilities menu) are Tracking, Highlighting, and Show/Hide Toolbar. The Redline Toolbar also includes the Tracking and Highlighting commands, as well as controls for navigating through changes, accepting or rejecting changes, and setting options for displaying changes.

In addition to the Tracking and Highlighting controls on the left side of the Redline toolbar, you can navigate through changes, accept or reject changes, and display the View Options dialog box.
Use the View Options dialog box to specify the reviewers and types of changes you want to display.

Text formatting changes are not tracked.
Notes

The Notes feature lets you store comments in an article or layout without affecting the actual content. You can use notes to add reminders, comments on the content, or URLs. Notes work in QuarkXPress, QuarkCopyDesk, and Quark Publishing Platform Web Client.

To use the Notes feature with QuarkXPress or QuarkCopyDesk, you must have Notes XTensions software installed.

Working with notes

You can use the commands in the Utilities > Notes submenu to navigate through notes, to create and delete individual notes, and to open and close all notes in an article.

Opening and closing notes

To open and close notes as you review comments:

- To open an existing note, click the Note icon and then choose Edit > Notes > Open Note.
- To open all notes in the article, choose Edit > Notes > Open All Notes.
- To close a note, click the close box in the upper-left (Mac OS) or upper-right (Windows) corner of the note window, or choose Edit > Notes > Close Note.
- To close all open notes in the article, choose Edit > Notes > Close All Notes.
- To move the text insertion point to the next note in the text, choose Edit > Notes > Go to Next. To move the text insertion point to the previous note in text, choose Edit > Notes > Go to Previous.

Showing and hiding notes

To show notes when they are hidden, choose View > Show Notes. To hide notes when they are visible, choose View > Hide Notes.

Deleting notes

To delete a note, do one of the following things:

- Click the Note icon and then choose Edit > Notes > Delete.
- Click an open note window and then choose Edit > Notes > Delete.
- Place the text insertion bar to the right of the note icon and press Delete/Backspace.
- Select a range of text that contains a note icon and press Delete or Backspace.
Converting between notes and text

To convert the selected text to a note, press F10.

To convert a note (or part of a note) to text, select the target characters in the note, then press F10.

Viewing notes by author, date, name, or color

To view notes by a certain author or by the date they were created, choose View > Show Notes to enable notes, choose Edit > Notes > Open Notes By to display the Open Notes dialog box, click All Notes, and then use the controls in the All Notes area.

To view notes by name or color, choose Edit > Note > Open All Notes in New Article, then choose an option from the By Name submenu or the By Color submenu. The notes display as text in a new article.

Moving and resizing notes

To move a note window, drag its title bar. You can move note windows anywhere within an article. If a note has been moved, you can return it to its original location by clicking the note's button.

To resize a note, click and drag the resize box in the lower-right corner of the note window. On Mac OS, you can also click the icon in the upper-right corner of the note window to resize the note window to display all of the note's text.

Printing notes

When you print an article, you can choose whether you want notes to be included and how they should be formatted. In the Print dialog box (File menu), click Notes in the list on the left to display the Notes pane, then check Print Notes to include notes in the output. You can choose whether to include all notes or only notes that are open, and you can choose to format the notes as footnotes, leave them inline, or collect them on a separate page.

Notes in PDFs

When you create a PDF from an article that contains notes, you can choose whether you want the notes to appear in the PDF. If you export in WYSIWYG view, the notes are included as PDF notes; if you export in Galley view or Full Screen view, the notes display inline, as they do on the screen in these views.

To include notes in a PDF file, click Options in the Export as PDF dialog box (File > PDF), click Notes in the list on the left, and then check Include Notes in PDF.
With Quark Publishing Platform Web Client, remote writers and editors can use a Web browser to perform many Quark Publishing Platform operations. Quark Publishing Platform Web Client users can log on to Quark Publishing Platform Server, create articles based on Quark Publishing Platform Job Tickets, check out and edit QuarkCopyDesk articles in a Web browser, check out other assets to edit in separate applications, and check the assets back in to Quark Publishing Platform Server.

Quark Publishing Platform Web Client users can also use the Check In Other feature to put new files in their workflow (including QuarkCopyDesk articles, QuarkXPress projects, and other files).

Quark Publishing Platform Web Client includes many of the features available in the Workspace Browser palette in Quark Client, QuarkXPress, and QuarkCopyDesk, including the following:

- The Favorites area, the Assignments area, the My Searches area, the Saved Searches area, and the Collections area (including the ability to work with collections and collection templates)
- The subcollections pane
- The search interface
- The search results pane

For more information, see “User interface.”

Logging on with Quark Publishing Platform Web Client

Quark Publishing Platform Web Client enables access to Quark Publishing Platform Server through a Web browser. (For a list of supported browsers, see the Quark Publishing Platform ReadMe.)

You must enable cookies in your Web browser for Quark Publishing Platform Web Client to work correctly.

To log on to Quark Publishing Platform Server using Quark Publishing Platform Web Client:

1. Launch a supported browser.

2. In the URL field, enter the computer name or IP address and port number for your Quark Publishing Platform Server followed by /workspace/ (for example: http://10.1.5.30:61400/workspace). The Log On page displays.
Quark Publishing Platform Web Client lets you log on to Quark Publishing Platform Server with a Web browser.

3 Enter your user name in the **User Name** field and your password in the **Password** field, then click **Log On**.

4 If the log-on process is successful, the Quark Publishing Platform Web Client screen displays your assignments.

If you close all your Quark Publishing Platform Web Client windows or if your network connection is broken, you will be logged off within two minutes. However, administrators can change this setting by adjusting the "session-timeout" variable in the "Web.xml" file located in the "WEB-INF" folder (QPP Server/webapps/Workspace/WEB-INF).

Your log-on password might be case-sensitive, depending on your administrator's specifications. Also, check with your Quark Publishing Platform administrator to verify if your Quark Publishing Platform user name and password are the same as your network user name and password.

**Changing password**

You can change your Quark Publishing Platform log-on password after you log on with Quark Publishing Platform Web Client.

1 Choose **Change Password** from the gear menu in the top right corner of your browser window. The **Change Password** dialog box displays.

2 Enter your password in the **Old Password** field.

3 Enter your new password in the **New Password** field.

4 Enter your new password again in the **Confirm New Password** field, and click **OK**.

**Customize search results display**

To control which attribute columns display in the **Search** or **Assignments** tabs:
1 Choose **Customize Current View** from the view menu. The **Configure Columns** dialog box displays.

![Configure Columns](image)

**Configure Columns** tab

2 Check the attributes you want to display as columns in the Web Client window.

You can drag column headers to reposition columns in the search results display.

**Searching in Web Client**

Searching in Web Client works the same way as searching in other Quark Publishing Platform clients. For more information, see "Performing a search."

A Web Client user now has the ability to delete, duplicate, rename and share searches

**Archiving and Restoring in Web Client**

A Web Client user now has the ability to archive and restore assets. Archiving can be done from a search of collection(s) or asset(s).

**Using display options**

You have several buttons for displaying search results and collection contents in Quark Publishing Platform Web Client.

Not all views are available in all situations.

Click **List View** to display assets in a list format.
List View button
Click Snippet View to display assets in a thumbnail view with snippets of text.

Snippet View button
Click List View with Relationships to display assets in a list view where you can expand them to see their relationships.

List View with Relationships button
Click Project and Page to display projects in a list view where you can expand them to see their pages.

Project and Page button
Click List View with Relationship Status to display assets in a list view where you can expand them to see their relationships, organized by type.

List View with Relationship Status button
Click Collection View to display search results in the hierarchical structure of the collections tree.

Collection View button
Click Thumbnails to display small previews of assets with attachment information, check-out status, and status identified by icons below each preview.
Thumbnails View button

Click **Customize Current View** to choose the columns you want to display.

Cutomize Current View button

Previewing assets with Quark Publishing Platform Web Client

Click the **Preview** icon to display a large, zoomable spread preview of the selected QuarkCopyDesk article, QuarkCopyDesk article template, QuarkXPress project, or QuarkXPress project template.

If the selected asset is a project, you can use the tabs at the top of the **Preview** window to view all of the Print, Interactive, and App Studio layouts in the project.

For Print, Interactive, and App Studio layouts, the **Preview** window displays a flatplan view of the layout.

Using the Publish features

The Web Client publishing buttons let you execute the following commands: **Get**, **Publish as PDF**, **Publish as AVE**, **Publish as Adobe® Flash®**, **Publish as ePUB**, **Publish as Rich Text Format**, **Publish as HTML**, **Publish as App Studio Article**, and **Publish as QuarkXPress Project**. For more information about these options, see "Publishing assets."

Editing asset attributes

You can use the Web Client **Edit Attributes** button to view and change an asset's attributes. To edit asset attributes with Quark Publishing Platform Web Client:

1. Select the asset and click **Edit Attributes**. The **Edit Attributes** dialog box displays.
The **Edit Attributes** dialog box allows you to change an asset's attributes (privileges permitting).

2. Expand the form view.

3. View or change attributes, then click **OK**. See "Viewing and editing attribute information" for information about the controls in the **Edit Attributes** dialog box.

You can re-index an asset in Quark Publishing Platform by choosing **Index Again** from the asset's context menu.

**Viewing asset revisions**

To display the **View Revisions** dialog box, click **View Revisions**.

**View Revisions** dialog box
The View Revisions dialog box displays information about the revisions tracked by Quark Publishing Platform Server for the selected asset. For pictures, videos, audio assets, XML assets, and "other" files, you can open a read-only copy of a revision or revert to an earlier revision to make it become the current version. The View Revisions dialog box also shows thumbnail previews of asset revisions and allows you to delete those revisions.

Viewing relationship information

To view the relationships (including primary attachments and secondary attachments, if any) for the selected asset, click Relationship Information. The Relationship Information dialog box displays.

The Relationship Information dialog box

The Refers To tab displays all assets that the selected asset refers to (including assets that are attached to it). The Where used tab displays all assets that refer to the selected asset.

You can also view relationship information at the bottom of the Preview pane.

Creating articles in Quark Publishing Platform Web Client

When you create a new QuarkCopyDesk article in Quark Publishing Platform Web Client, you can base that article on collection default settings or on a template that has been checked into Quark Publishing Platform.

If you click New > Article From Server Ticket, the New Article From Server Ticket dialog box lets you choose a collection. The default Job Jackets file and Job Ticket for the collection display in bold and are selected by default, but you can use any Job Jackets file and Job Ticket that is available in the dialog box if you have the necessary privileges. The new article has dimensions that are based on the Job Ticket's default Layout Specification (if any) and uses the style sheets and other resources defined in the Job Ticket.
New Article from Server Ticket dialog box

If you click New > Article From Server Template, the New Article from Server Template dialog box lets you choose from among all available article templates. You can also select a saved search for templates or create a new search for article templates checked in to Quark Publishing Platform Server.

Creating projects from templates in Quark Publishing Platform Web Client

To create a new QuarkXPress project from a project template in Quark Publishing Platform Web Client, choose New > Project from Server Template in the Quark Publishing Platform toolbar to display the New Project from Server Template dialog box, then select a template and click OK. If the template contains multiple layouts, you can choose which one you want to work on.

- You can edit only Print and App Studio layouts.
- You can edit article templates in Quark Publishing Platform Web Client the same way you edit articles. Just check the template out, make your changes, and then check it back in.

Editing articles in Quark Publishing Platform Web Client

To edit an article in Web Client, you must first check it out. Select the article and click Check Out. The article opens for editing in WYSIWYG view.

- If an article assignment includes a revision comment, the revision comment displays when you check out the article.

To navigate to a different page, click the page preview in the Preview pane on the left.

To show or hide the page picture (if any), click Show/Hide Page Picture.

To change the view percentage, use the zoom control at the bottom right.

To show or hide the Article Components and Style Sheets palettes, use the buttons at upper right.
You can also edit article templates in Quark Publishing Platform Web Client.

Be sure to enable pop-ups for your Web browser. You can temporarily enable pop-ups, or you can always enable pop-ups from Quark Publishing Platform Server. If you do not enable pop-ups, you will not be able to paste text into articles while editing in Quark Publishing Platform Web Client.

Editing text components

To edit a text component in Web Client, check out the article and then click the text component. Alternatively, you can double-click the name of the text component in the Article Components palette. A text-editing dialog box displays.

In the page preview, bullets and numbers display normally. In the text-editing dialog box, however, a generic bullet or number displays in place of a formatted bullet or number. Also, bullets and numbering do not display in the text-editing dialog box unless they have been applied to a paragraph using a paragraph style sheet.

If the tools do not display, expand the toolbar at the top of the text-editing dialog box. The tools are as follows:

• Click **Undo** to reverse a change.
• Click **Redo** to reverse an undo.
• Click **Find** to display the Find dialog box. Enter text in the Find what field. Check Match case to find only instances of Find what text that matches the case you enter. Check Match whole word to avoid finding Find what text included within larger words (such as "the" in "other").
• Click **Replace** to display the Replace dialog box. This dialog box includes the Find what field, the Replace with field, the Match case and Match whole word check boxes, and the Replace and Replace All buttons.
• Click **Select All** to select all the text in the text-editing pane.
• Click **Copy** to copy selected text to the Clipboard. Depending on your browser security settings, you might have to respond to a message before you can copy text to your Clipboard.
• Click **Paste** to display the **Paste** dialog box. Use Command/Ctrl+V to paste the text from your Clipboard into the field.

• Click **Paste from Word** to display the **Paste from Word** dialog box, which provides controls to prevent formatting inconsistency when you paste text copied from a Microsoft® Word document.  
  **Ignore Font Face definitions** is automatically checked to prevent adding fonts when you paste text copied from Microsoft Word. **Remove Styles definitions** is automatically checked to prevent the addition of Microsoft Word styles to the style sheets defined in your Quark Publishing Platform workflow. You can edit the pasted text in the dialog box before you click **OK**.

• Click the appropriate icon to apply bold, italic, underline, strikethrough, subscript, and superscript formatting to text.

• Click **Insert Special Character** to display the **Select Special Character** dialog box and enter a special character at the text insertion point. Click the character to insert it.

• Click **Background Color** to display the **Select Color** dialog box and specify a color for the text-editing pane background. For example, if you are editing text that is white on a black background in the QuarkXPress project to which it is attached, you can choose a dark background color so you can see the white text. See "Adjusting background color for editing" for more information.

• Click **Rubi** and **Group Character** to apply Rubi notation and create a group of characters. See "Working with Rubi" and "Working with Grouped Characters" for more information.

• Click **Note** to add a note. See "Using notes in articles" for more information.

• Click **Tracking** to track changes to text.

• Click **Highlighting** to highlight changes to text.

• Click **Accept Change** to accept changes to text.

• Click **Reject Change** to reject changes to text.

To import text from a text file on your computer, Control+click/right click in the text and choose **Import Text** from the context menu. You can import text with formatting or as plain text.

If the **Style Sheets** palette is not displayed, click **Show/Hide Style sheet Palette** at top right of the **Quark Publishing Platform Web Client** window. Use the **Style Sheets** pane to apply paragraph and character style sheets to text.

If the **Conditional Styles** palette is not displayed, click **Show/Hide Conditional Styles Palette**. You can use the **Conditional Styles** palette to apply conditional styles to text, but you cannot create, edit, or delete conditional styles. You can insert a conditional style marker into text using the **Insert Special Character** button.

If the **Bullet, Numbering, and Outline Styles** palette is not displayed, click **Show/Hide Bullet, Numbering, and Outline Styles Palette**. You can use the **Bullet, Numbering, and Outline Styles** palette to apply bullets, numbering, and outline indents to text, but you cannot view the bullets, numbering, and indents in the text-editing dialog box. Also, you cannot add, edit, or delete bullet, numbering, and outline styles. To view the results of applying bullet, numbering, and outline styles in the layout, click **Apply** in the text-editing dialog box.
Editing picture components

To edit a JPEG, TIFF, or EPS picture component in Web Client, check out the article and then click the picture component or double-click the picture component in the Article Components palette. A picture-editing dialog box displays.

![Picture-editing dialog box](image)

**Picture-editing dialog box**

Use the arrow buttons to flip the picture horizontally or vertically.

Use the X% and Y% fields to scale the picture. The chain icon controls whether the picture scales proportionally or not.

Click and drag to move the picture in the box. The X+ and Y+ fields display the picture's origin relative to the upper-left corner of the box.

Use the field on the right to rotate the picture.

When you click **Apply**, the spread preview updates to display any changes you've made.

You can also manipulate pictures by Control-clicking/right-clicking their components in the page preview and choosing an option from the context menu:

- To replace a picture with a different picture, Control+click/right-click the picture's preview and choose **Replace from Server**.
- To import a picture from the local hard disk, Control+click/right-click the picture component and choose **Import Picture**.
- To scale a picture to fit its picture component, Control+click/right-click the picture component and choose **Scale Picture to Box**.
- To remove a picture from its picture component, Control+click/right-click the picture component and choose **Clear Picture**.

You cannot edit assets that have been attached to a picture component with the App Studio palette. For more information, see *A Guide to App Studio*.

Managing components

When you check out or create an article in Quark Publishing Platform Web Client, you can add and remove components, and you can display the Component Properties dialog box to confirm the
Content Type and view or edit the Component Name and Component Type. You must belong to a user role with the appropriate privileges.

1. Check out an article.

2. To display the Article Components palette, click the Show/Hide Component Palette button.

![Article Components palette](image)

3. To add a component, click New. The New Component dialog box displays. Enter a name in the Component Name field, choose Text or Picture from the Content Type drop-down menu, choose a component type from the Component Type drop-down menu, and then click OK.

![New Component dialog box](image)

4. To delete a component, select it in the Component palette, then click Delete.

5. To view or change a component's properties, select it in the Component palette, then click Properties.

Finding and replacing text in articles

To find and replace text with Quark Publishing Platform Web Client:

1. Click the box containing the text you want to edit. The text-editing dialog box displays.

2. If the tools do not display, expand the toolbar at the top of the text-editing dialog box.
3 Click **Find**.

**Find tab of the Find and Replace dialog box**

4 To locate text in an article, click the **Find** tab.

5 To replace text in the article, click the **Replace** tab.

**Replace tab of the Find and Replace dialog box**

---

**Adjusting background color for editing**

If a QuarkCopyDesk article contains white text, the white text will not display on a white background in the Quark Publishing Platform Web Client text-editing dialog box. You can change the background color of the text-editing dialog box, but the background color you specify is only for editing. It does not apply to the QuarkCopyDesk article.

To change the background color:

1 Click the box containing the text you want to edit. The text-editing dialog box displays.

2 If the tools do not display, expand the toolbar at the top of the text-editing dialog box.

3 Click the **Background Color** button. The **Select Color** dialog box displays.

4 Select a color, and click **OK**. The background color of the text-editing dialog box updates.
Changing text size for editing

If a QuarkCopyDesk article contains extremely large or small type, you can use the **Zoom In** and **Zoom Out** controls in the text-editing pane toolbar to adjust the size of display in the text-editing pane without changing the copyfit information.

The **Zoom** control in the WYSIWYG pane does not affect the font size in the text-editing pane.

To change the size of text display:

1. Select an article in the list and click **Check Out**.
2. Click the text component you want to edit, or double-click its name in the **Article Components** palette. A text-editing dialog box displays.
3. To reduce the size of the text display, click **Zoom Out** in the toolbar.
4. To increase the size of the text display, click **Zoom In** in the toolbar.

Working with Rubi

Rubi text clarifies the meaning or pronunciation of base text. Base text can run vertically or horizontally, and rubi text usually follows the direction of the base text. There are two types of rubi text: mono rubi and group rubi. **Mono rubi** is rubi text that is associated with a single character of the base text. **Group rubi** is rubi text that is associated with more than one character of the base text. To specify rubi for one or more characters:

1. Select one or more characters for which you want to apply rubi.
2. Click **Rubi**. The **Rubi** dialog box displays.

![Rubi dialog box](image)

Use the **Rubi** dialog box to specify rubi for the selected base text.

3. Enter text in the **Rubi Text** field that clarifies the base text.

The selected base text displays in the **Base Text** field. If you enter new text in this field, the new text becomes the new base text.

4. Click **OK**. A Rubi icon displays in place of the base text in the text-editing pane.
5. Click **Apply** to update the display of base text and Rubi text in the WYSIWYG view pane.

After you apply Rubi, you cannot view or edit the base text or Rubi text in the text-editing pane. To edit the base text or Rubi text, click the Rubi icon and change values in the **Rubi Text** and **Base Text** fields.
You cannot apply Rubi to grouped characters.

If you click the Rubi button without selecting text, you can enter values in the Rubi Text and Base Text fields.

Working with Grouped Characters

Use the Group Character control to create a group of horizontal characters, such as Roman characters, within a vertical line of text. Grouped characters always display horizontally and do not break at the end of a line. To group selected characters:

1. Select one or more characters.
2. Click Group Character. The Group Characters dialog box displays.

Specify scaling and character spacing in the Group Characters dialog box.

3. Choose Vertical or Horizontal from the Scale drop-down menu and enter a value between 25 and 400 percent in the field to the right of the Scale drop-down menu.
4. If you want to change the character spacing for the grouped characters, enter a value in the Track/Sending Amount field.

The range for tracking values is between –500 and 500. The range for sending values is between 0.353mm and 50.8mm, but if you specify a value beyond the range and your measurement unit preference is not millimeters, the range displayed in the alert indicates your measurement unit preference.

5. Click OK.

Group characters in horizontal stories do not display scaling or character spacing, but the characters remain as a group if text reflows.

After you create grouped characters, the Group Character icon replaces the text in the text-editing pane. To edit the text, click the Group Character icon and change the text in the Group Character Text field.

If you click the Group Character button without selecting text, you can enter base text in the Group Character Text field.
Using notes in articles

If you have the privileges, you can create, edit, and delete notes in articles with Quark Publishing Platform Web Client.

• To create a note, place the text insertion point where you want to enter the note and click the Note icon. Enter text in the note window and click OK.
• To convert text into a note, select the text and click the Note icon. When you click OK to close the note window, the text is replaced with a note icon.
• To open a note, click the Note icon in the text editing window. The note window displays with the note author's name and the date and time the note was created.
• To close a note, click the close box in the note window.
• To delete a note, place the text insertion bar to the right of the note icon and press Delete/Backspace.

If you select a range of text that contains a Note icon and start entering characters, the text (including the Note icon) is replaced by the characters you enter, and the note is removed.

Editing projects in Quark Publishing Platform Web Client

To edit a project in Web Client, you must first check it out. Select the project and click Check Out. The project opens for editing. If the project contains multiple Print, Interactive, and/or App Studio layouts, you can choose which one you want to work on.

You can edit both attached and in-line articles within projects in Quark Publishing Platform Web Client. To edit an attached article while editing a project, check out the attached article using the Check Out button in the Article Components palette.

For more information on editing content in Quark Publishing Platform Web Client, see “Editing articles in Quark Publishing Platform Web Client.”

You can edit only Print and App Studio layouts.

You cannot edit articles that a layout artist has added interactivity to with the App Studio palette.

Callouts in Quark Publishing Platform Web Client

If you use Web Client to open an article or project with a component that includes a callout anchor, the callout is visible only in the page picture. Its content cannot be edited in Web Client. You can delete or reposition callout anchors, but you cannot create, cut, copy, or paste them, and you cannot apply callout styles to them. Also, you cannot associate a callout with a callout anchor, and you cannot release a callout anchor from a callout.

Checking in Other files

You can use the Check In Other feature in Quark Publishing Platform Web Client to check in assets.
1 Click Check In Other.

2 On the Windows platform, a drop-down menu displays the options: Check In File and Check In Folder (Check In Folder option is in QPP client Only). Click Check In File.

3 The Check In Other dialog box displays.

4 Click Choose File/Browse. A dialog box displays for you to select an article, project, picture, or other asset.

5 Select a file and click Choose/Open. If you are using a Web browser that supports HTML 5, you can select multiple files.

6 Click OK to display the Check in dialog box. The Check in dialog box displays. If Quark Publishing Platform server recognizes the file type, the appropriate content type is selected automatically. If Quark Publishing Platform does not recognize the file type, the content type is listed as Asset.

7 Specify a collection, workflow, and other asset attributes in the Check in dialog box.

8 Click OK to check in the asset.

You can also add assets to Quark Publishing Platform by dragging them from the file system to the Collections tree or the Search Results pane.

Editing Other Files

You can use Quark Publishing Platform Web Client to check out any type of asset. You can then use a third-party application to edit the asset. When you're finished, you can check it back in with Quark Publishing Platform Web Client.

If you use Internet Explorer on Windows to check out an asset, you can choose a location for storing the checked-out file. If you use Safari on Mac OS or Mozilla Firefox on either platform, the checked-out file is stored in the location specified for downloaded files.

If you use Quark Publishing Platform Web Client to check in an asset that has been edited with a third-party application, you must browse to select the file during the check-in process.

Using the Web Client Preview pane

The Preview pane on the right side of the screen works like the Preview pane in the Workspace Browser window, except the tabs at the bottom of the Web Client version of this pane do not display as much information as they do in other Quark Publishing Platform clients. For more information, see "Preview pane."

Setting Quark Publishing Platform Web Client preferences

You can specify preferences for preview and style sheet displays and default horizontal and vertical measurement units. To specify preferences:

1 Click Preferences. The Preferences dialog box displays.
2 Click the **General** tab.

![Preferences dialog box](image)

Use the **General** tab in the *Preferences* dialog box to specify display preferences in the *Quark Publishing Platform Web Client* window.

3 To specify a default background color for text editing, enter a hexadecimal description of that color in the **Default Editor Background Color** control or choose a color from the drop-down menu.

4 To show QuarkCopyDesk article page pictures by default, check **Show Page Picture in Editing Window**.

5 To display status colors as a border around asset previews, check **Show Status Color around Thumbnails**.

6 To display a warning when you delete a Quark Publishing Platform asset in Quark Publishing Platform Web Client, check **Global Warning: Always Warn Before Deleting Any Asset**.

7 To specify how Quark Publishing Platform Web Client responds when you attempt to delete checked-out assets and assets attached to QuarkXPress projects, use the **Checked-out Assets** and **Attached Assets** drop-down menus in the **Asset Deletion Options** area. The controls are identical for both options.

8 To specify measurement units, click the **Measurements** tab.

![Measurements tab](image)

Use the **Measurements** tab in the *Preferences* dialog box to specify measurement units to display in the *Quark Publishing Platform Web Client* window.
Choose one of the following options from the **Horizontal Units** drop-down menu: Inches, Inches Decimal, Picas, Points, Millimeters, Centimeters, Ciceros, Agates, or Q.

Choose one of the following options from the **Vertical Units** drop-down menu: Inches, Inches Decimal, Picas, Points, Millimeters, Centimeters, Ciceros, Agates, or Q.

Click **OK**.
A script is a set of commands written in an interpreted language to automate certain application tasks. You can use server-side scripts with Quark Publishing Platform Server. The Quark Publishing Platform Script Manager application allows you to manage automated scripts that perform actions without requiring another Quark Publishing Platform application or user intervention. Script writers can access almost all Quark Publishing Platform Server services through the Quark Publishing Platform Script Manager interface, including all Data Transfer Objects (DTOs) and Java™ Message Service (JMS) messages.

Scripts can initiate actions based on Quark Publishing Platform events, a predefined schedule, or a user's single click. Your Quark Publishing Platform installation includes sample scripts that you can import into Quark Publishing Platform Script Manager.

For example, you can import a sample script called "PublishAssetOnStatusChange.js" that automates the steps required for creating PDFs from QuarkXPress projects when the Quark Publishing Platform status changes.

The Quark Publishing Platform Server comes pre-configured with two scripting engines: JavaScript™ (using Rhino) or Groovy (a scripting language for Java Virtual Machine environments). However, you can write scripts in any language that is supported by Apache Bean Scripting Framework (BSF), and you can plug the corresponding scripting engine into the Bean Scripting Framework.

**Quark Publishing Platform Script Manager configuration**

After you install Quark Publishing Platform Server, look for the "ScriptManager" folder in the Quark Publishing Platform Server application folder (also in the Quark Publishing Platform installation). This folder contains "Quark Publishing Platform Script Manager.app" (Mac OS) or "ScriptManagerStartup.bat" (Windows), a folder of sample scripts, and (after you log on with Quark Publishing Platform Script Manager) a log folder with incremented versions of "Quark Publishing PlatformScriptManager.log" to report runtime errors and warnings. On Windows, the "ScriptManager" folder also contains Java archive files (JAR files).

Sample scripts are provided in the "ScriptManager" folder.

**Working with Quark Publishing Platform Script Manager**

The Quark Publishing Platform Script Manager user interface includes commands for creating, importing, exporting, and editing scripts for Quark Publishing Platform Server. In addition to writing and editing scripts with Quark Publishing Platform Script Manager, you can execute scripts manually,
schedule scripts to run at certain times, or define Quark Publishing Platform events that trigger scripts, such as the first check-in of an asset.

When you are logged on with Quark Publishing Platform Script Manager, you can view saved scripts and individual script information by double-clicking the Quark Publishing Platform Server folder icon at the top of the **Stored Scripts** column.

The "PublishAssetOnStatusChange" script in the illustration below had already been imported and saved.

Double-click a script listed in the **Stored Scripts** column to view it. When a script displays, many Quark Publishing Platform Script Manager menu commands are available from the toolbar at the top of the window.

Use Quark Publishing Platform Script Manager to automate Quark Publishing Platform Server functions, such as the "PublishAssetOnStatusChange" sample script.

**Logging on with Quark Publishing Platform Script Manager**

You must log on before you can create or edit a script for Quark Publishing Platform Server.

1. Double-click "Quark Publishing Platform Script Manager.app" (Mac OS) or "ScriptManagerStartup.bat" (Windows).
Log on to your Quark Publishing Platform Server to use Quark Publishing Platform Script Manager.

2 Enter your user name, password, and Quark Publishing Platform Server name, then click Log On.

Creating a script
You can write scripts with Quark Publishing Platform Script Manager, import Quark Publishing Platform sample scripts for editing and execution, or import other scripts for editing and execution.

1 To write a new script, choose File > New > javascript or File > New > groovy.

Use the New submenu to create a script in Quark Publishing Platform Script Manager.

A new tab displays in the Quark Publishing Platform Script Manager window, and the script name displays in the Stored Scripts list on the left side of the Quark Publishing Platform Script Manager window.

Although you can create and modify scripts with the Quark Publishing Platform Script Manager application, most script writers use a separate authoring application for writing JavaScript or Groovy scripts. Consult your script authoring software documentation to learn about structuring JavaScript or Groovy scripts.

2 Choose File > Save to retain your work as you write your script.

Saving a script transmits the script content to Quark Publishing Platform server where it is saved. A new or imported script is not added to Quark Publishing Platform until it is saved.

Importing a script
You can use File > Import to import JavaScript or Groovy scripts in Quark Publishing Platform Script Manager. Your Quark Publishing Platform Server installation includes sample scripts that you can import, edit, and execute.
Choose File > Import.

You can find Quark Publishing Platform sample scripts in the "javascript" folder in the "Sample Scripts" folder.

Navigate to the "javascript" folder, select a script, and click Open.

The Stored Scripts area lists open scripts in Quark Publishing Platform Script Manager.

Scroll through the script to view the variables and structure.

Choose File > Save to save the script.

The script you imported remains unchanged, but you must save the imported script in Quark Publishing Platform Script Manager.

Deleting and exporting scripts

You must log on and open a script in Quark Publishing Platform Script Manager before you can export or delete it.
1. Double-click the script name in the **Stored Scripts** list on the left side of the Quark Publishing Platform Script Manager window (or click the Script tab in the **Script Content** area).

2. To delete a script, select it and choose **File > Delete** or click the Delete icon in the Quark Publishing Platform Script Manager toolbar. A warning message allows you to cancel the deletion.

3. To generate a standalone script file, select it and choose **File > Export**, or click the Export icon in the Quark Publishing Platform Script Manager toolbar.

4. Enter a name for your exported script and click **Save**.

**Writing, editing, and triggering a script**

To automate a process, you need to write or import a script that directly uses services and data provided by Quark Publishing Platform Server to perform required tasks. All Quark Publishing Platform Server objects are accessible to the script, and operations as defined in the Quark Publishing Platform Server API can be invoked to produce required results. To use the script, you must save it first while logged on to Quark Publishing Platform Server.

Whether your execute a script manually or according to schedule or Quark Publishing Platform event, the script is executed on the Quark Publishing Platform Server computer. Not all of the Quark Publishing Platform Console output displays in the Quark Publishing Platform Script Manager Result window. Only the final result or error returned by the script execution displays in Quark Publishing Platform Script Manager.

**Accessing Quark Publishing Platform Server objects**

You can use the RuntimeBeanManager to access Quark Publishing Platform Server objects. By default RuntimeBeanManager is a declared bean from Bean Scripting Framework (BSF), which makes it directly available to scripts. You can use the lookup method to access any server object.

The sample script text below demonstrates how to access server objects.

```javascript
var assetFacade = runtimeBeanManager.lookupBean("restAssetFacade")
var queryFacade = runtimeBeanManager.lookupBean("queryFacade")
```

**Loading a script in a script**

You can use a `load()` method in Quark Publishing Platform Script Manager to add an existing script to another script. Loading a script includes the entire script within the current script so that its variables and methods can be used. Specifying "load(S1)" loads a script named S1. Specifying "load(S1, S2, Sn)" loads scripts named "S1," "S2," and "Sn."

Quark Publishing Platform Script Manager includes two sample scripts that contain common functions for Quark Publishing Platform and QuarkXPress Server Manager ("QppFunctions.js" and "QxpsmFunctions.js"). You can save time by importing and loading these sample scripts.

**Logging and debugging scripts**

The following functions are helpful methods for logging details in scripts. The log level set for Quark Publishing Platform Server determines whether log comments are logged or not.

- `print()`
Prints string values of the variable arguments. The printing occurs on the server standard output. For example, you can specify print("Hello") or print(arg1, ..., argN).

- **debug(.)**
  Logs a debug comment in the Quark Publishing Platform Server log file.

- **info(.)**
  Logs an informative comment in the Quark Publishing Platform Server log file.

- **warn(.)**
  Logs a warning comment in the Quark Publishing Platform Server log file.

- **error(.)**
  Logs an error comment in the Quark Publishing Platform Server log file.

- **exception(.)**
  Logs an exception in the Quark Publishing Platform Server log file. For example:
  ```
  {}  //do something
  ```
  ```
  catch (err) {
   exception(err);
  }
  ```

### Using utility methods in scripts

Use the following methods to read URLs and to run, spawn, and synchronize functions.

- **readUrl(.)**
  Opens a connection to the given URL, reads all its data, and converts the data to a string using specified character encoding or default character coding (if an explicit coding argument is not provided). For example, readUrl(url) or readUrl(url, charCoding).

- **runCommand(.)**
  Executes the specified command with the given argument and options as a separate process and returns the exit status of the process. For example, runCommand(command) or runCommand(command, arg1, ..., argN).

- **spawn(.)**
  Runs a given function or script in a different thread. For example, function g() { //do something; } or spawn(g);.

- **sync(.)**
Creates a "synchronized" function (a java synchronization method) from an existing function. The new function synchronizes on the "this" object of its invocation.

```javascript
var o = { f: sync(function(x) {
    print("entry");
    Packages.java.lang.Thread.sleep(x*1000);
    print("exit");
});
```

**Triggering a script**

Quark Publishing Platform Script Manager scripts can execute in three ways. You can run a script manually from within Quark Publishing Platform Script Manager, you can schedule a script to execute at specific intervals, or you can specify events that occur within a Quark Publishing Platform workflow that "trigger" the script.

1. Display the script in the **Script Content** area of the Quark Publishing Platform Script Manager window.
2. Save the script.
3. Click the **Trigger** button on the right side of the Quark Publishing Platform Script Manager window. The **Script Execution** dialog box displays.

Use the **Script Execution** dialog box to manually execute a script, schedule a script execution, or define a Quark Publishing Platform event to trigger the script.

4. To execute the script, click **Manual**, and click **OK**. The script executes.
5. To schedule a script to execute once, click **Schedule Based**, check **Once**, then choose a date and time. The script will execute at the scheduled time.
6. To schedule a script to run at regular intervals, click **Schedule Based**, check **Recurring**, then specify the intervals.
7. To specify a Quark Publishing Platform event that triggers the script, click **Event Based** and choose an option from the **Object Type** drop-down menu. The options in the **Change Type** drop-down menu change according to your **Object Type** drop-down menu choice.
8. Choose an option from the **Change Type** drop-down menu, then click **OK**.
Quark Publishing Platform event-based script example

The sample script below is triggered to publish and deliver a PDF version of an asset to a particular location when the asset's status is changed. In this case, the Object Type is called "ASSET" and the Change Type is "ASSET_CHANGED".

The whole script needs to be replaced by the following content:

```java
importPackage(Packages.java.lang);
importPackage(Packages.java.io);
importPackage(Packages.java.util);
importPackage(Packages.com.quark.qpp.core.messaging.service.constants);

// name of the status, such that when an asset is in given status, it should be published.
var statusName = "Publish";

// Destination folder for published content
var destinationFolder = "E:/target";

var assetId = ASSET.get(DefaultMessagePropertyNames.OBJECT_ID);

// Declare QPP Service Facades
var publishFacade = runtimeBeanManager.lookupBean("publishFacade");
var assetFacade = runtimeBeanManager.lookupBean("restAssetFacade");

// Map of content types and publishing channel ids.
// Depending upon the asset's content type, corresponding publishing channel will be considered
var publishingChannelsMap = {'QuarkXPress Project':'qxpPdf', 'Business Document':'busDocPdf'};

// Map of publishing channel id and publishing parameters
var parametersMap = { 'qxpPdf' : parametersForQxpPdf, 'busDocPdf' : parametersForBusDocPdf};

// Declare a string buffer
var stringBuffer = new StringBuffer();

// names of the attributes to be fetched
var attributes = ["Name", "Status", "Content Type"];

var assetInfo = assetFacade.getAsset(assetId, null/*majorVersion*/, null/*minorVersion*/, attributes,
false/*get child asset relations */,
false /* get parent asset relations*/,
[] /*Relation types*/,
null /*Rendition Type */,
null /* Output stream*/,
null /*layout number*/,
null /*page number*/);

var attributesList = assetInfo.getAttributeValueList().getAttributeValue();

for(var i = 0; i<attributesList.size(); i++)
{
  var attributeValue = attributesList.get(i);
  if(attributeValue.getName().equalsIgnoreCase("Name")){
    assetName = attributeValue.getValue();
  }
  if(attributeValue.getName().equalsIgnoreCase("Status")){
    currentStatus = attributeValue.getValue();
  }
  if(attributeValue.getName().equalsIgnoreCase("Content Type")){
    contentType = attributeValue.getValue();
  }
}

// In case the asset is in desired status
```
if(currentStatus.equalsIgnoreCase(statusName)){
    try{
        var pdfFile = new File(destinationFolder + "/*+ assetName:+*.pdf");
        var fileOutputStream = new FileOutputStream(pdfFile);
        //get publishing channel id on the basis of content type
        var publishingChannelId = publishingChannelsMap[contentType];
        var publishingChannelParameters = parametersMap[publishingChannelId];
        publishFacade.publishQPPResource(assetId, fileOutputStream, publishingChannelId, null /* Since we want to
        publish the given asset, hence delivery channel is null*/,
        publishingChannelParameters);
        stringBuffer.append("\n"+assetName+" has been published as PDF at location "+destinationFolder);
    }
    catch(exception){
        stringBuffer.append("Error while publishing the asset with name : "+assetName+"\n");
        stringBuffer.append(exception);
    }
    finally{
        if(fileOutputStream != undefined){
            fileOutputStream.close();
        }
    }
}
stringBuffer.toString();

Executing a script manually

Even if you define a Quark Publishing Platform event to trigger a script or schedule the script execution, you can execute a script manually at any time.

1) Display the script in the **Script Content** column.

2) To execute a script, choose **QPP > Execute** or click the **Execute** button.

3) To execute a specific function of a script, choose **QPP > Execute Parameter**. The **Execute Parameters** dialog box displays.

4) Enter a name in the **Method name** field, specify parameters (you can add and delete parameters), and click **OK** to execute the specific parameter(s).
Privileges

When you specify privileges for a role, you are defining the commands available to the members of that role for the selected Quark Publishing Platform application. When the members of a role do not have the privilege to perform a task, the command will be unavailable or hidden. To specify privileges, log in to the Quark Publishing Platform Web Admin interface at http://[IP address of Platform Server computer]:61400/admin and then click Roles and Privileges on the left.

There are two types of privileges:

• **Content Privileges**: These privileges control the way that users interact with content.

![Content Privileges](image)

Different content privileges are available for different asset types, and privileges may work differently depending on which asset type is selected.

• **Application Privileges**: These privileges control the application features that are available to users.
Content privileges are generally related to the degree and type of access that users have to content.

Content privileges: General

This section includes general privileges.

- **Check In New**: Role members can check in new articles, projects, pictures, and other assets.

- **Check Out Assets Assigned to Other Users**: Role members can check out articles, projects, pictures, and other assets that are assigned to other users.

- **Override Another User’s Checkout**: Role members can check out articles, projects, pictures, and other assets that are checked out by another user. For example, if a user has an asset checked out and you have the privilege to override a checkout, you can select the asset, press Option/Alt, and click Check Out on the Quark Publishing Platform Workspace toolbar. A message informs you that the asset is checked out by a specific user. If you continue with the override checkout, the other user will receive notice as well. The other user cannot check the asset in unless he or she renames it (and has the privilege to check in new assets). The new asset is a separate asset, unrelated to the original.

- **Duplicate**: Role members can duplicate articles, projects, pictures, and other assets.

- **Delete**: Role members can delete articles, projects, pictures, and other assets.

- **Preview**: Role members can preview articles, projects, pictures, and other assets.

- **View All Revisions**: Role members can view all revisions of articles, projects, pictures, or other assets within the collections to which the user belongs on Quark Publishing Platform Server.

- **Revert to Previous Version**: Role members can revert articles, projects, pictures, and other assets to previous versions.

- **Read-only Check Out or Get: Assets Assigned to Other Users**: Role members can copy read-only versions of articles, projects, pictures, and other assets. Users can retrieve copies of assets from Quark Publishing Platform Server without checking out the assets.
• **Change Checked-in Asset Name**: Role members can change the names of checked-in assets that are assigned to other users.

• **Check In Asset without Displaying the Check In Dialog Box**: Check this box to enable users to bypass the Check In dialog box by pressing Option/Alt while clicking Check In Asset.

• **Enable Asset Archiving**: This privilege allows users to archive Quark Publishing Platform assets.

• **Get Original Assets**: Role members can get the original version of assets.

• **Publish**: This set of privileges lets you control whether role members can publish in the various formats supported by Quark Publishing Platform.

**Content privileges: Edit Attributes**

This section includes several privileges that you can enable or disable for attributes assigned to each Quark Publishing Platform file type. When you create attributes, you can specifically limit their access to users who have the privilege to edit normal- and limited-access attributes by checking **Limited Access** in the **Create Attribute** dialog box. Users with the privilege to edit only normal-access fields cannot edit limited-access attributes. For example, members of the "Editors" role may have access to a limited attribute, such as "Editor's Approval." But members of the "Writers" role may not be able to edit the field because they only have the privilege to edit normal-access fields. The privileges include:

• **Edit Normal Access Fields of Asset(s) Routed to the User**: Role members can edit Normal Access attributes for articles, projects, pictures, and other assets routed to them.

• **Edit Normal Access and Limited Access Fields of Asset(s) Routed to the User**: Role members can edit Normal Access and Limited Access attributes for articles, projects, pictures, and other assets routed to them.

• **Edit Normal Access Fields of Asset(s) Routed to Other Users**: Role members can edit Normal Access attributes for articles, projects, pictures, and other assets that are routed to another user.

• **Edit Normal Access and Limited Access Fields of Asset(s) Routed to Other Users**: Role members can edit Normal Access and Limited Access attributes for articles, projects, pictures, and other assets that are routed to another user.

• **Change Collection of Checked-in Asset**: Role members can move a checked-in asset to a different collection.

• **Change Workflow of Checked-in Asset**: Role members can move a checked-in asset to a different workflow.

**Content privileges: Job Jackets**

This section includes several privileges that control whether role members can override Job Jackets features.

• **Override Default Job Jackets File or Job Ticket Template**: Role members can use a Job Jackets file or Job Ticket that is not the default.

• **Override Layout Evaluation Rules When Checking In a Project**: Role members can check in a project even if it fails layout evaluation.

• **Override Layout Evaluation Rules When Printing a Project**: Role members can print a project even if it fails layout evaluation.
Content privileges: Edit Redlining

Use these privileges to control whether users can accept and reject changes, as well as whether they can enable and disable redline change tracking.

- **Accept and Reject Changes (Selected/Displayed/All):** Role members can accept and reject redlining changes.
- **Enable/Disable Tracking:** Role members can turn redline tracking on and off.

Content privileges: Article Components

This section includes several privileges related to article components.

- **Drag and Drop Components to Form Primary Attachments Only (No Multilinks):** Role members can drag and drop components to create primary attachments only.
- **Drag and Drop Components to Form Primary and Secondary Attachments (Multilinks):** Role members can drag and drop components to create secondary attachments.
- **Override Primary Attachment of Components:** Check this box to enable users to press the Shift key while attaching an article component that is already a primary attachment. This creates a new primary attachment.
- **Enable Drag and Drop for Components across Collections:** Check this box to enable users to attach article components to projects in different collections.
- **Detach Components from Projects:** Check this box to enable users to detach a component from a project.
- **Add Components to Articles:** Role members can add components to articles.
- **Delete Components from Articles:** Role members can delete components from articles.
- **Rename Components and Change Component Types:** Role members can rename components and change their component types.
- **Retain Local Resources During Article Check-in:** Role members can keep local resources associated with an article after the article is checked in.

Content privileges: Edit Pictures

Use the controls in this area to enable users to manage picture attachments.

- **Drag and Drop:** Role members can drag and drop pictures from the Workspace Browser window into a layout.
- **Enable Drag-and-drop for Pictures across Collections:** Check this box to enable users to attach pictures to projects in different collections.
- **Detach Pictures from Projects:** Check this box to enable users to detach a picture from a project.
- **Modify Picture Placement Properties:** Role members can change the properties of imported pictures.
- **Replace or Clear Picture:** Role members can replace or remove imported pictures.

Content privileges: Editing

These privileges specify how role members can format text.
• **Edit Text**: Members of the role can edit text in checked-out articles.

• **East Asian Typography Features**: Members of the role can use East Asian typographic features.

• **Paragraph Formats**: This section includes privileges for applying paragraph formatting.

• **Character Formats**: This section includes privileges for applying character style sheets and certain character attributes (bold, italic, underline, superscript, subscript, and strike-through).

• **Notes**: This section includes privileges for creating and editing notes, as well as editing and viewing notes created by other users.

**Application privileges**

Application privileges are generally related to the degree and type of access that users have to application features.

**Application privileges: Administration**

The following privileges apply to workflow and file management.

• **Attributes**: This section includes three privileges to view, create and modify, and delete asset attributes.

• **Redlining**: Use these privileges to control whether users can accept and reject changes, as well as whether they can enable and disable redline change tracking.

• **Users and Groups**: This section includes privileges to view, create and modify, and delete users and groups of users. You can also manage users imported from a Lightweight Directory Access Protocol (LDAP) list.

• **Drop-down Menu Attribute Lists**: This section includes three privileges to view, create and modify, and delete lists that you can include in drop-down menu attributes.

• **Roles**: This section includes three privileges to view, create and modify, and delete roles.

• **System Monitoring**: This section includes three privileges to view the system monitor, log off users, and shut down Quark Publishing Platform Server.

• **Storage**: The storage function allows you to specify locations for Quark Publishing Platform Server to store assets, as well as rules for each kind of file type.
  
  • **Repositories**: This section includes three privileges to view, create and modify, and delete storage repositories.

  • **Storage Rules**: This section includes three privileges to view, create and modify, and delete locations for storing different file types.

• **Workflows**: This section includes privileges to view, create/modify, and delete workflows.

• **Content types**: This section includes privileges to view, create/modify, and delete content types.

• **Forms**: This section includes privileges to view and modify forms.

• **Relations**: This section includes privileges to view and modify relationships.

**Application privileges: Workspace**

The following privileges apply to the Quark Publishing Platform workspace.
• **Collections**: This section includes privileges to create, delete, duplicate, move, copy, browse, and modify collections.

• **Collection Templates**: This section includes privileges to create, delete, duplicate, move, and copy collection templates.

• **Searches**: This section includes privileges to create/modify, share/unshare, and delete searches. It also lets you enable enhanced search displays.

• **Live Preview**: Allows users to have a live preview of rendered XML documents in the References/Preview pane of Quark XML Author.
This glossary serves as a quick reference for Quark Publishing Platform specific terms.

**Archive**
To copy a Quark Publishing Platform asset from the storage folder to a backup storage location. Archiving an asset does not remove it from Quark Publishing Platform Server.

**Article**
A text file in a Quark Publishing Platform workflow. See also *Attached Article, No Subcategory Article*, and *Unattached Article*.

**Article component**
A text chain within a QuarkCopyDesk article. Article components can be created or deleted using QuarkCopyDesk, Quark Publishing Platform Web Client, or Quark Publishing Platform XTensions software for QuarkXPress. Each article component has its own copyfit information. See also *Picture Component*.

**Assign**
To route a new project, article, picture, or other Quark Publishing Platform asset to a user, group, or *No One*.

**Assignment notification**
An audio alert or dialog box that notifies you of an assignment. QuarkCopyDesk, QuarkXPress, and Quark Publishing Platform Client users can set a preference for being notified of assignments while logged on to Quark Publishing Platform Server. Users can receive an audio alert, a dialog box alert, both alerts, or neither alert.

**Attached article**
An article that has been linked to one or more text or pictures boxes in a QuarkXPress project. Attached articles may contain text, picture content, and a page picture.

**Attached picture**
A picture that has been linked to a picture box in a QuarkXPress project.

**Attributes**
Specific information attached to a Quark Publishing Platform asset. A typical set of attributes for a Quark Publishing Platform asset might include such information as the time and date the asset was
assigned, the due date and due time, and the current status of the asset. Administration role users define attributes at the server level.

**Attribute field**
An element of a Quark Publishing Platform asset attribute. Each attribute field holds a specific kind of information, such as due date or status. Fields can be normal access (available to all users with the privilege to edit attributes) or limited access (available only to users with the proper privileges). Field access can also be controlled with constraints. Field types include text fields, date fields, time fields, number fields, measurement fields, check box fields, and drop-down menu fields.

**Cancel Checkout**
To discard changes made to a checked-out asset and remove it from your hard disk. When you cancel a checkout, the version you most recently checked out from Quark Publishing Platform Server (or the last revision saved, if any) becomes the current version again.

**Check in**
The meaning of "check in" depends on whether an asset is already part of the Quark Publishing Platform workflow. If an asset is new, to check it in is to introduce it into the Quark Publishing Platform workflow by adding it to Quark Publishing Platform Server. If an asset is already in Quark Publishing Platform Server, to check it in is to return control of the asset to Quark Publishing Platform Server after having the asset checked out. Checking in usually involves routing the asset to another user or group, although users can also route assets to themselves.

**Check out**
To check an asset out is to copy the most recent version of that asset to your local hard disk for editing. When you check out an asset, you prevent other users from editing it. When editing is complete, you must check in the asset to return control of it to Quark Publishing Platform Server.

**Collect for Output**
A QuarkXPress command that enables you to create a copy of a project, copies of picture assets imported into the project, color profiles and fonts used in the project, and a report of the project's elements. When you create a "collect for output" version of a project (usually after all attached articles and page elements are finished and the project is ready for output), all article text is saved to the copy, which can be opened and printed using any compatible version of QuarkXPress.

**Collection**
A collection is a group of related assets. Each collection can have one or more associated workflows (optionally with automatic routing rules), a set of Job Jackets, a number of associated users and groups, and revision settings for each asset type.

**Collection template**
Collection templates make it easier to create and maintain collections. For example, assume you have several publications, and each publication needs its own identically configured "Images" subcollection. Rather than creating each "Images" collection manually from scratch, you can create an "Images Template" collection template, then create each "Images" collection from that template. If you later need to add a user or make a change to a Job Ticket used by the "Images" subcollections, you can simply make the change to the "Images Template" collection template, and the change is automatically applied to all collections that use that collection template.
**Component**
See Article Component and Picture Component.

**Constraint**
A limitation on what a user can or cannot do to an attribute field when he or she checks in an asset, saves a revision, or edits an attribute. A constraint can require a user to make a change to the value in a field, require the user to enter a value in the field, or prevent the user from changing the contents of the field. Constraints can be based on status and role.

**Copy tasting (also called "text preview")**
The ability to view the first 255 characters of a QuarkCopyDesk article component or text file in the Workspace window.

**Default path for checked-out assets**
The folder on a user's hard disk where checked-out assets are stored while the user is working with them.

**Delete**
To delete a Quark Publishing Platform asset is to permanently remove it from Quark Publishing Platform Server. You can also delete article components using Quark Publishing Platform XTensions software and QuarkCopyDesk.

**Destination server**
The server to which you are copying assets when you replicate them.

**Display submenu (View menu) and Display drop-down menu (Workspace toolbar)**
Display options that enable you to display search results according to file name, collection, thumbnail preview, or a scrollable "filmstrip" of thumbnail previews. For users who have the "Enable Enhanced Search Displays in Workspace Browser Window" privilege, additional options display. Users with the privilege can view search results by name, project, project and page, and the custom hierarchy of attributes. Users without sufficient privileges can see the search results displayed by name. To change a display mode, choose an option from the Display drop-down menu or Display submenu (View menu).

**Drag and Drop**
A method for attaching an article or picture to a box in a QuarkXPress project or to a component in a QuarkCopyDesk article. Using Quark Publishing Platform XTensions software, you can drag and drop an asset from a Workspace window or a file system folder by clicking the asset's icon, dragging it over a box or component, and releasing the mouse button. When you attach a picture file to a QuarkXPress project, you can assign it as a picture or a QuarkCopyDesk article.
Duplicate asset
The act of creating a copy of a Quark Publishing Platform asset. Users with the privilege can select an asset in the Workspace window and click the Duplicate button. The duplicate asset includes the same attribute information as the original asset, but it has no revisions.

Edit attribute
The act of changing the attribute fields of a Quark Publishing Platform asset. You can select an asset in a Workspace window and click Edit Attribute to display the Attribute information dialog box, which includes all attribute fields you can access.

Favorites
An area in the Workspace navigation pane of the Workspace Browser where you can store links to often-used collections and searches for easy access.

FIT!!
The QuarkCopyDesk Measurements palette displays FIT!! when an article component matches its assigned length. If an article component does not fit, either the overset or underset amount is displayed in the Measurements palette.

Full Screen view
One of three article viewing options in QuarkCopyDesk. Displays the text of the article in a single column that is as wide as the article window. Full Screen view redraws rapidly and displays some character formatting, but it does not display paragraph formatting and line breaks. See also Galley View and WYSIWYG View.

Galley view
One of three article viewing options in QuarkCopyDesk. Displays the text of the article in a single column that accurately shows line breaks, but does not show all paragraph formats and character attributes. See also Full Screen view and WYSIWYG view.

Geometry
Geometry consists of box-shape information, runaround information, text-formatting information, hyphenation exceptions, and everything else that determines how text flows in a project. Attached articles include geometry from the projects to which they are attached. Geometry is necessary for maintaining accurate copyfitting information and text display in WYSIWYG view.

Get
The ability to retrieve a copy of a Quark Publishing Platform asset without checking out the asset itself. Using Get to retrieve a copy of an asset does not affect the corresponding master file.

Group
A name that refers to a defined list of users. You can route an asset to a group the same way you route an asset to a single user. Assets routed to a group will display in the user assignment Workspace navigation pane for all users in that group.
**Issue**
A server-level attribute that provides a customizable category for organizing content structures and Quark Publishing Platform assets. Users with the "Enable Enhanced Search Displays in Workspace Browser Window" privilege can organize search displays according to assets associated with issues.

**Lightweight Directory Access Protocol (LDAP)**
LDAP is a protocol that allows administrators to consolidate user accounts for different network systems. Often referred to as "active directory" on Windows, LDAP streamlines system administration because users can be added, deleted, and modified in one location and updated in Quark Publishing Platform. Quark Publishing Platform Administrators can also create and manage separate users not on the LDAP list.

**Limited-access field**
A field in a Quark Publishing Platform attribute that can be edited only by users with the privilege to edit limited-access fields. See also **Normal-access field**.

**Log file**
Log files record activity on Quark Publishing Platform Server.

**Log off**
To disconnect from Quark Publishing Platform Server.

**Log on**
To connect to Quark Publishing Platform Server. To log on, you must enter a user name and password.

**Mapping set**
A set of replication guidelines that determines where assets are copied and what happens to attribute data when an asset is replicated. A mapping set enables you to specify how values in attribute fields on the source server are mapped to values in corresponding attribute fields on the destination server.

**Master file**
The most recently checked-in version of a Quark Publishing Platform asset. Master files are stored in Quark Publishing Platform file repositories.

**MultiLinks**
The ability to attach an article or picture to more than one project. MultiLinks include one "primary link" and one or more "secondary links."

**Normal-access field**
An attribute field that can be edited by any user with the privilege to edit attributes. See also **Limited-access field**.

**Note**
An annotation inserted into an article using QuarkCopyDesk or QuarkXPress using the Notes XTensions software. An editor might use a note to remind a writer to check the spelling of a name or the accuracy of a statement. Notes can be made invisible and do not affect text flow. QuarkCopyDesk users can print notes in an article.
**Overset**
An article is overset when its current length is greater than its assigned length. See also *FIT!!* and *Underset.*

**Page picture**
An onscreen representation of the QuarkXPress project page to which a QuarkCopyDesk article is attached. Page pictures are visible in WYSIWYG view in QuarkCopyDesk, as well as Quark Publishing Platform Web Client.

**Pane**
An area with user-specific controls in the Quark Publishing Platform Client interface.

**Password**
A set of characters without which a user cannot log on to Quark Publishing Platform Server. A password can also be empty.

**Picture**
A graphics file in a format compatible with QuarkXPress.

**Picture component**
A QuarkCopyDesk article component that contains a picture.

**Preview**
A representation of an asset in the *Workspace* window.

**Primary link**
The first link created between an article and a text box or a picture and a picture box in a QuarkXPress project. The primary link determines the geometry used when the article is edited using QuarkCopyDesk. If the primary link is broken and a QuarkXPress user is logged on, he or she can establish a new primary link. The QuarkXPress user can override an attachment to establish a new primary link. See also *Secondary link.*

**Privileges**
Privileges determine if and when members of a role can have access to specific Quark Publishing Platform assets, attribute fields, and software features. For example, privileges for a "Reviewer" role may enable the members to add notes to articles but prevent them from editing article text. Privileges can be altered according to an asset's status. See also *Status privileges.*

**Quark Publishing Platform**
See *Quark Publishing Platform.*

**Quark Publishing Platform Client application**
The application that provides workflow administration functions, file management, and connectivity with third-party applications.
**QuarkCopyDesk**
An application that opens and creates articles in which you can enter and edit text, notes, and pictures. QuarkCopyDesk can be linked to Quark Publishing Platform Server or used as a standalone text processor.

**QuarkCopyDesk Preferences file**
The file that contains program default information for QuarkCopyDesk. The "QuarkCopyDesk Preferences.prf" file contains Application preferences, Article preferences, style sheets, colors, H&J specifications, lists, auxiliary dictionary path information, and hyphenation exceptions.

When a QuarkCopyDesk user logs on to Quark Publishing Platform Server and works on an article that is attached to a QuarkXPress project or created from server defaults, the project-level and server-level attributes override "QuarkCopyDesk Preferences.prf" file settings.

**QuarkCopyDesk template**
A write-protected version of a QuarkCopyDesk article, created by saving the file in template format. When you open a QuarkCopyDesk template, you create an editable copy of the template file.

**QuarkDispatch configuration file**
A file that defines the parameters of an older Quark Publishing Platform (that is, earlier than Quark Publishing Platform 7).

**Quark Publishing Platform asset**
An article, project, picture, or other asset that has been checked in to Quark Publishing Platform Server. A Quark Publishing Platform asset has an associated set of attributes, which includes information about the asset, such as its due date and the name of the user who modified it most recently.

**Quark Publishing Platform Server**
A networked application that keeps track of all the transactions (asset movements and revisions) on the system, searches for and retrieves assets, and manages all elements and asset access authorization in Quark Publishing Platform.

**Quark Publishing Platform Web Client**
A browser-based text-editing application to use within the Quark Publishing Platform workflow.

**Quark Publishing Platform XTensions software for QuarkXPress and QuarkCopyDesk (Quark Publishing Platform XTensions software)**
XTensions software that enables QuarkXPress and QuarkCopyDesk users to connect to Quark Publishing Platform Server. With Quark Publishing Platform XTensions software, QuarkXPress users can assign articles, search for articles and pictures, and attach them to text and picture boxes in a project. Using the **Update Geometry** function, QuarkXPress users can notify other users when a project with attached items changes.

**Quark Publishing Platform**
An integrated workgroup publishing system based on software from Quark Software Inc. Quark Publishing Platform (Quark Publishing Platform) provides editorial, page layout, and workgroup-management functionality. Built around QuarkXPress, Quark Publishing Platform enables writers, editors, graphic artists, and workgroup managers to work on projects simultaneously.
**Read-Only**
To retrieve a read-only copy of a Quark Publishing Platform asset from Quark Publishing Platform Server.

**Require Value**
An asset attribute constraint that requires a user to enter or choose a value for the field before proceeding with the check-in, save revision, or edit attribute operation.

**Revert**
The act of accessing a previous revision of a Quark Publishing Platform asset. Users with the privilege to view a list of asset revisions can choose a revision and revert to it. When you revert to a previous revision, it becomes the current version on Quark Publishing Platform Server.

**Revision**
A previous version of a Quark Publishing Platform asset. A new revision is saved each time you check in an asset or save a revision manually. You can view and revert to revisions if you have the appropriate privileges. See also Revision Comment and Revision Tracking.

**Revision comment**
A message that can be attached to a Quark Publishing Platform asset revision when you save a revision or check in the asset.

**Revision tracking**
The capability of a Quark Publishing Platform site to automatically save revisions and keep track of the location of Quark Publishing Platform assets as they are routed through the production process from the time they are assigned or checked in until they are produced and deleted from the system.

**Role**
A set of privileges that determines a user's access to Quark Publishing Platform assets, attribute fields, and software features. You must assign each user to a role.

**Route**
Users can route Quark Publishing Platform assets to particular users, to a group, or to no particular user (No One). A Quark Publishing Platform asset that has been routed to a user is displayed in that user's Workspace window when he or she checks assignments. Assets routed to a group display in all the group members' Workspace windows.

**Search**
A set of criteria used to search for assets according to attributes in Quark Publishing Platform Server. In response to a search, Quark Publishing Platform Server returns a list of matching assets in the Workspace window.

**Search results pane**
The pane in the Workspace pane of the Workspace Browser palette where search results are displayed.
Secondary link
A link between a project's text or picture box and a Quark Publishing Platform asset that has already been linked to a different project. A secondary link is created by dragging and dropping an attached article or picture to a box in a different project. A secondary link is essentially a read-only link to the original content, but it can be updated when the content is updated. See also Primary link.

Server
The top organizational level of a Quark Publishing Platform site.

Source server
The server from which assets originate when you replicate them.

Spread view
A view that displays previews of page spreads. This view is visible in the Preview pane in Quark Publishing Platform clients.

Status
A labeled "stage" that a Quark Publishing Platform asset goes through on its way through a Quark Publishing Platform workflow. A list of statuses might include Assigned, First Draft, Edited, Copy Edited, Proofed, Final Draft, and so forth. Statuses are set up by members of the Administration role at the workflow level, and statuses can be customized to meet different needs.

Status privileges
Privileges granted to users when an asset reaches a certain status. Status privileges can match role privileges, or they can be custom-defined for the status. Members of the Administration role set up status privileges.

Status routing
The ability to automatically route a Quark Publishing Platform asset to another user or group whenever a new status is chosen for the asset. (For example, when an article's status is set to "Ready for Editing," the editor's name can be automatically selected in the Route to drop-down menu.)

System integrator
A system integrator evaluates a site's current hardware and software needs, determines how to integrate the hardware and software required for a Quark Publishing Platform system, installs the system, and provides technical support, training, and expertise. Although they are not Quark employees, system integrators are trained and certified by Quark Software Inc. to sell, install, and support Quark Publishing Platform software.

Unattached article
An article that is tracked by Quark Publishing Platform Server but is not attached to a box in a project.

Unattached item
A Quark Publishing Platform asset that is not attached to a project.

Unattached picture
A picture that is tracked by Quark Publishing Platform Server but is not attached to a box in a project.
Glossary

Underset
An article is underset when its current length is less than its assigned length. See also FIT!! and Overset.

Users
When you configure a Quark Publishing Platform Server, you must create a system-wide list of users at the server level. Users in the server-level list can be selectively included or excluded in collections.

Workspace Browser window
A window that lets you perform almost all client and administrative tasks in Quark Publishing Platform Client, and almost all client tasks in other Quark Publishing Platform client applications.

Workspace navigation pane
An area on the left side of the Workspace pane where you can easily perform searches and access favorites, saved searches, unsaved searches, shared searches, assignments, and collections.

Workspace window
The Workspace window includes buttons and drop-down menus for performing most Quark Publishing Platform functions, and it displays the results of a search.

WYSIWYG view
One of three article viewing options in QuarkCopyDesk. Displays the text of the article using the geometry of the project to which the article is attached. If the article has a page picture, the page picture is also displayed in WYSIWYG view. ("WYSIWYG" stands for What You See Is What You Get.) See also Galley view and Full Screen view.

XTensions software
Software that adds functionality to QuarkXPress and QuarkCopyDesk.
Legal notices

©2013 Quark Software Inc. and its licensors. All rights reserved.

Protected by the following United States Patents: 5,541,991; 5,907,704; 6,005,560; 6,052,514; 6,081,262; 6,633,666 B2; 6,947,959 B1; 6,940,518 B2; 7,116,843; 7,463,793; and other patents pending.

Quark, the Quark logo, and Quark Publishing Platform are trademarks or registered trademarks of Quark Software Inc. and its affiliates in the U.S. and/or other countries. All other marks are the property of their respective owners.
Índice Remissivo

A
administration 20, 29, 38, 39, 66
anchored picture boxes 103
App Studio 48, 104, 106
App Studio articles 48, 60
archiving 71, 113
archiving assets 41, 42, 50
article templates 101, 105
articles 96, 142, 143, 144
Ask 91
assigning 47, 60
assigning assets 67, 87, 88
attachments 49, 98, 99, 100, 102, 103, 104
attribute constraints 26
attribute forms 20, 31
attribute types 22, 23, 25
attributes 20, 21, 22, 26, 31, 48, 61, 107, 135
auto logoff 116, 123
automation 71
AVE 48
AVE publishing 61

B
bullet styles 140
bullets 139

C
callouts 146
canceling checkout 47, 61, 98
checking in assets 47, 60, 83, 85
checking out assets 47, 60, 95, 96, 97
collection templates 61, 73
collection types 20, 74
collections 73, 74, 81, 82
compact view 50
component attachments 103
conditional styles 140
Content Diffsers 99
collection structure 45
collection types 20

captions 8
copytasting 71
creating assets 73
customizing 50, 80, 95, 108, 109, 110, 111, 112, 113, 114,
116, 121, 123, 143, 144, 147

delting assets 42, 49
detaching attachments 104
digital assets 104
direct attachments 103
displaying assets 47, 60
duplicating assets 49

ePUB 48, 60, 106
expanded view 51, 58
exporting assets 71

F
Flash 48, 61, 106
formatting conventions 8
forms 20, 31

G
Geometry Differs 99
grouping assets 105
getting assets 47, 60, 106, 135
groups 17, 38

H
HTML 48

I
icons 56
index 49
ÍNDICE REMISSIVO

J
Job Jackets 73, 80

L
libraries 105
list view 51
logging off 41, 116, 123
logging on 72, 131

M
managing assets 67
monitoring activity 41
moving assets 41

N
notification 110, 115, 122
numbering 139
numbering styles 140

O
opening assets 47
outline styles 140
output 71

P
page pictures 102
password 72
PDF 48, 61, 106
picture components 106
preferences 80, 109, 110, 111, 112, 113, 114, 116, 121,
123, 147
previewing assets 57
primary attachments 99
privileges 17, 32, 159
projects 96
publishing 48
publishing assets 106, 135

Q
QuarkCopyDesk 62, 73, 96, 97, 121, 123
QuarkXPress 63, 64, 73, 80, 88, 96, 114, 116
QuarkXPress projects 48, 61
Quicksearch 90

R
read-only assets 47, 60, 106
redlining 39, 127
repositories 18
restoring 71
restoring assets 41, 43, 50
revisions 49, 61, 108
revisions, saving 48
roles 32, 45
routing 71, 79
routing rules 79
RTF 48, 61

S
saved searches 94
saving revisions 48
scripts 150, 154
search from here 94
searches 90, 94
searching 48, 49, 88, 91, 94, 95, 142
secondary attachments 99
server name 72
statuses 30
storage options 17, 18
style sheets 140
SWF 48, 61, 106

T
templates 98, 138
templates, editing 138
text files 102
tracking 71

U
unsaved searches 94
user name 72
users 17, 32, 33, 38

V
views 45

W
workflow 17
workflows 29, 30, 31, 66

Z
zave format 106