Contents

Chapter 1

Before you begin 5

About this guide 5
Registration and customer support 5
Update notification 6
About the license key 7
Activating your FileMaker software 7
Hardware and software requirements 9
  Windows requirements 9
  Mac OS requirements 9
Networking requirements 9
Web publishing requirements 10
Requirements for other features (Windows) 10
Requirements for other features (Mac OS) 11
Features not supported in Mac OS X 11
Features not supported in Windows 11
Opening files from previous versions 11
Updating your User Dictionary 11
Installing under a volume license 12

Chapter 2

Installing FileMaker Pro in Windows 13

Installation notes 13
Installing FileMaker Pro 14
Installing FileMaker Pro from the command line 15
Where files are stored on your hard disk 15
Uninstalling, modifying, or repairing FileMaker Pro 15
Changing the FileMaker Pro cache size 16
Where to go from here 17
Chapter 3

*Installing FileMaker Pro in the Mac OS*

- Installation notes 19
- Installing FileMaker Pro 20
- Where files are stored on your hard disk 20
- Installing ODBC client drivers in Mac OS X 20
- Adjusting the FileMaker Pro cache 21
- Where to go from here 22

Chapter 4

*New features*

- New features in FileMaker Pro 9 23
- New features in FileMaker Pro 9 Advanced 26
Chapter 1
Before you begin

Welcome to your FileMaker® software. FileMaker is designed to help you manage information easily and effectively.

About this guide
This Installation and New Features Guide tells you how to install FileMaker Pro 9 or FileMaker Pro 9 Advanced on your Windows or Mac OS computer and introduces new features in the software.

Note This guide uses “FileMaker Pro” to refer to both FileMaker Pro and FileMaker Pro Advanced, unless describing specific FileMaker Pro Advanced features.

The FileMaker Pro User’s Guide provides essential information to get you working productively right away. If you’ve never used FileMaker Pro, work through the FileMaker Pro Tutorial to try out the major features. For details and comprehensive, step-by-step procedures, see FileMaker Pro Help.

The FileMaker Pro Advanced Development Guide describes additional features available in FileMaker Pro Advanced, including features such as customizing menus; copying and importing tables; Database Design Reports; field, variable, and expression monitoring using the Data Viewer; and adding tooltips.

Note When a feature or procedure is specific to a particular platform, you see instructions and illustrations that are also specific to that platform. For features or procedures that are similar on both platforms, you may see illustrations for either Windows or the Mac OS.

Registration and customer support
Please take a few moments to register your product during installation. By registering your software, you may be eligible for upgrade offers and other customer services. Follow the prompts to provide your registration, product, and additional information.
Before you begin

If you are using the FileMaker Pro trial version, you must register your software prior to use.

You can also register through the FileMaker website at www.filemaker.com/register, or by choosing Help menu > Register Now in FileMaker Pro. In either case, you must register with a valid license key.

For information about Technical Support and Customer Assistance, visit www.filemaker.com/intl.

To access resources on the FileMaker website such as ready-made solutions and the FileMaker Knowledge Base, choose Help menu > Learning Center.

If you do not have access to the web, please refer to the FileMaker Service Directory that comes with your software.

Update notification

FileMaker Pro 9 automatically checks for software updates every seven days. If you have an internet connection, you can go to the update web page and download the updater software. You can update later by choosing Help menu > Downloads and Updates.

Note This feature does not install the software for you. You must have an internet connection to access and download the updater software.

To turn off update notification, do one of the following:

- In the Update Notification dialog box, select Do not automatically check for updates and click Yes.

- In Windows, choose Edit menu > Preferences. In Mac OS, choose FileMaker Pro menu > Preferences. Deselect the Automatically check for updates every 7 days option in the General tab. To turn on update notification again, select this preference.

If you disable update notification, the Update Notification dialog box will not display.
About the license key

FileMaker software comes with a unique, 35-digit alphanumeric license key. Do not lose this license key. We recommend that you keep the license key in a safe place in case the software ever needs to be reinstalled.

You can find your license key(s) on the back of the CD sleeve. If you paid for your software electronically, you received an email with a link to a PDF file with your license key. You must enter a valid license key to activate the software. See the following section, “Activating your FileMaker software,” for more information.

The license key ensures adherence to the end-user license agreement, which generally allows for use of one (1) copy of the Software on a single computer at a time (refer to your Software License). If the license key is invalid or if another copy of the application installed with that same license key is running on the network, the FileMaker Pro application displays this error message: “The maximum number of licensed users are currently using this copy of FileMaker Pro. Please refer to the License Key section of your software documentation for further instructions.”

If you receive this error message, you have entered a duplicate license key. To install FileMaker Pro on multiple computers, you must have a unique license key for each user, or obtain a volume license. You must license one copy of FileMaker Pro for each computer.

Activating your FileMaker software

FileMaker Pro software uses online activation technology to help ensure you and your organization have a genuine copy of FileMaker software. Activation also helps protect FileMaker, Inc. from unauthorized software distribution.

<table>
<thead>
<tr>
<th>To</th>
<th>In FileMaker, do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Activate FileMaker Pro at startup</td>
<td>In the FileMaker Activation dialog box, click Activate.</td>
</tr>
<tr>
<td>Activate commercial software later</td>
<td>In the FileMaker Activation dialog box, click Activate Later.</td>
</tr>
<tr>
<td>Activate commercial software during a grace period</td>
<td>Choose Help menu &gt; Activate. In the FileMaker</td>
</tr>
<tr>
<td></td>
<td>Activation dialog box, click Activate.</td>
</tr>
</tbody>
</table>
Before you begin

Activation works differently for trial versions and commercial software. As a trial user, you have time (typically 30 days) before you are required to pay for the software. At any time during the trial period, you may pay for the software, and then activate it by entering the license key at startup. After the trial period expires, you must pay for the software and activate it immediately to continue using it.

You can activate your commercial software later. This is called an *activation grace period*. FileMaker Pro gives you a grace period (typically 30 days) for activating the software. Each time you launch the software you see the Activation dialog box indicating the time remaining in your grace period and prompting you to activate your software.

Following this grace period, you must activate the software to continue using it. Trial versions do not have an activation grace period.

If you do not have an internet connection, you can activate your software by phone. Call FileMaker Customer Assistance using a phone number listed in the Service Directory. Check www.filemaker.com/activation for updated information and phone numbers.

After activating your software, you can deactivate and transfer activation to another computer. This lets you run FileMaker Pro on a different computer. If you need to uninstall FileMaker Pro for any reason, deactivate before uninstalling.

For more information on activation, see “Activating your FileMaker software” in FileMaker Pro Help.
Hardware and software requirements

Important At the time this book was written, FileMaker, Inc. tested FileMaker Pro 9 with the Windows and Mac OS operating systems listed below. FileMaker Pro may or may not work with newer operating system releases. For information on newer operating systems, see www.filemaker.com.

To install and use FileMaker Pro, you need the following minimum equipment and software:

Windows requirements
- Windows Vista Home, Business, or Ultimate: Pentium III 800 MHz or faster with 512 MB RAM
- Windows XP SP2: Pentium III 500 MHz or faster with 256 MB RAM
- SVGA (800x600) or higher resolution video adapter and display

Mac OS requirements
- Macintosh computer with PowerPC G3 processor or faster, or Intel-based Macintosh computer
- 256 MB RAM
- Mac OS X version 10.4.8
- QuickTime 6.4 to 7 software (available at www.apple.com if it was not included with your Mac OS version)

Note Mac OS plug-ins created for PowerPCs need to be re-compiled as universal binaries in order to run natively when FileMaker Pro is run on Intel-based Mac computers. Universal binaries allow applications to run natively on both PowerPC and Intel-based Macintoshes. If you have plug-ins from previous FileMaker Pro versions that you would like to use with FileMaker Pro 9 on an Intel-based Macintosh, you can set FileMaker Pro to run under Rosetta. Select FileMaker in the Finder, choose File menu > Get Info, and select the Open using Rosetta option.

Networking requirements
If you plan to share FileMaker Pro files with other computers on a network, you need to know which type of network you’re using. FileMaker Pro 9 supports the TCP/IP network protocol.
If you’re not sure which network protocol is installed and in use on your computer, check with your network administrator before you begin installation.

To connect to a network, your computer must also have a network card and the required software.

**Web publishing requirements**

To publish a database on the web using FileMaker Pro Instant Web Publishing, you need a host computer with access to the internet or an intranet via TCP/IP.

**Important** Access to the internet requires an internet service provider (ISP). FileMaker Pro does not provide an internet account for you.

**Requirements for other features (Windows)**

Some of the features of FileMaker Pro for Windows require additional software.

<table>
<thead>
<tr>
<th>Feature</th>
<th>Software requirement</th>
</tr>
</thead>
<tbody>
<tr>
<td>Send Mail script step</td>
<td>A Mail API (MAPI) enabled email client software</td>
</tr>
<tr>
<td>Phone dialing</td>
<td>Phone dialer or other Telephony API (TAPI) compliant software</td>
</tr>
<tr>
<td>ODBC features</td>
<td>Microsoft Data Access Components (MDAC) version 2.8 SP1 (Windows XP) or Windows DAC 6.0 (Windows Vista). To update MDAC software, see the Microsoft website at <a href="http://www.microsoft.com">www.microsoft.com</a>. Accessing external data sources using FileMaker Pro as a client application requires third-party drivers for the data source you are using. For more information on using ODBC, see <a href="http://www.filemaker.com/support/technologies">www.filemaker.com/support/technologies</a></td>
</tr>
<tr>
<td>Insert QuickTime movie</td>
<td>QuickTime 6 software (available at <a href="http://www.apple.com">www.apple.com</a>)</td>
</tr>
<tr>
<td>and image files</td>
<td></td>
</tr>
</tbody>
</table>
Requirements for other features (Mac OS)

Some of the features of FileMaker Pro for Mac OS X require additional software.

<table>
<thead>
<tr>
<th>Feature</th>
<th>Software requirement</th>
</tr>
</thead>
<tbody>
<tr>
<td>Send Mail script step</td>
<td>Microsoft Entourage or Mac OS X Mail email client software</td>
</tr>
<tr>
<td>ODBC features</td>
<td>Accessing external data sources using FileMaker Pro as a client application requires third-party drivers for the data source you are using. For more information on using ODBC, see <a href="http://www.filemaker.com/support/technologies">www.filemaker.com/support/technologies</a></td>
</tr>
</tbody>
</table>

Features not supported in Mac OS X

In Mac OS X, FileMaker Pro does not support the Dial Phone, Insert Object, Send DDE Execute, and Update Link script steps.

Features not supported in Windows

In Windows, FileMaker Pro does not support the Perform AppleScript and Speak script steps.

Opening files from previous versions

FileMaker Pro 9 can open files created in earlier versions of FileMaker Pro. See FileMaker Pro Help for information.

Updating your User Dictionary

If you added words to a User Dictionary in a previous version of FileMaker Pro, you can use it with FileMaker Pro 9. See FileMaker Pro Help for information about converting a User Dictionary.
Installing under a volume license

If you’re installing multiple copies of FileMaker Pro under a volume license, or if you want to do a silent install, you can automate the process. Use the Assisted Install.txt file on the FileMaker Pro CD or in your electronic download to bypass the usual install dialog boxes. For more information, see Network Install Setup for FileMaker Pro and FileMaker Pro Advanced. For information on volume licensing, see www.filemaker.com.
Chapter 2

Installing FileMaker Pro in Windows

Before you begin the installation process, exit other open programs and save your work. For late-breaking information about FileMaker Pro, browse the contents of the CD and view the Read Me file or visit www.filemaker.com.

Installation notes
Before you install FileMaker Pro, review the following notes:

- To install FileMaker Pro, you must have Administrator privileges.
- If your computer is running virus protection software, turn it off prior to installing FileMaker Pro, and then turn it back on afterwards.
- When you are installing FileMaker Pro, you will see the License Agreement panel. Read the Software License Agreement. If you accept the terms of the license agreement, click I accept..., then click Next.
- By default, FileMaker Pro will be installed in this folder: C:/Program Files/FileMaker/FileMaker Pro 9
  During installation, you can choose another drive or another folder.
- By default, FileMaker Pro Advanced will be installed in this folder: C:/Program Files/FileMaker/FileMaker Pro 9 Advanced
  During installation, you can choose another drive or another folder.
- During installation, you can choose whether to install all program features (Complete), or to install only selected portions of the program (Custom). For example, you may choose not to install certain features in order to save disk space.
At the start of installation, you choose a language version for the FileMaker Pro application. The default selection matches your operating system language. A Complete install will install only the language version you choose. You can install additional language versions by choosing Custom install, then selecting other language packs from the list of supported languages.

Prior to an upgrade installation or software update, FileMaker software scans all hard drives and volumes connected to your system, searching for previous versions. This scan may take several minutes if you have multiple drives or volumes.

**Installing FileMaker Pro**

You must use the installation program to install FileMaker Pro—you can’t install FileMaker Pro by dragging files to your hard disk.

If you want to create an install log file that lists the registry entries and path of all installed files, you must install FileMaker Pro from the command line. See “Installing FileMaker Pro from the command line” on page 15.

To install FileMaker Pro on your hard disk:

1. Insert the CD into your CD or DVD drive, and open the FileMaker CD window. (If you paid for your software online, navigate to the Install icon.)
2. Click the Install icon.

The FileMaker Pro InstallShield Wizard appears.

3. Install FileMaker Pro by following the on-screen instructions.

   For details about installation issues, see “Installation notes” on page 13.

4. When the installation is complete, click Finish.

   When installation completes, you see the Product Registration panel.
Installing FileMaker Pro from the command line

To install FileMaker Pro from the command line and create an installation log file:

1. Insert the CD into your CD or DVD drive. (If you paid for your software online, skip this step.)
2. Open a command window.
3. In the command window, type
   
   E:\Files\setup.exe /v"/Lr C:\FMP9InstallLog.txt"
   
   where E: is the CD or DVD drive. If your CD or DVD drive uses a different drive letter, type that letter instead of E.
4. Follow the on-screen instructions.
   
   The FMP9InstallLog.txt file will be located in the root directory of your hard disk. You can view it with WordPad or a word processing program.

   **Note** If your CD or DVD drive is not located at drive E, then substitute the correct letter for your drive.

Where files are stored on your hard disk

The FileMaker Pro installer copies files to several folders on your hard disk, depending on the installation options you choose and your operating system. If you performed a command line installation and specified an install log file, you can view the install log file, which lists the location of each installed file.

Uninstalling, modifying, or repairing FileMaker Pro

You can use the Windows XP Add or Remove Programs control panel, or Windows Vista Programs and Features control panel, to uninstall FileMaker Pro, replace missing or corrupt files, or to change which features are installed. For more information, refer to Windows Help.

   **Note** Uninstalling doesn’t delete files that you’ve created, as long as they are named differently than the sample and template (Starter Solution) files that are installed with FileMaker Pro.
When you modify or repair FileMaker Pro, you may be prompted to enter your license key.

**Note** Before uninstalling FileMaker Pro, deactivate your software. See “Activating your FileMaker software” on page 7 for more information.

**Changing the FileMaker Pro cache size**

FileMaker Pro maintains an internal cache of portions of your database. Depending on your computer’s memory configuration, you may want to adjust the cache size to improve performance.

You may want to consider increasing the cache size if you plan to:

- work on a large database file
- work on several database files at once
- host database files
- use a database file that contains many graphics
- insert a large graphic into a database file

Consider decreasing the cache size if you plan to run several applications at the same time and you have a limited amount of memory (RAM) installed.

**Note** When you increase or decrease the FileMaker Pro cache size, you also increase or decrease the amount of memory needed to run FileMaker Pro.

For more information on managing memory, see the documentation that came with your computer.

To change the cache size that FileMaker Pro uses:

1. In FileMaker Pro, choose Edit menu > Preferences.

   The Preferences dialog box appears.
2. Click the Memory tab.

3. Type a number in the Attempt to set file cache to box, then click OK. The next time you start FileMaker Pro, the new cache size is used.

Where to go from here
After you install FileMaker Pro, you can immediately begin working with the application. Here are some suggestions on where to go in the documentation to get started:

- If you’re new to databases, read chapter 2, “Using databases” and chapter 3, “Creating databases” in the *FileMaker Pro User’s Guide* to learn basic database concepts.

- If you’re new to FileMaker Pro, work through the lessons in the *FileMaker Pro Tutorial*. The PDF file and sample file for the tutorial are located in the Tutorial folder inside the English Extras folder.

- If you’ve used FileMaker Pro before, read chapter 4, “New features” in this guide for an overview of new features available in FileMaker Pro 9 and FileMaker Pro 9 Advanced.

- If you’re a FileMaker Pro Advanced user, see the *FileMaker Pro Advanced Development Guide* and FileMaker Pro Help.
Chapter 3
Installing FileMaker Pro in the Mac OS

Before you begin the installation process, quit other open programs and save your work. For late-breaking information about FileMaker Pro, browse the contents of the CD and view the Read Me file or visit www.filemaker.com.

Installation notes
Before you install FileMaker Pro, review the following notes:

- If your computer is running virus protection software, turn it off prior to installing FileMaker Pro, and then turn it back on afterwards.
- When you are installing FileMaker Pro, you will see the License Agreement panel. Read the Software License Agreement. If you accept the terms of the license agreement, click Accept.
- During installation, you can choose whether to install all the program files (an Easy Install), or to install portions of the program (a Custom Install). For example, you may choose not to install certain features in order to save disk space.
- An Easy Install installs FileMaker Pro in the language matching your operating system. You can install additional language versions by choosing Custom install, then selecting other language packs from the list of supported languages.
- Prior to an upgrade installation or software update, FileMaker software scans all hard drives and volumes connected to your system searching for previous versions. This scan may take several minutes if you have multiple drives or volumes.
Installing FileMaker Pro

You must use the installation program to install FileMaker Pro—you can’t install FileMaker Pro by dragging files to your hard disk.

To install FileMaker Pro on your hard disk:

1. Insert the CD into your CD or DVD drive, and open the FileMaker CD window. (If you paid for your software online, skip this step.)

2. Locate and double-click the FileMaker Pro 9 installer icon.

3. When prompted, type your Mac OS administrator user name and password.

4. Install FileMaker Pro by following the on-screen instructions.

5. Click Quit to leave the Installer.

When installation completes, you see a Product Registration dialog box.

Where files are stored on your hard disk

The FileMaker Pro installer copies files to several folders on your hard disk, depending on the installation options you choose and your operating system. When installation is complete, you can view the Installer Log File in the FileMaker Pro 9 folder. The log file lists the location of each installed file. You can view it with TextEdit or a word processing program.

Installing ODBC client drivers in Mac OS X

FileMaker Pro ODBC support allows you to interact with data from other applications, such as Oracle databases, on your computer or over a network. For more information on using ODBC, including links to driver vendors, see www.filemaker.com/support/technologies.
Adjusting the FileMaker Pro cache

Because Mac OS X dynamically allocates memory to applications as needed, there is no way to set a specific amount of memory to allocate to the FileMaker Pro application. However, you can adjust the FileMaker Pro cache size.

You may want to increase the cache size if you plan to do any of the following:

- work on a large database file
- work on several database files at once
- host database files
- use a database file that contains many graphics
- insert a large graphic into a database file

Consider decreasing the cache size if you plan to run several applications at the same time and you have a limited amount of memory (RAM) installed.

To change the cache size that FileMaker Pro uses:

1. In FileMaker Pro, choose the FileMaker Pro menu > Preferences and click the Memory tab.

2. Type a number in the Attempt to set file cache size to box, then click OK.

The next time you start FileMaker Pro, the new cache size is used.
Where to go from here

After you install FileMaker Pro, you can immediately begin working with the application. Here are some suggestions on where to go in the documentation to get started:

- If you’re new to databases, read chapter 2, “Using databases” and chapter 3, “Creating databases” in the *FileMaker Pro User’s Guide* to learn basic database concepts.

- If you’re new to FileMaker Pro, work through the lessons in the *FileMaker Pro Tutorial*. The tutorial PDF file and sample file are located in the Tutorial folder inside the English Extras folder.

- If you’ve used FileMaker Pro before, read chapter 4, “New features” in this guide for an overview of new features available in FileMaker Pro 9 and FileMaker Pro 9 Advanced.

- If you’re a FileMaker Pro 9 Advanced user, see the *FileMaker Pro Advanced Development Guide* and FileMaker Pro Help.
Chapter 4
New features

This chapter provides you with an overview of the new features and improvements in FileMaker Pro 9 and FileMaker Pro 9 Advanced. Unless otherwise noted, please see FileMaker Pro Help for more information on these features.

New features in FileMaker Pro 9

Sharing and collaboration

- Support for external SQL (ODBC) data sources — Display, access, and use data from SQL tables. For example, you can add a table from an external SQL database to the FileMaker Pro relationships graph.

- Supplemental fields — Add unstored calculation fields and summary fields to SQL (ODBC) data source tables within FileMaker Pro. Then use these fields in FileMaker Pro layouts, scripts, finds, sorts, joins, and exports, without changing data from an external table. This feature lets you extend SQL tables. For example, you can use supplemental fields to display aggregated data from an external file as you would use summary fields to display aggregated data stored in FileMaker Pro files.

- Email links to shared databases — Choose the new File menu > Send Link menu item to send an email with URL links to FileMaker Pro shared databases. Use this feature with shared peer-to-peer or FileMaker Server hosted databases.

- Increased number of peer-to-peer file sharing users — Share files with up to 9 concurrent users with FileMaker Pro Network Sharing.
New features

**Reporting and analysis**
- Conditional formatting — Set formatting rules based on conditions you specify with the new Format menu > Conditional menu item, and apply conditional formats to data in fields, layouts, or text-based buttons. For example, you can display past-due invoices in red.
- Append to PDF — Append new data to an existing PDF file with this new script step option. For example, add incremental data to a report saved as a PDF file.
- Updated label support — Use new and updated Avery label sizes in the New Layout/Report assistant, including new, popular shipping labels.

**Usability improvements**
- New FileMaker Pro Quick Start Screen — Start using and learning about FileMaker Pro with this new dialog box. The FileMaker Quick Start Screen provides a central place where you can create files, open existing files located on your computer or on remote networked computers, and access electronic FileMaker Pro documentation.
- Online update notification — Receive notification when software updates are available over the internet. (For more information, see “Update notification” on page 6.)
- Auto-resize layout objects — Specify how layout objects dynamically adjust to window resizing. As you resize windows, data contracts or expands on a form, in Preview mode, and in printing.
- Enhanced tab panel control — Use new tab control setup features to set the default tab and tab width on a form.
- Improved web viewer — View and set options for status and messages in the new progress bar area.
- Learn buttons — Link directly to context-sensitive Help topics from these dialog boxes to learn more about using them: Web Viewer Setup, Button Setup, Specify Calculation, and Create Layout/Report.
- Enhanced Help menu — Access product documentation, register or activate FileMaker Pro, transfer activation to another computer, send FileMaker your feedback, and more from the Help menu.
Revised File menu — The File menu > Define menu item is now the File menu > Manage menu item, and the Manage dialog boxes replace the Define dialog boxes. For example, to add fields to a database, use the Manage Database dialog box.

Improved Undo/Redo — Undo or redo editing multiple times in the active field or layout text object.

Improved spell checking — Control visual spell checking for individual fields.

Enhanced toolbar — Use new and improved buttons on the toolbar, including Alignment (Layout mode), Save Records as Excel, and Save Records as PDF.

Scripting
Multiple script editing windows — Open multiple edit script windows at one time.

Script organization features — Create groups and filters to manage numerous scripts and search for scripts.

Copy and paste scripts — Copy entire scripts and script steps from one file and paste them into the same or a different file.

Functions and script steps
Get(HostApplicationVersion) function — Returns the version of FileMaker Pro or FileMaker Server running on the computer that is hosting the current database.

Get(TemporaryPath) function — Returns the path to the temporary folder that FileMaker Pro uses on the current user’s computer.

Self function — Returns the content of the object in which the calculation is defined.

Acos function — Returns the arccosine, or inverse cosine, of a number.

Asin function — Returns the arcsine, or inverse sine, of a number.

Undo/Redo script step — Reverses, restores, or switches between the most recently performed actions in the file.
New features in FileMaker Pro 9 Advanced

- Enhanced Script Debugger — Debug restricted-access scripts upon login and authentication from within the Script Debugger, select multiple script steps, view last script error results, and link directly to Help for more information with the Script Debugger.

- Enhanced Data Viewer — Use the new Current tab to view field or variable data in the current script, and view restricted data in Data Viewer upon login and authentication.

- PHP Site Assistant link — Choose Tools menu > Launch PHP Assistant to link directly to PHP Site Assistant. (PHP tools are part of the FileMaker Server product. For more information, refer to the FileMaker Server documentation.)

- Enhanced Database Design Report — Document your database solution, including new features such as script groups, external SQL data source tables, new functions, and more. (For more information, see FileMaker Pro Advanced DDR XML Output Grammar, available at www.filemaker.com/downloads.)