# Contents

## Part I  Introduction to Pro Tools

### Chapter 1. Welcome to Pro Tools
- Avid Master Account ................................................. 3
- System Requirements and Compatibility Information ................ 3
- Checking for Software Updates with Avid Application Manager .......... 3
- Conventions Used in Pro Tools Documentation .......................... 4
- Resources ............................................................. 4
- Join the Avid Artist Community ........................................ 5

### Chapter 2. Pro Tools Concepts
- Hard Disk Audio Recording ........................................... 7
- Nonlinear Editing ..................................................... 7
- Audio Engines .......................................................... 8
- Avid Video Engine .................................................... 8
- MIDI ................................................................. 8
- Synchronization ....................................................... 9
- Surround Sound ....................................................... 9
- Pro Tools Sessions .................................................... 9
- Pro Tools Projects ..................................................... 15
- Tick-Based and Sample-Based Time ................................... 16
- System Resources ..................................................... 17
- Workspace Browsers .................................................. 19
- AAF, MXF, and OMF .................................................. 19
- Pro Tools and Media Composer Terminology ............................ 21
- Embedded Media and Linked Media ................................... 22

### Chapter 3. Keyboard and Mouse Shortcuts
- Mouse Shortcuts ...................................................... 25
- Global Key Commands ................................................ 25
- Keyboard Focus ....................................................... 26
Chapter 4. Using Help ................................................................. 31
  Accessing Guides in Pro Tools Software ....................................... 31
  Accessing the Help System ....................................................... 31
  Help Display ............................................................................ 32
  Using the Contents and Index Tabs .............................................. 32
  Using the Search Tab .................................................................. 33
  Search Guidelines ...................................................................... 34
  Copying from a Help Topic ......................................................... 34
  Printing Help Topics .................................................................. 34

Part II System Configuration

Chapter 5. Pro Tools Systems ......................................................... 37
  Pro Tools Software .................................................................... 37
  Pro Tools | Ultimate Software with Pro Tools | HDX Hardware .......... 39
  Pro Tools | Ultimate Software with Pro Tools | HD Native Hardware ... 40
  Supported Pro Tools HD Audio Interfaces .................................... 41
  Playback, Recording, and Voice Limits with Pro Tools | Ultimate Software 42
  Pro Tools HD Audio Interface Features ....................................... 43
  Additional Pro Tools Hardware Options ...................................... 47
  Additional Pro Tools HD Hardware Options ................................ 47
  Pro Tools Software Options ..................................................... 48
  Avid Application Manager ........................................................ 48

Chapter 6. I/O Setup ..................................................................... 49
  Pro Tools Software Signal Paths ............................................... 50
  I/O Setup Pages ....................................................................... 53
  I/O Setup Signal Path Controls ............................................... 56
  I/O Setup Buttons .................................................................... 56
  I/O Setup Options .................................................................... 57
  Customizing I/O Settings ......................................................... 62
  Configuring Hardware in I/O Setup .......................................... 63
  Signal Path Routing for Audio Input ......................................... 65
  Signal Path Routing for Audio Output ....................................... 66
Closing a Session or Project .......................................................... 179
Renaming Projects ........................................................................ 179
Remove Local Cache ..................................................................... 180
Deleting Projects ......................................................................... 180
Restore Project from Cloud .......................................................... 181
Open Revision History ................................................................ 181
Backup to Cloud .......................................................................... 182
Project Collaboration Invitations in the Dashboard ...................... 183
Quitting or Exiting Pro Tools ......................................................... 183

Chapter 12. Pro Tools Main Windows ............................................. 185
Mix Window .................................................................................. 186
Edit Window .................................................................................. 188
Transport Window ........................................................................ 194
MIDI Editor Windows ................................................................... 198
Score Editor Window ..................................................................... 199
Workspace Browsers ..................................................................... 199
Task Manager Window ................................................................... 200
Artist Chat Window ....................................................................... 200
In-Application Web Browser .......................................................... 200
Managing Windows ....................................................................... 203
How Window Configurations Work ............................................. 206
Window Configuration Commands and Options ....................... 208
Menus .............................................................................................. 210
Tool Tips ........................................................................................ 212

Chapter 13. Tracks ....................................................................... 213
Track Types .................................................................................... 213
Track Channel Strips in the Mix Window .................................... 215
Track Controls and Indicators in the Edit Window ..................... 219
Edit Window Views ....................................................................... 221
Track Level Meters ....................................................................... 224
Adjusting Track Width ................................................................. 230
Creating Tracks ............................................................................. 230
Track Views .................................................................................... 236
Setting Track Views in the Edit Window .................................... 238
Track Height ................................................................................... 240
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tracks List</td>
<td>242</td>
</tr>
<tr>
<td>Track Name Right-Click Menu</td>
<td>245</td>
</tr>
<tr>
<td>Assigning Audio Inputs and Outputs to Tracks</td>
<td>246</td>
</tr>
<tr>
<td>Track Priority and Voice Assignment</td>
<td>252</td>
</tr>
<tr>
<td>Assigning MIDI Inputs and Outputs to Tracks</td>
<td>254</td>
</tr>
<tr>
<td>Soloing and Muting Tracks</td>
<td>256</td>
</tr>
<tr>
<td>Making Tracks Inactive</td>
<td>259</td>
</tr>
<tr>
<td>Color Coding for Tracks, Clips, Markers, and Groups</td>
<td>259</td>
</tr>
<tr>
<td><strong>Chapter 14. Track Presets</strong></td>
<td>263</td>
</tr>
<tr>
<td>Creating and Saving Track Presets</td>
<td>263</td>
</tr>
<tr>
<td>Creating New Tracks from Track Presets</td>
<td>268</td>
</tr>
<tr>
<td>Recalling Inserts from Track Presets</td>
<td>271</td>
</tr>
<tr>
<td>Recalling Track Presets to Sends</td>
<td>272</td>
</tr>
<tr>
<td>Track Presets in Workspace Browsers</td>
<td>273</td>
</tr>
<tr>
<td><strong>Chapter 15. Grouping Tracks</strong></td>
<td>277</td>
</tr>
<tr>
<td>Grouping Tracks</td>
<td>277</td>
</tr>
<tr>
<td>Group Controls</td>
<td>279</td>
</tr>
<tr>
<td>Working with Groups</td>
<td>282</td>
</tr>
<tr>
<td>Setting Group Attributes</td>
<td>284</td>
</tr>
<tr>
<td>Enabling Groups</td>
<td>287</td>
</tr>
<tr>
<td>Grouped Control Offsets</td>
<td>288</td>
</tr>
<tr>
<td><strong>Chapter 16. The Clips List</strong></td>
<td>289</td>
</tr>
<tr>
<td>Clips List Menu</td>
<td>289</td>
</tr>
<tr>
<td>Sorting and Searching in the Clips List</td>
<td>291</td>
</tr>
<tr>
<td>Selecting Clips in the Clips List</td>
<td>293</td>
</tr>
<tr>
<td>Previewing Clips in the Clips List</td>
<td>295</td>
</tr>
<tr>
<td>Stereo and Multichannel Clips in the Clips List</td>
<td>296</td>
</tr>
<tr>
<td>Naming and Displaying Clips in the Clips List</td>
<td>296</td>
</tr>
<tr>
<td>Managing Clips in the Clips List</td>
<td>299</td>
</tr>
<tr>
<td>Clip Name Right-Click Commands</td>
<td>300</td>
</tr>
<tr>
<td>Batch Renaming</td>
<td>301</td>
</tr>
<tr>
<td><strong>Chapter 17. Workspace Browsers</strong></td>
<td>307</td>
</tr>
<tr>
<td>Performance and Transfer Volumes</td>
<td>308</td>
</tr>
<tr>
<td>Databases</td>
<td>309</td>
</tr>
</tbody>
</table>
Workspace Browser Layout and Tools .................................................... 310
Working with Items in Workspace Browsers ........................................ 313
Indexing Workspace Databases ......................................................... 314
Workspace Browser Menu ................................................................. 315
Workspace Right-Click Menu ............................................................... 316
Workspace Browser Panes and Display ............................................... 318
Column Data ..................................................................................... 320
Selecting Items .................................................................................. 323
Moving, Copying, Duplicating, and Removing Items. ............................ 323
Set Column Metadata Values for Multiple Selected Files in Workspace Browsers .................................................. 324
Searching Items. ............................................................................... 325
Soundbase and Tags. .......................................................................... 331
Searching Based on Tags .................................................................... 333
Adding and Editing Tags ..................................................................... 335
Waveforms ......................................................................................... 337
Elastic Audio Files in the Workspace. .................................................. 338
Previewing Audio in Workspace Browsers .......................................... 339
Preview Controls and Indicators ......................................................... 340
Preview Modes .................................................................................. 342
Linking and Relinking Files ................................................................ 344
Transfer Files .................................................................................... 345
Missing Files ..................................................................................... 345
Relink Window. ................................................................................ 347
Catalogs .............................................................................................. 351
Task Manager Window. ....................................................................... 354

Chapter 18. Artist Chat Window .......................................................... 359
Profile Setup ....................................................................................... 360
Contacts ............................................................................................. 361
Notifications. ................................................................................... 362
History ................................................................................................. 363
Projects ............................................................................................... 363
Chat ..................................................................................................... 366
Filtering Chat and Project Messages. ................................................... 370
Editing Chat or Project Messages ........................................................ 370
Emoticon and Notations Panel ............................................................ 371
Pinning or Unpinning Items in the Projects and Chat Lists ................. 372
Leaving a Project or Group Chat ................................................................. 372
Move to or Restore from Artist Chat History .............................................. 373
Remaining Signed In to your Avid Account Offline ...................................... 373
Availability for Participation ........................................................................ 375

Chapter 19. Track Collaboration .................................................................... 377
Sharing Projects and Collaborating ................................................................. 377
What is Shared? ............................................................................................... 377
What is Not Shared? ....................................................................................... 379
Project Ownership .......................................................................................... 379
Start Collaboration .......................................................................................... 379
Track Collaboration Tools in the Edit Window ............................................... 379
Track Collaboration Tools in the Transport Window ........................................ 380
Global Track Collaboration Tools .................................................................... 380
Track Collaboration Track View in the Edit and Mix Windows ...................... 383
Track Collaboration Controls .......................................................................... 384
Track Ownership ............................................................................................. 387
Conflicts Between Track Changes and the Cloud ......................................... 390
Track Cloud Synchronization Indicator in the Tracks List .............................. 391
Conductor Ruler Collaboration Controls ......................................................... 392

Chapter 20. Importing and Exporting Session Data .......................................... 397
Importing and Exporting Data to and from a Session or Project .................... 397
Audio Conversion on Import .......................................................................... 398
Importing Files with Drag and Drop ............................................................... 400
Importing Audio Files and Clips Using the Import Audio Command .......... 403
Importing Audio from Audio CDs .................................................................. 405
Importing ACID and REX Files ..................................................................... 406
Importing Multichannel Audio Files from a Field Recorder ....................... 407
Import Options and Preferences .................................................................... 408
Exporting Audio ............................................................................................. 410
Importing MIDI Files ...................................................................................... 412
Exporting MIDI Files ...................................................................................... 414
Exporting Sibelius Files .................................................................................. 416
Importing Session Data .................................................................................. 416
Import Session Data Dialog ........................................................................... 419
Importing AAF and OMF Sequences ............................................................... 426
# Chapter 23. Record Setup

- Record Setup Overview
- Configuring Pro Tools Hardware I/O for Recording
- Connecting a Sound Source
- Recording with a Click
- Setting the Session Meter and Tempo
- Record Modes
- Configuring Default Names for Audio Files and Clips
- Assigning Hardware I/O on a Track
- Record Enabling Tracks
- Working with Hard Drives for Recording
- Selecting a Record Input Monitoring Mode
- Setting Monitor Levels for Record and Playback
- Reducing Monitoring Latency

# Chapter 24. Audio Recording

- Recording Shortcuts
- Prime for Record Mode
- Setting Punch and Loop Points
- Setting Pre- and Post-Roll
- Audio Punch Recording Over a Specified Range
- Recording Additional Takes
- Loop Recording Audio
- Alternate Takes
- Recording from a Digital Source
- Half-Speed Recording

# Chapter 25. MIDI Recording

- Recording from MIDI Devices
- Enabling Input Devices
- MIDI Thru
- MIDI Input Filter
- Input Quantize
- Wait for Note
- MIDI Merge/Replace
- Configuring MIDI or Instrument Tracks for Recording
- Recording MIDI and Instrument Tracks
Chapter 29. Making Selections

 Linking or Unlinking Timeline and Edit Selections .......................... 629
 Linking or Unlinking Track and Edit Selections .............................. 631
 Selecting Track Material .................................................. 631
 Timeline Selections .................................................................. 642
 Auto-Scrolling Tracks in the Mix and Edit Windows ..................... 645
 Universe View ................................................................. 646
 Navigating a Pro Tools Session with Keyboard Shortcuts ............ 648

Chapter 30. Editing Clips and Selections

 Creating New Clips ........................................................... 653
 Healing Separated Clips ...................................................... 656
 Trimming Clips ................................................................. 657
 Nudging Clips ...................................................................... 659
 Layered Editing ................................................................. 662
 Quantizing Clips to Grid ....................................................... 663
 Editing Stereo and Multichannel Tracks ................................. 664
Consolidating Clips .......................................................... 665
Compacting an Audio File .................................................. 665
Processing Audio with AudioSuite Plug-Ins .............................. 666
TCE (Time Compression and Expansion) Edit To Timeline Selection ........................................................................... 666
Rating Clips ........................................................................ 667

Chapter 31. Fades and Crossfades ............................................. 669
About Crossfades and Curves .................................................. 669
Fade Dialogs ....................................................................... 671
Fade and Crossfade Preferences .............................................. 676
Fade Presets ....................................................................... 676
Creating Fades at the Beginnings and Ends of Clips .................. 677
Creating a Crossfade ............................................................ 679
Using AutoFades ................................................................. 680
Creating Fades and Crossfades in Batches ............................... 681
Manually Adjusting Fade Shapes in Fade Windows ................ 682
Adjusting the Start and End Points of a Crossfade .................. 682
Adjusting Fade Shapes with the Smart Tool in the Edit Window ........................................................................... 683
Changing Fade Shapes in the Edit Window .............................. 684
Fades Options in the Edit Selection Right-Click Menu .......... 684
Moving and Nudging Fades and Crossfades ......................... 685
Separating Clips that Include Fades or Crossfades ................. 687
Trimming Clips that Include Fades or Crossfades ................... 688
Fade Boundaries and Shapes Displayed in Automation View .... 689

Chapter 32. Playlists ............................................................... 691
Working with Playlists ........................................................ 691
Track Compositing ................................................................ 694
Playlists View ..................................................................... 697
Matching Alternate Clips ....................................................... 704
Matching Criteria Options .................................................... 705
Selecting Alternate Takes on Tracks ...................................... 706
Automatically Create New Playlists when Loop Recording .... 707
Expanding Alternate Takes to New Playlists or Tracks .......... 708
Expanding Alternate Channels to New Playlists or Tracks .... 709
Target Playlist .................................................................... 711
Track Compositing Keyboard Shortcuts ................................. 717
Chapter 33. Beat Detective ................................................................. 719
  Beat Detective and Source Material .......................................... 719
  Uses for Beat Detective ............................................................ 719
  Beat Detective Requirements .................................................. 720
  The Beat Detective Window ................................................... 721
  Beat Detective Modes ............................................................. 721
  Defining a Beat Detective Selection ......................................... 722
  Beat Detective Analysis .......................................................... 723
  Calculating Tempo with Beat Detective .................................... 724
  Generating Beat Triggers .......................................................... 724
  Editing Beat Triggers ............................................................... 728
  Generating Bar|Beat Markers with Beat Detective ....................... 730
  DigiGroove Templates ............................................................ 731
  Separating Clips with Beat Detective ....................................... 733
  Conforming Clips with Beat Detective ..................................... 734
  Edit Smoothing ........................................................................ 737
  Detection (Normal) and Collection Mode .................................... 739

Part VI MIDI

Chapter 34. MIDI Editing ............................................................. 745
  MIDI Editing Options ............................................................... 745
  Setting the Grid Value .............................................................. 747
  Using the Pencil Tool ............................................................... 748
  Inserting MIDI Notes .............................................................. 750
  Inserting a Series of Notes ....................................................... 751
  Manually Editing MIDI Notes .................................................. 752
  Using the Grabber Tools .......................................................... 755
  Time Compression/Expansion Trim Tool Functionality on MIDI Clips ........................................................................ 762
  Continuous Controller Events ................................................... 764
  Keyboard Shortcuts for Navigating MIDI .................................... 767
  Patch Select (Program and Bank Changes) .................................. 772
  System Exclusive Events .......................................................... 776
  Note and Controller Chasing .................................................... 777
  Offseting MIDI Tracks .............................................................. 778
  Stuck Notes ............................................................................ 780
Remove Duplicate Notes ................................................................. 780
MIDI Real-Time Properties .......................................................... 780
Real-Time Properties Settings ....................................................... 782
Real-Time Properties on Tracks and Clips. ...................................... 784
Writing Real-Time Properties to Tracks or Clips. ............................... 785
Real-Time Properties In the MIDI Event List .................................... 786
Display of Real-Time Properties Effects ......................................... 786

Chapter 35. MIDI Editors .......................................................... 787
Opening a MIDI Editor Window ..................................................... 788
MIDI Editor Window Toolbar ........................................................ 789
MIDI Editor Zoom Controls .......................................................... 795
Tracks List ............................................................................. 795
Groups List ............................................................................ 797
Timebase and Conductor Rulers ..................................................... 797
Superimposed Notes View ............................................................. 798
Notes Pane Right-Click Menu ......................................................... 801
Notation View ........................................................................ 802
Velocity, Controller, and Automation Lanes ..................................... 804

Chapter 36. Score Editor ........................................................... 805
Opening the Score Editor Window .................................................. 806
Edit Tools ............................................................................ 806
Default Note Duration ................................................................ 809
Default Note On Velocity ............................................................... 809
Play MIDI Notes When Editing ....................................................... 809
Link Timeline and Edit Selection .................................................... 809
Mirrored MIDI Editing ................................................................ 810
Double Bar ............................................................................. 810
Cursor Location ......................................................................... 810
Grid ....................................................................................... 811
Score Editor Window Target ........................................................ 811
Score Editor Window Menu .......................................................... 812
Tracks List .............................................................................. 813
Page Controls ........................................................................ 814
Score Editor Zoom Controls .......................................................... 815
Notation Display Track Settings .................................................... 816
Score Setup ................................................................. 817
Editing Notes ............................................................... 819
Score Editor Right-Click Menu ................................... 822
Key Changes ................................................................. 823
Meter Changes ............................................................... 824
Chord Symbols and Diagrams ..................................... 824
Exporting Scores .......................................................... 826
Printing Scores .............................................................. 826

Chapter 37. MIDI Event List .......................................... 827
Opening the MIDI Event List ........................................ 827
Inserting Events in the MIDI Event List ...................... 830
Editing Events in the MIDI Event List ......................... 832
MIDI Event List Options ............................................... 834

Part VII Arranging

Chapter 38. Time, Tempo, Meter, Key, and Chords .......... 837
Timebase Rulers and Conductor Rulers ...................... 837
Main Time Scale .......................................................... 839
The Sub Counter ............................................................ 840
Tick-Based Timing .......................................................... 841
Tick- and Sample-Based Timebases ......................... 841
Song Start Marker .......................................................... 843
Tempo ............................................................................. 844
Graphic Tempo Editor .................................................. 850
Editing Tempo Events in the Tempo Editor ............... 851
Changing the Linearity Display Mode ....................... 856
Tempo Operations Window ......................................... 857
Identify Beat Command ............................................... 863
Meter Events ................................................................. 866
Time Operations ............................................................. 868
Change Meter ................................................................. 868
Insert Time ..................................................................... 870
Cut Time ....................................................................... 871
Move Song Start ............................................................ 872
Renumbering Bars .......................................................... 873
Chapter 41. Clip Loops and Groups ................................................................. 915
  Clip Looping .......................................................... 915
  Creating Looped Clips ................................................. 916
  Unlooping Clips ....................................................... 917
  Editing looped Clips .................................................. 917
  Clip Groups ........................................................... 919
  Creating Clip Groups ............................................... 920
  Ungrouping Clips .................................................... 921
  Regrouping Clips .................................................... 921
  Multitrack Clip Groups ............................................. 921
  Clip Groups on Tick-Based Tracks ................................. 923
  Editing Clip Groups ................................................. 924
  Fades and Crossfades on Clip Groups ......................... 925
  Clip Groups and Clip Gain ....................................... 926
  Importing and Exporting Clip Group Files ..................... 926

Part VIII          Processing

Chapter 42. AudioSuite Processing ......................................................... 929
  AudioSuite Menu ..................................................... 929
  AudioSuite Window ................................................... 929
  AudioSuite Window Header ........................................ 930
  AudioSuite Window Footer ....................................... 934
  Using AudioSuite Plug-Ins ...................................... 936
  Conditions for AudioSuite Rendering with Handles, Fades, Clip Gain, and Metadata .... 939

Chapter 43. Clip Gain and Clip Effects ................................................. 941
  Clip Gain .......................................................... 941
  Clip Effects ......................................................... 949
  Clip Effects Settings .............................................. 955
  Clip Effects Presets and Settings Files ....................... 962

Chapter 44. Elastic Audio ................................................................. 965
  Example Elastic Audio Workflow .................................. 966
  Elastic Audio Tracks ................................................. 970
  Disabling Elastic Audio Tracks .................................. 971
  Elastic Audio Track Controls ..................................... 972
Chapter 47. HEAT ................................................................. 1031
    Enabling HEAT .......................................................... 1031
    About HEAT Processing .............................................. 1031
    HEAT Controls .......................................................... 1033
    Master Bypass and Track Bypass Indicators. .................. 1034
    A Note About Other Track Types .................................. 1035
    DSP and Voice Requirements ...................................... 1035
    Using HEAT with a Control Surface ............................... 1036

Part IX  Mixing

Chapter 48. Basic Mixing .................................................. 1041
    Mixing Concepts ....................................................... 1041
    Metering and Calibration ........................................... 1041
    Signal Flow by Track Type. ........................................ 1042
    Audio Tracks and Signal Flow ...................................... 1042
    Auxiliary Input Tracks and Signal Flow ......................... 1043
    Master Fader Tracks and Signal Flow ............................ 1044
    Instrument Tracks and Signal Flow ............................... 1046
    VCA Master Tracks ................................................... 1047
    Inserts ................................................................. 1050
    Configuring Inserts View in the Mix and Edit Windows. .... 1050
    HEAT ................................................................. 1051
    Stereo Pan Depth ..................................................... 1051
    Views in the Mix and Edit Windows ............................... 1052
    Audio Input and Output Paths ...................................... 1056
    Sends ................................................................. 1058
    Configuring Sends View in the Mix and Edit Windows ......... 1064
    Sends View Options .................................................. 1064
    Editing Sends in the Mix and Edit Windows (Individual Send Views) ............................... 1066
    Bus Interrogation Options ......................................... 1069
    Output Windows for Tracks and Sends ........................... 1070
    Output Meters ........................................................ 1073
    Signal Routing for Monitoring and Submixing .................. 1074
    Delay Compensation ................................................ 1082
    Dither ............................................................... 1089
Chapter 51. Mixdown................................................................. 1185
Selecting Audio for Loops, Submixes, and Effects..................... 1185
Using Dither ........................................................................ 1186
Bus Recording to Tracks ......................................................... 1187
Bounce to Disk ..................................................................... 1188
Bounce From Sends or Track Outputs ........................................ 1189
Bounce Options .................................................................... 1190
Recording a Submix (with Bounce to Disk) .............................. 1197
Final Mixdown (with Bounce to Disk) ....................................... 1197
Mastering ............................................................................. 1198

Part X    Surround

Chapter 52. Pro Tools Setup for Surround ................................. 1201
Surround Mixing in Pro Tools .................................................. 1201
Pro Tools Audio Connections for 5.1 Mixing ............................ 1201
7.1 and 7.0 Formats ................................................................ 1202
7.1.2 and 7.0.2 Formats ................................................................. 1202
Ambisonics Formats ................................................................. 1203
Configuring Pro Tools for Multichannel Sessions .......................... 1203
Default I/O Selectors in I/O Setup ................................................. 1208
5.1 Track Layouts, Routing, and Metering ...................................... 1209

Chapter 53. Multichannel Tracks and Signal Routing ....................... 1211
Multichannel Audio Tracks .......................................................... 1211
Multichannel Signal Routing ....................................................... 1214
Paths in Surround Mixes ............................................................ 1217
Example Paths and Signal Routing for a Surround Mix .................. 1219

Chapter 54. Surround Panning and Mixing ..................................... 1225
Introduction to Pro Tools Surround Panning ................................. 1225
Output Windows ......................................................................... 1226
Standard Controls ....................................................................... 1227
Surround Panner Controls ............................................................. 1228
Panning Modes ........................................................................... 1230
Divergence and Center Percentage ................................................ 1233
LFE Faders in Multichannel Panners ............................................ 1235
Pan Playlists ............................................................................... 1236

Chapter 55. Mixing to Dolby Atmos ................................................ 1237
Dolby Atmos Overview ................................................................. 1237
Installing and Configuring Dolby Atmos Software and Hardware .... 1238
7.0.2 and 7.1.2 Surround Formats in Pro Tools ............................... 1239
Configuring the Network Connection for Pro Tools and a Dolby Atmos Renderer .......................... 1239
Pro Tools Restrictions when Mixing to Dolby Atmos ..................... 1240
Configuring Session Setup for Dolby Atmos ................................. 1241
Configuring the I/O Setup for Dolby Atmos ................................. 1241
Mixing Bed Material .................................................................... 1242
Mapping Busses to Objects ........................................................... 1243
Track Object Output Assignment .................................................. 1245
Monitoring Object Audio when not Connected to a Renderer .......... 1246
Object View in the Edit and Mix Windows ..................................... 1246
Object Controls ........................................................................... 1247
7.0.2, 7.1.2, and Object Panner .................................................... 1249
Object/Bus Toggle Automation ....................................................... 1253
Auto-Height Overrides Height Automation Option .......................... 1253
Coalesce Pan Guide Automation .............................................. 1254
Duplicating Object Track Pan Automation and Dolby Atmos Panner Plug-in Automation . 1254
Object Controls Mix Attribute for Grouped Tracks ....................... 1255
Importing Object-Related Track Data from Another Session ............ 1256
Import ADM files ................................................................. 1256
Dolby Atmos PEC/DIR Recorder Workflow Example .................... 1257

Chapter 56. Ambisonics .......................................................... 1259
Pro Tools Support for Ambisonics ............................................. 1259
What is Ambisonics? ............................................................. 1259
Configuring the I/O Setup for Ambisonics ................................. 1260
Channel Ordering for Ambisonics Audio Signal Paths ................... 1261
Ambisonics Mixes in Pro Tools ................................................. 1262

Part XI   Sync and Video

Chapter 57. Working with Synchronization ................................. 1267
Pro Tools Synchronization Options ......................................... 1267
Session Setup Window ......................................................... 1269
Format Displays and Controls in the Session Setup Window .......... 1270
SYNC Setup and Timecode Offsets in the Session Setup Window .... 1272
Timecode Settings in the Session Setup Window ......................... 1274
Preparing to Work with SMPTE .............................................. 1275
Configuring Pro Tools for SMPTE ........................................... 1275
Pull Up and Pull Down .......................................................... 1277
Effect of Using Pull Up or Pull Down ....................................... 1281
Generating Timecode ........................................................... 1282
Using MIDI Machine Control .................................................. 1283
Enabling MIDI Machine Control in Pro Tools ............................ 1284
MMC Transport Settings ....................................................... 1286
Setting Minimum Sync Delay .................................................. 1286
Remote Track Arming ............................................................ 1287
Spotting Clips to SMPTE Frame Locations ................................. 1287
The Spot Dialog ................................................................. 1288
Capturing Timecode .............................................................. 1289
Auto-Spotting Clips .............................................................. 1290
Chapter 58. MachineControl

MachineControl Requirements ................................................... 1297
Cables and Connections ............................................................ 1298
Connecting Machines ............................................................... 1299
Starting Up Your System .......................................................... 1300
MachineControl Communication Modes .................................... 1301
Setting Up Machine Control ....................................................... 1302
Serial Deck Control Mode ........................................................ 1305
Configuring Serial Deck Control (Overview) ............................ 1305
Configuring a MachineControl Device for Deck Control .......... 1305
Preferences for Serial Deck Control Mode ................................. 1307
Session Setup Window and MachineControl .............................. 1309
Additional Pro Tools MachineControl Commands ...................... 1311
Selecting Pro Tools or the Machine as the Transport Master .... 1313
Playback in Serial Deck Control Mode ....................................... 1314
Remote Track Arming ............................................................... 1315
Configuring Track Arming ........................................................ 1315
Creating a Track Arming Profile ............................................... 1316
Arming Tracks Remotely for Layback ....................................... 1319
Remote 9-Pin Deck Emulation Mode ......................................... 1319
Configuring Remote 9-Pin Deck Emulation Mode ...................... 1320
Preferences for Remote 9-Pin Deck Emulation Mode ................. 1320
Playback in Remote 9-Pin Deck Emulation Mode ....................... 1323
Recording in Remote 9-Pin Deck Emulation Mode ..................... 1323
Track Arming in Remote 9-Pin Deck Emulation Mode ............... 1323
Using a Paddle Device in Local Mode ...................................... 1324
Connecting a Supported Third-Party Paddle Device to Your Pro Tools System ................................................. 1324
Allow Track Arm Commands in Local Mode Preference ............ 1325
Configuring Ports for a Deck and a Supported Third-Party Paddle Device ......................................................... 1325
Deck Control Key Commands .................................................. 1326
Machine IDs ........................................................................... 1327
Chapter 59. Working with Field Recorders in Pro Tools

Field Recorder and Production Workflow Terminology
Supported Field Recorder Audio Files and Metadata
Displaying Field Recorder Metadata in Pro Tools
Workspace Support for Field Recorder Metadata
Field Recorder Workflows
Ensuring Metadata of Source Files Have Been Preserved
Receiving Source Files
Importing Source Files into Pro Tools
Designating Field Recorder Tracks
Displaying Multichannel Files from a Field Recorder in the Clips List
Selecting a Matching Field Recorder Channel to Replace a Clip
Expanding Matching Field Recorder Channels to New Tracks
Determining the Method of Expanding Matching Field Recorder Channels to New Tracks
Film Workflow
Video and Fully Non-Linear Workflows

Chapter 60. Working with Video in Pro Tools

Avid Video Engine (AVE)
QuickTime Movie Support in Pro Tools
Before Starting Your Project
Pro Tools Video Preferences
Video Tracks
Main Video Track
Video Track Controls and Indicators
Video Track Settings
Locking Video Tracks
Video Engine Rate
Importing Video into Pro Tools
Configuring Video Import Options
Importing Audio from a QuickTime Video Clip
Video Clips
Showing or Hiding Video Clips in the Clips List
General Video Editing
Renaming Video Disk Files
# Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Video Clip Groups</td>
<td>1374</td>
</tr>
<tr>
<td>Using the Video Window</td>
<td>1375</td>
</tr>
<tr>
<td>Browsing Video in the Video Universe Window</td>
<td>1377</td>
</tr>
<tr>
<td>Playback of High-Definition Video</td>
<td>1379</td>
</tr>
<tr>
<td>Optimized Video Playback</td>
<td>1379</td>
</tr>
<tr>
<td>Tips for Optimizing Video Playback</td>
<td>1380</td>
</tr>
<tr>
<td>Compensating for Video Monitoring Delays</td>
<td>1380</td>
</tr>
<tr>
<td>Playing Video to an External Monitor Using a Video Peripheral</td>
<td>1381</td>
</tr>
<tr>
<td>Bouncing the Video Track to a QuickTime Movie</td>
<td>1381</td>
</tr>
</tbody>
</table>

## Part XII Satellite Systems

### Chapter 61. Satellite Link

- Satellite Link Requirements and Compatibility                         | 1387 |
- Configuring Satellite Link                                            | 1388 |
- Linking Satellite Systems                                             | 1390 |
- Using Satellite Link with MachineControl                              | 1394 |
- Control Surface Support for Satellite Link                            | 1395 |

### Chapter 62. Pro Tools Video Satellite

- Video Output Options                                                  | 1397 |
- Connecting a Pro Tools Video Satellite System                         | 1397 |
- Linking the Pro Tools Video Satellite System                         | 1398 |

### Chapter 63. Avid Video Satellite

- Video Output Options                                                  | 1401 |
- Supported Video Resolutions                                           | 1402 |
- Avid Video Satellite Workflows                                       | 1403 |
- Using a Video Satellite in a MediaCentral | Production Management Environment | 1403 |
- Connecting Pro Tools and a Video Satellite                           | 1403 |
- Matching Media Composer and Pro Tools Settings in a Video Satellite System | 1405 |
- Linking or Unlinking Pro Tools and a Video Satellite                 | 1411 |
- Capturing Audio and Video with a Video Satellite                     | 1413 |
- Re-Digitizing an Existing Sequence                                   | 1414 |
- Digitizing from an EDL                                                | 1414 |
- Laying Back Audio and Video to Tape                                  | 1414 |

**Index**                                                               | 1417 |
Part I: Introduction to Pro Tools
Welcome to Pro Tools®, brought to you by Avid® Technology. Pro Tools Software integrates powerful multitrack digital audio and MIDI sequencing features, giving you everything you need to record, arrange, compose, edit, mix, and master professional quality audio and MIDI for music, video, film, and multimedia.

Avid Master Account

Your Avid Master Account simplifies access to all of your user accounts and entitlements at my.avid.com. To sign up, go to avid.com and click on “Sign In.”

Fill in the required fields located under the “Create Avid Master Account.”

The Master Account is divided into sections. Notice that the Avid Support Center, Download Center and Avid Community need to be linked. Simply choose “Link this account” if you already have an account or choose “Create Account,” fill in the required fields and click Submit.

System Requirements and Compatibility Information

Avid can only assure compatibility and provide support for hardware and software it has tested and approved.

For complete system requirements and a list of qualified computers, operating systems, hard drives, and third-party devices, visit:

www.avid.com/compatibility

Checking for Software Updates with Avid Application Manager

Pro Tools installs the Avid Application Manager, which can check for application and plug-in updates, either automatically or manually. An Internet connection is required to check for updates.

If updates are available for Pro Tools or any plug-ins, Application Manager reports what updates (if any) are available and how important the updates are for your system. You can visit the Avid website to locate, download, and install the appropriate updates for your system.

To manually check for updates:

1. Launch Avid Application Manager.

2. If you are not already logged in, click the Account tab and login to your Avid Master Account.

3. Click the Apps tab to review what updates are available and follow the on-screen instructions.

For more information about the Avid Application Manager, refer to the Avid Application Manager Guide.
Conventions Used in Pro Tools Documentation

Pro Tools documentation uses the following conventions to indicate menu choices, keyboard commands, and mouse commands:

<table>
<thead>
<tr>
<th>Convention</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>File &gt; Save</td>
<td>Choose Save from the File menu</td>
</tr>
<tr>
<td>Control+N</td>
<td>Hold down the Control key and press the N key</td>
</tr>
<tr>
<td>Control-click</td>
<td>Hold down the Control key and click the mouse button</td>
</tr>
<tr>
<td>Right-click</td>
<td>Click with the right mouse button</td>
</tr>
</tbody>
</table>

The names of Commands, Options, and Settings that appear on-screen are in a different font.

The following symbols are used to highlight important information:

💡 User Tips are helpful hints for getting the most from your Pro Tools system.

⚠️ Important Notices include information that could affect your Pro Tools session data or the performance of your Pro Tools system.

⚡️ Shortcuts show you useful keyboard or mouse shortcuts.

🔍 Cross References point to related sections in this guide and other Avid documentation.

Resources

The Avid website (www.avid.com) is your best online source for information to help you get the most out of your Avid system.

Account Activation and Product Registration

Activate your product to access downloads in your Avid account (or quickly create an account if you do not have one). Register your purchase online, download software, updates, documentation, and other resources.

www.avid.com/account

Support and Downloads

Contact Avid Customer Success (technical support), download software updates and the latest online manuals, browse the Compatibility documents for system requirements, search the online Knowledge Base or join the worldwide Avid user community on the User Conference.

www.avid.com/support

Training and Education

Study on your own using courses available online, find out how you can learn in a classroom setting at an Avid-certified training center, or view video tutorials and webinars.

www.avid.com/education

Video Tutorials

The Get Started Fast with Pro Tools series of online videos provide tutorials to help if you are new to Pro Tools. They also provide videos for the experienced user that introduce new features found in the latest versions of Pro Tools.

www.avidblogs.com/get-started-fast-with-pro-tools/
Products and Developers

Learn about Avid products, download demo software, or learn about our Development Partners and their plug-ins, applications, and hardware.

www.avid.com/products

Join the Avid Artist Community

Once you are online and up and running with Pro Tools, join the Avid Artist Community. The Avid Artist Community lets you connect with an extensive network of artists, musicians, producers, and media professionals to share your work and your services, find collaborators, and expand your music and audio opportunities.

Pro Tools integrates seamlessly with the Avid Artist Community.

To connect to the Avid Artist Community from Pro Tools:

1. Choose Marketplace > Artist Community.
2. Click Sign In (if you don’t already have an Avid Master Account, create one).
3. Sign in to your Avid Master Account.
4. Create your portfolio and explore the Artist Community.

Chapter 2: Pro Tools Concepts

Before you begin to use Pro Tools, you may find it helpful to review Pro Tools concepts. These concepts are the foundation of Pro Tools operation and functionality.

**Hard Disk Audio Recording**

Hard disk recording is a *nonlinear* (or random access) medium—you can go immediately to any spot in a recording without having to rewind or fast forward.

This differs from tape-based recording, which is a *linear* medium—where you need to rewind or fast forward to hear a particular spot in a recording. To rearrange or repeat material in a linear system, you need to re-record it, or cut and splice it.

Nonlinear systems have several advantages. You can easily rearrange or repeat parts of a recording by making the hard disk read parts of the recording in a different order or multiple times. In addition, this re-arrangement is *nondestructive*, meaning that the original recorded material is not altered.

**Nonlinear Editing**

Pro Tools is a nonlinear editing system that lets you rearrange and mix recorded material nondestructively. Nonlinear editing simply means that you can cut, copy, paste, move, delete, trim, and otherwise rearrange any audio, MIDI, or video in the Pro Tools Edit window.

Nonlinear editing provides significant advantages over dubbing (re-recording), and cutting and splicing magnetic tape. It gives you the greatest possible flexibility for editing and arranging, and it is all nondestructive and “undoable.” Additionally, with nonlinear editing in Pro Tools, you will never introduce any degradation of audio fidelity as you would with tape.
Audio Engines

Pro Tools can stream audio between the application and your audio hardware using the Avid Audio Engine (Avid audio hardware only), Core Audio (Mac only with third-party audio hardware), or ASIO (Windows only with third-party audio hardware).

Avid Audio Engine

The Avid audio engine (AAE) is a real-time operating system for digital audio recording, playback, and processing with Pro Tools and Avid audio hardware. When you install Pro Tools, AAE is automatically installed on your system. AAE provides the foundation for much of the hard disk recording, digital signal processing, and mix automation required by Pro Tools and other products from Avid and its Development Partners.

Core Audio

Apple’s Core Audio provides audio connectivity between software applications and audio hardware on Mac OS X. Pro Tools software can use audio interfaces with supported Core Audio drivers for playback and recording with up to 32 channels of I/O.

ASIO

Steinberg’s Audio Stream Input/Output (ASIO) provides audio connectivity between software applications and audio hardware on Windows. Pro Tools software can use audio interfaces with supported ASIO drivers for playback and recording with up to 32 channels of I/O.

WASAPI

The Windows Audio Session API (WASAPI) lets client applications manage the flow of audio data between the application and an external audio interface. WASAPI provides benefits similar to those of ASIO. It also allows any single audio application the exclusive access to a specific audio device. (To access the WASAPI Device Settings in Windows Media Center, choose Tools > Options > Audio > Audio Device > Device settings.)

Avid Video Engine

Pro Tools uses the Avid Video Engine (AVE) for real-time digital video playback. AVE is installed automatically with Pro Tools. AVE provides compatibility and interoperability across the full product line of Avid audio and video editing solutions, and provides support for a wide range of Avid HD and SD MXF video formats on Pro Tools video tracks without transcoding (including Avid DNxHD®). AVE also lets you monitor Avid HD and SD MXF, and QuickTime media using a supported Avid video peripheral.

MIDI

MIDI (Musical Instrument Digital Interface) is a communication protocol for musical instruments. This industry standard enables connections between a variety of devices from different manufacturers. Examples of MIDI-compatible equipment include synthesizers, drum machines, MIDI patch bays, effects processors, MIDI interfaces, MIDI control surfaces, and MIDI sequencers.

MIDI devices are equipped with 5-pin DIN connectors, labeled as either IN, OUT, or THRU. The MIDI OUT port transmits messages. The MIDI IN port receives messages. The MIDI THRU outputs whatever is received from the IN port. MIDI devices are connected with MIDI cables that are available at most music stores.

USB and FireWire-compatible MIDI devices send and receive MIDI messages to and from the computer over USB or FireWire.
The MIDI protocol provides 16 channels of MIDI per port. A single MIDI cable can transmit a separate set of messages for each of the 16 channels. These 16 channels can correspond to separate MIDI devices or to multiple channels within a single device (if the device is multitimbral). Each channel can control a different instrument sound.

Pro Tools provides powerful MIDI sequencing capabilities. You can record, enter, edit, and play back MIDI data on Pro Tools Instrument and MIDI tracks. These actions can be done in the Edit window, the MIDI Editor window, the Score Editor window, and the MIDI Event List.

MIDI data in Pro Tools can be anything from MIDI note data (note number, on/off, velocity) to System Exclusive (Sysex) messages. MIDI data can be recorded or played back from both external MIDI devices with a MIDI interface and other MIDI software (such as instrument plug-ins and ReWire client applications).

**Synchronization**

When you are working with multiple time-based systems, such as Pro Tools and an external deck, you want the systems to be synchronized. Synchronization is where one system outputs clock source (such as timecode or MIDI Beat Clock) and another device synchronizes to or follows that clock source so that they work together. Pro Tools can be synchronized to other devices (or other devices can be synchronized to Pro Tools) using SMPTE/EBU timecode or MIDI Timecode.

**Surround Sound**

*(Pro Tools | Ultimate Software Only)*

Surround sound simply means having one or more speakers with discrete audio signals (channels) placed behind the listener in addition to the typical stereo pair.

There are multiple types of surround formats in use (from three-channel LCR to 7.1, which has eight channels).

The most common surround format is 5.1, which refers to having 5 speakers and a sub-woofer (the “.1”). 5.1 is used in movie theaters and home entertainment systems. Additionally, most DVDs are mixed to 5.1. The standard speaker placement for 5.1 for surround monitoring is stereo left and right speakers, and an additional center speaker in front, two more stereo left and right speakers in the rear, and the sub-woofer on the side.

Pro Tools | Ultimate Software supports mixing in surround formats. In Pro Tools, each surround format is considered to be a greater-than-stereo multichannel format.

**Pro Tools Sessions**

When you start a session in Pro Tools, you create a session.

**Session Files**

A session file is the document that Pro Tools creates when you choose File > New Session and configure a new session. Pro Tools can open only one session file at a time. The session file is named with a .ptx (Pro Tools file) extension. Session files contain maps of all elements associated with a project, including audio files, MIDI data, and all your edit and mix information. It is important to realize that a Pro Tools session file does not contain
any media files (audio or video). Instead, it references audio, video, MIDI, and other files. You can make changes to a session and save those changes in a new session file. This lets you create multiple versions of a session or back up your editing and mixing work.

Session file icon

Tracks

Pro Tools tracks are where audio, MIDI, video, and automation data are recorded and edited. Pro Tools tracks also provide audio channels for routing internal busses, and physical inputs and outputs for audio and MIDI.

Pro Tools provides multiple types of tracks: Audio, Auxiliary Input, Master Fader, VCA Master, MIDI, Instrument, and Video.

Audio, MIDI, Instrument, and video track data can be edited into clips or repeated in different locations to create loops, re-arrange sections or entire songs, or to assemble tracks using material from multiple takes.

Auxiliary Input tracks can route internal audio busses or physical inputs to internal busses or physical outputs. Auxiliary Inputs are typically used for audio effects busses, audio throughput (monitoring), and submixing.

Master Fader tracks provide controls for physical audio output channels, including the volume level of your mix, panning, and plug-in inserts.

VCA Master tracks provide control of tracks in a Mix Group that has been assigned to the VCA Master.

Video tracks support QuickTime movies (all Pro Tools systems) and VC-1 video files (Windows only). Additionally, Pro Tools supports Avid video using a the Avid Video Engine (AVE) either natively or with a supported Avid video peripheral. An individual video track can play back only one type of video at a time.

Audio, Auxiliary Input, Master Fader, and Instrument tracks can be mono, stereo, or multichannel (Pro Tools Ultimate only). When creating a new track, select from the list of channel formats supported by your system.

Voices

In Pro Tools, voices are unique, discrete audio streams that can be routed to and from Pro Tools audio tracks, and physical audio outputs and inputs on your Pro Tools audio interfaces. The audio paths to and from Pro Tools software routed to Pro Tools hardware use voices. If you exceed the number of available voices in your system, you have effectively exceeded the available number of audio paths. Voices are allocated dynamically.
Typically, each audio channel for each track in your Pro Tools session uses a single voice. So, for a mono audio track, a single voice is used; for a stereo audio track, two voices are used. When using Punch Recording, two voices are needed for every single audio channel (one for playback and one for recording on punch in and out). In some situations, with Pro Tools | HDX systems, more than one voice may be necessary for a single channel (such as when using host processing on a DSP bus).

On HDX systems, the number of available voices is dependent on the amount of dedicated DSP processing in your system (see “Playback, Recording, and Voice Limits with Pro Tools | Ultimate Software” on page 42).

On all other Pro Tools systems, the full number of available voices for your system may be limited by the host processing power of your computer (see “Pro Tools Capabilities with Different Hardware Configurations” on page 38).

For more information about voicing in Pro Tools, see “Track Priority and Voice Assignment” on page 252.

Media Files

Pro Tools sessions create, import, export, and reference media files. Media files are audio, MIDI, and video files. Audio and video media files are stored separately from the Pro Tools session file. MIDI data is stored in the session file.

Audio Files

When you record audio into a Pro Tools session, audio files are created.

Audio files for each session are stored in a folder named “Audio Files.” Audio files are listed in the Pro Tools Clips List and can appear in an audio track. A section of an audio file can be defined as a clip. See “Clips” on page 11.

MIDI Files

When you record or enter MIDI into a Pro Tools session, all MIDI data is stored in the Pro Tools session file. You can import and export MIDI files to and from Pro Tools sessions, but MIDI recorded or otherwise created in a Pro Tools session does not automatically create new MIDI files.

Video Files

When you record or import video into a Pro Tools session, all video data is stored as the corresponding video file type (such as QuickTime). Video files can be created in (or copied to) the Video Files folder in the session folder. However, in most cases, Pro Tools references video files that have been captured by another application, such as Avid Media Composer® | Software.

Clips

A clip is a segment of audio, MIDI, or video data. A clip could be a drum loop, a guitar riff, a verse of a song, a recording take, a sound effect, some dialog, or an entire sound file. Clips are especially useful for arranging audio and MIDI. A clip can also have associated automation data. In
Pro Tools, clips are created from audio files or MIDI data, and can be arranged in audio and MIDI track playlists. Clips can also be grouped (a “clip of clips”) and looped (repeated).

Playlists

A playlist is a sequence of clips arranged on an audio, MIDI, or video track. Tracks have edit playlists and automation playlists.

On audio tracks, an edit playlist tells the hard disk which audio clips to play in what order. For example, you can have separate audio clips for a song introduction, the first verse, the first chorus, and so on. You can also use the same audio clip to access the same piece of audio multiple times at different locations and not use additional disk space. Different versions of the same original audio can be used in different places and have different effects applied. On MIDI and Instrument tracks, edit playlists can store multiple MIDI sequences (or performances) on a track.

A playlist can be made up of a single clip or many separate clips. It can be made up of similar elements (such as clips from several different takes of a solo), or dissimilar elements (such as several sound effects).

You can create any number of alternate edit playlists for a track. This lets you assemble different versions of performances or edits on a single track and choose between them from the Playlists menu on the track.
Each audio, Auxiliary Input, Instrument, Master Fader, and VCA track also has a single set of automation playlists. Automation playlists can include volume, pan, mute, and each automation-enabled control for the insert and send assignments on that track.

MIDI controller data on Instrument and MIDI tracks is always included as part of the track playlist.

Channels

The term *channel* is used to describe several related components of a Pro Tools system.

The first example of channel refers to a physical input or output of your Pro Tools system. For example, Pro Tools | HD I/O provides up to 16 channels of audio input and output to a HDX or Pro Tools | HD Native system, while the Pro Tools | Mbox® Pro audio interface provides up to eight inputs and eight outputs.

The second use of the term *channel* refers to a channel strip in the Pro Tools Mix window. Each track in a Pro Tools session has a corresponding *channel strip* in the Mix window.

Audio and MIDI channel strips have similar controls, but those controls have slightly different effects. For example, audio, Auxiliary Input, and Instrument track channel strip faders control the output gain to the mix bus for that channel, while MIDI channel strip faders send MIDI volume data (MIDI controller 7) to the selected MIDI instrument.

The term “MIDI channel” also describes a separate aspect of MIDI operation. See “MIDI” on page 8.
Signal Routing

Pro Tools provides software-based mixing and signal routing controls for audio and MIDI. These controls are located in the Mix window. Some of these controls can also be accessed from the Edit window.

A common audio signal routing task is to submix multiple tracks to a single channel strip (such as an Auxiliary Input) for shared processing and level control. The following example shows two audio tracks submixed to a stereo Auxiliary Input.

Signal Routing Options

Signal routing options include the following:

**Track Input and Output (I/O) Controls** The most basic type of signal routing is track input and output. A track needs to have an assigned input path to record audio, and an assigned mapped output path in order to be audible through a hardware output. Signals can also be routed to or from other tracks in Pro Tools (or hardware inputs and outputs) using internal busses.

**Auxiliary Input and Master Fader Tracks** Auxiliary Inputs can be used as returns, submixers, and bus masters. Master Fader tracks are used as bus and output master level controls. Both Auxiliary Input and Master Fader tracks can have plug-in and hardware inserts.

**MIDI Tracks** MIDI tracks are generally used for routing MIDI from internal or external sources to external MIDI devices. MIDI data can also be routed to plug-ins on Auxiliary Inputs or Instrument tracks.

**Instrument Tracks** Instrument tracks are the primary way to route MIDI to an instrument plug-in and then route the plug-in’s sound to outputs, sends and busses, or other inserts. Instrument tracks can also be used to send MIDI to and monitor audio from external MIDI devices.

**Sends** Sends route audio from tracks to hardware outputs, or to internal busses that are in turn routed to other tracks within Pro Tools. MIDI, Master Fader, and VCA Master tracks do not have sends.

**Plug-In and Hardware Inserts** Plug-In processing occurs completely within the Pro Tools system. Hardware inserts use audio interface inputs and outputs for traditional insert routing to and from external effects and other devices. MIDI and VCA Master tracks do not have inserts.
Instrument Plug-Ins Instrument plug-ins are different from processing plug-ins in that they generate audio rather than process the audio signal from a track’s audio input or from hard disk. Instrument plug-ins are typically played by MIDI.

Paths Paths are any routing option in Pro Tools, including internal or external inputs, outputs, busses, and inserts. Pro Tools lets you name these paths, and these path names appear in the Audio Input and Output Path selectors and other menus. For more information, see Chapter 6, “I/O Setup.”

Mixing Formats Sessions can include combinations of mono, stereo, and greater-than-stereo multichannel format tracks, busses, inputs, outputs, and inserts. Greater-than-stereo multichannel formats are supported with Pro Tools Ultimate only.

Grouping and VCA Tracks Tracks can be grouped together for mixing so that their relative mix settings are maintained when changing a mix setting for any track in the group. For example, changing the volume of one track affects the volume of all the other tracks in the group. VCA Master tracks control the relative mix settings for all tracks within the selected group.

Pro Tools Projects Projects are similar to sessions, but projects are cloud enabled. Projects are written to a local project cache that includes all project data and associated media as well as mirrored in your Avid Cloud Account. Offline projects store all media and project data in the local cache only. Online projects are stored in your Avid Cloud Account and mirrored locally (though you can clear the local project cache and have the project and its media stored only in the cloud).

Online projects let you collaborate on a track-by-track basis with anyone in the Avid Artist Community anywhere in the world; or, if you prefer, you can choose your collaborators privately and invite them to join a project by email.

You can only collaborate with projects, never with sessions. Otherwise, projects work just like sessions. Projects have all of the same recording, editing, mixing, and processing capabilities as do sessions (you can save a copy of a session as a project or a project as a session using the Save Copy In command). Throughout this Reference Guide, “sessions” refers to session and projects unless otherwise noted.

Project data and media are bundled and cached on local storage, but you cannot open a project by navigating through the file system. You can only access projects through the Pro Tools Dashboard. Projects are differentiated from sessions by their file icon.

You must be online and logged in to your Avid Master Account the first time you create a project, but after that you can work offline. Pro Tools and the Avid Application Manager will synchronize your local project with your account the next time you online. This process runs in the background and can be monitored in Pro Tools by checking the Task Manager (Window > Task Manager).

If a project is downloaded on another system when you log in to your Avid Master Account, all associated media is downloaded inside of the project bundle. This does not affect the location of the media on the originating system. Each system maintains its own unique placement of media without duplication.
Tick-Based and Sample-Based Time

Pro Tools lets you set any track timebase to either sample-based or tick-based. You can also set the Timeline to be viewed as tick-based or sample-based.

Audio in Pro Tools is sample-based by default. This means that if an audio clip is located at a particular sample location, it will not move from that location if the tempo changes in the session—though its Bar|Beat location will change.

MIDI data in Pro Tools is tick-based by default. This means that if a MIDI clip is located at a particular Bar|Beat location, it will not move from that Bar|Beat location if the tempo changes in the session—though its sample location will change.

You can select whether a track is sample-based or tick-based when it is created, or change timebases later.

Sample-Based Audio and MIDI

With a sample-based audio track, all clips in the track have an absolute location on the Timeline. Clips stay fixed to the sample time, regardless of where tempo or meter changes occur in a session.

If you make a MIDI track sample-based, all MIDI events in the track have an absolute location on the Timeline. MIDI events stay fixed to sample time, regardless of any tempo or meter changes in a session.

Tick-Based Audio and MIDI

Tick-based audio is fixed to a Bars|Beat location, and moves relative to the sample Timeline when tempo and meter changes occur. However, MIDI events and tick-based audio respond differently to tempo changes with respect to duration. MIDI note events change length when tempo or meter is adjusted, while audio clips do not (unless Elastic Audio is enabled). When Elastic Audio is not enabled on an audio track, meter and tempo changes affect only the start point (or sync point) for each audio clip in a tick-based track. If Elastic Audio is enabled on an audio track, tempo changes apply Elastic Audio processing, which changes the duration of the audio clip.

Elastic Audio

Elastic Audio provides real-time and non-real-time (rendered) Time Compression and Expansion (TCE) of audio. Tick-based Elastic Audio tracks actually change the location of samples according to changes in tempo. The audio stretches or compresses to match changes in tempo. Elastic Audio also provides high-quality non-real-time clip-based pitch shifting.

Pro Tools Elastic Audio uses exceptionally high-quality transient detection algorithms, beat and tempo analysis, and real-time or rendered TCE processing algorithms. Elastic Audio lets you quickly and easily tempo conform and beat match audio to the session’s Tempo ruler. It also provides an unprecedented degree of control over transient detection and TCE processing on an event-by-event basis.
With Elastic Audio, Pro Tools analyzes entire audio files for transient “events.” For example, an event can be a drum hit, a sung note, or chord played by a guitar. These detected events can then serve as control points for “warping” the audio. Pro Tools can warp (TCE) audio events automatically, such as when automatically conforming audio to the session tempo or quantizing audio events, or you can warp audio manually using the standard editing tools with the audio track set to Warp view.

Elastic Audio is useful in several common workflows: working with loops, correcting performances, remixing, beat and pitch matching, and sound design and special effects.

System Resources

Track count, plug-in processing, signal path and routing options, and voice availability are ultimately limited by the combined resources available from the host computer and from your Pro Tools hardware.

Pro Tools provides several ways to manage and conserve resources to maximize the performance of your system. As you begin working with Pro Tools sessions and tracks, you can take advantage of the following features to extend the effectiveness of your available DSP and other resources:

- Pro Tools lets you adjust the performance of your system by changing system settings that affect its capacity for processing, playback, and recording. See “Configuring Pro Tools Software System Settings” on page 90.

- In order to free up needed DSP resources, Pro Tools allows for certain items (such as tracks and inserts) to be manually made inactive. Inactive elements are viewable, editable, and retained within the session. See “Active and Inactive Items” on page 17.

- All Pro Tools systems provide flexible voice options for audio tracks, to help maximize use of available voices in your system. For more information on voice management and options, see “Track Priority and Voice Assignment” on page 252.

Active and Inactive Items

Pro Tools lets you make certain items (such as tracks and inserts) inactive, in order to free up DSP resources and mixer connections.

Items in Pro Tools that can be made inactive include the following:

- Audio, Auxiliary Input, Master Fader, VCA Master, and Instrument tracks
- Track Inputs and Outputs
- Sends
- Side-chain inputs
- Plug-Ins
- Hardware inserts
- Paths (session-wide)

⚠️ MIDI tracks cannot be made inactive.

⚠️ Side-chain inputs support direct active and inactive switching, but do not follow switching all or all selected side-chain inputs.
In addition to manually setting Active and Inactive modes, Pro Tools automatically makes items inactive if there are insufficient or unavailable resources.

When *active*, items are fully engaged and operational.

When *inactive*, items are silent and off, although most associated controls can still be adjusted. Different inactive items affect available system resources in specific ways, as follows:

**Plug-Ins** When a plug-in is inactive on a track, its DSP is made available for other plug-ins and processing. Plug-In assignments can be made inactive manually or automatically.

**Paths and Path Assignments** When a path or path assignment is inactive, its mixer resources are made available for other signal routing purposes in the session. Paths and assignments can be made inactive manually or automatically.

**Tracks** When a track is made inactive, its voices become available for another track. Inactive mono tracks free up one voice; inactive stereo and multi-channel tracks free up one voice per channel. Additionally, when an audio, Auxiliary Input, Instrument, or Master Fader track is made inactive, its plug-ins, inserts, sends, and I/O assignments become inactive, and the associated DSP used is freed up for use elsewhere in the session.

**Display of Inactive Items**

When items are inactive, their names appear in italics, and their background becomes dark gray. When a track is inactive, the entire channel strip is grayed out.
Workspace Browsers

The Workspace is a database management tool for Pro Tools. Workspace browsers expand upon basic Pro Tools search and import capabilities by providing powerful tools to manage your data both inside and outside of your sessions, on any hard drive connected to the system.

A database is a way of organizing data such that it can easily be searched, sorted, managed, and utilized. Your checkbook is an example of a database file. For every check you write, you enter a new record. That record contains information about the check, such as when you wrote it, to whom you wrote it, and for what amount. This information is written in specific columns, or fields. Everything you need to know (the check’s metadata) is there, even though the check itself is not.

Workspace browsers let you search, sort, and manage these databases by volume or catalog. You can use Workspace browsers not only to organize your Pro Tools sessions and media files (audio, MIDI, and video), but also to audition and import by drag and drop.

AAF, MXF, and OMF

Pro Tools lets you exchange audio, video, and sequences with other AAF-, MXF-, and OMF-compatible applications (such as Media Composer).

Media Data (Media Files)

Media data represents raw audio or video material and is stored in individual media files. Every time you record a piece of video or audio material into an application, you are creating a media file. Audio media files hold samples (such as 44,100 or 48,000 samples per second of recording) while video media files use frames (24, 25, or 30 frames per second of recording).

The size of each media file depends on how much audio or video material it contains. For example, a file containing ten minutes of high resolution video might be approximately 2 GB in size, whereas a ten-minute audio recording at the might result in a 100 MB file. Media files tend to be large, since high quality audio and video signals are data intensive. Video data generally requires considerably more storage than audio data.

For more information, see Chapter 17, “Workspace Browsers.”
**Metadata**

Metadata is used to describe the following:

- Information embedded in a media file. This may include scene, take, sample rate, bit depth, external clip names, the name of the videotape from which the media file was captured, and even timecode values.

- Information embedded in Pro Tools sessions or other sequences, including what files are used, where they appear in a timeline, and automation.

- For AAF or OMF sequences, metadata also includes information embedded in unrendered AudioSuite™ effects (such as real-time EQ) for Media Composer. Pro Tools skips unrendered effects on import. Rendered effects are media files that can be imported into Pro Tools.

- For AAF or OMF sequences, information about automation (clip-based gain or keyframe gain).

**AAF, OMF, and MXF Basics**

AAF and OMF files are mechanisms for storing and retrieving media files and metadata so that projects can be freely exchanged between different applications and platforms. MXF is a media file format that can be used with AAF (but not OMF) files.

AAF and OMF sequences can also have media data embedded in them. This creates a single, larger file that is slower to export and import, but which may be easier to manage than thousands of files stored on different volumes.

**AAF**

AAF is a sequence file format. AAF sequences are the best way to exchange projects and maintain valuable metadata. An AAF sequence can refer to OMF or MXF media files, or have OMF and MXF media files embedded within them. There is no such thing as an AAF audio or video media file.

Pro Tools will import, play back, and export an AAF sequence that either links to media files or has audio embedded within it.

When you import an AAF sequence with embedded audio into Pro Tools, the audio will be extracted into mono tracks using the current session’s audio file format.
MXF

MXF is a media file format. There are MXF video files and MXF audio files, but there are no MXF sequences. An AAF sequence may refer to or include MXF media files, but OMF sequences cannot refer to or include MXF files.

Pro Tools can import and play back MXF audio and video files created in Media Composer.

OMF

OMF is both a media file and sequence format. OMF media files can be audio or video, and Pro Tools can import and play back OMF audio, but not OMF video. Pro Tools can also export OMF audio, but not OMF video.

Pro Tools can import and play back OMF audio files created in Media Composer or other applications.

An OMF sequence cannot reference or have MXF media embedded within it.

Pro Tools can import an OMF sequence with embedded audio, but not embedded video.

---

Pro Tools and Media Composer Terminology

Pro Tools and Media Composer use different terms to describe the same items. For example, a Pro Tools *session* is equivalent to a Media Composer *sequence*. The following table lists common Pro Tools elements and their Media Composer equivalents.

<table>
<thead>
<tr>
<th>Pro Tools</th>
<th>Media Composer (AAF or OMF)</th>
</tr>
</thead>
<tbody>
<tr>
<td>session</td>
<td>sequence</td>
</tr>
<tr>
<td>whole file clip</td>
<td>master clip</td>
</tr>
<tr>
<td>clip</td>
<td>subclip</td>
</tr>
<tr>
<td>plug-ins</td>
<td>real-time audio effects</td>
</tr>
<tr>
<td>volume automation</td>
<td>Media Composer key-frame volume</td>
</tr>
<tr>
<td>gain</td>
<td></td>
</tr>
</tbody>
</table>

⚠️ *Whole audio files in the Clips List normally appear in bold type. However, master clip audio files imported from AAF or OMF into Pro Tools will not appear in bold type (indicating clips) in the Pro Tools Clips List even though they are audio files.*
Embedded Media and Linked Media

There are two types of AAF and OMF files: ones with embedded media, and ones with linked media.

Embedded Media

Exporting to AAF or OMF with embedded media results in one large AAF or OMF file containing both the metadata and all associated media files.

AAF/OMF Interchange Workflow with Embedded Media

Sequence (metadata)

Export AAF/OMF with Embedded Media creates...

Embedded AAF/OMF File (metadata and media)

Refers to:

Original Source Media Files

Consolidated Media Files (with Handle)

AAF/OMF Interchange Workflow with Embedded Media
Linked Media

Exporting AAF or OMF with linked media results in a single metadata file (.AAF or .OMF) and all associated media stored as separate files.

The main benefit to this approach is that fewer copies of media files may need to be made, so the export and import process can be much faster. Using this approach, it is less likely that you will encounter any file size limitations since the data is broken up into many smaller files.

The main disadvantage to this approach is that there are potentially many files (for example, one AAF or OMF file and hundreds of media files) that must be transported between systems.

**AAF and OMF Interchange Workflow with Linked Media**
Chapter 3: Keyboard and Mouse Shortcuts

For increased operational speed and ease of use, there are many Pro Tools keyboard and Right-click shortcuts.

A full list of Pro Tools shortcuts is available in online Help and in a PDF guide.

To access the full list of Pro Tools shortcuts in online Help:

2. Click Pro Tools Shortcuts on the Contents page (in the left pane of Help).

To access the full list of Pro Tools shortcuts in the Pro Tools Shortcuts Guide:

- Choose Help > Shortcuts.

---

Global Key Commands

Some keyboard shortcuts apply to many functions in Pro Tools.

For a complete list of keyboard shortcuts, see the Shortcuts Guide.

Track Functions

Pro Tools provides keyboard shortcuts for the following track functions:

- Changing Automation mode
- Enabling playlists
- Adding plug-ins
- Record enabling, soloing, and muting tracks
- Record saffing and solo safing tracks
- Assigning inputs, outputs, and sends
- Toggling volume/peak/delay display
- Clearing meters
- Changing track heights

---

Mouse Shortcuts

Right-Click Shortcuts

Pro Tools provides Right-Click shortcuts for choosing various Pro Tools commands and menus with any Right-Click capable mouse.

For a complete list of Right-Click shortcuts, see the Shortcuts Guide.

Scroll-wheel Functions

Pro Tools lets you increment or decrement values in numerical fields by selecting the value and moving the mouse scroll wheel up or down.
List and Parameter Selection

Pro Tools provides keyboard shortcuts for the following items:

- Selection of tracks in Tracks List
- Enabling of groups in Groups List
- Automation Enable window parameters
- Setting Memory Location parameters

<table>
<thead>
<tr>
<th>Command</th>
<th>Mac</th>
<th>Windows</th>
</tr>
</thead>
<tbody>
<tr>
<td>Apply action to all channel strips/tracks</td>
<td>Option+ action</td>
<td>Alt+ action</td>
</tr>
<tr>
<td>Apply action to selected channel strips/tracks</td>
<td>Option+ Shift+ action</td>
<td>Alt+Shift+ action</td>
</tr>
<tr>
<td>Vertically constrained, fine adjustment for automation and control breakpoints</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Controls and Editing Tools

Pro Tools provides keyboard shortcuts for moving plug-in controls, faders and sliders, the Scrubber, and automation data.

<table>
<thead>
<tr>
<th>Command</th>
<th>Mac</th>
<th>Windows</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fine adjustment of sliders, knobs, and breakpoints</td>
<td>Hold Command while clicking the item</td>
<td>Hold Control while clicking the item</td>
</tr>
<tr>
<td>For extra-fine adjustment of breakpoints in Grid mode</td>
<td>Hold Command +Shift while adjusting automation breakpoints</td>
<td>Hold Control +Shift while adjusting automation breakpoints</td>
</tr>
</tbody>
</table>

Keyboard Focus

The Keyboard Focus in Pro Tools determines how the alpha keys function. Depending on which Keyboard Focus is enabled, you can use the keys on your computer (alpha) keyboard to select clips in the Clips List, enable or disable groups, or perform an edit or play command.

You can only enable one of the three Keyboard Focus modes at a time. Enabling a Keyboard Focus will disable the one previously enabled.

There are three types of Keyboard Focus:

Commands Keyboard Focus When selected in the Tracks pane in the Edit window or in the Notes pane of any MIDI Editor window, this provides a wide range of single key shortcuts from the computer keyboard for editing and playing. The frontmost Edit or MIDI Editor window always receives Commands Keyboard Focus when it is enabled.

With Commands Keyboard Focus disabled, you can still access any of its key shortcuts by pressing the Start key Control (Mac) or (Windows) along with the key. See the Shortcuts Guide for a complete list of Commands Keyboard Focus shortcuts.
Commands Keyboard Focus provides single-key shortcuts for a range of edit and play commands. Avid as well as other vendors supply custom keyboards for Mac and Windows labeled with Pro Tools commands when in Commands Keyboard Focus.

**Clips List Keyboard Focus** When selected, audio clips, MIDI clips, and clip groups can be located and selected in the Clips List by typing the first few letters of the clip’s name.

**Groups List Keyboard Focus** When selected, Mix and Edit Groups can be enabled or disabled by typing the Group ID letter (in either the Mix or Edit window).

To set the Keyboard Focus, do one of the following:
- Click the a–z button for the focus you want to enable.
- While pressing Command+Option (Mac) or Control+Alt (Windows), press one of the following keys: 1 (Commands), 2 (Clips List), or 3 (Groups List).

⚠️ Although multiple plug-in windows can have a keyboard focus enabled, only the front-most window receives any keyboard input.

**Toolbar Focus**

In the Edit window, the MIDI Editor pane can be displayed in addition to the Tracks pane (View > Other Displays > MIDI Editor). When the MIDI Editor pane is displayed, there are two separate Toolbars and Timelines in the Edit window: one for the Tracks pane and one for the MIDI Editor pane. Only one Toolbar and Timeline can be focused for Menu and Toolbar commands (including the corresponding keyboard shortcuts) at a time. The focused Toolbar displays a yellow outline.
If Keyboard Focus for the Edit window is enabled, it follows the selected Toolbar focus.

**To enable Toolbar focus for the Tracks pane, do one of the following:**

- Click the Toolbar at the top of the Edit window.
- Press Command+Option+4 (Mac) or Control+Alt+4 (Windows).

**To enable Toolbar focus for the MIDI Editor pane, do one of the following:**

- Click the Toolbar right above the MIDI Editor pane.
- Press Command+Option+5 (Mac) or Control+Alt+5 (Windows).

---

### Numeric Keypad Modes

The Operation preference for Numeric Keypad mode determines how the numeric keypad functions for Transport.

There are two Shuttle Lock modes (Classic and Transport), and one Shuttle mode.

No matter which Numeric Keypad mode is selected, you can always use the numeric keypad to select and enter values in the Event Edit Area, Edit Selection indicators, Main and Sub Counters, and Transport fields.

**To set the Numeric Keypad Mode:**

1. Choose Setup > Preferences and click the Operation tab.
2. In the Transport section, select a Numeric Keypad mode (Classic, Transport, or Shuttle).
3. Click OK.

---

### Shuttle Lock Modes

There are two Shuttle Lock modes (Classic and Transport). Both modes let you use the numeric keypad to shuttle forward or backwards at specific speeds.

- 5 is normal speed.
- 6–9 provide increasingly greater fast-forward speeds.
- 1–4 provide progressively greater rewind speeds (4 is the slowest, 1 is the fastest).
- Press 0 to stop Shuttle Lock, then press the number to resume Shuttle Lock speed.
- Press Escape or Spacebar to exit Shuttle Lock mode.

### Custom Shuttle Lock Speed

(Pro Tools | Ultimate Software Only)

The highest fast-forward Shuttle Lock speed (key 9) can be customized.

> For more information, see “Custom Shuttle Lock Speed” on page 625.

---

### Classic Mode

This mode emulates the way Pro Tools worked in versions lower than 5.0. With the Numeric Keypad mode set to Classic, you can:

- Play up to two tracks of audio in Shuttle Lock mode. Press the Control key (Mac) or the Start key (Windows), followed by 1–9 for different play speeds.
- Press Plus or Minus to reverse direction.
- Press 0 to stop Shuttle Lock, then press the number to resume Shuttle Lock speed.
- Press Escape or Spacebar to exit Shuttle Lock mode.
- Recall Memory Locations by typing the Memory Location, followed by a Period (.).
Transport Mode

This mode lets you set a number of record and play functions, and also operate the Transport from the numeric keypad.

<table>
<thead>
<tr>
<th>Function</th>
<th>Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Click on/off</td>
<td>7</td>
</tr>
<tr>
<td>Countoff on/off</td>
<td>8</td>
</tr>
<tr>
<td>MIDI Merge/Replace mode</td>
<td>9</td>
</tr>
<tr>
<td>Loop Playback mode on/off</td>
<td>4</td>
</tr>
<tr>
<td>Loop Record mode on/off</td>
<td>5</td>
</tr>
<tr>
<td>QuickPunch mode on/off</td>
<td>6</td>
</tr>
<tr>
<td>Rewind</td>
<td>1</td>
</tr>
<tr>
<td>Fast Forward</td>
<td>2</td>
</tr>
<tr>
<td>Record enable</td>
<td>3</td>
</tr>
<tr>
<td>Play/Stop</td>
<td>0</td>
</tr>
</tbody>
</table>

With the Numeric Keypad mode set to Transport, you can also:

- Play up to two tracks of audio in Shuttle Lock mode. Press the Control key (Mac) or the Start key (Windows), followed by 1–9 for different play speeds.
- Press Plus or Minus to reverse direction.
- Press 0 to stop Shuttle Lock, then press the number to resume Shuttle Lock speed.
- Press Escape or Spacebar to exit Shuttle Lock mode.
- Recall Memory Locations by typing Period (.), the Memory Location number, and Period (.) again.

Shuttle Mode

(Pro Tools | Ultimate Software Only)

Pro Tools offers another form of shuttling, different from that of the two Shuttle Lock modes. With the Numeric Keypad mode set to Shuttle, playback of the current Edit selection is triggered by pressing and holding the keys on the numeric keypad—playback stops once the keys are released. Various playback speeds are available in both forward and reverse. In this mode, pre- and post-roll are ignored.

<table>
<thead>
<tr>
<th>Playback Speeds</th>
<th>Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>1x Forward</td>
<td>6</td>
</tr>
<tr>
<td>1x Rewind</td>
<td>4</td>
</tr>
<tr>
<td>4x Forward</td>
<td>9</td>
</tr>
<tr>
<td>4x Rewind</td>
<td>7</td>
</tr>
<tr>
<td>1/4x Forward</td>
<td>3</td>
</tr>
<tr>
<td>1/4x Rewind</td>
<td>1</td>
</tr>
<tr>
<td>1/2x Forward</td>
<td>5+6</td>
</tr>
<tr>
<td>1/2x Rewind</td>
<td>5+4</td>
</tr>
<tr>
<td>2x Forward</td>
<td>8+9</td>
</tr>
<tr>
<td>2x Rewind</td>
<td>8+7</td>
</tr>
<tr>
<td>1/16x Forward</td>
<td>2+3</td>
</tr>
<tr>
<td>1/16x Rewind</td>
<td>2+1</td>
</tr>
<tr>
<td>Loop Selection (1x)</td>
<td>0</td>
</tr>
</tbody>
</table>

With the Numeric Keypad mode set to Shuttle, you can also recall Memory Locations by typing Period (.), the Memory Location number, and Period (.) again.

⚠ Shuttle Lock modes are not available when the Numeric Keypad mode is set to Shuttle.
Using Help

The Pro Tools Help menu provides quick access to installed PDF documentation and online Help. The Help system is HTML-based and launches in the Pro Tools in-application browser. It also runs on most common web browsers.

The Pro Tools Help menu also provides direct access to the online Pro Tools Knowledge Base, Avid Audio Forums, and the Avid Support Center using the in-application browser (an internet connection is required).

\[ The \text{ Pro Tools in-application Web browser is not available outside Pro Tools. To use Pro Tools Help while Pro Tools is not running, use the default Web browser for your operating system.}\]

Guides Accessible in Pro Tools

The following guides are available from the Pro Tools Help menu:

Audio Plug-Ins Guide Describes the plug-ins included free with Pro Tools, as well as additional plug-ins available for purchase separately.


Pro Tools Shortcuts Lists keyboard and Right-click shortcuts for Pro Tools, including those shown in Pro Tools menus.

Accessing the Help System

There are several ways to access the Help system.

- Open Help at its Welcome page from the Help menu in Pro Tools
- Open Help at its Welcome page from within a Help browser in Pro Tools
- Open Help at its Welcome page outside of Pro Tools
- Open a different version or language of Pro Tools Help

Accessing Guides in Pro Tools Software

PDF (Portable Document Format) versions of the main Pro Tools guides are accessible from the Pro Tools Help menu. Adobe Reader is recommended for PDF documentation.

To access guides in Pro Tools:

- Choose Help, then a guide name.
To open Help within Pro Tools, do one of the following:

- Choose Help > Pro Tools Help.
- From the Pro Tools Online browser window, choose Help.

To open Help outside of Pro Tools (or to select a different version or language of Help):

1. Open your favorite online browser (such as Safari or Explorer).
2. Visit the Pro Tools Help launch page apps.avid.com/ProToolsHelp/
3. Follow the on-screen instructions to open a version of Help.

To close the Help system:

- Click the Help viewer’s Close button.

Help Display

The Help system includes the following display elements:

**Topics**  Help topics open in the right pane of the Help viewer.

**Navigation Tools**  Contents, Index, and Search tabs open in the left pane of the Help viewer.

**Hierarchy Links** Use these links to verify the location of the currently displayed topic within its chapter and to jump to relevant higher-level topics, including the Main Topic.

**Show in Contents Button** Use this button to locate the current topic in the Contents.

**Previous Topic and Next Topic Buttons** Use these buttons to browse through the topics in the order in which they appear in the Contents.

**Print** Click this button to print one or more topics.

Using the Contents and Index Tabs

The left pane of the Help browser is the display area for most of the Help system’s main navigation tools, including the Contents and Index tabs.

Contents Tab

The Contents tab displays a complete hierarchical list of all topics in the Help system. This lets you quickly see the overall organization of the Help system.

You can expand and collapse the contents to view the logical organization of the Help system, and you can move to any topic by clicking its entry in the Contents.

When you move to a new topic, the contents expands to the level of that topic and highlights the topic. This feature, like the hierarchy links at the top of each topic, lets you see exactly where the current topic is positioned within the logical organization of the Help system.

To display a topic from the contents:

- Click the Contents tab, and then click a topic’s entry in the contents.

To expand or close a section in the contents:

- Click the Contents tab, and then click a book icon to the left of a link.
**Index Tab**

The Index provides an alphabetized list of entries similar to the index of a printed book.

If Java is enabled in your browser, the Index displays as a dynamic index where the listing scrolls as you type a word in the text box. If you do not have Java enabled in your browser, or if your browser does not support Java implementations, a JavaScript version of the index displays, which lets you scroll manually through the entries.

**To find topics by using the Index tab:**

1. Click the Index tab.
2. Click the first character of the topic in the Numerics, Letters, Symbols list.

**To view the topic associated with an index entry:**

- Click the index entry.

---

**Using the Search Tab**

The Search tab lets you search the entire text of the Help system for one or more words and then lists the topics that include those words. The list of results is ranked, placing the topics that the Search feature considers most likely to be relevant at the top of the list.

When you search for text, the text string automatically highlights by default. You can turn these highlights off. You can also stop displaying highlights after a search by using the Back and Forward buttons to go to a different topic. When you come back to your searched topic, the highlights no longer display.

For more guidelines on using the Search feature effectively, see “Search Guidelines” on page 34.

**To perform a basic search:**

1. Click the Search tab.
2. In the Search pop-up menu (located below the Search text box), click whether you want to search in “All Available Books” or a specific book (such as Pro Tools Shortcuts).
3. In the Search text box, type the word or words that you want to find.
4. Click Go.

A list of topics and ranking numbers appears.

**Additional Search Information**

The Search feature provides the best combination of usefulness and speed:

- The Search feature uses a database of valid words. This database includes all words that are significant for identifying topics and excludes all other words. When you type words in the search text box, the system ignores any invalid words that you have typed and searches for valid words.

- The Search feature cannot search for words in a certain order. For example, if you type “TIFF graphics import” as a search entry, Search displays all topics that contains these three words regardless of their location in the topic. The results include topics where the three words appear together as a phrase, and also topics where the three words are scattered throughout the topic.

- The Search feature cannot distinguish between words that are similar but not identical. For example, if you type “capture” as a search entry, Search displays topics that include that word, but it does not find topics that include related words such as “captures” or “capturing.” If a search for a word fails to produce useful results, you might be more successful if you search again using one of the related words.
**Search Guidelines**

Use the following rules for formulating search queries:

- Searches are not case-sensitive, so you can type your search in uppercase or lowercase characters.
- You can search for any combination of letters (a–z) and numbers (0–9).
- Punctuation marks (such as the period, colon, semicolon, comma, and hyphen) are ignored during a search, unless they are part of the topic (such as .WAV).
- You can search for a literal phrase by using quotation marks. You cannot search for quotation marks.

**Copying from a Help Topic**

You can copy information from a Help topic for use in another document (such as a text file).

To copy information from a Help topic to another document:

1. Open or click the topic to make it active.
2. Select the text that you want to copy.
3. Choose Edit > Copy.
4. Place the mouse pointer in another application, such as a word processing application.
5. Choose Edit > Paste to paste the copied text into a document. (You can also paste the text into the Search text box.)

**Printing Help Topics**

You can print Help topics if you need to refer to them during a complicated procedure or to use for reference later.

See your browser documentation for more information on print options.

To print a Help topic:

1. Click the topic pane within the browser window that you want to print.
2. Do one of the following:
   - Click the Print button in the Topic pane.
   - Right-click in the Topic pane and select Print.
   - Select File > Print.
3. Select the print options.
4. Click Print.

*Topics that you print from Help have limited page layout and formatting features. If you want to print a higher quality version of Help information, Avid recommends that you print all or part of the PDF version of the appropriate guide.*
Part II: System Configuration
Chapter 5: Pro Tools Systems

There are three types of Pro Tools systems:

**Pro Tools Software with Avid or Third-Party Hardware**

These systems include Pro Tools software with Avid audio hardware (such as Pro Tools | Quartet, Pro Tools | Duet, Pro Tools | Fast Track family, Pro Tools | Mbox® family (third generation), Pro Tools | Eleven® Rack, or Avid 003™ family audio interfaces). These systems also include Pro Tools software using third-party audio interfaces with supported Core Audio (Mac, including the built-in audio on Mac computers), ASIO (Windows), or WASAPI hardware.

**Pro Tools | Ultimate Software with Avid or Third-Party Hardware**

These systems include Pro Tools Ultimate software with any compatible non-HDX or non-HD Native Avid audio interfaces (such as Mbox Pro), or Core Audio (Mac), ASIO (Windows), or WASAPI hardware.

**Pro Tools Software**

Pro Tools software provides the following capabilities, depending on your hardware configuration:

- Up to 32 channels of I/O depending on your system and audio hardware
- Up to a total of 128 mono or stereo audio tracks per session:
  - Playback of up to 128 tracks, or a combination of playing back and recording up to 128 tracks, mono or stereo, at 44.1 kHz and 48 kHz
  - Playback of up to 64 tracks, or a combination of playing back and recording up to 64 tracks, mono tracks or stereo, at 88.2 kHz and 96 kHz
  - Playback of up to 32 tracks, or a combination of playing back and recording up to 32 tracks, mono or stereo, at 176.4 kHz and 192 kHz

For a list of qualified audio interfaces and computers for all Pro Tools systems, visit www.avid.com/compatibility.

Pro Tools | Ultimate software (versions 2018.4 and higher) was previously Pro Tools | HD software (versions 2018.3 and lower).
• Up to 128 Auxiliary Input tracks
• Up to 64 Master Fader tracks
• Up to 512 MIDI tracks
• Up to 512 Instrument tracks
• A single QuickTime video track
• 16-bit, 24-bit, or 32-bit floating point audio resolution, at sample rates up to 192 kHz
• Automatic Delay Compensation (up to 16,383 samples at 48 kHz)
• Fixed RAM Disk Cache allocation options
• Non-destructive, random-access editing and mix automation
• Audio processing with up to 10 real-time plug-ins per track, depending on your computer’s capabilities
• Up to 10 hardware inserts per track
• Up to 10 sends per track

For more information about the I/O capabilities of your audio interface with Pro Tools, see the documentation that came with your audio interface.

Supported Hardware Configurations with Pro Tools Software

Pro Tools Software works seamlessly with non-HD Avid audio hardware (such as Pro Tools | Quartet). For the latest information on supported hardware configurations with Pro Tools Software, visit:

http://www.avid.com/compatibility

Processing Capacity

The total processing capacity of a Pro Tools system depends on the processing power of your computer. Contact your dealer or visit www.avid.com for the latest system requirements and compatibility information.

Pro Tools Capabilities with Different Hardware Configurations

Pro Tools supports up to 32 channels of audio input and output, but the available input and output capabilities with Pro Tools varies depending on your audio interface. For information about the input and output capabilities of your audio interface, refer to the documentation that came with your hardware.

If you open a Pro Tools session created on a Pro Tools HD system that contains more than the number of tracks supported on your Pro Tools system, audio tracks beyond the system’s voiceable track limit will be automatically set to inactive.

For details on transferring session material between Pro Tools HD and Pro Tools systems, see “Sharing Sessions Created on Different Pro Tools Systems” on page 462.
Pro Tools | Ultimate Software with Pro Tools | HDX Hardware

Each system requires at least one Avid HD audio interface (sold separately). HDX systems can be expanded by adding HDX cards to increase track count and the amount of plug-in and mixer processing, and by adding additional audio interfaces.

Pro Tools Ultimate Capabilities with HDX Hardware

Pro Tools Ultimate with HDX hardware provides the following capabilities:

- Up to 256 channels of I/O depending on your system
- Up to a total of 768 voiced audio tracks
- Up to 512 Auxiliary Input tracks
- Up to 64 Master Fader tracks
- Up to 128 VCA Master tracks
- Up to 512 MIDI tracks
- Up to 256 Instrument tracks
- Up to 64 video tracks per session
- 16-bit, 24-bit, or 32-bit floating point audio resolution, at sample rates up to 192 kHz
- Up to 7.1 surround mixing capability
- Automatic Delay Compensation (up to 16,348 samples at 48 kHz)
- Fixed RAM Disk Cache allocation options
- No-latency monitoring
- Non-destructive, random-access editing and mix automation
- Audio processing with up to 10 inserts per track (any combination of real-time plug-in and hardware inserts), depending on your computer’s capabilities
- Up to 10 sends per track

Audio Recording and Playback Capabilities

The number of simultaneous tracks of audio recording or playback depends on your system configuration. A Pro Tools HD system with a single HDX card provides recording and playback of 24-bit or 16-bit audio files with the following voiced track counts:

- Up to 256 tracks at 44.1 kHz or 48 kHz
- Up to 128 tracks at 88.2 kHz or 96 kHz
- Up to 64 tracks at 176.4 kHz or 192 kHz

Each additional HDX card increases the possible track count by the same amount. For example, at 44.1 kHz, two HDX cards provide up to 512 audio tracks, and three HDX cards provide up to 768 audio tracks.
Pro Tools | Ultimate Software with Pro Tools | HD Native Hardware

Each system requires at least one Pro Tools HD audio interface (sold separately). HD Native systems can be expanded by adding additional HD audio interfaces.

Pro Tools HD systems with HD Native hardware consist of the following:

- One of the following:
  - HD Native PCIe card
  - HD Native Thunderbolt interface
- Pro Tools Ultimate
- An authorized iLok for running Pro Tools Ultimate software
- One or more Avid HD audio interfaces (sold separately)
- DigiLink Mini cable for connecting HD Native hardware to an audio interface
- A MIDI interface (optional)

For detailed information about installing HD Native PCIe hardware, see the HD Native Installation Guide.

For information about installing HD Native Thunderbolt hardware, see the HD Native Thunderbolt Guide.

Pro Tools Ultimate Capabilities with HD Native Hardware

Pro Tools Ultimate with HD Native hardware provides the following capabilities:

- Up to 64 channels of I/O depending on your system, and the number and type of installed audio interfaces
- Up to a total of 256 voiced audio tracks (up to 768 voiceable audio tracks):
  - Up to 256 voices at 44.1 kHz or 48 kHz
  - Up to 128 voices at 88.2 kHz or 96 kHz
  - Up to 64 voices at 176.4 kHz or 192 kHz
- Up to 512 Auxiliary Input tracks
- Up to 64 Master Fader tracks
- Up to 128 VCA Master tracks
- Up to 512 MIDI tracks
- Up to 256 Instrument tracks
- Up to 64 video tracks per session
- 16-bit, 24-bit, or 32-bit floating point audio resolution, at sample rates up to 192 kHz
- Non-destructive, random-access editing and mix automation
- Up to 7.1 surround mixing capability
- Automatic Delay Compensation (up to 16,348 samples at 48 kHz)
- Fixed RAM Disk Cache allocation options
- FPGA-based low latency monitoring (LLM)
- Audio processing with up to 10 inserts per track (in any combination of real-time, host-based plug-in and hardware inserts), depending on your computer’s capabilities, and the number and type of installed audio interfaces
- Up to 10 sends per track
Supported Pro Tools HD Audio Interfaces

The following Pro Tools HD audio interfaces are compatible with HDX and HD Native hardware:

- Pro Tools | HD I/O
- Pro Tools | HD OMNI
- Pro Tools | HD MADI
- Pro Tools | MTRX

⚠️ HDX and HD Native systems require at least one HD I/O, HD OMNI, HD MADI, or MTRX.

Maximum I/O Configuration with HDX

HDX supports up to a maximum combination of 12 total of the following audio interfaces:

- HD OMNI (only 1 HD OMNI interface is supported in a single system)
- HD I/O (up to 12 HD I/O interfaces can be used simultaneously—requires 3 HDX cards)
- HD MADI (up to 3 HD MADI interfaces can be used simultaneously—requires 3 HDX cards)
- MTRX (up to 12 MTRX interfaces can be used simultaneously—requires 3 HDX cards)

Maximum I/O Configuration with HD Native

HD Native supports up to a maximum combination of up to 4 total of the following audio interfaces:

- HD OMNI (only 1 HD OMNI interface is supported in a single HD Native system)
- HD I/O (up to 4 HD I/O interfaces can be used simultaneously)
- HD MADI (full connectivity with 1 HD MADI interface is possible when both DigiLink ports of the HD MADI are connected to both DigiLink ports on the HD Native PCIe card or Thunderbolt interface)
- MTRX (up to 4 MTRX interfaces can be used simultaneously)
Playback, Recording, and Voice Limits with Pro Tools | Ultimate Software

The table below lists the audio playback, recording, and voiceable track limits with Pro Tools Ultimate software with HDX, HD Native, Core Audio, and ASIO hardware. *Playback and recording voices* refers to the number of unique simultaneous playback and record tracks on your system. *Total voiceable tracks* refers to the maximum number of audio tracks that can share the available voices on your system. (Mono tracks take up one voice. Stereo and multichannel tracks take up one voice per channel.)

With HDX hardware accelerated systems, voice limits are dependent on the session sample rate and the number of DSP chips dedicated to the system’s Playback Engine. Pro Tools Ultimate can open sessions with up to 768 audio tracks, but any audio tracks beyond that system’s voiceable track limit will be automatically set to Voice Off.

*Pro Tools Ultimate audio playback, recording and voice limits by hardware configuration*

<table>
<thead>
<tr>
<th>Core System Type</th>
<th>Maximum I/O</th>
<th>Sample Rate (kHz)</th>
<th>Playback and Recording Voices (Mono Tracks of Simultaneous Playback and Recording)</th>
<th>Total Voiceable Tracks</th>
</tr>
</thead>
<tbody>
<tr>
<td>HDX, 1 card</td>
<td>64 channels</td>
<td>44.1/48</td>
<td>256</td>
<td>768</td>
</tr>
<tr>
<td></td>
<td></td>
<td>88.2/96</td>
<td>128</td>
<td>768</td>
</tr>
<tr>
<td></td>
<td></td>
<td>176.4/192</td>
<td>64</td>
<td>768</td>
</tr>
<tr>
<td>HDX, 2 cards</td>
<td>128 channels</td>
<td>44.1/48</td>
<td>512</td>
<td>768</td>
</tr>
<tr>
<td></td>
<td></td>
<td>88.2/96</td>
<td>256</td>
<td>768</td>
</tr>
<tr>
<td></td>
<td></td>
<td>176.4/192</td>
<td>128</td>
<td>768</td>
</tr>
<tr>
<td>HDX, 3 cards</td>
<td>192 channels</td>
<td>44.1/48</td>
<td>1024</td>
<td>768</td>
</tr>
<tr>
<td></td>
<td></td>
<td>88.2/96</td>
<td>512</td>
<td>768</td>
</tr>
<tr>
<td></td>
<td></td>
<td>176.4/192</td>
<td>128</td>
<td>768</td>
</tr>
<tr>
<td>HD Native</td>
<td>64 channels</td>
<td>44.1/48</td>
<td>256</td>
<td>768</td>
</tr>
<tr>
<td></td>
<td></td>
<td>88.2/96</td>
<td>128</td>
<td>768</td>
</tr>
<tr>
<td></td>
<td></td>
<td>176.4/192</td>
<td>64</td>
<td>768</td>
</tr>
</tbody>
</table>
Pro Tools Ultimate audio playback, recording and voice limits by hardware configuration

<table>
<thead>
<tr>
<th>Core System Type</th>
<th>Maximum I/O</th>
<th>Sample Rate (kHz)</th>
<th>Playback and Recording Voices (Mono Tracks of Simultaneous Playback and Recording)</th>
<th>Total Voiceable Tracks</th>
</tr>
</thead>
<tbody>
<tr>
<td>Core Audio and ASIO (Pro Tools Ultimate)</td>
<td>32 channels</td>
<td>44.1/48</td>
<td>256</td>
<td>768</td>
</tr>
<tr>
<td></td>
<td></td>
<td>88.2/96</td>
<td>128</td>
<td>768</td>
</tr>
<tr>
<td></td>
<td></td>
<td>176.4/192</td>
<td>64</td>
<td>768</td>
</tr>
</tbody>
</table>

Pro Tools HD Audio Interface Features

The following table lists the input and output capabilities of the various Pro Tools HD audio interfaces for HDX and HD Native systems. Each HDX card in your system supports a maximum of 64 channels of I/O. HD Native hardware supports a maximum of 64 channels of I/O. To record and play audio with Pro Tools Ultimate with any of these hardware configurations, you must have at least one Pro Tools HD audio interface connected to the first port of the first card (or Thunderbolt interface) in the system.

Avid HD audio interface channel capabilities

<table>
<thead>
<tr>
<th>Interface Type</th>
<th>Number of I/O Channels</th>
<th>Sample Rates (kHz)</th>
<th>A/D Conversion</th>
<th>D/A Conversion</th>
<th>Digital I/O</th>
</tr>
</thead>
<tbody>
<tr>
<td>HD I/O</td>
<td>16 in/16 out</td>
<td>44.1, 48, 88.2, 96, 176.4, 192</td>
<td>24-bit</td>
<td>24-bit</td>
<td>24-bit</td>
</tr>
<tr>
<td>HD OMNI</td>
<td>8 in/8 out</td>
<td>44.1, 48, 88.2, 96, 176.4, 192</td>
<td>24-bit</td>
<td>24-bit</td>
<td>24-bit</td>
</tr>
<tr>
<td>HD MADI</td>
<td>64 in/64 out</td>
<td>44.1, 48, 88.2, 96, 176.4, 192</td>
<td>None</td>
<td>None</td>
<td>24-bit</td>
</tr>
<tr>
<td>MTRX</td>
<td>up to</td>
<td>44.1, 48, 88.2, 96, 176.4, 192</td>
<td>24-bit</td>
<td>24-bit</td>
<td>24-bit</td>
</tr>
</tbody>
</table>
HD OMNI Audio Interface

HD OMNI is a professional digital audio interface designed for use with Pro Tools HD systems. HD OMNI provides a compact preamp, monitoring, and I/O solution for music production and recording, and post production studios.

HD OMNI Features

HD OMNI provides up to 8 discrete channels of Pro Tools input and output, with 4-segment LED meters for input or output (selectable).

Analog I/O

- 24-bit analog-to-digital (A/D) and digital-to-analog (D/A) converters, with support for sample rates up to 192 kHz
- 2 high-quality Mic/DI preamps (Channels 1–2)
- 2 combined XLR and 1/4-inch TRS front panel inputs for microphone and instrument level input
- 2 XLR back panel microphone inputs
- 2 1/4-inch TRS Send and 2 1/4-inch TRS Return back panel jacks for hardware inserts on channels 1 and 2
- 4 analog TRS line level back panel inputs (Channels 1–4)

Digital I/O

- 8 channels of AES/EBU output (up to 192 kHz Single Wire) using a DB-25 breakout cable (sold separately)
- 2 channels of AES/EBU XLR input (up to 192 kHz Single Wire)
- 2 channels of S/PDIF RCA input and output (up to 192 kHz)
- 8 channels of ADAT TOSLINK input and output
- Support for ADAT S/MUX Optical for sample rates of 88.2 kHz, 96 kHz, 176.4 kHz, and 192 kHz
- Support for two channels of S/PDIF Optical with sample rates of up to 96 kHz
- Real-time sample rate conversion (SRC) on Digital Inputs 1–2 of either AES/EBU, S/PDIF, or Optical (S/PDIF)

\[\text{SRC is not supported with ADAT S/MUX.}\]

Monitoring

- An additional stereo “CUE” output path in Pro Tools for headphone monitoring from the front panel headphone jack
- Front panel Control Room (MAIN/ALT) and Headphone monitoring volume control
- Flexible monitoring with fold-down from all stereo and surround formats (up to 7.1 surround)
- Input mixer for low latency direct monitoring of a variety of incoming signals (configured in the Pro Tools Hardware Setup)

Synchronization

- Loop Sync input and output for connecting additional HD peripherals
- External Clock input and output for synchronizing HD OMNI with external Word Clock devices

\[\text{For more information, see the HD OMNI Guide.}\]
HD I/O Audio Interface

HD I/O is a multichannel digital audio interface designed for use with Pro Tools HD systems. HD I/O features extremely high quality 24-bit analog-to-digital (A/D) and digital-to-analog (D/A) converters, and supports sample rates of up to 192 kHz.

HD I/O comes in three standard configurations:
- 8 x 8 x 8 (8 analog in, 8 analog out, and 8 digital in and out)
- 16 x 16 analog in and out
- 16 x 16 digital in and out

You can also add or remove HD I/O Analog Expansion cards (ADC and DAC) and HD I/O Digital Expansion cards for custom configurations.

HD I/O Features

HD I/O provides up to 16 discrete channels of Pro Tools input and output, with 4-segment LED meters for input and output.

Analog I/O
- Up to sixteen channels of 24-bit D/A and A/D converters for superior analog input and output at sample rates of 44.1 kHz, 48 kHz, 88.2 kHz, 96 kHz, 176.4 kHz, and 192 kHz with Analog In and Analog Out HD I/O cards
- Soft Clip and Curv limiting circuits to protect against clipping on analog input

Digital I/O
- Up to sixteen channels of 24-bit digital I/O, using AES/EBU, TDIF DB-25, or Optical at sample rates of 44.1, 48, 88.2, 96, 176.4, and 192 kHz with a Digital HD I/O card
- Real-time sample rate conversion on digital inputs with a Digital I/O card (up to sixteen channels of AES/EBU, Optical, or TDIF)
- Support for S/MUX Optical for sample rates of 88.2 kHz and higher
- Support for 2 channels of S/PDIF Optical (enclosed) with sample rates of up to 96 kHz
- 2 channels of AES/EBU I/O (enclosed) with support for sample rates up to 192 kHz
- 2 channels of 24-bit-capable S/PDIF I/O (enclosed) with support for sample rates up to 192 kHz

Synchronization
- Loop Sync input and output for connecting additional Avid HD audio interfaces and peripherals
- External Clock input and output for synchronizing HD I/O with external Word Clock devices

Expandability
- Optional addition of I/O cards to expand analog or digital I/O
- Simultaneous use of multiple Avid HD audio interfaces to further expand system input and output

For more information, see the HD I/O Guide.
HD MADI Digital Audio Interface

HD MADI is a 64-channel, digital audio interface designed for use with Avid HD systems. HD MADI supports the Multichannel Audio Digital Interface (MADI) format and sample rates of up to 192 kHz. HD MADI provides simplified connectivity between your Avid HD system and MADI-compatible audio equipment.

**HD MADI Features**

- 2 MADI Optical and Coaxial inputs and 2 MADI Optical and Coaxial outputs for up to 64 discrete channels of digital input and output (32 channels per DigiLink Mini port)
- Supports sample rates of 44.1, 48, 88.2, 96, 176.4, and 192 kHz
- 24- or 16-bit resolution
- Sample Rate Conversion (SRC) on input or output
- Front panel clock and SRC indicators
- Front panel signal present LEDs for input and output
- BNC Word Clock I/O for synchronizing HD MADI with external 1x Word Clock
- BNC Loop Sync I/O for synchronizing HD MADI with additional Avid HD audio interfaces and peripherals (such as HD I/O, HD OMNI, or SYNC HD)
- Dedicated BNC Word Clock input and XLR AES/EBU input (clock input only) for external MADI synchronization (when using SRC on output)
- Clock support for the following formats: Internal, Loop Sync, Word Clock, AES/EBU, and MADI
- Varispeed modes (supports both 64- and 56-channel standards)

For more information, see the HD MADI Guide.

MTRX Audio Interface

Pro Tools | MTRX is a multichannel digital audio interface designed for use with Pro Tools HD systems.

Depending on installed analog expansion I/O cards, MTRX features extremely high quality 24-bit analog-to-digital (A/D) and digital-to-analog (D/A) converters, and supports sample rates of up to 192 kHz.

MTRX comes in three standard configurations:

- 8 x 8 x 8 (8 analog in, 8 analog out, and 8 digital in and out)
- 16 x 16 analog in and out
- 16 x 16 digital in and out

You can also add or remove analog and digital I/O expansion cards for custom configurations.

**MTRX Features**

Pro Tools MTRX provides up to 64 discrete channels of audio for Pro Tools with two DigiLink Mini ports (Primary and Primary/Expansion).

**Digital I/O**

- Built-in 8 AES3 interfaces with 16 channels of I/O.
- Built-in MADI coax interface with 64 channels of I/O.
- Compliant with the Dante Controller and Dante Virtual Sound Card.
- Ethernet IP audio interface for 64 I/O channels using Dante with configurable redundant network.
- Digital router and format converter between all analog and digital inputs and outputs.
Synchronization
• Sample rates of 44.1–384 kHz as well as DSD64/DSD 128 with high precision internal clock and PLL.
• Sample rate can be adapted to the setting of an external device.
• Synchronization by Word Clock, AES11, Video, and all digital audio inputs.

Remote Control
• Operation using MTRX Control software (Mac OS X or Windows)—some settings can be controlled on the front panel.
• All settings are controlled over Ethernet.

Pro Tools | MTRX I/O Expansion Options
• 2 to 48 analog channels depending on the installed analog I/O cards (Mic/Line AD cards include microphone preamplifiers with relay-based gain circuits):
  • MTRX 8 Line Pristine AD Card
  • MTRX 2 Mic/Line Pristine AD Card
  • MTRX 8 Mic/Line Pristine AD Card
  • MTRX Pristine 8 DA Card
• Digital I/O Expansion Cards:
  • MTRX 8 AES3 I/O Card
  • MTRX Dual SDI/HD/3G Card
  • MTRX 64-Channel IP Audio Dante Module
  • MTRX Dual MADI I/O Card

Additional Pro Tools Hardware Options
Pro Tools software systems also supports the following Pro Tools hardware options.
• Pro Tools | PRE (Eight-channel microphone preamp)
• Eleven Rack (guitar processor)
• Control surfaces (such as Avid Artist Series controllers)

Additional Pro Tools HD Hardware Options
Pro Tools Ultimate also supports the following Avid HD hardware options.
• SYNC HD synchronization peripheral (HDX and HD Native systems only):
  • PRE (Eight-channel microphone preamp)
  • Eleven Rack (guitar processor)
  • Control surfaces (such as S6, D-Command, or D-Control)

For more information, see the Pro Tools | MTRX Guide.
Pro Tools Software Options

(Pro Tools | Ultimate Software Only)

HEAT

HEAT (Harmonically Enhanced Algorithm Technology) is a paid software option that adds “analog color” to Pro Tools HD. For more information, see Chapter 47, “HEAT.”

HDX and HD Native Systems with MachineControl

Pro Tools | Ultimate software provides MachineControl™ with HDX and HD Native systems. MachineControl enables serial communication with Sony® 9-pin compatible synchronizers, and video or audio machines. For more information, see Chapter 58, “MachineControl.”

Pro Tools with VENUE Link

For Pro Tools systems that are connected to VENUE systems using Ethernet, VENUE Link provides Pro Tools and VENUE system integration and interoperability.

Avid Application Manager

The Avid Application Manager is installed with Pro Tools. The Avid Application Manager is used to manage your software and entitlements related to your MyAvid account. The Avid Application Manager helps you maintain the most current Pro Tools software and audio plug-in updates that you are entitled to when new versions become available. For more information about the Avid Application Manager, see the Avid Application Manager Guide (available online through the Avid Knowledgebase).
Chapter 6: I/O Setup

The I/O Setup provides tools to label, format, and assign Pro Tools input, output, insert, and bus audio signal paths both for individual sessions as well as for your specific Pro Tools system. I/O Setup also provides controls for PRE (Mic Preamp) signal paths, and Delay Compensation settings for hardware inserts.

The I/O Setup displays a graphical representation (cross-point matrix) of the signal routing for physical input and output paths for each connected audio interface. Like a virtual patchbay, I/O Setup controls let you route physical inputs and outputs on audio interfaces to Pro Tools input and output channels. For HDX and HD Native systems, some of these controls mirror the routing controls found in the Hardware Setup—changes made to physical routing in one is always reflected in the other. The I/O Setup also includes controls for creating internal mix busses and for creating and mapping output busses.
Opening the I/O Setup

The I/O Setup can be opened from the application window (with a session closed), or from within a session (when a session is open).

To open the I/O Setup:
1. Make sure your audio interfaces are enabled and configured properly in the Hardware Setup. See “Configuring Hardware Settings in Pro Tools” on page 95.
2. Choose Setup > I/O.

Closing the I/O Setup

To close the I/O Setup and save changes:
- Click OK.

Pro Tools checks several settings for routing validity (to prevent feedback loops). If there are any overlapping or invalid settings, you will be required to correct them (see “Valid Paths and Requirements” on page 75).

To close the I/O Setup without saving changes:
- Click Cancel.

Navigating in the I/O Setup

To scroll left or right in the I/O Setup:
- Press Option+Page Up/Down (Mac) or Alt+Page Up/Down (Windows).

Pro Tools Software Signal Paths

A signal path is a logical grouping of multiple inputs, outputs, or busses that has a single name and (channel) format. The I/O Setup lets you create, define and name paths according to the configuration of your studio and the needs of each project. 24 busses are created by default, but you can create as many as you need.

Main Paths and Sub-Paths

Paths in Pro Tools tracks and I/O Setup include main paths and sub-paths.

Main Paths

Main paths are logical groupings of inputs, inserts, busses, or outputs. For example, a master stereo output path will include both its left and right channels.

Sub-Paths

A sub-path represents a signal path within a main path. For example, a default stereo output bus path consists of two mono sub-paths, left and right. Mono tracks and sends can be routed to either mono sub-path of the stereo output bus path.
**Sub-paths for Output Paths**

Pro Tools lets you create sub-paths for physical output paths in the Output page. Using output bus sub-paths rather than physical output sub-paths is sufficient for most workflows. Use physical output sub-paths only when you need alternate mix formats for the same physical output (including explicit downmix paths).

**Default Bus Sub-paths**

Pro Tools lets you create the default sub-paths for busses in the New Sub-Path dialog when accessed from the Bus page. Enable the Create Default Sub-Paths option to have Pro Tools automatically create the default set of sub-paths for the path format (channel width) of the selected main bus path, as follows:

**Default Sub-Paths**

<table>
<thead>
<tr>
<th>Main Path</th>
<th>Sub-Paths</th>
<th>Sub-Path Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>Mono</td>
<td>N/A</td>
<td>N/A</td>
</tr>
<tr>
<td>Stereo</td>
<td>2 mono</td>
<td>&lt;main path name&gt; followed by channel designation .L and .R</td>
</tr>
<tr>
<td>LCR</td>
<td>1 Stereo (LR) 3 Mono (one for each channel)</td>
<td>Stereo: &lt;main path name&gt;.LR, Mono: &lt;main path name&gt;.L, .C, .R, .Ls, .Rs, .Ls, .R, and so on</td>
</tr>
<tr>
<td>Quad</td>
<td>1 Stereo (LR) 4 Mono (one for each channel)</td>
<td>Stereo: &lt;main path name&gt;.LR, Mono: &lt;main path name&gt;.L, .R, .Ls, .Rs</td>
</tr>
</tbody>
</table>

When the Create Default Sub-Paths option is enabled, all other custom options in the New Sub-Paths dialog are grayed-out and unavailable.

💡 It is especially useful to define and name sub-paths for complex mixing setups, such as a 5.1 surround mix.
Paths in Sessions

In sessions, signals are routed to and from tracks, sends, and inserts using track Input, Output, Insert, and Send selectors.

When you click a track Input, Output, Insert, or Send selector, the paths created and defined in the IO Setup appear in the list of available paths (see “Assigning Audio Inputs and Outputs to Tracks” on page 246).

Path Configurations and I/O Settings

Each Pro Tools system can have a different path configuration, determined by:

- On Pro Tools systems, the type of audio interface or other physical I/O (including built-in hardware)
- On HDX and HD Native systems, the number and types of audio interfaces

Path configurations in Pro Tools are saved as I/O settings.

I/O Settings are saved with both the session and with the system. You can choose to overwrite the I/O settings saved with the system with those saved with the session (see “Restore from Session” on page 83).

Unavailable items (including hardware, paths, or required resources) remain in the session as inactive items (see “Making Paths Active or Inactive” on page 74).

When you create a new session, you can specify which I/O Settings to use. For example, you can use the factory installed default settings, the “Last Used” setting, or one of any available custom I/O settings files.

See “Factory I/O Settings” on page 81 and “I/O Settings Files” on page 82 for more information.

Default I/O Settings

Pro Tools comes with default I/O Setup settings to get you started (see “Factory I/O Settings” on page 81). You should only need to open the I/O Setup if you want to customize I/O paths or if you change your system hardware (for example, adding an expansion card to HD I/O, or adding or removing an audio interface).

You can always return to the default settings for an I/O Settings page by clicking the Default button. These paths are available in session tracks and are reflected in the I/O Setup.

You can customize your I/O Setup configuration at any time, according to the needs of each project (see “Customizing I/O Settings” on page 62).
I/O Setup Pages

The I/O Setup provides tabs to open pages for configuring specific I/O Settings.

Opening an I/O Setup Page

To open an I/O Setup page:
- Click the corresponding tab at the top of the I/O Setup.

Hold the Command key (Mac) or the Control key (Windows) and use the Left or Right Arrow keys to cycle through the different pages of the I/O Setup.

It is recommended that if you choose to customize your I/O Setup, configure the system-specific options first: Input, Output, Insert, Mic Preamps, and H/W Insert Delay. Then configure the Bus page. Once you have configured your system, you should not need to change it unless you add or remove hardware (such as audio interfaces) from your system. See “Customizing I/O Settings” on page 62.

Input Page

The Input page of the I/O Setup lets you create and assign Pro Tools Input channels to receive audio from the physical inputs of your audio hardware.

Configure input signal path names, formats, and source channel (analog or digital) on the Input page. Multichannel input paths (stereo or greater) can have any number of sub-paths. Input channels can have overlapping input paths. Input names, channel widths, and physical input mappings are saved with the system and the session, and can be recalled from either.
Output Page

The Output page of the I/O Setup lets you create and assign Pro Tools Output channels to send audio to the physical outputs of your audio hardware.

Configure output signal path names and formats on the Output page. Output channels can have overlapping output paths. Multichannel Output paths (stereo or greater) can have any number of sub-paths. Output names, channel widths, and physical output assignments are saved with the system and the session, and can be recalled from either.

Bus Page

The Bus page of the I/O Setup lets you create and edit internal mix busses and output busses. The Bus page also lets you map output busses to output paths (as configured in the Output page of the I/O Setup).

Configure bus path names and formats, and map any main bus path to any available output of the same width or greater. Multichannel bus paths (stereo or greater) can have any number of sub-paths. Output bus and internal mix bus names and channel widths are saved with and recalled from the session.

For more information, see “Configuring Busses” on page 76.
Insert Page

The Insert page of the I/O Setup lets you create and edit hardware insert signal paths for the Pro Tools mixer. Hardware inserts can route audio through an external device connected to parallel inputs and outputs of a Pro Tools audio interface. This lets you process audio on a track with a hardware insert in real time.

Insert paths require audio interface inputs and outputs, and are determined by the configuration of the Insert page in the I/O Setup for your system.

For more information, see “Using Hardware Inserts” on page 1121.

Mic Preamps Page

On the Mic Preamps page of the I/O Setup, signal paths for one or more PRE multi-purpose microphone preamplifiers can be mapped to audio interfaces. For more information, see the PRE Guide.

H/W Insert Delay (Compensation) Page

To compensate for the delay (latency) of any external hardware devices (such as an effects unit) used in your session, you can set the amount of Hardware Insert Delay Compensation (in milliseconds) for each external device. These times will be used by the Delay Compensation Engine to time-align input paths when the hardware insert is in use and Delay Compensation is enabled.

For more information, see “Setting a Hardware Insert Delay Offset” on page 1088.
I/O Setup Signal Path Controls

Depending on the I/O Setup page, the I/O Setup provides the following controls in its graphical section for configuring signal routing paths.

**Input and Output Selectors (HDX and HD Native Systems Only)** Let you select the physical ports on your audio interface to route to Pro Tools inputs and outputs. Ports are selectable in channel pairs. Available ports for each displayed interface are based on Hardware Setup settings; for example, if the AES/EBU inputs and outputs of an interface are enabled in Hardware Setup, they are available for routing in I/O Setup. The functionality provided with the Input and Output selector is the same as that provided on the Main page of the Hardware Setup.

**Path Name Column** Shows paths that are available for selection, including the name of each defined path. Path names can be renamed.

**Expand/Collapse Triangle** Shows or hides the sub-paths associated with a main path (Input and Bus paths only).

**Active/Inactive Status Box** Shows and changes the active/inactive status of each path.

**Path Format Selector** Shows and selects the type/format (such as Mono, Stereo, Quad, or 5.1) of each defined path (greater-than-stereo multi-channel formats are supported with Pro Tools Ultimate only).

**Channel Grid** Assigns paths to specific interfaces and channels.

I/O Setup Buttons

Depending on the I/O Setup page, the I/O Setup can provide the following buttons for configuring signal routing.

**New Path Button** Lets you create a new path on signal path pages for Input, Output, Insert, Bus, or Mic Preamp.

**New Sub-Path Button** Lets you create a new sub-path on signal path pages for Input, Output, Insert, or Bus.

**Delete Path Button** Lets you delete any selected path or sub-path on signal path pages for Input, Output, Insert, or Bus.

**Default Button** Resets a path type to its default path configuration, depending on the physical hardware I/O you are using and how your hardware is configured.

Option-click (Mac) or Alt-click (Windows) the Default button to restore defaults to paths in all pages of the I/O Setup.
**Import Settings Button** Lets you import an I/O settings file to reconfigure I/O Setup. Import Settings only imports the settings for the currently viewed page of the I/O Setup (such as the Input page).

**Apply to All Tabs** Applies imported I/O settings to all pages of the I/O Setup.

Option-click (Mac) or Alt-click (Windows) the Import Settings button to import settings to all pages of the I/O Setup.

**Export Settings Button** Lets you save I/O settings as a file that can be imported into other sessions or used on other Pro Tools systems. Export Settings exports the settings for all pages of the I/O Setup.

**Show Last Saved Setup** Appears in the I/O Setup in certain session transfer situations. For details on this feature, see “Show Last Saved or Current Setup” on page 84.

**Cancel Button** Closes the I/O Setup without saving changes.

**OK Button** Closes the I/O Setup and saves any changes.

---

**I/O Setup Options**

Pro Tools systems have several additional I/O Setup options depending on which page of the I/O Setup you are viewing. These include default signal routing for metering and auditioning, and default track layout for multichannel mix formats.

---

**Compensate for Delays After Record Pass**

*(HDX and HD Native Systems Only)*

Pro Tools provides two options for compensating for input and output latency (due to any inherent latency in the analog to digital and digital to analog converters of the audio interface) after recording.

**Compensation for Input Delays After Record Pass**

When enabled, this option provides automatic compensation for any analog or digital input delay with Avid HD interfaces. Enable this option for all recording situations. When recording from a digital source, both the Compensation for Input Delays After Record Pass and the Compensation for Output Delays After Record Pass options must be enabled.

The Compensation for Input Delays After Record Pass option is only available in the Input page of the I/O Setup.

**Compensation for Output Delays After Record Pass**

When enabled, this option provides automatic compensation for any analog or digital output delay with Avid HD audio interfaces. Enable this option when you are synchronized to an external clock source. When recording from a digital source, both the Compensation for Input Delays After Record Pass and the Compensation for Output Delays After Record Pass options must be enabled.

The Compensation for Output Delays After Record Pass option is only available in the Output page of the I/O Setup.
Monitor Path

Pro Tools provides a Monitor Path setting in the Output page of the I/O Setup. Using the selected Monitor path for the main mix output of your Pro Tools sessions ensures that a session created on another Pro Tools system will always have at least one audible output.

Pro Tools automatically downmixes or upmixes the session Monitor path to the system Monitor path so that you always hear session playback regardless of name and width of the Output path on either system.

The Monitor path is graphically indicated by a speaker icon in track and send Output selectors, Output paths, and in the Output and Bus pages of the I/O Setup.

Audition Path

You can specify the output path through which files and clips are previewed ( auditioned ) from the Clips List or Workspace browsers, as well as when previewing AudioSuite processing. Pro Tools lets you assign the Audition path to any available Output path regardless of its channel width. For mismatched channel widths, the Audition path is automatically downmixed or upmixed to the selected Output path.

The Audition Path selector is available in the Output page of the I/O Setup.

For information on previewing audio, see “Previewing Clips in the Clips List” on page 295 or “Previewing Audio in Workspace Browsers” on page 339.

Using the Default Audition Path

When you preview a file or clip in the Clips List or in a Workspace browser, or when previewing AudioSuite processing, Pro Tools routes the audio output through the specified Audition Path.

Pro Tools assigns a default Audition Path to the first available main Output path of the corresponding format. You can also select a different Audition Path in the I/O Setup.

Configuring Audition Paths

You can specify the monitoring outputs for auditioning audio in the Clips List and Workspace browsers, or for previewing AudioSuite processing, using the Audition Paths pop-up menu.

Audition Paths Main Menu

The main menu consists of all path format choices available on the current system ( Mono and Stereo on all systems, and LCR and greater with Pro Tools Ultimate only).

Audition Paths Submenus

Each path format choice has a submenu listing Output paths of that given format. (The mono submenu lists Output paths of any format.)

To configure an Audition Path:

- Select a path from the Audition Paths pop-up menu or submenus.

Object Fold Down Path

(Pro Tools | Ultimate with Dolby Atmos Only)

Dolby Atmos® mixes are monitored from the Dolby Atmos Renderer. If Pro Tools is disconnected from or can’t communicate with the Renderer, you can monitor the mix in Pro Tools over the output path designated as the Object Fold Down Path. When Pro Tools can’t recognize a connection to the Renderer, it automatically re-routes all object output paths, and folds them down to the selected output format using coefficients for down mixing 7.1.2 panning.
To designate the Object Fold Down Path:

1. Open the I/O Setup (Setup > I/O) and click the Output tab.
2. In the Output page, ensure that there is an available output path with the channel format that you want. If not, create one.
3. From the Object Fold Down Path selector, output path you want to use to monitor panned object audio.
4. Click OK to save your changes and close the I/O Setup.

Make sure that Pro Tools is not connected to a Renderer, start playback and you will hear all object audio downmixed to the designated Object Fold Down Path.

⚠️ Because the Object Fold Down Path activates an invisible internal bus, it cannot be metered on a Master Fader or the Edit Window Output Meter Path display.

Output Meter Path

The Output Meter Path selector determines the which output or bus paths are monitored by the Output Meters in the transport (see “Output Meters” on page 1073). It also determines the path displayed across the Output meters of D-Control or D-Command worksurfaces as well as in the Pro Tools transport. For more details, see your control surface documentation.

The Output Meter Path selector is available in the Output and Bus pages of the I/O Setup.

To set the Output Meter Paths:

1. Choose Setup > I/O Setup.
2. Select the Output tab.
3. From the Output Meter Path selector, select the desired output path for metering.

Default Output Bus

You can specify the default output bus path assignment for new tracks, in each available format.

The Default Output Bus selector is available in the Bus page of the I/O Setup.

💡 The Default Output Bus can be set for internal mix bus paths, as well as for output bus paths.

To specify a default output for new tracks in the I/O Setup:

- Click the Default Output Bus pop-up menu and select a format and output bus path.

AFL/PFL Path

Tracks soloed in AFL (After Fader Listen) or PFL (Pre Fader Listen) Solo mode are routed to the current AFL/PFL Path, as set with the AFL/PFL Path selector.

Pro Tools provides a combined AFL/PFL Path setting that can use any available Output path, regardless of channel width. For mismatched channel widths, the AFL/PFL path is automatically downmixed or upmixed to the selected Output path.
Note that if you assign the AFL/PFL Path to a physical output used for monitoring, that signal is muted when soloed and the solo path is used for monitoring instead. However, if the AFL/PFL Path is assigned to a different output, the main output continues to pass signal even when the AFL/PFL path is soloed. This lets you use XMON “Broadcast Mode” without XMON (ICON) hardware.

The AFL/PFL Path selector is available in the Output page of the I/O Setup.

See “Solo Modes” on page 256 for more information on using AFL or PFL Solo modes.

To select the AFL/PFL Path output:
- Select a path from the AFL/PFL Path pop-up menu.

Selecting None as the AFL/PFL Path disables AFL and PFL Solo modes. When None is selected, AFL and PFL cannot be used.

Setting AFL or PFL Path Levels

You can set a separate master AFL/PFL Path level for all AFL solos and all PFL solos.

Tracks do not need to be soloed to have the master AFL/PFL Path level adjusted.

To set the AFL/PFL Path level for AFL or PFL solos:
1 Choose Options > Solo Mode, and select a Solo mode:
   - To set the level for AFL solos, select AFL,
   - To set the level for PFL solos, select PFL.
2 In the Mix or Edit window, Control-click Command-click (Mac) or (Windows) a Solo button on any track.
3 Adjust the AFL/PFL Path fader.
4 Click on the new fader position (or press Esc) to close the fader display.

To set the AFL/PFL Path level to 0 dB, Command-Control-click (Mac) or Control-Start-click (Windows) any Solo button.

Low Latency Monitoring
(HD Native Systems Only)

With HD Native systems, the Output page of the I/O Setup lets you enable (or disable) Low Latency Monitoring. It also lets you specify any available Output path for Low Latency Monitoring. The Output path for Low Latency Monitoring can be of any channel width (from Mono to 7.1). Low Latency Monitoring uses Outputs 1–2 by default.

To configure Low Latency Monitoring in the I/O Setup:
1 Open the I/O Setup dialog (Setup > I/O).
2 Click the Output tab.
3 Enable the Low Latency Monitoring option.
4 From the Low Latency Monitoring pop-up menu, select the Output path you want to use for Low Latency Monitoring.
5 Click OK to save your changes and close the I/O Setup.

Default Format
(Pro Tools | Ultimate Software Only)

The Default Format selector lets you select the default format (Mono, Stereo, and all multichannel formats) for new paths and for when you click the Default button.
The Default Format selector is available in the Input, Output, and Insert pages of I/O Setup. The Default Format settings on each page are set independently of one another. The Input and Insert pages only provide Mono and Stereo options. The Output page provides all available formats.

Depending on which page of the I/O Setup is currently shown, the Default Format setting determines the width of the first output (or input or insert) when clicking the Default button. If mono or stereo is selected, all outputs (or inputs or inserts) are created accordingly.

**To choose a Default Format:**
- Select the desired channel format from the Default Format pop-up menu.

For more information about multichannel mixing, see Chapter 52, “Pro Tools Setup for Surround.”

**Path Order**
*(Pro Tools | Ultimate Software Only)*

The Path Order selector lets you specify the default channel order for all new paths created. The selected Path Order setting determines the channel order for the following:
- Channels added to newly created path (first paths) when hitting the Default button.
- Channels added to empty paths when penciling in channel assignments.
- Channels added when creating a new path and selecting the Add default channel assignments option.

The Path Order selector is available in the Input, Output, and Insert pages of I/O Setup. Setting the Path Order on any page of I/O Setup affects the other pages.

**To choose a new default path order (track layout):**
1. Choose Setup > I/O.
2. Click the Output tab.
3. Use the Default Path Order setting to select the channel order you want for the corresponding channel width.

**Embed Eleven Settings From**
*(Systems with Eleven Rack Only)*

With an Eleven Rack connected to your Pro Tools system, Pro Tools lets you embed the current Eleven Rack Rig settings into audio clips as you record them, so that you can retrieve that same setting for further use later. This can also be helpful when collaborating or bringing sessions or clips to a different system using Eleven Rack, because your settings travel with the files.

The Embed Eleven Setting From selector determines the audio input used for routing audio from an Eleven Rack into a separate audio interface.

**To embed Rig setting in recorded audio:**
1. Choose Setup > I/O Setup.
2. Select the Input tab.
3. Set the Embed Setting From menu to the input you plan to record through, such as Eleven Rig L/R.
4. Create an audio track, and set its input to the corresponding input on your audio interface.
5. Record enable the track.
6. Record your part.
The settings of the currently loaded Rig will be embedded in each audio clip that is recorded from the input you select in the Embed Setting From menu.

Audio clips with embedded Rig data are marked with a small Eleven Rack logo icon in both the Edit Window and the Clips List in Pro Tools.

## Customizing I/O Settings

The following shows how to customize your I/O settings for your particular studio setup.

> If you are using an HD OMNI, be sure to configure the Monitor page of the Hardware Setup for HD OMNI before configuring the I/O Setup. For more information, see the HD OMNI Guide.

### To customize I/O Settings:

1. Open the I/O Setup (Setup > I/O).

2. Import I/O settings from an existing I/O settings .pio file or a Pro Tools session file (.ptx) (see “Importing I/O Settings” on page 82).

   > You can prepare a session for use on a different system this way. Any paths for hardware that is not present on the current system will appear as inactive.

3. For HDX and HD Native systems, double-click the label above an interface and enter a name.

   > With systems using HDX or HD Native hardware, the I/O Setup bases default Input and Output path names on the custom name given to the interface.

4. Click the Input tab and do the following:
   - Create input paths and sub-paths with appropriate widths and physical input assignments that match your studio configuration (see “Signal Path Routing for Audio Output” on page 66).
   - Rename input paths and sub-paths to match your studio configuration.

5. Click the Output tab and do the following:
   - Create output paths with appropriate widths and physical output assignments that match your studio configuration.
   - Rename output paths to match your studio configuration.

6. If you plan on using hardware inserts, click the Insert tab and do the following:
   - Create insert paths with appropriate widths and physical input and output assignments that match your studio configuration.
   - Name insert paths to match your studio configuration. Name insert paths using standard industry terminology if possible, such as “Compressor,” “Reverb,” “EQ,” and so on.
   - Click the H/W Insert Delay tab and enter the correct insert delay in milliseconds for each input/output pair that you are using for hardware inserts. (See “H/W Insert Delay (Compensation) Page” on page 55.)

7. If you are using one or more PRE peripherals, click the Mic Preamps tab and configure it accordingly (see the PRE Guide).

8. Click the Bus tab.

9. Create internal mix bus paths and sub-paths. Ensure that output busses are mapped to the correct output paths (see “Output Busses” on page 76).

   > Output busses are automatically created and mapped to outputs when new output paths are created.
10 Export your I/O settings to create a backup of your current settings (see “Exporting I/O Settings” on page 83).

11 Click OK. You should not have to open the I/O Setup again unless you add or remove hardware to or from your system, or if you open a session created on a different system (see “Session or Project Interchange and I/O Mapping” on page 84).

### Configuring Hardware in I/O Setup

**(Pro Tools HDX and HD Native Systems Only)**

With HDX and HD Native systems, you can define which physical ports on your audio interface are routed to available input and output channels in the I/O Setup. Any changes made here are also reflected in the Hardware Setup, and vice-versa (see “Configuring Hardware Settings in Pro Tools” on page 95).

HD MADI and Pro Tools systems such as Mbox Pro and 003 are “hard-wired” and cannot be changed. For third-party and built-in hardware, in the Hardware Setup click the Launch Setup App button to for available configuration options.

**To configure I/O routing in I/O Setup:**

1. Choose Setup > I/O.
2. Click the Input or Output tab to display the corresponding path type.
3. Click the Input or Output selector for the first interface channel pair, located below the first audio interface icon.
4. From the pop-up menu, select a physical port pair (such as Analog 1–2), to route to a Pro Tools channel pair (such as A 1–2) in the Path Name column on the left.

5. Repeat the above step for additional channel pairs.
6. Click OK to save changes and close the I/O Setup.

**Routing a Pro Tools Output Pair to Multiple Destinations**

Pro Tools channel pairs can be routed to multiple outputs on an audio interface through the I/O Setup. For example, if you assign both Analog 1–2 and Analog 3–4 interface outputs to Pro Tools Output pair 1–2, when you send a signal to Pro Tools Outputs 1–2, that signal will be routed simultaneously to both pairs of output ports on your audio interface.

This lets you send the same signal (such as a stereo pair, a stem mix, or a multichannel mix) to multiple destinations (such as multiple mastering devices).
The only limit to output choices is the number of outputs available in your system.

Output path assignments can overlap in certain situations. See “Valid Paths and Requirements” on page 75 for details.

Pro Tools outputs pairs can also be routed to multiple audio interface outputs in the Hardware Setup.

To route a Pro Tools output channel pair to multiple audio interface output ports:

1. Choose Setup > I/O.
2. Click the Output tab.
3. Click the Output selector for an interface channel pair, just below an audio interface icon.
4. From the pop-up menu, select a physical port pair (such as Analog 1–2) to route to the corresponding Pro Tools channel pair (such as A 1–2) in the Path Name column on the left.
5. Control-click (Mac) or Start-click (Windows) the same Output selector and select an additional output pair from the same pop-up menu.

The output name updates with a plus sign (“+”) before it to indicate that multiple output ports are selected. In the pop-up menu, each physical port pair assigned to that Pro Tools output pair is indicated by a check mark.

6. Repeat the above steps to select additional output destinations.
7. Click OK to save changes and close the I/O Setup.
Signal Path Routing for Audio Input

The following example shows the signal path from the physical analog input of an HD OMNI audio interface, through the Pro Tools audio input path, to the Input of an audio track in the Pro Tools mixer:

(1) Physical Input For Avid HD interfaces, such as the HD OMNI, the physical inputs that are available to Pro Tools are set on the Main page of the Hardware Setup (this selector is mirrored in the Input page of the I/O Setup).

💡 For Pro Tools systems such as the Mbox Pro and the 003, physical inputs are fixed. For third-party and built-in hardware, in the Hardware Setup click the Launch Setup App button for available configuration options.

(2) Input Path Main input paths and sub-paths are routed (patched) to physical inputs using cross-point matrix mapping in the I/O Setup. In this example, audio input is routed from HD OMNI physical inputs Analog 1–2 to Pro Tools Input channels A 1–2.

(3) Track Input Input paths and sub-paths are routed to track inputs in the Pro Tools mixer by selecting the path (or sub-path) from the Track Input selector. In this example, input sub-path A1 is routed to the input of track “Audio 1.”
Signal Path Routing for Audio Output

The following example shows the signal path from the output of an audio track through an output bus mapped to an output path that is routed to a physical output on an HD I/O audio interface:

1. **Track Output** Audio is played back from disk and routed from the Track Output to Output Bus “B 1–2.”


3. **Output Path** On the Output page of the I/O Setup, the Grid is used to route the output path (to which the output bus is mapped) to physical outputs.

Output signal path from an audio track to a physical output as mapped in I/O Setup

(1) **Track Output** Audio is played back from disk and routed from the Track Output to Output Bus “B 1–2.”

(2) **Output Bus Path** The Output Bus is defined on the Bus page of the I/O Setup. On the Bus page of the I/O Setup, the Output Bus “B 1–2” is mapped to Output “B 1–2,” which is defined on the Output page of the I/O Setup.

(3) **Output Path** On the Output page of the I/O Setup, the Grid is used to route the output path (to which the output bus is mapped) to physical outputs.
(4) Physical Output  For Avid HD audio interfaces, such as the HD OMNI, the physical outputs that are available to Pro Tools are set on the Main page of the Hardware Setup (this selector is mirrored in the Output page of the I/O Setup).

For Pro Tools systems such as the Mbox Pro and the 003, physical outputs are fixed. For third-party and built-in hardware, click the Launch Setup App button in the Hardware Setup for available configuration options.

Creating New Paths
The I/O Setup lets you create new paths with custom names, formats, and assignments to physical I/O. Custom path names appear in a session’s track Input, Output, Insert, and Bus selectors.

To create a new path:
1 Choose Setup > I/O.
2 Click the Input, Output, Insert, or Bus tab to display the corresponding path type.
3 Click New Path.
4 In the New Path dialog, specify the number of new paths you want to create, the channel width for each path, and the path name.

5 Do one of the following:
   • To add more paths, click the Add Row button (“+”).
   • To remove a path, click the Remove Row button (“–”).

Add a new path by pressing Command+N (Mac) or Control+N (Windows), or by pressing Command+Plus (+) (Mac) or Control+Plus (+) (Windows) on the numeric keypad.

6 Enable (or disable) the New Paths options Add the Default Channel Assignments and Auto-Create Sub-paths.

7 Click Create.

When you create a new Output path, an output bus is automatically created on the Bus page of the I/O Setup, and is automatically mapped to the output path you created. See “Output Busses” on page 76.

8 Assign the path to a specific audio interface (Input, Output, and Insert pages only) in the Grid column. See “Assigning Paths to Hardware I/O” on page 74.

9 Repeat the previous steps to configure all path types (Input, Output, Insert, or Bus).

10 Click OK to save changes and close the I/O Setup. If there are any identically named paths, you will be instructed to correct them before the I/O Setup will close. For more information, see “Valid Paths and Requirements” on page 75.

Multichannel paths and mixing are explained in Chapter 52, “Pro Tools Setup for Surround.”
New Paths Dialog


Add Default Channel Assignments Option

Enable Add Default Channel Assignments option if you want Pro Tools to automatically assign input, output, and insert paths to physical inputs and outputs in the Channel Grid (from the first available channel to the maximum number of channels available). If the number of new paths of a certain width exceeds the number of available channels, Pro Tools wraps around and starts over at the first physical input or output of your audio interface.

Auto-Create Sub-Paths Option

For input, bus, and insert paths, enable the Auto Create Sub-Paths option to have Pro Tools automatically create the default set of sub-paths for the path format (channel width), as follows:

Default Sub-Paths

<table>
<thead>
<tr>
<th>Main Path</th>
<th>Sub-Paths</th>
<th>Sub-Path Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>Mono</td>
<td>N/A</td>
<td>N/A</td>
</tr>
<tr>
<td>Stere</td>
<td>2 mono</td>
<td>&lt;main path name&gt; followed by channel designation .L and .R</td>
</tr>
</tbody>
</table>
| LCR       | 1 Stereo (LR), 3 Mono (one for each channel) | Stereo: &lt;main path name&gt; .LR  
Mono: &lt;main path name&gt; .L, .C, .R |
| LCRS      | 1 Stereo (LR), 4 Mono (one for each channel) | Stereo: &lt;main path name&gt; .LR  
Mono: &lt;main path name&gt; .L, .C, .R, .S |
| Quad      | 1 Stereo (LR), 4 Mono (one for each channel) | Stereo: &lt;main path name&gt; .LR  
Mono: &lt;main path name&gt; .L, .R, .Ls, .Rs |
Creating New Sub-Paths

You can create sub-paths for main paths in the Input, Output, Bus, and Insert pages of the I/O Setup.

To create a new sub-path:

1. Select the page of the I/O Setup where you want to create sub-paths (such as the Input page).
2. Select the Main path for which you want to create sub-paths.
3. Click New Sub-Path.
4. Configure the New Sub-Paths dialog as desired and click Create.
5. Click in the Grid to assign the new sub-path channels to available main path channels.

New Sub-Path Dialog

The New Sub-Path dialog lets you create new sub-paths for main paths on the Input, Output, Bus, and Insert pages of the I/O Setup.

<table>
<thead>
<tr>
<th>Main Path</th>
<th>Sub-Paths</th>
<th>Sub-Path Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>5.0 – 6.0 – 7.0</td>
<td>1 Stereo (LR), 5–7 Mono (one for each channel)</td>
<td>Stereo: &lt;main path name&gt;.LR Mono: &lt;main path name&gt;.L, .C, .R, .Ls, .Rs, and so on</td>
</tr>
<tr>
<td>5.1 – 6.1 – 7.1</td>
<td>1 Stereo (LR), 6–8 Mono (one for each channel)</td>
<td>Stereo: &lt;main path name&gt;.LR Mono: &lt;main path name&gt;.L, .C, .R, .Ls, .Rs, and so on, and LFE</td>
</tr>
<tr>
<td>7.0.2 (Dolby Atmos only)</td>
<td>1 each: 7.0, 5.0, Quad, LCR, Stereo, Overhead (LR); and 9 Mono (one for each channel)</td>
<td>multichannel sub-paths: &lt;main path name&gt;.&lt;channel format&gt; Mono: &lt;main path name&gt;.L, .C, .R, .Lss, .Rss, .Lsr, .Rsr, .Lts, .Rts</td>
</tr>
<tr>
<td>7.1.2 (Dolby Atmos only)</td>
<td>1 each: 7.1, 7.0, 5.1, 5.0, Quad, LCR, Stereo, Overhead (LR); and 10 Mono (one for each channel)</td>
<td>Stereo: &lt;main path name&gt;.LR Mono: &lt;main path name&gt;.L, .C, .R, .Ls, .Rs, .Lsr, .Rsr, .LFE, .Lts, .Rts</td>
</tr>
</tbody>
</table>
New Sub-Path Row Settings

Number of New Sub-Paths Enter the number of new sub-paths you want to create for the selected main path.

Sub-Path Format Select the channel width from the Path Format selector.

Sub-Path Name Enter the sub-path name. If you are creating more than one sub-path, the number of each new sub-path will be appended to the sub-path name (for example, Bus 1, Bus 2, Bus 3, and so on).

Add/Remove Rows Click the Add Row button to add more paths, or click the Remove Row button to remove paths.

Move Row Icon Drag a Move Row icon up or down to reorder paths.

Add Default Channel Assignments Option (Input, Output, and Insert Sub-Paths Only)

Enable Add Default Channel Assignments option if you want Pro Tools to automatically assign input, output, and insert sub-paths to physical inputs and outputs in the Grid (from the first available channel to the maximum number of channels available). If the number of new sub-paths of a certain width exceeds the number of available channels, Pro Tools wraps around and starts over the first physical input or output of your audio interface.

Create Default Sub-Paths Option (Bus Sub-Paths Only)

Pro Tools lets you create the default sub-paths for busses in the New Sub-Path dialog when accessed from the Bus page. Enable the Create Default Sub-Paths option to have Pro Tools automatically create the default set of sub-paths for the path format (channel width) of the selected main bus path, as shown in the following table.

<table>
<thead>
<tr>
<th>Main Path</th>
<th>Sub-Paths</th>
<th>Sub-Path Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>Mono</td>
<td>N/A</td>
<td>N/A</td>
</tr>
<tr>
<td>Stereo</td>
<td>2 mono</td>
<td>&lt;main path name&gt; followed by channel designation L and R</td>
</tr>
<tr>
<td>LCR</td>
<td>1 Stereo (LR), 3 Mono (one for each channel)</td>
<td>Stereo: &lt;main path name&gt;.LR Mono: &lt;main path name&gt;.L, .C, .R</td>
</tr>
<tr>
<td>LCRS</td>
<td>1 Stereo (LR), 4 Mono (one for each channel)</td>
<td>Stereo: &lt;main path name&gt;.LR Mono: &lt;main path name&gt;.L, .C, .R, .S</td>
</tr>
<tr>
<td>Quad</td>
<td>1 Stereo (LR), 4 Mono (one for each channel)</td>
<td>Stereo: &lt;main path name&gt;.LR Mono: &lt;main path name&gt;.L, .R, .Ls, .Rs</td>
</tr>
<tr>
<td>5.0 – 6.0 – 7.0</td>
<td>1 Stereo (LR), 5–7 Mono (one for each channel)</td>
<td>Stereo: &lt;main path name&gt;.LR Mono: &lt;main path name&gt;.L, .C, .R, .Ls, .Rs, and so on</td>
</tr>
<tr>
<td>5.1 – 6.1 – 7.1</td>
<td>1 Stereo (LR), 6–8 Mono (one for each channel)</td>
<td>Stereo: &lt;main path name&gt;.LR Mono: &lt;main path name&gt;.L, .C, .R, .Ls, .Rs, and so on, and LFE</td>
</tr>
</tbody>
</table>
Chapter 6: I/O Setup

When the Create Default Sub-Paths option is enabled, all other custom options in the New Sub-Paths dialog are grayed-out and unavailable.

**Default Sub-Paths**

<table>
<thead>
<tr>
<th>Main Path</th>
<th>Sub-Paths</th>
<th>Sub-Path Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>7.0.2 (Dolby Atmos only)</td>
<td>1 each: 7.0, 5.0, Quad, LCR, Stereo, Overhead (LR); and 9 Mono (one for each channel)</td>
<td>multichannel sub-paths: &lt;main path name&gt;.&lt;channel format&gt; Mono: &lt;main path name&gt;.L, .C, .R, .Lss, .Rss, .Lsr, .Rsr, .Lts, .Rts</td>
</tr>
<tr>
<td>7.1.2 (Dolby Atmos only)</td>
<td>1 each: 7.1, 7.0, 5.1, 5.0, Quad, LCR, Stereo, Overhead (LR); and 10 Mono (one for each channel)</td>
<td>Stereo: &lt;main path name&gt;.LR Mono: &lt;main path name&gt;.L, .C, .R, .Lss, .Rss, .Lsr, .Rsr, .LFE, .Lts, .Rts</td>
</tr>
</tbody>
</table>

In addition, you can import and export your I/O Setup configurations as I/O Settings files, as well as set default path parameters. See “I/O Settings Files” on page 82.

The following table lists the available attributes for each path type:

**Path options that can be edited by type**

<table>
<thead>
<tr>
<th>Path Type</th>
<th>Path Options (Attributes)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Input</td>
<td>Names, formats, and source channel (physical input)</td>
</tr>
<tr>
<td>Output</td>
<td>Names, formats, and destination channel (physical output)</td>
</tr>
<tr>
<td>Insert</td>
<td>Names, formats, and destination (physical inputs and outputs)</td>
</tr>
<tr>
<td>Bus</td>
<td>Names, formats, output mapping</td>
</tr>
</tbody>
</table>

Interfaces can also be renamed.

**Restoring Default Paths and Path Names**

You can restore I/O Setup paths to their default state at any time. You may want to restore defaults if, for example, you replace or add an audio interface to your system.

**To restore default paths and path names:**

1. Choose Setup > I/O.
2. Click the Input, Output, Insert, or Bus tab to display the corresponding path type.
3. Click Default. Pro Tools does the following:
   - If a session is open, deletes any paths that are not in use.
   - Creates new default paths up to the capacity of your system’s available physical I/O and resources.
• Resets path names to the default path names (see “Default Path Names” on page 72). These de-
  fault path names appear in track Input and Out-
  put Path selectors.

Option-click (Mac) or Alt-click (Windows) the Default button to set all pages of I/O Setup to the default settings.

4 Click OK to save changes and close the I/O Setup.

Renaming Interfaces

Audio interfaces can be renamed in the IO Setup. When you rename Avid HD audio interfaces, de-
  fault path names are based on the custom name given to the interface.

To rename an audio interface in the I/O Setup:

1 Double-click the label above an interface.

Renaming Paths

Path names can be customized in the I/O Setup.

I/O paths can also be renamed directly from the Edit or Mix window by Right-clicking the Input or Output selector and choosing Rename.

To rename a path in the I/O Setup:

1 Double-click the path name.

2 Type a new path name.

3 Click OK to save changes and close the I/O Setup.

Default Path Names

Default names for input, output, and insert paths are based on the hardware you are using for physi-
  cal I/O.

For HDX and HD Native systems, default path names are based on the names of interfaces you are using. If you have renamed your interface, default path names are based on the custom name.
Selecting Paths

Individual and multiple paths can be selected in the I/O Setup Path Name column. Selected paths and sub-paths can be reordered higher or lower in the Path Name column to change their menu order in track Input, Output, Insert, and Bus selectors. Paths can also be deleted. Sub-paths follow their main paths when they are moved in the I/O Setup.

To select a main path or sub-path:

- Click the path name.

To select a range of paths:

1. Click the path name.
2. Shift-click an additional path name.

All paths between the first selected path name and the additional path name will also be selected.

To select or deselect noncontiguous paths, do one of the following:

- Command-click (Mac) or Control-click (Windows) path names that are unhighlighted to select them.
- Command-click (Mac) or Control-click (Windows) path names that are highlighted to deselect them.

To select all paths and sub-paths:

- Option-click (Mac) or Alt-click (Windows) any path name that is unhighlighted.

To deselect all paths and sub-paths:

- Option-click (Mac) or Alt-click (Windows) any path name that is highlighted.

Reordering Paths

Selected paths and sub-paths can be reordered higher or lower in the Path Name column to change their menu order in track Input, Output, Insert, and Bus selectors.

To reorder paths in the I/O Setup and Track selectors:

1. Drag one or more selected path names up or down.
2. Click OK to save changes and close the I/O Setup.

Deleting Paths

Path definitions can be deleted from the current session to reflect changes to your hardware setup, or to clean up track selector menus by removing unwanted or unnecessary path definitions. After deleting a path, any tracks or send assignments to that path are reset to No Output.

To delete a main path or sub-path:

1. In the I/O Setup, select the path you want to delete.
2. Click Delete Path.
3. Click OK to save changes and close the I/O Setup.

To delete all paths:

1. Option-click (Mac) or Alt-click (Windows) any path name.
2. Click Delete Path.
3. Click OK to save changes and close the I/O Setup.
Making Paths Active or Inactive

Pro Tools paths can be Active (on) or Inactive (off, or unavailable). Paths can be globally activated or deactivated in the I/O Setup. Making a signal path inactive will turn off the signal path on any and all tracks currently assigned to it.

Pro Tools also sets unavailable paths to inactive. Paths can be unavailable when hardware or other system resources are unavailable, such as when opening a session saved on a different system.

Tracks can also be made active or inactive. For information, see “Making Track Inputs and Outputs Inactive from the Edit or Mix Window” on page 251.

To globally activate or deactivate a path:

1. Choose Setup > I/O.
2. Select a path type using the tabs at the top of the window.
3. Set the Active/Inactive control for the path.
4. Click OK to save changes and close the I/O Setup. Path status is displayed as follows:

**Italics** Indicates the path is inactive.

**Non-Italics** Indicates the path is active.

⚠️ With overlapping output paths of different channel widths, if the widest path is made in-active, all other overlapped output paths will not pass audio from Pro Tools.

Assigning Paths to Hardware I/O

Paths are assigned to specific inputs, outputs, and inserts in the Grid. Paths can be assigned to physical I/O in the Grid, and can be reassigned at any time.

To assign channels:

1. Select (or create) a main path or sub-path.
2. Select the channel Format (such as Stereo).
3. In the row for the selected path, click in the Grid column under an audio interface and channel.

Assigning channels

Other channels for the path type, if any, fill to the right. For example, when assigning a new stereo path, clicking in the path row under output channel 1 fills both channel 1 and 2 (left to 1, right to 2).

⚠️ To reassign channels in a path, see “Reassigning Paths” on page 75.
4 Click OK to save changes and close the I/O Setup.

If there are any invalid settings, you will be required to correct them before the I/O Setup will close. For more information, see “Valid Paths and Requirements” on page 75.

Assigning Paths with the Surround Mixer
(Pro Tools | Ultimate Software Only)

When assigning multichannel paths, the left channel (L) is assigned first to the clicked Grid box, and remaining channels fill immediately to the right according to the default path order.

Because some multichannel mixing formats use unique track layouts, Pro Tools lets you set the default format in the I/O Setup (see “I/O Setup Options” on page 57).

Reassigning Paths

You can move the individual assignments to different channels, to reorder the path’s definition (for example, changing a multichannel path to L-R-C-LFE-Ls-Rs).

To reassign channels in a path:

- Drag the channel to the new location in the Grid. Other channel assignments move (shuffle) to accommodate dragged channels.

Channel Shuffling

Moving a signal from right to left results in a shuffle of other signals after the new destination channel. Moving a signal from left to right shuffles any and all signals after the new destination channel and leaves the previous channel empty.

⚠️ Changing a path’s format erases any current channel assignment.

Sub-Paths Follow Main Paths

When a main path is reassigned, its sub-paths (if any) are reassigned automatically to maintain consistent routing. For example, reassigning a stereo path to different hardware outputs results in any of its sub-paths moving with it.

Valid Paths and Requirements

While configuring the I/O Setup, certain rules apply for path definition and channel assignment. All paths must be valid before the I/O Setup configuration can be applied.

Though it is possible to set up invalid assignments in the Channel Grid, Pro Tools will not accept an I/O Setup configuration unless all paths meet the path definition and channel assignment requirements, as follows:

Minimum Path Definitions All paths must have a name, be of a specific format, and have a valid I/O assignment.

Valid Paths Channel assignment follows certain rules regarding overlapping paths.

- There can be no partial overlaps between any two output paths.
• A newly-created output path must either be completely independent of other assignments (not assigned to any other available I/O interface/channels), or it must be a path completely contained within a larger path (for example, an LCR sub-path within a larger 5.1 path).

Where possible, Pro Tools can automatically re-map the session’s output busses to the output paths of the system on which the session is being opened.

See “Session or Project Interchange and I/O Mapping” on page 84 for more information exchanging sessions between systems, and on opening sessions in lower version of Pro Tools. Output busses do not exist in Pro Tools 8.0.x and lower.

Output Busses

Output busses are mapped (routed) to output paths, as configured on the Output page of the I/O Setup. Output paths are then assigned to the system’s physical audio outputs in the I/O Setups Grid (see “Assigning Paths to Hardware I/O” on page 74).

When you create a new output path on the Output page of the I/O Setup, a new output bus of the same width is automatically created and mapped to that output path. Output busses are also created and mapped according to default settings when creating a new session or restoring defaults (see “Restoring Default Paths and Path Names” on page 71).

Physical outputs for output paths are configured on the Outputs page of the I/O Setups (see “Assigning Paths to Hardware I/O” on page 74).

Internal Mix Busses

Pro Tools provides internal mix busses that can be used to route audio signal from track outputs and sends to other track inputs and plug-in side-chains. Common uses for internal mix busses include effects sends and returns (such as bussing sends from audio tracks to an Auxiliary Input track for plug-in effects processing) and bus recording.
Object Paths
(Pro Tools | Ultimate with Dolby Atmos Only)

Object paths are busses mapped (routed) to Object Input paths, as defined by the Dolby Atmos Renderer (see “Mapping Busses to Objects” on page 1243).

For more information about Pro Tools authoring to Dolby Atmos, see Chapter 55, “Mixing to Dolby Atmos.”

Creating and Mapping Busses to Outputs

Any available bus can be mapped to any of the available output paths of the same channel width or greater. For example, a mono bus can be mapped to a mono output path, a stereo bus can be mapped to a stereo output path, and a 5.1 surround bus can be mapped to a 5.1 surround output path.

You can unmapped buses from outputs at any time.

To create a bus and map it to an output path:

2. In the New Paths dialog, specify the number of new paths you want to create, the channel width for each path, and the path name.
3. Click Create to create the new paths.

Unmapped “MAIN” output bus

4. Enable Mapping To Output for the path.
5. Select an output path from the Mapping To Output selector.

Mapping the “MAIN” output bus to output path “A 1–2”

Command-click (Mac) or Control-click (Windows) to select multiple outputs in the Mapping to Output menu in the Bus page of the I/O Setup (I/O Setup > Bus > Mapping to Output).

Any signals from tracks or sends sent to the bus are now sent to the hardware outputs assigned to the corresponding Output paths.

To map all output busses of the same format to an output path:

- Option-click (Mac) or Alt-click (Windows) the Mapping To Output selector and select an output path (mono or stereo).

All mapped output busses of the same format (such as stereo) are all assigned to the same output path. For example, you can assign all stereo output busses to output path A 1–2.
To map all output busses of the same format to one output path:

1. Do one of the following:
   - Shift-click to select contiguous Output busses.
   - Command-click (Mac) or Control-click (Windows) to select noncontiguous Output busses.

2. Option-Shift-click (Mac) or Alt-Shift-click (Windows) the Mapping To Output selector for one of the selected Output busses and select an output path (mono or stereo).

Only the selected mapped output busses of the same format (such as stereo) are assigned to the same output path. For example, you can assign only the selected stereo output busses to output path A 1–2.

To map all busses of the same format to unique ascending output paths (cascading):

- Command-Option-click (Mac) or Control-Alt-click (Windows) the Mapping To Output selector of the top-most output path and select the first output path.

All busses of the same channel format are automatically assigned to unique output path assignments in ascending order. For example, for stereo output paths, output bus A 1–2 is assigned to output path A 1–2, A 3–4 to A 3–4, A 5–6 to A 5–6, and so on.

Mapping Mono Busses to Surround Paths

(Pro Tools | Ultimate Software Only)

You can map a mono bus to any channel of a surround output path. For example, route a dialogue track to the center channel of 5.1 output path. (This capability is available for all output channel widths except Stereo and Quad outputs.)

To map a mono bus to a channel of a surround output path:


2. In the New Paths dialog, specify Mono channel width for the bus path, type a path name, and click Create.

3. Enable Mapping To Output for the path.

4. Select a multichannel output path from the Mapping To Output selector. The mono bus indicator changes to “C” (Center) by default, and a pop-up menu becomes available.

Selecting a multichannel output path

5. To assign another channel, click the mono bus indicator and select the channel from the pop-up menu.

Assigning a channel to a mono bus

To assign the same channel to all mono busses mapped to a multichannel output path:

- Option-click (Mac) or Alt-click (Windows) the mono bus indicator and select the channel from the pop-up menu.
To assign the same channel to all selected mono busses mapped to a multichannel output path:

1. Do one of the following:
   - Shift-click to select contiguous mono busses in the Name column.
   - Command-click (Mac) or Control-click (Windows) to select noncontiguous mono busses in the Name column.

2. Option-Shift-click (Mac) or Alt-Shift-click (Windows) a mono bus indicator and select the channel from the pop-up menu.

To assign ascending (cascading) channels to all mono busses mapped to a multichannel output:

- Command-Option-click (Mac) or Control-Alt-click (Windows) the mono bus indicator of the top-most mono bus and select the first channel from the pop-up menu.

To assign ascending (cascading) channels to all selected mono busses mapped to a multichannel output:

1. Do one of the following:
   - Shift-click to select contiguous mono busses in the Name column.
   - Command-click (Mac) or Control-click (Windows) to select noncontiguous mono busses in the Name column.

2. Command-Option-Shift-click (Mac) or Control-Alt-Shift-click (Windows) the mono bus indicator of the top-most mono bus and select the first channel from the pop-up menu.

Using Keyboard Modifiers When Enabling or Assigning Output Busses

Pro Tools lets you use keyboard modifiers when enabling or assigning Output busses. These keyboard modifiers behave in the same way as when assigning track inputs, and track and send outputs. Being able to assign a single output bus to multiple physical outputs is useful in cases where you want to route a single source signal to two or more outputs. Rather than assigning multiple outputs on a track-by-track basis, you can do it once in the I/O Setup.

In the I/O Setup, the following keyboard modifiers apply:

- Option-click (Mac) or Alt-click (Windows) to apply to all busses.
- Command-Option-Shift-click (Mac) or Control-Alt-Shift-click (Windows) to apply only to selected Output busses.
- Control-click (Mac) or Start-click (Windows) for each additional Output path you want to assign an Output bus to.
- Command-Option-click (Mac) or Control-Alt-click (Windows) to assign a bus to the selected Output path and all subsequent busses to the next available Output path sequentially.
Resetting Busses

You can reset the number of available internal mix busses in your session to match your system’s full capabilities by reverting to the default bus configuration.

⚠️ Pro Tools creates 24 internal busses by default.

To revert to the default bus configuration for your system:

1. Open the I/O Setup.
2. Click the Bus tab in the upper left.
3. From the pop-up menu to the right of the Default button, select one of the following:
   - All Busses
   - Output Busses
   - Internal Busses
4. Click Default.
5. Click OK to save changes and close the I/O Setup.

⚠️ Resetting busses to the default setting will rename all busses to their default name (Bus 1–2, Bus 3–4, and so on).

Active Busses

The Bus page of the I/O Setup displays the number of active internal mix busses. If the number of active busses exceeds the number of available busses, the display turns red. Delete or deactivate any active busses in excess of the available number of busses to be able close the I/O Setup and save your settings.

Sorting Bus Paths

The Bus page provide controls to sort busses by name (ascending or descending), format (ascending or descending), or by mapped to output status (ascending only).

To sort bus paths by Name:

1. In the Bus page, click the Name column header.
2. Click the Name column header again to toggle between ascending and descending sort order.

To sort bus paths by Format:

1. In the Bus page, click the Format column header.
2. Click the Format column header again to toggle between ascending and descending sort order.

To sort bus paths by Mapping To Output status:

1. In the Bus page, click the Mapping To Output column header.
Factory I/O Settings

Pro Tools provides factory I/O settings for stereo and surround mixing, and are automatically installed with Pro Tools. These settings provide new sessions with generic path and sub-paths for either mixing format.

Factory I/O settings are available in the I/O Settings pop-up menu in the Dashboard.

Stereo Mix Settings

This Stereo Mix setting creates the maximum number of stereo paths, as determined by the available system’s I/O Setup and hardware configuration.

💡 Using the “Stereo Mix” settings file has the same effect as clicking Default for every individual tab in I/O Settings. See “Restoring Default Paths and Path Names” on page 71.

Surround Mix Settings
(Pro Tools | Ultimate Software Only)

The Surround Mix setting provides additional, surround-specific Output and Bus settings files.

⚠️ It is not recommended that you mix while monitoring the session through a downmixed or unmixed Output path. Uses downmixed or upmixed monitoring for editing and other non-mixing tasks.

To assign downmix or upmix Output bus paths:

1. Open the I/O Setup (Setup > I/O).
2. Select the Bus page (I/O Setup > Bus).
3. Click the Mapping to Output column on the row for the Output bus that you want to remap to a lower or higher channel format (from the available Output paths).
4. Click OK to save your changes and close I/O Setup.

Downmix and Upmix Output Busses to Outputs
(Pro Tools | Ultimate Software Only)

Narrower formats automatically map to wider ones with one-to-one matching connections (for example, L to L, R to R, and so on). In cases where certain channels do not match (such as mono to stereo Left and Right, or LCRS to 5.1), Pro Tools lets you upmix by distributing the mismatched channels of an output bus channel to more than one physical output channel. For example, Pro Tools let you upmix a mono output bus to both channels of a stereo output path, or the Surround path from an LCRS source to the Left Surround and Right Surround paths of a 5.1 output.

Pro Tools lets you “downmix” session output buses to physical output paths with channel formats of a lesser width. For example, you can listen to a 5.1 mix on a stereo system without modifying the actual session routing.

Selecting a stereo Output path for a 5.1 Output Bus

Selecting a 5.1 Output path for an LCRS Output Bus

4. Click OK to save your changes and close I/O Setup.
Downmix and Upmix Indicators for Output Paths

When a track or send is set to an Output path of a different channel width, the source audio is downmixed or upmixed accordingly. The Output selector in the Mix, Edit, and Output windows displays a > (downmix) or a < (upmix) symbol respectively. This lets you easily identify any track that is downmixing or upmixing to an Output path of a different channel width.

Custom I/O Settings

Custom I/O Settings files can be created by changing I/O Setup settings (see “Customizing I/O Settings” on page 62), and then exporting the settings. These I/O settings can then be restored by importing them into a system.

This lets you save settings for different projects, import settings to reconfigure the I/O Setup, and manage path definitions and signal routing setups.

Importing I/O Settings

Pro Tools lets you import I/O Settings from session files (.ptx) I/O settings files (.pio) before or after you open a session. I/O Settings are only imported for the current page of the I/O Setup. For example, if you are viewing the Output page and import I/O Settings, only the settings for the Output page are imported. This helps to avoid overwriting your custom I/O Settings on other pages.

When you import I/O Settings, you can choose to delete any unused path definitions before importing the new paths, or leave unused path definitions intact and add the new paths to the current I/O Setup configuration.

To import I/O settings for your Pro Tools system from a Pro Tools session file:

1. Open the I/O Setup (Setup > I/O).
2. Select the tab for the page where you want to import settings.
3. Click Import Settings.

💡 Enable the Apply to all tabs option or press Option (Mac) or Alt (Windows) while clicking Import Settings to overwrite I/O Settings in all pages with the settings imported from a session file.

4. In the Open dialog, navigate to and select the session or I/O settings file you want.

I/O Settings Files

I/O settings files (.pio files) provide default path configurations for new sessions. I/O settings can be imported and exported for use with sessions shared between systems. I/O settings files are also available in the I/O Settings pop-up menu in the Dashboard.

For I/O settings files to be available in the Dashboard, I/O settings files must be saved to the IO Settings folder in the Root Settings Folder. You can change the location of the Root Settings Folder in the Operation Preferences (see “User Media and Settings Location” on page 110).

Last Used I/O Settings

If any changes are made to the I/O Setup, these changes are automatically saved to the IO Settings folder as the Last Used settings file when the I/O Setup is closed (by clicking OK).

Last Used settings are available in the I/O Settings pop-up menu in the Dashboard, or when importing I/O Settings in the I/O Setup.
5 Click Open.

6 Click OK to save your changes and close I/O Setup.

💡 You can also import I/O paths and path names, as well as other session data, from a different session by using the Import Session Data command (File > Import > Session Data). For information, see “Importing Session Data” on page 416.

To import I/O Settings:

1 Click the tab for the page of the I/O Setup for which you want to import settings.

2 Click Import Settings.

3 Select an I/O settings file (.pio) or a Pro Tools session file (.ptx) in the Import Settings dialog and click Import.

4 A dialog appears asking whether you want to delete existing paths. Do one of the following:

   • Click Yes to remove any unused paths and add the imported paths to the current I/O Setup configuration.

   • Click No to add the imported paths to the current I/O Setup configuration.

If the import results in overlapping paths, the new paths will appear in the I/O Setup as Inactive. See “Making Paths Active or Inactive” on page 74.

After importing I/O Settings, you can then reassign path routing definitions in the I/O Setup by remapping, renaming, and deleting paths. See “Pro Tools Software Signal Paths” on page 50.

Exporting I/O Settings

When you export I/O settings, all pages of the I/O Setup are exported.

To export and save an I/O Setup configuration as a custom I/O Settings file:

1 Configure the I/O Setup settings.

2 Click Export Settings.

3 Name and save the settings file. The settings file is appended with “.pio” to distinguish it as an I/O settings file.

💡 To start sessions with a blank or empty I/O Setup, you can create and export an I/O Settings file in which all definitions have been deleted.

Restore from Session

Pro Tools provides a Restore from Session button that only affects the currently viewed page in I/O Setup. For example, if you are viewing the Output page, only the Output settings are overwritten by the settings saved with the session.

To restore I/O settings from the session:

1 Open the I/O Setup (Setup > I/O).

2 Select the tab for the page that you want to restore from the session.

3 Click Restore from Session.

4 Click OK to save your changes and close I/O Setup.

You can also import I/O paths and path names, as well as other session data, from a different session by using the Import Session Data command (File > Import > Session Data). For information, see “Importing Session Data” on page 416.

Enable the Apply to all tabs option or press Option (Mac) or Alt (Windows) while clicking Import Settings to overwrite I/O Settings in all pages with the settings imported from a session file or I/O settings file.

Enable the Apply to all tabs option or press Option (Mac) or Alt (Windows) while clicking Restore from Session to restore settings for all I/O Setup pages from the session.
Session or Project Interchange and I/O Mapping

I/O Setup mappings are saved both with the last used .pio file (Pro Tools I/O settings file) and the session or project. When opening a session or project on a system that has a different I/O Setup, Pro Tools follows these rules to ensure the best possible re-mapping of the session’s or project’s I/O Setup to the new system:

- Output busses are mapped to system Output paths by unique ID if possible.
- Pro Tools always maps the Monitor Path of the session or project to the Monitor path of the current system. (If Monitor subpaths exist in the session, Pro Tools uses the best matching format for the system Monitor subpaths.)
- Otherwise, Output busses that are mapped to system Output paths by name and format if there is an exact match.

If there is no match between Output busses and system Output paths, you can manually remap Output busses. Pro Tools uses the manually remapped unique ID the next time the session is opened on that system.

After configuring the I/O Setup on any given system for a session or project, the settings are retained with the session file or the project.

You can recall the I/O settings saved with the session or project and overwrite the system settings (see “Restore from Session” on page 83).

Indication of Remapping in the Bus Page

Where the system Output path name or format has changed, session Output busses that are successfully remapped are displayed in green.

Additionally, a Previous Output Mappings column appears to the right of the Output Mappings column. This lets you take note of the output mappings that the session used the last time it was saved.

Once you save the session, the Output mapping changes from green to black and is saved both with the system and with the session.

Show Last Saved or Current Setup

When opening a session that was saved with a different I/O Setup configuration for either hardware inputs or outputs, Pro Tools lets you switch between the I/O Setup last saved with the session and the current system I/O Setup. This lets you take note of the hardware Input and Output configuration of the I/O Setup saved with the session.
Both the Input and Output pages of the I/O Setup window provide the Show Last Saved Setup button. When the last saved I/O setup is shown, the button is highlighted.

Once you save the session, the Show Last Saved Setup button is grayed out.

![Show Last Saved Setup button in the Input page](image)

When showing the I/O Setup last saved with the session, any unavailable hardware Inputs or Outputs are displayed in italics.

![Unavailable hardware Input shown in italics](image)

Additionally, when showing the I/O Setup last saved with the session, the Monitor Path, Audition Path, Output Meter Path, and AFL/PFL Path settings that were saved with the session are shown grayed out.

### To show the last saved I/O settings:

1. Open the I/O Setup (Setup > I/O).
2. Click either the Input or Output tab.
3. Click the Show Last Saved Setup button (the button highlights).

### You can restore the I/O settings saved with the session and overwrite the system settings (see “Restore from Session” on page 83).

### When viewing the I/O Setup last saved with the session, the OK option is not available for saving and closing I/O Setup.

### To show the current I/O settings:

1. If not already open, open the I/O Setup (Setup > I/O).
2. Click either the Input or Output tab.
3. Click the highlighted Show Last Saved Setup button (the button becomes unhighlighted).

## I/O Settings and the Playback Engine

When you change the Playback Engine (for example, from HDX to Built-in) Pro Tools automatically creates and recalls I/O Settings (.pio) files based on the Playback Engine. The first time that you use a new Playback Engine, Pro Tools uses the stereo defaults for the selected Playback Engine and corresponding hardware. Thus, even on the same computer, Pro Tools treats different Playback Engines as if they are different systems. This facilitates changing the Playback Engine without having to manually remap Output Busses in the I/O Setup. These I/O Settings files are named after the corresponding Playback Engine and are saved both on the system and with the session.
Pro Tools remembers the individual I/O settings for your system for each Playback Engine available to your system. This includes all Inputs, Output, Insert, and Hardware Delay settings, and also settings such as the selected Monitor and Audition paths. The session’s output bus mappings are stored in the I/O Settings of the selected Playback Engine, ensuring that you can hear the main mix from the session from any Playback Engine.

**Organize Track I/O Menus By Preference**

Pro Tools lets you organize track I/O Menus by Type, Width, or both Type and Width.

To specify the organization of Track I/O Menus:

1. Choose Setup > Preferences.
2. Select the Display tab.
3. Select one of the following options from the Organize Track I/O Menus By selector:
   - **Type** Displays only the I/O Type (Interface or Bus) as I/O categories in Track I/O menus.
   - **Width** Displays only the I/O Channel Width (such as stereo or 5.1) as I/O categories in Track I/O menus.
   - **Type and Width** Displays both Type and Width as I/O categories in Track I/O menus.
4. Click OK.

**I/O Setup in Session Notes**

When opening a Pro Tools session or project, the Session Notes dialog provides a complete list of any mismatched Output bus mappings. In addition to being able to see this information and save it to a text file, you can also open the I/O Setup from the Session Notes dialog to resolve any unmapped Output busses.

![Session Notes with unmapped Output busses](image)

To open the I/O Setup from the Session Notes dialog:

1. If the Session Notes dialog reports unmapped bus paths, click the I/O Setup button.
2. In I/O Setup, reassign any unmapped bus paths as necessary.
3. Click OK to save your changes and close I/O Setup.
Pro Tools Session Templates and I/O Settings

Pro Tools session templates include the I/O Settings of the system on which the template was created. The I/O Settings selector is available when creating a new session from a template. This setting determines the configuration of the physical inputs and outputs of your system. The new session uses the busses from the selected template, but these busses are automatically mapped to the physical outputs of the system (the selected Playback Engine).
Chapter 7: System Setup

You can review and update the setup of your system to ensure it is configured for your needs.

**Starting Up or Shutting Down Your System**

To ensure that the components of your Pro Tools system communicate properly with each other, you need to start them in a particular order.

**Start up your Pro Tools system in this order:**

1. Make sure all your equipment (including your computer) is off.
2. Lower the volume of all output devices in your system.
3. For systems with an expansion chassis, turn on the chassis.
4. Turn on any external hard drives. Wait approximately ten seconds for them to spin up to speed.
5. Turn on any control surfaces (such as D-Command® or Avid Artist Control).
6. Turn on any MIDI interfaces, MIDI devices, or synchronization peripherals.
7. Do one of the following, depending on your Pro Tools system:
   - For HDX and HD Native systems, with the volume of all output devices lowered, turn on your audio interfaces (such as HD OMNI). Wait at least fifteen seconds for your system hardware to initialize.
   - For Pro Tools systems that use hardware requiring external power (such as 003), with the volume of all output devices lowered, turn on the hardware.
8. Turn on your computer.
9. Launch Pro Tools or any third-party audio or MIDI applications.

**Shut down your Pro Tools system in this order:**

1. Quit Pro Tools and any other running applications.
   - *To quit Pro Tools, choose Pro Tools > Quit (Mac) or File > Exit (Windows).*
2. Turn off or lower the volume of all output devices in your system.
3. Turn off your computer.
4 Do one of the following depending on your Pro Tools system:
   • For HDX and HD Native systems, turn off your Pro Tools audio interfaces.
   • For Pro Tools systems that use hardware requiring external power (such as 003), turn off the hardware.

5 For systems with an expansion chassis, turn off the chassis.

6 Turn off any MIDI interfaces, MIDI devices, or synchronization peripherals.

7 Turn off any worksurfaces (such as D-Command) or control surfaces (such as Command|8).

8 Turn off any external hard drives.

---

### Configuring Pro Tools Software System Settings

Pro Tools lets you adjust the performance of your system by changing system settings that affect its capacity for processing, playback, and recording. These system settings are available in the Playback Engine (Setup > Playback Engine).

In most cases, the default settings for your system provide optimum performance, but you may want to adjust them to accommodate large or processing-intensive Pro Tools sessions.

---

### Checking a Pro Tools | HDX or Pro Tools | HD Native System with DigiTest

Before you use Pro Tools, you may want to run the DigiTest diagnostic application to ensure that all HDX cards in the system are recognized, installed in the proper order, and have valid connections. You can also use DigiTest to validate your HD Native PCIe card or Thunderbolt interface. See the Avid DigiTest Guide for more information.
**Playback Engine**

In the Playback Engine dialog, Pro Tools lets you select the audio engine for use with your audio interfaces. The available options are determined by which audio interfaces are connected and have compatible drivers installed.

Changing the Playback Engine setting can be useful if you have multiple audio interfaces connected to your computer with different routing configurations in your studio, or if you want to prepare a session for use with a specific interface on a different system (for example, you might want to prepare a session created on your HDX system for use with the built-in audio on your Mac laptop).

To select which audio engine Pro Tools uses:

2. From the Playback Engine selector, select your audio interface:
   - For HDX and HD Native systems, use the default setting of HDX or HD Native.
   - For supported Avid audio interfaces (such as the Mbox Pro), selecting the name of the corresponding interface uses the Avid Audio Engine for Pro Tools.
   - For third-party audio interfaces with compatible Core Audio (Mac) or ASIO (Windows), select the name of the corresponding Core Audio (Mac) or ASIO (Windows) compatible audio interface.
   - On Mac systems, if you are using built-in audio, select any of the available built-in options for playback or select Pro Tools Aggregate I/O for simultaneous input and output with the built-in I/O hardware options.
3. Click OK.

When changing engines with a Pro Tools session open, Pro Tools closes and reopens the session to initialize the new engine.

On HDX systems, changing engines requires that you quit and relaunch Pro Tools for the new setting to take effect.

💡 When changing engines on any Pro Tools system, you may need to reset the default I/O settings to match the selected audio interface.

**Pro Tools Aggregate I/O**

(Mac Only)

On Mac systems using Core Audio, you can use Pro Tools with the built-in audio inputs and outputs on your Mac by selecting any of the available built-in inputs and outputs, or by selecting the Pro Tools Aggregate I/O option for using a combination of built-in inputs and outputs simultaneously (for recording and monitoring).

You can configure the Input and Output options for Pro Tools Aggregate I/O in the Mac Audio Setup, which can be accessed from the Pro Tools Hardware Setup.

💡 If you need simultaneous input (recording) and output (playback and monitoring) with Pro Tools using the built-in audio options on Mac, use the Pro Tools Aggregate I/O option. If you only need to play back audio for editing and mixing, select the appropriate built-in audio output option.
Hardware Buffer Size

The Hardware Buffer Size (H/W Buffer Size) in the Playback Engine controls the size of the buffer used to handle host processing tasks such as processing with host-based, or “Native” plug-ins.

- Lower Hardware Buffer Size settings are useful for improving latency issues in certain recording situations or for improving certain system performance problems:
  - On all Pro Tools systems, lower settings reduce MIDI-to-audio latency (such as when playing a virtual instrument live and monitoring the instrument’s output). Lower settings can also improve screen response or the accuracy of plug-in and mute automation data.
  - On host-based Pro Tools systems, lower settings reduce all input-to-output monitoring latency on any record-armed tracks or Auxiliary Input tracks with live inputs.
  - On HDX systems, lower settings reduce monitoring latency that occurs on tracks that have one or more Native plug-ins. Lower settings can also improve the accuracy of MIDI track timing on systems without a MIDI interface that supports time stamping. Lower settings also improve MIDI track timing on tracks using MIDI virtual instruments that do not support time stamping.
  - Higher Hardware Buffer Size settings are useful for sessions that are using more Native plug-ins for playback. These settings allow for more audio processing. They can also be useful to reduce errors on machines that require a higher buffer size.

To change the Hardware Buffer Size:

2. From the H/W Buffer Size pop-up menu, select the audio buffer size, in samples.
3. Click OK.

Host Engine

The Host Engine settings provide options for error suppression during playback and recording, and the option to use dynamic plug-in processing.

Ignore Errors During Playback/Recording

The Ignore Errors During Playback/Record option determines how Pro Tools responds to error reporting from the Avid Audio Engine (AAE) during playback and recording. This can be useful when working with instrument plug-ins where you care less about clicks and pops in the audio signal while you work on composing and arranging. Once you are ready to work on the final mix you should disable this option. Observe the following guidelines as to whether or not to enable or disable error suppression:

- Enable error suppression only if you are experiencing frequent errors that are interrupting your creative workflow. When error suppression is enabled, you can experience a degradation of audio quality. However, this may be acceptable in order to avoid interrupting playback and recording when working with instrument plug-ins.
- Disable error suppression when you need to ensure the highest possible audio quality, such as for a final mix.

To enable error suppression:

2. Select Ignore Errors During Playback/Record.
3. Click OK.
If the Ignore Errors During Playback/Record option is enabled and too many CPU intensive Native plug-ins are active in the session (such as Eleven Free or various virtual instrument plug-ins), you may experience badly distorted audio. If you encounter this problem, remove or make inactive any unnecessary Native plug-ins. You can also isolate and bus record any tracks that use virtual instruments, and then make those source tracks inactive to free up processing resources.

**Minimize Additional I/O Latency**  
(Host-based Pro Tools Systems Only)

When the Minimize Additional I/O Latency option is enabled, any additional latency due to ignoring errors during playback and recording is minimized to 128 samples. Ignoring errors requires at least 128 samples of additional buffering on some systems. If this option is disabled, the buffer is half the H/W Buffer Size, or at least 128 samples (whichever is greater). If you are using a slower computer, you may want to disable this option to avoid adverse performance.

This option is only available if the Ignore Errors During Playback/Record option is enabled and the Pro Tools system you are using requires additional buffering for error suppression, as follows:

- **Windows:**
  - Mbox Pro and Mbox 2 Pro
- **Mac:**
  - 003 family devices
  - Eleven Rack
  - Mbox family devices
  - Pro Tools Aggregate I/O

**Dynamic Plug-In Processing**

When enabled, the Dynamic Plug-In Processing option maximizes plug-in counts by dynamically reallocating host-based processing resources as needed. This means that plug-ins only use CPU cycles when they are actually processing audio.

**To enable dynamic plug-in processing:**

2. Select Dynamic Plug-In Processing.
3. Click OK.

**Number of Voices**  
(HDX Systems Only)

On HDX systems, the Number of Voices setting in the Playback Engine lets you control the number of available voices.

Changing the number of voices affects the total number of voiceable tracks.

Depending on the session sample rate and the number of HDX cards in your system, there are different choices for voice count. For voice limits on different HDX systems, see “Playback, Recording, and Voice Limits with Pro Tools | Ultimate Software” on page 42.

**To change the Number of Voices:**

2. Select a value from the Number of Voices pop-up menu.
3. Click OK.
Sample Rate
(HDX Systems Only)

The Sample Rate setting in the Playback Engine shows the default sample rate used when you create a new session. If a session is open, the current session sample rate is displayed, but cannot be changed. If no session is open, you can set the default sample rate for new sessions.

Video Engine

Enable the Video Engine option to import, edit, and playback a wide range of Avid HD and SD MXF video formats on Pro Tools video tracks without transcoding (including Avid DNxHD) as well as QuickTime video. With the Video Engine enabled you can simultaneously view desktop video and video monitored using a video peripheral (Media Composer | Nitris DX, Media Composer | Mojo DX, and other Avid qualified third-party video interfaces).

To enable the Avid Video Engine for Pro Tools:

1 Choose Setup > Playback Engine.
2 Select the Video Engine option.
3 Click OK.

Cache Size

The Cache Size setting in the Playback Engine determines the amount of memory AAE allocates to pre-buffer audio for playback and recording. In most cases, the default setting of Normal is the optimum Cache Size for most sessions.

Pro Tools can also load audio files used in Pro Tools sessions into RAM for cached playback. Pro Tools prioritizes files closest to the current play head location. This way, when you start playback, those files are already cached for playback. This is especially useful when working with shared media storage (such as with Avid Unity ISIS shared storage systems).

To determine the maximum amount of RAM available for the Disk Cache, Pro Tools polls the computer for the amount of RAM installed and subtracts 4 GB of RAM. For example, if your computer has 16 GB of RAM installed, the total amount of RAM available for the Disk Cache will be 12 GB.

💡 You can use the Disk Cache and Memory meters in the System Usage window to determine whether to assign more or less RAM to the Disk Cache for the current session. See “System Usage” on page 102.

To set the amount of RAM for use by the Disk Cache:

1 Choose Setup > Playback Engine.
2 From the Disk Cache selector, select the amount of RAM you want to allocate for Disk Cache.
3 Click OK.

Configuring MIDI Setup

If you plan to use any external MIDI devices with Pro Tools (such as controllers, keyboards, synthesizers, drum machines, samplers, sequencers, or sound modules), you may want to configure your MIDI setup using Audio MIDI Setup (Mac) or MIDI Studio Setup (Windows).

⚠️ For more information, see Chapter 10, “Configuring MIDI.”
Configuring Hardware Settings in Pro Tools

Pro Tools lets you configure the signal routing, digital I/O format, default sample rate, clock source, and other hardware-based settings depending on your system configuration. These system settings are available in the Hardware Setup (Setup > Hardware).

Selecting an Audio Interface to Configure

The Peripherals list in the Hardware Setup lets you select any audio interface connected to your Pro Tools system associated with the selected Current Engine setting in the Playback Engine dialog.

To change the Playback Engine setting to use a specific audio interface or AAE (such as HDX, 003, a third-party Core Audio or ASIO interface, or Pro Tools Aggregate I/O), see “Playback Engine” on page 91).

For Avid HD audio interfaces (such as HD OMNI or HD I/O) you can configure the signal routing, digital I/O format, default sample rate, clock source, and other hardware-based settings for each HD peripheral connected to your system.

For some Avid audio interfaces (such as 003), you can configure the signal routing, digital I/O format, default sample rate, clock source, and other hardware-based settings, depending on your system configuration.

For third-generation Mbox family audio interfaces, and third-party Core Audio (Mac) and ASIO (Windows) compatible audio interfaces, use the Launch Control Panel button to launch the control panel for configuring your specific audio interface.
Launch Control Panel or Setup App  
(Pro Tools with Avid Hardware or Third-Party Audio Interfaces with Control Panel Software)

Using the control panel or setup application for your audio interface, you can change settings in the following areas, depending on your audio interface:

- Mixer Settings
- Output Settings
- Hardware Settings (including sample rate, hardware buffer size, and sync source).

💡 You can set the sample rate when creating a new Pro Tools session by selecting a different sample rate in the New Session dialog.

To change control panel settings:

1. In the Hardware Setup dialog, click the Launch Control Panel button or Launch Setup App button (depending on your audio interface).
2. To change settings in the control panel or setup application, see the documentation that came with your audio interface.
3. When finished, close the control panel or setup application.

Configuring Pro Tools Aggregate I/O  
(Mac Only)

On Mac systems using Core Audio, you can select Pro Tools Aggregate I/O as the Current Engine to use the built-in audio inputs and outputs on your Mac computer. You can configure the Pro Tools Aggregate I/O setting in the Mac Audio Setup, which can be accessed from the Pro Tools Hardware Setup.

To configure Pro Tools Aggregate I/O settings:

1. Choose Setup > Hardware.
2. In the Peripherals list, select Pro Tools Aggregate I/O, or whichever Built-in input or output option is selected as the Current Engine in the Playback Engine.
3. Click the Launch Setup App button.
4. In the Audio Devices window of the Mac Audio Setup, configure the Pro Tools Aggregate I/O settings.

⚠️ The Pro Tools Aggregate I/O device is intended for use only with the built-in audio on your Mac computer. For best performance, use the default settings.
Configuring Default Sample Rate Setting in Hardware Setup

The Sample Rate setting in the Hardware Setup dialog determines the default sample rate when you create a new session. This setting is available only when there is no session open. Otherwise, the current session sample rate is displayed, but cannot be changed.

With HDX and HD Native hardware, you can change the default Sample Rate in the Hardware Setup, or in the Playback Engine.

⚠️ With HDX and HD Native hardware, the Sample Rate setting can affect the number of available voices.

On other Pro Tools systems, you can only change the default sample rate in the Hardware Setup or using the control panel for third-party audio interfaces.

💡 You can set the sample rate when creating a new Pro Tools session by selecting a different sample rate in the New Session dialog.

To change the default Sample Rate in the Hardware Setup:

2. Select the sample rate from the Sample Rate pop-up menu.
3. Click OK.

Configuring Clock Source

The Pro Tools Hardware Setup lets you select the Clock Source for the system.

💡 Changes made to Clock Source in the Session Setup window are reflected in the Hardware Setup window.

Internal If you are recording an analog signal directly into Pro Tools, you will usually use the Pro Tools Internal clock source.

External If you are transferring material into Pro Tools from an external digital device, or if you utilize a common house clock signal, you will synchronize Pro Tools to that digital device or common signal.

Depending on your audio interface, external options can include AES/EBU [Encl], S/PDIF, Optical [Encl], AES/EBU 1–8, TDIF, ADAT, and Word Clock. For details, see the guide for your audio interface.

To select the Clock Source:

1. Choose Setup > Hardware.
2. Choose the clock source from the Clock Source pop-up menu.
3. Click OK.

⚠️ Your digital input device must be connected and powered on for Pro Tools to synchronize to it. If your input device is not powered on, leave the Clock Source set to Internal.
Configuring Digital Format and Hardware Routing

The Hardware Setup includes additional settings for configuring the digital format and hardware routing for your system’s audio interfaces.

For an outline of the configuration of an HDX or HD Native system with one or more Pro Tools HD interfaces, see “Configuring Pro Tools | HDX and Pro Tools | HD Native Hardware Settings” on page 98.

Selecting Footswitch Control (003 Only)

The footswitch connector on your 003 family interface lets you use a footswitch pedal to control either playback start/stop or recording punch in/out. Both QuickPunch audio punch-in and punch-out and MIDI punch-in and punch-out recording are supported.

Record Punch In/Out Select this option to use a footswitch connected to your 003 family interface to punch in and punch out during recording.

Playback Start/Stop Select this option to use a footswitch connected to your 003 family interface to start and stop playback.

Configuring Pro Tools | HDX and Pro Tools | HD Native Hardware Settings

On HDX and HD Native systems, you configure Hardware settings for each audio interface connected to your system (see Chapter 5, “Pro Tools Systems.”)

HDX and HD Native systems can have HD I/O, HD OMNI, HD MADI or Pro Tools | MTRX audio interfaces connected to HDX cards or HD Native hardware. HD I/O, HD OMNI, and MTRX can also have additional interfaces attached using the Expansion port on each interface.

Identifying Audio Interfaces

If you have multiple audio interfaces of the same type connected to your system, before you make audio connections to them, you should confirm the identity of each interface. This ensures that you choose the appropriate interface in the Peripherals list when you define its inputs and outputs in the Hardware Setup.

To identify audio interfaces in your system:

1 Choose Setup > Hardware.

2 From the Peripherals list, select an audio interface connected to your system.

3 Use the Up and Down Arrow keys to scroll through the Peripherals list in the Hardware Setup.

4 Make sure the Main page is shown.
4 Select the Identify option, located in the lower left corner of the Hardware Setup. This illuminates all the LEDs on the front panel of the selected audio interface.

5 Make a note of which interface in your studio setup corresponds to the identified interface.

6 Repeat the above steps for each additional audio interface in your setup.

**Configuring Avid HD Audio Interfaces**

HD OMNI supports up to eight channels of simultaneous I/O and multiple I/O formats (such as analog, AES/EBU, ADAT Optical, and S/PDIF).

HD I/O audio interfaces support sixteen channels of simultaneous I/O and multiple I/O formats (such as analog, AES/EBU, ADAT Optical, S/PDIF, and TDIF). HD MADI supports up to 64 channels of MADI I/O.

The Main page of the Hardware Setup is where you define which physical inputs and outputs on your audio interface are routed to available inputs and outputs in Pro Tools. You can think of this window as a patchbay that allows you to route any of the inputs or outputs on your audio interfaces to channel assignments in the Pro Tools mixer.

Additional pages are available to configure other controls for each audio interface (such as setting operating levels).

**To configure Avid HD audio interfaces:**

1 Choose Setup > Hardware.

2 From the Peripherals list, select the audio interface connected to the first card in your system. This will be the interface at the top of the list.

3 Click the Main tab.

4 From the Clock Source pop-up menu, select the appropriate clock source for the interface.

In many cases, you will use Internal. The other choices are for resolving Pro Tools to external clock sources. Depending on your audio interface, Clock Source options can include: AES/EBU [Encl], S/PDIF, Optical [Encl], AES/EBU 1–8, TDIF, ADAT, and Word Clock (optional Word Clock rates are available when operating at higher sample rates).

5 If you want to send clock output to other devices attached to the audio interface, select the appropriate output from the Ext. Clock Output pop-up menu.

6 Select which digital I/O port on your audio interface enclosure is active by selecting the corresponding option under Digital Format. Depending on the type of interfaces in your system, choices include AES/EBU, S/PDIF, and Optical (S/PDIF). Selecting Optical (S/PDIF) resets the Optical I/O port (which is, by default, eight channels of ADAT Optical I/O) to two channels of S/PDIF Optical I/O.

Press Command+Left or Right Arrow keys (Mac) or Control+Left or Right Arrow keys (Windows) to move through the different pages of the Hardware Setup.
7 For S/PDIF compatibility with Tascam DA-30 DAT recorders, select the Tascam option under S/PDIF Format.

8 From the Input and Output channel pop-up menus, select the physical ports (such as Analog 1–2 or Optical 1–2), that will be routed to the corresponding Pro Tools input and output channels (such as Ch 1–2, Ch 3–4), listed on the left side of the Main page.

Inputs and outputs of similar format are differentiated in the input and output channel pop-up menus. For example, the AES/EBU inputs and outputs in the HD I/O enclosure are listed as AES/EBU [Encl], while the AES/EBU inputs and outputs on the factory-installed Digital I/O card are listed (in pairs) as AES/EBU 1–2, AES/EBU 3–4, AES/EBU 5–6, and AES/EBU 7–8. For HD I/Os equipped with a second Digital I/O Card, the additional AES/EBU I/O ports on the optional card are listed as AES/EBU 9–10, AES/EBU 11–12, AES/EBU 13–14, and AES/EBU 15–16.

9 Configure any specific controls for your audio interface:
   • “Configuring HD OMNI Controls” on page 100.
   • “Configuring HD I/O Controls” on page 101.
   • “Configuring HD MADI Controls” on page 102.

10 For additional audio interfaces, select them in the Peripherals list, and repeat the above steps.

💡 See your audio interface guide for additional configuration details and restrictions.

---

### Configuring HD OMNI Controls

For detailed information about configuring HD OMNI, see the HD OMNI Guide.

To configure HD OMNI in Pro Tools:

1 Choose Setup > Hardware.

2 From the Peripherals list, select the HD OMNI audio interface.

3 Click the Monitor tab and configure the options. When working with HD OMNI, you should always configure the Monitor page first.

[Image: HD OMNI Hardware Setup, Monitor page]

4 Click the Main tab and configure the options.

[Image: HD OMNI Hardware Setup, Main page]
5 Click the Analog In tab and configure the options.

6 Click the Analog Out tab and configure the options.

7 Click the Mixer tab and configure the options.

8 When you are finished, click OK.

---

**Configuring HD I/O Controls**

For detailed information about configuring HD I/O, see the HD I/O Guide.

To configure controls for HD I/O:
1 Choose Setup > Hardware.
2 From the Peripherals list, select the HD I/O audio interface.
3 Click the Main tab and configure the options.
4 If you have at least one HD I/O AD card, click the Analog In tab and configure the options. If you have two HD I/O AD cards, this tab is labeled Analog In 1–8.
5 If you have two HD I/O AD cards, click the Analog In 9–16 tab and configure the options.

6 If you have at least one HD I/O Digital card, click the Digital tab and configure the options.

7 If you have two HD I/O Digital cards, click the second Digital tab and configure the options.

8 When you are finished, click OK.

Configuring HD MADI Controls

For detailed information about configuring HD MADI, see the HD MADI Guide.

To configure controls for HD MADI:

1 Choose Setup > Hardware.

2 From the Peripherals list, select either HD MADI Port 1 or HD MADI Port 2 and configure the options.

3 When you are finished, click OK.

System Usage

Meters in the System Usage window indicate how much of your system’s processing power is being used when processing audio, and when writing and playing back automation.

As these meters approach their limits, host processing and recording or playback of automation data can be affected. If CPU or PCI Activity are high, a system error may occur. If Disk Activity is high, Pro Tools may miss playback of some automation data during particularly dense periods of activity, such as while using the Bounce to Disk command.

Configuring MTRX Controls

MTRX is configured using MTRX Control software. For information about configuring MTRX, see the Pro Tools | MTRX Guide.

For detailed information about configuring HD MADI, see the HD MADI Guide.

HD MADI Hardware Setup

The settings for HD MADI Port 1 and HD MADI Port 2 are linked. Any changes are global regardless of which is selected in the Peripherals list.

3 When you are finished, click OK.
CPU Meters

The CPU Total meter displays session performance for Elastic Audio processing, Clip Gain processing, and Native plug-in and mixer processing. A 3-second peak indicator provides visual indication of peak CPU usage.

The individual CPU meters provide a general indication of how much Pro Tools is using each of the processors in your computer.

Activity Meters

The Activity section of the System Usage window display meters for disk usage and memory usage.

Disk Meter

As in previous versions of Pro Tools, the Disk meter displays the amount of hard disk processing activity.

The Disk Cache meter indicates the amount of allocated memory being used to cache audio in the timeline (up to the amount of RAM selected for the Disk Cache setting in the Playback Engine). An additional peak-meter style indicator is included to show how much of the allocated RAM is needed for caching the session.

Memory Meter

The Memory meter displays how much of the installed physical RAM in the system is being used by Pro Tools. This includes RAM used by the audio engine, the video engine (if enabled), plug-ins, and the disk cache. Other than Pro Tools, it does not show any other RAM usage by the system. If the Memory meter approached 100%, install more physical RAM or lower the Disk Cache setting in the Playback Engine dialog.
DSP Usage Meters
(HDX Systems Only)

HDX systems provide additional meters below the Activity meter.

Voices

The Voices meter displays the total number of voices that can be allocated and the number of voices currently allocated. This includes all voices whether they are allocated explicitly or dynamically, as well as any voices used for routing host-based processing.

Time Slots

The Time Slots meter displays the total number of DSP Time Slots available and the number of DSP Time Slots currently used.

DSP

The DSP meters display how much of each DSP chip on each HDX card is currently being used for mixer configurations and DSP-based plug-ins.

Managing System Resources

To monitor the usage of resources during a Pro Tools session:

- Choose Window > System Usage.

To reduce processing load, do one of the following:

- Reduce the density of automation in places where it shows the most activity. For details, see “Thinning Automation” on page 1150.
- Make unnecessary track inputs and outputs inactive. For details, see “Making Track Inputs and Outputs Inactive from the Edit or Mix Window” on page 251.
- Make unnecessary tracks inactive. For details, see “Making Tracks Inactive” on page 259.
- Make unnecessary DSP plug-ins inactive. For details, see “Making Inserts Inactive” on page 1096.
Chapter 8: Preferences

The settings in the Pro Tools Preferences define how Pro Tools features work. The Preferences dialog has several tabbed pages in which you can specify your preferred settings.

To change Pro Tools preferences:
1. Choose Setup > Preferences.
2. Click the tab for the page that has preferences you want to change.
3. Change preferences.
4. Click OK to save your changes and close the Preferences dialog.

Basics Section

Track Position Numbers Stay with Hidden Tracks When selected, tracks keep their track numbers even when hidden. When not selected, numbers are only assigned to tracks that are shown. In this case, shown tracks are then numbered sequentially, and hidden tracks are not numbered.

Tool Tips Display Options

Function Configures Tool Tips to show the basic function of the item.

Details Configures Tool Tips to show the complete form of an abbreviated name or item (such as a track name). Details view can also show the hidden or abbreviated value of parameters, as well as input and output assignments.

Edit Window Default Length

This preference sets a default length for the Edit window in hours, minutes, seconds, and frames (Pro Tools Ultimate only). This is useful if you want to assemble a session of a particular length or leave extra room to expand the Edit window’s work area in your session. The maximum length is 24 hours. For best scrollbar sensitivity, set the length to slightly longer (a minute or more) than the total session or song length.
“Organize Plug-In Menus By” Options

These options determine how plug-in menus are organized in the Insert selector or Plug-In selector.

**Flat List** Organizes plug-ins in a single list, in alphabetical order.

**Category** Organizes plug-ins by process category (such as EQ, Dynamics, and Delay), with individual plug-ins listed in the category submenus. Plug-Ins that do not fit into a standard category (such as the Signal Generator), or third-party plug-ins that have not had a category designated by their developers, appear in the Other category. Plug-Ins can appear in more than one category.

**Manufacturer** Organizes plug-ins by their manufacturer (such as Bomb Factory, Focusrite, or TL Labs), with individual plug-ins listed in the manufacturer submenus. Plug-Ins that do not have a Manufacturer defined will appear in the “Other” manufacturer folder.

**Category and Manufacturer** Organizes plug-ins in two levels of menus. The top menus display plug-ins by process category (such as EQ, Dynamics, and Delay), with individual plug-ins listed in the category submenus. The bottom menus display plug-ins by manufacturer (such as Bomb Factory, Focusrite, or TL Labs), with individual plug-ins listed in the manufacturer submenus.

“Organize Track I/O Menus By” Options

These options determine how track I/O menus are organized in the Track Input selector, and Send and Track Output selectors.

**Type** Displays only the I/O Type (Interface or Bus) as I/O categories in Track I/O menus.

**Width** Displays only the I/O Channel Width (such as stereo or 5.1) as I/O categories in Track I/O menus.

**Type and Width** Displays both Type and Width as I/O categories in Track I/O menus.

**Language Options**

You must have Administrator privileges for the Pro Tools application Properties to change these options.

**Language** Sets the language to use in the Pro Tools application, independently of what language is used by your OS.

**Default Automatic Naming to English** Causes automatically named session elements in a session to be named in English even when working with the Pro Tools application set to another language.

**Auto-Switch Input Language**

When the Auto-Switch Input Language option is enabled, the input language is switched automatically from English to the current OS input language when entering text. It automatically switches back to English for using Keyboard commands in Pro Tools. When disabled, English is used when entering text regardless of the current OS input language.
**Warnings and Dialogs Section**

**Reset “Don’t Show This Again” Settings** If you have made any changes by selecting the Don’t Show This Again setting for any dialog in Pro Tools, you can click this Reset button to revert to the default settings.

**Show Dashboard Window When Pro Tools Starts** When selected, Pro Tools shows the Dashboard window on launch. Deselect this option if you do not want to see the Pro Tools Dashboard window on launch.

**Color Coding Section**

**Always Display Marker Colors** Lets you choose to view Marker colors in the Markers ruler, regardless of the settings you choose for Default Clip Color Coding.

**MIDI Note Color Shows Velocity** When enabled, MIDI notes display varying shades of the assigned track color in MIDI notes view in the Edit window and in MIDI Editor windows. Notes with high velocities are darker and notes with lower velocities are lighter.

**Default Track Color Coding Options**

These color coding options determine the default color coding assignment for tracks in the Edit and Mix windows. The options are:

- **None** Turns off color assignment for tracks.
- **Tracks and MIDI Channels** Assigns a color to each track in the Mix or Edit window according to its voice or MIDI channel assignment.
- **Tracks and MIDI Devices** Assigns a color to each track in the Mix or Edit window according to its voice assignment or MIDI device assignment.
- **Groups** Assigns a color to each track according to its Group ID. If groups are suspended using the Suspend Groups command, the tracks color bars are not shown.
- **Track Type** Assigns a color to each track according to its type (audio, Auxiliary Input, Master Fader, VCA Master, MIDI, Instrument, or Video).

**Default Clip Color Coding Options**

These color coding options determine the default color coding assignment for tracks, Marker Locations, and clips residing in the track playlist and Clips List. The options are:

- **None** Turns off color assignment for clips. Clips are drawn with black waveform or MIDI notes on a light gray background.
- **Tracks and MIDI Channels** Assigns a color to each clip in the Edit window according to its voice or MIDI channel assignment.
- **Tracks and MIDI Devices** Assigns a color to each clip in the Edit window according to its voice assignment or MIDI device assignment.
- **Groups** Assigns a color to each clip according to the Group ID of its track. If groups are suspended using the Suspend Groups command, all clips display black waveforms or MIDI notes on a light gray background.
- **Track Color** Assigns a clip color based on the color assigned to the track.
- **Marker Locations** Assigns a unique color to each marker area in the Marker ruler, including the area preceding the first marker.
- **Clips List Color** Assigns a color to each clip based on its color in the Clips List.
**Operation Preferences**

**Transport Section**

**Timeline Insertion/Play Start Marker Follows Playback** When selected, the Timeline Insertion and the Play Start Marker both move to the point in the Timeline where playback stops. When deselected, the Timeline Insertion and Play Start Marker do not follow playback, but return to the location where playback began.

Press Control+N (Mac) or Start+N (Windows) to toggle the Timeline Insertion/Play Start Marker Follows Playback preference on and off.

**Edit Insertion Follows Scrub/Shuttle** When selected, the edit cursor automatically locates to the point where scrubbing stops.

**Audio During Fast Forward/Rewind** When selected, audio is audible during fast forward or rewind.

**Latch Forward/Rewind** When selected, fast forward and rewind latch and continue until you press Stop, Play, Return To Zero, or Go To End on the Transport. When disabled, the Fast Forward and Rewind only last as long as you hold the mouse after clicking either button on the Transport (or hold the corresponding switch on a Control Surface).

**Play Start Marker Follows Timeline Selection** When enabled, the Play Start Marker snaps to the Timeline Selection In Point when you move the Timeline Selection, draw a new Timeline Selection, or adjust the Timeline Selection Start. When disabled, the Play Start Marker doesn’t move with the Timeline selection.

**Reserve Voices for Preview in Context (HDX and HD Native Only)** When enabled, Pro Tools reserves the appropriate number of voices for preview in context (previewing audio files from Workspace browsers during session playback).

The number of available voices is reduced by the channel width of the selected audition paths on the Output page of the I/O Setup window. For example, if the number of playback voices is set to 48 in the Playback Engine, and you have a stereo audition path selected in the I/O Setup, only 46 voices will be available for tracks. If you have a 5.1 audition path, only 42 voices will be available. When this option is disabled, you will not be able to preview in context if there are not enough available voices.

**Custom Shuttle Lock Speed** Sets the highest fast-forward Shuttle Lock speed (key 9) for Shuttle Lock modes (Classic or Transport).

The range for this setting is 50–800%.

For more information, see “Custom Shuttle Lock Speed” on page 625.

**Custom FF/REW Speed** Sets the speed for fast forward and rewind in relation to normal playback.

The range for this setting is 100–3,200%.
**Back/Forward Amount (Pro Tools | Ultimate Only)** Sets the default length of Back, Back and Play, Forward and Forward and Play. The timebase of the Back/Forward Amount settings follows the Main Time Scale by default, or you can deselect the Follow Main Time Scale option and select another timebase format: Bars|Beats, Min:Sec, Timecode, Feet+Frames, or Samples.

**Numeric Keypad Mode**

Numeric Keypad mode determines how the numeric keypad functions. You can always use the numeric keypad to select and enter values in the Event Edit Area, Edit Selection indicators, Main and Sub Counters, and Transport fields.

**Classic** Selects a Shuttle Lock mode that emulates the way Pro Tools worked in versions lower than 5.0. With the Numeric Keypad mode set to Classic, you can play up to two tracks of audio in Shuttle Lock mode. Press Control (Mac) or the Start key (Windows), followed by 0–9 for different play speeds. Press Plus (+) or Minus (–) to reverse direction. Recall Memory Locations by typing the Memory Location number, followed by Period (.)

**Transport** Selects a Shuttle Lock mode that lets you set a number of record and play functions, and also operate the Transport from the numeric keypad. With the Numeric Keypad mode set to Transport, you can play up to two tracks of audio in Shuttle Lock mode. Press Control (Mac) or the Start key (Windows), followed by 0–9 for different play speeds. Press Plus (+) or Minus (–) to reverse direction. Recall Memory Locations by typing the Memory Location number, followed by Period (.)

**Shuttle (Pro Tools | Ultimate Only)** Selects a type of shuttling different from that of Shuttle Lock mode. With the Numeric Keypad mode set to Shuttle, playback is triggered by pressing and holding the keys on the numeric keypad—playback stops once the keys are released. Various playback speeds are available in both forward and reverse. You can also recall Memory Locations by typing Period (.), the Memory Location number, and Period (.) again.

**Use Separate Play and Stop Keys**

When enabled, this option lets you start playback with the Enter key and stop playback with the 0 key on the numeric keypad. This is useful for quickly starting and stopping playback when auditioning loop transitions. The Use Separate Play and Stop Keys option is only available in Transport Numeric Keypad mode.

⚠️ When this option is enabled, it overrides using the Enter key to add Memory Location markers. Instead, press Period (.) and then Enter on the numeric keypad to add a Memory Location marker.

**Auto Backup Section**

**Enable Session File Auto Backup** When selected, Pro Tools automatically saves backups of your Pro Tools session file while you work. Backups are saved to in the Session File Backups folder in your session folder.

**Keep # Most Recent Session Backups** Specifies the total number of incremental backups that are kept for sessions (backups for projects are handled separately by Revision History).

**Backup Every** Specifies how often the session is saved.

---

To customize the highest fast-forward Shuttle Lock speed, see “Custom Shuttle Lock Speed” on page 625.
User Media and Settings Location

Documentation and Settings
Click the Change button to set the Root directory for all user files including Documentation, Grooves, IO Settings, Plug-In Maps, Plug-In Settings, Session Templates, and Video Test Patterns.

Project Media Cache
Click the Change button to set the Root directory for caching all project media.

Sound Libraries
When Pro Tools is installed, any included audio loops are stored in the Sound Libraries folder by default:

Mac
Macintosh HD/Users/<username>/Documents/Pro Tools/Sound Libraries

Windows
C:UsersUSERNAMEDocumentsPro ToolsSound Libraries

Click the Change button to direct Pro Tools to reference another location for the Sound Libraries folder and Loops content.

Show Sound Libraries in Workspace Locations
Enable the Show Sound Libraries in Workspace/Locations option to show Sound Libraries in the Locations pane of Workspace browsers.

Record Section

Latch Record Enable Buttons When selected, multiple audio tracks can be record-enabled. When not selected, multiple audio tracks cannot be record-enabled. Record-enabling an audio track takes all other audio tracks out of record-enabled mode.

Enable Automation in Record When this option is enabled, automation can be written during recording as well as during playback. When this option is disabled, automation can only be written during playback.

Note that when the Enable Automation in Record option is selected, the Link Record and Play Faders option is automatically disabled and is unavailable.

Link Record and Play Faders When selected, Pro Tools does not remember separate fader levels for tracks when they are record-enabled, allowing you to maintain the same monitoring level for tracks during recording and playback.

Audio Track RecordLock (Pro Tools | Ultimate Only) This option configures Pro Tools tracks to either emulate a digital dubber, or to maintain legacy behavior for track record status.

• When selected, the record-enabled audio tracks remain record-enabled when playback or recording stops.
• When not selected, record-enabled audio tracks are taken out of record enable when Pro Tools is stopped. This prevents tracks from remaining armed from pass to pass, emulating track record behavior of a digital dubber.
**Transport RecordLock (Pro Tools | Ultimate Only)** This option lets the Transport Record (the Record button in the Transport controls) be configured to either emulate a digital dubber, or to maintain legacy behavior for the Transport master Record.

- When selected, the Transport Record remains armed when playback or recording stops. This saves having to re-arm the Transport between takes, emulating digital dubber behavior.
- When not selected, the Transport Record disarms when Pro Tools is manually stopped or stops due to a loss of timecode. This replicates standard Pro Tools recording behavior.

The Transport RecordLock option is automatically disabled and grayed out when Destructive Record mode is enabled.

**Disable “Input” When Disarming Track (In “Stop”) (Pro Tools | Ultimate Only)** For flexibility, TrackInput monitoring can be customized to remain selected regardless of track record status, or to automatically switch to Auto Input monitoring after a recording pass. This lets you optimize monitoring for a typical dubbing workflow (in which you might want tracks to remain in Input Only mode until explicitly switched to Auto Input monitoring) or a typical music tracking workflow (in which leaving a track in Input Only monitoring mode after recording can result in accidental double-monitoring).

- When selected, taking an audio track out of record enable (any mode) takes it out of Input Only mode, regardless of the global monitor mode, and switches it to monitor audio from disk only.
- When not selected, audio tracks remain in Input Only monitoring mode until explicitly switched to Auto Input monitoring.

**Mute Record-Armed Tracks While Stopped (Pro Tools | Ultimate Only)** This setting determines monitor status of record-armed tracks.

- When selected, Pro Tools mutes all record-enabled tracks when the transport is stopped. Input can still be monitored while stopped using the TrackInput Monitor button.
- When not selected, Pro Tools does not mute audio input on record-enabled tracks when the transport is stopped.

**PEC/Direct Style Input Monitoring (Pro Tools | Ultimate Only)** This option changes the way the TrackInput monitoring mode is indicated on-screen (and on supported control surfaces) to emulate “PEC” (playback) and “Direct” (input/bus) indication on some large format consoles.

- When not selected, the TrackInput button shows the letter “I.” The button remains gray to indicate Auto Input mode and lights green to indicate Input Only mode.
- When selected, the TrackInput button remains gray and shows the letter “D” to indicate Input Only mode (“Direct”); it lights green and shows the letter “P” to indicate Auto Input mode (“Pec” or playback).

**Automatically Create New Playlists When Loop Recording** When selected, copies loop recorded alternate takes to new playlists in the track. This is especially useful to prepare for track compositing in Playlists view after loop recording multiple alternate takes.

**Online Options**

**Record Online at Timecode (or ADAT) Lock** When selected, online recording begins as soon as Pro Tools receives and locks to incoming timecode.
**Record Online at Insertion/Selection** When selected, online recording begins at the edit cursor location. Recording continues until Pro Tools stops receiving timecode. If you make a selection, Pro Tools records online for the length of the selection.

**DestructivePunch File Length (Pro Tools | Ultimate Only)**

This preference sets the duration of consolidated audio files when preparing tracks for Destructive-Punch mode. The default value for this setting is 25 minutes.

**Misc (Miscellaneous) Section**

**Mouse Wheel Scrolling Snaps to Track**

The Operations page of the Preferences window includes a new Mouse Wheel Scrolling Snaps to Track option. When this option is enabled, the top of tracks in the Edit window snap to fit as you scroll with the mouse wheel and tracks in the Mix window snap to the left. When this option is disabled, scrolling with the mouse wheel is smooth and continuous.

**Tip** Press Control (Mac) or Start (Windows) while scrolling the mouse wheel to accelerate scrolling tracks vertically in the Edit window or horizontally in the Mix window.

**Tip** Press Command (Mac) or Control (Windows) while scrolling the mouse wheel to slow down scrolling tracks vertically in the Edit window or horizontally in the Mix window.

**Clip Auto Fade In/Out Length (Pro Tools | Ultimate Only)**

This setting determines the default length for fade-ins and fade-outs that are automatically applied to clip boundaries on playback. Using automatic fade-ins and fade-outs saves you the trouble of editing to zero-crossings or creating numerous rendered fades in order to eliminate clicks or pops in playback. Autofades are not written to disk. Value range is from 0–10 ms for the Auto Clip Fade In/Out Length setting. A value of zero means that no auto-fading will occur. The Auto Fade value is saved with the session, and is automatically applied to all free-standing clip boundaries until you change it.

**Calibration Reference Level (HDX and HD Native Systems Only)**

This setting determines a default calibration reference level in dB when Pro Tools is in Calibration mode. For audio interfaces that have trims (such as the HD I/O), see the interface’s guide for calibration instructions.

💡 If your system includes one or more EUCON controllers, be sure to disable “Auto-bank to selected track” in EuControl software before enabling Pro Tools Calibration Mode to ensure that faders remain silent. To make sure “Auto-bank to select track” is not enabled, open the EuControl Settings window, click to go to the General tab, and verify the setting is not enabled. If necessary, click to disable “Auto-bank to selected track.” After exiting Calibration Mode, be sure to re-enable the “Auto-bank to selected track” setting (if necessary).
Most Recent Local Waveform Cache Versions
(Pro Tools | Ultimate Software Only)

The Local Waveform Cache Versions preference determines whether or not one or more copies of the Waveform cache are stored locally for sessions on network storage systems (such as Avid NEXIS).

Keeping a short history of the Waveform cache stored locally can greatly speed up opening sessions on network storage. Rendering tasks and redrawing waveforms are also quicker when the Waveform cache is stored locally.

A setting of 0 means that no local Waveform cache is stored and the Waveform cache is only saved on the network storage system. A setting of 1 always only saves the most recent version of the Waveform cache locally and deletes the previously locally saved Waveform cache. You can store up to 99 versions of the Waveform cache locally. When the designated number of versions to be stored locally is exceeded creation of a new Waveform cache, the oldest locally stored Waveform cache is deleted.

The local Waveform cache (if any) is saved to the Documents/Pro Tools/Local Waveform Cache folder on your system drive.

Video Section

Enable GPU

Pro Tools video processing is done on the GPU (Graphics Processing Unit) in order to free up the CPU for Pro Tools audio and MIDI. If you are using a slower GPU and encounter poor video playback, you may want to disable this option and have the video processing done on the CPU.

Prevent Tearing

When enabled, Pro Tools buffers video to prevent visual artifacts with horizontal movement in situations where video sync does not match the screen refresh rate. This option is not available when the Enable GPU option is disabled.

Enable Hardware During Scrub

When selected, the Enable Hardware During Scrub option lets you monitor video using video hardware (such as Avid Mojo DX or Nitris DX video peripherals) while scrubbing. When this option is disabled, you can only monitor video in the Pro Tools Video window while scrubbing. If you experience performance issues when scrubbing video while monitoring video using video hardware, disable this option.

Play Start Latency

If you are working on a slower computer, set the Play Start Latency setting to a higher value. The range is from 1-Shortest to 5-Longest.

Editing Preferences

Clips Section

Clips List Selection Follows Edit Selection

When selected, selecting a clip in a track also selects it in the Clips List.
Edit Selection Follows Clips List Selection When selected, selecting a clip in the Clips List causes Pro Tools to highlight that clip’s occurrence in a track.

Auto-Name Separated Clips When selected, Pro Tools automatically names newly separated clips by appending a number to the clip’s name.

“Separate Clip” Operates On All Related Takes When selected, editing a clip with the Separate Clip command also affects all other related takes (recording passes) with the same User Time Stamp. This option helps you compare different sections from a group of related takes.

Send Fully Overlapped Clips to Playlist while Editing Whenever a whole clip is fully overlapped by another clip when editing it is moved from the main playlist to a new playlist (or the first available, empty playlist). This is true for editing on all playlists, not just the main playlist.

Send Fully Overlapped Clips to Playlist while Recording Whenever a whole clip is fully overlapped by another clip when recording it is moved from the main playlist to a new playlist (or the first available, empty playlist).

Clip Gain Nudge Value This setting specifies the amount (from 0.1 dB to 6.0 dB) by which clip gain settings are adjusted when nudging clip gain.

Clip Matching Options Lets you assign number keys 1–5 to control either Zoom Presets or Clip Effects Presets. Press Control+1–5 (Mac) or Start+1–5 (Windows) to recall the corresponding preset in your session or project for the selected option. If Commands Keyboard Focus is also enabled in the Edit window, just press the number for the preset you want (1–5).

Press Command+Control+1–5 (Mac) or Control+Start+1–5 (Windows) to apply the number keys to the opposite of what is set for the 1–5 Number Keys Control preference (for example, if Zoom Presets is selected, these key combinations would apply to Clip Effects Presets instead). If Commands Keyboard Focus is enabled for the Edit window, press Command+1–5 (Mac) or Control+1–5 (Windows).

Tracks Section

New Tracks Default To Tick Timebase When selected, all new tracks default to ticks. When deselected, audio, Auxiliary Input, Master Fader, and VCA tracks default to samples.

Suppress Name Dialog When Creating New Playlists Enable this option to automatically name new playlists without opening the Name New Playlist dialog. This applies when creating both new of duplicate playlists.

Show Target Playlist(s) After Sending Clip Selection Enable this option to show Target playlist(s) in the Main playlist after moving or copying an Edit selection to that playlist.

Memory Locations Section

Auto-Name Memory Locations When Playing When selected, Pro Tools gives new Memory Locations default names based on their time location in the session. The time units currently chosen in the View menu determine the units for the names.

Recall Memory Location at Original Track When selected, Memory Locations that recall a selection also recall the track in which the selection was made.
**Fades Section**

**Crossfade Preview Pre-Roll** This setting specifies the amount of pre-roll to be added when you are auditioning crossfades in the Fades dialog.

**Crossfade Preview Post-Roll** This setting specifies the amount of post-roll to be added when you are auditioning crossfades in the Fades dialog.

**QuickPunch/TrackPunch Crossfade Length**

Specifies a default length for crossfades created by QuickPunch or TrackPunch (Pro Tools Ultimate only) recordings. Crossfades occur before the punch in and after the punch out.

**Preserve Fades when Editing** This option preserves fade-ins and fade outs, and converts separated crossfades into corresponding fade-ins and fade-outs.

**Auto Accept Adjust Bounds** This option automatically adjusts fade boundaries without presenting the Invalid Fades dialog.

**Smart Tool Fade Adjustment**

Determines whether adjusting fade and crossfade shapes in the Edit window using the Smart Tool is always on or if it requires that you also use the Command key (Mac) or the Control key (Windows) to adjust fades and crossfades with the Smart Tool (see “Adjusting Fade Shapes with the Smart Tool in the Edit Window” on page 683).

**Always On** Adjust fade and crossfade shapes in the Edit window using the Smart Tool.

**Requires Command Key (Mac) or Requires Control Key (Windows)** adjust fade and crossfade shapes in the Edit window using the Smart Tool only when the Command key (Mac) or Control key (Windows) is pressed.

**Default Fade Settings**

**Fade In** Selects the default envelope shape for fade-ins when using the Smart Tool.

**Fade Out** Selects the default envelope shape for fade-outs when using the Smart Tool.

**Crossfade** Selects the default envelope shape for crossfades when using the Smart Tool.

**REX** Selects the default envelope shape for fades and crossfades between clips (“slices”) in imported REX files.

**Zoom Toggle Section**

**Vertical Zoom** Selects either Selection or Last Used for the Zoom Toggle Vertical Zoom setting.

**Horizontal Zoom** Selects either Selection or Last Used for the Zoom Toggle Horizontal Zoom setting.

**Remove Range Selection After Zooming In** When selected, the current Edit selection collapses into an insertion point after zoom toggling in. Zoom toggling back out reverts to the previous selection.

**Track Height** Selects Last Used, Medium, Large, Extreme, or Fit To Window for the Zoom Toggle Track Height setting.

**Track View** Selects Waveform/Notes, Warp/Notes, Last Used, or No Change for the Zoom Toggle Track View setting.
Separate Grid Settings When Zoomed In When selected, the Grid setting stored with Zoom toggle is recalled when zoom toggling in. When this option is deselected, the same (current) grid setting is used whether zoom toggling in or out.

Zoom Toggle Follows Edit Selection When selected, zoom toggle automatically follows the current Edit selection. When disabled, changing the Edit selection has no affect on the currently toggled-in track.

Levels of Undo
This preference sets the maximum number of actions that can be undone with the multiple undo feature. Setting this to a lower number can speed up the performance of slower computers. Pro Tools supports up to 64 levels of Undo.

Mixing Preferences

**Setup Section**

**Sends Default to –INF** When selected, the initial fader level of newly-created sends is set to \(-\infty\) (no audible signal level). When not selected, the initial fader level of newly-created sends is set to 0 dB.

**Send Pans Default to Follow Main Pan** When selected, newly created sends have Follow Main Pan turned on, so the Send Pan controls follow the pan controls of the track. When not selected, newly created sends have Follow Main Pan turned off.

**Use Absolute Pan Linking (Pro Tools | Ultimate Only)** This option affects behavior of grouped pan controls.

- When selected, grouped pan controls do not maintain relative offsets when any of the grouped pan controls is adjusted. All grouped pan controls snap to the absolute value of the adjusted control.

- When not selected, grouped pan controls maintain relative offsets when any of the linked controls is adjusted.

**Allow Sends to Persist During LLM (CoreAudio, ASIO, and HD Native Systems Only)** All plug-ins and sends are bypassed by default when Low Latency Monitoring (LLM) is enabled (Options > Low Latency Monitoring). Enable the Allow Sends to persist during LLM option to maintain audio signal output for sends when using Low Latency Monitoring.

**Default EQ**
This preference lets you choose any installed EQ plug-in as the default, which makes it available for quick assignment, both on-screen and on ICON controllers (Pro Tools Ultimate only). On-screen, the plug-in appears at the top of the Insert selector pop-up menu. On ICON controllers, the plug-in appears first in the list of menu choices on the rotary encoders.
**Insert Slot** The specified Insert slot (none, or a–j) is used (if it is available) when inserting the default EQ plug-in from a S6 control surface. If the specified slot is not available, the next available plug-in slot is used. When None is selected, S6 control surfaces insert the selected default plug-in in the first available insert slot.

**Default Dynamics**

This preference lets you choose any installed Dynamics plug-in as the default, which makes it available for quick assignment, both on-screen and on ICON controllers (Pro Tools Ultimate only). On-screen, the plug-in appears at the top of the Insert selector pop-up menu. On ICON controllers, the plug-in appears first in the list of menu choices on the rotary encoders.

**Insert Slot** The specified Insert slot (none, or a–j) is used (if it is available) when inserting the default Dynamics plug-in from an EUCON control surface. If the specified slot is not available, the next available plug-in slot is used. When None is selected, EUCON control surfaces insert the selected default plug-in in the first available insert slot.

**Auto Insert Default Plug-Ins from EUCON Surfaces** When selected, the default EQ and default Dynamics plug-ins are automatically available when creating new tracks from EUCON surfaces.

**Controllers Section**

**Edit Window Follows Bank Selection** If you are using a supported control surface with Pro Tools, this option scrolls the Edit window to display the selected bank of tracks when you switch banks on the control surface, ensuring that the current bank is viewable on-screen.

**Mix Window Follows Bank Selection** If you are using a supported control surface with Pro Tools, this option scrolls the Mix window to display the selected bank of tracks when you switch banks on the control surface, ensuring that the current bank is viewable on-screen.

**“Scroll to Track” Banks Controllers** When using a control surface (such as D-Control) you can select this option to bank control surface faders to a numbered track when using the Scroll to Track command.

**Always Fill Channel Strips When Banking** If you are using an ICON controller (Pro Tools Ultimate only), or other supported control surface, you can select this option to maximize the number of channels displayed when banking. This setting optimizes the Bank commands to prevent the display of a small number of channels at the extremes of the surface.

**Touch Timeout** If you are writing automation in Touch mode and you stop moving a non-touch sensitive fader or encoder, Pro Tools continues to write automation for the Touch Timeout value.

After the Touch Timeout period, writing of automation stops and the automation data returns to its previous automation value at the rate specified in the AutoMatch Time setting.

**EUCON Surfaces EQ Dyn cycling Starting at Insert (S6 Consoles Only)** Lets you specify the starting slot for EQ/Dyn cycling with S6 consoles to optimize EQ and Dyn cycling (via repeated pressing of the EQ or Dyn switches) to start from either a specific slot, or from the most recently cycled slot. Choose <none> to have Pro Tools begin cycling from most recently cycled slot.
Automation Section

Smooth and Thin Data After Pass When selected, Pro Tools automatically smooths and then applies the specified amount of thinning to the automation data created in an automation pass.

Degree of Thinning Specifies the amount of thinning performed on automation data when you use the Thin Automation command, or if you have selected the Smooth and Thin Data After Pass option.

Plug-In Controls Default to Auto-Enabled When selected, all applicable controls of newly added plug-ins are enabled for automation. When not selected, the controls of newly added plug-ins must be manually enabled for automation.

Suppress Automation “Write To” Warnings (Pro Tools | Ultimate Only) When selected, Pro Tools suppresses the warnings that appear after invoking any of the Write Automation To Start, Selection, End, or Punch commands and then stopping the transport.

Latching Behavior for Switch Controls in “Touch” This option determines the behavior of switch-type controls (such as mute or plug-in bypass) when writing automation in Touch mode.

- When selected, controls in Touch mode will latch in their current state. If an existing breakpoint is encountered, writing of automation stops. If the transport is stopped while writing, the control will AutoMatch to the underlying value.
- When not selected, controls in Touch mode will not latch.

Allow Latch Prime in Stop (Pro Tools | Ultimate Only) When selected and any tracks are in Latch mode, any automation-enabled controls on those tracks can be set to new values while the transport is stopped by touching or moving controls, to prepare for the next automation pass.

Coalesce when Removing Slaves from VCA Group This option determines the behavior when removing slave tracks from a VCA-controlled group.

- When selected, any automation on the VCA Master is automatically coalesced (without confirmation) to its slave tracks when the tracks are removed from the group.
- When not selected, a confirmation dialog lets you choose whether or not to coalesce the VCA Master automation to the slave tracks.

Standard VCA Logic for Group Attributes This option determines which Mix group attributes may be selected in the Group dialog when the group is assigned to a VCA Master.

- When selected, the Main Volume, Mute, Solo, Record Enable, and Input Monitoring controls on slave tracks follow the VCA Master only and are not available to be independently linked. (This emulates the behavior of analog console VCA masters.)
- When deselected, the Main Volume, Mute, Solo, Record Enable, and Input Monitoring controls follow the VCA Master, but also remain available for independent linking with groups.

Include Sends in Trim Mode (Pro Tools | Ultimate Only) This option determines the Trim status of Send faders when a track is put in Trim mode.

- When selected, Send faders go into Trim mode along with the Main Volume fader.
- When deselected, the Main Volume fader goes into Trim mode, but the Send fader stays in the corresponding standard Automation mode.
Include Control Changes in Undo Queue  This option determines whether certain mixer control changes, such as moving a fader or pan control, are entered into the Undo queue.

- When selected, mixer control changes appear in the Undo queue, and are undone if any prior operation is undone.
- When deselected, mixer control changes will not appear in the undo queue, allowing you to undo other types of operations without losing the current mixer settings.

Any set to default operations that affect mixer controls will be entered into the Undo queue.

AutoMatch Time  If you are writing automation in Touch mode, when you release a fader or control, writing of automation stops and the automation data returns to its previous value. The rate of return to the previous value is the AutoMatch Time.

AutoGlide Time (Pro Tools | Ultimate Only)  Specifies how quickly Pro Tools transitions (glides) from one automation value to another, when AutoGlide mode is used.

After Write Pass, Switch To Options  These options select the Automation mode that Pro Tools tracks automatically switches to after an automation pass in Write (or Write Trim) mode. Select one of the following options:

- **Touch**  Switches to Touch mode after an automation pass in Write (or Write Trim) mode.
- **Latch**  Switches to Latch mode after an automation pass in Write (or Write Trim) mode.
- **No Change**  Stays in Write mode after an automation pass in Write (or Write Trim) mode.

After an automation pass in Write Trim mode, tracks automatically switch to the Trim version of the specified setting.

Coalesce Trim Automation Options (Pro Tools | Ultimate Only)  These options determine when Trim automation is committed to the main automation playlist on a track.

After Every Pass  Sets Trim automation to coalesce when the transport is stopped at the end of each Trim automation pass. No Composite Playlist is indicated.

On Exiting Trim Mode  Sets Trim Automation to coalesce on a track when the track is taken out of Trim mode. A Composite Playlist can be viewed before committing Trim moves.

Manually  Trim Automation can be coalesced only with the Coalesce Trim Automation command. A Composite Playlist can be viewed before committing Trim moves.

Delay Compensation Section

Delay Compensation Time Mode  When Delay Compensation is enabled (Options > Delay Compensation), this option lets you choose whether information in the Delay Manager is displayed in milliseconds or samples.

Compensate Side Chains (HDX Systems Only)  When Delay Compensation is enabled (Options > Delay Compensation), this option applies Delay Compensation to plug-in sidechain signals.
Metering Preferences

Track and Master Meter Types

The Track Meters section of the Mixing preferences let you set the Meter Type and associated metering ballistics and displays settings for audio, Auxiliary Input, and Instrument tracks. The Master Meters sections let you configure these settings independently for Master Fader tracks.

Track and Master Meter Types Linked

Enable the Track and Master Meter Types Linked option to ensure that Track (audio, Auxiliary Input, and Instrument tracks) and Master (Master Fader) meters always use the same Meter Type setting. Disable this option if you want the Track and Master meters to use different Meter Type settings (for example, you may want to use VU metering for your Track meters, but Peak for your Master meters).

Pro Tools lets you choose from several industry standard meter types for visually monitoring audio levels. You can link the Track (audio, Auxiliary Input, and Instrument tracks) and Master (Master Fader) meter settings, or you can set them independently of one another. The following Meter Type options are available:

Sample Peak Provides the default Pro Tools metering. The scale and the decay time is calculated in dB/second, which results in slower decay in metering compared to lower versions of Pro Tools. The Sample Peak option is the only Meter Type that has a 0 sample integration time, and as such shows all dynamic activity of the digital signal at every moment in time.

Pro Tools Classic Provides legacy Pro Tools scale and metering ballistics.

Linear Use Linear for post-production and music mixing scenarios. Using a fast decay time, Linear provides direct one-to-one linear metering of sample peaks in the audio signal with a metering range down to –40 dB. This offers higher metering resolution closer to 0 dB (which can be particularly useful for mixing and mastering).

Linear (Extended) Provides the same ballistics as Linear, but the meter scaling extends to –60 dB.

RMS Provides metering ballistics that display the average loudness (Root Mean Square of the signal) over a range of time. Peak metering, on the other hand, displays the peak signal level at any given point in time.

VU Popular for music and dialog mixing, the VU scale used in Pro Tools is extended on the low end from –23 dB to –40 dB to accommodate a wide range of material without the need for stage re-calibration.
Digital VU Provides VU ballistics with a modern digital scale.

PPM Digital Popular in Europe and Asia with broadcasters, and also with US Film consoles (such as the Avid System5 consoles), PPM Digital has a similar integration time to Sample Peak metering, but different scales and decay times.

The PPM Digital option, like all other Meter Type options besides Sample Peak, does not report every transient (such as a series of very fast transients). However, even though it under-reports the actual digital dynamic range, it more closely matches human hearing of loudness over time.

PPM BBC Adopted by commercial broadcasters in the UK, BBC scaling uses 4 dB spacing between scale marks. Other organizations around the world, including the EBU, CBC, and ABC used the same dynamics but with slightly different scales.

PPM Nordic A Scandinavian variant of the DIN PPM has the same integration and return times but a different scale, with “TEST” corresponding to Alignment Level (0 dBu) and +9 corresponding to Permitted Maximum Level (+9 dBu). Compared to the DIN scale, the Nordic scale is more logarithmic and covers a somewhat smaller dynamic range.

PPM EBU Is a variant of the British PPM designed for the control of program levels in international program exchange (Type Iib PPM in IEC 60268-10). It is identical to the British PPM (BBC) except for the meter scale. The meter scale is calibrated in dB relative to the Alignment Level, which is marked “TEST.” There are ticks at 2 dB intervals and at +9 dB, which corresponds to the Permitted Maximum Level.

PPM DIN Used in German broadcasting, the nominal analog signal corresponding to Permitted Maximum Level was standardized by ARD at 1.55 volts (+6 dBu), and this is the usual sensitivity of a DIN-type PPM for an indication of 0 dB. The Alignment Level (−3 dBu) is shown on the meter by a scale mark at −9.

K-12 The K-scales are RMS based scales with an integrated sample peak meter as a secondary value. K-Scales are popular with music mixers that are looking for a meaningful indication of overall loudness. K-12 should be reserved strictly for audio to be dedicated to broadcast, though broadcast recording engineers may choose K-14 if they feel it fits their program material.

K-14 Use K-14 for mastering when working in a calibrated mastering suite.

K-20 Using K-20 during mix encourages a clean-sounding mix that is advantageous to the mastering engineer. At that point, the producer and mastering engineer should discuss whether the program should be converted to K-14, or remain at K-20. If mixing to analog tape, work at K-20, and realize that the peak levels off tape will not exceed about +14.

VENUE Peak Provides the same ballistics as Sample Peak, but with VENUE meter scaling to +20 dB.

VENUE RMS Provides the same ballistics as RMS, but with VENUE meter scaling to +20 dB.
Advanced Meter Type Settings

The Advanced Meter Type settings let you adjust the scale and ballistics of the selected Meter Type. These settings update automatically to match the specifications of the selected Meter Type. In some system configurations you may want to make manual adjustments to these settings in order to ensure that Pro Tools metering matches the meter response your broadcast console (some broadcast consoles use variations from the standard Meter Types that are provided in Pro Tools). However, in most cases these settings should be left at the default values.

Decay

The Decay settings determine the decibel range (dBs) that the meters fall at the specified rate in seconds after peak level is registered. For some Meter Types, these settings are not adjustable (such as VU).

0 dBFS

The 0 dBFS setting determines the unity reference level for the meter scale in decibels compared to digital 0 dB. Exceeding this level should result in clipping at the digital to analog converters or to the specified clipping level for broadcast. For some Meter Types, this setting is not adjustable (such as K-meters).

Integration Time

The Integration Time setting determines the amount of time it takes, in milliseconds, to average the peak level as registered on the meter display. You can think of this as the attack time for registering peak levels on the meters. For some Meter Types, this setting is not adjustable (such as Peak).

Color Break High

The Color Break High setting determines the high point in dB where the color changes for metering. Typically, this will be the ceiling level for the current Meter Type. When this level is exceeded clipping will occur. Levels registering on the meters between the Color Break High setting and the Color Break Low setting should be considered the “sweet spot” for the loudness of the program material.

Color Break Low

The Color Break Low setting determines the low point in dB where the color changes for metering. Typically, this will be the minimum level for the current Meter Type. Use this setting to provide a visual indication in the meters for the lowest level of the dynamic range of the program material for the intended delivery format (such as film, DVD, CD, MP3, or broadcast).

Reset

Click the Reset button to reset the Advanced Meter Type preferences to the default settings for the selected Meter Type.

Peak/Clip Section

Peak Hold Options

These options determine how long the peak indicators on track meters stay lit after a peak is detected.

3 Seconds When selected, track meters display the last peak level for three seconds.

Infinite When selected, track meters display the last peak level until you click them to clear them.

None When selected, track meters do not hold the peak level.
Clip Indication Options

These options determine how long the clip indicators on plug-in, send, and track meters stay lit after a clip is detected.

3 Seconds When selected, meters display the last clip indication for three seconds.

Infinite When selected, meters display the last clip indications until you click them to clear them.

None When selected, meters do not hold the clip indication.

Display Section

The Display section of the Metering preferences provides options for configuring the display of the new Gain Reduction meters on tracks and in sends.

Show Send Assignment Level Meter

Enable the Show Send Assignment Level Meter option to show Level meters in Sends Assignments on audio, Auxiliary Input, and Instrument tracks in the Mix window. When this option is disabled, level meters are not displayed in Send Assignments on tracks.

Show Track Gain Reduction Meter

Enable the Show Track Gain Reductions Meter option to show Gain Reduction meters in tracks on audio, Auxiliary Input, Instrument, and Master Fader tracks in the Mix window. Note that even when this option is enabled, Gain Reduction meters are only displayed for those tracks with supported dynamics plug-in inserted. When this option is disabled, Gain Reduction meters are not displayed in Insert Assignments on tracks.

Gain Reduction Meter Type

The Gain Reduction Meter Type settings determine which dynamics processing plug-ins display Gain Reduction meters on audio, Auxiliary Input, Instrument, and Master Fader tracks in the Mix window. Note that even Gain Reduction Meters are only displayed for those tracks with supported dynamics plug-in of the corresponding type inserted.

Compressor/Limiter When selected, only gain reduction applied by Compressor/Limiter plug-ins on tracks are displayed in the gain reduction meter.

Expander/Gate When selected, only gain reduction applied by Expander/Gate plug-ins on tracks are displayed in the gain reduction meter.

Priority Compressor/Limiter When selected, if a Compressor/Limiter is inserted on a track, only gain reduction applied by Compressor/Limiter plug-ins is displayed in the gain reduction meter. However, if no Compressor/Limiter plug-in is on a track, any gain reduction applied by other dynamics processing plug-ins on the track is displayed on that track.
Priority Expander/Gate When selected, if an Expander/Gate plug-in is inserted on a track, only gain reduction applied by Expander/Gate plug-ins is displayed in the gain reduction meter. However, if no Expander/Gate plug-in is on a track, any gain reduction applied by other dynamics processing plug-ins on the track is displayed on that track.

All – Summed When selected, the sum of all gain reduction applied on a track by dynamics plug-ins inserted on that track is displayed in the gain reduction meter.

Processing Preferences

AudioSuite Section

Default Handle Length

The Default Handle Length options let you set the default length for AudioSuite and clip gain handles.

Whole File When enabled, AudioSuite and clip gain rendering renders the whole file referenced by the selection or clip.

Length This setting lets you specify the default Handle Length (from 0.00 to 60.00 seconds) for AudioSuite and clip gain rendering. AudioSuite and clip gain rendering renders the selection plus any additional available audio up to the specified Handle Length.

Import Section

Convert Imported “WAV” Files To AES31/BroadcastWave When selected, this option applies to all newly imported WAV files, making them compliant with the AES31/EBU Broadcast standard.

Automatically Copy Files on Import When selected, all audio files that are imported by dragging and dropping are copied to the current session’s Audio Files folder, regardless of whether the files need to be converted to the current session’s file type, bit depth or sample rate. Additionally, when selected, the Copy from Source Media option is automatically enabled in the Import Session Data dialog. The Automatically Copy Files on Import preference does not affect the Import Audio command.

Convert Copied Files to Session Format When selected, files that have different file formats from the current session file format are copied and converted to the current session audio file format on import. For example, if the session file format is WAV and you import an AIF, the files is copied and converted to WAV on import. When this option is not selected, copied files retain their original format (unless that file format is incompatible with Pro Tools, in which case it must be converted).

Do Not Convert Sample Rate on Import When selected, files with different sample rates than the session sample rate are not automatically converted when imported into the session. This means that files with mis-matched sample rates playback at a different speed (and pitch transpositions than when they were originally recorded (or converted).
Import REX Files as Clip Groups When selected, REX files are imported as clip groups, all the underlying slices are imported as individual clips contained within the clip group. When this option is not selected, importing REX files into a session converts them to the session’s audio file format, the individual slices are consolidated, and the slice information is used for Elastic Audio analysis. These files remain tick-based after import and conversion.

Automatically Create Fades When selected, crossfades are applied automatically to the sliced clips within clip groups created by importing REX files. If the Import REX Files as Clip Groups option is not selected, the Automatically Create Fades option is not available.

To change the default fade settings for REX files, click the REX button in the Default Fade Settings section on the Editing Preferences page.

Drag and Drop From Desktop Conforms to Session Tempo

The Drag and Drop From Desktop Conforms to Session Tempo options determine whether or not REX, ACID, and audio files are imported as tick-based Elastic Audio and conform to the session tempo.

No Files When enabled, REX and ACID files, and all other audio files are not conformed to the session tempo when imported by drag and drop from Windows Explorer or the Mac Finder. They are imported as sample-based files and converted to the sessions audio file format.

REX and ACID Files Only When enabled, only REX and ACID files are conformed to the session tempo when imported by drag and drop from Windows Explorer or the Mac Finder. REX files are imported either as tick-based Elastic Audio or, if the Import REX Files as Clip Groups option is enabled, as tick-based clip groups.

All Files When enabled, all audio files (including REX and ACID files) imported by drag and drop from Windows Explorer or the Mac Finder are imported as tick-based Elastic Audio and conform to the session tempo.

Sample Rate Conversion Quality

The Sample Rate Conversion Quality pop-up menu lets you select the default sample rate conversion quality for importing audio files by drag and drop from any Workspace browser, or Windows Explorer or Mac Finder. The higher the quality of sample rate conversion you select, the longer Pro Tools will take to process the audio file.

Commit Section

Rendered File Bit Depth

The Rendered File Bit Depth options determine the bit depth of new audio files created using the Track Commit command.

Always Use 32-bit When selected, new audio files created using Track Commit command are 32-bit files regardless of the session bit depth.

Follow Session Settings When selected, new audio files created using Track Commit command are the same bit depth as the session.

TC/E (Time Compression/Expansion) Section

TC/E Plug-In Lets you select the plug-in used for Time Compression and Expansion when you edit audio with the Time Compression/Expansion Trim tool. This Trim tool works by using Time Compression/Expansion to match an audio clip to the length of another clip, a tempo grid, a video scene, or other reference point. The Time Shift plug-in is selected by default.
**Default Settings** Specifies the default settings used by the chosen Time Compression/Expansion plug-in.

**Elastic Audio Section**

These preferences determine Elastic Audio usage and settings on new tracks, as well as for previewing and importing tick-based audio.

**Default Plug-In** Lets you select any Real-Time Elastic Audio plug-in as the default for previewing and importing Elastic Audio. The selected default Elastic Audio plug-in is also used when new tracks are created with the **Enable Elastic Audio on New Tracks** option enabled.

**Default Input Gain** Lets you attenuate the signal input to Elastic Audio plug-ins by 0 to –6 dB for preview and import. If you experience clipping due to Elastic Audio processing during preview or after import, you may want to set the Default Input Gain to slightly attenuate the audio signal input for Elastic Audio processing. This preference also applies to any audio imported to an Elastic Audio-enabled track.

The Elastic Properties window inherits the Default Input Gain setting. To apply further clip-based input gain attenuation for Elastic Audio processing, select the clip and adjust the Input Gain setting in the Elastic Properties window (see “Elastic Properties Window” on page 988).

**Enable Elastic Audio on New Tracks** When selected, new tracks are created with Elastic Audio enabled. The selected default Elastic Audio plug-in is used.

—if the Enable Elastic Audio on New Tracks option is selected, you may want to also select the New Tracks Default to Tick Time-base option in the Editing Preferences page.

**DSP Management Section**

These preferences determine DSP management behavior for converting DSP plug-ins to Native and also for the HEAT software option.

**Open Unresourced DSP Plug-Ins as Native (HDX Systems Only)** When this option is enabled, any DSP plug-ins that exceed the available DSP processing are converted to Native format plug-ins wherever possible. When this option is disabled, any DSP plug-ins that exceed the available DSP processing are made inactive.

**Enable HEAT in New Sessions** When enabled, new sessions are created with HEAT enabled for all audio tracks. When disabled, HEAT is disabled in new sessions by default. This option is only available if the HEAT software option is installed. For more information, see Chapter 47, “HEAT.”

**Miscellaneous Section**

**Parallel Task Optimization** (Pro Tools | Ultimate Software Only)

The Parallel Task Optimization preference lets you select the optimal possible number of parallel processing tasks that can happen at the same time on your computer. Relevant factors include how many core processors your computer has, how fast the processors are, how fast or how fragmented your hard drives are, how fast your network storage connection is, and so on. The optimal possible number of parallel processing tasks is usually proportional to the number of core processors in your computer.

Affected parallel processing tasks include:

- Waveform calculation
- File indexing
- Rendering Clip Gain, Clip Effects, and Elastic Audio
Compare different settings to see what works best with your system.

**Off** Only a single task is processed at a time

**Low** Up to 4 tasks can be processed simultaneously

**Med** Up to 6 tasks can be processed simultaneously

**High** Up to 8 tasks can be processed simultaneously

When working with an Avid NEXIS network storage system, select the optimal setting for your network connection as follows:

**Low** 1 Gb Connection

**Med** Dual 1 Gb Connection

**High** 10 Gb Connection

### Basics Section

**Remove Range Selection After Opening the MIDI/Score Editor** When selected, the MIDI Editor and Score Editor open with no Edit selection. When this option is disabled, the MIDI Editor and Score Editor open with the current Edit selection intact.

**Use MIDI to Tap Tempo** When enabled, you can tap a MIDI keyboard to enter a new tempo value into a tempo field.

**Display Events as Modified by Real-Time Properties** When enabled, Pro Tools displays the effects of Real-Time Properties in the Edit, MIDI Editor, and Score Editor windows, and the MIDI Event List.

**Use F11 Key for Wait for Note** When enabled, pressing the F11 Function key puts MIDI recording in Wait for Note mode.

**Automatically Create Click Track in New Sessions** When enabled, Pro Tools automatically creates a new click track in new sessions.

**Default Thru Instrument**

This option lets you set the default MIDI Thru instrument. You can select a predefined device from your available MIDI instruments, or select First Selected MIDI Track to use the assigned MIDI output of the first selected MIDI or Instrument track. When multiple MIDI or Instrument tracks are selected, the instrument in the selected track that is closest to the top of the Edit window (or closest to the left edge of the Mix window) is used. Select None to only route MIDI Thru record enabled MIDI and Instrument tracks.
Pencil Tool Resolution When Drawing Controller Data

This option lets you set the default resolution for MIDI controller data created with the Pencil tool. Setting this to a lower resolution helps avoid creating controller data that is unnecessarily dense. The value range is from 1 to 100 milliseconds.

Global MIDI Playback Offset

This option lets you set an offset in samples to compensate for MIDI latency. Entering a value here has the same effect as setting an offset with the MIDI Track Offsets command. Offset values can be positive (later) or negative (earlier).

Double-Clicking a MIDI Clip Opens

This option lets you specify what happens when you double-click MIDI clips with the Grabber tool.

MIDI Editor Opens the MIDI clip in a MIDI Editor window.

Score Editor Opens the MIDI clip in the Score Editor window.

MIDI Event List Opens the MIDI clip in the MIDI Event List.

Name Dialog Opens the Name dialog for the MIDI clip.

MIDI Merge Release Mode

MIDI Merge Release mode determines how Pro Tools writes MIDI CC data when recording MIDI in MIDI Merge mode.

Latch Continues writing the last value. Any existing events are overwritten until you stop recording.

Latch Until Next Event Continues writing the last value until the next event even if you are still recording.

Touch Immediately stops writing any new values (only use this mode to add pedal-based control data, not to modify existing data).

Note Display Options

These options set the reference for middle C as C3, C4, or MIDI note number 60.

Delay Compensation for External Devices Options

These options only apply when a Delay Compensation Engine is selected in the Playback Engine and Delay Compensation is enabled in Pro Tools. These options are distinct from the hardware offsets available for hardware inserts in the I/O Setup.

MIDI Timecode When selected, Pro Tools applies Delay Compensation to Pro Tools-generated MIDI Timecode (MTC). Enable this option when synchronizing video to Pro Tools using MTC.

MIDI Beat Clock When selected, Pro Tools applies Delay Compensation to Pro Tools-generated MIDI Beat Clock.

MIDI Notes and Controllers When selected, Pro Tools applies Delay Compensation to MIDI notes and MIDI controller data. This is useful when monitoring playback or when recording input from external MIDI devices.

MIDI/Score Editor Display

Additional Empty Bars in the Score Editor

This setting lets you specify the default number of empty bars that appear in the Score Editor window after the end of the last MIDI clip in the session.
Collaboration Preferences

New Tracks Are Shared When enabled, new tracks are automatically shared when they are created.

First Invite Shares All Tracks When enabled, all tracks are automatically shared when you invite anyone to join your project.

Joining Project Downloads All Shared Tracks When enabled, all shared tracks in the project are automatically downloaded when you join a project.

Enable “Track Notes” Dialog When enabled, the Track Notes dialog is presented whenever opening a project that reports information such as mismatched I/O Settings or missing plug-ins and so forth. When this option is disabled, the Track Notes dialog is suppressed when opening a project even there are reportable discrepancies.

Automatically Download New Shared Tracks When enabled, any new remote shared tracks are automatically downloaded.

Synchronization Preferences

Machine Control Section

Machine Chases Memory Location When selected, navigating to a specific location in a session with a Memory Location causes a connected transport to chase to that location.

Machine Follows Edit Insertion/Scrub When selected, navigating to a specific location in a session by moving the selection point or by scrubbing a track will cause a connected transport to chase to that location.

When the connected device is a linear device (such as a tape deck), select Linear Devices (jog) to set Pro Tools to send jog commands.

When the connected device is a non-linear device (such as a random-access video recorder or another Pro Tools system), select Non-Linear Devices (cue) to set Pro Tools to send cue commands.
Machine Cues Intelligently (HDX and HD Native Systems Only) When selected, if you navigate to a cue point that is more than 10 seconds from the current location, Pro Tools will command a connected transport to fast wind to the new location at full speed to within 10 seconds of the cue point. Cueing will then slow to normal speed until the point is reached. This can significantly speed up tape cueing with certain video transports.

Stop at Shuttle Speed Zero (HDX and HD Native Systems Only) Causes Pro Tools to send a Stop command whenever you stop shuttling. This is useful if you have a machine that requires an explicit stop command to park correctly.

Non-Linear Transport Error Suppression (HDX and HD Native Systems Only) When Transport = Pro Tools, keeps Pro Tools from sending a Stop command when taken offline. This prevents Pro Tools from stopping any other 9-pin devices connected to the system.

Synchronization Section

Minimum Sync Delay Sets the initial amount of prime time (in frames) your system’s devices need to achieve synchronization “lock.” This amount varies for each device. Pro Tools lock up delay is set by entering a value for Minimum Sync Delay in the Synchronization page of the Preferences. The lowest value available is 15 frames. Find the shortest possible lock-up time that your equipment can operate at consistently, and set this as the Minimum Sync Delay. On systems using MachineControl, enabling the Use Serial Timecode option will make machines lock up much faster. (Serial timecode requires both a qualified synchronization peripheral and external devices to be locked to house video reference.)

Remote Mode Section

Ignore Track Arming Sets Pro Tools to ignore incoming track arming (record enable) commands. This is useful if you are using a master controller to arm tracks on other machines, but you do not want to arm tracks in Pro Tools.

Set Servo Lock Bit at Play Enable this option when using a synchronizer to control Pro Tools in Remote mode to minimize lock-up times during recording.

Allow 9-Pin Track Arm Commands in Local Mode Sets Pro Tools to respond to incoming track arming (record enable) commands even when the system is not in Remote mode. This is useful if you are using a paddle device to control Pro Tools track arming or punching.

Allow 9-Pin Transport Commands in Local Mode Sets Pro Tools to respond to incoming transport commands even when the system is not in Remote mode. This is useful when using Satellite Link in conjunction with a 9-pin controller. You can receive the transport controls from the 9-pin controller, but not experience the lag-time associated with a 9-pin device.
**Punch In Frame Offset** Sets an offset (in frames) to compensate for punch in timing advances or delays.

**Punch Out Frame Offset** Sets an offset (in frames) to compensate for punch out timing advances or delays.

**Delay After Play Command** Sets the amount of time (in frames) for Pro Tools to wait after receiving a Play command before starting the audio engine. This can prevent false starts when locking to synchronizers that are not fully supported by Pro Tools.

**Satellites Section** *(HDX and HD Native Systems Only)*

Satellite Link lets you link up to 12 Pro Tools HD systems, or 11 Pro Tools HD systems and an Avid Video Satellite (Media Composer or Avid Symphony Nitris DX) or a Pro Tools Video Satellite system, over an Ethernet network so that you can cue, play, and stop the transport, make play selections, and solo tracks across any of the systems from any linked workstation.

**Transmit Solos** Causes a linked Pro Tools system to send the solo status of its tracks to all other linked Pro Tools systems. On other linked systems that are set to receive solos, tracks follow solo behavior as if the solo were on the local system.

**Receive Solos** Causes a linked Pro Tools system to receive solos from all other linked Pro Tools systems that are set to transmit play selections. Tracks on the receiving system follow solo behavior as if the solos were on the local system.

**Solo Independent of Linked State** Causes a Pro Tools system to send the solo status of its tracks to other satellite systems even when it is unlinked. This allows control of solo status across systems even when transport control is not enabled.

**AAE Errors Stop All Linked Systems** Causes an AAE error on any linked Pro Tools system to stop the transport on all linked systems. When this option is not selected, linked systems will not stop if an AAE error occurs on one system.

**Transmit Play Selections** Causes a linked Pro Tools system to send the Edit window selection to all other linked Pro Tools systems. On other linked systems that are set to receive play selections, the selection is mirrored in the Edit window.

**Receive Play Selections** Causes a linked Pro Tools system to receive Edit window selections from all other linked Pro Tools systems that are set to transmit play selections.

**Global and Local Preferences**

Pro Tools preferences are either global (system-wide) or local (for the current session or project only).

**Global (System-Wide) Preferences** Global preferences are applied to all sessions. These preferences become the default preferences for any existing sessions that you subsequently open or any new sessions that are created.

**Local (Current Session) Preferences** Local preferences are applied to the current session (if one is open). Local preferences are not applied to older sessions that are subsequently opened.

**Preferences and New Sessions**

New sessions use global preference settings, plus the most recent local preference settings. The most recent local settings refer to the last open session (unless subsequent changes were made in the Preferences from the application window).
**Local (Session or Project Only) Preferences**

All Preferences are global (system-wide), except for the following, which are local:

- **Display Preferences**
  - Edit Window Default Length
  - Always Display Marker Colors
  - Default Track Color Coding options
  - Default Clip Color Coding options

- **Operation Preferences**
  - Latch Forward/Rewind
  - Custom Shuttle Lock Speed
  - Custom FF/REW Speed
  - Back/Forward Amount (Pro Tools Ultimate only)
  - PEC/Direct Style Input Monitoring (Pro Tools Ultimate only)
  - DestructivePunch File Length (Pro Tools Ultimate only)
  - Clip Auto Fade In/Out Length (Pro Tools Ultimate only)
  - Delay Comp Time Mode
  - Compensate side chains (HDX systems only)

- **Editing Preferences**
  - None

- **Mixing Preferences**
  - Coalesce When Removing Slaves from VCA Group (Pro Tools Ultimate only)

- **Metering Preferences**
  - None

- **Processing Preferences**
  - Convert Imported “WAV” Files To AES31/BroadcastWave

- **MIDI Preferences**
  - Display Events as Modified by Real-Time Properties
  - Automatically Create Click Track in New Sessions
  - Default Thru Instrument
  - Pencil Tool Resolution When Drawing Controller Data
  - Delay for External Devices Options

- **Synchronization Preferences**
  - None
Chapter 9: Peripherals

The settings in the Peripherals dialog define how Pro Tools works with various audio, synchronization and controller devices, as well as with VENUE systems.

To configure settings for Pro Tools peripherals:

1. Choose Setup > Peripherals.
2. Click the tab for the type of peripheral you want to configure.
3. Change the settings.
4. Click OK to save your changes and close the Peripherals dialog.

Synchronization

The Synchronization page lets you configure Pro Tools for use with MIDI Timecode and a synchronization peripheral.

For information about synchronization peripherals, see the SYNC HD Guide.
MTC Reader and Generator

The MIDI Timecode (MTC) settings let you select the MIDI In and Out ports for MTC.

MTC Reader Port The MTC Reader Port setting lets you select the MIDI In port to which the MTC slave device is connected (the source of MTC information from the slave device).

MTC Generator Port The MTC Generator Port setting lets you select the MIDI Out port to which the master device is connected (this the destination of MTC information from Pro Tools).

Synchronization Device (HDX and HD Native Systems Only)

The Synchronization Device settings let you configure a synchronization peripheral (SYNC HD).

Enable SYNC Peripheral

When this option is selected, any connected synchronization peripheral is enabled for use with Pro Tools.

Current Firmware Version

This displays the firmware version for the connected synchronization peripheral, such as a SYNC HD.

VITC Insertion Enabled

When this option is selected, VITC is inserted into the outgoing video signal—assuming that a video signal is present at a synchronization peripheral video input, and that the synchronization peripheral is in a valid mode for inserting VITC.

Pitch Memory Enabled

When this option is selected, the synchronization peripheral will remain at a *pitch* (sample rate) that corresponds to the last known incoming timecode speed. When deselected, the Synchronization peripheral reverts to the selected sample rate. If Pitch Memory is disabled and the selected external clock reference is not available, then the synchronization peripheral reverts to the nominal, selected internal sample rate setting.

Idle MTC Enabled

When this option is selected, MTC is continuously output. When not enabled, MTC output is muted when playback is idle.

LTC Output Level

This setting adjusts the analog audio level of the LTC output, from –24 dBu to +9 dBu.

VITC Read Lines

This setting determines which line pair of incoming video signal is used for the VITC source. When set to Auto, the synchronization peripheral searches for the first valid line pair automatically. Alternatively, this value can be set to specific VITC line pairs.

VITC Generate Lines

This setting determines the line pair of the outgoing video signal onto which the synchronization peripheral inserts VITC. Normally, this should be left at the default (and preferred) setting of 14/16.

Bi-Phase/Tach Wiring

This setting lets you select from the following options for Bi-Phase or Tach wiring:

- Bi-Phase: FWD = A leads B
- Bi-Phase: FWD = B leads A
- Tach: FWD = B is Low
- Tach: FWD = B is High
**Bi-Phase/Tach Pulses/Frame (2–254)**

There are several different standards for the number of pulses-per-frame output by Bi-Phase or Tach devices. You can set the synchronization peripheral to operate from 2 to 254 pulses per frame from Pro Tools. The setting should match the PPF rate of the Bi-Phase/Tach encoder on the external device.

**Reset Bi-Phase**

This button lets you set the Bi-Phase/Tach start frame from Pro Tools. Click the button to update the Timecode Display on the synchronization peripheral to match the session timecode value.

**Enable Dub Window**

When this option is selected, you can insert a timecode window into a video signal with the following Window dub appearance settings:

- **Vertical Position** Sets the vertical position of the window dub, relative to the bottom of the video picture. The choices range from 10% From Bottom to 50% From Bottom, in 10% increments.

  - **Warning:** "10% from Bottom" vertical position is outside the standard “safe title” area, which means it may not be visible on some video monitors.

- **Horizontal Position** Sets the relative horizontal position of the window dub within the video picture. The choices include Extreme Left, Left, Center, Right and Extreme Right.

  - **Warning:** The “Extreme” horizontal positions are outside the standard “safe title” area, which means they may not be visible on some video monitors.

- **Size** Sets the relative size of the window dub (Small or Large).

**Color** Sets the color of the timecode numbers and background of the window dub. The choices include White on Black Bkrgd, Black on White Bkrgnd, White on Video Bkrgnd, or Black on Video Bkrgnd. (Video Bkrgnd means that the background of the window dub is transparent, so that the timecode numbers are displayed directly on top of the video signal, without a contrasting background box.) The default setting is White on Black Bkrgnd.

**Machine Control**

The Machine Control page lets you configure Pro Tools | Ultimate for use with MIDI Machine Control or 9-Pin Machine Control.

For information about using MachineControl with Pro Tools | Ultimate, see Chapter 58, “MachineControl.”
**MIDI Machine Control (Master)**

Pro Tools provides the following for configuring MIDI Machine Control (Master) settings.

**Enable**

When the Enable option is selected, Pro Tools is the Master and it sends MMC commands to the slave device and receives MTC information back from the slave device.

**MIDI Out Port**

The MIDI Out Port pop-up menu lets you select the MIDI Out port to which the slave device is connected.

**MMC ID**

The MMC ID setting lets you specify the MMC ID number for which MMC information will be sent. MMC commands contain an ID number to identify which machine should respond to the MMC command. There are 128 MMC ID numbers, from 0–127. The default of ID #127 is a special setting that transmits to all 128 MMC IDs. With a setting of 127, Pro Tools will transmit MMC commands to all MMC IDs.

**Preroll**

The Preroll setting lets you specify a pre-roll time in frames for your MMC slave device. Pre-roll is needed to provide the device with sufficient time to lock to the timecode transmitted by Pro Tools. This value will vary depending on the external device. If the pre-roll time is insufficient, the device may not be ready to lock until after the current timecode position has passed.

**MIDI Machine Control (Slave)**

Pro Tools provides the following for configuring MIDI Machine Control (Slave) settings.

**Enable**

When the Enable option is selected, Pro Tools is the slave and it receives MMC commands from the master device and sends MTC information back to the slave device.

**MMC ID**

The MMC ID setting lets you specify the MMC ID number for which MMC information will be received.

**9-Pin Machine Control (Deck Control)**

(HDX and HD Native Systems with MachineControl Only)

The 9-Pin Machine Control (Deck Control) settings let you configure a Machine Control device for Serial Deck Control mode with Pro Tools | Ultimate. Serial Deck Control mode is available whenever Machine Control is connected using the Serial Deck Control cable. When connected for Serial Deck Control mode, Machine Control enables all Pro Tools track arming, synchronization, and Transport features, as available on your system. Serial Deck Control mode also supports 9-pin serial timecode.

**Enable**

When the Enable option is selected, Pro Tools is in Serial Deck Control mode.
Port

The Port setting lets you select the 9-pin Machine Control port. The available choices depend on your platform and configuration.

Machine Type

After you select a port, Pro Tools automatically polls the port to see what kind of machine is connected. If the machine is recognized, Pro Tools loads the corresponding Machine Type. This includes the corresponding track layout and automatically enters the name of that machine into the Machine Track Arming window. However, if the machine is not recognized, the “Generic 1” personality is automatically loaded.

Preroll

The Preroll setting lets you specify a variable amount of machine preroll to account for the time it may take the machine to achieve servo lock. Shorter preroll values are usually better for non-linear machines. Longer preroll values are usually better for older tape transports. The Machine preroll value is added to any preroll specified in the Transport window.

9-Pin Remote (Deck Emulation) (HDX and HD Native Systems with MachineControl Only)

The 9-Pin Remote (Deck Emulation) settings let you configure Pro Tools | Ultimate for 9-Pin Remote (Deck Emulation) mode. This mode makes Pro Tools operate as a virtual tape deck, supporting most standard Sony P2 9-pin commands. By default, Pro Tools emulates a Sony BVW-75 model video deck. You can also configure Pro Tools to emulate other machines.

Enable

When the Enable option is selected, Pro Tools is in 9-Pin Remote (Deck Emulation) mode.

MIDI Controllers

The MIDI Controllers page lets you configure up to four different MIDI controllers for Pro Tools.

Chase LTC

When Chase LTC is enabled, Pro Tools still responds to track arming and record commands. However, Pro Tools will chase incoming LTC instead of behaving as a master or slave device with the machine controller. By slaving Pro Tools to the LTC source instead of slaving the machine to Pro Tools timecode, you can avoid the waiting (and tape wear) that occurs while a machine transport locates and bumps tape to the cue point.
**Number and Color**

The number of the row indicates the order of the selected controllers. The color corresponds to the controller focus around Pro Tools track and plug-in controls.

**Type**

The Type setting lets you select the MIDI controller connected to your computer. Choose from any of the following types of MIDI controllers:

- Command|8
- HUI
- Surround Panner
- M-Audio Keyboard

**Receive From**

The Receive From setting lets you select the MIDI In port to which your MIDI controller is connected.

**Send To**

The Send To setting lets you select the MIDI Out port to which your MIDI controller is connected.

**Number of Channels**

The Number of Channels (# Ch’s) setting displays the number of control channels supported by the selected MIDI controller type.

---

**Ethernet Controllers**

The Ethernet Controllers page lets you configure up to seven different Ethernet controllers for Pro Tools.

**Enable**

When selected, Pro Tools is enabled for control by one or more Ethernet controllers (such as D-Command or C|24).

**Ethernet Port**

The Ethernet Port setting lets you specify the Ethernet port on your computer to which your controller is connected.

**Number and Color**

The number of the row indicates the order of the selected controllers. The color corresponds to the colored controller focus border around Pro Tools track and plug-in controls.

**Ethernet Controller**

From the Ethernet Controller pop-up menu, select the Ethernet controller that you want to use.
Name

Click the Name button to enter a name for the selected Ethernet controller.

Enable EUCON (Extended User Control)

When selected, Pro Tools is enabled for control by one or more EUCON-compatible controllers. EUCON is an innovative high-speed Ethernet protocol developed by Avid to allow hardware control surface to directly communicate with a software application.

For more information about using Pro Tools with EUCON, see the documentation included with your controller.

Mic Preamps

The Mic Preamps page lets you configure up to nine different Mic Preamps (PRE) for Pro Tools.

For information about the PRE, see the PRE Guide.

Type

The Type setting lets you select none or PRE. Select the PRE option to declare any connected PRE.

Receive From

The Receive From setting lets you specify the MIDI In port to which the PRE is connected.

Send To

The Send To setting lets you specify the MIDI Out port to which the PRE is connected.

Defaults

Click the Reset button reset the corresponding PRE to its default settings.

Retain Current Settings

Select the Retain Current Settings option to retain PRE channel settings when an existing session with different settings is loaded. New sessions will automatically retain the current settings.

Remote Lock-Out Mode

When the Remote Lock-Out Mode option is selected, all connected PREs ignore their front panel controls.
Satellites

The Satellites page lets you configure synchronization between multiple Pro Tools systems (including an Avid Video Satellite system) using Satellite Link.

Satellite Link lets you link up to 12 HDX or HD Native systems (or any combinations of 11 HDX or HD Native systems and an Avid Video Satellite system or a Pro Tools Video Satellite system) over an Ethernet network so that you can cue, play, and stop the transport, make play selections, and solo tracks across any of the systems from any linked workstation.

Media Composer Video Satellite lets you link an HDX or HD Native system and a Media Composer system for monitoring Avid video. Pro Tools Video Satellite lets you link an HDX or HD Native system and a Pro Tools host-based system for monitoring Avid or QuickTime video.

System Name

Type a name for the local system. This name appears in the list of available satellites in other connected systems with the Satellite Link option.

Mode

The Mode settings let you configure the satellite behavior of the local system.

Administrator When enabled, the Administrator option sets the local system to be the administrator system for any satellite systems on the network. Satellite systems can be declared from the administrator system.

Satellite When enabled, the Satellite option sets the local system to be a satellite system on the network. When a system is in Satellite mode, it becomes available to be declared as a satellite from any administrator system on the network.

Administrator (HDX and HD Native Systems Only)

When the local system is in Administrator mode, the Administrator settings let you declare satellites from that system.

System 1–12 These pop-up menus let you declare up to 11 satellite systems (in addition to the administrator system itself) from an administrator system. The number of the system indicates the order of the declared satellites in the Transport window.

Advanced Network Settings

The Advanced Network Settings options let you manually configure the satellite network. Typically, these options should be left at the default settings.

Interface Lets you select the Ethernet interface if more than one interface is available on your system.
**TCP/UDP Port** Lets you enter the TCP/UDP Port number. By default, Satellite Link uses TCP/UDP port 28282. If the default port is already in use, or if you want to set up separate Satellite Link networks, you can select a different TCP/UDP port for Satellite Link communication.

⚠️ *For Satellite Link to function properly, you must select a TCP/UDP port number between 1024 and 65534.*

**Reset Network** Lets you reset the entire satellite network. Click the Reset Network button to automatically disconnect and reconnect all satellites on the network.

---

**VENUE**

The VENUE page lets you configure Pro Tools for use with a VENUE system over Ethernet using VENUE Link.

Pro Tools VENUE Link lets you import VENUE Settings into Pro Tools, create Pro Tools markers from VENUE Snapshots, and locate to Pro Tools markers from VENUE Snapshots.

**System Name**

The System Name field lets you enter a name for your Pro Tools system.

**VENUE System**

The VENUE System selector lets you select a remote VENUE system for recording to (or playback from) your Pro Tools system. You can also manually enter the IP addresses of the VENUE system.

**Advanced Network Settings**

The Advanced Network settings let you specify an IP address and port for VENUE Link communication.

**Interface** For systems that have more than one Ethernet network connection, the Interface setting lets you select which connection to use for VENUE Link communication.

**TCP/UDP Port** For systems that have more than one Ethernet network connection, you can enter the TCP/UDP port number to be used for VENUE Link communication.
Atmos
(Pro Tools | Ultimate with Dolby Atmos Only)

The Atmos page in the Peripherals dialog lets you configure Pro Tools for use with a Rendering Mastering Unit (RMU) in a Dolby Atmos system.

RMU Host
Enter the IP Address for the RMU (or rendering and mastering workstation) on the network that you want to use or select it from the drop-down list. Enter localhost if you are mixing to the Dolby Atmos Renderer application included with the Dolby Atmos Production Suite.

Link Object and Audio Recording
When this option is enabled, Pro Tools links recording and monitoring of audio and metadata for tracks with object output assignments. For more information, see “Dolby Atmos PEC/DIR Recorder Workflow Example” on page 1257).

Monitor Format
Monitor Format displays the current monitoring mode of the connected Dolby Atmos Renderer.

Enable
When this option is selected, Pro Tools is enabled for communication with the Renderer over the network. This option must be selected to mix to Dolby Atmos regardless of whether you are connected to the Renderer.

Connection Status
When Pro Tools is successfully connected to the Dolby Atmos Renderer, the Connection Status indicator lights solid. This indicator flashes on and off when Dolby Atmos is enabled, but the connection failed and Pro Tools is unable to communicate with the Renderer. Note that you can still work on the session even if not connected to the Renderer as long as Enable is selected.

If Dolby Atmos is not enabled, the Connection Status indicator is unlit.
Chapter 10: Configuring MIDI

If you are using external MIDI devices with Pro Tools (such as controllers or sound modules), you can customize your MIDI studio setup to display the names of your MIDI devices in Pro Tools.

MIDI Studio Setup (Mac)

Pro Tools recognizes the ports on your MIDI interface as generic ports. With Mac OS X, you use Apple’s Audio MIDI Setup (AMS) utility to identify external MIDI devices connected to your MIDI interface and configure your MIDI studio for use with Pro Tools.

⚠ To ensure optimum performance, do not change the AMS configuration while Pro Tools is playing back. Stop the Pro Tools transport before launching AMS.

To configure your MIDI studio in AMS:

1. Do one of the following:
   • Launch Audio MIDI Setup (located in Applications/Utilities).
   • In Pro Tools, choose Setup > MIDI > MIDI Studio.

2. If the MIDI Studio window is not showing, choose Window > Show MIDI Studio.

Audio MIDI Setup, MIDI Devices window

AMS scans your system for connected MIDI interfaces. If your MIDI interface is properly connected, it appears in the window with each of its ports numbered.

3. To create a custom MIDI device for any external MIDI devices connected to your MIDI interface, click the + button at the top of the window. A new external device icon with the default MIDI keyboard image appears.

4. Drag the new device icon to a convenient location within the window.
5 Connect the MIDI device to the MIDI interface by clicking the arrow for the appropriate output port of the device and dragging a connection or “cable” to the input arrow of the corresponding port of the MIDI interface.

6 Click the arrow for the appropriate input port of the device and drag a cable to the output arrow of the corresponding port of the MIDI interface.

💡 *To remove a connection, select the cable and press Delete.*

7 Repeat steps 3–6 for each MIDI device in your MIDI setup.

**To customize an external MIDI device in AMS:**

1 Double-click the new device icon.

2 Select a manufacturer and model for the new device from the corresponding pop-up menus. (If the Manufacturer and Model pop-up menus do not provide a name for your particular device, you can type a name.)

共鸣: To remove a connection, select the cable and press Delete.

**Making MIDI input and output connections**

**Naming a new MIDI device**

💡 *For Manufacturer and Model names, AMS refers to one or more files with the suffix “.middev” in the directory Root/Library/Audio/MIDI Devices. Pro Tools installs a file that contains information for many commercially available MIDI devices, named “Digidesign Device List.middev.” If the Manufacturer or Model names for any of your external MIDI devices is not available in the AMS Manufacturer and Model pop-up menus, you can add them by editing the .middev file in any text editor (such as TextEdit).*

냤풀: For more information, see “MIDI Patch Names” on page 773.
3 If necessary, click Properties, then enable the appropriate MIDI channels (1–16) for the Transmits and Receives options. (These determine which channels the device will use to send and receive MIDI.)

4 Click the device image. The window expands to show images for various MIDI devices (such as keyboards, modules, interfaces, and mixers). Select an icon for your device.

5 Select a device image and click Apply.

6 Close the AMS window to quit the AMS application.

The device names you enter appear as MIDI input and output choices in Pro Tools.

---

### MIDI Studio Setup (Windows)

MIDI Studio Setup (MSS) lets you configure the MIDI controllers and sound modules that are connected to your system, and control the routing of MIDI data between your MIDI equipment and Pro Tools.

MSS automatically finds MIDI interfaces, and lets you specify a custom name for each of the MIDI ports within the MIDI Studio Setup document.

MSS also supports XML-based patch file names for storing and importing patch names for your external MIDI devices.

Entire MIDI Studio Setup configurations created within MSS can be imported and exported.

**To configure your MIDI studio with MSS:**

1. In Pro Tools, choose Setup > MIDI > MIDI Studio.
2. Configure the MIDI Studio Setup windows.
3. When you are finished configuring the MIDI Studio Setup, close the MIDI Studio Setup window.

### MIDI Studio Setup Window

The MIDI Studio Setup window is organized into three sections. Interface controls are at the top of the window. All the currently defined instruments are displayed in the Instrument Name list on the left side of the window. A detailed view of MIDI parameters is shown in the Properties section on the right.
Interface Controls

Create Adds a new instrument to the Instrument Name list.

Delete Deletes the instrument or instruments selected in the Instrument Name list.

Import Imports an existing MIDI Studio Setup file.

Export Exports the current MIDI Studio Setup file.

Show Duplicate Emulated Ports When this option is selected and you are using a MIDI interface that supports time-stamping, the MIDI Studio setup window shows both the DirectMusic time-stamped output ports, and non-stamped duplicate emulated output ports.

Some MIDI Interfaces will not properly load or unload their drivers unless you quit and re-launch Pro Tools. Refer to the documentation that came with your MIDI interface for more information.

Instrument List

The Instrument list contains all the currently defined instruments. Selecting an instrument in the list displays that instrument’s properties in the Properties section of the window.

Properties Section

The Properties section lets you edit information for new instruments, or instrument currently selected in the Instrument list.

When a previously defined instrument is selected in the Instrument list, the Properties section changes to reflect the properties of the selected instrument.

To define an instrument with MIDI Studio Setup:

1. Choose Setup > MIDI > MIDI Studio.
2. Click Create.
3. In the Instrument Name field, type the name of your instrument, and press Enter.
   
   ![If you do not enter an instrument name, the Instrument Name field will automatically inherit information from the Manufacturer and Model pop-up menu.]

4. Set a manufacturer and model for the new device from the corresponding pop-up menus. If the Manufacturer and Model pop-up menus do not provide a name for your particular device, choose None.
5. From the Input pop-up menu, choose the input port on your MIDI interface that is connected to the MIDI Out of your instrument.
6. From the Output pop-up menu, choose the output port on your MIDI interface that is connected to the MIDI In of your instrument.
7. Enable the appropriate MIDI channels (1–16) for the Send Channels and Receive Channels options (These determine which channels send and receive MIDI.)
**Instrument Name**

The Instrument Name field shows the user-definable instrument name for the currently selected instrument.

**Manufacturer**

The Manufacturer pop-up menu provides a list of MIDI equipment manufacturers. This list is derived from the XML-based MIDI device files.

*For more information, see “MIDI Patch Names” on page 773.*

**Model**

The Model pop-up menu provides a list of MIDI devices, filtered by the manufacturer name. This list is derived from the XML-based MIDI device files provided with your Pro Tools installation.

*For more information, see “MIDI Patch Names” on page 773.*

**Input Port**

The Input Port pop-up menu displays a list of available MIDI interface input ports. The MIDI interface port that is set and displayed here is the port through which MIDI data is sent from the external MIDI device specified in the Instrument Name field into your MIDI interface.

*If you set the input port to None, the defined instrument will not appear as a choice in a MIDI Input Selector.*

**Output Port**

The Output Port pop-up menu displays a list of available MIDI interface output ports. The port set and displayed here is the port through which MIDI data is sent from your MIDI interface to the MIDI device specified in the Instrument Name field.

*If you set the output port to None, the defined instrument will not appear as a choice in a MIDI Output Selector.*

**Send Channels**

The Send Channels grid sets the send channels for the MIDI device specified in the Instrument Name field.

**Receive Channels**

The Receive Channels grid sets the receive channels for the MIDI device specified in the Instrument Name field.
Part III: Sessions, Projects & Tracks
Chapter 11: Sessions and Projects

Sessions and Projects

The first step to working in Pro Tools is creating a new session or project.

Sessions are represented by session files that can be saved, copied, and made into templates. Sessions and all associated media and settings files are stored locally on connected qualified storage systems (such as internal and external hard drives, or certain network storage systems (such as Avid ISIS).

Projects are similar to sessions except that they store your media and project data online (as well as caching it locally) in your Avid Cloud account. Projects also let you collaborate on a track-by-track basis with anyone in the Avid Artist Community anywhere in the world; or, if you prefer, you can choose your collaborators privately and invite them to join a project by email as long as everyone is using Pro Tools 12.5 or higher. Otherwise, projects operate just like sessions. Projects have all of the same recording, editing, mixing, and processing capabilities as sessions. As such, throughout most of this Reference Guide, unless otherwise noted, any feature or function for sessions works for projects as well.

Projects can also be online or offline (Pro Tools 12.8 or higher). Online projects are stored in the cloud and mirrored locally (though the local cache can be cleared to free up local storage and downloaded later). Offline projects are not backed up to the cloud and are only stored in the local project cache (you might want to do this to free up online storage for other active projects). You can only collaborate with online projects.

Projects store all associated media and project data in the cloud while caching it locally. Sessions store all associated media and session data locally, either on hard drives in your computer or networked storage. For example, with a session, you can go to the session folder and find all of the audio files associated with that session in the Audio Files folder (note that if you have configured Pro Tools to store audio in other locations, those files will not be in the session’s Audio Files folder). With projects you must export media from the project as a new file. While media is cached locally it is all bundled with the project data, so you cannot simply go and find individual audio files in the local cache.

You can save a copy of a session as a project using the Save Copy In command. This lets you take an existing session and save it as a project for cloud collaboration. Likewise, you can save a copy of a project as a session. You might want to do this with the project is complete so that you can archive it as a session and free up storage space in your Avid Cloud Account.
**Signing In and Out of Your Avid Master Account**

To be able to create or open a project, you must first be signed in to your Avid Master Account. You will have already created your Avid Master Account when you registered Pro Tools. Once you are signed in and have created or opened a project, you can choose to work online or offline.

**To sign in to your Avid Master Account from Pro Tools:**

1. Do one of the following:
   - If the Dashboard is not open, choose File > Sign In.
   - In the Dashboard window, click Sign In.
   - In the Dashboard window, press Command+S (Mac) or Control+S (Windows).

2. Enter your email and password for your Avid Master Account.

3. Click Sign In.

**To sign out of your Avid Master Account, do one of the following:**

- If the Dashboard is not open, choose File > Sign Out (<username>).
- In the Dashboard window, click Sign Out.
- In the Dashboard window, press Command+S (Mac) or Control+S (Windows).

**Dashboard Window**

Pro Tools presents the Dashboard window on launch. The Dashboard lets you quickly and easily create a new session or project, or open an existing one. You can choose to show or hide the Dashboard on launch in the Pro Tools Display Preferences (Settings > Preferences > Display).
When you first launch Pro Tools, you are prompted by the Dashboard window to do one of the following:

- Create a new session or project from a template.
- Create a new blank session or project.
- Open any of the last ten most recent sessions and projects.
- Open any other session on your system.
- Open any projects you created or projects that you are collaborating on.

To open or close the dashboard window, do any of the following:

- Choose File > New or press Command+N (Mac) or Control+N (Windows).
- Choose File > Open Project or press Command+Option+N (Mac) or Control+Alt+N (Windows).

Dashboard Commands, Options, and Settings

The Dashboard provides several options for creating and opening sessions and projects.

Global Dashboard Commands and Settings

Sign In/Out The Sign In/Out link is present in all tabs. Click Sign In to sign in to your Avid Master Account. Once you are signed in, your Display Name will be shown and you will also see the percentage of your Avid Cloud storage that you are using all of the projects you own. Any media you post to a shared project that you do not own will count against the project owner’s Cloud storage allocation. To sign out, click your Display Name and choose Sign Out.

Open from Disk (Sessions Only) Click to navigate to and open any session stored on your local system. You can also press Command+O (Mac) or Control+O (Windows).

Cancel Click to close the Dashboard window without creating or opening a session or project.

Create/Open Click Create to close the Dashboard and create a new session or project with the specified session or project settings (on the Create tab only). Click Open to open the selected session or project (on the Recent and Project tabs only). You can also press Return (Mac) or Enter (Windows) to Create or open a session or project.

Show on Startup Disable to skip the Dashboard when Pro Tools starts. To resume showing the Dashboard when Pro Tools starts, enable the Show Dashboard window when Pro Tools starts option (Settings > Preferences > Display).

Create Tab Settings

To show the Create tab (if not already shown, do one of the following:

- In the Dashboard, click the Create tab.
- In the Dashboard, press Command+1 (Mac) or Control+1 (Windows).
- In the Dashboard, press Command+Up/Down Arrows to toggle through the tabs.
- In Pro Tools, choose File > Create New, or press Command+N (Mac) or Control+N (Windows).
- In Pro Tools, choose File > Create New, or press Command+N (Mac) or Control+N (Windows).

Local Storage (Session) Select this option to create a session using local storage only.
Collaboration and Cloud Backup (Projects) Select this option to create an online project for collaboration and cloud back up. The number of projects you currently have is displayed in relation to the total number of projects you are entitled to base on your Avid Cloud Storage Account.

![Press Command+Left/Right Arrow (Mac) or Control+Left/Right Arrow (Windows) to toggle between these options.]

Name Type a name for your session or project.

Create from Template Enables the options to create a session or project from a template.

Template Group Select the Template Group you want to review. Press Option+Up/Down Arrows (Mac) or Alt+Up/Down Arrows (Windows) to scroll through the available Template Groups.

File Type Sets the File Type (WAV or AIFF) for the session or project. Press Command+F (Mac) or Control+F (Windows) to toggle between the two options.

Sample Rate Sets the sample rate for the session or project. Press Command+R (Mac) or Control+R (Windows) to scroll

Bit Depth Sets the Bit Depth (16-bit, 24-bit, or 32-bit floating) for the session or project. Press Command+B (Mac) or Control+B (Windows) to toggle through the available options.

I/O Settings Sets which I/O Settings to use for the session or project. Press Command+I (Mac) or Control+I (Windows) to toggle through the available I/O Settings options.

Interleaved Enable the Interleaved option to create interleaved stereo (or greater) audio files in the session or project. Press Command+G (Mac) or Control+G (Windows) to enable or disable the Interleaved option.

Prompt for Location (Sessions Only) Enable to be prompted for where you want to save the session. When Prompt for Location is enabled, Location is automatically disabled.

Location (Sessions Only) Click the Location button to specify the default location for saving sessions. When Location is enabled, Prompt for Location is automatically disabled.

Backup to Cloud (Projects Only) Select the Backup to Cloud option to create an online project. Disable this option if you want to create an offline project (you can always put the project online later with the Backup To Cloud command in the Projects tab). For more information, see “Backup to Cloud: Online and Offline Projects” on page 159.

Recent Tab

In the Dashboard, click the Recent tab, or press Command+2 (Mac) or Control+2 (Windows) to show the Recent tab. The Recent tab lists your 10 most recent sessions and projects, but otherwise it has no unique commands, options, or settings. Double-click any session or project in the list to open it. Recent projects are not shown if you are not logged in.

Projects Tab

In the Dashboard, click the Projects tab, or press Command+3 (Mac) or Control+3 (Windows) to show the Projects tab. The Projects tab lists all projects stored in the cloud that you have created or collaborated on. Double-click any project in the list to open it. No projects are shown if you are not logged in.
Additional Dashboard Keyboard Shortcuts

To navigate through the focused Template, Session, or Project list, press the Up/Down Arrows (Mac) or Alt+Up/Down Arrows (Windows).

To select the item at the top or bottom of the displayed list, press Home/End (Mac and Windows).

To scroll up or down through the focused Template, Session, or Project list, press Page Up/Down (Mac and Windows).

Showing or Hiding the Dashboard on Start

To show or hide the Dashboard on startup, do one of the following:

- In the Dashboard, enable (or disable) the Show on startup option.

- In the Warnings & Dialogs section of the Display Preferences page (Setup > Preferences), select (to show) or deselect (to hide) the Show Dashboard window when Pro Tools starts option. Click OK.

Bit Depths and Sample Rates

When selecting a bit depth or sample rate for your session or project, consider fidelity, any compatibility issues with others systems, and storage space.

Bit depth and sample rate also have an effect on the amount of mixing power available in a session or project. Fewer mixer channels are available with 24-bit and 32-bit floating point sessions and projects, and with sessions at higher sample rates.

Bit Depths

16-Bit Using 16-bit for audio files is useful for keeping audio file sizes down. You may want to use 16-bit for sessions and projects with few tracks, and little mixing and plug-in processing. CDs (Compact Discs) use 16-bit.

24-Bit Using 24-bit for audio files is commonly used for most music production and post-production sessions and projects with multiple audio tracks, mixing, and plug-in processing. 24-bit files take up a third as much space as 16-bit files.

32-Bit Floating Point Using a 32-bit floating point bit depth for audio files in Pro Tools sessions and projects can help avoid clipping or unnecessary dithering with AudioSuite rendering. It can also help avoid rounding errors in signal processing (which can occur during bit depth conversion for file playback and real-time plug-in insert processing). However, 32-bit files take up a third more disk space and audio streaming bandwidth, which can be problematic with higher track counts when using slower hard drives.

You can change the bit depth for all newly recorded or imported (and converted) files in the session or project by selecting a different Bit Depth option in the Session Setup window.

To change the Bit Depth for the Pro Tools session or project:

1. Choose Setup > Session.

2. In the Session Setup window, select a bit depth from the Bit Depth selector.

Session Setup window, selecting 32 Bit Float
Sample Rates

44.1 kHz Is the sample rate used for CDs and is used in most common music production environments.

48 kHz Is the standard sample rate for film and video projects, and is commonly used in post-production environments. It is the sample rate used for DVDs.

88.2 kHz and 96 kHz Each of these sample rates are twice the standard sample rates for CD audio and DVD audio respectively. Audio files recorded at higher sample rates take up more drive space, but provide higher resolution for time-based plug-in processing (which can help avoid aliasing). These options are only available if you are running Pro Tools with audio hardware that supports these sample rates.

176.4 kHz and 192 kHz Each of these sample rates are four times the standard sample rates for CD audio and DVD audio respectively. Audio files recorded at higher sample rates take up more drive space, but provide higher resolution for time-based plug-in processing (which can help avoid aliasing). These options are only available if you are running Pro Tools with audio hardware that supports these sample rates.

Mixed Audio File Formats

Pro Tools supports mixed audio file formats (such as WAV and AIF) in a single session or project. When importing audio files into a Pro Tools session or project, you can choose to Add them rather than Convert them regardless of the audio file format.

You can change the audio file format for all newly recorded or imported (and converted) files in a session or project by selecting a different Audio Format option in the Session Setup window.

To change the Audio Format for the Pro Tools session or project:

1. Choose Setup > Session.

2. In the Session Setup window, select an audio file format (AIF or WAV) from the Audio Format selector.

Interleaved Multichannel and Multi-Mono Audio Files

For stereo and greater-than-stereo multichannel audio, Pro Tools supports both interleaved multichannel audio files and multi-mono audio files.

An interleaved audio file contains all channel information, stored in an alternating single audio “stream.” Interleaving distributes and “interleaves” the consecutive bits of data. This helps protect against consecutive errors when the data is read back.

Multi-mono, or “split-mono” multi-channel audio files are separate mono audio files that are treated together as a multichannel group of audio files. This lets you each channel (file) independently. For example, with stereo files, two separate files are created, where one file contains the left channel, and the other file contains the right channel. The files are identified by the suffixes of “.L” and “.R”. The two files are linked, and are edited as a pair in stereo tracks in Pro Tools. However, you can decouple them and split them to individual mono audio tracks in Pro Tools so that the can be edited, processed, and mixed independently.

You can change the Interleaved setting for the currently open session or project in the Session Setup window. When this option is enabled, all newly recorded or imported (and converted) stereo or greater-than-stereo multichannel files in the session will be interleaved audio files.
To enable (or disable) interleaved audio files for the Pro Tools session or project:

1. Choose Setup > Session.
2. In the Session Setup window, select (or deselect) the Interleaved option.

**Session Files and Folders**

When you create a new session, Pro Tools automatically creates a new folder named for your session. Within this folder is the session file, a WaveCache.wfm file, and several subfolders (including, but not limited to, an Audio Files folder and a Clip Group folder).

**Audio Files Folder**

The Audio Files folder contains all audio recorded or converted during the session. When you record a new audio track, the track is saved as a new audio file to the Audio Files folder. You can also import other audio files into the session, and work with them as well.

*For details on allocating audio tracks to different hard drive locations, including shared media volumes, see “Recording with Multiple Hard Drives” on page 509.*

**Fade Files Folder**

The Fade Files folder may be present in legacy Pro Tools sessions. Versions of Pro Tools lower than 10.0 use rendered fades and cross-fades that are written to the “Fade Files” folder in the session folder.

**Rendered Files Folder**

The Rendered Files folder contains any temporary files created by Rendered Elastic Audio processing in the session. It may also contain temporary filtered analysis files (.aan) as a result of any changes to Elastic Audio analysis.

**Clip Groups Folder**

The Clip Groups folder is the default directory for any clip groups that you export from your Pro Tools session.

Typical session folder contents (Mac OS X shown)
WaveCache File

The WaveCache.wfm file stores all of the waveform display data for the session. If you delete the WaveCache.wfm file, Pro Tools creates a new one the next time you open the session.

By storing waveform data in the WaveCache file, sessions open more quickly. The session WaveCache file can be included whenever a session is transferred to another Pro Tools system (7.x and higher).

Pro Tools also maintains a distinct WaveCache file inside the Databases folder, which retains waveform data for all files used on the system.

Deleting or trashing a WaveCache file does not harm the session or your system. However, the session will take longer to open because it has to re-calculate waveform data for any associated audio files and store that data in a new WaveCache file.

Session File Backups Folder

The Session File Backups folder contains automatically-generated backups of your Pro Tools sessions. These files are created when working on a session and the Operations preference for Enable Session File Auto Backup is enabled. (See “Enable Session File Auto Backup” on page 109.)

Renamed Audio Files Folder

This folder includes file names that have been renamed when you open a session that contains audio file names with incompatible characters, or, in certain situations, save a copy of a session to a Pro Tools version that does not support long file names.

For more information, see “Renamed Audio Files” on page 457.

Pro Tools Projects

A Pro Tools project is like an online session. It lets you access your session from any system with online access. Projects also let you collaborate remotely with other people. Pro Tools synchronizes your local project and associated media with your online account automatically.

You must be online and signed in to your Avid Master Account the first time you create a project (see “Signing In and Out of Your Avid Master Account” on page 152), but after that you can work offline. Pro Tools synchronizes your local project with your online account the next time you are online. This process runs in the background and can be monitored in Pro Tools by checking the Task Manager (Window > Task Manager).

Project data and media are bundled and cached on local storage, but you cannot open a project by navigating through the file system. You can only access projects through the Pro Tools Dashboard. Projects are differentiated from sessions by the Project icon in the Dashboard.

You can save a session as a project using the Save Copy In command. This lets you take an existing session and save it as a project for cloud collaboration. Likewise, you can save a project as a session. You might want to do this when the project is complete so that you can archive it as a session and free up storage space in your Avid Cloud Account.
Backup to Cloud: Online and Offline Projects

The Backup to Cloud option determines whether or not a project is online (stored in the cloud) or offline (stored in the local project cache only). Disabling Backup to Cloud for online projects can be useful for freeing up storage in your Avid Cloud Account for other projects. This option is only available for projects (not sessions).

Online Projects

When the Backup to Cloud option is enabled for a project, the project is online and all associated media are copied to your Avid Cloud Storage Account as well as being stored in the local designated project cache. You can collaborate with other users on online projects as well as access your project from any computer when you are signed in to your Avid Master Account. Enabling the Backup to Cloud option for an offline project copies the project and all associated media to your Avid Cloud Account.

Offline Projects

When the Backup to Cloud option is disabled for a project, the project is offline and all associated media is only stored in the local project cache.

You cannot collaborate with other users on offline projects nor can you access offline projects from any other computer. Disabling the Backup to Cloud option for an online project deletes the project and all associated media from your Avid Cloud Account, leaving only the local cached copy of the project. Offline projects do not appear in the Projects List in the Artist Chat window, they only appear in the Projects List in the Dashboard. Note that you cannot disable the Backup to Cloud option for shared projects or if the local project cache has been cleared.

Shared Projects and Ownership

 Whoever creates a project, owns the project. All media posted to the project, whether by the owner or a collaborator, counts against the owner’s cloud storage allocation. Posted media never counts against a collaborator’s cloud storage allocation.

You can hover the cursor over a project icon in the Dashboard and a tooltip identifying the project name and the project owner appears.

Setting the Location of the Local Cache

All project data and media is stored both in your Avid Cloud account and in a local cache. The local project cache is stored on your system drive by default. However, for the best performance with Pro Tools, it is generally recommended that you do not use your system drive for recording audio, so you should set the local project cache to an external drive if possible. You can change the location of where the project cache is stored in the Pro Tools Operation Preferences.
To set the location for storing the local project cache:

1. Choose Setup > Preferences.
2. Click the Operation tab.
3. Click the Change button for the Project Media Cache.
4. In the Open dialog, navigate to the location where you want to store the Project Media Cache and click Open.

Creating a New Session or Project from a Template

To create a new session or project from a template:

1. In the Dashboard, click the Create tab if it is not already shown, or press Command+1 (Mac) or Control+1 (Windows).

You can create your own custom categories. For more information, see “Session Templates” on page 176.

2. For Type, select either Project (cloud) or Session (local).
3. Type a Name for the session or project.
4. Enable the Create From Template option.
5. From the Template Group pop-up menu, select the category of templates you want (for example, Guitar or Songwriter).
6. Select the template you want to use from the list (on the right).
7. If you want to change any of the session or project parameters, do any of the following:
   - Select the Audio File Type (WAV or AIF).
   - Select the Bit Depth (16 bit, 24 bit, or 32 bit float).
   - Select the Sample Rate.
   - To create interleaved multichannel audio files in the session or project, enable Interleaved.
   - For sessions only, select either the Prompt for location option or the Location option. If you select the Location option, you can specify the default location for saving sessions by clicking the Location button.
   - For projects only, select the Backup to Cloud option to create an online project. Disable this option if you want to create an offline project.
8 Click Create.

9 For sessions only, in the Save dialog, specify where you want to save the session, and then click Save.

For optimum compatibility between Mac and Windows, set the file project to BWF (.WAV).

Creating a New Blank Session or Project

To create a new blank session or project:

1 In the Dashboard, click the Create tab if it is not already shown, or press Command+1 (Mac) or Control+1 (Windows).

2 For Format, select either Project (cloud) or Session (local).

3 Type a Name for the session or project.

4 Ensure that the Create From Template option is deselected.

5 If you want to change any of the session or project parameters, do any of the following:
   • Select the audio File Type (WAV or AIF).
   • Select the Bit Depth (16 bit, 24 bit, or 32 bit float).
   • Select the Sample Rate.
   • Select the I/O Settings to use for the session or project. Several pre-configured I/O Settings are included with your system, or you can select a custom I/O Setting. For more information, see Chapter 6, “I/O Setup.”
   • To create interleaved multichannel audio files in the session or project, enable Interleaved.
   • For sessions only, select either the Prompt for location option or the Location option. If you select the Location option, you can specify the default location for saving sessions by clicking the Location button.
   • For projects only, select the Backup to Cloud option to create an online project. Disable this option if you want to create an offline project.

6 Click Create.

7 For sessions only, in the Save dialog, specify where you want to save the session, and then click Save.

Dashboard, creating a new project

You must be online and signed in to your Avid Master Account to create a new project (see “Signing In and Out of Your Avid Master Account” on page 148).
Opening a Recent Session or Project

To open a recent session or project:

1. In the Dashboard, select Recent, or press Command+2 (Mac) or Control+2 (Windows).

2. Select any of the last ten recent sessions or projects from the list (on the right).

3. Click Open.

Dashboard, Recent Sessions/Projects list

⚠️ The Open Recent Session option is not available the first time you launch Pro Tools (or if you have cleared the Recent Sessions list by choosing File > Open Recent > Clear).

Opening Any Session

To open any session:

1. Do one of the following:
   - In the Dashboard, click the Open from Disk button.
   - In Pro Tools, choose File > Open Session.
   - Press Command+O (Mac) or Control+O (Windows).

2. In the Open dialog, navigate to the location of the session file you want to open and select it.

3. Click Open.

Opening a Session

When you open a session, Pro Tools looks in the session folder for audio and fade files linked to the session.

⚠️ For more information on opening sessions created on different platforms, Pro Tools systems, or versions of Pro Tools software, see Chapter 21, “File and Session Management and Compatibility.”

To open an existing session:

1. Do one of the following:
   - If Pro Tools is running, choose File > Open Session.
   - To open a session from the Dashboard, click the Open from Disk button or press Command+O (Mac) or Control+O (Windows).

2. In the Open dialog, locate the session you want to open and click Open.

⚠️ You can also open a session from a Workspace browser by double-clicking it.
Opening a Session that Contains Fade Files

When opening a session created in a version of Pro Tools lower than 10.0, Pro Tools calculates and plays back all fades in real time. The “Fade Files” folder in the session folder is neither deleted nor used. Any rendered fades created in legacy sessions are calculated and played back in real time. Any new fades created in the session do not generate any new rendered fade files in the pre-existing “Fade Files” folder.

Opening a Session that Contains Unavailable Files

Pro Tools notifies you if files are found but reside on Transfer volumes, or if any required files cannot be found. For more information, see “Locating Audio Files” on page 456.

Opening a Session from a Transfer Volume

When opening a session from a Transfer volume (such as a CD or DVD), Pro Tools prompts you to save the session on a Performance volume, and copy and convert any referenced media files. For more information, see “Locating Audio Files” on page 456.

Opening a Session that Contains Unavailable Resources

Pro Tools prompts you when opening a session that contains unavailable voices, I/O paths, DSP resources, or plug-ins. This is common when transferring sessions between systems with different Pro Tools hardware.

The Unavailable Resources dialog provides an initial report of the missing session components. To save a text (.txt) file containing a more detailed Notes report, along with the resulting action, click Yes. The Notes report is named with the session name, followed by Notes.txt. You can choose to save this file in your Session folder, or in another location.

The following occurs when opening a session with unavailable items:

With all Pro Tools Systems:
- Inserts assigned to unavailable plug-ins are made inactive.
- Inputs, outputs, and sends that are assigned to unavailable paths are made inactive.

With HDX Systems Only:
- Any tracks beyond the maximum number of available voices on the current system are made inactive.

With Pro Tools Host-based Systems Only:
- Any tracks beyond the maximum number of available voices on the current system are set to voice off.

Opening a Session with Audio File Names that Contain Illegal Characters

Pro Tools does not support audio file names that contain the following ASCII characters:

/ (Forward Slash)
\ (Backslash)
: (Colon)
* (Asterisk)
? (Question mark)
" (Quotation mark)
" (Quotation marks)
< (Less-than symbol)
> (Greater-than symbol)
| (vertical line or pipe)
When opening a session that contains audio files with illegal characters, Pro Tools automatically creates a renamed copy of each file (replacing these characters with an underscore “_”). Renamed files are copied to the Renamed Audio Files folder. The original files are left intact in the Audio Files folder.

Before the session opens, you are prompted to save a detailed report of the renamed files and their original file names to a Notes text file. Follow the on-screen instructions. By default, the Notes text file is saved to the Session folder.

Opening a Session that was Saved with +6 dB Fader Gain

All Pro Tools 7.x and higher sessions have a +12 dB fader gain level. However, when saving a Pro Tools 7.x or higher session to a lower version of Pro Tools that supports +6 dB and +12 dB fader gain, the new session can be saved with either a +6 dB or a +12 dB maximum fader gain.

When saving a +12 dB session as a +6 dB session, Pro Tools alerts you that any automation settings over +6 dB will be lowered to +6 dB. See “Save Copy In” on page 166.

In Pro Tools 7.x or higher, when opening a session that was saved with a +6 dB maximum gain level, the session will update to a +12 dB range.

Opening a Session or Project with Plug-Ins Deactivated

Pro Tools lets you open sessions and projects with all plug-ins set to inactive. Since sessions and projects with a lot of plug-ins can take a long time to load, this lets you quickly open any session or project for immediate visual inspection and audio playback (without plug-ins). If it is the session or project that you want to work with, you can easily reopen the session or project with plug-ins activated.

To open a Pro Tools session with all plug-ins set to inactive:
1. In Pro Tools, choose File > Open Session.
2. In the Open Session dialog, locate and select the session you want.
3. Shift-click Open.

To open a Pro Tools project with all plug-ins set to inactive:
1. In Pro Tools, choose File > Open Project.
2. In the Dashboard Projects list, select the project you want.
3. Shift-click Open.
To re-open the same session or project with all plug-ins set to active, do one of the following:

- Choose File > Revert To Saved (for sessions only).
- Choose File > Open Recent and select the most recent session or project in the submenu.

Press Command+Shift+O (Mac) or Control+Shift+O (Windows) to open the most recent session or project.

Instead of reverting to the saved version of the session or project to open the session with all plug-ins active, you can simply make an individual plug-in active by Command-Control-clicking (Mac) or Control-Start-clicking (Windows) it. To make an entire row of plug-ins active, Command-Option-Control-click (Mac) or Control-Alt-Start-click (Windows) any plug-in in the row of inserts.

---

**Saving Sessions and Projects**

**Saving the Session File**

The Save command saves the changes you have made to your session and writes them over the previously saved version of the session file. The Save command cannot be undone. Consider saving regularly while working on your session to ensure that your work is preserved on your hard drive.

To save a session or project:

- Choose File > Save.

Press Command+S (Mac) or Control+S (Windows) to save the session or project.

---

**Saving Projects**

Projects are saved to the cloud when changes are uploaded by any collaborator. The local cache keeps your local working copy distinct from the cloud version (and from other collaborators’ versions) until all changes are uploaded and downloaded (you can set this to happen automatically).

**Reverting to a Previously Saved Session or Project**

If you have made changes to a session or project since you last saved it, you can discard those changes and revert to its previously saved state.

To revert to the last saved version of a session or project:

- Choose File > Revert to Saved.

If you have enabled the Operation preference for Auto Backup, you can also open up a backup copy of your session or project. This feature lets you specify the total number of incremental backups that are kept and how often the session or project is saved. See “Auto Backup Section” on page 109.

Reverting to a previously saved session or project can also be used to open a session or projects with all of its plug-ins active, after opening it with all of its plug-ins inactive. See “Opening a Session or Project with Plug-Ins Deactivated” on page 164.
Saving the Session File with a New Name

To save a copy of the current session with a new name or to a different hard drive location, use the Save As command. The Save As command closes the current session and lets you keep working on the renamed copy. This is useful if you are experimenting and want to save successive versions of the session.

By working this way, you can quickly retrace your steps if you want to go back to an earlier version of your session. The Save As command saves a new version of the session file only, and does not duplicate versions of the audio or fade files.

To save a session with a new name:
1. Choose File > Save As.
2. Type a new name for your session.
3. Click Save.

Press Command+Control+S (Mac) or Control+Start+S (Windows) for the Save As command.

The renamed session file is saved in the session folder along with the original session (unless you specify a different destination). Any new audio files that you record in your renamed session will be placed into the same Audio Files folder that was created for your original session.

Save Copy In

To save a copy of the current session or project, use the Save Copy In command. In addition, you can specify the session or project file format, audio file format, bit depth, and sample rate for the copy.

For information on sharing sessions between different platforms, Pro Tools systems, or Pro Tools software versions, see Chapter 21, “File and Session Management and Compatibility.”

Save Copy In dialog

To save a session or project copy as new session or project:
1. Choose File > Save Copy In.
2. Specify the Format for the copy, such as Session (Latest).
3. Set the audio File Type for the copy: BWF (.WAV) or AIFF.
4. Set the Sample Rate and Bit Depth for the copy.
5. If applicable, select a Fader Gain level for the copy.
6 If applicable, select Enforce Mac/PC Compatibility to create session and audio files that can be used on both Windows and Mac Pro Tools systems (see “Saving Copies of Mac Sessions to be Compatible with Windows” on page 460).

7 Select the Items to Copy for the copy.

   To include all audio being used in the session, select the All Audio Files option.

8 Click Save.

How the Save Copy In Command Works

Unlike the Save As command, Save Copy In does not close the original session, so subsequent edits are made to the original session. Session copies can be used to archive important sessions, for versioning, or as a means to prepare sessions for transfer to another Pro Tools system.

Save Copy In can save only the audio being used in the session. Any audio that was recorded or imported and then later removed from the session, but not deleted from disk, is not included in the new session or project copy.

   To include all audio being used in the session or project, select the All Audio Files option.

Using the Save Copy In command is the only way to change the sample rate of a session or project. The sample rate of each of the session or project copied audio files is converted to the selected sample rate. When saving a session copy to a different sample rate, Pro Tools uses the selected Sample Rate Conversion Quality option in the Import section of the Processing Preferences page (Setup > Preferences).

When you save a copy of the session or project to a lower bit depth, Dither (and Noise Shaping) are applied automatically.

See the following table:

<table>
<thead>
<tr>
<th>Bit Depth</th>
<th>Dither</th>
<th>Noise Shaping</th>
</tr>
</thead>
<tbody>
<tr>
<td>32-bit float to 32-bit float</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>32-bit float to 24-bit</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>32-bit float to 16-bit</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>24-bit to 32-bit float</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>24-bit to 24-bit</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>24-bit to 16-bit</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>16-bit to 32-bit float</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>16-bit to 24-bit</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>16-bit to 16-bit</td>
<td>No</td>
<td>No</td>
</tr>
</tbody>
</table>

The dither setting used for any conversion is the Dither plug-in with Noise Shaping enabled.

   For more information about using Dither, see “Dither” on page 1089.
Save Copy In Options

When saving a copy of a session or project, the Save Copy In command provides the following options.

Format

When saving a copy of a session or project with the Save Copy In command, you can save the session or project copy in the following formats:

• Project; lets you save a copy of the session as a project.
• Latest; supports Pro Tools 10.x and higher sessions (.ptx)
• Pro Tools 7.x -> 9.x Session (.ptf)
• Pro Tools 5.1 -> 6.9 Session (.pts)

Session Parameters

When saving a copy of a session or project with the Save Copy In command, the following Session Parameters are available:

Audio File Type

You can save the session or project to reference BWF (.WAV) or AIFF audio files.

Using Mixed File Types

Sessions and projects can use mixed audio file projects. If your original session or project has mixed file projects, they are not converted to the selected file project unless you specify that they be converted by selecting the Convert to Specified Format option in the Items To Copy section (see “Items to Copy” on page 169).

Bit Depth

You can save the session or project at a Bit Depth of 16 Bit, 24 Bit, or 32 Bit Float.

Pro Tools 10.0 and higher sessions can use audio files with different bit depths. If your original session or project has mixed bit depths, they are not converted to the selected bit depth unless you specify that they be converted by selecting the Convert to Specified Format option in the Items To Copy section (see “Items to Copy” on page 169).

When saving to a Session Format lower than 10.0, if your session or project is in a different bit depth, audio files are converted to the new session bit depth, and copied to the specified location. Also, 32 Bit Float is not available for session formats lower than 10.0.

For information on bouncing to disk and dither, see “Using Dither” on page 1186.

Sample Rate

You can save the session or project at various sample rates depending on your system hardware. See “Supported Hardware Configurations with Pro Tools Software” on page 38.

If your session or project is at a different sample rate, audio files are converted to the new session or project sample rate, and copied.

Fader Gain

When saving a Pro Tools 7.x or higher session to a lower version that supports +12 dB fader gain, you can save the new session with either a +6 dB or a +12 dB maximum fader gain. When saving a +12 dB session as a +6 dB session, any automation over +6 dB will be lowered to +6 dB.
Enforce Mac/PC Compatibility

When saving a Pro Tools 7.x or higher session to a lower version, enable the Enforce Mac/PC Compatibility option to force Windows or Mac versions of Pro Tools to create sessions and audio files that are compatible on both platforms.

For more information, see “Saving Copies of Mac Sessions to be Compatible with Windows” on page 460.

Limit Character Set

When saving a copy of a session or project to the current session or project format, you can choose to limit the character set to a single language by selecting the Limit Character Set option.

When saving a copy of a session or project to a lower session format, the Limit Character Set option is automatically selected. Select a language from the Limit Character Set pop-up menu.

To choose the language encoding when saving a copy of a session or project:

1. Choose File > Save Copy In.
2. Select the Limit Character Set option.
3. Choose the language you want to use from the Limit Character Set pop-up menu.

Items to Copy

When saving a copy of a session or project with the Save Copy In command, you can select which items are copied, as follows:

Audio Files

When this option is selected, all audio files are copied to the new location. This setting is automatically selected if you select a Session Format lower than 10.0.

Convert To Specified Format

When the Convert To Specified Format option is selected, all copied audio files are converted to the specified audio file format settings in the Session Parameters section. When this option is not selected, any copied audio files retain their original audio file format settings (including sample rate and bit depth), and are exactly copied, bit-by-bit.

Note that copying formats bit-by-bit is much faster than converting files.

This option is automatically selected if you do any of the following:

- Save to a session format lower than 10.0.
- Enable Enforce Mac/PC Compatibility.

Don’t Copy Elastic Audio Rendered Files

When this option is selected, Elastic Audio Rendered files are not copied to the new session’s Rendered Files folder or project bundle.

When opening the new session or project, Pro Tools opens the session or project with all available media and any missing Rendered files are regenerated automatically.

Main Playlist Only

When this option is selected, only the main playlists are included with the copy. Any alternate playlists are not included with the copy.

When this option is not selected, all playlists are included with the copy.

Selected Tracks Only

When this option is selected, only the selected tracks in the source session or project are saved with the copy. This option is automatically enabled when choosing File > Export > Selected Tracks As New Session.
When this option is not selected, all tracks in the source session or project are saved with the copy. This option is automatically disabled when choosing File > Save Session Copy.

**Backup to Cloud (Projects Only)**

When saving a copy of a session or project as a new project, enable the Backup to Cloud option to create an online project. Disable this option to create an offline project.

**Session Plug-In Settings Folder (Sessions Only)**

When this option is selected, the session’s Plug-In Settings folder is copied to the new location. The references to these settings in the session are redirected to the copied settings files.

**Root Plug-In Settings Folder (Sessions Only)**

When this option is selected, the contents of the root-level Plug-In Settings Folder are copied into a folder named *Place in Root Settings Folder*, indicating that these files will need to be moved to the root level plug-in settings folder on the destination system before you can use them. The references to these settings files in the session are *not* redirected to point to the copied files.

**Movie/Video Files**

When this option is selected, video files (Avid or QuickTime) are copied, and references are updated to point to the copied video files.

**Preserve Folder Hierarchy (Sessions Only)**

When this option is selected, the relative arrangement of session audio files located across different drives or folders is maintained. The main folder for the session copy will include subfolders for each drive or folder in the original session and the destination subfolders will use the same names as the source drives and folders.

When this option is not selected, the Save Copy In command copies all files of the same project, regardless of their location, into a single destination folder.

**Session Fade Settings Folder (Sessions Only)**

When this option is selected, the session’s Fade Settings folder is copied to the new location. The references to these settings in the session are redirected to the copied settings files.

**Root Fade Settings Folder (Sessions Only)**

When this option is selected, the contents of the root-level Fade Settings Folder are copied into a folder named *Place in Root Settings Folder*, indicating that these files will need to be moved to the root level Fade settings folder on the destination system before you can use them. The references to these settings files in the session are *not* redirected to point to the copied files.

**Clip Effects Quick Presets**

Enable this option to export any custom Clip Effects Presets with the copy of the session or project.
Save As New Version
(Projects Only)

You can save different versions of Pro Tools projects using the Save As New Version command (similar to using the Save As command for sessions). Pro Tools lets you review and restore any version of a project from the Project Revision History window.

To save a new version of the current project:

1. Choose File > Save As New Version.

   Press Command+Control+S (Mac) or Control+Start+S (Windows) to save a new version of the open project.

2. In the Save New Version window, type the Title for the new version of the project (for example, “Ver. 3” or “acapella version”).

3. Type any notes for this version of the project under Project Notes. This is optional—you can always add or edit Project Notes for any given version later (see “Project Notes” on page 179).

4. Click OK.

Revision History
(Projects Only)

Revision History keeps track of all versions of a project, including any automatically and manually saved histories for each version.

The left pane of the Revision History window lists all versions for the project, and the right side displays Project Notes (if any) for the selected version of the project.

To open the revision history window, do one of the following:

- Choose File > Revision History.
- Press Command+Control+O (Mac) or Control+Start+O (Windows).
- On the Project page of the Dashboard, choose Open Revision History from the Project pop-up menu.
To close the revision history window:
- Click Done.

Press Esc to close the Revision History window.

Version List

The Version List displays the versions you have saved by name and are always sorted by date (with the most recent at the top of the list). Any manually or automatically saved histories of any version in the list can be displayed by clicking the reveal triangle to the left of the version title. You can also rename any version of the project in the list.

Save History

Automatic and manual save histories are readily accessible for any version of a project. However, they are automatically thinned out over time—always keeping the most recent while gradually deleting older save histories from your local cache and cloud storage for the project (automatic saves are deleted first). Revision History maintains a reasonable distribution of older to more recent save histories in relation to your available storage.

Save histories are deleted (or not deleted) according to the following rules:
- Original versions are always kept.
- The latest manual save for each version is always kept.
- If at least one save (manual or auto) is contained in the version, it is always kept.
- The last two automatically saved backups are always kept for all versions.
- Every manual save for the last two hours is kept.
- A save for every half hour, if any, is kept for up to 24 hours for all versions.
- Manual saves are preferred over auto-saves.
- A save for every hour, if any, is kept for a week for all versions.
- The last manual save of every day, if any, is always kept for all versions.
- The automatic deletion of save histories in both the cloud and the local cache that are to be “thinned out” for the project happens directly after any save (manual or automatic).
- The version history for a project is synchronized across all machines sharing the project.

The Auto Backup settings in the Operation preferences determine how often the active version of a project is automatically saved and how many automatically saved backups are maintained for that version.
Renaming Versions of a Project

To rename any version of a project:

1. Open the Revision History window.
2. Do one of the following:
   • Right-click the version you want to rename and choose Rename.
   • Click the name of the version you want to rename.
   • Select Window > Metadata Inspector and type the Title that you want for this version of the project. However, you can only do this if you are the owner of the project; collaborators cannot edit the Meta-data Inspector.
3. Type the new name.
4. Press Enter.

When renaming a version of a project, it must be a name that is not already used by another version of the project. No project can contain two separate versions with the same name nor can one version overwrite another.

Restoring a Version of the Project

The Revision History window lets you restore any version of a project and still maintain access to all other versions. Restoring a version closes the currently open, active version of the project (you will be prompted to save any changes) and opens the selected version of the project. The date and time are reset for the most recently opened version of the project and it moves to the top of the Version List.

To restore a version of a project:

1. Select the version you want to restore in the Version List.
2. Do one of the following:
   • Click the Restore button.
   • Double-click the version in the Version List.
   • Press Return or Enter.
   • Press the R key.
3. You may be prompted to Save the currently open version of the project before restoring the selected version.

Conflicts Between Shared Tracks in Different Versions of a Project

It is possible to have conflicts with shared tracks and project data in the active version of a project if they do not match the latest version on the cloud. This may be a common occurrence when working with different versions of a shared project. For example, if you save version X of a shared project, make some edits without saving or uploading your changes, then save as new version Y and upload your changes, and then restore version X, there will be conflicts between the version in the cloud (Y) and the local, active version (X).
Pro Tools warns you of conflicts and lists the names of mismatched tracks so that you can make an informed decision on how to proceed:

- Upload and overwrite tracks and project data in the cloud.
- Download and overwrite local tracks and project data.
- Do nothing and leave both the local version and the cloud version unaltered.
- Unshare any conflicting tracks and leave the cloud version unaltered.

Even if the Auto Upload All or Auto Download All Track Collaboration options are enabled in a shared project, Pro Tools never automatically overwrites the cloud version with the local version, nor the local version with the cloud version, when conflicts are detected.

**Importing Data from Another Version of a Project**

You can import project data from any version into the currently active version of the project (much like when importing data from another session into the current session). This can be useful if you only want to use some of the data from another version of the project and not have to restore that entire version. For example, you might have the best guitar solo in one version of the project, but you want to keep everything else in the currently active version. Use the Import command in the Revision History window to import just that one track.

**To import project data from another version into the current version of the project:**

1. In the Version List, select the version from which you want to import data.
2. Do one of the following:
   - Click the Import button.
   - Press I on your computer keyboard.
   - Right-click the version you want to import data from and choose Import.
3. Configure the Import Session Data dialog as desired.
4. Click OK.

For detailed information on the Import Session Data dialog, see “Importing and Exporting Data to and from a Session or Project” on page 397.
Deleting a Version of a Project

You can delete any version (or manual or automatic save) of a project in the Revision History window.

To delete any version of a project:
1 In the Version List, select the version you want to delete.
2 Do one of the following:
   • Click the Delete button.
   • Press the D key.
   • Right-click the version you want to delete and choose Delete.
3 Click Delete.

The selected version of the project and its entire save history are permanently deleted. When deleting one of the automatically or manually saved histories for a version, only that one history of the version is deleted.

Saving a Session as a Project

Pro Tools lets you save a copy of a session as a project. This facilitates taking an existing session and converting it to a project for online collaboration (and you will still have the original session for reference).

Before saving a copy of a session as a project, consider your allocated online storage space and available bandwidth. For example, if you are working with clips that only reference only a little bit of audio in much larger files, you might want to consolidate each of those clips. If you don’t have the fastest internet connection, it might take awhile to upload large referenced files whereas small whole file clips might upload and download relatively quickly. Maybe you don’t need to share every alternate playlist, perhaps just a track’s main playlist will do. Or, maybe you can have your collaborators record to a scratch track rather than the whole mix.

The more you can do to lighten up your session before saving it as a project, the better. It will save you and your collaborators both time and online storage space.

To save a copy of a session as a project:
1 Prepare the session for saving as a project (for example, remove extraneous files from the session, consolidate clips that only reference part of large files, and so on).
2 Select only the tracks that you want in the project (optional).
3 Ensure that you are logged in to your Avid Master Account through Pro Tools (File > Sign In or click Sign In in the upper right corner of the Dashboard).
4 Choose File > Save Copy In.
5 In the Save Copy In dialog, set the Format to Project.
6 Set the Session Parameters as desired. For the sake of bandwidth and storage, you may consider saving the session to a project with a lower sample rate and bit depth.
7 Select which Items To Copy. Saving a session as a project always copies all Audio Files, and only the main playlist on tracks. Also, you might not want to copy rendered Elastic Audio files.

8 Enable Selected Tracks Only (optional).

9 Enable (or disable) Backup to Cloud to save as an online project (or an offline project).

10 Click OK.

---

**Saving a Project as a Session**

Pro Tools lets you save a copy of a project as a session. When you are done working on a project you can archive it as a session locally and delete the online project to free up cloud storage in your Avid Cloud Account.

To save a copy of a project as a session:

1 Ensure that you have accepted or rejected all changes to shared tracks.

2 Choose File > Save Copy In.

3 In the Save Copy In dialog, set the Format to Session (Latest).

4 Set the Session Parameters as desired.

5 Select which Items To Copy. Note that Audio Files and Movie/Video Files will always be copied.

6 Click OK.

---

**Session Templates**

In addition to the Session Templates provided in the Dashboard, Pro Tools lets you create and share your own custom Session Templates. Pro Tools Session Template files use the suffix “.ptxt” to differentiate them from regular Pro Tools session files (“.ptx”).

**Creating and Saving Custom Templates (Sessions Only)**

To create a custom Pro Tools Session Template:

1 Create a new Pro Tools session and configure it for the session template you want.

2 For example, if you are a songwriter you might simply want a session consisting of a stereo Instrument track with an instrument plug-in (such as Xpand! 2 with a piano preset), a mono audio track (for tracking vocals), a stereo Auxiliary Input track (for an effects bus), and a stereo Master Fader track. You can then use this template every time you sit down to work on a new song.

3 Choose File > Save As Template.

---

![Image of the Save Copy In dialog](image1)

![Image of the Save Session Template dialog](image2)
3 Configure the Save Session Template dialog (see “Save Session Template Dialog” on page 177).

4 Select the Include Media option if there is any audio, MIDI, or video media in the session that you want included in the template.

⚠️ When the Include Media option is enabled, all media in the session is included in the template. If you want to include media in your session template, be sure that your session only contains the media you want.

5 Click OK.

If you selected the Install Template In System option, your session template will be available in the Dashboard.

If you selected the Select Location For Template option, you are prompted by the Save As Template dialog to save the file to another location on your system.

⚠️ When you are ready to use a template as the basis for a new session, see “Creating a New Session or Project from a Template” on page 160.

Save Session Template Dialog

The Save Template dialog provides the following options:

Install Template In System

Select this option to save the template file in the system folder referenced by the Dashboard (the Session Templates in the Pro Tools application folder).

Category

The Category pop-up menu is only available if the Install Template In System option is enabled. The Category pop-up menu lets you select the subdirectory in which to save the template file. It also provides options for adding a category and revealing the Session Templates folder in Windows Explorer or the Mac Finder.

Add Category Select this option from the Category pop-up menu to create a new subdirectory in the Session Templates folder.

Name

The Name setting is only available if the Install Template In System option is enabled. This lets you project a new name for the template file. From the Name pop-up menu (to the right of the Name field), you can select from a list of all of the templates available in the currently selected Category. Selecting one places that name in the Name field, letting you overwrite, or create a incremental version of, an existing template.

Select Location For Template

Select this option to save the template file to any directory location on your system. Note that the saved session template will not appear in the Dashboard unless it is in a subdirectory (Category) in the Session Templates folder in the Pro Tools Root Settings folder. You can change the location of the Root Settings Folder in the Operation Preferences (see “User Media and Settings Location” on page 110).

Include Media

Select this option to include any audio, MIDI, or video media in the session with the template.
Creating New Sessions or Projects from Templates

You can create new session or project from templates by opening a template. You can open any Pro Tools Session Template file (.ptt) to start a new session based on that template.

For information on creating new sessions from templates using the Dashboard, see “Creating a New Session or Project from a Template” on page 160.

Project and Session Metadata

Pro Tools provides a Metadata Inspector window for sessions and projects. Sessions and projects have slightly different Metadata options. This window lets you view and edit metadata for sessions and projects. However, certain metadata is display only (such as Sample Rate and Bit Depth). Metadata is stored with the session file (.ptx) or with the project bundle.

To open the Metadata Inspector:

- Choose Window > Metadata Inspector.

Metadata Inspector Window

The Metadata Inspector window displays the following information about your session or project. Some metadata can be edited and some is display only.

**Name (Sessions Only)** Displays the name of the session.

**Project Name (Projects Only)** Displays the name of the project.

**Project Owner (Projects Only)** Displays the name of the project owner.

**Title** Enter a title that is independent of the name of the session or project.

**Artist(s)** Enter the name of the artist (or artists) for the session or project.

**Contributor(s)** Enter the names of the contributors to the session or project.

**Sample Rate** Displays the session or project sample rate. The Sample Rate can also be viewed in the Workspace.

**Bit Depth** Displays the session or project bit depth. The Bit Depth can also be viewed in the Workspace.

**Location** Enter the location where the session or project was recorded.

**Date Created** Display the date and time that the session or project was created. The Date Created can also be viewed in the Workspace.

**Date Modified** Displays the date and time that the session or project was last modified. The Date Modified can also be viewed in the Workspace.

**BPM** Displays the tempo or range of tempos used in the session or project in beats per minute. BPM can also be viewed in the Workspace as Tempo.
Project Notes

Pro Tools lets you add and edit Project Notes for any version of a project. Use Project Notes for anything from reminders to descriptions, or a to do list. You can add and edit Project Notes when you create a new version of a project or in the Project Notes window. Project Notes are always saved with the specific version of the project.

To add or edit Project Notes:
1. Do one of the following:
   - Choose File > Save as New Version to open the Save New Version dialog.
   - Select Window > Project Notes to open the Project Notes window for the current version of the project.
2. Type and edit the Project Notes as desired.

Closing a Session or Project

Pro Tools only lets you work on just one session or project at a time. The Close Session/Project command closes your current Pro Tools session or project but leaves the Pro Tools application running. Pro Tools prompts you to save the session or project when closing it, but it is recommended that you save your work using the Save or Save As command before closing a session or project.

To close a session or project:
- Choose File > Close Session/Project.

Renaming Projects

You can rename any project you own that is not currently open on the Projects tab of the Dashboard.

To rename a project:
1. Ensure that you are logged in to your Avid Master Account through Pro Tools (File > Sign In or click Sign In in the upper right corner of the Dashboard).
2. In the Dashboard window, select the Projects tab to view your current projects; or if Pro Tools is already running, choose File > Open Project—Command+Option+O (Mac) or Control+Alt+O (Windows)—to access Projects tab in the Dashboard window.
3. To the right of the project list, click the pop-up menu for the project you want to rename.
5. In the resulting dialog, project the new name for the project.
6. Click OK.
Remove Local Cache

Use the Remove Local Cache command for any project that is not currently open to free up storage space on your local system. Your project will remain intact and retrievable from the cloud. You can always restore your project from your online MyAvid account cloud storage.

To remove the local cache for a project:

1. Ensure that you are logged in to your Avid Master Account through Pro Tools (File > Sign In or click Sign In in the upper right corner of the Dashboard).

2. In the Dashboard window, select the Projects tab to view your current projects; or if Pro Tools is already running, choose File > Open Project—Command+Option+O (Mac) or Control+Alt+O (Windows)—to access Projects tab in the Dashboard window.

3. To the right of the project list, click the pop-up menu for the project whose local cache you want to clear.

4. Choose Remove Local Cache.

5. When prompted, click Delete.

Notice the Cloud icon to the right of the project. Pro Tools deletes the local cache for the project while keeping the project intact in the cloud. Click the Cloud icon to download the project media and synchronize the local and online versions of the project.

Deleting Projects

Once you have completed work on a project and exported the final mix or archived it as a session using the Save Copy In command, you can delete the project to free up online storage space for other projects. Use the Dashboard window to delete any project that you no longer need.

You cannot undo the Delete Project command. If you delete a project that you do not own, but are only collaborating on, you simple remove yourself as a collaborator for that project. The project remains available to the owner and other collaborators. However, once you delete a project that you own, it is permanently deleted and is unrecoverable.

To delete a project:

1. Ensure that you are logged in to your Avid Master Account through Pro Tools (File > Sign In or click Sign In in the upper right corner of the Dashboard).

2. In the Dashboard window, select the Projects tab to view your current projects; or if Pro Tools is already running, choose File > Open Project—Command+Option+O (Mac) or Control+Alt+O (Windows)—to access Projects tab in the Dashboard window.

3. To the right of the Project list, click the pop-up menu for the project you want to delete.

4. Choose Delete.
Pro Tools deletes the project and updates the percentage of your available storage used.

### Restore Project from Cloud

If you have deleted the local cache for a project, you can restore your project from the cloud.

**To restore a project from the cloud:**

1. Ensure that you are logged in to your Avid Master Account through Pro Tools (File > Sign In or click Sign In in the upper right corner of the Dashboard).

2. In the Dashboard window, select the Projects tab to view your current projects; or if Pro Tools is already running, choose File > Open Project—Command+Option+O (Mac) or Control+Alt+O (Windows)—to access Projects tab in the Dashboard window.

3. To the right of the Project list, click the Cloud icon for the project you want to restore.

Pro Tools downloads all data from the cloud to the local cache on your system for the selected project. Download progress is shown to the right of the project name.

### Open Revision History

Use the Open Revision History command to open the Revision History window and restore the project from any version or from any version’s save history.

**To open the latest auto-backup for a project:**

1. Ensure that you are logged in to your Avid Master Account through Pro Tools (File > Sign In or click Sign In in the upper right corner of the Dashboard).

2. In the Dashboard window, select the Projects tab to view your current projects; or if Pro Tools is already running, choose File > Open Project—Command+Option+O (Mac) or Control+Alt+O (Windows)—to access Projects tab in the Dashboard window.

3. To the right of the Project list, click the pop-up menu for the project for which you want to open the Revision History.

4. Choose Open Revision History.

Pro Tools opens the Revision History window where you can view, restore, import, and delete versions of the project as well as their save histories.

---

For more information about working with the Restore History window, see “Revision History” on page 171.
**Backup to Cloud**

Using the Backup to Cloud option in the Projects tab in the Dashboard, you can take existing online projects offline or put offline projects online at any time. Since shared projects cannot be taken offline, the Backup to Cloud option is grayed out and unavailable.

For projects you are taking offline, all project data and associated media is deleted from your Avid Cloud Storage Account and the Project icon turns gray.

For projects you are putting online, all project data and associated media are uploaded to your Avid Cloud Storage Account and the Project icon turns blue.

To take an online project offline (or to put an offline project online):

1. Ensure that you are logged in to your Avid Master Account through Pro Tools (File > Sign In or click Sign In in the upper right corner of the Dashboard).
2. Choose File > Open Project, or press Command+Option+O (Mac) or Control+Alt+O (Windows) to open the Dashboard showing the Projects tab.
3. In the list of projects list, deselect (or select) Backup to Cloud from the pop-up menu to the right of the project you want to take offline (or put online).

Dashboard, Projects tab, deselecting Backup to Cloud for a project

*Dashboard, Projects tab, offline projects are indicated by a gray Project icon and online projects are blue*
Project Collaboration Invitations in the Dashboard

The Dashboard lets you accept or reject project participation requests. When another user invites you to join a project, that project appears in the Project List in the Dashboard along with Reject and Accept icons.

To accept or reject project participation requests from the Dashboard:

1. Ensure that you are logged in to your Avid Master Account through Pro Tools (File > Sign In or click Sign In in the upper right corner of the Dashboard).

2. In the Dashboard, select the Projects tab. Projects that you have been invited to display Accept and Reject icons to the right of the project name.

3. Do one of the following:
   - Click the Accept icon to join the project.
   - Click the Reject icon to reject the collaboration request and remove the project from the project list.

For more information about project participation requests, see “Projects” on page 363.

Quitting or Exiting Pro Tools

When you quit (Mac) or exit (Windows) the Pro Tools application, Pro Tools prompts you to save any open session before exiting or closing the application.

To quit Pro Tools on the Mac:
- Choose Pro Tools > Quit Pro Tools.

To exit Pro Tools in Windows:
- Choose File > Exit.
Chapter 12: Pro Tools Main Windows

Pro Tools provides two complementary ways of viewing tracks in a session:

**Mix Window** Shows tracks as channel strips, like a mixing board (see “Mix Window” on page 186).

**Edit Window** Shows tracks and track material against the Timeline (see “Edit Window” on page 188).

To toggle between the Mix and Edit windows, press Control+Equals (=) (Windows), or press Command+Equals (=) (Mac).
Pro Tools provides several other types of windows:

**Transport Window** Lets you control the transport and transport-related functions (see “Transport Window” on page 194).

**Plug-In Windows** Let you control plug-in parameters, such as Frequency and Q for an EQ (see “Plug-In Windows” on page 1102).

**MIDI Editor Windows** Lets you edit MIDI data (see Chapter 35, “MIDI Editors”).

**Score Editor Window** lets you edit MIDI data as music notation (see Chapter 36, “Score Editor”).

**Workspace Browsers** Let you manage, audition, and import media for Pro Tools sessions (see “Workspace Browsers” on page 307).

**Artist Chat** Lets you find, invite, and chat with project collaborators (see Chapter 18, “Artist Chat Window”).

**In-App Web Browsers** Let you access the Avid Marketplace and Pro Tools Online (see “In-Application Web Browser” on page 200).

---

### Mix Window

In the Mix window, tracks appear as channel strips just like a mixing console, with controls for:

- Inserts
- Sends
- Input and output assignments
- Volume
- Panning
- Record enable
- Track Input monitoring
- Automation mode
- Solo and Mute
- Instrument controls
- HEAT controls (Pro Tools HD only)
- Mic preamps

**To display the Mix window:**

- Choose Window > Mix.

**To display all Mix window view options:**

- Select View > Mix Window > All.

For information on selecting individual view options, see “Views in the Mix and Edit Windows” on page 1052.
Chapter 12: Pro Tools Main Windows

Pro Tools Mix window
Edit Window

The Edit window provides a Timeline display of audio, video, MIDI notes, as well as other MIDI data and mixer automation for recording, editing, and arranging on tracks. As in the Mix window, each track has controls for record enable, solo, mute, and automation mode.

To display the Edit window:
- Choose Window > Edit.

To display all Edit window view options:
- Select View > Edit Window > All.

Edit window view options can be selected individually. See “Views in the Mix and Edit Windows” on page 1052.
Edit Window Toolbar

At the top of the Edit window is the Edit Window Toolbar and menu. This Toolbar provides access to the editing modes, tools, options, indicators, and displays for Pro Tools. You can customize the Toolbar in the Edit, MIDI Editor, or Score Editor windows by re-arranging, showing, and hiding the available controls and displays.

Edit Toolbar Controls and Displays

The following controls and displays in the Edit Window Toolbar are always shown.

Edit Modes

The Edit mode affects the movement and placement of audio and MIDI clips (and MIDI notes), how commands like Copy and Paste function, and also how the various Edit tools (Trim, Selector, Grabber, and Pencil tools) work. For more information, see “Edit Modes” on page 599.

Edit Tools

Edit tools are used for editing audio, MIDI, and automation data in Pro Tools. For more information, see “Edit Tools” on page 603.

Counters and Edit Selection Indicators

The Counters and Edit selection indicators provide information where selections are in the Timeline.

Edit window indicators

Main Counter Displays the current Edit insertion location in the Main Timebase ruler.

Sub Counter Displays the current Edit insertion location in the Sub Timebase ruler.

Cursor Location Displays the current cursor location in the Main Timebase ruler.

Cursor Value Displays the value of the current cursor value in peak amplitude (audio), pitch (MIDI), or according to the current automation or controller data type.

Edit Selection Indicators Display the Start, End, and Length of the current Edit selection.

MIDI Selection Indicators and Controls Display the current MIDI Edit selection (MIDI note number, and Note On and Note Off velocities) and provide controls for MIDI editing.
Timeline Data Online Status Indicator  Is green when all files in use in track playlists are available for playback. If files are offline, being processed, or otherwise unavailable for playback, this indicator is red.

Session Data Online Status Indicator Is green when all audio files referenced by the session are available for playback. If files are offline, being processed, or otherwise unavailable for playback, this indicator is red. If any files are offline, you can click the indicator to open the Relink window and relink to offline files.

Delay Compensation Status Indicator Is displayed when Delay Compensation is enabled (Options > Delay Compensation). When Delay Compensation is disabled, this indicator is not displayed.

Task Manager Status Lights and animates when the Task Manager is busy. When no tasks are in progress, it is unlit. The indicator turns red if the Task Manager requires your attention. Click the Task Manager Status indicator to open or close the Task Manager window.

Global Freeze Tracks Indicator lights when one or more tracks in the session are frozen. When it is unlit, Option-click (Mac) or Alt-click (Windows) the Global Freeze Tracks button to freeze all audio, Auxiliary Input, and Instrument tracks in the session. When it is lit, Option-click (Mac) or Alt-click (Windows) it to unfreeze all tracks in the session. You can also Right-click the Global Freeze Tracks button to specify which track types you want (or don’t want) to freeze.

⚠️ Tracks cannot be frozen while hidden or inactive.

If any of the Include options are unselected, you can Option-click (Mac) or Alt-click (Windows) the Global Freeze icon to freeze (or unfreeze) all tracks. The selected Include options remain selected.

Track Solo Indicator Lights yellow when any track in the session is soloed. When no tracks in the session are soloed, the Track Solo indicator appears dim green. For systems using Satellite Link, the Track Solo indicator lights dim yellow when a track is soloed on any satellite system.

If the Track Solo indicator is lit, you can click it to clear all soloed tracks in the session.

Track Mute Indicator Lights orange when any track in the session is muted. When no tracks in the session are muted, the Track Mute indicator appears dim green. (Note that because Mute is an automatable mixing function, the Track Mute indicator does not function to clear all mutes when clicked.)

Grid and Nudge

The Grid and Nudge selectors let you set the Grid and Nudge values for editing in Pro Tools. For information on the Grid Value selector, see “Configuring the Grid” on page 602. For information on the Nudge Value selector, see “Defining the Nudge Value” on page 660.
**Showing and Hiding Additional Controls in the Edit Window**

To show or hide controls in the Edit window toolbar:

1. Do one of the following:
   - Click the Edit Window Toolbar menu (in the upper-right corner of the window).
   - Right-click in the Toolbar.

2. From the menu, select or deselect any of the following depending on which window you are configuring:

   **Zoom Controls** When selected, the Zoom controls are displayed in the Edit window toolbar.
   
   ![Zoom Controls](image)

   **Transport** When selected, the Transport controls are displayed in the Edit window toolbar.
   
   ![Transport Controls](image)

   **MIDI Controls** When selected, the MIDI controls are displayed in the window toolbar.
   
   ![MIDI Controls](image)

   **Synchronization** When selected, the Synchronization controls and indicators are displayed in the Edit window toolbar.
   
   ![Synchronization Controls](image)

   **Output Meters** When selected, the Output meters are displayed in the Edit window toolbar.
   
   ![Output Meters](image)

   **Track Collaboration (Projects Only)** When selected, the Track Collaboration controls are displayed in the Edit window toolbar.
   
   ![Track Collaboration](image)

   **Eleven Rack (Eleven Rack Only)** This option is available only when an Eleven Rack is connected to your Pro Tools system. When selected, Eleven Rack controls are displayed in the Edit window toolbar. For more information, refer to the *Eleven Rack User Guide*.
   
   ![Eleven Rack](image)

   **Minimal** When selected, the Zoom, Transport, MIDI, and Synchronization controls are not displayed in the Edit window toolbar.
   
   ![Minimal Controls](image)
When selected, the Zoom, Transport, MIDI, and Synchronization controls are all displayed in the Edit window toolbar.

**Expanded Transport** When selected, the Expanded Transport controls are displayed in the Edit window toolbar if Transport is also selected.

**Universe** When selected, Universe view is shown near the top of the Edit window.

**Clip Effects** When selected, Clip Effects view is shown near the top of the Edit window.

**Tracks List** When selected, the Tracks List is shown on the left of the Edit window.

**Clips List** When selected, the Clips List is shown on the right of the Edit window.

**MIDI Editor** When selected, the MIDI Editor view is shown at the bottom of the Edit window.

**MIDI Input Display** When selected, the MIDI Input display is shown in the Edit window toolbar.

### Rearranging Controls and Displays

To rearrange controls and displays in the Edit, MIDI Editor, or Score Editor window toolbar:

- Command-click (Mac) or Control-click (Windows) the control or display you want to move and drag it to a new location in the toolbar.

For example, if you want the Counters and Edit Selection indicators to the right of the Transport controls in the toolbar, Command-click (Mac) or Control-click (Windows) and drag them to the right of the Transport controls.

### Edit Window Zoom Buttons

The Edit window also provides Zoom buttons in the lower right and upper right corners of the tracks pane.

**Vertical and Horizontal Zoom In and Out Buttons**

In addition to the Zoom controls in the Toolbar, Pro Tools provides horizontal and vertical zoom buttons in the lower-right corner of the Edit window.
Chapter 12: Pro Tools Main Windows

Vertical Zoom Buttons
Zoom the track heights proportionally in the Edit window.

Horizontal Zoom Buttons
Zoom the Timeline just like the Horizontal Zoom controls in the Edit window toolbar.

Audio and MIDI Zoom In and Out Buttons
Pro Tools also provides Audio and MIDI Zoom In and Out buttons in the upper-right corner of the Edit window. These controls function exactly the same as the Audio and MIDI Zoom controls in the Toolbar, and let you zoom in and out vertically on audio waveforms and MIDI notes respectively.

⚠️ In the Edit window, MIDI Vertical Zoom only affects tracks not in Clips view.

Edit Window Default Length
Pro Tools lets you set a default length for the Edit window in hours, minutes, seconds, and frames. This is useful if you want to assemble a session of a particular length or leave extra room to expand the Edit window’s work area in your session. The maximum length is 12 hours and 25 minutes at 48 kHz, and proportionally less at higher sample rates. For best scrollbar sensitivity, set the length to slightly longer (a minute or more) than the total session or song length.

To set the default length for the Edit window:
1. Choose Setup > Preferences.
2. On the Display page, enter the value in hours, minutes, seconds, and frames for the Edit Window Default Length setting.
3. Click OK.
Transport Window

The Transport window can be set to show basic transport controls, counters, MIDI controls, and expanded features. The counters in the Transport window mirror the controls and counters at the top of the Edit window.

To display the Transport window:
- Choose Window > Transport.

Basic Transport Controls and Counters

Transport window showing basic transport controls and counters (Main and Sub Counters and MIDI not shown)

Online Puts Pro Tools online so that playback and recording is triggered by an external timecode source.

Return to Zero Locates to the beginning of the session.

Press Return (Mac) or Enter (Windows) to Return to Zero.

Rewind Rewinds from the current play location. You can also click repeatedly to rewind incrementally, by an amount based on the Main Time Scale, as follows:

With Numeric Keypad mode set to Transport, you can rewind by pressing 1.

Fast Forward Fast forwards from the Timeline insertion point. You can also click repeatedly to fast forward incrementally (by an amount based on the Main Time Scale).

With Numeric Keypad mode set to Transport, you can fast forward by pressing 2.

Go to End Locates to the end of the session.

You can press Option+Return (Mac) or Control+Enter (Windows) on the alphanumeric keyboard to locate to the end of the session.

You can Right-click the Return to Zero button to access the Write to Start and Write to All automation commands.

Rewind and Fast Forward Increments

<table>
<thead>
<tr>
<th>Main Time Scale Format</th>
<th>Increment Amount</th>
</tr>
</thead>
<tbody>
<tr>
<td>Min:Sec</td>
<td>1 second</td>
</tr>
<tr>
<td>Timecode</td>
<td>1 frame</td>
</tr>
<tr>
<td>Bars</td>
<td>Beats</td>
</tr>
<tr>
<td>Feet+Frames</td>
<td>1 foot</td>
</tr>
<tr>
<td>Sample</td>
<td>1 second</td>
</tr>
</tbody>
</table>
Stop  Stops playback or recording.

You can also stop the transport by pressing the Spacebar, or with the Numeric Keypad mode set to Transport, pressing 0.

Play  Starts playback or (if the Record button was clicked first) recording from the Timeline insertion point or the Play Start Marker location if Dynamic Transport mode is enabled.

You can also begin playback by pressing the Spacebar, or with the Numeric Keypad mode set to Transport, pressing 0.

Right-clicking the Play button lets you select the playback mode from a pop-up menu:
- Half-Speed
- Prime for Playback
- Loop
- Dynamic Transport

To initiate playback at half-speed, you can also press Shift+Spacebar (Windows or Mac) or Shift-click (Mac) the Play button.

With the Transport stopped, Control-click Play (Mac) or Start-click Play (Windows) to toggle Loop Playback mode. When enabled, a loop symbol appears in the Play button and Pro Tools plays continuously from the beginning of the selection to the end.

For more information on loop playback and Dynamic Transport mode, see “Loop Playback Mode” on page 485.

Record  Arms Pro Tools for recording (the button flashes). Clicking Play then starts recording on record-enabled tracks only.

You can also begin recording immediately by pressing F12, pressing Command+Spacebar (Mac) or Control+Spacebar (Windows), or with the Numeric Keypad mode set to Transport, pressing 3.

Right-clicking the Record button lets you select the record mode from a pop-up menu:
- Normal
- Loop
- Destructive
- QuickPunch
- TrackPunch (Pro Tools HD only)
- Destructive Punch (Pro Tools HD only)

You can also cycle through the Pro Tools record modes with the Transport stopped, by Control-clicking (Mac) or Start-clicking (Windows) the Record button.

The Record button changes to indicate the currently selected mode: blank for Nondestructive, “D” for Destructive, a loop symbol for Loop Record, “P” for QuickPunch, “T” for TrackPunch, and “DP” for DestructivePunch.

To initiate recording at half-speed, you can press Command+Shift+Spacebar (Mac) or Control+Shift+Spacebar (Windows).

Track Record Enable Indicator  When lit (red), indicates that at least one audio track is currently record-enabled. When off (gray), no tracks are currently record-enabled.
**Track Input Monitor Indicator** When lit (green), indicates that at least one audio track is currently set to Input Only monitoring (regardless of record enable status). When off (gray), all tracks are in Auto Input monitoring.

**Transport Window Menu** Lets you select what options to show in the Transport window: Counters, MIDI Controls, Synchronization, Minimal, All, and Expanded Transport.

**Pre-Roll** During playback or record, specifies the amount of audio that plays before the Play (Timeline) Cursor or Play Start Marker location, or beginning of the Timeline selection. Pre-roll is particularly useful with punch recording since it gives you time to “catch the beat” before reaching the punch-in point. To set the pre-roll amount, type a new value in this field, or drag the Pre-Roll flag in the Main Timebase ruler.

**Post-Roll** During playback or record, specifies the amount that plays after the end of a Timeline selection. Post-roll is useful in punch recording since playback continues after the punch-out point so you can check for a smooth transition to previously recorded material. To set the post-roll amount, type a new value in this field, or drag the Post-Roll flag in the Main Timebase ruler.

**Start** Specifies the beginning of the play or record range. You can set the start point by entering a location in this field, or by dragging the corresponding Timeline Selection or Play Start Marker in the Main Timebase ruler. For more information, see “Timeline Selection Markers” on page 521.

**End** Specifies the end of the play or record range. You can set the end point by entering a location in this field, or by dragging the corresponding Timeline Selection Marker in the Main Timebase ruler. For more information, see “Timeline Selection Markers” on page 521.

**Length** Specifies the length for the play or record range. You can set the length by entering a location in this field, or by selecting a range in any Timebase ruler.

*When the Timeline and Edit selections are linked, you can make an Edit selection in a track’s playlist to set the play and record range. See “Linking or Unlinking Timeline and Edit Selections” on page 629.*

**MIDI Controls**

To view the MIDI controls in the Transport, do one of the following:

- Select View > Transport > MIDI Controls.

- Command-click (Mac) or Control-click (Windows) the Expand/Collapse “+” button in the Transport window to display the MIDI controls.
**Wait for Note** When selected, recording does not begin until a MIDI event is received. This ensures that you begin recording when you’re ready to play, and that the first note, or other MIDI data, is recorded precisely at the beginning of the record range.

>You can press F11 to turn on Wait for Note, unless the MIDI preference for “Disable F11 for Wait for Note” is enabled.

⚠️ On Mac, the Desktop Keyboard Shortcut uses the same key command that Pro Tools uses for Wait For Note (F11). To use F11 for Wait For Note in Pro Tools, be sure to disable the Desktop Keyboard Shortcut in the Apple System Preferences.

**Metronome Click** When selected, Pro Tools generates a metronome pulse that can be set to trigger built-in sounds or MIDI instruments during playback and recording.

The Pro Tools metronome is configured in the Click/Countoff Options dialog. Double-click the Metronome Click button to open the Click/Countoff Options dialog.

>With the Numeric Keypad mode set to Transport, press 7 to enable the Metronome Click.

**Count Off** When selected, Pro Tools counts off a specified number of measures (indicated in the button) before playback or recording begins.

Double-click the Count Off button, to open the Click/Count Off Options dialog.

>With the Numeric Keypad mode set to Transport, press 8 to enable the Count Off.

**MIDI Merge** When selected (Merge mode), recorded MIDI data is merged with existing track material. When deselected (Replace mode), recorded MIDI data replaces existing track material.

>With the Numeric Keypad mode set to Transport, press 9 to enable MIDI Merge.

**Tempo Ruler Enable (Conductor)** When selected, Pro Tools uses the tempo map defined in the Tempo ruler. When deselected, Pro Tools switches to Manual Tempo mode and ignores the Tempo ruler.

In Manual Tempo mode, you can enter a BPM value in the tempo field, or tap in the tempo with the T key on your alphanumeric keyboard.

**Current Meter** Displays the session’s current meter based on the play location. Double-click the Current Meter indicator to open the Change Meter window.

**Current Tempo** Displays the session’s current tempo based on the play location. In Manual Tempo mode, you can enter a BPM value into this field, or manually tap in a tempo with a computer keyboard or an external MIDI keyboard.

**Output Meters**

Pro Tools provides Output meters in the Transport that display the monitoring levels for signals routed to the physical outputs on your audio interfaces from your session or to internal busses in the session. The top LED is red and indicates clipping at the converters on your audio interface (DAC) on the corresponding channels or on internal busses.
To view the Output Meters in the Transport:

1. Do one of the following:
   - Select View > Transport > Output Meters.
   - Click the Transport Window menu (in the upper-right corner of the window) and select or deselect Output Meters.
   - Right-click in the Transport window and select or deselect Output Meters.

2. From the menu, select or deselect Output Meters.

Transport Window menu

Output meters in the Transport window

For more information, see “Output Meters” on page 1073.

Track Collaboration
(Projects Only)

The Track Collaboration controls can be shown or hidden in the Transport window. They mirror the controls at the top of the Edit window.

MIDI Editor Windows

MIDI Editor windows let you view and edit MIDI notes and controller data. You can open multiple MIDI Editor windows to work on different parts of your MIDI arrangements separately. MIDI Editor windows show Instrument and MIDI track data superimposed in Notes view, or on separate tracks in Notation view, and lets you view and edit MIDI controller data (such as velocity, pitch bend, and mod wheel) in controller lanes under the Notes pane.

For more information, see Chapter 35, “MIDI Editors.”
Displaying the MIDI Editor in the Edit Window

You can choose to show (or hide) a MIDI Editor pane at the bottom of the Edit window (below the Tracks pane).

To show (or hide) the MIDI Editor view in the Edit window, do one of the following:

- Select (or deselect) View > Other Displays > MIDI Editor.
- Click the MIDI Editor Show/Hide icon in the lower left corner of the Tracks pane in the Edit window.
- Double-click the divider below the Tracks pane in the Edit window.
- From the Edit Window menu, select (or deselect) MIDI Editor.
- Press Shift+Option+Control+“=” (Mac) or Shift+Alt+Start+“=” (Windows).

Score Editor Window

The Score Editor window lets you view and edit Instrument and MIDI tracks as music notation. It automatically transcribes MIDI performances in real-time. You can print a score of your session or just parts from individual tracks.

For more information, see Chapter 36, “Score Editor.”

Workspace Browsers

Pro Tools can database your session and media files and directories using Workspace browsers. Browsers provide an intuitive user interface within Pro Tools to quickly access both online and offline media files and sessions.

Browsers in Pro Tools are analogous to windows in your computer’s operating system (such as Windows Explorer or the Mac Finder), but are specially designed for working in Pro Tools. Multiple browsers can be displayed simultaneously, and arranged independently with custom display settings for each.

Browsers let you search and sort audio files, video files, and sessions. These files are displayed in browsers and can be dragged directly into the current Pro Tools session.

When offline items are needed, Pro Tools lets you find the correct matching files, then relink to online media.

To open/close a Workspace browser focused on Volumes, press Option+; (Mac) or Alt+; (Windows).

To open a default Workspace browser focused on Volumes, press Option+I (Mac) or Alt+I (Windows). Press these key combinations again to open additional Workspace browsers.

To open a Workspace browser with Soundbase and the Tags pane revealed, press Option+Control+I (Mac) or Alt+Start+I (Windows). Press these key combinations again to open additional Workspace browsers with Soundbase.

To bring all browsers to the front, press Option+J (Mac) or Alt+J (Windows).

To send all browsers to the back, press Option+Shift+J (Mac) or Alt+Shift+J (Windows).

The main elements of a Workspace browser (see the figure below) include the following:

**View Presets** Let you store up to 5 different browser views.

**Preview Controls** Provide tools for auditioning audio files from the browser.
Search Tools  Let you search your system for files and folders by simple or advanced search criteria.

Browser Menu  Provides commands for file management.

Column Headers  Display the type of metadata displayed in the Items List. Column Headers can be:
• Resized by dragging the column border, or rearranged by dragging the Column headers.
• Dragged to either of two available panes, the Fixed or Scrolling panes.

Soundbase  Lets you tag audio files with descriptive metadata that you can then use as search criteria.

Locations Pane  Provides a view of Volumes (and folders and files), Catalogs, and the currently open Session for your system.

Browser Pane  Provides a view of items on your system contained within the Volume (or folder), Catalog, or open session that is selected in the Locations pane. Alternatively, the Browser pane displays search results.

For detailed information about Workspace browsers, see Chapter 17, “Workspace Browsers.”

Task Manager Window  
The Task Manager window is a utility for viewing and managing all of the background tasks that you initiate with Pro Tools. Use the Task window to monitor, pause, or cancel background tasks such as file copies, searches, indexing, and fade creation.

For detailed information about the Task window, see “Task Manager Window” on page 354.

Artist Chat Window  
The Artist Chat window lets you invite and communicate using text chat with collaborators for your Pro Tools projects.

For detailed information about the Artist Chat window, see Chapter 18, “Artist Chat Window.”

In-Application Web Browser  
Pro Tools provides easy access to the online Avid Store, as well as web-based Pro Tools Help, the Avid Support Center, and other online resources using two in-application Web browsers.

Avid Marketplace  Provides a secure web connection to Avid’s online commerce web pages for Pro Tools.

Pro Tools Online  Provides easy access to web-based Pro Tools Help, the Knowledge Base, and Avid Audio community forums.

To launch the Pro Tools in-application Web browser for online commerce, choose one of the following from the Marketplace menu:
• Your Account
• Plug-ins
• Support Center
• Upgrades

To launch the Pro Tools in-application Web browser for online resources, choose one of the following from the Help menu:
• Pro Tools Help
• Pro Tools Knowledge Base
• Avid Audio Forums
• Avid Support Center
Pro Tools In-Application Web Browser Navigation Controls

The Pro Tools in-application Web browser provides a few simple navigation controls in the Web Browser Tool Bar.

Go Backward Clicking the Go Backward button navigates back to the previously viewed page.

Go Forward Clicking the Go Forward button navigates forward to the next page.

Go Home Clicking the Home button navigates to the starting page for the currently selected Location.

Refresh Clicking the Refresh button reloads the currently viewed page.

Locations Clicking a location button navigates to the corresponding starting page on the Avid website. The Avid Marketplace and Pro Tools Online browsers provide different Location options.

Launching an External Web Browser

You can launch the currently viewed page in the default Web browser for your operating system.

To launch the currently viewed page in an external browser:
- Click the Launch in External Web Browser icon in either the Avid Marketplace window or the Pro Tools Online window.
**Avid Marketplace**

The Marketplace menu in Pro Tools lets you access your Avid Account, the Avid online store (to shop for plug-ins, or Avid support).

To log in to your online Avid account:
- Choose Marketplace > My Account.

To access the Avid online store for plug-ins:
- Choose Marketplace > Plug-ins.

You can also access the Avid online store from the AudioSuite menu and from track Insert selectors for plug-ins by choosing the Avid Marketplace option.

To access the Avid online store for support and training, do one of the following:
- Choose Marketplace > Avid Support Center.
- Choose Help > Avid Support and Training.

**Pro Tools Online**

In addition to the local resources that are installed with Pro Tools, the Help menu also provides access to the Pro Tools Online browser.

To access the Pro Tool online resources from the Help menu:
- Click Help and choose one of the following:
  - Pro Tools Help
  - Pro Tools Knowledge Base
  - Avid Audio Forums

**Pro Tools Help**

The Pro Tools Help command provides access to web-based Pro Tools Help within the Pro Tools web browser. Web-based Help provides the latest Pro Tools Help files in (English and in translation) as they become available.

If you are not connected to the Internet, Pro Tools will open the local English Help files that are installed with Pro Tools.

💡 You can also access Pro Tools Help online using Safari or Explorer. This can be useful if Pro Tools is not running, or if you want to change the version or language of Help you are using. For more information, visit [http://apps.avid.com/ProToolsHelp](http://apps.avid.com/ProToolsHelp).

**Pro Tools Knowledge Base**

The Pro Tools Knowledge Base command provides access to the online Avid Knowledge Base using the Pro Tools in-application web browser. The Avid Knowledge Base provides extensive information for you to solve problems you may encounter with Pro Tools (including compatibility information and software updates).

**Avid Audio Forums**

The Avid Audio Forums command provides access to the online Avid Audio Forums using the Pro Tools in-application web browser. The Avid Audio Forum provide a broad-based user community where you can interact with other Pro Tools users.

**Avid Support Center**

The Avid Support Center command provides access to the online Avid Support Center using the Pro Tools in-application web browser. The Avid Support Center provides support instructions for your Avid products.
Managing Windows

Window Configurations

Pro Tools provides a powerful means of managing the configuration of windows in your session, as well as the internal configurations of the Edit, Mix, MIDI Editor, Score Editor, and Transport windows. Use the Window Configuration List to create (or delete) and manage stored Window Configurations. Pro Tools lets you store up to 99 Window Configurations. Window Configurations are saved with the session.

Create a session template with your favorite Window Configurations. You can then use the template when you start a new session, or you can use Import Session Data to import Window Configurations into your current session.

Creating New Window Configurations

To create a new Window Configuration:

1 Open the windows you want to include in the Window Configuration and position them where you want on the screen.

2 Do one of the following:
   • Choose Window > Configurations > New Configuration.
   • If the Window Configuration List is open, choose New Configuration from the Window Configuration List pop-up menu.

   New Window Configuration dialog

3 In the New Window Configuration dialog, do one of the following:
   • Select Window Layout and whether or not to include the Edit, Mix, Targeted MIDI Editor, Score Editor, and Transport window display settings.
   • Select a Window Display Settings option from the pop-up menu (Edit Window, Mix Window, MIDI Editor (Targeted), Score Editor Window, or Transport Window).
   • If there are any shown MIDI CC lanes that you want to save with the configuration, enable Include MIDI Lanes in Display Settings.

4 Name the Window Configuration.

5 You can type a different number for the new Window Configuration. If the number you type is already used by another Window Configuration, you are prompted to replace it or Cancel. Otherwise, Pro Tools automatically fills in the first available number (1–99) for the Window Configuration.
6 Type any comments for the new Window Configuration.

7 Click OK to store the new Window Configuration, or Cancel.

The new Window Configuration is added to the Window Configuration List.

To create a new Window Configuration at a specific numbered slot:

- On the numeric keypad, type Period (.), a number (1–99), and then Plus (+) to add a new Window Configuration at that number slot.

⚠️ If a Window Configuration already exists at that numbered slot, the new WindowConfiguration overwrites it.

Recalling Window Configurations

You can use the Window Configuration List to recall stored Window Configurations. You can also use the Number Keypad on your computer keyboard to recall a specific Window Configuration.

To recall a Window Configuration, do one of the following:

- Select the Window Configuration from Window > Configurations.
- In the Window Configuration List, click the Window Configuration to recall it.
- On the numeric keypad, press Period (.), the number of the Window Configuration (1–99), and then Asterisk (*).

The Pro Tools session’s screen layout updates with the stored Window Configuration.

Undoing Window Configurations

Pro Tools lets you revert to the previous Window Layout and Window Settings with a single level of undo. This is useful, for example, if you recall a Window Configuration, but then decide you want to revert to the previous screen state.

To undo a Window Configuration:

- On the numeric keypad, press Period (.), 0, and then Asterisk (*).

To redo a Window Configuration:

- On the numeric keypad, press Period (.), 0, and then Asterisk (*).

If Auto-Update Active Configuration is enabled, undoing the Window Configuration reverts to the previously stored Window Configuration without automatically saving changes (see “Updating Window Configurations” on page 205).

Editing Window Configurations

You can change which properties are stored with Window Configurations, as well as the number, name, or comments.

To edit a Window Configuration:

1 In the Window Configuration List, select the Window Configuration you want to edit.

2 From the Window Configuration List pop-up menu, select Edit <Name>.

3 In the Edit Window Configuration dialog, edit the configuration and click OK.
**Updating Window Configurations**

After you recall a stored Window Configuration, you can make changes to the window layout and window settings, and then update the stored Window Configuration with your changes. You can do this manually, or you can have Pro Tools automatically update the active configuration.

**To manually update a Window Configuration, do one of the following:**

- Choose Window > Configurations > Update Active Configuration. The active Window Configuration updates to include any changes to its included properties (Window Layout and Window Display Settings).

- From the Window Configuration List pop-up menu, choose Update <Name>. The selected Window Configuration updates with any changes to its included properties.

**To have Pro Tools automatically update the active Window Configuration, do one of the following:**

- Select Window > Configurations > Auto-Update Active Configuration.

- From the Window Configuration List pop-up menu, select Auto-Update Active Configuration.

When Auto-Update Active Configuration is selected, the active Window Configuration updates with every change to the Window Layout and Window Display Settings.

Window Configurations that do not include Window Layout and only store Window Display Settings cannot be made active and thus won’t automatically update. If you want to update a Window Configuration with changes to the Window Display Settings (such as the width of the Clips List in the Edit window), use the Update command in the Window Configuration List.

**Clearing Window Configurations**

Clearing a window configuration removes it and its associated slot number while keeping the slot numbers of other window configurations unchanged. The Clear command is useful if you want to insert another configuration in the same slot.

**To clear a Window Configuration:**

1. In the Window Configuration List, select the Window Configuration you want to clear.

2. From the Window Configuration List pop-up menu, select Clear <Name>.

**Deleting Window Configurations**

Deleting a Window Configuration removes it and its slot number, and renumbers any subsequent Window Configurations.

**To delete a Window Configuration:**

1. In the Window Configuration List, select the Window Configuration you want to delete.

2. From the Window Configuration List pop-up menu, select Delete <Name>.

**To delete all Window Configurations:**

- From the Window Configuration List pop-up menu, select Delete All.

**Importing Window Configurations**

You can import Window Configurations from another session using Import Session Data.

**To import Window Configurations:**

1. Choose File > Import > Session Data.

2. Select the Window Configurations option.
If you only want to import Window Configurations, click the Session Data to Import pop-up menu and select None.

Click OK.

Arranging Windows

Pro Tools provides commands to tile or cascade all open windows. Floating windows (such as plug-in windows) and the Transport window are not affected by these commands.

To arrange windows:
- Choose Window > Arrange and select one of the following:
  - **Tile**: Arranges all open windows in a tiled pattern on the screen.
  - **Tile Horizontal**: Arranges all open windows in a horizontally tiled pattern on the screen. This option is not available if there are too many windows open.
  - **Tile Vertical**: Arranges all open windows in a vertically tiled pattern, side by side, on the screen. This option is not available if there are too many windows open.
  - **Cascade**: Arranges all open windows in cascading pattern on the screen.

Hiding All Floating Windows

The Hide All Floating Windows command hides or shows all floating windows. This is useful for quickly clearing the screen of all floating windows so that you can work in the Edit or Mix windows.

To hide or show all floating windows:
- Select or deselect Window > Hide All Floating Windows.

Press Command+Option+Control+W (Mac) or Control+Alt+Start+W (Windows) to hide or show all floating windows.

Closing Windows

To close an open window:
1. Make sure the window you want to close is in the foreground.
2. Do one of the following:
   - Click the Close button for the window.
   - Choose Window > Close Window.

Press Command+W (Mac) or Control+W (Windows) to close the frontmost window.

How Window Configurations Work

A Window Configuration can store the location and size of all open windows, including:
- Edit window
- Mix window
- Targeted MIDI Editor window
- Score Editor window
- Workspace browsers
- Session Setup window
- Time, Tempo, and Event Operations windows
- MIDI Event List
- Real-time MIDI Properties window
- Beat Detective window
- Plug-In windows
- Panner windows
• Mic Pre windows
• All floating windows listed in the Window menu:
  • Task Manager window
  • Transport window
  • Big Counter window
  • Automation window
  • Memory Locations window
  • Machine Track Arming window
  • Video Universe window
  • Video window
  • Color Palette window
  • Undo History window
  • Disk Space window
  • System Usage window

A Window Configuration can also store the Window Display settings for the Edit, Mix, Targeted MIDI Editor, Score Editor, and Transport windows.

Window Configuration List

The Window Configuration List lets you recall and manage stored Window Configurations, as well as create new Window Configurations.

To open the Window Configuration List:

- Select Window > Configurations > Window Configuration List.

Press Command+Option+J (Mac) or Control+Alt+J (Windows) to show or hide the Window Configuration List.

Window Configuration Properties

Window Configurations can be stored and recalled with the layout of windows in your Pro Tools session, as well as with the settings for the Edit, Mix, and Transport windows. You can specify which of these properties are stored for each Window Configuration either in the New Window Configuration dialog or the Edit Window Configuration dialog.

Number Is the number of the slot in which the Window Configuration is stored (1–99). You can type Period (.), the number of the Window Configuration, and then Asterisk (*) on the numeric keypad on your computer keyboard to recall the Window Configuration stored in that slot.

Name Is the name of the stored Window Configuration.

Window Layout When enabled, stores the size and location of all open windows.
Include Edit, Mix, Targeted MIDI Editor, Score Editor, and Transport Display Settings When enabled, stores all window display settings for the Edit, Mix, Targeted MIDI Editor, Score Editor, and Transport windows with the Window Configuration (such as whether or not the Clips List is shown in the Edit window). This option is only available when the Window Layout option is enabled.

Window Display Settings Stores only the window display settings for the selected window (Edit, Mix, Targeted MIDI Editor, Score Editor, or Transport):

- Edit Window Display Settings
  - Width of the Tracks List and Groups List
  - Height of the Tracks List
  - Width of the Clips List
  - What rulers are shown (the main ruler is always shown)
  - What track columns are shown (such as Inserts, Sends, or Comments)
  - Tempo editor display
  - Whether Transport controls are shown in the Edit window
  - Edit Window Toolbar arrangement
- Mix Window Display Settings
  - Width of the Tracks List and Groups List
  - Height of the Tracks List
  - What track rows are shown (such as Inserts, Sends, or Comments)
  - Narrow/wide mixer view
- Score Editor
- MIDI Editor (Targeted)
- MIDI Editor (Untargeted)
- Transport Window Display Settings
  - Counters display
  - MIDI controls display
  - Expanded view

Include MIDI Lanes in Display Settings Stores the layout of MIDI Automation Lanes in MIDI Editor windows, whether docked in the Edit window or when open as a separate window. Any Window Configuration that includes MIDI Lanes in Display Settings will recall that exact window and MIDI Automation Lane layout.

Comments Lets you type comments for the Window Configuration.

Window Configuration Commands and Options

There are three main types of Window Configuration commands and options

- View Filter icons
- Window Configuration List pop-up menu items
- Active Window configuration options

View Filter Icons

Using the View Filter icons, the Window Configuration List lets you show or hide Window Configurations based on whether or not they are stored with Window Layout, Edit Window settings, Mix Window settings, Score Editor window settings, MIDI Editor Window settings, or Transport Window settings.
To show or hide Window Configurations in the Window Configuration List, do one of the following:

- Click the View Filter icon to show or hide Window Configurations that include that property (Window Layout, Edit Window Settings, Mix Window Settings, Score Editor Window Settings, MIDI Editor Window Settings, or Transport Window Settings).

- Select or deselect the View Filter item in the Window Configuration List pop-up menu.

### Window Configuration List Pop-Up Menu

You can select viewing and sorting options, along with commands for creating and removing Window Configurations, from the pop-up menu in the Window Configuration List.

**View Filter**

Let you show or hide Window Configuration filter icons in the Window Configuration List as well as show or hide Window Configurations with Window Layout, Edit Window Settings, Mix Window Settings, Score Editor Window Settings, MIDI Editor Window Settings, or Transport Window Settings.
Show Comments  Lets you show or hide Comments in the Window Configuration List.

New Configuration  Creates a new Window Configuration. This command is also available from Window > Configurations.

Update <Name>  Updates the selected Window Configuration with any changes to the layout and settings of windows depending on the Window Configuration’s properties. This command is also available from Window > Configurations.

Edit <Name>  Opens the Edit Window Configuration dialog where you can edit the properties of the selected Window Configuration.

Clear <Name>  Clears the selected Window Configuration without deleting the slot (number).

Delete All  Deletes all Window Configurations.

Insert Slot Before <Name>  Inserts a new slot before the selected Window Configuration and, if necessary, increments the number of each following slot.

Delete <Name> Slot  Deletes the selected Window Configuration and its slot (number), and renumbers each subsequent slot.

Auto-Update Active Configuration  Automatically updates the active Window Configuration as you make changes to the layout and settings of windows. If Auto-Update Active Configuration is enabled, the number of the active configuration is also displayed in the Window menu. This command is also available from Window > Configurations.

Active Window Configuration

The active Window Configuration is indicated by a diamond to the left of the Window Configuration Number in the Window Configuration List and in the Configurations submenu (Window > Configuration). If Auto-Update Active Configuration is enabled, the number of the active configuration is also displayed in the Window menu. Only Window Configurations that include Window Layout can be made active.

Menus

Pro Tools menus provide commands and options for configuring and working with Pro Tools, sessions, and session material.

Pro Tools Main Menus

Pro Tools includes the following main menus:

File  Provides commands that are used to create and maintain Pro Tools sessions.

Edit  Provides commands that are used to edit and manipulate the current selection and affect data in the Timeline or the clipboard.

View  Provides options and commands to customize what is shown in various windows.
**Track** Provides commands that are used to create, manage, and edit tracks.

**Clip** Provides commands that are used to manage and edit clips.

**Event** Provides commands for editing audio and MIDI events.

**AudioSuite** Provides AudioSuite plug-ins.

**Options** Provides commands that let you select several editing, recording, monitoring, playback, and display options.

**Setup** Provides commands to open dialogs and windows or configure various Pro Tools hardware and software parameters.

**Window** Provides commands to toggle the display of various Pro Tools windows.

**Marketplace** Provides access to your online Avid account, the online Plug-In finder, the online Avid Support Center, and upgrade options for your current version of Pro Tools.

**Help** Provides access to searchable Pro Tools Help, the online Pro Tools Knowledge Base, and the online Avid Audio Forums. The Help menu also provides easy access to PDF documentation (installed with Pro Tools).

The Help menu also provides access to the Avid Support Center and to the Check For Updates command.

---

**Track, Clip, and Groups List Menus**

The Track, Clip, and Groups Lists provide pop-up menus for managing and working with the contents of each list, as follows:

**Tracks List Menu** Provides commands to show and hide tracks in the Mix, Edit, MIDI Editor, and Score Editor windows. The Tracks List pop-up menu also lets you sort the contents of the Tracks List.

*For more information, see “Tracks List” on page 242.*

**Groups List Menu (Edit Groups and Mix Groups)** Provides commands to create, display, suspend, and delete Mix and Edit Groups.

*For more information, see “The Groups List” on page 279*

**Clips List Menu (Edit Window Only)** Provides commands to find, select, sort, clear, rename, time stamp, compact, export, and recalculate waveform overviews of items in the Clips List. The pop-up menu also lets you set the drop order for clips dragged from the Clips List and dropped in the Timeline.

*For more information, see Chapter 16, “The Clips List.”*
Track Name and Clip Name Right-Click Menus

Track and clip names provide Right-click menus for managing and working with tracks or clips, as follows:

Track Name Right-Click Menu Right-clicking a track name in the Edit window, Mix window, or the Tracks List provides access to various track commands (such as show/hide, make active/inactive, rename, duplicate, and delete tracks).

Clip Name Right-Click Menu (Edit Window Only)

Right-clicking a clip name in the Clips List provides commands to clear, rename, time stamp, or replace clips (Pro Tools HD software only). The pop-up menu also lets you export clip definitions or selected clips as files, recalculate waveform overviews, select the parent file of selected clips in a Workspace Browser, or select a clip as an object in the Edit window.

For more information, see Chapter 16, “The Clips List.”

Group Name and Track Group ID Indicator Pop-Up Menus

When you click and hold on a group name in the Groups List, or click on a Group ID indicator in a track, a pop-up menu provides access to various group commands (such as selecting tracks in a group).

For more information, see “Group Name and Track Group ID Indicator Pop-Up Menus” on page 280.

Tool Tips

Pro Tools provides Tool Tips in all main windows. Holding the cursor for a few seconds over an abbreviated name, or unlabeled icon or tool, displays either the function or details of the item (depending on the Tool Tips preferences settings).

To configure Tool Tips for Pro Tools:

1. Choose Setup > Preferences, and click the Display tab.

2. In the Basics section, enable the Tool Tips options you want displayed.

Function Shows the functional name of different Pro Tools items (such as specific buttons, indicators, modes, selectors, and Edit tools).

Details Shows abbreviated or hidden Pro Tools names or values for different Pro Tools items (such as insert names, gain levels, settings, and routing assignments).

To turn off Tool Tips, leave both options deselected.

3. Click OK.
Chapter 13: Tracks

Pro Tools provides different types of tracks for working with audio, MIDI, and video in Pro Tools sessions.

Track Types

In a Pro Tools session, you can have several different types of tracks. These can include audio, Auxiliary Input, Master Fader, VCA Master, MIDI, Instrument, and video tracks.

Audio, Auxiliary Input, Master Fader, and VCA Master Tracks

Pro Tools provides mono, stereo, and multichannel format audio, Auxiliary Input, Master Fader, and VCA Master tracks.

Audio Tracks Audio tracks let you record to disk and play back from disk recorded or imported audio files.

Auxiliary Input Tracks Auxiliary Input tracks can be used as effects sends, destinations for submixes, as a bounce destination, as inputs to monitor or process audio (such as audio from external MIDI instruments), and for many other audio routing tasks.

Master Fader Tracks Master Fader tracks control the overall level of audio paths that are routed to physical output paths. For example, you could have 24 tracks in a session with channels 1–8 routed to Analog Output 1–2, channels 9–16 to Analog Output 3–4, and channels 17–24 to Analog Output 5–6. You could then create three master faders, one to control each of these output pairs.

Master Fader tracks have additional uses (such as controlling submix levels). For more information, see “Master Fader Tracks and Signal Flow” on page 1044.

VCA Master Tracks VCA Master tracks (or VCA Masters) emulate the operation of voltage-controlled amplifier channels on analog consoles, where a VCA channel fader would be used to control, group, or offset the signal levels of other channels on the console.

VCA Master tracks do not pass audio, so they do not have inputs, outputs, inserts, or sends. A Mix Group is assigned to a VCA Master track, which appears in the VCA track’s Assignment selector.

The controls of the tracks in that Group, called the slave tracks, are modified by the controls on the VCA Master. For more information, see “VCA Master Tracks” on page 1047.

Video track features are described in Chapter 60, “Working with Video in Pro Tools”
MIDI Tracks

MIDI tracks record, store, and playback MIDI data. You cannot select a track format when you create a MIDI track, because audio does not pass through it.

Instrument Tracks

Instrument tracks are a special type of track that provide both MIDI and audio capabilities in a single channel strip. Instrument tracks simplify using software and hardware instruments to record and monitor MIDI instruments.

Video Tracks

Video tracks let you add or import QuickTime (Windows and Mac).

With an Avid video peripheral and Pro Tools, you can add or import Avid video to the Pro Tools Timeline (see Chapter 60, “Working with Video in Pro Tools.”)

Video tracks only appear in the Edit window, and video can be viewed in the Video window.

Track Formats

Mono Tracks

A mono audio, Auxiliary Input, Master Fader, or Instrument track controls volume, and, in some cases, panning, for a single channel of audio. A mono audio track uses a single voice. A mono track can also be routed to a multichannel output.

Stereo Tracks

A stereo audio, Auxiliary Input, Master Fader, or Instrument track is a single channel strip for two channels of audio as a stereo pair. Stereo audio tracks use two voices.

Multichannel Tracks (Pro Tools | Ultimate Software Only)

A multichannel track is a single channel strip that plays multiple channels of audio (from 3 to 8 channels at a time). This allows Pro Tools to support multichannel mixing formats including LCRS, 5.1, 6.1, and others. Audio, Auxiliary Input, Master Fader, and Instrument tracks can all use any supported multichannel format.

For more information on surround mixing with Pro Tools, see the following:

• Chapter 52, “Pro Tools Setup for Surround”
• Chapter 53, “Multichannel Tracks and Signal Routing”
• Chapter 54, “Surround Panning and Mixing”
Track Channel Strips in the Mix Window

Audio Track Channel Strips

Each audio track has its own set of channel strip controls, including volume, pan, record enable, input monitoring, automation mode, solo, mute, and voice assignment.
**Auxiliary Input Track Channel Strips**

Each Auxiliary Input track has its own set of channel strip controls, including volume, pan, automation mode, solo, and mute.

**Master Fader Track Channel Strips**

Each Master Fader track has its own set of channel strip controls, including volume and automation mode.
VCA Master Track Channel Strips

Each VCA Master track has its own set of channel strip controls, including volume, record enable, input monitoring, automation mode, solo, and mute.

For more information, see “VCA Master Tracks” on page 1047.

MIDI Track Channel Strips

Each MIDI track has its own set of channel strip controls, including MIDI volume, pan, record enable, automation mode, solo, mute, patch assignment, and channel assignment.

VCA Master track

MIDI channel strip
**Instrument Track Channel Strips**

Each Instrument track has its own set of channel strip controls, including audio (like an Auxiliary Input track) volume, pan, automation mode, solo, and mute, and MIDI (like a MIDI track) record enable. Instrument tracks have an additional Instruments view that provides controls for MIDI input, output, mute, volume, and pan (like on a MIDI track).
Track Controls and Indicators in the Edit Window

Audio Track Controls

Each audio track has its own set of track controls, including Track Name, Playlist, Record Enable, Input Monitoring, Solo, Mute, Track View, Track Height, Track Freeze, Timebase, Elastic Audio, Voice Assignment, and Automation mode.

Auxiliary Input Track Controls

Each Auxiliary Input track has its own set of track controls, including Track Name, Solo, Mute, Track View, Track Height, Track Freeze, Timebase, and Automation mode.

Master Fader Track Controls

Each Master Fader track has its own set of track controls, including Track Name, Track View, Track Height, Timebase, and Automation mode.
VCA Master Track Controls

Each VCA Master track has its own set of track controls, including Track Name, Playlist, Record Enable, Input Monitoring, Solo, Mute, Track View, Track Height, Timebase, and Automation mode.

MIDI Track Controls

Each MIDI track has its own set of track controls, including Track Name, Playlist, Record Enable, Solo, Mute, Track View, Track Height, Patch, Timebase, and Automation mode.

---

Edit window track controls for a VCA Master track (medium track height)

Edit window track controls for a MIDI track (medium track height)
Instrument Track Controls

Each Instrument track has its own set of track controls, including Track Name, Playlist, Record Enable, Solo, Mute, Track View, Track Height, Track Freeze, Patch, Timebase, and Automation mode.

Video Track Controls

Each video track has its own set of track controls, including Track Name, Playlist, Online, Track View, and Track Height.

Edit Window Views

In addition to track controls and playlists (of clips of events on the Timeline), the Edit window provides the following views that correspond to channel strip controls in the Mix window:

- Comments
- Mic Preamps
- Instruments
- Inserts (A–E and F–J)
- Sends (A–E and F–J)
- I/O
- Object (Pro Tools Ultimate with Dolby Atmos only)
- Real-Time Properties
- Track Color
- Track Collaboration (projects only)
- All
- Minimal

See also “Views in the Mix and Edit Windows” on page 1052.

Comments View

Comments view lets you type and view comments for a specific track.

For more information on Comments view, see “Adding Comments to Tracks” on page 233.

Mic Preamps View

The Mic Preamps view shows controls for tracks with physical audio inputs routed through PRE.

For more information, see the PRE Guide.
Instruments View

Instruments view provides MIDI controls for Instrument tracks: MIDI Input selector, MIDI Output selector, MIDI Volume, MIDI Pan, and MIDI Mute.

For more information, see “Assigning MIDI Input and Output for Instrument Tracks” on page 255.

Inserts View (A–E and F–J)

Inserts view provides up to ten inserts (software plug-ins and hardware I/O inserts for generating and processing audio) on each audio, Auxiliary Input, Master Fader, and Instrument track.

For more information on inserts, see Chapter 49, “Plug-In and Hardware Inserts.”

Sends View (A–E and F–J)

Sends view shows send assignments in each audio, Auxiliary Input, and Instrument track.

For more information, see “Configuring Sends View in the Mix and Edit Windows” on page 1064.

I/O View

In the Edit window, I/O view provides Input and Output selectors on audio, Auxiliary Input, Master Fader (output only), MIDI, and Instrument tracks (corresponding to the controls of the same name in the Mix window).

For details on Input and Output selectors, see “Assigning Audio Inputs and Outputs to Tracks” on page 246.

To show the I/O View in the Edit window:

- Select View > Edit Window > I/O.

Channel strips in the Mix window always display Input and Output selectors as well as volume and pan values, so there is no I/O view display option for the Mix window.

Volume/Peak/Channel Delay Indicator

The Volume indicator on an audio track has three display modes: Volume, Peak, and Channel Delay.

To toggle the Volume indicator display:

- Command-click (Mac) or Control-click (Windows) the indicator to toggle it between the following modes:

Volume Indicator (and Pop-Up Fader) Shows the current volume, or input level of a track as set by the track Volume fader. In I/O view (Edit window), click the Volume indicator to display the Volume pop-up fader, which can be used to adjust the volume.

Edit window I/O view, Volume pop-up fader (audio track)

Peak Indicator Functions as a headroom indicator based on the last peak playback level. To reset the peak counter, click anywhere in the meter. Values range from \(-\infty\) (no signal) to 0 dB.
Pan Indicator

The Pan indicator displays the current pan setting of a track. Pan values range from $<100$ (full left) to $100>$ (full right). Pan controls are only available for stereo tracks or for mono tracks routed to a stereo output.

In I/O view (Edit window), click the Pan indicator to display the Pan pop-up slider, which can be used to adjust panning.

Volume Fader

The Volume fader controls the playback level of a track when it is playing back, and the monitor level of the track when it is recording. You can link the record and monitor levels by enabling the Link Record and Play Faders option in the Operation preferences.

The maximum fader gain for a volume fader is $+12$ dB.

MIDI Volume Fader

If your MIDI sound module supports volume, the volume fader on a MIDI or Instrument track can send a value of 0–127 to the MIDI volume controller.

Real-Time Properties

In the Edit window, Real-Time Properties view provides access to Real-Time Properties controls (such as Quantize or Transpose) on MIDI and Instrument tracks. For more information, see “MIDI Real-Time Properties” on page 780.

Track Color

In the Edit window, Track Color view displays the Track Color strip at the left-most side of the Track controls.

Track Collaboration (Projects Only)

In the Edit window, Track Collaboration view provides access to the Track Collaboration controls for all track types except VCA and Video tracks. Track Collaboration controls are only available in projects and never in sessions. For more information, see “Track Collaboration Track View in the Edit and Mix Windows” on page 383.
Track Level Meters

On audio tracks, level meters indicate the level of the signal being recorded or played back from the hard drive. When an audio track is record-enabled or input monitoring-enabled, these meters indicate record or input monitoring levels respectively.

On Auxiliary Input, Master Fader, and Instrument tracks, level meters indicate the level of the signal being played through the channel output.

On MIDI tracks, and in Instruments view for Instrument tracks, the meter shows the MIDI velocity of the most recent MIDI event.

Fader Gain Scale
The Fade Gain scale indicates the amount of gain boost or attenuation of the signal by the Fader control.

Meter Type Scale Displays the meter scale for the selected Meter Type (see “Advanced Metering” on page 227).

Gain Reduction Meter Pro Tools provides the option to display a Gain Reduction Meter just to the right of the track signal meters on audio, Auxiliary Input, Instrument, and Master Fader tracks with supported dynamics plug-ins (such as the Avid Pro Compressor or Pro Expander). For more information, see “Configuring Gain Reduction Meters” on page 229.

Track Signal Meter For audio, Auxiliary Input, Instrument, VCA, and Master Fader tracks, meters show a green hash mark to indicate where digital 0 dB sits on the selected Meter scale. If digital 0 dB sits above the current Meter scale, the hash mark moves to the top of the Meter and is colored orange.

Clip Indicator Displays Red when clipping at the audio interface input or output converters, or when clipping while writing to a 16- or 24-bit audio file. The clip indicator displays yellow when the audio signal exceeds 0 dBFS in the internal mixer. For more information, see “Clip Indication” on page 225.

Pre- and Post-Fader Metering
You can globally set audio track level meters to indicate pre- or post-fader levels. When pre-fader metering is selected, the level meters show levels independent of fader position. With post-fader metering, the level meters respond to fader position.

To toggle track level metering between pre- fader and post-fader metering:
- Select Options > Pre-Fader Metering.
Peak Hold

Pro Tools meters provide a Peak Hold feature with three options: 3 Second, Infinite, or None.

To choose a Peak Hold setting:
1. Choose Setup > Preferences and click the Metering tab.
2. Select a Peak Hold option.
3. Click OK.

To clear a meter:
- Click anywhere on the meter.

To clear all meters, do one of the following:
- Option-click (Mac) or Alt-click (Windows) any meter.
- Choose Track > Clear All Clip Indicators.
- Press Option+C (Mac) or Alt+C (Windows).

Clip Indication

Because Pro Tools uses 64-bit floating point calculations for the mixer, there will never be any internal clipping in the mixer. However, it is possible to clip at the converters on your audio interface. It is also possible to clip when writing audio to disk in fixed point audio files (16-bit or 24-bit files only, 32-bit floating point files will not clip).

Pro Tools meters provide Clip Indication with three options: 3 Second, Infinite, or None. If clipping occurs, the topmost LED will stay lit.

💡 Clip indicators appear in plug-in, send, and track windows.
**Master Fader Track Clip Indicators**

Master Fader track clip indicators display red when the audio signal exceeds 0 dBFS, causing clipping at the output converters on your audio interface. This behavior is mirrored in the Output Meters in the Transport.

**Audio Track Clip Indicators**

Audio track clip indicators display red under the following circumstances, otherwise they display yellow:

- When an audio track is record enabled or set to input monitoring and the input assignment is set to a physical input signal that exceeds 0 dBFS causing clipping at the converters.
- When an audio track is recording to a fixed-point bit depth (16- or 24-bit) and the audio written to disk exceeds 0 dBFS causing clipping in the file.

**Auxiliary Input and Instrument Track, and Sends Clip Indicators**

Auxiliary Input and Instrument tracks, as well as Sends clip indicators display yellow when the audio signal exceeds 0 dBFS (even though there is no internal clipping). This provides a warning that these audio streams can clip at the output converters or when writing fixed-point file formats to disk.

**Wide Meters View**

Wide Meters view expands the width of the level meters for tracks in both the Mix and Edit windows, to make the track level meters easier to read. Wide Meters view are also available Narrow Mix view.

To toggle Wide Meters View on or off:

- Command-Option-Control-click (Mac) or Control-Alt-Start-click (Windows) any track level meter in the Mix or Edit window.
**Showing or Hiding Meters and Faders**

Pro Tools lets you show or hide Meters and Faders in the Mix window. This can be useful for conserving screen space, especially if you are working with a control surface.

**To show (or hide) meters and faders in the Mix window, do one of the following:**

- Select (or deselect) View > Mix Window Views > Meters and Faders.
- From the Mix Window View selector, select (or deselect) Meters and Faders.

**Advanced Metering**

Pro Tools lets you change metering ballistics and scales to match your needs for visually monitoring audio levels. For most users, the default settings for each of the Meter Type settings work best. However, for some broadcasters, post production facilities, and mixing and mastering facilities, other metering options may be desired so that Pro Tools metering matches the metering on various external consoles or other devices.

**Fader and Meter Scales**

In the Mix window, Pro Tools shows a gain boost and attenuation scale, measured in dB, to the left of the track Volume fader from +12 dB down to –INF dB. This scale shows how much changes to the fader affect the audio level for the track. In some cases, such as with Wide Meters view or greater-than-stereo channel widths, the Fader scale may not be displayed.

The values between the fader and the meters change depending on the selected Meter Type. For example, for the Peak Meter Type, the meter scale is from 0 dB down to –60 dB, while for the VU Meter Type, the meter scale is from +3 dB down to –20 dB.
Gain Reduction Meter Placement to Scale

The placement of the Gain Reduction meter (when shown) depends on the scale for the selected Meter Type. The top of the Gain Reduction meter will always match the reference level for the selected Meter Type. Likewise, the bottom the Gain Reduction meter scales to the range of the selected Meter Type.

Setting the Meter Type

You can set the Meter Type either in the Pro Tools Metering preferences or using the Right-click Meter menu. Depending on the Track and Master Meter Types Linked setting, you can set the Track (audio, Auxiliary Input, and Instrument tracks) or Master (Master Fader tracks) Meter Type settings independently.

To set the Meter Type for Track and Master meters in the Pro Tools Preferences:

1. Choose Setup > Preferences.
2. Click the Metering tab.
3. Enable or disable the Track and Master Meter Types Linked setting as desired.
4. Do one of the following:
   - If the Track and Master Meter Types Linked setting is enabled, select the desired Meter Type from either the Track Meters or Master Meters pop-up menus.
   - If the Track and Master Meter Types Linked setting is disabled, select the desired Meter Type for Track meters from the Track Meters pop-up menu and select the desired Meter Type for Master meters from the Master Meters pop-up menu.

Option-Right-click (Mac) or Alt-Right-Click (Windows) any track meter and select the desired Meter Type to set all track types to the same setting regardless of the Track and Master Meter Types Linked option is setting.

5. Click OK.

To set the Track Meter Type in the Mix or Edit windows:

1. Right-click on any Track meter.
2. From the Meter Type menu, select the desired option.

If the Track and Master Meter Types Linked option is enabled in the Pro Tools Metering Preferences, Master meters are also set to the selected Meter Type.
To set the Master Meter Type in the Mix or Edit windows:

1. Right-click on any Master meter.
2. From the Meter Type menu, select the desired option.

⚠️ If the Track and Master Meter Types Linked option is enabled in the Pro Tools Metering Preferences, all Track meters are also set to the selected Meter Type.

Configuring Gain Reduction Meters

You can configure the Gain Reduction meters either in the Pro Tools Metering preferences or using the Right-click Meter menu. The Gain Reduction Meters setting applies equally to Track and Master meters regardless of the Track and Master Meter Types Linked setting.

To configure Gain Reduction Meter Type, do one of the following:

- Choose Setup > Preference > Metering and select the desired Gain Reduction Meter Type option.
- Right-click on any Track meter and select the desired option from the Gain Reduction submenu in the Gain Reduction Meter Type menu.
Adjusting Track Width
(Mix Window)

The Narrow Mix command lets you view all tracks/channels in the Mix window at a reduced width to conserve screen space in a large session. (See “Track Height” on page 240, to adjust track height in the Edit Window.)

To reduce the width of tracks in the Mix window:
- Select View > Narrow Mix.

To display tracks at normal width:
- Deselect View > Narrow Mix.

Creating Tracks

You can create mono and stereo tracks on all Pro Tools systems. With Pro Tools Ultimate option, you can also create multichannel tracks (from LCR to 7.1).

When new tracks are created, they are given a default name that can be changed at any time.
- To insert new tracks next to a specific track in a session, select that track by clicking the track’s name in the Mix or Edit window before opening the New Tracks dialog. The new tracks are added immediately after the selected track.
- To insert new tracks after the last tracks in a session, make sure that no track names are selected on-screen before opening the New Tracks dialog.

You can also add tracks to your session by importing them from preexisting sessions. See “Importing Session Data” on page 416.

To create new tracks:
1. Do one of the following to open the New Tracks dialog:
   - Choose Track > New.
   - Right-click any Track Name in the Mix or Edit windows, or Tracks List, and choose New.

   Press Command+Shift+N (Mac) or Control+Shift+N (Windows) to open the New Tracks dialog

   To auto-scroll the Track Type pop-up menu in the New Tracks dialog, press Command (Mac) or Control (Windows) and use the Up/Down Arrow keys.

2. Select the type of track you want to add from the Track Type pop-up menu.

   To auto-scroll the Track Format pop-up menu, press Command (Mac) or Control (Windows) and use the Left/Right Arrow keys.

3. Select the track format (mono, stereo, or one of the multichannel surround formats) from the Track Format pop-up menu. Surround formats are only available with Pro Tools Ultimate.

   To auto-scroll the Track Format pop-up menu, press Command (Mac) or Control (Windows) and use the Left/Right Arrow keys.

Number of new tracks
Track Format
Track Type
Track Timebase
Add/Remove Row

New Tracks dialog
4 Select the timebase (samples or ticks) from the Track Timebase pop-up menu.

To auto-scroll the Track Timebase pop-up menu, press Command+Option (Mac) or Control+Alt (Windows) and use the Up/Down Arrow keys.

5 Enter the number of new tracks.

If you are creating various multiple new tracks, you can move to the next or previous row’s Number of New Tracks field by pressing Tab or Shift+Tab.

6 Do any of the following:
• To add more tracks, click the Add Row button.
• To remove a track, click the Remove Row button.

To add a new track, press Command+N (Mac) or Control+N (Windows), or press Command+Plus (+) (Mac) or Control+Plus (+) (Windows) on the numeric keypad.

To remove the last track from the New Tracks dialog, press Command+Minus (–) (Mac) or Control+Minus (–) (Windows).

7 To reorder tracks, drag a Move Row icon up or down.

8 Click Create.

Adding New Tracks by Double-Clicking in the Edit or Mix Windows

Pro Tools lets you add new tracks by double-clicking in blank space below tracks in the Edit window or below or to the right of tracks in the Mix window.

To add a new track of the same type and channel width as the last new track, do one of the following:

• Double-click in the empty area of the Mix window below or to the right of any current tracks.
• Double-click in the empty area of the Edit window below any current tracks.
• Double-click in the empty area below any current tracks in the Tracks List.

If no tracks exist in the session, a stereo audio track is created by default.

To add a new audio track of the same channel width as the last new track, do one of the following:

• Command-double-click (Mac) or Control-double-click (Windows) on the empty area of the Mix window below or to the right of any current tracks.
• Command-double-click (Mac) or Control-double-click (Windows) on the empty area of the Edit window below any current tracks.
• Command-double-click (Mac) or Control-double-click (Windows) in the empty area below any current tracks in the Tracks List.

If no tracks exist in the session, a stereo audio track is created by default.
To add a new Auxiliary Input track of the same channel width as the last new track, do one of the following:

- Control-double-click (Mac) or Start-double-click (Windows) on the empty area of the Mix window below or to the right of any current tracks.
- Control-double-click (Mac) or Start-double-click (Windows) on the empty area of the Edit window below any current tracks.
- Control-double-click (Mac) or Start-double-click (Windows) in the empty area below any current tracks in the Tracks List.

If no tracks exist in the session, a stereo Auxiliary Input track is created by default.

To add a new Master Fader track of the same channel width as the last new track, do one of the following:

- Shift-double-click on the empty area of the Mix window below or to the right of any current tracks.
- Shift-double-click on the empty area of the Edit window below any current tracks.
- Shift-double-click (Mac) in the empty area below any current tracks in the Tracks List.

If no tracks exist in the session, a stereo Master Fader track is created by default.

### Default Track Names

When creating new audio, Auxiliary Input, Master Fader, VCA Master, MIDI, and Instrument tracks, Pro Tools names them as “Audio,” “Aux,” “Master,” “VCA,” “MIDI,” or “Inst” accordingly and numbers them consecutively. For example, when you create the first two audio tracks in a new session, their default names are “Audio 1” and “Audio 2.” You can rename tracks and also log comments for each track.

### Naming Tracks

Track names are used to auto-name recorded audio files and clips.

**To rename a track:**

1. Do one of the following:
   - In the Mix or Edit window, double-click the Track Name button for the track you want to rename.
   - In the Tracks List, or Mix or Edit window, Right-click the track name for the track you want to rename.

2. In the Track Name/Comments dialog, type a new track name.

3. Click Previous or Next to rename other displayed tracks.

4. Click OK.

To move to the previous or next track in the Track Name/Comments dialog, you can press Command (Mac) or Control (Windows) and use the Up/Down or Left/Right Arrows.
Batch Renaming Tracks

The Batch Rename command for tracks is only available in the Track Name Right-click menu.

To rename selected tracks in batches:

1. Select the tracks you want to rename.
2. Right-click any selected track name in the Tracks List, Edit window, Mix window, Score Editor window, or a MIDI Editor window.
3. Choose Batch Rename.

   Press Option+Shift+R (Mac) or Alt+Shift+R (Windows) to open the Batch Track Rename dialog.

4. Configure the Batch Track Rename dialog as desired.
5. Click OK.

All selected tracks are renamed accordingly.

Adding Comments to Tracks

To add comments to a track, do one of the following:

- From the track channel strip, click directly in the Comments area, type any comments for the track, and press Return (Mac) or Enter (Windows).
- In the Edit or Mix window, double-click the Track Name button for a track. Then click directly in the Comments area, type any comments for the track, and press Return (Mac) or Enter (Windows).

   To enter a carriage return in the Comments area, press Shift+Return (Mac) or Shift+Enter (Windows) on the alphanumeric keyboard.

Track Numbering

With Track Number view enabled, each track is assigned a number corresponding to its position in the Mix and Edit Windows. When tracks are reordered, they are renumbered to maintain positional sequence.

To enable Track Number view:

- Choose View > Track Number.
Selecting Tracks

Tracks need to be selected for operations such as duplicating tracks or adding tracks to a group. One or more tracks can be selected at a time.

To select a track:
- Click the name of an unhighlighted track in its track channel strip.

To select a range of tracks:
1. Click the name of an unhighlighted track in its track channel strip.
2. Shift-click an additional button.

All tracks between the first track selected and the additional track will also be selected.

To select or deselect noncontiguous tracks, do one of the following:
- Command-click (Mac) or Control-click (Windows) Track Name buttons that are unhighlighted to select them.
- Command-click (Mac) or Control-click (Windows) Track Name buttons that are highlighted to deselect them.

To select all tracks:
- Option-click (Mac) or Alt-click (Windows) any Track Name button that is unhighlighted.

To deselect all tracks:
- Option-click (Mac) or Alt-click (Windows) any Track Name button that is highlighted.

Selecting Tracks when Making Edit Selections

Pro Tools lets you link Track selection with Edit selections. When Track and Edit selections are linked, you can make a selection within a track or across multiple tracks for editing and each associated track is selected (track names automatically highlight).

To link Track and Edit selections:
- Select Options > Link Track and Edit Selection.

Scrolling a Track into View

The Scroll To Track dialog lets you type the name of the track you want to scroll to. As you type a track name, only those tracks whose names begin with the letter you enter appear in the Scroll To Track list. You can also Right-click a track name in the Tracks List and choose Scroll Into View.

To scroll to a track by name in the Edit or Mix window:
1. Choose Track > Scroll To Track.

   Press Command+Option+F (Mac) or Control+Alt+F (Windows) to open the Scroll to Track dialog.

2. In the Scroll To Track dialog, type the first few letters of the track name you want to scroll to.
3 From the Scroll To Track list, select the track name you want to scroll to using the Up and Down Arrow keys.

Scroll To Track dialog

4 Press Return (Mac) or Enter (Windows), or click OK.

The specified track is selected and scrolled into view.

To scroll a track into view from the Tracks List Right-click menu:

- In the Tracks List, or Mix or Edit window, Right-click the track name and select Scroll into View.

Deleting Tracks

When you delete tracks, your audio or MIDI clip data remains in the Clips List, but your arrangement of the clips on the deleted track (the track’s playlist) will be lost.

If the track contains playlists that are not assigned to any track, you are prompted to delete or retain them.

⚠️ The Delete Track command cannot be undone.

To delete a track:

1 Click the name of the track in its track channel strip to select it.

 hü To select multiple tracks, Command-click (Mac) or Control-click (Windows) additional Track Names.

 hü To select a range of tracks, Shift-click additional Track Names.

2 Do one of the following:

- Choose Track > Delete.

- In the Tracks List, or Mix or Edit window, Right-click the track name and select Delete.

3 Click OK to remove the selected tracks from the session.

Duplicating Tracks

The Duplicate Track command lets you duplicate one or more tracks, including their audio or MIDI data, playlists, automation, and other attributes.

To duplicate one or more tracks:

1 Select the tracks you want to duplicate.

 hü For information, see “Selecting Tracks” on page 234.
2 Do one of the following:
• Choose Track > Duplicate.
• Press Option+Shift+D (Mac) or Alt+Shift+D (Windows).
• Right-click the name of the track in the Tracks List, or Mix or Edit window, and select Duplicate.

3 In the Duplicate Tracks dialog, configure the following options:
• Enter how many copies you want to create in the Number of Duplicates filed.
• To copy the currently active (visible) Edit playlist from the source track, select Active Playlist.
• To copy all Edit playlists on the source track, select Alternate Playlists.
• To copy all automation from the source track, select Automation.
• To copy all plug-in and insert assignments, select Inserts.
• To copy all sends and send assignments, select Sends.
• To maintain all Mix and Edit Group assignments, select Group Assignments.

4 If duplicating multiple tracks, do one of the following:
• If you want all the newly created tracks to follow the last selected source track (to the far-right of the Mix window, and at the bottom of the Edit window), select the Insert after Last Selected Track option.
• If you want each newly-created track to be inserted directly after its source track, deselect the Insert after Last Selected Track option.

5 Click OK to duplicate tracks according to the settings in the Duplicate Tracks dialog. Click Cancel to close the dialog and not create duplicate tracks.

Duplicating VCA Slave Tracks
Duplicating a VCA slave track without duplicating its group assignments will coalesce any automation on the duplicate track. The coalesced duplicate plays back exactly as if it were in the VCA group. For more information, see “VCA Master Tracks” on page 1047.

Track Views
The Track View determines which data is displayed and edited in the track’s playlist area. Track View data can be set to Playlists, Blocks, Analysis, Warp, Waveform, Volume, Volume Trim, Mute, Pan, Send, or an automated control or continuous controller, based on the track type and your Pro Tools system.

Audio Tracks Can be set to Blocks, Playlists, Analysis, Warp, Waveform, Volume, Volume Trim, Mute, Pan, Send controls, or any plug-in controls that are enabled for automation. By default, audio tracks are set to Waveform view where track mate-
material is graphically drawn with amplitude waveforms (a time-domain representation of sound). This Track View provides the necessary detail for important clip edits.

**Auxiliary Input Tracks** Can be set to Volume, Volume Trim, Mute, Pan, Send controls, or any plug-in controls that are enabled for automation.

**Master Fader Tracks** Can be set to Volume, Volume Trim, or any plug-in controls that are enabled for automation.

**VCA Master Tracks** Can be set to Volume, Volume Trim, or Mute.

**MIDI Tracks** Can be set to Blocks, Clips, Notes, Velocity, Volume, Mute, Pan, Pitch Bend, Mono After Touch, Program Change, Sysex, and any continuous controller type. MIDI tracks are commonly set to Notes or Clips, each of which displays notes in a “piano roll” format. Use Clips view to edit and arrange MIDI clips. Use Notes view for inserting and editing MIDI notes. Other MIDI track views are useful for editing velocity, controller data, program changes, and Sysex events.

**Instrument Tracks** Can be set to Blocks, Clips, Notes, Velocity, Volume, Mute, Pan, Pitch Bend, Mono After Touch, Program Change, Sysex, and any continuous controller type for MIDI; as well as Volume, Volume Trim, Mute, Pan, Send controls, or any plug-in controls that enabled for automation. Instrument tracks are commonly set to Notes or Clips, each of which displays notes in a “piano roll” format. Use Notes view for inserting, editing, and copying and pasting MIDI notes. Use Clip view to arrange, capture, or consolidate clips. Other Instrument track views are useful for editing automation, controller data, program changes, and Sysex events.

**Video Tracks** For information on video track views, see “Video Track View” on page 1359.

---

**Blocks Track View**

With the Track View set to Blocks, audio and MIDI clips are displayed as empty blocks bearing the clip’s name. This Track View is most useful once you have finished capturing and editing clips at the waveform or MIDI event level and are moving and rearranging them. Screen redraws are fastest with this format.

**Playlists Track View**

(Audio Tracks Only)

With the Track View set to Playlists, alternate playlists for audio tracks are revealed in Playlist lanes under the Main Playlist on the track. This view is useful for track compositing, letting you select the best parts from a track’s alternate playlists and copy them to the main playlist.

**Analysis and Warp Track View**

(Audio Tracks Only)

With the Track View set to Analysis or Warp, you can edit Elastic Audio analysis and warp markers on Elastic Audio-enabled tracks.

**Waveform View**

(Audio Only)

With the Track View set to Waveform, you can edit and arrange audio clips on audio tracks. Waveforms are time-domain representations of the audio data and can be shown as normal or rectified waveforms, and calculated using Peak or Power mode.
On audio tracks, the Waveform is also visible in Playlists, Analysis, Warp, and Automation views.

Clips View
(MIDI Only)
With the Track View set to Clips, you can edit and arrange MIDI clips on MIDI and Instrument tracks.

Notes View
(MIDI Only)
With the Track View set to Notes, you can insert and edit MIDI notes on MIDI and Instrument tracks.

Automation and Controller Views
When an audio or Instrument track is displayed as Volume, Pan, or another automated control, or when a MIDI or Instrument track is set to one of the continuous controller types (such as Volume or Pitch Bend), the data for that track appears in the form of a line graph with a series of editable breakpoints. The breakpoints can be dragged to modify the automation data, and new breakpoints can be inserted with the Pencil tool or a Grabber tool. MIDI and Instrument tracks also provide Velocity view for editing MIDI velocities.

Setting Track Views in the Edit Window
To set the Track View:
- Click the Track View selector for the track and select the view from the pop-up menu.

The track displays the new view. If the track is part of an active Edit Group, all tracks in the group are set to the new view.
Changing Track Views

For audio, Auxiliary Input, MIDI, and Instrument tracks, you can change to the next or previous Track View, or toggle between pre-defined common views.

Changing to Previous or Next Track View

When changing to the next or previous Track View, Track View list ordering is maintained as shown in the Track View selector.

Track Views at the beginning of the list (such as Blocks for audio or MIDI tracks) cannot be changed to the previous Track View. Tracks Views at the end of the list (such as a MIDI controllers option) cannot be changed to the next Track View.

To change to the previous or next Track View:

1. Click in the track you want to change. To change views on multiple tracks, Shift-click or drag the Selector tool to select additional tracks, or select a group.
2 Do one of the following:

- To change to the previous or next Track View on all selected tracks, press Control+Command (Mac) or Control+Start (Windows) and the Left or Right Arrow key.

- To change to the previous or next Track View on all tracks, press Command+Option+Control (Mac) or Control+Alt+Start (Windows) and the Left or Right Arrow key.

**Toggling Common Track Views**

The most common editing view for audio tracks are Waveform and Volume view. The most common editing views for MIDI and Instrument tracks are Notes and Clips view. Pro Tools provides an easy way to toggle these views.

**To toggle Track Views on tracks containing the edit cursor (or an Edit selection):**

1. Click in the track you want to toggle. To toggle multiple tracks, Shift-click or drag with the Selector tool to select additional tracks.

2. Do one of the following:
   - Press Control+Minus (Mac) or Start+Minus (Windows) on the alphanumeric keyboard.
   - With Commands Keyboard Focus enabled (see “Keyboard Focus” on page 26), press Minus on the alphanumeric keyboard.

   ![To toggle Track Views for all tracks, press Option+Control+Minus (Mac) or Alt+Start+Minus (Windows) on the alphanumeric keyboard.]

   ![To toggle Track Views for all tracks with Commands Keyboard Focus enabled, press Option+Minus (Mac) or Alt+Minus (Windows) on the alphanumeric keyboard.]

Audio tracks are toggled between Waveform and Volume view. MIDI and Instrument tracks are toggled between Notes and Clips view.

**Master Views for Tracks**

Audio, MIDI, and Instrument tracks have Track Views that act as “master.” When a track is displayed in its Master view, any edits performed apply to all data in the track. For instance, when an audio track is set to Waveform, copying and pasting affects not just the waveform information, but all of the automation data as well.

The Master view is based on the type of track, as follows:

- Audio tracks: Waveform and Blocks
- MIDI and Instrument tracks: Clips, Blocks, and Notes (when using the Selector tool)

**Track Height**

Tracks can be viewed in the Edit window at any of eight heights: Micro, Mini, Small, Medium, Large, Jumbo, Extreme and Fit To Window. Larger track heights are particularly useful for precise editing, especially for MIDI. Smaller track heights are useful for conserving screen space in a large session.

You can adjust track heights on an individual track basis or set all tracks to the same height. Track heights can be changed during playback.
To set the Track Height, do one of the following:

- Click the small arrow to the left of the Track name to get the Track Height pop-up menu.

- Right-click on the vertical zoom scale just to the right of the track controls and choose the height from the pop-up menu.

The track is resized to the new height. If the track is part of an Edit Group, all tracks in the group are set to the new height.

**Track Height pop-up menu**

- Press Control+Up/Down Arrow key (Mac) or Start+Up/Down Arrow key (Windows) to increase/decrease track height of any track that contains a selection or in which the edit cursor is currently placed.

**To resize all tracks proportionally:**

- Click Edit window Vertical Zoom In or Out button.

**Continuously Variable Track Height**

In the Edit window, you can continuously resize the Track Height of any given track by dragging the lower boundary of the Track Controls column.

**To resize the Track Height of any track in the Edit window:**

- Drag the bottom line of any given track’s Track Controls column up or down. The cursor changes to indicate that you can resize the track.

The track’s Track Height changes incrementally.

**Adjusting the Track Height of an audio track**

- Hold Command (Mac) or Control (Windows) while adjusting track height for continuous, non-incremental adjustments.

**To continuously resize all tracks, Option-drag (Mac) or Alt-drag (Windows).**

**To continuously resize all selected tracks, Option-Shift-drag (Mac) or Alt-Shift-drag (Windows).**
Track Controls and Track Height

The Track Height affects how the various track controls appear in the Edit window. For instance, when a track’s height is set to Small, most of the buttons are reduced in size.

Track Height set to Small

When the Track Height is set to Mini or Micro, only controls for Record, Solo, and Mute appear, and the menus for Playlist, Track Timebase, Track Height, and Track View are accessed from the same selector.

Track Height set to Mini

When the Track Height is set to Medium, Large, Jumbo, or Extreme, all track controls are displayed at their full size.

Track Height set to Large

Tracks List

The Tracks List (at the left of both the Mix and Edit windows) shows all tracks in the session. It allows you to show or hide a track in the Mix, Edit, MIDI Editor, and Score Editor windows. Even though a track is hidden, the material on the track will still play as part of the session. Inactive tracks appear in italics in the Tracks List.

The Tracks List can also be used to create new tracks when importing media by drag and drop from a Workspace browser. See “Importing Files with Drag and Drop” on page 400.
Show/Hide Tracks List and Groups List

To show (or hide) the Tracks List (and Groups List), do one of the following:

- From the Edit window menu, select (or deselect) Tracks List.
- Click the Show/Hide Tracks List/Groups List View button in the Mix or Edit window.

Tracks List Menu

The Tracks List menu (at the top right of the Tracks List) provides commands that allow you to show or hide all tracks, tracks currently selected on-screen, or specific types of tracks (audio, Auxiliary Input, Master Fader, MIDI, Instrument, VCA Master, or Inactive tracks).

Sort Tracks By options

When a track that is a member of an active group is hidden from view, editing operations performed on other members of the group in the Edit window will not affect the hidden track. In the Mix window, however, all operations other than record-enable will affect a hidden track that is a member of an active group.

The options in the Tracks List menu in the Score Editor window are different from the Mix, Edit, and MIDI Editor windows. For more information, see “Tracks List” on page 812.

Showing and Hiding Tracks

The Mix and Edit windows are linked in terms of which tracks are shown or hidden. However, the Score Editor window and MIDI Editor windows are all unique in terms of which tracks are shown or hidden. For example, hiding a specific track in the Edit window also hides it in the Mix window, but not in the Score Editor or MIDI Editor windows. Also, hiding a specific track in a MIDI Editor window hides it only in that MIDI Editor window.
To hide a track, do one of the following:

- Click the Track Show/Hide icon in the Tracks List.
- In the Tracks List (or on the track channel strip), Right-click the track name and select Hide (or Hide and Make Inactive if the track is active and you also want to make it inactive).

To show a track that is currently hidden, do one of the following:

- Click the Track Show/Hide icon in the Tracks List.
- In the Tracks List (or on the track channel strip), Right-click the track name and select Show (or Show and Make Active if the track is inactive and you also want to make it active).

To reorder tracks on-screen, drag the track names to new positions within the Tracks List or in the Mix or Edit window.

To show all tracks:

- Click the Tracks List menu and choose Show All Tracks.

You can also show all tracks by Option-clicking (Mac) or Alt-clicking (Windows) the Show/Hide icon of any track that is hidden.

To hide all tracks:

- Click the Tracks List menu and choose Hide All Tracks.

You can also hide all tracks by Option-clicking (Mac) or Alt-clicking (Windows) the Show/Hide icon of any track that is shown.

To show or hide a range of tracks in the Tracks List with the Marquee:

1. Move the cursor to the left of a track name until the Marquee with a small “+” symbol appears.
2. Click on the track in the list and drag up or down over the Show/Hide icons (to show or hide the track and the tracks immediately above or below it).

To show or hide non-contiguous tracks:

- Click the Show/Hide icon for the tracks you want to show or hide.

To restore previously shown tracks after using the Show All Tracks, Show Only Selected Tracks, or Show Only Tracks by <Track Type> commands:

- From the Tracks List menu, choose the Restore Previously Shown Tracks option.
To show selected hidden tracks and hide all shown tracks:

1. In the Tracks List, select the hidden tracks you want to show.

2. Option-Shift-click (Mac) or Alt-Shift-click (Windows) the Show/Hide icon for one of the selected hidden tracks.

**Mix/Edit Groups and Hidden Tracks**

In the Mix window, if a hidden track is part of an enabled group, all Mix window operations performed on other members of the group also affect the hidden track—with the exception of audio or MIDI record-enabling. If you solo, mute, or automation write-enable a grouped track, any group members that are hidden are soloed, muted, or automation write-enabled as well.

In the Edit window, however, editing operations performed on members of an enabled group do not affect hidden tracks that are also members of the enabled group.

**Track Numbering and Hidden Tracks**

In the Mix and Edit windows, Track Position Numbers can either include hidden tracks in their numbering sequence, or ignore them.

- When Track Position Numbers Stay with Hidden Tracks is not selected in the Display Preferences page, numbers are only assigned to tracks that are shown. In this case, active tracks are then numbered sequentially. Hidden tracks are un-numbered.

- When Track Position Numbers Stay With Hidden Tracks is selected in the Display Preferences page, tracks keep their Track Position Numbers even when hidden.

---

**Track Name Right-Click Menu**

*(Mix Window, Edit Window, MIDI Editor Windows, or Tracks List)*

When you Right-click a track name in the Mix window, Edit window, MIDI Editor windows, or the Tracks List, a pop-up menu provides access to the following commands:

- **Download** (Tracks List, Remote Shared Tracks Only) Downloads the track data without importing. Track data can be imported at a later time.

- **Ignore for Future Download** (Tracks List, Remote Shared Tracks Only) Does not download or import the track data.

- **Import** (Tracks List, Remote Shared Tracks Only) Downloads and imports the track data immediately.

  - *For more information about downloading remote shared tracks, see “Track Cloud Synchronization Indicator in the Tracks List” on page 391.*

- **Hide/Show** Hides (or shows) the track (or selected tracks if any).

- **Hide and Make Inactive** Hides the track and makes it inactive (or selected tracks if any).

- **Make Active/Inactive** Toggles the active status of the track (or all selected tracks in the Mix or Edit window only).

- **Scroll Into View** Scrolls the track to the top of the Edit window or to the left of the Mix window.

- **Export MIDI** (MIDI and Instrument Tracks Only) Exports the MIDI data from one or more MIDI or Instrument tracks to a standard MIDI file. For more information, see “Exporting MIDI Files” on page 414.
Coalesce VCA Master Automation (VCA Master Tracks Only) Coalesces the VCA automation to the slave tracks of the VCA.

Coalesce Trim Automation (Pro Tools Ultimate Only) Coalesces Trim automation on the track (or selected tracks if any).

Clear Trim Automation (Pro Tools Ultimate Only) Clears Trim automation on the track (or selected tracks if any).

Locked (Video Track Only) Toggles the locked/unlocked status of the video track (or selected video tracks if any).

New Opens the New Track dialog.

Rename Opens the Track Name dialog.

Batch Rename Opens the Batch Track Rename dialog.

Duplicate Duplicates the track (or selected tracks if any).

Split Into Mono (Multichannel Tracks Only) Splits a multichannel track (or selected multichannel tracks if any) into their mono component tracks.

Delete Deletes the track (or selected tracks if any).

Field Recorder Guide Track (Audio Tracks on Pro Tools Ultimate Only) Sets the selected track to be the guide track for field recorder workflows.

MIDI Real-Time Properties (MIDI and Instrument Tracks Only) Opens the Real-Time Properties window for the track.

Open in New MIDI Editor (MIDI and Instrument Tracks Only) Opens the track in a new MIDI Editor window.

Open in Score Editor (MIDI and Instrument Tracks Only) Opens the track in the Score Editor window.

Open in MIDI Event List (MIDI and Instrument Tracks Only) Opens the track in the MIDI Event List.

Notation Display Track Settings (MIDI and Instrument Tracks Only) Opens the Notation Display Track Settings window for the track. Music notation can only be viewed in the Score Editor or in MIDI Editor windows set to Notation view.

Expand Channels to New Tracks Expands multichannel audio files imported from a field recorder to new tracks, such that every channel resides on its own mono audio track. Pro Tools also automatically conforms all expanded tracks to the edits in the guide (expanded) track. You can expand multichannel files to new tracks ordered by channel name, by channel number, by channel name and number, or by Timecode only.

EUCON Control (Master Fader Tracks Only) On systems configured for use with EUCON, Pro Tools lets you use a single Master Fader to act as a Monitor Path control for EUCON control surfaces.

Assigning Audio Inputs and Outputs to Tracks

Inputs for audio, Auxiliary Input, and Instrument tracks can be assigned to audio interface channels, busses, or plug-in output busses (such as with some Virtual Instrument or multi-band processing plug-ins). Outputs for audio, Auxiliary Input, Master Fader, and Instrument tracks can also be assigned to audio interface channels or busses.

Input/output assignments for three mono audio tracks
For stereo and multichannel surround tracks, inputs and outputs appear as stereo pairs and multichannel groups. The available inputs, outputs, and busses are defined as *paths* in the I/O Setup dialog (see Chapter 6, “I/O Setup”).

**Automatic Input and Output Assignments**

When adding tracks to a new session, inputs are automatically assigned in ascending order. For example, if you have an audio interface with eight inputs, creating four new mono audio tracks will automatically add four audio tracks with inputs assigned to the first four paths defined in the I/O Setup dialog. When creating stereo tracks, inputs are automatically assigned to subsequent input pairs.

The outputs automatically assigned to new tracks are determined by the *New Track Default Output Bus* specified in the I/O Setup dialog.

**Assigning Audio Inputs** *(Audio, Auxiliary Input, and Instrument Tracks)*

To assign an audio input of an audio, Auxiliary Input, or Instrument track:

1. In order to assign audio track inputs in the Edit window, select View > Edit Window > I/O.

2. In the Mix or Edit window, click the track’s Input Path selector and choose from the available audio interface channels and busses. Stereo and multichannel surround tracks have inputs available as pairs and multichannel groups.

   The Input Path selector lets you route any audio input or any of the Pro Tools internal busses to an audio, Auxiliary Input, or Instrument track. The choices available in this pop-up menu are determined by the Input Path configuration in the I/O Setup. Inputs in use by another track appear bold in the Input Path selector pop-up menu.

   *Instrument tracks automatically assign the audio output from the instrument plug-in inserted on the track to the track audio Input.*

   **To automatically assign all track inputs (of the same type and channel width) to unique ascending Input paths (cascading):**

   - Command-Option-click (Mac) or Control-Alt-click (Windows) the Input Path selector of the left-most Input Path selector and select the first Input Path (mono or stereo, depending on whether your tracks are mono or stereo).

   All visible tracks of the same channel width (mono or stereo) are auto-assigned to unique Input Path assignments in ascending order. For example, Track 1 to A1, Track 2 to A2, Track 3 to A3, and so on.

   ![Input Path selector](https://via.placeholder.com/150)

   **To remove an input assignment:**

   - Select No Input from the Input Path selector.
Assigning Audio Outputs
(Audio, Auxiliary Input, Master Fader, and Instrument Tracks)

To assign an audio output of an audio, Auxiliary Input, Master Fader, or Instrument track:

1. In order to assign audio track outputs in the Edit window, select View > Edit Window > I/O.
2. In the Mix or Edit window, click the track’s Output Path selector and choose from the available audio interface channels and busses. Stereo and multichannel surround tracks have outputs available as pairs and multichannel paths.

The Output Path selector lets you route a track to any configured audio output or internal bus. The choices available in this pop-up menu are determined by the Output Bus Path configuration in the I/O Setup. Outputs in use by another track appear bold in the Output Path selector’s pop-up menu.

Command-Option-click (Mac) or Control-Alt-click (Windows) the Output Path selector of the left-most track and select the first Output Path (mono or stereo). All visible tracks are automatically assigned to unique Output Bus Path assignments in ascending order. For example, Track 1 to A1–2, Track 2 to A3–4, Track 3 to A5–6, and so on.

To remove an output assignment:
- Select No Output from the Output Path selector. Playlists become dimmed for tracks with no output assignment.

Assigning an audio track, Auxiliary Input, Master Fader, or Instrument track to “No Output” will cause its automation data for pan and plug-in controls to be lost.

Create and Assign New Track from Track Output

Pro Tools lets you create a new Auxiliary Input, Audio, or Instrument track from the Output selector and automatically assign the Output of the original track to the Input of the new track using an available internal mix bus.

To create a new track from a track output:

1. On an existing track, click the Output selector for the track and select New Track.
2. In the New Track dialog, select the Width, Type, and Time Base for the new track.
3. Type a Name for the new track.
4. Select (or deselect) whether you want the new track to be created next to the current track.
5. Click OK.

Pro Tools creates a new track with the output of the originating track automatically routed to the input of the new track using an available internal mix bus.
When creating a new internal mix bus, the new bus will be named after what you typed for the new track. For example, if you entered the name “Drum Sub,” Pro Tools creates a new Auxiliary Input track named “Drum Sub” and also creates an internal mix bus named “Drum Sub.”

**To assign the output of a track to an available input on an existing track:**

1. On an existing track, click the Output selector for a track and select **Track**.
2. From the **Track** submenu, select the destination track you want.

Pro Tools automatically routes the track or send to the input of the selected track using an available internal mix bus.

**New Auxiliary Input track with audio track output automatically assigned to Bus 1–2**

**Assign Existing Track from a Track Output**

Pro Tools lets you assign the Output of a track to the Input of an existing track using an available internal mix bus. Note that the destination track must be set to either an internal mix bus or to No Input in order to be available for assignment.

**Searching Track Input and Track Output Path Selectors**

**To search for a path in an Input or Output selector:**

1. Click the path selector for the input or output you want to assign and do one of the following:
   - Type the first character of the path name you want.
   - Click **Search**.
   - Press Tab.
2 Type a few letters included the path name that you want. Only paths whose names that include those letters (highlighted yellow) now appear in the list (maximum of 20).

3 Select the desired path with the mouse, or use the Up and Down arrow keys to select the path name.

4 Do one of the following:
   • Press Return again to close the selector menu.
   • Click anywhere outside the menu.

To search for and assign multiple paths (Sends and Track Outputs only):

1 Type to search for each additional path assignment, do one of the following:
   • Tab to confirm current tag that you are typing.
   • Press Shift+Return.
   • Click the entry.

2 Press Return to close the selector menu and assign the outputs.

- Option-click (Mac) or Alt-click (Windows) to assign outputs to the same path for all tracks of the same type.

- Option-Shift-click (Mac) or Alt-Shift-click (Windows) to assign outputs to the same path for all selected tracks.
Renaming Track Inputs and Outputs from the Edit or Mix Window

I/O path names can be renamed in the Edit or Mix windows, or in the I/O Setup.

To rename an I/O path in the Edit or Mix window:

1. In the Edit or Mix window, Right-click the Input selector or Output selector for a track, and choose Rename from the pop-up menu.
2. In the Rename I/O dialog, type a name for the I/O Path, and click OK.

You can also make a path globally inactive (or active) in the I/O Setup dialog. See “Making Paths Active or Inactive” on page 74.

Making Track Inputs and Outputs Inactive from the Edit or Mix Window

Track Input, Output, and Bus Path assignments can be made inactive using the corresponding selector on the track. Making a track’s Input or Output inactive silences that Input or Output, while retaining all automation and playlist data. For HDX systems, inactive Inputs and Outputs do not consume resources for DSP mixer connections, but any active assigned plug-ins on the track continue to use their required DSP resources. For Pro Tools host-based systems, inactive Inputs and Outputs do not consume host-processing resources. Host-based, or Native plug-ins require CPU resources, and DSP-based plug-ins use the DSP available on HDX cards.

You can make track inputs and outputs inactive (or active) directly from the Edit or Mix windows. Inactive I/O Paths are grayed out.

To make a track’s Input or Output Path inactive (or active), do one of the following:

- In the Edit or Mix window, Right-click the Input selector or Output selector for a track, and choose Make Inactive (or Make Active) from the pop-up menu.
- Command-Control-click (Mac) or Control-Start-click (Windows) the Input or Output selector in the Mix or Edit window.

To make all tracks’ Inputs or Outputs assigned to the same path inactive (or active), do one of the following:

- In the Edit or Mix window, Option-Right-click (Mac) or Alt-Right-click (Windows) the Input selector or Output selector for a track, and choose Make Inactive (or Make Active) from the pop-up menu.
- Command-Option-Control-click (Mac) or Control-Alt-Start-click (Windows) the Input or Output selector in the Mix or Edit window.

To make all selected tracks’ Inputs or Outputs assigned to the same path inactive (or active), do one of the following:

- In the Edit or Mix window, Option-Shift-Right-click (Mac) or Alt-Shift-Right-click (Windows) the Input selector or Output selector for a track, and choose Make Inactive (or Make Active) from the pop-up menu.
- Command-Option-Control-Shift-click (Mac) or Control-Alt-Start-Shift-click (Windows) the Input or Output selector in the Mix or Edit window.
Toggling Multiple Paths

If a track has only one main output assignment, Command-Control-click (Mac) or Control-Start-click (Windows) the track’s Output Path selector to toggle the main output to inactive. When there are multiple assignments, the track selector will be displayed for you to specify the Input, Output, Insert, or Bus Path by Control-clicking (Mac) or Start-clicking (Windows).

⚠️ If a Send (A–J) has multiple Output Path assignments and one of those is toggled active or inactive, then all of the Output Path assignments for that Send (A–J) are toggled active or inactive.

Track Priority and Voice Assignment

Track priority and voice assignment are dependent on your Pro Tools hardware and software configuration.

HDX systems provide a certain number of voices (simultaneous channels of audio playback and recording), depending on the number of cards in the system. For details on Pro Tools system capabilities, see “Playback, Recording, and Voice Limits with Pro Tools | Ultimate Software” on page 42.

Pro Tools systems let you play or record up to 128 simultaneous stereo or mono tracks. For details on system capabilities, see “Pro Tools Capabilities with Different Hardware Configurations” on page 38.

Track Priority

While your Pro Tools hardware allows a fixed number of voices, Pro Tools software allows for additional audio tracks beyond that fixed number of voices. While all of these tracks can be recorded to or imported, arranged, and cued for playback, not all of them can be played back simultaneously.

When the number of tracks exceeds the number of available voices, tracks with lower priority may not be heard. For these situations, Pro Tools assigns priorities to tracks that compete for the available voices. Because there can be more tracks than available voices, Pro Tools provides multiple ways of adjusting the playback priority of audio tracks. See “Changing a Track’s Playback Priority” on page 252 and “Freeing up Voices on a Track” on page 253.

Changing a Track’s Playback Priority

Tracks with higher positions (leftmost in the Mix window or topmost in the Edit window) have priority over tracks in lower positions in a session.

To increase a track’s priority, do any of the following:

- In the Mix window, drag the Track Name button to the left of other tracks in the session. Tracks at the left of the Mix window have higher priority than those on the right.
- In the Edit window, drag the Track Name button above other tracks in the session. Tracks at the top of the Edit window have higher priority than those below.
- In the Tracks List, drag the Track Name to a higher position in the list. Tracks at the top of this list have higher priority than those below.
Freeing up Voices on a Track

You can also adjust the relative priority of tracks by freeing up the voices of individual tracks, making them available to other tracks in the session.

To free up the voice of a track, do one of the following:

- Click the Voice selector of the track and set it to Off. See “Setting Voice Assignment” on page 253.
- Deactivate the track by Command-Control-clicking (Mac) or Control-Start-clicking (Windows) its track type icon in the Mix window.
- Make sure the track does not have an Output Path or Send assignment.

Setting Voice Assignment

A track’s voice assignment can be turned off or set to be dynamically allocated. Use Dynamically Allocated Voicing to automatically take care of voice management in the background, assigning voices not in use by other tracks.

With Pro Tools Ultimate, QuickPunch, TrackPunch, and DestructivePunch require additional voices. For more information, see Chapter 26, “Punch Recording Modes.”

With HDX systems, the initial insert of a Native (host-based) plug-in may use additional voices in certain situations. See “Inserting Native and DSP Plug-Ins on Tracks” on page 1098.

To set the voice assignment for a track:

- Click the Voice selector and set the track to Dyn or Off.

Track Priority and Dynamic Voicing

The lowest-numbered (highest priority) audio tracks that are active and have their voice assignment set to DYN (Dynamically Allocated Voicing) are the tracks that play back. (The total number of tracks that play back depends on the maximum number of voiced audio tracks allowed by your system.)

Tracks that are higher-numbered (lower priority) than these tracks do not play back and you cannot record to them. Their Dynamically Allocated Voicing button are blue to indicate they are unavailable for playback or recording.

With HDX systems, the initial insert of a Native (host-based) plug-in may use additional voices in certain situations. See “Inserting Native and DSP Plug-Ins on Tracks” on page 1098.

Tracks do not play back when they are inactive or their voice assignment is set to Off.

When working with more than the maximum number of voiced audio tracks allowed by your system, you can only play back audio from higher-numbered (lower priority) tracks by changing the track priority by doing any of the following:

- Make a lower-numbered track inactive (click the Track Name and select Track > Make Inactive).
- Set the voice assignment in a lower-numbered track to Off (click the Voice selector and select Off).
• Drag the Track Name button of the higher-numbered track to the left (Mix window) or upwards (in the Edit window or Tracks List) until it is in the range of the maximum number of voiced audio tracks allowed by your system. The previously last voiced audio track is moved out of range and its voice assignment is changed to Off.

When the priority of the higher-numbered track is changed, its voice assignment is automatically changed from Off to DYN.

Assigning MIDI Inputs and Outputs to Tracks

MIDI recording and playback is supported with MIDI tracks and Instrument tracks.

MIDI ports in your system can be named and configured for use in Pro Tools (for Windows, see “Configuring MIDI Studio Setup” and for Mac, see “Configuring AMS”).

Assigning MIDI Track Input

Pro Tools lets you assign specific MIDI ports and channels to a MIDI track input. The default selection of All receives all incoming MIDI data from all ports on all channels. Use the MIDI Input selector to specify a MIDI port and channel for input.

To assign a MIDI track input:

- Click the track’s MIDI Input selector and assign a port and channel for MIDI input. Channels already assigned to another track appear in bold.

💡 In the Edit window, select View > Edit Window > I/O to access any track’s Input selector.

MIDI Input selector (MIDI Track shown)
Assigning MIDI Track Output

Pro Tools lets you assign specific MIDI ports and channels to a MIDI track output. The default selection of none sends MIDI data to no port on any channel. Use the MIDI Output selector to specify a MIDI port and channel for output.

MIDI tracks in Pro Tools cannot contain multiple channels of MIDI data.

To assign a MIDI track (and all its clips) to a specific MIDI device channel:

- Click the track’s MIDI Output selector and assign a port and channel for MIDI output. Channels already assigned to another track appear in bold.

- In the Edit window, select View > Edit Window > I/O to access any track’s Output selector.

To assign multiple destinations to a single MIDI track:

- Control-click (Mac) or Right-click (Mac or Windows) the MIDI Output selector and select additional channels from any device.

For information on assigning MIDI output to Instrument tracks, see “Assigning MIDI Input and Output for Instrument Tracks” on page 255.

Assigning MIDI Input and Output for Instrument Tracks

Instrument tracks have a specific view for MIDI controls, including MIDI Input and Output selectors.

In addition to assigning MIDI input and output for recording and playing back MIDI data, Instrument tracks can also be used to monitor the audio from your hardware MIDI instruments and instrument plug-ins. See “Signal Routing for Monitoring and Submixing” on page 1074.

To view Instrument track MIDI controls, do one of the following:

- Select View > Mix Window > Instruments.
- Select View > Edit Window > Instruments.

Instrument Track MIDI Input

Pro Tools lets you assign specific MIDI ports and channels to an Instrument tracks’ MIDI input. The default selection of All receives all incoming MIDI data from all ports on all channels. Use the MIDI Input selector to specify a MIDI port and channel for input.
Channels in use by another track input appear bold in the MIDI Input pop-up menu.

**To assign an Instrument track MIDI input:**
- Click the track’s MIDI Input selector and assign a port and channel for MIDI input. Channels already assigned to another track appear in bold.

**Instrument Track MIDI Output**

Pro Tools lets you assign specific MIDI ports and channels to an Instrument tracks’ MIDI output. The default selection of none sends MIDI data to no device, port, or node on any channel. Use the MIDI Output selector to specify a MIDI port and channel for output.

Channels in use by another track input appear as bold in the MIDI Input pop-up menu.

**To assign an Instrument track MIDI output:**
- Click the track’s MIDI Output selector and assign a port and channel for MIDI output. Channels already assigned to another track appear in bold.

---

**Soloing Tracks**

**To solo tracks:**

1. Click the Solo button on a track. The button is highlighted and all other tracks are muted.
2. Click the Solo button on another track. The buttons for both tracks are highlighted and all other tracks are muted.

**To un-solo tracks:**

- Click the Solo button on soloed tracks.

*For information on creating and modifying groups for track soloing and muting, see “Grouping Tracks” on page 277.*

**Solo Button**

The Solo button normally mutes other tracks so that the selected track can be auditioned independently.

With Pro Tools Ultimate, this behavior is selected as a Solo mode, called “Solo In Place.” Additional Solo modes are provided to change how the Solo button works. See “Solo Modes” on page 256.

**Solo Modes**

Pro Tools lets you use the Solo button to:

- Mute other tracks so that the selected track can be auditioned alone.
- Route a selected track to a separate output.

Solo button behavior is defined by the Solo mode, as follows:

**SIP (Solo In Place)** The Solo button mutes other tracks. When this mode is enabled, tracks can be solo safed (see “Solo Safe Mode” on page 258).
AFL (After Fader Listen) The Solo button routes the track’s post-fader/post-pan signal to the AFL/PFL Path output. The AFL/PFL Path is configured in the Output page of the I/O Setup dialog (see “AFL/PFL Path” on page 59).

With AFL, the level you hear is dependent on the fader level for that track. Additionally, there is a separate master level setting for AFL that affects the output of any or all tracks you solo in AFL mode (see “AFL/PFL Path” on page 59). This level setting is independent of the PFL level setting.

PFL (Pre Fader Listen) The Solo button routes the track’s pre-fader/pre-pan signal to the AFL/PFL Path output. The AFL/PFL Path is configured in the Output page of the I/O Setup dialog (see “AFL/PFL Path” on page 59).

With PFL, the fader level and pan are ignored, and the level you hear is dependent on the signal’s recorded level. Additionally, there is a separate master level setting for PFL that affects the output of any or all tracks you solo in PFL mode (see “AFL/PFL Path” on page 59). This level setting is independent of the AFL level setting.

To select a Solo mode:

1. Choose Options > Solo Mode.
2. Select SIP, AFL, or PFL.

DSP Usage when Using AFL or PFL Mode

AFL and PFL are accomplished by Pro Tools creating a “behind the scenes” mixer to route the signal to the chosen AFL/PFL Path. Depending on the size of your main mixer, Pro Tools will devote a substantial portion of its available DSP when using AFL/PFL mode.

Un-declaring the AFL/PFL Path will free up all DSP resources previously used for AFL/PFL mode.

Using AFL/PFL on Pro Tools Systems with a D-Control or D-Command

AFL/PFL is optimized for Pro Tools systems using a D-Control or D-Command control surface, where the XMON automatically switches its monitor source between the main output and the AFL/PFL output from Pro Tools.

For more information on using XMON and AFL/PFL, see your control surface guide.
Solo Latch Options

Solos can be *latched* (where pressing subsequent buttons adds them to the soloed mix of tracks), unlatched, or temporarily latched (Pro Tools Ultimate only).

**To select a Solo Latch mode:**

- Choose Options > Solo Mode and select from the following options:

  **Latch** When selected, pressing subsequent Solo buttons adds them to the soloed mix of tracks.
  
  **X–OR (Cancels Previous Solos)** When selected, pressing subsequent Solo buttons cancels previous solos.

  > *To override X–OR mode and solo more than one track at a time, hold the Solo button on the first track. Subsequently pressed Solo buttons will latch.*

  **Momentary (Pro Tools | Ultimate Only)** When selected, Solo buttons are not sticky. A track is soloed only when its Solo switch is held down.

  With a qualified control surface, additional tracks can be soloed by pressing their SOLO switches (as long as at least one Solo button is held down). When no SOLO switch is held down, all soloed tracks will unsolo.

  **Temporarily Latching Solos in Momentary Solo Mode**

  **(Pro Tools | Ultimate Software Only)**

  **To temporarily latch solos:**

  1. Choose Options > Solo Mode > Momentary.
  2. Press the Solo button on the first track that will be soloed.

  3. While holding the first Solo button, press additional Solo buttons. Solo buttons remain soloed as long as one Solo button is held.

  > *As long as at least one Solo button is held, all the solos will remain latched.*

Solo Safe Mode

Pro Tools lets you *solo safe* a track. This prevents the track from being muted even if you solo other tracks. This feature is useful for tracks such as Auxiliary Inputs that are being used as a submix of audio tracks, or effects returns, allowing the audio or effects track to remain in a mix even when other tracks are soloed. It is also useful to solo safe MIDI tracks so that their playback is not affected when you solo audio tracks.

> **AFL or PFL soloed tracks cannot be solo safed.**

**To solo safe a track:**

- Command-click (Mac) or Control-click (Windows) the Solo button on the track. This prevents the track from being muted even if you solo other tracks. The Solo button changes to a transparent color in Solo Safe mode.

**To return a solo safe track to normal:**

- Command-click (Mac) or Control-click (Windows) the Solo button on the track again.

Mute Button

The Mute button silences a chosen track. More than one track can be muted at one time.

**To mute a track:**

- Click the Mute button on the track.

**To unmute a track:**

- Click the Mute button again.
MIDI Mute

The Mute button on a MIDI track mutes MIDI data, not audio. Muting MIDI results in no MIDI data being passed to the MIDI output. On Instrument tracks, the track’s Mute button mutes the audio signal and the MIDI Mute button is only available in Instruments view.

Making Tracks Inactive

Audio, Auxiliary Input, Master Fader, VCA Master, and Instrument tracks can be made inactive. Inactive tracks use no DSP or voices. Plug-Ins, sends, voices, and automation on inactive tracks are all disabled. Tracks may also be automatically made inactive if a session is opened on a system with less DSP power than the system that it was created on.

⚠️ MIDI tracks cannot be made inactive.

To toggle a track active/inactive:

- Command-Control-click (Mac) or Control-Start-click (Windows) the Track Type indicator in the Mix window.

Playlists for inactive tracks are dimmed and track controls are grayed out.

To make one or more tracks inactive or active, do one of the following:

- Select the track and select Track > Make Inactive/Active.
- Right-click the Track Name in the Tracks List, or Mix or Edit windows and choose Make Inactive/Active.

To select multiple tracks, Command-click (Mac) or Control-click (Windows) additional Track Names.

To select a range of tracks, Shift-click the Track Names bounding the range of tracks you want selected.

Color Coding for Tracks, Clips, Markers, and Groups

Separate colors can be assigned to audio and MIDI clips, tracks, markers, and groups. Clips shown in Waveform and Block Views in the Edit window are drawn in color. Tracks shown in the Tracks List, Groups List, and Mix and Edit windows have associated color bars.

Color Bars

Color coding at the track level is displayed using color bars, as follows:

Mix Window Track colors are displayed in horizontal color bars that appear above each channel strip, and below the track name.

Edit Window Track colors are displayed in vertical color bars that appear to the left of each track.

Tracks List Track colors are displayed in vertical color bars that appear to the left of each track name.

Groups List Track colors are displayed in vertical color bars that appear to the left of each Group Name.
Default colors are automatically assigned to tracks, but you can override those colors by choosing from a color palette of 96 possible colors. For more information, see “Color Palette” on page 261.

**Display Page Preferences for Color Coding**

Color Coding options determine how colors are assigned to the display of tracks and clips.

**To change Color Coding options:**

1. Choose Setup > Preferences.
2. Click the Display tab.
3. Select or deselect the Always Display Marker Colors option.
4. Select the MIDI Note Color Shows Velocity option.
5. Select or deselect the Apply Color Coding to Track Channel Strip option.
6. Select a Default Track Color Coding option.
7. Select a Default Clip Color Coding option.
8. Click OK.

**Always Display Marker Colors**

This option lets you view Marker colors in the Markers ruler, regardless of the option you choose for the Default Clip Color Coding option.

**MIDI Note Color Shows Velocity**

When this option is enabled, MIDI notes display varying shades of the assigned track color in MIDI notes view in the Edit window and in MIDI Editor windows. Notes with high velocities are darker and notes with lower velocities are lighter.

**Default Track Color Coding**

The Default Track Color Coding options determine how colors are assigned to the display of tracks.

- **None** Turns off default color assignment for tracks.
- **Tracks and MIDI Channels** Assigns a color to each track in the Mix or Edit window according to its voice assignment or MIDI channel assignment.
- **Tracks and MIDI Devices** Assigns a color to each track in the Mix or Edit window according to its voice assignment or MIDI device assignment.
- **Groups** Assigns a color to each track according to its Mix or Edit Group ID. If groups are suspended using the Suspend Groups command, the tracks color bars are not shown.
- **Track Type** Assigns a color to each track according to its type (audio, Auxiliary Input, Master Fader, VCA Master, MIDI, Instrument, or video).

**Default Clip Color Coding**

The Default Clip Color Coding options determine how colors are assigned to the display of tracks, clips in the track playlist and Clips List, and Marker Locations.

- **None** Turns off default color assignment for clips. Clips are drawn as black waveforms or black MIDI notes on a light gray background.
- **Tracks and MIDI Channels** Assigns a color to each clip in the Edit window according to its voice or MIDI channel assignment.
- **Tracks and MIDI Devices** Assigns a color to each clip in the Edit window according to its voice assignment or MIDI device assignment.
Groups Assigns a color to each clip according to the Group ID of its track. If groups are suspended (using the Suspend Groups command) all clips display black waveforms or MIDI notes on a light gray background.

Track Color Assigns a clip color based on the color assigned to the track. (See “Color Palette” on page 261.)

Marker Locations Assigns a unique color to each marker area in the Marker ruler, including the area preceding the first marker.

Clips List Color Assigns a color to each clip based on its color in the Clips List. When this Default Clip Color Coding option is enabled, the assigned clip color is maintained even if the clip is placed in a track set to a different color coding.

Enabling any Default Clip Color Coding option other than Clips List Color will override Clips List Color and reassign the parent track color to copies of the clip placed in tracks. Copies of the clip in the Clips List will retain their unique color.

Color Palette

The Color Palette lets you make color selections for tracks, clips, groups and markers.

The Color Palette supports independent clip color coding in the Clips List and in tracks.

To apply a color from the Color Palette:

1. Choose Window > Color Palette.

2. Do one of the following:
   - In the Apply to Selected pop-up menu, select the destination for color coding: Tracks, Marker, Group, Clips in Tracks, or Clips in Clips List.
   - Select a track, marker, group, track clip, or Clips List clip in the appropriate Pro Tools window. The Apply to Selected menu will display the type of item you have selected.

   If selecting a marker does not display the Marker option in the Apply to Selected pop-up menu, then the Always Display Marker Colors option in the Display Preferences page is deselected. See “Always Display Marker Colors” on page 260 for more information.

3. Select a color from the palette, or select one of the following:

   Default Removes any custom coloring and restores the color to the default color orientation. See “Display Page Preferences for Color Coding” on page 260 for more information.

   None Turns off color assignment. Affected clips are drawn with black waveform or MIDI notes on light gray background. Affected tracks and groups no longer show their color bars.
**Using the Hold Button**

The Color Palette provides a Hold button to simplify the process of assigning the same colors to multiple items (such as track and clips).

By default, the Hold button is off. When off, the Color Palette automatically highlights the assigned color (if any) of items as you select them.

When the Hold button is enabled, the assigned color selected in the Color Palette persists and does not change when a different track or clip is selected.

**To use the Hold button to assign the same color to multiple items:**

1. Click the Hold button to enable it. The Hold button becomes white, and the currently selected color is now highlighted with a wider white outline.

2. Select additional tracks or clips to which you want to assign the same color. Because the Hold button is enabled, the Color Palette does not follow item selection; it remains (or “holds”) at the last currently assigned color.

3. Click the assigned color again to assign it to the new selection of tracks or clips. Use the Apply to Selected pop-up menu to determine which selected elements are affected.

4. To turn off Hold and return the Color Palette to its default mode, click the Hold button until it turns off.

**Applying Track Color Coding to Channel Strips**

The Color Palette lets you apply the Track color coding to channel strips in the Mix and Edit windows.

**To apply track color coding to channel strips:**

1. Enable the Apply to Channel Strip button.

2. If necessary, adjust the Saturation slider to get the color saturation you want.

3. If necessary, adjust the Brightness slider.
Chapter 14: Track Presets

Pro Tools lets you create, save, overwrite, and recall Track Presets. A Track Preset captures the current configuration of the selected track or tracks, and can include the track type, format, level, panning, plug-in and send configurations, and more. You can recall Track Presets to create new pre-configured tracks in your session. You can also recall Inserts or Sends configurations from Track Presets to tracks that are already in your session.

Track Presets are available for recall in the Track Type selector in the New Tracks dialog. Track Presets can also be recalled from a Workspace browser to create new tracks. You can use Workspace browsers to organize, manage, and search your collection of Track Presets, so you always have easy access to the perfect Track Presets for any session or project.

Creating and Saving Track Presets

You can save any selected track or tracks in your session as a Track Preset. A Track Preset captures the current configuration of the selected track or tracks.

To create and save a new Track Preset:

1. Create and configure one or more tracks for any of your common workflow scenarios (such as “lead vocal input chain,” or “drums parallel compression bus,” and so on).

2. Do one of the following:
   - Select the track or tracks and choose Track > Save Track Preset.
   - Right-click the track name and choose Save Track Preset.
   - Select the track or tracks and press Option+Shift+P (Mac) or Alt+Shift+P (Windows).

3. Configure the Save Track Preset dialog as desired (see “Save Track Preset Dialog Settings” on page 264).

4. Click OK.
Save Track Preset Dialog Settings

The Save Track Preset dialog lets you name the preset, assign it to a category, and include audio and MIDI clips (all clips or only clips within the current Edit selection). Add metadata tags to your Track Presets to make searching for the perfect Track Preset in a Workspace browser even easier. You can rename and re-categorize Track Presets later in any Workspace browser.

Category

From the Category selector, assign the Track Preset to an appropriate category. If the appropriate category for the preset doesn’t yet exist, create a new one.

To create a new Track Preset Category:

1. In the Save Track Preset dialog, choose Add Category from the Category selector.

2. In the resulting dialog, type the name for the New Category.

3. If desired, select the directory in which you want your new category to be created.

4. Click OK.

The new category is added to the available Track Preset Categories.

Press Command+Left/Right Arrow keys (Mac) or Control+Left/Right Arrow keys (Windows) to cycle through the available Categories.
**Name**

The Name field is pre-populated with the track name. You can continue using the track name for the preset, type a new name, or select the name of an existing preset to overwrite it.

Press Command+Up/Down Arrow keys (Mac) or Control+Up/Down Arrow keys (Windows) to cycle through the Name menu.

**Include Audio and MIDI Clips**

Enable Include Audio and MIDI Clips to include any audio or MIDI clips on the track with the Track Preset. This can be useful if you often work with loops, for example.

Press Command+I (Mac) or Control+I (Windows) to enable or disable the Include Audio and Media Clips option.

**Clips in Edit Selection Only**

Enable Clips in Edit Selection Only to include only whole audio and MIDI clips, and any associated automation data that is within the current Edit selection. Use this option in conjunction with Track Offset Options set in the Track Data To Recall dialog to place included media at any desired Timeline location in any other session or project (see “Track Data to Recall” on page 266).

The beginning of the Edit selection is defined as the first sample of the saved Track Preset.

Press Command+N (Mac) or Control+N (Windows) to enable or disable the Clips in Edit Selection Only option.

**Tags**

Add metadata tags to Track Presets to narrow searches for Track Presets in Workspace browsers.

To add a tag to a Track Preset:

1. Click in the Tags filed and type the tag you want (for example, “Strings,” “Synth,” or “Pad”).
2. Press Return (Mac) or Enter (Windows) to assign each new tag that you type.

To remove a tag from a Track Preset:

- Click the X on the right-edge of the tag.

Use the Left and Right Arrow keys to navigate tags. Press Delete to remove a selected tag.

**Auto-populate tags from Track Data**

Enable Auto-populate tags from Track Data to automatically create tags based on the following Track Data: Plug-in Manufacturers, Plug-in Names, Plug-in Categories, Plug-in Preset (if unmodified), Track Types, Track Names, and Track Width.

Press Command+T (Mac) or Control+T (Windows) to enable or disable the Auto-populate Tags from Track Data option.

**Entering tags in the Tags field**

Use the Left and Right Arrow keys to navigate tags. Press Delete to remove a selected tag.
Track Data to Recall

Pro Tools lets you specify what Track and Session data to recall with the Track Preset. These settings can be modified in a Workspace browser for any selected Track Preset (see “Track Presets in Workspace Browsers” on page 273).

Press Command+R (Mac) or Control+R (Windows) to open the Track Data To Recall dialog from the Save Track Preset dialog.

When recalling a Track Preset by any means, press Control (Mac) or Start (Windows) to open and edit the Track Data to Import dialog. You can then specify what Track Data you want to recall.

Clips and media will only be stored with a Track Preset if the Clips and Media option is enabled.
Track Data to Recall Presets

Pro Tools lets you store and recall different configurations of the Track Data to Recall dialog as presets. The Presets controls for the Track Data to Recall dialog work much like the Presets controls for Batch Renaming, Fades, and Clip Effects.

Presets Buttons

The Track Data to Recall dialog provides five Presets buttons that let you store and recall your most commonly used Track Data to Recall configurations. You can also save and recall Track Data to Recall settings using the Librarian menu.

To store a Track Data to Recall preset:

1. Configure the Track Data to Recall dialog as you like.
2. Command-click (Mac) or Control-click (Windows) the Presets button where you want to store the current Track Data to Recall settings.

To recall a Track Data to Recall preset:

1. Click the Presets button that contains the settings you want to recall.

Librarian Menu

Use the Librarian menu to save and recall presets files (.ptpreset). These are usually saved to and recalled from the Track Data to Recall folder (/Documents/Pro Tools/Pro Tools Presets/Track Data to Recall/). However, you can save to and recall from any directory location on your system. Preset files can be shared and used on any other Pro Tools system as well.

The Librarian menu commands include:

- <factory default> Restores the default settings for the Track Data to Recall dialog.
- `Press Command+Shift+S (Mac) or Control+Shift+S (Windows) to save the current settings.`
- Save Settings Saves the current settings. This command overwrites any previous version of the preset.
- Save Settings As Saves the current settings as a new preset. You can name the preset and save it to any location on your system.
- Import Settings Opens the Choose a Settings File dialog focused on the default Track Data to Recall folder. Track Data to Recall Settings files stored in this location are listed by name under `<factory default>` in the Librarian menu. In the Choose a Settings File dialog, you can navigate to any location on your system to select and import the Track Data to Recall Settings preset file you want.
- Delete Current Settings File Permanently deletes the current settings file from disk.
- Lock (Unlock) Settings File Locks (or unlocks) the selected Settings file so that it cannot (or can) be edited.

Track Data

Pro Tools lets you include (or exclude) Track Data with Track Presets. For a complete list of Track Data options with descriptions, see “Track Data to Import” on page 422.

Session Data

Pro Tools lets you include (or exclude) the following Session Data with Track Presets: For a complete list of Session Data options with descriptions, see “Importing Session Data” on page 416.
Track Offset Options

Pro Tools lets you specify a Track Offset in addition to any offset incurred with the Timecode Mapping Options. Any imported audio is offset in the current session or project Timeline by the specified amount.

Select one of the following options:

No Offset  No Track Offset is applied.

Offset To  Lets you specify the Track Offset to a Timeline location in Bars|Beats, Min:Sec, Timecode, Feet+Frames, or Samples.

Offset to Song Start Marker  Locates the Track Offset to the Session Song Start Marker.

Offset to Timeline Selection  Locates the Track Offset to the start of the current Timeline Selection.

Other Options

Pro Tools lets you set the current Track Preset to Recall settings to be Tick-based or as a Sample-based track.

Force to Timebase

Enable the Force to Timebase option to ensure that the Track Preset is always imported in the selected Timebase:

Ticks  Ensures that the Track Preset imports as Tick-based.

Samples  Ensures that the Track Preset imports as Sample-based.

Track Presets Files

All Track Presets are stored as and recalled from Track Presets files (.ptxp). By default, Pro Tools installs and looks for Track Presets files in the following locations:

Mac  Macintosh HD/Users/<username>/Documents/Pro Tools/Track Presets

Windows  C:\Users\<username>\Documents\Pro Tools\Track Presets

Tip  Customize the location for storing Track Preset files in Preferences > Operation > Documentation and Settings.

Track Presets can be stored in sub-folders within the designated directories so you can organize your Track Presets by sub-categories. Pro Tools displays these as sub-menus when selecting Track Presets in the application.

Creating New Tracks from Track Presets

You can create new tracks from Track Presets using the New Tracks dialog or the Track Right-click menu, or by drag and drop from a Workspace browser (see “Track Presets in Workspace Browsers” on page 273).
**Track Presets in the New Tracks Dialog**

*To create a new track from a Track Preset:*


2. From the Track Type selector, choose Track Presets and select the Track Preset Category (such as “Avid”).

3. Select the Track Preset.

4. Click Create.

The Track Preset is recalled into the session as a new track (or as new tracks) according to the current Track Data to Recall settings.
Track Presets in the New Tracks Dialog from Track Output Selector

To create a new track from a Track Preset using the Track Output Selector:

1. Click the Output selector of a track and choose New Track.

2. From the Track Type selector, choose Track Presets and select the Track Preset Category (such as “Avid”).

3. Select the Track Preset.

4. Click Create.

The Track Preset is recalled into the session as a new track (or as new tracks) according to the current Track Data to Recall settings.
Track Presets in the Tracks Right-Click Menu

To configure a track from a Track Preset using the Track Right-click menu:

1. Right-click any Track Name in the Tracks List, or in the Edit or Mix windows.

2. From the Right-click menu, choose Recall Track Preset and select the Track Preset you want to recall.

Recalling Inserts from Track Presets

Pro Tools lets you recall Inserts saved in a Track Preset. This lets you quickly configure any track with common effects chains saved in Track Presets.

Plug-ins recalled from Track Presets adapt to the format of the current track when possible. For example, if a Track Preset was saved as stereo, but you are recalling Inserts from it to a 5.1 track, any plug-ins stored with that Track Preset that support 5.1 are recalled as 5.1 inserts. However, if a plug-in does not support the track format (for example, in this case, if there is no 5.1 version of a plug-in saved with the Track Preset), it is not recalled.
To recall inserts from a Track Preset, do one of the following:

- Drag and drop a Track Preset from a Workspace browser to the Inserts view of an existing track.
- Choose a Track Preset from the Recall Inserts submenu in the Inserts selector of an existing track.

Recalling Track Presets to Sends

Pro Tools lets you recall Sends configurations saved in a Track Preset. This lets you quickly configure any track with common send configurations saved in Track Presets.

To recall sends from a Track Preset, do one of the following:

- Drag and drop a Track Preset from a Workspace browser to the Sends view of an existing track.
- Choose a Track Preset from the Recall Sends submenu in the Sends selector of an existing track.
Track Presets in Workspace Browsers

Workspace browsers provide easy access to all of your Track Presets from the Track Presets alias in the Locations pane. Subdirectories of the Track Presets location let you organize Track Presets by Category—each subdirectory appears as a Track Preset Category in the New Tracks dialog. Search for Track Presets by name, category, or by matching metadata tags (just like with Soundbase) in any Workspace browser.

To recall Track Presets from the Workspace into a session and create new tracks, do one of the following:
- Drag and drop a Track Preset to the Tracks List or to blank space in the Mix or Edit windows.
- Double-click a Track Preset.
- Right-click a Track Preset and choose Recall Track Preset.

Tagging Track Presets

Pro Tools lets you add metadata tags to Track Presets just like with Soundbase. For more information about working with tags, see the Pro Tools Reference Guide.
Searching Track Presets

Pro Tools lets you search for track presets in a Workspace browser using basic or advanced search criteria, or by searching on metadata tags. For more information about searching in Workspace browsers, see “Searching Items” on page 325.

Filtering Track Data when Recalling Track Presets from Workspace

When a Track Preset is selected in the search pane of a Workspace browser, the Track Data to Recall settings for the selected Track Preset appears in its own pane on the right side of the Workspace browser. These settings are the same as those in the Track Data to Recall dialog. You can edit the Track Data to Recall settings for the selected Track Preset in the Workspace browser. The Track Preset is updated with any changes you make. These settings are applied when you recall the Track Preset from the Workspace browser or when you create a new track (Track > New) from the Track Preset.

For more information about the Track Data to Recall settings, see “Track Data to Recall” on page 266.
Dragging Track Presets from a Workspace Browser

You can recall Track Presets by dragging and dropping them from Workspace browsers to your session or project.

Dragging to the Tracks List, or Edit or Mix Windows

Drag and drop a Track Preset from a Workspace browser to the Tracks List, or to the Edit or Mix window to create new tracks from the Track Preset. See also “Creating New Tracks from Track Presets” on page 268.

Dragging to Inserts

Drag and drop a Track Preset from a Workspace browser to a track’s Inserts view in the Edit or Mix window to recall Inserts from the Track Preset. See also “Recalling Inserts from Track Presets” on page 271.

Dragging to Sends

Drag and drop a Track Preset from a Workspace browser to a track’s Sends view in the Edit or Mix window to recall Sends configurations from the Track Preset. See also “Recalling Track Presets to Sends” on page 272.

Dragging to a Track Name

Drag and drop a Track Preset from a Workspace browser to a Track Name in the Edit or Mix window to configure that track based on the Track Preset. If the Track Preset contains more than one track, on the first track stored with the Track Preset is recalled.

Press Option+Shift (Mac) or Alt+Shift (Windows) when dragging and dropping to configure all tracks based on the Track Preset.

Importing Multiple Presets from Workspace Browser Simultaneously

Pro Tools lets you import an entire folder of Track Presets from Workspace browsers with a single command. Similarly, you can import a selection of multiple Track Presets at once.

To import all of the Track Presets in a folder:

1. Locate the folder of Track Presets you want to recall in a Workspace browser.
2. Right-click the folder and choose Import Track Preset.

All Track Presets are recalled to create new tracks in your session or project.

To recall a selection of Track Presets:

1. Locate the Track Presets you want to recall in a Workspace browser.
2. Command-click (Mac) or Control-click (Windows) the Track Presets you want to import.
3. Right-click one of the selected Track Presets and choose Import Track Preset.

All selected Track Presets are imported to create new tracks in your session or project.
Chapter 15: Grouping Tracks

Pro Tools provides a relative grouping function for linking tracks and their controls.

**Grouping Tracks**

Groups are useful for editing several tracks in exactly the same way, or for mixing several tracks (such as a pair of stereo tracks or a submix) while keeping them at the same relative volume level.

Pro Tools provides the following grouping features:

- Up to 104 different groups are available, arranged in 4 banks of 26 Group IDs.
- Groups can be nested (subgroups within groups).
- Grouped faders or controllers preserve their levels relative to each other.
- Groups are assignable to an available VCA Master track.

**Mix Groups, Edit Groups, and Mix/Edit Groups**

Mix Groups only affect mixing functions and Edit Groups only affect editing. Mix/Edit Groups link the grouping functions of the Mix Group and the Edit Group.

**Edit Groups**

Edit Groups affect the following items in the Edit and MIDI Editor windows:

- Track View
- Track Height
- Track Timebase
- Audio and MIDI editing functions
- Automation editing functions
Mix Groups

Mix Groups can be set to affect the following items:

- Main Mute
- Solo
- Send Level
- Send Mute
- Main Volume
- Main Pan
- Main LFE Level (Pro Tools Ultimate only)
- Record Enable
- Input Monitoring
- Automation Mode
- Object Controls (Pro Tools Ultimate with Dolby Atmos only)
- Send Pan
- Send LFE Level (Pro Tools Ultimate only)
- Plug-In Controls
- Plug-In Bypass

💡 In Pro Tools Ultimate, when the Main Pan attribute is enabled for groups, grouped behavior applies to the Link, Front inverse, Rear inverse and Front/Rear inverse controls in stereo and multichannel panner windows.

Grouping Limitations

Grouping does not affect these parameters:

- Voice assignment
- Output assignment
- Inserting plug-ins
- Elastic Audio plug-ins

Selectable Group Attributes

You can select which parameters, or attributes, are linked in groups by the following methods:

- By making the group an Edit Group, a Mix Group, or both (Mix/Edit Group).
- With Mix and Mix/Edit Groups, by selecting from a list of attributes for the group.
- With Mix Groups in Pro Tools Ultimate only, by choosing whether the selected attributes apply globally to all groups or to individual groups.
Mix Groups and VCA Masters

An existing Mix Group can be assigned to a VCA Master, or a new Mix Group can be assigned to a VCA Master while it is being created. Only one group can be assigned to a VCA Master at a time. A VCA Master cannot control a group that includes itself.

For information on assigning groups to VCA Masters, see “Assigning Groups to VCA Masters” on page 1049.

Group Controls

Menus and commands for creating and modifying groups are accessible in the following:

- Groups List
- Group name in the Groups List
- Group ID indicator on a track
- Track > Group menu

The Groups List

The Pro Tools track grouping functions are located at the left side of the Mix, Edit, and MIDI Editor windows in the Groups List. This scrolling window contains the names of all the groups in your session, as well as a pop-up menu for accessing grouping commands. From this menu, you can select and enable groups.

By default, every session has a group named All, which includes every track in the session. The All group cannot be edited or deleted.

Show/Hide Tracks List/Groups List View Button

To show the Groups List (and Tracks List):

- Click the Show/Hide Tracks List/Groups List View button in the Mix, Edit, or MIDI Editor window.

Group ID

To the left of each name in the Groups List is a letter denoting its Group ID (“a” through “z”).
**Group Symbols**

To the left of each Group ID (“a” through “z”) is a symbol indicating whether that group is selected in the current window (either the Mix or Edit window). There are three types of Group symbols, as shown in the following figure:

- **Filled-in Circle**: Indicates that all members of the group are currently selected, and no members from outside the group are selected.
- **Hollow Circle**: Indicates that only some members of the group are currently selected.
- **Circle with a Dot**: Indicates that all members of the group are currently selected, plus additional members outside the group.

**Groups List Menu**

The pop-up menu at the top of the Groups List provides the following commands:

- **New Group**: Executes the Track > Group command.
- **Display**: Provides commands to show Edit groups only, Mix groups only, or all groups (Edit, Mix, and Mix/Edit).
- **Suspend All Groups**:Suspends group behavior for all Mix and Edit groups.

**Modify Groups**: Opens Group dialog to modify existing groups only.

**Delete Active Groups**: Deletes only currently active groups.

**Group Name and Track Group ID Indicator Pop-Up Menus**

When you Right-click on a group name in the Groups List or click a Group ID indicator in a track, a pop-up menu provides the following commands:

- **Tracks**: Displays track membership in group.
- **Attributes**: Displays attributes of group.
- **Modify**: Opens Group dialog to modify existing groups only.
- **Duplicate**: Opens Group dialog for duplicated group.
- **Delete**: Deletes a single group.
- **Select Tracks in Group**: Selects tracks in the group.
- **Show/Hide Tracks in Group**: Shows or hides tracks in the current group.
- **Show Only Tracks in Group**: Shows only the tracks in the group and hides all other tracks.
Show All Tracks Shows all tracks in the session.

Group Dialog

The Group dialog has three pages:

**Tracks** Lets you add and remove tracks from the current group.

**Attributes** Lets you select which parameters are linked for the current Mix or Mix/Edit Group.

**Globals** Lets you select parameters to use as a template that can be applied to individual groups by selecting the Follow Globals option.

*Group Name pop-up menu*

*Group ID indicator pop-up menu*

**Group Dialog**

Whether you are creating or modifying groups with the Groups List, a track's Group ID indicator, or the Track > Group menu command, you use the Groups dialog.

The Group dialog lets you create new groups and assign attributes to groups.
Working with Groups

Creating Groups

You can select the tracks you want to add to a group before creating it, or add and remove tracks from a group after it has been created.

Creating Groups

To create a group:

1 Select the tracks you want to include in the group. (If you do not select tracks at this time, you can add tracks later.)

2 Do one of the following:
   • Choose Track > Group.
   • Choose New Group from the Groups List menu.

3 Type a name for the group.

4 Select the type of group to create: Edit, Mix, or Mix/Edit.

5 Choose a Group ID from the ID pop-up menu.
   Four banks of 26 are available: a–z, 2a–z, 3a–z, 4a–z. (If you do not choose a Group ID, Pro Tools automatically assigns the next available ID to a new group.)

6 Click Tracks in the Group dialog, and do any of the following:
   • To add the tracks that are currently selected in the session to the group, click the Add button at the bottom of the Group dialog.
   • To add tracks to the group, select the track names in the Available Tracks List, and click Add or press A on the computer keyboard.
   • To remove tracks from the group, select the track names in the Currently In Groups List, and click Remove or press R on the computer keyboard.
   • Double-click track names in either list to move them to the opposite column.
   • To replace all tracks in the group with the tracks that are currently selected in the session, click the Replace button at the bottom of the Group dialog.

7 If the group is a Mix Group or a Mix/Edit Group, do the following:
   • Set the Attributes for the Group (see “Setting Group Attributes” on page 284).
   • If you want to assign the group to an available VCA, select the VCA Master track from the VCA pop-up menu.

8 Click OK.
Modifying Groups

To modify a group:

1. Do one of the following:
   - Choose Modify Groups from the Groups List menu.
   - In the Mix window, click the Group ID indicator on a track and choose Modify from the pop-up menu.
   - Right-click the Group name in the Groups List and choose Modify from the pop-up menu.

2. In the Groups dialog, choose the group you want to modify from the ID pop-up menu.

3. Change any of the following for the current group:
   - Group name
   - Group type (Edit, Mix, or Mix/Edit)
   - VCA status
   - Follows Global status
   - Track membership
   - Attributes
   - Linked Within Group items

4. Click OK.

To modify the settings for the “All” group:

1. Right-click the “All” group name in the Groups List and choose Modify from the pop-up menu.

2. In the Group dialog, select Edit, Mix, or Mix/Edit to change the settings for the “All” group. If you select Edit only or Mix only, the “All” group will apply only to that Group type.

3. For Mix or Mix/Edit Groups, you can change any of the following:
   - Follows Globals status
   - Mix Attributes

4. Click OK.

Deleting Groups

One or all groups can be deleted at a time.

Deleting a group cannot be undone.

To delete a single group, do one of the following:

- In the Mix window, click the Group ID indicator on a track and choose Delete from the pop-up menu.
- Right-click the Group name in the Groups List and choose Delete from the pop-up menu.
To delete all currently active groups

- Choose Delete Active Groups from the Groups List menu.

💡 The “All” group cannot be deleted.

Duplicating Groups

You can duplicate a group and modify its settings in order to quickly set up a mix.

**To duplicate a group:**

1. Do one of the following:
   - Click the Group ID indicator on a track and choose Duplicate from the pop-up menu.
   - Right-click the Group name in the Groups List and choose Duplicate from the pop-up menu.

2. Change any of the following for the current group:
   - Group name
   - Group type (Edit, Mix, or Mix/Edit)
   - VCA status (Pro Tools Ultimate only)
   - Follows Global status (Pro Tools Ultimate only)
   - Track membership
   - Attributes (Pro Tools Ultimate only)
   - Linked Within Group items (Pro Tools Ultimate only)

3. Click OK.

Setting Group Attributes

When creating a Mix Group or a Mix/Edit Group, you can select the Mix window parameters that will be linked for that group. These linked parameters are the attributes of the group.

You can select attributes in the Globals page and then set individual groups to follow the Global settings, or you can select attributes for groups individually.

Selecting Attributes in the Globals Page

**To select attributes in the Globals page:**

1. While creating or modifying a group, click Globals in the Group dialog.

![Globals page of Group dialog](image)
2 Select the base set of attributes for groups in your session.

3 Click OK to save the group and the new Globals settings.

   For information on selecting attributes, see “Selecting Group Attributes” on page 285.

To select attributes for an individual group:

1 While creating or modifying a Mix Group or a Mix/Edit Group, do one of the following:
   • Click Attributes in the Group dialog, and select the attributes you want to link.
   • Enable Follow Globals to follow the base set of attributes. The Attributes page grays out to indicate that the group is following the selections in the Globals page.

   For information on selecting attributes, see “Selecting Group Attributes” on page 285.

Attributes page of Group dialog

Selecting Group Attributes

The following attributes can be selected for Global settings and for individual groups.

Track controls:
   • Main Volume
   • Main Mute
   • Main Pan
   • Main LFE Level (Pro Tools Ultimate only)
Insert controls (Inserts A–J):
- Plug-In Controls
- Insert Bypass

Send controls (Sends A–J):
- Send Level
- Send Mute
- Send Pan
- Send LFE Level (Pro Tools Ultimate only)

Mix Attributes:
- Record Enable
- Input Monitoring
- Solos
- Automation Mode
- HEAT Pre/Post (Pro Tools Ultimate only)
- HEAT Bypass (Pro Tools Ultimate only)
- Object Controls (Pro Tools Ultimate with Dolby Atmos only)

To select the attributes for a group, do any of the following:
- Select individual attributes.
- To select or deselect all attributes, Option-Shift-click (Mac) or Alt-Shift-click (Windows) any attribute.
- To select or deselect all attributes for a single Send or Insert (across a row), Control-click (Mac) or Start-click (Windows) any attribute in that row.
- To select or deselect attributes for a single control across all Sends, all Inserts, or for the four track controls (down a column), Option-click (Mac) or Alt-click (Windows) any attribute in that column.

Saving Group Attribute Presets

You can define six Group presets that can be recalled on either the Attributes or Globals page whenever you are creating or modifying a Mix or Mix/Edit Group.

To save the current attribute settings as a Group preset:

1. In the Groups dialog, click Save. (Follow Globals must be deselected to save a setting from the Attributes page.)

2. In the Save Group Settings dialog, select one of the six preset locations from the Location pop-up menu, and click Save.

Selecting a Group Settings Location

To save the current attribute settings directly to a preset location, Command-click (Mac) or Control-click (Windows) the preset button.

To recall a Group preset:

- Click the corresponding Preset button (1–6) in the Groups dialog. (Follow Globals must be deselected to recall a setting in the Attributes page.)
Enabling Groups

Editing operations are not applied to members of a group that are hidden with the Tracks List. Mix operations (with the exception of record-enabling of tracks) are applied to hidden tracks.

Pro Tools lets you create separate groups for editing and mixing. You set this option when you use the New Group command. Groups that apply to both editing and mixing can be decoupled.

To enable a group:
- In the Groups List, click the name of the group you want to enable. The name is highlighted to indicate that it is enabled.

To enable additional groups, click their names in the Groups List.

Moving a fader of a group member causes all other group members to move relative to it. If a fader belongs to multiple groups, and the groups conflict when faders are moved, the fader will follow the top-most or “parent” group to which it belongs.

To disable a group:
- In the Groups List, click the name of the group you want to disable. The name is unhighlighted to indicate that it is not enabled.

Keyboard Selection of Groups

The Groups List Keyboard Focus lets you type a Group ID letter to automatically toggle that group’s enable status.
- In the Mix window, the Groups List Keyboard Focus is always enabled.
- In the Edit window, you need to enable the Groups List Keyboard Focus to use it.

To enable the Edit Groups List Keyboard Focus, do one of the following:
- Click the Keyboard Focus button in upper right of the Edit Groups List.
- Press Command+Option+3 (Mac) or Control+Alt+3 (Windows).

To enable and disable groups using the Edit and Mix Groups List Keyboard Focus:
- With Groups List Keyboard Focus enabled, type the Group ID letter (a–z) to automatically enable or disable the corresponding group.
Temporarily Isolating Control of an Item from Group Operation

You can temporarily isolate control of a group item from group operation by Right-clicking on the item.

You can also temporarily suspend group behavior for a track by Control-clicking (Mac) or Start-clicking (Windows) a group function.

The following items can be isolated from group operation:
- Pan slider
- Channel Record Enable
- Channel TrackInput
- Send Pan slider
- Channel Volume fader
- Channel Pan slider
- Channel Mute button
- Channel Solo button
- Channel Record Enable button
- Channel TrackInput button
- Send fader
- Send Pan slider

Grouped Control Offsets

When the following controls are grouped with offsets and moved to their extremes, relative offsets are preserved when the controls are moved back from their extremes:
- Main Volume
- Main Pan
- Send Level
- Send Pan

For example, when a grouped Volume fader is moved to its maximum value, any other faders in that group that had higher values will remember their relative offset whenever the first fader is pulled down again.

In Automation views, this “overflow” is indicated on the automation playlist by blue automation breakpoints at the extremes of the automation playlist.

Setting Group Pan Controls to Ignore Offsets

By default, offsets are preserved for grouped pan controls. In some workflows, it is desirable to have grouped pan controls match absolute values rather than preserve offsets.

To set grouped pan controls to ignore offsets:

1. Choose Setup > Preferences and click Mixing.
2. Select the Use Absolute Pan Linking option.

When this option is enabled, grouped pan controls will snap to the absolute value of the pan control that is being adjusted.
The Edit Window displays all audio clips, MIDI clips, and clip groups in a single, comprehensive Clips List. All clips of all types that are recorded, imported, or created by editing appear in the Clips List. Items can be dragged from the list to tracks and arranged in any order. You can also preview audio and MIDI clips and clip groups in the Clips List.

Because clip information can become lengthy, the Clips List can be scrolled or resized as necessary. Use the Clips List as a bin for storing your favorite audio loops and MIDI clips. Save the session as a template and the clips are available for future sessions (see “Session Templates” on page 176).

**Clips List Menu**

The Clips List menu provides tools to search, select, sort, export, clear, and manage items in the Clips List.

**To access the Clips List menu:**

- In the Edit window, click the Clips List menu.

**Clips List**

All clips of all types that are recorded, imported, or created by editing appear in the Clips List. Items can be dragged from the list to tracks and arranged in any order. You can also preview audio and MIDI clips and clip groups in the Clips List.
Displaying Clips in the Clips List

The Clips List can show all clip types (audio, MIDI, video, Groups, Auto-Created), or only certain clip types. This is useful for isolating the type of clips you want to work with while editing and arranging. For example, when arranging clip groups, you may want the Clips List to show only clip groups.

To show or hide certain types of clips in the Clips List:

- Click the Clips List menu (at the top of the Clips List) and choose Show. From the submenu, select or deselect the clip type you want to show or hide.

Control-click (Mac) or Start-click (Windows) to select (or deselect) multiple items in the Show submenu without closing the menu.

Audio Shows or hides audio clips in the Clips List.

MIDI Shows or hides MIDI clips in the Clips List.

Video Shows or hides video clips in the Clips List.

Groups Shows or hides clip groups in the Clips List.

Auto-Created Shows or hides automatically-created clips (of all types) in the Clips List. These are clips that were created as a by-product of cutting, pasting, and separating other clips. Since these auto-created clips can become numerous, hiding them (by deselecting the option) helps you to avoid scrolling through an unnecessarily long Clips List.

Hiding Auto-Created clips can be useful when importing clip groups (or REX files as clip groups), because these file types can contain so many separate clips that it becomes difficult to read the Clips List.

In the Clips List, whole-file audio clips are displayed in bold, and stereo and multichannel audio clips can be expanded to display individual channels.

If the Clips List Selection Follows Edit Selection option is enabled in the Editing preferences, selecting a clip or clip group in the Clips List selects it on any track where it is present in assigned playlists. Likewise, selecting a clip or clip group on a track selects it in the Clips List.

Displaying File Info for Audio Clips

In addition to clip names, the Clips List can also display information about the clip’s color coding, type (audio, MIDI, and clip group), timebase, Elastic Audio processing, and parent file:

- Timebase Displays the timebase (samples or ticks) for audio and MIDI clips, and clip groups.
- Color Displays Track Color Coding as assigned with Default Clip Color Coding option in Display Preferences page, or as assigned in the Color Palette.
- Processing State Displays the Warp Indicator icon if Elastic Audio processing has been applied to the clip.
- Guitar Settings (Eleven Rack Only) Displays the Eleven Rack icon if guitar settings are embedded in the clip.
- File Type Displays the File Type icon for audio and MIDI clips, and clip groups.
- File Name Displays the parent file name.
- Disk Name Displays the name of the hard drive on which referenced file resides.
**Full Path** Displays the full directory path of the clip’s parent file.

**Channel Name** Displays the channel name for audio files imported from field recorders.

**Scene and Take** Displays the scene and take for audio files imported from field recorders.

---

Pro Tools displays only the clip name in the Clips List by default.

💡 *When editing, the Clips List can become cluttered with auto-created clips. You can hide auto-created clips by choosing Show in the Clips List menu, and deselecting Auto-Created.*

---

**Sorting and Searching in the Clips List**

Most sessions will contain many clips, which can make it challenging to swiftly locate a particular clip in the Clips List. Pro Tools lets you sort and search clips in the Clips List to quickly locate any clip you want.

---

**Sorting Clips**

**To sort clips in the Clips List:**

1. Click the Clips List menu (at the top of the Clips List) and choose **Sort By**.

2. From the submenu, select a basis for sorting. Different options are available for audio and MIDI clips. See “Sort By Options” on page 291.

3. To set whether clips are listed in ascending or descending order, click the Clips List menu, choose **Sort By**, and select **Ascending** or **Descending**.

**Sort By Options**

The Sort By options let you sort clips to help keep track of large numbers of clips.

Audio clips can be sorted by:

- Clip Type
- Name
- Length
- Original Time Stamp
- User Time Stamp
- Timebase
- Start in Parent
- End in Parent
- File Name
- File Length
- File Creation Date
- File Modification Date
- Disk Name (audio and clip groups only)
- Track Format/Width
- By Channel Name
- By Scene and Take
- Guitar Settings
MIDI clips can be sorted by:
- Name
- Length
- Original Time Stamp
- User Time Stamp
- Timebase
- Start in Parent
- End in Parent

Clips can also be sorted by Clip Type (Audio and MIDI), or in Ascending or Descending order.

Finding Clips

Use the Find command to display all clips in a list whose names contain a particular word or phrase.

**To find and display clips in the Clips List:**

1. Do one of the following:
   - Click the Clips List menu and choose Find.
   - Press Command+Shift+F (Mac) or Control+Shift+F (Windows).

2. In the Find Clips dialog, do any of the following:
   - Select By Name and type the name, or any portion of the name, for clips you want to find. The search string appears at the top of the Clips List.
   - Select Include Subsequently Added Clips to limit the display to newly added clips. A plus (+) sign appears at the top of the Clips List to indicate this option is selected.
   - Select both options to start with a list of named clips and allow display of added clips.

[Find Clips dialog]

3. Click OK.

**To repeat a previous search:**

1. Click the Clips List menu, and choose Find.

2. Click the small arrow to the right of the text field in the Find dialog and select a text string from the Find History pop-up menu.

[An example of a Find history]
The Find History is saved with the session.

In addition to storing each text string previously entered, you can insert multiple entries into the Find History manually (without having to perform each Find in order to store words or phrases).

**To compile a Find History without performing each search:**

1. Click the Clips List menu, and choose **Find**.
2. Click and hold the small arrow to the right of the text field in the Find dialog and select the item in the Found History list before which you want to insert the new entry.
3. Type the name, or any portion of the name, for the clips you want to find.
4. Click and hold the small arrow to the right of the text field in the Find dialog and choose **Insert Entry** from the pop-up menu.

5. If desired, type another entry and choose **Insert Entry** again to add additional search strings to the Found History list.

**To remove an entry from the history:**

1. Select it from the Find History pop-up menu so it is displayed in the text field.
2. Choose **Remove Entry** from the Find History pop-up menu.

**To clear the Find History:**

- Choose **Remove All Entries** from the Find History pop-up menu.

---

**Select Parent in Workspace**

Enable this option to highlight the parent file of any selected clips in a Workspace browser.

---

**Selecting Clips in the Clips List**

In the Clips List, you can select clips so they can be dragged to tracks, processed with AudioSuite plug-ins, or exported.

**To select or deselect a clip in the Clips List, do the following:**

- Click a clip name that is unhighlighted to select it.
- Click a clip name that is highlighted to deselect it.

**To select a range of clips in the Clips List, do one of the following:**

- Move the cursor to the left of the clip names, so the Marquee appears, and drag around the clips you want to select.

**Clips selected with Marquee**

- Click the name of a clip in the Clips List, and Shift-click an additional clip name.

All clips that occur between the first clip selected and the additional clip will also be selected.
To select or deselect a range of clips with the Marquee:

1. Move the cursor to the left of the clip name until the Marquee icon with a small “+” symbol appears:
   - To select clips, the Marquee should be to the left of an unhighlighted clip name.
   - To deselect clips, the Marquee should be to the left of a highlighted clip name.

2. Click on the clip name and drag up or down (to select or deselect clips immediately above or below the clip name).

To enable and use the Clips List Keyboard Focus:

1. Click the Keyboard Focus button in the upper right of the Clips List.

To select multiple noncontiguous clips in the Clips List, hold Command (Mac) or Control (Windows) when making subsequent selections.

To select or deselect noncontiguous clips, do one of the following:

- Command-click (Mac) or Control-click (Windows) clip names that are unhighlighted to select them.
- Command-click (Mac) or Control-click (Windows) clip names that are highlighted to deselect them.

**Keyboard Selection of Clips**

If Clips List Keyboard Focus is enabled, you can type the first few letters of a clip’s name and Pro Tools will automatically locate and select the clip in the Clips List.

2. Type the first or first few letters of the clip to automatically locate and select it. Once a clip is located and selected, it can be dragged to a track.

Keyboard selection of audio clips locates clips based on their clip name, not on the names for their parent audio files or the volumes on which they reside.

**Select Options**

In the Clips List, you can select specific clips so they can be dragged to tracks, processed with AudioSuite plug-ins, or exported.

To select specific clips in the Clips List:

- From the Clips List menu, choose Select, and then choose one of the Select options:

  **All** Selects all clips in the Clips List.

  **Unused** Selects clips that have not been placed in a track in the current session. Offline clips appear in the Clips List italicized and dimmed.
Unused Except Whole Files Selects clips that have not been placed in a track in the current session, but do not include Whole-file clips. Whole-file clips are clips that were created when recording or importing audio, consolidating existing clips, and when nondestructively processing with an AudioSuite plug-in. Whole-file audio clips reference an entire audio file that resides on your hard drive. Whole-file audio clips are displayed in bold in the Clips List.

Offline Selects clips whose parent files cannot be located, or are not available, when opening a session or importing a track. Offline clips appear in the Clips List as italicized and dimmed; they appear in playlists as light blue clips with italicized names.

“Select Unused” Ignores Parent Clip Enabling the “Select Unused” Ignores Parent Clip option affects the behavior of the Select Unused command. When it is enabled, all unused clips are selected except for any unused whole clips that have related sub-clips currently on tracks in the session.

Previewing Clips in the Clips List

You can preview audio and MIDI clips and clip groups in the Clips List. Previewing follows the master Audition path as selected in the Output page of the I/O Setup. The base level for previewing is determined by the Master Fader (or Auxiliary Input) level assigned to the Audition path.

To preview a clip in the Clips List:

- Option-click (Mac) or Alt-click (Windows) the clip name.

Audio clips and clip groups play back through the specified Audition Path (see “Audition Path” on page 58).

Sample-based clips play back at their native tempo. Tick-based MIDI and Elastic Audio processed clips play back at the session tempo (based on the location of the playback cursor). You can also preview clips from the Clips List during session playback.

MIDI clips play back using the Default Thru Instrument selected in the MIDI Preferences page (see “The Default Thru Instrument” on page 539).

Auditioning Discrete Signals in Multichannel Items

In the Clips List, multichannel clips are auditioned through the Audition Path specified in the I/O Setup. Signals can be auditioned “in-place,” or through all outputs, as described below.

Audition In-Place

When auditioning a mono component of a mono component clip, the mono clip can be played from the corresponding channel of its parent mono component clip. This playback method is called audition in-place.

To audition in-place:

1. In the Clips List, make sure the stereo or multichannel clip is in expanded view (showing .L, .R, and other component channels).
2. Option-click (Mac) or Alt-click (Windows) the clip for the channel you want to audition.
Audition to All Outputs

When auditioning a mono component of a mono component clip, the clip can be routed equally to all outputs of the parent clip’s Audition Path.

To audition through all channels of the main audition path:

- Shift-Option-click (Mac) or Shift-Alt-click (Windows) on the signal in the Clips List.

Stereo and Multichannel Clips in the Clips List

Stereo and multichannel clips, whether imported or recorded into Pro Tools, are displayed as single items in the Clips List. For example, two mono source clips named “Main Piano.L” and “Main Piano.R” are listed as “Main Piano (Stereo).” An expand/collapse triangle indicates stereo and multichannel clips.

Stereo and multichannel clips are displayed in the Clips List by default in collapsed view. The individual clips can be displayed by clicking the arrow to the left of the clip to expand the name.

Individual items of an expanded-view stereo or multichannel clip can be selected independently of the other associated clips in the Clips List.

Rules for Stereo and Multichannel Clips

For stereo and multichannel audio clips to be shown as collective clips, the component clips must be the same length. If an existing stereo or multichannel clip has been dragged onto multiple mono tracks and edited such a way that one or more components are no longer the same length, the stereo display is removed and the clips are displayed as individual clips in the Clips List.

Naming and Displaying Clips in the Clips List

A typical session can become cluttered with dozens of tracks and hundreds of clips. There are a number of things you can do to keep track of and manage a session’s clips, including:

- Renaming existing clips
- Specifying how auto-created clips are named
- Hiding auto-created clips
- Removing unused clips

Renaming Clips

In the course of a session you can rename clips to give them more descriptive names, or to shorten or simplify existing names. When renaming a clip that was auto-created during editing, the clip becomes a user-defined clip and is displayed in the Clips List even when auto-created clips are hidden.

If a clip resides in a track, you can easily rename it by double-clicking it with one of the Grabber tools. However, if the clip does not reside in a track, or if you want to rename several clips, use the Rename command in the Clips List.
You can also rename a clip in a track using the Rename command in the Clips List menu or the Right-click menu.

**To rename one or more clips from the Clips List:**

1. If you will be renaming an auto-created clip, select Show > Auto-Created from the Clips List menu.

2. Select one or more clips to be renamed in the Clips List.

   **If the Clips List Selection Follows Edit Selection option in the Editing Preferences page is enabled, you can highlight a clip in the Clips List by selecting it in a track.**

3. Do one of the following:
   - From the Clips List menu, choose Rename.
   - Right-click on any selected clip and select Rename from the pop-up menu.

4. In the Name dialog, type a new name for the clip. If a whole-file audio clip was selected, specify whether to rename just the clip, or both the clip and the disk file.

   ![Name dialog](image)

   **Name dialog**

5. Click OK to rename the clip. If renaming multiple clips, you are prompted, successively, to rename each clip.

    **You can resize the Name dialog by dragging the boundaries of the dialog.**

**Clip Info**

The Name dialog provides the option to view information about the selected clip. This information is not editable from the Name dialog. The following clip information is available:

**Instances** Displays the number of instances of the clip used in the session.

**Rating** Displays the Rating for the clip (see “Rating Clips” on page 667).

**File Name** Displays the file name of the parent file for the clip.

**Start** Displays the start time of the selected clip according to the main timebase.

**Sync** Displays the Sync point time of the selected clip according to the main timebase.

**End** Displays the end time of the selected clip according to the main timebase.

**Duration** Displays the duration of the selected clip according to the main timebase.

**Original Time Stamp** Displays the original time stamp of the selected clip according to the main timebase.

**User Time Stamp** Displays the user time stamp of the selected clip according to the main timebase.
To show (or hide) information for the selected clip:

- In the Name dialog, click the show/hide triangle for Clip Info.

3 In the Rename Selected Clips dialog, enter the text to be used when naming clips created from the selected clip.

![Rename Selected Clips dialog]

**Auto-Naming Options**

You can specify the auto-naming options for a clip when new clips are created from it in the course of editing.

Auto-naming of clips does not affect the names of parent audio files. Instead, it stores pointers to the clips within the parent source file.

To set auto-naming options for a clip:

1. Select a clip in the Clips List.
2. Choose Auto Rename from the Clips List menu.

**Batch Clip Renaming**

The Batch Rename command for clips is only available in the Clips List.

> Clip Groups and clips contained within are ignored by Batch Clip Renaming.

To batch rename selected clips:

1. In the Clips List, select the clips you want to rename.
2. Do one of the following:
   - Click the Clips List menu.
   - Right-click a selected Clip in the Clips List.
3 Choose Batch Rename.

Press Control+Shift+R (Mac) or Start+Shift+R (Windows) to open the Batch Clip Rename dialog.

All selected clips are renamed accordingly.

For details on batch renaming tracks or clips, see “Batch Renaming” on page 301.

Managing Clips in the Clips List

In the course of editing a session, the Clips List can quickly fill up with many clips—with ones you have created intentionally and also with those that are automatically created by cutting, pasting, and separating other clips, or importing Clip Group files (or REX files as clip groups). Pro Tools lets you hide or remove clips in your session so you do not have to scroll through a long Clips List.

Hiding Auto-Created Clips

You can hide clips that were automatically created during the course of editing.

To hide auto-created clips:

- From the Clips List menu, deselect Show > Auto-Created. With this option deselected, only user-defined clips appear in the Clips List.

User-defined clips include:

- Whole-file clips
- Clips created during recording
- Imported clips
- Renamed clips
- Clips created as a result of AudioSuite processing
- New clips created with the Clip > Capture command or the Edit > Separate Clip commands
- Clips created by trimming whole-file audio clips
When auto-created clips are hidden, Pro Tools warns you if the number of auto-created clips exceeds a certain threshold, and gives you the option of deleting them. If you choose to delete them, all auto-created clips are deleted at the same time.

To ensure that you keep any specific auto-created clips, rename them. When you name a clip, it is promoted from being an auto-created clip to a user-defined clip (see “Renaming Clips” on page 296).

Clearing Unwanted Clips

In the Clips List, you can select unwanted clips and then use the Clear command to remove them from the session. Whole-file clips can also be permanently removed from the hard drive on which they are stored.

⚠️ The Clear command cannot be undone.

To find and remove unused clips in a session:

1. Do any of the following:
   - For MIDI clips, from the Clips List menu, choose Select > Unused.
   - For audio clips, from the Clips List menu, choose Select, then choose Unused, Unused Except Whole Files, or Offline.

2. After all unused clips are selected, choose Clear from the Clips List menu. The Clear Selected dialog opens.

3. In the Clear Selected dialog, select the Automatically select all unused clips option if you want to ensure that all unused clips, including whole file clips, are selected for deletion or removal. Any selections previously made in the Clips List are ignored.

4. Do one of the following:
   - Click Remove to remove the unused clips from the session.
   - If clearing a whole-file audio clip and you want to permanently remove the audio file from your hard drive, click Delete.

When deleting audio files for multiple clips, Pro Tools presents a warning dialog for each audio file.

To bypass repeated warning dialogs:

- Option-click (Mac) or Alt-click (Windows) the Delete button in the Clear dialog. This permanently deletes each successive audio file from your hard drive (for each of the unused clips) without any further warning.

⚠️ Use this “power delete mode” with caution. Deletion of these files cannot be undone.

Clip Name Right-Click Commands

When you Right-click a clip name in the Clips List, a pop-up menu provides access to the following commands:

- **Clear** Removes selected clips from the session.
- **Rename** Renames selected clips.
- **Time Stamp** Redefines the time stamp of selected clips.
- **Replace Clip (Pro Tools | Ultimate Only)** Replaces multiple instances of a clip with another clip.
- **Compact** Compacts selected clips.
- **Export Clip Definitions** Exports definitions for selected clips.
Export Clips as Files Exports selected clips as files.

Recalculate Waveform Overviews Redraws waveforms for selected clips.

Reveal in Workspace Lets you reveal the parent file for any individual clip in a Workspace browser.

Reveal in Finder/Reveal in Explorer lets you reveal the parent file for any individual clip in the Mac Finder or Windows Explorer.

Object Select in Edit Window Selects clip as an object in the Edit window.

---

**Batch Renaming**

Pro Tools lets you rename selected tracks or clips in batches. This can be very useful for managing auto-named tracks and clips, especially in a large session.

**Batch Renaming Dialog Options and Settings**

The Batch Track Renaming and Batch Clip Renaming dialogs provide controls for changing the names of all selected items (tracks or clips) by Replacing text, Trimming characters, Adding characters, and sequential Numbering. The Batch Clip Renaming dialog also provides controls for setting the order for numbering selected clips based on timeline order or Clips List sort order. Both dialogs also offer presets so you can store and recall common renaming schemes best suited to your workflow.

💡 Renaming tasks are applied in order from top to bottom: Replace, then Trim, then Add, and finally Numbering.

---

**Replace**

Enable (or disable) the Replace option to replace text in the names of clips or tracks.

논

Find Type the text you want replaced in the names of selected items.

Replace Type the text you want to use in the names of selected items instead.

Clear Existing Name Enable to completely clear the existing names of selected items.

Regular Expressions Enable to use advanced find and replace operations using regular expressions.

💡 For more information about using regular expressions for batch renaming tasks, see “Regular Expressions Workflow Examples” on page 304.
**Trim**

Enable (or disable) the Trim option to remove the specified number of characters from the beginning or end of names.

Press Command+T (Mac) or Control+T (Windows) to select (or deselect) Replace.

**Batch Rename, Trim options**

**From Beginning** Enter the number of characters you want to trim from the beginning of the names of selected items.

**From End** Enter the number of characters you want to trim from the end of the names of selected items.

**Range** Enable Range and then enter the number of characters From the beginning and the number of character To the end of the range that you want to trim (or crop) the selected names to. The From and To values can be counted from the beginning or from the end of the selected names.

**Count From Beginning** Enable to count the From and To values for Range from the beginning of the selected names.

**Count From End** Enable to count the From and To values for Range from the end of the selected names.

---

**Add**

Enable (or disable) the Add option to add prefixes or suffixes to names. You can also insert text into the middle of names.

Press Command+D (Mac) or Control+D (Windows) to select (or deselect) Add.

**Batch Rename, Add options**

**Prefix** Enable the Prefix option and type the text you want to add to the names of selected items as a prefix.

**Insert** Enable the Insert option and type the text you want to insert into the names of selected items. Enter a number in the At Index field to specify after which character you want to insert the text (for example, type 3 to insert text after the third character in names).

**Suffix** Enable the Suffix option and type the text you want to add to the names of selected items as a suffix.
Numbering

Enable (or disable) the Numbering option to add numbers to the names of selected items.

Press Command+N (Mac) or Control+N (Windows) to select (or deselect) Numbering.

![Batch Rename, Numbering options](image)

Position Select whether you want numbers to be added at the Beginning or End of names, or at the specified character index (At Index) in names. If you select At Index, also enter a number in the Index field to specify after which character in names you want to insert the numbers.

Starting Number Enter the number from which you want to start.

Number of Places Enter the number of places you want for numbering (for example, type 3 for three places 000).

Increment Enter the value by which you want the numbering to increment.

Separate With Enable to separate added numbers with a space or any other single character after (if placed at the beginning) or before (if placed at the end), or before and after the specified character index (if inserted at the specified index).

Use A.Z Enable to use capital letters instead of numbers.

Process Order

(Batch Clips Renaming Only)

The Process Order options are only in the Batch Clips Rename dialog and determine the order by which numbering is applied to selected clips.

![Batch Clips Rename, Process Order](image)

Timeline Order (Left to Right, Top to Bottom) Applies numbering according to the timeline order of selected clips from left to right and then from top to bottom.

Clips List Sort Order Applies number according to the current Clips List sort order for selected clips.

Presets

Pro Tools lets you store and recall common renaming schemes best suited to your workflow in both the Batch Track Renaming and Batch Clip Renaming dialogs. The Presets controls for Batch Renaming work much like the Preset controls for Fades and Clip Effects.

Presets Buttons

Both the Batch Track Renaming dialog and the Batch Clip Renaming dialog provide five preset buttons that let you store and recall your most commonly used naming conventions. You can also save and import additional Batch Naming settings using the Librarian menu.
To store a Batch Naming preset:
1. Configure the Batch Naming dialog as you like.
2. Command-click (Mac) or Control-click (Windows) the Preset button where you want to store the current Batch Naming settings.

To recall a Batch Naming preset:
- Click the Preset button that contains the settings you want to recall.

Librarian Menu

Use the Librarian menu to save and recall Batch Naming Settings files (.ptpreset). These are usually saved to and recalled from the Batch Track Rename folder or the Batch Clip Rename folder accordingly (/Documents/Pro Tools/Pro Tools Presets/Batch Track Rename/). Of course you can save to and import from any directory location on your system. Batch Name preset files can be shared and used on any other Pro Tools system as well.

The Librarian menu commands include:

<factory default> Restores the default settings for Batch Naming.

Save Settings Saves the current settings. This command overwrites any previous version of the preset.

Save Settings As Saves the current settings as a new preset. You can name the preset and save it to any location on your system.

Import Settings Opens the Choose a Settings File dialog focused on the default Batch Rename folder. Batch Naming Settings files (.ptpreset) stored in this location are listed by name just under <factory default> in the Librarian menu. In the Choose a Settings File dialog, you can navigate to any location on your system to select and import the Batch Settings file you want.

Delete Current Settings File Permanently deletes the current settings file (.ptpreset) from disk.

Lock (Unlock) Settings File Locks (or unlocks) the selected Settings file so that it cannot (or can) be edited.

Regular Expressions Workflow Examples

Regular expressions are standardized text strings that describe search patterns. Use regular expressions when batch renaming tracks or clips to find and replace text based on more advanced criteria than simple find and replace text operations.

For more information about regular expressions, visit https://www.regex101.com.
With Regular Expressions enabled, any number of text patterns can be matched and replaced when batch renaming tracks or clips. In the Find field, type the pattern you want to match inside parentheses and then separate patterns using | (the pipe symbol). For example:

<table>
<thead>
<tr>
<th>find</th>
<th>replace</th>
</tr>
</thead>
<tbody>
<tr>
<td>(Audio)</td>
<td>(VCA)</td>
</tr>
</tbody>
</table>

The text following ?1 will replace the text Audio, the text following ?2 will replace VCA, and the text following ?3 will replace Aux—(?1Aud)(?2Group Master)(?Bus)
Removing Automatic Names Generated By Track Duplication

Use the following regular expressions to remove all instances of .dup1, .dup2, or up to any number of duplicates from track or clip names by replacing them with no character at all.

```
<table>
<thead>
<tr>
<th>find</th>
<th>replace</th>
</tr>
</thead>
<tbody>
<tr>
<td>.dup\d+</td>
<td></td>
</tr>
</tbody>
</table>
```

\. searches for literal periods—as opposed to the special token . (period) since . itself is used to match any character—followed by dup, then \d (the regular expression for any number) followed by + (which matches any number of digits that follow .dup) and replaces all matches with nothing (effectively deleting that text).

Replacing Multiple Common AudioSuite Suffixes from Clip Names

Use the following regular expressions to find text automatically added by common AudioSuite processes and remove them or replace them with something more appropriately descriptive.

```
<table>
<thead>
<tr>
<th>find</th>
<th>replace</th>
</tr>
</thead>
<tbody>
<tr>
<td>(-Norm)</td>
<td></td>
</tr>
</tbody>
</table>
```

This replaces -Norm with nothing (effectively deleting that text), and replaces -EQ3-1B with -HPF to indicate that the EQ3-1B AudioSuite processing on the selected clips was used to roll off low frequencies.
Chapter 17: Workspace Browsers

The Pro Tools Workspace combines an intuitive, browser-style interface with an integrated databasing engine, optimized for metadata and media management.

Workspace browsers provide extensive databasing tools for searching, sorting, auditioning, and importing of audio, MIDI, video, plug-in settings (.tfx), Guitar Rig Settings (Eleven Rack only), and session files. Multiple browsers can be displayed and arranged, with custom display settings provided to customize your work environment.

For information on dragging and dropping files from Workspace browsers to your Pro Tools session, see “Importing Files with Drag and Drop” on page 400.

Workspace Browsers

Workspace browsers provide an intuitive user interface to databases with many convenient features for various file management tasks (such as search and sort functions).

Workspace browsers in Pro Tools are analogous to windows in your computer’s operating system, but are specifically designed for Pro Tools workflow. Multiple browsers can be displayed simultaneously, and arranged independently with custom display settings for each.

Workspace browsers let you search and sort audio files, video files, and sessions. Audio, video, and session files displayed in browsers can be dragged directly into the current Pro Tools session.

When offline items are needed, Pro Tools lets you find the correct matching files, then relink to online media.

The Workspace browser provides access to all your mounted volumes, as well as the folders and files they contain.

Using the Workspace browser, you can:
• Use Soundbase to tag and find audio files with musically descriptive metadata
• Access all mounted volumes
• Access all Catalogs
• Search across multiple volumes and Catalogs simultaneously
• Designate volumes for Record and Playback, Playback Only, or Transfer
• View, manage, audition, and import individual items in any catalog or mounted volume
• Update databases for entire volumes

Sound Libraries

At the top of the list in the Location pane of any Workspace browser is the Sound Libraries directory. Sound Libraries provides easy access to tagged audio files, and search on criteria that includes musically useful information about the audio content—especially Time Base, Duration (Min:Sec or Bars|Beats), Tempo, Key, Time Signature, Favorites, Rating, and Tags. Use Soundbase in Workspace browsers to find audio files using tags (WAV and AIFF only). Tags are
descriptive metadata saved to and read from the header of an audio file. You can create, add, and edit tags for any WAV or AIFF file accessible through the Workspace.

**Volumes**

Workspace browsers provide file management for local and network volumes. Volumes are formatted partitions on a physical drive (hard drive). Any changes made in the Workspace (such as copying, or moving files and folders) is mirrored on the volumes themselves. Volumes include mounted hard drives, network storage, and removable media (such as CD-ROMs).

When Volumes are focused in the Locations pane you can:
- View, manage, audition, and import individual items on the volume
- Update a database for contents of the volume

**Session**

Workspace browsers provide powerful search and management tools for the files referenced in your current session, regardless of where they are stored.

When the currently open session is focused in the Locations pane you can:
- Show all the media files associated with the current session, including any missing files
- View, manage, audition, and spot individual items

**Catalogs**

Catalogs provide the highest level of Pro Tools file management. Catalogs make it easy to organize files from multiple sources into libraries of favorite files. Catalogs can be sorted and searched, even when the files they reference are offline.

Using Catalogs, you can:
- Collect and organize files from any combination of volumes
- Create catalogs of complete volumes to view and search even if a volume is offline
- View, manage, audition, and import individual items in the catalog
- Update a database for contents of catalog

![For more information, see “Catalogs” on page 351.]

**Task Manager Window**

The Task Manager window is a utility for viewing and managing all of the background tasks that you initiate with Pro Tools. Use the Task Manager window to monitor, pause, or cancel background tasks such as file copies, searches, and indexing.

![For more information, see “Task Manager Window” on page 354.]

**Relink Window**

The Relink window provides tools and features for relinking sessions and catalogs to media files. Use Relink tools to search and reacquire missing files for use in the current session.

![For more information, see “Relink Window” on page 347.]

**Performance and Transfer Volumes**

Workspace browsers let you view, manage, and import sessions and media from both Performance and Transfer volumes.
**Performance Volumes** These are storage volumes (hard drives) that are suitable for playback and have been designated in the Workspace browser as Record and Playback (R) or Playback Only (P) of media files in a Pro Tools session.

**Transfer Volumes** These are volumes that are not supported for media playback in Pro Tools (such as shared network volumes or CD-ROMs), or storage volumes (hard drives) that have been designated in the Workspace browser as Transfer (T) volumes. Transfer volumes cannot be used to record or play back media in a Pro Tools session. Designated Transfer (T) volumes can be useful for transferring session and media files between different Pro Tools systems.

For more information, see “Volume Permissions” on page 312.

**Databases**

The information displayed in Workspace browsers is stored in the system-wide Pro Tools database. Pro Tools creates a centralized database automatically for all mounted volumes, including Transfer volumes, on your system drive. Pro Tools uses a single database file that maintains an index of all volumes (hard drives, networked drives, and removable media) and catalogs.

On Mac, the database file is stored in /Users/Shared/Pro Tools.

On Windows, the database file is stored in <Systemdrive>/Users/Public/Pro Tools.

The waveform cache for audio files indexed by the database are stored within the database file. This includes the mini thumbnail waveforms for previewing (waveform cache files for sessions continue to be stored in the session folder).

There is also a global waveform cache file used to store audio file metadata when no session is open, or for files that reside on read-only volumes. As in previous versions of Pro Tools, this is a separate file that is stored next to the database file.

> When opening sessions created in lower versions of Pro Tools in Pro Tools 12.7 or higher, you are prompted to update the database file and to manually back up the database file from the lower version of Pro Tools. This is important if you (or anyone else for that matter) expect to continue to work on the session in a version of Pro Tools lower than 12.7. Back up that database file to facilitate session interchange between different versions Pro Tools. This helps to maintain things like Catalogs created in lower versions of Pro Tools or Favorites and Ratings created in Pro Tools 12.7 or higher.

> When opening a session last saved in Pro Tools 12.7 in a lower version of Pro Tools, any Pro Tools 12.7 database file is backed up automatically and appended with the version of the backup starting with “.1” (Workspace.wksp.1). The appended number increases incrementally for each subsequent backup.

With Pro Tools 11 and higher, the database file is versioned and is not backward compatible with previous versions of Pro Tools. When using a system where Pro Tools 11 or higher and Pro Tools 10 are co-installed, there will be separate database files for each version of Pro Tools. Database files of the same version are cross-platform compatible (Mac and Windows).

Pro Tools databases use two file types:

**Workspace.wksp** Stores media and session file metadata for a particular volume or catalog.

**Wavecache.wfm** Stores waveform overviews for all audio files referenced by each session.

There is also the MiscSettings file which stores the directory path for the Sound Libraries folder.
Workspace Browser Layout and Tools

Workspace browsers display all files in their database, including Pro Tools and non-Pro Tools files. Unknown file types can be shown, as well as aliases, and desktop folders.

To maximize processing speed and protect vital components, Workspace browsers do not display all folders. For example, in Windows, Workspace browsers do not display the WU Temp or System Volume Information folders; and on Mac, Workspace browsers do not display the System folder. This excludes them from being indexed, searched, sorted, or affected in any way by Workspace tasks. You should not store Pro Tools session or media files in any of these folders.

The main elements of a Workspace browser include the following.

**Toolbar** Provides the Browser menu, Search icon, View Presets (numbered 1–5), Workspace browser navigation tools, and preview tools.

**Items List** Displays the contents of a volume, folder, session, or Catalog database in rows.

---

**Basic Workspace browser tools, panes, and columns**

---
**Columns** Identifies the type of metadata displayed in the items list (such as file name and format) for volumes, folders, and files in the Items List. Columns can be resized by dragging the column border, or rearranged by dragging the Column headers.

Each row of data in a Workspace browser represents an Item (such as a file or folder). Data about each item is displayed in columns.

**Locations Pane** Used to navigate the Sound Libraries, volumes (local and networked drives) on your system, the currently open session, indexed Catalogs of media, and the system User directory.

**Browser Pane** Displays the contents of items selected in the Locations pane or search results.

**Opening Workspace Browsers**

There are several ways to open, close, and navigate one or more Workspace browsers.

**To open a new Workspace browser focused on Volumes, do one of the following:**

- Choose Window > New Workspace > Default.
- Press Option+I (Mac) or Alt+I (Windows).

**To open a new Workspace browser focused on Soundbase:**

- Choose Window > New Workspace > Soundbase.
- Press Option+Control+I (Mac) or Control+Alt+I (Windows).

**To open a new Workspace browser focused on the Project:**

- Press Option+O (Mac) or Alt+O (Windows).

**To open a new Workspace browser from a selected volume, catalog, or folder, do one of the following:**

- Command-double-click (Mac) or Control-double-click (Windows) a volume, catalog, or folder in the currently open Workspace browser.
- Press Option+Down Arrow (Mac) or Alt+Down Arrow (Windows) to open the currently selected volume, catalog, or folder in a new Workspace browser.
- Press Option+; (Mac) or Alt+; (Windows) to open and close a single Workspace browser.

*Option+; (Mac) or Alt+; (Windows) also close the Workspace browser if the selection in the Locations pane is on the Volumes root folder. If another item is selected in the Locations pane, these key commands will open a new browser focused on that item.*

**Viewing the Contents of Sound Libraries, or a Volume, Folder, or Catalog**

**To expand or collapse the currently selected folder, do one of the following:**

- Click the Expand/Collapse icon next to the volume, folder, session, or catalog in either the Browser pane or the Locations pane.
- Select Sound Libraries, or a volume, folder, or Catalog, and press the Right Arrow key to expand, or the left Arrow key to collapse.

**To move up one level in a browser:**

- Click the Browse Back arrow in the toolbar.

*To move up one level in a browser, press Command+Up Arrow key (Mac) or Control+Up Arrow key (Windows).*
Moving Workspace Browsers to the Foreground or Background

To bring all open Workspace browsers to the foreground:
- Choose Window > Browsers > Bring to Front.

To send all Workspace browsers to the background:
- Choose Window > Browsers > Send to Back.

All open Workspace browsers are moved to the background, bringing the other windows to the foreground. Nonetheless, all Workspace browsers remain open and accessible.

To bring an open Workspace browser to the foreground:
- Choose Window > Browsers, and select an open Workspace browser from the submenu.

To cycle to the next or previous Workspace browser:
- Press Command+Left/Right Arrow keys (Mac) or Control+Left/Right Arrow keys (Windows).

Closing Workspace Browsers

To close all Workspace browsers:
- Option-click (Mac) or Alt-click (Windows) the Close box of any Workspace browser.

Because the Task window is a utility and not a browser, it remains open.

Volume Permissions

The Workspace includes a permissions column (Permissions) for Volume permissions. This column displays, and let you designate, whether a volume has permissions for Record, Playback, or Transfer of media files.

R (Record and Playback) Able to play audio and video files already on the volume, and record new audio files.

P (Playback Only) Can play audio and video files already on the volume, but cannot have new files recorded to it.

T (Transfer) Can only be used for storing, transferring, or auditioning files, and cannot be used for recording or playback.

If you have a Pro Tools system with multiple drives, and you intend to record multiple tracks simultaneously, you may want to designate the System drive as a Playback only or Transfer only drive for optimal performance.

To change a volume designator:
1. Open a Workspace browser.
2. In the Locations pane, select Volumes.
3. In the Browser pane, click and select the appropriate permissions for any volume.

You can also Right-click any volume in either the Locations pane or the Browser pane and set the desired permissions setting for the selected volume.

Designating a volume in the Workspace
Unmounting Volumes

Use the Finder (Mac) or Windows Explorer (Windows) to mount and unmount volumes while Pro Tools is running.

Working with Items in Workspace Browsers

Opening Sessions

To open a Pro Tools session listed in a Workspace browser:

- With no Pro Tools session currently open, double-click a Pro Tools session file in the Browser pane of any Workspace browser.

Opening AAF and OMF Sequences

AAF and OMF sequences can be opened from Workspace browsers.

You can also drag and drop AAF and OMF sequences from Workspace browsers into the current session.

To open an AAF or OMF sequence from a Workspace browser:

1. Do one of the following:
   - With no Pro Tools session currently open, double-click the AAF or OMF sequence in the Browser pane of any Workspace browser.
   - Drag the AAF or OMF sequence from the Browser pane of any Workspace browser to the Timeline in an open session.

2. Configure the Import Session Data dialog.

3. Click OK.

Creating and Opening Workspace Browser Folders

Workspace browsers let you create and manipulate folders (file system sub-directories). All folders have Expand/Collapse icons to show their contents. Dragging items onto a folder icon is the same as dragging into an open Workspace browser.

To create a new folder in a volume, folder, or catalog:

1. Select the volume, folder, or catalog in which you want to create a new folder.
2. Right-click the item and choose New Folder.
3. Type a name for the folder and click OK.
4. For volumes and folders, the folder is created on disk. In Catalogs, the folder is created in the catalog database only. The Items List updates as new items are added.

To open a folder in the current Workspace browser:

- Double-click the folder, or click the Expand/Collapse icon for the item.

With a browser in the foreground and the folder selected, press Command+Down Arrow (Mac) or Control+Down Arrow (Windows) to open a folder in the current Workspace browser.
To open a folder in its own new Workspace browser:

- Command-double-click (Mac) or Control-double-click (Windows) the folder. The previous (parent) Workspace browsers window remains open.

> With a browser in the foreground and the folder selected, press Command+Option+Down Arrow (Mac) or Control+Alt+Down Arrow (Windows) to open a folder in its own new browser.

Scrolling and Moving Selections

To scroll the active pane up or down:
- Press the Page Up or Page Down key.

To scroll to the top or bottom of the active pane:
- Press Home (for the top) or End (for the bottom).

To move items up or down in the current Workspace browser:

1. Select items in a Workspace browser, and make sure that window is in the foreground.
2. Press the Up Arrow or Down Arrow key.

Text Entry in Workspace Browsers

Many text fields can be edited to replace or update data for an item.

To enter an edit to a text field and exit, and return to the previous display state:
- Press Enter.

To revert to the previous text and cancel a text edit:
- Press Esc.

For details on column editing, see “Column Data” on page 320.

Indexing Workspace Databases

Indexing is the process of reading media files, extracting just the metadata for each file, then storing that data in an associated database so that it may be displayed in the columns of a Workspace browser. Once a volume or folder has been fully indexed, it can be searched very quickly because all of the metadata has already been sorted and organized.

If a volume or folder has not been indexed, it is indexed automatically the first time it is opened in a Workspace browser. Volumes or folders containing a lot of media files can take a long time to index. For this reason, you may want to manually index specific volumes or files prior to starting a project to help expedite workflow.

Indexing while Browsing

The first time you open a browser for a volume or folder that has never been indexed, Pro Tools automatically begins to fill the database for that level of the volume. Files and folders appear in the browser Items List, along with metadata in the columns for each item. Indexing continues until you either close the browser, or until that folder is completely indexed.
Chapter 17: Workspace Browsers

The next time you open that browser, metadata for items that have already been indexed is visible immediately. If the browser or folder was closed before indexing was complete, or if the contents of the folder have changed since the last time it was browsed, Pro Tools automatically updates the database the next time it is opened. This way, the database is always up to date for the folder you are browsing. (View the Task Manager to see current activity.)

Indexing while Browsing saves time because it only fills the database for items on the level of the volume that you are currently browsing. For example, if you are browsing the root level of the volume, it indexes only the folders and files on the root level. If you open a folder, Pro Tools indexes just the items in that folder. As a result, a database is only indexed for the parts of the volume that you have browsed. However, searches are faster and more complete when a volume is already completely indexed.

**Manual Indexing**

Manual indexing fills in all missing data, and updates changed data for selected folders and all of their sub-folders.

**To update the index for a folder and all sub-folders:**
- Right-click the item in a Workspace browser Items List and choose Update Index.

**To update the index for an entire volume:**
- Right-click the volume to update in the Workspace browser and choose Update Index.

**Last Indexed Date Display**

The Date Indexed column shows the date that the index for that folder and all of its sub-folders was updated. Keep in mind that individual sub-folders may have been updated more recently.

**Automatic Updating for Pro Tools Actions**

Whenever Pro Tools adds, deletes, or modifies a file on a volume or in a session, the appropriate database is immediately updated to reflect the change.

**Changes that are made with Windows Explorer or the Mac Finder (such as copying or moving files) are not tracked by Pro Tools and are only indexed if the necessary folder is browsed or if a manual index is performed.**

**Workspace Browser Menu**

All Workspace browsers provide a Browser menu in the upper right corner of their toolbar. The Browser menu provides access to global workspace commands. When enabled, these commands apply to all items in all open browsers.

**Loop Preview**

Previews the selected file by looping playback of the file. If multiple files are selected, only the first selected file previews. When Loop Preview mode is enabled, the Preview button updates to show a Loop Preview Mode icon.

**Auto-Preview**

Enables or disables automatic preview of files. When this option is enabled, selecting a file in the browser starts preview. The Preview button updates to show that Auto-Preview is enabled.
Spacebar Toggles File Preview Enables or disables the Spacebar for starting and stopping preview. When this option is disabled, use the Preview button to start and stop preview. In this mode, the Spacebar starts and stops session playback. This lets you play back the session and, with the Audio Files Conform to Session Tempo option enabled, preview the selected audio file in time with the session.

Audio Files Conform to Session Tempo Conforms all tick-based audio files with Elastic Audio analysis, as well as REX and ACID files, to the session tempo. This option lets you play back the session and simultaneously preview the selected files in time with the session. This option is only available when a session is open. For more information, see “Conforming Preview to the Session Tempo” on page 343.

When the Audio Files Conform to Session Tempo option is enabled, Pro Tools analyzes un-analyzed files on preview or import. Audio files that have been analyzed as tick-based can then be previewed at the session tempo and conform to the session tempo on import.

When the Audio Files Conform to Session Tempo option is disabled, any tick-based audio files with Elastic Audio analysis, and REX and ACID files preview and import at their native tempo.

Don’t Limit Search Results Select (or deselect) the Don’t Limit Search Results option to show all search results past the default 1,000 item limit. If a search returns more than 1,000 items you are notified to the left of the simple search field that 1,000+ items were found. You can click the 1,000+ link to show all items found or you can enable the Don’t Limit Search Results option to always show all search results.

Show Offline Volumes Select (or deselect) the Show Offline Volumes command to show (or hide) all indexed offline volumes from the database in the Locations pane.

Delete Index for All Offline Volumes Deletes the index for all offline volumes from the database.

Keep Window on Top Select (or deselect) the Keep Window On Top option in the Workspace Browser menu to ensure that the Workspace remains in the foreground when working with other windows. This can be helpful when working with the Workspace and the Edit window in particular. When this option is disabled, clicking on another window (such as the Edit or Mix windows) brings that window to the front and the Workspace may be hidden behind it. When enabled, all open Workspace browser remain in front of all other windows with the focused Workspace always in the foreground.

Workspace Right-Click Menu

Pro Tools lets you Right-click on items in the Locations pane (such as volumes and folders) and the Browser pane (such as folders and files) to access relevant contextual commands. These commands are specific to the type of items selected in the Locations pane or the Browser pane, as described below.

New Folder Creates a new folder on the currently selected volume or folder, or within the currently selected catalog. For volumes and folders, a new folder is created on disk. For more information, see “Creating and Opening Workspace Browser Folders” on page 313.

Create Catalog from Selection Creates a fully indexed catalog of all items selected in either the Locations or the Browser pane.
Reveal in Finder/Explorer Opens the corresponding parent window in the Finder (Mac) or Explorer (Windows) for the currently selected file.

Open in New Workspace Opens the selected item in a new browser. The selected item is highlighted in the new browser.

Tags Opens the Assign Tags popover window for audio files (WAV or AIFF only). For details on the Assign Tags popover window, see “Soundbase and Tags” on page 331).

Recently Used Tags Lets you assign any of the last 10 used tags to the selected audio file (WAV or AIFF only).

Spot To Edit Insertion Spots the selected audio file to the current Edit insertion location. Note that the channel width of the file must match the channel width of the target audio track.

Update Index Updates the index for the currently selected volumes or folders.

Delete Index Deletes the index of files for the items in the selected volume or folder from the database.

Delete Index for All Offline Volumes Deletes the index for all offline volumes from the database.

Invert Selection Reverses (inverts) the current selection.

Select All Selects all items shown in the browser.

Calculate Waveform Calculates the waveform displays for selected audio files, or for all audio files within selected volumes, folders, or catalogs.

For more information, see “Waveforms” on page 337.

Calculate Elastic Analysis Calculates Elastic Audio analysis data for all selected audio files. Analyzed files where a tempo has been detected are also updated as tick-based, display their duration in Bars|Beats, and display their native tempo in the Tempo column. You can view the progress of Elastic Audio analysis in the Task window.

Clear Elastic Analysis Clears Elastic Audio analysis data for all selected audio files. Files cleared of Elastic Audio analysis data revert to sample time-base, display their duration in minutes and seconds, and do not report a tempo.

Load Guitar Rig Settings (Eleven Rack Only) Loads the Guitar Rig Settings for selected audio files with embedded Guitar Rig Settings from an Eleven Rack.

Select Offline Files Selects all files that are currently offline.

Select Online Files Selects all files that are online.

Select Transfer Files Selects all files identified as Transfer files (files found on media that do not support playback).

Relink Offline Opens the Relink window for items selected in the current session.

Relink Opens the Relink window, with all selected files from the current browser displayed and selected as Files to Match. This command is available for catalogs and sessions only.

Copy and Relink Copies items selected in the current session browser to a chosen location, and relinks the session to the copies instead of the originals. Use this to easily move files from a Transfer to a Performance volume. This command is also available in selected catalogs to copy items and relink the current catalog to the copies.

For more information, see “Elastic Audio Files in the Workspace” on page 338.
Duplicate Creates a duplicate of the selected items in the same location.

Rename Renames the selected item.

Permissions Lets you set Transfer, Playback, or Record permissions for the selected volume (see “Volume Permissions” on page 312).

Lock Locks all selected items. Any files already locked remain so. Locking a folder locks all files and sub-folders it contains.

Unlock Unlocks the selected items.

Delete Lets you delete selected files, folders, and catalogs from disk, or move selected items to the Trash (Mac) or to the Recycle Bin (Windows).

### Workspace Browser Panes and Display

Workspace browsers display an Items List consisting of various columns (such as file name, size, creation date, and sample rate).

### Showing (or Hiding) the Locations Pane

The Locations pane can be hidden.

To show or hide the Locations pane:
- Click the Show/Hide icon in the lower right corner of the left-hand pane.

### Showing and Hiding Columns

You can show or hide individual columns in Workspace browsers to fit your workflow. The default column display includes the items you would use in most sessions.

To show or hide individual columns:
- Right-click a column label and select or deselect checkboxes for column names in the pop-over menu.

### Moving Columns

To move a column:
- Drag the column to a new location in the Workspace.

### Resizing Columns

To resize a column, do one of the following:
- Drag the right column boundary to a new width.
- Double-click the right column boundary to resize the column to the widest element in column.
Selected items appear in new columns. Deselected items are hidden.

Option-click (Mac) or Alt-click (Windows) a column to hide it. The item is deselected in the Column menu.

To show all columns:
- Right-click a column label and Option-click (Mac) or Alt-click (Windows) any unchecked checkbox in the popover menu.

To hide all columns:
- Right-click a column label and Option-click (Mac) or Alt-click (Windows) any checked checkbox in the popover menu.

To show the default set of columns:
- Right-click a column header and choose DEFAULT from the popover menu.

View Presets

Pro Tools lets you save up to five preset views for the Workspace browser and for the Relink window. Presets can be recalled by clicking a View Preset button.

To store a View Preset:
1. Open a Workspace browser or the Relink window.
2. Arrange columns and views.
3. Command-click (Mac) or Control-click (Windows) any of the Preset buttons 1–5.

To recall a saved preset:
- Click the appropriate View Preset button.

Sorting Columns

Columns can be sorted in ascending or descending order, and multiple sorts can be applied (up to four levels).

To sort by columns:
- Click the column title header.

To toggle the current sort order between ascending and descending:
- Click the column title header a second time.

To sort by multiple columns:
- Shift-click successive column headers.
**Column Data**

In Workspace browsers, each row of data represents an item in a database (such as a file, session, or volume). Each column displays specific data for an item.

**ALL** Choose to show all columns.

**NONE** Choose to hide all but the Name column (which is always shown).

**DEFAULT** Choose to show the default columns.

**SOUNDBASE** Choose to show only Soundbase related columns.

**# of Channels** Displays the number of channels in an audio file: mono, stereo, or 3–8 as appropriate for supported multichannel files. This field cannot be edited.

**Author** Displays the assigned Author of the item. Click in the Author column for an item and type the name of the author or authors.

**Bit Depth** Displays an audio file’s bit depth. This field cannot be edited.

**Capacity** Displays the total capacity of a volume. This field cannot be edited.

**Channel Names** Displays the channel name and number data embedded in multichannel audio files. You can edit the Channel name for mono BWF files only. When editing the channel name, anything entered in parentheses is discarded. However, the channel number will always be preserved.

**Circled** Indicates if the status of a take is set to “circled” (No or Yes) in audio files. This is usually for indicating which take should be used.

**Clip Name** Displays the name of the file, or the Avid clip name when the item is an AAF or OMF file. The Clip Name is what appears in the Timeline and Clips List when a file is imported into a session.

**Copyright** Displays the assigned Copyright for the item. Click in the Copyright column for an item and type the copyright.

**Database Comment** Displays user comments stored with the database, with support for Finder comments. See “Comments Fields” on page 322 for more information.

**Date Created** Displays the creation date of an item. This field cannot be edited.

**Date Modified** Displays the last modified date for the item. This field cannot be edited.

**Date Indexed** Displays the last indexed date for the item. This field cannot be edited.

**Duration** Displays the duration of a file in absolute time (minutes and seconds), regardless of the time-code format. For clip groups, MIDI, tick-based Elastic Audio files, REX, and ACID files, Duration displays Bars and Beats. This field cannot be edited.

**Favorite** Select (or deselect) the heart icon to designate an item as a Favorite. Only items in the selected Location that are marked as a Favorite are shown when the Favorites (heart) icon is enabled in the Workspace Toolbar.
**File Comment** Displays any embedded comments associated with the file. File comments are supported with BWF and SD II files, but are not supported with AIFF files. File Comments always remain with the file when copied, converted, or transferred. See “Comments Fields” on page 322 for more information.

⚠️ *When importing SD II files into Pro Tools, they must first be converted to a supported audio file format (.WAV or .AIF).*

**Format** Displays the audio file format: WAV, WAV (ACID) for ACID files, WAV (BWF), AIFF, MP3, or ReCycle for REX files. This field cannot be edited.

**Frame Rate** Displays the frame rate of video files where applicable.

**Free** Displays the unused space on volumes. This field cannot be edited.

**ISRC** Displays the ISRC (International Standard Recording Code), if any, for the selected file. Click the ISRC field to add or edit the ISRC for a file.

*For more information about ISRC, visit www.usisrc.org.*

**Key** Displays the assigned key of the file. Click in the Key column for an item and select the key (such as C) and mode (such as Major).

**Kind** Displays whether the item is a volume, folder, catalog, or file. For files, this column displays what kind of file it is: session file, audio file, video file, or other. This field cannot be edited. For audio files, this column also indicates whether the file is sample-based to tick-based.

**Link Path** Displays the path to the file used for relinking. Available in the Relink window only.

**Loop** Click the Loop icon for an item to enable (or disable) its Loop designation.

**Name** Displays the name of the file, folder, volume, catalog, or session. For offline items, the name is italicized. The Name column is always shown.

**Original Time Stamp** Displays the original time stamp (timecode location) of audio or video files.

**Path** Displays the directory path to the item.

**Permissions** Displays the designated permissions for volumes for media recording, playback, or transfer only.

*For more information, see “Volume Permissions” on page 312.*

**Plug-In Manufacturer Name** Displays the plug-in manufacturer’s name for Plug-In Settings files (.tfx).

**Plug-In Name** Displays the name of the plug-in for Plug-In Settings files (.tfx).

**Project** Displays the project name data embedded in audio files.

**Rating** Lets you rate the item from zero to five stars. Click the Stars to set the rating for an item.

**Sample Rate** Displays an audio file’s sample rate. This field can be edited in Workspace browsers for WAV and SD II files only. This can be useful when dealing with audio that has been pulled up or down, or to force a sample rate conversion to occur if that is necessary before importing a file that otherwise would not require conversion.

**Scene** Displays scene number data embedded in audio files.

**Shoot Date** Displays origination date and time information embedded in audio files. However, many field recorders do not populate the Shoot Date field, relying instead on the file’s Creation Date to indicate date of production. When Pro Tools imports a field recorder file, it checks to
see if the Shoot Date field is populated. If it is empty, Pro Tools copies the Creation Date of the original source file to the Shoot Date field of the new imported files. This field cannot be edited.

**Size** Displays the size of a file. This field cannot be edited.

**SMPTE ID** Displays the 32-bit unique ID for specific MXF files that were made with the SMPTE standard identifier.

**Sound Roll** Displays sound roll number data (This data is usually named “Tape” in BWF files, but is distinct from the date displayed in the Workspace Tape column). This field cannot be edited.

**Sound Roll TC** Displays the starting timecode of audio files. This field cannot be edited.

**Sound Roll TC Rate** Displays the frame rate information embedded in audio files: 24, 25, 29.97, 30, drop or non-drop. This field cannot be edited.

**Tags** Displays, and lets you add and edit tags. Click in the Tags column for an item to add or edit tags. You can also mark items as Favorites and Rate them from zero to five stars. For more information, see “Soundbase and Tags” on page 331.

**Take** Displays take number data embedded in audio files.

**Tape** This column displays the original Avid tape name if the item is an OMF file (audio or video). If an audio file was originally recorded in Pro Tools, this field displays the name of the original session.

**Tape ID** Displays tape ID information embedded in audio files. This field cannot be edited.

**TC Rate** This column displays the frame rate of the item if the item is an AAF sequence or an OMF sequence or file: 24, 25, 29.97, 30, drop or non-drop. For sequences, the frame rate at the start of the sequence is displayed.

**Tempo** Displays the tempo associated with clip group, MIDI, tick-based Elastic Audio files, REX, and ACID files, and session files. This field cannot be edited.

**Time Signature** Displays the assigned Time Signature of the file. Click in the Time Signature column and select the meter (such as 4/4).

**Unique ID** Displays the standard 8-bit Unique ID for most media and Pro Tools files.

**User Bits** Displays text information embedded in audio files. This field can be used for user comments, or auto-generated info with certain field recorders.

**User Time Stamp** Displays the user time stamp, if any, of audio files only.

**Video Compression** Displays the compression ratio of video files where applicable.

**Waveform** Displays a graphical overview of an audio file. See “Waveforms” on page 337 for more information.

## Comments Fields

Comments about individual files can be stored in the database, and embedded with the file’s metadata wrapper. There are two types of comments fields: File Comments and Database Comments.

### File Comments

File Comments are stored with the metadata of the file itself. Not all file types support File Comments. Indexing stores File Comments in the database, allowing them to be searched and viewed even if the file is offline. File Comments can be edited in Workspace browsers, as long as the files or their parent media are not defined as read-only.

You can also add and edit File Comments to Pro Tools Session files. File Comments cannot be edited in Catalogs.
Database Comments
(Sessions and Catalogs Only)

Database Comments, which can be up to 256 characters in length, are searchable, cross-platform, and editable.

Adding and Editing Comments

To add, view, or edit a comment:
1 Click the Comments field. The field expands to display the entire contents of the field if necessary.
2 Enter or edit a comment.
3 Press Enter, or click outside the text box to close it.

Selecting Items

To select a single item in the Locations pane:
- Click the icon for an item. When selected, the item is highlighted. The contents of the selected item (volume, folder, session, or catalog) are displayed in the Browser pane.

If there is already a selection in the Locations or Browser pane, you can also type the first letters of the item you want to select.

To select multiple items in the Browser pane:
- Drag to select a group of items, or Shift-click additional items. Command-click (Mac) or Control-click (Windows) to select multiple non-contiguous items.

To select all items listed:
- Press Command-A (Mac) or Control-A (Windows).

To select all Transfer files in the current window:
- Choose Select Transfer Files from the Browser menu.

To select all offline files:
- Choose Select Offline Files from the Browser menu.

To select all online files:
- Choose Select Online Files from the Browser menu.

To reverse the current selection:
- Choose Invert Selected from the Browser menu.

Moving, Copying, Duplicating, and Removing Items

Moving, copying, duplicating, and removing items in Workspace browsers follow the same rules and behavior as in the operating system. For example, moving a file to another volume copies the file, and Pro Tools warns you if an items is about to be overwritten or replaced. Dragging an item from a Catalog to a Volume folder always makes a new copy of the item.

Moving Items

To move items:
- Select one or more items and drag them to a new location. Moving to a new location on the same volume moves the item, while moving to a different volume copies the item.

You can drag items directly into the Time- line or Clips List of the current session. See “Importing Files with Drag and Drop” on page 400.
Copying Items

To copy and move items:
- Select one or more items and Option-drag (Mac) or Alt-drag (Windows) them to a new location.

Duplicating Items

To duplicate one or more items:
1. Select one or more items.
2. Choose Duplicate Selected from the Browser menu.

Removing Session Items

Workspace browsers let you remove or delete files from the currently open session. If a selected item resides on a read-only volume, it can be removed from the session, but it cannot be deleted.

To delete one or more items from the session:
1. Select the current session in the Locations pane.
2. Select one or more items in the Browser pane.
3. Choose Delete from the Right-click menu.
4. Do one of the following:
   - Click Move to Trash (Mac) or Move to Recycle Bin (Windows) to remove the item from session.
   - Click Delete to remove the items from your system.
   - Click Cancel to leave selected items unchanged.

Set Column Metadata Values for Multiple Selected Files in Workspace Browsers

Pro Tools lets you select multiple files in a Workspace browser and then set certain metadata (by column) for the selected items to the same value simultaneously. The following columns can be edited in this fashion: Permissions, Circled, Key, Time Signature, Tags, Favorite, Rating, and Loop.

To set the column metadata for all selected files in a Workspace browser to the same value:
1. Select multiple files in a Workspace browser. The selected files can be contiguous or discontinuous.
2. Do one of the following:
   - Option-Shift-click (Mac) or Alt-Shift-click (Windows) the column drop-down menu (Permissions, Circled, Key, Time Signature, or Tags) and select the desired value.
   - Option-Shift-click (Mac) or Alt-Shift-click (Windows) the Rating, Favorite, or Loop column.
   - Click on the Rating, Favorite, or Loop icon and drag up or down.
**Searching Items**

Pro Tools lets your search your entire system, or specific volumes, directories, or catalogs with ease. Workspace browsers provide a simple set of search tools so you can quickly search and find files (both online and offline) on your system.

Performing a search filters items listed in the Browser pane to display only those items that match the search criteria.

The Relink window provides specialized search capabilities for finding and relinking missing files. For more information, see “Linking and Relinking Files” on page 344.

**Searching for Either/Or or And Text Strings**

When typing in a search query in either simple or advanced search mode, use spaces for OR searches. For example, to search for file names that contain either guitar or bass, type guitar bass.

Similarly, use quotes around text strings separated by spaces for AND searches. For example, to search for file names that contain both bass and guitar, type “bass guitar”.

**Search Tools**

The top of every Workspace browser provides a set of search tools for finding files on your system quickly and easily.

**Number of Items**

The Number of items listed in the Browser pane is displayed to the left of the Browser Search field in the Workspace Toolbar. If a search returns more than 1,000 items you are notified that 1,000+ items are returned from the search. You can click this to show all items returned in the search.

**Browser Search Field**

Type the names of files, dates, durations, and so forth into the Browser Search field. As soon as you start typing, Pro Tools initiates the search for matches to the text you type. Results are displayed in the Browser pane.

**Simple Search Button**

Click the Search button to initiate a simple search before typing any text into the Browser Search field. The Simple Search button changes from a magnifying glass icon to an “X” and immediately initiates a search. Click the Search button again to end the search (or press the Esc key).

**Advanced Search Button**

Click the Advance Search button to open the Advanced search toolbar (see “Advanced Search” on page 327).

**Tags Button**

Click the Tags button to show the Tags pane. (see “Tags Pane” on page 333).
Simple Search

Pro Tools provides a simple text search with the Browser Search Field that lets you quickly search all volumes for items by file name as well as any other text field available in the Workspace browser (such as File Comment, Database Comment, Scene, Take, Plug-In Name, and so on).

💡 Initiating a search with no search criteria returns all items on the system.

To initiate a simple search:

1. In the Locations pane, select the Volume, Catalog, Session, or Folder that you want to search. If you do not make a selection, the entire system is searched (including shown offline volumes).

2. Do one of the following:
   - Click the Simple Search button.
   - Press Command+F (Mac) or Control+F (Windows).

3. Type in the Browser Search field.

4. Click in the Browser Search field and type text for the search.

Search results are displayed in the Browser pane.
Advanced Search

Pro Tools provides advanced tools for searching files and volumes by specific categories. You can refine your search by providing multiple constraints on the search parameters. You can also easily switch from an advanced search to a simple search.

To initiate an advanced search on a selected item in the Locations pane:

1. Do one of the following:
   • Click the Advanced Search button.
   • Press Command+Shift+F (Mac) or Control+Shift+F (Windows).
2. If it is disabled, enable the Search Checked option at the left of the Locations pane header by clicking it.
3. In the Locations pane, select the Volume, Catalog, Session, or Folder that you want to search.

Advanced search results for the selected Volume
4 Select the Column name.

5 Select the Search Criteria.

6 Click in the Search Text field and type text for the search.

7 Press Return (Mac) or Enter (Windows).

The search results are displayed in the Browser pane.

If you want to refine your search, click the Add Row button to add further constraints to the search. Repeat steps 4–6 for each row you add.
To initiate an advanced search on checked items in the Locations pane:

1. Do one of the following:
   - Click the Advanced Search button.
   - Press Command+Shift+F (Mac) or Control+Shift+F (Windows).

2. If it is disabled, enable the Search Checked option at the left of the Locations pane header by clicking it.

3. In the Locations pane, check each of the Volumes, Catalogs, Sessions, or Folders that you want to search.

4. Select the Column type.

5. Select the Search Criteria.

6. **Command-click (Mac) or Control-click (Windows) to select multiple criteria for an either/or search.**

7. Click in the Search Text field and type text for the search. (Use spaces between text strings for either/or searches and use quotes around text strings with spaces for and searches.)

8. Press Return (Mac) or Enter (Windows).
The search results are displayed in the Workspace pane.

If you want to refine your search, click the Add Row button to add further constraints to the search. Repeat steps 4-6 for each row you add.

**To switch from an advanced search to a simple search, do one of the following:**

- Click the Advanced Search button so that it is unhighlighted.
- Press Command+Shift+F (Mac) or Control+Shift+F (Windows).

**To switch from an simple search to an advanced search, do one of the following:**

- Click the Advanced Search button so that it is highlighted.
- Press Command+F (Mac) or Control+F (Windows).

**To cancel the search entirely:**

- Click the Simple Search button ("X").

**Advanced Search Features**

Once you have initiated an advanced search, the Workspace browser displays additional advanced search features.

**Column Search Selector**

You can search text by all columns or only be specific columns in the browser.

**Search Criteria Selector**

You can search for items in the selected column according to the following search criteria:

- **Contains** Select this option to search for items that include the text you type into the Search Text field.
- **Does Not Contain** Select this option to exclude items from the search that contain the text you type into the Search Text field.
- **Starts With** Select this option to search for items that start with the text that you type into the Search Text field.
- **Contains Exactly** Select this option to search for items that are an exact match to the text you type into the Search Text field.

**Search Text Field**

Use the Search Text field to search the selected column type according to the selected column type and search criteria.

**Add/Remove Row Buttons**

Pro Tools lets you refine your search by up to 8 rows of search criteria.

**Add Row Button** Click the Add button ("+") to add another row to refine the advanced search.

- Press Shift + "+" (plus) or to add a new row.

- Command-Option-click (Mac) or Control-Alt-click (Windows) a column header to add it as search criteria.
Remove Row Button Click the Remove button (“–”) for a row to remove that row.

Press Shift + “–” (minus) to remove the bottom row.

Saving Search Results as a Catalog

To save the results of your search as a Catalog:

1 Choose Edit > Select All, or press Command+A (Mac) or Control+A (Windows), to select all items in the Items List.

2 Right-click any selected item and choose Create Catalog.

For more information, see “Catalogs” on page 351.

Soundbase and Tags

Use Soundbase in Workspace browsers to find audio files using tags (WAV and AIFF only). Tags are descriptive metadata saved to and read from the header of audio file. You can create, add, and edit tags for any WAV or AIFF file accessible through the Workspace. Use the Sound Libraries folder in the Locations pane to store and organize the audio files in your sound library collection.

Tags are written to and read from the file header.

Opening a Workspace Browser with Soundbase

By default, Workspace browsers open without the Tags pane shown (see “Tags Pane” on page 333). However, you can open a new Workspace browser with the Tags pane shown for ready access to Soundbase. The Workspace browser also opens with columns relevant to Soundbase shown (such as Key, Time Signature, and Tags).

To open a Workspace browser with Soundbase, do one of the following:

- Choose Window > New Workspace > Soundbase.
- Press Option+Control+I (Mac) or Alt+Start+I (Windows).

Sound Libraries

At the top of the list in the Location pane of any Workspace browser is the Sound Libraries folder. It is an essential part of Soundbase that provides a special location for easy access to tagged audio files. In addition to descriptive metadata tagging, you can include musically useful information about the audio content through column data, especially Time Base, Duration (Min:Sec or Bars|Beats), Tempo, Key, Time Signature, Favorites, Rating, and Tags.

To show (or hide) Sound Libraries in Workspace Locations:

1 Choose Setup > Preferences.

2 Click the Operations tab.

3 Enable (or disable) the Show Sound Libraries in Workspace Locations option.

4 Click OK to close the Preferences dialog.
When you install Pro Tools, this folder is created in the following locations:

**Mac OS X** HD/Users/<username>/Documents/Pro Tools/Sound Libraries/

**Windows** C:Users/<username>\Documents\Pro Tools\Sound Libraries

You can install audio content for Sound Libraries available from Avid as well as third-party vendors. Of course, you can also add your own content by either actually copying it to the location Sound Libraries folder on your system or by adding alias to other locations on your system.

**To show (or hide) Sound Libraries in Workspace Locations:**
1. Choose Setup > Preferences.
2. Click the Operations tab.
3. Enable (or disable) the Show Sound Libraries in Workspace Locations option.
4. Click OK to close the Preferences dialog.

**Sound Libraries Location**

Pro Tools lets you change the location of the Sound Libraries folder in the Operation preferences. However, you will have to manually copy or move any media to the new location.

**To change the location of the Sound Libraries folder:**
1. Choose Setup > Preferences.
2. Click the Operations tab.
3. Click the Change button for Sound Libraries under User Media and Settings Location.
4. Navigate to the new location you want for the Sound Libraries folder and click Open.
5. Click OK to close the Preferences dialog.

**Adding and Removing Sound Library Locations**

You can add (or remove) different directories on your system whose contents are not actually copied or moved to the Sound Libraries folder. Added locations are essentially aliases that point to the original location of the designated folder and no media is copied or moved from the original location.

**To add a location to the Sound Library:**
1. In any Workspace browser, navigate to the location of the folder you want to add to the Sound Library.
2. Right-click the folder and choose Add Sound Library Location.

**Adding a folder to Sound Libraries**

An alias of that folder is added to Sound Libraries. Directories (and all folders and files in that folder) that are added as a Sound Library Location are colored blue, whereas files and folders actually located in the default (or assigned) Sound Libraries location are gray.

**Added folders that point to other locations are blue**
To remove a location from the Sound Library:
1 In the Locations pane of any Workspace browser, reveal the contents of Sound Libraries.
2 Right-click the folder you want to remove from the Sound Library and choose Remove Sound Library Location.

The folder is removed from Sound Libraries. However, the folder and all files within it remain at the original location. Only the alias is removed.

Tags Pane
You can show or hide the Tags pane in any Workspace browser. The Tags pane shows all tags for media in the selected folder in the Locations pane. Click any Tag in the Tags pane to show only media with that Tag in the browser.

Tip: Tags appear in the Tags Pane in order from most used to least used for any selected location in Sound Libraries folder. After adding a new Sound Library that has existing tags (such as the Avid Loopmasters Sample Pack) or after tagging a number of files, relaunch Pro Tools to ensure that these tags appear in the proper order.

To show (or hide) the Tags pane in a Workspace browser:
- Click the Tags pane icon at the top of the Workspace browser. It is highlighted only when the Tags pane is shown.

Press Command+Option+Control+T (Mac) or Control+Alt+Start+T (Windows) to show or hide the Tags pane.

Searching Based on Tags
Use tags in Soundbase to find all audio files in the selected Location that have the selected tags. Any WAV or AIFF audio file can be assigned multiple tags so you can refine your search criteria using as many descriptive tags as necessary. Be sure to be consistent in how you tag your audio files so that you can quickly and reliably call up the audio files you need, based on tags that accurately describe the audio, for whatever project you are working on.
To search audio files based on tags:

1. Show the Tags pane in any Workspace browser.
2. Navigate to the location you want to search in the Locations pane.
3. Click the desired tags in the Tags pane to limit the search to those criteria, or type in the name of Tags in the search field.
4. Click the “X” on the right side of any tag in the Tag Search field to clear it from the search criteria. The search results in the Browser list update automatically.
5. Audition and use the audio in the search results that best suits your needs.

Exclude Files from Search Results with Selected Tags

Not only can you find audio files by what tags they do have, you can also find files by what tags they do not have.

To exclude files from the search results that have the specified tag:

1. Show the Tags pane in any Workspace browser.
2. Navigate to the location you want to search in the Locations pane.
3. Option-click (Mac) or Alt-click (Windows) any tags in the Tags pane that you want to exclude from the search results. Those tags turn gray in the Search Tags field.

Option-click (Mac) or Alt-click (Windows) any gray tags in the Search Tags field again to include files with those tags in the search results. Those tags turn back to blue.

A single audio file found with two matching tags

Search results based on tags “R&B” included (blue) and Melodic excluded (gray)

The search results include only files with the blue tags and exclude those with the gray tags.
Adding and Editing Tags

Pro Tools lets you add and edit tags for audio files in Soundbase. If you want to search your existing sample libraries or custom audio files, you will need to add tags manually.

To add tags to an audio file:

1. Locate and select one or more audio files that you want to tag in any Workspace browser.

2. Right-click on a selected audio file in the Workspace browser and choose Tags.

3. Select the tags you want to add or type in a new tag. You can add as many tags to any audio file (WA V or AIFF only) as you like. If more than one audio file is selected, you are prompted to confirm that you want to add the tag to all selected files.

4. When done, press Enter.

When searching on tags, all audio files in the selected location with matching tags appear in the search results—the more tags you specify, the more selective your searches can be.

💡 You can also assign tags by clicking in the Tags column.

3. Select the tags you want to add or type in a new tag. You can add as many tags to any audio file (WA V or AIFF only) as you like. If more than one audio file is selected, you are prompted to confirm that you want to add the tag to all selected files.

4. When done, press Enter.

💡 Choose from the Recently Used Tags options in the Right-click menu to quickly add any of the last used tags to the selected audio files.
Assign Tags Popover Window

Access the Assign Tags popover window for one or more selected items either through the Right-click menu or from the Tags column. Here you can add, remove, and create new tags assigned to the selected audio files. You can also mark a file as a favorite and rate it from zero to five stars.

To enable (or disable) the Favorite marker for selected audio files in the Assign Tags popover window:
- Click the Heart icon so that it is highlighted (or unhighlighted).

To assign 0–5 stars for the rating of selected audio files in the Assign Tags popover window:
- Click the Star icons so that the number of stars you want for the rating are highlighted.

Press Control+0–5 (Mac) or Start+0–5 (Windows) to assign the number of stars for Rating.

To mark (or unmark) a file as a loop in the Tags pop-up window:
- In the Tags pop-up window, select (or deselect) the Loop icon in the lower-right corner of the pop-up window. The icon highlights when selected.

Press Control+O (Mac) or Start+O (Windows) to mark (or unmark) the selected file as a loop.
Favorites

Pro Tools lets you mark audio files as Favorites, so you can quickly filter the Items List to show only Favorites.

To mark an audio file as a favorite, do one of the following:
- Select the Heart icon in the Assign Tags popover window.
- Select the Heart icon in the Favorite column.

To filter for Favorites:
- Select the Heart icon in the Workspace Browser Toolbar.

Waveforms

The Waveform column displays waveforms for audio files. Waveform display depends on the following:
- Waveforms are displayed if they have already been calculated and stored, either with the file metadata or in the global Waveform cache.
- When a file is imported into a session, a waveform is automatically calculated for it.

Waveform displays in a Workspace browser

The waveform overview is stored in the file, or in the Pro Tools Databases folder on your system drive. For more information, see “WaveCache” on page 338.

To scale the vertical zoom on waveforms displayed in the Workspace browser, press Command+Option+[ or Command+Option+] (Mac), or Control+Alt+[ or Control+Alt+] (Windows).

Summed Waveforms for Multichannel Files

Waveform displays for stereo and multichannel files are summed.

Calculating Waveforms for Display

If an audio file item does not have a waveform, the waveform must be calculated to be visible in a Workspace browser Waveform display.
To calculate waveforms in a Workspace browser:

1. Select online audio files, or folders containing audio files, in a Workspace browser.

2. Right-click any selected item and choose Calculate Waveform.

WaveCache

A global WaveCache file stores waveforms that cannot be written back to the sound file, such as read-only files, files on network and other read-only volumes, and interleaved files.

On Mac, the WaveCache file is stored in /Users/Shared/Pro Tools.

On Windows, the WaveCache file is stored in <Systemdrive>/Users/Public/Pro Tools.

Elastic Audio Files in the Workspace

You can both calculate and clear Elastic Audio analysis for selected audio files in Workspace browsers. Only AIFF and WAV files are supported for Elastic Audio analysis and processing. Any other file format (such as MP3) must be converted to AIFF or WAV for Elastic Audio analysis and processing.

Even though the MP3 file formats are not directly supported by Elastic Audio, you can import them into a WAV- or AIFF-based session and then use the converted files on Elastic Audio-enabled tracks. File formats that do not match the session are converted automatically on import.

For more information, see Chapter 44, “Elastic Audio.”

To calculate Elastic Audio analysis:

1. In a Workspace browser, select the files you want to analyze.

2. Do one of the following:
   - Right-click one of the selected files and choose Calculate Elastic Analysis from the pop-up menu.
   - Preview the file with the Audio Files Conform to Session Tempo option enabled.

Analyzed files in which a regular tempo was detected are updated as tick-based, display their duration in Bars|Beats, and display their native tempo in the Tempo column.

Analyzed files in which no tempo was detected remain sample-based. These files typically contain only a single transient (such as a snare hit) or they are longer files without a readily identifiable regular tempo (such as entire songs).

On Mac, if you do not see the Elastic Audio Analysis icon or the duration does not change to tick-based during the preview process, check the permissions for the folder in the Mac Finder. You must have write access of the directory for this feature to work.

To clear Elastic Audio analysis:

1. In a Workspace browser, select the files with Elastic Audio analysis that you want to clear.

2. Right-click one of the selected files and choose Clear Elastic Analysis from the pop-up menu.

Files cleared of Elastic Audio analysis data revert to sample timebase, display their duration in minutes and seconds, and do not report a tempo.
File Timebase and Elastic Audio Analysis Icons

Workspace browsers provide two different icons for time-based or tick-based files. For time-based files, the time-based icon is color coded to indicate whether or not a file includes Elastic Audio analysis.

Sample-Based File Icon Indicates that the file is sample-based. The icon is color coded to display whether or not the file includes Elastic Audio analysis data. Sample-based WAV and AIF files without elastic audio analysis data display a gray clock icon. Sample-based WAV and AIF files with elastic audio analysis data display a blue clock icon. The file’s duration is displayed in minutes and seconds.

Tick-Based File Icon Indicates that the file is tick-based. The file’s duration is displayed in Bars|Beats and the file’s native tempo is displayed in the tempo column. MIDI, REX and ACID files are tick-based and contain their own tempo and Bar|Beat metadata. WAV and AIF files with elastic audio analysis that are tick-based also display a green metronome icon.

Previewing Audio in Workspace Browsers

Audio files can be previewed in Workspace browsers. Previewing follows the master Audition path as selected in the Output pane of the I/O Setup (see “Audition Path” on page 58). The base level for previewing is determined by the Master Fader (or Auxiliary Input) level assigned to the Audition path. You can also adjust the Preview Volume in the Workspace browser.

To preview an audio file in a Workspace browser:

1. Select an audio file in a browser Items List. Make sure the Workspace browser is the foreground (active) window.

2. Do one of the following:
   - Click the Waveform Preview button (the speaker icon to the left of the waveform display). Click again to stop auditioning.
   - If Spacebar Toggles File Preview is selected in the Browser menu, press the Spacebar. Press the Spacebar again to stop auditioning.
   - Press Command+P (Mac) or Control+P (Windows) to start and stop previewing.
   - Press the Esc key to stop previewing.

⚠️ If the Auto-Preview option is enabled, previewing starts as soon as the file is selected in a Workspace browser.
To audition from a specific location within the file:

- Click in the waveform display at the location.

**Interleaved Files**

When previewed in Workspace browsers, interleaved audio files with more than two channels are summed to mono for auditioning.

**Multi-Mono Files**

Multi-mono files must be previewed one file at a time.

**Split Stereo Files Preview Together**

When selecting one of a pair of Split Stereo files, such as “Drums.L” and “Drums.R,” both files preview together. To preview only the selected channel of a split stereo pair, press the Shift key and start preview.

⚠ Some Pro Tools operations can cause temporary interruptions in Workspace auditioning.

💡 MIDI files can be previewed from the session Clips List, but not from Workspace browsers. See “Previewing Clips in the Clips List” on page 295.

---

**Preview Controls and Indicators**

Every Workspace browser provides the following preview controls in the Toolbar: Preview, Volume, Meters, Audio Files Conform to Session Tempo, and Elastic Audio Plug-In.

**Preview Button**

The Preview button starts and stops preview of audio files selected in Workspace browsers. You can also Right-click the Preview button to change the Preview mode and set whether or not the Spacebar toggles file preview.

**Volume**

The Volume control in Workspace browsers lets you boost or attenuate the gain for previewing selected files.
To change the volume for previewing in Workspace browsers:

1. Click the Volume control (Fader icon) to display the Volume fader.
2. Adjust the Volume fader (from –INF to +12 dB).

When the Audio Files Conform to Session Tempo button is enabled, Pro Tools analyzes any un-analyzed files on preview or import. Tick-based audio files conform to the session tempo during preview and on import. Sample-based files, those where no tempo has been detected, always preview and import at their original speed and duration.

When the Audio Files Conform to Session Tempo button is disabled, any tick-based audio files with Elastic Audio analysis, and REX and ACID files preview at their native tempo.

For more information, see “Conforming Preview to the Session Tempo” on page 343

Elastic Audio Plug-In Selector


To the Elastic Audio plug-in for preview in context:

1. Right-click the Audio Files Conform to Session Tempo button.
2. Select the desired Elastic Audio plug-in.


For more information, see “Elastic Audio Plug-Ins” on page 975.
Preview Modes

Workspace browsers provide three Preview modes: Normal Preview, Loop Preview, and Auto-Preview.

Normal Preview

Normal Preview simply plays the selected audio file and stops at the end of the file. Deselect Loop Preview and Auto-Preview for Normal Preview mode.

Loop Preview

Loop Preview plays the selected file by looping playback of the file. If multiple files are selected, only the first selected file previews. When Loop Preview mode is enabled, the Preview button updates to show a Loop Preview Mode icon.

To loop preview a file in a Workspace browser:

1. Do one of the following:
   - In the Browser menu, select Loop Preview. The Browser Preview button updates to show the Loop Preview icon.
   - Right-click the Preview button and select Loop Preview.
2. Select an audio file in a Workspace browser’s Items List. Make sure the Workspace browser is the foreground (active) window.

To stop loop audition:

- Do one of the following:
  - Click the Browser Preview button again.
  - If Spacebar Toggles File Preview is selected in the Browser menu, press the Spacebar again.
  - Press Command+P (Mac) or Control+P (Windows).
  - Press the Esc key.

Auto-Preview

Auto-Preview plays the audio file as soon as it is selected. Additionally, the Preview button updates to show an Auto-Preview icon.

To automatically preview files when selected:

- Do one of the following:
  - From the Browser menu, select Auto-Preview. The Preview button updates to show that Auto-Preview is enabled.
  - Right-click the Preview button and select Auto-Preview.
Conforming Preview to the Session Tempo

Pro Tools lets you preview Elastic Audio analyzed files at the session tempo. The selected default Elastic Audio plug-in is used for previewing Elastic Audio analyzed audio files at the session tempo. Additionally, other tick-based files, such as REX and ACID files, can also be previewed at the session tempo and in time with playback.

To preview files at the session tempo:

1. In the session, place the insertion point at the location where you want to preview the file in Workspace.
2. In a Workspace browser, select the file you want to preview.
3. Do one of the following:
   • Click the Audio Files Conform to Session Tempo button. It highlights when enabled.
   • From the Browser menu, select Audio Files Conform to Session Tempo.
   • Right-click the file you want to preview and select Audio Files Conform to Session Tempo from the pop-up menu.
4. Click the Preview button in the Workspace browser and the file plays at the session tempo.

Preview in Context

Pro Tools lets you preview audio files in Workspace browsers while playing back a Pro Tools session. Tick-based audio files (those with tempo detected Elastic Audio analysis, as well as REX and ACID files) can play back in tempo, and at the corresponding bar and beat location, with session playback. Tick-based audio files audition at the session tempo when the Audio Files Conform to Session Tempo option is enabled.

💡 Deselect the Spacebar Toggles File Preview option in the Browser menu to start and stop session playback with the Spacebar without previewing in the Workspace browser. Use Command+P (Mac) or Control+P (Windows) to start and stop preview in the frontmost Workspace browser during session playback.

Reserve Voices for Preview in Context

(Pro Tools | Ultimate Software Only)

Preview in context (previewing audio files in Workspace during session playback) uses disk voices for playback. The number of voices required depends on the channel width of the selected Audition Paths on the Output page of the I/O Setup window. For example, if a stereo audition path selected in the I/O Setup requires 2 voices for preview in context, whereas a 5.1 audition path requires 6 voices. If one or more voices are not available for preview in context because they are in use by disk tracks (or routing for Native processing on HDX systems), the Preview button in Workspace browsers will be unavailable during session playback.
Pro Tools provides an option to reserve voices for preview in context. The number of reserved voices is determined by the channel width of the selected Audition Paths in the I/O Setup. Voices reserved for preview in context are unavailable for disk tracks.

To reserve for voices for preview in context:
1. Choose Setup > Preferences.
2. Select the Operation tab.
3. Enable the Reserve Voices For Preview In Context option.
4. Click OK to close the Preferences dialog.

Linking and Relinking Files

A Pro Tools session is made up of references, or links, to audio files and other session media. Audio and video files must be stored on suitable Performance volumes and be properly linked in order to be playable in the session.

The following types of files are not playable:

Transfer Files Files that are stored on volumes not suitable for playback, such as network volumes or CD-ROMs.

Missing Files Files that cannot be found where the session expects them, either because they have been moved, or because they are stored on volumes that are not currently mounted (offline volumes).

The process of reacquiring missing files is referred to as relinking. Relinking can involve certain sub-tasks, depending on the situation.

- Transfer files must first be copied to a suitable Performance volume. The session is then relinked to the copies on the Performance volumes instead of the original Transfer files.
- Volumes may be searched for missing files and, when the files are found, Pro Tools relinks the session to the file's new location.
- Files that reside on offline volumes must first have their volumes mounted (brought online) before they can be relinked.

Catalogs have unique linking characteristics. See “Relinking and Aliases in Catalogs” on page 350.

Choosing When to Relink

Pro Tools lets you relink files while opening a session or after a session is already open, as follows:

- Relinking when opening a session ensures that the session opens with all media playable. Automatic and manual relinking can be performed. See “Opening a Session with Missing Files” on page 346.
- Relinking later (after a session is already open) is the fastest way to open the session, but all missing items remain offline and unplayable. See “Relink Window” on page 347.

Forcing a Relink

If you cannot relink to the original file, you can force a relink to another file. See “Force Relinking Files” on page 350.
Transfer Files

Unlike missing files, Transfer files are files that have been found but which reside on volumes unsuitable for playback, such as CD-ROMs or network drives. These volumes appear as Transfer volumes in the Workspace browser.

Opening a Session with Transfer Files

If a session finds files on a volume unsuitable for playback, a dialog appears prompting you to copy them to a suitable volume.

To copy Transfer files found when opening a session, do one of the following:

- Click Yes to open the Copy and Relink dialog.
- Click No to open the session with all Transfer files offline. When opened, the session’s Workspace browser indicates Transfer files with a “T” in their Status column.

Transfer Files in an Open Session

To make Transfer files playable in the current session:

1. Select the current session in the Locations pane.
2. Double click the Audio Files folder to display all of the audio files.
3. Choose Select Transfer Files from the Browser menu.
4. Choose Copy and Relink from the Browser menu.
5. Specify a location for the copied files on a valid Performance volume and click OK.
6. Repeat for video files, as necessary.

Copy and Relink

The Copy and Relink command is a file management option for session and catalogs in the Workspace browser.

Copy and Relink provides a convenient way to copy files and relink the session or Catalog to the copies rather than to the originals.

To copy items to a new location and Relink to the copies:

1. Do one of the following:
   - Choose Window > New Workspace and select the current session in the Locations pane.
   - Open a Catalog.
2. Select the items you want to copy and relink. You can select any media files (online, offline, and Transfer files).
3. Choose Copy and Relink Selected from the Browser menu.
4. If the default location for the copies (the session’s Audio Files folder) is not appropriate, specify a different location and click Choose.
5. The files are copied to the chosen destination and the session or Catalog is relinked in the background.

Missing Files

Files are missing if they are not found in the same location as when the session was last saved. This could be because you moved the files or the session folder, or because the files are on a volume that is not currently mounted.
Opening a Session with Missing Files

To open a session with missing files:

1. When you open a session, Pro Tools opens the session with all available media, then shows you how many files are missing (if any) and asks how you want to proceed. (If told that files are unsuitable for playback, see “Transfer Files” on page 345.)

2. Select one of the following:
   - **Skip All**—or press Command+S (Mac) or Control+S (Windows).
   - **Manually Find Relink**—or press Command+M (Mac) or Control+M (Windows).
   - **Automatically Find Relink**—or press Command+A (Mac) or Control+A (Windows).

3. Select **Regenerate Missing Rendered Files Without Searching** to exclude rendered Elastic Audio files from the relink process and regenerate them instead.

4. Click **OK**.

**Skip All** Skips all missing files. This option is the fastest way to open the session utilizing all available media. Missing files are offline in the session, and shown in the Clips List and the Workspace browser with *italic* text.

**Manually Find and Relink** Opens the Relink window. Use the Relink window to search, compare, verify, and relink missing files. Files can be relinked one at a time or in batches. See “Relink Window” on page 347 for more information.

**Automatically Find and Relink** Is the simplest method to relink sessions to required media, but it provides no way to compare files or verify links. This option cannot be undone. The Automatically Find and Relink option does the following:
   - Searches all Performance volumes for all missing items with matching Name, ID, Format, and Length
   - Links missing items to the first matches found
   - Commits links for all items possible

⚠️ **Links, once committed, cannot be undone once the session is saved. The only way to revert to previous links is to close the session without saving changes.**

If some files remain unlinked, the Task window opens and a failed task appears in the Paused Tasks pane. Double-click the Task icon to open the Relink window and manually find and relink files.

⚠️ **Even if all of the missing files are later found and relinked, the failed task remains in the Task Window. Like all failed tasks, it must be manually selected and deleted. See “About Failed Tasks” on page 356.**

**Regenerate Missing Rendered Files Without Searching**

Enable this option to exclude rendered Elastic Audio files from the relinking process (rendered files are recalculated instead). This option is available when Automatically Find and Relink or Manually Find and Relink is enabled.
Relink Window

The Relink window provides tools for all relinking tasks.

Menu and Toolbar Includes the Relink menu, View Presets, and relinking buttons. Status is displayed at the far right.

Areas to Search Selects volumes on which to search for missing items.

Files to Relink Lists missing files.

Candidates Lists files that match the “relinking criteria” for a particular missing file. The Link icon next to the candidate can be toggled on or off to link (or unlink) the proposed candidate to the selected missing file.

The Relink window controls each phase of the relinking process.

Opening the Relink Window

When opening a session with missing files, use the Manually Find and Relink option to open the Relink window. The Relink window can also be accessed after a session is open.

To access the Relink window from an open session:

1. In the Workspace browser, select the item you want to relink.

2. Choose Relink Offline from the Browser menu.

**Tip**: The Session Data Online Status indicator in the Edit window (under the Edit Selection indicators) is green when all audio files referenced by the session are available for playback. However, if files are offline, being processed, or otherwise unavailable for playback, this indicator is red. If any files are offline, click the indicator to open the Relink window and relink to offline files.
Selecting Areas to Search

Selecting volumes and folders in the Areas to Search pane lets you focus the search for missing files. This can speed the relinking process by limiting the number of volumes or folders to search. In addition, excluding folders from a search for missing files also lets you redirect a session or Catalog to a more appropriate copy of an item.

To select volumes or folders to include or exclude in a search:

1. Configure the Areas to Search pane to display the appropriate volume, Catalog, or folder.
2. Click each item’s Search column to toggle it to be included or excluded in the search. A check next to an item indicates it will be included in the search. All folders within items are also checked.

Single and Multi-File Relinking

The Relink window can be used to relink one missing file at a time, or to relink missing files in batches.

Relinking Individual Missing Files

In some situations, individual files must be relinked one at a time in order to relink the session to the correct file. This is necessary if multiple copies of a media file are online, or whenever you want the most control and flexibility over the relinking process.

To relink a missing file:

1. Configure the Areas to Search pane.
2. Select one item in the Files to Relink list.
3. Click Find All Candidates.
Pro Tools searches the selected volumes and displays all files that match File Name, SMPTE ID, or Unique ID in the Candidates list. Link icons indicate if a Candidate is already linked.

⚠️ **OMF video clips can only be relinked to a session if they have matching Unique IDs.**

⚠️ **QuickTime video clips can only be relinked to a session by file name and file format (QuickTime).**

💡 **To control matching and linking criteria when relinking an individual missing file, use the Find Links button. Find Links is explained in “Relinking Multiple Missing Files” on page 349.**

4 Click the Link icon next to the appropriate Candidate to which you want to relink. A Link icon next to an item indicates it will be relinked to the item currently selected in the Files to Relink list.

5 Click the Link icon next to other Candidates, if you want to relink to additional missing files.

6 Click the Commit Links button.

**Relinking Multiple Missing Files**

Using the Find Links button, multiple files can be matched and linked in one procedure.

**To relink multiple missing files:**

1 Configure Areas to Search. (See “Selecting Areas to Search” on page 348.)

2 Select one or more items in the Files to Relink list. The Find Links button becomes available.

3 Click Find Links.

4 Configure criteria for relinking, if necessary, in the Linking Options dialog:
   - By default, Find by Name and ID is enabled.
   - To add additional matching criteria, select an option from the Linking Options dialog. (Modification Date is only applicable to Catalogs.)
   - If Match Duration is enabled, Pro Tools only selects files of the same length or greater.

5 Click OK to continue (or click Cancel to return to the Relink window).

Pro Tools searches for an acceptable candidate for the first missing file (the first item selected in the Files to Relink list). A link icon appears next to each file as Pro Tools finds and links the first acceptable candidate to the missing file. The Link
Path column shows the location of the selected candidate. Pro Tools continues searching, matching, and linking for each missing file in the Files to Relink list.

6 To view a candidate for a missing file, select to highlight the missing file. That file’s candidate appears in the Candidates pane, where you can view its information and waveform.

7 If you are not satisfied with the candidate for a particular missing file, you can click Find All Candidates for the selected file (see “Relinking Individual Missing Files” on page 348).

**Force Relinking Files**

If you want to link to a substitute file (for example, if you know a file has the same audio or video but does not have a matching File Name, SMPTE ID, or Unique ID), you can force a relink.

- To force relink an audio file, its file format (WAV, AIFF, or MXF), sample rate and bit depth must match those of the original file.

- To force relink a video file, its format (QuickTime, Avid, MXF, or OMF) and frame rate must match those of the original file.

**To force a relink:**

1 Select the items you want to relink.

2 Choose Relink Offline from the Browser menu.

3 In the Relink window, select one item in the Files to Relink list.

4 Navigate in the Areas to Search pane to locate the file you want to relink.

5 Drag the file to the Candidates pane in the Relink window.

6 Click the Link icon next to the file you dragged to the Candidates pane.

7 Click the Commit Links button.

**Committing Links**

There is no Undo for relinking. Once a file has been relinked and the session saved, the session always remembers the new link (the original link is forgotten). For this reason, no files are actually relinked until you click Commit Links.

⚠️ The Automatically Find and Relink option is the only relinking process that does not ask you to verify links before they are committed. If you use this option and are unsatisfied with the results, close the session without saving to prevent the new links from being committed.

**To commit links:**

1 Use the Relink window to link files as explained in “Single and Multi-File Relinking” on page 348.

2 Click Commit. You are asked to verify committing links.

3 Do one of the following:
   - Click Yes to commit links.
   - Click No to stop without affecting files.

**Relinking and Aliases in Catalogs**

Catalogs are collections of “aliases” or “shortcuts” to actual files. If the files are moved, an item in a Catalog can become unlinked from the file it references.

**To relink a Catalog:**

1 Open the Catalog.

2 Select items to relink.

3 Choose Relink Selected from the Browser menu in that Catalog window.
Catalogs

Catalogs are similar to having a Favorites folder, and serve as a way to collect and organize frequently used items regardless of where they are stored. A Catalog is analogous to a folder full of aliases or shortcuts. Placing a file in a Catalog does not create a copy of the file, and does not change where the file is stored. Rather, it stores a reference (or alias) to the file so that it can be found and manipulated without having to search for its physical location.

Creating Catalogs

Catalogs can be added to the Workspace as new, empty Catalogs, or you can select items first and then save a Catalog of all selected items.

**To create a new, empty Catalog:**
1. Open a Workspace browser.
2. Choose New Catalog from the Browser menu.
3. Type a unique name and click OK.

**To catalog a selection of items:**
1. Open a Workspace browser.
2. Select the items you want to include in the new Catalog.
3. Choose Create Catalog from Selection from the Browser menu.

A new, fully indexed Catalog database of the selected items is created.

Creating Catalogs of Folders

**To create a Catalog of an entire folder and all its contents:**
1. Open the Workspace browser, if not already open.
2. Drag and drop a single folder onto the Catalog icon in the Workspace browser.

Pro Tools first indexes the folder, then a fully indexed Catalog is created, with the same name as the dropped folder.

Renaming a Catalog

Catalogs can be renamed at any time.

**To rename a Catalog:**
1. Click the Catalog item in the Workspace browser until its name highlights.
2. Type a new name for the Catalog.

Modifying Catalogs

**To add items to a Catalog, do one of the following:**
- Open the Catalog and drop new items from another Workspace browser.
- Click the main Catalogs icon in the Workspace, to expand your view of all existing Catalogs, then drop items onto any Catalog.

**To add a folder to a Catalog:**
1. Open the Catalog.
2. Choose New Folder from the Browser menu.
Removing Catalog Items

When you remove a folder or file from a Catalog, Pro Tools lets you choose whether to delete only the alias from the Catalog, or also delete the original files from disk.

To delete an item from a Catalog.

1 Select a catalog in the Locations pane.
2 In the Browser pane, select one or more items in the catalog that you want to remove.
3 Choose Remove Selected Items from the Browser menu.
4 When prompted, do one of the following:
   • To remove the aliases for the selected items from the Catalog, click Remove.
   • To delete the selected items from disk (and remove their aliases from the Catalog), click Move To Trash (Mac) or Move To Recycle Bin (Windows).

Consolidating Files with Catalogs

Catalogs are excellent tools for consolidating files from a variety of sources.

For example, create a Catalog named “Thumps” and fill it with sound effects from three different volumes. You can then drag the Catalog from the Workspace browser to another volume, and a folder named “Thumps” is created on that volume. All of the files referenced by the Catalog are automatically copied to the volume. Folders and sub-folders, if any, and their contents are included in the copy.

Updating Catalogs

Since a Catalog database is not linked to any particular volume, there is a limit to the abilities of the Update Index command. When Update Index for Selected Items is selected from the Browser menu in a Catalog, Pro Tools searches for the items represented by the aliases in the Catalog and updates the following information:

Metadata Metadata for all files found online, including File comments, are updated.

Database Comments Database Comments are not updated, because they are unique to each Catalog and are not part of the file’s metadata.

Relinking Catalog Items

If files are ever missing from a Catalog, use the Relink window to locate, copy, and relink files. For more information, see “Linking and Relinking Files” on page 344.

Removing Catalogs

To delete a Catalog:

1 Select a catalog in the Locations pane.
2 Select the catalog in the Browser pane.
3 Choose Remove Selected Items from the Browser menu. A warning dialog appears.
4 In the warning dialog, do one of the following:
   • Click Cancel to cancel the delete operation.
   • Click Move To Trash (Mac) or Move To Recycle Bin (Windows) to remove aliases and associated files from disk.
   • Click Remove to remove only the aliases from the catalog (and not the associated files on disk).

This operation cannot be undone.
**Importing Catalog Items**

You can import online and offline items from Catalogs into the current session.

**Importing Online Items from a Catalog**

Dragging and dropping audio files to the Pro Tools Clips List and Timeline is identical to dragging and dropping from Workspace browsers.

For more information, see “Importing Files with Drag and Drop” on page 400.

**Importing Offline Items from a Catalog**

With Catalogs, it is possible to search and import files that are offline. For example, if you have a music cue that you know you want to use, but it resides on a CD-ROM or other unmounted volume, you can spot the file from a Catalog to the session Timeline, and it is automatically imported into the session when the volume is mounted.

The first step is to add files to a Catalog (files must be online to be added to a Catalog). Once added to a Catalog, if the items are taken offline they are listed in italicized text.

Offline files can be dropped from a Catalog to the Timeline just like online files. When you drop the files, a dialog appears asking if you want to relink the files or skip relinking. Click Skip All to load all the items as offline files (in the Timeline, their clips appear in light blue).

Whenever the volume containing the offline items is mounted, Pro Tools automatically starts to import the files, in the background. This is true even if you have saved the session, quit, and relaunched Pro Tools.

Once the items are completely imported, they appear as online items in the Timeline, Clips List, and in the Workspace browser.

If the offline items match the session sample rate, bit depth, and file format, no conversion is necessary. As long as the volume is playable, the items become playable in the session as soon as the volume is mounted.

If the volume is unsuitable for playback, you are informed that some items must be copied to suitable volumes first.

For more information on Transfer files, missing files, and relinking, see “Relink Window” on page 347.
Task Manager Window

For maximum performance and flexibility with file management tasks, Pro Tools provides the Task Manager window. File management with Pro Tools involves nearly constant creating, copying, converting, processing, searching, and indexing files. These tasks occur in the background, letting you continue recording, editing, and mixing without delay.

The Task window lets you monitor, pause and cancel ongoing tasks including file copying, fade regeneration, and indexing. You can also use the Task Manager to monitor upload and download progress with projects.

Opening the Task Window

To open the Task Window, do one of the following:
- In Pro Tools, choose Window > Task Manager.
- Press Option+’ (Mac) or Alt+’ (Windows) to open the Workspace browser.
- Click the Task Manager Status indicator in the Edit Window toolbar.

Task Manager Status

The Task Manager Status indicator lights and animates when the Task Manager is busy. When no tasks are in progress, it is unlit. The indicator turns red if the Task Manager requires your attention.
Task Window Messages

If any background task cannot be successfully completed, the Task window comes to the foreground to notify you. The incomplete task is shown in the Paused Tasks pane of the Task window.

Because the Task window is a floating window, it does not interrupt current work. This allows you to continue recording and editing, and postpone file management until a more convenient time.

Task Window Views

The Task window provides a maximized and minimized view.

**To toggle between maximized and minimized views:**
- Click the View Toggle icon in the top of the Task window.

Task window, minimum view

Task Window Tools, Columns, and Displays

The Task window menu provides commands for Task window operations.

The following data is always displayed in the Task window (both views):

**Item Name** Indicates affected item, whether a file, database, or other supported item.

**Status** Action being taken (for example, copying, processing, indexing and so on).

**Progress** Indicates the progress of the task or its sub-tasks, which include assessing the size of the items and the estimated amount of time necessary to complete the task.

**Progress Indicator** Indicates processing is ongoing.

**Quantification** Shows percentage of progress of the current task.

Active Tasks Pane

The upper Active Tasks pane shows the tasks that are in progress or waiting to start. The currently executing task is at the top. Tasks in this pane will be processed.

As tasks complete, they disappear from the queue.

Any task that fails to complete successfully is moved to the Paused Tasks pane (see below). The Status column displays a description of the failure.

Paused Tasks Pane

The Paused Tasks pane is displayed below the Active Tasks pane, and is separated by a movable horizontal divider. Tasks listed in this pane will not be processed until they are moved back to the Active Tasks pane.

Pausing and Canceling Tasks

The Task window lets you pause, resume, and cancel tasks.

**To pause a task:**
- Drag the appropriate task from the Active Tasks pane to the Paused Tasks pane.

**To pause all tasks:**
- Choose Pause All from the Task window menu.
To resume a task:
- Drag a task from the Paused Tasks pane to the Active Tasks pane. The task returns to its previous position in the queue.

To resume all paused tasks:
- Select Resume All from the Task window menu. All tasks in the Paused Tasks pane (except failed tasks) are moved to the Active Tasks pane.

To cancel a task:
1. Highlight any task in either pane of the Task window.
2. Press Delete to remove it from the Task window.

To cancel all tasks:
1. Select any single task in either pane.
2. Press Command+A (Mac) Control+A (Windows) to select all the tasks in that pane.
3. Press Delete.

This command cannot be undone.

About Canceling Tasks
Some tasks involve one or more sub-tasks. Deleting a task cannot undo sub-tasks already completed. For example, if importing and converting multiple files appears as a single task, deleting that task before it is completed stops the import and conversion process, but files already converted and imported remain on disk. If you want to cancel a task involving multiple sub-tasks, you can instead let the process complete and then use Undo to completely undo all sub-tasks, as available.

Closing Sessions with Pending Tasks
If you close a session or quit Pro Tools while tasks are still pending (either in the Active or Paused Tasks panes of the Task window) Pro Tools asks if you want to cancel, or complete the pending tasks. You can choose to open the Task window and wait for pending tasks to complete, cancel the pending tasks, or quit. If you quit, some tasks are canceled. Tasks that involve file copies are remembered and restarted when you relaunch Pro Tools.

About Failed Tasks
The Paused Tasks pane shows any tasks that could not be completed. The reason for the failure is shown in the Status column.

Failed Tasks cannot be resumed, and must be deleted manually from the Paused Tasks pane.

If Automatically Find and Relink was unable to find all files in a session, a failed task is placed in the Paused Tasks pane of the Task window. It remains there unless you manually remove it from the Task window (even if you have since found the files through a subsequent search and relink task).

Task Prioritization
A task that is in progress may be interrupted by a task of higher priority. When this happens, the partially completed task is halted and rescheduled later in the queue, and shown with a progress bar in the Active Tasks pane. When the higher priority task is finished the first incomplete task in the queue resumes.
Pausing Tasks During Playback

A global preference Pause During Playback is provided in the Task window Browser menu. When enabled, Active Tasks are paused whenever Pro Tools is playing (or recording). This setting is especially useful when working on slower CPUs, or whenever you want to minimize system load for maximum playback and recording performance. This preference maintains its setting until the next time it is changed.

Stored Tasks

Any task that imports files into a session is stored with a session when it is closed, and resumes when the session is re-opened. For example, if you Import Session Data with Copy From Source Media selected, then Save and Close the session before the copy completes, the copy tasks resume when the session is reopened.

Grouped Tasks

Some tasks consist of many smaller tasks. For instance, Copy and Relink may require hundreds of individual files to be copied. To help manage these tasks, they are grouped under the originating command. So in the example of a Copy and Relink command, one copy task would appear with an Expand/Collapse icon in the Task window. Clicking the icon shows each of the individual sub-tasks.

If there is more than one grouped task in the queue, all of the sub-tasks for the first group must be completed before the sub-tasks of the second group can be processed.

If the session is saved and closed while several of these group tasks are in the queue, and if those tasks are the type that can be interrupted and saved when closing the session, all of the tasks reappear as part of the same group when the session is reopened.
Chapter 18: Artist Chat Window

Use the Artist Chat window to find and invite other Pro Tools users to collaborate on projects. Use text chat to communicate during the collaboration process. The Artist Chat window is a floating window.

To open (or close) the Artist Chat window:

1. Launch Pro Tools.
2. Log in to your Avid Master Account, either through the Dashboard window or by selecting File > Sign In. You must be signed in to access the Artist Chat window.
3. Do one of the following:
   • Choose Window > Artist Chat.
   • Press Command+Shift+= (equals) (Mac) or Control+Shift+= (equals) (Windows).
Profile Setup

The first time you open the Artist Chat window, you are prompted to set up your Profile. The information in your profile will help other Pro Tools users find you in the Avid directory.

To edit your Artist Profile:
1. Click the avatar icon in the upper-right corner of the Artist Chat window and choose Profile.

2. Update the information for your Artist Profile in the Profile Setup.

3. Click Save.

Artist Profile Setup

You must enter at least your Display Name (this is what other users will see), all other fields are optional, but they will help other users find you in the Avid directory. This is also the name you will see in the Dashboard after you sign in to your Avid Master Account, for your Avatar in the Artist Chat window, in collaboration transaction logs for any actions you took, and in the Track Ownership control when you have ownership of a track in a shared project.

You can always edit your Profile and change your Display Name at a later time if you want.
Contacts view in the Artist Chat window lets you add and delete contacts, as well as initiate text chat with any of your contacts. You can find new contacts through the Avid directory or email people you want to work with directly.

Add Contacts

To add a contact:

1. Click Contacts in the left column of the Artist Chat window.
2. Click the Add Contacts tab.
3. Type at least the first three letters of the user’s Display Name or their complete e-mail address in the search field and press Return (Mac) or Enter (Windows).
4. If the user you are looking for has set up their Artist Profile, they should be found in the Avid directory.
5. Click the + (plus) button to the right of their Display Name.
6. Type a message to the person you want to add to your contacts and click Send.
7. Once you have sent the contact request, that user will have the opportunity to deny or approve your request.

To add a contact not listed in the Avid directory:

1. Click Contacts in the left column of the Artist Chat window.
2. Click the Add Contacts tab.
3. If the person you are looking for is not found in the Avid directory, type the complete email address for their Avid Master Account.
4. Click the Send Invite link.

The person will receive an email invite to be added to your contacts.
My Contacts

Once you have added other users to your contacts, you can chat with them and invite them to collaborate on your projects, just as they can invite you to join their projects. You can also delete contacts.

To view your contacts:
1 Click Contacts in the left column of the Artist Chat window.
2 The My Contacts tab should be shown, but if not, click it.
3 You can double-click one of your contacts to start a text chat with them.

To delete a contact:
1 Click Contacts in the left column of the Artist Chat window.
2 The My Contacts tab should be shown, but if not, click it.
3 Click Edit in the upper-right corner of the My Contacts pane. It will turn blue.
4 Move the mouse cursor over the far right of the contact you want to delete. A “−” (minus) symbol appears.
5 Click the “−” (minus) symbol.

Notifications

When you receive and invitation to collaborate on a project, you are informed by Notifications. You can choose to accept or reject the request to collaborate.

Accepting or rejecting an invitation to collaborate on a project:
1 When you receive a notification, a number appears to the right of Notifications in the left column of the Artist Chat window.
2 Click Notifications in the left column of the Artist Chat window to review your notifications.
3 Review the notification and then decide to accept or reject the request.
4 Click the “check mark” button to accept the request or click the “x” button to reject the request.

5 Once you have accepted the request, you can open and download the project (either by double-clicking the project icon in the Artist Chat Project list or from the Dashboard), and begin collaborating.

💡 You can also accept or reject invitations to collaborate on a project in the Dashboard (see “Project Collaboration Invitations in the Dashboard” on page 183).

## History

Artist Chat History provides a comprehensive list of all contact requests and collaboration invitations, as well as archived items from the Project list and the Chat list (see “Move to or Restore from Artist Chat History” on page 373).

Each item lists the contact name, whether it is a contact request or collaboration invitation (including project name), and date. The list is always sorted by date (most recent first).

To view Artist Chat History:
- Click History in the left column of the Artist Chat window.

## Projects

The Projects list shows all of the online projects that you are currently own or collaborating on. Offline projects are only shown in the Projects list in the Dashboard. In the Projects pane, you can show or hide the collaboration transaction log, review the collaboration transaction logs for the selected project, invite contacts to collaborate on the project, and chat with users who are collaborating on the project. You can also “pin” projects to the top of the list or leave a project (if you are not the project owner).

Only the owner of the project can invite or remove collaborators from the project. Though all collaborators can message each other independently or as a group.

To view Projects in the Artist Chat window:

1 Click the Projects list in the left column of the Artist chat window. If the Projects list was collapsed, it is revealed to show all projects that you own or are collaborating on. You can reveal or collapse the Projects list by click the reveal/collapse triangle to the left of Projects.

2 Select the project you want.

3 The chat for the selected project appears and shows who is working on the project, the collaboration transaction logs, and lets you invite collaborators to the project from your contacts.
**Project Chat Controls**

The chat for projects provides controls for managing who can participate in the project, messaging between project participants, and whether or not to show the project collaboration transaction logs.

**Collaboration Transaction Logs**

The collaboration transaction logs show all actions taken by the owner and all contributors on the project. These are useful for tracking all changes to the project. However, if you find that they clutter the chat for the project, you can hide them.

**To show or hide the collaboration transcript logs for the project:**

1. To show the collaboration transaction logs for the project, click the Show/Hide Collaboration Transaction Logs icon so that it turns blue.

2. To hide the collaboration transaction logs for the project, click the Show/Hide Collaboration Transaction Logs icon so that it turns gray.

**Invite Contacts to Collaborate**

*(Project Owner Only)*

To invite a contact to collaborate on the selected project:

1. Click the Invite Contacts to Collaborate icon.

2. Search your contacts or select one or more contacts from the list.

3. Click Add.

The selected contacts are notified that you invited them to collaborate on your project. They can choose to accept or reject your invitation.
Revoke an Invitation to Collaborate
(Project Owner Only)

Use the Participant menu to revoke the invitation to collaborate from an individual who has not yet accepted the invitation. Only the owner of the project can revoke an invitation.

Chat with All Project Participants

Use the Chat field to enter text chat to communicate with all participants on the project. For more information about chat, see “Chat” on page 366. You can also add emoticons and music notation symbols to your chat (for more information, see “Emoticon and Notations Panel” on page 371).

Show or Hide Project Participants

Under the Shared Project icon, there is a Show/Hide Participants icon. You can hide the Participants List (collaborators and the owner) on the project to have more a little more room to view the project chat. Show the participants if you want to message (all participants) or remove any one of them (project owner only).

Message a Participant on the Project

Use the Participant menu to message an individual participant on the project without messaging all participants.

Remove a Participant from the Project
(Project Owner Only)

Use the Participant menu to remove an individual participant from the project. Only the owner of the project can remove participants.
**Project Notifications**

When any participant makes any changes to the project, the number of changes appears to the right of the project in the Projects list. To see what has changed, review the collaboration transaction logs for the project.

---

**Opening a Project from Artist Chat**

You can open any project listed in the Projects List from the Artist Chat window.

**To open a project:**

- Double-click the Project icon in the Project List.

---

**Chat**

The Chat section of the Artist Chat window keeps track of all of your individual and group chats that are independent of project chats. You can collapse and reveal the Chat list in the left column of the Artist Chat window just like you can with the Projects list. Also, when you are not viewing a specific chat thread, a number shows up to the right of the chat thread name in the list if you have received any messages or actions have taken place with the chat thread while you were not viewing it. As soon as you select that chat thread in the list, the number will disappear as you will be able to review all messages and transactions in the chat section.

---

**Chat view (group chat shown)**

**To view the Chat list in the Artist Chat window:**

1. Click the Chat list in the left column of the Artist chat window. If the Chat list was collapsed, it is revealed to show all chat threads that you are participating in. You can reveal or collapse the Chat list by clicking the reveal/collapse triangle to the left of Chat.

2. Select the Chat thread you want to view.
3 The selected Chat thread appears and shows who is in the chat, collaboration transaction logs, and lets you add or remove chat participants.

You can show or hide the chat collaboration transactions log just like you can with projects. You can also invite people from your contacts list to join a chat just like you can with projects. For more information, see “Project Chat Controls” on page 364.

Start a New Chat

You can start a new Chat thread by click the “+” (plus) button to the right of the Chat list or by double-clicking one of your contacts in the My Contacts list.

• Click the “+” (plus) button to start a new chat and select from your contacts to start a new chat. If a chat thread has already been started with a contact, you will not be able to select that contact in the New Chat list.

Individual Chat

To chat with an individual contact:

1 Do one of the following:
   • Double-click the contact with whom you want to chat in the My Contacts list. If a chat thread is already in progress with that contact, that chat thread is shown.

2 Click Start to initiate a new chat with the selected contact.

3 Type your message in the text chat field and press Return (Mac) or Enter (Windows) to send the message.

4 If you want you can even add emoticons and notation symbols to your message (for more information, see “Emoticon and Notations Panel” on page 371).
Group Chat

You can add other contacts to create a group chat. You can also specify a topic for group chat rooms so you can stay focused on the essentials for that chat.

Group chats provide several additional options that are not available with individual chats:

- Rename group chat
- Set a topic for a group chat
- Individually message a participant in a group chat.
- Add a participant to join your contacts if they are not already one of your contacts.

To start a group chat:

1. Either add more contacts to an existing chat thread or start a new one. Any participant on a group chat thread can add any of their contacts to the group chat.
2. Click the Invite Contacts to Chat icon in the upper-right corner of the Chat.

3. Type a message to the contact you want to add and click the Add button.

Your contact is notified and added to the group chat pending their acceptance of your invitation.

Renaming a Group Chat Thread

When a group chat is started, it initially uses the names of the members of the chat as the name for the chat. You can add a specific name to the group chat to help identify it in the Chat list. You can only change the name for a group chat.

To rename a group chat:

1. Do one of the following:
   - Double click the title of the group chat at the top of the chat pane.
   - Right-click the group chat in the Chat list and choose Rename.

2. Type the name for the group chat and press Return (Mac) or Enter (Windows).

Setting a Topic for a Group Chat

Any participant in a group chat can specify a topic for the chat thread. This can help maintain focus for the discussion in the group. Only a group chat can have a topic.
To specify a topic for a group chat:

1 Double-click the topic field under the group chat title.

2 Type the desired topic for the group chat and press Return (Mac) or Enter (Windows).

Remove a Participant from a Group Chat

If you initiated a group chat, you can remove any other participant in that group chat.

To remove a participant from a group chat (only if you started the chat):

1 Click the Participant menu for the person you want to remove from the chat.

2 Choose Remove.

Add a Participant to your Contacts

If there is a participant in a Group Chat with you who is not already in your contacts, you can add them.

To add participant in a group to your contacts:

1 Click the Participant menu for the person you want to add to your contacts.

2 Choose Add to Contacts.

That person is added to your contacts.
Filtering Chat and Project Messages

You can filter your chat and project messages to that you can quickly find any past or current conversation that you are looking for based on a key word.

To filter chat and project messages:

1. Select the Project or Chat in the left column for which you want to filter messages.
2. Type the key word that you want to filter your messages by in Search field in the upper-left corner of the Artist Chat window. It might be something as simple as “bass” or “synths” or another collaborators name.
3. Press Return (Mac) or Enter (Windows) to view the results.

Editing Chat or Project Messages

You can go back and edit any chat or project messages that you have authored.

To edit your chat or project messages:

1. Locate the message you want to edit.
2. Right-click the message and choose Edit Message from the pop-up menu.
3. In the text chat field at the bottom of the window, your previous message is shown and you can edit it as desired.
4. Press Return (Mac) or Enter (Windows) when you are done and want to send the edited message.

Edited message identified by pencil icon
Any edited message displays a pencil icon, which is visible to all participants in the chat, indicating that it has been edited.

**To remove your chat or project messages:**

1. Locate the message you want to remove.
2. Right-click the message and choose Remove from the pop-up menu.

The message is removed, and the chat log reports to all participants in the chat that "This message has been removed."

**Emoticon and Notations Panel**

On the far right of the text chat field is an emoticon icon. You can click that icon to show the Emoticon and Notations pane where you can select emoticons and notation symbols to add to the chat.

**To add an emoticon or notation symbol to the chat:**

1. Click the emoticon icon on the far right of the text chat field.

2. At the top of the Emoticon and Notations pane, click the Emoticon symbol to show all available emoticons, the Eight-Note icon to show all available Notation symbols, or the Chord Symbol to show all Chord symbols.
Pinning or Unpinning Items in the Projects and Chat Lists

After you have been working with projects, adding contacts, and collaborating for awhile, you can imagine that the Projects and Chat lists might get rather long. Pro Tools lets you “pin” items in either list to the top of the list, or if you don’t need to keep an item at the top of the list any longer, you can “unpin” it. Note that pinning a project or a chat also pins it for all participants in that project or chat (the same is true for unpinning). This can be useful for keeping the highest priority projects and chats at the top of this list for all participants.

To pin a project or chat thread:
1. Right-click the project or chat you want to pin to the top of the list.
2. Choose Pin.
3. The project or chat moves to the top of the list. This item will also be pinned to the top of the list for all participants the next time they go online.

To unpin a project or chat thread:
1. Right-click the project or chat you want to unpin from the top of the list.
2. Choose Unpin.
3. The project or chat moves back to its original location on the list. This item will also be unpinned for all participants the next time they go online.

Leaving a Project or Group Chat

If you are a collaborator on a project (but not the owner), you can leave it. Likewise, if you are a participant in a group chat thread (but did not initiate it), you can leave it.

Project owners cannot leave their own projects nor can you leave a group chat you initiated (but you can add and remove other collaborators and participants using Invite Contacts and Participant commands).

To leave a project or group chat thread:
1. Right-click the project in the Projects list or the group chat thread in the Chat list and choose Leave.
When you leave a project, it is removed from the Projects lists from both the Artist Chat window and from the Dashboard. When you leave a group chat thread, it is removed from the Chat list in the Artist Chat window. No other collaborators or participants are affected.

**Move to or Restore from Artist Chat History**

You can move any project chat from the Projects list or any chat thread from the Chat list to Artist Chat History. This removes it from the Project list or Chat list. You can also restore itemized events from the Artist Chat History. No other collaborator’s or participant’s Histories are affected.

**To move a project or chat thread to Artist Chat History:**

- Right-click a project in the Projects list or a chat thread in the Chat list and choose **Move to History**.

**To restore an item from Artist Chat History:**

1. In the Artist Chat window, click **History**.
2. Locate the item you want to restore and double-click it.

**Restoring a project from Artist Chat History**

This item is shown in the Chat window focused at the time of the event and it appears in either the Project list or the Chat list accordingly.

**Remaining Signed In to your Avid Account Offline**

Pro Tools lets you remain signed in to your Avid Account offline. This lets you continue to work on a project offline. When working offline, you will not be able to send or receive any invitations, notifications, requests, messages, or changes to shared projects.

Any changes you make while working offline will be uploaded to the cloud the next time you go back online. Likewise, any changes made to the cloud and any messages and notifications that were sent while you were offline can be received the next time you go back online.
To go offline and remain signed in to your account while you are offline:

1. Ensure that you are connected to the internet.
2. Launch Pro Tools | First and sign in with your Avid Master Account credentials.
3. Open the Artist Chat window (Window > Artist Chat).
4. At the right-top corner of the Artist Chat window, click the Avatar icon and select Offline from the menu.

A white dot appears on your Avatar icon to indicate that you are offline, but still signed in. You will not be able to receive or write any new messages while Offline (whether you are still connected to the internet or not) and you appear offline to other collaborators (signified by a white dot next to your name wherever you are listed as a participant).

Going Offline Automatically

If you disconnect from the internet, Pro Tools automatically goes offline. If you go offline automatically, it is recommended that you save your project and quit Pro Tools. When going offline automatically, there you may also be automatically signed out from your account. If this happens, you will no longer be able to work offline. If you want to work offline, manually take yourself offline. This is more reliable than going offline automatically.

Working Offline

When working offline, you can open projects using the Projects list in either the Artist Chat window or in the Dashboard, make changes in these projects and save those changes to the local project cache, you can even create new projects. However, no collaboration features will be available until you re-connect to the internet and bring your account back online. Once you come back online, you will be able to upload all of your cached changes as well as download any changes made to the cloud since you went offline.

Bringing Artist Chat Back Online

When you ready to bring Artist Chat back online, make sure you are connected to the internet. You can then check for any new notifications or chat messages, as well as send notifications and chat messages.
To go back online:

1. Ensure that you are connected to the internet.
2. In the Artist Chat window, click the Avatar icon and select Online.

A green dot appears on your Avatar icon to indicate that Artist Chat is now back online and you can send and receive notifications, and chat with any of your contacts and collaborators.

Putting Artist Chat Online

Setting your availability

This way your contacts can recognize your availability for chatting and collaboration. Collaborator status is displayed as a colored dot in the Project Chat.

Availability for Participation

Artist Chat publishes your status so both current and potential collaborators can check on your availability.

To set your status:

1. Launch Pro Tools and sign in with your Avid Master Account credentials.
2. Open the Artist Chat window (Window > Artist Chat).
3. At the right-top corner of the Artist Chat window, click the Avatar icon and select from the following:

   - **Online** Indicates that you are online and available.
   - **Busy** Indicates that you are online, but busy working.
   - **Away** Indicates that you are online, but away from your Pro Tools system.
   - **Offline** Indicates that you are offline and unavailable.

You will always appear to others as offline if Pro Tools is not running.

Project chat, collaborator status
Chapter 19: Track Collaboration

Sharing Projects and Collaborating

Pro Tools lets you upload your projects to the cloud and collaborate on the same project with other users on a track-by-track basis. Obviously, you do not have to share a project and you can just use your cloud storage to keep your project and all associated media backed up online, but the real fun of working with online projects is being able to collaborate with others. Once you have created a project using the Dashboard, and you have created your Artist Profile in the Artist Chat Settings, you can find and invite other Pro Tools users to collaborate on the project. Likewise, other users can share their projects with you and enlist your collaboration.

When you first get started with shared projects and collaboration, you may want to use an existing session rather than create a new project from scratch. In this case, open the session you want to work with and use the Save Copy In command to save it and its associated media (for more information, see “Saving a Session as a Project” on page 175).

What is Shared?

Most project data, media, track data, and conductor rulers is shared when you choose to share a project. Some items are continuously shared, that is they can be constantly edited and posted or downloaded. Other aspects of a project are only shared the first time you upload or download a project, such as the sample rate, bit depth, and audio file format for the project. Other project data is never shared.

Continually Shared Items

The following items are continually shared with all participants in the project:

Tracks and Rulers

Tracks

- Audio, MIDI, Instrument, and Master Fader tracks
- Main Playlists
- Alternate Playlists
- Clips Associated with Playlists
- Clip Gain
- Clip Color
- Elastic Audio Properties for Clips
- Media Associated with Clips
- Track Color
- Volume Automation Settings
- Pan Automation Settings
• Mute Automation Settings
• Plug-In Assignments
• Plug-In Settings and Automation
• Sidechain Assignments
• HW Insert Assignments
• Track Metadata
• Track I/O assignments

Rulers
• Markers (Specific Markers)
• Tempo ruler
• Meter
• Key
• Chords

Automation Mode Selector
The track automation mode selector is continuously shared, but not every change prompts an update.

While “Read” and “None” are continually shared, “Write” modes are not (as this could cause problems for other project participants).

I/O Setup
New projects are received with the bus settings from the project owner. All existing busses on collaborator systems are cleared for the new project.

Any received bus follows the standard I/O Setup mapping logic. Output mapped busses look for a unique ID, followed by the assigned monitor path (if any), followed by the name and channel format of tracks. If none are found, the bus does not map to the collaborator’s system and they are notified through the project notes when they first receive an open the project. If this occurs, they may have to remap those busses manually.

Items Shared Only when a Project is First Downloaded

Project Level
• Sample Rate
• Bit Depth
• File Format
• Interleaved Audio Files option (enabled or disabled)
• Project Start Time
• Project Length
• Timecode Rate
• Feet+Frames Rate
• Timecode 2 Rate
• If the Conductor is enabled or not (whether or not to follow the project Tempo track)
• Pan depth
• Track level (initial fader settings, not volume automation)
• Track Voice assignments

Sending and Receiving Tracks and Updates
A track must be shared to send or receive updates with other project participants. If a track is not shared, it is usable only on the local system. This can be desirable if you want to keep certain tracks from being changed by other participants in the project, or if you want to share only mixdowns of the full mix rather than the entire mix (this can actually save time and online storage space).

A track must be shared by at least one user to show up as “available for download” in the Tracks List.
What is Not Shared?

The following are not shared in a project:
- Mix and Edit groups
- Clip groups
- VCA tracks
- HEAT settings
- Video

Project Ownership

The owner of the project is the one who creates the project and invites others to collaborate on the project. All media posted to the shared project counts only against the project owner’s storage allocation. Be sure to communicate using the Artist Chat window to make sure all participants manage the amount of media they post to the project so as to not overburden the project owner. Only the project owner can invite participants to collaborate on the project and delete participants from the project. When the project owner deletes the project, it is deleted for all participants. When a participant who is not the project owner deletes the project, it is the same as if they simply leave the project and all other participants will be able to continue collaborating on the project.

Start Collaboration

Use the Start Collaboration command to quickly invite collaborators to join an existing session or project, or to create a new collaborative online project.

To start a collaboration:
1. Open an existing session or project (skip this step to create a new collaborative project from scratch).
3. Configure the Dashboard to create a new online project and click Create. (This step is unnecessary if a session or a project is already open.)
4. The Artist Chat window opens and you can immediately invite collaborators from your contacts to join the project.

For detailed information about Artist Chat, see Chapter 18, “Artist Chat Window.”

Track Collaboration Tools in the Edit Window

The Edit Window toolbar is host to the global Track Collaboration tools.

To show (or hide) the Track Collaboration tools in the Edit window toolbar, do one of the following:
- Select (or deselect) View > Track Collaboration.
- From the Edit Window menu, select (or deselect) Track Collaboration.
Track Collaboration Tools in the Transport Window

Just like the Edit window, the Transport window can also be host to the Global Track Collaboration tools. These controls and their settings mirror each other in both the Edit Window toolbar and in the Transport window.

To show (or hide) the Track Collaboration tools in the Transport window, do one of the following:

- Select (or deselect) View > Transport > Track Collaboration.
- From the Transport Window menu, select (or deselect) Track Collaboration.

Global Track Collaboration Tools

The Global Track Collaboration tools provide a high level means of posting and receiving all shared track data. For track-by-track collaboration controls, see “Track Collaboration Controls” on page 384.

⚠️ If a project is offline, all collaborations tools are grayed out. Collaboration is only possible with online projects.

Invite User

Click the Invite User button to open the Artist Chat window and invite one or more of your contacts to participate on the project (see “Invite Contacts to Collaborate” on page 364).

Show Artist Chat

Click the Show Artist Chat button to open the Artist Chat window. The Show Artist Chat button turns green when you receive a message from another participant in the Project Chat for the open project.

See Chapter 18, “Artist Chat Window.”
**Track Ownership Request**

The Track Ownership Request indicator turns orange when you have ownership of a track and another participant wants to take ownership of the track.

**Upload All New Changes**

As soon as you have made any change on any track whose own Upload Track Changes control turns green, the Upload All New Changes button also turns green. If you are busy working on the project you probably won’t want to upload each change individually, but rather wait until you feel ready to post all of your changes at once.

To post all the new changes you have made on tracks in the project since the last complete upload:
- Click the lit Upload All New Changes button

If you have made changes to tracks and decide that you do not want to share your changes, you can Abandon Changes. The Upload All New Changes light goes out and your project reverts to the way it was right before you started making changes.

To abandon all changes since the last upload:
- Right-click the Upload All New Changes button and choose Abandon Changes.

**Download All New Changes**

As soon as another collaborator has made any change on any track whose Upload Track Changes control turns green, your Download All New Changes button turns green as well. Since you probably won’t want to download each change individually, you can wait until you are ready to download all changes from the cloud.

To receive all the new changes other collaborators on the project have made on tracks in the project since your last complete download:
- Click the lit Download All New Changes button

If other participants have made changes to tracks and you decide that you do not want to receive these changes, you can choose Ignore Changes. The Upload All New Changes light goes out and no changes are downloaded.

To ignore all changes other collaborators on the project have made in the project since your last complete download:
- Right-click the Download All New Changes button and choose Ignore Changes

**Download All Shared Tracks**

Typically, the Download All Shared Tracks button turns green the first time you join a project with tracks. As with all collaboration transaction activity, you can monitor the progress of the download in the Task Manager window (Window > Task Manager). The Download All Tracks button turns green again when any participant creates new tracks and shares them. Tracks that are unshared, and then re-shared do not trigger the lighting of the Download All Tracks button.
To download all available tracks in a project:

- If it is lit, click the Download All Tracks button to download all available tracks in the project.

![Download All Tracks button lights when any new tracks are available](image)

### Automatically Upload All New Changes, Download All New Changes, and Download All Shared Tracks

The Auto buttons directly below the Upload All New Changes, Download All New Changes, and Download All Shared Tracks buttons can be enabled for each so that their function is automatically engaged when any corresponding change occurs. For example, you might want to automatically upload your changes as they happen, but not want to automatically receive changes from other collaborators as they happen. In that case enable Auto for Upload All New Changes, but not for Download All New Changes and Download All Shared Tracks. The corresponding button flashes anytime it is automatically activated by a change to one or more shared tracks.

![Auto Upload enabled for Upload All New Changes](image)

### Cloud Storage Usage Meter

The Cloud Storage Usage Meter shows how much cloud storage is being used on the project owner’s account. If you hover the mouse cursor over the meter, a tooltip appears that shows how much of the owner’s storage space is being used by the project. Note that the Details Tool Tip option must be enabled in the Pro Tools Display Preferences for this to occur.

### What the Project Owner Sees

The project owner sees the meter level rise or lower as more media is posted to or deleted from their Cloud Account. The tool tip informs you of how much storage is being used (both as a percentage and as a hard number) on your Cloud Account and how much total storage you have allocated to your account.

![Cloud Storage Meter and tool tip for the project owner](image)

### What a Project Collaborator Sees

A collaborator does not see a meter level, but only sees how full the project owner’s cloud storage is.

![Cloud Storage Meter and tool tip for a collaborator](image)
Track Collaboration Track View in the Edit and Mix Windows

Track Collaboration controls can be shown or hidden independently in both the Edit window and Mix windows. In the Edit window, these controls show up in the left-most column of all Track and Ruler views. In the Mix window, these controls appear between the Sends and the I/O selectors. These controls mirror each other for any given track regardless of whether they are changed in the Edit window or the Mix window.

To show (or hide) the Track Collaboration controls in the Edit window, do one of the following:

- Select (or deselect) View > Edit Window Views > Track Collaboration.
- From the Edit Window View selector, enable (or disable) Track Collaboration.

To show (or hide) the Track Collaboration controls in the Mix window, do one of the following:

- Select (or deselect) View > Mix Window Views > Track Collaboration.
- From the Mix Window View selector, enable (or disable) Track Collaboration.
Track Collaboration Controls

The Track Collaboration controls in the Edit and Mix windows mirror each other on a track-by-track basis. Use these controls to share a track, take or release ownership of a track, upload changes on a track, or download changes to a track.

Share Track

Enable the Share Track control to share a track with other participants in the project. When a track is shared, the Share Track icon is blue. When a track is not shared, it is gray. Anyone can share or unshare any track in the project that has been posted to the cloud and that they have downloaded from the cloud. Any participant can create new tracks and keep them private in their own local copy of the project by not sharing them at all.

To share a track:

1. Create a new track (or use an existing one).

2. Show Track Collaboration view to access the Track Collaboration controls (see “Track Collaboration Track View in the Edit and Mix Windows” on page 383).

3. Click the Share Track control.
Track, Not Shared  When it is not shared, it is gray. When a track is not shared, none of the other Track Collaboration controls are available. You can keep unshared tracks in your project as if they are “private” tracks. In many cases you won’t need to share all the tracks in your project. Consider duplicating tracks to keep them as a reference against other collaborators changes. Or, consider sharing only mixed down tracks as a reference for your collaborators rather than sharing the entire mix.

Shared Track  When a track is shared, the Share Track control is blue. When a track is shared, anyone can take ownership of the track and make changes to it.

Upload Track Changes

When any participant makes a “share-able” change to a shared track, they take ownership of that track, even if only temporarily, and the Upload Track Changes control on that track turns green. When that person clicks the Upload Track Changes control, it uploads the track changes to the cloud copy of the project. Other participants will notice that the Download Track Changes control for that track turns green in their local copy of the project and they can choose to download those changes or not.

To upload track changes:

1  Make changes on a shared track.
2  Do one of the following:
   •  Click the Upload Track Changes control.
   •  Right-click the Upload Track Changes control and choose Upload.

💡 Command-click (Mac) or Control-Click (Windows) an Upload Track Changes control to force upload the track.

Upload Track Changes Right-Click Menu

The Upload Track Changes control provides a few additional options in its right-click menu as follows:

Force Upload

The Force Upload command is only available when the Upload Track Changes control is not lit. Choose Force Upload to force upload the entire track, replacing the cloud version.

Upload

The Upload command works just like clicking a green Upload Track Changes control and posts all of the changes on that track to the cloud copy of the project.

Abandon Changes

Choosing the Abandon Changes command clears the upload and resets all of the changes to how the track was prior to you working on the track.

Manual Uploads Only

Enable the Manual Uploads Only option to ensure that the Upload All New Changes button does not automatically upload any of your changes on this track. Your changes will only be uploaded if you click the Upload Track Changes control for that track. Disable this option to return to allowing the Upload All New Changes button to automatically upload all changes on this track.
Shared as Frozen

The Shared as Frozen option is especially useful if you know that your collaborators do not have a particular plug-in that you are using, but you want them to be able to hear what you are doing on that track. The Upload Track Changes control icon shows a slightly different graphic to indicate that the track has been shared as a frozen track.

![Upload Track as Frozen](image1)
![Uploading Track as Frozen](image2)
![Track Shared as Frozen](image3)

Sharing Track as Frozen indicators

A shared frozen track will be frozen on all systems that download that track. Also, note that tracks that are Shared as Frozen are exempt from Auto mode.

Download Track Changes

When any participant makes a “share-able” change to a shared track that you do not own and they upload it to the cloud copy of the project, your Download Track Changes control for that track turns green. When you click the Download Track Changes control, your local copy of the project begins to download the changes for that track.

To download track changes, do one of the following:

- Click the Download Track Changes control.
- Right-click the Download Track Changes control and choose Accept Download.

💡 Consider making an unshared duplicate of a track before you download changes to it. This way you will always have your original for reference.

Download Track Changes Right-Click Menu

The Download Track Changes control provides a few additional options in its right-click menu as follows:

**Force Download**

The Force Download command is only available when the Download Track Changes control is not lit. Choose Force Download to force download of the entire track from the cloud, replacing the entire local track.

**Accept Download**

The Accept Download command works just like clicking a green Download Track Changes control and downloads all changes to the track from the cloud copy of the project.

**Ignore Changes**

Choosing the Ignore Changes command rejects any changes to that track in the cloud copy of the project and maintains your current version of the track.
Manual Downloads Only

Enable the Manual Downloads Only option to ensure that the Download All New Changes button does not automatically download any changes from the cloud copy of this track. You will only download changes from the cloud copy of the project if you click the Download Track Changes control when it is green. Disable this option to return to allowing the Download All New Changes button to automatically download all changes on this track.

Track Ownership

The Track Ownership control lets you take ownership of a shared track, release ownership of a shared track, request ownership of a shared track, and show you if another participant currently owns the track.

It is important to understand that the ownership of shared tracks is not restrictive. Multiple participants can edit unowned tracks simultaneously, and this can result in edit conflicts between the cloud copy of the project and collaborators’ local copies (see “Conflicts Between Track Changes and the Cloud” on page 390).

Generally speaking, no collaborator should take ownership of any track for any longer than they need to work on that track and upload their changes. This helps to avoid conflicting changes between collaborators.

When any Upload Track Changes control or Download Track Changes controls light yellow, it indicates that there are edit conflicts between various participants’ local copies of the project and the cloud copy of the project. You can upload your changes and overwrite the cloud copy for a track simply by clicking the Upload Track Changes control, even if it is yellow. Otherwise, you can click the Download Track Changes button, even if it is yellow, and overwrite your local track with the version from the cloud.

Taking Ownership of an Unowned Track

Unowned Shared Track

When no one owns a shared track, the Track Ownership control is gray and anyone is free to work on it.

You can take ownership of an unowned track either by making changes on the track (in this case you automatically become the owner of the track) or you can click on the Track Ownership control to manually take ownership of the track. The Display Name for whoever takes ownership of a track is shown in the Track Ownership control for all participants to see. It turns green when you own it, and it turns orange when another participant owns it.

Automatic Ownership

You automatically take ownership of an unowned track by making a “share-able” change on it. The Track Ownership control turns dim green (it turns orange for everyone else) and shows your Display Name and the Upload Track Changes control turns green. You automatically release ownership of the once your changes are uploaded. Any other collaborator can download your changes and even take ownership of it if they want.

You automatically own the track
Manual Ownership

You manually take ownership of an unowned track (or one that you took ownership of automatically) simply by clicking the Track Ownership control. It shows your Display Name and turns solid green. Even if you make changes to the track and then upload those changes, you retain ownership of the track. Any other collaborator must request ownership and be granted ownership, or seize ownership to take ownership of a manually owned track.

Requesting Track Ownership

If another collaborator has manual ownership of a track, their Display Name appears in the Track Ownership control on the track and the control is colored orange. You can request ownership, and they can relinquish ownership to you or deny your request.

To request track ownership, do one of the following:

- Click the Track Ownership control.
- Right-click the Track Ownership control and choose Request.

The Track Ownership control highlights and displays the notification, “Ownership Pending.”

Rescinding Your Request

If you change you mind, you can rescind your request.

To rescind your request for track ownership:

- Right-click the Track Ownership control and choose Rescind My Request.

The Track Ownership control reverts to the owner’s name and remains colored orange.

Seizing Ownership

If you really need to work on a track owned by someone else and they aren’t responding to your request for ownership, you can seize ownership.

To seize track ownership:

- Right-click the Track Ownership control and choose Seize.

The you now own the track, and the Track Ownership control displays your name and turns solid green (or orange for everyone else).

Relinquishing Track Ownership

If you own a track, you can relinquish ownership whether or not another collaborator requested ownership from you. If you relinquish a track that no one else is requesting, it becomes an unowned track.

To relinquish ownership of a track, do one of the following:

- If you took ownership of the track automatically, click the Track Ownership control.
- If you took ownership of the track either manually or automatically, Right-click the Track Ownership control and choose Relinquish.

The Track Ownership control turns gray and is now unowned.
To relinquish a track with change that have not yet been uploaded, Right-click the Track Ownership control and choose one of the following options (depending on whether you took ownership of the track automatically or manually):

**Keep** If you took ownership of the track automatically, choose *Keep* to keep your changes without posting and change the track to manual ownership.

**Relinquish After Posting** If you took ownership of the track automatically, choose *Relinquish After Posting* to do nothing until you upload your changes by clicking the Track or Global Upload button. Once your changes have posted, track ownership is relinquished.

**Relinquish Now** If you took ownership of the track automatically, choose *Relinquish Now* to relinquish ownership immediately without uploading your changes (but keeping your changes).

If you chose either the *Relinquish After Posting* (and then uploaded your changes) or the *Relinquish Now* commands, the Track Ownership control turns gray and the track is unowned.

### Responding to a Track Ownership Request

If another collaborator requests ownership of a track from you, you are notified both on the track requested and by the Track Ownership Request indicator in the Edit window toolbar. The collaborator who is requesting ownership can rescind the request, seize ownership, or be denied the transfer of ownership. You can relinquish ownership (or not) at any time.

#### Track Ownership Requested

The Track Ownership control on the track for which ownership is being requested also highlights and displays the text “Ownership Requested.”

![Ownership Requested indicator in the Edit window toolbar](image)

#### Track Ownership Request Indicator

The Track Ownership Request indicator turns orange when you have ownership of a track and another participant wants to take ownership of the track.

If you have many tracks in your project, it may not be immediately clear for which track ownership is being requested. The Track Ownership Request indicator lets you toggle between showing all tracks and only those tracks requested by another collaborator.

To show only tracks requested by another collaborator:

- Click the Track Ownership Request indicator to show only the requested track (or tracks) in the Edit window.
The Track Ownership Request indicator turns blue and all tracks except those being requested are hidden.

- Click the Track Ownership Request indicator again to show all previously shown tracks in the project. The Track Ownership Request indicator again turns orange.

To relinquish ownership or reject a request, Right-click the Track Ownership control and choose one of the following options (depending on whether or not you still have track changes to upload):

**Relinquish** If you have no track changes that have not yet been uploaded, choose Relinquish to surrender track ownership to the collaborator making the request.

**Reject Collaborator Request** If you do not want to surrender track ownership (and regardless of whether or not you have any track changes that have not yet been uploaded), choose Reject Collaborator Request.

**Relinquish After Posting** If you have track changes that have not yet been uploaded, choose Relinquish After Posting to do nothing until you upload your changes by clicking the Track or Global Upload button. Once your changes have posted, track ownership is surrendered to the collaborator making the request.

**Relinquish Now** If you have track changes that have not yet been uploaded, choose Relinquish Now to immediately surrender track ownership to the collaborator making the request. Any track changes are kept without uploading them.

If you chose either the Relinquish After Posting (and then uploaded your changes) or the Relinquish Now commands, the Track Ownership control turns solid orange and shows the Display Name of the new owner.

### Conflicts Between Track Changes and the Cloud

When any Upload Track Changes control or Download Track Changes control turn yellow, it indicates that there are conflicts between collaborators’ changes and the cloud.

You can upload your changes and overwrite the cloud copy for a track simply by clicking the Upload Track Changes control, even if it is yellow. However, if you upload your changes, the cloud copy will be overwritten.

Likewise, you can click the Download Track Changes control, even if it is yellow, and overwrite your local track with the version from the cloud.
If you make changes to a track while another participant uploads their changes to the cloud copy, when you are notified that changes are available for download, the Download Track Changes control turns yellow indicating that your local track changes will be overwritten by changes on the cloud.

Cloud copy conflicts with your track changes

💡 If you place the cursor over any yellow track Upload Track Changes or Track Download Changes control, a tool tip appears with a warning about whether the track will be overwritten by the cloud copy or the cloud copy will be overwritten by your track changes.

Making Changes to Tracks Owned by Another Collaborator

You can make changes to a track that you do not own, in which case the Upload Track Changes control is darkened. You should request and take ownership of the track before uploading your changes to avoid conflicts with other collaborator’s work. You will not be able to upload your changes until ownership is relinquished.

Local track changes conflict with changes made by the track owner

Indication of Transfer of Conflicting Changes

The Download Track Changes control turns red when a download for that track is currently in progress and the cloud copy is in conflict with the local track changes. Once the transfer is complete it changes to yellow. You can then choose to ignore those changes and keep your version of the track, or download those changes and overwrite your version of the track.

Download from cloud in progress that conflicts with local track changes

Track Cloud Synchronization Indicator in the Tracks List

Pro Tools displays a Cloud icon in the Tracks List for tracks in online projects that are shared but the track data is not downloaded to the local cache. The Cloud icon is gray for tracks that are in the cloud, but not mirrored in the local project cache. The icon changes to clear with a black border and an arrow pointing down while the track is being downloaded. The Cloud icon is cleared once the track is downloaded and synchronized between the cloud copy and the local cache.

Two states of the cloud icon
To download a track from the cloud, do one of the following:

- In the Tracks List, click the gray Cloud icon to the left of the track name to download and import all track data.

- In the Tracks List, right-click the gray Cloud icon to the left of the track name and select one of the following options:

  **Download** Downloads the track data without importing. Track data can be imported at a later time.

  **Ignore for Future Download** Does not download or import the track data.

  **Import** Downloads and imports the track data immediately.

It is important to understand, that unlike tracks in a shared project (which can be shared or not), all Conductor rulers in a shared project are always shared.

**Upload Conductor Ruler Changes**

When any participant makes a “share-able” change to a Conductor ruler, the Upload Ruler Changes control turns green. They can then click the control to upload their changes to the cloud copy of the project.

**To upload Conductor ruler changes:**

1. Make changes on a Conductor ruler (see “Track Ownership” on page 387).

2. Do one of the following:
   - Click the Upload Ruler Changes control.
   - Right-click the Upload Ruler Changes control and choose Upload.

   **Command-click (Mac) or Control-Click (Windows) an Upload Ruler Changes control to force upload the track.**
Upload Ruler Changes Right-Click Menu

The Upload Ruler Changes control provides a right-click menu that offers similar controls to the Upload Track Changes control right-click menu.

**Force Upload**

The Force Upload command is only available when the Upload Ruler Changes control is not lit. Choose Force Upload to force upload the entire ruler as is, replacing the cloud version.

**Upload**

The Upload command works just like clicking a green Upload Ruler Changes control and posts all of your changes on the ruler to the cloud copy of the project.

**Abandon Changes**

Choosing the Abandon Changes command clears the upload and resets all of your changes to how the Conductor ruler was prior to you working on it.

**Manual Uploads Only**

Enable the Manual Uploads Only option to ensure that the Upload All New Changes button does not automatically upload any of your changes on this Conductor ruler. Your changes will only be uploaded if you click the Upload Ruler Changes control. Disable this option to return to allowing the Upload All New Changes button to automatically upload all changes on this Conductor ruler.

Download Conductor Ruler Changes

When another participant makes a “share-able” change to a Conductor ruler and they then upload their changes to the cloud copy of the project, the corresponding Download Ruler Changes control turns green for all other participants. They can click the Download Ruler Changes control to download the changes to the Conductor ruler from the cloud copy of the project to their local copy.

To download Conductor ruler changes, do one of the following:

- Click the Download Ruler Changes control.
- Right-click the Download Ruler Changes control and choose Accept Download.

Download Ruler Changes Right-Click Menu

The Download Ruler Changes control provides a right-click menu that offers similar controls to the Download Track Changes control right-click menu.

**Force Download**

The Force Download command is only available when the Download Ruler Changes control is not lit. Choose Force Download to force download of the entire ruler from the cloud, replacing the entire local ruler.
Accept Download

The Accept Download command works just like clicking the green Download Ruler Changes control and downloads all changes on that ruler from the cloud copy of the project.

Ignore Changes

Choosing the Ignore Changes command clears the download and keeps your Conductor ruler as is regardless of any changes in the cloud copy of the project.

Manual Downloads Only

Enable the Manual Downloads Only option to ensure that the Download All New Changes button does not automatically download any changes from the cloud copy of the project to this Conductor ruler. Cloud changes to the ruler will only be downloaded if you click its Download Ruler Changes control. Disable this option to return to allowing the Download All New Changes button to automatically download all changes on this Conductor ruler.

Conductor Ruler Ownership

The Conductor Ruler Ownership control lets you take ownership of a Conductor ruler, release ownership of a Conductor ruler, request ownership of a Conductor ruler, and show you if another participant currently owns that Conductor ruler.

Ruler Ownership Right-Click Menu

The Conductor Ruler Ownership control right-click menu provides different commands depending on whether or not the ruler is unowned, owned by you, or owned by another, and whether or not changes are pending upload or download.

Request

Choose Request to request ownership of a Conductor ruler that is owned by another or to take ownership of an unowned Conductor ruler.

Keep

Choose Keep to keep ownership of a Conductor ruler that you have changed without posting your changes.

Relinquish

Choose Relinquish to surrender ownership of a Conductor ruler.

Reject Collaborator Request

Choose Reject Collaborator Request to deny the request for ownership of a Conductor ruler by another collaborator, keeping ownership for yourself.
**Relinquish After Posting**

Choose Relinquish After Posting to automatically surrender ownership of a Conductor ruler right after posting changes.

**Relinquish Now**

Choose Relinquish Now to surrender ownership of a Conductor ruler without posting changes.

**Rescind My Request**

Choose Rescind My Request to cancel your request for ownership of a Conductor ruler.

**Seize**

Choose Seize to seize ownership of a Conductor ruler from another collaborator.

**Unowned Conductor Rulers**

When no one owns a Conductor ruler, anyone is free to work on it and the Conductor Ruler Ownership control is gray.

**Automatic Ownership**

When you automatically take ownership of a Conductor ruler by making a “share-able” change on an unowned ruler, the Upload Ruler Changes control turns dim green.

**Manual Ownership**

When you manually take ownership of a Conductor ruler by clicking its Conductor Ruler Ownership control, it turns solid green and no other participant can take ownership of that Conductor ruler simply by making a “share-able” change to their copy of that Conductor ruler.

**Ownership Requested**

If any other participant wants to take ownership of that Conductor ruler, they must request ownership either by making a “share-able” change to that Conductor ruler or by clicking the Conductor Ruler Ownership control for that ruler in their local copy of the project.

You can click the Conductor Ruler Ownership control to relinquish ownership of that ruler and the other participant will take ownership of that ruler.
Conductor Ruler Owned by Another Participant

When another participant owns a Conductor ruler, the Conductor Ruler Ownership control turns orange for everyone else.

Ownership Pending

If you want to take control of a Conductor ruler owned by another participant, you can make a “share-able” change on the Conductor ruler or click the Conductor Ruler Ownership control. The other participant is notified that the ownership of the Conductor ruler is being requested and you will see that the request is pending. If they relinquish ownership of that Conductor ruler, you will take ownership of it.
Chapter 20: Importing and Exporting Session Data

Pro Tools lets you import and export a variety of data into and out of a session, including audio and MIDI files, clip groups, video files, track playlists, I/O configurations, and signal routing configurations.

You can import individual audio and MIDI files into a session, or import entire audio or MIDI tracks, along with all of their attributes, from another session. Additionally, with Pro Tools Ultimate, you have the option of importing any combination of track attributes from another session, such as a track’s audio or MIDI playlists, signal routing, plug-ins, or automation (see “Importing Session Data” on page 416).

When you are working with video, you can import and export video files from a session (see Chapter 60, “Working with Video in Pro Tools”).

### Importing and Exporting Data to and from a Session or Project

#### Importing

Pro Tools lets you import audio, video, MIDI, clip groups, or session files into the current Pro Tools session or project by:

- Dragging and dropping from:
  - A Workspace browser
  - Mac Finder or Windows Explorer

- Using the File menu Import commands:
  - Session Data
  - Audio
  - MIDI
  - Video
  - Clip Groups
  - VENUE Channel Names as Track Names

Session or project data, audio files, and clips can be imported to existing tracks, new tracks, the Tracks List, or the Clips List in a Pro Tools session or project.

#### Exporting

Pro Tools lets you export audio, video, MIDI, clip groups, and session data by:

- Using the Export to Sibelius or Send to Sibelius command (MIDI only)

- Using the File menu Export commands:
  - Selected Tracks as New AAF/OMF
  - Selected Tracks as New Session
  - MIDI
  - Sibelius
  - Session Info As Text

- Using the Tracks Right-click menu:
  - Send To Sibelius command (Score Editor only)
  - Export MIDI command
• Using the Clips List menu:
  • Export Clip Definitions command
  • Export Clips as Files command
  • Export Clip Groups command

Audio Conversion on Import

Depending on the properties of the audio files you are importing, you can add, copy, or convert the files:

- When files are added to a Pro Tools session, they remain at their current hard drive location and are not moved or copied. The session references the original files wherever they are on your system. Additionally, the files referenced by the session retain their original file format, sample rate, and bit depth.
- When files are copied into the session, the original files remain wherever they are on your system and are copied to the session’s Audio Files folder and are then added to the session. The session references the copied files, not the original files. Additionally, the copied files referenced by the session retain their original file format, sample rate, and bit depth.
- When files are converted into the session, the original files remain wherever they are on your system, converted to the session file format, sample rate, and bit depth, and are written to the session’s Audio Files folder. The session references the converted files, not the original files.

Files That Can Be Added to a Session or Project Without Conversion

Any audio file of a supported file format (WAV and AIFF) and bit depth (16, 24, and 32-bit float) can be added to sessions and projects without conversion. Audio files with sample rates that do not match the session or project sample rate can be added to the session or project without conversion, but will playback at a different pitch and speed from files that match the session or project sample rate.

You can enable the Automatically Copy Files on Import option in the Processing Preferences page to be sure to always copy files to the session’s Audio Files folder when importing audio by drag and drop.

Files That Must Be Converted on Import

Audio files formats other than WAV and AIFF must be converted on import. Pro Tools automatically converts these files to the current session or project audio file format on import. Also, if the session or project is not enabled for Interleaved files, Pro Tools splits interleaved audio files into multiple mono files on import.

If clip definitions are present in an audio file, you can convert and import the audio for a clip without importing the entire parent audio file using the Import Audio command.

Pro Tools 7.x and higher does not support audio file names that contain certain ASCII characters (see “Opening a Session that Contains Audio File Names with Illegal Characters” on page 457).

Supported Audio File Formats

Audio files of the following types can be imported into Pro Tools sessions and projects without conversion:

• AIFF
• WAV or BWF (.WAV) (including support for WAV Extensible and RF64)
Audio files of the following types can be imported into Pro Tools sessions and projects, but will be converted to the current session or project file format on import:

- AAC audio (including audio with AAC, Mp4, and M4a file extensions)
- ACID files
- MP3
- MXF audio
- QuickTime (Mac only)
- ReCycle (REX 1 and 2) files
- Sound Resource (AIFL—Mac only)

⚠️ *Pro Tools 11 and higher cannot import SD I or SD II files. Please use Pro Tools 10 to open older sessions that reference SD II files, or use an audio file format conversion utility to convert the files to AIFF or WAV.*

⚠️ *Pro Tools cannot import protected AAC or MP4 files with the .M4p file extension. These files are protected under the rules of digital rights management.*

### Sample Rate Conversion Quality

The Sample Rate Conversion Quality setting determines the quality of sample rate conversion used when converting and importing audio into a session. It can also be applied when exporting files at different sample rates and when bouncing to disk. There are five possible settings, ranging from Low (fastest, but lowest quality) to Tweak Head (highest quality, but slowest). The higher the quality of sample rate conversion you choose, the longer Pro Tools will take to process the audio file.

The Sample Rate Conversion Quality options are available in the Import Audio and the Import Session Data dialogs. In each case, the Sample Rate Conversion Quality setting is local to that specific dialog. The Sample Rate Conversion Quality preference only applies to conversion on import by drag and drop.

**To set the sample rate conversion quality for importing audio by drag and drop:**

1. Choose Setup > Preferences and click the Processing tab.
2. From the Sample Rate Conversion Quality pop-up menu, select a quality setting. For most applications, the Good or Better setting will yield very good results.
3. Click OK.

💡 *The Import Audio and Import Session Data dialogs provide local controls for sample rate conversion quality.*

### Bit Depth Conversion and Dither

If the Convert Copied Files on Import preference is enabled (Setup > Preferences > Processing), the following occurs when importing audio files with different bit depths than the current session bit depth:

- When importing audio at a lower bit depth than the session, Pro Tools converts the file to match the session bit depth by adding empty bits. For example, when importing a 16-bit file into a 24-bit session, Pro Tools converts the file to 24-bit.
- When importing audio at a higher bit depth than the session, Pro Tools automatically applies a preset, noise-shaped dither and converts the file to the session bit depth. For example, when importing a 24-bit file into a 16-bit session, dither is applied automatically and the file is converted to 16-bit.
**Importing Interleaved Files**

When using the Import Audio command, interleaved stereo files are automatically imported to stereo tracks. With Pro Tools Ultimate, greater-than-stereo multichannel audio files are automatically imported to tracks with the corresponding multichannel audio file format.

If the Interleaved option is enabled for the session, or is enabled on import, interleaved files are imported to the session and remain interleaved files. If this option is not enabled, interleaved files are split into multi-mono.

Conversely, split stereo (dual mono) audio files can be automatically imported to stereo tracks. Split stereo audio files must have the channel identifiers “.L” and “.R” in their names (for example, `filename.L` and `filename.R`), and the files must be the same length. In Windows, or in Mac/PC Compatibility mode, these files will have a 3-letter file extension appended after the “.L” or “.R” channel identifier.

**Importing Files with Drag and Drop**

Pro Tools lets you import audio, MIDI, video, and session files by dragging and dropping files from a Workspace browser, Windows Explorer, or Mac Finder to the Pro Tools application icon, the session Timeline, a track, the Tracks List, or the Clips List.

The following figure illustrates some of the options available to import files using drag and drop from Workspace browsers.

To import files into the Clips List:
1. Select audio, video, MIDI, clip group, REX, or ACID files in a Workspace browser, or Windows Explorer, or Mac Finder.
2. Drag the selected files onto the Clips List.

To import files into an existing track:
1. Select the files you want to import in a Workspace browser, or Windows Explorer or Mac Finder.
2. Drag the selected file to a location on an existing, compatible track. The file is imported and placed where it was dropped.

To import files as new tracks:
1. Select the files you want to import in a Workspace browser, or Windows Explorer or Mac Finder.
2. Do any of the following:
   - Shift-drag files and drop anywhere in the Edit window.
   - Drop files to the Tracks List.
   - Drop files to empty space in the Edit window, below or between tracks.

**Important:** Importing does not always convert or copy audio files. See “Audio Conversion on Import” on page 398.

**Important:** Importing using drag and drop does not necessarily bring the Edit window to the foreground. For example, dragging and dropping a file from a browser into a track leaves the source browser in the foreground (not the Edit window). Always verify the active, foreground window or browser before continuing.
Importing from the Workspace by drag and drop

Drop media or session files to existing tracks, or to the Tracks List to add as new

Drop files in the Clips List to import
To import and spot files into a track:

1. Enable Spot mode.
2. Select the files you want to import in a Workspace browser, or Windows Explorer, or Mac Finder.
3. Drag the files onto an existing, compatible track. The Spot dialog appears.
4. Enter the appropriate timecode location (where you want to spot the imported file).
5. Click OK.

To import and spot an audio file by its Waveform in Workspace browsers:

1. In a Workspace browser, Command-click (Mac) or Control-click (Windows) the file’s waveform display at the approximate reference point you want to use for placement in a track.
2. While continuing to press Control (Windows), or Command (Mac), drag the waveform onto an existing audio track (the source audio file and the destination audio track must have the same number of channels).

Snapping to Head and Tail

You can drag and drop files to tracks and have them snap to the head or the tail of the current Edit selection or insertion point. When snapping to head, the beginning of the imported file snaps to the beginning of the Edit selection. When snapping to tail, the end of the imported file snaps to the beginning of the Edit selection.

To import and snap to head:

- Control-drag (Mac) or Start-drag (Windows) a file onto a track.

To import and snap to head and copy the file to the session Audio files folder:

- Option-Control-drag (Mac) or Alt-Start-drag (Windows) a file onto a track.

To snap to tail:

- Command-Control-drag (Mac) or Control-Start-drag (Windows) a file onto a track.

To snap to tail and copy the file to the session Audio Files folder:

- Command-Option-Control-drag (Mac) or Control-Alt-Start-drag (Windows) a file onto a track.

Elastic Audio on Import

When importing any audio file by drag and drop to an Elastic Audio-enabled track, the audio file is imported and analyzed (if not already analyzed). If the imported audio file is tick-based, it is conformed to tempo using the track’s Elastic Audio plug-in. If it is a sample-based audio file, such as a single drum hit or short sound effect, it maintains its original duration. Longer audio files with no detectable tempo also remain sample-based.

You can also import audio by drag and drop to create new tick-based Elastic Audio-enabled tracks.

When importing tick-based audio by drag and drop from Workspace browsers to the Tracks List or empty space in the Edit window, Pro Tools creates a new tick-based, Elastic Audio-enabled track using the default Elastic Audio plug-in selected in the Processing Preferences page (see “Elastic Audio Options” on page 409).
If you are importing an audio file by drag and drop from Windows Explorer or Mac Finder to the Tracks List or to empty space in the Edit window, files are imported as sample-based or as tick-based Elastic Audio depending on the Drag and Drop from Desktop Conforms to Session Tempo preference (see “Drag and Drop From Desktop Conforms to Session Tempo” on page 408).

**Importing Elastic Audio from Workspace to the Clips List**

With the Audio Files Conform to Session Tempo option enabled, dragging and dropping tick-based audio from Workspace browsers to the Clips List (or to the Tracks List), creates two separate clips in the Clips List. The first is a sample-based whole file clip and the second is a tick-based copy of the same clip.

**Importing Tempo from Tick-Based Audio**

If there are no tracks in the session, and you import a tick-based audio file to the Clips List, Tracks List, or empty space in the Edit window, you are prompted to either import the tempo from the file or use the default session tempo. To keep the default session tempo, and have the loop conform to the session tempo, click Don't Import.

If the session already contains at least one track (regardless of track type), you are not prompted to import the tempo from the file and the file is conformed to the session tempo.

---

**Importing Audio Files and Clips Using the Import Audio Command**

The Import Audio command lets you import audio files or clips into your Pro Tools session or project.

1. Choose File > Import > Audio.
2. In the Import Audio dialog, locate and select an audio file to display its properties and associated clips.

You can choose to display only a certain file type (such as WAV) by selecting the type from the Show pop-up menu. To display all supported file types, select All Documents from the Show pop-up menu.

---

![Import Audio dialog](image.png)
In the import list, audio files are distinguished from clips by their icons.

Audio File icon

Audio Clip icon

*File and Clip icons in the Import Audio dialog*

⚠️ *On Mac, Sound Resource files must have the “.SFIL” extension to be imported by Pro Tools.*

3 To preview a selected file or clip before you import it, click the Play and Stop buttons in the Import Audio dialog.

Adjust the preview volume with the vertical slider. To navigate to a particular location in the file, use the horizontal slider under the Play and Stop buttons.

⚠️ *The Preview Volume control in the Import Audio dialog also affects the preview volume when auditioning clips in the Clips List.*

The audition output path defaults to channels 1–2. For Pro Tools systems with more than 2 channels of output, the audition path can be changed in the I/O Setup (see “Audition Path” on page 58).

4 Do any of the following:

- To place a file or clip in the Import list, select the file and click Add or Convert.
- To import all files and clips in the current directory, click Add All or Convert All.
- To remove a file or clip from the Import list, select it and click Remove.
- To remove all files and clips, click Remove All.

⚠️ *Pro Tools lets you add files to a session that are at a different sample rate than your session. In the comments field of the Import Audio dialog, a warning is posted that these files will play back at the wrong speed and pitch if they are not converted.*

5 When you have added all audio files and clips to the Import list, you can apply sample rate conversion by doing the following:

- Enable Apply SRC.
- Specify the Source Sample Rate either by typing a number, or by selecting a sample rate from the pop-up menu.
- Select the sample rate conversion quality from the Quality pop-up menu. This setting overrides the Sample Rate Conversion Quality setting in the Processing Preferences page.

6 Click Done.

Press Command+W (Mac) or Alt+E (Windows) to select Done. Press Command+ “.” (Period) (Mac) or Esc to Cancel.

7 If you are copying or converting files, choose a location for the new files. Choose a folder on a valid audio drive, such as the Audio Files folder for the current session.
8 In the Audio Import Options dialog, select where the imported files will go in the session:

![Audio Import Options dialog]

**New Track** Each audio file is imported into its own individual track and into the Clips List.

When importing audio into a track, you can also choose the location in the track where the audio file will begin (such as Session Start).

**Clips List** Audio files are imported into the Clips List without creating a new track. Imported audio files appear in the Clips List and can then be dragged to audio tracks.

9 If you chose to create a new track, choose a location for the imported file in the track:

**Session Start** Places the file or clip at the start of the session.

**Song Start** Aligns the beginning of the file or clip to the Song Start point.

**Selection** Aligns the beginning of the file or clip to the edit cursor or to the beginning of a selection in the Timeline.

**Spot** Displays the Spot dialog, which lets you spot the file or clip to a precise location based on any of the Time Scales.

10 Click OK.

---

**Importing Audio from Audio CDs**

Pro Tools lets you import tracks from audio CDs using the same methods that you use to import audio files, as follows:

- Drag CD audio from the CD folder.
- Drag files from a Workspace Browser.
- Use the Import Audio command.

Before importing CD audio, make sure your hard drive has enough space for the converted audio files.

Importing CD audio with either drag and drop method lets you continue working in the session foreground (such as in the Mix or Edit window), while the Task Manager (Window > Task Manager) works in the background (importing and converting the audio until the import is completed). For more information on the Task Manager, see “Task Manager Window” on page 354.

Because the transfer is made in the digital domain, there is no signal loss.

The sample rate for audio CDs is 44.1 kHz. Therefore, if your session’s sample rate is set to 48 kHz or higher, Pro Tools will convert the sample rate for the imported audio. Before importing CD audio, set the Sample Rate Conversion Quality preference accordingly. For more information, see “Sample Rate Conversion Quality” on page 399.
Importing ACID and REX Files

ACID files and REX 1 and 2 files are converted to the session audio file type. Depending on the preferences settings, ACID and REX files can be imported as sample-based clips or as tick-based Elastic Audio clips. For REX files only, Pro Tools uses any slice data to create Event markers with 100% confidence. ACID files are analyzed for Elastic Audio events just like WAV files, and so events are detected with varying degrees of confidence.

For information on Elastic Audio, see Chapter 44, “Elastic Audio.”

REX files can also be imported as tick-based clip groups.

For information on clip groups, see “Clip Groups” on page 919).

To import ACID and REX files as sample-based clips:

1. Choose Setup > Preferences and click the Processing tab.
2. Disable the Import REX Files as Clip Groups option.
3. Select No Files as the Drag and Drop from Desktop Conforms to Session Tempo preference.
4. Click OK to close the Preferences dialog.
5. When importing by drag and drop from Workspace browsers, make sure that the Audio Files Conform to Session Tempo option is disabled.
6. Import the ACID and REX files you want by drag and drop from a Workspace browser or the Desktop, or using the Import Audio command (see “Importing Audio Files and Clips Using the Import Audio Command” on page 403).

To import ACID and REX files as tick-based Elastic Audio clips:

1. Choose Setup > Preferences and click the Processing tab.
2. Disable the Import REX Files as Clip Groups option.
3. Select REX and ACID Files Only or All Files as the Drag and Drop from Desktop Conforms to Session Tempo preference.
4. Click OK to close the Preferences dialog.
5. Do one of the following:
   - Import the REX files you want by drag and drop from a Workspace browser.
   - Import the REX files you want by drag and drop from the Desktop.
   - Use the Import Audio command (see “Importing Audio Files and Clips Using the Import Audio Command” on page 403).

To import REX files as tick-based clip groups:

1. Choose Setup > Preferences and click the Processing tab.
2. Select the Import REX Files as Clip Groups option.
3. To apply real-time crossfades to the files, enable the Automatically Create Fades option (see “Automatic Fades for Imported REX Files” on page 407).
4. Select REX and ACID Files Only or All Files as the Drag and Drop from Desktop Conforms to Session Tempo preference.
5. Click OK to close the Preferences dialog.
6 Do one of the following:
• Import the REX files you want by drag and drop from a Workspace browser
• Import the REX files you want by drag and drop from the Desktop.
• Use the Import Audio command (see “Importing Audio Files and Clips Using the Import Audio Command” on page 403).

Automatic Fades for Imported REX Files

If the Import REX Files as Clip Groups option is enabled in the Processing Preferences page, Pro Tools can automatically apply real-time cross-fades to the clips or “slices” in imported REX format files.

To apply real-time crossfades to REX files:
1 Choose Setup > Preferences and click the Processing tab.
2 Enable the Import REX Files as Clip Groups option.
3 Enable the Automatically Create Fades option.
4 In the Preferences dialog, click the Editing tab.
5 Under Default Fade Settings, click REX.
6 In the REX Auto-Crossfades dialog, select the shapes you want for crossfades, and click OK.
7 Click OK to close the Preferences dialog.

⚠️ Depending on your edits or tempo changes after importing REX files, fades can be deleted and you will have to recreate them manually.

Importing Multichannel Audio Files from a Field Recorder

Pro Tools lets you use any of its import methods to import monophonic and polyphonic audio files recorded by a field recorder. When you import these types of files, they must be converted to an audio format compatible with Pro Tools.

For more information on importing files from a field recorder, see Chapter 59, “Working with Field Recorders in Pro Tools.”

Importing Monophonic Audio Files

A monophonic audio file contains one mono channel and relevant metadata from a single multichannel recording.

When you import monophonic audio files that were recorded simultaneously, they are converted to multichannel clips and displayed together in the Clips List. Any metadata is also imported with the files.

Importing Polyphonic Audio Files

A polyphonic audio file contains multiple mono channels and relevant metadata recorded simultaneously in a multichannel recording.

When imported into Pro Tools, a polyphonic audio file is divided into individual monophonic audio files written to disk—one file for each channel. Clips for each channel appear in the playlist, and a multichannel clip appears in the Clips List with the channels expandable underneath. Any metadata is also imported with the files.
**Import Options and Preferences**

Pro Tools provides several options and preferences that affect audio import. Configure Pro Tools to match your most common workflows. For example, if you frequently work by importing REX files for loop-based composition, you can configure Pro Tools to always import REX files to conform to tempo and create new tick-based Elastic Audio tracks.

**Convert Imported “WAV” Files To AES31/BroadcastWave** When selected, this option applies to all newly imported WAV files, making them compliant with the AES31/EBU Broadcast standard.

**Automatically Copy Files on Import** When selected, all audio files that are imported by dragging and dropping are copied to the current session’s Audio Files folder, regardless of whether the files need to be converted to the current session’s file type, bit depth, or sample rate. Additionally, when selected, the Import Session Data dialog defaults to Copy from Source Media. The Automatically Copy Files on Import preference does not affect the Import Audio command.

**Convert Copied Files to Session Format** When selected, files that have different file formats from the current session file format are copied and converted to the current session audio file format, bit depth, and sample rate on import. For example, if the session file format is WAV, 24-bit, 48 kHz and you import an AIF, 16-bit, 44.1 kHz file, the file is copied and converted to WAV, 24-bit, 48 kHz on import. When this option is not selected, copied files retain their original format (unless that file format is incompatible with Pro Tools, in which case it must be converted).

**Do Not Convert Sample Rate on Import** When selected, files with different sample rates than the session sample rate are not automatically converted when imported into the session. This means that files with mis-matched sample rates play back at a different speed (and pitch transpositions than when they were originally recorded (or converted).

**Import REX Files as Clip Groups** When selected, REX flies are imported as clip groups, all the underlying slices are imported as individual clips contained within the clip group. When this option is not selected, importing REX files into a session converts them to the session’s audio file format, the individual slices are consolidated, and the slice information is used for Elastic Audio analysis. These files remain tick-based after import and conversion.

**Automatically Create Fades** When selected, crossfades are applied automatically to the sliced clips within clip groups created by importing REX files. If the Import REX Files as Clip Groups option is not selected, the Automatically Create Fades option does not apply.

To change the default fade settings for REX files, click the REX button in the Default Fade Settings section on the Editing Preferences page (see “Fades Editing Preference” on page 410).

**Drag and Drop From Desktop Conforms to Session Tempo**

The Drag and Drop From Desktop Conforms to Session Tempo options determine whether or not REX, ACID, and all other audio file formats dragged and dropped from Windows Explorer or Mac Finder are imported as tick-based Elastic Audio and conformed to the session tempo.
None When enabled, all audio files, including REX and ACID files, are not conformed to the session tempo when imported by drag and drop from Windows Explorer or the Mac Finder. They are imported as sample-based files and converted to the sessions audio file format.

REX and ACID Files Only When enabled, only REX and ACID files are conformed to the session tempo when imported by drag and drop from Windows Explorer or the Mac Finder. REX files are imported either as tick-based Elastic Audio or, if the Import REX Files as Clip Groups option is enabled, as tick-based clip groups.

All Files When enabled, all audio files are imported as tick-based Elastic Audio and conform to the session tempo.

Sample Rate Conversion Quality
The Sample Rate Conversion Quality preference determines the quality of sample rate conversion used when converting and importing audio into a session by drag and drop. Sample rate conversion is used in a variety of Pro Tools processes including converting and importing audio files of different formats into a session, and bouncing and saving tracks to a different sample rate or bit depth. The higher the quality of sample rate conversion you choose, the longer Pro Tools will take to process the audio file.

Elastic Audio Options
The Elastic Audio preferences determine which Elastic Audio plug-in is used for preview and import, and whether or not new tracks are created with Elastic Audio enabled using the selected default plug-in.

Default Plug-In Lets you select any Real-Time Elastic Audio plug-in as the default plug-in for previewing and importing Elastic Audio. The selected default Elastic Audio plug-in is also used when new tracks are created with Elastic Audio enabled. The Elastic Audio Plug-In selector in Workspace browsers inherits the selected default plug-in. Likewise, changing the selected plug-in in Workspace browsers updates the selected Default Plug-In in the Processing preferences.

Default Input Gain Lets you attenuate the signal input to Elastic Audio plug-ins by 0 to –6 dB for preview and import. If you experience clipping due to Elastic Audio processing during preview or after import, you may want to set the Default Input Gain to slightly attenuate (lower) the audio signal input for Elastic Audio processing. This preference also applies to any audio imported to an Elastic Audio-enabled track.

If you commit any clips on a track (by disabling Elastic Audio on the track) that were imported with the Default Input Gain applied, their clip-based Input Gain is reset to 0.

The Elastic Properties window inherits the Default Input Gain preference. To apply further clip-based Input Gain for Elastic Audio processing, select the clip and adjust the Input Gain setting in the Elastic Properties window (see “Elastic Properties Window” on page 988).

Enable Elastic Audio on New Tracks When selected, new tracks are created with Elastic Audio enabled. The selected default Elastic Audio plug-in is used. When importing audio to new tracks, new tracks are created with Elastic Audio enabled if this option is enabled.

⚠️ If the Enable Elastic Audio on New Tracks option is selected, you may want to also select the New Tracks Default to Tick Time-base option in the Editing Preferences page.
Tracks Preference

When the New Tracks Default To Tick Timebase option is enabled, all new tracks default to ticks. This includes importing audio to new tracks. When deselected, audio, Auxiliary Input, Master Fader, and VCA tracks default to samples. MIDI and Instrument tracks always default to ticks.

Fades Editing Preference

The Default Fade Settings for REX files in the Editing preferences lets you select the default envelope shape for fades and crossfades between clips (“slices”) in imported REX files. Fades are only applied to imported REX files if the Import REX Files as Clip Groups option and the Automatically Create Fades option are both enabled on the Processing Preferences page.

Exporting Audio

Pro Tools supports exporting audio clips as audio files, exporting left and right audio files as stereo interleaved files, and exporting clip information.

You can also export audio from Pro Tools by bouncing or consolidating audio tracks. For more information, see “Bounce to Disk” on page 1188 and “Consolidating Clips” on page 665.

Exporting a Clip as a New Audio File

You can export clips as audio files with the Export Clips as Files command. Use this command if you intend to use a clip in other sessions (or other audio applications) without using its parent source file.

Warped clips (Elastic Audio) will be exported unwarped at their original duration.

To export clips as new audio files:

1. In the Clips List, select the clips you want to export.

2. From the Clips List menu, choose Export Clips as Files.

3. In the Export Selected dialog, set the File Type, Format, Bit Depth, and Sample Rate. In addition, choose the Destination Directory.

This command also provides a way to convert clips to a different audio format, sample rate, or bit depth.
When you export clips to a lower bit depth, Dither (with or without Noise Shaping) is applied as shown in the following table:

<table>
<thead>
<tr>
<th>Bit Depth</th>
<th>Dither</th>
<th>Noise Shaping</th>
</tr>
</thead>
<tbody>
<tr>
<td>32-bit float to 32-bit float</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>32-bit float to 24-bit</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>32-bit float to 16-bit</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>24-bit to 32-bit float</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>24-bit to 24-bit</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>24-bit to 16-bit</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>16-bit to 32-bit float</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>16-bit to 24-bit</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>16-bit to 16-bit</td>
<td>No</td>
<td>No</td>
</tr>
</tbody>
</table>

The Avid Dither plug-in is used for any conversion (with or without Noise Shaping enabled).

For more information about using Dither, see “Dither” on page 1089.

4 Select an option for how Pro Tools should resolve duplicate file names.

Prompting for Each Duplicate Prompts you for a file name for any file that has the same name as a file in your destination directory.

Auto Renaming Automatically changes the name of any duplicate file by adding a number at the end of the file name (such as file_01).

Replacing with New Files Replaces files with the same name with the new files.

5 Click Export to export the new audio files.

Exporting Stereo or Multichannel Interleaved Files

You can use the Export Clips as Files command to export audio clips to stereo or multichannel interleaved files for use in other applications. (Pro Tools cannot use interleaved files directly in the Timeline—these must be converted into multiple mono files.) For example, for this to work with a stereo file, the selected clips must have identical names with “.L” and “.R” suffixes (for instance, vocals_01.L and vocals_01.R). These clips appear as a stereo clip in the Clips List.

Pro Tools Ultimate also let you bounce multichannel interleaved files of any supported file type.

To export clips as a stereo or multichannel interleaved file:

1 Select the stereo or multichannel audio clip in the Clips List or in the track playlist. If the clips appear on mono tracks in the session, select the two mono clips.

2 From the Clips List menu, choose Export Clips as Files.

3 In the Export Selected dialog, select Stereo Interleaved in the Format pop-up menu. For multichannel clips, the Stereo Interleaved option produces a multichannel interleaved file.

4 Configure any other output settings, then click Export to export the new stereo interleaved file.
Exporting Clip Definitions

Pro Tools stores clip definitions for audio files within each session. If you want to use an audio file’s clips in another session, or with another application that supports them, you can export the clip information.

If you plan to transfer Pro Tools session data to another session, you should export clip definitions for sessions containing multiple takes created with Loop Record.

The Export Clip Definitions command does not export clips as audio files (unlike the Export Clips as Files command). Instead, it stores pointers to the clips within the parent source file.

To export clip definitions for an audio file:

1. In the Clips List, select any clips or clip groups for which you want to export definitions. You do not have to select the parent file audio clip.
2. Choose Export Clip Definitions from the Clips List menu.
3. Click Export.

Importing MIDI Files

You can import Standard MIDI Files (SMF) into your Pro Tools sessions and projects.

Pro Tools provides several ways to import MIDI files into an open session or project.

• “Importing MIDI Files Using Pro Tools Menu Commands” on page 412.
• “Importing MIDI Files with Drag and Drop” on page 414.

Pro Tools does not import proprietary sequence files. To use sequences from other MIDI applications in a Pro Tools session, you will need to first save them as Standard MIDI Files. See the manufacturer’s documentation for details on saving Standard MIDI Files.

There are two types of Standard MIDI Files, both of which are supported by Pro Tools:

• Type 0 MIDI files store data for all MIDI channels in a single track. When importing these files, Pro Tools separates the data by channel and places each track’s data in separate clips and tracks.
• Type 1 MIDI files, sometimes referred to as multitrack MIDI files, contain multiple tracks of MIDI data. When importing these files, each track’s data is placed on its own new MIDI track in the Pro Tools session.

Importing MIDI Files Using Pro Tools Menu Commands

Pro Tools provides commands to import MIDI files.

To import Standard MIDI Files into a session or project using the Pro Tools File menu:

1. Choose File > Import > MIDI and select the file you want to import.
2. Configure the MIDI Import Options dialog as desired (see “MIDI Import Options Dialog” on page 413).
3. Click OK.

The MIDI file will be imported according to the settings in the Import MIDI Settings dialog.

If the Standard MIDI File contains markers, they are only imported if the current session does not contain any markers.
4 In the Mix window, click the MIDI Output selector for each new track and assign a MIDI instrument and channel.

**MIDI Import Options Dialog**

The MIDI Import Options dialog lets you specify what Pro Tools does when importing MIDI files.

![MIDI Import Options dialog](image)

**Destination**

The Destination options determine whether new tracks are created for imported MIDI or if MIDI is imported just to the Clips List.

- **New Track(s)**
  - **Instrument Track** Select this option to create new Instrument tracks for imported MIDI.
  - **MIDI Track** Select this option to create new MIDI tracks for imported MIDI.

- **Clip List**

**Location**

The Location options determine where imported MIDI is placed when the New Track(s) option is selected.

- **Session Start** Places the file or clip at the start of the session.
- **Song Start** Aligns the beginning of the file to the Song Start point.
- **Selection** Aligns the beginning of the file to the edit cursor or to the beginning of a selection in the Timeline.
- **Spot** Displays the Spot dialog, which lets you spot the file to a precise location based on any of the Time Scales.

**Additional Options**

- **Import Tempo Map From MIDI File** When selected, overwrites any existing tempo and meter map with tempo and meter information read from the MIDI file.
- **Import Key Signature From MIDI File** When selected, overwrites any existing key signatures with key signature information read from the MIDI file.
- **Remove Existing Instrument Tracks** When selected, deletes any existing Instrument tracks. Selecting this option does not remove any current MIDI tracks. All existing MIDI clips will be left in the Clips List.
Remove Existing MIDI Tracks When selected, deletes any existing MIDI tracks. Enabling this option does not remove any current Instrument tracks. All existing MIDI clips will be left in the Clips List.

Remove Existing MIDI Clips When selected, deletes existing MIDI clips (all data on all MIDI and Instrument tracks) but leaves existing MIDI and Instrument tracks in place.

Importing MIDI Files with Drag and Drop

You can drag and drop MIDI files from a Workspace browser, Windows Explorer, or Mac Finder to the Timeline, a track, the Tracks List, or the Clips List.

To import MIDI into the Clips List:
1. Select MIDI files in a Workspace browser, or Windows Explorer, or Mac Finder.
2. Drag the files onto the Clips List of the current session.

To import MIDI into an existing track:
1. Select MIDI files in a Workspace browser, Windows Explorer, or Mac Finder.
2. Drag the files onto an existing track in the Edit window of the current session.

To import MIDI into new tracks:
1. Select MIDI files in a Workspace browser, Windows Explorer or Mac Finder.
2. Do one of the following:
   - From the Workspace browser, Shift-drag the files anywhere in the Edit window of the current session.
   - Drag the files to the Timeline of the current session.

• Drag the files to the Tracks List.

For more information, see Chapter 17, “Workspace Browsers.”

Exporting MIDI Files

To export a session’s MIDI tracks for use in another MIDI application, or for playback with an external (hardware) MIDI sequencer, you can export Pro Tools MIDI and Instrument tracks as a Standard MIDI File.

MIDI can be exported from Pro Tools as a merged, single, multichannel track (Type 0), or as multiple tracks (Type 1).

If your Pro Tools session uses key signatures and meters, they are exported with the MIDI file.

To export all MIDI and Instrument tracks in the current session:
1. Make sure to unmute any MIDI tracks in the session that you want included in the exported MIDI file. (Or, conversely, mute any MIDI tracks you do not want included in the exported MIDI file.) For Instrument tracks, enable or disable the MIDI mute button (Instruments view).
2. Choose File > Export > MIDI. The Export MIDI Settings dialog opens.

Export MIDI Settings dialog
3 From the MIDI File Format pop-up menu, select 1 (multitrack) or 0 (single track).

4 If the Song Start time is different from the Session Start time, select Session Start or Song Start from the Location Reference pop-up menu.

5 Enable or disable the Apply Real-Time Properties option.

6 Click OK.

7 Specify a folder destination and name for the MIDI file.

8 Click Save.

Pro Tools exports all unmuted MIDI and Instrument tracks in the current session to a Standard MIDI File and writes it to your hard drive. Exported MIDI information includes notes, controller events, program changes, and System Exclusive data, as well as events for tempo, meter, and markers.

The SMPTE start time for the session or the song (depending on the selection from the Location Reference pop-up menu) is also exported. This ensures that the exported tracks, when played from another MIDI application, will align with the correct SMPTE frames, and also synchronize correctly to tape and video devices, or Pro Tools.

See your third-party MIDI sequencer documentation to determine whether it supports importing SMPTE start times from MIDI files.

**Items Not Exported with MIDI Files**

Mute automation and muted clips do not affect exported MIDI. As long as a MIDI track is not muted by clicking its Mute button, or an Instrument track is not muted by clicking its MIDI Mute button (Instruments view), all of its MIDI data is exported.

Chord symbols and chord diagrams are not exported with MIDI files.

When exporting MIDI files from Pro Tools, device assignments for tracks are not retained (though channel assignments are). If you export MIDI or Instrument tracks from Pro Tools and later re-import them, you will need to reassign the tracks to devices in your studio.

All playlist information for MIDI and Instrument tracks is lost when exporting. For example, tracks that previously contained dozens of MIDI clips will be flattened and only contain single clips after exporting and re-importing.

**Exporting Individual MIDI and Instrument Tracks**

You can also export individual MIDI and Instrument tracks as MIDI files. This can be useful for storing libraries of your favorite MIDI sequences or Sysex data (such as bulk or individual patch dumps for your external MIDI devices), or for importing MIDI into notation applications (other than Sibelius).

To export a single MIDI or Instrument track as a MIDI file:

1 Do one of the following:
   - Right-click the Track name of an unselected track in the Edit or Mix window, or in the Tracks List.
   - In the Tracks List, or Mix or Edit window, Command-Right-click (Mac) or Control-Right-click (Windows) the track name.
2 From the Right-click menu, select Export MIDI.
3 Set the Export MIDI settings in the Export MIDI Settings dialog.
4 Click OK.
5 In the Save dialog, type a name for the MIDI file, specify where you want to save it, and click Save.

Option-Right-click (Mac) or Alt-Right-click (Windows) to export all tracks to a single MIDI file.

To export all selected Pro Tools Instrument or MIDI tracks as a MIDI file:

1 Select the tracks you want to export to a MIDI file.
2 Right-click the Track name of one of the selected tracks in the Edit or Mix window, or in the Tracks List.
3 From the Right-click menu, select Export MIDI.
4 Set the Export MIDI settings.
5 Click OK.
6 In the Save dialog, type a name for the MIDI file, specify where you want to save it, and click Save.

Sibelius 5.x or higher is required to open .sib files exported from Pro Tools.

Exporting Sibelius Files

Pro Tools can export the score of your session or project as a Sibelius file (.sib). You can choose to export the score as a Sibelius file for later use or score transfer, or to open the score in Sibelius immediately (if Sibelius) is installed on your computer. Sibelius uses the Pro Tools transcription of MIDI in your session as seen in the Pro Tools Score Editor window (for more information, see “Exporting Scores” on page 826).

Importing Session Data

You can import data and copy media from other Pro Tools sessions into the current Pro Tools session or project using the Import Session Data command (or drag and drop). You can also import data into sessions from versions of projects by means of the Revision History window. The Import Session Data dialog lets you import tracks and select specific session data (such as automation and routing) to import. You can also import main playlist options—either replacing existing options or overlaying elements onto existing tracks.

To import tracks or their attributes:

1 Open or create a new session or project.
2 Do one of the following:
   • Choose File > Import > Session Data, select the session to import data from, and click Open.
   • Drag the session file whose tracks or attributes you want to import from a Workspace browser, Windows Explorer, or Mac Finder into empty space in the Edit window or to the Tracks List.

Option-Shift-Right-click (Mac) or Alt-Shift-Right-click (Windows) to export all selected tracks as a single MIDI file.
3 If the Fader Gain setting of the session is different, you will be prompted to keep or change the Fader Gain before the Session Data dialog opens.

4 In the Source section, select tracks to import by clicking the pop-up menu to the right of each track name and selecting New Track.

To select multiple tracks, Opt-click (Mac) or Alt-click (Windows) on any track pop-up menu and select Import As New Track.

If the destination Pro Tools system does not support surround mixing, surround tracks are not displayed in the Source Tracks List.

5 For each track you select, you can choose to import it as a new track, or choose a destination track from the corresponding pop-up menu. Click Match Tracks to automatically match source and destination tracks with the same names.

6 Select any additional track data you want to import from the Track Data to Import pop-up menu.

7 Select from among the Main Playlist Options to choose how you want to import the source tracks.

8 If applicable, choose options for how media files should be imported from the Audio Media Options and the Video Media Options pop-up menus.

Any tracks in a project containing media linked to a local source file cannot be shared.

9 Choose the Timecode Mapping Options for imported data.

10 If the sample rates of the sessions are different, select the sample rate for the source session from the Source Sample Rate pop-up menu.

11 To import the meter and tempo maps from the source session, select the Import Tempo/Meter Map option.

12 To import key signatures from the source session, select the Import Key Signature Map option.

13 To import Markers and Memory Locations from the source session, select the Import Marker/Memory Locations option.

14 To import Window Configurations, select the Import Window Configurations option.

15 With Pro Tools Ultimate, select the Import Mic Pre Settings option to import any Mic Pre settings from the source session.

16 Click OK when you are finished.

17 If you chose to copy or consolidate media, choose a location to place the media files.

Imported tracks are made inactive if their source media is unavailable, or if the current session does not contain an equivalent output path.

Importing Grouped Playlists from Other Sessions

You can import tracks that use Grouped Playlists from another Pro Tools session, and the playlist grouping function will remain intact for those imported tracks. There is, however, a restriction for importing from pre-Pro Tools 6.1 sessions: After importing a partial set of grouped playlists (such as tracks 1–7 of a 10-track group), you cannot subsequently import tracks 8–10 and have them rejoin the playlist group for tracks 1–7.
Importing Sessions and Tracks by Drag and Drop

Session files can be dragged into the current session or project to import (and spot) audio, video, MIDI, clip group, REX and ACID files, tracks, and session data.

- Dragging a session to the Clips List imports all the clips from that session (without importing tracks).
- Dragging a session to a track in Pro Tools lets you import tracks.
- Dragging a session to a track playlist in Pro Tools opens the Import Session Data dialog, letting you select tracks and attributes to import. The imported session data will begin wherever you drop the session in the Timeline.

To import tracks and other session data by drag and drop:

1. Open a Workspace browser.
2. Drag a Pro Tools session file, or an AAF or OMF sequence, into the current session, as follows:
   - Drag onto an existing track to overlay or overwrite data on the target tracks. Hold the Shift key while dragging if you intend to replace the current track playlists with those being imported (the Shift key pre-configures the settings in the Import Session Data dialog).
   - Drag to empty space in the Edit window to create new tracks for the imported session data.
   - Configure the Import Session Data options (see “Import Session Data Dialog” on page 419).

Copying During Import

If no conversion is necessary, and the files reside on a suitable Performance volume, Pro Tools references the original version of the media. You can also choose to copy media while importing by using key commands, or enabling the Automatically Copy Files on Import preference. Copies are created in the session’s Audio Files Folder or, for projects, uploaded to the cloud.

To manually copy files on import:

- Option-drag (Mac) or Alt-drag (Windows) the files. A copy is created in the session Audio Files folder or, for projects, uploaded to the cloud.

When importing sessions or tracks, the Import Session Data dialog lets you specify whether to reference the source media, or copy it.

To automatically copy files on import:

1. Choose Setup > Preferences, and click the Processing tab.
2. Select Automatically Copy Files on Import.
3. Click OK to close the Preferences dialog.

Using Undo after Importing

Using Undo after importing any files to the Timeline removes the files from the Timeline. However, the files remain in the session or project (in the Clips List and Workspace browser) and are offline. If you do not remove or delete the files from the session or project manually, Pro Tools will report them as missing files the next time the session or project is opened.
Import Session Data Dialog

The Import Session Data dialog lets you view the properties of the source session, select which tracks to import, and with Pro Tools Ultimate, choose which attributes of those tracks you want to import into the current session or project.

Source Properties

The Import Session Data dialog displays properties for the source session. These properties include source session name, session type, start time of the session, audio bit depth, and sample rate. For Pro Tools 5.1 or higher sessions, the program that created the session and the session’s audio file type are listed.

Text Encoding

Pro Tools allows entry and display of any language characters supported in Unicode anywhere in the Pro Tools application. This lets you use multiple languages in session names, and in path names, file names and clip names.

However, Pro Tools 7.3.x and lower does not support Unicode. When importing data from sessions or OMF sequences created or saved with older versions of Pro Tools, you may need to identify the language encoding used in the imported elements.

To choose the language encoding when importing data from a legacy Pro Tools session:

1. Choose File > Import > Session Data.
2. Choose the language used in the legacy session from the Text Encoding pop-up menu.

Audio Media Options

The following Audio Media Options are available in the Import Session Data dialog:

Link to Source Media (Where Possible) This option lets you avoid duplicating audio files by referring to the original files when possible. If the source files do not reside on supported playback media (such as a CDs or DVDs), or if they require bit depth or sample rate conversion, the source files are copied instead. This option allows the current session or project to refer to files that do not match the current session or project audio file format.

Projects can link to media files on the local system that are stored outside of the project bundle. In this case, linked media it will still sync to the cloud, but it will not be copied to the local project media cache.
**Copy from Source Media** This option copies all audio files related to the imported tracks from the source media to a new specified location (for sessions) or to the cloud (for projects), and converts the files to the current session or project sample rate if necessary. The source media’s audio file format and bit depth are not changed. This is useful if you are importing tracks from a source such as CD or DVDs or shared storage, and you want to place the audio files on a different hard drive.

**Consolidate from Source Media** This option consolidates audio while copying it. This is useful if you want to copy only the clips of the audio files used in the source tracks, without copying unused audio. This option copies and converts consolidated audio to the current session or project audio file format, bit depth, and sample rate if necessary.

When you choose this option, you can also choose the **Handle Size** (in milliseconds) applied to consolidated audio. **Handle** is the amount of the original audio file that is preserved before and after each clip in case you need to make any edits (such as applying fades or trimming) to the new clips.

⚠️ **Consolidate From Source Media is not available when importing Elastic Audio tracks.**

**Force to Target Session Format** This option copies and converts all source media files to the current session or project file format, bit depth, and sample rate. Files are copied even if they already match the current session or project format.

---

**Video Media Options**

In the Import Session Data dialog, you can either choose to leave video media files in their original locations or copy them to a new location. This is useful if you are importing tracks from a source such as CDs or DVDs or shared storage, and you want to place video files on a different drive.

**Link to Source Media**

Select this option to avoid duplicating video files by referring to the original files.

**Copy from Source Media**

Select this setting to copy all video files related to the imported tracks from the source media to a new specified location.

**Import as Offline Satellite Media** *(Pro Tools | Ultimate Software Only)*

Select this option to import a video track with offline media. You will be able to see cuts and clip names, but the video media remains offline. You can view the video media on a connected Video Satellite system. This option is only available when New Satellite Track is selected for the video track.
Timecode Mapping Options

In the Import Session Data dialog, you can specify where the imported tracks are placed in the current session. Times are indicated in timecode.

The following Timecode Mapping Options are available:

**Maintain Absolute Timecode Values** This option places tracks at the locations where they were located in the source session. For example, if the current session starts at 00:01:00:00, and the session from which you are importing starts at 10:00:00:00, the earliest imported tracks can appear in your session is 9 hours and 59 minutes after the start of the session.

**Maintain Relative Timecode Values** This option places tracks at the same offset from session start as they had in the source session. For example, if the source session starts at 01:00:00:00 and contains a track that starts at 01:01:00:00, and the current session start is 02:00:00:00, the track will be placed at 02:01:00:00 in the current session.

**Map Start Timecode To** This option places tracks relative to their original session start time. (Times are expressed in hh:mm:ss:ff) For example, if the current session starts at 00:01:00:00, and the session from which you are importing starts at 10:00:00:00, you can reset the start timecode to 00:01:00:00, to avoid placing files 9 hours and 59 minutes from the start of your session.

**Adjust Session Start Time to Match Source Start Time**

When selected, the Adjust Session Start Time to Match Source Start Time option lets you automatically set the start time of the current Pro Tools session to match the start time of the session, or AAF or OMF sequence you are importing.

Track Offset Options

In the Import Session Data dialog, you can specify a track offset in addition to any offset incurred with the Timecode Mapping Options. Any imported audio is offset in the current session or project Timeline by the specified amount. You can enter values in Minutes:Seconds, Bars|Beats, Samples, Timecode, or Feet/Frames.

Sample Rate Conversion (SRC) Options

In the Import Session Data dialog, you can set options that control how sample rate conversion is applied to imported audio files. If the source session and the current session have the same sample rate, this portion of the dialog is unavailable.

The following Sample Rate Conversion (SRC) Options are available:

**Source Sample Rate** For audio files created in any session, no matter what the session sample rate is, you can have the sample rate conversion process treat the files in several ways to compensate for pull up, pull down, and NTSC or PAL frame rates. This setting allows you to choose the sample rate from which you want the sample rate conversion process to start.

**Destination Sample Rate** The destination sample rate is always set to the sample rate of your current session.

**Conversion Quality** This option lets you set the quality of the sample-rate conversion process (see “Sample Rate Conversion Quality” on page 399).
Source Tracks

This area of the Import Session Data dialog lists the tracks in the source session that can be imported, each with a corresponding pop-up menu.

Operation/Destination Track Pop-Up Menus

In the Import Session Data dialog, each source track has a corresponding pop-up menu that lists options for importing the track as well as for possible destination tracks in the current session or project. The pop-up menus display the following items:

Do Not Import Neither the source track nor any of its attributes are imported.

Import as New Track The source track and all attributes selected in the Track Data to Import pop-up menu are imported into a new track in the current session or project.

Destination Track Names The names of possible destination tracks in the current session or project are listed at the bottom of the pop-up menu. Imported playlists and all attributes selected in the Track Data to Import pop-up menu will be placed in the destination track you select.

Only destination tracks that match the track type (audio, Instrument, MIDI, Auxiliary Input, or Master Fader) and the channel format (mono, stereo, or any of the supported multichannel formats) of the source track appear in the pop-up menu.

Matching Tracks

In the Import Session Data dialog, you can make sure track names match when you are importing playlists from source tracks with the same name as destination tracks in the current session or project (such as a new cut of a scene). Click Matching Tracks to automatically match the track names. Tracks must have the same name, track type, and channel format to be automatically matched.

Track Data to Import

Available through the Import Session Data dialog, the Track Data to Import dialog lets you select which attributes of the selected tracks you want to import into the current session or project.

Selected attributes are applied to all tracks that you choose to import into the current session or project.

Replacing Track Attributes

When you import an attribute of the source track into an existing track in the current session or project, it replaces the corresponding attribute in the destination track. If you choose not to import an attribute of the source track, the corresponding attribute in the destination track is retained.

Replacing Track Path Names

When you import a track’s input, output, send output or hardware insert assignments, any custom path names and I/O configurations from the source session are not imported. You can import path names and I/O configurations by importing I/O Setup settings. For more information, see “Factory I/O Settings” on page 81.
Selecting Track Data to Import

To select what Track Data to import:

1. In the Import Session Data dialog, click the Choose button for Track Data to Import.

2. Configure the Track Data to Import dialog as desired.

3. Click OK.

Pro Tools lets you include (or exclude) the following Track Data with Track Presets:

**Alternate Playlists** Recalls all of the alternate playlists from source tracks. The alternate playlists appear in the playlist selector of destination tracks.

**Clips and Media** Recalls all of the audio files or clips in the source track, and places them in the Clips List.

**Clip Gain** Recalls the clip gain settings for all imported audio clips.

**Clip Effects** Recalls the clip effects settings for all imported audio clips.

**Main Volume Automation and Setting** Recalls the source track’s Volume fader setting and any automation data on the track’s Volume Automation playlist. The Volume fader setting and any Volume automation data in the destination track are replaced.

**Main Pan Automation and Setting** Recalls the source track’s Pan Slider settings and any automation data on the track’s Pan Automation playlist. The Pan Slider setting and any Pan automation data in the destination track are replaced.

**Main Mute Automation and Setting** Recalls the source track’s Mute setting and any automation data on the track’s Mute automation playlist. The Mute setting and any Mute automation data in the destination track are replaced.

**Main Output Assignments** Recalls the source track’s channel output assignments, including any multiple output assignments. The channel output assignments in the destination track are replaced.

**Send Volume Automation and Setting** Recalls the Volume fader setting and any automation data for sends on the source track. The Volume fader setting and any Volume automation data for sends in the destination track are replaced.

**Send Pan Automation and Setting** Recalls the Pan slider setting and any automation data for sends on the source track. The Pan slider setting and any Pan automation data for sends in the destination track are replaced.

**Send Mute Automation and Setting** Recalls the Mute setting and any Mute automation data on the source track. The Mute setting and any Mute automation data in the destination track are replaced.
**Send Output Assignments** Recalls the source track’s send output assignments. Any Send output assignments in the destination track are replaced.

**Plug-In Assignments** Recalls the source track’s plug-in assignments. Any plug-ins in the destination track are removed, and their associated settings and automation are lost.

If the source track uses a plug-in that is not available on the destination system, it appears in the destination track and is made inactive.

**Plug-In Settings and Automation** When the source track’s plug-in assignments are recalled, this option imports the track’s plug-in settings and any automation data associated with the plug-ins. If no plug-in assignments are imported, this option has no effect.

**Elastic Audio Track State** Recalls the source track’s Elastic Audio track state. Any Elastic Audio settings in the destination track are replaced.

**HW Insert Assignments** Recalls the source track’s hardware Insert assignments. Any Insert assignments in the destination track are replaced.

**Voice Assignments** Recalls the source track’s voice assignment from the source session. Any voice assignments in the destination track are replaced.

**Input Assignments** Recalls the source track’s channel input assignment. The Input assignment in the destination track is replaced.

**Side-Chain Assignments** When the source track’s plug-in assignments are recalled, this option imports any side-chain assignments associated with the plug-ins. If no plug-in assignments are imported, this option has no effect.

**Track Active State** Recalls the active/inactive state of the source track from the source session.

**Track Comments** Recalls the track comments associated with the source track. Any comments in the destination track are replaced.

**Track Colors** Recalls the track color associated with the source track. Any color for the destination track is changed.

**Record Safe/Solo Safe Settings** Recalls the record safe and solo safe settings of the source track from the source session. Any record safe or solo safe settings in the destination track are replaced.

**Track View Settings** Recalls the track height and playlist view of the source track from the source session.

**Mix/Edit Groups** Recalls track groups from the source session.

**ICON Custom Fader Groups (Pro Tools | Ultimate Only)** Recalls any ICON Custom Fader Groups from the source session.

**ICON Automation Snapshots (Pro Tools | Ultimate Only)** Recalls any ICON Automation Snapshots from the source session.

**HEAT Switch Settings (Pro Tools | Ultimate with the HEAT Software Option Only)** Recalls any stored HEAT switch settings from the source session.

**Object Assignment and Toggle Setting (Pro Tools | Ultimate with Dolby Atmos Only)** Recalls Object Output Path assignments and Bus/Object toggle settings for any tracks selected for import.

**Track Data to Import Presets**

Pro Tools lets you store and recall different configurations of the Track Data to Import dialog as presets. The Presets controls for the Track Data to Import dialog work much like the Presets controls for Batch Renaming, Fades, and Clip Effects.
Presets Buttons

The Track Data to Import dialog provides five Presets buttons that let you store and recall your most commonly used Track Data to Import configurations. You can also save and import Track Data to Import settings using the Librarian menu.

To store a Track Data to Import preset:

1. Configure the Track Data to Import dialog as you like.
2. Command-click (Mac) or Control-click (Windows) the Presets button where you want to store the current Track Data to Import settings.

To recall a Track Data to Import preset:

- Click the Presets button that contains the settings you want to recall.

Librarian Menu

Use the Librarian menu to save and recall presets files (.ptpreset). These are usually saved to and recalled from the Track Data to Import folder (/Documents/Pro Tools/Pro Tools Presets/Track Data to Import/). However, you can save to and import from any directory location on your system. Preset files can be shared and used on any other Pro Tools system as well.

The Librarian menu commands include:

<factory default> Restores the default settings for the Track Data to Import dialog.

Save Settings Saves the current settings. This command overwrites any previous version of the preset.

Press Command+Shift+S (Mac) or Control+Shift+S (Windows) to save the current settings.

Save Settings As Saves the current settings as a new preset. You can name the preset and save it to any location on your system.

Import Settings Opens the Choose a Settings File dialog focused on the default Track Data to Import folder. Track Data to Import Settings file stored in this location are listed by name under <factory default> in the Librarian menu. In the Choose a Settings File dialog, you can navigate to any location on your system to select and import the Track Data to Import Settings preset file you want.

Delete Current Settings File Permanently deletes the current settings file from disk.

Lock (Unlock) Settings File Locks (or unlocks) the selected Settings file so that it cannot (or can) be edited.

Import Options

The following Import Options are available in the Import Session Data dialog:

Import Tempo/Meter Map Imports the meter and tempo maps, as they appear in the Tempo and Meter Conductor rulers, from the source session. Any Tempo or Meter events in the destination session or project are replaced.

Import Key Signature/Chord Map Imports all key signatures (if present) and chord markers into Pro Tools with the imported session data. Any key signatures and chord markers in the destination session or project are replaced.

Import Marker/Memory Locations Imports markers and Memory Locations as they appear in the Marker ruler, from the source session. Any markers and Memory Locations in the destination session or project are retained. Imported marker and Memory Locations are assigned the next available Marker/Memory Location numbers.

Import Window Configurations Imports the Window Configurations from the source session.
**Import Mic Pre Settings** Imports any Pro Tools Mic Pre settings from the source session. Any Mic Pre settings in the destination session or project are replaced.

**Import HEAT Master Settings** *(Pro Tools | Ultimate with the HEAT Software Option Only)* Imports any HEAT Master settings from the source session, including Bypass, Drive, and Tone settings. The HEAT Master settings in the destination session or project are replaced.

**Main Playlist Options**

In the Import Session Data dialog, you can select from the following options to control how the main playlist from each source track is imported to the destination track in the current session or project.

**Import – Replace Existing Playlists** Imports the main playlist from the source track. When you import the playlist into an existing track, the main playlist in the destination track is deleted and replaced with the imported playlist.

- If you select this option and import all of the source track’s attributes, this is equivalent to importing the entire track.

- If you select this option and do not import any of the source track’s attributes, you replace the audio playlists while keeping your current mixer settings.

**Import – Overlay New On Existing Playlists** Imports the main playlist from the source track. When you import the playlist into an existing track, any existing playlist data that overlaps data imported from the source track is trimmed and replaced with the imported data. Any playlist data in the destination track that does not overlap remains in the destination track.

**Do Not Import** Does not import the main playlist from the source track. No audio is imported; only the attributes selected in the Track Data to Import list are imported to the selected tracks. When selected, importing all of the source track’s input, output, send, insert and plug-in attributes is equivalent to importing a channel strip.

---

**Importing AAF and OMF Sequences**

Pro Tools lets you open AAF and OMF sequences as new Pro Tools sessions or projects, or you can import AAF and OMF sequences into existing Pro Tools sessions and projects. Pro Tools can import AAF and OMF sequences exported from other Pro Tools sessions or projects, from Avid Media Composer, or from third-party applications (such as Final Cut Pro, Logic Audio, Adobe Premiere Pro, and Nuendo—consult your third-party application’s documentation for information on how they handle OMF and AAF export).

When importing AAF sequences generated from an Avid video editing application, Pro Tools can import mono, stereo, and 5.1 and 7.1 surround audio tracks. Mono tracks with 5.1 or 7.1 surround panning can also be imported, with panning information intact. (Greater-than-stereo multichannel formats are supported with Pro Tools Ultimate only.)

When opening and importing an AAF or OMF sequence, a modified version of the Dashboard window opens and prompts you to name and save the sequence as a new session or project. Once you name and save the new session or project, the Import Session Data dialog opens. For more information, see “AAF/OMF Source Track Translation Settings” on page 434.
Pro Tools can import the following types of files sourced from Avid editors:

- AAF or OMF sequences (including those with embedded audio)
- Individual Avid video files in the MXF or OMF format
- OMF and MXF audio files

⚠ Multi-channel import and export are only possible with AAF sequences.

⚠ Avid Mojo SDI or Avid Mojo is required for importing MXF and OMF video.

To import AAF or OMF sequences into Pro Tools, do one of the following:

- Use the File > Import > Session Data command.
- Use the File > Open Session command.
- Drag and drop them from any Workspace browser or the desktop.

For more information, see “Importing an AAF or OMF Sequence into an Existing Session or Project” on page 429.

To import individual Avid MXF or OMF video files into Pro Tools, do one of the following:

- Use the File > Import > Video command.
- Drag and drop them from any Workspace browser or the desktop.

To import individual OMF or MXF audio files into Pro Tools, do one of the following:

- Use the File > Import > Audio command.
- Drag and drop them from any Workspace browser or the desktop.

⚠ Pro Tools cannot play video files embedded within an AAF or OMF sequence.

Importing an AAF or OMF Sequence as a Pro Tools Session

The easiest way of using Pro Tools to edit a sequence exported from an Avid application (such as Media Composer) is to open it as a new session or project.

To open and import an AAF or OMF sequence in Pro Tools:

1. Launch Pro Tools.
2. Choose File > Open Session.
3. In the Open Session dialog, navigate to the AAF or OMF sequence you want to import.
4. Click Open.

5. Set Type to Project (cloud) or Session (local).
6. Name your session or project.
7. Select the Audio File Type, Sample Rate, and Bit Depth to use for the session.
8. To create interleaved multichannel audio files in the session, select Interleaved.
9. Click OK.
10 Click Save. The Import Session Data dialog opens.

You can open and import OMF or AAF sequences that reference audio files with mixed sample rates or bit depths.

11 Select an option for importing audio from the Audio Media Options pop-up menu (see “Audio Media Options” on page 431).

12 Select an option for importing video from the Video Media Options pop-up menu (see “Video Media Options” on page 432).

13 Change other settings and options as necessary (see “Import Options when Importing AAF or OMF Sequences” on page 431).

14 Click OK.

Pro Tools creates a new online project or a new local session file in the location you specified, along with the following new items (sessions only):
- Audio Files folder
- Clip Groups folder
- Session File Backups folder
- Video Files folder
- cache.wfm file

This session or project will match the audio file type, sample rate, and bit depth of the audio in the OMF or AAF you selected. Pro Tools does not import video embedded in a sequence.

If a Video Satellite system is available, Pro Tools can import the video metadata from a sequence to a satellite track. In this case, the video itself is played back from the Video Satellite machine, in tandem with Pro Tools playback.

For more information, see Chapter 63, “Avid Video Satellite.”

During the import, if there are any errors, clip name truncations, or other notes (such as missing effect renderings), a dialog appears asking you if you want a detailed report of the changes. Click Yes and choose where you want to save the log. The log is a text file that you can open in any text editing application.

Every AAF and OMF file has a filename and unique identifier stored in the AAF and OMF metadata, and a name which is displayed on the desktop. Truncating a clip name in the translation process does not change the AAF or OMF filename, Unique ID, or SMPTE ID (only Pro Tools 12.8 and higher generate and recognize both Unique ID and SMPTE ID for AIFF and WAV files).
Multi-Cam Resolution Files

On an Avid system, Multi-Cam Resolution files display multiple individual camera angles of the same scene. The Avid operator chooses which of the Multi-Cam files (and therefore camera angles) will be dominant, at the time of creating an AAF or OMF export. When you import an AAF or OMF sequence into a Pro Tools session, only the clip representing the dominant camera angle will be displayed.

Importing an AAF or OMF Sequence into an Existing Session or Project

You can import an AAF or OMF sequence containing audio and video media into an existing Pro Tools session or project.

To open and import audio and/or video tracks from an OMF or AAF sequence:

1 Launch Pro Tools, and open an existing Pro Tools session or project.

2 Choose File > Import > Session Data, and select the AAF or OMF sequence that you want to import.

3 In the Import Session Data dialog, deselect any source tracks that you do not want imported. (If importing Session Data from AAF or OMF sequences, all tracks are selected by default. However, if you are importing tracks from a Pro Tools session, no tracks are selected by default.)

Source Tracks

4 Select the AAF/OMF translation settings (see “AAF/OMF Source Track Translation Settings” on page 434).

5 Select the Audio Media Options (see “Audio Media Options” on page 431).

6 Select the Video Media Options (see “Video Media Options” on page 432).

7 Select the Timecode Mapping Options (see “Timecode Mapping Options” on page 432).

8 Set the Track Offset Options (see “Track Offset Options” on page 433).

9 Set the Sample Rate Convert Options (see “Sample Rate Conversion Options” on page 433).

10 Change other settings and options as necessary (for more information about the Import Session Data dialog, see “Import Session Data Dialog” on page 419).

11 Click OK.

⚠️ If there are any errors or clip name truncations, a dialog will appear asking you if you want a detailed report of the changes. Click Yes and choose where you want to save the log.

12 If your audio or video source media is on a volume that is not suitable for playback (shown as a Transfer volume in the Workspace browser), Pro Tools displays a dialog that guides you to copy the media to a volume designated for Playback or Record. (Click Yes.)
Pro Tools imports the audio and video media to the Timeline. Audio tracks with mixed sample rates are automatically converted to the same sample rate as the session.

**Importing AAF/OMF Audio Sequences with Mixed Sample Rates or Bit Depth**

You can open and import AAF or OMF sequences with mixed sample rates and bit depths into Pro Tools.

Audio files that are not of the same sample rate as a session or project must be converted to be used with the session or project. When an audio file is converted, a new file with the correct file type, and sample rate is created and placed in a folder you choose. Audio files with mixed bit depths (and matching sample rates) can be imported without conversion.

You can use the Source Sample Rate settings to compensate for any pull up or pull down factors that may have been applied to the audio prior to importing. In a sequence with files of mixed sample rates, set the Source Sample Rate in proportion to the Target sample rate of the session, and the pull up or pull down compensation will be applied correctly to all files in proportion with their original sample rate.

**Importing Audio from AAF Sequences with Unsupported Video Formats**

Pro Tools lets you import audio from AAF sequences containing unsupported video formats, including high-definition Avid video files with frame rates over 30 frames per second.

The following rules apply when importing AAF sequences of this type:

- Supported audio in these sequences will play back, but unsupported video will not.
- Unsupported video appears in the Timeline as orange blocks.

**Importing AAF/OMF Sequences Containing Media Mixdowns**

Pro Tools with an Avid video peripheral lets you import AAF and OMF sequences exported from Avid editing applications by selecting File > Import > Session Data or by dragging them from the desktop or a Workspace browser to Pro Tools. For more information, see “Importing Session Data” on page 416.

If the sequence contains a video mixdown, the video mixdown and its corresponding metadata are displayed in two separate video tracks on the Timeline.

If the sequence contains an audio mixdown, the audio mixdown and its corresponding metadata are displayed in two separate video tracks on the Timeline.
**SMPTE ID and Unique ID**

Pro Tools recognizes and creates two different unique IDs for media files (AIFF and WAV only): Unique ID and SMPTE ID. SMPTE ID (Pro Tools 12.8 and higher only) provides optimal compatibility and interchange with other applications that utilize SMPTE IDs in media files and AAF sequences (such as Avid Media Composer), and ensures truly unique IDs for AIFF and WAV files.

**8-bit Unique ID** Legacy ID format used with versions of Pro Tools lower that 12.8.

**SMPTE ID** 32-bit SMPTE IDs created and supported with Pro Tools 12.8 or higher.

---

**Import Options when Importing AAF or OMF Sequences**

When importing AAF or OMF sequences, Pro Tools provides the following import options through the Import Session Data dialog:

- Audio Media options
- Video Media options
- Timecode Mapping options
- Track Offset options
- Sample Rate Conversion options
- AAF/OMF Source Track Translation settings
- Main Playlist options

**Audio Media Options**

When importing AAF or OMF tracks into Pro Tools, use the Audio Media Options pop-up to select whether to copy, consolidate, or link to the source audio media.

**Link to Source Audio Media (Where Possible)**

Select this option to translate the AAF or OMF file to a Pro Tools session that refers to as many of the original media files as possible. In this case, the Pro Tools session points to the BWF (WAV) or AIF files from the source project.

When importing audio embedded in an AAF sequence, Pro Tools copies the audio to a new drive or folder even if this setting is selected.

For projects, you should always copy or consolidate from source media. Any tracks in a project that contain linked local media cannot be shared.

**Copy from Source Media**

Use this setting to copy referenced audio to a new drive or folder.

You can perform sample rate conversion on audio during translation.

**OMFI Audio Media and Copy from Source Media Mode**

When importing an AAF or OMF sequence with the Copy from Source Media option enabled, Pro Tools can copy OMFI format .WAV and .AIF audio files directly into the session. However, Pro Tools treats OMFI audio files as read-only.

Destructive edits or processes (such as the Pencil tool) cannot be applied to these files, unless they are first converted into standard audio files.

**To convert OMFI audio files during import:**

- Choose Force to Target Format mode, rather than Copy from Source Media mode, when setting import options. For more information, see “Force to Target Session Format” on page 432.
To convert an OMFI audio file that exists in the current session or project:

1. Select the audio to be converted.
2. Apply the Consolidate command to convert the selected audio (Edit > Consolidate Clip).
3. Edit and process your newly converted files as normal.

Consolidate from Source Media

Use this setting to copy the audio from the source sequence to the Pro Tools session or project, while removing all unused areas in the copies. For example, you might only be using ten seconds of a ten-minute audio file in your project. Consolidating this audio saves a great deal of disk space by preserving only the audio you use and a user-defined amount of handle, and discarding the rest.

You can sample-rate convert the audio during translation.

Force to Target Session Format

Use this setting to convert source media to the session audio file format if the source media file format differs from the project or session file format.

Handle Size (Milliseconds)

If you have selected Consolidate from Source Media, you can specify the number of milliseconds of each original audio file to retain both before and after the clip boundaries defined in the source project. This enables you to extend clip boundaries even after you’ve consolidated, by the amount you specify.

It is a good idea to have at least 1000 milliseconds of handle, so you can “trim out” edits that sound “clipped” or “up-cut.”

Video Media Options

When importing AAF or OMF tracks into Pro Tools, use the pop-up menu in the Video Media Options section to copy or link to the source video media.

Link to Source Media

Select this option to avoid duplicating video files by referring to the original files.

Copy from Source Media

Select this setting to copy all video files related to the imported tracks from the source media to a new specified location.

Import as Offline Satellite Media

(Pro Tools | Ultimate Software Only)

Select this option to import a video track with offline media. You will be able to see cuts and clip names, but the video media remains offline. You can view the video media on the connected Video Satellite system. This option is only available when New Satellite Track is selected for the video track.

Timecode Mapping Options

When importing AAF or OMF tracks into Pro Tools, you can specify where the imported tracks are placed in the current session. Times are indicated in timecode.

Maintain Absolute Timecode Values

This option places tracks at the locations where they were located in the source session. For example, if the current session starts at 00:01:00:00, and the session from which you are importing starts at 10:00:00:00, the earliest imported tracks can appear in your session is 9 hours and 59 minutes after the start of the session.
Maintain Relative Timecode Values

This option places tracks at the same offset from session start as they had in the source session. For example, if the source session starts at 01:00:00:00 and a contains a track that starts at 01:01:00:00, and the current session start is 02:00:00:00, the track will be placed at 02:01:00:00 in the current session.

Map Start Timecode to hh:mm:ss:ff

This option places tracks relative to their original session start time. For example, if the current session starts at 00:01:00:00, and the session from which you are importing starts at 10:00:00:00, you can reset the start timecode to 00:01:00:00, to avoid placing files 9 hours and 59 minutes from the start of your session.

Adjust Session Start Time to Match Source Start Time

This option changes the start time of the current session to match the start time of the AAF or OMF sequence being imported. When this option is enabled, the Map Start Timecode to hh:mm:ss:ff option (and its timecode entry box) are disabled.

⚠️ If the sequence being imported has a later start time than the current session or project, the Maintain Absolute Timecode Values option is disabled.

⚠️ In some cases, when clips in the current session or project are situated near the time boundaries of the session or project, enabling Adjust Session Start Time and choosing to Maintain Relative Timecode Values can put clips in danger of being moved out of bounds. In these cases, a warning is displayed and Pro Tools does not adjust the session start time.

Track Offset Options

When importing AAF or OMF tracks into Pro Tools, specify a track offset in addition to any offset incurred with the Timecode Mapping options. Any imported audio is offset in the current session’s timeline by the specified amount. Values can be entered in Bars|Beats, Min:Sec, Timecode, Feet+Frames, or Samples.

Sample Rate Conversion Options

When importing AAF or OMF tracks into Pro Tools, these settings let you convert the sample rate of the session’s audio files. For example, you can convert from 48 kHz to 44.1 kHz, or from 44.1 kHz to 48 kHz. HDX and HD Native systems support sample rates higher than 48 kHz (88.2 kHz, 96 kHz, 176.4 kHz, and 192 kHz). These settings also enable you to convert to compensate for the 0.1% speed change (pull up or pull down) between 24 fps film and 29.97 fps NTSC video, or the 4% speed change (pull up or pull down) between 24 fps film and 25 fps PAL video.

⚠️ See “Speed Correction for Film, NTSC Video, and PAL Video” on page 1294 for information about converting between different speeds and sample rates.

Source Sample Rate

This setting lets you specify the sample rate of the audio material you are working with in Pro Tools independently of the source audio sample rate settings.

For example, you may receive a a sequence created on Media Composer at 44.1 kHz. If you want to work at 48 kHz in Pro Tools, you should set the Source Audio Sample Rate setting to 44,100 and the Destination Audio Sample Rate to 48,000.
These settings can also be used to correct for pull up or pull down problems. For example, you may receive an AAF or OMF transfer from a Film Composer that contains audio media at “film speed” when played back at 48 kHz. You may want to convert all the audio files and edits to play back at NTSC video speed and 48 kHz.

In this case, set the Source Audio Sample Rate setting to 47,952 and the Destination Audio Sample Rate to 48,000. These settings tell Pro Tools that you want to fit 47,952 of the original “film speed” samples into 48,000 of the new “video speed” samples. With these settings, you sample-rate-convert the material to NTSC video speed.

You can set the Source Audio Sample Rate either by selecting one of the predefined sample rates from the pop-up menu, or by typing a value into the text box.

**Destination Sample Rate**

This setting determines the target session or project audio sample rate setting, as shown in the Session Setup window, and the sample rate of all audio files in the target session or project. Available settings include Pro Tools standard sample rates of 44.1 kHz or 48 kHz. HDX and HD Native systems support sample rates higher than 48 kHz (88.2 kHz, 96 kHz, 176.4 kHz, and 192 kHz).

If this setting differs from the Source Audio Sample Rate setting, audio is sample-rate converted digitally to the Destination Audio Sample Rate.

**Conversion Quality Pop-Up Menu**

This pop-up menu lets you select settings corresponding to Pro Tools sample rate conversion settings. The Tweak Head (Slowest) option provides the best results.

---

**AAF/OMF Source Track Translation Settings**

Pro Tools provides specific options for “translating” audio clips when importing AAF sequences or OMF files and sequences.

**Import Rendered Audio Effects**

Enabling the Import Rendered Audio Effects option imports clips as audio clips, retaining the rendered effects (such as EQ) that were applied to the clip. You may want to disable this if you plan to use Pro Tools audio effects and audio processing exclusively for your audio post production work. The resulting audio with this setting disabled is the unprocessed source material.

**Import Clip Gain**

The Import Clip Gain setting lets you import clip-based gain settings, or ignore clip-based gain entirely. Media Composer and other Avid products provide clip-based gain to adjust the volume of an individual audio clip.

Clip-based gain differs from standard Pro Tools volume adjustments for an entire track, or volume breakpoint automation. Enable this option to import clip-based gain data from the incoming sequence.

**Import Volume Automation**

The Import Volume Automation setting lets you import volume breakpoint automation, or ignore it entirely. Media Composer and other Avid products provide volume automation, for continuous volume change throughout a sequence.
Pan Odd Tracks Left/Even Tracks Right

The Pan Odd Tracks Left/Even Tracks Right setting enables you to set the basic track pan setting so that odd-numbered tracks translate with full-left panning, and even-numbered tracks translate with full-right panning. This is useful if you want to pan the currently unpanned audio full-left or full-right.

💡 The Pan Odd Tracks Left/Even Tracks Right setting is not supported when importing multi-channel audio tracks from an AAF. When importing multi-channel tracks, the setting is greyed-out and any imported stereo channels are panned hard right and hard left.

Markers To Import

Avid Media Composer sequences can contain metadata points called Markers that serve a similar purpose to the Markers in Pro Tools, adding color-coded contextual information to the timeline. Even though markers are associated with specific tracks in Media Composer, you can import markers into Pro Tools without importing those tracks.

When exporting an AAF from Media Composer, Marker information is included and can be imported into Pro Tools, thus preserving this data.

⚠️ Markers can only be imported from AAF sequences.

To import all Markers:
- Click the Markers to Import menu and select All.

To import no Markers:
- Click the Markers to Import menu and select None.

To import Markers based on marker color:
1. Click the Markers to Import menu.
2. Select the colors of markers you want to import. Check marks appear next to the selected colors.

Once imported, the new Markers can be edited as normal.

💡 Unlike Pro Tools Markers, which only mark specific points in time in a session, Media Composer Markers point specifically to individual audio or video tracks. Information on which track each Marker was associated with can be found in the Comments section in the Memory Locations window in Pro Tools.

💡 When Media Composer Markers are imported to Pro Tools as Markers, the associated comment text is added to the Marker name in Pro Tools (up to 31 characters). Comments over 31 characters can be viewed in full in the Memory Locations window in Pro Tools.

Track Data to Import Pop-Up Menu

The Track Data to Import pop-up menu lets you select which attributes of the selected tracks you want to import into the current session or project. The selected attributes are applied to all tracks that you choose to import into the current session or project. For more information about Track Data To Import options, see “Track Data to Import” on page 422.

When importing an AAF into Pro Tools, use the Track Data to Import menu to specify whether or not to import the plug-ins and plug-in settings.
To import plug-in settings when importing AAF tracks or sequences:

1. Open the Track Data to Import menu.
2. Do one of the following:
   - Choose All.
   - Choose Some, and ensure that Plug-In Assignments is selected.

To avoid importing plug-in settings when importing AAF tracks or sequences:

1. Open the Track Data to Import menu.
2. Choose Some, and ensure that Plug-In Assignments is deselected.

Main Playlist Options

When importing AAF or OMF tracks into Pro Tools, you can choose how the main playlist from each source track is imported to the destination track in the current session. See “Main Playlist Options” on page 426.

Import Sequence from Media Production

(Pro Tools | Ultimate Only)

Pro Tools | Ultimate lets you import sequences from Avid MediaCentral | Production Management.

To import a sequence from Production Management:

1. Create a new session or use an existing session.
2. Choose File > Import > Sequence from Production Management.

For more information, see the Pro Tools Production Management Guide.

Media Composer | Software
Export Options for Audio and Video Mixdowns

You can request the following export options for the AAF you are receiving from an Avid application:

- To export both a video mixdown and its corresponding editing metadata, the Avid video editor should select Video Mixdown from the Export Method pop-up menu, then select Mixdown with Video Edits in the Export Settings dialog.
- To export both an audio mixdown and its corresponding editing metadata, the Avid video editor should select Add Audio Mixdown Track(s) in the Export Settings dialog.

Audio File Format

Compatibility Issues

AIFC Audio File Format

Avid Media Composer and other Avid editors support audio files in the AIFC format, a version of the Audio Interchange File Format (AIFF) that supports compressed media. Pro Tools can import and use this format, but not compress audio in this format.

Sound Designer II Audio File Format

Support for AAF Sequences Referencing SD II Audio Files

Pro Tools 11.x and higher do not support Sound Designer II (SD II) audio files. Open any AAF sequence that references SD II files in Pro Tools 10.x and lower. Any referenced Sound Designer II files are automatically converted to a supported audio file format (WAV or AIF). You can then save the session and open it in Pro Tools 11.x or higher.
Translation Notes File

If there are any errors, clip name truncations, or other notes (such as missing effect renderings), during import of an AAF or OMF file or sequence, a dialog appears asking if you want a detailed report of the changes. Click Yes and choose where you want to save the translation notes file.

The Translation Notes File can be opened by most word processing applications that can read plain text files.

Translation Notes Format

Translation Notes are presented in the following format:

Track Name <Timecode Start–Timecode End> “clip name (if available)”;message

Translation Notes and Categories

The Translation Notes File is separated into different categories. The following are sample messages in each category, with explanations of what has happened and solutions if necessary.

Parsing Errors

Example

A1<01:00:00:00–01:00:04:20>error reading component “Assertion in OMF_Objects2x.cpp”, line 2871; substituting fill.

This error indicates a problem that may have originated in Pro Tools or the application that produced the AAF or OMF file. In the translated composition, there will be silence or video black at the given interval.

Missing Renderings

Example 1

A1<01:00:02:00–01:00:07:01> no rendering for effect: EFF_AUDIO_EQMB; using bypass clip.

This indicates the presence of an effect for which there is no rendering. The “bypass clip” is the (unprocessed) source material for the effect.

Example 2

V1<01:00:48:25–01:00:49:26> no rendering for effect: omfi:effect: VideoRepeat; substituting silence/video black.

For some effects, the length of the output is different than the length of the input. In this case, substituting a bypass when a rendering is missing doesn't make sense, because it won't sync properly. Pro Tools substitutes silence or video black.

Ignored Effects

A1<01:00:02:00–01:00:07:01> ignoring rendering for effect: EFF_AUDIO_EQMB; using bypass clip.

This indicates that the user has selected “Ignore Rendered Audio Effects” in Pro Tools. This note is a convenience so that if something is odd in the translated sequence, the user can determine if an effect that was ignored is actually required.

Incomplete Rendering

A1<00:00:28:29–00:00:31:17> incomplete rendering for effect Audio MultiBand EQ; using bypass clip.
This indicates that an effect was not rendered completely at a fade boundary in an Avid system. On import, Pro Tools bypassed the incomplete rendering and imported the audio without the effect. If you need the effect, re-render the effect and fade on the Avid system, and export again.

Miscellaneous Errors (Misc Errors)

Example

A1<01:00:00:00–01:00:16:06>“Jag film to Whirl.01.Sub.06.new.01”; insufficient source material for clip; shortening clip by 1 sample.

This Translation Note is primarily informational, informing you that Pro Tools was not able to translate the AAF or OMF sequence exactly, and has had to make an adjustment so Pro Tools can understand it.

This error occurs because applications do not always calculate the number of samples in a frame in the same way. In some cases, there may be one too few samples of media to support a given clip from the Pro Tools standpoint. In this situation, there can potentially be an audio “pop.”

Exporting Pro Tools Tracks as AAF or OMF Sequences

Pro Tools lets you export individual tracks in AAF or OMF format. Use the Export Selected Tracks as AAF/OMF command.

AAF and OMF sequences exported from Pro Tools do not support video files. They also do not retain information about Elastic Audio, plug-in assignments, parameters, markers, routing, or grouping. It is recommended that you commit Elastic Audio tracks, and any plug-in or hardware insert processing prior to export. Clip effects and clip gain are automatically rendered on export to AAF (but not to OMF).

Pro Tools can export AAF or OMF sequences linked to RF64 audio files, which are special WAV files that can be larger than 2 GB (normal WAVs must be under 2 GB). However, Avid video editing applications cannot open WAV files larger than 2 GB. Keep file size in mind when exporting AAF/OMF for Avid video users.
2 Choose File > Export > Selected Tracks as OMF/AAF.

3 From the Export As pop-up menu, select AAF or OMF.

4 If desired, select Enforce Avid Compatibility.

*Enforce Avid Compatibility limits the sample rate options to 44.1 or 48 kHz, and enables exporting of clip gain data. Dither without noise shaping will be applied to files being exported from 24-bit to 16-bit.

5 Be sure to select the correct Target Project Timecode Format option for the project as set for the project in your target application (such as Avid Media Composer).

6 Set the Sample Rate Conversion Options as necessary.

7 Set the Audio Media Options settings by doing the following:
   • Ensure that the Format and Bit Depth match the settings in your target project (as set for the project in your video software application).
   • Select a Copy Option (Link to Source Media, Copy from Source Media, or Consolidate from Source Media).

8 If you’re exporting a sequence that contains stereo, 5.1 or 7.1 tracks and want those tracks to retain proper channel layouts upon export, enable the Export Stereo, 5.1 and 7.1 Tracks as Multi-Channel option.

9 Select other export options as desired.

10 Click OK.

11 In the Publishing Options dialog, type the Pro Tools Comment and Sequence Name.

12 Click OK.

13 In the Save dialog, navigate to a folder where you can easily locate the AAF or OMF sequence when it is time to distribute it to another editor or import it into Media Composer.

14 Click Save.

15 In the “Please Choose a Folder for Converted Audio Files” dialog, navigate to a folder where the media files can be easily located (such as the same folder where AAF or OMF sequence resides).

*Some video editors (such as Avid Media Composer), require all media files to be in specific folders to allow proper relinking.

16 Click Choose (Mac) or Use Current Folder (Windows).

Pro Tools exports the composition and related media to the appropriate folders.

---

For more information, see “Export Options when Exporting to AAF or OMF Sequences” on page 444.
Exporting Multichannel Audio Tracks

When exporting AAF, stereo, 5.1, and 7.1 tracks can be exported as multichannel tracks, or as split mono tracks. When exporting to OMF, multichannel tracks are always exported as multiple mono files.

⚠️ Video tracks cannot be exported to AAF or OMF from Pro Tools.

Exporting Clip Gain

When exporting to AAF with the Enforce Avid Compatibility option on, Pro Tools generates Media Composer-style clip gain data, based on the clip gain data on each track.

⚠️ To export clip-based gain data, the Enforce Avid Compatibility option must be enabled.

The clip gain of Pro Tools clips with static volume between -inf dB and +12 dB will translate directly to clip-based gain upon export. Dynamic clip gain and values above 12 dB will be rendered for each clip in the resulting media, to optimize compatibility with Avid video editing applications.

💡 Clip-based gain is not exported when exporting to OMF format.

Exporting Volume Automation to OMF

Pro Tools does export volume automation to OMF, but only if the Enforce Avid Compatibility option is disabled.

Exporting Fades

While Pro Tools supports generating audio fades in real time, all fades in the session are rendered to disk upon AAF or OMF export, to optimize compatibility with Avid video editing applications.

💡 Fades are rendered and exported even when creating an AAF/OMF sequence with the Link to Source Media option enabled.

Clip Groups

Pro Tools cannot export tracks with clip groups when exporting to AAF or OMF. Before exporting tracks from a sequence containing clip groups to AAF or OMF, ensure that any tracks containing clip groups are not selected or ungroup any clip groups on tracks you want to export.

Exporting Pro Tools Tracks as MXF Audio Files

You can export MXF audio files using the following commands:

- Export Selected Tracks as OMF/AAF
- Bounce to Disk
- Export Selected Clips as Files

Exporting AAF Sequences Containing MXF Audio

Use Export Selected Tracks as OMF/AAF to export individual tracks or an entire Pro Tools session as an AAF sequence referring to MXF audio files.

💡 Tracks are exported in their entirety and time selections are ignored.

💡 Volume and pan automation is not exported if Quantize Edits to Frame Boundaries or Avid Compatibility Mode are enabled.
To export selected audio tracks from Pro Tools as an AAF sequence referring to MXF audio files:

1. In Pro Tools, select the tracks you want to export.
2. Choose File > Export > Selected Tracks as OMF/AAF.
3. Under OMF/AAF Options, select AAF from the Export As pop-up menu.
4. Select Enforce Avid Compatibility.

\[ An OMF sequence cannot reference MXF media files. When using the Export Selected Tracks as OMF/AAF dialog, choose AAF in the Export As pop-up menu to enable MXF in the Audio Format menu. \]

5. Ensure the Target Project Timecode Format is correct for the Avid application project to which you are exporting the AAF sequence.
6. Under the Audio Media Options section, select MXF from the Audio Format pop-up menu.
7. Verify the Audio Bit Depth setting is acceptable for the recipient of this export.
8. If you’re exporting a sequence that contains stereo, 5.1 or 7.1 tracks and want to export those tracks as multi-channel audio files, enable the Export Stereo, 5.1 and 7.1 Tracks as Multi-Channel option.
9. Click OK.
10. In the Publishing Options dialog, type the Pro Tools Comment and Sequence Name.

Pro Tools will create a sequence with the name you supply. The comment appears in the Avid application bin in the Pro Tools Comment column.
11. Click OK.
12. In the Name the AAF File to Export dialog, navigate to a folder where you can easily locate the AAF sequence when it is time to distribute it to another editor or import it into Media Composer.
13. Click Save.
14. In the Please Choose a Folder for Converted Audio Files dialog, navigate to a folder where the media files can be easily located (such as the same folder where AAF or OMF sequence resides).

\[ Some video editors (such as Avid Media Composer), require all media files to be in specific folders to allow proper relinking. \]

15. Click Choose (Mac) or Use Current Folder (Windows).

Pro Tools exports the AAF sequence to the selected folder, and exports the related media to the OMFI MediaFiles folder (OMF files) or the Avid MediaFiles folder (MXF files).
16. If you are ready to import the files into the Avid video application, exit Pro Tools.

\[ For more information on working in Avid video applications, see the appropriate Avid video application guide. \]
Exporting MXF Audio Files Using Bounce to Disk

You can use the Bounce to Disk command to create pre-mixed MXF audio files of the current Pro Tools session or project. This does not export all of the individual files on the Timeline, but it does guarantee that the mix you hear in another application will be identical to the mix you hear in Pro Tools, including all panning, effects, and automation.

To export to MXF using Bounce to Disk:

1. After you have finished recording and mixing a session in Pro Tools, highlight the length of the session in the timeline ruler (or on a track), plus an additional amount of time to avoid cutting off any reverb tails that might continue past the end of the clip.
2. Choose File > Bounce To > Disk.
3. In the Bounce dialog, select the Bounce Source.
4. Select Enforce Avid Compatibility.
5. Select MXF for the File Type.
6. Select a Sample Rate and Bit Depth.
7. Type a different name for the bound file if desired.
8. Click Choose to specify the directory where you want the bounced file to be saved.
9. Click Bounce.

Enforce Avid Compatibility creates frame-accurate edits, wraps the files as OMFI (unless you choose MXF), and limits the sample rate options to 44.1 or 48 kHz. Dither without noise shaping will be applied to files being exported from 24-bit to 16-bit.
10 In the Publishing Options dialog, do the following:

- Type the Pro Tools Comment and Clip Name.
- Choose a Target Project Timecode Format that matches the Avid application project to which you are exporting the MXF audio.

11 Click OK.

All audible audio in the selection will be exported to two multi-mono audio files.

Pro Tools begins bouncing to disk. Pro Tools bounces are done in real time, so you hear audio playback of your mix during the bounce process (though you cannot adjust it).

**Exporting a Clip as a New MXF File**

You can export clips as MXF audio files with the Export Selected As Files command. Use this command if you intend to use a clip in other sessions or other audio applications without using its parent source file. This command also provides a way to convert clips to a different sample rate or bit depth.

**To export clips as new MXF files:**

1. In the Clips List, select the clips you want to export.
2. From the Clips List menu, choose Export Selected As Files.
3. In the Export Selected dialog, select the Enforce Avid Compatibility option.
4. Select MXF from the Audio Format pop-up menu.
5. Set the bit resolution and sample rate.
6. Click Choose to specify the Destination Directory.
7. Click Export.
Export Options when Exporting to AAF or OMF Sequences

Pro Tools provides several translation settings when exporting tracks to OMF/AAF, including OMF/AAF Options, Sample Rate Conversion Options, and Audio Media Options.

OMF/AAF Options

When exporting tracks to AAF or OMF, Pro Tools provides the following OMF/AAF Options:

Enforce Media Composer Compatibility

If the Enforce Media Composer Compatibility option is enabled, all AAF and OMF files and sequences will meet the specific requirements of Media Composer. Sample rates are limited to 44.1 kHz or 48 kHz. Exported clips will be padded to the nearest frame boundaries (Quantize Edits to Frame Boundaries). This padding ensures that the placement of a file in the Timeline will be the same on sample-accurate as well as frame-accurate systems.

⚠️ When exporting a sequence with multi-channel audio tracks, the Enforce Media Composer Compatibility option must be enabled.

Target Project Timecode Format

Select the timecode format for the project into which this file or sequence will be imported. This may be different from the timecode format of the current session or project. This parameter allows clips to be placed correctly in sessions or projects with different timecode formats, and also calculates how many samples must be added to pad clips to frame boundaries.

⚠️ The Quantize Edits to Frame Boundaries setting must be selected when you are translating your Pro Tools session or project for use in frame-accurate editing workstations. Therefore, it is automatically selected whenever you export tracks with Enforce Media Composer Compatibility selected.

Quantize Edits to Frame Boundaries

Pro Tools allows sample-accurate placement of clips. In Pro Tools, you can place a clip of any length at any position, without any requirement for aligning clips with frame boundaries.

However, most video editing programs, such as Media Composer, only support frame-accurate editing. In these programs, you can only edit sounds on whole frame boundaries, limiting your precision.

Selecting Enforce Media Composer Compatibility will automatically select Quantize Edits to Frame Boundaries.

The Quantize Edits to Frame Boundaries option allows Pro Tools to export your sample-accurate Pro Tools edits into an AAF or OMF file so they appear as frame-accurate.
When you quantize edits to frame boundaries, you must enter a handle size (length) under Audio Media Options. See “Consolidate Handle Size (Milliseconds)” on page 447.

A master clip consisting of the clip plus the handle size (length) on both front and back will be exported. The exported sequence creates a subclip which is equivalent to the original clip, but extended to the farthest frame boundaries. For example, if the clip starts at 1:15 and 500 samples, the subclip would start at 1:15; and if the clip ends at 4:00 and 500 samples, the subclip would end at 4:01.

Because quantizing edits to frame boundaries extends the clips, extra audio may be heard. To prevent this extra audio from playing, special one-frame sound files are rendered to duplicate the original boundaries of the clip. In the exported sequence, these one-frame files are placed over the start and end frames of the extended clip so you cannot hear the extension.

One-frame files (OFFs) are imported into Avid workstations as part of the AAF or OMF sequence like any other sound file. In the Avid Timeline, they appear as one-frame edits on either side of a subclip. If you decide you need to extend the subclip at any point, discard the OFF and trim the subclip as needed.

⚠️ This solution is only available when you export a sequence, not when you export individual files.

If Quantize Edits to Frame Boundaries is selected, Pro Tools volume automation will not be exported.

### Export Stereo, 5.1, and 7.1 Tracks as Multi-Channel

Select this option to make Pro Tools export audio from multi-channel tracks as multi-channel audio files, rather than sets of multiple mono files.

### Sample Rate Conversion Options

These settings allow you to convert the sample rate of your Pro Tools session or project during export to AAF or OMF by sample-rate converting each audio file, and adjusting the edits in the resulting AAF or OMF file to compensate for this change.

⚠️ See “Speed Correction for Film, NTSC Video, and PAL Video” on page 1294, for information about converting between different speeds and sample rates.

You might want to change the sample rate of a session or project if you are exporting to a system or are at a stage in the process that requires a different sample rate.

⚠️ Check the Audio and Video pull options before applying a sample rate conversion to the entire session or project.
For example, your session or project contains audio media at 29.97 fps (NTSC video) at 48 kHz, while the film composer to whom you are exporting your session or project requires audio media at 24 fps (film speed) at 48 kHz. To convert all the audio files and edits to play back at 24 fps (film speed) at 48 kHz, you would set the Source Sample Rate setting to 48,048 (a pull up rate of 0.1%) and the Destination Sample Rate to 48,000. These settings tell Pro Tools that you want to fit 48,048 of the original video speed samples into 48,000 of the new film speed samples. With these settings, you sample-rate convert the video material to film speed.

**Source Sample Rate**

This setting allows you to specify the sample rate of the material you are working with in Pro Tools, independent of the session or project sample rate settings.

**Destination Sample Rate**

This setting allows you to specify the sample rate for audio files after the AAF or OMF translation.

If this setting differs from the Source Sample Rate setting, audio is sample-rate converted digitally to the Destination Sample Rate.

**Sample Rate Conversion Quality**

These settings correspond to Pro Tools sample rate conversion settings. It is not recommended that you use the Low (Fastest) setting. The Tweak Head (Slowest) setting provides the highest quality sample rate conversion.

---

**Audio Media Options**

When exporting tracks to AAF or OMF, Pro Tools provides the following Audio Media Options:

**Audio Format**

Choose whether you want the resulting AAF or OMF file to refer to BWF (.WAV), AIFF, MXF (AAF only), or embedded files. The audio files will be converted accordingly.

⚠️ *If you create AIFF or BWF (.WAV) audio, the audio files have extra OMF data attached to them. Though most applications will not have problems reading these audio files, they may not be compatible with all applications.*

⚠️ *MXF is only available if you have selected the Enforce Media Composer Compatibility option.*

**Bit Depth**

Select 16-bit or 24-bit as the target bit depth for the exported media. Pro Tools automatically applies dither, without noise shaping, when reducing bit depth from 24-bit to 16-bit.

**Source Media**

When exporting tracks from Pro Tools to AAF or OMF, there are three ways that Pro Tools can handle source audio media (as set in the Export to OMF/AAF dialog’s Audio Media Options pop-up menu).

**Link To Source Media** Creates an AAF or OMF file that refers to as many of the original media files as possible. In this case, the AAF or OMF file points to the BWF (.WAV), AIFF, or MXF from the source project.

**Copy From Source Media** Copies audio to another drive or folder. You can sample-rate convert the audio during this translation.
Consolidate From Source Media Copies only the part of the files that are actually used by the session or project. For example, you may only be using a ten second clip of a ten-minute audio file in your session or project. Consolidating this audio saves a great deal of disk space by copying only the audio you use and discarding the rest.

Consolidate Source Audio Media is the only usable option for a Pro Tools to AAF or OMF translation when Quantize Edits to Frame Boundaries is selected. See “Quantize Edits to Frame Boundaries” on page 444.

Consolidate Handle Size (Milliseconds) Specifies the number of milliseconds of the original audio file to retain at the beginning and end of each audio clip that is created. This lets you extend clip boundaries even after you have consolidated, by the amount you specify. It is a good idea to have at least 1000 milliseconds (one second) of handle, so you can “trim out” edits that sound “clipped” or “up-cut.” Consolidate Handle Size is only available when Consolidate From Source Media is selected.

Export Stereo, 5.1, and 7.1 Tracks as Multi-Channel

When exporting a sequence with multi-channel (stereo, 5.1 or 7.1) tracks, enable this option to retain proper channel layouts upon export.

OMF Options

Comments Identifies the source of the file, and defaults to the name of the current session. The Comment field does not appear if you are using the Export Selected as Tracks command, since audio on one track may have many different sources.

Sequence Name This is the name that will be displayed when the file is imported into another AAF- or OMF-compatible program. The sequence name is not the file name that will appear in the finder. This field defaults to the Pro Tools clip name. When exporting more than one clip, all clip names are automatically set to the clip name.

Target Project Timecode Format This is the timecode format for the project into which this file or sequence will be imported. This may be different from the timecode format of the current session or project. This parameter allows clips to be placed correctly in sessions or project with different timecode formats, and also calculates how many samples must be added to pad clips to frame boundaries.

Time Stamping

When you export to AAF or OMF, all exported media is time stamped. A time stamp is a specific timecode location stored within an individual media file.

The time stamp can indicate:

- Timecode location on the source tape
- Where the file was originally recorded in the Pro Tools Timeline
- Where a clip was placed in an Avid or Pro Tools Timeline
- User-entered timecodes
Time stamps can be stored in three different places within a media file:

- In a clip definition
- In the file format metadata (for example, .WAV file wrappers)
- In the AAF or OMF wrapper

**Exporting a Clip**

If you are exporting a clip, the time stamp will be the start point of the clip, relative to the point where the file originally started to record. For example, if you record a file from 1:00 to 1:30, then trim it to start at 1:15, the time stamp for the exported clip would be 1:15. This is true even if the clip is slipped elsewhere in the Timeline.

**Exporting a Clip as Part of a Sequence**

When you export a clip as part of a sequence, the clip’s original time stamp reflects the clip’s position in the Timeline of the sequence.

**Exporting a File**

**Recorded in Pro Tools** If the file was recorded in Pro Tools, the time stamp is the location in the Timeline at which the recording began. For instance, if you record the file from 1:00 to 2:00, the time stamp would be 1:00.

**AudioSuite** If the file was created by AudioSuite, the time stamp depends on the rendering mode used when the file was rendered. If Create Individual Files mode is selected, the time stamp of the new file matches the original time stamp of the source file. If Create Continuous File is selected, the time stamp of the new file matches the position of source file on the timeline.

**Existing Time Stamp** If a file is imported with an existing time stamp, it will remain the time stamp for the exported file as well. If the original file contained a time stamp in the format wrapper, it will be copied to the OMF wrapper when exported.

**Exporting a File With No Time Stamp**

If you import a file that does not contain a time stamp (such as a sound effect from a CD), the time stamp will be 0 when it is exported.

**Importing Files from an Avid AAF or OMF Sequence**

If you import a file from an Avid AAF or OMF sequence, the media file's source tape time stamp becomes the original time stamp of the new Pro Tools file. The User Timestamp maintains the original time stamp.

_workspace provides columns for specific Avid OMF metadata, including Clip Name, Tape, FPS, Original Timestamp, and User Timestamp._

**Export Selected Tracks to Sequence in Production Management**

*(Pro Tools | Ultimate Only)*

Pro Tools | Ultimate lets you export selected tracks in your session as a sequence for check-in to Avid MediaCentral | Production Management.

**To export selected tracks as a sequence to Production Management:**

1. Select the tracks you want to export as a sequence and check in to Production Management.

2. Choose File > Export > Selected Tracks to Sequence in Production Management.

_for more information, see the Pro Tools Production Management Guide._
Export Selected Tracks as New Session or Project

Pro Tools lets you export any selected tracks in a session or project as a new session or project. This feature is especially useful in collaborative situations.

For example, you might be working on a large post-production session and you want your collaborator to work on only some dialog in the session or project while you continue working on other parts of the session. You can now select the dialog tracks and export them as a new session or project. Your collaborator can then open the new session or project and edit the dialog. When your collaborator is done, you can import the session data from the dialog session or project to update the dialog tracks in your big session or project.

To export selected tracks as a new session or project:

1 Select the tracks you want to export as a new session or project.

2 Choose File > Export > Selected Tracks As New Session. The Save Copy In dialog opens. (You can also open the Save Copy In dialog by choosing File > Save Copy In.)

3 In the Save Copy In dialog, verify that the Selected Tracks Only option is enabled.

4 Configure the Format (Project or Session) and Session Parameters settings and options.

5 Configure the Items to Copy settings and options.

6 For projects only, enable (or disable) the Backup to Cloud options to create an online project (or an offline project).

7 You can also enable the Main Playlist Only option if you do not want to include any of the alternate playlists associated with any of the selected tracks in the new session or project.

8 Click OK.

9 Either the Save dialog opens or the Save Project Copy dialog opens depending on the Format setting. Type a name for the session or project.

10 For sessions only, navigate to where you want to save the session.

11 Click Save.
A copy of the session or project that contains only the selected tracks from the source session or project is saved to the specified location for sessions and to the cloud for projects.

For information on the Save Copy In dialog settings and options, see “Save Copy In Options” on page 168.

Exporting Session Information as Text

You can use the Export Session Info as Text command to create a text file that contains extensive information about your session or project.

This text file can contain a list of audio files, audio clips, audio track EDL (Edit Decision List) information, extended timestamp information, and information about crossfades.

Track EDLs are exported as tab-delimited text, with tabs between each column heading, and tabs between each event parameter. You can use this data in a program for reading EDLs, or you can format the EDL data into tables using a word processor or spreadsheet application.

To export session information as text:

1. Choose File > Export > Session Info as Text.
2. Select whether to include the File List, Clips List, and track EDLs.
3. If you choose to include track EDLs, select whether to show subframes, and whether to include user timestamps. Also select an option for crossfade handling.
4. If you choose to include track EDLs, select the Time Format for the exported session text from the pop-up menu.
5. Select the File Format for exported text using the pop-up menu.
6. When you have set your options, click OK.
7. Select a location and type a filename for the exported text file. In Windows, Pro Tools adds the correct 3-letter filename extension, while on the Mac, the file extension “.txt” is added.

Exported Session Text Files

Session Information

The session text file starts with basic information about the session or project. This information includes the session or project name, sample rate, bit depth, timecode format, and number of audio tracks, audio clips, and audio files, as shown in the following example.

Session Information example

<table>
<thead>
<tr>
<th>SESSION NAME:</th>
<th>Ripleys II-092700</th>
</tr>
</thead>
<tbody>
<tr>
<td>SAMPLE RATE:</td>
<td>48000.000000</td>
</tr>
<tr>
<td>BIT DEPTH:</td>
<td>24-bit</td>
</tr>
<tr>
<td>TIMECODE FORMAT:</td>
<td>30 Frame</td>
</tr>
<tr>
<td># OF AUDIO TRACKS:</td>
<td>19</td>
</tr>
<tr>
<td># OF AUDIO CLIPS:</td>
<td>203</td>
</tr>
<tr>
<td># OF AUDIO FILES:</td>
<td>54</td>
</tr>
</tbody>
</table>

File List and Clips List

Next, if you choose to include them, are the lists of audio files and clips.

Track EDLs

The final item, if exported, is the list of track EDLs. A track EDL lists the track name, and all edits, including the event number, the clip name, clip start and end time, and clip duration. The clip timestamp is also exported, if you select this option. Subframes are shown in each time field if you select this option.
Export Session Information as Text Options

Export Session Text dialog

Include File List
Select this option to export a list of the session or project audio files. The File List provides a list of all the audio files in the session (and their hard drive locations) or project.

Include Clips List
Select this option to export a list of the session or project audio clips. The Clips List provides a list of all of the audio clips in the session or project, as well as the source audio file for each clip.

Include Markers
Select this option to export a list of all markers included in the session or project.

Include Plug-In List
Select this option to export a list of the plug-ins used in the session or project.

Include Track EDLs (Playlists)
You can export track EDLs (playlists). Track EDLs can be used to spot-check clip placement and edits, or in a conforming program for post applications. In extreme circumstances the EDL can be used to recreate the entire session or project. You can export session text for All Tracks or for Selected Tracks Only.

⚠️ MIDI track EDLs are not exported.

When exporting track EDLs, the following options are available:

Show Subframes
This option allows you to export subframe time information with track EDLs, if used in your session or project.

Include User Timestamps
You can include user timestamps with track EDLs. User timestamps indicate a user-defined session or project location for the clip, or the original location of the clip when recorded.

Fade Handling
For track EDLs, you can choose whether to show crossfades, not to show them, or to combine crossfaded clips. When clips are combined, their durations and locations are listed up to the center of the crossfade (for the leading clip) and from the center of the crossfade (for the following clip).
**Time Format**

You can select the appropriate time format that exported EDL information is based on. For example, for post work, you might select SMPTE time, but for music creation locked to a grid, you might select Bars:Beats.

**File Format**

On Mac, you can export to TextEdit, UTF-8, MS Excel, MS Word, Write Now, Word Perfect, and AppleWorks text formats. On Windows, you can export to either TextEdit or UTF-8.

---

**Importing and Exporting Clip Group Files**

Pro Tools can export and import the clip group file format (.rgrp). This lets you do the following:

- Separate clip group metadata from audio files to avoid unnecessary file copy operations when exporting audio clip groups composed from multiple source files.
- Export MIDI data as part of a clip group.
- Create multitrack loops.

Clip group files store the following metadata:

- References to all audio files within the clip group
- Clip names and relative location in tracks
- Embedded fades and crossfades
- Clip group names and format (single or multitrack)
- All MIDI data present in the clip group (such as notes, controllers, and Sysex)
- Track names
- Elastic Audio Warp markers and TCE factor
- Clip timebase (samples or ticks)
- Sync points
- Loops
- Tempo map
- Tempo map

Clip group files do not store the following:

- Audio
- Automation
- Plug-Ins
- Track routing
- Meter map
- Clips List information

Pro Tools provides several ways to import clip groups into an open session:

- “Importing Clip Groups with Pro Tools Menu Commands” on page 453
- “Importing Clip Groups with Drag and Drop” on page 453
Chapter 20: Importing and Exporting Session Data

Importing Clip Groups with Pro Tools Menu Commands

To import a clip group with Pro Tools menu commands:

1. Choose File > Import > Clip Groups and select the clip group you want to import.

2. In the Clip Group Import Options dialog, choose where the clip group will go:
   - **New Track** Creates a new track where the clip group will be imported.
   - **Clips List** Imports the clip group into the Clips List, where it will be where it will be available to place into tracks.

3. If you chose to create a new track, choose a location for the imported group in the track.
   - **Session Start** Places the group at the start of the session or project.
   - **Song Start** Aligns the beginning of the group to the Song Start point.
   - **Selection** Aligns the beginning of the group to the edit cursor or to the beginning of a selection in the Timeline.
   - **Spot** Displays the Spot dialog, which lets you spot the group to a precise location based on any of the Time Scales.

4. If desired, enable the Import Tempo Map from Clip Group File option, which replaces the session tempo map with the tempo map of the clip group). This option is only available when importing the clip group to the Session Start.

5. Click OK.

Importing Clip Groups with Drag and Drop

You can drag and drop clip groups from a Workspace browser, or from Windows Explorer or the Mac Finder to the Timeline, to a track, to the Tracks List, or to the Clips List.

To import clip groups into the Clips List:

1. Select one or more clip groups in a Workspace browser, or Windows Explorer or Mac Finder.

2. Drag the files onto the Clips List of the current session.

To import clip groups into an existing track:

1. Select one or more clip groups in a Workspace browser, or from Windows Explorer or Mac Finder.

2. Drag the files onto an existing track in the Edit window of the current session or project.

To import clip groups into new tracks:

1. Select one or more clip groups in a Workspace browser, Windows Explorer or Mac Finder.

2. Do one of the following:
   - From the Workspace browser, Shift-drag the files anywhere in the Edit window of the current session or project.
   - Drag the files onto any empty space in the Edit window of the current session or project.
   - Drag the files to the Tracks List.
Exporting Clip Groups

To export a clip group:

1. Select one or more clip groups in the Clips List.
2. From the Clips List menu, choose Export Clip Groups.

Export Clip Groups dialog

3. In the Export Clip Groups dialog, the Destination Directory defaults to the auto-created Clip Groups folder in the session folder. You can change the Destination Directory by clicking the Choose button, navigating to a new location, and clicking Open. Click Reset to reset the Destination Directory to the default location.

4. Enable one of the following options for resolving duplicate clip group file names:
   - Prompting for Each Duplicate (default)
   - Auto Renaming
   - Replacing with New Files

5. Click Export.

Exporting Clip Groups to Another Hard Drive

Generally, if you are exporting clip groups to another hard drive, you should copy any referenced audio files. This way you can move clip groups not only from one session to another, but from one system to another.

To export a clip group to a different hard drive and include its audio files:

1. Export one or more clip groups to the new drive.
2. Create a new session or project on the new drive.
3. Choose Setup > Preferences.
4. In the Preferences dialog, click the Processing tab and select Automatically Copy Files on Import.
5. Click OK to close the Preferences dialog.
6. Import all previously exported clip groups by dragging and dropping them into the session or project.

The audio files folder of the new session or the cloud account for the project now contain all files referenced by the clip groups.
Chapter 21: File and Session Management and Compatibility

When working with Pro Tools, you will encounter several different kinds of computer files. Pro Tools systems require that you keep certain files in specific hard drive locations in order to function properly:

- **Pro Tools software files** (such as the application and plug-ins files) should be located on your Startup drive (the drive that contains your operating system and other system-related files).
- **Data files** (such as session files, audio files, and video files) can be located on any compatible drive connected to your computer’s internal or external SAS, SATA, IDE/ATA, FireWire, or Thunderbolt busses.

You can specify the location of new session files when creating new sessions (see “Creating a New Blank Session or Project” on page 161).

In Pro Tools sessions, use the Disk Allocation command to specify where you want newly recorded audio files to be stored (see “Working with Hard Drives for Recording” on page 508).

⚠️ **Although Pro Tools lets you record to your system drive, this is generally not recommended. You should record to system drives only when necessary—for example, if your computer system has just one hard drive, or if your other hard drives are completely full.**

💡 **If you have a system with multiple drives, you can designate the System drive as a Playback only or Transfer only drive for optimal performance** (see “Volume Permissions” on page 312).
Audio File Management

Unique File IDs

Pro Tools tags each audio file in a session with a unique identifier that allows it to distinguish a particular file even if its name or location has changed. This Unique ID is 8-bit and is used by versions of Pro Tools lower than 12.8.

SMPTE IDs

Pro Tools (version 12.8 and higher) creates and reads 32-bit SMPTE IDs. SMPTE ID provides optimal compatibility and interchange with other applications that utilize SMPTE IDs in media files and AAF sequences (such as Avid Media Composer), and ensures truly unique IDs for all AIFF and WAV files.

Locating Audio Files

With Pro Tools, you manage links to audio and other media files using the Relink window.

Pro Tools classifies storage volumes according to their suitability for performance (recording or playback) or transfer (storage or copying) of audio and other media files. Audio files must be stored on suitable Performance volumes and be properly linked in order to be playable in a Pro Tools session.

When you open a session, if Pro Tools determines that audio files are not located on a Performance volume, or if it is unable to locate audio files contained in the session, you can locate or copy the files in order to play back the session. This process is called relinking.

Transfer Files

Transfer files reside on volumes unsuitable for playback, such as CD or DVD discs, or network drives.

To open a session containing Transfer files:

- Open the Pro Tools session. If any files are on a volume unsuitable for playback, Pro Tools prompts you to do one of the following:
  - Click Yes to open the Copy and Relink window.
  - Click No to open the session with all Transfer files offline.

To make Transfer files playable in the current session:

1. Select the session in the Locations pane.
2. Double-click the Audio Files folder to display all of the audio files.
3. Choose Select Transfer Files from the Browser menu.
4. Choose Copy and Relink from the Browser menu.
5. Specify a location for the copied files on a valid Performance volume.
6. Click OK.

For more information on storage volume classifications, see “Performance and Transfer Volumes” on page 308.

For more information, see “Linking and Relinking Files” on page 344.
Missing Files

A file is missing if it is not found in the same location as when the session was last saved.

To open a session with missing files:

1. Open the Pro Tools session. If any files are missing, Pro Tools posts a Missing Files warning.

2. Choose one of the following options:
   - **Skip All** Ignores all missing files. Missing files appear offline in the session.
   - **Manually Find and Relink** Opens the Relink window, where you can search, compare, verify, and relink missing files.
   - **Automatically Find and Relink** Searches all Performance volumes for all missing files with matching name, unique file ID, format, and length, and automatically commits links to missing files where possible.

3. To exclude any Rendered Elastic Audio files from the relink process and regenerate them instead, select **Regenerate Missing Rendered Files Without Searching**.

4. Click OK.

For more information, see “Linking and Relinking Files” on page 344.

Renamed Audio Files

Renamed audio files are located in the auto-created Renamed Audio Files folder in the Pro Tools session folder. Files can be renamed when you open a session that references audio file names with incompatible characters. Files can also be renamed in certain situations when saving a copy of a session to a Pro Tools version that does not support long file names.

Opening a Session that Contains Audio File Names with Illegal Characters

Pro Tools 7.x and higher does not support audio file names that contain the following ASCII characters:

/ (Forward Slash)
\ (Backslash)
: (Colon)
* (Asterisk)
? (Question mark)
“ (Quotation marks)
< (Less-than symbol)
> (Greater-than symbol)
| (vertical line or pipe)

When opening sessions that contain audio file names with illegal characters, Pro Tools automatically creates a renamed copy of each file that contains illegal characters (replacing these characters with an underscore “_”). Renamed files are copied to the Renamed Audio Files folder. The original files are left intact in the Audio Files folder.
Before the session opens, you are prompted to save a detailed report of the renamed files and their original file names to a Notes text file. By default, the Notes text file is saved to the Session folder.

⚠️ It is possible to have a Pro Tools 7.x or higher session that contains audio file names with illegal characters. If you Save Copy In the session to Pro Tools 6.9.x or lower with Mac/PC Compatibility on, the tracks are renamed with legal characters. If Mac/PC Compatibility is off, the characters are not changed.

Saving a Copy of a Session that Contains Long Audio File Names

When saving files to Pro Tools 6.9.x and lower (using Save Copy In), audio files with file names that exceed the limits of the destination format are truncated and located in the Session folder, as follows:

- If the new session is saved to the same directory as the original, a Renamed Audio Files folder is created in the session’s original folder, and the renamed audio files are placed in it.
- If the new session is saved to a different directory than the original and the All Audio Files option is not selected, a new Session folder is created, which includes an Audio Files folder and a Renamed Audio Files folder. Renamed audio files are included in the Audio Files folder.
- If the new session is saved to a different directory than the original and the All Audio Files option is selected, a new Session folder is created, which includes an Audio Files folder. Renamed audio files are included in the Audio Files folder.

WAV File Compatibility

Convert Imported WAV files to AES31/Broadcast Wave

Pro Tools always creates AES31/Broadcast compliant BWF (.wav) files when the file originates in Pro Tools. Non-BWF .wav files can be added to BWF (WAV) format Pro Tools sessions without conversion. This option ensures that all WAV files are imported, and if necessary, converted to BWF (WAV), compliant with the AES31/EBU Broadcast standard.

AES31/Broadcast Wave is a variant of the standard audio WAV file type. The AES31 format contains SMPTE time stamps and other information beyond the raw PCM audio data.

This variant complies with standards set by the AES (Audio Engineering Society) and EBU (European Broadcasters Union). Choose this option to ensure compatibility with other workstations that recognize this file type.

To make imported WAV files compliant with the AES31/EBU Broadcast standard:

1. Choose Setup > Preferences and click the Processing tab.
2. Select the Convert Imported “.wav” Files to AES31/BroadcastWave option.
3. Click OK.
**WAVE Extensible File Format**

Pro Tools supports the WAVE Extensible file format for audio files. This file format specifies multiple audio channel data (surround sound) along with speaker positions, which is stored within the audio file header. These audio files are identified in Workspace browsers with the designation “WAV (BWF EXT)” in the Attributes field.

If you are working with greater-than-stereo multichannel track formats in your Pro Tools sessions, it is recommended that you use the WAV file format.

*When using the WAV file format in Pro Tools sessions, the corresponding channel order for each channel of greater-than-stereo, interleaved multichannel files is displayed in the Clips List.*

**RF64**

Pro Tools supports the RF64 audio file format. RF64 is an extension to the WAV audio file format that addresses the 4 gigabyte size limitation of other WAV audio file formats. RF64 audio files are identified in Workspace browsers with the designation “MBWF” in the Attributes field.

*Lower versions of Pro Tools cannot read RF64 files. These files have to be manually edited and consolidated so that they are no larger than 4 GB in order to be available to systems running lower versions of Pro Tools.*

**Sharing Projects Offline**

For Pro Tools projects, all media is stored in the cloud and cached locally as specified in the Project Media Cache setting in the Operation Preferences.

To share projects offline, you must save the project as a session using the Save Copy In command, and then share the session.

**Sharing Sessions Created on Different Computer Platforms**

**Working with Mac-Based HFS+ Drives on Windows Computers**

You can use the MacDrive Utility from Mediafour to mount HFS+ drives on an NTFS system for use with Pro Tools.

**Moving Sessions on Windows Systems to Mac-Based HFS+ Drives**

*(From Window-Based NTFS Drives Only)*

There are specific steps for transferring session files from Windows-based NTFS drives to Mac-based HFS+ drives.

**To transfer Pro Tools Windows sessions from NTFS drives to HFS+ drives:**

1. Set the MacDrive Options to Backup/File Transfer.
2. Do one of the following:
   - Drag the session folder from the NTFS drive to the HFS+ drive.
   - Open the Windows session on the NTFS drive, choose Save Copy In, and save a copy of the session to the HFS+ drive.

**Moving Mac-Based Sessions on HFS+ Drives to Windows Systems**

*(To Windows-Based NTFS Drives Only)*

There are specific steps for transferring files from Mac-based HFS+ drives to Windows-based NTFS drives.

*When using the WAV file format in Pro Tools sessions, the corresponding channel order for each channel of greater-than-stereo, interleaved multichannel files is displayed in the Clips List.*

Lower versions of Pro Tools cannot read RF64 files. These files have to be manually edited and consolidated so that they are no larger than 4 GB in order to be available to systems running lower versions of Pro Tools.
To save (or create) Mac sessions to be compatible on Windows systems, see “Saving Copies of Mac Sessions to be Compatible with Windows” on page 460.

When transferring Pro Tools sessions from HFS+ drives to NTFS drives, Pro Tools sessions cannot relink to audio files that have Mac characters that are illegal in Windows. These characters are automatically converted to underscore (“_”) characters. These files are saved to the Renamed Audio Files folder. You need to manually relink each file by File ID. See “Missing Files” on page 457.

To transfer Pro Tools Mac sessions from HFS+ drives to NTFS drives:

1. Set the MacDrive Options to Normal Use.
2. Do one of the following:
   • Drag the session folder from the HFS+ drive to the NTFS drive.
   • Open the Mac session on the HFS+ drive, and when prompted, choose Save Copy In and save a copy of the session to the HFS+ drive.

If the session previously used SD II files, the files are converted to the new audio file format.

Recording and Playback from HFS+ Drives on Windows

Windows supports recording and playback of sessions directly from Mac-formatted (HFS+) drives using the MacDrive software application.

In older versions of Pro Tools, Mac-formatted HFS+ drives could only be used as Transfer volumes when connected to Windows systems using MacDrive.

When using MacDrive for recording and playback on a Windows system, the session file and all audio files must be stored on Mac-formatted (HFS+) drives. Recording and playback of a session from a mixture of Windows- and Mac-formatted drives is not supported.

To record or play back from HFS+ drives with Windows using MacDrive:

1. In Windows, go to the MacDrive Control Panel.
2. Choose Options > File Names and select the International Use option.
3. Delete all options listed under “File Name Maps.”
4. In Pro Tools, choose Window > Workspace and make sure that all Mac-formatted volumes are set to R (record) or P (playback) in the A (Audio) and V (Video) columns.

Saving Copies of Mac Sessions to be Compatible with Windows (Save Copy In to Pro Tools 6.9.x and Lower Only)

Sessions created and saved as Pro Tools 7.x and higher sessions are always compatible on both Windows and Mac systems.

If you create a Pro Tools 6.9.x or lower session on a Mac system, the session is only compatible on Windows systems if the Enforce Mac/PC Compatibility option is selected when using the Save Copy In command. In addition, there are cross-platform limits to consider when completing the Save Copy In command.

Cross-Platform Session Limits

When saving (or creating) a copy of a Pro Tools session that you want to be compatible on both Mac and Windows, keep in mind the following limits and how Pro Tools deals with them:
Audio File Types

The recommended file format for cross-platform interoperability is BWF (.WAV). To support optimal session interchange, Pro Tools defaults to BWF format for new sessions.

Pro Tools lets you save, bounce, and export in a variety of audio file formats, including WAV, AIFF, MP3, and QuickTime.

File Name Extensions

For cross-platform compatibility, all files in a session must have a 3-letter file extension added to the file name. Pro Tools 5.1 to 6.9.x session files have the extension “.pts,” and Pro Tools 5 sessions have the extension “.pt5.” Wave files have the “.wav” file extension, and AIFF files have the “.aif” file extension.

Incompatible ASCII Characters

Clip names, track names, file names, and plug-in settings cannot use ASCII characters that are incompatible with either system.

When importing files into a session, incompatible characters are converted to underscores (“_”) and the renamed files are placed in the Renamed Files folder.

The following characters cannot be used in Windows sessions:
- / (Forward Slash)
- \ (Backslash)
- : (Colon)
- * (Asterisk)
- ? (Question mark)
- " (Quotation marks)
- < (Less-than symbol)
- > (Greater-than symbol)
- | (vertical line or pipe)

Saving Cross-Platform Sessions

To save an existing session to Pro Tools 6.9.x or lower and maintain Mac and Windows compatibility:

1. Choose File > Save Copy In.
2. In the Save Session Copy dialog, choose a destination and type a name for the new session file.
3. Set the Audio File Type to AIFF or BWF (.WAV). These file formats are compatible with either platform.
4. Set the Sample Rate and Bit Depth for the session.
5. Select Enforce Mac/PC Compatibility. This option must be selected to make the session cross-platform compatible.
6. Select the Items to Copy options for the new session.
7. Click Save.

If the session previously used SD II files, the files are converted to the new audio file format.

Pro Tools can convert a file created on a Mac and saved without the “Enforce Mac/PC compatibility” option selected to a Windows compatible file. For more information, see “Sharing Sessions Created on Different Computer Platforms” on page 459.
Sharing Sessions Created on Different Pro Tools Systems

Pro Tools makes it easy to share sessions between Pro Tools Ultimate and Pro Tools. There are some important differences between systems that can affect how session material is transferred.

For details on transferring sessions between Windows and Mac systems, see “Sharing Sessions Created on Different Computer Platforms” on page 459.

Differences between Pro Tools systems

<table>
<thead>
<tr>
<th>Feature</th>
<th>HDX Systems</th>
<th>HD Native Systems</th>
<th>Pro Tools</th>
</tr>
</thead>
<tbody>
<tr>
<td>Maximum number of audio tracks</td>
<td>up to 768 tracks (up to 768 voiceable)</td>
<td>up to 768 tracks (up to 256 voiceable)</td>
<td>up to 128 tracks (up to 256 voices)</td>
</tr>
<tr>
<td>Maximum number of Auxiliary Input tracks</td>
<td>512 Aux Input tracks</td>
<td>512 Aux Input tracks</td>
<td>128 Aux Input tracks</td>
</tr>
<tr>
<td>Maximum number of Instrument tracks</td>
<td>512 Instrument tracks</td>
<td>512 Instrument tracks</td>
<td>512 Instrument tracks</td>
</tr>
<tr>
<td>Inserts per track</td>
<td>up to 10 inserts</td>
<td>up to 10 inserts</td>
<td>up to 10 inserts</td>
</tr>
<tr>
<td>Sends per track</td>
<td>up to 10 sends</td>
<td>up to 10 sends</td>
<td>up to 10 sends</td>
</tr>
</tbody>
</table>

Opening Pro Tools Ultimate Sessions in Pro Tools

A Pro Tools Ultimate session can be opened with Pro Tools, but certain session components open differently or not at all.

When opening a Pro Tools Ultimate session in Pro Tools, the following occurs:

Tracks

- Any tracks beyond the first 128 are deleted.
- Any Auxiliary Input tracks beyond 128 are deleted.
- DSP plug-ins with Native equivalents are converted; those without equivalents are made inactive.
- Multichannel surround tracks are removed from the session.
- Unavailable input and output paths are made inactive.
- HEAT (if present) is removed.
Video

- Only the main video track is displayed.
- Only the first QuickTime movie in the session is displayed or played back.
- If the session contains QuickTime movies in the Clips List but no video track, the session opens with a new QuickTime Movie track containing the first QuickTime movie from the Clips List.
- The Timeline displays and plays back only the video playlist that was last active. Alternate video playlists are not available.

Sharing Sessions Created on Different Pro Tools Software Versions

Pro Tools makes it easy to share sessions between different software versions of a particular Pro Tools system.

Pro Tools 10.x sessions and higher cannot be opened with lower versions of Pro Tools. To save a Pro Tools 10.x session or higher so it is compatible with a lower version of Pro Tools, use the File > Save Copy In command to select the appropriate session format.

Sharing Sessions Between Pro Tools 2018.x and Pro Tools 12.x

Pro Tools 2018.x and Pro Tools 12.x sessions are cross-compatible. However, the following caveats apply:

- Track Presets are not available in Pro Tools 12.x and lower.
- EQ Curve view is not available in Pro Tools 12.x and lower.
- When opening sessions created in Pro Tools 12.2 or higher that have VCA Master tracks in

Sharing Sessions Between Pro Tools 12.x and Pro Tools 11.x

Pro Tools 12.x and Pro Tools 11.x sessions are cross-compatible. However, the following caveats apply:

- When opening a session created Pro Tools 12.8.2 session with any Ambisonics paths or tracks in a lower version of Pro Tools, they are dropped.
- When opening a session created Pro Tools 12.8 session with any Dolby Atmos specific elements in a lower version of Pro Tools, they are dropped.
- When opening a session created Pro Tools 12.8 session with 7.0.2 or 7.1.2 paths or tracks in a lower version of Pro Tools, those paths and tracks are dropped.
- Offline projects created by Pro Tools 12.8 or higher are not supported with lower versions of Pro Tools.
- Pro Tools 12.8 and higher can create and read ISRC metadata for audio files (AIFF and WAV), but lower versions cannot.
- When opening sessions created in Pro Tools 12.7 or higher in Pro Tools 12.6.1 or lower, Revision History in not available.
- When opening sessions created in Pro Tools 12.7 or higher in Pro Tools 12.6.1 or lower, Soundbase in not available.
- When opening sessions created in Pro Tools 12.7 or higher in Pro Tools 12.6.1 or lower, the database file for Soundbase is backed up and a new database file is written.
- When opening sessions created in Pro Tools 12.6 or higher in Pro Tools 12.5 or lower, clip effects will be dropped.

Pro Tools 12.1 or lower, those tracks will be dropped.
• When opening sessions created in Pro Tools 12.1 or higher that have more than the maximum number of audio tracks or instrument tracks in Pro Tools 12.0 or lower, those tracks will be dropped.

Sharing Sessions Between Pro Tools 11.x or Higher and Pro Tools 10.x

Pro Tools 11.x or higher and Pro Tools 10.x sessions are cross-compatible. However, for sessions with 64-bit AAX plug-ins that do not have 32-bit equivalents, those plug-ins will be made inactive when opening the session in Pro Tools 10.x. Likewise, for sessions with 32-bit AAX, RTAS, and TDM plug-ins that do not have 64-bit AAX equivalents, those plug-ins will be made inactive when opening the session in Pro Tools 10.x.

Additionally, for sessions created or modified by Pro Tools 11.x or higher, any instrument tracks beyond 128 will be made inactive when the session is opened in Pro Tools 10.x.

When opening a session in Pro Tools 10.x that was created in Pro Tools 11.x or higher that uses more than 4 GB of RAM (due to plug-in usage), the session will not open.

Sharing Sessions with Video

When opening a session in Pro Tools 11.x or higher created in a lower version of Pro Tools that contains SD video, the aspect ratio must be reset. When opening a session created in Pro Tools 11.x or higher that contains Avid video in a lower version of Pro Tools, the track will be inactive unless the Avid video is an SD resolution and a Mojo or Mojo SDI is attached.

Saving Pro Tools 12.x–10.x Sessions to Pro Tools 7 –> 9 Format

To save a Pro Tools 12.x or 10.x session so it is compatible with Pro Tools version 7.x through 9.x, use the File > Save Copy In command to choose the Pro Tools 7 –> 9 Session format.

When saving a Pro Tools 12.x–10.x session to Pro Tools 7 –> 9 format, the following occurs:
• Any audio tracks beyond 256 are made inactive
• Clip effects and settings are dropped (sessions created in Pro Tools HD 12.6 or higher). If you want to apply any clip effects prior to saving the session copy, you will need to manually render clip effects.
• Clip gain and settings are dropped. If you want to apply any clip gain settings prior to saving the session copy, you will need to manually render clip gain settings.
• Fades have to be rendered when the session is opened in a lower version of Pro Tools.
• Sessions with mixed file formats and bit depths must convert all files to the same file format and bit depth.
• Sessions with files that have a bit depth of 32-bit floating point must be converted to 24-bit or 16-bit.
• For sessions with RF64 files larger than 4 GB, these files will be unavailable to lower versions of Pro Tools. (You will need to manually edit and consolidate these files so that the audio can be available to lower versions of Pro Tools.)
Opening Pro Tools 9.0 Sessions with Pro Tools 8.1 and 8.5

A Pro Tools 9.0 session can be opened with Pro Tools 8.1 and 8.5, but certain session components open differently or not at all.

⚠️ When opening a Pro Tools 9.0 session with Pro Tools 8.1 or 8.5, you are warned that you are opening a session created with a newer version of Pro Tools and that not all session components will be available.

When opening a Pro Tools 9.0 session with Pro Tools 8.1 or 8.5, the following occurs:

• Any audio tracks beyond 256 are made inactive.
• Any internal mix busses beyond 128 are made inactive.
• The Stereo Pan Depth reverts to –2.5 dB.

Opening Pro Tools 9.0 Sessions with Pro Tools 8.0

A Pro Tools 9.0 session can be opened with Pro Tools 8.0, but certain session components open differently or not at all.

⚠️ When opening a Pro Tools 9.0 session with Pro Tools 8.0, you are warned that you are opening a session created with a newer version of Pro Tools and that not all session components will be available.

When opening a Pro Tools 9.0 session with Pro Tools 8.0, the following occurs:

• All that occurs when opening a Pro Tools 9.0 session with Pro Tools 8.1.
• Output bus assignments are removed.
• HEAT (if present) is removed.

Opening Pro Tools 9.0 Sessions with Pro Tools 7.4.x

A Pro Tools 9.0 session can be opened with Pro Tools 7.4.x, but certain session components open differently or not at all.

⚠️ When opening a Pro Tools 9.0 session with Pro Tools 7.4.x, you are warned that you are opening a session created with a newer version of Pro Tools and that not all session components will be available.

When opening a Pro Tools 9.0 session with Pro Tools 7.4.x, the following occurs:

• All that occurs when opening a Pro Tools 9.0 session with Pro Tools 8.0.
• Inserts F–J and any associated automation are removed.
• Clips from audio files larger than 2 GB appear offline.
• Pitch transpositions of Elastic clips are removed.
• Chord markers are removed.

Opening Pro Tools 7.4 or Higher Sessions with Pro Tools 7.3.x or 7.2

A Pro Tools 7.4–9.x session can be opened with Pro Tools 7.3.x or 7.2, but certain session components open differently or not at all.

⚠️ When opening a Pro Tools 7.4–9.x session with Pro Tools 7.3.x, you are warned that you are opening a session created with a newer version of Pro Tools and that not all session components will be available.
When opening a Pro Tools 7.4.x or higher session with Pro Tools 7.3.x or 7.2, the following occurs:

- All that occurs when opening a Pro Tools 8.x or higher session with Pro Tools 7.4.x.
- Elastic Audio-enabled tracks open without Elastic Audio and clip durations revert to the timing of the original source file.
- Sessions with mixed language characters supported in Unicode may not open or, if they do open, Pro Tools displays “garbage” text.

Opening Pro Tools 7.2 or Higher Sessions with Pro Tools 7.1 or 7.0

A Pro Tools 7.2–9.x session without video tracks or VCA Masters can be opened with Pro Tools 7.1 or 7.0, but certain session components open differently or not at all.

⚠️ **When opening a Pro Tools 7.4–9.x session with Pro Tools 7.2, 7.1, or 7.0, you are not warned that not all session components will be available.**

⚠️ **Sessions created with Pro Tools HD 7.2–9.x that contain video tracks or VCA Masters can only be opened with Pro Tools HD 7.1cs3 and higher.**

When opening a Pro Tools 7.4–9.x session with a version of Pro Tools 7.1 or 7.0 the following occurs:

- All that occurs when opening a Pro Tools 7.4 or higher session with Pro Tools 7.3.x or 7.2.

**Tracks**

- VCA Master tracks are removed and any uncoalesced VCA automation is dropped.
- Any uncoalesced Trim automation is dropped.

**Groups**

- All groups beyond the first 26 (Bank 1, Groups a–z) are dropped.
- Mix Groups keep only Main Volume information.
- Mix/Edit Groups keep only Main Volume and Automation Mode information.
- Automation overflow information for grouped controls is not preserved.
- Group behavior of Solos, LFEs, Mutes, Send Levels, Send Mutes is not preserved.
- Solo Mode and Solo Latch settings are dropped.

**Video**

- Only the main video track is displayed.
- Only the first QuickTime movie in the session is displayed or played back.
- If the session contains QuickTime movies in the Clips List but no video track, the session opens with a new QuickTime Movie track containing the first QuickTime movie from the Clips List.
- The Timeline displays and plays back only the video playlist that was last active. Alternate video playlists are not available.
- Video clips and video clip groups are not shown or saved.

Opening Sessions Created with Pro Tools HD 7.2–9.x with Pro Tools LE 8.0

A session created with Pro Tools HD 7.2–9.x session that does not contain video tracks or VCA Masters can be opened with Pro Tools LE 8.0, but certain session components open differently or not at all.

⚠️ **Session created with Pro Tools HD 7.2 or higher that contain video tracks or VCA Master tracks can only be opened with Pro Tools LE 7.0cs3 and higher.**
When opening a session created with Pro Tools HD 7.x–9.x in Pro Tools LE 8.0, the following occurs:

**Tracks**
- Any tracks beyond the first 48, as well any inactive tracks, are set to *voice off*.
- Any assignments to busses beyond 32 are made inactive.
- Any Instrument tracks beyond 32 are made inactive.
- TDM plug-ins with RTAS equivalents are converted; those without equivalents are made inactive.
- Multichannel surround tracks are removed from the session.
- Unavailable input and output paths are made inactive.
- Any Delay Compensation settings are removed.
- VCA Master tracks are removed and any uncoalesced VCA automation is dropped.
- HEAT (if present) is removed (Pro Tools HD 8.1 or higher sessions with HEAT option only).
- Output Bus assignments are removed (Pro Tools HD 8.1 or higher sessions only).

**Groups**
- In Pro Tools LE 7.1 or lower only, all groups beyond the first 26 (Bank 1, Groups a–z) are dropped.
- Mix Groups keep only Main Volume information.
- Mix/Edit Groups keep only Main Volume and Automation Mode information.
- Automation overflow information for grouped controls is be preserved.
- Group behavior of Solos, Mutes, Send Levels, Send Mutes is be preserved.
- Solo Mode and Solo Latch settings are dropped.

**Video**
- Only the main video track is displayed.
- Only the first QuickTime movie in the session is displayed or played back.
- If the session contains QuickTime movies in the Clips List but no video track, the session opens with a new QuickTime Movie track containing the first QuickTime movie from the Clips List.
- The Timeline displays and plays back only the video playlist that was last active. Alternate video playlists are not available.
- In Pro Tools LE 7.1 or lower only, video clips and video clip groups are not shown or saved.

**Saving Pro Tools 12.x–10.x Sessions to Pro Tools 5.1 -> 6.9 Format**

Pro Tools 7.x and higher sessions cannot be opened with Pro Tools versions 6.9.x through 5.1. To save a Pro Tools 12.x–10.x session so it is compatible with Pro Tools version 6.9.x through 5.1, use the File > Save Copy In command to choose the Pro Tools 5.1 -> 6.9 Session format.

⚠ **Pro Tools 8.x and higher supports file sizes up to 3.4 GB, and Pro Tools 10 and higher support file sizes over 4 GB. Pro Tools 5.1 through 6.9 on Mac only supports file sizes up to 2 GB. If your session references audio files larger than 2 GB, edit and consolidate clips to reference only files smaller than 2 GB.**
When saving a Pro Tools 12.x–10.x session to Pro Tools 5.1 -> 6.9 format, the following occurs:

- All that occurs when saving a Pro Tools 12.x–10.x session to Pro Tools 7–>9 session format.

**Tracks**
- Any audio tracks beyond 256 are removed.
- Any internal mix busses beyond 128 are removed.
- Output bus assignments are removed.
- HEAT (if present) is removed.
- Elastic Audio-enabled tracks are saved untransposed, unwarped, and clip durations revert to the timing of the original source file.
- Instrument tracks are split into separate Auxiliary Input and MIDI tracks.
- VCA Master tracks are removed and VCA automation is coalesced to the corresponding slave tracks.
- Trim automation playlists are coalesced to their corresponding automation playlists.
- Fader Gain levels and automation breakpoints higher than +6 dB are changed to +6 dB.
- Long names are shortened to 31 characters.
- The following attributes are dropped:
  - Clip groups
  - Clip loops
  - Sample-based MIDI clips
  - Sample-based MIDI tracks
  - Inserts F–J and any associated automation
  - Sends F–J and any associated automation
  - Marker/Memory Locations 201–999

**Groups**
- All groups beyond the first 26 (Bank 1, Groups a–z) are dropped.
- Mix Groups keep only Main Volume information.
- Mix/Edit Groups keep only Main Volume and Automation Mode information.
- Automation overflow information for grouped controls is not preserved.
- Group behavior of Solos, LFEs, Mutes, Send Levels, Send Mutes is not preserved.
- Solo Mode and Solo Latch settings are dropped.

**Video**
- Only the main video track is displayed.
- Only the first QuickTime movie in the session is displayed or played back.
- If the session contains QuickTime movies in the Clips List but no video track, the session opens with a new QuickTime Movie track containing the first QuickTime movie from the Clips List.
- The Timeline displays and plays back only the video playlist that was last active. Alternate video playlists are not available.
- Video clips and video clip groups are not shown or saved.

**Language Compatibility**
- The Limit Character Set option must be enabled and you must select a single language and character set.
Saving Pro Tools 12.x–10.x Sessions to Pro Tools 5.0 Format

Pro Tools 5.1 and higher sessions cannot be opened with Pro Tools version 5.0.

To save a Pro Tools 12.x–10.x session so it is compatible with Pro Tools version 5.0, use the File > Save Copy In command to choose the Pro Tools 5.0 Session format.

When saving a Pro Tools 12.x–10.x session to Pro Tools 5.0 format, the following occurs:

- All that occurs when saving a Pro Tools 12.x–10.x session to Pro Tools 5.0 format.
- Multichannel surround tracks are removed from the session.
- Inactive tracks are removed from the session.
- Tracks assigned to “No Output” are routed to busses 31 and 32.
- Tracks or sends assigned to busses 33–64 are routed to busses 31 and 32.
- Tracks assigned to multichannel paths or sub-paths of multichannel paths are routed to busses 31 and 32.
- Sends assigned to multichannel paths or sub-paths of multichannel paths are dropped.
- Tracks or sends assigned to stereo paths referring to even/odd channels (such as 2–3) are routed to busses 31 and 32.
- Multi-mono plug-in instances are dropped.

Language Compatibility

Unicode Support for Languages

Pro Tools supports entry and display of any language characters supported in Unicode anywhere in the Pro Tools application. This lets you:

- Use multiple languages in session names, and in path names, file names and clip names within the same session.
- Search for terms in multiple languages in Workspace browsers.

Pro Tools Automatic Naming Language

When working in a language other than English, you can set Pro Tools to automatically name session elements (such as clips, tracks, and I/O paths) in English. This is useful when sharing sessions with other users working in English.

To set the Automatic Naming Language to match the language selected for the Pro Tools application:

1. Choose Setup > Preferences and click the Display tab.
2. Choose the language you want to use in Pro Tools from the Language pop-up menu.
3. Deselect the Default Automatic Naming to English option.
**Pro Tools Application Language**

You can choose the language you want to use in the Pro Tools application, independently of what language the OS is using.

**To select the language for Pro Tools:**

1. Choose Setup > Preferences and select the Display tab.
2. Choose the language you want to use in Pro Tools from the Language pop-up menu.

**Multilingual Application Support for Pro Tools Systems**

*(Localized OS on Mac Only)*

Localized versions of Pro Tools can be opened on a qualified Mac that supports English and the localized language versions of Mac. You can also select a different language in any localized version of Pro Tools (including English) in the Apple System Preferences.

**To change to a different language version of Pro Tools:**

1. Quit Pro Tools if it is currently open.
2. Launch Apple System Preferences.
3. Click International (the “flag” icon).
4. Click the Language tab.
5. In the Languages column, drag the language you want to the top of the list.
6. Close the International window.
7. Do one of the following:
   - If you are changing from a localized language to English, launch Pro Tools.
   - If you are changing from one language to another (or from English to a localized language), log out and log in from the Apple menu, then launch Pro Tools.

⚠️ If you want your computer to start with the previous language (after working on a different language version) follow the above steps and change the International preference back to the previous language.
Part IV: Playback and Recording
Chapter 22: Playing Back Track Material

After importing or recording audio or MIDI to tracks, you will want to play back the material when editing and mixing.

Starting and Stopping Playback

To start playback, do one of the following:
• Click Play in the Transport.
• Press the Spacebar.
• With the Numeric Keypad mode set to Transport or Shuttle, press 0 on the numeric keypad.
• If the Numeric Keypad mode is set to Transport, and the Use Separate Play and Stop Keys option is enabled, press Enter on the numeric keypad.
• If you have a worksurface or MIDI control surface connected and configured, press the Play switch.
• If Pro Tools is online and slaved to another deck, press play on the master deck (see “4% audio pull rates are not available in 176.4 and 192 kHz sample rate sessions.Putting Pro Tools Online” on page 1281).

To stop playback, do one of the following:
• Click Stop in the Transport.
• Press the Spacebar.
• With the Numeric Keypad mode set to Transport or Shuttle, press 0 on the numeric keypad.
• If you have a control surface connected and configured, press the Stop switch.
• If Pro Tools is online and slaved to another deck, press stop on the master deck (see “4% audio pull rates are not available in 176.4 and 192 kHz sample rate sessions.Putting Pro Tools Online” on page 1281).

Playing Back Audio

To play back audio:
1 Import or record audio to a track.
2 Assign the track’s Output selector to your main monitoring path.
3 To have playback start from the beginning of the session, click Return to Zero in the Transport.
4 Start playback.
5 The audio plays through the selected Output Path. Adjust the track’s volume and pan faders as necessary.
6 When you are finished, stop playback.

For more information about the Numeric Keypad modes, see “Numeric Keypad Modes” on page 28.
Playing Back MIDI

To play back MIDI (and monitor the audio):

1. Import, record, or enter MIDI into an Instrument or MIDI track.

2. For an Instrument track, do the following:
   • Set the Instrument track’s audio Output selector to the main monitoring path.
   • If you are using an Instrument Plug-In, insert the plug-in on the track. The track’s MIDI Output selector (in Instrument view) should be automatically set to the plug-in.
   • If you are using an external MIDI device (not an Instrument plug-in), set the MIDI Output selector in Instrument view to the MIDI device (port) and channel you want to play back.
   • If you are using an external MIDI device (not an Instrument plug-in), set the Instrument track’s audio Input selector to the Input path to which your MIDI device’s audio outputs are connected.

3. For a MIDI track, do the following:
   • If you are using an Instrument plug-in, create an Auxiliary Input or Instrument track insert the Instrument plug-in on the track.
   • If you are using an external MIDI device (not an Instrument plug-in), create an Auxiliary Input or Instrument track to monitor the audio from an external MIDI device or Instrument plug-in.
   • If you are using an external MIDI device (not an Instrument plug-in), set the Auxiliary Input or Instrument track’s audio Input selector to the Input path to which your MIDI device’s audio outputs are connected.
   • Set the Auxiliary Input or Instrument track’s audio Output selector to the main monitoring path.
   • Set the MIDI track’s output selector to the Instrument plug-in, or MIDI device (port), and channel you want to play back.

4. To have playback start from the beginning of the session, click Return to Zero in the Transport.

5. Start playback.

6. The MIDI plays the selected MIDI device, and the audio from the MIDI device is monitored through the selected Output Path on the Auxiliary Input or Instrument track. Adjust the MIDI, Auxiliary Input, or Instrument track’s volume and pan faders as necessary.

7. When you are finished, stop playback.

For information about synchronizing external MIDI devices with Pro Tools for playback and recording using MIDI Beat Clock, see “MIDI Beat Clock” on page 489, and for information about using MIDI Timecode, see “Generating Timecode” on page 1282.

Playback Location

The playback location is the point in the Pro Tools Timeline where you can begin playing back audio or MIDI in your session.

The playback location is displayed in counters and indicators in the Edit window, Transport window, and Big Counter. The playback location (or Edit selection) is also indicated by a playback or edit cursor in the Timeline or playlist of the Edit window.

Pro Tools also provides a pre-roll control for setting playback to begin before the playback location. See “Basic Transport Controls and Counters” on page 194.
Counters and Indicators that Display the Playback Location

Main and Sub Counters and Edit Selection Indicators

At the top of the Edit window, the playback location is displayed in the Main and Sub counters, and the Edit Selection Start indicator. If no selection is made, the playback location is also displayed in the Edit Selection End indicator.

Counters and Edit Selection indicators can also be displayed in the Transport window.

To display the Main Counter in the Transport window:

- Select View > Transport > Counters.

To display the Sub Counter in the Transport window:

1. Select View > Transport > Counters.
2. Select View > Transport > Expanded.

To display Edit Selection indicators in the Transport window:

- Select View > Transport > Expanded.

The Big Counter

The current playback location can also be displayed in the Big Counter.

To display the Big Counter:

- Choose Window > Big Counter.

 Cursors that Indicate the Playback (or Edit) Location

There are two types of cursors in the Pro Tools Edit window for indicating the current playback or Edit selection:

Playback Cursor

The playback cursor is a solid line that moves across the Edit window to indicate the current playback location.

The selected Scrolling Option determines how the Edit window scrolls during playback, and how the playback cursor functions. See “Scrolling Options” on page 480 for details.
Edit Cursor

The edit cursor is a flashing line that appears when you click with the Selector tool in a track’s playlist. The flashing edit cursor indicates the start point for any editing tasks performed. If you make a selection and perform an edit, the selection is the target of the edit.

Locating the Playback Cursor when It Is Off-Screen

Use the Playback Cursor locator to locate the playback cursor when it is off-screen.

If the playback cursor is located after the time visible in the Edit window, the Playback Cursor locator appears on the right edge of the Main Timebase ruler. If the playback cursor is located before the time visible in the Edit window, the Playback Cursor locator appears on the left edge of the Main Timebase ruler.

For example, if the Scrolling option is set to None, the playback cursor moves off-screen after it has played past the time currently visible in the Edit window. The Playback Cursor locator appears on the right edge of the Main Timebase ruler after the playback cursor has moved beyond the time visible in the Edit window.

The Playback Cursor locator is red when a track is record-enabled and blue when no track is record-enabled.

To locate the playback cursor when it is off-screen:

- Click the Playback Cursor locator in the Main Timebase ruler.

The Edit window changes to center the playback cursor on-screen.

Setting the Playback Location

Pro Tools provides commands for different ways of setting or moving the playback location in a session. These include finding a passage in a song, moving to a different section of your arrangement, or comparing different sections.

Setting Playback Location Using the Selector Tool

To set where playback begins, you can click anywhere in a track with the Selector tool (as long as the Timeline and Edit selections are linked). See “Linking or Unlinking Timeline and Edit Selections” on page 629.

Playback Cursor locator, recording enabled (playback cursor located after currently viewed audio)

Setting a playback point with the Selector tool
To begin playing from a specific point within a track:

1. Make sure that Options > Link Timeline and Edit Selection is enabled.
2. With the Selector tool, click in the track where you want playback to begin.
3. Start playback.
4. Stop playback.

To jump to a different location and begin playing from there, do one of the following:

- When playback is stopped, click with the Selector tool at the point you want to start playback and click Play in the Transport window.
- During playback, click the new location in any Timebase Ruler.

With the Timeline and Edit selections linked, you can click a clip or MIDI note with the Time Grabber tool to automatically update the Timeline with the selection’s start time, letting you play from that point.

Setting Playback Location with Basic Transport Controls

Transport controls in the Transport window and top of the Edit window can be used to move the playback location. These include Rewind, Fast Forward, and Return to Zero (to move playback location to the beginning of the session). For more information, see “Basic Transport Controls and Counters” on page 194.

Setting Playback Location with the Main Counter or Edit Selection Start Indicator

To set the playback location using a Main Counter (or the Edit Selection Start indicator):

1. Do one of the following:
   - Click in one of the counters.
   - Press asterisk (*) on the numeric keypad to highlight the Main Counter in the Edit window (or the Main Counter in the Transport window or Big Counter window, if either are displayed).
2. Type in the new location. Press Period (.) to cycle through to the different time fields.
3. Press Enter to accept the new value and automatically locate there.

Setting Playback Location with Fast Forward/Rewind

You can use the Fast Forward and Rewind buttons in the Transport window to move the playback location. If the Operation preference for Audio During Fast Forward/Rewind is selected, the scanned audio is heard (similar to a CD player) when clicking the Fast Forward and Rewind buttons.

You can also fast forward or rewind incrementally by repeatedly clicking the appropriate button. The size of these increments is determined by the Main Time Scale:

- **Bars|Beats** Moves to the beginning of the previous or next bar.
- **Min:Sec** Moves back or forward in one-second steps.
**Timecode** Moves back or forward in one-second steps (while adjusting for current SMPTE format).

**Feet+Frames** Moves back or forward in one-foot steps.

**Samples** Moves back or forward in one-second steps.

### Setting Playback Location with Back and Forward Commands

(Pro Tools | Ultimate Software Only)

Pro Tools provides four Back/Forward commands (sometimes called “rollback”) for moving the playback location in the Edit window.

You can also move the playback location in multiple increments by repeating the command (See “Repeating Back/Forward Commands” on page 479).

To configure the Back/Forward Amount:
1. Choose Setup > Preferences and click the Operation tab.

The timebase of the Back/Forward Amount settings follows the Main Time Scale by default, or you can deselect Follow Main Time and select any of the following timebase formats:

- Bars|Beats
- Min:Sec
- Timecode
- Feet+Frames
- Samples

2. Do one of the following:
   - Select a preset amount in the Back/Forward Amount pop-up menu.
   - In the Back/Forward Amount field, enter a custom amount.

### Using Back or Forward Commands

To move the playback location backward by the Back/Forward Amount:

- Press Command (Mac) or Control (Windows), and click Rewind in the Transport window.

To move the playback location forward by the Back/Forward Amount:

- Press Command (Mac) or Control (Windows), and click Fast Forward in the Transport window.

To move the playback location backward by the Back/Forward Amount and then begin playback:

- Press Command+Option (Mac) or Control+Alt (Windows), and click Rewind in the Transport window.
To move the playback location forward by the Back/Forward Amount and then begin playback:

- Press Command+Option (Mac) or Control+Alt (Windows), and click Fast Forward in the Transport window.

Repeating Back/Forward Commands

All the Back/Forward commands can be repeated in order to increase the amount of the total Back or Forward move.

To repeat Back/Forward moves:

1 Hold Command (Mac) or Control (Windows).

2 Click Rewind or Fast Forward the number of times you want to repeat moving the playback location backwards or forwards by the specified Back/Forward Amount.

Extending Selections with Back or Back and Play Commands

The Back or Back and Play commands can be used to extend a selection backwards by the length of the specified Back/Forward Amount.

Although you cannot extend a selection with the Forward or Forward and Play commands, you can use the following procedures with Forward or Forward and Play to move the start point of a current selection.

To extend a selection with Back or Back and Play commands:

1 Specify the Back/Forward Amount. (See “Setting the Back/Forward Amount” on page 478.)

2 With the Selector tool, drag within a track to make a selection.

3 Do one of the following:

- To extend the selection backwards by the Back/Forward Amount, press Shift+Command (Mac) or Shift+Control (Windows) and click Rewind in the Transport window.

- To extend the selection backwards by the Back/Forward Amount and then begin playback, press Shift+Command+Option (Mac) or Shift+Control+Alt (Windows) and click Rewind in the Transport window.

Additional Ways of Moving the Playback Location

You can also move the playback location with the following:

Shuttle Lock Modes With either Shuttle Lock mode (Classic or Transport) you can use the numeric keypad to shuttle forward or backwards at specific speeds. For more information, see “Shuttle Lock Modes” on page 28.

Memory Locations Memory Locations can be used to move the playback location (or Edit selection). When a Memory Location is recalled, the playback location (or Edit selection) updates. Memory Locations can be recalled from the Memory Locations window and from the numeric keypad. In addition, Marker Memory Selections can be recalled by clicking them in the Markers ruler. For more information, see “Recalling Memory Locations” on page 885.

Tabbing to Transients With the Tab to Transients button enabled, you can automatically navigate to transients in audio waveforms, placing the cursor just before the detected transient peak. For more information, see “Tabbing to Transients” on page 641.
Scrolling Options

You can configure how contents of the Edit window scroll during playback and recording.

To configure Scrolling options:

- Choose Options > Scrolling and select one of the following options:

**No Scrolling** The Edit window does not scroll during or after playback. The playback cursor moves across the Edit window, indicating the playback location.

**After Playback** The playback cursor moves across the Edit window, indicating the playback location. When playback has stopped, the Edit window scrolls to the final playback location.

**Page** The playback cursor moves across the Edit window, indicating the playback location. When the right edge of the Edit window is reached, its entire contents are scrolled, and the playback cursor continues moving from the left edge of the window. For more information, see “Page Scrolling During Playback” on page 480.

**Continuous** See “Continuous Scrolling During Playback” on page 480.

**Center Playhead (HDX and HD Native Systems Only)** See “Center Playhead Scrolling” on page 481.

- You can change the Scrolling option while the Transport is running.

Page Scrolling During Playback

You can set Pro Tools to scroll the track display while playing, and also have the edit cursor appear wherever playback stops.

To make the track display and the edit cursor follow playback:

- Enable the Timeline Insertion/Play Start Marker Follows Playback button in the Edit window.

![Timeline Insertion/Play Start Marker Follows Playback button enabled](image)

- You can enable or disable the Timeline Insertion/Play Start Marker Follows Playback option in the Operation Preferences.

- Press Control+N (Mac) or Start+N (Windows) to toggle the Timeline Insertion/Play Start Marker Follows Playback preference on and off.

Continuous Scrolling During Playback

When this scrolling option is selected, the Edit window’s contents scroll continuously past the playback cursor, which remains in the center of the window. With this option, playback is always based on the Timeline selection (unlike the Center Playhead Scrolling option).
Continuous Scrolling During Playback uses host processing power, so use this option with host-based Pro Tools systems only when absolutely necessary.

**Center Playhead Scrolling**  
(HDX and HD Native Systems Only)

When this scrolling option is selected, the Edit window’s contents scroll continuously past the Playhead, which is a blue line in the center of the window (or a red line when recording).

The Playhead indicates where playback begins when clicking Play in the Transport window.

To move the Playhead to a particular location for playback, you can scroll there in a ruler (see “Scrolling in a Timebase Ruler” on page 644), use the Edit window’s horizontal scroll bar, or type the location into one of the Edit Selection indicators or one of the Counters.

Moving the Playhead with these methods does not update the Timeline selection. However, updating the Timeline selection automatically moves the Playhead to the Timeline insertion point.

With the Playhead enabled, you can jump to and play an Edit or Timeline selection. For details, see “Playing Timeline and Edit Selections with the Playhead” on page 483.

⚠️ *Center Playhead Scrolling and Dynamic Transport mode cannot be used at the same time. Selecting Center Playhead Scrolling disables Dynamic Transport mode (if it is enabled). Likewise, enabling Dynamic Transport mode when Center Playhead Scrolling is selected automatically changes the Scrolling option to No Scrolling.*

**Half-Screen Edit Window**

When the Scrolling option is set to Continuous or Center Playhead, a half-screen appears at the far left of the Edit window (before the beginning of the session) when the Playhead is at the beginning of the session.

**Playing Selections**

Once an Edit selection is made, you can audition it by clicking Play in the Transport window. If enabled, the pre- and post-roll amounts play as well.

**To play a selection:**

1. Select Options > Link Timeline and Edit Selection.
2. With the Selector or Time Grabber tool, make a track selection.
3. If you want to use pre-roll or post-roll, enable and set the pre-roll and post-roll amounts. For details, see “Setting Pre- and Post-Roll” on page 523.
4. Click Play in the Transport window, or press the Spacebar.
All tracks play for the range of the selection, including pre-roll and post-roll if enabled.

To play an Edit selection with Link Timeline and Edit Selection disabled:
- Choose Edit > Selection > Play Edit.

To play a Timeline selection with Link Timeline and Edit Selection disabled:
- Choose Edit > Selection > Play Timeline.

Auditioning Pre-Roll and Post-Roll

You can audition and play just the pre-roll or post-roll material for a selection.

To play from the pre-roll point to the start of a selection, or to the current Cursor location:
- Press Option+Left Arrow (Mac) or Alt+Left Arrow (Windows).

To play to the post-roll point from the end of a selection, or from the current Cursor location:
- Press Command+Right Arrow (Mac) or Control+Right Arrow (Windows).

Auditioning Start and End Points for Selections

There may be times when you want to audition the start or end of an audio selection without hearing the entire selection. This allows you to check, for instance, whether the beginning or end of a selection includes any unwanted clicks or pops.

To audition a selection start point:
- Press Command+Left Arrow (Mac) or Control+Left Arrow (Windows).

When auditioning the beginning of a selection, the selection plays from the start point for a duration equal to the post-roll amount.

To audition a selection start point with pre-roll:
- Press Command+Option+Left Arrow (Mac) or Control+Alt+Left Arrow (Windows).

To audition a selection end point:
- Press Option+Right Arrow (Mac) or Alt+Right Arrow (Windows).

When auditioning the end of a selection, playback begins before the end point by the pre-roll amount.

To audition a selection end point with post-roll:
- Press Command+Option+Right Arrow (Mac) or Control+Alt+Right Arrow (Windows).
Transport Fade-in

Pro Tools provides a Fade-in option for the Transport. Enable this option to fade in the levels for all source audio linearly, from silence to the current levels of the source audio when the transport starts. The Fade-in time can be set between 0.000 and 4.000 seconds. This option is useful for avoiding pops and clicks, or sudden boosts in volume when relocating the playback location during playback.

For music production scenarios, use shorter fade-in times (250 ms). In certain post-production scenarios when synchronizing to external decks, use longer fade-in times depending on how long it takes for all synchronized decks to lock to time-code (up to 2 seconds).

To enable (or disable) the Fade-in Transport option:
1. Open the Expanded Transport window.
2. Click Fade-in so that it is lit (or unlit).

To set the Fade-in time for the Transport:
1. Open the Expanded Transport window.
2. Click in the numeric field to the right of the Fade-in enable button.
3. Type in the desired time.
4. Press Return (Mac) or Enter (Windows) on your computer keyboard.

Be sure to disable the Fade-in Transport option when recording. Audio that is recorded with the Fade-in Transport option enabled will include a fade based on the set Fade-in duration.

Playing Timeline and Edit Selections with the Playhead
(Pro Tools | Ultimate Software Only)

When the Scrolling option is set to Center Playhead, selections in the Timeline do not determine when playback begins. The Playhead itself denotes where playback begins.

Timeline and Edit selections, however, can still be played when the Playhead is enabled.

To play an Edit selection with the Playhead enabled:
1. Deselect Options > Link Timeline and Edit Selections.
2. Select Options > Scrolling > Center Playhead.
3. With the Selector or Time Grabber tool, make a track selection.

To play a Timeline selection with the Playhead enabled:
1. Deselect Options > Link Timeline and Edit Selections.
2. Select Options > Scrolling > Center Playhead.
3. Drag with the Selector tool in any Timebase ruler to set the play range.
4. Choose Edit > Selection > Play Timeline.
Moving the Playhead

When the Scrolling option is set to Center Playhead, the Playhead can be moved forward or back to the next clip boundary in the selected track.

To move the Playhead through a track's clip boundaries:

1. Make sure the Tab to Transients button is not enabled (see “Tabbing to Transients” on page 641).
2. Click in the track with the Selector tool.
3. Do one of the following:
   • Press Tab to move the Playhead forward to the next clip boundary.
   • Press Option+Tab (Mac) or Control+Tab (Windows) to move the Playhead back to the previous clip boundary.

Playback Modes

Pro Tools provides several Playback modes:

• Normal Playback mode
• Half-Speed Playback mode
• Prime for Playback mode
• Loop Playback mode
• Dynamic Transport mode

Normal Playback Mode

Normal Playback mode is simply when none of the other Playback modes are selected. In Normal Playback mode, Pro Tools plays back at the session sample rate.

Half-Speed Playback Mode

Use Half-Speed Playback mode to learn or transcribe difficult passages in recorded tracks.

To play at half-speed:

1. Do one of the following:
   • Shift-click the Play button in the Transport.
   • Right-click the Play button in the Transport and select Half-Speed. Then click Play to start Half-Speed Playback.

   You can also play at half-speed by pressing Shift+Spacebar.

2. Click Stop in the Transport to stop playback.

Prime for Playback Mode

When playing back a large number of tracks, Pro Tools may take a little longer to actually start playback. To avoid this delay, put Pro Tools in Prime for Playback mode before starting playback.

To enable Prime for Playback mode and start playback:

1. Do one of the following:
   • Option-click (Mac) or Alt-click (Windows) Play in the Transport to put Pro Tools in Prime for Playback mode.
   • Right-click the Play button and select Prime for Playback.

The Stop button lights and the Play button flashes.

2. To begin playback instantaneously, click Play.

3. Click Stop to stop playback.

When synchronizing to timecode, use Prime for Playback mode to play back large numbers of tracks. This decreases the time it takes to lock to timecode.
Loop Playback Mode

When Loop Playback mode is enabled, the selected track range repeats on playback. If there is no selection, playback occurs normally from the current Cursor location.

A selection must be at least 500 ms in length for it to loop on playback.

Looping playback is a useful way to check the rhythmic continuity of a selection when working with musical material. If you’re working with one-bar selections, you can loop playback to see if the material loops cleanly. If it seems to skip, you should then adjust the length of the selection until it works “musically” within the context of the playlist and the other tracks.

To loop playback of a selection:
1. Select Options > Link Timeline and Edit Selection.
2. With the Selector tool, select the track range you want to loop.
3. Enable Loop Playback by doing one of the following:
   • Select Options > Loop Playback.
   • Right-click the Play button in the Transport window and select Loop from the pop-up menu.
   • Control-click (Mac) or Start-click (Windows) the Play button in the Transport window.
   • Press Command+Shift+L (Mac) or Control+Shift+L (Windows).
   • With the Numeric Keypad mode set to Transport, press 4 on the numeric keypad.

When enabled, a loop symbol appears in the Play button in the Transport window.

4. Click Play in the Transport window.
   
   Playback begins from the pre-roll point (if enabled) and continues to the selection’s end point, where it loops back to the selection’s start point.

5. Click Stop in the Transport window to stop playback.

Loop Playback and Audio Recording

Looping playback does not enable loop recording. Use Loop Record mode to loop during recording (see “Loop Recording Audio” on page 528).

Dynamic Transport Mode

Dynamic Transport mode lets you decouple the playback location from the Timeline selection. This means that you can start playback from anywhere on the Timeline without losing your Timeline or Edit selections. For example, you can use Dynamic Transport mode in conjunction with Loop Playback mode to quickly audition loop transitions.

When Dynamic Transport mode is enabled, the Main Timebase ruler expands to double-height and reveals the Play Start Marker. The Play Start Marker determines where playback starts when the Transport is engaged. You can position the Play Start Marker independently of the Timeline Selection. The Play Start Marker can be repositioned during playback and playback continues from the new location.
To enable or disable Dynamic Transport mode, do one of the following:

- Select or deselect Options > Dynamic Transport.
- Right-click the Play button in the Transport window and select Dynamic Transport from the pop-up menu.
- Press Command+Control+P (Mac) or Control+Start+P (Windows) to toggle Dynamic Transport mode on or off.

⚠️ Enabling Dynamic Transport mode automatically disables Link Timeline and Edit Selection, and automatically enables Loop Playback mode.

⚠️ Center Playhead Scrolling (Pro Tools Ultimate only) and Dynamic Transport mode cannot be used at the same time. Selecting Center Playhead Scrolling disables Dynamic Transport mode (if it is enabled). Likewise, enabling Dynamic Transport mode when Center Playhead Scrolling is selected automatically changes the Scrolling option to No Scrolling.

To reposition the Play Start Marker, do one of the following:

- With any Edit tool selected, click in the Play Start Marker strip in the Main Timebase ruler.
- With any Edit tool selected, drag the Play Start Marker to a new location.
- Click Fast Forward or Rewind in the Transport to relocate the Play Start Marker forward or backward by the standard Fast Forward and Rewind increment amount.

💡 Double-click anywhere in the Play Start Marker strip in the Main Timebase ruler to move the Play Start Marker to that location and start playback.
To change the Timeline Selection Start or End Markers:

1. Make a Timeline selection with the Selector tool by dragging in the Main Timebase ruler. If the Link Timeline and Edit Selection option is enabled, you can make an Edit selection with the Selector or any of the Grabber tools.

2. With any Edit tool selected, drag either the Timeline Selection Start or End Markers left or right, extending or constricting the Timeline selection.

⚠️ Changes to the Timeline selection during playback temporarily interrupt playback. To minimize this interruption, reduce the AAE Playback Buffer size in the Playback Engine dialog.

To move the Timeline selection:

- With any Edit tool selected, drag the selection on the Main Timeline ruler to another location.

Dynamic Transport mode, moving the Edit selection

When the Link Timeline and Edit Selection option is disabled, Option-drag (Mac) or Alt-drag (Windows) the Timeline selection to snap the Edit selection to the Timeline selection and move both in tandem.

Play Start Marker Follows Timeline Selection

When enabled, the Play Start Marker snaps to the Timeline Selection In Point when you move the Timeline Selection, draw a new Timeline Selection, or adjust the Timeline Selection Start. When disabled, the Play Start Marker doesn’t move with the Timeline selection.

To have the Play Start Marker always snap to the Timeline Selection In Point:

1. Choose Setup > Preferences.
2. Click the Operation tab.
3. Select Play Start Marker Follows Timeline Selection.
4. Click OK.

Timeline Insertion Follows Playback

When enabled, the Timeline Insertion follows playback.

To have the Timeline Insertion follow playback, do one of the following:

- Select Option > Insertion Follows Playback.
- In the Edit window Toolbar, select the Insertion Follows Playback button so that it is lit.

![Insertion Follows Playback button enabled](image)

Press Control+N (Mac) or Start+N (Windows) to toggle Insertion Follows Playback on and off.
Using Dynamic Transport Mode with Loop Playback

Use Dynamic Transport mode in conjunction with Loop Playback to specify the loop start and end points with the Timeline selection while using the Play Start Marker to specify where playback begins. This is especially useful for auditioning loop transitions. Note that enabling Dynamic Transport mode automatically enables Loop Playback mode.

To audition a loop transition:

1. Enable Dynamic Transport mode.
2. Ensure that Loop Playback mode is enabled.
3. Make a Timeline selection to loop.
4. Reposition the Play Start Marker before the Timeline Selection Out Point.
5. Start playback.

Playback starts before the loop end point and continues across the loop point through the loop start. You can reposition the Timeline Selection Start and End Markers by dragging them left or right, even during playback.

Using Separate Play and Stop Keys

When enabled, the Use Separate Play and Stop Keys option lets you start playback with the Enter key and stop playback with the 0 key on the numeric keypad. This is useful for quickly starting and stopping playback when auditioning loop transitions.

To use separate play and stop keys on the numeric keypad:

1. Choose Setup > Preferences.
2. Click the Operation tab.
4. Select Use Separate Play and Stop Keys.
5. Click OK.

The Enter key starts playback. The Zero key stops playback. Pressing Zero twice locates the Play Start Marker to the Timeline Selection start.

Keyboard Shortcuts for Relocating the Play Start Marker

In Dynamic Transport mode, you can use keyboard shortcuts to quickly relocate the Play Start Marker either during playback or when the Transport is stopped.

To move the Play Start Marker to the Timeline Selection Start:

- Press Period (.) on the numeric keypad and then the Left Arrow.
To move the Play Start Marker to the Timeline Selection End:
- Press Period (.) on the numeric keypad and then the Right Arrow.

To move the Play Start Marker to the Edit Selection Start:
- Press Period (.) on the numeric keypad and then the Down Arrow.

To move the Play Start Marker to location of the Playhead:
- Press Period (.) on the numeric keypad and then the Up Arrow.

To nudge the Play Start Marker backward (rewind):
- Press 1 on the numeric keypad.

To nudge the Play Start Marker forward (fast forward):
- Press 2 on the numeric keypad.

To move the Play Start to a specific bar:
- With Bars|Beats selected as the Main Timebase ruler, do the following on the numeric keypad:
  - Press Asterisk (*).
  - Type the bar number.
  - Press Enter.

Recording in Dynamic Transport Mode

Recording in Dynamic Transport mode lets you start playback independently of the Timeline selection. Use the Play Start marker as a manual preroll before the Timeline selection. Recording punches in and out based on the Timeline selection.

MIDI Beat Clock

Pro Tools can transmit MIDI Beat Clock to synchronize external MIDI devices that receive MIDI Beat Clock (such as drum machines, hardware sequencers, or arpeggiators) with the Pro Tools session tempo for playback and recording. Some instrument plug-ins also support MIDI Beat Clock for synchronizing to the Pro Tools tempo.

For information about synchronizing external MIDI devices with Pro Tools for playback and recording using MIDI Timecode, see “Generating Timecode” on page 1282.

Transmitting Beat Clock

To transmit MIDI Beat Clock:
1. Choose Setup > MIDI > MIDI Beat Clock.
2. In the MIDI Beat Clock dialog, select the Enable MIDI Beat Clock option.
3. Select the devices you want to receive MIDI Beat Clock. If your MIDI interface does not support transmitting MIDI Beat Clock to separate ports, only the interface appears as a destination.

MIDI Beat Clock dialog
Enter the correct negative offset values (such as “–200” samples) for each port that is enabled for transmitting MIDI Beat Clock (see “Measuring Beat Clock Latency” on page 490).

Click OK.

**Sending MIDI Beat Clock Over IAC** *(Mac Only)*

You can synchronize other MIDI applications that use the Apple Inter-Application Communication (IAC) driver to Pro Tools by transmitting MIDI Beat Clock on the IAC bus.

1. Choose Setup > MIDI > MIDI Studio.
2. In the MIDI Devices window of Audio MIDI Setup, double-click the IAC Driver icon.
3. Configure the IAC Driver ports and confirm that it is online.
5. In the MIDI Beat Clock dialog, select the Enable MIDI Beat Clock option.
6. Select the IAC Driver ports you want to enable for sending MIDI Beat Clock.
7. Click OK.

**MIDI Beat Clock Offsets**

You can set an offset for MIDI Beat Clock on a port-by-port basis with your MIDI interface and external MIDI devices. This lets you adjust the timing for each device where some devices sound late due to different, fixed latencies. Where appropriate, enter negative offset values in samples for each port to correctly synchronize the audio signals from your external MIDI devices with Pro Tools playback.

---

**Measuring Beat Clock Latency**

To determine the correct MIDI Beat Clock offset for an external MIDI device:

1. Ensure that your computer and external MIDI device are correctly connected and configured for MIDI, and that its audio output is correctly connected to audio inputs on your Pro Tools audio interface.
2. Ensure that your external MIDI device is configured to receive MIDI Beat Clock, and that it is correctly configured to play back a simple rhythmic pattern “on the beat.”
3. Create a new Pro Tools session.
4. In the MIDI Beat Clock dialog, ensure that MIDI Beat Clock is enabled and that the device is selected.
5. Set the Main Time Scale to Bars|Beats.
6 Create a new audio track and select the audio input channels for your external MIDI device.

7 Record enable the audio track and start recording. MIDI Beat Clock is sent to the external MIDI device, which starts playing back the pattern.

8 Stop recording after a few bars.

9 Enable both Snap to Grid and Show Grid.

10 With the Selector tool, place the edit cursor on the beat grid prior to a prominent transient in the waveform that is “on the beat.”

11 Enable Tab to Transients and Shift+Tab to the transient. The duration of this selection is the approximate amount of latency for your external MIDI device.

12 Switch the Main Time Scale to Samples. The length of the selected clip in samples is the MIDI Beat Clock latency for that device.

13 In the MIDI Beat Clock dialog, enter the Sample Offset value as a negative number.

---

Measuring the offset for MIDI Beat Clock in samples

MIDI Beat Clock Sample Offset

💡 Since MIDI is not sample accurate, you may want to make several measurements at different grid locations and average them to come up with the best value for the MIDI Beat Clock Offset.

💡 Once you have measured the latency for your MIDI Beat Clock-enabled devices, be sure to keep a record of these values in case you need to re-enter the MIDI Beat Clock Sample Offset in other sessions.
Chapter 23: Record Setup

Before you start recording in Pro Tools, you need to set up your Pro Tools system, a session, and one or more tracks for recording. You will also need to configure how Pro Tools monitors the input you intend to record.

While some of the information here is relevant to preparing to record MIDI, there are more specific setup details for MIDI recording in Chapter 25, “MIDI Recording.”

For information on recording audio, see Chapter 24, “Audio Recording.”

Record Setup Overview

Record setup includes the following:

Session Setup for Recording
- Configuring a new or existing session for recording:
  - “Working with Hard Drives for Recording” on page 508
  - “Recording with a Click” on page 496
  - “Setting the Session Meter and Tempo” on page 498
  - Setting a Record Mode. See “Record Modes” on page 501

Track Setup for Recording
- Configuring one or more tracks for recording:
  - “Configuring Default Names for Audio Files and Clips” on page 504
  - “Assigning Hardware I/O on a Track” on page 505
  - “Record Enabling Tracks” on page 506
  - “Recording with Multiple Hard Drives” on page 509

Monitoring Setup for Recording
- “Selecting a Record Input Monitoring Mode” on page 511
- “Setting Monitor Levels for Record and Playback” on page 513
- “Reducing Monitoring Latency” on page 513
- “Recording with Delay Compensation” on page 514

For information on digitizing (recording) video in Pro Tools, see Chapter 60, “working with Video in Pro Tools” or the Avid Video Peripherals Guide.
### Configuring Pro Tools Hardware I/O for Recording

Before you start recording, make sure your Pro Tools system hardware is connected and configured properly. For details on connecting Pro Tools to your studio and configuring your Hardware in the Hardware Setup dialog, see the User Guide that came with your system. For information on how to route audio signal paths in Pro Tools, see Chapter 6, “I/O Setup.”

### Input Connections and Audio Levels

Avid HD audio interfaces operate as line-level devices and offer no pre-amplification. Low-level sources like microphones and electric guitars need to be pre-amplified. You can do this with a quality mixing board or dedicated preamp (such as PRE).

💡 **PRE can be remote-controlled from within Pro Tools sessions.**

003 Rack+ has eight inputs with preamps, to which you can connect low-level signals.

003 and 003 Rack have four inputs with preamps, to which you can connect low-level signals, and four additional line-level inputs with switchable gain.

Eleven Rack has one Mic input with a preamp and 1 instrument-level Guitar input with a special variable-impedance circuit called True-Z (for more information, see the Eleven Rack User Guide.)

Mbox (3rd generation), Mbox 2, Mbox Pro, Mbox 2 Pro, Mbox Mini, and Mbox 2 Mini each have two inputs with preamps, to which you can connect low-level signals.

For all systems, volume and pan controls for tracks in Pro Tools only affect monitoring levels—not the recording input gain. The LED meters on HD audio interfaces (such as HD I/O or HD OMNI) indicate both full-code (highest level before clipping) and true clipping of Pro Tools output signals. The on-screen meters in Pro Tools indicate true clipping on audio input and when recording to disk. With Pro Tools, it is possible to clip at the input and output converters on your audio interface, as well as when recording to a fixed-point file bit depth (16- or 24-bit only, 32-bit floating point bit depth will not clip).

### Digital Clipping

Clipping occurs when you feed a signal to a recorder or mixer that is louder or “hotter” than the device allows. On many analog tape decks, a little clipping adds a perceived warmth to the sound due to tape compression. In digital recording, however, clipping causes digital distortion, which is undesirable and should always be avoided.

### Set Input Levels

When you feed a signal into any audio recording system, including Pro Tools, make sure to adjust the input level to optimize the dynamic range and signal-to-noise ratio of the recorded file. If the input level is too low, you will not take full advantage of the dynamic range of your Pro Tools system. If the input level is too high, the waveform can clip and distort the recording. Set the input levels high, but not high enough to clip.

As a general rule of thumb, try to set levels so that they peak within –3 dB to –12 dB on the input meter without triggering the clipping indicator on your audio interface. Depending on the type of material you are recording and its dynamic range and peak content, you may want to record with higher or lower levels.
You can display a track’s input levels in its Audio Volume indicator. Normally, this indicator is set to be a Peak Volume indicator. You can also use the Headroom indicator to compare the incoming peak level of the signal with how much headroom is available.

To display a track’s peak level:

- Command-click (Mac) or Control-click (Windows) a track’s Volume indicator to step through the different indicator modes (Volume or Channel Delay) until the indicator displays peak (pk) level.

Headroom Indicator

Pro Tools provides a numeric display (in dB) of the available headroom on tracks based on the last registered sample peak level in relation to the reference level of the currently selected Meter Type. The Headroom indicator is just to the right of the Audio Volume indicator below the faders and meters in the Mix window. Click the Headroom indicator to reset the current value.

Option-click (Mac) or Alt-click (Windows) to reset all Headroom indicators. Shift-Option-click (Mac) or Shift-Alt-click (Windows) to reset the Headroom indicators for only selected tracks.

If the Headroom indicator is displayed in blue, it is measuring below the dB value of the lowest scale marking for the currently selected Meter Type.

Calibration Mode

(HDX and HD Native Systems Only)

You can use the Calibration mode in Pro Tools to adjust the input and output levels for your audio interface so they match those of your mixing console and other audio devices in your studio.

HD I/O has one set of adjustable trim pots for its inputs. Additionally, the reference level for the input can be set to +4 dBu or –10 dBV. For more information on calibrating HD I/O, see the HD I/O Guide.

There are no input or output trims on the following audio interfaces: HD OMNI, HD MADI. Some Pro Tools audio interfaces that do not have output trims (such as the HD OMNI) offer software-controllable input levels, adjustable from Setup > Hardware (see the guide for your particular audio interface).
Connecting a Sound Source

Depending on your Pro Tools audio interfaces, you can connect different types of sound sources (such as musical instruments, mics, and mixer outputs). See the User Guide for your Pro Tools system. For additional information, see the documentation that came with your sound source.

If you connect a sound source to a Pro Tools input that was not previously configured to accept input, you may need to reconfigure you hardware in the Hardware Setup dialog (see your User Guide). You may also need to reset your I/O signal paths in I/O Setup (see Chapter 6, “I/O Setup.”).

Recording with a Click

If you intend to work with MIDI or Instrument tracks in your session, or if the audio you’re working with is bar and beat-oriented, you can record your tracks while listening to a click. This ensures that recorded material, both MIDI and audio, aligns with the session’s bar and beat boundaries.

When your track material lines up with the beats, you can take advantage of some very useful editing functions in Pro Tools, such as quantizing MIDI and audio events or clips, quantizing individual MIDI notes, and copying and pasting measures and song sections in Grid mode.

Material that is recorded without listening to a click can still be aligned to bar and beat boundaries in Pro Tools with Beat Detective (see Chapter 33, “Beat Detective”), or by using the Identify Beat command to determine the tempo (see “Identify Beat Command” on page 863).

Creating a Click Track

Pro Tools lets you create a Click track using the Click plug-in. You can also create a click track using the Click II plug-in (included with Pro Tools) or using a MIDI instrument.

For more information on the Click II plug-in, see the Audio Plug-Ins Guide.

To create a click track using the Click plug-in:

1. Choose Track > Create Click Track.

Pro Tools creates a new Auxiliary Input track named “Click” with the Click plug-in already inserted. In the Edit window, the click track’s Track Height is set to Mini. You can create more than one click track and each subsequent click track is named in sequence. For example, Click 1, Click 2, and Click 3.

To hear the click during playback and recording, configure the Click Options (see “Click Options” on page 498) and ensure that Click is enabled (see “Enabling the Click” on page 497).

To create a click track using MIDI:

1. Create a new (mono) Auxiliary Input or Instrument track.

2. Do one of the following:
   - From the track’s Input selector, select the path to which the MIDI device is connected.
   - Insert an instrument plug-in on the track (such as Xpand²).

3. Configure the Click/Countoff options, and be sure to select the port for the MIDI device or instrument plug-in from the Output pop-up menu (see “Click Options” on page 498).

4. Enable Click (see “Enabling the Click” on page 497).
Enabling the Click

Click tracks must be enabled to be heard during playback or recording.

To enable the click from the MIDI menu:

- Select Options > Click.

To enable the click in the Transport:

1. Display the MIDI controls in the Transport by doing one of the following:
   - Select View > Transport > MIDI Controls.
   - From the Transport window menu, select MIDI Controls.
   - Command-click (Mac) or Control-click (Windows) the Expand/Collapse “+” button in the Transport window to display the MIDI controls.
   - Option-click (Mac) or Alt-click (Windows) the Expand/Collapse “+” button in the Transport window to display the MIDI controls and the Counters.

2. In the Transport, click the Metronome button so it is highlighted.

3. To hear the click count off when recording or playing, click the Count Off button in the Transport so it is highlighted.

Hearing the countoff before recording helps musicians to start playing at the right time and in tempo. The Count Off button in the Transport window displays the number of bars counted before the transport starts.

💡 The countoff is ignored when Pro Tools is online and synchronized to SMPTE timecode.
### Click Options

Pro Tools provides options and controls for driving a click. The following steps are for configuring and enabling a click using the Click II plug-in or MIDI.

**To configure click options:**

1. Open the Click/Countoff Options dialog by doing one of the following:
   - Choose Setup > Click/Countoff.
   - Double-click the Metronome button in the Transport window.

2. In the Click/Countoff Options dialog, do one of the following:
   - If using the Click II plug-in, select None in the Output pop-up menu.
   - If playing a click using MIDI, select the port number (device) and channel for the click from the Output pop-up menu.

3. Specify the note, velocity, and duration for the accented and unaccented notes.

   *Note: If one is connected, you can also play new note values on a MIDI controller keyboard.*

4. Select whether the click is heard **During Play and Record**, or **Only During Record**, or **Only During Countoff**.

5. If using a countoff, specify the number of Bars to be counted off. To hear the countoff only when recording, select that option.

6. Click OK.

### Setting the Session Meter and Tempo (Optional)

#### Setting the Session Meter

When opening a new session in Pro Tools, the meter defaults to 4/4. If you intend to record with a click in a meter other than 4/4, make sure to set the meter accordingly.

If a session’s meter does not match the music you’re recording, the accented clicks will not line up with what you’re playing, and, as a result, the recorded material may not align with the bars and beats in the Edit window.

Meter events, which can occur anywhere within a Pro Tools session, appear in the Meter ruler. For more information on inserting and editing meter events, see “Meter Events” on page 866.
To set the meter for a session:

1. Double-click the Current Meter button in the Transport window.

2. Enter the Meter for the session and set the Location to 1|1|000 (to ensure that the inserted meter event replaces the default).

3. From the Click pop-up menu, select a note value for the beat. (For example, if you are in 6/8, select a dotted-quarter note).

4. Click OK to insert the new meter event.

Setting the Session Tempo

When opening a new session in Pro Tools, the tempo defaults to 120 BPM. If you intend to record with a click at a tempo other than 120 BPM, make sure to set the tempo accordingly.

- Tempo events, which can occur anywhere within a Pro Tools session, appear in the Tempo ruler. For more information on inserting and editing tempo events, see “Tempo” on page 844.

To change the session tempo:

1. Double-click the Song Start Marker in the Edit window (see “Song Start Marker” on page 843).

2. Enter the BPM value for the session.

- You can type in a specific tempo, or you can use the T key to tap in the tempo.

3. Set the Location to 1|1|000 (to ensure that the inserted tempo event replaces the default).

4. From the Resolution pop-up menu, select the note value for the beat. (For example, if you are in 6/8, select a dotted-quarter note.)

5. Click OK.
Using Manual Tempo Mode

In Manual Tempo mode, Pro Tools ignores tempo events in the Tempo ruler and instead plays back a Manual Tempo. This tempo can be set with the Tempo slider, or if you are not sure of the actual tempo, by tapping in the tempo.

While you can adjust the Manual Tempo during playback, doing so momentarily interrupts playback.

To set the Manual Tempo with the Tempo slider:

1. To view the MIDI controls in the Transport window, select View > Transport > MIDI Controls.

2. In the Transport window, click the Tempo Ruler Enable button (Conductor) button so it becomes unhighlighted. Pro Tools switches to Manual Tempo mode. In this mode, any tempo events in the Tempo ruler are ignored.

3. To base the BPM value on something other than the default quarter-note, click the Tempo Resolution selector and select a different note value. (For example, if you are in 6/8, select a dotted-quarter note.)

4. To enter a new tempo, do one of the following:
   - Drag the Tempo value up or down. For finer resolution, press Command (Mac) or Control (Windows) while dragging.
   - Click the Tempo value, type a new number, and press Enter.

To exit Manual Tempo mode and enable the Tempo ruler:

- Click the Tempo Ruler Enable (Conductor) button in the Transport window so it becomes highlighted.

To set the Manual Tempo by tapping:

1. Ensure that the MIDI controls are shown in the Transport window (select View > Transport > MIDI Controls).

2. In the Transport window, click the Tempo Ruler Enable (Conductor) button so it becomes unhighlighted. Pro Tools switches to Manual Tempo mode. In this mode, any tempo events in the Tempo ruler are ignored.

3. Do one of the following:
   - Click in the Tempo field so it becomes highlighted and tap the “T” key on your computer keyboard repeatedly at the new tempo.
   - If the Use MIDI to Tap Tempo option is enabled in the MIDI Preferences, click in the Tempo field so it becomes highlighted and tap in the tempo by playing a note repeatedly at the new tempo on your MIDI keyboard controller.

To compute the new tempo, Pro Tools averages the last eight (or fewer) taps to determine the correct tempo. The computed BPM value appears in the Transport window’s Tempo field.

To lock in the new tempo:

- Take Pro Tools out of Manual Tempo mode by clicking the Tempo Ruler Enable (Conductor) button, then set the default tempo for the Song Start Marker to the new tempo.
Chapter 23: Record Setup

Record Modes

For recording audio, Pro Tools provides the following Record modes:

- Normal (Nondestructive)
- Destructive
- Loop
- QuickPunch
- TrackPunch (Pro Tools Ultimate only)
- DestructivePunch (Pro Tools Ultimate only)

To select the Record mode, do one of the following:

- Select the Record mode in the Options menu. If no Record mode is selected, Pro Tools is in Normal (Nondestructive) Record mode.
- Right-click the Record button in the Transport and select the Record mode from the pop-up menu.

The Record button changes to indicate the selected Record mode as follows:

- Blank for Normal (Nondestructive)
- “D” for Destructive
- Loop symbol for Loop Record
- “P” for QuickPunch
- “T” for TrackPunch (Pro Tools Ultimate only)
- “DP” for DestructivePunch (Pro Tools Ultimate only)

When recording, you can preserve disk space by removing unwanted record takes (see “Clearing Unwanted Clips” on page 300) and compacting audio files (see “Compacting an Audio File” on page 665).

Normal (Nondestructive) Record Mode

In Normal, Nondestructive Record mode, Pro Tools records audio nondestructively, which means that if you record over a track’s existing clips, the audio is not erased from your hard drive. Both the new and old audio files remain on your hard drive, available as clips from the Clips List.

In Normal Record mode, the record range can be defined by selecting a range in a ruler or in a track’s playlist, or by specifying start and end points in the Transport window. If there is no selection, recording begins from the current Cursor location and continues until the Transport Stop button is clicked.

To set a record range by selecting within a track’s playlist, the Timeline and Edit selections must be linked. See “Linking or Unlinking Timeline and Edit Selections” on page 629.

The pre- and post-roll settings allow material to be heard up to and after the start and end points, which is useful when punch recording (see “Audio Punch Recording Over a Specified Range” on page 525).
Destructive Record Mode

In Destructive Record mode, recording over existing clips replaces the original audio permanently, which allows you to keep disk use to a minimum. However, if you have sufficient drive space, it is usually best to use Pro Tools in Nondestructive Record mode, to avoid losing any previously recorded material.

When defining the record range and setting pre- and post-roll, Destructive Record mode works the same as Normal (Nondestructive) mode.

Unlike the other record modes, it is not possible to cancel or undo record takes when using Destructive Record mode (see “Canceling a Record Take” on page 519).

⚠️ In Destructive Record mode, the waveform overview is not redrawn until you stop recording.

⚠️ Destructive recording is not supported with AudioSuite rendered clips with handles. You can consolidate such clips if you need to use Destructive Record mode.

Loop Record Mode

Loop Record mode lets you record take after take (nondestructively) while the same section of audio repeats. This is a convenient technique for quickly recording multiple takes of a part without losing spontaneity.

The time range that is looped and recorded—which must be at least one second in length—is defined by selecting a range in a ruler or in a track’s playlist, or by specifying start and end points in the Transport window. The pre-roll setting, if enabled, is used during the first record pass, but on each successive loop the pre- and post-roll times are ignored.

💡 To set a record range by selecting within a track’s playlist, enable the Link Timeline and Edit Selection option. See “Linking or Unlinking Timeline and Edit Selections” on page 629.

When using Loop Record mode, each successive take appears as a clip in the Clips List and each is numbered sequentially. The various takes, which are identical in length and start time, are easily auditioned and placed in the track at the correct location with the Matches pop-up menu (see “Selecting Alternate Takes” on page 530).

⚠️ In Loop Record mode, the waveform overview is not redrawn until you stop recording.
QuickPunch

QuickPunch gives you the ability to manually and instantaneously punch in (initiate recording) and punch out (stop recording) on record-enabled audio tracks during playback by clicking the Record button in the Transport. Recording with QuickPunch is nondestructive.

When using QuickPunch, Pro Tools begins recording a new file when playback begins, automatically generating clips in that file at each punch in/out point. These clips appear in the track’s playlist; and the complete audio file appears in the Clips List along with the QuickPunch created clips. Up to 200 of these “running punches” can be performed in a single pass.

Though you can punch record in the other record modes by manually specifying the record range, only QuickPunch provides instantaneous monitor switching on punch-out.

For more information on QuickPunch, see “QuickPunch Audio Recording” on page 564.

TrackPunch

(Pro Tools | Ultimate Software Only)

TrackPunch lets individual tracks be punched in, punched out, and taken out of record enable without interrupting online recording and playback.

TrackPunch is a nondestructive recording mode. When a track is TrackPunch-enabled, Pro Tools begins recording a new file when playback begins. During playback, you may record arm or disarm, or punch in or out a combination of any or all TrackPunch enabled tracks.

TrackPunch automatically creates clips in that file at each punch-in and punch-out point. These clips appear in the track’s playlist, and the complete audio file appears in the Clips List along with the TrackPunch created clips. Up to 200 of these “running punches” can be performed in a single pass.

For more information on TrackPunch, see “TrackPunch Audio Recording” on page 566.

DestructivePunch

(Pro Tools | Ultimate Software Only)

Destructive Punch is a destructive recording mode that lets you instantaneously punch in (start recording) and punch out (stop recording) on individual audio tracks during playback, while preserving a contiguous audio file on each punched track.

For more information on DestructivePunch, see “DestructivePunch Audio Recording” on page 569.

Record Modes and MIDI

In addition to the various record modes, there is also a MIDI Merge button in the Transport window that determines how MIDI is recorded. When enabled (Merge mode), recording over existing MIDI clips results in the new data being merged with the old. When the MIDI Merge button is disabled (Replace mode), the new material replaces the old.

MIDI Merge button, enabled
MIDI recording works the same whether using Nondestructive or Destructive Record mode. In addition, neither QuickPunch nor TrackPunch need to be enabled to punch on-the-fly with MIDI—this capability is available in Nondestructive and Destructive Record modes.

Unlike audio loop recording, the state of the MIDI Merge toggle determines whether existing material is replaced or merged.

Unless MIDI Merge is enabled, MIDI recording is destructive (though you can undo a MIDI record pass), either overwriting or adding to clip material. One exception to this rule is when Loop Record mode is enabled; in this mode, existing track clips are replaced with new clips when new material is recorded. The old clips remain intact and available from the Clips List, and from the Matches pop-up menu. In Loop Record mode, MIDI Merge has no effect, so its button is dimmed.

Subsequent record takes on the same track are named identically, but the digits (indicating the take number) are incremented (for example, “Electric Gtr_02.”) A second set of digits (such as used in “Electric Gtr_01-01”) indicates that the clip was auto-created from an edit.

QuickPunch, TrackPunch, and Destructive Punch modes use a different method for numbering clips. For details, see “TrackPunch Audio Recording” on page 566.

When recording MIDI tracks, a similar naming scheme is used, though with only one set of digits. For example, after recording to a track called “Synth 1,” a clip is created called “Synth 1-01.” Subsequent clips for that track, generating either from additional record takes or clip edits, are numbered sequentially (for example, “Synth 1-02”).

To rename a track:

1. Do one of the following:
   - In the Mix or Edit window, double-click the Track Name button for the track you want to rename.
   - In the Tracks List in the Mix, Edit, MIDI Editor, or Score Editor window, Right-click the track name for the track you want to rename.

2. In the Track Name/Comments dialog, type a new track name.

3. Click OK.

---

Configuring Default Names for Audio Files and Clips
(Optional)

Track names define new file and clip names when recording to a track (see “Naming Tracks” on page 232).

When recording to an audio track, the resulting file and clip names are based on the name of the track. For example, after recording for the first time on a track called “Electric Gtr,” an audio file is created with the name “Electric Gtr_01.” In addition, a clip appears in the Clips List with the name “Electric Gtr_01.” This clip is a whole-file clip.
Names for Stereo Audio Tracks

When recording to stereo audio tracks, audio file and clip names for the left and right channels are appended with a “.L” and “.R” suffix.

Names for Multichannel Tracks
(Pro Tools | Ultimate Software Only)

When recording to multichannel surround tracks, audio file and clip names for each channel are appended with the following suffixes:

<table>
<thead>
<tr>
<th>Multichannel Format</th>
<th>File and Clip Suffixes</th>
</tr>
</thead>
<tbody>
<tr>
<td>LCR</td>
<td>L, C, R</td>
</tr>
<tr>
<td>Quad</td>
<td>L, R, Ls, Rs</td>
</tr>
<tr>
<td>LCRS</td>
<td>L, C, R, S</td>
</tr>
<tr>
<td>5.0</td>
<td>L, C, R, Ls, Rs</td>
</tr>
<tr>
<td>5.1</td>
<td>L, C, R, Ls, Rs, LFE</td>
</tr>
<tr>
<td>6.0</td>
<td>L, C, R, Ls, Cs, Rs, LFE</td>
</tr>
<tr>
<td>6.1</td>
<td>L, C, R, Ls, Cs, Rs</td>
</tr>
<tr>
<td>7.0</td>
<td>L, C, R, Lss, Rss, Lsr, Rsr</td>
</tr>
<tr>
<td>7.1</td>
<td>L, C, R, Lss, Rss, Lsr, Rsr, LFE</td>
</tr>
<tr>
<td>7.0 SDDS</td>
<td>L, Lc, C, R, Rc, Ls, Rs</td>
</tr>
<tr>
<td>7.1 SDDS</td>
<td>L, Lc, C, R, Rc, Ls, Rs, LFE</td>
</tr>
</tbody>
</table>

Assigning Hardware I/O on a Track

Before recording to a track, you must specify the input and output signal path for the material you are recording. You will do this by assigning a hardware input (recording source) and an output bus (for monitoring recording) on the track.

To assign I/O on a track:

1. Assign a hardware input (recording source) by doing one of the following:
   - In the Mix window, select the corresponding hardware input for your source from the track’s Input Path selector.
   - In the Edit window, with I/O view enabled, select the corresponding hardware input for your source from the track’s Input Path selector.

Input Path selector (mono audio track, Mix window)

Input Path selector (stereo audio track, Edit window)
2 Assign an output bus (for monitoring recording) by doing one of the following:

- In the Mix window, select the corresponding output bus for monitoring (such as “Monitor” or “A 1–2”) from the track’s Output Path selector.

- In the Edit window, with I/O view enabled, select the corresponding output bus for monitoring (such as “Monitor” or “A 1–2”) from the track’s Output Path selector.

### Record Enabling Tracks

To record audio or MIDI to a track you must first enable the track’s Record Enable button. To record simultaneously to multiple tracks, record enable multiple audio, Instrument, or MIDI tracks.

When one or more tracks are record-enabled, click the Record button in the Transport to arm recording, and then click the Play button in the Transport to start recording.

MIDI and Instrument tracks can be record-enabled during playback or record. To record enable audio tracks, the Transport must be stopped, or QuickPunch, TrackPunch, or Destructive-Punch must be enabled. For more information on QuickPunch, TrackPunch, and Destructive-Punch, see “Record Modes” on page 501.

To record enable an audio, MIDI, or Instrument track:

- From either the Mix or Edit window, click the track’s Record Enable button to toggle record enable on or off for the track. The track’s Record Enable button flashes red, the track’s fader is solid red, and the Track Record Enabled indicator in the Transport turns red (indicating at least one track is record-enabled).

Press Shift+R to record enable any track containing the Edit cursor on an Edit selection.
To record enable multiple audio tracks:

- From either the Mix or Edit window, click each audio track’s Record Enable button to toggle record enable on or off for each track.

> If Latch Record mode is not enabled, Shift-click each track’s Record Enable button to toggle record enable on or off for each track. See “Latch Record Enable Buttons Preference” on page 507.

To record enable multiple MIDI and Instrument tracks:

- From either the Mix or Edit window, Shift-click each MIDI or Instrument track’s Record Enable button to toggle record enable on or off for each track.

To record enable MIDI and Instrument tracks using the Up/Down Arrows:

- While pressing Command (Mac) or Control (Windows), press the Up/Down Arrows to record enable the previous or next MIDI or Instrument track. The previous (or next) record track is no longer record-enabled.

> To keep the previous track record-enabled while enabling new tracks, press Command+Shift+Up/Down (Mac) or Control+Shift+Up/Down (Windows).

To record enable (or disable) all audio, MIDI, and Instrument tracks:

- Option-click (Mac) or Alt-click (Windows) any Record Enable button to toggle record enable on or off for all audio, Instrument, and MIDI tracks.

To record enable (or disable) all selected audio, MIDI, and Instrument tracks:

- Option-Shift-click (Mac) or Alt-Shift-click (Windows) the Record Enable button on any selected audio, MIDI, or Instrument track to toggle record enable on or off for all selected tracks.

> Record enabling a track that is part of a Mix Group does not record enable the other tracks in the Group. To record enable all tracks in a group, click directly to the left of the group’s name in the Groups List to select all tracks in the group, and then Option-Shift-click (Mac) or Alt-Shift-click (Windows) the Record Enable button of one of the tracks to record enable the selected tracks.

**Latch Record Enable Buttons Preference**

When the Latch Record Enable Buttons option is selected in the Operation Preferences, you can record enable additional audio tracks by clicking their Record Enable buttons. Previously record-enabled tracks remain enabled. The Latch Record Enable Buttons option affects audio tracks only.

When the Latch Record Enable Buttons option is deselected, record enabling a subsequent audio track disables the previously record-enabled audio track.

**To enable the Latch Record Enable Buttons preference:**

1. Choose Setup > Preferences and click the Operation tab.
2. Select Latch Record Enable Buttons.
Record Safe Mode

Pro Tools provides a Record Safe mode on a per track basis that prevents tracks from being record-enabled by accident. Use Record Safe mode to protect important audio or MIDI data on a track from being recorded over.

To put an audio, MIDI, or Instrument track in Record Safe mode:
- Command-click (Mac) or Control-click (Windows) the track’s Record Enable button. The Record Enable button is grayed out.

Command-click (Mac) or Control-click (Windows) again to take the track out of Record Safe mode.

To put all audio, MIDI, and Instrument tracks in Record Safe mode:
- Command-Option-click (Mac) or Control-Alt-click (Windows) the Record Enable button on any track.

Command-Option-click (Mac) or Control-Alt-click (Windows) again to take all tracks out of Record Safe mode.

To put all currently selected tracks into Record Safe mode:
- Command-Option-Shift-click (Mac) or Control-Alt-Shift-click (Windows) the Record Enable button on any of the selected tracks to toggle them in and out of Record Safe mode.

Working with Hard Drives for Recording

Monitoring Drive Space

Pro Tools lets you check how much drive space is available. The Disk Usage window shows the available drive space for each drive connected to your system as text and as a gauge display.

To monitor available space on your drive during a Pro Tools session:
- Choose Window > Disk Space.

Disk Usage window

To display available drive space in Text Only view only:
- From the Disk Usage menu, select Text Only.

Disk Usage window, selecting Text Only view
Recording with Multiple Hard Drives
(Optional)

By default, Pro Tools records audio files to the Audio Files folder inside the session folder. If you have multiple hard drives for recording, you can use the Disk Allocation window to specify other hard drive locations to record audio files on a track-by-track basis.

Hard drives that are full do not appear in the Disk Allocation window.

To increase system performance, Pro Tools can record and play each track from a different hard drive. You can also automatically distribute any newly created tracks to multiple audio drives with Round Robin Allocation.

Navigating in the Disk Allocation Window

To resize the Disk Allocation window:

- Drag the lower-right corner of the window.

To scroll up or down in the Disk Allocation window:

- Press Page Up or Page Down.

Allocating Audio Drives in Your System

To allocate the audio drives in your system:


2. In the Disk Allocation window, assign a hard drive for each track by clicking in the Root Media Folder column and selecting a volume from the Disk Allocation pop-up menu.

Only drives designated as R (Play and Record) can be selected in the Disk Allocation window. For more information, see “Performance and Transfer Volumes” on page 308.
A folder with the session name is created on each hard drive, containing subfolders for audio and fade files.

- To assign a track to a different hard drive, click the track and select a drive name.
- To assign all tracks to the same hard drive, press Option (Mac) or Alt (Windows) while selecting a drive name.
- To make a continuous selection, Shift-click a track name (in the Track column) to extend the selection to include already-selected tracks and all tracks in between.
- To make a noncontiguous selection, Command-click (Mac) or Control-click (Windows) a track name in the Track column to extend the selection to include already-selected tracks without including tracks in-between.

3 To save recorded audio files to an existing folder (without creating another session folder), select Customize Allocation Options, then click Change and choose the folder. To create subfolders in this folder, select the Create Subfolders for Audio, Video, and Fade Files option.

4 To automatically distribute any newly created tracks among the drives connected to your system, select the Use Round Robin Allocation for New Tracks option.

If you are using Round Robin Allocation and want audio to be recorded to your system’s start-up drive, do the following:

- Open the Workspace browser (Window > Workspace) and set the Volume Designator for your system volume to R (Record and Playback). See “Workspace Volume Designation” on page 510.

⚠️ Round Robin Allocation is not supported with partitioned hard drives.

5 When you are finished, click OK.

### Saving Disk Allocation Settings

To save Disk Allocation settings for use with future sessions, save the session as a template. For details, see “Session Templates” on page 176.

### Disk Allocation and Cross-Platform Sessions

To ensure cross-platform operation, it is required that Mac Pro Tools sessions and their associated audio files be on Mac-formatted (HFS or HFS+) drives. Windows Pro Tools sessions and their associated audio files must be on Windows-formatted NTFS drives.

⚠️ See “Saving Copies of Mac Sessions to be Compatible with Windows” on page 460 and “Sharing Sessions Created on Different Computer Platforms” on page 459.

### Workspace Volume Designation

The Workspace volume designation can alter disk availability, thus affecting Disk Allocation. From the Workspace browser, you can designate volumes as Record, Playback, or Transfer. If you change a drive’s designation, making it read-only (Play Only or Transfer), check the Disk Allocation window for any tracks formerly allocated to that drive. For more information, see “Volume Permissions” on page 312.
Recording to the System Volume

Although Pro Tools lets you record to your system volume, this is generally not recommended. Performance for audio recording and playback on system drives is not as good as on non-system hard drives.

Record to system drives only when absolutely necessary, such as if your computer system has only one hard drive, or if your other hard drives are completely full.

By default, the system volume is not included in Round Robin Allocation (regardless of volume designation in the Workspace browser). To include the System Volume in Round Robin Allocations, see “Allocating Audio Drives in Your System” on page 509.

💡 If you have a Pro Tools system with multiple drives, and you intend to record multiple tracks simultaneously, you may want to designate the System drive as a Playback only or Transfer only drive for optimal performance.

Disk Allocation and Unavailable Volumes

Pro Tools remembers disk allocation settings for tracks and does not automatically reassign them if a volume becomes unavailable.

If a volume for a session becomes unavailable (because it went offline or its volume designation changed), Pro Tools cannot record to tracks allocated to that volume.

To enable recording, bring the volume online, change its volume designation to R (Play and Record), or change the allocation of the affected tracks to a valid record volume.

Selecting a Record Input Monitoring Mode

Pro Tools offers two modes of input monitoring: Auto Input and Input Only. These monitoring modes determine how input signals are monitored during playback, recording, or while the transport is stopped.

Auto Input Monitoring

In Auto Input mode, when session playback is stopped, Pro Tools monitors audio input. When playback is started for a punch-in, Pro Tools monitors existing track material up until the punch point. While punched in, the input signal is monitored. On punch-out, monitoring switches back to the existing track material. This is similar to the auto-switching logic found on digital and analog multitrack tape machines.

⚠️ When in Auto Input mode, the switch back to monitoring track material on punch-out is not instantaneous.

💡 Tracks are in Auto Input mode by default, and a monitoring control (TrackInput button) is provided for each track. See “Selecting Record Monitor Modes with Track-Input Monitoring” on page 512.

Input Only Monitoring

In Input Only mode, when a track is record-enabled, Pro Tools monitors audio input only, regardless of any punch-in/out selection or state.

For Pro Tools, the Input Monitor Enabled Status indicator (in the Transport window) lights green when Input Only mode is enabled.
The indicator lights green when one or more tracks have TrackInput enabled (see “Selecting Record Monitor Modes with TrackInput Monitoring” on page 512).

Selecting a Record Monitor Mode

For record-enabled tracks to use Auto Input Monitoring:

- Select Track > Set Record Tracks to Input Only.

For record-enabled tracks to use Input Only Monitoring:

- Select Track > Set Record Tracks to Auto Input.

To toggle between Auto Input and Input Only monitoring, press Option+K (Mac) or Alt+K (Windows).

Selecting Record Monitor Modes with TrackInput Monitoring

TrackInput monitoring lets you toggle individual audio tracks between Auto Input and Input Only monitoring modes at any time, during playback, recording, while stopped, and even when a track is not record-enabled. TrackInput monitoring provides the necessary monitoring flexibility for overdubbing and mixing, and is similar to input switching on analog multitrack recorders and similar machines.

When the TrackInput button in a track is enabled (green), the track monitors audio in Input Only mode.

When the TrackInput button in a track is disabled, the track monitors in Auto Input mode.

To toggle the monitoring mode of audio tracks, do one of the following:

- To toggle individual tracks, click the TrackInput Monitor button for each track you want to toggle.
- To toggle all tracks in the session, Option-click (Mac) or Alt-click (Windows) a TrackInput Monitor button.
- To toggle all selected tracks in the session, Option-Shift-click (Mac) or Alt-Shift-click (Windows) a selected track’s TrackInput Monitor button.

Press Shift+I to enable the TrackInput Monitor button for any track containing the Edit cursor on an Edit selection.
To toggle the TrackInput button states of all record-enabled tracks, do one of the following:

- To change all record-enabled tracks to Auto Input monitoring, select Track > Set Record Tracks to Auto Input.
- To change all record-enabled tracks to Input Only monitoring, select Track > Set Record Tracks to Input Only.

To toggle record-enabled tracks between Auto Input and Input Only monitoring, press Option+K (Mac) or Alt+K (Windows).

Disable “Input” When Disarming Track

When the Disable “Input” When Disarming Track (in “Stop”) option is enabled in the Operation Preferences, TrackInput monitoring is disabled whenever a track is taken out of record enable. This is useful for certain workflows, such as when you are recording on a series of tracks, one at a time.

Disabling this option allows TrackInput buttons to remain enabled when deselecting the track Record Enable button.

Link Record and Play Faders

When the Link Record and Play Faders option is selected in the Operation Preferences, Pro Tools does not keep track of record and play levels for audio tracks. In this case, record enabling an audio track has no effect on the fader level for the track. This lets you maintain a consistent mix regardless of whether you are recording or just listening.

Reducing Monitoring Latency

There will inevitably be some audio delay, or latency, in the monitoring signal (even if only a few samples) due to the process of converting an analog signal to a digital signal (input) and back again (output). There may be additional latency due to mixer configurations and processing.

HDX systems have additional latency when using Native plug-ins because these plug-ins also use your computer’s host processor.

Host-based Pro Tools systems use the host processor in your computer for all audio processing, playback, and recording, so there is always a small amount of latency in the system. For example, there may be some audible delay between the incoming signal and outgoing signal when monitoring recording through Pro Tools.

With Pro Tools, latency occurs as follows:

- All Pro Tools systems can have Virtual Instrument plug-in MIDI-to-audio latency (such as when playing a virtual instrument live and monitoring the instrument’s output).
- Pro Tools systems have input-to-output monitoring latency on any record-armed tracks or Auxiliary Inputs with live inputs.
- HDX systems have monitoring latency on tracks that have one or more host-based plug-ins.
The latency amount is related to the H/W Buffer Size setting—the larger the buffer size, the greater the latency. You can reduce the amount of monitoring latency by reducing the H/W Buffer Size setting. However, even at the smallest buffer size, there is still some latency.

In addition, reducing the buffer size limits the number of simultaneous audio tracks you can record without encountering performance errors.

While there may be times when you want a larger buffer size, such as when you have higher track counts with more plug-ins, you will generally want the smallest possible buffer size when latency is present during recording and monitoring.

If you are monitoring the recording source with an external mixer before it is routed to Pro Tools, you will not hear any latency.

**To set the Hardware Buffer Size:**

2. Choose the number of samples from the H/W Buffer Size pop-up menu.
3. Click OK.

*For more information on the H/W Buffer Size setting, see “Hardware Buffer Size” on page 92.*

*Computers with slower CPUs may not be able to use a H/W Buffer Size setting lower than 512 samples buffer size without encountering performance errors.*

### Recording with Delay Compensation

Generally, you will want to record with Delay Compensation enabled to maintain phase coherent time alignment between tracks with different DSP delays. However, you will generally want to avoid using inserts on recording tracks or tracks used for controlling the levels of cue mixes. For more information, see “Delay Compensation” on page 1082.

### Zero Latency Monitoring

Some Avid, and third-party CoreAudio and ASIO audio interfaces give you the ability to monitor your analog input signals while recording, without hearing any latency. This zero-latency analog monitoring is typically controlled by a Mix knob on the audio interface, which you can use to blend and adjust the mix between the interface’s analog input and Pro Tools playback. For more information, see the documentation that came with your audio interface.

### Low Latency Monitoring

(HD Native, 003, 003 Rack, 003 Rack+, Mbox Pro, and Core Audio and ASIO Interfaces with Built-in Mixers Only)

HD Native, 003, 003 Rack, 003 Rack+, and Mbox Pro systems can use the Low Latency Monitoring option to record with an extremely small amount of monitoring latency, to as many tracks as each system supports.

Likewise, certain Core Audio and ASIO audio interfaces that have a built-in mixer can use the Low Latency Monitoring option.

Only tracks with inputs set to a physical output (not an internal mix bus) use Low Latency Monitoring.
Software monitoring is automatically disabled for all Record-enabled tracks and TrackInput Monitoring–enabled tracks. This lets you use hardware monitoring with any output channels on your audio interface without having to re-configure your session.

⚠️ If your Core Audio or ASIO hardware does not have a built-in mixer, Low Latency Monitoring does not function. If you do enable Low Latency Monitoring with such hardware, monitoring will not available for record-enabled tracks in Pro Tools.

**To use Low Latency Monitoring:**

1. Assign each track to the selected Low Latency Monitoring Path as set in the I/O Setup Output page (see “Low Latency Monitoring” on page 60). Only tracks assigned to these outputs use Low Latency Monitoring.

2. Record enable audio tracks by clicking their Record Enable buttons.

3. Select Options > Low Latency Monitoring.

When Low Latency Monitoring is enabled, any plug-ins and sends assigned to record-enabled tracks are automatically bypassed, and must remain bypassed. Also, these tracks do not register on meters for Master Faders.

**Allow Sends to Persist During LLM Preference**

All plug-ins and sends are bypassed by default when Low Latency Monitoring (LLM) is enabled (Options > Low Latency Monitoring). Enable the Allow Sends to persist during LLM preference to maintain sends audio signal output with Low Latency Monitoring.

**To maintain (or bypass) sends with Low Latency Monitoring enabled:**

1. Choose Setup > Preferences and click the Mixing tab.

2. Select (or deselect) the Allow Sends to persist during LLM option.

3. Click OK.

**Low Latency Monitoring and Bounce To Disk**

With Low Latency Monitoring enabled, only audio tracks are included with the Bounce to Disk command—Auxiliary Input and Instrument tracks are ignored. To include Auxiliary Input and Instrument tracks, disable Low Latency Monitoring before using Bounce to Disk.

⚠️ External input cannot be recorded during a Bounce to Disk. To include external input in your bounce, it must be recorded to new audio tracks before using Bounce to Disk (see “Bounce to Disk” on page 1188).
In Pro Tools, you record audio to audio tracks. Audio tracks can be mono, stereo, or multichannel as appropriate for the recording source.

When recording a mono source, record to a single, mono audio track in Pro Tools. A single, mono audio file is written to disk, and the file appears as a clip both in the track’s playlist and in the Clips List.

When recording a stereo audio source, record to a single, stereo audio track in Pro Tools. A single, mono audio file is written to disk for each channel of a stereo track: one for the left channel, and one for the right channel. These files appear as a stereo clip both in the track’s playlist and in the Clips List.

Recording a multichannel source to a multichannel track (Pro Tools Ultimate only) is similar to recording stereo audio tracks. A single, mono audio file is written for each channel in the track, and these files appear as multichannel clips in both the track’s playlist and in the Clips List (see “Multichannel Audio Tracks” on page 1211).

**Before Recording**

Before you start recording in Pro Tools, you need to set up your Pro Tools system, a session, and one or more tracks for recording. You will also need to configure how Pro Tools monitors the input you intend to record. For information, see Chapter 23, “Record Setup.”

**Basic Recording Steps**

1. From the track’s Input Path selector, select the audio Input Path you want to record (see “Assigning Hardware I/O on a Track” on page 505).
2. From the track’s Output Path selector, select the main monitoring path.
3. Click the Record Enable button for the audio track. It lights red.
4. Adjust the output level of your sound source (instrument, mixer, or preamp). Monitor the track’s meter levels in Pro Tools to ensure that levels peak within at least –6 dB to –12 dB on the input meter without triggering the clipping indicator on your audio interface.
5  Do one of the following:
• In the Mix window, adjust the track’s volume and pan faders. These settings are for monitoring purposes only and do not affect the recorded material.
• In the Output window for the track, adjust the track’s Volume fader and Pan sliders. These settings are for monitoring purposes only and do not affect the recorded material. (See “Output Windows for Tracks and Sends” on page 1070.)

6  Choose Window > Transport to display the Transport window. Click Return to Zero to go to the beginning of the session.

7  Click Record in the Transport window to arm Pro Tools for recording. The Record button flashes red to indicate that Pro Tools is ready to record.

8  Ensure that Normal Record mode is selected (see “Record Modes” on page 501).

9  When you are ready to start recording, click Play or press the Spacebar.

If using Countoff, Pro Tools counts off the specified number of measures and then begins recording. See “Recording with a Click” on page 496.

10  Record your performance.

11  Click Stop in the Transport window or press the Spacebar when you are finished recording.

The newly recorded audio is written to disk and appears as an audio clip both in the track’s playlist and in the Clips List.

To play back the audio track:

1  Click the Record Enable button for the audio track so that it is no longer record-enabled. Track volume faders now function as playback level controls.

   If a record-enabled track is in Auto Input Monitor mode, you will hear “through” the input while the Transport is stopped. The track automatically switches to playback when you press play, then back to Input mode when you either stop, or punch into record. For more information, see “Auto Input Monitoring” on page 511.

2  To have playback start from the beginning of the session, click Return to Zero in the Transport.

3  To start playback, click Play in the Transport or press the Spacebar.

Undo or Cancel Audio Recording

Once you have recorded an audio track and the transport is stopped, you can undo the record take.

To undo an audio recording:

• Once the Transport has been stopped, choose Edit > Undo Record Audio.
The track’s playlist is restored to its previous state and material is discarded as follows:

- When in normal Record mode, only the most recent take is discarded.
- When in Loop Record mode, all takes from each record pass are discarded.
- When using QuickPunch, TrackPunch, or DestructivePunch mode, all punches from the last recording pass are discarded.

If you undo a record pass during recording, Pro Tools removes any previously undone record pass from the session and lets you delete the previous record pass from your hard drive.

If no actions are available to undo, the menu displays a grayed out Can’t Undo.

**Canceling a Record Take**

While recording, it is possible to discard the current record take. This removes the audio (recorded up to that point) from your hard drive and deletes the clip from the track’s playlist and the Clips List. When using Loop Record mode, all takes from each record pass are discarded. Canceling recording when in Destructive Record mode is prohibited.

To cancel a record take while recording:

- Press Command+Period (.) (Mac) or Control+Period (.) (Windows) before the Transport is stopped.

**Recording Multiple Audio Tracks**

Pro Tools can record multiple audio tracks simultaneously, up to the track recording limits of your system. To record to multiple tracks, configure and record enable each track, then record. Follow the same steps as in “Basic Recording Steps” on page 517.

For each record-enabled track, a new audio file is written to disk, and a new clip is created that appears both in the track’s playlist and in the Clips List.

If you have a Pro Tools system with multiple drives, and you intend to record multiple tracks simultaneously, you may want to designate the System drive as a Transfer only drive for optimal performance.

### Recording Shortcuts

In addition to clicking the Record button in the Transport or Edit window to arm Pro Tools recording, you can arm and start recording with the following keyboard shortcuts:

- Press F12 to start recording immediately.

**On Mac systems, to use F12 for recording, the Mac “Dashboard” feature must be disabled or remapped. See your User Guide for details.**

- Press Command+Spacebar (Mac) or Control+Spacebar (Windows) to start recording.

**On Mac systems, to use Command+Spacebar for recording, the Mac “Spotlight” feature must be disabled or remapped. Refer to Apple’s documentation for more information.**

- Press 3 on the numeric keypad (when the Numeric Keypad mode is set to Transport) to start recording.

**To initiate recording at half speed, press Command+Shift+Spacebar (Mac) or Control+Shift+Spacebar (Windows). See “Half-Speed Recording” on page 535.**
Prime for Record Mode

When recording a large number of tracks or channels, or playing back a large number of tracks while recording, Pro Tools may take a little longer to begin recording. To avoid this delay, put Pro Tools in Prime for Record mode before beginning to record.

To enable Prime for Record mode and start recording:

1. Click Record in the Transport. The Record button flashes.

2. Do one of the following:
   - Option-click (Mac) or Alt-click (Windows) Play in the Transport to put Pro Tools in Prime for Record mode.
   - Right-click the Play button and select Prime for Record.

The Stop button lights and both the Play and Record buttons flash.

3. To begin recording instantaneously, click Play.

4. Click Stop to stop recording.

When synchronizing to timecode, use Prime for Record mode to record or play back large numbers of tracks. This decreases the time it takes to lock to timecode.

Setting Punch and Loop Points

The start and end points of a record range for punch and loop recording can be set by the following methods:

- Select a range in a track’s playlist (with Options > Link Timeline and Edit Selection enabled).
- Select a range in a Timebase ruler.
- Drag the Timeline Selection Markers in the ruler.
- Enter start and end times in the Transport window.
- Recall a Memory Location that includes an Edit selection (with Options > Link Timeline and Edit Selection enabled).

To set the record range in a track’s playlist:

1. If you want to constrain the selection to the current Grid value, set the Edit mode to Grid.

2. Select Options > Link Timeline and Edit Selection.

3. Do one of the following:
   - With the Selector tool, select the record range in a track’s playlist.
   - If a clip’s start and end points define the record range, select the entire clip.

When synchronizing to timecode, use Prime for Record mode to record or play back large numbers of tracks. This decreases the time it takes to lock to timecode.

Playlist selection

- You can also enter a start and end point during playback. Press the Down Arrow to set the start point, and press the Up Arrow to set the end points. Note that when in Grid mode, start and end point when entered in this manner do not snap to the grid.
To set the record range in a Timebase ruler:
1. If you want to constrain the selection to the current Grid value, set the Edit mode to Grid.
2. Select the record range in any Timebase ruler.

To set the record range by dragging the Timeline Selection Markers:
1. If you want the Timeline Selection Markers to snap to the current Grid value, set the Edit mode to Grid.
2. Drag the first Timeline Selection Marker (down arrow) to the start point of the range.
3. Drag the second Timeline Selection Marker (up arrow) to the end point of the range.

Timeline Selection Markers
When tracks are record-enabled, Timeline Selection Markers for start and end times appear as red up and down arrows in the Main Timebase ruler. If no tracks are record-enabled, the Timeline Selection Markers are blue.

The Timeline Selection Markers can be moved, either separately or at the same time, to set record and play ranges.

Start, End, and Length Fields
In its Expanded view, the Transport window can display start, end, and length times, and pre- and post-roll settings. When setting a record or play range, the range is reflected in these fields.
You can enter locations in the start and end fields to set the record or play range. The Timeline Selection Markers in the Main Timebase ruler are updated accordingly.

To set the record range by entering start and end times in the Transport window:

1. To see the start, end, and length times, do one of the following:
   - Select View > Transport > Expanded.
   - Shift-click the Expand/Collapse “+” button in the Transport window.

2. Do one of the following:
   - In the Transport window, click in the Start field.
   - Press Option+/ (Mac) or Alt+/ (Windows) on the numeric keypad to select the start field in the Transport window.

3. Type in the start location and press Option+/ (Mac) or Alt+/ (Windows) on the numeric keypad to enter the value and automatically move to the end field.

4. Type in the end location and press Enter to accept the value.

   Use the Period (.) or Left/Right Arrow keys to move through the different time fields for Start and End. Use the Up/Down Arrow keys to increase or decrease the numerical values.

**Memory Locations**

You can store Edit selections as Memory Locations, which can also include current pre- and post-roll values.

For more information on Memory Locations, see Chapter 39, “Memory Locations.”

To save an Edit selection with a Memory Location:

1. Ensure that Options > Link Timeline and Edit Selection is selected.

2. Set the record range by making an Edit or Timeline selection, or by entering start and end times in the Transport window.

3. To save the pre- and post-roll values, enable and set the pre- and post-roll amounts by entering them in the Transport window, or by dragging the Pre- and Post-Roll Flags in the ruler that represents the Main Time Scale (see “Setting Pre- and Post-Roll” on page 523).

4. Press Enter on the numeric keypad or click the Add Marker/Memory Location button in the Edit window.

5. In the New Memory Location dialog, set Time Properties to Selection, and if saving pre- and post-roll values, select the Pre/Post Roll Times option in the General Properties section.
6 Type a name for the new Memory Location.
7 Click OK.

To recall an Edit selection with a Memory Location:
1 Make sure to select Options > Link Timeline and Edit Selection.
2 Choose Windows > Memory Locations.

3 Do one of the following:
   • In the Memory Locations window, click the name or number of the Memory Location.
   • Recall the Memory Location by typing Period (.), the Memory Location number, and Period (.) again on the numeric keypad. (See “Numeric Keypad Modes” on page 28).

The start and end times and pre- and post-roll settings stored with the Memory Location are recalled.

---

Setting Pre- and Post-Roll

Pre- and post-roll times appear as flags in the ruler that represents the Main Time Scale. When pre- and post-roll are enabled, the flags are green, otherwise they are gray.

Pre- and post-roll amounts can be entered in the Transport window, set from a track’s playlist or Timebase ruler, or by recalling a Memory Location.

Setting Pre- and Post-Roll in the Transport Window

Pre- and post-roll can be enabled and set in the Transport window.

To set and enable the pre- and post-roll times in the Transport window:
1 Select View > Transport > Expanded.
2 In the Transport window, click in the pre-roll field.
3 Type in the pre-roll amount and press Forward Slash (/) on the numeric keypad to enter the value and automatically move to the post-roll field.
4 Type in the post-roll amount and press Enter to accept the new value.

To enable either pre- or post-roll, click the appropriate button so it is highlighted.

Use the Period(.) or Left/Right Arrow keys to move through the different time fields for pre and post-roll. Use the Up/Down Arrow keys to increase or decrease the numerical values.
**Setting Pre- and Post-Roll in a Playlist**

You can use the Selector tool to enable and disable pre- and post-roll by clicking in a track’s playlist.

**To set and enable the pre- and post-roll by clicking in a playlist:**

1. Select Options > Link Timeline and Edit Selection.
2. With the Selector tool, select the record range in the track’s playlist.
3. With the Selector tool, Option-click (Mac) or Alt-click (Windows) in the track’s playlist before the selection to enable the pre-roll at that location.
4. With the Selector tool, Option-click (Mac) or Alt-click (Windows) in the track’s playlist after the selection to enable the post-roll at that location.

**To disable the pre- and post-roll by clicking in a playlist:**

1. With the Selector tool, Option-click (Mac) or Alt-click (Windows) in the Edit selection near the start to disable the pre-roll.
2. With the Selector tool, Option-click (Mac) or Alt-click (Windows) in the Edit selection near the end to disable the post-roll.

*In the Timeline, you can reset the pre- and post-roll to zero. First, drag the Pre-Roll Flag to the Timeline Selection In Point, then drag the Post-Roll Flag to the Timeline Selection Out Point.*

3. Drag the Pre-Roll Flag to the Timeline Selection In Point.
4. Drag the Post-Roll Flag to the Timeline Selection Out Point.

**Enabling Pre/Post-Roll from the Options Menu**

Pre- and post-roll (as a pair) can be enabled and disabled from the Options menu.

**To enable both pre/post-roll from the Options menu:**

- Select Options > Pre/Post-Roll.

**Dragging Pre- and Post-Roll Flags in the Timebase Ruler**

The Pre- and Post-Roll Flags can be moved in the Main Timebase ruler, either separately or at the same time, to set their location.

**To set the pre- and post-roll amounts by dragging in the Main Timebase ruler:**

1. If you want the Pre- and Post-Roll flags to snap to the current Grid value, set the Edit mode to Grid.
2. Drag the Pre-Roll Flag to a new location in the ruler.

3. Drag the Post-Roll Flag to a new location in the Timebase ruler.

**Dragging a Pre-Roll Flag in a Timebase ruler**

To set pre- and post-roll values to the same amount, Option-drag (Mac) or Alt-drag (Windows) either the Pre- or the Post-Roll Flag in the ruler. The deselected flag will immediately reset to the same value, and will adjust accordingly as you drag the selected flag.
Audio Punch Recording Over a Specified Range

You can set Pro Tools to automatically punch record over a specific range in an audio track (for example, to replace a portion of a recorded track). The range’s start (punch in) and end (punch out) points must be specified before recording.

To manually punch in and out on record-enabled audio tracks during playback, see Chapter 26, “Punch Recording Modes.”

Though there are several ways to set record and play ranges (see “Setting Punch and Loop Points” on page 520), perhaps the easiest is to select within the track’s playlist the range for recording.

To set a record or play range by selecting within a playlist, the Edit and Timeline selections must be linked (select Options > Link Timeline and Edit Selection).

During the recording process, playback begins at the pre-roll time (if enabled) and proceeds to the start time (the punch-in point), where recording begins. When the end time (the punch-out point) is reached, Pro Tools automatically switches out of Record mode and continues playing through the specified amount of post-roll. This automated punch-in/out feature is a powerful and precise way of recording or re-recording on a track.

To punch record on an audio track:

1. Do one of the following:
   - To record nondestructively, make sure that Options > Destructive Record is not selected.
   - If you do want to permanently record over the specified record range, select Options > Destructive Record.

2. Record enable the track.

3. Select Options > Link Timeline and Edit Selection.
4 With the Selector tool, drag in the track’s playlist or in one of the Timebase rulers until the selection encompasses the punch range (see “Setting Punch and Loop Points” on page 520).

5 To hear any existing track material up to the start point, or after the end point, enable and set pre- and post-roll times (see “Setting Pre- and Post-Roll” on page 523).

6 Click Record in the Transport to arm Pro Tools for recording.

7 Click Play to start recording.

Pro Tools starts recording from the punch-in (start) point. If there is any pre-roll, recording starts when the punch-in (start) point is reached. Recording continues until the punch-out (end) point is reached (unless you manually stop recording first). If post-roll is enabled, playback continues for the specified post-roll amount.

If recording nondestructively, a new audio file is written to your hard drive and a new audio clip appears both in the track and the Clips List.

If recording in Destructive Record mode, the new audio overwrites the previous material in the existing audio file and clip.

**Monitoring during Punch-Ins**

Pro Tools provides two monitoring modes for recording: Auto Input monitoring and Input Only monitoring (see “Selecting a Record Input Monitoring Mode” on page 511).

---

**Recording Additional Takes**

After recording to an audio track, you can record additional takes to the same track. Any of these additional takes can be used in the main playlist. For information about accessing alternate takes, see “Alternate Takes” on page 530.

Recording additional takes in Destructive Record mode overwrites previous take. To keep the audio from previous takes, record the new takes in Normal (Nondestructive) Record mode.

For information on audio file and clip names for new takes, see “Configuring Default Names for Audio Files and Clips” on page 504.

To nondestructively record a new take on the same track:

1 Ensure that Normal Record mode is selected (see “Record Modes” on page 501).

2 Record enable the track.

3 Do one of the following:
   • To record from the beginning of the session, click Return to Zero in the Transport.
   • If Options > Link Timeline and Edit Selection is enabled, click anywhere in the track’s playlist to begin recording from that point.

To record a specific track range, with precise start and end points, see “Audio Punch Recording Over a Specified Range” on page 525.

4 Click Record in the Transport to arm Pro Tools for recording.

5 Click Play to start recording.

6 Click Stop to stop recording.
An audio file for the new take is written to disk and appears as an audio clip both in the track’s playlist and in the Clips List.

The audio from the original take remains on your hard drive, and is still available as a clip in the Clips List.

To destructively record over a previous take:

1. Do one of the following:
   - Select Options > Destructive Record. When in Destructive Record mode.
   - Right-click the Record button in the Transport and select Destructive.

A “D” appears in the Record button.

To append new material to the end of a Track

You can also append new material to the end of a track.

To append new material to the end of a track:

1. Do one of the following:
   - Click the Go to End button in the Transport to locate to the end of the track (this locates the end of the session).
   - Tab to the end point of the last clip on the track.

2. From there, begin recording.

Pro Tools adds the new material to the end of the track. If using Destructive Record mode, the new audio is appended to the audio file and clip from the first take. In Nondestructive Record mode, a new file and clip are created.

Recording to a New Playlist

Instead of recording over existing audio clips, there is another way to nondestructively record new takes to the same track. Do this by creating a new playlist for the track, then record just as before.

Tracks can have multiple edit playlists, each of which stores a list of clips strung together in a particular order. Also, since playlists follow groups, duplicating or selecting alternate playlists for a track in an enabled group will affect all tracks in the group.
To record to a new playlist for a track:

1. From the track’s Playlist selector, choose New.

2. Type a name for the new playlist.

3. Click OK.

When a new playlist is created, its name replaces the track name. Names for new audio files and clips are based on the track name.

4. Record enable the track.

5. To start from the beginning of the session, click Return to Zero in the Transport.

6. Click Record in the Transport to arm Pro Tools for recording.

7. Click Play to start recording.

8. Click Stop to stop recording.

An audio file for the new take is written to disk and appears as an audio clip both in the track’s new playlist and in the Clips List.

Selecting a previous playlist from track’s Playlist selector recalls its clips as they previously appeared in the track. At any time, all clips from all playlists are available in the Clips List, and can be mixed and matched between playlists and tracks.

For more information on playlists and playlist editing, see “Playlists” on page 691.

---

**Loop Recording Audio**

Pro Tools provides a loop recording feature that lets you record take after take while the same section of audio repeats over and over. This is a convenient technique for quickly recording multiple takes of a part without losing spontaneity.

When loop recording, you must first specify the start and end points for the loop. Though there are several ways to set record and play ranges (see “Setting Punch and Loop Points” on page 520), the easiest is to select the range to be looped in the track’s playlist (ensure that Options > Link Timeline and Edit Selection is selected).

The pre-roll setting, if enabled, is used only during the first record pass. Pre- and post-roll times are ignored on each successive loop. To compensate for this, you may want to make the loop range slightly longer. Later, you can trim back the recorded takes to the proper length with the Trim tool (see “Using the Trim Tools” on page 613).

When loop recording audio, Pro Tools creates a single audio file that includes all takes. Takes appear as individual clips in the Clips List and are numbered sequentially. Once you stop recording, you can audition any of the recorded takes.

To use alternate takes created with Loop Record in other sessions (such as when using Import Session Data), export clip definitions (see “Exporting Clip Definitions” on page 412). If clip definitions are not exported, alternate takes created with Loop Record will be inaccessible when imported into another session.
To loop record an audio track:

1. Do one of the following:
   - Select Options > Loop Record. When Loop Record mode is enabled, a loop symbol appears in the Record button.
   - Right-click the Record button in the Transport and select Loop.

2. Record enable the audio track by clicking its Record Enable button.

3. Select Options > Link Timeline and Edit Selection.

4. With the Selector tool, select the loop range on the track. For other methods of setting the record range, see “Setting Punch and Loop Points” on page 520.

5. To hear track material up to the start point of the loop, enable pre-roll and set the pre-roll time (see “Setting Pre- and Post-Roll” on page 523).

6. Click Record in the Transport to arm Pro Tools for recording.

7. Click Play to start recording.

The Record button flashes during the pre-roll. When the start point is reached, Pro Tools begins recording. When the end point is reached, Pro Tools loops back to the start time and continues recording.

8. To cancel all recorded takes while loop recording, press Command+Period (.) (Mac) or Control+Period (.) (Windows).

9. When finished, click Stop to stop recording.

If you stop recording before you reach the midpoint of the loop, Pro Tools discards that take. If you record more than half of the looped take, Pro Tools leaves the take in the track when you stop recording.

The recorded takes appear as clips in the Clips List and are numbered sequentially. The most recently recorded take appears in the active playlist on the track. For details on auditioning the different takes, see “Selecting Alternate Takes” on page 530.

Loop Playback and Audio Recording

Pro Tools ignores Loop Playback when recording. The only way to loop while recording is to enable Loop Record mode.

Automatically Create New Playlists When Loop Recording

When loop recording, Pro Tools creates a single file containing all recording passes where each recording pass is a clip in the file. On the track, only the last recording pass is present as a clip in the main playlist. All other clips (recording passes) are hidden and can only be recalled as matching alternate clips (takes). When enabled, the new Automatically Create New Playlists When Loop Recording option in the Operation Preferences page automatically copies each clip (take) to a new playlist in the track. This facilitates using Playlists view for auditioning and selecting alternate takes.

To automatically create new playlists when loop recording:

1. Choose Setup > Preferences and click the Operation tab.

2. In the Recording section, enable the Automatically Create New Playlists When Loop Recording option.
Alternate Takes

When punch recording or loop recording, Pro Tools creates matching alternate takes (clips). Pro Tools lets you exchange clips in the main playlist on tracks with matching alternate clips from other playlists associated with the same track, from other tracks, or from the Clips List. Matching alternate clips are clips that meet certain criteria, for example, clips that have the same User Time Stamp match (see “Matching Alternate Clips” on page 704).

Selecting Alternate Takes

After recording multiple takes with loop or punch recording, you can replace the current take in the track’s active playlist with any of the previous takes. All takes are numbered sequentially.

Selecting Alternate Takes from the Clips List

To select a take from the Clips List:

1. In the Edit window, select the current clip (take) with the Time Grabber tool.

2. Option-click (Mac) or Alt-click (Windows) different clips in the Clips List to audition them.

3. Control-drag (Mac) or Start-drag (Windows) the clip you want from the Clips List into the playlist.

The clip replaces the previous take and snaps precisely to the correct location.

Selecting Alternate Takes on a Track

Each clip resulting from a punch or loop record pass has an identical start time (the User Time Stamp). You can select and audition alternate takes from the Right-click Matches submenu or the Alternate Takes pop-up menu—even during playback.

To select an alternate take:

1. Ensure that Track ID (or Track Name) is selected and that Clip Start is selected in the Matching Criteria window (see “Matching Criteria Window” on page 531).

2. Do one of the following:
   - Right-click the clip with the Selector or the Grabber tool, and select a matching alternate take from the Matches submenu in the pop-up menu.
   - If the take currently residing in the track is selected, Command-click (Mac) or Control-click (Windows) anywhere on the selected take with the Selector tool, and select a different take from the Alternate Takes pop-up menu.
   - With the Selector tool, Command-click (Mac) or Control-click (Windows) at the precise beginning of the loop or punch range and select a different take from the Alternate Takes pop-up menu.

To cycle through matches for the selected clip, press Command+Option+Up/Down Arrows (Mac) or Control+Alt+Up/Down Arrows (Windows).
Chapter 24: Audio Recording

531

The selected matching alternate clip (take) replaces the clip in the main playlist and snaps precisely to the correct location.

One way to ensure that subsequent recording takes have the same User Time Stamp (and as such can be available as matching alternate clips) is to store punch and loop record selections as Memory Locations. Then, if you later need to record additional takes, recall the corresponding Memory Location.

To change the User Time Stamp of other clips so that they can be available as alternate matching clips for a specific location, use the Time Stamp command in the Clips List menu.

Matches and Multiple Tracks

If you have loop recorded on multiple tracks, and each track contains multiple takes with identical User Time Stamps, you can change all takes simultaneously.

To switch takes for multiple tracks:

1. Configure the Matching Criteria window (see “Matching Criteria Window” on page 531), so that the following options are enabled:
   - Track Name
   - Selection Range

2. With the Selector tool, select the take range for each track you want to replace.

3. Do one of the following:
   - Right-click the Edit selection and select a different matching alternate take from the Matches submenu.
   - Command-click (Mac) or Control-click (Windows) the Edit selection and select a different take from the Alternates pop-up menu.

The selected take replaces the previous take and snaps precisely to the correct location on each track.

Matching Criteria Window

The Matching Criteria window lets you select the criteria for matching alternate clips. This lets you refine the list of available matching clips in the Alternate Takes pop-up menu and Clip Right-click Matches submenu.

Alternate Takes pop-up menu

The selected matching alternate clip (take) replaces the clip in the main playlist and snaps precisely to the correct location.

Alternate Takes pop-up menu

Matching Criteria window

Matching Criteria affects MIDI as well as audio clips.
Alternates Match Options

The following Alternates Match options can be selected in any combination:

**Track ID** Any clips recorded to the same track are considered matching. Use this option for selecting alternate takes from loop or punch recording.

**Track Name** Any clips that share the same root name with the track or playlist are considered matching. For example, the Matches for a track named “Gtr.L” would show the clips “Gtr.L_01” and “Gtr.L_02-01,” but not “Guitar.L_01.”

**Clip Rating** Any clips that have the same Rating are considered matching. Enable this option if you have rated clips (see “Rating Clips” on page 667).

In Addition To Match Options

The following In Addition To Match options are mutually exclusive.

**All** Any clips that include the time location of the Edit cursor; or any clips that are either partly or fully within the current time range of the Edit selection.

**Clip Start** Any clips that have the same start time as the time location of the Edit cursor or Edit selection.

**Clip Start and End** Any clips that have the same start and end times as the Edit selection.

**Within Selection** Any complete clips that are entirely within the Edit selection.

**None** No other criteria in addition to the selected Alternates Match options are used to filter matching alternate clips.

Expanding Alternate Takes to New Playlists or Tracks

Pro Tools lets you copy alternate takes to new playlists or tracks. This is especially useful for auditioning, editing, and mixing multiple alternate takes or channels. Alternate takes are created when punch and loop recording.

Expanding Alternate Takes to New Playlists

Expanding alternate takes to new playlists readily facilitates track compositing. Once you have expanded alternate takes to new playlists on a track, you can audition and edit them in Playlists view to assemble the best takes in the main playlist.

To expand alternate takes to new playlists:

1. Identify the clip on the main playlist with matching alternate clips (takes).

2. Do one of the following:
   - Right-click the clip and choose Matches > Expand Alternates To New Playlists.
   - If the clip is selected, with the Selector tool, Command-click (Mac) or Control-click (Windows) anywhere on the selected clip and choose Matches > Expand Alternates To New Playlists.
   - If the clip is not selected, with the Selector tool, Command-click (Mac) or Control-click (Windows) at the precise beginning of the loop or punch range and choose Matches > Expand Alternates To New Playlists.

All matching alternate clips are copied to new playlists on the track. To view all playlists for the track, select Playlists view. In any track view, you can also select any available alternate playlist as the main playlist from the Playlist selector. For more information, see “Playlists View” on page 697.
Expanding Alternate Takes to New Tracks

Expanding alternate takes to new tracks readily facilitates auditioning, editing, and mixing alternate takes, each on separate tracks.

To expand alternate takes to new tracks:

1. Identify the clip on the main playlist with matching alternate clips (takes).

2. Do one of the following:
   • Right-click the clip and choose Matches > Expand Alternates To New Tracks.
   • If the clip is selected, with the Selector tool, Command-click (Mac) or Control-click (Windows) anywhere on the selected clip and choose Matches > Expand Alternates To New Tracks.
   • If the clip is not selected, with the Selector tool, Command-click (Mac) or Control-click (Windows) at the precise beginning of the loop or punch range and choose Matches > Expand Alternates To New Tracks.

3. Then choose one of the following from the Expand Alternates To New Tracks sub-menu:

   **By Track Name** Names all new tracks after the source track name.

   **By Clip Name** Names each new tracks after the corresponding original clip names that you see in the Matches list.

   **By Track and Clip Name** Names all new tracks after the source track name, but with the corresponding original clip names in parenthesis.

All matching alternate clips are copied to new tracks.

Recording from a Digital Source

If you plan to use a DAT player, digital-output CD recorder, or other digital device with your Pro Tools system, make sure it supports the correct digital format. For example, your Pro Tools audio interface’s AES/EBU inputs and outputs should only be connected to another AES/EBU device.

> For additional information on configuring your particular Pro Tools system for recording from a digital source, see your User Guide.

Pro Tools HD Audio Interface Digital Options

HD I/O and HD OMNI include AES/EBU, S/PDIF, and ADAT digital options. Additionally, the HD I/O with a Digital Expansion card includes TDM digital I/O options.

HD MADI includes both optical and coaxial MADI I/O (for more information, see the *HD MADI Guide)*.

Pro Tools | MTRX includes built-in AES3 and MADI coaxial digital interfaces. Additionally, you can install optional digital I/O expansion cards for AES3 I/O, Dual SDI/HD/3G, and Dual MADI I/O, and a 64-Channel IP Audio Dante module.

On HD I/O and HD OMNI, Pro Tools can receive digital audio from the factory-installed Optical (ADAT) I/O at any time (if it is not set to S/PDIF). However, Pro Tools can only receive digital audio from one of its enclosure [Enc] digital sources—AES/EBU, S/PDIF, or Optical (S/PDIF)—at a time.
Enclosure digital sources come standard with Avid HD audio interfaces and are labeled on-screen as [Encl] versions, to differentiate them from digital inputs and outputs available on the Digital card installed in HD I/O. For example, the AES/EBU inputs and outputs that come standard in the HD I/O enclosure are identified as AES/EBU [Encl].

The additional digital ports on the HD I/O are TDIF, AES/EBU, and ADAT. Pro Tools can only receive digital audio from one of these ports at a time.

Inputs on the HD I/O enclosure I/O and Digital card can be used simultaneously. For example, on an HD I/O, it is possible to clock off a source from one of the enclosure inputs and have another digital input from the digital ports doing a sample rate conversion, thus having two digital sources.

**Pro Tools Audio Interface Digital Options**

003, 003 Rack, and 003 Rack+ include S/PDIF and ADAT digital I/O.

Eleven Rack includes S/PDIF and AES/EBU digital I/O.

Mbox (3rd generation) include only the S/PDIF digital option.

All digital outputs are active at all times, so you can actually send digital audio to different digital devices simultaneously at mix time.

**Recording from Digital Sources**

To record from a digital source with Pro Tools:

1. Connect the digital output of the recording source to the appropriate digital input of your audio hardware.

2. If you want to start a new session with a different sample rate, do the following:
   - Choose File > New Session
   - Select the sample rate.
   - Configure the rest of the New Session dialog accordingly.
   - Click Save.

3. Specify the format (digital) of the inputs of the audio interface to which the digital recording source is connected:
   - Choose Setup > Hardware.
   - Choose the audio interface.
   - Select the digital format for the appropriate channel pair (such as AES/EBU or S/PDIF).

4. For Pro Tools Ultimate, select the appropriate Clock Source in the Session Setup window or Hardware Setup dialog.

5. Create a new stereo audio track.
Assign the Input Path selector for the track to the appropriate input. Since this is a digital transfer, you do not need to worry about input levels.

Assign the Output Path selector for the track to the appropriate output for monitoring (such as A 1–2).

In the Options menu, ensure that the following options are deselected: Destructive Record, Loop Record, QuickPunch, TrackPunch, and DestructivePunch.

To have recording start from the beginning of the session, click Return to Zero in the Transport.

Record enable the new audio track.

Click Record in the Transport to arm Pro Tools for recording.

Click Play to start recording.

Start playback on the recording source.

When the material from the source has finished, click Stop in the Transport.

Stop playback on the recording source.

After a Digital Transfer

(HDX or HD Native Systems Only)

After you have finished recording digitally, set the Clock Source pop-up menu in the Session Setup window back to Internal. Otherwise, Pro Tools will not switch back to its own internal clock and may not record or play audio properly. Failure to switch back to Internal synchronization typically results in pitch problems (fast or slow playback), clicks and pops, or AAE errors, since a DAT machine or CD Recorder that is idle can default to a different sample rate or stop outputting a sample rate clock altogether.

Half-Speed Recording

Pro Tools lets you play and record at half speed. This capability is similar to that of a tape deck where you can record material at half-speed and then play it back at normal speed (faster and up an octave), or record material at normal speed and play it back at half speed (slower and down an octave), for special effects.

Use half-speed recording to record difficult-to-play MIDI tracks or to record complex automation moves.

To record at half speed:

1 Record enable the tracks you want to record at half speed.

2 Click Record in the Transport to arm Pro Tools for recording.

3 Press Command+Shift+Spacebar (Mac) or Control+Shift+Spacebar (Windows). Recording begins and all existing track material plays at half speed.

4 When you have finished recording, click Stop.

For information on Half-Speed Playback, see “Half-Speed Playback Mode” on page 484.
Chapter 25: MIDI Recording

Although recording MIDI in Pro Tools is similar to recording audio, there are some important differences:

- Unlike audio, MIDI recording is almost always destructive. See “Record Modes and MIDI” on page 503 for details.
- Unlike audio tracks, MIDI and Instrument tracks can be record-enabled during playback or recording.
- MIDI and Instrument tracks have an Input selector that determines which port on your MIDI interface (devices) and which MIDI channel is routed and recorded to the track. If the MIDI Input selector is set to All, all channels for all devices are merged to the track.
- Similar to Auxiliary Inputs, Instrument tracks have audio Input and Output selectors. These selectors are different than the Instrument track’s selectors for MIDI Input and Output and are primarily used for monitoring audio from MIDI instruments or instrument plug-ins.
- It is not necessary to use QuickPunch, TrackPunch, or DestructivePunch to punch in with MIDI or Instrument tracks. This capability is available both in Normal (Nondestructive) Record mode and Destructive Record mode.

Recording from MIDI Devices

The MIDI Inputs for record-enabled MIDI and Instrument tracks determine what MIDI data is recorded in Pro Tools. MIDI Inputs can be set to a specific device (port) and channel, or they can be set to All, where all channels for all devices are merged to the track.

MIDI and Instrument tracks in Pro Tools do not contain multiple channels and always play back on the track’s assigned MIDI output device and channel. Multiple MIDI devices and channels can be simultaneously recorded to multiple tracks.

The following Pro Tools options determine whether you can record from a MIDI controller (such as a MIDI keyboard or drum pad):

- Devices that are assigned as a MIDI Controller in the Peripherals dialog (Setup > Peripherals) are ignored when MIDI tracks are recorded. This is to avoid recording data from MIDI control surfaces (such as Command|8).
- To record and play MIDI, the device must be enabled in the MIDI Input Enable dialog. For more information, see “Enabling Input Devices” on page 538.
In addition, the following options affect how MIDI data is recorded in Pro Tools:

- The MIDI Input Filter can filter out MIDI messages that you may not want to record, such as Polyphonic Aftertouch or System Exclusive data. For more information, see “MIDI Input Filter” on page 540.

- Input Quantize, when enabled, automatically quantizes (time corrects) all MIDI notes that are recorded. For more information, see “Input Quantize” on page 540.

### Enabling Input Devices

To record from a MIDI device (such as a MIDI keyboard) in Pro Tools, the device must be enabled in the MIDI Input Enable dialog. You can also use this dialog to make sure unwanted notes from certain devices, such as drum machines or arpeggiators, are not recorded.

**MIDI Control Surfaces** In order to use any MIDI control surfaces (such as Command|8), they must be enabled in the MIDI Input Enable dialog.

**MMC** In order for Pro Tools to synchronize to MIDI Machine Control (MMC), the MMC source must be enabled in the MIDI Input Enable dialog. For more information on using MMC with Pro Tools, see “Using MIDI Machine Control” on page 1283.

### To enable input devices:

2. Select the MIDI devices you want to record. Also, select any device to be used as a control surface.
3. Deselect any input devices you want to ignore while recording MIDI.
4. Click OK.

*Devices do not need to be selected to receive MIDI data from Pro Tools. For example, a device used exclusively as a sound module does not need to be selected in the MIDI Input Enable dialog.*
MIDI Thru

To monitor MIDI tracks while recording, enable MIDI Thru. When enabled, Pro Tools routes MIDI from your controllers to the device and channels assigned to the currently record-enabled MIDI track.

The MIDI preference for Global MIDI Playback Offset and individual MIDI track offsets do not affect MIDI routed with MIDI Thru.

When MIDI Thru is enabled, System Exclusive (Sysex) events are echoed to the MIDI device assigned to the record-enabled track—but only if the Sysex events are smaller than 256 bytes.

To enable MIDI Thru:
- Select Options > MIDI Thru.

When using MIDI Thru, you should disable Local Control, if present, on your MIDI devices. Otherwise, your MIDI device may receive double MIDI notes, which can lead to stuck notes. If you are unsure how to disable Local Control for your instrument, see the manufacturer’s documentation.

The Default Thru Instrument

In addition to any MIDI tracks that are record-enabled, you can also route MIDI to the Default Thru Instrument. This saves the extra steps of creating a MIDI track and record enabling it to hear a particular MIDI device and channel.

Unlike MIDI tracks, which only receive MIDI from the device and channel assigned to its MIDI Input selector, all incoming MIDI data is routed to the Default Thru Instrument.

If the Default Thru Instrument is assigned to a record-enabled MIDI track, Pro Tools only routes incoming MIDI to the record-enabled track.

To configure a default Thru instrument:
1. Choose Setup > Preferences.
2. Click the MIDI tab.
3. Do one of the following:
   - Select a specific device from the Default Thru Instrument pop-up menu to play MIDI through on that device by default.
   - Select Follows First Selected MIDI Track to have MIDI preview assignment follow MIDI track selection. When multiple MIDI tracks are selected, previewing uses the topmost MIDI track in the Edit window or the leftmost MIDI track in the Mix window.
   - To disable the Default Thru Instrument, select None.

The Default Thru Follows First Selected MIDI Track Selection option also lets you play an instrument without having to create and record-enable a MIDI or Instrument track.
**MIDI Input Filter**

Use the MIDI Input Filter to prevent certain types of MIDI messages from being recorded. The MIDI Input Filter can be set to record All messages, Only the specified messages, or All Except the specified messages.

**For example, to filter out program changes:**


2. In the MIDI Input Filter dialog, select the All Except option.

3. Select the option for Program Changes. Leave all other messages deselected.

4. Click OK.

When using the All Except option, the selected types of MIDI messages are not recorded. Conversely, when using the Only option, only the selected types of MIDI messages are recorded.

**Input Quantize**

When Input Quantize is enabled in the Input Quantize Event Operations dialog (Event > Event Operations > Input Quantize), all recorded MIDI notes are quantized automatically. Quantizing MIDI on input is useful for achieving rhythmically precise MIDI recordings. However, to preserve all of the original nuance of your recorded MIDI tracks (such as *rubato* phrasing), disable this option.

*For more information on Input Quantize, see “Input Quantize Command” on page 1027.*

**Wait for Note**

The Wait for Note button, located in the Transport window, determines how Pro Tools begins recording. When enabled, Pro Tools does not start recording until a MIDI event is received. This ensures that recording begins only when you start playing, and that the first note, or other MIDI data, is recorded precisely at the beginning of the set record range (start time).

Wait for Note can be used when recording normally, when punching in, or when loop recording. If pre-roll is enabled, it occurs after the MIDI event is received and before recording begins.

*Wait for Note and Countoff are mutually exclusive and cannot both be enabled at the same time. If, for instance, Countoff is enabled and you click the Wait for Note button, Countoff is disabled. Furthermore, Wait for Note starts recording immediately, ignoring any specified Pre-roll.*
To enable Wait for Note:

1. To view the MIDI controls in the Transport window, select View > Transport > MIDI Controls.

2. In the Transport window, click the Wait for Note button so it becomes highlighted.

Transport window with MIDI Controls

Wait for Note button, enabled

With the Operation preference for “Use F11 for Wait for Note” enabled, you can press F11 to turn on Wait for Note. (On Mac systems, the Mac “Desktop” keyboard shortcut must be disabled or remapped.)

**MIDI Merge/Replace**

The MIDI Merge button, located in the Transport window, determines how MIDI is recorded when overdubbing or punching in. When MIDI Merge is on (Merge mode), recorded MIDI is merged with existing track material. When MIDI Merge is off (Replace mode), existing data within the punched clip is replaced by the newly recorded material.

The MIDI Merge button can be turned on and off during playback and recording. In Loop Record mode, MIDI Merge has no effect, and the button is dimmed.

- To enable MIDI Merge with a keyboard shortcut, set the Numeric Keypad mode to Transport, and press the 9 key on the numeric keypad.

- You can also paste and merge MIDI notes using Paste Special commands. See “Special Paste Function for Automation Data” on page 1160.

**To enable MIDI Merge:**

1. To view the MIDI controls in the Transport window, select View > Transport > MIDI Controls.

2. In the Transport window, click the MIDI Merge button so it becomes highlighted.

MIDI Merge button, enabled
MIDI Merge Release Mode

MIDI Merge Release mode provides three options for how Pro Tools writes MIDI Continuous Controller (CC) automation when recording MIDI in MIDI Merge mode. These options determine how MIDI CC data (such as the Sustain Pedal: MIDI CC 64) is written. Select the desired MIDI Merge Release Mode option in the Pro Tools MIDI Preferences or from the Right-click menu on the MIDI Merge button.

To set the MIDI Merge Release mode:

1. Do one of the following:
   - Right-click the MIDI Merge button.
   - Choose Settings > Preferences > MIDI.

2. Select the best option for your workflow:

   **Latch** Continues writing the last value. Any existing events are overwritten until you stop recording.

   **Latch Until Next Event** Continues writing the last value until the next event even if you are still recording.

   **Touch** Immediately stops writing any new values (only use this mode to add pedal-based control data, not to modify existing data).

Configuring MIDI or Instrument Tracks for Recording

To configure one or more MIDI or Instrument tracks for recording:

1. Create a new MIDI or Instrument track, or use an existing MIDI or Instrument track.

2. For Instrument tracks, select View > Mix Window > Instruments or View > Edit Window > Instruments.

3. From the track’s MIDI Input selector, select the device and channel to be recorded. (For Instrument tracks, the MIDI Input selector is available in Instruments view.)
4 From the MIDI Output selector, select the device and channel for MIDI playback.

5 To assign multiple destinations to a single MIDI or Instrument track, Control-click (Mac) or Start-click (Windows) the MIDI Output selector and select additional channels from any device. When multiple destinations are selected for a single MIDI track, a plus sign (“+”) appears next to the first destination name in the track’s MIDI Output selector.

6 To assign a default program change to the track, do the following:
   • Click the Patch Select button.
   • Make the necessary selections for program and bank select.
   • Click Done.

7 If recording to multiple MIDI or Instrument tracks, repeat the preceding steps for each track, then continue to the next step.

8 To use a click, enable and configure the click, and set a default tempo and meter for the session (see “Recording with a Click” on page 496).

9 Enable either Wait for Note or Countoff in the Transport window.

10 To replace existing track material, disable MIDI Merge in the Transport window (see “MIDI Merge/Replace” on page 541).

11 To automatically quantize material as it is recorded, enable Input Quantize (Event > Event Operations > Input Quantize). See “Input Quantize” on page 540.

12 To start recording from the beginning of the session, click Return to Zero in the Transport.

13 Record enable the MIDI or Instrument track by clicking its Record Enable button.

14 Make sure that Options > MIDI Thru is selected, then play your MIDI controller. The MIDI device or instrument plug-in assigned to the track’s MIDI Output sounds, and the track’s meters register MIDI activity (note velocity).

You are now ready to record MIDI data to the record-enabled MIDI and Instrument tracks.

To record enable additional MIDI and Instrument tracks, Shift-click their Record Enable buttons.

To monitor audio from an external MIDI instrument, select the corresponding audio Input Path for your MIDI instrument on the Instrument track (or use an Auxiliary Input track). See “Signal Routing for Monitoring and Submixing” on page 1074.

Default program changes are sent whenever the track is played. For more information, see “Patch Select (Program and Bank Changes)” on page 772.
Recording MIDI and Instrument Tracks

In Pro Tools, you can record to one or more MIDI and Instrument tracks. Recording simultaneously to multiple tracks lets you:

- Record from multiple MIDI devices at the same time, such as when recording several performers.
- Record multiple channels from the same device, such as recording from a split keyboard.
- Transfer MIDI tracks from an external MIDI sequencer.

To take full advantage of the MIDI editing capabilities in Pro Tools, make sure to record tick-based MIDI tracks with a click. This ensures that recorded data aligns with the session’s bar and beat boundaries. You can also record to sample-based MIDI tracks without a click and derive the tempo and meter from the performance.

To record audio from a MIDI instrument or instrument plug-in, bus the audio output of the Instrument or Auxiliary Input track that is monitoring the instrument to an audio track. Record enable the audio track and start recording. See “Recording Audio from a MIDI Instrument” on page 553.

To record to one or more MIDI or Instrument tracks:

1. Configure a MIDI or Instrument track for recording (see “Configuring MIDI or Instrument Tracks for Recording” on page 542).

2. Ensure that the track to which you want to record is record enabled.

3. Ensure that Normal Record mode is selected (see “Record Modes” on page 501).

4. Click Record in the Transport to arm Pro Tools for recording (Record Ready mode). The Track Record Enabled indicator lights red.
5 Do one of the following:

- Click Play to start recording. If using Countoff, Pro Tools counts off the specified number of measures and then begins recording.
- If Wait for Note is enabled, do not click the Play button; recording will begin automatically as soon as you start playing (when a MIDI event is received).

6 Play your MIDI controller.

7 When you are finished playing, click Stop in the Transport to stop recording.

For each record-enabled track, a new MIDI clip is created and appears both in the playlist and in the Clips List.

Press F12 to start recording immediately.

You can also press Command+Spacebar (Mac) or Control+Spacebar (Windows) to start recording. For more information, see “Recording Shortcuts” on page 519.

MIDI Clips Are Created on Barlines

When recording MIDI, or when manually entering MIDI notes, the beginning and ending of MIDI clips are created on bar boundaries. This greatly facilitates arranging MIDI clips in a musically meaningful way, in whole bar lengths.

The beginning of a recorded MIDI clip always starts on the barline immediately before the first MIDI note (Note On) of the clip. Likewise, the MIDI clip ends on the barline immediately following the last note (Note Off) of the clip. The resulting clip contains all MIDI data recorded.
Recording Over Existing MIDI Clips

Unlike audio clips, existing MIDI clips are never overwritten even though MIDI data within clips can be overwritten. When MIDI Merge mode is disabled and recording MIDI on a track with existing clips, newly recorded MIDI data overwrites existing MIDI data within existing clips, but the existing clip boundaries remain. New MIDI clips are only created to fill the gaps between existing MIDI clip boundaries. Typically, new MIDI clips are always created on barlines. However, if existing clip boundaries are not on barlines, newly created clips are bound by the existing clips.

⚠️ It is possible to have the Note On of a MIDI note be in one MIDI clip, and its Note Off be in a subsequent MIDI clip. It is also possible to have the clip end before the Note Off, resulting in notes that extend beyond the clip boundary. However, Note Ons can never precede the beginning of a clip.

Playing Back Recorded MIDI

To play back recorded MIDI and Instrument tracks:

1. To start from the beginning of the session, click Return to Zero in the Transport.
2. Click Play in the Transport to begin playback.
The recorded MIDI data plays back through each track’s assigned Output device (port) and channel.

To monitor audio from an external MIDI instrument, select the corresponding audio Input Path for your MIDI instrument on the Instrument track (or use an Auxiliary Input track). See “Signal Routing for Monitoring and Submixing” on page 1074.

Undoing MIDI Recording

You can undo previous MIDI record takes.

To undo a MIDI recording:

- Once the Transport has been stopped, choose Edit > Undo MIDI Recording.

The track’s playlist is restored to its previous state. However, the following conditions apply:

- If you punched in and out several times before stopping the Transport, only the last punch is undone.
- When using Loop Record mode, all takes from each record pass are discarded.

Canceling a Record Take

It is also possible to discard the current record take before the Transport is stopped.

To cancel a take while recording:

- Press Command+Period (.) (Mac) or Control+Period (.) (Windows) before the Transport is stopped.

When in Loop Record mode, all takes from each record pass are discarded.

MIDI Input Display

The MIDI Input display in the Edit window toolbar shows chord names as they are received by MIDI and Instrument tracks. You can use this display to ensure that you are playing the right chords for your music when recording MIDI.

The MIDI Input Display can also be shown in MIDI Editor windows, see “MIDI Input Display” on page 791.

To show (or hide) the MIDI Input display in the Edit window, do one of the following:

- Select (or deselect) View > Other Displays > MIDI Input Display.
- Click the Edit Window Toolbar menu and select (or deselect) MIDI Input Display.

Editor Window toolbar, MIDI Input Display shows that a G augmented chord is received at an Instrument or MIDI track input

MIDI Punch Recording Over a Specified Range

You can set Pro Tools to automatically punch record over a specific range in a MIDI or Instrument track. The range’s start (punch in) and end (punch out) points must be specified before recording. Recording starts at the punch-in point and continues until the punch-out point is reached.

If pre-roll is enabled, the track material leading up to the punch-in point plays. You can start playing during the pre-roll to get the “feel.” However, MIDI is not recorded until the punch-in point is reached. Only when that point is reached does
Pro Tools begin recording. Additionally, for any note that is played before the punch-in point, but is released after that point, it is recorded and the start of the note is quantized to the punch-in point.

If post-roll is enabled, playback continues after recording stops for the specified post-roll amount.

**To punch in on a MIDI or Instrument track:**

1. Configure a MIDI or Instrument track for recording (see “Configuring MIDI or Instrument Tracks for Recording” on page 542).
2. Ensure that Normal Record mode is selected (see “Record Modes” on page 501).
3. In the Transport window, disable Wait for Note and Countoff.
4. Select Options > Link Timeline and Edit Selection.
5. With the Selector tool, select the punch range in the track’s playlist.

   For other methods of setting the record range, see “Setting Punch and Loop Points” on page 520.

6. To hear existing track material up to the start point, or after the end point, enable and set pre- and post-roll times (see “Setting Pre- and Post-Roll” on page 523).
7. Record enable the track containing the previous take.
8. Click Record in the Transport to arm Pro Tools for recording. The Record button flashes.
9. Click Play to start recording.
10. When you have finished recording, click Stop in the Transport. The newly recorded MIDI data appears in the track.

**Punch Recording During Playback with MIDI**

You do not have to set a record range to punch in on a MIDI or Instrument track. In fact, you can punch in and out at any time during playback. Unlike audio tracks, it is not necessary to enable QuickPunch to perform real-time punch recording.

**To punch record with MIDI:**

1. Configure a MIDI or Instrument track for recording (see “Configuring MIDI or Instrument Tracks for Recording” on page 542).
2. Ensure that Normal Record mode is selected (see “Record Modes” on page 501).
3. In the Transport window, disable Wait for Note and Countoff.
4. Record enable the track containing the previous take.
5. Click Play in the Transport to start playback.
6. When you reach the punch-in point, do one of the following:
   - Click Record in the Transport.
   - For Pro Tools systems that support a connected footswitch, press the footswitch at the punch-in point.

Footswitches are supported by 003 family interfaces, Mbox Pro, and Mbox 2 Pro, as well as any Pro Tools system with a supported control surface.

The Record button in the Transport and the track’s Record Enable button stop flashing and stay lit during recording.

7. To punch out, click Record again (or press the footswitch).

Pro Tools exits Record mode and continues playing. You can perform additional punches during the same pass.
MIDI Clips and Punch Recording

Depending on the record range, new clips may be created after punch recording.

For example, if MIDI Merge mode is disabled, recording overwrites any existing MIDI data within the record range. Since the start and end times for recording are located within both of the existing clips, newly recorded notes are written into both of the existing clips, and into a new clip created to fill the space between them.

When selecting an entire clip, or a section within a clip, before punching, no new clips are created. In this instance, only the material residing within the existing clip changes, with no new material recorded outside the clip.

Unlike audio recording, MIDI recording in this scenario is destructive. Newly recorded MIDI data overwrites existing MIDI data while leaving the existing clip boundaries intact.

If the MIDI data within a clip is altered because of a record take, the original material is either lost (unless you choose Edit > Undo MIDI Recording) or combined with new material (if MIDI Merge was enabled during recording). If an existing clip contains material you want to keep, use Duplicate to make a copy of the clip (“Duplicating Clips” on page 913), or duplicate the track’s playlist or record in a new playlist to keep a backup (see “Working with Playlists” on page 691).

Loop Recording MIDI

Loop recording with MIDI is supported by two methods:

- In Normal (Nondestructive) Record mode, enable Loop Playback and MIDI Merge for drum machine style loop recording.
- Use Loop Record mode to record multiple takes on each record pass. This is similar to loop recording audio.

Loop Recording in MIDI Merge Mode

For MIDI loop recording, use Normal (Nondestructive) Record mode with Loop Playback and MIDI Merge enabled. With this method, MIDI is recorded and merged to the same clip with each new record pass—for example, you can record hi-hats on the first pass and kick and snare on the next.

For drum machine-style step entry, use Step Input (see “Step Input Command” on page 1028).
Make sure that MIDI Merge is enabled in the Transport window, otherwise (in Replace mode) each subsequent take destructively replaces the previous take.

💡 You can record enable a different MIDI or Instrument track while loop recording. While pressing Command (Mac) or Control (Windows), use the Up/Down Arrows to record enable the previous or next MIDI or Instrument track.

**To loop record in MIDI Merge mode:**

1. Configure a MIDI or Instrument track for recording (see “Configuring MIDI or Instrument Tracks for Recording” on page 542).
2. Ensure that Normal Record mode is selected (see “Record Modes” on page 501).
3. Select Options > Loop Playback. When Loop Playback is enabled, a loop symbol appears in the Play button.

![Loop Playback enabled](image)

4. Record enable the MIDI or Instrument track. Ensure that no audio tracks are record-enabled.
5. In the Transport window, click the MIDI Merge button so it is highlighted.
7. Select Options > Link Timeline and Edit Selection.
8. With the Selector tool, select the loop range in the track’s playlist.

💡 For other methods of setting the record range, see “Setting Punch and Loop Points” on page 520.

9. To hear track material up to the start point of the loop, enable and set the pre-roll time (see “Setting Pre- and Post-Roll” on page 523).
10. Click Record in the Transport to arm Pro Tools for recording. The Record button flashes.
11. Click Play to start recording.

The Record button flashes during pre-roll. When the start point is reached, Pro Tools begins recording. When the end point is reached, Pro Tools loops back to the start point and continues playing and recording.

12. Play your MIDI controller. Newly recorded MIDI data appears as a clip in the record track. On each successive take, recorded material shows up in the clip, without replacing material from previous takes.
13. To switch to a new record track, press Command (Mac) or Control (Windows), and press the Up/Down Arrow keys to record enable the previous or next MIDI or Instrument track.
14. When you are finished recording, click Stop in the Transport.

The newly recorded MIDI data appears as a MIDI clip in the track’s playlist, and in the Clips List.

**Loop Recording Multiple Takes**

When recording MIDI in Loop Record mode, new clips are created each time new material is received during a record pass. This differs somewhat from loop recording audio, where Pro Tools creates a single audio file that comprises all takes, which appear as individual clips in the Clips List.
You can use MIDI loop recording to record successive takes without stopping the record process, thereby capturing your creative spontaneity. Another advantage with this method of recording MIDI, which is nondestructive, is that all existing and newly recorded clips remain intact (and available in the Clips List).

**To record MIDI in Loop Record mode:**

1. Configure a MIDI or Instrument track for recording (see “Configuring MIDI or Instrument Tracks for Recording” on page 542).

2. Select Options > Loop Record. When Loop Record mode is enabled, a loop symbol appears in the Record button.

3. If you have not done so already, record enable the MIDI or Instrument track by clicking its Record Enable button. Make sure no audio tracks are record-enabled.


5. Select Options > Link Timeline and Edit Selection.

6. With the Selector tool, select the loop range in the track’s playlist.

7. To hear track material up to the start point of the loop, enable and set the pre-roll time (see “Setting Pre- and Post-Roll” on page 523).

8. Click Record in the Transport to arm Pro Tools for recording. The Record button flashes.

9. Click Play to start recording.

The Record button flashes during the pre-roll. When the start point is reached, Pro Tools begins recording. When the end point is reached, Pro Tools loops back to the start point and continues playing and recording.

10. Play your MIDI controller. A new MIDI clip containing the newly recorded material is automatically created and appears in the track’s playlist, replacing the previous clip.

Clips are replaced (nondestructively) during subsequent record passes when new MIDI material is received.

11. When you are finished recording, click Stop in the Transport.

The recorded takes appear as clips in the Clips List and are numbered sequentially. The takes, which are the same length and easily interchangeable, can be selected from the Matches pop-up menu—even while the session plays or loops.

*For other methods of setting the record range, see “Setting Punch and Loop Points” on page 520.*
To select the various record takes:

1. Ensure that the Matching Criteria window is correctly configured (see “Matching Criteria Window” on page 531).

2. Do one of the following:
   - Right-click the clip with the Selector or Grabber tools, and select a take from the Matches submenu in the pop-up menu.
   - With the Selector tool, Command-click (Mac) or Control-click (Windows) at the precise beginning of the loop or punch range and select a different take from the Alternates pop-up menu.
   - If the take currently residing in the track is selected, with the Selector tool, Command-click (Mac) or Control-click (Windows) anywhere on the selected take and select a different take from the Alternates pop-up menu.

The selected take (clip) replaces the previous take and snaps precisely to the correct location.

For more information on auditioning and managing takes, see “Selecting Alternate Takes” on page 530.

MIDI Step Input

Step Input lets you use a MIDI keyboard (or any other MIDI controller that sends MIDI note data) to enter notes individually, one step at a time. This gives you precise control over note placement, duration, and velocity. With MIDI Step Input you can also create musical passages that might be difficult to play accurately, or at faster tempos.

For more information on Step Input, see “Step Input Command” on page 1028.

Recording System Exclusive Data

Pro Tools supports recording and playing System Exclusive data (Sysex) with MIDI tracks. This allows you to use MIDI tracks in Pro Tools to store patch and configuration data for your MIDI devices, or to record real-time Sysex changes for a particular parameter of a MIDI device that cannot be controlled by a standard MIDI controller.

To record a Sysex dump at the beginning of a MIDI track:

1. Make sure that the MIDI OUT for the device sending the Sysex is connected to your MIDI interface’s MIDI IN.

2. In the MIDI Input Filter dialog, enable Only and System Exclusive.

3. Configure a MIDI track for recording (see “Configuring MIDI or Instrument Tracks for Recording” on page 542).

4. Ensure that Normal Record mode is selected (see “Record Modes” on page 501).

5. Record enable a MIDI track.


7. To start recording from the beginning of the session, click Return to Zero in the Transport.
When you are ready to begin recording, click Record in the Transport window. The Record, Play, and Wait for Note buttons flash, indicating that Pro Tools is waiting for MIDI data.

Initiate the Sysex transfer from the MIDI device, according to the manufacturer’s instructions. Pro Tools automatically begins recording as soon as it starts to receive Sysex data.

When the Sysex transfer is complete, click Stop in the Transport.

The newly recorded MIDI data appears as a MIDI clip in the track’s playlist, and in the Clips List. MIDI clips that contain System Exclusive data appear blank when the Track View is set to Clips.

To see the Sysex event blocks, which indicate the location of the data, set the Track View to Sysex (see “Clips View for MIDI and Instrument Tracks” on page 587).

For information on moving and copying of Sysex data, see “System Exclusive Events” on page 776.

To send Sysex data from Pro Tools to an external MIDI device:

1. For the device receiving the System Exclusive data, make sure its MIDI IN is connected to the MIDI interface’s MIDI OUT. Also, make sure the device is set to receive Sysex. Some devices require that memory protect be off. For more information, see the manufacturer’s instructions.

2. Make sure that the MIDI track containing the Sysex data is not record enabled.

3. Click the track’s MIDI Output selector and assign the device from the pop-up menu.

4. Configure the external MIDI device to receive Sysex data according to the manufacturer’s instructions.

5. Click Play in the Transport to begin playback. Pro Tools begins playing and transmits the previously recorded Sysex to the assigned MIDI device.

Recording Audio from a MIDI Instrument

Typically, you will monitor the audio from MIDI instruments (both hardware and plug-ins) using Instrument and Auxiliary Input tracks. During the final mixdown, audio from Instrument and Auxiliary Input tracks can be included when using Bounce to Disk, or on a bussed recording path if recording to a new track.

When using instrument plug-ins, you may want to record the audio from a MIDI instrument to a new track before mixing in order to free up DSP resources.

Recording Audio from an Instrument Plug-In

To record audio from an instrument plug-in:

1. Create a new Instrument track.

2. Insert an instrument plug-in on that track.

3. Do one of the following:
   - Record your MIDI performance on the Instrument track.
   - Manually enter MIDI data in the Instrument track.

   You can also record the MIDI and audio from your performance at the same time.

4. Create a new audio track with the same number of channels as the Instrument track (such as stereo).

5. Set the Instrument track’s Audio Output Path selector to a bus (for example, Bus 1–2).
6 Set the audio track’s Audio Input Path selector to the same bus.

7 Set the audio track’s Audio Output Path selector to the main monitoring path).

8 Record enable the audio track.

9 Do one of the following:
   • To record from the beginning of the session, click Return To Zero in the Transport.
   • Make a Timeline selection for the record range.

10 Click Record in the Transport to arm Pro Tools for recording.

11 Click Play in the Transport to start recording.

12 When your previously recorded MIDI performance is finished playing, click Stop in the Transport to stop recording.

**Recording Audio from an External MIDI Instrument**

You can record audio from an external MIDI instrument in one of two ways:

• By bussing audio from the output of the Instrument (or Auxiliary Input) track used to monitor the MIDI instrument to an audio track for recording.

• By setting the audio track’s Audio Input Path selector to the same Audio Input Path as the Instrument (or Auxiliary Input) track used for monitoring the external MIDI instrument.

This second method avoids any additional latency associated with bussing. However, be sure to mute the Instrument (or Auxiliary Input) track used for monitoring while recording the same audio path to the audio track.
Retrospective Record for MIDI

When you play a MIDI controller (such as a USB MIDI keyboard or trigger pad) along with the playback of your Pro Tools session or project, your MIDI performance is stored in a buffer by Pro Tools behind the scenes. As long as any MIDI or Instrument is record-enabled, Pro Tools captures any MIDI performance during playback whether you are recording or not. For example, if were playing along with your session, but did not actually record your performance, Pro Tools captures it for you. You can then place it on a MIDI or Instrument track spotted to the exact time of your original performance on the Timeline. Using Retrospective Record, you won't lose that perfect take or that great musical idea just because you were only playing along with the session but not actually recording.

💡 Retrospective Record takes into account the MIDI Import Filter settings. For example, if Pitch Bend is filtered, but the Modulation Wheel (MIDI CC 1) is not, when you perform using both any Pitch Bend activity is excluded while Modulation Wheel activity is included.

⚠️ Pro Tools only captures your MIDI performance when a MIDI or Instrument track is record enabled, or if the Default Thru Instrument in the Pro Tools MIDI preferences is set to any option other than None (Setup > Preferences > MIDI).
To recover a MIDI performance that was played, but not recorded:

1. First, one of the following conditions must be met for Pro Tools to buffer any MIDI performance:
   - There is at least one MIDI or Instrument track in the session and Default Thru Instrument is set to any option other than None in the MIDI Preferences (Setup > Preferences > MIDI).
   - Any MIDI or Instrument track is record enabled and its MIDI Input selector is set to either your MIDI instrument or All.

2. Start playback of your Pro Tools session.

3. Play your MIDI controller along with session playback. You will hear your performance either from the designated Default Thru Instrument (if one is assigned in the MIDI Preferences) or from the instrument (virtual or hardware) assigned to the MIDI output of the record-enabled MIDI or Instrument track to which your controller is assigned.

4. Choose Events > Retrospective Record.

   Press Option+Shift+Z (Mac) or Alt+Shift+Z (Windows) to write your MIDI performance to the record-enabled MIDI or Instrument track.
Pro Tools places your MIDI performance in the record-enabled track matching the time of the original performance on the Timeline.

Additional Behaviors with Retrospective Record for MIDI

- Pro Tools lets you apply Retrospective Record during playback.
- Pro Tools lets you play over a MIDI or Instrument track that already contains MIDI data. When using Retrospective Record on a track that already contains MIDI data, your performance is written to and merged with the existing MIDI data on that track.
Chapter 26: Punch Recording Modes

Punch recording is used in many areas of audio production for film, video, and music.

**Introduction to Punch Recording Modes**

Once basic track material has been recorded, it is often necessary to replace some, but not all, of the audio that makes up each track. Punch recording lets you manually punch one or more audio tracks in and out of recording without stopping the Transport.

💡 You do not need to use QuickPunch or any other audio punch recording mode to punch record with MIDI tracks. MIDI tracks can be punched while in Normal (Nondestructive) Record mode, and in Destructive Record mode.

**Pro Tools Punch Recording Modes**

Pro Tools provides three different manual punch recording modes:

**QuickPunch** A nondestructive Record mode that lets record-enabled tracks be punched in and punched out during playback by clicking the Record button in the Transport. QuickPunch mode is available on all systems.

**TrackPunch (Pro Tools | Ultimate Only)** A nondestructive Record mode that lets individual tracks be punched in, punched out, and taken out of record enable without interrupting online recording and playback.

**DestructivePunch (Pro Tools | Ultimate Only)** A destructive Record mode that maintains a single continuous audio file per punch track, and lets individual tracks be punched in, punched out, and taken out of record enable without interrupting online recording and playback.

💡 To automatically punch in and out on record-enabled audio tracks over a specific range, see “Audio Punch Recording Over a Specified Range” on page 525.
Guidelines for Punch Recording

This topic lists the basic settings and guidelines for Pro Tools punch recording, including the following:

- “Voice Requirements for Punch Recording” on page 560.
- “Delay Compensation and DestructivePunch Mode” on page 561.
- “Audio Files, Clips and Takes” on page 561.
- “Preferences for Punch Recording” on page 562 (for crossfades, as well as transport and monitor configuration settings).

Voice Requirements for Punch Recording

The maximum number of tracks that can be punched depends on the type of system you are using, as well as the number of available voices. The following topics provide guidelines for voice usage with punch recording that can be useful when managing resources during sessions.

Pro Tools (QuickPunch Only)

QuickPunch capabilities for Pro Tools depends on the total number of voices available. This will vary depending on the number of tracks and plug-ins in use in the current session (which affects the number of available voices).

⚠️ QuickPunch uses CPU processing power, and may reduce the number of tracks and plug-ins you can use.

To make more voices available for punch recording:

1. Identify tracks that are not record-enabled, and do not need to be heard while recording.
2. Make those tracks inactive.

Pro Tools Ultimate (QuickPunch, TrackPunch, and DestructivePunch)

When using any punch recording mode with Pro Tools Ultimate, two voices are required for each record-enabled mono track. This means that you can punch record up to half the total number of voices available on your system.

If the required number of voices for the record-enabled tracks is not available when switching to QuickPunch, TrackPunch, or DestructivePunch mode, you are prompted to free up the necessary voices.

To make more voices available for punch recording:

- Identify tracks that are not record-enabled, and do not need to be heard while recording, and do any of the following:
  - Set voice assignments for tracks to Off.
  - Make tracks inactive.
  - Group all Native plug-ins before DSP plug-ins.

Voices that are in use by other tracks, but not record-enabled, may be “stolen” during punch recording as necessary.

For details on voice capabilities, see “Pro Tools Capabilities with Different Hardware Configurations” on page 38.
When any punch recording mode is enabled, voice playback priority is as follows (from highest to lowest playback priority):

- Tracks with assigned voices that are not record-enabled.
- Tracks with assigned voices that are record-enabled.
- Tracks with Dynamically Allocated Voicing that are not record-enabled.
- Tracks with Dynamically Allocated Voicing that are record-enabled.

If a session has plenty of available voices, you should have no trouble punch recording tracks using Dynamically Allocated Voicing. However, if you are running out of voices, and want to ensure that a track is heard when punch recording, be sure to set the voicing tracks that you don’t need to punch into to Off.

**Delay Compensation and DestructivePunch Mode**

When using DestructivePunch to punch in on an existing recording, make sure the Delay Compensation settings are the same as when the original file was recorded. If they differ, the punched-in audio will not be time-accurate to the original recording.

- If Delay Compensation was inactive when recording the original file, it should be deactivated while using DestructivePunch.
- If Delay Compensation was active when recording the original file, it should be kept active while using DestructivePunch.

To ensure that the Delay Compensation path on record tracks remains consistent while using DestructivePunch, you need to prevent Pro Tools from using the Low Latency monitoring path when record tracks switch to Input monitoring.

**To apply Delay Compensation to a track where Delay Compensation was suspended, do one of the following:**

- Right-click the Track Compensation indicator on the track and select Auto Low Latency Off.
- Command-Control-click (Mac) or Control-Start-click (Windows) the Track Compensation indicator on the track.

**To apply Delay Compensation to all selected tracks where Delay Compensation was suspended, do one of the following:**

- Shift-Right-click the Track Compensation indicator on the track and select Auto Low Latency Off.
- Command-Control-Shift-click (Mac) or Control-Start-Shift-click (Windows) the Track Compensation indicator on the track.

For more information, see “Delay Compensation” on page 1082.

**Audio Files, Clips and Takes**

**QuickPunch and TrackPunch Modes**

QuickPunch and TrackPunch are **nondestructive** recording modes. Instead of replacing audio while punching, QuickPunch and TrackPunch create new audio files for each pass (a pass is one cycle of starting and stopping the Transport).

Pro Tools begins recording a new audio file when playback begins, automatically generating clips in that file at each punch-in and punch-out point. Up to 200 of these “running punches” can be performed in a single pass. QuickPunch and TrackPunch provide instantaneous monitor switching on punch-out.
After recording with QuickPunch or TrackPunch, the new audio clips appear in the Clips List. This includes the whole-file audio clip encompassing all punches from the record pass, along with the clips derived for each punch.

Names for the punched clips are numbered consecutively starting with “01.” For example, if QuickPunch is used to punch in twice on a track called “Lead Gtr,” a clip for the parent audio file appears and is named “Lead Gtr_01,” and two clips for the punches are named “Lead Gtr_01-01” and “Lead Gtr_01-02.”

If you stop playback and record additional punches with QuickPunch (or TrackPunch), a new whole file clip is created (since one is created for each pass), and subsequent clips are named by incrementing the first two digits in the name. For example, on the second pass, the punched clips are named “Lead Gtr_02-01,” “Lead Gtr_02-02,” and so forth.

**DestructivePunch Mode**

DestructivePunch is a destructive recording mode which permanently replaces pre-existing track material with newly recorded “punch” audio. Pro Tools only records while tracks are punched in, inserting new material and replacing audio in the track playlist.

**Preferences for Punch Recording (Crossfade, Transport, and Record Settings)**

Pro Tools provides several punch-related preference settings that let you specify how crossfades, monitoring and transport functions are to perform during and after recording passes. These settings optimize Pro Tools fades, transport and track behavior for different types of tasks, including dubbing, mixing, and overdubbing.

### Crossfades while Punch Recording

Pro Tools places crossfades at each in and out point, for smooth transitions between punch clips. You can specify the crossfade length for QuickPunch and TrackPunch modes (DestructivePunch uses a fixed crossfade length which cannot be changed). After punch recording is completed, all crossfades can be edited in the same manner as standard crossfades (see Chapter 31, “Fades and Crossfades”).

#### QuickPunch/TrackPunch Crossfade Length

Pro Tools can automatically write a crossfade for each punch point when using QuickPunch and TrackPunch. The length for these crossfades is set with the QuickPunch/TrackPunch Crossfade Length option on the Editing Preferences page.

**To set the QuickPunch/TrackPunch Crossfade Length:**

1. Choose Setup > Preferences and click the Editing tab.
2. Enter a new value (in msec) for the QuickPunch/TrackPunch CrossFade Length. A good general-purpose crossfade length for punches is 10 milliseconds. If you set the preference to zero, Pro Tools will not create any crossfades at the punch-in/out points.
3. Click OK.

If a value other than zero is specified for the QuickPunch/TrackPunch Crossfade Length, Pro Tools writes a pre-crossfade at the punch-in point (the fade occurs up to but not into the punched clip boundary), and a post-crossfade at punch-out (after the punched clip).
Regardless of the current QuickPunch/TrackPunch Crossfade Length setting, Pro Tools always executes a 4 millisecond “monitor only” crossfade (which is not written to disk) to avoid distracting pops or clicks that might occur as you enter and exit record mode.

**DestructivePunch and Crossfades**

DestructivePunch uses a fixed 10-millisecond linear crossfade at each in and out point. After punch recording is completed, crossfades can be edited in the same manner as standard crossfades (see Chapter 31, “Fades and Crossfades”).

**Transport and Record Settings**

Transport and Record preferences for punch recording appear on the Operation Preferences page. These preferences specify how track and Transport record status respond during, between, and after punches and passes.

**Transport RecordLock**

This setting lets the Transport Record be configured to either emulate a digital dubber, or to maintain legacy behavior for the Transport master Record.

- When not enabled, the Transport Record disarms when Pro Tools is manually stopped or stops due to a loss of timecode. This replicates legacy Pro Tools recording behavior.
- When enabled, the Transport Record remains armed when playback or recording stops. This saves having to re-arm the Transport between takes, emulating digital dubber behavior.

**Destructive Recording and Transport RecordLock**

As a precaution against accidentally recording over previous material, the Transport RecordLock option is automatically disabled and grayed out when Destructive record mode is enabled.

**Audio Track RecordLock**

This setting lets Pro Tools tracks either emulate a digital dubber, or maintain legacy behavior for track record status.

- When the Audio Track RecordLock option is enabled, the record-enabled audio tracks remain armed when playback or recording stops.
- When the Audio Track RecordLock option is not enabled, record-enabled audio tracks are taken out of record enable when Pro Tools is stopped. This prevents tracks from remaining armed from pass to pass, emulating track record behavior of a digital dubber.

*For examples of how these settings can be applied, see “Example TrackPunch and DestructivePunch Workflows” on page 574.*
Synchronization and Track Arming Options for Punch Recording (SYNC HD Only)

Synchronization settings for online punch recording vary depending on the type and capabilities of your Pro Tools system and other devices in your studio.

For basic timecode and synchronization information for Pro Tools, see Chapter 57, “Working with Synchronization.”

Pro Tools Ultimate with MachineControl lets you remotely arm tracks on supported 9-pin decks (or V-LAN for Transport only).

Choose Setup > Machine Track Arming Profiles to configure your system, and choose Window > Machine Track Arming to display the Machine Track Arming window.

For information on remote track arming with MachineControl, see Chapter 57, “MachineControl.”

QuickPunch Audio Recording

QuickPunch is available on all systems and lets you instantaneously punch in and out all record-enabled audio tracks during playback by clicking the Record button in the Transport.

Many Pro Tools systems also let you use a footswitch to punch in and out. See the guide that came with your Pro Tools audio interface or control surface.

Recording with QuickPunch

To punch record with QuickPunch:

1. Do one of the following:
   • Select Options > QuickPunch.
   • Right-click the Record button in the Transport and select QuickPunch.

When QuickPunch is enabled, a “P” appears in the Record button in the Transport.

QuickPunch enabled

2. Check or reconfigure the crossfade setting for punch recording (see “QuickPunch/TrackPunch Crossfade Length” on page 562).

3. Click the track Record Enable button to record enable each track on which you want to punch in.

If you cannot record enable tracks due to voice limitations, see “Voice Requirements for Punch Recording” on page 560.
4 Prepare to record by cueing Pro Tools to an appropriate location. To use pre-roll, enable a pre-roll value in the Transport window.

5 Start playback by clicking Play in the Transport window.

6 Do one of the following:
   • When you reach the punch-in point, click Record in the Transport.
   • For Pro Tools systems that support using a connected footswitch, step on the footswitch at the punch-in point.

   The Record button stops flashing and stays lit during recording.

7 To punch out, click Record again (or step on the footswitch).

   As Pro Tools continues playing, you can perform additional punches (up to 200). When recording multiple punches during a single pass, a single audio file is recorded from which Pro Tools creates the appropriate clips.

   After a QuickPunch recording pass, the punched track’s playlist in the Edit window displays the clips created by punching. You can use any of the Trim tools after punch recording to open up the head or tail of QuickPunch recorded clips, or to reveal the parent audio file that was recorded in the background. This lets you compensate for any late or missed punches.

   For information on file and clip naming, see “Audio Files, Clips and Takes” on page 561.

QuickPunch with an Edit Selection

   If you make an Edit selection and use QuickPunch, the following rules apply:
   • If the Transport is not online, recording begins and stops whenever you click the Record button in the Transport—regardless of the selection’s start or end point.
   • If the Transport is online, punch-in/out behavior is controlled by the Online Options setting on the Operation Preferences page.
     • If you select Record Online at Insertion/Selection, QuickPunch punches in and out only within the selection (or in the case of an insertion point, only after the insertion point).
     • If you select Record Online at Timecode Lock, QuickPunch disregards the selection and punches in and out whenever you want (after Pro Tools has locked to timecode).

   For information about online playback with Pro Tools, see the User Guide that came with your system. For information about synchronization with TrackPunch and Destructive-Punch recording, see “Synchronization and Track Arming Options for Punch Recording” on page 564.
TrackPunch Audio Recording
(Pro Tools | Ultimate Software Only)

TrackPunch mode lets you punch tracks in and out individually (one at a time) or punch multiple tracks in and out simultaneously. TrackPunch is a nondestructive punch mode which leaves previous material on disk. (To destructively replace audio on disk, see “DestructivePunch Audio Recording” on page 569).

TrackPunch Setup

Before using TrackPunch in a record pass you must configure Pro Tools, session, and track settings.

Configuring Pro Tools

To configure Pro Tools:

1 Configure tracks, voicing, and other TrackPunch settings as needed (see “Guidelines for Punch Recording” on page 560).

2 Make sure Pro Tools is not recording or playing back (the Transport is stopped).

Enabling TrackPunch Mode

To enable TrackPunch mode:

Do any of the following:

• Select Options > TrackPunch.

• Right-click the Record button in the Transport, and select TrackPunch from the pop-up menu.

• Control-click (Mac) or Start-click (Windows) the Record button in the Transport to cycle through available Record modes until TrackPunch mode is selected (a “T” indicates TrackPunch mode).

• Press Command+Shift+T (Mac) or Control+Shift+T (Windows).

Transport Display of TrackPunch Status

The Transport Record button indicates TrackPunch and Record status as follows:

When TrackPunch mode is enabled:

• A “T” appears in the Record button in the Transport.

• If at least one track is TrackPunch-enabled, the Record button lights solid blue.

When TrackPunch mode is enabled and the transport is armed for recording:

• If no tracks are TrackPunch-enabled, the Record button in the Transport flashes gray and red.

• If at least one track is TrackPunch-enabled, the Record button flashes blue and red, and the record LED lights.

Whenever at least one audio track is recording, the Transport Record button lights solid red.
TrackPunch Enabling Tracks

Before each pass, you must TrackPunch enable all tracks that you intend to punch (you can TrackPunch enable tracks without record enabling them).

To TrackPunch enable one audio track:
- Control-click (Mac) or Start-click (Windows) the track’s Record Enable button.

To TrackPunch enable or disable all audio tracks:
- Option-Control-click (Mac) or Alt-Start-click (Windows) a track’s Record Enable button.

To TrackPunch enable or disable all selected audio tracks:
- Option-Control-Shift-click (Mac) or Alt-Start-Shift-click (Windows) a track’s Record Enable button.

When TrackPunch enabled, Track record enable buttons light solid blue.

💡 Create track groups for each stem or set of tracks on which you plan to punch, then use the Groups List to quickly select all tracks in the group.

Track Record Status Display

Each track’s Record Enable button indicates its TrackPunch and record enable status as follows:

- When a track is TrackPunch-enabled but not record-enabled, its Record Enable button lights solid blue.
- When a track is both TrackPunch-enabled and record-enabled, its Record Enable button flashes blue and red.
- When a track is record-enabled only, its Record Enable button flashes red.
- While a track is recording (in any mode), its Record Enable button lights solid red.
Monitoring and Levels

To complete the setup for TrackPunch:

1 Configure monitoring for record-enabled tracks by selecting a mode from the Track menu, or using the TrackInput button, as appropriate. Choices include:
   - Set Record Tracks to Auto Input
   - Set Record Tracks to Input Only

Selecting either monitoring mode only affects tracks that are record-enabled.

2 Start playback and compare levels of the input source with audio on disk. Click the TrackInput button to toggle the track source. When lit (green), the track is monitoring input. When unlit (gray), the track is monitoring from disk (see “Selecting Record Monitor Modes with Track-Input Monitoring” on page 512).

3 When you are satisfied with your levels, you are ready to start punch recording.

Using TrackPunch

After you have configured Pro Tools, tracks, and levels, you can record with TrackPunch in several ways.

Punching In on Individual Tracks

To punch in on individual tracks:

1 Make sure Pro Tools is in TrackPunch mode.

2 Control-click (Mac) or Start-click (Windows) the Record Enable button for each track you want to punch in, so that the track is Track-Punch-enabled only. The track’s Record Enable button should light solid blue.

3 Click Record in the Transport to enter the TrackPunch Record Ready mode. The Record button flashes blue and red.

4 Click Play in the Transport to begin playback.

5 During playback, punch in and out on individual TrackPunch-enabled tracks by clicking their respective Record Enable buttons.

6 While continuing local or remote playback, do any of the following:
   - Punch in on other TrackPunch enabled tracks individually.
   - After punching out, take tracks out of record enable then record enable different TrackPunch enabled tracks.
   - Repeat as needed to punch other stems, tracks, or takes.

7 Stop playback. When you are finished with the record pass, track Record Enable status and transport Record Arm status follow the current Audio Track RecordLock and Transport RecordLock preference settings.

After a TrackPunch recording pass, the punched track’s playlist in the Edit window displays the clips created by punching. You can use any of the Trim tools after punch recording to open up the head or tail of TrackPunch recorded clips, or to reveal the parent audio file that was recorded in the background. This lets you compensate for any late or missed punches.

For information on file and clip naming, see “Audio Files, Clips and Takes” on page 561.
Punching In on Multiple Tracks Simultaneously

To punch in on multiple tracks simultaneously:

1. Enable TrackPunch mode.

2. Click the Record Enable button on each track you want to punch in, so that the track is both TrackPunch- and Record-enabled. The track’s Record Enable button flashes blue and red.

3. Do one of the following:
   - During playback, click Record in the Transport to punch in and out on all TrackPunch-enabled tracks simultaneously.
   - Click Record in the Transport first, then Option-Shift-click (Mac) or Alt-Shift-click (Windows) a track’s Record Enable button to simultaneously punch in and out on all currently selected TrackPunch enabled tracks.

4. Stop playback. When you are finished with the record pass, track Record Enable status and transport Record Arm status follow the current Audio Track RecordLock and Transport RecordLock preference settings.

Start Recording on All Tracks

You can choose to begin a punch pass in record, to punch out and back in as needed.

To punch in on all tracks:

1. Enable TrackPunch mode (see “Transport Display of TrackPunch Status” on page 566).

2. Click the Record Enable button on each track you want to punch in, so that the track is both TrackPunch- and Record-enabled. The track’s Record Enable button flashes blue and red.

3. Click Record in the Transport to enter the TrackPunch Record Ready mode. The Record button flashes blue and red.

4. Click Play in the Transport to begin playback.

5. During playback, punch out and back in on individual TrackPunch-enabled tracks by clicking their respective Record Enable buttons.

6. Stop playback. When you are finished with the record pass, track Record Enable status and transport Record Arm status follow the current Audio Track RecordLock and Transport RecordLock preference settings.

DestructivePunch Audio Recording

(Pro Tools | Ultimate Software Only)

DestructivePunch is a destructive recording mode that lets you punch in and out on during playback, while preserving a contiguous audio file on each punched track. Like TrackPunch mode, DestructivePunch mode lets you punch tracks in and out individually (one at a time) or punch multiple tracks in and out simultaneously.

Unlike QuickPunch and TrackPunch, DestructivePunch replaces audio within the target parent file. DestructivePunch is essentially a destructive version of TrackPunch mode. Where TrackPunch always records audio to a new file in the background, DestructivePunch destructively records audio directly into the original file, using a fixed 10-millisecond linear crossfade. No additional clips are created when recording in DestructivePunch mode. Up to 200 “running punches” can be performed in a track during a single DestructivePunch pass.

DestructivePunch recording is not supported with AudioSuite rendered clips with handles. You can consolidate such clips if you need to use DestructivePunch.
DestructivePunch Setup
(Pro Tools | Ultimate Software Only)

Before using DestructivePunch in a record pass you must configure Pro Tools, session, and track settings.

Configuring Pro Tools for DestructivePunch

To configure Pro Tools:

1 Configure tracks, voicing, and other settings as needed (see “Guidelines for Punch Recording” on page 560).

2 Make sure Pro Tools is not recording or playing back (the Transport is stopped).

Enabling DestructivePunch Mode

To enable DestructivePunch mode:

- Do one of the following:
- Select Options > DestructivePunch.
- Right-click the Record button in the Transport and select DestructivePunch.
- Control-click (Mac) or Start-click (Windows) the Record button in the Transport to cycle through available Record modes until DestructivePunch mode is indicated by “DP” in the Transport Record Enable button.

⚠️ Power waveform view is not available in Destructive Punch mode.

Transport Display of DestructivePunch Status

When DestructivePunch mode is enabled:

- The letters “DP” appear in the Record button in the Transport.

- If at least one track is DestructivePunch-enabled, the Record button in the Transport lights solid blue.

![Transport Record Enable button with DestructivePunch mode enabled](image)

When DestructivePunch mode is enabled and the transport is armed for recording:

- If no tracks are DestructivePunch-enabled, the Record button in the Transport flashes gray and red.

- If at least one track is DestructivePunch-enabled, the Record button flashes blue and red.

- If at least one DestructivePunch-enabled track is also record enabled, the Record button flashes blue and red, and the record LED lights.

- Whenever at least one audio track is recording, the Record button lights solid red.
Preparing Tracks for DestructivePunch Recording

In order for a track to be enabled for DestructivePunch recording, the track must contain a contiguous audio file that meets the following requirements:

- The file must start at the beginning (sample 0) of the session.
- The File Length must be equal to or greater than the DestructivePunch File Length setting (see “DestructivePunch File Length” on page 571).

If a track does not contain a file that meets these requirements, you can do any of the following to meet the requirements:

- Move the current file in the track Timeline so that its beginning aligns with the session start.
- Use the Consolidate command to create a continuous file of the required length.
- Change the DestructivePunch File Length setting so that the current file is equal to or greater than the required length.
- Use the Prepare DPE Tracks command to consolidate audio on all DestructivePunch-enabled tracks. (See “Using the Prepare DPE Tracks Command” on page 571.)

DestructivePunch File Length

To use DestructivePunch on an audio track, the track must contain a contiguous audio file of a minimum length, which is set in the Pro Tools Operation preferences page.

To set DestructivePunch File Length:

1. Choose Setup > Preferences and click the Operation tab.
2. Type a value for DestructivePunch File Length.
3. Click OK.

Using the Prepare DPE Tracks Command

To prepare a track for DestructivePunch recording:

1. Enable DestructivePunch mode (“Enabling DestructivePunch Mode” on page 570).
2. Make sure the tracks you want to prepare are DestructivePunch-enabled (see “DestructivePunch-Enabling Tracks without Record Enabling Them” on page 572).
3. Choose Options > Prepare DPE Tracks.

Pro Tools consolidates audio on all DestructivePunch-enabled tracks from the beginning of the session to the value specified in the DestructivePunch File Length preference.

⚠️ For clips with any clip gain settings other than 0 dB, the Prepare DPE Tracks command automatically renders all clip gain and resets all clip gain to 0 dB.

Enabling Tracks for DestructivePunch Recording

You can enable tracks for DestructivePunch without record enabling them. This lets you punch in on individual tracks at any time after starting playback by clicking their respective Record Enable buttons.

You can also simultaneously DestructivePunch enable tracks and record enable them. This lets recording begin as soon as the transport is record-armed and playback begins. (See “DestructivePunch-Enabling and Record-Enabling Tracks Simultaneously” on page 572.)
DestructivePunch Enabling Tracks without Record Enabling Them

This method lets you use the Prepare DPE Tracks command to consolidate files for Destructive-Punch recording.

To DestructivePunch-enable an audio track:
- Control-click (Mac) or Start-click (Windows) the track’s Record Enable button to toggle the button to solid blue.

To DestructivePunch-enable all audio tracks:
- Option-Control-click (Mac) or Alt-Start-click (Windows) a track’s Record Enable button to toggle all Record Enable buttons to solid blue.

To DestructivePunch-enable all selected audio tracks:
- Control-Option-Shift-click (Mac) or Alt-Start-Shift-click (Windows) a track’s Record Enable button to toggle the Record Enable buttons for the selected audio tracks solid blue.

Create a VCA group for each stem or set of tracks on which you plan to punch, and use the VCA Record Enable button to arm all tracks in the group for DestructivePunch. For more information, see “VCA Master Tracks” on page 1047.

DestructivePunch-Enabling and Record-Enabling Tracks Simultaneously

This method can be used when tracks already meet the requirements for DestructivePunch recording.

To simultaneously DestructivePunch enable and record enable an audio track:
- Click the track’s Record Enable button. The track’s Record Enable button flashes blue and red.

To simultaneously DestructivePunch enable and record enable all audio tracks:
- Option-click (Mac) or Alt-click (Windows) a track’s Record Enable button. All tracks’ Record Enable buttons flash blue and red.

To simultaneously DestructivePunch enable and record enable all selected audio tracks:
- Option-Shift-click (Mac) or Alt-Shift-click (Windows) a track’s Record Enable button. The Record Enable buttons for the selected audio tracks flash blue and red.

Track Record Status Display

When Pro Tools is in DestructivePunch mode, each track’s Record Enable button indicates its DestructivePunch and record enable status as follows:
- When a track is both DestructivePunch-enabled and record-enabled, its Record Enable button flashes blue and red.
- When a track is DestructivePunch-enabled but not record-enabled, its Record Enable button lights solid blue.
- When a track is record-enabled only, its Record Enable button flashes red.
- While a track is recording (in any mode), its Record Enable button lights solid red.
Monitoring and Levels

To complete the setup for DestructivePunch:

1. Configure monitoring for record-enabled tracks by selecting a mode from the Track menu, as appropriate. Choices include:
   - Set Record Tracks to Auto Input
   - Set Record Tracks to Input Only

Selecting either monitoring mode only affects tracks that are record-enabled.

2. Start playback.

3. To compare levels of the input source with audio on disk, click the TrackInput button. When lit (green), the track is monitoring input. When unlit (gray), the track is monitoring from disk (see “Selecting Record Monitor Modes with TrackInput Monitoring” on page 512).

When you are satisfied with your levels, you are ready to start punch recording.

Using DestructivePunch

After you have configured Pro Tools, tracks, and levels, you can use DestructivePunch to record in several ways.

Punching In On Single Tracks

To punch in on single tracks:

1. Enable DestructivePunch mode (“Enabling DestructivePunch Mode” on page 570).

2. Control-click (Mac) or Start-click (Windows) the Record Enable button for each track you want to punch in, so that the track is DestructivePunch-enabled only. The track’s Record Enable button lights solid blue.

3. Click Record in the Transport to enter Record Ready mode. The Record Enable button flashes blue and red.

4. Click Play in the Transport to begin playback.

5. During playback, punch in and out on individual DestructivePunch-enabled tracks by clicking their Record Enable buttons.

6. Stop playback. When you are finished with the record pass, track Record Enable status and transport Record Arm status follow the current Audio Track RecordLock and Transport Record-Lock preference settings.

Punching In on Multiple Tracks

To punch in on multiple tracks simultaneously:

1. Enable DestructivePunch mode (“Enabling DestructivePunch Mode” on page 570).

2. Click the Record Enable button on each track you want to punch in, so that the track is both DestructivePunch-enabled and Record-enabled. Each track’s Record Enable button flashes blue and red.

3. Click Play in the Transport to begin playback.

4. During playback, click Record in the Transport to punch in and out on all DestructivePunch-enabled tracks simultaneously.

5. Stop playback. When you are finished with the record pass, track Record Enable status and transport Record Arm status follow the current Audio Track RecordLock and Transport Record-Lock preference settings.
Starting Recording Immediately on Multiple Tracks

To punch in on multiple tracks:

1 Enable DestructivePunch mode (“Enabling DestructivePunch Mode” on page 570).

2 Click the Record Enable button on each track you want to punch in, so that the track is both DestructivePunch-enabled and Record-enabled. Each track’s Record Enable button flashes blue and red.

3 Click Record in the Transport to enter Record Ready mode. The Record button flashes blue and red.

4 Click Play in the Transport to begin playback.

5 During playback, punch out and back in on individual DestructivePunch-enabled tracks by clicking their respective Record Enable buttons.

6 Stop playback. When you are finished with the record pass, track Record Enable status and transport Record Arm status follow the current Audio Track RecordLock and Transport RecordLock preference settings.

Example TrackPunch and DestructivePunch Workflows

TrackPunch and DestructivePunch let you use Pro Tools punch recording in many ways. For example, DestructivePunch lets Pro Tools be used as a digital dubber for film re-recording (dubbing) and mixing (see “Film Dubbing and Mixing” on page 574).

Keyboard shortcuts and preference settings for recording and input monitoring provide flexibility that makes TrackPunch or DestructivePunch equally useful for the following workflows commonly performed in film, video, and music production:

- Loading dailies (see “Loading Dailies Using RecordLock” on page 575)
- Recording Foley (see “Foley Recording” on page 576)
- Tracking and overdubbing in music production and any other recording situation (see “Tracking and Overdubbing Music” on page 576)

Tip: Throughout these examples, references to TrackPunch can also be applied to DestructivePunch (just remember that TrackPunch is nondestructive, while DestructivePunch is a destructive punch mode).

Because Pro Tools can be networked, TrackPunch (and all other) audio files and whole sessions can be available for secure transfer to other systems for review, editing, and archiving.

Film Dubbing and Mixing

Film dubbing and mixing features of TrackPunch and DestructivePunch let you do the following:

- Arm and punch Pro Tools audio tracks remotely from a master synchronizer such as SoundMaster through P2 commands, at any time, without having to stop playback and while maintaining timecode lock (requires MachineControl).
- Toggle Pro Tools audio tracks between input and disk monitoring.

Warning: Do not use any Native plug-ins on any tracks that are Record or TrackInput–enabled. You will hear an audible click as Native plug-ins on those tracks are automatically bypassed.

If you are not already familiar with routing, selecting, and grouping Pro Tools tracks, see Chapter 13, “Tracks” and Chapter 48, “Basic Mixing.”
• Use Pro Tools as the timecode master (generating) or when slaving.
• Punch non-destructively with TrackPunch, or destructively with DestructivePunch.

**A typical pre-dub session includes the following steps:**

1. Configure synchronization between Pro Tools and other devices as appropriate.
2. Choose Setup > Preferences and click the Operation tab.
3. Select (enable) Transport RecordLock. This keeps the Transport Record armed after the transport stops.
4. Deselect Audio Track RecordLock. This causes the audio track record to disarm when the transport stops.
5. Do one of the following:
   • Select Options > TrackPunch to enable TrackPunch mode for non-destructive punch recording.
   • Select Options > DestructivePunch to enable DestructivePunch recording.
6. Create 32 new tracks
7. Assign the track inputs.
8. Group the tracks into groups of eight.
9. Click the record enable buttons in the first eight tracks to TrackPunch enable the first eight tracks (or, the group for the first pre-dub).
10. Assign the console paddles to the first eight-track group in the session.
11. Begin the pre-dub pass. Use the console paddles to arm Pro Tools, and to punch in and out on the first group.
12. When the first pre-dub is over and all tracks are punched out, clear all TrackPunch or DestructivePunch enabled tracks.
13. Select the next group of tracks and TrackPunch- or DestructivePunch-enable them.
14. Punch in and out on the second group of tracks.
15. Repeat the preceding steps as necessary.

**Loading Dailies Using RecordLock**

Dailies and similar types of transfers are comprised of multiple takes or scenes, each recorded while locked to unique time-of-day timecode. In between each take, timecode does not continue but stops completely. Because of this, the timecode on dailies and similar source material is said to be “discontinuous” (also known as broken timecode).

By default, Pro Tools drops out of recording when it goes offline due to broken timecode. However, you can change this behavior so that Pro Tools will instead remain armed, waiting to begin recording again when lock is re-established with the timecode of the next take.

**To configure RecordLock for loading:**

1. Choose Setup > Preferences and click the Operation tab.
2. Enable Transport RecordLock.
3 Enable Audio Track RecordLock.

4 Configure synchronization and other settings as required.

5 Put Pro Tools online, and start the external source player.

6 Whenever timecode drops out or stops, Pro Tools remains online and waits to receive new timecode. The Transport and record-enabled tracks remain record-enabled. When timecode resumes, Pro Tools begins recording to a new audio file (properly time stamped based on the incoming code).

⚠️ Because Pro Tools has a 24-hour Timeline limit, you must use multiple sessions to load dailies if the span is more than 24 hours.

**Foley Recording**

Foley recording is one of the more specialized forms of recording in film production with unique monitoring requirements. Between punches and takes, inputs must be muted while Foley artists move themselves and equipment as they progress through a scene.

TrackInput monitoring can be configured to support Foley style TrackPunch recording using the Mute Record-Armed Tracks While Stopped preference.

**To configure Pro Tools for Foley-style punch record monitoring:**

1 Choose Setup > Preferences and click the Operation tab.

2 Enable Mute Record-Armed Tracks While Stopped.

3 Configure synchronization and other settings for Pro Tools and your other devices.

4 Enable TrackPunch or DestructivePunch mode and proceed with punch recording.

When recording online and Mute Record-Armed Tracks While Stopped is enabled, record-enabled tracks mute when the Transport is stopped. Input can still be monitored at any time by using the TrackInput switch.

**Tracking and Overdubbing Music**

Modern multitrack recording requires the flexibility to “capture the moment” by allowing on-the-fly record enabling and punch recording, as provided by TrackPunch. Features of TrackPunch for all tracking, overdubbing, and punching situations include the following:

- Record enable tracks while the transport is moving.
- Punch tracks in and out using on-screen Record Enable buttons, remotely from a synchronizer, from a control surface, or using a foot switch.
- Compare and match levels using TrackInput switching.

**“In-the-box” Dubbing (HDX Only)**

Pro Tools Ultimate software with HDX hardware lets you punch in and out of cascaded tracks. You can activate and deactivate recording or input monitoring on tracks in all punch modes (and in punch modes only): QuickPunch, TrackPunch, and DestructivePunch.

**Workflow example for configuring “in-the-box” dubbing:**

1 Using internal busses, route your source tracks, by stem (for example, dialog, music, and effects), to your record tracks (see Figure 1 on page 577).

2 Route your stem source tracks to your print master track (such as a 5.1 audio track).
3 When encoding an LTRT, also route your stem source tracks to a 5.1 Auxiliary Input track with an AAX DSP LTRT encoder plug-in; or, use a pre-fader send from the print master track for LTRT encoding. Note that only AAX DSP LTRT encoders are supported with this workflow.

4 Route the output of the LTRT encoded track to a stereo Auxiliary Input track for monitoring (stereo).

5 Route the LTRT Auxiliary Input track to a stereo audio track for recording.

6 Route the output of your LTRT-encoded stereo audio track to an Auxiliary Input track to monitor LTRT decoding (stereo to 5.1). Note that only AAX DSP LTRT decoders are supported with this workflow.

7 Cascade as many tracks as you want for punch recording.

8 Disable Auto Low Latency for all Record-enabled and InputMonitoring-enabled audio tracks (blue mode) by doing one of the following:
   - Right-click the Track Compensation indicator on the track and select Auto Low Latency Off.
   - Command-Control-click (Mac) or Control-Start-click (Windows) the Track Compensation indicator on the track.

9 Ensure that all plug-ins on tracks that are Record-enabled or InputMonitoring-enabled are AAX DSP plug-ins. Using AAX Native plug-ins will result in audible artifacts as they will be bypassed and unbypassed as you punch in and out.

10 Prepare your punch tracks and begin your punch-in and punch-out record pass.

---

**Figure 1. In-the-box punch recording workflow example with cascading tracks**
Part V: Editing
Chapter 27: Editing Basics

Use the Edit window in Pro Tools to edit and arrange audio, video, and MIDI. Track material can be edited nondestructively and in real time during playback.

The Edit window also lets you graphically edit other data, as follows:

**Editing Clips and Selections** See Chapter 30, “Editing Clips and Selections.” Also, see Chapter 40, “Arranging Clips.”

**Editing Fades and Crossfades** See Chapter 31, “Fades and Crossfades.”

**Editing Elastic Audio** See Chapter 44, “Elastic Audio.”

**Editing MIDI** See Chapter 34, “MIDI Editing.”

**Editing Automation** See Chapter 50, “Automation.”

**Editing Video** See Chapter 60, “Working with Video in Pro Tools.”

Nondestructive Editing

The vast majority of audio editing in Pro Tools is nondestructive. Whether cutting, pasting, trimming, separating, or clearing clips, you are only performing these functions on a map of the actual media (such as audio files). The source files remain untouched. However, certain processes or tools work destructively (can permanently change audio files on your hard disk), as noted in other topics.

While editing for MIDI tracks is in some instances destructive, with a few precautions you can keep important MIDI tracks and clips safe when performing edits (see “Nondestructive MIDI Editing” on page 590).

Editing During Playback

Pro Tools lets you perform many editing tasks while the session plays. This powerful capability lets you interactively modify and edit a session, hearing the changes as you make them.

💡 Use Loop and Dynamic Transport modes for auditioning and editing loops during playback. See “Playback Modes” on page 484.
Following are just a few examples of editing and arranging tasks that can be performed while playing back a Pro Tools session:

- Capture, separate, cut, copy, paste, and trim clips
- Place, spot, or rearrange clips
- Add fades or crossfades to audio clips
- Quantize MIDI notes and audio events
- Transpose and otherwise modify MIDI tracks
- Nudge audio or MIDI clips
- Audition different playlists
- Adjust or scale automation and MIDI continuous controller data
- Insert real-time plug-ins
- Apply Real-Time (and Rendered) Elastic Audio processing
- Process audio with an AudioSuite plug-in
- Automation editing

There are a few things that cannot be changed while Pro Tools plays, as noted in relevant topics.

**Track Material**

Each time you record or import audio, video, and MIDI, Pro Tools creates *clips* for the new track data, which not only indicate where the material begins and ends, but also provides visual feedback on its general character and content. When you record additional takes, or “punch in” on a specific location within a track, Pro Tools creates additional clips.

Clips are also created by cutting and pasting, resizing, separating, and re-capturing existing clips. Clips in a session are listed in the Clips List, where they can be dragged to existing tracks. A track can contain any number of clips, in any arrangement. The order and location of clips in a track define its *playlist*.

In addition to audio and MIDI clips, tracks provide automation playlists of any automation data (such as volume and pan). Automation can be recorded and edited in the Mix, Edit, and MIDI Editor windows (see Chapter 50, “Automation”).

**Clip Types**

There are different types of audio and MIDI clips, based on how they are created:

* For information on video clips, see Chapter 60, “Working with Video in Pro Tools.”

**Whole-File Audio Clips** These audio clips are created when recording or importing audio, consolidating existing clips, and when nondestructively processing with an AudioSuite plug-in. Whole-file audio clips reference an entire audio file that resides on your hard drive. Whole-file audio clips are displayed in bold in the Clips List (see Chapter 16, “The Clips List”). Normal clips often reference only a portion of the parent audio file and are created in the course of editing and, in some instances, when punch recording or loop recording.

**User-Defined Clips** These are clips that are explicitly defined, such as when you record or import audio or MIDI; capture, separate, or consolidate a selection; trim a whole-file audio clip; or rename an existing clip.

**Auto-Created Clips** These clips are automatically created in the course of editing, and, in some instances, when punch recording over existing clips. Since these clips can accumulate rapidly in a session, you can hide them in the Clips List. Auto-created clips can be turned into user-defined clips by renaming them.

* For more information, see “Naming and Displaying Clips in the Clips List” on page 296.
Offline Clips

Clips are offline when their parent files cannot be located, or are not available, when opening a session or importing a track. Offline clips appear in the Clips List as italicized and dimmed; they appear in playlists as light blue clips with italicized names. Offline clips can be edited like other clips, but they cannot be processed with AudioSuite plug-ins.

Multichannel Clips

These clips, which are displayed as a single clip in the Clips List, reference multiple clips and audio files for stereo and surround tracks. Multichannel clips can be expanded (by clicking the triangle next to their name) to see the individual channels, which can be dragged independently to tracks.

Clip Groups

A clip group is a collection of any combination of audio and MIDI clips that looks and acts like a single clip. Clip groups are essentially containers holding one or more clips. Clip groups can be created on a single track or on multiple adjacent audio, MIDI, and Instrument tracks. Clip groups let you “nest” multiple clips into “macro” clips for groove and tempo manipulation, editing, and arranging (see “Clip Groups” on page 919).

Warped Clips

Clips on Real-Time Elastic Audio-enabled tracks can be warped. Warped clips are identified with a Warp Indicator icon in the upper-right corner of clips on tracks and to the left of clip names in the Clips List. Warped clips result from the application of Elastic Audio processing. Elastic Audio processing can be applied manually in Warp view or using the TCE Trim Tool in Waveform view, or automatically using tempo conform, quantization, or transposition (see “Warped Clips” on page 984).

Audio Clips and Waveforms

When the Track View for audio tracks is set to Waveform, Pro Tools draws a waveform diagram of the audio. Audio waveforms tell you several things about the recorded sound.

Audio waveform of a drum track

In the figure above, the “peaks” represent places in the recording where the attack of the sound causes the volume to increase momentarily. These are followed by “valleys,” where the volume decreases.

Different types of sounds produce different types of waveforms. Drums, for example, generally produce waveforms with sharp transients (peaks of short duration) that are clearly defined. A drum hit has a loud, sharp attack and a rapid decay.

Other sounds, such as vocals or sustained synthesizer pads, produce very different waveforms. These sounds have less pronounced peaks and valleys because they generally have softer attacks and longer decays.
Waveform Views

Pro Tools provides several different Waveform View options. Depending on the editing task, you may want to display waveforms in any number of different ways.

Calculating Waveform Overviews

Waveforms can be calculated using Peak or Power overviews.

To set how the Waveform view is calculated:

- Choose View > Waveforms and select Peak or Power

Peak When selected, the waveform display is calculated based on the sample-by-sample peak level. Peak view is traditionally how Pro Tools calculates the waveform overview and can be used for normal or rectified views. Peak view clearly displays any clipping in the waveform.

Power When selected, the waveform display is calculated according to the Root Mean Square (RMS). Power view can be used for normal or rectified views. Power view is useful for better seeing the characteristics of the audio in the waveform representation when zoomed out beyond the sample level. For mastering applications in particular, it can be more revealing of the sonic characteristics of the audio than Peak view.

Rectified Waveforms

Rectified waveforms are displayed so that their positive and negative waveform excursions (the portions that fall above and below the center line) are summed together and viewed as a single positive-value signal. This view lets you see more waveform detail in normal or reduced track height views. It can be particularly useful when editing volume automation data, since it depicts waveform levels as starting at the bottom of the track. Rectified view is available in both Peak and Power views.
To show waveforms rectified (or normally):
- Select (or deselect) View > Waveforms > Rectified.

Outlined Waveforms

Outlined waveforms provide more visual definition of the waveform, especially when viewed from a distance. However, you may want to disable Outlines when you need to do precise, detailed editing in Peak waveform view. Outlines are not displayed when you are zoomed in to the sample level.

To show (or hide) waveform outlines:
- Select (or deselect) View > Waveforms > Outlines.

Overlapped Crossfades

Overlapped Crossfades view (View > Waveforms > Overlapped Crossfades) lets you see the waveforms for both the end of the first clip and the beginning of the second clip within a crossfade. Use this view option to help visually align crossfaded audio.
Guidelines for Editing Waveforms

With the Selector tool in the Edit window, you can select portions of audio waveforms and divide them into segments called clips, so that you can rearrange and manipulate them in tracks.

While editing musical material, try to create clips that let you maintain a consistent beat. If you always define clips so that they contain a whole number of beats, you will be able to string the clips together and maintain a smooth, steady rhythm.

It is sometimes useful to have a steady, well-defined reference waveform (such as a drum track or click track) as a guide when selecting and defining other clips. If you have played in time with the beat, it should be easier to create rhythmically accurate clips by referring to the reference waveform.

Some important rules to keep in mind when defining clips:

- Whenever possible, begin a clip precisely before a volume peak, and end it immediately before another volume peak.
- Whenever possible, make sure a clip starts and ends on exactly the same part of a beat.
- Use the following Pro Tools features to help you edit rhythmic material or audio with clear transients into precise clips:
  - Tab to Transients (see “Tabbing to Transients” on page 641.)
  - Editing to a Grid (see “Grid Mode” on page 601)
  - Beat Detective (see Chapter 33, “Beat Detective”)

Avoiding Clicks and Pops

If an edited clip begins or ends at a point of high amplitude, you may hear a click when Pro Tools plays from one clip to another. In order to avoid clicks or pops do any of the following:

- Make sure that the start and end points of your selection are as close as possible to the point where the amplitude of the waveform tapers down to meet the zero-crossing line (the center line of the track’s waveform display). If necessary, use the zooming tools in the Edit window (see “Zooming Options” on page 604) to display waveforms in greater detail.

- Apply a crossfade between clips where a click or pop occurs. See “Creating a Crossfade” on page 679 for details.
- With Pro Tools Ultimate, use the AutoFade feature to apply real-time fade-ins/outs to all clip boundaries that do not touch or overlap other clips. See “Using AutoFades” on page 680 for details.

Nondestructive Audio Editing

When editing an audio track’s playlist in Pro Tools, you are not actually cutting and moving pieces of sound as you would if you were cutting and splicing analog tape. Instead, Pro Tools creates a map of the audio file on your hard disk, which describes the order in which to play various portions of the audio.

When trimming audio clips with any of the Trim tools, or when editing the placement or order of clips within a track, you can use multiple playlists to easily return to a track’s previous state. For more information, see “Playlists” on page 691.
Audio Clips and Automation Data

Automation data for audio resides in tracks and not in the Clips List. This means that when you drag an audio clip from the Clips List to a new track, no automation data is placed in the track. However, if you drag an audio clip from an existing track (that contains automation data) to another track, the automation from the source track is placed in the destination track.

You can edit automation data by switching track views or by revealing the automation lanes under the track.

\[ For\ more\ information\ on\ automation,\ see\ \textit{Chapter 50, “Automation.”} \]

MIDI Clips and MIDI Data

The two most common Track Views you will use for MIDI and Instrument tracks are Notes and Clips:

- Use Clips view for arranging clips.
- Use Notes view for inserting and editing individual MIDI notes, and for working with and affecting groups of notes.

\[ For\ more\ information\ on\ setting\ Track\ View,\ see\ “Track\ Views”\ on\ page\ 236. \]

To toggle the Track View between Notes and Clips, click in the track you want to toggle and press Control+Minus (Mac) or Start+Minus (Windows) on the alphanumeric keyboard.

Clips View for MIDI and Instrument Tracks

MIDI and Instrument tracks can be viewed as Clips, which is similar to Waveform view for audio tracks. While a track’s notes are visible in Clips view, individual note editing is not available in this view. Instead, all editing occurs across a time range encompassing all track data, including continuous controller events, program changes, and System Exclusive events.

Use Clips view to define clips that represent song sections and clips, or to rearrange or assemble track material.

In Clips view, the vertical zoom is automatically scaled to fit the entire range of pitches of MIDI notes on a track.

\[ You\ can\ double-click\ a\ MIDI\ clip\ to\ open\ it\ in\ the\ MIDI\ Editor\ window.\ See\ \textit{Chapter 35, “MIDI Editors.”} \]

There are a few things to consider when selecting, copying and cutting, and trimming MIDI clips:

- When cutting or clearing a clip or clip group selection that includes a note’s start point, the entire note is removed. This is even the case when only a portion of the note (that includes its start point) is selected.
- When cutting or clearing a clip or clip group selection that includes a note’s end point (but not its start point), the note remains and overlaps the edge of the clip.
Similar rules also apply when MIDI clips or clip groups containing MIDI clips are trimmed with any of the Trim tools. If the MIDI clip’s start point is moved beyond a note’s start point, the note is removed. If the clip’s end point is trimmed so that a note’s start point is within the clip but its end point is not, the note remains and overlaps the edge of the clip.

When moving and placing MIDI clips with overlapping notes, the notes always move with the clips. When placing MIDI clips with overlapping notes next to or near another clip, the overlapping notes extend into the next clip on the track.

To separate MIDI notes, rather than leave them hanging, when separating, cutting or copying clips, make the Edit selection you want, switch to Notes view and use the Separate At Selection command, then switch back to Clips view and make the edit (separating, cutting, or copying).

**MIDI Clips Created on Barlines**

When recording MIDI, or when manually entering MIDI notes, the beginning and ending of resulting MIDI clips are constrained to bar boundaries. This facilitates arranging MIDI clips in a musically meaningful way, in whole bar lengths.

The beginning of a recorded MIDI clip always starts on the barline immediately before the first MIDI note (Note On) of the clip. Likewise, the MIDI clip ends on the barline immediately following the last note (Note Off) of the clip.

**MIDI Clips and Continuous Controller Events**

Continuous controller events reside in MIDI clips and not in tracks. This means that when dragging clips that contain controller data from either a track or the Clips List, the controller data is written to the destination track.

You can edit continuous controller events by switching track views or by revealing the controller lanes under the track.

For more information on editing MIDI controller data, see Chapter 34, “MIDI Editing.”

**MIDI Mute Automation**

Unlike continuous controller events, which represent nuances that are part of a MIDI performance, Mute in Pro Tools is an automation playlist that actually mutes the MIDI engine. Mute automation does not correspond to actual MIDI events and is therefore not exported when saving as a Standard MIDI File.
Notes View for MIDI and Instrument Tracks

When a MIDI or Instrument track’s Track View is set to Notes, MIDI notes are displayed in a “piano roll” format. Each note is displayed as a small rectangle with its vertical placement indicating pitch and its horizontal placement indicating location in time (and duration).

To the left of the MIDI or Instrument track’s playlist is a vertical mini-keyboard, complete with octave numbering, for pitch reference. You can click the mini-keyboard to play pitches using the track’s selected MIDI output. Arrows at the top and bottom of the mini-keyboard (not available in the smaller track heights) are used to scroll the Notes display up and down.

To scroll the Notes display up or down for a MIDI or Instrument track, do one of the following:

- Click either the up or down arrow of the mini-keyboard.

- With any of the Edit tools (such as the Time Grabber tool) selected, press Command+Option+Control (Mac) or Control+Alt+Start (Windows) and drag up or down on the mini-keyboard.

- If you have a mouse with a scroll wheel, move the cursor over the track and Command-Option-Control-scroll (Mac) or Control-Alt-Start-scroll (Windows) up or down to scroll the notes display up or down.

Using the Edit tools, notes can be inserted, deleted, transposed, trimmed, and moved. For more information, see “Manually Editing MIDI Notes” on page 752.

In Notes view, the pitch range of MIDI notes that can be displayed depends on the track height, and on the current zoom value. Any time a track’s notes do not fit within its current height, notes above or below the viewed area are displayed as single-pixel lines at the very top and bottom of the range.
Nondestructive MIDI Editing

While editing audio clips is usually nondestructive, this is generally not the case for MIDI clips. For instance, if a MIDI clip resides in just one track at a single location, editing for that clip is destructive. This means that altering the pitch, duration, or placement of notes in Notes view permanently alters the clip.

However, if the Mirror MIDI Editing option is disabled, when editing a MIDI clip that appears elsewhere in the session (either on the same track at another location or in a different playlist, or in another track), editing is nondestructive and creates a new auto-created clip. To go back to the previous material, drag the original clip from the Clips List, or return to a previously saved playlist.

One way to safely return to a track’s previous state is with playlists. Before you edit notes, trim clips, or rearrange the order of clips, make a duplicate of the track’s existing playlist and then edit the duplicate (see “Playlists” on page 691).

To apply edits to all instances of a MIDI clip, enable Mirrored MIDI Editing mode (see “Mirrored MIDI Editing” on page 747).

Naming Clips

You can rename clips to give them more descriptive names, or to simplify existing names. When renaming a clip that was auto-created during editing, the clip becomes a user-defined clip and is displayed in the Clips List even when auto-created clips are hidden.

For more information, see “Renaming Clips” on page 296.

To rename a clip on a track:

1. Do one of the following:
   - Select the clip you want to rename and then choose Clip > Rename.
   - With any of the Edit tools, Right-click the clip that you want to rename and select Rename from the pop-up menu.
   - Press Command+Shift+R (Mac) or Control+Shift+R (Windows).
   - With the Grabber tool, double-click the clip you want to rename. For MIDI clips, the Name Dialog option must be selected as the Double-Clicking a MIDI Clip Opens setting in the MIDI Preferences.

2. In the Name dialog, type a new name for the clip. If a whole-file audio clip was selected, specify whether to rename just the clip, or both the clip and the disk file.

3. Click OK to rename the clip.
Displaying Clip Names, Clip Times, and Other Data

Clip names and times can sometimes get in the way of editing audio waveforms and MIDI data. In these instances, you may want to disable their display. In other instances, such as arranging or spotting Foley, displaying clip names and times is extremely useful.

To enable or disable the display of clip names in playlists:
- Select or deselect View > Clip > Name.

To display clip times:
- From View > Clip, select one of the following options:
  - No Time Disables display of clip times.
  - Current Time Displays start and end times for clips.
  - Original Time Stamp Displays the Original Time Stamp for each clip. The Original Time Stamp is the original timecode location for the clip when it was first recorded or created.
  - User Time Stamp Displays the User Time Stamp for each clip. The User Time Stamp, which defaults to the Original Time Stamp, can be redefined with the Time Stamp command.

Displaying Clip Data on All Channels

For stereo and greater-than-stereo multichannel tracks, clip data can be shown on all channels.

To enable or disable the display of clip data on all channels:
- Select or deselect View > Clip > Display on All Channels.

Displaying Other Clip Information

You can also choose to display the following in clips:

Sync Points Can be displayed on clips in playlists. This is useful when visually spotting to timecode or in arranging in Grid mode. For more information, see “Sync Points” on page 905.

Processing State For clips that are processed with Elastic Audio, displays a Warp indicator in playlists and in the Clips List. See “Warped Clips” on page 984.

Channel Name and Scene And Take Information Can be displayed in clips in playlists and in the Clips List. This is useful for working with multichannel recordings and metadata made by field recorders. For detailed information on workflows for field recorders, see Chapter 59, “Working with Field Recorders in Pro Tools.”

Rating Can be displayed on clips in playlists. This is useful for arranging when working with multiple playlists and alternate takes. See “Rating Clips” on page 667.

Overlap Shadows When enabled, overlapping clips cast shadows over any partially overlapped clips. This is useful for arranging and when working with tick-based audio tracks. See “Tempo Changes and Tick-Based Audio Tracks” on page 849.

Transparency When enabled, this option shows transparent clip overlays when moving clips on the timeline. This can be useful for visually aligning clips over other clips when arranging. See “Arranging with Transparent Clip Overlays” on page 895.
**Overwrite Indicator** When Overwrite Indicator is enabled (View > Clip > Clip Overwrite Indicator), Pro Tools provides a visual indication that an off-screen clip is being fully overlapped by a larger clip that you are moving. The clip you are moving highlights red at the edge of the screen if a smaller off-screen clip is being overwritten. If the Send Fully Overlapped Clips to Available Playlist While Editing preference is enabled (Setup > Preferences > Editing), it highlights blue indicating that a smaller off-screen clip is being fully overlapped and moved to an alternate playlist.

**Copy/Move Indicators** When Copy/Move Indicators is enabled (View > Clip > Copy/Move Indicators), Pro Tools provides a visual indication of any clips being sent to an alternate playlist whether or not the track is in Playlist view. The indicator appears as a blue animated down arrow.

**Clip Gain Line** Shows the Clip Gain Line for all clips in the Edit window. The Clip Gain Line lets you edit the clip gain settings for any given clip using breakpoint editing, much like with track-based volume automation. See “Clip Gain Line” on page 592.

**Clip Gain Info** Shows the Clip Gain Fader icon at the beginning of the clip, in the lower left corner. If the clip uses static clip gain, the static Clip Gain value (−144 dB to +36.0 dB) for a clip is displayed to the right of the Clip Gain Fader icon. For a clip that has dynamic clip gain (using breakpoint gain settings), the Clip Gain value is not shown. For more information, see “Clip Effects Status View” on page 953.

**Clip Effects Status** When Clip Effects Status is enabled (View > Clip > Clip Effects Status), ø, EQ, and DYN are displayed in the upper right corner of the clip depending on which effects are being applied to the clip. ø is displayed when the phase is inverted. EQ is displayed when EQ or Filtering is applied to the clip. DYN is displayed when Dynamics processing or Input Gain is set to any value other than 0.0 dB. See “Clip Effects” on page 949.

**Multiple Undo**

Pro Tools can keep track of up to 32 of the last undoable operations, allowing you to return to a previous editing state.

The Undo operations in Pro Tools are stored in a queue, in the order in which they were invoked. When choosing Edit > Undo, the most recent operation is undone. If you choose Undo again, the next operation in the queue is undone. You can also choose Edit > Redo to redo an operation, which moves back through the Undo queue by one step.
When the number of operations in the Undo queue reaches the maximum specified level of Undo (set in the Editing Preferences page), performing another undoable operation will remove the oldest operation at the top of the queue.

To undo the last operation, do one of the following:
- Choose Edit > Undo.
- Press Command+Z (Mac) or Control+Z (Windows).

⚠️ If no actions are available to undo, the menu displays Can’t Undo.

To redo the last undone operation, do one of the following:
- Choose Edit > Redo.
- Press Shift+Command+Z (Mac) or Shift+Control+Z (Windows).

⚠️ If no actions are available to redo, the menu displays Can’t Redo.

Undo History Window

You can use the Undo History window to view the queue of the undoable and redoable operations and return to any previous state. The Undo History can show edit creation times, enabling you to revert to the state a session held at a particular time.

![Undo History Window](image)

To show (or hide) the Undo History window:
- Choose Window > Undo History.

To undo operations in the Undo History window:
- Click the operation (bold) in the list to undo.

All operations in the queue that were performed after the operation you select are also undone. In the Undo History window, undoable operations are shown in bold and redoable operations (operations that have already been undone) are shown in italics.

To redo operations in the Undo History window:
- Click the operation (italics) in the list to redo.

The operation you choose, as well as all the operations in the queue before it, are redone.

To toggle display of creation times in the Undo History window:
- Click the Options pop-up menu and choose Show Creation Times.

To undo all the operations in the Undo Queue:
- Click the Options pop-up menu and choose Undo All.

To redo all the operations in the Redo Queue:
- Click the Options pop-up menu and choose Redo All.

Clearing the Undo Queue

To manually clear the Undo Queue:
- Click the Options pop-up menu and choose Clear Undo Queue.
Other operations that clear the Undo Queue include:

- Deleting a track, or clearing a clip from the Clips List
- Selecting Select > Unused, or Select > Unused Audio Except Whole Files in the Clips List menu

When the number of operations in the Undo History reaches the maximum level of Undo, performing another undoable operation removes the oldest operation at the top of the Undo History queue. When the oldest operation is one operation away from being pushed out of the queue, it is shown in red.

**Levels of Undo and Memory**

Because Pro Tools needs to keep track of the playlists for all tracks that are edited, the use of multiple levels of Undo can be memory intensive. You can lower the Levels of Undo setting (Editing Preferences) in Pro Tools to reduce the amount of system memory (RAM) used by the Undo queue. If you have plenty of memory available for Pro Tools, you can use a higher Levels Of Undo setting.

> Use the Undo History window to view a queue of undo operations and return to a previous state.

**To set the Levels of Undo in Pro Tools:**

1. Choose Setup > Preferences and click the Editing tab.
2. Click in the Levels of Undo field and type a value between 1–64.
3. Click OK.

---

**Basic Editing Commands**

Pro Tools provides many standard edit commands (such as Cut, Copy, and Paste). Pro Tools also provides many specialized edit commands that are optimized for audio and MIDI production (such as Repeat Paste to Fill).

**Cut, Copy, Paste, and Clear**

Use the Cut, Copy, Paste, and Clear commands to rearrange and edit track material. Edits can operate on entire clips selected with the Time Grabber tool, or on track ranges selected with the Selector tool. Edits can also work across multiple tracks (see “Editing Across Multiple Tracks” on page 598).

💡 You can Cut, Copy, and Paste noncontiguous clips by selecting them with the Object Grabber tool.

**Track View and Edit Content**

When cutting or copying track material, the Track View determines the type of data placed on the Clipboard. When editing in a track’s Master View (Waveform view for audio tracks and Clips view for MIDI or Instrument tracks), selections can include all underlying automation and controller data (“Automation Follows Edit Option” on page 1134). Thus, cutting an audio clip can also cut any volume, pan, mute, send, continuous controller, or plug-in automation that is also on the track. This saves you from having to individually cut from each automation playlist on the track.
When selecting groups of MIDI notes in Notes view with any of the Grabber tools (by drawing a rectangle around them), only the note data is placed on the Clipboard. When selecting a time range of MIDI notes (in Notes view) with the Selector tool, all controller data in the track is selected (similar to selecting with the Selector tool for audio tracks in Waveform view).

When a track is displaying automation data or controller data, only that data is placed on the Clipboard. Also, whenever you cut or copy automation data, bounding breakpoints are created at each end of the selected area, in order to preserve the slope of the automation both inside and outside the selection.

If tracks are grouped, copying and pasting on any of the tracks affects each of the other tracks in the group. Tracks that are hidden—even if they are part of a group being edited—are not affected by edits.

The Shuffle Clips option affects how material is cut and pasted:
- When Shuffle Clips is enabled, the Cut command leaves no empty space, since the clips to the right of the cut slide over, closing the gap. Otherwise the Cut command leaves an empty space corresponding to the data removed from the track.
- When Shuffle Clips is enabled, pasted data causes all clips to slide over to make room for the pasted material. Otherwise, pasted data can overlap an adjacent clip.

New clips are often auto-created when performing edits. For instance, when clearing a selection from a clip, new clips are auto-created from the material residing outside of the selection.

**Cut and Copy Commands**

Use the Cut command to remove the selection from the track and place it on the Clipboard.

Use the Copy command to place a copy of the selection on the Clipboard so it can be pasted to another track, or to the same track at a different location, while leaving the original intact and in place.

**To cut or copy a selection or clip:**

1. If you want to constrain the selection to the current Grid value, enable Snap to Grid.
2. Set the Track View for the tracks you want to edit.
When displaying waveforms for audio tracks, or notes or clips for MIDI tracks, selections include underlying automation and controller data. If the track is displaying automation data, only the automation data is affected by the edits.

3 Make an Edit selection of the material you want to Cut or Copy.

For information on making Edit selections, see “Selecting Track Material” on page 631.

4 Do one of the following:
   • Choose Edit > Cut to remove the selection and place it on the Clipboard.
   • Choose Edit > Copy to place the selection on the Clipboard, without removing it.

If a portion of a clip was cut or copied, the material on the Clipboard appears as a new clip in the Clips List. If a portion of a clip was cut, new clips are auto-created from the material residing outside of the selection.

When Shuffle Clips is enabled, any subsequent clips slide over to fill any empty space.

Deleting Underlying Clip Data

When removing a clip or selection, you can choose to remove or keep the underlying clip data.

To delete a clip or selection along with the underlying clip data:
   • Choose Edit > Cut.

To delete a clip or selection without removing the underlying clip data:
   • Choose Edit > Clear.

Paste Command

Use the Paste command to place the contents of the Clipboard at the Edit insertion point, and overwrite any material already there.

To paste a selection or clip:

1 If you want to constrain the insertion point or the selection to the current Grid value, enable Snap to Grid.

2 Do one of the following:
   • With the Selector tool, click in a track at the point where you want to paste the material.
   • Use the Selector or Time Grabber tool to make a selection where the material will be placed.

   With the Grabber tool, Control-click (Mac) or Start-click (Windows) a clip to conform it to the current selection.

3 Choose Edit > Paste.

If pasting at an insertion point with Shuffle Clips enabled, material to the right of the paste point is shifted to the right. Otherwise, any material within the paste range is overwritten.

If pasting into a selection with Shuffle Clips enabled, the selection is replaced by the Clipboard’s contents with the adjacent material slid left or right as necessary. Otherwise, the selection is also replaced but with the surrounding material remaining unchanged.

When working with MIDI, you can merge the contents of the Clipboard with material in the destination track using Edit > Paste Special > Merge. For more information, see “Paste Special” on page 1159.
Clear Command

Use the Clear command to remove a selection from a track without placing it on the Clipboard.

To clear a selection or clip:

1 If you want to constrain the selection to the current Grid value, enable Snap to Grid.
2 Set the Track View for the tracks you want to edit.

When displaying waveforms for audio tracks, or notes or clips for MIDI tracks, selections include underlying automation and controller data. If the track is displaying automation data, only the automation data is affected by the edits.

3 Make an Edit selection.
4 Choose Edit > Clear to remove the selection.

If the Layered Editing option is disabled (Options > Layered Editing) and a portion of a clip was cleared, new clips are auto-created from the material residing outside of the selection. When Shuffle mode is enabled, any subsequent clips slide over to fill any empty space.

Special Cut, Copy, Paste, and Clear Commands

Use the four “special” Edit menu commands (Cut Special, Copy Special, Paste Special, and Clear Special) for cutting, copying, pasting, and clearing automation (volume, pan, mute, and plug-in automation) on audio, Auxiliary Input, Master Fader, VCA Master, and Instrument tracks. These commands can also be used for MIDI controller data on MIDI and Instrument tracks. There are also Cut Special, Copy Special, and Clear Special commands for cutting, copying, and clearing clip gain settings (see “Clip Gain” on page 941) and clip effects settings (see “Clip Effects” on page 949).

You cannot paste MIDI controller data to automation data nor automation to MIDI.

For more information, see “Cutting, Copying, and Pasting Automation” on page 1157.

The Repeat to Fill Selection command lets you automatically fill a selection with audio or MIDI clips or data without requiring that you manually duplicate the clips. To use Repeat to Fill Selection, Cut or Copy a clip, then make a selection and use the command to fill the selection. When pasting audio clips, you are prompted to specify a cross-fade to be used for the pasted clips.

If you fill an area that is an exact multiple of the copied clip size (for example, filling 16 bars with a 4-bar clip), the copied selection is pasted as many times as it takes to fill the selection. If you fill an area that is not an exact multiple of the copied clip size (for example, filling 15 seconds of a track with a 2-second clip of room noise), the remaining selection area is filled with an automatically trimmed version of the original selection.

⚠️ Non-automated plug-in parameters need to be the same between different instances of a plug-in, or the pasted automation can have unpredictable results.
To fill a selection with Repeat to Fill Selection:
1 Select the clip you want to copy.
2 Choose Edit > Copy.
3 Select the area you want to fill using the Selector tool and choose Edit > Paste Special > Repeat to Fill Selection.
4 Do one of the following:
   • If pasting audio clips to larger areas, the Batch Fades dialog opens. Configure the dialog to create crossfades between each pasted clip, then click OK.
   • If you do not want crossfades for the pasted audio, click Cancel in the Batch Fades dialog.

Editing Across Multiple Tracks

When working with data from multiple tracks, there are some important points to remember. For example, if any selected tracks are set to their master view (see “Master Views for Tracks” on page 240), edits affect not only audio and MIDI for the selected tracks, but all automation and controller data as well.

If all selected tracks are displayed as automation data, edits only affect the type of automation data displayed in each track. Furthermore, if track 1 displays Pan automation, track 2 displays Volume automation, and track 3 displays Mute automation, the Cut command cuts only pan data from track 1, volume data from track 2, and mute data from track 3.

For more information on selecting data on multiple tracks, see “Selecting Across Multiple Tracks” on page 638.

To copy all types of automation on all selected tracks when copying only automation or controller data:

- Choose Edit > Copy Special > All Automation.

To paste to multiple tracks:

1 Do one of the following:
   • Place the insertion point in each of the destination tracks by Shift-clicking in them.
   • Make a selection in one of the Timebase rulers.
2 Choose Edit > Paste.

When you paste multiple types of data, whatever data has been copied is pasted into the correct type of playlist. Automation data is pasted into the corresponding automation playlist. Audio or MIDI data is pasted into the audio or MIDI playlist. You do not need to set target tracks to the specific type of data being pasted for the paste to work correctly.

If all destination tracks in a multitrack paste are displayed as automation, the paste replaces any previous data on the target track without shuffling—regardless of whether Shuffle Clips is enabled.
Chapter 28: Edit Modes and Tools

Pro Tools provides four Edit modes and various Edit tools to help you successfully edit material.

**Edit Modes**

Pro Tools has four Edit modes: Shuffle, Spot, Slip, and Grid. Grid mode provides two modes of operation, Relative and Absolute, explained below. The Edit mode is selected by clicking the corresponding button in the upper left of the Edit window.

**Shuffle Mode**

In Shuffle mode, you can move, trim, delete, cut, or paste clips freely within a track or to other tracks, but their movement is constrained by other clips. That is, if you place several clips in a track, they automatically snap to each other. You can then “shuffle” their order, but you cannot separate them from each other and you cannot make them overlap as in Slip mode. However, if there is silence between existing clips, and the clips are shuffled, the silence is maintained, and not removed.

In Shuffle mode, adding another clip to the beginning of a track moves all subsequent clips to the right (later in time) by the length of the added clip.

When using any of the Trim tools in Shuffle mode, changing a clip’s start or end point automatically moves any subsequent clips as necessary. The placement and insertion of MIDI notes is not affected by Shuffle mode.

Press F1 to enable Shuffle mode.
Shuffle Lock

With certain workflows, it is important to exclude Shuffle mode in order to ensure that clips stay time-aligned while editing. Shuffle Lock prevents you from inadvertently entering Shuffle mode by disabling all key commands and control surface switches for Shuffle mode. You cannot invoke Shuffle Lock while in Shuffle mode.

To lock out Shuffle Mode:
- While in any Edit mode other than Shuffle mode, Command-click (Mac) or Control-click (Windows) the Shuffle button on-screen. A lock icon appears in the Shuffle button.

To unlock Shuffle Mode:
- Command-click (Mac) or Control-click (Windows) the locked Shuffle button on-screen.

Slip Mode

In Slip mode, clips can be moved freely within a track or to other tracks. In this mode, it is possible to place a clip so that there is space between it and other clips in a track. When the track is played back, this space is silent. It is also possible to move a clip so that it overlaps or completely covers another clip.

Use Slip mode when you want the Trim, Selector, Grabber, and Pencil tools to work without any restrictions to placement in time.

Press F2 to enable Slip mode.

To temporarily suspend Slip mode and switch to Grid mode while editing, Command-click (Mac) or Control-click (Windows) while making the edit.

Spot Mode

Use Spot mode to place clips at precise locations. In Spot mode you can specify a frame location (or a location based on any of the other time formats), capture an incoming Timecode address, or use a clip’s time stamps as reference points for spotting. This can be particularly useful when performing post production tasks around SMPTE frame locations.

When Spot mode is enabled, Pro Tools asks you to specify a destination location when a clip is dragged from the Clips List, a Workspace browser, Windows Explorer, or the Mac Finder.

Press F3 to enable Spot mode.
Grid Mode

In Grid mode, clips and MIDI notes that are moved, trimmed or inserted “snap” to the currently selected Grid value, or to precise increments on a user-definable time grid.

Press F4 to enable Grid mode.

Displaying Grid Lines

To show (or hide) the Grid lines in the Edit window or in a MIDI Editor window, do one of the following:

- Select (or deselect) the Grid button.

Absolute and Relative Grid

Grid mode can be applied in Absolute or Relative mode:

- In Absolute Grid mode, moving any clip (or selected MIDI data) snaps the clip start to Grid boundaries. If a clip’s start point falls between beats, and the Grid is set to 1/4 notes, dragging the clip will snap its start time to the nearest 1/4 note (the current absolute Grid value).

- In Relative Grid mode, clips (or selected MIDI data) can be moved by Grid (or Nudge) units. If a clip’s start point falls between beats and the Grid is set to a 1/4 note (assuming the 1/4 note gets the beat), dragging the clip will be constrained to 1/4 notes, preserving the clip’s relative position to the nearest beat. For more information on Relative Grid mode, see “Arranging Clips in Grid Mode” on page 901.

To select Absolute or Relative Grid mode:

- Click the Grid mode selector and choose Absolute or Relative.

Snap To Grid

Pro Tools lets you enable Snap To Grid while in Shuffle, Slip, or Spot mode. When in any of these modes with Snap To Grid also enabled, placing the Edit cursor and making Edit selections is constrained by the Grid, but any clip editing is also affected by the other selected Edit mode.
For example, in Shuffle mode, with Snap To Grid enabled, you can make a selection in a clip based on the Grid, cut the selection, and any clips to the right of the edit shuffle to the left.

**Shuffle mode with Snap To Grid enabled**

**To enable Snap To Grid while in another Edit mode:**
- Shift-click the Grid mode button.

  ![Press Shift+F4 to enable Snap To Grid while in another Edit mode.](image)

**To enable Shuffle, Slip, or Spot while in Grid mode:**
- Shift-click the Shuffle, Slip, or Spot mode button.

  ![Press F1+F4 to enable Snap To Grid and Shuffle mode; press F2+F4 to enable Snap To Grid and Slip mode; and press F3+F4 to enable Snap To Grid and Spot mode.](image)

**Configuring the Grid**

The actual Grid size, chosen from the Grid value selector can be based on a time value using the Main Time Scale; or, if the Follow Main Time Scale option is deselected, another time format can be used for the Grid size.

The Grid Value indicator and selector are located in the Edit window. Also, the Score Editor window and MIDI Editor windows each provide an independent Grid Value indicator and selector.

**Grid Value indicator and pop-up menu**

The current Grid value is also used for the Quantize to Grid command (see “Quantizing Clips to Grid” on page 663) and Separated Clip At Grid command (see “Separated Commands” on page 654).

**To increase the grid value incrementally:**
- Press Shift+Equal (=)

**To decrease the grid value incrementally:**
- Press Shift+Minus (–)

The Clips/Markers option in the Grid Value menu allows events to be placed freely (as in Slip mode), but they will snap to clip locations (start, end, and sync points), markers, and Edit selections when placed near them.

**MIDI notes inserted with the Pencil tool ignore the Clips/Markers option, and instead snap to the time value selected in the Grid Value selector.**
Grid Mode Lock

To ensure that you do not inadvertently change the Grid mode setting when using Edit mode keyboard shortcuts, you can enable Edit/Tool Mode Keyboard Lock.

To lock (or unlock) the selected Grid mode:
1. Click the Grid mode selector and choose Absolute or Relative.
2. Select (or deselect) Options > Edit/Tool Mode Keyboard Lock.

Edit Tools

Pro Tools provides the following Edit tools: the Zoomer, Trim, Selector, Grabber, Scrubber, and Pencil tools, and the multifunctional Smart Tool.

The Zoomer, Trim, Grabber, and Pencil tools have multiple modes, which you can select from a pop-up menu when you click the tool.

You can use F5 (Zoomer), F6 (Trim), F7 (Selector), and F8 (Grabber), F9 (Scrubber), and F10 (Pencil) to select and toggle through the modes for each tool.

Press the Escape key to toggle through the Edit tools.

Zoom Buttons Use the Zoom buttons to zoom in and out vertically and horizontally on MIDI and audio track material. You can also store and recall five Zoom presets.

Zoomer Tool Use the Zoomer tool to select a zoom view in a track.

Zoom Toggle Use the Zoom Toggle to switch between the current zoom view and a defined zoom view.

Trim Tools Use the Trim tools to trim clips and clip groups.

Selector Tool Use the Selector to make selections on tracks.

Grabber Tools Use the Grabber tools to select, separate, or move clips on tracks.

Smart Tool Use the Smart tool to Trim, Select, or Grab clips, or apply or adjust fades in tracks.

Scrubber Tool Use the Scrubber tool to scrub through track material.
**Pencil Tool** Use the Pencil tool to draw automation and MIDI data.

- For information on using the Edit tools in Notes view on MIDI and Instrument tracks, see Chapter 34, “MIDI Editing.”

- For information on using the Edit tools in Warp view and Analysis view on Elastic Audio-enabled tracks, see “Editing in Warp View” on page 979 and “Editing in Analysis View” on page 986.

**Zooming Options**

Zooming options in Pro Tools include Zoom buttons, the Zoomer tool, the Zoom Preset buttons, and the Zoom Toggle command.

**Zoom Buttons**

Pro Tools includes different Zoom buttons for zooming in and out on track data.

The Edit window, MIDI Editor windows, and the Score Editor window also provide Zoom buttons above and below the right vertical scroll bar (see “Edit Window Zoom Buttons” on page 192, “MIDI Editor Zoom Controls” on page 795, and “Score Editor Zoom Controls” on page 815.)

**Horizontal Zoom In and Out Buttons**

The Horizontal Zoom In and Out buttons let you zoom in and out horizontally on track data.

To zoom in horizontally for all tracks, do one of the following:
- Click the Horizontal Zoom In button.
- Drag on the Horizontal Zoom In button to zoom in continuously.
- Press Command+](Mac) or Control+](Windows).

To zoom out horizontally for all tracks, do one of the following:
- Click the Horizontal Zoom Out button.
- Drag on the Horizontal Zoom Out button to zoom out continuously.
- Press Command+[(Mac) or Control+[(Windows).

**Audio and MIDI Zoom In and Out Buttons**

The Audio and MIDI Zoom buttons let you zoom in and out vertically on audio and MIDI data respectively.

- Audio Vertical Zoom button
- MIDI Vertical Zoom button
MIDI Vertical Zoom only affects tracks in not in Clips view.

To zoom in vertically for all audio tracks, do one of the following:
- Click the Audio Zoom In button.
- Drag on the Audio Zoom In button to zoom continuously.
- Press Command+Option+] (Mac) or Control+Alt+] (Windows).

To zoom out vertically for all audio tracks, do one of the following:
- Click the Audio Zoom Out button.
- Click the Audio Vertical Zoom buttons.
- Press Command+Option+[ or Command+Option+] (Mac) or Control+Alt+[ or Control+Alt+] (Windows).

To zoom all audio vertically to show the default waveform height:
- Press Command+Option+Control+[ (Mac) or Control+Alt+Start+[ (Windows).

To zoom in vertically for all MIDI and Instrument tracks, do one of the following:
- Click the MIDI Zoom In button.
- Press Command+Shift+] (Mac) or Control+Alt+] (Windows).

To zoom out vertically for all MIDI and Instrument tracks, do one of the following:
- Click the MIDI Zoom Out button.
- Press Command+Shift+[ (Mac) or Control+Alt+[ (Windows).

To zoom MIDI vertically to show all notes (lowest to highest) in MIDI and Instrument tracks:
- Press Command+Control+Shift+[ (Mac) or Control+Start+Shift+[ (Windows).

To zoom in or out vertically for a single MIDI or Instrument track:
1. Make sure the Track View is not set to Clips.
2. Select the Zoomer tool.
3. Hold Control (Mac) or Start (Windows) and drag upwards to zoom in, or downward to zoom out.

Additional Zoom Key Commands

To return to the previous zoom level, do one of the following:
- Option-click (Mac) or Alt-click (Windows) any of the Horizontal, Audio, or MIDI Zoom buttons.
- Press Command+Option+E (Mac) or Control+Alt+E (Windows).

To zoom in horizontally on the Edit selection without affecting vertical zoom:
- Press Option+F (Mac) or Alt+F (Windows).

If the selection contains MIDI notes, the selected MIDI notes are vertically scrolled to show in tracks as necessary.

To zoom in horizontally on a selection without affecting vertical zoom or scrolling, do one of the following:
- Press Option+Control+F (Mac) Alt+Start+F (Windows).
- Press Command+Control+] (Mac) or Control+Start+] (Windows).
To zoom horizontally to show the entire session, do one of the following:

- Double-click the Zoomer tool in the toolbar.
- Press Option+A (Mac) or Alt+A (Windows).

Audio waveforms revert to the default vertical zoom; on tracks set to Notes view, MIDI notes zoom vertically to show all notes in the track (same as the vertical zoom in Clips view); and the Tempo Editor zooms vertically to show all tempo events.

To zoom horizontally to show the entire session without affecting vertical zoom or scrolling, do one of the following:

- Press Option+Control+A (Mac) or Alt+Start+A (Windows).
- Press Command+Control+[ (Mac) or Control+Start+[ (Windows).

To set horizontal zoom to “overview scale” (256 samples per pixel):

- Command-click (Mac) or Control-click (Windows) the Zoomer tool.

---

**Zoomer Tool**

Use the Zoomer tool to zoom in and out around a particular area within a track.

The Zoomer tool offers two modes:

**Normal Zoom** The Zoomer tool remains selected after zooming.

**Single Zoom** The previously selected Edit tool is automatically reselected after zooming.

Press the F5 key to select the Zoomer tool and toggle between Normal and Single Zoom modes.

---

**Normal Zoomer Tool**

To zoom around a certain point in a track:

1. Do one of the following:
   - Click the Zoomer tool pop-up menu and select Normal Zoom mode.

2. Click once with the Zoomer tool at a location within the track. All tracks are zoomed in by one level and the Edit window is centered around the zoomed location.

3. To zoom back to the previous level, Option-click (Mac) or Alt-click (Windows) with the Zoomer tool.

To zoom into a particular track area:

1. Do one of the following:
   - Click the Zoomer tool pop-up menu and select Normal Zoom mode.
   - Right-click on any track and select Tools > Zoomer Tools > Normal Zoom.

2. Do one of the following:
   - To zoom horizontally only, drag with the Zoomer tool in the track’s playlist.
   - To zoom horizontally and vertically, press Command (Mac) or Control (Windows) while dragging in the track’s playlist.
Single Zoom mode returns you to the previously selected tool after a zoom has been performed.

For example, when using the Smart Tool you can click the Single Zoomer tool, and once the Zoom operation has been performed, Pro Tools automatically switches back to the Smart Tool.

To use Single Zoom mode, do one of the following:

- Click the Zoomer tool pop-up menu and select Single Zoom mode.
- Right-click on any track and select Tools > Zoomer Tools > Single Zoom.
- Press the F5 key to toggle to Single Zoom mode.

Single Zoom is identified with an arrow to the right of the Zoomer icon.

Normal Zoom mode does not have the arrow.

Zooming in a Ruler

To zoom horizontally in a ruler:

1. Press Command+Control (Mac) or Control+Start (Windows) and move the cursor into the ruler area, so the Zoomer tool appears.

Zooming horizontally with Zoomer tool

The zoomed area fills the entire Edit window.
Continuous Zoom with the Zoomer Tool

Use the Zoomer tool to zoom in or out continuously.

To use continuous zoom on one track or a group of tracks:
1. Select the Zoomer tool.
2. Hold the Control (Mac) or Start key (Windows) and do one of the following:
   • Drag up to continuously zoom in vertically.
   • Drag down to continuously zoom out vertically.
   • Drag to the right to continuously zoom in horizontally.
   • Drag to the left to continuously zoom out horizontally.

For horizontal zoom, all tracks zoom together. Tracks will zoom in or out centered horizontally on the location where you click.

Vertical Zooming In or Out of All Audio Tracks Continuously

To vertically zoom in or out of all audio tracks using continuous zoom:
• Drag up or down on the Audio Zoom In or Out button.

To vertically zoom in or out of all MIDI and Instrument tracks that are set to Notes view using continuous zoom:
• Drag up or down on the MIDI Zoom In or Out button. Any waveform height offsets will be maintained.

To zoom horizontally and show the entire session or project, and to reset the audio waveform to show the default height, zoom MIDI to show all notes in a track, and zoom the Tempo Editor to show all tempo events, do one of the following:
• Double-click the Zoomer tool.
• Press Option+A (Mac) or Alt+A (Windows).

⚠️ This will also affect your MIDI note heights.

To reset the default audio waveform heights without affecting the horizontal zoom level or MIDI note heights, press Command+Option+Control+[] (Mac) or Control+Alt+Start+[] (Windows).

To vertically zoom in or out of all MIDI and Instrument tracks that are set to Notes view using continuous zoom:
• Drag up or down on the MIDI Zoom In or Out button. Any waveform height offsets will be maintained.

To only zoom horizontally to show the entire session without affecting vertical zoom or scrolling:
• Press Option+Control+A (Mac) or Alt+Start+A (Windows).

To set all audio track waveform heights to match the waveform height of the topmost audio track in the Edit window:
• Command-Shift-click (Mac) or Control-Shift-click (Windows) the Audio Zoom button. All waveform height offsets will be lost.

To set all MIDI and Instrument track note heights to match the note height of the topmost MIDI or Instrument track in the Edit window:
• Command-Shift-click (Mac) or Control-Shift-click (Windows) the MIDI Zoom button. All note height offsets will be lost.
Zoom Preset Buttons

Pro Tools lets you save up to five horizontal Edit window Zoom presets, which can be recalled by typing a number or by clicking a Zoom Preset button.

To store a view as a Zoom preset:

1. Use the Zoomer tool to configure the Track View.

2. Click and hold one of the Zoom Preset buttons (1–5) and choose Save Zoom Preset from the Zoom Preset pop-up menu. The preset button flashes momentarily, and any previously stored Zoom preset at that number is replaced.

To recall a saved Zoom preset, do one of the following:

- Click the appropriate Zoom Preset button (1–5).
- Click and hold the Zoom Preset button and choose Recall Zoom Preset from the Zoom Preset pop-up menu.

Zoom Toggle

Zoom Toggle lets you define and toggle between zoom states in the Edit window.

Zoom Toggle Parameters

The Zoom Toggle stores and recalls the following parameters:

- Vertical Zoom
- Horizontal Zoom
- Track Height
- Track View
- Grid setting

Zoom Toggle Preferences

The Zoom Toggle preferences determine how Zoom Toggle works. Adjust the Zoom Toggle preferences to fit your workflow.

To change the Zoom Toggle preferences:

1. Choose Setup > Preferences.

2. Click the Editing tab.

3. Change the Zoom Toggle settings and options.

Zoom Toggle preferences

If the 1–5 Number Keys Control Editing Preference is set to Zoom Presets, press Control+1–5 (Mac) or Start+1–5 (Windows) to recall the corresponding Zoom preset.
For MIDI Editing, set the Zoom Toggle preferences as follows: Vertical Zoom to Last Used, Horizontal Zoom to Last Used, Track View to Waveform/Notes, and Track Height to Fit to Window.

For audio editing, set the Zoom Toggle preferences as follows: Vertical Zoom to Selection, Horizontal Zoom to Selection, Track Height to Fit to Window, and Track View to No Change.

4 Click OK.

**Vertical Zoom**

**Selection** When selected, zoom toggling in zooms vertically to the current Edit Selection.

**Last Used** When selected, zoom toggling in zooms vertically to the last stored Zoom Toggle state for MIDI notes in Notes view only.

**Horizontal Zoom**

**Selection** When selected, zoom toggling in zooms horizontally to the current selection. This is especially useful for audio editing.

**Last Used** When selected, zoom toggling in zooms horizontally to the last stored Zoom Toggle state. This option can emulate a separate editor window. This is especially useful for editing MIDI notes.

**Remove Range Selection After Zooming In**

When the Remove Range Selection After Zooming In option is selected, the current Edit selection collapses into an insertion point after zoom toggling in.

**Track Height**

**Last Used** When selected, zoom toggling in changes all tracks containing an Edit Selection to the last used Track Height.

**Medium** When selected, zoom toggling in changes all tracks containing an Edit Selection to the Medium Track Height.

**Large** When selected, zoom toggling in changes all tracks containing an Edit Selection to the Large Track Height.

**Jumbo** When selected, zoom toggling in changes all tracks containing an Edit Selection to the Jumbo Track Height.

**Extreme** When selected, zoom toggling in changes all tracks containing an Edit Selection to the Extreme Track Height.

**Fit To Window** When selected, zoom toggling in changes the Track View to the last used Track View that was stored with Zoom Toggle.

**No Change** When selected, the track view does not change when zoom toggling in or out.
Separate Grid Settings When Zoomed In

When this option is selected, the Grid setting stored with Zoom toggle is recalled when zoom toggling in. When this option is deselected, the same (current) grid setting is used whether zoom toggling in or out.

Zoom Toggle Follows Edit Selection

When selected, this option ensures that zoom toggle automatically follows the current Edit selection. When disabled, changing the Edit selection has no affect on the currently toggled-in track.

Using Zoom Toggle

Depending on the Zoom Toggle preference settings, the Zoom Toggle button in the Edit window lets you define a zoom state and toggle between it and the current zoom state, or it zooms to the settings in the Zoom Toggle preferences. When Zoom Toggle is enabled, the Edit window displays the stored zoom state. Additionally, any changes made to the view while Zoom Toggle is enabled are also stored in the zoom state.

When Zoom Toggle is disabled, the Edit window reverts to the last zoom state.

To store a zoom state using Zoom Toggle:

1 Set the Zoom Toggle preferences.
2 Make an Edit selection.
3 Click the Zoom Toggle button. It lights to indicate that Zoom Toggle is enabled and Pro Tools zoom toggles in based on the settings of the Zoom Toggle preferences.

Zoom Toggle button in the Edit window

If Last Used is selected for any of the following, you can adjust the corresponding zoom, height, or view in the Edit window to update the stored zoom state:

- Vertical Zoom
- Horizontal Zoom
- Track Height
- Track View

In Commands Keyboard Focus mode (see “Keyboard Focus” on page 26), press the E key to enable or disable Zoom Toggle.

Press Option+Shift+E (Mac) or Alt+Shift+E (Windows) to cancel Zoom Toggle without reverting to the previous view.

To modify the stored Zoom Toggle state if Last Used is selected:

1 Make sure the Zoom Toggle button is lit (enabled).
2 Adjust the Track Height, Vertical Zoom, Track View, or the Grid depending on which preferences are set to Last Used. Changes are stored as the new Zoom Toggle state.
To clear the stored Zoom Toggle state:
1. Make sure the Zoom Toggle button is lit (enabled).
2. Option-click (Mac) or Alt-click (Windows) the Zoom Toggle button.

To use Zoom Toggle without changing playlist views:
1. Make a selection on one or more tracks.
2. Do one of the following:
   - Press Option+Control+E (Mac) or Alt+Start+E (Windows).
   - With Commands Keyboard Focus enabled (see “Keyboard Focus” on page 26), press Option+E (Mac) or Alt+E (Windows).

Auto-Toggle When Changing Selection

When Zoom Toggle is enabled, selecting a different range of material, or selecting material on a different track affects Zoom Toggle as follows:
- Changing the selection length does not re-zoom the window, the current zoom level is maintained.
- Changing the selection to a different track sets the toggle-in state for track height and view. However, horizontal zoom remains unchanged. When moving the selection from a toggled in track, the toggled out track height and view are restored.

⚠️ Auto-Toggle does not work for Edit selections across multiple tracks that are Zoom-toggled to Fit to Window.

Zooming with a Scroll Wheel

If you have a mouse with a scroll wheel, you can use the scroll wheel to zoom in and out of tracks, both vertically and horizontally.

To continuously zoom horizontally using a scroll wheel:
- Hold Option (Mac) or Alt (Windows) while turning the mouse scroll wheel.

To continuously zoom audio (vertical zoom) in the Edit window:
- Hold Option+Shift (Mac) or Alt+Shift (Windows) while turning the mouse scroll wheel.

To continuously zoom MIDI (vertical zoom) in the Edit window:
- Hold Option+Control (Mac) or Alt+Start (Windows) while turning the mouse scroll wheel.
To scroll the contents of the Edit window or Mix window horizontally:

1. Focus the window you want to scroll by clicking in it or bringing it forward.
2. Hold the Shift key while turning the mouse scroll wheel.

**Using the Trim Tools**

Trim tools provide clip, note, and data trimming functions. The following Trim tools are available:

- Trim tool; also called the Standard Trim tool
- Time Compression/Expansion Trim tool; also called the TCE Trim tool
- Scrub Trim tool (Pro Tools Ultimate Only)
- Loop Trim tool

The Standard and Scrub Trim tools are only constrained by the boundaries of the whole-audio file referenced by the clip. The TCE Trim tool is only constrained by the maximum TCE amount when using the TCE Trim tool.

The TCE, Scrub, and Loop Trim tools do not apply to fades.

**Trim Tool**

With the Trim tool, you can quickly shorten or expand a clip (up to the entire length of the source audio file). The first time you trim a clip, Pro Tools automatically adds it to the Clips List as a new clip (with a name derived from the original) in order to differentiate it from the original.

The Trim tool is a nondestructive tool and does not actually modify the original audio or MIDI data (when working on clips). To return to the length of the original clip, drag it from the Clips List, or resize the edited clip with the Trim tool to its original length.

Use of the Trim tool is affected by the current Edit mode: Shuffle, Slip, Spot, or Grid (see “Edit Modes” on page 599).

💡 The Trim tool can also be used to lengthen and shorten MIDI notes (see “Trimming Note Start and End Times” on page 756), and also to scale automation and controller data up or down. See “Drawing Automation” on page 1151.

**To trim a clip with the Trim tool:**

1. Select the Trim tool.
2. Do one of the following:
   - Click the Trim tool pop-up menu and select Standard.
   - Right-click on any track and select Tools > Trim Tools > Standard.
3. Move the cursor near the start or end of the clip, so the Trim Tool cursor appears.

To reverse the direction of the Trim tool, press Option (Mac) or Alt (Windows).
4 Do one of the following:
• If trimming the end, drag left to shorten the clip, right to lengthen.
• If trimming the start, drag right to shorten the clip, left to lengthen.

⚠️ When working with audio, you cannot trim past the boundaries of adjacent clips.

When trimming clips in a stereo or multichannel track, all channels are trimmed.

The standard Trim tool trims the edges of all selected clips (not just the one you click and trim).

Time Compression/Expansion Trim Tool

The Time Compression/Expansion Trim tool (TCE Trim) is a convenient tool for matching an audio clip to the length of another clip, a tempo grid, a video scene, or to practically any other reference point you want.

⚠️ The TCE Trim tool unloops and consolidates looped clips.

💡 You can match an Edit selection to the length of a Timeline selection by selecting Edit > TCE Edit To Timeline Selection command (see “TCE (Time Compression and Expansion) Edit To Timeline Selection” on page 666.

When using the TCE or Elastic trimmer, hold Control (Mac) or Start (Windows) to constrain the trim to the edge of adjacent clips.

Elastic Audio TCE Trim Tool

On Elastic Audio-enabled tracks, the TCE tool uses the track’s selected Elastic Audio plug-in (Real-Time or Rendered) to apply Real-Time or Rendered Elastic Audio processing. The resulting clip displays a Warp indicator to indicate Elastic Audio processing.

⚠️ For information on Elastic Audio plug-ins, see “Elastic Audio Plug-Ins” on page 975.
AudioSuite TCE Trim Tool

On audio tracks without Elastic Audio enabled, the Time Compression/Expansion Trim tool works by using the Time Compression/Expansion (TCE) AudioSuite plug-in selected in the Pro Tools Processing preferences to create a new audio file.

Time Compression/Expansion Plug-In Preferences

You can select which AudioSuite plug-in is used for trimming with the TCE Trim tool on non-Elastic Audio-enabled audio tracks.

To set the AudioSuite plug-in for use with the TCE Trim tool:

1. Choose Setup > Preferences.
2. Click the Processing tab.
3. From the TC/E Plug-In pop-up menu, select the AudioSuite plug-in to be used with the Time Compression/Expansion Trim tool.
4. From the Default Settings pop-up menu, select the plug-in setting best suited to the material you work with most (such as Stereo Mix Default).
5. Click OK.

For more information about AudioSuite plug-ins, see Chapter 42, “AudioSuite Processing.”

Using the TCE Trim Tool in Grid Mode

The TCE Trim tool can be used in Grid mode to match a clip to the tempo of a session or a section of a session. For example, you might import a one-bar drum loop with a tempo of 90 BPM into a session with a tempo of 120 BPM. In Grid mode, you can use this tool to simply and quickly “time compress” the drum loop to the length of one measure, with no noticeable to minimal loss of audio fidelity.

Trimming clips while in Relative Grid mode will trim the clips in grid increments while maintaining their relative offset (if any) from the grid.

To use the TCE Trim tool in Grid mode:

1. Set the Edit mode to Grid.
2. Do one of the following:
   - Click the Trim tool pop-up menu and select TCE.
   - Right-click on any track and select Tools > Trim Tools > TCE.
3. With the TCE Trim tool, drag the audio clip’s start or end point to compress or expand the clip to the Grid (for example, by quarter notes).
Using the TCE Trim Tool in Slip Mode

To use the TCE Trim tool in Slip mode:
1 Set the Edit mode to Slip.
2 Click the Trim tool pop-up menu and select TCE.
3 With the TCE Trim tool, drag the clip’s start or end point to compress or expand the clip freely.

Using the TCE Trim Tool in Spot Mode

In Spot mode, clicking with the TCE Trim tool in a clip opens the Spot dialog. You can specify the location you want the clip to start or end at, or the duration of the clip, and the clip is automatically compressed or expanded as specified.

To use the TCE Trim tool in Spot mode:
1 Set the Edit mode to Spot.
2 Click the Trim tool pop-up menu and select TCE.
3 Click the clip near its start or end point. The Spot dialog opens. Using any Time Scale, enter a new start or end time (or duration) for the clip, then click OK.

Scrub Trim Tool
(Pro Tools | Ultimate Software Only)

The Scrub Trim tool is a convenient tool for auditioning material (on up to two tracks) to find a trim point. You can drag in a track to hear the audio information, then trim at a specific location by releasing the mouse button.

This action creates a new clip. Note that the Scrub Trim tool changes into a “right trim” or “left trim” shape as it is placed over the right or left side of a clip. To reverse the direction of the Scrub Trim tool, press Option (Mac) or Alt (Windows) before you click the clip.

Scrub playback speed and direction vary with controller movement. Scrubbed audio is routed through the track signal path, so you hear any effects in the signal path.

To scrub trim a track:
1 Do one of the following:
• Click the Trim tool pop-up menu and select Scrub.
• Right-click on any track and select Tools > Trim Tools > Scrub.

The tool changes to a speaker with a bracket.
2 Drag within a track to the left or right. Audio from a scrubbed track is routed through the track signal path, including any DSP effects. When you locate the trim point, release the mouse button to trim the clip.

• To scrub trim two tracks, drag with the Scrub Trim tool between two adjacent tracks.
• To scrub with finer resolution (without having to zoom in), press Command (Mac) or Control (Windows) while scrubbing.
Loop Trim Tool

Use the Loop Trim tool to create or trim looped clips (see "Clip Looping" on page 915).

Creating Loops with the Loop Trim Tool

To create loop clips using the Loop Trim tool:

1. Do one of the following:
   • Click the Trim tool pop-up menu and select Loop.
   • Right-click on any track and select Tools > Trim Tools > Loop.

2. Position the cursor over the top half of an unlooped audio or MIDI clip, or clip group. The cursor changes to indicate that you can loop trim the clip. (Positioning the cursor over the bottom half of the clip results in the Standard Trim cursor.)

3. Do one of the following:
   • Click at the end of the clip, and drag left or right to the point you want the loop to stop.
   • Click at the beginning of the clip, and drag left or right to the point you want the loop to start.

Trimming Looped Clips

You can trim looped clips in two ways:

• Loop Trim a looped clip to change how long the clip is looped. For example, Loop Trim a looped clip from 2 bars to four bars. With a 1 bar clip, the number of loops changes from 2 to 4. Each loop iteration remains the same length, but the length of the entire looped clip changes.

• Trim the source clip (loop iteration) while keeping the overall loop length unchanged. The number of loop iterations within the looped clip changes accordingly. For example, trim a 2 bar loop iteration of a 4 bar looped clip to 1 bar. The 4 bar looped clip remains constant, but the number of loop iterations changes from 2 to 4. Each loop iteration’s length changes, but how long the clip is looped does not.
To Loop Trim a looped clip:

1. Select the Loop Trim tool.
2. Move the cursor over the top half of the looped clip (not over a Loop icon). The cursor indicates the Loop Trim tool.
3. Trim the looped clip.

The number of loops increases or decreases to fill the new length of the entire looped clip.

- Hold the Start key (Windows), or the Control key (Mac) while trimming to trim in loop iteration increments.

- Trimming a looped clip does not trim any underlying Fades.

To trim the source clip (loop iteration) of a looped clip:

1. Select the Loop Trim tool.
2. Move the cursor over a Loop icon in the looped clip, or anywhere along the bottom of the clip. The cursor indicates the Trim tool icon.
3. Trim the start or end of the loop iteration.

The number of trimmed loop iterations increases or decreases to fill the original length of the entire looped clip.
**Tandem Trimming**

Tandem trimming lets you trim the start and end of two adjacent clips in tandem as long as one clip overlaps the other. When the Tandem Trimming option is enabled, if the cursor is placed at the intersection of two such clips, the cursor updates to show two brackets and an arrow to show the direction of the tandem trim.

Tandem trimming can be used in conjunction with Loop trimming and Scrub trimming. However, TCE and Elastic trim do not support tandem trimming.

To enable (or disable) tandem trimming:
- Select (or deselect) Options > Tandem Trimming.

**Using the Selector Tool**

Use the Selector tool to place the edit cursor in a track or Timebase ruler, or to make Timeline selections or Edit selections on tracks.

**Placing the Edit Cursor**

To place the edit cursor with the Selector tool:

1. Select the Selector tool in the Edit window.
2. Click the location in a track or on a Timebase ruler.
Making an Edit Selection with the Selector Tool

To make an Edit selection with the Selector tool:
1. Select the Selector tool in the Edit window.
2. Do one of the following:
   - To make an Edit selection in a single track, drag in the track.
   - To make an Edit selection across multiple tracks, drag across the tracks.
   - If Link Timeline and Edit Selection is enabled, drag on the Timebase ruler to make an Edit selection across all tracks.

Making a Timeline Selection with the Selector Tool

To make a Timeline selection with the Selector tool:
1. Select the Selector tool in the Edit window.
2. Do one of the following:
   - Drag on a Timebase ruler.
   - If Link Timeline and Edit Selection is enabled, drag in a track.

Using the Grabber Tools

Use the Grabber tools to select, move, separate, and arrange clips on tracks. There are three modes for the Grabber tool: Time Grabber, Separation Grabber, and Object Grabber. For more information about arranging clips, also see Chapter 40, “Arranging Clips.”

Time Grabber Selects an entire clip on a track with a single click. For more information on selecting clips, see “Selecting Track Material” on page 631.

Separation Grabber Cuts and pastes an Edit selection from one location to another by dragging. For more information, see “Separation Grabber Tool” on page 655.
**Object Grabber** Lets you select multiple, noncontiguous clips. For more information, see “Object Selections” on page 633.

**Object Grabber tool**

To select one of the Grabber tools, do one of the following:

- Click the Grabber tool in the Edit window and select the Grabber tool from the pop-up menu.

- Right-click on any track and select the Grabber tool from Tools > Grabber Tools.

**Using the Smart Tool**

With the Smart Tool, you can instantly access the Selector, Grabber, and Trim tools, and you can also apply and adjust fades and crossfades. The position of the cursor in relation to a clip or note, or within an automation playlist, determines how the Smart Tool functions.

To select the Smart Tool, click its icon in the upper left of the Edit window, or press F6+F7 (or F7+F8) simultaneously.

**The Smart Tool in Waveform View (Audio) or Clips View (MIDI)**

The following capabilities are available with the Smart Tool when working with audio tracks in Waveform or Blocks view, or MIDI or Instrument tracks in Clips view:

- For the Selector tool, position the cursor over the middle of the clip, in the upper half of the clip.

- For the Grabber tool, position the cursor over the middle of a clip, in the lower half of the clip.

- For the Trim tool, position the cursor near the clip’s start or end point.

- For a fade-in or fade-out, position the cursor near an audio clip’s start or end point, near the top of the clip. Once the Fade cursor appears, drag into the clip to set the fade length. The fade is created automatically with the Default Fade Settings (in the Editing Preferences page).
For a crossfade, position the cursor between two adjacent audio clips, near the bottom of the clip. Once the Crossfade cursor appears drag left or right to set the crossfade length. The crossfade is created automatically with the Default Fade Settings (in the Editing Preferences page).

To adjust a fade-in, fade-out, or crossfade (if present), position the cursor over the fade in the vertical middle of the clip. Once the corresponding Fade or Crossfade cursor appears, drag to the left or right to adjust fade shape.

To temporarily switch the Smart Tool to the Scrubber, place the cursor over the clip so that the Selector tool is enabled, then press Control (Mac) or Start (Windows).

The Smart Tool in Warp View

The following capabilities are available with the Smart Tool when working with Elastic Audio-enabled audio tracks in Warp view, or MIDI or Instrument tracks in Clips view:

- For the Select tool, position the cursor over the middle of the clip, in the upper half of the clip.
- For the Grabber tool, position the cursor over the middle of a clip, in the lower half of the clip, but not over an Event marker or Warp marker.
- For Elastic Audio warping, position the cursor over an Event marker or a Warp marker, in the lower half of the clip (for more information on warping audio, see “Editing in Warp View” on page 979).
- For the Trim tool, position the cursor near the clip’s start or end point, in the upper half of the clip.

The Smart Tool in Notes View

The following capabilities are available with the Smart Tool when working with MIDI and Instrument tracks in Notes view in the Edit window and in MIDI Editor windows:

- For the Marquee Selector, position the cursor so it does not cover any notes.
- For the Grabber tool, position the cursor over the note, near its middle.
- For the Trim tool, position the cursor near the note start or end point.
For the Velocity Trim tool, position the cursor over the note and press Command (Mac) or Control (Windows).

The Smart Tool in Automation and Controller Views

The following capabilities are available with the Smart Tool when working in both automation and controller views:

- For the Selector tool, position the cursor anywhere in the bottom 75% of the playlist for the Selector tool. Drag with the Selector tool to select breakpoints.

- For Trim tools, position the cursor in the top 25% of the playlist for the Trim tool. Drag with the Trim tool to trim breakpoints. Press Command+Shift (Mac) or Control+Shift (Windows) while trimming for fine control.

- To add a breakpoint with the Smart Tool, press Command (Mac) or Control (Windows) to temporarily change the cursor from the trimmer to the insertion grabber. When this occurs, other command key behaviors such as a Grid toggle and High Resolution editing are superseded by the insertion operation.

- For Grabber tools, Command (Mac) or Control (Windows) for the Grabber tool, then click in on the automation line to create breakpoints.

- To edit existing breakpoints, move the cursor near a breakpoint for the Grabber tool.

- To vertically constrain Grabber tool movement, press Shift.

- To vertically constrain Grabber tool movement with fine control, press Command+Shift (Mac) or Control+Shift (Windows).

The Smart Tool with Stereo and Multichannel Tracks

When using the Smart Tool on stereo and multichannel tracks, individual channels cannot be independently edited. All edits affect all channels as a whole.

Tool switching for the Smart Tool in stereo and multichannel tracks is determined by the position within the entire track, and not within individual channels.

Using the Scrubber Tool

The Scrubber tool lets you “scrub” up to two tracks of audio in the Edit Window. Scrubbing is a technique that originated in tape editing, where the tape was rocked back and forth past the playhead at slower than normal speeds to find a particular location (usually for cutting and splicing).
While viewing an audio waveform in Pro Tools can be helpful in visually finding an edit point, sometimes a waveform display (because of its sonic characteristics) may not reveal the desired spot in the audio material. By scrubbing back and forth in Pro Tools, you can listen and locate an exact edit point.

When the Edit Insertion Follows Scrub/Shuttle option is enabled in the Operation Preferences page, the edit cursor automatically locates to the point where scrubbing stops.

When the Scrolling option is set to Continuous (Pro Tools Ultimate only) or Center Playhead (Pro Tools Ultimate only), clicking with the Scrubber in a track’s playlist centers the Edit window around that point, and moves the Playhead there. With these Scrolling Options, scrubbed material moves past the Playhead, which remains stationary and centered.

**To scrub a single audio track:**

1. Select the Scrubber tool.
2. Drag within the track: left for reverse or right for forward.

![Scrubbing an audio track with the Scrubber](image)

The distance and speed with which you drag (with either the mouse, or the scrub wheel on a control surface) determine the length and speed of the scrubbed audio. Audio from the scrubbed track is routed to its output, along with any effects assigned to the track.

The resolution for the Scrubber is dependent on the zoom factor for the scrubbed track.

💡 *You can temporarily switch the Selector tool to the Scrubber tool by Control-clicking (Mac) or Start-clicking (Windows). For finer resolution, Command-Control-click (Mac) or Control-Start-click (Windows).*

**To scrub multiple audio tracks, do one of the following:**

- With the Scrubber selected, drag between two adjacent tracks.

![Scrubbing between two audio tracks](image)

- Scrub within a selection that contains multiple tracks.

When scrubbing multiple tracks, only the first two tracks are heard.

⚠️ *The maximum number of channels scrubbed in Pro Tools is eight, which lets you scrub a 7.1 track, two stereo tracks (four channels), but not two 5.1 surround tracks (12 channels).*

**Scrub/Shuttle Mode**

When scrubbing normally, you can scrub at normal playback speeds or slower. Scrub/Shuttle mode, however, lets you scrub at several times normal speed, which is helpful in playing through large ranges and locating material.
To scrub in Shuttle mode (at several times normal speed):

1. Select the Scrubber tool.
2. While pressing Option (Mac) or Alt (Windows), drag within the track—left for reverse, right for forward. The Fast Forward and Rewind buttons in the Transport window engage.

The distance and speed dragged determine the speed for the scrubbed audio.

Shuttle Lock Mode

Shuttle Lock mode lets you use the numeric keypad to shuttle up to two tracks forward or backwards at specific speeds: 5 is normal speed, numbers from 6 up to 9 provide increasingly faster fast-forward speeds, and numbers from 4 down to 1 provide progressively faster rewind speeds (4 is the slowest rewind Shuttle Lock speed, 1 is the fastest). If multiple tracks are selected, only the first two tracks are shuttled.

To play one or two tracks with the shuttle lock:

1. With Pro Tools Ultimate, make sure the Operation preference for Numeric Keypad mode is not set to Shuttle (see “Operation Preferences” on page 108).
2. With the Selector tool, click in the track where you want playback to begin. To shuttle on two tracks, Shift-click in a second track.
3. Press the Control (Mac) or Start key (Windows) and a number on the numeric keypad: 0–9 (9 is fastest, 5 is normal speed, and 0 stops shuttling).

Once Shuttle Lock mode is initiated, Fast Forward and Rewind become highlighted in the Transport window.

4. Press additional keys to change the playback speed, or press Plus (+) or Minus (−) to switch the playback direction (plus for forward, minus for backward).

5. To stop playback, press Control+0 (Mac) or Start+0 (Windows).

To exit Shuttle Lock mode, do one of the following:

- Press Stop in the Transport window.
- Press the Spacebar.

Custom Shuttle Lock Speed

(Pro Tools | Ultimate Software Only)

Use the Custom Shuttle Lock Speed preference to customize the highest fast-forward Shuttle Lock speed (key 9) to better match your editing and auditioning needs.

To configure Custom Shuttle Lock Speed:

1. In Pro Tools, select Setup > Preferences and click the Operation tab.
2. Be sure that the Numeric Keypad mode is set to Transport or Classic (see “Operation Preferences” on page 108).
3. Enter a percentage for the Custom Shuttle Lock Speed setting. The range for this setting is 50–800%. You can use the Up and Down Arrow keys to increase or decrease the setting.
4. Click OK.

The Custom Shuttle Lock Speed setting is saved with your Pro Tools system preferences (not with the session).

To enable Custom Shuttle Lock Speed:

- Press Control+9 (Mac) on the numeric keypad or Start+9 (Windows).
Pro Tools offers another form of shuttling, different from that of Shuttle Lock mode. With the Numeric Keypad mode set to Shuttle, playback of the current Edit selection is triggered by pressing and holding the keys on the numeric keypad—playback stops once the keys are released. Various playback speeds are available in both forward and reverse. In this mode, pre- and post-roll are ignored.

**To shuttle with the Numeric Keypad mode set to Shuttle:**

1. Choose Setup > Preferences and click the Operation tab.
2. Set the Numeric Keypad mode to Shuttle and click OK.
3. With the Selector tool, click in the track where you want playback to begin. To shuttle on two tracks, Shift-click in a second track.
4. Hold any of the following keys (or key combinations) on the numeric keypad to trigger playback.

<table>
<thead>
<tr>
<th>Shuttle Speed</th>
<th>Rewind Key</th>
<th>Forward Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 X Speed</td>
<td>4</td>
<td>6</td>
</tr>
<tr>
<td>4 X Speed</td>
<td>7</td>
<td>9</td>
</tr>
<tr>
<td>1/4 X Speed</td>
<td>1</td>
<td>3</td>
</tr>
<tr>
<td>1/2 X Speed</td>
<td>4+5</td>
<td>5+6</td>
</tr>
<tr>
<td>2 X Speed</td>
<td>7+8</td>
<td>8+9</td>
</tr>
</tbody>
</table>

5. Press a different key to switch the playback direction or speed. Release to stop.

---

**Using the Pencil Tool**

The Pencil tool lets you draw several types of Pro Tools data:

- Audio waveforms (see “Waveform Repair with the Pencil Tool” on page 626)
- MIDI data (see “Using the Pencil Tool” on page 748)
- Tempo changes (see “Editing Tempo Events in the Tempo Editor” on page 851)
- Automation (see “Drawing Automation” on page 1151).

> When editing automation or MIDI control data with the Pencil tool, you can switch between the current Pencil Tool shape (such as Line) and Free Hand pencil editing using the Command key (Mac) or the Control key (Windows). When editing with the selected Pencil shape, the Pencil cursor angles to the left. When editing in Free Hand with the key modifier, the Pencil cursor angles to the right.

---

**Waveform Repair with the Pencil Tool**

On audio tracks, the Pencil tool lets you destructively “redraw” waveform data. This tool is most commonly used to repair a pop or click in an audio file. A pop or click appears as a sudden sharp spike in a waveform. This tool only becomes active when the Edit window is zoomed in to the sample level.
Although you can Undo a Pencil tool edit, it is recommended that you create a backup copy of the target audio before using the Pencil tool. You can do this by using the AudioSuite Duplicate plug-in.

⚠️ The Pencil tool is a destructive editing tool that permanently modifies the audio file on disk and should be used with caution.

For information about the AudioSuite Duplicate plug-in, see the Audio Plug-Ins Guide.

To destructively edit an audio waveform with the Pencil tool:

1. Locate the area you want to edit.
2. Using the Zoomer tool or the Zoom buttons, zoom down to the sample level so the waveform appears as a continuous thin line. Adjust the Track Height, as necessary, to edit the waveform with greater precision. You can also use vertical zoom for greater visual resolution.

💡 You can recall zoom levels with the Zoom Preset buttons (see “Zooming Options” on page 604), or with Memory Locations (see “Recalling Memory Locations” on page 885). The default setting for Zoom Preset 5 is at the sample level for Pencil editing.

3. Select the Pencil tool.

4. Carefully draw with the Pencil tool by dragging over the area of the waveform.

Do not over-edit or the results may be undesirable. However, you can use the Undo command to undo your previous edit.

Repairing a “pop” with the Pencil tool

The Pencil tool can independently edit different channels of a multichannel track.

Try to limit editing to smoothing over a very small problem area, and keep the “fixes” in character with the shape of the surrounding waveform.

Edit/Tool Mode Keyboard Lock

Enable Options > Edit/Tool Mode Keyboard Lock to lock the currently selected Edit Tools (Zoom, Trim, Grabber, and Pencil only) in place and prevent them from being inadvertently changed when using keyboard shortcuts. However, even when Edit/Tool Mode Keyboard Lock is enabled, Edit Tool types can still be changed using the mouse or by using the Right-click menu. You can also switch between tools (such as switching from the Grabber to the Trim) using keyboard shortcuts.

To lock (or unlock) the current Edit Tool modes:

1. Select the Edit Tool modes you want (such as the Standard Trim tool, Time Grabber tool, and the Free Hand Pencil tool).
2. Select (or deselect) Options > Edit/Tool Mode Keyboard Lock.
Chapter 29: Making Selections

Pro Tools provides many tools for selecting material in the Edit window.

Linking or Unlinking Timeline and Edit Selections

Pro Tools lets you link or unlink the Timeline and Edit selections.

When the Timeline and Edit selections are linked, selecting in a track’s playlist (making an Edit selection) also defines the play and record range (the Timeline selection).

Unlinking Timeline and Edit selections lets you make a selection within a track for editing purposes that is distinct from the selection in the Timeline (which determines the playback and recording range).

To link or unlink the Timeline and Edit selections, do one of the following:

- Select or deselect Options > Link Timeline and Edit Selection.
- In the Edit window, a MIDI Editor window, or the Score Editor window, click the Link Timeline and Edit Selection button so it becomes highlighted (selected) or unhighlighted (not selected). Enabling or disabling the Link Timeline and Edit Selection button in any editor window affects all editor windows.

Press Shift+Forward Slash (/) to toggle Link Timeline and Edit Selection on and off.
If you are working on a film or video scene, you may want to unlink the Timeline and Edit selections to find or audition material that is at a different location than the current Timeline selection. Edit selections can be played (choose Edit > Selection > Play Edit) without disrupting the current Timeline selection. Once you find the material, you can then go back to the Timeline selection and place it within the context of the scene.

The following figure illustrates another reason why you might want to unlink the Timeline and Edit selections. In this example, the Timeline selection sets a range to be looped on playback, while a MIDI clip (residing within the loop) is selected for editing purposes.

During playback, the Edit selection can be nudged, quantized, or transposed while the loop plays back completely independent and uninterrupted.

Timeline and Edit Selection Markers

Timeline selections are displayed in the Main Timebase ruler with Timeline Selection Markers, which appear as blue arrows (red when recording). In addition, there are Pre- and Post-Roll Flags (which are green when enabled) indicating the location for pre- and post-roll.

![Timeline Selection Markers with Pre- and Post-Roll Flags](image)

When the Timeline and Edit selections are unlinked, Edit selections are displayed in the ruler with Edit Markers, which appear as black brackets.

![Edit Markers](image)

If the Timeline and Edit selections are linked, Edit selections are represented by the blue Timeline Selection Markers.

See the following topics for more information on working with Timeline and Edit selections:

- “Selecting Track Material” on page 631
- “Timeline Selections” on page 642
- “Setting Punch and Loop Points” on page 520
- “Setting Pre- and Post-Roll” on page 523
Linking or Unlinking Track and Edit Selections

Pro Tools lets you link or unlink Track selection with Edit selections.

When Track and Edit selections are linked, you can make a selection within a track or across multiple tracks for editing and each associated track is selected (track names automatically highlight). This lets you quickly apply track-level commands (such as Track View toggle, change track heights) and have the command apply to all tracks you are working on.

When Track and Edit selections are unlinked, making an Edit selection does not automatically select all associated tracks.

To link or unlink Track and Edit selection, do one of the following:

- Select or deselect Options > Link Track and Edit Selection.
- In the upper left of the Edit window, under the Edit tools, click the Link Track and Edit Selection button so it becomes highlighted (selected) or unhighlighted (not selected).

Selecting Track Material

Before audio and MIDI material can be edited, it must first be selected. The Track View determines how the material is viewed and selected.

When you make a selection, it appears as a highlighted area of the tracks, and is also indicated by blue start and end arrows (Timeline Selection Markers) in the Main Timebase ruler. If any track (audio or MIDI) in the session is record-enabled, even if it is hidden, these markers appear red.

If the Timeline and Edit selections are unlinked, the Edit selection range is indicated by Edit Markers in the Main Timebase ruler. See “Linking or Unlinking Timeline and Edit Selections” on page 629 for details.

Selections and Edit Groups

When making selections on tracks that are part of an Edit Group, all tracks within the group become selected.

Selections and Hidden Tracks

When editing tracks that are part of an active Edit Group, any tracks within the group that are hidden are not affected by the edits. To edit all members of a group, make sure they are visible by highlighting their names in the Tracks List.
Selections in Multiple Tracks

To make a selection in multiple tracks:
- With the Selector tool, drag vertically to include adjacent tracks in a selection (drag horizontally to define the time range).

Selecting Clips

To select a portion of a clip:
- With the Selector tool, drag within a clip (left or right) to select the material on a single track. (You can also use the Selector tool across multiple, adjacent tracks to make multitrack selections.)

![Selecting a portion of a clip](image)

To select an entire clip, do one of the following:
- Click the clip with the Time Grabber tool.
- Double-click the clip with the Selector tool.

To select two clips and the time range between them:
1. With the Time Grabber, click the first clip.
2. Shift-click the second clip. Both clips are selected, along with the time range between them (including any other clips).

To select an entire track, do one of the following:
- Click in the track with the Selector tool and then choose Edit > Select All.
- Triple-click with the Selector tool in the track.

> Press Command+A (Mac) or Control+A (Windows) for Select All.

To select all clips in all tracks:
1. Select the “All” Edit Group in the Groups List menu.
2. Do one of the following:
   - Click in any track with the Selector tool and choose Edit > Select All.
   - Triple-click with the Selector tool in any track.

> Another way to select all clips in all tracks, without having to select the “All” Edit Group, is to press Return (Mac) or Enter (Windows), then press Command+A (Mac) or Control+A (Windows). The Link Timeline and Edit Selection option must be enabled.

Clips List Selection Follows Edit Selection

When the Editing preference for Clips List Selection Follows Edit Selection is enabled, selecting a clip in a track also causes the clip to become selected in the Clips List.

Conversely, if the Editing preference for Edit Selection Follows Clips List Selection is enabled, selecting a clip in the Clips List causes the initial occurrence of that clip to become selected within the track.
Selecting All from Timebase Rulers

To select all material in all displayed audio and MIDI tracks:

1. Enable Link Timeline and Edit Selection (Options > Link Timeline and Edit Selection).
2. Double-click in any Timebase ruler. All clips in all displayed audio and MIDI tracks are selected. Tracks that are hidden are not selected.

To select all material in all tracks, including Conductor events:

1. Enable Link Timeline and Edit Selection (Options > Link Timeline and Edit Selection).
2. While pressing Option (Mac) or Control (Windows), double-click in any Timebase ruler. All clips in all displayed audio and MIDI tracks are selected, including all events in each of the Conductor tracks.

Making Selections While Playing

Pro Tools lets you make selections during playback with the Up and Down Arrow keys.

To make a selection while playing:

1. Enable Link Timeline and Edit Selection (Options > Link Timeline and Edit Selection).
2. With the Selector tool, click somewhere near the beginning of the track in which you want to make the selection.
3. Click Play in the Transport window (or press the Spacebar) to begin playback.
4. When playback reaches the point where you want the selection to begin, press the Down Arrow key.
5. Press the Up Arrow key at the point where you want the selection to end. The selected range becomes highlighted.
6. To stop playback, click Stop in the Transport (or press the Spacebar).

To automatically scroll to the beginning of the selection (or to the location of the on-screen cursor), press the Left Arrow key. To scroll to the end of the selection, press the Right Arrow key.

While in Page Scroll or Continuous Scroll mode, making a selection in the Timeline or a playlist during playback as the playback cursor moves off-screen suspends page scrolling. To resume page scrolling and jump to the current playback location, click the Playback Cursor locator in the Main Timebase ruler (see “Locating the Playback Cursor when It Is Off-Screen” on page 476).

Object Selections

Use the Object Grabber tool to select noncontiguous clips on one or more tracks. Noncontiguous selections must encompass entire clips. If you want a noncontiguous selection to include a portion of a clip, first turn the portion into a new clip with the Separate Clip command (see “Separate Commands” on page 654).

⚠️ The Object Grabber is not available when the Edit mode is set to Shuffle or Spot.

To select noncontiguous clips:

1. Set the Edit mode to either Slip or Grid.
2. Click the Grabber tools pop-up menu and select Object.
3 Shift-click each clip you want to include in the selection. The clips can even reside on different tracks.

Each clicked clip is surrounded by a dark border, indicating it is selected.

The Object Grabber tool ignores Edit Groups when making selections. For instance, selecting a clip on a grouped track does not cause clips in the other tracks in the group to become selected.

**Object to Time Selection**

You can convert between Time- and Object-based selections. Time selections are made with the Selector and Time Grabber tools. Object selections are made with the Object Grabber tool.

Converting to an Object selection is useful when you are working with large selections, especially across multiple tracks, and you want to remove certain clips from the selection.

Converting to a Time selection is useful if you want to select all clips between a noncontiguous Object selection.

**To change a Time selection to an Object selection:**

1 Drag with the Selector tool in any track to define a selection, or select in a Timebase ruler to select across all tracks.

2 With the Object Grabber tool selected, double-click the Grabber icon in the toolbar. Clips falling within the selection range become selected as objects. Clips that were partially selected become deselected.

To select clips that were partially selected, press Control (Mac) or Start (Windows) while double-clicking the Grabber icon.

**To change an Object selection to a Time selection:**

1 Select any number of clips with the Object Grabber tool.

2 Double-click the Selector tool in the toolbar. The time range between the first and last clip becomes selected.

When using the Object Grabber tool on tracks that belong to an Edit Group, clips in the other grouped tracks are selected if they fall within the range of the selected clip.
**Changing a Selection Length**

The selection range can be shortened or lengthened. This does not affect the material within the selection.

**To change the length of a selection, do one of the following:**

- With the Selector tool, position the cursor over one end of the current selection and Shift-click, or Shift-drag left or right.
- In the Main Timebase ruler, drag the Timeline Selection Marker for the selection’s start or end point.

**Nudging a Selection Range**

The selection range (not the material within the selection) can be moved by the Nudge value.

**To nudge a selection range:**

1. Configure the Nudge value. For details, see “Defining the Nudge Value” on page 660.
2. Make the initial selection with the Selector tool.
3. While pressing Shift, press Plus (+) or Minus (–) on the numeric keypad to move the selection range by the Nudge value.

**Nudging Selection Start/End Points**

Start and end points for selections can be moved by nudging them.

**To move a selection start or end point by the Nudge value:**

1. Configure the Nudge value. For details, see “Defining the Nudge Value” on page 660.
2. Make the initial selection with the Selector tool.
3. Do one of the following:
   - While pressing Option+Shift (Mac) or Alt+Shift (Windows), press Plus (+) or Minus (–) on the numeric keypad to move the selection’s start point by the Nudge value.
   - While pressing Command+Shift (Mac) or Control+Shift (Windows), press Plus (+) or Minus (–) on the numeric keypad to move the selection’s end point by the Nudge value.

**Dragging a Timeline Selection Marker**

**Edit Markers**

**To make a long-length selection:**

1. With the Selector tool, click at where you want the selection to start.
2. Scroll to the end point and Shift-click at the point where you want the selection to end.

To verify the start and end points of a long selection, press the Left Arrow key to scroll to the beginning of the selection, or press the Right Arrow key to scroll to the end.
Extending Selections in Time

You can extend the Edit selection to clip start and end points, to include an adjacent clip, to Markers and Memory Locations (Edit and/or Timeline selections).

To extend the selection to a clip start or end point:

1. With the Selector tool, select a portion of a clip, or click anywhere in the clip.
2. Do one of the following:
   - Press Shift+Tab to extend the selection to the clip’s end point.
   - Press Option+Shift+Tab (Mac) or Control+Shift+Tab (Windows) to extend the selection to the clip’s start point.

To extend the selection to include an adjacent clip:

1. Select the first clip with the Time Grabber tool.
2. Do one of the following:
   - With Tab to Transients disabled, press Control+Shift+Tab (Mac) or Start+Shift+Tab (Windows) to extend the selection to the next clip boundary.
   - Press Option+Control+Shift+Tab (Mac) or Control+Start+Shift+Tab (Windows) to extend the selection to include the previous clip boundary.

To extend the selection to a Marker or Memory Location:

1. With Link Timeline and Edit Selection enabled, do one of the following:
   - Click in a track with the Selector tool at the start or end point.
   - Make a selection with the Selector or Time Grabber tool.
2. Do one of the following:
   - Shift-click a Marker in the Markers ruler.
   - Shift-click a Memory Location in the Memory Locations window.

The selection is extended from the original Insertion point to the Marker or Memory Location.

Doubling or Halving the Edit Selection

Pro Tools lets you double or halve the current Edit selection. This can be especially useful for music production when working with audio loops and MIDI in Grid mode.

To double the Edit selection, do one of the following:

- Choose Edit > Selection > Double Selection.
- Press Command+Option+Control+Shift+’ (Mac) or Control+Alt+Start+Shift+’ (Windows).

To halve the Edit selection, do one of the following:

- Choose Edit > Selection > Halve Selection.
- Press Command+Option+Control+Shift+L (Mac) or Control+Alt+Start+Shift+L (Windows).
Duplicating and Extending the Edit Selection

Pro Tools lets you Duplicate and Extend the Edit selection. This can be especially useful for music production when working with audio loops and MIDI in Grid mode.

To duplicate and extend the Edit selection, do one of the following:

- Choose Edit > Selection > Duplicate and Extend Selection.
- Press Command+Option+Control+Shift+D (Mac) or Control+Alt+Start+Shift+D (Windows).

Any track content in the Edit selection is duplicated and the selection extends from the original start time to the end of the duplicate.

Moving the Edit Selection in Time

Pro Tools lets you move the Edit selection earlier or later by the selection amount. You can also move the Edit selection to the next track above or below the current Edit selection.

To move the Edit selection earlier by the selection amount, do one of the following:

- Choose Edit > Selection > Move Edit Left.
- Press Command+Option+Control+L (Mac) or Control+Alt+Start+L (Windows).

To move the Edit selection later by the selection amount, do one of the following:

- Choose Edit > Selection > Move Edit Right.
- Press Command+Option+Control+' (Mac) or Control+Alt+Start+' (Windows).

Using the Edit Selection Indicators (Start, End, and Length)

The Edit Selection indicators at the top of the Edit window can define precise Edit selections. Time values for the Edit Selection indicators use the time format for the Main Time Scale.

To make a selection with the Edit Selection indicators:

1. Click with the Selector tool in the track you want to select.
2. Click in the Start field at the top of the Edit window.
3. Type in the start point for the selection and press the Forward Slash key (/) to enter the value and automatically move to the end field.
4. Type in the end point for the selection and press Enter to accept the value.

Numeric Entry Shortcuts for Selection Indicators

You can use the following shortcuts for entering values in the Edit Selection indicators:

- Press the Forward Slash (/) key to cycle through the three Edit Selection indicators.
- Use Period (.) or the Left and Right Arrow keys to move through the different time fields in each Edit Selection indicator.
- Press the Up or Down Arrow keys to increase or decrease numerical values.
- Move the mouse scroll wheel up or down to increase or decrease numerical values.
• Drag in a field to scroll to a new value. For finer resolution, Command-drag (Mac) or Control-drag (Windows).

• Press Command (Mac) or Control (Windows) and Plus (+) or Minus (–), then type a number, to add or subtract from the current field value. For example, to add 10 to a current field value, press Command (Mac) or Control (Windows) and Plus (+) key, type “10,” and press Enter.

• Press Escape to exit the Edit Selection indicators without entering any values.

These shortcuts can also be used to enter start and end values in the Transport window.

Calculator Entry Mode

You can perform calculator-style editing of values in the Edit Selection indicators.

To subtract time values:
1 In the Edit Selection indicator, highlight the time field you want to change.
2 Press Minus (–) on the numeric keypad.
3 Type the amount you want to subtract from the current time value, then press Enter.
4 Press Enter again to apply the change.

To add time values:
1 In the Edit Selection indicator, highlight the time field you want to change.
2 Press Plus (+) on the numeric keypad.
3 Type the amount you want to add to the current time value, then press Enter.
4 Press Enter again to apply the change.

Selecting Across Multiple Tracks

To perform edits across multiple tracks or all tracks, you must first select the tracks. Do this by including other tracks in the selection, or by selecting in a Timebase ruler (for all tracks).

To make a selection in multiple tracks:
- With the Selector tool, drag vertically to include adjacent tracks in a selection (drag horizontally to define the time range).

To extend a selection to another track:
1 Using the Selector or Time Grabber tool, make a selection in the first track or tracks.
2 Shift-click in additional tracks with the Selector tool. An identical range is selected for each additional track.

To shorten or lengthen the selection across each of the tracks, press Shift while dragging to change the range of the selection.

To select across all tracks, do one of the following:
- Enable the All Edit Group and make a selection in any track.
- Drag with the Selector tool in any Timebase ruler (make sure the Timeline and Edit Selections are linked).

These selections include all tracks in the Edit window, but do not include the Conductor tracks (for Tempo, Meter, and Markers).

To select across all tracks, including the Conductor tracks (for Tempo, Meter, and Markers):
- Option-drag (Mac) or Alt-drag (Windows) with the Selector tool in any Timebase ruler.
Moving the Edit Selection Across Tracks

To move the Edit selection to the next track above the current selection, do one of the following:
- Choose Edit > Selection > Move Edit Up.
- Press Control+P (Mac) or Start+P (Windows).

To move the Edit selection to the next track below the current selection, do one of the following:
- Choose Edit > Selection > Move Edit Down.
- Press Control+; (Mac) or Start+; (Windows).

Extending (or Contracting) the Edit Selection Over Multiple Tracks

To extend the Edit selection to the next track above the current selection, do one of the following:
- Shift-click with the Selector tool (within the same time as the current Edit selection) on the track just above the current Edit selection.
- Choose Edit > Selection > Extend Edit Up.
- Press Control+Shift+P (Mac) or Start+Shift+P (Windows).

To extend the Edit selection to the next track below the current selection, do one of the following:
- Shift-click with the Selector tool (within the same time as the current Edit selection) on the track just below the current Edit selection.
- Choose Edit > Selection > Extend Edit Down.
- Press Control+Shift+; (Mac) or Start+Shift+; (Windows).

To remove the top track from an Edit selection spanning more than one track, do one of the following:
- Choose Edit > Selection > Remove Edit From Top.
- Press Option+Control+P (Mac) or Alt+Start+P (Windows).

To remove the bottom track from an Edit selection spanning more than one track, do one of the following:
- Choose Edit > Selection > Remove Edit From Bottom.
- Press Option+Control+; (Mac) or Alt+Start+; (Windows).

Moving and Extending Selections Between Tracks with Commands Keyboard Focus

With Commands Keyboard Focus enabled, Edit selections can be moved or extended to adjacent tracks.

To move a selection to an adjacent track:
1. Enable Commands Keyboard Focus (see “Keyboard Focus” on page 26).

2. With the Selector or Time Grabber tool, make a selection.
3 Do one of the following:
   • Press P on your computer keyboard to move the selection to the previous track.
   • Press semicolon (;) to move the selection to the next track.

In either instance, the original Edit selection becomes deselected.

To extend a selection to an adjacent track:
1 Enable Commands Keyboard Focus (see “Keyboard Focus” on page 26).
2 With the Selector or Time Grabber tool, make a selection.
3 Do one of the following:
   • Press Shift+P to extend the selection to the previous track.
   • Press Shift+Semicolon (;) to extend the selection to the next track.

In either instance, the original Edit selection remains selected.

Other Useful Selection Techniques
Following are some additional useful selection editing techniques.

To position the edit cursor precisely at a clip start, end, or sync point:
1 Make sure the Tab to Transients button is not enabled. (See “Tabbing to Transients” on page 641.)
2 Click with the Selector tool in the track.

3 Do one of the following:
   • Press Tab to move the cursor to the next clip or clip group start, end, or sync point.
   • Press Option+Tab (Mac) or Control+Tab (Windows) to move the cursor to the previous clip or clip group start, end, or sync point.

To make a selection with the Scrubber:
1 Choose Setup > Preferences and click the Operation tab.
2 Select the option for “Edit Insertion Follows Scrub/Shuttle,” then click OK.
3 Scrub with the Scrubber to find an appropriate start point for the selection, then release.
4 While pressing Shift, scrub to an appropriate end point for the selection, then release. The range between the initial and final scrub becomes selected.

To move a selection to an adjacent clip on the same track:
1 Select a clip with the Time Grabber.
2 Do one of the following:
   • Press Control+Tab (Mac) or Start+Tab (Windows) to move the selection to the next clip.
   • Press Option+Control+Tab (Mac) or Control+Start+Tab (Windows) to move the selection to the previous clip.

In either instance, the original clip becomes deselected.
To slide an Edit selection in the Main Timebase ruler:

1. With the Selector or Time Grabber tool, make a selection.
2. While pressing Option (Mac) or Alt (Windows), move the cursor over either of the Timeline Selection Markers in the ruler (the Time Grabber appears).
3. Drag left or right to move the Edit selection back or forward in time while preserving its length.

If Link Timeline and Edit Selection is disabled (Options > Link Timeline and Edit Selection), Option-drag (Mac) or Alt-drag (Windows) the Edit Markers instead.

**Right-Click Commands and Selection Preservation**

You can use Right-click commands with key combinations to perform operations on objects while maintaining selections in the Edit and Mix windows. For example, you can maintain selections in the following areas while carrying out certain commands:

- Clip selections in the Timeline
- Clip name selections in the Clips List
- Track selections

**To apply a command to an object while keeping the current selection:**

- Command-Right-click (Mac) or Control-Right-click (Windows) the object and choose a command from the pop-up menu.

**Tabbing to Transients**

With the Tab to Transients button enabled, you can automatically navigate to transients in audio waveforms in Waveform view, placing the cursor just before the detected transient peak. This lets you define selections and play ranges, as well as start and end points for new clips, without having to zoom in on the waveform.

In Warp view, Tab to Transients tabs to all Event and Warp markers in a clip. Normal Tab tabs to clip boundaries and all Warp markers. In Analysis view, pressing Tab always tabs to Event markers, regardless of whether or not Tab to Transients is enabled.

With MIDI and Instrument tracks when Tab to Transients is disabled, pressing Tab moves the insertion point to the next MIDI clip boundary regardless of the track view (just like with audio clips).
With MIDI and Instrument tracks when Tab to Transients is enabled, pressing Tab moves the Edit insertion to the beginning of the next note or clip boundary regardless of the track view (just like with audio transients), but does not make note selections.

For more information, see “Keyboard Shortcuts for Navigating MIDI” on page 767.

To set the start and end points of a selection with Tab to Transients:

1. In the upper left of the Edit window, click the Tab to Transients button so it becomes selected.

2. If you will be setting the play range with this selection, enable Options > Link Timeline and Edit Selection.

3. Click in the audio track just before the beginning of the material you want to select.

4. Press Tab repeatedly until the cursor locates to the transient where you want to start the selection.

If necessary, you can move to the previous transient by pressing Option+Tab (Mac) or Control+Tab (Windows).

5. Press Shift+Tab until the cursor locates to the end of the material you want to select.

To move the selection end point to the previous transient, press Option+Shift+Tab (Mac) or Control+Shift+Tab (Windows).

Once selected, the material can be looped for recording or playback, or it can be turned into a new clip with the Separate or Capture command.

Peak transients are usually visible in the waveform. However, some low-frequency transients may not appear as visible peaks in the waveform.

Tab to Transients Across Multiple Tracks

With the edit cursor inserted across multiple tracks, you can use Tab to Transients to tab to the next transient on any of those tracks. When transients on multiple tracks are closely aligned, Tab to Transients tabs to the first transient on any of those tracks.

Timeline Selections

With the Link Timeline and Edit Selection option disabled, selections can be made in the Timeline that are distinct and separate from Edit selections.

With the Timeline and Edit selections linked, any Edit selections that are made are mirrored in the Timeline, and any Timeline selection is mirrored as an Edit selection across all tracks.

Whether the Timeline and Edit selections are linked or not, the range indicated by the Timeline Selection Markers always determines the range for playback and recording (except when in Dynamic Transport mode, see “Dynamic Transport Mode” on page 485).

With Pro Tools Ultimate, when the Scrolling option is set to Center Playhead, it determines where playback begins (see “Playing Timeline and Edit Selections with the Playhead” on page 483).

To make a Timeline selection with the Selector tool:

1. If you want to constrain the selection to the current Grid value, set the Edit mode to Grid.

2. Drag with the Selector tool in any Timebase ruler.
Making a Timeline selection with the Selector tool

The Timeline selection is indicated in the Main Timebase ruler by the blue Timeline Selection Markers (or if a track is record-enabled, the Timeline Selection Markers are red). The start, end, and length for the Timeline selection is displayed in the corresponding fields in the Transport window.

To select all tracks, including Conductor tracks, press Option (Mac) or Alt (Windows) while dragging in a Timebase ruler with the Selector tool.

To set the Timeline selection by dragging the Timeline Selection Markers:
1. If you want to constrain movement to the current Grid value, set the Edit mode to Grid.
2. With the Time Grabber, drag the first Timeline Selection Marker (down arrow) to set the start point.
3. Drag the other Timeline Selection Marker (up arrow) to set the end point.

Sliding a Timeline Selection

Like Edit selections, Timeline selections can be slid in the Main Timebase ruler.

To move a Timeline selection in the Main Timebase ruler:
1. While pressing Option (Mac) or Alt (Windows), move the cursor over either of the Timeline Selection Markers (the Time Grabber appears).
2. Drag left or right to move the Timeline selection back or forward in time, while preserving its length.

Timeline Selections to/from Edit Selections

When the Timeline and Edit selections are unlinked, you can copy selections between them.

To change the Timeline selection to match the current Edit selection:
- Choose Edit > Selection > Change Timeline to Match Edit.
To change the Edit selection to match the current Timeline selection:

- Choose Edit > Selection > Change Edit to Match Timeline.

Press Option+Shift+5 (Mac) or Alt+Shift+5 (Windows) to change the Timeline selection to match the Edit selection.

Press Option+Shift+6 (Mac) or Alt+Shift+6 (Windows) to change the Edit selection to match the Timeline selection.

Navigating the Timeline with the Edit Window Counters and Indicators

The counters and indicators at the top of the Edit window display the current playback location and Edit selection. These include the Main and Sub Counters, and the Edit Selection Start, End, and Length indicators.

All Edit window counters and indicators (except the Sub Counter) let you enter a location in their counter display to navigate to a specific time location.

The Main Counter displays the playback location in the time format for the Main Time Scale. The Sub Counter can be set to any of the other Time Scale formats for another timing reference.

The Edit Selection indicators (to the right of the Main and Sub counters) display the Start and End times, and Length of the current Edit selection according to the Main Timebase.

The Main and Sub Counters, as well as the Edit Selection indicators, also appear in the Transport window when it is set to display Counters.

To navigate with the Edit window Main Counter (or one of the Edit Selection indicators):

1. Do one of the following:
   - Click in one of the counters.
   - Press asterisk (*) on the numeric keypad to highlight the Main Counter in the Edit window (or the Main Counter in the Transport window or Big Counter window, if either are displayed).

2. Type in the new location. Press Period (.) to cycle through to the different time fields.

3. Press Enter to accept the new value and automatically locate there.

Scrolling in a Timebase Ruler

You can scroll the contents of the Edit window by dragging in a ruler. While this does not actually update the session’s Current Location, it does let you conveniently shift the display left or right for the sake of finding and editing material.

This method of scrolling is especially useful when using the Continuous Scrolling option, which does not update or follow Timeline selections.

To scroll the entire contents of the Edit window from a ruler:

- While pressing Command+Option+Control (Mac) or Control+Alt+Start (Windows), drag left or right in any of the Timebase rulers.
Scrolling with a Scroll Wheel

If you have a mouse with a scroll wheel, you can use the scroll wheel to scroll vertically or horizontally in any Pro Tools window that has a scroll bar (such as the MIDI Event List).

To scroll a Pro Tools window vertically:
1 Place the mouse over the window you want to scroll (for example, in the Edit window you might want to scroll either the track display or the Clips List).
2 Scroll the scroll wheel up or down to scroll the window up or down.

To scroll a Pro Tools window horizontally:
1 Place the mouse over the window you want to scroll (for example, in the Edit window you might want to scroll either the track display or the Clips List).
2 Shift-scroll the scroll wheel up or down to scroll the window to the left or right.

Auto-Scrolling Tracks in the Mix and Edit Windows

If you are working with more tracks than can be displayed at one time in the Mix or Edit windows, you can select a track in one window and Pro Tools will automatically scroll to that track in both windows.

To auto-scroll the Mix and Edit windows to show a track, do one of the following:

- In the Tracks List, Right-click the track name and select Scroll Into View.
- In the Tracks List, Control-click (Mac) the track name and select Scroll Into View.

The track becomes selected, and the Mix and Edit windows both scroll to display the selected track.

Navigating to Tracks Using Track Position Numbers

With Track Number View enabled, each track is assigned a number corresponding to its position in the Mix and Edit Windows. You can scroll directly to any track by its positional number.

When tracks are reordered, Track Position Numbers are reassigned to keep them in numerical sequence.

To navigate directly to any track using Track Position Numbers:
1 Choose View > Track Number.
2 Choose Track > Scroll to Track.

Press Command + Option + F (Mac) or Control + Alt + F (Windows) to Scroll to Track.

Scroll To Track dialog

3 In the Scroll To Track dialog, enter the Track Number for the track you want to view.
4 Click OK.

The track is selected, and the windows scroll as follows:

- The Edit window tracks scroll to bring the selected track as close to the top as possible.
- The Mix window tracks scroll to bring the selected track as close to the left as possible.
Universe View

The Universe view displays an overview of the entire Pro Tools session above the tracks pane in the Edit window.

Universe view at the top of the Edit window

This overview represents audio and MIDI material on all tracks in the session that are not hidden (including tracks that are inactive, or that contain offline clips). The order in which material is displayed in the Universe view corresponds to the track order in the Edit window.

In the Universe view, audio, MIDI, and video clips on tracks are represented by horizontal lines that are the same colors as the clips on the tracks. Each audio track is represented at the same height regardless of how many channels it has. Additionally, tracks that show Automation, Controller, or Playlist lanes are represented with increasing height for each lane shown.

Since Auxiliary Input, Master Fader, and VCA Master tracks do not contain audio or MIDI clips, they are displayed as blank areas in the Universe view.
Showing the Universe Window

To show or hide the Universe view in the Edit window, do one of the following:

- Select or deselect View > Other Displays > Universe.
- Double-click the divider above the Main Timebase ruler.
- From the Edit window menu, select or deselect Universe.
- Click the Show/Hide Universe/Clip Effects view button.
- Press Option+7 (Mac) or Alt+7 (Windows).

Framed Area in the Universe View

The framed area in the Universe view represents what is visible in the Tracks pane in the Edit window. If you change what is displayed in the Edit window—by zooming, scrolling horizontally or vertically, hiding or showing tracks, or changing track heights—the framed area in the Universe view relocates and resizes accordingly. During playback, if the Edit window is set to scroll, the framed area in the Universe view also scrolls.

When all tracks are visible in the Edit window and the session is zoomed all the way out, with all clips visible, the entire Universe window is framed.
Navigating with the Universe View

By clicking in the Universe view, you can scroll the material displayed in the Edit window horizontally, vertically, or both. This provides a convenient method of focusing the Edit window anywhere in the session.

To navigate the session using the Universe view:

1. Ensure that Universe view is shown (View > Other Displays > Universe).
2. Click anywhere in the Universe view to move the framed area and the Edit window updates accordingly.

Resizing the Universe View

You can resize the height of the Universe view to fit the total number of tracks in the session, or to show more of the Edit window.

To resize the height of the Universe view:

1. Click the area between the bottom of the Universe window and the top of the Timebase rulers. The cursor changes to show that you can resize the Universe view.
2. Drag up to decrease the height of the Universe view or drag down to increase the height of the Universe view.

Scrolling the Universe View

If you have more tracks in the session than are visible in the Universe view, you can scroll up or down to show the other tracks.

To scroll the Universe view up or down:

- Click the Scroll Up or Scroll Down Arrows on the right of the Universe view.

Navigating a Pro Tools Session with Keyboard Shortcuts

In addition the Universe view, Pro Tools lets you quickly and easily navigate a session using keyboard shortcuts. This topic provides an overview of the essential key commands for navigating and making Edit selections in a session.
Zooming to the Entire Session and to the Edit Selection

To zoom your entire session into view:

1. Press Option+Control+A (Mac) or Alt+Start+A (Windows) to horizontally fit the beginning and end of the session to the length of the Edit window.

2. Press Option+Control+Up Arrow (Mac) or Alt+Start+Up Arrow (Windows) to fit all of the tracks in the session to the height of the Edit window.

To zoom to an Edit selection:

1. With the Selector or the Grabber tool, make an Edit selection.

   - Press F7 for the Selector tool or F8 for the Grabber tool.

2. Press Option+Control+F (Mac) or Alt+Start (Windows) to fit the length of the selection to the length of the Edit window.

3. Press Command+Control+Up Arrow (Mac) or Control+Start+Up Arrow (Windows) to zoom the Track Height of the Edit selection to fit to the height of the Edit window.

To zoom to an Edit selection using Zoom Toggle:

1. With the Selector or the Grabber tool, make an Edit selection.

   - Press F7 for the Selector tool or F8 for the Grabber tool.

2. Press Control+E (Mac) or Start+E (Windows) to enable Zoom Toggle.

   - Set the Track Height option for Zoom Toggle to Fit To Window in the Editing Preferences.

3. Do one of the following:
   - Press Control+E (Mac) or Start+E (Windows) again to revert to the preview zoom state.
   - Press Option+Shift+E (Mac) or Alt+Shift+E (Windows) to cancel Zoom Toggle without reverting to the previous view.

Creating Edit Selections with Tab to Transients

If you are editing audio with clear transients, you can use Tab to Transients to make Edit selections.

To toggle Tab to Transients on and off:

- Press Command+Option+Tab (Mac) or Control+Alt+Tab (Windows).

To navigate and extend selections forward with Tab to Transients:

1. With the Selector tool, place the Edit cursor before the first transient your want in your selection.

2. Press Tab to place the Edit cursor at the first transient.

3. Press Shift+Tab to extend the selection to the next transient.

To navigate and extend selections backward with Tab to Transients:

- Press Option+Tab (Mac) or Control+Tab (Windows) to move the Edit cursor to the previous transient.

- Press Option+Shift+Tab (Mac) or Control+Shift+Tab (Windows) to extend the selection to the previous transient.
Making an Edit Selection During Playback

To make an Edit selection during playback:

1. Place the Edit cursor in the track or across multiple tracks where you want to make the selection.
2. Start playback.
3. Press the Down Arrow to place the Edit cursor at the current playback location and mark the beginning of the Edit selection.
4. Press the Up Arrow to mark the end point of the Edit selection.
5. Stop playback.
6. Do one of the following:
   - Press the Left arrow to locate the beginning of the Edit selection.
   - Press the Right arrow to locate the end of the Edit selection.

Moving the Edit Selection

Pro Tools provides several keyboard shortcuts for moving and extending or decreasing the range of an Edit (or Timeline) selection.

To move the selection down to the next track:

- Press Control+; (semicolon) (Mac) or Start+; (semicolon) (Windows).

To move the selection up to the next track:

- Press Control+P (Mac) or Start+P (Windows).

To extend the Edit selection up across tracks, Press Control+Shift+P (Mac) or Start+Shift+P (Windows).

To move the selection forward by the selection amount:

- Press Command+Control+Option+’ (single quote) (Mac) or Control+Alt+Start+’ (single quote) (Windows).

To move the selection backward by the selection amount:

- Press Command+Control+Option+L (Mac) or Control+Alt+Start+L (Windows).

To double the Edit selection:

- Press Command+Control+Option+Shift+’ (single quote) (Mac) or Control+Alt+Start+Shift+’ (single quote) (Windows).

To halve the Edit selection:

- Press Command+Option+Control+Shift+L (Mac) or Control+Alt+Start+Shift+L (Windows).

To go to and select the previous clip, do one of the following:

- Press Option+Control+Tab (Mac) or Alt+Start+Tab (Windows).
- Press Command+Control+L (Mac) or Control+Start+L (Windows).
To go to and select the next clip, do one of the following:

- Press Control+Tab (Mac) or Start+Tab (Windows).
- Press Command+Control+' (single quote) (Mac) or Control+Start+' (single quote) (Windows).

To extend the selection to include the previous clip, do one of the following:

- Press Option+Control+Shift+Tab (Mac) or Alt+Start+Shift+Tab (Windows).
- Press Command+Control+Shift+L (Mac) or Control+Start+Shift+L (Windows).

To extend the selection to include the next clip, do one of the following:

- Press Control+Shift+Tab (Mac) or Start+Shift+Tab (Windows).
- Press Command+Control+Shift+' (single quote) (Mac) or Control+Start+Shift+' (single quote) (Windows).

Moving the Insertion to the Beginning or End of the Selection

With the Transport stopped, you can use the Down and Up Arrows on your alphanumeric keyboard to the beginning or end of the Edit (or Timeline) selection (and collapse the selection).

To move the insertion to the beginning of the selection:

- Press the Down Arrow.

To move the insertion to the end of the selection:

- Press the Up Arrow.

Restoring the Last Selection

There are times when editing that you can lose your selection. If you lose the current Edit (or Timeline) selection and want to restore it, use the Restore Last Selection command.

To restore the last selection:

- Choose Edit > Restore Last Selection.

You can also press Command+Option+Z (Mac) or Control+Alt+Z (Windows) to restore the previous selection.

Changing Track Heights

To fit the Track heights of tracks containing the Edit selection to the height of the Edit window:

- Press Command+Control+Up Arrow (Mac) or Control+Start+Up Arrow (Windows).

To change Track height proportionally for tracks containing the Edit selection:

- Press Control+Up or Down Arrows (Mac) or Start+Up or Down Arrows (Windows).

To change Track views for all tracks together:

- Press Option+Control+Up or Down Arrows (Mac) or Alt+Start+Up or Down Arrows (Windows).

Changing Track Views

To change Track views for tracks containing the Edit selection:

- Press Command+Control+Left or Right arrows (Mac) or Control+Start+Left or Right arrows (Windows).

To change Track views for all tracks together:

- Press Command+Option+Control+Left or Right arrows (Mac) or Control+Alt+Start+Left or Right arrows (Windows).
Chapter 30: Editing Clips and Selections

Clips are the basic building blocks for arranging audio and MIDI in Pro Tools. Understanding how clips are created, edited, and arranged is essential to taking full advantage of the editing capabilities of Pro Tools.

This chapter covers basic editing functions as they apply to clips and clip groups, and selections, which for the most part apply to both MIDI and audio data. For editing procedures more specific to MIDI, see Chapter 34, “MIDI Editing.” For editing procedures specific to video, see “Video Clips” on page 1371.

Creating New Clips

Pro Tools provides several commands for creating clips and clip groups, each of them having a slightly different effect on the selection. When you create a new clip or clip group, it appears in the Clips List and in the track’s playlist. When creating a new clip from an existing clip, the original clip remains in the Clips List. New clips are named automatically (see “Auto-Naming Options” on page 298).

Capture Clip Command

The Capture Clip command defines a selection as a new clip and adds it to the Clips List. From there, the new clip can be dragged to any existing tracks.

To capture a new clip:

1. With the Selector tool, drag in an existing clip to select the material for the new clip.

2. Choose Clip > Capture.

3. Type a name for the new clip and click OK.

The new clip appears in the Clips List. The original clip remains intact and unchanged.
Separate Commands

The Separate commands define a selection within an existing clip, or a partially selected clip, as a new clip and separate it from surrounding material. The Separate commands can also be applied to MIDI notes (see “Separating MIDI Notes” on page 757).

New clips appear in the tracks in which they are created, separate from the data surrounding them. They also appear in the Clips List.

There are three different Separate commands:

**At Selection (or Edit Cursor)** Creates new clip boundaries at the selection start and end points. If there is no selection and the edit cursor is placed within the clip, the clip is split into two new clips at the insertion point. Likewise, MIDI notes can be separated at the selection start and end points (or at the Edit cursor).

**On Grid** Creates new clips according to the selected Grid value (see “Defining the Grid Value” on page 901). Likewise, MIDI notes can be separated on the grid.

**At Transients** Automatically creates clip boundaries on detected transients within a selection. This uses the same algorithm for transient detection as the Tab to Transients feature (see “Tabbing to Transients” on page 641). On Elastic Audio-enabled tracks, the Separate At Transients command uses the transient events detected by Elastic Audio analysis (see “Elastic Audio Analysis” on page 973). Separate At Transients only applies to audio and is not applicable to MIDI notes or clips.

To separate one or more clips (or MIDI notes) at the selection (or at the edit cursor):

1. Do one of the following:
   - With the Selector tool, make an Edit selection.
   - With the Selector tool, click at the point where you want to separate the clip (or MIDI note).

2. Do one of the following:
   - Choose Edit > Separate > At Selection.
   - With an Edit selection, Right-click near the cursor position or selection and choose Separate from the pop-up menu.

3. If the Editing preference for Auto-Name Separated Clips is disabled, type a name for the new clip when prompted, then click OK.

To separate clips (or MIDI notes) according to the current grid resolution:

1. Make an Edit selection.
2. Choose Edit > Separate > On Grid.
3. In the Pre-Separate Amount dialog, type a pre-separate amount in milliseconds. This can be useful to pad the beginnings of the new clips.

4. Click OK.

To separate audio clips at transients:

1. Make an Edit selection.
2. Choose Edit > Separate > At Transients.
3. In the Pre-Separate Amount dialog, type a pre-separate amount in milliseconds. This can be useful to pad the beginnings of the new clips.

4. Click OK.
Auto-Name Separated Clips Option

With the Auto-Name Separated Clips option in the Editing Preferences page selected, Pro Tools automatically names separated clips for you. The name is a numbered variation of the original clip’s name.

By separating a clip, additional clips are auto-created from data on either side of the separation, which have new numbers assigned to their names. The original clip remains intact and unchanged on the Clips List.

The Clips List can quickly fill up with auto-created clips. For easier clip management, click the Clips List menu, deselect Show > Auto-Created to hide all auto-created clips in the Clips List.

“Separate Clip” Operates On All Related Takes

When the “Separate Clip” Operates on All Related Takes option is enabled in the Editing Preferences, editing a clip with the Separate Clip command also affects all other related takes with the same User Time Stamp.

This option helps you compare different sections from a group of related takes. For example, you can quickly separate an entire group of related vocal takes into sections, then audition and select the best material from each section independently.

If this option is selected, make sure the Track Name and Clip Start and End options are also selected in the Matching Criteria window (see “Matching Criteria” on page 705). If they are not, all clips in the session that have the same User Time Stamp will be affected.

In most instances, you will want to disable the Separate Clip Operates On All Related Takes option, to prevent a large number of clips from being created when you use the Separate Clip command.

Separating Multiple Tracks

The following figure illustrates a separation across one mono audio track and two stereo tracks. For some tracks, the selection resides within a clip, while others reside at the start or end of a clip.

Once separated, this material can be moved or copied to another location.

Separation Grabber Tool

You can use the Separation Grabber tool to automatically separate an Edit selection and move it to another location or another track.

To separate a selection with the Separation Grabber tool:

1. With the Selector tool, make an Edit selection. The selection can reside within a single clip, across adjacent clips within the same track, or across multiple tracks.
2 From the Grabber tools pop-up menu, choose the Separation Grabber tool.

3 Drag the selection to the new location, or to another track.

A new clip (or clips) containing the previous selection is created, separate from the original selection. New clips are also created from the material outside the original selection.

To separate a selection without affecting the original clips:

1 With the Selector tool, make an Edit selection. The selection can reside within a single clip, across adjacent clips within the same track, or across multiple tracks.

2 From the Grabber tools pop-up menu, choose the Separation Grabber tool.

3 While pressing Option (Mac) or Alt (Windows), drag the selection to the new location, or to another track.

New clips containing the previous selection are created and placed at the new location. The original selection and clips remain intact.

Healing Separated Clips

The Heal Separation command returns separated clips to their original state—provided the clips are still next to each other and their relative start and end points have not changed since the separation.

If you have trimmed or otherwise changed the start or end points of the two clips, or moved them further away from each other, you will not be able to repair them with the Heal Separation command. It is not possible to heal two clips created from different audio files.

To heal a separation between two clips:

1 With the Selector tool, make a selection that includes part of the first clip, the entire separation between the clips, and part of the second clip.

2 Choose Edit > Heal Separation.

Press Command+H (Mac) or Control+H (Windows) to Heal Separation.
If the clips do not heal with Heal Separation, do one of the following to return the separated clips to a single clip:

- Delete one of the two separated clips (verify that Slip mode is enabled so the gap does not close) and use the Trim tool to expand the remaining clip to its original length (see “Using the Trim Tools” on page 613).

- Delete both of the separated clips and drag the original clip from the Clips List to the original location (see “Placing Clips from the Clips List on to Track Playlists” on page 891).

### Trimming Clips

In addition to the Trim tools (see “Using the Trim Tools” on page 613), Pro Tools provides several options for editing clip and clip group boundaries.

#### Trim to Selection Command

The Trim to Selection command removes data before and after a clip or MIDI note selection, leaving only the selection. This command lets you quickly remove all data in a clip (and in some instances the entire track) except for the current selection.

**To trim unwanted data from a clip or note:**

1. With the Selector tool, select a portion of a clip or note (or a range of notes).
2. Choose Edit > Trim Clip > To Selection to remove material outside of the selection.

#### Trim to Insertion Commands

You can trim a clip or MIDI note by automatically removing the material between the Edit insertion point and the start or end point of the clip.

**To trim from a start point to insertion:**

1. With the Selector tool, click inside the clip or note where you want the new start point to be.
2. Choose Edit > Trim Clip > Start To Insertion. The clip’s start point is automatically trimmed to the insertion point.

**To trim from an end point to insertion:**

1. With the Selector tool, click inside the clip or note where you want the new end point.
2. Choose Edit > Trim Clip > End To Insertion. The clip’s end point is automatically trimmed to the insertion point.

Press Option+Shift+7 (Mac) or Alt+Shift+7 (Windows) to Trim Start To Insertion.

Press Option+Shift+8 (Mac) or Alt+Shift+8 (Windows) to Trim Start To Insertion.
Trim to Fill Selection Commands

The Trim to Fill Selection commands let you automatically reveal underlying material in the gaps between clips, or before and after individual clips, as follow:

To trim from a start point to fill gaps:
1 With the Selector tool, select across at least one gap between clips.
2 Choose Edit > Trim Clip > Start to Fill Selection.

The start point of the clip behind the gap is automatically trimmed (expanded) to the previous clip, or as far as possible if there is not enough underlying material to cover the gap.

To trim from an end point to fill gaps:
1 With the Selector tool, select across at least one gap between clips.
2 Choose Edit > Trim Clip > End To Fill Selection.

The end point of the clip in front of the gap is automatically trimmed (expanded) to the next clip, or as far as possible if there is not enough underlying material to cover the gap.

The Trim to Fill Selection command is the inverse of the Trim to Fit Selection command: where the Trim to Fill Selection command trims a clip out to match the Edit selection, the Trim to Fit Selection command trims a clip in to match the Edit selection.
Trim Clip to File Commands

There are three Trim Clip to File commands that let you trim a clip to the end of the file, the beginning of a file, or both. However, clips trimmed to file boundaries do not overlap other clips on the same track. Instead, the selected clip is trimmed out only to the next or previous clip boundary depending on which command you use.

To trim out the selected audio clip to the start of the referenced file:

1. Select the entire clip.
2. Choose Edit > Trim Clip > To File Start.

To trim out the selected audio clip to the end of the referenced file:

1. Select the entire clip.
2. Choose Edit > Trim Clip > To File End.

To trim out the selected audio clip to the start and end of the referenced file:

1. Select the entire clip.
2. Choose Edit > Trim Clip > To File Boundaries.

Trimming with Nudge

You can trim the start and end points of clips (or MIDI notes) by the current Nudge value.

To trim a clip’s start or end point by the Nudge value:

1. Configure the Nudge value (see “Defining the Nudge Value” on page 660).
2. With the Time Grabber tool, select the clip you want to trim.
3. Do one of the following:
   - While pressing Option (Mac) or Alt (Windows), press Plus (+) or Minus (–) on the numeric keypad to trim the clip’s start point by the Nudge value.
   - While pressing Command (Mac) or Control (Windows), press Plus (+) or Minus (–) on the numeric keypad to trim the clip’s end point by the Nudge value.

Nudging Clips

Pro Tools can nudge clips (or MIDI notes) by precise increments with the Plus (+) and Minus (–) keys on the numeric keypad. The amount of the nudge is determined by the value specified in the Nudge Value pop-up menu. The Nudge function can be used in any of the Edit modes.

Nudging can be invaluable for adjusting the “groove” of a musical phrase or a sound effect relative to other elements in the session. Since Pro Tools can nudge material during playback, you can nudge continuously in real time to adjust the timing relationship between tracks.

Nudge can also be used to adjust the placement of automation breakpoints. For more information, see “Editing Automation” on page 1152.
Defining the Nudge Value

The Nudge value determines how far clips and selections are moved when nudging.

Start and end points for selections can also be moved by the Nudge value (see “Nudging Selection Start/End Points” on page 635). In addition, clips can be trimmed by the Nudge value (see “Trimming with Nudge” on page 659).

To set the Nudge value:

1. Do one of the following:
   - From the View > Main Counter menu, select the Time Scale for the Nudge value.
   - To keep the Main Time Scale and use a different time format for the Nudge value, deselect Follow Main Timebase in the Nudge Value pop-up menu.

2. Specify a Nudge value by doing one of the following:
   - From the Nudge value pop-up menu in the Edit window, select the Nudge value.
   - To specify a Nudge value not listed in the Nudge Value pop-up menu, click the Nudge Value indicator and type in the value.

To increase the nudge value incrementally:
- Press Shift+Option+Equal (=) (Mac) or Shift+Alt+Equal (=) (Windows)

To decrease the nudge value incrementally:
- Press Shift+Option+Minus (–) (Mac) or Shift+Alt+Minus (–) (Windows)

Nudging Clips by the Nudge Value

To nudge one or more clips:

1. Configure the Nudge value (see “Defining the Nudge Value” on page 660).

2. With the Time Grabber or Selector tool, select the clip, clips, or clip groups you want to nudge. The clips can reside on multiple tracks. Only clips that are completely selected are nudged.

3. Do one of the following:
   - On the numeric keypad, press Plus (+) to move the selection forward by the Nudge value.
   - Press Minus (–) to move the selection back by the Nudge value.

The Nudge command works the same regardless of the Edit mode. Adjacent clips are overlapped in Shuffle mode, the Spot dialog does not appear when in Spot mode, and shifted material does not snap to the Grid when in Grid mode.

Nudging Clips on Multiple Tracks and in Multichannel Tracks

When nudging a selection of multiple clips within a single track or across multiple tracks, that also contains silence, any automation data residing within the silence is also nudged.
Nudging by Next Nudge Value

In addition to nudging by the current Nudge value, you can also nudge by the next larger value in the Nudge pop-up menu.

For example, if the Nudge value is set to 1 frame and you want to nudge by a larger value, you can nudge by the Nudge value of 10 frames.

To nudge forward or back by the next larger Nudge value:

1. Enable Commands Keyboard Focus (see “Keyboard Focus” on page 26).
2. Select the clips or notes you want to nudge.
3. Do one of the following:
   • Press Forward Slash (/) to nudge the selected material forward by the next Nudge value.
   • Press M to nudge the selection back by the next Nudge value.

When Commands Keyboard Focus is not enabled, press Control+Forward Slash (/) (Mac) or Start+Forward Slash (/) (Windows) to nudge the selected material forward by the next Nudge value, and press Control+M (Mac) or Start+M (Windows) to nudge the selected material back by the next Nudge value.

Nudging the Contents of a Clip

Often a clip’s start point will reside at the correct location, perhaps at a SMPTE frame or barline, but the material within the clip starts too late or early. You can, in effect, nudge a clip’s audio waveform or MIDI notes without displacing the clip start and end points.

This “sliding” of clip contents is only possible if there is material residing outside the clip’s start and end points—from the clip having been trimmed, or perhaps captured from a larger clip.

To nudge the contents of a clip without changing the clip start and end points:

1. Configure the Nudge value (see “Defining the Nudge Value” on page 660).
2. With the Time Grabber tool, select the clip whose contents you want to nudge.
3. While pressing the Control (Mac) or Start key (Windows), press Plus (+) or Minus (–) on the numeric keypad to move the material by the Nudge value.
Layered Editing

Pro Tools provides the option to enable layered editing so that you don’t lose partially overlapped clips while editing. This is true for both audio and MIDI.

To enable (or disable) layered editing, do one of the following:

- Select (or deselect) Options > Layered Editing.
- Click the Layered Editing button in the Edit Window toolbar so that it is lit (or unlit).

When the Layered Editing option is enabled, any partially overlapped clips are revealed when cutting, clearing (deleting), or moving the overlapping clip. Note that if any clip is fully overlapped by another, larger clip, it is removed from the timeline. In Figure 1, the clip “Audio 1_01” (1) is moved (2) to fully cover one clip and partially cover another clip (3). When that clip (“Audio 1_02-01”) is cleared, the fully covered clip is gone, but the partially covered clip is revealed (4).

Press Command+Delete (Mac) or Control+Delete (Windows) to clear all track data within the edit selection regardless of whether or not Layered Editing is enabled.
When the Layered Editing option is disabled, overlapped clips remain “trimmed” to the start or end time of the overlapping clip. In Figure 2, the clip “Audio 1_01” (1) is moved to cover the middle of a larger clip (2). When that clip (“Audio 1_01”) is cleared, the overlapped clip has a hole punched in it (3). If Layered Editing is enabled in this case, the underlying clip is completely revealed and healed (4).

---

### Quantizing Clips to Grid

The Quantize to Grid command adjusts the placement of selected audio and MIDI clips so that their start points (or sync points, if present) align precisely to the nearest Grid boundary.

To quantize individual MIDI notes or Elastic Audio Events, use the Quantize Event Operations. You can also use the Quantize Event Operation to quantize audio clips (see “Quantize Command” on page 1006).

**To quantize one or more clips:**

1. Select the Grid value (see “Defining the Grid Value” on page 901).

2. With the Selector or Time Grabber tool, select the clip or clips you want to quantize. The clips can be on multiple tracks. Only clips that are entirely selected will be quantized.

3. Choose Clip > Quantize to Grid. Clip start times (or sync points) are aligned to the nearest boundaries for the defined Grid.

   Press Command+0 (Mac) or Control+0 (Windows) to Quantize to Grid.

For MIDI clips, only the clips are quantized and all MIDI data contained within the clips (such as notes) are moved equally, thereby retaining their rhythmic relationships.
For Elastic Audio clips, only the clips are quantized and all Elastic Audio Events contained within the clips (such as transient events) are moved equally, thereby retaining their rhythmic relationships.

To quantize individual MIDI notes or Elastic Audio Events, use the Quantize Event Operations. You can also use the Quantize Event Operation to quantize audio clips. For more information see “Quantize Command” on page 1006).

**Editing Stereo and Multichannel Tracks**

Clips on individual channels within stereo and multichannel tracks cannot be independently selected. All selections for these tracks are time-based, which means that selections made with the Selector or Time Grabber tool extend to each and every channel in the track.

When clips in multichannel tracks are edited with any of the Trim tools or dragged with the Time Grabber tool, material on all channels is affected equally as a group.

**Split Selected Tracks**

To edit a specific channel within a stereo or multichannel track without affecting the other channels, you can split the track into separate mono tracks. Once the edits have been made to the separated material, you can then drag or copy it back to the original multichannel track.

To split a stereo or multichannel track:

1. Select one or more stereo or multichannel tracks (see “Selecting Tracks” on page 234).
2. Choose Track > Split Into Mono. Clips from the channels on the selected tracks are placed on new, mono audio tracks.

Names for the new tracks are based on the source track name and channel suffix. For example, if a stereo track called “Funkit” is split, two new tracks called “Funkit.L” and “Funkit.R” are created.

Output and send assignments and volume and pan settings are retained in the new tracks. Mono equivalents of stereo and multi-mono plug-in assignments are assigned in the new tracks. However, multichannel plug-in assignments are not assigned in the new tracks.

**Dragging Clips to and from Stereo and Multichannel Tracks**

Dragging a stereo clip to two mono audio tracks
When dragging clips to or from stereo or multichannel tracks, the following rules apply:

- Provided the number of tracks and channels are the same for the source and destination, you can drag clips between multichannel tracks and mono tracks.
- The source and destination for dragged clips can be mixed. For example, you can drag clips from a 5.0 track (containing five channels) to a stereo track and three mono audio tracks.
- When dragging multichannel clips to mono tracks, the destination tracks must be adjacent.
- When dragging clips from mono tracks to a multichannel track, the source tracks need not be adjacent.

Multichannel clips can also be dragged from the Clips List, to multichannel tracks of the same format, groups of mono audio tracks, or a combination of both.

Conversely, a collection of single, mono clips can be dragged from the Clips List to multichannel tracks—provided the dragged number of clips matches the number of channels in the destination track.

### Consolidating Clips

During the course of normal edit operations, any track can accumulate many clips. However, once a track or track range (such as a verse or chorus) reaches a satisfactory state, you may want to consolidate multiple clips into a single clip.

When consolidating an entire audio track or just an Edit selection, a new audio file is written that consists of the entire selection, including any blank space.

When consolidating, muted clips are treated as silence. Otherwise, whether or not a track is muted, or contains Mute automation, does not affect the Consolidate command.

⚠️ **Consolidating an audio track does not consolidate underlying automation data. To create a single file with automation data applied to the audio, use Bounce to Disk (see “Bounce to Disk” on page 1188).**

**To consolidate clips within a track:**

1. Do one of the following:
   - Using the Time Grabber or Selector tool, select the clips you want to consolidate.
   - To select all clips in a track, triple-click in its playlist with the Selector tool.
2. Choose Edit > Consolidate.

Press Option+Shift+3 (Mac) or Alt+Shift+3 (Windows) to Consolidate.

### Compacting an Audio File

The Compact command deletes unused portions of audio files to conserve disk space, and to prepare for cleaner hard drive back-ups. The Compact Selected command also deletes any audio files for which there are no clips on tracks referencing those files.

Because it permanently deletes audio data, the Compact command should be used only after you have completely finished your editing and are sure that you have no further use for the unused audio data.
The Compact command can pad the clips of the compacted file by a selectable amount. If clips in your session use crossfades, or if you want to pad the clips for the sake of any future trimming, you should enter an appropriate amount of padding (in milliseconds).

⚠️ The Compact command is destructive and cannot be undone. It permanently alters the original audio files. There is no way to recover data deleted by this command.

To compact an audio file:

1. In the Clips List, select the clip or clips you want to compact.
2. From the Clips List menu, choose Compact.
3. Enter the amount of padding in milliseconds that you want for each clip in the file.
4. Click Compact to compact the file or Cancel to cancel the command.

Once the Compact command has been completed, the session is saved automatically.

---

### Processing Audio with AudioSuite Plug-Ins

The AudioSuite plug-ins included with your Pro Tools system can be used to process and modify audio clips or even entire audio files. Do this in order to apply a specific AudioSuite process (such as Normalization or DC Offset Removal) to any number of audio clips in your session.

For more information about AudioSuite plug-ins, see Chapter 42, “AudioSuite Processing.”

---

### TCE (Time Compression and Expansion) Edit To Timeline Selection

(Pro Tools | Ultimate Software Only)

When the Edit and Timeline selections are unlinked, you can compress or expand an audio selection to fit the Timeline selection. On audio tracks, TCE Edit to Timeline Selection uses the TCE AudioSuite Plug-In selected in the Processing preferences (see “Processing Preferences” on page 124). On Elastic Audio-enabled tracks, TCE Edit To Timeline Selection uses the track’s selected Elastic Audio plug-in (see “Elastic Audio Plug-Ins” on page 975).

#### To fit an Edit selection to the Timeline:

1. Deselect Options > Link Timeline and Edit Selection.
2. With the Selector tool, select the audio material to be compressed or expanded.
3. In any Timebase ruler, select the time range where you want to fit the audio material.
4. Choose Edit > TCE Edit to Timeline Selection. The Edit selection is compressed or expanded to the length of the Timeline selection.

---

### TCE Edit to Timeline Selection on Multiple Tracks and Channels

The TCE Edit to Timeline command can be used on multichannel selections, and selections across multiple tracks. All clips are compressed or expanded equally by the same percentage value, based on Edit selection range. This ensures that the rhythmic relationship between the different channels or tracks is maintained.
Fitting an Audio Clip to an Edit Selection

Clips can be dragged from the Clips List to fit within an Edit selection. The dragged clip is compressed or expanded to fit within the selection. On audio tracks, fitting an audio clip to the Edit selection uses the TCE AudioSuite Plug-In selected in the Processing preferences (see “Processing Preferences” on page 124). On Elastic Audio-enabled tracks, it uses the track’s selected Elastic Audio plug-in (see “Elastic Audio Plug-Ins” on page 975).

To fit an audio clip to an Edit selection:

1. With the Selector tool, make an Edit selection in an audio track.
2. Command-Option-drag (Mac) or Control-Alt-drag (Windows) the clip from the Clips List to the track with the selection. The start of the clip is positioned at the selection start, and the clip is compressed or expanded to match the length of the selection.

Fit to Selection on Multiple Tracks and Channels

The Fit to Selection command supports dragging multiple clips from the Clips List to multiple tracks, or multichannel tracks.

All dragged clips are compressed or expanded equally by the same percentage value, based on length of the clip last clicked before dragging.

Rating Clips

You can rate different clips on a scale of 1 to 5, where 5 is the highest (or best) and 1 is the lowest (or worst). Clip rating is useful for identifying which takes (clips) you like the most when compositing playlists. You can display or hide the clip rating in clips to facilitate track compositing or regular editing. You can also show or hide Playlist lanes based on the ratings of clips in the playlist (see “Filtering Lanes” on page 704).

To rate a clip:

1. Select the clip.
2. Do one of the following:
   • Choose Clip > Rating, and select a ranking of 1 to 5.
   • Right-click the clip, choose Rate, and select a ranking of 1 to 5.

   You can rate selected clips during playback by pressing Command+Option+Control (Mac) or Control+Alt+Start (Windows) and then typing the rating number (1–5) on the numeric keypad.

To display ratings in clips:

• Select View > Clip > Rating.

To hide ratings in clips:

• Deselect View > Clip > Rating.
You can quickly and easily apply fade-ins, fade-outs on audio clips, and crossfades between adjacent audio clips. Crossfading is the process of fading between two clips of audio to prevent pops, clicks, or sudden changes in sound. Crossfades have many applications, from smoothing transitions between clips to creating special audio effects. The crossfade duration, position, and shape are all user-definable.

**About Crossfades and Curves**

To create a crossfade between two clips, use the Selector tool to select across the end point of the first clip and the start point of the second. The length of the selection determines the length of the crossfade. Though fades may appear to be discrete clips, they cannot actually be separated from the clips in which they were created. You can, however, create fade-ins and fade-outs for individual clips (see “Creating Fades at the Beginnings and Ends of Clips” on page 677).

Use the Fades dialog to select, view, and manipulate the curves used to perform fades and crossfades. Different volume curves can be assigned to the fade-out and fade-in portions of crossfades. The Fades dialog can also be used to audition a fade or crossfade before applying it.

The type of selection you make determines the character of the crossfade.

- **Since crossfades are created by fading between overlapping audio material, a crossfade cannot be performed on clips that do not contain audio material beyond their clip boundaries.**

- **If a clip references insufficient data to execute a selected fade or crossfade, you are prompted to either skip those fades or to adjust the bounds of the selection to execute those fades.**

**Standard Crossfade (Centered)**

This type of selection creates a crossfade on both sides of the splice point, which affects the volume of clip 1 and clip 2. It is the most common type of crossfade.

This crossfade type requires that clip 1 contain audio material beyond its end point, and clip 2 contain audio material before its start point.
**Pre Crossfade**

This type of selection creates a crossfade before the splice point. This lets you maintain the volume of the very beginning of clip 2 instead of fading across it, which is useful if there is a strong attack at the beginning of clip 2 that you want to preserve. When making selections for crossfades that occur on the border of two clips, you can use the Tab key to move the cursor to the exact beginning or end of a clip.

This crossfade type requires that clip 2 contain audio material before its start point.

---

**Post Crossfade**

This type of selection creates a crossfade after the splice point. It is useful if you want to maintain the amplitude of clip 1 until its very end. When making selections for crossfades that occur on the border of two clips, you can use the Tab key to move the cursor to the exact beginning or end of a clip.

This crossfade type requires that clip 1 contain audio material beyond its end point.

---

**Overlapping Crossfades View**

Pro Tools lets you view overlapping waveforms in crossfades.

*Overlapping Crossfades view*

**To show (or hide) overlapping crossfades:**

- Select (or deselect) View > Waveform > Overlapping Crossfades.
**Fade Dialogs**

Choose Edit > Fades > Create to apply the appropriate fade to the Edit selection. Use the corresponding Fade dialog (Fade In, Fade Out, Cross-fade) to select, view, preview fades and crossfades, and edit fade curves.

The controls in the Fades dialog include:

**Audition**

Click this button to audition fades. Pro Tools supports fade auditioning directly from your audio interface outputs.

**View First Track (Crossfades Only)**

If you are cross-fading between more than one track, this button allows you to view and preview the audio of the first in a pair of adjacent tracks.

**View Second Track (Crossfades Only)**

If you are cross-fading between more than one track this button allows you to view and preview the audio of the second in a pair of adjacent tracks.

**View Both Tracks (Crossfades Only)**

Click this button to display the waveforms of the first two adjacent tracks in a multitrack crossfade.

**Fade Curves Only**

Click this button to display the specified fade curves without showing the actual audio waveforms. This is the default view when you open the Fades dialog.
Fade Curves and Separate Waveforms

Click this button to display the specified fade curves along with separate views of the fade-in and fade-out waveforms.

Fade Curves and Superimposed Waveforms

Click this button to display the specified fade curves along with superimposed views of the fade-in and fade-out waveforms.

Fade Curves and Summed Waveform

Click this button to display the specified fade curves along with a single waveform representing the summation of the any crossfaded audio.

Zoom In

Click this button to scale the view of the waveform’s amplitude upwards. Command-click (Mac) or Control-click (Windows) for the default view scale.

Zoom Out

Click this button to scale the view of the waveform’s amplitude downwards. Command-click (Mac) or Control-click (Windows) for the default view scale.

Fade-Out Shape Settings

The Out Shape setting lets you define the shape of the fade-out from a clip for a fade, or from clip 1 for a crossfade.

Fade-Out Shape

**Standard** Selects a single continuous fade curve. This creates a general-purpose fade that can be edited by clicking and dragging the curve in the curve editor.

**S-Curve** Selects an S-shaped curve, which inverts its beginning and end characteristics. This makes it possible to fade out faster at the curve’s start and slower at its end, for example. S-shaped curves can be useful with material that is difficult to crossfade effectively. S-curves can be edited by clicking and dragging the curve in the curve editor.

**Preset Curves** Seven commonly used preset curves are provided for fast fade creation. These cannot be edited by clicking and dragging in the curve editor.

For more information on adjusting the fade shape, see “Manually Adjusting Fade Shapes in Fade Windows” on page 682.
The seven presets are as follows:

- Preset Curve 1 stays at full volume throughout the fade, then immediately drops the volume at the end of the fade.

![Preset Curve 1]

- Preset Curve 2 fades out relatively slowly, keeping the volume fairly high throughout the duration of the fade.

![Preset Curve 2]

- Preset Curve 3 fades out slightly faster, keeping the volume slightly lower during the fade.

![Preset Curve 3]

- Preset Curve 4 fades out with a linear fade. This is the default curve.

![Preset Curve 4]

- Preset Curve 5 fades out quickly at the beginning of the crossfade.

![Preset Curve 5]

- Preset Curve 6 drops the volume even more quickly at the beginning of the fade.

![Preset Curve 6]

- Preset Curve 7 silences any audio at the beginning of the fade.

![Preset Curve 7]

**Fade-In Shape Settings**

The **Shape** setting lets you define the shape of the fade-in to a clip for a fade, or to clip 2 for a crossfade.

- **Standard** Selects a single continuous fade curve. This creates a general-purpose fade that can be edited by clicking and dragging the curve in the curve editor.

![Standard]

- **S-Curve** Selects an S-shaped curve, which inverts its beginning and end characteristics. This makes it possible to fade out faster at the curve’s start and slower at its end, for example. S-shaped curves can be useful with material that is difficult to crossfade effectively. S-curves can be edited by clicking dragging the curve in the curve editor.

![S-Curve]

- **Preset Curves** Seven commonly used preset curves are provided for fast fade creation. These cannot be edited by clicking and dragging in the curve editor.

![Preset Curves]

For more information on adjusting the fade shape, see “Manually Adjusting Fade Shapes in Fade Windows” on page 682.
The seven presets are as follows:

- Preset Curve 1 fades in at full volume immediately at the beginning of the fade and keeps it there throughout the fade.

Preset Curve 1

- Preset Curve 2 fades in quickly in the beginning, reaching full amplitude fairly early in the fade.

Preset Curve 2

- Preset Curve 3 fades in moderately fast.

Preset Curve 3

- Preset Curve 4 fades in with a linear fade curve. This is the default curve.

Preset Curve 4

- Preset Curve 5 fades in slowly at the beginning of the fade.

Preset Curve 5

- Preset Curve 6 fades in even more slowly than the previous curve.

Preset Curve 6

- Preset Curve 7 silences any audio until the end of the fade.

Preset Curve 7

**Fade Slope Settings**

The Fade In and Fade Out dialogs provide two options for the slope of the fade. The Slope setting lets you define the slope of the fade.

**Equal Power** Recommended for material that is not phase coherent. With this fade, you can Option-click (Mac) or Alt-click (Windows) the fade curve to reset it to its default shape.

**Equal Gain** Recommended for material that is phase-coherent or nearly phase-coherent. With this fade, you can Option-click (Mac) or Alt-click (Windows) the fade curve to reset it to its default shape.

**Link Settings**

(Crossfades Only)

![Fade Link](image)
The Link setting links the selected fade-out and fade-in curves of a crossfade. If you adjust one curve, the corresponding curve is also adjusted. This ensures that the resulting crossfade is an equal power or equal gain crossfade, depending on which one you select.

**Equal Power** Recommended for material that is not phase coherent, as in the case of a crossfade between two completely different types of material. Use this option to avoid the volume drop that can occur with an Equal Gain crossfade. With this fade, you can Option-click (Mac) or Alt-click (Windows) the fade curve to reset it to its default shape.

**Equal Gain** Recommended for material that is phase-coherent or nearly phase-coherent, as in the case of a crossfade between identical clips/instruments (for example, a repeated drum loop). Use this option to avoid clipping that can occur when using an Equal Power crossfade. With this fade, you can Option-click (Mac) or Alt-click (Windows) the fade curve to reset it to its default shape.

**None** Disables linking between the fade-out and fade-in curves, and lets you freely adjust them separately, including start and end points.

For more information on adjusting the fade shape, see “Manually Adjusting Fade Shapes in Fade Windows” on page 682.

For information on adjusting the start and end points of fades in a crossfade, see “Adjusting the Start and End Points of a Crossfade” on page 682.

### Typical Curve Combinations

Following are the available combinations of fade-out and fade-in curves.

**Linear Crossfade** This is a good general purpose crossfade with a smooth, even transition between clip 1 and clip 2.

![Linear Crossfade](image1)

**Equal Power Crossfade** This is a good general purpose crossfade useful in cases where a linear crossfade seems to create a noticeable drop in volume across the splice point.

![Equal Power Crossfade](image2)

**Overlap Fade** This combination of curves keeps both clips at full amplitude throughout the crossfade: clip 2 “jumps in” at the beginning and clip 1 “jumps out” at the end.

![Overlap Crossfade](image3)
Fade and Crossfade Preferences

You can set default fade and crossfade settings. These settings load as your “base” settings when you use the Create Fades command, and the Fade to Start and Fade to End commands.

To set the fade and crossfade preferences:

1. Choose Setup > Preferences and click the Editing tab.
2. Set the Pre-Roll and Post-Roll times for Fade previews.
3. Click Fade In and set the default shape for fade-ins when using the Smart Tool, then click OK.
4. Click Fade Out and set the default shape for fade-outs when using the Smart Tool, then click OK.
5. Click Crossfade and set the default shape for crossfades when using the Smart Tool, then click OK.
6. Click OK.

Fade Presets

Pro Tools provides five Fade Presets so that you can easily store and recall your most commonly used fade settings. You can also save and import Fade Preset settings.

To store a Fade preset:

1. Configure the Fades dialog as you like.
2. Command-click (Mac) or Control-click (Windows) the Preset button where you want to store the current Fades dialog settings.

To recall a Fade preset:

- Click the Preset button that contains the settings you want to recall.

- Press Control+1–5 (Mac) or Start+1–5 (Windows) to recall the corresponding preset.

To apply the default fade or crossfade shape, make an Edit selection and press Command+Control+F (Mac) or Control+Start+F (Windows).
Fade Settings Menu

Use the Fade Settings menu commands to save, copy, paste, and manage fade settings as presets (Fade settings files).

**Fade Settings menu**

Fades Settings menu commands include:

- **<factory default>** Restores the default settings for the Fades dialog.
- **Save Settings** Saves the current settings. This command overwrites any previous version of the preset.
- **Save Settings As** Saves the current settings as a new preset under a different name.
- **Import Settings** Imports a fade settings file (.fdpreset) from a location other than the Root Settings folder or Session folder.
- **Delete Current Settings File** Permanently deletes the current fade settings file (.fdpreset) from disk.
- **Save Fade Settings To** Selects the folder where Fades preset files (.fdpreset) are saved. If you select Session Folder, the settings are saved in a folder named “Fades Presets” within the current Session folder. If you select Root Settings Folder, the settings are saved in the Pro Tools Root folder specified in the Operation preferences.

Creating Fades at the Beginnings and Ends of Clips

Pro Tools lets you create fade-ins and fade-outs at the beginnings and ends of clips.

With Pro Tools Ultimate, you can also use an automatic fade-in/out option, which applies real time fade-ins/outs to all clips during playback automatically. For more information, see “Using Auto-Fades” on page 680.

Creating Fade-Ins and Fade-Outs

Depending on how you make the selection, you can position a fade-in or fade-out at the exact beginning or end of a clip, or position it so it extends into a blank area of the track. The length of the selection in the clip determines the length of the fade-in or fade-out.

You can also fade to the beginning or end of a clip from an insertion point.

Although fades appear to be discrete clips, they cannot be separated from the clips in which they were created.

When changing tempo in a tick-based audio track, fade-ins and fade-outs remain with their parent clips. Fades maintain their absolute duration and are consequently recalculated after any tempo changes.
**To create a fade-in:**

1. Select the beginning of the clip that you want to fade in. The selection must extend to the exact beginning of the clip or a blank area prior to the clip in the track.

2. Do one of the following:
   - Choose **Edit > Fades > Create**.
   - Press Command+F (Mac) or Control+F (Windows).

3. Select the fade-in curve and configure the other Fade settings.

4. Click the Audition button to audition the fade.

5. Adjust the curve by dragging it or by selecting a different shape from the *In Shape* pop-up menu.

6. Click **OK**.

The selected fade curve appears in the clip.

**To create a fade-out:**

1. Select the end of the clip that you want to fade out. The selection must extend to the exact end of the clip or a blank area after the clip in the track.

2. Do one of the following:
   - Choose **Edit > Fades > Create**.
   - Press Command+F (Mac) or Control+F (Windows).

3. Select the fade-out curve and configure the other Fade settings.

4. Click the Audition button to audition the fade.

5. Adjust the curve by dragging it or by selecting a different shape from the *Out Shape* pop-up menu.

6. Click **OK**.

Pro Tools calculates the fade and the selected fade curve appears in the clip.

*Fade lengths can be resized with any of the Trim tools, including Nudge Trim commands. See “Using the Trim Tools” on page 613 and “Trimming with Nudge” on page 659.*
**To fade from the insertion point to a clip start point:**

1. Place the cursor at a location in the clip.
2. Do one of the following:
   - Choose Edit > Fades > Fade To Start.
   - Press Control+D (Mac) or Start+D (Windows).

The fade is applied based on the Fade In preferences (see “Fade and Crossfade Preferences” on page 676).

**To fade from the insertion point to a clip end point:**

1. Place the cursor at a location in the clip.
2. Do one of the following:
   - Choose Edit > Fades > Fade To End.
   - Press Control+G (Mac) or Start+G (Windows).

The fade is applied based on the Fade Out preferences (see “Fade and Crossfade Preferences” on page 676).

---

**Creating a Crossfade**

**To create a crossfade between two clips:**

1. With the Selector tool, click at the point where you want the crossfade to begin in the first clip and drag to where you want it to end in the second clip. Crossfade selections can begin and end anywhere in their respective clips.
2. Do one of the following:
   - Choose Edit > Fades > Create.
   - Press Command+F (Mac) or Control+F (Windows).

   ![To apply a Crossfade using the Default Crossfade setting (in the Editing Preferences), and without opening the Fades dialog, press Command+Control+F (Mac) or Control+Start+F (Windows).]

3. Use the view buttons to adjust the view of the crossfade. It may take a few moments to calculate the waveform display for long selections.
4. Select an Out Shape and an In Shape.
5. Select a Linking option.
6. Click the Audition button to audition the crossfade. For long crossfades, it may take Pro Tools a few moments to calculate and load the audio into playback RAM.
7. Do one of the following:
   - Adjust the curves by selecting different preset shapes with the Out Shape and In Shape pop-up menus.
   - Drag the Fade-In and Fade-Out curves to a custom shape. By choosing None as the Linking option, you can drag the beginning or end points of a fade curve to adjust its beginning or end point.
8. Click the Audition button to audition the crossfade again.
9. When the crossfade sounds right, click OK.

**To remove a crossfade, do one of the following:**

- Select the area of the track containing any crossfades you want to delete and choose Edit > Fades > Delete.
- Select the crossfade with the Time Grabber tool and press Delete (Mac) or Backspace (Windows).
- Right-click the crossfade with any of the edit tools and select Delete Fades from the pop-up menu.

Crossfade lengths can be resized with any of the Trim tools, including Nudge Trim commands. See “Using the Trim Tools” on page 613 and “Trimming with Nudge” on page 659.
To trim a crossfade:

1. Select the crossfade with the Time Grabber tool, or double-click it with the Selector tool.

2. With any of the Trim tools, trim either side of the crossfade. The crossfade is recalculated to reflect the newly trimmed length.

Crossfades on Tick-Based Audio Tracks

Crossfades are re-rendered after changing tempo in a tick-based audio track. The new crossfade is the same duration as the crossfade prior to the tempo change.

If there is not enough audio material to complete the crossfade, or if the new crossfade area falls outside of valid clip boundaries, the crossfade is removed.

Pre and Post Crossfade Selections

By making a selection that begins or ends precisely on the border of two clips, you can create “pre” or “post” crossfades. Use the Tab key to place the insertion point at the exact beginning or end of a clip.

To create a pre- or post-crossfade:

1. With the Selector tool, click in the track that contains the clips you want to crossfade.

2. Do one of the following:
   • Press Tab to move forward to the next clip boundary.
   • Press Option+Tab (Mac) or Control+Tab (Windows) to move back to the previous clip boundary.

3. Extend the selection by doing one of the following:
   • Shift-drag to adjust your selection, or press Shift+Tab to extend the selection forward to the next clip boundary.
   • Press Option+Shift+Tab (Mac) or Control+Shift+Tab (Windows) to extend the selection back to the previous clip boundary.

4. Do one of the following:
   • Choose Edit > Fades > Create.
   • Press Command+F (Mac) or Control+F (Windows).

5. Select a fade type and click OK.

Using AutoFades
(Pro Tools | Ultimate Software Only)

Pro Tools | Ultimate can automatically apply real-time fade-ins and fade-outs to all clip boundaries in the session on playback. Specify the duration (0 to 10 ms) for automatic real-time fades with the Auto Clip Fade In/Out Length preference in the Operation Preferences page. These fade-ins and fade-outs are performed during playback and do not appear in the Edit window.

⚠️ AutoFades are not applied to AudioSuite processing.

This feature is especially useful in post production situations such as dialogue tracking. For example, you can assign both a dialogue track and a “room tone” track with matching background to the same voice. You can then set the AutoFade option to a moderate length (4 ms or so) so that whenever a silence occurs in the dialog, playback switches smoothly to and from the background track without clicks or pops.
Using automatic fade-ins/outs saves you the trouble of editing to zero-crossings or creating numerous rendered fades in order to eliminate clicks or pops in playback. However, those clicks or pops still exist in the underlying sound file. Consequently, those anomalies still appear if the Duplicate AudioSuite plug-in or the Export Clips As Files command (from the Clips List) are used to duplicate multiple clips as a continuous file. To render these real-time auto fades to disk, choose File > Bounce to > Disk.

**To set the length of automatic fade-ins/outs:**

1. Choose Setup > Preferences and click the Operation tab.
2. Type a value between 0 and 10 ms for the Clip Auto Fade In/Out Length. A value of zero (the default) means that no auto-fading will occur.
3. Click OK. The AutoFade value is saved with the session, and is automatically applied to all free-standing clip boundaries until you change it.

**Creating Fades and Crossfades in Batches**

Using Batch Fades, you can create many fades at once. Select across several clips and use the Create Fades command to create crossfades for each clip transition. If your selection includes clips that already have crossfades, you can modify them.

**To apply crossfades between multiple clips:**

1. With the Selector tool, click in the first clip in which you want to create a crossfade. Make sure that the selection includes the entire clip.
2. Drag to extend the selection to include the last clip you want to crossfade. Make sure that the selection includes the entire clip.
3. Do one of the following:
   - Choose Edit > Fades > Create.
   - Press Command+F (Mac) or Control+F (Windows).
4. In the Batch Fades dialog, select whether you want to Create New Fades, Adjust Existing Shape & Slope, Adjust Existing Length, or a combination of these options for fade ins, crossfades and fade outs.

If you choose to create new fades and new fade-ins and outs, new crossfades are created at each clip boundary that is bordered by another selected clip, a fade-in is created at the start of the first clip, and a fade-out is created at the end of the last clip.
5 Select the placement of the Fades: Pre-Splice, Centered, or Post-Splice (see “About Cross-fades and Curves” on page 669).

6 Enter a length in milliseconds for Fade In, Crossfades, and Fade Out.

7 Click OK.

Pro Tools creates the fades and crossfades for all selected clips.

💡 *Fade lengths can subsequently be resized with any of the Trim tools, including Nudge Trim commands. See “Using the Trim Tools” on page 613 and “Trimming with Nudge” on page 659.*

---

### Manually Adjusting Fade Shapes in Fade Windows

If the Fade Shape setting for a Fade In, Fade Out, or Crossfade is set to Standard or S-Curve, Pro Tools lets you adjust the fade shape in the any of the corresponding Fade window (Fade In, Fade Out, and Crossfade) using the mouse. This includes Batch Fades and Fade windows in the Editing preferences.

**To adjust the fade (or crossfade) shape:**

1. Create a new fade (or crossfade) or open the Fade (or Crossfade) window for an existing fade (or crossfade).

2. Ensure that the Fade Shape is set to either Standard or S-Curve, and not to one of the seven preset Fade Shapes.

3. In the Fade (or Crossfade) window, click on the fade shape and drag to the left or the right until you get the fade shape you want.

4. Click OK.

**For Crossfades, you can edit only the fade-in shape of the curve by pressing Option (Mac) or Alt (Windows) while dragging left or right. To edit only the fade-out portion of the curve, press Command (Mac) or Control (Windows) while dragging.**

5. Option-click (Mac) or Alt-click (Windows) the fade curve to reset it to its default shape.

---

### Adjusting the Start and End Points of a Crossfade

If the Link setting for a Crossfade is set to Standard or None, Pro Tools lets you adjust the start and end points of the fade in and fade out of the crossfade independently. This includes the Batch Fades and Crossfade windows in the Editing preferences.

**To adjust the start and end points of a crossfade:**

1. Create a crossfade or open the Crossfade window for an existing crossfade.

2. Ensure that the Link setting for the Crossfade is set to None.
3 Do one or both of the following:
• To adjust the start point of either the Fade In or Fade Out of the crossfade, click and drag the black square that appears at the beginning of the fade to the right (or to the left if you have already changed the start point from the default location).
• To adjust the end point of either the Fade In or Fade Out of the crossfade, click and drag the black square that appears at the end of the fade to the left (or to the right if you have already changed the end point from the default location).

4 Once you have set the start and end points of the fades as you like, click OK to close the Crossfade window and apply your changes.

----

### Adjusting Fade Shapes with the Smart Tool in the Edit Window

Pro Tools lets you adjust fade and crossfade shapes in the Edit window using the Smart Tool.

#### To adjust a fade-in, fade-out, or crossfade in the Edit window:

1. Select the Smart Tool.
2. Position the cursor over the fade in the vertical middle of the clip until the corresponding Fade or Crossfade cursor appears.

   ![Smart Tool showing Fade-out cursor]

   **Smart Tool showing Fade-out cursor**

   If the Smart Tool Fade Adjustment preference is set to use the Command key (Mac) or the Control key (Windows), press the Command key (Mac) or the Control key (Windows) while positioning the cursor.

3. Click (the fade shape highlights yellow) and drag to the left or right to adjust the fade shape.

   ![Task Manager Status indicator, tasks in progress]

   **Task Manager Status indicator, tasks in progress**
4 Release the mouse when the fade shape is what you want.

Command-click (Mac) or Control-click (Windows) with the Selector Tool to adjust fades in the same way as with the Smart Tool.

If the Edit selection includes two or more tracks with more than one fade, hold the Shift key while adjusting the shape of a fade to change all fades in the Edit selection.

While adjusting a fade shape in the Fades dialog or using the Smart Tool in the Edit window, the exact curve and waveform update to match. After adjusting the fade curve and seeing the exact, real-time updates to the curve and waveform, the persistent fade drawn in the Edit window is a more general representation that may not look exactly like the fade curve when you were adjusting it.

Changing Fade Shapes in the Edit Window

Pro Tools lets you change the shape of any selected fade in the Edit window using keyboard shortcuts to cycle through all available fade shapes in order: Standard, S-Curve, and seven parabolic fade shapes (see “Fade-Out Shape Settings” on page 672 and “Fade-In Shape Settings” on page 673).

To change the fade shape of any fade in the Edit window:

1 Make an edit selection that includes the fade (or fades) you want to change. Only completely selected fades will be affected.

2 Do one of the following:
   • Press Option+Control+Left Arrow (Mac) or Alt+Start+Left Arrow (Windows) to change to the previous preset fade shape.
   • Press Option+Control+Right Arrow (Mac) or Alt+Start+Right Arrow (Windows) to change to the next preset fade shape.

Fades Options in the Edit Selection Right-Click Menu

Pro Tools lets you set the Fade Shape (Standard or S-Curve) and the Fade Slope (Equal Power or Equal Gain) for fades and crossfades from the Right-click menu in the Edit window. The corresponding Shape and Slope for the selected fade are checked in the menu. If the edit selection includes two or more fades with different Shape settings, the Standard and S-Curve options appear in italics (and with no check marks). Likewise, if the edit selection includes two or more fades with different Slope settings, the Equal Power and Equal Gain options appear in italics (and with no check marks).

You can also edit Batch Fades from the Right-click menu in the Edit window.

To set the Shape for a fade or crossfade in the Edit window:

1 Right-click the fade you want to change.

2 Select the desired Shape from Fades submenu:
   Standard or S-Curve.

To set the Slope for a fade or crossfade in the Edit window:

1 Right-click the fade you want to change.

2 Select the desired Slope from Fades submenu:
   Equal Power or Equal Gain.
To edit Batch Fades in the Edit window:

1. Make an Edit selection that includes multiple whole clips with fades.
2. Right-click the Edit selection and choose Fades > Batch Fades.
3. Configure the Batch Fades dialog as desired and click OK.

Moving and Nudging Fades and Crossfades

Fades and crossfades can be moved or nudged in tracks, independently of their contributing clips. Moving or nudging fade-ins or fade-outs reveals or hides audio as the fade is moved from the edge of a contributing clip. Moving or nudging crossfades changes the overlap point of the contributing clips. Moving or nudging fades is also constrained by underlying clip boundaries.

Moving or Nudging Fades or Crossfades within Clips

To move or nudge a fade or crossfade within its contributing clips:

1. Select the fade or crossfade by doing one of the following:
   • Use the Time Grabber tool to select the fade.
   • Use the Selector tool to select a range that includes the fade.

Moving Clips Containing Fades or Crossfades

When you move or nudge a clip selection that contains a fade-in, fade-out, or crossfade, the fade moves with the selection.

To move a clip selection with fades or crossfades:

1. Do one of the following:
   • Click a clip with the Time Grabber tool (or double-click with the Selector tool) to select the clip along with the fade (in or out).
   • Select multiple clips that include the fades and crossfades you want to move.
2 Move the clip selection by doing one of the following:

• Drag the clip selection with the Grabber tool to a new location on the track.
• Nudge the clip selection by pressing Plus (+) or Minus (−) on the numeric keypad to move the clip forward or backward on the track.

Nudging Clips Adjacent to Fade-Ins or Fade-Outs

When you nudge a clip selection adjacent to a fade-in or fade-out, but do not select the fade, the adjacent fade stretches or shrinks to maintain the fade start or end point. The amount of change depends on the amount of audio material outside the fade start or end point.

To a nudge clip without its fade:
1 Select the clip, but not the fade.
2 Nudge the clip by pressing Plus (+) or Minus (−) on the numeric keypad.

Moving Clips Adjacent to Crossfades

When you move either of the clips that contributes to a crossfade, the clips separate. The status of the fade depends on the Preserve Fades when Editing preference (in the Editing Preferences page).

To separate crossfaded clips and retain the corresponding fades:
1 Choose Setup > Preferences and click the Editing tab.
2 Select Preserve Fades when Editing.
3 Click OK to close the Preferences dialog.
4 Use the Time Grabber or Separation Grabber tool to select one of the contributing clips to a crossfade.

To separate crossfaded clips and remove the fade:
1 Choose Setup > Preferences and click the Editing tab.
2 Deselect Preserve Fades when Editing.
3 Click OK to close the Preferences dialog.
4 Use the Time Grabber or Separation Grabber tool to select one of the contributing clips to a crossfade.

5 Drag the selected clip with the Grabber.

Nudging Clips Adjacent to Crossfades

When you nudge either of the clips that contributes to a crossfade, the fade stretches to preserve the relative position of the crossfade start and end points. The amount of stretch depends on the amount of overlap between the contributing clips.

If you nudge a clip beyond the boundary of available audio for the crossfade, the fade is removed.

To nudge a clip and stretch its crossfade:
1 Use the Time Grabber tool to select one of the contributing clips to the crossfade.
2 Nudge the clip by pressing Plus (+) or Minus (–) on the numeric keypad.

Separating Clips that Include Fades or Crossfades

You can create clips from track material that overlaps with fades or crossfades. If the Preserve Fades when Editing option is enabled in the Editing Preferences page, the fades from the source clip are adjusted to the new clip.

To separate a clip that overlaps with a fade or crossfade:
1 With the Selector tool, drag to select the material for the new clip.
2 Choose Edit > Separate Clip > At Selection.

Where your selection overlaps any fade-ins or fade-outs, the fade is trimmed to fit the selection.
Where your selection overlaps a crossfade, the crossfade is separated into a fade-out and fade-in at the selection boundary.

Trimming Clips that Include Fades or Crossfades

You can trim clips that include fades or crossfades.

Trimming a Clip to a Fade Boundary

You can trim clips that are adjacent to fade and crossfade boundaries.

To trim a clip on a fade boundary:

- With the Trim tool, click the clip boundary and drag to trim the clip. The fade remains constant and follows the new clip boundary.

If the Preserve Fades when Editing option is not enabled in the Editing preferences, any fades within the selection are deleted when editing.
Trimming to a Selection Across Fades or Crossfades

You can trim clips to selections that include fades or crossfades.

To trim a clip to a selection that includes fades, do one of the following:

- Make a selection in the track and choose Edit > Trim > To Selection. You can Trim across multiple clips and fades. Affected fades are adjusted to the new clip boundaries.
- Click with the Selector in the clip and choose Edit > Trim > Start to Insertion or End to Insertion. You can trim to clip or fade boundary in the track.

Fade Boundaries and Shapes Displayed in Automation View

Fade boundaries and fade shapes are shown and can be edited in Automation views, allowing for more precise viewing and editing of automation data. For more information on Automation and Automation views, see Chapter 50, “Automation.”
Chapter 32: Playlists

The ability to create playlists is a powerful feature of Pro Tools. Each track maintains a “main” playlist and any number of “alternate” edit playlists.

*Edit playlists* let you take a snapshot of a track’s current arrangement of clips, thereby freeing you to experiment with alternate arrangements, returning as necessary to previously saved playlists.

A playlist, which can consist of a single clip or many clips, can only be assigned to a track if it is not in use by another track. While you can create an almost unlimited number of edit playlists, which are shared among all tracks, each track has its own dedicated automation playlist.

Automation playlists for audio, Auxiliary Input, Master Fader, and Instrument tracks store data for volume, pan, mute, and plug-in controls. Automation playlists for MIDI tracks, however, store only mute information; continuous controller events, program changes, and Sysex events are stored in MIDI clips and therefore reside within edit playlists for both MIDI and Instrument tracks (see Chapter 50, “Automation”).

### Working with Playlists

When you create a new track, it contains a single, empty playlist until you record, import, or drag and drop material to it.

Audio material can be dragged and dropped onto a track from the Clips List, Workspace browsers, from Windows Explorer or the Mac Finder.

New playlists can be created that are empty or duplicates of the current playlist. Once created, you can recall, rename, and delete playlists as needed by using the Playlist selector.

New and duplicated playlists are auto-named with the track name, followed by a Period (.) and the playlist number. For example, the first duplicated playlist on a track named “Kick” is auto-named “Kick.01,” subsequent duplicated playlists are auto-named “Kick.02,” “Kick.03,” and so on.
Creating a Playlist

You can create new empty playlists for recording or importing audio and MIDI. This can be useful for creating alternate takes of audio or MIDI, or for constructing alternate arrangements.

To create a new (empty) playlist:

1. Click the track’s Playlist selector and choose New.
2. Type a name for the new playlist and click OK.

An empty playlist with the specified name appears in the track.

Press Control+\ (Mac) or Start+\ (Windows) to create a new playlist for the first selected track in the session.

Duplicating a Playlist

When you edit a track, you can work with a copy of the track's playlist and keep the original playlist arrangement intact.

To duplicate a track’s current playlist:

1. Click the track’s Playlist selector and choose Duplicate from the pop-up menu.
2. Type a name for the new playlist and click OK.

The duplicated playlist appears in the track and the track’s name is changed to the name of the new playlist.

Press Command+Control+\ (Mac) or Control+Start+\ (Windows) to duplicate the main playlist for first selected track in the session.

Assigning a Playlist to Another Track

By default, a playlist is typically available only for the track on which it was created. However, if the playlist is no longer in use on its original track or any other track, it can be reassigned in another track using the Other Playlists feature. When a playlist is reassigned to another track (assigned on any track), it is unavailable to other tracks including the track on which it originated.

An audio playlist’s timebase is saved with the playlist. When assigning an unassigned playlist to any track, the track assumes the saved timebase of the playlist.

To assign a track playlist:

- Click the track’s Playlist selector and do one of the following:
  - Select one of the track’s playlists.
  - Select a playlist from a different track by clicking the Other Playlists submenu, and selecting a playlist.

Selecting a playlist from a different track

The selected playlist appears in the track and the track’s name is updated to that of the selected playlist.
Renaming a Playlist

You can rename a playlist by renaming the track to which it is assigned.

**To rename a track’s assigned playlist:**
1. Double-click the track’s name.
2. Type a new name and click **OK**.

Both the track and playlist names are updated.

Deleting a Playlist

You can delete a playlist from a session entirely. However, since playlists require minimal disk space, you do not need to delete them to conserve storage.

**To delete one or more playlists from a track:**
1. Click the track’s Playlist selector and choose **Delete Unused**.
2. Select the unassigned playlists you want to delete. Shift-click (Windows or Mac), Control-click (Windows), or Command-click (Mac) to select multiple playlists.
3. Click **OK** to delete the selected playlists. This operation cannot be undone.

💡 You can also delete playlists in Playlists view. Right-click the Playlist Name on a lane or in the Tracks List and choose **Delete**.

💡 When deleting a track from a session, you have the option of deleting or keeping its playlists, so they can be used on other tracks.

Show Next and Previous Playlist

Pro Tools lets you quickly and easily cycle through playlists on any track containing the Edit cursor using keyboard shortcuts.

To show the next playlist in the main playlist for tracks that contain the Edit cursor:
- Press Shift+Down Arrow.

To show the previous playlist in the main playlist for tracks that contain the Edit cursor:
- Press Shift+Up Arrow.

Additional Playlists Indicator

When a track contains only the main playlist, the Playlist selector is gray. However, when a track contains more than one playlist, the Playlist selector turns blue.

Two tracks, Audio 1 with main playlist only (gray) and Audio 2 with multiple playlists (blue)

Playlists and Edit Groups

Creating new playlists with grouped tracks automatically increments the suffixes of the playlist names for each track of the active edit group. This lets you revert back to an earlier take by switching the playlist takes by group.

Using this method, you can add new tracks to the existing group and the suffixes for their playlist names are synchronized with the original tracks.
Empty playlists are created automatically to keep the playlist takes synchronized when switching back to the earliest playlist takes in the group.

**To keep your playlist names and performances synchronized (example workflow):**

1. Create new tracks and group them together.

   *For more information on grouping tracks, see “Grouping Tracks” on page 277.*

2. Make sure the group is enabled.

3. Create a new playlist (by clicking the Playlist selector in one of the tracks in the group and choosing New). The default suffix will now be “.01”—signifying take 1.

4. Record take 1, then create a new playlist. The playlists on all tracks in the group increment to “.02.”

5. Create new tracks (for example, for an additional musician or microphone), then add these tracks to the group (or create a new group with all the tracks).

6. Increment all the playlists by clicking the Playlist selector in one of the tracks in the group and choosing New.

All the playlists will now have the same suffix appended to them. (Creating additional playlists in any of the group tracks will increment all of their playlists to keep them synchronized.)

7. If you want to hear the .01 take on the first group of tracks, you can switch any playlist in the group back to playlist .01.

All tracks in the group have playlists numbered with .01 suffixes (even those tracks that were added to the original group after the earlier takes). Empty playlists are automatically created on these newly-added members so that playlist numbers match across all members of the group.

**Elastic Audio and Alternate Playlists**

Alternate playlists on Elastic Audio-enabled, tick-based tracks are only affected by tempo changes. Otherwise, alternate playlists are not affected by editing Warp or Event markers in the main playlist.

**Track Compositing**

Pro Tools provides *track compositing* tools for audio tracks. Track compositing is the process of assembling various selections from alternate takes, or playlists, to construct the best possible version of a performance from multiple recording passes. Using Playlists view for an audio track, you can select the best parts from the track’s alternate playlists and copy them to the main playlist. This lets you quickly and easily create the “perfect take” from multiple alternate playlists.
**Track Compositing Example**

In this workflow, you will be introduced to some common track compositing tasks:

- Configure a session for this workflow.
- Loop record multiple takes on an audio track.
- Audition and select the best take.
- Copy the best take to the target playlist.

**To configure a session:**

1. Open an existing Pro Tools session or create a new one.
2. Choose Setup > Preferences, and click the Operation tab.
3. On the Operation page, in the Record section, select the Automatically Create New Playlists When Loop Recording option.
4. Click OK.

**To loop record multiple takes:**

1. Create a new audio track (stereo or mono), or use an existing track.
2. Make sure the source you want to record is correctly connected and routed to the track input.
3. From the Track View selector, select Playlists.
4. To hear track material up to the start point of the loop, enable pre-roll and set the pre-roll time.
5. Enable Loop Recording by doing one of the following:
   - Select Options > Loop Playback.
   - Right-click the Play button in the Transport and select Loop.
6. Make sure that Options > Link Timeline and Edit Selection is selected.
7. With the Selector tool, select the loop range on the track.
8. Record enable the audio track by clicking its Record Enable button.
9. Click Record in the Transport to arm Pro Tools for recording.
10. Click Play to start recording.
11. When finished, click Stop to stop recording.
12. If you do not want to make another loop record pass, record disable the audio track.

After you have stopped loop recording, notice that all of the loop recording takes are revealed in Playlist lanes below the main playlist (including the whole audio file clip of all of the loop record passes).

---

*If the Automatically Create New Playlists When Loop Recording option was disabled before you started loop recording, Right-click the clip in the main playlist and choose Matches > Expand Alternates to New Playlists.*
To hide the playlist for the whole file clip, do one of the following:

- Right-click on the Playlist lane and choose Hide.
- With the same Edit selection that you used for loop recording intact, Right-click the Track Name or any of the Playlist Lane Names and choose Filter Lanes > Show Only Lanes With > Clips Within the Edit Selection.

Filtering Playlist lanes viewed

To audition alternate playlists:

1. Enable Loop Playback by doing one of the following:
   - Select Options > Loop Playback.
   - Right-click the Play button in the Transport and select Loop.
2. With the same Timeline selection intact, and the same pre-roll/post-roll settings enabled, start playback. The main playlist plays back.
3. Click the Solo button for the alternate playlist lane you want to audition. Repeat this step for each playlist lane. (Soloing a Playlist lane only solos the playlist in the track, it does not mute any other tracks in the session.)

To select and copy the best take to the target playlist:

1. Once you have identified the best take, make any changes to the Edit selection. This is the selection that will be copied to the target playlist.
2. Do one of the following:
   - Choose Edit > Copy Selection To > Target Playlist.
   - Right-click the selection and choose Copy Selection to Target Playlist.
   - Click the Copy Selection to Target Playlist button for the Playlist lane.

Press Option+Control+V or Option+Shift+Up Arrow (Mac) or Alt+Start+V or Alt+Shift+Up Arrow (Windows) to copy the selection to the target playlist.
Playlists View

Playlists view lets you view the main playlist in the track, and also any alternate playlists associated with the track. Alternate playlists are displayed directly below the track in Playlist lanes.

You can edit alternate playlists in Playlists view just like the main playlist in Waveform view. In Playlists view, edits that are applied to range selections are applied to all shown alternate playlists. Alternate playlists that are not shown are not affected.

💡 Before starting work with Track Compositing, duplicate the track’s Main Playlist to keep it intact as a backup alternate playlist.

⚠️ Clip groups are not supported in Playlists Track View.

To view the Playlist lanes for a track:

- From the Track View selector, select Playlists.

If the track does not contain any alternate playlists in addition to the main playlist, only a single, empty Playlist lane is shown under the main playlist. You can drag and drop audio to this lane from the Clips List, Workspace Browsers, or other audio tracks to create an alternate playlist for the track, in addition to the main playlist.

Dropping audio from Clips List to create an alternate playlist

If the track contains one or more alternate playlists in addition to the main playlist, they are displayed in lanes under the main playlist. Regardless, the bottom Playlist lane is always empty and can be used for adding clips to create new alternate playlists.

Selecting Playlists Track view

You can also Command-Control-click (Mac) or Control-Alt-click (Windows) the Playlist selector to toggle between Playlists view and Waveform view.

Track with alternate playlists in Playlists Track view
Auditioning Alternate Playlists

Only the main playlist plays back through the track audio output path. To hear an alternate playlist, you need to solo the Playlist lane. The soloed lane then plays through the track audio output path instead of the main playlist.

To audition an alternate playlist:

1. Click the Solo button for the Playlist lane you want to audition. (Soloing a Playlist lane only solos the playlist in the track; it does not mute any other tracks in the session.)

2. Start Pro Tools playback.

- Press Shift+S to solo any one Playlist lane containing the Edit cursor. If more than one Playlist lane contains the Edit cursor, the topmost lane is soloed.

- Use Control+P and Control+“;” (Mac) or Start+P and Start+“;” (Windows) to move the Edit cursor up and down through Playlist lanes.

Copying and Pasting Edit Selections to Other Playlists

Once you have found a selection in a playlist that you want to use in another playlist (such as the main playlist), copy and paste the selection to the target playlist. In this way you can construct the best combination of selections from alternate playlists.

In addition to manually copying and then pasting the selection to another playlist, Pro Tools provides several commands for copying and pasting the selection to any other playlist:

- **Copy Selection To Target Playlist** Copies and pastes the selection to the target playlist. Any material already on the target playlist at the same location is overwritten.

- **Copy Selection to New Playlist** Creates a new, empty target playlist and copies and pastes the selection to the new target playlist.

- **Copy Selection to Duplicate Playlist** Duplicates the current target playlist and copies and pastes the selection to the duplicate of the target playlist. The previous target playlist moves to a new Playlist lane.
To copy a selection in an alternate playlist to the target playlist:

1. In Playlists view, make a selection in an alternate playlist.

2. Do one of the following:
   - Click the Copy Selection To Target Playlist button in the Playlist Lane controls.
   - Choose Edit > Copy Selection to Target Playlist.
   - Right-click the selection and choose Copy Selection To Target Playlist.

   - Press Option+Control+V (Mac) or Alt+Start+V (Windows) to copy the selection to the target playlist.

The selection from the alternate playlist is copied to the same time location in the target playlist.

To copy a selection in an alternate playlist to a new target playlist:

1. In Playlists view, make a selection in an alternate playlist.

2. Do one of the following:
   - Choose Edit > Copy Selection To > New Playlist.
   - Right-click the Edit selection and choose Copy To > New Playlist.
   - Press Control+Shift+Left Arrow (Mac) or Start+Shift+Left Arrow (Windows).

Selection copied to the target playlist

Selection copied to a new target playlist
To copy a selection in an alternate playlist to a duplicate of the target playlist:

1. In Playlists view, make a selection in an alternate playlist.

2. Do one of the following:
   - Choose Edit > Copy Selection To > Duplicate Playlist.
   - Right-click the Edit selection and choose Copy To > Duplicate Playlist.

To copy the current edit selection to an existing playlist:

1. Make an Edit selection.

2. Right-click the Edit selection and choose Copy To > <playlist>.

Cutting and Pasting Edit Selections to Other Playlists

Once you have found a selection in any playlist that you want to use in another playlist, you can move (cut and paste) the selection to any other playlist.

In addition to manually cutting and then pasting to another playlist, Pro Tools provides several commands for moving the selection to other playlists:

- **Move Selection To Target Playlist** Cuts and pastes the selection to the target playlist. Any material already on the target playlist at the same location is overwritten.

- **Move Selection to New Playlist** Creates a new, empty target playlist and cuts and pastes the selection to the new target playlist.

- **Move Selection to Duplicate Playlist** Duplicates the current target playlist, and cuts and pastes the selection to the duplicate of the target playlist. The result being that the previous target playlist moves to a new Playlist lane and the new target playlist is empty.

To move a selection in an alternate playlist to the target playlist:

1. In Playlists view, make a selection in an alternate playlist.
2 Do one of the following:
• Choose Edit > Move Selection To > Target Playlist.
• Right-click the Edit selection and choose Move To > Target Playlist.
• Press Option+Control+M (Mac) or Alt+Start+M (Windows).

The selection from the alternate playlist is moved to the same time location in the target playlist.

To move a selection in an alternate playlist to a new playlist:

1 In Playlists view, make a selection in any playlist.

2 Do one of the following:
• Choose Edit > Move Selection To > New Playlist.
• Right-click the Edit selection and choose Move To > New Playlist.
• Press Control+Shift+N (Mac) or Start+Shift+N (Windows).

To move a selection in an alternate playlist to a duplicate of the target playlist:

1 In Playlists view, make a selection in an alternate playlist.

2 Do one of the following:
• Choose Edit > Move Selection To > Duplicate Playlist.
• Right-click the Edit selection and choose Move To > Duplicate Playlist.
To move the current edit selection to an existing playlist:
1 Make an Edit selection.
2 Right-click the Edit selection and choose Move To > <playlist>.

Dragging Clips to Playlists Lanes
You can drag and drop clips to any available Playlist lane on any track that has the same channel width. For example, you cannot drag and drop a stereo clip to a mono track Playlist lane. Similarly, you can drag clips from any Playlist lane to any other track of the same channel width.

Editing in Playlist Lanes
You can edit clips in Playlist lanes in the same way that you do in the main playlist. You can even move clips between different Playlist lanes (including the main playlist), between different tracks, and to different points in time. However, you will not be able to hear your edits on Playlist lanes unless the lane you are editing is soloed (see “Auditioning Alternate Playlists” on page 698).

Reordering Playlist Lanes
You can reorder Playlist lanes the same way you reorder tracks.

To reorder Playlist lanes:
- Click the name of the alternate playlist and drag it to the location you want.

Resizing Playlist Lanes
You can resize Playlist lanes the same way you resize tracks.

To resize the track and all Playlist lanes together, do one of the following:
- Click the line in between lanes and drag up or down. The track and all Playlist lanes resize accordingly.
- Right-click the vertical scale between the playlist area and the Playlist Lane controls and select the lane size you want. The track and all Playlist lanes resize accordingly.

Press Control+Up/Down Arrow key (Mac) or Start+Up/Down Arrow key (Windows) to resize heights for tracks, playlists, and lanes containing the Edit cursor or Edit selection.
To resize a single Playlist lane, do one of the following:

- Control-click the line in between lanes and drag up or down. The upper lane resizes accordingly.

- Control-Right-click the vertical scale between the playlist area and the Playlist Lane controls and select the lane size you want.

### Renaming Alternate Playlists

You can rename alternate playlists the same way you rename tracks.

**To rename an alternate playlist:**

1. Double-click the name of the alternate playlist.
2. In the resulting Name dialog, type the name you want.
3. Click OK.

### Alternate Playlists in the Tracks List

When an audio track is set to Playlists view, all of its associated playlists appear listed under the track name in the Tracks List. The names of associated alternate playlists are indented to distinguish Playlist lanes from tracks. From the Tracks List you can show and hide alternate playlists. You can also access the Right-click menu for alternate playlists, which lets you apply Show or Hide, Scroll Into View, Rename, Delete, and Filter Lanes commands.
Filtering Lanes
You can filter Playlist lanes to show or hide them based on different criteria.

To filter Playlist lanes:
1 Right-click the Track Name or the Playlist Name.
2 From the Right-click menu, select one of the following:
   • Show All Lanes
   • Show Only Lanes With > Clips Within The Edit Selection
   • Show Only Lanes With > Clips Outside The Edit Selection
   • Show Only Lanes With > “Clips Rated >= 1–5”
   • Hide All Lanes
   • Hide Only Lanes With > Clips Within The Edit Selection
   • Hide Only Lanes With > Clips Outside The Edit Selection
   • Hide Only Lanes With > “Clips Rated >= 1–5”

Playlist lanes are shown and hidden accordingly.

Matching Alternate Clips
Pro Tools lets you exchange clips in the main playlist on tracks with matching alternate clips from other playlists associated with the same track, from other tracks, or from the Clips List. Matching alternate clips are clips that meet certain criteria. For example, clips that have the same User Time Stamp are matches.

There are several ways to create matching alternate clips in Pro Tools:
• When punch recording (audio or MIDI), Pro Tools creates matching clips for the original clip (if any) and the new punch recorded clip.
• When loop recording (audio or MIDI), Pro Tools creates multiple matching clips for each recording pass.
• When duplicating playlists (audio or MIDI), there will be matching alternate clips between playlists.
• When importing multichannel audio from a field recorder, there will be matching alternate clips between channels.

Pro Tools also provides several ways to access and audition multiple matching alternate clips:
• Use the Clip Right-click menu to select matching alternate clips according to certain criteria.
• Use the Alternate Takes pop-up menu to select matching alternate clips.
• Use the Expand Alternates to New Tracks command to copy matching alternate clips to new tracks.
• Use the Expand Alternates to New Playlists command to copy matching alternate clips to new alternate playlists on the same track. Then use Playlists view to access the alternate playlists.
Matching Criteria

The Matching Criteria window lets you select the criteria for matching alternate clips. This lets you refine the list of available matching clips in the Alternate Takes pop-up menu and Clip Right-click Matches submenu.

To configure the Matching Criteria options for matching alternate clips:

1. Do one of the following:
   - Right-click the clip with the Selector or the Grabber tool and select Matches > Match Criteria.
   - With the Selector tool, Command-click (Mac) or Control-click (Windows) at the precise beginning of the loop or punch range and select Match Criteria.

2. In the Matching Criteria window, select any combination of the following Alternates Match options:
   - Track ID
   - Track Name
   - Clip Rating

3. Select one of the following In Addition To options:
   - All
   - Clip Start
   - Clip Start and End
   - Within Selection
   - None

4. Leave the Matching Criteria window open to change the settings as appropriate while compositing tracks. Close the Matching Criteria window when you are done.

Matching Criteria settings are saved with your Pro Tools session.

Matching Criteria Options

Alternates Match Options

The following Alternates Match options can be selected in any combination:

- **Track ID** Any clips recorded to the same track are considered matching. Use this option for selecting alternate takes from loop or punch recording.

- **Track Name** Any clips that share the same root name with the track or playlist are considered matching. For example, the Matches for a track named “Gtr.L” would show the clips “Gtr.L_01” and “Gtr.L_02-01,” but not “Guitar.L_01.”

- **Clip Rating** Any clips that have the same Rating are considered matching. Enable this option if you have rated clips (see “Rating Clips” on page 667).
In Addition To Match Options

The following In Addition To Match options are mutually exclusive.

All Any clips that include the time location of the Edit cursor; or any clips that are either partly or fully within the current time range of the Edit selection.

Clip Start Any clips that have the same start time as the time location of the Edit cursor or Edit selection.

Clip Start and End Any clips that have the same start and end times as the Edit selection.

Within Selection Any complete clips that are entirely within the Edit selection.

None No other criteria in addition to the selected Alternates Match options are used to filter matching alternate clips.

To select an alternate take:

1. Configure the Matching Criteria window if necessary (see “Matching Criteria” on page 705).

2. Do one of the following:
   - Right-click the clip with the Selector or the Grabber tool, and select a matching alternate take from the Matches submenu in the pop-up menu.

Selecting Alternate Takes on Tracks

Each clip resulting from a punch or loop record pass has an identical start time (the User Time Stamp). You can select and audition alternate takes from the Right-click Matches submenu or the Alternate Takes pop-up menu—even during playback.

Right-click Matches submenu

- If the take currently residing in the track is selected, with the Selector tool, Command-click (Mac) or Control-click (Windows) anywhere on the selected take and select a different take from the Alternate Takes pop-up menu.

- With the Selector tool, Command-click (Mac) or Control-click (Windows) at the precise beginning of the loop or punch range and select a different take from the Alternate Takes pop-up menu.

To cycle through matches for the selected clip, press Command+Option+Up/Down Arrows (Mac) or Control+Alt+Up/Down Arrows (Windows).
The selected matching alternate clip (take) replaces the clip in the main playlist and snaps precisely to the correct location.

One way to ensure that subsequent recording takes have the same User Time Stamp (and as such can be available as matching alternate clips) is to store punch and loop record selections as Memory Locations. Then, if you later need to record additional takes, recall the corresponding Memory Location.

To change the User Time Stamp of other clips so that they can be available as alternate matching clips for a specific location, use the Time Stamp command in the Clips List menu.

**Matches and Multiple Tracks**

If you have loop recorded on multiple tracks, and each track contains multiple takes with identical User Time Stamps, you can change all takes simultaneously.

**To switch takes for multiple tracks:**

1. Configure the Matching Criteria window (see “Matching Criteria” on page 705), so that the following options are enabled:
   - Track Name
   - Selection Range
2. With the Selector tool, select the take range for each track you want to replace.
3. Do one of the following:
   - Right-click the Edit selection and select a different matching alternate take from the Matches submenu.
   - Command-click (Mac) or Control-click (Windows) the Edit selection and select a different take from the Alternates pop-up menu.

The selected take replaces the previous take and snaps to the correct location on each track.

**Automatically Create New Playlists when Loop Recording**

When loop recording, Pro Tools creates a single file containing all recording passes where each recording pass is a clip in the file. On the track, only the last recording pass is present as a clip in the main playlist. All other clips (recording passes) are hidden, but can be recalled as matching alternate clips (takes).

When enabled, the new Automatically Create New Playlists When Loop Recording option in the Operation Preferences page automatically copies each clip (take) to a new playlist in the track. This facilitates using Playlists view for auditioning and selecting alternate takes.

**To automatically create new playlists when loop recording:**

1. Choose Setup > Preferences and click the Operation tab.
2. In the Recording section, enable the Automatically Create New Playlists When Loop Recording option.
3. Click OK.

*For more information on loop recording, see “Loop Recording Audio” on page 528.*
Expanding Alternate Takes to New Playlists or Tracks

Pro Tools lets you copy alternate takes and channels to new playlists or tracks. This is useful for auditioning, editing, and mixing multiple alternate takes or channels. Alternate takes are created when punch and loop recording. Alternate channels are included with files imported into Pro Tools from field recorders.

Expanding Alternate Takes to New Playlists

Expanding alternate takes to new playlists readily facilitates track compositing. Once you have expanded alternate takes to new playlists on a track, you can audition and edit them in Playlists view to assemble the best takes in the main playlist.

To expand alternate takes to new playlists:

1. Identify the clip on the main playlist with matching alternate clips (takes).
2. Do one of the following:
   • Right-click the clip and choose Matches > Expand Alternates To New Playlists.
   • If the clip is selected, with the Selector tool, Command-click (Mac) or Control-click (Windows) anywhere on the selected clip and choose Matches > Expand Alternates To New Playlists.
   • If the clip is not selected, with the Selector tool, Command-click (Mac) or Control-click (Windows) at the precise beginning of the loop or punch range and choose Matches > Expand Alternates To New Playlists.

All matching alternate clips are copied to new playlists on the track. To view all playlists for the track, select Playlists view. In any track view, you can also select any available alternate playlist as the main playlist from the Playlist selector.

Expanding Alternate Takes to New Tracks

Expanding alternate takes to new tracks readily facilitates auditioning, editing, and mixing alternate takes, each on separate tracks.

To expand alternate takes to new tracks:

1. Identify the clip on the main playlist with matching alternate clips (takes).
2. Do one of the following:
   • Right-click the clip and choose Matches > Expand Alternates To New Tracks.
   • If the clip is selected, with the Selector tool, Command-click (Mac) or Control-click (Windows) anywhere on the selected clip and choose Matches > Expand Alternates To New Tracks.
   • If the clip is not selected, with the Selector tool, Command-click (Mac) or Control-click (Windows) at the precise beginning of the loop or punch range and choose Matches > Expand Alternates To New Tracks.
3. Then choose one of the following from the Expand Alternates To New Tracks sub-menu:
   • By Track Name Names all new tracks after the source track name.
   • By Clip Name Names each new tracks after the corresponding original clip names that you see in the Matches list.
   • By Track and Clip Name Names all new tracks after the source track name, but with the corresponding original clip names in parenthesis.

All matching alternate clips are copied to new tracks.
Expanding Alternate Channels to New Playlists or Tracks  
(Pro Tools | Ultimate Software Only)

When working with a mono clip that is part of a multichannel recording imported from a field recorder, you can expand that clip (or a selected portion of it) to new playlists that reflect its matching alternate channels while preserving any edits or fades (see Chapter 59, “Working with Field Recorders in Pro Tools”).

Conditions for Alternate Channel Availability

An alternate channel is available to replace the original channel (represented by the clip or portion of a clip selected on the Timeline) if all of the following are true:

• Both channels are part of a multichannel recording made simultaneously on one or more field recorders.
• Certain metadata matches between the original channel and the alternate channel.
• The metadata embedded during shooting and recording has been preserved prior to import into Pro Tools.

Expanding Channels to New Playlists

To expand alternate channels to new playlists:

1  In the Timeline, do one of the following:
   • To expand only a portion of the clips on the track, make a selection that includes or overlaps any number of clips on a track, and Right-click (Windows or Mac) or Control-click (Mac) the selection.
   • To expand all of the clips on the track, Right-click (Windows or Mac) or Control-click (Mac) the track name.

2  Choose the Expand to New Playlists pop-up menu, and select one of the following methods by which to expand alternate channels for the selection to new tracks:
   • By Channel Name
   • By Channel Number
   • By Channel Name and Number
   • By Timecode Only

With multichannel recordings from one or more field recorders, both channels must overlap at least once between their start timecode and end timecode positions, and must also meet one of the following conditions:

• Matching Scene and Take
• Matching Shoot Date (applies only if Scene and Take contain any information for both channels)
• Matching Tape name
• Matching Sound Roll name
• Alternate channel Sound Roll name matches current channel Tape name
• Alternate channel Tape name matches current channel Sound Roll name
If alternate channels are available, Pro Tools expands them to new playlists (including the channel represented in the original track) according to the selected option.

**Expanding Channels to New Tracks**

**To expand alternate channels to new tracks:**

1. In the Timeline, do one of the following:
   - To expand only a portion of the clips on the track, make a selection that includes or overlaps any number of clips on a track, and Right-click (Windows or Mac) or Control-click (Mac) the selection.
   - To expand all of the clips on the track, Right-click (Windows or Mac) or Control-click (Mac) the track name.

2. Choose the Expand Channels to New Tracks pop-up menu, and select one of the following methods by which to expand alternate channels for the selection to new tracks:
   - By Channel Name
   - By Channel Number
   - By Channel Name and Number
   - By Timecode Only

If alternate channels are available, Pro Tools expands them to new tracks (including the channel represented in the original track) according to the chosen parameters.

⚠️ *It is not possible to rename files encoded with XML metadata. The file extension will always be .A1 and .A2 (even for stereo files). Also, it is not possible to rename files with a .L/.R suffix. As a result, Pro Tools does not always recognize these channels as a stereo pair.*

**Expanding Channels by Timecode Only**

The Expand To New Tracks By Timecode Only command lets you expand an entire track or only selected clips to new playlists on the same track or to new separate tracks, thus revealing all other clips recorded at the same timecode location, regardless of channel name or number. This is especially useful when expanding edited guide tracks to original source audio that was recorded while referenced to timecode, but where channel names or numbers were not written to the audio files.

**Example Workflow: Working with a Guide Track for Live Concert Videos**

1. Multitrack audio is recorded in Pro Tools while chasing timecode. A mono or stereo mix is recorded simultaneously as a guide track for the video editor.

2. The picture and audio guide tracks are edited in a video editing application.

3. The edited audio guide tracks are exported from the video editor as an AAF (or OMF) sequence, including handles of at least 2 frames.

4. The AAF (or OMF) sequence is imported into Pro Tools as a new session. The original source audio files and unedited guide track are also imported into the session.

5. The original unedited guide track is relinked to the session (see “Relinking the Original Unedited Guide Track” on page 711).

6. The Pro Tools editor Right-clicks the name of the guide track and selects Expand Channels to New Tracks > By Timecode Only. The original source tracks expand to new tracks with edits and fades that match the guide track.
Relinking the Original Unedited Guide Track

After importing the AAF (or OMF) sequence and original source audio files into the session, it is recommended that you relink the edited guide track to the original unedited source audio.

To relink the original unedited guide track:

1 In the Workspace browser, locate the session and open the Audio Files folder.
2 Right-click the edited guide track audio file in the browser and choose Relink Selected.
3 In the upper pane of the Relink window, navigate to the original unedited guide track audio file that was recorded in Pro Tools.
4 In the Select Files To Relink pane, select the edited guide track file.
5 Drag the original unedited guide track audio file into the Candidates pane. If a dialog appears stating that one or more files are shorter than the media file you are trying to relink, click Yes to select it for relinking anyway.
6 Check the box to the left of the file in the Candidates pane so that the Link icon appears.
7 Click Commit Links at the top of the Relink window and then close the Relink window.
8 You can now Right-click the name of the guide track and select Expand To New Tracks > By Timecode Only. All expanded tracks should be synchronous with the guide track.

Target Playlist

Pro Tools lets you designate any playlist on a track as the Target playlist. You can then use key commands to do the following when compositing—or “comping”—multiple takes of a performance:

• Quickly cycle through and audition Edit selections for clips in other playlists, whether in Waveform or Playlist view.
• Copy or move an Edit selection to the Target playlist from Waveform view without having to switch to Playlist view.
• Composite Grouped tracks.

The Main playlist is the Target playlist by default.

Designating the Target Playlist

The designated Target playlist is the destination for all edits whether you are editing in Playlist view or Waveform view. Editing to Target playlists in Waveform view is especially useful when editing grouped tracks.

To designate any playlist as the Target playlist from any track view:

1 Click the Playlist selector.
2 Select Target Playlist > Main Playlist or <playlist name> for any other available playlist.

If the original unedited file is not available, you can relink to any of the source audio files as long as they have the same start and end times as the guide track.
In Playlist view, the Target button for the targeted playlist turns blue. If the Target playlist is displayed as the main playlist, the Playlist selector is blue. If the Target playlist is not displayed as the main playlist, the Playlist selector is orange.

To designate any playlist as the Target playlist from Playlists view:

1. Select Playlists view for the track you want to work with.
2. Click the Target button for the Playlist you want to designate as the target. The button turns blue.

💡 Click the Target button again to make the Main playlist the Target playlist.

Active Edit Groups are observed and kept in sync on the Timeline. For example, if 10 tracks are grouped and a Target playlist is defined on one of those tracks, the playlists on the other 9 tracks that correspond to that playlist are also designated as the Target playlist for their respective track.

⚠️ If a Clip Group spans multiple tracks, the Clip Group is broken if the any of the tracks in the Clip Group are not also Edit grouped when switching to Playlists view.

Designating the Target Playlist for a stereo audio track

Designating an alternate playlist in Playlists view (Playlist selector is orange to indicate that the playlist displayed as the Main playlist is not the target)

To designate the playlist currently displayed as the Main playlist as the Target playlist using key commands:

1. Place the Edit cursor in the playlist you want to target.
2. Press Command+Shift+Right Arrow (Mac) or Control+Shift+Right Arrow (Windows).

⚠️ Designating alternate playlists as the Target playlist using keyboard shortcuts is not currently supported.
Working with Target Playlists

After you have designated Target playlists for tracks you can work quickly when comping from different playlists using key commands. Key modifiers can also be used to target the same playlist in all tracks of the same type or in all selected tracks of the same type (audio, MIDI, Instrument, or Video).

To show the Target playlist as the Main Playlist:
- Press Shift+Right Arrow.

To toggle between the two most recently viewed Main playlists:
- Press Shift+Left Arrow.

To copy the current Edit selection to the Target playlist, do one of the following:
- Choose Edit > Copy To > Target Playlist.
- Right-click and choose Copy To > Target Playlist.
- Press Option+Shift+Up Arrow (Mac) or Alt+Shift+Up Arrow (Windows).
- Press Control+Option+V (Mac) or Start+Alt+V (Windows).

To move the current Edit selection to the Target playlist, do one of the following:
- Choose Edit > Move To > Target Playlist.
- Right-click and choose Move To > Target Playlist.
- Press Option+Shift+T (Mac) or Alt+Shift+T (Windows).

💡 This key combination replaces Option+Shift+M (Mac) or Alt+Shift+M (Windows) in executing the Move to Main Playlist command in lower versions of Pro Tools.

To target the same playlist in all tracks:
1. In Playlists view, Option-click (Mac) or Alt-click (Windows) the Target button for the playlist you want to target.
2. Hold Option (Mac) or Alt (Windows), click on the Playlist Selector menu, then click the Target Playlist sub-menu and click on the playlist you want to target.

To target the same playlist in all selected tracks:
1. In Playlists view, Option-Shift-click (Mac) or Alt-Shift-click (Windows) the Target button for the playlist you want to target.
2. Hold Option-Shift (Mac) or Alt-Shift (Windows), click on the Playlist Selector menu, then click the Target Playlist sub-menu and click on the playlist you want to target.

To focus the first playlist:
- Press Shift+Home (full-sized keyboard).
- Press fn+Shift+Left arrow (laptop).

To focus the last playlist:
- Press Shift+End (full-sized keyboard).
- Press fn+Shift+Right arrow (laptop).

To move ahead five playlists:
- Press Shift+Page Down (full-sized keyboard).
- Press fn+Shift+Down arrow (laptop).

To move back five playlists:
- Press Shift+Page Up (full-sized keyboard).
- Press fn+Shift+Up arrow (laptop).
Cycling Audio Within a Selection

To cycle in audio in the Edit selection from the previous playlist:

- Press Command+Shift+Up Arrow (Mac) or Control+Shift+Up Arrow (Windows).

To cycle in audio in the Edit selection from the next playlist:

- Press Command+Shift+Down Arrow (Mac) or Control+Shift+Down Arrow (Windows).

When cycling through playlists, when you return to the starting playlist a “home” icon appears, no clip edits are made, and any previous clip separation edits are healed.
**Visual Indicators when Working in Waveform View**

The following indicators provide visual feedback when working with Targeted Playlists in Waveform view.

- Immediately following the execution of either the Copy To Target Playlist or the Move To Target Playlist commands, a green checkmark icon, a light blue overlay the size of the selection, and the name of current Target playlist are briefly displayed in the center of the selection.

![Green checkmark over clip promoted to the Target playlist](image1)

- If you designate the playlist in the Main playlist view as the Target playlist (using either the keyboard shortcut or the menu command), a blue target icon and light blue overlay the size of the Main playlist are briefly displayed.

![Blue target indicating that the Main playlist is the Target playlist](image2)
• If you disable the Main playlist as the Target playlist (using either the keyboard shortcut or the menu command), a gray target icon and a light blue overlay the size of the Main playlist are briefly displayed.

Table 1. If you send a selection to the Target playlist from the Target playlist, a red “not allowed” icon is briefly displayed at the center of the selection.
**Track Compositing Keyboard Shortcuts**

Pro Tools provides a powerful combination of keyboard shortcuts to streamline track comping workflows.

*Table 2. Keyboard Shortcuts for Track Comping tasks*

<table>
<thead>
<tr>
<th>Action</th>
<th>Mac</th>
<th>Windows</th>
</tr>
</thead>
<tbody>
<tr>
<td>Solo the Playlist lane containing the Edit cursor</td>
<td>Shift+S</td>
<td>Shift+S</td>
</tr>
<tr>
<td>Move the Edit cursor up and down through Playlist lanes</td>
<td>Control+P and Control+Semicolon (;)</td>
<td>Start+P and Start+Semicolon (;)</td>
</tr>
<tr>
<td>Show the previous or next playlist in the main playlist for tracks that contain the Edit cursor</td>
<td>Shift+Up Arrow/Shift+Down Arrow</td>
<td>Shift+Up Arrow/Shift+Down Arrow</td>
</tr>
<tr>
<td>To designate the Target playlist for the playlist containing the Edit insertion</td>
<td>Command+Shift+Right Arrow</td>
<td>Control+Shift+Right Arrow</td>
</tr>
<tr>
<td>To designate the Target playlist for the playlist containing the Edit insertion for all tracks</td>
<td>Command+Option+Shift+Right Arrow</td>
<td>Control+Alt+Shift+Right Arrow</td>
</tr>
<tr>
<td>To show the Target playlist as the Main Playlist</td>
<td>Shift+Right Arrow</td>
<td>Shift+Right Arrow</td>
</tr>
<tr>
<td>To toggle between the current and most recent Main playlists</td>
<td>Shift+Left Arrow</td>
<td>Shift+Left Arrow</td>
</tr>
<tr>
<td>Copy the selection to the Target playlist</td>
<td>Option+Shift+Up Arrow or Option+Control+V</td>
<td>Alt+Shift+Up Arrow or Alt+Start+V</td>
</tr>
<tr>
<td>Move the selection to the Target playlist</td>
<td>Option+Shift+T</td>
<td>Alt+Shift+T</td>
</tr>
<tr>
<td>Copy the selection to a new playlist</td>
<td>Option+Shift+Down Arrow</td>
<td>Alt+Shift+Down Arrow</td>
</tr>
<tr>
<td>Move the selection to a new playlist</td>
<td>Option+Shift+N</td>
<td>Alt+Shift+N</td>
</tr>
<tr>
<td>To cycle in material in the Edit selection from the previous playlist</td>
<td>Command+Shift+Up Arrow</td>
<td>Control+Shift+Up Arrow</td>
</tr>
<tr>
<td>To cycle in material in the Edit selection from the next playlist</td>
<td>Command+Shift+Down Arrow</td>
<td>Control+Shift+Down Arrow</td>
</tr>
<tr>
<td>Create a new playlist for the first selected track in the session</td>
<td>Control+\</td>
<td>Start+\</td>
</tr>
<tr>
<td>Create a new playlist for each track in the session</td>
<td>Control+Option+\</td>
<td>Start+Alt+\</td>
</tr>
<tr>
<td>Create a new playlist for each selected track in the session</td>
<td>Control+Option+Shift+\</td>
<td>Start+Alt+Shift+\</td>
</tr>
</tbody>
</table>
Table 2. Keyboard Shortcuts for Track Comping tasks

<table>
<thead>
<tr>
<th>Action</th>
<th>Mac</th>
<th>Windows</th>
</tr>
</thead>
<tbody>
<tr>
<td>Duplicate the main playlist for the first selected track in the session</td>
<td>Command+Control+\ - \</td>
<td>Control+Start+\ - \</td>
</tr>
<tr>
<td>Duplicate the main playlist for each track in the session</td>
<td>Command+Option+Control+\ - \</td>
<td>Control+Alt+Start+\ - \</td>
</tr>
<tr>
<td>Duplicate the main playlist for each selected track in the session</td>
<td>Command+Option+Control+Shift+\</td>
<td>Control+Alt+Start+Shift+\</td>
</tr>
<tr>
<td>Focus the first playlist (with Edit selection in the Main playlist)</td>
<td>Shift+Home (full-sized keyboard) \</td>
<td>Shift+Home (full-sized keyboard) \</td>
</tr>
<tr>
<td></td>
<td>fn+Shift+Left Arrow (laptop)</td>
<td>fn+Shift+Left Arrow (laptop)</td>
</tr>
<tr>
<td>Focus the last playlist (with Edit selection in the Main playlist)</td>
<td>Shift+End (full-sized keyboard) \</td>
<td>Shift+End (full-sized keyboard) \</td>
</tr>
<tr>
<td></td>
<td>fn+Shift+Right Arrow (laptop)</td>
<td>fn+Shift+Right Arrow (laptop)</td>
</tr>
<tr>
<td>Move ahead five playlists (with Edit selection in the Main playlist)</td>
<td>Shift+Page Down (full-sized keyboard) \</td>
<td>Shift+Page Down (full-sized keyboard)</td>
</tr>
<tr>
<td></td>
<td>fn+Shift+Down Arrow (laptop)</td>
<td>fn+Shift+Down Arrow (laptop)</td>
</tr>
<tr>
<td>Move back five playlists (with Edit selection in the Main playlist)</td>
<td>Shift+Page Up (full-sized keyboard) \</td>
<td>Shift+Page Up (full-sized keyboard)</td>
</tr>
<tr>
<td></td>
<td>fn+Shift+Up Arrow (laptop)</td>
<td>fn+Shift+Up Arrow (laptop)</td>
</tr>
<tr>
<td>Target the same playlist in all audio tracks</td>
<td>Shift-click the Target button for the</td>
<td>Shift-click the Target button for the</td>
</tr>
<tr>
<td></td>
<td>playlist you want to target</td>
<td>playlist you want to target</td>
</tr>
<tr>
<td>To target the same playlist in all tracks of the same type (audio,</td>
<td>Shift-click the playlist you want to</td>
<td>Shift-click the playlist you want to</td>
</tr>
<tr>
<td>MIDI, Instrument, or Video)</td>
<td>target in the Playlist selector menu</td>
<td>target in the Playlist selector menu</td>
</tr>
<tr>
<td>Target the same playlist in all selected audio tracks</td>
<td>In Playlists view, Option-Shift-click</td>
<td>In Playlists view, Alt-Shift-click the</td>
</tr>
<tr>
<td></td>
<td>the Target button for the playlist you</td>
<td>Target button for the playlist you</td>
</tr>
<tr>
<td></td>
<td>want to target</td>
<td>want to target</td>
</tr>
<tr>
<td>Target the same playlist in all selected tracks of the same type (</td>
<td>Option-Shift-click the playlist you</td>
<td>Alt-Shift-click the playlist you</td>
</tr>
<tr>
<td>audio, MIDI, Instrument, or Video)</td>
<td>want to target in the Playlist selector</td>
<td>target in the Playlist selector menu</td>
</tr>
<tr>
<td></td>
<td>menu</td>
<td></td>
</tr>
</tbody>
</table>
Chapter 33: Beat Detective

Beat Detective is a powerful tool for analyzing, editing, and manipulating audio or MIDI data that has an inherent rhythmic character.

Beat Detective analyzes an audio or MIDI selection, identifies its peak transients or accented notes, and generates beat triggers based on the detected peak transients or MIDI notes. From these beat triggers, Beat Detective can:

- Extract tempo and beat information to create Bar|Beat Markers that can be used to define the session’s tempo map. See “Generating Bar|Beat Markers with Beat Detective” on page 730.

- Extract tempo and groove information as groove templates, called DigiGrooves. These templates can be applied to audio or MIDI using Beat Detective or Groove Quantize (see “DigiGroove Templates” on page 731.

- Separate an audio selection into discrete clips, and then conform (or “quantize”) separated clips to the session’s tempo map, or to groove templates. See “Separating Clips with Beat Detective” on page 733 and “Conforming Clips with Beat Detective” on page 734.

Beat Detective and Source Material

Beat Detective is most effective with audio or MIDI that has clear attack transients or accent patterns (including most instruments used in popular music, such as drums, guitar, or bass). Beat Detective will be less successful with audio material with soft attacks, or legato phrasing (such as strings and vocals).

Uses for Beat Detective

Beat Detective can be useful in many situations, including:

Extracting Tempo from Audio and MIDI Beat Detective can generate Bar|Beat Markers, from which it can extract the tempo—even if the audio or MIDI contains varying tempos, or material with a swing feel. Additionally, once Bar|Beat Markers have been generated, other audio and MIDI clips and events can be quantized to them.

Creating DigiGrooves Beat Detective can extract groove templates, called DigiGrooves, from an audio or MIDI selection. DigiGrooves can be used to apply the groove, or feel of the captured passage to other audio selections (using Groove Conform) or MIDI data (using Groove Quantize).

Conforming Audio Clips Beat Detective can conform (“quantize”) audio with a different tempo, or with varying tempos, to the session’s current tempo map, or to a groove template.
“Tightening Up” Performances Beat Detective can be used to improve the timing of some audio material by calculating and extracting its average tempo, and then conforming its rhythmic components—clips separated with Beat Detective—to the session’s tempo map.

Loop Matching Since Beat Detective can extract tempo and beat information from audio and MIDI, and conform audio to an existing tempo map or groove template, this makes it very useful for aligning loops with different tempos or grooves. If a loop is at a different tempo than the current session, Beat Detective lets you quickly separate each beat in the loop and conform them to the tempo map (as an alternative to time compressing or expanding the loop, which can alter the pitch and tone of the audio).

Remixes Beat Detective can be used for remixes or creating new rhythms. It can extract tempo from the original drum tracks, or in some instances the original stereo mix. New audio or MIDI tracks can then be conformed to the original material, or the original material can be conformed to new drum tracks, achieving an entirely new feel.

💡 When working with tick-based audio, use Beat Detective’s Clip Separation command to quickly separate audio clips into individual “hits” (or slices). You can also create a clip group of the separated clips to facilitate editing and arranging.

Smoothing Post Production Edits (Audio Only) Beat Detective’s Edit Smoothing can be used to automatically clean up Foley tracks that contain many clips requiring trimming and cross-fading, effectively removing the gaps of silence between the clips (thus retaining the room tone throughout the track).

Beat Detective Requirements

Beat Detective is available with all Pro Tools systems.

RAM Requirements for Beat Detective

Beat Detective operations can require a large amount of RAM, especially when working with multiple tracks and lengthy selections. To avoid low memory situations with Beat Detective, do the following:

- If you begin to experience slower Beat Detective response, add more RAM to your computer.
- If your computer does not have extra RAM, work with shorter selections, or individual tracks.
- Set the Editing preference for Levels of Undo to a smaller value (see “Levels of Undo and Memory” on page 594). Memory-intensive editing operations, such as Edit Smoothing (audio only) with Beat Detective, can use up a large amount of memory when in the Undo queue.
The Beat Detective Window

Beat Detective is managed from the Beat Detective window.

The Beat Detective modes include the following:

**Operation** Lets you choose to analyze either MIDI or audio material.

**Bar|Beat Marker Generation** Generates Bar|Beat Markers corresponding to transients detected in the audio selection or according to accent patterns with MIDI notes.

**Groove Template Extraction** Extracts the rhythmic and dynamic information from audio or MIDI, and saves this information to the Groove Clipboard, or as a DigiGroove template.

**Clip Separation (Audio Only)** Separates and creates new clips based on transients detected in the audio selection.

**Clip Conform (Audio Only)** Conforms all separated clips within the selection to the current tempo map. Beat Detective can conform audio clips to groove templates (such as DigiGroove templates) in addition to standard quantization.

**Edit Smoothing (Audio Only)** Fills the gaps between conformed clips by automatically trimming them, and inserts crossfades.
Defining a Beat Detective Selection

Whether you will be generating Bar|Beat Markers, extracting a DigiGroove template, or separating clips to be conformed, you must always define the audio or MIDI selection to be analyzed. The Beat Detective window provides tools to define and capture the selection range, time signature, and swing (sub-division) content for the selected audio.

For Beat Detective to generate beat triggers that are metrically accurate, the length and meter of the selection must be correctly defined. In addition, the selection should not contain any meter or tempo changes.

- **To ensure the best possible results with Beat Detective, make sure the selected passage starts exactly on the attack of the first beat.**

To define a selection for Beat Detective:

1. In the Edit window, select a range of audio or MIDI material in a single track or in multiple tracks.

- **To keep the Edit selection intact while playing or looping from any location, deselect Options > Link Timeline and Edit Selection.**

2. Choose Event > Beat Detective.

3. You must define or capture the selection every time you make a new selection or change the tempo map. To define the selection range, do one of the following:
   - If the tempo and meter of the audio selection do not match the session’s default tempo and meter, enter the Time Signature, and Start Bar|Beat and End Bar|Beat locations. For a four-bar selection that starts on beat 1, enter 1|1 and 5|1.
   - If the tempo and meter of the audio selection do not match the session’s default tempo and meter, and you are unsure of the length of the material, enter the Time Signature and the Start Bar|Beat location; then start playback, and click the Tap End B|B button repeatedly to automatically calculate the End Bar|Beat. When using Tap End B|B with long selections, continue to tap until the End Bar|Beat stabilizes. Once stabilized, you may need to manually adjust the number to the nearest bar boundary.

- **To avoid losing an existing selection, save and recall an Edit selection by saving it as a Memory Location. See Chapter 39, “Memory Locations.”**

Make sure the selection’s start and end points fall cleanly on the beat. To zero in on an audio clip’s start and end points, zoom to the sample level and use the Tab to Transients option (see “Tabbing to Transients” on page 641).

Making an audio selection for Beat Detective
If the selection’s tempo and meter match the session tempo and meter (see “Calculating Tempo with Beat Detective” on page 724), and it aligns correctly with the session’s bars and beats, click the Capture Selection button. The correct Time Signature, and Start Bar|Beat and End Bar|Beat values will be filled in automatically.

Beat Detective Analysis

Beat Detective provides several analysis algorithms for beat detection appropriate to different types of audio material.

High Emphasis Works well with high frequency, inharmonic material, such as cymbals and hi-hats, while avoiding low frequency material.

Low Emphasis Works well with low frequency material, such as bass guitar and kick drum, as well as with most harmonic material, such as piano or rhythm guitar.

Enhanced Resolution Works well with the broadest range of material, such as full mixes and loops.

Beat Detection Across Multiple Tracks

When analyzing a selection with multiple tracks, Beat Detective analyzes each independently. Transients that are detected in any track appear as Beat Triggers across all selected tracks regardless of whether or not the detected transient resides in any other track. However, for closely aligned events on multiple tracks, Beat Detective only identifies the first detected transient of a beat event.

For example, if you have four drum tracks—kick, snare, and a pair of overheads—transients in the overhead mics tracks occur a little later than the closely miked snare and kick tracks because it takes more time for the sound to travel from the source to the microphones. If you make a selection across all four tracks and analyze them using Beat Detective, only the transients in the kick and snare tracks will be identified as beat triggers because the transients on overheads will be recognized as being part of the same beat events (only a little bit late). For information on individually analyzing multiple tracks, see “Using Collection Mode” on page 740.

As long as the audio material is correctly aligned with the session’s tempo map, use Capture Selection each time you make a new selection or make any changes to the tempo map (such as changing tempo or meter).

The Selection definition is not retained when a session is closed and re-opened.

To improve Beat Detective’s accuracy in analyzing swung notes, select the Contains option that indicates the smallest sub-division of the beat contained in the selection. The Contains option includes quarter-notes, eighth-notes, sixteenth-notes (the default setting), thirty-second-notes, and a triplet modifier. The selected Contains option determines the groove template grid locations for DigiGroove templates.

4
Calculating Tempo with Beat Detective

If you know the meter, and start and end points of the audio selection, use Beat Detective to calculate its tempo.

To calculate a selection’s tempo with Beat Detective:

1. Make an Edit selection in the Edit window or a MIDI Editor window (MIDI only) and define the selection in the Beat Detective window as described in “Defining a Beat Detective Selection” on page 722.

2. Select Bar|Beat Marker Generation.

3. In the Detection section (Normal mode), click Analyze.

4. Set Sensitivity set to 0%.

5. Click Generate.

Bar|Beat Markers are automatically generated at the beginning and end of the selection, indicating the material’s tempo and meter.

Generating Beat Triggers

Once you have accurately defined the selection range, Beat Detective can generate beat triggers based on detected MIDI notes or audio peak transients. The range and type of transients found can be adjusted with the Detection settings, allowing you to zero in on the bars, beats, and sub-beats in the material, while avoiding the non-rhythmic content.

To generate beat triggers from an audio selection:

1. In the Edit window, make an audio selection.

2. Select Audio from the Operation pop-up menu.

3. In the Beat Detective window, select one of the following modes:
   - Bar|Beat Marker Generation
   - Groove Template Extraction
   - Clip Separation (audio only)

4. Define or capture the selection as described in “Defining a Beat Detective Selection” on page 722.

5. From the Analysis pop-up menu, choose a detection algorithm.

6. Click Analyze.

7. Depending on the rhythmic content of the selection, set the Resolution to Bars, Beats, or Sub-Beats.

8. Adjust the Sensitivity until beat triggers appear on the beats and sub-beats in the selection.
Bar triggers are indicated with thick lines, beat triggers with medium lines, and sub-beat triggers with thin lines.

Beat triggers

9 You can zoom to the sample level and click the Scroll Next button to scroll to the next trigger within the selection. To scroll to the previous trigger, Option-click (Mac) or Alt-click (Windows) the Scroll Next button (see “Navigating Consecutive Beat Triggers” on page 729). This is useful to confirm that the beat triggers are appearing in the appropriate locations. If false triggers appear between the beats or sub-beats (representing non-rhythmic material), delete them (see “Deleting Beat Triggers” on page 728), or reduce the Sensitivity value.

10 To display the metric locations for the triggers, select the Show Trigger Time option.

11 If you cannot get the beat triggers to appear at the right locations, repeat steps 5–10, trying one of the other Analysis algorithms (High or Low Emphasis).

To generate beat triggers from a MIDI selection:

1 In the Edit window, set the MIDI track you want to use to Notes view.

2 In the Edit window, or in a MIDI Editor window, make a selection across a range of MIDI notes. Make certain that the selection start and end points are at musically relevant locations, such as barlines.

3 Choose Event > Beat Detective.

4 Select MIDI from the Operation pop-up menu.

5 In the Beat Detective window, select one of the following modes:
   • Bar|Beat Marker Generation
   • Groove Template Extraction

6 Define the selection range. If the tempo and meter of the audio selection do not match the session’s default tempo and meter, enter the Time Signature, and Start Bar|Beat and End Bar|Beat locations. For example, for a four-bar selection that starts on beat 1, enter 1|1 and 5|1.

7 If your MIDI track contains chords, choose one of the following MIDI chord recognition algorithms from the Analysis pop-up menu:
   • Last Note
   • First Note
   • Loudest Note
   • Average Location
   • Highest Note
   • Lowest Note

8 Click Analyze.
MIDI Chord Recognition

Since MIDI notes in a chord may be played at slightly different moments, Beat Detective interprets notes that are close together (closer than half the time value that is set in the Selection Contains field) as a chord.

![MIDI chord analysis](image)

**MIDI chord analysis**

Beat Detective uses the criteria you set in the Analysis pop-up menu to interpret the location of the beat in relation to the chord.

**Last Note** Sets the beat trigger to the start of the last note played in the chord.

**First Note** Sets the beat trigger to the start of the first note played in the chord.

**Loudest Note** Sets the beat trigger to the start of the note in the chord played with the highest velocity.

**Average Location** Sets the beat trigger to a point that represents the average between the start of the first note played in the chord, and the last note played in the chord.

**Highest Note** Sets the beat trigger to the start of the highest note played in the chord.

**Lowest Note** Sets the beat trigger to the start of the lowest note played in the chord.

Realign Session

Beat Detective’s Realign Session function lets you generate Bar|Beat markers without tick-based material shifting. This is useful if you want to extrapolate Bar|Beat markers from tick-based material to align the tempo map and Bar|Beat grid to the tick-based material.

💡 You can also switch tick-based material, such as a MIDI performance, to be sample-based and then manually insert Bar|Beat markers.

Generating Bar|Beat markers in sessions with tick-based material, such as MIDI tracks and tick-based audio tracks, can cause the tick-based material to shift in absolute time. This can be useful if you want to align the tick-based material to Bar|Beat markers generated from sample-based material.

When you generate Bar|Beat Markers in a session that contains tick-based audio or MIDI, Beat Detective gives you the option to preserve the position of the session’s tick-based material, or to allow the material to shift.

[Realign Session dialog](image)
To generate Bar|Beat Markers with Beat Detective in a session with tick-based tracks:

1. In the Edit window, make an audio or MIDI selection.
2. In the Beat Detective window, select Bar|Beat Marker Generation.
3. Define or capture the selection as described in “Defining a Beat Detective Selection” on page 722.
4. Set the Resolution to Bars or Beats.
5. Click Generate.
6. Do one of the following:
   - In the Realign Session dialog, choose Preserve Tick Position if you want to let the tick-based material shift in absolute time.
   - Choose Preserve Sample Position if you want to have the tick-based material maintain its absolute position. This option can be useful when adding a meter and tempo map to a freely played performance.
7. Click OK.

Tips for Getting Useful Beat Triggers

Use the following tips to verify beat triggers:

- To focus on a particular area in the selection, unlink the Timeline and Edit Selections and set the playback range by clicking or dragging in any Timebase ruler.
- Check the thickness of the beat triggers to see if they align properly with the audio material. Thick triggers fall on barlines, medium triggers fall on beats, and thin triggers fall on sub-beats.
- Select the option for Show Trigger Time and see if the (assumed) metric locations of the triggers align with the material. A false trigger should be moved or deleted because it can cause subsequent triggers to appear in the wrong locations (see “Editing Beat Triggers” on page 728).
- Consider whether lengthy selections should first be broken down into smaller selections, which could be more easily managed. For example, working in 8- or 4-bar sections might yield better results more quickly.
- Beat triggers are preserved when switching between audio and MIDI modes. This allows using MIDI triggers for editing audio, or collecting triggers from combinations of MIDI and audio tracks.
- For selections across multiple tracks, consider whether it may be easier to work with them individually, or in Collection mode. See “Detection (Normal) and Collection Mode” on page 739.
Editing Beat Triggers

Even though Beat Detective offers a great deal of flexibility in how transients are detected, there may be times when beat triggers must be deleted, moved, or manually inserted. Additionally, triggers can be promoted so they are retained at lower sensitivity settings.

Deleting Beat Triggers

False triggers, which do not represent an actual beat or sub-beat in the source material, may appear when raising the Sensitivity to detect quiet material. In these instances you can locate and manually delete any false triggers.

To delete a beat trigger:

1. With the Beat Detective window open, select any Grabber tool in the Edit window.
2. Locate the false trigger you want to delete. Transients for false triggers usually have smaller peaks than the other trigger points, and typically fall between the sub-beats.
3. Option-click (Mac) or Alt-click (Windows) the trigger to delete it.

Moving Beat Triggers

You can adjust the placement of triggers to allow for the attack of their transients, or to compensate for an individual transient that is slightly ahead of or behind the beat.

To move a beat trigger:

1. With the Beat Detective window open, select any Grabber tool in the Edit window.
2. Locate the beat trigger you want to move and drag it left or right.

Inserting Beat Triggers

If an important beat or sub-beat is not detected, because it is too quiet, you can manually insert a beat trigger.

To insert a beat trigger:

1. With the Beat Detective window open, select any Grabber tool in the Edit window.
2. Click in the selection where you want to insert the new trigger. After inserting a beat trigger, you can drag it left or right to adjust its placement (see “Moving Beat Triggers” on page 728).

⚠ If you click too close to an existing trigger, the existing trigger will be moved to the new location.
Promoting Beat Triggers

To ensure that important beat triggers do not disappear when lowering the Sensitivity, you can promote them. This is useful if a selection has numerous false triggers (too many to bother deleting) at a Sensitivity level where crucial, necessary beat triggers are also displayed. If lowering the Sensitivity and the needed triggers to disappear, simply promote them first.

To promote a beat trigger:
1. Raise the Sensitivity until the transient is detected and a beat trigger appears.
2. Command-click (Mac) or Control-click (Windows) the beat trigger to promote it.
3. If necessary, repeat steps 1–2 to promote additional beat triggers.
4. Lower the Sensitivity to a value where the false triggers disappear.

Once beat triggers are promoted, they will only disappear if the Sensitivity value is set to 0%. To demote all beat triggers in the selection—returning them to their original state—click the Analyze button.

Redefining a Beat Trigger’s Metric Location

It is vital that beat triggers are accurately placed at the correct metric location. If a detected transient is slightly off the beat, Beat Detective may assign it, as well as other transients in the selection, to the wrong metric location.

For example, if you have a bass track where a note was intended to be a downbeat, but was played too early, Beat Detective may define its location as occurring a little before the downbeat. If you then separate and conform the clip containing this note, it will be moved to the wrong location. Subsequent clips may be moved to the wrong locations as well.

If a beat trigger is not assigned the correct metric location, relocate it using Identify Trigger.

To change the metric location of a beat trigger:
1. Double-click the beat trigger you want to relocate. The Identify Trigger dialog opens.
2. In the Identify Trigger dialog, enter the correct location for the trigger, then click OK.

Navigating Consecutive Beat Triggers

Use the Scroll Next button to move from the currently selected beat trigger to the next beat trigger. To move to the previous beat trigger, Option-click (Mac) or Alt-click (Windows) the Scroll Next button. This is particularly useful for editing consecutive beat triggers when zoomed in at the sample level.
Generating Bar|Beat Markers with Beat Detective

Once Beat Detective has accurately detected the peak transients in the audio selection and accurately generated beat triggers, the triggers can be converted to Bar|Beat Markers. Bar|Beat Markers generated by Beat Detective create a tempo map that can be used throughout the session.

Once a tempo map has been generated, other audio clips and MIDI notes can be conformed to the Bar|Beat Markers generated by Beat Detective.

If you want to match the audio material to the session’s existing tempo map or a groove template, do not generate Bar|Beat Markers from the material. Instead, use Beat Detective to separate and conform the material (see “Separating Clips with Beat Detective” on page 733).

💡 If you are simply aligning a sloppy part to the other tracks, you probably do not need to generate Bar|Beat markers.

To generate Bar|Beat Markers with Beat Detective:

1. Make an Edit selection.
2. In the Beat Detective window, select Bar|Beat Marker Generation mode.
3. Define or capture the selection as described in “Defining a Beat Detective Selection” on page 722.
4. Set the Resolution to Bars or Beats, and configure the Detection setting so the selection’s peak transients (or MIDI Note Ons) are accurately detected (see “Generating Beat Triggers” on page 724).
5. Click Generate.

Bar|Beat Markers are generated, based on the beat triggers, and appear in the Tempo ruler.

Working with Sub-Beats

Tempo is derived from Bar|Beat Markers. Groove, or feel, is derived from Sub-Beats—the deviation of subdivisions of the beat from the strict tempo grid determines the groove or feel.

To extract the groove from a selection, set the Detection Resolution to Sub-Beats. This ensures that the inner rhythms within each bar (if they indeed exist) are represented when generating Bar|Beat Markers. These Bar|Beat Markers can then be used to quantize other audio clips or MIDI tracks, thereby conforming to the Bar|Beat Markers generated by Beat Detective.

⚠️ When quantizing clips or MIDI notes to Bar|Beat Markers on sub-beats that represent a swing feel, make sure to use a straight quantize value (with the Swing option for Quantize disabled).
DigiGroove Templates

Beat Detective allows the fine timing nuances of a rhythmic performance to be extracted and saved as a groove template, called a DigiGroove template. DigiGrooves can be saved locally to the Groove Clipboard, or saved to disk as DigiGrooves.

Groove templates can be used to transfer the feel of a particular performance to:

• Selected audio clips using Groove Conform (see “Groove Conform” on page 736).
• Selected MIDI data using Groove Quantize (see “Groove Quantize” on page 1012).

Groove templates are “quantization maps” derived from real musical performances. The rhythmic character of each performance is analyzed and stored as a groove template. Beat Detective analyzes an audio selection for transient peaks according to a defined threshold and maps the rhythmic relationships to a 960 parts per quarter note (ppq) template.

When creating DigiGroove templates, Beat Detective also analyzes the dynamics of a performance. MIDI velocity data is saved from MIDI tracks, and accents and peak levels in audio data are incorporated into the groove template as velocity data, which can be applied to change the dynamics of MIDI tracks.

Beat Detective translates the amplitude of signals in audio tracks to MIDI velocity according to a linear scale. For example:

• A 0 dBFS signal equals a MIDI velocity of 127.
• A –6 dBFS signal equals a MIDI velocity of 64.
• A –12 dBFS signal equals a MIDI velocity of 32.
• A –48 dBFS signal equals a MIDI velocity of 1.

Capturing this information is very important to preserving the feel of a performance, and can add life to MIDI tracks that lack dynamics.

⚠️ Beat Detective only captures duration data from MIDI tracks, not from audio tracks.

Extracting Groove Templates

To extract a Groove Template:

1 In the Edit window, make an Edit selection (including audio or MIDI). The selection should consist of one or more complete bars, starting and ending on downbeats.

⚠️ When extracting Groove Templates, the captured selection must not include Bar|Beat Markers. Otherwise, the accuracy of the Groove Template will be compromised.

2 In the Beat Detective window, select Groove Template Extraction.

3 Define or capture the selection as described in “Defining a Beat Detective Selection” on page 722.

4 Configure the Detection options so the selection’s peak transients (or MIDI Note Ons) are accurately detected (see “Generating Beat Triggers” on page 724).

5 Click Extract.

6 In the Extract Groove Template dialog, enter comments about the groove. You can enter a maximum of 255 characters to describe the groove. Comments can be viewed using the Show Info button in the Beat Detective window.
Do one of the following:

- To save the extracted template for use in the current session, without writing the template file to disk, click **Save To Groove Clipboard**. (This template will be lost when you close the current session.)

- To save the extracted template to disk in order to use it in other sessions or share it with other Pro Tools users, click **Save To Disk**. Enter a name for the template and click **Save**. (Do not change the location of DigiGroove template files and folders or they will not be available in your sessions.)

- Click **Cancel** to cancel without saving the template.

**Swing Content for Generating Groove Templates**

When defining swing content of the selection, select the **Contains eighth-note** option if the audio selection has a heavily swung eighth-note groove. If the audio selection has relatively straight eighth-notes, use the **Contains sixteenth-note** option. This lets the resultant DigiGroove template be applied more easily elsewhere. Although a groove might be based upon non-swung eighth-note material, you might want to apply the template to material that contains sixteenth-notes. If a template only has eighth-note resolution, but the material being conformed contains sixteenth-notes, adjacent sixteenth-notes will be mapped to the same eighth-note location.

**Groove Extrapolation**

Beat Detective’s ability to extract tempo data from a wide range of material is enhanced by its powerful “groove extrapolation” logic. Groove extrapolation automatically generates beat triggers for inclusion in groove templates even if a peak transient is not detected. For example, a drum loop might not have a hit on beat 3, consequently no peak transient is detected and no beat trigger is generated. Beat Detective will extrapolate from other beat triggers in the selection and create a trigger for beat 3 in the groove template.

In addition, extrapolated triggers preserve the feel of triggers generated from detected peak transients. For example, if a bar of kick drum detected three beat triggers, all of which were 20 ticks ahead of the beat, any extrapolated beat triggers will also be mapped 20 ticks ahead of the beat.
Separating Clips with Beat Detective
(Audio Only)

Once beat triggers appear in your selection, they can be used to define start and end points for new clips that can be separated automatically. The new clips can then be conformed to the session’s existing tempo map, or to a groove template.

If you want to clean up the timing for the selection, without affecting the tempo, make sure to first calculate the tempo by generating Bar|Beat Markers (see “Calculating Tempo with Beat Detective” on page 724).

To separate clips with Beat Detective:
1. In the Edit window, make an audio selection.
2. In the Beat Detective window, select Clip Separation.
3. Define or capture the selection as described in “Defining a Beat Detective Selection” on page 722.
4. Configure the Detection options so the selection’s peak transients are accurately detected (see “Generating Beat Triggers” on page 724).
5. Click Separate.

Clips are separated based on the detected beat triggers.

Trigger Pad

When separating clips, the Beat Detective window displays an option called Trigger Pad.

Detection settings, Clip Separation mode

Type a value (0–50 ms) in this field to pad clip start points—where the point of separation is located in relation to the beat trigger (transient). This creates a space between the clip start point and the clip sync point, thereby ensuring that the attack portion of the material remains intact.

Separated clip with 20 ms Trigger Pad

When conforming separated clips, the clip sync point determines where the clip is placed (see “Sync Points” on page 905).
Separating Multiple Tracks

You can use beat triggers from a single track, or subset of tracks, to separate a group of tracks.

In the following example, the defined selection is a drum loop consisting of two bars of 5/4. The kick, snare, hi-hat, and overhead microphones are recorded to separate tracks.

Analyzing the loop’s kick drum track, with the detection Resolution set to Beats, Beat Detective places beat triggers at the transients on beats 1 and 4.

Extending the selection to the snare, hi-hat, and overhead microphones tracks, and then performing the separation, results in separated clips in each of the drum tracks at the same location, based on the beat triggers from the kick drum track.

The separated clips can then be conformed as a group.

You can also use Collection mode when working with multiple tracks. Collection mode lets you analyze and detect triggers on tracks individually, and if you choose, add only the unique triggers from the current track to the overall collection. For more information, see “Detection (Normal) and Collection Mode” on page 739.

Conforming Clips with Beat Detective

(Audio Only)

After clips have been separated with Beat Detective, the clips can then be conformed using one of two modes:

**Standard Conform** Uses the session’s current tempo map (Grid)

**Groove Conform** Uses groove templates.

Beat Detective will conform any selected clip, whether or not it was separated with Beat Detective. However, in order to successfully conform clips with Beat Detective, the clip start points must correspond to the start of the material that will align with the session’s bars and beats. This should generally not be a problem if the clips were separated with Beat Detective (rather than manually separated or trimmed).
**Standard Conform**

This is similar to using the Clip > Quantize to Grid command, but with one important difference: With a single operation, Beat Detective can adjust the position of all clips, whether they have a straight or swing feel.

![Beat Detective, Standard Conform options](image)

**Beat Detective, Standard Conform options**

**To conform clips using Standard Conform:**

1. In the Beat Detective window, select Clip Conform.
2. Make sure Standard is selected.
3. In the Edit window, if not already selected, select the separated clips you want to conform. Make sure the selection’s start and end points fall cleanly on the beat.
4. In the Beat Detective window, define or recap-ture the selection as described in “Defining a Beat Detective Selection” on page 722.
5. To affect how strongly the clips are conformed to the Grid (tempo map), select the Strength option and specify a percentage value with either the slider or by typing in a value:
   - Lower percentage values preserve the original feel of the clips.
   - Higher percentage values align the clips more tightly to the tempo map, with 100% aligning precisely to the tempo map.

**To “tighten up” the original feel while retaining it, set the Strength option to 85–88%.

6. To affect which clips are conformed, select the Exclude Within option and specify a percentage value with the slider or by typing in a value:
   - Lower percentage values ensure that clips further away from the Grid are conformed, while those closer to the Grid are not.
   - Higher percentage values ensure that clips closer to the Grid, as well as those further away, are conformed.

**To “tighten up” the original feel while retaining it, set the Exclude Within option to 10–15%.

7. To achieve a swing feel for the conformed clips, select the Swing option and whether the swing is based on eighth-notes or sixteenth-notes, then specify a percentage value with the slider or by typing in a value:
   - Smaller percentage values yield less swing, with 0% yielding none.
   - Larger percentage values yield more swing, with 100% yielding a triplet, swing feel.
   - Percentage values between 100–150 move the clips beyond a triplet, swing feel, toward the next sixteenth-note boundary (provided the Swing note value is set to eighth-notes).

**If Beat Detective has successfully captured enough of the sub-beats from a selection before separating, you can successfully conform with the Swing option to change the groove from a “straight” feel to one that is swung. You can also import a groove tem-plate containing a swing feel (see “Groove Conform” on page 736).**
8. Click Conform to automatically conform all clips in the selection.

Clips conformed with Beat Detective

9. Audition the new conformed clips by clicking Play in the Transport.

10. Do one of the following:
   • If necessary, select Edit > Undo, and repeat steps 4–8 trying a different set of Conform settings.
   • If necessary, apply Edit Smoothing (see “Edit Smoothing” on page 737).

**Groove Conform**

Instead of using a grid based on the session’s tempo map, Groove Conform uses a grid based on a groove template, or DigiGroove. DigiGrooves can be used to apply the feel of a captured passage to the selected audio clips. For information about creating DigiGroove templates, see “DigiGroove Templates” on page 731.

**To conform clips using Groove Conform:**

1. In the Beat Detective window, select Clip Conform.

2. Select Groove.

![Groove Conform options](image)

Beat Detective, Groove Conform options

3. In the Edit window, if not already selected, select the separated clips you want to conform. Make sure the selection’s start and end points fall cleanly on the beat.

4. In the Beat Detective window, define or recapture the selection as described in “Defining a Beat Detective Selection” on page 722.

![Warning](image)

> **When using Groove Conform, the captured selection must not include Bar|Beat Markers. Otherwise, the accuracy of the Groove Template will be compromised.**

5. From the Groove Template pop-up menu, select the Groove Clipboard or a saved groove template (for information on creating groove templates, see “DigiGroove Templates” on page 731).

6. To see comments about the selected template, click Show Info.
To affect how strongly the clips are conformed to the groove template, select the Timing option and specify a percentage value with either the slider or by typing in a value:

- Lower percentage values preserve the original feel of the clips.
- Higher percentage values align the clips more tightly to the groove templates grid, with 100% aligning precisely to the template grid.
- If the slider is set to 200%, clips move to a location that is twice the difference between the original clip location and the position of the referenced template event.

For example, if a note was played at Bar 1|1|060 (a 16th note), and the corresponding template event is at 1|1|073, a slider value of 100% results in the note being shifted to 1|1|073; a slider value of 200% shifts the note to 1|1|086.

To conform the material before applying the groove template, enable the Pre-Process Using Standard Conform option.

With this option enabled, Beat Detective conforms clips to the current Standard Conform settings before applying the groove template. For material in which the performance was not accurate, enabling Pre-Process Using Standard Conform can lead to better results by ensuring that the performance is accurately mapped to the correct bars, beats, and sub-beats before the groove template is applied. Experimentation is the best way to determine when it is appropriate to use this option.

When conforming an audio passage to a heavily swung groove template, enabling Pre-Process using Standard Conform will often yield better results.

Click Conform to automatically conform all clips in the selection.

Audition the new conformed clips by clicking Play in the Transport.

Do one of the following:

- If necessary, select Edit > Undo, and repeat steps 4–9 trying a different groove template or Groove Conform settings.
- If necessary, apply Edit Smoothing (see “Edit Smoothing” on page 737).

Edit Smoothing
(Audio Only)

After clips are conformed, there may be gaps between the clips. These gaps can cause the material to sound unnatural on playback.

Beat Detective, Smoothing options

Beat Detective can automatically fill the gaps between clips, and even add crossfades if you choose. The Edit Smoothing option can be used with clips that have been conformed, or with a track that contains many clips that need to be trimmed and crossfaded (such as in a sound effects track). This automated process of smoothing clip edits can save many hours of tedious editing.
To use Edit Smoothing on conformed clips:

1. In the Beat Detective window, select Edit Smoothing.

2. Select a Smoothing option:
   - Fill Gaps: Select this option to trim clip end points so that the gaps between clips are filled.
   - Fill And Crossfade: Select this option to trim clip end points and automatically add a pre-fade (in ms) directly before each clip start point.

3. In the Edit window, if not already selected, select the range of conformed audio clips you want to smooth. Make sure the selection’s start and end points fall cleanly on the beat.

4. Click Smooth to smooth the edits for the selected clips.

5. Audition the results by clicking Play in the Transport.

6. If necessary, select Edit > Undo, and repeat steps 2–5 trying a different Crossfade Length.

**Edit Smoothing Creates Sync Points**

After smoothing edits with Beat Detective, sync points (corresponding to the material’s start point) are automatically created for the conformed clips. This allows you to later conform the clips to a different tempo map or groove template, or use different Conform settings.

However, sync points are only created as they are needed: If gaps between clips are created during Clip Conform, Fill Gaps in Edit Smoothing mode will trim clips to fill the gap and a sync point will be created at each clip’s original start point. If there is no gap between clips, no sync point will be created by Edit Smoothing.

For more information on clip sync points, see “Sync Points” on page 905.

**Consolidating Clips after Edit Smoothing**

The process of separating, conforming, and smoothing with Beat Detective can leave tracks with many clips and many crossfades. If you are working with multiple tracks, the density of these edits may lead to system performance problems.

If performance is not an issue, use the Clip Group command for easier editing and manipulation of clips. This can be useful for arranging beats that were sliced with Beat Detective, especially if you plan on changing tempos with tick-based audio tracks. For more information on clip groups, see “Clip Groups” on page 919.
Once you are satisfied with the results from Beat Detective, it is recommended that you flatten the tracks with the Consolidate command. For all clips selected, Consolidate creates a single, contiguous audio file to reduce the session’s edit density. See “Consolidating Clips” on page 665.

⚠️ Before consolidating a large selection across multiple tracks, make sure there is enough RAM available. See “RAM Requirements for Beat Detective” on page 720.

### Detection (Normal) and Collection Mode

In some instances, it may be difficult for Beat Detective to successfully analyze multiple tracks with the same Detection settings. With Beat Detective’s Collection mode, you can collect a set of beat triggers from different tracks, each with different Detection settings, and use the collection of triggers to generate Bar|Beat Markers or DigiGroove templates, or separate new clips. Collection mode is the only way to analyze and create beat triggers on one track, and apply them to another track.

This method of selectively adding beat triggers from separate analysis passes on different tracks, until you get only the triggers you want, is potentially much more effective than manually deleting, inserting, or adjusting incorrect or false triggers.

### Drum Tracks and Collection Mode

Suppose you have drum tracks for kick, snare, hi-hat, and overhead mics. If you analyze a selection across all of the tracks, you may get many false triggers when you raise the Sensitivity slider high enough to capture the hi-hat material (coming mainly from the tracks for the overhead mics).

However, if you analyze only the track for the overhead mics, the resulting beat triggers are slightly later than the material on the other tracks (since it will take more time for the sound to reach the overhead mics). If you then extend the selection to the other drum tracks and separate them, the clips from the kick, snare, and tom tracks will be cut slightly late.

*Overhead mics generate late beat triggers*

Using Collection mode, you can analyze each drum track separately, one at a time, optimizing the Detection settings for each track until you get the triggers you want. The triggers for each track can be added successively to the collection, or you can choose to collect only the unique triggers from a track. The collection of triggers that results can then be used to generate Bar|Beat Markers or a DigiGroove template, or separate new clips.
**Using Collection Mode**

Collection mode is available in Bar|Beat Marker Generation, Groove Template Extraction, or Clip Separation mode (audio only), and is accessed by selecting Collection in the Detection pop-up menu.

To use Collection mode:

1. In the Edit window, make an audio selection on a single track. Make sure the selection’s start and end points fall cleanly on the beat.

2. In the Beat Detective window, select one of the following modes:
   - Bar|Beat Marker Generation
   - Groove Template Extraction
   - Clip Separation (audio only)

3. Define or capture the selection as described in “Defining a Beat Detective Selection” on page 722.

4. Configure the Detection options so the selection’s peak transients are accurately detected (see “Generating Beat Triggers” on page 724).

5. From the Detection pop-up menu, select Collection.

6. In the Detection (Collection Mode) section, click Add All to add all the current beat triggers to the collection.

7. From the Detection pop-up menu, select Normal and move the selection to the next track you want to analyze. Make sure to keep the selection range constant for each track.

8. Configure the Detection options so the selection’s peak transients are accurately detected (see “Generating Beat Triggers” on page 724).

9. Select Collection again.

10. Do one of the following:
    - In the Detection (Collection Mode) section, click Add Unique to add only the unique triggers from the track to the collection. When you choose to add unique triggers, Pro Tools looks for triggers that are close to triggers already collected from other tracks. Where triggers already exist, the newly detected triggers are discarded.
    - Click Add All to add all triggers to the collection.
    - Click Clear All to clear all triggers from the collection.
Each new set of triggers added to the collection appears in a different color. If successive triggers in the collection are located closely together (for example, because of microphone leakage), Beat Detective keeps only the earlier triggers.

11 Repeat steps 7–10 for each additional track you are analyzing.

The beat triggers stored in the Collection mode are saved with sessions. Therefore, when a session is opened later, the previous collection material is still there (until it is cleared).

12 Once the beat triggers have been added to the collection, you can use them to generate Bar|Beat Markers or groove template, or separate clips. However, this must be done from the Collection Mode section (when the triggers are displayed in multiple colors).

💡 To separate clips across multiple tracks, make sure to extend the selection to any additional tracks before separating.
Part VI: MIDI
Chapter 34: MIDI Editing

Pro Tools provides powerful MIDI editing tools. You can create and edit individual MIDI notes and controller events with the Pencil, Trim, and Grabber tools in the Edit window, MIDI Editor windows (see Chapter 35, “MIDI Editors”), and the Score Editor window (Chapter 36, “Score Editor”).

For information on clip-specific editing for both MIDI and audio, see Chapter 30, “Editing Clips and Selections.”

You can use the various Event Operations (such as Quantize, Transpose, Change Velocity, and Change Duration) to destructively transform groups of MIDI notes in terms of pitch, timing, dynamics, and phrasing (see Chapter 46, “Event Operations”).

Additionally, you can use Real-Time Properties to nondestructively affect MIDI on playback or play-through (see “MIDI Real-Time Properties” on page 780).

Pro Tools also provides numerous zoom and view tools that are optimized for MIDI editing.

MIDI Editing Options

Pro Tools provides a few options for determining MIDI editing behavior. These options are available in the Edit window, MIDI Editor windows, and the Score Editor window. However, these options are only available if there is at least one MIDI or Instrument track in your Pro Tools session.

Play MIDI Notes When Editing

When enabled, the Play MIDI Notes When Editing option causes MIDI notes to play (send a MIDI Note On message) when editing.
Default Note Duration

The Default Note Duration setting lets you define the default note duration for inserting notes manually. The Edit window, MIDI Editor windows, and Score Editor window can each have a different Default Note Duration setting.

To select a Default Note Duration:

1. Click the Default Note Duration setting in the Edit window, a MIDI Editor window, or the Score Editor window.
2. Select the Default Note Duration value you want. (For example, select the 1/4 Note option to insert quarter notes with the Pencil tool.)
3. To define a dotted or triplet duration, do one of the following:
   - To dot the selected Default Note Duration value, click the Default Note Duration setting and select Dotted.
   - To make the selected Default Note Duration value a triplet, click the Default Note Duration setting and select Triplet.

Follow Grid

Select the Follow Grid option to have the Default Note Duration follow the selected Grid value. To stop following the Grid value, select the rhythmic value for the Default Note Duration setting.

Default Note On Velocity

The Default Note On Velocity setting lets you define the default Note On velocity for inserting notes manually. The Edit window, MIDI Editor windows, and Score Editor window can each have a different Default Note On Velocity setting.

To define the Default Note On Velocity, do one of the following:

- Click the Default Note On Velocity setting in the Edit window, a MIDI Editor window, or the Score Editor window and drag up or down.
- Click the Default Note On Velocity setting in the Edit window, a MIDI Editor window, or the Score Editor window, type a new number and press Enter.
Mirrored MIDI Editing

Mirrored MIDI Editing lets you edit MIDI clips and have your edits apply to every copy of the same MIDI clip. This can be particularly useful when editing looped MIDI clips.

To enable Mirrored MIDI Editing, do one of the following:

- Select Options > Mirror MIDI Editing.
- Enable the Mirrored MIDI Editing button in the Edit window, MIDI Editor window, or Score Editor window.

In Mirrored MIDI Editing mode, the Mirrored MIDI Editing button flashes Red once as an edit is made to alert you that your edit is being applied to more than one clip.

To disable Mirrored MIDI Editing, do one of the following:

- Deselect Options > Mirror MIDI Editing.
- Disable the Mirrored MIDI Editing button in the Edit window, MIDI Editor window, or Score Editor window.

⚠️ If Mirrored MIDI Editing mode is disabled, and you edit notes of looped clips in Notes view, the edit flattens the loop. Similarly editing clip groups separates the clip groups.

Setting the Grid Value

When inserting MIDI notes with the Pencil tool, the Grid value determines the Note On location of each note, or other characteristics, based on the Pencil tool shape (see “Using the Pencil Tool” on page 748). The Edit window, MIDI Editor windows, and Score Editor window can each be set to a different Grid value.

To set the Grid value for MIDI editing:

1. Click the Grid value selector and select Bars|Beats. If the Follow Main Time Scale option is enabled you can simply set the Main Time Scale to Bars|Beats (see “Setting the Main Time Scale” on page 840).

2. Click the Grid value selector again and select a note value (such as 1/4, 1/8, or 1/16).
3 To define a dotted or triplet value, do one of the following:
• To dot the selected Grid value, click the Grid Value selector again and select Dotted.
• To make the selected Grid value a triplet, click the Grid Value selector again and select Triplet.

4 Verify the default session meter and tempo (see “Setting the Session Meter” on page 498 and “Setting the Session Tempo” on page 499).

To show (or hide) grid lines in the Edit window or in a MIDI Editor window:

- Select (or deselect) the Grid button.

To increase the grid value incrementally:
- Press Shift+Equal (=).

To decrease the grid value incrementally:
- Press Shift+Minus (–).

Using the Pencil Tool

The Pencil tool is useful for creating and editing MIDI data. The first five Pencil tool shapes (Free Hand, Line, Triangle, Square, and Random) can be used to create MIDI notes with varying durations and velocities. In the Edit window MIDI Editor windows, and the Score Editor window, note velocities are determined by the Pencil tool shape). The various Pencil tool shapes can be particularly useful for drawing and editing different types of MIDI control data—for example, try using Line for volume, Triangle for pan, Free Hand for pitch bend, and Square or Random for velocity.

Parabolic and S-Curve Pencil shapes are used for drawing tempo events only in the Tempo Editor. See “Drawing Tempo Events” on page 851.

To select the Pencil tool shape:

1 Click the Pencil tool icon in the Toolbar for the Pencil tool shape pop-up menu.

2 Select a Pencil tool shape.

For more information on Grid mode, see “Grid Mode” on page 601.

Grid button selected in the Edit window

To increase the grid value incrementally:

- Press Shift+Equal (=).

To decrease the grid value incrementally:

- Press Shift+Minus (–).

Pencil tool shapes available for MIDI

Pencil Tool Shapes for MIDI

Free Hand

In the Edit window on MIDI and Instrument tracks in Notes view, in MIDI Editor windows, and in the Score Editor, the Free Hand shape inserts a single MIDI note whose velocity is defined by the Default Note On Velocity setting. The pitch, location, and duration of the note are determined by where on the track you click with the mouse.
When editing MIDI velocities or continuous controller data, the Free Hand shape draws freely according to the movement of the mouse. The shape is reproduced as a series of steps according to the Pencil Tool Resolution When Drawing Controller Data MIDI preference.

When editing automation or MIDI control data with the Pencil tool, you can switch between the current Pencil Tool shape (such as Line) and Free Hand pencil editing using the Command key (Mac) or the Control key (Windows). When editing with the selected Pencil shape, the Pencil cursor angles to the left. When editing in Free Hand with the key modifier, the Pencil cursor angles to the right.

**Line**

In the Edit window on MIDI and Instrument tracks in Notes view, in MIDI Editor windows, and in the Score Editor, the Line shape inserts a series of MIDI notes on a single pitch whose velocities are defined by the Default Note On Velocity setting. The duration and spacing for the inserted notes are determined by the current Grid value and the Default Note Duration setting.

When editing MIDI velocities or continuous controller data, the Line shape draws in a straight line from click to release. MIDI continuous controller values change in steps according to the Pencil Tool Resolution When Drawing Controller Data option in the MIDI Preferences page.

**Triangle**

In the Edit window on MIDI and Instrument tracks in Notes view, in MIDI Editor windows, and in the Score Editor, the Triangle shape inserts a series of MIDI notes on a single pitch whose velocities oscillate between the Default Note On Velocity setting and 127 according to a triangle pattern. The duration and spacing for the inserted notes are determined by the current Grid value and the Default Note Duration setting.

When editing MIDI velocities or continuous controller data, the Triangle shape draws a triangular pattern that changes direction according to the current Grid value. MIDI controller values change in steps according to the Pencil Tool Resolution When Drawing Controller Data option in the MIDI Preferences page.

**Square**

In the Edit window on MIDI and Instrument tracks in Notes view, in MIDI Editor windows, and in the Score Editor, the Square shape inserts a series of MIDI notes on a single pitch whose velocities alternate between the Default Note On Velocity setting and 127. The duration and spacing for the inserted notes are determined by the current Grid value and the Default Note Duration setting.

When editing MIDI velocities or continuous controller data, the Square shape draws a square pattern that repeats at a rate based on the current Grid value.

**Random**

In the Edit window on MIDI and Instrument tracks in Notes view, in MIDI Editor windows, and in the Score Editor, the Random shape inserts a series of MIDI notes on a single pitch whose velocities change randomly within the range between the Default Note On Velocity setting and 127. The duration and spacing for the inserted notes are determined by the current Grid value and the Default Note Duration setting.

When editing MIDI velocities or continuous controller data, the Random shape draws a series of random values that change at a rate based on the current Grid value.
**Inserting MIDI Notes**

In addition to recording, step recording, and importing MIDI into Pro Tools, you can manually insert MIDI notes using the Pencil tool.

> When inserting MIDI notes or other MIDI data with the Pencil tool, MIDI clip boundaries are created on the nearest barlines.

**To insert a MIDI Note on a track in the Edit window:**

1. In the Edit window, set the MIDI or Instrument track to Notes view.
2. Select the Pencil tool and make sure it is set to Free Hand. The cursor will change to the Pencil tool when located over the playlist area of a MIDI or Instrument track in Notes view.
3. To insert quarter notes on the beat, do the following:
   - Set the Main Time Scale to Bars|Beats.
   - Set the Edit mode to Grid.
   - Set the Grid value to quarter notes.
   - Set the Default Note Duration value either to quarter notes (or to Follow Grid).
4. Move the Pencil tool into the playlist area for the MIDI or Instrument track. Use the Edit window’s ruler and the track’s mini-keyboard as a reference to locate the pitch and time location you want.

When using the Pencil tool, the Cursor location and value are displayed in the Window Toolbar.

5. When you reach the pitch and time location you want, click to insert the note.

When using the Smart Tool (see “Using the Smart Tool” on page 621), Control-click (Mac) or Start-click (Windows) to change the cursor to the Pencil tool and insert MIDI notes; Option-Control-click (Mac) or Alt-Start-click (Windows) to delete notes.

> With Grid mode enabled, the start point of the MIDI note snaps to the nearest Grid boundary by default. With the Free Hand Pencil tool, press Command (Mac) or Control (Windows) after clicking and holding to temporarily suspend Snap to Grid.
The velocity for inserted notes is determined by the Default Note On Velocity setting. The duration is determined by the Default Note Duration value. When in Grid mode, the Note On location is determined by the Grid value.

If the Play MIDI Notes When Editing option is enabled, each note sounds as it is inserted.

The Pencil tool can be dragged after clicking (and before releasing) to adjust the note’s pitch or duration. Drag right to lengthen the note without changing its start point. Drag left to shorten the note without changing its end point.

Inserting a Series of Notes

In the Edit window and in MIDI Editor windows, the Line, Triangle, Square, and Random Pencil tool shapes can be used to enter a series of identical pitches with varying velocities. The duration and spacing for the inserted notes are determined by the current Grid value and the Default Note Duration setting.

When the Default Note Duration is greater than the Grid value, the inserted notes are truncated to match the Grid value and not overlap.

The note velocities are determined by the Pencil tool shape:
- Use the Line shape to enter notes with identical velocities.
- Use the Triangle shape for a ramp up and down of velocities.
- Use the Square shape for alternating velocities of loud and soft.
- Use the Random shape for a series of notes with random velocities.

For example, to insert a series of notes with random velocities in the Edit window:

1. In the Edit window, set the MIDI or Instrument track to Notes view.
2. Select the Pencil tool and make sure it is set to Random.
3. To insert consecutive quarter notes on the beat, do the following:
   - Set the Main Time Scale to Bars|Beats.
   - Set the Edit mode to Grid.
   - Set the Grid value to quarter notes.
   - Set the Default Note Duration value either to quarter notes (or to Follow Grid).

With these settings, the notes are inserted spaced one quarter note apart.

4. Click at the point to insert the first note and drag to the right until the number of notes you want have been inserted.
Manually Editing MIDI Notes

All aspects of a MIDI note can be edited in the Edit window or in a MIDI Editor window, including start and end points, duration, pitch, and velocity. The Selector, Grabber, and Pencil tools can operate on individual notes or groups of notes.

Selecting MIDI Notes

MIDI notes must be selected before they can be edited.

To select MIDI notes, do one of the following:

- With the Pencil tool or any Grabber tool, Shift-click each note.
- With any Grabber tool, move the cursor to where there are no notes (the Marquee appears) and click and draw a rectangle around the group of notes you want to edit.
- With the Selector tool, drag across a range of notes.

When using a Grabber tool, if any portion of the rectangle touches a note (either its start or end point), the note is included in the selection. However, selections made with a Grabber tool are object selections and do not include underlying controller and automation data for the MIDI track.

Selecting notes with the Selector tool

When using the Selector tool, a note’s start point must be included in order for it to be selected. When a MIDI or Instrument track is in Notes or Clips view, selections made with the Selector tool are range selections and include all underlying controller and automation data.

With the Selector tool, Option-click (Mac) or Alt-click (Windows) to get the Note Selector tool in the Edit window and MIDI Editor windows (the Selector tool always makes note selections in the Score Editor). The Note Selector tool selects all MIDI notes within the duration of the selection as objects and does not select any other MIDI events (such as controller data or program changes).

To deselect one or more notes from a selection:

- With the Pencil tool or any Grabber tool, Shift-click the notes so they become deselected.
- You can also select notes in the Select/Split Notes window. See “Select/Split Notes Command” on page 1025.
Selecting and Auditioning MIDI Notes with the Mini-Keyboard

Use the mini-keyboard on MIDI and Instrument tracks to select and play notes on that track. You can click on the mini-keyboard with any Edit tool.

- Use the scroll wheel on your mouse or the track pad on your laptop to scroll the piano roll up or down on a MIDI or Instrument track to view the note range you want to work with.

To play a note on a MIDI or Instrument track, and select all notes of that pitch on the track:

- With any Edit tool selected, click a key on the mini-keyboard.

Playing a note with the mini-keyboard and selecting all notes of that pitch

Option-click (Mac) or Alt-click (Windows) to play notes without making a selection.

Command-click (Mac) or Control-click (Windows) to select or deselect notes, and to make noncontiguous selections.

To select and play a range of notes on a MIDI or Instrument track:

- With any Edit tool selected, click a key and drag up or down on the mini-keyboard.

Playing a range of notes with the mini-keyboard and selecting all notes of including those pitches

You can also Shift-click on the mini-keyboard to extend or contract the range of notes.

Selecting Only MIDI Notes Using the Note Selector Tool

In Notes or Velocity view on MIDI and Instrument tracks in the Edit window, or in a MIDI Editor window, the Selector tool makes a time range selection that includes all MIDI event types in addition to MIDI notes and velocities (such as program changes, and continuous controller data). The Note Selector tool can be used to select only MIDI notes and velocities in a time range selection.
To select only MIDI notes and velocities with the Note Selector tool:

1. Select the Selector tool.

2. On MIDI or Instrument tracks in the Edit window in Notes or Velocity view, or in a MIDI Editor window, Option-drag (Mac) or Alt-drag (Windows) over the time range that includes the notes you want to select.

Also see “Absolute and Relative Grid Mode” on page 902.

Editing MIDI Notes in Grid or Relative Grid Mode

When sequencing MIDI for music (such as drum patterns or synth pads), you will typically set the Main Timebase ruler to Bars|Beats—and keeping the default Timebase setting of ticks for MIDI and Instrument track—in order to maintain alignment with the tempo and meter of the music. Thus, you will typically want to edit MIDI notes (and other MIDI data) in Grid mode with the Grid set to the lowest common rhythmic value—for instance, if the shortest rhythm in the sequence is a sixteenth-note, set the Grid value to a sixteenth note (see “Setting the Grid Value” on page 747).

However, if recorded a MIDI performance to a click and you may want to keep the timing of the performance intact in relation to the Grid rather than quantizing the performance to the Grid when editing it. If so, use Relative Grid mode when editing. With Relative Grid mode is enabled, any part of the MIDI performance maintains its relative offset from the Grid when moving, when cutting or copying and pasting, or when cutting or copying and merge pasting (Edit > Paste Special > Merge) selected MIDI notes.
Using the Grabber Tools

Use the Grabber tools to select, move, separate, and arrange clips on tracks. There are three modes for the Grabber tool: Time Grabber, Separation Grabber, and Object Grabber. For more information about arranging clips, also see Chapter 40, “Arranging Clips.”

When in Grid mode and in Notes view on MIDI and Instrument tracks, clicking anywhere in the timeline outside of a clip with the Grabber tool places the Edit insertion point at the nearest grid location.

Transposing Notes

MIDI notes can be transposed by dragging them up or down with the Pencil tool or any Grabber tool. If several notes are selected before dragging, each is transposed.

To transpose a MIDI note:
1 Set the MIDI or Instrument track to Notes view.
2 Select the Pencil tool or any Grabber tool.
3 While pressing Shift, drag the note up or down.

While dragging, each new note sounds and the Cursor Location Value indicator (in the Edit window) indicates the number of semitones and direction (+/–) for the transposition.

Press Command (Mac) or Control (Windows) while clicking with the Grabber tool in notes view temporarily toggle to Slip mode.

Moving Notes

Like clips, MIDI notes can be dragged left or right with the Pencil tool or any Grabber tool to change their start point. If several notes are selected before dragging, they are all moved together.

To move a MIDI note:
1 Set the MIDI or Instrument track to Notes view.
2 With the Pencil tool or any Grabber tool, drag the note left or right (press Shift while dragging to preserve the note’s pitch).

As the note is dragged, the Cursor Location Value indicator (in the Edit window) displays the new start point.
If the Edit mode is set to Grid, the dragged note snaps to the nearest Grid boundary. If the Edit mode is set to Spot, the Spot dialog opens.

💡 To copy the selected notes, leaving the originals intact, press Option (Mac) or Alt (Windows) while dragging.

енным Grid mode.

The placement of MIDI notes can also be adjusted with Shift (see “Shift Command” on page 907) or Nudge (see “Nudging Clips” on page 659).

Trimming Note Start and End Times

Like clips, start and end points for MIDI notes can be adjusted with the Trim tool. If several notes are selected when performing the trim, each note is changed.

💡 The Trim tool can also be used on MIDI clips. For more informations, see “Time Compression/Expansion Trim Tool Functionality on MIDI Clips” on page 762.

To change the start or end points for a group of MIDI notes:

1. Set the MIDI or Instrument track to Notes view.

2. Using the Pencil tool or any Grabber tool, Shift-click each note you want to trim.

3. Do one of the following:
   • Select the Trim tool.
   • Use the Pencil tool.

4. Move the cursor near the beginning of any of the highlighted notes, so the Trim tool appears. Drag right to shorten the notes, or drag left to lengthen them.

Changing note end times with the Trim tool

If the Edit mode is set to Grid, the dragged start or end point snaps to the nearest Grid boundary. If the Edit mode is set to Spot, the Spot dialog opens, where you can enter the new location for the note’s start or end point.

💡 When in Grid mode, use the Command key (Mac) or Control key (Windows) to temporarily disable Grid mode.

Notes can also be trimmed with the Trim Clip to Selection command (see “Trim to Selection Command” on page 657) and the Trim To Insertion command (see “Trimming with Nudge” on page 659).
Trimming MIDI Notes with Nudge

You can trim the start and end points of selected MIDI notes by the current Nudge value.

To trim the selected MIDI notes start or end points by the Nudge value:
1. Configure the Nudge value (see “Defining the Nudge Value” on page 660).
2. With the Time Grabber tool, select the MIDI notes you want to trim.
3. Do one of the following:
   • While pressing Option (Mac) or Alt (Windows), press Plus (+) or Minus (–) on the numeric keypad to trim the start point of the selected MIDI notes by the Nudge value.
   • While pressing Command (Mac) or Control (Windows), press Plus (+) or Minus (–) on the numeric keypad to trim the numeric keypad to trim the end point of the selected MIDI notes by the Nudge value.

Transposing MIDI Notes with Nudge

You can transpose selected MIDI notes by semitonal increments using Plus (+) or Minus (–) on the numeric keypad.

To transpose the selected MIDI notes by semitones:
1. With the Time Grabber tool, select the MIDI notes you want to transpose.
2. Do one of the following:
   • While pressing Control (Mac) or Start (Windows), press Plus (+) on the numeric keypad transpose the selected MIDI notes up by one semitone.
   • While pressing Control (Mac) or Start (Windows), press Minus (–) on the numeric keypad transpose the selected MIDI notes down by one semitone.

Separating MIDI Notes

The Separate command lets you separate MIDI notes at the Edit cursor location or at the boundaries of the Edit selection. When in Notes view in the Edit window and in MIDI Editor windows, separating MIDI clips creates new MIDI notes but does not create new MIDI clips. However, when in Clips view in the Edit window, separating MIDI clips only creates new MIDI clips. Also, if the Edit selection includes any audio tracks, the Separate command separates only clips on MIDI and Instrument tracks regardless of the Track View setting.
To separate MIDI notes at the Edit cursor location or at the boundaries of the Edit selection:

1. Make an Edit selection or place the Edit cursor at the location where you want to separate one or more MIDI notes.

2. Do one of the following:
   - Choose Edit > Separate > At Selection.
   - Right-click in the Notes pane and choose Separate.

   Press Command+E (Mac) or Control+E (Windows) to separate MIDI notes at the selection.

To separate MIDI notes on the grid:

1. Set the Grid value.

2. Make an Edit selection or a marquee selection that includes the MIDI notes you want to separate.

3. Choose Edit > Separate > On Grid.

4. In the Pre-Separate Amount dialog, click OK.

Separate and Consolidate Tools for MIDI Notes

In Notes view in the Edit window and in MIDI Editor windows, both the Pencil and Grabber tools can be used to separate MIDI notes and to consolidate MIDI notes.

The cursor updates to show a “knife” for the Separate tool and a “bandage” for the Consolidate tool.

To separate a MIDI note with the Separation tool:

- With the Grabber or Pencil tool, Control-Shift-click (Mac) or Start-Shift-click (Windows) on the MIDI note at the location where you want the separation.

To consolidate MIDI notes with the Consolidate tool:

- With the Grabber or Pencil tool, Control-Shift-click (Mac) or Start-Shift-click (Windows) between the separated MIDI notes.
Consolidating MIDI Notes

The Consolidate command lets you combine two or more consecutive MIDI notes of the same pitch into a single MIDI note.

To consolidate MIDI notes:
1 Select the MIDI notes you want to consolidate.
2 Do one of the following:
   • Choose Edit > Consolidate.
   • Right-click the selected notes and choose Consolidate.

Press Option+Shift+3 (Mac) or Alt+Shift+3 (Windows) to consolidate adjacent selected MIDI notes of the same pitch.

Muting MIDI Notes

The Mute command lets you mute individual MIDI notes. If entire clips are selected, the Mute command prompts you to either mute clips or MIDI notes.

To mute one or more MIDI notes:
1 Select the MIDI notes you want to mute.
2 Do one of the following:
   • Choose Edit > Mute Notes.
   • Right-click the selected MIDI notes and choose Mute Notes.

Press Command+M (Mac) or Control+M (Windows) to mute and unmute selected MIDI notes.

Manually Editing Note Velocities

When a MIDI or Instrument track is set to Velocity view, or when the Velocity lane is revealed under a track, each note’s attack velocity is represented with a velocity stalk. The taller the velocity stalk, the higher the velocity value (0–127).

To edit MIDI velocity in the Edit window:
1 Do one of the following:
   • Set the MIDI or Instrument track to Velocity view.
   • Reveal the Controller lane for the MIDI or Instrument track and show Velocity.

Revealing the Velocity Lane
2 Select any Grabber tool.
3 Drag the top (diamond) of the velocity stalk up or down.

The velocities for a range of notes can be edited with any Pencil tool.

For fine-resolution editing of velocity values, Command-click-drag (Mac) or Control-click-drag the top of the velocity stalk to the desired value.

To draw velocity values for a crescendo:
1 Do one of the following:
   • Set the MIDI or Instrument track to Velocity view.
   • Reveal the Controller lane for the MIDI or Instrument track and show Velocity.
2 Select the Pencil tool with the shape set to Line.
3 Click at the beginning of the note range, near the bottom of the velocity range, and drag to the right and up until the line encompasses the range of notes you want to include in the fade.

You can also use the Trim tool to scale the velocities for all selected notes. This is useful if you like the velocity relationship between the notes, but want them all to be louder or softer.

When in Velocity view, the Trim tool can be used to trim note durations in addition to changing velocities.

To scale velocities with the Trim tool:
1 Set the MIDI or Instrument track to Velocity view.
2 Using the Selector tool or any Grabber tool, select the range of notes to be edited.
3 With the Trim tool, click near the range of selected notes and drag up or down. Dragging up increases the velocities for each note and dragging down decreases them.

Velocity Trim Tool

To trim the velocity of one or more selected MIDI notes:
- With the Grabber tool selected, Command-click (Mac) or Control-click (Windows) the note and drag up or down. Notice that the Grabber tool changes to the Velocity Trim tool.
Drag up to increase the velocity value, or down to decrease it. While dragging, the diamond turns blue and the associated note becomes selected. The dragged velocity values are reflected in the Cursor Location Value indicator (in the Edit window).

If two notes have the same start time (with velocity stalks on top of each other), Command-drag (Mac) or Control-drag (Windows) the actual note up or down to adjust its velocity.

Auditioning Velocity Changes

If the Play MIDI Notes When Editing option is enabled, Pro Tools plays the note at the new velocity when editing velocities for MIDI notes with the Grabber tool. This lets you hear when you have the velocity setting you want for a MIDI note.

Typing in Note Attributes

When an individual note is selected with the Pencil tool or any Grabber tool, its attributes are displayed in the Event Edit area.

1. In the Edit window, with a MIDI or Instrument track set to Notes View, select the note with the Pencil tool or any Grabber tool.

2. Click in the Attributes text box and do one of the following:
   - Enter the new value on the numeric keypad.
   - Press the Up or Down Arrow to increment or decrement to the new value.
   - Drag up or down to scroll to the new value.
   - Play the new note value on your MIDI keyboard controller.

Press Forward Slash (/) to move between the fields in the Event Edit area.

Multiple Notes and Event Edit Area

When multiple notes are selected, you can enter values in the Event Edit area fields to affect all selected notes. A triangle (delta symbol) to the left of the displayed note indicates that multiple notes are selected.

A new value in the Start field moves the first note in the selection to that location, with all other notes moving with it.

Values entered in the pitch and velocity fields add to or subtract from the values for all selected notes. For example, to transpose all selected notes down an octave, enter a value of –12 for pitch.
Deleting MIDI Notes

In addition to deleting selected notes with the Clear command in the Edit menu, individual notes can also be deleted with the Pencil tool.

To delete a group of MIDI notes with the Clear command:

1. Using the Grabber or Selector tool, select the notes to be deleted (see “Selecting MIDI Notes” on page 752).

2. Do one of the following:
   - Choose Edit > Clear to delete the selected notes. The track’s underlying controller data remains intact.
   - With any Edit tool, Right-click any selected note and choose Clear.
   - Press the Delete (Mac) key or Backspace (Windows).

⚠️ When deleting MIDI notes within a time range selection, all underlying controller and automation data is also deleted.

To delete a single MIDI note with the Pencil tool:

- With the Pencil tool selected, Option-click (Mac) or Alt-click (Windows) the note. The Pencil tool changes to an Eraser when Option (Mac) or Alt (Windows) is pressed.

💡 Program change events and Sysex events can also be deleted by Option-clicking (Mac) or Alt-clicking (Windows) them with the Pencil tool.

Time Compression/Expansion Trim Tool Functionality on MIDI Clips

The Time Compression/Expansion Trim tool is useful for matching a MIDI clip to the length of another clip, a tempo grid, or any other reference point.

With the Time Compression/Expansion Trim tool, you can move the MIDI clip’s start or end point to expand or compress the clip, scaling the MIDI data accordingly regardless of the track’s timebase (ticks or samples).

Before trimming a MIDI clip with the Time Compression/Expansion Trim tool

After trimming a MIDI clip with the Time Compression/Expansion Trim tool

Using the Time Compression/Expansion Trim Tool in Grid Mode

The Time Compression/Expansion Trim tool (TCE Trim tool) can be used in Grid mode to match a clip to the tempo of a session or a section of a session, or to create “double time” or “half time” performances.
To compress or expand MIDI clips in Grid mode:

1. Set the Edit mode to Grid.
2. If necessary, set the MIDI or Instrument track to Clips view.
3. Select the TCE Trim tool.
4. With the TCE Trim tool, drag the MIDI clip’s start or end point to compress or expand the clip to the Grid (for example, by quarter notes). A new MIDI clip is automatically created, and appears both in the playlist and in the Clips List.

**Using the Time Compression/Expansion Trim Tool in Slip Mode**

To compress or expand MIDI clips in Slip mode:

1. Set the Edit mode to Slip.
2. Set the MIDI or Instrument track to Clips view.
3. Select the TCE Trim tool.
4. With the TCE Trim tool, drag the MIDI clip’s start or end point to compress or expand the clip freely. A new MIDI clip is automatically created, and appears both in the playlist and in the Clips List.

**Using the Time Compression/Expansion Trim Tool in Spot Mode**

In Spot mode, clicking with the TCE Trim tool in a clip opens the Spot dialog. You can specify the location where you want the clip to start or end, or the duration of the clip, and the clip is automatically compressed or expanded as specified.

**Using the Time Compression/Expansion Trim Tool in Shuffle Mode**

In Shuffle mode, the trimmed clip will always begin at the original clip’s start point regardless of whether you trim from the front to the rear or from the rear to the front.

To compress or expand MIDI clips in Shuffle mode:

1. Set the Edit mode to Shuffle.
2. Set the MIDI or Instrument track to Clips view.
3. Select TCE Trim tool.
4. With the Time Compression/Expansion Trim tool, drag the MIDI clip’s start or end point to compress or expand the clip freely. A new MIDI clip is automatically created, and appears both in the playlist and in the Clips List.
Continuous Controller Events

Continuous controller events for MIDI and Instrument tracks are displayed in the form of a line graph with a series of editable breakpoints. Controller events for MIDI and Instrument tracks differ from automation data for audio tracks in that the breakpoints are stepped (instead of vector-based), where each breakpoint represents a single controller event.

To show MIDI Controller data for a track, do one of the following:

- Select the corresponding Track View from the Track View menu.
- Reveal the corresponding MIDI Controller lane under the track.

Continuous controller events that can be inserted and edited in Pro Tools include:

- volume
- pan
- pitch bend
- aftertouch (mono)
- MIDI controllers, 0–127

⚠️ Polyphonic aftertouch cannot be viewed in the Edit window. To view polyphonic aftertouch in Pro Tools, use the MIDI Event List (see Chapter 37, “MIDI Event List”).

MIDI controller #7 (volume) and #10 (pan) are treated by Pro Tools as automation data. This means that these controller events (along with Mutes) can be recorded and automated from the Mix window; in addition, each MIDI or Instrument track’s automation mode affects how these events are played back and recorded. While a MIDI track’s volume, pan, and mute events can be suspended, all other controller events in the track always play. Instrument tracks support both MIDI volume, pan, and mute, and audio volume, pan, and mute.

To avoid overwriting existing MIDI volume and pan automation data, record in MIDI Merge mode. When recording in MIDI Merge mode, existing volume and pan data play back while recording new MIDI data.

Continuous controller events (including volume and pan) can be recorded from an external MIDI controller (such as a keyboard or control surface), and they can be inserted in a MIDI track’s playlist using the Pencil tool or any Grabber tool.
Inserting and Editing Controller Events

Continuous controller events can be edited with any of the following methods:

- Individual breakpoints can be dragged with any Grabber tool to adjust their location or value.
- A group of selected breakpoints can be scaled up or down with any of the Trim tools.
- New controller events can be drawn in with the Pencil tool to replace existing events. Events can be drawn with the Pencil tool (set to Free Hand, Line, Triangle, Square, or Random).
- Controller events can be cut or copied and pasted, as well as nudged or shifted.

For vertically constrained, fine-resolution editing of any control breakpoint, Command-Shift-click-drag (Mac) or Control-Shift-click-drag the breakpoint to the desired value.

To copy continuous MIDI controller events and paste to a different MIDI controller, use Special Paste (Edit > Paste Special > To Current Automation Type). For example, you might want to use the same control data for volume and a cut-off filter, or for pan and pitch bend. For more information, see “Special Paste Function for Automation Data” on page 1160.

Edits to volume data affect all tracks within an enabled Edit Group. This is not the case, however, for other controller playlists (such as pan). To insert and edit other controller types across all tracks in an Edit Group, press the Control key (Mac) or Start key (Windows) while performing the edits.

Setting Resolution for Inserted Controller Events

When inserting controller events with the Pencil tool, the density of the events is determined by the Pencil Tool Resolution When Drawing Controller Data setting in the MIDI Preferences page.

To set the Pencil tool resolution:

1. Choose Setup > Preferences, then click the MIDI tab.
2. Type a value (1 to 100 milliseconds) for Pencil Tool Resolution When Drawing Controller Data.
3. Click OK.

To edit a continuous controller event with the Pencil tool, the controller first has to be added to the Automated MIDI Controllers list.

The controller is automatically added to the Automated MIDI Controllers list when you record controller information from an external device.

To manually enable a continuous controller for automation:

1. Do one of the following:
   - Click the Track View selector for the MIDI or Instrument track you want to edit, and select Add/Remove Controller from the controllers submenu.

Selecting Add/Remove Controllers from the Track View selector
• If Controller lanes are revealed under the MIDI or Instrument track you want to edit, click the Controller Type selector for the Controller lane under the track and select Add/Remove Controller from the controllers submenu.

2 In the Automated MIDI Controllers dialog, select the MIDI Controllers range for the controller you want to automate.

3 Select the controller that you want to automate from the list on the left, and click Add. The selected controller is added to the Automated MIDI Controllers list on the right.

4 Repeat steps 2 and 3 as necessary until you have added all of the MIDI controllers you want for automation.

5 To remove a controller from the Automated MIDI Controllers list, select it in the list on the Right and click Remove.

6 Click OK to close the Automated MIDI Controller dialog.

When you record continuous controller information from an external MIDI device, the controller is automatically added to the MIDI Controllers list.
MIDI Controller Numbers Shown in Track View and Controller Lane Selectors

MIDI Continuous Controller (CC) numbers are shown in parenthesis in the Track View and Controller Lane selectors. Aside from common controller number assignments like “Mod Wheel” (1), “Volume” (7), or “Sustain Pedal” (64), many MIDI continuous controllers are simply “unassigned” in the standard MIDI specification. This can be confusing if you are editing data for several “unassigned” or otherwise generic continuous controllers, so by having the controller number always shown next to the name in parenthesis, you can easily see which continuous controller you are editing.

Clip Boundaries Shown in MIDI Control Automation Track Views

When working on Instrument and MIDI tracks in any MIDI Controller Automation view (such as Velocity, Pitch Bend, or Mod Wheel) Clip boundaries are displayed. This provides context for note and MIDI Controller data visible on the track as you are editing. MIDI clip boundaries are also shown in MIDI Editor windows. This is useful for navigating various MIDI views when editing and arranging MIDI clips and MIDI data.

Keyboard Shortcuts for Navigating MIDI

Using Tab to Transients with MIDI Clips and MIDI Notes

Tab to Transients works with MIDI clips and MIDI notes and MIDI CC events on MIDI and Instrument tracks much like it does with audio clips and audio transients on audio tracks.

Tab to Transients Disabled

When Tab to Transients is disabled, pressing Tab moves the insertion point to the next MIDI clip boundary regardless of the track view (just like with audio clips).
Tab to Transients Enabled

When Tab to Transients is enabled, pressing Tab moves the Edit insertion to the beginning of the next note on, note off, or clip boundary regardless of the track view (just like with audio transients), but does not make note selections.

Tabbing to Notes and MIDI CC Events in Notes View with Controller Lanes Shown

When a MIDI or Instrument track is set to Notes view and Tab to Transients is enabled, press the Tab key to move to the next MIDI note or MIDI CC event (such as MIDI CC 64 Sustain Pedal) shown in a revealed controller lane. Press Option+Tab (Mac) or Alt+Tab (Windows) to move to the previous note or MIDI event.

Insertion point tabbed to next MIDI event on a MIDI track in notes view (Tab to Transients enabled)

- Press Option+Tab (Mac) or Alt+Tab (Windows) to move the insertion point to the previous clip boundary or MIDI event.

- Hold the Shift key while pressing Tab—or Option+Tab (Mac) or Alt+Tab (Windows)—to move the insertion point and make or extend the edit selection.
Tabbing to MIDI CC Events in MIDI CC Track Views

When a MIDI or Instrument track is set to any MIDI Controller track view and Tab to Transients is enabled, press the Tab key to move to the next MIDI event shown in that track view. Press Option+Tab (Mac) or Alt+Tab (Windows) to move to the previous MIDI event.

Using the Arrow Keys in Notes View or in MIDI Editor Windows

Navigating Notes

In Notes view, use the Left and Right Arrow keys to navigate to and select the previous or the next note.

In Notes view, moving from one note to the next using the Right Arrow key

💡 For MIDI and Instrument tracks in Notes view where any MIDI Controller lanes shown, the Left and Right Arrow keys only navigate through MID notes and skip all MIDI CC events shown in any Controller lane.
Selecting Notes

Hold the Shift key while using the Left and Right Arrow keys to extend the note selection.

Navigating and Selecting Notes in Chords

When navigating through chords with the Left and Right Arrow keys, each note in the chord is recognized as a single event. This lets you move through each note in the chord, selecting each individually.

In Notes view, selecting notes using the Right Arrow key while holding the Shift key

Transposing MIDI Notes with the Arrow Keys

Use the Up and Down Arrow keys, with or without additional key modifiers, to transpose selected MIDI notes up and down on MIDI and Instrument tracks in Notes view or in MIDI Editor windows.

To transpose selected notes up or down by semitones:
- Press the Up Arrow to transpose up or the Down Arrow to transpose down a semitone.

To transpose selected notes up or down by an octave:
- Press Shift+Up Arrow to transpose up or Shift+Down Arrow to transpose down by an octave.

To transpose notes in key according to Key markers in the Key ruler:
- Press Control+Up/Down Arrows (Mac) or Start+Up/Down Arrows (Windows).

To duplicate and transpose selected notes up or down by semitone:
- Press Option+Up/Down Arrows (Mac) or Alt+Up/Down Arrows (Windows).

To duplicate and transpose selected notes up or down by octave:
- Press Option+Shift+Up/Down Arrows (Mac) or Alt+Shift+Up/Down Arrows (Windows).
To duplicate notes when transposing in key (to create chords):

1. Press Control+Option+Up/Down Arrows (Mac) or Start+Alt+Up/Down Arrows (Windows) to duplicate the notes in key.

2. Then Press Control+Up/Down Arrows (Mac) or Start+Up/Down Arrows (Windows) to transpose the duplicate notes to the desired chord tone in the key.

3. Repeat steps 1 and 2 to add more notes to the chord.

Trimming MIDI Notes with the Arrow Keys

Use the Up and Down Arrow keys with key modifiers to trim selected MIDI notes on MIDI and Instrument tracks in Notes view or in MIDI Editor windows.

To trim the note off value of selected notes incrementally by the current grid value, do one of the following:

- Press Option+Left Arrow (Mac) or Alt+Left Arrow (Windows) to shorten selected notes.
- Press Option+Right Arrow (Mac) or Alt+Right Arrow (Windows) to lengthen selected notes.

To trim the note off value of selected notes incrementally by the next larger grid value of the current grid value, do one of the following:

- Press Option+Shift+Left Arrow (Mac) or Alt+Shift+Left Arrow (Windows) to shorten selected notes.
- Press Option+Shift+Right Arrow (Mac) or Alt+Shift+Right Arrow (Windows) to lengthen selected notes.

Editing MIDI Note Velocities with the Arrow Keys

Use the Up and Down Arrow keys with key modifiers to change the velocities of selected MIDI notes on MIDI and Instrument tracks in Notes view or in MIDI Editor windows.

To increase or decrease the velocities of selected notes in increments of 5:

- Press Command+Up/Down Arrow (Mac) or Control+Up/Down Arrow (Windows).

To increase or decrease the velocities of selected notes in increments of 15:

- Press Command+Shift+Up/Down Arrow (Mac) or Control+Shift+Up/Down Arrow (Windows).
Patch Select (Program and Bank Changes)

Each MIDI and Instrument track can have a default program change that is sent each time the track plays. Additional program changes can be inserted at any point within the track.

⚠️ Program changes are sent to external MIDI devices. Instrument plug-ins in Pro Tools do not respond to program change information.

About Program and Bank Changes

The MIDI protocol lets you choose from a range of 128 programs (0–127). However, most MIDI instruments have several banks of 128 programs. To specify a bank, a bank select message must be sent. Some instruments use Controller 0 to switch the bank while others use Controller 32; some use a combination of the two. The Patch Select dialog in Pro Tools lets you use either of these bank select messages when inserting a program change event. Refer to the manufacturer’s documentation for your MIDI device to see which Controller value it uses.

💡 If you do not know what bank select command your instrument uses, you can record MIDI to Pro Tools while making a bank change from the instrument. Then review the bank select information your instrument has recorded into Pro Tools in the MIDI Event List.

💡 Some older MIDI devices (such as the Kurzweil K1000) use a program change instead of a Bank Select message to switch banks. For these devices you may find it necessary to send two program change messages to access a particular program, where the first sets the bank and the second sets the program.

Default Program Change

The default program change for each MIDI track is specified by clicking on the Patch Select button, from either the Mix or Edit window. Once specified, the default program change message is sent to your instrument when playing the track.

To set the default program change for a MIDI or Instrument track:

1. From the Mix or Edit window, click the Patch Select button.

2. Do one of the following:
   - In the Patch Select dialog, select a program number.
Chapter 34: MIDI Editing

• If you are using patch name files, select a patch name (see “MIDI Patch Names” on page 773).

3 Click Done.

Once selected, the program number (or patch name) appears in the Patch Select button in the Edit window.

Patch Select button, Edit window

Unlike recorded and inserted program change events, the default program change does not appear in the track’s playlist.

To clear the default program change, select None in the Patch Select dialog.

**MIDI Patch Names**

Pro Tools supports XML (Extensible Markup Language) for storing and importing patch names for external MIDI devices (such as MIDI instruments). Pro Tools installs MIDI patch name files (.midnam) for the factory default patch names of many common MIDI devices.

💡 **MIDI patch name files (.midnam) can be edited in any text editor, or you can use third-party patch librarian and editor software to create your own custom patch names.**

On Mac, these files reside in /Library/Audio/MIDI Patch Names/Avid.

On Windows, these files reside in Program Files/Common Files/Avid/Pro Tools/MIDI Patch Names.

To import MIDI patch names into Pro Tools:

1 Choose Setup > MIDI > MIDI Studio.

2 Do one of the following depending on your computer platform:
   • On Mac, verify the MIDI Device name in the MIDI Studio window (see “MIDI Studio Setup (Mac)” on page 143).
   • On Windows, verify the MIDI Device name in the MIDI Studio Setup window (see “MIDI Studio Setup (Windows)” on page 145).

3 Verify the Instrument or MIDI track output is correctly assigned to the MIDI device.

4 Click the Instrument or MIDI track Patch Select button.

Patch Select button, Edit window

Patch Select button, Mix window
5

In the Patch Select dialog, click Change.

9

For MIDI devices that have multiple banks of
patches, select which bank of patches you want
from the Bank pop-up menu.

Change button
Patch Select dialog
6

In the Open dialog, do one of the following:
• On Mac, navigate to /Library/Audio/MIDI
Patch Names/Avid/<name of manufacturer>,
and select the MIDI Patch Name file (.midnam) for the MIDI device.
• On Windows, navigate to Program
Files\Common Files\Avid\Pro Tools\MIDI
Patch Names\<name of manufacturer>, and
select the MIDI Patch Name file (.midnam)
for the MIDI device.

Choosing a bank in Patch Select dialog

Once patch names have been imported into
Pro Tools, they are available for that MIDI device
in all sessions.
To clear patch names:

7

Select the MIDI Patch Name file (.midnam) for
the MIDI device.

1

In the Patch Select dialog, click the Clear button.

8

Click Open. The Patch Select dialog is populated by patch names from the selected file.

2

Click Done.

Inserting and Editing Program
Changes
Program changes can be inserted into a track’s
playlist with the Pencil tool. Existing program
changes can be edited, moved, and copied and
pasted.
On some instruments, changing programs
during playback can interrupt playback. To
avoid this, place program change events in
the track where there are no notes sounding.

Patch Select dialog with patch names

774

Pro Tools Reference Guide


To insert a program change with the Pencil tool:

1. Do one of the following:
   - Set the MIDI or Instrument track to Program Change view.
   - Reveal the Controller lane for the MIDI or Instrument track and show Program Change.
2. If you want the inserted event to snap to a Grid value, enable Grid mode.
3. Click with the Pencil tool in the track’s playlist at the point where you want to insert the program change.
4. In the Patch Select dialog, select a program number (or patch name) and, if necessary, specify a bank change value.
5. Click Done to insert the program change event in the track’s playlist.

To edit a program change event:

1. With the Pencil tool or any Grabber tool, double-click the program change event you want to edit.
2. In the Patch Select dialog, select the new program number, or name and specify a bank change value (if necessary).
3. Click Done.

To move a program change event:

- With the Pencil tool or any Grabber tool, drag the program change event left or right.

If the Edit mode is set to Grid, the dragged event snaps to the nearest Grid boundary. If the Edit mode is set to Spot, the Spot dialog opens.

The placement of program changes can also be adjusted with Shift (see “Shift Command” on page 907) or Nudge (see “Nudging Clips” on page 659).

To delete a program change event:

1. With the Track View or Controller lane set to Program Change view, click the program change event with any Grabber tool to select it.
2. Do one of the following:
   - Choose Edit > Clear to remove the selected events from the track.
   - Press Delete (Mac) or Backspace (Windows).

Auditioning Programs

When the Patch Select dialog is open, Pro Tools can automatically scroll through the different patches for a track’s assigned MIDI device.

To audition patches:

1. If you want to audition patches for a MIDI track or Instrument during playback, click Play in the Transport.
2. Open the Patch Select dialog by clicking the Patch Select button, or by inserting or editing a program change event in a MIDI or Instrument track.
3 Click a program number (or patch name)—the starting point from which you will scroll through the patches.

4 Type a value for the number of seconds that will elapse between each program change.

5 Select the Increment Patch option.

After the specified number of seconds, Pro Tools selects the next patch and transmits the program change to the track’s assigned MIDI output.

6 When you are finished auditioning settings, deselect the Increment Patch option and select the program number (or patch name) you want and click Done.

**System Exclusive Events**

System Exclusive (Sysex) events can be recorded to MIDI or Instrument tracks in Pro Tools (see “MIDI Step Input” on page 552). Once the events are recorded, they appear in the track’s playlist as blocks when the Track View is set to Sysex or a Controller lane set to Sysex is shown.

![Sysex event block, Sysex view shown](image)

While the contents of recorded System Exclusive events cannot be directly edited in Pro Tools, the events can be moved or nudged, copied and pasted, or deleted.

**To record a Sysex event:**

1 Create a new MIDI track.

2 Set the MIDI track Input to the MIDI port to which your MIDI device is connected.

3 Configure your MIDI device to send Sysex (such as a bulk dump).

4 Start recording in the Transport.

   *To begin recording the Sysex transfer from your MIDI device at the Timeline insertion point, enable Wait For Note.*

5 Start the Sysex transfer from your MIDI device.

6 When the Sysex transfer from your MIDI device is complete, click Stop in the Transport.

**To move a Sysex event:**

1 Do one of the following:
   - Set the MIDI or Instrument track to Sysex view.
   - Reveal the Controller lane for the MIDI or Instrument track and show Sysex.

2 With any Grabber tool, drag the Sysex event left or right.

If the Edit mode is set to Grid, the dragged event snaps to the nearest Grid boundary. If the Edit mode is set to Spot, the Spot dialog opens.

   *The placement of Sysex event blocks can also be adjusted with Shift (see “Shift Command” on page 907) or Nudge (see “Nudging Clips” on page 659).*
To delete one or more Sysex events:

1. Do one of the following:
   • Set the MIDI or Instrument track to Sysex view.
   • Reveal the Controller lane for the MIDI or Instrument track and show Sysex.

2. Do one of the following:
   • Choose Edit > Clear to remove the selected events from the track.
   • Press Delete (Mac) or Backspace (Windows).

Individually Sysex event blocks can also be deleted by Option-clicking (Mac) or Alt-clicking (Windows) them with the Pencil tool.

---

Note and Controller Chasing

Note Chasing

*Note Chasing* allows long, sustained MIDI notes to be heard when playing from a point after their start time. For example, if a note’s start time is at 1|1|000 and lasts for 8 measures (until 9|1|000), note chasing lets you begin playing from bar 5 and still hear the note that started at 1|1|000 as it continues to sustain until 9|1|000.

Note Chasing is an option that can be turned on and off individually for each MIDI or Instrument track. By default, new MIDI and Instrument tracks have Note Chasing enabled.

---

To enable Note Chasing for a MIDI track:

- Click the track’s Playlist selector and select the Note Chasing option.

Make sure to disable Note Chasing when working with samplers that are playing loops. If a MIDI track, for example, is triggering a 4-bar drum loop and you begin playing at bar 3, the loop will begin playing at the wrong time and be out of synchronization with the other tracks.

Controller and Program Chasing

Pro Tools always chases continuous controller events and program changes for MIDI tracks. This ensures that controller values and patches for MIDI devices are always set correctly.

For example, suppose a MIDI track lasting 32 measures starts with a MIDI volume of 127 and in the last bar fades down to 0. If after playing the track in its entirety you attempt to play from bar 8, the initial MIDI volume of 127 is chased and sent to the track’s assigned device—otherwise the track would not be heard since the most recent volume event sent would have been 0.
Chasing also occurs for a MIDI track’s default program change, along with any program change events residing within the track. Therefore, if you have chosen a default program change for a track, when playing from any point within the track, the program change event is sent to the track’s assigned device.

**Default Controller Values and Chasing**

Though new MIDI tracks appear to have default values for continuous controller playlists, this is actually not the case. For example, when viewing a MIDI track’s Mod Wheel playlist, you’ll see that the breakpoint line is set to a default of zero. However, since the modulation wheel on your MIDI controller may be purposely set to a different value, the default value in the track is not transmitted when playing.

For example, if you record Mod Wheel automation that changes from 0–90 towards the end of the track, and you then play from the beginning of the track, or from anywhere before the change, having the Mod Wheel value remains at 90 until the 0 value is reached is not likely to be what you want.

To ensure that the default controller value for a playlist is sent (and chased), click the initial breakpoint at the beginning of the track, move it slightly, and set it back to the default value.

**Global MIDI Playback Offset**

Pro Tools provides a preference for MIDI offset that lets MIDI and Instrument tracks play back earlier or later (than audio tracks) by the specified number of samples. The offset affects playback only and does not alter in any way how MIDI data is displayed in the Edit window.

This capability is provided in large part to compensate for the audio monitoring latency in host-based Pro Tools. If you are monitoring the output of external MIDI instruments with an external mixer or sound system (or headphones), there is no latency. If, however, you are monitoring the output of your MIDI devices through a Pro Tools interface (such as 003 family devices), your MIDI tracks sound slightly later than your audio tracks. The larger the setting for the H/W Buffer Size (128, 256, 512, or 1024 samples), the larger the latency.

By configuring the Global MIDI Playback Offset setting, you can align your MIDI tracks to play back slightly earlier (by a specified number of samples), thereby compensating for any latency when monitoring audio in Pro Tools host-based systems.

**To configure the Global MIDI Playback Offset:**

1. Choose Setup > Preferences and click the MIDI tab.

2. Enter the number of samples (–10,000 to 10,000) for the Global MIDI Playback Offset setting. A negative value causes the MIDI tracks to play back earlier than the audio tracks; a positive value causes the MIDI tracks to play back later.

To allow for monitoring latency in Pro Tools host-based systems, set the offset to a value that is roughly equivalent to the H/W Buffer Size.

---

**Offsetting MIDI Tracks**

Pro Tools can offset MIDI tracks globally or individually.

💡 When Delay Compensation is active, MIDI and Instrument tracks are automatically delay-compensated to provide low latency monitoring. For more information, see “Delay Compensation for MIDI” on page 1086.
3 Click OK.

💡 The Global MIDI Playback Offset can also be set from the MIDI Track Offsets window. You can also apply MIDI Real-Time Properties delay to offset MIDI (see “MIDI Real-Time Properties” on page 780).

**Individual MIDI and Instrument Track Offsets**

You can offset individual MIDI and Instrument track offsets in Pro Tools to compensate for delays in MIDI devices (the time it takes to trigger events on a sampler or synth).

For example, if you have some kick drums that are being played by an audio track in Pro Tools and want them to be exactly synchronized with kick drums that are being played by a MIDI device, you may need to use a MIDI offset. In this example, it will usually take at least 5 ms to trigger the MIDI notes, and it could take even longer, depending on the MIDI device.

You can measure the latency for a MIDI device assigned to a MIDI track by recording its audio output back into Pro Tools. Compare the sample locations for the recorded audio events against the original MIDI notes to calculate the latency.

To configure a MIDI or Instrument track offset for a track:

1 Choose Event > MIDI Track Offsets.

2 Click in the Sample Offset column for the MIDI or Instrument track and enter the number of samples (–10,000 to 10,000) for the offset. A negative value causes the MIDI or Instrument tracks to play back earlier than the audio tracks; a positive value causes the MIDI or Instrument tracks to play back later.

The equivalent offset in milliseconds is displayed in the msec Offset column. This value cannot be edited, but updates when a new value is entered in the Sample Offset column.

3 Press Return (Mac) or Enter (Windows) to accept the entered offset value.

To reset all offsets for all MIDI and Instrument tracks, click the Reset button in the upper left of the window.
**Stuck Notes**

If you encounter stuck notes with any of your MIDI devices, you can silence them with the All MIDI Notes Off command.

**To turn off all stuck notes:**

- Choose Event > All MIDI Notes Off.

**Remove Duplicate Notes**

The Remove Duplicate Notes command is used to remove duplicate MIDI notes. If a note starts within the first 25% of the duration of a note of the same pitch which is already sounding (or within an eighth-note, whichever is shorter), it is considered a duplicate and is combined with the previous note. If it starts later than that, the first note is shortened so that it ends at the same tick at which the new one starts.

**To remove duplicate notes:**

1. Make an Edit selection including the duplicate notes you want to remove.
2. Choose Event > Remove Duplicate Notes.

---

**MIDI Real-Time Properties**

MIDI Real-Time Properties let you change some MIDI properties of MIDI and Instrument tracks (or MIDI clips) during playback. There are five types of MIDI Real-Time Properties: Quantize, Duration, Delay, Velocity, and Transpose.

MIDI Real-Time Properties can be adjusted during playback, so you can listen to the results. Once you have found the settings you want, you can write the settings to the selected tracks or clips. This overwrites the corresponding MIDI properties on selected tracks or clips and resets the Real-Time Properties display to its default settings.

Real-Time Properties can be adjusted in the Real-Time Properties view in the Edit window, or in the Real-Time Properties window.

⚠️ For MIDI Real-Time Properties to apply to incoming MIDI data with MIDI Thru enabled, the corresponding MIDI and Instrument tracks must be record-enabled.

**Real-Time Properties View**

Real-Time Properties view in the Edit window only applies to tracks. To apply Real-Time Properties to clips, use the Real-Time Properties window (see “Real-Time Properties Window” on page 781).

**To enable Real-Time Properties view in the Edit window:**

- Select View > Edit Window > Real-Time Properties.
For Micro, Mini, and Small track heights, the Real-Time Properties column only displays one or two properties, accordingly. The first one or two properties that are enabled are displayed automatically.

To select a different Real-Time Property in Mini or Small track height view:

- Command-click (Mac) or Control-click (Windows) on a real-time property element to select a different element from the pop-up menu.

Real-Time Properties Window

Using the Real-Time Properties window, you can apply Real-Time Properties to selected tracks or clips.

To open the Real-Time Properties window:

- Choose Event > MIDI Real-Time Properties.

The Real-Time Properties window can be used to apply either track-based or clip-based Real-Time Properties by making an Edit selection and selecting tracks or clips from the Apply To pop-up menu.

Expanded Real-Time Properties Window

In the Real-Time Properties window, Quantize, Duration, and Velocity each provide an expand/collapse triangle to show or hide additional settings.

Enabling Real-Time Properties

To enable Real-Time Properties:

1. Select a track, or make an Edit selection.

When using Real-Time Properties, enable Link Track and Edit Selection mode to make a track selection from an Edit selection (see “Linking or Unlinking Track and Edit Selections” on page 631).
2 In Real-Time Properties view in the Edit window, or in the Real-Time Properties window, select Real-Time Properties by clicking the property name (Quantize, Duration, Delay, Velocity, or Transpose). Enabled Real-Time Properties are highlighted and display their settings.

3 If you are using the Real-Time Properties window and Link Track and Edit Selection mode is enabled, select the track or clip to affect from the Apply To pop-up menu.

4 Configure the Real-Time Properties settings (see “Real-Time Properties Settings” on page 782).

Enabled Real-Time Properties are heard on playback and play through for the selected tracks and clips.

---

**Real-Time Properties Settings**

**Quantize**

Quantize either can be based on a grid or a groove template. For grid quantize, additional tuplet and grid offset settings are available in addition to the standard MIDI quantize properties. For groove quantize, additional controls are provided to set the extent to which the groove’s duration and velocities are applied. Both grid and groove quantize also let you set a strength amount, an “include” range, and a randomize amount.

⚠️ *Quantize cannot be applied as a Real-Time Property to MIDI Input and Thru.*

**Quantize Pop-Up Menu** Select the quantize value, including all standard note rhythm values between whole notes and 64th notes, including dotted and triplet options. This pop-up menu also provides access to all standard and custom groove templates.

**Swing Value** Enter the amount of swing as a percentage between 0 and 300%.

**Tuplet Value** Enable Tuplet and enter the ratio for the tuplet (1–99), such as 3 to 2 or 5 to 4. Tuplet is only available in the expanded Real-Time Properties window.

**Offset Value** Enable Offset and enter the offset value in Ticks between –2000 and 2000. Offset is only available in the expanded Real-Time Properties window.

**Strength Value** Enable Strength and enter the amount as a percentage between 0 and 100%. Strength is only available in the expanded Real-Time Properties window.

**Include** Enable Include and enter the range between 0 and 100%. Include is only available in the expanded Real-Time Properties window.

**Random** Enable Random and enter a percentage between 0 and 100%. Random is only available in the expanded Real-Time Properties window.
Duration

Duration can be used to increase or decrease the duration of MIDI notes by a fixed amount or by a percentage. This is useful for creating legato or staccato passages.

⚠️ Duration cannot be applied as a Real-Time Property to MIDI Input and Thru.

Duration Mode Pop-Up Menu

Select one of the following options from the Duration Mode pop-up menu: Set, Add, Subtract, Scale, Legato/Gap, or Legato/Overlap.

Duration Amount

If the Ticks/Notes pop-up menu is set to ticks, enter a duration as a number of quarter notes plus a number of ticks, such as 4|000. If the Ticks/Notes pop-up menu is set to a note size, enter a number to by which to multiply that note size, such as seven 16th notes.

Ticks/Notes Pop-Up Menu

The Ticks/Notes pop-up menu lets you select either Ticks or a note size for Note Durations. There is also a Ticks/Notes pop-up menu for the Minimum and Maximum Durations options.

Minimum and Maximum Durations

Enable either or both minimum and maximum durations and enter a value in quarter notes plus ticks or as a multiple of a note size. The Minimum (Min) and Maximum (Max) Durations options are only available in the expanded Real-Time Properties window.
Delay

Delay lets you delay or advance all MIDI data in the selected clip or track. Select “+” from the Delay pop-up menu to delay MIDI data, or select “−” to advance MIDI data. Select Ticks or Milliseconds (MS) from the Ticks/Milliseconds pop-up menu. Enter the Delay amount in Tick or Millisecond values. Delay is limited to a maximum of value of 2000 ms or 999 ticks.

Velocity

Velocity lets you change MIDI velocity by a percentage or by constant value. Enter a percentage value in the Dynamics field to scale velocity around the median velocity of 64. You can also enter an offset by adding (+) or subtracting (−) values between 1 and 127. You can also enter Minimum and Maximum Velocity value limits. The Minimum (Min) and Maximum (Max) Velocity options are only available in the expanded Real-Time Properties window.

Transpose

Transpose lets you transpose MIDI notes up or down by a specified number of octaves and semitones, or in key by scale steps (based on the Key Signature ruler). You can also transpose to a specified pitch. Select By, To, or In from the Transpose pop-up menu to transpose by an interval, to a specific pitch, or in key by scale steps.

To transpose by an interval, enter the number of octaves and semitones as a positive or negative numbers.

To transpose to a specific pitch, enter the MIDI note name.

To transpose in key by scale steps, enter the number of steps as a positive or negative numbers. For example, enter +2 to transpose up by thirds in key (a unison plus a second equals a third).

Real-Time Properties on Tracks and Clips

Real-Time Properties can be configured to apply to an entire track (all clips on that track), or on a clip-by-clip basis. Track-level properties also provide real-time MIDI input processing of velocity and transposition.

The presence of track-based Real-Time Properties are indicated by a “T” displayed in the upper right-hand corner of MIDI clips. Clip-based Real-Time Properties are indicated by an “R” displayed in the upper right-hand corner of the clip. Clips boundaries including the “T” and the “R” displays are indicated in Notes view and in MIDI Editor windows, but not in the Score Editor window.
Clip-Based Real-Time Properties

Clip-based Real-Time Properties can only be applied using the Real-Time Properties window (Event > MIDI Real-Time Properties). Real-Time Properties can be applied to multiple clips. Once Real-Time Properties have been assigned to a clip, the clip can be moved or copied and pasted and retain its Real-Time Properties.

Track-Based Real-Time Properties

All track-based Real-Time Properties consistently apply to MIDI data throughout the entire track. However, clips with clip-based Real-Time Properties will take precedence over any track-based Real-Time Properties. You can clear clip-based Real-Time Properties by selecting the clip and clicking the Clear Clip Properties button in the Real-Time Properties window (see “Writing Real-Time Properties to Tracks or Clips” on page 785).

For greater flexibility, when Real-Time Properties are assigned on a track basis they are actually contained in a track playlist. This lets you create multiple playlists containing different Real-Time Property settings.

Writing Real-Time Properties to Tracks or Clips

Once you have found the settings you want, you can write Real-Time Properties to the selected tracks or clips using the Real-Time Properties window. Real-Time Properties are applied to the current MIDI data on the track or in a clip.

To write Real-Time Properties to tracks:

1. Enable Link Track and Edit Selection.
2. Select one or more tracks to which you want to apply Real-Time Properties.
4. Select Tracks from the Real-Time Properties Apply To pop-up menu.
5. Configure the Real-Time Property settings.
6. Do one of the following:
   • Click the Write to Track button in the Real-Time Properties window.
   • Choose Track > Write MIDI Real-Time Properties.

To write Real-Time Properties to clips:

1. Select one or more clips to which you want to apply Real-Time Properties.
3. If Link Track and Edit Selection is enabled, select Clips from the Real-Time Properties Apply To pop-up menu.
5. Click the Write to Clip button.
To clear Real-Time Properties from a clip:
1. Select the clip for which you want to clear Real-Time Properties.
3. Select Clips from the Real-Time Properties Apply To pop-up menu.
4. Click the Clear Clip Properties button.

**Real-Time Properties In the MIDI Event List**

In the MIDI Event List, the presence of track-based Real-Time Properties are indicated by a “T” displayed to the right of each event. Clip-based Real-Time Properties are indicated by an “R.”

*For more information on the MIDI Event List, see Chapter 37, “MIDI Event List.”*

**Display of Real-Time Properties Effects**

The Display Events as Modified by the Real-Time Properties option determines if Pro Tools displays the effects of Real-Time Properties in both the Edit window, MIDI Editor windows, the Score Editor window, and the MIDI Event List. The Edit window, MIDI Editor windows, the Score Editor window, and the MIDI Event List all display the effects of Real-Time Properties when the Display Events as Modified by Real-Time Properties option is enabled. With this option disabled, the effects of Real-Time Properties are heard but not seen—you see the notes and other MIDI events at their original locations, pitches, durations, and velocities, but you hear them as they are affected by the Real-Time Properties settings.

To enable or disable the Display Events as Modified by Real-Time Properties option:
1. Choose Setup > Preferences, and click the MIDI tab.
2. Enable or disable the Display Events as Modified by Real-Time Properties option.
3. Click OK.

**Real-Time Properties Effects Displayed in the MIDI Event List**

The MIDI Event List takes into account the effect of Real-Time Properties whenever the Display Events as Modified by Real-Time Properties option is enabled. When editing or inserting an event in a track or clip with active Real-Time Properties, Pro Tools takes the properties into account and edits or inserts the event in a different place if necessary to match the effect of the Real-Time Properties.

**Real-Time Properties Effects Displayed in the Edit Window**

MIDI events appear where they sound in the Edit window, MIDI Editor windows, and the Score Editor window, with the Display Events as Modified by Real-Time Properties option enabled in the MIDI preferences. However, MIDI events are not actually written to their modified locations until you write the Real-Time Properties to the track or clip.

When moving MIDI events, the actual locations (pitch or time) move by the amount the events are dragged, but the effect of Real-Time Properties is displayed.

When inserting an event in a track or clip with active properties, Pro Tools takes the properties into account and edits or inserts the event in a different place if necessary to match the effect of the Real-Time Properties.
Chapter 35: MIDI Editors

Pro Tools provides MIDI Editor windows for detailed MIDI editing.

MIDI Editor window
Superimposed MIDI and Instrument Tracks

MIDI Editor windows display and let you edit MIDI data (notes, velocities, and continuous controller data) for one or more MIDI or Instrument tracks. When displaying multiple tracks in a MIDI Editor window, MIDI notes from different tracks are superimposed. MIDI Editor windows can also show Auxiliary Input tracks.

Automation and Controller Lanes

Velocity, other continuous controller data (MIDI and Instrument tracks), and automation data (Instrument and Auxiliary Input tracks only), can be edited along with MIDI notes and appear in Controller lanes under the Notes pane. Velocities for MIDI notes on multiple tracks are also superimposed in the Velocity lane. However, for all other automation and controller data, additional lanes are shown for each automation or controller type for each track.

For example, if two Instrument tracks are shown in a MIDI Editor window, the MIDI notes for each track are superimposed in the Notes pane and the velocities for each track are superimposed in the Velocity lane. However, you would see two Mod Wheel Controller lanes, one for each track; and you would see two Volume lanes, one for each track.

Opening a MIDI Editor Window

To open a MIDI Editor window, do one of the following:

- Choose Window > MIDI Editor.
- In the Edit window, Right-click a MIDI clip on the track, or the track name in the track controls or in the Tracks List, and choose Open in MIDI Editor.
- In the Score Editor window, Right-click anywhere on the score, or on a track name in the Tracks List, and choose Open in MIDI Editor.

Press Control+“=” (Mac) or Start+“=” (Windows) to open a MIDI Editor window.

If the MIDI Editor option is selected as the “Double Clicking a MIDI Clip Opens” setting in the Pro Tools MIDI Preferences, you can double-click a MIDI clip to open it in a MIDI Editor.

To open additional MIDI Editor windows, do one of the following:

- Deselect the Target button in the open MIDI Editor window and open another MIDI Editor window.
- Right-click in the open MIDI Editor window and select Open in New MIDI Editor.

To bring an open MIDI Editor window to the front:

- Choose Window > MIDI Editor and select the MIDI Editor window you want.

To cycle through all open MIDI Editor windows, press Control+“=” (Mac) or Start+“=” (Windows) repeatedly until the window you want is in the front.
MIDI Editor Window Toolbar

The MIDI Editor window toolbar is similar to the Edit window toolbar, but with a few exceptions. Each MIDI Editor window and the Edit window can be configured independently of one another. For example, you can have Notation view enabled in one MIDI Editor window, but not another; or you can have a MIDI Editor window set to Grid mode, but the Edit window set to Slip mode. You can also customize the toolbar in MIDI Editor windows.

Record-Enable, Solo, and Mute Buttons

In a MIDI editor window, the Record-enable, Solo, and Mute buttons affect tracks in all windows. They let you either audition the tracks shown in the current MIDI Editor window without the rest of the mix, or let you hear just the mix without the tracks shown in the MIDI Editor window. Additionally, these buttons provide a quick visual indication as to whether or not any MIDI or Instrument tracks are record-enabled, soloed, or muted.

Record-Enable

The Record-enable button lets you record-enable (or record-disable) all the tracks currently displayed in the MIDI Editor window.

Solo

The Solo button lets you solo all the tracks currently displayed in the MIDI Editor window.

Mute

The Mute button lets you mute all the tracks currently displayed in the MIDI Editor window.

Mixed Record-Enable, Mute, and Solo States

The Record-enable, Solo, and Mute buttons in MIDI Editor windows are global controls in that they affect all tracks shown in a MIDI Editor window. If you independently record-enable, solo, or mute tracks in the Edit window that are also shown in a MIDI Editor window, the appearance of the Record-enable, Solo, and Mute buttons update to indicate mixed states. Mixed states occur when one or more tracks shown in the MIDI Editor window, but not all, are record-enable, soloed, or muted respectively.

Notation View

The Notation view button lets you view MIDI notes in the MIDI Editor window as music notation. In Notation view, MIDI and Instrument tracks are not superimposed, but are shown as staves just like in the Score Editor window.

Notation view enabled in a MIDI Editor window

💡 You can access the Notation Display Track Settings in a MIDI Editor window when in Notation view. Select the Notation Display Track Settings option from the Tracks List menu or Right-click in the Notes pane and select the Notation Display Track Settings option from the Right-click menu. For more information, see “Notation Display Track Settings” on page 816.
**Edit Tools**

The Edit tools in MIDI Editor windows can be viewed as a single tool with a pop-up menu for selecting other tools, or as an expanded, complete row of Edit tool icons just like in the Edit window. The Edit tools in MIDI Editor windows function exactly the same way for MIDI data as in the Edit window. Edit tool settings can be set independently in each MIDI Editor window, and are independent of tool selection in the Edit window and Score Editor.

**To view the Expanded Edit tools in a MIDI Editor window, do one of the following:**

- Click the MIDI Editor Window Toolbar menu and select Expanded Edit Tools.
- Right-click in the toolbar and select Expanded Edit Tools.

**To revert to the single Edit Tool icon with the Edit Tool pop-up menu:**

- Deselect Expanded Edit Tools.

**MIDI Editing Controls**

The MIDI Editing controls function exactly the same way in MIDI Editor windows as in the Edit window.

- **Track Edit Selector**
  If more than one MIDI or Instrument track is shown in the MIDI Editor window, the Track Edit selector lets you select which track is “pencil-enabled.” You can manually insert MIDI notes only in pencil-enabled tracks. You can also pencil-enable tracks in the Tracks List (see “Manually Inserting MIDI Notes” on page 800).

- **Default Note Duration**
  The Default Note Duration selector lets you define the default note duration for manually inserted notes.

- **Default Note On Velocity**
  The Default Note On Velocity setting lets you define the default Note On velocity for manually inserted notes.

- **Play MIDI Notes When Editing**
  When enabled, Play MIDI Notes When Editing causes MIDI notes to sound when you insert them with the Pencil tool, click them with the Grabber tool, Tab to them, or select them with the Note Selector tool.

- **Link Timeline and Edit Selection**
  When this button is enabled, the Timeline and Edit selections are linked. When it is disabled, you can make Timeline and Edit selections independently of one another.
Mirrored MIDI Editing

Mirrored MIDI Editing lets you edit MIDI clips and have your edits apply to every copy of the same MIDI clip. This can be particularly useful when editing looped MIDI clips.

If Mirrored MIDI Editing mode is disabled, and you edit notes of looped clips in Notes view, the edit flattens the loop. Similarly, editing clip groups separates the clip groups.

Edit Modes

The Edit modes in MIDI Editor windows function exactly the same way for MIDI data as in the Edit window. Edit mode settings are unique to each MIDI Editor window and are also set independently of the Edit window.

Cursor Location Display

The Cursor Location display in MIDI Editor windows functions exactly the same way in MIDI Editor windows as in the Edit window.

Edit Selection Display

The Edit Selection display in MIDI Editor windows functions exactly the same way for MIDI data in MIDI Editor windows as in the Edit window. The Selection display can be shown or hidden in the Toolbar.

To show (or hide) the Edit Selection display in a MIDI Editor window, do one of the following:

- Click the MIDI Editor Window Toolbar menu and select (or deselect) Selection Display.
- Right-click in the toolbar and select (or deselect) Selection Display.

MIDI Input Display

The MIDI Input display shows note and chord names as they are received by tracks shown in the Edit and MIDI Editor windows. For example, when an Instrument or MIDI track is record-enabled and a MIDI controller is assigned to its Input, note names and recognized chords are displayed as you play your controller.

Display of a single note being played

Display of a known chord being played

Display of several notes being played simultaneously that Pro Tools does not recognize as a chord

To show (or hide) the MIDI Input display in a MIDI Editor window:

1. Click the MIDI Editor Window menu or Right-click anywhere in the MIDI Editor window toolbar.
2. Select (or deselect) MIDI Input Display.

Note names are displayed as the note letter name and register number (for example, C3 or C4) or as the MIDI note number (for example, 60) according to the specified Note Display option in the Pro Tools MIDI Preferences (Setup > Preferences > MIDI).
Grid and Nudge Selectors

When the Expanded Grid/Nudge Display option is enabled in the MIDI Editor Window menu, the Grid and Nudge selectors in MIDI Editor windows function exactly the same way for MIDI data in MIDI Editor windows as in the Edit window.

When the Expanded Grid/Nudge Display option is disabled in the MIDI Editor Window menu, you can toggle between Grid Display and Nudge Display using the Grid/Nudge Display selector.

To enable or disable the Target for a MIDI Editor window:

- Click the Target button for the MIDI Editor window so that it is highlighted (targeted) or un-highlighted (untargeted).

Target

Generally, the Target button for MIDI Editor windows functions just like the Target button for Plug-In, Output, and Send windows. Additionally, the Target button in a MIDI Editor window synchronizes its Timeline location view to the Timeline location view in the Edit window. Any changes to the Edit selection in the Edit window are reflected in the Targeted MIDI Editor window. There can only be one targeted MIDI Editor window at a time. The targeted MIDI Editor window can also be stored in a Window Configuration.

One or more untargeted MIDI Editor windows can remain open and available at the same time, just like untargeted Plug-In windows. Targeting an untargeted MIDI Editor window disables any other targeted MIDI Editor window.

The front-most window, regardless of whether it is targeted, always receives Commands Keyboard Focus and control surface focus.

MIDI Editor Window Menu

The MIDI Editor Window menu provides access to MIDI Editor Window Display options and Scrolling options.

MIDI Editor Window Display Options

Expanded Edit Tools

When selected, the Expanded Edit Tools option displays all of the Edit Tools in the MIDI Editor window toolbar.
When this option is not selected, only the icon for the selected Edit tool is displayed. Any of the other Edit tools can be selected from the Edit Tool pop-up menu.

**Expanded Grid/Nudge Display**

When selected, the Expanded Grid/Nudge Display option displays the Nudge selector in addition to the Grid selector in the MIDI Editor window toolbar.

**Selection Display**

When selected, the Selection Display option shows the Edit Selection Display in the MIDI Editor window toolbar.

**MIDI Input Display**

When selected, the MIDI Input Display option shows the MIDI Input display in the MIDI Editor window.

**Tracks List**

When selected, the Tracks List option displays the Tracks List in the MIDI Editor window.

**Scrolling Submenu**

The Scrolling submenu lets you select the scrolling options for the MIDI Editor window independently of other MIDI Editor windows and the Edit window. The scrolling options include:

- **No Scrolling** The MIDI Editor window does not scroll during or after playback. The playback cursor moves across the MIDI Editor window, indicating the playback location.

- **After Playback** The playback cursor moves across the MIDI Editor window, indicating the playback location. When playback has stopped, the MIDI Editor window scrolls to the final playback location.

- **Page** The playback cursor moves across the MIDI Editor window, indicating the playback location. When the right edge of the MIDI Editor window is reached, its entire contents are scrolled, and the playback cursor continues moving from the left edge of the window.

- **Continuous** The MIDI Editor window scrolls continuously past the playback cursor, which remains in the center of the window. With this option, playback is always based on the Timeline selection (unlike the Center Playhead Scrolling option).
Center Playhead (Pro Tools Ultimate Only) The MIDI Editor window scrolls continuously past the Playhead, which is represented as a blue line in the center of the window (or a red line when recording).

Follow Edit Window When selected, the MIDI Editor window follows the scrolling option selected for the Edit window (Options > Edit Window Scrolling).

Keep MIDI Editor Window On Top
The MIDI Editor window lets you set it to remain in the foreground even when clicking on and focusing another window (such as the Edit or Mix windows).

Enable the Keep Window On Top option in the MIDI Editor window menu to ensure that the window remains in the foreground when working with other windows. When this option is disabled, clicking on another window (such as the Edit or Mix windows) brings that window to the front and the MIDI Editor window may be hidden behind it.

To keep the MIDI Editor window always in front of all other windows:
- From the MIDI Editor window menu, select the Keep Window On Top option.

Customizable Toolbar
You can customize the toolbar in MIDI Editor windows by rearranging, and showing and hiding the available controls and displays just like in the Edit window or the Score Editor window.

Changing Toolbar Display Options
To change the toolbar display options in a MIDI Editor window toolbar:
1. Do one of the following:
   - Click the MIDI Editor Window Toolbar menu.
   - Right-click in the toolbar.
2. From the pop-up menu, select or deselect any of the following:
   - Expanded Edit Tools
   - Expanded Grid/Nudge Display
   - Selection Display

Rearranging Controls and Displays
You can rearrange the controls and displays in the MIDI Editor window toolbar just like in the Edit window or the Score Editor window.

To rearrange controls and displays in a MIDI Editor window toolbar:
- Command-click (Mac) or Control-click (Windows) the controls or displays you want to move and drag them to the location in the Toolbar you want.
MIDI Editor Zoom Controls

Vertical and Horizontal Zoom In and Out Buttons

In addition to the Zoom controls in the Toolbar, Pro Tools provides horizontal and vertical zoom buttons in the lower-right corner of MIDI Editor windows.

Vertical Zoom Buttons Zoom the lane heights proportionally for Automation and Controller lanes.

Horizontal Zoom Buttons Zoom the Timeline just like the Horizontal Zoom controls in the MIDI Editor window toolbar.

MIDI Zoom In and Out Buttons

Pro Tools provides MIDI Zoom In and Out buttons in the upper-right corner of MIDI Editor windows. These controls function exactly the same as the MIDI Zoom controls in the toolbar, and let you zoom in and out vertically on MIDI notes.

Tracks List

The Tracks List in MIDI Editor windows lets you show or hide MIDI, Instrument, and Auxiliary Input tracks in the MIDI Editor window. The Tracks List settings are unique to each MIDI Editor window. However, the order of tracks in the Tracks List is global. Sorting or changing the order of tracks affects the Tracks List in every window.

Tracks List Columns

In MIDI Editor windows there are four columns for the Tracks List:

- **Show/Hide** Indicates which tracks are shown or hidden in the MIDI Editor window.
- **Track Color** Displays the track color for each track by type or by track.
- **Name** Displays the name for each track.
- **Pencil** Lets you enable a track for manually entering MIDI notes with the Pencil tool.

Tracks List Menu

The Tracks List menu lets you show and hide MIDI, Instrument, and Auxiliary Input tracks in the MIDI Editor window (see “Showing and Hiding Tracks” on page 796).
The Tracks List menu also lets you sort tracks in the Tracks List by Name, Type, Edit Group, Mix Group, or Voice (see “Sorting Tracks in the Tracks List” on page 796).

### Showing and Hiding Tracks

#### To show MIDI, Instrument, and Auxiliary Input tracks in a MIDI Editor window:
- Enable the Track Show/Hide icon in the Tracks List for tracks you want to show in the MIDI Editor window.

#### To show all MIDI, Instrument, and Auxiliary Input tracks in a MIDI Editor window:
- From the Tracks List menu, select Show All Tracks.

#### To show only selected MIDI, Instrument, and Auxiliary Input tracks in a MIDI Editor window:
1. In the Tracks List, select the MIDI, Instrument, and Auxiliary Input tracks you want to show in the MIDI Editor window.
2. From the Tracks List menu, select Show Only Selected Tracks.

#### To show all tracks of a single type (MIDI or Instrument) in a MIDI Editor window:
- From the Tracks List menu, choose Show Only, and select the track type you want.

#### To hide MIDI, Instrument, and Auxiliary Input tracks in a MIDI Editor window:
- Disable the Track Show/Hide icon for tracks you want to hide in the MIDI Editor window.

#### To hide all (but one) MIDI, Instrument, and Auxiliary Input tracks in a MIDI Editor window:
- From the Tracks List menu, select Hide All Tracks.

All but the top MIDI or Instrument track in the Tracks List are hidden. MIDI Editor windows require that at least one MIDI or Instrument track always be shown in the window.

#### To hide selected MIDI, Instrument, and Auxiliary Input tracks in a MIDI Editor window:
1. In the Tracks List, select the MIDI, Instrument, and Auxiliary Input tracks you want to hide.
2. From the Tracks List menu, select Hide Selected Tracks.

### Sorting Tracks in the Tracks List

You can sort tracks in the Tracks List by the following criteria:

- **Name** Sorts the order of tracks in the Tracks List by Track Name.
- **Type** Sorts the order of tracks in the Tracks List by Track Type.
- **Edit Group** Sorts the order of tracks in the Tracks List by Edit Groups.
- **Mix Group** Sorts the order of tracks in the Tracks List by Mix Groups.
- **Voice** Sorts the order of tracks in the Tracks List by Voice allocations.

### Tracks List Right-Click Menu

In addition to common track management commands, the Tracks List Right-click menu shares commands with both the Tracks List menu and the Notes Pane Right-click menu.

#### To access the MIDI Editor Tracks List Right-click menu:
- Right-click on any Track Name in the Tracks List.
Tracks List Right-click Menu Options

The following options are available depending on the track type (Auxiliary Input, Instrument, or MIDI).

**Hide** Hides the selected track.

**Hide and Make Inactive** Hides the selected track and makes it inactive.

**Make Inactive** Makes the selected track inactive.

**Export MIDI** Exports the selected track as a MIDI file.

**New** Opens the New Track dialog.

**Rename** Renames the selected track.

**Duplicate**Duplicates the selected track.

**Split into Mono** Splits the selected stereo Instrument or Auxiliary Input track into two mono tracks.

**Delete** Deletes the selected track.

**MIDI Real-Time Properties** Opens the MIDI Real-Time Properties window for the selected track.

**Open in New MIDI Editor** Opens the tracks displayed in the current MIDI Editor window in a new MIDI Editor window. The new MIDI Editor window will be untargeted.

**Open in Score Editor** Opens the shown tracks in the Score Editor window.

**Open in MIDI Event List** Opens the selected track in the MIDI Event List.

**Notation Display Track Settings** Opens the Notation Display Track Settings window.

---

**Groups List**

The Groups List in MIDI Editor windows provides the same functionality as in the Edit window. You can create, edit, and delete Edit Groups using the Groups List in any MIDI Editor window. The Groups List is linked between the Edit window and all MIDI Editor windows.

*For information on grouping tracks, see Chapter 15, “Grouping Tracks.”*

---

**Timebase and Conductor Rulers**

Timebase and Conductor rulers in MIDI Editor windows function exactly the same as in the Edit window. However, the Edit window and each MIDI Editor window can have a unique view of the Timeline in terms of which Timebase and Conductor rulers are shown, and in terms of zoom level and time location.
Superimposed Notes View

The Notes pane in MIDI Editor windows lets you view and edit MIDI notes superimposed from different MIDI and Instrument tracks such that you can easily edit multitrack arrangements in a single constellation of color-coded notes. The Notes pane lets you edit MIDI notes much the same way as in Notes view on MIDI and Instrument tracks in the Edit window, except you can edit MIDI notes on multiple MIDI and Instrument tracks at the same time.

💡 You can also view and edit MIDI notes in Notation view in the Notes pane (see “Notation View” on page 802).

Color Coding MIDI Notes

You can color code MIDI notes by Track or by Velocity.

Color Coding by Track

When Color Coding by Track is enabled, tracks in the MIDI Editor are temporarily assigned one of sixteen fixed colors, in the order they appear in the Tracks List.
To Color Code MIDI notes by Track:
- Enable the Color Code MIDI Notes By Track button

Color Coding by Velocity

When Color Coding by Velocity is enabled, MIDI notes are all the same red color (hue) on all tracks displayed, and MIDI notes vary in color saturation (from a light red to a dark red) based on the Note On velocity. Notes with low velocities are lighter in color and those with high velocities are darker.

To Color Code MIDI notes by Velocity:
- Enable the Color Code MIDI Notes By Velocity button.

No Color Coding

When neither Color Coding by Track nor Color Coding by Velocity are enabled, notes are drawn in the MIDI Editor in as the same color they are in the Edit window—using the color coding options as set in the Track Color Coding settings in the Display Preferences.
Editing MIDI Notes

You can edit any note on any track shown in the Notes pane. You edit MIDI notes in the Notes pane the same way as in Notes view for MIDI and Instrument tracks in the Edit window, except that notes from different tracks are superimposed.

For more information on editing MIDI notes, see Chapter 34, “MIDI Editing.”

Manually Inserting MIDI Notes

Using the Pencil tool, you can manually insert MIDI notes to any pencil-enabled track shown in the Notes pane. If only one track is viewed in the MIDI Editor window, that track will automatically be pencil-enabled. If multiple superimposed tracks are shown in the Notes pane, MIDI notes will be inserted on the pencil enabled tracks only.

For more information on manually inserting MIDI notes, see “Inserting MIDI Notes” on page 750.

To insert MIDI notes on a specific track in the Notes pane:

1. Do one of the following:
   - Select the track you want pencil-enabled from the Track Edit selector in the Toolbar.
   - Click the Pencil column in the Tracks List to pencil-enable the track you want.

2. With the Pencil tool, click at a time and pitch location to insert a MIDI note on the pencil-enabled track with the default Note On velocity and the selected Default Note Duration.

Selecting a track for editing

Only tracks that are currently shown in the MIDI Editor window are available in the Track Edit selector pop-up menu.

To pencil-enable multiple contiguous tracks, Shift-click in the Pencil column of the range of tracks you want. To pencil-enable multiple discontiguous tracks, Command-click (Mac) or Control-click (Windows) in the Pencil column of any additional tracks. Option-click (Mac) or Alt-click (Windows) to pencil-enable all tracks. Manually inserted notes are written to all pencil-enabled tracks.
Notes Pane Right-Click Menu

The Notes Pane Right-click menu provides several useful commands for editing, exporting, and viewing MIDI data.

To access the MIDI Editor Right-click menu:
- Right-click anywhere in the Notes pane.

Notes Pane Right-Click Menu Options

Tools
The Tools submenu lets you select any Edit tools relevant to the Score Editor.
- **Zoomer** Selects the Zoomer tool.
- **Trim** Selects the Trim tool.
- **Selector** Selects the Selector tool.
- **Grabber** Selects the Grabber tool.
- **Scrubber** Selects the Scrubber tool.
- **Pencil** Selects the Pencil tool.
- **Smart** Selects the Smart tool.
- **Zoomer Tools** Lets you select Normal Zoom or Single Zoom.
- **Pencil Tools** Lets you select any of the Pencil tools.

Insert
The Insert submenu lets you insert key changes, meter changes, and chord symbols at the location of the Edit cursor.
- **Key** Inserts a key change.
- **Meter** Inserts a meter change.
- **Chord** Inserts a chord symbol.

Cut
The Cut command cuts the current Edit selection.

Copy
The Copy command copies the current Edit selection.

Paste
The Paste command pastes the clipboard to the current Edit selection or at the current Edit cursor location. Any MIDI notes already present at the same location are overwritten.

Merge
The Merge command pastes the clipboard to the current Edit selection or at the current Edit cursor location and merges the pasted data with any MIDI notes already present at the same location.

Clear
The Clear command clears (deletes) the current Edit selection.

Separate
The Separate command lets you separate MIDI notes at the Edit cursor location.

Consolidate
The Consolidate command lets you consolidate selected multiple consecutive MIDI notes of the same pitch.

Mute Notes
The Mute Notes (or Unmute Notes) command lets you mute (or unmute) selected MIDI notes.

MIDI Real-Time Properties
Selecting the MIDI Real-Time Properties option opens the MIDI Real-Time Properties window.
Event Operations

The Event Operations submenu lets you select any of the Event Operations windows (such as Quantize or Change Velocity).

Open In New MIDI Editor

Selecting the Open In New MIDI Editor option opens all shown tracks in a new MIDI Editor window.

Open In Score Editor

The Open In Score Editor option opens the shown tracks in the Score Editor window.

Open in MIDI Event List

The Open In MIDI Event List option opens the selected track in the MIDI Event List.

Display Notation

Selecting the Display Notation option changes the MIDI Editor to Notation view. Deselecting this option reverts the MIDI Editor to Notes view.

Notation View

The Notes pane in MIDI Editor windows can also display MIDI notes in standard music notation. In Notation view, each MIDI and Instrument track is displayed independently, with one track per staff.

In MIDI Editor windows, notation is displayed as a continuous timeline and not in page view as in the Score Editor window.

For information on editing notation, see “Editing Notes” on page 819.
To enable Notation view, do one of the following:

- Enable the Notation view button in the MIDI Editor window toolbar.

- Right-click in the Notes pane and select Notation View.

Editing in Notation view in a MIDI Editor window works the same way as in the Score Editor window, but with the advantage of having access to Velocity, Controller, and Automation lanes.

In Notation view, the Trim tool functions as the Grabber tool when over a note and as the Note Selector tool when not over a note.

In Notation view, the Edit mode is automatically set to Grid and cannot be changed.

**Double Bar in Notation View**

The Double Bar button is only available in Notation view. When enabled, the Double Bar option shows the final double bar line in the MIDI Editor window. The double bar line is located at the end of the last MIDI clip or event in the session.

When the Double Bar option is disabled, there will be a number of empty bars at the end of the last event in the session. The number of empty bars is determined by the Additional Empty Bars In The Score Editor setting in the MIDI Preferences page (Setup > Preferences). Disable the Double Bar option to manually enter notes in the Score Editor after the last MIDI clip or event in the session.

**Notation View Right-Click Menu**

When in Notation view, the Notes Pane Right-click menu provides slightly different options than when in Superimposed Notes view.

In both views, the following options are available:

- Tools
- Insert
- Cut
- Copy
- Paste
- Clear
- Separate
- Consolidate
- Mute
- MIDI Real-Time Properties
- Event Operations
- Open In New MIDI Editor
- Open In Score Editor
- Open In MIDI Event List.
- Display Notation

In Notation view, the additional Notation Display Track Settings option is available in the Right-click menu. Select this option to open the Notation Display Track Settings dialog and configure the
display settings for tracks in Notation view. For information on the Notation Display Track Settings dialog, see “Notation Display Track Settings” on page 816.

**Velocity, Controller, and Automation Lanes**

MIDI Editor windows let you edit velocities, MIDI controller data, and automation for all shown MIDI, Instrument, and Auxiliary Input tracks in lanes under the Notes pane. You can move and resize Automation and Controller lanes just like in the Edit window. When viewing multiple MIDI and Instrument tracks, the velocities for notes on separate tracks are superimposed in a single lane, just like notes in the Notes pane. However, all other Controller lanes are grouped by automation and controller type, and provide individual lanes for each shown track.

*To show or hide lanes under the Notes pane:*
- Click the Show/Hide Lanes button.

*To add lanes:*
- Click the Add Lane button.

*To remove lanes:*
- Click the Remove Lane button.

*To change the Automation or Controller type for a lane:*
- Click the Automation or Controller Type selector and select the Automation or Controller type you want.
Chapter 36: Score Editor

The Score Editor window lets you view, edit, arrange, and print MIDI from your session as music notation. MIDI notes are transcribed in real-time whether you record, import, draw (with the Pencil tool), or Step Enter MIDI.
Opening the Score Editor Window

To open the Score Editor window:

- Choose Window > Score Editor.

Press Option+Control+“=” (Mac) or Alt+Start+“=” (Windows) to show the Score Editor window.

To open the Score Editor window with a single MIDI or Instrument track shown:

1. Ensure that there is no Edit selection.
2. Right-click the Track name of an unselected track in the Edit or Mix window, or in the Tracks List of the Edit, Mix, or MIDI Editor window.
3. From the Right-click menu, choose Open In Score Editor.

To open the Score Editor window with the current Edit selection shown:

1. In the Edit window or in a MIDI Editor window, make an Edit selection on one or more tracks that includes what you want shown in the Score Editor window.
2. Right-click the Edit selection and choose Open In Score Editor.

If the Score Editor option is selected as the “Double Clicking a MIDI Clip Opens” setting in the MIDI Preferences page, you can double-click a MIDI clip to open it in the Score Editor.

Edit Tools

The Edit tools in the Score Editor window function much the same as in the Edit window, but with a few differences for editing music notation.

Zoomer

Use the Zoomer tool to zoom in and out around a particular area in the score.

The Zoomer tool provides two modes:

Normal Zoom The Zoomer tool remains selected after zooming.

Single Zoom The previously selected Edit tool is automatically reselected after zooming.

Press the F5 key to select the Zoomer tool and toggle between Normal and Single Zoom modes.

Also see “Score Editor Zoom Controls” on page 815

Normal Zoom Mode

To zoom around a certain point in the score:

1. Click the Zoomer tool pop-up menu and select Normal Zoom mode.
2. Click once with the Zoomer tool at a location within the score. The score is zoomed in by one level and is centered around the zoomed location.
3. To zoom back to the previous level, Option-click (Mac) or Alt-click (Windows) with the Zoomer tool.
To marquee zoom to a particular area of the score:

1. Click the Zoomer tool pop-up menu and select Normal Zoom mode.

2. Drag in the score, making a marquee selection of the area to which you want to zoom.

The zoomed area fills the entire Edit window.

Single Zoom Mode

Single Zoom mode returns you to the previously selected tool after a zoom has been performed.

For example, when using the Pencil tool you can select the Single Zoomer tool, and once the Zoom operation has been performed, Pro Tools automatically switches back to the Pencil tool.

Single Zoom is identified with an arrow to the right of the Zoomer icon. (Normal Zoom mode does not show the arrow.)

To use Single Zoom mode:

- Click the Zoomer tool pop-up menu and select Single Zoom mode.

Trim

The Trim tool lets you lengthen or shorten the duration of a note in the Score Editor window.

> Press the F6 key to select the Trim tool.

Note Selector

Use the Note Selector tool to select notes on one or more staves in the Score Editor window. Selected notes highlight blue. Selected notes can be deleted, moved, transposed, and processed (using Event Operations).

> Press the F7 key to select the Note Selector tool.

> The Note Selector tool makes a range selection that only includes MIDI notes and velocities. It does not include any other MIDI data, such as program changes or continuous controller data.

Grabber

Use the Grabber tool to select one or more notes in the Score Editor window. You can also use the Grabber tool to move single notes, or all selected notes, to a different pitch or time location.

> Press the F8 key to select the Grabber tool.
**Pencil**

Use the Pencil tools to insert, select, move, or delete notes in the Score Editor window. The various Pencil tools differ in how they draw note durations, repeated notes, and velocities, but function the same when drawing notes on tracks in Notes view in the Edit window or in a MIDI Editor window.

**To select a Pencil tool:**

- Click the Pencil tool pop-up menu and select the Pencil tool you want.

  *Press the F10 key repeatedly to cycle through the different Pencil tools.*

The following Pencil tools are available in the Score Editor:

**Free Hand**

The Free Hand Pencil tool lets you draw single notes of varying duration.

Note velocities are determined by the Default Note Velocity setting (see “Default Note On Velocity” on page 809).

The minimum duration of the note is determined by the selected Default Note Duration (see “Default Note Duration” on page 809).

**Line**

The Line Pencil tool lets you draw multiple notes of the same pitch and duration.

Note velocities are determined by the Default Note Velocity setting (see “Default Note On Velocity” on page 809).

The duration is determined by the selected Default Note Duration (see “Default Note Duration” on page 809).

The start time for each note is determined by the selected Grid value (see “Grid” on page 811).

**Triangle**

The Triangle Pencil tool lets you draw a series of MIDI notes on a single pitch whose velocities oscillate between the defined Default Note Velocity and 127 in a triangle pattern. The duration of each note is determined by the current Grid value.

The duration is determined by the selected Default Note Duration (see “Default Note Duration” on page 809).

The start time for each note is determined by the selected Grid value (see “Grid” on page 811).

**Square**

The Square Pencil tool lets you draw a series of MIDI notes on a single pitch whose velocities alternate between the defined Default Note Velocity and 127 in a square pattern. The duration of each note is determined by the current Grid value.

The duration is determined by the selected Default Note Duration (see “Default Note Duration” on page 809).

The start time for each note is determined by the selected Grid value (see “Grid” on page 811).

**Random**

The Square Pencil tool lets you draw a series of MIDI notes on a single pitch whose velocities change randomly within the range between the defined Default Note Velocity and 127 in a square pattern. The duration of each note is determined by the current Grid value.

The duration is determined by the selected Default Note Duration (see “Default Note Duration” on page 809).

The start time for each note is determined by the selected Grid value (see “Grid” on page 811).
**Default Note Duration**

The Default Note Duration selector lets you define the default note duration for manually inserted notes.

**To define the Default Note Duration:**

- From the Default Note Duration selector, select a note value. Select the Follow Grid option if you want the Default Note Duration to use the selected Grid value.

If you want dotted note values, also select the Dotted option.

If you want triplet note values, also select the Triplet option.

**Default Note On Velocity**

The Default Note On Velocity setting lets you define the default Note On velocity for manually inserted notes.

**Play MIDI Notes When Editing**

When enabled, the Play MIDI Notes When Editing option causes MIDI notes to sound when you insert them with the Pencil tool or drag them with the Grabber tool.

**Link Timeline and Edit Selection**

When this button is enabled, the Timeline and Edit selections are linked. When it is disabled, you can make Timeline and Edit selections independently of one another.
Mirrored MIDI Editing

Mirrored MIDI Editing lets you edit MIDI clips and have your edits apply to every copy of the same MIDI clip. This can be particularly useful when editing looped MIDI clips.

In Mirrored MIDI Editing mode, the Mirrored MIDI Editing button flashes Red once as an edit is made to alert you that your edit is being applied to more than one clip.

To enable Mirrored MIDI Editing, do one of the following:
- Select Options > Mirror MIDI Editing.
- Select the Mirrored MIDI Editing button in the Edit window, MIDI Editor window, or Score Editor window.

Double Bar

When enabled, the Double Bar option shows the final double bar line in the Score Editor window. The double bar line is located at the end of the last MIDI clip or event in the session. Enable the Double Bar option when you are ready to print the score.

When the Double Bar option is disabled, there will be a number of empty bars at the end of the last MIDI clip in the session. The number of empty bars is determined by the Additional Empty Bars In The Score Editor setting in the Pro Tools MIDI Preferences (Setup > Preferences). Disable the Double Bar option to manually enter notes in the Score Editor after the last MIDI clip.

Mouse Location

The Cursor Location display provides information about the current cursor location in Bars|Beats|Ticks and pitch.

⚠️ If Mirrored MIDI Editing mode is disabled, and you edit notes of looped clips in Notes view, the edit flattens the loop. Similarly, editing clip groups separates the clip groups.
Grid

The Grid selector lets you define the Grid value for MIDI notes inserted and displayed in the Score Editor window.

To set the Grid value for the Score Editor window:

- From the Grid Value pop-up menu, select a note value.

If you want dotted note values, also select the Dotted option.

If you want triplet note values, also select the Triplet option.

Inserting Notes on the Grid

When inserting MIDI notes with the Pencil tool (using the Line, Triangle, Square, or Random shapes), the Grid value determines the Note On location and the Default Note Duration value determines the note duration (see “Default Note Duration” on page 809).

For example, if the Default Note Duration is set to quarter notes and the Grid is set to half notes, drawing with the Line Pencil tool creates alternating quarter notes and quarter note rests.

Score Editor Window Target

When the Target is enabled for the Score Editor window, navigating the Edit window automatically navigates the Score Editor window as well. For example, if in the Edit window you navigate to bar 32, beat 3 in a MIDI track, when you view the Score Editor window it too will show the same location.

When the Target is disabled, the Score Editor does not update to show the current Edit window selection or Edit cursor location.
Score Editor Window Menu

The Score Editor Window menu provides access to the Expanded Edit Tools, Selection Display, Tracks List, and Scrolling options.

Expanded Edit Tools

When selected, the Expanded Edit Tools option displays all of the relevant Edit Tools in the Score Editor window toolbar.

When this option is not selected, only the icon for the selected Edit tool is displayed. Any of the other Edit tools can be selected from the Edit Tool pop-up menu.

Selection Display

When selected, the Selection Display option shows the Edit Selection Display in the MIDI Editor window toolbar.

Tracks List

When selected, the Tracks List option displays the Tracks List in the Score Editor window.

Scrolling

The Scrolling submenu lets you select the scrolling options for the Score Editor window independently of the Edit window and any MIDI Editor windows. The scrolling options include:

No Scrolling The Score Editor window does not scroll during or after playback. The playback cursor moves across the Edit window, indicating the playback location.

After Playback The playback cursor moves across the Score Editor window, indicating the playback location. When playback has stopped, the Score Editor window scrolls to the final playback location.

Page The playback cursor moves across the Score Editor window, indicating the playback location. When the right edge of the current page shown in the Score Editor window is reached, it scrolls to the next page and the playback cursor continues moving from the left edge of the window.

Follow Edit Window When selected, the Score Editor window follows the scrolling option selected for the Edit window (Options > Edit Window Scrolling).

For Pro Tools HD systems, the Continuous and Center Playhead scrolling options are not available in the Score Editor window. If the Score Editor window is set to the Follow Edit Window scrolling option and the Edit window is set to either the Continuous or Center Playhead scrolling options, the Score Editor window scrolls by page.

Keep Score Editor Window On Top

The Score Editor window lets you set it to remain in the foreground even when clicking on and focusing another window (such as the Edit or Mix windows).

Enable the Keep Window On Top option in the Score Editor window menu to ensure that the window remains in the foreground when working with other windows. When this option is disabled, clicking on another window (such as the Edit or Mix windows) brings that window to the front and the Score Editor window (whichever one you are working with) may be hidden behind it.
To keep the Score Editor window always in front of all other windows:

- From the Score Editor window menu, select the Keep Window On Top option.

Customizable Toolbar

You can customize the toolbar in the Score Editor window by re-arranging, and showing or hiding the available controls and displays just like in the Edit window or MIDI Editor windows.

Changing Toolbar Display Options

To change the toolbar display options in the Score Editor window toolbar:

1. Do one of the following:
   - Click the Score Editor Window Toolbar menu.
   - Right-click in the Toolbar.
2. From the pop-up menu, select or deselect any of the following:
   - Selection Display
   - Expanded Edit Tools

Rearranging Controls and Displays

To rearrange controls and displays in a MIDI Editor window toolbar:

- Command-click (Mac) or Control-click (Windows) the controls or displays you want to move and drag them to a new location in the Toolbar.

Tracks List

The Tracks List lets you show and hide MIDI and Instrument tracks in the Score Editor. It also provides access to the Notation Display Track Settings and Score Setup (see “Notation Display Track Settings” on page 816 and “Score Setup” on page 817).

To show or hide the Tracks List in the Score Editor window:

- From the Score Editor Window menu, select or deselect Tracks List.

Showing and Hiding Tracks

Use the Tracks List to show and hide MIDI and Instrument tracks as staves in the score.

To show MIDI and Instrument tracks in the Score Editor:

- Enable the Track Show/Hide icon in the Tracks List for tracks you want to show in the score.

Partial Score: Violin I and Violin II shown; all other tracks are hidden
To show all MIDI and Instrument tracks in the Score Editor:
- From the Tracks List menu, select Show All Tracks.

To show only selected MIDI and Instrument tracks in the Score Editor:
1. In the Tracks List, select the MIDI and Instrument tracks you want to show in the score.
2. From the Tracks List menu, select Show Only Selected Tracks.

To hide MIDI and Instrument tracks in the Score Editor:
- Disable the Track Show/Hide icon in the Tracks List for tracks you want to hide in the score.

To hide all MIDI and Instrument tracks in the Score Editor:
- From the Tracks List menu, select Hide All Tracks.

To hide selected MIDI and Instrument tracks in the Score Editor:
1. In the Tracks List, select the MIDI and Instrument tracks you want to hide in the score.
2. From the Tracks List menu, select Hide Selected Tracks.

Page Controls

The Score Editor window provides controls for navigating forward and backward by page. The current page number is displayed in the lower-left corner of the window.

To display the next page of the score:
- Click the Page Forward button.

To display the previous page of the score:
- Click the Page Back button.

To display any specific page of the score:
1. Click the Current Page display.
2. Type the page number for the page you want to view.
3. Press Return (Mac) or Enter (Windows).
Score Editor Zoom Controls

In addition to the Zoomer tool, the Score Editor provides Zoom In and Out buttons in the lower right hand corner of the window. It also provides a Zoom selector that lets you zoom to a preset percentage or page size. When using these Zoom controls, the Score Editor zooms around the current Edit selection.

To zoom in one level:
- Click the Zoom In button.

To zoom out one level:
- Click the Zoom Out button.

To zoom to a preset percentage:
1. Click the Zoom selector.
2. From the Zoom pop-up menu, select the zoom percentage.

Selecting a zoom percentage from the Zoom pop-up menu

To zoom to a page size:
1. Click the Zoom selector.
2. From the Zoom pop-up menu, select the page size.

Zoom to Page Sizes

The Zoom pop-up menu provides the following page sizes:

- **Fit Page Width** Zooms so that the width of one page fits in the Score Editor window.
- **Fit Page Height** Zooms so that the height of the page fits in the Score Editor window.
- **Fit Page** Zooms so that an entire page fits in the Score Editor window.
- **Fit 2 Pages** Zooms so that two pages fit horizontally in the Score Editor window.
Notation Display Track Settings

The Notation Display Track settings determine how individual MIDI and Instrument tracks appear in the Score Editor. You can set the Clef, Display Quantization, and whether or not to display the track at “concert pitch” or as a transposing instrument (such as a B-flat tenor sax).

To configure the Notation Display Track settings:

1. Do one of the following:
   - From the Track menu in the Score Editor, select Notation Display Track Settings.
   - Right-click in the Score Editor and select Notation Display Track Settings.
   - Double-click a Clef on a Staff.

2. From the Track pop-up menu, select the MIDI or Instrument track whose Notation Display Settings you want to change.

3. Configure the settings.

4. Repeat the preceding steps for other MIDI and Instrument tracks as necessary.

Notation Display Track Settings Options

Track

From the Track pop-up menu, select the track you want to configure.

Clef

From the Clef pop-up menu, select the Clef you want for the selected track from the following options:

- Grand Staff
- Treble Clef
- Bass Clef
- Alto Clef
- Tenor Clef

Display Transposition

From the Key pop-up menu, select the key of Transposition for the track. For instruments that transpose from another octave, you can also adjust the Octave slider. For example, for a Bass Clarinet track, select the Key of B-flat and set the Octave slider to +1. This way, when you print the Bass Clarinet part, the player will be able to read the part and concert pitch will sound correctly a major ninth below where the part is written.

Attributes

The Attributes tab lets you specify the notation display quantization settings for the selected track. If the Clef is set to Grand Staff, you can also set the Split Point to divide notes between the treble and bass clefs.
Follow Globals

When the Follow Globals option is selected, the track attributes use the global attributes settings (see “Globals” on page 817). This option is enabled for all tracks by default.

Display Quantization

The Display Quantization setting lets you select the quantization grid for the display of MIDI notes in music notation. MIDI notes in Pro Tools still maintain their original start time and duration, but this setting affects what note values are displayed. The notation display is quantized to the nearest select note value.

Straighten Swing

When enabled, the Straighten Swing option causes “swung” notes to be displayed as straight notation. For example, a run of swung eighth notes will be displayed as straight eighth notes.

Allow Note Overlap

Pro Tools only displays a single rhythmic line on a single staff. When two notes that start at different times overlap, the first note will be truncated when the second note begins. If the Allow Note Overlap option is enabled, Pro Tools displays the full length of overlapping notes using tied notes.

Split Point

When the Clef for the selected track is set to Grand Staff, the selected Split Point setting determines at which pitch the notes are placed in either the upper or lower staff of the Grand Staff.

Automatic When selected, Pro Tools splits notes between the upper and lower staves of the Grand Staff based on logical note groupings.

Fixed When selected, you can specify a particular pitch at which to split notes between the upper and lower staves of the Grand Staff.

Globals

The Globals tab provides the same settings as the Attributes tab (see “Attributes” on page 816). You can select which tracks follow the settings in the Globals tab in the Attributes tab for each track.

Score Setup

The Score Setup window lets you set up the page layout and staff spacing. You can enter the Title and Composer for the score. You can also select what elements of the score to display. Changes to the Score Setup update instantly in the Score Editor.

To open the Score Setup, do one of the following:

- Choose File > Score Setup.
- From the Tracks List menu in the Score Editor window, select Score Setup.
- Right-click in the Score Editor window and select Score Setup.
### Score Setup Window Options

**Information**

**Title** Enter the Title for the score. This appears at the top of the first page.

**Composer** Enter the Composer for the score. This appears in the upper right-hand corner of the first page.

**Display**

The Display options determine which score elements you want displayed in the score. Deselect the elements you do not want displayed in the score.

- **Title and Composer** Select to display the Title and Composer on the score.
- **Page Numbers** Select to display Page Numbers at the bottom of each page.
- **Bar Numbers** Select to display Bar Numbers at the beginning of each system above the top staff.
- **Track Names** Select to display Track Names for each staff at the beginning of the score.
- **Chord Symbols** Select to display chord symbols in the score.
- **Chord Diagrams** Select to display Chord Diagrams (guitar tablature) in the score (see “Chord Symbols and Diagrams” on page 824).

* Disable the Chord Diagrams option when printing charts and lead sheets where you just want to see chord symbols.*
Spacing

**Between Staves** Enter the spacing you want between staves.

**Between Systems** Enter the spacing you want between systems.

⚠️ *On pages where the music is vertically justified, the distance between staves and systems will be larger than the numbers specified.*

**Below Title and Composer** Enter the spacing you want between the Title and Composer and the first staff of the score.

**Below Chord Symbols and Diagrams** Enter the spacing you want between Chord Symbols and Diagrams and the top stave of each system.

Layout

**Page Size** Select the page size (Letter, Legal, Tabloid, or A4).

**Portrait** Select to set the page orientation to Portrait.

**Landscape** Select to set the page orientation to Landscape.

**Staff Size** Enter the Staff Size.

**Page Margins** Enter the size for the top, bottom, left, and right page margins.

**Inches** Select to enter Stave Size and Page Margins in inches.

**Millimeters** Select to enter Stave Size and Page Margins in millimeters.

---

Editing Notes

MIDI note editing in the Edit window, MIDI Editor windows, and the Score Editor window all affect the same MIDI data. When editing in one window, your edits are reflected in all other windows.

The Score Editor provides simple score editing tools for entering, moving, and transposing MIDI notes as music notation:

- The Trim tool lets you lengthen or shorten the duration of notes.
- The Note Selector tool lets you make object selections of notes in the score.
- The Grabber tool lets you select and move notes to another time or pitch location on the same track.
- The Pencil tool lets you insert notes and move them to another time or pitch location on the same track.

Selecting Notes

You can use either the Note Selector tool or the Grabber tool to select notes on one or more staves.

**To select notes on one or more staves with the Note Selector tool:**

1. Click the Note Selector tool.
2. Drag in the score to highlight the notes you want to select.

---

Selecting notes with the Note Selector tool
To make a marquee selection on one or more staves with the Grabber tool:

1 Click the Grabber tool.
2 Drag in the score to highlight the notes you want to select.

To transpose a single note:

1 Click the Grabber tool.
2 Drag the note you want to transpose up or down.

To transpose all selected notes:

1 Click the Grabber tool.
2 Drag around the notes you want to Transpose to select them.
3 Drag any of the selected notes up or down to transpose them.

Transposing Notes

You can use the Grabber tool or the Pencil tool to manually transpose a note up or down. You can also use the Transpose Event Operation (Event > Event Operations > Transpose) to transpose selected notes.

To transpose a single note:

1 Click the Grabber tool.
2 Drag the note you want to transpose up or down.

Moving Notes

Use the Grabber tool to move selected notes from one time location to another time location on the same staff. When moving notes in the Score Editor, the underlying MIDI notes maintain their position relative to the Grid.

To move notes to another time location:

1 Click the Grabber tool.
2 If you want to move more than one note, drag around the notes you want to move to select them.
3 Drag any of the selected notes to another time location on the same staff.

You can also Nudge notes in the Score Editor by the currently selected Grid value.
Inserting Notes

Use the Pencil tool to manually insert notes in the Score Editor. When you insert a note, the Score Editor automatically places it on the Grid and creates rests where appropriate.

💡 You can also enter notes by recording MIDI, importing MIDI from a file, or using Step Input (Event > Event Operations > Step Input).

To manually insert a note:

1. Select the Default Note Duration setting (see “Default Note Duration” on page 809).
2. Select the Grid setting (see “Grid” on page 811).
3. Select the Default Note On Velocity (see “Default Note On Velocity” on page 809).
4. Click the Pencil tool and select Free Hand.
5. With the Free Hand Pencil tool, do any of the following:
   - Single-click at the time location and pitch you want to enter a single note of the selected Default Note Duration.

![Entering a single note with the Pencil tool]

To manually insert multiple notes of the same pitch:

1. Select the Default Note Duration setting (see “Default Note Duration” on page 809).
2. Select the Grid setting (see “Grid” on page 811).
3. Select the Default Note On Velocity (see “Default Note On Velocity” on page 809).
4. Click the Pencil tool and select any of the following shapes:
   - Line
   - Triangle
   - Square
   - Random

![Entering a single longer note with the Pencil tool]
5 Click at the time location and pitch and drag to the right. Repeated notes of the selected Default Note Duration are entered on the selected Grid. The Note On velocities for each note are determined in part by the Default Note On Velocity setting and the selected Pencil tool shape (see “Pencil” on page 808).

Rests

The Score Editor automatically adds rests as necessary. Rests cannot be moved or inserted manually.

Score Editor Right-Click Menu

The Score Editor Right-click menu provides several useful commands for editing, exporting, and formatting the score and MIDI data.

To access the Score Editor Right-click menu:
- Right-click anywhere on the score.

Score Editor Right-Click Menu Items

Tools

The Tools submenu lets you select any Edit tools relevant to the Score Editor.

Zoomer Selects the Zoomer tool.

Note Selector Selects the Note Selector tool.

Grabber Selects the Grabber tool.

Pencil Selects the Pencil tool.

Insert

The Insert submenu lets you insert key changes, meter changes, and chord symbols into the score at the location of the Edit cursor.

Key Inserts a key change.

Meter Inserts a meter change.

Chord Inserts a chord symbol.

Cut

The Cut command cuts the current Edit selection.

Copy

The Copy command copies the current Edit selection.

Paste

The Paste command pastes the clipboard to the current Edit selection or at the current Edit cursor location. Any MIDI notes already present at the same location are overwritten.

Merge

The Merge command pastes the clipboard to the current Edit selection or at the current Edit cursor location and merges the pasted data with any MIDI notes already present at the same location.

Clear

The Clear command clears (deletes) the current Edit selection.
Event Operations

The Event Operations submenu lets you select any of the Event Operations windows (such as Quantize or Change Velocity).

Open in MIDI Editor

Choosing the Open in MIDI Editor option opens the tracks shown in the Score Editor in a MIDI Editor window.

Open in MIDI Event List

The Open In MIDI Event List option opens the selected track in the MIDI Event List.

Notation Display Track Settings

Choosing the Notation Display Track Settings option opens the Notation Display Track Settings dialog (see “Notation Display Track Settings” on page 816).

Score Setup

Choosing the Score Setup option opens the Score Setup dialog (see “Score Setup” on page 817).

Send to Sibelius

Choosing the Send to Sibelius option command sends the score exactly as it appears in the Score Editor window to Sibelius notation software (see “Exporting Scores” on page 826).

Print Score

Choosing the Print Score command prints the score (see “Printing Scores” on page 826).

Key Changes

You can add, edit, and delete Key Signatures in your score. Key Signatures affect the note spelling of MIDI notes in the score. For example, MIDI note number 58 ("B-flat 3") is B-flat in F major, but it is A-sharp in B major.

You can also add and delete Key Signatures in the Key Signatures ruler in the Edit window or in any MIDI Editor window.

To add a Key Signature:

1. With the Note Selector, Grabber, or Pencil tool, Right-click at the location in the score where you want to change key and select Insert > Key Change.
2. In the Key Change dialog, select the mode (major or minor), the key, its location and range, and how you want it to affect pitched tracks.
3. Click OK.

The selected Key Signature is displayed in the score and the note spellings for notes after the key change are updated accordingly.

To edit a Key Signature:

1. With the Grabber tool, double-click the Key Signature you want to edit.
2. Enter values in the Key Change dialog and click OK.

To delete a Key Signature:

- With the Grabber tool, Option-click (Mac) or Alt-click (Windows) the Key Signature you want to delete.
Meter Changes

You can add, edit, and delete Meters in your score. Meter changes affect the number of bars in the score (and in your session). When changing meter, notes are not moved, but the barlines will be redrawn.

You can also add and delete Meters in the Meter ruler in the Edit window and in MIDI Editor windows.

To add a Meter change:

1. Do one of the following:
   - Choose Event > Time Operations > Change Meter.
   - With the Note Selector, Grabber, or Pencil tool, Right-click at the location in the score where you want to change meter and select Insert > Meter Change.

2. In the Meter Change dialog, enter the Location and Meter for the meter change.

3. If you want the inserted meter event to fall cleanly on the first beat of the nearest measure, select the Snap To Bar option.

4. Select a note value for the number of clicks to sound in each measure. For a dotted-note click value, select the dot (.) option in addition to the note value.

   For some meters, it may be desirable to use a dotted value for the click. For instance, if using a meter of 6/8, a dotted quarter note click (yielding two clicks per measure) is generally more suitable than a straight eighth note click (six clicks per measure).

5. Click OK to insert the new meter.

To edit a Meter change:

1. With the Grabber tool, double-click the Meter event you want to edit.

2. Enter values in the Meter Change dialog and click OK.

To delete a Meter change:

- With the Grabber tool, Option-click (Mac) or Alt-click (Windows) the Meter event you want to delete.

Chord Symbols and Diagrams

You can add, edit, and delete chord symbols and chord diagrams (guitar tablature) in your score. Chord symbols have no effect on MIDI data. Also, chord symbols are not included when exporting MIDI data from Pro Tools to a MIDI file, but they are included when exporting to a Sibelius file (.sib) or when using the Send to Sibelius command.

You can also add and delete chord symbols in the Chord Symbol ruler in the Edit window and in MIDI Editor windows. However, Chord Diagrams (guitar tab) are only displayed in the Score Editor window.
To insert a chord symbol:

1. With the Note Selector, Grabber, or Pencil tool, Right-click at the location in the score where you want to add a chord symbol and select Insert > Chord.

2. In the Chord Change dialog, select the name for the root of the Chord from the Chord selector (such as D).

3. Select the quality from the Chord Quality selector (such as major or minor).

4. Select the bass note of the chord from the Bass selector (such as B-flat for an inverted G minor chord).

5. Select a Chord Diagram (guitar tablature) from the available options.

6. Click OK.

The selected chord symbol is placed above the top staff in the system.

To edit a chord symbol:

1. With the Grabber tool, double-click the chord symbol you want to edit.

2. Make changes in the Chord Change dialog, and click OK.

To move a chord symbol:

- With the Grabber tool, drag the chord symbol to a new location.

To delete a chord symbol:

- With the Grabber tool, Option-click (Mac) or Alt-click (Windows) the chord symbol you want to delete.

To display or hide chord symbols in the score:

- In the Score Settings dialog (File > Score Setup), enable or disable the Chord Symbols option.

To display or hide chord diagrams (guitar tab) in the score:

- In the Score Settings dialog (File > Score Setup), enable or disable the Chord Diagrams option.
Exporting Scores

Pro Tools lets you export the score from your session as a Sibelius (.sib) file. You can then open your score in Sibelius as transcribed by Pro Tools, edit the notation in Sibelius, and print the score and parts from Sibelius.

⚠️ Sibelius 5.x or higher is required to open .sib files exported from Pro Tools.

To export a score from Pro Tools:
1. Configure the score for your session in Score Editor window.
2. Choose File > Export > To Sibelius.
3. Select a destination and click Save.

To send the score from your Pro Tools session to Sibelius, do one of the following:
1. Configure the score for your session in the Score Editor window.
2. Choose File > Export > To Sibelius.
3. Select a destination and click Save.

Printing Scores

Pro Tools lets you print the score from your Pro Tools session. The score will be printed exactly as it appears in the Score Editor window. Configure the Score Setup and show or hide any MIDI and Instrument tracks. Only those tracks that are shown in the score will be printed.

To print the score from your Pro Tools session:
1. Open the Score Editor window and configure your score.
2. Choose File > Print Score.
3. Configure the Print dialog as necessary and click Print (Mac) or OK (Windows).

Press Command+P (Mac) or Control+P (Windows) to print the score.
Chapter 37: MIDI Event List

The MIDI Event List displays a detailed list of all events in a single MIDI or Instrument track. The events are displayed with text and numbers, allowing you to precisely edit their location, length, and event values.

Opening the MIDI Event List

To open the MIDI Event List, do one of the following:

- Choose Window > MIDI Event List.
- Right-click a MIDI or Instrument track name in the Mix or Edit window, or in the Tracks List.

Press Option+Equal (Mac) or Alt+Equal (Windows) to open the MIDI Event List.

Track Selector

The Track selector in the MIDI Event List both indicates the currently displayed MIDI or Instrument track and can be used to choose a different MIDI or Instrument track to be displayed.

Number of Events

The number of MIDI events on the selected track are displayed at the top of the MIDI Event List.

Target

The Target button for the MIDI Event List determines whether or not the MIDI Event List follows the Edit cursor and Edit selections in the Edit window and MIDI Editor windows. For example, when the Target is enabled, the Events shown in the MIDI Event List update to show the event in

Unlike playlists in the Edit window, you can insert and display polyphonic aftertouch in the MIDI Event List.

Mute data for MIDI and Instrument tracks is not displayed in the MIDI Event List.
the Edit selection in the Edit window. When the Target is disabled, the MIDI Event List shows the same events regardless of changes to the Edit selection in other windows.

**MIDI Event List Menu**

The MIDI Event List menu contains commands and options for the MIDI Event List (see “MIDI Event List Options” on page 834).

**Columns in the MIDI Event List**

Information for the events in the MIDI Event List is displayed in the following three columns:

**Start Column** Displays the start location, using the Main Time Scale, for each event. Locations can also be displayed in the Sub Time Scale when the Show Sub Counter option is selected in the Options pop-up menu.

The playback cursor appears as a blue arrow (red, when tracks are record-enabled) in the Start column.

When several events reside at the same location, the location is only indicated for the top event, with the others dimmed. The dimmed locations can be edited by double-clicking them.

**Event Column** Displays the event type, indicated by an icon, and associated event values.

**Length/Info Column** Displays the end point or length for notes, depending on which option is selected in the Options pop-up menu. Also displayed are the names for continuous controller events and program changes.

**View Filter for MIDI Event List**

You can use the View Filter to specify which event types are displayed in the MIDI Event List. This can help you zero in on only the events you want to affect; it also protects MIDI events from being edited or deleted. Events not displayed in the MIDI Event List still play back.

The View Filter can be set to display “all” messages, “only” the specified messages, or “all except” the specified messages.

⚠️ *When inserting an event type that has been filtered from the MIDI Event List, that event type will no longer be filtered.*

**Example: To filter the display of aftertouch and System Exclusive Messages in the MIDI Event List:**

1. In the MIDI Event List, choose View Filter from the MIDI Event List menu.

   With the MIDI Event List as the front-most window, press Command+F (Mac) or Control+F (Windows) to open the MIDI Event List View Filter dialog.
2 In the MIDI Event List View Filter dialog, select the All Except option.

MIDI Event List View Filter dialog

3 Select the options for Mono Aftertouch, Polyphonic Aftertouch, and System Exclusive. Leave all other messages deselected.

When using the All Except option, the selected events are not displayed. Conversely, when using the Only option, only the selected events are displayed.

4 Click OK.

Navigating in the MIDI Event List

You can use the Tab and Arrow keys to move through the MIDI Event List. You can also locate to the Edit start point, or any other specified location.

To move through the MIDI Event List, do any of the following:

• Double-click to edit a value.
• Press Tab or the Down Arrow to move to the next event (with or without the edit field selected).

• Press Option+Tab (Mac) or Control+Tab (Windows) or the Up Arrow to move to the previous event (with or without the edit field selected).
• With an edit field selected, press the Right Arrow to move to the next edit field to the right.
• With an edit field selected, press the Left Arrow to move to the next edit field to the left.

To keep the last event selected, press Shift while moving to the next or previous event.

To go to the Edit start point:

■ In the MIDI Event List, choose Scroll To Edit Selection from the MIDI Event List menu.

To go to a specific location in the MIDI Event List:

1 In the MIDI Event List, choose Go To from the MIDI Event List menu.

   • With the MIDI Event List as the front-most window, press Command+G (Mac) or Control+G (Windows) to open the Go To dialog.

2 In the Go To dialog, choose a format from the Time Scale pop-up menu.

   3 If using Timecode, you can select the Use Subframes option.

4 Enter the location you want to go to, then click OK.
The following items from the MIDI Event List menu affect navigating in the MIDI Event List:

- When the Page Scroll During Playback option is selected, the MIDI Event List scrolls during playback.
- When Scroll During Edit Selection is selected, the MIDI Event List is scrolled automatically when the Edit selection changes in the Edit window.

## Inserting Events in the MIDI Event List

You can insert events in the MIDI Event List by choosing an event type from the MIDI Event List menu. Following are several examples of inserting events in the MIDI Event List.

### To insert a note in the MIDI Event List:

1. From the MIDI Event List menu, select Insert > Note.

   With the MIDI Event List as the front-most window, press Command+N (Mac) or Control+N (Windows) to Insert a note.

2. Enter the location, pitch, attack (Note On) and release (Note Off) velocities, and length for the new note. To move between the Event Entry fields, use the Left and Right Arrow keys.

   With the Start field selected, you can automatically enter the location of another event already in the track by clicking that event.

3. Do one of the following:
   - To insert the note and remain in Event Entry mode, press Enter on the numeric keypad.
   - To insert the note and exit Event Entry mode, press Return (Mac) or Enter (Windows) on the alphanumeric keyboard.
   - To exit Event Entry mode, without inserting the note event, press Escape on the alphanumeric keyboard.

### To insert a controller event in the MIDI Event List:

1. From the MIDI Event List menu, choose Insert > Controller.

   With the MIDI Event List as the front-most window, press Command+L (Mac) or Control+L (Windows) to Insert a controller event.

2. Enter the location, controller “type” number, and controller value for the new event. The controller name is displayed in the Length/Info column, to the right of the controller value. To move between the Event Entry fields, use the Left and Right Arrow keys.
When a field is selected, enter a value with any of the following methods:

- Enter the value on the numeric keypad.
- Press the Up or Down Arrow to scroll to the value.
- While pressing Command (Mac) or Control (Windows), drag up or down to scroll to the value.
- Play the controller event on your MIDI controller keyboard, then press Return (Mac) or Enter (Windows) on the alphanumeric keyboard to confirm the value.

3 Do one of the following:

- To insert the controller event and remain in Event Entry mode, press Enter on the numeric keypad.
- To insert the controller event and exit Event Entry mode, press Return (Mac) or Enter (Windows) on the alphanumeric keyboard.
- To exit Event Entry mode, without inserting the controller event, press Escape on the alphanumeric keyboard.

To insert a program change in the MIDI Event List:

1 From the MIDI Event List menu, choose Insert > Program Change.

   With the MIDI Event List as the front-most window, press Command+P (Mac) or Control+P (Windows) to Insert a program change event.

2 Enter the location for the new event.

3 Enter a Program Change number and Bank Select value (if necessary). The program change name is displayed in the Info column.

4 Do one of the following:

- To insert the program change and remain in Event Entry mode, press Enter on the numeric keypad.
- To insert the program change and exit Event Entry mode, press Return (Mac) or Enter (Windows) on the alphanumeric keyboard.
- To exit Event Entry mode, without inserting the program change, press Escape on the alphanumeric keyboard.

Event Entry fields for controller event

When a field is selected, enter a value with any of the following methods:

Event Entry fields for program change

You can click in the Length/Info column to open the Program Change window (for details, see “Patch Select (Program and Bank Changes)” on page 772).
Inserting Another Event

After inserting an event, you can easily insert another event of the same type. The event type to be inserted is indicated at the bottom of the Insert menu.

**Example:** After inserting a note, to insert another, do one of the following:

- From the MIDI Event List menu, select Insert > Another Note.

With the MIDI Event List as the front-most window, press Command+M (Mac) or Control+M (Windows) to Insert a note.

When the option for Insert At Playback Location is enabled (see “MIDI Event List Options” on page 834), you can use the keyboard shortcuts for inserting “another” event to insert events on-the-fly.

Editing Events in the MIDI Event List

Events in the MIDI Event List can be edited, selected, deleted, and copied and pasted.

**To edit an event in the MIDI Event List:**

1. Do one of the following:
   - Double-click the event field you want to edit.
   - To edit a selected event, press Command+Enter (Mac) or Control+Enter (Windows).

2. Enter a new value with any of the following methods:
   - Enter the new value on the numeric keypad.
   - While pressing Option (Mac) or Alt (Windows), press the Up or Down Arrow to scroll to a new value.
   - While pressing Command (Mac) or Control (Windows), drag up or down to scroll to a new value.
   - Play the new note or controller value on your MIDI controller keyboard, then press Return (Mac) or Enter (Windows) on the alphanumeric keyboard to confirm.

3. Do one of the following:
   - To enter the new event value and move to another field or event, use the Arrow keys.
   - To enter the new value and remain in Edit Entry mode, press Enter on the numeric keypad.
   - To enter the new value and exit Edit Entry mode, press Return (Mac) or Enter (Windows) on the alphanumeric keyboard.
   - To exit Edit Entry mode without entering the new value, press Escape on the alphanumeric keyboard.

Selecting Events in the MIDI Event List

**To select a range of events in the MIDI Event List, do one of the following:**

- Click the event at the beginning of the selection and drag to the ending event.
- Shift-click the event at the beginning of the selection, then Shift-click the ending event.
To select noncontiguous events in the MIDI Event List:
- Command-click (Mac) or Control-click (Windows) each event.

To deselect an event in the MIDI Event List:
- Command-click (Mac) or Control-click (Windows) the selected event.

*Notes selected in the MIDI Event List can be modified by any of the commands in the Event Operations window (see Chapter 46, “Event Operations”).*

Deleting Events in the MIDI Event List

To delete an event in the MIDI Event List:
- Option-click (Mac) or Alt-click (Windows) the event you want to delete.

To delete a selection of events in the MIDI Event List:

1. Select the events you want to delete by either dragging in the Start column, or by Shift-clicking each event.
2. To view only the events you want to delete, use the View Filter (see “View Filter for MIDI Event List” on page 828). Events not displayed cannot be deleted.
3. Do one of the following:
   - Choose Edit > Clear to delete all selected events.
   - Press Delete (Mac) or Backspace (Windows) on the alphanumeric keyboard.

Copying and Pasting Events in the MIDI Event List

To copy and paste events in the MIDI Event List:
1. Select the events you want to copy in the MIDI Event List.

2. Choose Edit > Copy.
3. Do one of the following:
   - To paste the material at an existing event’s location, click the event in the MIDI Event List.
   - To paste the material at any location, choose Go To from the Options menu in the MIDI Event List, enter the location where you want to paste, and click OK.
4. Choose Edit > Paste. The events from the Clipboard are pasted, replacing any existing events already there.

*To paste events without overwriting other events, use the Merge Paste Special command.*
MIDI Event List Options

The MIDI Event List menu provides the following options:

**Show Sub Counter** Displays event times in the Sub Time Scale.

**Go To** Opens the Go To dialog, where you can specify a location, based on any of the supported Time Scales, to which the Edit insertion point is moved.

**Scroll To Edit Selection** Scrolls the MIDI Event List to the Edit start point or Edit insertion point.

**Page Scroll During Playback** Scrolls the MIDI Event List during playback.

**Show Note Length** Displays note lengths, instead of note end times, in the Length/Info column of the MIDI Event List.

**Show Note End Time** Displays note end times, instead of note lengths, in the Length/Info column of the MIDI Event List.

**Insert** Provides a submenu of options that let you insert any type of MIDI event.

**Insert At Edit Location** Defaults the location for inserted events defaults to the Edit start point or Edit insertion point.

**Insert At Playback Location** Lets you insert events in the MIDI Event List in real time while listening to the session playback.

**Insert At Playback Location With Grid** Snaps the location for events inserted in real time to the grid.

**View Filter** Opens the View Filter dialog, where you can specify which events are displayed in the MIDI Event List (see “View Filter for MIDI Event List” on page 828).

**Keep Window On Top** Keeps the MIDI Event List window in the foreground even when clicking on and focusing another window (such as the Edit or Mix windows). Enable the Keep Window On Top option in the MIDI Event List menu to ensure that the window remains in the foreground when working with other windows. When this option is disabled, clicking on another window (such as the Edit or Mix windows) brings that window to the front and the MIDI Event List may be hidden or partially covered behind it.
Part VII: Arranging
Chapter 38: Time, Tempo, Meter, Key, and Chords

In Pro Tools, editing and arranging is typically done on tracks against a fixed Timeline.

Clips and events can be anchored to points in absolute time, or relative time, as measured on the session’s Timeline. The Timeline includes two different types of rulers for measuring time: Timebase rulers and Conductor rulers.

Pro Tools also provides a Markers ruler for Memory Location (see Chapter 39, “Memory Locations”).

The Timebase rulers can measure time in two different ways: sample-based time (absolute time) and tick-based time (relative time). For example, the Minutes:Seconds ruler measures absolute time and the Bars|Beats ruler measures relative time.

The relative time of the Bars|Beats ruler is determined in part by tempo and meter. Tempo, Meter, and Key Signature rulers reside in Conductor tracks. Tempo and meter events affect the timing of tick-based tracks, and also provide the tempo and meter map for the Bar:Beat grid and Click. You can edit tempo events in the Tempo ruler or Tempo Editor.

Key changes can affect MIDI notes when applying transposition. You can edit key and key changes in the Key Signature ruler.

Timebase Rulers and Conductor Rulers

Timebase Rulers

Any or all of the following Timebase rulers can be displayed at the top of the Edit window and in MIDI Editor windows:

Bars|Beats Displays the Time Scale in bars and beats. Use this Time Scale if you are working with musical material that must align with bars and beats. The Bars|Beats Time Scale is relative and is affected by the session’s tempo and meter map.
Minutes:Seconds Displays the Time Scale in minutes and seconds. As you zoom in farther with the Zoomer tool, the Time Scale begins to display tenths, hundredths, and thousandths of a second. The Minutes:Seconds Time Scale is absolute.

Timecode Displays the Time Scale in SMPTE frames. The Timecode Rate and Session Start time are set from the Session Setup window. The Timecode Time Scale is absolute, based on the frame rate.

Pro Tools supports the following frame rates:
- 23.976 FPS
- 24 FPS
- 25 FPS
- 29.97 FPS
- 29.97 FPS Drop
- 30 FPS
- 30 FPS Drop

Secondary Timecode Ruler A secondary timecode ruler, labeled Time Code 2, lets you reference video frame rates in the Timeline that are different from the session Timecode rate. However, you cannot Spot to the Timecode 2 ruler and it cannot be set as the Main Time Scale. The secondary timecode ruler can be set to show any Pro Tools supported frame rate.

The Timecode 2 ruler can also display the following additional frame rates:
- 50 FPS
- 59.94 FPS
- 59.94 FPS Drop
- 60 FPS
- 60 FPS Drop

Feet+Frames Displays the Time Scale in feet and frames for referencing audio-for-film projects. The Feet+Frames time display is based on the 35 millimeter film format. The Feet+Frames Time Scale is absolute, based on the frame rate.

Samples Displays the Time Scale in samples. This format is very useful for high-precision sample editing. The Samples Time Scale is absolute, based on the sample rate.

In addition to providing a timing reference for track material, the Timebase rulers are also used to define Edit selections for track material, and Timeline selections for record and play ranges.

With the Selector tool, drag in any Timebase ruler to select material across all tracks in the Edit window or MIDI Editor window. To include the Conductor tracks in the selection, press Option (Mac) or Alt (Windows) while dragging.

Conductor Rulers

Any or all of the following Conductor rulers can be displayed:
- Markers
- Tempo (and Tempo Editor)
- Meter
- Keys (and Key Signature Staff)
- Chords
The Meter and Tempo rulers indicate changes in meter and tempo within the Session. The Key Signature ruler indicates changes of key. The Chord Symbols ruler shows chord markers. The Markers ruler displays markers to important track locations.

Displaying Rulers

To display all rulers:
- Select View > Rulers > All.

To remove a ruler from the display, do one of the following:
- Option-click the ruler’s name (to the left of the ruler display).
- Choose View > Rulers, and deselect a ruler option.

To display only the Main Time Scale in the Timebase ruler:
- Select View > Rulers > None (“Main Time Scale” on page 839.)

To add a specific ruler to the display, such as the Markers ruler, for instance:
- Select View > Rulers > Marker.

To change the display order for the rulers:
- Drag a ruler’s name up or down to a new location.

To copy the range selection from a Conductor ruler to make an Edit selection in the top track in the Edit window (or in the Notes pane in MIDI Editor windows):
- Press Control+; (semicolon) (Mac) or Start+; (semicolon) (Windows).

Ruler View Selector

The Timebase and Conductor rulers can also be configured with the Ruler View selector.

Main Time Scale

While all Timebase rulers can be displayed simultaneously in the Edit and MIDI Editor windows, there is only one that represents the Main Time Scale. This ruler is also called the Main Timebase ruler.

The Main Time Scale determines the time format used for:
- The Main Counter in the Transport
- The Main Counter at the top of the Edit window or MIDI Editor window
- Start, End, and Length values
- Pre- and post-roll amounts
- Grid and Nudge values
The Main Time Scale can be set to the following formats:

- Bars|Beats
- Minutes:Seconds
- Timecode
- Feet+Frames
- Samples

**Setting the Main Time Scale**

**To set the Main Time Scale, do one of the following:**

- Click a Main Counter selector (located at the top of the Edit or Transport window (when it is set to display Counters) and select a Time Scale.
- If a Timebase ruler is displayed, click its name so it becomes highlighted.

**Navigating with the Main Counters**

The Main Counters (at the top of the Edit window and in the Transport window) provide a convenient way to navigate to a specific time location.

* The Main Counter indicator in the Transport window only displays when the Transport is set to display Counters.

**To navigate with a Main Counter:**

1. Click in a Main Counter.
2. Type in a location.
3. Press Enter (Windows or Mac) or Return (Mac) to automatically navigate to a new location.

**The Sub Counter**

Below each Main Counter is a Sub Counter that can be shown or hidden. The Sub Counter provides an additional timing reference.

**To show (or hide) the Sub Counter in the Edit window:**

- From the Main Counter selector, select (or deselect) the Show Sub Counter option.

**To show the Sub Counter in the Transport window:**

- From the Transport Window menu, ensure that the Counters and Expanded Transport options are enabled.

**To set the Time Scale for the Sub Counter:**

- Click the Sub Counter selector and select a Time Scale.
**Tick-Based Timing**

Pro Tools is a sample-based program with an internal MIDI resolution of 960,000 pulses per quarter note (ppq). However, when the Time Scale is set to Bars|Beats, the display resolution in Pro Tools is 960 ppq and the Timebase is tick-based.

> **In the Bars|Beats Time Scale, Pro Tools is tick-based (960 ticks to a quarter note). Some amount of sample-rounding may occur when placing events at certain locations (see “Sample Rounding and Edit Operations” on page 843).**

When working in Bars|Beats, you will often want to specify tick values for a number of operations, including:

- Placing and spotting clips
- Setting lengths for clips or MIDI notes
- Locating and setting play and record ranges (including pre- and post-roll)
- Specifying settings in the Quantize and Change Duration pages of the Event Operations window
- Setting the Grid and Nudge values

> **When the Main Time Scale is set to Bars|Beats, and you are using tempo changes, set the Linearity Display Mode to Linear Tick Display (see “Changing the Linearity Display Mode” on page 856). This will keep the Bars|Beats ruler fixed (at the selected zoom level) and sample-based rulers such as Minutes:Seconds will scale to fit any tempo changes while bar lengths remain constant.**

The following table lists the number of ticks for each of the main note sizes:

<table>
<thead>
<tr>
<th>Note Value</th>
<th>Normal</th>
<th>Dotted</th>
<th>Triplet</th>
</tr>
</thead>
<tbody>
<tr>
<td>1/2 note</td>
<td>1920</td>
<td>2880</td>
<td>1280</td>
</tr>
<tr>
<td>1/4 note</td>
<td>960</td>
<td>1440</td>
<td>640</td>
</tr>
<tr>
<td>1/8 note</td>
<td>480</td>
<td>720</td>
<td>320</td>
</tr>
<tr>
<td>1/16 note</td>
<td>240</td>
<td>360</td>
<td>160</td>
</tr>
<tr>
<td>1/32 note</td>
<td>120</td>
<td>180</td>
<td>80</td>
</tr>
<tr>
<td>1/64 note</td>
<td>60</td>
<td>90</td>
<td>40</td>
</tr>
</tbody>
</table>

**Tick- and Sample-Based Timebases**

Pro Tools lets you set any track timebase to either sample-based or tick-based.

Audio tracks in Pro Tools are sample-based by default. This means that audio clips and events are located at specific sample locations, and they do not move from that location if the tempo changes in the session—even though their bar and beat locations do change.

MIDI and Instrument tracks in Pro Tools are tick-based by default. This means that MIDI clips and events are located at a specific bar and beat locations, and they do not move from that location if the tempo changes in the session—even though its sample location does change.

**Sample-Based Audio and MIDI**

With a sample-based audio track, all audio clips in the track have an absolute location on the absolute Timeline (for example, on the Samples or Minutes:Seconds Timebase ruler). Audio stays fixed to the sample time, regardless of any tempo or meter changes occur in a session.
On sample-based MIDI and Instrument tracks, all MIDI events in the track have an absolute location on the absolute Timeline (for example, on the Sample or Minutes:Seconds Timebase ruler). MIDI events stay fixed to the sample time, regardless of where tempo or meter changes occur in a session.

**Tick-Based Audio and MIDI**

Tick-based audio is fixed to the relative time of the Bars|Beats Timebase ruler, and moves relative to the sample Timeline when tempo and meter changes occur. However, MIDI and Elastic Audio events, and tick-based audio clips (non–Elastic Audio) respond differently to tempo changes in respect to duration. MIDI note events and Elastic Audio clips change their duration when tempo is adjusted, while non–Elastic Audio audio clips do not. Tempo changes affect only the location of the beginning (or sync point) of each audio clip in a tick-based (non–Elastic Audio) audio track.

You can select whether a track is sample-based or tick-based when it is created, or change timebases later.

*To have all new tracks default to tick-based, enable the New Tracks Default to Tick Timebase option in the Editing Preferences.*

**Tick-Based Elastic Audio**

Tick-based Elastic Audio tracks automatically apply Real-Time (or Rendered) Elastic Audio processing (TCE) when changing tempo. For more information, see “Tempo Changes and Tick-Based Elastic Audio Tracks” on page 848.

**Switching Timebases**

All Pro Tools tracks can be switched between being sample-based or tick-based.

Track height affects how various track controls appear in the Edit window. The Timebase selector, which is used for switching a track’s timebase, is only visible in Medium or larger track heights.

**To switch the timebase of a track, do one of the following:**

- If the track’s height is set to Medium or larger, click the Timebase selector for the track and select the timebase. The Timebase selector icon changes to reflect your choice.

![Timebase selector (samples)](image)

- If the track’s height is set to Small (or smaller), click the Track Height selector and select the timebase from the Track Timebase submenu.

![Timebase selector (ticks)](image)

![Track Height pop-up menu](image)
Alternate Playlist Timebases

When you change a track’s timebase, you can choose to apply the timebase change to that track only, or to the active Playlist and all alternate playlists for that track.

To configure a timebase change to affect timebases of all playlists in a track:

- Click the Timebase selector (or Track Height Selector) and enable the Selection Changes Alternate Playlists option.

Groups

When you change the timebase for an audio track that is part of an active Edit group, all the tracks in the group will change to the same timebase.

Audio Clip Location

In tick-based audio tracks, the location of an audio clip is determined by the clip’s start point, unless the clip contains a sync point.

If the clip contains a sync point, the sync point determines where the audio clip is fixed to the grid.

Marker Location

When creating markers and Selection Memory Locations, you can specify whether they have an Absolute (sample-based) or Bar|Beat (tick-based) reference. For more information, see “Bar|Beat and Absolute Reference” on page 884.

Sample Rounding and Edit Operations

When audio material in Pro Tools is sample-based, some amount of sample-rounding may occur with some edits when the Main Time Scale is set to Bars|Beats. This is most evident when you need audio clips to fall cleanly on the beat (as when looping) and notice that the material is sometimes a tick or two off. With a few simple precautions, this can be avoided.

To ensure that selections are precisely aligned to the grid for looping, copying, duplicating, or repeating, consider the following:

- If you use the Selector tool, enable Grid mode and select the appropriate grid value (such as sixteenth notes).
- For the greatest accuracy, type the selection Start and End points in the Event Edit area.
- Do not select the material with any of the Grabber tools (or by double-clicking with the Selector tool).

Song Start Marker

The Song Start Marker defines the initial tempo for Bar|Beat-based material. New sessions open with a default tempo of 120 BPM.

When a new session is created, the Song Start Marker has no associated meter event. A meter event is added automatically at the Song Start if you add another meter event anywhere else on the Meter ruler.

The position of the Song Start Marker can also be changed in the Time Operations window, see “Move Song Start” on page 872.
To move the Song Start Marker by dragging:
- In the Tempo ruler with any Edit tool, drag the Song Start Marker left or right.

Dragging the Song Start Marker

If the Edit mode is set to Grid, the Song Start Marker moves in increments of the current Grid value.

To move the Song Start Marker only, without moving any tick-based data, press Control+Shift (Mac) or Start+Shift (Windows) while dragging. When dragging the Song Start Marker only, dragging is constrained to whole bar increments only.

To edit the initial tempo in the Song Start Marker:
1. In the Tempo ruler, double-click the Song Start Marker.
2. In the Change Tempo dialog, enter a new BPM value.
3. Click OK.

**Tempo**

The Tempo ruler lets you edit Tempo events one at a time or according to tempo curves. You can edit tempo visually in the Tempo Editor, or make precise changes in tempo using the Tempo Operations window.

To display the Tempo ruler:
- Select View > Rulers > Tempo.

To set the default session tempo, see “Setting the Session Meter and Tempo” on page 498.

You can use Beat Detective to generate Bar|Beat markers (tempo map). For more information, see “Generating Bar|Beat Markers with Beat Detective” on page 730.

When working with tempo changes and tick-based material, set the Linearity Display Mode to Linear Tick Display.

**Tempo Events**

Tempo events can be assigned to the Song Start Marker to replace the default tempo (of 120 BPM), and they can be inserted anywhere else within the session to change tempo.

In Manual Tempo mode, the Tempo ruler is ignored and the session plays at the tempo defined in the Transport window, See “Using Manual Tempo Mode” on page 500.

**Current Tempo**

As tempo events are encountered during playback, the session’s current tempo is displayed in the Transport window.
Inserting Tempo Events

To insert a tempo event:

1. Click in the Tempo ruler where you want to insert the tempo event.

2. Click the Add Tempo Change button at the left of the Tempo ruler.

3. In the Tempo Change window, enter the Location and BPM value for the tempo change.

4. To place the inserted tempo event cleanly on the first beat of the nearest measure, select the Snap To Bar option.

5. To base the BPM value on something other than the default quarter note, select a different note value.

6. Click OK. The new tempo event is inserted and appears in the Tempo ruler.

Inserted tempo event

Moving and Editing Tempo Events

Existing tempo events can be moved, edited, deleted, copied, and pasted.

To move a tempo event by dragging:

- In the Tempo ruler, drag the triangle for the tempo event left or right.

Dragging a tempo event

If the Edit mode is set to Grid, the dragged event snaps to the current Grid value.

To edit a tempo event:

1. In the Tempo ruler, double-click the tempo event.

2. In the Tempo Change window, enter a new Location or BPM value for the tempo event.

3. Click OK.
To delete a tempo event:

- Option-click (Mac) or Alt-click (Windows) the tempo event (the cursor changes to a Grabber with a “–”).

To copy and paste several tempo events:

1. With the Selector tool, drag in the Tempo ruler to select the range of bars that includes the tempo events.
2. Choose Edit > Copy.
3. Click in the Tempo ruler at the point where you want to paste the tempo events.
4. Choose Edit > Paste. The contents of the Clipboard are pasted from the insertion point, replacing any existing tempo events.

To extend an Edit selection in a track to the Tempo ruler:

1. With the Selector or Grabber tool, make a Timeline selection.

To select all tempo events:

- Double-click with the Selector tool in the Tempo ruler.

To clear a range of selected tempo events:

1. If you want to constrain the selection to the current Grid value, set the Edit mode to Grid.
2. Drag with the Selector tool in the Tempo ruler to select the tempo events you want to remove.
3. Choose Edit > Clear to delete the selected tempo events.

Tap Tempo

You can manually set the tempo for a Pro Tools session by tapping on your computer keyboard. You can also use a connected MIDI keyboard to tap tempo.

To set the Manual Tempo by tapping on a computer keyboard:

1. To view the MIDI controls in the Transport window, select View > Transport > MIDI Controls.
2. In the Transport window, click the Tempo Ruler Enable (Conductor) button so it becomes un-highlighted. Pro Tools switches to Manual Tempo mode. In this mode, any tempo events in the Tempo ruler are ignored.

3. Click in the Tempo field so it becomes highlighted and tap the “T” key on your computer keyboard repeatedly at the new tempo.

You can apply the new tempo to the entire session by changing the default tempo of the Song Start Marker. See “Song Start Marker” on page 843.
To set the Manual Tempo by tapping on an external MIDI keyboard:

1 To view the MIDI controls in the Transport window, select View > Transport > MIDI Controls.

2 Choose Setup > Preferences and click the MIDI tab.

3 Ensure that Use MIDI to Tap Tempo is selected.

4 In the Transport window, click the Tempo Ruler Enable (Conductor) button so it becomes un-highlighted. Pro Tools switches to Manual Tempo mode. In this mode, any tempo events in the Tempo ruler are ignored.

5 Click in the Tempo field so it becomes highlighted and tap in the tempo by playing a note repeatedly at the new tempo on your MIDI keyboard controller.

To compute the new tempo, Pro Tools averages the last eight (or fewer) taps to determine the correct tempo. The computed BPM value appears in the Transport Tempo field.

**Tempo and Automation Drift**

*(With Sample-Based Clips on Tick-Based Tracks Only)*

When a track is sample-based, the track’s automation playlist is unaffected by changes in tempo. This means that automation is always aligned with any sample-based audio on the track with sample accuracy.

When a track is tick-based, the automation breakpoints change to match the changes in tempo.

Generally, when applying tempo changes with tick-based MIDI and Elastic Audio, this is desirable. In fact, you will probably want to set all of the tracks in your session that contain automation to tick-based. This way any tempo changes affect all tick-based track automation and track material equally. However, when working with sample-based (non-Elastic) audio on tick-based tracks, tempo changes affect the start location of audio clips, but not their duration.

Since the length of each sample-based audio clip in a track is unaffected by changes in tempo, existing automation data is not aligned with the audio after a tempo change is made to a tick-based audio track.
Minimizing Automation Drift

In general, automation drift is more pronounced with larger sample-based audio clips. By creating many small clips, the effects of automation drift can be minimized, because the start points of each subsequent clip changes as the tempo changes. When tempo is decreased, automation expands. When tempo is increased, automation contracts.

Tempo Changes and Tick-Based Elastic Audio Tracks

Clips on tick-based, Elastic Audio-enabled tracks apply Time Compression and Expansion (TCE) based on tempo changes. For simple tempo changes, clips on tick-based Elastic Audio-enabled tracks automatically conform to match the new tempo. Tempo changes do not affect sample-based, Elastic Audio-enabled tracks.

In the following figure, the first two-bar clip is at its native tempo of 120 bpm. The second two-bar clip has been conformed to the tempo change of 100 bpm. Since the second clip has been warped to remain two bars long at the slower tempo, it displays the Clip Warp indicator in the upper right-hand corner of the clip.

To break an audio clip into smaller clips, use Beat Detective. For more information, see Chapter 33, “Beat Detective.”

You can also separate clips at transients or based on the current grid resolution. For more information, see “Separate Commands” on page 654
Tempo Event-generated Warp markers cannot be edited. They only show where the audio has been warped in order to conform to tempo changes.

If you change the track timebase from ticks to samples, any Tempo Event–generated Warp markers convert to regular, editable Warp markers.

**Tempo Changes and Tick-Based Audio Tracks**

When a tick-based audio track has multiple clips, and Elastic Audio is not enabled, an increase in tempo can cause neighboring clips to overlap. Audio clips can be set to display a “shadow” to indicate overlapping clip boundaries.

To toggle the display of Overlap Shadows:
- Choose View > Clip > Overlap Shadows.

**To change the clip overlap or underlap:**
1. In the Edit window, choose the clip or clips you want to re-order.
2. Do one of the following:
   - Choose Clip > Bring to Front to make the clip overlap the neighboring clips.
   - Choose Clip > Send to Back to make the clip underlap the neighboring clips.

If multiple overlapping clips are selected, Pro Tools will apply the command to each clip as that clip relates to the neighboring clip on the right.

**Conform to Tempo**

Pro Tools lets you conform clips on Elastic Audio-enabled tracks (both sample- and tick-based) to the session tempo. If necessary, the Conform to Tempo command analyzes the selected clips to determine its tempo and duration (in bars and beats), and then applies Elastic Audio processing to conform the clip to match the session tempo.

**To conform a clip to the session tempo:**
1. Select the clip you want to conform to the session tempo.
2. Do one of the following:
   - Choose Clip > Conform to Tempo.
   - Right-click the clip you want to conform to tempo and select Conform to Tempo.

Pro Tools analyzes the clip’s entire file for Elastic Audio events and tempo. If a tempo is detected, and a duration in bars and beats is determined, the clip conforms automatically to the session tempo. If a tempo and duration is not detected (such as with a clip that is a single drum hit or with a long clip with no clear tempo), the clip is not conformed to the session tempo.

You can also use telescoping warp in Warp view to manually conform a long clip to the session tempo. See “Telescoping Warp” on page 981.
Alternate Playlists and Tempo

Alternate playlists on Elastic Audio-enabled, tick-based tracks are only affected by tempo changes. Otherwise, alternate playlists are not affected by editing Warp or Event markers in the main playlist.

Graphic Tempo Editor

The Tempo Editor, a resizeable window beneath the Tempo ruler in the Edit Window, lets you view and edit tempo information graphically.

Displaying the Tempo Editor

The Tempo Editor is an expansion of the Tempo ruler, opening in the rulers section of the Edit Window.

To display the Tempo Editor, do one of the following:

- Select View > Rulers > Tempo, then select View > Rulers > Tempo > Tempo Editor.
- Click the Tempo Editor expand/collapse triangle.

Zooming and Scrolling in the Tempo Editor

To zoom in vertically in the Tempo Editor:

- Click the Tempo Editor Zoom In button (“+”).

To zoom out vertically in the Tempo Editor:

- Click the Tempo Editor Zoom Out button (“−”).

To scroll vertically in the Tempo Editor, do any of the following:

- Click the Scroll Up Arrow to scroll up.
- Click the Scroll Down Arrow to scroll down.
- Drag the Scroll bar up or down.
Editing Tempo Events in the Tempo Editor

Tempo events in the Tempo Editor can be edited with any of the following methods:

- Individual tempo events can be dragged with any of the Grabber tools to adjust their location or value.
- A group of selected tempos can be scaled up or down with the Trim tool.
- New tempo events can be drawn in with the Pencil tool to replace existing ones.
- Tempo events can be copied and pasted, nudged, and shifted.

Drawing Tempo Events

Tempo events can be drawn in the Tempo Editor using the following Pencil tool shapes.

**Free Hand** The Free Hand shape draws freely according to the movement of the mouse. The shape is reproduced as a series of steps according to the Tempo Edit Density setting. (For more information, see “Selecting Tempo Edit Density” on page 852.)

**Line** The Line shape draws in a straight line from click to release. Tempo values change in steps according to the Tempo Edit Density and Resolution.

**Parabolic** The Parabolic shape draws the best possible curve to fit your freehand drawing. The shape is reproduced as a series of steps according to the Tempo Edit Density setting.

**S-Curve** The S-Curve shape draws a best possible fit of an S-Curve to your freehand drawing. The shape is reproduced as a series of steps according to the Tempo Edit Density setting.

⚠️ The Triangle, Square, and Random Pencil tool shapes do not apply to tempo events.

Selecting Tempo Resolution (BPM Rate)

The Tempo Editor lets you specify the beat note value for tempo events by changing the Tempo Resolution. The beat note value selected for the Tempo Resolution is usually based on the meter. For example, in 4/4 the beat is a quarter note and in 6/8 the beat is (usually) a dotted-quarter note.

To select the Tempo Resolution (BPM rate) for Pencil tool edits, do one of the following:

- Click the Tempo Resolution selector and select the appropriate note value from the pop-up menu. The Tempo Resolution for tempo events created by drawing with the Pencil tool are set to the specified note value for the BPM rate.
- Click the Tempo Resolution selector and select Follow Metronome Click. The Tempo Resolution for tempo events created by drawing with the Pencil tool automatically mirror the click values set by meter events in the Meter ruler.

A tempo curve can have different BPM values if there are meter click changes within the selected range.

⚠️ Because it can be unnecessarily complicated to set meter events separately for each Tempo event, selecting Follow Metronome Click is recommended in most cases.
Selecting Tempo Edit Density

The Tempo Editor lets you specify the density of tempo events created in the Tempo ruler when you draw a tempo curve with the Pencil tool.

To select the Tempo Edit Density for Pencil tool edits:
- Click the Tempo Edit Density selector and select a time value from the pop-up menu. Tempo events created by drawing with the Pencil tool are placed in the Tempo ruler at the specified density.

Pressing Control (Mac) or Start (Windows) before drawing a pencil line conforms already created tempo events to the drawn line rather than creating new tempo events.

Curve Adjustment Mode

Immediately after you draw new tempos using the Pencil tool, a tempo curve appears in blue, outlining the newly created tempo graph. Blue adjustment handles on the curve let you adjust the shape and size of the new tempo graph.

All the new tempo events under the curve will change as you move the Tempo Curve Adjustment Handles. To adjust the curve shape without the track data adjusting immediately, press Control (Mac) or Start (Windows) while adjusting the curve. Tempo events will change to fit the new curve when you release the mouse button.

The blue adjustment handles are only active until a new tool is selected or a new command is executed.
Creating New Tempo Settings with Grabber Tools

The Grabber tools let you create new tempo settings by dragging tempo events in the Tempo Editor.

To change the tempo of a tempo event:
- With the Grabber tool, drag a tempo event up or down.

To adjust the location of the tempo change:
- With the Grabber tool, drag a tempo event to the left or right.

To remove a tempo event:
- With the Grabber tool, Option-click (Mac) or Alt-click (Windows) the tempo event.

Selecting Tempo Events

You can easily select a single tempo event, or an entire tempo curve within the Tempo Editor.

To Select a tempo event in the Tempo Editor:
- Using the Selector tool or any Grabber tool, double-click between two tempo events. The first event is selected.

To Select a tempo curve in the Tempo Editor:
- Using the Selector tool or any Grabber tool, triple-click on a horizontal tempo line in the curve that you want to select.
Extending Tempo Selections

You can extend Tempo selections to the next or the previous tempo event.

To extend a tempo selection:

1. With the Selector tool, select a range of tempo events.
2. Do one of the following:
   - Press Shift+Tab to extend the selection to the next tempo event.
   - Press Shift+Option+Tab (Mac) or Shift+Control+Tab (Windows) to extend the selection to the previous tempo event.

Scaling and Stretching Tempo Events with the Trim Tool

The Trim tool lets you scale all the tempo events of the session, or within a Timeline selection. The Trim tool also lets you stretch a clip of tempo events to cover a longer or shorter area in the Timeline.

To scale all the session’s tempo events with the Trim tool:

1. Open the Tempo Editor.
2. With the Trim tool, click above any tempo event and drag up or down. Dragging up increases the tempo values for all tempo event in BPM; dragging down decreases them.

To scale selected tempo events with the Trim tool:

1. Open the Tempo Editor.
2. With the Selector tool, select the area you want to edit.
3. With the Trim tool, click within the selected area, and drag up or down. Dragging up increases the tempo values of the selection in BPM; dragging down decreases them.

To adjust the rate of tempo change over absolute time with the Trim tool:

1. Open the Tempo Editor.
2. With the Selector tool, select the area you want to edit.
3. With the Trim tool, click either the start or end handle for the selected range, and drag up or down. The BPM values for tempo events scale accordingly and tempo events scale over a longer or shorter amount of absolute time.
To scale the duration of tempo changes with the Trim tool:

1. Open the Tempo Editor.
2. With the Selector tool, select the area you want to edit.
3. With the Trim tool, click at the start or end of the selection, and drag horizontally. Tempo events do not change in terms of actual BPM values, but they are scaled over a longer or shorter amount of absolute time.

![Scaling the duration of selected tempo events with the Trim tool](image)

Moving, Cutting, Pasting and Nudging in the Tempo Editor

To move a selected group of tempo events in the Tempo Editor:

1. Open the Tempo Editor.
2. With the Selector tool, select the area you want to move.
3. With any Grabber tool, click on any selected tempo event and drag horizontally to move the tempo events to a new location.

💡 Press Option (Mac) or Alt (Windows) while dragging to move a copy of the tempo events.

To copy and Paste tempo events in the Tempo Editor:

1. Open the Tempo Editor.
2. With the Selector tool, select the area you want to copy.
3. Choose Edit > Copy.
4. Click in the Tempo Editor at the point where you want to paste the tempo events.
5. Choose Edit > Paste. Your copied selection is pasted from the insertion point, replacing any existing tempo events.

To nudge a selection in the Tempo Editor:

1. Open the Tempo Editor.
2. With the Selector tool, select the area you want to nudge.
3. Do one of the following:
   - On the numeric keypad, press Plus (+) to move the selected tempo events forward by the Nudge value.
   - Press Minus (–) to move the selection back by the Nudge value.
Changing the Linearity Display Mode

The Timeline can be viewed in either a Linear Tick (relative) scale or a Linear Sample (absolute) Time Scale. MIDI and Instrument tracks, audio tracks, and Tempo curves can appear and function very differently depending on the timebase display settings.

The Linearity Display Mode pop-up menu determines whether the Tempo Editor displays tempo events in an absolute (samples) timebase or a relative (ticks) timebase.

**Linear Sample Display** The display of the Timeline is sample-based and the location of tick-based events (like Bars and Beats) shift after a tempo curve is drawn. That is, as you change tempo, the location of bars and beats move against the fixed sample-based Timeline (such as Minutes:Seconds). When working with sample-based material, such as when you are tracking or mixing, make sure that Linear Sample Display is selected. This is especially true if you intend to align the tempo and meter map to sample-based events.

**Linear Tick Display** The display of tempo events is tick-based and tempo event Bar|Beat locations remain constant after the tempo curve is drawn and all sample-based events move against bar beat locations in the Timeline. When working on any tick-based material, such as MIDI notes or Elastic Audio events, make sure that Linear Tick Display is selected. This is especially true if you will be making tempo changes, but want the bars and beats to remain fixed in the Timeline.

⚠️ Drawing tempo events using the Linear Tick Display causes Bar|Beat based material to move. This can make it difficult to work on tick-based material. In most cases, you will want to use Linear Sample Display when drawing tempo changes.

To change the timebase display:
- Click the Linearity Display Mode selector and select a timebase from the pop-up menu.

**Tempo Edit Density and Linearity Display Mode**

When the Tempo Edit Density setting (in the Tempo Editor) and the Linearity Display Mode setting are both set to either a Bars|Beats Time Scale or to an absolute Time Scale, Tempo edits appear evenly spaced. When the Tempo Edit Density setting and the Linearity Display Mode setting are set so that one is set to an absolute Time Scale and the other is set to a Bars|Beats Time Scale, the number of Tempo edits appear to increase or decrease over time (against absolute time).
The Tempo Operations window lets you define tempo events over a range of time (or measures). The time range is specified in the time format chosen for your Main Time Scale. In addition, the Tempo Operations window lets you:

- Fit a specific number of Bars|Beats into a precise time range.
- Create tempos that speed up or slow down, both linearly and over various curves.
- Scale and stretch existing tempos.

The Tempo Operations window has six pages, one for each type of tempo operation.

**Constant** Lets you create a constant tempo over a selected range of time.

**Linear** Lets you create tempos that change evenly over a selected range of time.

**Parabolic** Lets you create tempos that accelerate or decelerate following a tempo curve that changes the tempo more rapidly or less rapidly over the selection time.

**S-Curve** Lets you create tempos that accelerate or decelerate following a tempo curve with a definable breakpoint that determines mid-curve times and tempo values.

**Scale** Lets you scale tempos within the selection by a percentage amount.

**Stretch** Lets you select a clip of tempo events and apply them to a larger or smaller selection area.

---

**To open a specific Tempo Operations window page:**

- Choose Event > Tempo Operations, followed by one of the Tempo Operations page commands (such as Constant).

**If the Tempo Operations window is already open, you can select any of the pages from the pop-up menu at the top of the window.**

**To open the last active Tempo Operations window page:**

- Choose Event > Tempo Operations > Tempo Operations Window.

**Press Option+2 (Mac) or Alt+2 (Windows) on the number keypad to open the Tempo Operations window and display the last active Tempo Operations page.**

---

**To define tempo events over a range of time:**

1. Make a selection in the Timebase or in a track.
3. Select a Tempo Operation page from the pop-up menu at the top of the Tempo Operation window.
4. Change the settings for the page you have chosen, as necessary.
5. Do one of the following:
   - Click Apply.
   - Press Return (Mac) or Enter (Windows) to automatically apply the values and close the window.
**Constant**

The Constant page in the Tempo Operations window lets you create a constant tempo over a selected range of time.

**Advanced**

When this option is selected, the selection range changes to the Main Time Scale format, and additional and modified options become available.

**Calculate (Advanced Option)** Calculates either the tempo, or the selection end time.

**Selection Start and End** Specifies the start and end point for the tempo change in Bars|Beats. When an Edit selection is made, the Start and End fields will display the selection boundaries.

**End Time (Advanced Option)** Displays the selection end time. When the Main Time Scale is set to Bars|Beats, the end time is displayed in the Sub Time Scale. When the Main Time Scale is set to any absolute timebase, the end time is calculated and displayed in Bars|Beats. Changing the end time value causes the tempo to change.

**Tempo** Specifies the tempo, in beats per minute (BPM), to apply to the selected range.

**Resolution (Advanced Option)** Lets you select the BPM note value for your tempo setting.

**Density (Advanced Option)** Lets you specify the density of the tempo change events written to the Tempo ruler.

**Preserve Tempo after Selection** If selected, the previous tempo setting that was in effect at the selection end point is preserved after the selection. If unselected, the last tempo event created by the tempo operation continues to the end of the session, or until the next tempo event beyond the selected range.

**Linear**

The Linear page in the Tempo Operations window lets you create tempos that change evenly over a selected range of time.

**Advanced**

When this option is selected, the selection range changes to the Main Time Scale format, and additional and modified options become available.
**Calculate (Advanced Option)** Calculates either the selection end time, the start tempo, or the end tempo.

**Selection Start and End** Displays the start and end points for the tempo change in the currently selected Main timebase. When an Edit selection is made, the Start and End fields will display the selection boundaries. Changing start or end values changes the selection range.

**End Time (Advanced Option)** Displays the absolute time for the selection end. When the Main Time Scale is set to Bars|Beats, the end time is displayed in the Sub Time Scale. When the Main Time Scale is set to any absolute timebase, the end time is calculated and displayed in Bars|Beats. Changing the end time value causes the tempo to change.

**Tempo Start and End** Displays the tempo, in beats per minute (BPM), for the start and end points of the selected range. Changing the tempo causes the end time value to change.

**Resolution (Advanced Option)** Lets you select the BPM note value for your tempo setting.

💡 *Selecting “Follow Metronome Click” will set the tempo BPM note value to mirror the click value set in the meter markers.*

**Density (Advanced Option)** Lets you specify the density of the tempo change events written to the Tempo ruler.

**Preserve Tempo after Selection** If selected, the previous tempo setting that was in effect at the selection end point is preserved after the selection. If unselected, the last tempo event created by the tempo operation continues to the end of the session, or until the next tempo event beyond the selected range.

**Parabolic**

The Parabolic page in the Tempo Operations window lets you create tempos that accelerate or decelerate by following a tempo curve, which changes the tempo more rapidly or less rapidly over the selection time.

![Parabolic page (Advanced Option)](image)

**Advanced** When this option is selected, the selection range changes to the Main Time Scale format, and additional and modified options become available.

**Calculate (Advanced Option)** Calculates the selection end time, the start tempo, the end tempo, or the curvature of the tempo change.

**Selection Start and End** Displays the start and end points for the tempo change in the currently selected Main timebase. When an Edit selection is made, the Start and End fields will display the selection boundaries. Changing start or end values changes the selection range.
End Time (Advanced Option) Displays the absolute time for the selection end. When the Main Time Scale is set to Bars|Beats, the end time is displayed in the Sub Time Scale. When the Main Time Scale is set to any absolute timebase, the end time is calculated and displayed in Bars|Beats. Changing the end time value causes the tempo to change.

Tempo Start and End Displays the tempo, in beats per minute (BPM), for the start and end points of the selected range. Changing the tempo causes the end time value to change.

Curvature Specifies and displays a numerical and graphic representation of the tempo curve. Negative numbers indicate a more rapid tempo change at the beginning of the time range, and positive numbers indicate a more rapid tempo change at the end of the time range. This value can be set with the Curvature slider.

Resolution (Advanced Option) Lets you select the BPM note value for your tempo setting.

Density (Advanced Option) Lets you specify the density of the tempo change events written to the Tempo ruler.

Preserve Tempo after Selection If selected, the previous tempo setting that was in effect at the selection end point is preserved after the selection. If unselected, the last tempo event created by the tempo operation continues to the end of the session, or until the next tempo event beyond the selected range.

S-Curve

The S-Curve page in the Tempo Operations window lets you create tempos that accelerate or decelerate by following a tempo curve with a definable breakpoint that determines mid-curve times and tempo values.

S-Curve page (Advanced Option)

Advanced When this option is selected, the selection range changes to the Main Time Scale format, and additional and modified options become available.

Calculate (Advanced Option) Calculates either the selection end time, the start tempo, the end tempo or the curvature of the tempo change.

Selection Start and End Displays the start and end points for the tempo change in the currently selected Main timebase. When an Edit selection is made, the Start and End fields will display the selection boundaries. Changing start or end values changes the selection range.
**Start and End Time (Advanced Option)** Displays the absolute time for the selection end. When the Main Time Scale is set to Bars|Beats, the end time is displayed in the Sub Time Scale. When the Main Time Scale is set to any absolute timebase, the end time is calculated and displayed in Bars|Beats.

**Tempo Start and End** Displays the tempo, in beats per minute (BPM), for the start and end points of the selected range. Changing the tempo causes the end time value to change.

**Curvature** Specifies and displays a numerical and graphic representation of the tempo curve. Negative numbers indicate a more rapid tempo change at the start and end of the selected range, with a low rate of change around the midpoint. Positive numbers indicate a low rate of change near the start and end of the selected range, with rapid tempo change around the midpoint. This value can be set with the Curvature slider.

**Mid Point** Specifies the Main Time Scale location for the curve mid point. This value can be set with the Mid Point slider.

**Mid Tempo** Specifies the tempo at the mid point. This value can be set with the Mid Tempo slider.

**Resolution (Advanced Option)** Lets you select the BPM note value for your tempo setting.

💡 *Select “Follow Metronome Click” will set the tempo BPM note value to mirror the click value set in the meter markers.*

**Density (Advanced Option)** Lets you specify the density of the tempo change events written to the Tempo ruler.

**Preserve Tempo after Selection** If selected, the previous tempo setting that was in effect at the selection end point is preserved after the selection. If unselected, the last tempo event created by the tempo operation continues to the end of the session, or until the next tempo event beyond the selected range.

**Scale**

The Scale page in the Tempo Operations window lets you scale tempos within the selection by a percentage amount.

**Scale page (Advanced Option)**

**Advanced** When this option is selected, the selection range changes to the Main Time Scale format, and additional and modified options become available.

**Calculate (Advanced Option)** In combination with settings chosen in the Scale pop-up menu, the Calculate pop-up menu lets you calculate the selection end time, the average tempo, the start tempo, or the end tempo.
Scale (Advanced Option) In combination with settings chosen in the Calculate pop-up menu, the Scale pop-up menu lets you scale all tempos, the start tempo, or the end tempo.

Scaling all tempos scales each tempo in the selected range equally. Scaling the start tempo scales the tempos unevenly, scaling the first tempo event the most, scaling each consecutive tempo event less until the end tempo which is not scaled. Scaling the end tempo scales the tempos unevenly, scaling the last tempo the most, scaling each previous tempo event less until the start tempo which is not scaled.

Selection Start and End Displays the start and end points for the tempo operation in the currently selected Main timebase. When an Edit selection is made, the Start and End fields will display the selection boundaries. Changing start or end values changes the selection range.

Start and End Time Displays the absolute time for the selection start and end points. When the Main Time Scale is set to Bars|Beats, times are displayed in the Sub Time Scale. When the Main Time Scale is set to any absolute timebase, times are calculated and displayed in Bars|Beats.

Average Tempo Displays the Average Tempo, in beats per minute (BPM), across the selected range. Changing the Average Tempo changes the Scale percentage.

Scale Displays the percentage by which the tempo is scaled, in beats per minute (BPM), across the selected range. Changing Scale changes Average Tempo.

Preserve Tempo after Selection If selected, the previous tempo setting that was in effect at the selection end point is preserved after the selection. If unselected, the last tempo event created by the tempo operation continues to the end of the session, or until the next tempo event beyond the selected range.

Stretch

The Stretch page in the Tempo Operations window lets you select a clip of tempo events and apply them to a larger or smaller selection area.

Advanced When this option is selected, the selection range changes to the Main Time Scale format, and additional and modified options become available.

Selection Start and End Specifies the range of tempo events that you want to modify. When an Edit selection is made, the Start and End fields will display the selection boundaries.

Stretch To End Specifies a new end point for the clip to which you want to apply the selected tempo events. Changing the end point causes the Stretch percentage to change.

Stretch To Start (Advanced Option) Specifies a new start point for the clip to which you want to apply the selected tempo events. Changing the end point causes the Stretch percentage to change.

Stretch Specifies the percentage of time for the selected tempo events to cover.
Preserve Tempo after Selection If selected, the previous tempo setting that was in effect at the selection end point is preserved after the selection. If unselected, the last tempo event created by the tempo operation continues to the end of the session, or until the next tempo event beyond the selected range.

Identify Beat Command

The Identify Beat command lets you establish a tempo/meter map for audio that was recorded without a click, or for imported audio with unknown tempos.

The Identify Beat command analyzes a selection range (usually with a distinct number of beats or measures) and calculates its tempo based on the specified meter. In doing this, Bar|Beat Markers for the calculated tempo are inserted and appear in the Tempo ruler at the beginning and end of the selection; in addition, meter events are inserted into the Meter ruler.

Choosing Bar|Beat Markers or Tempo Events

Because tempo events are tick-based, and Bar|Beat Markers are sample-based, they cannot be mixed. If a session contains tempo events and you attempt to insert Bar|Beat Markers, existing tempo events are converted to Bar|Beat Markers (and vice versa).

Tempo events can also be manually converted to Bar|Beat Markers and vice versa. When converting between Tempo events and Bar|Beat Markers, some amount of sample rounding may occur.

To use either tempo events or Bar|Beat Markers:

1. Press Command (Mac) or Control (Windows) and click the Add Tempo Change button.
2. Select either Tempo Events or Bar|Beat Markers from the pop-up menu.

Identifying Beats

Identifying the beat of a one-bar drum loop and creating Bar|Beat Markers for it:

1. Place a one-bar drum loop at the beginning of an audio track.
2. Select View > Rulers > Samples. This ensures that the selected audio material will be sample-accurate.
3. Select the audio clip with the Time Grabber tool and choose Event > Identify Beat.
4 In the Bar|Beat Markers dialog, specify the start and end locations for the inserted Bar|Beat Markers. Since this example deals with a one-bar loop, enter 1|1|000 and 2|1|000.

To accurately define tempos for a range of audio with the Identify Beat command, make certain that the initial selection represents an accurate length of bars and beats. You may want to first loop the selection on playback to see if it plays accurately (see “Loop Playback Mode” on page 485). To avoid drift, and remain sample-accurate, select the audio material with the Time Scale set to Samples rather than Bars|Beats.

*When identifying beats, select as large an area as possible. For example, if you have a four-bar-long audio file you want to identify, select the entire four bars instead of just one bar, in order to minimize rounding errors* (see “Sample Rounding and Edit Operations” on page 843).

**Dragging Bar|Beat Markers**

Bar|Beat Markers can be dragged to new locations so they can align with audio clips that have been moved, or so that they can align to a slightly different point within an audio clip. This results in neighboring MIDI data being adjusted to align with the new tempo map.

Because Bar|Beat Markers are sample-based and tempo events are tick-based, they behave differently when you drag them in the Tempo ruler.

*When dragging a Bar|Beat Marker:*

- Its BPM value is recalculated along with the Bar|Beat Marker to its immediate left. Bar|Beat Markers to the right of the dragged marker remain unchanged.
- Its bar and beat location is dragged with the Bar|Beat Marker. If the Bar|Beat Marker was originally placed at 3|1|000, it remains there (unless it is edited).
- Its sample and SMPTE locations change, as calculated for by the new tempo for the Bar|Beat Marker.

5 If necessary, specify a time signature for the start and end range.

6 Click **OK** to automatically calculate the new tempo and insert the necessary Bar|Beat Markers and meter events. Any existing tempo and meter events residing within the selection are deleted.

When working with a selection, the Identify Beat command only calculates a single tempo for the selected range. If the tempo varies from measure to measure, or beat to beat, you’ll need to use the Identify Beat command for each tempo variance (making sure to accurately define a precise selection range or beat location for the tempo change).
• Neighboring MIDI events, along with the Bars|Beats ruler, shrink or expand as necessary to adjust for the new tempo.

When dragging a tempo event:
• The tempo event is placed at a new bar and beat location. The sample and SMPTE locations for the event are updated as well.
• The BPM value for the dragged tempo event remains constant, as do any other tempo events in the session.
• Neighboring MIDI events and audio clips on tick-based tracks, along with the ruler, shrink or expand as necessary to adjust for the new tempo location.

Editing Bar|Beat Markers
A Bar|Beat Marker can be edited to redefine its bar and beat location, which also redefines the start or end point of the range being analyzed for tempo. This is different from dragging a Bar|Beat Marker.

To edit a Bar|Beat Marker:
1. In the Tempo ruler, double-click the Bar|Beat Marker.
2. In the Edit Bar|Beat dialog, enter a new Location for the Bar|Beat Marker.
3. Enter a new Time Signature.
4. Click OK.

To delete a Bar|Beat Marker:
• With the Grabber tool, Option-click (Mac) or Alt-click (Windows) the Bar|Beat Marker.

Inserting Bar|Beat Markers One at a Time
Sample-Based Material with Varying Tempos
You can insert Bar|Beat Markers one at a time by setting an Edit insertion point (instead of making a selection) before using the Identify Beat command. The ability to identify each beat, one at a time, is especially useful when working with sample-based material with varying tempos.

For instance, if you have a measure that accelerates slightly, you can insert a Bar|Beat Marker on each beat so the tempo is accurately reflected.

After the Bar|Beat Markers are inserted, further adjustments in the tempo map are possible by dragging each of the Markers, as necessary, to align with the associated beat within the audio.
**Meter Events**

You can change meter in the Meter ruler, or make precise meter changes in the Time Operations window.

Meter events can be inserted at the beginning of a session to replace the default meter (of 4/4), and they can be inserted anywhere within the session for additional meter changes.

**To display the Meter ruler:**
- Select **View > Rulers > Meter**.

**Current Meter**

As meter events are encountered during playback, the session’s current meter is displayed in the Transport window.

**Inserting Meter Events**

**To insert a meter event:**
1. Do one of the following:
   - Choose **Event > Time Operations > Change Meter**.
   - Click the Add Meter Change button at the right of the Meter ruler.
   - Double click the meter display in the Transport window.
2. In the Meter Change window, enter the Location and Meter for the meter change.
3. If you want the inserted meter event to fall cleanly on the first beat of the nearest measure, select the **Snap To Bar** option.

- With the Grabber, Control-click (Mac) or Start-click (Windows) at the location where you want to insert the event.
4 Select a note value for the number of clicks to sound in each measure. For a dotted-note click value, select the dot (.) option.

For some meters, it may be desirable to use a dotted value for the click. For instance, if using a meter of 6/8, a dotted quarter note click (yielding two clicks per measure) is generally more suitable than a straight eighth note click (six clicks per measure).

5 Click OK to insert the new meter event. The new meter event is inserted and appears in the Meter ruler.

Each meter event has a small yellow triangle next to it that indicates its location. These triangles can be selected for copying and pasting, and they can be double-clicked to edit the meter event.

# Editing Meter Events

Existing meter events can be edited, deleted, copied, and pasted.

**To edit a meter event:**

1 In the Meter ruler, double-click the meter event.
2 In the Meter Change dialog, enter a new Location or Meter for the event.
3 Click OK.

**To delete a meter event:**

- Option-click (Mac) or Alt-click (Windows) the meter event.

**To copy and paste several meter events:**

1 If you want to constrain the selection to the current Grid value, set the Edit mode to Grid.
2 Drag in the Meter ruler to select the range that includes the meter events.

If the beginning of the selection includes a meter event, press Command (Mac) or Control (Windows) so the Selector tool appears.

Press Option (Mac) or Alt (Windows) while dragging to select across all Conductor tracks.

3 Choose Edit > Copy.
4 Click in the Meter ruler at the point where you want to paste the meter events.
5 Choose Edit > Paste. The contents of the Clipboard are pasted from the insertion point, replacing any existing meter events.

**To extend an Edit selection in a track to the Meter ruler:**

1 Using the Selector tool or any Grabber tool, select a track range.
2 Shift-click in the Meter ruler.

Shift-click again in the Meter ruler to remove it from the selection.

**To select all meter events:**

- With the Selector tool, double-click in the Meter ruler.

**To clear a range of selected meter events:**

1 If you want to constrain the selection to the current Grid value, set the Edit mode to Grid.
2 Drag in the Meter ruler to select the meter events you want to remove.
3 Choose Edit > Clear to delete the selected meter events.
Partial Measures

As necessary, Pro Tools will create a partial measure to accommodate the inserted meter event. When a meter event is preceded by a partial measure, the meter event is displayed in italics in the Meter ruler.

Partial measure of 4/4

Partial measures can also occur when pasting meter events to locations other than the first beat of a measure.

💡 To insert meter events while avoiding partial bars, use the Change Meter command in the Time Operations window. See “Change Meter” on page 868.

Time Operations

The Time Operations window lets you:
- Change Meter
- Insert Time
- Cut Time
- Move Song Start

To open a specific Time Operations window:
- Choose Event > Time Operations, followed by one of the Time Operations commands (such as Change Meter).

💡 If the Time Operations window is already open, you can select any Time Operation from the pop-up menu at the top of the window.

To open the last active Time Operations window:
- Choose Event > Time Operations > Time Operations Window.

Press Option+1 (Mac) or Alt+1 (Windows) on the number keypad to open the Time Operations window and display the last active Time Operations window.

Change Meter

Change Meter in the Time Operation window lets you specify complex meter changes for Bar|Beat-based material. You can enter meter changes at a particular bar, make a meter change over a selected area of time, or add meter changes sequentially one bar at a time.
Change Meter Examples

To change the meter over a range of bars:
1. Do one of the following:
   - Drag with the Selector tool to select a range of bars to change.
   - To have the meter change apply until the next meter event, click where you want the meter change to begin with the Selector tool. The meter change will be made at the beginning of the nearest bar.
2. Choose Event > Time Operations > Change Meter.
3. Specify a new meter and click setting. Pro Tools will automatically set the selection options to fit the new meter to the selected range as closely as possible, adding or subtracting beats as necessary.
4. Select To Selected Range in the Apply Change pop-up menu.
5. Select which rulers and tracks you want to realign after meter changes have been made.
6. Click Apply.

To add a series of meter changes, one measure at a time:
1. Do one of the following:
   - With the Selector tool, click where you want the meter change to begin. The meter change will be made at the beginning the nearest bar.
   - Enter the first measure number in the Starting At Bar field.
2. Choose Event > Time Operations > Change Meter.
3. Specify a new meter and click setting.
4. Select Until the Next Bar from the Apply Change To pop-up menu.
5. Click Apply to enter the new meter and to move the insertion point to the end of the new measure.
6. Specify a new meter and click setting for the next measure.
7. Repeat steps 5–6 for every additional meter change you want to insert.

Change Meter Options

Options for the Change Meter command include:

**New Meter** Lets you specify a new time signature. The first field lets you enter the number of beats (up to 99) in a measure, and the second field lets you enter the note length that counts as one beat.

**Click** Lets you specify the note value that will trigger the metronome click. For example, if an eighth note is chosen, a click is played for every eighth note, regardless of tempo.

**Starting at Bar** Sets the bar where the meter change is added. Meter changes made in the Change Meter page can only be made at the beginning of a bar.

**Apply Change To** Lets you apply the meter change to the selected range, to the end of the session, or until the next bar.

**Change** The Change fields let you specify the number of bars of the new meter that you want to have replace the selected range.

Pro Tools automatically calculates the nearest whole bar number, or you can specify a number of bars to be affected. Time is inserted or deleted, in whole bar increments, at the end of the selection, as necessary on all affected tracks when you override the calculated range.
Realign

The Realign controls let you choose which items to realign after a meter change has been made. You can choose to realign meter events, or choose to realign meter and tempo events, tick-based markers and tracks, and also all or none of the sample-based markers and tracks.

**Meter Ruler Only** Applies the meter change and realigns only the Meter ruler. All other rulers and tracks are unaffected.

**Meter, Tempo, Key, and Chord Rulers, all Tick-Based Markers and Tracks, and Sample-Based Markers and Tracks** Applies the meter change and realigns the Meter, Tempo, Key, and Chord rulers, and all tick-based markers and tracks. Using the pop-up menu, you can also choose to realign All or No sample-based markers and tracks. Time is inserted or deleted as needed at the end of the selection to preserve the alignment of material following the selection.

Insert Time

Insert Time in the Time Operation window lets you insert an amount of blank time (silence) into Conductor rulers, MIDI tracks, and audio tracks.

**Insert Time Example**

To insert four empty measures of 4/4 time into a session:

1. Set the Main Time Scale to Bars|Beats.
3. Enter the measure where you want to insert the measures in the Start field.
4. Enter four measures in the Length field.
5. Select the Realign option for **Meter, Tempo, Key, and Chord Rulers, Tick-Based Markers and Tracks** and **All Sample-Based Markers and Tracks**.
6. Click Apply.

**Insert Time Options**

Options for the Insert Time command include:

**Start, End, and Length** Sets the start and end points for the selection, and the selection length.

**Set Meter** If your Main Time Scale is Bars|Beats, Set Meter lets you specify a new meter for the inserted time. The selection is quantized to the nearest bars, and the previous meter is inserted after the selection. If your Main Time Scale is sample-based, Set Meter is not available.
Realign

The Realign settings let you select which items shift (occur later) when time is inserted, as follows:

- If your Main Time Scale is set to Bars|Beats, you can choose to realign meter events only, or choose to realign a combination of Meter and Tempo rulers, all tick-based markers and tracks, and your choice of sample-based tracks.

- If your Main Time Scale is set to an absolute timebase (such as Min:Secs), you can choose to independently realign conductor events, tick-based markers and tracks, and your choice of sample-based tracks.

**Meter Ruler Only** If your Main Time Scale is Bars|Beats, you have the option to insert time into the Meter ruler only. Meter events after the start point of the selection are shifted past the end point by the length of time selection.

If your Main Time Scale is sample-based, Realign Meter Ruler Only is not available.

**Meter, Tempo, Key, and Chord Rulers, Tick-Based Markers and Tracks, and Sample-Based Markers and Tracks** Lets you insert time into the Meter, Tempo, Key, and Chord rulers, and all tick-based markers and tracks. Events after the start point of the selection are shifted past the end point by the length of time inserted.

If the Timeline selection includes any audio clips on tick-based tracks, the audio clips are separated at the Start point, and the new clip containing the previous selection is shifted to the end point.

Using the pop-up menu, you can also choose to insert time into All or No sample-based markers and tracks. If All is selected and the selection includes any audio clips on sample-based tracks, the selected portions of the audio clips are separated at the Start point, and the new clip containing the previous selection is shifted to the end point.

Cut Time

Cut Time in the Time Operation window lets you cut a specified amount of time (both Timebase and track data) from Conductor rulers, MIDI tracks, and audio tracks.

**Cut Time Example**

1. Set the Main Time Scale to Minutes:Seconds.
3. With the Selector tool, click at the beginning of the area that you want to cut.
4. Enter thirty seconds (0:30.000) in the Length field.
5. Select the Realign option for Meter, Tempo, Key, and Chord Rulers, all Tick-Based Markers and Tracks and All Sample-Based Markers and Tracks.
6. Click Apply.
Cut Time Options

Options for the Cut Time command include:

Start, End, and Length Sets the start and end points for the selection, and the selection length.

Realign

The Realign controls let you choose which items shift when time is cut, as follows:

• If your Main Time Scale is set to Bars|Beats, you can choose to realign meter events only, or choose to realign a combination of Meter and Tempo rulers together, all tick-based markers and tracks, and your choice of sample-based tracks.

• If your Main Time Scale is set to an absolute timebase (such as Min:Secs), you can choose to independently realign conductor events, tick-based markers and tracks, and your choice of sample-based tracks.

Meter Ruler Only

If your Main Time Scale is Bars|Beats, you have the option to remove time from the Meter ruler only. Meter events within the selection are removed, and meter events that occur after the end point of the selection are shifted to the selection start point.

If your Main Time Scale is sample-based, Realign Meter Ruler Only is not available.

Meter, Tempo, Key, and Chord Rulers, Tick-Based Markers and Tracks, and Sample-Based Markers and Tracks Cuts time and realigns the Meter, Tempo, Key, and Chord rulers, and all tick-based markers and tracks.

If the time selection includes any tick-based clips, the selected area of the clips is deleted, and clips following the selection are shifted forward.

Using the pop-up menu, you can also choose to cut time from All or No sample-based markers and tracks. If All is selected and the selection includes any audio clips on sample-based tracks, the selected area of the clips is deleted, and clips following the selection are shifted forward.

Move Song Start

Move Song Start in the Time Operation window lets you redefine the location of the Song Start Marker.

Move Song Start Example

To move the Song Start Marker to 15 seconds on the Timeline:

1 Choose Event > Time Operations > Move Song Start.

2 Select Minutes:Seconds from the Timebase pop-up menu.

3 In the Move Song Start To field, enter “0:15:000” to move the song start forward by 15 seconds.
4 If you want to renumber the bars so that the Song Start Marker sits at a different bar, select the Renumber Song Start option, and enter the bar number.

5 Select whether you want to move All or No sample-based markers and tracks.

6 Click Apply.

**Move Song Start Options**

Options for the Move Song Start command include:

**Timebase** Lets you precisely redefine the position of the Song Start Marker measured by any supported timebase.

**Move Start To** Sets the location for the Song Start Marker in the chosen timebase.

**Renumber Song Start To** When enabled, this lets you set the Song Start Marker to any bar number.

**Move**

The Move controls let you choose which items shift when the Song Start is moved, as follows:

**Song Start Only** Moves the Song Start Marker only.

**Meter, Tempo, Key, and Chord Rulers, all Tick-Based Markers and Tracks, and Sample-Based Markers and Tracks** Moves the Song Start Marker, events in the Meter, Tempo, Key, and Chord rulers, all tick-based markers and tracks, and your choice of all or no sample-based markers and tracks.

---

**Renumbering Bars**

You can use the Renumber Bars command to renumber all bars in the session, effectively changing the bar locations for all clips, meter and tempo events while leaving their position intact. In doing so, however, the SMPTE and sample locations of the session data are not changed.

To renumber bars:

1 Choose Event > Renumber Bars.

2 Specify the bar you want to renumber, along with the new bar number, then click Renumber.

**Renumber Bars dialog**

---

**Key Signatures**

The Key Signature ruler lets you add key signatures to Pro Tools sessions. Key signatures can be imported and exported with MIDI data. This is especially useful when exporting MIDI sequences for use in notation programs like Sibelius (see “Exporting Sibelius Files” on page 416). The default key signature is C major.
**Key Signature Ruler**

The Key Signature ruler lets you add, edit, and delete key signatures. You can use key signatures to indicate key and key changes in your Pro Tools session. Key signatures can also be used for certain diatonic functions, such as transposing in key or constraining pitches to the specified key.

To view the Key Signature ruler, do one of the following:
- Select View > Rulers > Key Signature.
- From the Ruler View selector in the Edit window, select Key.

You can also show or hide the Key Signature Staff for the Key Signatures ruler.

**To view the staff for the Key Signature ruler:**
1. Show the Key Signature ruler.
2. Do one of the following:
   - Select View > Rulers > Key Signature Staff.
   - Click the Show/Hide triangle on the Key Signature ruler.

**Changing Key Signatures**

You can add, edit, or delete key signatures.

**To add a key signature:**
1. Place the cursor in the Timeline where you want to add a key signature.
2. Do one of the following:
   - Choose Event > Add Key Change.
   - Click the Plus (+) button in the Key Signature ruler.
3. In the Key Change dialog, select the mode (major or minor), the key, its location and range, and how you want it to affect pitched tracks.
4. Click OK.

**To edit a key signature:**
1. Double-click the Key Signature marker in the Key Signature ruler.
2. Make changes in the Key Change dialog.
3. Click OK.

**To delete a key signature, do one of the following:**
- Option-click (Mac) or Alt-click (Windows) the Key Signature marker in the Key Signature ruler.
- Make a selection in the Key Signature ruler that includes the key signature you want to delete and choose Edit > Clear or press Delete.
Key Change Dialog

The Key Change dialog lets you specify the mode (major or minor), the key (from seven flats to seven sharps), the range affected (for example, from Bar 1 to the next key change), and whether or not MIDI notes on pitched tracks are transposed or constrained to key (see “Pitched Tracks” on page 876). The Key Change dialog opens whenever you add or edit a Key Signature marker.

**Key Change dialog**

**Major Keys** Displays the major keys from seven flats to seven sharps.

**Minor Keys** Displays the minor keys from seven flats to seven sharps. Pro Tools only applies the natural minor mode.

**Sharps** Lets you select any of the sharp keys to seven sharps and C major (or A minor).

**Flats** Lets you select any of the flat keys to seven flats and C major (or A minor).

**From** Lets you specify where to place the Key Signature marker in Bars|Beats.

**To** Lets you specify to where you want the key change to take effect: to the next Key Signature marker, to a selection, or to the end of the session.

**Snap to Bar** Snaps the Key Signature marker to the barline.

**Edit Pitched Tracks** Enabling the Edit Pitched Tracks option lets you transpose existing MIDI notes on Pitched tracks up or down, either diatonically or chromatically based on the key change, or constrain pitches to the new key. For more information on Pitched tracks, see “Pitched Tracks” on page 876.

**Transpose** When the Edit Pitched Tracks option is enabled, lets you transpose existing MIDI notes on Pitched tracks up or down, diatonically or chromatically. For example, if the session is in C major and you are adding a key change to D minor, select Edit Pitched Tracks, Transpose, Up, and Diatonically to transpose notes on Pitched tracks up a whole step and then lower the third, sixth, and seventh scale degrees by a half step. The sequence C, D, E is transposed to D, E, F (natural, rather than sharp as happens when transposing chromatically).

When transposing diatonically, chromatic notes are maintained when changing key. For example, when changing key from C major to E major, the note B-flat is transposed to D-natural. This lets you maintain “blue-notes” when changing keys and applying diatonic transposition.

**Constrain Pitches To Key** When the Edit Pitched Tracks option is enabled, lets you constrain pitches to the notes of the new key. This means that any diatonic pitches of the old key on Pitched tracks that are not in the new key are individually transposed to the nearest diatonic pitch of the new key. For example, when changing from C major to D major, the sequence C, D, E, F, G changes to C-sharp, D, E, F-sharp, G.

Constraining pitches to key also constrains any chromatic pitches to the new diatonic scale. For example, when changing from C major to D major, the sequence C, D, D-sharp, E changes to C-sharp, D, D, E.
**Pitched Tracks**

Pitched tracks are MIDI or Instrument tracks that can be affected by transpositions due to key changes (including constrain to key). MIDI and Instrument tracks are “pitched” by default. However, if you have MIDI or Instrument tracks assigned to drum machines or samplers, you do not want those tracks to be affected by key changes because of key mappings. You can deselect the Pitched option for specific MIDI and Instrument tracks so that they will not be affected by key changes.

**To select (or deselect) Pitched tracks:**
- Click the track’s Playlist selector and select (or deselect) the Pitched option.

**Importing Key Signatures**

When importing MIDI (or session data with MIDI), you can select whether or not to import any key signatures stored in MIDI files.

**Import MIDI**

The Import MIDI dialog includes the Import Key Signature from MIDI File option. When selected, key signatures (if present) are imported into Pro Tools with any other MIDI data.

**Import Session Data**

The Import Session Data dialog includes the Import Key Signature/Chord Map option. When selected, key signatures (if present) and chord markers (if present) are imported into the current session with the imported session data.
Chapter 38: Time, Tempo, Meter, Key, and Chords

Chord Symbols

The Chord Symbols ruler lets you add chord symbols to Pro Tools sessions in the Edit window and in MIDI Editor windows. You can also add chord symbols and diagrams in the Score Editor (“Chord Symbols and Diagrams” on page 824).

Chord symbols have no effect on MIDI data. Also, chord symbols are not included when exporting MIDI data from Pro Tools to a MIDI file, but they are included when exporting to a Sibelius file (.sib) or when using the Send to Sibelius command.

Chord Symbols Ruler

The Chord Symbols ruler lets you add, edit, and delete chord symbols. You can use chord symbols to indicate the chord changes in your Pro Tools session.

To view the Chord Symbols ruler, do one of the following:

- Select View > Rulers > Chord Symbols.
- From the Ruler View selector in the Edit window or in a MIDI Editor window, select Chords.

To add a chord symbol:

1. Place the cursor in the Timeline where you want to add a chord symbol.

2. Do one of the following:
   - Place the cursor in the timeline, then click the Plus (+) button in the Chords ruler.
   - While pressing the Control (Mac) or Start key (Windows), move the cursor into the Chords ruler (where the cursor changes to the Grabber with a “+”) and click at the location where you want to place the chord symbol.

3. In the Chord Change dialog, select the name for the root of the chord, the chord quality, the bass note of the chord, and the chord diagram (chord diagrams are only displayed in the Score Editor).

4. Click OK.

To change a chord symbol:

1. Double-click the Chord Symbol marker in the Chord Symbol ruler.

2. Make changes in the Chord Change dialog.

3. Click OK.

To move a chord symbol:

- Drag the Chord Symbol marker to a new time location.

To delete a chord symbol, do one of the following:

- Option-click (Mac) or Alt-click (Windows) the Chord Symbol marker in the Chords ruler.
- Make a selection in the Chords ruler that includes the chord symbols you want to delete and choose Edit > Clear or press Delete.
Chord Change Dialog

The Chord Change dialog lets you specify a commercial chord symbol and chord diagram (guitar tab) to place in the Chords ruler or on the score in the Score Editor. The Chord Change dialog opens whenever you add or edit a Chord marker.

Chord Select the name for the root of the Chord (such as D).

Chord Quality Select the chord quality from the selector (such as major or minor).

Bass Select the bass note of the chord (such as B-flat for a G minor chord in first inversion).

Chord Diagram Select the chord diagram for guitar tablature.

To show or hide chord symbols and diagrams in the Score Editor, select or deselect the corresponding option in the Score Setup dialog.

Extract Chords From Selection

Pro Tools lets you analyze selected MIDI clips to identify chords, and then add them to the Chord Symbols ruler in the Edit window as well as in MIDI Editor windows. Depending on the Score Setup Display settings (File > Score Setup), analyzed chords will also be shown as Chord Symbols and Chord Diagrams in the Score Editor window. When analyzing MIDI clips, Pro Tools can only recognize chords that are available in the Chord Change dialog. Chord Symbol markers are added to the Chord Symbol ruler quantized to quarter-note intervals on the Timeline. Chord extraction is useful for scoring in addition to providing chord symbols for charts and recording overdubbed performances.
To analyze MIDI clips for chord content and add Chord Symbol markers to the Chord Symbols ruler:

1. Select one or more whole MIDI clips.
2. Choose Event > Extract Chords from Selection.

Pro Tools adds Chord Symbol markers to the Chord Symbols ruler for all chords detected in the selected MIDI clips.
Chapter 39: Memory Locations

Memory Locations provide a powerful way to navigate your session while editing and arranging.

Each session can save up to 999 Memory Locations that can be used to recall:

- Markers to important locations in the session
- Edit selections across one or more tracks
- Record and play ranges, along with pre- and post-roll times
- Track settings that include Show/Hide status, Track Heights, and zoom values
- Edit and Mix Groups enables
- Window Configurations

Memory Locations are viewed and sorted in the Memory Locations window, where they can be recalled by clicking the Memory Location.

Creating Memory Locations

Memory Locations can be created in different ways, based on the type of Memory Location:

**Marker Memory Location** Refers to a specific point in the timeline.

**Selection Memory Location** Refers to an Edit Selection

**General Properties Memory Location** Refers to a combination of session settings (such as zoom settings, pre- and post-roll times, Show/Hide status for tracks, Track Heights, and Edit and Mix Group enables).

When creating Memory Locations, the next available number is assigned to it (1–999). This number is used in recalling the Memory Location from the numeric keypad.

To create a Marker Memory Location:

1. Configure any session settings you will save with the Marker Memory Location, such as zoom settings, pre- and post-roll times, Show/Hide status for tracks, Track Heights, and Edit and Mix Group enables.
2. If necessary, enable Options > Link Timeline and Edit Selection.
3. Ensure that the Markers ruler is displayed (View > Rulers > Markers).
4. Do one of the following:
   - Click with the Selector tool in any track or ruler at the location where you want to place the Marker. To place a Marker at the beginning of a clip, select the clip with the Time Grabber tool. Click the Add Marker/Memory Location button (or press Enter on the numeric keypad).

![Add Marker/Memory Location button](image-url)
• While pressing the Control (Mac) Start key or (Windows), move the cursor into the Markers ruler (where the cursor changes to the Grabber with a “+”) and click at the location where you want to place the Marker.

5 In the New Memory Location dialog, select the Marker option and set the Reference to either Bar|Beat or Absolute.

6 Enter a Name for the new Marker and select any General Properties you want to save with the Marker.

7 Click OK. The Marker is created and appears in the Markers ruler, and in the Memory Locations window.

To create a Selection Memory Location:

1 Configure any session settings you will save with the Selection Memory Location, such as zoom settings, pre- and post-roll times, Show/Hide status for tracks, Track Heights, and Edit and Mix Group enables.

2 Select a range of material in one or more tracks.

3 Do one of the following:
   • Press Enter on the numeric keypad.
   • From the Memory Locations Window menu, choose Add Memory Location.

4 In the New Memory Location dialog, select the Selection option and set the Reference to either Bar|Beat or Absolute.

5 Enter a Name for the new Memory Location and select any General Properties you want to save with it.

6 Click OK. The Selection Memory Location is created and appears in the Memory Locations window.

To create a General Properties Memory Location:

1 Configure any session settings you will save with the Selection Memory Location, such as zoom settings, pre- and post-roll times, Show/Hide status for tracks, Track Heights, and Edit and Mix Group enables.

2 Press Enter on the numeric keypad.

3 In the Memory Location dialog, select the None option.

4 Enter a Name for the new Memory Location and select any General Properties you want to save with it.

5 Click OK. The General Properties Memory Location is created and appears in the Memory Locations window.

In the New Memory Location dialog, you can Option-click (Mac) or Alt-click (Windows) any General Property to enable or disable all properties. You can also Command-click (Mac) or Control-click (Windows) any property to toggle its state and the state of all other General Properties.

Creating Memory Locations During Playback

When the Auto-Name Memory Locations When Playing option is enabled in the Editing Preferences page, Memory Locations can be created during playback, without opening the New Memory Location dialog. This option can also be selected from the Memory Locations Window menu.
This capability is useful if you want to mark certain locations while listening during a record pass, or if you want to mark frame locations while viewing a video scene.

**To create a Marker during playback:**

1. From the Memory Locations Window menu, select Default To Marker. This ensures that new Memory Locations default to being Markers.
2. From the Memory Locations Window menu, select Auto-Name Memory Locations.
3. For inserted Markers to have a Bar|Beat reference, make sure to set the Main Time Scale to Bars|Beats.
4. Click Play in the Transport.
5. When the location is reached, press Enter on the numeric keypad. A Marker is automatically created and appears in the Markers ruler.

Auto-created Markers are named with increasing numbers, for example, “Marker 1,” “Marker 2,” and “Marker 3.”

When the Default To Marker option is deselected, new Memory Locations default to whatever type was last created. Therefore, if a Selection Memory Location was created last, it will be the type that is created during playback. In this case, the name for the created Memory Location is based on the start of the Edit selection using the time format for the Main Time Scale (such as “2|2|305” or “0:02.658”).

When Use Separate Play and Stop Keys option is enabled in the Operation Preferences page, it overrides using the Enter key to add Memory Location markers. When this option is enabled, press Period (.) and then Enter on the numeric keypad to add a Memory Location marker. The new marker is created when you press Enter.

---

**Properties of Memory Locations**

When creating a new Memory Location (see “Creating Memory Locations” on page 881) you are prompted to define its Time Properties and General Properties.

**Time Properties**

Under Time Properties, a Memory Location can be set to Marker, Selection, or None. This determines the type of Memory Location that is created. Each of these three Memory Location types can also save any combination of General Properties.

**Marker** Recalls a Timeline location whose reference can be either Bar|Beat (tick-based) or Absolute (sample-based). When recalling a Marker Memory Location, the playback cursor moves to
the Marker’s location and the start and end times in
the Transport window are also updated. If the
Timeline and Edit Selections are linked, the edit
cursor also moves to the Marker location.

Markers appear in the Markers ruler with a thin
color yellow line extending down through all tracks in
the Edit window (to assist in arranging and align-
ing track material). You can click a Marker in the
Markers ruler to recall its location along with its
stored General Properties.

**Selection** Recalls an Edit selection or edit cursor
location whose reference can be either Bar|Beat
tick-based) or Absolute (sample-based). A Selec-
tion Memory Location lets you store Edit selec-
tions, for one or more tracks, that you return to of-
ten within a session. If the Timeline and Edit
Selections are linked, a Selection Memory Location
can recall record and play ranges.

**None** Recalls no Time Properties and is therefore
referred to as a General Properties Memory Loca-
tion.

**Bar|Beat and Absolute Reference**
The Reference pop-up determines whether the
Marker or Selection Memory Location is Bar|Beat
or Absolute. When set to Bar|Beat, the Memory
Location is tick-based and its bar and beat location
remains constant if the tempo is changed—though
its relation to the absolute sample location changes
accordingly.

When set to Absolute, the Memory Location is
sample-based and its bar and beat location shifts if
the tempo is changed—though its sample location
remains constant, along with its relation to audio
material.

In the Markers ruler, Markers that are Bar|Beat ap-
pear as yellow chevrons, and Markers that are Ab-
solute appear as yellow diamonds.

**General Properties**
All three types of Memory Locations (Marker, Se-
lection, and None) can store and recall any combi-
nation of the following General Properties:

**Number** Change the number to overwrite an exist-
ing Memory Location, or to reorder Memory Lo-
cations in the Memory Locations window.

**Name** Enter a descriptive name for each memory
location.

**Zoom Settings** Recalls the horizontal, audio, and
MIDI zoom values for audio, MIDI, and Instru-
ment tracks.
Pre/Post Roll Times Recalls pre- and post-roll times (but not whether they are enabled). This property can be stored with a Selection Memory Location to recall record and play ranges along with pre- and post-roll.

Track Show/Hide Recalls which tracks are hidden. Use this property to display groups of tracks for editing and mixing.

Track Heights Recalls all Track Heights. Use this option along with Zoom Settings to recall edit environments that are suited for particular tasks, such as editing down to the sample level or trimming MIDI notes.

Group Enables Recalls which Edit and Mix Groups are enabled. This option is helpful in recalling groups for particular edit and mixing operations, such as muting all drum tracks or fading a stereo pair.

Window Configuration Recalls a specific Window Configuration. This option is helpful in recalling specific Window Configurations to facilitate editing or mixing tasks. For more information on Window Configurations, see “Window Configurations” on page 203.

Comments
All three types of Memory Locations (Marker, Selection, and None) can store and recall comments. You can enter a maximum of 255 characters to describe the Memory Location. You can also edit comments previously entered.

Recalling Memory Locations
Memory Locations can be recalled from the Memory Locations window and from the numeric keypad. Additionally, Memory Location Markers can be recalled by clicking them in the Markers ruler.

To recall a Memory Location:
1. Select Window > Memory Locations to display the Memory Locations window.
2. If recalling a Selection Memory Location that defines a record or play range, ensure that Options > Link Timeline and Edit Selection is selected.
3. Do one of the following:
   - In the Memory Locations window, click the Memory Location to recall it.
   - With the Numeric Keypad mode set to Classic, press the Memory Location number followed by Period (.).
   - With the Numeric Keypad mode set to Transport or Shuttle, press Period (.), the Memory Location number, and Period (.) again.

When recalling a Memory Location from the numeric keypad, the Memory Locations window does not need to be open.

To recall a Marker from the Markers ruler:
1. Select View > Rulers > Markers to display the Markers ruler.
2. Click the Marker you want. The playback cursor locates to the Marker and any General Properties stored with the Marker are recalled.

Even if the Markers ruler is not displayed, Markers can be recalled from the Memory Locations window, or from the numeric keypad.
Editing Memory Locations

Memory Locations can be renamed, edited, deleted, and copied and pasted.

To rename a Memory Location:
1  Do one of the following:
   • In the Memory Locations window, double-click the Memory Location to open the Edit Memory Location dialog.
   • In the Marker ruler, double-click the Marker to open the Edit Memory Location dialog and relocate the insertion point at the marker location.
   • In the Marker ruler, Control-click (Mac) or Start-click (Windows) the Marker to open the Edit Memory Location dialog without locating the insertion point at the marker location.
2  Enter the new name for the Memory Location, and click OK.

To redefine the General Properties stored with a Memory Location:
1  Make changes to the session’s zoom settings, pre- and post-roll times, Show/Hide status of tracks, Track Heights, or Group Enables.
2  Do one of the following:
   • In the Memory Locations window, double-click the Memory Location to open the Edit Memory Location dialog.
   • In the Marker ruler, double-click the Marker to open the Edit Memory Location dialog and relocate the insertion point at the marker location.
   • In the Marker ruler, Control-click (Mac) or Start-click (Windows) the Marker to open the Edit Memory Location dialog without locating the insertion point at the marker location.
3  In the Memory Location dialog, select the General Properties you want to save with the Memory Location.
4  Enter a name for the Memory Location and click OK.

To change a Memory Location from one type to another:
1  Do one of the following:
   • In the Memory Locations window, double-click the Memory Location to open the Edit Memory Location dialog.
   • In the Marker ruler, double-click the Marker to open the Edit Memory Location dialog and relocate the insertion point at the marker location.
   • In the Marker ruler, Control-click (Mac) or Start-click (Windows) the Marker to open the Edit Memory Location dialog without locating the insertion point at the marker location.
2  In the Memory Location dialog, select either Marker, Selection, or None as the Memory Location type.
3  Enter a name for the Memory Location and click OK.

To change the Selection stored with a Memory Location:
1  Select View > Rulers > Markers to display the Markers ruler.
2  Select a range of material in one or more tracks.
3  In the Memory Locations window, Control-click (Mac) or Right-click (Windows) the Memory Location that you want to redefine.
4  Enter a name for the Memory Location and click OK.
To move a Marker by dragging:

- In the Markers ruler, drag the Marker left or right.

If the Edit mode is set to Grid, the dragged event snaps to the current Grid value. If using Spot mode, the Spot dialog opens.

To align a Marker to a different location:

1. If necessary, select Options > Link Timeline and Edit Selection.
2. Do one of the following:
   - In any of the Timebase rulers, click with the Selector tool at the new location.
   - Click in the playlist for any track. To align the Marker to the start of a clip, select the clip with the Time Grabber tool.
3. In the Memory Locations window or the Markers ruler, Control-click (Mac) or Start-click (Windows) the Marker Memory Location that you want to redefine.
4. Enter a name for the Marker and click OK.

Deleting Memory Locations

To delete a Memory Location, do one of the following:

- Select the Memory Location and choose Delete Memory Location from the Memory Locations Window menu.
- In the Memory Locations window, Option-click (Mac) or Alt-click (Windows) the Memory Location.

To delete all Memory Locations, do one of the following:

- Choose Delete All from the Memory Locations Window menu.
- Option-Shift-click (Mac) or Alt-Shift-click (Windows) any Memory Location in the Memory Locations window.

To delete a Marker from the Markers ruler:

- Option-click (Mac) or Alt-click (Windows) the Marker.

Copying Marker Memory Locations

To copy and paste a range of Markers:

1. If you want to constrain the selection to the current Grid value, set the Edit mode to Grid.
2. Drag in the Tempo ruler to select the range of measures that includes the Markers.
   - If the beginning of the selection includes a Marker, press Command (Mac) or Control (Windows) so the Selector tool appears.
3. Choose Edit > Copy.
4. Click in the Markers ruler at the point where you want to paste the tempo events.
5. Choose Edit > Paste. The contents of the Clipboard are pasted from the insertion point, replacing any existing Markers.
To extend an Edit selection in a track to the Markers ruler:

1. Using the Selector or Grabber tool, select a track range.

2. Shift-click in the Markers ruler.

Shift-click again in the Markers ruler to remove it from the selection.

To select all Markers in the Markers ruler:

- With the Selector tool, double-click in the Markers ruler.

---

### Memory Locations Window

In the Memory Locations windows, Memory Locations are listed with assigned number, name, and View Filter icons. Locations can be recalled or edited from this window.

![Memory Locations window with View Filter icons](image_url)

To recall a Memory Location from the Memory Location window:

- Click the Memory Location.

---

**Memory Locations Commands and Options**

You can select viewing and sorting options, along with commands for creating and removing Memory Locations, from the Memory Locations Window menu.

![Memory Locations Window menu](image_url)

**View Filter Submenu** Provides commands to show or hide specific memory location properties:

- Show Icons
- View Markers
- View Selections
- View Locations with Zoom Info
- View Locations with Pre/Post Roll Info
- View Locations with Track Show/Hide Info
- View Locations with Track Height Info
- View Locations with Group Info
- View Locations with Window Configuration Info
- Show Markers Only
- View All

---

*With the Numeric Keypad mode set to Classic, press the Memory Location number followed by Period (.). With the Numeric Keypad mode set to Transport or Shuttle, press Period (.), the Memory Location number, and Period (.) again.*
Show Main Counter When selected, a column appears in the Memory Locations window that displays the locations based on the Main Time-scale for Markers, and the start times for Selection Memory Locations. General Property Memory Locations display nothing in this column.

You can click at the top of the Main Time Scale column for a pop-up menu that lets you change the Main Time Scale.

Show Sub Counter When selected, a column appears in the Memory Locations window that displays the locations based on the Sub Time Scale for Markers, and the start times for Selection Memory Locations. General Property Memory Locations display nothing in this column.

You can click at the top of the Sub Time Scale column for a pop-up menu that lets you change the Sub Time Scale.

Show Comments

When selected, a column appears in the Memory Locations window that displays the comments for each of the Markers.

Comments in the Memory Locations window

Sort by Time When selected, Markers are sorted by their order in the Timeline, followed by Selection and General Properties Memory Locations, which are listed in the order in which they were created.

When Sort by Time is deselected, all Memory Locations are listed in the order of their assigned numbers.

New Memory Location Choose this command to create a new Memory Location.

Edit <Name> Opens the Edit Memory Location dialog for the selected Memory Location. You can also double-click a Memory Location in the Memory Locations window to edit it.

Clear <Name> Clears the selected Memory Location, but does not remove its slot. Subsequent Memory Locations are not renumbered.

Option-click (Mac) or Alt-click (Windows) a Memory Location in the Memory Locations window to clear it.
Delete All  Deletes all Memory Locations. The next Memory Location you add starts at slot number 1.

Insert Slot Before <Name>  Adds a new, empty Memory Location slot above the selected Memory Location, and renumbers all subsequent Memory Locations.

Delete <Name> Slot  Deletes the selected Memory Location, and renumbers all subsequent Memory Locations.

Default To Marker  When selected, new Memory Locations default to Markers, though in the New Memory Location dialog you can still define the new Memory Location as one of the other types.

Auto-Name Memory Location  When selected, Memory Locations are created automatically without encountering the New Memory Location dialog. If the Default To Marker option is selected, a Marker Memory Location is auto-created. Otherwise, the Memory Location type is determined by whatever type (Marker, Selection, or None) was created last.

View Filter Icons

When Show Icons is selected in the Memory Locations pop-up menu, the Memory Locations window provides an icon-based “View Filter” that lets you show or hide Memory Locations based on the properties they contain.

To show or hide Memory Locations containing a specific property:

- Click the appropriate icon.

Color and Properties

When a view icon is enabled, it appears in color. When it is disabled, it appears gray.

If an icon is disabled (grayed out), all Memory Locations associated with that property are hidden. However, if a Memory Location contains other properties for an icon that is enabled, it is still displayed.

In addition, the View Filter provides a useful reference for which properties are stored in each Memory Location (indicated by a row of icons for each Memory Location).
Chapter 40: Arranging Clips

Pro Tools provides several ways of arranging clips on tracks including, but not limited to, moving them with the Grabber tool, nudging, cutting or copying and pasting, spotting them to a time location, and so on. The exact placement of clips in a track depends on whether the Edit mode is set to Shuffle, Slip, Spot, or Grid (see “Edit Modes” on page 599).

Placing Clips from the Clips List on to Track Playlists

Once you have created a clip, it appears in the Clips List. From the Clips List you can drag it to a track to add to an existing arrangement of clips on a track, or you can create a new track and start adding clips from scratch.

You can locate clips in the Clips List by typing the first few letters of their name (see “Keyboard Selection of Clips” on page 294).

To place a clip from the Clips List on a track:

1. In the Clips List, select the clip or clips you want to place.
2. Drag the selected clips from the Clips List to a location in a track.

If dragging multiple clips, the clips are placed on adjacent tracks left to right or on multiple tracks from top to bottom depending on the selected Timeline Drop Order option (see “Setting Timeline Drop Order” on page 892). If dragging a stereo audio clip, it must be placed in a stereo track or in two mono tracks.

Clips are placed according to the current Edit mode:

- In Shuffle mode, existing track clips are slid as necessary to make room for the new clip.
- In Spot mode, you are prompted by the Spot dialog to enter a location for the dragged clip (see “Spotting Clips” on page 900).
- In Grid mode, the dragged clip snaps to the nearest Grid boundary.

You can temporarily disable Grid mode while dragging a clip by holding down the Command key (Mac) or Control key (Windows) after clicking with the mouse.

- In Slip mode, the clips are placed exactly where they are dropped in the destination track.
Working with Multiple Items from the Clips List

Setting Timeline Drop Order

The Timeline Drop Order option in the Clips List menu sets whether tracks dragged from the Clips List are dropped sequentially in a single track or spread across multiple tracks, as follows:

**Top to Bottom** When enabled, clips spread across multiple destination (drop) tracks or on new tracks (when dragging to the area below the last track or to the Tracks List).

**Left to Right** When enabled, clips are placed sequentially in a single destination (drop) track or on a new track (when dragging to the area below the last track or on to the Tracks List).

To set the Clips List Drop Order:

- Choose Clips List > Timeline Drop Order, and then Top to Bottom or Left to Right.

Dragging and Dropping Multiple Items from the Clips List

To drag and drop multiple items from the Clips List to multiple new tracks:

1. From the Clips List menu, choose Timeline Drop Order > Top to Bottom.

2. Search and sort the Clips List to configure the order in which items will be placed.

3. Select multiple items in the Clips List and do one of the following:
   - To create new tracks and place items to a specific location, drop items at the location along the area below the last track.
   - To create new tracks and have items placed at the start of the session, drop the items on the Tracks List.

New tracks after dropping multiple Clips List items, with Timeline Drop Order set to Top to Bottom mode

To place multiple items across multiple existing tracks:

1. From the Clips List menu, choose Timeline Drop Order > Top to Bottom.

2. Select multiple items in the Clips List and drop them in the playlist of a compatible track at the target location. When the cursor is over a compatible destination, the clip outlines appear at the location.
To drag and drop multiple items from the Clips List to a single track:

1. From the Clips List menu, choose Timeline Drop Order > Left to Right.

2. Search and sort the Clips List to configure the order in which items will be placed.

3. Select multiple items in the Clips List and do one of the following:
   - To create a new track and spot the first item to a specific location, drop at the location in the area below the last track shown in the Edit window.
   - To create a new track and have the first item placed at the start of the session, drop the items on the Tracks List.
   - To place items in an existing track, drop the items in the Edit playlist for the track.

If the selected items include mixed types of clips (such as audio and MIDI, or clip groups and MIDI) the appropriate track types will be created and each corresponding item will be placed in them. Similarly, if the selected items include multiple formats (mono, stereo, or other) new tracks of each format will be created and those clips placed in them.

---

**Placing Clips at the Edit Insertion Point**

You can drag a clip from the same track, from another track, or from the Clips List, and align its start, end, or sync point to the Edit insertion point. This technique is useful in post production since it lets you set an Edit selection point during playback or while stopped and then quickly place sound effects at the edit insertion point.

*With Pro Tools Ultimate, when the Scrolling option is set to Center Playhead, clips snap to the playhead, instead of the Edit insertion point.*

**To place the start of a clip at the Edit insertion point:**

1. With the Selector tool, click in the track at the time location where you want to place the start of the clip.

2. Do one of the following:
   - While pressing Control (Mac) or Start (Windows), drag the clip from the Clips List, or from another track, to the destination track.
   - If the clip is already in the track, Control-click (Mac) or Start-click (Windows) the clip with the Time Grabber tool.

**To place the end of a clip at the Edit insertion point:**

1. With the Selector tool, click in the track at the time location where you want to place the end of the clip.

2. Do one of the following:
   - While pressing Command+Control (Mac) or Control+Start (Windows), drag the clip from the Clips List, or from another track, to the destination track.
   - If the clip is already in the track, Command-Control-click (Mac) or Control-Start-click (Windows) the clip with the Time Grabber tool.
To place the sync point of a clip at the Edit insertion point:

1. With the Selector tool, click in the track at the time location where you want to place the sync point of the clip.

2. Do one of the following:
   • While pressing Control+Shift (Mac) or Start+Shift (Windows), drag the clip from the Clips List, or from another track, to the destination track.
   • If the clip is already in the track, Shift-Control-click (Mac) or Shift-Start-click (Windows) the clip with the Time Grabber tool.

Aligning Clips with the Edit Insertion Point

The start, end, and sync point of one clip can be aligned to the start of a different clip on another track.

In Pro Tools Ultimate, when the Scrolling option is set to Center Playhead, clip start, end, and sync points align to the playhead.

To align the start point of a clip to the Edit insertion point:

1. Place the Edit insertion point where you want.

2. Do one of the following:
   • Control-drag (Mac) or Start-drag (Windows) a clip from the Clips List to another track.
   • If the clip is already in the track, Command-Control-click (Mac) or Control-Start-click (Windows) the clip you want to move with the Time Grabber tool (or with the Smart tool positioned over the middle, lower-third of the clip).

To align the end point of a clip to the Edit insertion point:

1. Place the Edit insertion point where you want.

2. Do one of the following:
   • Command-Control-drag (Mac) or Control-Start-drag (Windows) a clip from the Clips List to another track.
   • If the clip is already in the track, Command-Control-click (Mac) or Control-Start-click (Windows) the clip you want to move with the Time Grabber tool (or with the Smart tool positioned over the middle, lower-third of the clip).

To align the sync point of a clip to the Edit insertion point:

1. Place the Edit insertion point where you want.

2. Do one of the following:
   • Control-Shift-drag (Mac) or Start-Shift-drag (Windows) a clip from the Clips List to another track.
   • If the clip is already in the track, Control-Shift-click (Mac) or Start-Shift-click (Windows) the clip you want to move with the Time Grabber tool (or with the Smart tool positioned over the middle, lower-third of the clip).

Command-Option-Control-click (Mac) or Start-Alt-Start-click (Windows) and drag to align a copy of the clip rather than moving the clip.

Option-Control-click (Mac) or Alt-Start-click (Windows) and drag to align a copy of the clip rather than moving the clip.
Arranging with Transparent Clip Overlays

Transparent clip overlays can be useful for visually aligning the placement of one clip over another clip (for example, if you want to align a particular transient of one clip over a particular transient in another clip).

To toggle the display of clip transparency:
- Select or deselect View > Clip > Transparency.

Moving Clips with the Grabber Tools

Use the Grabber tools to move one or more clips, or the Edit selection, to another location.

💡 Hold Option (Mac) or Alt (Windows) when dragging the selection with a Grabber tool to copy the selection rather than cut it.

To move one or more clips, or the Edit selection, with one of the Grabber tools:

1. Select one or more clips, or make an edit selection.

2. With one of the Grabber tools (Time, Separation, or Object), drag the selection to the new location.

Time Grabber and Object Grabber

If you are moving audio data, the Time Grabber and Object Grabber tools overlay only the audio data on the destination track.

Separation Grabber

The Separation Grabber replaces the entire selected range on the destination track Timeline.
Layered Editing

Pro Tools provides the option to enable layered editing so that you don’t lose partially overlapped clips while editing. This is true for both audio and MIDI.

To enable (or disable) layered editing, do one of the following:

- Select (or deselect) Options > Layered Editing.
- Click the Layered Editing button in the Edit Window toolbar so that it is lit (or unlit).

When the Layered Editing option is enabled, any partially overlapped clips are revealed when cutting, clearing (deleting), or moving the overlapping clip. Note that if any clip is fully overlapped by another, larger clip, it is removed from the timeline. In Figure 1, the clip “Audio_1_01” (1) is moved (2) to fully cover one clip and partially cover another clip (3). When that clip (“Audio_1_02-01”) is cleared, the fully covered clip is gone, but the partially covered clip is revealed (4).

Press Command+Delete (Mac) or Control+Delete (Windows) to clear all track data within the edit selection regardless of whether or not Layered Editing is enabled.
When the Layered Editing option is disabled, overlapped clips remain “trimmed” to the start or end time of the overlapping clip. In Figure 2, the clip “Audio 1_01” (1) is moved to cover the middle of a larger clip (2). When that clip (“Audio 1_01”) is cleared, the overlapped clip has a hole punched in it (3). If Layered Editing is enabled in this case, the underlying clip is completely revealed and healed (4).

Snapping to the Preceding or Next Clip on a Track

A clip—or an Edit selection including one or more clips on the same track or on multiple tracks—can snap to the end of the preceding clip or to the beginning of the following clip. This is useful for “butt splicing” adjacent clips on a track.

**To snap to the preceding clip on a track:**

1. Do one of the following:
   - With the Time Grabber, select a clip.
   - With the Selector, select an area in a track that contains whole clips. The clips do not need to be adjacent.
   - Do one of the following:
     - Choose Edit > Snap To > Previous.
     - Right-click the clip or Edit selection and choose Snap to Previous.

The selected clip snaps to the preceding clip on the track so that the two clips are “butt-spliced.”

**To snap to the next clip on a track:**

1. Do one of the following:
   - With the Time Grabber, select a clip.
   - With the Selector, select an area in a track that contains whole clips. The clips do not need to be adjacent.
2 Do one of the following:
• Choose Edit > Snap To > Next.
• Right-click the clip or Edit selection and choose Snap to Next.

The selected clip snaps to the following clip on the track so that the two clips are “butt-spliced.”

Arranging Clips in Shuffle Mode

In Shuffle mode, you can move clips freely within a track or onto another track, but their movement is constrained by other clips. That is, if you place several clips in a track, their start and end points automatically snap to each other. You can then “shuffle” their order, but you cannot separate them from each other and you cannot make them overlap as in Slip mode. In Shuffle mode, adding another clip to the beginning of a track moves all subsequent clips to the right by the length of the clip added.

To shuffle clips:

1 Enable Shuffle mode (see “Edit Modes” on page 599).
2 Drag a mono clip from the Clips List to an empty track. The clip snaps to the beginning of the track.
3 Drag a second clip from the Clips List to the same track, somewhere in the middle. The start point for the second clip snaps to the end of the first clip.
4 With the Time Grabber tool, drag the second clip to the beginning of the track.
5 Experiment more with Shuffle mode by dragging additional clips to the track and rearranging them.

Pro Tools “shuffles” the position of the two clips. The second clip now occurs first, yet the two still cling together.

Locked clips (see “Locking Clips” on page 907), and all clips occurring after the locked clip, are not displaced when other neighboring clips are moved in Shuffle mode. If there is not enough room to place or duplicate a clip in front of a locked clip, the insertion area is disabled.

💡 You can also use the Snap To commands with an Edit selection that includes multiple clips on one or more tracks.
If you place a clip while in Slip mode and switch to Shuffle mode, Pro Tools preserves the relative timing and position of the slipped clip, and any space between it and other clips.

*With certain workflows, it is important to exclude Shuffle mode in order to ensure that clips stay time-aligned while editing. Shuffle Lock prevents you from inadvertently entering Shuffle mode by disabling all key commands and control surface switches for Shuffle mode. For more information, see “Shuffle Lock” on page 600.*

**Shuffling Multiple Tracks and Multichannel Clips**

Selections across multiple tracks or on multichannel tracks can be shuffled. Unlike shuffling clips on a single track, any partially selected clips are cut and moved along with the dragged clip. This lets you retain only the material that corresponds to the dragged clip.

**Arranging Clips in Slip Mode**

In Slip mode, clips can be moved with the Time Grabber tool and placed freely within a track, or onto other tracks. In this mode, it is possible to place a clip so that there is space between it and other clips in a track. When the track is played back, this space is silent. It is also possible to move a clip so that it overlaps or completely covers another clip.

**To slip clips:**

1. Enable Slip mode (see “Edit Modes” on page 599).
2. Drag a clip from the Clips List to an empty track.
3. Drag a second clip from the Clips List to the same track, somewhere in the middle. The second clip is placed wherever you release it. It does not snap to the first clip as in Shuffle mode.
4. Drag the clips to different locations within the track to get a feel for moving them in Slip mode. Try placing the second clip so that it slightly overlaps the first clip. Play back the results.

*Shuffling a clip results in cutting the channel*
Spotting Clips

Spot mode is useful for sessions in which you want to spot clips to precise locations based on any of the Time Scales. This is useful when performing post production tasks. In Spot mode you can spot a clip by specifying a SMPTE frame or bar and beat location, by capturing an incoming timecode address, or by using the clip’s time stamps.

For even quicker spotting, if you are using VITC, use the Auto-Spot Clips command to spot a clip to the current SMPTE frame location with the Time Grabber tool. For more information, see “Auto-Spotting Clips” on page 1290.

For more information on using SMPTE with Pro Tools, see Chapter 57, “Working with Synchronization.”

To spot a clip:

1 Enable Spot mode (see “Edit Modes” on page 599).

2 Do one of the following:
   - Drag a clip from the Clips List, or drag audio files or sessions from a Workspace browser to an existing track.
   - Click a clip already in a track with the Time Grabber tool.

3 In the Spot dialog, select a time format from the Time Scale pop-up menu.

Each of the fields in the Spot dialog are displayed in the chosen Time Scale.

4 If the Time Scale is set to Timecode, select the Use Subframes option to display subframes in the fields for improved accuracy.

5 Do one of the following:
   - Click in the field for Start, Sync Point, or End and type in a new location. Changing one of these locate points automatically updates the other locate points.
   - Click one of the up arrows next to Original Time Stamp or User Time Stamp to enter the associated values into the currently selected field.
   - If you are using an external SMPTE timecode source, click the down arrow next to the Current Timecode display—or press Equal (=) on the numeric keypad—to capture an incoming timecode address.

6 Click OK. The clip is moved to the new location specified for its start, end, or sync point.

If a clip does not have a sync point defined, the Sync Point field in the Spot dialog functions the same as the Start field.
Right-Click Commands for Spotting Clips

You can use Right-click commands with a key combination to spot clips in a track.

💡 In lower versions of Pro Tools, Right-clicking in a clip with the Grabber tool would spot the clip to a selection.

To spot a clip to a selection:

1. Click or drag with the Selector tool to locate the cursor or make a selection in the track where you want to spot the clip.

2. Command-Right-click (Mac) or Control-Right-click (Windows) the clip and choose any of the following from the pop-up menu:
   - Move Clip Start to Selection Start
   - Move Clip Sync to Selection Start
   - Move Clip End to Selection Start

Clip Time Stamps

When a clip is created, it is time stamped relative to the SMPTE start time specified for the session. This Original Time Stamp is permanently stored with the clip and cannot be changed. If a clip is ever moved, it can easily be placed at its original position from the Spot dialog.

When the Original Time Stamp for a clip is initially set, this same location is also used to define the clip’s User Time Stamp.

Unlike the Original Time Stamp, the User Time Stamp can be redefined with the Time Stamp command in the Clips List menu (see “Time Stamping” on page 1290).

Time Stamps in the Workspace

Columns are provided in Workspace browsers for both the Original and User Time Stamps.

Time Stamps and Matches

Clips with identical User Time Stamps appear together in the Matches submenu in the Right-click menu when auditioning takes (see “Selecting Alternate Takes on a Track” on page 530).

Arranging Clips in Grid Mode

Grid mode provides several useful capabilities for moving and placing clips in track playlists. This mode is especially useful for lining up clips at precise intervals, as when working with a session that is bar- and beat-based. Grid boundaries, depending on the Main Time Scale, can be based on frames, bar and beat values, minutes or seconds, or a number of samples.

Grid mode also provides two operational modes, Absolute and Relative. These modes control how the Grid is applied (see “Absolute and Relative Grid Mode” on page 902).

To temporarily suspend Grid mode and switch to Slip mode while dragging a clip, hold the Command key (Mac) or Control key (Windows).

Setting Up the Grid

When the Draw Grid in Edit Window option is enabled in the Display Preferences page, vertical Grid lines appear in the Edit window.

Grid lines in the Edit window can also be enabled and disabled by clicking the Timebase ruler name after it becomes highlighted.

Defining the Grid Value

In addition to affecting the placement of clips, the Grid value also constrains Timeline and Edit selections, and determines how the Clip > Quantize to Grid command works.
To set the Grid value:

1. Do one of the following:
   - From the View > Main Counter menu, select the Time Scale for the Grid value.
   - To keep the Main Time Scale and use a different time format for the Grid, deselect Follow Main Timebase in the Grid value pop-up menu.

2. Do one of the following:
   - From the Grid value pop-up menu, select the time value for the Grid boundaries.
   - To define a Grid based on the session’s Markers, selections, and clip boundaries, select Clips/Markers from the Grid value pop-up menu.

To increase the grid value incrementally:
- Press Shift+Equal (=).

To decrease the grid value incrementally:
- Press Shift+Minus (–).

Absolute and Relative Grid Mode

Grid mode can be applied in Absolute or Relative mode.

- In Absolute Grid mode, moving any clip snaps the clip start to Grid boundaries. If a clip’s start point falls between beats, and the Grid is set to 1/4 notes, dragging the clip will snap its start time to the nearest 1/4 note (the current absolute Grid value). Similarly, when moving MIDI notes (and other MIDI data), the start of the first MIDI event in the selection snaps to the nearest Grid location. Likewise, when cutting or copying and pasting clips or MIDI data while in Grid mode, the start of the clip or the start of the first MIDI event snaps to the nearest Grid location.

- In Relative Grid mode, clips can be moved by Grid (or Nudge) units. If the start point of a clip is offset from the Grid, the clip maintains its relative grid offset at the new location. Similarly, when moving MIDI notes (and other MIDI data), the start of the first MIDI event in the selection maintains its relative offset from the nearest Grid location. Likewise, when cutting or copying and pasting clips or MIDI data while in Relative Grid mode, any offset from the Grid is preserved. Also when pasting and merging MIDI data (Edit > Special Paste > Merge MIDI) while in Relative Grid mode, the pasted and merged MIDI data maintains its relative grid offset.

To select Absolute or Relative Grid mode:
- Click the Grid mode selector and select Absolute Grid or Relative Grid.

To temporarily suspend Grid mode and switch to Slip mode while dragging a clip, hold the Command key (Mac) or Control key (Windows).
To place, move, or paste a clip (or MIDI data) while in Grid mode:

1. Configure the Grid value (see “Defining the Grid Value” on page 901).
2. Enable Grid mode.
3. Do one of the following:
   - Drag a clip from the Clips List to an existing track.
   - With the Time Grabber tool, drag a clip already in a track to a new location.
   - Cut or Copy a clip (or selected MIDI data) and Paste it to a new location.

The clip’s start point (or the beginning of the selected MIDI data) snaps to the closest Grid boundary. If the clip has a sync point defined, the sync point snaps to the Grid boundary.

To place, move, or paste a clip (or selected MIDI data) while in Relative Grid mode:

1. Configure the Grid value (see “Defining the Grid Value” on page 901).
2. Enable Relative Grid mode.
3. Do one of the following:
   - With the Time Grabber tool, drag a clip that starts offset from the grid to a new location.
   - Cut or Copy a clip (or selected MIDI data) whose start time is offset from the Grid and Paste it to a new location.

The beginning of the moved or pasted clip (or selected MIDI data) maintains its relative offset from the nearest Grid location.

---

Replacing Audio Clips

(Pro Tools | Ultimate Software Only)

Use the Replace Clip function to replace multiple instances of an audio clip in a playlist with another clip. This is useful in post production if you use a sound effect, room noise, or atmosphere clip many times in a session, and later decide to replace one or all of the original clips with a different clip.

This is also useful in music production if you want to replace a certain loop or sample (for example, a drum beat) with a new one. You can use this compositionally, if you know the tempo of a section or session, to create a scratch piece with “rough” clips of the correct length, and later replace them with “final” clips of the same length.

To replace clips by dragging and dropping:

1. Select a clip in a track’s playlist that you want to replace. The selection can extend beyond the clip’s end point, to include material from the replacement clip that is longer than the original clip.
2. Command-Shift-drag (Mac) or Control-Shift-drag (Windows) the replacement clip from the Clips List to the selected clip. The Replace Clip dialog opens.
3. Configure the Replace Clip dialog (see “Replace Clip Dialog Options” on page 904).
4. Click OK.

Command-Shift-drag (Mac) or Control-Shift-drag (Windows) any clip from the Clips List to any unselected clip on a track to open the Replace Clip dialog without first making a selection.
Replacing Clips from the Clips List

The Replace Clips command is also available in the Clips List menu. To use this command, make sure there is a clip selected in a track and a different (replacement) clip selected in the Clips List.

To replace clips using the Clips List menu:
1. Select a clip in a track to be replaced.
2. Do one of the following:
   • Right-click the replacement clip in the Clips List and choose Replace Clips from the pop-up menu.
   • Select the replacement clip in the Clips List and choose Replace Clips from the Clips List menu. (If the Clips List Selection Follows Edit Selection preference is enabled, Command-click (Mac) or Control-click (Windows) the selected clip to de-select it, then Command-click (Mac) or Control-click (Windows) the replacement clip to select it, and then choose Replace Clips from the Clips List menu.)
3. Configure the Replace Clip dialog (see “Replace Clip Dialog Options” on page 904).
4. Click OK.

Replace Clip and Multichannel Tracks

The Replace Clip command supports dragging multichannel clips from the Clips List to multichannel tracks, provided they are the same channel format. For example, you can replace a selected stereo clip in a stereo audio track with another stereo clip from the Clips List. However, you cannot replace it with two mono audio clips. Additionally, you cannot replace clips in multiple mono tracks with multichannel clips.

Replace Clip Dialog Options

The following options are available in the Replace Clip dialog:

Replace: Original Clip Only Replaces only the selected clip with the replacement clip dragged from the Clips List.
Replace: All Instances of the Original Clip Replaces all instances of the selected clip that fit the On criteria with the replacement clip from the Clips List.

- On This Track: replaces clips that fit the Match criteria and are on the same track as the original clip.
- On All Tracks: replaces clips that fit the Match criteria for all tracks in the session.
- On Within the Selection: replaces clips that fit the Match criteria within the current selection.

Replace: All Clips that Match Original Clip’s Replaces all clips that fit the Match criteria and the On criteria with the replacement clip from the Clips List.

- Start Position: replaces all clips that have the same original start time as the selected clip. This includes clips that may have been auto-created when trimming end points.
- End Position: replaces all clips that have the same original end time as the selected clip. This includes clips that may have been auto-created when trimming start points.
- Name: replaces all clips that come from the same audio file and have been renamed to the same name
- On This Track: replaces clips that fit the Match criteria and are on the same track as the original clip.
- On All Tracks: replaces clips that fit the Match criteria for all tracks in the session.
- On Within the Selection: replaces clips that fit the Match criteria within the current selection.

Clip matching uses all specified Match criteria. For example, if you select Start Position and End Position, all clips from the same original audio file as your selection with the same original start and end times will be replaced.

Fit Clip Using The: Original Clip Length If the replacement clip is smaller than the original clip, the clip is placed in the playlist and any remaining audio from the original clip is removed.

If the replacement clip is larger than the selection, it is placed in the playlist and trimmed to fit within the length of the original clip.

Fit Clip Using The: Original Selection Length When the playlist selection extends beyond the original clip, the replacement clip (if larger than the original clip) is trimmed to fit within the selection.

Fit Clip Using The: Replacement Clip Length The replacement clip is placed in its entirety, regardless of the length of the original clip or selection.

Sync Points

The placement of clips in Grid and Spot mode can be based on the definition of a clip sync point. Sync points can be added to audio, MIDI, and video clips and also to clip groups. Sync points are used when a specific point within a clip must be aligned to the Grid or to a particular SMPTE or bar/beat location. This capability is especially important when placing music and sound effects for film and video work.

For example, suppose you had an audio clip for a door slam that included the creak of the door closing, the actual slam, and the reverb of the slam. Using a sync point for the slam sound in the clip lets you spot it to a specific time in the session.
To define a clip sync point:

1 Enable Slip mode (see “Edit Modes” on page 599).

2 Do one of the following:
   • With the Selector tool, click at the point in the clip where you want the sync point.
   • Press the Down Arrow key while playing back.

3 Choose Clip > Identify Sync Point. A small down arrow appears at the bottom of the clip, with a vertical, light gray line indicating the location of the sync point.

To change the location of a sync point:

   ▪ With the Selector tool, click at a point in a clip and choose Clip > Identify Sync Point. The new location is identified as the sync point for the clip.

You can also move the location of a sync point by dragging it (see “Dragging Sync Points” on page 906).

Removing Sync Points

To remove a sync point, do one of the following:

   ▪ Select the entire clip and choose Clip > Remove Sync Point.

   ▪ Choose the Time Grabber tool, then Option-click (Mac) or Alt-click (Windows) the sync point to delete it.

Displaying Sync Points

Sync points in audio clips may displayed or hidden.

To disable the display of sync points in audio clips:

   ▪ Deselect View > Clip > Sync Point.

To enable the display of sync points in audio clips:

   ▪ Choose View > Clip > Sync Point.

Dragging Sync Points

You can drag a sync point to another position in the audio clip.

To set the sync point by dragging:

1 If you want the sync point to snap to the current Grid value, enable Grid mode (see “Edit Modes” on page 599).

2 Select the Time Grabber tool.

3 Drag the sync point to a new location.

Scrubbing Sync Points

While viewing an audio waveform can be a good way to set a sync point, a waveform display may not always reveal the desired spot in the audio material. By scrubbing while moving the sync point over an audio waveform, you can listen for the exact location to place the sync point.
To scrub while dragging the sync point:

1. If you want the sync point to snap to the current Grid value when you finish scrubbing, set the Edit mode to Grid (see “Edit Modes” on page 599).

2. Select the Scrubber tool.

3. Drag the sync point to a new location. The sync point scrubs the audio as you move it.

---

**Shift Command**

Use the Shift command to move track material forward or back in time by a specified amount. The Shift command can operate on selections, clips, MIDI notes, MIDI controller data, and automation breakpoints.

**To shift a selection or clip:**

1. With the Selector or Time Grabber tool, select the track material you want to shift. The selected material can reside on multiple tracks.

2. Choose Edit > Shift. In the Shift dialog, select whether the data will be moved Earlier or Later.

3. Click in one of the Timebase fields to specify the amount by which the material will be shifted. Entering a value in one Timebase field automatically updates the others.

---

4. If you want to shift material with greater precision, select the Use Subframes option.

5. Click OK. The material is shifted earlier or later by the specified amount.

If a portion of a clip was selected, new clips are created from the selection and from any material outside of the selection.

The Shift command works the same regardless of the Edit mode. For example, adjacent clips are overlapped in Shuffle mode, the Spot dialog does not appear when in Spot mode, and shifted material does not snap to the Grid when in Grid mode.

---

**Locking Clips**

In many cases you may want to “lock” clips or clip groups to a specific time location to keep them from being moved or otherwise edited inadvertently. Pro Tools provides two different commands for locking clips: Edit locking and Time locking.

**Edit Locking Clips**

If you have a clip or group of clips that you want to protect from being inadvertently edited, you can Edit lock them. Clips that are Edit-locked cannot be edited (such as cutting, deleting, separating, trimming, or adjusting clip gain) or moved to a different time location. Copied edit-locked clips can be pasted to any other track or time location, but the copy will also be Edit-locked at the new time location.

*Edit locking takes precedence over Time locking. You can Edit lock a Time locked clip, but you cannot Time lock an Edit locked clip without unlocking it first.*
To Edit lock (or unlock) a clip:

1. With the Time Grabber, select the clip or clips to Edit lock (or unlock). The clips can reside on multiple tracks.

2. Choose Clip > Edit Lock/Unlock.

When Edit-locked, a small Edit Lock icon appears in the clip and it cannot be moved, deleted, or edited. If you attempt to perform edits on a locked clip, Pro Tools alerts you (see “Allowing Editing of Edit-Locked Clips” on page 908).

In Shuffle mode, Edit-locked clips, and all clips occurring after the locked clip, are not displaced when other neighboring clips are moved.

On tick-based Elastic Audio-enabled tracks, Edit-locked clips conform to tempo changes, but not other Elastic Audio processing (such as Quantize or manual warping) can be applied.

To Time lock (or unlock) a clip:

1. With the Time Grabber, select the clip or clips to Time lock (or unlock). The clips can reside on multiple tracks.

2. Choose Clip > Time Lock/Unlock.

When Time-locked, a small Time Lock icon appears in the clip and the clip cannot be moved, but it can be edited or even deleted.

In Shuffle mode, Time-locked clips, and all clips occurring after the locked clip, are not displaced when other neighboring clips are moved.

On tick-based Elastic Audio-enabled tracks, Time-locked clips conform to tempo changes, but not other Elastic Audio processing (such as Quantize or manual warping) can be applied.

Allowing Editing of Edit-Locked Clips

If you attempt to edit an Edit-locked clip, Pro Tools warns you and prompts you to Cancel or Allow the edit. If you allow an edit that keeps any part of the clip intact, the clip remains locked.
**Muting/Unmuting Clips**

Choosing the Mute/Unmute Clip command mutes playback of a selected clip. Choosing the command a second time unmutes the clip. Clips that are muted become dimmed to indicate their status.

**To mute or unmute a clip or clips:**

1. With the Time Grabber, select the clip or clips you want to mute or unmute. The clips can even reside on multiple tracks.
2. Choose Edit > Mute/Unmute. When muted, clips are dimmed.

**Stripping Silence from Clips**

Strip Silence analyzes audio selections—across multiple tracks—and removes (or extracts) any areas of silence, dividing the selection into smaller clips and removing the silent areas.

You can use Strip Silence to strip (remove) silence from a clip, or instead, extract the audio and keep the silence. Getting rid of silent areas is useful when preparing to compact audio (see “Compacting an Audio File” on page 665). Strip Silence automatically separates the selection into separate clips, which is useful if you want to quantize audio to musical values, or locate sound effects to SMPTE locations.

**Auto-Naming for Strip Silence**

The Rename button in the Strip Silence window opens the Rename Selected Clips dialog, which determines how clips are named when stripping silence. The dialog remembers your previous settings, which can be cleared by clicking the Clear button.

**Rename Selected Clips dialog**

**Name** Specifies the base name for clips created with Strip Silence.

**Number** Specifies the number at which sequential auto-numbering starts.

**Zeros** Specifies the number of zeroes that occur before the appended auto numbers.

**Suffix** Specifies text appended to the end of the name, after the auto numbering.

For example, if you set these naming options to:

- Name = SFX
- Auto Number Start = 23
- Leading Zeros = 1
- Suffix = .Reel1
The names generated for clips created by Strip Silence would be:

- SFX023.Reel1
- SFX024.Reel1
- SFX025.Reel1
- SFX026.Reel1

**Using Strip Silence**

**To strip silence from an audio selection:**

1. Select one or more audio clips.
2. Choose Edit > Strip Silence.

   \[\text{Press Command}+U \text{ (Mac) or Control}+U \text{ (Windows) to open the Strip Silence window.}\]

3. To set the naming scheme for clips created with Strip Silence, click Rename to open the Rename Selected Clips dialog. For details, see “Auto-Naming for Strip Silence” on page 909.

4. In the Strip Silence window, adjust the settings for Strip Threshold and Minimum Strip Duration (Min Strip) until Strip Silence rectangles appear in the selection.

   \[\text{Strip Silence rectangles}\]

   For finer resolution on these controls, press Command (Mac) or Control (Windows) while adjusting them.

5. To retain material before and after the new clips, adjust the settings for Clip Start Pad and Clip End Pad.

6. Once the Strip Silence rectangles encompass the audio that you want to keep, press the Strip button.

   The material defined as silence is removed from the selection and new clips are created, which also appear in the Clips List.

Strip Silence is nondestructive and does not remove audio data from parent audio files. In addition to the Undo command, you can use the Heal Separation command to restore stripped material.

\[\text{Strip Silence works with stereo and multi-channel tracks, and keeps their audio clips phase-coherent.}\]

**To extract audio from an audio selection using Strip Silence:**

1. Make an Edit selection.
2. Choose Edit > Strip Silence.
3. To set the naming scheme for clips created with Strip Silence, click Rename to open the Rename Selected Clips dialog (see “Auto-Naming for Strip Silence” on page 909).
4 In the Strip Silence window, adjust the settings for Strip Threshold and Minimum Strip Duration (Min Strip) until the Strip Silence rectangles appear in the selection.

5 Click the Extract button.

All audio above the designated threshold is deleted and the “silent” portions of the track are left.

To separate clips using Strip Silence:
1 Make an Edit or Timeline selection.
2 Choose Edit > Strip Silence.
3 To set the naming scheme for clips created with Strip Silence, click Rename to open the Rename Selected Clips dialog (see “Auto-Naming for Strip Silence” on page 909).
4 In the Strip Silence window, adjust the settings for Strip Threshold and Minimum Strip Duration (Min Strip) until the Strip Silence rectangles appear in the selection.
5 Click the Separate button.

New clips are created based on the boundaries detected by Strip Silence.

The Strip Silence Window
The Strip Silence window contains the following controls that let you set the parameters by which silence is defined when using Strip Silence.

- **Strip Threshold**: Sets the amplitude threshold (from –96 dB to 0 dB) for Strip Silence. Audio falling below this threshold is considered silence and removed. Audio above the threshold is retained and defined as new clips.
- **Minimum Strip Duration**: Sets the minimum duration (from 0 to 4,000 ms) that the material above the threshold must last to be considered silence. Use this control to avoid countless small clips that may occur within a selection.
- **Clip Start Pad**: Specifies a time value to be added to the beginning of each new clip created with Strip Silence. This is useful for preserving musical material that falls below the threshold, such as the breath before a vocal phrase, or the finger slide before a guitar chord.
- **Clip End Pad**: Specifies a time value to be appended to the end of each new clip created with Strip Silence, thereby preserving the nuances in the decay of the material.
- **Strip**: Clears the detected silence, but leaves the clips containing audio on the track.
- **Extract**: Clears the audio and leaves the silent portions of the track (in other words, an “inverse” strip silence feature that is ideal for generating room tone or ambience to use elsewhere).

Adjusting these controls causes rectangles to temporarily appear in the selection, indicating areas of silence that will be affected by the Strip, Extract, or Separate commands.
**Rename** Opens the Rename Selected Clips dialog (see “Auto-Naming for Strip Silence” on page 909).

**Separate** Separates clips based on the boundaries detected by Strip Silence.

---

### Inserting Silence

The Insert Silence command is a simple and convenient way to insert silence on audio, MIDI, and Instrument tracks. This command lets you make a selection on a track (or tracks) and insert precisely that amount of silence.

*The Insert Silence command also affects markers in any selected Conductor Rulers (such as the Tempo or Meter rulers).*

In Shuffle mode, all data on the track is shuffled later in the track by an amount equal to the selection.

In Grid mode, the Insert Silence command works just like the Clear command.

**Shuffle Mode** When inserting silence on multiple tracks in Shuffle mode, the following conditions apply:

- If any track is displayed as audio or MIDI data, the selected duration of silence is inserted into the audio or MIDI data and all underlying automation data on all selected tracks. All subsequent clips are shuffled by the amount of silence inserted. On MIDI tracks, only notes that are selected from the beginning are affected, so if you have selected the tail of a note and you Insert Silence, the note will remain unchanged.

- If all selected tracks are displayed as automation data, the selected range is cleared of automation data only of the type visible on each track. Clips are not shuffled. Instead, a blank gap appears equal to the length of the selection.

- If all selected tracks are displayed as automation data, press the Control (Mac) or Start key (Windows) while choosing the Insert Silence command to inserts silence on all automation playlists for all selected tracks. Clips are not shuffled.

**Slip Mode** When inserting silence on multiple tracks in Slip mode, the following conditions apply:

- If any track is displayed as audio or MIDI data, the selected range is cleared of audio or MIDI data and all underlying automation data on all selected tracks.

- If all selected tracks are displayed as automation data, silence is inserted only into the automation type visible on each track.

- If all selected tracks are displayed as automation data, press the Control (Mac) or Start key (Windows) while choosing the Insert Silence command to insert silence on all automation playlists for all selected tracks.

**To insert silence into a track:**

1. Make a selection in a track or tracks. The length of the selection determines the duration of the silence inserted.

2. Choose Edit > Insert Silence.

In Shuffle mode, Pro Tools inserts the selected amount of silence. In the process, it splits the clips at the beginning of the insertion point, and moves the new clips later in the track by an amount equal to the length of the selection.
Duplicating Clips

The Duplicate command copies a selection and places it immediately after the end of the selection. Though this is similar to using Copy and Paste, Duplicate is more convenient and faster, particularly when working with data on multiple tracks.

To make more than one copy of a selection, use the Repeat command (see “Repeating Clips” on page 914). You can also loop clips (see “Clip Looping” on page 915).

As with the Copy and Paste commands, certain rules apply when duplicating material on multiple tracks (see “Editing Across Multiple Tracks” on page 598).

**To duplicate a selection or clip:**

1. If working with material that is bar- and beat-based, such as loops, set the Main Time Scale to Bars|Beats.
2. If you want to constrain the selection to the current Grid value, set the Edit mode to Grid.
4. Choose Edit > Duplicate. The material is placed immediately after the selection’s end point.

   - Press Command+D (Mac) or Control+D (Windows) to Duplicate any selected clips.

In Shuffle mode, the duplicated data is placed directly after the end of the selection. Clips occurring after it slide to accommodate the duplicated material. In Slip mode, the duplicated material overlaps any adjacent data.

When using Duplicate (or Repeat) with MIDI notes that were selected with the Time Grabber tool, material is always duplicated one measure later, and is merged with existing track material (instead of replacing it).

Duplicating Audio and Keeping It On The Beat

When using Duplicate (or Repeat) for audio that must fall cleanly on the beat (such as rhythmic loops), it is important that you select the audio material with the Selector tool, or by typing in the start and end points in the Event Edit area. If you select an audio clip with the Time Grabber tool (or by double-clicking it with the Selector tool), the material may drift by several ticks because of sample-rounding.

If, on the other hand, you want to Duplicate (or Repeat) audio that is not bar- and beat-based, set the Time Scale to any format except Bars|Beats. This ensures that the duplicated audio material has the correct number of samples and is accurately placed.

Duplicate and Extend Selection

When working on music using audio loops and MIDI sequences, you may want to duplicate the track content of an Edit selection and include both the original and the duplicate in a new selection. This can be especially useful when working with repeating material in Grid mode with the Main Timebase ruler set to Bars|Beats. For example, you might have a 2 bar audio loop or MIDI sequence that you want to extend to 4 and then 8 bars, and then copy and paste to another location.

**To duplicate and extend the Edit selection:**

1. Make an Edit selection that include audio or MIDI on a track.
2. Do one of the following:
   - Choose Edit > Selection > Duplicate and Extend.
   - Press Command+Option+Control+Shift+D (Mac) or Control+Alt+Start+Shift+D (Windows).
Repeating Clips

The Repeat command is similar to Duplicate, but lets you specify the number of times the selected material is duplicated.

As with the Copy and Paste commands, certain rules apply when repeating material on multiple tracks (see “Editing Across Multiple Tracks” on page 598).

You can repeatedly paste copied data until it completely fills a selection (see “Special Cut, Copy, Paste, and Clear Commands” on page 597).

You can also loop clips (see “Clip Looping” on page 915).

To repeat a selection or clip:

1  If working with material that is bar- and beat-based, such as loops, set the Main Time Scale to Bars|Beats.

2  If you want to constrain the selection to the current Grid value, set the Edit mode to Grid.

3  Make an Edit selection.

4  Choose Edit > Repeat. In the Repeat dialog, enter the number of times you want the material to repeat, then click OK.

The material is placed immediately after the selection’s end point, and duplicated the specified number of times.

In Shuffle mode, the repeated data is placed directly after the end of the selection. Clips occurring after it slide to accommodate the repeated material. In Slip mode, the repeated material overlaps any subsequent data.

Press Option+R (Mac) or Alt+R (Windows) to open the Repeat dialog for any selected clips.
Chapter 41: Clip Loops and Groups

Pro Tools lets you loop clips or a group of clips (called a *clip group*).

**Clip Looping**

Pro Tools lets you loop audio clips, MIDI clips, and clip groups. Looping clips is an easy and powerful way to repeat a single clip on a track or clips across tracks for composing and arranging. Looping clips provides more flexibility than the Repeat and Duplicate commands.

Looped clips repeat the source clip as many times as specified in the Clip Looping dialog, or enough to fill the specified Loop Length (such as 30 seconds or until the next clip on the track). The *source clip* is the original clip selected for looping. *Loop iterations* are all looped clips following the source clip. In cases where a specific number of repetitions has not been indicated, the last loop iteration is truncated to fill to the end of the selection or specified Loop Length.

Once looped, the looped clip can be edited much like a clip group. For example, selecting and moving a looped clip selects and moves the source clip and all its loop iterations together.

Looped clips (all iterations) display a Loop icon in the lower, right corner or each loop iteration.

Looping a clip does not loop any automation associated with the source clip. Use the Copy Special and Paste Special Repeat To Fill Selection commands to copy automation for the source loop to all loop iterations (see “Automation and looped clips” on page 918).
Creating Looped Clips

You can create looped clips using the Loop command or using the Loop Trim tool.

For information on using the Loop Trim tool, see “Loop Trim Tool” on page 617.

To loop a clip:
1. Select an audio or MIDI clip, or clip group.

You can also select clips across tracks for looping.

2. Do one of the following:
   - Choose Clip > Loop.
   - Right-click the clip you want to loop and select Loop.

3. In the Clip Looping dialog, do one of the following:
   - Select the Number of Loops option and enter the number of times to loop the clip.
   - Select the Loop Length option and enter the duration according to the main timebase. If the duration is not an exact multiple of the source loop’s duration, the last loop iteration will be truncated.
   - Select the Loop Until End of Session or Next Clip option. The looped clip will be repeated until the end of the session, or until the next clip on the track. If necessary, the last loop iteration will be truncated to fit.

4. To add a crossfade at the loop point, select the Enable Crossfade option. To edit the loop crossfade, do the following:
   - Click the Settings button.
   - Configure the Loop Crossfades.
   - Click OK.

5. In the Clip Looping dialog, click OK.

For information on working with crossfades, see Chapter 31, “Fades and Crossfades.”
Unlooping Clips

To unloop a looped clip:

1. Select the looped clip.
2. Do one of the following:
   - Choose Clip > Unloop.
   - Right-click the clip you want to unloop and select Unloop.
3. Do one of the following:
   - Click Remove to unloop and remove all loop iterations except the first full loop iteration (source clip).
   - Click Flatten to unloop and create individual clips from each loop iteration.

Clip Ungroup functions on loops the same as using the Unloop command and choosing Flatten.

To unloop and ungroup a selection down to its individual clips:

1. Select a looped clip that contains one or more clip groups.
2. Choose Clip > Ungroup All.

To select a looped clip as a group (all loop iterations), do one of the following:

- With the Grabber tool or Smart Tool, single-click the looped clip.
- With the Selector tool, double-click the looped clip.

The source clip and all its loop iterations are selected.

Editing Looped Clips

Looped clips can be edited as a group (all loop iterations together) or as individual clips (each loop iteration). For example, selecting a looped clip with the Grabber tool selects the entire loop (the source clip and all its loop iterations), but clicking the Loop icon of one of the loop iterations selects only that one iteration.

Moving a looped clip moves the source clip and all its loop iterations together as a group. Loop iterations cannot be moved independently of their source clip. If you move or paste another shorter clip over a looped clip the loop is continued after the new clip. The parts of a separated looped clip can be adjusted independently.

Manually warping any part of a looped clip in Warp view separates only that iteration from the looped clip.

Unlooping and Flattening Looped Clips with Separate Clips Menu Commands

The Separate Clips commands (At Selection, On Grid, and At Transients) automatically unloop and flatten looped clips before separating.
To select an individual source clip or loop iteration, do one of the following:

- With the Grabber tool or Smart Tool, single-click the Loop icon of the source clip or loop iteration.
- With the Selector tool, single click the Loop icon and drag to the left until the clip is selected.

If the source clip is extended to the left by using the Trim tool to change the total length of the looped clip, the source clip is moved earlier in the Timeline and loop iterations fill in up to the point where the last original loop iteration ended. If the trim to the left is part of the source clip’s length, the source clip is not moved and a partial loop iteration is created to the left of the source clip. This is a powerful feature that lets you make quick changes to your arrangement by using partial loops as upbeats, or by extending looped sound effects or ambiance earlier in a film score.

To trim a looped clip to the selection:

1. Use the Selector tool to make an Edit selection including some or all of the looped clip.
2. Choose Edit > Trim Clip and one of the Trim Clip commands (To Selection, To Fill Selection, Start to Fill Selection, or End to Fill Selection).

Automating and Looped Clips

Looping an audio clip does not loop any automation associated with the source clip. This lets you apply automation across an entire looped clip. For example, you may want to have a long volume fade across part or all of a looped clip that is independent of any one single loop iteration.

You can also repeat automation on each loop iteration. For looped audio clips, use the Copy Special and Paste Special Repeat to Fill Selection commands to copy and paste any or all automation data from the source clip to some or all of its loop iterations.
To copy and paste automation from the source clip to loop iterations:

1. Select the source clip.
2. Choose Edit > Copy Special and one of the Copy Special commands (All Automation, Pan Automation, or Plug-In Automation), depending on what automation you want to copy.
3. Select the entire looped clip.
4. Choose Edit > Paste Special > Repeat to Fill Selection.

Clip Groups

A clip group is a collection of any combination of audio and MIDI clips that looks and acts like a single clip. Clip groups are essentially containers holding one or more clips. Clip groups can be created on single or multiple adjacent audio, MIDI, and Instrument tracks. Clip groups let you “nest” multiple clips into “macro” clips for groove and tempo manipulation, editing, and arranging.

Clip groups can be placed on tracks alongside standard clips, and edited using many of the same editing techniques as regular clips. Certain edits to a clip group will apply to all clips contained by the clip group, such as Cut or Delete. Other edits only apply to the boundaries of the clip group and do not affect the underlining clips, such as Trim.

Each clip group is saved with the session as a Clip Group file (.rgrp). Clip group files can be exported from and imported into different Pro Tools sessions.

Clip groups are especially useful for:

- Grouping tick-based audio clips that have been separated into many small clips, such as with individual hits of a drum pattern. Many such small clips can easily be created with Beat Detective or the Separate Clip At Transients command, or imported as REX or ACID files.

- Grouping parts and sections of your session to facilitate composition and arranging. For example, grouping the clips of a brass section during the chorus to copy it to the next chorus.

Clip groups are completely independent of and unique from Mix and Edit Groups.

Editing Elastic Properties is disallowed for clip groups.

Clip groups are not supported on audio tracks set to Playlists view. Changing an audio track to Playlist View automatically ungroups any clip groups on the track.
Creating Clip Groups

**To create a clip group:**

1. Select one or more clips on one or more tracks. (For more information on multitrack clip groups, see “Multitrack Clip Groups” on page 921).

   ![Selecting clips to be grouped on a single audio track](image)

   The size of the selection determines the size of the clip group. The selection can start and end on any clip boundary, empty space, or even in the middle of a clip. Selections starting or ending within a clip will separate the clip at the selection boundary when you create a clip group. Clip groups created from object-based selections include all selected and unselected clips between the first and last selected clip on the track.

2. Do one of the following:
   - Choose Clip > Group.
   - Right-click the Edit selection and choose Group.

   ![Press Command+Option+G (Mac) or Control+Alt+G (Windows) to group selected clips.](image)

   **Tip:** Press Command+Option+G (Mac) or Control+Alt+G (Windows) to group selected clips.

   ![The Group and Ungroup Clip menu commands apply to any Edit selection regardless of the current Track View.](image)

   **Tip:** The Group and Ungroup Clip menu commands apply to any Edit selection regardless of the current Track View.

   ![Clip groups can be created from empty selections. This can be useful when working in Shuffle mode to preserve the gaps between clips.](image)

   **Tip:** Clip groups can be created from empty selections. This can be useful when working in Shuffle mode to preserve the gaps between clips.

The clip group appears as one clip with the clip groups icon in the lower left corner. Clip groups also appear in the Clips List.

![Clip Group icons on an audio track and in the Clips List](image)

### Clip Group Timebase Format

Clip groups are created in the same timebase format (samples or ticks) as the tracks on which they are created. Multitrack clip groups can include both sample-based and tick-based tracks.

![Audio Clip Group icon on an audio track](image)

![MIDI Clip Group icon on a MIDI track](image)
Ungrouping Clips

**To ungroup a clip group:**

1. Select a clip group.
2. Do one of the following:
   - Choose Clip > Ungroup.
   - Right-click the Edit selection and choose Ungroup.

   Press Command+Option+U (Mac) or Control+Alt+U (Windows) to ungroup selected clip groups.

The clip group disappears, revealing all underlying clips and any nested clip groups. When there are multiple nested clip groups, the Ungroup command will ungroup the front-most top-layer clip group only, preserving any underlying clip groups.

**To ungroup a clip group (and include all of its nested clip groups):**

1. Select a clip group.
2. Choose Clip > Ungroup All.

Regrouping Clips

The Regroup menu command undoes the last Ungroup command and regroups all the individual clips as a clip group. This lets you ungroup a grouped clip, edit its underlying clips, and regroup it to continue working on higher-level composition and arranging.

**To regroup a clip group:**

1. Select any clip from the ungrouped clip group.
2. Choose Clip > Regroup.

   Press Command+Option+R (Mac) or Control+Alt+R (Windows) to regroup selected clips that were formally part of a clip group.

If you used the Ungroup All command, the Regroup command recreates all previous nested clip groups.

3. If you regrouped an ungrouped clip group that was used more than once in the session, do one of the following when the Change All dialog opens.
   - Choose Modify to apply your changes to all other instances of the same clip group.
   - Choose Copy to create a copy and apply your changes only to the copied clip group.

Multitrack Clip Groups

Multitrack clip groups (clip groups created across multiple tracks) are useful for grouping parts (such as multi-miked drum tracks), and for composing and arranging. Multitrack clip groups can be created across any combination of audio, MIDI, and Instrument tracks, and can include either or both tick-based or sample-based tracks.

Multitrack clip groups work much like single-track clip groups. Multitrack clip groups appear as a single object across adjacent tracks.

**To create a multitrack clip group:**

1. Select clips across multiple adjacent tracks.

Selecting clips to be grouped across multiple tracks
2 Choose Clip > Group.

**Separated Multitrack Clip Groups**

You can insert, move, hide, or delete tracks in multitrack clip groups, but it may break the clip group. A separated clip group displays a break in the Clip Group icon. Separated clip groups will continue to function as a single clip group, but the separated icon indicates that the clip group displayed is somehow incomplete or separated across nonadjacent tracks.

A clip group is separated when you do any of the following:

- Insert a track within a multitrack clip group.
- Move a track that is part of a multitrack clip group so that it is no longer adjacent with the other tracks of the clip group.
- Hide a track that is part of a multitrack clip group.
- Delete a track that is part of a multitrack clip group.
- Change the tempo of a mixed sample-based and tick-based clip group.
- Record into a clip group.
- Change playlists on a track that is part of a multitrack clip group.

**Multitrack clip groups create nested clip groups of multiple clips by track before grouping them across tracks.**

**The Regroup command supports multitrack clip groups.**

---

**Clip Group icon**

**Mixed Clip Group icon (for a multitrack clip group of sample- and tick-based audio, and tick-based MIDI)**

**Separated Clip Group icon**
• Change to Playlists view.
• Apply manual warping in Warp view.

There may be situations where you want separated clip groups. For example, if you use the same accompaniment on verses one and two of a song, you can group the parts of verse one and copy them as a clip group for verse two, but still have a continuous vocal track in the middle of those clip groups.

👉 If you want to delete a track and keep the clip group intact, first ungroup the clip group, then delete track, and then Regroup the clip group. The clip group will be recreated intact, but without the deleted track.

---

**Clip Groups on Tick-Based Tracks**

When changing tempos, clip groups on tick-based tracks adjust their length by adjusting the position of all enclosed clips accordingly. This can be useful for arranging rhythmic material and for playing back clip groups imported from REX and ACID files.

---

**Changing Clip Group Timebase**

The timebase format of a clip group can be changed by:
• Changing the track’s timebase.
• Dragging the clip group to a track with a different timebase.

Changing the timebase creates a copy of the original clip group. Both clip groups (the original and the copy) appear in the Clips List, but they have different timebases.

**Converting Samples to Ticks**

When dragging a clip group from a sample-based track to a tick-based track, the length of the clip group does not change. This is because clip groups are converted from samples to ticks after they are moved into tick-based tracks. The length of the clip group only changes with subsequent tempo changes. If appropriate, change the local tempo on the tick-based track to match the tempo of the sample-based clip group before moving a sample-based clip group to a tick-based track.

**Converting Ticks to Samples**

When dragging a clip group from a tick-based track to a sample-based track, the length of the clip group does not change unless it is moved to another time location with a different tempo. This is because clip groups are converted from ticks to samples after they are moved into the sample-based tracks.

---

*A clip group on a tick-based audio track at 120 BPM and at 160 BPM*
Multitrack Clip Groups with Sample- and Tick-Based Tracks

Multitrack clip groups can include both sample-based and tick-based tracks. However, changing the tempo separates the clip group between sample-based tracks and tick-based tracks.

Editing Clip Groups

Clip groups are edited in much the same way as regular clips: They can be named, moved, cut, copied, pasted, trimmed, muted, locked, and so on. However, there are a few significant differences between editing regular clips and clip groups.

Editing MIDI Clip Groups

If a MIDI clip within a clip group is modified in any way, a new clip copy is created and placed over the clip group. For example, if you record, draw in a new note, edit MIDI controller data, or quantize a Timeline selection, a new clip is created over the clip group.

Editing Audio Clip Groups

Certain audio editing commands create new clips over clip groups. To use these commands and maintain the clip group, ungroup the clip group, perform the edit, and then regroup the clip group.

The following edit commands create new clips over clip groups:

- AudioSuite processing of a grouped clip results in a new clip over the clip group.
- Consolidating a selection of a grouped clip creates a new audio file and clip over the clip group.
- Recording into a clip group creates a new audio file and clip over the clip group.
- Pencil tool waveform redraw results in a new clip over the clip group.

Tabbing to Transients and Clip Boundaries

With Tab to Transients enabled, the Tab key moves the Location Cursor to transients and clip boundaries within a clip group.

With Tab to Transients disabled, the Tab key moves the Location Cursor to clip group boundaries only (and the sync point, if present).

For more information, see “Tabbing to Transients” on page 641.
Trimming Clip Groups

Trimming clip groups with the Standard Trim tool works the same way as trimming regular clips, regardless of whether you are trimming a single-track clip group or a multitrack clip group.

Trimming a clip group does not trim the underlying clips, but rather trims the clip group boundaries. All underlying clips retain their original length and location. This is true for all underlying audio and MIDI clips, and nested clip groups. If you trim the clip group shorter, underlying clips may not be heard on playback because they are outside the clip boundaries of the trimmed clip group.

When trimming clip groups with the TC/E Trim tool, it applies only to audio or MIDI clips, depending on which clip type in the group you trim, and creates a new clip over the clip group.

If you ungroup clips after trimming a clip group in (shorter), audio clips falling outside of the bounds of the current clip group are trimmed to fit the clip group boundary or removed.

Recording

When recording audio or MIDI, new clips are created over (in front) of clip groups instead of being included in the clip group. To record into a clip group, first ungroup the clip group, then record, and then regroup the clip group. The clip group will be recreated intact with the newly recorded material.

Fades and Crossfades on Clip Groups

Clip groups can have fades and crossfades just like regular clips. Fades only apply to audio clips. In addition to crossfading between clip groups, you can also crossfade between clip groups and regular audio clips.
Clip Groups and Clip Gain

Clip gain settings for individual clips are preserved in clip groups. Additionally, you can adjust the clip gain settings for clip groups. Clip gain editing on clip groups behaves just like individual clip gain editing (see “Clip Gain” on page 941).

To adjust the clip gain settings for individual clips within a clip group, the clips must first be ungrouped, edited, and then regrouped.

Clip gain settings are preserved when clip groups are exported. Clip groups can then be imported into other sessions with the same clip gain settings.

Importing and Exporting Clip Group Files

Pro Tools can export and import clip groups as clip group files (.cgrp) to do any of the following:

• Separate clip group metadata from audio files to avoid unnecessary file copy operations when exporting audio clip groups composed from multiple source files
• Export MIDI data as part of a clip group
• Create multitrack loops

Clip groups created in Pro Tools 10 and higher (.cgrp) cannot be imported into lower versions of Pro Tools, but region groups (.rgp) created in lower versions of Pro Tools can be imported into Pro Tools 10 and higher.

Clip group files store the following metadata:

• References to all audio files within the clip group
• Clip names and relative location in tracks
• Embedded fades and crossfades
• Clip gain settings for the clip groups as well as for individual clips within the group
• Clip group names and format (single or multitrack)
• All MIDI data present in the clip group (such as notes, controllers, Sysex, and so on)
• Track names
• Elastic Audio Warp markers and TCE factor
• Clip timebase (samples or ticks)
• Sync points
• Loops
• Tempo map

Clip group files do not store the following:

• Automation
• Plug-ins
• Track routing
• Meter map
• Clips List information

For more information, see “Importing and Exporting Clip Group Files” on page 452.
Part VIII: Processing
Chapter 42: AudioSuite Processing

AudioSuite plug-ins are used to render processing and modify audio files on disk. AudioSuite processing applies non-real-time, or rendered, audio processing to selected audio clips in your Pro Tools session. Depending on how you configure an AudioSuite plug-in, it will either alter the original source audio file or create an entirely new audio source file.

For information on individual AudioSuite plug-ins included with Pro Tools, see the Audio Plug-Ins Guide.

AudioSuite Menu

AudioSuite plug-ins are accessed through the AudioSuite menu. Plug-ins can be organized in the AudioSuite menu in Pro Tools by Flat List (with plug-ins in alphabetical order), Category, Manufacturer, or Category and Manufacturer.

For more information, see “Plug-In Menu Organization” on page 1099.

To open the AudioSuite Plug-In window:

1. Make an Edit selection that includes the audio clip, or clips, you want to process.

2. From the AudioSuite menu, select the plug-in you want.

AudioSuite Window

When you select a plug-in from the AudioSuite menu, the AudioSuite window appears. From this floating window you can access and edit the controls for the selected AudioSuite plug-in.

AudioSuite window, EQ III 1-Band shown
AudioSuite Window Header

The AudioSuite Window header provides controls for changing AudioSuite plug-ins and setting presets, and how AudioSuite processing will be applied.

AudioSuite Plug-In Selector

From this menu you can select any AudioSuite plug-in installed in your Plug-Ins folder. Plug-Ins are listed in the Plug-In selector pop-up menu according to the Organize Plug-Ins Menu By setting in the Display Preferences page.

Selection Reference

This menu aims the selected process at either clips selected in an audio track or playlist, or at clips selected in the Clips List.

When you select a clip on-screen (in either a track/playlist or the Clips List) Pro Tools normally selects both occurrences of the clip. Since you may not want to process both, this menu provides a convenient means of limiting the AudioSuite process to clips selected in one or the other.

AudioSuite Processing Clip Groups in the Clip List

AudioSuite plug-ins process Clip Groups in the Clips List with certain limitations. With audio files, AudioSuite processes are applied to all copies of a unique audio file in your session when the Clips List option and the Use in Playlist option are selected. However, when a Clip Group is selected for Audio Suite processing in the Clips List, Pro Tools does not recognize the Clip Group as au-
dio. This is because a Clip Group is not treated as audio until it is actually used in a track. To apply AudioSuite processing to a Clip Group in the Clips List, first ungroup the Clip Group, and then re-group it after processing.

**To apply an AudioSuite process to all copies of a Clip Group in a session at once, do the following:**

1. Select the Clip Group to be processed.
2. From the Clip menu, select Ungroup All. All elements of the group will remain selected.
3. Perform the AudioSuite processing.
4. From the Clip menu, select Regroup.

When prompted, choose Modify to apply the AudioSuite process to all copies of the Clip Group in the session, or Copy to apply it only to the selected Clip Group.

**Use In Playlist Button**

This button determines whether AudioSuite processing will replace *all instances* of the selected clips everywhere in the session, or *only* the occurrences of the clips that are currently selected.

**Use In Playlist Off** When Use in Playlist is disabled, a new, processed version of the selected clip will be added to the Clips List. No original clips will be replaced or overwritten anywhere in the session.

**Use In Playlist On, Reference = Clips List** When Use in Playlist is enabled and the Selection Reference pop-up menu is set to Clips List, all copies of the selected clip will be replaced everywhere in the session.

**Use In Playlist On, Reference = Playlist** When Use in Playlist is enabled and the Selection Reference is set to Playlist, only clips selected in tracks in the Edit window will be replaced. If the session includes other copies of the clip used in other playlists, those copies of the original, unprocessed clip will not be replaced.

**File Mode Selector**

This menu lets you select whether or not the AudioSuite plug-in will process the selected audio destructively or nondestructively, and how the original files will be modified.

**File Mode pop-up menu (Invert plug-in shown)**

There are three File mode options:

**Overwrite Files** Processes the selected clips destructively, overwriting the original audio. Not all AudioSuite plug-ins can be used destructively.

**Create Individual Files** Processes the selected clips nondestructively, creating a new audio file for each clip. The new audio files are added to the session, leaving the original source audio files in the Clips List unchanged. (Whether the processed audio is added to the current playlist or only to the Clips List, is determined by the Selection Reference setting.)
Create Continuous File Processes the selected clips nondestructively and creates a new audio file consisting of the selected clips consolidated into a single, unbroken clip. This mode is particularly useful if you are assembling a composite track from multiple takes. This mode is not available when the Selection Reference is set to Clips List.

The Create Continuous File option is not available with some time domain plug-ins. To achieve a similar result, use the Duplicate plug-in to consolidate clips processed with these plug-ins.

Process Mode Selector
If you have made a selection that includes multiple clips, this pop-up menu lets you specify whether AudioSuite processing is performed on a clip-by-clip, or entire-selection basis.

Clip by Clip Analyzes each clip in a selection individually, rather than over the entire multi-clip selection as a whole.

Entire Selection Uses the entire selection for analysis. All clips will be analyzed and processed relative to the entire selection.

AudioSuite Plug-In Preset Controls
Most AudioSuite plug-ins let you load and save presets (plug-in settings files). However, some AudioSuite plug-ins, such as DC Offset Removal or Duplicate, do not provide Preset controls since they have no parameter controls.

For more information about plug-in presets, see “Plug-In Presets” on page 1109.

Plug-In Selector Lets you select any AudioSuite plug-in installed on your system.

Plug-In Settings Menu Lets you copy, paste, save, and import plug-in presets.

Plug-In Librarian Menu Recalls settings files (presets) saved in the plug-in’s root settings folder or in the current session’s Settings folder.

Next (+) and Previous (–) Setting Buttons Lets you select the next or previous plug-in setting from the Plug-In Librarian menu.

You will lose the current plug-in settings if they are not saved before you use the Next and Previous Setting buttons. Always save your plug-ins settings as presets using the Plug-In Settings menu.
Plug-Ins Settings Select Button Accesses the Plug-In Settings dialog, which lists the presets for the current plug-in. From this list, you can select a new preset, or audition a series of presets.

Compare Toggles between the original saved plug-in preset and any changes you have made to it so you can compare them.

Target Button
Pro Tools lets you view multiple AudioSuite plug-in windows at the same time. The AudioSuite plug-in window provides a Target button. Untargeted plug-in windows remain open, while the targeted plug-in window can switch between different AudioSuite plug-ins and receive keyboard input.

To target or untarget AudioSuite plug-in windows:
- Click the Target button in the AudioSuite plug-in window so that it is lit (targeted) or unlit (untargeted).

Other AudioSuite Controls
In addition to the standard AudioSuite controls that are common to all AudioSuite plug-ins, there are a number of special-purpose controls found only on certain plug-ins:

Key Input Selector
Selects a track/bus to be used to trigger processing. In order to use this feature, the key input source audio must occur at the same time as the target audio. Side-chain input is monophonic. See “Side-Chain Input” on page 1107.

Channel Mode Button
The Channel Mode button lets you process contiguous channels within a selected clip as though they were mono or stereo tracks (and in some cases greater-than-stereo tracks), regardless of the type of tracks they occupy.

Mono Mode Processes each contiguous channel within a selected clip as a separate mono track. For example, a clip comprised of six mono tracks would be processed as six mono tracks.

Stereo Mode Processes each contiguous pair of channels within a selected clip as a stereo track. When applied to an odd number of channels, the plug-in processes the last odd, unpaired channel as mono, using the left channel settings of the stereo plug-in. If you want the last track to be processed in stereo, you must select an additional track to pair it with—an empty one if necessary.

For example, a clip comprised of two mono tracks would be processed as a stereo track, with the first mono track processed as the left channel and the second mono track processed as the right channel.

Multi Mode Processes each set of three or more contiguous channels within a selected clip as a multichannel greater-than-stereo track, with the number of selected channels determining the type of track. For example, five contiguously-selected channels would be processed as a 5.0 track, while seven contiguously-selected channels will be processed as a 7.1 track.

⚠️ Multi mode is available only for certain plug-ins, such as Dynamics III.

⚠️ Side-chain inputs for plug-ins have no effect on AudioSuite processes when the Selection Reference is set to Clips List.
AudioSuite Window Footer

The AudioSuite Window footer provides controls for previewing and applying AudioSuite processing.

Preview Button

The Preview button in the AudioSuite window lets you audition the effect of a plug-in before you process the audio. By adjusting the plug-in controls while you listen to this audio preview, you can fine-tune the effect. Not all AudioSuite plug-ins support previewing.

The Preview function routes audio to the specific outputs selected for the Audition Path setting in the Outputs page of the I/O Setup dialog. Make sure you have configured this option correctly for your system or you may not be able to hear previewed audio.

Before you preview AudioSuite processing, be aware that:

- The performance of the Preview function depends on the speed of your CPU. Faster computers preview AudioSuite effects better than slower computers.

- Regardless of how many tracks and clips are currently selected, the Preview button will audition only the first selected stereo track or the first selected pair of mono tracks.

- In Mono mode, only the first channel of any selected multichannel clip will be previewed.

- If you are processing using Clip-by-Clip mode, the Preview function will preview only the first clip within a multi-clip selection. To hear all selected clips, temporarily select Create Continuous File from the File Mode menu before previewing.

Preview Volume Control

The Preview Volume control in the AudioSuite window lets you adjust the volume for previewing AudioSuite processing.

To adjust the volume for previewing AudioSuite processing:

1. Click the Preview Volume control.
2. In the resulting pop-up fader, drag up to increase the preview volume or drag down to decrease the preview volume.

Preview Volume Level Meters

The Preview Volume Level meters display the levels for previewed AudioSuite processing. This can help you watch for clipping in the processed signal.

Bypass Button

When Bypass is enabled in the AudioSuite window, the selected audio is auditioned without AudioSuite processing. The Bypass button applies only to previewing. It does not affect actual AudioSuite processing.
Reverse Button

Pro Tools provides a Reverse button in the AudioSuite plug-in window footer for Reverb and Delay plug-ins. This lets you easily render reverse delay and reverb effects with a single click. Clicking the Reverse button provides three processes in one:

• First, it reverses the Edit selection.
• Then, it processes the reversed Edit selection with the current plug-in settings.
• Finally, it reverses the processed Edit selection.

Whole File Button

When the Whole File button is enabled in the AudioSuite window, the selected audio is rendered as a new clip whose duration exactly matches the selection. However, the clip can be trimmed out as far as the whole file. This option is not available in Create Continuous File mode or when rendering with Entire Selection mode combined with Create Individual Files mode.

Handle Length

The Handle Length field lets you set the Handle Length for rendering from 0.00 to 60.00 seconds. This means that you trim clips out past the rendered selection after processing up to the set Handle Length. For more information, see “AudioSuite Handles” on page 937.

Render Button

Clicking the Render button in the AudioSuite window begins AudioSuite processing of the selected audio. Processing can occur during playback (though it may take slightly longer). Processed files are auto-named with the clip or audio file’s name and include an acronym for the chosen AudioSuite process.

New files are written to the hard disk specified for that track in the Disk Allocation dialog, or to the same drive as the original file if the clip is not currently on a track. See “Automatic File Naming of AudioSuite-Processed Audio” on page 936.

Multichannel Processing

Most AudioSuite plug-ins can process up to 48 channels of audio simultaneously.

⚠️ When processing multiple clips of different formats (mono and multichannel surround, for example), all channels will be processed according to the channel format of the AudioSuite plug-in. Mono AudioSuite plug-ins can process stereo clips and stereo AudioSuite plug-ins can process mono clips.

Undoing AudioSuite Processing

If you have processed an audio selection nondestructively, the Undo and Redo commands let you undo the selected AudioSuite process. You can undo or redo an AudioSuite process during audio playback.

⚠️ Undo is not available when a plug-in is configured for destructive editing since the process has already overwritten the source audio file.
Automatic File Naming of AudioSuite-Processed Audio

When new audio files are created as a result of AudioSuite processing, Pro Tools will auto-name these files according to the type of plug-in used. The name of the clip determines the prefix, while the type of AudioSuite plug-in determines the suffix.

**Automatic file naming follows these rules:**

- New clips are named beginning with the clip name, followed by an abbreviation of the current AudioSuite process, followed by standard Pro Tools file and clip numbering.
- If a plug-in’s File Mode is set to Overwrite Files, the original clip’s name will not be changed.
- If a plug-in’s File Mode is set to Create Individual Files, the resulting clips will have an abbreviated version of the plug-in name appended to them.

---

Using AudioSuite Plug-Ins

AudioSuite plug-ins can be applied to whole clips, partial clips, or selections that are made up of whole and partial clips across one or more tracks.

When audio selected in the Edit window includes partial clips, the clips will automatically be split into two or more clips when they are processed. Processing is applied only to the selection, leaving other clips unchanged.

**Processing a locked clip will cause the clip to become unlocked, and processing a muted clip will cause it to become unmuted.**

Only audio files on locally connected hard drives can be processed with AudioSuite plug-ins. You cannot process audio files on remote hard drives over a network (unless it is an Avid Unity network).

To process audio with an AudioSuite plug-in:

1. Do one of the following:
   - Make an Edit selection of the audio you want to process.
   - Select audio clips in the Clips List that you want to process.

2. Choose an AudioSuite plug-in from the AudioSuite menu.

3. Adjust the plug-in controls for the effect you want. These settings determine how the file is processed and what effect the processing has on the original clips.
   - To process the selected clip only in the track in which it appears, select Playlist for the Selection Reference. Alternatively, if you want to process the selected clip in the Clips List only, select Clips List.
   - If you want to process and update every occurrence of the selected clip throughout your session, enable the Use In Playlist button (and also select Clips List as the Selection Reference). Alternatively, if you do not want to update every occurrence of the selected clip, deselect the Use In Playlist button.
   - To configure the plug-in for destructive processing, select Overwrite Files for the File Mode. This will overwrite and permanently modify the original source audio files.
   - Alternatively, to configure the plug-in for non-destructive processing, select Create Individual Files for the File Mode. This will create new audio files that have been processed with the AudioSuite plug-in settings and leave the original source audio files untouched.
   - If you have selected multiple clips for processing and want to create a new file that connects and consolidates all of these clips together, select Create Continuous File for the File Mode.
4 Click the Preview button to audition the AudioSuite processing of the selected material.

5 Make any further adjustments to the plug-in controls if necessary.

6 When you are satisfied with the results, click the Render button.

The selected audio is processed according to the specified settings. Pro Tools appends text to the clip name indicating the AudioSuite process that has been applied. Any new audio files appear in the Clips List.

Selecting Tracks for AudioSuite Processing

Because AudioSuite processes are performed on the specific clips that you select, it is important that you select only those clips, or parts of clips, you actually want to process.

⚠️ When processing a single audio channel with an AudioSuite plug-in, make sure that the plug-in is set to Mono mode, if available.

Selecting Tracks for Delay or Reverb Processing

Because some AudioSuite effects such as delay and reverb add additional material to the end of the selected audio, it is important that you make a selection that is longer than the original source material so that the plug-in can write it to the audio file. If you select only the original material, without leaving additional space at the end, any reverb decay or delay that occurs after the end of the clip will be cut off.

To compensate for this, place the clip in a track and select the audio plus an amount of blank space at the end of the clip equal to the amount of delay or reverb decay that you have added in the plug-in. The plug-in will then have space at the end of the clip in which to write the final delay or decay. If you select more time than needed, you can trim it after applying AudioSuite processing.

AudioSuite Handles

Pro Tools lets you render clips with AudioSuite plug-ins and include “handles” beyond the current edit selection from 0.00 to 60.00 seconds, or even the whole file referenced by the clip. This means that you trim clips out past the rendered selection after processing.

To render a clip with AudioSuite handles:

1 Make the audio selection that you want to render.

2 Select the AudioSuite plug-in you want to use from the AudioSuite menu.

3 Adjust the AudioSuite plug-in options and settings.

4 Do one of the following:
   - In the Handle Length field, enter a value for the Handle Length (0.00 to 60.00 seconds). The default Handle Length can be set in the Preferences dialog.

Handle Length field in the AudioSuite plug-in window
• Select the Whole File option to render the whole file. Note that only the current edit selection will appear in the Timeline.

5 Click Render.

The selection is rendered as a new clip whose duration exactly matches the selection. However, the clip can be trimmed out as far as the specified Handle Length.

AudioSuite Default Handle Length Preferences

Pro Tools provides two preferences for setting the default AudioSuite Handle Length.

To set the default AudioSuite Handle Length:

1 Choose Setup > Preferences.

2 Click the Processing tab.

3 In the AudioSuite section, select one of the following options:

• Whole File—by default, renders the whole file referenced by the selection.
• Length—by default, renders the selection plus any additional available audio up to the specified Handle Length (0.00 to 60.00 seconds)

4 Click OK.

Using AudioSuite Plug-Ins in Stereo

Some AudioSuite plug-ins can be used in either mono or stereo. If you plan to use them in stereo, consider the following:

• To process a mono track and obtain a stereo result, select the track or clip plus an empty track or clip. Then set the plug-in to Stereo mode and select the Sum Inputs button (if present) to center the dry signal. When you process the audio, the result will be two tracks or clips that represent the right and left channels of the processed audio. You should then pan these tracks hard right and hard left in your mix.

• If you set a plug-in to Stereo mode, then select an odd number of Pro Tools tracks for processing (as opposed to an even number), the plug-in will process the selected tracks in pairs, in stereo. However, the last odd, unpaired track will be processed as mono, using the left channel settings of the stereo plug-in. If you want the last track to be processed in stereo, you must select an additional track to pair it with—an empty one if necessary.

For more information, see “Channel Mode Button” on page 933.
Conditions for AudioSuite Rendering with Handles, Fades, Clip Gain, and Metadata

Most AudioSuite plug-ins provide several options for rendering clips, but only certain settings let you apply AudioSuite handles. For example, AudioSuite Handles are not available with Entire Selection mode (since the point of this option is to render the whole selection only). Fades and crossfades, and clip gain settings are preserved or rendered depending on the File mode and AudioSuite Rendering mode settings. Additionally, clip metadata can be preserved for rendered clips under certain conditions. The following conditions apply.

Handle creation, and Fade, Clip Gain, and Metadata preservation criteria for AudioSuite rendering

<table>
<thead>
<tr>
<th>File Mode</th>
<th>Rendering Mode</th>
<th>Handle Behavior</th>
<th>Whole File</th>
<th>Fades</th>
<th>Clip Gain</th>
<th>Metadata</th>
</tr>
</thead>
<tbody>
<tr>
<td>Overwrite File</td>
<td>Clip By Clip</td>
<td>No Handles</td>
<td>Unavailable</td>
<td>Preserved</td>
<td>Preserved</td>
<td>Preserved</td>
</tr>
<tr>
<td>Overwrite File</td>
<td>Entire Selection</td>
<td>No Handles</td>
<td>Unavailable</td>
<td>Rendered</td>
<td>Rendered</td>
<td>Preserved</td>
</tr>
<tr>
<td>Individual Files</td>
<td>Clip By Clip</td>
<td>Handles created</td>
<td>Available</td>
<td>Preserved</td>
<td>Preserved</td>
<td>Preserved</td>
</tr>
<tr>
<td>Individual Files</td>
<td>Entire Selection</td>
<td>No Handles</td>
<td>Unavailable</td>
<td>Rendered</td>
<td>Rendered</td>
<td>Preserved</td>
</tr>
<tr>
<td>Continuous File</td>
<td>Clip By Clip</td>
<td>Handles created at the beginning and end of the new continuous file</td>
<td>Unavailable</td>
<td>Rendered</td>
<td>Rendered</td>
<td>Not preserved</td>
</tr>
<tr>
<td>Continuous File</td>
<td>Entire Selection</td>
<td>Handles created at the beginning and end of the new continuous file</td>
<td>Unavailable</td>
<td>Rendered</td>
<td>Rendered</td>
<td>Not preserved</td>
</tr>
</tbody>
</table>

⚠️ Some plug-ins that rely on the Edit selection for processing (including plug-ins that require an analysis pass) may not work as expected when using handles. In this case, it is recommended that the handle length be set to zero.

⚠️ Destructive recording and Destructive Punch recording are not supported with AudioSuite rendered clips with handles.
Chapter 43: Clip Gain and Clip Effects

Clip Gain

Pro Tools provides clip-based gain for quick and easy gain matching of clips (formerly called regions in Pro Tools) from different sources in a Pro Tools session. Clip-based gain is applied pre-mixer (pre-fader and before any plug-in processing). This is especially useful when working with field recordings and sample libraries in post-production sessions.

By adjusting the clip gain for individual clips on a single track, you can match their relative gain levels so that you do not have to execute complex track volume automation to compensate.

Static and Dynamic Clip Gain

You can have either static or dynamic clip gain settings for a single clip. Static clip gain simply means that there is a single gain setting for the entire clip (see “Simple Clip Gain Adjustment” on page 943). Dynamic clip gain means that you can have gain settings for a clip that vary over time (see “Graphically Editing Clip Gain” on page 944).

Clip Gain Info View

When Clip Gain Info view is enabled (View > Clip > Clip Gain Info), the Clip Gain Fader icon is shown at the beginning of the clip, in the lower left corner. If the clip uses static clip gain, the static Clip Gain value (–144 dB to +36.0 dB) for the clip is displayed to the right of the Clip Gain Fader icon. For a clip that has dynamic clip gain (using breakpoint gain settings), the Clip Gain value is not shown.

Clip Gain commands (including the Clip Gain Fader and its Right-click commands) only apply to the single, whole clip with which it is associated.
To show or hide Clip Gain icon, do one of the following:

- Select or deselect View > Clip > Clip Gain Info.
- Press Control+Shift+“=” (Equal) (Mac) or Start+Shift+“=” (Equal) (Windows).

Clip Gain Fader Icon Right-Click Menu

You can Right-click the Clip Gain Fader icon for any individual clip to access relevant clip gain commands for that clip.

Clip Gain Icon Right-click menu

The Clip Gain Fader icon Right-click menu operates independently of the Clip Gain sub-menu that is accessible when Right-clicking on an Edit selection. When rendering clip gain settings, the resulting clip provides handles for trimming out the clip based on the Default Handle Length settings in the Processing Preferences.

Bypass Clip Gain

When Bypass Clip Gain is selected in the Right-click menu, the current clip gain settings are bypassed and the clip plays back with 0 dB gain adjustment.

Clear Clip Gain

Choose Clear Clip Gain in the Right-click menu to clear the clip gain settings for the clip.

Render Clip Gain

Choose Render Clip Gain in the Right-click menu to render the current clip gain settings for the clip. After the clip is rendered with its new gain, the clip gain settings are reset to 0 dB.

Show/Hide Clip Gain Line

Select Show/Hide Clip Gain Line in the Right-click menu to show or hide the Clip Gain Line for all clips.

Clip Gain Line

The Clip Gain Line lets you edit the clip gain settings for any given clip using breakpoint editing, much like with track-based volume automation. However, unlike track-based volume automation, the clip gain settings are always associated with the clip rather than with the track. The Clip Gain Line can be shown or hidden for all clips in the Edit window.

Clip Gain Line (with multiple breakpoints)

To show or hide the Clip Gain Line, do one of the following:

- Select or deselect View > Clip > Clip Gain Line.
- Press Control+Shift+“-” (Hyphen) (Mac) or Start+Shift+“-” (Hyphen) (Windows).
- Right-click the Clip Gain Fader icon on any clip and choose Show Clip Gain Line or Hide Clip Gain Line.
Right-click any clip and choose Clip Gain > Show Clip Gain Line or Clip Gain > Hide Clip Gain Line.

The Clip Gain Line is only shown when the track height is set to Small or larger.

Clip Gain Line and Crossfades

Clip gain is applied on a clip-by-clip basis. When cross-fading between clips, the Clip Gain Line for the first clip carries through the fade out segment of the crossfade and the Clip Gain Line for the second clip carries through the fade in segment of the crossfade. Consequently, crossfades can display two Clip Gain Lines, one for the first clip and one for the second clip.

Simple Clip Gain Adjustment

You can adjust clip gain using the Clip Gain Fader icon for quick and easy clip gain adjustments.

To boost or attenuate the current clip gain settings for a single clip:

1. Ensure that the Clip Gain Info option is enabled.

2. Click the Clip Gain Fader icon on the clip and drag the Clip Gain fader up or down to boost or attenuate the clip gain settings for the clip.

Simple Clip Gain Adjustment

You can adjust clip gain using the Clip Gain Fader icon for quick and easy clip gain adjustments.

To boost or attenuate the current clip gain settings for a single clip:

1. Ensure that the Clip Gain Info option is enabled.

2. Click the Clip Gain Fader icon on the clip and drag the Clip Gain fader up or down to boost or attenuate the clip gain settings for the clip.

Editorial: The text includes a diagram of a clip gain fader, adjusting static clip gain value, and another diagram of a clip gain fader, adjusting all breakpoint clip gain values. The text also includes a note that pressing Command (Mac) or Control (Windows) while adjusting the Clip Gain fader for fine control.

Editing Clip Gain

Pro Tools lets you adjust the gain settings for a clip using the Clip Gain Fader for quick and easy adjustments, or using breakpoint editing on the Clip Gain Line for detailed clip gain control.

If a clip is Edit-locked and you attempt to edit clip gain, you are prompted to Cancel or Allow the edit.
Graphically Editing Clip Gain

You can graphically edit clip gain using breakpoints on the Clip Gain Line for individual clips. When you drag a clip gain breakpoint up or down, the change in the gain setting value is numerically indicated. Dragging a clip gain breakpoint to the left or right adjusts its timing.

Using the Grabber Tool

Using the Grabber tool, you can add, adjust, and delete individual clip gain breakpoint settings.

To add a clip gain breakpoint with the Grabber tool:
1. Ensure that the Clip Gain Line option is enabled.
2. Select the Grabber tool.
3. Click at any point on the Clip Gain Line for the clip to add a breakpoint. The Grabber points and displays a Plus sign (“+”).

To adjust a clip gain breakpoint with the Grabber tool:
1. Ensure that the Clip Gain Line option is enabled.
2. Select the Grabber tool.
3. Option-click (Mac) or Alt-click (Windows) the breakpoint you want to delete. The Grabber points and displays a Minus sign (“−”).

Using the Pencil Tool

The Pencil tool lets you create new breakpoints by clicking once on the graph line. Pro Tools lets you use the Free Hand, Line, Triangle, Square, and Random Pencil Tool shapes for drawing clip gain. The Parabolic and S-Curve Pencil Tool shapes are not available for editing clip gain.

Press Control+Shift+E (Mac) or Start+Shift+E (Windows) to add a Clip Gain breakpoint at the current Edit location.

To adjust a clip gain breakpoint with the Pencil tool:
1. Ensure that the Clip Gain Line option is enabled.
2. Select the Grabber tool.
When drawing clip gain settings with the Pencil tool, its effect is bounded by the Edit selection if the pencil gesture crosses into the selection. However, if the pencil gesture is entirely outside of a selection, it creates clip gain breakpoints outside of the selection.

To add clip gain breakpoints with the Pencil tool:
1. Ensure that the Clip Gain Line option is enabled.
2. Select the Pencil tool.
3. Do one of the following:
   • Click once on the Clip Gain Line to add a single breakpoint.
   • Drag on the Clip Gain Line to draw breakpoints.

To delete a clip gain breakpoint with the Pencil tool:
1. Ensure that the Clip Gain Line option is enabled.
2. Select the Pencil tool.
3. Option-click (Mac) or Alt-click (Windows) the breakpoint you want to delete.

Using the Trim Tools

The Trim tools let you adjust all selected breakpoints up or down by dragging anywhere within that selection. Unlike track-based Volume automation, which scales when trimming, clip gain provides true trimming (where clip gain settings maintain their fixed relations to one another when trimming).

To trim the selected clip gain settings up or down:
1. Ensure that the Clip Gain Line option is enabled.
2. Make an Edit selection that includes the clip gain settings that you want to adjust.
3. Select the Trim tool.
4. Drag up or down over the Clip Gain Line within the Edit selection.

Nudging Clip Gain

Pro Tools lets you nudge the selected clip gain settings up or down by the Nudge Clip Gain By amount specified in the Pro Tools Editing Preferences. You can also nudge the selected clip gain settings back or forward in the clip by the specified nudge amount.

💡 You can also nudge Clip Gain up or down with EUCON. See the Artist Series and Pro Tools guide for more info.
To set the Nudge Clip Gain By amount:
1 Choose Setup > Preferences.
2 Click the Editing tab.
3 Enter a value for the Nudge Clip Gain By setting.
4 Click OK.

To nudge the selected clip gain up:
- Press Control+Shift+Up Arrow (Mac) or Start+Shift+Up Arrow (Windows).

To nudge the selected clip gain down:
- Press Control+Shift+Down Arrow (Mac) or Start+Shift+Down Arrow (Windows).

To nudge the selected clip gain backward, do one of the following:
- Press Control+Shift+“–” (Minus) (Mac) or Start+Shift+“–” (Minus) (Windows).
- Press Control+Shift+M (Mac) or Start+Shift+M (Windows).
- Press Control+Shift+“,” (Comma) (Mac) or Start+Shift+“,” (Comma) (Windows).

To nudge the selected clip gain forward, do one of the following:
- Press Control+Shift+“+” (Plus) (Mac) or Start+Shift+“+” (Plus) (Windows).
- Press Control+Shift+“.” (Period) (Mac) or Start+Shift+“.” (Period) (Windows).
- Press Control+Shift+“/” (Slash) (Mac) or Start+Shift+“/” (Slash) (Windows).

Clearing Clip Gain
Pro Tools lets you clear the clip gain settings for the current Edit selection. This resets the clip gain for the selection to 0 dB. For clips only partially included in the Edit selection, only the clip gain settings within the Edit selection are affected.

To clear clip gain, do one of the following:
- Right-click a clip or Edit selection and choose Clip Gain > Clear Clip Gain.
- Right-click the Clip Gain Fader icon for a single clip and choose Clear Clip Gain.
- Select a clip or make an Edit selection and choose Edit > Clip Special > Clear Clip Gain.
- Select a clip or make an Edit selection and press Control+Shift+B (Mac) or Start+Shift+B (Windows).
- Press Option (Mac) or Alt (Windows) and click Clip Gain Fader icon for a single clip.

Cutting, Copying, and Pasting Clip Gain
Pro Tools lets you cut, copy, and paste clip gain settings, so that you can apply the clip gain settings from one clip to any other. Clip gain settings cannot be cut, copied, or pasted across clip boundaries.

To cut clip gain settings:
1 Select a single whole clip or make an Edit selection within a single whole clip.
2 Do one of the following:
   • Choose Edit > Cut Special > Cut Clip Gain.
   • Press Control+Shift+X (Mac) or Start+Shift+X (Windows).
The selected clip gain settings are cut and copied to the clipboard. Clip gain breakpoints on the clipboard are time-stamped with the playback times in the timebase of the track being copied (which means you can cut and paste clip gain settings from clips on tick-based tracks and have the pasted clip gain settings match the corresponding bar:beat locations of clips on other tick-based tracks).

⚠️ You can cut clip gain settings from any Edit selection. However, if you want to cut and paste clip gain settings, you can only paste the clip gain settings cut from a single clip.

To copy clip gain settings:
1. Select a single whole clip or make an Edit selection within a single whole clip.
2. Do one of the following:
   - Choose Edit > Copy Special > Copy Clip Gain.
   - Press Command+Option+Control+C (Mac) or Control+Alt+Start+C (Windows).
   - Right-click any single whole clip selection and choose Clip Gain > Copy Clip Gain.

The selected clip gain settings are copied to the clipboard. Clip gain breakpoints on the clipboard are time-stamped with the playback times in the timebase of the track being copied (which means you can copy and paste clip gain settings from clips on tick-based tracks and have the pasted clip gain settings match the corresponding bar:beat locations of clips on other tick-based tracks).

To paste clip gain settings:
1. Cut or Copy the clip gain settings you want.
2. Do one of the following:
   - Select another clip.
   - Make an Edit selection within a single whole clip.
   - Place the Edit In Point where you want the cut or copied clip gain settings to be pasted.
3. Do one of the following:
   - Choose Edit > Paste Clip Gain.
   - Press Command+V (Mac) or Control+V (Windows).

The clip gain settings on the clipboard are pasted into the clip starting at the Edit In Point. The clip gain settings are pasted in their entirety, but only apply to a single clip. If the pasted clip gain settings extend beyond the end of the clip, they are all still associated with the clip. This means that if you trim out the clip later, the pasted clip gain is revealed. When pasting clip gain within a clip (rather than to a single whole clip of the same duration), breakpoints are added before and after the pasted data so that any clip gain settings outside the paste do not change.

**Converting Clip Gain and Track Volume Automation**
(Pro Tools | Ultimate Software Only)

Pro Tools lets you convert clip gain settings to track-based volume automation, as well as letting you convert track-based volume automation to clip gain settings.

When converting clip gain settings to volume automation, the clip gain settings are cut from the clip and pasted to track-based volume automation at the same timeline locations as the clip.

When converting track-based volume automation to clip gain, the volume automation is cut from the track volume automation playlist and pasted to the clip. Once volume automation has been converted to clip gain, the clip gain settings stay with the clip when moved, cut, copied, or pasted.
To convert clip gain settings to track-based volume automation:

1. Select a clip or make an Edit selection.

⚠️ Any clip gain settings above +12 dB are lost when converted to volume automation. Also, clip gain settings within crossfades are cross-faded as part of the volume automation.

To convert track-based volume automation to clip gain:

1. Select a clip or make an Edit selection.

Coalescing Clip Gain and Track Volume Automation
(Pro Tools | Ultimate Software Only)

Pro Tools lets you coalesce clip gain settings to track-based volume automation, as well as letting you coalesce track-based volume automation to clip gain settings.

When coalescing clip gain settings to volume automation, the clip gain settings are cut from the clip and coalesced with track-based volume automation at the same timeline locations as the clip.

When coalescing track-based volume automation to clip gain, the volume automation is cut from the track volume automation playlist and coalesced with the selected clip gain settings. Once volume automation has been coalesced to clip gain, volume automation is set to 0 dB for the selection.

To coalesce clip gain settings to track-based volume automation:

1. Select a clip or make an Edit selection.

To coalesce track-based volume automation to clip gain settings:

1. Select a clip or make an Edit selection.

⚠️ Any clip gain settings above +12 dB are lost when it is coalesced to volume automation. Also, clip gain within crossfades is cross-faded as part of the volume automation.

Bypassing Clip Gain

Pro Tools lets you bypass the current clip gain settings for any selected whole clip. This means that you can hear the clip without any clip gain adjustments without losing your current clip gain settings.

To bypass (or unbypass) clip gain for a clip, do one of the following:

- Select one or more whole clips and choose Clip > Clip Gain > Bypass Clip Gain (or choose Clip > Clip Gain > Unbypass Clip Gain).
- Right-click the Clip Gain Fader icon for a clip and select (or deselect) Bypass.
- Right-click a clip or an Edit selection and choose Clip Gain > Bypass Clip Gain (or choose Clip Gain > Unbypass Clip Gain).

The clip gain settings for any whole clips within the Edit selection are bypassed (or unbypassed).

Rendering Clip Gain

Pro Tools lets you render the current clip gain settings for any selected whole clip. Rendering clip gain applies the current clip gain settings to a new clip and sets the clip gain settings for the new clip to 0 dB.
To render clip gain for a clip, do one of the following:

- Select one or more whole clips and choose Clip > Clip Gain > Render Clip Gain.
- Right-click the Clip Gain Fader icon for a clip and choose Render Clip Gain.
- Right-click a clip or an Edit selection and choose Clip Gain > Render Clip Gain.

Clip gain for any whole clips within the Edit selection is rendered and their clip gain settings are reset to 0 dB.

⚠️ For clips with any clip gain settings other than 0 dB, the Prepare DPE Tracks command (for DestructivePunch) automatically renders all clip gain settings and resets all clip gain settings to 0 dB.

⚠️ When processing in an AudioSuite mode that renders in clip gain, any clip gain settings are rendered first, and then AudioSuite processing is applied. Clip gain is reset to 0 dB for the resultant clip. However, when creating individual files with AudioSuite, or overwriting files clip-by-clip, clip gain settings are preserved. For more information, see “Conditions for AudioSuite Rendering with Handles, Fades, Clip Gain, and Metadata” on page 939.

### Clip Effects

Pro Tools Ultimate software provides clip-based effects that let you apply non-destructive EQ, filtering, and dynamics processing to any whole audio clip on any audio track. This lets you modify the sound of any single whole clip or a selection of whole clips on one or more tracks without having to use rendered AudioSuite processing or having to process entire tracks using plug-in inserts. Clip effects processing uses the same algorithms as the Avid Channel Strip plug-in (based on the Euphonix System 5 console channel strip effects), and provides similar controls and settings.

Clip effects settings always stay with the clip, which means you can move, and Cut or Copy and Paste clips along with their corresponding clip effects settings (clip effects settings are also maintained with other edit commands, such as Duplicate or Loop). You can also Cut Special > Cut Clip Effects or Copy Special > Copy Clip Effects, and Paste Clip Effects settings independently of the selected clip’s audio.

You can save and import clip effects settings as presets. You can also use your computer keyboard to quickly store and recall presets just like you can with plug-in inserts and AudioSuite plug-ins.

Clip effects are fully supported with Pro Tools Ultimate software. However, while Pro Tools software can open and playback sessions and projects with clip effects as well as Bypass, Clear, and Render clip effects (if present), it cannot create or edit clip effects. Clip effects use the host processor (Native processing) on all systems.
Clip Effects Display
(Pro Tools | Ultimate Software Only)

With Pro Tools Ultimate, clip effects controls are displayed at the top of the Edit window below the toolbar in the same space as the Universe display (see Figure 1 on page 950). You can toggle between Clip Effects display and Universe display, but they cannot both be viewed at the same time.

To show or hide the Clip Effects display, do one of the following:

- Select or deselect View > Other Displays > Clip Effects.
- Select or deselect Clip Effects from the Edit Window Toolbar menu.
- Click the Show/Hide icon for the Clip Effects/Universe displays. If the Universe display is showing, click the Clip Effects icon in the upper-right corner of the display.

- Press Option+6 (Mac) or Alt+6 (Windows). The behavior of this key command varies slightly depending on the edit selection: if no whole clip is selected, it shows or hides the Clip Effects display while leaving the Edit window focused; if one or more whole clips are selected, it shows and focuses the Clip Effects display (if the display is shown, but not focused, it becomes focused) or hides the display.
Clip Effects Header
(Pro Tools | Ultimate Software Only)

The header at the top of the Clip Effects display provides controls for Presets, Compare, and Bypass controls as well as displaying the name of the selected, whole Clip.

Clip Displays the name of the selected, whole clip. If more than one whole clip is selected, the number of selected whole clips is displayed.

Presets Lets you store and recall up to five presets (see “Clip Effects Presets and Settings Files” on page 962).

Clip Effects Settings Menu Provides commands to save, copy, paste, and manage clip effects settings as presets (see “Clip Effects Settings Menu” on page 963).

Compare Toggles between the original saved Clip Effects preset and any changes you have made to it so you can compare them.

Bypass Lets you bypass clip effects processing (see “Bypassing Clip Effects” on page 951).

Applying Clip Effects
(Pro Tools | Ultimate Software Only)

Pro Tools Ultimate lets you apply clip effects to one or more selected whole clips on one or more tracks. The specific clip effects settings applied to that selection remains with any whole clips within that selection until you clear or change those settings. Each subsequent selection of one or more whole clips can be assigned its own unique clip effects settings.

To apply clip effects:
1 Make an edit selection that includes at least one whole clip.
2 If not already shown, reveal the Clip Effects display (see “Clip Effects Display” on page 950).
3 Choose a preset or adjust the clip effects settings as desired (see “Clip Effects Settings” on page 955).

⚠ Clip effects cannot be applied to committed or frozen tracks.

Bypassing Clip Effects

Both Pro Tools Ultimate and Pro Tools software let you bypass the current clip effects settings for any selected whole clip. This lets you can the clip without any clip effects while maintaining your current clip effects settings.

To bypass (or unbypass) clip effects for a clip:
1 Select one or more whole clips.
2 Adjust the Clip Effects settings as desired (Pro Tools Ultimate only).
3 Do one of the following:
   • Choose Clip > Clip Effects > Bypass Clip Effect (or Clip > Clip Effects > Unbypass Clip Effects).
   • Right-click a clip or an Edit selection and choose Clip Effects > Bypass Clip Effects (or Clip Effects > Unbypass Clip Effects).
   • Click the Bypass button in the Clip Effects Display header so that it is lit (or unlit).

The clip effects settings for any whole clips within the Edit selection are bypassed (or unbypassed).
Rendering Clip Effects

Both Pro Tools Ultimate and Pro Tools software let you render the current clip effects settings for selected whole clips. Rendering clip effects applies the current clip effects settings to a new whole-file clip and clears the clip effects settings.

To render clip effects for a clip:

1. Select one or more whole clips.
2. Adjust the Clip Effects settings as desired (Pro Tools Ultimate only).
3. Do one of the following:
   • Choose Clip > Clip Effects > Render Clip Effects.
   • Right-click and choose Clip Effects > Render Clip Effects.

Clip Effects Signal Chain and Rendering

Clip effects are applied after elastic audio and before clip gain. The signal chain from an audio clip on a track to the track fader is as follows:

Audio File > Elastic Audio > Clip Effects > Clip Gain > AudioSuite > Fades > Inserts > Fader

Rendering always leaves down-stream processing in place while rendering upstream elements. The following examples show what is rendered in the signal chain depending on which commit or render command is used.

What is rendered by process

<table>
<thead>
<tr>
<th>command</th>
<th>Audio File</th>
<th>Elastic Audio</th>
<th>Clip Effects</th>
<th>Clip Gain</th>
<th>Audio Suite</th>
<th>Fades</th>
<th>Inserts</th>
<th>Fader</th>
</tr>
</thead>
<tbody>
<tr>
<td>committing Elastic Audio</td>
<td>rendered</td>
<td>rendered</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>rendering Clip Effects</td>
<td>rendered</td>
<td>real-time</td>
<td>rendered</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>rendering Clip Gain</td>
<td>rendered</td>
<td>real-time</td>
<td>rendered</td>
<td>rendered</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>rendering AudioSuite</td>
<td>rendered</td>
<td>rendered</td>
<td>rendered</td>
<td>rendered</td>
<td>rendered</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>consolidating audio clips</td>
<td>rendered</td>
<td>rendered</td>
<td>rendered</td>
<td>rendered if present</td>
<td>rendered if present</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>freezing tracks</td>
<td>rendered</td>
<td>rendered</td>
<td>rendered</td>
<td>rendered if present</td>
<td>rendered if present</td>
<td>rendered</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Clip Effects Signal Chain Ordering  
(Pro Tools | Ultimate Software Only)

By default the signal chain order for clip effects is EQ > Filters > Dynamics. However, you can reorder this signal chain however you like. For example, maybe you want your dynamics processing before the EQ and Filters.

To change the signal chain order of clip effects:
- Click and drag the title bar of the effect you want to move to the desired location in the signal chain. (For example, drag the Dynamics section to the left of the EQ.)

Showing or Hiding the EQ, Filters, and Dynamics Sections  
(Pro Tools | Ultimate Software Only)

You can independently show or hide the EQ, Filters, and Dynamics sections of the Clip Effects display to use less screen space. These sections are shown by default.

Enabling or Disabling EQ, Filter, and Dynamics Effects  
(Pro Tools | Ultimate Software Only)

You can independently enable or disable EQ, Filter, and Dynamics processing in the Clip Effects display. For example, you may want to apply Dynamics processing, but not EQ or filtering; or, you may want to apply only EQ.

Clip Effects Status View  
(Pro Tools | Ultimate Software Only)

When Clip Effects Status view is enabled (View > Clip > Clip Effects Status), Ø, EQ, and DYN are displayed in the upper right corner of the clip depending on which effects are being applied to the clip. Ø is displayed when the phase is inverted. EQ is displayed when EQ or Filtering is applied to the clip. DYN is displayed when Dynamics processing or Input Gain is set to any value other than 0.0 dB.
To show or hide Clip Effects Status:
- Select or deselect View > Clip > Clip Effects Status.

Clip Effects Special Edit Commands
(Pro Tools | Ultimate Software Only)

Cut Clip Effects
Cutting clip effects copies the clip effects settings to the clipboard and resets the settings for the selected whole clip (or clips) to <factory default>.

To cut clip effects:
1. Select one or more whole clips with clip effects.
2. Do one of the following:
   • Choose Edit > Cut Special > Cut Clip Effects.
   • Press Command+Option+Control+X (Mac) or Control+Alt+Start+X (Windows).

Copy Clip Effects
Copying clip effects copies the clip effects settings for selected whole clips to the clipboard while leaving the settings for those clips intact.

To copy clip effects:
1. Select one or more whole clips with clip effects.
2. Do one of the following:
   • Choose Edit > Copy Special > Copy Clip Effects.
   • Right-click the edit selection and choose Clip Effects > Copy Clip Effects.
   • Press Command+Option+Control+C (Mac) or Control+Alt+Start+C (Windows).

Paste Clip Effects
When Clip Effects are cut or copied to the clipboard, the Paste command changes to Paste Clip Effects in the Edit menu.

To paste clip effects:
1. Special Cut or Copy Clip Effects from one or more whole clips.
2. Select one or more whole clips with or without clip effects.
3. Do one of the following:
   • Choose Edit > Paste Clip Effects.
   • Right-click the edit selection and choose Clip Effects > Paste Clip Effects.
   • Press Command+V (Mac) or Control+V (Windows).

Clear Clip Effects
Clearing clip effects resets the settings for the selected whole clip (or clips) to <factory default>.

To clear clip effects:
1. Select one or more whole clips with clip effects.
2. Do one of the following:
   • Choose Edit > Clear Special > Copy Clip Effects.
   • Right-click the edit selection and choose Clip Effects > Clear Clip Effects.
   • Press Command+Option+Control+B (Mac) or Control+Alt+Start+B (Windows).
Clip Effects Settings
(Pro Tools | Ultimate Software Only)

Input Trim and Polarity Invert

Input Trim

The Input Trim control sets the input gain for clip effects before EQ processing. This lets you make up gain or prevent clipping at the input stage.

To Trim the input signal, do one of the following:
- Click in the Input Trim field and type a Trim value (−36.0 dB to +36.0 dB).
- Click Trim and drag up or down to adjust the Input Trim setting.

Polarity Invert

The Polarity Invert button at the top of the Input section inverts the phase (polarity) of the input signal, to help compensate for phase anomalies that can occur either in multi-microphone environments or because of mis-wired balanced connections.

To enable (or disable) phase inversion on input:
- Click the Polarity Invert button so that it is highlighted. Click it again so that it is not highlighted to disable it.

EQ and Filters

Clip effects provides a high-quality 4-band parametric equalizer and two separate filters for shaping the frequency spectrum of your audio.

Frequency Graph

The EQ section of the Clip Effects display (see Figure 2 on page 956) provides an interactive Frequency Graph display that shows the response curve for the current EQ settings on a two-dimensional graph of frequency and gain. The Frequency Graph display also lets you modify frequency, gain, and Q settings for individual EQ bands by dragging their corresponding points in the graph. The Frequency Graph display also plots the frequency, Q, and filter shape of the two filters (when either or both are enabled).

Adjusting EQ and Filter Controls on the Frequency Graph

You can adjust the following EQ and Filter controls by dragging control points directly in the Frequency Graph display:

Control-Shift-click (Mac) or Start-Shift-click (Windows) the control point for any frequency band to solo that frequency band. Drag left or right to change the frequency value.
**Frequency** Dragging a control point to the right increases the Frequency setting. Dragging a control point to the left decreases the Frequency setting.

![Press the Shift key while clicking and dragging an EQ control point up or down to adjust the Gain setting without changing the Frequency. Likewise, press the Shift key while clicking and dragging an EQ control point left or right to adjust the Frequency setting without changing the Gain setting.](image)

**Gain** Dragging a control point up increases the Gain setting. Dragging a control point down decreases the Gain setting.

![Option-Shift-click (Mac) or Alt-Shift-click (Windows) an EQ control point to invert its Gain setting.](image)

**Q** Click within the curve of an EQ control point and drag up or down to increase or decrease the Q setting. For the Low and High Frequency Bands, the Q control is only available when the EQ Type is set to Peak. For Filter control points, drag it up or down to adjust the Q for that filter. The Q control is only available when the Filter Type is set to Band Pass or Notch.

![You can also Control-click (Mac) or Start-click (Windows) and drag a control point up or down to increase or decrease the Q setting.](image)
Frequency Graph Gain Resolution

Clip Effects let you view the gain scale on the Frequency Graph display either in 3 dB increments from –12 dB to +12 dB or in 6 dB increments from –24 dB to +24 dB.

To change the Frequency Graph Gain resolution:
- Click the Graph Resolution toggle.

Enable/Disable EQ Bands and Filters

Click the Enable/Disable button for an EQ frequency band (HF, HMF, LMF, or LF) or a filter (1 or 2) to enable or disable that frequency band or filter. Buttons are lit when enabled, and unlit when disabled.

High and Low Frequency EQ Controls

Enable the HF button for the high frequency band of the EQ and the LF button for the low frequency band. The both the high and low frequency band can be set to be either a Peak or Low Shelf EQ.

EQ Type
Enable either the Peak or Shelf button to set the EQ type for the frequency band.

Frequency
Sets the center frequency for the frequency band.

Gain
Boosts or attenuates the corresponding frequencies for the frequency band.

Q
Sets the width of the frequency band. Higher Q values represent narrower bandwidths. Lower Q values represent wider bandwidths. The Q control is only available when the EQ Type is set to Peak.

High Mid and Low Mid Frequency EQ Controls

Enable the HMF button for the high mid–frequency band of the EQ and the LMF button for the low mid–frequency band. Both bands are peak EQs.

Frequency
Sets the center frequency for the frequency band.

Gain
Boosts or attenuates the corresponding frequencies for the frequency band.

Q
Sets the width of the frequency band. Higher Q values represent narrower bandwidths. Lower Q values represent wider bandwidths.
Filter 1 and 2 Controls

Enable the 1 button for the first filter and the 2 button for the second filter. Both filters provide the same set of controls that can be independently configured.

**Type** Lets you select from the following Filter Type options: High Pass, Low Pass, Band Pass, and Notch.

**Freq (Frequency)** Sets the center frequency for the selected Filter Type (from 20 Hz to 21.0 kHz).

**Slope** Sets the slope for the filter from the selected Frequency to –INF (12 dB/O or 24 dB/O). The Slope control is only available when the Filter Type is set to Low Pass or High Pass.

**Q** Sets the width of the filter around the center frequency band. Higher Q values represent narrower bandwidths. Lower Q values represent wider bandwidths. The Q control is only available when the Filter Type is set to Band Pass or Notch.

Dynamics

The Dynamics section of the Clip Effects display provides Expander/Gate, Compressor/Limiter, and Side Chain processing all in one. This section also provides a dynamics graphic display for Expander/Gate and Compressor/Limiter processing.

**Dynamics Graph**

The Dynamics Graph display shows a curve that represents the level of the input signal (on the horizontal x-axis) and the amount of gain reduction applied (on the vertical y-axis). The display shows two vertical lines representing the Threshold setting for the Expander/Gate and the Compressor/Limiter, respectively. Use this graph as a visual guide to see how much dynamics processing you are applying to the incoming audio signal.
Dynamics Graph Resolution

Clip effects let you view the gain reduction scale on the Dynamics Graph display either in 3 dB increments from 0 dB to 18 dB or in 6 dB increments from 0 dB to –36 dB.

To change the Dynamics Graph resolution:
- Click the Dynamics Graph Resolution toggle.

Adjusting Controls on the Dynamics Graph

You can drag in the Dynamics Graph display to adjust the corresponding Expander/Gate and Compressor/Limiter controls. The cursor updates to show which control is being adjusted:
- Expander/Gate Ratio
- Expander/Gate Knee
- Expander/Gate Threshold
- Gate Depth
- Hysteresis
- Compressor/Limiter Ratio
- Compressor/Limiter Knee
- Compressor/Limiter Threshold
- Limiter Depth

Enable/Disable Expander/Gate and Compressor/Limiter

Click the Enable/Disable button for Exp/Gate or Comp/Lim to enable or disable the corresponding dynamics processing. Buttons are lit when enabled, and unlit when disabled.

Expander/Gate Controls

**Threshold** Sets the level below which an input signal must fall to trigger expansion or gating. Signals that fall below the threshold will be reduced in gain. Signals that are above it will be unaffected. The Dynamics Graph display shows the threshold as a vertical line.

**Attack** Sets the attack time, or the rate at which gain is reduced after the input signal crosses the threshold. Use this along with the Ratio setting to control how soft the Expander gain reduction curve is.

**Ratio** Sets the amount of expansion. For example, if this is set to 2:1, it will lower signals below the threshold by one half. At higher ratio levels the Expander/Gate functions like a gate by cutting off signals that fall below the threshold. As you adjust the ratio control, refer to the Dynamics Graph display to see how the shape of the expansion curve changes.
**Depth** Sets the depth of the Expander/Gate when closed. Setting the gate to higher range levels allows more and more of the gated audio that falls below the threshold to peek through the gate at all times.

**Hold** Specifies the duration (in seconds or milliseconds) during which the Expander/Gate will stay in effect after the initial attack occurs. This can be used as a function to keep the Expander/Gate in effect for longer periods of time with a single crossing of the threshold. It can also be used to prevent gate chatter that may occur if varying input levels near the threshold cause the gate to close and open very rapidly.

**Release** Sets how long it takes for the gate to close after the input signal falls below the threshold level and the hold time has passed.

**Knee** Sets the rate at which the Expander/Gate reaches full effect once the threshold has been exceeded.

**Hysteresis** Adjusts whether or not the gate rapidly opens and closes when the input signal is fluctuating near the Threshold. This can help prevent undesirably rapid gating of the signal. Hysteresis applies a differential threshold for signals that are rising, as opposed to signals that are falling, to reduce the chance of the gate opening when you don’t want it to. For example, if the threshold is set to –30 and Hysteresis is set to 10, the gate opens when the signal reaches –20 and closes when signal reaches the set threshold of –30. This control is only available when Ratio is set to Gate, otherwise it is grayed out.

**Compressor/Limiter Controls**

**Threshold** Sets the level that an input signal must exceed to trigger compression or limiting. Signals that exceed this level will be compressed. Signals that are below it will be unaffected.

**Attack** Sets the attack time, or the rate at which gain is reduced after the input signal crosses the threshold. The smaller the value, the faster the attack. The faster the attack, the more rapidly the Compressor/Limiter applies attenuation to the signal. If you use fast attack times, you should generally use a proportionally longer release time, particularly with material that contains many peaks in close proximity.

**Ratio** Sets the compression ratio, or the amount of compression applied as the input signal exceeds the threshold. For example, a 2:1 compression ratio means that a 2 dB increase of level above the threshold produces a 1 dB increase in output. The compression ratio ranges from 1.0:1 to 20.0:1. Once the Ratio control passes 20.0:1 the Compressor/Limiter effect functions as a limiter rather than a compressor.

At the limiter setting (LMTR), for every decibel that the incoming signal goes over the set Threshold, 1 dB of gain reduction is applied. Once the Ratio control passes the LMTR setting, it provides negative ratio settings from –20.0:1 to 0:1. With these settings, for every decibel that the incoming signal goes over the set Threshold, more than 1 dB of gain reduction is applied according to the negative Ratio setting. For example, at the setting of –1.0:1, for each decibel over the set threshold, 2 dB of gain reduction is applied. Consequently, the output signal is both compressed and made softer.
**Depth** Sets the amount of gain reduction that is applied regardless of the input signal. For example, if the Limiter is set at a Threshold of –20 dB and Depth is set at 0 dB, up to 20 dB of gain reduction is applied to the incoming signal (at 0 dB). If you set Depth to –10 dB, no more than 10 dB of gain reduction is applied to the incoming signal.

**Release** Sets the length of time it takes for the Compressor/Limiter to be fully deactivated after the input signal drops below the threshold. Release times should be set long enough that if signal levels repeatedly rise above the threshold, the gain reduction recovers smoothly. If the release time is too short, the gain can rapidly fluctuate as the compressor repeatedly tries to recover from the gain reduction. If the release time is too long, a loud section of the audio material could cause gain reduction that continues through soft sections of program material without recovering.

**Knee** Sets the rate at which the compressor reaches full compression once the threshold has been exceeded. As you increase this control, it goes from applying hard-knee compression to soft-knee compression. With hard-knee compression, compression begins when the input signal exceeds the threshold. This can sound abrupt and is ideal for limiting. However, with soft-knee compression, gentle compression begins and increases gradually as the input signal approaches the threshold, and reaches full compression after exceeding the threshold. This creates smoother compression.

**Gain** Lets you boost overall output gain to compensate for heavily compressed or limited signals.

---

**Side Chain Processing**

**Side Chain controls**

Dynamics processors typically use the detected amplitude of their input signal to trigger gain reduction. This split-off signal is known as the side chain. Compressor/Limiter and Expander/Gate processing also features filtering on the side chain. By filtering the side chain, you can make dynamics processing more or less sensitive to certain frequencies. For example, you might configure the side chain so that certain lower frequencies on a drum track trigger dynamics processing.

**Source**

The Source selector lets you set the source for side chain processing: Internal or All-Linked.

**Internal** Uses the amplitude of the input signal to trigger dynamics processing. With greater-than-stereo multichannel processing, the input signal for each stereo pair effects only those same channels, and likewise mono channels are effected only by their own input signal. For example, with an LCR multichannel format, the processing for the Center channel is only triggered when the Center channel input signal reaches the threshold. However, when the input signal reaches the threshold on the Left or the Right channel, processing is triggered for both the Left and the Right channel.
**All-Linked** Applies dynamics processing equally to all channels when the input signal reaches the threshold on any input channel, except for the LFE channel (if present). The LFE channel is always processed independently based on its own input signal.

**Detection**

The Detection options include Peak or Avg (Average).

- **Peak** Applies side-chain processing according to the detected peak amplitude.
- **Average** Applies sidechain processing according to the detected average amplitude.

**Filter Frequency**

The Filter Frequency control lets you set the frequency for the selected Filter Type.

**Filter Type**

Four Filter Type options are available for side-chain processing:

- **Low Pass** Applies a low pass filter to the side-chain processing at the selected frequency.
- **High Pass** Applies a high pass filter to the side-chain processing at the selected frequency.
- **Notch** Applies a notch filter to the side-chain processing at the selected frequency.
- **Band Pass** Applies a band pass filter to the side-chain processing at the selected frequency.

**Listen Mode**

The Side Chain pane in the Dynamics section provides a Listen button. When enabled, Listen mode lets you hear the input signal that feeds the dynamic section. This can be either the internal side chain (including the applied filter) or all linked channels of the source audio.

**To enable (or disable) Listen on the Side Chain:**

- Click the Listen button (speaker icon) in the Side Chain section so that it is highlighted. Click it again so that it is not highlighted to disable it.

---

**Clip Effects Presets and Settings Files**

*(Pro Tools | Ultimate Software Only)*

In addition to the stored settings named in the Clip Effects Settings menu, clip effects provides five preset buttons so that you can easily store and recall your most commonly used settings. You can also save and import Clip Effects settings using the commands in the Clip Effects Settings menu.

**To store a Clip Effects preset:**

1. Configure the clip effects settings as you like.
2. Command-click (Mac) or Control-click (Windows) the Preset button where you want to store the current clip effects settings.
To recall a Clip Effects preset:

- Click the Preset button that contains the settings you want to recall.

If the Editing preference “1–5 Number Keys Control” is set to “Clip Effects Presets,” you can press Control+1–5 (Mac) or Start+1–5 (Windows) to recall the corresponding preset. If Commands Keyboard Focus is also enabled in the Edit window, just press the number for the preset you want (1–5).

Press Command+Control+1–5 (Mac) or Control+Start+1–5 (Windows) to apply the number keys to the opposite of what is set for the 1–5 Number Keys Control preference (for example, if Zoom Presets is selected, these key combinations would apply to Clip Effects Presets instead). If Commands Keyboard Focus is enabled for the Edit window, press Command+1–5 (Mac) or Control+1–5 (Windows).

Clip Effects Settings Menu

Clip effects settings are saved and recalled just like Plug-in settings. The Clip Effects Settings menu commands include:

<factory default> Restores the default settings for clip effects.

Save Settings Saves the current settings. This command overwrites any previous version of the preset.

Press Command+Option+Control+S (Mac) or Control+Alt+Start+S (Windows) to save the current Clip Effects settings.

Save Settings As Saves the current settings as a new preset under a different name.

Import Settings Imports a Clip Effects Settings file (.tfx) from a location other than the Root Settings folder or Session folder.

Delete Current Settings File Permanently deletes the current Clip Effects Settings file (.tfx) from disk.

Lock (Unlock) Settings File Locks (or unlocks) the selected Clip Effects Settings file so that it cannot (or can) be edited.

Copy Settings Copies the selected Clip Effects Settings to the clipboard.

Paste Settings Pastes Clip Effects Settings from the clipboard.

Save Clip Effects Settings To Selects the folder where Clip Effects settings files are saved. If you select Session Folder, the settings are saved in a folder called Channel Strip in the Plug-in Settings folder in the current session folder. If you select Root Settings Folder, the settings are saved in the Documentation and Settings folder specified in the Operation preferences.
Chapter 44: Elastic Audio

Elastic Audio provides track-based Real-Time and Rendered Time Compression and Expansion (TCE) and clip-based pitch shifting (transposition). Pro Tools Elastic Audio uses exceptionally high-quality transient detection algorithms, beat and tempo analysis, and real-time TCE and pitch shifting processing algorithms. Elastic Audio lets you quickly and easily transpose the pitch of audio clips and tempo conform (beat match) audio to the session’s Tempo map. It also provides an unprecedented degree of control over transient detection and TCE processing on an event-by-event basis.

With Elastic Audio, Pro Tools analyzes entire audio files for transient events. For example, an event can be a drum hit, a sung note, or chord played by a guitar. These detected events can then serve as control points for warping the audio. Pro Tools can warp (TCE) audio events automatically, such as automatically conforming audio to the session tempo or quantizing audio events, or you can warp audio manually using standard editing tools in Warp view.

Elastic Audio is useful in several common workflows: working with loops, correcting performances, remixing, sound design and special effects, and film scoring.

Working with Loops

If you work with loops, Elastic Audio lets you preview your loops in Workspace browsers at their native tempo (BPM) or at the session tempo (BPM). You can even preview the loop while the session is playing back. When you find the loop you like, drag it from the browser and drop it into the session. The loop automatically conforms to the session tempo map and Bar|Beat grid. You can then further manipulate its timing and also transpose the clip to match the pitch of other loops in your session.

Correcting Performances

Elastic Audio lets you quantize audio to tighten up a performance or even manually re-align that one note that was played just a little late. Or, you might decide that the performance is excellent, but just a little under tempo. Tick-based Elastic Audio automatically warps audio to conform to tempo changes. When you change your tracks to tick-based and increase the session tempo, the audio automatically time compresses to match.

Remixing

Elastic Audio lets you quickly beat match an entire song to the session tempo and Bar|Beat grid. You can also transpose clips to match pitch.

Sound Design and Special Effects

Use Elastic Audio to achieve special effects with extreme or widely variable TCE or pitch manipulation. Use the Varispeed algorithm to achieve tape-like effects for speed and pitch change.
Film Scoring

If you are scoring a film scene, use Elastic Audio to fit the music to the required duration. You can even use tempo changes to achieve accelerandos and ritardandos.

💡 Remember, when using tempo adjustments for sessions that include multiple cues, tempo changes may affect the timecode position of other cues later on the Timeline.

⚠️ Elastic Audio is not recommended for pull up and pull down workflows. Use the Session Setup window real time pull up or pull downs, or the presets included with Time Shift or X-Form AudioSuite plug-ins.

Example Elastic Audio Workflow

In this workflow, you will be introduced to some common Elastic Audio tasks for working with loops:

• Create and configure a new session for this workflow.

• Locate and preview a loop in a Workspace browser at the session tempo.

• Import the loop at the session tempo on a tick-based, Elastic Audio-enabled track.

• Change the session tempo to change the tempo of the clip on tick-based, Elastic Audio-enabled tracks.

• Quantize the audio to apply a Groove Template to the rhythm.

• Transposition the clip to match the pitch of the imported audio to other audio and MIDI in the session.

Create and configure a new session or project:

1. Create a new Pro Tools session or project.
2. Set the session’s Main Timebase ruler to Bars|Beats.
3. Be sure to display the Tempo and Meter rulers.
4. Use the default tempo of quarter-note equals 120 BPM.

Locate and preview a loop in a Workspace browser at the session tempo:

1. Open the Workspace (Window > Workspace).
2. Navigate to the folder where you keep your drum loops. Double-click the folder name to open a browser window showing just the folder’s contents.
3. Select the loop you want to preview.
4. Click the Preview button to preview the loop at its native tempo.

💡 Audition Paths for previewing are selected in the I/O Setup window (Choose Setup > I/O and click the Output tab).

Preview and Audio Files Conform to Session Tempo buttons in a Workspace browser
5 Click the Audio Files Conform to Session Tempo button so that it highlights.

6 Click the Preview button again and the file previews at the session tempo.

7 Notice that if the loop was sample-based to begin with, once it is analyzed the file’s Duration is now measured in Bars and Beats instead of Minutes and Seconds, the Sample-based icon is replaced by the Tick-based icon, and the detected tempo of the file is displayed in the Tempo column.

8 Repeat the preceding steps to preview other loops at the session tempo.

Import the loop at the session tempo:

1 Make sure that the Audio Files Conform to Session Tempo button is still highlighted. This ensures that the file will be imported as a tick-based, Elastic Audio clip and can be conformed to the session tempo.

2 Drag and drop the loop from the browser to the Tracks List in the session’s Edit window.

3 One of the following occurs:
   - If there are no tracks in the session and the file is tick-based, you are prompted to either import the tempo from the file or use the session tempo. To keep the session tempo and have the loop conform to the session tempo, click Don’t Import.
   - If there are tracks in the session, the file is imported and automatically conformed to the session tempo.

4 A new tick-based audio track is created with the Default Elastic Audio plug-in enabled.

5 Since you chose to not import the file’s original tempo, you will notice that the loop conforms to the tempo map and Bar|Beat grid of the session. A Warp indicator appears in both the clip in the track and in the Clips List.

Also in the Clips List, notice that there are two clips. One is the sample-based whole file clip (the imported source file) and the other is the tick-based Elastic Audio–processed copy.

You can also conform clips on Elastic Audio-enabled tracks to the session tempo using the Conform to Tempo command (see “Conform to Tempo” on page 849).
Dragging and dropping a tick-based audio file from a Workspace browser to the Tracks List

Imported tick-based audio file with Elastic Audio processing
Change the session tempo to change the tempo of the clip:

1 Change the tempo from the default 120 BPM to 110 BPM (see “Tempo” on page 844).

2 Notice that since the clip is on a tick-based, Real-Time Elastic Audio-enabled track it automatically conforms to the new tempo.

Quantize audio to apply a Groove Template:

1 Select the clip on the tick-based, Real-Time Elastic Audio-enabled track.

2 Choose Event > Event Operations > Quantize.

3 In the What to Quantize section, make sure Elastic Audio Events option is selected.

4 From the Quantize Grid pop-up menu, select a Groove Template.

5 Set any other options.

6 Click Apply.

7 In the following figure, notice that the audio has been quantized according to the selected Groove Template. In Warp view, you can see that Warp markers have been added at every Event marker near the Quantize Grid and were used to apply quantization to those events.
Transpose the audio clip down a whole-tone:

1. Select the clip on the Elastic Audio-enabled track.
3. Select the Transpose By option.
4. Enter “–2” semitones.
5. Click Apply.

Elastic Audio Tracks

Any audio track in your Pro Tools session can be Elastic Audio enabled. Elastic Audio tracks can be either sample- or tick-based. Sample-based Elastic Audio-enabled tracks let you apply real-time or rendered Elastic Audio processing by editing in Warp view, applying Quantize, and using the TCE Trim tool. However, only tick-based Elastic Audio tracks also automatically apply Elastic Audio processing based on tempo changes in the session.

To enable Elastic Audio on a track:

1. Create a new audio track or choose an existing audio track.
2. Click the track’s Elastic Audio Plug-In selector, and select the Elastic Audio plug-in appropriate to your track material and the results you want from the pop-up menu: Polyphonic, Rhythmic, Monophonic, Varispeed, or X-Form (see “Elastic Audio Plug-Ins” on page 975).
From the track’s Elastic Audio Plug-In pop-up menu, select Real-Time Processing or Rendered Processing for Real-Time or Rendered Elastic Audio processing.

Elastic Audio processing can be Real-Time or Rendered. Real-Time Elastic Audio processing is immediate, but it is more demanding of system resources. Rendered Elastic Audio processing is non-real-time, but is less demanding of system resources. If you are working on a system with limited resources, use Rendered Elastic Audio processing. For more information, see “Real-Time and Rendered Elastic Audio Processing” on page 974.

Creating New Tracks with Elastic Audio Enabled

New tracks are created with Elastic Audio automatically enabled in the following cases:

• When the Enable Elastic Audio On New Tracks option is enabled in the Processing Preferences page (see “Elastic Audio Options” on page 409).

• When dragging and dropping tick-based, Elastic Audio analyzed files from Workspace browsers to the Tracks List or empty space in the Edit window with the Audio Files Conform to Session Tempo option enabled (see “Elastic Audio on Import” on page 402).

• When dragging and dropping REX or ACID files from the Desktop (if either REX and ACID Files Only or the All Files option is enabled for the Drag and Drop from Desktop Conforms to Session Tempo setting in the Processing Preferences page) or a Workspace browser (if the Audio Files Conform to Session Tempo button is enabled) to the Tracks List or empty space in the Edit window (see “Importing ACID and REX Files” on page 406).

Disabling Elastic Audio Tracks

To disable Elastic Audio on a track:

1. From the track’s Elastic Audio Plug-In selector, select None – Disable Elastic Audio.

2. If the track had any Elastic Audio-based processing, you are prompted to Cancel, Revert, or Commit.

Cancel Leaves Elastic Audio enabled on the track.

Revert Removes any Elastic Audio processing, reverts clips on the track to their original duration, and disables Elastic Audio on the track.

Commit Renders and commits any Elastic Audio processing on the track, writes new files to disk, and disables Elastic Audio on the track.

Committed Clips

Clips that are committed, either by disabling Elastic Audio on a track or by moving a clip to a track without Elastic Audio enabled, are written to disk as new audio files. These new audio files include the audio in the clip, plus any fades, and also an additional 5 seconds of audio before and after the clip, if available.

Disabling Elastic Audio and Alternate Playlists

Disabling Elastic Audio on a track affects all playlists on the track. All playlists on the track are committed or reverted depending on which option you choose.
Elastic Audio Track Controls

Audio tracks provide controls for enabling Elastic Audio, selecting the Elastic Audio plug-in, and selecting whether Real-Time or Rendered Elastic Audio processing.

Elastic Audio Plug-In Selector

Selects the Elastic Audio plug-in for Elastic Audio processing (see “Elastic Audio Plug-Ins” on page 975). You can also use the Elastic Audio Plug-In selector to disable Elastic Audio processing, and to select either Real-Time or Rendered processing (see “Real-Time and Rendered Elastic Audio Processing” on page 974).

Elastic Audio Plug-In Button

Displays the name of the selected Elastic Audio plug-in. Click the Elastic Audio Plug-In button to open the Elastic Audio Plug-In window (see “Elastic Audio Plug-Ins” on page 975).

Real-Time or Rendered Processing Indicator

Lights when Elastic Audio processing is real-time and dims when Elastic Audio processing is rendered (see “Real-Time and Rendered Elastic Audio Processing” on page 974).

Elastic Audio Track Views

There are two special Track Views for Elastic Audio-enabled tracks: Warp and Analysis.

Warp View

Warp view lets you manually “time warp” (Elastic Audio process) audio. In Warp view you can create and edit Warp markers. If you are using Elastic Audio to correct the timing of a performance, or to achieve special effects, work in Warp view (see “Editing in Warp View” on page 979).

Analysis View

Analysis view lets you edit detected Event markers. In most cases you will not need to use Analysis view. However, with material that does not have clear transients, you may want to work in Analysis view to add or relocate Event markers, or to delete erroneous Event markers. For example, when using Elastic Audio to correct the timing of a performance, you may need to add, move, or remove Event markers in Analysis view to achieve the highest quality Elastic Audio processing (see “Editing in Analysis View” on page 986).
Elastic Audio Analysis

When recording, pasting, moving, or importing un-analyzed audio to an Elastic Audio-enabled track, or when enabling Elastic Audio on an existing audio track, Pro Tools automatically analyzes the audio for transient events. In Waveform view, the waveform initially appears grayed out because clips go offline during Elastic Audio analysis. Once the analysis is complete, the audio comes back online. Elastic Audio analysis is file-based, which means that even if you are only working with a small clip of a large file, the entire audio file is analyzed.

Elastic Audio analysis detects transient events in the audio file. These transient events are indicated by Event markers. Event markers are displayed in both the Warp and Analysis track views. Elastic Audio analysis also calculates the native tempo of the analyzed audio file and its duration in bars and beats.

Elastic Audio analysis data (detected events, tempo, and duration in Bars|Beats) is stored with the file. In Workspace browsers, analyzed audio files are indicated by a check mark to the left of the file name, and these files display their duration in Bars|Beats, their timebase as ticks, and their native tempo in BPM.

Tempo Detection

Elastic Audio analysis does its best to detect a regular tempo for all analyzed audio. Any audio containing regular periodic rhythm can be successfully analyzed for tempo and duration in bars and beats. Analyzed files in which a tempo was detected are treated as tick-based files. Tick-based files can be conformed to the session tempo for preview and import.

Note that peak amplitude is not the most important measure for event confidence. The clarity of transients is measured in part by the spectral transition from one moment to the next. This tends to favor higher frequency content in terms of event confidence. For example, changing the Event Sensitivity in the Elastic Properties window for a selected drum loop results in the clearer transients of the higher frequency hi-hat hits having more event confidence than the less well defined transients of the lower frequency kick drum hits even though kick drum hits have a higher peak amplitude.

Pro Tools is very aggressive with its transient detection in order to detect every possible audio event. Consequently, it is possible to have erroneously detected events. These events will be analyzed with a low degree of confidence and can be filtered out by lowering the Event Sensitivity in the

Event Confidence

Transient events are detected with a certain degree of confidence. The level of confidence is based on the relative clarity of transients.

For example, a drum loop is likely to have clear, sharp transients. These will be detected with a high degree of confidence. However, a legato violin melody may not have clear, sharp transients, so transients will be detected with a lower degree of confidence.

Analyzed files in which no tempo was detected are treated as sample-based files. If there is only a single transient in the file (such as with a single snare hit), no tempo will be detected. Also, longer files that contain tempo changes or rubato, or that do not contain regular periodic rhythmic patterns will probably not have a detected rhythmic pattern and will be treated as sample-based files.
Elastic Properties window (see “Event Sensitivity Property” on page 990). Filtering out any false transients can result in higher quality Elastic Audio processing.

Conversely, for material with few clear transients, Elastic Audio analysis may not accurately detect audio events, and those detected may be detected with a low level of confidence. You can relocate or add Event markers where necessary in Analysis view (see “Editing in Analysis View” on page 986).

For example, a slow synth pad may not have clear transients and detected Event markers may be incorrectly located or may have not been detected at all. In Analysis view, you can relocate, remove, and add Event markers as necessary (such as where the chord changes). Accurately locating Event markers yields better results when applying Elastic Audio processing.

When processing non-rhythmic audio (such as legato strings) with the Polyphonic plug-in, reducing the number of Event markers often yields better sounding results. You can either manually remove Event markers in Analysis view (see “Editing in Analysis View” on page 986) or lower the Event Sensitivity setting in the Elastic Properties window for the clip you want to process (see “Elastic Properties Window” on page 988).

Real-Time and Rendered Elastic Audio Processing

Real-Time Elastic Audio processing means that any changes to Elastic Audio processing—whether it be a tempo change or a manual TCE warp, or pitch shifting—take effect immediately. However, Real-Time Elastic Audio processing can be very demanding on your system’s resources. Consequently, you may want to use Rendered Elastic Audio processing in some cases. With Rendered Elastic Audio processing, when you make a change to Elastic Audio processing, any affected audio clips temporarily go offline, a new “rendered” audio file is generated, and any affected audio clips come back online.

In rendered mode, any change you make is rendered using the original source audio to avoid generational loss from multiple subsequent edits.

To set an Elastic Audio track to Real-Time or Rendered:

1. Click the track’s Elastic Audio Plug-In selector.
2. From the pop-up menu, select an Elastic Audio plug-in.
3. From the pop-up menu, select one of the following:
   - Real-Time Processing
   - Rendered Processing

Select Real-Time processing for tick-based Elastic Audio processing (such as tempo changes). Rendered audio processing can be useful for sample-based Elastic Audio processing or if you need to save system resources.
To toggle between Real-Time and Rendered Elastic Audio processing, Command-Control-click (Mac) or Control-Start-click (Windows) the Elastic Audio Plug-In button.

About Rendered Files

Pro Tools creates temporary files for Rendered Elastic Audio processing. These files are kept in an auto-created Rendered Files folder in the session folder. Once you commit Rendered Elastic Audio processing to a track, a new file is written to disk in the Audio Files folder, and the temporary rendered file from which it was created is deleted from the Rendered Files folder.

Clipping Indicator (Rendered Processing Only)

Since Rendered Elastic Audio processing is not real-time, it does not report clipping due to Elastic Audio processing in the Elastic Audio plug-in window. Instead, when clipping occurs due to Rendered Elastic Audio processing, the clip displays an Elastic Audio Processing Clipping indicator just to the left of the Warp indicator.

To avoid clipping on playback, lower the Input Gain for the clip in the Elastic Properties window (see “Elastic Properties Window” on page 988).

Elastic Audio Plug-Ins

Pro Tools provides several algorithms for real-time and rendered track-based Elastic Audio processing. The selected Elastic Audio plug-in determines how the audio is processed. Each plug-in uses different algorithms for Elastic Audio processing. Different algorithms are better suited to different types of audio. Select the plug-in whose algorithm is appropriate to the material on the track you want to process.

Elastic Audio plug-ins have their own selector that is only available in the Edit window. You cannot insert Elastic Audio plug-ins on track inserts.

Elastic Audio plug-ins provide few to no adjustable parameters. The adjustable controls, if any, are available in the Elastic Audio Plug-In window. Elastic Audio plug-in parameters cannot be automated.

To open an Elastic Audio Plug-In window:
- Click the Elastic Audio Plug-In button.

Elastic Audio Plug-In Window Controls

The Elastic Audio Plug-In window provides a set of controls in the window header that are common to all Elastic Audio plug-ins.
Elastic Audio plug-in controls

**Track Selector** Lets you access any other audio track in the session.

**Plug-In Selector** Lets you select any Elastic Audio plug-in or disable Elastic Audio.

**Plug-In Settings Menu** Lets you copy, paste, save, and import plug-in presets.

**Plug-In Librarian Menu** Recalls Elastic Audio plug-in settings files (presets) saved in the plug-in’s root settings folder or in the current session’s Settings folder.

**Next (+) and Previous (–) Setting Buttons** Lets you select the next or previous preset from the Plug-In Librarian menu.

⚠️ You will lose the current plug-in settings if they are not saved before you use the Next and Previous Setting buttons. Save your plug-in settings as presets using the Plug-In Settings menu.

**Plug-Ins Settings Select Button** Accesses the Plug-In Settings dialog, which lists the presets for the current plug-in. From this list, you can select a new preset, or audition a series of presets.

**Compare** Toggles between the original saved plug-in settings and any changes you have made to it so you can compare them.

**Target Button** When multiple Elastic Audio Plug-In windows are open, clicking this button selects that plug-in as the target for any computer keyboard commands. Deselecting the Target button lets you open another targeted Elastic Audio Plug-In window.

**Polyphonic Plug-In**

The Polyphonic plug-in is a general, all-purpose algorithm that is effective with a wide range of material. For complex loops and multi-instrument mixes, use the Polyphonic plug-in. The Polyphonic plug-in supports clip-based pitch shifting.

💡 The Polyphonic plug-in is the default plug-in for previewing and importing from Workspace browsers or the Clips List.

**Follow**

Selecting the Follow option enables an envelope follower that simulates the original acoustics of the audio being stretched. Click the Follow button to enable or disable envelope following.
Window

The Polyphonic plug-in provides a single control for adjusting the analysis window size for TCE processing. Experiment with adjusting the Window size for different types of material until you achieve the best results. The following table provides some recommended Window sizes for different types of material.

💡 If you frequently work with distinct types of material, you may want to find the best Window settings for each type of material and save them as plug-in settings for quick and easy recall.

<table>
<thead>
<tr>
<th>Type of Material</th>
<th>Recommended Window Size</th>
</tr>
</thead>
<tbody>
<tr>
<td>General purpose</td>
<td>30–40 ms</td>
</tr>
<tr>
<td>Percussive</td>
<td>20 ms or lower</td>
</tr>
<tr>
<td>Pads and other legato material</td>
<td>60 ms or higher</td>
</tr>
</tbody>
</table>

Rhythmic Plug-In

The Rhythmic plug-in is best suited to material with clear attack transients, such as drums. The Rhythmic plug-in supports clip-based pitch shifting.

Decay Rate

The Decay Rate control determines how much of the decay from a transient is heard in the processed audio when time stretching. When the Rhythmic plug-in is selected, any gaps between transients resulting from time stretching are filled in with audio. The Decay Rate determines how much of this audio is heard by applying a fade out rate. Adjust the Decay Rate up to 100% to hear the audio that is filling the gaps created by the time stretching with only a slight fade, or adjust down to 1.0% to completely fade out between the original transients.

Monophonic Plug-In

The Monophonic plug-in is best suited to monophonic material where you want to keep the formant relationships intact, such as with vocals. The Monophonic plug-in is also well suited to monophonic instrumental lines, such as a bass track. The Monophonic plug-in provides no plug-in specific parameters.

⚠️ Elastic Audio pitch shifting is not supported with the Monophonic algorithm.
The Monophonic plug-in analyzes pitch as well as peak transients in order to provide higher quality TCE to pitched material. Consequently, analysis for the Monophonic algorithm takes longer than for the Polyphonic, Rhythmic, and Varispeed algorithms. Also, when switching from another Elastic Audio plug-in to Monophonic, Pro Tools reanalyzes any audio on the track to collect the extra analysis data.

**Varispeed Plug-In**

Use the Varispeed plug-in to link time and pitch changes for tape-like speed change effects, and post production workflows. The Varispeed plug-in provides no plug-in specific controls.

![Varispeed Plug-In](image)

**TIP** Try using Varispeed with Quantize on drum loops for some interesting effects.

**Elastic Audio plug-in: Varispeed**

**X-Form Plug-In**

(Rendered Only)

The X-Form Elastic Audio plug-in is a modified version of the standalone X-Form AudioSuite processing plug-in (based on the Radius® algorithm from iZotope). The X-Form Elastic Audio plug-in is for Rendered Elastic Audio processing only and cannot process in real-time or as an AudioSuite plug-in. It provides the highest quality time compression algorithms for music production, sound design, and audio loop applications. Use it to manipulate audio loops for tempo matching or to change vocal tracks for formant correct pitch shifting.

![X-Form Plug-In](image)

**Quality**

Select either Maximum or Low (Faster) from the Quality pop-up menu. Maximum is the slowest processing algorithm, but provides the highest quality results. Low (Faster) produces relatively good results and is much faster than the Maximum setting.

**Formant**

For audio material with clear formants, enable Formant to preserve the formant shape of audio when applying TCE processing.

![Formant](image)

Audio with a fundamental pitch has an overtone series, or set of higher harmonics. The strength of these higher harmonics creates a formant shape, which is apparent if viewed using a spectrum analyzer. The overtone series, or harmonics, have the same spacing related to the pitch and have the same general shape regardless of what the fundamental pitch is. It is this formant shape that gives the audio its overall characteristic sound or timbre. When pitch shifting audio, the formant shape is shifted with the rest of the material, which can result in an unnatural sound. Keeping this shape constant is critical to formant correct pitch shifting and achieving a natural sounding result.
Editing in Warp View

In Warp view, you can manually “time warp” (TCE) audio to correct or adjust the timing of a performance, or create special effects. In Warp view, you can add, move, and delete Warp markers. Warp markers are used to fix a specific point in the audio (typically a detected transient event) to a specific point in the Timeline. In this way, you can apply detailed and nuanced “warping” (TCE) of audio events.

⚠️ **Warp view is only available for Elastic Audio-enabled tracks.**

To display Warp view:

1. Click the Elastic Audio-enabled track’s Track View selector.
2. Select **Warp** from the Track View pop-up menu.

Elastic Audio Markers in Warp View

Three types of markers are visible in Warp view: Event markers, Warp markers, and Tempo Event–generated Warp markers. Use Event markers and Warp markers as control points for applying Elastic Audio processing.

Event Markers

Event markers indicate detected (or manually created) audio events. Event markers are only displayed in Warp view and Analysis view. In Warp view, Event markers appear as gray vertical lines that do not fully extend to the top and bottom of the track. With the Grabber tool in Warp view, you can drag Event markers to apply various kinds of warping depending on whether or not Warp markers are present in the clip as well. In Warp view, you cannot add, relocate, or delete Event markers. Use Analysis view to edit Event markers (see “Editing in Analysis View” on page 986).

💡 The display of Event markers is dependent on Horizontal Zoom. If you are zoomed out too far, Event markers are not displayed. To see Event markers, zoom in.

Warp Markers

Warp markers anchor the audio to a specific point in the Timeline. Warp markers are only displayed in Warp view. In Warp view, a Warp marker appears as a thick black vertical line with a triangle at its base.

To better understand how Warp markers work, think of the audio clip as a rubber band, the Timeline as a ruler, and Warp markers as pins. Warp markers can be used to pin a specific point of the rubber band (the audio) to a specific point on the ruler (the Timeline). If you pin down one point of the rubber band to one point on the ruler, use a second pin to pin down another point of the rubber band to another point on the ruler, and then place a third pin equally between them on the rubber band, but fix it to a point on the ruler closer to the second pin, the rubber band will be stretched (or expanded) between the first and middle pins, and relaxed (or compressed) between the middle pin and the last pin.
In Warp view, you can add, relocate (without warping), and delete Warp markers. You can also move a Warp marker to apply Elastic Audio processing (see “Warping Audio” on page 981).

**To add a Warp marker:**

1. Make sure you are in Warp view,
2. Do one of the following:
   - With the Pencil tool, click anywhere in the clip to add a Warp marker at that location. If you click on an Event marker, a Warp marker is created on top of the Event marker.
   - With the Grabber tool, Control-click (Mac) or Start-click (Windows) anywhere in the clip to add a Warp marker at that location. If you click on an Event marker, a Warp marker is created on top of the Event marker.
   - With the Grabber tool, if no Warp markers are present in the clip, or if Warp markers are only present prior to the location where you want to add a new Warp marker, double-click an Event marker to add a Warp marker on top of the Event marker.
   - With the Grabber tool, double-click anywhere in the clip where an Event marker is not present to add a Warp marker at that location.
   - With the Grabber tool, single-click any Event marker prior to another existing Warp marker in the clip to add a Warp marker on top of that Event marker.
   - With any Edit tool, Right-click anywhere in the clip and select Add Warp Marker from the pop-up menu to add a Warp marker at that location. If there is an Edit selection, Warp markers are added at the selection start and end.

**To relocate a Warp marker (without applying warping):**

- With the Grabber or the Pencil tool, Control-drag (Mac) or Start-drag (Windows) a Warp marker to a new location.

**To delete a Warp marker:**

1. Make sure you are in Warp view,
2. Do one of the following:
   - With the Grabber tool, double-click a Warp marker.
   - With the Grabber or the Pencil tool, Option-click (Mac) or Alt-click (Windows) a Warp marker.
   - With any Edit tool, Right-click a Warp marker and select Remove Warp Marker from the pop-up menu.

**To delete all Warp markers in a selection:**

1. In Warp view, make an Edit selection that includes only the Warp markers you want to delete (and none of the Warp markers you want to keep).
2. Do one of the following:
   - Press Delete or Backspace on your computer keyboard.
   - With any Edit tool, Right-click the Edit selection and select Remove Warp Marker from the pop-up menu.
Tempo Event-Generated Warp Markers

Tempo Event-generated Warp markers are not editable and are only displayed to indicate where Elastic Audio processing has been applied to conform the audio to Tempo Events. You will only see Tempo Event-generated Warp markers on tick-based tracks.

If you change the track timebase from ticks to samples, any Tempo Event-generated Warp markers convert to regular, editable Warp markers.

For more information, see “Tempo Changes and Tick-Based Elastic Audio Tracks” on page 848.

Warping Audio

In Warp view, you can manually warp audio in three specific ways: Telescoping Warp, Accordion Warp, and Range Warp.

Automation does not follow manual warping of audio clips, including TCE trimming and quantization of Elastic Audio. However, automation does follow tempo changes on tick-based tracks.

Telescoping Warp

Telescoping Warp can be applied to any audio clip before or after a Warp marker as long as no other Warp marker precedes or follows it accordingly. The audio can be on a sample- or tick-based track. Telescoping Warp is especially useful for adjusting audio files to match the session tempo map and Bar|Beat grid.

To apply Telescoping Warp to a clip:

1. Make sure you are in Warp view,

2. Do one of the following:
   - With the Grabber tool, drag any Event marker that is after the last Warp marker in the clip to the left or right to Telescope-Warp the audio that is after the Warp marker in or out. If no Warp marker is present in the clip, one is created automatically at the clip start. The clip start remains anchored to its location on the Timeline.
   - With the Grabber tool, Option-drag (Mac) or Alt-drag (Windows) any Event marker that is before the first Warp marker in the clip to the left or right to Telescope-Warp the audio that is before the Warp marker in or out. If no Warp marker is present in the clip, one is created automatically at the clip end. The clip end remains anchored to its location on the Timeline.

Before and after warping, applying Telescoping Warp with the clip start fixed
Workflow Example

Beat match a song to the session tempo and Bar|Beat grid using Telescoping Warp:

1. Make sure the Main Timebase ruler is set to Bars|Beats.
2. Set the default tempo and meter.
3. Select Grid mode.
4. Import a song, or any other longer audio file from a Workspace browser.
5. Make sure that Elastic Audio is enabled on the track.
7. Make sure there are no Warp markers present on the clip. If necessary, delete any existing Warp markers.
8. With the Pencil tool, add a Warp marker at the bar 1 downbeat location within the clip.
9. With the Grabber tool, drag the single Warp marker to the bar in the Timeline where you want the downbeat of the audio file to start.
10. Drag the Event marker on the downbeat of bar 2 of the clip to Telescope warp the audio such that the Event marker matches the corresponding bar number in the Bars|Beats ruler.
11. If the clip’s tempo varies, add a Warp marker to the next downbeat location at the tempo change and repeat the preceding steps.

Accordion Warp

Accordion Warp applies Elastic Audio processing on both sides of a single Warp marker in a clip. This lets you expand or compress the audio equally on both sides of a fixed point. Accordion warp is useful for audio files where the downbeat occurs in the middle of the clip.

To apply Accordion Warp to a clip:

1. In Warp view, add a single Warp marker at the point in the clip that you want to remain fixed on the Timeline.
2. With the Grabber tool, drag any Event marker that is before or after the single Warp marker to the left or the right.
Range Warp

Range Warp applies Elastic Audio processing between two fixed points in a clip. To apply Range Warp, there must be at least two Warp markers present in the clip.

To apply Range Warp within a clip:

1. In Warp view, add a Warp marker at the first point that you want to fix to the Timeline.
2. Add another Warp marker to the end point that you want to fix to the Timeline.
3. With the Grabber tool, drag an Event marker between the two Warp markers to the left or right. A Warp marker is added on top of the Event marker and the audio is compressed or expanded on either side of the dragged marker while the audio outside the bounding markers remains unaffected.

Range Warp with an Edit Selection

Pro Tools lets you apply Range Warp between bounding Warp markers, but keeps the timing intact between other Warp markers within an Edit selection.

To apply Range Warp with an Edit Selection:

1. In Warp view, add a Warp marker at the first point that you want to fix to the Timeline.
2. Add another Warp marker to the end point that you want to fix to the Timeline.
3. Add any number of Warp markers in between.
4. With the Selector tool, make an Edit selection that includes the Warp markers in between the bounding Warp markers.
5. With the Grabber tool, drag any of the Warp markers within the Edit Selection to the left or the right.

Before and after warping, applying Range Warp between two Warp markers in a clip

Before and after warping, applying Range Warp to a selection between bounding Warp markers
Elastic Audio processing is only applied to the audio between the bounding Warp markers and the first and last Warp markers in the Edit Selection. All audio between the first and last Warp markers in the Edit Selection maintain their relative timing.

**Individual Range Warp**

Individual Range Warp applies warping to a single audio event in relation to the adjacent audio events.

**To apply Individual Range Warp:**

1. In Warp view, with the Grabber tool, Shift-click a Warp marker or an Event marker. If not already present, Warp markers are automatically created on the adjacent Event markers.

2. Drag to the left or right to warp the clicked event.

**Warped Clips**

Clips that have been warped either manually or automatically by tempo change, quantization, or pitch shifting display a Warp indicator in the upper right-hand corner of the clip. This indicator is visible in any track view. Since unwarped clips can reside on Elastic Audio-enabled tracks, clips on Elastic Audio-enabled tracks do not necessarily display the Warp indicator. The Warp indicator only indicates that Elastic Audio processing has been applied to a clip.

**Displaying the Warp Indicator**

The Warp indicator for Elastic Audio clips can be displayed or hidden.

**To toggle the display of the Warp indicator in Elastic Audio clips:**

- Select or deselect View > Clip > Processing State.
Out of Range Processing

Pro Tools lets you apply extreme amounts of Elastic Audio processing. However, at such extremes, it is possible to go out of the selected Elastic Audio plug-in’s processing range. When this happens, it is possible that not every sample will be processed correctly and you may encounter audio drop outs.

The valid range for Elastic Audio TCE processing is 1/4x to 4x for all Elastic Audio plug-ins except X-Form, which supports 1/8x to 8x. TCE less than or greater than these ranges is effectively “out of range.”

When out of range processing occurs, the section of the audio clip that is out of range turns red. You can still apply Elastic Audio processing, but you are warned by the color change that the TCE factor is out of the normal range of Elastic Audio processing.

Removing Clip Warping

If you have applied any warping to a clip, you can remove warping and revert the clip to its original duration. This can be useful if you are not satisfied with the results and want to revert to the pre-w warped clip. Warp markers are not deleted when applying the Remove Warp command, but any warping is undone.

To remove clip warping:

1. Select the clip for which you want to remove warping.
2. Do one of the following:
   • Choose Clip > Remove Warp.
   • With any Edit tool, Right-click the clip and select Remove Warp from the pop-up menu.

   Remove Warp can only be applied to clips and cannot be applied to clip groups. To un-warp clip groups you must first ungroup the clip, then apply Remove Warp to the underlying clips, and then regroup those clips.

Edit Groups and Warp Editing

Elastic Audio-enabled tracks can be included in Edit Groups. For Elastic Audio-enabled tracks that are part of an Edit Group, applying Elastic Audio processing on one track likewise applies it to all other tracks within that Edit Group.

If corresponding Warp markers are not already present on Elastic Audio-enabled tracks that are part of an Edit Group, new Warp markers are created on those tracks when you add or move a Warp marker on any track that is part of the Edit Group.
Editing in Analysis View

In Analysis view, you can add, move, promote, and delete Event markers. Usually, Pro Tools accurately detects all the transient events (Event markers) in an audio file and you will not need to work in Analysis view. However, Pro Tools may not accurately detect every audio event or may erroneously detect audio events with some types of audio material. This is especially true for audio without clear transients, such as legato strings, melismatic vocals, or soft synth pads.

Use Analysis view to manually correct the presence and location of Event markers. The accurate identification of audio events yields the best results when applying Elastic Audio processing.

To display Analysis view:

1. Click the Elastic Audio-enabled track’s Track View selector.
2. Select Analysis from the Track View pop-up menu.

⚠️ Analysis view is only available for Elastic Audio-enabled tracks.

⚠️ In Analysis view, you can only edit Analysis markers using the Edit tools. You cannot use the Edit tools for any clip editing. Switch to Warp or Waveform views for clip-based editing capabilities with the Edit tools.

⚠️ When manually editing Analysis markers, Pro Tools writes temporary Elastic Audio analysis files (.aan) to the session’s Rendered Files folder. Any unused temporary analysis files are purged when you close the session.

Adding Event Markers

To add an Event marker:

1. Make sure you are in Analysis view.
2. Do one of the following:
   - With the Pencil tool, click at the location where you want to add an Event marker.
   - With the Grabber tool, double-click at the location where you want to add an Event marker.
   - With the Grabber tool, Control-click (Mac) or Start-click (Windows) at the location where you want to add an Event marker.
   - With any Edit tool, Right-click at the location where you want to add an Event marker and select Add Event Marker from the pop-up menu.

Moving Event Markers

To move an Event marker:

1. Make sure you are in Analysis view,
2. Do one of the following:
   - With the Pencil tool, drag the Event marker to a new location.
   - With the Grabber tool, drag the Event marker to a new location.
Promoting Event Markers

Event markers are detected with relative degrees of confidence (between 1% and 100%). You can filter out extraneous Event markers by adjusting the Event Sensitivity setting in the Elastic Properties window; event markers with the least confidence are filtered out first. However, some significant events may not be recognized with a high degree of confidence. In this case, you may want to promote the Event marker to ensure that it is not filtered out when reducing the Event Sensitivity setting. Promoted Event markers, like manually created or moved Event markers, have 100% confidence.

To promote an Event marker:

- In Analysis view, with the Grabber or Pencil tool (or with the Smart Tool in the bottom half of the track), single-click the Event marker you want to promote.

⚠️ Promoted Event markers look the same as detected Event Markers. To see all Event markers that have 100% confidence, reduce the Event Sensitivity setting in the Elastic Properties window (see “Event Sensitivity Property” on page 990).

Deleting Event Markers

To delete an Event marker:

1. Make sure you are in Analysis view.
2. Do one of the following:
   - With the Pencil tool, Option-click (Mac) or Alt-click (Windows) the Event marker you want to delete.
   - With the Grabber tool, Option-click (Mac) or Alt-click (Windows) the Event marker you want to delete.
   - With the Selector tool, make an Edit selection that includes any Event markers you want to delete, Right-click the selection, and choose Remove Event Marker from the pop-up menu.

Edit Groups and Event Editing

Elastic Audio-enabled tracks can be included in Edit Groups. For Elastic Audio-enabled tracks that are part of an Edit Group, editing Event markers on one track likewise applies to all other tracks within that Edit Group.
Elastic Properties

Each clip on an Elastic Audio-enabled track has specific Elastic Audio properties (such as tempo, meter, TCE factor, Input Gain, and Pitch Shift).

The Elastic Properties window lets you view and change the properties for selected clips. For example, you can reduce the Input Gain for Elastic Audio processing to avoid clipping that can occur during processing.

From the Elastic Properties window, you can also filter Event markers for Elastic Audio clips on tick-based tracks. Filtering Event markers can result in better quality Elastic Audio processing of material with ambiguous transients.

To view the Elastic Properties for a clip:

1. Select a clip on an Elastic Audio-enabled track. The track can be either sample- or tick-based.

2. Do one of the following:
   - Choose Clip > Elastic Properties.
   - Right-click the clip and choose Elastic Properties.

Press Option+5 (Mac) or Alt+5 (Windows) on the numeric keypad to open the Elastic Properties window.

Elastic Properties Window

The Elastic Properties window displays information about Elastic Audio processing and analysis for one or more clips. You can also use the Elastic Properties window to adjust Elastic Audio processing and analysis data.

There are different Elastic Properties available in the Elastic Properties window, depending on whether the track is tick-based or sample-based. If the track is sample-based, a reduced set of Elastic Audio Properties are displayed.
Clip Property

The Clip property in the Elastic Properties window displays the name of the clip and indicates whether or not the clip is on a tick or sample-based track. If more than one clip is selected, the number of selected clips is displayed. If clips on both tick and sample-based tracks are selected, only the reduced set of properties are displayed.

Source Length Property
(Tick-Based Tracks Only)

The Source Length property in the Elastic Properties window displays the length of the clip based on the source file in bars and beats. If the length of the source file was analyzed incorrectly, you can change it.

To change the Source Length of a clip:
1. Open the Elastic Properties window for the clip.
2. Do one of the following:
   • Type the correct bar, beat, and tick values in the Source Length field.
   • If the duration was incorrectly analyzed as being half the duration of the source file, click the x2 button.
   • If the duration was incorrectly analyzed as being twice the duration of the source file, click the 1/2 button.

Source Tempo Property
(Tick-Based Tracks Only)

The Source Tempo property in the Elastic Properties window displays the average tempo of the source file, which is calculated based on the detected transient events and the length of the file. If the tempo of the source file was analyzed incorrectly, you can change it.

To change Source Tempo of a clip:
1. Open the Elastic Properties window for the clip.
2. Select the correct note value for the beat from the Tempo Resolution pop-up menu. For example, if the source file is in 5/8, select 1/8 note.
3. Do one of the following:
   • Type the tempo in the Source Tempo field.
   • If the tempo was incorrectly analyzed as being half the tempo of the source file, click the x2 button.
   • If the tempo was incorrectly analyzed as being twice the tempo of the source file, click the 1/2 button.

Meter Field
(Tick-Based Only)

Elastic Audio analysis does not calculate meter and assumes all files are in 4/4. If you work with meters other than 4/4, use the Meter property to correctly identify the source meter.

To change Meter of a clip:
1. Open the Elastic Properties window for the clip.
2. Click in the Meter nominator field and type the correct number of beats per measure. For example, if the clip is in 3/4, type 3.
3. Click the Meter denominator field and type the correct note value. For example, if the meter is in 6/8, type 8.
**TCE Factor Property**

The TCE Factor property in the Elastic Properties window displays the percentage of change applied to the source file. On tick-based tracks, this property is display only and cannot be edited. On sample-based tracks, you can change the TCE Factor to apply TCE to the clip. The percentage of the TCE factor is always calculated in relation to the source file. The TCE Factor value turns red when Elastic Audio processes exceeds the valid range (see “Out of Range Processing” on page 985).

**Event Sensitivity Property**

The Event Sensitivity property in the Elastic Properties window lets you filter Event markers based on the analysis confidence level. The confidence level for any detected transient event is based, in part, on the clarity of the transient. For example, if the file is a drum loop, loud accented hits will be analyzed with a higher degree of confidence than a soft, unaccented hit.

The Event Sensitivity acts like a threshold for showing only the transient events that were detected with a high degree of confidence. In Warp or Analysis track views you will see the number of Event markers decrease or increase as you lower or raise the Event Sensitivity.

Lowering the event sensitivity can help reduce the number of erroneously detected transients. In turn, this can result in better sounding Elastic Audio processing. Pro Tools preserves the detected transients when applying TCE in order to avoid flanging and granulation of the transients. Consequently, false transients are also preserved and the resulting sound quality can be less than desirable. If you are working with audio material that does not have clearly defined transients, you may want to lower the Event Sensitivity in the Elastic Properties, or you may want to even edit the Event markers in Analysis view.

If lowering the Event Sensitivity results in filtering out important Event markers, you can promote those Event markers in Analysis view (see “Promoting Event Markers” on page 987).

> **For REX files, Pro Tools converts the slices as Events with 100% confidence. Consequently, setting the Event Sensitivity from 99% to 1% does not filter out any events based on slices. However, if you set the Event Sensitivity to 0%, all markers are filtered out regardless.**

> **When you change the Event Sensitivity property, Pro Tools writes temporary filtered Elastic Audio analysis files (.aan) to the session’s Rendered Files folder. Any unused temporary filtered analysis files are purged when you close the session.**

**Reset Button**

Click the Reset button in the Elastic Properties window to reset event analysis data for the clip to match the original file. The Event Sensitivity property is reset to 100%.

**Input Gain Property**

It is possible to encounter clipping when time compressing audio. Real-Time Elastic Audio plug-ins provide a Clip indicator to let you know when clipping has occurred and the Elastic Audio plug-in button turns red. Rendered Elastic Audio clips display a Clip indicator on the clip when clipping has occurred (see “Clipping Indicator” on page 975).

If you encounter clipping when processing Elastic Audio, use the Input Gain property in the Elastic Properties window to attenuate the gain of the audio signal before it is processed.
**Pitch Shift Property**  
*(Polyphonic, Rhythmic, and X-Form Only)*

The Pitch Shift property in the Elastic Properties window lets you pitch shift whole clips on Elastic Audio-enabled tracks using the Polyphonic, Rhythmic, and X-Form plug-ins. You apply real-time or rendered pitch shifting in semitones and cents by $+/- 2$ octaves.

**Elastic Audio Clip-Based Pitch Shifting**  
*(Polyphonic, Rhythmic, and X-Form Only)*

In addition to Pro Tools Elastic Audio time compression and expansion capabilities, you can also change the pitch of whole audio clips in semitones and cents in the range of $+/- 2$ octaves.

*Elastic Audio pitch transposition is not supported with the Monophonic algorithm. However, if you switch to the Monophonic plug-in after pitch shifting with another plug-in, the pitch metadata for the clip is maintained.*

*Elastic Audio pitch transposition cannot be applied to looped clips or clip groups.*

**To pitch shift a clip:**

1. Make sure the clip, or clips, you want to pitch shift are on Elastic Audio-enabled tracks (using the Polyphonic, Rhythmic, or X-Form algorithm).
2. With the Grabber or Selector tool, select the audio clip you want to pitch shift. Only clips that are completely selected will be affected.
3. Open the Elastic Properties window for the clip.
4. Adjust the Pitch Shift settings up (“+”) or down (“−”) by an amount in semitones and cents.

**To transpose the pitch of an audio clip in the Transpose window:**

1. Make sure the clip, or clips, you want to transpose are on Elastic Audio-enabled tracks (using the Polyphonic, Rhythmic, or X-Form algorithm).
2. With the Grabber or Selector tool, select the audio clip you want to transpose. Only clips that are completely selected will be affected.
4 Do one of the following:
• Adjust the Transpose By settings by an amount in Semitones and Cents.
• Adjust the Transpose From and To settings by an amount in Semitones and Cents.

⚠️ The Transpose All Notes To and the Transpose In Key settings can only be applied to MIDI notes. When only audio clips are selected, these options are unavailable.

5 Click Apply.

Varispeed and Pitch Shifting

When using the Varispeed algorithm, pitch transposition and time compression/expansion are always linked. If you apply pitch transposition to an audio clip using the Polyphonic or Rhythmic algorithms, that transposition data is stored in the metadata for the clip. Consequently, if you then switch to Varispeed, change the TCE factor, and then switch back to the original Elastic Audio algorithm, the clip will revert to the original amount of pitch shifting while maintaining the amount of time compression/expansion applied by the Varispeed algorithm.

Removing Clip Pitch Shifting

If you have applied any pitch shifting to a clip, you can remove pitch shifting and revert the clip to its original pitch. This can be useful if you are not satisfied with the results and want to revert to the pre–pitch shifted clip.

To remove clip pitch shifting:

1. Select the clip for which you want to remove warping.
2. Do one of the following:
   • Choose Clip > Remove Pitch Shift.
   • With any Edit tool, Right-click the clip and select Remove Pitch Shift.

⚠️ Remove Pitch Shift can only be applied to clips and cannot be applied to clip groups. To remove pitch shifting from clip groups you must first ungroup the clip, then apply Remove Pitch Shift to the underlying clips, and then regroup those clips.

AudioSuite Processing and Elastic Audio Clips

Real-Time Elastic Audio processing is non-destructive. However, since AudioSuite plug-ins process the entire clip and write a new audio file (or actually apply destructive processing), when applying AudioSuite processing to clips on Elastic Audio-enabled tracks, any Elastic Audio processing is rendered first, the rendered file is then processed by AudioSuite, and the resulting new audio file is analyzed for Elastic Audio processing.
Moving Elastic Audio Between Tracks

Pro Tools analyzes, conforms, and commits audio in different ways when moving audio clips between tracks with Elastic Audio enabled and tracks without Elastic Audio enabled. The following table shows the different results for moving clips between real-time Elastic Audio-enabled tracks, Rendered Elastic Audio-enabled tracks, and audio tracks without Elastic Audio.

Moving Elastic Audio between tracks

<table>
<thead>
<tr>
<th>From</th>
<th>To</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>Real-time Elastic Audio–enabled track</td>
<td>Rendered Elastic Audio–enabled track</td>
<td>Render clip with destination track’s Elastic Audio plug-in</td>
</tr>
<tr>
<td>Real-time Elastic Audio–enabled track</td>
<td>Audio track (no Elastic Audio)</td>
<td>Render clip with source track’s Elastic Audio plug-in and commit the clip to the destination track</td>
</tr>
<tr>
<td>Rendered Elastic Audio–enabled track</td>
<td>Real-time Elastic Audio–enabled track</td>
<td>Apply real-time Elastic Audio processing using the destination track’s Elastic Audio plug-in</td>
</tr>
<tr>
<td>Rendered Elastic Audio–enabled track</td>
<td>Audio track (no Elastic Audio)</td>
<td>Commit to track</td>
</tr>
<tr>
<td>Audio track (no Elastic Audio)</td>
<td>Real-time Elastic Audio–enabled track</td>
<td>Calculate Elastic Audio analysis and apply real-time Elastic Audio processing using the destination track’s Elastic Audio plug-in</td>
</tr>
<tr>
<td>Audio track (no Elastic Audio)</td>
<td>Rendered Elastic Audio–enabled track</td>
<td>Calculate Elastic Audio analysis and render the clip using the destination track’s Elastic Audio plug-in</td>
</tr>
<tr>
<td>Pitched Elastic Audio–enabled track</td>
<td>Audio track (no Elastic Audio)</td>
<td>Render clip pitch shift with source track’s Elastic Audio plug-in and commit the clip to the destination track</td>
</tr>
</tbody>
</table>

⚠️ Clips that are committed, either by disabling Elastic Audio on a track or by moving a clip to a track without Elastic Audio enabled, are written to disk as new audio files (see “Committed Clips” on page 971.)
Approximate Waveforms

With Real-Time Elastic Audio processing, the drawing of waveforms is only approximate. For example, if you bus record a Real-Time Elastic Audio processed track, you will notice that the Waveform on the source track does not necessarily exactly match the recorded track. However, be assured that what you hear is an accurate rendition of the Real-Time Elastic Audio processing even if the waveform drawing on the source track is only approximate.

Elastic Audio Preferences

The Elastic Audio settings in the Processing Preferences page determine which Elastic Audio plug-in is used for preview and import, and whether or not new tracks are created with Elastic Audio enabled using the selected default plug-in.

Default Plug-In

Let you select any Real-Time Elastic Audio plug-in as the default plug-in for previewing and importing Elastic Audio. The selected default Elastic Audio plug-in is also used when new tracks are created with Elastic Audio enabled. The Elastic Audio Plug-In selector in Workspace browsers inherits the selected Default Plug-In setting. Likewise, changing the selected plug-in in Workspace browsers updates the selected Default Plug-In setting in the Processing Preferences page.

Default Input Gain

Lets you attenuate the signal input to Elastic Audio plug-ins by 0 to –6 dB for preview and import. If you experience clipping due to Elastic Audio processing during preview or after import, you may want to set the Default Input Gain to slightly attenuate the audio signal input for Elastic Audio processing. This preference also applies to any audio imported to an Elastic Audio-enabled track.

If you commit any clips on a track (by disabling Elastic Audio on the track) that were imported with Input Gain, their clip-based Input Gain is reset to 0.

The Elastic Properties window inherits the Default Input Gain preference. To apply further clip-based Input Gain for Elastic Audio processing, select the clip and adjust the Input Gain setting in the Elastic Properties window (see “Elastic Properties Window” on page 988).

Enable Elastic Audio on New Tracks

When selected, new tracks are created with Elastic Audio enabled. The selected default Elastic Audio plug-in is used.

If the Enable Elastic Audio on New Tracks option is selected, you may want to also select the New Tracks Default to Tick Time-base option in the Editing Preferences page.
Chapter 45: Committing, Freezing, and Bouncing Tracks

Commit Tracks

Pro Tools lets you “commit” tracks, where a new track is created containing the audio rendered from the output of the source track. This is useful for freeing up processing power on your system, as well as for sharing sessions with other systems that may not have all of the plug-ins used in the session.

You can commit the following track types: audio, Auxiliary Input, MIDI (only when routed to an Instrument plug-in), and Instrument tracks. Committing a track is undo-able.

To commit one or more tracks:

1. Select one or more tracks and do one of the following:
   - Choose Track > Commit.
   - Right-click a track and choose Commit Tracks.
   - Press Option+Shift+C (Mac) or Alt+Shift+C.
2. Configure the resulting Commit Tracks dialog as desired (see “Commit Tracks Dialog” on page 996).
3. Click OK.

What Gets Committed

Committing a track always renders the following:
- Clip gain
- Clip effects
- All Inserts (or Commit to Insert)
- HEAT, if Pre-Insert (Pro Tools Ultimate only)
- Elastic Audio

The following source track data is always copied to the new track when committed:
- Timebase
- Elastic Audio Algorithm
- Solo Safe
- Track Input assignment (unless the channel width changes)
- Track Output assignment
- HEAT settings (Pro Tools Ultimate only)

The following source track data can optionally be rendered if selected in the Commit Tracks dialog:
- Pan automation
- Volume automation

The following source track data can optionally be copied if selected in the Commit Tracks dialog:
- Sends
- Group assignments
Clip Boundaries Maintained on Committed Tracks

When committing a track, clip boundaries are maintained with different results depending on the following criteria:

When Commit is set to Selected Tracks, the start and end of each clip on the track is maintained in the rendered copy.

When Commit is set to Edit Selection, the start and end of the edit selection determine the start of the first clip and the end of the last clip on the rendered copy. All clip boundaries in between are maintained.

When the Consolidate Clips option is selected, the rendered copy results in a single consolidated clip.

If the audio signal from a source track remains above –144 dBFS after the end of a clip due to plug-in processing (such as with time base effects like reverb or delay), the rendered clip is extended to include the ongoing audio signal. Once the audio signal drops below –144 dBFS, the rendered clip ends. If the audio signal from the source track continues past the end of one clip and into the beginning of the next, the rendered track merges the source clips into a single clip.

Note that plug-ins with intentionally high noise floors, such as amp modeling plug-ins, may extend rendered clip boundaries.

Committed Auxiliary Input tracks reference the clip boundaries from audio tracks routed to the input of the Auxiliary Input track and preserve them whenever possible.

Commit Tracks Dialog

The Commit Tracks dialog provides several options for how you want selected tracks committed.
Commit

Select either Selected Tracks or Edit Selection to determine what is committed.

**Selected Tracks** Commits all selected tracks from the beginning of the first clip on the track to the end of the last clip on the track. If the Consolidate Clips option is disabled, all clip boundaries are maintained.

**Edit Selection** Commits only the current Edit selection. If the Consolidate Clips option is disabled, all clip boundaries within the edit selection are maintained.

⚠️ *If there is an Edit selection in the session, press Command+Up/Down Arrow (Mac) or Control+Up/Down Arrow (Windows) to switch between the Commit options.*

Consolidate Clips

Select to consolidate all clips on a track (or all clips in the edit selection) into a single new complete file clip.

Render Automation

The Render Automation options determine whether or not Volume and Mute or Pan automation is rendered in committed tracks.

**Volume and Mute** Select to render Volume and Mute automation to committed tracks. If this option is selected, Volume automation is reset to unity and Mute automation is reset to unmuted for all committed tracks. If it is not enabled, Volume and Mute automation playlists are copied to committed tracks.

**Pan** Select to render Pan automation to committed tracks. If this option is selected, Pan automation playlists are reset to the defaults for all committed tracks. If it is not enabled, Pan automation playlists are copied to committed tracks.

Copy

The Copy options determine whether or not sends or Group assignments are copied to committed tracks.

**Sends** Select to copy sends from the source track to the committed track.

⚠️ *Sends cannot be copied if pan automation is rendered resulting in a different channel width and follow main pan (FMP) is not enabled, or if volume automation is rendered and the send is set to pre-fader (PRE).*

**Group Assignments** Select to copy Group Assignments from the source track to the committed track.

Insert After Last Selected Track

Select the Insert After Last Selected Track option to have new committed tracks placed after the last selected track. When disabled, each committed track is placed immediately following the source track.

Source Tracks

The Source Tracks options determine what happens to the source tracks that are committed to new tracks.

**Hide and Make Inactive** Select to hide and make the source tracks inactive.

**Make Inactive** Select to make the source tracks inactive (without hiding them).

**Delete** Select to delete the source tracks.

**Do Nothing** Select to leave the source tracks intact.

⚠️ *Press Command+Left/Right Arrow (Mac) or Control+Left/Right Arrow (Windows) to move through the Source Track options.*
**Offline**

Select to commit selected tracks offline. When this option is deselected, Pro Tools commits selected tracks in real time. Any source tracks that use Hardware Inserts include their processing as well.

**Commit Up To This Insert**

Pro Tools lets you commit a track or Edit selection up to an individual plug-in insert on a track. For example, you might want to commit a virtual instrument plug-in, but continue to adjust processing plug-ins, like EQ or dynamics.

**To commit a track up to a single insert:**

1. Ensure that Inserts view is shown in either the Edit or Mix window.
2. Right-click on the insert up to which you want to commit the track and choose Commit Up To This Insert.
3. Configure the resulting Commit Tracks dialog as desired (see “Commit Tracks Dialog” on page 996).
4. Click OK.

**Committing MIDI**

Pro Tools lets you commit MIDI tracks as long as the MIDI output assignment is set to an Instrument plug-in on another track. Commit is unavailable for MIDI tracks assigned to external MIDI devices.

When more than one MIDI track are routed to the same Instrument plug-in, you can commit one, some, or all of the MIDI tracks. Only selected MIDI tracks are committed. For example, if you have four MIDI tracks routed to a single Instrument plug-in on another track (audio, Auxiliary Input, or Instrument), and you select only MIDI tracks 1–3, the committed track will include only the notes from those tracks while the notes from MIDI track 4 are excluded. Similarly, if you have a complex MIDI arrangement and you only want to commit one part of it, select the MIDI track you want to commit and the rendered audio will only include the MIDI performance from that track.
Committing MIDI Clips by Drag and Drop

You can commit MIDI clips on Instrument tracks by dragging and dropping the MIDI clip from the source track to an audio track of the same channel width.

Committing Tracks with Multiple Output Assignments

If the source track is assigned to multiple output paths of different channel widths, and Pan automation is rendered, a new track with committed audio is created for each channel width. For example, if the output of the source track is assigned to a mono output path, a stereo output path, and a 5.1 output path, three separate tracks with separate committed files are created, each with the corresponding channel width. If the track output is assigned to multiple output paths of the same channel width, only one track and committed file is created.

If Pan automation is not rendered, and the source track is assigned to multiple output paths, the track output assignments are copied to a single committed track.

Committing Tracks with Inserts that Have Auxiliary Output Sends

Some plug-ins, such as Pro Multiband Dynamics and many Virtual Instrument plug-ins, let you assign Auxiliary Output Sends (AOS) from the plug-in to track inputs of other tracks (such as audio or Auxiliary Input tracks). When committing a track that has a plug-in that is assigned to Auxiliary Output Sends, you are prompted to also commit any tracks that are assigned to the plug-in Auxiliary Outputs. Choose Yes to commit those tracks as well or No to commit only the source track.

Rendered File Bit Preference

The Rendered File Bit Depth preference on the Processing Preferences page (Setup > Preferences > Processing) determines the bit depth of new audio files created using the Track Commit command.

Always Use 32-bit

When this option is selected, new audio files created using Track Commit are 32-bit files regardless of the session bit depth. Since the mixer in Pro Tools is 32-bit floating point, it is recommended that you use the default Always Use 32-bit option. This ensures that what you hear on the source track is what you get on the committed track.

Follow Session Settings

When this option is selected, new audio files created using Track Commit command are the same bit depth as the session. If you select the Follow Session Settings option, it is possible the committed audio may clip (since you are truncating from 32-bit floating point to 24- or 16-bit). However, you may want to select this option if you need to have all audio generated by the session follow a particular bit-depth.
Track Freeze

Pro Tools lets you “freeze” audio, Auxiliary Input, and Instrument tracks. When you freeze a track, the source material (audio and MIDI) on the track is replaced with audio that has been processed by all of the plug-ins on the track (or only up to a specified insert), including instrument plug-ins. This process is reversible, so you can “unfreeze” frozen tracks.

Freezing tracks is useful for freeing up processing power in your session for other tracks and processing tasks. It is especially useful for exchanging sessions with other systems that may not have all of the same plug-ins as your system. Rather than committing tracks as final print tracks, you can freeze tracks that you want to share but might want to keep editing while that track is shared or out for review.

The ability to unfreeze a track lets you go back and adjust plug-in settings or edit track material (such as audio or MIDI data to correct a note or rhythm) and then re-freeze the track.

⚠ Editing is disabled on frozen tracks. To make edits, unfreeze the track, make the edits you want, and then re-freeze the track. For more information, see “Editing Restrictions on Frozen Tracks” on page 1002.

To freeze (or un-freeze) one or more tracks, do one of the following:

- Select one or more tracks and choose Track > Freeze (or Unfreeze).
- Click the Track Freeze icon in the Track controls so that it is highlighted (or unhighlighted).
- Right-click on the track name and select Freeze (or Unfreeze).

Option-Shift-Click (Mac) or Alt-Shift-Click (Windows) to freeze all selected tracks. Option-Click (Mac) or Alt-Click (Windows) to freeze all audio, Auxiliary Input, and Instrument tracks.

When a track is frozen, any plug-ins on the track are made inactive. On Instrument tracks, the waveform of the frozen audio is superimposed over the MIDI data on the track as a visual cue.

On Auxiliary Input tracks, the waveform of the frozen audio is shown as a visual cue.
On audio tracks, any plug-ins on the track are made inactive and the waveform updates to show the processed, or “frozen” audio.

**What Gets Frozen**

The following track data is rendered when freezing a track:
- Plug-ins and automation for all plug-ins (except for any plug-ins remaining active when using Freeze to Insert)
- Clip gain
- Clip effects
- HEAT (if set to pre-insert)
- Elastic audio

The following track controls are maintained and are not rendered with track freeze:
- Volume
- Volume Trim
- Mute
- Pan
- Send Level
- Send Level trim
- Send Mute
- Plug-in automation for plug-ins that are not frozen (when using Freeze to Insert)

**Freezing Audio and Instrument Tracks**

When freezing audio and Instrument tracks, the rendered (“frozen”) audio starts at the beginning of each clip on the track and ends either at each clip end point or after the processed audio of the clip (such as with time-based plug-in processing like reverb or delay) falls below –144 dBFS for at least 60 seconds. Muted clips are not rendered.

**Freezing Auxiliary Input Tracks**

When freezing Auxiliary Input tracks, audio is rendered (“frozen”) starting when audio is detected at the track input. Audio stops rendering when the audio signal drops below –144 dBFS for 60 seconds.

**Freezing Tracks with Inserts that Have Auxiliary Output Sends**

Some plug-ins, such as Pro Multiband Dynamics and many Virtual Instrument plug-ins, let you assign Auxiliary Output Stems (AOS) from the plug-in to track inputs of other tracks (such as audio or Auxiliary Input tracks). When freezing a track that has a plug-in that is assigned to Auxiliary Output Stems, you are prompted to also freeze any tracks that are assigned to the plug-in Auxiliary Outputs. Choose Yes to freeze those tracks as well or No to freeze only the source track.
**Freeze Up To This Insert**

Pro Tools lets you freeze a track up to an individual plug-in insert on the track. For example, you might want to freeze a virtual instrument plug-in, but continue to adjust processing plug-ins, like EQ or dynamics.

**To freeze a track up to a single insert:**

1. Ensure that Inserts view is shown in either the Edit or Mix window.

2. Right-click on the insert up to which you want to freeze the track and choose Freeze Up To This Insert.

When any plug-in processing on a track is frozen, frozen inserts are italicized and grayed out. The also display the Track Freeze icon.

**Editing Restrictions on Frozen Tracks**

Frozen tracks disallow most editing functions. To edit a frozen track, unfreeze it, make your edits, and then re-freeze the track.

The following editing actions are *not* allowed on frozen tracks:

- Editing clips or clip contents is disallowed.
- Elastic Audio is disallowed.
- Clip gain and clip effects are disallowed on frozen tracks.
- AudioSuite rendering is disallowed on frozen tracks.
- Tempo changes, Song Start changes, and enabling or disabling the Conductor Track are not allowed when there are frozen tracks in the session.
- Insert and Cut Time operations are disallowed in a session if there are frozen tracks.
- HEAT is unavailable for frozen Auxiliary Input and Instrument tracks.
- Instrument Tracks are removed from the MIDI Editor window while frozen and MIDI parameters including Real Time Quantize settings cannot be adjusted until the track is unfrozen.
- Clips used on a source playlist for a frozen track cannot be removed from the session until the track is unfrozen.

The following editing actions are allowed on frozen tracks:

- Editing and writing of all basic track automation parameters including sends.
- Editing and writing of automation on unfrozen plug-ins as well as addition and removal of plug-ins on unfrozen inserts (when using the Freeze Up to This Insert functionality)
- Changing the track output path.
Global Freeze Tracks

The Global Freeze Tracks icon lights when one or more tracks in the session are frozen. You can use the Global Freeze Tracks icon to freeze (or unfreeze) all audio, Auxiliary Input, and Instrument tracks in the session or project. You can also specify which track types you want (or don’t want) to freeze.

- Tracks cannot be frozen while hidden or inactive.

Global Freeze Tracks, one or more tracks frozen

To globally freeze or unfreeze tracks, do one of the following:

- Option-click (Mac) or Alt-click (Windows) the Global Freeze icon so that it is lit (frozen) or unlit (unfrozen).
- Right-click the Global Freeze icon and choose Freeze All or Unfreeze All.

To freeze (or unfreeze) only certain track types:

1. Right-click the Global Freeze icon and select (or deselect) which track types you want to include (or exclude):
   - Include all Audio Tracks
   - Include all Aux Tracks
   - Include all Instrument Tracks

2. Do one of the following:
   - Command-click (Mac) or Control-click (Windows) the Global Freeze icon.
   - Right-click the Global Freeze icon and choose Freeze All or Unfreeze All.

   If any of the Include options are unselected, you can still Option-click (Mac) or Alt-click (Windows) the Global Freeze icon to freeze (or unfreeze) all tracks of all types. The selected Include options remain selected.

Bounce Track

Pro Tools lets you bounce individual tracks from your session or project. Track Bounce is useful for delivering audio files from tracks in the session without having to re-route sub-master stems or individual tracks for bus recording. You can just select the desired source tracks and Bounce them to disk.

You can Bounce the following track types: audio, Auxiliary Input, Master Fader, and Instrument tracks.

To bounce a track from your session or project:

1. Do one of the following:
   - Select the track you want to bounce and then choose Track > Bounce.
   - Right-click the track you want to bounce and select Bounce.
   - Press Command+Option+Shift+B (Mac) or Control+Alt+Shift+B (Windows).

2. In the Track Bounce dialog, configure the options as desired.

3. Click Bounce.
If there is a timeline selection, the bounce includes only the selection. Otherwise, the bounce starts at the beginning of the session or project and ends with the last sample of audio on the track.

If the source track is assigned to multiple output paths of different channel widths, and Pan automation is rendered, a new file is created for each channel width. For example, if the output of the source track is assigned to a mono output path, a stereo output path, and a 5.1 output path, three separate files are created, each with the corresponding channel width. If the track output is assigned to multiple output paths of the same channel width, only one file is created. If Pan automation is not rendered, only one new file is created and it will have the channel width of the Format selected in the Track Bounce dialog.

**Track Bounce Dialog**

The Track Bounce dialog provides the same options as the Bounce dialog (see “Bounce Options” on page 1190), but with the additional option to render (or not render) track volume and pan automation.

**Render Automation**

The Render Automation options determine whether or not Volume or Pan automation is rendered for bounced tracks.

**Volume** Select to render Volume automation from bounced tracks.

**Pan** Select to render Pan automation from bounced tracks.
Chapter 46: Event Operations

Various events in Pro Tools (such as groups of MIDI Notes, audio clip start times or sync points, and whole clips) can be transformed with Event Operations.

Event Operations Window

The Event Operations window provides commands to transform groups of MIDI notes to affect pitch, timing, and phrasing. The Quantize and Restore Performance Event Operations can also be applied to audio clip start times (or sync points) and Elastic Audio events. The Transpose Event Operation can also be applied to whole clips on Elastic Audio-enabled tracks.

The Event Operations window has nine pages, one for each Event Operations command.

- Quantize
- Restore Performance
- Flatten Performance
- Change Velocity
- Change Duration
- Transpose
- Select/Split Notes
- Input Quantize
- Step Input

The Event Operations window can be left open. This provides quick access to apply a command or try out different options for a particular command.

💡 You can also apply quantize, duration, delay, and transpose to MIDI nondestructively using MIDI Real-Time Properties. See “MIDI Real-Time Properties” on page 780.

To open a specific Event Operations window page:

- Choose Event > Event Operations, followed by one of the Event Operations (such as Quantize).
To open the last active Event Operations window page:


💡 To open the Event Operations window, press Option+3 (Mac) or Alt+3 (Windows).

💡 If the Event Operations window is already open, you can select any of the pages from the pop-up menu at the top of the window.

To apply an Event Operations command, do one of the following:

- Click Apply or press Enter on the numeric keypad. This applies the command and leaves the window in the foreground.

- Press Return (Mac) or Enter on the alphanumeric keyboard (Windows). This applies the command and closes the window.

⚠️ When using the Event Operations window and MIDI Real-Time Properties at the same time, Event Operations are applied to the actual MIDI data. MIDI Real-Time Properties are applied on top of the actual MIDI data.

To undo a command in the Event Operations window:

- Choose Edit > Undo.

Using the Event Operations Window

Use the following methods to configure options in the Event Operations window:

- To move forward and back through the various fields, press Tab or Shift+Tab.

- Increment or decrement selected fields with the Up and Down Arrow keys. Hold these keys to scroll quickly through the values.

- Drag up or down in a selected field to scroll to a new value.

- Press Command (Mac) or Control (Windows) while adjusting sliders for finer resolution.

- For selected pitch and velocity fields, play a note on your MIDI controller keyboard to automatically enter it.

- Changing a value for a particular control (such as the Swing Percentage in the Quantize window), automatically enables the control.

Quantize Command

The Quantize command in the Event Operations window can be applied to MIDI notes, audio clips, and Elastic Audio events. For MIDI, quantization adjusts MIDI note locations and durations so that timing is improved, or so that a particular rhythmic “feel” is achieved. For audio clips, quantization adjusts the start times (or sync points) of audio clips. For Elastic Audio, quantization adjusts to the location of detected transient events and applies Elastic Audio processing accordingly.
The Quantize Event Operations window lets you apply Grid Quantize based on rhythmic values (such as a 16th note) or using Groove Quantize based on Groove Templates. Slightly different options are provided for Grid Quantize and Groove Quantize.

The Quantize Event Operation and Quantize to Grid commands can both be used to quantize clips. However, each command also has a specific additional use.

Use the Quantize to Grid command (Clip > Quantize to Grid) to adjust the start points (or sync points) for selected clips. The Quantize to Grid command can be applied to both MIDI and audio clips (see “Quantizing Clips to Grid” on page 663).

The Quantize Event Operation, on the other hand, can be applied to MIDI notes and Elastic Audio events individually in addition to audio clip start times (or sync points). Some notes or events may be moved back in time, others forward. For MIDI notes only, some may be shortened, some lengthened, and some more drastically affected than others.

To open the Quantize window:

- Choose Event > Event Operations > Quantize.

Press Option+0 (Mac) or Alt+0 (Windows) to open the Quantize window.

To select Grid Quantize:

- From the Quantize Grid pop-up menu, select a note value.

To select Groove Quantize:

- From the Quantize Grid pop-up menu, select a groove template.

You can also quantize MIDI input, see “Input Quantize Command” on page 1027.

The settings in the Quantize window are saved with each session. To store your favorite settings for use in future sessions, save them as part of a session template (see “Session Templates” on page 176).
Grid Quantize

The Quantize window can apply Grid Quantize when a specific rhythmic value is selected in the Quantize Grid pop-up menu. When a groove template is selected in the Quantize pop-up menu, Groove Quantize can be applied. For information on Groove Quantize, see “Groove Quantize” on page 1012.

What to Quantize

The What to Quantize settings determine what aspects of any selected MIDI notes are quantized: Note Ons (attacks), Note Offs (releases), or both. You can also select whether to quantize audio clips or Elastic Audio events. Depending on what type of track material is selected, not all options will be available. If only MIDI is selected, the Audio Clips and Elastic Audio Events options are unavailable. If only audio is selected, the Note On, Note Off, and Preserve Note Duration options are not available.

**Note On** When selected, MIDI note start points are quantized.

**Note Off** When selected, MIDI note end points are quantized.

**Preserve Note Duration** When selected, MIDI note durations are preserved.

When deselected with the Note On option selected, note end points are not moved.

When deselected with the Note Off option selected, note start points are not moved.

If the options for both Note On and Note Off are selected, the Preserve Note Durations option is unavailable.

The following figure shows how MIDI notes are adjusted by the different What To Quantize options.

Before quantizing, followed by two examples showing the results of different What To Quantize settings

**Audio Clips** When selected in the What to Quantize pop-up menu, Quantize is applied to clip start times (or sync points if present) for selected audio clips. MIDI clips are not affected. Typically, you will only want to apply quantization to sliced audio clips or clip groups (such as imported REX files or clips created using the Separate Clips at Transients command or Beat Detective). Quantization can be applied to mixed selections of MIDI notes and audio clips.

**Elastic Audio Events** When selected in the What to Quantize pop-up menu, Quantize is applied to detected transient events within the Edit selection on Elastic Audio-enabled tracks. Quantization can be applied to mixed selections of MIDI notes and Elastic Audio events. Warp markers are created automatically on top of Event markers nearest the quantize grid. Quantize then uses these Warp markers to apply quantization.
Quantize Grid

Quantize Grid Pop-Up Menu Determines the beat boundaries to which MIDI notes, Elastic Audio events, and audio clip start points are aligned. Any size from whole notes (1/1) to sixty-fourth notes (1/64), including dotted and triplet values, can be selected for the Grid size.

💡 Relative Grid mode does not affect the Quantize Grid.

Tuplet Select the Tuplet option to quantize according to irregular note groupings, such as quintuplets (5 in the time of 4). The Quantize Grid for tuplets is calculated from the note size selection and the Tuplet value. For example, if an sixteenth note equals 240 ticks, quintuplet sixteenth notes with 5 in time of 4 would yield a Grid size of 192 ticks or (240 ticks/5)*4.

Offset Grid By Offsets the Quantize Grid forward or back in time by a specified number of ticks. Use this option to achieve a pushed feel (by using negative values) or a laid back feel (by using positive values).

💡 To Quantize just the backbeats, set the Quantize Grid to half-notes with an Offset of 960 ticks.

Randomize When selected, MIDI notes, Elastic Audio events, and audio clips are moved randomly forward or back in time (after the Quantize occurs). For example, with the Quantize Grid set to eighth notes and Randomize set to 50%, notes and events are placed up to a 32nd note before or after the beat boundary. The Randomize setting also affects note durations (if Releases is selected).

Additional Grid Quantize Options

Additional Grid Quantize options include:

Swing When selected, every other Grid boundary is shifted by the specified percentage value (0–300) to achieve a “swing” feel. A Swing value of 0% yields no swing, while 100% yields a triplet feel. Settings above 100% progressively narrow the swing until the maximum of 300%, at which every other Grid boundary is moved to the next Grid point.

Include Within When selected, MIDI Note Ons and MIDI Note Offs, Elastic Audio events, and audio clips are only quantized if located within the specified percentage of the Quantize Grid. Use this option to clean up downbeats without affecting notes that are “swung” or wildly off the beat.

The following figure shows the Quantize Grid set to quarter notes with the Include Within option set to 50%. In this example, only the MIDI Note Ons and MIDI Note Offs falling within the shaded area (equivalent to an eighth note area around each beat) are quantized.

💡 Include Within option
Exclude Within When selected, MIDI Note Ons and MIDI Note Offs, Elastic Audio events, and audio clips are not quantized if located within the specified percentage of the Quantize Grid. Use this option to preserve the feel of events close to the beat, while correcting others that are drastically away from the beat.

The following figure shows the Quantize Grid set to quarter notes with the Exclude Within option set to 25%. In this example, MIDI Note Ons and MIDI Note Offs falling within the shaded area (equivalent to a sixteenth note area around each beat) are not quantized.

<table>
<thead>
<tr>
<th>2</th>
<th>1</th>
<th>0</th>
<th>0</th>
<th>0</th>
<th>2</th>
<th>3</th>
<th>0</th>
<th>0</th>
</tr>
</thead>
<tbody>
<tr>
<td>Exclude within: 0%</td>
<td>Exclude within: 25%</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Exclude Within option

Strength When selected, MIDI notes, Elastic Audio events, and audio clips are moved a percentage toward the Quantize Grid. Lower percentages preserve the original feel of the events, higher percentages align the notes more tightly to the Grid.

Grid Quantize Examples

The following examples illustrate some of the more common uses for Grid Quantize.

If you intend to loop playback while quantizing, you may want to deselect Options > Link Timeline and Edit Selection. This ensures that the play range does not change when selected events are moved in the course of quantizing and undoing.

⚠️ After quantizing, you can use Restore Performance to revert to the original version (see “Restore Performance Command” on page 1018.)

Straight Quantize

To quantize to a straight sixteenth note feel:

1 Select the range of MIDI notes, Elastic Audio events, or audio clips to be quantized.

2 Choose Event > Event Operations > Quantize.

3 Under What to Quantize, select the Note On option for quantizing MIDI notes. To also quantize MIDI note durations, select the Note Off option. If you are quantizing audio, select Audio Clips or Elastic Audio Events from the pop-up menu.

4 From the Quantize Grid pop-up menu, select sixteenth notes (1/16). Make sure that the other options for Tuplet, Offset Grid By, and Swing are not selected.

5 Ensure that the remaining Quantize options are deselected.

6 Click Apply.

Quantizing While Preserving the Original Feel

You can quantize less strictly, to preserve the original feel of your recorded MIDI and audio tracks.

To quantize while preserving the original feel:

1 Select the range of MIDI notes, Elastic Audio events, or audio clips to be quantized.

2 Choose Event > Event Operations > Quantize.

3 Under What to Quantize, select the Note On option for quantizing MIDI notes. To also quantize MIDI note durations, select the Note Off option. If you are quantizing audio, select Audio Clips or Elastic Audio Events from the pop-up menu.

4 From the Quantize Grid pop-up menu, select the note value you want to use.
5 Ensure that the other options for Tuplet, Offset Grid By, and Swing are not selected.

6 Select the Exclude Within option with a value of 10–15%.

7 Select the Strength option with a value of 70–80%.

8 Ensure that the remaining Quantize options are deselected.

9 Click Apply.

10 Audition the change. If the desired effect is not achieved, undo the edit and experiment with different values for Exclude Within and Strength.

Quantizing with Swing

If you are working with MIDI hi-hats or bass lines or audio equivalents, you may want to apply more of a swing feel when quantizing.

To quantize with an eighth note swing feel:

1 Select the range of MIDI notes, Elastic Audio events, or audio clips to be quantized.

2 Choose Event > Event Operations > Quantize.

3 Under What to Quantize, select the Note On option for quantizing MIDI notes. To also quantize MIDI note durations, select the Note Off option. If you are quantizing audio, select Audio Clips or Elastic Audio Events from the pop-up menu.

4 From the Quantize Grid pop-up menu, select the note value you want.

5 Select the Swing option with the Swing percentage you want:
   • For a light swing, use 12%.
   • For a tighter swing-like groove, use 24%.
   • For a true “triplet-like” swing feel, use 50–75%.

6 Ensure that the options for Tuplet, Offset Grid By, and Randomize are not selected.

7 Click Apply.

8 Audition the change. If the desired effect is not achieved, undo the edit and experiment with different Swing percentages.

Quantizing with Randomize

If quantized events sound too mechanical or “on the beat,” use the Randomize option in the Quantize window to make them sound more natural.

To “humanize” the rhythmic feel of events:

1 Select the range of MIDI notes, Elastic Audio events, or audio clips to be quantized.

2 Choose Event > Event Operations > Quantize.

3 Under What to Quantize, select the Note On option for quantizing MIDI notes. To also quantize MIDI note durations, select the Note Off option. If you are quantizing audio, select Audio Clips or Elastic Audio Events from the pop-up menu.

4 From the Quantize Grid pop-up menu, select the note value you want to use.

5 Select the Randomize option and enter a value of 5%.

6 Click Apply.

7 Audition the change. If the desired effect is not achieved, undo the edit and experiment with different Randomize percentages.

Experimenting with Grid Quantize

When using the Quantize command, you may have to experiment with many of the controls to achieve the results you want. Try different values for Include Within and Exclude Within, and Strength;
these controls determine which notes are affected and how drastically they are changed. Additionally, use the Randomize option, which adds a percentage of randomness to the quantization, to make tracks sound less “mechanical.”

**Groove Quantize**

In the Quantize window, you can apply Groove Quantize when a groove template is selected in the Quantize Grid pop-up menu. Groove quantize adjusts MIDI note locations and durations, Elastic Audio events, and audio clips according to a groove template rather than a strict quantization grid. Groove templates extract the particular rhythmic feel of a recorded audio or MIDI performance so that it can be applied to another MIDI sequence or audio selection. DigiGroove templates can be generated using Beat Detective.

**Groove Templates**

Groove templates (such as DigiGroove templates) are “quantization maps” derived from real musical performances. The rhythmic character of each performance is analyzed and stored as a groove template. Groove templates can be used to transfer the feel of a particular performance to MIDI notes (Timing, Duration, and Velocity), Elastic Audio events, and audio clips.

DigiGroove templates can be created using Beat Detective. Beat Detective analyzes an audio selection for transient peaks according to a defined threshold and maps the rhythmic relationships to a 960 parts per quarter note (ppq) template. Beat Detective can also analyze a MIDI selection for Note Ons and velocities to generate groove templates. These templates can then be used with Groove Quantize, as well as with Beat Detective.

```
For information on Beat Detective and creating groove templates, see Chapter 33, “Beat Detective.”
```

DigiGroove templates are also available from Avid and third-party manufacturers.

```
Numerical Sound’s Feel Injector Templates (960 ppq) are supported in Pro Tools, but DNA Groove Templates (192 ppq) are not.
```

**Groove Quantize Settings**

**Quantize Grid Pop-Up Menu** Determines which groove template to use for quantization. All groove template files in the Grooves folder are available in the Quantize Grid pop-up menu.

Grooves files are stored in the Grooves folder in the Root Settings Folder. You can change the location of the Root Settings Folder in the Operation Preferences (see “User Media and Settings Location” on page 110).
If you organize your groove templates in sub-folders in the Groove folder, they appear as submenus in the pop-up menu. Once you have selected a groove template, specific information about the template’s meter and duration (in bars) is displayed under the pop-up menu.

**Show Comments** The Comments field displays any comments saved with the groove template from Beat Detective. The Comments field cannot be edited in the Quantize page, but can be edited when saving a groove template from the Groove Quantize page.

**Pre-Quantize** Enable to hard quantize the selected MIDI notes to a sixteenth-note grid before applying Groove Quantize.

**Groove Quantize Options**

**Timing** Enable to apply Groove Quantize to the selected MIDI notes, Elastic Audio events, or audio clips. Use the slider to change the amount of quantization applied to the selection. If the slider is set to 0%, there is no change in timing. A setting of 100% moves notes to the underlying template locations. If the slider is set to 200%, events move to a tick location that is twice the difference between the original event location and the position of the referenced template event.

For example, if an event was played at Bar 1|1|060 (a 16th note), and the corresponding template event is at 1|1|073, a slider value of 100% results in the event being shifted to 1|1|073 (a slider value of 200% shifts the note to 1|1|086).

The default value for the Timing slider is 100%.

**Duration** Enable to influence the durations of the selected MIDI notes. The Duration option does not apply to audio selections. At a setting of 100%, durations are changed to match the current groove template. Set to 200%, durations increase and decrease based on the ratio of the original duration of the selected notes and the durations in the template.

The default value for the Duration slider is 100%.

**Beat Detective does not extract duration information from audio performances. DigiGroove templates created using Beat Detective contain a fixed duration value that is 50% of the selected template resolution (see “Defining a Beat Detective Selection” on page 722).**

**Velocity** Enable to influence the velocities of the selected MIDI notes. The Velocity option does not apply to audio selections. If the slider is set to 0% there is no change to the selected velocities, a setting of 100% sets all velocities to match the current groove template. A velocity setting of 200% typically results in over-exaggerated velocities—loud notes increasing and soft notes decreasing in volume.

For example, if two adjacent notes have equal velocities of 80, and the two corresponding template velocities are 70 and 90, setting the slider to 200% changes the velocities to 60 and 100.

The default value for the Velocity slider is 100%.

**Recalling Options Slider Settings**

To Save the groove template with the current Options Slider Settings:

1. In the Quantize window, select Recall with Template if you want to restore all Groove Quantize Options to the settings that are saved with the current template.

2. Click the Save button.
3 Enter or edit any comments you want to save with the template.

4 Do one of the following:
• Click the Save button to save the groove template with the current Options Slider Settings.
• Click the Save As button to make a copy of the groove template with the current Options Slider Settings. In the resulting Save dialog, enter a name for the copy and click Save.

Slider settings can be lost if any of the following operations are performed without saving the settings first:
• Another Event Operations window is selected.
• The Event Operations window is closed.
• You switch to another groove template.

Applying Groove Templates

Groove templates can be of any length and can be applied to any number of bars. Typically, you will apply groove templates to selections of the same bar length and meter. However, groove templates can be applied to different meters—for example, a groove template in 6/8 can be applied to a selection in 4/4. Also, it is not necessary to start on the downbeat when making a selection to apply a groove template.

To apply Groove Quantize:

1 With the Grabber or Selector tool, select the MIDI notes, Elastic Audio events, or audio clips you want to Groove Quantize.

2 Choose Event > Event Operations > Quantize.

3 Select a groove template from the Grid Quantize pop-up menu.

4 Enable Timing, Duration, and Velocity, and adjust their sliders to the percentages you want.

5 If desired, enable Pre-Quantize.

6 Click the Apply button.

A DigiGroove template (derived from the audio shown) applied to a series of sixteenth-notes with Timing and Velocity both set to 100%
**Mapping Groove Templates**

Pro Tools applies groove templates relative to the song start. For example, a two-bar groove template repeats starting at every odd-numbered bar in the session (bar 1, 3, 5, 7…).

**Template Mapping for Equal Meters And Odd Numbered Bars**

If a two-bar groove template is applied to a selection of one bar of the same meter, only the first bar of the template is used. If the selection does not encompass bar boundaries, for example 1|2|000 to 2|1|000, the groove template only modifies the selected notes.

**Template Mapping for Equal Meters And Even Numbered Bars**

If a selection starts on an even bar, only the appropriate portion of the groove template will be used. For example, if the selection is two bars long and starts on an even bar, the template applies bar 2 before bar 1.

**Template Mapping for Unequal Meters**

In cases where the Groove Templates and track selections are based on different meters, the template will be repeated or truncated to match the number of beats in the selection.

For example, if the Groove Template contains fewer beats than the selection, such as a one-bar template in 6/8 being applied to a one-bar selection in 4/4, the template repeats to make up the difference.

If the Groove Template contains more beats than the selection on a track, such as a one-bar template in 6/4 being applied to a two-bar selection in 4/4, only uses the appropriate number of beats.
Behavior for Mixed Meters

If the selection contains mixed meters, the groove template will always be mapped so that the downbeats are aligned. For example, if the Groove Template consists of one-bar of 4/4 and it is being applied to a selection of one-bar of 4/4 followed by a bar of 7/16 and one-bar of 5/8, the downbeat of the Groove Template is aligned with the downbeats in the selection and only uses the appropriate number of beats from the Groove Template.

Quantizing Elastic Audio

Pro Tools lets you apply Quantize to Elastic Audio events as well as MIDI notes. Quantize can be applied to Event and Warp markers closest to the quantize grid on Elastic Audio-enabled tracks, regardless of whether they are sample- or tick-based. When quantizing, Event markers closest to the quantize grid are promoted to Warp markers and all Warp markers closest to the quantize grid are quantized based on the Quantize settings.

Quantization can also be applied to clip start times (or sync points) on all audio tracks, whether they are Elastic Audio-enabled, or sample- or tick-based. This lets you quickly quantize audio clips without applying TCE, and is especially useful when working with “one-shot” clips (single-event clips) such as sliced clips or clip groups.

Use Restore Performance to undo quantization of audio and MIDI. See “Restore Performance Command” on page 1018.

To quantize Elastic Audio events:

1. Select the audio you want to quantize on Elastic Audio-enabled tracks. (Audio not on Elastic Audio-enabled tracks will not be quantized.)
2. Choose Events > Event Operations > Quantize.
3. In the Quantize window, select Elastic Audio Events from the What to Quantize pop-up menu.
4. Set the Quantize Grid and Options settings.
5. Click Apply.
The Warp and Event markers closest to the Quantize Grid are quantized accordingly. TCE is applied between these markers and all other markers maintain their position relative to the Quantize Grid.

Quantizing Audio Clips

Pro Tools lets you quantize audio clip start times (or sync points) using the Quantize operation. Audio clip start times (or sync points) are quantized to the nearest quantize grid value.

To quantize audio clips:

1. Select the audio clips you want to quantize.

2. Choose Events > Event Operations > Quantize.

3. In the Quantize window, select Audio Clips from the What to Quantize pop-up menu.

4. Set the Quantize Grid and Options settings.

5. ClickApply.

The clip start times (or sync points if present) are quantized according to the quantize settings.

Quantizing Mixed Selections

You can apply Quantize to both MIDI notes and audio clips, or both MIDI notes and Elastic Audio events at the same time. However, you cannot apply Quantize to both audio clips (non-Elastic Audio) and Elastic Audio events at the same time.
**Restore Performance Command**

The Restore Performance command in the Event Operations window reverts all selected MIDI notes to their original state (when first recorded or manually inserted), even after the session has been saved, or the Undo queue has been cleared. Restore Performance can also be applied to quantized Elastic Audio Events or quantized audio clips.

The following MIDI note, Elastic Audio Event, and audio clip attributes can be restored:

- **Timing (Quantization)** Restores the original start times of the selected notes, audio clips, and Elastic Audio Events. For MIDI only, this changes the durations of selected notes if the Duration option is not enabled.

- **Duration** Restores the original durations of the selected notes. If the Timing (Quantization) option is not enabled, the start times of selected notes are not restored and the end times are affected. Duration has no effect on audio.

- **Velocity** Restore the original velocities of the selected notes. Velocity has no effect on audio.

- **Pitch** Restores the original pitches of the selected notes and pitch shifted Elastic Audio clips.

**To restore the original time, duration, velocity, or pitch for selected MIDI notes, audio clips, or Elastic Audio Events:**

1. Select the MIDI notes, audio clips, or Elastic Audio Events you want to restore.
3. Select which performance attributes to restore.
4. Click Apply.

Any changes made through the Quantize, Change Duration (MIDI only), Change Velocity (MIDI only), or Transpose commands are undone and the original “performance” is restored. Also, any MIDI notes that were recorded with Input Quantize enabled are restored (see “Input Quantize Command” on page 1027).

- **⚠️ Restore Performance does not undo cut, copied, pasted, or otherwise manually moved MIDI notes, audio clips, or Elastic Audio events.**

- **⚠️ Restore Performance does not undo Duration changes made by trimming the start of a note. Trimmed the start of a note essentially changes the note’s timing, and therefore is treated by Pro Tools the same as if it were manually moved.**
Removing Input Quantize

Restore Performance can be used to remove quantization on input for MIDI notes. For example, if you recorded a performance with Input Quantize on, you can still restore the performance as it was actually played.

For information on Input Quantize, see “Input Quantize Command” on page 1027.

Flatten Performance

The Flatten Performance command in the Event Operations window “locks in” the current performance for selected notes, creating a new “restore to” state for the specified note attributes when using Restore Performance.

To flatten the performance:
1 With the Grabber or Selector tool, select the MIDI notes you want to flatten.
2 Choose Event > Event Operations > Flatten Performance to open the Flatten Performance page.
3 Select the note attributes to flatten. (For descriptions of these attributes, see “Restore Performance Command” on page 1018).
4 Click Apply.

Change Velocity

The Change Velocity command in the Event Operations window automatically adjusts Note On (attack) and Note Off (release) velocities for selected MIDI notes. Use it to make notes louder or softer, or to create crescendos or decrescendos.

Velocities can also be edited manually with the Pencil and Grabber tools (see “Manually Editing MIDI Notes” on page 752).

You can also change velocity nondestructively in real-time using MIDI Real-Time Properties. See “MIDI Real-Time Properties” on page 780.

Fading Velocities

To change velocities smoothly over time:
1 Select the range of MIDI notes to be edited.
2 Choose Event > Event Operations > Change Velocity.
3 Select the Change Smoothly option with the range set from 127 to 0.
4 Click Apply.
Preserving Existing Velocity Relationships

To partially preserve the existing velocity relationships and still achieve velocity fades, use the option for Change Smoothly by Percentage. The following figures illustrate the difference between the two Change Smoothly options.

3. Select the Scale By option with the percentage value set to 120.
4. Click Apply.

Change Velocity Settings

Scaling Velocities

Many times existing note velocities already have the relationship between them that you want, but are either too soft or too loud overall. In these instances, use the Scale By option.

For example, to make velocities 20% louder:
1. Select the range of MIDI notes to be edited.
3. Select the Scale By option with the percentage value set to 120.
4. Click Apply.

Velocity values usually affect the loudness of MIDI notes. Depending on how velocity is mapped with any MIDI instrument, velocities may also affect other aspects of an instrument’s sound (such as filter cutoff, envelopes, and modulations).

The settings in the Change Velocity window are saved with each session. To store your favorite settings as the default for use in future sessions, save them as part of a session template (see “Session Templates” on page 176).
**Note On** Applies the Change Velocity options to the MIDI Note On.

**Note Off** Applies the Change Velocity options to the MIDI Note Off.

💡 **While there are options for adjusting both the Note On (attack) and Note Off (release) velocities for notes, most MIDI devices ignore release velocity information. To see if your instrument supports release velocities, see the manufacturer’s documentation.**

**Set All To** Sets all velocities to the specified value (1–127).

**Add** Adds to existing velocity values by the specified amount (1–127).

**Subtract** Subtracts from existing velocity values by the specified amount (1–127).

**Scale By** Scales all velocities by a percentage amount (1–400%).

**Change Smoothly** Allows velocities to change smoothly from one value to another over time.

**Change Smoothly by Percentage** Allows velocities to change smoothly from one percentage value to another over time.

The curve for this change can be adjusted (+/- 99) to affect how gradually the change occurs.

**Limit To** When selected, restricts the Change Velocity command to a minimum and maximum range after the selected Change Velocity option has been applied (and also after any randomization has been applied).

**Randomize** When selected, the selected Change Velocity option is randomized by the specified percentage value after the selected Change Velocity option has been applied. For example, with the Set All To option enabled and set to a value of 64, and with Randomize enabled and set to a value of 50%, the resulting velocities will be anywhere between 48 and 80 (+/- 25% of the velocity value).

**To randomize selected velocities without applying any other Change Velocity options:**

1. Enable the Scale By option and set it to 100%.
2. Enable Randomize and set the amount of randomization you want.
3. Click Apply.

**Velocity Ranges**

The valid range for MIDI note velocities is 1–127. The Change Velocity command will never result in moving velocities outside this range; 1 is always the lowest and 127 is always the highest. This means that you can encounter situations where the Change Velocity command has no effect on a particular note.

For example, if a note with a velocity 64 is scaled by 200%, the new velocity would be 127. Attempting to scale or increase the velocity any further yields no further change.

**Change Duration**

The Change Duration command in the Event Operations window adjusts durations for selected MIDI notes. Use it to affect the articulation of the selected notes by making them more staccato or legato.

💡 You can also change note duration non-destructively in real-time using MIDI Real-Time Properties. See “MIDI Real-Time Properties” on page 780.
Change Duration Settings

The settings in the Change Duration page are saved with each session. To store your favorite settings as the default for use in future sessions, save them as part of a session template (see “Session Templates” on page 176).

Set/Add/Subtract/Scale Option

**Set All To** Sets all durations to a length specified in quarter notes and ticks.

**Add** Adds to the durations by a specified number of quarter notes and ticks.

**Subtract** Subtracts from the durations by a specified number of quarter notes and ticks.

**Scale by** Shortens or lengthens durations based on a percentage value (1–400%).

**Legato**

Enable the legato option to add legato to the MIDI selection. Select Gap or Overlap from the Legato pop-up menu and enter the gap or overlap in beats and ticks.

**Remove Overlap**

The Remove Overlap option removes any note overlap for all notes of the same pitch. This command is different from Legato in that non-overlapping notes of the same or different pitches remain unchanged. To create a gap between previously overlapping notes, enter the gap in beats and ticks.

**Transform Sustain Pedal To Duration**

The Transform Sustain Pedal To Duration option extends the length of all notes that are sounding when the sustain pedal (controller 64) is down (64 to 127) to the point when the sustain pedal goes up (0 to 63). Enable the Delete Sustain Pedal Events option to convert sustain pedal events to note durations. Converting sustain pedal events to note duration can greatly simplify editing while maintaining the desired performance effect. For example, if a sustain pedal down event is deleted while editing, the subsequent MIDI performance loses its legato effect.

**Change Continuously Option**

The Change Continuously option lets you change the duration of notes continuously in ticks or by percentage. Adjust the Curve slider to modify the shape of the change.

**Change Continuously in Ticks** Allows note lengths to change smoothly from one duration to another over time. Duration values are specified in quarter notes and ticks.
Change Continuously by Percentage  Allows note lengths to change smoothly from one percentage value to another over time.

The curve for this change can be adjusted (+/− 99) to affect how gradually the change occurs.

Limit Range  When selected, restricts the Change Duration command to a minimum and maximum range (in quarter notes and ticks).

Randomize  When selected, the Change Duration command is randomized by the specified percentage value. For example, using “Set all to” with a value of 480 ticks, along with a Randomize value of 50%, yields durations anywhere between 360 and 600 (+/− 25% of the duration value).

Change Duration Examples

To make notes more staccato:
1 Select the range of MIDI notes to be edited.
2 Choose Event > Event Operations > Change Duration.
3 Select the option for Scale By with a percentage value of 50.
4 Click Apply. The durations for the selected notes are reduced by 50%.

With this option you may have to experiment with the percentage value to achieve the desired effect.

To make notes more legato:
1 Select the range of MIDI notes to be edited.
2 Choose Event > Event Operations > Change Duration.
3 Enter 0|000 for the amount of overlap.
4 From the Legato pop-up menu, select Overlap.
5 Click Apply.

The end points for the selected notes are extended to the start point of the next note, thereby eliminating the space between each note.

Transpose

While the Grabber tools can be used to manually transpose individual MIDI notes, or small groups of notes, the Transpose command in the Event Operations window can be used for entire MIDI tracks and clips. One of the more common uses for Transpose is to change the key for your MIDI tracks. You can define an Edit Group for MIDI tracks that you want to transpose, making sure to exclude any drum tracks from the group so they aren’t transposed. You can even transpose in key.

You can also transpose MIDI notes nondestructively in real-time using MIDI Real-Time Properties. See “MIDI Real-Time Properties” on page 780.

The Transpose command can also be applied to whole clips on Elastic Audio-enabled tracks using the Polyphonic, Rhythmic, or X-Form plug-ins.

For information on Transposing Elastic Audio clips, see “Elastic Audio Clip-Based Pitch Shifting” on page 991.

Elastic Audio pitch transposition is not supported with the Monophonic algorithm.

Elastic Audio pitch transposition cannot be applied to looped clips or clip groups.
To transpose MIDI notes:
1. If you will be transposing a group of tracks, enable the Edit Group.
2. Select the MIDI notes you want to transpose.
   
   *Press Option+T (Mac) or Alt+T (Windows) to open the Transpose window.*
   
   4. Select the Transpose option (By, From and To, All Notes To, or In Key).
   5. Set the corresponding pitch fields.
   
   With any pitch field selected, play a note on your MIDI controller to automatically enter it as the pitch value.
6. Click Apply.

To transpose all notes on a track down by an octave:
1. With the Selector tool, double-click in the track to select all of its MIDI notes.
3. Select the Transpose By option.
4. Enter a value of –1 octave.
5. Click Apply.

To transpose selected notes in key:
1. Select the MIDI notes you want to transpose.
3. Select Transpose in Key.
4. Adjust the slider (or type a number) for the number of scale steps (+ or –) by which you want to transpose the selection. For example, to transpose down a third, enter “–2.”
5. Click Apply.
To transpose an Elastic Audio clip:

1. Make sure the clip, or clips, you want to Transpose are on Elastic Audio-enabled tracks.

   "Elastic Audio pitch transposition is not supported with the Monophonic algorithm."

2. With the Grabber or Selector tool, select the audio clip you want to transpose. Only clips that are completely selected will be affected.


4. Do one of the following:
   • Adjust the Transpose By settings by an amount in semitones and cents.
   • Adjust the Transpose From and To settings by an amount in Semitones and Cents.

   "The Transpose All Notes To and the Transpose In Key settings can only be applied to MIDI notes. When only audio clips are selected, these options are unavailable."

5. Click Apply.

---

**Select/Split Notes Command**

The Select/Split Notes command in the Event Operations window provides a complete set of tools to select and split MIDI notes based on a wide variety of criteria. Additional tools are provided to specify whether selected data is copied to the clipboard or to new tracks, whether the data is split to multiple new tracks or a single destination, and more.

**Select/Split Notes Settings**

**Pitch Criteria**

**All Notes** Selects all notes.

**Notes Between** Selects a range of notes between the specified upper and lower note. Values for the notes can be entered in pitch (C1–G8) or MIDI note numbers (0–127).

**Top** Selects the highest note or notes in each chord.

**Bottom** Selects the lowest note or notes in each chord.

**Other Criteria**

**Velocity** Enable the Velocity option to specify a range of velocities for selecting or splitting notes. Enter minimum and maximum velocities.

**Duration** Enable the Duration option to specify a range of durations (in beats and ticks) for selecting or splitting notes. Enter minimum and maximum durations.
**Position** Enable the Position option to select or split all notes that fall into a range of relative beat and tick locations within each bar. The minimum value determines the start of the range, the maximum value sets the end of the range.

**Action**

**Select Notes** Selects MIDI notes based on the specified criteria.

**Split Notes: The Clipboard** Copies the selected data to the clipboard only.

**Split Notes: A New Track** Copies all selected data to a single, new track. If the selection includes multiple tracks, that same number of tracks are created. The new tracks duplicate the original track type (Instrument or MIDI).

**Split Notes: A New Track per Pitch** Copies all selected data to multiple new tracks (one new track for each pitch). New tracks zoom to single-note display. If the selection includes multiple tracks, each track has its data split separately.

**Include All Continuous MIDI Data** Includes all continuous MIDI data, including pitch bend and aftertouch, on the entire track, without any restriction on time selection.

**Selecting and Splitting Notes**

**To select and split notes:**

1. Do one of the following:
   - With the Grabber or Selector tool, select the range of MIDI notes that contains the notes.
   - To affect all the MIDI notes on a track, click in the track with the Selector tool, so that it contains a flashing edit cursor.


3. Configure the Pitch Criteria.

4. Configure the Other Criteria (Velocity, Duration, and Position).

5. Enable the Select or Split option.

6. From the Split Notes pop-up menu, select Copy or Cut.

7. If splitting notes, select the Copy or Cut to destination.

8. If splitting notes, enable the Include All Continuous MIDI Data option. Enabling this option includes all controller data associated with the split notes in newly created tracks. Leave this option deselected to split only note data to new tracks.

9. Click Apply.

Any Real-Time Properties associated with the track or clips are copied to new tracks created by Select/Split Notes.

**Selecting a Pitch Range of Notes**

A common use for Select/Split Notes is to select a single note for the entire length of a clip or track. This is especially useful if you want to select a note in a MIDI drum track (such as a hi-hat), and affect it over the selected time range with the Quantize, Groove Quantize, Transpose, or Change Duration command.

**To select only the hi-hats in a General MIDI drum track:**

1. Do one of the following:
   - With the Grabber or Selector tool, select the range of MIDI notes that contains the notes.
   - To affect all the MIDI notes on a track, click in the track with the Selector tool, so that it contains a flashing edit cursor.

3 Select the Notes Between option with the note range set to F#1 and F#1 (if the MIDI Note Display setting in the MIDI Preferences page is set to Standard Pitch).

For a General MIDI drum kit, the closed hi-hat is assigned to MIDI note number 42 (F#1 at Standard Pitch). If the hi-hat for your drum kit is assigned to a different note, make sure to specify it.

4 Click Apply.

You can also select all notes of a specific pitch on a track using the mini-keyboard. For more information, see “Selecting MIDI Notes” on page 752.

Selecting Notes in a Chord

Another use for Select/Split Notes is to select only the upper or lower notes in a chord. Many times you may only want to affect the upper or lower notes in a chord—for example, to increase velocities or transpose pitches.

To select only the bass notes in a chord:

1 Do one of the following:
   • With the Grabber or Selector tool, select the range of MIDI notes that contains the notes.
   • To affect all the MIDI notes on a track, click in the track with the Selector tool, so that it contains a flashing edit cursor.

2 Choose Event > Event Operations > Select/Split Notes.

3 Select the Bottom option and leave the number of notes set to 1.

4 Click Apply.

In order for notes to be considered a chord, their start times must be within thirty-two ppq ticks of each other.

Input Quantize Command

When Input Quantize is enabled in the Event Operations window, all recorded MIDI notes are quantized automatically.

To enable Input Quantize:

1 Choose Event > Event Operations > Input Quantize.

2 In the Input Quantize page, select Enable Input Quantize.

3 Configure the other options in the Input Quantize page. (For more information on the Quantize options, see “Quantize Command” on page 1006.)

4 When finished, close the Event Operations window.

Event Operations window, Input Quantize

Use Input Quantize for drum machine style loop recording (see “Loop Recording in MIDI Merge Mode” on page 549).
Step Input Command

Step Input in the Event Operations window lets you use a MIDI controller to enter notes individually, one step at a time. This gives you precise control over note placement, duration, and velocity. With MIDI step input you can also create musical passages that might be difficult to play accurately, or at a fast tempo.

To enter MIDI notes with Step Input (using an external MIDI device):

1. Make certain your external MIDI device is properly connected and working with Pro Tools.
3. Select the Enable option.

⚠️ When Step Input is enabled, each previously record-enabled MIDI or Instrument track is taken out of record enable, and if the Default Thru Instrument preference is defined, it is disabled.

4. Choose the MIDI or Instrument track for step entry from the Destination track pop-up menu.
5. Choose the note value you want to enter from the Step Increment section.
6. Play a note or chord on your MIDI instrument. This enters the note and moves to the next step of the insertion point.

To increase a note’s length while using Step Input:

1. Play and hold a note on your MIDI instrument.

💡 When a note is being held on the MIDI keyboard, Next Step changes to read “Increment.”

2. Choose the note value that you would like to add and press the Increment button.

Release the note on your MIDI keyboard to move to the next step insertion point.

⚠️ Use Step Input to enter MIDI notes in the Score Editor or in MIDI Editor windows.
Step Input Controls

The Step Input page has the following controls:

**Enable** When selected, adds MIDI events to the destination track when you play your external MIDI keyboard. Additionally, each previously record-enabled MIDI track is taken out of record enable.

If a Default Thru Instrument is defined in the MIDI Preferences page, it is disabled when Step Input is enabled, and is re-enabled when Step Input is no longer disabled.

**Destination** Lets you select the destination track for the Step Input from a pop-up list of all the MIDI tracks in your session.

Step Increment Section Controls

The controls in the Step Increment section let you set the spacing and duration of MIDI events entered using the Step Input operation. You can select any size from whole notes to sixty-fourth notes (including dotted values).

**Tuplet** Lets you input irregular note groupings (such as triplets or quintuplets). The tuplet length is calculated from the note spacing selection and the Tuplet values. For example, an eighth note equals 480 ticks, so tuplet eighth notes with 3 in time of 2 would yield a note spacing of 320 ticks (480 ticks / 3 * 2).

**Note Length** Lets you select the note length as a percentage of the spacing value. For example, an eighth note equals 480 ticks, so an eighth note with an 80% duration would be 384 ticks long.

Step Input Options

**Use Input Velocity** When selected, MIDI notes are recorded using the velocity that you play on your MIDI keyboard.

**Set Velocity To** When selected, MIDI notes are recorded with the velocity that you specify in the Velocity field. This value can be set with the Velocity slider.

**Enable Numeric Keypad Shortcuts** When selected, Step Input options can be selected from the numeric keypad. See “Numeric Keypad Shortcuts for Step Input” on page 1030.

Undo Step, Next Step, and Redo Step

Use the Undo Step and Next Step buttons to do the following:

- Move the step insertion point, by either removing the previous note or by advancing the insertion point by the Step Increment value.

- Lengthen and shorten notes that are being held on the MIDI controller, by adding or removing Step Increment values. The Step Increment value can be changed mid-note to create a note with a hybrid note length.
Use the Redo Step button to sequentially redo any previously undone steps.

**Undo Step** When the previous note has been released from the MIDI keyboard, and the insertion point has moved forward to the next note, Undo Step removes the entire last note.

When a note is being held on the MIDI keyboard, Undo Step changes to read “Decrement,” and removes the last Step Increment length that was added to the held note.

**Next Step (or Increment)** When no note is being held on the MIDI keyboard, Next Step moves the insertion point by the Step Increment value, essentially inserting a musical rest.

When a note is being held on the MIDI keyboard, Next Step changes to read “Increment” and adds the Step Increment value to the held note, increasing its length by the Step Increment value.

While the note is being held, the Step Increment value can be changed, allowing you to create notes of any musical length.

**Redo Step** Reinserts the last note that was removed by the Undo Step operation.

**Triggering the Undo Step, Next Step, or Redo Step Buttons**

The Undo Step, Next Step, and Redo Step buttons can be set to be triggered by an external MIDI synth, drum pad, or other controller.

**To set Undo Step, Next Step and Redo Step MIDI triggers:**

1. Place the Edit insertion on a track at the location where you want to enter the first MIDI note.
3. Locate the button you want to assign a MIDI event to, and click in the field below the button.
4. Play the MIDI event you want to use as a trigger.

💡 *If you use a continuous controller as a trigger (such as Pitch Bend), you should make certain to use an extreme controller value to avoid erroneous data input.*

5. Press Enter to confirm the MIDI trigger assignment.

**Numeric Keypad Shortcuts for Step Input**

When Enable Numeric Keypad Shortcuts is selected, you can apply many of the controls in the Step Input page, as well as several selection controls, using your computer’s numeric keypad.

<table>
<thead>
<tr>
<th>Step Input Shortcuts</th>
<th>Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Whole note</td>
<td>1</td>
</tr>
<tr>
<td>1/2 note</td>
<td>2</td>
</tr>
<tr>
<td>1/4 note</td>
<td>4</td>
</tr>
<tr>
<td>1/8 note</td>
<td>5</td>
</tr>
<tr>
<td>1/16 note</td>
<td>6</td>
</tr>
<tr>
<td>1/32 note</td>
<td>7</td>
</tr>
<tr>
<td>1/64 note</td>
<td>8</td>
</tr>
<tr>
<td>Dotted note</td>
<td>.</td>
</tr>
<tr>
<td>Toggle Tuplet on/off</td>
<td>3</td>
</tr>
<tr>
<td>Next step</td>
<td>Enter</td>
</tr>
<tr>
<td>Undo step</td>
<td>0</td>
</tr>
<tr>
<td>Nudge forward</td>
<td>+</td>
</tr>
<tr>
<td>Nudge back</td>
<td>–</td>
</tr>
<tr>
<td>Select Main Counter</td>
<td>=</td>
</tr>
<tr>
<td>Edit Selection indicators</td>
<td>/</td>
</tr>
</tbody>
</table>
HEAT (Harmonically Enhanced Algorithm Technology) is a paid software option that adds “analog color” to Pro Tools | Ultimate software. HEAT is available in both DSP and Native formats. To use HEAT, iLok authorizations are required for both Pro Tools Ultimate and HEAT.

HEAT is applied to all active audio tracks in your session, emulating magnetic recording tape combined with harmonic coloration commonly experienced with analog mixing consoles. Use HEAT to open up your mixes with warm, analog-modeled soft-saturated distortion.

**Enabling HEAT**

When enabled, HEAT is applied to all active audio tracks in your session, emulating the effect of an analog mixing console. HEAT is supported with all mono, stereo, and surround formats.

With HDX systems, HEAT uses DSP resources on all active audio tracks. This is important to know because as you increase (or decrease) the number of audio tracks in the session, you also increase (or decrease) the amount of DSP resources required to keep HEAT hot. Note that HEAT does not use DSP resources on inactive audio tracks.

With Pro Tools | Ultimate Software on Native systems, HEAT uses the host-processor.

**To enable (or disable) HEAT in a session, do one of the following:**

- Select (or deselect) Options > Activate HEAT.
- Select (or deselect) the HEAT On/Off button in the Mix window in HEAT view.

You can also enable the Enable HEAT in New Sessions option in the Pro Tools Preferences to have HEAT automatically enabled for all new sessions.

**To enable (or disable) HEAT for new sessions:**

1. Choose Setup > Preferences.
2. Click the Processing tab.
3. In the DSP Management section, select (or deselect) the Enable HEAT in New Sessions option.
4. Click OK.

**About HEAT Processing**

HEAT provides global controls for Drive and Tone. These affect all audio tracks where HEAT is not bypassed.

**Drive**

The Drive control introduces non-linear processing that emulates magnetic recording tape combined with harmonic information commonly found in analog gear.
Turning the Drive control counter-clockwise emulates tape-based non-linear distortion. As with tape, increasing the Drive control level by turning it counter-clockwise increases harmonic content by adding higher frequency odd harmonics (starting with the 3rd and 5th harmonics). HEAT also emulates the recording and reproduction equalizers of tape decks that further modifies the harmonic content. As a result, when turning the Drive control counter-clockwise, HEAT fattens up the bottom and mid-range of the processed audio and smooths high-frequency transients as you increase the processing.

Turning the Drive control clockwise has a more aggressive effect, adding an even harmonic series commonly found in triode tube circuits to the odd harmonic series. This can give the effect of prized tube microphones and other tube based analog gear.

Note that the harmonic structure changes with signal level and the amount of processing being applied, just like it does with vacuum tubes in the analog world.

**Tone**

As with tape, there can be loss of high frequencies with respect to low frequencies if driven far enough, as the high frequencies start compressing sooner than the low frequencies. HEAT can compensate for these losses, adding more detail and some brightness too, depending on the program material and its level. Moving the Tone control away from its default position accentuates (clockwise) or de-accentuates (counter-clockwise) the amount of detail and brightness.

The effect of the Tone control is different, depending on the Drive control setting. The amount and character of the harmonic content is changed by this control, in a non-linear fashion, unlike what a tone control in an equalizer would do.

**HEAT Processing**

With HEAT processing, the peaks in the signal are being reduced while the low level harmonic content is increased, thus reducing the level of existing peaks. Think of it as a tube or tape doing soft clipping, “squashing” the peaks and causing analog compression over a wide dynamic range.

**How Much Processing Should I Use?**

HEAT processing is level and program dependent. Although a general setting usually works for many sources, some settings that work best for one source may not have the desired effect for another source. If you need a general purpose setting try adding two steps of the Drive control (in either direction).

Since your ears may not be used to the changes to the harmonic content that HEAT provides, you may need to spend a little time listening to the effect of HEAT processing on your program material to acclimate yourself. The human ear loves a little harmonic generation. Experiment with the settings to discover what sounds best to you.

Once you are used to how the program material sounds with some HEAT processing, disabling HEAT can highlight the subtle yet significant effect of HEAT on your program material.

The amount of processing can result in subtle changes or drastic changes depending on what the program is like, and how it was recorded. The difference between processing an analog or digital recording can be subtle or drastic. It may be easier to hear the effect of the processing in material that is more “open,” as opposed to material that is more dense. The amount of low frequency information added also affects how you hear the processing.
HEAT Controls

HEAT provides a simple set of master controls for tuning the color of the effect, and a set of controls for each audio track in your session.

HEAT Master Controls

The HEAT Master controls let you adjust the amount and color of HEAT processing for all audio tracks. Take some time to experiment with different settings until you get the desired tone color for your mix.

On/Off (HEAT) Enables (or disables) HEAT in your Pro Tools session.

Bypass (BYPASS) Bypasses HEAT processing without disabling it. Note that bypassing HEAT does not free up DSP or Native resources needed for HEAT.

Meter Displays the average amount of HEAT processing across all audio tracks.

Drive Adjusts the amount of Drive for HEAT, which emulates the distortion you get when overdriving an analog channel strip on a console. At the default 12 o’clock position, no HEAT processing is applied. Turn the knob counter-clockwise to add odd harmonics to the mix (a magnetic tape saturation-like effect). Turn the knob clockwise to add even harmonics to the odd harmonic series for the effect of simulating a triode tube circuit.

Tone Adjust the Tone (bass to treble) for HEAT. Turn the control to the right for a brighter sound and to the left for a darker sound.

Showing and Hiding HEAT Master Controls

HEAT Master controls can be viewed in the Mix window.

To show (or hide) HEAT Master controls:

- Click the Show/Hide HEAT View button in the lower right corner of the Mix window.

HEAT Track Controls

HEAT track controls are available on all audio tracks. HEAT only affects audio tracks.

Bypass (BYP) Bypasses HEAT processing for the individual audio track. Note that bypassing HEAT on individual tracks does not free up the DSP resources used by HEAT for that track.

Pre/Post Insert (PRE) Sets HEAT processing to be Pre or Post inserts on the individual track. HEAT processing is Pre Inserts when the PRE button is lit.
**Meter** Displays the amount of HEAT processing on the individual audio track. On multichannel tracks, the meter shows the average amount of HEAT applied to all channels of that track.

**Showing and Hiding HEAT Track Controls**

HEAT Track controls can be viewed in the Mix window.

To show (or hide) HEAT Track controls, do one of the following:

- Select (or deselect) View > Mix Window Views > HEAT.
- Select (or deselect) HEAT in the Mix Window View selector.

**Master Bypass and Track Bypass Indicators**

The Track Bypass button is color coded to indicate whether or not HEAT is explicitly (or implicitly) bypassed when Master Bypass is enabled. Explicitly bypassed tracks remain bypassed when disabling the Master Bypass.

When a track is explicitly bypassed, the BYP button is bright orange.

When the Master Bypass is enabled, it is bright orange and any explicitly bypassed track BYP buttons also remain bright orange. For any implicitly bypassed track, the BYP button changes to dark orange.
A Note About Other Track Types

HEAT only affects audio tracks. It is not applied to Instrument, Auxiliary Input, or Master tracks. If you are using virtual instrument plug-ins on an Instrument or Auxiliary Input track and want to apply HEAT, you can either bus record audio from that track to an audio track, or you can bus the output of the track to the input of an audio track and enable Input monitoring.

DSP and Voice Requirements

(HDX Systems Only)

The amount of DSP resources used by HEAT is based on the number of voices used for audio tracks, the type of DSP hardware, and the session sample rate.

The following table lists the number of mono audio tracks per DSP chip that are available with HEAT processing enabled.

| Available number of mono audio tracks per DSP chip |
|-----------------|-----------------|-----------------|
| DSP Chip Type   | 44.1/48 kHz     | 88.2/96 kHz     | 176.4/192 kHz   |
| HDX             | 86              | 42              | 19              |

Stereo tracks require twice the DSP of mono tracks, and surround formats require as much DSP per channel as the corresponding number of mono tracks (for example, a 5.1 track uses the same amount of DSP as 6 mono tracks).

Insufficient DSP Resources

It is possible that your system may have insufficient DSP resources to add more audio tracks to the session when HEAT is enabled (because there is not enough DSP available for HEAT on the new tracks). Should this occur, Pro Tools prompts you to do one of the following:

- Create the new tracks, but make them inactive. (Inactive audio tracks do not use any DSP resources.)
- Disable HEAT and create the new tracks.

When opening a session that was saved with HEAT enabled, but your system does not have enough DSP to apply HEAT to all active audio tracks in the session, HEAT is automatically disabled. The session notes dialog will indicate that HEAT has been made inactive.

Once the session is open, you can manage which tracks you want to have active with HEAT enabled within the DSP limitations of your system. You can also expand your HDX system with additional cards to increase the available DSP resources for HEAT.

In some cases, if the session you are opening has a lot of active DSP plug-ins, the session may open with HEAT enabled, but make some of the session’s DSP plug-ins inactive. This is because HEAT processing takes priority over DSP plug-in processing.
Voice Requirements

When enabling HEAT, extra voices may be required to make HEAT active if HEAT is set to Pre insert on a track and the first plug-in on that track is a Native plug-in. If there are an insufficient number of voices available, HEAT cannot be activated.

If HEAT is already active, set to Post insert on a track, and a Native plug-in is the first plug-in on that track, HEAT may require extra voices to be changed to Pre insert. If there are an insufficient number of voices available, the Pre button will be inactive until you increase the number of voices (in the Playback Engine) or until more voices are made available (such as by making some audio tracks inactive).

Using HEAT with a Control Surface

(ICON and C|24 Only)

You can use the following features provided on ICON (D-Control and D-Command) and C|24 to control HEAT.

For information about using HEAT with Avid Artist and Pro Series Control Surfaces, see the Pro Tools EUCON Guide.

D-Control and D-Command

With D-Control or D-Command, you can access HEAT Master Controls in the Custom Fader section, and HEAT channel controls directly from the channel strips.

Master Controls

HEAT Master Controls include On/Off, Bypass, Drive, and Tone.

To access HEAT Master Controls from D-Control or D-Command:

- Shift+Control+Press the Plug-Ins switch in the Custom Fader section.

HEAT creates a Custom Fader for HEAT and maps controls to the middle encoders as described below.

D-Control

D-Control provides HEAT Master Controls within a single Custom Fader (#8)

HEAT Master Controls on D-Control

<table>
<thead>
<tr>
<th>Encoder</th>
<th>Parameter</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>#3</td>
<td>HEAT (On/Off)</td>
<td>Rotate the encoder, or press encoder 3 BMP, to toggle</td>
</tr>
<tr>
<td>#4</td>
<td>MstByp (Master Bypass)</td>
<td>Rotate encoder, or press encoder 4 BMP, to toggle</td>
</tr>
<tr>
<td>#5</td>
<td>Drive</td>
<td>Rotate encoder</td>
</tr>
<tr>
<td>#6</td>
<td>Tone</td>
<td>Rotate encoder</td>
</tr>
</tbody>
</table>
D-Command (Custom Fader 7 and 8)

D-Command provides HEAT Master Controls in the encoder sections of two Custom Faders (7 and 8).

HEAT Master Controls on D-Command

<table>
<thead>
<tr>
<th>Encoder</th>
<th>Parameter</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>#1 (Fader 7)</td>
<td>HEAT (On/Off)</td>
<td>Press BMP to toggle, or rotate the encoder</td>
</tr>
<tr>
<td>#2 (Fader 7)</td>
<td>MstByp (Master Bypass)</td>
<td>Press BMP to toggle, or rotate the encoder</td>
</tr>
<tr>
<td>#1 (Fader 8)</td>
<td>Drive</td>
<td>Rotate encoder</td>
</tr>
<tr>
<td>#2 (Fader 8)</td>
<td>Tone</td>
<td>Rotate encoder</td>
</tr>
</tbody>
</table>

Channel HEAT Bypass and Pre/Post

When HEAT is enabled in a session, each channel strip provides HEAT Bypass and Pre/Post. You can access these channel settings directly from D-Control and D-Command channel strips. Channel HEAT controls follow Do To All and Do to All Selected modifiers.

To access HEAT in the channel strip:

1. Make sure HEAT is enabled in the session.
2. Shift+Control+Press the channel Inserts switch.

D-Control

On D-Control, encoders/BMP switches 5 and 6 map to HEAT Pre/Post and Bypass, respectively.

To toggle a channel between (HEAT) Pre or Post Inserts:

- Do one of the following:
  - Rotate encoder 5
  - Press encoder 5 BMP switch.

To toggle a channel in or out of HEAT Bypass:

- Do one of the following:
  - Rotate encoder 6
  - Press encoder 6 BMP switch.

D-Command

On D-Command, both channel encoders and their BMP switches map to HEAT Pre/Post (upper encoder row) and Bypass (lower encoder row).

To toggle a channel in or out of HEAT Bypass:

- Do one of the following:
  - Rotate the lower encoder.
  - Press the lower encoder’s BMP switch.

To toggle a channel between (HEAT) Pre or Post Inserts:

- Do one of the following:
  - Rotate the upper encoder.
  - Press the upper encoder’s BMP switch.

💡 HEAT supports Flip mode for both its Master and Channel controls.
C|24

C|24 lets you adjust HEAT Master Controls from encoders 21–24, and HEAT channel controls in each channel strip.

Master Controls

To access HEAT Master Controls on C|24:

- Press the Soft Keys switch in the Channel Bar. To exit, press the Soft Keys switch again.

HEAT Master Controls are mapped to the encoder and encoder switches of channel strips 21–24, as shown in Table 1 on page 1038.

Channel HEAT Bypass and Pre/Post

When HEAT is enabled in a session, each channel strip provides HEAT Bypass and Pre/Post. You can access these channel settings directly from C|24 channel strips. Channel HEAT controls follow Do To All and Do to All Selected modifiers.

To access HEAT channel controls:

1. Make sure HEAT is enabled in the current session.
2. In the channel strip, press and hold the channel Insert switch. To exit, press the same switch again.

To toggle a channel in or out of HEAT Bypass:

- Press the channel Bypass switch.

To toggle a channel between (HEAT) Pre or Post Inserts:

Rotate the channel encoder, or press the encoder switch, and choose Pre or Post.

Table 1. HEAT Master Controls on C|24

<table>
<thead>
<tr>
<th>Encoder:</th>
<th>21</th>
<th>22</th>
<th>23</th>
<th>24</th>
</tr>
</thead>
<tbody>
<tr>
<td>Parameter</td>
<td>HEAT (On/Off)</td>
<td>MstByp (Master Bypass)</td>
<td>Drive</td>
<td>Tone</td>
</tr>
<tr>
<td>Action</td>
<td>Press the Encoder switch to toggle</td>
<td>Press the Encoder switch to toggle</td>
<td>Rotate encoder</td>
<td>Rotate encoder</td>
</tr>
</tbody>
</table>
Part IX: Mixing
Chapter 48: Basic Mixing

Mixing in Pro Tools involves working with elements of audio signal flow, including inputs, outputs, busses, inserts, and sends, for purposes of submixing and mixdown.

In addition to the final mixdown, mixing tasks can occur any time during a session.

During mixing, real-time plug-ins and hardware inserts provide effects and signal processing (see Chapter 49, “Plug-In and Hardware Inserts”).

Mixing Concepts

Mixing involves making decisions about elements such as volume levels, panning, and effects in your studio. While you can control many variables in your studio (such as speakers and room acoustics), you cannot control the listening environment in which your final mix will be heard. The following tips will help you make your mix sound as good as possible to as many listeners as possible:

Alternate Speakers and Reference Monitoring Listen to your mixes on a variety of different speakers to gauge how well the mix will translate to different playback systems.

Reference Mixes Make audio CDs and MP3-encoded files of rough mixes and audition them outside the studio in different listening environments.

Format Compatibility Monitoring Check stereo mixes for compatibility with mono playback systems, and multichannel surround mixes for compatibility with stereo playback systems.

Metering and Calibration

Meters provide a visual display of signal levels. They tell whether signal is getting to a channel, and how loud or soft a signal is relative to (above or below) “0.”

By calibrating all your equipment to standard reference levels, a consistent level can be achieved (and metered) among different recording devices in a studio, throughout a facility, or throughout an entire production chain. For example, a level of –18 dBFS coming out of a DAT deck should play and meter at –18 dBFS in Pro Tools.

Calibrating Audio Interfaces (HD I/O Only)

If you are using an HDX or HD Native system with an HD I/O, use the Calibration Reference Level option (in the Operation Preferences page) to set the reference level when Pro Tools is in Calibration mode.

For instructions on calibrating an HD I/O, see the HD I/O Guide.
Signal Flow by Track Type

Pro Tools provides the following track types:

- Audio
- Auxiliary Input
- Master Fader
- MIDI
- Instrument
- VCA Master

Audio, Auxiliary Input, Master Fader, and Instrument tracks can route audio. MIDI and Instrument tracks can route MIDI data.

VCA Master tracks do not pass audio or MIDI data, but do affect controls on other tracks. See “VCA Master Tracks” on page 1047.

Tracks can be identified in the Mix window by their Track Type icon.

Audio, Auxiliary Input, Master Fader, VCA Master, MIDI, and Instrument tracks

For information on creating tracks, see “Creating Tracks” on page 230.

Audio Tracks and Signal Flow

Audio tracks play audio from disk, record audio to disk, and monitor input signals when record-enabled or in TrackInput monitoring mode. Inserts on audio tracks are pre-fader. Sends on audio tracks can be pre- or post-fader.

Mono and stereo audio tracks are available on all Pro Tools systems.
Auxiliary Input Tracks and Signal Flow

Auxiliary Input tracks provide the same signal routing options as audio tracks, except that their input must come from an internal bus or hardware input. Inserts on Auxiliary Inputs are pre-fader.

Auxiliary Input tracks are used as inputs for audio from external MIDI instrument and other sources, as well as to submix internal bus and output paths. They can be fully automated. When using Auxiliary Input tracks as inputs for external sources, adjust the source output levels to achieve proper recording levels.

Common Uses for Auxiliary Inputs

Auxiliary Inputs can be used to:

- Apply real-time plug-ins or an external processor to a submix, using the Auxiliary Input as an effects return (such as reverb or bus line compression)
- Input audio from external MIDI instruments and other audio sources into the mix, to monitor or route to audio tracks for recording to disk (such as from the audio outputs of a MIDI synthesizer)
- Consolidate volume control of any submix under a single fader
- Mix multiple outputs from an instrument plug-in.

Routing an Auxiliary Input

To route an Auxiliary Input:

1. Click the Input Path selector of the Auxiliary Input and choose an input or bus path.
2. Click the Output Path selector of the Auxiliary Input and choose an output or bus path.
3. Adjust the Auxiliary Input fader to set the return volume.

See the submix examples in “Signal Routing for Monitoring and Submixing” on page 1074.
Master Fader Tracks and Signal Flow

Master Fader tracks control the master output levels of output and bus paths. When assigned to an active output or bus path, they provide post-fader effects processing and master level control for a main mix, headphone and cue mixes, stems, effects sends, and other signal routing applications. Master Faders support all track formats supported on your Pro Tools system.

Unlike inserts on audio tracks and Auxiliary Inputs, Master Fader inserts are post-fader. This lets you insert a dither plug-in, or similar plug-in, on your master mix, and affect its processing with the Master Fader level (for more information, see “Dither” on page 1089).

Master Faders do not consume any of your system’s audio processing power. Master Faders provide up to five post-fader inserts and no sends. Also, Master Fader tracks do not have Pan sliders, or Mute and Solo buttons.

Master Fader Meters

Meters on Master faders always show post-fader levels, regardless of the Pre-Fader Metering setting in the Options menu.

Master Faders and Paths

Master Faders can be assigned to main or sub-paths as defined in the I/O Setup. Multiple Master Faders cannot be assigned to the same path.

Active and Inactive Master Faders

When a Master Fader track is inactive, its associated plug-ins, I/O assignments, and their resources are made inactive.

When a Master Fader output assignment (path assignment) is made inactive, the Master Fader no longer controls the master gain of that path.

When you duplicate a Master Fader track, the duplicated track’s assignment will be inactive.
Common Uses for Master Faders

Master Faders can be used to:
• Control and process output mixes
• Monitor and meter an output (such as a bus or hardware output) to guard against clipping
• Control submix levels
• Control effects sends levels
• Control submaster (bussed tracks) levels
• Apply dither or other inserts to an entire mix
• Control the monitoring path with a EUCON control surface

Use Master Faders to control submix levels, send level masters, and other outputs. Master Faders can control either output or internal busses. You can use a Master Fader track assigned to an Output path as a master volume control. You can also use a Master Fader track assigned to a bus to trim the inputs to Auxiliary Input tracks for submixes to avoid clipping.

Using a Master Fader

To use a Master Fader as a stereo master volume control:
1. Create a stereo Master Fader track.
2. Set the outputs of all audio tracks in the session to the main output path (for example, outputs 1–2 of your primary audio interface) and set the panning for each track.
3. Set the output of the Master Fader to the main output path.

To use a Master Fader to trim the input to a submix:
1. Create an Auxiliary Input track.
2. Bus the signal from audio tracks in your session to the input of the Auxiliary Input track.
3. Create a stereo Master Fader track and assign the Output to the bus path that feeds the Auxiliary Input track.
**Instrument Tracks and Signal Flow**

Instrument tracks provide the same audio signal routing options as Auxiliary Input tracks, except that their input must come from an instrument plug-in inserted on that Instrument track, or from a bus or hardware input.

**Common Uses for Instrument Tracks**

By playing back MIDI from or through an Instrument track you can control and monitor the audio from:

- Instrument plug-ins, such as software synthesizers or samplers.
- External MIDI instruments, such as synthesizers and samplers

**Routing with an Instrument Track**

To route audio from an external MIDI instrument to an Instrument track:

1. Click the Input Path selector of the Instrument track and choose the corresponding hardware input for your external MIDI instrument.
2. Click the Output Path selector of the Instrument track and choose an output or bus path.
3. In Instruments view, click the MIDI Input selector, and assign a device and channel from the pop-up menu to record and control the external MIDI instrument.
4. In Instruments view, click the MIDI Output selector, and assign the port and channel for the external MIDI instrument from the pop-up menu. Adjust the Instrument fader to set the volume.

*For information on assigning MIDI input and output for Instrument tracks, see “Assigning MIDI Input and Output for Instrument Tracks” on page 255.*

*For information inserting plug-ins on tracks, see “Inserting Plug-Ins on Tracks” on page 1097.*
Chapter 48: Basic Mixing

VCA Master Tracks

VCA Master tracks emulate the operation of voltage-controlled amplifier channels on analog consoles, where a VCA channel fader would be used to control, group, or offset the signal levels of other channels on the console.

VCA Master tracks do not pass audio, so they do not have inputs, outputs, inserts or sends. A Mix group is assigned to a VCA Master track, which appears in the VCA track’s Group Assignment selector. The controls of the tracks in that Mix group, called the slave tracks, are modified by the controls on the VCA Master.

VCA Slave Track Control Indications

Unlike VCAs on traditional analog consoles, VCA Master tracks in Pro Tools directly affect their slave tracks, so that the controls on each slave track always show their actual values:

- The output level of each slave track is indicated by the position of its fader.
- The solo, mute, record enable, and TrackInput status of each slave track are indicated by the corresponding controls on the track.

This ensures that even when a VCA Master track is not visible, the true state of its slave tracks is accurately displayed.

VCA Slave Track Controls and Group Behavior

When a group is assigned to a VCA Master, the VCA-modifiable controls (Volume, Mute, Solo, Record Enable and TrackInput) on its slave tracks, by default, do not follow any grouped behavior that may be set in the Attributes page of the Groups dialog. This lets you control the output levels of the group’s member tracks while retaining the ability to adjust individual member track levels.

Slave tracks can be set to follow normal grouped behavior. See “Assigning Groups to VCA Masters” on page 1049.

Common Uses for VCA Master Tracks

By grouping tracks in a Mix group and assigning that group to a VCA Master track, you can:

- Control the output levels of all the VCA group’s member tracks without the need to bus them to an Auxiliary Input track or to the same output path
• Create multiple, nested VCA groups and control the output levels of multiple submixes at the same time

• Automate a submix by automating its VCA Master track

**VCA Master Track Controls**

The controls on a VCA Master track affect the corresponding controls on the slave tracks in its assigned Mix group. VCA Master tracks have the following controls:

**Volume**

The VCA Volume fader controls the Volume fader on audio, Auxiliary Input, Instrument, Master Fader, and other VCA Master tracks in a VCA-controlled group. (Volume faders on MIDI tracks are not affected.) Volume faders on slave tracks move to show the composite level, or the level on each track resulting from the position of the VCA Master Volume fader.

**Mute**

The VCA Mute button controls the mute state of audio, Auxiliary Input, Instrument, MIDI, and other VCA Master tracks in a VCA-controlled group. Muting a VCA-controlled group does not change the underlying mute state of slave tracks. (Mute buttons on slave tracks that were previously unmuted show an implicit mute.)

**Solo**

The VCA Solo button controls the solo state of audio, Auxiliary Input, Instrument, MIDI, and other VCA Master tracks in a VCA-controlled group.

- Soloing a VCA Master will implicitly mute all tracks except its slave tracks, thereby indirectly soloing the slave tracks.

- Explicitly soloing a slave track while its VCA Master track is soloed will override the VCA Master solo.

**Record Enable**

The VCA Record Enable button toggles the Record Enable status of only those audio, Instrument, and other VCA tracks that have already been record-enabled individually. You can then toggle record enable on and off for those tracks using the VCA Master Record Enable.

**To temporarily force all slave tracks to toggle their record enable status:**

- Option-click (Mac) or Alt-click (Windows) the Record Enable button on the VCA Master.

**TrackInput**

The VCA TrackInput button toggles the input monitor status of only those audio tracks in a VCA-controlled group that are record-enabled. You can toggle input monitor status for those tracks using the VCA Master TrackInput button.

**To temporarily force all slave tracks to toggle their input monitoring status:**

- Option-click (Mac) or Alt-click (Windows) the VCA Master TrackInput button on the VCA Master.

**Level Meter**

On VCA Master tracks, level meters indicate the highest level occurring on any of its individual tracks, not a summed level of all slave tracks.
The channel format of level meters on the VCA Master is set according to the channel formats of its slave tracks, as follows:

- If all slave tracks are the same channel format (mono, stereo or a multichannel format), the number of level meters on the VCA Master track is identical to that of the slave tracks.
- If the slave tracks are different formats, the number of level meters on the VCA Master track is set to one.

**Assigning Groups to VCA Masters**

An existing Mix group can be assigned to a VCA Master, or a new Mix group can be assigned to a VCA Master while it is being created. Only one group can be assigned to a VCA Master at a time. A VCA Master cannot control a group that includes itself.

**To assign an existing group to a VCA Master:**

- Click the Group Assignment selector on the VCA Master track and choose an available group from the pop-up menu.

**To assign a new group to a VCA Master:**

1. While creating a new group, select Mix or Mix/Edit as the Group type.
2. In the Group dialog, choose an available VCA Master track from the VCA pop-up menu.

**Track Membership in Multiple VCA Groups**

It is possible for a single slave track to be a member of more than one VCA-controlled group. In this case, the contribution of all VCA Master Volume faders is summed on the slave track. Mute, Solo, Record Enable, and TrackInput follow the same rules for enabling or disabling slave tracks.

**Allowing Grouped Behavior of VCA Slave Track Controls**

When a track is a VCA slave track, its Volume, Mute, Solo, Record Enable, and TrackInput controls follow VCA functions, and normally do not follow Mix group behavior.

However, these slave track controls can be set to allow Mix group behavior in addition to their VCA functions.

**To allow grouped behavior of VCA-related controls on slave tracks:**

1. Choose Setup > Preferences and click Mixing.
2. In the Automation section, deselect the Standard VCA Logic for Group Attributes option.
3. Click OK.

Volume, Mute, Solo, Record Enable, and TrackInput are made available as Mix group attributes in the Group dialog.
Inserts

Pro Tools lets you insert up to ten inserts (A–E and F–J) on each audio, Auxiliary Input, Master Fader, or Instrument track. Each insert can be either a software plug-in insert or a hardware insert, or an instrument plug-in (see Chapter 49, “Plug-In and Hardware Inserts”).

Inserts provide the following features:
- Plug-Ins and hardware inserts route the signal from the track through the effect of your choice, and automatically return it to the same track.
- Hardware inserts send and return the signal to corresponding input and output channels of an audio interface, which can be connected to outboard effects.
- Some Instrument plug-ins accept audio from the track input (letting you use them as processing plug-ins).
- Inserts on audio, Auxiliary Input, and Instrument tracks are pre-fader.
- Inserts on Master Faders are post-fader.
- Inserts can be bypassed or made inactive.
- Most plug-in controls are fully automatable.

Track Output Format and Plug-Ins

Pro Tools supports mono, multi-mono, stereo, and multichannel plug-ins (Pro Tools Ultimate with Surround Mixer only).

Because inserts process in series, changing the plug-in format can alter the channel format. For example, inserting a mono-to-stereo plug-in on a mono Auxiliary Input changes the signal path from that plug-in through the rest of the track. This restricts all hardware inserts or plug-ins after the stereo plug-in to be stereo-in/stereo-out plug-ins (or the supported multichannel format).

Plug-In Formats

Pro Tools supports mono and stereo plug-ins, including the following three types of plug-in paths:
- mono in/mono out
- mono in/stereo out
- stereo in/stereo out

Pro Tools Ultimate sessions running with the Surround mixer also support 3–8 channel multi-mono and multichannel plug-ins.

Configuring Inserts View in the Mix and Edit Windows

Audio tracks, Auxiliary Inputs, Master tracks, and Instrument tracks include two sets of inserts Views: Inserts A–E (inserts 1–5) and Inserts F–J (inserts 6–10). The View menu provides separate options for viewing each of set of inserts in the Mix and Edit windows.

To display inserts in the Mix window:
- Select any of the following:
  - View > Mix Window > Inserts A–E.
  - View > Mix Window > Inserts F–J.

To display inserts in the Edit window:
- Select any of the following:
  - View > Edit Window > Inserts A–E.
  - View > Edit Window > Inserts F–J.
HEAT
(Pro Tools | Ultimate with HEAT Option Only)

HEAT (Harmonically Enhanced Algorithm Technology) is a paid software option that adds “analog color” to Pro Tools Ultimate. HEAT is applied to all active audio tracks in your session, emulating the effect of an analog mixing console. Use HEAT to open up your mixes with warm, analog-modeled soft-saturated distortion. Using HEAT in conjunction with the Stereo Pan Depth option (in the Session Setup window) lets you emulate the effect of classic analog consoles right in Pro Tools.

For more information, see Chapter 47, “HEAT.”

Stereo Pan Depth

Pro Tools lets you select the pan depth for stereo output paths. You can set the Pan Depth in the Session Setup window. The Pan Depth setting lets you set the amount of signal attenuation when a track is routed to a stereo output and panned to center.

The Surround Mixer requires slightly more DSP resources than the Stereo Mixer. Consequently, if you plan to regularly mix in stereo and use a Pan Depth of –2.5, you may want to use the Stereo Mixer plug-in.

To set the stereo pan depth:

1. Choose Setup > Session to open the Session Setup window.
2. Select an option from the Pan Depth selector.

Stereo Pan Depth Options

The following Pan Depth options are available:

–2.5 dB The standard stereo pan depth setting in Pro Tools 8.0.x and lower. When opening Pro Tools 8.0.x or lower session in Pro Tools 8.1 and higher, this is the default option.

–3.0 dB The industry standard pan depth for surround mixers and many consoles. This is the default setting for new Pro Tools 8.1 and higher sessions.

–4.5 dB The standard pan depth for many British analog consoles.

–6.0 dB The standard pan depth for full mono compatibility.

For greater than stereo formats (such as 5.1), all surround output panning is fixed at –3.0 dB. The variable pan depth options are only available for stereo outputs.
Views in the Mix and Edit Windows

The Mix and Edit windows can be configured to show or hide various mixing controls, using menu commands or view selectors.

Most of these views are available in both windows, unless noted otherwise.

Window View Selectors

Both the Edit window and Mix window provide Window View selectors to configure their views.

Displaying Views

To display all views in the Mix or Edit window, do one of the following:

- Select View > Mix Window (or Edit Window) > All.
- Click the Mix Window View selector (or Edit Window View selector), and select All.

To display none of the views in the Mix or Edit window, do one of the following:

- Select View > Mix Window (or Edit Window) > None.
- Click the Mix Window View selector (or Edit Window View selector), and select None.
To show or hide available views in the Mix and Edit windows, do one of the following:

- Choose View > Mix Window (or Edit Window) and select or deselect one of the view types (such as Comments).
- Click the Mix Window View selector (or Edit Window View selector), and select or deselect one of the view types (such as Comments).

**Hiding Views in the Edit Window**

You can quickly hide View columns in the Edit window using the mouse with keyboard modifier.

**To hide a View column in the Edit window:**

- Option-click (Mac) or Alt-click (Windows) at the top of the column you want to hide (Mic Pre, Comments, Instrument, Inserts A–E, Inserts F–J, Sends A–E, Sends F–J, I/O, Real-Time Properties, or Track Color).

**Window View Options**

**Comments View** Shows any text entered as comments in the Track Name/Comments dialog. For more information, see “Naming Tracks” on page 232.

**Mic Preamps View** Shows controls in each track for PRE. For detailed information, see the PRE Guide.

**Instruments View** Shows MIDI controls on Instrument tracks (MIDI Input selector, MIDI Output selector, MIDI volume, MIDI pan, and MIDI mute).

**HEAT View (Pro Tools | Ultimate with the HEAT Software Option Only) (Mix Window Only)** Shows HEAT track controls on audio tracks in the Mix window. This view is only available in the Mix window for Pro Tools Ultimate with an authorized version of the HEAT option installed.

**Inserts View (Inserts A–E and Inserts F–J)** Shows inserts (software plug-ins and hardware I/O inserts) in each track. For more information, see “Configuring Inserts View in the Mix and Edit Windows” on page 1050.
Sends View (Sends A–E and Sends F–J) Shows send assignments in each track. Deselect to hide. For more information, see “Configuring Sends View in the Mix and Edit Windows” on page 1064.

To show (or hide) the EQ Curve view in the Mix window, do one of the following:

- Select (or deselect) View > Mix Window > EQ Curve.
- Select (or deselect) EQ Curve from the Mix Window View selector.

EQ Curve View (Mix Window Only) The EQ Curve view in the Mix window indicates whether or not an EQ plug-in is inserted on the track, and if so, displays the curve of that EQ. The EQ Insert indicator is lit when there is an EQ plug-in inserted on the track and it is grayed out if there is no EQ plug-in inserted on the track. The EQ Curve updates to show any changes to the EQ inserted on the track. If there is more than one EQ inserted on a track, the EQ Curve view displays the sum of the EQs.

Not all EQ plug-ins support EQ Curve view. Most EQ audio plug-ins from Avid and some third-party plug-ins support EQ Curve view. Other EQ plug-ins light the EQ Insert indicator, but no EQ Curve is displayed for these plug-ins.

Views in the Mix window

For supported unlinked multi-mono EQ plug-ins (such as EQ III), the EQ Curve display shows a color-coded EQ curve for each channel.
Meters and Faders View (Mix Window Only) Shows track meters and faders. Hiding Meters and Faders can be useful for conserving screen space, especially if you are working with a control surface.

I/O View (Edit Window Only) Shows Input and Output selectors, and Volume and Pan indicators in each track.

Click on the volume or pan indicators in the Edit window I/O View to adjust the volume or pan controls with a pop-up fader.

Object View (Pro Tools | Ultimate with Dolby Atmos Only) Shows the Object controls for audio, Auxiliary Input, and Instrument tracks (mono or stereo only).


Delay Compensation View The Delay Compensation View displays the total amount of plug-in and hardware insert delay on each track, lets you apply a user offset of track delay, and displays the total amount of delay that Pro Tools applies to each track. The Delay Compensation View can be shown or hidden in the Mix Window.
Delay Compensation View

Delay values can be specified in either samples or milliseconds, as selected in the Operation Preferences page. For more information on Delay Compensation, see “Delay Compensation” on page 1082.

Track Color View

Shows track color in each track. For detailed information, see “Color Coding for Tracks, Clips, Markers, and Groups” on page 259.

Track Collaboration View (Projects Only)

Shows the collaboration controls for tracks. For more information about collaboration, see “Track Collaboration Track View in the Edit and Mix Windows” on page 383.

Audio Input and Output Paths

Pro Tools lets you configure the physical input and outputs of your audio interfaces and also internal bus paths and subpaths in the I/O Setup dialog and the Hardware Setup dialog. These hardware inputs and outputs, and internal bus paths can be assigned as inputs and outputs on audio, Auxiliary Input, Instrument, and Master Fader tracks.

Input Audio Path

Input Path selectors determine the source input for audio, Auxiliary Input, and (optionally) Instrument tracks. Track inputs can be set from hardware inputs or internal bus paths or subpaths. For detailed information on assigning track inputs, see “Assigning Audio Inputs” on page 247.

Hardware input and bus paths can be configured in the I/O Setup. For more information, see Chapter 6, “I/O Setup.”

You can also define what physical ports are routed to Pro Tools input ports in the Hardware Setup dialog. For more information, see “Configuring Pro Tools Software System Settings” on page 90.

Output Audio Path

Track Output Path selectors route the post-fader signals to the assigned output or bus paths. The Output Path selector routes the main track output to the chosen main or sub-path. Tracks can be routed directly to hardware output or internal bus paths and subpaths for submixing (main or sub-paths).

The track format (mono, stereo, or multichannel) determines the available main and sub-path choices for track output. For detailed information on assigning track outputs, see “Assigning Audio Outputs” on page 248.
When audio, Auxiliary Input, Master Fader, and Instrument tracks are created, their mono, stereo, or greater-than-stereo multichannel format is defined:

- Mono tracks can be assigned to any available mono, stereo, multichannel main and sub-paths.
- Stereo tracks can be assigned to any available mono, stereo, or multichannel main and sub-paths.
- Multichannel tracks (Pro Tools Ultimate only) can be assigned to any mono path, or path of the same number of channels (for example, an LCRS track can be assigned to a mono or LCRS path).

Output Windows

Output windows provide the essential track mixing controls (such as track panning and volume), as an alternative to Mix and Edit window views. Multi-channel Output and Send windows also provide expanded Panner views, and other surround-specific controls. See Chapter 54, “Surround Panning and Mixing.”

Output windows are useful in large sessions to leave important tracks in an anchored location, unaffected by Mix and Edit window (or control surface) banking. See “Output Windows for Tracks and Sends” on page 1070.

Multiple Output Assignments

Pro Tools audio, Auxiliary Input, and Instrument tracks can be assigned to multiple output paths. Assigning to multiple paths is an efficient way to route an identical mix to other discrete outputs, for simultaneous monitor feeds, headphone mixes, or other situations where a parallel mix is needed.

To assign a track to multiple outputs:

1 Control-click (Mac) or Start-click (Windows) the Track Output selector and select a main output path.

2 Control-click (Mac) or Start-click (Windows) additional output paths in the track’s Output Path selector. Newly selected output destinations are added as additional outputs.

3 Do one of the following to close the Output selector menu and assign all selected paths:
   - Press Return.
   - Press Esc.
   - Click anywhere outside the Output selector menu.

Option-Control-click (Mac) or Alt-Start-click (Windows) to add the assignment to all tracks, or Option-Shift-Control-click (Mac) or Alt-Shift-Start-click (Windows) to add the assignment to all selected tracks.

Display of Multiple Output Assignments

When a track is assigned to multiple output paths, the Output Path selector denotes multiple assignment status and active/inactive status with the following indicators:

- A plus sign (+) indicates that the track has multiple output assignments.

Indication of multiple output assignments
• In the Output Path selector menu, all currently assigned track outputs are checked to indicate they are active for the current track.
• An asterisk (*) indicates that one or more currently assigned outputs is Inactive.

Inactive Outputs

An output path can be made inactive, either globally in the I/O Setup dialog (affecting all tracks assigned to that path), or locally per assignment (only affecting that output on that audio track Auxiliary Input track, or Instrument track).

To make an output path inactive, do one of the following:

- Command-Control-click (Mac) or Control-Start-click (Windows) the Output selector.
- Right-click the Output selector and select Make Inactive.

When opening sessions, outputs will be made inactive automatically if the required hardware or other resources are not available.

Inactive outputs retain all associated automation playlists. Edits made in the session also affect the inactive track’s output automation playlists.

See “Making Tracks Inactive” on page 259.

To make an inactive output path active, do one of the following:

- Command-Control-click (Mac) or Control-Start-click (Windows) the Output selector.
- Right-click the Output selector and select Make Active.

Inactive Outputs and DSP Resources

Making a track output inactive silences the output, while retaining all automation and playlist data. Inactive outputs do not consume resources for HDX DSP mixer connections, but any assigned plug-ins on the track continue to use their required DSP resources. Host-based AAX plug-ins require CPU resources. DSP-based AAX plug-ins use the DSP available on HDX cards.

You can free up DSP of an unused plug-in by making its track inactive, or by making just the plug-in inactive.

See “Active and Inactive Items” on page 17, and “Making Inserts Inactive” on page 1096 for more information.

About the “No Output” Option

Track outputs can be set to No Output. Assigning a track output to No Output causes any panning automation associated with the track to be lost.

Tracks assigned to No Output will not be audible, but they do not free their associated DSP resources.

Sends

Pro Tools lets you insert up to ten sends (A–E and F–J) on each audio track, Auxiliary Input, or Instrument track.

Sends provide the following features:

• Sends can be set as pre- or post-fader.
• Sends can show level meters.
• Send level, pan, mute, and LFE controls can be configured to follow Groups.
• Send level, send mute, and send pan (for stereo and multichannel sends) are fully automatable. See “Automating Sends” on page 1140.

• Send controls can be displayed and edited from the Mix or Edit windows, or in their own output windows.

• Sends can be assigned to available output and bus paths (main or sub-paths), in mono or stereo, or any of the supported multichannel formats for surround mixing.

• Each send can have multiple assignments (for example, to available output and bus paths).

To be audible in Pro Tools, sends must be returned to the mix through an Auxiliary Input, audio track, or Instrument track. The sends can then be monitored and processed through an Auxiliary Input (or Instrument track), recorded to audio tracks, and bounced to disk. (Bouncing and mixdown are explained in Chapter 51, “Mixdown.”)

**Assigning Sends to Tracks**

**To add a send to a track:**

1. Make sure Sends View is enabled in the Mix or Edit window (see “Views in the Mix and Edit Windows” on page 1052 for information).

2. Click the Send selector on the track and choose a path from the pop-up menu.

3. Set the output level of the send in the Send window by doing one of the following:
   - Adjust the Send Level fader.
   - Set the send level to unity gain (0 dB) by Option-clicking (Mac) or Alt-clicking (Windows) the Send Level fader.

When you create a new send, its initial output level depends on the setting of the Sends Default to –INF preference.

Pans for sends can be linked to the panning on the track’s main output path by enabling the Send Pans Default To Follow Main Pan preference.
To change the default setting for sends:

1. Choose Setup > Preferences and click Mixing.

2. Do one of the following:
   - Select Sends Default to “–INF.”
   - Deselect Sends Default to “–INF” and new sends will default to unity gain (0 dB).

3. Do one of the following:
   - Select Send Pans Default to Follow Main Pan.
   - Deselect Send Pans Default to Follow Main Pan to have panning control over the sends independent of the panning on the track’s main output path.

To remove a send from a track:

- Click the Sends button on the track and choose No Send from the pop-up menu.

Search Send Paths

To search for a path in a Send:

1. Click the path selector for the send you want to assign and do one of the following:
   - Type the first character of the path name you want.
   - Click Search.
   - Press Tab.

2. Type a few letters included the path name that you want. Only paths whose names that include those letters (highlighted yellow) now appear in the list (maximum of 20).

3. Select the desired path with the mouse, or use the Up and Down arrow keys to select the path name.
4 Do one of the following:
   • Press Return (Mac) or Enter (Windows) again to close the selector menu.
   • Click anywhere outside the menu.

💡 You can also search Track Presets by name from the Sends selector. (Track Presets are not available from the Track Input or Output selectors.)

To search for and assign multiple paths (Sends and Track Outputs only):
1 Type to search for each additional path assignment, do one of the following:
   • Tab to confirm current tag that you are typing.
   • Press Shift+Return.
   • Click the entry.
2 Press Return to close the selector menu and assign the outputs.

Muting Sends
Pro Tools lets you mute sends individually, for all selected tracks in your session, or just for sends A–E or F–J on selected tracks.

To mute (or unmute) a sends from the Send window or in the Mix window in Expanded Send view:
- Click the Mute button for the send.

To mute (or unmute) sends from the Track menu:
1 Select the tracks on which you want to mute sends. Option-click (Mac) or Alt-click (Windows) to select all tracks shown in the session.
2 Select one of the following:
   - Track > Mute Sends > All.
   - Track > Mute Sends > A–E.
   - Track > Mute Sends > F–J.

Key Commands for Muting Sends
Pro Tools provides key commands for muting sends on tracks in the Mix window:
- Control-click (Mac) or Start-click (Windows) a Send Assignment button in the Mix or Edit window to Mute it and all sends below it on a track.
- Control-Option-click (Mac) or Start+Alt-click (Windows) a Send Assignment button in the Mix or Edit window to Mute it and all sends below it on all tracks. This lets you mute all sends in your session with a single click.
- Press Shift+Q to mute (or unmute) all sends on selected tracks.
- Press Shift+4 to mute (or unmute) sends A–E on selected tracks.
- Press Shift+5 to mute (or unmute) sends F–J on selected tracks.

Searching and assigning multiple outputs

Option-click (Mac) or Alt-click (Windows) to assign sends to the same path for all tracks of the same type.

Option-Shift-click (Mac) or Alt-Shift-click (Windows) to assign sends to the same path for all selected tracks.
Creating and Assigning a New Track from a Send

Pro Tools lets you create a new Auxiliary Input, Audio, or Instrument track from the Send selector and automatically assign the send to the Input of the new track using an available internal mix bus.

To create a new track from a send:

1. On an existing track, click the Send selector and select New Track.

2. In the resulting New Track dialog, select the Width, Type, and Time Base for the new track.

3. Type a Name for the new track.

The name entered is used for both the new track and the new mix bus. (For example, if you entered the name “Drum Sub,” Pro Tools creates a new Auxiliary Input track named “Drum Sub” and also creates an internal mix bus named “Drum Sub.”)

4. Select (or deselect) whether you want the new track to be created next to the current track (with the send).

5. Click OK.

Pro Tools creates a new track with the output of the originating send automatically routed to the input of the new track using an available internal mix bus.
Assigning an Existing Track from a Send

Pro Tools lets you assign a send directly to an active Auxiliary Input, Audio, or Instrument track using an available internal mix bus. Note that the destination track must be set to either an internal mix bus or to No Input in order to be available for assignment.

To assign a send to an available input on an existing track:

1. On an existing track, click the Send selector and select Track.
2. From the Track submenu, select the destination track you want.

Pro Tools automatically routes the send to the input of the selected track using an available internal mix bus.

Send Formats

Mono and Stereo Sends When you click the Sends button on a track, you can choose from a list of mono or stereo output or bus paths.

Multichannel Sends (Pro Tools | Ultimate Only)

When you click the Sends button on a track, you can choose from a list of multichannel output or bus paths.

Send Path Selector Choices

The choices available in track Send selectors include bus and output paths.

The names, format, and channel mapping of busses and output paths can be customized in the I/O Setup dialog. See “Output Busses” on page 76.

Internal Mix Busses Pro Tools provides internal mix busses for routing signals internally. Internal bus paths are useful for submixing and processing with plug-ins. Bus paths are defined in the I/O Setup dialog, and are available in all supported channel formats (mono, stereo, or multichannel, as supported on your system).

Hardware Outputs Hardware sends are often used for headphone cue mixes, or for sending signals to external effects processors. Sends do not automatically return audio as do hardware inserts.
Configuring Sends View in the Mix and Edit Windows

Audio tracks, Auxiliary Inputs, and Instrument tracks include two sets of Sends Views: Sends A–E (sends 1–5) and Sends F–J (sends 6–10). The View menu provides separate options for viewing these sends in the Mix and Edit windows.

To display sends in the Mix window:
- Select any of the following:
  - View > Mix Window > Sends A–E.
  - View > Mix Window > Sends F–J.

To display sends in the Edit window:
- Select any of the following:
  - View > Edit Window > Sends A–E.
  - View > Edit Window > Sends F–J.

Sends View Options

Sends are displayed in the Mix and Edit window according to the Sends A–E View and Sends F–J View options. Each Send View has six view choices: Assignments View and five individual Send Views (A–E or F–J).

Assignments View

This is the default Sends View, showing all five of the Sends A–E or Sends F–J sends on all tracks displayed in the Mix and Edit windows.

In Assignments View, send controls are adjusted from Send Output windows (see “Output Windows for Tracks and Sends” on page 1070). You can also adjust some send controls in Expanded Send views (see “Expanded Send Views (A–J)” on page 1065).
Expanded Send Views (A–J)

Pro Tools lets you expand any combination of individual send assignments views. Expanded Send Views provide send level, pan, and mute controls for a single send across all tracks. Send controls can be adjusted directly from these Send Views. Sends can also be opened for control or metering in Send windows. See “Output Windows for Tracks and Sends” on page 1070.

To expand (or collapse) a send:

- Select (or deselect) View > Expanded Sends > Send <n> (A–J).

  Command-click (Mac) or Control-click (Windows) a send selector to expand or collapse the send.

To expand all sends:

- Choose View > Expanded Sends > All.

  Command-Option-click (Mac) or Control-Alt-click (Windows) a send selector to expand or collapse all sends within the send group (Sends A–E or Sends F–J).

To collapse all sends:

- Choose View > Expanded Sends > None.

Meters in Send Assignments

Pro Tools can show segmented level meters to the right of the send path name in the Send Assignment button in normal sends view. Sends only show post-send fader metering.

To show (or hide) meters in Send Assignments, do one of the following:

- Choose Setup > Preferences > Metering and select (or deselect) the Show Send Assignment Level Meter option (see “Show Send Assignment Level Meter” on page 123).

- Right-click on a track meter and select (or deselect) the Show Send Assignment Level Meter option.

Expanded Sends view for Sends A, B, and F

Assignments View, meters shown
Editing Sends in the Mix and Edit Windows (Individual Send Views)

Individual Send Views (such as Send A) display all the controls of an individual send in the sends area of the Mix and Edit windows. These views provide full access to all controls for that send on all tracks.

Send level and mute can follow Mix groups, to adjust multiple send controls from a single set of controls.

Individual Send Views and Meters

When you display the controls for an individual send, you also have the option of displaying send level meters.

Send level meters show peak values and indicate clipping that occurs while the meter is displayed (if a send clips any time before its meter is displayed, this is not shown). If you are using a slower computer, hiding send level meters can improve screen redraw times.

To clear a send meter’s Clip indicator:
- Click the Clip indicator.

Send Status Display

When displaying all controls for an individual sends, the Send status is visible directly in the Mix or Edit windows.

In Assignment View, Send status is displayed as follows:
- By default, the Send button is gray, to indicate that it is unmuted.
- The Send button text is red when the send has clipped.
- The Send button is blue when the send is muted.
- The Send button is lit whenever a send’s window is open.

If you use a control surface (such as D-Control or 003) with Pro Tools, colored outlines around sends, inserts, and outputs indicate the current controller focus.

To clear all meters, do one of the following:
- Option-click any Clip indicator.
- Choose Track > Clear All Clip Indicators.
- Press Option+C (Mac) or Alt+C (Windows).
**Inactive Sends**

Sends can be made inactive. Inactive sends free their DSP and mixer resources, while retaining their position in track Sends View. Inactive sends do not output audio. However, Inactive sends retain all related automation playlists. In addition, edits made to clips on tracks with inactive sends can still affect the sends automation playlists.

When opening sessions, sends will automatically be made inactive if the required hardware or other resources are not available.

To make a send inactive, do one of the following:
- Command-Control-click (Mac) or Control-Start-click (Windows) on the Send assignment.
- Make the Track inactive. See “Making Tracks Inactive” on page 259.

To toggle sends in the same position (A–J) and assigned to the same path on all tracks active or inactive:
- Command-Control-Option-Shift-click (Mac) or Control-Start-Alt-Shift-click (Windows) a send button in the position you want to toggle.

**Moving or Copying Sends**

Sends can be moved or copied to other tracks, or to other positions on the same track by dragging. Sends can be dragged to create new sends at the destination, or dragged onto existing send assignments to replace them.

Sends can be moved and copied to tracks with compatible send output formats (mono, stereo, or other). Pro Tools alerts you when you try to move or copy a send to an incompatible destination. (For more information, see “Send Format and Track Compatibility” on page 1067).

To move a send:
- Drag the send name to a new position in the original track or in a different track.

To copy a send:
- Option-drag (Mac) or Alt-drag (Windows) the send to a new position.

Moving or copying a send maintains all routing assignments, automation, level/pan/mute settings, and output format.

**Send Format and Track Compatibility**

Sends can only be copied to other tracks with a compatible send output format (mono, stereo, or other). In addition, the following conditions apply when moving or copying sends among tracks:
- When copying a stereo send from a mono track to a stereo track, Send pan automation (if any) will be dropped without warning.
• When copying a stereo send from a stereo track to a mono track, the left Send pan automation data is retained and the right side data is dropped. A warning dialog appears for you to confirm or cancel this destructive operation.

• When moving or copying a send and replacing an existing send, all automation on the existing send will be replaced. A warning dialog appears for you to confirm or cancel this destructive operation.

Copying Track Settings to Sends (Pro Tools | Ultimate Software Only)

Sometimes you need send settings to match the settings in the track itself—for example, to provide a headphone mix based on the main mix. You can copy the current values or the entire automation playlist from selected tracks to any of their sends.

For more information, see “Copying Track Automation to Sends” on page 1141.

Linking Send Pan and Main Pan Controls

You can link pan controls of individual Sends to the Main pan controls of their corresponding tracks. This can help you quickly setup cue mix (headphone mix) or effects processing bus routing.

To link a Send’s Pan controls to the Main Pan controls of a track:

1. Click the Send Assignment button for the Send you want to link to open the Send window.

2. In the Send window, click the FMP (Follow Main Pan) button.

To change the default FMP (Follows Main Pan) setting for newly created Sends:

1. Choose Setup > Preferences and click Mixing.

2. Under Setup, select or deselect the Send Pans Default to Follow Main Pan option.

Pre/Post–Fader Indicator for Sends

In Sends view in both the Mix and Edit windows, the Sends selector changes color to indicate whether a Send is Pre-fader (blue) or Post-fader (no color). This lets you quickly see which sends are Pre-fader and which are Post-fader simply by glancing at the Sends view of tracks in the Mix or Edit window.
Bus Interrogation Options

Pro Tools lets you select or show tracks based on the track input or output assignment, send assignment, or hardware insert assignment. This can be useful for quickly identifying all tracks that use a specific input, internal bus, output bus, or hardware insert.

Right-click the assignment selector and choose from the following options:

**Select Assignments To** This option selects all tracks that use a specific input, internal bus, output bus, or hardware insert.

**Show Assignments To** This option shows all tracks, including hidden tracks, that use a specific input, internal bus, output bus, or hardware insert. All other tracks remain shown as well.

**Show Only Assignments To** This option shows only those tracks that use a specific input, internal bus, output bus, or hardware insert. All other tracks are automatically hidden.

**Restore Previously Shown Tracks** This option restores the previous state of shown and hidden tracks. This option is only available if tracks have been hidden by using the Show Only Assignments To option.

Press Option (Mac) or Alt (Windows) while Right-clicking and selecting any of the Bus Interrogation commands to apply the command to all related paths and sub-paths. For example, Press Option (Mac) or Alt (Windows) while Right-clicking an output selector and choosing Show Only Assignments To Bus 1. If Bus 1 is a sub-path of Bus 1–2, all tracks using path Bus 1–2, and all tracks using sub-paths Bus 1 and Bus 2 are shown, and all other tracks are hidden.

To select tracks based on the track Input or Output assignment, Send assignment, or Hardware Insert assignment:

- Right-click the assignment selector and choose Select Assignments To for the bus you want.

Choosing the Select Assignments To Bus 9–10 option

To show all tracks based on the track Input or Output assignment, Send assignment, or Hardware Insert assignment:

- Right-click the assignment selector and choose Show Assignments To for the bus you want. Any hidden tracks with the corresponding assignment are shown.

To show only tracks based on the track Input or Output assignment, Send assignment, or Hardware Insert assignment:

- Right-click the assignment selector and choose Show Only Assignments To for the bus you want. All other tracks are automatically hidden.

To restore all previously shown tracks:

- Right-click any assignment selector and choose Restore Previously Shown Tracks.
Output Windows for Tracks and Sends

Track Output and Send windows provide standard Pro Tools track, send, Target, and other controls. Track outputs and sends can be opened for display and editing in dedicated windows.

- Track Output windows provide track fader, pan, automation, solo, and mute controls.
- Send windows provide send level, pan, automation, and mute controls.
- Standard Output and Send window controls provide additional routing, assignment, and display settings.

To open a track Output window:
- Click the Output Window button in the channel strip.

To open a Send window:
- Click the Send Assignment button in the Mix or Edit window.

Opening a track Output window

To view a different track Output or Send window:
- Click an Output Window button, or Send Assignment button, in the Mix or Edit window.

If a similar Output window was already open with a highlighted Target icon (red, lit), the newly selected send will open in its place.
Opening Multiple Output Windows

Multiple Track Output and Send windows can be displayed simultaneously using either of the following methods.

To open additional Track Output or Send windows:
- Shift-click any Track Output Window button or Send Assignment button.

To set a window to remain open when opening additional Track Output or Send windows:
- Make sure the Target is disabled.

Track or Send Fader, Pan Controls, and Solo, Mute, and Automation Controls

Output windows provide the associated track’s Volume fader, Pan controls, Solo and Mute switches, and Automation Mode selector. Use these to adjust or automate the controls of the Output window.

Panner Linking

Stereo outputs provide two panning controls, one for each side of the left/right pair. Multichannel outputs provide a multichannel panner.

The Output window provides controls to link channels for precise panning of stereo and multichannel tracks.

In the linked state, all sides match changes to any other side’s Pan control. This is Absolute Link mode. To mirror panning changes, see “Inverse Linked Panning” on page 1072.

When unlinked, Pan controls are completely independent of each other.

To enable linking:
- Enable the Link icon.

To unlink an output for independent panning:
- Deselect the Link icon.
Inverse Linked Panning

When linked and set to Inverse mode, panning moves are inverted or reversed in the other channels.

Inverse panning reflects one side’s location and direction in the other side. For example, when enabled for Front Inverse, if you pan one side of a stereo track output from right to left, the other side will exactly mirror that movement and pan left to right.

Front Inverse linking is available on all systems. Rear Inverse, and Front/Rear Inverse linking are available on Pro Tools HD systems only, and only appear as options on multichannel plug-ins and panners/output windows.

To enable inverse linking:
1. Enable the Link icon.
2. Select an Inverse mode.

Standard Selector Controls in Output Windows

All Output windows provide standard selectors for path, automation, and other controls in the top area of the window (the Output Editor area).

Inverse Pan Reflects one side’s panning location and direction in the other side (for example, left- and right-channel Pan controls).
**Link and Unlink** Lets you link and unlink left and right (or other) outputs in stereo (or multichannel). Unlinked mode provides discrete adjustment of individual sides, or channels. When linked, all changes affect all channels. See “Panner Linking” on page 1071.

**Target** Identifies the target of plug-in settings commands. Also sets the current window for display of Output windows.

**Path Meter View** Opens the path Meter View. These meters display levels of the selected path (not the levels of the track or send).

---

**Output Meters**

Pro Tools provides Output meters in the Transport window and Edit window that display the monitoring levels for signals routed to the physical outputs on your audio interfaces from your session or to internal busses in the session. The top LED is red and indicates clipping at the converters on your audio interface (DAC) on the corresponding channels or on internal busses.

For Pro Tools HD systems using greater than stereo output paths, up to 8 meters are shown. The number of Output meters displayed is determined by the selected Output paths on tracks. The meters are ordered according to the channel order of the Output paths as configured in the I/O Setup.

The audio paths monitored in the Output meters are determined by the Output Meter Path setting in the Output page of the I/O Setup.

**To set the Output Meter Paths:**

1. Choose Setup > I/O Setup.
2. Select the Output tab.
3. From the Output Meter Path selector, select the desired output path for metering.
4. Click OK.

---

Path Meter View in a Send window

Selecting the Output Meter Path in the I/O Setup
The channel order is determined by the configuration of the output paths in the I/O setup.

Output Meters channel order determined by the Output configuration in the I/O Setup

For all Pro Tools systems using stereo output paths, stereo meters are shown (L/R).

Stereo Output Meters in the Transport window

To show (or hide) Output Meters in the Edit window transport or in the Transport window:

- From the Edit window or Transport window menu, select (or deselect) Output Meter.

Selecting the Output Meters option in the Transport Window menu

Signal Routing for Monitoring and Submixing

The bussing and mixing features in Pro Tools support many possibilities for submixing and monitoring, including the ability to:

- Monitor and mix playback of audio tracks with audio inputs or with MIDI instruments
- Bus submixes for effects processing or monitoring (including headphone or “cue” mixes)
- Mix submixes with Master Faders

Monitoring and Mixing Audio with Auxiliary Input Tracks

Use Auxiliary Input tracks to monitor and mix audio from external sources, such as MIDI instruments, tape, or microphone inputs, in a Pro Tools mix.

To use an Auxiliary Input track to monitor and mix external audio sources:

1. Connect the audio outputs of your audio source (such as a MIDI synthesizer or tape output) to available inputs on your Pro Tools audio interface.

2. If necessary, configure the I/O Setup dialog for the input paths you plan to use (see Chapter 6, “I/O Setup.”)

3. Use an existing or create a new Auxiliary Input track with a channel format that corresponds to the channel format of your audio source (mono, stereo, or multichannel).

4. Set the input of the Auxiliary Input track to the corresponding input path.

5. Assign the track output to the appropriate path or paths for monitoring.

6. Adjust the Auxiliary Input fader to mix the audio input.
Monitoring and Mixing Audio with Instrument Tracks

Use Instrument tracks to monitor and mix audio from instrument plug-ins or external MIDI instruments in a Pro Tools mix.

To use an Instrument track to monitor and mix the output of an instrument plug-in:

1 Use an existing or create a new Instrument track.
2 Choose View > Mix Window > Instruments to show the MIDI controls of the Instrument track.
3 Select an instrument plug-in from the first Insert selector on the Instrument track (such as Xpand2).
4 The virtual MIDI node (port) for the instrument plug-in should be automatically selected for the Instrument track’s MIDI Output. If not, select the MIDI channel and corresponding port for the instrument plug-in from the MIDI Output selector.
5 Assign the track audio output to the appropriate path or paths for monitoring.
6 Adjust the Instrument track fader to mix the audio input.
7 If you are controlling the Instrument plug-in from the Instrument track, you can also mix using the MIDI Volume and Pan controls in the Instrument View.

For information on configuring audio and MIDI signal routing for controlling and monitoring ReWire client applications, see the Audio Plug-Ins Guide.

To use an Instrument track to monitor and mix audio from an external MIDI instrument:

1 Connect the audio outputs of your external MIDI instrument (such as a MIDI synthesizer) to available inputs on your Pro Tools audio interface.
2 If necessary, configure the I/O Setup dialog for the input paths you plan to use (see Chapter 6, “I/O Setup.”)
3 Connect the MIDI input and output of your external MIDI instrument to available MIDI input and output ports on your MIDI interface.
4 If necessary, configure the MIDI Studio Setup (Setup > MIDI > MIDI Studio).

5 Use an existing or create a new Instrument track with a channel format that corresponds to the channel format of your audio source (mono, stereo, or multichannel).

6 Choose View > Mix Window > Instruments to show the MIDI controls of the Instrument track.

7 Set the audio input of the Instrument track to the corresponding input path.

8 In the Instrument track’s Instrument View, set the MIDI output to the corresponding MIDI port connected to the MIDI input of your external MIDI instrument.

9 Assign the track output to the appropriate path or paths for monitoring.

10 Adjust the Instrument track fader to mix the audio input.

11 If you are controlling the external MIDI instrument from the Instrument track, you can also mix using the MIDI Volume and Pan controls in the Instrument View.

To monitor and mix audio from an Instrument plug-in with multiple audio outputs:

1 Use an existing or create a new Instrument track.

2 Choose View > Mix Window > Instruments to show the MIDI controls of the Instrument track.

3 Select a multi-output instrument plug-in from the first Insert selector on the Instrument track (such as Xpand²).

4 The virtual MIDI node (port) for the instrument plug-in should be automatically selected for the Instrument track’s MIDI Output. If not, select the MIDI channel and corresponding port for the instrument plug-in.

5 In the plug-in window, assign the individual audio outputs of the plug-in.

6 Create an Auxiliary Input track for each output of the plug-in. Make sure the channel format of the Auxiliary Inputs corresponds to the channel format of the plug-in outputs (mono, stereo, or multichannel).

7 Set the inputs of the Auxiliary Input tracks to receive the individual outputs of the plug-in.

8 Assign the outputs of the Auxiliary Input tracks to the appropriate path or paths for monitoring.

9 Adjust the Auxiliary Input faders to mix the individual outputs of the plug-in.
Creating a Submix

A submix is created by routing multiple audio sources to a common bus or output path. This “submixes” the sources to a single path that can be returned to an Auxiliary Input, where the submix can be processed with plug-ins or external effects processors.

Audio is routed to a submix by assigning any combination of sends and track output to available bus or output paths.

When routing mono signals with internal mix busses, be sure to use mono busses rather than splitting stereo busses. Since Pro Tools keeps stereo busses phase aligned, splitting stereo busses can result in inaccurate delay compensation.

Submixing with Track Outputs or Sends

You can use both track outputs and sends to route audio for submixing, depending on whether you want a discrete or send and return submix.

Discrete Submix Output

Pro Tools lets you discretely route source audio through a submix. This is preferred for dither or other mastering processing, where you do not want unprocessed audio heard in addition to the processed signals. Use track outputs (not sends) to assign tracks to a bus path for discrete submixing. In this arrangement, the balance of processed and unprocessed signal is controlled by plug-in wet/dry settings.

To create a discrete submix:

1. Set the output of the tracks you want to include in the submix to a stereo bus path.
2. Pan each track.
3. Choose Track > New.
4 Specify the track type (Aux Input) and format (stereo), then click Create.

5 Set the input of the Auxiliary Input to the same bus path to which you assigned all contributing tracks.

6 Set the output of the Auxiliary Input track to your main stereo mix outputs (typically, outputs 1–2).

7 Set the Auxiliary Input Track level.

8 To process the submix, assign a plug-in or hardware insert on the Auxiliary Input.

9 Set the controls of the plug-in. The plug-in Bypass and Wet/Dry controls (if available) determine the amount of effect heard.

The contributing track faders control the balance within the submix. The Auxiliary Input track controls the output levels of all tracks routed to it.

You can apply mix automation to the volume, pan, mute, and send level, send pan, and send mute controls of the Auxiliary Input.

You can also bounce a submix to disk to free up the voices for use by other tracks. See Chapter 51, “Mixdown” for more information.

### Send and Return Submixing for Effects Processing

When you are submixing for reverb, delay, and similar effects processing, use sends to achieve traditional send/return bussing. You can use a real-time plug-in or a hardware insert as a shared resource for all tracks included in a submix. The wet/dry balance in the mix can be controlled using the track faders (dry level) and Auxiliary Input fader (effect return, or wet, level).

To create an effects return submix with a plug-in or hardware insert:

1 Assign each track’s main output to your main mix outputs.

2 On the source tracks, assign a send (mono or stereo) and select a mono or stereo bus path from the Send selector. Configure the sends for pre- or post-fader, as needed.

3 Choose Track > New.

4 Specify the track type (Aux Input) and format (stereo), then click Create.

5 From the Auxiliary Input track’s Input Path selector, select the send bus path.

6 Solo safe the track so that if you solo another track that uses the effects send, you won’t mute the effects return (see “Solo Safe Mode” on page 258).

7 Assign a plug-in or hardware insert on the Auxiliary Input.

8 Set the effect to “100% wet,” and set any other controls.

9 From the Auxiliary Input track’s Output Path selector, select an output path (main outputs).

Adjust the individual track faders to balance the dry (unprocessed) tracks. With the send set to pre-fader, the amount of effect is controlled by the level of the Send Level fader or the Auxiliary Input Volume fader. If the send is post-fader, the Send Level fader follows volume level.

See Chapter 49, “Plug-In and Hardware Inserts” for more information.
Send and Return Submixes with External Devices

To create an effects return submix with an external device:

1. Assign each track’s main output to your main mix outputs.

2. Assign a send (mono or stereo) and set the send destinations on the source tracks to the output path connected to the external device. Configure the sends for pre- or post-fader, as needed.

3. Choose Track > New.

4. Specify the track type (Aux Input) and format (stereo or mono), then click Create.

5. From the Auxiliary Input track’s Input Path selector, select the input path connected to the external device.

6. From the Auxiliary Input track’s Output Path selector, select an output path (main outputs).

7. Adjust the individual track faders to balance the dry (unprocessed) tracks.

The amount of effect is controlled by the level of the Send Level fader or the Auxiliary Input Volume fader.
Creating Monitor Submixes

Route track sends to one or more Auxiliary Input tracks to monitor submixes in a studio environment. You can monitor the main mix in the control room on one or more pairs of audio outputs while you route a submix to another pair of audio outputs for a headphone or “cue” mix for the “talent.” For example, you may want to provide the bassist with a submix of the drums and their own track for overdubbing a new bass part.

💡 With cue mixes, when recording overdubs it is recommended that there be no inserts (or at least only inserts with very low delays) on the record track to avoid any unnecessary latency in the monitoring signal path.

To create a monitor submix:

1. Assign each track’s main output to your main mix outputs.
2. Assign a send (mono or stereo) and set the send destinations on the source tracks to the output path connected to the external device. Configure the sends for pre- or post-fader, as needed.
3. Choose Track > New.
4. Specify the track type (Aux Input) and format (stereo or mono), then click Create.
5. From the Auxiliary Input track’s Output Path selector, select the output path (not the main outputs) for monitoring the mix.

Adjust the Auxiliary Input track fader to control the volume for the monitor mix.
Creating a Master Send Level Control

A Master Fader can control the overall level of bus and output paths.

To create a Master send level control:

1. Choose Track > New.
2. Specify the track type (Master Fader), and mono, stereo, or any of the supported multi-channel formats for surround mixing.
3. Click Create.
4. Do one of the following:
   • Set the output of the Master Fader to the same path that you are using to send to an Auxiliary Input track.
   • Set the output of the Master Fader to match the path that you have chosen for your effects send.

You can then adjust send levels to balance the source tracks, and use the Master Fader as a master level control for the entire submix.

Soloing Tracks in a Submix

Soloing any tracks implicitly mutes all other tracks, including Auxiliary Inputs. Solo-safing an Auxiliary Input prevents this implicit muting and lets the Auxiliary Input continue to pass audio when its source tracks are soloed.

To solo safe an Auxiliary Input:

- Command-click (Mac) or Control-click (Windows) the Solo button on the Auxiliary Input track.

To solo an individual track that is part of a group:

- Control-click (Mac) or Start-click (Windows) the Solo button.
Generating Stereo Output from a Mono Send/Return

You can use an Auxiliary Input to generate a stereo output from a mono send. Set the send destination to a mono Auxiliary Input track and place a mono to stereo plug-in on the Auxiliary Input. The output of the Auxiliary Input becomes stereo.

To create a “stereo” effect from a mono source, you must use reverb, delay, or other time domain effects.

Delay Compensation
(Pro Tools | Ultimate Software Only)

Pro Tools provides automatic Delay Compensation for managing DSP and host-based delays from plug-in inserts, and mixer routing (bussing and sends). With Delay Compensation enabled, Pro Tools maintains phase coherent time alignment between tracks that have plug-ins with differing delays, tracks with different mixing paths, tracks that are split off and recombined within the mixer, and tracks with hardware inserts.

When Delay Compensation is enabled, Pro Tools allocates 16,383 samples at 44.1/48 kHz, 32,767 samples at 88.2/96 kHz, or 65,534 samples at 176.4/192 kHz of Delay Compensation for each mixer channel. For sessions with plug-ins on mixer channels that result in more than 4,000 samples of delay at 48 kHz, select this setting.

To maintain phase coherent time alignment, Delay Compensation should always be enabled during playback and mixing. Delay Compensation should also be used in most recording situations.

Enabling Delay Compensation

To enable Delay Compensation:

- Select Options > Delay Compensation.

When Delay Compensation is enabled, the Delay Compensation status indicator in the Edit Window Toolbar is displayed.

⚠️ The Delay Compensation indicator in the Edit window turns red if you have any delays in the session that exceeds the maximum available delay compensation (see “Delay that Exceeds the Compensation Limit” on page 1085).

Red can also indicate that you have created a feedback loop that cannot be compensated for. For example, if the output of a track is routed to the input of the same track. Mouse over the Delay Compensation indicator in the Edit window to see if the tooltip identifies this as a problem.

The Delay Compensation View for tracks can be displayed in the Mix Window (see “Delay Compensation View” on page 1083).
Delay Compensation Time Mode

Delay values can be specified in either samples or milliseconds, as selected with the Delay Compensation Time Mode setting in the Operation Preferences page.

System Delay

Pro Tools adds the exact amount of delay to each track necessary to make that particular track’s delay equal to the total System Delay. The total system delay is the longest delay reported on a track, plus any additional delay caused by mixer routing.

The System Delay is shown in the Session Setup window (Session > Setup). Reference the reported System Delay to monitor whether or not you are close to exceeding the Delay Compensation limit.

Delay Compensation View

The Delay Compensation View displays the total amount of plug-in and hardware insert delay (Pro Tools Ultimate only), and the total amount of delay that Pro Tools applies to each track. You can also apply an offset for track delay on a track-by-track basis. The Delay Compensation View can be shown or hidden in the Mix Window.

Delay Compensation View

Delay Compensation view only shows the insert delay for each track. To view the complete system delay, including mixer delays, check the System Delay in the Session Setup window (see “System Delay” on page 1083).

To view Delay Compensation information:

- Select View > Mix Window > Delay Compensation.

Delay Compensation View Indicators and Field

Delay (dly) Indicator

The Delay (dly) indicator reports the total plug-in and hardware insert delay on the track. The Delay indicator’s report to Pro Tools Delay Compensation Engine can be bypassed when Delay Compensation is enabled. This is useful for manually time-aligning a track when the total delay on a track exceeds the Delay Compensation limit. See “Delay that Exceeds the Compensation Limit” on page 1085.
The display color indicates reported track delay, as follows:

**Green** Indicates that track delay reporting is enabled and the track does not exceed the available amount of Delay Compensation.

**Orange** Indicates that this is the track reporting the longest plug-in and hardware insert delay in the session.

**Red** Indicates that the amount of plug-in and hardware insert delay on the track exceeds the available amount of Delay Compensation (see “Delay that Exceeds the Compensation Limit” on page 1085).

**Gray** Track delay report is bypassed.

**User Offset (+/-) Field**

This field lets you adjust track delays manually while Delay Compensation is enabled. The User Offset is added to or subtracted from the amount of delay applied by Track Compensation. The User Offset is useful for the following cases:

- For manually time-aligning a track if a plug-in is incorrectly reporting its delay.
- For adjusting the timing “feel” of a track.

**To change track delay using the User Offset field:**

1. In the Delay Compensation View, click in the User Offset edit field.

2. To set your delay value (in samples or milliseconds depending on your current preferences), do one of the following:
   - Enter a positive number (with or without the “+” modifier) for a positive delay (later in time) or negative number (with the “−” modifier) for a negative delay (earlier in time).
   - Drag in the User Offset field to scroll to a new value. For finer resolution, Command-drag (Mac) Control-drag (Windows).
   - Press the Up and Down Arrow keys to increase or decrease the numerical values.

3. Press Enter.

**To bypass the user delay:**

- Command-Control-click (Mac) or Start-Control-click (Windows) the User Offset field. The user-defined delay appears grayed out and does not apply to the track.

**Track Compensation (cmp) Indicator**

This indicator shows the amount of Delay Compensation Pro Tools applies to each track.

The display color indicates the amount of Delay Compensation applied, as follows:

**Green** Track compensation is enabled and the track does not exceed the Delay Compensation limit. The amount of Delay Compensation shown in the indicator is applied to the track.

**Blue (Audio Tracks Only)** Indicates that Delay Compensation is force-enabled on the track. When the track is record-enabled or TrackInput-enabled, Delay Compensation is not suspended and remains enabled (see “Overriding Low Latency Monitoring During Recording” on page 1086).

**Red** Indicates that the track delay exceeds the available amount of Delay Compensation and no Delay Compensation is applied to the track (see “Delay that Exceeds the Compensation Limit” on page 1085).

**Gray** Indicates that Delay Compensation for the track is bypassed and no delay is applied to the track.
Delay Compensation for Side-Chains
(HDX Systems Only)

HDX systems let you automatically compensate for signal delays in side-chain processing. In some cases, you may want to disable automatic delay compensation for side-chains (such as for sessions created on previous versions of Pro Tools where you have manually compensated for side-chain delays).

To enable (or disable) automatic delay compensation for side-chains:
1. Choose Setup > Preferences.
2. Click the Operation tab.
3. Select (or deselect) the Compensate Side Chains option.
4. Click OK.

Delay that Exceeds the Compensation Limit

When the total delay on a track exceeds the total available amount of available Delay Compensation (selected in the Playback Engine dialog), no Delay Compensation is applied on that track. Any audio on that track will no longer be properly time-aligned and will be out of phase. Both the Delay indicator and Track Compensation indicator turn red to show that the track delay exceeds the Delay Compensation limit. The maximum available Delay Compensation is applied to all other tracks.

However, you can manually compensate for delay on tracks that exceed the Delay Compensation limit.

To compensate for delay that exceeds the compensation limit:
1. Bypass the reported delay for the track by doing one of the following:
   - Command-Control-click (Mac) or Control-Start-click (Windows) the Delay indicator.
   - Right-click the Delay indicator and select Disable Plug-In Delay.

   The track information is grayed out once it is bypassed.
2. Manually nudge any audio data on the track earlier by the amount of delay reported in the track’s Delay indicator.

💡 Use the Time Adjuster plug-ins to manually offset tracks in real-time. For more information, see the Audio Plug-ins Guide.

Low Latency Monitoring During Recording

When an audio track is armed for recording (record-enabled), TrackInput-enabled, Destructive-Punch-enabled, or punched in, the track’s Delay Compensation is automatically suspended (and the Track Compensation indicator displays 0). This reduces monitoring latency on those track outputs. When the track is played back (with both record-enable and TrackInput disabled) it is correctly time-aligned with the other delay-compensated tracks.

Tracks that are not record-enabled still apply Delay Compensation. Pro Tools automatically compensates for any timing discrepancies between the recorded material and the delay-compensated mix.

For more information about Low Latency Monitoring with host-processing only Pro Tools systems, see “Low Latency Monitoring” on page 514.
Overriding Low Latency Monitoring During Recording

You can override Low Latency Monitoring During Recording on record-enabled tracks, but this may introduce latency in the signal path corresponding to the amount of Delay Compensation. This latency may be acceptable depending on the recording source. For example, in certain “non-performance” workflows, overriding Low Latency Monitoring During Recording ensures that delay compensation is applied consistently regardless of whether a track is record- or punch-enabled, or whether Pro Tools is recording or playing back.

In certain dubbing workflows you may want to cascade bus recordings to multiple tracks. In these cases, be sure to override Auto Low Latency on all cascaded Record or InputMonitor tracks. Also, if you are punch recording, be sure to not use Native plug-ins on any Record or InputMonitor–enabled tracks or you will hear an audible click as any Native plug-ins on those tracks are automatically bypassed or un-bypassed when punching in and out.

To override Low Latency Monitoring During Recording on specific record tracks:

- Command-Control-click (Mac) or Control-Start-click (Windows) the Track Compensation indicator. Delay Compensations is applied to the track and the Track Compensation indicator displays in blue.

Command-Control-Shift-click (Mac) or Control-Start-Shift-click (Windows) the Track Compensation indicator to override Low Latency Monitoring for all selected tracks.

Command-Option-Control-click (Mac) or Control-Alt-Start-click (Windows) the Track Compensation indicator to override Low Latency Monitoring for all tracks.

Delay Compensation on Auxiliary Inputs

Delay Compensation on Auxiliary Inputs can be bypassed to let you monitor outside sources (such as the audio tracks of a slaved video deck) with minimal latency, while still reporting the track’s delay.

To bypass an Auxiliary Input’s Delay Compensation:

- Command-Control-click (Mac) or Start-Control-click (Windows) the Track Compensation indicator. The reported track delay will be zero, and will appear grayed out.

Delay Compensation for MIDI

Pro Tools automatically maintains time alignment between recorded MIDI events and delay compensated playback.

When Delay Compensation is enabled, a MIDI event that is recorded to sound “in time” with delay-compensated material actually is recorded late by the length of total delay in effect. To compensate, MIDI events are shifted back in time by the total session delay following each MIDI recording pass. MIDI playback after a record pass with Delay Compensation enabled accounts for the low latency recording path and maintains phase coherent time alignment with MIDI playback.

When any Instrument or MIDI track is record enabled, all Instrument and Auxiliary Input tracks with Instrument plug-in inserts that are configured to receive MIDI in Pro Tools are set to low-latency mode. In this case, the Delay Compensation indicators for those tracks display 0.
Low-Latency Recording with Virtual MIDI Instruments and Delay Compensation

When a MIDI or Instrument track that is routing MIDI data to an instrument plug-in is record-enabled, Pro Tools automatically suspends Delay Compensation through the main outputs of the audio track, Auxiliary Input, or Instrument track on which the instrument plug-in is inserted. This allows for latency-free monitoring of the instrument plug-in during recording.

Delay Compensation for Instrument plug-ins works only when all MIDI and audio connections take place inside Pro Tools. While Pro Tools does not suspend Delay Compensation when you are using ReWire to connect software synthesizers and samplers in other ReWire client applications (such as Reason), Pro Tools cannot account for any latency within the ReWire client itself.

MIDI and Audio Processing Plug-Ins

Some audio processing plug-ins (such as Bruno and Reso) and many instrument plug-ins let you process audio while allowing MIDI data to control processing parameters. When you record enable a MIDI or Instrument track that is controlling an audio processing plug-in, the track the plug-in is inserted on will go into low-latency mode, effectively making the processed audio play early. The steps to prevent this and keep audio time-aligned depend on the type of track on which the plug-in resides.

To keep audio time-aligned when recording using a MIDI controlled plug-in on an audio track:

- Command-Control-click (Mac) or Start-Control-click (Windows) the Track Compensation indicator for the audio track to apply Delay Compensation.

To keep audio time-aligned when recording using a MIDI controlled plug-in on an Auxiliary Input:

1. Command-Control-click (Mac) or Start-Control-click (Windows) the Track Compensation indicator for the Auxiliary Input to bypass Delay Compensation.

2. Enter the total system delay into the User Offset field.

Configuring Cue Mixes with Delay Compensation

If you already have a Pro Tools session that uses various plug-in inserts and mixer routing, you will most likely want to have Delay Compensation enabled. However, if you want to record overdubs with a recording artist, “the talent,” you will need to configure monitoring mixes (headphone or “cue” mixes).

Use sends to bus cue mixes to audio output paths for headphone monitoring by the talent. In addition to the main mix, which will monitor in the control room, route track sends to one or more additional audio output paths tracks for cue mix monitoring. Using sends lets you configure different mixes from the main mix for cue mix monitoring. For example, when recording a guitarist, they may want to hear themselves more in the cue mix than you will want to hear in the main mix.

Example configuration using sends for cue mixes:

1. Assign each track’s main output to your main mix outputs.

2. Assign a send (mono or stereo) for each track and set the send outputs to output paths 3 and 4 on your audio interface.

3. Enable the FMP (Follow Main Pan) button on all of the sends so that the cue mix has the same panning as the main mix.
4 Set all of the sends to unity and to post-fader. This lets you use the same mix for the talent, but also lets you boost (or attenuate) the level of the talent’s signal in the cue mix by adjusting the send level as needed.

5 Choose Track > New.

6 Specify the track type (Master Fader) and format (stereo), then click Create.

7 From the Master Fader track’s Output Path selector, select output paths 3 and 4 for monitoring the mix.

8 Adjust the Master Fader track’s fader to control the overall volume for the cue mix.

⚠️ *With Delay Compensation enabled, it is recommended that you do not use any inserts on any Auxiliary Input or Master Fader tracks you may be using to control the cue mix volume. Also, you should avoid using inserts on any record tracks. (Some low latency inserts may be acceptable depending on the talent’s preference.)*

9 Repeat the preceding steps for additional cue mixes on additional outputs on your audio interface as necessary.

### Setting a Hardware Insert Delay Offset

You can manually compensate for the delay (latency) of any external hardware devices (such as an effects unit) used in your session, you can set the amount of Hardware Insert Delay Compensation (in milliseconds) for each external device in the I/O Setup. These times will be used by the Delay Compensation Engine to time-align input paths when the hardware insert is in use and Delay Compensation is enabled.

#### To set an insert delay offset:

1. Choose Setup > I/O.

2. Click the H/W Insert Delay tab.

3. Type a value, in milliseconds, in the field corresponding with the input where the hardware insert is connected.

⚠️ *Insert delay offsets only have an effect when the I/O is used for hardware inserts.*

### Determining Your Hardware’s Insert Delay

Refer to the documentation for your external hardware to see if it identifies the hardware latency, or use the following procedure in Pro Tools to determine the latency for hardware inserts.

#### To determine your hardware’s insert delay:

1. Ensure that Automatic Delay Compensation is enabled (Options > Delay Compensation).

2. Change your session’s Main Time Scale to Min:Sec.

3. Create two tracks.

4. Place a short tone (or other sound with a definitive beginning) on track 1.

5. Insert the HW insert on track 1.

6. Ensure that only the dry signal is being passed through the device.

7. Bus the output of track 1 to the input of track 2.

8. Record enable track 2 and press Record Enable and Play in the Transport window to play back the audio in track 1 and record it to track 2.

9. After recording, zoom in and measure the difference between where the audio starts in track 1 and track 2. The difference is the value you would enter as your hardware’s insert delay offset.
Dither

Dither is used to minimize quantization artifacts when reducing the bit depth of an audio signal, for example, from 24-bit to 16-bit. Quantization artifacts are most apparent when a signal is near the low end of its dynamic range, such as during a quiet passage or a fade-out.

Dither minimizes quantization artifacts by introducing very low-level random noise to a signal, which smooths out the distortion that can result when the signal’s bit depth is reduced.

With dither there is a trade-off between signal-to-noise performance and less-apparent distortion. Proper use of dither lets you get better subjective performance when reducing the bit depth of audio.

Dither in Pro Tools

There are several ways dither can be used in Pro Tools. Each has a specific application within the various operations that could benefit from using dither.

Dither Plug-Ins for Mixdown Whenever you are mixing down or bouncing to disk and your destination bit depth is lower than 24-bit, insert a dither plug-in on a Master Fader that controls the output mix. You can use real-time dither plug-ins from Avid or third-party manufacturers.

For important information on using dither when mixing down or bouncing to disk, see “Using Dither” on page 1186.

Dither on Export and Import When you export audio to a lower bit depth, or when you import an audio file into a session that is at a lower bit depth than the file, a preset, noise-shaped dither is applied.

For more information about the application of dither on export, see “Exporting Audio” on page 410.

For more information about the application of dither on import, see “Bit Depth Conversion and Dither” on page 399.

Noise Shaping

Noise shaping can further improve audio performance and reduce perceived noise inherent in dithered audio. Noise shaping uses filtering to shift noise away from frequencies in the middle of the audio spectrum (around 4 kHz), where the human ear is most sensitive.

Noise Shaping is available in the Dither and POW-r Dither plug-ins.

For more information on using Noise Shaping, see the Audio Plug-Ins Guide.

Using an Ethernet Control Surface with Pro Tools

Avid offers several Ethernet-based control surface options for Pro Tools.

Pro Tools | S6

Pro Tools | S6 is a modular, ergonomically designed control surface for Pro Tools and EUCON-compatible digital audio workstations (DAWs). S6 uses the EUCON Ethernet protocol to provide fast, reliable data transmission. S6 is flexible and scalable. Modules can be arranged in many ways, and can be added to address new workflows or increase the number of strips.
D-Control and D-Command
(Pro Tools | Ultimate Software Only)

D-Control and D-Command tactile control surfaces are part of ICON, a flexible, integrated system that extends the functionality of Pro Tools.

C|24

C|24 is a dedicated control surface that provides access to nearly all Pro Tools recording, mixing, editing, signal routing, plug-in control, and automation features.

EUCON

Pro Tools supports Avid control surfaces using EUCON (Extended User Control) control (see the Pro Tools EUCON Guide). EUCON is an innovative high-speed Ethernet protocol developed by Avid to allow hardware control surfaces to directly communicate with software applications (such as Pro Tools).

Pro Tools | Control

The Pro Tools | Control app lets you control Pro Tools over a wireless network from an Apple iPad using EuControl. When combined with Pro Tools | S3, Pro Tools | Dock, or Artist Mix, Pro Tools | Control provides additional touch workflows for recording and mixing.

Enabling an Ethernet Control Surface in Pro Tools

To enable an Ethernet control surface in Pro Tools:

1 Choose Setup > Peripherals and click the Ethernet Controllers tab.
2 Select Enable.
3 If your Ethernet control surface consists of more than one unit, select the units in numerical order as you want them arranged left to right.
4 Click OK.

For more information, see the documentation that came with your Ethernet control surface.

To enable EUCON control in Pro Tools:

1 Choose Setup > Peripherals.
2 Select the Ethernet Controllers tab.
3 Select the EUCON option.
4 Click OK.

When the EUCON option is selected, Pro Tools is enabled for control by one or more EUCON-compatible controllers.

For more information about using Pro Tools with EUCON, see the Pro Tools EUCON Guide.

Using a MIDI Control Surface with Pro Tools

MIDI Control Surfaces add hands-on control to many Pro Tools functions, allowing you to adjust faders and knobs, activate transport controls, or edit plug-in parameters.

Command|8

Command|8 is a compact USB-based MIDI control surface for Pro Tools systems.

The Command|8 driver is only installed with Pro Tools 10.x.

For complete instructions on connecting and configuring Command|8, see the Command|8 Guide.
Other MIDI Control Surfaces

Pro Tools supports some MIDI control surfaces that use HUI controller personalities.

MIDI Control Surface Personalities

*MIDI Control Surface Personalities* are files that allow Pro Tools to communicate with the MIDI control surface. When you install Pro Tools, these files are installed by default in the Controllers folder inside the Pro Tools application folder. If the files are not present, run the Pro Tools installer to install the personality files.

Connecting a MIDI Control Surface

If your Pro Tools hardware includes MIDI ports, you can connect a MIDI control surface directly to your system. If it does not include MIDI ports, you will need to use a MIDI Interface. USB MIDI control surfaces (such as the Command|8) and FireWire control surfaces (such as the 003) do not require an additional MIDI connection to your computer.

To connect a (non-USB or FireWire) MIDI control surface:

1. Using a standard 5-pin MIDI cable, connect the MIDI Out port on your MIDI control surface to the MIDI In port on your Pro Tools hardware or MIDI interface.
2. Using a standard 5-pin MIDI cable, connect the MIDI In port on your MIDI control surface to the MIDI Out port on your Pro Tools hardware or MIDI interface.
3. If you have a multi-port MIDI interface, note which MIDI port the control surface is connected to.

Configuring Your System for a MIDI Control Surface

A MIDI Control Surface is configured in the same way as any other MIDI device in Pro Tools, using Audio MIDI Setup (Mac) or MIDI Studio Setup (Windows).

*For complete instructions on configuring your MIDI studio, see the User Guide that came with your system.*

Enabling a MIDI Control Surface in Pro Tools

To enable a MIDI control surface in Pro Tools:

1. Choose Setup > Peripherals and click the MIDI Controllers tab.
2. Choose your MIDI control surface device name from the Type pop-up menu.
3. Choose the MIDI control surface’s source port from the Receive From pop-up menu.
4. Choose a destination port from the Send To pop-up menu.
5. If your MIDI control surface has more than eight channel strips, or if you are using multiple devices of the same type in series, choose the appropriate number of channel strips from the pop-up menu under #Ch’s.
6. Click OK.

You can configure additional MIDI control surfaces (up to a total of four) by repeating the above steps. Make sure that none of the control surfaces are assigned to the same MIDI source and destination ports or channels in the Pro Tools Peripherals dialog.
Enabling the MIDI Control Surface as an Input Device

You must ensure that the MIDI control surface is enable as an input device in Pro Tools.

To enable a MIDI control surface as an input device:


2. Select the source port that you selected in the Receive From pop-up menu in the MIDI Controllers page of the Peripherals dialog.

3. Click OK.

If you want to prevent control surface MIDI data from reaching Pro Tools, you can deselect its source port in the MIDI Input Enable window.
Chapter 49: Plug-In and Hardware Inserts

A Pro Tools insert routes the signal from the track to an effect of your choice and automatically returns it to the same track. Inserts do not alter the original audio source files, but process audio in real time, during playback. You can permanently apply real-time effects to tracks by recording or bouncing the effect to disk (see Chapter 51, “Mixdown” for more information).

Inserts on audio tracks and Auxiliary Inputs and Instrument tracks are pre-fader. You can cause clipping if you boost their gain to extremes, especially on tracks recorded at high amplitude. Watch on-screen metering for indication of clipping. (Inserts on Master Faders are post-fader.)

Types of Inserts

An insert can be either a software DSP plug-in or a hardware insert.

Plug-In Inserts

Plug-In inserts are software inserts that process audio material on a track in real time. For example, the EQ, compressor, and delay plug-ins supplied with your Pro Tools system can be used as real-time plug-in inserts.

Additional real-time plug-ins are available from Avid and from many third-party developers.

Chapter 49: Plug-In and Hardware Inserts 1093
Hardware I/O Inserts

Hardware I/O inserts can route audio through an external device connected to parallel inputs and outputs of an audio interface. You can process the audio material on a track with a hardware insert in real time.

Insert paths require audio interface inputs and outputs, and are determined by the I/O Setup configuration of your system.

Using Inserts for Effects Processing

Inserts can be used in two ways:

On Single Tracks An insert can be applied to an individual audio, Auxiliary Input, Master Fader, or Instrument track.

With in-line inserts, you control the amount of effect by adjusting the balance (or the wet/dry mix) controls of the plug-in or external device.

As Shared Resources An insert can be used as a shared resource in a send-and-return arrangement, by bussing signals from several tracks to an Aux Input, and then applying the insert to that track. You can then control the send level for each track, and the overall level of the effect can be controlled from the Auxiliary Input track. Using sends and other signal routing features helps maximize your system’s processing power.

For examples of send and return busses and other submixing setups, see “Signal Routing for Monitoring and Submixing” on page 1074.

Insert Formats

Mono Inserts Used on mono tracks. Inserts that occur on a track after a stereo insert are automatically used in stereo as well.

Stereo Inserts Used on stereo tracks. A stereo hardware I/O insert sends the signal to an input/output path.

Mono In/Stereo Out Plug-In Inserts Used to return a stereo effect from a mono source. Certain plug-ins (such as D-Verb) let you generate stereo output from a mono channel. A track made into stereo in this way has panning controls for each channel of the stereo signal. Any inserts that occur on a track after a stereo insert are automatically used in stereo as well.

Multi-Mono Plug-In Inserts Used on stereo or greater-than-stereo multichannel tracks when a multichannel version of the plug-in is not available. Controls for all channels are linked by default so that you can adjust them in tandem. You can unlink controls for independent adjustment using the Master Link button. See “Linking and Unlinking Controls on Multi-Mono Plug-Ins” on page 1121.

Multichannel Plug-In Inserts Used on stereo and greater-than-stereo multichannel tracks. On greater-than-stereo multichannel tracks, the controls for all channels are generally linked together.

Relinking may cause automation to be lost. See “Linking and Unlinking Controls on Multi-Mono Plug-Ins” on page 1121.
Plug-In Formats

There are three plug-in formats supported by Pro Tools (DSP, Native, and AudioSuite), two of which can be used as real-time inserts, as follows:

**DSP Plug-Ins** Provide real-time plug-in processing using DSP-based processing with HDX systems only.

**Native Plug-Ins** Provide real-time plug-in processing using host-based processing.

**AudioSuite Plug-Ins** Provide non-real-time (rendered), file-based processing plug-ins for Pro Tools.

For information on using AudioSuite plug-ins in Pro Tools, see Chapter 42, “AudioSuite Processing.”

Depending on your Pro Tools software, real-time plug-ins can be used as follows:

**HDX Systems**

DSP and Native plug-ins can be used on audio, Auxiliary Input, Master Fader, and Instrument tracks.

With HDX systems, Native plug-ins may use additional voices and introduce extra latency based on the HW Buffer Size. See “Inserting Native and DSP Plug-Ins on Tracks” on page 1098.

**Pro Tools Host-Based Systems**

Native plug-ins can be used on audio, Auxiliary Input, Master Fader, and Instrument tracks.

For tips on maximizing Native plug-in performance, see “Configuring Pro Tools Software System Settings” on page 90.

Viewing Inserts

Both the Mix and Edit windows can be configured to show or hide inserts A–E and F–J. Plug-In windows provide complete access to plug-in controls.

To show (or hide) inserts, do one of the following:

- In the Mix window (or Edit window), select View > Mix Window (or Edit Window) > Inserts A–E or Inserts F–J.

- Select Inserts A–E or Inserts F–J from the Edit Window or Mix Window View selector.

inserts and Sends in the Mix window

- Select Inserts A–E or Inserts F–J from the Edit Window or Mix Window View selector.
Display of Plug-In Window Status

In the Mix and Edit window, the plug-in button and selector display the currently inserted plug-in, its bypass state (see “Bypassing Plug-Ins” on page 1119), focus status, and window status.

Indicating the Controller Focus

For most control surfaces, only one plug-in can be focused at a time. ICON control surfaces can have up to four plug-ins focused at once (using the EQ and Dynamics controls, and Custom Faders on your control surface).

The current controller focus, if any, is indicated with a color outline around its name:

Making Inserts Inactive

Plug-In and hardware inserts can be made inactive to free up their resources for other uses. When a plug-in insert is inactive it retains its assignment, position, and related automation playlists. However, it will not pass audio and does not consume any DSP resources.

When opening sessions, inserts will automatically be made inactive in any of the following situations:

- The system has insufficient DSP resources
- A plug-in is not installed
- A plug-in type is not available
- Opening the session results in plug-in type substitutions. This can happen if the type is available but substituting would result in an unsupported condition, such as opening a session containing a DSP-based plug-in for which a host-based version is unavailable.

To make an insert inactive, do one of the following:

- Command-Control-click (Mac) or Control-Start-click (Windows) the Insert button.
- Right-click the Insert button and select Make Inactive.
- Make the track inactive. See “Making Tracks Inactive” on page 259.

To toggle inserts in the same position on all tracks active or inactive:

- Command-Control-Option click (Mac) or Control-Start-Alt click (Windows) an Insert button in the position you want to toggle.

To toggle inserts in the same position on all selected tracks active or inactive:

- Command-Control-Option-Shift-click (Mac) or Control-Start-Alt-Shift-click (Windows) an Insert button in the position you want to toggle.
Inactive Plug-In Inserts

Inactive plug-in inserts retain all associated automation playlists. In addition, any edits made in the session affect the plug-in automation playlists. You cannot record automation or adjust the controls for an inactive plug-in.

Inactive Hardware Inserts

Inactive hardware inserts retain their assignments, but do not pass audio and do not consume any DSP resources.

💡 Hardware inserts do not provide a bypass control. You can use the inactive feature whenever you need to mute or bypass a hardware insert.

Inserting Plug-Ins on Tracks

To use a real-time plug-in, insert it on a track.

⚠️ Plug-Ins cannot be inserted or removed during recording.

To insert a plug-in on a track:

1. Make sure the Inserts (A–E or F–J) View is shown in the Mix or Edit window.

2. Click the Insert selector on the track and select the plug-in that you want to use. (See “Plug-In Formats” on page 1095 for related information.)

To remove an insert from a track:

- Click the Insert selector and choose No Insert.

💡 You can insert a plug-in on a track by dragging one of its Plug-In Settings (.tfx) files from a Workspace browser onto an available track Insert position in the Mix window. See “Dragging and Dropping Plug-In Settings Files” on page 1113.
Inserting Native and DSP Plug-Ins on Tracks
(HDX Systems Only)

With HDX systems, you can use both Native (host-based) and DSP plug-ins on tracks.

Using Only Native Plug-Ins

With Pro Tools HDX systems, the initial insert of a Native plug-in may cause additional latency, and in large sessions, may use an additional voice, under the following conditions:

• When inserted on an Auxiliary Input or Master Fader track
• When inserted on an Instrument track that does not contain an instrument plug-in
• When inserted after a DSP plug-in on any kind of track

Subsequent Native plug-ins on the same track do not take up additional voices unless a DSP plug-in is inserted between those Native plug-ins.

In large sessions, when using Native plug-ins on a track, an additional voice may be used in each occurrence of any of the following conditions:

• When you use the external key side-chain of a Native plug-in on that track
• When you select multiple track outputs for that track (one voice used for each output)
• When you select an AFL/PFL Path output in the Output tab of the I/O Setup dialog (one voice used for each channel)

Combining Native and DSP Plug-Ins

With Pro Tools HDX systems, when Native and DSP plug-ins are combined on tracks, the order in which they are inserted produces different results:

Native Plug-Ins Grouped Before DSP Plug-Ins
On audio tracks, no additional voices are used, and no processing latency occurs. Native plug-ins are bypassed when the track is record enabled or TrackInput monitoring is enabled for that track.

Native Plug-Ins Grouped After DSP Plug-Ins
On audio, Auxiliary Input, Master Fader and Instrument tracks, each initial insert of a Native plug-in after a DSP plug-in on a track may cause processing latency, and in large sessions, may use additional voices. Native plug-ins remain active while the track is record enabled or TrackInput monitoring is enabled for that track.

⚠️ To optimize voice usage and minimize latency, group plug-ins of the same type together, especially if inserting Native after DSP plug-ins. Otherwise, additional voices may be used unnecessarily.

Ordering Recommendations

When combining Native and DSP plug-ins on a track, use one of the following strategies based on your recording needs:

• To ensure that Native plug-ins stay active when you record enable a track or use TrackInput monitoring, order all DSP plug-ins before Native plug-ins.
• To conserve voices and minimize processing latency, order all Native plug-ins before DSP plug-ins.

⚠️ Native Virtual Instrument plug-ins cannot follow Native processing plug-ins.
Plug-In Menu Organization

You can customize how plug-in lists (plug-in menus) are organized in the Insert selector and Plug-In selector.

Use the Organize Plug-In Menus By setting in the Display Preferences page to organize plug-in menus in a Flat List (with plug-ins in alphabetical order), or by Category, Manufacturer, or Category and Manufacturer.

Control Surface Support

Control surfaces with multi-color LCDs (such as D-Control) indicate plug-ins as follows:

- Plug-In categories (such as EQ) and plug-in manufacturers (such as Aphex) are indicated in yellow (amber) text.
- Specific plug-ins located in the plug-in subfolders (such as EQ III in the EQ subfolder) are indicated in green text.

Control surfaces with single-color displays (such as Command|8) do not indicate plug-in view choices. They display contents of a plug-in folder as a single list of plug-ins.

“Organize Plug-In Menus By” Setting

Flat List Organizes plug-ins in a single list, in alphabetical order.

Category Organizes plug-ins by process category (such as EQ, Dynamics, and Delay), with individual plug-ins listed in the category submenus. Plug-Ins that do not fit into a standard category (such as the Signal Generator), or third-party plug-ins that have not had a category designated by their developers, appear in the Other category. Plug-Ins can appear in more than one category.

Plug in categories include:
- EQ
- Dynamics
- Pitch Shift
- Reverb
- Delay
- Modulation
- Harmonic
- Noise Reduction
- Dither
- Sound Field
- Instrument
- Other
- Effects

The Effects subfolder organizes special effects, multi-effect processors, and other plug-ins. All plug-ins that specify their plug-in category as an “Effects” type will be displayed within the Effects subfolder.

⚠ If no plug-ins within a certain category are installed on your system, the subfolder named for that category will not appear in the menu.

Manufacturer Organizes plug-ins by their manufacturer, with individual plug-ins listed in the manufacturer submenus. Plug-Ins that do not have a Manufacturer defined will appear in the “Other” manufacturer folder.

⚠ If no plug-ins by a certain manufacturer are installed on your system, the subfolder named for that manufacturer will not appear in the menu.
**Category and Manufacturer** Organizes plug-ins in two levels of menus. The top menus display plug-ins by process category (such as EQ, Dynamics, and Delay), with individual plug-ins listed in the category submenus. The bottom menus display plug-ins by manufacturer, with individual plug-ins listed in the manufacturer submenus.

**To select how plug-ins are organized:**

1. Open or create a session.
2. Choose Setup > Preferences, and click Display.
3. Click the Organize Plug-In Menus By pop-up menu, and select one of the view options.
4. Click OK.

The Organize Plug-In Menus By setting is saved with Pro Tools preferences (it is not saved with the Pro Tools session file).

---

**Plug-in Insert Search**

**To find a plug-in in an Insert selector by typing:**

1. Click the insert selector on a track where you want to insert a plug-in and do one of the following:
   - Type the first character of the plug-in name you want.
   - Click Search.
   - Press Tab.

2. Type a few letters included in the plug-in name that you want. Only plug-ins whose names include those letters (highlighted yellow) now appear in the list (maximum of 20).

3. Select the desired plug-in with the mouse, or use the Up and Down arrow keys to select the plug-in name.

4. Press Return (Mac) or Enter (Windows) to insert the selected plug-in.

💡 You can also search Track Presets by name from the Insert selector. Depending on the preset, this lets you insert multiple pre-configured inserts on the track.
Default EQ and Dynamics Plug-Ins

You can set a default EQ plug-in and Dynamics plug-in, which places them at the top of the Insert selector pop-up menu on-screen, and first in the list of menu choices when assigning inserts on ICON worksurfaces.

To set a default plug-in:

1. Choose Setup > Preferences and click Mixing.
2. Under Setup, choose a plug-in from the Default EQ or Default Dynamics pop-up menu.
3. Click OK to close the Preferences window.

Plug-In Favorites

To find a plug-in faster, a plug-in can be designated as a favorite. Favorite plug-ins are shown at the top of the plug-in menu.

When a plug-in becomes a favorite, it is still shown in its plug-in category and its name appears in bold.

To designate a plug-in as a favorite:

- Command-click (Mac) or Control-click (Windows) the Insert selector and select a plug-in to designate it as a favorite.

To change the status of a plug-in favorite:

- Command-click (Mac) or Control-click (Windows) the Insert selector and select a plug-in favorite that you no longer want designated as a favorite.

When selecting the plug-in favorite to change, you can select the plug-in from the list of favorites at the top of the plug-in menu, or in its plug-in category (where the plug-in appears in bold).
Moving and Duplicating Plug-In and Hardware Inserts

You can move or duplicate an insert by dragging it to a different position on the same track or a different track. Inserts that are moved or duplicated retain their original settings and automation.

⚠️ Plug-ins cannot be moved or duplicated during recording.

To move an insert:

- Drag the insert to a new insert location.

To duplicate an insert:

- Option-drag (Mac) or Alt-drag (Windows) the insert to a new insert location. Duplicated plug-in inserts retain their original settings and automation.

💡 You can also duplicate Sends. See “Moving or Copying Sends” on page 1067

Plug-In Windows

A Plug-In window appears whenever you click a plug-in’s Insert button on a track. This floating window lets you adjust the controls of any real-time plug-in insert in use on a track.
Track Controls in the Plug-In Window

**Track Selector**
Accesses any track in the session except MIDI, VCA, and Video tracks.

**Insert Position Selector**
Accesses any insert on the current track.

**Plug-In Selector**
Lets you select any real-time plug-in installed in the Plug-Ins folder (that is created when you install Pro Tools).

**Key Input Selector**
Lets you select audio on a particular input or bus and route it to trigger the plug-in. This selector only appears on plug-ins that feature side-chain processing. Key inputs are monophonic.

**MIDI Node Display**
Shows MIDI node information for MIDI-enabled plug-ins. MIDI nodes are virtual connections from Pro Tools to software instruments and other MIDI-enabled plug-ins. MIDI nodes are useful for routing multiple MIDI tracks to different channels of a single virtual MIDI device. MIDI node numbers are also displayed in a track’s MIDI Output selector. The MIDI node indicator only appears in plug-ins that can receive MIDI.

Preset Controls in the Plug-In Window

**Plug-In Settings Menu**
Lets you copy, paste, save, and import plug-in settings.

**Plug-In Librarian Menu**
Recalls plug-in presets (plug-in settings files saved in the plug-in’s root settings folder or in the current session’s Settings folder). See “Plug-In Presets” on page 1109.

**Next (+) and Previous (–) Setting Buttons**
Let you select the next or previous preset from the Librarian menu.

**Compare**
Toggles between the original saved plug-in settings and any changes you have made to it so you can compare them.

---

You will lose the current settings if they are not saved before you use the Next and Previous Setting buttons. Always save your plug-in settings as a preset using the Plug-In Settings menu.

---

Chapter 49: Plug-In and Hardware Inserts
Automation Controls in the Plug-In Window

**Auto button**

**Automation Safe button**

 Automation controls in the plug-in window

**Auto Button** Lets you enable individual plug-in controls for automation recording. See “Automating Plug-Ins” on page 1141.

**Automation Safe** When enabled, prevents existing plug-in automation from being overwritten.

Plug-In Map Controls in the Plug-In Window

(Control Surfaces Only)

When a supported control surface is declared in Pro Tools, Plug-In Map controls appear in the plug-in window.

Map Options menu

Map Presets menu

Learn button

Parameter menu

Plug-In Map controls in the plug-in window

**Map Options Menu** Lets you create, rename, save, delete, import, export, and set default plug-in maps.

**Map Presets Menu** Lets you choose from available custom Plug-In Maps for the plug-in.

**Learn Button** Puts the plug-in in Learn mode, where you can map plug-in parameters to a control surface.

Parameter Menu When in Learn mode, lets you select a parameter on the plug-in for mapping. If you click a parameter in the plug-in window while in Learn mode, this menu shows the name of the parameter.

Additional Plug-In Controls in the Plug-In Window

**Plug-In Bypass button**

**Target button**

**Convert Plug-In selector**

Plug-In Map controls in the plug-in window

**Effect Bypass Button** Disables the currently displayed plug-in. This lets you compare the track with and without the effect.

**Convert Plug-In Selector** Lets you convert the insert from a DSP plug-in to a Native plug-in of the same type (or vice-versa). This feature can only be used on plug-ins that are available in both DSP and Native formats.

⚠️ **Converting from DSP to Native is disallowed on Auxiliary Input tracks.**

**Target Button** When multiple Plug-In windows are open, clicking this button selects that plug-in as the target for any computer keyboard commands.

Multi-Mono Controls in the Plug-In Window

**Link Enable buttons**

**Master Link button**

**Channel Selector**

Plug-In window (multi-mono 1-Band EQ shown)
**Master Link Button** When enabled, links the controls on all channels of a multi-mono plug-in so that they can be adjusted in tandem.

**Link Enable Buttons** Let you selectively link or unlink the controls of specific channels of a multi-mono plug-in. Each square represents a speaker channel. The Master Link button must be disabled to use the Link Enable buttons. See “Linking and Unlinking Controls on Multi-Mono Plug-Ins” on page 1121.

**Channel Selector** Accesses a specific channel within a multichannel track for plug-in control editing. This menu appears only on multi-mono plug-ins inserted on tracks with more than one channel. Shift-clicking this selector opens a separate Plug-In window for each channel of the multichannel track on which the plug-in is inserted.

---

**Opening Plug-In Windows**

**To open a plug-in window:**

- Click the plug-in button in Inserts view in the Mix or Edit window.

By default, each plug-in you open will appear in the same location as a currently open plug-in, replacing it in the same window location.

**Opening Multiple Plug-In Windows**

Pro Tools normally displays a single plug-in window from which you can adjust the controls of any session plug-in. You can also open additional Plug-In windows for specific plug-ins. Once you begin working with multiple plug-in windows, you will need to click the Target button on the plug-in whose controls you want to adjust using keyboard commands.

**To open an additional plug-in window:**

- In the Mix window, Shift-click the Insert button of a plug-in. The new plug-in window opens un-targeted.

**To open plug-in windows for each channel of a multi-mono plug-in:**

- Option-click (Mac) or Alt-click (Windows) the Channel selector in the Plug-In window of a plug-in insert.

**To close all currently open plug-in windows:**

- Option-click (Mac) or Alt-click (Windows) the close box of any currently open plug-in window.

---

**Using Plug-In Window Controls**

All plug-ins provide standard Pro Tools controls for track and insert selection, bypass, and other controls, in addition to the EQ, dynamics, and other processor-specific controls.

**To select a different plug-in on the same track:**

- Click the Insert selector and select another plug-in from the pop-up menu.

**To choose a different track:**

- Click the Track selector and select another track from the pop-up menu.

**Target Window and Settings Shortcuts**

When multiple plug-in windows are open, a highlighted target indicates the target window. Pro Tools keeps a single plug-in target window. Opening a new plug-in opens it as the new target window, in the same location. In addition, the plug-in target window is also the focus of keyboard shortcuts for plug-in settings.
Editing Plug-In Controls

You can adjust plug-in controls by dragging the control’s slider or knob, or by typing a value into the control’s text box. For instructions on editing specific plug-ins, see the plug-in’s documentation.

For information about the specific controls of each of the plug-ins (installed with Pro Tools), see the Audio Plug-Ins Guide. Additional free plug-ins (and paid plug-in options) that can be installed with Pro Tools are also documented in the Audio Plug-Ins Guide.

To adjust a plug-in control:

1. Begin audio playback so that you can hear the control changes in real time.
2. Adjust the controls of the plug-in for the effect you want.
3. Close the Plug-In window to save the most recent changes.

Editing Plug-In Parameters Using a Mouse

You can adjust rotary controls by dragging horizontally or vertically. Parameter values increase as you drag upward or to the right, and decrease as you drag downward or to the left.

Keyboard Shortcuts

- For finer adjustments, Command-drag (Mac) or Control-drag (Windows) the control.
- To return a control to its default value, Option-click (Mac) or Alt-click (Windows) the control.

Editing Plug-In Parameters Using a Computer Keyboard

You can use your computer keyboard to edit plug-in controls.

If multiple Plug-In windows are open, Tab and keyboard entry remain focused on the plug-in that is the target window.

The plug-in target window is the focus of keyboard shortcuts for plug-in settings. To make a plug-in the target for any computer keyboard commands (including key shortcuts), click the plug-in’s Target button in its Plug-In window.

To change control values with a computer keyboard:

1. Click or Navigate to the control text field that you want to edit to activate the field.

   To move forward through the different control fields, press the Tab key. To move backward, press Shift+Tab.

2. Change the value by doing one of the following.
   - To increase a value, press the Up Arrow on your keyboard.
   - To decrease a value, press the Down Arrow on your keyboard.
   - Type the value.

In fields that support values in kilohertz, typing “k” after a number value will multiply the value by 1,000. For example, type “8k” to enter a value of 8,000.
3 Do one of the following to confirm the value:
• Press Enter on the numeric keyboard to input the value and remain in keyboard editing mode.
• Press Return (Mac) or Enter on the alphanumerical keyboard (Windows) to enter the value and leave keyboard editing mode.

To clear all clip indicators in the session, including plug-in clipping:
- Press Option+C (Mac) or Alt+C (Windows).

Plug-In Automation and Safe Modes

All real-time plug-ins can be fully automated, and support all Pro Tools Automation modes (Write, Touch, and Latch, plus Trim).

The Auto button opens the Plug-In Automation dialog, where you can enable individual plug-in controls for automation recording (see “Automating Plug-Ins” on page 1141).

The Safe button engages Automation Safe mode. When enabled, existing plug-in automation is protected from being overwritten (see “Record Safing Plug-In Automation” on page 1143).

Side-Chain Input

The side-chain input is the split-off signal used by a plug-in's detector to trigger dynamics processing, and is generally drawn internally from the input signal. However, some plug-ins let you switch between internal and external side-chain processing.

With external side-chain processing, a plug-in's detector is triggered by an external signal (such as a separate reference track or audio source) known as the key input.

A typical use for external side-chain processing is to control the dynamics of one audio signal using the dynamics of another signal (the key input). For example, a kick drum track could be used to trigger gating of a bass track to tighten it up, or a rhythm guitar track could be used to gate a keyboard pad.

When using a dynamics insert keyed to an external side chain using physical I/O, it is recommended that the plug-in be the first insert (Insert A) on a track.

Side-Chain Filters

Some plug-ins feature key high-pass and low-pass filters. These controls let you define a specific frequency range in the side-chain signal with which to trigger the plug-in effect. A common production technique is to use these controls to filter a drum track so that only specific high frequency sounds (such as a hi-hat) or low frequency ones (such a tom or a kick) trigger the effect.

Using a Key Input for External Side-Chain Processing

To use a key input for external side-chain processing:

1 Click the plug-in’s Key Input selector and select the input or bus carrying the audio you want to use to trigger the plug-in; or select Search to find the desired key input by typing the path name.
2 Click the External Key to activate external side-chain processing.

3 Press the Spacebar to begin playback. The plug-in uses the input or bus that you chose as a key input to trigger its effect.

4 During playback, do any of the following to fine-tune key input triggering:
   • To hear the audio source you have selected to control the key input, enable Side-Chain Listen or Key Listen (depending on the plug-in). When finished, disable Side-Chain Listen/Key Listen to resume normal plug-in monitoring.
   • To filter the key input so that only specific frequencies trigger the plug-in, use the filtering controls (if available) to select the frequency range.

5 Adjust the plug-in’s Threshold control (if available) and other controls as needed.

**Delay Compensation for Side Chains**  
**(HDX Systems Only)**

Pro Tools | Ultimate with HDX hardware lets you apply automatic Delay Compensation to side-chains.

To apply Delay Compensation to side-chains:
1 Choose Setup > Preferences.
2 Click the Mixing tab.
3 Enable the Compensate Side Chains option.
4 Click OK.

---

**Plug-in Bus Outputs**

Some plug-ins (such as some virtual instrument or multi-band processing plug-ins) provide separate bus outputs you can use to route audio from the plug-in to the input of another track for additional processing, monitoring, or recording.

---

Assigning a plug-in bus output to the input of an Auxiliary Input track

⚠️ A plug-in with an output bus assigned to the input of another track cannot be moved to that track.

⚠️ A plug-in with any assigned output busses cannot be removed or replaced until all plug-in output busses are unassigned.
Plug-In Presets

Pro Tools makes it easy to create your own library of plug-in settings, or presets. Using the Plug-In Settings menu, you can copy, paste, save, and import these settings from plug-in to plug-in, or from session to session.

Once you create and save settings files to disk (and tell Pro Tools where to find them by assigning to a root folder) they appear both in the Plug-In Librarian menu and in the Plug-In Settings dialog. They also appear as plug-in settings files (.tfx) in Workspace browsers.

💡 You can use the Plug-In Settings dialog to audition and select plug-in settings (see “Plug-In Settings Dialog” on page 1111).

Plug-In Settings Menu

Use the Plug-In Settings menu commands to save, copy, paste, and manage plug-in settings as presets (plug-in settings files).

Plug-In Settings menu commands include:

**Save Settings** Saves the current settings. This command overwrites any previous version of the preset.

**Save Settings As** Saves the current settings as a new preset under a different name.

**Copy Settings** Copies the current plug-in settings. You can then apply these settings to the same type of plug-in on a different track by choosing the track in the Plug-In window and pasting the settings with the **Paste Settings** command.

**Paste Settings** Pastes plug-in settings copied with the **Copy Settings** command.

**Import Settings** Imports a plug-in settings file (.tfx) from a location other than the Root Settings folder or Session folder.

**Delete Current Settings File** Permanently deletes the current plug-in settings file (.tfx) from disk.

**Lock Settings File** Prevents the current preset from being overwritten by the Save command. If you attempt to save any changes to the plug-in settings, you will be prompted to save them using a different name or disk location.

**Set As User Default** Defines the current preset as the User Default for the selected plug-in.

Settings Preferences

The Settings Preferences submenu provides commands for configuring preferences for saving and importing presets. They include:

**Set Plug-In Default To** Sets the default preset to either Factory Default (the standard default setting for that plug-in) or User Default (your custom setting).
**Save Plug-In Settings To** Selects the folder where presets (plug-in settings files) are saved. If you select Session Folder, the settings are saved in a folder named “Plug-In Settings” within the current Session folder. If you select Root Settings Folder, the settings are saved in the folder you specified with the Set Root Settings Folder command. You can change the location of the Root Settings Folder in the Operation Preferences (see “User Media and Settings Location” on page 110).

⚠️ To save plug-in settings to any location other than the default Plug-In Settings folder, you must first create a folder named “Plug-In Settings” in the new location and then save to that folder.

**Choosing a Destination for Settings**

Before you save plug-in settings, select their destination folder.

**To select a destination folder:**

- From the Plug-In Settings menu, choose Settings Preferences > Save Plug-In Settings To, and select Session Folder or Root Settings Folder.

If you selected Root Settings Folder, Pro Tools saves to the default Root Plug-In Settings folder unless you have specified a different location for the Root Settings folder.

**To select a different Root Settings folder:**

1. From the Plug-In Settings menu, choose Settings Preferences > Set Root Settings Folder.
2. Select the folder you want to use as your Root folder and click Select.

**Creating Subfolders for Settings**

To make it easier to find specific types of settings, you can subdivide settings files by creating subfolders for them.

**To create a settings subfolder:**

1. From the Plug-In Settings menu, choose Save Settings.
2. Click the New Folder button and type a name for the subfolder.
3. Name the preset and click Save. The plug-in settings file is saved within the subfolder.

**Managing Presets**

Use the Plug-In Settings menu to manage plug-in presets.

⚠️ Unlinked multi-mono plug-ins have specific rules for settings. See “Linking and Unlinking Controls on Multi-Mono Plug-Ins” on page 1121.

**To save a preset:**

1. Choose Save Settings from the Plug-In Settings menu.
2. Type a name and click OK. The setting appears in the Plug-In Librarian menu.

Press Command+Shift+S (Mac) or Control+Shift+S (Windows) to save plug-in settings.

**To load a plug-in preset:**

- Choose the name of the preset from the Plug-In Librarian menu.
To import a preset:

1. Choose Import Settings from the Plug-In Settings menu.

2. Locate the settings file you want to import and click Open. Pro Tools loads the setting and copies it to the root destination folder.

To copy plug-in settings:

- Choose Copy Settings from the Plug-In Settings menu.

   \[\text{Press Command}+\text{Shift}+C\ (\text{Mac})\ or\ \text{Control}+\text{Shift}+C\ (\text{Windows})\ to\ copy\ plug-in\ settings.\]

To paste plug-in settings:

1. Open the destination plug-in.

2. Choose Paste Settings from the Plug-In Settings menu.

   \[\text{Press Command}+\text{Shift}+V\ (\text{Mac})\ or\ \text{Control}+\text{Shift}+V\ (\text{Windows})\ to\ paste\ plug-in\ settings.\]

To create a custom User Default preset:


2. Select Set As User Default from the Plug-In Settings menu.

To make a plug-in default to your custom preset:

- From the Plug-In Settings menu, select Settings Preferences > Set Plug-In Default To > User Setting.

---

**Changing Presets with the Next (+) and Previous (−) Setting Buttons**

These buttons let you select the next or previous preset in the Plug-In Librarian menu.

To change plug-in presets using the +/− buttons:

- Click the Plus (+) or Minus (−) buttons to select the next or previous preset. The next (or previous) preset is enabled, and the Plug-In Librarian menu changes to show the name of the new preset.

   \[\text{You will lose the current plug-in settings if they are not saved before you use the Next and Previous Setting buttons. Always save your plug-in settings to the selected Root Settings folder.}\]

**Editing Settings on Unlinked Multi-Mono Plug-Ins**

When a multi-mono plug-in is unlinked, importing, copying, pasting, or bypassing settings affects only the currently selected channel.

---

**Plug-In Settings Dialog**

The Plug-In Settings dialog lists the presets for the current plug-in type. From this list, you can audition and select presets.

Use the Folder pop-up menu at the top of the Plug-In Settings dialog to switch between plug-in settings subfolders, or root and session settings folders.
The Plug-In Settings dialog includes the following:

**Folder** This pop-up menu lets you switch between presets located in root or session folders (and any available subfolders).

**Patch Field** This field displays the name of the active (highlighted) preset.

**Increment Patch Every X Sec** This option lets you audition plug-in presets in series by automatically scrolling through them for a specified number of seconds.

To change plug-in presets using the Plug-In Settings dialog:

1. Click the Settings Select button.
2. Do one of the following:
   - Select a preset from the dialog list.
   - Use the Arrow keys to scroll through the available presets.
3. Click Done.

---

**Auditioning Plug-In Presets**

When the Plug-In Settings dialog is open, you can have Pro Tools automatically scroll through and audition the plug-in settings files saved in the plug-in’s root settings folder or in the current session’s settings folder.

**To audition plug-in presets:**

1. Click the Settings Select button.
2. From the dialog list, click a preset—the starting point from which you will scroll through the settings files.
3. Enter a value for the number of seconds that will elapse between each preset change.
4. Select the Increment Setting option.

After the specified number of seconds, Pro Tools selects the next preset.

5. When you are finished auditioning presets, do one of the following:
   - Click Done to stop incrementing patches, and to close the Plug-In Settings dialog.
   - Deselect the Increment Patch option to stop incrementing patches and keep the Plug-In Settings dialog open. Then select the preset you want and click Done.

**Workspace and Plug-In Settings Files**

Workspace browsers recognize plug-ins settings files (.tfx) as a known Type and lets you drag and drop them to Pro Tools plug-in windows and Inserts. You can also search for plug-in settings by type.

---

*To switch between plug-in settings subfolders, press Command (Mac) or Control (Windows) and use the Up/Down Arrow keys.*

3. Click Done.
Searching for Plug-In Settings Files

To search for plug-in settings files:

1. In the Workspace browser, click the Advanced Search icon.

2. For the search criteria, select Kind > Is > Plug-In Settings File.

3. To further narrow your search, set additional search criteria as desired.

💡 You can create catalogs of specific plug-in settings that you work with frequently to streamline your workflow. For more information on Catalogs, see “Catalogs” on page 351.

Dragging and Dropping Plug-In Settings Files

You can insert a plug-in with a specific plug-in settings file, as well as change plug-in settings of inserted plug-ins by dragging and dropping plug-in settings files from a Workspace browser.

To insert a plug-in by drag and drop:

- Drag a plug-in settings file from a Workspace browser to an Insert in the Mix (or Edit) window.
To change a plug-in preset by drag and drop:

- Drag a plug-in settings file from a Workspace browser to the plug-in window. The plug-in settings file must be for the same plug-in name. For example, you cannot replace a 1-Band EQ 3 with a plug-in setting for 4-Band EQ 3.

**Selecting Plug-In Presets from the Plug-In Selector**

Pro Tools lets you select plug-in settings from the Insert Right-click menu using the User Presets submenu.

**To select a plug-in setting for a plug-in insert in the Mix or Edit window:**

1. With Inserts view shown, Right-click the plug-in Insert in the Mix or Edit window.

2. From the User Presets submenu, select the plug-in setting you want.

**Plug-In Mapping (Control Surfaces Only)**

Pro Tools lets you customize the arrangement of plug-in parameter controls on supported control surfaces. You can save these customized plug-in maps as presets and export them for use across different sessions and systems. Plug-In Maps are stored in the Plug-In Maps folder in the Pro Tools Root Settings folder. You can change the location of the Root Settings Folder in the Operation Preferences (see “User Media and Settings Location” on page 110).

**Plug-In Learn Mode**

Plug-Ins can be put into Learn mode, from which any automatable plug-in parameter can be mapped to a channel strip encoder, switch, or (in Flip mode) fader on the control surface.

**Plug-In Map Presets**

A map for a plug-in can be saved and recalled for any plug-in of the same type.

You can save multiple map presets for a single plug-in, and switch between maps at any time during a session.

You can also use multiple map presets on different instances of a plug-in at the same time. This is useful for virtual instrument plug-ins with multiple configurations, or for multi-user workflows on large systems.

You can set a custom plug-in map to be the default map for a plug-in, so that the same map is used for all default instances of that plug-in.
Plug-In Map Files
Plug-In maps can be exported (as .pim files) for use in other sessions and on other systems with a similar type of control surface (8-fader surface, 24-fader surface, or ICON surface).

Control Surface Mapping
When you create a custom plug-in map, its parameters are arranged in pages that correspond to the controls on the control surface. The size of a page depends on the type of control surface. Each custom plug-in map allows up to 200 pages of mapped parameters.

Plug-In mapping is stored according to the following types of control surfaces:
- 003
- C|24
- Command|8
- D-Control
- D-Command
- EUCON-compatible controllers
- M-Audio controllers

⚠️ If you import a plug-in map that was created on a different type of control surface, it will appear as an inactive choice in the Map Presets menu.

Plug-In Map Controls
When a supported control surface is declared in Pro Tools, Plug-In Map controls appear in the plug-in window.

Map Options Menu Lets you create, rename, save, delete, import, export, and set default plug-in maps.

Map Presets Menu Lets you choose from available custom Plug-In Maps for the plug-in.

Learn Button Puts the plug-in in Learn mode, where you can map plug-in parameters to a control surface.

Parameter Menu When in Learn mode, lets you select a parameter on the plug-in for mapping. If you click a parameter in the plug-in window while in Learn mode, this menu shows the name of the parameter.

Plug-In Map controls can be shown or hidden.

To show (or hide) Plug-In Map controls:
- Select (or deselect) View > Plug-In > Map Controls.
Creating Plug-In Maps

This topic covers creating plug-in maps on the following control surfaces:

- C|24
- 003
- Command|8

For details on plug-in mapping for D-Control and D-Command, see the D-Control Guide and D-Command Guide.

Putting a Plug-In into Learn Mode

When you first put a plug-in into Learn mode, a new plug-in map is created (with the default name “Custom Map”), and the plug-in is focused on the control surface, but with a blank page of controls, ready for mapping.

Only one plug-in can be in Learn mode at a time.

To put a plug-in into Learn mode, do one of the following:

- Click the Learn button in the plug-in window.
- From the Map Options pop-up menu, choose New Map.

To take a plug-in out of Learn mode, do one of the following:

- Click the active Learn button in the plug-in window.
- Close the plug-in window.
- Click the Learn button in a different plug-in window.

Plug-Ins are automatically taken out of Learn mode when moved to a different insert position, made inactive, or converted between DSP and Native formats.

Creating and Editing Plug-In Maps

To create a custom map of plug-in parameters:

1. Open the plug-in whose mapping you want to customize.
2. Put the plug-in into Learn mode. The plug-in is focused on the control surface, but with a blank page of controls, ready for mapping.
3. In the plug-in window, click the plug-in parameter you want to map. The parameter name appears in the Parameter menu.
4. On the control surface, do one of the following:
   - Turn the encoder or press the channel Select switch where you want to map the parameter.
   - If the control surface is in Flip mode, move the fader or press the channel Select switch where you want to map the parameter.
5. Repeat steps 3-4 for each parameter you want to map.
6. Take the plug-in out of Learn mode.

To change parameter mapping in a plug-in map:

1. Open the plug-in whose custom map you want to change.
2. Choose the map you want to change from the Map Preset pop-up menu.
3. Put the plug-in into Learn mode. The plug-in is focused on the control surface.
4. Do the following for each parameter mapping you want to change:
   - In the plug-in window, click the new plug-in parameter you want to map. The parameter name appears in the Parameter menu.
   - On the control surface, page to the encoder or switch where you want to change the mapping, and turn the encoder or press the switch.
5. Take the plug-in out of Learn mode.

To remove parameter mapping from a plug-in map:

1. Open the plug-in whose custom map you want to change.
2. Choose the map you want to change from the Map Preset pop-up menu.
3. Put the plug-in into Learn mode. The plug-in is focused on the control surface.
4. Do the following for each parameter mapping you want to remove:
   - Make sure the Parameter menu displays No Control.
   - On the control surface, page to the encoder or switch where you want to remove the mapping, and turn the encoder or press the switch.
5. Take the plug-in out of Learn mode.

Saving Plug-In Maps

You can save plug-in maps as presets for reuse on the same Pro Tools system.

Plug-In maps are saved as global preferences on a Pro Tools system, so they are available to all sessions created on the system.

When you create a map for a plug-in, that map becomes available to all other plug-ins of the same type and channel format.

💡 If you want to map the same plug-in in different channel formats (such as mono, stereo and 5.1 surround) you need to create a separate plug-in map for each format.

You can also export plug-in maps for use on other Pro Tools systems with a similar control surface (see “Exporting and Importing Plug-In Maps” on page 1119.

To save a copy of a custom plug-in map:

1. Open the plug-in whose map you want to copy.
2. Choose the map you want to copy from the Map Presets pop-up menu.
3. From the Map Options pop-up menu, choose Save Map As.
4. Enter a name for the plug-in map.
5. Click OK. The new copy becomes the active plug-in map.

To rename a custom plug-in map:

1. Open the plug-in whose map you want to rename.
2. Choose the map you want to rename from the Map Presets pop-up menu.
3. From the Map Options pop-up menu, choose Rename Map.
4. Enter a new name for the plug-in map.
5. Click OK.

Deleting Plug-In Maps

From the plug-in window, you can delete individual plug-in maps.

You can also delete all custom plug-in maps on the system, reverting all plug-ins to their Factory Default plug-in maps.

⚠️ On D-Control and D-Command systems, when you delete all plug-in maps, you are also deleting all Custom Fader Plug-In mappings.

To delete a custom plug-in map:

1. Open the plug-in whose map you want to delete.
2. Choose the map you want to delete from the Map Presets pop-up menu.
3 From the Map Options pop-up menu, choose Delete Current Map.

4 Click Delete.

To delete all plug-in maps from the system:
1 Open any plug-in in the session.
2 From the Map Options pop-up menu, choose Delete All Maps.
3 Click Delete.

Setting a Custom Plug-In Map as the Default Map
You can set a custom plug-in map as the default map for a plug-in, instead of the Factory Default map.

When you set a custom plug-in map as the default, it applies across the entire session. All instances of that plug-in that were set to the Factory Default map, or to another custom default map, change to the new default.

If you change parameter mapping in the custom plug-in map that has been set as the default, the changes will propagate to all instances of the plug-in using that default.

⚠️ When you export a plug-in map, the default map setting for that plug-in is also exported. When that map is imported, the default setting is also updated, and all instances of the plug-in change to the new default.

How Default Plug-In Map Settings are Stored
Default map settings are stored as global (system-wide) Pro Tools preferences, so they are applied to all sessions that you subsequently open or create on that system.

💡 If you plan to work with the same plug-in mapping on multiple sessions, back up your settings by exporting all plug-in maps on a regular basis and saving the .pim file with your sessions.

To set a custom plug-in map as the default plug-in map:
1 Open the plug-in whose default plug-in map you want to change.
2 Choose the map you want to use as the new default from the Map Presets pop-up menu.
3 From the Map Options pop-up menu, choose Set As Default.

Hiding Default Plug-In Map Pages
When you create a custom plug-in map, its parameters are arranged in pages that correspond to the groups of controls that appear on a control surface.

When you page through the controls for a plug-in on a control surface, the pages for custom plug-in maps appear first, and the pages for the Factory Default map appear after the custom pages.

You can hide the Factory Default pages of a plug-in, so that only the custom pages appear on the control surface. This applies to all instances of the plug-in.
To hide the Factory Default pages of a plug-in map:

1. Open the plug-in whose default plug-in map pages you want to hide.
2. From the Map Options pop-up menu, choose Hide Factory Default Pages.

Exporting and Importing Plug-In Maps

Plug-In maps can be exported as .pim files for use on other Pro Tools systems.

When exporting plug-in maps, you can choose to save individual map files for each plug-in, or a single map file containing all the plug-in maps for the system.

⚠️ On D-Control and D-Command systems, when you export all plug-in maps, you are also exporting Custom Fader Plug-In mapping to the same file. For more information, see the D-Control Guide or D-Command Guide.

To export an individual plug-in map:

1. Open the plug-in whose map you want to export.
2. Choose the map you want to export from the Map Presets pop-up menu.
3. From the Map Options pop-up menu, choose Export Current Plug-In Map.
4. Choose a location for the map file.
5. Click Save.

To export all plug-in maps in the system to a single map file:

1. Open any plug-in in the session.
2. From the Map Options pop-up menu, choose Export All Plug-In Maps.
3. Choose a location for the map file.

To import a map file:

1. Open the plug-in where you want to import a plug-in map.
2. From the Map Options pop-up menu, choose Import Plug-In Maps From File.
3. Locate the plug-in map (.pim) file you want to import.
4. Click Open.

Bypassing Plug-Ins

Plug-Ins can be bypassed from their Plug-In window, or from the Mix and Edit window Inserts View.

To bypass a plug-in, do one of the following:

- Click the Plug-In window’s Effect Bypass button.
- Command-click (Mac) or Control-click (Windows) the plug-in’s Insert button in the Mix or Edit window.

When a plug-in is bypassed, its Insert button turns blue. If only some of the channels of a multi-mono plug-in are bypassed, its Insert button turns purple.
To bypass (or pass) certain Inserts using the Track menu, choose:

1. Select the tracks on which you want to bypass inserts. Option-click (Mac) or Alt-click (Windows) to select all tracks shown in the session.

2. Choose Track > Bypass Insert.

3. Select (or deselect) one of the following:

   - **All** Bypasses all Inserts on all selected tracks in the session.
   - **Inserts A–E** Bypasses Inserts A–E on all selected tracks in the session.
   - **Inserts F–J** Bypasses Inserts A–E on all selected tracks in the session.
   - **EQ** Bypasses all EQ plug-ins on all selected tracks in the session. For those plug-ins that are available in multiple categories (such as Channel Strip), only the EQ portion of the plug-in is bypassed.
   - **Dynamics** Bypasses all Dynamics plug-ins on all selected tracks in the session. For those plug-ins that are available in multiple categories (such as Channel Strip), only the Dynamics portion of the plug-in is bypassed.
   - **Reverb** Bypasses all Reverb plug-ins on all selected tracks in the session.
   - **Delay** Bypasses all Delay plug-ins on all selected tracks in the session.
   - **Modulation** Bypasses all Modulation plug-ins on all selected tracks in the session.

### Key Commands for Bypassing Inserts

Pro Tools provides key-click commands for bypassing inserts on selected tracks in the Mix window:

- Control-click (Mac) or Start-click (Windows) an Insert Assignment button in the Mix or Edit window to bypass it and all inserts below it on a track.
- Control-Option-click (Mac) or Start+Alt-click (Windows) an Insert Assignment button in the Mix or Edit window to bypass it and all inserts below it on all tracks. This lets you bypass all plug-ins in your session with a single click.
- Press Shift+A to bypass (or un-bypass) all inserts on selected tracks.
- Press Shift+2 to bypass (or un-bypass) inserts A–E on selected tracks.
- Press Shift+3 to bypass (or un-bypass) inserts F–J on selected tracks.
- Press Shift+E to bypass (or un-bypass) all EQ plug-ins on selected tracks.
- Press Shift+C to bypass (or un-bypass) all Dynamics plug-ins on selected tracks.
- Press Shift+V to bypass (or un-bypass) all Reverb plug-ins on selected tracks.
- Press Shift+D to bypass (or un-bypass) all Delay plug-ins on selected tracks.
- Press Shift+W to bypass (or un-bypass) all Modulation plug-ins on selected tracks.
Linking and Unlinking Controls on Multi-Mono Plug-Ins

When a multi-mono plug-in is used on a stereo track or greater-than-stereo multichannel track (Pro Tools Ultimate only), the controls are linked by default. Adjusting the Gain control on one channel, for example, will adjust it for all channels.

You can unlink multi-mono plug-in controls on specific channels of a track and edit them independently. You can also selectively link the controls of specific channels.

To unlink controls on a multi-mono plug-in:
- Deselect the Master Link button.

To access controls for a specific channel:
- Select the channel from the Channel selector.

To link the controls of specific channels:
1. Deselect the Master Link button if it is not already deselected.
2. Click the Link Enable buttons for the channels whose controls you want to link.

Using Hardware Inserts

You can connect external devices, such as reverb or effects processors, to your Pro Tools system and use them as hardware inserts on individual tracks or on submixes.

Pro Tools inserts utilize corresponding hardware input and output channels to send and return the audio. Inserts can be defined, and their channels mapped to audio interface channels on the Insert page in the I/O Setup dialog.

If you plan to use a device as an insert, be sure to connect the device to matching inputs and outputs on your system. For example, a hardware insert being supplied by outputs 7–8 needs to be returned to hardware inputs 7–8.

Delay Compensation can be applied to Hardware Inserts. See “H/W Insert Delay (Compensation) Page” on page 55.

To define a hardware insert:
1. Choose Setup > I/O, then click the Insert tab.
2. Select an insert path, or click New Path to create a new Insert path.
3. Double-click the Path Name to enter a custom path name for the insert.
4. Make sure the insert path is set to the correct format (mono, stereo, or other).
5. Map inserts in the Channel Grid as needed. Insert and Output paths have special rules regarding channel mapping (see “Valid Paths and Requirements” on page 75).
Assigning Hardware Inserts

To assign an external hardware insert to a track:

- Select an insert from the track Insert selector.

Connecting and Integrating External Devices

Pro Tools can create dedicated connections to external analog or digital devices. The number and type of connections depends on what kind of system you have.

To connect an external device to a Pro Tools system:

1. Connect an unused output (or pair of outputs for a stereo device) of your Pro Tools system to an input of the external signal processor.
2. Connect the output of the external signal processor to an unused input (or pair of inputs for a stereo device) of your Pro Tools system.
3. Define what physical ports are routed to Pro Tools input and output ports, as appropriate, in either the Hardware Setup dialog or I/O Setup dialog.
4. Define output, input, or insert paths as appropriate in the I/O Setup dialog.

If you plan to use a device as an insert, be sure to connect the device to matching inputs and outputs on your system. For example, to use outputs 7–8, the insert has to use inputs 7–8 also.

Bypassing Hardware Inserts

Hardware inserts do not provide a bypass control. To monitor playback without a hardware insert, either set it to Inactive, remove it by reassigning it to No Insert, or use a bypass switch on the hardware device itself. (See “Making Inserts Inactive” on page 1096 for more information.)
Connecting Effects Units Digitally

If you want to use the digital inputs and outputs on your Pro Tools system as effects sends and returns to a digital effects device, Pro Tools should be the clock master in most cases. Set your digital effects device to accept an external digital clock so that it synchronizes to Pro Tools.

To set up a digital send to an external device for HDX and HD Native systems:
1. Choose Setup > Hardware
2. Select the audio interface from the Peripherals list (HD I/O, HD MADI, or HD OMNI).
3. Select an audio format and clock format, and set the appropriate channel pair to Digital.
4. Select Internal from the Clock Source pop-up menu.
5. Click OK.

To set up a digital send to an external device from a Pro Tools system with 003, 003 Rack+, or 003 Rack:
1. Choose Setup > Playback Engine and choose the peripheral.
2. Do one of the following:
   - If the external device is connected to the S/PDIF RCA jacks, deselect S/PDIF Mirroring. (When S/PDIF Mirroring is on, digital output at the S/PDIF RCA jacks exactly mirrors the output of analog Channels 1–2.)
   - If the external device is connected to the Optical ports, choose a format (most likely S/PDIF for an effects device) from the Optical Format pop-up menu.
3. Choose Internal from the Clock Source pop-up menu.
4. Click OK.

5. Optionally, configure the I/O Setup dialog with new path names for effects routing.

If you set the Optical Format to S/PDIF, Pro Tools will watch the Optical port for any audio input, and ignore any audio input on the S/PDIF RCA jacks.

Using External Clock Sources (for Recording and Monitoring)

When recording or monitoring, Pro Tools can synchronize to an external clock source. Options for external clock vary according to the type of Pro Tools system you are using.

HDX and HD Native Systems

HDX and HD Native systems can receive external clock through any of the digital inputs on any Avid HD audio interface (including AES/EBU, S/PDIF, and Optical).

For details on audio interface connections, see the guide for your audio interface.

To select an external clock source for HDX or HD Native systems:
1. Choose Setup > Hardware.
2. Select the appropriate audio interface in order to display its settings in the Main page.
3. If necessary, enable the appropriate Digital Format (if you have not already done so, according to the instructions in your User Guide or I/O Guide).
4. Set the Clock Source to match the type of input.
5. Configure input routing of the digital source, using the Input and Output pop-up menus, if necessary.
6. Click OK to close the Hardware Setup dialog.
Pro Tools Systems with 003, 003 Rack+, or 003 Rack

Pro Tools can receive external clock from the Optical input or S/PDIF input.

To select an external clock source for a Pro Tools system with 003, 003 Rack+, or 003 Rack:
1. Choose Setup > Hardware.
2. Set the Clock Source to match the type of input.
3. If you select Optical, make sure the Optical Format matches the type of optical input you are sending to your Pro Tools system.

⚠️ If you set the Optical Format to S/PDIF, Pro Tools will watch the Optical port for external clock, and ignore any clock input on the S/PDIF RCA jacks.

Pro Tools Systems with Eleven Rack

Pro Tools can receive external clock from the AES/EBU input or S/PDIF input.

To select an external clock source for Eleven Rack:
1. Choose Setup > Hardware.
2. Set the Clock Source to match the type of input.

Pro Tools Systems with Mbox Pro or Mbox (3rd generation)

Pro Tools can receive external clock from the S/PDIF input on these interfaces.

To select an external clock source from Pro Tools with an Mbox Pro or Mbox (3rd generation):
1. Choose Setup > Hardware.
2. Select SPDIF/RCA (Mac) or SPDIF (Windows) from the Clock Source pop-up menu.
3. Click OK.

⚠️ Your digital input device must be connected and powered on for Pro Tools to synchronize to it. If your input device is not powered on, leave the Clock Source set to Internal.
Chapter 50: Automation

Pro Tools features dynamic automation of mixing controls on each of the track types. You can write automation moves and view them in real time during playback and recording in your session. You can also edit automation data with the same techniques you use to edit audio and MIDI data.

Automation Accuracy with Control Surfaces

Control Surfaces D-Control, D-Command, C|24, and Command|8 control surfaces (as well as the 003) support the automation features in Pro Tools. Pro Tools control surfaces provide 10-bit resolution, or 1,024 steps of fader resolution. Pro Tools interpolates this input to 24-bit resolution on playback, resulting in extremely accurate and smooth fader automation.

For details on using control surfaces to create mix automation, see your control surface guide.

EUCON Avid control surfaces using EUCON, such as Pro Tools | S6 or Artist Series controllers, provide 12-bit resolution fader and knob control.

MIDI Control Surfaces Most MIDI control surfaces have 7-bit resolution, or 128 steps. Pro Tools interpolates this input to 24-bit resolution on playback, resulting in accurate and smooth fader automation.

Automation Overview

Pro Tools provides many options for recording, replacing, and editing automation data.

The basic steps for automation recording are:

- Enable the automation type that you want to record (volume, pan, mute, send level, send pan, send mute, or plug-in automation).
- Put the appropriate tracks in an automation writing mode (Write, Touch, or Latch, or a Trim mode).
- If you are automating a plug-in, enable the individual plug-in controls to be automated.
- Automation Safe any plug-ins, outputs, or sends that have existing automation data that you want to protect from being overwritten.
- Begin playback to begin automation recording, and adjust controls as needed. Pro Tools remembers all moves performed on enabled controls.

To edit automation once it has been recorded, you can:

- Repeat the above steps to write new automation over the previous data.
- Graphically edit the automation data in the Edit window.
- Cut, copy, paste, or delete automation data (certain restrictions apply).
Automation Playlists

Each Pro Tools track contains a single automation playlist for each automatable parameter. The available options vary depending on track type, track channel width, and track output path channel width.

On audio tracks, these parameters include:

- Volume
- Volume Trim (Pro Tools Ultimate only)
- LFE (.1 surround outputs only, Pro Tools Ultimate only)
- Mute
- Object Toggle (Object tracks only, Pro Tools Ultimate only)
- Pan
- Send Level
- Send Level Trim (Pro Tools Ultimate only)
- Send Pan
- Send Mute
- Plug-In controls

On Auxiliary Input tracks, these parameters include:

- Volume
- Volume Trim (Pro Tools Ultimate only)
- LFE (.1 surround outputs only, Pro Tools Ultimate only)
- Mute
- Object Toggle (Object tracks only, Pro Tools Ultimate only)
- Pan
- Send Level
- Send Level Trim (Pro Tools Ultimate only)
- Send Pan
- Send Mute
- Plug-In controls

On Master Faders, these parameters include:

- Volume
- Volume Trim (Pro Tools Ultimate only)
- Plug-In controls

On MIDI tracks, these parameters include:

- MIDI Volume
- MIDI Pan
- MIDI Mute
- pitch bend
- mono aftertouch
- program change
- sysex
- controllers
On Instrument tracks, these parameters include:

- MIDI Volume
- MIDI Pan
- MIDI Mute
- pitch bend
- mono aftertouch
- program change
- sysex
- controllers
- Audio Volume
- Volume Trim (Pro Tools Ultimate only)
- LFE (.1 surround outputs only, Pro Tools Ultimate only)
- Mute
- Object Toggle (Object tracks only, Pro Tools Ultimate only)
- Pan
- Send Level
- Send Level Trim (Pro Tools Ultimate only)
- Send Pan
- Send Mute
- Plug-In controls

On VCA Master tracks, these parameters include:

- Volume
- Volume Trim
- Mute

You can display and edit each of these automatable playlists individually from Pro Tools, even during playback.

In addition, on MIDI and Instrument tracks you can display and edit other continuous MIDI controller data (such as mod wheel, breath controller, foot controller, or sustain) in a similar manner. For more information on editing MIDI data, see “Continuous Controller Events” on page 764.

Automation Playlists with Audio and MIDI Clips

Pro Tools handles audio clips and their automation playlists differently from MIDI clips and their automation playlists.

Audio Tracks

On audio tracks, automation data resides on a separate playlist from audio data and clips. Each edit playlist on an audio track shares the same automation data.

MIDI and Instrument Tracks

On MIDI tracks and Instrument tracks, all controller automation data except for MIDI Mute data, or audio mute (Instrument tracks only), is stored in the MIDI clip that contains it. Each edit playlist on the track is separate, and represents a distinct performance, complete with controller automation.

⚠️ MIDI Mute data is independent of the MIDI data in a MIDI clip. This lets you mute playback of individual MIDI or Instrument tracks in Pro Tools without altering the controller data.

Trim Automation Playlists

(Pro Tools | Ultimate Software Only)

Separate Trim automation playlists are available for Volume trim and Send Level trim. Volume trim is available on all track types except MIDI tracks. Send Level trim is available on audio tracks only.
Each Trim automation playlist shows the position of the Trim fader with yellow breakpoint automation that can be edited. For more information on Trim playlists, see “Trim Mode” on page 1131 and “Viewing Automation” on page 1135.

Multiple Edit Playlists and Audio Track Automation

All edit playlists on a single audio track share the same automation data. When you record or edit automation data in an audio track, the automation data is stored in the track’s corresponding automation playlist so it can be edited with, or independently from, its associated audio clips.

- When you copy or cut audio data from a track while it is in Waveform view, the underlying automation data is cut or copied with it.
- If you paste audio data from other locations or tracks into an edit playlist, you may change the underlying automation data on the track.
- When you trim clips using Edit > Trim, the underlying automation data remains unchanged.

MIDI continuous controller data always follows clip editing, with the exception of mute. See “MIDI and Instrument Tracks” on page 1127 for more information.

Duplicating Tracks for Playlist Editing

The Duplicate Track command provides a convenient way to make a working copy of a track to experiment with routing, plug-ins, and automation. This protects the original track and its automation data from being edited or overwritten.

Automation Modes

Automation modes control how a track’s automation data is written and played back. Each track provides an Automation Mode selector for selecting the track’s Automation mode.

Off Mode

Off mode turns off automation for all automatable parameters:

- Volume
- Pan
- Mute
- Send volume, pan, and mute
- Plug-In controls
- MIDI volume, pan, and mute

In Off mode, automation data for these parameters is ignored during playback. All other MIDI controller data is sent.

Automation can be switched from Off to another Automation mode during playback or record.

Read Mode

Read mode plays any automation that was previously written for a track.

Write Mode

Write mode writes automation from the time playback starts to the time it stops, erasing any previously written automation for the duration of the automation pass.

AutoMatch can be applied to a Write automation pass. See “AutoMatch Time” on page 1134.
“After Write Pass, Switch To” Option

You can set Pro Tools to automatically change to Touch mode or Latch mode, or remain in Write mode after the completion of an automation pass in Write mode.

To set the Automation mode after a Write pass:

1. Choose Setup > Preferences and click Mixing.
2. Under Automation, select an After Write Pass, Switch To option (Touch, Latch, or No Change).
3. Click OK to close the Preferences window.

Touch Mode

Touch mode writes automation only while a fader or switch is touched or clicked with the mouse. When the fader is released, the writing of automation stops and the fader returns to any previously automated position, at a rate determined by the AutoMatch and Touch Timeout settings. See “Automation Preferences” on page 1133.

In Touch mode, certain control surfaces start writing automation as soon as you touch them. These include touch-sensitive fader controllers, such as D-Control, D-Command, C|24, 003, or Command|8.

With other control surfaces in Touch mode, writing of automation does not begin until the fader hits the pass-through point, or the previously automated position. Once you reach the pass-through point with the fader, or a non-touch sensitive rotary control, writing of automation begins and continues until you stop moving the fader.

Latch Mode

Latch mode works in the same way as Touch mode, writing automation only if you touch or move a control. However, unlike Touch, writing of automation continues until you stop playback or “punch out” of the automation pass by changing the Automation mode to Read or Touch.

AutoMatch can be applied to a Latch automation pass. See “AutoMatch Time” on page 1134.

Latch mode is particularly useful for automating Pan controls and plug-ins on non-touch sensitive rotary controls, since it does not time out and revert to its previous position when you release a control.

See also “Writing Automation to the Start, End, or All of a Track or Selection” on page 1164.

AutoJoin with Latch Mode
(Pro Tools | Ultimate Software Only)

Pro Tools provides two different methods to resume writing automation on controls that were active at the point where the transport stopped:

AutoJoin Lets you automatically resume writing automation in Latch mode.

Join Lets you manually resume writing automation in Latch mode. To Join, Command-click (Mac) or Control-click (Windows) the Auto Join button in the Automation window (Window > Automation). Join is also available with supported control surfaces.
To enable AutoJoin from Pro Tools:
1. Choose Window > Automation.
2. Click the AutoJoin button.

AutoJoin Indicator

After a Latch automation pass with AutoJoin enabled, the AutoJoin indicator appears in the Pro Tools Edit window.

The AutoJoin indicator is a vertical line that signifies the point where the last automation pass was stopped, and the point where the “join” will automatically occur on all tracks that were writing during that previous pass. When automation writing is resumed from this point, the line disappears.

⚠️ To use Join or AutoJoin to resume writing on controls that were writing when the transport stopped, restart the transport before the AutoJoin indicator.
**Touch/Latch Mode**  
*(Pro Tools | Ultimate Software Only)*

Touch/Latch Automation mode places a track’s Volume control in Touch mode and all other automatable controls in Latch mode.

In Touch/Latch mode, the Volume control follows Touch behavior, writing automation when touched and returning to previously written levels when released.

All other controls follow Latch behavior, writing automation when touched and continuing until playback stops, or until you punch out of writing automation.

When writing automation in Trim mode, fader moves write relative rather than absolute values. The existing automation data is changed by the amount of increase or decrease (or the delta value) indicated by the faders.

When Trim mode is enabled, non-trimmable controls behave in the same manner as in the standard Automation modes, with the exception of Write/Trim mode, where non-trimmable controls operate as in Touch mode.

**Trim Automation Modes**

When a track is in a Trim automation mode (except for Trim Off) its main Volume faders and all Send level faders are displayed in yellow. When trimming, a track’s Volume indicator or Send Level indicator shows the delta value being written rather than the absolute value.

Behavior of the Trim Automation modes also depends on the Coalesce Trim Automation preference setting. See “Coalescing Trim Automation” on page 1163.

**Trim Off**

Trim Off turns off reading and writing of all automation (main and trim) for a track. All automation moves are ignored during playback. Trim faders are temporarily set to zero when a track is set to Trim Off mode.

Depending on the Coalesce Trim Automation preference setting, changing a track to Trim Off can coalesce Trim automation on that track. See “Coalescing Trim Automation” on page 1163.

Automation can be switched from Trim Off to another Automation mode during playback or record.
**Read Trim**

In Read Trim mode, Volume and Send level Trim faders are disengaged from the main automation playlist and follow any existing Trim automation. You can move a Trim fader during playback to audition new trim values, but no automation is written. When the Trim fader is released, it returns to any previously written Trim automation values.

If a track does not contain Trim automation, you can move a Trim fader during playback to audition new trim values, but no automation is written. The Trim fader retains its position until the track is removed from Trim mode, or if you manually coalesce the Trim level.

When this mode is enabled, non-trimmable controls (all controls other than track volume and send level) behave as if they are in regular Read mode—no automation data is written.

**Touch Trim**

In Touch Trim mode, Volume and Send level Trim faders are disengaged from the main automation playlist and follow any existing Trim automation. When a Trim fader is touched, writing of Trim automation begins. When the fader is released, writing stops and the fader returns to any previously written Trim automation values.

The rate of the fader’s return to previous trim values is determined by the AutoMatch Time specified in the Automation Preferences page. See “AutoMatch Time” on page 1134 for more information.

When this mode is enabled, non-trimmable controls (all controls other than track volume and send level) behave as if they are in regular Touch mode—they follow the previously written automation until touched. When they are touched, their absolute positions are written until playback is stopped.

**Latch Trim**

In Latch Trim mode, Volume and Send level Trim faders are disengaged from the main automation playlist and follow any existing Trim automation. When a Trim fader is touched, writing of Trim automation begins. Writing of Trim automation continues until playback stops, or until you punch out of writing automation.

When this mode is enabled, non-trimmable controls (all controls other than track volume and send level) behave as if they are in regular Latch mode—they follow the previously written automation until touched. When they are touched, their absolute positions are written until playback is stopped.

**Touch/Latch Trim**

In Touch/Latch Trim mode, Volume and Send level faders are disengaged from the main automation playlist and follow any existing Trim automation. The main Volume Trim fader follows Touch Trim behavior, and Send level Trim faders follow Latch Trim behavior.

**Write Trim**

In Write Trim mode, as soon as playback begins, writing of Trim automation begins for Volume and Send levels, and continues until playback stops, or until you punch out of writing automation.
When Write Trim mode is enabled, non-trimmable controls (all controls other than track volume and send level) are not in Write mode, but behave as if they are in regular Touch mode (no automation is written unless a control is touched). This is to prevent the controls from overwriting all of their automation data on every pass in Write Trim mode.

⚠️ The “After Write Pass, Switch To” preference affects Write Trim mode. After an automation pass in Write/Trim mode, tracks automatically switch to the Trim mode version of the setting specified by this preference.

## Automation Preferences

Pro Tools gives you several options for controlling the writing and playback of automation data.

**To display Automation preferences:**
- Choose Setup > Preferences and click Mixing.

### Send Levels and Trim Mode (Pro Tools | Ultimate Software Only)

You can set Pro Tools to exclude Send levels from Trim mode, so that only the Main Volume goes into Trim when a track is put into Trim mode. This gives you more flexibility in setting Send levels while in Trim mode.

**To exclude Send levels from Trim mode:**

1. Choose Setup > Preferences and click Mixing.
3. Click OK.

### Smoothing

When you perform automation moves (including Trim moves) with a continuous control, Pro Tools records the move as a series of very small steps, resulting in a staircase pattern with many breakpoints. Smoothing intelligently resolves this staircase pattern into a single, smooth ramp from one breakpoint to the next. (Smoothing does not apply to switched controls such as mutes or plug-in bypasses.) With smoothing enabled, the resulting automation data is often a more accurate representation of actual automation moves.
Thinning

Thinning automatically reduces the overall number of breakpoints in an automation playlist (including Trim playlists) in order to improve system performance. The amount of thinning applied is determined by the Degree of Thinning setting in the Automation Preferences page. When using high amounts of thinning, the resulting automation may differ noticeably from the original automation moves. Thinning only applies to audio tracks, and does not affect MIDI tracks. For instructions, see “Thinning Automation” on page 1150.

AutoMatch Time

AutoMatch Time is the amount of time it takes for a fader to return (by ramping up or down) to the level of automation still on the track as the automation pass ends. This time value is set in the Automation Preferences page (see “Automation Preferences” on page 1133).

AutoMatch is automatically applied to all Touch mode passes, and can be applied to Latch or Write passes.

The AutoMatch Time also determines the rate at which delta values written with the Trim will return to 0 dB (delta value of zero).

The AutoMatch feature works with continuous controls (such as Volume or Pan) by ramping their values back to previously automated levels. There are some stepped controls (for example, the EQ type in the 1-band EQ plug-in) that provide more than two discrete steps over their operational range. AutoMatch has no effect on these controls.

Automation Follows Edit Option

When disabled, automation events are not affected by edits to audio or MIDI notes. When enabled, automation events are affected by edits to audio or MIDI notes.

To enable or disable Automation Follows Edit, do one of the following:

- Select or deselect Options > Automation Follows Edit.
- Click the Automation Follows Edit indicator in the Edit window toolbar. The indicator is highlighted blue when enabled. When disabled, the indicator is highlighted orange.

Automation Safe

Outputs, sends, and plug-ins can be placed in Automation Safe mode. In Automation Safe mode, any automation associated with an Output window (such as track or send level, panning, or mute), or plug-in on that track, is protected from being overwritten while automating other items on that track.

Automation Safe mode suspends automation recording for the selected track output, send, or plug-in that is enabled. You can also suspend automation recording and playback session-wide from the Automation window. See “Enabling and Suspending Automation” on page 1147.
Viewing Automation

Pro Tools creates a separate playlist in the Edit window for each type of automation in a track, including a playlist for each type of Trim automation. This data can be viewed and edited in the same way as audio and MIDI data. You can either change Track Views to show the automation you want, or you can reveal an Automation lane under the track regardless of its Track View.

💡 You can easily toggle between different Track Views. See “Changing Track Views” on page 239.

Track Views

You can view automation data by type by selecting the corresponding Track View.

To display an automation playlist in the Track View:

- Click the Track View selector and select from the automation type you want to view.

Automation and Controller Lanes

In the Edit window, you can view automation and controller data under a track (regardless of the selected Track View). Each track provides Automation and Controller lanes that let you edit track automation and controller data without changing the Track View. You can edit automation and controller data in lanes exactly the same way that you do in different automation and controller Track Views.
Automation and Controller lanes can be shown or hidden. You can also add and remove lanes. These lanes always remain under the track, but you can resize and reorder lanes independently of one another.

To show or hide Automation lanes under the main track view:

- Click the Show/Hide Lanes button.

To add a lane:

- Click the Add Lane button.

To remove lanes:

- Click the Remove Lane button.

To change the Automation or Controller type for a lane:

- Click the Automation/Controller Type selector and select the Automation or Controller type you want.

To replace all Automation and Controller lanes under the track with a single lane of the specified automation or controller type:

1. Right-click the Show/Hide Lanes button.
2. Select the Automation or Controller type you want.

To resize the height of all Automation and Controller lanes for a track, do one of the following:

- Right-click on the vertical zoom scale just to the right of the track controls and select the height from the pop-up menu.
- Drag the bottom line of any given Lane Controls column up or down. The cursor changes to indicate that you can resize the lane.

Press Control+Up/Down Arrow key (Mac) or Start+Up/Down Arrow key (Windows) to increase or decrease height of any lane that contains the Edit cursor or an Edit selection.

To resize the height of a single Automation or Controller lane for a track:

- Press Control (Mac) or Start (Windows) while selecting the Lane Height setting.

To reorder lanes:

- To reorder lanes on-screen, drag the lane control section to new positions in the Edit window.
Displaying Trim Automation Along with the Main Playlist
(Pro Tools | Ultimate Software Only)

The appearance of Trim automation depends on how it is set to be coalesced. See “Coalescing Trim Automation” on page 1163.

If automation is not set to coalesce after every automation pass, you can display Trim automation data along with the main Volume or Send level automation data in the same automation view. This Trim automation display cannot be directly edited.

To display the Trim automation playlist along with main automation playlist on tracks:
- Select View > Automation > Trim Playlist.

Display of Trim automation in a main Volume playlist

Displaying the Composite Automation Playlist
(Pro Tools | Ultimate Software Only)

If automation is not set to coalesce after every automation pass, you can display a composite automation playlist that shows the contribution of the Trim automation to the main Volume or Send Level automation data. This composite playlist display cannot be directly edited.

The composite playlist is shown in both the main automation playlist and the Trim automation playlist.

AutoMatch Indicators

There are triangular AutoMatch indicators at the bottom left of each channel strip in the Mix window. When lit, these indicate the direction the fader will automatically move when Auto-Matching.
Indication of Automation in Track View and Automation Lane Selectors

Automation Track view and Automation lane selectors display orange to indicate which automation playlists currently contain automation.

```
Writing Automation
```

You can write automation for all automatable controls by moving those controls during playback or recording.

Select the Enable Automation in Record option in the Operation Preferences to write automation while recording.

To write automation on tracks:

1. Choose Window > Automation.
2. Make sure the automation type is write-enabled.

```
Automation window
```

“volume” in Track View selector displays orange to indicate the presence of automation

“volume” in Automation Lane selector displays orange to indicate the presence of automation
3 In the Mix or Edit window, click the Automation Mode selector on each of the tracks you want to automate, and set the Automation mode. For the initial automation pass, select Write.

4 Start playback to begin writing automation.

5 Move the controls you want to automate (such as a track volume fader).

6 When you have finished, stop playback.

After the first automation pass, you can write additional automation to the track without completely erasing the previous pass by choosing Touch mode or Latch mode. These modes add new automation only when you actually move a control. (See “Automation Modes” on page 1128.)

To write additional automation to a previous pass:

1 Enable Options > Link Timeline and Edit Selection.

2 In the Edit window, make a selection or place the cursor in the location where you want to start writing automation.

3 In the Mix or Edit window, click the Automation Mode selector on each of the tracks you want to automate, and set the Automation mode to Touch or Latch mode.

4 If you write automation in Touch mode with Loop Playback enabled, writing of automation will automatically stop at the end of the looped selection. At the beginning of each successive loop, you can then touch or move the control again to write new data.

**Storing an Initial Control Position**

When you create a new audio, Auxiliary Input, VCA Master, MIDI, or Instrument track, it is automatically placed in Read mode. Even though the track is in Read mode, you can set the initial position of any automatable control, and it is saved with your session.

In this initial state, only a single automation breakpoint appears at the beginning of each automation playlist. If you move the control without writing automation, this breakpoint will move to the new value.

You can permanently store the initial position of an automatable control by doing any of the following:

- Place the track in Write mode and press Play to write a few seconds of automation data to the track
- Manually place a breakpoint on the automation playlist somewhere after the initial breakpoint. (See “Graphical Editing of Automation Data” on page 1153 for more information.)
Automating Switched Controls

When automating switched controls (such as mutes, plug-in bypasses, or switched controls on plug-ins) Pro Tools treats them as touch sensitive controls. Automation data is written for as long as the switch or button for that control is pressed or touched.

For example, if you have just written a series of mute on/off states on a track in quick succession, the manual method for clearing this automation data would require you to move to the Edit window, choose automation playlist for Mute, select the mute automation data, and delete it. In Pro Tools, this can be done automatically.

To automate a switched control (such as the Mute button):

1. Perform another automation pass on the track.
2. When you reach the location of the mute state you want to remove, hold the switched control (such as the Mute button).
3. As long as the button is held, Pro Tools overwrites the underlying data on the track with the current state of the switch (on or off) until playback is stopped.

Automating Switched Controls in Touch Mode

When automating switched controls (including mute, plug-in bypass, and any switched control on a plug-in) in Touch mode, these controls will latch in their current state after they are touched. However, to preserve any automation for that switched control later in the Timeline, this latched behavior ends if either of the following occurs:

- If an existing automation breakpoint is encountered, Pro Tools stops writing automation at that point.
- If you stop playback or punch out of writing automation before reaching an existing automation breakpoint, Pro Tools AutoMatches to the underlying automation state.

Setting Switched Controls for Momentary Behavior

In some cases, such as when overwriting or extending Mute automation, you may want to momentarily write automation for a control by holding it down, and not have the control latch.

To set switched controls for momentary behavior:

1. Choose Options > Preferences and click Mixing.
2. Deselect Latching Behavior for Switch Controls in “Touch.”
3. Click OK to close the Preferences window.

Automating Sends

Pro Tools provides automation of send level, send mute, and send pan (for stereo and multichannel sends only). This makes it easy to control effect levels and placement during mixdown with great precision.

Send level and mute can also be configured to follow groups.
To automate a send level, mute or pan:

1. In the Automation window, make sure the automation type is write-enabled (send level, send mute, send pan).

2. In the Mix or Edit window, set the Automation mode for each track containing sends you want to automate. For each track, click the Automation Mode selector and set the Automation mode. For the initial automation pass, choose Write mode.

3. If sends are not currently visible on your tracks, select View > Mix Window (or Edit Window) > Sends A–E (or Sends F–J).

4. To display send controls, do one of the following:
   - Click the send to open the Output window for the send that you want to automate.
   - Select View > Sends A–E (or Sends F–J) and select one of the individual views (such as Send A).

5. Start playback to begin writing automation.

6. Move the controls you want to automate.

7. When you have finished, stop playback.

Send level, mute, and pan can also be configured to follow Mix Groups (see “Automation Preferences” on page 1133).

Copying Track Automation to Sends

There may be times where you want a track’s send settings or automation to mirror the settings or automation in the track itself, for example, when creating a headphone mix based on the main mix, or when an effect level needs to follow the levels in a main mix. You can copy the current settings or the entire automation playlist for the selected controls to the corresponding playlist for the send.

To copy a track’s settings or automation to one of its sends:

1. Select the tracks you want to edit by clicking on the track names to highlight them.

2. Choose Edit > Automation > Copy to Send.

   Copy To Send dialog

3. In the Copy to Send dialog, do any of the following:
   - Select Current Value to copy the current settings of the corresponding controls.
   - Select Automation to copy the entire automation playlist for the corresponding controls.

4. Select the controls you want to copy.

5. Select the sends to which to copy the automation, and click OK.

You can undo the results of the Copy to Send command.

Automating Plug-Ins

You can automate changes to virtually all plug-in controls. Automating a plug-in is slightly different from other automation procedures, because you must enable individual plug-in controls for automation.
To enable plug-in controls for automation:
1. Open the Plug-In window for the plug-in you want to automate.
2. Do one of the following:
   • Click the Automation Enable button in the Plug-In window.
   • Command-Option-Control-click (Mac) or Control-Alt-Start-click (Windows) the Track View selector in the Edit window.
3. In the plug-in automation dialog, choose the controls to automate and click Add. If there are multiple plug-ins on the same track, you can select from among them by clicking their buttons in the Inserts section of this dialog.
4. Click OK to close the Plug-In Automation dialog.

To automate a plug-in:
1. In the Plug-In Automation Enable window, make sure plug-in automation is enabled for the controls you want to automate.
2. In the Mix or Edit window, for each track containing plug-ins you want to automate, click the Automation Mode selector and set the Automation mode. For the initial automation pass, select Write.
3. Start playback to begin writing automation, and move the controls you want to automate.
4. When you have finished, stop playback.

Enabling Automation for Individual Plug-In Parameters

You can enable individual plug-in controls directly from the Plug-In window.

To enable a plug-in parameter from the plug-in window:
1. Make sure the plug-in window is open for the plug-in you want to automate.
2. Command-Option-Control-click (Mac) or Control-Alt-Start-click (Windows) the control for the parameter.
Enabling Automation for All Plug-In Parameters

To enable all plug-in parameters:

1. Make sure the plug-in window is open for the plug-in you want to automate.
2. Command+Option+Control-click (Mac) or Control+Alt+Start-click (Windows) on the Auto button at the top of the plug-in window.

Automatically Enabling Plug-Ins for Automation

You can set Pro Tools to automatically enable all controls of a plug-in for automation when you first add the plug-in to your session.

To automatically enable all plug-in controls for automation:

1. Choose Setup > Preferences and click Mixing.
2. Select Plug-In Controls Default to Auto-Enabled.
3. Click OK to close the Preferences window.

Color Indication of Automation Mode for Plug-In Parameters

In the Plug-In window, the controls for plug-in parameters highlight in different colors to indicate whether or not a control is automated in what automation mode. The color also is different depending on whether or not a parameter is being controlled by a control surface (such as D-Command or Command|8).

The following table shows the color coding for automated plug-in parameters, with and without a control surface.

<table>
<thead>
<tr>
<th>Automation Mode:</th>
<th>Off</th>
<th>Read</th>
<th>Touch, Latch, Write</th>
</tr>
</thead>
<tbody>
<tr>
<td>No Control Surface</td>
<td>none</td>
<td>Green</td>
<td>Red</td>
</tr>
<tr>
<td>Control Surface</td>
<td>none</td>
<td>Blue</td>
<td>Yellow</td>
</tr>
</tbody>
</table>

Record Safing Plug-In Automation

You can protect plug-in automation from being overwritten by using Automation Safe mode.

To enable plug-in safe mode:

1. Open a plug-in.
2. Click the Safe button so that it is highlighted.
AutoMatching Controls
(Pro Tools | Ultimate Software Only)

Use the AutoMatch button in the Automation window to automatically change automation controls to their existing automation levels.

AutoMatching All Controls
You can AutoMatch all currently writing controls to their existing automation levels.

To AutoMatch all currently writing controls:
1. Choose Window > Automation.
2. Make sure the automation types you want to AutoMatch are write-enabled.
3. Start playback.
4. When you reach a point in the track where you want to return control to their previously written values, click the AutoMatch button in the Automation window.

All currently writing controls stop writing automation and return to any previously written values according to the AutoMatch Time setting in the Mixing preferences.

AutoMatching Individual Tracks
You can invoke AutoMatch on individual tracks. All controls currently writing automation on the track stop writing and return to existing automation levels.

To AutoMatch all controls on a track:
- Command-click (Mac) or Control-click (Windows) the Automation Mode selector on the track.

AutoMatching Individual Automation Types
You can invoke AutoMatch on individual automation types across a session.

To AutoMatch all controls of one automation type:
- In the Automation window, Command-click (Mac) or Control-click (Windows) the button for the automation type (Volume, Pan, Mute, Plug-In, Send level, Send pan, or Send mute).

AutoMatching Individual Controls
(D-Control and D-Command Only)

On ICON worksurfaces, you can invoke AutoMatch on individual controls or control types on single channels.

To AutoMatch all controls of a type on a channel:
- Hold Command (Mac) or Control (Windows) and press any of the following in the Channel Strip Mode controls for the track whose controls you want to AutoMatch:
  - Inserts
  - Sends
  - Pan
  - Dyn (D-Control only)
  - EQ (D-Control only)
To AutoMatch a pan control or the controls for an individual insert or send:

1. Press the switch in the Channel Strip Mode controls to display the Pan controls or the top level of Inserts or Sends for the channel.

2. Hold Command (Mac) or Control (Windows) and press the Rotary Encoder Select switch for the control you want to AutoMatch:
   - For Sends, the Send level, pan, and mute will AutoMatch.
   - For Inserts, all automated controls will AutoMatch.
   - For Pan, all pan sliders on the channel will AutoMatch.

To AutoMatch all controls for a plug-in displayed in the Dynamics or EQ section:

- Hold Command (Mac) or Control (Windows) and press the Auto switch in the Dyn or EQ section of the console.

---

### Priming Controls for Writing Automation in Latch Mode

(Pro Tools | Ultimate Software Only)

If a track is in Latch or Touch/Latch automation mode, you can prime individual controls for writing automation while the transport is stopped. This Latch Prime capability lets you prepare for an automation pass before starting playback.

**To prime controls for writing automation in Latch mode while the transport is stopped:**

1. Choose Setup > Preferences and click Mixing.

2. Under Automation, select Allow Latch Prime in Stop.

3. Click OK to close the Preferences window.

4. In the Automation window, make sure the controls you want to automate are write-enabled.

5. Click the Automation Mode selector on the track where you want to write automation and do one of the following:
   - Choose Latch mode to allow priming of all automation-enabled controls on the track.
   - Choose Touch/Latch mode to leave the main Volume fader in Touch mode and allow priming of all other automation-enabled controls.

6. While the transport is stopped, touch or move the controls you want to start writing at the beginning of the automation pass. When at least one control on a track is primed, the Automation Mode selector displays in red.

7. Start playback. All primed controls begin writing automation at their primed values.

8. Stop playback to finish the automation pass. All tracks are taken out of their Latch Prime state.

---

*You can use the Write to Punch command at the end of your automation pass to write the current value back to the start of the pass.*
Taking Tracks and Controls Out of Latch Prime

You can take individual tracks or automation types out of their Latch Prime state before or during an automation pass.

- When you take a track or automation type out of Latch Prime before starting playback, it stays in Latch mode but the corresponding controls are not primed to write when playback starts.
- When you take a track or automation type out of Latch Prime during an automation pass, the corresponding controls AutoMatch to their currently written values.
- If you AutoMatch a control that is in a Latch Prime state, the control will no longer be primed.

To take a track out of Latch Prime:

- Command-click (Mac) or Control-click (Windows) the Automation Mode selector on the track.

The selector button unbolds to indicate that the track is no longer primed.

To take all tracks out of Latch Prime, do one of the following:

- Option-Command-Shift-click (Mac) or Alt-Control-Shift-click (Windows) the Automation Mode selector on a track.
- Alt-Shift-click (Windows) Option-Shift-click (Mac) the AutoMatch button in the Automation window.

To take an automation type out of Latch Prime on all tracks, do one of the following:

- In the Automation window, Command-click (Mac) or Control-click (Windows) the button for the automation type (Volume, Pan, Mute, Plug-In, Send level, Send pan, or Send mute).

Rolling Through Automation Punch Points in Latch Prime

After you prime controls for writing automation while the transport is stopped, you can set Pro Tools to automatically punch in at that point after issuing a back and play command, or after rolling back and locking to timecode.
To set Pro Tools to automatically punch in automation writing on a track:

1. Locate the cursor where you want to punch in automation.

2. Prime controls for writing while the transport is stopped. (See “Priming Controls for Writing Automation in Latch Mode” on page 1145.)

3. In the Automation window, click the AutoJoin button.

4. In the Automation window, click the Capture button and then click the Punch Capture button. The AutoJoin marker (a vertical red line) appears on-screen at the punch point.

5. Issue a Back and Play command, roll back the external machine to before the punch in point, or enable pre-roll.

6. Start playback. When the transport reaches the punch-in point, automation writing begins.

---

**Enabling and Suspending Automation**

From the Automation window, you can enable or suspend writing for the following types of automation across all tracks:

- Volume
- Volume trim
- Pan
- Mute
- Plug-In
- Send level
- Send level trim
- Send pan
- Send mute
- Object/Bus (Pro Tools Ultimate with Dolby Atmos only)

Automation can be suspended or enabled during playback (without having to stop the Transport).

**Suspending Automation on All Tracks**

To suspend automation on all tracks:

1. Choose Window > Automation.

2. Do one of the following:

   - To suspend writing of all automation on all tracks, click the Suspend button.
   - To suspend writing of a specific type of automation on all tracks, click the button for that automation type (volume, mute, pan, plug-in, send level, send mute, or send pan).
To suspend Trim automation on all tracks (Pro Tools Ultimate only):

- In the Automation window, Command-click (Mac) or Control-click (Windows) the Suspend button.

The Suspend button highlights yellow to indicate that Trim automation is suspended.

To suspend automation for individual controls on a track:

1. In the Edit window, set the Track View selector to show the automation playlist for the control you want to suspend.

2. Do one of the following:
   - To suspend writing and playback of automation for only the displayed control, Command-click (Mac) or Control-click (Windows) the control name in the Track View selector.
   - To suspend writing and playback of automation for all controls, Command-Shift-click (Mac) or Control-Shift-click (Windows) the name of any control in the Track View selector.
   - To suspend writing and playback of automation for a specific control on all tracks, Command-Option-click (Mac) or Control-Alt-click (Windows) the name of the control in the Track View selector.

To suspend Trim automation for individual controls on a track (Pro Tools Ultimate only):

1. In the Edit window, set the Track View selector to show the automation playlist for the Trim control you want to suspend (Volume Trim or Send level Trim).

2. Do one of the following:
   - To suspend only the displayed Trim control on a single track, Command-click (Mac) or Control-click (Windows) the control name in the Track View selector.
   - To suspend the displayed Trim control on all tracks, Command-Option-click (Mac) or Control-Alt-click (Windows) the control name in the Track View selector.
Viewing Automation Enable Status

Track Automation Mode Selectors

- When a track is enabled for automation but not writing automation, the Automation mode selector shows the mode in normal red text.
- When any control on a track is writing automation, the Automation mode selector shows the mode highlighted in red.

Automation Window Buttons

- When an automation type is writing automation on any track in the session, the corresponding button in the Automation window displays bold red text.
- When an automation type is enabled but is not writing anywhere in the session, the corresponding button in the Automation window displays normal red text.

Automation Enable Guidelines

The following rules determine whether automation is enabled for a track:

- Although Pro Tools shows a single Automation mode for each track, all automatable controls associated with that track are not necessarily in the same Automation mode.
- If automation is globally suspended in the Automation window, all automatable controls behave as if they were in Off mode, regardless of the track’s current Automation mode.
- If automation for a control is suspended by Command-clicking (Mac) or Control-clicking (Windows) its name in the Track View selector, that control behaves as if it were in Off mode, regardless of the track’s current Automation mode.
- If automation for a control is suspended in the Automation window, that control behaves as if it is in Read mode when the track is in a writable Automation mode (Touch, Latch, or Write mode).

Deleting Automation

Automation data takes the form of a line graph with editable breakpoints. The easiest way to remove automation in a track or selection is to manually delete breakpoints from the automation playlist.

Removing data in this manner is different from using the Cut command, which creates anchor breakpoints at the boundaries of the remaining data. For details, see “Cutting, Copying, and Pasting Automation” on page 1157.
To remove automation data, display the automation playlist you want to edit by selecting it from the Track View selector, or by revealing it in an Automation lane, and do one of the following:

To remove a single breakpoint:
- With the Pencil tool or any Grabber tool, Option-click (Mac) or Alt-click (Windows) the breakpoint.

To remove several breakpoints at once:
- Use the Selector tool to select a range that contains the breakpoints, and press Delete (Mac) or Backspace (Windows).

To remove all automation data of the displayed type:
- Click with the Selector tool in the track and choose Edit > Select All, then press Delete (Mac) or Backspace (Windows).

To remove all automation for all automation playlists on a track:
1. Use the Selector tool to select a range of data to be removed.
2. Press Control+Delete (Mac) or Start+Backspace (Windows).

All automation data within the selection is removed for all automation playlists on that track, regardless of whether automation is write-enabled for those controls.

---

**Clearing Trim Automation**  
*(Pro Tools | Ultimate Software Only)*

If Trim automation has not been coalesced on a track, you can clear it. When you clear Trim automation, automation breakpoints on all Trim playlists are deleted and all Trim faders are reset to zero.

**To clear Trim automation:**

1. Select the track where you want to clear the Trim automation.
2. Do one of the following:
   - Choose Track > Clear Trim Automation.
   - Right-click the track name and choose Clear Trim Automation.

---

**Thinning Automation**

Pro Tools writes a maximum density of automation data during an automation pass in the form of breakpoints. Since Pro Tools creates ramps between breakpoints, it may not need all of the captured points to create a sonically accurate representation of the automation moves that you have made. Each breakpoint takes up space in memory allocated for automation, so thinning data by removing unneeded breakpoints can maximize system efficiency and performance.

Pro Tools provides two different ways to thin automation data: automatically with the Smooth and Thin Data After Pass option and manually with the Thin Automation commands.
Smooth and Thin Data After Pass

When this option is selected in the Mixing Preferences page, Pro Tools automatically thins the automation breakpoint data after each automation pass.

In the default settings for new sessions, the Smooth and Thin Data After Pass option is selected, with the Degree of Thinning setting set to Some. In most cases, this setting yields optimum performance while providing an accurate reproduction of your automation moves.

If you select None for the Degree of Thinning setting, Pro Tools writes the maximum possible number of breakpoints. You can still perform thinning at any time with the Thin Automation command. For more information on smoothing automation data, see “Smoothing” on page 1133.

Thin Automation Commands

The Thin Automation and the Thin All Automation commands lets you selectively thin areas where automation data is too dense. You can use the Undo command to audition the results of thinning (comparing thinning and not thinning) before you apply it permanently.

To manually thin automation:

1. In the Edit window, click the Track View selector to display an automation type you want to thin, or reveal the corresponding Automation lane.

2. With the Selector tool, highlight the automation data you want to thin. To thin automation for the entire track, click in the track with the Selector tool and choose Edit > Select All.

3. Do one of the following:
   - To thin only the currently displayed type of automation, choose Edit > Automation > Thin.
   - To thin all types of automation, choose Edit > Automation > Thin All.

Drawing Automation

Use the Pencil tool to create automation events for audio and MIDI tracks by drawing in any automation or MIDI controller playlist, including Trim automation if it has not been coalesced.

The Pencil tool can be set to draw a series of automation events with the following shapes:

Free Hand Draws freely according to the movement of the mouse. In audio tracks, the shape has the number of breakpoints needed to smoothly interpolate and reproduce the automation shape. In MIDI tracks, the shape is reproduced as a series of steps, according to the resolution setting in the MIDI Preferences page.

Line Draws a straight line. In audio tracks, the line has a single breakpoint at either end. In MIDI tracks, the controller value changes in steps according to the resolution setting in the MIDI Preferences page.

Triangle Draws a sawtooth pattern that repeats at a rate based on the current Grid value. In audio tracks, the pattern has a single breakpoint at each extreme. In MIDI tracks, the controller value changes in steps according to the resolution setting in the MIDI Preferences page. Amplitude is controlled by vertical movement of the Pencil tool.

Square Draws a square pattern that repeats at a rate based on the current Grid value. Amplitude is controlled by vertical movement of the Pencil tool.
Random Draws a random pattern of levels that change at a rate based on the current Grid value. Amplitude is controlled by vertical movement of the Pencil tool.

⚠️ The Parabolic and S-Curve Pencil shapes are not available for editing automation.

Using Pencil Tool Shapes

You can draw automation for audio as well as MIDI tracks. For example, use the Triangle pattern to control continuous functions, or the Square pattern to control switched functions such as Mute or Bypass.

Since the Pencil tool draws these shapes using the current Grid value, you can use it to perform panning in tempo with a music track, or on frame scene changes when working in post production.

For more information on MIDI continuous controller data, see “Continuous Controller Events” on page 764.

Resolution of MIDI Controller Data

When using the Pencil tool to draw MIDI automation, the data is drawn as a series of discrete steps. You can control the resolution (or density) of these steps to help manage the amount of MIDI data sent for a given MIDI controller move.

To set the resolution for the Pencil tool:

1. Choose Setup > Preferences and click MIDI.
2. Enter a value for Pencil Tool Resolution When Drawing Controller Data. The value can range from 1 to 100 milliseconds.
3. Click OK to close the Preferences window.

The following illustrations show the same MIDI controller automation drawn with different Pencil tool resolution settings.

MIDI Data drawn with resolution of 10 ms

MIDI Data drawn with resolution of 100 ms

For better performance, consider selecting a smaller value for MIDI controls that need higher resolution (such as MIDI volume), and a larger value for controls that may not require a high resolution (such as Pan).

Editing Automation

For all tracks in a session, Pro Tools provides several ways to edit automation data—including Trim automation if it has not been coalesced (Pro Tools Ultimate only). You can edit automation data graphically by adjusting breakpoints in any automation playlist. You can also cut, copy, and paste automation data in the same manner as audio and MIDI data.
Graphical Editing of Automation Data

Automation data takes the form of a line graph with editable breakpoints.

By dragging these breakpoints, you can modify the automation data directly in the Edit window and MIDI Editor windows. When you drag an automation breakpoint up or down, the change in value is numerically or textually indicated.

Drag an automation breakpoint to the left or right to adjust the timing of the automation event.

To view the breakpoint automation type on any track, either select the corresponding Track View or reveal the corresponding Automation or Controller lane under the track.

Using the Grabber Tools

The Grabber tools let you create new breakpoints by clicking on the graph line, or adjust existing breakpoints by dragging them. Option-click (Mac) or Alt-click (Windows) breakpoints with a Grabber tool to remove them.

Using the Pencil Tool

The Pencil tool lets you create new breakpoints by clicking once on the graph line. Option-click (Mac) or Alt-click (Windows) breakpoints with the Pencil tool to remove them.

Using the Trim Tools

The Trim tools let you adjust all selected breakpoints up or down by dragging anywhere within that selection.
Editing Automation Types

Each automatable control has its own automation playlist, that can be displayed by choosing it from the Track View selector. “Viewing Automation” on page 1135.

Editing Volume Automation

Drag a breakpoint up or down to change the volume (dB value). Drag a breakpoint to the left or right to adjust the timing of the volume change.

Editing Pan Automation

Drag a breakpoint down to pan right, and up to pan left. Drag a breakpoint to the left or right to adjust the timing of the panning moves.

Editing Mute Automation

Drag the breakpoint down to mute a section. Drag a breakpoint up to unmute the section. Drag a breakpoint to the left or right to adjust the timing of the mute.

Editing Stepped Control Automation

Automation for certain controls (such as MIDI controller values or plug-in settings) appears as a stepped pattern on the breakpoint line. Drag a breakpoint up or down to a different step to change to a new control value. Drag a breakpoint to the left or right to adjust the timing of the stepped control change.

Editing Automation Breakpoints

To edit automation breakpoints, display the automation playlist for the control you want to edit by selecting it from the Track View selector, then do one of the following:

To create a new breakpoint:

- Click with the Pencil tool or any Grabber tool on the line graph.
To edit a single breakpoint:

- Click an existing point on the line graph with any Grabber tool and drag it to a new position.

For vertically constrained, fine-resolution editing of any automation breakpoint, Command-Shift-click-drag (Mac) or Control-Shift-click-drag the breakpoint to the desired value.

To clear a single breakpoint:

- Option-click (Mac) or Alt-click (Windows) with any Grabber tool.

To edit several breakpoints at once:

- Use the Selector tool to select a range in the automation playlist that contains the breakpoints, and do one of the following:
  - To move the breakpoints earlier or later in the track, press the Plus key (+) to nudge them later (to the right) or the Minus key (–) to nudge them earlier (to the left). The breakpoints move by the current Nudge value.
  - To adjust the breakpoint values, click with any of the Trim tools in the selection and drag the breakpoints up or down.

When you nudge a selection containing breakpoints, if necessary, new anchor breakpoints are created to preserve the slope of the automation within the selection.

- To adjust the breakpoint values, click with any of the Trim tools in the selection and drag the breakpoints up or down.

When you use a Trim tool to edit a selection containing breakpoints, new anchor breakpoints are created before and after the selected area. To suppress creation of anchor breakpoints while using a Trim tool, hold Option (Mac) or Alt (Windows) while trimming.

To edit all breakpoint values in a clip:

- Click in the clip with any of the Trim tools and drag the breakpoints up or down.

Constraining New Breakpoints to the Next or Previous Automation Value

New automation breakpoints can be constrained and written to the same value as the next or previous breakpoint.

To write a new breakpoint to the next automation value:

- Hold Option+Shift (Mac) or Alt+Shift (Windows) while writing a breakpoint (by clicking with any Grabber tool in a track’s automation playlist).

To write a new breakpoint to the previous automation value:

- Hold Command+Option (Mac) or Control+Alt (Windows) while writing a breakpoint (by clicking with any Grabber tool in a track’s automation playlist).

The Smart Tool cannot be used to write a new breakpoint to the next or previous automation value.
Editing Automation on Stereo and Multichannel Tracks

Stereo and multichannel tracks display a single automation playlist per track. Only one playlist for volume and mute is available for the stereo or multichannel track.

Plug-In Automation Playlists on Stereo and Multichannel Tracks

Some multichannel plug-ins provide a single set of automatable controls for all channels in a track. Other multichannel plug-ins and all multi-mono plug-ins provide a single set of controls for all channels when linked, or discrete controls for each channel when unlinked. See your plug-in guide for more information.

For multi-mono plug-ins, automation playlists for each individual channel can be displayed and edited when the plug-in is unlinked, and the track is in showing Automation lanes.

To view and edit the individual playlists of a multi-mono plug-in:

1. Unlink the plug-in.

2. Select the automation playlist from the Track View selector or reveal it in an Automation lane under the track.

Editing Automation on Grouped Tracks

When you edit automation on an audio track that is a member of an active Edit Group, the same type of automation is also edited on all tracks that are part of that group. This occurs even if the playlist for that type of automation is not currently displayed on the other grouped tracks.

Examples

- If you create new automation breakpoints on a grouped track (with the Pencil tool or any Grabber tool), other members of the group have breakpoints placed relative to that track.

- If you move automation on a grouped track (with any of the Trim tools), other members of the group have their breakpoints trimmed relative to that track. This lets you trim entire sections of a mix.

To individually edit a automation for a member of a group without affecting the other members, do one of the following:

- Press Control (Mac) or Start (Windows) while you perform the edit.
Cutting, Copying, and Pasting Automation

Cutting automation data is different from deleting it, and yields different results (although both change the existing automation data). Copying automation leaves the original automation data intact.

You delete automation data by selecting a range of breakpoints and pressing Delete (Mac) or Backspace (Windows). See “Deleting Automation” on page 1149 for details.

You cut automation data by selecting a range of breakpoints from an automation playlist and selecting the Cut command.

When you cut automation data and when you paste it into a new location, anchor breakpoints are added to the beginning and end points of the data. This is done to preserve the true slope (of continuous controls, such as Volume faders or pans) or state (of switched or stepped controls, such as Mutes) of the automation data both inside and outside the selection.

The following illustrations show the difference between cutting and deleting automation data. In the following figure, a track is set to display volume automation, and a range of automation data is selected.

If the Cut command is chosen, anchor breakpoints are created at each end of the selection, and the automation slope on either side of the cut data is preserved, as shown in the following figure.

If the data is deleted by pressing Delete (Mac) or Backspace (Windows), the automation data is removed, and automation values span the gap between pre-existing breakpoints, as shown in the following figure.

In addition, if cut or copied data is pasted elsewhere in a track, breakpoints are created at the end points of the pasted data to preserve its “neighboring” (incoming and outgoing) automation value and slope, as shown in the following figure.

⚠️ You cannot cut or copy automation data from an automation playlist unless that playlist includes at least one breakpoint in it. The selection you are cutting or copying does not need to include any breakpoints, but without at least one breakpoint on an automation playlist, there is no automation data to copy.
Editing and Track Views

Audio, MIDI, and Instrument tracks each have a Track View that acts as the Master View for purposes of editing. When the Master View is displayed, any edits performed on the track apply to all data in the track.

The Master Views are:
- Audio tracks: Blocks and Waveform
- MIDI and Instrument tracks: Blocks, Clips, and Notes

For example, when an audio track is set to Waveform or Blocks, cutting, copying and pasting affects the audio data and all types of automation data on that track. If the track is set to show Pan automation, only the Pan data is affected.

When a selection includes multiple tracks, if any of those tracks is in its Master View, all data on all selected tracks is affected.

To edit all automation types on an Auxiliary Input or Master Fader track, do one of the following:
- Make an Edit selection that includes at least one audio or MIDI track that is displayed in its main format.
- Press Control while cutting or copying the automation data.

Tips for Cutting, Copying and Pasting Automation

- On audio tracks, when you are in Waveform View and cut or copy a section of the waveform, any automation data associated with the waveform is also cut or copied.
- On audio tracks, when you are in Waveform View and cut audio data from a track also containing automation data, breakpoints are automatically created at the boundaries of the remaining automation data.
- On audio tracks, pasting waveform data also pastes any associated automation data.
- On Auxiliary Input, Master Fader, or Instrument tracks, only the displayed automation data is cut or copied. To cut or copy all automation data on these types of tracks, press Control while cutting or copying.
- In tracks where an automation playlist contains no data (when there is only a single breakpoint at the very beginning of the track), if you cut data, no new breakpoints are created.
- In cases where clips overlap (such as when moving clips in Slip mode) and an overlapping clip is removed, any overlapped automation breakpoints are lost.
- If cut or copied data contains a type of automation not currently on the target track, Pro Tools prompts you before allowing you to paste the data.
- Cut or copied automation data for plug-ins or sends that do not exist on the target track is ignored when pasted.

For additional flexibility, you can use playlists or the Duplicate Track command to work nondestructively on a copy of the edit data.
Cut, Copy, Clear, and Paste Special Commands

Four “special” commands—Cut Special, Copy Special, Paste Special, and Clear Special—simplify the tasks involved with moving or clearing different types of automation data and MIDI controller data between tracks, sends, and plug-ins. These commands let you

• Edit automation and MIDI controller data only (without associated audio or MIDI notes).
• Edit automation and MIDI controller data without having to change Track Views

In addition, the Paste Special command lets you copy one data type to another (for example, Left Pan data into the Right Pan playlist)

⚠️ You cannot paste MIDI controller data to automation data nor automation to MIDI.

Cut Special

The Cut Special commands let you cut just automation data from the current selection (without associated audio or MIDI notes) and place it in memory to paste elsewhere, as follows:

All Automation Cuts all automation or MIDI controller data whether it is shown or not.

Pan Automation Cuts only pan automation or MIDI pan data whether it is shown or not.

Plug-In Automation Cuts only the plug-in automation that is shown.

Copy Special

The Copy Special commands let you copy just automation data from the current selection (without associated audio or MIDI notes) and place a copy of it in memory to paste elsewhere, as follows:

All Automation Copies all automation or MIDI controller data whether it is shown or not.

Pan Automation Copies only pan automation or MIDI pan data whether it is shown or not.

Plug-In Automation Copies only the plug-in automation that is shown.

Paste Special

The Paste Special commands let you paste automation data into another clip (without affecting associated audio or MIDI notes) in the following ways:

Merge Lets you add the pasted data to any existing automation data of the same type in the destination selection. This can be useful for consolidating MIDI data from several tracks into a single MIDI track. For example, you like the pitch bend on the synth trombones and want to apply it to the synth guitar.

Repeat to Fill Selection Pastes multiple iterations of the automation data to the entire selection range. If you select an area that is not an exact multiple of the copied clip size, the remaining selection area is filled with a trimmed version of the original selection. This lets you easily create drum loops and other repetitive effects. Before the data is pasted, Pro Tools prompts you to specify a crossfade to smooth transitions between clips.
**To Current Automation Type** Pastes the automation data or MIDI controller data from the clipboard to the selection as current automation type or MIDI controller. This lets you copy automation from any type to any other type. For example, you can copy a Left Pan automation to Plug-In automation. You can also copy MIDI volume data and paste it to MIDI pan.

**Clear Special**

The Clear Special commands let you clear just automation data from the current clip, as follows:

**All Automation** Clears all automation or MIDI controller data whether it is shown or not.

**Pan Automation** Clears only pan automation or MIDI pan whether it is shown or not.

**Plug-In Automation** Clears only the plug-in automation that is shown.

**Special Paste Function for Automation Data**

Normally, when you copy and paste automation data, it is pasted in an automation playlist of the exact same type (for example, Left Pan data is pasted into the Left Pan playlist).

However, there may be times when you want to paste from one data type to another (for example, Left Pan data into the Right Pan playlist).

The Special Paste command lets you copy one data type to another.

If you want to paste automation or MIDI controller data only (without its associated audio or MIDI notes), use the Paste Special command.

For this special paste mode to function, the following must be true:

- Every track selected for pasting must be currently displayed as automation data.
- There must be only one automation playlist on the Clipboard for each target track. (The Special Paste command cannot copy multiple automation playlists for each track.)

⚠️ You cannot interchange automation data between audio and MIDI tracks, or between continuous controls (such as faders or pans) and switched or stepped controls (such as mute or MIDI controllers).

**To paste data into a different automation playlist:**

- Press the Control (Mac) or Start key (Windows) when choosing Edit > Paste.

**Converting Volume Automation and Clip Gain**

*(Pro Tools | Ultimate Software Only)*

Pro Tools lets you convert clip gain settings to track-based volume automation, as well as letting you convert track-based volume automation to clip gain settings. For more information, see “Converting Clip Gain and Track Volume Automation” on page 947.

**Coalescing Volume Automation and Clip Gain**

*(Pro Tools | Ultimate Software Only)*

Pro Tools lets you coalesce clip gain settings to track-based volume automation, as well as letting you coalesce track-based volume automation to clip gain settings. For more information, see “Coalescing Clip Gain and Track Volume Automation” on page 948.


Glide Automation
(Pro Tools | Ultimate Software Only)

The Glide Automation commands let you manually create an automation transition (or glide) from an existing automation value to a new one, over a selected area.

💡 When gliding multiple parameters at the same time, such as with the Surround Panner or plug-ins, use the Edit > Automation > Glide to All Enabled option.

⚠️ For MIDI automation, Glide To commands only apply to MIDI Volume, MIDI Pan, and MIDI Mute. MIDI parameters cannot use the Write To commands.

To apply a Glide Automation to the current automation parameter type:
1 In the Automation window, make sure the automation type is write-enabled.
2 Click the Track View selector to choose the automation type you want to automate.
3 Drag with the Selector tool in the track to select the area you want to write the glide to.
4 Change the automation parameter to the value you want at the end of the selection. For example, to glide automation volume to –Infinity, move the Volume fader to –Infinity.
5 Choose Edit > Automation > Glide to Current.

voor You can also press Option+Forward Slash (/) (Mac) or Alt+Forward Slash (/) (Windows).

To apply a Glide Automation to all current enabled parameters:
1 In the Automation window, make sure the automation types are write-enabled.
2 In each track you want to automate, click the Track View selector and select from the pop-up menu the automation type you want to automate.
3 With the Selector tool, drag horizontally to include all the tracks you want to automate in a selection (drag vertically to define the time range).
4 In each track you want to automate, change the automation parameter to the value you want at the end of the selection.
5 Choose Edit > Automation > Glide to All Enabled.

voor You can also press Option+Shift+Forward Slash (/) (Mac) or Alt+Shift+Forward Slash (/) (Windows).

To apply a Glide Automation to pan only:
1 In the Automation window, make sure that Pan automation is write-enabled.
2 Click the Track View selector to choose Pan automation.
3 Drag with the Selector tool in the track to select the area you want to write the glide to.
4 Change the pan automation to the value you want at the end of the selection.
5 Choose Edit > Automation > Glide Pan Only.

voor You can also press Control+Shift+Forward Slash (/) (Mac) or Start+Shift+Forward Slash (/) (Windows).
Glide Automation
Considerations

When Glide Automation is applied to automation data, it behaves as follows:

• When a selection is made, automation breakpoints are written at the start and end points of the Glide Automation. The automation value at the start of the selection is the start point of the Glide Automation and the end of the selection is the end point of the Glide Automation. The Glide Automation that is created between the two is based on the length of the selection and the end value that is selected.

• If automation breakpoints follow the selection, they are not changed, but the value selected for the end of the selection is written from the end point up until the next breakpoint.

• If no automation breakpoints follow the selection, the value selected for the end of the selection is written to the end of the track.

• If no selection is made, a breakpoint is written to the current location, and the value selected for the Glide Automation is written to the next breakpoint.

• The Glide Pan Only command lets you glide all pan automation parameters without affecting other automation enabled playlists. This is particularly useful for surround tracks.

To enable Trim mode:

- In the Mix or Edit window, click the Automation Mode selector of the track where you want to trim automation, and select Trim.

Enabling Trim mode

When a track’s Trim mode is enabled, its Volume and Send Level faders turn yellow, and its Automation Mode selector is outlined in yellow. This outline appears solid if the track is trim-enabled, and flashes whenever trimming is occurring on the track’s volume or send levels.

Writing Trim Automation

The writing of Trim automation depends on how it is set to be coalesced. See “Coalescing Trim Automation” on page 1163. If automation is not set to coalesce after every automation pass, Trim automation moves are written to a separate Trim playlist.

To trim track Volume or Send levels:

1 In the Automation window, make sure the automation type (Volume or Send level) is write-enabled.

2 Click the Automation Mode selector of the track where you want to write automation and choose the automation mode (Touch, Latch, Touch/Latch, or Write).
3 Click the Automation Mode selector and select Trim.
4 Start playback, and adjust the Volume or Send levels.
5 Stop playback to finish the Trim pass.

**Coalescing Trim Automation**

You can set Pro Tools to commit, or *coalesce*, Trim automation to the main automation playlist by the following methods:

**After Every Pass** Trim moves are automatically applied when the transport is stopped at the end of an automation pass. Trim automation playlists are cleared, and Trim faders are returned to zero.

**On Exiting Trim Mode** Trim moves are stored separately in the Trim automation playlist until they are coalesced. Trim automation is automatically coalesced on a track only when you take the track out of Trim mode. You can repeat an automation pass, edit Trim automation manually on any of the Trim playlists, or clear Trim automation before coalescing with this method.

*Even when automation is set to coalesce on exiting Trim mode, you can use the Coalesce Trim Automation command to commit Trim moves at any time.*

**Manually** Trim moves are stored separately in the Trim automation playlist until they are coalesced. With this setting, the only way to coalesce Trim moves is with the Coalesce Trim Automation command. You can repeat an automation pass, edit Trim automation manually on any of the Trim playlists, or clear Trim automation before coalescing with this method.

To manually coalesce Trim automation on a track:

1 Select the track where you want to coalesce the Trim automation.
2 Do one of the following:
   • Choose Track > Coalesce Trim Automation.
   • Right-click the track name and choose Coalesce Trim Automation.

To set the method by which Trim Automation is coalesced:

1 Choose Setup > Preferences and click Mixing.
2 Under Coalesce Trim Automation, select one of the following:
   • After Every Pass
   • On Exiting Trim Mode
   • Manually

To coalesce Trim automation on a track when exiting Trim mode:

1 Choose Setup > Preferences and click Mixing.
2 Under Coalesce Trim Automation, select On Exiting Trim Mode.
3 Click OK to close the Preferences window.
4 Make sure the Pro Tools transport is stopped.
5 On the track where you want to coalesce Trim automation, click the Automation Mode selector and deselect Trim.

The Trim automation is applied to the main automation playlist, Trim automation playlists are cleared, and Trim faders are returned to zero.

*If transport is playing and you are writing automation, you cannot directly enter or exit Trim mode. You must AutoMatch before exiting Trim mode. This prevents any abrupt jumps in automation values.*
The Trim automation is applied to the main automation playlist, Trim automation playlists are cleared, and Trim faders are returned to zero.

Writing Automation to the Start, End, or All of a Track or Selection
(Pro Tools | Ultimate Software Only)

Pro Tools lets you write current automation values from any insertion point forward (or backward) to the end (or beginning) of a track or Edit selection in a track, or to an entire track or Edit selection, while performing an automation pass.

Optionally, Write Automation to Start, All, and End can be configured to always be applied automatically. See “Writing Automation to the Start, End or All of a Track or Selection on Stop” on page 1165.

⚠️ For MIDI automation, the Write To commands only apply to MIDI Volume, MIDI Pan, and MIDI Mute. MIDI parameters cannot use the Write To commands.

Requirements for Standard Write Automation Commands

For automation data to be written for a specific parameter, the associated track must be in one of the following Automation modes and meet the following conditions:

- **Latch Mode** The control for the parameter must be changed (touched) during the automation pass.
- **Touch Mode** The control for the parameter must be changed (touched).
- **Write Mode** All controls on that track must be in Write mode.

This command can be undone.

To write current automation values to the start, end, or all of a track or Edit selection:

1. Choose Window > Automation.
2. Make sure that the automation type is write-enabled.
3. Do one of the following:
   - Click in a track at an insertion point.
   - Drag with the Selector tool to select a portion of the track.
4. Start playback.
5. Make sure you are actively writing on the appropriate track if you are in Latch or Touch mode.

The standard Write Automation to Start, All, or End commands do not operate when the Pro Tools transport is stopped. It only affects automation for those parameters that are currently write-enabled and currently writing automation data.
6 When you reach a point in the track or selection that contains the automation data you want to apply, click the Write Automation to Start, All, or End button in the Automation window.

7 Stop playback.

The current values of all write-enabled automation at that point are written to the corresponding area of the track/selection.

**Write to Start, End or All and Trim Mode**

While in Trim mode, it is also possible to write trim delta values for track volume and send levels to the start, end or all of a track or Edit selection.

To write current trim delta values to the start, end, or all of a track or selection:

1 Choose Window > Automation.

2 Make sure the automation type (track volume or send level) is write-enabled.

3 In the Mix or Edit window, click the Automation Mode selector of the track you want to trim automation, and select Trim. The track Volume and Send Level faders turn yellow.

4 Do one of the following:
   - Click in a track at an insertion point.
   - Drag with the Selector tool to select a portion of the track.

5 Click Play to begin playback.

6 When you reach a point in the track or selection that contains the trim setting (delta value) you want to apply, click the Write Automation to Start, All, or End button in the Automation window.

7 Stop playback.

The relative changes to the track volume and send levels at that point are written to the corresponding area of the track/selection.

**Writing Automation to the Start, End or All of a Track or Selection on Stop**

The Automation window provides options for writing automation on any automation playlist (including Trim playlists) after a valid automation pass has been performed.

The Write Automation to Start, End, or All modes can be configured to disable or remain enabled after a valid automation pass.

See “Requirements for Standard Write Automation Commands” on page 1164.
The enabled Write on Stop arrow appears in blue.

**To configure Write on Stop modes to remain enabled after an automation pass:**

1. Choose Window > Automation.
2. Option-click (Mac) or Alt-click (Windows) one of the Write On Stop buttons (Start, All or End) to enable the Write On Stop mode.

The enabled Write on Stop arrow appears in red.

---

**Writing Automation to the Next Breakpoint or to the Punch Point**

*(Pro Tools | Ultimate Software Only)*

While performing an automation pass, Pro Tools lets you write current automation values from the current insertion point forward to the next automation breakpoint, or back to the punch point (the location in the track where automation writing started).

- Write Automation to Next Breakpoint lets you update automation within a track without overwriting automation located earlier or later in the Timeline, and without having to define a selection before editing automation.

- Write Automation to Punch Point lets you fill back an automation value within a track after finding the right level or setting during an automation pass, without having to go back and repeat the pass.

Like the standard Write Automation to Start, End, and All commands, the Write Automation to Next Breakpoint and Write Automation to Punch Point commands do not operate when the Pro Tools transport is stopped. They only affect automation for those parameters that are currently write-enabled and currently writing automation data.

⚠️ *For MIDI automation, the Write To commands only apply to MIDI Volume, MIDI Pan, and MIDI Mute. Other MIDI parameters cannot use the Write To commands.*

Optionally, the Write Automation to Next Breakpoint and Write Automation to Punch Point commands can be configured to be applied automatically after a valid automation pass has been performed. See “Writing Automation to the Next Breakpoint or to the Punch Point on Stop” on page 1168.

⚠️ *Write Automation to Next Breakpoint and Write Automation to Punch Point have the same requirements as Write Automation to Start, End and All commands. See “Writing Automation to the Start, End, or All of a Track or Selection” on page 1164.*

**To write current automation values to the next breakpoint:**

1. Choose Window > Automation.
2. Make sure that the automation type is write-enabled.
3. Click in a track to define an insertion point.
4. Start playback.
5. Make sure you are actively writing on the appropriate track if you are in Touch, Latch, or Touch/Latch mode.
6 When you reach a point in the track where you want to apply the current settings, click the Write Automation to Next Breakpoint button.

7 Stop Playback.

The current values of all controls being written at that point are written up to the next breakpoint.

⚠️ Write Automation to Next Breakpoint remains enabled after a valid automation pass. Unlike standard Write Automation commands, it cannot be configured to disable after an automation pass.

To write current automation values back to the automation punch point:

1 Choose Window > Automation.
2 Make sure the automation type is write enabled.
3 Click in a track to define an insertion point.
4 Start playback.
5 Make sure you are actively writing on the appropriate track if you are in Touch, Latch, or Touch/Latch mode.
6 When you reach a point in the track where you want to apply the current settings, click the Write Automation to Punch Point button.

The current values of all write-enabled parameters are written back to the point where the first control began writing automation.
Write To Next Breakpoint or Punch Point and Trim Mode

While in Trim mode, it is also possible to write trim values for track volume and send levels to the next written breakpoint or back to the automation punch-in point.

To write current trim values to the next breakpoint or to the punch point:

1. Choose Window > Automation.
2. Make sure that the automation type (track volume or send level) is write-enabled.
3. In the Mix or Edit window, click the Automation Mode selector and select Trim. The track Volume and Send Level faders turn yellow.
4. Click in a track to define an insertion point.
5. Start playback.
6. When you reach a point in the track where you want to apply the current trim values, click the Write Automation to Next Breakpoint button in the Automation window.

To write current trim values to the punch point:

1. Choose Window > Automation.
2. Make sure that the automation type (track volume or send level) is write-enabled.
3. In the Mix or Edit window, click the Automation Mode selector and select Trim. The track Volume and Send Level faders turn yellow.
4. Click in a track to define an insertion point.
5. Start playback.
6. When you reach a point in the track where you want to apply the current trim values, click the Write Automation to Punch Point button in the Automation window.

Writing Automation to the Next Breakpoint or to the Punch Point on Stop

The Automation window provides an option for automatic Write Automation to Next Breakpoint on Stop or Write Automation to Punch Point on Stop.

⚠️ Write Automation to Next Breakpoint remains enabled after a valid automation pass. Unlike standard Write Automation commands, it cannot be configured to disable after an automation pass.

To configure Write Automation to Next Breakpoint on Stop:

1. Choose Window > Automation.
2. Click the Write Automation to Next Breakpoint on Stop button or the Write Automation to Punch Point button.

When this option is enabled, automation writing will be performed automatically forward to the next breakpoint after a valid automation pass has been performed.

To configure Write Automation to Punch Point on Stop:

1. Choose Window > Automation.
2. Click the Write Automation to Punch Point on Stop button.

When this option is enabled, automation writing will be performed automatically back to the automation punch-in point after a valid automation pass has been performed.
Guidelines for “Write To” Commands

(Pro Tools | Ultimate Software Only)

Using “Write To” Commands During Playback

You can carry out any of the Write Automation To commands without stopping the Pro Tools transport. On supported control surfaces, the corresponding “Write To” button flashes until you stop the transport.

While the Pro Tools transport is moving, issuing Write Automation To commands affects writing of automation in the following ways:

- Write to Start/Selection Start: Currently writing controls continue writing automation
- Write to All/Selection: Currently writing controls (except controls in Write mode) punch out of writing automation
- Write to End/Selection End: Currently writing controls (except controls in Write mode) punch out of writing automation
- Write to Next Breakpoint: Currently writing controls (except controls in Write mode) punch out of writing automation
- Write to Punch point: Currently writing controls continue writing automation

⚠️ For MIDI automation, the Write To commands only apply to MIDI Volume, MIDI Pan, and MIDI Mute. MIDI parameters cannot use the Write To commands.

Applying “Write To” Commands to Selected Tracks

The Write Automation To commands normally apply to all tracks currently writing automation. It is possible to apply these commands to selected tracks only.

To apply any of the “Write Automation To” commands to currently selected tracks:

1. Select the tracks where you want to apply the Write To commands.

2. Option-Shift-click (Mac) or Alt-Shift-click (Windows) the corresponding “Write Automation To” button.

Suppressing Warnings when Using “Write To” Commands

When you carry out any of the Write Automation To commands (except Write to Next Breakpoint), Pro Tools posts a dialog warning that automation values will be changed in the session. You can suppress these warnings.

To suppress “Write To” warning dialogs:

1. Choose Setup > Preferences and click Mixing.

2. Under Automation, select Suppress Automation “Write To” Warnings.
Overwriting or Extending Mute Automation

(Pro Tools | Ultimate Software Only)

Pro Tools lets you overwrite or extend an existing mute event in real time, without changing the current mute state.

A mute event can be overwritten when the automation pass begins before the first mute event and ends after the second event. In this case, the current on/off state of the mute is maintained.

A mute event can be extended when the automation pass begins before an on or off event and stops before the end of the second event.

Overwriting a mute automation event

Extending a mute automation event

Mute Overwrite/Extend is Supported in Touch and Latch Mode, as follows:

Touch Mode Writes the current state as long as the Mute button is held.

Latch Mode Writes the current state until you stop or AutoMatch out.
To overwrite a mute state on one or more tracks:

1. Choose Window > Automation.
2. Make sure Mute is write-enabled.
3. In the Mix or Edit window, click the Automation Mode selector of the track where you want to overwrite the mute state, and set the Automation mode to Touch or Latch mode.
4. In each track you want to automate, click the Track View selector and select mute.
5. Place the cursor before the start of the mute event you want to overwrite.
7. Press Command (Mac) or Control (Windows) and the track Mute button before the start of the mute event you want to overwrite.
8. After the end of the second mute event, release the key and the Mute button.
9. When you have finished the automation pass, stop playback.

To overwrite mute states on multiple tracks, set all tracks to the same Automation mode.

To extend a mute state on a track:

1. Choose Window > Automation.
2. Make sure mute is write-enabled.

To extend a mute state on multiple tracks, press Option+Command (Mac) or Alt+Control (Windows) and the Mute button on one of the tracks to be automated.

With Touch mode, you have to hold the Mute button for the duration of the write.
3 In the Mix or Edit window, click the Automation Mode selector of the track you want to automate, and select Touch or Latch mode.

💡 To extend mute states on multiple tracks, set all the tracks to the same Automation mode.

4 In each track you want to automate, click the Track View selector and select mute.

5 Place the cursor before the start of the mute event you want to extend.

6 Start playback.

7 Press Command (Mac) or Control (Windows) and the track Mute button before the start of the mute event you want to extend.

💡 To extend mute states on multiple tracks, press Option+Command (Mac) or Alt+Control (Windows) and the Mute button on the track.

8 Before the end of the second mute event, release the key and the Mute button.

💡 If you extend past the subsequent on or off event, the entire event will be changed.

9 When you have finished the automation pass, click Stop.

Creating Snapshot Automation

(Pro Tools | Ultimate Software Only)

Pro Tools Ultimate lets you write automation data values for multiple parameters in a single step. You can write snapshot automation in two ways:

**To a Selection** Automation data is written to the Timeline selection (as well as the Edit selection if linked). Anchor breakpoints are placed just before and after the selection so that data outside the selection is not affected.

**To a Cursor Location** Automation data is written at the insertion point. After the insertion point, the automation ramps to the next breakpoint value, or if no breakpoints exist, remains at the newly written value for the remainder of the session.

⚠️ For MIDI automation, the Write To, Trim To, and Glide To commands only apply to MIDI Volume, MIDI Pan, and MIDI Mute. MIDI parameters cannot use the Write To commands.

For more information on cutting, copying, and pasting automation data within a session, see “Writing Automation to the Start, End, or All of a Track or Selection” on page 1164.
To write snapshot automation:

1. In the Automation window, make sure that the parameters you want to edit are write-enabled. Deselect any parameters whose automation you want to preserve.

2. In the Edit window, click the Track View selector to show the automation you want to edit.

3. Write a breakpoint in the playlist if none currently exists, as follows:
   - Place the cursor in the playlist (or make an Edit selection), then press Command+Forward Slash (/) (Mac) or Control+Forward Slash (/) (Windows).
   - Select the Grabber tool and click anywhere in the playlist.

4. Do one of the following:
   - Select an area in the track’s playlist (or within multiple tracks) where you want to apply the automation.
   - Place the cursor at an Edit insertion point.

5. Adjust the controls you want to automate. You can also change a plug-in preset.

6. Choose Edit > Automation and do one of the following:
   - To write the current value to only the currently displayed automation parameter, choose Write to Current.
   - To write the current settings for all automation parameters enabled in the Automation window, choose Write to All Enabled.

Adding Snapshot Automation to Empty Automation Playlists

When you use a Write Automation command on an automation playlist with no previously written automation data, the selected value is written to the entire playlist and not just the selected area.

This is because a playlist with no automation data contains only a single automation breakpoint that corresponds to the current position of the control for the parameter. The position of the breakpoint is updated whenever the parameter value is changed.

If you do not want the Write Automation command to write the selected automation value to the entire playlist, you can:
   - Anchor the automation data by placing the cursor at the end of the session (or any other end point) and choosing Write to Current.
   - Click with any Grabber tool on each side of the selection.

This lets the Write Automation command write only to the selected area.

Writing Snapshot Automation over Existing Automation Data

When you move the playback cursor, the automated controls in Pro Tools update to reflect the automation data that is already on the track. To keep the settings you have made for a snapshot, you can suspend automation parameters to prevent them from updating.
To write snapshot automation over existing data:

1 In the Automation window, make sure that the automation parameters you want to edit are write-enabled. Deselect any parameters whose automation you want to preserve.

2 Adjust the controls for the parameters you want to automate.

3 Click the Automation Mode selector and select Off mode for the tracks where you want to apply the automation.

4 With the Selector, select the range where you want to apply the automation.

5 Choose Edit > Automation and select one of the following from the submenu:
   - To write the current value to only the automation parameter currently displayed in the Edit window, choose Write to Current.
   - To write the current settings for all automation parameters enabled in the Automation window, choose Write to All Enabled.

6 Click the Automation Mode selector and select Read mode for the tracks you want to play back with automation.

Capturing Automation and Applying it Elsewhere

The Write Automation commands can also be used to capture automation states at specific locations in a track and apply them to other locations in the track.

To capture and apply automation:

1 In the Automation window, make sure that the automation parameters you want to edit are write-enabled. Deselect any parameters whose automation you want to preserve.

2 Click the Automation Mode selector and select Read mode for the tracks that have automation you want to capture.

3 Ensure that Options > Link Timeline and Edit Selection is selected.

4 With the Selector tool, select the location where you want to capture automation. All automated controls update to reflect the automation at that location. (If you make a selection, the controls update to reflect the automation at the beginning of the selection.)

5 In each track you want to apply the captured automation, click the track’s Automation Mode selector and set the Automation mode to Off.

6 With the Selector tool, select the location where you want to apply the automation.

7 Enable the automation parameters previously suspended.

8 Choose Edit > Automation and select one of the following from the submenu:
   - To write the current value to only the automation parameter currently displayed in the Edit window, choose Write To Current.
   - To write the current settings for all automation parameters enabled in the Automation Enable window, choose Write To All Enabled.

9 Click the Automation Mode selector and select Read mode for the tracks you want to play back with automation.
Snapshots Automation and Trimming of Automation Data

Pro Tools lets you use trim values as snapshots and apply the relative changes (delta values) to the selected automation by using the Trim Automation command. This works in much the same way as the Write Automation command, except that it writes delta values instead of absolute values to automation data.

You can use trim values in writing snapshot automation to any automatable parameter.

To create a snapshot of relative changes in automation data:

1. In the Automation window, make sure that the automation parameters you want to edit are write-enabled. Deselect any parameters whose automation you want to preserve.

2. Select the area of the track you want to edit. All automated controls update to reflect the automation at the beginning of the selection.

3. Move the controls for the parameter up or down by the amount you want to change the data.

4. Choose Edit > Automation and do one of the following:

   • To write the current delta value to only the currently displayed automation parameter, choose Trim to Current.

   • To write the current delta value for all automation parameters enabled in the Automation window, choose Trim to All Enabled.

Previewing Automation

(Pro Tools | Ultimate Software Only)

Automation Preview mode lets you audition changes to a mix and compare them to existing automation values without committing them to the automation playlist.

When you put Pro Tools in Automation Preview mode, you can preview values for automation-enabled controls on any track that is in a writable automation mode.

While in Automation Preview mode, when you touch or move a control, it isolates the control, dis-engaging it from its automation playlist. The control stops reading or writing automation, allowing you to freely audition changes.

When you have found a level or state that you want to use, you can then commit or punch the previewed value to the automation playlist for the isolated controls.

- If you punch during playback, the automation mode is set to Latch and writing begins at the preview value.

- If you punch while the transport is stopped, the automation mode is set to Latch and the control is primed at the preview value.

💡 It is not necessary for the Allow Latch Prime in Stop preference to be enabled for Preview to put a control into Latch Prime.
Previewing New Automation Values

To preview a new automation value for a control:

1. Make sure the track where you want to preview the value is enabled for automation (Touch, Latch, Touch/Latch or their corresponding Trim modes).

2. Make sure the automation type you want to preview is enabled in the Automation window (Volume, Pan, Mute, Send level, Send pan, Send mute, or Plug-In).

3. Click the Preview button in the Automation window. The button lights green to indicate that Preview mode is active.

4. To isolate a control, touch or move an automation-enabled control. You can isolate controls during playback or while the transport is stopped.

The Automation Mode indicator on the track lights green to indicate that at least one of its controls is isolated, and the Punch Preview button in the Automation window lights to indicate a preview value is available to punch.

5. Start playback and adjust the isolated control to audition the changes.

Taking Controls Out of Isolated State

You can take controls out of their isolated state without leaving Preview mode.

To take all controls on a track out of their isolated state, do one of the following:

- Command-click (Mac) or Control-click (Windows) the automation mode selector on the track.
- Change the track automation mode to Read or Off.

To take all controls of an automation type out of their isolated state:

- In the Automation window, disable the automation type.

Isolating Multiple Controls

In some cases, such as when starting a new mix, you may want to isolate multiple controls at the same time.

To isolate all currently write-enabled controls:

- Option-click (Mac) or Alt-click (Windows) the Preview button.

To isolate all write-enabled controls on all selected tracks:

- Option-Shift-click (Mac) or Alt-Shift-click (Windows) the Preview button.
Suspending Preview Mode

You can temporarily suspend Preview mode, allowing you to toggle between preview values and existing automation.

To suspend Preview mode:

- Command-click (Mac) or Control-click (Windows) the Preview button.

Punching Preview Values

After you have isolated a control and auditioned a new value, you can punch (write) the value to the automation playlist.

To punch a preview value to the automation playlist:

- Click the lit Punch Preview button.

Preview Mode and “Write To” Commands

The Write Automation To commands work as follows with Preview mode:

Before Punching Preview Values The Write Automation To commands (except Write to Next Breakpoint) can be used to extend previewed values. The Write Automation To command will only apply to isolated controls. Pro Tools remains in Preview mode.

After Punching Preview Values The Write Automation To commands (except Write to Next Breakpoint) can be used to extend the punched value in the same manner as other automation.

Capturing Automation

(Pro Tools | Ultimate Software Only)

You can capture current automation values at one location in a session and quickly apply them in another location with the Capture and Punch Capture commands. The Capture command temporarily stores the value of all controls currently writing automation, and the Punch Capture commands writes those stored values to all enabled automation types.

- ICON Systems allow for the capture of up to 48 different values, or snapshots.
- All other systems allow for the capture of a single value.
Capturing Automation Values

You can capture the current automation values of actively writing controls.

To capture automation values:

1. Make sure all tracks whose automation values you want to capture are in a write-enabled state (Write, Touch, Latch, Touch/Latch or Latch).
2. Make sure the automation types you want to capture are enabled in the Automation window (Volume, Pan, Mute, Send level, Send pan, Send mute, or Plug-In).
3. Start playback. When you reach a location where you want to capture the current automation states, click the Capture button in the Automation window.

The Punch Capture button in the Automation window lights to indicate a captured value is available to punch.

Punching Captured Automation Values

After automation values are captured, they can be punched (written) to another location in the track. Any tracks set to Read or Off are unaffected.

- If you punch during playback, the automation mode of any track set to Touch is set to Latch and writing begins at the captured value.
- If you punch while the transport is stopped, the automation mode of any track set to Touch is set to Latch and the control is primed at the captured value.

To punch captured automation values:

1. Move to a location where you want to apply the captured automation states. You can do this during playback or while the transport is stopped.
2. Click the Punch Capture button in the Automation window to apply the captured automation states. The captured states are applied to all automation types that are currently enabled in the Automation window.

Capturing Automation Values for All Controls

You can capture the state of all automatable controls (except on tracks with their Automation Mode set to Off) in a session, regardless of whether they are currently writing automation.

To capture the automation values of all controls:

- When you reach a location where you want to capture the current automation states, Option-click (Mac) or Alt-click (Windows) the Capture button.

To capture the automation values of all controls on selected tracks only:

- When you reach a location where you want to capture the current automation states, Option-Shift-click (Mac) or Alt-Shift-click (Windows) the Capture button.
Punching Automation Values for All Controls

You can punch all captured automation values to another location on their corresponding tracks (except those tracks with their Automation Mode set to Off).

To punch the automation values of all controls:

- When you reach a location where you want to apply the captured automation states, Option-click (Mac) or Alt-click (Windows) the Punch Capture button. Any track set to Read or Touch are set to Latch. Any tracks set to Off are unaffected.

To punch the automation values of all controls on selected tracks only:

- When you reach a location where you want to apply the captured automation states, Option-Shift-click (Mac) or Alt-Shift-click (Windows) the Punch Capture button. Any selected tracks set to Read or Touch are set to Latch. Any selected tracks set to Off are unaffected.

Capture and Trim Mode

The Capture and Punch Capture commands work with Trim automation in the same way as regular automation. Pro Tools saves Trim status when capturing, so if you attempt to punch captured Trim values while displaying a non-Trim automation playlist, Pro Tools will automatically apply the values to the corresponding Trim playlist.

Punch Capture and “Write To” Commands

After issuing a Punch Capture command, the affected controls are writing automation (in Latch mode), so any of the Write Automation To commands can be used to extend the punched value in the same manner as other automation.

Capture and Preview Mode

Loading Captured Values into Preview

You can preview and modify captured automation values in Preview mode before punching the values to the automation playlist.

To capture an automation value and use it to preview:

1. Make sure the track where you want to preview the value is enabled for automation (Touch, Latch, Touch/Latch or their corresponding Trim modes).

2. Make sure the automation type you want to preview is enabled in the Automation window (Volume, Pan, Mute, Send level, Send pan, Send mute, or Plug-In).

3. Capture an automation value that you want to preview in another location on a track. (See “Capturing Automation Values” on page 1178.)

4. Go to a location where you want to preview the captured automation states, and click the Preview button in the Automation window.

5. Click the Punch Capture button.

The affected controls are isolated and updated to the captured values. The Punch Preview button in the Automation window lights to indicate the preview value is available to punch.
6 Start playback and adjust the isolated control to audition the changes.

7 When you are ready to punch the preview value to the automation playlist, click the lit Punch Preview button.

Capturing Values While in Preview Mode

When you are in Preview mode, you can capture the values of isolated controls and apply them elsewhere on a track. By capturing preview values, you can leave the underlying automation unchanged at the place where you capture.

On ICON systems, you can use preview mode to capture multiple snapshots without changing automation.

To capture a preview value:

1 Activate Preview mode and isolate a control. (See “Previewing New Automation Values” on page 1176).

2 Start playback and adjust the isolated control to audition the changes.

3 When you are ready to capture preview value, click the Capture button in the Automation window.

The Punch Capture button in the Automation window lights to indicate a captured value is available to punch.

VCA Master Track Automation

(Pro Tools | Ultimate Software Only)

You can automate changes to VCA Master track controls (as well as the controls for VCA slave tracks).

Displaying Automation on VCA Master Tracks

The following controls on VCA Master tracks can be automated and have separate automation playlists:

- Volume
- Volume trim (Pro Tools Ultimate only)
- Mute

These automation playlists follow the same behavior as automation playlists on other track types. For more information on Volume trim automation, see “Trimming Automation” on page 1162.

Displaying the Composite Automation Playlist on Slave Tracks

When a track is a VCA slave, you can display a composite automation playlist that shows the contribution of the VCA Master to the Volume or Mute automation data on the slave track. This composite playlist reflects the actual position of the Volume fader on the slave track. The composite playlist display cannot be directly edited.
To display the composite playlist on VCA slave tracks:

- Select View > Automation > Composite Playlist.

Excluding VCA Slave Tracks from VCA Master Automation

When you are writing automation on a VCA Master track, the corresponding moves will appear on the composite automation playlist of each of its slave tracks. If you want to exclude a slave track from an automation pass, write-enable the slave track for automation.

To exclude a slave track from VCA Master track automation pass:

1. Write-enable the VCA Master track for automation (Write, Touch or Latch mode).
2. Write-enable the slave track you want to exclude for automation (Write mode).
3. Make sure other slave tracks that you want to include in the pass are not write-enabled for automation.
4. Start playback.
5. Move the fader on the VCA Master track.
6. Stop playback.

Automation is written on the excluded slave track such that the fader moves on the VCA Master track are canceled out, and the fader on the excluded slave track does not move on subsequent playback.

Coalescing VCA Automation
(Pro Tools | Ultimate Software Only)

There are several ways to commit, or coalesce, the contribution of a selected VCA Master track’s Volume and Mute automation to the automation playlists of its slave tracks.

Clearing a VCA Master

You can use a VCA Master to write grouped automation, coalesce the VCA automation to all of the slave tracks, and clear the automation on the VCA Master. The coalesced tracks will play back exactly as they did when they were in the VCA group.
To coalesce automation from a VCA Master to all of its slave tracks and retain the VCA Master:

1. Select the VCA Master track whose automation you want to coalesce.
2. Do one of the following:
   • Choose Track > Coalesce VCA Master Automation.
   • Right-click the VCA Master track name and choose Coalesce VCA Master Automation.

The composite Volume level and Mute state are coalesced to each of the slave tracks. The VCA Master Volume fader is reset to zero, the VCA Mute is set to unmuted, and any automation on the VCA Master is cleared.

Deleting a VCA Master

You can temporarily use a VCA Master to write grouped automation, then coalesce the VCA automation to all of the slave tracks by deleting the VCA Master. The coalesced tracks will play back exactly as they did when they were in the VCA group.

To coalesce automation from a VCA Master to all of its slave tracks and delete the VCA Master track:

1. Select the VCA Master track whose automation you want to coalesce.
2. Choose Track > Delete.

The composite Volume level and Mute state are committed to each of the slave tracks.

Removing a Slave Track from a VCA Group

You can remove an individual slave track from a VCA group, which commits the VCA automation to that track, leaving the VCA Master and the other slave tracks untouched. The coalesced slave track plays back exactly as it did when it was in the VCA group.

To coalesce automation from a VCA Master to an individual slave track:

1. Do one of the following:
   • Choose Modify Groups from the Groups List menu.
   • Click the Group ID indicator on the track and choose Modify.
   • Right-click the Group name in the Groups List and choose Modify.
2. In the Groups dialog, select the VCA-controlled group that includes the slave track.
3. In the Groups dialog, click Tracks and remove the slave track from the group.
4. Click OK.

The slave track is removed from the VCA group, and the composite Volume level and Mute state are coalesced to the track.

⚠️ This action cannot be undone.
Duplicating a Slave Track

When you duplicate a slave track without duplicating its group assignments, the VCA automation is coalesced to the duplicate track. The coalesced duplicate plays back exactly as if it were in the VCA group.

To coalesce automation from a VCA Master to a single slave track by duplicating the track:

1. Select the slave track whose automation you want to coalesce.
2. Choose Track > Duplicate.
3. In the Duplicate Track dialog, deselect Group Assignments.
4. Click OK.

The composite Volume level and Mute state are coalesced to the duplicate track. The original slave track is preserved, and the VCA group is unchanged.

Coalescing Automation Across an Edit Selection

You can commit VCA automation across an Edit selection in a VCA Master track, without committing the automation on the entire length of the track.

To coalesce automation in an Edit selection on a VCA Master track:

1. Select the VCA Master track whose automation you want to coalesce.
2. Make an Edit selection in the VCA Master track that includes the range of automation you want to coalesce.
3. Do one of the following:
   - Hold Control (Mac) or Start (Windows) and choose Track > Coalesce VCA Master Automation.
   - Hold Control (Mac) or Start (Windows) and Right-click the VCA Master track name and choose Coalesce VCA Master Automation.

The composite Volume level and Mute state are committed to each of the slave tracks over the Edit selection. The VCA Master Volume is set to zero, the VCA Mute state is set to unmuted, and any automation on the VCA Master is cleared for the selected area only.
Chapter 51: Mixdown

Pro Tools lets you mix down by recording a mix to new audio tracks or by bouncing a mix to disk.

**Recording to Tracks** This is the process of sub-mixing and recording the submix to new audio tracks, as you would any other track input signals. This method requires available tracks, voices, and bus paths to accommodate the submix and the new tracks. While recording to tracks, you can manually adjust mixer or other controls.

Record to new tracks if you want to adjust mixer controls during the mixdown.

**Bouncing to Disk** The Bounce to Disk command lets you write a final mix, create a new loop, print effects, or consolidate any submix to new audio files on disk. This method lets you write all available voices to disk without holding any in reserve.

Any available output or bus path can be selected as the bounce source. Sample rate, bit depth, and other conversion processes can be applied during or after the bounce. Though you can hear the bounce being created in real time, you cannot adjust mixer or other controls while bouncing to disk.

Use Bounce to Disk if you need to convert the bounced files, or if you do not want to manually adjust mixer controls during the mixdown.

---

**Selecting Audio for Loops, Submixes, and Effects**

Both Bounce to Disk and recording to tracks operate on the current Timeline or Edit selection, if one exists. This makes it easy to turn multitrack selections into mono, stereo, or multichannel loops. Submixes, stems, and other specialized types of mixes can also be recorded (or “printed”) to disk using either method, or played out to another recording, transfer, or archiving medium.

Printing effects to disk is the technique of permanently adding real-time effects, such as EQ or reverb, to an audio track by bussing and recording it to new tracks with the effects added. The original audio is preserved, so you can return to the source track at any time. This can be useful when you have a limited number of tracks or effects devices.

AudioSuite plug-ins provide another option for writing (or “printing”) a plug-in effect to disk. For more information, see Chapter 42, “AudioSuite Processing.”
Using Dither

Dither can significantly improve audio quality when reducing the bit depth of digital audio.

When to Use a Dither Plug-In

You should use a dither plug-in in any situation where you are reducing bit depth, for example, when mixing down to a 16-bit file with the Bounce to Disk command, or when sending your final mix to an external digital device that records at 16-bit resolution.

A dither plug-in is necessary even when mixing down to 16-bit from a 16-bit session. Even though 16-bit sessions use 16-bit files, they are still processed at higher internal bit depths. Pro Tools systems use 24-bit audio input and output signal paths, and internal 64-bit floating point processing for mixing and audio processing.

For this reason, whether you are working with a 32-bit floating-point session, or a 24-bit session or a 16-bit fixed-point session, the following are recommended:

• When mixing down to a 16-bit destination, use a dither plug-in on the main output.
• When bus recording a submix to a track in the same session, do not use a dither plug-in on the destination track.
• When mixing down to a 24-bit destination, do not use a dither plug-in on the main output.
• When mixing down to an analog destination with any 24-bit capable interface, do not use a dither plug-in on the main output.
• During normal recording and playback, bypass any dither plug-in on the main output.

Bounce to Disk and Dither

Bouncing to disk does not apply dither when reducing bit depth. To apply dither when bounce to disk, you should insert a dither plug-in as the last processor in the signal path on a Master Fader assigned to the bounce source audio output path.

Using a dither plug-in on a Master Fader is preferable to an Auxiliary Input because Master Fader inserts are post-fader. As a post-fader insert, the dither plug-in can process changes in Master Fader level.

If you do not use a dither plug-in on your bounce source path, and you choose to convert to a lower resolution during or after bouncing to disk, the resulting file will be converted by truncation.

Using Dither on an Output Mix

Pro Tools includes real-time dither plug-ins that improve 16-, 18-, or 20-bit performance and reduce quantization artifacts when reducing the bit depth of an output mix.

To use a dither plug-in on an output mix:

1 Choose Track > New and create a (stereo) Master Fader track.
2 Set the output of the Master Fader to the output or bus path you want to bounce.
3 Assign the outputs of all audio tracks in the session to the same path you selected in step 2. The Master Fader now controls the output levels of all tracks routed to it.
4 On the Master Fader, insert a dither plug-in as the last processor in the signal chain.
5 In the dither plug-in window, choose an output Bit Resolution and Noise Shaping setting.

6 Do one of the following:
- Play back the session to record (or “layback”) Pro Tools output to lower bit-rate media (such as 16- or 20-bit Blue-ray).
- Choose File > Bounce To > Disk. In the Bounce to Disk dialog, select the appropriate bit depth (such as 16-bit for CD audio). Before being converted by the Bounce to Disk command, the signal is processed according to the resolution and noise shaping settings in the dither plug-in inserted on the Master Fader.

For information about dither plug-ins, see the Audio Plug-Ins Guide.

Sample Rate Conversion and Bit Depth Reduction

If you want to do both a sample rate conversion and a bit depth reduction when mixing down, first convert the sample rate while maintaining the higher bit depth, and then reduce the sample rate-converted file to the lower bit depth, using a dither. By keeping the higher bit depth when performing the sample rate conversion, you ensure the highest possible audio quality.

Bus Recording to Tracks

You can create a submix in your Pro Tools session and bus record it to available tracks in the same session. This technique lets you add live input to the mix, as well as adjust volume, pan, mute, and other controls during the recording process. You can also use this technique instead of Bounce to Disk to create mixed tracks directly in your Pro Tools session.

Voice Requirements for Recording a Submix

Recording a submix to new tracks requires an available voice for each track that you want to record. Make sure you have enough voices available to play back all tracks that you want to record and enough voices available to record the destination tracks.

In contrast, the Bounce to Disk command lets you bounce all available voices to disk without holding any in reserve, but you cannot manually change any controls during the bounce. For more information, see “Bounce to Disk” on page 1188.

For information about voice management, see “Track Priority and Voice Assignment” on page 252.

With HDX systems, Native plug-ins placed on Auxiliary Input, Master Fader, and Instrument tracks may use additional voices and may introduce extra latency based on the H/W Buffer Size. For more information, see “Inserting Native and DSP Plug-Ins on Tracks” on page 1098.
To record a submix to a track:

1. Apply any plug-ins or external processors you want to add to your audio tracks or Auxiliary Inputs before you record.

2. Set the main channel output of the tracks you want to include in the submix to a bus path. If you are using stereo or multichannel tracks, set the panning of each track.

3. Make sure Loop Record is not enabled.

4. Choose Track > New and create one or more mono, stereo, or multichannel audio tracks.

5. If you are recording in stereo, pan the new stereo track (or mono tracks) hard left and right.

6. Set the input of each destination track to the bus path from which you are recording.

7. Set the output of your new tracks to your main output path.

8. Ensure that Options > Link Timeline and Edit Selection is selected.

9. Select audio to record. The start, end, and length of the recording can be based on the cursor location or Timeline and Edit selections.

- Selection-based recording automatically punches in and out of recording at the selection start and end. Be sure to include time at the end of a selection for reverb tails, delays, and other effects.

- If you do not make a selection, recording will begin from the location of the playback cursor. Recording will continue until you press Stop.

10. Record enable the new tracks and click Record in the Transport.

11. Click Play to begin recording the submix.

12. If recording a selection, recording will stop automatically. If performing an open-ended recording, click Stop, or punch out of recording.

13. When the recording has finished, you can export the bus recorded clip using the Export Clips as Files command (see “Exporting a Clip as a New Audio File” on page 410).

---

Bounce to Disk

The Bounce to Disk command lets you mix down any or all of the available voices on your system. Bouncing records to separate audio files, so you do not have to reserve any tracks for a bounce. A bounce can be done offline (faster than real-time) or in real-time (so you can listen to audio playback of your mix during the bounce process).

You can use the Bounce to Disk command to export loops, sub-mixes, stems or any other session audio. You can use it to create a final mono, stereo, or multichannel master files in any of several audio file formats. Bounce to Disk also provides conversion options for sample rate, bit resolution, and format. It will even let you automatically import bounced files after the bounce is complete.

To Bounce to Disk (basic instructions):

1. Make a Timeline selection to define the range to be bounced.

2. Choose File > Bounce to > Disk.

3. Configure the Bounce options (see “Configure the Bounce Options” on page 1190).

4. Click Bounce.
When you bounce to disk, the resulting file includes the following:

**Audible Tracks** All audible tracks that are routed to the output which is selected as the source of the bounce are included in the bounce. Any muted tracks are not included in the bounce. If you solo one or more tracks, only the soloed tracks are included in the bounced mix.

**Automation** All read-enabled automation is played back and incorporated in the bounced mix.

**Inserts and Sends** All active inserts, including real-time plug-ins and hardware inserts, are applied to the bounced mix.

**Selection or Track Length** If you make a selection in a track, the bounced mix will be the length of the selection. If there is no selection in any track, the bounce will be the length of the longest audible track in the session.

**Time Stamp Information** Bounced material is automatically time stamped so that you can drag it into a track and place it at the same location as the original material. For more information about time stamping, see “Time Stamping” on page 1290.

**Bounced Files Are Delay-Compensated**

Pro Tools compensates for any bus and plug-in delays when bouncing to disk. This means that if a bounced file is imported back into a session, and placed directly in time against the source mix, it is time-aligned with the original source mix.

**Record-Enabled Tracks and Track Input-Enabled Tracks Cannot Be Bounced**

Pro Tools does not include tracks that are either record-enabled or in Input Only monitoring mode in the bounce.

### Bounce From Sends or Track Outputs

Pro Tools lets you open the Bounce dialog pre-configured to use the channel path of any given send or track output using Right-click menus.

1. Right-click the Output Path selector or the Send Path selector for the desired track Output or Send.
2. From the right-click menu, choose Bounce <path>.
3. The Bounce dialog opens with the Output or Send path selected as the Bounce Source.
4. Configure the other Bounce settings as desired and click Bounce.
**Bounce Options**

When you use the Bounce to Disk command, you can configure several file options.

**Bounce Source**

All currently active output paths (both internal mix busses and output busses) and physical outputs as defined in the I/O Setup dialog are available as the Bounce Source.

**To set the bounce source:**

- Select a bus path, output path, or physical output from the Bounce Source selector.

**File Type**

- WAV

**Format**

- Multiple mono

**Bit Depth**

- 24 Bit

**Sample Rate**

- 48 kHz

**On Mac**, press **Command+Shift+“+” (plus)** or **Command+Shift+Down arrow** or **Command+Shift+N** to add a new Bounce Source row. **On Windows**, press **Control+Shift+“+” (plus)** or **Control+Shift+Down arrow** or **Control+Shift+N** to add a new Bounce Source row.
5 Repeat steps 3 and 4 as desired (up to 16 simultaneous bounce sources).

6 If necessary, click the “–” button to the right of any bounce source (except the first) to remove it from the bounce.

**On Mac, press Command+Shift + “–” (minus) or Command+Shift+Up arrow to remove the bottom Bounce Source row. On Windows, press Control+Shift + “–” (minus) or Control+Shift+Up arrow to remove the bottom Bounce Source row.**

7 Configure all other Bounce options as desired.

8 Click Bounce.

After clicking Bounce, a progress dialog appears that displays the time and rate of the Bounce.

**File Type**

The File Type selector lets you select the file type for bounced files.

**WAV (Broadcast .WAV Format)**

This format is supported on Windows and Mac. To use a WAV file in Pro Tools, you can drag and drop from a Workspace browser, Windows Explorer or Mac Finder, or a folder, or you can use the Import Audio command. Files in this format do not have to be converted to be used in Pro Tools.

**AIFF (Audio Interchange File Format)**

This format is supported on Windows and Mac. To use an AIFF file in Pro Tools, you can drag and drop from a Workspace browser, Windows Explorer or Mac Finder, or you can use the Import Audio command. Files in this format do not have to be converted to be used in Pro Tools.

**MP3 (MPEG-1 Layer 3)**

The MPEG-1 Layer 3 (MP3) compression format is used for streaming and downloading audio over the Internet, and for playback on portable devices.

**MP3 Export Options**

When you select this format, the Resolution pop-up menu in the Pro Tools Output Options dialog is unavailable. The resolution is set by the encoder.

The sample rate chosen is given to the codec as a base sample rate for operations. The actual sample rate of the resulting file is determined in the MP3 Encoder Options dialog. For example, if a base sample rate of 48000 Hz is chosen, the MP3 Encoder Options dialog will allow output streams in 48, 24, or 12 kHz, depending on encoding quality.

When you export or bounce to MP3 format, you can set the following options:

**Encoder Settings**

**Encoder Speed** Determines the audio quality of the bounced file. There are two options: Highest Quality and Fastest Encoding Time.

The Highest Quality option can take up to five times longer to process audio than the Fastest Encoding option, so you should use it only when the highest fidelity is essential and you have the time to devote to the encoding process.
**Constant Bit Rate (CBR)** Encodes the file at a single bit rate that you choose from the Constant Bit Rate (CBR) pop-up menu. Because the bit rate is fixed, the quality of the encoded audio will vary depending on the nature of the material being compressed. The 128 kbit/s option is generally best for streaming over the Internet, since it has predictable bandwidth requirements.

**ID3 Tag Info Settings**

**ID3 Tag Type** The ID3 tag stores data about the encoded audio file that is used by MP3 players to display information about the file. Pro Tools supports three versions of this tag, in order to provide backward compatibility with older MP3 players:

- ID3 v1.0: Appears at the end of a streaming MP3 file, so that tag information is only displayed after software streaming is finished.
- ID3 v1.1: Same as version 1.0, but adds track number information to the tag.
- ID3 v2.3: Appears at the front of a streaming MP3 file, so that tag information is displayed when streaming begins.

⚠️ **While ID3 v2.3 is the current standard MP3 format, not all MP3 players support ID3 v2.3. Contact the player software developer for compatibility information.**

**Title/Artist/Album/Comment** Type the title, artist, and other information for the MP3 file. This information is displayed by many MP3 players.

**Genre** Choose a genre for the file. This information is displayed by many MP3 players, and can appear in searchable catalogs and databases.

**Track Number** If you select ID3 tag type v1.1 or v2.3, you can enter a CD track number for the file. This information is displayed by many MP3 players.

**Year** Enter a year for the file. This information is displayed by many MP3 players.

**Default Button**

To restore all settings in this dialog to their default values, click Defaults.

**QuickTime**

QuickTime is Apple’s multimedia audio file format. Pro Tools does not directly support this type of file in its sessions. To use a QuickTime audio file within Pro Tools, use the Import Audio command. The QuickTime format is popular for attaching to emails, to simplify long-distance project review and approval. Many popular multimedia applications also support QuickTime.

**Windows Media** (Windows Only)

Windows Media formatted files can contain audio, video, or script data stored in Windows Media Format. A Windows Media Format file may have an .asf, or .wmv file name extension.

**MXF (Material Exchange Format)**

MXF is a media file format that includes both video and audio files, and is designed for the interchange of audio-visual material with associated data and metadata. It was designed for improving file-based interoperability between servers, workstations, and other content creation devices.

AAF and OMF sequence format files can refer to MXF media files, or have MXF media files embedded within them. Pro Tools supports AAF embedded sequences.

**Bouncing to MP3 and Another File Type Simultaneously**

The new Add MP3 option in the Bounce to Disk dialog lets you simultaneously create an MP3 version of each bounce source in addition to the selected File Type (such as WAV).
When the Add MP3 option is selected, and you are adding the bounce to your iTunes Library, the selected File Type is used rather than the MP3. To share an MP3, select MP3 as the File Type.

The Add MP3 option is not available for QuickTime bounce.

To bounce multiple sources to disk:
1. Make a Timeline selection to define the range to be bounced.
2. Choose File > Bounce to > Disk.
3. Select the desired File Type.
4. Select the Add MP3 option (mono or stereo bounce sources only).
5. Configure all other Bounce options as desired.
6. Click Bounce.
7. Configure the resulting MP3 dialog as desired and click OK.

Format

This is the format for the bounced result. Options include Mono (Summed), Multiple Mono, and Interleaved.

To set the format of the bounced file:
- Select a file format from the Format selector.

Mono (Summed) Creates a single disk file that is a summed mono mix of the current sources being monitored.

Before bouncing to disk, make sure your levels are below –3 dB to avoid clipping that occurs when left and right signals exceed –3 dB below maximum, or full code (0 dBFS).

Multiple Mono Creates multiple mono files with the same number of channels as the source path.

- If the source output or bus path is stereo, two mono files will be created, and appended with “.L” and “.R” suffixes on bounce.
- If a multichannel format is used (for example, six-channel, 5.1), individual mono files will be created for each member of the path. Files will be appended with path suffixes according to the path definition in the I/O Setup dialog.
- If the source output or bus path is mono, the pop-up menu will switch from multiple mono to mono, and will create one mono file (no summing of multiple sources).

Interleaved Creates a single, interleaved file that contains all of the bounced streams from the chosen output path. In an interleaved stereo bounce, tracks assigned to odd-numbered outputs are sent to the left channel, and tracks assigned to even-numbered outputs are sent to the right channel.

Pro Tools also lets you bounce multichannel interleaved files of any supported multichannel file type (such as 5.1). This can simplify file management of mixes and projects for backup and archiving.

Bit Depth

This setting lets you select between four different bit depths for the bounce conversion. Note that Bounce to Disk does not apply dither when converting during or after a bounce to a lower resolution. If you need to bounce to a lower resolution file, use a dither plug-in on a Master Fader track assigned to the bounce source path. This dithers the bounced file, before the Bounce to Disk conversion truncates the bounced file to the selected bit depth resolution. (See “Using Dither” on page 1186.)
The following Bit Depth options are available:

16-Bit This is the Compact Disc standard bit resolution.

💡 If your session is 16-bit, you should still use a dither plug-in on the output mix, because all Pro Tools systems process audio internally at higher bit depths.

24-Bit This setting provides the highest resolution that is compatible with most audio interfaces. It is useful when you want to create a final mix without losing any resolution (for example, if you are delivering a final mix that will be ready to master).

32-Bit Float This setting provides the highest resolution for internal Pro Tools mixing and plug-in processing. It is useful when you want to export and re-import loops and sound effects into your Pro Tools session, or when you are exchanging files between Pro Tools sessions.

To set the resolution of the bounced file:

- Select a bit depth from the Bit Depth selector.

Sample Rate

This option lets you save to any of several sample rates. Choices are dependent on your Pro Tools system and audio interfaces. Options can include sample rates from 8 kHz to 192 kHz, including sample rates with Pull Up and Pull Down options.

Common Sample Rates

The following are the more common sample rates, and their applications. Higher sample rates provide better audio fidelity for recording and playback, and also for processing with dynamics, dither (with noise shaping), and analog emulation plug-ins.

192 kHz This is a supported sample rate for some audio DVDs, and provides the highest quality audio fidelity with compatible audio interfaces (such as the HD I/O).

176.4 kHz You may want to work at a sample rate of 176.4 kHz if the final delivery will be at 44.1 kHz (such as compact disc). This will provide a slightly faster sample rate conversion to 44.1 kHz than from 192 kHz.

96 kHz This is a supported sample rate for DVD audio and provides high-quality audio fidelity with compatible audio interfaces (such as the HD I/O and 003).

88.2 kHz You may want to work at a sample rate of 88.2 kHz if the final delivery will be at 44.1 kHz (such as compact disc). This will provide a slightly faster sample rate conversion to 44.1 kHz than from 96 kHz.

48 kHz This is a standard sample rate for Professional and DVD video, as well as some broadcast and recording label archiving, and is supported by DA-88/98, DAT, and ADAT decks.

44.1 kHz This is the standard sample rate for compact discs (CD), and is supported by DA-88/98, DAT, and ADAT decks.

Additional sample rate options include 8 kHz, 11.025 kHz, 16 kHz, 22.050 kHz, and 32 kHz.

Custom For a custom sample rate, click in the sample rate window and manually enter in a value from 4,000 to 200,200 samples.

Pull Up and Pull Down Rates All available sample rates support pull up and pull down rates, or other specialized rates.
Enforce Avid Compatibility

Enable this option in the Bounce to Disk dialog to create a bounced file with frame-accurate edits, wrapped as OMFI (unless File Type is MXF), and with the sample rate options limited to 44.1 kHz or 48 kHz. Dither without noise shaping will be applied to files being exported from 24-bit to 16-bit.

Add to iTunes Library

Pro Tools lets you bounce your mix to your iTunes library using the Add to iTunes Library option in the Bounce to Disk dialog. When this option is selected, the bounced file is copied to your local iTunes library. You can specify the location of your iTunes library using the new iTunes Library Folder setting in the Pro Tools Operation preferences.

If the Add to iTunes Library option is enabled when bouncing to disk, the resultant audio file is automatically imported into iTunes the next time you launch the iTunes application. If iTunes is not installed on your computer, this option does not do anything.

To export your mix to your iTunes library:

1. Choose File > Bounce to > Disk.
2. In the Bounce to Disk dialog, select the Bounce Source and set the other options.
3. Enable the Add to iTunes Library option.
4. Click Bounce.

Import After Bounce

The Import After Bounce option automatically imports the newly bounced files into the Clips List so you can place them in tracks. If your newly bounced files are split stereo files (Multiple Mono), they are listed together in the Clips List.

⚠️ The Import After Bounce option is only available if the target file type and sample rate for the bounce is the same as the file type and sample rate of the current session, and the target resolution (bit rate) is the same or lower than the resolution of the session. In addition, tracks bounced to a Stereo Interleaved file cannot be automatically imported after a bounce.

Bounce File Name

Pro Tools provides a File Name text entry field for Bounce to Disk. In the Bounce dialog, type the File Name you want for the bounced file. For multi-source bounces, the entered file name is appended with the name of the Bounce Source and a number (incremented for each source): “<file name>_<source name>_<n>.”

Directory

Click the Choose button to specify a different directory for bounced files than the default location.

Offline Bounce

Pro Tools provides an Offline option for Bounce to Disk and Bounce to QuickTime. This lets you bounce faster-than-real-time in most cases (depending on the session mixer size and DSP plug-in complement).
To bounce audio to disk offline:
1. Make a Timeline selection to define the range to be bounced.
2. Choose File > Bounce to > Disk.
3. In the Bounce dialog, enable the Offline option.
4. Configure the Bounce options as desired.
5. Click Bounce.

Limitations of Offline Bounce

When using the Offline Bounce option, the following are not included in the bounce:
• Hardware Inserts
• External MIDI driven audio (such as outboard MIDI synthesizers or samplers).
• External audio sources monitored by Auxiliary Input tracks.
• DSP only plug-ins (Offline Bounce always uses the Native version of DSP plug-ins, but only if they are available).
• Any audio source that is synchronized externally.

With Pro Tools Ultimate, any HEAT processing in the bounce path is included with offline bounce.

Speed of Offline Bounce

The speed of offline bounce can be affected by the following:
• CPU Usage—The speed of your CPU and how much CPU is in use by the system and other applications. You can monitor CPU usage in the System Usage window.
• Disk Usage—For example, if the Disk meter in the System Usage window reads 50% when you are playing back the session, offline bounce will max out at two times the speed of real-time simply because it is physically impossible to read the disk data from the drive fast enough. If you can increase the Disk Playback Cache Size (Setup > Playback Engine) to cache all audio on the timeline, this should not be an issue (Pro Tools Ultimate only).
• If there is an unbalanced use of your computer’s core processors due to large mixers and Native plug-in usage, you can check to see if the individual core CPU meters are unbalanced in the CPU section of the System Usage window. Removing or making Native plug-ins inactive on Auxiliary Input and Master Fader tracks may help alleviate this problem.
• Some third-party plug-ins may slow down offline bounce due to their CPU requirements.

⚠ Note that for some sessions that use very large mixer configurations with lots of DSP-based plug-ins and automation, it is possible that Offline Bounce may actually be slower than bouncing in real time.

Cancel

The Cancel button closes the Bounce to Disk dialog without initiating the bounce to disk conversion.

Bounce

The Bounce button initiates the bounce to disk conversion. A Save dialog opens in which you can navigate to and select where you want to save the bounced file. Once you have selected the location and clicked Save, a progress window opens and progressively shows you how much time remains for the bounce to complete.
Recording a Submix (with Bounce to Disk)

You can create a submix with the Bounce to Disk command by muting tracks or bypassing inserts that are not part of the submix, and selecting the part of the session you want to bounce; or, you could solo only the audio you want to bounce.

You can also create a submix by recording to new tracks. For details, see “Sample Rate Conversion and Bit Depth Reduction” on page 1187.

To bounce a submix to disk:

1. Configure your submix using sends, Auxiliary Inputs, and Master Faders. (See “Signal Routing for Monitoring and Submixing” on page 1074.)

2. Do one of the following:
   • To bounce the entire session, click Return to Zero in the Transport window to go to the beginning of the session.
   • To bounce a portion of the session, enable Options > Link Timeline and Edit Selection, and make a selection in the Edit window.

3. Choose File > Bounce to > Disk.

4. Configure bounce options and settings.

5. Verify the bit resolution for the bounced file matches the bit resolution of the session.

6. Verify the sample rate for the bounced file is supported by the session and the audio interface.

7. If required, verify the file type and format for the bounced file matches the file type and format of the session.

8. Click Bounce.

To bring bounced files back into tracks, do one of the following:

- Enable the Import after Bounce option prior to bouncing to disk. Once bounced files are imported to the Clips List, you can drag and drop them to tracks.

- Import the bounced file(s) into the session using the Import Audio command (File > Import > Audio).

- Drag and drop the bounced files from a Workspace browser or the desktop.

Final Mixdown (with Bounce to Disk)

In final mixdown, you create a mix that includes all your edits, automation, and effects processing.

To bounce a final mix to disk:

1. Adjust track output levels, and finalize any mix automation for each track in the session.

2. Adjust any real-time plug-in and effects settings and automation for each track in the session.

3. Make sure that all of the tracks you want to include in the bounce are audible (not muted or inactive).

4. Assign the output of each of the tracks you want to include in your bounce to the same output or bus path.

5. Add dither (see “Using Dither” on page 1186).
Do one of the following:

- To bounce the entire session, click Return to Zero in the Transport to go to the beginning of the session.

  *By default, the bounce will end at the last audio waveform or MIDI note. To end the bounce sooner, make an Edit or Timeline selection to define the end (and start) of the bounce.*

- To bounce a portion of the session, enable Options > Link Timeline and Edit Selection, and make a selection in the Edit window.

Choose File > Bounce to > Disk.

Choose the source path you want to bounce.

Configure other Bounce to Disk settings as appropriate. See “Bounce Options” on page 1190.

Click Bounce.

---

**Mastering**

In the final mastering process, you might record directly to disk, Blue-ray, DAT, DVD, CD, stereo mastering recorder, or a multitrack recorder (for surround mixes).

Once you have created a master of your session, you can transfer it to a portable medium for duplication. You can transfer the master file to CD or DAT to be used as a master for pressing compact discs.

**Mastering to a Digital Recorder**

Although it is usually best to master sessions directly to hard disk, Pro Tools also lets you master digitally, direct to any AES/EBU-equipped or S/PDIF-equipped digital recorder such as a DAT deck.

**Mastering and Audio Compression**

Although audio compression is often an indispensable tool in analog recording, it can present problems in the digital domain. If you compress an input signal at a very high ratio, you create a signal that contains a much higher overall power level compared to its transients. By recording a number of such signals at the highest possible level on multiple tracks, you create a scenario that is more likely to clip the mixed output signal.

High-power compressed signals, when mixed together, create an extremely high-level output. This output may rise above the full-code level, resulting in clipping.

To avoid this problem, watch the overall level of your program material—use a meter on a Master Fader, or use an external mastering deck’s meters to help identify clipping. If you are mastering to hard disk, avoid mixing full-code audio signals together at unity or “0” level, as this invariably causes clipping.

**Mastering and Error-Correcting Media**

Random access media (such as hard disks, or USB or flash drives) can produce a true digital copy of your data, because every bit value is maintained. Sequential media (such as digital tape) use error correction schemes to fix the occasional bad data that is received in a digital transfer. These corrections are deviations from the actual data, and with successive reproductions, represent a subtle form of generation loss.

You can avoid this loss by creating and maintaining masters on random-access digital media (such as a hard drive) and transferring them to sequential digital media only as needed.
Part X: Surround
Chapter 52: Pro Tools Setup for Surround

Pro Tools | Ultimate Software lets you work with surround formats up to 7.1, and up to 7.1.2 with Dolby Atmos.

**Surround Mixing in Pro Tools**  
*(Pro Tools | Ultimate Software Only)*

Pro Tools supports mixing in the following multi-channel (greater than stereo) formats: LCR, Quad, LCRS, 5.0, 5.1, 6.0, 6.1, 7.0, 7.0 SDDS (Sony Dynamic Digital Sound), 7.1, and 7.1 SDDS. With Dolby Atmos, Pro Tools also supports 7.0.2 and 7.1.2 formats.

For information on fundamental surround concepts, see the Pro Tools Sync & Surround Concepts Guide.

**Pro Tools Audio Connections for 5.1 Mixing**

While all 5.1 mixing formats provide the same speaker arrangement, there are three primary standards in use for the track layout of the individual channels that comprise the 5.1-format multichannel mix.

In the following table, it is assumed that surround channels are assigned to outputs 1–6 of a Pro Tools audio interface. Use channels 7–8 to monitor a stereo mix for a stereo version, or for cue mixes and monitoring.

**Track Layouts for 5.1 Formats**

<table>
<thead>
<tr>
<th>Formats</th>
<th>Track Layout</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>1</td>
</tr>
<tr>
<td><strong>Film</strong> (Pro Tools default)</td>
<td>L</td>
</tr>
<tr>
<td><strong>SMPTE/ITU for Dolby Digital (AC3)</strong></td>
<td>L</td>
</tr>
<tr>
<td><strong>DTS</strong></td>
<td>L</td>
</tr>
<tr>
<td>**C</td>
<td>24**</td>
</tr>
</tbody>
</table>

The following table shows the X-MON mono track routing for a 7.1 SDDS mix. A 5.1 mix should use the same routing, excluding outputs 2 and 4 (Lc and Rc).

**Default Track Layout for 7.1 SDDS Format**

<table>
<thead>
<tr>
<th>Formats</th>
<th>Track Layout</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>1</td>
</tr>
<tr>
<td><strong>X-MON</strong></td>
<td>L</td>
</tr>
</tbody>
</table>
To connect your audio interfaces for 5.1 format mixing and monitoring:

1. Determine the 5.1 format and track layout you want to use.

2. Connect the output channels of your audio interface to the corresponding input channels of your monitoring system according to the assignments listed in the tables above.

If you use a control surface, see its guide for more information.

---

### 7.1 and 7.0 Formats

#### 7.1 and 7.0 Format

HD-DVD and Blu-Ray systems use the following track layout for 7.1 and 7.0 surround formats:

- **3 front channels** Left (L), Center (C), Right (R)
- **2 side channels** Left Surround Side (Lss) and Right Surround Side (Rss)
- **2 rear channels** Left Surround Rear (Lsr) and Right Surround Rear (Rsr)
- **1 LFE channel (7.1 only)** Low Frequency Effects

The following table shows the default mono track routing for a 7.1 mix in Pro Tools.

**Default Track Layout for 7.1 Format**

<table>
<thead>
<tr>
<th>Track Layout</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 2 3 4 5 6 7 8</td>
</tr>
<tr>
<td>L Lc C Rc R Ls Rs LFE</td>
</tr>
</tbody>
</table>

#### 7.1 and 7.0 SDDS Formats

The Sony Dynamic Digital Sound (SDDS) 7.1 and 7.0 surround formats use the following track layout:

- **5 front channels** Left (L), Left Center (Lc), Center (C), Right Center (Rc), Right (R)
- **2 rear channels** Left Surround Rear (Ls) and Right Surround Rear (Rs)
- **1 LFE channel (7.1.2 only)** Low Frequency Effects

The following table shows default mono track routing for a 7.1 SDDS mix in Pro Tools.

**Default Track Layout for 7.1 SDDS Format**

<table>
<thead>
<tr>
<th>Track Layout</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 2 3 4 5 6 7 8</td>
</tr>
<tr>
<td>L Lc C Rc R Ls Rs LFE</td>
</tr>
</tbody>
</table>

#### 7.1.2 and 7.0.2 Formats (Dolby Atmos)

Pro Tools lets you create 7.0.2 and 7.1.2 surround format input, output, insert, and bus paths in the I/O Setup for mixing to Dolby Atmos. Pro Tools can likewise create tracks with 7.0.2 and 7.1.2 channel widths.

For more information, see Chapter 55, “Mixing to Dolby Atmos.”
7.0.2 and 7.1.2 Track Layouts

7.0.2 and 7.1.2 formats are nine- and ten-channel surround formats, respectively. The mono channels of these two surround formats always appear using the following track layouts (top to bottom in a track and left to right in meters): L C R Lss Rss Lsr Rsr LFE Lts Rts.

3 front channels Left (L), Center (C), Right (R)
2 side channels Left Surround Side (Lss) and Right Surround Side (Rss)
2 rear channels Left Surround Rear (Lsr) and Right Surround Rear (Rsr)
1 LFE channel (7.1.2 only) Low Frequency Effects
2 overhead channels Left Top Surround (Lts) and Right Top Surround (Rts)

7.0.2 and 7.1.2 Path Orders

Set the Default Path Order for new paths in the Output page of the I/O Setup. Changing the Path Order does not affect the track layout order or metering, but it does change the channel order of the output path to the assigned physical outputs on the audio interface.

7.0.2 L C R Lss Rss Lsr Rsr – Lts Rts (Film)
7.0.2 L R C – Lss Rss Lsr Rsr Lts Rts (SMPTE)
7.1.2 L C R Lss Rss Lsr Rsr LFE Lts Rts (Film)
7.1.2 L R C LFE Lss Rss Lsr Rsr Lts Rts (SMPTE)

Ambisonics Formats

Pro Tools lets you create 1st-, 2nd-, and 3rd-Order Ambisonics channel format (4-, 9-, and 16-channel formats respectively) input, output, insert, and bus paths in the I/O Setup for Ambisonics mixing workflows. Pro Tools can likewise create tracks with 1st-, 2nd-, and 3rd-Order Ambisonics channel widths.

For more information, see Chapter 56, “Ambisonics.”

Configuring Pro Tools for Multichannel Sessions

Configuring Pro Tools and sessions for multichannel mixing can be done in any (or all) of the following ways:

New Sessions

You can create a new session and choose a surround mix I/O Settings file as the default I/O Setup. See “New Sessions and I/O Settings” on page 1204.

Remixing Sessions in Surround (Importing Multichannel I/O Setups)

By creating or importing a surround mix I/O Settings file in the I/O Setup dialog, multichannel paths can be made available in any stereo (or other format) session. You can then reassign track routing from the original stereo paths to multichannel paths. Inactive and active paths simplify reassignment. See “Importing Multichannel I/O Setups” on page 1206.
Custom Multichannel Paths

You can customize and redefine existing paths in the I/O Setup dialog. For more information, see “Custom Multichannel Paths” on page 1206.

Importing Session Data

By using the Import Session Data command (File > Import > Session Data), you can import tracks and media from other sessions plus their associated paths and track assignments. After importing session data, you can use the I/O Setup dialog to configure main and sub-paths for the requirements of the session. For more information, see Chapter 6, “I/O Setup.”

New Sessions and I/O Settings

When you create a new session, you can specify a surround format that you want to use as your I/O Setup. Default path configurations are provided as I/O Settings files, for stereo and surround mixing.

To see multichannel options in Pro Tools, the Surround Mixer plug-in must be installed in the Plug-Ins folder. This plug-in can be installed with Pro Tools (see the User Guide for your Pro Tools system). If it is not installed, you can move it from the Plug-Ins (Unused) folder to the Plug-Ins folder.

Once you create the new session, you can create and import tracks, import audio, and assign signal routing to set up your mix.

To create a new session for multichannel mixing:

2. Select the Create Blank Session option.
3. Select the Audio File Type, Sample Rate, and Bit Depth.
4. From the I/O Settings menu, select one of the following options:
   • 5.1 Film Mix
   • SMPTE/ITU
   • DTS Monitoring
   • C24 Mix
   • ICON X-MON Mix
5. Click OK.
6. In the Save dialog, name the session, navigate to the location where you want to save the new session, and click Save.
The surround presets preconfigure the I/O Setup dialog for the new session with default 5.1 format main and sub-paths for outputs and busses.

**Surround Mix Settings Files**

The surround mix I/O Settings provide output and bus paths for six specific track layout standards in the new session. (For information on inputs and insert paths, see “Default Input and Insert Paths with 5.1 Settings” on page 1205.)

**Settings Files and Track Layouts**

<table>
<thead>
<tr>
<th>5.1 Settings</th>
<th>Track Layout</th>
</tr>
</thead>
<tbody>
<tr>
<td>5.1 Film Mix</td>
<td>L C R Ls Rs LFE</td>
</tr>
<tr>
<td>SMPTE/ITU Mix</td>
<td>L R C LFE Ls Rs</td>
</tr>
<tr>
<td>DTS Mix</td>
<td>L R Ls Rs C LFE</td>
</tr>
<tr>
<td>C24 Mix</td>
<td>L C R Ls Rs Lf</td>
</tr>
<tr>
<td>ICON X-MON Mix</td>
<td>L Lc C Rc R Ls Rs LFE</td>
</tr>
</tbody>
</table>

All available 5.1 format (and greater) I/O Settings (Film, SMPTE/ITU, DTS, C24 Mix, or ICON X-MON Mix) provide the following default output and bus paths for the new session:

**Default 5.1 Output Paths**
- One 5.1 main output path.
- One stereo main path.

**Default 5.1 Bus Paths**
- One 5.1 output bus path, with sub-paths for 5.0 (no LFE), left/right (stereo), LCR, and center (mono).
- One stereo main output bus path with two mono sub-paths.

The 5.1 Mix settings files provide default stereo main paths and mono sub-paths for inputs and inserts. If you need multichannel input paths or inserts, you can create them in the I/O Setup (see “Custom Multichannel Paths” on page 1206).
Importing Multichannel I/O Setups

The I/O Setup dialog can import and export settings files. This is useful when you want to remix a stereo session in surround. You can also use this feature to prepare a session for transfer to a different Pro Tools system, or to save and exchange I/O Settings.

To import a multichannel I/O Setup settings file:

1. Choose Setup > I/O.
2. Click the Output tab.
3. Click Import Settings.
4. Select the settings file (.pio) to import and click Open.
5. If the current session has path definitions that do not match those in the imported settings file, Pro Tools asks whether you want to delete the existing paths or retain them and add the imported settings to your session.
   - Click No to add new paths to your current I/O Setup configuration.
   - Click Yes to replace your current I/O Setup configuration with the imported settings.
6. Click the Bus tab.
7. If the Bus page does not show the correct output bus mappings for the imported I/O Settings file, click the Default button (for All Busses or for Output Busses).
8. Click OK to close the I/O Setup.

Exporting I/O Settings

Exporting I/O Setup settings files lets you build a library of multichannel setups for different projects.

To export an I/O Setup settings file:

1. Choose Setup > I/O.
2. Click Export Settings.
3. Name and Save your current I/O Settings.

Custom Multichannel Paths

The I/O Setup dialog lets you create and customize signal paths for any supported multichannel mixing format.

Multichannel paths and sub-paths are assigned to input and output channels in the Channel Grid. When you select a preset 5.1 I/O Settings file, default layout for the corresponding multichannel format paths you create will match the selected format’s track layout.

In addition, the I/O Setup dialog, like the Main page of the Hardware Setup dialog, provides controls for routing the physical inputs and outputs on your audio interface to available inputs and outputs in Pro Tools.

When creating 5.1 format paths, you can specify the default track layout. See “Path Order” on page 61.
Reassigning Channels

The I/O Setup dialog and its Channel Grid also let you reassign channels. This is especially useful for routing channels within a multichannel path, without having to repatch your audio interfaces.

You can reassign paths to any required configuration, limited only by your systems resources, and the I/O Setup dialog requirements for channel overlapping and naming (see “Valid Paths and Requirements” on page 75 for more information).

See also “Example Paths and Signal Routing for a Surround Mix” on page 1219.

Example LCRS Setup

The following example shows one possible way to configure the I/O Setup dialog to mix in 4-channel LCRS format, with an HD OMNI.

For additional I/O Setup information, see “Output Busses” on page 76.

To define an LCRS path:
1 Choose Setup > I/O, and click the Output tab.
2 Click New Path.
3 Select LCRS from the Path Format selector.
4 Name the path LCRS.
5 In the Channel Grid, click in the box below the first (left-most) audio interface channel for the path. Pro Tools automatically fills up the adjacent units to the right. If you click in the LCRS row under channel 1, the LCRS path will be assigned to channels 1–4.

6 Click the Bus tab.
7 If the Bus page does not show the correct output bus mappings for the LCRS output, click the Default button (for all Busses or for Output Busses).
8 Select the new LCRS path and click the Reveal Sub-paths triangle.
9 If not all of the sub-paths are present, do the following:
   • Click New Sub-Path.
   • Name the new sub-path LCR and select LCR as the Path format. Click in channel 1 in the LCR row to assign the bus path.
   • Select the LCRS path, click New Sub-Path, and create a stereo sub-path for front Left and front Right.
   • Select the LCRS path, click New Sub-Path, and create a mono sub-path for the Center channel.
   • Select the LCRS path, click New Sub-Path, and create a mono sub-path for the Surround channel.
10 Click OK to close the I/O Setup.
5.1 Tracks, Formats, Assignments, and Metering

Path definitions in I/O Setup determine how audio is routed through, and metered on, your audio interfaces.

Pro Tools internal (on-screen) metering of 5.1 format paths always follows the Film track layout:

L C R Ls Rs LFE

Pro Tools track layout of 5.1 format audio tracks in the Edit window also conforms to the Film layout (arranged top to bottom). See “5.1 Track Layouts, Routing, and Metering” on page 1209.

In the I/O Setup dialog, you can route these signals out of your audio interfaces according to any track layout (such as DTS or SMPTE/ITU).

To re-assign channels in a path:

- Drag a channel to a new valid location in the Grid. Other channel assignments will move (shuffle) to accommodate dragged channels.

Default I/O Selectors in I/O Setup

The Output page of the I/O Setup dialog provides selectors for setting I/O defaults in your multichannel sessions.

Default Format Sets the default format for new Output paths and for when you click the Default button.

Path Order Selects the default track layout (or, path order) for new Output paths.

Monitor Path Selects the monitor path for the main mix output of your Pro Tools sessions.

Audition Path Selects the monitoring path for previewing audio in the Clips List, Import Audio dialogs, and a Workspace browser. Only outputs on your primary interface can be used as your Audition path.

Object Fold Down Path Selects the Output path for monitoring Object audio when not connected to a Dolby Atmos Renderer.

Output Meter Path Selects the path that will be shown in the control surface output meters as well as in the Transport Output meters. See “5.1 Tracks, Formats, Assignments, and Metering” on page 1208 for more information.

Default Output Bus Selects the default output bus path for all new tracks, for each supported track format.

AFL/PFL Path (HDX or HD Native Systems Only)

Selects where tracks are routed to when they are soloed in AFL (After Fader Listen) or PFL (Pre Fader Listen) Solo mode.

Default selectors in the I/O Setup dialog

Default 5.1 Path Order I/O Setup Options

The New Track Default Output can be set to bus paths, as well as output paths.

AFL/PFL Path (HDX or HD Native Systems Only)

Selects where tracks are routed to when they are soloed in AFL (After Fader Listen) or PFL (Pre Fader Listen) Solo mode.
### 5.1 Track Layouts, Routing, and Metering

<table>
<thead>
<tr>
<th>5.1 Format</th>
<th>Tracks</th>
<th>Track Meters</th>
<th>Channel Assignments in I/O Setup</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Film</strong></td>
<td><img src="image" alt="Film Track Layout" /></td>
<td><img src="image" alt="Film Track Meters" /></td>
<td><img src="image" alt="Film Channel Assignments" /></td>
</tr>
<tr>
<td>(Pro Tools Standard, and C</td>
<td>24 Mix)</td>
<td>L C R Ls Rs LFE</td>
<td>L C R Ls Rs LFE</td>
</tr>
<tr>
<td><strong>SMPTE/ITU</strong></td>
<td><img src="image" alt="SMPTE/ITU Track Layout" /></td>
<td><img src="image" alt="SMPTE/ITU Track Meters" /></td>
<td><img src="image" alt="SMPTE/ITU Channel Assignments" /></td>
</tr>
<tr>
<td>(Control</td>
<td>24 Mix)</td>
<td>L R C LFE Ls Rs</td>
<td>L C R Ls Rs LFE (left to right)</td>
</tr>
<tr>
<td><strong>DTS</strong></td>
<td><img src="image" alt="DTS Track Layout" /></td>
<td><img src="image" alt="DTS Track Meters" /></td>
<td><img src="image" alt="DTS Channel Assignments" /></td>
</tr>
<tr>
<td>L R Ls Rs C LFE</td>
<td>L C R Ls Rs LFE</td>
<td>L C R Ls Rs LFE</td>
<td></td>
</tr>
<tr>
<td><strong>ICON X-MON</strong></td>
<td><img src="image" alt="ICON X-MON Track Layout" /></td>
<td><img src="image" alt="ICON X-MON Track Meters" /></td>
<td><img src="image" alt="ICON X-MON Channel Assignments" /></td>
</tr>
<tr>
<td>(8-channel 7.1)</td>
<td>L x C x R Ls Rs LFE</td>
<td>L x C x R Ls Rs LFE</td>
<td></td>
</tr>
</tbody>
</table>

*Track layout of different 5.1 formats*
Chapter 53: Multichannel Tracks and Signal Routing

Surround sessions typically include a combination of mono, stereo, and multichannel audio, Auxiliary Input, Master Fader, and Instrument tracks, and inserts and busses.

⚠️ **Multichannel surround mixing is supported with Pro Tools Ultimate only.**

Once the appropriate I/O Setup has been imported or configured, audio, Auxiliary Input, Master Fader, and Instrument tracks can be mixed in multichannel for surround using Pro Tools mixing features.

Multichannel I/O and signal routing is determined by the paths defined in the I/O Setup dialog.

### Multichannel Audio Tracks
*(Pro Tools | Ultimate Software Only)*

Multichannel audio tracks contain an individual channel for each signal in the track (for example, a 5.1 track would have six channels for left, center, right, left surround, right surround, and LFE).

Multichannel audio tracks can be:
- Recorded directly into Pro Tools, using multiple microphones or microphone arrays, or routed to appropriate multichannel Pro Tools Input paths
- Imported from other Pro Tools sessions
- Edited, processed, and mixed in combination with mono and stereo tracks

5.1 format multichannel audio track

5.1 format audio files and tracks conform to the Film track layout standard. Regardless of path assignments in the I/O Setup dialog, all 5.1 format audio tracks and meters follow the Film standard track layout:

```
L C R Ls Rs LFE
```

Multichannel audio tracks are not required to mix in multichannel formats. Mono, stereo, and all supported track formats can be mixed using Pro Tools track outputs and sends (see “Multichannel Signal Routing” on page 1214).
Placing Audio in Multichannel Tracks

You can drag audio files and clips from Workspace browsers, the Clips List, Windows Explorer, or Mac Finder, or from other tracks, to place them in multichannel audio tracks.

To do so, the number of channels being dragged must match the destination track format. For example, you can only drag a stereo pair or two mono clips onto a stereo audio track. Similarly, you can only place audio into an LCR track when you have selected three clips. With 5.1 tracks, you must select six mono files or clips.

⚠️ When dragged into a multichannel track, audio files are placed from top to bottom in the exact order that they appear in the Clips List or playlist from which they came (Top to Bottom must be selected for in the Clips List menu > Timeline Drop Order). For this reason, you may want to rename audio files before dragging them, so that they are placed in the preferred order. Rename them so that sorting them By Clip Name in the Clips List results in the preferred order. (For example, with a 5.1-format track, you can rename the audio tracks so that the arrangement of the tracks corresponds to L, C, R, Ls, Rs, and LFE.)

Solo, Mute, and Gain in Multichannel Tracks and Paths

Stereo and multichannel tracks consist of multiple audio signals, linked together. By default, multichannel tracks are linked and are controlled by a single channel fader, and solo and mute switches.

For discrete control of signals, multichannel tracks can be converted into individual mono tracks. For discrete level and phase adjustment, you can insert and unlink a multi-mono Trim plug-in. Both of these techniques are explained below.

⚠️ Once converted to mono, multichannel tracks cannot be relinked into their original multichannel format. However, a multichannel track can be reassembled by dragging the corresponding number of mono files (with the appropriate file suffixes) into a multichannel track, although some automation data may be lost. As an alternative, record the submix of the mono tracks to disk on a multichannel track.

To convert a multichannel track into discrete mono tracks:

1. Select the multichannel track.
2. Choose Track > Split Into Mono.

To have discrete control of gain on individual channels of a multichannel track:

1. Insert a multi-mono Trim plug-in on the multichannel track.
2. Unlink the Trim plug-in by clicking the Link icon so that it is unlit.
3. Use the Channel selector to display the controls for a channel, and adjust the gain.

⚠️ See “Linking and Unlinking Controls on Multi-Mono Plug-Ins” on page 1216 for more information.
Track and Output Formats

When you create new tracks, you specify mono, stereo, or a supported multichannel format for the new tracks.

In the Mix and Edit windows, the track format of a track’s output is always visible by the number of track meters contained in its fader strip (for example, a single meter for mono tracks, a pair of meters for stereo tracks, and six meters for 5.1 tracks).

Assigning track output determines the format of that output. For example, a mono track always has a single track meter, even when assigned to a stereo output path. If that same mono track is assigned to a 5.1 output path, its output will be split among those six output channels, depending on the position of its panner.

Changing Format

Changing the output format for a given track has several effects:

- The panner that appears in the track will change to reflect the new output format.
- It may be necessary for one or more pan related automation playlists to be created or deleted.

Because changing the output format has these effects, a warning dialog appears whenever you change the output format of a track to a format of fewer channels. Specifically, this will occur whenever automation playlists will have to be deleted.

Multiple Output Assignments and Track Format

When a track is assigned to more than one path of differing formats, the main output for that track will match the format of the assigned path with the greatest number of channels.

Multiple Outputs and Automation Playlists

When a track has multiple output assignments, Pro Tools sorts panning data appropriately for each assigned path. For example, if you assign a mono track to a stereo path and a 5.1 path simultaneously, that track will have a 5.1 panner in the Mix or Edit window. When you pan the track, Pro Tools interprets the 5.1 panning moves into stereo panning moves.

This provides a type of parallel mixing. You can create a variety of mixes of differing formats all at the same time by routing your elements to multiple paths.

💡 Command-Control-click (Mac) or Control-Start-click (Windows) any control in an Output window to show its automation playlist in the Edit window and view any pan automation.
Multichannel Signal Routing

To mix in a multichannel format, tracks are assigned to multichannel paths.

Tracks can be mixed in surround using the following two methods:

- By setting a track main output to a multichannel path.
- By assigning a multichannel send to route audio to a multichannel path.

Multichannel Track Outputs

Tracks can be routed to multichannel output or bus paths using the track’s Output Path selector. This provides a multichannel panner and meter in the Mix and Edit window I/O View.

Additional output assignments can be added by Control-clicking (Mac) or Start-clicking (Windows) the Selector tool and assigning another path.

Multichannel Sends

All track formats, including mono and stereo, let you assign one or more multichannel sends. This provides a multichannel panner in the Sends View. Sends are also useful to bus tracks for multichannel plug-in processing. The following figure shows a mono audio track with a 5.1 (6-channel) send (View > Sends A–E > Send A).
Pro Tools bussing and submixing features are available for all channel formats, from mono/stereo through 8-channel. For examples of multichannel monitoring, effects processing, and bussing, see “Mixing with Paths and Sub-Paths” on page 1217. For mono and stereo mix examples, see Chapter 48, “Basic Mixing.”

**Multichannel Auxiliary Inputs and Master Faders**

A multichannel Auxiliary Input or Master Fader is used as a return for the multichannel bus. Sends are useful when you need to create an additional, independent mix simultaneously (perhaps of a distinct format), requiring dedicated fader, mute, solo, and automation controls.

You can assign Master Faders to main and sub-paths. Main paths must match the format of the Master Fader, and only one Master Fader can be active and assigned to any single (active) main or sub-path. A Master Fader cannot be assigned to a sub-path if its associated main path is already assigned on another Master Fader. See “Master Fader Tracks and Signal Flow” on page 1044.

**Multichannel Instrument Tracks**

Multichannel tracks can be used to monitor and route multichannel instrument plug-ins or multichannel external MIDI instruments.

**Mono, Multi-Mono and Multichannel Plug-Ins**

Plug-Ins can be used in mono, multi-mono, or multichannel formats.

For information about mono, stereo, and mono-in/stereo-out plug-ins, see Chapter 49, “Plug-In and Hardware Inserts.”

**Multi-Mono Plug-Ins** Are designed for use on stereo or greater-than-stereo multichannel tracks. Multi-mono plug-ins are useful, or required, in the following situations:

- When a plug-in does not involve multichannel correlated processing (for example, when applying EQ to select sides of a multichannel signal)
- When you need to adjust signals within the multichannel track independently
- When a plug-in does not support multichannel formats

When a multi-mono plug-in is first inserted on a multichannel track, the plug-in controls are linked. You can unlink them for independent adjustment. See “Master Fader Tracks and Signal Flow” on page 1044 for more information.

Multi-mono plug-ins can also be inserted on stereo tracks, to apply unlinked plug-ins on the left and right channels.

**Multichannel Plug-Ins** Are designed for use on stereo and multichannel tracks that require correlated processing, including stereo and multichannel limiting, compression, and similar effects.
Linking and Unlinking Controls on Multi-Mono Plug-Ins

When a multi-mono plug-in is used on a multichannel track of more than two channels, the controls are normally linked. Adjusting the Gain control on one channel, for example, will adjust it for all channels.

If necessary, you can unlink plug-in controls on specific channels of a track and edit them independently. You can also selectively link the controls of specific channels.

For example, to apply equal filter cutoffs to the Ls and Rs (surround) channels in a 5.1 mix, you could link enable just those channels in an unlinked, multi-mono EQ plug-in. Adjusting the controls in the plug-in window for either channel (Ls or Rs) adjusts the other, linked channel as well.

Link Enable Buttons Let you selectively link the controls of specific channels of a multi-mono plug-in. Each square represents a speaker channel. The Master Link button must be disabled to use the Link Enable buttons.

To unlink controls on a multi-mono plug-in:
- Deselect the Master Link button. It is lit when linked, unlit when unlinked.

To access controls for a specific channel:
- Select the channel from the Channel selector.

To open a plug-in window for all channels of a multi-mono plug-in:
- Option-click (Mac) or Alt-click (Windows) the Channel selector.

To link the controls of specific channels:
1. Deselect the Master Link button if it is not already deselected.
2. Click the Link Enable buttons for the channels whose controls you want to link.

Channel selector and Link controls

Channel Selector Accesses a specific channel within a multichannel track for plug-in parameter editing. This menu appears only on multi-mono plug-ins inserted on tracks with more than two channels.

Master Link Button When enabled, links the controls on all channels of a multi-mono plug-in so that they can be adjusted in tandem.
 Paths in Surround Mixes

Because Pro Tools provides a flexible routing and submixing environment, you can maximize your system’s available resources by first identifying the elements that you want to pan dynamically and those that can be placed in certain channels only (see “Mixing with Paths and Sub-Paths” on page 1217).

Once you have identified these elements in your session, you can use a combination of main and sub-path assignments, and multichannel panning.

 Mixing with Paths and Sub-Paths

It is rare that every track needs to be “flown” (actively panned in between more than a pair of speakers). In most situations, certain elements are placed in certain speakers and remain there, providing the foundation for a mix.

The following figure illustrates an example of how panning and signal routing can be combined in a multichannel mix.

See “Extending Stereo Mixing Conventions to Surround Mixing” on page 1220 for related information.

 When to Use Assign Multichannel Outputs

- Assign 5.1 paths only to those tracks that need to be panned to all six channels.

For example, a sound effects track with a jet fly-over should be assigned a 5.1 path to fly the sound from front-to-back. In a music mix, you can fly a solo instrument or make a synth pad swirl around the room as a special effect.

Elements that need to be heard in all speakers simultaneously can also be assigned to the multichannel output, whether or not they require active panning in the sound field.
When to Use Sub-Paths

- To help simplify large sessions, use sub-paths to route static (or, stationary) elements directly to the output channel or channels.

For example, film dialog is often mixed to the center channel to anchor this essential sound element to the picture. Instead of assigning a six-channel panner to dialog tracks and panning the tracks to the center speaker only, you can route the dialog track’s main output to a mono (Center) sub-path.

Using signal routing and sub-paths to mix in surround
Extending Stereo Mixing Conventions to Surround Mixing

Stereo mixing sets the precedent for active and static panning, and surround mixing can benefit from the same basic principles.

Panning a sound back-and-forth between the left and right speakers is best used as a special effect. In a typical music mix, the basic tracks are placed in the stereo sound field and remain there.

Surround mixes can become incoherent if too many elements are continuously moving. For special effects, some tracks can be panned dynamically, bouncing between speakers or sweeping from one side to the other.

Example Paths and Signal Routing for a Surround Mix

Signal routing is the key element in any Pro Tools surround session. Signal routing is configured and defined in the I/O Setup dialog.

The examples that follow show how Auxiliary Inputs, Master Faders, and other Pro Tools signal routing features can be used for stem mixes, submixes, and similar project needs.

In these examples, music and effects are being mixed for a trailer, in 5.1 surround. Separate stem mixes (for music and for effects) are to be mastered to 8-track MDM.

Example Output Paths

The following figure shows output paths defined in the I/O Setup dialog of an example session that was created on a HDX system with an HD OMNI audio interface.

Different Output paths have been defined for Mix, FX, dialog, and Music.

Example Bus Paths

The following figure shows example bus paths.

An LCR format path (“Dialog”), a stereo format path (“Music”) and a 5.1 format path (“FX”) have been defined, each with several of their own sub-paths.
Example Sub-Paths

Sub-paths let you route to selective channels within the multichannel surround output. In the following figure, the Surround bus has several sub-paths that show this.

LCR Sub-Path The forward 3-channel sub-path. Use this type of sub-path routing to mix dialog, or other forward-facing sound effects.

Stereo Sub-Path The forward stereo sub-path. Use this type of sub-path routing to mix music stems and effects to the front left and right speakers.

Center Sub-Path The front center-channel sub-path provides a discrete mono path for the center channel.

Ls/Rs Sub-Path The surround, rear left and right stereo sub-path. Use this type of sub-path to mix surround effects.

LFE Path The LFE sub-path provides a discrete mono path for the LFE channel.

5.0 Sub-Path The 5.0 path is a 5-channel sub-path. Use this type of sub-path routing to conserve mixing resources with tracks you want to keep out of the LFE channel.

Signal Routing Examples

The following examples show how main and sub-paths can be used, using an example session consisting of a 5.1 main mix, with music and effects stems (or submixes).

Submix Stem Examples

The following figure shows a routing configuration for an effects submix. Two tracks are routed to stereo bus sub-paths, while others are assigned to an LCR and a mono bus sub-path. Two tracks (one mono, one stereo) are assigned to multichannel busses for surround panning. A 5.1 Auxiliary Input assigned to the FX main bus path serves as a submixer.

Extending Stereo Mixing Conventions to Surround Mixing

Stereo mixing sets the precedent for active and static panning, and surround mixing can benefit from the same basic principles.

Panning a sound back-and-forth between the left and right speakers is best used as a special effect. In a typical music mix, the basic tracks are placed in the stereo sound field and remain there.

Surround mixes can become incoherent if too many elements are continuously moving. For special effects, some tracks can be panned dynamically, bouncing between speakers or sweeping from one side to the other.
The following figure shows a routing configuration for effects tracks.

FX stem

The following figure shows a routing configuration for music tracks.

Music stem
Most of the music tracks in this example are routed to the front left/right channels, using a stereo sub-path. A 5.1 Auxiliary Input controls the bus and stem output.

**Multiple Output Assignments**

Multiple output assignments make it possible to configure a number of multi-format mixes. For example, you can assign an additional stereo output to tracks and create a stereo mix at the same time as a 5.1 mix. For more information, see “Multiple Output Assignments” on page 1057.

**LFE Examples**

LFE tracks and other audio can contribute to the LFE output in two ways:

- Using the LFE fader in Output windows. This LFE signal is post-fader.
- Using a custom sub-path to route channels discretely.

The following figure shows a channel Output window, sending and metering the LFE channel.

Using the LFE fader, you can add any amount of any multichannel path to the overall LFE output. In the above example, the track’s Center percentage has been turned off, and the LFE fader has been raised to route it to the LFE channel.

The following figure shows how a “traditional” LFE track can be routed to only the LFE channel. This example uses a custom-defined LFE sub-path to the FX main bus path.

*LFE faders can follow Mix and Edit Groups. For information, see “Selecting Group Attributes” on page 285.*

*For instructions on creating a sub-path, see “Custom Multichannel Paths” on page 1206.*
LFE and Filtering

Pro Tools applies no filtering to LFE signals. Some delivery requirements may require filtering for the LFE track.
Chapter 54: Surround Panning and Mixing

Before you can pan a track in surround, it must be assigned to an appropriate multichannel output or bus path.

See Chapter 52, “Pro Tools Setup for Surround” for more information on multichannel configurations and I/O Setup options. For multichannel signal routing, see Chapter 53, “Multichannel Tracks and Signal Routing.”

Multichannel surround mixing is supported with Pro Tools Ultimate only.

The I/O Setup dialog defines the busing and output architecture of the Pro Tools multichannel surround mixer. If you have not already done so, it is recommended that you become familiar with main and sub-paths and the I/O Setup dialog before starting multichannel Pro Tools projects.

Introduction to Pro Tools Surround Panning

(Pro Tools | Ultimate Software Only)

There are four different track panning methods available:

- In the Edit window, using the reduced-height Panner Grid in the I/O View
- In the Mix window, using the reduced-height Panner Grid
- In the Output window, using the full-size Panner Grid
- Through pan automation editing

Certain Pro Tools control surfaces provide additional panning options. See the documentation for your control surface.
Mix and Edit Window Panner Grids

In the Mix and Edit window, multichannel Panner Grids are displayed on tracks that have multichannel track or send output assignments.

To pan from the Mix or Edit window:

1. To pan in the Edit window, make sure I/O View is being shown (View > Edit Window > I/O). Panner Grids are always displayed in Mix window tracks that support panning.
2. Begin playback.
3. Drag in the appropriate multichannel track’s Panner Grid in the Mix or Edit windows.

The Pan Location cursor follows your movements as long as you hold the mouse button. Movements are scaled so that, once you click to “grab” the Pan Location cursor, you do not need to limit your movements to the small Track Grid area.

Pan Location Cursor Color while Automating

The Pan Location cursor is green when the track is in Automation Read mode, red in an Automation Touch, Latch, Touch/Latch, or Write modes, and yellow in Automation Off (or Automation Suspend) mode.

In Trim mode, the Volume fader and LFE fader are yellow.

Output windows provide additional features and controls (and a much larger Grid). For details, see “Output Windows” on page 1226.

Output Windows

Output windows provide panning controls (called panners), as well as standard Pro Tools controls, for tracks of all mix formats (from 3-channel LCR through 8-channel 7.1).

For information on Output window standard controls, see “Standard Controls” on page 1227. For information on Output window panning controls, see “Surround Panner Controls” on page 1228.

Some of the features of Output windows include:

- X/Y (joystick-style) panning
- 3-Knob panning
- Full Divergence and Center Percentage control
- AutoGlide
- LFE feed
- Multichannel meters
- Pro Tools target window support

Multiple panners can be opened simultaneously, or a single window can display the current panner.
To open an Output window:

- Click the Output Window button (the small fader at the right edge of the Output selector for a track in the Mix or Edit window (I/O View)).

**Standard Controls**

All Output windows provide standard Pro Tools controls for routing, path assignment and other track features. These controls are located at the top of all Output, Send, Insert, and Plug-In windows (see “Standard Selector Controls in Output Windows” on page 1072).

- **Track Fader, Solo, Mute, and Auto**

  All Output windows provide track volume and mute controls. You can adjust and automate track volume, or mute, directly using these controls. The larger fader and Mute button are equivalent to those in the Pro Tools Mix window.

  For instructions on managing multiple Output windows, see “Output Windows for Tracks and Sends” on page 1070.
Surround Panner Controls

When assigned to tracks or paths with four or more channels, the Output window provides an X/Y Grid for surround panning. The speakers associated with the panner’s multichannel format are displayed in their relative positions outside the Panner Grid. These speakers are also used as Snap Pan to Speaker controls.

This section identifies all the controls and features found in Pro Tools multichannel panners.
The X/Y Grid and Pan Location Cursor

The X/Y Grid is where multichannel panning information is input and displayed. You can input pan information using X/Y mode, 3-Knob mode, or by entering numeric values in the Position data fields. You can also edit pan automation graphically in the Edit window.

Multichannel panners default to X/Y mode. In X/Y mode, the track’s current pan position is represented by a green dot. This dot is the Pan Location cursor, and its color indicates track automation status using standard Pro Tools colors:

**Green** The track is in automation Read mode.

**Red** The track is in automation Write, Touch, Latch, or Touch/Latch mode.

**Yellow** The track is in automation Off mode (or Automation Suspend) mode.

Panning Mode Button

This button, located below the X/Y Grid, provides access to Surround panning modes (see “Panning Modes” on page 1230).

Position Controls

The Position controls let you set the positions of the panner.

**Front** Displays and controls the current front X-axis (left/right) position of the panner.

**Rear** Displays and controls the current rear X-axis (left/right) position of the panner. In default X/Y Panning mode, Rear is linked to Front position and cannot be controlled independently.

**F/R (Front/Rear)** Displays and controls the current Y-axis position of the panner.

Front/Rear Linking

Links (or unlinks) the Front and Rear left/right positions controls (they are linked by default). When linked, the F/R control pans the signal front to back always along the same left/right path. When unlinked, you can pan front to back diagonally according to independent Front and Rear settings.

Center % Control

Center % controls how much of the signal is routed to the center speaker. This lets you mix a track to the front with a phantom center (0% Center value) or to three-channel (LCR) when panning front.

Divergence Controls

Divergence determines the width of the panned signal with respect to neighboring speakers. For more information, see the Pro Tools Sync & Surround Concepts Guide. There are three Divergence controls:

**Front, Rear, and F/R Divergence** Provide separate, automatable divergence control over front speakers, rear speakers, and between front/rear, respectively.

For examples of how divergence settings affect output panning, see “Divergence and Center Percentage” on page 1233.
Snap Pan to Speaker Icons

The Snap Pan to Speaker icons let you force the panner to the speaker’s location. For example, clicking on the upper left speaker moves the Pan Location cursor to the upper left corner of the X/Y Grid.

LFE Fader

The LFE fader is only available in “.1” surround formats (5.1, 6.1, and 7.1).

The LFE fader determines how much of the current track’s signal will be routed to the LFE channel. LFE faders in Track and Send windows can follow groups. The Pro Tools LFE channel is always full-bandwidth. For more information on how to use the LFE fader, see “LFE Faders in Multichannel Panners” on page 1235.

Multichannel Panner Linking

Stereo tracks with multichannel outputs provide left and right multichannel panners. The Output window provides controls to link the left and right channels for precise panning.

When you create a stereo track that is routed to a multichannel output, the following pan linkage controls are active by default:

- Link (links Left and Right pan controls)
- Front Inverse (inverts Left and Right pan control linkage across front)
- Rear Inverse (inverts Left and Right pan control linkage across rear)

Panning Modes

The Panning Mode button provides access to four panning modes: X/Y mode, Divergence Editing, 3-Knob mode, and AutoGlide mode. Panning controls can be automated in all four modes.

Pro Tools provides the following Panning Modes:

- **X/Y Mode** Joystick-style panning by dragging the Pan Location cursor within the X/Y Speaker Grid. See “X/Y Panning” on page 1231 for more information.
- **3-Knob Mode** Point-to-point panning, between pairs of speakers. See “3-Knob Panning” on page 1231 for more information.
- **Divergence Editing** The divergence X/Y Grid can be dragged to resize the divergence boundaries. See “Divergence Editing Mode” on page 1234.
- **AutoGlide Mode** Point-to-point panning from the Pan Location cursor to a new destination over a specified AutoGlide Time. See “AutoGlide Mode” on page 1232 for more information.

To enable a Panning Mode:

- Click on the Panning Mode button in the Surround Panner until the mode icon is displayed.
X/Y Panning

To pan in X/Y mode:

1. Click on the Panning Mode button until the X/Y mode icon is displayed.

2. Drag the Pan Location cursor, or click anywhere in the Grid and drag to pan the track. The location of the Pan Location cursor determines the pan position of the signal. For example, to pan something to the left rear speaker, move the Pan Location cursor to the lower-left corner of the Grid.

It is not necessary to click exactly on the Pan Location cursor. Clicking anywhere in the Grid will move the Pan Location cursor relative to where you click or take over with a hardware panner. Panning does not jump to the click position.

To snap the Pan Location cursor to a location in the Grid:

- Command-Shift-click (Mac) or Control-Shift-click (Windows) at the location in the X/Y Grid.

Grid Options and Shortcuts

Fine-Adjust Mode Hold the Command key (Mac) or Control key (Windows) for fine adjustment of all Panner controls.

Constraining to X or Y Movement Shift-drag the Pan Location cursor to constrain its movement to the X or Y direction.

Reset to Default Option-click (Mac) or Alt-click (Windows) in the Panner Grid to reset all controls to their default position.

Snap Pan to Speaker Click one of the Snap Pan to Speaker icons to force the panner to that speaker location.

Display Automation in Edit Window Control-Command-Control-click (Mac) or Start-click (Windows) a control to display that control’s playlist in the Edit window.

All Pan controls can be automated, including pan position and divergence. See Chapter 50, “Automation” for details.

3-Knob Panning

Pro Tools provides 3-Knob mode as an additional way to input pan moves.

3-Knob mode lets you do the following:

- Pan in straight lines, moving the Pan Location cursor using the Position rotary knobs with full movement of front, rear, and front-rear position
- Pan discretely between pairs of speakers.

For example, when panning front-left to rear-right in 3-Knob mode, audio will be heard from just those two speakers (assuming full divergence is in effect).

By comparison, in X/Y mode a diagonal pan may result in audio being heard in some or all channels.
The difference is that 3-Knob mode pans discretely between the front and rear position of the panning trajectory, while X/Y mode panning takes place in the full 360° Panning Grid. Divergence and Center Percentage are variable in both Panning modes.

To enable 3-Knob Panning mode:
- Click on the Panning Mode button until the 3-Knob mode icon is displayed.

The panner trajectory line appears across the Grid, extending from the front (X-axis) to the rear (Y-axis).

To pan in 3-Knob mode:
1. Adjust the Front and Rear Position knobs to set the trajectory line.
2. Rotate the Front/Rear Position knob to pan along the trajectory. The Pan Location cursor is constrained to the white trajectory line.

To change the 3-Knob trajectory angles, do one of the following:
- Drag either end point (Front or Rear) of the trajectory line.
- Adjust the Front or Rear Position controls.

To change the current trajectory position (left-to-right) and retain its current angles:
- Drag the trajectory line (not its end points) to a new position.

AutoGlide Mode

AutoGlide mode lets you quickly write Surround Panner automation by clicking new locations in the Surround Panner window, instead of manually moving the Surround Panner controls.

⚠️ When writing automation in AutoGlide mode, the Pan Location cursor cannot be dragged from its location.

The time it takes to glide from point to point (from the Pan Location cursor to the new destination) is called the AutoGlide Time. This time is set in the Mixing Preferences page and has a range of 10 msec to 10000 msec (10 seconds).

To set the AutoGlide Time
1. Choose Setup > Preferences and click Mixing.
2. Set the AutoGlide Time in the Automation section.

To do an AutoGlide automation pass:
1. Click the Panning Mode button until the AutoGlide mode icon is displayed.

The Panning Mode button displays a slanted dotted line that ends with a filled in dot (representing a cursor) at its top right corner.

2. In the Mix or Edit window, click the Automation Mode selector and select an Automation mode for the track you want to automate.
3. Press Play to begin playback.
4 Set a new destination for the cursor by doing one of the following:
• Click a Snap Pan to Speaker icon to glide to its speaker location.
• Click in the pan window to glide to a specific location in the X/Y Grid.

5 Repeat the previous step if you want to write additional panning moves.

6 Stop the transport when finished.

Divergence and Center Percentage

The Divergence and Center Percentage controls range from 0 to 100, and can be automated. They are especially useful for ensuring audibility and coverage in large venues, and to increase clarity of voices.

Front Divergence Controls divergence between front speakers (X-axis only).

Rear Divergence Controls divergence between the rear speakers (X-axis only).

Front/Rear Divergence Controls divergence between front and rear (the Y-axis).

Center % (Percentage) Determines whether there is a discrete center image, a completely phantom center image, or a variable amount in between.

Side % (Percentage) Determines whether there is a discrete side image, a completely phantom side image, or a variable amount in between the right and left side channels for 7.1 and 7.0 formats.

Divergence

In the Panner Grid, the current divergence values are displayed using a purple outline.
By default, Pro Tools surround panners are 100% or fully divergent, meaning that a signal that is panned completely to one speaker will only be audible in that speaker.

Lower divergence settings result in a progressively wider source signal. When Divergence is less than 100%, tracks will be routed to neighboring speakers to some degree, even when the Pan Location cursor is positioned next to a single speaker.

**To adjust divergence:**
- Adjust the Front, Rear, and Front/Rear Divergence controls as necessary.

---

**Divergence Editing Mode**

In Divergence Editing mode, you can adjust the divergence boundaries by dragging directly in the Divergence Grid.

**To adjust divergence graphically:**

1. Click on the Panning Mode button until the Divergence Editing icon is displayed.

2. Drag in the Grid to resize the divergence boundaries.

---

**Center % (Percentage)**

In LCR, LCRS, 5.0, 5.1, 6.0, 6.1 7.0, 7.0 SDDS, 7.1, and 7.1 SDDS surround formats, the Center % controls whether there is a discrete center channel for the track or a phantom center channel.

**Center Percentage Example**

In film and video production, the center channel often contains dialog. To enhance the clarity of dialog, it is often beneficial to keep elements such as music out of the center speaker. By reducing the Center Percentage on music tracks, music panned to the front of the soundfield can be panned to only the left and right speakers, forcing them to have a variable phantom center image.
To adjust Center Percentage:

- Adjust the Center Percentage knob.

As you reduce the Center Percentage value, the center speaker at the top of the Grid becomes less visible. At 0, the center speaker is completely invisible, reflecting the setting for fully phantom center.

![Center % set to 0 (no center speaker shown)](image)

**Side % (Percentage)**

For 7.1 and 7.0 surround formats, the Side % controls whether there are discrete side channels for the track or a phantom side channel.

![Side % set to 50% (side center speakers dimmed)](image)

To adjust Side Percentage:

- Adjust the Side Percentage knob.

As you reduce the Side Percentage value, the speakers at the sides of the Grid become less visible. At 0, the side speakers are completely invisible, reflecting the setting for fully phantom center.

**LFE Faders in Multichannel Panners**

The LFE fader controls how much of the track is sent to LFE. LFE faders are only available when a track is assigned to a path whose format supports LFE (5.1, 6.1, or 7.1).

*For general information about LFE, sub channels, and related topics, see the Pro Tools Sync & Surround Concepts Guide.*

To mix to the LFE channel:

- Adjust the LFE fader in any “.1” surround format Output window.
**LFE Faders and Groups**

Track and send LFE faders can follow Mix and Edit Groups by being enabled in the Group Attributes page in either the Create Groups or Modify Groups dialog. LFE faders can be assigned to follow groups as a global attribute or on a group by group basis. See “Selecting Group Attributes” on page 285.

**LFE Enable**

Some multichannel plug-ins, including the multichannel Dynamics III Compressor/Limiter, provide LFE Enable. This lets you enable or bypass processing of the LFE channel if present.

![LFE Enable in the multichannel Dynamics III Compressor/Limiter](image)

**To process the LFE channel in a multichannel plug-in:**

- Click to enable LFE Enable in supporting multichannel plug-ins. LFE Enable is highlighted when LFE processing is enabled, and unhighlighted when LFE processing is bypassed.

💡 *When LFE Enable is unavailable, try using the multi-mono version of the plug-in.*

---

**Pan Playlists**

Multichannel panners have an automation playlist for each position and divergence control.

Pan automation can be drawn, edited, cut, copied, and pasted from the Edit window. For more information, see Chapter 50, “Automation.”
Chapter 55: Mixing to Dolby Atmos

Dolby Atmos Overview (Pro Tools | Ultimate Software Only)

Pro Tools | Ultimate software lets you mix to Dolby Atmos 7.0.2 and 7.1.2 multichannel formats with support for play back and record of object audio and panning metadata when used with a Dolby Atmos Renderer.

Audience Immersion

With Dolby Atmos, three critical elements significantly improve the audience experience over 5.1 and 7.1 systems:

- Sounds originating overhead
- Improved audio quality and timbre matching
- Greater spatial control and resolution

“3D” Multichannel Formats

Pro Tools provides 7.0.2 and 7.1.2 channel widths for mixing to Dolby Atmos. While 7.0 and 7.1 are standard surround channel widths (in this case, 7 surround channels and an optional LFE channel for low frequency content played back through a subwoofer), the additional “.2” indicates another two audio channels that are mixed to stereo (left and right) overhead speakers (or speaker groups). This adds the dimension of height to surround sound for truly three-dimensional audio.

Elements of a Dolby Atmos Mix

A Dolby Atmos mix consists of three primary elements:

Bed Audio (or Bed Material) Channel-based premixes or stems (including their multichannel panning)—such as music, Foley, or dialogue stems. Bed audio is mixed in Pro Tools with all multichannel panning, including height as well as surround channels and a low frequency channel, applied to the audio output from Pro Tools. The resulting multichannel audio mix is streamed to a Dolby Atmos Renderer for inclusion in a Dolby Atmos master.

Object Audio (or Objects) Unique mono (or stereo) audio sources that are streamed directly to a Dolby Atmos Renderer. The Renderer then applies all panning and processing for each object independently according to associated Dolby Atmos metadata. Typical object audio content might be something like an airplane fly-over or a pesky mosquito, an object can really be any single sound source that might be in motion over and in or around the audience—hence a sound object.

Dolby Atmos Metadata Proprietary panning control data for object audio (as well as additional metadata) that is applied in the Renderer. For each Pro Tools track assigned to an object output path, 7.1.2 (or 7.0.2) Pro Tools pan automation is translated into Dolby Atmos metadata to control object panning done in the Renderer.
Mixing to Dolby Atmos with Pro Tools Ultimate

Pro Tools Ultimate provides the following features supporting mixing to a Dolby Atmos Renderer:

- 7.0.2 and 7.1.2 channel widths for Input, Output, and Bus paths, and for audio, Auxiliary Input, Master Fader, and Instrument tracks.
- Mapping busses to dedicated Object Output Paths in the I/O Setup
- Object view for mono and stereo audio, Auxiliary Input, and Instrument tracks.
- Automated switching between assigned track Output and an Object output path for mono and stereo audio, Auxiliary Input, and Instrument tracks
- Object Fold Down Path for monitoring fully mixed object audio when a Dolby Atmos Renderer is not available
- 7.0.2, 7.1.2, and Object panning
- 3D “Theater” panning view
- Enhanced object re-recording (dubbing) workflows

References to the “Dolby Atmos Renderer” or “Renderer” include the Dolby Atmos Rendering and Mastering Unit (RMU), custom Dolby Atmos rendering and mastering workstations, and the Dolby Atmos Rendering application that is part of the Dolby Atmos Production Suite.

Installing and Configuring Dolby Atmos Software and Hardware

To use Pro Tools with Dolby Atmos, follow the instructions provided by Dolby for installing and configuring your Dolby Atmos hardware (if any) and software. Pro Tools cannot provide essential Dolby Atmos features if the necessary Dolby Atmos software is not correctly installed, configured, and authorized on your Pro Tools system.

For complete information on installing, configuring, and using Dolby Atmos products, please refer to the appropriate documentation for your specific Dolby Atmos products published by Dolby.

Example Hardware-Based Dolby Atmos System Configuration

A basic hardware-based Dolby Atmos system includes the following components:

- One or more Pro Tools | HDX systems for audio playback and panning control for sound objects.
- Optional dubbing (recording) Pro Tools | HDX system
- One or two Avid HD MADI audio interfaces per Pro Tools system for digital audio streaming from Pro Tools to the Dolby Atmos RMU or rendering and mastering workstation (MADI optical or coaxial connections)
- Dolby Atmos Rendering and Mastering Unit (RMU)—applies object panning and creates the Dolby Atmos master from your Pro Tools mix
- Dolby Atmos Monitor application (installed and running on a Pro Tools system)
- Dolby Atmos Renderer Web Client for configuring the Dolby Atmos RMU, setting up beds (speaker/room configurations) and objects (panning with metadata through speaker zones).
Dolby also provides software-only solutions for rendering and mastering a Dolby Atmos mix, such as the Dolby Atmos Renderer application that is part of the Dolby Atmos Production Suite.

Contact Dolby for complete information about Dolby Atmos product solutions.

### 7.0.2 and 7.1.2 Surround Formats in Pro Tools

Pro Tools lets you create 7.0.2 and 7.1.2 surround format input, output, insert, and bus paths in the I/O Setup. Pro Tools can likewise create tracks with 7.0.2 and 7.1.2 channel widths.

Once 7.0.2 or 7.1.2 paths have been created, they are available in any path input or output selector, such as track input and output assignments, sends, and so on.

7.0.2 or 7.1.2 paths can also be used for internal busses, monitoring, auditioning, and output metering.

7.0.2 and 7.1.2 formats work in Pro Tools just like any other multichannel surround format, but with the addition of two overhead channels. Because of the overhead channels, additional automatable panning controls are provided (see “7.0.2, 7.1.2, and Object Panner” on page 1249).

When mixing for Dolby Atmos, assign the output of mono or stereo source tracks to a 7.1.2 (or 7.0.2) audio or Auxiliary Input track using a 7.1.2 (or 7.0.2) bus to feed a bed mix. Use volume and pan automation on the source tracks to mix them into the final 7.1.2 (or 7.0.2) bed mix.

#### Configuring the Network Connection for Pro Tools and a Dolby Atmos Renderer

The Atmos page in the Peripherals dialog lets you configure the network connections required for sending Dolby Atmos metadata between Pro Tools and the Dolby Atmos Renderer. When properly configured, Pro Tools and the Renderer communicate with Dolby Atmos metadata over the network.
To setup the network connection between Pro Tools and a Dolby Atmos Renderer:

1. Choose Setup > Peripherals.
2. Click the Atmos tab.
3. Select Enable.

4. Specify the Renderer host in the RMU Host field by doing one of the following (if there is more than one Renderer on the network, make sure you specify the correct one for the Pro Tools system):
   - Enter the IP Address for the RMU (or rendering and mastering workstation) on the network that has a MADI connection to your Pro Tools system.
   - Click the RMU Host drop-down selector to see a list of RMUs (or other Dolby Atmos rendering and mastering workstations) identified on the network and select one that has a MADI connection to your Pro Tools system.
   - If your Pro Tools machine is using a software Renderer (such as the Dolby Atmos Renderer application that is part of the Dolby Atmos Production Suite), type localhost or select it from the drop-down selector.

The Connection Status indicator lights solid if the connection is successful. It flashes on and off if the connection is not successful. You can still work on the session even if not connected to the Renderer, but Enable must be selected.

5. Enable Link Object and Audio Rendering if desired (see “Link Object and Audio Recording” on page 142).

6. Click OK to save your changes and close the Peripherals dialog.

---

**Pro Tools Restrictions when Mixing to Dolby Atmos**

When you create a Pro Tools session for Dolby Atmos workflows, the following restrictions apply:

**Only Use a 48 kHz Session Sample Rate**

If working with different sample rates during sound creation or premixing, convert the session sample rate to 48 kHz before working with the Renderer.

**Only Use a Supported Session Timecode Rate**

For home theater workflows, the Dolby Atmos Renderer supports mixing and creating masters at the following timecode rates: 23.976, 24, 25, 29.97, 29.97 drop frame, and 30 frames per second (fps).

For cinema workflows, the Dolby Atmos Renderer supports creating masters at 24 fps only. If mixing with a 24 fps session, set Audio Rate Pull Up/Down and Video Rate Pull Up/Down to None.

**Set the Hardware Buffer Size to 1,024 Samples (Recommended)**

Sessions used to author Dolby Atmos mixes tend to be very large and processor intensive. Using the highest available Hardware Buffer Size setting is recommended for optimal performance and reliability on your Pro Tools system.
Configuring Session Setup for Dolby Atmos

To configure the Session Setup for Dolby Atmos:

1. Choose Setup > Session.
2. In the Format section, set Timecode Rate to the appropriate supported Timecode rate for mixing:
   - For home theater workflows, the Dolby Atmos Renderer supports mixing and creating masters at the following timecode rates: 23.976, 24, 25, 29.97, 29.97 drop frame, and 30 frames per second (fps).
   - For cinema workflows, the Dolby Atmos Renderer supports creating masters at 24 fps only.
3. If mixing with a 24 fps session, in the Timecode Settings section, do the following:
   - Set Audio Rate Pull Up/Down to None.
   - Set Video Rate Pull Up/Down to None.

Configuring the I/O Setup for Dolby Atmos

Configure the I/O Setup according to the needs of where and how your Pro Tools system fits into the larger Dolby Atmos workflow.

I/O Setup Example for a Pro Tools Playback System on a Dolby Atmos Mix Stage

When working within a large, hardware-based Dolby Atmos mixing environment, if your Pro Tools system is a playback machine being used for authoring Dolby Atmos mixes (and assuming it has two HD MADI interfaces), configure the Output and Bus pages of the I/O setup as follows:

- Ensure that the Path Order is correctly set.
- In the Output page, create a 7.1.2 Output path (SMPTE path order) and assign it to the first ten outputs on the first HD MADI. This path will be used to play back bed audio.
- In the Output page, create 1–118 mono output paths and assign each to the remaining outputs on both HD MADI interfaces (objects 11–64 to HD MADI 1 outputs 11–64 and objects 65–128 to HD MADI 2 outputs 1–64). These paths will be used to play back object audio.
• In the Bus page, create a 7.1.2 bus and map it to the 7.1.2 output path for the main bed mix.
• In the Bus page, create 118 mono busses and map each to its own object path (objects 11–128).

To automatically create busses in Pro Tools that match the Dolby Atmos Renderer configuration:

1 Configure the Dolby Atmos Renderer.
2 In Pro Tools, ensure that Dolby Atmos is enabled (Setup > Peripherals > Atmos).
3 Open the I/O Setup (Setup > I/O) and click the Bus tab.
4 Delete any existing busses.
5 From the Default Busses selector, enable the Use Atmos Renderer option.

To configure a Pro Tools session for mixing bed material:

1 In the Output page of the I/O Setup, create a 7.1.2 Output path assigned to the first ten physical outputs of your audio interface (for monitoring the mix with a 7.1.2 speaker configuration).
2 In the Bus page of the I/O setup, create a 7.1.2 busses and map it to the 7.1.2 output (“Bed Monitor”).
3 Create another 7.1.2 bus with the Auto-create sub-paths option enabled (“Bed Mix”).
4 Create a new 7.1.2 audio track.
5 Assign the 7.1.2 track Output to the 7.1.2 Output path (“Bed Monitor”).
6 Assign the 7.1.2 track Input to the 7.1.2 internal bus (“Bed Mix”).
7 Create as many new tracks as needed for source audio.

Mixing Bed Material

Mix bed material for a Dolby Atmos mix to 7.1.2. Bus record the bed mix to a 7.1.2 audio track in preparation for playback and mixing to a Renderer.

For additional information about configuring and using Pro Tools with the Dolby Atmos Renderer, see the Dolby documentation included with your Renderer software.
8 Assign the track Output for each source track to the 7.1.2 internal bus (“Bed Mix”).

9 Enable Input monitor on the 7.1.2 audio track.

10 Mix the audio on the source tracks to the 7.1.2 audio track using volume and pan automation.

Mapping Busses to Objects

Object output paths are defined by mapping busses to Objects in the Bus page of the I/O Setup. Both mono and stereo busses can be individually mapped to up to 118 predefined Object inputs to the Renderer. Mono or stereo audio, Auxiliary Input, and Instrument tracks can be assigned to mono or stereo Object paths in Object view in the Edit and Mix windows.

💡 Note that the numbering of Objects begins at 11 as the first ten input channels of the Renderer are reserved for the 7.1.2 bed mix.

To map busses to Objects in the I/O Setup:
1 Open the I/O Setup (Setup > I/O) and click the Bus tab.

2 Click the New Path button.

3 In the New Paths dialog, create a mono or stereo path (or both). If you are creating a stereo path, enable the Auto-Create sub-paths option.

4 Type a name for each new bus path (try to be consistent with your naming scheme for busses to be mapped to objects) and click Create.

5 Do one of the following for the new bus path depending on its channel width:
   • For a mono bus, click the checkbox in its row in the Mapping to Object column so that it is checked. The bus is automatically mapped to the first available Object.
   • For a stereo bus, reveal its mono sub-paths and click the checkbox in either of their rows in the Mapping to Object column so that both are checked. Both sub-paths are automatically mapped to the next two available Objects.

Example Bed mix
If you are working with an RMU (or rendering and mastering workstation), also do the following:

- In the Output page of the I/O Setup, create the corresponding number of mono (or stereo) output paths assigned to physical MADI outputs.
- In the Bus page of the I/O Setup, map each Object-mapped bus to the corresponding Output path (the first mono bus is mapped to Object 11 and to Output path 11, the second to Object 12 and to Output path 12, and so on).

This reserves each physical MADI output to the RMU (or rendering and mastering workstation) for the mapped Object paths. These steps are not necessary if you are working with the Dolby Atmos Renderer application since Pro Tools uses the Dolby Atmos Send plug-in inserted on object tracks to stream audio to the Dolby Atmos Renderer application.

7 Click OK.

The mono (or stereo) bus is now defined as an object output path. Any one mono (or stereo) audio, Auxiliary Input, or Instrument track can now be assigned to this object output path in the track Object view.

To change the Object mapping of a bus:

1 Open the I/O Setup (Setup > I/O) and click the Bus tab.

2 Click the name of the Object the bus is currently mapped to in the Mapping to Object column and select another available Object (unless all 118 Objects are already mapped, another one should be available). Objects in the list that are grayed out are not available because another bus is already mapped to it.

Selecting the object path to which the bus is mapped

If you need to make a mapped Object available, locate it in the Mapping to Object column and deselect the checkbox for the currently mapped bus. That bus is no longer mapped to that Object, making it available for another bus.

Object Names and Properties

Object descriptions defined on the Renderer are displayed in the Object selector in the Mapping to Object column as the name of the Object. Additionally:

- Only one mono bus can be mapped to one object path at a time. A stereo bus requires that its two mono sub-paths (left and right) each be mapped to a pair of individual Objects.
- Objects that are grayed out are already mapped to other busses and are unavailable.
- Object mappings persist in session files and in the current I/O Settings file, similar to Pro Tools Output Mappings.
- Object mappings are made by Renderer Input channel, not Object name or description. If a session is opened with Object mappings to a given Renderer Input channel that exists in the network it will be mapped regardless of name or description. If an Renderer Input channel is no longer available for any reason, it will be deactivated in the Bus page and a warning dialog is displayed.
Track Object Output Assignment

After you have mapped busses to Objects in the Bus page of the I/O Setup, you can assign any single mono (or stereo) audio, Auxiliary Input, or Instrument track to a unique object output path.

To assign a new track to an object output path:

1. Create a new mono (or stereo) audio, Auxiliary Input, or Instrument track.
2. Show Object view in the Edit or Mix window (see “Object View in the Edit and Mix Windows” on page 1246).
3. From the Object Output Path selector in Object view, select the desired available object output path (see “Object Path Selector” on page 1247).

Object output paths are only available if they match the track channel width (mono or stereo) and are not already assigned to another track.

Bus Output

When a track is toggled to Bus, track audio follows the selected Output path (in I/O view) but the 7.1.2 object panner appears in the track Output window, as well as in the track I/O view in the Edit and Mix windows. The channel width of the selected Output path persists, but its panning is now controlled by the 7.1.2 object panner.

Object Output

When a track is toggled to Object, track audio follows the selected object output path (in Object view) and the track Output (in I/O view) is completely bypassed. The track audio follows the assigned object output path and is streamed over MADI to the Renderer (RMU or rendering and mastering workstation). If you are working with the Dolby Atmos Renderer application, use the Dolby Atmos Renderer Send plug-in.

The Object panner appears in the track Output window, as well as in the track I/O view in the Edit and Mix windows. All pan controls are available and automatable, but no panning is applied to the track audio in Pro Tools. Rather, Pro Tools converts pan automation to Dolby Atmos metadata, which is sent to the Renderer over the network.
Monitoring Object Audio when not Connected to a Renderer

Dolby Atmos mixes are monitored from the Renderer. If Pro Tools is disconnected from or can’t communicate with the Renderer, you can monitor the mix in Pro Tools over the output path designated as the Object Fold Down Path. When Pro Tools can’t recognize a connection to the Renderer, it automatically re-routes all object output paths, and folds them down to the selected output format using coefficients for down mixing 7.1.2 panning.

To designate the Object Fold Down Path:

1. Open the I/O Setup (Setup > I/O) and click the Output tab.
2. In the Output page, ensure that there is an available output path with the channel format that you want. If not, create one.
3. From the Object Fold Down Path selector, output path you want to use to monitor panned object audio
4. Click OK to save your changes and close the I/O Setup.

To make sure that Pro Tools is not connected to a Renderer, start playback and you will hear all object audio downmixed to the designated Object Fold Down Path.

⚠️ Because the Object Fold Down Path activates an invisible internal bus, it cannot be metered on a Master Fader or the Edit Window Output Meter Path display.

Object View in the Edit and Mix Windows

Edit and Mix Window Object view provides Object controls for audio, Auxiliary Input, and Instrument tracks (mono and stereo only). In the Edit window, these controls appear between the I/O column and the Real-Time Properties column of all Track and Ruler views. In the Mix window, these controls appear between the I/O selectors and the Auto selector. Object view can be shown or hidden independently in both the Edit and Mix windows.

To show (or hide) the Edit Window Object view, do one of the following:

- Select (or deselect) View > Edit Window Views > Object.
- From the Edit Window View selector, enable (or disable) Object.

Object Track view, Edit window

To show (or hide) the Object controls in the Mix window, do one of the following:

- Select (or deselect) View > Mix Window Views > Object.
- From the Mix Window View selector, enable (or disable) Object.

Object view, Mix window
Object Controls

Object controls shown in the Edit and Mix window Object view mirror each other on a track-by-track basis. These controls let you assign audio, Auxiliary Input, and Instrument tracks to object output paths, automate toggling of the track between the Bus and Object output, and set the control mode for object panning metadata.

Object Path Selector

The Object Path Selector lets you assign the track to any available object output path (defined in the Bus page of the I/O Setup).

Output Window Button

The Output Window button in the Object view opens the Output Window for the track.

Bus/Object Toggle

The Bus/Object toggle switches the routing of track audio between the Output selected in the I/O view (Bus) and the selected object output path (Object).

- When toggled to Bus, the track behaves like a normal Pro Tools track. The only exception is that track panning is controlled by the 7.1.2 object panner regardless of the channel width of the selected Output.

- When toggled to Object, the selected Output in I/O view is completely bypassed and track audio follows the selected object output path to the Renderer. Also, all pan automation is translated to Dolby Atmos metadata and sent over the network to the Renderer. No panning automation is applied to the track audio in Pro Tools.

Bus/Object toggle can be automated (see “Object/Bus Toggle Automation” on page 1253).
**Object Control Mode**

The Object Control Mode button lets you cycle between the three different Master Object Control modes: Master, Record, and Off/Bypass. Click the Object Control Mode button to cycle through and select the Object Control mode.

<table>
<thead>
<tr>
<th>Mode</th>
<th>Description</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Master</td>
<td>Object assigned, sending metadata</td>
<td>Set by default if no other tracks are already assigned to this object, use this mode to control an object on the renderer.</td>
</tr>
<tr>
<td>Record</td>
<td>Object assigned, record mode</td>
<td>Use this mode in a re-recording workflow to record pan automation sent from a Master panner on the network.</td>
</tr>
<tr>
<td>Off/bypass</td>
<td>Object assigned, no metadata being sent</td>
<td>Use this mode to mix multiple tracks of audio to the same object output path. In this workflow, one track set as Master controls the panning, while one or more other tracks with the same object output path assignment but set to Off/bypass feed audio to the object output path but without sending pan metadata.</td>
</tr>
</tbody>
</table>

**Renderer Connection Status Indicator**

The Renderer Connection Status indicator appears in the title bar of the Object view to the right of the title in the Edit and window if Atmos is enabled in the Peripherals dialog, but not if Atmos is disabled. It is green if Pro Tools is successfully connected and communicating with the Renderer on the network. It is pale yellow if it is not connected or the network connection has failed.
7.0.2, 7.1.2, and Object Panner

When a mono or stereo track is assigned to a 7.0.2 or 7.1.2 output bus, or to an object output path, it uses the corresponding 7.0.2, 7.1.2, or Object panner.

![Output window in standard (2D) view for a mono track assigned to a 7.1.2 bus (left) and an Object (right)](image)

**Panner Controls and Indicators**

The following elements of the Pro Tools Output window are specific to the 7.0.2, 7.1.2, and Object panners. The Output window for each provides the same controls, except that the Object panner additionally provides the Object Output Path selector and the Object Control Mode button, and the 7.0.2 panner excludes the LFE fader.

**Theater Mode**

The Pro Tools Panning Mode selector provides the Theater option, which is only available with the 7.0.2, 7.1.2, and Object panners. When this mode is selected, the panner displays a 3D/Theater view.

![Enabling Theater mode](image)
Theater mode provides a 3D room view that can be rotated.

**To rotate the room view in Theater mode:**
- Move the cursor over the room view and use the scroll-wheel to rotate the room up or down. Scroll all the way down for top-down view.

**Indication of Height, Proximity, and Location in 3D/Theater Mode**

**Height** Adjusting the Height value raises or lowers the Height plane. See 1 in Figure 4.

**Proximity** The size of the pan dot indicates proximity (whether the element is closer or further away relative to the current view). The pan dot appears smallest when panned furthest away and largest when panned nearest (see 2 in Figure 4).

**Location** Pan lines appear on the Height plane to indicate Left/Right and Front/Rear location. See 3 in Figure 4.

**Screen** The Screen image provides a visual reference for the front room in all views. See 4 in Figure 4.

---

**Height Mode**

Sets the Height mode for the track. Choices include FreeForm mode (manual height adjustment), and Wedge, Sphere, and Ceiling modes (automatic height modes). Height mode can be automated.

**To select the Height mode:**
- Click a Height mode icon to select that mode.

**To toggle Height on/off:**
- Click the Height Enable icon. When lit, Height is enabled (requires FreeForm Height mode).

Height Enable can be automated.
**Height**

The Height knob becomes available when FreeForm mode and Height is enabled/active. Height can be automated.

Adjusting Height in standard 2D view displays a vertical bar to the right of the pan grid to indicate relative height of that track. In addition, the size of the pan dot increases as Height is increased.

In Theater mode a colored Height plane shows the current Height value. The size of the pan dot indicates proximity (see “Indication of Height, Proximity, and Location in 3D/Theater Mode” on page 1250).

**Zones**

The Zones selector sets the speaker Zone (Zone Mask). Choices include All, F/S (front and side), F/R (front and rear), FC/R (front, center and rear), Front, and Rear. Speaker icons surrounding the panner grid appear as appropriate for the current Zone.

**To select the Zone:**
- Right-click, or click and hold on the Zones selector and set the Zone.

Zones can be automated.

**Size**

Increases or decreases the element size. When Size is set to any value above 0/off, a transparent grid (or cube if in 3D/Theater mode) surrounds the pan dot. The grid/cube gets larger as Size is increased, and smaller as it is decreased.

To change the element Size:
- Adjust the Size knob, or hold down Shift and use the scroll wheel.

**Speaker Snap**

You can toggle Dolby Atmos Speaker Snap on or off for tracks assigned to an Object.

To enable (or disable) Speaker Snap:
- Click the Speaker Snap icon to toggle on/off.

*Do not confuse Dolby Atmos Speaker Snap with the Pro Tools panner ability to click a speaker icon to “jump” the pan dot to a location.*
Object Output Path Selector and Object Control Mode

Across the top of the Output window are the Audio Output Path selector, the Object Output Path selector, and the Object Control button.

Object Output Path Selector

Click the Object Output Path selector to assign the track to an Object (see “Object Path Selector” on page 1247).

Toggling Object/Bus Assignment

Command-click (Mac) or Control-click (Windows) the Object Output Path selector or the pan dot to toggle the track audio output between the selected Object path or selected track output (output bus). Toggling between object output and bus output assignments can be automated (see “Bus/Object Toggle” on page 1247).

Object Control

Click the Object Control mode button to cycle through and select the Object Control mode (see “Object Control Mode” on page 1248).

Object/Bus Assignment and Automation Mode Indication

The Pan Dot control in Output windows, and in the graphic panner in I/O view on tracks in both the Edit and Mix windows changes color to show whether track audio follows the selected output bus path shown in the I/O view or the selected object output path shown in the Object view as well whether the Track Automation mode is set to Read, any Write mode, or is Off.

Pan Dot Color Indication

<table>
<thead>
<tr>
<th>Pan Dot Color</th>
<th>Object/Bus</th>
<th>Automation Mode</th>
</tr>
</thead>
<tbody>
<tr>
<td>Green</td>
<td>Bus</td>
<td>Read</td>
</tr>
<tr>
<td>Orange</td>
<td>Object</td>
<td>Read</td>
</tr>
<tr>
<td>Red</td>
<td>Any</td>
<td>Any Write mode</td>
</tr>
<tr>
<td>Yellow</td>
<td>Any</td>
<td>Off</td>
</tr>
<tr>
<td>Gray</td>
<td>Object, but off/bypassed</td>
<td></td>
</tr>
</tbody>
</table>

About Object Bypass

Bypass can be used to establish a workflow where multiple source tracks are assigned to the same object but only one of them is sending pan metadata to control the panning on the Renderer. For more information, see “Dolby Atmos PEC/DIR Recorder Workflow Example” on page 1257.
Object/Bus Toggle Automation

The Object/Bus Toggle setting can be automated on object tracks. To be able to write Object/Bus Toggle automation for all Object tracks in the session, ensure that it is enabled in the Automation window. If you want to ensure that no Object/Bus Toggle automation is written at all, or if want to ensure that existing Object/Bus Toggle automation is not over-written, disable it in the Automation window.

Auto-Height Overrides Height Automation Option

With multichannel panning automation, Pro Tools lets you re-purpose existing Front, Rear, and Front/Rear pan automation for Height automation when mixing to Dolby Atmos (7.0.2 or 7.1.2). When this option is enabled, the selected auto-height mode overrides any Height automation, generating new height automation automatically. This way you don’t have to re-write all new automation when opening existing 5.1 or 7.1 sessions and re-mixing them for Dolby Atmos (7.0.2 or 7.1.2 panning).

💡 The Auto-Height Overrides Height Automation option defaults to on if the track already has a main output assignment prior to assigning an object output (assuming a re-use workflow). This option defaults to off when translating automation from the Dolby Atmos Panner plug-in and also when a track has an object output assigned but no main output assigned.

⚠️ To commit automatically generated height automation, use the Coalesce Pan Guide Automation command. See “Coalesce Pan Guide Automation” on page 1254.
To enable (or disable) Auto-Height Overrides Height Automation:

1. Open the Output window for the track you want.
2. Do one of the following:
   • Double-click the Height Mode selector.
   • Right-click the Height Mode selector and select (or deselect) Auto-Height Overrides Height Automation.

Coalesce Pan Guide Automation

When using the Auto-Height Overrides Height Automation option to automatically generate Height automation, you can commit that automation using the Coalesce Pan Guide Automation command. Committed Height automation is calculated by interpolating Front, Rear, and Front/Rear pan automation, and the selected Auto-Height mode.

To automatically generate Height automation from Front, Rear, and Front/Rear pan automation, and the selected Auto-Height mode for one or more tracks:

1. Select the tracks for which you want to generate Height automation.

Duplicating Object Track Pan Automation and Dolby Atmos Panner Plug-in Automation

When exchanging sessions between Pro Tools 12.8 and lower versions of Pro Tools (such as Pro Tools 12.7.1), you probably want to ensure that object tracks have duplicate automation for track panning (Pro Tools 12.8) and Dolby Atmos panner plug-in automation.

When opening an older session in Pro Tools 12.8, you may prefer to use pan automation for object tracks rather than Dolby Atmos panner plug-in automation.
To duplicate Dolby Atmos panner plug-in automation to track pan automation:

1. Select the object track (or tracks) with the Dolby Atmos panner plug-in automation you want to duplicate.

2. Choose Edit > Automation > Duplicate Dolby Atmos Plug-in automation to track pan automation.

All Dolby Atmos panner plug-in automation is duplicated as track pan automation. Both copies of the automation remain the same until you change the automation of one or the other. If you remove the Dolby Atmos panner plug-in from an object track, its automation is lost.

When opening a Pro Tools 12.8 session that uses pan automation to generate Dolby Atmos metadata in a lower version of Pro Tools (such as Pro Tools 12.7.1), the pan automation is lost. Duplicate the pan automation for object tracks to Dolby Atmos panner plug-in automation to ensure that these tracks playback as objects when opened in the lower version of Pro Tools.

To duplicate track pan automation to Dolby Atmos panner plug-in automation:

1. Select the object track (or tracks) with pan automation you want to duplicate.

2. Ensure that the Dolby Atmos panner plug-in is inserted on the track.

3. Choose Edit > Automation > Duplicate track pan automation to Dolby Atmos Plug-in automation.

All track pan automation is duplicated as Dolby Atmos panner plug-in automation. Both copies of the automation remain and remain the same until you change the automation of one or the other. If you remove the Dolby Atmos panner plug-in from the track, its automation is lost.

Object Controls Mix Attribute for Grouped Tracks

You can enable Object Controls in theGlobals tab of the Groups dialog to link Object Control mode and Object/Bus toggle for all object tracks in the Group.
Importing Object-Related Track Data from Another Session

When importing session data from another Dolby Atmos session, you can import the object output path assignments (if any) and the Bus/Object toggle setting for tracks selected for import. This is vital when importing tracks already defined as objects from another session.

To import object tracks from another session:

1. Choose File > Import > Session Data.
2. Navigate to the session from which you want to import object tracks, select it and click Open.
3. In the Tracks section of the Import Session Data dialog, identify the tracks you want to import (Source) and specify the Destination for each track (either create a new object track or replace an existing object track).
4. In the Track Data to Import selector, ensure that the Object Assignment and Toggle Setting option is enabled (this option is selected by default).
5. Configure the rest of the Import Session Data dialog as desired and click OK.

Import ADM files

A .wav (ADM BWF) file is a Broadcast Wave file that can include audio and Dolby Atmos metadata from a Dolby Atmos master.

After creating a Dolby Atmos master file set with the Dolby Atmos Renderer, you can use the Dolby Atmos Conversion Tool to convert the Dolby Atmos master to a .wav (ADM BWF) file.

Pro Tools can import a .wav (ADM BWF) file created by the Dolby Atmos Conversion Tool into a session with all audio and metadata converted to pan automation.

To import an ADM file into Pro Tools:

1. Create a new session.
2. Choose File > Import > Session Data.
3. Navigate to and select the .wav (ADM BWF) file you want to import.
4. Click Open.
5 In the Import Session Data dialog, select a Destination for the Source tracks in the .wav (ADM BWF) file.

6 Select what Custom Data to import:

**Object Pan Data** Imports Dolby Atmos metadata and converts it to track pan automation.

**Object Output Assignment** Imports object output path assignments for imported tracks.

**Add Object Group Name to Track Name** Lets you add the object group name to the Beginning or the End of the track name.

7 Configure any other Import Session Data settings as desired.

8 Click OK.

You can also import audio from .wav (ADM BWF) files using the Import Audio command or by dragging and dropping the file into a session. However, only the audio is imported.

For more information about .wav (ADM BWF) files, contact Dolby.

---

**Dolby Atmos PEC/DIR Recorder Workflow Example**

In a typical Dolby Atmos mix, two or more Pro Tools | HDX systems provide playback of tracks and stems. An additional Pro Tools | HDX system is configured as the recorder (dubber). The recorder also communicates with the Dolby Atmos Renderer.

By linking Object and audio recording on the Pro Tools recorder system, audio and metadata punch in/out occur simultaneously on the Pro Tools recorder.

**Metadata** Only for Object panning in the RMU (or rendering and mastering workstation). This includes Pro Tools tracks with their Object Toggle set to Object.

**Pro Tools Pan Automation** Only for Bus panning in Pro Tools (tracks with Object Toggle set to Bus.)

The following section is an example workflow of how to configure and operate Pro Tools and a Dolby Atmos Renderer.

**Configuring the Pro Tools Recorder**

**To configure the Pro Tools recorder system:**

1 Choose Setup > Peripherals, click to display the Atmos tab, then do the following:
   - If necessary, establish communication with the Dolby Atmos Renderer (see “Configuring the Network Connection for Pro Tools and a Dolby Atmos Renderer” on page 1239).
   - Disable Link Object and Audio Recording only if you do not want to record object metadata along with object audio.
To configure tracks and mix:

1. On each object track, set the Object Control mode to Record.

You can set the Object Control mode by clicking the Object Control button shown in the Track Output window, or in the Mix and Edit windows when showing Object view. If your system includes an S6 with a Master Post Module, you can use its Record arm switch.

2. Enable the desired Automation mode for each track (such as Touch, Latch, or Touch/Latch). On-screen, the pan dot turns red indicating the track is in an automation write mode.

3. Record enable all tracks (if using Destructive-Punch, be sure to Prepare DPE Tracks if necessary).

4. Begin playback and adjust parameters, toggling monitor source as needed.

5. When ready, punch in/out on the record tracks.

To close the Peripherals dialog:

- Click OK to close the Peripherals dialog.

Recommended: Choose Setup > Preferences, click to display the Operation tab, then do the following:

- Select Enable Automation in Record.
- Select PEC/Direct Style Input Monitoring.

You can set the Object Control mode by clicking the Object Control button shown in the Track Output window, or in the Mix and Edit windows when showing Object view. If your system includes an S6 with a Master Post Module, you can use its Record arm switch.

When PEC/Direct Style Input Monitoring is enabled, the Pro Tools Input Monitor switch label lights green and shows P (for PEC, playing back from disk), or is unlit and shows D (for Direct, input monitoring). When this setting is not enabled, the Input Monitor switch label shows I (Input) either lit green when Input mode is active, or unlit when playing back from disk.

Enable DestructivePunch, TrackPunch, or Quick-Punch. (For details, see the Pro Tools Reference Guide.)
Chapter 56: Ambisonics

Pro Tools Support for Ambisonics
(Pro Tools | Ultimate Software Only)

Pro Tools | Ultimate software provides support for 1st-, 2nd-, and 3rd-Order Ambisonics channel formats (4-, 9-, and 16-channel formats respectively). Import Ambisonics audio recordings, record Ambisonics audio in Pro Tools using Ambisonics miking techniques, or use supported 3rd-party AAX Ambisonics panning, and encoding and decoding plug-ins to create your own Ambisonics mixes from source audio tracks.

What is Ambisonics?

Ambisonics is a “full-sphere” surround sound technique that is capable of representing sound sources that are stationary or in motion, and at variable distances from above, below, and all around the listener. More interestingly though, higher order Ambisonics can represent sound sources that seem to remain fixed in a sound field while the listener’s perspective changes with their head position (as opposed to “head-locked” stereo mixes). Ambisonics audio mixes are used for 3D audio in virtual reality and gaming applications, as well as 360 video. However, the possibilities for Ambisonics are only just beginning to be explored commercially.

1st Order Ambisonics correspond to physical microphone pickup patterns using an omni-directional microphone in conjunction with figure-eight capsules oriented along three spatial axes. Miking for 1st Order Ambisonics is a three-dimensional extension of common Mid/Side stereo (M/S) miking techniques that adds additional difference channels for height and depth. This results in B-format audio (WXYZ), or 1st Order Ambisonics, which consists of four discrete audio channels: W for sound pressure (omni-directional—the M in M/S), X for the front-minus-back sound pressure gradient, Y for left-minus-right (the S in M/S), and Z for up-minus-down.

1st Order Ambisonics is most commonly used for horizontal-only surround because of positional errors and shading effects that result from adding a fourth microphone. Higher-order Ambisonics provide greater positional resolution of sound sources in the sound field. Higher-order difference signals are derived from several spatially distributed (usually omni-directional) capsules using sophisticated digital signal processing. Higher-order Ambisonics can also be rendered from channel-based audio recordings (such as mono and stereo) strictly using Ambisonics plug-in processing in Pro Tools.
Configuring the I/O Setup for Ambisonics

Pro Tools lets you create 1st-, 2nd-, and 3rd-Order Ambisonics input, output, and bus paths. Typically, you will only need to create bus paths in Ambisonics formats for most Ambisonics mixing workflows. Create Ambisonics Input paths if you will be recording Ambisonics right into Pro Tools using Ambisonics miking techniques (using specially configured microphone arrays or specialized commercially available Ambisonics microphones). It is unlikely that you would ever need to create Ambisonics Output paths unless you are playing back Ambisonics from one Pro Tools system and recording it on another Pro Tools system or using another system to decode Ambisonics audio.

To create an Ambisonics bus path:

1. Choose Setup > I/O and click the Bus tab.
2. Click the New Path button.
3. Create the busses that you need with the desired Ambisonics format.
4. Click Create.
5. Click OK to close the I/O Setup.
Ambisonics Sub-Paths

Any higher-order Ambisonics path can have lower-order Ambisonics sub-paths. For example, a 3rd-order Ambisonics path can have 2nd and 1st-order sub-paths, and a 2nd-order Ambisonics path can have a 1st-order sub-path. All supported orders of Ambisonics paths can have mono sub-paths. Since Ambisonics channels do not map directly to speaker channels, all other channel-width formats are disallowed as sub-paths for Ambisonics paths.

Channel Ordering for Ambisonics Audio Signal Paths

Ambisonics formats use discrete channel orderings that are distinct from channel-based surround formats (such as 5.1). In Pro Tools, the individual channels of all Ambisonics formats are numbered from left to right in the I/O Setup starting with 00 (or W in B-format) and increase incrementally. For example, the individual channels for 1st Order Ambisonics are 00, 01, 02, 03 (WXYZ); and for 2nd Order Ambisonics are 00, 01, 02, 03, 04, 05, 06, 07, 08.

The individual channels of Ambisonics formats do not correspond to speaker signal mappings like other surround formats (such as 5.1—L C R Ls Rs LFE). In most cases, use Ambisonics panning, encoder and decoder plug-ins to accurately mix and monitor Ambisonics mixes over headphones. However, even though Ambisonics formats do not directly map to common channel-based surround speaker configurations, various alternate speaker configurations can be used for the playback of Ambisonics mixes.

⚠️ Do not use multi-mono plug-ins following any Ambisonics plug-ins. Likewise, any plug-in processing of source tracks should only be inserted before Ambisonics plug-ins.
Ambisonics Mixes in Pro Tools

Creating Ambisonics mixes in Pro Tools usually entails using Avid-qualified third-party AAX Ambisonics panning plug-ins on source audio tracks and routing the output of those tracks to an Auxiliary Input track with an Ambisonics format–to-stereo plug-in for headphone monitoring. Ambisonics mixing workflows and configurations vary depending on the source material, specific Ambisonics plug-ins used, and required delivery formats.

Figure 6. Mono audio mixed in 2nd Order Ambisonics to stereo for headphone monitoring
Example—configuring Pro Tools to mix from a mono source audio track to a 2nd Order Ambisonics stereo mix using FB360 Audio plug-ins:

1. Ensure that the I/O Setup is configured with a 2nd Order Ambisonics bus path (see “Configuring the I/O Setup for Ambisonics” on page 1260).

2. Create a mono audio track with audio you want to mix to 2nd Order Ambisonics.

   - Depending on the Ambisonics panning plug-in you are using, source audio tracks can be mono or stereo, or even surround formats (such as 5.0 or 7.0) or Ambisonics formats (such as B-format).

3. Assign the Output of the track to the 2nd Order Ambisonics bus path.

4. Insert the FB360 Spatialiser plug-in on the track (if you want to process the audio with other plug-ins on the track, they must precede the Ambisonics plug-in).

   - Repeat steps 3–5 to create additional source tracks for the Ambisonics mix.

5. Create a 2nd Order Ambisonics Auxiliary Input track.

6. Assign the 2nd Order Ambisonics bus path to the Input of the Auxiliary Input track.

7. Insert the FB360 Control plug-in on the Auxiliary Input track.

8. Assign the Output of the Auxiliary Input track to the main stereo output of your audio interface for headphone monitoring.

   - In order to avoid coloring the audio projected from speakers with the room ambiance, Ambisonics mixes are typically monitored over headphones.

9. Automate panning of mono source to 2nd Order Ambisonics with the FB360 Spatialiser plug-in.

10. Playback and monitor Ambisonics mix over headphones.

   - Ambisonics panning, encoding and decoding plug-ins typically change the track channel width (such as mono to 2nd Order Ambisonics). It is important to know that for some Ambisonics plug-ins that change track channel widths you must first create the track with the appropriate channel format (such as mono source or 2nd Order Ambisonics input) and then assign the appropriate track output (such as mono to 2nd Order Ambisonics) before you can insert the appropriate Ambisonics plug-in.

   - Clip effects editing is not supported for clips on Ambisonics tracks. When a timeline selection is made that includes clips from both Ambisonics and non-Ambisonics tracks, only clips on non-Ambisonics tracks are processed by clip effects. If clip effects are applied to one or more clips on a non-Ambisonics track and then dragged-and-dropped to an Ambisonics track, clip effects processing of those clips play back, but clip effects for these clips cannot be edited until they are moved back to a non-Ambisonics track.
Part XI: Sync and Video
Synchronization allows one system to output time-code and the other device to *chase* (follow) that timecode. Pro Tools is synchronized to other devices using SMPTE/EBU timecode or MIDI Time-code.

**Pro Tools Synchronization Options**

There are several options for synchronizing Pro Tools to an external source or using Pro Tools as the master device.

**SMPTE Trigger Only**

This solution is useful for short projects if both systems are extremely close in speed, but even the best systems will rarely stay perfectly synchronized for longer than a couple of minutes.

**SMPTE Trigger Resolved with a SYNC HD**

(HDX and HD Native Systems Only)

You can use SYNC HD to resolve Pro Tools recording and playback speed with any of the following clock reference sources while slaving Pro Tools to timecode:

- LTC
- Video source
- House video reference (SD or HD)
- VITC
- 1x Word Clock
- AES/EBU “null” clock
- Pilot Tone
- Bi-Phase

This enables long-term, high-fidelity synchronization when all transports within the system are resolved to this common synchronization source, or by resolving to any variations in incoming time-code while slaving to timecode.
SMPTE Trigger while Locking to an Unresolved Source

SMPTE Trigger can be used with a SYNC HD to resolve Pro Tools recording and playback speed while slaving to LTC. This enables long-term, accurate synchronization by resolving to any variations in incoming timecode. SYNC HD also supports VITC and Bi-phase/Tach positional reference.

SYNC HD Synchronization Options

By adding a SYNC HD to your HDX or HD Native system, you can use Pro Tools as the master device in your synchronization setup. All other devices are then slaved to Pro Tools.

You can use Pro Tools in conjunction with a SYNC HD to generate LTC, MIDI Timecode, or MMC commands. When the SYNC HD is reading incoming SMPTE timecode, it regenerates the timecode through the LTC or MTC output connector. This signal can be passed along to other slave devices.

MachineControl

SYNC HD also supports MachineControl with Pro Tools | Ultimate software. MachineControl provides many specialized features for post production synchronization tasks including remote track arming, VTR emulation, serial timecode, and other capabilities. (See the MachineControl Guide for more information, or contact your dealer.)

For instructions on connecting a SYNC HD to your Pro Tools system, see the SYNC HD Guide.

Ext. Clock Output

Pro Tools can be used as the master device in your synchronization setup, where all other devices are then slaved to Pro Tools Word Clock output.

To set Ext. Clock Output:

1 In Pro Tools, choose Setup > Hardware.

2 Click the Ext. Clock Output pop-up menu and select an available signal.

3 Click OK to close the Hardware Setup dialog when you have finished.
Session Setup Window

The Session Setup window lets you configure various timecode-related settings on your system, as well as certain session format settings (such as bit depth, pan depth, audio format, and interleaved). The window also includes display-only areas for session sample rate, system delay, and timecode-related data (such as incoming time).

The Session Setup window is organized into three sections. The Format section is at the top of the window. The SYNC Setup & Timecode Offsets section and the Timecode Settings section can be shown or hidden.

The controls in this section configure SYNC HD settings. Settings are provided for Clock and Positional Reference, Video Ref Format, Video In Format, and Variable Speed Override.

To show the Session Setup window:
- From a Pro Tools session, choose Setup > Session.

Press Command+2 (Mac) or Control+2 (Windows) to open the Session Setup window.

To expand SYNC Setup & Session Offset section:
- Click the SYNC Setup & Timecode Offsets expand/collapse triangle.

The controls in this section provide timecode generation and freewheel options, and separate pull up and down selectors for audio and video rates.
Format Displays and Controls in the Session Setup Window

The Format section of the Session Setup window includes displays and controls for timecode-related settings on your system, as well as certain session format settings (such as bit depth, pan depth, audio format, and interleaved).

Sample Rate

This display indicates the sample rate for the current session.

Bit Depth

This menu indicates the bit depth for the current session. You can change the bit depth for all newly recorded or imported (and converted) files in the session by selecting a different Bit Depth option. For information on each option, see “Bit Depths” on page 155.

Clock Source

Use this menu to configure the system Clock Source. You can choose between a SYNC HD, an internal clock source from a peripheral, or an external clock source connected to an Avid HD audio interface.

Changes made to Clock Source in the Hardware Setup dialog will be reflected in the Session Setup window.

Clock Source Options

SYNC When using a SYNC HD, Pro Tools receives its clock source from the SYNC HD. The SYNC HD can in turn reference an external clock source, selected in the SYNC Setup section of the Session Setup window.

Internal In Internal mode, your system references your peripheral’s internal clock and plays back at the session’s sample rate.

External Clock Sources Depending on your audio interface, external Clock Source options can include AES/EBU, S/PDIF, S/PDIF Optical, ADAT Optical, TDIF, and Word Clock (optional word clock rates are available at higher session sample rates). External sources can be any multiple of the “base” rate. The base rate is 44.1 kHz for 88.2 and 176.4 kHz sources. The base rate is 48 kHz for 96 and 192 kHz sources. If an external source is chosen and no valid sync clock is detected at the External Clock In, the I/O reverts to Internal mode.

💡 If a SYNC HD is enabled in the Peripherals dialog, and is correctly connected in the Loop Sync chain, the SYNC HD can be the Loop Master, and your audio interfaces will clock as Loop Sync slaves.

For more information on external clock sources, see the SYNC HD Guide.

System Delay

When Delay Compensation is enabled (Options > Delay Compensation), this display indicates the total amount of delay (in samples) applied by the system to compensate for plug-ins and mixer routing delays.

Pan Depth

This menu lets you select the pan depth for stereo output paths in a Pro Tools session. Pan depth is the amount of signal attenuation when a track is routed to a stereo output and panned to center. For information on each option, see “Stereo Pan Depth” on page 1051.
Audio Format
This display indicates the current file format for files recorded in the session. You can change the audio file format for all newly recorded or imported (and converted) files in the session by selecting a different Audio Format option. For more information, see “Mixed Audio File Formats” on page 156.

Interleaved
Enable the Interleaved option to ensure that all newly recorded or imported (and converted) stereo or greater-than-stereo multichannel files in the session will be interleaved audio files. For more information, see “Interleaved Multichannel and Multi-Mono Audio Files” on page 156.

Session Start
Use this field to specify a SMPTE start time for your session. For more information, see “Setting a SMPTE Session Start Time (Start Frame)” on page 1275.

Session Length
Use this field to specify a limit for the length of the session in timecode (between 6 and 24 hours). Used in conjunction with the Session Start setting, the Session Length field lets you specify the desired working range for the session when Pro Tools is slaved to an external transport (such as with MachineControl, MMC, or Satellite Link). If a timecode location is received outside of this range, Pro Tools does not respond. Pro Tools responds only when a timecode location within the range is received. This prevents unintended jumps to the end of the timeline, thus providing intelligent handling of 24-hour timecode.

Incoming Time (Current Time)
This display indicates incoming timecode from an external source.

Timecode Rate
The Timecode Rate setting lets you set the SMPTE timecode rate for the current session.

Feet+Frame Rate
The Feet+Frame Rate setting lets you set the Feet+Frame rates for sessions. Supported rates include 23.976, 24, and 25 fps.

Set this rate to match the rate of the film projector, or the video if the film projector speed is taken into account. For example, doing a Telecine transfer from a 24 fps film projector to NTSC video would necessitate the projector running at 23.976 fps. This is regardless of whether the session is using pull down audio or not.

Timecode 2 Rate
The Timecode 2 Rate setting lets you set a secondary frame rate that can be displayed in the ruler alongside the main Timecode ruler. This lets you reference frame rates in the Timeline that are different from the session timecode rate (also see “Timebase Rulers” on page 837).
SYNC Setup and Timecode Offsets in the Session Setup Window

The SYNC Setup and Timecode Offsets section of the Session Setup window includes displays and menus for timecode-related settings on your system.

SYNC Setup
(HDX and HD Native Systems with a SYNC HD Only)

The controls in the SYNC Setup section of the Session Setup window let you configure SYNC HD settings, including clock reference, positional reference, video reference format, video input format, and Variable Speed Override (VSO).

Clock Reference

This menu lets you set the Pro Tools clock reference.

- When using a SYNC HD, the Clock Reference selector lists all supported clock types.
- When using HDX or HD Native systems without a SYNC HD, choices include any currently-enabled digital format or source available from your Avid HD audio interface (such as AES, S/PDIF, or 1x Word arriving at the HD audio interface’s Word Clock In port).

Positional Reference

Sets the timecode source for Pro Tools to use for positional reference.

Video Ref Format

Sets the video reference format for the SYNC HD.

Video In Format

Indicates the expected format at the Video In connector on the SYNC HD. At certain HD rates, a pop-up menu is provided for selecting a format.

Variable Speed Override (VSO)

Requires a SYNC HD. When a SYNC HD is connected to an HDX or HD Native system, the VSO controls are located in the SYNC Setup section of the Session Setup window.

For instructions on using VSO to varispeed Pro Tools playback, see the SYNC HD Guide.

When using Varispeed with HD MADI, it is possible to exceed the available bandwidth. When Varispeed exceeds the maximum frequency for the current nominal sample rate, audio drops out. The maximum frequency for Varispeed at each nominal sample rate is listed in the following table.

<table>
<thead>
<tr>
<th>Nominal sample rate</th>
<th>Channel Count</th>
<th>Maximum Frequency</th>
</tr>
</thead>
<tbody>
<tr>
<td>44.1/48 kHz</td>
<td>64</td>
<td>48.8 kHz</td>
</tr>
<tr>
<td>44.1/48 kHz</td>
<td>56</td>
<td>55.6 kHz</td>
</tr>
<tr>
<td>88.2/96 kHz</td>
<td>32</td>
<td>97.5 kHz</td>
</tr>
<tr>
<td>88.2/96 kHz</td>
<td>28</td>
<td>111.5 kHz</td>
</tr>
<tr>
<td>176.4/192 kHz</td>
<td>16</td>
<td>194.9 kHz</td>
</tr>
<tr>
<td>176.4/192 kHz</td>
<td>14</td>
<td>223.0 kHz</td>
</tr>
</tbody>
</table>
Ref Present, Locked, and Speed Cal Indicators

The Ref Present, Locked, and Speed Cal indicators in the SYNC Setup section of the Session Setup window display synchronization status of the SYNC HD. The Locked and Speed Cal indicators reflect the state of the same LEDs on the front panel.

**Ref Present Indicator** The Ref Present indicator lights when the Video Ref In connector is receiving a valid video signal.

**Locked Indicator** The Locked indicator lights solid green when the SYNCHD is locked to the selected clock reference. The Locked indicator flashes yellow if the selected clock reference source is missing or out of lockable range.

**Speed Cal Indicator** This indicator shows the status of the incoming clock reference:

- Yellow Solid: SYNC HD is locked and the clock reference is within 0.025% of the expected rate
- Yellow Flashing Fast: SYNC HD is locked but the clock reference is between 0.025% and 4% faster than the expected rate
- Yellow Flashing Slow: SYNC HD is locked but the clock reference is between 0.025% and 4% slower than the expected rate
- Red Flashing Fast: SYNC HD is locked but the clock reference is more than 4% faster than the expected rate
- Red Flashing Slow: SYNC HD is locked but the clock reference is more than 4% slower than the expected rate
- Unlit: SYNC HD is not locked to the chosen clock reference

External Timecode Offsets

In the External Timecode Offsets section, Pro Tools lets you compensate for devices that are consistently offset by a fixed number of frames (such as some color–corrected video masters), or for material that starts at a different time than the session.

Pro Tools provides four different types of External Timecode Offset settings. These offsets include:

- MMC (MIDI Machine Control)
- 9-Pin (Deck Control)
- Synchronization peripherals, including SYNC HD (HDX or HD Native systems only), or other peripherals (such as MIDI interfaces that provide MIDI Timecode).
- Satellite

Unique values can be defined for each of these types of offsets, or you can link all to adjust in unison.

Positive and negative offset values can be entered to offset Pro Tools timecode display later or earlier, respectively.

Additional options for External Timecode Offsets are available when using MachineControl with Pro Tools | Ultimate software. See the Machine-Control Guide for more information.
To redefine the External Timecode offsets:


2. In the Redefine External Timecode Offset dialog, enter the offset you want in the Desired Timecode Position field.

3. Click OK.

Sample Offset (Sync Offset)

This field creates an offset that lets you fine-tune the point at which Pro Tools synchronizes relative to incoming timecode. Use this to compensate for timing differences between various SMPTE-to-MIDI Timecode converters or analog-to-digital/digital-to-analog converters. For example, a value of –50 makes an event in Pro Tools occur 50 samples before the same event in incoming LTC, MTC, VITC, or Serial Timecode. However, this does not apply to synchronization for Satellite systems.

The Sample Offset field allows a range of plus or minus roughly one frame's length in samples. For instance, if the session is at 48 kHz and the Timecode Rate is 24 FPS, the range is +/-2002 samples (1 frame).

Timecode Settings in the Session Setup Window

Freewheel

The choices in the Freewheel section let you configure how Pro Tools will freewheel, or continue playback if timecode is interrupted or corrupted. Use these options to protect against errors that can occur if your SMPTE timecode source has “drop outs” or temporary lost signals.

None No freewheel is applied.

Frames Sets a number of frames to freewheel, from 1 to 120 frames. This value defaults to 8 frames, which is the recommended setting for most applications.

Jam Sync Lets Pro Tools trigger synchronization to incoming timecode, and continue to play back even if timecode input is completely interrupted. It can be useful if timecode is damaged, or has been accidentally erased from your source tape.

Pull Up/Down

When Pro Tools is used in conjunction with a SYNC HD, this option lets you “pull up” or “pull down” the current sample rate.

For more information on applying pull factors in Pro Tools, see “Pull Up and Pull Down” on page 1277.

⚠️ Pull up and pull down are applied differently in different workflows. Make sure you check each project’s specific workflow before you begin your work.
Chapter 57: Working with Synchronization

Preparing to Work with SMPTE

The first step when preparing to work with SMPTE is to choose an appropriate SMPTE frame rate. Pro Tools supports all standard SMPTE frame rates. If you are working with SMPTE striped tape, it is important to know the frame rate. In some cases, a SYNC HD can be used to do this.

Configuring Pro Tools for SMPTE

Synchronization and MachineControl system settings are enabled in the Pro Tools Peripherals dialog (Setup > Peripherals). These settings are system settings, and remain constant regardless of the particular session you are working on. Configure these settings before opening a session.

⚠️ MachineControl is supported on HDX and HD Native systems only.

Other settings are configured in the Session Setup window, such as the session Timecode rate, the Feet+Frames rate, the session start frame, and time display format. These settings are session-specific settings. These settings can only be configured when a session is open.

Selecting a SMPTE Format

To choose a SMPTE format:

1. In Pro Tools, choose Setup > Session.
2. Choose a frame rate (SMPTE format) from the Timecode Rate selector.
3. Enter the Timecode Freewheel frames (if any) in the designated box (see “Freewheel” on page 1274).

Setting a SMPTE Session Start Time (Start Frame)

The Session Setup window also allows you to set a SMPTE Start Frame for your session. Video work tapes are rarely striped beginning at a SMPTE frame address of 00:00:00:00. You can quickly enter a start time for your session based on an appropriate frame number from your project tape. The Pro Tools SMPTE-related functions (such as Spot mode) will then use this value as their reference for the session’s start point.

Start Time When Striping Tape

If you are generating timecode, it is a good practice to stripe your timecode beginning at 01:00:00:00 (subtracting time for the head format, such as initial black, bars and tone, or logos). This prevents problems that can occur with some synchronizers when the striped timecode crosses from 23:59:59:29 to 00:00:00:00 (commonly referred to as the “midnight” boundary).

To set a SMPTE Start Time for your session:

1. Choose Setup > Session.
2. Enter a SMPTE frame number in the Session Start field.

To capture an incoming SMPTE address as the session start time:

1. Click in the Session Start field.
2. Begin playback of the timecode source.
3. At the location where you want to capture the incoming value, press Equal (=) in the numeric keypad.
4 Press Enter to accept the value. You can then edit the captured address. The session uses the frame number you enter as its SMPTE start frame when online.

- If there are existing clips on the tracks and you are changing the original SMPTE start frame to a later time (from 00:00:00:00 to 01:00:00:00, for example), all existing clips on tracks will remain in their relative positions, but will start later by the time value added to the start frame.

- If you are changing the session start time in an open session in which tracks already exist, a warning dialog appears when you press Enter. Choose from one of two options:

  **Maintain Timecode** Places the additional session time at the start of the session, and keeps existing clips in their original timecode locations.

  **Maintain Relative Position** Places the additional session time at the start of the session, and maintains the relative position of existing clips to the new start frame. For example, if you change the session start frame from 01:00:00:00 to 00:59:00:00, Pro Tools adds one minute of session time to accommodate the new start frame, and moves all existing clips earlier in time to maintain their relative position to the start frame.

**Redefining a Feet+Frames Position**

Use the Current Feet+Frames command to redefine the Feet+Frames position at the current insertion point. The session start time is recalculated based on the new, relative Feet+Frames location.

Typically, this command is used for integrating test tones, pre-roll, Academy leader, and similar pre-program material into Pro Tools sessions. Redefining Feet+Frames does not redefine the session start time.

To set a relative frame position for a session (Feet+Frames):

1. With the Selector tool, click in a track (or make a selection) where you want to redefine the position.

   ![If your insertion or selection is not on a grid boundary, it will round to the closest boundary.](image)


3. Enter a Feet+Frame position to correspond to the timecode shown in the dialog.

4. Click OK.

**Redefining a Timecode Position**

Use the Current Timecode Position command to redefine the current timecode position and session start time. By creating an insertion point (or selection), and then entering the new timecode position for that location, the session start time will be recalculated based on the new, relative Timecode location.

To redefine a current Timecode code position:

1. With the Selector tool, click in a track (or make a selection) where you want to redefine the position.

   ![If your insertion or selection is not on a grid boundary, it will round to the closest boundary.](image)


3. Enter a new SMPTE frame number in the dialog to correspond to the timecode shown in the dialog.

4. Click OK.
Displaying Time in SMPTE Frames

In Pro Tools, you can set the Main Time Scale to Timecode (SMPTE) and this will be displayed in the Main Counter. Though Pro Tools will still synchronize to incoming SMPTE timecode if the Time Scale is displayed in Bars|Beats, Minutes:Seconds, or Feet|Frames, it is usually more useful to use SMPTE timecode as your reference.

To set the Main Time Scale to SMPTE Timecode, do one of the following:

- Choose View > Rulers > Timecode.
- Click the Main Counter selector in the Edit window and select Timecode.

Pro Tools displays timecode values in the currently selected SMPTE frame rate.

Sub Counter and Sub Time Scale Display

You can display a Sub Time Scale in the Sub Counter. For example, if the Main Time Scale is set to Timecode, and you want to compare SMPTE time to “wall clock,” when you are using 29.97 Non-Drop frame rate, click the Sub Counter selector and select Min:Secs as the Sub Time Scale.

Pull Up and Pull Down

Pro Tools supports up to 4% pull up and pull down, with support for an additional 0.1% up or down. Separate rates can be set for session audio and video (when video has been imported or captured into the session).

When referring to 4% pull up and pull down, the precise percentages used in pull ups is 4.167%.

While a SYNC HD is not required in order to use the extended pull up and down options provided in Pro Tools, a SYNC HD is the only device that can be controlled from within Pro Tools, and that recalls and restores pull factors automatically when a session opens. Other synchronization peripherals must be configured manually.

Pull up and pull down settings do not affect timecode generated by a SYNC HD.

Configuring Pull Up and Pull Down

To pull up or pull down audio or video:

1. Choose Setup > Session.

2. From the Timecode Settings section of the Session Setup window, select a Pull Up/Down Rate.

   - Audio Rate Pull Up/Down Controls the audio sample rate. See “Audio Sample Rate Pull Up and Down” on page 1278.
   - Video Rate Pull Up/Down Controls the video rate. See “Video Frame Rate Pull Up and Down” on page 1279.

   The choices available in these menus are determined by the session frame rate. Combinations can be applied by choosing from both menus.

   - 4% pull factors are not available in 176.4 and 192 kHz sessions.

Press Command+2 (Mac) or Control+2 (Windows) to open the Session Setup window.
The choices available in these menus are also determined by the Preferences and the Auto Match Pull Factors option in the Timecode Rate menu. See “Extended Pull Up and Pull Down Preference and Session Setup Controls” on page 1278 and “Auto Match Pull Factors” on page 1278.

**Extended Pull Up and Pull Down Preference and Session Setup Controls**

The Audio Rate Pull Up/Down setting offers all possible combinations of pull ups and pull downs for the audio sample rate, regardless of the session frame rate.

In addition, if there is a QuickTime movie in the Timeline, the video rate can be pulled up or down by 0.1%, regardless of the session frame rate. Though not a recommended workflow, earlier versions of Pro Tools also enabled pull down of QuickTime video clips when audio was pulled down, so this option is included in Pro Tools 5.3.1 and higher to maintain compatibility with earlier sessions.

**Auto Match Pull Factors**

The Auto Match Pull Factors option is available from the session Timecode Rate menu in the Session Setup window. When Auto Match Pull Factors is enabled, Pro Tools adjusts audio and video playback rates as needed to match any changes to the current session Timecode Rate.

Auto Match Pull is applied relative to the current pull up setting. While enabled, if the session frame rate is changed in such a way that the video would have to be pulled by an unsupported amount, the video remains unaffected.

This setting is latching, is not enabled by default, and its state is stored with the session.

**Example of Auto Match Pull Factors**

The Auto Match Pull Factors option links audio and video pull factors when changing session frame rate.

For example, assume a Pro Tools session is set to a frame rate of 25 fps, the audio and video are both playing with no pull ups, and Auto Match Pull Factors is enabled.

If you then change the session Frame Rate to 24 fps, both the Audio and Video Rate Pull settings would change by –4.0% (the appropriate pull setting required by the change in frame rate).

Auto Match-enabled pull factors are applied to any existing Audio Rate Pull Up/Down or Video Rate Pull Up/Down settings.

For example, if audio was already being pulled –0.1% when you changed the session Frame Rate from 29.97 to 24 fps, then the Audio Rate Pull Up/Down menu would switch to None.

**Audio Sample Rate Pull Up and Down**

The Audio Rate Pull Up/Down setting applies pull up or down factors to session audio record and playback. All pull rates are available, regardless of session frame rate.

See also “Auto Match Pull Factors” on page 1278.
Audio Rates and Pull Up/Down Options

The following table lists actual sample rates of each pull up and pull down option and combination (rounded to the nearest whole Hz):

Sample Rates at Pull Up and Pull Down Settings

<table>
<thead>
<tr>
<th>Pull Up/Down</th>
<th>Sample Rate</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>44100</td>
</tr>
<tr>
<td>+4.1667%</td>
<td>45983</td>
</tr>
<tr>
<td>and +0.1%</td>
<td></td>
</tr>
<tr>
<td>+4.1667%</td>
<td>45938</td>
</tr>
<tr>
<td>+4.1667% and –0.1%</td>
<td>45892</td>
</tr>
<tr>
<td>+0.1%</td>
<td>44144</td>
</tr>
<tr>
<td>–0.1%</td>
<td>44056</td>
</tr>
<tr>
<td>–4.0% and +0.1%</td>
<td>42378</td>
</tr>
<tr>
<td>–4.0%</td>
<td>42336</td>
</tr>
<tr>
<td>–4.0% and –0.1%</td>
<td>42294</td>
</tr>
</tbody>
</table>

Video Frame Rate Pull Up and Down

The Video Pull Up/Down setting lets you change the frame rate of video playback independently from the audio pull up/down rate. Note that video pull rates are saved with the session.

See also “Auto Match Pull Factors” on page 1278.

The choices available for Video Rate Pull Up/Down depend on the file format and frame rate of the video, and whether or not you are using video hardware.

With no video hardware, Pro Tools supports 0.1% pull up and pull down at all project frame rates when monitoring video in the Pro Tools Video window.

However, when monitoring with video hardware, certain frame rates only support pull in certain directions (as follows):

- 23pNTSC can only pull up by 0.1%
- 24pNTSC can only pull down by 0.1%
- 24pPAL can only pull up by 4%
- 25pPAL can only pull down by 4%
### Video Rates and Pull Up/Down Options

The following table summarizes which pull up or pull down rate is supported with hardware (both hardware and software) or only in the Pro Tools Video window (software only) for each project frame rate. Note that some pull up and down rates are not supported at all for certain project frame rates.

*Project rates and supported pull up and pull down with or without hardware*

<table>
<thead>
<tr>
<th>Project Frame Rate</th>
<th>1% pull up</th>
<th>1% pull down</th>
<th>4% pull up</th>
<th>4% pull down</th>
</tr>
</thead>
<tbody>
<tr>
<td>23pNTSC</td>
<td>both hardware and software *</td>
<td>software only</td>
<td>N/A</td>
<td>N/A</td>
</tr>
<tr>
<td>24pNTSC</td>
<td>software only</td>
<td>both hardware and software *</td>
<td>N/A</td>
<td>N/A</td>
</tr>
<tr>
<td>24pPAL</td>
<td>software only</td>
<td>software only</td>
<td>both hardware and software *</td>
<td>N/A</td>
</tr>
<tr>
<td>25pPAL</td>
<td>software only</td>
<td>software only</td>
<td>N/A</td>
<td>both hardware and software *</td>
</tr>
<tr>
<td>25i</td>
<td>software only</td>
<td>software only</td>
<td>N/A</td>
<td>N/A</td>
</tr>
<tr>
<td>30i</td>
<td>software only *</td>
<td>software only</td>
<td>N/A</td>
<td>N/A</td>
</tr>
<tr>
<td>720p23</td>
<td>software only *</td>
<td>software only</td>
<td>N/A</td>
<td>N/A</td>
</tr>
<tr>
<td>720p25</td>
<td>software only</td>
<td>software only</td>
<td>N/A</td>
<td>N/A</td>
</tr>
<tr>
<td>720p29</td>
<td>software only *</td>
<td>software only</td>
<td>N/A</td>
<td>N/A</td>
</tr>
<tr>
<td>720p50</td>
<td>software only</td>
<td>software only</td>
<td>N/A</td>
<td>N/A</td>
</tr>
<tr>
<td>720p59</td>
<td>software only *</td>
<td>software only</td>
<td>N/A</td>
<td>N/A</td>
</tr>
<tr>
<td>1080i50</td>
<td>software only</td>
<td>software only</td>
<td>N/A</td>
<td>N/A</td>
</tr>
<tr>
<td>1080i59</td>
<td>software only *</td>
<td>software only</td>
<td>N/A</td>
<td>N/A</td>
</tr>
<tr>
<td>1080p23</td>
<td>software only *</td>
<td>software only</td>
<td>N/A</td>
<td>N/A</td>
</tr>
<tr>
<td>1080p24</td>
<td>software only</td>
<td>software only *</td>
<td>N/A</td>
<td>N/A</td>
</tr>
<tr>
<td>1080p25</td>
<td>software only</td>
<td>software only</td>
<td>N/A</td>
<td>N/A</td>
</tr>
<tr>
<td>1080p29</td>
<td>software only *</td>
<td>software only</td>
<td>N/A</td>
<td>N/A</td>
</tr>
</tbody>
</table>

*Suggested pull rates for any given project frame rates appear highlighted in the Video Rate Pull Up/Down selector.*
Effect of Using Pull Up or Pull Down

This topic describes how related Pro Tools features are affected by pull up and down rates.

Video Pull Up and Pull Down and Timecode Ruler

Video pull up and down does not affect the Timecode ruler. Be sure to set the session Frame Rate to the correct frame rate for your project. For example, if working with 24 fps video and you pull the video up by 4%, switch the session Frame Rate to 25 fps to keep the Timecode ruler aligned. Similarly, if working with 24 fps video that is pulled down by 0.1%, switch the frame rate of the session to 23.976.

When working with 25 fps Avid media and the video is set to pull down by 4%, set the session Frame Rate to 24 fps.

Plug-Ins and Pull Up and Pull Down

For proper operation at larger (4%) pull rates, plug-ins must utilize sample clock instead of an absolute time clock. All Pro Tools audio plug-ins are based on sample clock.

Higher Sample Rates and Pull Factors

4% audio pull rates are not available in 176.4 and 192 kHz sample rate sessions.

Putting Pro Tools Online

To trigger playback or recording from an external source, the Pro Tools Transport must be placed online. This tells Pro Tools to listen for incoming timecode.

To put the Pro Tools Transport online, do one of the following:

- Choose Options > Transport Online.
- Click the Online button in the Transport.

Press Command+J (Mac) or Control+J (Windows) to put the Transport Online.

Clicking the Online button in the Transport

The Online button flashes while Pro Tools waits for a SMPTE frame to trigger playback. When timecode is received, playback begins and the Online button becomes highlighted. The Edit Selection indicators in the Edit window, and the Incoming Time field in the Session Setup window display the incoming timecode.

To take Pro Tools offline, do one of the following:

- Deselect Options > Transport Online.
- Deselect the Online button in the Transport window.
**Recording Online**

The Operation Preferences page contains two options that affect how Pro Tools initiates recording when online.

**Record Online at Timecode (or ADAT) Lock** Makes online recording begin as soon as Pro Tools receives and locks to timecode or ADAT sync. In this case, you do not need to make an insertion or selection in a track to designate a start point.

**Record Online at Insertion/Selection** Makes online recording begin wherever you have placed the insertion point in a track. Recording then continues until Pro Tools stops receiving timecode. If you make a Timeline selection, Pro Tools will record online only for the length of the selection.

---

**Generating Timecode**

Using a SYNC HD, Pro Tools can generate SMPTE and MIDI Timecode (MTC). Without a SYNC HD, Pro Tools can only generate MTC. This lets Pro Tools function as a master synchronization source with other devices slaved to it (or chasing it).

**To generate MIDI Timecode from Pro Tools:**

1. Choose Setup > Peripherals and click the Synchronization tab.
2. From the MTC Generator Port setting, select the MIDI output port on which you want to transmit MIDI Timecode (MTC).

**To generate timecode using a SYNC HD:**

1. Connect the SYNC HD LTC Out to the SMPTE in connector on the devices you are slaving. If you are slaving a device that recognizes MTC, connect the MTC OUT connector of the SYNC HD to the MIDI IN connector of the slaved device.
2. Make sure your SYNC HD is powered on.
3. In Pro Tools, choose Setup > Peripherals and click the Synchronization tab.
4. In the Synchronization Device section of the Synchronization page, select Enable SYNC Peripheral.
5. Click OK to close the Peripherals dialog.
6. Choose Setup > Session, and choose the appropriate frame rate for the Timecode Rate setting.
7. In the SYNC Setup section of the Session Setup window, choose a clock reference from the Clock Reference selector. Not all clock choices are available at all sample rates. See “External Clock Sources” on page 1270.)
8. From the Transport Window menu (or the Edit Window menu), select Synchronization.
9 Select one of the following:
- Gen MTC to generate MIDI Timecode.
- Gen LTC to generate Linear Timecode.

10 Start playback.

Pro Tools generates and outputs timecode from the SYNC HD.

Limitations for SYNC HD Locked to Video Input or Video Reference

A SYNC HD can generate timecode at any frame rate when locked to Video Reference or Video In, regardless of the frame rate of the incoming video reference signal. However, if you choose to generate timecode using a frame rate which does not match that of the video signal, the frame edges in the Pro Tools session (and the frame edges of the timecode you are generating) will not be aligned with the video frame edges.

⚠️ If you change timecode rates in the middle of a session, many SMPTE-to-MIDI Timecode converters need to be turned off and turned on again to recognize the new frame rate.

Using MIDI Machine Control

Pro Tools provides the capability to transmit location information to external devices and to control their transports using MIDI Machine Control (MMC).

Controlling External Devices Using MMC

Any device that supports MMC can be controlled directly from within Pro Tools, with either the device or Pro Tools acting as clock master.

The external devices supported by Pro Tools implement “open loop” communications only. Because of this, while Pro Tools is the Transport Master, any direct operation of the receiving device’s transport will not be communicated back to Pro Tools. Instead, you can use the Transport popup to select the external device (MMC in the popup) and use the Pro Tools on-screen transport controls to drive the device.

Pro Tools does not support remote track arming of MMC-controlled external devices. You need to manually arm tracks for recording on the external device.

Pro Tools | Ultimate with MachineControl option supports remote track arming for Sony 9-pin and V-LAN enabled devices. See “Remote Track Arming” on page 1287.
Enabling MIDI Machine Control in Pro Tools

Pro Tools as MMC Master

When Pro Tools is the Master, it sends MMC commands to the slave device and receives MTC information back from the slave device.

To slave an external device to Pro Tools using MIDI Machine Control:

1. Connect a MIDI Out port on your Pro Tools MIDI interface to an appropriate port on the slave device.

2. Connect the MTC out from the slave device to a MIDI In port on your Pro Tools MIDI Interface.

3. In Pro Tools, choose Setup > Peripherals and click the Synchronization tab.

4. Deselect the Enable SYNC HD option if it is selected.

5. From the MTC Reader Port pop-up menu, select the MIDI In port to which the slave device is connected (the source of MTC information from the slave device).

6. Click the Machine Control tab in the Peripherals dialog.

7. In the MIDI Machine Control (Master) section, select Enable.

8. In the MIDI Machine Control (Master) section, select the MIDI Out port to which the slave device is connected from the pop-up menu.

9. Set the MMC ID number for which this information will be sent in the “ID” field.

MMC commands contain an ID number to identify which machine should respond to the MMC command. There are 128 MMC ID numbers, from 0–127. The default of ID #127 is a special setting that transmits to all 128 MMC IDs. With a setting of 127, Pro Tools will transmit MMC commands to all MMC IDs.

10. Set a pre-roll time for your MMC slave device. Pre-roll is needed to provide the device with sufficient time to lock to the timecode transmitted by Pro Tools. This value will vary depending on the external device. If the pre-roll time is insufficient, the device may not be ready to lock until after the current timecode position has passed.

11. Click OK to close the Peripherals dialog.

12. In the Pro Tools Transport window, Right-click the Online button and select Transport > MMC.
Pro Tools will now be able to control the selected device’s transport and act as the clock master.

13 To have the Pro Tools transport chase the playback location of the slave device, click the Online button in the Transport window so that it flashes blue.

**Pro Tools as MMC Slave**

When Pro Tools is the slave, it receives MMC commands from the master device and sends MTC information back to the slave device.

💡 *In order for Pro Tools to receive MMC commands, the MMC source must be enabled in the MIDI Input Enable dialog. For more information, see “Enabling Input Devices” on page 538*

**To slave Pro Tools to an external device using MIDI Machine Control:**

1 Connect a MIDI In port on your Pro Tools MIDI interface to an appropriate port on the master device.

2 Connect a MIDI Out port on your Pro Tools MIDI Interface to the MTC in port on the master device.

3 In Pro Tools, choose Setup > Session.

4 In the Timecode Settings section of the Session Setup window, select Using MTC.

5 Choose Setup > Peripherals and click the Synchronization tab.

6 Deselect the Enable SYNC HD option if it is selected.

7 From the MTC Generator Port pop-up menu, select the MIDI Out port to which the master device is connected (this the destination of MTC information from Pro Tools).

8 Click the Machine Control tab in the Peripherals dialog.

9 In the MIDI Machine Control (Slave) section, select Enable.

10 Set the MMC ID number (channel) on which this information will be received in the “ID” field.

11 Click OK to close the Peripherals dialog.

Pro Tools will now respond to MMC commands from the external device.

**Operating MMC Devices with the Pro Tools Transport**

You can use the Pro Tools Transport window as the remote controller for all your enabled devices (such as a nonlinear video deck). To do so, set the enabled devices to listen to the address you enter for MMC. The Transport window will then drive the Pro Tools transport and any slaved devices.
To control external devices from the Pro Tools Transport:

- Right-click the Online button in the Transport and select either Pro Tools or MMC. The selected deck will act as Transport Master.

Selecting the Transport Master

- When the Transport Master is set to Pro Tools, the playback position is governed by the on-screen cursor in Pro Tools.
- When the Transport Master is set to MMC, the playback position is governed by the external device’s play position.

MMC Transport Settings

When using MMC, you can set the following options for machine transport behavior in the Synchronization Preferences page.

Machine Chases Memory Location When selected, navigating to a specific location in a session with a Memory Location causes a connected transport to chase to that location.

Machine Follows Edit Insertion/Scrub When selected, navigating to a specific location in a session by moving the selection point or by scrubbing a track causes a connected transport to chase to that location.

Taking a Device Offline

Use the Transport Online Right-click menu to take a MIDI (or Machine) device offline.

To take a device offline:

1. Click the Transport Master selector.

2. In the Transport, click on the Online pop-up menu and deselect the device (Machine or MIDI). Device choices depend on the current Transport Master and which devices have been set up in Pro Tools.

Deselecting Online > MMC

To bring a device back online, click and reselect it in the Online pop-up menu.

The Online pop-up menu will only display devices that have been properly set up in Pro Tools.

To set up MIDI devices, see “Enabling MIDI Machine Control in Pro Tools” on page 1284.

To set up machine devices, see the Machine-Control Guide.

Setting Minimum Sync Delay

Lock-up time delay is the initial amount of prime time your system’s devices need to achieve synchronization “lock.” This amount varies for each device. Pro Tools lock up delay is set by entering a value for Minimum Sync Delay in the Synchronization preferences. The lowest value available is 15 frames. Find the shortest possible lock-up time that your equipment can operate at consistently, and set
this as the Minimum Sync Delay. On systems utilizing MachineControl, enabling the Use Serial Timecode setting in the Session Setup window will make machines lock up much faster. (Serial timecode requires both the SYNC HD and external devices to be locked to house video reference.)

To set a Minimum Sync Delay:

1. Choose Setup > Preferences, and click the Synchronization tab.
2. Enter a number of frames in the Minimum Sync Delay field.
3. Click OK to close the Preferences dialog.

Configuring Minimum Sync Delay for External MMC Devices Locked to House Sync

When controlling a house-synced device from Pro Tools through MMC, the device will first lock to the MMC location and then align the color framing. Within house sync code are 4 frames for ensuring color frame lock. If the minimum synchronization setup time is less than the time required to achieve both location and color frame lock, playback will begin before the device has aligned the color frames. In this scenario, you should set the Minimum Sync Delay to be more than the time required for color frame lock. This is not a problem with a SYNC HD, which will drop out of lock until the color frame is locked.

Spotting Clips to SMPTE Frame Locations

Spotting is the process of assigning music and sound cues to specific SMPTE frame locations in a film or video. This function can be used to spot:

- Entire clips, selected with the Time Grabber tool. Multiple clips can also be selected, and Pro Tools will reference the first clip in your selection.
- A specific location within a clip, by clicking with the Selector tool at that location, and choosing Clip > Identify Sync Point.
- Sessions or tracks, dragged from a browser to the session Timeline or Clips List.

Spot Mode

In Spot mode, a clip in a track can be quickly spotted by simply clicking it with the Time Grabber tool.

You can also drag a clip from a Workspace browser, or from the Clips List, to a track while in Spot mode.
The Spot Dialog

The Spot dialog appears when you drag a clip to a track or click a clip with the Time Grabber tool in Spot mode. The numeric fields function as both data displays and editing controls for the currently selected clips.

Information in these fields is displayed in SMPTE Timecode, Minutes:Seconds, Feet:Frames, Samples, or Bars:Beats, depending on which Time Scale format is selected.

Spot dialog

A highlighted numeric field indicates the current active field for numeric entry editing. Entering a value in a field allows you to move a selected element to the time location that you enter. The Start, Sync Point, and End fields are accessible when the Time Grabber tool is active. Only the Start or End (depending on where you click the mouse) and Duration fields are active when one of the Trim tools is active (see “Using the Trim Tools in Spot Mode” on page 1290).

Use Subframes Option

A subframe is 1/100th of a frame. The Use Subframes option enables you to use these smaller units for greater accuracy. This command adds an additional time field in the SMPTE hours:minutes:seconds:frames box, which appears as the far right time field when enabled. Use a Period (.) to separate subframe values from whole frames.

Additional time field with “Use Subframes” enabled

Subframe measurements are not available in the Current Time field.
Capturing Timecode

Pro Tools also allows you to easily capture frame locations on the fly in the Spot dialog by pressing the Equal key, or by clicking the Current Timecode button while valid timecode is being received by Pro Tools. With VITC, you can accurately capture a paused or crawling VTR’s SMPTE location.

When Timecode is selected for the Time Scale, pressing the Equal key captures the incoming timecode. When Bars|Beats is selected for the Time Scale, pressing the Equal key will capture to the nearest measure.

Although Capture Timecode works with free-running Linear Timecode (LTC) or VITC, frame numbers of a paused frame can only be captured with VITC.

SYNC HD can read VITC. With MachineControl and a SYNC HD, you can also read serial timecode.

To use Remote mode with MachineControl, you will need an approved serial port. For a complete list of currently approved ports, visit http://avid.force.com/pkb/articles/en_US/compatibility/en352813.

To spot a clip to a specific SMPTE frame:

1. Enable Spot mode.
2. Set the Main Time Scale to Timecode. (See “Setting a SMPTE Session Start Time (Start Frame)” on page 1275.)
3. Identify the SMPTE frame location where you want to trigger playback of your clip by pausing your video deck on that frame.
4. With the Time Grabber tool, click a clip in a track, or in the Clips List, and drag it into a track. The Spot dialog appears.
5. Enter the SMPTE frame location by doing one of the following:
   - If you are using VITC, you can press the Equal (=) key on the numeric keypad, or click Current Timecode to enter a paused VTR’s current SMPTE location.
   - If you are using LTC, when Timecode is selected for the Time Scale, press the Equal (=) key on the numeric keypad to capture the incoming timecode. When Bars|Beats is selected for the Time Scale, press the Equal key to capture the nearest measure.
6. If you recorded the clip while online, you can use the Original Time Stamp button to recall and enter the SMPTE frame location at which the clip was originally recorded. You can also access a user-defined Time Stamp by clicking the User Time Stamp button. See “Time Stamping” on page 1290 for more information.
7. Click OK to close this dialog. The clip spots to the chosen SMPTE frame location. When the session is online, this frame number will trigger playback of the clip.
Auto-Spotting Clips

The Pro Tools Auto-Spot Clips option simplifies the task of spotting clips even further. If you are using VITC with this option enabled, or Machine-Control, you can pause your video at an appropriate SMPTE frame location, click a clip with the Time Grabber tool, and the clip will be automatically spotted to the current timecode location.

You can also use MachineControl’s serial timecode ability to auto-spot by enabling MachineControl and enabling serial timecode in the peripheral.

To Auto-Spot a clip:

1. Choose Options > Auto-Spot Clips.

2. If you are using VITC, identify the SMPTE frame location where you want to trigger playback of your clip by pausing your video deck on that frame.

3. Click the clip with the Time Grabber tool. The clip will be automatically spotted to the current timecode location (or machine location).

*Clicking a clip with any of the Trim tools will allow you to trim the clip to the current timecode location.*

*Auto-spotted clips are spotted by their start times, unless you have identified a Sync Point (see “Identifying a Synchronization Point” on page 1292). If the clip contains a Sync Point, the clip is spotted to it.*

Using the Trim Tools in Spot Mode

You can use the Spot dialog to trim your clips, including start/end/duration times and referencing incoming timecode addresses. If you click a clip with any of the Trim tools in Spot mode, the Spot dialog will appear, allowing you to enter a value in the Start or End and Duration fields to specify exactly where you want to trim the clip’s beginning or end. Use this to edit the length of a clip to correspond to a particular visual “hit point.”

Trimming a clip that contains a sync point (see “Identifying a Synchronization Point” on page 1292) does not affect the SMPTE location of the sync point, unless the clip is trimmed past the sync point.

Time Stamping

Pro Tools time stamps every clip recorded online with the original SMPTE time at which audio was recorded. You can recall this original SMPTE time for a clip by clicking the Original Time Stamp button in the Spot dialog.

You can also spot a clip to a separate user-defined SMPTE time stamp, defined using the Time Stamp command in the Clips List menu. Once the clip is time stamped using this command, you can click the User Time Stamp button to re-spot a clip to its user-defined SMPTE location.
Show Original Timecode in Clips

This command displays the original “time stamped” SMPTE times in all clips currently placed in tracks. This SMPTE frame number represents the time at which the clip was originally recorded online with Pro Tools, and does not necessarily reflect the clip’s current SMPTE location in a track.

To show (or hide) Original Time Stamps in clips:

- Select (or deselect) View > Clip > Original Time Stamp.

Creating a User Time Stamp

If you want to create a separate user-defined SMPTE time stamp, you can use the Time Stamp command in the Clips List menu. This command lets you select a clip (or clips) and redefine its SMPTE time stamp. The Original Time Stamp and the User-Time Stamp are then stored with your session.

When audio is first recorded, the User Time Stamp will match the Original Time Stamp, but you can change the User Time Stamp at any time using the Time Stamp command. This feature is particularly useful in post production situations where the SMPTE timecode on video “work prints” often changes from one edit revision to another.

To time stamp a clip (or clips) with a new SMPTE frame number:

1. In a track, select the clip that you want to time stamp.
2. From the Clips List menu, choose the Time Stamp command.

To show (or hide) User Time Stamps in clips:

- Select (or deselect) View > Clip > User Time Stamp.
Identifying a Synchronization Point

The Pro Tools Identify Sync Point command lets you identify a specific point within a clip for audio spotting purposes.

Imagine the following sound effects spotting scenario: You have a single sound effect that consists of a creaky door slamming shut, followed by a few seconds of ambient reverberation. The slam portion of the effect—which you must precisely match to picture—occurs neither at the very beginning of the audio file nor at the very end. It is somewhere in the middle, making it tough to spot. In this scenario, use the Identify Sync Point command to create a point in the clip and synchronize that point to a SMPTE frame.

For more information on Sync Points, see “Sync Points” on page 905.

To create a sync point in a clip:

1. Do one of the following:
   - Click with the Selector tool at the point in the clip that you want to synchronize to a SMPTE frame location.
   - Press the Down Arrow key while playing back.

2. Choose Clip > Identify Sync Point. The current SMPTE time is automatically entered as the SMPTE location for the sync point. A small down arrow appears at the bottom of the clip, with a vertical, light gray line indicating the location of the sync point.

Troubleshooting SMPTE Synchronization

If you are having problems getting SMPTE synchronization to work properly, you can troubleshoot your system and solve common problems.

Stripe SMPTE Before You Record

All tapes in your setup (both audio and video) must be striped with SMPTE Timecode before any audio is recorded onto them or to Pro Tools. If tapes aren’t striped, your system may seem to work, but synchronization will never properly occur. The machines and Pro Tools will drift farther and farther apart the longer they run.

The same problem occurs when audio is recorded into Pro Tools without a resolved SMPTE source (for example, if it was recorded before the current session). The audio cannot be accurately synchronized with an analog tape recorder or video tape deck, since the Pro Tools audio was not recorded referenced to the SMPTE timecode from the analog tape deck or video tape deck.

Resolve All Components of Your System

When striping timecode, make sure that the timecode generator and the video record deck are resolved to the same crystal reference. For example, when striping 29.97 Drop Frame timecode onto a VTR, both the SMPTE generator and the VTR should be resolved to the same “black burst” or house sync generator. During playback, the master deck should be resolved to “black burst” or house sync.
This convention provides compatibility for your tape between the record and playback passes, and when it is played back in other facilities on different equipment. This also means that when playing back a tape striped with timecode, the playback deck should be resolved to the same synchronization rate as the record deck was resolved to at the time of the striping. When you stripe timecode using an audio transport, it should be “free-running” and unresolved, but should be resolved with a house sync-referenced synchronizer during playback.

**Know the True Frame Rate on Your Media**

If you get your media from a production company instead of recording them yourself, be absolutely sure that they indicate the SMPTE frame rate used on the tape correctly. Several timecode formats use the same frame count (such as 23.976 fps and 24 fps) yet they run at slightly different frame rates per second.

A SYNC HD (and some third-party products) can be used to help determine frame rate.

**29.97 fps Non-Drop Rate Not Recognized**

29.97 fps Non-Drop is a slightly slower version of 30 fps Non-Drop timecode. When 29.97 fps Non-Drop is used with color video, each video frame matches up with each SMPTE frame without having to use a drop-frame coding. This makes any frame number mathematics much simpler, since no frame numbers are dropped.

Some hardware and software devices do not recognize 29.97 Non-Drop as a separate frame rate. For example, any standard SMPTE-to MTC-converter does not explicitly recognize it. You must set the converter to expect 30 fps Non-Drop instead. In fact, many devices that read SMPTE work acceptably by reading 29.97 Non-Drop if they are set to expect 30 fps Non-Drop.

Any SMPTE reader that uses the timecode numbers to make real-time calculations (as Pro Tools does when it tries to trigger and synchronize to SMPTE) also needs to know that the frame format is 29.97 and not 30 fps. Since Pro Tools allows this choice of frame rate this does not really pose a problem. The problem exists because many users cannot readily distinguish 29.97 from 30 fps.

Even though NTSC tapes only use 29.97, some production companies will distribute video work prints striped with 29.97 fps but mark them as “30 fps NTSC,” by which they actually mean 29.97 fps Non-Drop.

By the time you get the tape, you may have no idea what’s actually on it. Feeding 29.97 Non-Drop to Pro Tools when it is set for 30 fps Non-Drop will result in timing errors of about 1.8 frames per minute, causing audio playback to trigger out of sync.

**Use a Consistent Clock Source**

When possible, media files should be played back using the same sync reference signal they were recorded with. This assures the closest match between record and playback sample rates.
Speed Correction for Film, NTSC Video, and PAL Video

Frame rates, telecine transfers, and relative playback speeds
### Sample Rate Conversion Using Source Sample Rates at Pull Up and Pull Down Setting

<table>
<thead>
<tr>
<th>From:</th>
<th>To:</th>
<th>Pull:</th>
<th>Source Sample Rate</th>
<th>Destination Sample Rate</th>
</tr>
</thead>
<tbody>
<tr>
<td>NTSC Video</td>
<td>PAL</td>
<td>+0.1% then +4.1667%</td>
<td>45983 50050 91967 100100 n/a n/a</td>
<td></td>
</tr>
<tr>
<td>Film</td>
<td>PAL</td>
<td>+4.1667%</td>
<td>45938 50000 91875 100000 n/a n/a</td>
<td></td>
</tr>
<tr>
<td>NTSC Video</td>
<td>Film</td>
<td>+0.1%</td>
<td>44144 48048 88288 96096 176576 192192</td>
<td></td>
</tr>
<tr>
<td>Film</td>
<td>NTSC Video</td>
<td>–0.1%</td>
<td>44056 47952 88112 95904 176224 191808</td>
<td></td>
</tr>
<tr>
<td>PAL</td>
<td>Film</td>
<td>–4.0%</td>
<td>42336 46080 84672 92160 n/a n/a</td>
<td></td>
</tr>
<tr>
<td>PAL</td>
<td>NTSC Video</td>
<td>–4.0% then 0.1%</td>
<td>42294 46034 84587 92068 n/a n/a</td>
<td></td>
</tr>
</tbody>
</table>

NTSC Video = 23.976/29.97 fps  
Film = 24/30 fps  
PAL = 25 fps

### Sample Rate Conversion Using Destination Sample Rates at Pull Up and Pull Down Setting

<table>
<thead>
<tr>
<th>From:</th>
<th>To:</th>
<th>Pull:</th>
<th>Source Sample Rate</th>
</tr>
</thead>
<tbody>
<tr>
<td>NTSC Video</td>
<td>PAL</td>
<td>+0.1% then +4.1667%</td>
<td>42294 46034 84587 92068 n/a n/a</td>
</tr>
<tr>
<td>Film</td>
<td>PAL</td>
<td>+4.1667%</td>
<td>42336 46080 84672 92160 n/a n/a</td>
</tr>
<tr>
<td>NTSC Video</td>
<td>Film</td>
<td>+0.1%</td>
<td>44056 47952 88112 95904 176224 191808</td>
</tr>
<tr>
<td>Film</td>
<td>NTSC Video</td>
<td>–0.1%</td>
<td>44144 48048 88288 96096 176576 192192</td>
</tr>
<tr>
<td>PAL</td>
<td>Film</td>
<td>–4.0%</td>
<td>45938 50000 91875 100000 n/a n/a</td>
</tr>
<tr>
<td>PAL</td>
<td>NTSC Video</td>
<td>–4.0% then 0.1%</td>
<td>45983 50050 91967 100100 n/a n/a</td>
</tr>
</tbody>
</table>

NTSC Video = 23.976/29.97 fps  
Film = 24/30 fps  
PAL = 25 fps
Chapter 58: MachineControl

Pro Tools | Ultimate software with HDX and HD Native systems provides MachineControl™, which enables serial communication with Sony® 9-pin compatible synchronizers, and video or audio machines.

**MachineControl Requirements**

MachineControl requires a qualified HDX or HD Native system running Pro Tools | Ultimate software.

**Serial Deck Control Mode Requirements**

**For Tighter Lockups**

- For Serial Deck Control, use of a SYNC peripheral is recommended, such as SYNC HD.
- For near sample accurate Serial Deck Control, a SYNC peripheral is required.
- If you are not using a SYNC peripheral with Pro Tools, some features of MachineControl can be used by connecting the deck to the computer with the proper cable and adapter configuration.

See “Connecting Machines for Serial Control Mode” on page 1299.

**Remote 9-Pin Deck Emulation Requirements**

A SYNC peripheral is required when running MachineControl 9-Pin Remote Deck Emulation mode, as it provides frame-accurate LTC.

*Remote 9-Pin Deck Emulation does not work using the serial ports on a SYNC peripheral or using the Serial port on an HDX card, HD Native card, or HD Native Thunderbolt. Instead, you must connect the remote controller to your Pro Tools system using one of the methods detailed in “Connecting Machines for Remote 9-Pin Deck Emulation Mode” on page 1299.*

**MachineControl Components**

To use MachineControl with Pro Tools | Ultimate software you will need the following components, based on your operating system:

**Mac Systems**

- Serial Deck Control cable: Male 8-pin mini-DIN to male 9-pin cable
- Remote 9-pin Deck Emulation cable: Male 8-pin mini-DIN to female 9-pin cable

**Windows Systems**

- Serial Deck Control cable: RS-232 to RS-422
- 9-pin Turnaround adapter (for Remote 9-pin Deck Emulation mode)
Cables and Connections

MachineControl requires its own connections between Pro Tools hardware, the computer, and external machines. Connections differ depending on your Pro Tools audio interface, operating system, and on which of the two MachineControl operational modes you want to use: Serial Deck Control mode or Remote 9-Pin Deck Emulation mode.

When using a supported third-party paddle device with Pro Tools, you can use both Serial Deck Control mode and Remote 9-Pin Deck Emulation mode simultaneously. See “Using a Paddle Device in Local Mode” on page 1324 for more information.

Cables

MachineControl comes with the following cables and adapters, depending on your computer platform:

Mac Systems

Serial Deck Control Cable Male 8-pin mini-DIN to male 9-pin cable, for Deck Control.

Remote Deck Emulation Mode Cable Male 8-pin mini-DIN to female 9-pin cable, required for Remote 9-Pin Deck Emulation.

Windows Systems

Serial Deck Control Cable RS-232 to RS-422 cable, for serial timecode and all other MachineControl functions.

Turnaround Adapter 9-pin adapter, used with RS-232 to RS-422 cable, for Remote 9-Pin Deck Emulation.

For computers that do not have serial ports, a supported USB serial adapter (not provided) is required to make the MachineControl connection. For a list of qualified USB serial adapters, visit www.avid.com/compatibility.

Serial Deck Control Mode

Serial Deck Control mode supports bi-directional communication between Pro Tools and a compatible external machine. With this feature you can:

• Synchronize to serial timecode
• Arm tracks on the machine remotely
• Control a transport from Pro Tools
• Configure machine settings and options.

Pro Tools HDX and HD Native Systems

With Pro Tools HD and HDX or HD Native hardware, you can use a Serial to 9-pin connection or a 9-pin to 9-pin connection for Serial Deck Control mode.

CPU to Deck Connection This type of connection yields the best performance, especially with linear decks. Use the included Serial Deck Control cable for this type of connection.

SYNC Peripheral to Deck Connection This type of connection is suitable for non-linear decks. If you are using a SYNC peripheral, as many as two machines can be connected to the two 9-pin Out ports on the SYNC peripheral. You can control one machine at a time, and switch between them from within Pro Tools. These ports support all MachineControl modes except Remote 9-Pin Deck Emulation mode. For Remote Deck Emulation mode on Mac systems, a supported USB serial adapter is required.

Do not substitute 9-pin or serial adapters for either MachineControl cable. Each cable is specifically wired for one operation mode.
Remote 9-Pin Deck Emulation Mode

This mode enables a form of *deck emulation* in Pro Tools. When the Remote 9-Pin Deck Emulation Mode cable is used on a supported system, Pro Tools can respond to record-arming, transport, and other standard 9-pin commands from an external machine.

While in Remote 9-Pin Deck Emulation mode, Pro Tools always generates timecode, and can be either the timecode master or a slave device.

- On Mac systems, use the Remote 9-Pin Emulation Mode cable. This mode requires a supported serial adapter connected to a computer USB port, and a properly wired configuration. See “Remote 9-Pin Deck Emulation Mode” on page 1319 for details.

- On Windows systems, Remote 9-pin Deck Emulation mode uses an RS-232 to RS-422 cable and a Turnaround adapter connected to an available serial or COM port on the computer.

Connecting Machines

This section describes how to connect machines for Serial Control Mode or Remote 9-Pin Deck Emulation Mode.

Connecting Machines for Serial Control Mode

For Best Serial Deck Control

For best serial deck control, connect your deck as follows depending on your computer’s Operating System.

To connect a deck to a Mac computer:

1. Connect a supported USB serial adapter (not provided) to a USB port on the computer.
2. Connect the provided male mini DIN-8 serial to male 9-pin D-sub Deck Control cable to the end of the adapter.
3. Connect the end of the cable to the machine.

To connect a deck to a Windows computer:

- Do one of the following:
  - Connect the computer’s COM port to the machine, using the provided 9-pin RS-322 to RS-422 cable.
  - Use a supported USB serial adapter (not provided) for computers that do not have a 9-pin serial connector to connect the machine to any available USB port on the computer.

For Limited Serial Deck Control (Non-Linear Decks Only)

- Connect a standard 9-pin cable from one of the 9-pin Out ports on the SYNC peripheral to the 9-pin input of the machine. Due to performance limitations, this configuration should be used primarily with non-linear decks.

Connecting Machines for Remote 9-Pin Deck Emulation Mode

To connect a machine for Remote 9-Pin Deck Emulation mode (Mac Systems):

1. Connect a supported USB serial adapter (not provided) to a USB port on the computer.
2. Connect the provided male mini DIN-8 serial to female 9-pin Deck Emulation cable to the end of the adapter.
3. Connect the end of the cable to the machine.
To connect a machine for Remote 9-Pin Deck Emulation mode (Windows Systems):

- Connect the Turnaround adapter to the RS-322 to RS-422 cable, and connect them from an available serial or COM port on your computer to the 9-pin output of the machine.

Do not use the Serial port on your HDX card, HD | Native card, HD | Native Thunderbolt, or the 9-pin ports on the SYNC peripheral for Remote 9-Pin Deck Emulation mode. The Serial port should only be used for SYNC peripheral connections.

**Using a Rosetta Stone Adapter with MachineControl (Windows Only)**

Using the Rosetta Stone adapter with Machine-Control on Windows lets you increase reliability for long cable runs for Serial Deck Control mode or Remote mode.

A Rosetta Stone RS-232 to RS-422 adapter (model 2/8 or 2/9) and additional RS-232 and RS-422 cables are required.

To increase reliability in long cable runs in Remote mode:

- Follow the instructions as described above for setting up a Rosetta Stone converter for an edit controller.

To increase reliability in long cable runs in Serial Deck Control mode:

1. Connect the RS-232 cable from your computer’s COM port into the RS-232 side of the Rosetta Stone adapter.
2. Connect the RS-422 cable from the RS-422 side of the Rosetta Stone to the deck or 9-pin patch bay. If a longer run is needed, add more 9-pin cable on the RS-422 end.

---

**Starting Up Your System**

To ensure that the components of your Pro Tools system communicate properly with each other and your external machines, start them in a particular order.

**Start up your Pro Tools system in this order:**

1. For systems with an expansion chassis, turn on the chassis.
2. Turn on any external hard drives. Wait approximately ten seconds for them to come up to speed.
3. Turn on any external machines (VTR, ATR, synchronizer, and monitors).
4. Turn on any MIDI interfaces, MIDI devices and synchronization peripherals.
5. Lower the volume of all output devices in your system.
6. Turn on Pro Tools audio interfaces. Wait at least fifteen seconds for your system hardware to initialize.
7. Turn on your computer.
8. Launch Pro Tools.

**Machine Local and Remote Modes**

Be sure to set your machine-controllable device to “remote” or “ext” mode to receive the 9-pin information (not “local” or front-panel mode). With some supported machines, if all other communication is established and the machine is not in remote mode, Pro Tools will indicate machine “local” mode.
MachineControl

Communication Modes

MachineControl supports two machine communication modes: Serial Deck Control mode and Remote 9-Pin Deck Emulation mode.

Serial Deck Control Mode

With Serial Deck Control mode, you can use the Pro Tools Transport window to control an external deck.

Transport

The setting of the Transport Master determines the type of Serial Deck Control, as follows:

Transport = Pro Tools The Transport window controls the Pro Tools Timeline. When online, the deck locates relative to actions taken in the Pro Tools Timeline.

Transport = Machine The Transport window controls the machine. When Pro Tools is Online, the Pro Tools Timeline chases the machine.

Transport = MMC The Transport window controls MIDI Machine Control (MMC). When Pro Tools is Online, the Pro Tools Timeline chases MMC.

Cueing and Pre-Roll

Pro Tools Preference settings let you optimize MachineControl operation, including adjustable machine pre-roll, selectable edit and memory location chasing.

Pro Tools sessions can be as long as 24 hours. MachineControl features are disabled for the final minutes of the 24-hour period, to allow for pre-roll to be used at the beginning of the session without unwanted machine shuttling.

Track Arming

When the Transport Master is set to Transport = Machine, you can arm tracks of external machines from within Pro Tools for layback and transfer. Features include individual record enables for up to 48 external tracks, with selectable record protocol and mode. Machine profiles included with the software let you pre-configure track arming for many machine types.

Serial Timecode

When the Positional Reference is set to Serial Timecode in the Session Setup window, Pro Tools can control an external machine via the Serial Deck Control cable. This setting also enables Pro Tools to receive timecode directly using only the Serial Deck Control cable.

(This mode requires that the 9-pin device be capable of transmitting serial timecode. It also requires that the Pro Tools and the device receive a common video reference.)
Using a Paddle Device in Local Mode

When using MachineControl in Local mode with or without an external synchronizer, you can use a supported third-party paddle device to issue the following Pro Tools track commands:

- Input monitoring
- Record Enable
- Record Safe
- Solo
- Solo Mute

See “Using a Paddle Device in Local Mode” on page 1324.

Remote 9-Pin Deck Emulation Mode

With Remote 9-Pin Deck Emulation mode (also called Remote 9-Pin mode), an external synchronizer can take control over Pro Tools transport and recording functions.

Pro Tools responds to commands sent by the master 9-pin machine controller, but because Pro Tools is in Remote mode, many of its transport commands are locked out.

Remote and Remote/LTC Chase Modes

When using an external machine controller to control Pro Tools, you can configure Pro Tools to emulate a 9-pin deck in either of the following modes:

Remote mode Pro Tools emulates a device that can be the timecode master or timecode slave.

Remote/LTC Chase mode Pro Tools emulates a device that receives track and transport arming commands, while chasing incoming LTC.

Track Arming

In Remote Deck Emulation mode, you can arm Pro Tools tracks from an external machine.

Features include remote control of individual record enables for up to 112 tracks, with selectable record protocol and mode. Included factory and user programmable profiles let you configure track arming for any machine type.

For arming tracks during playback, see “TrackPunch Audio Recording” on page 566 and “DestructivePunch Audio Recording” on page 569.

Setting Up Machine Control

Online and Offline Operation

Pro Tools can remotely control, or be controlled by, any approved enabled external device. You can select a device by using the Transport Master selector in the Transport window.
To trigger Pro Tools playback or recording from an external source, the Pro Tools Transport needs to be online. There are four ways to put the Pro Tools Transport online:

- Click the Online button in the Transport window.
- Choose Options > Transport Online.
- Press Command+J (Mac) or Control+J (Windows).
- Press Option+Spacebar (Mac) or Alt+Spacebar (Windows).

The Online button in the Transport window indicates online status. It flashes while enabled and waiting for synchronization, and stays lit when lock is achieved.

**Transport Controls**

With MachineControl, the Pro Tools Transport window becomes a multi-function controller.

**Counter Display**

The Pro Tools Edit window counter displays the current machine (9-pin) or session timecode location, depending on which device is the Transport Master, plus any current Session Start Time Offsets being applied. (See “External Timecode Offsets” on page 1310 for more information.)

The Incoming Time display in the Session Setup window always shows absolute incoming time-code, without any offsets.

**Transport Master**

To selecting the Transport Master:

- Right-click the Online button in the Transport and select Transport > Pro Tools or Transport > Machine.

You can also press Control+backslash (\) to toggle between Pro Tools, the Machine, and Remote transport (or, on a Pro Tools control surface, press EXT TRANS).

**Transport = Pro Tools**

In this mode, the controls in the Transport window are focused on Pro Tools playback and recording.

When the transport is online, the machine slaves to Pro Tools, and the session locks to the machine’s timecode. The machine follows Preferences for Machine Chase and Online Record.

When the transport is offline, the Pro Tools Transport window controls Pro Tools only.

**Transport = Machine**

In this mode, the controls in the Transport window are focused on the machine connected and enabled for Serial Deck Control mode. Record commands are sent to the machine only.
When the transport is online, Pro Tools slaves to the machine. The Transport window controls the machine, and Pro Tools chases and locks to it.

In addition, when -Spot is turned on, clips are spotted to the current machine time, and the Trim tool trims to the current machine time.

For details on Auto-Spotting, see “Auto-Spotting Clips” on page 1290.

When the transport is offline, the Pro Tools Transport window controls the machine only.

**Toggling the Transport while Online**

When the Transport window is online, toggling the Transport Master between Pro Tools and your machine will also toggle their master/slave relationship.

**Toggling the Online Status of a Device**

Use the Online pop-up menu in the Transport Master selector to toggle the online status of a Machine device.

**To put a device online (or offline):**

- Right-click the Online button in the Transport and select (or deselect) Online > Pro Tools or Online > Machine.

Device choices depend on the current Transport Master and which devices have been set up in Pro Tools.

The Online pop-up menu will only display devices that have been properly set up in Pro Tools. To set up machine devices, see “Serial Deck Control Mode” on page 1305. To set up MIDI devices, see “Using MIDI Machine Control” on page 1283.

**Online Display Information**

Several display elements of the Edit and Transport windows provide machine status information during MachineControl use, as follows:

- When Pro Tools is online, the Transport Online button flashes. “Waiting for Sync” will be displayed in the status box in the lower left corner of the Edit window.
- The Transport Online button continues to flash until you click Play and timecode lock occurs (all devices locked and responding in sync).
- The Timecode display in the Edit window shows the Machine Time when the machine is Master.
- Upon lockup, the Timecode display switches to show the session time.
- When set to 9-pin Deck mode, the Online button icon updates to show a 9-pin icon.

**Remote Mode**

In Remote 9-Pin Deck Emulation mode, you put Pro Tools in Remote mode to enable Machine Control operation.

When you put Pro Tools in Remote mode, it responds to commands sent by the master 9-Pin machine. Many Pro Tools commands, including transport controls, are inactive in the Transport window.
When you take Pro Tools out of Remote mode, it operates in Local mode and ignores commands from the 9-pin machine controller. Pro Tools responds only to requests from the 9-pin machine controller for machine type and status, and returns that it is in Local mode.

**To put Pro Tools in Remote mode:**
1. Choose View > Transport > Synchronization.
2. Click the Remote button in the Transport window.

For more information on Remote mode in Pro Tools, see “Remote 9-Pin Deck Emulation Mode” on page 1319.

**Serial Deck Control Mode**

Serial Deck Control mode is available whenever MachineControl is connected using the Serial Deck Control cable. For more information about connecting Pro Tools for Serial Deck Control mode, see “Cables and Connections” on page 1298.

When connected for Serial Deck Control mode, MachineControl enables all Pro Tools track arming, synchronization, and Transport features, as available on your system. Serial Deck Control mode also supports 9-pin serial timecode (see “Using Serial Timecode for Positional Reference” on page 1307). Some features require a SYNC peripheral, as noted throughout this chapter.

For information on track arming, see “Remote Track Arming” on page 1315.

---

### Configuring Serial Deck Control (Overview)

To configure Pro Tools for Serial Deck Control, do the following:

1. Open an existing session or create a new session.
2. Set up a MachineControl device. (See “Configuring a MachineControl Device for Deck Control” on page 1305.)
3. Configure Pro Tools Machine Control preferences and Online Options in the Preferences dialog. (See “Preferences for Serial Deck Control Mode” on page 1307.)
4. Configure Pro Tools session settings in the Session Setup window. (See “Session Setup Window and MachineControl” on page 1309.)
5. In the Pro Tools Transport window, select Pro Tools or Machine as the Transport Master. (See “Selecting Pro Tools or the Machine as the Transport Master” on page 1313.)
6. Use the Transport window to play back material. (See “Playback in Serial Deck Control Mode” on page 1314.)

### Configuring a MachineControl Device for Deck Control

To set up a MachineControl device:

1. In Pro Tools, choose Setup > Peripherals.
2. If you are using a SYNC peripheral, click the Synchronization tab and select Enable SYNC HD.
3. Click the Machine Control tab in the Peripherals dialog.
4 In the 9-pin Machine Control (Deck Control) section, select Enable.

5 Select the 9-pin MachineControl port from the Port pop-up menu.

6 Choose the appropriate machine profile from the Machine Type pop-up menu.

7 Set machine pre-roll for use when the Transport Master is set to Pro Tools. (See “Machine Pre-Roll” on page 1306 for more information.)

8 Click OK to close the Peripherals dialog.

**Machine Pre-Roll**

You can set a variable amount of machine pre-roll to account for the time it may take the machine to achieve servo lock. Shorter pre-roll values are usually better for non-linear machines. Longer pre-roll values are usually better for older tape transports.

The Machine pre-roll value is added to any pre-roll specified in the Pro Tools Transport window.

**To set MachineControl pre-roll:**

1 In Pro Tools, choose Setup > Peripherals, and click the Machine Control tab.

2 In the 9-pin Machine Control (Deck Control) section, type the number of frames of pre-roll in the Preroll box.

3 Click OK.

**Selecting Machines in Serial Deck Control Mode**

When using a SYNC HD with machines connected to each of its two 9-pin ports, or to serial ports on the computer, use the Peripherals dialog to choose which machine to control.

**To select a machine for Serial Deck Control mode:**

1 In Pro Tools, choose Setup > Peripherals and click the Machine Control tab.

2 In the 9-pin Machine Control (Deck Control) section select Enable.

3 Choose SYNC 9-Pin Out 1 or SYNC 9-Pin Out 2, or an available serial port from the Port pop-up menu.

4 Choose the appropriate machine profile from the Machine Type pop-up menu.

5 Click OK to close the Peripherals dialog.

---

**Pro Tools lets you define and save custom machine profiles. See “Remote Track Arming” on page 1315 for more information.**

**Machine pre-roll is different from the main Transport pre-roll that is set in the Transport window.**

**If you are using a SYNC peripheral and your machine has timecode reader capability, you can use serial timecode for Positional Reference.**
Using Serial Timecode for Positional Reference

If you are using a SYNC HD and your machine has 9-pin serial timecode capability, you can use serial timecode for positional reference. This improves lockup times.

To use serial timecode for positional reference, a Video Reference signal must be present, as indicated by the Ref Present indicator in the Session Setup and Edit windows. Both the SYNC peripheral and the external machine should be locked to the same video reference signal.

When using Serial Timecode for positional reference, you can regenerate LTC.

To enable Serial Timecode:
1. Choose Setup > Session.
2. Choose Serial Timecode from the Positional Reference pop-up menu.

To regenerate LTC when locking to Serial Timecode:
1. Choose Setup > Session.
2. Choose Serial Timecode from the Positional Reference pop-up menu.

3. In the Transport window, click the Gen LTC button.

Gen LTC button in Transport window

Preferences for Serial Deck Control Mode

You can configure preferences for MachineControl playback and recording in Pro Tools.

Playback Options

Machine Control Section

Machine Chases Memory Location When selected, navigating to a specific location in a session with a Memory Location causes a connected transport to chase to that location.

Machine Follows Edit Insertion/Scrub When selected, navigating to a specific location in a session by moving the selection point or by scrubbing a track will cause a connected transport to chase to that location.

- When the connected device is a linear device (such as a tape deck), select Linear Devices (jog) to set Pro Tools to send jog commands.
- When the connected device is a non-linear device (such as a random-access video recorder or another Pro Tools system), select Non-Linear Devices (cue) to set Pro Tools to send cue commands.

Machine Cues Intelligently When selected, if you navigate to a cue point that is more than 10 seconds from the current location, Pro Tools will command a connected transport to fast wind to the new loca-
tion at full speed to within 10 seconds of the cue point. Cueing will then slow to normal speed until the point is reached. This can significantly speed up tape cueing with certain video transports.

**Stop at Shuttle Speed Zero** Causes Pro Tools to send a Stop command whenever you stop shuttling. This is useful if you have a machine that requires an explicit stop command to park correctly.

**Non-Linear Transport Error Suppression** When Transport = Pro Tools, keeps Pro Tools from sending a Stop command when taken offline. This prevents Pro Tools from stopping any other 9-pin devices connected to the system.

**Synchronization Section**

**Minimum Sync Delay** Sets the amount of time (in frames) for devices to achieve synchronization “lock.” This amount varies for each device. Pro Tools lock up delay is set by entering a value for Minimum Sync Delay in the Synchronization page of the Preferences dialog. The lowest value available is 15 frames. Find the shortest possible lock-up time that your equipment can operate at consistently, and set this as the delay value.

**Delay Before Locking to Longitudinal Timecode**

Sets the amount of time (in frames) for Pro Tools to lock to incoming LTC. Use this option when locking Pro Tools to a stable timecode source (such as a non-linear machine or LTC generator) and not a linear tape machine.

**Delay Before Locking to Serial Timecode** Sets the amount of time (in frames) for Pro Tools to wait before attempting to lock to machines that issue servo lock messages. This setting allows time for the servo mechanisms to achieve stable lock.

**To set Machine Control playback options:**

1. Choose Setup > Preferences, and click the Synchronization tab.
2. Select or set Machine Control options.
3. Click OK to close the Preferences dialog.

**Recording Options**

**Record Online at Timecode (or ADAT) Lock** When selected, online recording begins as soon as Pro Tools receives and locks to incoming timecode.

**Record Online at Insertion/Selection** When selected, online recording begins at the edit cursor location. Recording continues until Pro Tools stops receiving timecode. If you make a selection, Pro Tools records online for the length of the selection.

**To set Serial Deck Control mode recording options:**

1. Choose Setup > Preferences, and click the Operation tab.
2. Select or set the above Online options in the Record section.
3. Click OK to close the Preferences dialog.
Session Setup Window and MachineControl

The Session Setup window has three sections.

**Format** Includes displays and controls for time-code-related settings on your system, as well as certain session format settings (such as bit depth, pan depth, audio format, and interleaved).

**SYNC Setup & Timecode Offsets** Lets you set Clock Reference and Positional Reference, Video Reference format, and Video Input format.

**Timecode Settings** Lets you configure Timecode Freewheel settings and Audio and Video Pull Up/Down amounts.

**To show SYNC Setup and Timecode Offsets:**
- Click the SYNC Setup and Timecode Offsets show/hide button.

**To show Timecode settings:**
- Click the Timecode Settings show/hide button.
Session Settings for MachineControl

Use the steps in this section to quickly configure the basic session settings for MachineControl.

Basic Session Settings

Confirm the following settings for each session.

To configure a session for MachineControl:
1 Open an existing session or create a new one.
2 Choose Setup > Session.
3 In the Format section, do the following:
   • Set a Session start time.
   • Set the session Timecode Rate and Feet+Frames Rate.

Clock Source, Clock and Positional Reference Settings

The Session Setup window provides selectors for the system Clock Source, as well as Clock Reference and Positional Reference. These settings must be configured based on the signal connections between Pro Tools, the SYNC peripheral, and external devices.

To configure Clock Source and Reference settings:
1 Choose Setup > Session.
2 In the Format section, select a Clock Source (a SYNC peripheral or an Avid HD audio interface) from the Clock Source pop-up menu.
3 In the SYNC Setup section, select a Clock Reference and Positional Reference.
4 In the SYNC Setup section, set the appropriate Video Reference and Video In formats.

Testing Session Settings

To check your session and MachineControl settings, place the machine in Local mode and manually start playback on the external machine. If Pro Tools is receiving timecode, the current location will be shown in the Incoming Time display. Be sure to reset the machine to Remote mode when finished.

External Timecode Offsets

In the External Timecode Offsets section, Pro Tools lets you compensate for devices that are consistently offset by a fixed number of frames (such as some color–corrected video masters), or for material that starts at a different time than the session.
Pro Tools provides four different External Timecode Offset settings:

- MMC (MIDI Machine Control)
- 9-Pin (Deck Control)
- Synchronization peripherals such as the SYNC HD or other peripherals (such as MIDI interfaces that provide MIDI Timecode).
- Satellite (Pro Tools with Satellite Link or Video Satellite)

Unique values can be defined for each of these types of offsets, or you can link all to adjust in unison.

Positive and negative offset values can be entered to offset Pro Tools timecode display later or earlier, respectively.

**Sample Offset**

This field lets you set an offset value for incoming timecode (up to the equivalent of plus or minus one frame at the current session sample rate). This lets you create a permanent offset to fine-tune the point at which Pro Tools synchronizes relative to incoming timecode. For example, a value of –50 makes an event in Pro Tools occur 50 samples before the same event in the incoming timecode. Use this to compensate for timing differences between various SMPTE-to-MIDI Timecode converters or analog-to-digital/digital-to-analog converters.

**Offsets and SYNC Timecode Display**

The timecode display on the front panel of the SYNC peripheral continues to display actual incoming timecode, regardless of any External Timecode Offset applied in Pro Tools.

**To apply an offset to an external timecode source:**

- In the Session Setup window, enter an offset value time in an offset field.

**External Timecode Offsets in the Session Setup window**

**To apply the same timecode offset to all devices:**

- In the Session Setup window, select Link to apply the same offset value to all devices.

**Timecode Settings**

The Timecode settings control timecode generation, Freewheel, and session Pull Up and Pull Down options.

Configure these settings as appropriate for the current project and situation (refer to the **SYNC HD Guide**).

**Additional Pro Tools MachineControl Commands**

The following commands are available in all MachineControl operating modes.

**Current Timecode Position**

Use this command to redefine the current timecode position and session start time. By creating an insertion point (or Edit selection), and then entering the desired new timecode position for that location, the session start time will be recalculated based on the new, relative timecode location.
For example, if you place an insertion point at 01:02:04:11, choose Setup > Current Timecode Position, and enter 01:00:08:00 to correspond to the first frame of film, this adjusts the session start time such that the insertion point location is now 01:00:08:00.

To redefine the current timecode location:
1. Enable Link Edit/Timeline.
2. Click the Grid mode selector. This ensures that your selection is on a frame boundary.
3. Locate Pro Tools to the beginning of the relevant material (usually the first audio of a scene, a 2 pop, or similar).
4. If appropriate, cue the external timecode source to the location where you want to align the current Pro Tools insertion point. Note the timecode location, or copy it to the clipboard.
6. Type the new timecode position in the Desired Timecode Position text box, or paste the timecode position into the text box, if you copied it to the clipboard.
7. Click OK.

Current Feet+Frames Position

Use this command to redefine the Feet+Frames position at the current insertion point (or the Timeline Selection In Point).

💡 Redefining Feet+Frames does not redefine the session start time.

Typically, this command is used for integrating test tones, pre-roll, and similar pre-program material into the Pro Tools session ahead of the first hour timecode position on the Timeline. In most cases when working on reels of film, the user will want to set the first hour mark in the session to equal 0+0 feet and frames, to line up properly with the start of the Academy leader for each reel of film.

To set a relative frame position for a session (Feet+Frames):
1. Enable Link Edit/Timeline.
2. Click the Grid mode selector. This ensures that your selection is on a frame boundary.
3. With the Selector tool, click in a track (or make a selection) where you want to redefine the position.
5. Enter a Feet+Frame position in the Desired Feet+Frames Position text box.
6. Click OK.

Create Machine Track Arming Profile

The Create Machine Track Arming Profile command lets you create and save machine descriptions as Machine Profiles. Profiles are provided for an ever-increasing list of common machines, or you can customize profiles for specific situations and requirements. Options include the ability to emulate a different machine type, remap and rename audio tracks, and choose to include or exclude the video and timecode tracks, when available. For more information, see “Creating a Track Arming Profile” on page 1316.
Selecting Pro Tools or the Machine as the Transport Master

In Serial Deck Control mode, the deck is always the timecode master. However, the start of machine playback changes based on the Transport Master mode you are using.

The setting of the Transport Master (located in the Pro Tools Transport window) determines where the deck will start playback when the Pro Tools Transport sends a play command to the deck Control, as follows:

Transport = Pro Tools

In this mode, the Transport window controls the Pro Tools Timeline position (playback and recording). When you click Play in the Transport window while it is online, the deck locates relative to the current Pro Tools Timeline.

- When the Transport window is online, the machine locates to a position ahead of the current Timeline insertion point. This location ahead is equal to the sum of the machine pre-roll and the Transport pre-roll. Once the machine has located to this total pre-roll position, it plays, sending timecode to Pro Tools, which chases that incoming timecode. The machine follows the Preferences settings for Serial Deck Control. (See “Preferences for Serial Deck Control Mode” on page 1307.)

- When the Transport window is offline, the Pro Tools Transport window controls Pro Tools only.

- All record commands in this mode are directed to the deck only.

- When Auto-Spot is turned on, clips are spotted to the current machine time, and the Trim tool trims to the current machine time.

Transport = Machine

In this mode, the Transport window controls the machine connected and enabled for Serial Deck Control mode. Record commands are sent to the machine only. When online and a Play command is given, the machine plays from its current location, feeding timecode to Pro Tools, which chases that incoming timecode from the deck.

- When the Transport window is online, Pro Tools chases the timecode coming from the machine. The Transport window controls the machine, and Pro Tools chases and locks to it.

- All record commands in this mode are directed to the deck only.

- When Auto-Spot is turned on, clips are spotted to the current machine time, and the Trim tool trims to the current machine time.

- When the Transport is offline, the Pro Tools Transport window controls the machine only.

To select a Transport Master:

1. In Pro Tools, Right-click the Online button in the Transport to display the Transport Master pop-up menu.

2. From the Transport Master pop-up menu, select Pro Tools or Machine.

Press Control+backslash (\) (Windows) or Command+backslash (\) (Mac) to toggle between available Transport Master choices.
Toggling the Transport while Online

When the Online button is highlighted, toggling the Transport Master between Pro Tools and Machine also toggles their master/slave relationship.

Playback in Serial Deck Control Mode

To play or cue your machine independently of Pro Tools:

1. Make sure Pro Tools is not online (the Online button in the Transport window is not flashing).
2. Right-click the Online button in the Pro Tools Transport and select Transport > Machine.
3. Click any of the buttons in the Pro Tools Transport window to control your machine.

Pro Tools always displays incoming LTC or 9-pin time in the incoming time field in the Session Setup window during fast-wind, and switches during playback to display the current positional reference.

To automatically locate your deck to pre-roll into your current Timeline insertion time each time you play back:

1. Make sure Pro Tools is not online (the Online button in the Transport window is not flashing).
2. Right-click the Online button in the Pro Tools Transport and select Transport > Machine.
3. Put Pro Tools online.
4. Click Play in the Transport window.

If the tape in the machine is striped with timecode that matches your Session time, the machine will locate to the total pre-roll position ahead of the Pro Tools on-screen selection/insertion point or memory location, and begin playing back. Pro Tools will chase its timecode output.

Machine Remote Setting

If the Transport Master selector will not stay set to Machine, or if it switches to Pro Tools from Machine, check your machine’s Local/Remote setting. It should be set to Remote to receive commands from the Pro Tools Transport.

Machine Cueing

MachineControl provides two Cue modes for remote machine operation: Search and Hi-speed.

- In Search mode, the tape remains laced during Fast Forward or Rewind.
- In Hi-speed mode, the tape is unlaced before fast-forward/rewind. The Transport window indicates the status of the tape as described below.

Search Mode

In Search mode, the tape is laced against the heads when the machine is paused or searching, and the Stop button stays lit (it does not flash) and the Play button flashes. When cueing in this mode, the Fast Forward or Rewind button also lights when searching in either direction.

To fast forward and rewind in Search mode:

1. Right-click the Online button in the Pro Tools Transport and select Transport > Machine.
2. Click Play in the Transport window or press the Spacebar to begin machine playback, then press the Spacebar again to pause the machine (this is to ensure that the tape is laced).
3. Click Fast Forward or Rewind in the Transport window to search the tape.

Some devices, including several popular VHS decks, do not support a shuttle mode in which the tape stays laced. These decks unlace the tape before shuttling. Refer to your tape machine’s guide for more information.
Hi-Speed Mode

In Hi-speed mode, the tape is unlaced, and all Transport window buttons are dark. When you cue in this mode, only the selected Fast Forward or Rewind button lights.

To fast forward and rewind in Hi-speed mode:

1. Right-click the Online button in the Pro Tools Transport and select Transport > Machine.
2. To unlace the tape, click Stop in the Transport window or press Command+period(.)
3. Click Fast Forward or Rewind in the Transport window. The Pro Tools cursor indicates the current machine location.
4. Press the Spacebar to pause the machine.

⚠️ Some devices may not support all shuttle modes, and may not accept the above shuttle commands. In these cases, the Fast Forward and Rewind buttons in the Pro Tools Transport window flash, and clicking them places the device in true Fast Forward / Rewind mode.

Spotting to the Machine

To spot clips to the machine’s current location, use Pro Tools Spot mode or Auto-Spot (if using VITC).

⚠️ Auto-Spot mode uses incoming VITC for location information. Therefore, Auto-Spot mode will force the clip to be spotted to the current incoming machine timecode location, not the current insertion cursor location. To spot your elements directly to the current cursor location, Control-drag (Mac) or Right-click and drag (Windows) the elements.

Remote Track Arming

Pro Tools with MachineControl provides the ability to record-arm audio, video, or timecode tracks on external decks, and rehearse an edit.

On MachineControl-equipped systems, the Machine Track Arming command is available in the Pro Tools Window menu. The Machine Track Arming window lets you configure track arming during sessions using the settings appropriate for the current Track Arming Profile. (See “Identifying Your Machine” on page 1316.)

To display the Machine Track Arming window:

- Choose Window > Machine Track Arming.

Configuring Track Arming

Pro Tools provides automatic, direct support for track configuration of most common video decks. If your deck is supported, MachineControl identifies and displays your machine’s track layout.

Even if your machine is not directly supported, the Track Arming window lets you arm tracks, set the Record Protocol and configure the Record mode for the machine.

You can also define, save, and load customized device profiles. (See “Creating a Track Arming Profile” on page 1316.)

💡 Not all machines support independent arming of their audio tracks locally or remotely, and some machines require a separate utility menu selection. Pro Tools remote track arming cannot operate in these situations.
Identifying Your Machine

When you configure Pro Tools for MachineControl, it automatically loads the track arming profile for the identified machines.

For more information on basic Pro Tools settings for MachineControl, see “Configuring a MachineControl Device for Deck Control” on page 1305.

If Pro Tools does not recognize your machine, or if you want your machine to emulate a different type of device (for example, to use a different track layout), you can load a generic machine profile.

If you are using a generic machine profile, be sure to double-check record behavior using non-essential tapes before using MachineControl’s remote track arming functions.

For maximum flexibility, use Track Arming Profiles to create, customize, and manage multiple machine descriptions (see “Creating a Track Arming Profile” on page 1316).

Creating a Track Arming Profile

The Create Track Arming Profile dialog provides extensive control over Pro Tools track arming. You can customize arming, track naming, and mapping, and save configurations for different machines as Track Arming Profile files. These Profiles can be imported to quickly reconfigure Track Arming as needed for future projects. You can also test track mapping, and remap tracks if needed.

Use the Create Track Arming Profile feature to create profiles for machines that may not be included with Pro Tools, and to manage multiple profiles.

To create a machine Track Arming Profile:


When you create a new Track Arming Profile, a Stop command is sent to any connected machine to protect elements on tape.

Choosing a Machine ID

To recognize your machine:

- In the Create Machine Track Arming Profile dialog, click Identify Machine.

MachineControl queries the connected machine for its machine ID, which is then displayed below the Identify Machine button.

You can edit or replace the ID manually if needed. See “Entering a New Byte Code” on page 1317 for more information.

Configuring a Profile

The Create Track Arming window lets you specify track names and track mapping.

Customizing Names for Track Arming Buttons

You can rename the Track Arm buttons displayed in each Track Arming Profile to better describes the recording taking place. For example, an eight track profile might be easier to use with tracks named Dx-L, Dx-R, FX-L, FX-R, Mx-L, Mx-R, Lt, and Rt, for eight tracks comprised of stereo Dialog, stereo FX, stereo Music, and an Lt-Rt mix.

To edit the name of a track arming button:

1. In the Create Machine Track Arming Profile dialog, double-click the Track Arm button you want to rename.

2. Enter a new track name in the dialog, and click OK.
**Remapping Tracks**

You can remap track buttons to target different tracks on the machine.

**To remap tracks:**

1. In the Create Machine Track Arming Profile dialog, click the Track button you want to remap to display its remap pop-up menu.

2. Do one of the following:
   - Choose a new target track.
   - Choose a different machine profile from the Load Configuration selector.

**Reassigning the Byte Value for a Track**

In a remote machine’s firmware, each record track on the machine has a unique hexadecimal byte code that tells the machine which track should be armed when an arm command is received from a remote master. The standard profile (the default setup) corresponds to the Sony P-2 protocol, but many decks have their own unique mapping of byte codes to track numbers for a particular deck.

If an audio or video track, or the deck timecode track do not arm when you click its corresponding track arming button, you may need to assign a different hex value to the button.

**To select a different hex value for an individual track arm button:**

- Select another hex value byte code from the Byte Code sub-menu for the appropriate track arm button.

**Entering a New Byte Code**

As the Sony P2 protocol continues to expand, more manufacturers add specific byte code commands that may be listed in the current byte code list. Pro Tools lets you create entirely new, custom byte codes. This lets you enter additional byte commands as needed to support new features as they are added to decks.

**Choosing a Record Protocol**

The Machine Track Arming window provides the following two choices for configuring the recording protocol of the target deck:

**Auto Edit**

This mode is a highly accurate way to ensure that the target deck will record only within the boundaries of an on-screen selection. (If your deck does not support Auto Edit, use Punch In/Punch Out, as explained below.)

In Auto Edit mode, the record in/out points are downloaded to the target deck (along with any pre- or post-roll), and the deck is responsible for performing the insert punch in/out at the specified times (see “Rules for On-Screen Selections” on page 1318 for details).

Because this protocol removes the vagaries of CPU timing from the remote recording process, Auto Edit is frame-accurate. It is also the best way to ensure that your machine will punch out correctly and avoid accidental erasure of audio, even in the event of a CPU error.

**Punch In/Out**

This mode uses Pro Tools to control the process of punch in/out. Instead of downloading the punch points (as in Auto Edit), Pro Tools actually performs them during the record pass. Because serial
communication has inherent delays, timing with Punch In/Punch Out mode cannot guarantee frame-accuracy (though it will almost always be within 2 to 3 frames).

Choosing a Record Mode

The Machine Track Arming window provides two choices for Record mode:

**Insert**

Insert mode is used to perform insert editing (punching in individual tracks) where one or more audio tracks is replaced by new material and the video material is retained.

**Assemble**

Use Assemble mode when you want to:

- Begin recording program onto a completely blank tape (unformatted)
- Append program to the remainder of a tape which already has program you want to keep

Assemble mode is not appropriate for audio laybacks to video masters.

Assemble mode should be used carefully because it arms all tracks on the target deck for recording—including the video track, timecode track and control track. When performing an Assemble edit, all material on all tracks after the edit in point will be replaced. Because a break in the control track will result at the edit out point, any remaining program material after an Assemble edit may be unusable.

To avoid accidentally recording over program material, experiment with Assemble and Insert modes on a dispensable tape to familiarize yourself with the edit capabilities of your deck.

⚠️ Assemble mode replaces all the elements on the target tape deck—audio, video and timecode. Use this mode with caution.

Rules for On-Screen Selections

The Record Protocol buttons allow you to choose between the two different record protocol choices described above (Auto Edit and Punch In/Punch Out). Regardless of which choice is used, however, Pro Tools follows these rules for record selection:

- If there is an on-screen selection, recording will take place over the period of the selection and punch out at the out point of the selection.
- If pre- or post-roll is enabled, recording takes place only in the selection area, not during pre- or post-roll.
- If there is no selection (only a start location), recording will continue until it is manually stopped.
- If you make a selection in Pro Tools that crosses the “midnight” boundary (00:00:00:00), make sure your deck can handle this situation. Experiment with a dispensable tape to familiarize yourself with the crossover capabilities of your deck.

Rehearsing a Layback to an External Device

Before laying back audio to an external device, you can rehearse the layback using Edit Preview (Rehearse) mode. In Edit Preview mode, instead of performing an edit insert (recording) on armed remote tracks, the input is monitored without recording.

While in Edit Preview mode, the Transport Record button flashes yellow when armed and lights solid yellow when rehearsing. Armed tracks are indicated by yellow track buttons in the Track Arming window.
To rehearse a layback:

1. In Pro Tools, select the audio you want to rehearse for layback, or place the playback cursor at a start point.
2. Choose Window > Machine Track Arming.
3. In the Track Arming window, select Edit Preview.
4. In the Track Arming window, arm the tracks you want to rehearse by clicking the corresponding buttons. The buttons light yellow to indicate armed status.
5. Right-click the Online button in the Pro Tools Transport and select Transport > Machine.
6. In the Pro Tools Transport window, click the Online button to put Pro Tools online.
7. In the Pro Tools Transport window, click Record. The button flashes yellow to indicate Edit Preview (Rehearse) mode.
8. In the Pro Tools Transport window, click Play. The machine cues to the selection in point or insert point and starts playing back. Pro Tools then syncs to the deck, and the deck records as determined by the settings for Record Protocol and Record mode in the Track Arming window.

Arming Tracks Remotely for Layback

To arm tracks remotely for layback, you need to first configure Track Arming for your machine.

To configure Track Arming:

1. Make sure your machine is properly connected and configured to slave to Pro Tools.
2. Open the Track Arming window.
3. Select a Record Protocol (Auto Edit or Punch In/Out).
4. Select a Record mode (Insert or Assemble).

Once the Track Arming options are configured, you can change the Track Arming window to “small view” and still see the track arm buttons.

To perform a layback:

1. In Pro Tools, select the audio to lay back, or place the playback cursor at a start point.
2. In the Remote Track Arming window, arm the appropriate tracks on the machine.
3. Right-click the Online button in the Pro Tools Transport and select Transport > Machine.
4. Make sure the Pro Tools Transport is online.
5. Click Record in the Transport window to arm recording.
6. Click Play in the Transport window.

Your machine will cue to the selection start minus all relevant pre-roll, then begin to play back. Pro Tools will then sync to the deck, and the target deck will record as determined by your settings for Record Protocol and Record mode. If you did not create an on-screen selection, deck recording will continue until you manually stop playback.

Remote 9-Pin Deck Emulation Mode

Remote 9-Pin Deck Emulation mode makes Pro Tools operate as a virtual tape deck, supporting most standard Sony P2 9-pin commands. For a list of supported commands, see “9-Pin Commands” on page 1324.
By default, Pro Tools emulates a Sony BVW-75 model video deck. You can also configure Pro Tools to emulate other machines. For more information, see “Alternate Machine Types” on page 1322.

For instructions on connecting Pro Tools for Remote 9-Pin Deck Emulation mode, see “Cables and Connections” on page 1298.

Generating Timecode in Remote 9-Pin Deck Emulation Mode

Pro Tools with MachineControl and a SYNC peripheral can generate frame-edge aligned timecode at 1x play speed while in Remote 9-Pin Deck Emulation mode.

Configuring Remote 9-Pin Deck Emulation Mode

To configure Pro Tools for Remote 9-Pin Deck Emulation mode:

1. Choose Setup > Peripherals, and click the Synchronization tab.
2. Choose SYNC from the Device pop-up menu.
3. Click the Machine Control tab in the Peripherals dialog.
4. In the 9-Pin Remote (Deck Emulation) section, select Enable.
5. Select the 9-pin MachineControl port from the Port pop-up menu.
6. Choose the appropriate machine profile from the Machine Type pop-up menu.
7. If you want Pro Tools to ignore transport commands and just chase LTC, enable Chase LTC.
8. Click OK to close the Peripherals dialog.
9. In the Transport window, click the Remote button to put Pro Tools in Remote mode.
10. Choose Setup > Session, and ensure that the following settings are configured:
   - The Clock Source should be set to SYNC.
   - The Clock Reference should be set to Video Reference.
   - If you did not enable Chase LTC, the Positional Reference should be set to Generate. This is required for Pro Tools to lock to the video reference with frame edge accuracy.
   - If you enabled Chase LTC, the Positional Reference should be set to LTC.
11. If you will be recording, select a Record mode by right-clicking (Windows or Mac) or Control-clicking (Mac) the Record button in the Transport window.

See also “Optimizing Playback in Remote 9-Pin Deck Emulation Mode” on page 1323.
Selecting Full Remote Mode or Remote/LTC Chase Mode

Remote 9-Pin Deck Emulation mode lets a master device control Pro Tools track and transport arming.

When Pro Tools is in Remote mode, Remote 9-pin Deck Emulation operates in Full Remote mode or in Remote/LTC Chase mode.

When Pro Tools is not in Remote mode, it ignores commands from the 9-pin machine controller. Pro Tools responds only to requests from the 9-pin machine controller for machine type and status, and responds that it is in Local mode.

Full Remote Mode

In Remote 9-Pin Deck Emulation mode, when Pro Tools is in Remote mode and Chase LTC is not enabled, Pro Tools is in one of the two following states:

- When the Delay after Play Command preference is set to zero, Pro Tools is set to function as the timecode master. Pro Tools locates, then plays when it gets a play command.
- When the Delay after Play Command preference is set towards 30 frames, another machine is the timecode master. Pro Tools locates, sends timecode position responses, and when its timecode lines up with the timecode master device, goes into play in sync with the timecode master device.

To set the timecode master in Full Remote mode:

1. Choose Setup > Preferences, and click the Synchronization tab.

2. In the Remote Mode section, do one of the following:
   - Set the Delay after Play Command preference to zero, to set Pro Tools to behave as the timecode master.
   - Set the Delay after Play Command preference towards 30 frames, to set Pro Tools to behave as a timecode slave device, by delaying playback until its timecode can properly synchronize.

Generally, delay should only be added if Pro Tools is having problems starting and locking to a machine during playback or record. For example, if Pro Tools tries to lock, and the Transport window lights go from play to shuttle or fast-forward to rewind many times before locking, you should increase the Delay After Play setting by a few frames.

Remote/LTC Chase Mode

When Chase LTC is enabled, Pro Tools can still respond to track arming and record commands. However, Pro Tools will chase incoming LTC instead of behaving as a master or slave device with the machine controller. By slaving Pro Tools to the LTC source instead of slaving the machine to Pro Tools timecode, you can avoid the waiting (and tape wear) that occurs while a machine transport locates and bumps tape to the cue point.

In Remote 9-Pin Deck Emulation mode, when Pro Tools is in Remote Mode and Chase LTC is enabled, it communicates record status to the machine.

Receiving Commands While Chase LTC is Enabled or Disabled

When Chase LTC is enabled, Pro Tools waits until it receives only specific transport record and track record commands from the machine.

When Chase LTC is not enabled, Pro Tools listens to all transport commands coming through the serial connection, including bump and crawl commands necessary for a tape machine to locate.
Scrubbing and Chase LTC

The Chase LTC option does not affect scrubbing. Pro Tools video playback will always respond to locate and scrubbing command, even if Chase LTC is enabled.

Alternate Machine Types

By default, MachineControl lets Pro Tools emulate a Sony BVW-75. If you use a machine that follows a different 9-pin command set, you can configure Pro Tools for that machine’s description.

To configure Pro Tools for an alternate machine:

1. Choose Setup > Peripherals, and click the Machine Control tab.
2. In the 9-Pin Remote (Deck Emulation) section, choose a machine profile from the Machine Type pop-up menu.
3. Click OK.

Special settings have been created for specific machine controllers (such as the Soundmaster ION). When under the control of a specific machine controller, first check if there is a specific setting for that machine controller.

Preferences for Remote 9-Pin Deck Emulation Mode

Pro Tools provides the following preference settings to configure Remote 9-Pin Deck Emulation Mode options.

Remote Mode Section

Ignore Track Arming Sets Pro Tools to ignore incoming track arming (record enable) commands. This is useful if you are using a master controller to arm tracks on other machines, but you do not want to arm tracks in Pro Tools.

Set Servo Lock Bit At Play Enable this option when using a synchronizer to control Pro Tools in Remote mode to minimize lock-up times during recording.

Allow Track Arm Commands in Local Mode Enables a supported third-party paddle device to issue the following Pro Tools track commands while in Local mode:

- Input monitoring
- Record Enable
- Record Safe
- Solo
- Solo Mute

See “Using a Paddle Device in Local Mode” on page 1324.

Punch In Frame Offset Sets an offset in frames to compensate for punch-in timing advances or delays.

Punch Out Frame Offset Sets an offset in frames to compensate for punch-out timing advances or delays.

Delay After Play Command Sets the amount of time (in frames) for Pro Tools to wait after receiving a Play command before starting the audio engine. This can prevent false starts when locking to synchronizers that are not fully supported by Pro Tools.

See “Selecting Full Remote Mode or Remote/LTC Chase Mode” on page 1321 for more information.
To set Remote 9-Pin Deck Emulation mode preferences:

1. Choose Setup > Preferences, and click the Synchronization tab.

2. Select or set Machine Control options in the Remote mode section:

3. Click OK to close the Preferences dialog.

---

**Playback in Remote 9-Pin Deck Emulation Mode**

Pro Tools plays back audio only when the received command requires audio playback at 1X speed in the forward direction. Reverse playback and vari-speed playback are not supported in Pro Tools.

**Optimizing Playback in Remote 9-Pin Deck Emulation Mode**

When using Remote 9-Pin Deck Emulation mode with an unsupported synchronizer, clicking Play may display multiple nudge and bump messages caused by Pro Tools attempting to achieve lock before the master device has stabilized.

The Delay After Play Command preference lets you configure a short delay before Pro Tools attempts to lock with the master device. This allows the master device to stabilize before Pro Tools locks with it in order to avoid nudge and bump messages.

See “Preferences for Remote 9-Pin Deck Emulation Mode” on page 1322 for more information.

**Recording in Remote 9-Pin Deck Emulation Mode**

MachineControl lets Pro Tools support Auto Edit (selection-based) and Punch-in/Punch-Out (QuickPunch) commands.

---

Pro Tools must have QuickPunch or TrackPunch with tracks enabled when recording in Remote 9-Pin Deck Emulation mode with an edit controller.

⚠️ *Preview Edit and Rehearse modes are not supported by Pro Tools.*

**Auto Edit Recording**

When a machine sends Auto Edit commands to Pro Tools in Remote 9-Pin Deck Emulation mode, the edit in and out points are converted to a Pro Tools Timeline selection. This selection, with offsets options, will then be used to record on all armed tracks when Pro Tools receives the Perform Auto Edit Record command.

**Punch In/Out Recording**

Punch-In/Punch-Out Recording supports punch-on-the-fly, with Pro Tools in QuickPunch mode. In this mode, tracks are armed before the record pass, and recording begins and ends when Punch-In and Punch-Out commands are received from the master machine.

QuickPunch must be enabled and the required voices must be available in Pro Tools for Punch-In/Punch-Out recording commands to work. This mode must be set manually in Pro Tools.

**Track Arming in Remote 9-Pin Deck Emulation Mode**

In Remote 9-Pin Deck Emulation mode, Pro Tools can be configured to either respond to, or ignore, track arming (record enabling) commands. Pro Tools communicates track record status back to the control machine.
9-Pin Commands

In Remote 9-Pin Deck Emulation Mode, Pro Tools with MachineControl can respond to the following 9-pin commands from compatible workstations, synchronizers, and other devices:

- Play
- Stop
- Pause
- Rewind
- Forward
- Cue To
- Poll Timecode
- Record Arm Track
- Set In/Out Point (for Auto Edit)
- Set Pre/Post Roll (for Auto Edit)
- Perform Auto Edit Record
- Perform Punch-In/Punch-Out Record (requires QuickPunch mode and voices)
- Return Status-Online, State, Tracks Armed
- Servo Lock
- Clear “In” Point

Ignore Track Arming Commands

You can set Pro Tools to ignore incoming track arming (record-enable) commands. Use this to record-safe Pro Tools if, for example, you are using a master 9-pin transport controller to arm tracks on several other machines, but not Pro Tools tracks. You can still manually arm Pro Tools audio tracks, as needed.

To have Pro Tools ignore remote track arming commands:

1. Choose Setup > Preferences, and click the Synchronization tab.
2. In the Remote Mode section, select Ignore Track Arming.

Using a Paddle Device in Local Mode

When using MachineControl in Local mode (with or without an external synchronizer), you can use a supported third-party paddle device to issue the following Pro Tools track commands:

- Input monitoring
- Record Enable
- Record Safe
- Solo
- Solo Mute

Using these features involve the following steps:

1. Connect the supported third-party paddle device to your system.
2. Make sure the Allow Track Arm Commands in Local Mode preference is enabled.
3. Serial Deck Control and Remote 9-Pin Deck Emulation ports must be configured simultaneously.

Connecting a Supported Third-Party Paddle Device to Your Pro Tools System

To connect a supported third-party paddle device to your Pro Tools system, use the same method you would use to connect a deck for Remote 9-Pin Deck Emulation mode.

See “Remote 9-Pin Deck Emulation Mode” on page 1319 for detailed information on connecting a machine to Pro Tools.
Allow Track Arm Commands in Local Mode Preference

The Allow Track Arm Commands in Local Mode preference must be enabled in order to control Pro Tools with a paddle device in Local mode.

To enable the Allow Track Arm Commands in Local Mode preference:
1. Choose Setup > Preferences, and click the Synchronization tab.
2. Select Allow Track Arm Commands in Local Mode.

Configuring Ports for a Deck and a Supported Third-Party Paddle Device

Before connecting a paddle device and a deck to Pro Tools simultaneously, both the Serial Deck Control port and the Remote 9-Pin Deck Emulation port may be configured.

To configure Serial Deck Control and Remote 9-Pin Deck Emulation ports to operate simultaneously:
1. Choose Setup > Peripherals, and click the Synchronization tab.
2. Choose SYNC from the Device pop-up menu.
3. Click the Machine Control tab.
4. In the 9-pin Machine Control (Deck Control) section, select Enable.
5. Select the 9-pin MachineControl port from the Port pop-up menu.
6. Choose the appropriate machine profile from the Machine Type pop-up menu.

See “Serial Deck Control Mode” on page 1305 for detailed information about configuring and using Serial Deck Control mode.

7. In the 9-Pin Remote (Deck Emulation) section, select Enable.

Remote 9-Pin Deck Emulation mode settings
8. Select the 9-pin MachineControl port from the Port pop-up menu.
9. Choose the appropriate machine profile from the Machine Type pop-up menu.
10. Make sure Chase LTC is not selected.
11. Click OK to close the Peripherals dialog.

To set Pro Tools to Local mode:
- Right-click the Online button in the Pro Tools Transport and select Transport > Machine.

Setting Transport to Pro Tools

Configuring MachineControl for Serial Deck Control
## Deck Control Key Commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Mac</th>
<th>Windows</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rewind</td>
<td>Shift+&lt;</td>
<td>Shift+&lt;</td>
</tr>
<tr>
<td>Fast Forward</td>
<td>Shift+&gt;</td>
<td>Shift+&gt;</td>
</tr>
<tr>
<td>Shuttle Backward</td>
<td>Option+comma</td>
<td>Start+comma</td>
</tr>
<tr>
<td>Shuttle Forward</td>
<td>Option+period</td>
<td>Start+period</td>
</tr>
<tr>
<td>Toggle Transport Master</td>
<td>Command+\</td>
<td>Control+\</td>
</tr>
<tr>
<td>All Transport Buttons Off/Unthread Tape</td>
<td>Command+period</td>
<td>Control+period</td>
</tr>
<tr>
<td>Search Mode Toggle (Play-Pause/Stop)</td>
<td>Spacebar/ Command+period</td>
<td>Spacebar/ Control+period</td>
</tr>
</tbody>
</table>

**When Transport = Machine:**

<table>
<thead>
<tr>
<th>Command</th>
<th>Mac</th>
<th>Windows</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cue to Selection In Point</td>
<td>Command+Left Arrow</td>
<td>Control+Left Arrow</td>
</tr>
<tr>
<td>Cue to Selection Out Point</td>
<td>Command+Right Arrow</td>
<td>Control+Right Arrow</td>
</tr>
<tr>
<td>Cue to Selection In Point Minus Preroll</td>
<td>Option+Left Arrow</td>
<td>Alt+Left Arrow</td>
</tr>
<tr>
<td>Cue to Selection Out Point Minus Preroll</td>
<td>Option+Right Arrow</td>
<td>Alt+Right Arrow</td>
</tr>
</tbody>
</table>
## Machine IDs

The following table lists the machine profiles supported in MachineControl by their Pro Tools hexadecimal ID.

For special IDs to support 48-track arming, see “48 Track Profiles” on page 1328.

### Machines and Hex ID Numbers

The first 0x signifies hex value. The next four numbers signify the machine ID. The name of the associated machine follows.

### Machines, by ID number

<table>
<thead>
<tr>
<th>ID number</th>
<th>Machine</th>
</tr>
</thead>
<tbody>
<tr>
<td>0x0000</td>
<td>Generic 1</td>
</tr>
<tr>
<td>0x0001</td>
<td>Generic 2</td>
</tr>
<tr>
<td>0x1000</td>
<td>BVU-800</td>
</tr>
<tr>
<td>0x101C</td>
<td>BVU-950</td>
</tr>
<tr>
<td>0x1019</td>
<td>BVU-920</td>
</tr>
<tr>
<td>0x1080</td>
<td>BVU-900</td>
</tr>
<tr>
<td>0x104C</td>
<td>VO-9850</td>
</tr>
<tr>
<td>0x1048</td>
<td>VO-9800</td>
</tr>
<tr>
<td>0x102C</td>
<td>SVO-9600</td>
</tr>
<tr>
<td>0x2000</td>
<td>BVW-10</td>
</tr>
<tr>
<td>0x2001</td>
<td>BVW-40</td>
</tr>
<tr>
<td>0x2002</td>
<td>BVW-11</td>
</tr>
<tr>
<td>0x2003</td>
<td>BVW-15</td>
</tr>
<tr>
<td>0x2010</td>
<td>BVW-35</td>
</tr>
<tr>
<td>0x2020</td>
<td>BVW-60</td>
</tr>
<tr>
<td>0x2021</td>
<td>BVW-65</td>
</tr>
<tr>
<td>0x2022</td>
<td>BVW-95</td>
</tr>
<tr>
<td>0x2023</td>
<td>BVW-96</td>
</tr>
<tr>
<td>0x2024</td>
<td>BVW-70</td>
</tr>
<tr>
<td>0x2025</td>
<td>BVW-75</td>
</tr>
</tbody>
</table>
48 Track Profiles

The following are special IDs to support 48-track arming.

Machines

**IDs for 48-Track Capable Machines**

<table>
<thead>
<tr>
<th>ID</th>
<th>Machine</th>
</tr>
</thead>
<tbody>
<tr>
<td>0x6007</td>
<td>3348HR</td>
</tr>
<tr>
<td>0x6005</td>
<td>3348HRV</td>
</tr>
<tr>
<td>0x6003</td>
<td>3324</td>
</tr>
</tbody>
</table>

Tascam DA-88 and other decks can be set to emulate other machines. If a deck is set to emulate another type of machine, the machine type being emulated will be displayed.
9-Pin Cable Pinouts

Serial Deck Control Mode Cable: D Sub 9-Pin Male to D Sub 9-Pin Female (Windows Only)

Cable Construction Details
Machine Control Cable
For Controlling a 9-Pin RS-422
Tape Transport from a standard
Windows PC serial port

Windows PC Side
9-Pin Female
DB-9F Connector
to mate with 9-pin male on PC chassis

Controlled Deck Side
9-Pin Male
DB-9M Connector
to mate with 9-pin female on Deck

Cable Length 50 Feet Maximum
2 twisted pairs, each pair individually shielded

PC Side
Pin Assignments on DB-9F Connector
1 - DCD (Input; Data Carrier Detect)
2 - RxD (Input; Receive Data)
3 - TxD (Output; Transmit Data)
4 - DTR (Output; Data Terminal Ready)
5 - SG (Signal Ground)
6 - DSR (Input; Data Set Ready)
7 - RTS (Output; Request to Send)
8 - CTS (Input; Clear to Send)
9 - RI (Input; Ring Indicator) (No Connect)

Deck Side
Pin Assignments on DB-9M Connector
1 - No Connection
2 - Output; TxD (+)
3 - Input; RxD (-)
4 - Shield for Output Twisted Pair on Pins 3 & 8
5 - No Connection
6 - Shield for Input Twisted Pair on Pins 2 & 7
7 - Output; TxD (+) (No Connection)
8 - Input; RxD (-)
9 - No Connection
MachineControl Master/Slave Adapter

Serial Deck Control Cable:
Mini DIN 8 Male to D Sub 9-Pin Male (Mac Only)
Remote 9-Pin Deck Emulation Cable:  
Mini DIN 8-Pin to D Sub 9-Pin Female (Mac Only)

<table>
<thead>
<tr>
<th>Remote 9-Pin Deck Emulation Mode Cable (Macintosh)</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>DIN-9</strong></td>
</tr>
<tr>
<td>NC</td>
</tr>
<tr>
<td>NC</td>
</tr>
<tr>
<td>2</td>
</tr>
<tr>
<td>9,1</td>
</tr>
<tr>
<td>8</td>
</tr>
<tr>
<td>7</td>
</tr>
<tr>
<td>NC</td>
</tr>
<tr>
<td>3</td>
</tr>
<tr>
<td>NC Shield</td>
</tr>
</tbody>
</table>

**Shielding**

The outside shielding of the D-Sub 9-pin (female) should be wired to the outside shielding of the Mini DIN 8-pin (male).
Chapter 59: Working with Field Recorders in Pro Tools

Pro Tools Ultimate lets you import multichannel audio files and metadata recorded by field recorders.

Field Recorder and Production Workflow Terminology

(Pro Tools | Ultimate Software Only)

Before working with field recorders in Pro Tools Ultimate, you may want to review a brief glossary of common field recorder and production terms.

Field Recorder Terminology

The following terminology applies to field recorders in general:

Metadata

Metadata is used to describe the following:

• Information embedded in a media file. This may include scene, take, sample rate, bit depth, external clip names, the name of the videotape from which the media file was captured, and even timecode values.

• Information embedded in Pro Tools sessions or other sequences, including what files are used, where they appear in a timeline, and automation.

• For AAF or OMF sequences, information about automation or clip-based gain.

Digital Field Recorders

A field recorder, also known as a hard disk location audio recorder, is a device used by a production sound mixer during a film or video shoot to make a multichannel recording of multiple microphone inputs recorded simultaneously.

Depending on the capabilities and settings of a field recorder, multichannel recordings can include one or more tracks (up to 32) and are saved as monophonic or polyphonic audio files on a hard drive, DVD-RAM, or Flash media.

Multichannel recordings made by a field recorder should be encoded with start and end time stamps representing SMPTE timecode or linear timecode (also known as LTC). Most field recorders also allow manual entry of additional types of metadata, including Channel Name/Number, Scene, Take, Circled Take, User Bits, and more.

Pro Tools can import monophonic and polyphonic files and certain types of metadata entered on field recorders.

Production Sound Mix

For each multichannel recording made by a field recorder, the production sound mixer may designate a production sound mix comprising either a representative channel or a mixdown of other selected channels in the recording.
The production sound mix is intended to function as a general reference of all audio recorded within an individual multichannel recording, and is typically used by the Avid video editor when assembling a sequence.

**Broadcast WAV Files (BWF)**

A WAV file containing a BEXT chunk is known as a Broadcast WAV file (or BWF) while still maintaining a .WAV file extension. Broadcast WAV files can contain both BEXT and iXML chunks, or a BEXT chunk by itself.

**BEXT and iXML Chunks**

BEXT and iXML chunks are sets of metadata found within a Broadcast WAV file.

**Limitations**

The following limitations apply to handling of imported metadata from field recorders.

- The BEXT specification as described here adds some features that conform to standards used by Avid video editing applications and Pro Tools—specifically, Description metadata is interpreted differently.
- When you import multiple files in which the same metadata are populated with different values, Pro Tools imports the value that is first present based on the following order:
  - Avid OMF-wrapped media or MXF media
  - Any iXML chunk metadata in a BWF
  - Any BEXT chunk metadata in a BWF

---

**Production Terminology for All Production Workflows**

The following terminology applies to all production workflows:

**Timecode**

There are four types of timecode, depending on your production:

- **Keycode** Each frame of film stock is embedded during manufacturing with a unique identifying timecode position known as *keycode*.
- **SMPTE Timecode** Also known as LTC or linear timecode. The generating clock of this timecode can be based on the time of day or can be set to ascend beginning from a certain starting time of day.
- **Minutes:Seconds** Timecode based on minutes and seconds.
- **Wild** No timecode. Most consumer digital video recorders do not have the ability to generate timecode.

**Production Sound Mixer**

The production sound mixer uses a field recorder to record multichannel audio during a shoot, and later delivers those source files to one or more parties:

- Telecine operator (film workflow only)
- Avid video editor
- Pro Tools editor
Production Terminology for Film Workflows Only

The following terminology applies only to film workflows:

Shootlist

The shootlist is a document in which the camera assistant records each scene and take relative to its keycode value on the film stock. It is later used by the telecine operator to synchronize the audio and video together.

Sound Log

The sound log is a document in which the production sound mixer records each scene and take relative to its beginning timecode position.

Slate Operator and Clapboard Information

The slate operator holds and labels the slate (also known as a clapboard) for each new scene and take. At the start of each take, the slate operator claps the slate, which simultaneously captures the following information:

- The scene, take, and timecode information is captured visually on film.
- The sound of the slate clapping is captured by the field recorder, which should be using the same timecode as displayed on the slate.

The telecine operator uses all of the information above to synchronize used film stock to the recorded audio in order to create the telecine videotape.

Telecine and Telecine Videotape

The Telecine is a machine used to transfer film footage and synchronized audio to videotape (referred to as the dailies).

The telecine videotape contains the dailies. The SMPTE timecode on the telecine videotape will be different from the timecode recorded on location.

FLEEx File

The FLEEx file is a text file generated during a telecine session that relates film keycode, field recorder timecode, and telecine videotape timecode. When the telecine videotape is batch digitized in the Avid video editing application, the information in the FLEEx file is used to assign the original (location) timecode to the resulting audio and video source files.

Supported Field Recorder Audio Files and Metadata

Pro Tools supports the following audio files recorded by field recorders:

- OMF-wrapped media
- MXF
- Broadcast WAV (BWF) files with the following metadata:
  - Both BEXT and iXML chunks
  - BEXT metadata but no iXML metadata
Displaying Field Recorder Metadata in Pro Tools

You can enable or disable the display of field recorder metadata within clips in the Timeline and the Clips List.

To enable or disable the display of field recorder metadata in playlists, do the following:

- From View > Clip, select or deselect either of the following options:
  - Channel Name
  - Scene and Take

To show or hide field recorder metadata in the Clips List:

1. Click the Clips List menu, and choose Show.
2. From the Show submenu, select or deselect either of the following options:
   - Channel Name
   - Scene and Take

When enabled in the Clips List, Scene and Take metadata are added to every clip when available in the corresponding audio file.

Workspace Support for Field Recorder Metadata

Workspace browsers display the following metadata from multichannel recordings made with field recorders.

- Duration
- File Comment
- Date Modified
- Date Created
- # Channels
- Format
- Sample Rate
- Bit Depth
- Original Time Stamp
- User Time Stamp
- Tape
- TC Rate (renamed from FPS)
- Channel Names
- Scene
- Take
- Shoot Date
- Sound Roll
- Sound Roll TC
- Sound Roll TC Rate
- User Bits
- Tape ID
- Project
- Circled
- Clip Name
To show or hide field recorder metadata in Workspace browsers:

- Right-click the column header and select or deselect any of the Recorder Metadata types.

### About Tape and Sound Roll Metadata

Avid video editing applications and field recorders use Tape to represent different kinds of metadata: Avid uses Tape to store the telecine videotape name, while a BWF file with a BEXT chunk or iXML chunk uses Tape to store the name of the sound roll.

To avoid this overlap, Pro Tools preserves Tape metadata from the Avid video editing application and maintains the Sound Roll and Tape metadata from BWF audio files in their respective metadata fields.

### About Shoot Date Metadata

Many field recorders do not populate the Shoot Date field, relying instead on the file's Creation Date to indicate date of production. When Pro Tools imports a field recorder file, it checks to see if the Shoot Date field is populated. If it is empty, Pro Tools copies the Creation Date of the original file to the Shoot Date field of the new files.

### Editing the Channel Name

The Channel Names field in the Workspace displays the channel name, followed by channel number in parentheses. You can edit the Channel name for BWF files. When editing the channel name, anything you enter in parentheses will be discarded. However, the channel number will always be preserved.

### Field Recorder Workflows

Using Pro Tools Ultimate to work with field recorder files from a film, video, or digital shoot involves the following steps:

1. Before receiving source files, ensure that metadata have been preserved (“Ensuring Metadata of Source Files Have Been Preserved” on page 1337).
2. Receive source files (“Receiving Source Files” on page 1338).
3. Import source files into Pro Tools (“Importing Source Files into Pro Tools” on page 1339).
4. Replace edits from the production sound mix with audio from different takes of the same scene (“Selecting a Matching Field Recorder Channel to Replace a Clip” on page 1342).

### Ensuring Metadata of Source Files Have Been Preserved

Before you receive source files, it is important to ensure that the files have been prepared properly at each phase of the production process so that their original metadata is preserved.

If the original metadata has not been preserved, you can use other types of data (such as File Creation Date or File Name) to find related channels. However, the matching process will be easier if metadata has been preserved.
Receiving Source Files

When involved in the audio post-production of edited video sequences, you need both of the following sets of source files:

- AAF or OMF sequence with an edited production sound mix synced to video (such as referenced QuickTime movies or Avid video)
- Raw Production source files representing multi-channel recordings from a field recorder

You will receive these files either separately (from the Avid video editor and production sound mixer) or together as part of an AAF or OMF sequence export including raw production source audio (from the Avid video editor).

Separate Deliveries of Source Files

When you receive an AAF or OMF sequence from the Avid editor and raw production source audio from the production sound mixer, you import the sequence, then either import the raw production source audio, or instruct Pro Tools to search for matching audio outside the session.

Once the production audio is imported or located, Pro Tools will be able to match them together.

See “Importing an AAF or OMF Sequence into Pro Tools” on page 1339 and “Importing Raw Production Source Audio Directly into Pro Tools” on page 1340.

Single Delivery of Source Files

There are two methods the Avid editor may use to prepare the files before exporting them:

- Production source audio has been auto-synced in the Avid Bin and placed on the Timeline
- Production source audio has been auto-synced and resides only in the Avid Bin

Production Source Audio in Timeline Auto-Synced to Edited Production Sound Mix

The production source audio in the Avid Bin has been auto-synced to the edited located sound mix, and all audio channels reside in the Avid Timeline.

When you import this type of sequence into Pro Tools, the edited video, edited production sound mix, and all production source audio will be available to import directly into the Timeline.

Production Source Audio Auto-Synced and Resides Only in the Avid Bin

In an Avid editing application, the raw production source audio has been auto-synced to the edited production sound mix, but all audio channels reside only in the Avid Bin.

In this case, the AAF or OMF sequence does not contain or reference the production source audio when imported into Pro Tools. The Avid editor must deliver the production files to Pro Tools separately. The Avid editor may either deliver the production audio files from the Avid or OMFI Media Files folder, or they may deliver the raw production source audio files, which have not passed through Media Composer.
Importing Source Files into Pro Tools

This topic describes importing production source audio from the following types of files:

- AAF or OMF sequences
- Raw production source audio (if received separately from the AAF or OMF sequence)

Importing an AAF or OMF Sequence into Pro Tools

To open an AAF (or OMF) sequence as a Pro Tools session:

1. Launch Pro Tools.
2. Choose File > Open Session.
3. In the Open Session dialog, navigate to the AAF or OMF sequence you want to import.
4. Click Open.
5. Name your session in the File Name field.
6. Select WAV from the Audio File Type pop-up menu.
7. Select the I/O Settings to use for the session. Several pre-configured I/O Settings are included with your system, or you can select a custom I/O Setting that you have created.
8. Click Save.

The Import Session Data dialog appears.

9. Choose Link to Source Media (Where Possible) from the Audio Media Options pop-up menu.
10. Choose Link to Source Media from the Video Media Options pop-up menu.
11. In the Source Tracks section, select tracks to import by clicking the pop-up menu to the right of each track name and selecting Import As New Track.

To select multiple tracks, Option-click (Mac) or Alt-click (Windows) on any track pop-up menu and select Import As New Track.

12. Change other parameters.
13. Click OK.

Pro Tools creates a new Audio Files folder, Video Files folder, cache.wfm file, and session file at the designated locations. This session matches the audio file type, sample rate, and bit depth of the audio in the selected AAF or OMF. Any selected tracks in the Source Tracks section of the Import Session Data dialog are automatically placed in the Timeline.

For more information about importing AAF and OMF sequences in Pro Tools, see “Importing AAF and OMF Sequences” on page 426.
Importing Raw Production Source Audio Directly into Pro Tools

If the AAF or OMF sequence you imported into Pro Tools did not include raw production source audio, you may import it into the session separately using media supplied by the production sound mixer.

You can import monophonic or polyphonic audio files from field recorders into Pro Tools using any of the following methods:

- Using File > Import > Audio, and selecting the files you want to import.
- Dragging files to the Clips List from the Workspace browser or the desktop.

Repairing Audio Misalignment When Importing Audio Not Exported from Avid

When you use Pro Tools to import raw production source audio that was not exported from an Avid video editing application—such as audio delivered separately from an AAF or OMF sequence—that audio may be offset with the audio in the AAF or OMF sequence by as much as half a frame.

This misalignment results from the incompatibility between frame-accurate time stamping in Avid video editing applications and sample-accurate time stamping in Pro Tools. When you attempt to link the two, the misalignment results.

In order to repair this discrepancy, you may need to manually offset the raw production source audio after importing it into Pro Tools. Another option is to use a utility like SynchroArts Titan to process and align the source audio.

Don’t Convert Sample Rate on Import Preference

In some workflows, it is common for production audio to be recorded at 48.048 kHz to accommodate for a pull down to 48 kHz applied downstream in the workflow. When importing audio at this special sample rate, Pro Tools can either sample rate convert the file to 48 kHz, or pull the file down to 48 kHz in real time during playback.

If you plan to import audio at 48.048 kHz and want Pro Tools to apply the 48 kHz pull down in real time, do the following:

To set the Don’t Convert Sample Rate on Import Preference:

1. Choose File > Preferences.
2. Select the Processing tab.
3. In the Import section, find the Don’t Convert Sample Rates on Import preference setting.
4. Enable that preference to activate real-time pull down for 48.048 kHz audio files.
Designating Field Recorder Tracks

Working with field recorder data often requires Pro Tools to do additional administrative work to locate and keep track of production field recorder channels and metadata. This file handling can be system-intensive when working with large amounts of data.

Pro Tools lets you specially designate field recorder tracks after importing them, ensuring that Pro Tools only does field-recorder-specific file operations on channels that actually contain field recorder data.

To designate a field recorder track:

1. Right-click on the name of the track you want to designate as a field recorder track.

-test

2. Click Field Recorder Guide Track.

3. Repeat for each field recorder track in the session.

Each mono field recorder track must be designated to enable the special Pro Tools field recorder features for that track.

To remove the field recorder designation from a track that has been designated, Right-click its name and deselect the Field Recorder Guide Track option.

Displaying Multichannel Files from a Field Recorder in the Clips List

When importing multichannel recordings from a field recorder, Pro Tools saves the multichannel audio as interleaved audio files, which display as single items in the Clips List.

In previous versions of Pro Tools, multichannel files were saved as separate files, one for each channel. Pro Tools treats these groups of related clips as single items. An expand/collapse triangle next to an item in the Clips List indicates this type of grouped multichannel clip. If you’re working with material imported by an earlier version of Pro Tools, you may see these collective clips.

For multichannel audio clips imported from field recorders to be shown as collective clips, both component clips must have the following properties:

- Same length
- Same clip name prefix (such as Audio File or Audio File_01)
- Consecutively-numbered clip name suffix, from A1 through A8

For example, the clips Audio File_01.A1 and Audio File_01.A2 would be grouped as a multichannel clip in the Clips List.

If an existing stereo or multichannel grouped clip has been dragged onto multiple mono tracks and edited in such a way that one or more components are no longer the same length, the stereo display is removed and the clips are displayed as individual clips in the Clips List.
Selecting a Matching Field Recorder Channel to Replace a Clip

Once you have imported an AAF or OMF sequence into the Timeline, you can replace the original production sound mix with an equivalent matching field recorder channel while preserving the original edits.

Replacing a Clip with a Matching Segment from a Matching Field Recorder Channel

You can replace a mono clip (or selected portion of a mono clip) with a matching segment of a matching field recorder channel that was recorded simultaneously. Any fades performed on the original clip are automatically applied to the replacement clip, and any pre-existing automation on that track is unchanged.

If the production sound mixer entered the channel name (or some other descriptive reference) during shooting, the Matching Field Recorder Channels pop-up menu displays this information.

To replace a clip with a matching field recorder channel:

1. In the Timeline, make a selection that includes or overlaps the clip or portion of the clip you want to replace.

2. Do one of the following:
   - With any Edit tool, Right-click the selection you want to replace, then select Matching Field Recorder Channels from the pop-up menu.
   - With the Selector tool, Command-option-click (Mac) or Control-alt-click (Windows) the selection you want to replace.

3. From the Matching Field Recorder Channels pop-up menu, select the name of the matching clip that you want to use to replace the original clip.

4. Repeat this procedure for every clip you want to replace on each track.

To cycle through matches for the selected clip, press Command+Option+Up/Down Arrows (Mac) or Control+Alt+Up/Down Arrows (Windows).
Conditions for Matching Field Recorder Channel Availability

By default, a matching field recorder channel is available to replace the original channel (represented by the clip or portion of a clip selected on the Timeline) if all of the following are true:

- Both channels are part of a multichannel part of a recording made simultaneously on one or more field recorders.
- Both channels overlap at least once between their start timecode and end timecode positions.
- Criteria set in the Match Criteria dialog is met.
- The metadata embedded during shooting and recording has been preserved prior to import into Pro Tools.

For information on how to ensure that metadata have been properly preserved in your source files, see “Ensuring Metadata of Source Files Have Been Preserved” on page 1337.

However, different field recorders can behave differently, and in some cases, available metadata can be incorrect, incomplete, or missing. To aid in finding matching field recorder channels in these situations, Pro Tools lets you control its channel match criteria.

Field Recorder Channels Match Criteria

For maximum flexibility, the Field Recorder Channels Match Criteria dialog lets you set the criteria Pro Tools uses to find matching field recorder channels.

Field Recorder Channels Match Criteria window

You can find matches using any or all of the following identifying data points:

File Creation Date The date the files were created, as specified by the operating system.

Shoot date The shoot date of the content, as specified by iXML metadata.

Scene The scene number of the content, as specified by iXML metadata.
Scene and Take  The scene number and take number, as specified by iXML metadata.

_matching channels by take can only be done if also matching by scene_

Tape Name  The tape name, as specified by iXML metadata, must match the tape name of the guide file.

Sound Roll Name  The sound roll name, as specified by iXML metadata, must match the sound roll name of the guide file.

Sound Roll Name to Tape Name  The tape name, as specified by iXML metadata, matches the sound roll name of the guide file.

Tape Name to Sound Roll Name  The sound roll name, as specified by iXML metadata, matches the tape name of the guide file.

First X Characters in File Name  Matches files based on a user-specified number of characters in the file name, starting at the beginning.

Channel Name  The channel name, as specified by iXML metadata.

Channel Number  The channel number, as specified by iXML metadata.

Name and Sort Tracks By
This option lets you set the method Pro Tools uses to name and sort the audio files created by expanding matching field recorder channels.

To set match criteria:
1  Do one of the following:
   • In the Edit window, Right-click on a mono clip, and choose Matching Field Recorder Channels > Match Criteria from the pop-up menu.
   • In the Edit window, Command-option click (Mac) or Control-alt-click (Windows) on a mono clip, and choose Field Recorder Channel Match Criteria from the pop-up menu.
   • Right-click the name plate of the track you want to find matches for, and choose Field Recorder Channel Match Criteria from the pop-up menu.
2  In the Field Recorder Channels Match Criteria window, select the matching conditions you want Pro Tools to search.
3  Choose ANY or ALL from the Match Timecode Plus pop-up menu. Choosing ANY will find matches based on any one of the criteria you’ve set. Choosing ALL will require that all of the criteria you’ve set must be matched for Pro Tools to consider a prospective match valid.

The Reset button toggles all criteria to their default values.

_option-click (Mac) or Alt-click (Windows) any item to select or deselect all criteria in the dialog._
Select Areas to Search

By default, Pro Tools searches for matching field recorder files in the Audio Files folder for the current session. Because field recorders often accumulate large amounts of audio data, importing the necessary files into your Pro Tools session can be a slow and complex task.

The Select Areas to Search option lets you specify additional locations (such as alternate folders or hard drives) for Pro Tools to search for matches.

To select areas to search for matching field recorder tracks:
1. Right-click the name of a field recorder track.
2. Click Select Areas to Search.
3. Navigate to a folder or hard drive you want Pro Tools to search for matches.
4. Click Choose to confirm your choice.
5. To delete a search area from the list, select it and click the Minus (–) button.
6. Do one of the following:
   - Click Save to close the Select Areas to Search dialog and save the new search area settings.
   - Click Save & Index to save the new search area settings and re-index the selected folders. For more information, see “Re-Indexing” on page 1345.

Re-Indexing

When new audio is added to one of the designated search areas, Pro Tools must index the contents of that folder before the new audio can be accessed.

To re-index all alternate search areas:
1. In the Field Recorder Channels Match dialog, click Select Areas to Search.
2. Click Save & Index to save the current settings and re-index all search areas in the list.

Missing Search Folders

Folders that you select as search areas can go missing for a variety of reasons (such as deletion or the absence of a needed hard drive). If a folder is missing, Pro Tools shows an error message when you open the Select Areas to Search dialog. The missing path name is displayed in the list in gray-colored italic text.

Field recorder files imported through searches outside the session are always imported as .WAV if any conversion needs to take place, to preserve the field recorder metadata. Session file type selected in the Session Setup window is ignored.
Expanding Matching Field Recorder Channels to New Tracks

When working with a mono clip that is part of a multichannel recording, you can expand that clip (or a selected portion of it) to new tracks that reflect its matching channels while preserving any edits or fades.

Matching field recorder channels are mono channels that were usually recorded simultaneously with the original clip (such as multichannel recordings made by one or more field recorders). For information on setting the detailed criteria that matching channels must meet, see “Conditions for Matching Field Recorder Channel Availability” on page 1343.

For example, this feature lets you easily create different versions of an edited dialogue track corresponding to multiple channel inputs (microphones) that were recorded simultaneously.

To expand matching field recorder channels to new tracks:

1. In the Timeline, do one of the following:
   - To expand a single clip on a single track, right-click the clip.
   - To expand a portion of the clips on the track, make a selection that includes or overlaps any number of clips, and Command-option-click (Mac) or Control-alt-click (Windows) the selection.
   - To expand all of the clips on a mono track, Right-click the track’s name plate.

   The channel you plan to expand must be mono.

2. Click the Expand Channels to New Tracks submenu, and select one of the following methods by which to expand matching field recorder channels for the selection to new tracks:
   - By Match Criteria
   - By Timecode Only

   When expanding only a portion of the clips on a track, the By Match Criteria option will be grayed out if there are no valid matches found, or if the ANY option is chosen in the Field Recorder Channels Match Criteria dialog and no criteria are selected.

   See “Determining the Method of Expanding Matching Field Recorder Channels to New Tracks” on page 1347 for more information on how each of these options expand to new tracks.

If matching field recorder channels are available, Pro Tools expands them (plus the channel represented in the original track) to new tracks according to the chosen parameters.

Result of expanding a selection to new tracks
Determining the Method of Expanding Matching Field Recorder Channels to New Tracks

Matching field recorder channels may be expanded to new tracks based on the channel match criteria specified in the Field Recorder Channels Match Criteria dialog (For more info, see “Field Recorder Channels Match Criteria” on page 1343), or by timecode only.

Expanding Matching Field Recorder Channels by Match Criteria

Choosing Expand Channels to New Tracks > By Match Criteria creates a new track for each unique channel found in matching channels of the selection that meets the criteria you’ve specified.

If channels with duplicate match criteria (such as Channel Name or Channel Number) are encountered, additional tracks are created for each duplicate channel. The new channels share the name of the original channel they were expanded from, appended with a period, followed by an identifying number. The first matching channel will be appended by .2, the second by .3, and so on.

Each new track contains only channels that match according to the specified match criteria, with edits and fades preserved from the original selection. Gaps reflect clips from the original selection that did not have a matching channel with that channel name.

Naming and Sorting Expanded Channels

For maximum flexibility, Pro Tools lets you control the naming and sorting of new channels created by the Expand Channels to New Tracks by Match Criteria command.

This parameter can be set in the Field Recorder Channels Match Criteria dialog (for more info, see “Field Recorder Channels Match Criteria” on page 1343.)

How Tracks Are Named When Expanding Matching Field Recorder Channels by Channel Name

Tracks expanded this way are named as follows:

- For unique channel names that create only one track, each track is named using the original track’s name plus the channel name. For example, expanding the unique channel name Boom from the track Guide.A1 would create a new track called Guide.A1.Boom.

- For unique channel names that create two or more tracks, each of the new tracks that share channel names are named by appending a period, followed by an identifying number. The first matching channel will be appended by .2, the second by .3, and so on. For example, expanding the duplicate channel names Boom from the track Guide.A1 would create Guide.A1.2 and Guide.A1.3.
How Tracks Are Named When Expanding Matching Field Recorder Channels by Channel Number

Tracks expanded this way are named as follows:

- For unique channel numbers that create only one track, each track is named using the original track’s name plus the channel number. For example, expanding the unique channel number A1 from the track Guide.A1 would create a new track called Guide.A1.A1.

- For unique channel number that create two or more tracks, each of the new tracks that share channel numbers are named by appending a period, followed by an identifying number. The first matching channel will be appended by .2, the second by .3, and so on. For example, expanding the duplicate channel numbers A1 from the track Guide.A1 would create Guide.A1.A1.2 and Guide.A1.A1.3.

How Tracks Are Named When Expanding Matching Field Recorder Channels by Channel Name & Number

Tracks expanded this way are named as follows:

- For unique channel name and number combinations that create only one track, each track is named using the original track’s name plus the channel name and number. For example, expanding the unique channel name and number combination Boom.A1 from the track Guide.A1 would create a new track called Guide.A1.Boom.A1.

- For unique channel name and number combinations that create two or more tracks, each of the new tracks that share channel name and numbers are named by appending a period, followed by an identifying number. The first matching channel will be appended by .2, the second by .3, and so on. For example, expanding the duplicate channel names Boom.A1 from the track Guide.A1 would create Guide.A1.A1.2 and Guide.A1.A1.3.

Expanding Matching Field Recorder Channels by Timecode Only

The Expand Channels To New Tracks By Timecode Only command lets you expand an entire track or only selected clips to new playlists on the same track or to new separate tracks, thus revealing all other clips recorded at the same timecode location, regardless of channel name or number. This is especially useful when expanding edited guide tracks to original source audio that was recorded while referenced to timecode, but where channel names or numbers were not written to the audio files.

When finding matches by timecode only, Pro Tools will reference both Original Time Stamp and Sound Roll Timecode. If a cross-match is found between Tape and Sound Roll Name (or vice versa) Pro Tools will also look for cross-matches between Original Time Stamp and Sound Roll Timecode.
Example Workflow: Working with a Guide Track

For live concert videos, the video is captured separately while the audio is recorded in Pro Tools. The video editor will use a guide audio track that is edited along with the video in their video editing software (such as Avid Media Composer). The edited guide track is then returned to Pro Tools, but it needs to be expanded to the conformed original source tracks for mixing and mastering.

1 Multitrack audio is recorded in Pro Tools while chasing timecode. A mono or stereo mix is recorded simultaneously as a guide track for the video editor.

2 The picture and audio guide tracks are edited in a video editing application (such as Avid Media Composer).

3 The edited audio guide tracks are exported from the video editor as an AAF (or OMF) sequence, including handles of at least 2 frames.

4 The AAF (or OMF) sequence is imported into Pro Tools as a new session.

5 The original source audio files and unedited guide track are also imported into the session.

6 The original unedited guide track is relinked to the session (see “Relinking the Original Unedited Guide Track” on page 1349).

7 The Pro Tools editor Right-clicks the name of the guide track and selects Expand Channels to New Tracks > By Timecode Only. The original source tracks expand to new tracks with edits and fades that match the guide track.

Relinking the Original Unedited Guide Track

After importing the AAF (or OMF) sequence and original source audio files into the session, it is recommended that you relink the edited guide track to the original unedited source audio.

To relink the original unedited guide track:

1 Open a Workspace browser. Select your session in the Locations column, then open or expand the Session Audio Files folder.

2 Right-click the edited guide track audio file in the browser and choose Relink Selected Items.

3 In the upper pane of the Relink window, navigate to the original unedited guide track audio file that was recorded in Pro Tools.

   If the original unedited file is not available, you can relink to any of the source audio files as long as they have the same start and end times as the guide track.

4 In the Select Files To Relink pane, select the edited guide track file.

5 Drag the original unedited guide track audio file into the Candidates pane. If a dialog appears stating that one or more files are shorter than the media file you are trying to relink, click Yes to select it for relinking anyway.

6 Check the box to the left of the file in the Candidates pane so that the Link icon appears.

7 Click Commit Links at the top of the Relink window and then close the Relink window.

You can now Right-click the name of the guide and select Expand To New Tracks > By Timecode Only. All expanded tracks should be synchronous with the guide track.
Film Workflow

This topic describes the film workflow from shooting to the point where the Avid editor is ready for editing, and is intended for the following parties:
• Camera assistant
• Camera operator
• Production sound mixer
• Telecine operator
• Pro Tools editor

Overview of Film Workflow

The following describes an overview of the steps necessary to a film workflow:
1 Set up before shooting.
2 Shoot.
3 Telecine transfer.
4 Batch digitize in Avid video editing application.

Following these steps ensures that timecode metadata are preserved from the moment shooting begins to the final delivery of source files to the Pro Tools editor.

Setting Up Before Shooting (Film Workflow)

Before each day’s shooting begins, the production sound mixer should decide on a unique name—preferably ascending by day—and enter that exact name in the Tape BEXT or iXML metadata field inside the Broadcast WAV file.

For example, the production sound mixer might use $T001$ for the first day’s shooting, $T002$ for the second day’s shooting, and so forth.

Shooting (Film Workflow)

1 Shooting proceeds as follows:
• Film camera begins rolling.
• One or more field recorders begin recording. The production sound mixer has designated one or two channels as a production sound mix, which is a consolidation of one or more channels in each multichannel recording.

2 During shooting, the following timecode information is captured:
• The camera captures images to film, each frame of which is embedded during manufacturing with a unique identifying timecode position known as keycode.
• One or more field recorders simultaneously make multichannel recordings that are embedded with SMPTE timecode based on time of day (or longitudinal timecode).

3 During shooting, the following information is noted:
• The camera assistant keeps a written record (called a shootlist) documenting each scene and take with a corresponding keycode position.
• The production sound mixer also keeps a written record (also called a sound log) documenting each scene and take with a corresponding timecode position.

4 The slate operator claps the slate to indicate the beginning of the take. The field recorder records the audio of the clap, and the film camera captures the following images:
• Scene and take number (written on the slate)
• Exact moment the slate closes
• Timecode position of the slate closing

5 Shooting ends and the take is complete.
**Telecine Transfer (Film Workflow)**

When shooting is complete for the day, the following components are delivered to the telecine operator:

- Processed film stock
- Multichannel location audio
- Written shootlist and sound log

The telecine operator generates the *dailies* (a videotape containing the day’s shots) by transferring the film and audio to a videotape. The shootlists will be used as a guide.

**To use a telecine to create dailies:**

1. Load film and audio into the telecine.
2. Enter the Tape name or Sound Roll name (whichever was used during the production) *character for character* into the telecine.

![Warning symbol] *To ensure that metadata are preserved for the Pro Tools editor, it is critical to enter the Tape name or Sound Roll name character for character. For example, if the metadata was T001 (with two zeroes), enter T001 with two zeroes—not T01 with one zero or T0001 with three zeroes.*

3. Using the camera assistant’s shootlist, locate the film frame representing the first keycode position of the film in the shootlist (which should be just before the slate is clapped).

4. Locate the film to the first frame where the slate clap occurs, and note the timecode position displayed on the slate.

5. Locate the audio to the exact timecode position listed on the slate in the film frame (which lines up the audio with the film).

6. Play back the film and audio to test that they are synchronized. If they are not synchronized, make small manual adjustments as needed until the film and audio are synchronized.

7. Once the film and audio are properly synchronized, lock the film and audio in place.

8. Insert a blank videotape into the VTR connected to the telecine, and manually assign linear timecode (LTC) information to the videotape.

9. Begin the telecine capture. During the telecine capture, the following occurs:

   - The telecine begins capturing the synchronized film and audio to the videotape, with linear timecode (LTC) assigned to the videotape beginning from where you entered the start timecode.
   - A FLEEx file is created, where scene and take information is automatically written and associated to the film keycode and telecine videotape timecode relative to audio timecode.

10. When the telecine transfer is complete, deliver the following to the Avid editor:

    - Telecine videotape
    - FLEEx file
    - Shootlist
    - Sound log
    - Location audio media
Batch Digitizing the Telecine Videotape to Digital Files (Film Workflow)

This phase of the workflow begins after the Avid editor receives the following components from the telecine operator:

• Telecine videotape
• FLEEx file
• Shootlist
• Sound log

In some cases, you may also receive location audio from the production sound mixer.

In a film workflow, the Avid editor batch digitizes the telecine videotape to digital video and audio files in order to edit them.

To batch digitize a telecine videotape to digital source files:

1. In the Avid video editing application, import all relevant FLEEx files into Avid Log Exchange.

Avid Log Exchange displays a list of all scene and take combinations, with associated film keycode, audio timecode, and relative videotape timecode.

2. In Avid Log Exchange, select the items in the FLEEx file that represent the scenes and takes you want to batch digitize from the videotape.

3. Process the selected scenes and takes in the FLEEx file. Avid Log Exchange sends the selected items to the Avid video editing application, where they are loaded into the Bin as offline media.

Any metadata required for matching (such as Tape name) should be visible in the undigitized clips.

4. In the Avid Bin, select the items you want to capture.

5. Load the telecine videotape into the Avid, and begin the batch digitize.

The Avid automatically batch digitizes the scenes and takes selected in the Avid Bin, and uses the FLEEx file to assign each of the digitized video and audio files with the timecode information matching the original keycode and timecode information from the shoot.

6. When the batch digitize is complete, use the Avid video editing application to edit audio and video.

7. When you are finished editing, export the edited sequence as an AAF or OMF sequence so that it can be imported into Pro Tools.

Video and Fully Non-Linear Workflows

This topic describes both video and fully non-linear workflows from shooting to the point where the Avid editor is ready for editing, and is intended for the following parties:

• Camera assistant
• Camera operator
• Production sound mixer
• Avid editor
• Pro Tools editor

Any metadata required for matching (such as Tape name) should be visible in the undigitized clips.
Overview of Video and Fully Non-Linear Workflows

The following describes an overview of the steps that are necessary in these workflows:

1. Set up before shooting.
2. Shoot.
3. Digitize video in Avid video editing application (video workflow only) or import digital video files directly into Avid video editing application (fully non-linear workflow only).

Following these steps ensures that timecode and other metadata are preserved from the moment shooting begins to the final delivery of source files to the Pro Tools editor.

Setting Up Before Shooting (Video and Fully Non-Linear Workflows)

Before shooting begins, the camera operator and the production sound mixer should ensure the following:

- The field recorder’s audio output feeds the video camera’s audio input.
- Both the field recorder and the video camera should be locked to the same production timecode.

Matching Tape Name to Sound Roll Metadata for Video Shoots

Before loading the videotape into the video camera, the camera operator physically labels the videotape with a unique name. The production sound mixer must enter that exact name in the Tape BEXT or iXML metadata field inside the Broadcast WAV file.

To ensure that metadata are preserved for the Pro Tools editor, it is critical to enter the Tape name character for character. For example, if the metadata was T001 (with two zeroes), enter T001 with two zeroes—not T01 with one zero or T0001 with three zeroes.

Matching Tape Name to Sound Roll Metadata for Fully Non-Linear Shoots

After loading the digital video storage into the camera, the camera operator gives it a unique name. The production sound mixer must enter that exact name in the Tape BEXT or iXML metadata field inside the Broadcast WAV file.

After you import a file containing Tape metadata into Pro Tools, the metadata displays in the Sound Roll field in Workspace browsers.

Shooting (Video and Fully Non-Linear Workflows)

1. Shooting proceeds as follows:
   - Camera begins rolling.
   - One or more field recorders begin recording.

2. During shooting, the following timecode information is captured:
   - The camera captures images to video or file embedded with SMPTE timecode based on time of day (or longitudinal timecode).
   - One or more field recorders simultaneously make multichannel recordings that are embedded with SMPTE timecode based on time of day (or longitudinal timecode).
The slate operator claps the slate to indicate the beginning of the take. The field recorder records the audio of the clap, and the film camera captures the following images:

- Scene and take number (displayed on the slate)
- Exact moment the slate closes
- Timecode position of the slate closing

Shooting ends and the take is complete.

**Digitizing a Videotape in the Avid Video Editing Application**

*(Video Workflow Only)*

This phase of the workflow begins after the Avid editor receives the following components from the camera operator and the production sound mixer:

- Videotape
- Multichannel recordings

In a video workflow, the Avid editor digitizes the videotape to digital video and audio files in order to edit them. Before doing so, however, the Avid editor must name the tape.

**To digitize a videotape to digital source files:**

1. Load the videotape into the Avid system.
2. When prompted to name the videotape, enter the exact Tape name used by the camera operator and the production sound mixer.
3. Digitize the videotape loaded into the Avid.
4. When the digitize is complete, use the Avid video editing application to edit audio and video.

When you are finished editing, export the edited sequence as an AAF or OMF sequence so that it can be imported into Pro Tools.

**Importing Digital Video Directly into the Avid Video Editing Application**

*(Fully Non-Linear Workflow Only)*

This phase of the workflow begins after the Avid editor receives the following components from the camera operator and the production sound mixer:

- Digital video (on flash card, hard drive, or some other file-based storage)
- Multichannel recordings

In a fully non-linear workflow, the Avid editor simply has to import the video and audio media into the Avid video editing application in order to edit them.

**To import video into the Avid video editing application:**

1. In the Avid video editing application, create a Bin.
2. Import the video files directly into the Bin.
3. When the Disk Label Import dialog appears, enter the exact Tape name used by the camera operator and the production sound mixer.

To ensure that metadata are preserved for the Pro Tools editor, it is critical to enter the Tape name character for character. For example, if the metadata was T001 (with two zeroes), enter T001 with two zeroes—not T01 with one zero or T0001 with three zeroes.

4. Use the Avid video editing application to edit audio and video.
5. When you are finished editing, export the edited sequence as an AAF or OMF sequence so that it can be imported into Pro Tools.
Chapter 60: Working with Video in Pro Tools

Pro Tools lets you do the following:

- Create a single video track and import Avid or QuickTime video to the Timeline
- Organize and group video clips in the Timeline much like audio clips
- Lock video tracks
- Extract audio from QuickTime
- Scrub audio in tandem with video
- View video in the Video window or output it through an Avid supported video peripheral to an external monitor
- Bounce the video track to QuickTime

Pro Tools Ultimate also lets you do the following:

- Import multiple video files into the Timeline
- Create and edit up to 64 video tracks with QuickTime and Avid video in the Timeline
- Select from multiple video playlists on each video track
- Organize, group, and edit video clips with audio clips
- Manage multiple video clips in the Clips List
- Undo multiple video operations

Avid Video Engine (AVE)

Pro Tools uses the Avid Video Engine (AVE) for video playback. AVE lets you simultaneously view desktop video (native video) and video monitored using a supported Avid or third-party video peripheral. AVE provides support for a wide range of QuickTime and Avid HD and SD MXF video formats on Pro Tools video tracks without transcoding (including Avid DNxHD).

To enable the Avid Video Engine for Pro Tools:

2. Enable the Video Engine option to use Pro Tools with the Avid Video Engine.
3. Click OK.

Support for Avid Video Peripherals and Third-party Video Hardware

Pro Tools and Pro Tools Ultimate software supports external video monitoring with qualified video hardware. Using the Avid Video Engine, Pro Tools provides support for monitoring DNxHD and QuickTime media using Media Composer | Nitris DX, Media Composer | Mojo DX, and Avid-qualified third-party video interfaces.
To enable (or disable) external video monitoring with qualified video hardware:

1. Ensure that your Avid or Avid-qualified third-party video hardware is correctly installed and configured.

2. Select (or deselect) Options > Enable Video Hardware.

---

**QuickTime Movie Support in Pro Tools**

Pro Tools supports the import, playback, and editing of QuickTime movies.

**QuickTime Required**

QuickTime must be installed if you plan to include movie files, or import MP3 or MP4 (AAC) files in your Pro Tools sessions. QuickTime for Windows is available as a free download from the Apple website (www.apple.com).

💡 For information on which version of QuickTime is compatible with your version of Pro Tools, visit www.avid.com.

**Supported QuickTime Movies**

When working with someone who is preparing QuickTime movies for use with Pro Tools, ensure that you communicate the following:

**Consolidated and Referenced Media** QuickTime DV movies can be either complete (consolidated) QuickTime files (where media is copied into a QuickTime file) or QuickTime reference files (where just a small composition is in the QuickTime file which references the original media files).

---

**Before Starting Your Project**

Before you start any project that requires working with video, consider the following:

**Frame Rate** Before receiving video, find out the frame rate. Use this frame rate when setting the frame rate of your Pro Tools sessions and when capturing video.

**Creator Application and Codec** Before receiving video as media files, find out the application and codec used to create those files. Then confirm that you can play those files in Pro Tools. It is always a good idea to get a sample file in advance.

**Video Timecode Burn-in** Before receiving video files, request that the timecode display to be “burned in” (superimposed) if possible. This will help you place the file at the correct timecode location in the Pro Tools Timeline.

**Sufficient Space on Video Drives** Ensure sufficient space is available on separate dedicated video-only drives. Video files take up significantly more space and bandwidth than audio. It is recommended that video files be kept on separate drives from audio files to help avoid performance problems.

**Separate Video-Only and Audio-Only Drives** For best results, always use separate video-only and audio-only drives. For complete information on hard drive requirements, visit www.avid.com.
Pro Tools Video Preferences

The Video section of the Pro Tools Operation Preferences provides the following options:

**Enable GPU**

Pro Tools video processing is done on the GPU (Graphics Processing Unit) in order to free up the CPU for Pro Tools audio and MIDI. If you are using a slower GPU and encounter poor video playback, you may want to disable this option and have the video processing done on the CPU.

**Prevent Tearing**

When enabled, Pro Tools buffers video to prevent visual artifacts with horizontal movement in situations where video sync does not match the screen refresh rate. This option is not available when the Enable GPU option is disabled.

**Enable Hardware During Scrub**

When selected, the Enable Hardware During Scrub option lets you monitor video using video hardware (such as Avid Mojo DX or Nitris DX video peripherals) while scrubbing. When this option is disabled, you can only monitor video in the Pro Tools Video window while scrubbing. If you experience performance issues when scrubbing video while monitoring video using video hardware, disable this option.

**Play Start Latency**

If you are working on a slower computer, set the Play Start Latency setting to a higher value. The range is from 1-Shortest to 5-Longest.

**Video Tracks**

Video tracks let you add or import video to the Timeline, as follows:

- Pro Tools lets you add or import one video track per session, with a limit of one video playlist and one Avid or QuickTime video file on that track.
- Pro Tools Ultimate lets you add multiple video tracks to the Timeline, with multiple video playlists and multiple video files per track.
- Pro Tools Ultimate lets you mix QuickTime and Avid video tracks in the Timeline (but not on the same video track).

To create a video track in Pro Tools, do one of the following:

- Use File > Import to import a video file.
- Drag a video file to the Timeline.
- Use File > Import > Session Data to import a session or AAF sequence containing a video track.

For more information, see “Importing Video into Pro Tools” on page 1367.

To create a new video track with Pro Tools Ultimate:

1. Choose Track > New.
2. Select Video Track from the Track Type pop-up menu.
3. Enter the number of new video tracks.
4. Click Create.
A new empty video track appears. Video tracks may appear slightly different depending on your system configuration or the type of video added to a video track.

**Multiple Video Tracks in the Timeline**  
(Pro Tools Ultimate Only)

You can add multiple video tracks to the Timeline, but only one video track can be played back at a time. This track is known as the **main video track**.

**Multiple Video Track Playlists**  
(Pro Tools Ultimate Only)

Playlists provide an easy way of changing back and forth between alternate versions of a video track.

You can perform all of the same operations with video playlists as you can with audio playlists, including:

- Duplicating a playlist
- Creating a playlist
- Assigning a playlist to another video track
- Renaming a playlist
- Deleting a playlist

For more information, see Chapter 32, “Playlists.”

**Multiple Codecs on an Individual Video Track**  
(Pro Tools Ultimate Only)

A single video track can contain video clips compressed with different video codecs of the same type of video. For example, you can add QuickTime files that were compressed using multiple codecs to the same video track.

However, once the first video file has been added to a session, all additional video files added to the Timeline must have the same video frame rate as the first video file.

**Main Video Track**

The main video track is the video track that is currently online, and will be played back with any audio in the session.

When the main video track is offline, you can play back the audio in your session without playing back the video. When the video is offline, the Video Online button changes to gray so you can tell at a glance whether your video is offline or simply playing black fill.

If no video track is currently online, the main video track is the video track that was last online.

**To select the main video track:**

- Click the Video Online button of any track that is offline (gray) to put it online (blue), making that track the main video track.
Video Track Controls and Indicators

Video Track View

The video track can be viewed in Frames View or in Blocks View, both of which display all video clip boundaries and metadata. Video frame images are displayed only in Frames View.

⚠️ When switching from Blocks mode to Frames mode during playback, the video track will not update to displaying frames until playback is stopped.

To set the view for the video track:
- On the video track, select Frames or Blocks from the View Options pop-up menu.

Frames View

In Frames View, video data is displayed as pictures in the video track. These pictures are computed based on the video image, and scale according to your track zoom and height settings. They allow you to easily find a scene or sequence in the video track.

Frames do not display properly if you change zoom settings during playback. Blank frames are drawn until playback is stopped. You should stop playback before changing zoom settings if you want to view frames.

If video pull up or pull down is enabled, frames do not change position.

Frames View Performance

When using Frames View to view video content in the video track, your computer may exhibit reduced or sluggish performance. If this happens on your computer, hide the video track or switch to Blocks View.

Blocks View

In Blocks View, video frames are replaced by colored blocks.

Video Track Type Icons

A video track displays a QuickTime icon if there is QuickTime video on the track. No icon is displayed for Avid video or when the video track is empty.

QuickTime icon

Video tracks displaying a QuickTime icon

You can add any supported video to an empty video track.
Video Online Button

The Video Online button lets you select the main video track, switch that track online or offline, and see at a glance by color whether a video track is offline (gray) or online (blue).

To switch a video track online or offline:

- Click the Video Online button of any track that is offline (gray) to put it online (blue), making that track the main video track.
- Click the Video Online button of the main video track to take it offline, and Pro Tools will not output video.

With Pro Tools Ultimate, press Shift+J to cycle through all shown video tracks to determine which one is online.

Video Track Settings

Pro Tools provides Video track settings for Project Type, Output, and for Video Quality on playback.

To view (or hide) Video track controls in the Edit window:

- Select (or deselect) View > Edit Window Views > I/O.

Project Type

While Pro Tools does not allow mixed frame rates, it does allow different resolutions. The Project Type selector lets you set the Project Type (resolution) to best match mixed resolutions for the session. In general, you will not need to change the Project Type.

For Avid MXF video, Project Type is set automatically. However, when you are working with mixed resolutions, Pro Tools lets you set the closest matching resolution for the session using the Project Type setting.
The following Project Type video resolutions are available (depending on your media and the session setup):

**Supported Video Formats**

<table>
<thead>
<tr>
<th>Video Format</th>
<th>Video Reference Rate</th>
<th>Pro Tools Frame Rate</th>
<th>Video Output Format*</th>
</tr>
</thead>
<tbody>
<tr>
<td>30i NTSC</td>
<td>NTSC</td>
<td>29.97</td>
<td>NTSC</td>
</tr>
<tr>
<td>25i PAL</td>
<td>PAL</td>
<td>25</td>
<td>PAL</td>
</tr>
<tr>
<td>23.976p NTSC</td>
<td>NTSC</td>
<td>23.976</td>
<td>NTSC</td>
</tr>
<tr>
<td>24p NTSC</td>
<td>NTSC</td>
<td>24</td>
<td>NTSC</td>
</tr>
<tr>
<td>24p PAL</td>
<td>PAL</td>
<td>24</td>
<td>PAL</td>
</tr>
<tr>
<td>25p PAL</td>
<td>PAL</td>
<td>25</td>
<td>PAL</td>
</tr>
<tr>
<td>720p/23.976</td>
<td>720p/59.94 or NTSC</td>
<td>23.976</td>
<td>720p/59.94</td>
</tr>
<tr>
<td>720p/25</td>
<td>720p/25 or PAL</td>
<td>25</td>
<td>720p/25</td>
</tr>
<tr>
<td>720p/29.97</td>
<td>720p/59.94 or NTSC</td>
<td>29.97</td>
<td>720p/59.94</td>
</tr>
<tr>
<td>720p/50</td>
<td>720p/50 or PAL</td>
<td>25</td>
<td>720p/50</td>
</tr>
<tr>
<td>720p/59.94</td>
<td>720p/59.94 or NTSC</td>
<td>29.97</td>
<td>720p/59.94</td>
</tr>
<tr>
<td>1080i/50</td>
<td>1080i/50 or PAL</td>
<td>25</td>
<td>1080i/50</td>
</tr>
<tr>
<td>1080i/59.94</td>
<td>1080i/59.94 or NTSC</td>
<td>29.97</td>
<td>1080i/59.94</td>
</tr>
</tbody>
</table>

* The video output format may be displayed on the external monitor.

**QuickTime Media**

When importing a QuickTime movie, the following conditions may apply:

Pro Tools automatically sets the Frame Rate and Project Type on import based on the QuickTime movie’s frame rate and resolution.

If multiple project types are possible, Pro Tools lets you select the Project Type from the best possible matches available.

If the frame rate is close to a whole value, Pro Tools rounds to the nearest frame rate (for example, 29.972 is rounded to 29.97)

For imported QuickTime media of an unknown Project Type (such as stills or screen captures), change the Project Type setting to best match other video in the session.

**Command-click (Mac) or Control-click (Windows) to override Pro Tools and select and Project Type.**
Output Settings

Pro Tools provides an Output Settings window for configuring your Avid or Avid-qualified third-party video peripheral. The Output Settings are saved with the system. The Output Settings button is unavailable when working with video without a video peripheral.

To configure the Output Settings for your video peripheral:

1 On an existing Video track or on a newly created Video track, click the Output Settings button.

2 If a Mojo DX or a Nitris DX is connected, the Video Output Tool opens. If a third-party video peripheral is connected (such as an Avid supported Blackmagic or AJA video peripheral), its control panel is opened.

3 Configure the Output Settings for your Avid Video peripheral or the third-party control panel as desired.

Output Settings Options

In the Video Output Tool window, click the Options tab to configure the options for video output that are relevant to your video hardware and project type.

Video Output Tool, Options tab (Nitris DX hardware)

One or more of the following options are available in the Video Output Tool dialog depending on your video hardware, project type, and video resolutions. The Video Output Tool is not available with systems that do not use Avid video hardware. For systems that use third-party hardware (such as Avid supported Blackmagic or AJA video peripherals), the Output Settings button launches the control panel for your video hardware.
Sync Lock

The Sync Lock setting locks your video peripheral to an external reference or an internal clock. Pro Tools automatically detects the type of Avid video hardware you have and displays the appropriate options from the following:

- Mojo DX options:
  - Internal
  - Reference
- Nitris DX options:
  - Internal
  - Loop Through
  - Ref 1
  - Ref 2

If a SYNC HD is installed and enabled, and Clock Reference is set to Video Reference in the Session Setup window, suggested formats are highlighted in the Video Ref Format selector of the Session Setup window for Avid DX and DNxIO hardware.

HDMI Color Space

The options for HDMI Color Space are dynamic depending on whether a Mojo DX or Nitris DX is connected, as well as other settings. The HDMI Color Space setting determines the color standard (either YCbCr or Convert to RGB) to use for your HDMI (High-Definition Multimedia Interface) output. You must have HDMI-compatible Avid video hardware attached to your system.

HDMI Format

When working with SD video, this setting provides the following options:

- SD Interlaced
- SD Progressive

Output PSF or True Progressive

When working with HD video, this setting lets you toggle the hardware between PSF and Progressive output formats:

- PSF Output
- True Progressive

NTSC Has Setup

This option determines the correct color mapping for systems depending on whether or not you are using NTSC-EIAJ. NTSC-EIAJ users should not select this option. All other users should select this option.
Video Output Tool Calibration Settings
(Nitris DX Only)

In the Video Output Tool window, click the Calibration tab to configure the calibration settings for video output.

Output Menu for Non-HD Video

The Output selector lets you select either Component, Composite, S Video for non-HD projects.

On some systems, all outputs on your video hardware are active. Select an analog signal from the Output menu to calibrate the output.

Sat Lets you adjust saturation, a measurement of chrominance or the intensity of color in the video signal. Available for S Video or Composite output.

SC Phase Lets you adjust the subcarrier phase (the color-burst portion of a signal used to synchronize the timing of two or more video signals). Available for S Video or Composite output.

Setup Lets you set the relative lightness and darkness of images. Available for S Video, Component, or Composite output.

Gain Lets you adjust the variation of the lightest or brightest in comparison to the darkest portions of the image. Available for S Video or Composite output.

Y Gain, Pr Gain, Pb Gain Available for Component output only.

Y Gain—Lets you adjust Y Gain, a measurement of luma (Y) in the video signal that is the whitest point in the visible picture. Use color bars to set the white level.

Pb Gain—Lets you adjust the gain of the Pb color-difference signal (a scaled version of the BY signal) of an analog component system.

Pr Gain—Lets you adjust the gain of the Pr color-difference signal (a scaled version of the RY signal) of an analog component system.

System Phase

Some Avid video hardware configurations let you modulate the timing of the output signal and a reference signal. This option is available for S Video, Component, or Composite output.

SubPixel HPhase

The SubPixel HPhase setting provides a fine adjustment of Horizontal phase. Available for S Video, Component, or Composite output.
Output Menu for HD Video

The Output menu lets you select HD Component output, Convert to HD Component RGB, or HD Component YPbPr.

Gain Let you adjust a measurement of luma (Y) in the video signal that is the whitest point in the visible picture. Use color bars to set the white level. Available on some systems for HD Component RGB or HD Component YPbPr output.

Pb Gain For some Avid video hardware configurations, the Pb Gain setting lets you adjust the gain of the Pb color difference output, scaled from BY using the BT. 709 color space in HD component systems. This setting is available for HD Component YPbPr output.

Pr Gain For some Avid video hardware configurations, the Pr Gain setting lets you adjust the gain of the Pr color-difference signal (a scaled version of the RY signal) of an analog component system. Available for component output only.

System Phase

The System Phase setting lets you modulate the timing of the output signal and a reference signal. This option is available for HD Component RGB or HD Component YPbPr output.

Sub Pixel H Phase

The Sub Pixel H Phase setting lets you adjust the horizontal blanking interval used to synchronize the timing of two or more video signals. The Sub Pixel H Phase setting is available on some systems for S Video, Component, or Composite output.

Video Quality

Use the Video Quality selector to set the video quality for the track on playback. You can choose from options that range from best performance (lower video quality) to full quality.

The following options are available:

Full Quality

Select the Full Quality option to process and play back the full image raster for the project. Full Quality uses a bit depth of 8 bits. This option provides the highest video playback quality by processing every image pixel. In interlaced projects, this option processes the full width of every line in both fields. In progressive projects, this option processes the full width of every scan line.

Full Quality 10-bit

Select the Full Quality 10-bit option to process and play back the full image raster for the project. This option uses a bit depth of 10 bits, which provides higher quality processing. This options is only available with video hardware connected.

Draft

Select the Draft option to process and play back the full image raster for the project that uses 1/4 of the image information. The Draft option uses a bit depth of 8 bits. This option subsamples 50% of the raster width. For interlaced projects, this option uses one field. For progressive projects, this option uses 50% of the scan lines.

Best Performance

Select the Best Performance option to process and play back the full image raster for the project using 1/16 of the image information. The Best Performance option uses a bit depth of 8 bits. This option subsamples 25% of the raster width. For interlaced projects, this option uses 50% of the lines in one field. For progressive projects, this option uses 25% of the scan lines. This option is only available with Avid Mojo and Nitris DX.
Locking Video Tracks

You can lock one or more video tracks to prevent any video clips on those tracks from being edited.

When a video track is locked, Pro Tools restricts all editing operations involving the track (except for locking and unlocking video clips).

A locked video track displays a small lock to indicate that the video track has been locked and cannot be edited. (The lock does not appear if the Track Height of the video track is set to Mini.)

To lock a video track:

1. Select the video tracks you want to lock.
2. Do one of the following:
   - Control-click (Mac) or Start-click (Windows) the name of any selected video track, and select Locked.
   - Right-click the name of any selected video track, and select Locked.

Locking or unlocking a video track does not alter the lock status of individual clips. If a clip was locked before you lock the track, the clip will still be locked when you unlock the track. However, unlocking a clip in a locked track will not allow you to edit that clip. It will behave as if the clip were locked until you unlock the track.

💡 You can Edit lock or Time lock individual Video clips. For more information about locking clips, see “Locking Clips” on page 907.

Video Engine Rate

The video engine rate represents the number of video frames output by Pro Tools per second, and is determined automatically by the frame rate of the first video file added to a session. Video files subsequently added to the session must have the same video frame rate as the video engine rate.

The video frame rate is displayed for each video file in the Workspace browsers, and the current video engine rate is displayed in the I/O View of the main video track.

See “Video Engine Rate Indicator” on page 1367 for information on the Video Engine Rate indicator in the I/O View.

The video engine rate is independent of the session’s timecode rate, which determines the number of frames displayed per second in grids, rulers, and counters. You can set the session timecode rate manually with the Timecode Rate pop-up menu in the Session Setup window. In order for the grids and rulers to align with the actual frames of the video files in the Timeline, the session’s Timecode Rate setting should be set to match the video engine rate.
Video Engine Rate Indicator

The Video Engine Rate indicator displays only in the main video track (whether it is online or offline) and shows the video engine rate, which is the number of video frames per second output by Pro Tools.

The Video Engine Rate indicator is normally white, but turns red if one of the following conditions are present:

- The video engine rate does not match the session’s current Timecode Rate setting.
- A pull up has been applied to the video, causing the video engine rate to differ from the session Timecode Rate.

![Image of Video Engine Rate Indicator]

Video Frame Rate

The video frame rate of the first video file added to a session determines the session’s video engine rate. Video files subsequently added to the session must have the same video frame rate as the video engine rate.

The Timecode Rate is set in the Session Setup window. For more information, see “Session Setup Window” on page 1269.

See “Pull Up and Pull Down” on page 1277 for detailed information on using video pull up and pull down.

Importing Video into Pro Tools

Pro Tools provides the following methods of importing video files into the Timeline, Clips List, and new or existing video tracks:

- Using the Import Video command (File > Import > Video)
- Dragging from the Clips List to the Timeline (Pro Tools Ultimate only)
- Dragging from a Workspace browser or from Windows Explorer or Mac Finder
- Using the Import Session Data command (File > Import > Session Data)—this lets you import video from another Pro Tools session, or from an AAF file, but not individual video files

The video frame rate of the first video file added to a session determines the session’s video engine rate. Video files subsequently added to the session must have the same video frame rate as the video engine rate.

In general, audio and video media should be stored on separate dedicated drives. When importing audio and video at the same time by linking to media, however, Pro Tools may copy both to the same drive. To avoid performance problems, move the video to a video playback drive before importing the audio and video into your session.

In a Workspace browser, you can designate your audio drives to play or record audio but only transfer video, or vice versa. You may use these settings to ensure that your audio and video are on the correct volumes. For detailed instructions, see “Volume Permissions” on page 312.
Importing Video into Pro Tools
Using the Import Video Command

The Import Video menu command lets you choose one or more video files to import into Pro Tools.

When you use this method to import video into Pro Tools, the Video Import Options dialog appears. This dialog contains multiple options for customizing how files are imported.

To import video into Pro Tools using the Import Video command:

1. Do one of the following:
   • Choose File > Import > Video.
   • Press Command+Option+Shift+I (Mac) or Control+Alt+Shift+I (Windows).

2. In the Select Video File to Import dialog, select one or more video files.

3. Click Open.

4. Configure the Video Import options, and click OK to import video into Pro Tools.

To import video into Pro Tools using drag and drop:

1. Drag one or more video files from a Workspace browser or from Windows Explorer or Mac Finder to the Tracks List, Timeline, or an existing video track.

2. Configure the Video Import options, and click OK to import video into Pro Tools.

   See “Configuring Video Import Options” on page 1369 for detailed instructions.

Importing Video into Pro Tools
Using Import Session Data

You can use the Import Session Data command to import video from other Pro Tools sessions or from an AAF sequence. Any video files you import must have the same video frame rate as any video file already present in the session.

For information on importing session data, see “Importing Session Data” on page 416.

Dragging Video Files from the Clips List to the Timeline
(Pro Tools | Ultimate Software Only)

You can add video files to the Timeline by dragging and dropping directly from the Clips List to a video track.

To add video files to a video track by dragging them from the Clips List:

1. Select one or more video files in the Clips List.

2. In any Edit mode, drag the selected video files to a blank area in the Timeline (to create a new video track) or an existing video track (to place it within that track).
Configuring Video Import Options

The Video Import Options dialog appears when you import video into Pro Tools by using the Import Video command or dragging video files from a Workspace browser or from Windows Explorer or Mac Finder.

Destination Section

The Destination section of the Video Import Options dialog lets you choose a general destination for imported video in Pro Tools.

- **Main Video Track** The video file is imported directly to the track that is currently online (known as the main video track) and into the Clips List. If no track is currently online, the video file will be imported to the last existing video track that was online.
- **New Track** Each video file is imported into its own individual track and into the Clips List.
- **Clips List (Pro Tools Ultimate Only)** Each video file is imported directly into the Clips List, where it will be available to drag and drop into the Timeline.

Location Pop-Up Menu

If you do not select the Clips List as a destination in the Destination section, the Location pop-up menu lets you choose precisely where in the Timeline Pro Tools places imported video.

- **Session Start** Places the video file at the start of the session.
- **Song Start** Places the video file at the Song Start position.
- **Selection** Places the video file at the edit cursor position or within the selection (if one was made).
- **Spot** Displays the Spot dialog, which lets you spot video to precise locations based on any of the Time Scales.
- **Original Time Stamp (Avid Video Only)** Places Avid video in the Timeline at a timecode location that corresponds to the timestamps from the original source tape. With multiple video files, this places all video files in the Timeline at their respective original timestamps.

Additional Video Import Options

- **Gaps Between Clips (Pro Tools | Ultimate Only)**

When you import more than one video file into a track, they will be shuffled together by default. This option lets you indicate the number of seconds by which each video clip will be separated when imported into the video track.
Import Audio from File (QuickTime Video Only)
When selected, the audio from the QuickTime video file you are importing will be extracted and placed into new mono or stereo audio tracks in the Timeline. (Mono or stereo audio with a sample rate of 48 kHz or lower are supported.) When unselected, only the video portion of the video file will be imported into Pro Tools.

Remove Existing Video Tracks When selected, all existing video tracks will be deleted before Pro Tools imports video into the session.

Remove Existing Video Clips When selected, all existing video clips will be removed from the Timeline and the Clips List before Pro Tools imports video into the session (but left on disk). This option is useful if you want to import a video file into the session with a video frame rate that does not match the current video engine rate.

Clear Main Video Track Playlist When selected, all existing video clips in the currently-selected playlist on the main video track will be removed from the track before Pro Tools imports video into the session. No other playlists, video tracks, or video clips will be affected. (This option is only enabled if the main video track is selected as the Destination option.)

Bypassing the Video Import Options Dialog
You can bypass the Video Import Options dialog when dragging video files into Pro Tools. The video files are added exactly where you drop them in the Timeline following the current Pro Tools editing mode.

To bypass the Video Import Options dialog when importing video into Pro Tools:
- Option-drag (Mac) or Alt-drag (Windows) one or more video files from a Workspace browser, Windows Explorer, or Mac Finder into the Clips List or the Timeline.

Importing Audio from a QuickTime Video Clip
For QuickTime Video clips, Pro Tools lets you right-click on selected clips to import the audio from the QuickTime movie clips even if you imported QuickTime video without its associated audio.

To import audio from a QuickTime video clip:
1. Right-click on a QuickTime video clip in a video track or in the Clips List.
2. Choose Import Audio From Movie.
3. In the resulting dialog, specify the location where you want to save the audio and click Open.

See “Video Engine Rate” on page 1366 for more information.
4 In the Audio Import Options dialog, select whether you want to import the audio to the Clips List or to a New Track.

5 If you selected New Track, select the Location for the audio:
   - Session Start
   - Song Start
   - Selection
   - Spot

6 Click OK to import the audio (or click Cancel to cancel the import).

**Sample Rate Conversion Quality**

If you import QuickTime audio that was not originally recorded at the session’s sample rate, the sample rate is converted to match the audio to your session. Pro Tools allows you to choose the quality of the sample rate conversion by means of the Conversion Quality setting in the Processing Preferences page.

There are five possible settings, ranging from Low (lowest quality) to Tweak Head (highest quality). The higher the quality of sample rate conversion, the longer it takes to convert the bounced file.

**To set the sample rate conversion quality:**

1. Choose Setup > Preferences and click the Processing tab.
2. Click the Conversion Quality pop-up menu and select a conversion setting.

**Video Clips**

You can create video clips that function in much the same way as audio clips.

*Video clip as displayed in Frames View in the Timeline*

A video clip is a segment of video data, and can be a portion of video or an entire video file. In Pro Tools, video clips are created from QuickTime or Avid video files, and can be arranged in corresponding video track playlists. Video clips can also be grouped, looped, and color coded.

When using Pro Tools Ultimate, you can add, edit, and change viewing options for video clips in the same ways as audio clips. All edits to video clips are nondestructive. (See “General Video Editing” on page 1372 for more information.)

Just like audio clips, video clips display in Pro Tools in the Clips List or the Timeline (see “Video Clips in the Clips List” on page 1372).

When using Pro Tools, the following limitations apply to video clips:

- You can add only one video clip to a session. It can be played back, but cannot be edited and will not be listed in the Clips List.
- When you import video or open a session created by Pro Tools Ultimate, only the main or first available video track containing QuickTime clips will be imported. You can play back and view multiple clips, and tab through clip boundaries. However, you cannot edit them.
Video Clips in the Clips List  
(Pro Tools Ultimate Only)

A video clip displays in the Clips List with a small video icon next to its name.

Showing or Hiding Video Clips in the Clips List

The Clips List menu provides commands that let you show or hide video clips in the Clips List.

To show or hide video clips in the Clips List:

1. In the Edit window, click the Clips List menu, and choose Show.
2. Select the Video option to show or hide video clips.

General Video Editing  
(Pro Tools | Ultimate Software Only)

Most editing operations that are available for audio clips can also be applied to video clips. This section describes all available video editing operations. Unless noted, the procedure for each video editing operation is the same as its audio editing counterpart.

For more information, see Chapter 16, “The Clips List.”

Video clip icon in the Clips List

For more information, see Chapter 16, “The Clips List.”

Basic Video Editing Features

- Nondestructive editing
- Display of clip names, clip times, and other data in playlists
- Multiple video playlists
- Multiple Undo
- Video clips and video clip groups in Clips List
- All Edit modes
- All Edit Tools (except for Time Compression Expansion and Pencil tools)

Playing and Selecting Video Track Material

- Selecting within video frame boundaries (see “Selecting within Video Frame Boundaries” on page 1374)
- Selecting and editing across multiple tracks (see “Selecting and Editing Across Multiple Audio and Video Tracks” on page 1373)
- Link or unlink track and Edit selections
- Auto-scroll video tracks
- Loop playback
- Video Universe window (see “Browsing Video in the Video Universe Window” on page 1377)
Working with Clips and Selections

- Capture clips
- Separate clips and Separate Grabber Tool
- Clip overlap and underlap
- All trimming commands except for TCE
- Heal separated clips
- Place, align, slide, shuffle, and spot clips
- Nudging (quantized to frame boundaries)
- Shift command (moving track material back or forward in time by a specified amount)
- Quantize Clip to Grid (rounds to nearest video frame)
- Replace Clip command
- Cut, Copy, Paste, and Clear commands
- Special Cut, Copy, Paste, and Clear commands
  - Repeat to fill selection
  - Editing across multiple tracks
- Duplicate command
- Repeat command
- Clip groups (see “Video Clip Groups” on page 1374)
- Clip looping

Managing Clips

- Insert space (see “Using the Insert Silence Command to Insert Space in Video Tracks” on page 1374)
- Compact Selected (nothing happens to the video, and at least one audio track must be selected)
- All naming and displaying of clip commands

General Editing Operations Not Applicable to Video Clips

The following editing operations are applicable to audio clips, but are not applicable to video clips:

- Fades
- Mute/unmute clips
- AudioSuite plug-ins
- Waveform Repair with the Pencil tool
- Strip Silence
- Consolidate clips

Selecting and Editing Across Multiple Audio and Video Tracks

You can create a selection across multiple audio and video tracks, and cut, copy, or paste audio and video simultaneously.
Audio and video that is selected and cut, copied, or pasted follow the current Edit mode.

**Selecting within Video Frame Boundaries**

Pro Tools does not let you select, play back, or edit a partial video frame. The following rules apply when selecting or editing video:

- When you make a selection in a video track, the selection boundaries follow the current Grid setting but round to the nearest video frame boundary, as follows:
  - If the selection includes more than half of a video frame, the full video frame is included within the selection.
  - If the selection includes less than half of a video frame, that video frame is not included in a video selection.
  - When you paste a selection containing video to a video track, the insertion point automatically aligns with the closest video frame boundary.

⚠️ *When you paste audio and video simultaneously, this video frame re-alignment may result in the audio not being positioned exactly where you placed it. A warning dialog displays when this occurs.*

**Using the Insert Silence Command to Insert Space in Video Tracks**

The Insert Silence command lets you make a selection on a track (or tracks) and insert precisely that amount of space. You can also select across video and audio tracks, and use the Insert Silence command to insert audio silence and space simultaneously.

In Shuffle mode, all video data on the track is shuffled later in the track by an amount equal to the selection. In Slip, Grid, or Spot mode, the Insert Silence command works just like the Edit > Clear command.

**To insert space into a video track:**

1. Make a selection in a track or tracks. The length of the selection determines the duration of the space inserted.
2. Choose Edit > Insert Silence.

**Renaming Video Disk Files**

When renaming audio clips in either the Timeline or the Clips List, you have the option of also renaming the audio files on disk. However, this does not apply to video files on disk.

To rename video files on disk, you must rename them in a Workspace browser or in Windows Explorer or Mac Finder.

⚠️ *Changes made in the operating system will not automatically update the information displayed in the Workspace browser.*

**Video Clip Groups**

*(Pro Tools | Ultimate Software Only)*

You can include video clips within clip groups for the following operations:

- Creating clip groups
- Creating multitrack clip groups (including audio tracks)
- Editing clip groups
- Creating fades and crossfades for audio files in clip groups
- Importing and exporting clip group files
Using the Video Window

Pro Tools provides a Video window that lets you view, display, or scrub video.

Avid video displays in the Video window only when scrubbed or shuttled.

To display the Video window, do one of the following:

- Select Window > Video.
- Press Command+9 (Mac) or Control+9 (Windows).

Resizing the Video Window

You can resize the Video window by dragging or using the Video window pop-up menu.

To resize the Video window by dragging:

- Place the cursor at any corner of the Video window, and drag the window to the size you want.

To resize the Video window by using the Video window pop-up menu:

- Right-click (Windows or Mac) or Control-click (Mac) the Video window, and choose from the following resize options:
  - Quarter Size
  - Half Size
  - Actual Size
  - Double Size
  - Full Screen
  - Aspect Ratio

Managing Aspect Ratio in the Video Window

Pro Tools lets you include video media with different aspect ratios on a single video track. When viewing video with mixed aspect ratios or for video that simply does not match the aspect ratio of the Video window, Pro Tools lets you stretch (or squeeze) mismatched aspect ratios to fit or to maintain differing aspect ratios.

To set the Pro Tools Video window preference for managing mixed aspect ratios:

- Right-click in the Video window and select Stretch or Pillarbox/Letterbox.

Stretch

When the Stretch option is selected, the picture scales to match the width and height dimensions of the Video window. If the picture’s aspect ratio does not match the Video window’s aspect ratio, the image is stretched or squeezed accordingly.
**Pillarbox/Letterbox**

When the Pillarbox/Letterbox option is selected, the picture scales to create the largest possible image without cropping, while maintaining the original aspect ratio of each video clip. When this option is selected and you have video media with mixed aspect ratios on the online video track, or video that does not match the aspect ratio of the video window, there will be visible black borders around video that uses a smaller aspect ratio than the Video window. Additionally, this option can result in a significant increase in CPU usage. If you encounter performance problems, consider using the Stretch option.

**Scrubbing the Video Track**

Pro Tools lets you scrub video directly on a video track. When scrubbing on a video track, only the video scrubs (no audio plays). Video scrubbing is displayed in the Video window. If video hardware is connected, you can choose to scrub video with external video monitoring as well as in the Video window.

When scrubbing audio with a video track online, both audio and video scrub synchronously.

> For information on enabling (or disabling) video scrubbing with video hardware, see “Enable Hardware During Scrub” on page 1357.

**To scrub a video track:**

1. Select the Scrubber tool.
2. Click in the video track and drag the Scrubber.

> To scrub with finer precision, press the Command key while scrubbing.

**Shuttling the Video Track**

Shuttle Lock mode lets you use the numeric keypad to shuttle a video track and one or two audio tracks forward or backwards at specific speeds. Numbers 0 through 9 provide progressively faster speeds, as follows:

- To stop shuttling, press 0.
- To increase the speed progressively towards normal speed, press numbers 1 through 4.
- To shuttle at normal speed, press 5.
- To increase the speed progressively faster than normal speed, press numbers 6 through 9.

Only the main video track is shuttled. When multiple audio tracks are selected, only the first two tracks are shuttled.

**To play the video track with the shuttle lock:**

1. With Pro Tools Ultimate, make sure the Operation preference for Numeric Keypad mode is not set to Shuttle (see “Operation Preferences” on page 108).
2. Make sure the Video Online button in the video track you want to scrub is set to an online (blue) status.
3. With the Selector tool, click in the audio track where you want playback to begin. To shuttle on two tracks, Shift-click in a second audio track.
4. Press the Control (Mac) or Start key (Windows) and a number on the numeric keypad: 0–9 (9 is fastest, 5 is normal speed, and 0 stops shuttling).

Once Shuttle Lock mode is initiated, Fast Forward and Rewind become highlighted in the Transport window.

5. Press additional keys to change the playback speed, or press Plus (+) or Minus (−) to switch the playback direction (plus for forward, minus for backward).
To stop playback, press Control+0 (Mac) or Start+0 (Windows).

To exit Shuttle Lock mode, do one of the following:
- Click Stop in the Transport.
- Press the Spacebar.

### Browsing Video in the Video Universe Window
(Pro Tools Ultimate Only)

The Video Universe window lets you view, navigate, zoom, and select video clips on the main video track.

The Video Universe window displays the center video frame of each video clip in the main video track. Video frames are ordered sequentially according to their order in the Timeline, and the colored strip under each frame represents the color coding for that clip.

**To display the Video Universe window:**

1. Make sure the Video Online button in the main video track is set to online status (blue).
2. Choose Window > Video Universe.

### Increasing or Decreasing the Size of Video Frames

To increase or decrease the size of video frames in the Video Universe window:

- Right-click (Windows or Mac) or Control-click (Mac) anywhere in the Universe, and select Increase or Decrease.

### Selecting Zoom Resolutions in the Video Universe

When you move the cursor over the top half of a video frame in the Video Universe, it displays and behaves as a zoom tool. This tool lets you zoom in on one or more video clips to fill the entire Edit window display.

![Video frame with zoom tool](image)
To use the Video Universe window to zoom video clips in the Edit window:

1. Move the cursor over the top half of any video frame until it becomes a zoom tool.

2. Do one of the following:
   - To move the beginning of a video clip to the far left of the Timeline while maintaining the current zoom resolution in the Edit window, click the video frame representing the clip once.
   - To zoom in on a video clip so that it fills the entire Edit window, double-click the video frame representing the clip.
   - To zoom a range of selected clips so that they fill the Edit window, drag on the video frames that represent the clips.

Selecting Ranges in the Video Universe

When you move the cursor over the bottom half of a video frame in the Video Universe, it displays and behaves as a selector tool. This tool lets you select ranges within one or more video clips in the Edit window.

To use the Video Universe window to select ranges in video clips in the Edit window:

1. Move the cursor over the bottom half of any video frame until it becomes a selector tool.

2. Do one of the following:
   - To place the cursor at the beginning of a video clip, click the video frame representing the video clip.
   - To select an entire video clip from start to end, double-click the video frame representing that clip.
   - To select one or more entire clips from start to end, drag the video frames representing the video clips.

If the Edit window does not display the selected video clips, it will automatically scroll to show the beginning of the selection.

Selecting Zoom Resolutions and Ranges Simultaneously in the Video Universe

When you move the cursor over a video frame in the Video Universe while pressing Option (Mac) or Alt (Windows), the cursor appears as a selector tool. This tool lets you zoom and select ranges simultaneously.

To use the Video Universe window to select and zoom simultaneously in the Edit window:

1. Move the cursor over any area of any video frame in the Video Universe window until it becomes a selector or zoom tool.

2. To select a range of video clips while simultaneously zooming to fill the Edit window, Option-drag (Mac) or Alt-drag (Windows) multiple video frames.
Playback of High-Definition Video

Pro Tools lets you import and play back High-Definition (HD) video files.

Setting Session Timecode Rate for HD Video Import

When playing back video with frame rates higher than 30 fps, Pro Tools syncs properly only if the Timecode Rate in the Session Setup window is set to half of the video frame rate of the video files.

For example, to properly play back HD video at 59.94 fps, change the session’s Timecode Rate to 29.97 frames per second.

To set the session’s Timecode Rate:

1 Choose Setup > Session.

   Press Command+2 (Mac) or Control+2 (Windows) to open the Session Setup window.

2 In the Session Setup window, select the appropriate timecode rate in the Timecode Rate pop-up menu.

Optimized Video Playback

Certain video codecs provide optimal playback performance with Pro Tools using sample mapping (such as DNxHD, Apple Pro Res, and DV25). Video clips using these codecs appear with a check-mark icon in the Pro Tools Clips List and on the timeline.

Non-sample mapping video codecs (such as Photo JPEG) play back normally, but may drop frames on video playback. Video playback performance is not guaranteed with these codecs. These video codecs do not display the Optimized Video Clip icon (a check-mark icon) in the video clip on video tracks or in the Clips List.
To show (or hide) the Optimized Video Clip icon, do one of the following:

- Select (or deselect) View > Clip > Processing State.
- From the Clips List menu, select (or deselect) Show > Processing State.

⚠️ Enabling (or disabling) the Processing State option show (or hides) both the Optimized Video Clip icon and the Elastic Audio icon.

Tips for Optimizing Video Playback

When using Pro Tools to play video files, the quality of the playback is dependent on the following:

- Quality of the video hardware (graphics card) used to play back the digitized video
- Speed of your computer and hard drive
- Size (in pixels) of the video file
- Codec and level of compression used

For more consistently smooth video playback, here are some suggestions:

- Use a supported Optimized CODEC, such as DNxHD. (Visit www.avid.com for a list of supported video codecs.)
- Re-compress the video to a standard video resolution (such as 1920 x 1080). Be sure to use a resolution that is supported by your video codec.
- Select a Project Type that best matched your video frame rate and resolution.

- Use the fastest computer and graphics card possible.
- Use an Avid video peripheral.
- Set Scrolling option to None (Options > Scrolling > None).
- When working with non-sample mapped video codecs, use a video clip with less compression (heavily compressed files require more processor speed to decompress for display).
- Hide the video track when not needed (or change from Frames to Blocks view).
- Ensure that any unnecessary software is not running.
- Resize the Video window to actual size.
- If you are having poor performance, or any other any anomalies, try disabling the GPU in the Pro Tools Operation Preferences. In most cases, utilizing the GPU will increase performance, but some configurations will perform better when the video processing is done using the CPU.

Compensating for Video Monitoring Delays

You can compensate for delays in the video output that may be introduced by external decoders and certain types of displays (such as projectors or plasma screens).

To compensate for delays caused by video monitoring devices:

1. Choose Setup > Video Sync Offset.
2. In the Set Video Sync Offset dialog, enter a value in the QuickTime Video Offset field or Windows Media Video Offset field that is appropriate to compensate for the delay caused by your video monitor chain.
Once this value is set, it should not need to be updated unless you change components in your video monitoring chain (such as projectors or plasma screens).

Playing Video to an External Monitor Using a Video Peripheral

With a qualified video peripheral, Pro Tools can play and display Avid and QuickTime SD or HD video files with frame edge-locked HD image output to a variety of professional HD monitors.

HD or SD Output

Pro Tools lets you output Avid and QuickTime HD or SD video to an external HD-SDI, HDMI, NTSC, or PAL monitor using an Avid Qualified video peripheral.

Video Reference

Video output can be locked to external video reference, including Black Burst and Tri-Level Sync.

Pro Tools Ultimate should be locked to a suitable clock reference, such as a SYNC HD. If no external audio clock is referenced, audio will not be frame-edge aligned and may drift.

Bouncing the Video Track to a QuickTime Movie

When you have finished your final mix and synchronized your audio events to the movie, you can bounce the main video track and a mono, stereo, or greater-than-stereo (Pro Tools Ultimate only) mixdown of your session to a new QuickTime movie. Pro Tools Ultimate also lets you bounce multiple stems to QuickTime.

You can choose from a variety of standard QuickTime codecs, which are fully compatible with other QuickTime applications.

To bounce video and audio in the video track to a QuickTime movie:

1. Finalize your mix (or stems).

2. Make sure the video track you want to bounce is currently the main video track. (The track’s Video Online button must be highlighted blue.)

3. Make sure that all of the audio tracks you want to include in the bounce are audible (not muted or inactive).

4. Assign the output of each of the tracks you want to include in your bounce to the same stereo output or bus path.

5. Do one of the following:
   - To bounce the entire session, click Return to Zero in the Transport to go to the beginning of the session.
   - To bounce a portion of the session, enable Options > Link Timeline and Edit Selection, and make a selection in the Edit window or the Timeline.

6. Choose File > Bounce to > QuickTime Movie. The QuickTime Bounce dialog appears.
Select your main mix output or bus path from the Bounce Source selector. If desired, select additional bounce sources (see “Bouncing Multiple Sources Simultaneously” on page 1190).

Configure the File Type, Format, Bit Depth, and other Bounce options as desired (see “Bounce Options” on page 1190).

Select the Include Video option to include the online video track in the bounce.

Select Same as Source, Replace Timecode Track, and Use Avid Codecs as appropriate (see “Bounce to QuickTime Settings” on page 13820).

If you are bouncing Avid to QuickTime and you want to configure QuickTime video settings, click QuickTime Settings.

Refer to Apple’s documentation for detailed information on configuring QuickTime movie settings.

Enable the Offline option for faster-than-real-time bounce.

Select a destination for the new QuickTime movie, enter a new name, and click Save.

Bouncing video may take longer than real-time, depending on the format of the source video, the format of the bounced video, and processing speed.

Bounce to QuickTime Settings

When bouncing to QuickTime, the following additional options are available:

Include Video

Enable this option to include the online video track in the bounced QuickTime file.

Same as Source

Select the Same As Source option to bounce to QuickTime using the same video resolution as the online video track. The Same As Source option is not always available with some types of LongGOP QuickTime media (such as XDCAM), or when mixing multiple Codecs on a track.
Replace Timecode Track

When the Same as Source option is selected, enable the Replace Timecode Track option to have the timecode track in the bounced QuickTime file replaced by the selected timecode range in the session. If no timecode track is present in the source video file, the timecode range from the session is added to the bounced QuickTime file.

Note that when Same as Source is not enabled, a completely new file is generated and the selected timecode range in the session is used regardless of the Replace Timecode Track option.

Use Avid Codecs

The Use Avid Codecs option is only available when using codecs that are installed with the Avid LE (available from www.avid.com) or PE Codec packs (included with the Pro Tools installer). Select this option if two similar codecs are present on a system. For example, DV25 is usually included with a standard QuickTime installation, but Avid also offers a DV25 codec that is optimized for use with Avid products (such as Pro Tools and Media Composer).

When bouncing an Avid codec to QuickTime, the Avid codec must be installed to playback the QuickTime file in QuickTime Player on any playback system.

QuickTime Settings

Pro Tools lets you transcode video to QuickTime using the QuickTime Settings options (the encoder plug-in for QuickTime must be installed). When bouncing to QuickTime, if the video in the session is not a valid video resolution or codec for QuickTime, you are prompted to use the QuickTime Settings to transcode the video to a valid QuickTime resolution and codec.

To transcode video to a valid QuickTime resolution:

1. Choose File > Bounce To > QuickTime.
2. In the QuickTime Bounce dialog, enable the Include Video option.
3. Click QuickTime Settings. (If the video you are bouncing is a valid QuickTime resolution and codec, QuickTime Settings is grayed out).
4. In the Movie Settings dialog, configure the settings as desired.

Movie Settings dialog

5. Click OK.
6. In the QuickTime Bounce dialog, configure the other settings as desired.
7. Click Bounce.

⚠️ When bouncing to QuickTime from Pro Tools, the Sounds settings in the Movie Settings dialog are ignored.
Part XII: Satellite Systems
Chapter 61: Satellite Link

Avid Satellite Link lets you link up to twelve Pro Tools HD systems over an Ethernet network so that you can cue, play, and stop the transports, make play selections, and solo tracks across any of the systems from any linked workstation.

Alternatively, you can link up to eleven Pro Tools HD systems and one of the following:

- A Pro Tools Video Satellite system, which uses a separate Pro Tools system for video playback.
- An Avid Video Satellite system, which uses an Avid Media Composer or Avid Symphony system for video playback, capture, and conversion.

From each linked Pro Tools HD system, Satellite Link lets you link and unlink networked systems and see the link status of other connected systems.

By setting Satellite Link preferences, you can configure linked Pro Tools HD systems for single- or multi-operator workflows.

Satellite Link can be used simultaneously with MachineControl, allowing one linked Pro Tools HD system to go online and drive a 9-pin capable device.

On systems with a D-Control or D-Command console, Satellite Link can work in conjunction with ICON Multi-mode. This lets you operate the transport selectively for up to four networked Pro Tools HD systems from a single D-Control console, or up to two Pro Tools HD systems from a D-Command.

---

Satellite Link Requirements and Compatibility

Satellite System Requirements

The following is required for each Pro Tools HD system on the network:

- Avid-qualified computer
- Pro Tools | Ultimate Software
- HDX or HD Native hardware
- Pro Tools | SYNC HD
- Ethernet connection to a Local Area Network (LAN)

_for more information, see Chapter 62, “Pro Tools Video Satellite” and Chapter 63, “Avid Video Satellite.”_

All Pro Tools systems in a Satellite Link network must be resolved to a common video reference, or “house sync,” using SYNC HD.
Configuring Satellite Link

To set up multiple Pro Tools HD systems in a Satellite Link network, configure basic network settings and the Satellite Link network on each Pro Tools system.

Configuring Network Settings

Satellite Link systems communicate over Ethernet Local Area Networks. You can configure the network settings on each Pro Tools HD system to build one or more Satellite Link networks on the same LAN.

Satellite Link requires all linked systems to be connected to an Ethernet Local Area Network. All systems should be on the same subnet. If possible, they should also be on the same Ethernet switch, to minimize response time over the network.

Ethernet Interface

On computers with multiple Ethernet interfaces, you can select the interface you want to use for Satellite Link communications.

To select the Ethernet interface for Satellite Link:
1. Choose Setup > Peripherals and click Satellites.
2. Under Advanced Network Settings, choose the Ethernet interface from the Interface pop-up menu.
3. Click OK.

TCP/UDP Port

Systems in a Satellite Link network need to use the same TCP/UDP port to communicate. Available satellite systems will only appear on other satellite systems using the same port.

By default, Satellite Link uses TCP/UDP port 28282. However, if the default port is already in use, or if you want to set up separate Satellite Link networks, you can select a different TCP/UDP port for Satellite Link communication.

To select the TCP/UDP port for Satellite Link communication:
1. Choose Setup > Peripherals and click Satellites.
2. Under Advanced Network Settings, enter the TCP/UDP port number you want the system to use.
3. Click OK.

⚠️ For Satellite Link to function properly, you must select a TCP/UDP port number between 1024 and 65534.

3. Click OK.
Configuring a Satellite Link Network

To set up Pro Tools HD systems for Satellite Link operation, one Pro Tools system on the network must be designated an administrator system.

Other systems on the network are configured as satellite systems, and are added to the network from the administrator system.

Configuring Satellite Systems

Do the following for each Pro Tools system you want to configure as a Satellite Link satellite:

1. Choose Setup > Peripherals and click Satellites.
2. In the System Name text box, enter a name for the system.
4. Click OK.

To configure a Media Composer system as a video satellite:

1. In Media Composer, choose Edit > Preferences.
2. In the Project window, click the Settings Tab and double-click Video Satellite.
4. Click OK.

To configure a non-HD Pro Tools System system as a video satellite:

1. On the satellite Pro Tools system, choose Setup > Peripherals and click Satellites.
2. In the System Name text box, enter a name for the system.
4. Click OK.

Configuring a satellite in the Satellites page of the Peripherals dialog

Configuring a Pro Tools Video Satellite system in the Satellites page of the Peripherals dialog
Configuring an Administrator System

To configure a Pro Tools system as a Satellite Link administrator:

1. Choose Setup > Peripherals and click Satellites.
2. In the System Name text box, enter a name for the system.
3. Under Mode, choose Administrator.
4. Under Administrator, choose the current system from the System 1 pop-up menu.
5. Click OK.

Adding Satellites to the Network

When systems have been configured as satellites, they become available on the administrator system. The satellite systems are then declared from the Administrator system to build the Satellite Link network.

To declare satellite systems:

1. On the administrator system, choose Setup > Peripherals and click Satellites.
2. Under Administrator, declare the systems you want to use as satellites from the System 2-12 pop-up menus.
3. Click OK.

The administrator and declared satellite systems appear in the Synchronization section of the Transport. The display resizes to show all available systems.

Linking Satellite Systems

When a Pro Tools system has been declared as a satellite, it can then be placed in a linked state from the local machine or from another satellite. When a system is linked, the following features and commands can be controlled across all linked systems:

- Linking and unlinking of the system
- Transport controls (Stop, Play, FF, Rew)
- Play selections
- Scrub/Shuttle location
- Channel solo (including Solo clear)
- Clearing system errors (such as AAE errors)
Satellite Link Controls

When a Pro Tools system has been declared as a satellite, Satellite Link controls can be shown in the Transport.

To display Satellite Link controls in the Transport window:

- Choose View > Transport > Synchronization and View > Transport > Expanded.

Link Button

The Link button controls the link status of the local system. When linked, the button is highlighted.

Satellite Link Buttons

Satellite Link buttons control the link status of the other satellite systems on the network. On every other system, one of these buttons corresponds to that system’s main Link button.

Link buttons highlight to indicate linked status of the remote system. A Satellite Link button highlights red if that system stops playback due to an error or the opening of a modal dialog.

Transmit and Receive Play Selections Buttons

The Transmit Play Selections and Receive Play Selections buttons in the Transport mirror the Transmit Play Selections and Receive Play Selections options in the Satellites section of the Synchronization preferences (Setup > Preferences > Synchronization). The button highlights when the option is enabled.

Transmit Play Selections When enabled, causes a linked Pro Tools system to send the Edit window selection to all other linked Pro Tools systems. On other linked systems that are set to receive play selections, the selection is mirrored in the Edit window.

Receive Play Selections When enabled, causes a linked Pro Tools system to receive Edit window selections from all other linked Pro Tools systems that are set to transmit play selections.

Linking Systems During Playback

You can link or unlink a system while it or any other linked system is playing back (“join in play”), and the transports will play in sync. In cases where both systems are playing back, the newly linked system will cue to the location of the system on which the link was initiated.
Linking Pro Tools Systems in a Satellite Network

To link (or unlink) the local Pro Tools system:
- Click the Link button in the Transport so that it is highlighted (or unhighlighted).

Press Option+Shift+L (Mac) or Alt+Shift+L (Windows) to link or unlink the local system.

To link (or unlink) remote satellite systems:
- Click the corresponding Satellite Link button for the remote system in the Transport so that it is highlighted (or unhighlighted).

To link (or unlink) all declared satellite systems:
- Option-click (Mac) or Alt-click (Windows) the Link button or a Satellite Link button in the Transport so that they are all highlighted (or unhighlighted).

Linking Play Selections

You can set linked Pro Tools systems to transmit and receive play selections from other satellite systems. This lets you configure your setup to selectively mirror Edit window selections between systems, or to have all systems mirror Edit window selections on all other systems.

- If you are working in a multi-user dub stage environment where dialog, FX, and music reside on different systems, it can be useful to set those systems to only transmit play selections, and set the recorder/video Pro Tools system to only receive play selections.

- If you are working in a single-user mix environment and are moving between systems, it can be useful to set all systems to transmit and receive play selections, so that you can work with the same selection on any system.

To set satellite Pro Tools systems to mirror play selections on other satellite systems, do the following:
- On the systems where you will be making play selections, do one of the following:
  - Click the Transmit Play Selections button in the Transport so that it is highlighted.
  - Choose Setup > Preferences and click Synchronization. Then, in the Satellites section of the Synchronization page, select the Transmit Play Selections option. Click OK to close the Preferences window.

- On the systems that you want to mirror the play selections, do one of the following:
  - Click the Receive Play Selections button in the Transport so that it is highlighted.
  - Choose Setup > Preferences and click Synchronization. Then, in the Satellites section of the Synchronization page, select the Receive Play Selections option. Click OK to close the Preferences window.

Solo Linking

You can set linked Pro Tools systems to transmit the solo status of their tracks and receive solo status information from other satellite systems.

- If you are working in a multi-user dub stage environment where dialog, FX, and music reside on different systems, it can be useful to set those systems to send and receive solos, and set the recorder/video Pro Tools system so that it does not transmit or receive solos.

- If you are working in a single-user mix environment and are moving between systems, it might be useful to set all systems to transmit and receive solos, so that solos propagate across all systems.
**Solo Safe** When Solo Linking is enabled, tracks on all systems retain their Solo Safe status.

**Solo Clear** When Solo Linking is enabled, all solos are cleared on systems set to receive solos.

**To set satellite systems to transmit or receive solo status:**

1. On the systems that you want to solo tracks, do the following:
   - Choose Setup > Preferences and click Synchronization.
   - In the Satellites section of the Synchronization page, select the Transmit Solos option.
2. On the systems where you want tracks to follow solo behavior for solos on other systems, do the following:
   - Choose Setup > Preferences and click Synchronization.
   - In the Satellites section of the Synchronization page, select the Receive Solos option.
   - Click OK to close the Preferences window.
3. Make sure the systems are linked.

**Using Solo Link without Linking Transport Controls**

If you are synchronizing multiple Pro Tools systems to an external synchronizer, you can still take advantage of the Solo Link feature.

You can set a satellite Pro Tools system to always send its solo status, whether linked or unlinked, so you can solo tracks across systems without linking transport controls.

**To set a satellite Pro Tools system to always solo even when it is not linked:**

1. Choose Setup > Preferences and click Synchronization.
2. In the Satellites section of the Synchronization page, select the Solo Independent of Linked State option.
3. Click OK to close the Preferences window.

**Solo Link Behavior in the Solo Modes**

**Solo in Place** With Solo Link, when using Solo In Place, the mode of solo operation is determined by the system transmitting the solo.

- If a linked system is in Solo Latch mode, soloing a track on that system adds to the number of tracks in solo, regardless of the solo mode of other systems set to receive solos.
- If a linked system is in Solo X-OR mode, soloing a track on that system cancels all other system’s solos regardless of the solo mode of other systems set to receive solos.

**AFL and PFL Modes** With Solo Link, AFL and PFL solos on a linked system have no effect on other systems.

An AFL-soloed track on a linked system can be muted by a Solo In Place on another system. To avoid this, use PFL instead of AFL.
**Satellite Link Errors**

### Clearing Errors on Linked Systems

By default, linked systems continue to operate if one of the systems experiences an error and its transport stops. The Satellite Link button for the remote system reporting the error highlights red on all other systems in the network. Any error message on a linked system appears in the tool tip for the corresponding Satellite Link button in the Transport.

You can set each system independently to stop playback when it encounters an error.

**To clear an error dialog on a remote linked system:**

- In the Transport on any other system in the network, Shift-click the Satellite Link button for the affected system.

**To set a linked system to stop the transport on all systems when an error occurs:**

- Make sure the AAE Errors Stop All Linked Systems option is selected in the Synchronization Preferences.

To set all systems to stop the transport when an error occurs, make sure this option is selected on all linked systems.

### Playback and Modal Dialogs

Linked systems stop playback (or prevent playback from starting) if a modal dialog (such as the I/O Setup, Hardware Setup, or Playback Engine dialog) is opened on any linked system.

**To avoid interrupting playback on another system when opening a modal dialog,**

*unlink the system before opening the dialog.*

---

**Resetting All Satellites on the Network**

If one or more satellite systems on the network encounters a problem and the network becomes unstable, Pro Tools lets you reset all Satellites on the network to get back up and running as quickly as possible.

**To reset all satellite systems on a network, do one of the following:**

- Command-Option-Control-Click (Mac) or Control-Alt-Start-Click (Windows) the Satellite Link button in the Transport of any Pro Tools Satellite system on the network.

- In the Satellite page of the Peripherals window (Setup > Peripherals > Satellite), click the Reset Network button, and then click OK.

---

**Using Satellite Link with MachineControl**

MachineControl Deck Control Mode can be used to operate a 9-pin synchronization device (such as a Soundmaster ATOM or a CB Electronics 9-Pin synchronizer), allowing Pro Tools to act as a “code only master” for systems controlled by the synchronizer.

Satellite Link lets you use MachineControl on one linked Pro Tools system at a time.

- When one linked Pro Tools system is already online and you go online with another linked Pro Tools system, Satellite Link will automatically take the first system offline.

- Any linked Pro Tools systems set to “Transport=Pro Tools” will follow Satellite Link transport commands.

- Any linked Pro Tools systems set to “Transport=Machine” cannot transmit Satellite Link transport commands, but will follow Satellite Link transport commands if they are offline.
Control Surface Support for Satellite Link

Linking Satellite Systems
(D-Control, D-Command, and C|24)

To link or unlink the local Pro Tools system:

- Hold Command (Mac) or Control (Windows)
  and press the Machine Online switch in the
  Transport section.

Satellite Link Soft Keys
(D-Control and D-Command)

To link or unlink other satellite systems:

1. Hold Control (Mac) or Alt (Windows) and press
   the Modes switch in the Automation Soft Keys
   section.

2. Press the Soft Key that corresponds to the name
   of the system that you want to link or unlink.

   The Soft Key lights solid to indicate that the corre-
   sponding system is linked, and flashes to indicate
   that the corresponding system is displaying an er-
   ror.

To link or unlink all declared satellite systems:

- Hold Option+Command (Mac) or Alt+Control
  (Windows) and press the Online switch in the
  Transport section.

To toggle the solo transmit status of the local
Pro Tools system:

1. Hold Control (Mac) or Alt (Windows) and press
   the Modes switch in the Automation Soft Keys
   section.

2. Press the Soft Key that corresponds to
   “Transmit Solo.”

   The Soft Key lights solid to indicate that transmit
   solo is enabled.

Satellite Link and EUCON Control

A selection of Satellite Link controls have been
EUCONized. For more information on controlling
Satellite Link functions from EUCON devices, see
the Pro Tools EUCON Guide.
Chapter 62: Pro Tools Video Satellite

Pro Tools Video Satellite is a powerful post-production option that uses a separate computer running Pro Tools Software for synchronized video playback.

By off-loading video playback duties to a separate computer, Pro Tools Video Satellite contributes to the best possible performance on the administrator Pro Tools system.

Pro Tools Video Satellite uses a single non-HD Pro Tools system for video playback in a Satellite configuration. Pro Tools Video Satellite requires Pro Tools software (but not Pro Tools Ultimate software) and can use any Avid-supported non-HD audio interface (such as Mbox Pro). A Pro Tools Video Satellite cannot use a video reference, so it will not be as accurate as an Avid Video Satellite.

**Pro Tools Video Satellite System Requirements**

- Avid-qualified computer
- Pro Tools Software
- Supported video peripheral (optional)
- Client monitor (optional)
- Black burst or tri-level video reference generator, if using a video peripheral
- Ethernet connection to a Local Area Network (LAN)

**Video Output Options**

Pro Tools Video Satellite lets you output video through an Avid or Third Party video peripheral.

- Playback to an external monitor with the Avid Nitris DX. Output formats include HD/SD-SDI, HDMI, and HD/SD Analog.
- Playback to an external monitor with the Avid Mojo DX. Output formats include HD/SD-SDI and HDMI.
- Full-screen playback on your primary or secondary computer monitor using DVI output
- Playback to an external monitor with supported 3rd party video hardware

**Connecting a Pro Tools Video Satellite System**

To connect the Pro Tools Video Satellite system to the administrator Pro Tools system, that system must be designated an *administrator* system.

The Pro Tools Video Satellite system is set up as a *satellite* system, and then is declared from the administrator system.

*For complete instructions on configuring a Satellite Link network including a Pro Tools Video Satellite system, see “Configuring Satellite Link” on page 1388.*
Configuring the Main Pro Tools System as an Administrator

To configure the main Pro Tools system as an administrator:

- See “Configuring an Administrator System” on page 1390.

Configuring the Pro Tools Video Satellite System

To set up the Pro Tools Video Satellite system:

- See “Configuring Satellite Systems” on page 1389.

Declaring the Pro Tools Video Satellite System

When the Pro Tools Video Satellite system has been configured as a satellite, it becomes available on the administrator system. The satellite system is then declared by the Administrator.

To declare the satellite system on the administrator system:

- See “Adding Satellites to the Network” on page 1390.

The systems appear, in order, from left to right, in the Synchronization section of the Transport window.

⚠️ Only one Pro Tools Video Satellite system can be connected to a Satellite Link network.

Linking the Pro Tools Video Satellite System

After a Pro Tools system has been connected as a video satellite, it can then be placed in a linked state. When this system is linked, it follows the transport commands from the administrator system, and runs in sync with it. When the satellite system is unlinked, its transport acts like a normal Pro Tools system.

💡 The administrator Pro Tools system does not respond to playback commands from the Pro Tools Video Satellite system. Transport commands must originate from the main Pro Tools system.

Link Controls

When a Pro Tools system has been declared as a satellite, the following controls appear in the Transport window:

- **Link Button** Controls the link status of the local system.

- **Satellite Link Buttons** control the link status of the other satellite systems. On every system, one of these buttons corresponds to that system’s main Link button.

Link buttons highlight to indicate linked status.
To display link controls in the Transport:

- Choose View > Transport > Synchronization and View > Transport > Expanded.

To link or unlink the local Pro Tools Video Satellite system:

- Click the Link button in the Transport.

Press Option+Shift+L (Mac) or Alt+Shift+L (Windows) to link or unlink the local system.

To link or unlink the administrator Pro Tools system or other satellite systems:

- Click the corresponding Satellite Link button in the Transport window.

To link or unlink all declared satellite systems:

- Option-click (Mac) or Alt-click (Windows) the Link button or one of the Satellite Link buttons in the Transport window.

Linking Systems During Playback

You can link the Pro Tools Video Satellite system while the administrator Pro Tools HD system is playing back, and the transports will synchronize.

Pro Tools Video Satellite Operation

AAE Errors

By default, the two linked systems will continue to operate if one of the systems experiences an error and its transport stops.

The administrator system can be configured to stop playback if an AAE error occurs on the Pro Tools Video Satellite system, or any other Satellite Link satellite.

To clear an error dialog on the Pro Tools Video Satellite system from the main Pro Tools system:

- In the Transport window on the other linked system, Shift-click the Satellite Link button for the affected system.

If the administrator system is configured to Transmit Play Selections, those selections will be transmitted to the Video Satellite system. However, selections made on the Video Satellite system will not be transmitted to the administrator system.

To set the Pro Tools Video Satellite system to stop the transport on both systems when an error occurs:

- On the administrator Pro Tools system, make sure the AAE Errors Stop All Linked Systems option is selected in the Synchronization Preferences page.

If one of the systems encounters an AAE error, its satellite link button will light up red in the transport window on the other system. Hold the mouse pointer over the button to view the error, if necessary.
Modal Dialogs

Linked systems will stop playback if a modal dialog box (such as the I/O Setup, Hardware Setup, or Playback Engine dialog) is opened on any linked system. The corresponding Satellite Link button for that system highlights red on all other systems.

⚠️ A system cannot play back when a modal dialog box is open.

Spotting Video to the Pro Tools Timeline

Once a session is created (or an existing session opened) on the satellite Pro Tools system, and the video has been imported, the video must be set to the correct start time so that it runs in sync with the audio on the main Pro Tools system. Video can be spotted to the desired start time by matching timecode or feet+frames values.

Compensating for Different Start Times in Pro Tools and a Pro Tools Video Satellite

In some cases, you may want the Pro Tools Video Satellite system to be offset from the administrator system to accommodate for external deck offsets or differences in session start time.

You can control the amount of offset by changing the Timecode Offset parameters on the Pro Tools Video Satellite system.

To compensate for different start times:

1. In Pro Tools, go to Setup > Session. The Session Setup window appears.

2. In the Timecode Offsets section, compensate for the offset between Pro Tools and a Pro Tools Video Satellite as follows:
   - If the start time of the video clip in video satellite falls before the start time of the administrator Pro Tools session, type a positive timecode value into the Satellite Offset field.
   - If the start time of the video clip in video satellite falls after the start time of the administrator Pro Tools session, type a negative timecode value into the Satellite Offset field.

Compensating for Monitor-Induced Output Delay

Many monitors add a delay to the video output of one or more frames. You can compensate for this delay by advancing the video output by the necessary number of frames.

To set the number of frames to offset video output:

1. On the video satellite system, choose Setup > Video Sync Offset.

2. In the Video Sync Offset field, type a positive value that matches the amount of delay in the monitors. You may need to try a few different settings.
Chapter 63: Avid Video Satellite

Avid Video Satellite is a powerful post-production option for Pro Tools, employing a separate computer running Avid Media Composer or Symphony software for synchronized video playback, capture, and conversion.

Avid Video Satellite can use either a single Media Composer or Symphony system in a Satellite configuration. Avid Video Satellite can play full sequences and does not require a video mix-down. Avid Video Satellite requires a Pro Tools HD Administrator in the Satellite configuration.

Media Composer or Symphony software with the Video Satellite option can output and capture video using the following Avid video peripherals:
- Media Composer | Nitris DX
- Media Composer | Mojo DX

**Avid Video Satellite Requirements**

Avid Video Satellite requires the following system components:
- Avid-qualified computer
- Pro Tools | Ultimate Software
- HDX or HD Native hardware
- Pro Tools | SYNC HD
- A second Avid-qualified computer for Media Composer or Symphony
- Media Composer or Symphony System Identification Number and serial number, or Avid Application Key (included with Media Composer or Symphony)
- Avid video peripheral (optional; required for high-quality video output)

**Avid Video Peripherals**

For high-quality frame edge-aligned playback of HD or SD video (or 1080 HD video converted to SD video), you must add the I/O capabilities of an Avid video peripheral.

Media Composer supports the following Avid video peripherals:
- Media Composer | Nitris DX
- Media Composer | Mojo DX

When using an Avid video peripheral, the following is required:
- An NTSC/PAL black burst generator
- A tri-level sync generator (when working with HD-capable Avid video peripherals)
**Video Output Options**

Avid Video Satellite lets you output video using any of the following configurations:

- Playback to an external monitor with the Media Composer Nitris DX. Output formats include HD/SD-SDI, HDMI, and HD/SD Analog.
- Playback to an external monitor with the Avid Mojo DX. Output formats include HD/SD-SDI and HDMI.
- Full-screen playback on your primary or secondary computer monitor using DVI output
- Playback to an external monitor with supported 3rd party video hardware

### Playback to an External NTSC or PAL Video Monitor

Media Composer and Symphony require an Avid video peripheral for high-quality, frame edge-aligned playback of SD video (or 1080 HD video converted to SD video) to an external NTSC or PAL monitor.

When outputting 1080 HD video using this configuration, you can either transcode an HD sequence to SD video or down-convert an entire HD project to SD video in real time.

⚠️ 720p projects cannot be down-converted.

When using an Media Composer Nitris DX or Mojo DX peripheral, 1080 HD video can be down-converted to SD video in real time, in software mode.

Hardware-based down-convert is not supported with Video Satellite.

### Playback to an External HD-SDI Video Monitor

(Media Composer Nitris DX or Mojo DX Only)

Media Composer requires an HD-capable Avid video peripheral (Nitris DX or Mojo DX) for high-quality, frame edge-aligned playback of native HD video to an external HD-SDI monitor.

### Full-Screen Playback using DVI Output to a Computer Monitor

With a supported video card installed, Media Composer Video Satellite provides full-screen playback of SD or HD video through a DVI port to your primary or secondary computer monitor.

⚠️ For detailed information on the quality of DVI output to your primary or secondary monitor, see “Avid Video Satellite Workflows” on page 1403.

### Video Frame Rate and Monitor Refresh Rate

When you play back video on a monitor with a refresh rate that differs from the video frame rate (as is often the case during playback of video through a DVI output), the output yields visual artifacts and offsets in synchronization between audio and video. For example, this occurs during playback of a 24 fps video clip on a DVI monitor with a refresh rate of 75 Hz.

If your workflow requires high-quality playback, you must output video through an Avid video peripheral to a video monitor.

The artifact and audio/video sync issues occur as follows:

**Frame “Tearing” & Video “Stutter”** Frame “tearing” is the horizontal distortion on rapidly moving or heavily edited sequences. Video “stutter” is the subtle shifting of video during playback.
You can remedy one of these issues at a time (but not simultaneously) using the Flip On Vertical Sync option, located in the Full Screen Playback Settings dialog.

**Audio/Video Synchronization Offset** Audio/video synchronization varies slightly with each frame. Though usually not noticeable to the eye, more precise measuring devices cause offsets in AV sync of up to 1/2 frame or more. This is normal whenever using the output of a computer's monitor card, and does not affect capture, editing, or layback.

**Supported Video Resolutions**

Media Composer and Symphony Video Satellite supports the import, capture, and playback of a wide range of video resolutions and frame rates (including HD video):

For detailed information on supported resolutions and frame rates, see Avid Media Composer online help or visit the Avid website (www.avid.com).

To launch online help in Media Composer:
- Choose Help > Online Help.

**Avid Video Satellite Workflows**

The following sections describe workflows for using Pro Tools with Media Composer or Symphony configured as an Avid Video Satellite:
- Connecting Pro Tools to a satellite
- Linking Pro Tools to a satellite
- Capturing audio and video
- Batch capturing audio and video
- Laying back audio and video

---

**Using a Video Satellite in a MediaCentral | Production Management Environment**

Using a Video Satellite system in a MediaCentral | Production Management environment is useful for networked file management. For additional information on Pro Tools support with MediaCentral | Production Management, see the Pro Tools Production Management Guide.

**Connecting Pro Tools and a Video Satellite**

In order for Pro Tools and the video satellite to synchronize their transports, they must be linked. Before linking can occur, however, you must establish basic communication channels between them. When the Pro Tools and the video satellite systems have established this communication, they are connected.

To connect the Pro Tools and video satellite systems, they must first be connected using Ethernet.

In addition, the Video Satellite option must be enabled on the Media Composer system, and the systems must be connected.

⚠️ Running other applications simultaneously with Media Composer can cause unpredictable behavior, including AV sync problems, frame dropping and audio stuttering. It is suggested that you not launch other applications when Media Composer is running. This can occur with or without the use of Satellite mode.
Conditions for Connecting Pro Tools and a Video Satellite

The following conditions apply to connections between Pro Tools and video satellites:

- Quitting a Pro Tools application that is acting as administrator to a video satellite releases the video satellite so that it can be linked to other Pro Tools systems.
- If you quit Pro Tools while a satellite is connected, Pro Tools attempts to re-connect to the same satellite on relaunch.
- When linked to a Video Satellite, Pro Tools does not chase MIDI Timecode (MTC).

Troubleshooting the Satellite Connection

If the satellite does not appear in the Administrator pop-up menu, verify the following:

1. Ensure that Media Composer or Symphony is fully launched.
2. In Media Composer, go to the Project window and choose Settings > Video Satellite. Ensure that Video Satellite Mode is enabled.
3. In the Satellite page of the Pro Tools Peripherals dialog, select a different Ethernet port from the Interface menu. Many computers have more than one Ethernet port or “interface”. The interface selected here must be the one connected to the same network as the satellite.
4. In the Project window in Media Composer or Symphony, click the Settings tab, then double-click Video Satellite Settings and check that the TCP/UDP Port is the same as the TCP/UDP Port shown in the Satellite pane in the Pro Tools Peripherals dialog. (Both ports default to 28282.)

⚠️ For Video Satellite to operate properly, the TCP/UDP port you set must be between 1024 and 65534.

5. If the TCP/UDP port settings are the same, verify with your network administrator that the port shown is not being blocked on the network.
6. Check that all Ethernet cables are completely plugged in and working. In most cases, there are LEDs that show activity at the Ethernet ports.
7. Video satellite playback will not function in the following conditions:
   - Certain dialogs are open in either Pro Tools or Media Composer.
   - Media Composer is not the active application.
   - Pro Tools does not have an open session, or Media Composer does not have an open sequence.
Matching Media Composer and Pro Tools Settings in a Video Satellite System

In order to accurately synchronize playback between Pro Tools and Media Composer, the following parameters must be correctly matched:

- Media Composer Project Type and Pro Tools Timecode Rate, Clock Reference, and Video Format
- Pro Tools Audio Pull-Up setting and Media Composer Edit Play Rate
- Timecode Format (Drop Frame or Non-Drop Frame)

For Pro Tools to play in sync with Media Composer or Symphony as a video satellite, all of these settings are interdependent. A mismatch in any of these settings will cause Pro Tools to display an error message.

Media Composer Starting TC timecode setting and the Pro Tools session start do not have to match exactly, but should usually be close.

When working with 24p and 23.976 projects, Media Composer defaults to displaying frames mapped to 29.97 fps timecode. In order to keep the Pro Tools and Media Composer or Symphony timecode displays in sync when working in 24p or 23.976 projects, click the timecode display above the Record monitor and choose Sequence > Timecode > 24 > Mas.

To avoid sync problems during later stages of post production, it is strongly recommended in most cases to change the settings in Pro Tools to match those of the sequence open in Media Composer.

Matching Media Composer Project Type to Pro Tools Timecode Rate, Clock Reference, and Video Ref Format

This section explains how to match the Media Composer Project Type to the Pro Tools Timecode Rate, Clock Reference, and Video Format.

To ensure that your video satellite system will play back or capture using the proper settings:

1. In Media Composer, click the Format tab in the Project window.
2. Select the desired setting from the Project Type pop-up menu.
4. Select a timecode setting from the Timecode Rate pop-up menu that is compatible to the Media Composer Project Type setting.
5. Make sure that a compatible clock source is available and connected correctly.
6. Select the connected clock reference from the Clock Reference pop-up menu.
7. Select a compatible video format from the Video Ref Format pop-up menu.

Video Ref Format cannot be changed for most HD frame rates.
Matching Audio Pull-Up and Edit Play Rate

By default, Media Composer plays back sequences at the frame rate specified in the name of the project type. For example, a 25i PAL project plays at 25 fps. The notable exception is 30i NTSC, which actually plays at 29.97 fps.

When working with 23.976, 24p NTSC, 24p PAL, and 25p PAL projects, you can change the playback rate (known as the Edit Play Rate) without affecting other properties in order to slow down or speed up playback slightly. This is the video equivalent of the audio pull-up/down setting in Pro Tools.

To change the Edit Play Rate:

1 In the Settings tab of the Project window, open the Film and 24P setting.
2 Select an Edit Play Rate matching your configuration according to the following table.

💡 24p projects (PAL and NTSC) use a default Edit Play Rate that does not match the project rate. 24p PAL defaults to 25 fps and 24p NTSC defaults to 23.976 fps.

To change audio pull up/down settings in Pro Tools:

1 In Pro Tools, choose Setup > Session.
2 From the Timecode Settings section of the Session Setup window, select a rate from the Audio Rate Pull Up/Down pop-up menu.
3 Click OK to apply the new pull up/down rate to the session.
Compatibility Table

The following table describes compatibility between Avid Project Format and Edit Play Rate, and Pro Tools Timecode Rates, Audio Pull Up/Down Rate, Clock Reference, and Video Format.

*Rate and Sync Ref Compatibility between Avid and Pro Tools*

<table>
<thead>
<tr>
<th>Avid Project Format</th>
<th>Media Composer or Symphony</th>
<th>Pro Tools</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Edit Play Rate</td>
<td>Mojo DX or Nitris DX Video Ref</td>
</tr>
<tr>
<td>23.976p NTSC</td>
<td>23.976</td>
<td>NTSC</td>
</tr>
<tr>
<td></td>
<td></td>
<td>24 NTSC</td>
</tr>
<tr>
<td>24p NTSC</td>
<td>24</td>
<td>NTSC</td>
</tr>
<tr>
<td></td>
<td>23.976</td>
<td>NTSC</td>
</tr>
<tr>
<td>30i NTSC</td>
<td>29.97</td>
<td>NTSC</td>
</tr>
<tr>
<td>24p PAL</td>
<td>24</td>
<td>PAL</td>
</tr>
<tr>
<td></td>
<td>25</td>
<td>PAL</td>
</tr>
<tr>
<td>25p PAL</td>
<td>25</td>
<td>PAL</td>
</tr>
<tr>
<td></td>
<td>24</td>
<td>PAL</td>
</tr>
<tr>
<td>25i PAL</td>
<td>25</td>
<td>PAL</td>
</tr>
<tr>
<td>720p/23.976</td>
<td>23.976</td>
<td>720p/59.94*</td>
</tr>
<tr>
<td>720p/25</td>
<td>25</td>
<td>720p/50</td>
</tr>
<tr>
<td>720p/29.97</td>
<td>29.97</td>
<td>720p/59.94</td>
</tr>
<tr>
<td>720p/50</td>
<td>50</td>
<td>720p/50*</td>
</tr>
<tr>
<td>720p/59.94</td>
<td>59.94</td>
<td>720p/59.94*</td>
</tr>
</tbody>
</table>
### Rate and Sync Ref Compatibility between Avid and Pro Tools

<table>
<thead>
<tr>
<th>Media Composer or Symphony (continued)</th>
<th>Pro Tools (continued)</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Avid Project Format</strong></td>
<td><strong>Edit Play Rate</strong></td>
</tr>
<tr>
<td>1080p/23.976</td>
<td>23.976</td>
</tr>
<tr>
<td>1080p/24</td>
<td>24</td>
</tr>
<tr>
<td>1080p/25</td>
<td>25</td>
</tr>
<tr>
<td>1080p/29.97</td>
<td>29.97</td>
</tr>
<tr>
<td>1080i/50</td>
<td>50</td>
</tr>
<tr>
<td>1080i/59.94</td>
<td>59.94</td>
</tr>
</tbody>
</table>

*Although Media Composer standalone supports locking the video peripheral to black burst or tri-level sync at these HD rates, Video Satellite will only support locking the Media Composer video peripheral to tri-level sync when using these HD rates.*
Matching Timecode Format (Drop Frame or Non-Drop Frame)

Pro Tools and Media Composer must be set to the same timecode format (either Drop Frame or Non-Drop Frame).

To ensure timecode format settings are compatible:

1. In Pro Tools, choose Setup > Session. If the Timecode rate pop-up menu displays “DF” after the frame rate, Pro Tools is set to Drop Frame.

2. In Media Composer, right-click the Record monitor, and choose Sequence Report.

   ![Clip Info dialog (Media Composer, top) and a portion of the Session Setup window (Pro Tools, bottom)](image)

   - In some project formats, Media Composer can be configured for Drop Frame or Non-Drop Frame, while the corresponding Pro Tools timecode rate can only be set to Non-Drop Frame. In such cases, Media Composer sends Non-Drop timecode information to Pro Tools, even if it is set to Drop Frame. The following project formats in Media Composer exhibit this behavior: 23.976p NTSC, 24p NTSC, and 720p/23.976.

3. If both timecode formats do not match, do one of the following:
   - To force Pro Tools to match the timecode format of Media Composer, select the compatible timecode format from the Timecode Rate pop-up menu.
   - To force Media Composer to match the timecode rate of Pro Tools, type semi-colons (Drop Frame) or colons (Non-Drop Frame) between the numbers in the Starting TC field, and press Enter.
Matching Media Composer Starting TC Timecode Setting and Pro Tools Session Start

In almost all cases, the first frame of video is located at the start of the Media Composer sequence. However, Pro Tools sessions often have silence at the head to create countoffs or silence.

For example, a Media Composer sequence may start at 01:00:00:00 while the matching Pro Tools session starts at 00:59:55:00—allowing five seconds of silence before the audio starts.

⚠️ In some cases, starting playback from Media Composer at a point which is more than a minute earlier than the start of the Pro Tools session may fail. Change the Pro Tools session start time to be earlier.

To set the default start time for new sequences in Media Composer:

1. In the Project window, click the Settings tab and then double-click the General setting.
2. Type in the desired starting timecode in the Default Starting TC field.

To change the start time of an existing sequence in Media Composer:

1. In Media Composer, open the bin containing the existing sequence.
2. If needed, re-size the bin window so that you can see the Start column of the bin window.
3. In the Start column for the sequence for which you want to set a new start time, type the new start time using semi-colons (for Drop Frame) or colons (for Non-Drop Frame), and press Enter.
4. Click OK to confirm.

Compensating for Different Sequence Start Times in Pro Tools and a Video Satellite

You can compensate for any offsets that might occur if the start times of an Avid sequence differ between Media Composer and Pro Tools.

To compensate for different sequence start times:

1. In Pro Tools, go to Setup > Session. The Session Setup window will appear.
2. In the External Timecode Offset section, compensate for the offset between Pro Tools and Video Satellite as follows:
   - If the start time of the video satellite sequence falls before the start time of the Pro Tools sequence, type a positive timecode value into the Satellite Offset field.
   - If the start time of the video satellite sequence falls after the start time of the Pro Tools sequence, type a negative timecode value into the Satellite Offset field.

Compensating for Monitor-Induced Output Delay

Many monitors add a delay to the video output of one or more frames. You can compensate for this delay by advancing the video output by the necessary number of frames.

To set the number of frames to offset video output:

1. In Media Composer, choose Settings > Video Satellite Settings.
2. In the Video Satellite Offset field, type a positive value that matches the amount of delay in the monitors. You may need to try a few different settings.
Linking or Unlinking Pro Tools and a Video Satellite

After you have connected and configured a single Pro Tools HD system and an Avid Video Satellite system in a Satellite Link network, you can control their behavior with controls in the Pro Tools and Media Composer transports. However, if more than one Pro Tools HD system is connected and configured in a Satellite Link network that includes an Avid Video Satellite system, playback can be started only from a Pro Tools HD system on the network.

When linked, Pro Tools and Media Composer support the following transport operations:

- With audio playback:
  - Play
  - Half-speed Play
  - Loop Play
  - Shuttle
  - Scrub
  - Record
  - Loop Record
  - FF/REW (with the Audio During FF/RW preference turned on in Pro Tools)

- Without audio playback:
  - Locate
  - Nudge
  - Selecting

When using the J, K and L keys to shuttle in Media Composer, Pro Tools will play audio at 1x forward, but not in reverse or any other possible playback speeds.

⚠️ Trim, Color Correction and Effects modes in Media Composer and Symphony are not supported with Avid Video Satellite.

💡 In Media Composer, enable the Play Preparation Delay option (Settings > Video Satellite) to avoid possible errors on playback start in sequences with high bandwidth video or un-rendered effects. Enable the Loop Preparation Delay option to similarly avoid problems when looping playback.

Link Controls

When a Pro Tools HD system is configured as an administrator, the following controls can be shown in the Transport window:

**Link Button** Controls the link status of the local system.

**Satellite Link Buttons** control the link status of the other satellite systems. On every system, one of these buttons corresponds to that system’s main link button.

Link buttons highlight to indicate linked status.
To display linking controls in the Transport window:

- Choose View > Transport > Synchronization and View > Transport > Expanded.

To link or unlink the local Pro Tools system:

- Click the Link button in the Transport window.

To link or unlink other satellite systems:

- Click the corresponding Satellite Link button in the Transport window.

To link or unlink the video satellite system from within Media Composer, do one of the following:

- Click the Satellite Link button to change it to a linked (green) or unlinked (grey) state.

Controlling Linking with a Control Surface

To toggle the link button on the Pro Tools system (ICON and C|24):

- Press Control + the Online button (Mac) or Alt + Online (Windows) on the control surface.

To toggle the Satellite Link buttons (D-Control or D-Command only):

1. Press Command + the Modes button (Mac) or Control + Modes (Windows) on the control surface to display all linked systems in the softkeys display.
2. The Modes button will light up. Pressing Modes again will exit the Satellite Link mode.
3. The softkeys corresponding with each machine can then be pressed to link or unlink that machine.

Video Satellite and EUCON Control and Work Surfaces

A selection of system linking controls have been EUCONized. For more information on controlling Video Satellite functions from EUCON devices, see the Pro Tools EUCON Guide.

Link buttons flash briefly when establishing the network clock.

If Media Composer shows an error dialog, the Satellite Link button for the Video Satellite in Pro Tools will turn red. Hold the cursor over the link button to view the dialog. To dismiss the dialog, shift-click the video satellite system’s Satellite Link button.
Capturing Audio and Video with a Video Satellite System

You can use a video satellite system to capture audio to Pro Tools and video media to Media Composer in a single pass.

Before Capturing Audio and Video

Before capturing audio and video from tape, ensure that you have made the following connections.

For connections with an Avid video peripheral, do the following:

1. Connect the desired outputs of the video deck to the corresponding inputs on the video peripheral.
2. Connect the audio source to the inputs of your primary Pro Tools HD audio interface.

For connections without an Avid video peripheral, do the following:

- For FireWire-based connections, connect the FireWire cable directly to the FireWire port on the Media Composer system.

Since video and audio are streamed in one signal over FireWire, it is not necessary to connect any audio inputs.

If you are capturing video using FireWire, you must capture both audio and video into Media Composer, because a single FireWire cable provides both video and audio. This audio can then be exported over to Pro Tools.

Conditions for Capturing Audio and Video

The following conditions apply to capturing audio and video with a video satellite system:

- Due to technical limitations, when capturing video from a device being controlled using a 1394 connection, audio sync will be up to 3/4 of a frame out of sync.
- If you want to capture a 29.97 telecine video tape to a 24 fps project, you must first capture both audio and video on Media Composer and then export the audio back to Pro Tools. For manually exporting an AAF Sequence, see the Avid Media Composer Guide.

Configuring Pro Tools and a Media Composer Video Satellite for Capturing

Before configuring Pro Tools and Media Composer for synchronized capturing, ensure that the two applications have matching settings. For detailed information, see “Matching Media Composer and Pro Tools Settings in a Video Satellite System” on page 1405.

Configuring Pro Tools for Capturing within a Video Satellite System

To configure Pro Tools for capturing audio:

1. In Pro Tools, choose Setup > Session, and ensure the following:
   - Clock Source pop-up menu is set to SYNC.
   - Clock Reference pop-up menu is set to Video Reference.
   - If Clock Reference pop-up menu is set to another source, like Word Clock, make sure that the Ref Present LED is lit, and that the clock reference that the SYNC is locked to matches that of the VTR.
2 Route the audio inputs to the desired tracks.

3 Record enable the audio tracks to which you want to capture audio.

4 Click the Record Enable button in the Transport.

Configuring Media Composer for Video Capture

Avid Video Satellite supports video capture to a new or existing sequence using the Capture Tools in Media Composer or Symphony. See Media Composer or Symphony documentation for configuration details.

Playing Back Captured Audio and Video with a Video Satellite System

Once you have finished capturing with a video satellite system, the captured clip appears in the Record Monitor and in the Timeline. Audio appears in the Pro Tools Timeline.

To view the captured clip, do the following:
- Click Play (or press the Spacebar) in Pro Tools or Media Composer.

Re-Digitizing an Existing Sequence

Media Composer can open sequences created on other Avid editing systems. However, you may first want to re-digitize some or all of the media files because they were the wrong resolution, or missing.

When using this procedure with a video satellite, you must capture the audio to Media Composer and then export an AAF sequence referencing or containing the embedded audio to Pro Tools.

Digitizing from an EDL

Media Composer includes Avid EDL Manager software, which lets you open an EDL from another editing application, create a Media Composer sequence from that EDL, then re-digitize the sequence.

When using this procedure with a video satellite, you must capture the audio to Media Composer and then export an AAF sequence referencing or containing the embedded audio to Pro Tools.

Laying Back Audio and Video to Tape

You can layback audio from Pro Tools and video from Media Composer to tape using the Digital Cut Tool in Media Composer. See Media Composer documentation for configuration details. Note that the 9-pin connection must be on the Media Composer composer system.

The Universal Mastering feature in Symphony is not supported with Video Satellite.

To minimize the chance of dropped frames, it is recommended that all effects be rendered before performing a layback.

When laying back to an SDI VTR or 1394 device that requires audio and video to be combined in a single stream, you must export the audio to Media Composer from Pro Tools or combine audio and video signals using a third-party summing device, and then lay back the final sequence to tape.
To record audio and video to tape from Media Composer and Pro Tools simultaneously:

1 Make sure that your system is set up as follows:
   • Pro Tools and the Media Composer video satellite computers are linked.
   • Audio outputs on the Pro Tools HD audio interface are connected to the appropriate audio inputs on the VTR.
   • Video outputs from Media Composer system are connected to the VTR.
   • If you are using deck control, the deck control cable from Media Composer is connected to the VTR, and the VTR is set to Remote mode.

2 Insert a video tape into your VTR.

3 To ensure that the tape deck is properly configured, refer to the following topic in Media Composer Help (Help > Avid Media Composer Help): Configuring a Deck or Multiple Decks.

4 Do one of the following:
   • Select one of the displayed tape names and click OK.
   • Click New to add a new tape to the list.

5 Drag the sequence you want to record to tape from the bin to the Record Monitor.

6 Select Output > Digital Cut. The Digital Cut Tool appears.

7 If you want to set In and Out points for a digital cut.

8 Do one of the following:
   • Select the Entire Sequence option to record the entire sequence.
   • Deselect the Entire Sequence option and set the In and Out points in the Timeline.

9 If you are laying back over a FireWire (1394) connection (Special > Device > IEEE 1394), select the appropriate output mode from the Output Mode pop-up menu as follows:
   • If all of the media on your Timeline is DV25, or if it is all DV50, and all of your effects are rendered, you can achieve a slightly higher quality of output by selecting DV25 or DV50 as appropriate.
   • Otherwise, you must select the RT DV25 or RT DV50 options to render and transcode all of your video to that format.
10 Select the Stop on Dropped Frames option if you want Media Composer to automatically stop the tape if the audio and video does not record correctly.

11 Select the Add Black At Tail option, and type the amount of black you want added to the end of the sequence.

12 Select one of the following from the Deck Control options:

Local mode You will initiate recording manually.

Remote mode Media Composer will start the VTR and drop into record at the specified time-code.

13 If you chose Remote mode, select one of the following options:

Sequence Time Starts recording based on sequence time. For example, if the sequence starts at 01:00:00:00 in the Timeline, Media Composer will start recording when the tape reaches 01:00:00:00.

Record Deck Time Starts recording wherever the VTR is currently parked.

Mark In Time Starts recording at the address entered in the top window to the right of the transport controls.

14 In the Source Track buttons, select the top video track. Only the selected video tracks and the video tracks below it will be recorded.

15 If you selected Remote mode, use the Record Track buttons on the right to select which audio and video tracks to enable for recording on the tape.

16 Click the yellow Preview button to check that all of the tracks you selected are playing and that the insert points on the tape are correct.

17 Do one of the following:

- To record using Local mode, press play and record on the VTR. When ready, click the Record button in the Digital Cut window.
- To record using Remote mode, press Record in the Digital Cut window. Media Composer will queue the tape, play, then drop in at the appropriate location.

When doing a Digital Cut with an Avid Mojo DX or Nitris DX video peripheral, Output Mode should be set to “Real Time” when using non-FireWire video outputs, for best A/V sync performance.

Be sure to record at least a few seconds of black to the tape before performing a digital cut. This will guarantee that the video tape is correctly formatted when your digital cut starts.

[Diagram of Source Track buttons, Record Track buttons, Record Enable, and Preview]
Index

Symbols
431, 879, 1259
.ptxp file type 268
"Organize Track I/O Menus By" options 106

Numerics
1st Order Ambisonics 1259
29.97 FPS Non-Drop 1293
3D audio 1259
3-knob panning 1231
5.1 surround formats 1208
7.0.2 and 7.1.2 surround formats 1202, 1239
7.0.2 panner 1249
7.1 and 7.0 surround formats 1202
7.1.2 panner 1249
9-Pin MachineControl settings 136, 137

A
AAF
exporting 438, 444
import translation settings 434
importing 426
linked media 23
metadata 20, 1333
opening in Pro Tools 427
AAX Ambisonics panning plug-ins 1262
Abandon Changes command 385
Absolute Grid mode 601, 902
ACID files 399
importing 406
active 17
inserts 1096
tracks 259
Active Busses display 80
Add Contacts 361
Add Key Change command 874
Add Marker/Memory Location button 881
Add Meter Change button 866
Add Tempo Change button 845, 863
Add Unique Triggers 740
adding tags 335
Adjust Session Start Time to Match Source Start Time 421
ADM file 1256
Advanced Meter Type settings 122
advanced metering 227
AES31/Broadcast compliant BWF (.wav) 458
AFL (After Fader Listen) 257
AFL/PFL Path 60
After Fader Listen (AFL) mode 257
After Playback Scrolling option 480
After Write Pass, Switch To option 119, 1129
AIFC file format 436
AIFF file format 1191
All MIDI Notes Off command 780
Allow Latch Prime in Stop option 118
Allow Sends to persist during LLM option 116, 515
Allow Track Arm Commands in Local Mode option 130, 1325
alternate matching takes 530, 706
Alternate Takes pop-up menu 531, 707
Always Display Marker Colors option 107
Always Fill Channel Strips When Banking option 117
Ambisonics 1259
configuring I/O Setup 1260
creating mixes 1262
discrete channel orderings 1261
FB360 Audio plug-ins 1263
Higher-order 1259
Ambisonics formats 1203
Analysis view 972, 986
Apply Real-Time Properties option 415
archiving sessions (with Compact command) 665
arming
safe (ignore) 1324
Artificial Chat
History 363
Notifications 362
opening a project 366
Projects tab 363
Artist Chat window 359
Artist Profile 360
ASIO 8
aspect ratios (Video window) 1375
Assemble mode 1318
Assign Tags popover window 336
Assignments View (Sends View option) 1064
Attributes (Groups List) command 280
attributes (groups) 284
Audio During Fast Forward/Rewind option 108, 477
audio file formats 156, 1191
audio files 11
  compacting 666
default names 504
  importing 398
mixed file types 168
Audio Files Conform to Session Tempo 316
Audio Files Conform to Session Tempo button 341
Audio Files folder 157
audio format 446, 1271
Audio Media options 419
  on export 446
  on import 431
Audio MIDI Setup (AMS) (Mac) 94, 143
Audio Pull Up and Pull Down 1277, 1405
Audio Pull Up/Down setting 1406
Audio Pull-Up and Edit Play Rate 1406
audio signal paths 50
Audio Track RecordLock option 110, 563
audio tracks 10
  5.1 format 1201
  and Output format 1213
  and surround sessions 1211
bouncing to disk 1188
channel strips 215
creating a tempo map for 863
disabling Elastic Audio 971
enabling Elastic Audio 970
loop recording 528
placing audio in multichannel tracks 1212
punch recording 525
recording multiple 519
signal flow 1042
track controls 219
Waveform View 583
Audio Zoom In button 604
Audio Zoom Out button 604
AudioSuite menu 211
AudioSuite plug-ins 929, 930, 936, 1095
  Bypass button 934
  Clip by Clip mode 932
  Clips List command 930
  Create Continuous File command 932
  Create Individual Files command 931
  Default Handle Length preferences 124
  Entire Selection mode 932
  File Mode selector 931
  Handle Length setting 935
  multichannel processing 935
  Overwrite File command 931
  Playlist command 930
  Preview 934
  Preview Volume 934
  Render button 935
  Reverse button 935
  Selection Reference selector 930
  Target button 933
  Use in Playlist button 931
  using 936
  Whole File button 935
AudioSuite window 929
Audition Paths selector 58
auditioning
  clips in the Clips List 58, 295
  fades 671
  in browsers 339
  MIDI notes 753
  pre/post-roll 482
  programs 775
  selection start and end points 482
  takes 530
Auto Accept Adjust Bounds option 115
Auto Backup option 109
Auto button (plug-ins) 1104
Auto buttons
  upload, download, and download all shared
  tracks 382
Auto Edit 1317, 1323
Auto Input Monitoring mode 511, 512
Auto Insert Default Plug-Ins preference 117
Auto Match Pull Factors 1278
Auto Rename Clips List command 298
auto-created clips 582
  hiding 299
  renaming 296
AutoFades 680
AutoGlide mode 1232
AutoGlide Time preference 119, 1232
Auto-Height Overrides Height Automation option 1253
AutoJoin
  command 1129
  indicator 1130
AutoMatch
  all controls 1144
  button 1144
  indicators 1137
  individual automation types 1144
  individual controls 1144
AutoMatch Time preference 119, 1134
Automatic Ownership 387
Automatically Copy Files on Import option 124, 408, 418
Automatically Create Click Track in New Sessions option 127
Automatically Download New Shared Tracks option 129
Automatically Find and Relink 457
automating
  plug-ins 1141, 1142, 1143
  sends 1140
  switched controls 1140
  VCA Masters 1180
automation 1125
  and multichannel pan 1236
  and multiple output assignments 1213
  breakpoints 1154
  capturing and applying elsewhere 1174, 1177
  clips 587
  coalescing clip gain to volume automation 948
  coalescing Trim automation 1163
  coalescing VCA automation 1181
  coalescing volume automation to clip gain 948
  converting clip gain to volume automation 948
  converting volume automation to clip gain 948
  copying 1157
  creating 1142
  cutting 1157
  deleting 1149
  delta values 1131
  display of fade boundaries and shapes 689
  drawing with Pencil 1151
  editing 623, 1152
  enabling 1147
  grouped tracks 1156
  hidden tracks 245
  modes 1128
Object/Bus Toggle 1253
  on multichannel tracks 1156
  pass-through point 1129
  pasting 1157
  playlists 691, 1126, 1135
  relative and absolute 1131
  Safe button 1104
  safinig 1134
  smoothing 1133
  snapshot 1172
  Special Paste mode 1160
  stepped 1154
  suspending 1147, 1148
  thinning 1134, 1150
  Track View 594
  trimming 1162
  writing 1138
  writing on stop 1165
  writing to next breakpoint 1166
  writing to selection, selection start or end 1164
Automation Enable window 1138
Automation Follows Edit option 1134
Automation lanes 1135
  in MIDI Editor windows 804
  in the Edit window 1135
Automation Mode selector 1128
automation modes
  Latch 1129
  Latch Trim 1132
  Off 1128
  Read 1128
  Read Trim 1132
  Touch 1129
  Touch Trim 1132
  Touch/Latch 1131
  Touch/Latch Trim 1132
  Trim Off 1131
  Write 1128
  Write Trim 1132
Automation preferences
  AutoMatch Time preference 1134
  Smooth and Thin Data After Pass option 1151
Automation Preview mode 1175
  Punch Preview button 1177
  suspending 1177
  Write Automation To commands 1177
Auto-Name Memory Locations While Playing option 114, 882
Auto-Name Separated Clips option 114, 655
auto-naming
and Strip Silence 909
audio files and clips 504
playlists 691
QuickPunch clips 562
separated clips 655
takes 504
Auto-Spot 1304, 1313, 1315
Auto-Spot Clips command 1290
Auxiliary Inputs 14, 213
channel strips 216
monitoring and mixing 1074
signal flow 1043
track controls 219
Avid Application Manager 48
Avid Artist Community 5
Avid Audio Engine (AAE) 8
Avid Audio Forums command 202
Avid Master Account 152
  signing in 152
  signing out 152
Avid Video Engine (AVE) 94, 1355
Avid Video Satellite 1401

B
Back and Play command 478
Back command 478
Back/Forward Amount 109, 478
Back/Forward commands 478
backing up sessions automatically 109, 158
Backup to Cloud 159, 182
bank select 772
Bar|Beat Markers
  and tempo events 864
  audio with varying tempos 865
  editing 865
  from Identify Beat command 863
  generated with Beat Detective 730
  moving 864
bars
  renumbering 873
Bars|Beats Time Scale 837
Batch Clip Renaming dialog 301
Batch Rename
  clips 298
  tracks 233
Batch Rename Clips 298
Batch Rename Tracks 233
Batch Rename Tracks command 246
batch renaming 301
Batch Track Renaming dialog 301
Beat Detective 719, 720, 721
  beat triggers
    deleting 728
    generating 724
    inserting 728
    moving 728
    promoting 729
  Collection Mode 739
  conforming clips 734
  defining a selection 722
  detecting transients 724
  DigiGroove templates 731
  edit smoothing 737
  extrapolation 732
  generating Bar|Beat Markers 730
  groove templates 731
  Scroll Next 729
  separating clips 733
  system requirements 720
  templates 731
  Trigger Pad 733
  window 721
  with multiple tracks 734
Bed Audio (or Bed Material) 1237
Big Counter window 475
Bi-Phase/Tach
  pulses-per-frame setting 135
  Wiring setting 134
bit depth 155, 446, 1270
Blocks View
  audio track 237
  video track 1359
Bounce
  track 1003
Bounce to Disk command 1185, 1188, 1190, 1197
  bit depth options 1193
  channel format options 1193
  Choose directory 1195
  dither 1186
  File Type 1191
  Format 1193
  Offline option 1195
  Output Path selector, from the 1189
  recording a submix 1197
  sample rate conversion options 1194
  Send Path selector, from the 1189
  source path 1190
  time stamps 1189
Bounce to QuickTime Movie command 1381
breakpoints 1154
Avid keyframes 1153
  clip gain 944
Bring to Front command 849
browsers 310
  display options 318
  opening 311
  sorting 319
Buffer Size (Hardware) 514
bus interrogation 1069
bussing
  multichannel sends 1215
  sends 1058
  signal paths 49
  submixing and effects processing 1074
  surround examples 1219
BWF (.WAV) file format 1191
Bypass button (plug-ins) 1104
Bypass Clip Effects command 951
Bypass Clip Effects settings 951
Bypass Clip Gain setting 948

C
cables
  included cables 1297
  wiring diagrams 1330, 1331
Cache Size 94
Calculator Entry mode (for numeric entry) 638
Calibration Mode command 495
Calibration Reference Level preference 112
canceling record takes 519, 547
Capture Clip command 653
capturing automation values 1177
capturing timecode 1289
Catalogs (Workspace) 313
Center % (Percentage) 1233
Center % in Output window 1234
Center Playhead Scrolling option 481
centered crossfade 669
Change Duration command 1005, 1021
Change Edit to Match Timeline command 644
Change Meter command 824, 866, 868
Change Tempo command 845
Change Timeline to Match Edit command 643
Change Velocity command 1005, 1019
channel mapping
  default path order 60
  editing 74
  re-mapping 75
Channel selector 1105
  for multi-mono plug-ins 1216
channel strips 13
  audio tracks 215
  Auxiliary Inputs 216
  Instrument tracks 218
  Master Fader tracks 216
  MIDI tracks 217
  VCA Master tracks 217
channels 13
Chase LTC mode 1321
chasing
  MIDI controller events 777
  MIDI notes 777
  MIDI program changes 778
Chat 366
  start new 367
Chat list 366
  pinning items 371
  unpinning items 371
chat messages
  filtering 370
Chord Change dialog 878
chord diagrams 878
chord symbols 824, 878
Chord Symbols ruler 877
chords 877
Classic Numeric Keypad mode 28, 109
Clear All Clip Indicators command 225, 1066
Clear Clip Gain command 946
Clear command (Clips List) 300
Clear command (Edit menu) 597
Clear Special commands (automation) 1160
Clear Trim Automation Track command 246, 1150
click 496, 497, 498
Click plug-in 496
click track 496
clicks and pops, avoiding 586
Clip Auto Fade In/Out Length preference 681
clip boundaries
  extending selections to 636
  moving edit cursor to 640
  moving Playhead to 484
clip definitions 412
clip effects 949
  applying 951
  bypassing 951
  rendering 952
Clip Effects display 950
Clip Effects Status 592
clip gain 941
  adjusting with the Clip Gain Fader 943
breakpoint editing 944
bypassing 948
clearing 946
Clip Gain Info view 941
Clip Gain Line 942
clip groups 926
coalescing clip gain to volume automation 948
coalescing volume automation to clip gain 948
converting clip gain to volume automation 948
converting volume automation to clip gain 948
copying 947
cutting 946
Default Handle Length preferences 124
dynamic 941
editing 943
editing with the Grabber tool 944
editing with the Pencil tool 944
pasting 947
rendering 948
static 941
static clip gain value display 941
Clip Gain Fader 943
Clip Gain Fader icon 941
Clip Gain Info view 941
Clip Gain Line 942
Clip Gain Nudge Value setting 114
clip group file format (.rgrp) 452, 926
clip groups 583, 919
changing timebase format 923
creating 920
editing 924
exporting to different hard drives 454
fades and crossfades 925
importing 453
importing and exporting 452
mixed 921
multitrack 921
regrouping 921
separated 922
tick-based 923
timebase format 920
trimming 925
ungrouping 921
video 1374
Clip Groups folder 157
Clip Hold options 123, 225
Clip Info dialog 1409
Clip information 297
Clip Matching Options setting 114
Clip menu 211
Bring to Front command 849
Capture command 653
Identify Sync Point command 1292
Lock command 907
Mute/Unmute command 909
Quantize to Grid command 663
Remove Sync Point command 906
Send to Back command 849
Ungroup All Clips command 921
Ungroup Clips command 921
Unlock command 907
Unloop Clips command 917
Clip Name
Right-click menu 212, 300
View option 591
Clip Time View option 591
Clip Transparency view 895
Clip Views
  Transparency 895
clip-based effects 949
clip-based gain 434, 941
clipping 494
clips 11, 237, 583
  aligning to clip start points 894
  auto-created 582
  automation 587
  auto-naming options 298
  auto-spotting 1290
  bringing to front 849
  capturing 653
  clearing 597
  clearing Real-Time Properties 786
  clip effects 949
  Conform to Tempo 849
  conforming with Beat Detective 734
  consolidating 665
  copying 595
  creating 653
  crossfading between 679
  cutting 595
default names 504
displaying names 591
displaying times 591
dragging from Clips List 891
dragging to multichannel tracks 665
duplicating 913
Edit-locking 908
exporting as audio files 410
extending selections to include 636
finding 292
fitting to an Edit selection 667
 gaining 941
 healing separations 656
 hiding auto-created 299
 inserting silence into 912
 locking 907
 looping 915
 managing 296
 MIDI 545
 moving clips with fades 685
 moving in Grid mode 903
 multichannel 583
 muting 909
 nudging 660
 nudging clips with fades 685
 offline 583
 Original Time Stamp 901
 pasting 596
 placing at Edit insertion point 893
 placing in tracks 891
 quantizing 663, 1017
 removing pitch shift (Elastic Audio) 992
 removing silence from 910
 removing unused 300
 removing warp (Elastic Audio) 985
 renaming in the Clips List 297
 renaming on a track 590
 repeating 914
 replacing 903
 Select options 294
 selecting 620, 632
 selecting all in a track 632
 sending to back 849
 separating 654
 separating with Beat Detective 733
 separating with Separation Grabber 655
 shifting 907
 shuffling 898, 899
 slipping 899
 snapping to 897
 snapping to next 897
 sorting 291
 spotting 900, 1289
 stripping silence from 909
 sync points 905, 1292
 time stamping 1290
 Time-locking 908
 trimming by Nudge value 659, 757
 trimming start/end points 613
 trimming to Edit insertion point 657
 trimming unwanted data from 657
 unlocking 907
 User Time Stamp 901
 user-defined 296, 299, 582
 video 1371
 warped (Elastic Audio) 583, 984
 whole-file 582
 Clips List 289
 and MIDI clips 289
 auditioning clips 295
 displaying file info for audio clips 290
 dragging from 891
 Export Clips as Files command 410
 Find History 293
 finding clips 292
 Keyboard Focus 27
 menu 289
 previewing clips 295
 repeating a previous search 292
 selecting clips 293
 sorting 291
 Clips List Keyboard Focus 294
 Clips List menu 1291
 Auto Rename command 298
 Clear command 300
 Compact command 665
 Export Clip Definitions command 412
 Export Selected As Files command 443
 Find command 292
 Rename command 297
 Select options 294
 Selected Unused command 300
 Show Auto-Created option 299
 Sort By options 291
 Time Stamp Selected command 901
 Timeline Drop Order option 892
 Clips List Selection Follows Edit Selection option 113, 290, 632
 Clips View 237, 238, 587
 Clock Reference setting 1405
 Clock Source 97, 1123, 1270
 Close Session command 179
 closing plug-in windows 1105
 Cloud Storage Usage Meter 382
 Coalesce Clip Gain to Volume Automation command 948
 Coalesce Pan Guide Automation command 1254
 Coalesce Trim Automation options 119
 Coalesce Trim Automation Track command 246
Coalesce VCA Master Automation Track command 246
Coalesce Volume to Clip Gain command 948
Coalesce when Removing Slaves from VCA Group option 118
coaescing
  Trim automation 1163
  VCA automation 1181
Collaboration
  undowloaded shared tracks 391
Collaboration Preferences 129
collaboration transaction logs 364
Collection Mode (Beat Detective) 739
Color Coding
  Apply to Channel Strip 262
    options 107, 259
Color Palette window 261
Color setting (for window dub) 135
Column 200
Command|8 1090
Commands Keyboard Focus 26
Comments View 233, 1053
Commit Track 995
Commit Tracks dialog 996
Commit Up To This Insert 998
Committing Elastic Audio 971
Compact command 665
Compact Selected command 300
compacting audio files 666
Compare button (plug-ins) 1103
compatibility 3, 1407
Compensate Side Chains option 119
compensating
  for monitor delay 1400, 1410
  for video satellite offsets 1400
compensating for signal delays in side-chain processing 1085
Compensation for Input Delays After Record Pass option 57
Compensation for Output Delays After Record Pass option 57
compositing 694
Conductor button 197
Conductor Ruler Ownership control 394
Conductor Ruler Ownership control right-click menu 394
Conductor rulers 838
  including in selections 638
configuring
  MMC 1284, 1285
  SMPTE 1275
  configuring a paddle device 1325
Conform to Tempo command 849
connecting
  external audio devices 1122, 1123
Consolidate command
  audio 665
  MIDI notes 759
Consolidate From Source Media 447
Consolidate Handle Length 432, 447
Consolidate Handle Size 447
Consolidate Source Audio Media 432
consolidating media 352
Constant command (Tempo Operations) 858
Continuous Scroll with Playhead option 481
Continuous Scrolling During Playback option 481
continuous zoom 604
control surfaces
  C|24 1090
  Command|8 1090
  D-Command 1090
  D-Control 1090
control track 1318
controller events 764
  and MIDI clips 588
  editing 765
  editing with Smart Tool 623
  inserting 765
Controller lanes 764, 1135
  in MIDI Editor windows 804
  in the Edit window 1135
Controllers folder (controller personalities) 1091
Conversion Quality option 399, 1371
Convert Clip Gain to Volume Automation command 948
Convert Plug-In selector 1104
Convert Volume to Clip Gain command 948
Convert WAV files to AES31/BroadcastWave option 124, 408, 458
converting sessions 166
Copy Clip Gain command 947
Copy command 595
Copy From Source Media 446
Copy from Source Media (Video) 420, 432
Copy Settings command 1109
Copy Source Audio Media 431
Copy Special commands 1159
Copy to Send command 1141
Copy/Move Indicators 592
copying
MIDI notes with the Split command 1025
plug-in settings 1111
selections and clips 595
track automation to sends 1141
track control settings to sends 1068
Core Audio 8
count off 497
Countoff button 197
CPU peak indicator 103
CPU Total meter 103
Create Catalog from Selection 316
Create Click Track command 496
Create Fades command 679, 680
Create Machine Track Arming Profile 1316
Create tab 153
creating
clip groups 920
clips 653
crossfades 679
fade-ins/outs 677
Mac and PC compatible sessions 460
Markers and Memory Locations 881
settings subfolders 1110
Crossfade Preference for Pre/Post-Roll option 115, 676
crossfades
creating with Smart Tool 622
DestructivePunch 563
equal gain 675
equal power 675
Fades dialog 671
in batches 681
linear 675
overlap 675
Overlapping Waveforms view 670
pre/post 680
removing 679
TrackPunch 562
trimming 680
cueing
hi-speed mode 1315
search mode 1314
Current Feet+Frames command 1276
Current Meter indicator 197, 866
current tempo 197, 844
Current Time display 1271
Current Timecode Position command 1276
Custom FF/REW Speed preference 108
Custom Note Duration
  Follow Grid 746
custom session templates 176
Custom Shuttle Lock Speed preference 108, 625
Cut Clip Gain command 946
Cut command 595
Cut Special commands 1159
  All Automation 1159
  Pan Automation 1159
  Plug-In Automation 1159
Cut Time command 868, 871
cutting
  automation 1157
  MIDI notes with the Split command 1025
  selections and clips 595
D
Dashboard
  Accept or Reject collaboration invitations 183
  Backup to Cloud 182
  Open Revision History 181
  Show on startup option 155
Dashboard window 152, 153
DAT recorder, recording from 534
D-Command 1090
D-Control 1090
default
  audition path 58
  meter 498
  output path 59
  path order 60
  paths 71
  program change 772
  start time for Media Composer sequences 1410
tempo 499
Default (Paths) 71
Default Automatic Naming to English option 106
Default Clip Color Coding options 107
Default Dynamics preference 117, 1101
Default EQ preference 116, 1101
Default Fade Settings 115
Default Format selector 60
Default Handle Length options 124
Default Input Gain preference 126
Default Note Duration 746
Default Note On Velocity setting 746
Default Plug-In preference 126
Default Settings, for TC/E plug-in 126
Default Thru Instrument 539
Default Thru Instrument preference 127
Default Track Color Coding options 107
Degree of Thinning preference 118
Delay 1400, 1410
MIDI Track Offsets 779
Delay (dly) indicator 1083
Delay After Play Command option 1322
Delay After Play Command preference 131
Delay Before Locking to LTC option 130, 1308
Delay Before Locking to Timecode option 130, 1308
Delay Compensation 1082
- applying to automatically bypassed tracks 561, 1086
- bypassing 1084
- changing track delay 1084
- Compensate Side-Chains 119
- Delay (dly) indicator 1083
- enabling 1082
- exceeding compensation limit 1085
- H/W Insert 55
- hardware insert delays 55, 1088
- MIDI Beat Clock 128
- MIDI Timecode 128
- mode 1083
- side-chains 1085
- Time Mode option 119
- User Offset (+/-) field 1084
- viewing 230, 1055
Delay Compensation Status indicator 190
Delay Compensation Time Mode option 119, 1083
Delay Compensation View 230, 1055, 1083
Delay Compensation View option 1083
Delay for External Devices options 128
Delay plug-ins 1093
Delay setting (Real-Time Properties) 784
Delete Active Groups (Groups List) command 280, 284
Delete Current Settings File command 1109
Delete Current Settings File command (fares) 677
Delete Fades command 679
Delete Group command 280, 283
Delete Index for All Offline Volumes 316
Delete Track command 235, 246
delete version
  - Revision History
    - Delete version 175
deleting
  - automation 1149, 1157
  - groups 283
  - Memory Locations 887
  - MIDI Event List items 833
  - MIDI notes 762
paths in I/O Setup 73
playlists 693
program changes 775
sysex events 777
tracks 235
unused clips 300
Destination Audio Sample Rate 434, 446
destination folder for plug-in settings 1110
destructive editing 666
Destructive Record mode 502, 527
destructive recording 527
DestructivePunch 569
crossfades 563
  - Prepare DPE Tracks command 571
  - preparing for 571
DestructivePunch File Length preference 112, 571
DigiGroove templates 731
Digital Cut Tool (Media Composer) 1415
DigiTest 90
Disable “Input” When Disarming Track (In “Stop”) option 111
discrete signal control 1212
Disk Allocation 509
  - and cross-platform sessions 510
  - and system volume 511
Disk Cache meter 103
Disk meter 103
Disk Space window 508
Display (Groups List) command 280
Display Events as Modified by Real-Time Properties option 127, 786
Display Name 360
Display Preferences 105
  - Clip Hold options 123
  - Draw Grids in Edit Window option 601
  - Language options 106
  - Peak Hold options 122
displaying
  - all rulers 839
  - clip names 591
  - clip times 591
  - file info for audio clips 290
  - Meter Ruler 866
  - Original Time Stamps 1291
  - Tempo ruler 844
  - User Time Stamps 1291
dither
  - and Bounce to Disk 1186
  - on Master Faders 1186
  - resolution and Bounce to Disk 1193
divergence
drawing 1234
using 1233
Documentation and Settings setting 110
Dolby Atmos 1237
   Bed Audio (or Bed Material) 1237
   Bus/Object toggle 1247
   Dolby Atmos Metadata 1237
   Enable 1240
   mapping busses to Objects 1243
   mixing bed material 1242
   Network configuration 1239
   Object Audio (or Objects) 1237
   Object Control Mode 1248
   Object controls 1247
   object output path 1245
   Object Path selector 1247
   PEC/DIR Recorder Workflow example 1257
   Renderer Connection Status indicator 1248
   restrictions 1240
   Theater mode 1249
Dolby Atmos Metadata 1237
Dolby Atmos Renderer default busses 1242
Don't Limit Search Results 316
Double Selection command 636
Double-Clicking a MIDI Clip Opens option 128
Download 245
Download All New Changes button 381
Download All Shared Tracks button 381
Download command 386
Download Ruler Changes control 393
Download Ruler Changes Right-click menu 393
Download Track Changes control 386
Download Track Changes Right-click menu 386
drag and drop
   from the Clips List to tracks 892, 893
   importing audio files 400
   importing MIDI files 414
Drag and Drop From Desktop Conforms to Session Tempo options 125, 408
Draw Grids in Edit Window option 601
DSP
   active and inactive items 17
   and inactive inputs and outputs 251
   and inactive sends 1058
   and no output 1058
   and overall resources 17
   and Send meters 1066
DSP usage meters 104
dubber emulation 111, 563
Duplicate and Extend command 913
Duplicate and Extend Edit selections 913
Duplicate and Extend Selection command 637
Duplicate command 913
Duplicate Dolby Atmos Plug-in automation to track pan automation 1255
Duplicate Group command 280
Duplicate Track command 236, 246, 1128
Duplicate track pan automation to Dolby Atmos Plug-in automation 1255
duplicating
   inserts 1102
   MIDI note selections 913
   playlists 692
   selections and clips 913
   sends 1067
Duration
   Real-Time Properties 783
durations, for MIDI notes
   editing with Change Duration command 1021
   making more legato 1023
   making more staccato 1023
   randomizing 1023
Dynamic Plug-In Processing option 93
Dynamic Transport mode 485
Dynamics plug-ins 1093

E
Edit commands 594, 595, 596, 597
edit cursor 476
   and scrubbing 624
   moving to clip boundaries 640
   placing with the Selector tool 619
Edit Groups 282
   and selections 631
Edit Insertion Follows Scrub/Shuttle option 108, 624
Edit insertion point
   placing clips at 893
   trimming clips to 657
Edit Markers 630
   and selection length 635
Edit menu 210
   Change Edit to Match Timeline command 644
   Change Timeline to Match Edit command 643
   Clear command 597
   Clear Special commands 1160
   Consolidate command 665
   Copy command 595
   Copy Special commands (automation) 1159
Copy to Send command 1141
Create Fades command 679, 680
Cut command 595
Cut Special commands 1159
Delete Fades command 679
Duplicate command 913
Fade To End command 679
Fade To Start command 679
Fades command 671
Heal Separation command 656
Identify Sync Point command 906
Insert Silence command 912
Paste command 596
Play Edit Selection command 483
Play Timeline Selection command 483
Rego command 593
Repeat command 914
Repeat to Fill Selection command 597
Select All command 632
Separate Clip commands 654
Shift command 907
Strip Silence command 909, 910
TCE Edit to Timeline Selection command 666
Thin All Automation command 1151
Thin Automation command 1151
Trim Automation to All Enabled command 1175
Trim Automation to Current command 1175
Trim Clip End to Fill Selection command 658
Trim Clip End to Insertion command 657
Trim Clip Start to Fill Selection command 658
Trim Clip Start to Insertion command 657
Trim Clip to File commands 659
Trim Clip to Fill Selection command 658
Trim Clip to Selection command 657
Undo command 593
Write Automation commands 1173, 1174

Edit mode buttons 189, 599
Edit modes 599
and placing clips 891
Grid 601
Relative Grid 601
Shuffle 599
Shuffle Lock 600
Slip 600
Spot 600, 1287
Edit Play Rate setting 1405, 1406
edit playlists 691
Edit selection
doubling 636
duplicate and extend 637
extend to track above 639
extend to track below 639
halving 636
move earlier by selection amount 637
move later by selection amount 637
removing bottom track from multitrack selection 639
removing top track from multitrack selection 639

Edit Selection Follows Clips List Selection option 114, 632
Edit Selection indicators 637
Edit selections
auditioning with Playhead enabled 483
copied from Timeline selection 643
copied to Timeline selection 644
making with the Selector tool 620
sliding in the Ruler 641
Edit selection
moving down one track 639
moving up one track 639
edit smoothing (Beat Detective) 737
Edit tools 603
Grabber 603, 633
Pencil 603, 626
Scrubber 603, 623
Selector 476, 603
Smart Tool 603
Trim 603, 613
Zoomer 603, 604
Edit window 187, 188
All View option 1052
half-screen 481
None Views option 1052
scrolling from the Ruler 644
Universe view 646
View options 188
Edit Window Default Length preference 105, 193
Edit Window Follows Bank Selection option 117
Edit window View options 1052
Edit Window View selector 1052
Edit Window Views
Track Collaboration 383
Edit/Tool Mode Keyboard Lock 627
editing
across multiple tracks 598
and Edit modes 599
automation 1152
Bar|Beat Markers 865
breakpoints 1154
controller events 765
during playback 582
Edit modes 599
Grid mode 601, 602
Grid modes 902
hidden tracks 245
Markers 886
Memory Locations 886
meter events 867
MIDI clips 587
MIDI Event List 832
MIDI notes 752
nondestructively 581
nondestructively (audio) 586
nondestructively (MIDI) 590
note attributes 761
note durations 1021
note velocities 759, 1019
program changes 775
Shuffle Lock mode 600
Shuffle mode 599
Slip mode 600
Spot mode 600
tempo events 845
Track View 594
waveforms 586
Editing Preferences 113
Auto-Name Memory Locations While Playing option 882
Auto-Name Separated Clips option 655
Clips List Selection Follows Edit Selection option 290, 632
Conversion Quality option 399
Crossfade Preference for Pre/Post-Roll option 115, 676
Edit Selection Follows Clips List Selection option 632
QuickPunch Crossfade Length preference 562
Separate Clip Operates On All Related Takes option 655
editing tags 335
Edit-locking clips 908
Effect Bypass button 1104
Elastic Audio 965
Accordion Warp 982
adding Event markers 986
analysis 973
analysis in Workspace 338
Analysis view 972, 986
AudioSuite processing 992
batch analysis 338
Clipping indicator 975
committing 971
Conform to Tempo 849
creating new tracks 971
deleting Event markers 987
disabling 971
Edit Groups 985
enabling on tracks 970
event confidence 973
Event markers 979
Individual Range Warp 984
Monophonic plug-in 977
moving clips between tracks 993
moving Event markers 986
out of range processing 985
pitch shift 991
Plug-In selector in browsers 341
plug-ins 975
Polyphonic plug-in 976
preview at session tempo 343
processing types 974
promoting Event markers 987
properties 988
quantizing 1016
Range Warp 983
removing pitch shift 992
removing warp 985
Rendered files 975
regenerating 346, 457
Rhythmic plug-in 977
TCE algorithms 975
Telescoping Warp 981
tempo detection 973
Tempo Event–generated Warp markers 981
tempo-based warping 848
track controls 972
track views 972
tracks 970
transpose 991
Varispeed plug-in 978
Warp indicator 984
Warp markers 979
Warp view 972, 979
warped clips 984
workflows 965, 966
X-Form plug-in 978
Elastic Audio Plug-In Selector 972
Elastic Audio preferences 126
Elastic Audio-enabled tracks 970
Elastic Properties window 988
Embed Eleven Setting From selector 61
embedded media 22
Emoticon and Notations pane 371
Enable 129
Enable “Track Notes” Dialog option 129
Enable Dub Window option 135
Enable Elastic Audio on New Tracks preference 126
Enable GPU option 113
Enable Hardware During Scrub option 113
Enable Session File Auto Backup option 109
Enable SYNC Peripheral option 134
enabling
  Auto Backup option 109
  automation 1147
  groups 287
  MIDI input devices 538
  plug-in automation 1107
End To Insertion command 657
Enable Mac/PC Compatibility option 169, 460
Enable Media Composer Compatibility option 444
EQ Curve view 1054
EQ plug-ins 1093
equal gain crossfades 675
equal power crossfades 675
error suppression 92
Ethernet Controllers 138
EUCON 139, 1090, 1125
EUCON Control 246
Event Edit Area 761
Event menu 211
  All MIDI Notes Off command 780
  Beat Detective command 721
  Change Meter command 866
  Event commands 1005
  Identify Beat command 863
  MIDI commands 1005
  MIDI Event List 827
  MIDI Track Offsets command 779
  Remove Duplicate Notes command 780
  Renumber Bars command 873
  Tempo commands 857
  Time commands 868
Event Operations commands 1005
  Change Duration command 1021
  Change Velocity command 1019
  Flatten Performance command 1019
  Input Quantize command 1027
  Quantize command 1006
  Restore Performance command 1018
  Select/Split Notes command 1026
  Step Input command 1028
  Transpose command 1023
Event Operations window 1005, 1006
Exit command (Windows) 183
Expand Channels to New Playlists 709
Expand to New Tracks command 246
Expanded Transport View 208, 521
Export
  Audio Media options 446
  OMF/AAF Options 444
  Sample Rate Conversion options 445
  Selected Tracks to Sequence in Production
    Management 448
Export Clip Definitions command 300, 412
Export Clip Groups command 454
Export Clips as Files command 301, 410
Export MIDI command 414
Export MIDI Settings dialog
  Apply Real-Time Properties option 415
  MIDI File Format pop-up menu 415
Export Selected As Files command 443
Export Selected Tracks as OMF/AAF command 438, 440
Export Selected Tracks to Sequence in Production Management 448
Export Session Info as Text command 450
Export Settings button (I/O Setup) 83
exporting 397
  AAF files 438, 446, 447
  audio 410
  clip definitions 412
  clip groups 454
  markers 415
  MIDI tracks 414
  OMF files 446, 447
  OMFI files 438
  Score to Sibelius 826
    sessions as text 450
    Sibelius (.sib) files 826
    stereo interleaved files 411
Ext. Clock Output 99, 1268
Extend Edit Down command 639
Extend Edit Up command 639
extending selections 636, 854
  to adjacent tracks 638, 640
  to clip boundaries 636
  to include adjacent clips 636
  to Markers and Memory Locations 636
to next tempo event 854  
external clock source 1123  
external MIDI instruments 554  
external side-chain processing 1107  
External Timecode Offsets 1273, 1310  
extrapulation 732

F
factory I/O settings 81  
Fade Files folder 157  
Fade settings 676  
Fade Settings menu 677  
Fade To End command 679  
Fade To Start command 679  
fade-in shapes 673  
fade-out shapes 672  
fades 677  
    adjusting with Smart Tool 622  
    AutoFades 680  
    creating 677  
    creating with Smart Tool 621  
    equal gain 674  
    equal power 674  
    in batches 681  
    moving 685  
    nudging 685  
    presets 676  
    Slope setting 674  
Fades command 671  
Fades dialog 671  
    In Shape 673  
    Link option 675  
    Out Shape 672  
Fast Forward 477  
Fast Forward button 194  
FB360 Audio plug-ins 1263  
Feet+Frame Rate setting 1271  
Feet+Frames  
    redefining position 1276  
Feet+Frames Time Scale 838  
field recorder  
    expanding alternate channels to new playlists 709  
    importing monophonic audio files 407  
    importing polyphonic audio files 407  
file formats (audio)  
    AIFF 1191  
    BWF (.WAV) 1191  
    MP3 1191  
    MXF 1192  
    QuickTime 1192  
file management 455  
File menu 210  
    Bounce to Disk command 1188  
    Close Session command 179  
    Exit command (Windows) 183  
    Export MIDI command 414  
    Export Selected Tracks as OMF/AAF command 438  
    Export Session Info as Text command 450  
    Import Audio to Track command 403  
    Import Clip Groups command 453  
    Open Session command 162  
    Revert to Saved command 165  
    Save As command 166  
    save command 165  
    Save Copy In command 166, 461  
final mixdown 1197  
Find All Candidates command 348  
Find Clips  
    By Name 292  
    Include Subsequently Added Clips 292  
Find Clips List command 292  
Find History 293  
Find Matching Tracks option 422  
finding clips 292  
First Invite Shares All Tracks option 129  
First Selected MIDI Track option 127  
Flatten Performance command 1005, 1019  
footswitch 98  
Force Audio Media to Target Session Format 432  
Force Upload command 385, 386  
Forward and Play command 478  
Forward command 478  
frame rate  
    and refresh rate 1402  
    pull up and pull down 1277  
Frames 1359  
Frames View (video tracks) 1359  
frame-tearing 1402  
freewheeling timecode 1274  
Freeze Track 1000  
Front Divergence 1233  
Front/Rear Divergence 1233

G
Gain Reduction meter 228  
generating timecode 1282  
Glide Automation commands 1161  
global (system-wide) preferences 131
Global Freeze Tracks indicator 190
Global MIDI Playback Offset preference 128, 778
Global Track Collaboration 380
Go to End button 194
Grabber tools 603, 620, 633, 755
  editing breakpoints with 853, 1153
  editing clip gain breakpoints with 944
  Object Grabber tool 621, 633
  selecting MIDI notes with 752
  Separation Grabber tool 620, 655
  Time Grabber tool 620
Grid mode 601, 902
  Absolute 601, 902
  Clips/Markers option 602
  configuring 602
  Draw Grids in Edit Window option 601
  Relative 601, 902
  setting the Grid value 902
  suspending 902
  with Slip, Shuffle, or Spot enabled 601
Grid value 747, 901
  setting for MIDI editing 747
Grid Value selector 602
Groove Quantize 1012
groove templates 731, 1012
  applying 1014
  mapping 1015
Group Assignment selector 1047
  group chat
    renaming 368
    setting a topic 368
group chats 368
Group ID indicator 280
Group Name 280
Group Track command 282
groups
  attributes 284
  automation editing 1156
  control offsets 288
  creating 282
  deleting 283
  duplicating 284
  Edit Groups 282
  enabling 287
  hidden tracks 245
  keyboard selection 287
  Mix Groups 282
  modifying 283
  renaming 283
Groups dialog 281
  Keyboard Focus 27
  menu 280
guitar tablature 878

H
H/W Buffer Size 514
H/W Insert Delay 55
half-screen 481
half-speed playback 484
half-speed recording 535
Halve Selection command 636
hard drives
  and Compacting Audio 665
  recording to system volume 511
  Round Robin Allocation 510
Hardware Buffer Size 90, 92
hardware I/O inserts 1094
delays 55
hardware I/O sends 1063
Hardware Insert Delay Compensation 55, 1088
Hardware Setup
  Buffer Size 514
  Ext. Clock Output 99
  HD I/O 101
  HD MADI 102
  HD OMNI 100
  Launch Setup App 96
  MTRX 102
HD audio interfaces 41
HD I/O 45
  configuration 101
HD MADI 46
  configuration 102
HD Native systems 40
HD OMNI 44
  configuration 100
HDX
  DSP usage meters 104
  HDX systems 39
Heal Separation command 656
HEAT 48, 1031
  import Master Settings 426
Help 211
  Tool Tips 105, 212
Help menu 25, 211
HFS+ drives
  and Windows systems 459
hidden tracks
  and selections 631
group edits 245
groups 245
Hide All Floating Windows command 206
Hide and Make Inactive Track command 245
Hide/Show Track command 245
hiding
   auto-created clips 299
High-Definition video
   playback 1379, 1402
hi-speed mode 1315
Horizontal Position setting 135
Horizontal Zoom In button 604
Horizontal Zoom Out button 604
Host Engine 92

I
I/O Settings 81
I/O Setup 49
   Bus page 54
   controls 56
   customizing 62
dialog 50
factory settings files 81
H/W Insert Delay page 55
I/O routing 63
importing for surround 1206
Input page 53
Insert page 55
last used 83
Low Latency Monitoring 60
Mic Preamps 55
options 57
Output page 54
paths 67
settings files 81
sub-paths 69
surround 1219
surround formats 1204
surround mix settings file 81
I/O View 222, 1055
Identify Beat command 863, 864
Identify Sync Point command 906, 1292
Idle MTC Enabled option 134
IDs (machine) 1327
Ignore Changes command 386
Ignore Errors During Playback/Record option 92
Ignore for Future Download 245
Ignore Track Arming option 130, 1322, 1324
illegal characters 163, 457
Import 245
Audio Media options 431
Sample Rate Conversion options 433
Sequence from Production Management 436
Timecode Mapping options 432
Import as Offline Satellite Media 420, 432
Import Audio dialog 403
Import Audio to Track command 403
Import Clip Groups command 453
Import HEAT Master Settings 426
Import Key Signature Map option 425
Import Markers 425
Import Memory Locations 425
Import MIDI 412
Import project version data 174
Import Rendered Audio Effects 434
Import REX Files as Clip Groups option 125, 408
Import Sequence from Production Management 436
Import Session Data command 416
Import Settings button (I/O Setup) 83
Import Settings command (plug-ins) 1109
Import Settings command (fades) 677
Import Video command 1368
Import Volume Automation 434
Import Window Configurations 425
importing 397
   audio 398
   clip groups 453
copying during 418
copying imported files 418
HEAT Master Settings 426
key signature map 425
Markers 412, 425
Memory Locations 425
MIDI tracks 412
multichannel audio files from a field recorder 407
multichannel I/O Settings 1206
offline items from Catalogs 353
plug-in settings 1110
PRE settings 426
referencing imported files 418
session data 419
tempo and meter map 425
tracks for other sessions 416
using drag and drop 400
Window Configurations 425
importing audio from QuickTime movies 1370
importing video 1367
inactive 17
   inputs 251
inserts 1096
Master Faders and assignments 1044
outputs 251
paths 74
paths, global 74
sends 1067
track path assignments 251
tracks 259
Include Control Changes in Undo Queue option 119
Include Sends in Trim Mode option 118
Incoming Time 1310
Incoming Time display 1271
in-place auditioning 295
input connections 13, 494
Input Devices command 538
Input Filter command 540
MIDI Event List View Filter dialog 829
MIDI Input Filter dialog 540
input levels 494
Input Only Monitoring mode 511, 512
Input Path selector 222, 247
Input Quantize command 1005, 1027
Insert mode 1318
Insert Position selector 1103
Insert Silence command 912
Insert Time command 868, 870
inserting
controller events 765
events in MIDI Event List 830
meter events 866
MIDI notes 750
plug-ins on tracks 1097
program changes 775
tempo events 845
Insertion Follows Playback option 487
inserts 1050, 1093
Inserts View 1053
Inserts View options 1050
Instrument plug-ins 553
Instrument tracks 214
channel strips 218
Clips View 237
MIDI Input selector 256
MIDI Output selector 256
monitoring and mixing 1075
Notes View 237
recording 542
signal flow 1046
surround mixing 1215
track controls 221
Instruments View 1053
Interchange Workflow
linked media 23
Interchange workflow
embedded media 22
interleaved audio file 156
interleaved option (sessions) 156, 1271
Internal mode (Clock Source option) 1270
internal side-chain processing 1107
Inverse linked panning 1072
Invite Contacts to Collaborate 364
Items to Copy 169
Preserve Folder Hierarchy command 170
J
Jam Sync 1274
Join command 1129
Joining Project Downloads All Shared Tracks option 129
K
Keep Window on Top 316
key input 1103, 1107
Key Input selector 933, 1103
key signature map 425
Keyboard Focus 25
Clips List 27, 294
Commands 26
Groups List 27
keyboard shortcuts 1106
global key commands 25
numeric entry 637
recording 519
Knowledge Base 211
L
Language options 106, 470
Last Used 83
Latch automation mode 1129
  AutoJoin 1129
  Join 1129
Latch option 258
Latch Record Enable Buttons option 110
Latch Trim automation mode 1132
Latching Behavior for Switch Controls in “Touch” option 118
latency 92
Launch Setup App button 96
layback 1319
Layered Editing option 662, 896
LCRS path examples 1207
Level meters
  for audio tracks 224
  for Aux Input, Master Fader, and Instrument tracks 224
Levels of Undo preference 116, 594
LFE
  enable in plug-ins 1236
  faders 1236
  routing examples 1222
Librarian menu 1103
Limit Character Set option 169
Linear command (Tempo Operations) 858
linear crossfades 675
Linear Sample Display 856
Linear Tick Display 856
Linearity Display Mode 856
Link controls
  accessing mini-link buttons from a control surface 1412
  linking systems to a control surface 1412
link controls 1411
  displaying 1412
  link button 1411
  Satellite Link buttons 1411
Link Enable buttons 1105
  in multi-mono plug-ins 1216
Link Record and Play Faders option 110, 513
Link Selection button 629, 631
Link Timeline and Edit Selection option 629
Link to Source Media (Video) 420, 432
Link Track and Edit Selection option 234, 631
linked media 23
linking
  inverse panning 1072
  multi-mono plug-ins 1216
  plug-in controls 1121
  stereo panners 1071, 1230
local (current session) preferences 131
Local Control 539
Local Waveform Cache Versions preference 113
Local/Remote 1314
locating
  the playback cursor 476
  with Fast Forward/Rewind 477
  with Location indicators 644
Location indicators 644
locations
  dragging MIDI notes 755
  quantizing MIDI notes 1010
  randomizing MIDI notes 1009, 1011
Locators to Import 435
Lock Clip command 907
Lock Settings File command 1109
Locked indicator 1273
Locked Track command 246
Loop Playback option 485
  and Touch mode 1139
loop points 520
  Timeline Selection Markers 521
Loop Record mode 502, 529
loop recording
  and pre/post-roll 528
  audio 528
  MIDI 549
  multiple takes (MIDI) 550
Loop Trim tool 617
looped clips 915
  copying and pasting automation 919
  creating 916
  editing 917
  selecting 917
  trimming with Loop Trim tool 618
  unlooping 917
looping
  clips 915
  playback 485
  selections 485
loops
  creating with the Loop Trim tool 617
  Loop Trim tool 617
  recording with reverb or delay 1188
Low Latency Monitoring
  Bounce to Disk 515
Low Latency Monitoring option 514
Low Latency Monitoring path 60
LTC Output Level setting 134

M
Mac sessions
  compatibility with Windows 460
machine
  pre-roll 1306
  profiles 1316, 1327
  Transport Master 1303, 1313
Machine Chases Memory Location option 129,
  1286, 1307
Machine Control (Peripherals dialog) 135
Machine Cues Intelligently option 130, 1307
Machine Follows Edit Insertion/Scrub option 129,
  1286, 1307
machine IDs 1327
Machine Track Arming window 1287
MachineControl 48
Main Counters 840
main paths 50
Main Time Scale 839, 840, 1277
Main Timebase ruler 839
Make (Track) Inactive command 245, 259
managing clips 296
Manual Downloads Only option 387
Manual Ownership 388
Manual Tempo mode 197, 500
Manual Uploads Only option 385
Manually Find and Relink 457
mapping busses to Objects 1243
mapping paths in I/O Setup 74
Mapping to Object column 1243
Markers 435, 883
  creating 881, 882
  deleting 887
  editing 886
  exporting 415
  extending selections to 636
  importing 412, 425
  moving 887
  sorting 889
  tick-based and sample-based 884
  viewing options 888
Markers ruler 839, 884
Marketplace menu 202
Master Fader
  EUCON Monitor path control 246
  Master Faders 1044
  as a stereo master volume control 1045
  as master send level control 1081
  channel strips 216
  inactive 1044
  inserts 1093
  meters pre/post fader 1044
  multichannel 1215
  post-fader inserts 1044
  signal flow 1044
  track controls 219
  trimming the input to a submix 1045
Master Link button 1105
  in multi-mono plug-ins 1216
Master View for tracks 240, 1158
mastering 1198
Matches 706
Matches (alternate takes) 530, 706
Matching Criteria window 531, 705
Media Composer
  Edit Play Rate 1405
  linking and unlinking from 1412
  linking to Pro Tools 1411
  Project Type 1405
  Starting TC Timecode setting 1405
  Timecode Format 1405
  troubleshooting satellite connections 1404
  Video Satellite 140, 1401
media data 19
MediaCentral | Production Management
  export to 448
  import sequence from 436
Memory Locations 881, 884
  creating 881, 882
  deleting 887
  editing 886
  extending selections to 636
  importing 425
  Markers 883
  recalling 885
  recalling Edit selections 523
  renaming 886
  Selection Memory Locations 884
  storing Edit selections 522
Memory Locations window 883, 885
  View Filter 890
  viewing options for Markers 888
Memory meter 103
Merge mode (see MIDI Merge mode)
metadata 20, 1333
Metadata Inspector window 178
meter
  current 866
default 498
display 197
Meter button 499
meter events 866
  editing 867
  inserting 866
meter map 425
Meter Ruler
  displaying 866
  extending an Edit selection to 867
Meter Type 228
Metering Preferences 120
metering, advanced 227
  Advanced Meter Type settings 122
  Digital VU option 121
  Fader and Meter scales 227
  Gain Reduction meter 228
  K options 121
  Linear (Extended) option 120
  Linear option 120
  Meter Type setting 228
  PPM options 121
  Pro Tools Classic option 120
  RMS option 120
  Sample Peak option 120
  VENUE options 121
  VU option 120
meters
  for MIDI tracks 224
  pre/post fader levels 224
  Sends View 1066
Meters and Faders View 1055
Metronome button 497
Metronome Click button 197
Mic Preamps
  configuring 139
  I/O Setup 55
Mic Preamps View 1053
MIDI 8
  assigning channels 255
  configuring MIDI setup 94
  consolidating notes 759
  controller events 764
  Default Thru Instrument 539
  editing in a MIDI Editor window 800
  import by drag and drop 414
  importing 412
  loop recording 549
muting notes 759
  offsets 778
  patch name files (.midnam) 773
  patch names 773
  playing back 474
  Retrospective Record 555
  select and split notes 1025
  separating notes 757
  setting the Grid value for editing 747
  setup (Mac) 143
  setup (Windows) 145
MIDI Beat Clock 489
  offsets 490
  transmitting 489
  transmitting over IAC 490
MIDI clips 587
  and Clips List 289
  and controller events 588
  and punch recording 549
  created on barlines 545
  guidelines for editing 587
MIDI controller devices 537
  Local Control 539
MIDI controller events
  chasing 777
MIDI Controllers 137
MIDI Editor
  Automation lanes 804
  Controller lanes 804
  editing MIDI notes 800
  Notation view 802
  Superimposed Notes View 798
  Velocity lane 804
MIDI Editor view (in the Edit window) 199
MIDI Editor windows 787
MIDI Event List 827
  deleting events 833
  editing events 832
  inserting events 830
  navigating in 829
  Options menu 834
  selecting events 832
  View Filter 828
MIDI File Format pop-up menu 415
MIDI files (see Standard MIDI Files)
MIDI Input Display 791
MIDI Input selector 222, 254
  Instrument track 256
MIDI Machine Control (MMC) 1283
  configuring in Pro Tools 1284, 1285
controlling external devices with 1283
Master settings 136
Slave settings 136
MIDI Merge mode 197, 503, 541
MIDI Merge Release mode 128, 542
MIDI meter 224
MIDI Note Color Shows Velocity option 107
MIDI Note Display options 128
MIDI notes 753
attributes 761
chasing 777
deleting 762
duplicating selected 913
editing 752
durations 1021
pitch 755
velocities 759, 1019
inserting 750
lengths in ticks 841
mini-keyboard 753
moving 755
quantizing 1012
scrolling 589
selecting 752
splitting 1025
transposing 755, 1023
trimming start/end points 756
MIDI Operations window 1005
MIDI Output selector 222, 255
Instrument track 256
MIDI Preferences 126
Global MIDI Playback Offset preference 778
Pencil Tool Resolution When Drawing
Controller Data option 128, 765, 1152
MIDI Preferences page 126
MIDI program changes
chasing 778
MIDI Real-Time Properties 780
on tracks and clips 784
settings 782
MIDI recording 537
canceling takes 547
enabling input devices 538
Input Filter 540
Merge/Replace mode 541
monitoring with MIDI Thru 539
quantizing on input 540, 1027
System Exclusive data 552
undoing a take 547
Wait for Note 540
MIDI Replace mode 197, 503, 541
MIDI Setup commands
Input Devices command 538
Input Filter command 540
MIDI Beat Clock command 489
MIDI Studio Setup (MSS) (Windows) 94, 145, 773
MIDI Thru command 539
MIDI Timecode (MTC)
Idle MTC Output 134
MIDI Track Offsets command 779
MIDI tracks
assigning to multiple channels 543
channel strips 217
Clips View 237, 238, 587
default program change 772
input 254
loop recording 549
note chasing 777
Notes View 237, 238, 589
output 255
punch recording 547, 548
recording 537, 542
selecting a pitch range in 1026
Sysex View 776
track controls 220
Velocity View 759
MIDI Volume fader 223
MIDI Zoom In button 604
MIDI Zoom Out button 604
midnight boundary 1318
mini-keyboard 589, 753
Minimize Additional I/O Latency option 93
Minimum Sync Delay option 130, 1286, 1308
Minutes:Seconds Time Scale 838
Mirror MIDI Editing 747
missing files 457
skipping 346
mix busses 1063
Mix Groups 282
Mix window 186, 187
All View option 186, 1052
EQ Curve view 1054
None Views option 1052
track controls 186
track width 230
Mix Window Follows Bank Selection option 117
Mix window View options 1052
Mix Window View selector 1052
Mix Window Views
Track Collaboration 383
mixed bit depths 168
mixed file types 168
mixing down to stereo 1197
Mixing Preferences 116
MMC (see MIDI Machine Control)
Modify Group command 280
Modify Groups command 280
Mojo DX 1355
Momentary Solo Latch option 258
monitoring
during punch recording 526
MIDI recording with MIDI Thru 539
monitoring modes 511
Auto Input 511
Input Only 511
Move Edit Down command 639
Move Edit Left command 637
Move Edit Right command 637
Move Edit Up command 639
Move Song Start command 868, 872
moving
Bar|Beat Markers 864
clicks with fades 685
fades 685
inserts 1102
Markers 887
MIDI notes 755
program changes 775
sysex events 776
MP3 file format 1191
importing 399
MTC (MIDI Timecode) 1274
MTC Generator Port setting 134
MTC Reader Port setting 134
MTRX 46
configuration 102
Multi-Cam Resolution files 429
multichannel clips 583
multichannel plug-ins 1215
multichannel tracks 517
and automation 1156
dragging clips to 665
names for 505
replacing clips in 904
splitting 664
multilingual application support 470
multi-mono
plug-in Channel selector 1216
plug-ins 1215
multi-mono audio files 156
multiple tracks
and Beat Detective 734
audition takes 531, 707
editing across 598
extending selections to 638, 640
fitting audio clips to Edit selection 667
nudging clips in 660
pasting to 598
selecting 638
separating clips on 655
shuffling clips on 899
Mute Audio Inputs in Auto Input option 576
Mute automation 1154
Mute button 258
Mute Overwrite/Extend 1170
Mute Record-Armed Tracks While Stopped option 111, 576
Mute/Unmute Clip command 909
muted clips and AudioSuite processing 936
muting
clips 909
MIDI notes 759
sends 1061
tracks 258
MXF format 399, 1192
My Contacts 362

N
Narrow Mix View option 230
navigating Workspace browsers 311
New Group (Groups List) command 280
New Memory Location dialog 522
New Paths dialog 68
New Session command 83
New Subpath dialog 69
New Track command 230, 246
New Track Default Output selector 59
New Tracks Are Shared option 129
New Tracks Default To Tick Timebase option 114, 410
Next Setting button (plug-ins) 1103
Nitris DX 1355
No Output option 1058
no scrolling during playback 480
noncontiguous selections 633
nondestructive editing (audio) 586
nondestructive editing (MIDI) 590
Nondestructive Record mode 501
nondestructive recording 526
recording to a new playlist 527
with QuickPunch 561
Non-Linear Transport Error Suppression option 130, 1308
non-real-time plug-ins 929
Normal Zoom mode 606, 806
Notation Display Track settings 816
Notation view 802
Note Chasing option 777
Note Selector tool 753
notes (see MIDI notes)
Notes View 237, 238, 589
Nudge value 660
trimming clips by 659
trimming MIDI notes by 757
nudging 659
by next Nudge value 661
clip contents 661
clips with fades 685
fades 685
multiple clips 660
selection range 635
selection start/end points 635
selections and clips 660
setting the Nudge value 660
Number of Voices setting 93
numeric entry
shortcuts 637
Numeric Keypad modes 28, 109
Classic 28, 109
Shuttle 29, 109, 626
Transport 29, 109
Use Separate Play and Stop Keys 109

Offline (faster-than-real-time) Bounce 1195
offline projects 159
offset
setting for video satellite start time 1400
OMF 438
embedded media 22
exporting 444
import translation settings 434
importing 426
linked media 23
media data 19
metadata 20, 1333
opening in Pro Tools 427
publishing options 447
Online (Transport window) 1302
Online button 194
online help 1403
Online options 111, 1308
online project 159
online recording 1282
On-Screen Selections 1318
on-the-fly punch recording
QuickPunch 503, 564
Open in New Workspace 317
Open Revision History 181
Open Session command 162
Open Unresourced DSP Plug-Ins as Native preference 126
Opening an AAF sequence in Pro Tools 427
Opening an OMF sequence in Pro Tools 427
opening plug-in windows 1105
Operation Preferences 108
Audio During Fast Forward/Rewind option 477
Clip Auto Fade In/Out Length preference 681
Edit Insertion Follows Scrub/Shuttle option 624
Link Record and Play Faders option 513
Machine Chases Memory Location option 1286
Machine Follows Edit Insertion/Scrub option 1286
Record Online option 1282
Use F11 for Wait for Note 541
Operation/Destination Track pop-up menus 422
Operations menu
Calibration Mode command 495
Link Timeline and Edit Selection option 629
Link Track and Edit Selection 234, 631
Low Latency Monitoring option 514
Options menu 211
Auto-Spot Clips command 1290
Delay Compensation option 1082
Destructive Record mode 527
Link Track and Edit Selection option 234, 631
Loop Playback option 485
Loop Record mode 529
MIDI Thru command 539
Mirror MIDI Editing command 747
Pre/Post Roll option 524
Pre-Fader Metering option 224
Scrolling options 480
Solo Latch options 258
Transport Online command 1281
Organize Plug-In Menus By option 106, 1099
Original Time Stamp 901, 1291
Other Playlists menu 692
Output Meter Path selector 58, 59
Output Options
  Sample Rate 1194
Output Path selector 222, 248
Output Window button 1227
Output windows 1057
outputs
  assigning multiple outputs 1057
default 5.1 paths and sub-paths 1205
  format and tracks 1213
to multichannel paths 1214
overlap crossfades 675
Overlap Shadows 591
overlapping paths 75
Overwrite Indicator 592

P
P (Playback Only volumes) 312
paddle device 1325
  configuring ports for 1325
  connecting to a Pro Tools system 1324
Page Scrolling option 480, 793, 812
Pan automation 1154
Pan Depth 1051
Pan indicator 223
Pan Odd Tracks Left/Even Tracks Right 435
Pan slider 223
panning
  3-knob 1231
  automation and groups 1156
  fine-adjust mode 1231
  grids 1226
  guidelines 1219, 1220
  Height 1251
  Height mode 1250
linked stereo 1071, 1230
multichannel automation playlists 1236
Size 1251
Speaker Snap 1251
take over in grid 1231
Theater mode 1249
trajectory 1232
Use Absolute Pan Linking option 116
X/Y mode 1231
Zones 1251
Parabolic command (Tempo Operations) 859
Parallel Task Optimization preference 126
Participant menu 369
pass-through point 1129
Paste command 596
Paste Settings command 1109
Paste Special commands (automation) 1159
pasting
  automation 1160
  multiple data types 598
  plug-in settings 1111
  selections and clips 596
to multiple tracks 598
  with Repeat to Fill Selection command 597
Patch Select button 772
Path Order selector 61
paths 50
  active and inactive 74
  audition 58
  creating 67
  creating multichannel 1206
  customizing 71
default mono and stereo 71
default order 60
default output 59
deleting 73
editing 71
for surround 1217
last used 83
main 50
mapping 74
multichannel example 75
overlapping 75
reordering 73
selecting 73
sub-path surround examples 1220
sub-paths 50
Peak Hold options 122, 225
Peak indicator 222
Peak view 584
PEC/Direct Style Input Monitoring option 111
Pencil tool 603, 626, 748
    as Eraser 762
drawing automation 1151
    editing breakpoints 1153
editing clip gain 944
editing Tempo 851
Free Hand 748
inserting MIDI notes 750
Line 749, 851
Random 749
repairing waveforms with 626
resolution for inserted controller events 765
selecting the Pencil tool shape 748
shapes 748, 1151
Square 749
Triangle 749
Pencil Tool Resolution When Drawing Controller
    Data option 128, 765, 1152
pending tasks 356
Performance Volume 309
Peripherals
    Atmos 142, 1239
    Ethernet controllers 138
    Machine Control 135
    MIDI Controllers 137
    PRE 139
    Satellites 140
    Synchronization 133
    VENUE 141
Peripherals dialog 133, 537
Peripherals list 98, 99
personalities 1091
PFL (Pre Fader Listen) 257
pitch (MIDI notes)
    transposing 755
Pitch Memory Enabled option 134
pitch shifting 991
pitch, for MIDI notes
    transposing with Transpose command 1023
Play button 195
Play Edit Selection command 482, 483
Play MIDI Notes When Editing option 745
Play Start Follows Timeline Selection option 108
Play Start Latency setting 113
Play Start Marker Follows Timeline Selection option
    487
Play Timeline Selection command 482, 483
playback
    audio 473
    MIDI 474
    no scrolling 480
    starting 473
    stopping 473
playback cursor 475
Playback Cursor locator 476
Playback Engine 90
    Cache Size 94
    Hardware Buffer Size 92
    Host Engine 92
    Number of Voices 93
    Sample Rate 94
Playback Engine setting 91
Playhead 481, 794
    and Edit selections 483
    and Timeline selections 483
    moving to clip boundaries 484
playing
    and making selections 633
    at half-speed 484
    audio 473
    Edit selections with Playhead enabled 483
    from a track point 477
    MIDI 474
    selections 481
    Timeline selections with Playhead enabled 483
    tracks 473, 518
Playlist lanes 697
Playlist selector 12, 691
playlists 12, 691
    adding 692
    and groups 693
    and multichannel tracks 1156
    and nondestructive MIDI editing 590
    assigning 692
    automation playlists 691, 1126, 1135
    auto-naming 691
    changing timebase of 843
    deleting 693
    duplicating 692
    edit playlists 691
    Playlist selector 691
    recalling 692
    recording to new 528
    renaming 693
    setting pre/post-roll in 524
    Target 711
Playlists view 697
plug-in controls
    adjusting 1106
Index 1443

linking 1121
Plug-In Controls Default to Auto-Enabled option 118
plug-in inserts 1093
plug-in maps 1114
creating 1116
deleting 1117
importing and exporting 1119
Learn mode 1114
managing 1117
setting default 1118
Plug-In selector
for AudioSuite plug-ins 930
for real-time plug-ins 1103
plug-in settings 1110
Plug-In Settings menu 1103, 1109
Plug-In Settings Select button 1103
plug-in windows
opening and closing 1105
Plug-ins
searching for 1100
plug-ins
and pull rates 1281
and surround mixing 1215
automating 1141
bypassing from window 1119
Category 1099
Category and Manufacturer 1100
Channel selector for multi-mono 1216
creating a default setting 1111
enabling for automation 1107, 1142, 1143
favorites 1101
Flat List 1099
for surround 1215
inserting on tracks 1097
Librarian menu 1103
linking and unlinking 1121, 1216
Manufacturer 1099
mono-to-stereo 1094
multichannel 1094
multi-mono 1094, 1215
Next Setting button 1103
Organize Plug-In Menus By command 1099
Plug-In Settings menu 1103
Plug-In Settings Select button 1103
presets 1109
Previous Setting button 1103
removing from tracks 1097
post crossfades 670, 680
Post-Roll button 196
Power view 584
PRE 47
configuring 139
I/O Setup 55
pre crossfades 670, 680
Pre Fader Listen (PFL) mode 257
PRE settings 426
Pre/Post Fader button 1072
Pre/Post Roll option 524
pre/post-fader inserts 1093
pre/post-roll
and loop recording 528
and punch recording 525
auditioning 482
setting 523
Pre/Post-Roll Flags 524, 630
Pre-Fader Metering option 224
preferences
Automatically Copy Files on Import option 418
changing 105
DestructivePunch 563
DestructivePunch File Length 571
global 131
local 131
Mute Audio Inputs in Auto Input 576
Mute Record-Armed Tracks While Stopped 576
Pause during Playback 357
Project Media Cache setting 110
Remote mode 1322
Tool Tips Display 212
TrackInput 513
TrackPunch 563
Zoom Toggle 115
Preferences dialog 105
Prepare DPE Tracks command 571
Pre-Process using Standard Conform 737
pre-roll
compensating 1306
machine 1306
setting for machine from Pro Tools 1306
Pre-Roll button 196
Preserve Fades when Editing option 115
Preserve Folder Hierarchy command 170
presets
plug-in maps 1114
plug-ins 1109
Prevent Tearing option 113
preview
AudioSuite processing 934
in context 343
reserving voices 343
voice requirements 343

Preview Volume
AudioSuite 934

previewing
audio in browsers 339
clips in the Clips List 295

Previous Setting button (plug-ins) 1103
Prime for Playback mode (Play Pause) 484
Prime for Record mode (Record Pause) 520
Print Score 826

Pro Tools
Audio Pull Up and Pull Down 1405
Check For Updates 211
Clock Reference setting 1405
Drop Frame setting 1405
file management 455
Help 211
Knowledge Base 211
link controls 1411
displaying 1412
linking and unlinking systems 1412
main menus 210
Non-Drop Frame setting 1405
session file 157
session file icon 9
Session Start setting 1405
systems 37
Timecode Rate setting 1405
Transport Master 1303, 1313
Video Format setting 1405
Video Satellite 1403
Video Satellite settings 1405
video track 1359
Web browsers 200

Pro Tools | MTRX 46
Pro Tools | S6 1089
Pro Tools and Avid terms 21

Pro Tools application language 470

Pro Tools Help command 202

Pro Tools Knowledge Base command 202

Pro Tools menu
Quit command (Mac) 183

Pro Tools Online browser 202

Pro Tools software capabilities 37

Pro Tools systems
QuickPunch 560

Pro Tools Ultimate
capabilities with HD Native hardware 40
capabilities with HDX hardware 39

Process Mode selector 932
processing
AudioSuite 935
multichannel for AudioSuite 935
processing bandwidth 102
Processing Preferences 124
Program Change dialog 772, 774
program changes 772
and bank select 772
auditioning 775
default, for MIDI tracks 772
deleting 775
delaying 775
inserting 775
moving 775
project
chat controls 364
opening from Artist Chat 366
save as a session 176

Project Media Cache 110
project messages
filtering 370
Project Notes window 179
Project Notifications 366
project ownership 379
Project Type (Media Composer) 1405
projects 15, 158
deleting 180
leaving 372
moving to History 373
offline 159
online 159
putting online 182
renaming 179
restore from cloud 181
sharing 377
sharing offline 459
taking offline 182

Projects list 366
pinning items 371
unpinning items 371

Projects tab 154
pull up and pull down 1277, 1281
pulses-per-frame
Bi-Phase/Tach 135
Punch Capture button 1178
Punch In Frame Offset 1322
Punch In Frame Offset preference 131
Punch In/Out 1317
Punch Out Frame Offset 1322
Punch Out Frame Offset preference 131
punch points 520
  Timeline Selection Markers 521
Punch Preview button 1177
punch recording
  and monitoring 526
  and pre/post-roll 525
audio 525
MIDI 547
MIDI tracks 548

Q
Quantize
  audio clips 1008, 1017
  Elastic Audio events 1008, 1016
  quantizing clips to grid 663
  Real-Time Properties 782
Quantize Clips to Grid command 901
Quantize command 1005, 1006
Quantize Edits to Frame Boundaries option 444
Quantize to Grid command 663
Quantize window 1009
quantizing
  MIDI notes 1008, 1012
  MIDI on input 540, 1027
QuickPunch 503, 560, 564
  clip/take numbering 562
  crossfades 562
  Pro Tools HD systems 560
QuickPunch Crossfade Length preference 115, 562
QuickTime file formats 1192
QuickTime movies
  importing audio from 1370
  optimizing for playback 1380
  requirements 1356
  sync 1380
Quit command (Mac) 183

R
R (Record and Playback volumes) 312
randomizing
  note durations 1023
  note locations 1009
Read automation mode 1128
Read Trim automation mode 1132
real-time plug-ins 1093
Real-Time Properties
  clearing 786
  clip-based 785
  Delay 784
  Display Events as Modified by Real-Time Properties option 127
  Duration 783
  enabling 781
  in the Edit window 786
  in the MIDI Event List 786
  on tracks and clips 784
  Quantize 782
  settings 782
  track-based 785
  Transpose 784
  Velocity 784
  View 780
  viewing 780
  writing to clips 785
  writing to tracks 785
Real-Time Properties View 780, 1055
Real-Time Properties window 781
Rear Divergence 1233
Recalculate Waveform Overviews command 301
Recall Memory Location Selection at Original Track option 114
Recent tab 154
Record button (Transport) 195
Record Enable button 506, 566
record modes 501, 1318
  and MIDI 503
  Destructive Record mode 502
  Loop Record mode 502
  Nondestructive Record mode 501
  QuickPunch 503
Record Online at Insertion/Selection option 112, 1308
Record Online at Timecode (or ADAT) Lock option 111, 1308
Record Online option 1282
record protocol 1317
Auto Edit 1317
Punch In/Out 1317
Record Safe mode 508
recording 517
  a mono audio track 517
  a stereo audio track 517
  a submix to disk 1187
  additional takes 526
  at half-speed 535
  bouncing to disk 1188
  canceling takes 519
  destructively 527
from a digital source 533
from Record Pause mode 520
Instrument tracks 542
keyboard shortcuts 519
Loop Record 529
MIDI clips 545
MIDI tracks 542
multichannel tracks 517
multiple audio tracks 519
nondestructively 526
online 1282
QuickPunch mode 564
record enabling tracks 506
Remote mode 1323
status LED 566
System Exclusive data 552
to a new playlist 528
to the system volume 511
undoing a take 518
with a count off 497
with Round Robin Allocation 510
with the click 496
Rectified view 584
ReCycle 399
Redefine Current Timecode Position 1311
redefining
  Feet+Frames position 1276
timecode position 1276
Redo command 593
Ref Present indicator 1273
Refer to Source Audio Media Where Possible 431
Refer To Source Media 446
refresh rate 1402
Regenerate Missing Rendered Files 457
Regroup Clip command 921
regular expressions 304
related takes
  and Separate Clip command 655
Relative Grid mode 601, 902
relinking
  Find Links 349
  Linking Options 349
Remote 9-Pin Deck Emulation mode 1300
  Chase LTC 1321
  connections 1299
  preferences 1322
  see also Remote mode
Remote LTC mode
  Transport Master 1304, 1321
Remote mode
  and track arming 1323
  Auto Edit 1323
  commands 1324
  playback 1323
  recording 1323
  Transport Master 1304, 1321
Remote Mode options 130
Remove Duplicate Notes command 780
Remove Edit From Bottom command 639
Remove Edit From Top command 639
Remove Local Cache 180
Remove Sync Point command 906
removing
crossfades 679
plug-ins from tracks 1097
sends 1060
Rename command (Clips List) 297, 300
Rename Track command 246
Renamed Audio Files
  save copy in 458
renaming
  auto-created clips 296
  clips in the Clips List 297
  clips on tracks 590
  Memory Locations 886
  playlists 693
renaming project versions 173
Render Clip Effects command 952
Render Clip Effects settings 952
Render Clip Gain command 948
Rendered File Bit Depth options 125, 999
Rendered Files folder 157, 975
Renumber Bars command 873
Repeat command 914
Repeat to Fill Selection command 597
repeating selections and clips 914
Replace Clip command 300, 903
  and multichannel tracks 904
  Replace Clip dialog 904
Replace mode (see MIDI Replace mode)
Reserve Voices For Preview In Context option 108, 343
Reset Bi-Phase button 135
Restore Performance command 1005, 1018
Restore version 173
rests (Score Editor) 822
Retrospective Record 555
Return to Zero button 194
Reveal in Explorer command (Windows) 301
Reveal in Finder command (Mac) 301
Index

Reveal in Finder/Explorer 317
Reveal in Workspace command 301
Revert to Saved command 165
Revision History 171
  Restore 173
  Version List 172
Rewind 477
Rewind button 194
REX files 399
importing 406
RF64 audio file format 459
Root Settings folder 677, 1109, 1110
Round Robin Allocation 510
Ruler View options 839
  Bars|Beats Time Scale 837
  Feet+Frames Time Scale 838
  Minutes:Seconds Time Scale 838
  Samples Time Scale 838
  Timecode Time Scale 838
Ruler View selector 839
rulers
  changing display order 839
  Conductor rulers 838
  displaying all 839
  pull up and pull down 1281
  scrolling in 644
  Timebase rulers 837
  zooming in 607

S
S6 1089
safing automation 1134
Sample Offset (Sync Offset) 1274, 1311
Sample Rate Conversion options 421, 433, 445
Sample Rate Conversion Quality 125, 399, 409, 434, 446, 1371
Sample Rate Convert Audio 433
Sample Rate setting 1194
  Hardware Setup dialog 97
  Playback Engine dialog 94
sample-based timing 841, 884
Samples Time Scale 838
Satellite Link
  option 140
  preferences 131
Satellites 140
Save As command 166
Save command 165
Save Copy In command 166, 461
Save History 172
Save Track Preset dialog 264
  saving a copy of a session 166
  saving Fades settings
    Save Settings As command 677
    Save Settings command 677
  saving plug-in settings 1110
    Save fade settings to command 677
    Save Plug-In Settings To command 1110
    Save Settings As command 1109
    Save Settings command 1109
  saving sessions with a new name 166
  Scale command (Tempo Operations) 861
  scaling note velocities 760, 1020
Score Editor
  chord symbols and diagrams 824
  editing in 819
  exporting a score 826
  opening 806
  page controls 814
  printing 826
  rests 822
  zoom controls 815
Score Setup window 817
Scroll Into View command 235, 245
Scroll to Track Banks Controllers option 117
Scroll To Track command 645
Scroll To Track dialog 234
scroll wheel
  and MIDI track Note display 589, 612
  scrolling a Pro Tools window 645
  zooming in the Edit window 612
  zooming in the Edit windows 612
scrolling
  a track into view 235
  in the ruler 644
  MIDI Notes View 589
  Mix and Edit windows to tracks 645
  Notes View up or down 612
  Pro Tools window vertically or horizontally 645
Scrolling options 480
  After Playback 480
  Center Playhead 481
  Continuous Scrolling During Playback 481
  No Scrolling 480
  Page 480, 793, 812
Scrub Trim tool 616
Scrubber tool 603, 623
  in Shuttle mode 624
  selecting with 640
scrubbing 623
a single audio track 624
and edit cursor 624
on two audio tracks 624
playback speed and direction 624
resolution 624
video tracks 1376
with Scrub Trim tool 616
with the Selector 624
S-Curve command (Tempo Operations) 860
SDDS surround formats 1202
Search
and assign multiple Send paths 1061
Plug-in Insert menu 1100
Send selector 1060
tags 333
Track Input selector 249
Track Output and assign multiple paths 250
Track Output selector 249
search mode 1314
Secondary Timecode Ruler 838
Select All command 632
Select Clips List options 294
Select Parent in Workspace option 293
Select Tracks in Group command 280
Select Unused Clips command 300
Select/Split Notes command 1005, 1025, 1026
  Split notes action 1026
selecting
  a pitch range of notes 1026
  across all tracks 638
  across multiple tracks 638
  clips 632
during playback 633
in MIDI Event List 832
items in browsers 323
MIDI notes 752, 753
noncontiguous clips 633
notes in a chord 1027
track material 631
with Edit Selection indicators 637
with Scrubber 640
selecting tracks for AudioSuite processing 937
Selection Changes Alternate Playlists option 843
Selection commands
  Play Edit Selection 482
  Play Timeline 482
Selection Memory Location 884
  moving stored selection 886
selections
  across multiple tracks 632, 638
and Bounce to Disk 1189
and Edit Groups 631
and hidden tracks 631
and Timeline Selection Markers 631
auditioning start and end points 482
changing length 635
clearing 597
consolidating 665
copying 595
cutting 595
duplicating 913
during playback 633
extending 636, 854
extending to the Meter Ruler 867
extending to the Tempo ruler 846, 888
including Conductor rulers 638
looping 485
moving to adjacent tracks 639
moving to the next/previous clip 640
non-contiguous 633
nudging 635, 660
nudging start/end points 635
Object 633
pasting 596
playing 481
repeating 914
shifting 907
storing with Memory Locations 884
Selector tool 476, 603, 619
  making a Timeline selection 620
  making an Edit selection 620
  placing the edit cursor 619
  scrubbing with 624
  selecting an entire clip 620
  selecting an entire track 620
  selecting MIDI notes with 752
Send fully overlapped clips to playlist while editing
  option 114
Send fully overlapped clips to playlist while recording option 114
Send level 1059
Send mute 1059
Send pan 1059
Send Pans Default to Follow Main Pan option 116
Send to Back command (Clip menu) 849
Send To Sibelius command 826
Sends
  Pre/Post-fader indicators 1068
  searching paths 1060
sends 1058
adding 1059
and multichannel mixing 1214
Assignments View 1064
automating 1140
changing default setting 1060
copying track automation to 1141
default level 1059
displaying controls for 1066
for hardware I/O 1063
for mix busses 1063
labeling 1121
mono or stereo 1063
multichannel 1214
removing 1060
view options 1064
Sends Default to -INF option 116
Sends View 1054
Separate Clip commands 654
and multiple tracks 655
and related takes 655
At Selection 654
At Transients 654
On Grid 654
Separate Clip Operates On All Related Takes option 114, 655
Separate MIDI notes 757
Separation Grabber tool 620, 655
Serial Deck Control mode 1300
serial timecode 1307
servo lock 1306
session
save as a project 175
session data
importing 416
Session Data Online Status indicator 190
Session Data to Import menu 422
session file 157
Session File Backups folder 158
Session Length 1271
session parameters 168
Session Setup
Session Length 1271
Session Setup window 1269
Session Start setting 1405
sessions 9
audio format 1271
backups 109, 158
bit depth 155, 1270
closing 179
creating for surround mixing 1203
files 9
frame rate 1271
interleaved 156, 1271
interleaved multichannel audio files 156
mixed audio formats 156, 168
mixed bit depths 168
multi-mono audio files 156
opening 162
opening from a Transfer volume 163
opening Pro Tools | Ultimate sessions in Pro Tools 462
sample rate 155, 1270
sharing between different versions 463
sharing between Pro Tools | Ultimate and Pro Tools 462
start frame 1271
templates 176
Set As User Default command 1109
Set Plug-In Default To command 1109
Set Record Tracks to Auto Input command 513
Set Record Tracks to Auto Input option 512
Set Record Tracks to Input Only command 513
Set Record Tracks to Input Only option 512
Set Servo Lock Bit at Play option 130
setting
punch/loop points 520
satellite start time offset 1400
settings
choosing a destination for 1110
copying 1111
creating 1111
creating subfolders 1110
pasting 1111
saving 1110
Settings Preferences command 1109
Setup menu 211
Click/Countoff Options dialog 498
Disk Allocation 509
I/O Setup 50
MIDI Studio 773
Preferences command 105
Session Setup 1269
Video Sync Offset command 1380
Share Track control 384
Shared as Frozen option 386
Shared track, unowned 387
Shared Tracks Conflict 174
Shift command 907
shortcuts for keyboard input 1106
Show All Tracks Group command 281
Show Artist Chat button 380
Show Auto-Created option 299
Show Offline Volumes 316
Show Only Tracks in Group command 280
Show/Hide Clips List button 289
Show/Hide Tracks in Group command 280
Show/Hide Tracks List/Groups List View button 243, 279
Shuffle Lock mode 600
Shuffle mode 599
   and locked clips 908
   and moving clips 898
shuttle
   fixed mode option 625
Shuttle Numeric Keypad mode 29, 109, 626
Sibelius (.sib) file 826
Side % (Percentage) 1233
side-chain 1107
   filters 1107
   processing 1103
signal flow
   audio tracks 1042
   Auxiliary Inputs 1043
   Instrument tracks 1046
   Master Faders 1044
signal paths 50
signal routing
   and default path order 60
   basics for surround 1214
   example 14
   surround examples 1220
Single Zoom mode 607, 807
SIP (Solo In Place) 256
Size setting (for window dub) 135
Skip All 457
slices 720
Slip mode 600
   and moving clips 899
Smart Tool 603, 621
   adjusting fades with 622
   creating crossfades with 622
   creating fades with 621
   editing automation 623
   editing controller events with 623
   Elastic Audio tracks 622
   MIDI tracks 622
   multichannel tracks 623
Smart Tool Fade Adjustment 115
Smooth and Thin Data After Pass option 118, 1151
smoothing automation 1133

SMPTE
   configuration 1275
   start frame (sessions) 1271
SMPTE IDs 456
Snap Pan to Speaker icons 1230
Snap To Bar option 866
Snap To commands 897
Snap To Grid 601
snapping to the following or preceding clip 897
snapshot automation 1172
   adding to empty automation playlists 1173
   and trim values 1175
   writing over existing automation 1173
Solo button 256
Solo in Place (SIP) mode 256
Solo Latch options 258
Solo modes 256, 257
Solo Safe mode 258
soloing
   tracks 256
   tracks in a submix 1081
Song Start Marker 843
   editing tempo 844
   moving 844
Sony Dynamic Digital Sound (SDDS) 1202
Sort By options 291
sorting
   clips 291
   data in browsers 319
   Markers 889
Sound Libraries 307
   adding 332
   removing 332
Soundbase
   Assign Tags popover window 336
   excluding tags from search 334
   searching tags 333
   Sound Libraries 307
Source Audio Sample Rate 433, 446
source media 431, 446
Source Path 1190
Spacebar Toggles File Preview 316
Special Paste 1160
Speed Cal indicator 1273
split (MIDI) 1025
Split Into Mono Track command 246, 664, 1212
split mono audio files 156
Split notes action 1026
splitting stereo and multichannel tracks 664
Spot dialog 900, 1288
Index

Use Subframes option 1288
User Time Stamp button 1290
Spot mode 600, 1287
and moving clips 900
trimming clips in 1290
Spot To Edit Insertion 317
spotting
auto-spotting 1290
clicks 900, 1287, 1289
SRC (Sample Rate Conversion) options 421
Standard MIDI Files 412
exporting 414
importing 412
Standard VCA Logic for Group Attributes option 118
start frame (sessions) 1271
start time 1310
start time for Media Composer sequences 1410
Start To Insertion command 657
Start, End, and Length display 521
Starting TC Timecode setting
matching to Session Start setting 1405
Step Input command 1005, 1028
stepped control automation 1154
stereo interleaved files, exporting 411
stereo tracks
dragging clips to 665
names for 505
replacing clips in 904
splitting 664
Stop at Shuttle Speed Zero option 130, 1308
Stop button 195
Stretch command (Tempo Operations) 862
Strip Silence command 909, 910, 911
stuck notes 780
stutter 1402
Sub Counter selectors 840
Sub Time Scale 840, 1277
subfolders, creating for settings 1110
subframes 1288
submixes
applying an insert to 1078
bouncing to disk 1187
soloing tracks in 1081
sub-paths 50, 69
examples for surround 1218
Suppress Automation “Write To” Warnings option
118
surround
5.1 format paths 1208
and sends 1214
basic signal routing 1214
center percentage (%) 1234
configuring Pro Tools 1203, 1211
discrete level, solo, mute 1212
importing I/O Settings 1206
pan playlists and automation 1236
panning grids 1226
settings files 1204
side center percentage (%) 1235
using paths 1217
using sub-paths, examples 1218
Suspend All Groups (Groups List) command 280
suspending
automation 1147, 1148
writing automation 1147
swing 1009, 1011
Sync Offset 1274, 1311
SYNC peripherals
generating timecode with 1282
resolving with 1267
sync options 1268
Sync Point View option 906
sync points 1292
for clips 905
from Beat Detective 738
identifying 906, 1292
synchronization 133
black burst 1292
MIDI Beat Clock 489
MMC 1283
options 1267
resolving 1292
troubleshooting 1292, 1403, 1405
Synchronization Device settings 134
synchronization peripherals 47
Synchronization Preferences 129
Sysex View 776
System Exclusive data 776
deleting 777
moving 776
recording 552
system resources 17
system settings
Cache Size 94
Clock Source system setting 97
Hardware Buffer Size 90, 92
Hardware Setup 97
Host Engine 92
Number of Voices 93
Playback Engine 91
Sample Rate 94
System Usage window 102, 104

T
T (Transfer volumes) 312
Tab to Transients button 479, 641
Tags
adding 335
Assign Tags popover window 336
editing 335
excluding from search 334
searching 333
take over (surround pan) 1231
takes
auditioning 530
default names 504
matching alternates 530, 706
MIDI 552
multiple tracks 531, 707
numbering for QuickPunch 562
recording additional 526
selecting an alternate take 530, 706
Tandem Trimming option 619
tapping in the tempo 500
Target button (plug-ins) 1104
Target playlist 711
Target Project Timecode Format 444
Task 190
Task Manager 354, 405
Task Manager Status indicator 190
tasks
failed 356
grouped 357
paused 355
pausing during playback 357
pending 356
TC/E Plug-In preference 125, 615
TCE Edit to Timeline command 666
TCE Trim tool 614, 615, 616
templates
Beat Detective 731
DigiGroove 731
Pro Tools session 176
tempo
current 844
default 499
display 197
effects on Markers and Memory Locations 884
Manual Tempo mode 500
selecting in 500
Tempo Edit Density pop-up menu 852
Tempo Editor 850
Tempo Event Warp markers 848
Tempo Event–generated Warp markers 981
tempo events 844
and Bar|Beat Markers 864
displaying 845
extending selections to 854
inserting 845
tempo map 425
from Identify Beat command 863
Tempo Operations commands
Constant command 858
Linear command 858
Parabolic command 859
Scale command 861
S-Curve command 860
Stretch command 862
Tempo Operations window 857
Tempo Resolution selector 851
Tempo ruler
displaying 844
extending an Edit selection to 846, 888
Tempo Ruler Enable button 197
Theater mode 1249
Thin All Automation command 1151
Thin Automation command 1151
Thinning automation 1134, 1150
tick-based timing 841, 884
Time Compression/Expansion plug-in 666
Time Compression/Expansion Trim tool 125, 614
trimming MIDI 762
Time Grabber tool 620, 634
Time Operations commands 868
Change Meter command 868
Cut Time command 871
Insert Time command 870
Move Song Start command 872
Time Operations window 866, 868
Time Scale 839
Bars|Beats 837
Feet+Frames 838
Main 840, 1277
Minutes:Seconds 838
Samples 838
Sub 840, 1277
Timecode 838
Time Slots meter 104
Time Stamp command 300, 531, 707, 1291
Time Stamp Selected command 901
time stamps 447, 1290
  Bounce to Disk 1189
Timebase rulers 837
  and Timeline selections 642
  Edit Markers 630
  Pre/Post-Roll Flags 630
  sliding Edit selections 641
  sliding Timeline selections 643
  Timecode 2 838
  Timeline Selection Markers 630
timecode 1405
  and Jam Sync 1274
  and Pro Tools Drop Frame limitations 1409
  capturing 1289
  compensating for start time offsets 1400, 1410
  forcing a match on a satellite system 1409
  freewheeling 1274
  generating 1282
  matching between Pro Tools/satellite 1410
  matching format for 1409
  quick signal test 1310
  redefine current 1311
  redefining position 1276
  track 1318
  Timecode 2 Rate setting 1271
  Timecode 2 ruler 838
  Timecode Format 1405
  Timecode Mapping options 421
    on import 432
  Timecode Rate setting 1271, 1405
  Timecode Time Scale 838
  Timeline and Edit selection, unlinked 629
  Timeline Data Online Status indicator 190
  Timeline Drop Order option 892
  Timeline Insertion/Play Start Marker Follows
    Playback option 480, 487
  Timeline Selection Markers 521, 630
    and Edit selections 631
    selection length 635
    Timeline selections 643
  Timeline selections 642
    auditioning with Playhead enabled 483
    copied from Edit selection 644
    copied to Edit selection 643
    in Timebase rulers 642
    making with the Selector tool 620
    sliding in the Ruler 643
    start, end, and length fields 196
    Timeline Selection Markers 643
  Time-locking clips 908
toggling
  track height 241
  Track View 240
  Tool Tips 105, 212
  Toolbar focus 28
  Touch automation mode 1129
  Touch Timeout option 117
  Touch Trim automation mode 1132
  Touch/Latch automation mode 1131
  Track and Master Meter Types Linked option 120
  track arming
    112-track IDs 1328
    and Remote mode 1323
    create machine profile 1316
    IDs 1327
    ignore 1324
    remapping tracks 1317
  Track Bounce 1003
  Track Bounce dialog 1004
  Track Collaboration controls 384
  Track Collaboration tools 379
  Track Color View 1056
  Track Commit 995
  Track Compensation (cmp) indicator 1084
  track compositing 694
  track controls
    audio tracks 219
    Auxiliary Input tracks 219
    Edit window 219, 220, 221
    Elastic Audio 972
    Instrument tracks 221
    Master Fader tracks 219
    MIDI tracks 220
    VCA Master tracks 220
    video tracks 221
  track data 582
  Track Freeze 1000
  Track Height 240
    resizing 241
  track layout
    default path order 60
  track level meters 224
  Track menu 211
    Clear All Clip Indicators command 225, 1066
    Delete command 235
    Duplicate command 236, 1128
    Group command 282
    Make Inactive command 259
    New Track command 230
    Scroll to Track command 645
Set Record Tracks to Auto Input 512, 513
Set Record Tracks to Input Only 512, 513
Split Into Mono command 664, 1212
Write MIDI Real-Time Properties command 785

Track Name commands 245
Track Name/Comments dialog 232
Track Number command 233, 645
Track Offset options 421, 433

track ownership
rejecting a request for 390
rejecting request 390
relinquishing 388, 390
requesting 388
rescinding 388
responding to a request 388, 389
seizing 388

Track Ownership control 387, 389
Track Ownership Request indicator 381, 389
Track Position Numbers Stay with Hidden Tracks option 105

Track Presets 263
creating 263
in Workspace browsers 273
saving 263

Track Presets files (.ptxp) 268
Track Record Enable indicator 195
Track selector 1103

Track View 236
Blocks 237
changing 239
Clips 237, 238, 587
edit content 594
Master View 1158
Notes 237, 238, 589
Playlists 697
Sysex 776
toggling 240
Velocity 759
Waveform 583

Track View selector 238
Track View Toggle 240
track width 230
TrackInput Monitor button 512
TrackInput Monitor indicator 196
TrackPunch
crossfades 562
preferences 563
tracks 10
5.1 format track layout 1211

adding comments 233
adding to selection 638, 640
appending new material to end of 527
Color Coding options 259
commit 995
conflicts between track and cloud copies 390
converting multichannel tracks into mono tracks 1212
creating a click track 496
creating new Elastic Audio tracks 971
deleting 235
duplicating 236, 1128
Elastic Audio 970
formats 214
freeze 1000
grouping 277
hiding 244
locating with Fast Forward/Rewind 477
making inactive/active 259
Master View 240, 1158
metering 224
moving selections between 639
muting 258
names 230, 232
placing clips in 891
playback priority 253
playing 473, 518
record enabling 506
remapping 1317
scrolling shortcut 645
selecting across multiple 638
selecting clips 632
selecting in Timebase rulers 638
selecting material in 631
soloing 256
surround 1211
Track Height 240
Track View 236, 239
transposing 1023
trimming unwanted data from 657
types 213
video 1357

Tracks (Groups List) command 280
Tracks List 242
Cloud icon 391
hiding 243
menu 243
showing 243

Tracks List Right-click menu
Download 245
Ignore for Future Download 245
Import 245
Tracks Presets
  creating new tracks from 268
  trajectory panning 1232
Transfer files 456
  selecting in Workspace 317
Transfer volume 309
transients 583
  detecting with Beat Detective 724
  tabbing to 479, 641
Transparency 591
  transparent clip overlays 895
Transport 194
  Count Off 497
  Meter 499
  Metronome 497
Transport Master 1286, 1301, 1303, 1313
  machine 1303, 1313
  Pro Tools 1303, 1313
  Remote 1304, 1321
  Remote LTC 1304, 1321
  selecting 1303
  toggling 1304
transport master 1313
  Remote LTC 1321
  toggling 1314
Transport Numeric Keypad mode 29, 109
Transport Online option 1281
Transport RecordLock option 111, 563, 575
Transport View options 196, 475, 522, 523
Transport window 194
  MIDI controls 196
  pre/post-roll 196, 523
  record status display 566
  start, end, and length fields 196, 521
  transport controls 194
Transpose
  Elastic Audio 991
  MIDI notes 1023
  Real-Time Properties 784
Transpose command 1005, 1023
transposing 1023
  by octave 1024
  key 1024
  MIDI notes 755
  tracks 1023
Trim automation
  coalescing 1163
Trim Automation commands 1175
  Trim to All Enabled 1175
  Trim to Current 1175
Trim Clip commands
  End to Fill Selection 658
  End to Insertion 657
  Start to Fill Selection 658
  Start to Insertion 657
  To File 659
  To Fill Selection 658
  To Selection 657
Trim Clip to File Boundaries command 659
Trim Clip to File End command 659
Trim Clip to File Start command 659
Trim to All Enabled Automation command 1175
Trim to Current Automation command 1175
Trim tool
  when Transport = Machine 1304, 1313
trim tool
  tandem trimming 619
Trim tools 603, 613
  Loop Trim tool 617
  Scrub Trim tool 616
  Time Compression/Expansion Trim tool 125, 614, 762
  trimming automation 854, 1153
  trimming clip gain 945
trimming
  automation breakpoints 854, 1153, 1162
  clip gain breakpoints 945
  clip start/end points 613
  clips by Nudge value 659, 757
  clips to Edit insertion point 657
  clips with Scrub Trim tool 616
crossfades 680
  note start/end points 756
  unwanted clip and track data 657
Tweak Head setting (Conversion Quality) 1371
U
  unavailable resources 163
Undo command 518, 593
Undo History window 593
Undo Queue 593
Ungroup All Clips command 921
Ungroup Clips command 921
Unicode language support 469
Unique ID 431, 456
Universe view 646
unlinked Timeline and Edit selection 629
unlinking plug-in controls 1121, 1216
Unlock Clip command 907
Unlock Clips command 917
Upload All New Changes button 381
Upload command 385
Upload Ruler Changes control 392
Upload Ruler Changes Right-click menu 393
Upload Track Changes control 385
Use Absolute Pan Linking option 116
Use F11 for Wait for Note option 127, 541
Use MIDI to Tap Tempo option 127
Use Separate Play and Stop Keys option 109
Use Subframes option 1288
User Default setting 1111
User Offset (+/–) field 1084
User Time Stamp 901, 1291
user-defined clips 296, 299, 582

V

VCA Masters
assigning groups 1049
channel strips 217
clearing 1181
controls 1048
deleting 1182
displaying automation 1180
mixing 1047
track controls 220
track type 213, 1047

velocities (MIDI)
drawing with Pencil 760
editing 759, 1019
fading 1019
Real-Time Properties 784
scaling 760, 1020
Velocity Trim tool 760
Velocity View 759
VENUE 141
VENUE Link 48, 141
version conflicts 173
Version List 172
Vertical Position setting 135
video
importing 1367
Pillarbox/Letterbox option 1376
playback 1402
Stretch option 1375
Video Clip Groups 1374
video clips 1371
Video Engine option 94
video engine rate 1366

Video Engine Rate indicator 1367
Video Format setting 1405
Video Import Options dialog 1369
Video Media options 420
Video Online button 1358, 1360
Video Pull Up and Pull Down 1277
Video Satellite
avoiding sync issues 1405
connecting 1403
Media Composer 140, 1401
quitting Pro Tools 1404
settings 1405
troubleshooting satellite connections 1404
video satellite offset 1400
video stutter 1402
Video Sync Offset command 1380
video track 1318
video tracks 214, 1357
locking 1366
main video track 1358
Output Settings 1362
Project Type 1360
scrubbing 1376
settings 1360
shuttling 1376
track controls 221
Video Quality 1365
viewing as blocks 1359
Video Universe window 1377
Video window 1375
mixed aspect ratios 1375
Video Window command 1375
View Filter (Memory Locations window) 890
View Filter (MIDI Event List) 828
View menu 210
Clip Name View option 591
Clip Sync Point View option 906
Clip Time View options 591
Edit window View options 188, 1052
Mix window View options 186, 1052
Narrow Mix View option 230
Track Number command 233, 645
Transport View options 196, 475, 522, 523
viewing blocks in the video track 1359
views
Delay Compensation 230
I/O View 222
Inserts View 1053
Sends View 1054
Wide Meters View 226
VITC
Generate Lines setting 134
Read Lines setting 134
Read Lines, defaults 134
VITC Insertion Enabled option 134
Voice selector 253
voices 560
and track priority 253
Voices meter 104
volume
  Performance 309
  Transfer 309
Volume automation 1154
Volume fader 223
Volume indicator 222
Volume permissions 312

W
Wait for Note 197, 540
Warp indicator 984
Warp markers 979
  adding 980
  deleting 980
  relocating (without applying warping) 980
Warp view 972, 979
warped clips (Elastic Audio) 583
warping audio (Elastic Audio) 981
WAV file format 458, 1191
  AES31/Broadcast compliant 458
WAVE Extensible file format 459
WaveCache 338
WaveCache.wfm file 158, 309
Waveform View 583
Waveform View options 584
  Outlines 585
  Peak 584
  Power 584
  Rectified 584
waveforms 583
  and zero-crossing 586
  avoiding clicks and pops 586
  guidelines for editing 586
  repairing with Pencil tool 626
  WaveCache 338
  Workspace 337
Whole File button (AudioSuite) 935
whole-file clips 582
Wide Meters View 226
Window Configuration List 207
Window Configurations 203

importing 425

window dub
  horizontal position 135
  setting color 135
  size 135
  vertical position 135

Window menu 211
  Automation Enable command 1138
  Big Counter command 475
  Color Palette 261
  Disk Space command 508
  Edit command 188
  Machine Track Arming command 1287
  Memory Locations command 885
  Mix command 186
  System Usage command 104
  Task Manager command 405
  Transport command 194
  Undo History command 593
  Workspace command 510

windows
  arranging 206
  Cascade 206
  closing 206
  hiding all floating windows 206
  Tile 206
  Tile Horizontal 206
  Tile Vertical 206

Windows sessions
  compatibility with Mac 460

Word Clock 99, 1413

workflows 574

Workspace 307
  Audio Files Conform to Session Tempo 316
  auditioning 339
  Automatically Find and Relink 346
  Auto-Preview mode 342
  browser display options 318
  browser menu 315
  Calculate Waveform 338
  candidates for relinking 347
  Catalogs 308, 351, 352
  Comments 322
  Copy and Relink 345
  copying database items 323
  Create Catalog from Selection 316
  database 309
  database items 320, 322
  Delete Index for All Offline Volumes 316
  deleting database items 323
Don't Limit Search Results 316
Elastic Audio analysis 338
Elastic Audio Plug-In selector 341
exclude tags from search 334
Failed Tasks 356
Find Links 349
indexing 314
Keep Window on Top 316
Linking Options 349
links 344
Loop Audition mode 342
Manually Find and Relink 346
Missing files 344, 345
moving database items 323
navigating 311
Open in New Workspace 317
Paused Tasks 355
Performance Volume 309
preferences 357
previewing 339, 340, 343
Quick Search 325
Regenerate Missing Rendered Files 346
Relink window 308, 347
relinking 344
Reveal in Finder/Explorer 317
Right-click menu 316
saving a search as a Catalog 331
searching 325
searching with tags 333
session 308
Show Offline Volumes 316
Skip All 346
sorting columns 319
Sound Libraries 307
Spacebar Toggles File Preview 316
Spot To Edit Insertion 317
suitable volumes (see Transfer files) 345
Task Manager window 308
Tasks 355
Transfer files 344, 345
Transfer Volume 309
volume permissions 312
Volumes 308
WaveCache 309
waveform display 337
Workspace browsers 199, 307, 510, 511
Track Presets 273
Workspace.wksp file 309
Write 1174
Write Automation commands 1173, 1174
Write automation mode 1128
Write Automation To commands 1177
Write Automation to Next Breakpoint command 1166
Write Automation to Next Breakpoint on Stop command 1168
Write Automation to Selection/Selection Start/Selection End buttons 1164
Write MIDI Real-Time Properties command 785
Write Trim Real-Time Properties command 785
X
XML (MIDI patch names) 773
X–OR (Cancels Previous Solos) Solo Latch option 258
Z
zero-crossing 586
Zoom buttons 604
Zoom Presets 609
Zoom Toggle 609
Zoom Toggle preferences 115, 609
Zoomer tool 603, 604, 606
zooming 604
a track area 606, 807
around a track point 606, 806
continuously 604
horizontally for all tracks 604
in the ruler 607
in the Tempo Editor 850
on a selection 605
out to the entire session 606
recalling zoom levels 609
return to the previous zoom level 605
storing zoom levels 609
to make all clips visible 606
vertically 605
with a scroll wheel 612
Zoom Toggle 609