Pro Tools
Reference Guide

Version 5.3 for HD Systems on Macintosh or Windows
Version 5.1.1 for MIX or LE Systems on Macintosh or Windows

Digidesign
2001 Junipero Serra Boulevard
Daly City, CA  94014-3886 USA
tel: 650·731·6300
fax: 650·731·6399

Technical Support (USA)
650·731-6100
650·856·4275

Product Information (USA)
650·731·6102
800·333·2137

International Offices
Visit the Digidesign Web site
for contact information

Web Site
www.digidesign.com
Copyright
This guide is copyrighted ©2002 by Digidesign, a division of Avid Technology, Inc. (hereafter “Digidesign”), with all rights reserved. Under copyright laws, this manual may not be duplicated in whole or in part without the written consent of Digidesign.
DIGIDESIGN, AVID and PRO TOOLS are trademarks or registered trademarks of Digidesign and/or Avid Technology, Inc. All other trademarks are the property of their respective owners.
All features and specifications subject to change without notice.
PN 932709360-00 REV A 1/02
# Contents

**Part I Introduction**

<table>
<thead>
<tr>
<th>Chapter 1. Welcome to Pro Tools</th>
<th>3</th>
</tr>
</thead>
<tbody>
<tr>
<td>The Pro Tools Guides</td>
<td>3</td>
</tr>
<tr>
<td>Compatibility Information</td>
<td>4</td>
</tr>
<tr>
<td>Digidesign Registration</td>
<td>4</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Chapter 2. Pro Tools System Configurations</th>
<th>5</th>
</tr>
</thead>
<tbody>
<tr>
<td>TDM-Equipped Systems</td>
<td>5</td>
</tr>
<tr>
<td>Pro Tools LE Systems</td>
<td>8</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Chapter 3. Pro Tools Concepts</th>
<th>11</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hard Disk Audio Recording</td>
<td>11</td>
</tr>
<tr>
<td>The Digidesign Audio Engine</td>
<td>11</td>
</tr>
<tr>
<td>Pro Tools Sessions</td>
<td>12</td>
</tr>
<tr>
<td>System Resources</td>
<td>16</td>
</tr>
<tr>
<td>MIDI Concepts</td>
<td>18</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Chapter 4. Pro Tools Windows</th>
<th>21</th>
</tr>
</thead>
<tbody>
<tr>
<td>The Mix Window</td>
<td>21</td>
</tr>
<tr>
<td>The Edit Window</td>
<td>21</td>
</tr>
<tr>
<td>The Transport Window</td>
<td>25</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Chapter 5. Keyboard Shortcuts</th>
<th>29</th>
</tr>
</thead>
<tbody>
<tr>
<td>Global Key Commands</td>
<td>29</td>
</tr>
<tr>
<td>Keyboard Focus</td>
<td>30</td>
</tr>
<tr>
<td>Numeric Keypad Modes</td>
<td>31</td>
</tr>
</tbody>
</table>
# Part II  Sessions & Tracks

## Chapter 6. Sessions

- Starting Up Your System ................................................................. 35
- Configuring Your System ............................................................... 35
- Configuring a Pro Tools|HD System .................................................. 38
- Configuring Other Pro Tools Systems ............................................. 42
- Creating a New Session ....................................................................... 43
- Opening a Session .............................................................................. 44
- Saving a Session ................................................................................. 45
- Creating Custom Session Templates ................................................. 48
- Closing a Session ............................................................................... 50
- Quitting Pro Tools ............................................................................... 50
- Sharing Sessions Between Pro Tools TDM Systems and Pro Tools LE Systems ......................................................... 50

## Chapter 7. I/O Setup

- The I/O Setup Dialog .......................................................................... 59
- Routing Hardware I/O to Pro Tools I/O .............................................. 63
- Creating and Editing Paths .................................................................. 64
- I/O Settings Files ................................................................................ 71
- Default Output, Meter, Audition, and Default Path Order I/O Setup Options ................................................................. 73

## Chapter 8. Tracks

- Track Types ....................................................................................... 77
- Creating Tracks ................................................................................... 80
- Hiding Tracks ..................................................................................... 82
- Assigning Inputs and Outputs to Audio Tracks (and Other Tracks) .................................................................................. 84
- Assigning Voices and Track Priority ................................................... 85
- Setting MIDI Input and Output ........................................................... 87
- Soloing and Muting Tracks .................................................................. 88
- Making Tracks Inactive ....................................................................... 90
- Adjusting Track Width ....................................................................... 90
- Color Coding Tracks .......................................................................... 91
- Grouping Tracks ................................................................................ 91
Chapter 9. Importing and Exporting Audio and MIDI ............................... 95
  Importing Audio .......................................................... 95
  Importing Tracks from Other Sessions .................................. 98
  Loading Audio Files with Drag & Drop ................................. 100
  Exporting Audio ............................................................ 101
  Transferring Audio from CD ............................................. 102
  Conversion Quality .......................................................... 103
  Exporting Session Text .................................................... 104
  Importing MIDI Files ....................................................... 106
  Exporting MIDI Files ....................................................... 107

Chapter 10. File Management and Compatibility ............................. 109
  Locating Audio Files ....................................................... 109
  WAV File Compatibility .................................................... 110
  Avid File Compatibility ..................................................... 111
  Creating Mac and PC Compatible Sessions .............................. 111

Part III                Recording

Chapter 11. Record Setup .................................................... 117
  Input Connections and Audio Levels .................................... 117
  Record Enabling Tracks (Using the Record Enable Button) ............. 118
  Monitoring Modes .......................................................... 119
  Monitoring Latency ........................................................ 121
  Track Names ................................................................. 122
  Disk Allocation ............................................................. 123
  Allocating Hard Drive Space for Recording ................................ 125
  Record Modes ............................................................... 125
  Recording with the Click .................................................. 128
  Setting the Default Meter .................................................. 129

Chapter 12. Basic Audio Recording ............................................. 133
  Recording a Mono Audio Track .......................................... 133
  Recording a Stereo Audio Track ......................................... 135
Recording Multiple Audio Tracks ................................................. 136
Record Pause Mode ................................................................. 137
Recording Additional Takes ..................................................... 138
Punch Recording Audio .......................................................... 140
Loop Recording Audio ............................................................. 141
Auditioning Record Takes ....................................................... 142
Setting Punch/Loop Points ....................................................... 144

Chapter 13. MIDI Recording ................................................... 149
Recording from MIDI Devices .................................................. 149
Enabling Input Devices ............................................................ 150
MIDI Thru .............................................................................. 150
MIDI Input Filter ..................................................................... 151
Input Quantize ........................................................................ 151
Wait for Note ......................................................................... 152
MIDI Merge/Replace ............................................................... 152
Configuring MIDI Tracks for Recording ..................................... 153
Recording to MIDI Tracks ....................................................... 154
Punch Recording MIDI ............................................................ 155
Loop Recording MIDI ............................................................... 157
Recording System Exclusive Data ............................................. 160

Chapter 14. Advanced Recording ............................................ 161
QuickPunch Audio Recording ................................................... 161
Recording from a Digital Source ................................................. 164
Half-Speed Recording and Playback .......................................... 166

Part IV  Editing

Chapter 15. Editing Basics ...................................................... 169
Pro Tools Editing ..................................................................... 169
Track Material ......................................................................... 170
Displaying Region Names and Times ....................................... 174
Audio Regions and Waveforms ................................................. 174
### MIDI Regions and MIDI Data ................................................. 176
### Playlists .............................................................................. 178
### Multiple Undo ...................................................................... 180
### The Audio and MIDI Regions Lists ...................................... 181
### Edit Modes ........................................................................... 185
### Zooming .............................................................................. 186
### The Universe Window .......................................................... 187
### Timebase Rulers ................................................................... 189
### Main Time Scale .................................................................... 190
### Tick-Based Timing ............................................................... 191

### Chapter 16. Playing and Selecting Track Material ................. 193

- Playing Tracks ................................................................. 193
- Scrolling Options ............................................................. 195
- The Scrubber ....................................................................... 196
- Separate Edit and Timeline Selections .................................. 199
- Selecting Track Material ..................................................... 200
- Playing Selections ............................................................. 208
- Timeline Selections ............................................................ 209
- Playing Edit and Timeline Selections with the Playhead .......... 211

### Chapter 17. Working with Regions and Selections ............... 213

- Creating New Regions ........................................................ 213
- Healing a Separation .......................................................... 216
- Placing Regions in Tracks .................................................... 216
- The Trimmer Tool ............................................................... 218
- Sliding Regions .................................................................... 221
- Nudging ............................................................................... 225
- Shift Command .................................................................... 227
- Quantizing Regions ............................................................. 228
- Locking Regions ................................................................... 228
- Muting/Unmuting Regions ................................................... 228
- Edit Commands ..................................................................... 229
- Duplicate Command ............................................................ 233
- Repeat Command ............................................................... 233
- Merge Paste Command ......................................................... 234
<table>
<thead>
<tr>
<th>Chapter</th>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>18. Advanced Editing</td>
<td>Replacing Regions</td>
<td>239</td>
</tr>
<tr>
<td></td>
<td>Repeat Paste To Fill Selection</td>
<td>241</td>
</tr>
<tr>
<td></td>
<td>Compress/Expand Edit To Play</td>
<td>241</td>
</tr>
<tr>
<td></td>
<td>The Time Trimmer</td>
<td>242</td>
</tr>
<tr>
<td>19. Fades and Crossfades</td>
<td>Using Crossfades</td>
<td>245</td>
</tr>
<tr>
<td></td>
<td>Creating a Crossfade</td>
<td>252</td>
</tr>
<tr>
<td></td>
<td>Creating Fades at the Beginnings and Ends of Regions</td>
<td>253</td>
</tr>
<tr>
<td></td>
<td>Using AutoFades</td>
<td>254</td>
</tr>
<tr>
<td></td>
<td>Creating Fades and Crossfades in Batches</td>
<td>255</td>
</tr>
<tr>
<td>20. Managing Regions</td>
<td>Stripping Silence from Regions</td>
<td>257</td>
</tr>
<tr>
<td></td>
<td>Inserting Silence</td>
<td>259</td>
</tr>
<tr>
<td></td>
<td>Consolidate Selection Command</td>
<td>260</td>
</tr>
<tr>
<td></td>
<td>Managing Regions</td>
<td>260</td>
</tr>
<tr>
<td></td>
<td>Compacting an Audio File</td>
<td>263</td>
</tr>
<tr>
<td>21. Conductor Tracks and Memory Locations</td>
<td>Tempo Events</td>
<td>265</td>
</tr>
<tr>
<td></td>
<td>Default Tempo</td>
<td>268</td>
</tr>
<tr>
<td></td>
<td>Identify Beat Command</td>
<td>268</td>
</tr>
<tr>
<td></td>
<td>Meter Events</td>
<td>271</td>
</tr>
<tr>
<td></td>
<td>Renumbering Bars</td>
<td>273</td>
</tr>
<tr>
<td></td>
<td>Memory Locations and Markers</td>
<td>274</td>
</tr>
<tr>
<td></td>
<td>Memory Locations Window</td>
<td>280</td>
</tr>
<tr>
<td>22. Beat Detective</td>
<td>Beat Detective Requirements</td>
<td>283</td>
</tr>
</tbody>
</table>
About Beat Detective ................................................................. 283
The Beat Detective Window ...................................................... 285
Defining the Selection for Beat Detective ................................. 286
Detecting Transients with Beat Detective ................................. 287
Generating Bar|Beat Markers with Beat Detective ...................... 290
Separating and Conforming Regions with Beat Detective .......... 291
Beat Detective and Collection Mode ......................................... 294

Part V            MIDI Editing

Chapter 23. MIDI Editing ....................................................... 299
   Inserting MIDI Notes with the Pencil Tool .......................... 299
   Manually Editing MIDI Notes ............................................. 301
   Continuous Controller Events ......................................... 305
   Program Changes .......................................................... 306
   System Exclusive Events ............................................... 310
   Note and Controller Chasing .......................................... 311
   Offsetting MIDI Tracks .................................................. 312
   Stuck Notes .............................................................. 313

Chapter 24. MIDI Operations .................................................. 315
   MIDI Operations Window .............................................. 315
   Select Notes .............................................................. 316
   Quantize ................................................................. 318
   Change Velocity ........................................................ 322
   Change Duration ........................................................ 324
   Transpose ............................................................... 326

Chapter 25. MIDI Event List .................................................... 327
   The MIDI Event List ...................................................... 327
   Inserting Events in the MIDI Event List ............................... 330
   Editing in the MIDI Event List ......................................... 332
   MIDI Event List Options ............................................... 334
# Part VI  Mixing

## Chapter 26. Basic Mixing

- Audio Signal Flow .......................... 337
- Viewing I/O, Inserts, and Sends .......... 341
- Track Input ................................ 342
- Track Output ............................... 343
- Sends ....................................... 345
- Output Windows for Tracks and Sends ... 349
- Submixing for Signal Routing and Effects Processing ........................... 353
- Mixing Concepts ........................... 357
- Using a Control Surface with Pro Tools .. 358
- Dither .................................... 359

## Chapter 27. Plug-In and Hardware Inserts

- Inserting Plug-Ins on Tracks .......... 365
- The Plug-In Window ....................... 366
- Hardware I/O Inserts ..................... 370
- Connecting and Integrating External Devices .......................... 371

## Chapter 28. Automation

- Automation Quick Start .................... 375
- Automation Playlists ....................... 376
- Automation Modes .......................... 377
- Automation Preferences .................... 380
- Viewing Automation ....................... 383
- Writing Automation ....................... 384
- Enabling and Suspending Automation ..... 387
- Deleting Automation ....................... 388
- Thinning Automation ....................... 389
- Drawing Automation ....................... 390
- Editing Automation ....................... 391
- Writing Automation to the Start, End or All of a Selection ................. 397
- Trimming Automation ....................... 399
- Creating Snapshot Automation .......... 400
<table>
<thead>
<tr>
<th>Chapter 29. Mixdown</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Recording to Tracks</td>
<td>405</td>
</tr>
<tr>
<td>Bounce to Disk</td>
<td>406</td>
</tr>
<tr>
<td>Bounce Options</td>
<td>407</td>
</tr>
<tr>
<td>Recording a Submix</td>
<td>415</td>
</tr>
<tr>
<td>Final Mixdown</td>
<td>416</td>
</tr>
<tr>
<td>Mastering</td>
<td>416</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Part VII</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Chapter 30. Surround Concepts</td>
<td>421</td>
</tr>
<tr>
<td>Mixing Formats and Surround Formats</td>
<td>421</td>
</tr>
<tr>
<td>Pro Tools Mixing Formats</td>
<td>422</td>
</tr>
<tr>
<td>Speaker Layouts</td>
<td>422</td>
</tr>
<tr>
<td>Surround Monitoring</td>
<td>424</td>
</tr>
<tr>
<td>Formats and Terminology</td>
<td>425</td>
</tr>
<tr>
<td>Surround Mixing Concepts</td>
<td>428</td>
</tr>
</tbody>
</table>

| Chapter 31. Pro Tools Setup for Surround | 431   |
| Pro Tools Audio Connections for 5.1 Mixing | 431  |
| Configuring Pro Tools for Multichannel Sessions | 432  |
| Default Selectors in I/O Setup | 436  |
| 5.1 Track Layouts, Routing, and Metering | 436  |

| Chapter 32. Multichannel Tracks and Signal Routing | 437   |
| Multichannel QuickStart | 437  |
| Multichannel Audio Tracks | 438  |
| Multichannel Signal Routing | 440  |
| Paths in Surround Mixes | 443  |
| Example Paths and Signal Routing for a Surround Mix | 445  |

| Chapter 33. Surround Panning and Mixing | 449   |
| Introduction to Pro Tools Surround Panning | 449  |
| Output Windows | 450  |
Part VIII  Synchronization

Chapter 34. Synchronization Concepts ........................................ 463
  Synchronization Requirements ........................................... 463
  Aspects of Synchronization ............................................. 463
  Synchronizing Pro Tools ................................................. 463
  SMPTE Frame Formats .................................................. 466
  Working with Film-Originated Material ............................... 467

Chapter 35. Time Code Synchronization .................................. 473
  Pro Tools Synchronization Options .................................... 473
  Session Setup Window .................................................. 474
  Hardware Setup Window .............................................. 477
  Preparing to Work with SMPTE ....................................... 478
  Configuring Pro Tools for SMPTE .................................... 478
  Putting Pro Tools Online .............................................. 481
  Generating Time Code ................................................ 481
  Synchronizing a Sequencer to Pro Tools on the Macintosh ...... 482
  Synchronizing a Sequencer to Pro Tools in Windows ............. 484
  Using MIDI Machine Control ........................................ 485
  Remote Track Arming .................................................. 487
  Setting Minimum Sync Delay ....................................... 487
  Synchronizing Pro Tools to an OMS-Compatible Sequencer Using MMC .................................................. 489
  MIDI Beat Clock ....................................................... 491
  Spotting Regions to SMPTE Frame Locations .................... 491
  Time Stamping ......................................................... 494
  Identifying a Synchronization Point ................................ 495
Part I: Introduction
Welcome to Pro Tools®. Pro Tools integrates powerful multitrack digital audio and MIDI sequencing features, giving you everything you need to record, arrange, edit, mix, and master quality audio for music, video, film, and multimedia.

The Pro Tools Guides

Your Pro Tools System includes the following guides:

**Getting Started Guide** Instructions for installing your Pro Tools system and connecting your studio.

**Pro Tools Reference Guide** Provides full details on all Pro Tools functionality and operations. (Pro Tools LE systems only include an electronic PDF file version of this guide.)


**DigiRack™ Plug-Ins Guide** Instructions for using the DigiRack plug-ins (included with Pro Tools) for both real-time and file-based audio processing in Pro Tools. (Pro Tools LE systems only include an electronic PDF version of this guide.)

**Digidesign Plug-Ins Guide** Electronic PDF guide with instructions for using optional Digidesign plug-ins for both real-time and file-based audio processing in Pro Tools.

**Pro Tools MIDI Control Surfaces Guide** Electronic PDF guide that includes instructions for operating Pro Tools with various MIDI control surfaces.

**Expanded Systems Guide (TDM Systems Only)** Instructions for expanding a Pro Tools TDM system with optional Digidesign cards, or an expansion chassis.

**Pro Tools MachineControl Guide (TDM Systems Only)** Instructions for using MachineControl software for Pro Tools to enable serial communication with remote audio and video machines.

**Keyboard Shortcut Cards** Separate cards for Macintosh and Windows that list the many keyboard shortcuts not shown in the Pro Tools menus. (Pro Tools LE systems only include an electronic PDF version of the Keyboard Shortcut cards.)

Digidesign also provides guides with TDM audio interfaces, optional dedicated controllers (such as Control|24 and ProControl) and other Digidesign options, (such as SYNC I/O). Refer to the package shipped with your Digidesign product.
Conventions Used in These Guides

The Pro Tools guides use the following conventions to indicate menu choices and key commands:

<table>
<thead>
<tr>
<th>Convention</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>File &gt; Save Session</td>
<td>Choose Save Session from the File menu</td>
</tr>
<tr>
<td>Control+N</td>
<td>Hold down the Control key and press the N key</td>
</tr>
<tr>
<td>Option-click</td>
<td>Hold down the Option key and click the mouse button</td>
</tr>
<tr>
<td>Right-click (Windows)</td>
<td>Click with the right mouse button</td>
</tr>
</tbody>
</table>

The following symbols are used to highlight important information:

💡 User Tips are helpful hints for getting the most from your Pro Tools system.

⚠️ Important Notices include information that could affect your Pro Tools session data or the performance of your Pro Tools system.

🔍 Shortcuts show you useful keyboard or mouse shortcuts.

🔍 Cross References point to related sections in the Pro Tools Guides.

Choose and Select

The words “choose” and “select” are often interchangeable in conversational english. In this guide, however, there is a distinction between the two terms.

Select When the guide instructs you to select something, it stays selected. This is the case with dialog box options and menu items that enable or disable an option.

Choose When the guide instructs you to choose something, a one-time action is performed. This is the case with most menu commands; they perform their chosen action only once.

Compatibility Information

Digidesign can only assure compatibility and provide support for hardware and software it has tested and approved. For a list of Digidesign-qualified computers, operating systems, and third-party devices, refer to the latest compatibility information on the Digidesign Web site: www.digidesign.com/compato/

Digidesign Registration

Please make sure to register! Registered users are entitled to up to one year of free technical support based on the product purchased. For more information please refer to your registration card, or visit the Digidesign Web site: www.digidesign.com/support
Chapter 2: Pro Tools System Configurations

TDM-Equipped Systems

Pro Tools TDM-equipped systems are available in the following configurations. Each system requires at least one Digidesign audio interface (sold separately). TDM systems can be expanded by adding Digidesign cards to increase track count, add to the amount of possible plug-in and mixer processing, and connect additional audio interfaces.

⚠️ Pro Tools system performance depends on factors such as computer processor speed, amount of system memory, and hard drive performance. Contact your Digidesign dealer or visit Digidesign’s Web site for the latest system requirements and compatibility information.

HD-Series Systems

**Pro Tools|HD 1**
Includes:
- HD Core card
- Pro Tools software

**Pro Tools|HD 2**
Includes:
- HD Core card
- HD Process card
- Pro Tools software

**Pro Tools|HD 3**
Includes:
- HD Core card
- Two HD Process cards
- Pro Tools software
**MIX-Series Systems**

**Pro Tools|24 MIX**
Includes:
- MIX Core card
- Pro Tools software

**Pro Tools|24 MIXplus**
Includes:
- MIX Core card
- MIX Farm card
- Pro Tools software

**Pro Tools|MIX³**
Includes:
- MIX Core card
- Two Mix Farm cards
- Pro Tools software

**Pro Tools|24**
Includes:
- d24 Audio card
- DSP Farm card
- Pro Tools software

**Supported Audio Interfaces**

**HD-Series Only**
The following audio interfaces are compatible with Pro Tools HD-series systems:
- 192 I/O
- 96 I/O

⚠️ HD-series systems require the use of at least one 192 I/O or 96 I/O.

**HD-Series, MIX-Series and Pro Tools|24**
The following audio interfaces work with different TDM systems, as noted.

⚠️ Audio interfaces that work with HD-series systems require the use of at least one 192 I/O or 96 I/O.

The following Digidesign audio interfaces are supported with Pro Tools HD-series, Pro Tools MIX-series and Pro Tools|24 systems:
- 888|24 I/O and 882|20 I/O
- 1622 I/O
- 24-bit ADAT Bridge I/O or original ADAT Bridge I/O

The original 888 I/O and 882 I/O audio interfaces work with Pro Tools MIX-series and Pro Tools|24 systems only.
TDM System Playback, Recording and Voice Limits

The following table lists the audio playback, recording, and voiceable track limits of each type of Pro Tools TDM system. Playback and recording voices refer to the number of unique simultaneous playback and record tracks on your system. Total voiceable tracks (previously known as virtual voicing) refers to the maximum number of audio tracks that can share the available voices on your system. Voice limits are dependant on the session sample rate, and the number of DSP chips dedicated to the system’s Playback Engine. Pro Tools HD-series systems can open sessions with up to 256 audio tracks (and MIX-series systems can open sessions with up to 128 audio tracks), but any audio tracks beyond that system’s voiceable track limit will be automatically set to Voice Off.

All TDM-equipped Pro Tools systems provide a total of 64 internal mix busses. All TDM systems also provide 5 inserts and 5 sends per track, up to the DSP capacity of your system.

Table 1. Pro Tools HD-series, MIX-series and Pro Tools|24 system audio playback, recording and voice limits

<table>
<thead>
<tr>
<th>Core System Type</th>
<th>Sample Rate (kHz)</th>
<th>Voices (Mono Tracks of Simultaneous Playback)</th>
<th>Mono Tracks of Simultaneous Recording</th>
<th>Total Voiceable Tracks</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pro Tools</td>
<td>HD 1</td>
<td>44.1/48</td>
<td>96</td>
<td>96</td>
</tr>
<tr>
<td></td>
<td>88.2/96</td>
<td>48</td>
<td>48</td>
<td>48</td>
</tr>
<tr>
<td></td>
<td>176.4/192</td>
<td>12</td>
<td>12</td>
<td>12</td>
</tr>
<tr>
<td>Expanded Pro Tools</td>
<td>HD 1, Pro Tools</td>
<td>HD 2, Pro Tools</td>
<td>HD 3</td>
<td>44.1/48</td>
</tr>
<tr>
<td></td>
<td>88.2/96</td>
<td>64</td>
<td>64</td>
<td>80</td>
</tr>
<tr>
<td></td>
<td>176.4/192</td>
<td>24</td>
<td>24</td>
<td>24</td>
</tr>
<tr>
<td>Pro Tools</td>
<td>24 MIX</td>
<td>44.1/48</td>
<td>32, or 64</td>
<td>32, or 64</td>
</tr>
<tr>
<td>Pro Tools</td>
<td>24 MIXplus, Pro Tools</td>
<td>24 MIX3</td>
<td>44.1/48</td>
<td>64</td>
</tr>
<tr>
<td>Pro Tools</td>
<td>24</td>
<td>44.1/48</td>
<td>32</td>
<td>32</td>
</tr>
<tr>
<td>Expanded Pro Tools</td>
<td>24</td>
<td>44.1/48</td>
<td>64</td>
<td>64</td>
</tr>
</tbody>
</table>
Audio Interfaces for TDM Systems

The following table lists the input and output capabilities of the various audio interfaces for TDM-equipped Pro Tools systems. In expanded HD systems, audio interfaces can be combined for up to 96 audio inputs and outputs. In expanded MIX systems, audio interfaces can be combined for up to 72 audio inputs and outputs.

Table 2. Pro Tools TDM system audio interface channel capabilities

<table>
<thead>
<tr>
<th>Interface Type</th>
<th>Number of I/O Channels</th>
<th>Sample Rates (k Hz)</th>
<th>A/D Conversion</th>
<th>D/A Conversion</th>
<th>Digital I/O</th>
</tr>
</thead>
<tbody>
<tr>
<td>192 I/O</td>
<td>16 in/16 out</td>
<td>44.1, 48, 88.2, 96, 176.4, 192</td>
<td>24-bit</td>
<td>24-bit</td>
<td>24-bit</td>
</tr>
<tr>
<td>96 I/O</td>
<td>16 in/16 out</td>
<td>44.1, 48, 88.2, 96</td>
<td>24-bit</td>
<td>24-bit</td>
<td>24-bit</td>
</tr>
<tr>
<td>888</td>
<td>24 I/O</td>
<td>8 in/8 out</td>
<td>44.1, 48</td>
<td>24-bit</td>
<td>24-bit (or older 20-bit)</td>
</tr>
<tr>
<td>882</td>
<td>20 I/O</td>
<td>8 in/8 out</td>
<td>44.1, 48</td>
<td>20-bit</td>
<td>20-bit</td>
</tr>
<tr>
<td>1622 I/O</td>
<td>16 in/2 out</td>
<td>44.1, 48</td>
<td>20-bit</td>
<td>24-bit</td>
<td>24-bit</td>
</tr>
<tr>
<td>24-bit ADAT Bridge I/O, ADAT Bridge I/O</td>
<td>16 in/16 out</td>
<td>44.1, 48</td>
<td>24-bit</td>
<td>24-bit</td>
<td>24-bit</td>
</tr>
<tr>
<td>888 I/O</td>
<td>8 in/8 out</td>
<td>44.1, 48</td>
<td>18-bit (or older 16-bit)</td>
<td>18-bit</td>
<td>24-bit</td>
</tr>
<tr>
<td>882 I/O</td>
<td>8 in/8 out</td>
<td>44.1, 48</td>
<td>16-bit</td>
<td>16-bit</td>
<td>24-bit</td>
</tr>
</tbody>
</table>

The total processing capacity of a Pro Tools LE-based system depends on the processing power of your computer. Contact your Digidesign dealer or visit Digidesign’s Web site for the latest system requirements and compatibility information.

Pro Tools LE Systems

Pro Tools LE-based systems are available in the following configurations:

Digi 001

A Digi 001 system includes:
- Digi 001 PCI card
- Digi 001 I/O box
- Pro Tools LE software

Digi ToolBox XP

A Digi ToolBox system includes:
- Audiomedia III card
- Pro Tools LE software

The total processing capacity of a Pro Tools LE-based system depends on the processing power of your computer. Contact your Digidesign dealer or visit Digidesign’s Web site for the latest system requirements and compatibility information.
Pro Tools LE System Capabilities

The following table lists the playback, recording, and input and output capabilities of each Pro Tools LE-based system. All Pro Tools LE systems are limited to 24 mono audio tracks. If you open a Pro Tools session created on a TDM system containing more than 24 mono audio tracks on an LE-based system, only the audio tracks assigned to the first 24 voices will open; if you save the session using Pro Tools LE, any audio tracks beyond the available 24 voices will be lost.

All Pro Tools LE systems provide a total of 16 internal mix busses. Pro Tools LE also provides up to 5 inserts and 5 sends per track, depending on your computer’s processing capacity.

Table 3. Pro Tools LE system audio playback, recording, and channel capabilities

<table>
<thead>
<tr>
<th>System Type</th>
<th>Mono Tracks of Simultaneous Playback</th>
<th>Number of Simultaneous Recording Channels</th>
<th>A/D Conversion</th>
<th>D/A Conversion</th>
<th>Digital I/O</th>
</tr>
</thead>
<tbody>
<tr>
<td>Digi 001</td>
<td>24</td>
<td>up to 18 in/18 out</td>
<td>24-bit</td>
<td>24-bit</td>
<td>24-bit</td>
</tr>
<tr>
<td>Audiomedia III</td>
<td>24</td>
<td>up to 4 in/4 out</td>
<td>18-bit</td>
<td>18-bit</td>
<td>24-bit</td>
</tr>
</tbody>
</table>

For details on transferring session material between Pro Tools LE and Pro Tools TDM systems, see “Sharing Sessions Between Pro Tools TDM Systems and Pro Tools LE Systems” on page 50.
Chapter 3: Pro Tools Concepts

Pro Tools is based on simple concepts which are easy to grasp. Many of them you may already be familiar with. This chapter explains the principals and concepts that form the foundation of Pro Tools operation and functionality.

**Hard Disk Audio Recording**

Tape-based recording is a linear medium—you need to rewind or fast forward a tape to hear a particular spot in a recording. To rearrange or repeat material in a linear system, you need to re-record it.

Hard disk recording is a non-linear (or random access) medium—you can go immediately to any spot in a recording without having to re-wind or fast forward.

Non-linear systems have several advantages. You can easily rearrange or repeat parts of a recording by making the hard disk read parts of the recording in a different order and/or multiple times. In addition, this re-arrangement is non-destructive, meaning that the original recorded material is not altered.

Pro Tools is a non-linear recording system that lets you rearrange and mix recorded material non-destructively.

**The Digidesign Audio Engine**

When you start Pro Tools, the Digidesign Audio Engine, called DAE, automatically launches in the background. DAE is Digidesign’s real-time operating system for digital recording systems. When you install Pro Tools, DAE is automatically installed on your system (and can be accessed from within Pro Tools).

In the same way that a computer’s operating system provides the foundation for programs that run on the computer, DAE provides much of the hard disk recording, digital signal processing, mix automation, and MIDI functionality required by Pro Tools and other products from Digidesign and its Development Partners.

The DAE Playback Buffer Size determines the amount of memory allocated within DAE to manage disk buffers, which affects system performance. For more information, see “DAE Playback Buffer Size” on page 37. The DAE Playback Buffer Size can be changed in the Playback Engine Dialog, discussed below.
**Playback Engine Dialog**

Pro Tools takes advantage of your computer’s host processor for certain tasks and optional host-based DSP processing.

Pro Tools LE uses host (CPU) processing to provide audio track recording, playback, mixing, and effects processing. Pro Tools TDM can also use host processing to run RTAS plug-ins for effects processing. Performance is determined by your system and its Playback Engine settings.

The Playback Engine dialog lets you set a hardware buffer size and allocate a percentage of CPU resources for these tasks. For more information, see “Configuring Your System” on page 35.

![Playback Engine dialog for Pro Tools TDM system](image)

The Playback Engine dialog is also where you select the number of voices (and voiceable tracks) for your system and its sessions. Voice count choices in the dialog are based on how much DSP processing you wish to allocate for voicing. For more information, see “Configuring Your System” on page 35.

See also “System Resources” on page 16.

---

**Pro Tools Sessions**

When you start a project in Pro Tools, you create a session. Some basic elements of sessions are explained in this section.

**Session File**

A session file is the document that Pro Tools creates when you start a new project. The session file contains maps of all elements associated with a project, including audio files, MIDI data, and all your edit and mix information. You can make changes to a session and save those changes in a new session file. This lets you create multiple versions of a project or back up your editing and mixing work.

**Audio File**

When you record audio into a Pro Tools session, audio files are created.

Audio files for each session are stored in a folder named “Audio Files.” Audio files are listed in the Audio Regions List and can appear in a track. A section of an audio file can be defined as a region. See “Regions (or Loops)” on page 13.
**Tracks**

Pro Tools tracks are where audio, MIDI, and automation data are recorded and edited.

Audio and MIDI tracks can be edited into regions or repeated in different locations, to create loops, re-arrange sections or entire songs, or to assemble tracks using material from multiple takes.

Audio tracks can be mono, stereo, or any supported multichannel format (depending on your type of Pro Tools system). When creating a new audio track, you can choose from a list of formats supported by your system.

**Regions (or Loops)**

A region (or loop) is a piece of audio or MIDI data that may have associated automation data. A region could be a loop, a guitar riff, a verse of a song, a sound effect, a piece of dialog, or an entire sound file. In Pro Tools, regions are created from audio or MIDI files, and can be arranged in audio and MIDI track playlists.

**Playlist**

A playlist is a group of regions arranged on an audio or MIDI track. Tracks have edit playlists and automation playlists.

You can create any number of edit playlists for a track. This lets you assemble different versions of performances or edits on a single audio or MIDI track and choose among them with a pop-up menu on the track.

On audio tracks, an edit playlist tells the hard disk which audio files to read in what order. For example, you can use the same audio region to access the same piece of audio multiple times at different locations and not use additional disk space. If desired, different versions of the same original audio can be created to modify the length, fade-in, fade-out, and effects applied.

A playlist can be made up of a single region or many separate regions. It can be made up of similar elements, such as regions from several different takes of a solo, or dissimilar elements, such as several sound effects.

Each track has a single set of automation playlists, according to the type of track and any send or plug-in assignments.
**Channel**

The term *channel* is used to describe several related components of a Pro Tools system. The first example of channel refers to a physical input or output of your Pro Tools system.

For example, a 192 I/O audio interface (Figure 1) provides up to 16 channels of input and output to an HD-series TDM-equipped system. An 888|24 I/O audio interface provides eight channels of analog input and output to a TDM-equipped system.

The second use of the term *channel* refers to a mixer strip in the Pro Tools Mix window. The term *channel strip* refers to the mixer strip of any track (audio or MIDI track, Auxiliary Input, or Master Fader) in a session.

Audio and MIDI channel strips have similar controls, but those controls have slightly different effects. For example, audio and Auxiliary Input channel strip faders control the Pro Tools mixer, while MIDI channel strip faders send MIDI volume data (MIDI controller 7).

*The term channel also describes a separate aspect of MIDI operation. See “MIDI Concepts” on page 18.*
Signal Routing

Pro Tools provides software-based mixing and signal routing controls. The Mix window is where these controls are located. (Some of these controls can also be accessed from the Edit window, if desired.)

Signal Routing Example

A common signal routing task is to submix multiple tracks to a single channel strip for shared processing and level control. The following example shows three audio tracks submixed to a stereo Auxiliary Input.

Signal routing options include the following:

Track I/O Controls The most basic type of signal routing is track input and output. A track needs to have an assigned input path to record audio, and an assigned output path in order to be audible through a hardware output. Signals can also be routed to or from other tracks in Pro Tools (or hardware inputs and outputs) using internal busses.

Auxiliary Inputs and Master Faders Auxiliary Inputs are tracks that can be used as returns, submixers and bus masters. Master Faders are used as bus and output master level controls. Both Auxiliary Inputs and Master Faders can have inserts or plug-ins.

Sends Sends route audio to internal busses to send to other tracks in Pro Tools, or to hardware outputs.

Plug-Ins and Inserts Software plug-ins and hardware inserts process the audio on their associated track. Plug-in processing occurs completely within Pro Tools. Hardware inserts utilize audio interface inputs and outputs, for traditional insert routing to (and from) external effects and other devices.

Paths Pro Tools lets you define a group of multiple inputs, outputs, or busses that have a single name and (channel) format. These groups comprise the lists of available routing choices in track I/O Selectors and other menus. Paths can be very useful for assigning stereo and multichannel I/O routing or sub-paths within a path. See Chapter 7, “I/O Setup” for more information.

Mixing Formats Sessions can include combinations of mono, stereo, and multichannel format tracks, busses, inputs, outputs, and inserts. (Multichannel formats are supported on Pro Tools HD-series and MIX-series only.)
**System Resources**

Track count, plug-in processing, signal path and routing options, and voice availability are ultimately limited by the combined resources available from the host computer, and from your Pro Tools hardware.

Pro Tools provides several ways to manage and conserve resources to maximize the performance of your system. As you begin working with Pro Tools sessions and tracks, you can take advantage of the following features to extend the effectiveness of your available DSP and other resources:

- System usage settings (such as CPU Usage and H/W Buffer Size) let you balance the distribution of work between your computer and any Digidesign audio hardware. See “Configuring Your System” on page 35.
- Active and inactive switching lets you selectively toggle items (such as tracks and inserts) between active (on) and inactive (off). This lets you precisely allocate DSP and other resources when developing playlists, tracks, and mixes. See “Active and Inactive Items” on page 16.
- TDM-equipped Pro Tools systems provide flexible voice options for disk tracks. For more information on voice management and options, see “Voiceable Tracks and Track Priority” on page 87.

**Active and Inactive Items**

Pro Tools lets you set certain items (such as audio tracks) as inactive, in order to free up DSP resources and mixer connections.

Items in Pro Tools that can be made inactive (or active) include the following:

- Audio tracks, Auxiliary Inputs, and Master Faders (TDM systems only)
- Track Inputs and Outputs
- Sends
- Side-chain inputs
- Plug-ins
- Hardware Inserts
- Paths (session-wide)

MIDI tracks cannot be made inactive.

In addition to manually setting Active and Inactive modes, Pro Tools will automatically make items inactive if there are insufficient or unavailable resources.

When active, items are fully engaged and operational.

When inactive, items are silent and off. Different inactive items affect available system resources in specific ways, as follows:

**Plug-ins** When a plug-in is inactive on a track, its DSP is made available for other plug-ins and processing. Plug-in assignments can be made inactive manually, or automatically (see “Automatic and Manual Inactive Mode” on page 17).

**Paths and Path Assignments** When a path or path assignment is inactive, its mixer resources are made available for other signal routing purposes in the session. Paths and assignments can be made inactive manually, or automatically (see “Automatic and Manual Inactive Mode” on page 17).
Tracks (TDM systems only) When a track is inactive, its voice is made available for another track. Additionally, when an audio track, Auxiliary Input, or Master Fader is made inactive, its plug-ins, inserts, sends, and I/O assignments become inactive.

Display of Inactive Items

When items are inactive, their names appear in *italics*, and their background becomes dark grey. When a track is inactive (TDM systems only), the entire channel strip darkens.

Automatically Inactive Items

When opening a session, it is possible that not all signal paths, plug-ins, or audio interfaces used in the session will be available as defined on the current system. Whenever this occurs, the session will open as it was last saved. All items that are unavailable, or cannot be loaded due to insufficient resources, are made inactive.

Manual Inactive Switching

You can manually apply Active or Inactive modes to manage system resources. By making an item inactive, its associated resources are made available elsewhere in the session.

The following are basic instructions for manually making items inactive. Throughout the *Pro Tools Reference Guide*, instructions are provided whenever an item can be made inactive.

To toggle an item active or inactive:

- Command-Control-click (Macintosh) or Control-Start-click (Windows) the item.

You can apply Active or Inactive modes to all or all selected tracks using standard Pro Tools modifiers (Option and Option+Shift on the Macintosh, Alt and Alt+Shift in Windows). Side-chain inputs support direct active and inactive switching, but do not follow switching all or all selected.

Automatic and Manual Inactive Mode

Active and Inactive modes are powerful options for session transfer, and system resource management. Pro Tools provides automatic and manual Inactive mode switching. You can manually make items inactive (or active) to selectively manage system resources while editing and mixing.
MIDI Concepts

MIDI (Musical Instrument Digital Interface) is a communication protocol for musical instruments. This industry standard enables connections between a variety of devices from different manufacturers. Examples of MIDI-compatible equipment include synthesizers, sound modules, drum machines, patch bays, effects processors, MIDI interfaces, and sequencers.

MIDI devices are equipped with 5-pin DIN connectors, labeled as either IN, OUT, or THRU.

The MIDI OUT port transmits messages; the MIDI IN port receives messages; and, MIDI THRU echoes whatever is received from the IN port. MIDI devices are connected with MIDI cables that are available at most music stores.

A single MIDI cable can transmit a separate set of messages for each of the 16 channels. These 16 channels correspond to separate MIDI devices or to multiple channels within a single device (if the device is multi-timbral). Each channel represents a discreet instrument sound; for instance, bass on channel 1, piano on channel 2 and drums on channel 10. Similar to a multitrack tape recorder, a MIDI sequencer can record complex arrangements—even using a single multi-timbral keyboard.

MIDI Terms

The following are some basic MIDI terms:

**MIDI Interface** Hardware that lets computers connect to and communicate with MIDI devices.

**MIDI Device** Any keyboard, sound module, effects device or other equipment that can send or receive MIDI information.

**MIDI Controller** Any MIDI device that transmits MIDI performance data. These include keyboards, MIDI guitar controllers, MIDI wind instruments, and others. Controllers transmit MIDI from their MIDI OUT ports.

**MIDI Control Surface** Any device, such as the Mackie HUI, that uses a MIDI connection to send control messages to a software program, but is not generally used to record MIDI information.

**MIDI Sound Source** Any MIDI instrument capable of playing back MIDI-triggered sound. Sound sources receive MIDI from their MIDI IN ports.

**Multi-Timbral** The capability of playing several different instrument sounds (such as piano, bass, and drums) simultaneously on separate channels. This makes it possible for a single MIDI sound source to play back entire arrangements.

**MIDI Channel** Up to 16 channels of MIDI performance data can be transmitted on a single MIDI cable. The channel number separates the different messages so your sound sources can receive the right ones.

**Program Change Event** A MIDI command that tells a sound source which of its sounds (or sound patches) to use. The MIDI protocol lets you choose from a range of 128 patches.
Bank Select Message Many devices have more than 128 patches, which are arranged in banks. The Bank Select Message is a MIDI command that specifies the bank of patches from which to choose.

Local Control A controller setting found on most MIDI keyboards that lets them play their own sound source. Disabling “local control” ensures that a device’s internal sound source is only played by external MIDI messages.

When using Pro Tools, “local control” should usually be disabled. When “local control” is off, your keyboard still transmits data to its MIDI OUT port.

Continuous Controller Events MIDI instructions that allow real-time changes to notes that are currently sounding. These include pitch bend, modulation, volume, pan, and many others.

System Exclusive Data MIDI data commonly used for sending and retrieving patch parameter information for storage purposes.

Common Misconceptions about MIDI

MIDI is not audio. The messages that travel down a MIDI cable are only numbers that translate to specific instructions. For instance, when you strike a key on your MIDI keyboard it sends a message to its MIDI OUT port telling another device (if connected and set to the same MIDI channel) to play that particular note.

However, to actually hear that second device (sound source) you’ll need to connect its audio outputs to a sound system. Your MIDI instruments have two signal paths, one for audio and another for MIDI.

MIDI does not allow you to use your devices beyond their capabilities. Particular instruments have their own sound generation, polyphony, and multi-timbral limitations.
Chapter 4: Pro Tools Windows

Pro Tools provides two complementary ways of viewing a session: the Mix window and the Edit window. Pro Tools also allows you to control the transport and transport-related function from the Transport window.

For more information on the main elements of the Mix window and Edit window, see the page references provided in Figure 2 on page 22, and Figure 3 on page 23.

The Mix Window

In the Mix window, tracks appear as mixer strips (or channel strips), with controls for inserts, sends, input and output assignments, volume, panning, record-enable, automation mode, and solo/mute. The following section explains each of these track controls.

To display the Pro Tools input/output controls, inserts, sends, and comments, select Display > Mix Window Shows > All.

To toggle between the Mix and Edit windows: On Macintosh, press Command, followed by Equal (=); on Windows, press Control+Equal (=).

The Edit Window

The Edit window provides a timeline display of audio, as well as MIDI data and mixer automation for recording, editing and arranging tracks. As in the Mix window, each track has controls for record enable, solo, mute and automation mode.

Systems with the Pro Tools AVoption installed also provide a timeline display of movie tracks.

To display the input/output controls, inserts, sends, and comments in the Edit window, select Display > Edit Window Shows > All. You can choose to display all of these items, or some of them.
Figure 2. Pro Tools Mix window
Figure 3. Pro Tools Edit window
Track Controls

- Record Enable button (page 118)
- Automation Mode Selector (page 377)
- Solo button (page 89)
- Voice Selector (page 86)
- Mute button (page 89)

Mix window, controls for audio and MIDI tracks
(wide view)

- Record Enable button (page 118)
- Track Name (page 81)
- Playlist Selector (page 178)
- Automation Mode Selector (page 377)
- Solo button (page 89)
- Voice Selector (page 86)
- Track View Selector (page 170)

Edit window track controls (medium track height)

- Trimmer (page 218)
- Grabber (page 201)
- Selector (page 193)
- Scrubber (page 196)
- Zoomer (page 186)
- Smart Tool (page 237)
- Pencil (page 236)

Edit tools in Edit window

Event Edit Area

The Event Edit Area provides time, pitch, and other information for the currently selected audio or MIDI data. It also lets you define selections via key entry.

The Start, End, and Length display can be set for a different Time Scale format (such as Bars:Beats, or Minutes:Seconds, and so on). For more information, see “Main Time Scale” on page 190.

Location Indicators, Grid/Nudge Values, Current Cursor Display

The Location Indicators, Grid and Nudge values, and timeline Cursor Location display provide navigation and editing options.

The Main and Sub display can be set for a different Time Scale format (such as Bars:Beats, or Minutes:Seconds, and so on). For more information, see “Main Time Scale” on page 190.
The Transport Window

The Transport window can be set to show basic transport controls, counters, and MIDI controls. The counters in the Transport window mirror the Location Indicators at the top of the Edit window.

Basic Transport Controls and Counters

**Online** Puts Pro Tools online so that playback and recording is triggered by an external time code source.

**Return to Zero** Locates to the beginning of the session.

You can press Return (Macintosh) or Enter on the alpha keyboard (Windows) to locate to the beginning of the session.

**Rewind** Rewinds from the current play location. You can also click repeatedly to rewind incrementally, by an amount based on the Main Time Scale, as follows:

<table>
<thead>
<tr>
<th>Main Time Scale Format</th>
<th>Increment Amount</th>
</tr>
</thead>
<tbody>
<tr>
<td>Min:Sec</td>
<td>1 second</td>
</tr>
<tr>
<td>Time code</td>
<td>1 frame</td>
</tr>
<tr>
<td>Bars:Beats</td>
<td>1 bar</td>
</tr>
<tr>
<td>Feet:Frame</td>
<td>1 foot</td>
</tr>
<tr>
<td>Sample</td>
<td>1 second</td>
</tr>
</tbody>
</table>

With the Numeric Keypad Mode set to Transport, you can rewind by pressing 1.

**Stop** Stops playback or recording.

You can also stop the Transport with the following shortcuts:

- Press the Spacebar.
- With the Numeric Keypad Mode set to Transport, press 0.

**Play** Starts playback or (if the Record button was clicked first) recording from the Timeline insertion point.

With the Transport stopped, Control-click Play (Macintosh) or Right-click Play (Windows) to toggle Loop Playback mode. When enabled, a loop symbol appears in the Play button.

You can also initiate playback with the following shortcuts:

- Press the Spacebar.
- With the Numeric Keypad Mode set to Transport, press 0.
You can play at half-speed with the following shortcuts:

- Command-click (Macintosh) or Control-click (Windows) the Play button.
- Press Shift+Spacebar.

**Fast Forward** Fast forwards from the Timeline insertion point. You can also click repeatedly to fast forward incrementally (by an amount based on the Main Time Scale).

**Fast Forward Increments**

<table>
<thead>
<tr>
<th>Main Time Scale Format</th>
<th>Increment Amount</th>
</tr>
</thead>
<tbody>
<tr>
<td>Min:Sec</td>
<td>1 second</td>
</tr>
<tr>
<td>Time code</td>
<td>1 frame</td>
</tr>
<tr>
<td>Bars:Beats</td>
<td>1 bar</td>
</tr>
<tr>
<td>Feet:Frame</td>
<td>1 foot</td>
</tr>
<tr>
<td>Sample</td>
<td>1 second</td>
</tr>
</tbody>
</table>

With the Numeric Keypad Mode set to Transport, you can fast forward by pressing 2.

**Go to End** Locates to the end of the session.

You can press Option+Return (Macintosh) or Control+Enter on the alpha keyboard (Windows) to locate to the end of the session.

**Record** Arms Pro Tools for recording (the button flashes). Clicking Play then initiates recording.

With the Transport stopped, Control-click Record (Macintosh) or Right-click Record (Windows) to cycle through the four record modes. The Record button changes to indicate the currently selected mode: blank for Non-destructive, “D” for Destructive, a loop symbol for Loop Record, and “P” for QuickPunch.

You can also begin recording with the following shortcuts:

- Press F12.
- Press Command+Spacebar (Macintosh) or Control+Spacebar (Windows).
- With the Numeric Keypad Mode set to Transport, press 3.

To initiate recording at half-speed, press Command+Shift+Spacebar (Macintosh) or Control+Shift+Spacebar (Windows).

**Pre-Roll** During playback or record, specifies the amount that plays before the play (timeline) cursor location or beginning of the timeline selection. Pre-roll is particularly useful in punch recording since it provides you with time to “catch the beat” before reaching the punch-in point. To set the pre-roll amount, enter a new value in this field, or drag the Pre-Roll flag in the Main Timebase Ruler.

To enable pre-roll, click the Pre-Roll button to the left of the pre-roll field so it becomes highlighted.

**Post-Roll** During playback or record, specifies the amount that plays after the end of a timeline selection. Post-roll is useful in punch recording since playback continues after the punch-out point so you can check for a smooth transition to previously recorded material. To set the post-roll amount, enter a new value in this field, or drag the Post-Roll flag in the Main Timebase Ruler.

To enable post-roll, click the Post-Roll button to the left of the post-roll field so it becomes highlighted.
**Start** Specifies the beginning of the play or record range. You can set the start point by entering a location in this field, or by dragging the corresponding Playback Marker in the Main Timebase Ruler. For more information, see “Playback Markers” on page 144.

**End** Specifies the end of the play or record range. You can set the end point by entering a location in this field, or by dragging the corresponding Playback Marker in the Main Timebase Ruler. For more information, see “Playback Markers” on page 144.

**Length** Specifies the length for the play or record range. You can set the length by entering a location in this field, or by selecting a range in any Timebase Ruler.

**Transport Master** Specifies the “master” for transport functions. Click this button and choose from the pop-up menu to select the Transport Master, which can be set to Pro Tools, Machine, MMC, and Remote. For information, see Chapter 35, “Time Code Synchronization.”

**MIDI Controls**

![Transport window showing MIDI controls]

**Wait for Note** When selected, recording does not begin until a MIDI event is received. This ensures that you begin recording when you’re ready to play, and that the first note, or other MIDI data, is recorded precisely at the beginning of the record range.

> You can press F11 to turn on Wait for Note, unless the Operation Preference for “Disable F11 for Wait for Note” is selected.

**Click** When selected, a metronome sounds during playback and recording (as specified by the settings in the Click/Countoff Options dialog).

Double-click the Click button to open the Click/Countoff Options dialog.

> With the Numeric Keypad Mode set to Transport, you can press 7 to enable the Click.

**Countoff** When selected, Pro Tools counts off a specified number of measures (indicated in the button) before playback or recording begins.

Double-click the Countoff button, to open the Click/Countoff Options dialog.

> With the Numeric Keypad Mode set to Transport, you can press 8 to enable the Countoff.

**MIDI Merge** When selected (Merge mode), recorded MIDI data is merged with existing track material. When deselected (Replace mode), recorded MIDI data replaces existing track material.

> With the Numeric Keypad Mode set to Transport, you can press 9 to enable MIDI Merge.
**Conductor** When selected, Pro Tools uses the tempo map defined in the Tempo Ruler. When deselected, Pro Tools switches to Manual Tempo mode and ignores the Tempo Track.

In Manual Tempo mode, you can enter a BPM value in the tempo field, or tap in the tempo by clicking the Tap button.

**Meter** Displays the session’s current meter based on the play location. Double-click the Meter button to open the Change Meter window.

**Tempo** Displays the session’s current tempo based on the play location. In Manual Tempo mode, you can enter a BPM value into this field. In addition, when the tempo field is selected, you can tap in a tempo from a MIDI controller.
Chapter 5: Keyboard Shortcuts

Global Key Commands
This section shows keyboard shortcuts that apply to many functions in Pro Tools.

Track Functions
• Changing Automation mode
• Enabling playlists
• Adding plug-ins
• Record enabling, soloing, and muting tracks
• Record safining and solo safining tracks
• Assigning inputs, outputs, and sends
• Toggling volume/peak/delay display
• Clearing meters
• Changing track heights

List and Parameter Selection
• Selection of tracks in Show/Hide List
• Enabling of groups in Groups List
• Automation Enable window parameters
• Setting memory location parameters

<table>
<thead>
<tr>
<th>Command</th>
<th>Macintosh</th>
<th>Windows</th>
</tr>
</thead>
<tbody>
<tr>
<td>Apply action to all channel strips/tracks</td>
<td>Option+action</td>
<td>Alt+action</td>
</tr>
<tr>
<td>Apply action to selected channel strips/tracks</td>
<td>Option+Shift+action</td>
<td>Alt+Shift+action</td>
</tr>
</tbody>
</table>

Controls and Editing Tools
• Use to move plug-in controls, faders and sliders, the Scrubber, and automation data

<table>
<thead>
<tr>
<th>Command</th>
<th>Macintosh</th>
<th>Windows</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fine adjustment of sliders, knobs, and breakpoints</td>
<td>Command-click item</td>
<td>Control-click item</td>
</tr>
</tbody>
</table>
Keyboard Focus

The Keyboard Focus in Pro Tools determines how the alpha keys function. Depending on which Keyboard Focus is enabled, you can use the keys on your alpha keyboard to select regions in the Audio or MIDI Regions List, enable or disable groups, or perform an edit or play command (TDM systems only).

You can only enable one Keyboard Focus at a time. Enabling a Keyboard Focus will disable the one previously selected.

To set the Keyboard Focus:

- Click the a–z button for the focus you want to enable.
  - or -

While pressing Command+Option (Macintosh) or Control+Alt (Windows), press one of the following keys: 1 (Commands), 2 (Audio Regions List), 3 (MIDI Regions List), or 4 (Groups List).

Commands Focus (TDM Systems Only) When selected, this provides a wide range of single key shortcuts from the alpha keyboard for editing and playing.

With the Commands Focus disabled, you can still access any of its key shortcuts by pressing Control (Macintosh) or the Start key (Windows) along with the key.

Audio Regions Focus When selected, audio regions can be located and selected in the Audio Regions List by typing the first few letters of the region’s name.

MIDI Regions Focus When selected, MIDI regions can be located and selected in the MIDI Regions List by typing the first few letters of the region’s name.

Groups List Focus When selected, Edit and Mix Groups can be enabled or disabled by typing the Group ID letter.

Refer to the Keyboard Shortcut Card that came with your Pro Tools package (TDM systems only) for a list of keyboard shortcuts. This card is also available in PDF format in Pro Tools by choosing Help > Keyboard Shortcuts.
**Numeric Keypad Modes**

The Operation preference for Numeric Keypad Mode determines how the numeric keypad functions for Transport.

No matter which Numeric Keypad Mode is selected, you can always use the numeric keypad to select and enter values in the Event Edit Area, Location Indicators, and Transport fields.

**To set the Numeric Keypad Mode:**

1. Choose Setups > Preferences and click Operation.
2. Under the option for Numeric Keypad Mode, select a keypad mode (Classic, Transport, or Shuttle), then click Done.

**Classic**

This mode emulates the way Pro Tools worked in versions earlier than 5.0. With the Numeric Keypad Mode set to Classic, you can:

- Play up to two tracks of audio in Shuttle Lock mode. Press Control (Macintosh) or the Start key (Windows), followed by 0–9 for different play speeds. Press Plus or Minus to reverse direction.
- Recall Memory Locations by typing the Memory Location number, followed by a period.

**Transport**

This mode allows you to set a number of record and play functions, and also operate the Transport from the numeric keypad.

<table>
<thead>
<tr>
<th>Function</th>
<th>Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Click on/off</td>
<td>7</td>
</tr>
<tr>
<td>Countoff on/off</td>
<td>8</td>
</tr>
<tr>
<td>MIDI Merge/Replace mode</td>
<td>9</td>
</tr>
<tr>
<td>Loop Playback mode on/off</td>
<td>4</td>
</tr>
<tr>
<td>Loop Record mode on/off</td>
<td>5</td>
</tr>
<tr>
<td>QuickPunch mode on/off</td>
<td>6</td>
</tr>
<tr>
<td>Rewind</td>
<td>1</td>
</tr>
<tr>
<td>Fast Forward</td>
<td>2</td>
</tr>
<tr>
<td>Record</td>
<td>3</td>
</tr>
<tr>
<td>Play/Stop</td>
<td>0</td>
</tr>
</tbody>
</table>

With the Numeric Keypad Mode set to Transport, you can also:

- Play up to two tracks of audio in Shuttle Lock mode. Press Control (Macintosh) or the Start key (Windows), followed by 0–9 for different play speeds. Press Plus or Minus to reverse direction.
- Recall Memory Locations by typing period, the Memory Location number, and period again.
Shuttle
(TDM Systems Only)

Pro Tools offers another form of shuttling, different from that of Shuttle Lock mode. With the Numeric Keypad Mode set to Shuttle, playback of the current Edit selection is triggered by pressing and holding the keys on the numeric keypad—playback stops once the keys are released. Various playback speeds are available in both forward and reverse. In this mode, pre- and post-roll are ignored.

<table>
<thead>
<tr>
<th>Function</th>
<th>Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>1x Forward</td>
<td>6</td>
</tr>
<tr>
<td>1x Rewind</td>
<td>4</td>
</tr>
<tr>
<td>4x Forward</td>
<td>9</td>
</tr>
<tr>
<td>4x Rewind</td>
<td>7</td>
</tr>
<tr>
<td>1/4x Forward</td>
<td>3</td>
</tr>
<tr>
<td>1/4x Rewind</td>
<td>1</td>
</tr>
<tr>
<td>1/2x Forward</td>
<td>5+6</td>
</tr>
<tr>
<td>1/2x Rewind</td>
<td>5+4</td>
</tr>
<tr>
<td>2x Forward</td>
<td>8+9</td>
</tr>
<tr>
<td>2x Rewind</td>
<td>8+7</td>
</tr>
<tr>
<td>1/16x Forward</td>
<td>2+3</td>
</tr>
<tr>
<td>1/16x Rewind</td>
<td>2+1</td>
</tr>
<tr>
<td>Loop Selection (1x)</td>
<td>0</td>
</tr>
</tbody>
</table>

With the Numeric Keypad Mode set to Shuttle, you can also:

- Recall Memory Locations by typing period, the Memory Location number, and period again.

⚠️ Shuttle Lock mode is not available when the Numeric Keypad Mode is set to Shuttle.
Part II: Sessions & Tracks
Chapter 6: Sessions

This chapter covers some of the basics of starting a project in Pro Tools, including how to set up and save a Pro Tools session.

Starting Up Your System

In order for the components of your Pro Tools system to communicate properly with each other, you need to start them up in a specific order.

Start your Pro Tools system in this order:
1. Make sure all your equipment (including your CPU) is off.
2. For TDM systems with an expansion chassis, turn on the expansion chassis.
3. Turn on external hard drives, if any. Wait approximately ten seconds for them to spin up to speed.
4. Lower the volume of all output devices, then turn on your Pro Tools audio interfaces.
5. Turn on any MIDI interfaces and devices, or synchronization peripherals.
6. Turn on your Pro Tools audio interfaces (such as 96 I/O). On power up, the status LEDs will flash. Wait at least fifteen seconds for the audio interface to initialize, and the status LEDs to stop blinking and stay lit.

If you launch Pro Tools without turning on your audio interfaces, you will be prompted to turn them on. Allow fifteen seconds for audio interfaces to power-up and the status LEDs to stop blinking and stay lit, before clicking OK.

7. Turn on your computer.

For LE systems on Macintosh, if the Digi 001 is configured as a MIDI interface, make sure to launch Pro Tools before launching other MIDI applications, such as OMS Setup, and SampleCell Editor.

Once you have quit Pro Tools, shut down your Pro Tools system in this order:
1. Turn off your computer.
2. For TDM systems, turn off audio interfaces.
3. For TDM systems with an expansion chassis, turn off the expansion chassis.
4. Turn off any MIDI interfaces and devices.
5. Turn off external hard drives.

Configuring Your System

When you first use Pro Tools (or when you change your hardware), you should configure the Playback Engine and the Hardware Setup.

The Playback Engine lets you customize various System Usage parameters (such as buffers, CPU Usage).
Additionally, it sets voice count (and voiceable tracks) for your system and it’s sessions. Hardware Setup lets you set various parameters for your interfaces (such as whether you will use analog or digital inputs).

Configuring requirements are system-dependent. The following table provides general configuration guidelines.

<table>
<thead>
<tr>
<th>Pro Tools System</th>
<th>Configuration Guidelines</th>
<th>When</th>
<th>Pro Tools Window</th>
</tr>
</thead>
<tbody>
<tr>
<td>HD-series</td>
<td>Verify I/Os are present</td>
<td>first launch, or when you add or remove HD I/Os</td>
<td>Hardware Setup</td>
</tr>
<tr>
<td></td>
<td>Change physical I/O routings (unless you always use default settings)</td>
<td>when you add or remove HD I/Os</td>
<td>Hardware Setup</td>
</tr>
<tr>
<td></td>
<td>Make clock changes</td>
<td>first launch, or when you add or remove HD I/Os</td>
<td>Hardware Setup</td>
</tr>
<tr>
<td></td>
<td>Change other default Hardware Setup settings</td>
<td>when you want to change your defaults</td>
<td>Hardware Setup</td>
</tr>
<tr>
<td></td>
<td>Change default Playback Engine (for example, CPU Usage, Hardware Buffer Size, and DAE Buffer Size)</td>
<td>when you want to change your defaults</td>
<td>Playback Engine</td>
</tr>
<tr>
<td>MIX-series and Pro Tools</td>
<td>Change any of the default settings (such as changing Channel 1–2 input to digital or analog, and so on)</td>
<td>when you want to change your defaults</td>
<td>Hardware Setup</td>
</tr>
<tr>
<td></td>
<td>Change default Playback Engine (for example, the default number of DSPs used for the disk engine)</td>
<td>when you want to change your defaults</td>
<td>Playback Engine</td>
</tr>
<tr>
<td>LE</td>
<td>Change CPU Usage (for example, from 75% to 80%)</td>
<td>if you are not running other applications simultaneously with Pro Tools LE, or when you want to increase plug-ins</td>
<td>Playback Engine, or Hardware Setup</td>
</tr>
<tr>
<td></td>
<td>Increase H/W Buffer Size</td>
<td>when mixing, and you want to increase plug-in and mixer power</td>
<td>Playback Engine, or Hardware Setup</td>
</tr>
</tbody>
</table>
Host and RTAS Processing

Pro Tools LE uses host (CPU) processing to provide audio track recording, playback, mixing, and effects processing. Pro Tools TDM can also use host processing to run RTAS plug-ins for effects processing.

Pro Tools Playback Engine dialog allows you to set a hardware buffer size and allocate a percentage of CPU resources for these tasks.

RTAS on Pro Tools TDM Systems

On TDM systems, it is recommended that you set the H/W Buffer Size to 512 samples, and the CPU Usage Limit to 40%. These settings are the system defaults, and they should allow you to get good processing power from your RTAS plug-ins without slowing down the on-screen response of Pro Tools. These settings will work best on a fast computer (such as a G4 or Pentium IV computer).

On a slower TDM system, you should increase these settings. The H/W Buffer Size can be set as high as 1024 samples, and the CPU Usage Limit percentage can be set as high as 85%. This will increase the amount of processing you can get from RTAS plug-ins on slower systems.

When using RTAS plug-ins on TDM systems, you may encounter DAE -6031 or -9123 errors. In these instances, you can increase the H/W Buffer Size and CPU Usage Limit percentage in the Playback Engine dialog to get better system performance. With slower CPUs, you may also need to reduce the number of RTAS plug-ins used in the session to get acceptable results.

In addition to slower screen redraws and responsiveness, larger hardware buffer sizes can affect automation accuracy for plug-in parameters and mute data, as well as timing for MIDI tracks.

RTAS on Pro Tools LE Systems

On LE systems, it is recommended that you set the H/W Buffer Size to 256 samples, and the CPU Usage Limit to 70%. These settings are the system minimums, and they should allow you to get good processing power from your RTAS plug-ins without slowing down the on-screen response of Pro Tools. These settings will work best on a fast computer (such as a Power Macintosh G4 or fast Pentium IV-based computer).

However, on a slower system, to get maximum track count and processing power, you should use a higher H/W Buffer Size and CPU Usage Limit. At the maximum settings of 1024 samples and 85%, on most qualified systems, you should be able to get 24 audio tracks with plug-ins.

Higher H/W Buffer Sizes lead to increased latency. For more information on H/W Buffer Sizes and latency, see the Getting Started Guide.

DAE Playback Buffer Size

The DAE Playback Buffer Size determines the amount of memory allocated within DAE to manage disk buffers, which affects system performance.

DAE Playback Buffer in Playback Engine dialog

The default DAE Playback Buffer Size of “2” is recommended for 24-track, 24-bit sessions, and provides relatively fast record and playback while allowing most edits to be accommodated with reasonably fast hard disks. You may want to adjust this parameter to modify your system’s performance, as follows:
Allocating a larger buffer size can sometimes allow for a higher density of edits. This can be useful if you experience system performance problems in sessions with a large number of edits in rapid succession. However, choosing a larger buffer size can cause a time lag to occur before playback or recording begins. It can also cause a time lag to occur when you are editing during playback.

Allocating a smaller buffer size can sometimes improve playback/recording initiation speed. This can be useful if you are experiencing a time lag when you initiate playback/recording. However, choosing a smaller buffer size can make it difficult for slower hard drives to play or record tracks reliably.

Configuring a Pro Tools|HD System

Pro Tools Playback Engine

To configure the Playback Engine


2. From the H/W Buffer Size pop-up, select the audio buffer size, in samples, for host processing tasks such as Real-Time AudioSuite (RTAS) plug-in processing. The default setting is 512 samples. Select a higher setting if you need more buffer time for RTAS, HTDM, and Direct Connect applications.

3. From the CPU Usage Limit pop-up, select the maximum percentage of CPU resources to allocate to host processing tasks. The default setting is 40%. Select a higher setting if you need more buffer time for RTAS, HTDM, and Direct Connect applications.

4. From the Number of Voices pop-up, select the amount of voices (and voiceable tracks), for your sessions. The default number of voices on a Pro Tools|HD 1 system is 48 voices (at the default 48 kHz sample rate).

Increasing the CPU Usage Limit may slow down screen responses.

Changing the number of voices, along with sample rate, affects DSP usage and your system performance. Please read the following carefully.

Depending on the current sample rate, and the number of HD Core and Process cards in your system, you will have different choices available. For example, each HD card allows you to use one or two of its DSPs per card for voicing.
Most DSP amounts support three levels of voice numbers:

- Select higher voice numbers when your cards are in your machine, and you aren’t running extra PCI cards which may conflict with Digidesign cards. You should also select higher voice numbers when using a chassis to run higher track counts at higher sample rates (such as 64 tracks at 96 kHz) and you want more voices (such as 16 voices per DSP at 96 kHz).
- Select medium voice numbers when running cards in an expansion chassis, or when using other PCI cards along with Digidesign cards.
- Select minimum voice numbers if you are running high bandwidth PCI cards (such as video capture).

For voice limits on different HD systems, refer to Table 1 on page 7.

5 From the Sample Rate pop-up, select the session sample rate. This choice will not be available if a session is open.

6 Set DAE Playback Buffer Size.

The DAE Playback Buffer Size determines the amount of memory allocated within DAE to manage disk buffers, which affects system performance. For details, see “DAE Playback Buffer Size” on page 37.

7 Click OK, when finished.

### Hardware Setup

Pro Tools lets you configure many parameters of your audio interface. Choose Setups > Hardware Setup to open the Hardware Setup dialog. The Hardware Setup determines which Pro Tools audio interfaces are used for Pro Tools recording and playback. For example, HD-series systems can have HD Core and HD Process cards, connected directly to 192 I/O or 96 I/O audio interfaces. In turn, the audio interfaces can have additional I/Os attached (including older Digidesign audio interfaces, such as the 1622 I/O). For more information, see Chapter 2, “Pro Tools System Configurations.”

### Main Page

The Main tab page of the Hardware Setup dialog is where you define which physical ports on your I/O audio interface are routed to Pro Tools inputs and outputs. The channel input and output pop-ups in Hardware Setup serve as a patch-bay that allows you to route any of the physical inputs or outputs to your Pro Tools Mixer.

You must select the peripheral, then set the parameters for that interface—repeating this for each interface in your system.

The Main page also provides controls for Sample Rate, Clock Source, and expansion input and output.
Additional pages are available to configure other parameters on each I/O (such as setting operating levels). Refer to the Getting Started Guide for your system, or the guide for your audio interface.

To configure audio interfaces in Hardware Setup:

The following steps are for configuring an HD system with one or more HD interfaces (with one or more MIX-series interfaces attached). These steps can be applied to other system setups (such as a MIX system).

2. From the Peripherals list, select the Digidesign audio interface connected to the first card in your HD system. This will be the interface at the top of the list.
3. Make sure Main page tab is chosen.
4. From the Clock Source pop-up, select the appropriate clock source for the system. In most cases, you will use Internal. The other choices are for resolving Pro Tools to external clock sources. Depending on your audio interface, Clock Source options can include: AES/EBU [Encl], S/PDIF, Optical [Encl], AES/EBU 1–8, TDIF, ADAT, and Word Clock (optional word clock rates are available at higher frequencies).
5. From the Ext. Clock Output, select the appropriate clock source to feed to devices attached to your I/O.
6. To select a different digital I/O on your audio interface (enclosure), click on one of the format buttons, under Digital Format. Choices include: AES/EBU, S/PDIF, and Optical (S/PDIF). Selecting Optical (S/PDIF) resets the physical Optical I/O port (which is, by default, eight channels of ADAT I/O) to two channels of S/PDIF I/O.
7. For S/PDIF compatibility with Tascam DA30 DAT recorders, click on the Tascam button, under S/PDIF Format.
8. For the 96 I/O, click on the Meters pop-up menu and select whether to meter input or output meters.
9. From the Input and Output Channel Selectors, select the physical ports (such as Analog 1–2, Optical 1–2, and so on), that will be routed to the Pro Tools input and output ports (such as (Ch 1–2, 3–4, and so on).

Refer to your peripheral’s guide for sample rate, and other restrictions. For example, the Optical 1–8 channels will not be available for session sample rates of 88.2 or higher.

To differentiate inputs and outputs of the same format, they are labeled differently in the Input and Output Channel Selectors. For example, the AES/EBU inputs and outputs that come standard in the 192 I/O enclosure are identified as
AES/EBU (Encl); the AES/EBU inputs and outputs that come on the factory-installed Digital port are listed (in pairs) as AES/EBU 1–2, AES/EBU 3–4, and so on. For 192 I/Os equipped with the optional D/A Card (Digidesign 192 DA), the additional AES/EBU I/O ports on the optional card are labelled AES/EBU 9–10, AES/EBU 11–12, and so on.

The I/O Setup dialog provides a graphical representation of the Hardware Setup. Each I/O attached to your system is displayed, with controls to route physical ports to Pro Tools inputs and outputs. These controls mirror the routing controls found in Hardware Setup. Changes made to physical routing in one dialog, are always reflected in the other. I/O Setup also lets you label and map Pro Tools input, output, insert, and bus signal paths. For more information on paths, path mapping, and other I/O Setup features, see “I/O Setup” on page 59.

10 Click on other tabs (such as Analog In and Analog Out) for additional configuration options specific to the audio interface. These include:

- On the 96 I/O, configuring the operating levels of analog inputs and outputs (+4 dBu or –10 dB).
- On the 192 I/O analog input, setting the input connector, input trim (A or B), and Soft Limit.
- On the 192 I/O configuring two sets of trims for inputs and outputs.
- On the 192 I/O, configuring the optional D/A Card: Input Format, input sample rate converter (SR Conversion), and output channels to send AES/EBU Non-Audio Data.

If you install another A/D or D/A, or Digital I/O card, you will see another tab with Analog 9–16, or Digital 9–16.

11 Repeat the above steps for additional HD-series audio interface.

Use the Up and Down Arrow keys to scroll though each peripheral.

12 Repeat the above steps for any Legacy I/Os (such 888/24 I/O) connected to the first I/O, then second, and so on. Before you can configure a Legacy I/O, it must first be initialized in Hardware Setup (see below).

13 Click Ok.

For more information on Hardware Setup parameters for each Legacy I/O, refer to the guide that shipped with your Legacy audio interface.

Initializing MIX-Series Peripherals

Before you can configure a Legacy I/O, it must first be initialized in Hardware Setup, by completing the following:

1 Start your Pro Tools system. For startup steps, refer to See “Starting Up Your System” on page 35.

2 Make sure you turn down the volume of your speakers and amps. Very loud digital noise may be emitted before the Legacy I/O is initialized.

3 Turn on your Legacy I/O.

4 From the Peripheral list, choose the primary I/O (the audio interface to which your Legacy I/O is connected).

5 From the Main page, select the Legacy I/O button in the Port Settings.
In the Peripheral list, “> <No Interface>” is listed twice, directly below its primary I/O. Click on the first “> <No Interface>” and a pop-menu will be presented with supported I/O choices.

From the Interface pop-up, select the type of Legacy audio interface being configured (such as 888|24, 882|20, and so on). After selecting an audio interface, the Main page updates with controls that can be configured. Refer to the guide for your audio interface for details on each control.

Repeat the above steps for additional Legacy I/Os.

**Routing a Pro Tools Output Pair to Multiple Audio Interface Output Ports**

Pro Tools channel pairs can be routed to multiple outputs on your Digidesign audio interface through Hardware Setup.

This provides you with the ability to have the same signal (such as a stereo pair, a stem mix, or a multichannel mix) sent to multiple destinations (such as multiple mastering devices). Instead of doing multiple bounces or mix passes, each to a discreet device or output, or daisy-chaining devices, Hardware Setup allows you to “mirror” the Pro Tools output and provide multiple channels of the same signal to different I/O ports. For example, if you assign Analog 1–2 and Digital [Encl] (AES/EBU, S/SPDIF) in Hardware Setup to Pro Tools Output pair 1–2, when you select Pro Tools Output 1–2 (as defined in I/O Setup), the audio will be routed to all four outputs with a single dual channel assignment.

Pro Tools outputs pairs can also be routed to multiple audio interface outputs in I/O Setup. For more information, see “Routing Hardware I/O to Pro Tools I/O” on page 63.

To select multiple output ports for a Pro Tools output channel pair:

2. From the Peripherals list, select the desired interface.
3. Make sure Main page tab is chosen.
4. Select an output pair.
5. Ctrl+Shift an additional output destination.

The output name updates with a plus sign (“+”) before it.

To verify which output ports have been routed, select the original output: In the pop-up menu, each output assigned to the Pro Tools output channel pair will have a check mark next to it.

Select additional output destinations, as desired. The only limit to output choices is the number of outputs available in your system.

**Configuring Other Pro Tools Systems**

To configure a Pro Tools MIX-series, Pro Tools|24, or Pro Tools LE system, refer to the guides that came with your system.

Older Pro Tools software releases have different Playback Engine and Hardware Setup dialogs, as described in their guides.
Creating a New Session

The first step in beginning a Pro Tools project is creating a new session. When you do this, Pro Tools automatically creates a new folder named for your session. Within this folder is the session file and two other folders, an Audio Files folder, and a Fade Files folder.

The Audio Files folder contains all audio recorded or converted during the session. The Fade Files folder contains any crossfaded audio data generated by the session.

When you record a new audio track, the track is saved as a new audio file to the Audio Files folder. You can also import other audio files into the session, and work with them as well.

To use Japanese or non-ASCII characters in track and region names, or track comments, disable the option for “Enforce Mac/PC Compatibility” or “Enforce PC/Mac Compatibility” when creating a new session.

Similarly, if you attempt to save a session copy with the “Enforce Mac/PC Compatibility” or “Enforce PC/Mac Compatibility” option enabled, all Japanese and non-ASCII characters will be lost.

To create a new session:


2. Choose the drive where you want to save the session. The session should be created on a dedicated audio drive.

3. Select “Enforce Mac/PC Compatibility” (Macintosh) or “Enforce PC/Mac Compatibility” (Windows) if you want to create session and audio files that can be used in either Macintosh or Windows versions of Pro Tools. See “Creating Mac and PC Compatible Sessions” on page 111 for more information.

For details on allocating audio tracks to different hard drive locations, including shared media volumes, see “Disk Allocation” on page 123.
4 Select the audio file format for the session.

For optimum compatibility between Windows and Macintosh sessions, set the file type to WAV. SDII files are not supported on Windows systems, and Pro Tools prevents you from choosing SDII as the file type if Enforce Mac/PC Compatibility is selected (or the session is on a PC).

5 Select the bit depth (16 bit or 24 bit) and the sample rate.

6 Select the I/O Settings to use for the session. Several pre-configured I/O Settings are included with your system, or you can select a custom I/O Setting that you have created. See Chapter 7, “I/O Setup” for more information.

7 Name the Session.

8 Click Save.

Choosing Bit Depth and Sample Rate

When choosing a bit depth or sample rate for your session, consider the disk space and DSP mixing power your selection will require. 24-bit sessions occupy about 50% more disk space than 16-bit sessions. 192 kHz files occupy four times the space as 44.1 kHz files. Fewer mixer channels are available with higher samples rates or 24-bit sessions on TDM systems (see Appendix B, “TDM Mixing and DSP Usage”). On LE systems, 24-bit sessions require more processing power as well. It is not possible to combine different bit depths within a single session.

Opening a Session

When you open a session, Pro Tools looks in the session folder for associated audio and fade files.

To open an existing session:

1. Choose File > Open Session.

Open Session dialog

2. Locate the session you want to open and click Open.

Opening a Session that Contains Unavailable Items

Pro Tools prompts you when opening a session that contains unavailable I/O, DSP resources, plug-ins, or unsupported tracks. This is common when transferring sessions to systems with different Digidesign hardware.
The dialog contains a summary of the missing session components. To save a text file containing a more detailed report, along with the resulting action, click OK in the dialog.

Following are some actions that may occur when opening a session with unavailable items:
- Unsupported tracks for the current system are discarded. For example, trying to open a 64-track session on an LE system (which only supports 24 tracks) would result in the loss of 40 tracks. Furthermore, if you save this opened file, you will lose those tracks forever!
- Inserts assigned to unavailable plug-ins are made inactive.
- Inputs, outputs, and sends that are assigned to unavailable paths, are dropped.

**Saving a Session**

You should save regularly while working on your session to ensure that your work is preserved on your hard drive.

**Speeding up Saves by Reducing the Disk Cache Size**

(Macintosh Only)

To speed up session saves and disk bounces, it is recommended that you reduce the Cache Size for your Macintosh to 512k (in the Control Panel > Memory dialog).

**Saving the Session File**

The Save Session command saves the changes you have made to your session and writes them over the previously saved version of the file. The Save Session command cannot be undone.

To save a session:
- Choose File > Save Session.

**Revert to Saved Command**

If you have made changes to a session since you last saved it, you can discard the changes and revert to its previously saved state.

To revert to the last saved version of a session:
- Choose File > Revert to Saved.

**Save Session As Command**

The Save Session As command is useful for saving a copy of the current session under a different name, or to a different hard drive location. Because the Save Session As command closes the current session and lets you keep working on the renamed copy, it is particularly useful if you are experimenting and want to save successive stages of the session.

By working this way, you can quickly retrace your steps should you want to go back to an earlier version of your session. By using the Save Session As command you are saving a new version of the session file only—not duplicate versions of the audio or fade files.

To save a session under another name:

1. Choose File > Save Session As.
2. Enter a new name for your session and click Save to save the session.

The renamed session document is saved in the session folder along with the original session. Any new audio files that you record in your renamed session will be placed into the same Audio Files folder that was created for your original session.
**Saving a Copy of the Session**

You can use the Save Session Copy In command to save a copy of the current session, along with its audio files and fade files, to a different file and hard drive location. In addition, you can specify a session file format, audio file format, bit depth, and sample rate for the session copy.

Unlike the Save Session As command, Save Session Copy In does not close the original session, so subsequent edits are made to the original session. Session copies can be used to archive important sessions, or as a means to prepare sessions for transfer to another Pro Tools system.

Save Session Copy In only saves audio being used in the session. Any audio that was recorded or imported and then later removed from the session, will not be copied to the new session copy.

Using the Save Session Copy In command is the only way to switch sample rates of a session.

When you Save Session Copy with a lower bit rate, **Dither (and Noise Shaping) may be applied.** See the following table:

<table>
<thead>
<tr>
<th>Bit Rate Conversion</th>
<th>Save Session Copy</th>
</tr>
</thead>
<tbody>
<tr>
<td>24-bit to 16-bit (Dither and Noise Shape)</td>
<td>Yes</td>
</tr>
<tr>
<td>24-bit to 8-bit (Noise Shape Only)</td>
<td>No</td>
</tr>
<tr>
<td>16-bit to 8-bit (Noise Shape Only)</td>
<td>No</td>
</tr>
</tbody>
</table>

For more information about using Dither with Save, see “Dither” on page 359.

**Session Format**

You can save the session copy in the following formats:

- Latest (Pro Tools 5.1 or later)
- Pro Tools 5 Session
- Pro Tools 4, 16-Bit Session
- Pro Tools 4, 24-Bit Session
- Pro Tools 3.2 Session

Use Latest if you are working with Pro Tools software v5.1 or higher.

When saving 5.3 sessions to earlier versions, multichannel tracks and multi-mono plug-ins are lost. In this case, make sure to first separate the tracks and plug-ins to individual mono tracks.
Session Parameters

Audio File Type
You can save the session as a WAV or AIFF session. You can also save a session as SDII format on the Macintosh.

⚠️ SDII sessions are not supported for Pro Tools in Windows. For this reason, you cannot set the session audio file type to SDII on the Macintosh if Enforce Mac/PC Compatibility is selected.

Using Mixed File Types
A session can use mixed audio file types. If your original session has mixed file types, they are not converted to a different file type unless you specify that they be converted. However, when using mixed file types, audio performance will be reduced (due to additional file handling required for some file formats).

Bit Depth
You can save the new session at 16-bit or 24-bit depth. If your session is in a different bit depth, audio files are converted to the new session bit depth, and copied to the location you specify.

Sample Rate
You can save the new session at 44.1 kHz or 48 kHz sample rate (or higher for HD-series systems). If your session is at a different sample rate, audio files are converted to the new session sample rate, and copied to the location you specify.

The higher the quality of sample rate conversion you choose, the longer Pro Tools will take to process the audio file.

Enforce Mac/PC Compatibility (Macintosh)
Enforce PC/Mac Compatibility (Windows)
This setting forces Macintosh or Windows versions of Pro Tools to create sessions and audio files that are usable on both platforms. For more information, see “Creating Mac and PC Compatible Sessions” on page 111.

Items to Copy

All Audio Files and Session Plug-In Settings Folder
When this option is selected, all audio files and the session’s Plug-In Settings folder are copied to the new location. The references to these plug-in settings in the session are redirected to point to the copied files.

This setting is automatically selected if you are changing bit depth or sample rate, or copying a session on the Macintosh from SDII format to AIFF or WAV format with Enforce Mac/PC Compatibility selected.

All Non-SDII Audio Files
(Force Audio Files to Native Session Type)
This option ensures that all files in the new session are in the session file type you select, by converting files of different types to the session’s file format. Use this setting to avoid the reduced performance of a session with mixed file types.

This setting is automatically selected if you are changing bit depth or sample rate, or copying a session on the Macintosh from SDII format to AIFF or WAV format with Enforce Mac/PC Compatibility selected.
Don’t Copy Fade Files

With this option selected, Fade Files are not copied to the new session Fade Files folder. When the session is launched, the Find Files dialog will prompt you to locate Fade Files. You can either locate the existing fades using the find file dialog, or Skip All to let Pro Tools recreate the fades from the session document.

Root Plug-In Settings Folder

When this option is selected, the contents of the root-level Plug-In Settings Folder are copied into a folder named Place in Root Settings Folder, indicating that these files will need to be moved to the root level plug-in settings folder on the destination system before you can use them. The references to these settings files in the session are not redirected to point to the copied files.

Movie/Video Files (Macintosh Only)

When this option is selected, session movie files (QuickTime video files or AVoption or AVoption XL video files) are copied to the new location, and session references are updated to point to the copied movie files.

To save a session copy in a new location:

1. Choose File > Save Session Copy In.
2. In the Save Session Copy dialog, choose a destination and enter a name for the new session file.
3. Set the Audio File Type to AIFF, WAV, or SDII. If the audio files need to be compatible on either Macintosh or Windows platform, select AIFF or WAV.
4. Set the Sample Rate and Bit Depth for the session.
5. Select “Enforce Mac/PC Compatibility” (Macintosh) or “Enforce PC/Mac Compatibility” (Windows) if you want to create session and audio files that can be used in either Macintosh or Windows versions of Pro Tools. See “Creating Mac and PC Compatible Sessions” on page 111 for more information.
6. Select the Items to Copy to the new session.
7. Click Save.

Creating Custom Session Templates

You can create custom session documents that are pre-configured to the track setups, mixer setups, window arrangements, and zoom level memory locations that you use most frequently. Doing this will save you the trouble of having to create your studio setup from scratch every time you start a new session.

Creating Macintosh Templates

You can create a session template on the Macintosh by saving a session file as a Stationery Pad document. Once a session is saved as stationery, it acts as a template that you can open and then resave as a normal session.

To create a custom session template on the Macintosh:

1. Create a session and arrange Pro Tools as desired. You can also define the parameters within these windows, such as signal routings, insert and send configurations, track views, Ruler settings, and Preference settings.
2. Choose File > Save Session As.
3 Name the session and click Save.

4 Close the session.

5 Locate the session file that you just saved.

6 Click once on the file to select it.

7 Choose File > Get Info > General Information. A file information window appears.

8 Click the Stationery Pad check box to save the file as a template, then close the information window.

To use this template, double-click it or open it with the Open Session command if you are already running Pro Tools. You can create several custom templates for studio setups that you frequently use.

When you open a session saved as a Stationery Pad, Pro Tools gives you the option of editing the template or starting a new session using the template settings. If you choose New Session, Pro Tools will create a new folder containing a copy of your session template and Audio and Fades folders.

Creating Windows Templates

In Windows, you can create a session template by making a session file a Read Only document.

To create a custom session template in Windows:

1. Create a session and arrange Pro Tools as desired. You can also define the parameters within these windows, such as signal routings, insert and send configurations, track views, Ruler settings, and Preference settings.

2. Choose File > Save Session As.

3. Name the session and click Save.

4. Close the session.

5. Locate the session file that you just saved.

6. Right-click the file and choose Properties.

7. Under Attributes, deselect Archive and select Read Only.

8. Click OK.
To use this template, double-click it or open it with the Open Session command. When you first save the session, Pro Tools will ask you to give the session a new name. Your original session template will remain unchanged.

To modify the session template, you will need to reopen its Properties, deselect the Read Only option and select the Archive option, make your modifications, then change it back to a Read Only file.

**Closing a Session**

Because Pro Tools allows you to work on just one session at a time, you must close the current session if you want to work on another. The Close Session command closes your current Pro Tools session but leaves the Pro Tools application open. You can save your work using the Save Session or Save Session As command before closing the current session.

**To close a session:**
- Choose File > Close Session.

**Quitting Pro Tools**

Although Pro Tools will warn you before allowing you to quit without saving changes, you should generally save your work before quitting.

**To quit Pro Tools on the Macintosh:**
- Choose File > Quit.

**To exit Pro Tools in Windows:**
- Choose File > Exit.

---

### Sharing Sessions Between Pro Tools TDM Systems and Pro Tools LE Systems

Pro Tools makes it easy to share sessions between Pro Tools LE and TDM-equipped systems. There are some important differences between the two types of systems that can affect how session material is transferred.

**Differences between TDM and LE systems**

<table>
<thead>
<tr>
<th>Feature</th>
<th>TDM Systems</th>
<th>LE Systems</th>
</tr>
</thead>
<tbody>
<tr>
<td>Number of Tracks</td>
<td>up to 256 (HD-series), up to 128 (MIX-series)</td>
<td>limited to 24</td>
</tr>
<tr>
<td>Number of mix busses</td>
<td>64 busses</td>
<td>16 busses</td>
</tr>
<tr>
<td>Inserts per Track</td>
<td>up to 5 inserts</td>
<td>up to 5 inserts</td>
</tr>
<tr>
<td>Sends per Track</td>
<td>up to 5 sends</td>
<td>up to 5 sends</td>
</tr>
</tbody>
</table>

When opening a TDM session in Pro Tools LE, the following rules apply:
- Any tracks beyond the first 24, as well any inactive tracks, are discarded.
- Multichannel surround tracks are discarded.
- Any assignments to busses beyond 16 are made inactive.
- Input and output paths not available are discarded.
- TDM plug-ins with RTAS equivalents are retained; those without equivalents are made inactive.
Preferences

The Preferences dialog has several tabbed pages in which you can specify your preferred settings for various session parameters. Each new session will use these preferences.

Display Preferences

Recompute Invalid Overviews This option prompts Pro Tools to look for missing or corrupted overview data (the data used to create waveform displays) when it opens sessions. If Pro Tools finds that overview data is missing or corrupted, it will recreate one or more overviews for the session. This may take some time if there are many tracks in the session. If you suspect that overview data for a session has become corrupted, or if you import audio files which have no overview data into a session, make sure this preference is enabled for the session, save and close the session, then reopen it. Pro Tools will recreate any overviews for the session when it opens.

Draw Waveforms Rectified This option displays audio waveform data in rectified view. In this view, audio waveforms are displayed so that their positive and negative waveform excursions (the portions that fall above and below the center line) are summed together and viewed as a single positive-value signal. This view allows more waveform detail to be seen in either normal or reduced track height views. It can be particularly useful when editing volume automation data, since it depicts waveform levels as starting at the bottom of the track.

Draw Grids in Edit Window This option adds grid lines to the Edit window. Grid line resolution is based on the zoom level of the Edit window.

Mix Window Follows Bank Selection This option, which is only available if you are using a supported external MIDI controller, causes Pro Tools to scroll the Mix window to display the selected bank of tracks when you switch banks on the MIDI controller, ensuring that the current bank is viewable on-screen.

Edit Window Follows Bank Selection This option, which is only available if you are using a supported external MIDI controller, causes Pro Tools to scroll the Edit window to display the selected bank of tracks when you switch banks on the MIDI controller, ensuring that the current selection of tracks in the current bank is viewable on-screen.

Edit Window Default Length This option allows you to set a default length for the Edit window in hours, minutes, seconds, and frames. This capability is useful if you wish to assemble a session of a particular length or leave extra room to expand the Edit window’s work area in your session. There is a 13 hour maximum limit for the length of a Pro Tools session.

Show Meters in Sends View When the Sends View is displaying individual send controls, you can enable this option to show send level meters. If you are using a slower computer, you can disable this option to reduce the processing load on your CPU.
Edit Window Color Coding

Edit Window Color Coding determines how colors are assigned to the waveform display in the Edit window. Choices are:

None This option turns off color assignment to the waveform display of tracks in the Edit window.

Tracks and MIDI Channels Assigns a color to the waveform display of each track in the Edit window according to its voice number and MIDI channel assignment.

Tracks and MIDI Devices Assigns a color to the waveform display of each track in the Edit window according to its voice number and MIDI device type.

Groups Assigns a color to the waveform display of each track in the Edit window according to its group ID. If groups are suspended using the Suspend Groups command, all waveforms will be displayed in black.

Peak Hold Options

These options determine how long the peak indicators on track meters stay lit after a peak is detected. Choices are:

3-Second Peak Hold When selected, track meters display the last peak level for three seconds.

Infinite Peak Hold When selected, track meters display the last peak level until you click them to clear them.

No Peak Hold When selected, track meters do not hold the peak level.

Operation Preferences

Timeline Insertion Follows Playback This option causes the screen’s play cursor to update its location to the point where playback stops.

Edit Insertion Follows Scrub/Shuttle When selected, the edit cursor automatically locates to the point where scrubbing stops.

Support Background Record Applications Allows other audio recording applications to run in the background concurrently with Pro Tools. Files recorded in the background can be imported into Pro Tools, and then trimmed and viewed while recording continues.

Sends Default to –INF Sets the initial fader level of newly-created Sends to –∞ (no audible signal level).

Audio During Fast Forward/Rewind When selected, audio is audible during fast-forward or rewind.

Latch Record Enable Buttons When deselected, prevents multiple tracks from being record-enabled: Record-enabling a track takes any other track out of record-enabled mode.
Latch Solo Buttons When deselected, prevents multiple tracks from being soloed. Soloing a track mutes any track that is soloed.

Link Mix and Edit Group Enables When selected, links enabling and disabling of Mix and Edit groups: Enabling Group A in the Edit Window automatically enables Group A in the Mix window.

Use F11 Key for Wait for Note When selected, pressing the F11 Function key puts MIDI recording in Wait for Note mode.

Numeric Keypad Mode

Numeric Keypad Mode determines how the numeric keypad functions. You can always use the numeric keypad to select and enter values in the Event Edit Area, Location Indicators, and Transport fields.

Classic Emulates the way Pro Tools worked in versions earlier than 5.0. With the Numeric Keypad Mode set to Classic, you can play up to two tracks of audio in Shuttle Lock mode. Press Control (Macintosh) or the Start key (Windows), followed by 0–9 for different play speeds. Press Plus (+) or Minus (–) to reverse direction. Recall Memory Locations by typing the Memory Location number, followed by period (.).

Transport Allows you to set a number of record and play functions, and also operate the Transport from the numeric keypad. With the Numeric Keypad Mode set to Transport, you can play up to two tracks of audio in Shuttle Lock mode. Press Control (Macintosh) or the Start key (Windows), followed by 0–9 for different play speeds. Press Plus (+) or Minus (–) to reverse direction. Recall Memory Locations by typing the Memory Location number, and period (.) again.

Shuttle Selects a type of shuttling different from that of Shuttle Lock mode. With the Numeric Keypad Mode set to Shuttle, playback is triggered by pressing and holding the keys on the numeric keypad—playback stops once the keys are released. Various playback speeds are available in both forward and reverse. You can also recall Memory Locations by typing period (.), the Memory Location number, and period (.) again.

Autosave

This preference determines how the Autosave feature functions.

Enable Autosave When selected, Pro Tools automatically saves sessions while you work. Use the Keep and Save Every fields to specify the total number of incremental backups that are kept and how often the session is saved.

Online Options

Record Online at Time Code (or ADAT) Lock When selected, online recording begins as soon as Pro Tools receives and locks to time code or ADAT sync.

Record Online at Insertion/Selection When selected, online recording begins at the Edit cursor location. Recording continues until Pro Tools stops receiving time code. If you make a selection, Pro Tools records online for the length of the selection.
Open Ended Record Allocation

This preference determines how much of your available hard drive space is allocated for recording. Choices are:

Use All Available Space When selected, the drive’s entire available space is allocated. This can sometimes slow down the recording process for hard drives that use certain file systems, including HFS+ and NTFS.

Limit To Sets the maximum allowable recording duration. This can help reduce the time it takes to begin recording by allocating only a portion of your hard drive. The number of minutes specified is allocated for each record-enabled track. You may find it necessary to experiment with this number to achieve the desired performance for recording.

Machine Control

These preferences determine how a connected transport responds to Pro Tools. Choices are:

Machine Chases Memory Location When selected, navigating to a specific location in a session with a Memory Location causes a connected transport to chase to that location.

Machine Follows Edit Insertion/Scrub When selected, navigating to a specific location in a session by moving the selection point or by scrubbing a track will cause a connected transport to chase to that location.

Machine Cues Intelligently When selected, if you navigate to a cue point that is more than 10 seconds from the current location, Pro Tools will command a connected transport to shuttle to the desired location at full speed to within 10 seconds of the cue point. Cueing will then slow to normal speed until the point is reached. This significantly speeds up tape cueing.

Remote Mode

Punch In Frame Offset Sets an offset in frames to compensate for punch in timing advances or delays.

Punch Out Frame Offset Sets an offset in frames to compensate for punch out timing advances or delays.

Auto Regions Fade In/Out Length Sets a default length for fade-ins and fade-outs automatically applied to region boundaries. Using automatic fade-ins and fade-outs saves you the trouble of editing to zero-crossings or creating numerous rendered fades in order to eliminate clicks or pops in playback. Autofades are not written to disk. Value range is from 0–10 ms for the Auto Region Fade In/Out Length. A value of zero (the default) means that no auto-fading will occur. The Auto Fade value is saved with the session, and is automatically applied to all free-standing region boundaries until you change it.

Calibration Reference Level Sets a default calibration reference level in dB when Pro Tools is in Calibration mode.

Editing Preferences
Track Selection Follows Regions List Selection When selected, selecting a region in the Regions List causes Pro Tools to highlight that region's occurrence in a track.

Region List Selection Follows Track Selection When selected, selecting a region in a track also selects it in the Regions List.

Auto-Name Separated Regions When selected, Pro Tools automatically names newly separated regions by appending a number to the region's name.

Auto-Name Memory Locations When Playing When selected, Pro Tools gives new memory locations default names based on their time location in the session. The time units currently chosen in the Display menu determine the units for the names.

Recall Original Track Selections When selected, Memory Locations that recall a selection also recall the track in which the selection was made.

Crossfade Preview Pre-Roll This option specifies the amount of pre-roll to be added when you are auditioning crossfades in the Fades dialog.

Crossfade Preview Post-Roll This option specifies the amount of post-roll to be added when you are auditioning crossfades in the Fades dialog.

Default Fade Settings

Fade In Selects the default envelope shape for fade-ins.

Crossfade Selects the default envelope shape for crossfades.

Fade Out Selects the default envelope shape for fade-outs.

Conversion Quality Selects the sample rate conversion quality. Sample rate conversion is used in a variety of Pro Tools processes including converting and importing audio files of different formats into a session, and bouncing and saving tracks to a different sample rate or bit depth. The higher the quality of sample rate conversion you choose, the longer Pro Tools will take to process the audio file.

“Matching Start Time” Takes List

Command-clicking (Macintosh) or Control-clicking (Windows) in a track, will display a list of regions whose time stamp matches the current cursor location. The preferences that follow determine which takes appear in this list:

Take Region Names That Match Track Names When selected, only regions that share the same root name with the track and playlist appear in the Takes List pop-up menu.

Take Region Lengths That Match When selected, only regions that match the length of the current selection appear in the Takes List pop-up menu.

“Separate Region” Operates On All Related Takes When selected, editing a region with the Separate Region command also affects all other related takes with the same User Time Stamp. This option helps you compare different sections from a group of related takes.

QuickPunch Crossfade Length Specifies a default length for crossfades created by QuickPunch recording. Crossfades occur before the punch in and after the punch out.

Levels Of Undo Sets the maximum number of actions (up to 16) that can be undone with the multiple undo feature.
**Automation Preferences**

**Faders Move During Playback** When selected, faders move on-screen when automated. When deselected, faders do not move, but automation is still functioning.

**Smooth and Thin Data After Pass** When selected, automation is automatically smoothed and thinned by the amount specified with the Degree of Thinning option.

**Write Switches To Touch After Pass** After an automation pass in Auto Write mode, Pro Tools automatically switches to Auto Touch mode. On TDM systems you can choose to stay in Auto Write mode by deselecting this option.

**Mutes Follow Groups** When selected, muting a track that belongs to a Mix group mutes all other members of the group. When deselected, tracks must be muted individually.

**Solos Follow Groups** When selected, soloing a track that belongs to a Mix group solos all other members of the group. When deselected, tracks must be soloed individually.

**Send Mutes Follow Groups** When selected, muting a Send that belongs to a group mutes all other members of the group. When deselected, Sends must be muted individually.

**Send Levels Follow Groups** When selected, adjusting the level of a Send that belongs to a group adjusts the Send levels of all other members of the group. When deselected, Send levels must be adjusted individually.

**LFEs Follow Groups** When selected, adjusting or editing an LFE control that belongs to a group adjusts the LFE controls of all other members of the group. When deselected, LFE controls must be adjusted individually.

**Degree of Thinning** Specifies the amount of automation data thinning applied when automation is recorded. Avoid over thinning automation data or it may no longer accurately reflect the original pass.

**Touch Timeout** Specifies how quickly automation recording stops or “times out” after you stop moving a MIDI controller in Touch mode.

**AutoMatch Time** Specifies how quickly Pro Tools returns a fader or other control to its previously automated level after automation recording stops.

**Amount of Memory for Automation Recording** Allows you to reserve additional memory for recording automation. If you have dense automation data or a large number of automated tracks, increase this amount. Relaunch Pro Tools for this setting to take effect.
**Processing Preferences**

**AudioSuite Dither**

**Use AudioSuite Dither** When selected, applies dither to specific audio processing tasks.

**Dither Plug-In** Specifies the plug-in used for dither processing when the Use AudioSuite Dither option is selected.

**Edit Settings** When a Digidesign dithering plug-in is used, allows you to apply either normal or noise-shaping dither.

**Bit Depth**

**16-, 18-, 20-, and 24-Bit** allows you to select a bit depth for the dithered audio.

**AudioSuite Buffer Size**

Audio Suite Buffer Size sets the size of the memory buffer used for audio processing and previewing with AudioSuite plug-ins. Generally, choosing a smaller buffer speeds up AudioSuite audio previewing functions. Choosing a larger buffer speeds up AudioSuite processing functions. Set the buffer according to your current task. Before auditioning an AudioSuite plug-in, set the buffer to Mini or Small. When you process a file, set it to Large or Jumbo.

**TC/E**

**TC/E Plug-In** Allows you to choose the plug-in used for Time Compression and Expansion when you edit audio with the Time Trimmer tool. The Time Trimmer works by using Time Compression/Expansion to match an audio region to the length of another region, a tempo grid, a video scene, or other reference point.

**Default Settings** Specifies the default settings used by the chosen Time Compression/Expansion plug-in.

**Compatibility Preferences**

**Convert All Imported “WAV” Files To AES31/BroadcastWave** When selected, this option applies to all newly imported .WAV files, making them compliant with the AES31/EBU Broadcast standard.
Avid Compatibility Mode When selected, ensures that all imported OMF media files are treated as Read-Only and prevents destructive editing processes such as those used by the Pencil and Time Trimmer tools and AudioSuite processing.

MIDI Preferences

Play MIDI Notes When Editing When selected, causes MIDI notes to sound when you insert them with the Pencil or drag them with the Grabber.

Default Note On Velocity Sets the default Note On velocity for MIDI notes inserted in the Edit window and the MIDI Event List.

Pencil Tool Resolution Sets the default resolution for MIDI controller data created with the Pencil. Setting this to a lower resolution helps avoid creating controller data that is unnecessarily dense. The value range is from 1 to 100 milliseconds.

Global MIDI Playback Offset Sets an offset in samples to compensate for MIDI latency. Entering a value here has the same effect as setting an offset with the MIDI Track Offset command (Windows > MIDI Track Offset). Offset values can be positive (later) or negative (earlier).

MIDI Note Display Sets the reference for middle C as C3, C4, or MIDI note number 60.

Default Thru Instrument Sets the default MIDI Thru instrument from your available MIDI instruments.
Chapter 7: I/O Setup

The I/O Setup dialog provides tools to label, format, and map Pro Tools input, output, insert, bus, and SampleCell signal paths for each session. I/O Setup also lets you route the I/O ports on your Digidesign audio interface to Pro Tools inputs and outputs. On HD systems, the I/O Setup Dialog provides a graphical representation of the Hardware Setup, displaying your system’s audio interfaces and allowing you to mirror Hardware Setup routing. (SampleCell paths are available on MIX-series and Pro Tools|24 systems only.)

A signal path is a logical grouping of multiple inputs, outputs or busses that has a single name and (channel) format. In Pro Tools, paths are similar to stems, known to the film and video industries (see “Stems and Stem Mixes” on page 61 for more information).

The I/O Setup dialog lets you name and define these paths so that Pro Tools best suits the needs of your projects. For example, renaming Input 1 to Kick In.

Each Pro Tools system can have a different I/O Setup configuration, determined by:

- Whether it is a Pro Tools LE system, or a TDM-equipped Pro Tools system
- Whether it is an HD-series, MIX-series, or Pro Tools|24 system
- The number and types of audio interfaces (TDM systems only)
- The Mixer plug-in currently installed

Each Pro Tools session retains its path configurations as I/O Settings. The I/O Settings saved with the session are loaded into Pro Tools automatically when the session is opened. Unavailable items (including hardware, paths, or required resources) remain in the session as inactive items (see “Active and Inactive Paths” on page 69).

When you create new sessions you can specify a default I/O Setup configuration, including presets for stereo or multichannel mixing formats (multichannel mixing requires a Pro Tools|HD system, or Pro Tools|24 MIX system).

The I/O Setup dialog lets you customize signal path, as well as save and load I/O Settings files.
Number of Busses (TDM Only)

Pro Tools 5.3 supports up to 64 busses for TDM systems. However, when opening 5.0.1 (or earlier) sessions, only 32 busses are initially available.

To make 64 busses available in 5.0.1 (or earlier) sessions:
1. Open the I/O Setup dialog.
2. Click the Bus tab in the upper left.
3. Click the Default button.

Paths in Sessions

During sessions, audio is routed using the track Input, Output, Insert, Plug-in, and Send Selectors. The selectors let you assign tracks to hardware outputs and inputs, internal busses, and other Pro Tools signal paths.

Paths comprise the lists of available choices in track I/O Selectors and other menus.

Paths and I/O Setup

The signal routing choices available in track I/O Selectors are defined in the I/O Setup dialog.
Main Paths and Sub-Paths

Paths in the I/O Setup dialog include main paths and sub-paths.

Main Paths

Main paths are logical groupings of inputs, inserts, busses, or outputs. For example, Main Out is often the name of a master stereo output. Sometimes appended with “L/R” for left/right, this is an example of a signal path named by its content (the main stereo mix).

Sub-Paths

A sub-path represents a signal path within a main path. For example, a default stereo output path consists of two mono sub-paths, left and right. Mono tracks and sends can be routed to either mono sub-path.

Naming and defining sub-paths (of main paths) is especially useful for complex mixing, such as 5.1 Surround.

Default I/O Settings

Default path definitions are installed automatically by Pro Tools, so you can begin recording and mixing without requiring any configuration of the I/O Setup dialog. Default I/O Settings files configure the I/O Setup dialog with a combination of mono and stereo path definitions of all types, depending on your system and hardware configuration. As mixing and signal routing needs require, you can customize the I/O Setup configuration in numerous ways (see “The I/O Setup Dialog” on page 62).

Multichannel settings files are available for Pro Tools HD-series and MIX-series systems. These settings provide specialized path definitions for surround mixing. See “Configuring Pro Tools for Multichannel Sessions” on page 432.

Defaults

Default names for input, output, and insert paths are based on your audio interface’s name and its available channels.

Stems and Stem Mixes

The use of stems and stem mixes originated in the post production industry as a method to organize and manage elements of a mix by type or content.

For example, a film mix often requires a stem mix for Foley, a stem mix for sound effects, a stem mix for dialog, another for music, and so on. The dialog stem (for just one example) contains all the dialog elements, mixed relative to each other. Dialog can then be mixed with the other stems during the final mix of the scene or reel. The final mix is simplified (somewhat) by the ability to control the level of each stem, rather than the multitude of individual tracks that comprise a typical film mix.

In Pro Tools, you can work with main and sub-paths as you would stem mixes. These can be assigned as needed, including the ability to assign multiple outputs to tracks and sends. For more information, see “Multiple Output Assignments” on page 344.
The I/O Setup Dialog

The I/O Setup dialog defines Pro Tools input, output, insert, and bus paths. Routing I/O ports to Pro Tools inputs and outputs can also be done here.

To open the I/O Setup dialog:

1. Make sure your audio interfaces are enabled and configured properly in the Hardware Setup.
2. Choose Setups > I/O Setup.

To open the Input, Output, Insert, Bus or SampleCell window in I/O Setup:

- Click the appropriate tab at the top of the I/O Setup dialog.

Closing the I/O Setup Dialog

You can click Cancel at any time to close the I/O Setup dialog. However, when you click OK Pro Tools must check several settings for routing validity (to prevent feedback loops and other possible dangers). If there are any overlapping or otherwise invalid settings, you will be required to correct them before the I/O Setup dialog will close. For more information, see “Initializing I/O Setup” on page 68.
Chapter 7: I/O Setup

Controls in I/O Setup

This section provides an overview of the following I/O Setup controls.

Path Type Tabs Select the type of I/O to configure. Choices are Inputs, Outputs, Inserts, Busses, or SampleCell. (SampleCell paths are available on MIX-series systems only.)

Input and Output Selectors Selects physical ports on your I/O peripheral to route to Pro Tools inputs and outputs. Selections are made in channel pairs. Available ports for each displayed interface are based on Hardware Setup settings; for example, if the AES/EBU inputs and outputs of an interface are enabled in Hardware Setup, they are available for routing in I/O Setup. The functionality provided with the Input and Output Selector is the same as that provided on the Main page of the Hardware Setup dialog.

Path Name Column Shows paths that are available for selection, including the user-defined name of each defined path.

Expand/Collapse Shows/hides the sub-paths associated with a main path.

Active/Inactive Shows and changes the active/inactive status of each path.

Path Format Selector Shows and selects the type/format (mono, stereo, 5.1, and so on) of each defined path.

Channel Grid Maps paths to specific I/O units and channels.

Path Tools Customize the I/O Setup configuration. Buttons include: New Path, New Sub-Path, Delete Path, and Default.

Show Original Setup Displays in the I/O Setup dialog in certain session transfer situations. For details on this feature, see “Show Original Setup and Show Current Setup” on page 71.

Options Provide pop-up menus to set paths or orders for Meter, Audition (Regions List previewing), Default Output (for new tracks), and Default Path Order. See “Default Output, Meter, Audition, and Default Path Order I/O Setup Options” on page 73.

Routing Hardware I/O to Pro Tools I/O

The I/O Setup dialog lets you define which physical ports on your I/O peripheral are routed to Pro Tools inputs and outputs. The Input and Output Selectors in I/O Setup serve as a patch-bay that allows you to route any of the physical inputs or outputs to your Pro Tools Mixer.

To configure I/O routing in I/O Setup:

2. Click the Input, or Output tab to display the appropriate window.
3. Click on the Selector for the first channel pair, located below the first audio interface display.
4 From the pop-up menu, select a physical port pair (such as Analog 1–2), that will be routed to a Pro Tools input or output channel pair (such as Ch 1–2).

5 Repeat the above step for other channel pairs, and other audio interfaces.

6 When finished, click Ok.

Refer to the guide for your audio interface for sample rate, and other restrictions. For example, the Optical 1–8 channels will not be available for session rates of 88.4 or higher.

To route a Pro Tools output pair to multiple audio interface output ports:

2. Click the Output tab.
3. Click on the Output Selector for the output pair from which you will be routing signal.
4. From the pop-up menu, select a physical port pair (such as Analog 1–2).

5 Ctrl+Shift an additional output destination.

The output name updates with a plus sign (“+”) before it.

To verify which output ports have been routed, select the original output: In the pop-up menu, each output assigned to the Pro Tools output channel pair will have a check mark next to it.

6 Select additional output destinations, as desired. The only limit to output choices is the number of outputs available in your system.

Pro Tools outputs pairs can also be routed to multiple audio interface outputs in Hardware Setup. For more information, see “Hardware Setup” on page 39.

Creating and Editing Paths

The I/O Setup dialog lets you create and customize signal path definitions.

Paths can be:
- Renamed, for easier identification after changing or renaming audio interfaces
- Remapped, to or from different sources or destinations
- De-activated (or re-activated) to manage unavailable or unnecessary I/O resources
- Deleted

In addition, you can import and export your I/O Setup configurations as I/O Settings files, as well as set numerous default path parameters.

The following table lists the available path attributes for each path type.

<table>
<thead>
<tr>
<th>Path Type</th>
<th>Path Options (Attributes)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Input</td>
<td>Names, formats, and source channel (analog or digital audio interface, or CPU input)</td>
</tr>
<tr>
<td>Output</td>
<td>Names, formats, and destination (audio interface output channel or internal send bus)</td>
</tr>
<tr>
<td>Insert</td>
<td>Names, formats and destination (audio interface channels)</td>
</tr>
<tr>
<td>Bus</td>
<td>Names and formats</td>
</tr>
<tr>
<td>SampleCell (MIX-series only)</td>
<td>Input names</td>
</tr>
</tbody>
</table>
**Creating a Default Main or Sub-Path**

You can add (or reset) default paths to your current I/O Setup path (such as Input, Output, and so on) at any time.

**To add default mono or stereo paths:**
1. Choose Setups > I/O Setup.
2. Click the Input, Output, Insert, Bus, or SampleCell tab to display the appropriate path window. (SampleCell paths are available on MIX-series systems only.)
3. Click Default.

Pro Tools creates all possible stereo main paths. Mono sub-paths are also auto-created for every stereo main path. The path names are appended with their associated format—mono or stereo—in parentheses (when viewed with track Input or Output Selectors).

**Creating New Paths**

You can create new main path and sub-paths with custom names, format, and mapping.

**To create a new path:**
1. Choose Setups > I/O Setup.
2. Click the Input, Output, Insert, Bus, or SampleCell tab to display the appropriate path window. (SampleCell paths are available on MIX-series systems only.)
3. Click New Path, or press Command+N (Macintosh) or Control+N (Windows). Or, select a main path and click New Sub-Path.
4. Double-click in the Name field and enter a name for the path. (The path name is what is listed in Pro Tools track routing selectors.) Press Tab to move to the next editable field, or press Enter to set the new path name (pressing Return will close the I/O Setup dialog).
5. Choose a format from the Path Format Selector. (Path Format controls whether the path is mono, stereo, or multichannel.)
6. Configure other path types (Input, Output, Insert, Bus, or SampleCell) and configure them using the same techniques described in the previous steps.

Tip: To optimize mixer and DSP resources, it’s best to create mono sub-paths for Outputs and Busses, rather than create mono main paths.
7 Click OK (or press Return) to close the I/O Setup dialog. If there are any overlapping or identically named paths, you will be instructed to correct them before the I/O Setup dialog will close. For more information, see “Initializing I/O Setup” on page 68.

Multichannel paths and mixing are explained in Chapter 31, “Pro Tools Setup for Surround.”

Selecting and Editing Paths

Individual and multiple paths can be selected in the I/O Setup dialog Path Name column. Once selected, paths and sub-paths can be moved higher or lower to sort their listing in track Path Format Selectors, renamed, remapped, or reformatted. Paths can also be deleted. Sub-paths follow their main paths when editing in the I/O Setup dialog.

To select a main path or sub-path:

- Click the path name.

To select multiple main paths and/or sub-paths:

- Shift-click the desired path names.

To rearrange path names:

- Drag one or more path names up or down.

Resetting Paths

The Default button in the I/O Setup dialog provides two primary functions:

- Creates new, default paths up to the capacity of your system’s available audio interfaces and resources. See “Creating a Default Main or Sub-Path” on page 65.

- Resets selected path names to matching or corresponding paths in the current I/O Setup configuration. For example, if you change modes on Digi 001, or replace an audio interface on a Pro Tools HD-series or MIX-series system, you can use the Default switch to update your I/O Setup definitions with the new hardware configuration (for path naming).

On TDM systems, audio interface names can be customized. See “TDM Audio Interface Names” on page 66.

To reset path names:

- Click Default.

Assuming there are matching paths available with the new system configuration, existing paths will be updated to include new audio interfaces (TDM systems), or I/O mode selection (Digi 001 only).

TDM Audio Interface Names

With TDM-equipped Pro Tools systems, audio interfaces can be custom named in the I/O Setup dialog. The I/O Setup dialog bases default path names on the name shown above the graphic representation of each interface.
To rename an audio interface in the I/O Setup dialog:
- Double-click the text above an interface, enter a new interface name, and press Enter.

Interface name

Deleting Paths
Path definitions can be deleted from the current session to reflect changes to your hardware setup, or to clean up track selector menus by removing unwanted or unnecessary path definitions. After deleting a path, any tracks or send assignments to it are reset to No Output.

To delete a main path or sub-path:
1. In the I/O Setup dialog, select the path you want to delete.
2. Click Delete Path.

To delete all paths:
1. Option-click on any path name.
2. Click the Delete Path button or press the Delete key.

Channel Mapping
Once a path has been created and formatted, it can be mapped to specific audio interface, bus, or SampleCell channels in the Grid.

To map channels:
1. Select a main or sub-path.
2. In the row for the selected path, click in the Grid column under the desired audio interface and channel. Other channels, if any, fill to the right.

Mapping channels
For example, when mapping a new stereo path, clicking in the path row under output channel 1 fills both channel 1 and 2 (left to 1, right to 2).

To remap channels in a path, refer to “Remapping Channels” on page 68.

Channel and I/O Status Display
The Channel Grid uses different shades of gray to highlight different I/O status:

White Indicates channels available for the path.

Medium Gray Indicates I/O that overlaps with other path definitions (possible with Output and Bus path arrangements, though with limitations as described in “Overlapping Channels and Valid Paths” on page 69).

Dark Gray Indicates channels that are unavailable for sub-path assignment.

Light Gray Indicates extra space beyond recognized audio interfaces.

See “Valid Paths and Requirements” on page 68 for details.
Note for Session Transfer

Pro Tools shows paths for unavailable I/O until they are explicitly re-assigned to valid paths, or deleted. See “Active and Inactive Paths” on page 69 for more information.

Channel Mapping and Surround Mixer
(Pro Tools HD-Series and MIX-Series Systems Only)

When mapping multichannel paths, L is mapped first to the clicked Grid box, and remaining channels fill immediately to the right according to the default path order. Because some multichannel mixing formats use unique track layouts, Pro Tools lets you set the default format in the I/O Setup dialog (see “Default Output, Meter, Audition, and Default Path Order I/O Setup Options” on page 73).

Remapping Channels

You can move the individual assignments to different channels, to re-order the path’s definition (for example, changing a multichannel map to L-R-C-Sub-LS-RS).

To remap channels in a path:

- Drag the channel to the new location in the Grid. Other channel assignments will move (shuffle) to accommodate dragged channels.

Channel Shuffling

Moving a signal from right to left results in a shuffle of other signals after the new destination channel. Moving a signal from left to right shuffles any and all signals after the new destination channel and leave the previous channel empty.

Changing a path’s format erases any current channel mapping.

Sub-Paths Follow Main Paths

When a main path is remapped, its sub-paths (if any) will remap automatically to maintain consistent routing. For example, remapping a stereo path to different hardware outputs results in any of its sub-paths moving with it.

Initializing I/O Setup

To set the current I/O Setup configuration:

- Click OK in the I/O Setup dialog.

All paths must be valid before the I/O Setup configuration can be applied.

Valid Paths and Requirements

While configuring the I/O Setup window, certain rules apply for path definition and channel mapping.

Though it is possible to set up invalid mappings in the Channel Grid, Pro Tools will not accept (OK) an I/O Setup configuration unless all paths meet the path definition and channel mapping requirements described below.
Minimum Path Definitions

All paths must have a name, be of a specific format, and have a valid I/O mapping.

Overlapping Channels and Valid Paths

Channel mapping follows certain rules regarding overlapping paths.
- There can be no partial or complete overlaps between any two main Output paths, any two Insert paths, or any two main Bus paths.
- A newly-created Output or Bus path must either be completely independent of other maps (not mapped to any other available I/O interface/channels), or it must be a sub-path completely contained within a larger path (for example, an LCR sub-path within a larger 5.1 path).
- Output and Insert paths can overlap in I/O Setup, but only one or the other can be used at any given time in a session. (Inputs and Sample-Cell paths, however, can be routed to multiple tracks.)

Active and Inactive Paths

Pro Tools paths can be Active (on) or Inactive (off, or unavailable). You can manually switch paths between Active or Inactive on a per track or session-wide basis. In addition, Pro Tools sets paths to Inactive automatically when I/O is unavailable.

Track Path Assignments

Track input, output, and bus path assignments can be switched to Inactive using the appropriate selector on the desired track. Doing so leaves track playlists intact, while disconnecting that particular track from the output or bus path. Use this to remove a track from a signal path.

Session-Wide Path Assignments

Paths can be globally activated or de-activated in the I/O Setup window. Use this to turn off a signal path on any and all tracks currently assigned to it. Pro Tools also sets unavailable paths to inactive. Paths can be unavailable when hardware or other system resources are unavailable, such as when opening a session last saved on a different system.

Track Path Assignments

(Mix and Edit Windows)

To toggle a track path assignment to Active or Inactive:
- In the Mix (or Edit) window, Command-Control-click (Macintosh) or Control-Start-click (Windows) the track’s Input, Output, Insert, or Send Selector.

Inactive track path assignments are indicated with an asterisk (*) in its track selector menu. (Paths set to globally inactive in the I/O Setup window are listed in italics.)

Toggling All or All Selected

The Option (Macintosh) and Alt (Windows) modifiers apply the path toggle to all tracks. The Option+Shift (Macintosh) or Alt+Shift (Windows) modifiers apply the path toggle to all selected tracks. However, Pro Tools will only apply the change to identical path assignments, if any, in the current track or tracks. In other words, toggling multiple tracks only affects tracks that have the same path assignment as the one you are explicitly toggling.
Toggling Multiple Paths

If a track has only one main output assignment, you can Command-Control-click (Macintosh) or Control-start-click (Windows) the track’s Output Selector to toggle the main output to inactive. When there are multiple assignments, the track selector will be displayed for you to specify the input, output, insert, or bus path.

If a Send (A–E) has multiple output assignments and one of those is toggled, then all of the output assignments for that Send (A–E) will be toggled.

Session-Wide Path Assignments
(I/O Setup Dialog)

Paths can be globally configured for Active or Inactive status in the I/O Setup Dialog.

Display of Active and Inactive Status

Unhighlighted (Italics) Indicates the path is inactive.

Highlighted (Non-Italics) Indicates the path is active.

Highlighted (Italics) Indicates the path is active, but there are not enough system resources available.

To globally de-activate or activate a path:

1. Choose Setup > I/O Setup.
2. Select the appropriate path type using the tabs at the top of the window.
3. For the desired (or, undesired) path, set the Active/Inactive control to the appropriate choice.

Any track path assignment can also be de-activated on a per-track basis. See “Active and Inactive Paths” on page 69

Inactive paths are displayed in italics in the track path selectors.

Hardware Setup and Session Transfer

Sessions created in Pro Tools 5.1 and later store the type and order of audio interfaces connected and active when the session was last saved.

Unavailable I/O

When opening any session, Pro Tools checks to see if the hardware configuration has changed since the session was last saved. If the current hardware configuration differs from that saved in the session, paths associated with the unavailable I/O are made inactive.
Remapping

Remapping occurs when a session's original I/O Setup does not match that of the current system and session paths are remapped to current hardware.

Systems of equivalent I/O capability are remapped directly. For example, a session tracked to a Pro Tools HD-series system through two 192 I/O Audio Interfaces would include 32 Input paths spread across the two 16-channel interfaces. Later, for additional editing, the session is taken to a different Pro Tools system that has a 96 I/O Audio Interface (a 16-channel I/O unit) with a 1622 Audio Interface (a 16-channel I/O unit) connected to its Legacy Port. When the session is first opened on the system with the 96 I/O and 1622 Audio Interfaces, Pro Tools maps those input paths to the most appropriate inputs of the two interfaces, left-to-right. (Mapping will depend on mono and stereo track format and arrangement in the Mix and Edit windows.)

When hardware is unavailable to a session being opened, assignments can either be replaced using the remap option, or opened as Inactive. Any tracks left assigned to an unavailable path will not be audible. This can be beneficial, however, when you want to re-assign tracks into your system’s mix one at a time.

See “Active and Inactive Paths” on page 69 for more information.

Show Original Setup and Show Current Setup

When a session is opened that contains path definitions for unavailable I/O modules, the I/O Setup dialog lists those paths in italics. The Show Original Setup button displays the audio interfaces used in the original session. This temporary display lets you check the original I/O configuration for reference while configuring the session for your system.

Once a session has been opened with unavailable I/O retained, you can then re-assign tracks to available I/O paths.

To redefine the paths, see “Creating and Editing Paths” on page 64.

I/O Settings Files

I/O Settings can be managed when transferring sessions, and when developing I/O Setup configurations over the course of multiple sessions and projects.

Defaults, Settings Files, and Last Used Settings for New Sessions

When creating new sessions, you can select the session’s I/O Setup configuration from among numerous options:

Default I/O Setups The Pro Tools Installer provides factory presets for stereo and surround I/O Setups (surround mixing is only supported on Pro Tools HD-series and MIX-series systems). See “Factory I/O Settings Files” on page 72 for more information.

Custom Presets You can store and recall custom presets using the export and import features of the I/O Setup dialog.

Last Used The most recent (or, last used) I/O Setup configuration is saved as a Last Used settings file. See “Last Used” on page 72 for more information.
Default I/O Settings at First Launch

The first time you create a session, you can choose default Stereo Mix or Surround Mix settings, depending on your system and installation choices. See “Factory I/O Settings Files” on page 72.

Importing and Exporting I/O Settings Files

You can export and import I/O Setup configurations as I/O Settings files. This lets you save settings for different projects, import settings for quick reconfiguration, and manage path definitions and signal routing setups.

Exporting I/O Settings

To export and save an I/O Setup configuration:

1. Click the Export Settings button.
2. Name and save the settings file.

To start sessions with a blank or empty I/O Setup dialog, you must create and export a user setting file in which all definitions have been deleted.

Importing I/O Settings

I/O Settings can be imported into the current session. When doing so, you can choose to delete your system’s existing (last used) path definitions and replace them with settings being imported. Or, you can retain both your current and imported settings. Imported paths are added to the current configuration.

To import an I/O Settings file:

1. Click Import Settings in the I/O Setup dialog.
2. Select the desired settings file in the dialog.
3. You will be asked whether you want to delete, or retain, existing paths.

Select Yes to remap the original session path definitions to your current hardware setup of audio interfaces, left to right. The session will no longer have any references to or record of the original I/O assignments. When old path definitions are deleted, associated assignment and automation data is also deleted.

Select No to add session paths to the current system’s I/O Setup. If you cancel the remap option, the original I/O assignments remain in the session. Unavailable I/O results in paths opening as Inactive. In the session, you can then re-assign tracks to available paths as needed, based on their original (and inactive) I/O Setup and hardware configuration. See “Active and Inactive Paths” on page 69 for more information on utilizing inactive paths.

Last Used

If any changes are made to the I/O Setup dialog during a session, these changes are saved to the Last Used settings file when the I/O Setup dialog is closed (by clicking OK).

Changes to I/O Setup are only saved in the current session, when the session is saved. User Presets files will not contain recent changes unless you explicitly export an updated settings file.

The Last Used settings are available as a choice (or default) when creating or opening sessions, in addition to the factory presets described below.

Factory I/O Settings Files

Pro Tools provides I/O Settings files for Stereo and Surround mixing. These files provide generic main and sub-path definitions for either mixing format.
**Stereo Mix Settings File**

The Stereo Mix preset consists of all possible stereo and mono paths for your session.

> Using the “Stereo Mix” preset has the same effect as hitting the Default button for every individual tab in I/O Settings. See “Creating and Editing Paths” on page 64 for details.

Specifically, the Stereo Mix preset will create the maximum number paths of each type, as determined by the available system’s I/O Setup and hardware configuration.

**Surround Mix Settings File (TDM Systems Only)**

The Surround Mix provides additional, surround-specific Output and Bus presets. See “Surround Mix Settings Files” on page 433 for more information.

**About Direct Out Mode**

Direct Outputs mode, as found in older versions of Pro Tools, has been replaced by the default mono sub-paths available through all valid I/O in the I/O Setup dialog.

The Default switch creates main Output paths with appropriate mono sub-paths. These sub-paths provide discrete monophonic routing.

When a session is opened that was saved in Direct Outputs mode, Pro Tools maps all the output assignments to equivalent mono sub-paths (as available). See “Hardware Setup and Session Transfer” on page 70 for more information on remapping.

To convert a session so that it emulates Direct Outs mode, use the Auto Assign Ascending Outputs feature:

1. Make sure that all tracks are visible if desired (because the hidden tracks will not be affected).
2. Select all desired tracks (Shift-click each track name).
3. Command-Option-click (Macintosh) or Control-Alt-click (Windows) the Output Selector of the left-most track and assign it to the sub-path for Output #1. All visible tracks will be auto-assigned to unique mono sub-path outputs in ascending order.

---

**Default Output, Meter, Audition, and Default Path Order I/O Setup Options**

Pro Tools systems have additional I/O Setup features. These include default signal routing for metering and auditioning, and default track layout for multichannel mix formats.

**Default Output Path**

You can specify the default Output path assignment for new tracks, in each available format.

**To specify a default Output in I/O Setup window:**

- Select a format and Output path from the default Output Selector.

---

### Selecting default Output paths

---

Chapter 7: I/O Setup 73
**Audition Path**

The Audition path is the output path through which files and regions are previewed (listened to) in the Regions List.

**To audition regions in the Regions List:**
- Option-click (Macintosh) or Alt-click (Windows) the region in the list.

**Using Default Audition Path**

When you audition a file or region in the Regions List, Pro Tools routes the audition through the Audition path. Pro Tools assigns a default Audition path to the first main Output path of the given format available. As an alternative, you can pre-configure Region List previewing using the Audition Path Selector in the I/O Setup dialog.

*In TDM systems with more than one audio interface, you can only select the first audio interface as an Audition path (output). Select the Audition path from the Audition pop-up menu in I/O Setup.*

**Configuring Audition Paths**

You can specify the monitoring outputs for Regions List auditioning on a per-format basis using the Audition paths menu.

**Audition Path Main Menu** The main menu consists of all path format choices available on the current system (Mono and Stereo on all systems, LCR and greater on surround-capable systems).

**Audition Path Submenus** Each path format choice has a submenu listing Output paths of that given format. (The mono submenu lists Output paths of any format.)

**To configure Audition Paths:**
- Select the desired path from the Audition path menu or submenus.

**Selecting default Audition paths**

**Auditioning Discrete Signals in Multichannel Items**

In the Audio Regions List, multichannel regions are auditioned through the current Audition path. Signals can be auditioned “in-place,” or through all outputs, as described below.

**Audition In-Place**

When auditioning a mono component of a multichannel region, that mono component will by default be auditioned in-place. That is, it will play out the corresponding speaker channel of its parent multichannel region.

**To audition in-place:**
1. In the Regions List, make sure the stereo or multichannel region is in expanded view (showing .L,.R, and other component channels).
2. Option-click (Macintosh) or Alt-click (Windows) the region for the desired channel.

**Audition to All Outputs**

Mono regions can be routed equally to all outputs of the parent region’s Audition path.
To audition through all channels of the main audition path:

- Shift-Option-click (Macintosh) or Shift-Alt-click (Windows) on the signal in the Regions List.

**Default Path Order**
*TDM Systems Only*

The Default Path Order Selector lets you select the default track layout you want Pro Tools to follow when creating and mapping 5.1-format main or sub-paths in the I/O Setup dialog.

This setting does not affect existing path definitions or metering—it only specifies channel mapping in new 5.1-format paths.

**To choose a Default Path Order:**

- Select the channel mapping from the Default Path Order menu.

```
✓ L C R Ls Rs LFE (Film)
 L R C LFE Ls Rs (SMPTE/ITU)
 L R Ls Rs C LFE (DTS)
```

**Default Path Order Selector**

For more information about multichannel mixing, see Chapter 31, “Pro Tools Setup for Surround.”

**Meter Path Selector**
*ProControl Users Only*

The Meter Path Selector determines the path displayed across the ProControl Output meters. See the latest ProControl documentation for more details.
This chapter covers basic track management tasks such as creating and deleting tracks, assigning voices and output channels, and grouping tracks.

**Track Types**

In a Pro Tools session, you can have several different types of tracks. These can include audio tracks, Auxiliary Input tracks, MIDI tracks, and Master Fader tracks. On a Macintosh system, a session can have a QuickTime, AVoption, or AVoption XL Movie track.

*QuickTime Movie track features are described in Chapter 36, “Working with QuickTime Movies.”*

**Audio Tracks, Auxiliary Input Tracks, and Master Fader Tracks**

Pro Tools provides mono, stereo, and multichannel format audio tracks, Auxiliary Inputs, and Master Faders.

**Audio Track**

Audio tracks contain arrangements of recorded (or imported) audio files. Audio tracks can be mono, stereo, or multichannel surround (Pro Tools HD-series and MIX-series systems only).

**Auxiliary Input Track**

Auxiliary Input tracks can be used as effects sends, destinations for an alternate mix, as a bounce destination, as inputs to monitor or process audio (such as audio from MIDI sources), and for many other audio routing tasks.

**Master Fader Track**

Master Fader tracks control the overall level of the audio tracks that are routed to the session’s main output “paths.” For example, you could have 24 tracks, with Pro Tools channels 1–8 routed to Analog Output 1–2, channels 9–16 to Analog Output 3–4, and channels 17–24 to Analog Output 5–6. You could then create three master faders to control each of these eight-channel groups.

**MIDI Tracks**

MIDI tracks store MIDI note, instrument, and controller data. There is no option for selecting the track format when you create a MIDI track, because audio does not pass through it.

**Track Formats**

**Mono**

A mono audio track, Auxiliary Input, or Master Fader track controls volume, and, in some cases, panning, for a single channel of audio. A mono track uses a single voice.
**Stereo**

A stereo audio track, Auxiliary Input, or Master Fader track is a single channel strip that plays two channels of audio as a stereo pair. Stereo tracks use two voices.

**Multichannel Surround (Pro Tools HD-Series and MIX-Series Systems Only)**

A multichannel track is a single channel strip that plays multiple channels of audio (from 3–8 channels at a time). This allows Pro Tools to support multichannel mixing formats including 3+1, 5.1, 6.1, and others.

For more information on surround mixing with Pro Tools, see the following chapters:

- Chapter 31, “Pro Tools Setup for Surround”
- Chapter 32, “Multichannel Tracks and Signal Routing”
- Chapter 33, “Surround Panning and Mixing”

**Audio Track/Channel Strip**

Each audio track has its own set of controls for volume, pan, panner window, record enable, automation mode, solo, mute, comments, and (on TDM systems) voice assignment.

With slight variations, audio track channel strips in the Mix window look like the following mono audio track. Stereo audio tracks have two level meters and two pan controls; multichannel tracks (3–8 channels) have one level meter for each audio channel.

Audio tracks can be added to a session with the New Track command.
MIDI Track/Channel Strip

Each MIDI track has its own set of controls for volume, pan, record enable, automation mode, solo, mute, MIDI patch assignment (program change), and MIDI channel assignment. MIDI tracks can be added to a session with the New Track command.

Input/Output View

The I/O View shows Input and Output Selectors on audio and MIDI tracks. Both types of tracks show volume and pan values in this view. For details on Input and Output Selectors, see “Assigning Inputs and Outputs to Audio Tracks (and Other Tracks)” on page 84.

To show the I/O View:

- Select Display > Mix Window Shows (or Edit Window Shows) > I/O View.

Level/Peak/Channel Delay Indicator

The Indicator on an audio track has three modes: Level Indicator, Peak Indicator, and Channel Delay Indicator. Command-click (Macintosh) or Control-Click (Windows) this button to toggle between these modes.

Level Indicator Shows the current volume, or input level of a track as set by the track Volume Level fader.

Peak Indicator Functions as a headroom indicator based on the last peak playback level. To reset the peak counter, click anywhere in the meter. Values range from +6 dB (highest level signal), to ∞ (no signal).

Channel Delay Indicator Shows the total delay, in samples, incurred on the track, specifically from the use of any TDM plug-ins on that channel.

Pan Indicator

The Pan Indicator displays the current pan setting of a track. Pan values range from <100 (full left) to 100> (full right). Pan controls are only available for stereo tracks or mono tracks routed to a stereo output.

Pan Slider

The Pan slider controls the balance of a track between the assigned output pair. It only appears if you are using stereo tracks or mono tracks routed to a stereo output.

The Pan slider on a MIDI track is only effective if you are controlling a sound module that supports MIDI panning.
**Track Level Fader**

The track level fader controls the volume of a track when it is in playback, and the monitor level of the track when it is in record. You can link the record and monitor levels by enabling the Operation Preference for “Link Record and Play Faders.”

The level fader on a MIDI track is only effective if you are controlling a sound module that supports MIDI volume.

**Track Level Meter**

On audio tracks, level meters indicate the level of the signal being recorded or played back from the hard drive. Green indicates nominal levels; Yellow indicates pre-clipping (–6 dB below full scale); and Red indicates clipping. When a track is record-enabled, these meters indicate record levels.

You can globally set level meters to indicate pre- or post-fader levels by selecting or de-selecting Operations > Pre-Fader Metering. When pre-fader metering is selected, the level meters show levels independent of fader position. With post-fader metering, the level meters respond to fader position.

If clipping occurs, the topmost LED will stay lit (red). In addition, Pro Tools meters provide a peak hold feature with three options:

**To choose a peak hold setting:**
- Choose Setups > Preferences, click Display, and select one of the Peak Hold options: 3 Second Peak Hold, Infinite Peak Hold, or No Peak Hold.

**Clearing a Meter**

You can clear a meter’s clipping or peak hold indicator by clicking anywhere on the meter.

**To clear meters:**
- Option-click (Macintosh) or Alt-click (Windows) any meter.

On MIDI tracks, the level meter shows the MIDI velocity of the most recent MIDI event.

**Track Comments View**

The Comments View shows any comments entered in the Track Name/Comments dialog. You can also type directly in the Comments area for each track when it is displayed.

**To display the Comments View:**
- Select Display > Mix Window Shows (or Edit Window Shows) > Comments.

---

**Creating Tracks**

On all systems, you can create mono and stereo tracks with the New Tracks command. In addition, on Pro Tools HD-series and MIX-series systems, you can create multichannel tracks.

When new tracks are created, they are given a default name which can be changed at any time by double-clicking the track name and typing in a new name.

**Before you create new tracks:**
- For new tracks to appear next to a specific track in a session, select that track by clicking its name (in its track channel strip). The new tracks are added immediately after the selected track.
- For new tracks to appear as the last tracks in a session, make sure that no track names are selected on-screen.
To create a new track:


2. Select from the Track Type pop-up menu the type of track you want to add. For explanation of track types, see “Track Types” on page 77.

3. Select Mono or Stereo (or one of the multi-channel surround formats) from the Track Format pop-up menu. Surround formats only appear for Pro Tools HD-series and MIX-series systems.

4. Enter the number of new tracks, then click Create.

5. To configure which track controls appear in the Mix window or Edit window, select from Display > Mix Window Shows and Display > Edit Window Shows.

Naming Tracks and Adding Track Comments

Besides assigning a name to a track channel strip, track names are used to auto-name recorded audio files and regions (see “Track Names” on page 122).

To rename a track or add comments:

1. In the Edit window or Mix window, double-click the Track Name button for the track you want to rename.

2. In the Track Name/Comments dialog, type a new track name.

   – or –

   Click Previous or Next to rename another displayed track.

3. If desired, type comments for the track in the Comments text box.

4. When you are finished, click OK.
Deleting Tracks

When you delete tracks, your audio or MIDI region data will remain in the Regions List, but your arrangement of the regions on the deleted track (the track's playlist) will be lost.

⚠️ The Delete Selected Tracks command cannot be undone.

To delete a track:

1. Click the name of the desired track (in its track channel strip) to select it.

   - If you wish to select multiple tracks, hold down the Shift key and click additional track names to select them as well.

2. Choose File > Delete Selected Tracks.

3. Click OK to remove the selected tracks from the session.

Duplicating Tracks

The Duplicate Selected Tracks command allows you to duplicate one or more tracks, including their audio or MIDI data, playlists, automation, and other attributes.

To duplicate a track:

1. Click the name of the desired track (in its track channel strip) to select it.

   - If you wish to select multiple tracks, hold down the Shift key and click additional track names to select them as well.

2. Choose File > Duplicate Selected Tracks. Each duplicate track is created to the right of its original track.

Hiding Tracks

The Show/Hide Tracks List (at the left of both the Mix and Edit windows) lists all tracks in the session. It allows you to show or hide a track in the Mix and Edit windows, by selecting or deselecting its name. Even though a track is hidden, the material on the track will still play as part of the session. Inactive tracks appear in italics in the Show/Hide Tracks List.

To show a track, click and highlight its name in the Show/Hide List. To hide a track, deselect its name.

Show/Hide Tracks List

The Show/Hide Tracks List provides commands that allow you to show or hide all tracks, tracks currently selected on-screen, or specific types of tracks (audio, MIDI, Auxiliary Input or Master Fader).
The Sort Tracks By command allows you to set the track order according to Name, Type, Edit Group, Mix Group or Voice. The sort order will be reflected in the Show/Hide Tracks List in the Edit Window and the Mix Window.

To hide a track:
- Click the highlighted name of a track in the Show/Hide Tracks List.

To show a track that is currently hidden:
- Click the unhighlighted name of a track in the Show/Hide Tracks List.

To show all tracks:
1. Click the Show/Hide button at the top of the Show/Hide Tracks List.
2. From the pop-up menu, choose Show All Tracks.

To reorder tracks on-screen, drag the track names to new positions within the Show/Hide Tracks List.

About Groups and Show/Hide Tracks

Even if a track is hidden, if it is a member of an enabled group and active, all Mix window operations performed on other members of the group will also affect the hidden track—with the exception of audio or MIDI record-enabling. If you solo, mute, or automation write-enable a grouped track, any group members that are hidden will be soloed, muted, or automation write-enabled as well. These functions are not applied to hidden tracks.

In the Edit window, however, editing operations performed on members of an enabled group will not affect hidden tracks that are also members of the enabled group.

On TDM systems, even if a track is hidden from view, its position relative to other tracks still affects voiceable track playback priority. See “Making Tracks Inactive” on page 90.

To reorder tracks on-screen, drag the track names to new positions within the Show/Hide Tracks List.
Assigning Inputs and Outputs to Audio Tracks (and Other Tracks)

Inputs for audio tracks and Auxiliary Input tracks can be assigned to audio interface channels or busses. Outputs for audio tracks, Auxiliary Input tracks, and Master Fader tracks can be assigned to audio interface channels or busses.

For stereo and multichannel surround tracks, inputs and outputs appear as stereo pairs and multichannel groups. The available inputs, outputs, and busses are defined as paths in the I/O Setup dialog (see Chapter 7, “I/O Setup”).

Assigning Audio Track Inputs
(Audio and Auxiliary Input Tracks)

To assign an audio track input:

1. In the Edit window, select Display > Edit Window Show > I/O View.

2. In the Mix or Edit window, click the track Input Selector and choose from the available audio interface channels and busses. Stereo and multichannel surround tracks have inputs available as pairs and multichannel groups.

The Input Selector allows you to route any audio input or any of the Pro Tools internal busses to an audio track or an Auxiliary Input track. The choices available in this pop-up menu are determined by the I/O Setup configuration. Inputs in use by another track appear as bold in the Input Selector.

To remove an input assign:

- Select No Input from the Input Selector.

Input/output assignments for three mono audio tracks

<table>
<thead>
<tr>
<th>Track set to Audio Input 2</th>
<th>Track set to Bus 2</th>
<th>Track set to No Input</th>
</tr>
</thead>
<tbody>
<tr>
<td>In 2</td>
<td>Bus 2</td>
<td>Out 1-2</td>
</tr>
<tr>
<td>Out 1-2</td>
<td>Out 1-2</td>
<td>Out 1-2</td>
</tr>
</tbody>
</table>

Audio track Input Selector
Assigning Audio Track Outputs
(Audio Tracks, Auxiliary Inputs, Master Faders)

To assign an audio track output:

1. To display inputs and outputs in the Edit window, select Display > Edit Window Show > I/O View.

2. In the Mix or Edit window, click the track Output Selector and choose from the available audio interface channels and busses. Stereo and multichannel surround tracks have outputs available as pairs and multichannel groups.

The Output Selector allows you to route a track to any configured audio output or internal bus. The choices available in this pop-up menu are determined by the I/O Setup configuration. Outputs in use by another track appear as bold in the Input Selector.

If you want to auto-assign all visible tracks to unique mono sub-path outputs in ascending order, Command-Option-click (Macintosh) or Control-Alt-click (Windows) the Output Selector of the left-most track and assign it to the sub-path for Output #1. All visible tracks will be auto-assigned to unique mono sub-path outputs in ascending order.

To remove an output assign:

- Select No Output from the Input Selector. Playlists become dimmed for tracks with no output assignment.

⚠️ Assigning an audio track, Auxiliary Input, or Master Fader to “No Output” will cause its automation data for pan and plug-in parameters to be lost.

Assigning Voices and Track Priority
(TDM Systems Only)

Each TDM system provides a specific number of voices (simultaneous voices of playback and record). For example, a Pro Tools|HD 1 system can provide up to 96 voices of playback and record, at 44.1 kHz. (Refer to Table 1 on page 7.)

While your Pro Tools hardware allows a fixed number of voices, Pro Tools software provides additional tracks that can share these voices. The combination of playback/record tracks and shared voiced tracks is the total voiceable tracks for a system. For example, a 44.1 kHz session on a Pro Tools|HD 1 system can have 96 voices, spread across up to 256 tracks. While all of these tracks can be recorded or imported, arranged, and cued for playback, not all of them can be played back simultaneously.

When tracks exceed the number of available voices, tracks with lower priority may not be heard. For these situations, Pro Tools assigns priorities for tracks that compete for the available voices. Because there can be more tracks than available voices, Pro Tools provides multiple ways of adjusting playback priority to audio tracks.

Tracks do not use up voices when:

- Their Voice Selector is set to Off.
- They are made inactive.
- They do not have an output and send assignment.
In addition, you can temporarily free a track’s voice during playback by muting it (see “Mute Frees Assigned Voice” on page 90).

**Voice Assignment**

Tracks can be assigned to a specific voice, or they can be set to Auto. When tracks are auto-voiced, Pro Tools automatically takes care of voice management in the background—assigning voices not in use by other tracks.

Tracks assigned to a specific voice number take priority over auto-voiced tracks. To ensure a track is heard, or that it is available for Quick-Punch recording, assign it a voice.

**To set the voice assignment for a track:**

- Click the Voice Selector and select a voice number, or set the track to Auto.

**Automatic Assignment of Ascending Voices**

You can automatically assign all tracks or all selected tracks to successive voices. For example, you may want to select eight audio tracks and reassign them to voices 9–16.

**To assign all audio tracks to successive voices:**

- While pressing Command+Option (Macintosh) or Control+Alt (Windows), select the starting voice number from the Voice Selector for the track at the top of the Edit window, or at the far left of the Mix window.

The voice is assigned to the clicked track, with successive voices assigned to tracks (with the same format) of lower priority.

**To assign all selected audio tracks to successive voices:**

1. Select the desired audio tracks by Shift-clicking their names.
2. While pressing Command+Option (Macintosh) or Control+Shift (Windows), select the starting voice number from the Voice Selector for the top (Edit window) or left (Mix window) selected track.

The voice is assigned to the clicked track, with successive voices assigned to currently selected tracks (with the same format) of lower priority.

For stereo and multichannel tracks, voices appear in pairs and multichannel groups. Voices already assigned to another track appear in bold in the Voice Selector pop-up menu.
Changing a Track’s Playback Priority

When more than one track is assigned to the same voice, the track with the higher priority (left-most in the Mix window or topmost in the Edit window) has priority over others assigned to that voice. Moving another track of the same voice to a higher position will then give that track priority.

This track priority scheme is also used for auto-voiced tracks. When tracks in the session exceed the number of available voices, tracks with lower priority may not be heard.

To increase a track’s priority, do any of the following:

- In the Edit window, drag the Track Name button above other tracks in the session. Tracks at the top of the Edit window have higher priority than those below.
- In the Mix window, drag the Track Name button to the left of other tracks in the session. Tracks at the left of the Mix window have higher priority than those to the right.
- In the Show/Hide Tracks List, drag the track name to a higher position in the list. Tracks at the top of this list have higher priority than those below.

By experimenting with track priority, voice assignment, and arranging regions so that they are positioned to “pop through” holes in higher priority tracks, you will find many useful ways to use voiceable tracks in your TDM system.

Voiceable Tracks and Track Priority

Pro Tools features dynamic voice allocation, so that when a hole opens up in a higher-priority track, its voice is temporarily available, and the track with the next highest priority “pops through” and begins to play. When the original track returns, the track that had popped through relinquishes the voice to the higher priority track.

The following example demonstrates the concept of dynamic voice allocation:

In the above illustration, the two visible tracks are assigned to the same voice. There is an open area in the top track where no region appears. At this point, the voice is free since it is not being used, and the next highest priority track assigned to that voice (the bottom track) will pop through the open area and play. In order for a lower priority region to pop through, it must be placed so that its beginning occurs after a higher priority track’s region has ended.

Setting MIDI Input and Output

Assigning MIDI Track Input

This MIDI Input Selector allows you to choose which MIDI device and channel a MIDI track is receiving input from. This allows you to set up Pro Tools to record multiple MIDI tracks in the same record pass. Channels in use by another track input appear as bold in the MIDI Input Selector.

To assign a MIDI track input:

1. In the Edit window, select Display > Edit Window Show > I/O View.
In the Mix window, click on the track’s MIDI Input Selector and assign the device and channel that will be recorded.

Assigning MIDI Track Output

MIDI tracks can be assigned to one or more MIDI device channels with the Device/Channel Selector. When assigned to multiple channels, all material in the track is sent to all assigned channels.

MIDI tracks in Pro Tools cannot contain multiple channels of MIDI data.

To assign a MIDI track (and all its regions) to a specific MIDI device channel:

- Click on the track’s MIDI Device/Channel Selector and assign a device and channel from the pop-up menu. Channels already assigned to another track appear bold in this menu.

To assign multiple destinations to a single MIDI track:

- Control-click (Macintosh) or Right-click (Windows) the MIDI Device/Channel Selector and select additional channels from any device.

For details on recording and importing MIDI data, see Chapter 13, “MIDI Recording.”

Soloing and Muting Tracks

The Solo and Mute buttons can be engaged at any time during playback. The Solo and Mute buttons affect MIDI as well as audio tracks. It is possible to have more than one track soloed or muted at the same time in a session.

Grouping affects mute and solo behavior as well. Normally, muting or soloing a track that is a member of an active mix group will mute or solo all other tracks that are a member of that active mix group as well. However, by changing the Mute and Solo settings in the Pro Tools Preferences dialog, you can disable this behavior.

To disable group muting of tracks:

1. Choose Setups > Preferences, and click Automation.
2. Deselect the Mutes Follow Groups option, and click Done.

With this option deselected, muting a track that is a member of an active group does not affect other members of the group.

You can also mute or solo individual members of a group, by holding down the Control key while selecting the track’s Mute or Solo button.
To disable group soloing of tracks:

1. Choose Setups > Preferences, and click Automation.
2. Deselect the Solos Follow Mix option, and click Done.

With this option deselected, soloing a track that is a member of an active group does not affect other members of the group.

Solo Button

The Solo button mutes other tracks so that the chosen track can be auditioned alone. Normally solos are “latched,” that is, pressing subsequent solo buttons adds them to the soloed mix of tracks. Pro Tools allows you to “unlatch” solos, so that pressing a solo button will mute all tracks except the track you have just soloed.

To solo tracks:

1. Click the Solo button on a track. The button is highlighted and all other tracks are muted.
2. Click the Solo button on another track. The buttons for both tracks are highlighted and all other tracks are muted.

To turn off (or un-solo) tracks:

1. Click the Solo button on soloed tracks.

To unlatch solo buttons:

1. Choose Setups > Preferences and click Operation.
2. Deselect the Latch Solo Buttons option and click Done. With this option disabled, pressing a Solo button mutes all tracks except the track you have just soloed.

Solo Safe Mode

Pro Tools also allows you to solo safe a track. This prevents the track from being muted even if you solo other tracks. This feature is useful for tracks such as Auxiliary Inputs that are being used as a submix of audio tracks, or effects returns, allowing the audio or effects track to remain in a mix even when other tracks are soloed. It is also useful to solo safe MIDI tracks so that their playback is not affected when you solo audio tracks.

To solo safe a track:

- Command-click (Macintosh) or Control-click (Windows) the Solo button on the desired track. This prevents the track from being muted even if you solo other tracks. The Solo button changes to a transparent color in Solo Safe mode.

To return a solo safe track to normal:

- Command-click (Macintosh) or Control-click (Windows) the Solo button on the track again.

Mute Button

The Mute button silences a chosen track. More than one track can be muted at one time. If Operations > Mute Frees Assigned Voice (TDM systems only) is enabled, muting a track will allocate its voice to the next highest priority voiceable track (assigned to the same voice).

To mute a track:

- Click the Mute button on the track. The track will appear grayed-out and be muted.

To unmute a track:

- Click the Mute button again.
Mute Frees Assigned Voice
(TDM Systems Only)

Selecting Operations > Mute Frees Voice and muting a track disables playback of that track, and surrenders control of its voice to the next highest priority track with the same voice assignment.

With this option enabled, there may be a delay (ranging in length from one to several seconds depending on the processing power of your system) between the time you mute or unmute a track and when you hear the effect on playback.

To avoid this delay, make sure that the Mute Frees Assigned Voice option is disabled. Another factor that can cause delays is your DAE Playback Buffer Size setting. Playback Buffer Size is set in the Playback Engine dialog. The larger the playback buffer you choose, the longer the potential lag time between the time you click the Mute button and the onset of muting.

⚠️ Muting a track with Mute Frees Assigned Voice enabled does not free up the voice for QuickPunch recording.

Making Tracks Inactive
(TDM Systems Only)

Audio, Auxiliary Input, and Master Fader tracks can be made inactive. Inactive tracks use no DSP or voices. Plug-ins, sends, voices, and automation on inactive tracks are disabled. Tracks may also be automatically made inactive if a session is opened on a system with less DSP power than the system it was created on.

⚠️ MIDI tracks cannot be made inactive.

To toggle a track active/inactive:

- Command-Control-click (Macintosh) or Control-Start-click (Windows) the track type icon in the Mix window.

Playlists for inactive tracks are dimmed.

To make one or more tracks inactive:

1. Click the name of the desired track (in its track channel strip) to select it.

2. Choose File > Make Selected Tracks Inactive.

   If you wish to select multiple tracks, hold down the Shift key and click additional track names to select them as well.

Adjusting Track Width

Mix Window

The Narrow Mix Window command allows you to view all tracks/channels in the Mix window at a reduced width to conserve screen space in a large session. (See “Track Height” on page 172, to adjust track height in the Edit Window.)

To reduce the width of tracks in the Mix window:

- Select Display > Narrow Mix Window.

To display tracks at normal width:

- Deselect Display > Narrow Mix Window.
Color Coding Tracks

The Display Preference for Edit Window Color Coding determines how colors are assigned to waveforms and MIDI data in the Edit window. Colors can be based on groups, voice assignment for audio tracks, and channels or devices for MIDI tracks.

Color coding of voices is especially useful when working with tracks assigned to the same voice. Since tracks assigned to the same voice share the same color, you can easily identify and arrange regions so that they do not overlap or conflict with other regions on tracks assigned to the same voice.

To configure the Edit Window color coding:

1. Choose Setups > Preferences and click the Display tab.
2. Select one of the following color coding options:
   - **None**: Turns off color assignment for tracks in the Edit window.
   - **Tracks and MIDI Channels**: Assigns a color to each track in the Edit window according to its voice and MIDI channel assignment.
   - **Tracks and MIDI Devices**: Assigns a color to the track in the Edit window according to its voice and MIDI device assignment.
   - **Groups**: Assigns a color to each track in the Edit window according to its group ID. If groups are suspended using the Suspend Groups command, all waveforms are displayed in black.
3. Click Done to close the Preferences dialog.

Grouping Tracks

Pro Tools provides a relative grouping function for linking tracks and their controls. Groups can be applied to either the Mix or Edit window, or both.

Groups are useful for editing several tracks in exactly the same way, or for mixing several tracks (such as a pair of stereo tracks or a submix) while keeping them at the same relative volume level.

Pro Tools provides the following grouping features:

- Up to 26 different groups
- Nested groups (subgroups within groups)
- Grouped faders or controllers preserve their levels relative to each other

Grouping can affect the following track parameters:

- Volume levels
- Solos
- Mutes
- Automation modes
- Send levels
- Send mutes
- Track view
- Track height
- Editing functions

Grouping does not affect these parameters:

- Record enables
- Panning
- Send panning
- Voice assignment
- Output assignment
- Creating Plug-Ins instances
Using the Groups List

The Pro Tools grouping functions are located at the left side of the Mix or Edit window in the Groups List. This scrolling window contains the names of all the groups in your session, as well as a pop-up menu for accessing grouping commands. From this menu, you can select and enable groups.

By default, every session has a group named All, which includes every track and channel in the session. The All group cannot be edited or deleted.

To the left of each name in the Groups List is a letter denoting its Group ID (“a” through “z”), and to the left of that, a symbol indicating whether that group is selected in the current window (either the Edit or Mix window). These symbols indicate the following:

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Filled circle]</td>
<td>All members of the group are currently selected, and no members from outside the group are selected.</td>
</tr>
<tr>
<td>![Hollow circle]</td>
<td>Only some members of the group are currently selected.</td>
</tr>
<tr>
<td>![Circle with dot]</td>
<td>All members of the group are currently selected, plus additional members outside the group.</td>
</tr>
</tbody>
</table>

A pop-up menu allows you to show or hide tracks in a group, or show only tracks in a group. Click and hold on the group name to display the pop-up menu, then select the option.

The Groups Pop-up Menu

The Groups pop-up menu contains commands that allow you to create, delete and suspend groups. These commands are as follows:

**New Group** This command allows you to create a new group. You must first select two or more tracks/channel strips on-screen to do this.
Display This command allows you to toggle the Groups List display to either Mix Groups or Edit Groups. If all of your groups apply to both Editing and Mixing, the Groups List will be the same for both.

Suspend All Groups This command allows you to temporarily toggle all active groups off.

Delete Selected Groups This command allows you to permanently remove a group from the Groups List. You must first select a Group Name in the Groups List to do this.

Creating a Group

To create a group:

1. Hold down the Shift key and select the tracks you want to include in the group.

2. Choose New Group from the Group pop-up menu, or choose File > Group Selected Tracks.

3. Enter a name for the group.

4. Choose the type of group to create: Edit Group, Mix Group, or Edit and Mix Group.

5. Choose a Group ID (“a”–“z”).

6. Click OK to add the new group to the Groups List.

Editing Groups

Changing the Members of a Group

You can add or remove members from a group at any time.

To change the members of a group:

1. Hold down the Shift key and select the tracks to include in the group.

2. Choose File > Group Selected Tracks from the Group pop-up menu.

3. In the dialog that appears, select the Group ID that you want to update.

4. Click OK. The new group definition overwrites the original definition.

Renaming a Group

You can rename a group at any time.

To rename a group:

1. In the Groups List, double-click to the left of the group’s name (in the area with the circular symbols).

2. In the dialog that appears, enter a new name for the group. (If you wish to change the group’s type, you can also do so here.)

3. Click OK. The group is renamed in the Groups List.

Deleting a Group

You can delete a group at any time.

To delete a group:

1. In the Groups List, select the name of the group (or groups) you wish to delete.
2 Click the Group pop-up menu and choose Delete Selected Groups. You cannot undo this action.

**Linking Mix and Edit Groupings**

The “Link Mix and Edit Group Enables” option links group enabling between the Mix and Edit windows.

Pro Tools allows you to create groups that are both Mix and Edit groups, but in some cases you may prefer not to link enabling of Mix and Edit groups. For example, when you are using the Mix window for mixing, you may prefer to work with large, nested groups. However, in the Edit window, you may want to perform editing tasks within a smaller group. You could disable the Link Mix and Edit Group Enables preference. This would allow you to work with different groups in the two windows.

**To unlink mix and edit groups:**

1. Choose Setups > Preferences and click Operation.
2. Deselect the “Link Mix and Edit Group Enables” option and click Done.

**Enabling Groups**

Editing operations are not applied to members of a group that are hidden with the Show/Hide Tracks List. Mix operations (with the exception of record-enable) are applied to hidden tracks.

Pro Tools allows you to create separate groups for editing and mixing. You set this option when you use the New Group command. Groups that apply to both editing and mixing can be decoupled.

**To enable a group:**

- In the Groups List, click the name of the group you want to enable. The group name is highlighted to indicate that it is enabled.

**To enable additional groups, click their names in the Groups List. It is not necessary to Shift-click to enable or disable multiple groups.**

Moving a fader of a group member will cause all other group members to move relative to it. If a fader belongs to multiple groups, and the groups conflict when faders are moved, the fader will follow the topmost or “parent” group that it belongs to.

**To disable a group:**

- In the Groups List, click the name of the group you want to disable. The group name is unhighlighted to indicate that it is not enabled.

**Keyboard Selection of Groups**

If the Groups List Key Focus is enabled, you can type a Group ID letter and Pro Tools will automatically enable that group.

**To enable and use the Groups List Key Focus:**

1. Click the a–z button in upper right of the Groups List.
   - or –

Press Command+Option+4 (Macintosh) or Control+Alt+4 (Windows).

2. Type the Group ID letter (a–z) to automatically enable it.
Chapter 9: Importing and Exporting Audio and MIDI

Importing Audio

In Pro Tools you can import previously recorded audio files and regions from other sessions or other applications. You can also import tracks from other Pro Tools sessions (see “Importing Tracks from Other Sessions” on page 98), and convert the audio while importing.

Audio files and regions can be imported to new tracks, or they can be imported into the Audio Regions List, where they can be dragged to existing tracks.

Audio files in the following formats can be imported:

- AIFF
- WAV
- SDII
- SDI
- MP3 (with purchase of MP3 option)
- Sound Resource (AIFL—Macintosh only)
- WMA (Windows Media—Windows only)

Supported files and regions can be auditioned before importing.

If region definitions are present in an audio file, you can convert and import selected regions without importing the entire parent audio file.

When importing into a session, choose File > Import Audio to Track to place the audio into a new track. To import audio into the Audio Regions List, choose Import Audio from the Audio Regions pop-up menu. Both commands open the same Import Audio dialog (see Figure 5 on page 97).

Files that don’t match the session’s supported files types, must be converted when importing. If you import an audio file with a sample rate that doesn’t match the current session’s sample rate, and you do not convert it, the file will not play back at the original pitch.
Copying, Adding, and Converting Audio

Depending on the properties of the audio files you are importing, you can add, copy, or convert the files.

Add

Audio files that are of the same bit depth and file type can be added directly to a session. Use this option when you don’t want to use extra hard drive space for audio files that are already of the same bit depth and sample rate as your session. Note that added files remain in their original folder locations.

Pro Tools allows audio files that are not in the native session type to be added to a session. Macintosh sessions allow SDII, AIFF, or WAV files to be added to any session, and Windows sessions allow AIFF or WAV files to be added to any session. However, sessions with mixed file types will have reduced performance.

Audio files that are of a different bit depth must be converted.

⚠️ Pro Tools allows you to add files to a session that are at a different sample rate than your session (such as 48 kHz or 44.1 kHz). In the comments field of the Import Audio dialog, a warning is posted that these files will play back at the wrong speed if they are not converted.

Copy

If a file can be added to your session, you will also be given the option to copy it. This option creates a copy of the audio file and places it in a folder you choose.

You can also use Copy when the file you are importing is of the correct bit depth and file type, but it is at the wrong sample rate, and you want it to play back correctly. Additionally, use Copy to move audio from an unsupported or removable drive to an audio drive, or to consolidate audio files for a session to a specific location.

Convert

Audio files that are not of the same bit depth or sample rate, or audio files that are of an incompatible file type (SDII files in Windows or on the Macintosh in a Mac/PC compatible session) must be converted to be used with a session.

When audio files are converted, a new file with the correct bit depth, file type, and sample rate is created and placed in a folder you choose.

The quality of sample rate conversion used by Pro Tools is determined by the Preference for Conversion Quality. For details, see “Conversion Quality” on page 103.

Importing Stereo Files

When using the Import Audio to Tracks command, stereo files (“interleaved”) are automatically imported to stereo tracks.

Split stereo (dual mono) audio files can be automatically imported to stereo tracks. The files must be named “filename.L” and “filename.R”; both files must be the same length. In Windows, or in Mac/PC Compatibility mode, these files will have a 3-letter file extension appended after the “.L” or “.R” channel identifier.
Using the Import Audio Command

To import audio files or regions into a session:

1. Choose File > Import Audio to Track to import audio files or regions to their own separate tracks.
   - or -

Choose Import Audio from the Audio Regions List pop-up menu to import audio into the Audio Regions List without automatically creating tracks.

To import tracks, refer to “Using the Import Tracks Command” on page 100.

2. At the top of the Import Audio dialog, select an audio file to display its properties and associated regions.

You can choose to display only a certain file type (AIFF, for example) by selecting it from the Show pop-up menu. To display all supported file types, select All Documents from the Show pop-up menu.

3. To audition a selected file or region before you import it, use the Play and Stop buttons.

Adjust playback volume with the vertical slider. To navigate to a particular location in the file, use the horizontal slider under the Play and Stop buttons.

The audition output defaults to channel 1–2. On TDM systems, the audition output can be changed in I/O Setup or Hardware Setup.

4. To place a file or region in the import list (in the lower right of the dialog on a Macintosh, or on the right in Windows), select the file (Shift-click to select multiple files) and click Add or Convert. You can also click Add All or Convert All to import all regions and files in the current directory.

In the import list, audio files are distinguished from regions by their icons.

5. To remove a file or region from the import list (in the right list on a Macintosh, or on the right in Windows), select it and click Remove. To remove all regions or files, click Remove All.

6. Once the audio files and regions have been added to the import list, click Done.

7. If you are copying or converting files, you are prompted to choose a location for the new audio files. Choose a folder on a valid audio drive.

⚠️ On the Macintosh, Sound Resource files must have the “.SFIL” extension to be imported by Pro Tools.

File and Region Icons in the Import Audio dialog

5 To remove a file or region from the import list on the right, select it and click Remove. To remove all regions or files, click Remove All.

6 Once the audio files and regions have been added to the import list, click Done.

7 If you are copying or converting files, you are prompted to choose a location for the new audio files. Choose a folder on a valid audio drive.
We recommend you use the Audio Files folder that your session created to keep track of the session’s audio files.

If you chose File > Import Audio to Track, the files and regions are imported to separate audio tracks, and also appear as regions in the Audio Regions List.

If you chose Import Audio from the Audio Regions List, the files and regions appear as regions in the Audio Regions List.

**Importing Tracks from Other Sessions**

You can import tracks from a different Pro Tools session into a current Pro Tools session using the Import Tracks command. On the Macintosh, you can Import tracks from Pro Tools 3.2 sessions and later. On Windows, you can Import tracks from Pro Tools 4.2.5 sessions or later.

You can import audio tracks, MIDI tracks, Auxiliary Input tracks, and Master Fader tracks. During the import process, you can force the file type of the imported files to the current session file type, and you can change the bit depth and sample rate.

Import Tracks also lets you set time code location options, sample rate conversion options, and audio and video media translation options.

**Import Tracks dialog**

**Import Tracks Dialog**

The Import Tracks dialog allows you to select tracks to import, view source session properties, and configure settings that affect the way tracks are imported. The elements of this dialog are described below.

**Source Properties**

The Import Tracks dialog displays properties for the source session. These properties include source session name, session type, start time of the session, audio bit depth, and sample rate. For Pro Tools 5.1 or later sessions, the program that created the session, and the session’s audio file type are listed.

**Source Tracks**

You can select source tracks to Import in this area of the dialog. To select multiple contiguous tracks, Shift-click. To select multiple non-contiguous files, Command-click (Macintosh) or Alt-click (Windows).
Time Code Mapping Options

You can specify where Pro Tools places the imported tracks in your session using the Time Code Mapping Options. Times are indicated in time code for TDM systems, and minutes:seconds for Pro Tools LE systems.

Maintain Absolute Time Code Values This option places tracks at the locations where they were located in the source session. This means that if your session starts at 00:01:00:00, and the session from which you are importing starts at 10:00:00:00, the earliest imported tracks can appear in your session is 9 hours and 59 minutes after the start of the session.

Maintain Relative Time Code Values This option places tracks at the same offset from session start as they had in the source session. For example, if the session start was 01:00:00:00 in the source session and a track started at 01:01:00:00, then if the current session start is 02:00:00:00 the track will be placed at 02:01:00:00.

Map Start Time Code to hh:mm:ss:ff This option places tracks relative to their original session start time. This means that if your session starts at 00:01:00:00, and the session from which you are importing starts at 10:00:00:00, you can set the start time code to 00:01:00:00, and avoid placing files 9 hours and 59 minutes from the start of your session.

Sample Rate Conversion (SRC) Options

This dialog allows you to set options for sample rate conversion of imported audio files. If the source session and your target session have the same sample rate, this portion of the dialog is dimmed.

Source Sample Rate For audio files created in any session, no matter what the session sample rate is, you can have the sample rate conversion process treat the files in several ways to compensate for pull-up, pull-down, and NTSC or PAL frame rates. This setting allows you to choose the sample rate from which you want the sample rate conversion process to start.

Destination Sample Rate The destination sample rate is always set to the sample rate of your session.

Conversion Quality With this setting you can change the quality of the sample-rate conversion process. At lower quality settings, audio is processed faster; at higher settings, audio processing is slower. “Best” runs at approximately real time on a fast machine. See “Conversion Quality” on page 103.

Audio Media Options

Format for New Audio

Choose whether you want new media files to be SDII, WAV, or AIFF files.

Copy Options

Consolidate from Source Media This option lets you copy audio while consolidating it. In this way you can copy only the used portions of the media, without copying unused audio in the source files.

When you choose this option, you should also choose an amount of handle (in milliseconds). Handle is an amount of the original audio file that is preserved before and after each region in case you need to make any edits to the new regions.
Copy from Source Media This option copies all audio files related to the imported tracks from the source media to a new specified location. This is useful if you are importing tracks from a source such as CD-ROM or shared storage, and you want to place the audio files on a different hard drive.

Refer to Source Media (Where Possible) This setting lets you avoid duplicating audio files by referring to the original files when possible. If the source files do not reside on “playable” media (such as a CD-ROM), or if they require bit depth or file conversion, the files are instead copied.

Force Audio Media to New Format This forces all imported audio files to the audio media format you select.

Video Media Options
You can either choose to leave video media files in their original locations or copy them to a new location. This is useful if you are importing tracks from a source such as CD-ROM or shared storage, and you want to place video files on a different drive.

Import Tempo/Meter Map
Select this option to import the meter and tempo tracks from the source session.

Using the Import Tracks Command

To import tracks:
1. Open or create a new session.
2. Choose File > Import Tracks.
3. Navigate to and select the session to import tracks from and click Open. The Import Tracks dialog opens and displays the tracks that can be imported.

If the current Pro Tools system does not support surround mixing, surround tracks are not displayed in the Import Tracks dialog.

4. Select the tracks to import. Shift-click to select multiple contiguous files. Command-click (Macintosh) or Alt-click (Windows) to select multiple non-contiguous files.
5. Choose the time code mapping option for imported audio files.
6. If the sample rates of the sessions are different, choose the sample rate for the source session.
7. If applicable, choose options for imported audio and video media files.
8. To import the meter and tempo tracks from the source session, select that option.
9. Click OK when you are finished.
10. If you chose to copy or consolidate media, choose a location to place the media files.

⚠️ Imported tracks are made inactive if their source media is unavailable, or if the current session does not contain an equivalent output path.

Loading Audio Files with Drag & Drop

Pro Tools provides you with a convenient method of batch loading audio files into an open session.

To batch load audio files into a session:
1. Open or create a new session.
2. From the desktop, locate the audio files you want to import. Make sure the files match the session’s file type, bit depth, and sample rate.
Audio files must be in WAVE, SDII, or AIFF/AIFC format in order to be dropped into Pro Tools.

Audio files will be converted if they are not of the correct bit depth or number of channels. They will be converted to mono files of the default audio file format, with the session’s bit depth and sample rate.

Drag the audio files onto the Pro Tools icon or alias.

### Exporting Audio

Pro Tools supports exporting regions as audio files, exporting left and right audio files as stereo interleaved files, and exporting region information.

You can also export audio from Pro Tools by bouncing or consolidating audio tracks. For more information, see “Bounce to Disk” on page 406.

### Exporting a Region as a New Audio File

You can export regions as audio files with the Export Selected As Files command. Use this command if you intend to use a region in other sessions (or other audio applications) without using its parent source file.

This command also provides a way to convert regions to a different audio format, sample rate, or bit depth.

**To export regions as new audio files:**

1. In the Audio Regions List, select the regions you want to export.
2. From the Audio Regions List pop-up menu, choose Export Selected As Files.
3. In the Export Selected dialog, set the file type, format, bit resolution, and sample rate. In addition, specify the Conversion Quality, and choose the destination directory.
4. Select an option for how Pro Tools should resolve duplicate file names. Prompting for Each Duplicate will prompt you for a file name for any file that has the same name as a file in your destination directory.

Auto Renaming automatically changes the name of any duplicate file by adding a number at the end (such as file-01). Replacing with New Files replaces files with the same name with the new files.

When you Export Selected (or Save Session Copy) with a lower bit rate, Dither (and Noise Shaping) may be applied. See the following table:
For more information about using Dither with Save, see See “Dither” on page 359.

### Exporting Stereo Interleaved Files
You can use the Export Selected As Files command to export audio regions to stereo interleaved files for use in other applications. (Pro Tools sessions do not support stereo interleaved files.) For this to work, the selected regions must have identical names with “.L” and “.R” suffixes (for instance, vocals-01.L and vocals-01.R). These regions appear as a stereo region in the Audio Regions List.

#### To export regions as a stereo interleaved file:
1. Select the stereo audio region in the Audio Regions List or in the track playlist. If the regions appear on mono tracks in the session, select the two mono regions.
2. From the Audio Regions List pop-up menu, choose Export Selected As Files.
3. In the Export Selected dialog, select “Interleaved” in the Format pop-up menu.
4. Configure any other output parameters, then click Export to export the new stereo interleaved file.

#### Dither and Noise Shaping are applied as follows:

<table>
<thead>
<tr>
<th>Bit Rate Conversion</th>
<th>Export Selected</th>
</tr>
</thead>
<tbody>
<tr>
<td>24-bit to 16-bit (Dither and Noise Shaping)</td>
<td>Yes</td>
</tr>
<tr>
<td>24-bit to 8-bit (Dither Only)</td>
<td>Yes</td>
</tr>
<tr>
<td>16-bit to 8-bit (Dither Only)</td>
<td>Yes</td>
</tr>
</tbody>
</table>

The Export Region Definitions command does not export regions as audio files (unlike the Export Selected As Files command). Instead, it stores pointers to the regions within the parent source file.

#### To export region definitions for an audio file:
1. In the Audio Regions List, select any regions for which you want to export definitions. You do not have to select the parent file audio region.
2. Choose Export Region Definitions from the Audio Regions List pop-up menu.
3. Click Export.

### Transferring Audio from CD
(Macintosh Only)

Pro Tools allows you to transfer audio tracks from an audio CD with the Import Audio From Other Movie command. Since the transfer is made in the digital domain, there is no signal loss.

The sample rate for audio CDs is 44.1 kHz. Therefore, if your session’s sample rate is set to 48 kHz or higher, Pro Tools will convert the sample rate for the imported audio. Before importing CD audio, set the Conversion Quality Preference accordingly. See “Conversion Quality” on page 103 for details.
Chapter 9: Importing and Exporting Audio and MIDI

When importing a CD audio track, Pro Tools first imports it as QuickTime movie. The imported movie is then converted to audio files in your session file format. Before importing CD audio, make sure your hard drive has enough space for both the imported movie file and the converted audio files.

**To import a CD audio track:**

1. Insert the audio CD into your CD-ROM drive.
2. Choose Movie > Import Audio From Other Movie.
3. Locate and select the audio track to be imported, then click Convert.
4. When the Save dialog appears, click the Options button.
5. In the Options dialog, select the sample rate, bit resolution, and stereo format.
6. At the bottom of the Options dialog, set the range of the audio track to be imported by adjusting the Start and End times, then click OK.
7. To audition a selected file or region before you import it, use the Play and Stop buttons.
8. Specify the destination for the imported audio track and click Save. Pro Tools imports the CD audio track as a QuickTime movie and writes it to your hard drive.
9. When the Track Import window appears, click OK.

Pro Tools converts the audio track to your session’s sample rate and bit resolution and imports the selected audio tracks into the Audio Regions List. From there you can drag the regions to existing tracks.

**Conversion Quality**

The Conversion Quality Preference determines the quality of sample rate conversion used when converting and importing audio into a session, and when importing CD audio tracks (Macintosh only). There are five possible settings, ranging from *Low* to *Tweak Head*. The higher the quality, and the more extreme your conversion (for example, 44.1 to 192 kHz) the longer it will take.

**To set the sample rate conversion quality:**

1. Choose Setups > Preferences, and click Editing.
2. From the Conversion Quality pop-up menu, select the desired quality.
For most applications, the Good or Better setting will yield very good results. Because the Best and Tweak Head settings take significantly longer, use them only when higher fidelity is absolutely essential.

3 Click Done.

Slower computers can take an extremely long time to perform sample rate conversion, especially at higher-quality settings. The Tweak Head setting, for instance, can take as long as several hours to process an audio file of moderate length.

**Exporting Session Text**

*(TDM Systems Only)*

You can use the Export Session As Text command to create a text file that contains extensive information about your session.

This text file can contain a list of audio files, audio regions, audio track EDL (edit decision list) information, extended timestamp information, and information about crossfades.

Track EDLs are exported as tab-delimited text—that is, with tabs between each column heading, and tabs between each event parameter. You can use this data in a program for reading EDLs, or you can format the EDL data into tables using a word processor or spreadsheet application.

**Export Session Text Options**

- **Include File List/Region List**
  - You can choose to export a list of the session’s audio files and regions. The File List provides a list of all the audio files and fades in the session, and their hard drive locations. The Region List displays all audio regions in the session, and the source audio file for each region.

- **Include Track EDLs (Playlists)**
  - You can export track EDLs (playlists). Track EDLs can be used to spot-check region placement and edits, or in a conforming program for post applications. In extreme circumstances the EDL can be used to recreate the entire session.

  - **MIDI track EDLs are not exported.**

  - When exporting track EDLs, the following options are available:

    - **Show Subframes**
      - This option allows you to export subframe time information with track EDLs, if used in your session.
Include User Timestamps

You can include user timestamps with track EDLs. User timestamps indicate a user-defined session location for the region, or the original location of the region when recorded.

Fade Handling

For track EDLs, you can choose whether to show crossfades, not to show them, or to combine crossfaded regions. When regions are combined, their durations and locations are listed up to the center of the crossfade (for the leading region) and from the center of the crossfade (for the following region).

Time Format

You can select the appropriate time format that exported EDL information is based on. For example, for post work, you might select SMPTE time, but for music creation locked to a grid, you might select Bars & Beats.

File Format

You can choose to export to any of several different text formats. These include standard text formats, and Microsoft Word and Excel formats.

The Exported Session Text

Session Information

The session text file starts with basic information about the session. This information includes the session name, sample rate, bit depth, time code format, and number of audio tracks, audio regions, and audio files, as shown in the following example.

<table>
<thead>
<tr>
<th>SESSION NAME:</th>
<th>Ripleys II-092700</th>
</tr>
</thead>
<tbody>
<tr>
<td>SAMPLE RATE:</td>
<td>48000.000000</td>
</tr>
<tr>
<td>BIT DEPTH:</td>
<td>24-bit</td>
</tr>
<tr>
<td>TIME CODE FORMAT:</td>
<td>30 Frame</td>
</tr>
<tr>
<td># OF AUDIO TRACKS:</td>
<td>19</td>
</tr>
<tr>
<td># OF AUDIO REGIONS:</td>
<td>203</td>
</tr>
<tr>
<td># OF AUDIO FILES:</td>
<td>54</td>
</tr>
</tbody>
</table>

File List and Region List

Next, if you choose to include them, are the lists of audio files and regions.

Track EDLs

The final item, if exported, is the list of track EDLs. A track EDL lists the track name, and all edits, including the event number, the region name, region start and end time, and region duration. The region timestamp is also exported, if you select this option. Subframes are shown in each time field if you select this option.
Exporting a session as text:
1. Choose File > Export Session As Text.
2. Select whether to include the File List, Region List, and track EDLs.
3. If you choose to include track EDLs, select whether to show subframes, and whether to include user timestamps. Also select an option for crossfade handling.
4. If you choose to include track EDLs, select the Time Format for the exported session text from the pop-up menu.
5. Select the File Format for exported text using the pop-up menu.
6. When you have set your options, click OK.
7. Select a location and enter a filename for the exported text file. In Windows, Pro Tools adds the correct 3-letter filename extension, while on the Macintosh, the file extension “.txt” is added.

Importing MIDI Files

You can import Standard MIDI Files into your Pro Tools sessions. Use the Import MIDI to Track command to place the imported MIDI onto new tracks; or use the Import MIDI command in the MIDI Regions List pop-up menu to place the data in the MIDI Regions List, where it can be dragged to existing tracks.

Pro Tools does not import proprietary sequence files. To use sequences from other MIDI applications in a Pro Tools session, you’ll need to first save them as Standard MIDI Files. Refer to the manufacturer’s documentation for details on saving Standard MIDI Files.

There are two types of Standard MIDI Files, both of which are supported by Pro Tools:

- Type 0 MIDI files store data for all MIDI channels in a single track. When importing these files, Pro Tools separates the data by channel and places each track’s data in separate regions and tracks.
- Type 1 MIDI files, sometimes referred to as multitrack MIDI files, contain multiple tracks of MIDI data. When importing these files, each track’s data is placed on its own new MIDI track in the Pro Tools session.

To import a Standard MIDI File to new tracks:
1. Choose File > Import MIDI to Track.
2. Select the MIDI file you want to import.
3. To import the MIDI file’s tempo and meter tracks, select the option for Import Tempo From MIDI File.

This option overwrites existing meter and tempo events in the current session. If you don’t want this, make sure to instead select Use Existing Tempo From Session.

4. Click Import (Macintosh) or Open (Windows). If prompted, specify whether you want to Keep or Discard existing MIDI tracks and regions in the current session.
Chapter 9: Importing and Exporting Audio and MIDI

The MIDI data is imported to new MIDI tracks, and also appears as regions in the MIDI Regions List.

⚠️ *If the Standard MIDI File contains markers, they are only imported if the current session does not contain any markers.*

5 In the Mix window, click on the MIDI Device/Channel Selector for each new track and assign a MIDI instrument and channel, as desired.

To import a Standard MIDI File into the MIDI Regions List:

1. Choose Import MIDI from the MIDI Regions List pop-up menu.
2. Select the MIDI file you want to import.
3. To import the MIDI file’s tempo and meter tracks, select the option for Import Tempo From MIDI File.

This option overwrites existing meter and tempo events in the current session. If you don’t want this, make sure to instead select Use Existing Tempo From Session.

4. Click Import (Macintosh) or Open (Windows). If prompted, specify whether you want to Keep or Discard existing MIDI tracks and regions residing in the current session.

Pro Tools imports the MIDI data as regions and places them in the MIDI Regions List.

⚠️ *If the Standard MIDI File contains markers, they are only imported if the current session does not contain any markers.*

5. Drag the new MIDI regions, as desired, to existing MIDI tracks.

### Exporting MIDI Files

To export a session’s MIDI tracks for use in another MIDI application, or for playback with an external (hardware) MIDI sequencer, you can save the tracks as a Standard MIDI File.

When exporting, the session tracks can be merged to a single, multichannel track (Type 0), or they can be saved as multiple tracks (Type 1).

To export all MIDI tracks in the current session:

1. Make sure to unmute any MIDI tracks in the session that you want to export.
2. Choose File > Export MIDI.
3. Specify a folder destination and name for the MIDI file.
4. Select whether the Standard MIDI File will be Type 0 (merged, single track) or Type 1 (multi-track).
5. Click Export. Pro Tools exports all MIDI tracks in the current session to a Standard MIDI File and writes it to your hard drive. Exported MIDI information includes notes, controller events, program changes, and System Exclusive data, as well as events for tempo, meter, and markers.

⚠️ *If the Standard MIDI File contains markers, they are only imported if the current session does not contain any markers.*
The SMPTE start time for the session is also exported. This ensures that the exported tracks, when played from another MIDI application, will align with the correct SMPTE frames, and also sync correctly to tape and video devices, or Pro Tools.

Refer to your third-party MIDI sequencer documentation to determine whether it supports importing SMPTE start times from MIDI files.

**Not Exported with MIDI Files**

Mute automation and muted regions do not affect exported MIDI. As long as a track is not muted by clicking its Mute button, all of its MIDI data is exported.

When exporting MIDI files from Pro Tools, device assignments for tracks are not retained (though channel assignments are). If you therefore export MIDI tracks from Pro Tools and later re-import them, you’ll need to reassign the tracks to the desired devices.

All playlist information for MIDI tracks is lost when exporting. For example, tracks that previously contained dozens of MIDI regions will be flattened and only contain single regions after exporting and re-importing.
Chapter 10: File Management and Compatibility

The various Pro Tools systems require that you keep certain files on specific hard drives in order for these systems to function properly. Observe the following file management rules:

- On Macintosh Pro Tools Systems, Pro Tools software should reside on your startup drive (the drive that contains your System Folder and other System-related files).

- On Pro Tools TDM systems, data files (such as session files, audio files and fade files) can be located on any compatible drive connected to the internal SCSI bus or the external SCSI bus of your computer, or to a SCSI accelerator card in your computer. Pro Tools TDM also supports ATA/IDE busses.

- On Pro Tools LE systems, data files can be located on any compatible hard drive connected to your computer’s internal or external ATA/IDE or SCSI busses.

Unique File IDs

Pro Tools 5.1 tags each audio file in a session with a unique identifier that allows it to distinguish a particular file even if its name or location has changed.

In cases where the unique identifier is not present, Pro Tools can identify an audio file using other file attributes, such as sample rate, bit depth, file length, and creation or modification date. Pro Tools will search for files with similar attributes, and list potential matches in the Candidates Files List.

Locating Audio Files

When you open a session, if Pro Tools is unable to locate audio files contained in the session, it will post a Find File dialog. You can choose to search for replacement files based either on file name or on unique file ID.
To locate an audio file:

1. In most cases, you can find files created or modified by Pro Tools by selecting Current Folder or Current Volume under “Search In.” To search in all subfolders of the current folder, select Look in Subfolders. If this search does not provide adequate results, you can select All Volumes to search all available drives and partitions.

2. Select whether you want to search for the file by Matching Name or Matching Unique ID. It is faster to search for a file by File Name; however, this search could be less useful if you are searching for a common file name, for example, “Audio-01.”

3. Click Search.

4. If Pro Tools is unable to find the target file, it will list a number of exact matches for the files, as well as candidate files. These are files that have the right file name but do not have the correct Unique File ID.

7. If checking Candidate Files, and you determine that a file in the Candidates Files List is not the target file, click Skip. To eliminate all files in the list, click Skip All.

8. When you have located the target file, click Open.

If you do not locate the target file, the whole file region and regions based on it appear as offline media in the Audio Regions List and in tracks in the Edit window.

WAV File Compatibility

Convert all imported WAV files to AES31/BroadcastWave

Pro Tools always creates AES31/Broadcast compliant WAV files when the file originates in Pro Tools. This option, accessed by choosing Setups > Preferences > Compatibility, makes imported WAV files, compliant with the AES31/EBU Broadcast standard.

AES31/Broadcast Wave is a variant of the standard audio WAV file type. The AES31 format contains additional information beyond the raw PCM audio data such as SMPTE time stamps.

This variant complies with standards set by the EBU (European Broadcasters Union), and the AES (Audio Engineering Society). Choose this option to ensure compatibility with other workstations that recognize this file type.
Chapter 10: File Management and Compatibility

Avid File Compatibility

Enabling the Avid Compatibility mode preference in Pro Tools adds “metadata” when bouncing to disk, or when recording from a bus. This metadata includes the name of session, and the name of the source of the bounce (bus or track output). When the bounced file is opened from an Avid system, the metadata information will help identify the source of the file components.

In addition, when Avid Compatibility mode is enabled, it forces all OMF media to be treated as Read Only within Pro Tools.

To enable Avid Compatibility mode:
1. Choose Setups > Preferences > Compatibility.
2. Select Avid Compatibility Mode.
3. Click Done.

Creating Mac and PC Compatible Sessions

The Enforce Mac/PC Compatibility option (Macintosh) and Enforce PC/Mac Compatibility option (Windows) allow you to create and save Pro Tools sessions that are compatible on both Macintosh and Windows. These options are available when creating a new 5.3 session, or when saving a copy of a 5.3 session.

Cross-Platform Session Limits

Audio File Types

Sound Designer II (SDII) files cannot be read by Windows systems. Therefore, when creating Mac and Windows compatible session files, the audio file type for the session must be either AIFF or WAV.

File Name Extensions

For cross-platform compatibility, all files in a session must have a 3-letter file extension added to the file name. Pro Tools 5.1 session files have the extension “.pts,” and Pro Tools 5 sessions have the extension “.pt5.” WAV files have the “.wav” file extension, and AIFF files have the “.aif” file extension.

Incompatible ASCII Characters

Region names, track names, file names, and plug-in settings cannot use ASCII characters that are incompatible with either system.

When creating a new name, if an incompatibility is detected when Mac/PC Compatibility or PC/Mac Compatibility mode is enabled, a dialog will appear that prompts you to type a new name. When you import files into a session that is set for Mac/PC or PC/Mac Compatibility, incompatible characters are converted to underscores (“_”).

The following characters cannot be used in PC or Mac/PC compatible sessions:

/ (slash)
\ (backslash)
: (colon)
* (asterisk)
? (question mark)
“ (quotation marks)
< (less-than symbol)
> (greater-than symbol)
| (vertical line or pipe)

Any character typed with the Command key
To create a session that is compatible with Macintosh and Windows:


2. Choose the drive where you want to save the session. The session should be created on a dedicated audio drive.

3. Enter a name for the session.

4. In the New Session dialog, set the Audio File Type to AIFF or WAV. These file formats are compatible with either platform.

5. Set the Sample Rate and Bit Depth for the session.

6. Select the I/O Settings to use for the session. Several pre-configured I/O Settings are included with your system, or you can choose custom I/O Settings that you have created. See Chapter 7, “I/O Setup” for more information.

7. Select “Enforce Mac/PC Compatibility” (Macintosh) or “Enforce PC/Mac Compatibility” (Windows). This option must be selected to make the session cross-platform compatible.

8. Click Save.

To save an existing session that is compatible with Macintosh and Windows:

1. Choose File > Save Session Copy In.

2. In the Save Session Copy dialog, choose a destination and enter a name for the new session file.

3. Set the Audio File Type to AIFF or WAV. These file formats are compatible with either platform.

4. Set the Sample Rate and Bit Depth for the session.

5. Select “Enforce Mac/PC Compatibility” (Macintosh) or “Enforce PC/Mac Compatibility” (Windows). This option must be selected to make the session cross-platform compatible.

6. Select the Items to Copy to the new session.

7. Click Save.

If the session previously used SDII files, the files are converted to the new audio file format.

MacOpener and Cross-Platform Sessions (Windows Only)

MacOpener is supported by Pro Tools 5.3 or later on Windows. To share Pro Tools sessions between Macintosh and Windows, select the “Enforce Mac/PC Compatibility” option when creating the session, or when saving a session copy.

Although it is not recommended, MacOpener lets you record and play audio from HFS/HFS+ hard drives, as well as open Pro Tools sessions created on a Macintosh. See “To create a session that is compatible with Macintosh and Windows:” on page 112.

While SDII files can be exported, or converted on import, they cannot be used within Pro Tools sessions on Windows.

To install and configure the MacOpener demo included with Pro Tools:

1. Double-click the macopener5001.exe file in MacOpener Demo folder (located in the Pro Tools Utilities folder inside the Digidesign folder) to launch the installer. Follow the on-screen instructions. After installation is complete, restart your computer.

2. After restarting, go to Start > Programs > MacOpener 5.0 > MacOpener Driver Preferences.
3 Verify that the MacOpener Driver is enabled. Under Driver Settings, select “Enable MacOpener Driver.”

4 Under Extension Mapping, select “Do not add the PC extension to the Mac file name.”

⚠️ All formatting and drive maintenance for HFS/HFS+ drives should occur on the Macintosh.

**MacOpener Performance Limitations**

- To open a session from an HFS/HFS+ drive, the session must be created with Pro Tools 5.3 or later. In addition, the session must not be of mixed file formats. To use mixed-format sessions in Pro Tools, first save a session copy in the desired file format (make sure to select the option for “All Audio Files” under What To Copy).

- When using the Bounce To Disk command, the bounce destination must be a FAT/FAT32 drive. TDM systems also support NTFS. Bouncing to HFS/HFS+ drives is not supported.

- Operations such as opening sessions, initiating playback, drawing waveforms when zoomed, and allocating record files are slower on HFS/HFS+ drives than FAT/FAT32 or NTFS drives.

- Because MacOpener must clear the disk cache after copying between HFS/HFS+ drives and FAT/FAT32 drives of NTFS drives (TDM only), Pro Tools will launch very slowly after performing these disk copies.

- For SDII files to appear in the Import Audio dialog, you must set the File Of Type pop-up menu to “All Files.”

- On Pro Tools LE for Windows, when selecting all files in the Import Audio dialog, and some of these files have names with 13 or more characters, none will be added to the import list when clicking Convert All. The files can be added to the list if they are selected individually by Shift-clicking.
Part III: Recording
Chapter 11: Record Setup

Before you start recording, make sure your Pro Tools system is connected and configured properly. For details on connecting Pro Tools to your studio, refer to the Getting Started Guide that came with your system.

While some of the information in this chapter is relevant to recording MIDI, there are more specific setup details for MIDI recording in Chapter 13, “MIDI Recording.”

Input Connections and Audio Levels

Most Digidesign audio interfaces operate as line-level devices and offer no pre-amplification. You must therefore adjust the level of an input signal to line level before it reaches Pro Tools. Low-level sources like microphones and electric guitars need to be pre-amplified. You can do this with a quality mixing board or dedicated preamp.

The Digi 001 is an exception to this rule. Its I/O Box has two inputs with preamps, to which you can connect low-level signals, and six additional inputs with “input gain.”

Volume and pan controls for tracks in Pro Tools only affect monitoring levels—not the recording input gain. The LED meters on audio interfaces indicate both full-code (highest level before clipping) and true clipping of Pro Tools output signals. The on-screen meters in Pro Tools indicate only true clipping.

Digital Clipping

Clipping occurs when you feed a signal to a recorder or mixer that is louder or “hotter” than the device allows. On many analog tape decks, a little clipping adds a perceived warmth to the sound due to tape compression. In digital recording, however, clipping causes digital distortion, which is undesirable and should always be avoided.

Set Input Levels High But Don’t Clip

When you feed a signal into any audio recording system, including Pro Tools, you need to adjust the input level to optimize the dynamic range. Adjust the input signal to register as high as possible on your input meter without triggering the clipping indicator. If the input level is too low, you will not take full advantage of the dynamic range of your Pro Tools system. If the input level is too high, however, it will be clipped.
Calibration Mode (TDM Systems Only)
You can use the Calibration mode in Pro Tools to adjust the input and output levels for your audio interface so they match those of your mixing console and other audio devices in your studio.

The 192 I/O has +4 dBu and –10 dBV inputs, and +4 dBu outputs, each with their own trim pots for proper calibration. The 888|24 I/O has adjustable trim pots for its inputs and outputs.

There are no input or output trims on the following TDM Audio Interfaces: 96 I/O, 882|20 I/O, 1622 I/O, and ADAT Bridge I/O. Some Digidesign I/Os that do not have trim outputs offer software-controllable input level, adjustable from Setups > Hardware Setup (refer to your Getting Started Guide).

For more information on calibrating your Audio Interface, or using Calibration mode, see the Getting Started Guide.

Record Enabling Tracks (Using the Record Enable Button)
To record to a track you must first record-enable it with the Record Enable button. To record simultaneously to multiple tracks, you can record enable multiple audio or MIDI tracks.

When one or more tracks are record-enabled, you can click the Record and Play buttons in the Transport window to start recording.

Unlike audio tracks, MIDI tracks can be record-enabled on the fly while recording.

To record enable an audio or MIDI track:
- From either the Edit or Mix window, click the track’s Record Enable button.

Click again to take the track out of record-enabled mode.

To record enable all audio or MIDI tracks:
- Option-click (Macintosh) or Alt-click (Windows) the Record Enable button for any audio or MIDI track.

Option-click (Macintosh) or Alt-click (Windows) again to take all of those tracks out of record-enabled mode.

To record enable all selected tracks:
- Shift-Option-click (Macintosh) or Shift-Alt-click (Windows) the Record Enable button for any track.

Shift-Option-click (Macintosh) or Shift-Alt-click (Windows) any selected track to take all selected tracks out of record-enabled mode.

\* While record enabling does not affect audio tracks that are grouped, you can select all tracks in a group by clicking directly to the left of the group’s name in the Groups List. Then you can Shift-Option-click (Macintosh) or Shift-Alt-click (Windows) to record enable all selected tracks.

Record-enabled audio track
To record enable a MIDI track on the fly:
- Click the MIDI track’s Record Enable button while stopped or while Pro Tools is playing or recording. During recording, when you enable a new track, the previous record track is taken out of record-enabled mode.
  - or -
- While pressing Command (Macintosh) or Control (Windows), press the Up/Down Arrows to record enable the previous or next MIDI track. The previous (or next) record track is taken out of record-enabled mode.

Latch Record Mode

When the option for Latch Record Enable Buttons is selected in the Operations Preferences, you can record enable additional tracks by clicking their Record Enable buttons. Previously record-enabled tracks remain record-enabled.

When Latch Record Enable Buttons is deselected, record enabling a subsequent track takes the previously record-enabled track out of record-enabled mode.

To keep the previous track record-enabled, press Shift+Command+Up/Down (Macintosh) or Shift+Control+Up/Down (Windows).

You can always Shift-click the Record Enable buttons on multiple tracks to record enable them.

Record Safe Mode

Pro Tools provides a Record Safe mode that prevents tracks from being record-enabled. Use Record Safe mode to protect important track recordings.

To put an audio or MIDI track in Record Safe mode:
- Command-click (Macintosh) or Control-click (Windows) the track’s Record Enable button.

Command-click (Macintosh) or Control-click (Windows) again to take the track out of Record Safe mode.

To put all tracks in Record Safe mode:
- Command-Option-click (Macintosh) or Control-Alt-click (Windows) the Record Enable button on any track.

Command-Option-click (Macintosh) or Control-Alt-click (Windows) again to take all tracks out of Record Safe mode.

To put all currently selected tracks into Record Safe mode:
- Command-Option-Shift-click (Macintosh) or Control-Alt-Shift-click (Windows) the Record Enable button on any of the selected tracks to toggle them in and out of Record Safe mode.

Monitoring Modes

Pro Tools offers two modes of input monitoring, Auto Input Monitoring or Input Only Monitoring (chosen from the Operations menu), which determine how input signals are monitored while recording audio.
**Auto Input Monitoring**

In this mode, when session playback is stopped, Pro Tools monitors audio input. When playback is started for a punch-in, Pro Tools monitors existing track material up until the punch point. While punched in, the input signal is monitored. On punch-out, monitoring switches back to the existing track material. This is similar to the auto-switching logic found on digital and analog multitrack tape machines.

When Auto Input Monitoring is enabled, the Record button in the Transport window appears gray.

> **When using Auto Input Monitoring, the switch back to monitoring track material on punch-out is not instantaneous. To get instantaneous monitor switching on punch-out, use QuickPunch (see “QuickPunch Audio Recording” on page 161).**

**Input Only Monitoring**

In this mode, when a track is record-enabled, Pro Tools monitors audio input only, regardless of any punch in/out selection.

When Input Only Monitoring is enabled, the Record button in the Transport window appears green.

**Monitor Levels for Record and Playback**

You may want to monitor a certain track much louder when you are recording on it than when you are simply listening back to it. Therefore, Pro Tools remembers two different fader levels for each audio track: one for when the track is record-enabled, and one for when it is not record-enabled.

Pro Tools remembers these two states for fader levels automatically. If you adjust a fader when a track is record-enabled and then take the track out of record-enabled mode, the fader returns to its playback level.

When audio tracks are record-enabled, their volume faders in the Mix window turn red, indicating that the record monitor level is active.

**Link Record and Play Faders**

When the Operation Preference for “Link Record and Play Faders” is selected, Pro Tools does not keep track of record and play levels for audio tracks. In this case, record enabling an audio track has no effect on the fader level for the track. This lets you maintain a consistent mix regardless of whether you’re recording or just listening.
Monitoring Latency

(Pro Tools LE Only)

Because Pro Tools LE uses the host processor in your computer for audio processing, playback, and recording, there is a small amount of audio delay, or latency, in the system. This latency amount is related to the H/W Buffer Size—the larger the buffer size, the larger the latency.

While there may be times when you want a larger buffer size, for the sake of higher track counts with more plug-ins, you'll generally want a smaller buffer size when recording audio that is monitored through your Digi 001 or Audiomedia III.

If you are monitoring the audio material you're recording with an external mixer, you will not hear any latency.

To set the Hardware Buffer Size:

2. Choose the number of samples from the H/W Buffer Size pop-up.
3. Click OK.

⚠️ Computers with slower CPUs may not be able to use the 128 buffer size without encountering performance errors.

⚠️ If you have a SampleCell II Plus card, a buffer size of 128 should not be used when running the SampleCell Editor at the same time as Pro Tools LE. Use a larger buffer setting to avoid performance errors.

The following table lists the amount of monitoring latency (in milliseconds) you can expect from the four buffer sizes.

<table>
<thead>
<tr>
<th>Sample Rate (kHz)</th>
<th>Buffer Size (samples)</th>
<th>Latency Amount (ms)</th>
<th>Use for:</th>
</tr>
</thead>
<tbody>
<tr>
<td>44.1</td>
<td>128</td>
<td>2.9</td>
<td>recording drums and other timing-critical instruments</td>
</tr>
<tr>
<td></td>
<td>256</td>
<td>5.8</td>
<td>recording vocals and instruments with slower attacks (bass, guitar, etc.)</td>
</tr>
<tr>
<td></td>
<td>512</td>
<td>11.6</td>
<td>mixing with 24 tracks</td>
</tr>
<tr>
<td></td>
<td>1024</td>
<td>23.2</td>
<td>final mixdown or many plug-ins</td>
</tr>
<tr>
<td>48</td>
<td>128</td>
<td>2.7</td>
<td>recording drums and other timing-critical instruments</td>
</tr>
<tr>
<td></td>
<td>256</td>
<td>5.3</td>
<td>recording vocals and instruments with slower attacks (bass, guitar, etc.)</td>
</tr>
<tr>
<td></td>
<td>512</td>
<td>10.7</td>
<td>mixing with 24 tracks</td>
</tr>
<tr>
<td></td>
<td>1024</td>
<td>21.3</td>
<td>final mixdown or many plug-ins</td>
</tr>
</tbody>
</table>
Low Latency Monitoring
(Pro Tools LE Only)

You can reduce the amount of monitoring latency for Pro Tools LE systems by reducing the H/W Buffer Size. However, even at the smallest buffer size, there is still some latency. In addition, reducing the buffer size limits the number of simultaneous audio tracks you can record without encountering performance errors.

Digi 001 and Audiomedia III systems can use the Low Latency Monitoring option to record with an extremely small amount of monitoring latency, to as many tracks as each system supports.

To use Low Latency Monitoring:

1. Record enable the desired audio tracks (or Auxiliary Inputs) by clicking their Record Enable buttons. Only tracks with inputs set to an audio interface (not a bus) use Low Latency Monitoring.

2. From the Output Selector, assign each track to either Output 1 or Output 2. Only tracks assigned to these outputs use Low Latency Monitoring.


When Low Latency Monitoring is enabled, any plug-ins and sends assigned to record-enabled tracks (routed to Outputs 1–2) are automatically bypassed, and must remain bypassed. Also, these tracks will not register on meters for Master Faders.

Low Latency Monitoring and Bounce To Disk

With Low Latency Monitoring Enabled, only audio tracks are included with the Bounce To Disk command—Auxiliary Input tracks are ignored.

To record Auxiliary Inputs with Low Latency Monitoring enabled, you must record the material in real time.

Track Names

When creating new audio and MIDI tracks, Pro Tools names them as either “Audio” or “MIDI” and numbers them consecutively. For example, when you create 2 new audio tracks, their default names are “Audio 1” and “Audio 2.” You can rename tracks and also log comments for each track.

Track names define new file and region names when recording to a track. See “Default Names for Audio Files and Regions” on page 123.

To rename a track:

1. In the Edit or Mix window, double-click the Track Name.

2. In the Track Name/Comments dialog, type a new track name.

3. If desired, type comments for the track in the Comments text box. Click Previous and Next to rename another displayed track.

To switch tracks in the Track Name/Comments dialog, you can press Command (Macintosh) or Control (Windows) and use the Up/Down Arrows.
When you are finished, click OK.

**Default Names for Audio Files and Regions**

When recording to an audio track, the resulting file and region names are based on the name of the track. For example, after recording for the first time on a track called “Electric Gtr,” an audio file is written to your hard drive with the name “Electric Gtr-01.” In addition, a region appears in the Audio Regions List with the name “Electric Gtr-01-00.”

Subsequent record takes on the same track are named identically but with the first set of digits (indicating the take number) incremented. The second set of digits is only used for region naming and indicate a region auto-created from an edit.

*The QuickPunch record mode uses a slightly different method for numbering regions. For details, see “Region and Take Numbering with QuickPunch” on page 164.*

When recording MIDI tracks, a similar naming scheme is used, though with only one set of digits. For example, after recording to a track called “Synth 1,” a region is created called “Synth 1-01.” Subsequent regions for that track, generating either from additional record takes or region edits, are numbered sequentially.

**Names for Stereo Audio Tracks**

When recording to stereo audio tracks, audio file and region names for the left and right channels are appended with a “.L” and “.R” suffix.

**Names for Surround Tracks**

*(HD-Series and MIX-Series Systems Only)*

When recording to multichannel surround tracks, audio file and region names for each channel are appended with the following suffixes.

<table>
<thead>
<tr>
<th>Multichannel Format</th>
<th>File and Region Suffix</th>
</tr>
</thead>
<tbody>
<tr>
<td>LCR</td>
<td>L, C, R</td>
</tr>
<tr>
<td>Quad</td>
<td>L, R, Ls, Rs</td>
</tr>
<tr>
<td>LCRS</td>
<td>L, C, R, S</td>
</tr>
<tr>
<td>5.0</td>
<td>L, C, R, Ls, Rs</td>
</tr>
<tr>
<td>5.1</td>
<td>L, C, R, Ls, Rs, LFE</td>
</tr>
<tr>
<td>6.0</td>
<td>L, C, R, Ls, Cs, Rs, LFE</td>
</tr>
<tr>
<td>6.1</td>
<td>L, C, R, Ls, Cs, Rs</td>
</tr>
<tr>
<td>7.0</td>
<td>L, Lc, C, R, Rc, Ls, Rs</td>
</tr>
<tr>
<td>7.1</td>
<td>L, Lc, C, R, Rc, Rs, Ls, LFE</td>
</tr>
</tbody>
</table>

**Disk Allocation**

By default, Pro Tools records audio files to the Audio Files folder inside the session folder. You can use the Disk Allocation dialog to specify other locations for your audio files for each audio track.

Hard drives that are full do not appear in the Disk Allocation dialog.

To increase system performance, Pro Tools can record and play each track from a different hard drive. You can also automatically distribute any newly created tracks to multiple audio drives with Round Robin Allocation.
To allocate the audio drives in your system:

1. Choose Setups > Disk Allocation.

2. In the Disk Allocation dialog, assign a hard drive for each track by clicking in the Record Location column. A folder with the session name is created on each hard drive, containing subfolders for audio and fade files.

3. To automatically distribute any newly created tracks among the drives connected to your system, select “Use Round Robin Allocation for New Tracks.”

If you are using Round Robin Allocation and want audio to be recorded to your system’s startup drive, select Include System Volume (see “Recording to the System Volume” on page 125 for details).

⚠️ **Round Robin Allocation is not supported with partitioned hard drives.**

4. To save recorded audio files to an existing folder (without creating another session folder), select Customize Allocation Options, then click the Change button and choose the folder. To create subfolders in this folder, select “Create Subfolders for audio, video, and fade files.”

5. When you are finished, click OK.

### Customizing Allocation Options

To save Disk Allocation settings for use with future sessions, save the session as a template. For details, see “Creating Custom Session Templates” on page 48.

### Disk Allocation and Cross-Platform Sessions

Pro Tools for Windows supports recording and playback of audio from multiple hard drives, but to ensure cross-platform operation, it also requires that Macintosh Pro Tools sessions and their associated audio files be on Macintosh-formatted (HFS) drives.
Similarly, Windows sessions and their associated audio files must reside on Windows-formatted (FAT32) drives. If you want to share sessions between Windows and Macintosh platforms, consider these restrictions when allocating tracks to drives.

**Reallocating Tracks**

When opening a session where some of the previously assigned hard drives are no longer available (or don’t match the current session platform), Pro Tools automatically reassigns tracks to the volume where the session file is stored. In such cases, use Disk Allocation if you need to reallocate tracks to other drives.

*Reallocating tracks does not affect the audio that has been previously recorded. Reallocation tracks only affects where new audio recording will be saved.*

**Recording to the System Volume**

Though Pro Tools will let you record to your system hard drive, this is generally not recommended. Performance for audio recording and playback on system drives is worse than on non-system hard drives.

You should record to system drives only when absolutely necessary—if your computer system has just the one hard drive, or if your other hard drives are completely out of space.

---

When this preference is set to Use All Available Space, the drive’s entire available space is allocated. This can slow down the recording process for hard drives that use certain file systems, including HFS+ and NTFS.

In such cases, you can reduce the time it takes to begin recording by allocating only a portion of your hard drive.

**To allocate a portion of your hard drive for recording:**

1. Choose Setups > Preferences and click Operation.
2. Under the Open Ended Record Allocation option, select Limit To and enter a number of minutes to be allocated.

---

**Record Modes**

For recording audio, Pro Tools has four record modes:

- Non-destructive Record (Default)
- Destructive Record
- Loop Record
- QuickPunch
To enable Destructive Record, Loop Record, or QuickPunch, select them from the Operations menu. If none of these record modes are selected, Pro Tools is in normal Non-destructive Record mode.

The record mode can also be switched by Control-clicking (Macintosh) or Right-clicking (Windows) the Record button in the Transport window. This cycles through the four modes with the Record button changing to indicate the currently selected mode: blank for Non-destructive, “D” for Destructive, a loop symbol for Loop Record, and “P” for QuickPunch.

Non-destructive Record Mode

In normal Non-destructive Record mode, Pro Tools records audio non-destructively, which means that if you record over a track’s existing regions, the audio is not erased from your hard drive. Both the new and old audio remain on your hard drive, available as regions from the Audio Regions List.

In Non-destructive Record mode, the record range is defined by selecting a range in the Ruler or in a track’s playlist, or by specifying start and end points in the Transport window. If there is no selection, recording begins from the current cursor location and continues until the Transport’s Stop button is clicked.

Destructive Record Mode

In Destructive Record mode, recording over existing regions replaces the original audio permanently, which allows you to keep disk use to a minimum. However, if you have sufficient drive space, it is usually best to use Pro Tools in Non-destructive Record mode, to avoid losing any previously recorded material.

When defining the record range and setting pre-and post-roll, Destructive Record mode works the same as Non-destructive mode.

Unlike the other record modes, it is not possible to cancel record takes when using Destructive Record mode (see “Canceling a Record Take” on page 135).

Loop Record Mode

Loop Record mode allows you to record take after take (non-destructively) while the same section of audio repeats. This is a convenient technique for quickly recording multiple takes of a part without losing spontaneity.

The time range that is looped and recorded—which must be at least one second in length—is defined by selecting a range in the Ruler or in a track’s playlist, or by specifying start and end points in the Transport window.
The Record Modes and MIDI

In addition to the four record modes, there is also a MIDI Merge button in the Transport window that determines how MIDI is recorded. When enabled (Merge mode), recording over existing MIDI regions results in the new data being merged with the old. When the MIDI Merge button is deselected (Replace mode), the new material replaces the old.

MIDI Merge works the same whether using Non-destructive or Destructive Record mode. In addition, QuickPunch does not need to be enabled to punch on the fly with MIDI—this capability is available in Non-destructive and Destructive Record modes.

Unlike audio, MIDI can be loop recorded when Operations > Loop Playback is enabled. In this mode, the state of the MIDI Merge toggle determines whether existing material is replaced or merged.

In almost all instances, recording MIDI is destructive (though you can undo a MIDI record pass), either overwriting or adding to region material. One exception to this rule is when Loop Record mode is enabled; in this mode, existing track regions are replaced with new regions when new material is recorded. The old regions remain intact and available from the MIDI Regions List, and from the Takes List pop-up. In Loop Record mode, MIDI Merge has no effect, so its button is dimmed.
Recording with the Click

If you intend to work with MIDI tracks in your session, or if the audio you’re working with is bar- and beat-oriented, you can record your tracks while listening to the *click*. This ensures that recorded material, both MIDI and audio, will align with the session’s bar and beat boundaries.

When your track material lines up with the beats, you can take advantage of some useful editing functions in Pro Tools, such as quantizing MIDI and audio regions, quantizing individual MIDI notes, and copying and pasting measures and song sections in Grid mode.

> Material that is recorded without listening to the click can still be aligned to bar and beat boundaries in Pro Tools with Beat Detective (see Chapter 22, “Beat Detective”).

To configure the click options:

1. Choose MIDI > Click Options.
   
   – or –
   
   Double-click the Click or Countoff button in the Transport window.

2. In the Click/Countoff Options dialog, choose from the Output pop-up the port number (device) and channel that will play the click.

3. For the accented and unaccented notes, specify the note, velocity, and duration with the numeric keypad. If connected, you can also play new note values on your MIDI controller keyboard.

   When listening to the click in your Pro Tools sessions, the accented note sounds on the first beat of each measure and the unaccented note sounds on the remaining beats. Make sure the sound assigned to these notes has a sharp, percussive attack.

4. Select whether the click is heard “During play and record,” or “Only during record,” or “Only during countoff.”

5. If using a countoff, specify the number of Bars to be counted off. To hear the countoff only when recording, select that option.

6. Click OK.

To enable the click from the MIDI menu:

- Choose MIDI > Click.
To enable the click in the Transport:

1. To view the MIDI controls in the Transport window, select Display > Transport Window Shows > MIDI Controls.

2. In the Transport window, click the Click button so it becomes highlighted.

3. To use a countoff when recording or playing, click the Countoff button in the Transport window so it too becomes highlighted.

Hearing the countoff before recording is helpful in getting the feel for the tempo before you begin playing. The Countoff button in the Transport window displays the number of bars to be counted off.

> The countoff is ignored when Pro Tools is online and syncing to SMPTE time code.

Wait for Note and Countoff

Wait for Note and Countoff are mutually exclusive and cannot both be enabled at the same time. If, for instance, Countoff is enabled and you click the Wait for Note button, Countoff is disabled.

Setting the Default Meter

When opening a new session in Pro Tools, the meter defaults to 4/4. If you intend to record with the click and are working with a different meter, make sure to set the default meter accordingly.

If a session’s meter does not match the music you’re recording, the accented clicks will not line up with what you’re playing, and, as a result, the recorded material may not align with the bars and beats in the Edit window.

Meter events, which can occur anywhere within a Pro Tools session, are stored in the Meter Track and appear in the Meter Ruler. Inserting and editing for meter events is discussed in “Meter Events” on page 271.

To set the default meter for a session:

1. Choose Windows > Show Tempo/Meter.
   – or –

   Double-click the Meter button in the Transport window.
2 Enter the Meter you will use for the session and set the Location to 1|1|000 (so the inserted meter event replaces the default one).

3 Choose a note value for the number of clicks to sound in each measure.

4 Click Apply to insert the new meter event.

**Setting the Default Tempo**

When opening a new session in Pro Tools, the tempo defaults to 120 BPM. If you intend to record with the click and are working with a different tempo, make sure to set the default tempo accordingly. If you know the tempo you will use for the session, you can insert a tempo event at the beginning of the Tempo Track.

Tempo events, which can occur anywhere within a Pro Tools session, are stored in the Tempo Track and appear in the Tempo Ruler. Inserting and editing for tempo events is discussed in greater detail in “Tempo Events” on page 265.

To insert a default tempo event:

1. Choose Windows > Show Tempo/Meter.
   - or -
   Double-click the Meter button in the Transport window.

2. At the top of the Tempo/Meter Change window, choose Tempo Change from the pop-up menu.

3. Enter the BPM value you will use for the session and set the Location to 1|1|000 (so the inserted tempo event replaces the default tempo).

4. To base the BPM value on something other than the default quarter-note, select the desired note value.

5. Click Apply to insert the new tempo event.

See “Default Tempo” on page 268 for more information on the default tempo.

**Using Manual Tempo Mode**

In Manual Tempo mode, Pro Tools ignores the tempo events in the Tempo Track and instead plays back at the tempo displayed in the Transport window. The manual tempo can be set with the Tempo slider, or, if you’re not sure of the actual tempo, by tapping in the tempo.
While you can adjust the Manual Tempo during playback, doing so will momentarily interrupt playback.

**To set the manual tempo with the Tempo slider:**

1. To view the MIDI controls in the Transport window, select Display > Transport Window Shows > MIDI Controls.
2. In the Transport window, click the Conductor button so it becomes unhighlighted.
3. To base the BPM value on something other than the default quarter-note, change the note value in the Beat Value pop-up menu (just to the left of the Tap button).
4. To enter a new tempo, drag the horizontal Tempo slider in the Transport window.

   For finer resolution with the Tempo slider, press Command (Macintosh) or Control (Windows) while dragging.

**To exit Manual Tempo mode and enable the Tempo Track:**

- Click the Conductor button in the Transport window so it becomes highlighted.

**To set the manual tempo with the Tap button:**

1. To view the MIDI controls in the Transport window, select Display > Transport Window Shows > MIDI Controls.
2. In the Transport window, click the Conductor button so it becomes unhighlighted. Pro Tools switches to Manual Tempo mode. In this mode, any tempo events in the Tempo Track are ignored.
3. Click the Tap button repeatedly at the desired tempo.

   - or -

   Click in the Tempo field so it becomes highlighted and tap in the tempo by playing a note on your MIDI keyboard controller.

   To compute the new tempo, Pro Tools requires at least four taps (each of which is displayed in the Tap area when received). The computed BPM value appears in the Transport’s Tempo field.

   **To lock in the new tempo:**

   - Take Pro Tools out of Manual Tempo mode by clicking the Conductor button, then insert a tempo event (with the new tempo) at the beginning of the Tempo Track.
Chapter 12: Basic Audio Recording

Recording a Mono Audio Track

When recording from a mono source, record to a single, mono audio track in Pro Tools.

To configure a mono audio track for recording:

1. Connect a mono sound source to the appropriate input of your audio hardware.

2. If you want to start a new session with a different sample rate, choose File > New Session, and select the sample rate. Press Save.

3. Make sure to specify the format (analog or digital) of the inputs of the audio interface you will be using. Choose Setups > Hardware Setup, choose the audio interface, and select the format for the channel pair.

Some Digidesign I/O units, such as Digi 001, only have two channels (Ch 1–2) that can be set for analog or digital.

4. If a track doesn’t already exist, choose File > New Track and specify 1 Mono Audio Track, then click Create.

5. If desired, rename the track. Track names are used to auto-name recorded audio files and regions. For more information, see “Track Names” on page 122.

6. In the Mix Window, click the audio track’s Record Enable button to record enable the track. Volume faders for record-enabled tracks turn red.

7. In the Mix window, use the track’s Input Selector to assign a hardware input.

8. In the Mix window, click on the track’s Output Selector and assign a hardware output.

9. Adjust the output level of your sound source (instrument, mixer, or preamp). Monitor the track’s meter levels in Pro Tools to ensure that you get the highest possible signal without clipping.
In the Mix window, adjust the track's volume and pan faders as desired. These settings are for monitoring purposes only and do not affect the recorded material.

To record to a mono audio track:

1. Put Pro Tools in Non-destructive Record mode. In the Operations menu, deselect Destructive Record, Loop Record, and Quick-Punch.

2. If desired, enable the click and countoff in the Transport window. Also, make sure to specify the session's default meter and tempo. For details, see “Recording with the Click” on page 128.

3. In the Transport window, click Return to Zero so the start and end times are cleared. This ensures that you'll start recording from the beginning of the track.

4. Click Record in the Transport window. The Record button flashes.

5. When you are ready to begin recording, click Play. If using a countoff, Pro Tools counts off the specified number of measures and then begins recording.

6. When you have finished recording, click Stop in the Transport window.

The newly recorded audio is written to disk and appears as an audio region in the track's playlist. The new audio region also appears in the Audio Regions List.

To play back the mono audio track:

1. Click the Record Enable button for the audio track to take it out of record-enabled mode. The track's volume fader now functions as a playback level control.

2. In the Transport window, click Return to Zero.

3. Click Play in the Transport window to begin playback. Adjust the track's volume and pan faders as necessary.

Record Shortcuts

In addition to clicking the Record button in the Transport window, you can also begin recording with the following keyboard shortcuts:

- Press F12
- Press Command+Spacebar (Macintosh) or Ctrl+Spacebar (Windows)
- Press 3 on the Numeric Keypad (when the Numeric Keypad Mode is set to Transport)

To initiate recording at half-speed, press Command+Shift+Spacebar (Macintosh) or Control+Shift+Spacebar (Windows). For details, see “Half-Speed Recording and Playback” on page 166.

Undo and Audio Recording

Once you've recorded an audio track and the transport is stopped, you can undo the previous record take.

To undo an audio recording:

- Once the Transport has been stopped, choose Edit > Undo Audio Recording.

The track's playlist is restored to its previous state. However:

- If you punched in and out several times before stopping the Transport, only the last punch is undone.
When using Loop Record mode, all takes from each record pass are discarded.

**Canceling a Record Take**

While recording, it is possible to discard the current record take. This removes the audio (recorded up to that point) from your hard drive and deletes the region from the track’s playlist. This capability is not available in Destructive Record mode.

**To cancel a record take while recording:**

- Press Command+period (Macintosh) or Control+period (Windows) before the Transport is stopped.

If using Loop Record mode, all takes from each record pass are discarded.

---

**Recording a Stereo Audio Track**

To record a stereo audio source in Pro Tools, record to a single, stereo audio track.

**To record audio in stereo:**

1. Connect the left and right outputs from your sound source to the appropriate inputs of your audio hardware.
2. If a track doesn’t already exist, choose File > New Track and specify 1 Stereo Audio Track, then click Create.
3. If desired, rename the track. Track names are used to auto-name recorded audio files and regions. For more information, see “Track Names” on page 122.
4. In the Mix Window, click the audio track’s Record Enable button to record enable the track. Volume faders for record-enabled audio tracks turn red.
5. In the Mix window, use the Input Selector to assign the stereo input pair for the track’s left and right channels.
6. In the Mix window, click on the track’s Output Selector and assign a stereo hardware output.
7. Adjust the output level of your sound source (instrument, mixer, or preamp). Monitor the track’s meter levels in Pro Tools to ensure that you get the highest possible signal without clipping.
8. In the Mix window, adjust the track volume and pan faders as desired. These settings are for monitoring purposes only and do not affect the recorded material.
9. Put Pro Tools in Non-destructive Record mode. In the Operations menu, deselect Destructive Record, Loop Record, and Quick-Punch.
10 If desired, enable the click and countoff in the Transport window. Also, make sure to specify the session’s default meter and tempo. For details, see “Recording with the Click” on page 128.

11 In the Transport window, click Return to Zero so the start and end times are cleared. This ensures that you’ll start recording from the beginning of the track.

12 Click Record in the Transport window.

13 When you are ready to begin recording, click Play. If using a countoff, Pro Tools counts off the specified number of measures and then begins recording.

14 When you have finished recording, click Stop in the Transport window.

A single, mono audio file is written to disk for each track; one for the left channel, and one for the right channel; regions appear in the playlists for both channels. In addition, a multichannel (stereo) region appears in the Audio Regions List.

To play back the stereo audio track:

1 In the Transport window, click Return to Zero.

If Auto Input Monitoring is enabled, you can simply click the Record button in the Transport window to exit Record mode, then press Play, leaving the track record-enabled. The track will automatically switch to Playback mode when you press play, then back to Input mode when you stop. See “Auto Input Monitoring” on page 120.

2 Adjust the track’s volume and pan faders as necessary.

Recording Multichannel Tracks
(Pro Tools HD-Series and Mix-Series Systems Only)

Recording multichannel tracks is very similar to recording stereo audio tracks. A single, mono audio file is written for each channel in the track, and regions appear in the playlists for each channel. In addition, a multichannel region appears in the Audio Regions List.

Recording Multiple Audio Tracks

Pro Tools can record multiple audio tracks simultaneously, up to the track recording limits of your system. To record to multiple audio tracks, record enable each track you want to record.

To record multiple audio tracks:

1 Connect the outputs from your sound source to the appropriate inputs of your audio hardware.

2 If you want to start a new session with a different sample rate, choose File > New Session, and select the sample rate. Press Save.

3 Make sure to specify the format (analog or digital) of the inputs of the audio interface you will be using. Choose Setups > Hardware Setup, choose the audio interface, and select the format for the channel pair.
Some Digidesign I/O units, such as Digi 001, only have two channels (Ch 1–2) that can be set for analog or digital.

4 If you need to create any tracks, choose File > New Track and specify the number of audio tracks, then click Create.

5 Record enable the audio tracks you want to record by clicking their Record Enable buttons. As long as the preference for Latch Record Enable Buttons is enabled, you can record enable subsequent tracks by clicking their Record Enable buttons. Other tracks already record-enabled will remain so.

6 In the Mix window, assign an audio input and output for each record track.

7 Adjust the output level of your sound sources (instruments, mixer, or preamp). Monitor the tracks’ meter levels in Pro Tools to ensure that you get the highest possible signal without clipping.

8 In the Mix window, adjust the tracks’ volume and pan faders as desired. These settings are for monitoring purposes only and do not affect the recorded material.

9 Put Pro Tools in Non-destructive Record mode. In the Operations menu, deselect Destructive Record, Loop Record, and Quick-Punch.

10 If desired, enable the click and countoff in the Transport window. Also, make sure to specify the session’s default meter and tempo. For details, see “Recording with the Click” on page 128.

11 In the Transport window, click Return to Zero so the start and end times are cleared. This ensures that you’ll start recording from the beginning of the track.

12 Click Record in the Transport window. When you are ready to begin recording, click Play.

13 When you have finished recording, click Stop in the Transport window.

For each record-enabled track, a new audio file is written to disk and a new region is created and appears in the playlist. The new audio regions appear in the Audio Regions List.

You can create an Edit and Mix Group for the recorded tracks so that edits, fader movements, and mutes are automatically applied to the tracks.

Record Pause Mode

When recording a large number of tracks or channels, or playing back a large number of tracks while recording, Pro Tools may take a little longer to begin recording. To avoid this delay, put Pro Tools in Record Pause mode before beginning to record.

To record from Record Pause mode:

1 Click Record in the Transport window. The Record button flashes.

2 Option-click (Macintosh) or Alt-click (Windows) Play in the Transport window to put Pro Tools in Record Pause mode. The Play and Record buttons flash.

3 To begin recording instantaneously, click Play. When you have finished recording, click Stop in the Transport window.
You can also use Pause mode when recording or playing large numbers of tracks to speed up lock-up time when syncing to time code.

**Recording Additional Takes**

After recording to an audio track, you can record additional takes to the same track. However, if you record these additional takes in Destructive Record mode, the audio residing on your hard drive from the previous takes will be permanently lost.

To keep the audio from previous takes, record the new takes non-destructively in Non-destructive Record mode.

For details on audio file and region names for new takes, see “Track Names” on page 122.

To non-destructively record a new take on the same track:

1. Put Pro Tools in Non-destructive Record mode. In the Operations menu, deselect Destructive Record, Loop Record, and Quick-Punch.
2. Make sure the track containing the previous take is still record-enabled.
3. Make sure to select Operations > Link Edit and Timeline Selection. This lets you set the record start time by clicking anywhere in the track’s playlist.
4. To record from the beginning of the track, click Return to Zero in the Transport window.
   – or –
   Click anywhere in the track’s playlist to begin recording from that point.

To destructively record over a previous take:

1. Select Operations > Destructive Record. When using Destructive Record mode, a “D” appears in the Record button.

   Destructive Record mode enabled

2. Make sure the track containing the previous take is still record-enabled.
3. Make sure to select Operations > Link Edit and Timeline Selection. This lets you set the record start time by clicking anywhere in the track’s playlist.
4. To record from the beginning of the track, click Return to Zero in the Transport window.
   – or –
   Click anywhere in the track’s playlist to begin recording from that point.
5 Click Record in the Transport window. When you are ready to begin recording, click Play.

6 When you have finished recording, click Stop in the Transport window.

The audio for the new take is written to disk, permanently overwriting the original. The new material replaces the original material within the existing region.

Appending New Material to the End of a Track

You can also append new material to the end of a track. To do this, locate to the end of the track with the Go to End button in the Transport window. From there, simply begin recording and Pro Tools will add the new material to the end of the track. If using Destructive Record mode, the new audio is appended to the audio file and region from the first take. In Non-destructive Record mode, a new file and region are created.

Recording to a New Playlist

Instead of recording over existing audio regions, there is another way to non-destructively record new takes to the same track. Do this by creating a new playlist for the track, then record just as before.

Tracks can have multiple edit playlists, each of which stores a list of regions strung together in a particular order.

To record a specific track range, with precise start and end points, see “Punch Recording Audio” on page 140.

To record to a new playlist for a track:

1 From the track’s Playlist Selector pop-up, choose New. Enter a name for the new playlist and click OK.

When a new playlist is created, its name replaces the track name. With this playlist active, names for new audio files and regions are based on its name.

2 Make sure the track is still record-enabled.

3 In the Transport window, click Return to Zero.

4 Click Record in the Transport window. When you are ready to begin recording, click Play.

5 When you have finished recording, click Stop in the Transport window.

An audio file for the new take is written to disk and appears as an audio region in the track’s playlist. The new audio region appears in the Audio Regions List.

6 To audition the new take, click Play in the Transport window.

7 To go back to a previous playlist to compare it to the new take, select the playlist from the track’s Playlist Selector.

Selecting a playlist recalls its regions as they previously appeared in the track. At any time, all regions from all playlists are available in the Regions List, and can be mixed and matched between playlists and tracks.

For more information on playlists and playlist editing, see “Playlists” on page 178.
**Punch Recording Audio**

To replace a portion of a recorded track, you can punch in by specifying the record range before recording.

To manually punch in and out on record-enabled audio tracks during playback, refer to “QuickPunch Audio Recording” on page 161.

Though there are several ways to set record and play ranges (see “Setting Punch/Loop Points” on page 144), perhaps the easiest is to select within the track’s playlist the material to be replaced.

To set a record or play range by selecting within a playlist, the Edit and Timeline selections must be linked (select Operations > Link Edit and Timeline Selection).

You can listen to track material up to and after the punch record range by enabling pre- and post-roll.

During the recording process, playback begins at the pre-roll time (if enabled) and proceeds to the start time (the punch-in point), where recording begins. When the end time (the punch-out point) is reached, Pro Tools automatically switches out of Record mode and continues playing through the specified amount of post-roll. This automated punch-in/out feature is a powerful and precise way of re-recording a portion of a track.

If you are recording in Non-destructive Record mode, punches do not permanently replace the source material. If you do want to permanently record over the punched record range (and keep only the last, or most recent take), select Operations > Destructive Record.

**Monitoring during Punch-Ins**

When punch recording, you may want to enable Auto Input Monitoring (by selecting it in the Operations menu). For details, see “Auto Input Monitoring” on page 120.

To punch record on an audio track:

1. To record non-destructively, make sure that Operations > Destructive Record is not selected.

   If you do want to permanently record over the punched record range, select Operations > Destructive Record.

2. Make sure the track containing the previous take is still record-enabled.

3. Make sure to select Operations > Link Edit and Timeline Selection.

4. With the Selector, drag in the track’s playlist until the selection encompasses the desired punch range.

   For other methods of setting the record range, see “Setting Punch/Loop Points” on page 144.

5. To hear existing track material up to the start point, or after the end point, enable and set pre/post-roll times. For details, see “Setting Pre/Post-Roll” on page 145.

6. Click Record in the Transport window. When you are ready to begin recording, click Play.

   When the start point is reached, Pro Tools begins recording. Recording continues until the end point is reached, unless Stop is clicked in the Transport window. If post-roll is enabled, playback continues for the specified post-roll amount.

   If recording non-destructively, a new audio file is written to your hard drive and a new audio region appears in the record track and Audio Regions List.
If recording in Destructive Record mode, the new audio overwrites the previous material in the existing audio file and region.

## Loop Recording Audio

Pro Tools provides a loop recording feature that allows you to record take after take while the same section of audio repeats over and over. This is a convenient technique for quickly recording multiple takes of a part without losing spontaneity.

When loop recording, you must first specify the start and end points for the loop. Though there are several ways to set record and play ranges (see “Setting Punch/Loop Points” on page 144), perhaps the easiest is to select within the track’s playlist the material to be looped.

You can listen to track material up to and after the loop record range by enabling pre- and post-roll.

The pre-roll setting, if enabled, is used only during the first record pass, and the post-roll setting, if enabled, is used only on the last pass. Pre- and post-roll times are ignored on each successive loop. To compensate for this, you may want to make the loop range slightly longer. Later, you can trim back the recorded takes to the desired length with the Trimmer tool (see “The Trimmer Tool” on page 218).

When loop recording audio, Pro Tools creates a single audio file that comprises all takes. Takes appear as individual regions in the Audio Regions List and are numbered sequentially. Once you stop recording, you can audition any of the recorded takes.

### To loop record an audio track:

1. Select Operations > Loop Record. When Loop Record mode is enabled, a loop symbol appears in the Record button.

2. Record enable the audio track by clicking its Record Enable button.

3. Make sure to select Operations > Link Edit and Timeline Selection.

4. With the Selector, drag in the track’s playlist until the selection encompasses the desired loop range. For other methods of setting the record range, see “Setting Punch/Loop Points” on page 144.

5. To hear track material up to the start point of the loop, enable and set the pre-roll time. For details, see “Setting Pre/Post-Roll” on page 145.

6. Click Record in the Transport window. When you are ready to begin recording, click Play.

The Record button flashes during the pre-roll. When the start point is reached, Pro Tools begins recording. When the end point is reached, Pro Tools loops back to the start time and continues playing and recording.

7. To cancel all recorded takes while loop recording, press Command+period (Macintosh) or Control+period (Windows).
When you have finished recording, click Stop in the Transport window.

If you stop recording before you reach the midpoint of the loop, Pro Tools discards that take. If you record more than half of the looped take, Pro Tools will leave the take in the track when you stop recording.

The recorded takes appear as regions in the Audio Regions List and are numbered sequentially. The most recently recorded take is left in the record track. For details on auditioning the various takes from the Takes List pop-up, see “Auditioning from the Takes List Pop-up Menu” on page 142.

**Loop Playback and Audio Recording**

Pro Tools ignores “loop playback” when recording. The only way to loop while recording is to enable Loop Record mode.

**Auditioning Record Takes**

After recording multiple takes with loop or punch recording, you can replace the take currently residing in the track with previous takes to audition them.

**To place and audition previous takes:**

1. In the Edit window, select the current take with the Grabber.
2. Command-drag (Macintosh) or Control-drag (Windows) another take from the Audio Regions List into the playlist.

The region replaces the previous take and snaps precisely to the correct location.

3. Repeat the above steps as desired to audition other takes.

All takes are numbered sequentially.

**Auditioning from the Takes List Pop-up Menu**

Each region resulting from a punch or loop record pass has an identical start time (the User Time Stamp). This allows you to easily select and audition takes from the Takes List pop-up menu—even while the session plays or loops.

**To select a take from the Takes List pop-up:**

1. Command-click (Macintosh) or Control-click (Windows) with the Selector at the precise beginning of the loop or punch range.

   – or –

   If the take currently residing in the track is selected, Command-click (Macintosh) or Control-click (Windows) it with the Selector.

A pop-up menu appears containing a list of regions that share the same User Time Stamp.

2. Choose a region from the Takes List pop-up menu. The region replaces the previous take and snaps precisely to the correct location.

3. Repeat the above steps as desired to audition other takes.

One way to ensure that future takes have the same User Time Stamp (and appear in the Takes List pop-up) is to store punch and loop record selections as Memory Locations. Then if you
later need to record additional takes, simply recall the Memory Location. For more information, see “Storing and Recalling Edit Selections (with Pre- and Post-Roll Values)” on page 147.

To change the User Time Stamp of other regions so that they appear in the Takes List pop-up for a certain location, use the Time Stamp Selected command in the Regions List pop-up menu. For more information, see “Time Stamping” on page 494.

**Takes List and Multiple Tracks**

If you have recorded a group of tracks and each contains takes with identical User Time Stamps, you can use the Takes List pop-up menu to replace all takes simultaneously.

To replace the takes for multiple tracks:

1. Choose Setups > Preferences and click Editing and enable the following options:
   - Take Region Name(s) That Match Track Names
   - Take Regions Lengths That Match
2. Click Done to close the Preferences dialog.
3. With the Selector, select the take range for each track you want to replace.
4. Command-click (Macintosh) or Control-click (Windows) any of the select takes with the Selector.
   A pop-up menu appears containing a list of regions that share the same User Time Stamp for that track.
5. Choose a region from the Takes List pop-up menu. The region replaces the previous take and snaps precisely to the correct location. The same take numbers for the other selected tracks are also automatically selected.

**Editing Preferences and Take Regions**

In addition to having the same User Time Stamp, regions that appear in the Takes List pop-up are also restricted according to the following options in the Editing Preferences:

**Take Region Names That Match Track Names**

When selected, only regions that share the same root name with the track/playlist appear in the Takes List pop-up menu. For example, the Takes List for a track named “Gtr.L” would show the regions “Gtr.L-01” and “Gtr.L-02-01,” but not “Guit.L-01.”

**Take Region Lengths That Match**

When selected, only regions that match the length of the current selection (even if it is not an entire region) appear in the Takes List pop-up menu. If there is no selection, all takes with the same User Time Stamp are displayed.

**“Separate Region” Operates On All Related Takes**

When selected, editing a region with the Separate Region command also affects all other related takes with the same User Time Stamp.

This option helps you compare different sections from a group of related takes. For example, you can quickly separate an entire group of related vocal takes into sections, then audition and select the best material from each section independently.

If this option is selected, make sure the “Take Region Names That Match Track Name(s)” and “Take Region Lengths that Match” options are also selected. If they are not, *all* regions in the session that have the same User Time Stamp will be affected.
In most instances, you’ll want to deselect the “Separate Region Operates On All Related Takes” option, to prevent a large number of regions from being created when you use the Separate Region command.

### Setting Punch/Loop Points

The start and end points of a record range for punch and loop recording can be set by the following means:

- Select a range in a track’s playlist
- Select a range in a Timebase Ruler
- Drag the Playback Markers in the Ruler
- Enter start and end times in the Transport window
- Recall a Memory Location

#### To set the record range in a track’s playlist:

1. If desired, set the Edit mode to Grid so the selection is constrained to the current Grid value.
2. Make sure to select Operations > Link Edit and Timeline Selection.
3. With the Selector, drag in a track’s playlist until the selection encompasses the desired record range.

   – or –

   If a region’s start and end points define the record range, click on the region with the Grabber.

#### To set the record range in a Timebase Ruler:

1. If desired, set the Edit mode to Grid so the selection is constrained to the current Grid value.
2. Drag with the Selector in any Timebase Ruler until the selection encompasses the desired record range.

#### Playback Markers

When tracks are record-enabled, Playback Markers for start and end times appear as red up/down arrows in the Ruler. If no tracks are record-enabled, the Playback Markers are blue.

The Playback Markers can be moved, either separately or at the same time, to set record and play ranges.

#### To set the record range by dragging the Playback Markers:

1. If desired, set the Edit mode to Grid so the dragged Playback Markers snap to the current Grid value.
Drag the first Playback Marker (down arrow) to the start point of the range.

Drag the second Playback Marker (up arrow) to the end point of the range.

If the current record range is already the right length and the range needs only to be moved, Option-drag (Macintosh) or Alt-drag (Windows) either Playback Marker to move both to a new location (while keeping the same length).

**Start and End Fields**

The Transport window can be resized to display start, end, and length times, and pre- and post-roll settings (choose Display Transport Window Shows > Expanded). When setting a record or play range, it is reflected in these fields.

Start and End Fields in Transport window

You can enter locations in the start and end fields to set the record or play range. The Playback Markers in the Ruler are updated accordingly.

**To set the record range by entering start and end times in the Transport window:**

1. If necessary, resize the Transport window by clicking in the upper right so the start and end times are displayed.

   ![Transport window with start/end displayed](image)

2. In the Transport window, click in the start field.

   – or –

   Press Option+slash (Macintosh) or Alt+slash (Windows) to select the start field in the Transport window.

3. Type in the start location and press slash to enter the value and automatically move to the end field.

4. Type in the end location and press Enter to accept the value.

**Setting Pre/Post-Roll**

Pre- and post-roll times appear as flags in the Ruler. When pre- and post-roll are enabled, the flags are green, otherwise they are gray.

Pre- and post-roll times are displayed in the Transport window.

Green Pre/Post-Roll Flags (enabled) in the Ruler

You can enter pre- and post-roll amounts by dragging the markers, or by using the Transport window. Pre- and post-roll add significant demand on the system and should be disabled when not strictly needed (especially when using QuickPunch, which also adds load to the system).
Setting Pre- and Post-Roll in the Transport Window

Pre- and post-roll can be enabled and set from the fields in the Transport window.

To set and enable the pre- and post-roll times in the Transport window:

1. If necessary, resize the Transport window by clicking in the upper right so the start and end times are displayed.
2. In the Transport window, click in the pre-roll field.
3. Type in the pre-roll amount and press slash to enter the value and automatically move to the post-roll field.
4. Type in the post-roll amount and press Enter to accept the new value.
5. To enable either pre- or post-roll, click the appropriate button so it becomes highlighted.

Use the period (.) or Left/Right Arrow keys to move through the different time fields for pre/post. Use the Up/Down Arrow keys to increase or decrease the numerical values.

Setting Pre- and Post-Roll in a Playlist

You can use the Selector to enable and disable pre- and post-roll by clicking in a track’s playlist.

To set and enable the pre- and post-roll by clicking in a playlist:

1. Make sure to select Operations > Link Edit and Timeline Selection.
2. With the Selector, drag in the track’s playlist until the selection encompasses the desired record range.
3. With the Selector, Option-click (Macintosh) or Alt-click (Windows) in the track’s playlist before the selection to enable the pre-roll at that location.
4. With the Selector, Option-click (Macintosh) or Alt-click (Windows) in the track’s playlist after the selection to enable the post-roll at that location.

To disable the pre- and post-roll by clicking in a playlist:

1. With the Selector, Option-click (Macintosh) or Alt-click (Windows) within a track selection near the start to disable the pre-roll.
2. With the Selector, Option-click (Macintosh) or Alt-click (Windows) within a track selection near the end to disable the pre-roll.

In the timeline, you can reset the pre- and post-roll to zero. First, drag the Pre-Roll Flag to the Playback Marker at the start point of the range, then drag the Post-Roll Flag to the Playback Marker at the end point of the range.

3. Drag the Pre-Roll Flag to the Playback Marker at the start point of the range.
4. Drag the Post-Roll Flag to the Playback Marker at the end point of the range.

Enabling Pre- and Post-Roll from the Operations Menu

Pre- and post-roll (as a pair) can be enabled and disabled from the Operations menu.

To enable both pre- and post-roll from the Operations menu:

Dragging Pre- and Post-Roll Flags in the Timebase Ruler

The Pre- and Post-Roll Flags can be moved in the Ruler, either separately or at the same time, to set their location.

To set the pre- and post-roll amounts by dragging in the Ruler:

1. If desired, set the Edit mode to Grid so the dragged flags snap to the current Grid value.
2. Drag the Pre-Roll Flag to the desired location in the Ruler.
3. Drag the Post-Roll Flag to the desired location in the Ruler.

To set pre- and post-roll values to the same amount, Option-drag (Macintosh) or Alt-drag (Windows) either the Pre- or the Post-Roll Flag in the Ruler. The deselected flag will immediately reset to the same value, and will adjust accordingly as you drag the selected flag.

Storing and Recalling Edit Selections (with Pre- and Post-Roll Values)

You can store Edit selections as Memory Locations, which can include current pre- and post-roll values.

For more information on Memory Locations, see “Memory Locations and Markers” on page 274.

To save an Edit selection with a Memory Location:

1. Make sure to select Operations > Link Edit and Timeline Selection.
2. Set the record range by making a playlist or Ruler selection, or by entering start and end times in the Transport window.
3. If desired, enable and set the pre/post-roll amounts in the Transport window, or by dragging the Pre- and Post-Roll Flags in the Ruler.
4. Press Enter on the numeric keypad.
5. In the New Memory Location dialog, set Time Properties to Selection, and, if desired, under General Properties, select the option for Pre/Post Roll Times.
6. Enter a name for the new Memory Location and click OK to save it.

To recall an Edit selection with a Memory Location:

1. Make sure to select Operations > Link Edit and Timeline Selection.
2. Choose Windows > Show Memory Locations.
3. In the Memory Locations window, click the name or number of the Memory Location.

The start and end times and pre/post-roll settings stored with the Memory Location are recalled.
Chapter 13: MIDI Recording

Although recording MIDI in Pro Tools is similar to recording audio, there are some important differences.

- Unlike audio, MIDI recording is almost always destructive. See “The Record Modes and MIDI” on page 127 for details.
- Unlike audio, a MIDI recording take can be undone after stopping the Transport. For details, see “Undo and MIDI Recording” on page 155.
- Unlike audio tracks, MIDI tracks can be record enabled on the fly while recording.
- Similar to audio tracks, MIDI tracks have an Input Selector that determines which channels are routed and recorded to the track. If the Input Selector is set to All, all channels for all devices are routed to the track.
- It is not necessary to use QuickPunch to punch in on the fly with MIDI tracks. This capability is available in normal Nondestructive Record mode, and in Destructive Record mode.

Recording from MIDI Devices

The MIDI Inputs for record-enabled MIDI tracks determine which MIDI data is recorded in Pro Tools. MIDI Inputs can be set to a specific device and channel, or they can be set to “All,” where all channels for all devices are merged to the track.

MIDI tracks in Pro Tools do not contain multiple channels and always play back on the track’s assigned (MIDI output) devices and channels. Multiple MIDI channels can be simultaneously recorded to multiple tracks.

The following Pro Tools options determine whether you can record from a MIDI controller device:

- Devices that are assigned as a MIDI Controller in the Peripherals dialog are ignored when MIDI tracks are recorded. This is to avoid recording data from MIDI control surfaces like the Mackie HUI.
- On the Macintosh, to record to a device, it must be enabled in the Input Devices dialog. For more information, see “Enabling Input Devices” on page 150.

In addition, the following options affect how MIDI data is recorded in Pro Tools.

- The MIDI Input Filter can filter out MIDI messages that you may not want to record, such as Polyphonic Aftertouch or System Exclusive data. For more information, see “MIDI Input Filter” on page 151.
- Input Quantize, when enabled, automatically quantizes (time corrects) all MIDI notes that are recorded. For more information, see “Input Quantize” on page 151.
Enabling Input Devices
(Macintosh Only)

To record from a MIDI controller in Pro Tools, the device must be enabled in the Input Devices dialog. You can also use this dialog to make sure unwanted notes from certain devices, such as drum machines or arpeggiators, are not recorded.

MIDI Control Surfaces In order to use control surfaces, like the Mackie HUI, they must be enabled in the Input Devices dialog.

MMC In order for Pro Tools to sync to MMC, the MMC source must be enabled in the Input Devices dialog.

To enable input devices:
2. In the Input Devices dialog, select the MIDI devices you will record from. Also, make sure any devices that will be used as a control surface are also selected.
3. Deselect any devices you want to ignore while recording MIDI.
4. When you are finished, click OK.

MIDI Thru

To monitor MIDI tracks while recording, enable MIDI Thru. When enabled, Pro Tools routes MIDI from your controllers to the device and channels assigned to the MIDI track currently record-enabled.

The MIDI Preference for Global MIDI Playback Offset and individual MIDI track offsets do not affect MIDI routed with MIDI Thru.

When MIDI Thru is enabled, System Exclusive events are echoed to the MIDI device assigned to the record-enabled track—but only if the sysex events are smaller than 256 bytes.

To enable MIDI Thru:
- Select MIDI > MIDI Thru.

When using MIDI Thru, you should disable Local Control on your MIDI keyboard controller. Otherwise, your keyboard may receive double MIDI notes, which can lead to stuck notes. If unsure how to disable Local Control for your instrument, refer to the manufacturer’s documentation.
The Default Thru Instrument

In addition to any MIDI tracks that are record-enabled, you can also route MIDI to the Default Thru Instrument. This saves you the trouble of creating a MIDI track and record enabling it to hear a particular MIDI device and channel.

Unlike MIDI tracks, which only listen to the device and channel assigned to its Input Selector, all incoming MIDI data is routed to the Default Thru Instrument.

If the Default Thru Instrument is assigned to a record-enabled MIDI track, Pro Tools only routes to the record-enabled track.

To set the Default Thru Instrument:
1. Choose Setups > Preferences and click MIDI.
2. From the pop-up menu for Default Thru Instrument, select the MIDI device and channel to which MIDI data will be routed. To disable the Default Thru Instrument, select None.

MIDI Input Filter

Use the MIDI Input Filter to filter out certain MIDI messages from your recordings. The MIDI Input Filter can be set to record “All” messages, “Only” the specified messages, or “All Except” the specified messages.

For example, to filter out Polyphonic Aftertouch:
1. Choose MIDI > Input Filter.
2. In the MIDI Input Filter dialog, select the All Except option.
3. Select the option for Polyphonic Aftertouch. Leave all other messages deselected.
4. Click OK.

When using the All Except option, the selected MIDI messages will not be recorded. Conversely, when using the Only option, only the MIDI messages that are selected will be recorded.

Input Quantize

When Input Quantize is enabled, all recorded MIDI notes are quantized automatically. To preserve the original “feel” of your recorded MIDI tracks, make sure to disable this option.

To enable Input Quantize:
1. Choose MIDI > Input Quantize.
2 In the Input Quantize window, select the Enable Input Quantize option.

Configure the other options in the Input Quantize window as desired. For details on the various Quantize options, see “Quantize” on page 318. When finished, close the Input Quantize window.

For drum machine style loop recording, use Input Quantize while loop recording MIDI in Merge mode (see “Loop Recording with Merge Mode” on page 157).

**Wait for Note**

The Wait for Note button, located in the Transport window, determines how Pro Tools begins recording. When enabled, Pro Tools will not begin recording until a MIDI event is received. This ensures that you begin recording when you’re ready to play, and that the first note, or other MIDI data, is recorded precisely at the beginning of the record range (start time).

Wait for Note can be used when recording normally, when punching in, or when loop recording. If pre-roll is enabled, it occurs after the MIDI event is received and before recording begins.

**To enable Wait for Note:**

1. To view the MIDI controls in the Transport window, select Display > Transport Window Shows > MIDI Controls.

2. In the Transport window, click the Wait for Note button so it becomes highlighted.

**MIDI Merge/Replace**

The MIDI Merge button, located in the Transport window, determines how MIDI is recorded when overdubbing or punching in. When MIDI Merge is on (Merge mode), recorded MIDI is merged with existing track material. When MIDI Merge is off (Replace mode), existing data within the punched region is replaced by the newly recorded material.
The MIDI Merge button can be turned on and off while playing or recording. In Loop Record mode, MIDI Merge has no effect, so its button is dimmed.

To enable MIDI Merge with a keyboard shortcut, set the Numeric Keypad Mode to Transport, and press the 9 key on the numeric keypad.

To enable MIDI Merge:
1 To view the MIDI controls in the Transport window, select Display > Transport Window Shows > MIDI Controls.
2 In the Transport window, click the MIDI Merge button so it becomes highlighted.

To configure one or more MIDI tracks for recording:
1 If you do not have a MIDI track to record to, choose File > New Track and specify 1 MIDI Track, then click Create.

2 Rename the MIDI track as desired. Track names are used to auto-name recorded regions. For more information, see “Track Names” on page 122.

3 In the Mix window, click on the track’s MIDI Input Selector and assign the device and channel that will be recorded.

4 Click on the track’s MIDI Output Selector and assign a device and channel from the pop-up menu. Channels already assigned to other tracks appear bold in this menu.

Macintosh Users: If the IAC bus is enabled as a MIDI input and you attempt to record to a MIDI track assigned to IAC MIDI Channel 2 or higher, Pro Tools will freeze due to a MIDI feedback loop. Disable the IAC bus as an input source in MIDI > Input Devices, or turn off MIDI Thru.

For more information on OMS setup, see the Getting Started Guide.
5 To assign multiple destinations to a single MIDI track, Control-click the MIDI Output Selector and select additional channels from any device.

6 If desired, assign a default program change to the track. Click on the Program button (Prog) and make the necessary selections for program and bank select, then click Done. Default program changes are sent whenever the track is played. For more information, see “Program Changes” on page 306.

7 If recording to multiple MIDI tracks, repeat the above steps for each track, then continue to the next step.

8 If desired, enable and configure the click, and set a default tempo and meter for the session. For details, see “Recording with the Click” on page 128.

9 If desired, enable Wait for Note or Countoff in the Transport window.

10 To replace existing track material, disable MIDI Merge in the Transport window.

11 If desired, enable Input Quantize to automatically quantize recorded material (see “Input Quantize” on page 151).

12 Make sure MIDI > MIDI Thru is selected, then play some notes on your MIDI controller. The MIDI instrument assigned to the track should sound, and the track’s meters should register MIDI activity.

13 In the Transport window, click Return to Zero so the start and end times are cleared. This ensures that you’ll start recording from the beginning of the track.

14 Click the MIDI track’s Record Enable button to record enable the track.

You are now ready to record MIDI data to the record-enabled MIDI tracks. See “Recording to MIDI Tracks” on page 154.

**Recording to MIDI Tracks**

In Pro Tools, you can record to one or more MIDI tracks. Recording simultaneously to multiple MIDI tracks allows you to:

- Record from multiple MIDI devices at the same time, capturing material from several performers
- Record multiple channels from the same device, capturing data from a split keyboard
- Transfer MIDI tracks from an external MIDI sequencer

To take advantage of the editing capabilities in Pro Tools, make sure to record with the click enabled. This ensures that recorded data aligns with the session’s bar and beat boundaries.

**To record to one or more MIDI tracks:**

1 Configure a MIDI track for recording. Refer to “Configuring MIDI Tracks for Recording” on page 153.

2 Record enable any MIDI tracks you want to record by clicking their Record Enable buttons.
If the preference for Latch Record Enable Buttons is enabled, you can record enable subsequent tracks by clicking their Record Enable buttons. Other tracks already record-enabled will remain so.

3 Put Pro Tools in normal Nondestructive Record mode. In the Operations menu, deselect Destructive Record, Loop Record, and Quick-Punch.

4 Click Record in the Transport window.

Record button

- If using Wait for Note, the Play, Record, and Wait for Note buttons flash. Recording begins when a MIDI event is received.
- If using Countoff, click Play to start counting down. The Record and Play buttons flash during the countoff, after which recording begins.

5 When you have finished recording, click Stop.

For each record-enabled track, a new MIDI region is created and appears in the playlist. The new MIDI regions also appear in the MIDI Regions List.

Undo and MIDI Recording

You can undo the previous record take.

To undo a MIDI recording:

- Once the Transport has been stopped, choose Edit > Undo MIDI Recording.

The track’s playlist is restored to its previous state. However:

- If you punched in and out several times before stopping the Transport, only the last punch is undone.
- When using Loop Record mode, all takes from each record pass are discarded.

Canceling a Record Take

It is also possible to discard the current record take before the Transport is stopped.

To cancel a record take while recording:

- Press Command+period (Macintosh) or Control+period (Windows) before the Transport is stopped.

If using Loop Record mode, all takes from each record pass are discarded.

Punch Recording MIDI

To replace a portion of a MIDI track, you can punch in by specifying the record range before recording.

To punch in on a MIDI track:

1 Configure a MIDI track for recording. Refer to “Configuring MIDI Tracks for Recording” on page 153.
2 Put Pro Tools in normal Nondestructive Record mode. In the Operations menu, deselect Destructive Record, Loop Record, and Quick-Punch.

3 In the Transport window, disable Wait for Note and Countoff.

4 Record enable the track containing the previous take by clicking its Record Enable button.

5 Select Operations > Link Edit and Timeline Selection.

6 With the Selector, drag in the track’s playlist until the selection encompasses the desired punch range.

For other methods of setting the record range, see “Setting Punch/Loop Points” on page 144.

7 To hear existing track material up to the start point, or after the end point, enable and set pre/post-roll times. For details, see “Setting Pre/Post-Roll” on page 145.

8 Click Record in the Transport window.

9 When you are ready to begin recording, click Play.

If pre-roll is enabled, the track material leading up to the punch-in point plays. You can start playing during the pre-roll to get the “feel.” Material is not recorded until the start point is reached.

When the start point is reached, Pro Tools begins recording. Recording continues until the end point is reached, unless Stop is clicked in the Transport window. If post-roll is enabled, playback continues for the specified post-roll amount.

10 When you have finished recording, click Stop in the Transport window.

The newly recorded MIDI data appears in the track.

Punching “on the fly” with MIDI

You don’t have to set a record range to punch in on a MIDI track. In fact, you can punch in and out freely at any time during playback. Unlike audio tracks, it is not necessary to enable Quick-Punch to perform real-time punches.

To punch on the fly with MIDI:

1 Configure a MIDI track for recording. Refer to “Configuring MIDI Tracks for Recording” on page 153.

2 Put Pro Tools in normal Nondestructive Record mode. In the Operations menu, deselect Destructive Record, Loop Record, and Quick-Punch.

3 Disable Wait for Note and Countoff in the Transport window.

4 Record enable the track containing the previous take by clicking its Record Enable button.

5 Start playback by clicking Play in the Transport window.

6 When you reach the punch-in point, click Record in the Transport window.

– or –

For Digi 001 systems (or Digidesign ProControl and Control|24 dedicated controllers) with a connected footswitch, press the footswitch at the punch-in point.

The Record button stops flashing and stays lit during recording.

7 To punch out, click Record again (or press the footswitch).

Pro Tools exits Record mode and continues playing. You can perform additional punches during the same pass.
Regions and Punch Recording

Depending on the record range, new regions may be created after punch recording. For example, Figure 6 shows two existing regions before recording. Since the start and end times occur within both of the existing regions, a new region is created to fill the space between them.

However, when selecting an entire region, or a section within a region, before punching, no new regions are created. In this instance, only the material residing within the existing region changes, with no new material recorded outside the region.

Unlike audio recording, MIDI recording in this scenario is destructive. If a region is altered because of a record take, the original material is lost (unless you choose Edit > Undo MIDI Recording), or combined with new material (if MIDI Merge was enabled during recording). If an existing region contains important material, use Duplicate to make a copy of the region (“Duplicate Command” on page 233) or the track’s playlist (see “Working with Playlists” on page 179).

Loop Recording MIDI

Loop recording with MIDI is supported by two methods:

- In normal Nondestructive Record mode, enable Loop Playback and MIDI Merge for drum machine style loop recording.
  - or -
- Use Loop Record mode to record multiple takes on each record pass. This is similar to loop recording audio.

Loop Recording with Merge Mode

For drum machine style loop recording, use normal Nondestructive Record mode with Loop Playback and MIDI Merge enabled. With this method, MIDI is recorded and merged to the same region with each new record pass—thereby allowing you to, for example, record hi-hats on the first pass and kick and snare on the next.

Make sure that MIDI Merge is enabled in the Transport window, otherwise (in Replace mode) each subsequent take will destructively replace the previous.

tip You can record enable a different MIDI track on the fly while loop recording. While pressing Command (Macintosh) or Control (Windows), use the Up/Down Arrows to record enable the previous or next MIDI track.

To loop record with MIDI Merge:

2 Put Pro Tools in normal Nondestructive Record mode. In the Operations menu, deselect Destructive Record, Loop Record, and Quick-Punch.

3 Select Operations > Loop Playback. When Loop Playback is enabled, a loop symbol appears in the Play button.

4 If you have not done so already, record enable the MIDI track by clicking its Record Enable button. Make sure no audio tracks are record-enabled.

5 In the Transport window, click the MIDI Merge button so it becomes highlighted.

6 Disable Wait for Note and Countoff in the Transport window.

7 Select Operations > Link Edit and Timeline Selection.

8 With the Selector, drag in the track's playlist until the selection encompasses the desired loop range.

For other methods of setting the record range, see “Setting Punch/Loop Points” on page 144.

9 To hear track material up to the start point of the loop, enable and set the pre-roll time. For details, see “Setting Pre/Post-Roll” on page 145.

10 Click Record in the Transport window. When you are ready to begin recording, click Play.

The Record button flashes during the pre-roll. When the start point is reached, Pro Tools begins recording. When the end point is reached, Pro Tools loops back to the start point and continues playing and recording.

11 Play some notes on your MIDI controller. Newly recorded MIDI data appears as a region in the record track. On each successive take, recorded material shows up in the region, without replacing material from previous takes.

12 If desired, switch to a new record track. While pressing Command (Macintosh) or Control (Windows), use the Up/Down Arrows to record enable the previous or next MIDI track.

13 When you have finished recording, click Stop in the Transport window.

The newly recorded MIDI data appears as a MIDI region in the track's playlist, and in the MIDI Regions List.

### Loop Recording Multiple Takes

When recording MIDI in Loop Record mode, new regions are created each time new material is received during a record pass. This differs somewhat from loop recording audio, where separate audio files and regions are created with each subsequent record pass.

You can use this method of MIDI loop recording to record successive takes without stopping the record process, thereby preserving your creative spontaneity. Another advantage with this method of recording MIDI, which is nondestructive, is that existing and newly recorded regions remain intact (and available in the MIDI Regions List).
To record MIDI in Loop Record mode:


2. Select Operations > Loop Record. When Loop Record mode is enabled, a loop symbol appears in the Record button.

3. If you have not done so already, record enable the MIDI track by clicking its Record Enable button. Make sure no audio tracks are record-enabled.


5. Select Operations > Link Edit and Timeline Selection.

6. With the Selector, drag in the track’s playlist until the selection encompasses the desired loop range.

For other methods of setting the record range, see “Setting Punch/Loop Points” on page 144.

7. To hear track material up to the start point of the loop, enable and set the pre-roll time. For details, see “Setting Pre/Post-Roll” on page 145.

8. Click Record in the Transport window. When you are ready to begin recording, click Play.

The Record button flashes during the pre-roll. When the start point is reached, Pro Tools begins recording. When the end point is reached, Pro Tools loops back to the start point and continues playing and recording.

9. Play notes on your MIDI controller. A new MIDI region containing the newly recorded material is automatically created and appears in the track’s playlist, replacing the previous region. Regions are replaced (non-destructively) during subsequent record passes when new MIDI material is received.

10. When you have finished recording, click Stop in the Transport window. The most recently recorded take is left in the record track.

The recorded takes appear as regions in the MIDI Regions List and are numbered sequentially. The takes, which are the same length and easily interchangeable, can be auditioned from the Takes List pop-up menu—even while the session plays or loops.

To audition the various record takes:

1. Command-click (Macintosh) or Control-click (Windows) with the Selector at the precise beginning of the loop record range.

   – or –

   • If the take currently residing in the track is selected, Command-click (Macintosh) or Control-click (Windows) it with the Selector.

A pop-up menu appears containing a list of regions that share the same User Time Stamp.

2. Choose a region from the Takes List pop-up menu. The region replaces the previous take and snaps precisely to the correct location.

For more information on auditioning and managing takes, see “Auditioning Record Takes” on page 142.
Recording System Exclusive Data

Pro Tools supports recording and playing System Exclusive data (sysex) with MIDI tracks. This allows you to use MIDI tracks in Pro Tools to store patch and configuration data for your MIDI devices, or to record real-time sysex changes for a particular synth parameter (filter cutoff, for instance).

To record a sysex dump at the beginning of a MIDI track:

1. Make sure that the MIDI OUT for the device sending the sysex is connected to your MIDI interface's MIDI IN.

2. Configure a MIDI track for recording. Refer to “Configuring MIDI Tracks for Recording” on page 153.

3. Put Pro Tools in normal Nondestructive Record mode. In the Operations menu, deselect Destructive Record, Loop Record, and Quick-Punch.

4. In the MIDI Input Filter, enable recording of System Exclusive data.

5. If you have not done so already, record enable the MIDI track by clicking its Record Enable button.


7. In the Transport window, click Return to Zero so the start and end times are cleared. This ensures that you’ll start recording from the beginning of the track.

8. When you are ready to begin recording, click Record in the Transport window.

The Record, Play, and Wait for Note buttons flash, indicating that Pro Tools is waiting for MIDI data.

9. Initiate the sysex transfer from the MIDI device, according to the instructions in the guide for your MIDI device. When receiving the MIDI data, Pro Tools automatically begins recording.

10. When the transfer is complete (as defined in the guide for your MIDI device), click Stop in the Transport window.

The newly recorded MIDI data appears as a MIDI region in the track’s playlist, and in the MIDI Regions List. MIDI regions that contain System Exclusive data appear blank when the track’s Display Format is set to Regions.

To see the sysex event blocks, which indicate the location of the data, set the MIDI Track View to display Sysex (see “Regions View for MIDI Tracks” on page 177). For details on moving and copying of sysex data, see “System Exclusive Events” on page 310.

To resend the sysex from Pro Tools:

1. For the device receiving the System Exclusive data, make sure its MIDI IN is connected to your MIDI interface’s MIDI OUT. Also, make sure the device is set to receive sysex. Some devices require that memory protect be off.

2. For the previously recorded track, click its Record button to take it out of record-enabled mode.

3. Click on the track’s MIDI Device/Channel Selector and assign the device from the pop-up menu.

4. In the Transport window, click Return to Zero.

5. Click Play in the Transport window to begin playback. Pro Tools begins playing and transmits the previously recorded sysex to the assigned MIDI device.
Chapter 14: Advanced Recording

QuickPunch Audio Recording

Pro Tools features an intelligent on-the-fly punch capability called QuickPunch. QuickPunch lets you instantaneously punch in and out on record-enabled audio tracks during playback by merely clicking the Record button in the Transport window.

For DIGI 001 systems, or some Digidesign control surfaces, you can use a footswitch to punch in and out when recording with QuickPunch.

When using QuickPunch, Pro Tools starts recording a new audio file when you begin playback, automatically defining and naming regions in that file at each punch-in/out point. Up to 100 of these “running punches” can be performed during a single pass. Unlike normal punch recording (see “Punch Recording Audio” on page 140), QuickPunch provides instantaneous monitor switching on punch-out. All QuickPunch recording is nondestructive.

QuickPunch Crossfade Length

Pro Tools can automatically write a crossfade for each punch point when using QuickPunch. The length for these crossfades is set with the QuickPunch Crossfade Length option in the Editing Preferences.

To set the QuickPunch Crossfade Length:

1. Choose Setups > Preferences and click Editing.
2. Enter a value (in msec) for the QuickPunch CrossFade Length.
3. Click Done.

A good general-purpose crossfade length for punches is 4 milliseconds. If you set the preference to zero, Pro Tools will not create any crossfades at the punch-in/out points.

Even if the QuickPunch Crossfade Length is set to zero, Pro Tools always executes a 4 millisecond “monitor only” crossfade (which is not written to disk) to avoid distracting pops or clicks that might occur as you enter and exit record mode.
QuickPunch crossfades can later be edited in the same manner as standard crossfades. For details, see “Using Crossfades” on page 245.

**QuickPunch Guidelines for TDM Systems**

When using QuickPunch on TDM systems, two voices are required for each record-enabled, mono track. This means that you can record up to half the total number of voices available on your system. For example, a Pro Tools HD system with 64 voices can simultaneously record on up to 32 mono tracks with QuickPunch. QuickPunch with stereo tracks requires twice the number of voices.

If the required number of voices for the record-enabled tracks is not available when switching to QuickPunch mode, you’ll be prompted to free up the necessary voices.

To free up voices on tracks that are not record-enabled, and do not need to be heard while recording:

- Set voice assignments for tracks to Off.
  - or –
- Make tracks inactive.

As necessary, voices in use by other tracks, which are not record-enabled, may be stolen while recording with QuickPunch. Priority for tracks while recording with QuickPunch are as follows:

- Tracks with assigned voices that are not record-enabled
- Tracks with assigned voices that are record-enabled
- Auto-voiced tracks that are not record-enabled
- Auto-voiced tracks that are record-enabled

If the session has plenty of available voices, you may have no trouble using QuickPunch with auto-voiced tracks. However, if you are running out of voices, and want to ensure that a track will be heard when recording with QuickPunch, assign it a voice.

**QuickPunch and Auto Voice (TDM Systems Only)**

When using QuickPunch with a 128- or 64-voice system, make sure to set the voice assignment for each audio track to Auto. This ensures that Pro Tools will automatically handle the distribution of voices between each set of voices. For example, for a 128-voice system, auto-voice distributes voices evenly across four sets of voices (1–32, 33–64, 65–96, and 96–128).

If you do not use auto-voicing, the voices must be evenly distributed between all DSP engines. For example, to use QuickPunch on 32 tracks without auto-voicing, tracks 1–16 must be assigned to voices 1–16 and tracks 17–32 must be assigned to voices 33–48.
QuickPunch Guidelines for Pro Tools LE

Digi 001 and Audiomedia III

For non-TDM systems, the maximum number of mono tracks that can be simultaneously recorded with QuickPunch in a session with 24 audio tracks is 8.

To simultaneously record more tracks than this with QuickPunch, you’ll need to reduce the number of tracks in the session. For example, a session with 20 audio tracks can record 10 mono tracks with QuickPunch, and a session with 16 audio tracks can record 12.

With Pro Tools LE, QuickPunch uses CPU processing power, and may reduce the number of tracks and plug-ins you can use.

Recording with QuickPunch

To punch on the fly with QuickPunch:

1 Select Operations > QuickPunch. When QuickPunch is enabled, a “P” appears in the Record button.

2 If desired, configure the QuickPunch Crossfade Length option in the Editing Preferences (see “QuickPunch Crossfade Length” on page 161).

3 Record enable the tracks you want to punch in on. Make sure there are enough available voices on your system.

4 Prepare to record by cueing Pro Tools to an appropriate location (if desired, enable a pre-roll value in the Transport window).

5 Start playback by clicking Play in the Transport window.

6 When you reach the punch-in point, click Record in the Transport window.

– or –

For Digi 001 systems with a connected footswitch, press the footswitch at the punch-in point.

The Record button stops flashing and stays lit during recording.

7 To punch out, click Record again (or press the footswitch).

As Pro Tools continues playing, you can perform additional punches (up to 100). When recording multiple punches during a single pass, a single audio file is recorded from which Pro Tools creates the appropriate regions.

QuickPunch with an Edit Selection

If you make an Edit selection and use QuickPunch, the following rules apply:

• If you are not online, recording begins and stops whenever you click the Record button—regardless of the selection’s start or end point.

• If you are online, punch-in/out behavior is controlled by the Online Options setting in the Operations Preferences. If you select Record Online at Insertion/Selection, QuickPunch punches in and out only within the selection (or in the case of an insertion point, only after the insertion point). If you select Record Online at Time Code Lock, QuickPunch disregards the selection and punches in and out whenever you want (after Pro Tools has locked to time code).
Region and Take Numbering with QuickPunch

After recording with QuickPunch, the new audio regions appear in the Audio Regions List. This includes the whole-file audio region encompassing all punches from the record pass, along with the regions derived for each punch.

Names for the punched regions are numbered consecutively starting with “01.” For example, if QuickPunch is used to punch in twice on a track called “Lead Gtr,” a region for the parent audio file appears and is named “Lead Gtr-01,” and two regions for the punches are named “Lead Gtr-01-01” and “Lead Gtr-01-02.”

If you stop playback and record additional punches with QuickPunch, subsequent regions are named by incrementing the first two digits in the name. For example, on the second pass, the punched regions are named “Lead Gtr-02-01,” “Lead Gtr-02-02,” and so forth.

Recording from a Digital Source

If you plan to use a DAT player, digital-output CD recorder, or other digital input and output device with your Pro Tools system, make sure it supports the correct digital format. For example, your interface’s AES/EBU inputs and outputs should only be connected to another AES/EBU device.

The 192 I/O and 96 I/O include AES/EBU, S/PDIF, and ADAT digital options. Additionally, the 192 I/O includes TDIF digital I/O options.

All digital outputs are active at all times, so you can actually send digital audio to different digital devices simultaneously at mix time.

On a 96 I/O or 192 I/O, Pro Tools can receive digital audio from the factory-installed Optical (ADAT) I/O at any time (if it is not set to S/PDIF). However, Pro Tools can only receive digital audio from one of its enclosure [Encl] digital sources—AES, S/PDIF or Optical (S/PDIF).

Enclosure digital sources come standard with HD I/Os and are labelled on-screen as [Encl] versions, to differentiate them from digital inputs and outputs available on the 192’s Digital I/O card. For example, the AES/EBU inputs and outputs that come standard in the 192 I/O enclosure are identified as AES/EBU [Encl].

The additional digital ports on the 192 I/O are TDIF, AES/EBU, and ADAT. Pro Tools can only receive digital audio from one of these ports at a time.

However, both the 192 I/O’s enclosure I/O and Digital card I/O can be used simultaneously. For example, on a 192 I/O, it is possible to clock off a source from one of the enclosure inputs and have another digital input from the digital ports doing a sample rate conversion, thus having two digital sources.

Legacy Audio Interfaces and Digital Sources

On the 888|24 I/O, 24-bit ADAT Bridge I/O, and the original ADAT Bridge I/O, both AES/EBU and S/PDIF outputs are active at all times, so you can actually send digital audio to two different digital devices simultaneously at mix time. However, Pro Tools can only receive digital audio from one digital source (AES or S/PDIF) at a time.

In addition, although the 888|24 I/O has four stereo AES input pairs, only input pair 1–2 on the master audio interface, (the first audio interface connected to your main DSP card), can accept an external digital clock source.
To record from a DAT recorder with Pro Tools:

1. Connect the digital output of the DAT recorder to the appropriate digital input of your audio hardware.

2. If you want to start a new session with a different sample rate, choose File > New Session, and select the sample rate. Press Save.

3. Make sure to specify the format (digital) of the inputs of the audio interface you will be using. Choose Setups > Hardware Setup, choose the audio interface, and select the format for the appropriate channel pair. Some Digidesign I/O units, such as Digi 001, only have two channels (Ch 1–2) that can be set for analog or digital. Also, if your audio hardware supports different digital formats (such as AES/EBU and S/PDIF), select the digital format you will use.

4. For HD systems, choose Setups > Hardware Setup and select the appropriate Clock Source connected to the appropriate I/O audio interface.

5. Click OK to close the Hardware Setup dialog.

6. Choose File > New Track and specify 1 Stereo Audio Track, then click Create.

7. In the Mix window, record enable the new audio track by clicking its Record Enable button.

8. Assign the Input Selectors for the track to the appropriate inputs. Since this is a digital-domain transfer, you don’t need to worry about input levels.

9. In the Mix window, click on the track’s Output Selector and assign a stereo hardware output.


11. In the Transport window, click Return to Zero so the start and end times are cleared. This ensures that you’ll start recording from the beginning of the track.

12. Click Record in the Transport window. When you are ready to begin recording, click Play.

13. Initiate playback on the DAT recorder.

14. When the material from the DAT has finished, click Stop in the Transport window.

After a Digital Transfer

After you have finished recording digitally, set the Sync Mode pop-up menu in the Session Setup window back to Internal. Otherwise, Pro Tools will not switch back to its own internal clock and will not record or play audio properly. Failure to switch back to Internal sync typically results in pitch problems (fast or slow playback) or DAE errors, since a DAT recorder or CD Recorder that is idle can default to a different sample rate or stop outputting a sample rate clock altogether.
Half-Speed Recording and Playback

Pro Tools lets you play and record at half-speed. This capability is similar to that of a tape deck where you can record material at half-speed and then play it back at normal speed (up an octave) for special effects.

To record at half-speed:

1. Press Command+Shift+Spacebar (Macintosh) or Control+Shift+Spacebar (Windows). Recording begins and all existing track material plays at half-speed.

2. When you have finished recording, click Stop.

When played at normal speed, the material recorded at half-speed plays twice as fast (up an octave).

💡 Use half-speed recording to record difficult to play MIDI tracks. This allows you to hear audio tracks while recording. Half-speed recording and playback do not affect how MIDI tracks sound when played.

To play at half-speed

1. Press Shift+Spacebar. Playback begins and track material plays at half-speed. If any tracks were recorded at half-speed, they play at normal speed.

2. Click Stop in the Transport window to stop playback.

💡 Use half-speed playback to learn or transcribe difficult passages in recorded tracks.
Part IV: Editing
Chapter 15: Editing Basics

Pro Tools Editing

The Edit window in Pro Tools provides a powerful collection of tools for editing and assembling audio and MIDI tracks. Track material can be edited non-destructively and in real time during playback.

Non-destructive Editing

The vast majority of audio editing in Pro Tools is non-destructive. Whether cutting, pasting, trimming, separating, or clearing regions, you are only performing these functions on a map of the actual audio data. The source audio files remain untouched. If a particular process or tool works destructively (that is, if it can permanently change audio files on your hard disk), this guide alerts you.

While editing for MIDI tracks is in some instances destructive, with a few precautions you can keep important MIDI tracks and regions safe when performing edits (see “Non-destructive Audio Editing” on page 176).

Editing During Playback

Pro Tools lets you perform many editing tasks while the session plays. This powerful capability allows you to interactively modify and edit a session, hearing the changes as you make them. You’ll find many instances where you can use this capability to increase your productivity when working with a session.

Following are just a few examples of editing that can be performed while your tracks loop or play:

- Capture, separate, and trim regions
- Place, spot, or rearrange regions
- Add fades or crossfades to audio regions
- Transpose, quantize, and otherwise modify MIDI tracks
- Nudge audio or MIDI regions
- Audition different playlists
- Adjust or scale automation data
- Process audio with an AudioSuite plug-in

There are a few things that cannot be changed while Pro Tools plays. These include assigning TDM plug-ins to audio tracks, routing to sends, and assigning outputs.
Track Material

Each time you record or import audio and MIDI, Pro Tools creates regions for the new track data, which not only indicate where the material begins and ends, but also provides good feedback on its general shape and content. When you record additional takes, or “punch in” on a specific location within a track, Pro Tools creates additional regions.

Regions are also created by cutting and pasting, resizing, separating, and re-capturing existing regions. Regions in a session are listed in the Audio Regions List and MIDI Regions List, where they can be dragged to existing tracks. A track can contain any number of regions, in any arrangement. The order and location of regions in a track define its playlist.

Region Types

There are different region types, based on how they are created:

Whole-File Audio Regions These audio regions are created when recording or importing audio, consolidating existing regions, and when non-destructively processing with an AudioSuite plug-in. Whole-file audio regions reference an entire audio file that resides on your hard drive. Whole-file audio regions are displayed in bold in the Audio Regions List (see “The Audio and MIDI Regions Lists” on page 181). Normal regions often reference only a portion of the parent audio file and are created in the course of editing and, in some instances, when punch recording.

User-Defined Regions These are regions that are explicitly defined, such as when you record or import audio or MIDI; capture, separate, or consolidate a selection; trim a whole-file audio region; and rename an existing region.

Auto-Created Regions These regions are automatically created in the course of editing, and, in some instances, when punch recording over existing regions. Since these regions can accumulate rapidly in a session, you can hide them so they don’t appear in the Audio and MIDI Regions List (see “Managing Regions” on page 260). Auto-created regions can be turned into user-defined regions by renaming them.

Offline Regions Regions are offline when their parent audio files cannot be located, or are not available, when opening a session or importing a track. Offline regions appear in the Audio Regions List as italicized and dimmed; they appear in playlists as light blue regions with italicized names. Offline regions can be edited like other regions, but they cannot be processed with AudioSuite plug-ins.

Multichannel Regions These regions, which are displayed as a single region in the Audio Regions List, reference multiple regions and audio files for stereo and surround tracks. Multichannel regions can be expanded (by clicking the triangle next to their name) to see the individual channels, which can be dragged independently to tracks.

Track View

The Track View determines which data is displayed and edited in the track’s playlist area.

Audio tracks can be set to Blocks, Waveform, Volume, Pan, Mute, or any plug-in parameters that have been automated. Except when editing automation data, audio tracks are by default set to
Waveform, where track material is graphically drawn with amplitude waveforms. This Track View provides the necessary detail for important region edits.

Auxiliary input tracks can be set to Volume, Pan, Mute, or any plug-in parameter that has been automated. Master Fader tracks can be set to Volume, or any plug-in parameter that has been automated.

MIDI tracks can be set to Blocks, Regions, Notes, Volume, Pan, Mute, Velocity, Pitch Bend, After Touch, Program, Sysex, and any continuous controller type. Except when editing controller data, program changes, or sysex events, MIDI tracks are commonly set to Notes or Regions, each of which displays notes in a “piano roll” format. Use Notes View for inserting, editing, and copying and pasting MIDI notes; use Regions View to arrange, capture, or consolidate regions.

With the Track View set to Blocks, audio and MIDI regions are displayed as empty blocks bearing the region’s name. This mode is most useful once you have finished capturing and editing regions at the waveform or MIDI event level and are moving and rearranging them. Screen redraws are fastest with this format.

When an audio track is displayed as Volume, Pan, or another automated parameter, or when a MIDI track is set to one of the continuous controller types (Volume, Pitch Bend, After Touch), the data for that track appears in the form of a line graph with a series of editable breakpoints. The breakpoints can be dragged to modify the automation data, and new breakpoints can be inserted with the Pencil or Grabber.

For details on editing automation data for audio tracks, see “Automation” on page 375. For details on inserting and editing controller data for MIDI tracks, see “Continuous Controller Events” on page 305.

To set the Track View:

- Click the Track View Selector for the track and choose the format from the pop-up menu.
Toggling Track Views

Most editing for audio tracks occurs in the Waveform and Volume View. For MIDI tracks, most editing occurs in the Notes and Regions View. Pro Tools provides an easy way to toggle these views for tracks containing an edit selection or the edit cursor.

To toggle Track Views:
1. Click in the track you want to toggle. To toggle multiple tracks, Shift-click in additional tracks.
2. Press Control+Minus (Macintosh) or Start+Minus (Windows) on the alpha keyboard.
   – or –
   
   On TDM systems, with the Commands Focus enabled, press Minus on the alpha keyboard.

Audio tracks are toggled between Waveform and Volume View. MIDI tracks are toggled between Notes and Regions View.

The “Master” View Format

Audio and MIDI tracks have Track Views that act as “master.” When a track is displayed in its master format, any edits performed apply to all data in the track. For instance, when an audio track is set to Waveform, copying and pasting affects not just the waveform information, but all of the automation data as well.

The Track Views that act as master for audio and MIDI tracks are:
- Audio tracks: Waveform and Blocks
- MIDI tracks: Regions, Blocks, and Notes (when using the Selector)

Auxiliary Input tracks and Master Fader tracks do not have a Master View.

Track Height

Tracks can be viewed in the Edit window at any of six heights: Mini, Small, Medium, Large, Jumbo, and Extreme. Larger track heights are particularly useful for precise editing. Smaller track heights are useful for conserving screen space in a large session.

You can adjust track heights on an individual track basis or set all tracks to the same height. Track heights can be adjusted during playback.

To set the Track Height:
- Click in the area just to the right of the track controls and choose the height from the pop-up menu.

– or –

- Click the small arrow next to the Track View Selector to get the Track Height pop-up menu.

The track is resized to the new height. If the track is part of an Edit Group, all tracks in the group are set to the new height.
Expanded Track Display

Stereo and multichannel tracks share a single playlist for volume and mute. This shared playlist normally occupies the entire height of the track, extending across all channels.

With Expanded Track Display, you can display playlists individually for each channel, thereby allowing for more accurate breakpoint editing. This is also useful for editing pan or multi-mono plug-in data, both of which can be different for each channel.

Expanded Track Display also provides for a larger waveform display (equal to that of mono audio tracks), as well as a separate Track View Selector and meter for each channel.

To turn on Expanded Track Display for a stereo or multichannel track:
- From the Track Height pop-up menu, select Expanded Track Display.

Track Controls and Track Height

The Track Height affects how the various track controls appear in the Edit window. For instance, when a track’s height is set to Small, most of the buttons are reduced in size, and the menus for Track Height and Track View are accessed from the same pop-up.

When the Track Height is set to Mini, only controls for Mute and Solo appear, and the menus for Playlist, Track Height, and Track View are accessed from the same pop-up.

When the Track Height is set to Large, Jumbo, or Extreme, all track controls are displayed at their full size.
Displaying Region Names and Times

Region names can sometimes get in the way of editing audio waveforms and MIDI data. In these instances you may want to disable their display.

To disable the display of region names in playlists:
- Deselect Display > Display Name In Regions.

To enable the display of region names in playlists:
- Choose Display > Display Name In Regions. This is extremely useful when working with film and video.

Audio Regions and Waveforms

When the Track View for audio tracks is set to Waveform, Pro Tools draws a waveform diagram of the audio. Audio waveforms tell you several things about the recorded sound.

Figure 7 shows an audio waveform for a drum loop. The “peaks” represent places in the recording (beats) where the attack of the sound causes the volume to increase momentarily. These are followed by “valleys,” where the volume decreases.

Different types of sounds produce different types of waveforms. Drums, for example, generally produce waveforms with sharp transients (peaks of short duration) that are clearly defined. A drum hit has a loud, sharp attack and a rapid decay.

Other sounds, such as vocals or sustained keyboard sounds, produce very different waveforms, ones that have less pronounced peaks and valleys. That’s because these sounds generally have softer attacks and longer decays.

Draw Waveforms Rectified Preference

When the Display Preference for Draw Waveforms Rectified is selected, audio waveforms are displayed so that their positive and negative waveform excursions are summed together and viewed as a single positive-value signal. However, even when this preference is enabled, zooming in beyond a certain point will cause the waveforms to be displayed normally.
Rectified mode displays more detailed waveforms when using track heights of Medium or Small, and can be particularly useful when editing volume automation data, since it depicts waveform “levels” as starting at the bottom of the track.

Guidelines for Editing Waveforms

With the Selector tool in the Edit window, you can select portions of audio waveforms and divide them into segments called regions, so that you can rearrange and manipulate them in tracks.

While editing, try to create regions that allow you to maintain a consistent beat. If you always define regions so that they contain a whole number of beats, you’ll be able to string the regions together and maintain a smooth, steady rhythm.

It’s sometimes useful to have a steady, well-defined waveform, such as a drum track, as a guide when selecting and defining other regions. If you’ve played in time with the beat, chances are that you can create rhythmically accurate regions by referring to the drum’s waveform.

Some important rules to keep in mind when defining regions:

- Whenever possible, begin a region precisely before a volume peak, and end it immediately before another volume peak.
- Whenever possible, make sure a region starts and ends on exactly the same part of a beat.

Avoiding Clicks and Pops

If an edited region begins or ends at a point of high amplitude, you may hear an unpleasant click when Pro Tools plays from one region to another. In order to avoid clicks or pops do any of the following:

- Make sure that the start and end points of your selection are as close as possible to the point where the amplitude of the waveform tapers down to meet the zero-crossing line (the center line of the track’s waveform display). If necessary, use the zooming tools in the Edit window (see “Zooming” on page 186) to display waveforms in greater detail.

- On Pro Tools TDM systems, use the AutoFade feature to apply real-time fade-ins/outs to all region boundaries that do not touch or overlap other regions. See “Using AutoFades” on page 254 for details.

- Apply a crossfade between regions where a click or pop occurs. See “Creating a Crossfade” on page 252 for details.
Non-destructive Audio Editing

When editing an audio track’s playlist in Pro Tools, you’re not actually cutting and moving pieces of sound as you would if you were cutting and splicing analog tape. Instead, Pro Tools creates a map of the audio file on your hard disk, which describes the order in which to play the track portions.

When trimming audio regions with the Trimmer tool, or when editing the placement or order of regions within a track, use multiple playlists to easily return to a track’s previous state. See “Playlists” on page 178 for details.

Audio Regions and Automation Data

Automation data for audio resides in tracks and not regions. This means that when you drag an audio region from the Audio Regions List to a new track, no automation data is placed in the track. However, if you drag an audio region from an existing track (that contains automation data) to another track, the automation from the source track is placed in the destination track.

MIDI Regions and MIDI Data

The two most common Track Views you’ll use for MIDI tracks are Notes and Regions. Use Notes View for inserting and editing individual MIDI notes, and for working with and affecting groups of notes.

When you need to experiment with the arrangement of regions, or define new ones, use Regions View.

For more information on setting Track View, see “Track View” on page 170.
To scroll the Notes display up or down for a MIDI track:

- Click either the up or down arrow of the mini-keyboard.

- With any of the Edit window tools (such as the Pencil tool) selected, press Command+Option+Control (Macintosh) or Control+Alt+Start (Windows) and drag up or down on the mini-keyboard.

Using the Edit window tools, notes can be inserted, transposed, trimmed, and moved. For more information, see “Manually Editing MIDI Notes” on page 301.

Regions View for MIDI Tracks

MIDI tracks can also be viewed as Regions, which is similar to Waveform View for audio tracks. While a track’s notes are visible in Regions View, individual note editing is not available in this view. Instead, all editing occurs across a time range encompassing all track data, including continuous controller events, program changes, and System Exclusive events.

Use Regions View to define regions that represent song sections and clips, or to rearrange or assemble track material.

For more information on setting the Track View, see “Track View” on page 170.

There are, however, a few things to keep in mind when selecting, copying and cutting, and trimming MIDI regions:

- When cutting or clearing a region selection that includes a note’s start point, the entire note is removed. This is even the case when only a portion of the note (that includes its start point) is selected.

- When copying or cutting a region selection that includes a note’s end point (but not its start point), the note remains and overlaps the edge of the region.

- Similar rules also apply when MIDI regions are trimmed with the Trimmer tool. If the MIDI region’s start point is moved beyond a note’s start point, the note is removed. If the region’s end point is trimmed so that a note’s start point is within the region but its end point is not, the note remains and overlaps the edge of the region.
When moving and placing MIDI regions with overlapping notes, the notes always move with the regions. When placing MIDI regions with overlapping notes next to or near another region, the overlapping notes extend into the adjacent region.

**Non-destructive MIDI Editing**

While editing audio regions is usually non-destructive, this is not always the case for MIDI regions. For instance, if a MIDI region resides in just one track at a single location, editing for that region is destructive. This means that altering the pitch, duration, or placement of notes in Notes View permanently alters the region.

However, when editing a MIDI region that occurs elsewhere, in the same track (at another location or in a different playlist) or in another track, the editing is non-destructive and occurs to an auto-created region. To go back to the previous material, drag the original region from the MIDI Regions List, or return to a previously saved playlist.

Unlike continuous controller events, which represent nuances that are part of a MIDI performance, Mute in Pro Tools is an automation playlist that actually mutes the MIDI engine. Mute automation does not correspond to actual MIDI events and is therefore not exported when saving as a Standard MIDI File.

**Playlists**

The ability to create playlists is one of the most powerful features of Pro Tools, and one reason why it is infinitely more versatile than traditional multitrack recorders.

*Edit playlists* allow you to take a snapshot of a track’s current arrangement of regions, thereby freeing you to experiment with alternate arrangements, returning as necessary to previously saved playlists.

A playlist, which can consist of a single region or many regions, can only be assigned to a track if it is not in use by another track. While you can create an almost unlimited number of edit playlists, which are shared among all tracks, each track has its own set of dedicated automation playlists.

Automation playlists for audio tracks store data for volume, pan, mute, and plug-in parameters. Automation playlists for MIDI tracks, however, store only mute information; continuous controller events, program changes, and sysex events are stored in MIDI regions and therefore reside within edit playlists.
Playlists and Groups

Playlist functions affect all tracks within an Edit Group (if the group is active). This is useful when you want to switch to new or existing playlists among several tracks.

Working with Playlists

When you add a new track to a session, its playlist is empty until you record or import material to it, or drag a region to it from the Audio or MIDI Regions List.

Duplicating a Playlist

When you edit a track, you can work with a copy of the track's playlist and keep the original playlist arrangement intact.

To duplicate a track's current playlist:

1. Click the track's Playlist Selector and choose Duplicate from the pop-up menu.
2. Enter a name for the new playlist and click OK.

The duplicated playlist appears in the track and the track's name is changed to the name of the new playlist.

New and duplicated playlists are auto-named with the track name, followed by a period and the playlist number (such as the first playlist for a “Kick” track being auto-named “Kick.01”). In this example, subsequent playlists would be auto-named “Kick.02,” “Kick.03,” and so on.

Creating a Playlist

You can also create a new playlist and record or drag regions to it.

To create a new (empty) playlist:

1. Click the track's Playlist Selector and choose New from the pop-up menu.
2. Enter a name for the new playlist and click OK. An empty playlist with the specified name appears in the track.

As long as a playlist is unassigned, it can be recalled and assigned to any track. Only unassigned playlists appear in the Playlist Selector pop-up.

To recall and assign a playlist:

- Click the track's Playlist Selector and choose the playlist from the pop-up menu.

The selected playlist appears in the track and the track's name is updated to that of the selected playlist.

Renaming a Playlist

You can rename a playlist by renaming the track to which it is assigned.

To rename a track's assigned playlist:

1. Double-click the track's name.
2. Enter a new name and click OK. Both the track and playlist names are updated.

Deleting a Playlist

You can delete a playlist from a session entirely. However, since playlists take almost no disk space, you don’t need to delete them for space reasons.
To delete one or more playlists from a track:

1. Click the track’s Playlist Selector and choose Delete Unused from the pop-up menu.
2. Select the unassigned playlists you want to delete. Shift-click to select multiple playlists.
3. Click OK to delete the playlists. This operation cannot be undone.

💡 When deleting a track from a session, you have the option of deleting or keeping its playlists, so they can be used on other tracks.

Multiple Undo

Pro Tools can keep track of up to 16 of the last undoable operations, allowing you to return to a previous editing state.

The Undo operations in Pro Tools are stored in a queue, in the order in which they were invoked. When choosing Edit > Undo, the most recent operation is undone. If you choose Undo again, the next operation in the queue is undone. You can also choose Edit > Redo to redo an operation, which moves back through the Undo queue by one step.

For example, suppose the following operations have been performed, with item 1 being the most recent (first in the queue):

1. Region cut from track
2. Region pasted to track
3. Region slid forward
4. Regions shuffled
5. MIDI note trimmed
6. MIDI note inserted with Pencil

In this example, to Undo the region shuffle, you would have to choose Edit > Undo four times, which would also Undo the first three operations in the queue.

If you then choose Edit > Redo, followed by another edit operation, such as a region trim, the Undo queue would then be:

1. Region trimmed
2. Regions shuffled
3. MIDI note trimmed
4. MIDI note inserted with Pencil

To undo the last operation:

- Choose Edit > Undo.
  – or –
- Press Command+Z (Macintosh) or Control+Z (Windows).

To redo the last undone operation:

- Choose Edit > Redo.
  – or –
- Press Shift+Command+Z (Macintosh) or Shift+Control+Z (Windows).

Operations that Clear the Undo Queue

Pro Tools will not warn you of operations that clear the Undo Queue. Operations that clear the Undo Queue include:

- Deleting a track, or clearing a region from the Audio or MIDI Regions List
- Selecting “Select Unused” in the MIDI Regions List pop-up
- Selecting “Select Unused Regions,” or “Select Unused Regions Except Whole Files” in the Audio Regions List pop-up
Levels of Undo and RAM

Since Pro Tools needs to keep track of the playlists for all tracks that are edited, the use of multiple Undos can be memory intensive. You can lower the Levels of Undo in Pro Tools to reduce the amount of RAM used by the Undo queue. If on the other hand you have plenty of RAM allocated to Pro Tools, you can set the Levels Of Undo to as high as 16.

To set the Levels of Undo in Pro Tools:
1. Choose Setups > Preferences and click Editing.
2. Click in the Levels of Undo field and enter a value of between 1–16.
3. Click Done to close the Preferences dialog.

When the number of operations in the Undo queue reaches this limit, performing another undoable operation will remove the oldest operation at the bottom of the queue.

The Audio and MIDI Regions Lists

All regions that are recorded, imported, or created by editing appear in the Audio and MIDI Regions Lists. Regions can be dragged from either list to tracks and arranged in any order. Regions can also be auditioned from the Regions List by Option-clicking (Macintosh) or Alt-clicking (Windows) them.

In the Audio Regions List, whole-file audio regions are displayed in bold, and stereo and multichannel regions can be expanded to display individual channels.

Because region names can become lengthy (up to 31 characters), the Regions List can be scrolled or resized as necessary (see Figure 9). In addition, you can use the pop-up menu at the top of either list to sort, search, rename, and clear regions.
If the Editing Preference for “Region List Selection Follows Track Selection” is enabled, clicking a region in the Regions List highlights it in the track that contains it.

> Use the MIDI Regions List as a bin for storing your favorite MIDI clips. Save the session as a template and the regions are available for future sessions (see “Creating Custom Session Templates” on page 48). Since MIDI regions are tick-based (unlike audio regions), they scale seamlessly for use with any tempo.

**Displaying File Info for Audio Regions**

In addition to region names, the Audio Regions List can also display information about the region's parent audio file:

- Disk name, which represents the name of the hard drive on which it resides
- File name, which represents the audio file from which the region originated
- The full directory Pathname of the region's location

Pro Tools defaults to displaying just the region portion of a region’s name. To display file info for audio regions, choose Show File Names, Show Disk Names, or Show Full Pathnames from the pop-up menu at the top of the Audio Regions List.

**Sorting and Searching the Regions Lists**

Most sessions will contain many regions, which may make it difficult to locate a particular region in the Regions Lists. The ability to sort regions and search for them will help greatly in keeping track of large numbers of regions.

**To sort regions in a Regions List:**

1. From the Regions List pop-up menu, choose Sorting and select the basis for sorting from the submenu.

2. From the Regions List pop-up menu, select Ascending or Descending to switch the order of the displayed regions.

**Sort attributes for audio regions**

MIDI regions can be sorted by name, length, or timestamp. In addition to these, audio regions can be sorted by region start and end times, various attributes of the source audio file, disk name, and track format.

2. From the Regions List pop-up menu, select Ascending or Descending to switch the order of the displayed regions.
Finding Regions

Use the Find command to display all regions in a list whose names contain a particular word or phrase.

To find and display regions that match a word or phrase:

1. Choose Find from the pop-up menu in the Audio or MIDI Regions List.
2. Type the name, or any portion of the name, for the regions you want to find, then click OK.

Pro Tools displays all regions whose names contain the name that was specified. Figure 10 shows regions found when searching on the word “loop.” When displaying regions with the Find command, a small diamond appears at the top of the Audio and MIDI Regions List.

![Regions located with Find command](Image)

To return the Regions List to displaying all regions:

- Choose Display All from the Regions List pop-up menu.

Selecting in the Region Lists

In the Regions Lists you can select multiple regions so they can be dragged to tracks, or processed with AudioSuite plug-ins.

To select a range of regions in a Regions List:

- Move the cursor to the left of the region names, so the Marquee appears, and drag around the regions you want to select.

- or –

- Shift-click, to the left of the region names, the first and last region you want to select. All regions between become selected.

To select discontiguous regions in the Regions List:

1. Move the cursor to the left of the region names, so the Marquee appears.
2. Command-click each region you want to select.

- or –

- Shift-click each region name you want to select.
**Keyboard Selection of Regions**

If the Audio Regions Focus or MIDI Regions Focus is enabled, you can type the first few letters of a region’s name and Pro Tools will automatically locate and select the region in the Regions List.

**To enable and use the Audio Regions List Key Focus or MIDI Regions List Key Focus:**

1. Click the a-z button in upper right of the Audio Regions List or MIDI Regions List.

2. Type the first few letters of the region to automatically locate and select it. Once a region is located and selected, it can be dragged to a track.

Keyboard selection of audio regions locates regions based on their region name, not on the names for their parent audio files or the volumes on which they reside.

**Stereo and Multichannel Tracks in the Audio Regions List**

Stereo and multichannel regions, whether imported or recorded into Pro Tools, are displayed as single items in the Audio Regions List. For example, two mono source regions named “Main Piano.L” and “Main Piano.R” are listed as “Main Piano (Stereo).” A collapse/expand triangle indicates stereo and multichannel regions.

Stereo and multichannel regions are displayed in the Regions List by default in collapsed view. The individual regions can be displayed by clicking the arrow to the left of the region to expand the name.

**Stereo regions, collapsed (top) and expanded (bottom).**

**To expand or collapse all stereo and multichannel regions:**

- Press Option (Macintosh) or Alt (Windows) while clicking the triangle.

Individual items of an expanded-view stereo or multichannel region can be selected independently of the other associated regions in the Audio Regions List.

**Rules for Stereo and Multichannel Regions**

For stereo and multichannel regions to be shown as collective regions, the component regions must be the same length. If an existing stereo or multichannel region has been dragged onto multiple mono tracks and edited such that one or more components are no longer the same length, the stereo display is removed and the regions are displayed as individual regions in the Regions List.
**Edit Modes**

Pro Tools has four Edit modes: Shuffle, Spot, Slip, and Grid. The Edit mode is selected by clicking the desired button in the upper left of the Edit window.

![Edit mode buttons]

You can also use F1 (Shuffle), F2 (Slip), F3 (Spot), and F4 (Grid) to set the Edit mode.

The Edit mode affects the movement and placement of audio and MIDI regions (and individual MIDI notes), how commands like Copy and Paste function, and also how the various edit tools (Trimmer, Selector, Grabber, and Pencil) work.

**Shuffle**

In Shuffle mode, you can move regions freely within a track or to other tracks, but their movement is constrained by other regions. That is, if you place several regions in a track, they automatically snap to each other. You can then “shuffle” their order, but you cannot separate them from each other and you cannot make them overlap as in Slip mode. In Shuffle mode, adding another region to the beginning of a track moves all subsequent regions to the right by the length of the region added.

When using the Trimmer in Shuffle mode, changing a region’s start or end point automatically moves the adjacent regions as necessary. The placement and insertion of MIDI notes is not affected by Shuffle mode.

**Slip**

In Slip mode, regions can be moved freely within a track or to other tracks. In this mode it is possible to place a region so that there is space between it and other regions in a track. When the track is played back, this space is silent. It is also possible to move a region so that it overlaps or completely covers another region.

Use Slip mode when you want the Trimmer, Selector, Grabber, and Pencil tools to work without any restrictions to placement in time.

**Spot**

Use Spot mode to place regions at precise locations. This can be particularly useful when performing post production tasks around SMPTE frame locations. In this mode you can specify a frame location (or a location based on any of the other time formats), capture an incoming Time Code address, or use a region’s time stamps as reference points for spotting.

In Spot mode, when you move or trim regions, the Spot dialog opens.

**Grid**

In Grid mode, regions and MIDI notes that are moved or inserted “snap” to a user-definable time grid. In addition to placing material cleanly on the beat, Grid mode is also useful for making precise Edit and Timeline selections.
The actual Grid size, chosen from the Grid Value pop-up in the upper right of the Edit window, can be based on a time value using the Main Time Scale; or, if Follow Main Time Scale is deselected, another time format can be used for the Grid size.

Grid value set to 1 second

- The current Grid value is also used for the Quantize Regions Command. For information, see “Quantizing Regions” on page 228.

Also available in the Grid Value pop-up is an option for Regions/Markers. When selected, events can be placed freely (as in Slip mode) but will snap to region locations (start, end, and sync points), Markers, and Edit selections when placed near them.

- MIDI notes inserted with the Pencil tool ignore the Regions/Markers option, and instead snap to the time value selected in the Grid Value pop-up.

To display the Grid lines in the Edit window:

- Enable the Display Preference for “Draw Grids in Edit Window.”

Turning on Grid lines from Edit Window

- OR -

- Enable (and disable) Grid lines by Control-clicking (Macintosh) or Alt-clicking in any Timebase Ruler.

Turning on Grid lines from Ruler

Zooming options in Pro Tools include the Horizontal and Vertical Zoom buttons, the Zoomer tool, and the Zoom Preset buttons.

Horizontal and Vertical Zoom Buttons

Use the Horizontal and Vertical Zoom buttons to zoom in and out on track data. Unlike the horizontal zoom value, the vertical zoom value for MIDI and audio tracks are independent, and therefore have separate buttons.
To zoom in horizontally for all tracks:

- Click the right Horizontal Zoom button. To zoom out, click the other (left) Horizontal Zoom button.
  – or –
- Press Command+] (Macintosh) or Control+] (Windows). To zoom out, press Command+] (Macintosh) or Control+] (Windows).
- Click and drag on the Horizontal Zoom button to zoom continuously.

To zoom in vertically for all audio tracks:

- Click the (top) Vertical Zoom button with the audio waveform. To zoom out, click the bottom Vertical Zoom button.
  – or –
- Press Command+Option+] (Macintosh) or Control+Alt+] (Windows). To zoom out, press Command+Option+] (Macintosh) or Control+Alt+] (Windows).
- Click and drag on the Vertical Zoom button to zoom continuously.

To zoom in vertically for all MIDI tracks:

- Click the (top) Vertical Zoom button with the MIDI notes. To zoom out, click the bottom Vertical Zoom button.
  – or –
- Press Command+Shift+] (Macintosh) or Control+Shift+] (Windows). To zoom out, press Command+Shift+] (Macintosh) or Control+Shift+] (Windows).

To return to the previous zoom level:

- Option-click (Macintosh) or Alt-click (Windows) any of the Horizontal or Vertical Zoom buttons.
  – or –
- Press Command+Option+E (Macintosh) or Control+Alt+E (Windows).

To zoom in on a selection:

- Press Option+F (Macintosh) or Alt+F (Windows).

To zoom so that all regions are visible in the Edit window, do one of the following:

- Double-click the Zoomer tool in the toolbar.
- Press Option+A (Macintosh) or Alt+A (Windows).

---

**The Universe Window**

*(TDM Systems Only)*

The Universe window displays an overview of the entire session, representing audio and MIDI material on all tracks that are not hidden (including tracks that are inactive, or that contain offline regions). The order in which material is displayed in the Universe window corresponds to the track order in the Edit window.
To open the Universe window:

- Choose Windows > Show Universe.

Audio material residing in audio tracks is represented by a single, horizontal line in the Universe window. Each channel in a stereo or multi-channel track is represented individually.

Since Auxiliary Input and Master Fader tracks do not contain audio, they are displayed as blank areas in the Universe window.

Similar to audio tracks, MIDI tracks containing note material are represented by single, horizontal lines.

Resizing the Universe Window

Even though the Universe window can be resized horizontally and vertically, the length of the entire session is always displayed in the Universe window. If the Universe window is resized so some of the session’s track are not displayed, a vertical scroll bar becomes available.

Highlighted Material in the Universe Window

The highlighted, shaded area in the Universe window represents the material displayed in the Edit window. If you change what’s displayed in the Edit window—by zooming, scrolling horizontally or vertically, hiding or unhiding tracks, or changing track heights—the highlighted area in the Universe window updates.

During playback, if the Edit window is set to scroll, the highlighted area in the Universe window also scrolls.

Scrolling in the Universe Window

By clicking in the Universe window, you can automatically scroll, either horizontally or vertically, the material displayed in the Edit window. This provides a convenient method of locating anywhere in the session, or adjusting which shown tracks are visible in the Edit window.

To move the highlighted area in the Universe window:

1. Choose Windows > Show Universe.
2. To affect which tracks are displayed in the Edit window, click lower or higher (vertically) in the Universe window.
3. To scroll to a different session location, click later or earlier (horizontally) in the Universe window.

When all tracks are visible in the Edit window and the session is zoomed all the way out, with all regions visible, the entire Universe window is shaded.
Chapter 15: Editing Basics

Timebase Rulers

Any or all of the following Timebase Rulers can be displayed at the top of the Edit window:

- Bars:Beats
- Minutes:Seconds
- Time Code (TDM systems only)
- Feet:Frames (TDM systems only)
- Samples

In addition to providing a timing reference for track material, the Timebase Rulers are also used to define Edit selections for track material, and Timeline selections for record and play ranges.

With the Selector, drag in any Timebase Ruler to select material across all tracks in the Edit window. To include the Conductor Tracks in the selection, press Option (Macintosh) or Alt (Windows) while dragging.

All Rulers displayed

Any or all of the following Conductor Rulers can be displayed:

- Tempo
- Meter
- Markers

The Meter and Tempo Rulers indicate changes in meter and tempo within the Session. The Markers Ruler displays Markers to important track locations.

To display all Rulers:
- Select Display > Ruler View Shows > All.

To remove a Ruler from the display:
- Option-click the Ruler’s name (to the left of the Ruler display).
  - or -
- Deselect the Ruler in Display > Ruler View Shows.

To display only the Main Time Scale in the Ruler:
- Select Display > Ruler View Shows > None.
  (See See “Main Time Scale” on page 190.)

To add a specific Ruler to the display, such as the Markers Ruler, for instance:
- Select Display > Ruler View Shows > Markers.

To change the display order for the Rulers:
- Click a Ruler’s name and drag up or down to the new location.

Ruler Options Pop-up Menu

The Ruler display options are also available from a pop-up menu that is accessed by clicking just to the right of the Ruler names.
Main Time Scale

While all Timebase Rulers can simultaneously be displayed in the Edit window, there is only one that represents the Main Time Scale. The Main Time Scale determines the time format used for:

- The Transport's Main Counter
- Start, end, and length values
- Pre- and post-roll amounts
- Grid and Nudge values

The Main Time Scale can be set to the following formats:

**Bars:Beats** Displays the Time Scale in bars and beats. Use this Time Scale if you are working with musical material that must align with bars and beats.

To ensure your tracks align with the bars and beats in your session, make sure to record with the click (see “Recording with the Click” on page 128).

Material that is recorded without listening to the click can still be aligned to bar and beat boundaries in Pro Tools with the Identify Beat command (see “Identify Beat Command” on page 268).

**Minutes:Seconds** Displays the Time Scale in minutes and seconds. As you zoom in farther with the Zoomer, the Time Scale begins to display tenths, hundredths, and thousandths of a second.

**Time Code** (TDM systems only) Displays the Time Scale in SMPTE frames. The Frame Rate and Session Start time are set from the Session Setup window. Pro Tools supports the following frame rates: 24, 25, 29.97 Non-Drop, 29.97 Drop, 30 Non-Drop, and 30 Drop frames per second.

**Feet.Frames** (TDM systems only) Displays the Time Scale in feet and frames for referencing audio-for-film projects. The Feet.Frames time display is based on the 35 millimeter film format.

With this Time Scale, you can enter a Start Frame based on an appropriate frame location at the beginning of your project tape. The Feet.Frames Ruler will then use this value as its start reference.

**To set a start frame for a session:**

- Choose Setups > Feet.Frames and enter an appropriate start frame and click OK (negative offsets are not supported). This value will become the “zero point” in the Feet.Frames Ruler.

**Samples** Displays the Time Scale in samples. This format is very useful for high-precision sample editing.
Setting the Main Time Scale

To set the Main Time Scale:

- Select the desired Time Scale at the bottom of the Display menu.
  - or -

- Select from the Main Time Scale pop-up next to the Location Indicator (also available in the Transport window).
  - or -

- If a Timebase Ruler is displayed, click its Indicator Dot so it becomes highlighted.

To set the Time Scale for the Sub Location Indicator:

- Select from the Sub Time Scale pop-up next to the Location Indicator
  - or -

- Select from the Sub Time Scale pop-up in the Transport Window.

While you can click in the Main Counter and type in a location to automatically locate there, this is not supported for the Sub Counter.

Setting the Sub Time Scale

There is also a Sub Location Indicator displayed below the Main Location Indicator, and below the Transport's Main Counter, which provides an additional timing reference.

Tick-Based Timing

Pro Tools is a sample-based program with an internal MIDI resolution of 960,000 pulses per quarter note (ppq). However, when the Time Scale is set to Bars:Beats, the display resolution in Pro Tools is 960 ppq.

In Bars:Beats, Pro Tools is tick-based (960 ticks to a quarter note), which means that some amount of sample-rounding may occur when placing events at certain locations (see “Sample Rounding and Edit Operations” on page 192).
When working in Bars:Beats, you’ll often want to specify tick values for a number of operations, including:

- Placing and spotting regions
- Setting lengths for regions or MIDI notes
- Locating and setting play and record ranges (including pre/post-roll)
- Specifying parameters in the Quantize and Change Duration windows
- Setting the Grid and Nudge values

The following table lists the number of ticks for each of the main note sizes:

<table>
<thead>
<tr>
<th>Note Value</th>
<th>Normal</th>
<th>Dotted</th>
<th>Triplet</th>
</tr>
</thead>
<tbody>
<tr>
<td>1/2 note</td>
<td>1920</td>
<td>2880</td>
<td>1280</td>
</tr>
<tr>
<td>1/4 note</td>
<td>960</td>
<td>1440</td>
<td>640</td>
</tr>
<tr>
<td>1/8 note</td>
<td>480</td>
<td>720</td>
<td>320</td>
</tr>
<tr>
<td>1/16 note</td>
<td>240</td>
<td>360</td>
<td>160</td>
</tr>
<tr>
<td>1/32 note</td>
<td>120</td>
<td>180</td>
<td>80</td>
</tr>
<tr>
<td>1/64 note</td>
<td>60</td>
<td>90</td>
<td>40</td>
</tr>
</tbody>
</table>

**Ticks vs. Samples**

Audio material in Pro Tools is sample-based. This means that if an audio region is located at a particular sample (or SMPTE) location, it will not move from this location if the tempo changes in the session (though the audio region’s bar and beat location will change).

MIDI data in Pro Tools is bar- and beat-based. This means that if a MIDI region is located at a particular bar and beat location, it will not move from that location if the tempo changes in the session—though its sample location will change, thereby adjusting its relationship to audio.

When creating Markers and Selection Memory Locations, you can specify whether they have an Absolute (sample-based) or Bar|Beat (tick-based) reference. For more information, see “Bar|Beat and Absolute Reference” on page 275.

**Sample Rounding and Edit Operations**

Because audio material in Pro Tools is sample-based, some amount of sample-rounding may occur with some edits when the Main Time Scale is set to Bars:Beats. This is most evident when you need audio regions to fall cleanly on the beat (as when looping) and notice that the material is sometimes a tick or two off. With a few simple precautions, this can be avoided.

When selecting audio regions to be copied, duplicated, or repeated, make sure to select the material with the Selector (enable Grid mode for precise selections), or set the selection range by typing in the start and end points in the Event Edit area. Do not select the material with the Grabber (or by double-clicking with the Selector). This ensures that the selection will be precise in terms of bars and beats (and not based on the length of the material in samples).
Chapter 16: Playing and Selecting Track Material

Playing Tracks

After recording or importing to tracks, you’ll want to listen to the material to find track ranges that require editing, or material that can be turned into regions for use elsewhere.

To set where playback begins, you can click anywhere in a track with the Selector tool (as long as the Edit and Timeline selections are linked, see “Separate Edit and Timeline Selections” on page 199).

The *edit cursor*, on the other hand, is a flashing line that appears when you click with the Selector in a track’s playlist. The blinking edit cursor indicates the start point for any editing tasks performed. If you make a selection and perform an edit, the selection is the target of the edit.

The selected Scrolling Option determines how the Edit window scrolls during playback, and how the playback cursor functions. See “Scrolling Options” on page 195 for details.

To begin playing from a specific point within a track:

1. Select Operations > Scrolling Options > No Auto Scrolling.
2. Make sure to select Operations > Link Edit and Timeline Selection.
3. With the Selector, click in the track where you want playback to begin.
4. Click Play in the Transport window to begin playback.
5. Click Stop in the Transport window to stop playback.

To jump to a different location and begin playing from there, click with the Selector at that point and click Play in the Transport window.
With the Edit and Timeline selections linked, you can click a region or MIDI note with the Grabber to automatically update the Timeline with the selection’s start time, allowing you to easily play from that point.

**Page Scroll During Playback**

You can set Pro Tools to scroll the track display while playing, and also have the edit cursor appear wherever playback stops.

To make the track display and the edit cursor follow playback:
1. Select Operations > Scrolling Options > Page Scroll During Playback.
2. Choose Setups > Preferences. In the Operation page of the Preferences dialog, select the option for “Timeline Insertion Follows Playback,” then click Done.
3. Make sure to select Operations > Link Edit and Timeline Selection.
4. With the Selector, click in the track where you want playback to begin.
5. Click Play in the Transport window to begin playback. The playback cursor scrolls across the Edit window, indicating the current playback position.
6. Click Stop in the Transport window to stop playback. The edit cursor appears at the location where playback stops.

**Locating and Auditioning with Fast Forward/Rewind**

You can use the Fast Forward and Rewind buttons in the Transport window to locate material in your tracks. If the Operation Preference for “Audio During Fast Forward/Rewind” is selected, you’ll actually hear the scanned audio (similar to a CD player) when clicking the Fast Forward and Rewind buttons.

You can also fast forward or rewind incrementally by repeatedly clicking the appropriate button. The size of these increments is determined by the Main Time Scale:
- Bars:Beats: moves to the beginning of the previous or next bar.
- Min:Sec: moves back or forward in one-second steps.
- Time Code: moves back or forward in one-second steps (while adjusting for current SMPTE format).
- Feet.Frames: moves back or forward in one-foot steps.
- Samples: moves back or forward in one-second steps.

**Location Indicators**

The Location Indicators, in the upper right of the Edit window, display the current playback location, and also provide a convenient way to navigate to a specific time location.
The Main Location Indicator displays the playback location in the time format for the Main Time Scale. The Sub Location Indicator can be set to any of the other Time Scale formats for another timing reference. Both the Main and Sub indicators also appear in the Transport window when it is set to display Counters.

To navigate with the Location Indicators:

1. Click in one of the Location Indicators.
   - or -
   Press Equal (=) on the numeric keypad to highlight the Main Location Indicator (or the Transport Counters or Big Time window, if either are displayed).
2. Type in the new location. Press period (.) to cycle through to the different time fields.
3. Press Enter to accept the new value and automatically locate there.

Choose from the pop-up menus next to the Main and Sub indicators (in either the Edit window or Transport window) to set their time formats.

Scrolling in the Ruler

You can scroll the contents of the Edit window by clicking and dragging in the Ruler. While this doesn’t actually update the session’s Current Location, it does let you conveniently shift the display left or right for the sake of finding and editing material.

This method of scrolling is especially useful when using Continuous Scroll With Playhead (TDM systems only), which does not update or follow Timeline selections.

To scroll the entire contents of the Edit window from the Ruler:

- While pressing Command+Option+Control (Macintosh) or Control+Alt+Start (Windows), drag left or right in any of the Timebase Rulers.

Scrolling Options

Pro Tools offers the following options for how it scrolls the contents of the Edit window during playback and recording. Choose Operations > Scroll Options and select one of the following from the submenu:

**No Auto-Scrolling** With this scrolling option, the Edit window does not scroll during or after playback. The playback cursor moves across the Edit window, indicating the playback location.

**Scroll After Playback** Causes the Edit window to scroll to the final playback location after playback has stopped. In this mode, the playback cursor moves across the Edit window, indicating the playback location.

**Page Scroll During Playback** Causes the Edit window to scroll during playback. With this option, the playback cursor moves across the Edit window, indicating the playback location. When the right edge of the Edit window is reached, its entire contents are scrolled, and the playback cursor continues moving from the left edge of the window.
Continuous Scroll During Playback
(TDM Systems Only)
This scrolling option causes the Edit window’s contents to scroll continuously past the playback cursor, which remains in the center of the window. With this option, playback is always based on the Timeline selection (unlike Continuous Scroll With Playhead).

Continuous Scroll With Playhead
(TDM Systems Only)
This scrolling option causes the Edit window’s contents to scroll continuously past the Playhead, which is a blue line in the center of the window (red when recording).

The Playhead indicates where playback begins when clicking Play in the Transport window.

With the Playhead enabled, you can jump to and play an Edit or Timeline selection. For details, see “Playing Edit and Timeline Selections with the Playhead” on page 211.

Half-Screen Edit Window
When either Continuous Scroll During Playback or Continuous Scroll With Playhead is enabled, a half-screen appears at the far left of the Edit window (before the beginning of the session).

The Scrubber
The Scrubber allows you to “scrub” up to two tracks of audio in the Edit Window. Scrubbing is a technique that originated in tape editing, where the tape was rocked back and forth past the playhead at slower than normal speeds to find a particular location (usually for the sake of performing splices).

While viewing an audio waveform in Pro Tools can be helpful in visually finding an edit point, sometimes a waveform display (because of its sonic characteristics) may not reveal the desired spot in the audio material. By scrubbing back and forth over an edit point in Pro Tools, you can listen and zero in on the exact edit point you’re looking for.

When the Operation Preference for “Edit Insertion Follows Scrub/Shuttle” is enabled, the edit cursor automatically locates to the point where scrubbing stops.
When the Scrolling Option is set to Continuous Scroll During Playback or Continuous Scroll With Playhead, clicking with the Scrubber in a track’s playlist centers the Edit window around that point, and moves the Playhead there. With these Scrolling Options, scrubbed material moves past the Playhead, which remains stationary and centered.

Scrubs are only supported for audio tracks. MIDI tracks cannot be scrubbed.

To scrub a single audio track:

1. With the Scrubber selected, drag within the track—left for reverse, right for forward.

The Scrub/Shuttle Mode

When scrubbing normally, you can scrub at normal playback speeds or slower. Scrub/Shuttle mode, however, lets you scrub at several times normal speed, which is helpful in playing through large ranges and locating material.

To scrub in Shuttle mode (at several times normal speed):

1. Select the Scrubber tool.

2. While pressing Option (Macintosh) or Alt (Windows), drag within the track—left for reverse, right for forward. The Fast Forward and Rewind buttons in the Transport window engage.

The distance and speed dragged determine the speed for the scrubbed audio.

Scrub/Shuttle Mode

The maximum number of channels scrubbed in Pro Tools is eight, which would allow you to scrub two stereo tracks (four channels), but not two 5.1 surround tracks (12 channels).
**Shuttle Lock Mode**

Shuttle Lock mode lets you trigger playback for up to two tracks at varying speeds, forward and reverse, from the numeric keypad. If multiple tracks are selected, only the first two tracks are shuttled.

**To play one or two tracks with the shuttle lock:**

1. For TDM systems, make sure the Operation Preference for Numeric Keypad Mode is not set to Shuttle.
2. With the Selector, click in the track where you want playback to begin. To shuttle on two tracks, Shift-click in a second track.
3. Press Control (Macintosh) or the Start key (Windows) and a number on the numeric keypad: 0–9 (9 is fastest, 5 is normal speed, and 0 stops shuttling).

Once Shuttle Lock mode is initiated, Fast Forward and Rewind become highlighted in the Transport window.

4. Press additional keys to change the playback speed, or press Plus (+) and Minus (–) to switch the playback direction (plus for forward, minus for backward).
5. To stop playback, press Control+0 (Macintosh) or Start+0 (Windows).

**To exit Shuttle Lock mode:**

- Press Stop in the Transport window.
- or –
- Press the spacebar.

---

**Numeric Keypad Set to Shuttle (TDM Systems Only)**

Pro Tools offers another form of shuttling, different from that of Shuttle Lock mode. With the Numeric Keypad Mode set to Shuttle, playback of the current Edit selection is triggered by pressing and holding the keys on the numeric keypad—playback stops once the keys are released. Various playback speeds are available in both forward and reverse. In this mode, pre/post-roll are ignored.

**To shuttle with the Numeric Keypad Mode set to Shuttle:**

1. Choose Setups > Preferences and click Operations.
2. Set the Numeric Keypad Mode to Shuttle and click Done.
3. With the Selector, click in the track where you want playback to begin. To shuttle on two tracks, Shift-click in a second track.
4. Press and hold any of the following keys (or key combinations) on the numeric keypad to trigger playback.

<table>
<thead>
<tr>
<th>Shuttle Speed</th>
<th>Rewind Key</th>
<th>Forward Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 X Speed</td>
<td>4</td>
<td>6</td>
</tr>
<tr>
<td>4 X Speed</td>
<td>7</td>
<td>9</td>
</tr>
<tr>
<td>1/4 X Speed</td>
<td>1</td>
<td>3</td>
</tr>
<tr>
<td>1/2 X Speed</td>
<td>4+5</td>
<td>5+6</td>
</tr>
<tr>
<td>2 X Speed</td>
<td>7+8</td>
<td>8+9</td>
</tr>
</tbody>
</table>

5. Press a different key to switch the playback direction or speed. Release to stop.
Separate Edit and Timeline Selections

Pro Tools lets you unlink the Edit and Timeline selections. In doing so, you can make a selection within a track for editing purposes that is distinct from the selection in the Timeline (which determines the playback and recording range).

By default, the Edit and Timeline selections are linked. In this mode, selecting in a track’s playlist (an Edit selection) also defines the play and record range (the Timeline selection).

To unlink the Edit and Timeline selections:

- Deselect Operations > Link Edit and Timeline Selection.

- or –

- In the upper left of the Edit window, click the Link Selection button so it becomes unhighlighted.

Figure 11 illustrates another reason you’d want to unlink the Edit and Timeline selections. In this example, the Timeline selection sets a range to be looped on playback, while a MIDI region (residing within the loop) is selected for editing purposes. During playback, the Edit selection can be nudged, quantized, or transposed while the loop plays back completely independent and uninterrupted.

Playback/Edit Markers

Timeline selections are displayed in the Ruler with Playback Markers, which appear as blue arrows (red when recording). In addition, there are Pre- and Post-Roll Flags (which are green when enabled) indicating the location for pre/post-roll.

When the Edit and Timeline selections are unlinked, Edit selections are displayed in the Ruler with Edit Markers, which appear as black brackets.

Figure 12.  Edit Markers

Figure 11.  Edit and Timeline selections unlinked
If the Edit and Timeline selections are linked, Edit selections are represented by the blue Playback Markers.

See the following sections for details on working with Edit and Timeline selections:
- “Selecting Track Material” on page 200
- “Timeline Selections” on page 209
- “Setting Punch/Loop Points” on page 144
- “Setting Pre/Post-Roll” on page 145

**Selecting Track Material**

Before audio and MIDI material can be edited, it must first be selected. A track’s Display Format determines how the material is viewed and selected.

When you make a selection, it appears as a highlighted area of the track, and is also indicated by blue start and end arrows (Playback Markers) in the Ruler at the top of the Edit window. If any track (audio or MIDI) in the session is record-enabled, even if it is hidden, these markers appear red.

If the Edit and Timeline selections are unlinked, the Edit selection range is indicated by Edit Markers in the Ruler. See “Separate Edit and Timeline Selections” on page 199 for details.

**Selections and Edit Groups**

When making selections on tracks that are part of an Edit Group, all tracks within the group become selected.

**Selections and Hidden Tracks**

When editing tracks that are part of an active Edit Group, any tracks within the group that are hidden are not affected by the edits. To edit all members of a group, make sure they are visible by highlighting their names in the Show/Hide Tracks List.

**Selecting Regions**

To select a portion of a region:

1. With the Selector, drag within the region (left or right) to select the material.

To select an entire region:

- Click the region with the Grabber.
  - or -
- Double-click the region with the Selector.

To select two regions and the time range between them:

1. With the Grabber, click the first region.
2. Shift-click the second region. Both regions become selected, along with the time range between them (including any other regions).

To select an entire track:

- Click in the track with the Selector and then choose Edit > Select All.
  - or -
- Triple-click in the track with the Selector.
To select all regions in all tracks:

1. Select the “All” Edit Group in the Groups List.
2. Click in any track with the Selector and choose Edit > Select All.
   – or –
3. Triple-click with the Selector in any track.

Selecting All from Timebase Rulers

To select all material in all displayed audio and MIDI tracks:

1. Make sure the Edit and Timeline selections are linked.
2. Double-click in any Timebase Ruler. All regions in all displayed audio and MIDI tracks are selected. Tracks that are hidden are not selected.

To select all material in all tracks, along with Conductor events:

1. Make sure the Edit and Timeline selections are linked.
2. While pressing Option (Macintosh) or Control (Windows), double-click in any Timebase Ruler. All regions in all displayed audio and MIDI tracks are selected, along with all events in each of the Conductor tracks.

Making Selections While Playing

Pro Tools lets you make on-the-fly selections with the arrow keys.

To make a selection while playing:

1. Make sure to select Operations > Link Edit and Timeline selection.
2. With the Selector, click somewhere near the beginning of the track in which you want to make the selection.
3. Click Play in the Transport window to begin playback.
4. When playback reaches the point where you want the selection to begin, press the Down Arrow key.
5. Press the Up Arrow key at the point where you want the selection to end. The selected range becomes highlighted.

6. To stop playback, click Stop in the Transport window.

To automatically scroll to the beginning of the selection (or to the location of the on-screen cursor), press the Left Arrow key. To scroll to the end of the selection, press the Right Arrow key.

Object Selections (TDM Systems Only)

You can use the Object Grabber to select non-contiguous regions on one or more tracks. Non-contiguous selections must encompass entire regions. If you want a non-contiguous selection to include a portion of a region, first turn the portion into a new region with the Separation Grabber (see “Separation Grabber” on page 215) or the Separate Region command (see “Separate Region Command” on page 213).

The Object Grabber is not available when the Edit mode is set to Shuffle or Spot.

To select non-contiguous regions:

1. Make sure the Edit mode is set to either Slip or Grid.
2. Choose the Object Grabber from the Grabber tool pop-up menu.

Object Grabber
3 Shift-click each region you want to include in the selection. The regions can even reside on different tracks.

![Non-contiguous selection]

Each clicked region becomes surrounded by a dark rectangle, indicating it is selected.

The Object Grabber ignores Edit Groups when making selections. For instance, selecting a region on a grouped track does not cause regions in the other tracks in the group to become selected.

Object to Time Selection (TDM Systems Only)

You can convert between Time- and Object-based selections. Time selections are made with the Selector and Time Grabber. Object selections are made with the Object Grabber.

Converting to an Object selection is useful when you are working with large selections, especially across multiple tracks, and you want to remove certain regions from the selection.

Converting to a Time selection is useful if you want to select all regions between a non-contiguous Object selection.

To change a Time selection to an Object selection:
1. Drag with the Selector in any track to define a selection. Select in a Timebase Ruler to select across all tracks.

2 With the Object Grabber selected, double-click the Grabber icon in the toolbar. The regions falling within the selection range become selected as objects. Regions that were partially selected become deselected.

To select regions that were partially selected, press the Control key while double-clicking the Grabber icon.

To change an Object selection to a Time selection:
1. Select any number of regions with the Object Grabber.

2 Double-click the Selector icon in the toolbar. The time range between the first and last region becomes selected.

If using the Object Grabber (TDM systems only), regions on the other tracks in the group are selected if they fall within the range of the selected region.

Changing a Selection Length

The selection range can be shortened or lengthened; this does not affect the material within the selection.
To change the length of a selection:
- With the Selector, position the cursor over one end of the current selection and Shift-click or Shift-drag left or right.
- or -
- In the Ruler, drag the Playback Marker for the selection's start or end point.

To quickly make a long-length selection:
1. With the Selector, click at the beginning of the selection.
2. Scroll to the end point of the selection and Shift-click at that point.

To verify the start and end points of a long selection, press the Left Arrow key to scroll to the beginning of the selection, or press the Right Arrow key to scroll to the end.

Nudging a Selection Range

The selection range (not the material within the selection) can be moved by the Nudge value.

To nudge a selection range:
1. Configure the Nudge value as desired. For details, see “Defining the Nudge Value” on page 225.
2. Make the initial selection with the Selector.

3. While pressing Shift, press Plus (+) or Minus (−) on the numeric keypad to move the selection range by the Nudge value.

Nudging Selection Start/End Points

Start and end points for selections can be moved by nudging them.

To move a selection start or end point by the Nudge value:
1. Configure the Nudge value as desired. For details, see “Defining the Nudge Value” on page 225.
2. Make the initial selection with the Selector.
3. While pressing Option+Shift (Macintosh) or Alt+Shift (Windows), press Plus (+) or Minus (−) on the numeric keypad to move the selection's start point by the Nudge value.
- or -
While pressing Command+Shift (Macintosh) or Control+Shift (Windows), press Plus (+) or Minus (−) on the numeric keypad to move the selection's end point by the Nudge value.

Extending Selections

You can extend selections to region start and end points, to include an adjacent region, or to Markers and Memory Locations.

To extend a selection to a region start or end point:
1. With the Selector, select a portion of a region, or click anywhere in the region.
2. Press Shift+Tab to extend the selection to the region's end point.
- or -
Press Shift+Option+Tab (Macintosh) or Shift+Control+Tab (Windows) to extend the selection to the region’s start point.

**To extend a selection to include an adjacent region:**

1. Select the first region with the Grabber.
2. Press Shift+Control+Tab (Macintosh) or Shift+Start+Tab (Windows) to extend the selection to include the next region.
   - or –
   Press Shift+Control+Option+Tab (Macintosh) or Shift+Start+Control+Tab (Windows) to extend the selection to include the previous region.

**To extend a selection to a Marker or Memory Location:**

1. Click in a track with the Selector at the selection’s start or end point.
   - or –
   Make a selection with the Selector or Grabber.
2. Shift-click a Marker in the Markers Ruler.
   - or –
   Shift-click a Memory Location in the Memory Locations window.

The selection is extended from the original Insertion point to the Marker or Memory Location.

**Using the Selection Indicators (Start, End, and Length)**

The Selection Indicators at the top of the Edit window can define precise edit selections. Time values for the Selection Indicators use the time format for the Main Time Scale.

**Selection Indicators**

**To make a selection with the Selection Indicators:**

1. Click with the Selector in the track you want to select.
2. Click in the Start field at the top of the Edit window.
   - or –
   Press the slash key to select the Start field.
3. Type in the start point for the selection and press the slash key to enter the value and automatically move to the end field.
4. Type in the end point for the selection and press Enter to accept the value.

**Numeric Entry Shortcuts for Selection Indicators**

You can use the following shortcuts for entering values in the Selection Indicators:

- Press the slash key to cycle through the three Selection Indicators.
- Use period (.) or the Left and Right Arrow keys to move through the different time fields in each Selection Indicator.
- Press the Up or Down Arrow keys to increase or decrease the numerical values.
- Command-drag (Macintosh) or Control-drag (Windows) a selected field to scroll to a new value.
- Press Plus (+) or Minus (–), along with an accompanying number, to add or subtract from the current field value.
For example, to add 10 to a current field value, cycle to the field, press the Plus (+) key, type “10” and then press Enter.

If using Calculator Entry mode with the Time Scale set to Bars:Beats, see “Calculator Entry Mode and Bars:Beats” on page 205.

Press Escape to exit the Selection Indicators without entering any values.

These shortcuts can also be used to enter start and end values in the Transport window.

Calculator Entry Mode and Bars:Beats

To use Minus (–) in Calculator mode with the Time Scale set to Bars:Beats:

1. Highlight the time field you want to change.

2. While pressing Command (Macintosh) or Control (Windows), press Minus (–) on the numeric keypad.

3. Type the amount you want to subtract from the current time value, then press Enter.

Selecting Across Multiple Tracks

To perform edits across multiple tracks or all tracks, you must first select the tracks. Do this by making selections on tracks that are grouped (see “Grouping Tracks” on page 91), by extending selections to other tracks, or by selecting in a Timebase Ruler (for all tracks).

To extend a selection to another track:

1. Using the Selector or Grabber, make a selection in the first track.

2. Shift-click in additional tracks with the Selector. An identical range is selected for each additional track.

To shorten or lengthen the selection across each of the tracks, press Shift while dragging to change the range of the selection.

To select across all tracks:

- Enable the All Edit Group and make a selection in any track.

– or –

- Drag with the Selector in any Timebase Ruler (make sure the Edit and Timeline Selections are linked).

These selections include all tracks in the Edit window, but do not include the Conductor tracks (for Tempo, Meter, and Markers).

To select across all tracks, including the Conductor tracks (for Tempo, Meter, and Markers):

- Option-drag (Macintosh) or Alt-drag (Windows) with the Selector in any Timebase Ruler.

Moving and Extending Selections Between Tracks (TDM Systems Only)

With the Commands Focus enabled (TDM systems only), Edit selections can be moved or extended to adjacent tracks.
To move a selection to an adjacent track:

1. Enable the Commands Focus by clicking its button in the upper left of the Edit window.

2. With the Selector or Grabber, make a track selection.

3. Press P on your computer keyboard to move the selection to the previous track.

   – or –

   Press semicolon to move the selection to the next track.

In either instance, the original Edit selection becomes deselected.

To extend a selection to an adjacent track:

1. Enable the Commands Focus.

2. With the Selector or Grabber, make a track selection.

3. Press Shift+P to extend the selection to the previous track.

   – or –

   Press Shift+semicolon to extend the selection to the next track.

In either instance, the original Edit selection remains selected.

To remove the bottom track from a selection:

1. Press Control+Option+semicolon (Macintosh) or Start+Alt+semicolon (Windows) to remove the bottom track.

Other Useful Selection Techniques

Following are some additional selection techniques.

To position the edit cursor precisely at a region start, end, or sync point:

1. Click with the Selector in the track.

2. Press Tab to move the cursor to the next region start, end, or sync point.

   – or –

   Press Option+Tab (Macintosh) or Control+Tab (Windows) to move the cursor to the previous region start, end, or sync point.

To make a selection with the Scrubber:

1. Choose Setups > Preferences. In the Operation page of the Preferences dialog, select the option for “Edit Insertion Follows Scrub/Shuttle,” then click Done.

2. Scrub with the Scrubber to find an appropriate start point for the selection, then release.

3. While pressing Shift, scrub to an appropriate end point for the selection, then release. The range between the initial and final scrub becomes selected.

To move a selection to an adjacent region on the same track:

1. Select a region with the Grabber.

2. Press Control+Tab (Macintosh) or Start+Tab (Windows) to move the selection to the next region.

   – or –

   Press Control+Option+Tab (Macintosh) or Start+Control+Tab (Windows) to move the selection to the previous region.
In either instance, the original region becomes deselected.

**To slide an Edit selection in the Ruler:**

1. With the Selector or Grabber, make a track selection.
2. While pressing Option (Macintosh) or Alt (Windows), move the cursor over either of the Playback Markers in the Ruler (the Grabber appears).
   
3. Drag left or right to move the Edit selection back or forward in time, while preserving its length.

If the Edit and Timeline selections are unlinked, Option-drag (Macintosh) or Alt-drag (Windows) the Edit Markers instead.

**Tabbing to Transients**

With the Tab to Transients option, you can automatically navigate to transients in audio waveforms, placing the cursor just before the detected transient peak. This allows you to easily define selections and play ranges, as well as start and end points for new regions, without having to zoom in on the waveform.

When Tab to Transients is enabled, the Tabbing function also locates the cursor to region start, end, and sync points.

**To set the start and end points of a selection with Tab to Transients:**

1. In the upper left of the Edit window, click the Tab to Transients button so it becomes selected.
2. If you will be setting the play range with this selection, selection Operations > Link Edit and Timeline Selection.
3. Click in the audio track just before the beginning of the material you want to select.
4. Press Tab repeatedly until the cursor locates to the transient at the start of the selection.

If necessary, you can move to the previous transient by pressing Option+Tab (Macintosh) or Control+Tab (Windows).

5. Press Shift+Tab until the cursor locates to the end of the selection.

To move the selection end point to the previous transient, press Shift+Option+Tab (Macintosh) or Shift+Control+Tab (Windows).

Once selected, the material can be looped for recording or playback, or it can be turned into a new region with the Separate or Capture command.

**Region List Selection Follows Track Selection**

When the Editing Preference for “Region List Selection Follows Track Selection” is enabled, selecting a region in a track also causes the region to become selected in the Audio or MIDI Regions List.

Conversely, if the Editing Preference for “Track Selection Follows Region List Selection” is enabled, selecting a region in the Audio or MIDI Regions List causes the initial occurrence of that region to become selected within the track.
Playing Selections

Once an Edit selection is made, you can audition the track range by clicking Play in the Transport window. If enabled, the pre- and post-roll amounts play as well.

To play a selection:

1. Make sure to select Operations > Link Edit and Timeline Selection.
2. With the Selector or Grabber, make a track selection.
3. If desired, enable and set the pre- and post-roll amounts. For details, see “Setting Pre/Post-Roll” on page 145.
4. Click Play in the Transport window.

All tracks play for the range of the selection, including pre/post-roll if enabled.

Auditioning Pre- and Post-Roll

You can audition and play just the pre-roll or post-roll material for a selection.

To play from the pre-roll point to the start of a selection, or to the current cursor location:

- Press Option+Left Arrow (Macintosh) or Alt+Left Arrow (Windows).

To play to the post-roll point from the end of a selection, or from the current cursor location:

- Press Command+Option+Right Arrow (Macintosh) or Control+Alt+Right Arrow (Windows).

Auditioning Start and End Points for Selections

There may be times when you want to audition the start or end of a selection without hearing the entire selection. This allows you to check, for instance, whether the beginning or end of a selection includes any unwanted clicks or pops.

To audition a selection start point:

- Press Command+Left Arrow (Macintosh) or Control+Left Arrow (Windows).

When auditioning the beginning of a selection, the selection plays from the start point for a duration equal to the post-roll amount.

To audition a selection start point with pre-roll:

- Press Command+Option+Left Arrow (Macintosh) or Control+Alt+Left Arrow (Windows).

To audition a selection end point:

- Press Option+Right Arrow (Macintosh) or Alt+Right Arrow (Windows).

When auditioning the end of a selection, playback begins before the end point by the pre-roll amount.

To audition a selection end point with post-roll:

- Press Command+Option+Right Arrow (Macintosh) or Control+Alt+Right Arrow (Windows).
Looping Playback

When Loop Playback is enabled, the selected track range repeats on playback. If there is no selection, playback occurs normally from the current cursor location.

A selection must be at least 1 second in length for it to loop on playback.

Looping playback is a useful way to check the rhythmic continuity of a selection when working with musical material. If you’re working with one-bar selections, you can loop playback to see if the material loops cleanly. If it seems to skip, you should then adjust the length of the selection until it works “musically” within the context of the playlist and the other tracks.

To loop playback of a selection:

1. Make sure to select Operations > Link Edit and Timeline Selection.
2. With the Selector, select the track range you want to loop.
3. Select Operations > Loop Playback. When enabled, a loop symbol appears in the Play button in the Transport window.

You can also enable Loop Playback by Control-clicking (Macintosh) or Right-clicking (Windows) the Play button in the Transport window. Or, with the Numeric Keypad Mode set to Transport, press 4 on the numeric keypad.

4. Click Play in the Transport window.

Playback begins from the pre-roll point (if enabled) and continues to the selection’s end point, where it loops back to the start point.

5. Click Stop in the Transport window to stop playback.

Loop Playback and Audio Recording

When Loop Playback is enabled, Pro Tools will not loop when attempting to record audio tracks with QuickPunch, Destructive Record, or Nondestructive Record mode.

To loop record audio tracks in Pro Tools, you must enable Loop Record mode.

Timeline Selections

With the Edit and Timeline selections unlinked, selections can be made in the Timeline that are distinct and separate from Edit selections.

With the Edit and Timeline selections linked, any Edit selections that are made are mirrored in the Timeline.

Whether the Edit and Timeline selections are linked or not, the range indicated by the Playback Markers always determines the range for playback and recording.

For TDM systems, when Continuous Scroll With Playhead is enabled, it determines where playback begins. For details, see “Playing Edit and Timeline Selections with the Playhead” on page 211.

To make a Timeline selection with the Selector:

1. If desired, set the Edit mode to Grid to constrain the selection to the current Grid value.
2. Drag with the Selector in any Timebase Ruler.

Playback begins from the pre-roll point (if enabled) and continues to the selection’s end point, where it loops back to the start point.
The Timeline selection is indicated in the Ruler by the blue Playback Markers (red if a track is record-enabled). The start, end, and length for the Timeline selection is displayed in the corresponding fields in the Transport window.

To select all tracks, including Conductor tracks, press Option (Macintosh) or Alt (Windows) while dragging in a Timebase Ruler with the Selector.

To set the Timeline selection by dragging the Playback Markers:

1. If desired, set the Edit mode to Grid to constrain movement to the current Grid value.
2. With the Grabber, drag the first Playback Marker (down arrow) to set the start point.
3. Drag the other Playback Marker (up arrow) to set the end point.

To set the Timeline selection by typing into the Transport window:

1. If necessary, resize the Transport window by clicking in the upper right so the start and end times are displayed.
2. In the Transport window, click in the start field.
   - or -
   Press Option-slash (Macintosh) or Alt-slash (Windows) to select the start field in the Transport window.
3. Type in the new start location and press slash to enter the value and automatically move to the end field.
4. Type in the new end location and press Enter to accept the value.

Shortcuts for entering start and end values in the Transport window are listed in “Numeric Entry Shortcuts for Selection Indicators” on page 204.

Sliding a Timeline Selection

Like Edit selections, Timeline selections can be slid in the Ruler.

To move a Timeline selection in the Ruler:

1. While pressing Option (Macintosh) or Alt (Windows), move the cursor over either of the Playback Markers (the Grabber appears).
2. Drag left or right to move the Timeline selection back or forward in time, while preserving its length.

Timeline Selections to/from Edit Selections

When the Edit and Timeline selections are unlinked, you can copy selections between them.

To copy an Edit selection to the Timeline:

- Choose Operations > Copy Edit Selection to Timeline.

To copy a Timeline selection to an Edit selection:

- Choose Operations > Copy Timeline Selection to Edit.

Dragging a Playback Marker
Playing Edit and Timeline Selections with the Playhead
(TDM Systems Only)

When Continuous Scroll With Playhead is enabled, selections in the Timeline do not determine when playback begins. The Playhead, itself, denotes where playback begins when clicking Play in the Transport.

The Edit and Timeline selections, however, can still be played when the Playhead is enabled.

To play an Edit selection with the Playhead enabled:

1. Deselect Operations > Linked Edit and Timeline Selections.
2. Select Operations > Scroll Options > Continuous Scroll With Playhead.
3. With the Selector or Grabber, make a track selection.

The Playhead jumps to the Edit selection and plays it from beginning to end, and then stops.

To play a Timeline selection with the Playhead enabled:

1. Deselect Operations > Linked Edit and Timeline Selections.
2. Select Operations > Scroll Options > Continuous Scroll With Playhead.
3. Drag with the Selector in any Timebase Ruler to set the play range.

The Playhead jumps to the Timeline selection and plays it from beginning to end, and then stops.

Moving the Playhead

When Continuous Scroll With Playhead is enabled, the Playhead can be moved forward or back to the next region boundary in the selected track.

To move the Playhead through a track’s region boundaries:

1. Click in the track with the Selector.
2. Press Tab to move the Playhead forward to the next region boundary.
   – or –
   Press Option+Tab (Macintosh) or Control+Tab (Windows) to move the Playhead back to the previous region boundary.
Chapter 17: Working with Regions and Selections

Because regions are the basic building block of audio and MIDI tracks, understanding how they are created, edited, and arranged is essential to taking full advantage of the editing capabilities of Pro Tools.

This chapter covers basic editing functions as they apply to regions and selections. The material, for the most part, applies to both MIDI and audio data.

For editing procedures more specific to MIDI, see Chapter 23, “MIDI Editing.” For more advanced editing procedures, see Chapter 18, “Advanced Editing.” You should, however, become familiar with the information in this chapter before moving on to the others.

Creating New Regions

Pro Tools provides you with several commands for creating regions, each of them having a slightly different effect on the selection. When you create a new region, it appears in the Regions List and in the track’s playlist. For details on how these new regions are automatically named, see “Auto-Naming Parameters” on page 261.

When creating a new region from an existing region, the original region remains in the Regions List.

Capture Region Command

The Capture Region command defines a selection as a new region and adds it to the Regions List. From there, the new region can be dragged to any existing tracks.

To capture a new region:

1. With the Selector, drag within an existing region to select the material for the new region.
2. Choose Edit > Capture Region.
3. Enter a name for the new region and click OK.

The new region appears in the Regions List. The selected region portion remains intact and unchanged.

Separate Region Command

The Separate Region command defines a selection within an existing region, or a partially selected region, as a new region and separates it from adjacent material. If there is no selection and the Edit cursor is placed within the region, the region is split at the insertion point.
Auto-Name Separated Regions

With the Auto-Name Separated Regions option in the Editing Preferences selected, Pro Tools automatically names separated regions for you. The name is a numbered variation of the original region’s name.

To separate one or more regions:

1. With the Selector, drag to select the material for the new region or regions. The selection can reside within a single region, across adjacent regions within the same track, or across multiple tracks.

   – or –

   Click with the Selector at the point within a region, where you want to split the region in two.

2. Choose Edit > Separate Region.

3. If the Editing Preference for Auto-Name Separated Regions is disabled, enter a name for the new region when prompted, then click OK.

The new regions appear in the tracks in which they were created, separate from the data surrounding it. They also appear in the Regions List. From there they can be dragged to other tracks.

By separating a region, additional regions are auto-created from data on either side of the separation, which have new numbers assigned to their names. The original region remains intact and unchanged on the Regions List.

If the Editing Preference for “Separate Region Operates On All Related Takes” is selected and you are editing a region that is one of a number of related takes with the same User Time Stamp (for example, as created with loop recording), the Separate Region command affects each take. For details see, “Editing Preferences and Take Regions” on page 143.

Separating Multiple Tracks

Figure 13 illustrates a a separation across three mono audio tracks and one stereo track. For some tracks, the selection resides within a region, while others reside at the start or end of a region.

Figure 13. Separating across multiple tracks

Once separated, this material can be easily moved or copied to another location.
**Separation Grabber**

You can use the Separation Grabber to automatically separate an edit selection and move it to another location or another track.

**To separate a selection with the Separation Grabber:**

1. With the Selector, drag to select the material for the new region or regions. The selection can reside within a single region, across adjacent regions within the same track, or across multiple tracks.

2. From the Grabber pop-up, choose the Separation Grabber.

3. Drag the selection to the new location, or to another track.

A new region (or regions) containing the previous selection is created, separate from the original selection. New regions are also created from the material outside the original selection.

**To separate a selection without affecting the original regions:**

1. With the Selector, drag to select the material for the new region or regions. The selection can reside within a single region, across adjacent regions within the same track, or across multiple tracks.

2. From the Grabber pop-up, choose the Separation Grabber.

3. While pressing Option (Macintosh) or Alt (Windows), drag the selection to the new location, or to another track.

New regions containing the previous selection are created and placed at the new location. The original selection and regions remain intact.

**Trim To Selection Command**

The Trim To Selection command removes data before and after a region or MIDI note selection, leaving only the selection. This command provides a handy means of quickly removing all data in a region (and in some instances the entire track) except for the current selection.

**To trim unwanted data from a region or note:**

1. With the Selector, select a portion of a region or note (or a range of notes).

2. Choose Edit > Trim > To Selection to remove material outside of the selection.
Healing a Separation

The Heal Separation command returns separated regions to their original state—provided the regions are still next to each other and their relative start/end points haven’t changed since the separation.

If you have trimmed or otherwise changed the start or end points of the two regions, or moved them further away from each other, you won’t be able to repair them with the Heal Separation command. It is not possible to heal two regions created from different audio files.

To heal a separation between two regions:

1. With the Selector, make a selection that includes part of the first region, the entire separation between the regions, and part of the second region.
2. Choose Edit > Heal Separation.

If the regions won’t heal, there are other ways to return the separated regions to a single region.

- Delete one of the two separated regions (make sure you’re in Slip mode so the gap doesn’t close) and use the Trimmer to expand the remaining region to its original length. For information on using the Trimmer, see “The Trimmer Tool” on page 218.
- or –
- Delete both of the separated regions and drag the original region from the Regions List to the original location. For information on placing regions, see “Placing Regions in Tracks” on page 216.

Placing Regions in Tracks

Once you have created a region, it appears in the Audio or MIDI Regions List. From there you can drag it to a track to add to an existing arrangement of regions, or you can create a new track and start adding regions from scratch. The exact placement of regions in a track depends on whether the Edit mode is set to Shuffle, Slip, Spot, or Grid (see “Edit Modes” on page 185 for details).

For information on locating regions in the Regions List by typing the first few letters of their name, see “Keyboard Selection of Regions” on page 184.

To place a region in a track:

1. In the Audio or MIDI Regions List, select the region or regions you want to place in a track.
2. Drag the selected regions from the Regions List to a track at the desired point.

If dragging multiple regions, the regions are placed on adjacent tracks. If dragging a stereo region, it must be placed in a stereo track or in two mono tracks.

Regions are placed according to the current Edit mode:

- In Shuffle mode, existing track regions are slid as necessary to make room for the new region.
- In Spot mode, you are prompted by the Spot dialog to enter a location for the dragged region (see “Spotting Regions” on page 223).
- In Grid mode, the dragged region snaps to the nearest Grid boundary.
• In Slip mode, the regions are placed freely anywhere in the destination track.

Use the Replace Region function to replace all occurrences of a region (in all tracks) with a different region from the Regions List. See “Replacing Regions” on page 239.

Placing Regions at the Edit Insertion Point

You can easily place and align a region’s start, end, or sync point to the Edit insertion point. This technique is useful in post production applications since it allows you to set a reference point and quickly place sound effects while ensuring that their start point remains consistent.

You can drag a region from the same track, from another track, or from the Audio or MIDI Regions List.

For TDM systems, when Continuous Scroll with Playhead is selected, regions snap to the playhead, instead of the Edit insertion point.

To place the start of a region at the Edit insertion point:

1. Click with the Selector in the track at the desired time location.
2. While pressing Control (Macintosh) or Start key (Windows), drag the region from the Regions List, or from another track, to the destination track.

– or –

If the region is already in the track, Control-click (Macintosh) or Start-click (Windows) the region with the Grabber.

To place the end of a region at the Edit insertion point:

1. Click with the Selector in the track at the desired time location.
2. While pressing Command+Control (Macintosh) or Control+Start key (Windows), drag the region from the Regions List, or from another track, to the destination track.

– or –

If the region is already in the track, Command-Control-click (Macintosh) or Control-Start-click (Windows) the region with the Grabber.

To place the sync point of a region at the Edit insertion point:

1. Click with the Selector in the track at the desired time location.
2. While pressing Shift+Control (Macintosh) or Shift+Start key (Windows), drag the region from the Regions List, or from another track, to the destination track.

– or –

If the region is already in the track, Shift-Control-click (Macintosh) or Shift-Start-click (Windows) the region with the Grabber.

Aligning to Region Start Points

The start, end, and sync point of one region can be aligned to the start of a different region on another track.

For TDM systems, if Continuous Scroll with Playhead is enabled, region start, end, and sync points align to the playhead.
To align the start points of regions on different tracks:

1. With the Grabber, select the region you want to align to by clicking it.

2. For TDM systems, if Continuous Scroll with Playhead is enabled, move the playhead to the start of the selected region. For details, see “Moving the Playhead” on page 211.

3. With the Grabber, Control-click (Macintosh) or Start-click (Windows) the region you want to move.

   – or –

Control-drag (Macintosh) or Start-drag (Windows) a region from the Regions List to another track.

The start point of the second region is aligned to the start of the first region.

To align the sync point of a region to the start of another region (on a different track):

1. With the Grabber, select the region you want to align to by clicking it.

2. For TDM systems, if Continuous Scroll with Playhead is enabled, move the playhead to the start of the selected region. For details, see “Moving the Playhead” on page 211.

3. With the Grabber, Shift-Control-click (Macintosh) or Shift-Start-click (Windows) the region you want to move.

   – or –

Shift-Control-drag (Macintosh) or Shift-Start-drag (Windows) a region from the Regions List to another track.

The sync point of the second region is aligned to the start of the first region.

---

The Trimmer Tool

Standard Trimmer

With the Trimmer tool, you can quickly shorten or expand a region (up to the entire length of the source audio file). The first time you trim a region, Pro Tools automatically adds it to the Regions List as a new region (with a name derived from the original) in order to differentiate it from the original.

The Standard Trimmer is a nondestructive tool and doesn’t actually modify the original audio or MIDI data (when working on regions). To return to the length of the original region, drag it from the Regions List, or resize the edited region with the Trimmer to its original length.
Use of the Trimmer is affected by the current Edit mode: Shuffle, Slip, Spot, or Grid. See “Edit Modes” on page 185 for more information.

The Standard Trimmer can also be used to lengthen and shorten MIDI notes (see “Trimming Note Start and End Times” on page 302), and also to scale automation and controller data up or down “Drawing Automation” on page 390.

For TDM systems, the Trimmer has three modes: Standard Trimmer (discussed in this section), Scrub Trimmer (see “The Scrub Trimmer” on page 219), and Time Trimmer (see “The Time Trimmer” on page 242).

To trim a region with Standard Trimmer:

1. Select the Trimmer tool. For TDM systems, make sure the Standard Trimmer is selected in the Trimmer pop-up menu.

2. Move the cursor near the start or end of the region, so the Trim cursor appears.

To reverse the direction of the Trim cursor, press Option (Macintosh) or Alt (Windows).

3. If trimming the end, drag left to shorten the region, right to lengthen.
   - or -

If trimming the start, drag right to shorten the region, left to lengthen.

When trimming regions in a stereo or multi-channel track, all channels are trimmed.

When using Shuffle mode, adjacent regions are slid as necessary to make room for the edited region. If using Grid mode, the dragged start/end times snap to the nearest Grid boundary. If using Spot mode, the Spot dialog opens, where you can enter the new location for the region’s start or end point.

The Scrub Trimmer
(TDM Systems Only)

The Scrub Trimmer is a convenient tool for auditioning material (on up to two tracks) to find a trim point. You can drag in a track to hear the audio information, then trim at a specific location by releasing the mouse button.

This action creates a new region. Note that the cursor changes into a “right trim” or “left trim” shape as it is placed over the right or left side of a region. To reverse the direction of the Scrub Trimmer, press Option (Macintosh) or Alt (Windows) before you click the region.

Scrub playback speed and direction vary with controller movement. Scrubbed audio is routed through the track signal path, so you hear any effects in the signal path.
To scrub trim a track:

1. Click the Scrub Trimmer tool. The cursor changes to a speaker with a bracket.
2. Drag within a track to the left or right. Audio from a scrubbed track is routed through the track signal path, including any TDM effects. When you locate the desired trim point, release the mouse button to trim the region.

To scrub trim two tracks, click with the Scrub Trimmer between two adjacent tracks and drag.

To scrub with finer resolution (without having to zoom in), press Command (Macintosh) or Control (Windows) while scrubbing.

Trim To Insertion Command

You can trim a region or MIDI note by automatically removing the material between the Edit insertion point and the start or end point.

To trim from a start point to insertion:

1. With the Selector, click inside the region or note where you want the new start point to be.
2. Choose Edit > Trim > Start To Insertion. The region’s start point is automatically trimmed to the insertion point.

To trim from an end point to insertion:

1. With the Selector, click inside the region or note where you want the new end point to be.
2. Choose Edit > Trim > End To Insertion. The region’s end point is automatically trimmed to the insertion point.

Trimming with Nudge

You can trim the start and end points of a region by nudging them.

To trim a region’s start or end point by the Nudge value:

1. Configure the Nudge value as desired. For details, see “Defining the Nudge Value” on page 225.
2. With the Grabber, select the region you want to trim.
3. While pressing Option (Macintosh) or Alt (Windows), press Plus or Minus on the numeric keypad to trim the region’s start point by the Nudge value.
   – or –

While pressing Command (Macintosh) or Control (Windows), press Plus or Minus on the numeric keypad to trim the region’s end point by the Nudge value.
Sliding Regions

A region or group of selected regions (on the same track or on multiple tracks) can be slid with the Grabber tool to new locations or to other tracks. This feature is useful in music and post production applications where the timing of audio events such as sound effects and dialog need to be spotted to music, film, or video.

Sliding regions is affected by whether the current Edit mode is set to Shuffle, Slip, Spot, or Grid. See “Edit Modes” on page 185 for details.

You can slide a copy of a region to another location or track by pressing Option (Macintosh) or Alt (Windows) while dragging.

To retain a region’s location when dragging to another track, press Control (Macintosh) or the Start key (Windows) while dragging.

Defining Region Sync Points

The placement of regions in Grid and Spot mode can be based on the definition of a region sync point. Sync points are used when a point within a region must be aligned to the Grid or to a particular SMPTE or bar/beat location. This capability is important in placing music and sound effects for film and video work.

For example, suppose you had an audio region for a door slam that included the creak of the door closing, the actual slam, and the reverb of the slam. You may want to align the “slam” to other locations within the session.

To identify (define) a region sync point:

1. Set the Edit mode to Slip by clicking its button in the upper left of the Edit window.

2. With the Selector, click in the region at the point, usually the peak of the waveform, where you want to define the sync point.

3. Choose Edit > Identify Sync Point. A small down arrow appears at the bottom of the region, indicating the location of the sync point.

Sync point defined

To remove a sync point, select the entire region and choose Edit > Remove Sync Point.

Shuffling Regions

In Shuffle mode, you can move regions freely within a track or onto another track, but their movement is constrained by other regions. That is, if you place several regions in a track, their start and end points automatically snap to each other. You can then “shuffle” their order, but you cannot separate them from each other and you cannot make them overlap as in Slip mode. In Shuffle mode, adding another region to the beginning of a track moves all subsequent regions to the right by the length of the region added.

To shuffle regions:

1. Set the Edit mode to Shuffle by clicking its button in the upper left of the Edit window.
2 Drag a mono region from the Regions List to an empty track. The region snaps to the beginning of the track.

3 Drag a second region from the Regions List to the same track, somewhere in the middle. The start point for the second region snaps to the end of the first region.

4 With the Grabber, drag the second region to the beginning of the track.

Pro Tools “shuffles” the position of the two regions. The second region now occurs first, yet the two still cling together.

5 Experiment more with Shuffle mode by dragging additional regions to the track and rearranging them.

Locked regions (see “Locking Regions” on page 228), and all regions occurring after the locked region, are not displaced when other neighboring regions are moved in Shuffle mode. If there is not enough room to place or duplicate a region in front of a locked region, the insertion area is disabled.

If you place a region while in Slip mode and switch to Shuffle mode, Pro Tools preserves the relative timing and position of the slipped region, and any blank space between it and other regions.

**Slipping Regions**

In Slip mode, regions can be moved with the Grabber freely within a track, or onto other tracks. In this mode, it is possible to place a region so that there is space between it and other regions in a track. When the track is played back, this space is silent. It is also possible to move a region so that it overlaps or completely covers another region.

**To slip regions:**

1 Set the Edit mode to Slip by clicking its button in the upper left of the Edit window.

2 Drag a region from the Regions List to an empty track.

3 Drag a second region from the Regions List to the same track, somewhere in the middle. The second region is placed wherever you release it. It doesn’t snap to the first region as in Shuffle mode.

4 Drag the regions to different locations within the track to get a feel for moving them in Slip mode. Try placing the second region so that it slightly overlaps the first region. Play back the results.

**Shuffling Multiple Tracks and Multichannel Regions**

Selections across multiple tracks or on multichannel tracks can be shuffled. Unlike shuffling regions on a single, mono track, any partially selected regions will be cut and moved along with the dragged region. This lets you retain only the material that corresponds to the dragged region, similar to a tape splice and multitrack.
Spotting Regions

Spot mode is useful for sessions in which you want to spot regions to precise locations based on any of the Time Scales. This can be particularly useful when performing post production tasks. In Spot mode you can spot a region by specifying a SMPTE frame (TDM systems only) or bar and beat location, by capturing an incoming time code address, or by using the region’s time stamps.

For even quicker spotting, if you are using VITC, use the Auto-Spot Regions command to spot a region to the current SMPTE frame location with the Grabber. For more information, see “Auto-Spotting Regions” on page 493.

To spot a region:

1. Set the Edit mode to Spot by clicking its button in the upper left of the Edit window.

2. Drag a region from the Regions List to an existing track.
   – or –
   Click a region already in a track with the Grabber.

3. In the Spot dialog, select the desired time format from the Time Scale pop-up menu.

Each of the fields in the Spot dialog are displayed in the chosen Time Scale.

4. For TDM systems, if the Time Scale is set to Time Code, select the Use Subframes option to display subframes in the fields for great accuracy.

5. Click in the field for Start, Sync Point, or End and type in a new location. Changing one of these locate points automatically updates the other locate points.
   – or –
   Click one of the up arrows next to Original Time Stamp or User Time Stamp to enter the associated values into the currently selected field.
   – or –
   If you are using an external SMPTE time code source, click the down arrow next to the Current Time Code display—or press Equal (=) on the numeric keypad—to capture an incoming time code address.

6. Click OK. The region is moved to the new location specified for its start or sync point.

If a region does not have a sync point defined, the Sync Point field in the Spot dialog functions the same as the Start field.
To learn more about using SMPTE with Pro Tools, refer to Chapter 35, “Time Code Synchronization.”

**Region Time Stamps**

When a region is created, it is time stamped relative to the SMPTE start time specified for the session. This Original Time Stamp is permanently stored with the region and cannot be changed. If a region is ever moved, it can easily be placed at its original position from the Spot dialog.

When the Original Time Stamp for a region is initially set, this same location is also used to define the region’s User Time Stamp. Unlike the Original Time Stamp, the User Time Stamp can be redefined with the Time Stamp Selected command in the Regions List pop-up menu. For more information, see “Time Stamping” on page 494.

Regions with identical User Time Stamps appear together in the Takes List pop-up when auditioning takes. For more information, see “Auditioning from the Takes List Pop-up Menu” on page 142.

**Sliding Regions in Grid Mode**

In Grid mode, the movement and placement of regions is constrained to the current Grid value. Grid boundaries, depending on the Main Time Scale, can be based on frames, bar and beat values, minutes or seconds, or a number of samples. This mode is especially useful for lining up regions at precise intervals, as when working with a session that is bar- and beat-based. For example, if the Grid value is set to quarter notes (0|1|000), dragging a region to a new location causes it to snap to the nearest quarter note boundary.

When the Display Preference for “Draw Grid in Edit Window” is enabled, vertical Grid lines appear in the Edit window.

Grid lines in the Edit window can also be enabled and disabled by Control-clicking (Macintosh) or Right-clicking (Windows) the Indicator Dot for any Timebase Ruler.

**Defining the Grid Value**

In addition to affecting the placement of regions, the Grid value also constrains Edit and Timeline selections, and determines how the Quantize Regions command works.

**To set the Grid value:**

1. From the Display menu, select the Time Scale you will use for the Grid value.

   – or –

   To keep the Main Time Scale and use a different time format for the Grid, deselect Follow Main Timebase in the Grid Value pop-up in the upper right of the Edit window.
2 From the Grid Value pop-up in the upper right of the Edit window, select the time value that will define the Grid boundaries.

- or -

To define a Grid based on the session's Markers, selections, and region boundaries, select Regions/Markers from the Grid Value pop-up.

To place or move a region while in Grid mode:

1 Configure the Grid value as desired. For details, see “Defining the Grid Value” on page 224.

2 Drag a region from the Regions List to an existing track.

- or -

With the Grabber, drag a region already in a track to a new location.

The region’s start point snaps to the closest Grid boundary. If the region has a sync point defined, the sync point snaps to the Grid boundary.

---

**Nudging**

Pro Tools can nudge regions (or MIDI notes) by precise increments with the Plus (–) and Minus (+) keys on the numeric keypad. The amount of the nudge is determined by the value specified in the Nudge pop-up menu. The Nudge function can be used in any of the Edit modes.

Nudging can be invaluable for adjusting the “groove” of a musical phrase or a sound effect relative to other elements in the session. Since Pro Tools can nudge material during playback, you can nudge continuously in real time to adjust the timing relationship between tracks.

Nudge can also be used to adjust the placement of automation breakpoints. For more information, see “Editing Automation” on page 391.

**Defining the Nudge Value**

The Nudge value determines how far regions and selections are moved when nudging.

Start and end points for selections can also be moved by the Nudge value (see “Nudging Selection Start/End Points” on page 203). In addition, regions can be trimmed by the Nudge value (see “Trimming with Nudge” on page 220).

To set the Nudge value:

1 From the Display menu, select the Time Scale you will use for the Nudge value.

- or -

To keep the Main Time Scale and use a different time format for the Nudge value, deselect Follow Main Timebase in the Nudge pop-up in the upper right of the Edit window.
2 From the Nudge pop-up menu in the upper right of the Edit window, select the Nudge value.

**Nudge pop-up showing Time Code**

To specify a Nudge value not listed in the Nudge pop-up, click in the Nudge field and type in the value.

**Nudging Regions**

**To nudge one or more region:**

1. Configure the Nudge value as desired. For details, see “Defining the Nudge Value” on page 225.

2. With the Grabber or Selector, select the region or regions you want to nudge. The regions can reside on multiple tracks. Only regions that are entirely selected will be nudged.

3. On the numeric keypad, press Plus (+) to move the selection forward by the Nudge value.
   - or -

   Press Minus (-) to move the selection back by the Nudge value.

The Nudge command works the same regardless of the Edit mode. Adjacent regions are overlapped in Shuffle mode, the Spot dialog does not appear when in Spot mode, and shifted material does not snap to the Grid when in Grid mode.

**Nudging Regions on Multiple Tracks and in Multichannel Tracks**

When nudging a selection of multiple regions, within a single track or across multiple tracks, that also contains silence, any automation data residing within the silence is also nudged.

**Nudging by Next Nudge Value (TDM Systems Only)**

In addition to nudging by the current Nudge value, you can also nudge by the next, larger value in the Nudge pop-up.

For example, if the Nudge value is set to 1 frame and you want to nudge by a larger value, you can nudge by the next, larger Nudge value of 10 frames.

**To nudge forward or back by the next, larger Nudge value:**

1. Enable the Key Commands Focus by clicking the a-z button in the upper left of the Edit window.

2. With the Selector or Grabber, select the regions or notes you want to nudge.

3. Press slash (/) to nudge the selected material forward by the next Nudge value. Press M to nudge the selection back.

You can also nudge by the next Nudge value without enabling the Commands Focus.

While pressing Control (Macintosh) or the Start key (Windows), press slash (/) or M.
**Nudging a Region’s Contents**

Often a region’s start point will reside at the correct location, perhaps at a SMPTE frame or bar, but the material within the region starts too late or early. You can, in effect, nudge a region’s audio waveform or MIDI notes without displacing the region’s start and end points.

This “sliding” of region contents is only possible if there is material residing outside the region’s start and end points—from the region having been trimmed, or perhaps captured from a larger region.

**To nudge the contents of a region without changing the region start and end points:**

1. Configure the Nudge value as desired. For details, see “Defining the Nudge Value” on page 225.

2. With the Grabber, select the region whose contents you want to nudge.

3. While pressing Control (Macintosh) or the Start key (Windows), press Plus (+) or Minus (–) on the numeric keypad to move the material by the Nudge value.

**Shift Command**

Use the Shift command to move track material forward or back in time by a specified amount. The Shift command can operate on selections, regions, MIDI notes, MIDI controller data, and automation breakpoints.

**To shift a selection or region:**

1. Using either the Selector or Grabber, select the track material you want to shift. The selected material can reside on multiple tracks.

2. Choose Edit > Shift. In the Shift dialog, select whether the data will be moved Earlier or Later.

3. Click in one of the Timebase fields to specify the amount the material will be shifted. Entering a value in one Timebase field automatically updates the others.

4. If desired, select the Use Subframes option for greater accuracy.

5. Click OK. The material is shifted back or forward by the specified amount.

If a portion of a region was selected, new regions are created from the selection and from any material outside of the selection.
The Shift command works the same regardless of the Edit mode. Adjacent regions are overlapped in Shuffle mode, the Spot dialog does not appear when in Spot mode, and shifted material does not snap to the Grid when in Grid mode.

### Quantizing Regions

The Quantize Regions command adjusts the placement of selected audio and MIDI regions so that their start points (or sync points, if they contain one) precisely align to the nearest Grid boundary, which can be based on frames, bar and beat values, minutes or seconds, or a number of samples.

**To quantize one or more regions:**

1. Configure the Grid value as desired. For details, see “Defining the Grid Value” on page 224.
2. With the Grabber or Selector, select the region or regions you want to quantize. The regions can be on multiple tracks. Only regions that are entirely selected will be quantized.
3. Choose Edit > Quantize Regions. Region start times (or sync points) are aligned to the boundaries for the defined Grid.

For MIDI regions, all data contained within the regions (such as notes) are moved equally, thereby retaining their rhythmic relationships. To quantize individual MIDI notes, use the Quantize command in the MIDI menu (see “Quantize” on page 318).

### Locking Regions

If you have a region or group of regions that you want to permanently associate with a particular location in a track (a beat, SMPTE frame, or sample location), you can lock it in place so it will not be accidentally moved.

**To lock a region:**

1. With the Grabber, select the region or regions to lock. The regions can even reside on multiple tracks.
2. Choose Edit > Lock/Unlock Region.

A small lock appears in the region, indicating it has been locked and cannot be moved. If you attempt to perform edits that would move a locked region, Pro Tools alerts you.

In Shuffle mode, locked regions, and all regions occurring after the locked region, are not displaced when other neighboring regions are moved. If there is not enough room to place or duplicate a region in front of a locked region, the insertion area is disabled.

> **Locking a region prevents it from being moved only—operations such as recording and automation editing still affect it.**

### Muting/Unmuting Regions

Choosing the Mute/Unmute Region command mutes playback of a selected region. Choosing the command a second time unmutes the region. Regions that are muted become dimmed to indicate their status.
To mute a region or regions:

1. With the Grabber, select the region or regions you want to mute. The regions can even reside on multiple tracks.

2. Choose Edit > Mute/Unmute Region. The selected regions become dimmed, indicating they are muted.

To unmute a region, select it and choose Edit > Mute/Unmute Region.

---

**Edit Commands**

**Cut, Copy, Clear, and Paste**

Use the Cut, Copy and Paste commands to rearrange and edit track material. Edits can operate on entire regions selected with the Grabber, or on track ranges selected with the Selector. Edits can also work across multiple tracks (see “Editing Across Multiple Tracks” on page 232).

*For TDM systems, you can cut, copy, and paste discontiguous regions selected with the Object Grabber.*

When cutting or copying track material, the track's Display Format determines the type of data placed on the Clipboard. When displaying waveforms for audio tracks, or notes or regions for MIDI tracks, selections include all underlying automation and controller data. Thus, cutting an audio region also cuts any volume, pan, mute, send, or plug-in automation that is also on the track. This saves you from having to individually cut from each automation playlist on the track.

However, when selecting groups of MIDI notes with the Grabber (by drawing a rectangle around them), only the note data is placed on the Clipboard. When selecting a time range of MIDI notes with the Selector, all controller data in the track is selected (similar to selecting with the Selector for audio tracks in Waveform view).

When a track is displaying automation data or controller data, only that data is placed on the Clipboard. Also, whenever you cut or copy automation data, bounding breakpoints are created at each end of the selected area, in order to preserve the slope of the automation both inside and outside the selection.

If tracks are grouped, copying and pasting on any of the tracks affects each of the other tracks in the group. Tracks that are hidden—even if they are part of a group being edited—are not affected by edits.
The current Edit mode affects how material is selected, copied, and pasted:

- In Slip mode, the Cut command leaves an empty space corresponding to the data removed from the track.
- In Shuffle mode, the Cut command leaves no empty space, since the regions to the right of the cut slide over, closing the gap.
- In Slip mode, pasted data can overlap an adjacent region.
- In Shuffle mode, pasted data causes all regions to slide over to make room for the pasted material.

New regions are often auto-created when performing edits. For instance, when clearing a selection from a region, new regions are auto-created from the material residing outside of the selection.

**Clear Command**

Use the Clear command to remove a selection from a track without placing it on the Clipboard.

**To clear a selection or region:**

1. If desired, set the Edit mode to Grid to constrain the selection to the current Grid value.
2. Set the Display Format for the tracks you want to edit.

When displaying waveforms for audio tracks, or notes or regions for MIDI tracks, selections include underlying automation and controller data. If the track is displaying automation data, only the automation data is affected by the edits.

3. Drag with the Selector in the track to select the material you want to clear.
   
   – or –

   Use the Grabber to select one or more regions (or a group of MIDI notes).
4. Choose Edit > Clear to remove the selection.

If a portion of a region was cleared, new regions are auto-created from the material residing outside of the selection. If working in Shuffle mode, adjacent regions are slid over, as necessary, to fill the blank space.

**Cut and Copy Commands**

Use the Copy command to place a selection on the Clipboard so it can be pasted to another track, or to the same track at a different location.

Use the Cut command to place the selection on the Clipboard while also removing it from the track.

**To cut or copy a selection or region:**

1. If desired, set the Edit mode to Grid to constrain the selection to the current Grid value.
2. Set the Display Format for the tracks you want to edit.

When displaying waveforms for audio tracks, or notes or regions for MIDI tracks, selections include underlying automation and controller data. If the track is displaying automation data, only the automation data is affected by the edits.

3. Drag with the Selector in the track to select the material you want to cut or copy.
   
   – or –

   Use the Grabber to select one or more regions (or a group of MIDI notes).
Choose Edit > Cut to remove the selection and place it on the Clipboard.

- or -

Choose Edit > Copy to place the selection on the Clipboard, without removing it.

If a portion of a region was cut or copied, the material on the Clipboard appears as a new region in the Regions List. If a portion of a region was cut, new regions are auto-created from the material residing outside of the selection.

When working in Shuffle mode, adjacent regions are slid over, as necessary, to fill blank spaces.

Deleting Underlying Region Data

In Slip mode, Regions can be placed so that they overlap or completely cover other regions. When removing a region or selection, you can also remove the underlying region data.

To delete a region or selection along with the underlying region data:

- Choose Edit > Cut.

To delete a region or selection without removing the underlying region data:

- Choose Edit > Clear.

Paste Command

Use the Paste command to place the Clipboard’s contents at the Edit insertion point, overwriting existing material already there.

To paste a selection or region:

1. If desired, set the Edit mode to Grid to constrain the insertion point or selection to the current Grid value.

2. With the Selector, click in a track at the point where you want to paste the material. Press Tab to move the insertion point forward to region start and end times; to move back, press Option+Tab (Macintosh) or Control+Tab (Windows).

- or -

Use the Selector or Grabber to make a selection where the material will be placed.

3. Choose Copy > Paste.

If pasting at an insertion point in Shuffle mode, material to the right of the paste point is shifted to the right. In Slip mode, the material is overwritten with the paste.

If pasting into a selection in Shuffle mode, the selection is replaced by the Clipboard’s contents with the adjacent material slid left or right as necessary. In Slip mode, the selection is also replaced but with the surrounding material remaining unchanged.

When working with MIDI, you can merge the contents of the Clipboard with material in the destination track. For details, see “Merge Paste Command” on page 234.

For TDM systems, the Fill Paste command can be used to fill a selection with the contents of the Clipboard. For details, see “Repeat Paste To Fill Selection” on page 241.
Copying and Pasting Automation

The following are two special functions for copying and pasting automation data.

- To copy all automation playlists for a track, press Control (Macintosh) or the Start key (Windows) when copying from any of the track’s automation playlists. This special function also works across multiple tracks.

- To paste from one type of automation playlist to another similar playlist (for instance, from a volume playlist to a send level playlist), press Control (Macintosh) or the Start key (Windows) when pasting.

For more information on working with automation data, see Chapter 28, “Automation.”

Editing Across Multiple Tracks

When working with data from multiple tracks, there are some important points to remember.

If all selected tracks are displayed as automation data, edits only affect the type of automation data displayed in each track. Furthermore, if track 1 displays Pan automation, track 2 displays Volume automation, and track 3 displays Mute automation, the Cut command cuts only pan data from track 1, volume data from track 2, and mute data from track 3.

For details on selecting data on multiple tracks, see “Selecting Across Multiple Tracks” on page 205.

When copying only automation or controller data for selected tracks, press Control (Macintosh) or the Start key (Windows) to copy all types of automation on all selected tracks.

To paste to multiple tracks, place the insertion point in each of the destination tracks by Shift-clicking in them—or to select all tracks, Option-Shift-click (Macintosh) or Alt-Shift-click (Windows) in a track, or make a selection in one of the Timebase Rulers.

When you paste multiple types of data, whatever data has been copied is pasted into the correct type of playlist. Automation data is pasted into the appropriate automation playlist (pan, volume, mute and so on). Audio/MIDI data is pasted into the audio/MIDI playlist. You don’t need to set target tracks to the specific type of data being pasted for the paste to work correctly.

If all destination tracks in a multitrack paste are displayed as automation, the paste replaces any previous data on the target track without shuffling—regardless of whether you are in Slip or Shuffle mode.
**Duplicate Command**

The Duplicate command copies a selection and places it immediately after the end of the selection. Though this is similar to using Copy and Paste, Duplicate is more convenient and faster, particularly when working with data on multiple tracks.

To make more than one copy of a selection, use the Repeat command (see “Repeat Command” on page 233).

As with the Copy and Paste commands, certain rules apply when duplicating material on multiple tracks. For details, see “Editing Across Multiple Tracks” on page 232.

⚠️ The Duplicate command does not operate on conductor events.

**To duplicate a selection or region:**

1. If working with material that is bar- and beat-based, such as loops, set the Main Time Scale to Bars:Beats.

2. If desired, set the Edit mode to Grid to constrain the selection to the current Grid value.

3. Drag with the Selector in the track to select the material you want to duplicate.

   – or –

   Click in the track and enter the start and end points for the selection in the Event Edit area.

4. Choose Edit > Duplicate. The material is placed immediately after the selection’s end point.

In Shuffle mode, the duplicated data is placed directly after the end of the selection. Regions occurring after it are slid to accommodate the duplicated material. In Slip mode, the duplicated material overlaps any adjacent data.

When using Duplicate or Repeat with MIDI notes that were selected with the Grabber, material is always duplicated one measure later, and is merged with existing track material (instead of replacing).

**Duplicating Audio**

When using Duplicate or Repeat for audio that must fall cleanly on the beat (for loops), it is important that you select the audio material with the Selector, or by typing in the start and end points in the Event Edit area. If you select an audio region with the Grabber (or by double-clicking it with the Selector), the material may drift by several ticks because of sample-rounding.

If, on the other hand, you want to Duplicate or Repeat audio that is not bar- and beat-based, set the Time Scale to any format except Bars:Beats. This ensures that the duplicated audio material will have the correct number of samples and will be placed accordingly.

**Repeat Command**

The Repeat command is similar to Duplicate, but allows you to specify the number of times the selected material is duplicated.

As with the Copy and Paste commands, certain rules apply when repeating material on multiple tracks. For details, see “Editing Across Multiple Tracks” on page 232.

To repeatedly paste copied data until it completely fills a selection (TDM systems only), see “Repeat Paste To Fill Selection” on page 241.

⚠️ The Repeat command does not operate on conductor events.
To repeat a selection or region:

1. If working with material that is bar- and beat-based, such as loops, set the Main Time Scale to Bars:Beats.
2. If desired, set the Edit mode to Grid to constrain the selection to the current Grid value.
3. Drag with the Selector in the track to select the material you want to repeat.
   - or -
   Click in the track and enter the start and end points for the selection in the Event Edit area.
4. Choose Edit > Repeat. In the Repeat dialog, enter the number of times you want the material to repeat, then click OK.

The material is placed immediately after the selection’s end point, and duplicated by the number of times specified.

In Shuffle mode, the repeated data is placed directly after the end of the selection. Regions occurring after it are slid to accommodate the repeated material. In Slip mode, the repeated material overlaps any adjacent data.

To merge MIDI data:

1. If desired, set the Edit mode to Grid to constrain the selection to the current Grid value.
2. Drag with the Selector in the track to select the MIDI notes you want to merge.
   - or -
   Use the Grabber to select one or more MIDI regions (or a group of MIDI notes).
3. Choose Edit > Cut to remove the selection and place it on the Clipboard.
   - or -
   Choose Edit > Copy to place the selection on the Clipboard without removing it.
4. With the Selector, click in a MIDI track at the point where you want to merge the material.
5. Choose Edit > Merge Paste. The Clipboard’s contents are pasted at the insertion point, without removing the existing material already residing there.

If any portion of the material is pasted outside of existing regions, a new region is created for the data.

Editing Stereo and Multichannel Tracks

Regions on individual channels within stereo and multichannel tracks cannot be independently selected. All selections for these tracks are time-based, which means that selections made with the Selector and Grabber extend to each channel in the track.

When regions in multichannel tracks are edited with the Trimmer or dragged with the Grabber, material on all channels is affected equally as a group.

Merge Paste Command

(MIDI Only)

Use the Merge Paste command to merge MIDI notes from the Clipboard with material already residing in the paste destination. To replace track material, use the Paste command instead.
Split Selected Tracks

To edit a specific channel within a stereo or multichannel track without affecting the other channels, you can split the track into separate mono tracks. Once the desired edits have been made to the separated material, you can then drag or copy it back to the original multichannel track.

**To split a stereo or multichannel track:**

1. Select the track you want to split by clicking its name in the Edit or Mix window. To split multiple tracks, Shift-click additional tracks.

2. Choose File > Split Selected Tracks Into Mono. Regions from the channels on the selected tracks are placed on new, mono audio tracks.

Names for the new tracks are based on the source track name and channel suffix. For example, if a stereo track called “Funkit” is split, two new tracks called “Funkit.L” and “Funkit.R” are created.

Output and send assignments and volume and pan settings are retained in the new tracks. Mono equivalents of stereo and multi-mono plug-in assignments are assigned in the new tracks; multichannel plug-in assignments are not assigned in the new tracks.

Dragging Regions to and from Stereo and Multichannel Tracks

When dragging regions to or from stereo or multichannel tracks, the following rules apply:

- Provided the number of tracks and channels are the same for the source and destination, you can drag regions between multichannel tracks and mono tracks.

- The source and destination for dragged regions can be mixed. For example, you can drag regions from a 5.0 track (containing five channels) to a stereo track and three mono audio tracks.

- When dragging multichannel regions to mono tracks, the destination tracks must be adjacent.

- When dragging regions from mono tracks to a multichannel track, the source tracks need not be adjacent.

Multichannel regions can also be dragged from the Audio Regions List, to multichannel tracks of the same format, groups of mono audio tracks, or a combination of both.

Conversely, a collection of single, mono regions can be dragged from the Audio Regions List to multichannel tracks—provided the dragged number of regions matches the number of channels in the destination track.

*Dragging a stereo region to two mono audio tracks*
**Processing Audio with AudioSuite Plug-Ins**

The AudioSuite plug-ins included with your Pro Tools system can be used to process and modify an audio region or entire audio file. You may do this in order to apply a specific AudioSuite process, such as Normalization or DC Offset Removal, that you know you will always want applied to the audio.

Refer to the Digi Rack Plug-Ins Guide for more information about AudioSuite plug-ins.

**Waveform Repair with the Pencil Tool**

The Pencil tool allows you to destructively “re-draw” waveform data. This tool is most commonly used to repair a pop or click in an audio file. A pop or click appears as a sudden sharp spike in a waveform. This tool only becomes active when the Edit window is zoomed in to the sample level.

The Pencil tool is a destructive editing tool that permanently modifies the audio file on disk and should be used with caution.

Although you can Undo a Pencil tool edit, it is recommended that you create a backup copy of the target audio, before using the Pencil tool. You can do this by using the AudioSuite Duplicate plug-in.

**To make a backup copy of an audio region:**

1. Select the source region in the track's playlist.
2. Choose AudioSuite > Duplicate.
3. In the AudioSuite dialog, make sure that “Playlist” is the processing preference, and that Use In Playlist is selected.
4. Click the Process button.

The AudioSuite Duplicate plug-in creates a new audio file that is a duplicate of the original. The duplicate replaces the original on the track, and it is automatically named with the region name and the suffix “DUPL.”

**To destructively edit an audio waveform with the Pencil tool:**

1. Locate the area you want to edit. Adjust the Track Height, as necessary, to edit the waveform with greater precision.
2. Using the Zoomer tool or the Vertical Zoom buttons, zoom down to the sample level so the waveform appears as a continuous thin line.
   
   You can recall zoom levels with the Zoom Preset buttons (see “Zooming” on page 186), or with Memory Locations (see “Memory Locations and Markers” on page 274).
3. Select the Pencil tool.
4. Carefully draw with the Pencil by dragging over the desired area of the waveform.

Don’t over-edit or the results may be undesirable. You can use the Undo command to undo your previous edit.
Try to limit editing to smoothing over a very small problem area, and keep the “fixes” in character with the shape of the surrounding wave.

**The Smart Tool**

The Smart Tool lets you use the Selector, Grabber, and Trimmer, as well as create fades, without switching tools. Depending on where the cursor is placed in relation to a region or note, the Smart Tool automatically switches to the appropriate tool. For details, see “Using the Smart Tool” on page 237.

To temporarily switch the Smart Tool to the Scrubber, press Control (Macintosh) or the Start key (Windows).

To select the Smart Tool, click its icon in the upper left of the Edit window, or press F6+F7 (or F7+F8).

**Using the Smart Tool**

With the Smart Tool you can instantly access the Selector, Grabber, and Trimmer, and you can also perform fades and crossfades. The position of the cursor in relation to a region or note, or within an automation playlist, determines how the Smart Tool functions.

**Smart Tool in Waveform View (or MIDI Track Regions View)**

The following capabilities are available with the Smart Tool when working with audio tracks in Waveform or Blocks View, or MIDI tracks in Regions View:

- For the Selector, position the cursor over the middle of the region, in the upper half.
- For the Grabber, position the cursor over the middle of a region, in the lower half.
- For the Trimmer, position the cursor near the region’s start or end point.
- For a fade-in or fade-out, position the cursor near an audio region’s start or end point, near the top. Once the Fade cursor appears, drag into the region to set the fade length. The fade is created automatically with the Default Fade Settings (in the Editing Preferences).
- For a crossfade, position the cursor between two adjacent audio regions, near the bottom. Once the Crossfade cursor appears drag left or right to set the crossfade length. The crossfade is created automatically with the Default Fade Settings (in the Editing Preferences).

To temporarily switch the Smart Tool to the Scrubber, press Control (Macintosh) or the Start key (Windows).
The Smart Tool in Notes View

The following capabilities are available with the Smart Tool when working with MIDI tracks in Notes View:

- For the Selector, position the cursor so it doesn’t cover any notes.

To get the Selector while positioning the cursor over notes, press Command (Macintosh) or Control (Windows).

- For the Grabber, position the cursor over the note, near its middle.

To get the Marquee so you can select a group of notes, position the cursor so it doesn’t cover any notes and press Command (Macintosh) or Control (Windows).

- For the Trimmer, position the cursor near the note’s start or end point.

To temporarily switch the Smart Tool to the Pencil, press Control (Macintosh) or the Start key (Windows); for the Eraser, press Control+Option (Macintosh) or Start+Alt (Windows).

The Smart Tool in Automation and Controller Views

The following capabilities are available with the Smart Tool when working in automation and controller Views:

- For the Selector, move the cursor so it is positioned anywhere in the bottom 75% of the playlist.

- For the Grabber, press Command (Macintosh) or Control (Windows) to insert breakpoints. Continue pressing Command (Macintosh) or Control (Windows) after you begin editing for fine control; otherwise, release for coarse control.

Press Command+Shift (Macintosh) or Control+Shift (Windows) to vertically constrain movement.

- To edit existing breakpoints, move the cursor near a breakpoint and the Grabber will appear.

Press Shift to vertically constrain movement.

- For the Trimmer, position the cursor in the top 25% of the playlist to trim breakpoints. Press Command (Macintosh) or Control (Windows) after you begin trimming for fine control.

The Smart Tool with Stereo and Multichannel Tracks

When using the Smart Tool on stereo and multichannel tracks, individual channels cannot be independently edited. All edits affect all channels as a whole.

The tool switching for the Smart Tool in stereo and multichannel tracks is determined by the position within the entire track, and not within individual channels.
Chapter 18: Advanced Editing

Replacing Regions
(TDM Systems Only)

You can use the Replace Region function to replace multiple instances of a region in a playlist with another region that you Command-drag (Macintosh) or Control-drag (Windows) from the Regions List.

This is useful in post production if you use a sound effect, room noise, or atmosphere region many times in a session, and later decide to replace one or all of the original regions with a different region.

This is also useful in music production if you want to replace a certain loop or sample (for example, a drum beat) with a new one. You can use this compositionally, if you know the tempo of a section or session, to create a scratch piece with “rough” regions of the correct length, and later replace them with “final” regions of the same length.

The following options are available in the Replace Region dialog:

- **Replace Original Region** Replaces only the selected region with the replacement region dragged from the Regions List.
- **Replace All Regions That Match Original** Replaces all regions that fit the Match criteria and the Find Match On criteria with the replacement region from the Regions List.
**Match: Start Position** Replaces all regions that have the same original start time as the selected region. This includes regions that may have been auto-created when trimming end points.

**Match: End Position** Replaces all regions that have the same original end time as the selected region. This includes regions that may have been auto-created when trimming start points.

**Match: Region Name** Replaces all regions that have the same name as the selected region.

Region matching uses all specified Match criteria. For example, if you select Start Position and End Position, all regions from the same original audio file as your selection with the same original start and end times will be replaced.

**Find Match On: This Track Only** Replaces regions that fit the Match criteria and are on the same track as the original region.

**Find Match On: All Tracks** Replaces regions that fit the Match criteria for all tracks in the session.

**Fit To: Original Region Length** If the replacement region is smaller than the original region, the region is placed in the playlist and any remaining audio from the original region is removed.

If the replacement region is larger than the selection, it is placed in the playlist and trimmed to fit within the length of the original region.

**Fit To: Original Selection Length** When the playlist selection extends beyond the original region, the replacement region (if larger than the original region) is trimmed to fit within the selection.

**Fit To: Replacement Region Length** The replacement region is placed in its entirety, regardless of the length of the original region or selection.

The Replace Region function only works on a selection that includes a single region on one track. The function is not available when the playlist selection includes the start points for two or more regions. Also, if the selection is across several tracks, only the selection in the first (top) track is used.

**To replace regions:**

1. Select a region in a track’s playlist that you want to replace. If desired, the selection can extend beyond the region’s end point, to include material from the replacement region that is longer than the original region.

2. Command-drag (Macintosh) or Control-drag (Windows) the replacement region from the Regions List to the selected region. The Replace Region dialog opens.

3. If you want to replace only the original region, select Replace Original Region.

   - or -

If you want to replace multiple regions, select Replace All Regions That Match Original, and set the Match criteria.

4. Select whether to apply the replacement to all tracks, or only to the track with the current selection.

5. Select whether to fit the replacement regions to the current selection, the entire region, or the entire replacement region regardless of the destination length.

6. When you have set all the options, click OK.
Replace Region and Multichannel Tracks

The Replace Region command supports dragging multichannel regions from the Audio Regions List to multichannel tracks, provided they are the same format.

For example, you can replace a stereo region, selected in a stereo audio track, with another stereo region from the Audio Regions List. But you cannot replace it with two mono audio regions.

In addition, replacing regions in multiple mono tracks with multichannel regions is not supported.

Repeat Paste To Fill Selection

(TDM Systems Only)

The Repeat Paste To Fill Selection command allows you to automatically fill a selection with audio or MIDI data without requiring you to duplicate the regions manually. To use Repeat Paste, copy an audio or MIDI region, then make a selection and use the command to fill the selection. When pasting audio regions, you are prompted to specify a crossfade to be used for the pasted regions.

If you fill an area that is an exact multiple of the copied region size (for example, filling 16 bars with a 4-bar loop), the copied selection is pasted in exactly as many times as it takes to fill the selection. If you fill an area that is not an exact multiple of the copied region size (for example, filling 15 seconds of a track with a 2-second atmosphere or room noise region), the remaining selection area is filled with an automatically trimmed version of the original selection.

To fill a selection with Paste to Fill:

1. Select the audio or MIDI region you want to copy and choose Edit > Copy.
2. Select the area you want to fill using the Selector and choose Edit > Repeat Paste To Fill Selection.
3. If pasting audio regions to larger areas, the Batch Fades dialog opens. Configure the dialog as desired to insert crossfades between each pasted region, then click OK.

   – or –

   If you do not want crossfades for the pasted audio, click Cancel in the Batch Fades dialog.

Compress/Expand Edit To Play

(TDM Systems Only)

When the Edit and Timeline selections are unlinked, you can compress or expand an audio selection to fit the Timeline selection. This feature works by using the Time Compression/Expansion plug-in to expand or compress the selected audio material.

To fit an Edit selection to the Timeline:

1. Deselect Operations > Link Edit and Timeline Selection.
2. With the Selector, select the audio material to be compressed or expanded.
3. In any Timebase Ruler, select the time range where you want to fit the audio material.
4. Choose Edit > Compress/Expand Edit To Play. The Edit selection is compressed or expanded to the length of the Timeline selection.
Compress/Expand Edit to Play on Multiple Tracks and Channels

The Compress/Expand Edit Play command can be used on multichannel selections, and selections across multiple tracks.

However, all regions are compressed or expanded equally by the same percentage value, based on Edit selection range. This ensures that the rhythmic relationship between the different channels or tracks is retained.

Fitting an Audio Region to an Edit Selection

Regions can be dragged from the Audio Regions List to fit within an Edit selection. The dragged region is compressed or expanded to fit within the selection. This feature uses the Time Compression/Expansion plug-in to expand or compress the audio region.

To fit an audio region to an Edit selection:

1. With the Selector, select the desired time range in an audio track.
2. Command-Option-drag (Macintosh) or Control-Alt-drag (Windows) the region from the Audio Regions List to the track with the selection. The start of the region is positioned at the selection start, and the region is compressed or expanded to match the length of the selection.

Fit to Selection on Multiple Tracks and Channels

The Fit to Selection command supports dragging multiple regions from the Audio Regions List to multiple tracks, or multichannel tracks.

However, all dragged regions are compressed or expanded equally by the same percentage value, based on length of the region last clicked before dragging.

The Time Trimmer

(TDM Systems Only)

The Time Trimmer is a convenient tool for matching an audio region to the length of another region, a tempo grid, a video scene, or to practically any other reference point you want.

The Time Trimmer works by using the Time Compression/Expansion AudioSuite plug-in to create a new audio file. You use the Time Trimmer by dragging the region’s start or end point to expand or compress the region.

Time Compression/Expansion Plug-In Preferences

You can select settings for the Time Compression/Expansion AudioSuite plug-in by choosing from the Default Settings pop-up list in the Processing Preferences, under “TC/E.” The settings available are presets included with Pro Tools; in addition, if you save your own presets for the Time Compression/Expansion plug-in, they will also appear here.

Refer to the DigiRack Plug-Ins Guide for more information about AudioSuite plug-ins.
Using the Time Trimmer in Grid Mode

The Time Trimmer can be used in Grid mode to match a region to the tempo of a session or a section of a session. For example, you might import a one-bar drum loop with a tempo of 90 BPM into a session with a tempo of 120 BPM. In Grid mode, you can use the Time Trimmer to simply and quickly “compress” the drum loop to the length of one measure, with minimal loss of audio fidelity.

To use the Time Trimmer in Grid mode:
1 Set the Edit mode to Grid.
2 Select “TCE Trimmer” from the Trimmer pop-up menu.
3 With the Time Trimmer, drag the region’s start or end point to compress or expand the region to the Grid (for example, by quarter notes). The region is automatically processed using the Time Compression/Expansion AudioSuite plug-in. The new region appears in the playlist and in the Regions List.

Using the Time Trimmer in Slip Mode

To use the Time Trimmer in Slip mode:
1 Set the Edit mode to Slip.
2 Select “TCE Trimmer” from the Trimmer pop-up menu.
3 With the Time Trimmer, drag the region’s start or end point to compress or expand the region freely. A new region is automatically processed using the Time Compression/Expansion AudioSuite plug-in. The new region appears in the playlist and in the Regions List.

Using the Time Trimmer in Spot Mode

In Spot mode, clicking with the Time trimmer in a region opens the Spot Dialog. You can specify the location you want the region to start or end at, or the duration of the region, and the region is automatically compressed or expanded as specified.

To use the Time Trimmer in Spot mode:
1 Set the Edit mode to Spot.
2 Select “TCE Trimmer” from the Trimmer pop-up menu.
3 Click the region near its start or end point. The Spot Dialog opens. Using any Time Scale, enter a new start or end time (or duration) for the region, then click OK. A new region is automatically processed using the Time Compression/Expansion AudioSuite plug-in. The new region appears in the playlist and in the Regions List.
Chapter 19: Fades and Crossfades

Using Crossfades

You can quickly and easily crossfade between two adjacent audio regions. Crossfading is the process of fading two regions of audio to prevent pops, clicks, or sudden changes in sound. Crossfades have many applications, from smoothing transitions between regions to creating special audio effects. The crossfade duration, position, and shape are all user-definable.

Crossfades are computed and written to disk. Crossfades that are written to disk are stored in a folder named “Fade Files” within the session folder. When you play back your track, Pro Tools reads and plays back the crossfade file from disk.

Pro Tools does not allow you to replace fade-ins and fade-outs with crossfades. To add a crossfade between regions, any existing fade-ins and fade-outs between the regions must first be deleted.

Pro Tools TDM systems include an Auto Fade feature that provides real-time fades without processing them to disk. See “Using AutoFades” on page 254.

About Crossfades and Curves

To create a crossfade between two regions, use the Selector to select across the end point of the first region and the start point of the second. The length of the selection determines the length of the crossfade. Though fades may appear to be discrete regions, they cannot actually be separated from the regions in which they were created. You can, however, create fade-ins and fade-outs for individual regions (see “Creating Fades at the Beginnings and Ends of Regions” on page 253).

You can use the Fades dialog to select, view, and manipulate the curves used to perform the crossfade. Different volume curves can be assigned to the fade-out and fade-in portions of crossfades. The Fades dialog can also render a preview of the fade.

The following examples illustrate common crossfade types, and explain how the type of selection you make determines the character of the crossfade.

Since crossfades are created by fading between overlapping audio material, a crossfade cannot be performed on regions that do not contain audio material beyond their region boundaries.
Standard Crossfade (“Centered”)

This type of selection creates a crossfade on both sides of the splice point, which affects the volume of region 1 and region 2. It is the most common type of crossfade.

This crossfade type requires that region 1 contain audio material beyond its end point, and region 2 contain audio material before its start point.

Pre Crossfade

This type of selection creates a crossfade before the splice point. This lets you maintain the volume of the very beginning of region 2 instead of fading across it, which is useful if there is a strong attack at the beginning of region 2 that you want to preserve. When making selections for crossfades that occur on the border of two regions, you can use the Tab key to move the cursor to the exact beginning or end of a region.

This crossfade type requires that region 2 contain audio material before its start point.

Post Crossfade

This type of selection creates a crossfade after the splice point. It is useful if you want to maintain the amplitude of region 1 until its very end. When making selections for crossfades that occur on the border of two regions, you can use the Tab key to move the cursor to the exact beginning or end of a region.

This crossfade type requires that region 1 contain audio material beyond its end point.

The Fades Dialog

When choosing the Edit > Fades command you can use the Fades dialog to select, view, and preview the crossfade, and to edit the curves used to perform the crossfade.
The controls in the Fades dialog include:

**Audition**

Click this button to audition your crossfade. Pro Tools plays the audio in one of two ways, depending on your system:

- Pro Tools TDM and LE systems allow crossfade auditioning directly from your audio interface outputs.
- Older Pro Tools systems such as Pro Tools III on Macintosh use Apple’s Sound Manager to audition crossfades. Use the Digidesign Sound Drivers (automatically installed with Pro Tools) to audition via your audio interface outputs. Use the Macintosh Sound Control Panel to set the Output choice to Digidesign Sound Drivers. (If you do not use the Sound Drivers, you will hear crossfades through the Macintosh’s audio output.)

**View First Track**

If you are fading between more than one track, this button allows you to view and preview the audio of the first pair of adjacent tracks.

**View Second Track**

If you are fading between more than one track, this button allows you to view and preview the audio of the second pair of adjacent tracks.

**View Both Tracks**

Click this button to display the waveforms of the first two adjacent tracks in a multitrack fade.

**Fade Curves Only**

Click this button to display the specified fade curves without showing the actual audio waveforms. This is the default view when you open the Fades dialog.

**Fade Curves and Separate Waveforms**

Click this button to display the specified fade curves along with separate views of the fade-in and fade-out waveforms.

**Fade Curves and Superimposed Waveforms**

Click this button to display the specified fade curves along with superimposed views of the fade-in and fade-out waveforms.

**Fade Curves and Summed Waveform**

Click this button to display the specified fade curves along with a single waveform representing the summation of the crossfaded audio.

**Zoom In**

Click this button to scale the view of the waveform’s amplitude upwards. Command-click (Macintosh) or Control-click (Windows) for the default view scale.
**Zoom Out**

Click this button to scale the view of the waveform’s amplitude downwards. Command-click (Macintosh) or Control-click (Windows) for the default view scale.

**Fade Out Shape Parameter**

The Out Shape parameter allows you to choose the shape of the fade-out from region 1.

**Standard** Selects a single continuous fade curve. This creates a general-purpose fade that can be edited by dragging the curve itself.

**S-Curve** Selects an S-shaped curve, which inverts its beginning and end characteristics. This makes it possible to fade out faster at the curve’s start and slower at its end, for example. S-shaped curves can be useful with material that is difficult to crossfade effectively. S-curves can be edited by dragging the curve in the curve editor.

**Preset Curves** Seven commonly used preset curves are provided for fast crossfade creation. These can be edited by dragging the end points of the curve in the curve editor portion of this dialog. The seven presets are as follows:

- **Preset Curve 1** keeps region 1 at full volume throughout the crossfade, then immediately drops the volume at the end of the crossfade.

- **Preset Curve 2** fades out region 1 relatively slowly, keeping the volume fairly high throughout the duration of the fade.

- **Preset Curve 3** fades out region 1 slightly faster, keeping the volume slightly lower during the fade.

- **Preset Curve 4** fades out region 1 with a linear fade. This is the default curve.

- **Preset Curve 5** fades out region 1 quickly at the beginning of the crossfade.

- **Preset Curve 6** drops the volume of region 1 even more quickly at the beginning of the crossfade.
Preset Curve 7 silences region 1 at the beginning of the crossfade.

**Link Parameters**

The Link parameter links the selected fade-out and fade-in curves. If you adjust one curve, the corresponding curve also adjusts. This ensures that the resulting crossfade is an *equal power* or *equal gain* crossfade, depending on which you select.

- **Equal Power** Recommended for material that is not phase coherent, as in the case of a crossfade between two completely different types of material. Use this option to avoid the volume drop that can occur with an Equal Gain crossfade. With this fade, you can Option-click (Macintosh) or Alt-click (Windows) the fade curve to reset it to its default shape.

- **Equal Gain** Recommended for material that is phase-coherent or nearly phase-coherent, as in the case of a crossfade between identical regions/instruments (for example, a repeated drum loop). Use this option to avoid clipping that can occur when using an Equal Power crossfade. With this fade, you can Option-click (Macintosh) or Alt-click (Windows) the fade curve to reset it to its default shape.

- **None** Disables linking between the fade-out and fade-in curves, and lets you freely adjust them separately, including start and end points. This option also allows you to create custom crossfade shapes. To edit only the fade-in portion of the curve, press Option (Macintosh) or Alt (Windows) while dragging. To edit only the fade-out portion of the curve, press Command (Macintosh) or Control (Windows) while dragging.

Use Dither

The Use Dither option turns on a preset, noise-shaped dither function that improves audio performance when mixing or fading low-level audio signals. Use this option for fading in or fading out silence, and crossfading between low amplitude regions. Dithering is usually not necessary when fading between two regions of high amplitude. You can disable Dither while editing your crossfades in the Fades dialog to speed up previews and fade recalculation, then re-enable Dither to create the final crossfade.
Fade In Shape Parameters

The In Shape parameter allows you to choose the shape of the fade-in to region 2.

**Standard** Selects a single continuous fade curve. This creates a general-purpose fade that can be edited by dragging the curve itself.

**S-Curve** Selects an S-shaped curve, which inverts its beginning and end characteristics. This makes it possible to fade in faster at the start of the curve, and slower at the end. S-shaped curves are useful with material that is difficult to crossfade effectively. S-curves can be edited by dragging the curve in the curve editor.

**Preset Curves** Seven commonly used preset curves are provided for fast crossfade creation. These can be edited by dragging the end points of the curve in the curve editor portion of this dialog. The seven presets are as follows:

- **Preset Curve 1** fades in region 2 at full volume immediately at the beginning of the crossfade and keeps it there throughout the crossfade.

- **Preset Curve 2** fades in region 2 quickly in the beginning, reaching full amplitude fairly early in the crossfade.

- **Preset Curve 3** fades in region 2 moderately fast.

- **Preset Curve 4** fades in region 2 with a linear fade curve. This is the default curve.

- **Preset Curve 5** fades in region 2 slowly at the beginning of the crossfade.

- **Preset Curve 6** fades in region 2 even more slowly than the previous curve.

- **Preset Curve 7** silences region 2 until the end of the crossfade.
Typical Curve Combinations

Following are the available combinations of fade-out and fade-in curves.

**Linear Crossfade**  This is a good general purpose crossfade with a smooth, even transition between region 1 and region 2.

**Equal Power Crossfade**  This is a good general purpose crossfade useful in cases where a linear crossfade seems to create a noticeable drop in volume across the splice point.

**Overlap Fade**  This combination of curves keeps both regions at full amplitude throughout the crossfade: region 2 “jumps in” at the beginning and region 1 “jumps out” at the end.

---

Fade and Crossfade Preferences

**(TDM Systems Only)**

You can set default fade and crossfade settings. These settings load as your “base” settings when you use the Create Fades command, and the Fade to Start and Fade to End commands.

To set the crossfade preferences:

1. Choose Setups > Preferences and click Editing.
2. Set the Pre-Roll and Post-Roll times for Fade previews.
3. Click Fade In and set the default shape for fade-ins, then click OK.
4. Click Fade Out and set the default shape for fade-outs, then click OK.
5. Click Crossfade and set the default shape for crossfades, then click OK.
6. Click Done.
Creating a Crossfade

**To create a crossfade between two regions:**

1. With the Selector, click at the point where you want the crossfade to begin in the first region and drag to where you want it to end in the second region. Crossfade selections can begin and end anywhere in their respective regions.

2. Choose Edit > Fades > Create Fades.

3. Use the view buttons to adjust the view of the crossfade. It may take a few moments to calculate the waveform display for long selections.

4. Select an Out Shape and an In Shape.

5. Choose a Linking option.

6. Click the Audition button, or play the session, to hear the crossfade. For long crossfades, it may take Pro Tools a few moments to calculate and load the audio into playback RAM.

7. Adjust the curves by choosing different preset shapes with the Out Shape and In Shape pop-up menus.

   – or –

   Drag the Fade In/Out curves to the desired shape. By choosing None as the Linking option, you can drag the beginning or end points of a fade curve to adjust its beginning or end point.

8. Click the Audition button, or play the session, to hear the crossfade again.

9. When the crossfade is right, click OK. The fade is calculated and written to disk, but the audio files and regions remain unchanged. Crossfades are stored in the Fades Folder within the session folder.

   ![Crossfade lengths can later be resized with the Trimmer.]

**To remove a crossfade:**

- Select the area of the track containing the crossfades you want to delete and choose Edit > Fades > Delete Fades.

  – or –

- Select the crossfade with the Grabber and press Delete (Macintosh) or Backspace (Windows).

**To trim a crossfade:**

1. Select the crossfade with the Grabber, or double-click it with the Selector.

2. With the Trimmer, trim either side of the crossfade. The crossfade is recalculated to reflect the newly trimmed length.

**Pre/Post Crossfade Selections**

By making a selection that begins or ends precisely on the border of two regions, you can create “pre” or “post” crossfades. Use the Tab key to place the insertion point at the exact beginning or end of a region.

**To create a pre- or post-crossfade:**

1. With the Selector, click in the track that contains the regions you want to crossfade.

2. Press Tab to move forward to the next region boundary.

   – or –

   Press Option+Tab (Macintosh) or Control+Tab (Windows) to move back to the previous region boundary.

3. Shift-drag to adjust your selection, or press Shift+Tab to extend the selection forward to the next region boundary.

   – or –
Press Option+Shift+Tab (Macintosh) or Control+Shift+Tab (Windows) to extend the selection back to the previous region boundary.

4 Choose Edit > Fades > Create Fades.

5 Choose a fade type and click OK.

**Creating Fades at the Beginnings and Ends of Regions**

In addition to crossfades between regions, Pro Tools lets you create fade-ins and fade-outs at the beginnings and ends of regions.

On Pro Tools TDM systems, you can also use an automatic fade-in/out option, which applies *real time* fade-ins/outs to all regions during playback. These fades are not written to disk, but automatically applied during playback. See See “Using AutoFades” on page 254.

![Region with a fade-in](image)

**Creating Fade-Ins and Fade-Outs**

Depending on how you make the selection, you can position a fade-in/out at the exact beginning or end of a region, or position it so it extends into a blank area of the track. The length of the selection in the region determines the length of the fade-in/out.

You can also fade to the beginning or end of a region from an insertion point.

**To create a fade-in:**

1. Select the beginning of the region that you want to fade in. The selection must extend to the exact beginning of the region or a blank area prior to the region in the track.

2. Choose Edit > Fades > Create Fades. Choose your fade-in curve and other parameters.

3. Click the Audition button to hear the fade (or press the Spacebar to start and stop playback).

4. You can adjust the curve by dragging it or by choosing a different shape with the In Shape pop-up menu.

5. When you are finished, click OK. Pro Tools calculates the fade and writes it to disk. The chosen fade curve appears in the region.

**Selecting the beginning of a region for a fade-in**

**To create a fade-out:**

1. Select the end of the region that you want to fade out. The selection must extend to the exact end of the region or a blank area after the region in the track.

2. Choose Edit > Fades > Create Fades. Choose your fade-out curve and other parameters.

3. Click the Audition button to hear the fade (or press the Spacebar to start and stop playback).

4. You can adjust the curve by dragging it or by choosing a different shape with the In Shape pop-up menu.

5. When you are finished, click OK. Pro Tools calculates the fade and writes it to disk. The chosen fade curve appears in the region.

**Selecting the end of a region for a fade-out**
4 You can adjust the curve by dragging it or by choosing a different shape with the Out Shape pop-up menu.

5 When you are finished, click OK. Pro Tools calculates the fade and writes it to disk. The chosen fade curve appears in the region.

\[\text{Fade lengths can later be resized with the Trimmer.}\]

**To fade from the insertion point to a region start point:**

1. Place the cursor at the desired location in the region.
2. Choose Edit > Fades > Fade To Start.
3. The fade is applied based on the Fade In Preferences.

**To fade from the insertion point to a region end point:**

1. Place the cursor at the desired location in the region.
2. Choose Edit > Fades > Fade To End.
3. The fade is applied based on the Fade Out Preferences.

---

**Using AutoFades**

*(Pro Tools TDM Only)*

On Pro Tools TDM systems, you can choose to have Pro Tools automatically apply real-time fade-ins and fade-outs to all region boundaries in the session. These fade-ins and fade-outs are performed during playback and do not appear in the Edit window, and are not written to disk.

This automatic fade-in/out option also has an effect on virtual track switching in a session. Whenever a lower-priority virtual track “pops thru” a silence in a higher-priority track on the same voice, a fade-in and fade-out is applied to the transition.

This feature is especially useful in post production situations such as dialogue tracking. For example, you could assign both a dialogue track and a “room tone” track with matching background to the same voice. You could then set the Auto-Fade option to a moderate length (4 ms or so) so that whenever a silence occurred in the dialog, playback would switch smoothly to and from the background track without clicks or pops.

Using automatic fade-ins/outs saves you the trouble of editing to zero-crossings or creating numerous rendered fades in order to eliminate clicks or pops in playback. However, since these autofades are not written to disk, those clicks or pops still exist in the underlying sound file. Consequently, those anomalies still appear if the Duplicate AudioSuite plug-in or the Export Selected as Sound Files command (from the Audio Regions List) are used to duplicate multiple regions as a continuous file. To render these real-time auto fades to disk, choose File > Bounce to Disk.
To set the length of automatic fade-ins/outs:

1. Choose Setups > Preferences and click Operation.
2. Enter a value between 0 and 10 ms for the Auto Region Fade In/Out Length. A value of zero (the default) means that no auto-fading will occur.
3. Click Done. The Auto Fade value is saved with the session, and is automatically applied to all free-standing region boundaries until you change it.

Creating Fades and Crossfades in Batches

In “Batch Mode” you can create many fades at once. You select across several regions and use the Create Fades command to create crossfades for each region transition. If your selection includes regions that already have crossfades, this feature allows you to modify them.

To create crossfades between multiple regions at once:

1. With the Selector, click in the first region in which you want to create a crossfade.
2. Drag to extend the selection to the last region you want to crossfade. Make sure that the selection includes the entire region.
3. Choose Edit > Fades > Create Fades.
4. Select whether you want to Create New Fades, Create New Fade-Ins & Outs, Adjust Existing Fades, or a combination of these options.

If you select to create new fades and new fade-ins and outs, new crossfades are created at each region boundary that is bordered by another selected region, a fade-in is created at the start of the first region, and a fade-out is created at the end of the last region.

Selected regions for Batch Fades

5. Choose the placement of your Fades. You can choose Pre-Splice, Centered, or Post-Splice.
6. Enter a crossfade length in milliseconds.
7. Click OK. Pro Tools creates the fades for the selected regions.

Fades lengths can later be resized with the Trimmer.
Chapter 20: Managing Regions

**Stripping Silence from Regions**

The Strip Silence command analyzes audio selections—across multiple regions or multiple tracks—and removes any areas of silence, dividing the selection into smaller regions and removing the silent areas.

You can use Strip Silence to automatically divide a track into regions, which is useful if you want to quantize audio to musical values, or locate sound effects to SMPTE locations. It is also useful if you want to get rid of silent areas to prepare for compacting audio (see “Compacting an Audio File” on page 263).

**The Strip Silence Window**

The Strip Silence window contains the following four sliders that allow you to set the parameters by which silence will be defined for this operation. Adjusting these sliders will cause rectangles to appear in the selection (see Figure 14 on page 258), indicating areas of silence that will be removed.

- **StripThreshold** Sets the amplitude threshold (from –48 dB to 0) for Strip Silence. Audio falling below this threshold is considered silence and removed. Audio above the threshold is retained and defined as new regions.

- **Minimum Strip Duration** Sets the minimum duration (from 0 to 10,000 ms) that the material below the threshold must last to be considered silence.

  Use this parameter to avoid countless small regions that may occur within a selection.

- **Region Start Pad** Specifies a time value to be added to the beginning of each new region created with Strip Silence.

  This is useful for preserving musical material that falls below the threshold, such as the breath before a vocal phrase, or the finger slide before a guitar chord.

- **Region End Pad** Specifies a time value to be appended to the end of each new region created with Strip Silence, thereby preserving the nuances in the decay of the material.
Auto-Naming for Strip Silence

The Rename button in the Strip Silence window opens the following dialog, which determines how regions are named with the Strip Silence command.

![Strip Silence Renaming dialog](image)

**Name** Specifies the base name for regions created with Strip Silence.

**Number** Specifies the number at which sequential auto-numbering starts.

**Zeros** Specifies the number of zeroes that occur before the appended auto numbers.

**Suffix** Specifies text appended to the end of the name, after the auto numbering.

For example, if you set the naming parameters to:

- Name = SFX
- Auto Number Start = 23
- Leading Zeros = 1
- Suffix = .Reel1

The names generated for regions created by Strip Silence would be:

- SFX023.Reel1
- SFX024.Reel1
- SFX025.Reel1
- SFX026.Reel1
- SFX027.Reel1
- SFX028.Reel1

Using Strip Silence

**To strip silence from an audio selection:**

1. Select one or more audio regions.
2. To select across multiple tracks, Shift-click in additional tracks.
4. To set the naming scheme for regions created with Strip Silence, click Rename to open the Renaming dialog. For details, see “Auto-Naming for Strip Silence” on page 258.
5. In the Strip Silence window, adjust the sliders for Strip Threshold and Minimum Strip Duration until the Strip Silence rectangles appear in the selection.

![Strip Silence rectangles](image)

For finer resolution on these sliders, press Command (Macintosh) or Control (Windows) while adjusting them.

6. To retain material before and after the new regions, adjust the sliders for Region Start Pad and Region End Pad.
Once the Strip Silence rectangles encompass the audio that you want to keep, press the Strip button.

The material defined as silence is removed from the selection and new regions are created, which also appear in the Audio Regions List.

The Strip Silence command is nondestructive and does not remove audio data from parent audio files. In addition to the Undo command, you can use the Heal Separation command to restore stripped material.

Strip Silence works with stereo and multichannel tracks, and keeps their audio regions phase-coherent.

Inserting Silence

The Insert Silence command is a simple and convenient way to insert silence in sessions. This command allows you to make a selection on a track (or tracks) and insert precisely that amount of silence. In Shuffle mode, all data on the track is shuffled later in the track by an amount equal to the selection.

In Grid mode, the Insert Silence command works just like the Clear command.

Shuffle Mode When inserting silence on multiple tracks in Shuffle mode, the following conditions apply:

- If any track is displayed as audio or MIDI data, the selected duration of silence is inserted into the audio or MIDI data and all underlying automation data on all selected tracks. All subsequent regions are shuffled by the amount of silence inserted. On MIDI tracks, only notes that are selected from the beginning are affected, so if you have selected the tail of a note and you Insert Silence, the note will remain unchanged.
- If all selected tracks are displayed as automation data, the selected range is cleared of automation data only of the type visible on each track. Regions are not shuffled. Instead, a blank gap appears equal to the length of the selection.
- If all selected tracks are displayed as automation data, press Control (Macintosh) or the Start key (Windows) while choosing the Insert Silence command to insert silence on all automation playlists for all selected tracks. Regions are not shuffled.

Slip Mode When inserting silence on multiple tracks in Slip mode, the following conditions apply:

- If any track is displayed as audio or MIDI data, the selected range is cleared of audio or MIDI data and all underlying automation data on all selected tracks.
- If all selected tracks are displayed as automation data, silence is inserted only into the automation type visible on each track.
- If all selected tracks are displayed as automation data, press Control (Macintosh) or the Start key (Windows) while choosing the Insert Silence command to insert silence on all automation playlists for all selected tracks.

To insert silence into a track:

1. Make a selection on the desired tracks. The length of the selection determines the duration of the silence inserted.
2. Choose Edit > Insert Silence.

For Shuffle mode, Pro Tools inserts the selected amount of silence. In the process, it splits the regions at the beginning of the insertion point, and moves the new regions later in the track by an amount equal to the length of the selection.
Consolidate Selection Command

During the course of normal edit operations, a track may eventually contain many regions. However, once a track or track range (such as a verse or chorus) reaches a satisfactory state, you may want to consolidate its regions into a single region—thus making the material much more easy to work with.

When consolidating an audio track, a new audio file is written that encompasses the selection range, including any blank space.

To consolidate regions within a track:

1. Using the Grabber or Selector, select the regions you want to consolidate.
   – or –
   To select all regions in a track, triple-click in its playlist with the Selector.
2. Choose Edit > Consolidate.

A new, single region is created that replaces the previously selected regions, including any blank space. If working with an audio track, a new audio file is written (with the Audio Suite Duplicate plug-in).

When consolidating audio regions with the Consolidate Selection command, if the selection contains muted regions, the muted regions are treated as silence. Whether or not a track is muted, or contains Mute automation, does not affect the Consolidate Selection command.

Managing Regions

A typical session can become quite busy with many tracks and dozens of regions. There are a number of things you can do, however, to keep track of and manage a session’s regions, which include:

- Renaming existing regions
- Specifying how auto-created regions are named
- Hiding auto-created regions
- Removing unused regions

Renaming Regions

In the course of a session you can rename regions to give them more descriptive names, or merely to shorten or simplify an existing name. When renaming a region that was auto-created from an edit, the region becomes a user-defined region and is displayed in the Regions List when auto-created regions are hidden.

Perhaps the easiest way to rename a region, if it resides in a track, is to double-click it with the Grabber. However, if the region does not yet reside in a track, or if you want to rename several regions, use the Rename Selected command.

To rename one or more regions:

1. If you will be renaming an auto-created region, make sure to select Display > Auto-Created Regions.
2. Select one or more region to be renamed in either the Audio or MIDI Regions List.

If the Editing Preference for “Regions List Selection Follows Track Selection” is enabled, you can highlight a region in the Regions List by selecting it in a track.
Chapter 20: Managing Regions

3 Choose Rename Selected from the Regions List pop-up menu.

4 When prompted, enter a new name for the region. If a whole-file audio region was selected, specify whether to rename just the region, or both the region and the disk file.

5 Click OK to rename the region. If renaming multiple regions, you are prompted, successively, to rename each region.

**Auto-Naming Parameters**

You can specify the auto-naming parameters for a region when new regions are created from it in the course of editing.

**To set auto-naming parameters for a region:**

1 Select a region in the Audio or MIDI Regions List.

2 Choose Auto Rename Selected from the Regions List pop-up menu.

3 In the Rename Regions dialog, enter the text to be used when naming regions created from the selected region.

<table>
<thead>
<tr>
<th>Name</th>
<th>Determines the root name for the auto-created regions.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Number</td>
<td>Sets the start number for the sequentially numbered new regions.</td>
</tr>
<tr>
<td>Zeros</td>
<td>Determines the number of zeros that occur before the auto numbers.</td>
</tr>
<tr>
<td>Suffix</td>
<td>Specifies text to be appended to the end of the name, following the auto numbering.</td>
</tr>
</tbody>
</table>

4 When you are finished, click OK to accept the new naming parameters.

**Hiding and Removing Unwanted Regions**

In the course of editing a session, the Audio and MIDI Regions Lists can fill up quickly with regions—ones you’ve created purposely and those that are automatically created by cutting, pasting, and separating other regions. Pro Tools allows you to hide or remove regions in your session so you don’t have to scroll through unnecessarily long Regions Lists.

**Hiding Auto-Created Regions**

You can hide regions that were automatically created during the course of editing.

**To hide auto-created regions:**

- Deselect Display > Display Auto-Created Regions. With this option deselected, only user-created regions appear in the Audio and MIDI Regions List.
User-defined regions include:
- Whole-file regions
- Regions created during recording
- Imported regions
- Renamed regions
- Regions created as a result of AudioSuite processing
- New regions created with Capture Region and Separate Region commands
- Regions created by trimming whole-file audio regions

When auto-created regions are hidden, Pro Tools warns you if the number of auto-created regions exceeds a certain threshold, and gives you the option of deleting them. If you choose to delete them, all auto-created regions are deleted at the same time.

To ensure that you keep a particular auto-created region, turn it into a user-created region by renaming it. For details, see “Renaming Regions” on page 260.

Removing Unwanted Regions

You can locate and remove unused regions in a session with the Clear Selected command.

⚠️ The Clear Selected command cannot be undone.

To find and remove unused regions in a session:

1. For MIDI regions, choose Select Unused from the MIDI Regions List pop-up menu.

2. For audio regions, choose one of the following from the Select Unused submenu in the Audio Regions List pop-up menu:
   - Unused Regions
   - Unused Regions Except Whole Files
   - Offline Regions

3. After all unused regions are selected, choose Clear Selected from the Regions List pop-up menu.

4. Click Remove to remove the unused regions from the session.

   - or -

If clearing a whole-file audio region and you want to permanently remove the audio file from your hard drive, click Delete.

When deleting audio files for multiple regions, Pro Tools presents a warning dialog for each audio file. To bypass repeated warning dialogs:

- Option-click (Macintosh) or Alt-click (Windows) the Delete button in the Clear Audio dialog. This permanently deletes each successive audio file from your hard drive (for each of the unused regions) without any further warnings.

Use this “power delete mode” with caution, since deletion of these files cannot be undone.
Compacting an Audio File

The Compact Selected command deletes unused portions of audio files to conserve disk space, and to prepare for cleaner hard drive back-ups.

The Compact Selected command deletes audio if there are no regions referencing the data. For this reason you should delete any unused regions before compacting.

Because it permanently deletes audio data, the Compact Selected command should be used only after you have completely finished your editing and are sure that you have no further use for the unused audio data.

The Compact Selected command can pad the regions of the compacted file by a user-selectable amount. You may want to do this because Pro Tools requires extra audio data before and after audio regions to create crossfades. So, if your regions have crossfades, or if you want to pad the regions for the sake of any future trimming, you should enter an appropriate amount of padding (in milliseconds) to allow for this.

⚠️ The Compact Selected command is destructive and cannot be undone. It permanently alters the original audio files. There is no way to recover data deleted with this command.

To compact an audio file:

1. Choose Select Unused > Regions from the Audio Regions List pop-up menu. All regions that have not been placed in a track in the current session are highlighted in the Audio Regions List.
2. To remove all of these unused audio regions, choose Clear Selected from the Audio Regions List pop-up menu. When the dialog appears, choose Remove.
3. In the Audio Regions List, select the region or regions you want to compact.
4. Choose Compact Selected from the Audio Regions List menu.
5. Enter the amount of padding in milliseconds that you want to leave around each region in the file.
6. Click Compact to compact the file or Cancel to cancel the command.

Once the Compact operation has been completed, the session is automatically saved.
Chapter 21: Conductor Tracks and Memory Locations

**Tempo Events**

Tempo events, which are displayed in the Tempo Ruler, can be inserted at the beginning of a session to replace the default tempo (of 120 BPM), and they can be inserted anywhere within the session for additional tempo changes. Tempo events cannot be inserted in Manual Tempo mode.

**To display the Tempo Ruler:**
- Select Display > Ruler View Shows > Tempo.

*When in Manual Tempo mode, the Tempo Track is ignored and the session plays at the tempo defined in the Transport window. For details, see “Using Manual Tempo Mode” on page 130.*

**Current Tempo**

As tempo events are encountered during playback, the session’s current tempo is displayed in the Transport window.

**Inserting Tempo Events**

**To insert a tempo event:**

1. Click in the Tempo Ruler where you want to insert the tempo event and then choose MIDI > Change Tempo.
   - or –
   Click in the Tempo Ruler where you want to insert the tempo event and then click the Change Tempo button in the far left of the Tempo Ruler.

*Current tempo displayed in Transport window*
2 In the Tempo Change window, enter the Location and BPM value for the tempo change.

Select the Snap To Bar option to place the inserted tempo event cleanly on the first beat of the nearest measure.

3 To base the BPM value on something other than the default quarter note, select a different note value.

4 Click Apply. The new tempo event is inserted and appears in the Tempo Ruler.

Each tempo event has a small green triangle next to it that indicates its location. These triangles can be dragged to move the tempo event, and they can be double-clicked to edit the tempo event.

**Editing and Moving Tempo Events**

Existing tempo events can be moved, edited, deleted, and copied and pasted.

**To move a tempo event by dragging:**

- In the Tempo Ruler, drag the triangle for the tempo event left or right.

**Dragging a tempo event**

If the Edit mode is set to Grid, the dragged event snaps to the current Grid value.

**To edit a tempo event:**

1 In the Tempo Ruler, double-click the tempo event.

2 In the Change Tempo dialog, enter a new Location or BPM value for the tempo event.

3 Click OK.

**To delete a tempo event:**

- While pressing Option (Macintosh) or Alt (Windows), move the cursor over the tempo event (where the cursor changes to the Grabber with a “−”) and click to remove it.

**To copy and paste several tempo events:**

1 If desired, set the Edit mode to Grid to constrain the selection to the current Grid value.

2 Drag in the Tempo Ruler to select the range of measures that includes the tempo events.
If an existing tempo event is near the beginning of the selection, press Command (Macintosh) or Control (Windows) so the Selector appears.

Press Option (Macintosh) or Alt (Windows) while dragging to select across all Conductor tracks.

3 Choose Edit > Copy.

4 Click in the Tempo Ruler at the point where you want to paste the tempo events.

5 Choose Edit > Paste. The contents of the Clipboard are pasted from the insertion point, replacing any existing tempo events.

To extend an Edit selection in a track to the Tempo Ruler:

1 Using either the Selector or Grabber, select a track range.

2 Shift-click in the Tempo Ruler.

Shift-click again in the Tempo Ruler to remove it from the selection.

To select all tempo events:

Double-click with the Selector in the Tempo Ruler.

To clear a range of selected tempo events:

1 If desired, set the Edit mode to Grid to constrain the selection to the current Grid value.

2 Drag with the Selector in the Tempo Ruler to select the tempo events you want to remove.

3 Choose Edit > Clear to delete the selected tempo events.

---

**Tempo and MIDI and Audio**

When editing or moving tempo events, the Bars:Beats Ruler expands or shrinks, as necessary, to accurately reflect the placement of audio regions (which remain constant in terms of sample location). This, in turn, affects the relative placement of MIDI notes, and ensures that the visual relationship between MIDI and audio is accurate.

Figure 15 illustrates how MIDI notes shift and expand in relation to audio after the tempo is reduced.

![Figure 15. Before and after change in tempo](image)

After editing or moving a tempo event:

- Bar and beat locations for audio regions (which are sample-based) are adjusted for the new tempo. The audio region’s sample and SMPTE locations remain unchanged.
- MIDI notes (which are tick-based) remain at the same bar and beat location. In relation to audio, however, the notes shrink or expand based on the new tempo, and result in new sample and SMPTE locations for the note start and end times.
**Default Tempo**

New sessions open with a default tempo of 120 BPM. This tempo can be changed by inserting a tempo event at 1|1|000. However, this is not the same as inserting normal tempo events at other locations. The tempo event that resides at 1|1|000 is actually a Bar|Beat Marker (notice that it has a blue triangle).

The main distinction is that this Bar|Beat Marker can be dragged to any location within the session (such as to align with a particular SMPTE frame) to redefine where 1|1|000 is.

---

**Identify Beat Command**

**Bar|Beat Markers**

The Identify Beat command lets you establish a tempo/meter map for audio that was recorded without listening to the click, or for imported audio with unknown tempos.

The Identify Beat command analyzes a selection range (usually with a distinct number of beats or measures) and calculates its tempo based on the specified meter. In doing this, Bar|Beat Markers for the calculated tempo are inserted and appear in the Tempo Ruler at the beginning and end of the selection; in addition, meter events are inserted into the Meter Ruler.

You can use Beat Detective to generate Bar|Beat Markers within a selection that includes rhythmic changes on every beat and sub-beat. For more information, see Chapter 22, “Beat Detective.”

---

**Bar|Beat Markers**

Bar|Beat Markers look similar to tempo events, but instead have small blue triangles to indicate their location.

The key to accurately defining tempos for a range of audio with the Identify Beat command is to make sure that the initial selection represents an accurate length of beats or measures. In fact, you may want to first loop the selection on playback (see “Looping Playback” on page 209) to see if it plays cleanly without skipping. To avoid drift, and remain sample-accurate, select the audio material with the Time Scale set to Samples rather than Bars:Beats.

---

**Identifying Beats**

To add Bar|Beat Markers for a one-bar drum loop:

1. Place a one-bar drum loop at the beginning of an audio track.

2. Select Display > Samples. This ensures that the selected audio material will be sample-accurate.

3. Select the audio region with the Grabber and choose Edit > Identify Beat.
4 In the Bar|Beat Markers dialog, specify the start and end locations for the inserted Bar|Beat Markers. Since this example deals with a one-bar loop, enter 1|1|000 and 2|1|000.

5 If necessary, specify a time signature for the start and end range.

6 Click OK to automatically calculate the new tempo and insert the necessary Bar|Beat Markers and meter events. Any existing tempo and meter events residing within the selection are deleted.

When working with a selection, the Identify Beat command only calculates a single tempo for the selected range. If the tempo varies from measure to measure, or beat to beat, you’ll need to use the Identify Beat command for each tempo variance (making sure to accurately define a precise selection range or beat location for the tempo change).

Inserting Bar|Beat Markers One at a Time

Audio Material with Varying Tempos

You can insert Bar|Beat Markers one at a time by setting an Edit insertion point (instead of making a selection) before using the Identify Beat command. The ability to identify each beat, one at a time, is especially useful when working with audio with varying tempos.

For instance, if you have a measure that accelerates slightly, you could insert a Bar|Beat Marker on each beat (see Figure 16) so the tempo is accurately reflected.

Once the tempo has been determined for the audio, you can duplicate the original audio region with the Repeat command.

After the Bar|Beat Markers are inserted, further adjustments in the tempo map are possible by dragging each of the Markers, as necessary, to align with the associated beat within the audio.
**Dragging Bar|Beat Markers**

Bar|Beat Markers can be dragged to new locations so they can align with audio regions that have been moved, or so that they can align to a slightly different point within an audio region. This results in neighboring MIDI data being adjusted to align with the new tempo map.

![Dragging a Bar|Beat Marker](image)

**Tempo Events Versus Bar|Beat Markers**

Bar|Beat markers and Tempo Events behave differently when you drag them in the Tempo Ruler.

**When dragging a tempo event:**

- The tempo event is placed at a new bar and beat location. The sample and SMPTE locations for the event are updated as well.
- The BPM value for the dragged tempo event remains constant, as do any other tempo events in the session.
- Neighboring MIDI events, along with the Ruler, shrink or expand as necessary to adjust for the new tempo location.

**When dragging a Bar|Beat Marker:**

- Its BPM value is recalculated along with the Bar|Beat Marker to its immediate left. Bar|Beat Markers to the right of the dragged marker remain unchanged.
- Its bar and beat location is dragged with the Bar|Beat Marker. If the Bar|Beat Marker was originally placed at 3|1|000, it remains there (unless it is edited).
- Its sample and SMPTE locations change, as calculated for by the new tempo for the Bar|Beat Marker.
- Neighboring MIDI events, along with the Bars:Beats Ruler, shrink or expand as necessary to adjust for the new tempo.

**Editing Bar|Beat Markers**

A Bar|Beat Marker can be edited to redefine its bar and beat location, which also redefines the start or end point of the range being analyzed for tempo. This is different from dragging a Bar|Beat Marker.

**To edit a Bar|Beat Marker:**

1. In the Tempo Ruler, double-click the Bar|Beat Marker.
2. In the Identify Beat dialog, enter a new Location for the Bar|Beat Marker.
3. Click OK to recalculate the new tempo.

Like meter and tempo events, Bar|Beat Markers can also be deleted.

**To delete a Bar|Beat Marker:**

- While pressing Option (Macintosh) or Alt (Windows), move the cursor over the Bar|Beat Marker (where the cursor changes to the Grabber with a “-“) and click to remove it.
Meter Events

Meter events can be inserted at the beginning of a session to replace the default meter (of 4/4), and they can be inserted anywhere within the session for additional meter changes. Meter events are displayed in the Meter Ruler.

To display the Meter Ruler:
- Select Display > Ruler View Shows > Meter.

Current Meter

As meter events are encountered during playback, the session’s current meter is displayed in the Transport window.

Inserting Meter Events

To insert a meter event:
1. Choose MIDI > Change Meter.
   - or -
   Click the Change Meter button in the far left of the Meter Ruler.

   - or -

While pressing Control (Macintosh) or the Start key (Windows), move the cursor into the Meter Ruler (where the cursor changes to the Grabber with a “+”) and click at the desired location.

Manually inserting a meter event

2. In the Meter Change window, enter the Location and Meter for the meter change.

For some meters, it may be desirable to use a dotted value for the click. For instance, if using a meter of 6/8, a dotted eighth note click (yielding two clicks per measure) is more suitable than a straight eighth note click (six clicks per measure).
Click Apply to insert the new meter event. The new meter event is inserted and appears in the Meter Ruler.

Each meter event has a small yellow triangle next to it that indicates its location. These triangles can be selected for copying and pasting, and they can be double-clicked to edit the meter event.

**Editing Meter Events**

Existing meter events can be edited, deleted, and copied and pasted.

**To edit a meter event:**

1. In the Meter Ruler, double-click the meter event.
2. In the Change Meter dialog, enter a new Location or Meter for the event.
3. Click OK.

**To delete a meter event:**

1. While pressing Option (Macintosh) or Alt (Windows) while dragging to select across all Conductor tracks.

**To copy and paste several meter events:**

1. If desired, set the Edit mode to Grid to constrain the selection to the current Grid value.
2. Drag in the Meter Ruler to select the range that includes the meter events.
3. Choose Edit > Copy.
4. Click in the Meter Ruler at the point where you want to paste the meter events.
5. Choose Edit > Paste. The contents of the Clipboard are pasted from the insertion point, replacing any existing meter events.

**To extend an Edit selection in a track to the Meter Ruler:**

1. Using either the Selector or Grabber, select a track range.
2. Shift-click in the Meter Ruler.

Shift-click again in the Meter Ruler to remove it from the selection.

**To select all meter events:**

1. Double-click with the Selector in the Meter Ruler.
To clear a range of selected meter events:
1. If desired, set the Edit mode to Grid to constrain the selection to the current Grid value.
2. Drag in the Meter Ruler to select the meter events you want to remove.
3. Choose Edit > Clear to delete the selected meter events.

Partial Measures

Aligning Beat 1 to a SMPTE Location

When scoring to film or video, you will often need to start a section of music at a precise SMPTE time code location. Since this location will usually not fall cleanly at the beginning of a measure, you can insert a meter event at the time code location where the music needs to start.

As necessary, Pro Tools will create a partial measure to accommodate the inserted meter event. When a meter event is preceded by a partial measure, the meter event is displayed in italics in the Meter Ruler.

Renumbering Bars

You can use the Renumber Bars command to renumber all bars in the session, effectively changing the bar locations for all regions, meter and tempo events while leaving their position intact. In doing so, however, the SMPTE and sample locations of the session data are not changed.

To renumber bars:
1. Choose MIDI > Renumber Bars.
2. Specify the bar you want to renumber, along with the new bar number, then click Renumber.

Partial measures of 4/4

Partial measures can also occur when pasting meter events to locations other than beat one.
Memory Locations and Markers

Each session can save up to 200 Memory Locations that can be used to recall:

- Markers to important locations in the session
- Edit selections across one or more tracks
- Record and play ranges, along with pre/post-roll times
- Track settings that include Show/Hide status, Track Heights, and zoom values
- Edit and Mix Groups enables

Memory Locations are viewed and sorted in the Memory Locations window, where they can be recalled by clicking the Memory Location.

With the Numeric Keypad Mode set to Classic, Memory Locations can be recalled from the numeric keypad by pressing the Memory Location number followed by period (.)

With the Numeric Keypad Mode set to Transport or Shuttle, Memory Locations can be recalled from the numeric keypad by pressing period (.), the Memory Location number, and period (.) again.

Properties of Memory Locations

When creating a new Memory Location (see “Creating Memory Locations” on page 276) you are prompted to define its Time Properties and General Properties.

Time Properties

Under Time Properties, a Memory Location can be set to Marker, Selection, or None. This determines the type of Memory Location that is created. Each of these three Memory Location types can also save any combination of General Properties.

Marker Recalls a Timeline location whose reference can be either Bar|Beat (tick-based) or Absolute (sample-based). When recalling a Marker Memory Location, the playback cursor moves to the Marker’s location and the start and end times in the Transport window are also updated. If the Edit and Timeline Selections are linked, the edit cursor also moves to the Marker location.
Markers appear in the Markers Ruler with a thin yellow line extending down through all tracks in the Edit window (to assist in arranging and aligning track material). You can click on a Marker in the Markers Ruler to recall its location along with its stored General Properties.

**Selection** Recalls an edit selection or edit cursor location whose reference can be either Bar|Beat (tick-based) or Absolute (sample-based). A Selection Memory Location lets you store edit selections, for one or more tracks, that you return to often within a session. If the Edit and Timeline Selections are linked, a Selection Memory Location can recall record and play ranges.

*Only contiguous selections can be saved with Memory Locations. Discontiguous selections, made with the Object Grabber, will be recalled as if the selections were made with the Time Grabber.*

**None** Recalls no Time Properties and is therefore referred to as a General Properties Memory Location.

**Bar|Beat and Absolute Reference**

The Reference pop-up determines whether the Marker or Selection Memory Location is Bar|Beat or Absolute. When set to Bar|Beat, the Memory Location is tick-based and its bar and beat location remains constant if the tempo is changed—though its relation to audio is scaled, resulting in a new sample location.

When set to Absolute, the Memory Location is sample-based and its bar and beat location shifts if the tempo is changed—though its sample location remains constant, along with its relation to audio material.

In the Markers Ruler, Markers that are Bar|Beat appear as yellow chevrons, and Markers that are Absolute appear as yellow diamonds.

**General Properties**

Any of the three types of Memory Locations (Marker, Selection, and None) can store and recall any combination of the following General Properties:

**Zoom Settings** Recalls the horizontal and vertical zoom values for both audio and MIDI tracks.

**Pre/Post Roll Times** Recalls pre- and post-roll times (but not whether they are enabled). This property can be stored with a Selection Memory Location to recall record and play ranges along with pre/post-roll.

**Track Show/Hide** Recalls which tracks are hidden. Use this property to display groups of tracks for editing and mixing.

**Track Heights** Recalls all Track Heights. Use this option along with the Zoom Settings option to recall edit environments that are suited for particular tasks, such as editing down to the sample level or trimming MIDI notes.

**Group Enables** Recalls which Edit and Mix Groups are enabled. This option is helpful in recalling groups for particular edit and mixing operations, such as muting all drum tracks or fading a stereo pair.
Creating Memory Locations

Memory Locations can be created by pressing Enter on the numeric keypad, by Control-clicking (Macintosh) or Start-clicking (Windows) in the Markers Ruler, or by choosing the Add New Memory Location command from the pop-up menu in the Memory Locations window. The method you use will likely depend on the type of Memory Location you want to create.

When creating Memory Locations, the next available number is assigned to it (1–200). This number is used in recalling the Memory Location from the numeric keypad.

To create a Marker Memory Location:
1. Configure any session settings you will save with the Marker Memory Location, such as zoom settings, pre/post-roll times, Show/Hide status for tracks, Track Heights, and Edit and Mix Group enables.
2. Make sure to select Operations > Link Edit and Timeline Selection.
3. If the Markers Ruler is not displayed, select Display > Ruler View Shows > Markers.
4. Click with the Selector at the desired location in any track or Ruler. To place a Marker at the beginning of a region, select the region with the Grabber. Click the Marker Well button to the left of the Markers Ruler (or press Enter on the numeric keypad).

While pressing Control (Macintosh) or the Start key (Windows), move the cursor into the Markers Ruler (where the cursor changes to the Grabber with “+”) and click at the desired location.

Manually inserting a Marker

5. In the New Memory Location dialog, select the Marker option and specify the Reference as either Bar|Beat or Absolute.
6. If desired, enter a name for the new Marker and select any General Properties you want to save with the Marker.
7. Click OK. The Marker is created and appears in the Markers Ruler, and in the Memory Locations window.

To create a Selection Memory Location:
1. Configure any session settings you will save with the Selection Memory Location, such as zoom settings, pre/post-roll times, Show/Hide status for tracks, Track Heights, and Edit and Mix Group enables.
2. Select a range of material in one or more tracks.
3. Press Enter on the numeric keypad.
   – or –
   From the pop-up menu in the Memory Locations window (click the Name button), choose Add Memory Location.
4. In the New Memory Location dialog, select the Selection option and specify the Reference as either Bar|Beat or Absolute.
5. If desired, enter a name for the new Memory Location and select any General Properties you want to save with it.

6. Click OK. The Selection Memory Location is created and appears in the Memory Locations window.

**To create a General Properties Memory Location:**

1. Configure any session settings you will save with the Selection Memory Location, such as zoom settings, pre/post-roll times, Show/Hide status for tracks, Track Heights, and Edit and Mix Group enables.

2. Press Enter on the numeric keypad.

3. In the Memory Location dialog, select the None option.

4. If desired, enter a name for the new Memory Location and select any General Properties you want to save with it.

5. Click OK. The General Properties Memory Location is created and appears in the Memory Locations window.

**Creating Memory Locations on the Fly**

When the Editing Preference for “Auto-Name Memory Locations When Playing” is enabled, Memory Locations can be created while playing without encountering the New Memory Location dialog. This option can also be selected from the pop-up menu in the Memory Locations window.

This capability is useful if you want to mark certain locations while listening during a record pass, or if you want to mark frame locations while viewing a video scene.

**To create a Marker during playback:**

1. From the pop-up menu in the Memory Locations window, select Default To Marker. This ensures that new Memory Locations default to being Markers.

2. From the pop-up menu in the Memory Locations window, select Auto-Name Memory Locations.

3. For inserted Markers to have a Bar|Beat reference, make sure to set the Time Scale to Bars:Beats.

4. Click Play in the Transport window.

5. When the location is reached, press Enter on the numeric keypad. A Marker is automatically created and appears in the Markers Ruler.

When auto-creating Markers, they are named and numbered as “Marker 1,” “Marker 2,” “Marker 3,” and so on.

When the option for Default To Marker is deselected, new Memory Locations default to whatever type was last created. Therefore, if a Selection Memory Location was created last, it will be the type that is created on the fly. In this case, the name for the created Memory Location is based on the start of the Edit selection using the time format for the Main Time Scale (such as “2|2|305” or “0:02.658”).
Recalling Memory Locations

Memory Locations can be recalled from the Memory Locations window and from the numeric keypad. In addition, Marker Memory Selections can be recalled by clicking them in the Markers Ruler.

To recall a Memory Location:

1. If the Memory Locations window is not already open, choose Windows > Show Memory Locations to display it.
2. If recalling a Selection Memory Location that will define a record or play range, make sure to select Operations > Link Edit and Timeline Selection.
3. In the Memory Locations window, click the Memory Location to recall it.
   – or –

   With the Numeric Keypad Mode set to Classic, press the Memory Location number followed by period (.)
   – or –

   With the Numeric Keypad Mode set to Transport or Shuttle, press period (.), the Memory Location number, and period (.) again.

   Even if the Markers Ruler is not displayed, Markers can be recalled from the Memory Locations window, or from the numeric keypad.

Editing Memory Locations

Memory Locations can be renamed, edited, deleted, and copied and pasted.

To rename a Memory Location:

1. In the Memory Locations window, double-click the Memory Location you want to rename.
   – or –

   If renaming a Marker Memory Location, double-click the Marker in the Markers Ruler.
2. Enter the new name for the Memory Location, and click OK.

To redefine the General Properties stored with a Memory Location:

1. As desired, make changes to the session’s zoom settings, pre/post-roll times, Show/Hide status of tracks, Track Heights, and Group Enables.
2. In the Memory Locations window, Control-click (Macintosh) or Right-click (Windows) the Memory Location you want to redefine.
   – or –

   If changing a Marker Memory Location, Control-click (Macintosh) or Right-click (Windows) the Marker in the Markers Ruler.
3. In the Memory Location dialog, select the General Properties you want to save with the Memory Location.
4. Enter a new name for the Memory Location, if desired, and click OK.
To change a Memory Location from one type to another:

1. In the Memory Locations window, double-click the Memory Location you want to change.
   – or –
If changing a Marker Memory Location, double-click the Marker in the Markers Ruler.
2. In the Memory Location dialog, select either Marker, Selection, or None as the Memory Location type.
3. Enter a new name for the Memory Location, if desired, and click OK.

To change the Selection stored with a Memory Location:

1. If the Memory Locations window is not already open, choose Windows > Show Memory Locations to display it.
2. Select a range of material in one or more tracks.
3. In the Memory Locations window, Control-click (Macintosh) or Right-click (Windows) the Memory Location that you want to redefine.
4. Enter a new name for the Memory Location, if desired, and click OK.

To move a Marker by dragging:

1. In the Markers Ruler, drag the Marker left or right.

   ![Dragging a Marker](image)

   *Dragging a Marker*

   If the Edit mode is set to Grid, the dragged event snaps to the current Grid value. If using Spot mode, the Spot dialog opens.

To align a Marker to a different location:

1. Make sure to select Operations > Link Edit and Timeline Selection.
2. In any of the Timebase Rulers, click with the Selector at the new location.
   – or –
Click in the playlist for any track. To align the Marker to the start of a region, select the region with the Grabber.
3. In the Memory Locations window or the Markers Ruler, Control-click (Macintosh) or Right-click (Windows) the Marker Memory Location that you want to redefine.
4. Enter a new name for the Marker, if desired, and click OK.

Deleting Memory Locations

To delete a Memory Location:

- In the Memory Locations window, select the Memory Location and choose Delete Memory Location from the pop-up menu.
  – or –
- In the Memory Locations window, Option-click (Macintosh) or Alt-click (Windows) the Memory Location.

To delete all Memory Locations:

- In the Memory Locations Window, choose Delete All from the pop-up menu.
  – or –
- Option-Shift-click (Macintosh) or Alt-Shift-click (Windows) any Memory Location in the Memory Locations window.
To delete a Marker from the Markers Ruler:

- While pressing Option (Macintosh) or Alt (Windows), move the cursor over the Marker (where the cursor changes to the Grabber with a “–”) and click to remove it.

Copying Marker Memory Locations

To copy and paste a range of Markers:

1. If desired, set the Edit mode to Grid to constrain the selection to the current Grid value.
2. Drag in the Tempo Ruler to select the range of measures that includes the Markers.

If the beginning of the selection includes a Marker, press Command (Macintosh) or Control (Windows) so the Selector tool appears.

- Press Option (Macintosh) or Alt (Windows) while dragging to select across all Conductor tracks.

3. Choose Edit > Copy.
4. Click in the Markers Ruler at the point where you want to paste the tempo events.
5. Choose Edit > Paste. The contents of the Clipboard are pasted from the insertion point, replacing any existing Markers.

To extend an Edit selection in a track to the Markers Ruler:

1. Using either the Selector or Grabber, select a track range.
2. Shift-click in the Markers Ruler.

Shift-click again in the Tempo Ruler to remove it from the selection.

To select all Markers in the Markers Ruler:

- Double-click with the Selector in the Tempo Ruler.

---

Memory Locations Window

Memory Locations are listed, with their name and assigned number, in the Memory Locations window. To recall a Memory Location from this window, simply click it.

You can select viewing and sorting options, along with commands for creating and removing Memory Locations, from the pop-up menu in the Memory Locations window (obtained by clicking the Name button in the upper left).

Memory Locations Commands and Options

Show Markers Only When selected, only Marker Memory Locations are displayed in the Memory Locations window. However, even when Selection Memory Locations and General Property Memory Locations are hidden, they can still be recalled from the numeric keypad.
Show View Filter Icons When selected, the Memory Locations window provides an icon-based “View Filter” that allows you to show or hide Memory Locations based on the properties they contain. To show or hide Memory Locations containing a specific property, click the appropriate icon.

Memory Locations View Filter

If an icon is disabled, all Memory Locations associated with that property are hidden. However, if a Memory Location contains other properties for an icon that is enabled, it is still displayed. When a view icon is enabled, it appears in color. When it is disabled, it appears gray.

Show Main/Sub Counter When selected, a column appears in the Memory Locations window that displays the locations for Markers, and the start times for Selection Memory Locations. General Property Memory Locations display nothing in this column.

Main/Sub Counters in Memory Locations window

You can click at the top of these columns for a pop-up menu that will let you change the Main and Sub Time Scale.

Sort by Time When selected, Markers are sorted by their order in the Timeline, followed by Selection and General Properties Memory Locations, which are listed in the order in which they were created.

When Sort by Time is deselected, all Memory Locations are listed in the order of their assigned numbers.

Add Memory Location Choose this command to create a new Memory Location.

Remove Memory Location Deletes the currently selected Memory Location in the Memory Locations window.

Delete All Deletes all Memory Locations (Marker, Selection, and General Property) in the session.

Default To Marker When selected, new Memory Locations default to Markers, though in the New Memory Location dialog you can still define the new Memory Location as one of the other types.
Auto-Name Memory Location When selected, Memory Locations are created automatically without encountering the New Memory Location dialog. If the Default To Marker option is selected, a Marker Memory Location is auto-created. Otherwise, the Memory Location type is determined by whatever type (Marker, Selection, or None) was created last.
Chapter 22: Beat Detective

Beat Detective Requirements

Beat Detective is only available with Pro Tools TDM systems. It does not appear in Pro Tools LE.

RAM Requirements for Beat Detective

Beat Detective operations can require a large amount of RAM, especially when working with multiple tracks and lengthy selections.

To avoid low memory situations with Beat Detective, do the following:

- Macintosh users should substantially increase the RAM allocated to Pro Tools. Under extreme usage situations (eight or more tracks with selections of five minutes or longer), you should allocate 100 MB, or even more, to the Pro Tools application.
- If your computer does not have the extra RAM, work with shorter selections, or individual tracks.
- Set the Editing Preference for Levels of Undo to a smaller value (see “Levels of Undo and RAM” on page 181). Memory-intensive editing operations, such as Edit Smoothing with Beat Detective, can use up a large amount of memory when in the Undo queue.

About Beat Detective

Beat Detective can automatically detect peak transients in audio selections, so you can extract tempo information from the audio material, or so that you can conform the audio material to the session’s existing tempo map.

Beat Detective involves the following steps:

1. Define a selection of audio material, on a single mono track, multichannel track, or across multiple tracks.
2. Adjust the Detection parameters so that vertical beat triggers appear in Edit window, based on the peak transients detected in the selection.
3. Generate Bar|Beat Markers based on the beat triggers, thereby extracting a tempo map from the selection and using it for the session.
   - or -

Separate and automatically create new regions, representing beats or sub-beats, based on the beat triggers. You can then conform the new regions to the session’s existing tempo map, followed by automatic edit smoothing, if necessary.
Beat Detective and the Source Material

Beat Detective is most effective with rhythmic audio material that has strong percussive attacks. It should work well with most instruments used in pop music, such as drums, guitar, and bass. Beat Detective will be less successful with audio material that has soft attacks, or legato phrasing, such as strings and vocals.

While Beat Detective has intelligent analysis algorithms for detecting rhythmic material, some material may be too far off the rhythmic grid, or have tempo changes that are too varied, to be useful with Beat Detective.

Applications for Beat Detective

Following are some useful applications for Beat Detective.

Extracting Tempo and Grooves from Audio

Beat Detective can convert beat triggers to Bar|Beat Markers, which makes it possible to extract tempo from audio that was recorded without listening to a click—even if the audio contains varying tempos, or material that is swung.

Once the Bar|Beat Markers have been generated from the source audio, other audio regions and MIDI tracks in the session can be quantized to it.

Conforming Audio to an Existing Tempo Map

If your session already has the right tempo, you can conform audio with a different tempo, or with varying tempos, to the session’s tempo. If desired, the conformed audio can retain a percentage of its original feel, and you can increase or reduce the amount of swing in the conformed material.

“Tightening Up” an Audio Performance

Beat Detective can improve the timing of some audio material by calculating and extracting its average tempo, and then conforming its rhythmic components (regions separated with Beat Detective) to the session’s tempo map. You can even retain some of the original feel of the material.

Loop Matching

Since Beat Detective can extract tempo and beat information from audio, and conform audio to an existing tempo, this makes it very useful for aligning loops with different tempos or feels. If one loop has a subtly different feel or groove, you can potentially impose that groove on another loop.

Remixes

Beat Detective can be used for remixes. It can extract tempo from the original drum tracks, or in some instances the original stereo mix. New tracks, audio or MIDI, can then be conformed to the original material, or the original material can be conformed to new drum tracks, achieving an entirely new feel.

Smoothing Post Production Edits

Beat Detective’s Edit Smoothing can be used to automatically clean up foley tracks that contain many regions that need to be trimmed and crossfaded, effectively removing the gaps of silence between the regions (so you can retain the room tone throughout the track).
The Beat Detective Window

The Beat Detective window has four different modes, accessed by the tabs in the upper left of the window. Depending on the mode, the controls in the upper right of the window change. The Selection options for Beat Detective, in the center, are available in each of the modes.

The Beat Detective modes include:

- **Bar|Beat Marker Generation** Automatically generates Bar|Beat Markers corresponding to transients detected in the audio selection.

- **Region Separation** Automatically separates and creates new regions based on transients detected in the audio selection.

- **Region Conform** Conforms all separated regions within the selection to the current tempo map. You can preserve some of the original feel of the material with the Strength and Exclude Within option, or impose an amount swing with the Swing option.

- **Edit Smoothing** After conforming regions, this option is used to fill the gaps between the regions by automatically trimming them, and inserting crossfades if desired.

- **Collection Mode** Accesses a sub-mode for collecting beat triggers for multiple tracks, each with different Detection parameters.

**Opening the Beat Detective Window**

To open the Beat Detective window:

- Choose Windows > Show Beat Detective.
- or –

- Press Command+8 (Macintosh) or Control+8 (Windows) on the numeric keypad.

Beat Detective is a floating window that can be left open while working, adjusting the parameters in real time during playback, while viewing the beat triggers that appear in your selection in the Edit window.
Defining the Selection for Beat Detective

Whether you will be generating Bar|Beat Markers, or separating regions to be conformed, the first step in using Beat Detective is to define the Selection parameters for the audio material you want to analyze.

Beat Detective can work with selections on multichannel tracks, or with selections across multiple tracks. This is especially useful if you have different drum parts on different tracks and want the rhythmic events on each track detected, thereby generating a set of trigger points from all of the material as a whole.

For Beat Detective to accurately generate beat triggers that are metrically accurate, it’s very important that the length and meter of the selection be defined correctly. This is crucial whether you intend to generate Bar|Beat Markers, or separate and conform regions. In addition, the selection cannot contain any meter changes.

To account for the timbral subtleties and rhythmic nuances of freely recorded material, you may want to work with smaller selections.

To define a selection for Beat Detective:

1. In the Edit window, select a range of audio material. To work with multiple tracks, Shift-click in each additional track, or use an Edit Group.

Make sure the selection’s start and end points fall cleanly on the beat. To zero in on start and end points, see “Tabbing to Transients” on page 207.

You can easily recall an Edit selection by saving it as a Memory Location. See “Memory Locations and Markers” on page 274.

2. To keep the Edit selection intact while playing or looping from any location, deselect Operations > Link Edit and Timeline Selection.

3. Choose Windows > Show Beat Detective.

4. Enter a Time Signature for the material.

5. To set the selection range, do one of the following:
   - Enter locations for the Start Bar|Beat and End Bar|Beat. For a four-bar selection that starts on beat 1, enter 1|1 and 5|1.
   - If unsure of the length of the material, enter the Start Bar|Beat and click the Tap button repeatedly to automatically calculate the End Bar|Beat. When using Tap with long selections, continue to tap until the End Bar|Beat stabilizes. Once stabilized, you may need to manually adjust the number to the nearest bar boundary.
   - If the selection’s tempo matches the session tempo (see “Calculating a Selection’s Tempo with Beat Detective” on page 287), and it aligns correctly with the session’s bars and beats, click the Capture Selection button.

6. If the material contains 32nd notes or triplets, select those options.
Calculating a Selection’s Tempo with Beat Detective

If you know the start and end points of a selection, and its time signature, you can use Beat Detective to calculate its average tempo. This allows you to automatically define the selection range (with the Capture Selection button) when using Beat Detective.

To calculate a selection’s tempo with Beat Detective:

1. In the Edit window, select a range of audio material. Make sure the selection’s start and end points fall cleanly on the beat. To zero in on start and end points, see “Tabbing to Transients” on page 207.
2. Choose Windows > Show Beat Detective and click the tab for Bar|Beat Generation.
3. Enter a Time Signature for the selection.
4. Enter the Start Bar|Beat and End Bar|Beat for the selection.
5. With the Sensitivity slider set to 0%, click Analyze.
6. Click Generate to automatically insert Bar|Beat Markers at the beginning and end of the selection, representing the material’s average tempo.

Detecting Transients with Beat Detective

Once you’ve accurately defined the selection range, Beat Detective can generate beat triggers based on the peak transients detected in the material. The range and type of transients found can be adjusted with the Detection settings, allowing you to zero in on the bars, beats, and sub-beats in the material, while avoiding the non-rhythmic content.

To detect beat triggers for the selection:

1. In the Beat Detective window, click the tab for Bar|Beat Generation.
2. From the Analysis pop-up menu, choose one of the following detection algorithms:
   - High Emphasis, works well with high frequency material, such as cymbals and hi-hats, while avoiding low frequency material.
   - Low Emphasis, works well with low frequency material, such as bass guitar and kick drum, as well as with most tonal material, such as piano or rhythm guitar.
3. Click the Analyze button.
4. Depending on the rhythmic content of the selection, set the Resolution to Bars, Beats, or Sub-Beats.
5 Adjust the Sensitivity slider until beat triggers appear on the beats and sub-beats in the selection.

Bar triggers are indicated with thick lines, beat triggers with medium lines, and sub-beat triggers with thin lines.

6 Zoom in and scroll through the selection, if necessary, to confirm that the beat triggers are appearing in the appropriate locations. If false triggers appear between the beats or sub-beats, representing non-rhythmic material, reduce the Sensitivity value.

7 To display the metric locations for the triggers, select the Show Trigger Time option.

8 If you can’t get the beat triggers to appear at the right locations, go back to step 2 and try the other Analysis algorithm.

**Tips for Getting Useful Triggers**

Use the following tips to verify beat triggers:

- To focus on a particular area in the selection, unlink the Edit and Timeline selections and set the playback range by clicking or dragging in any Timebase Ruler.
- Set the Edit window to scroll during playback, zoom in, and watch for the triggers as the window scrolls. If necessary, use half-speed playback by Shift-clicking Play in the Transport window.
- Check the thickness of the beat triggers to see if they align properly with the material. Thick triggers fall on barlines, medium triggers fall on beats, and thin triggers fall on sub-beats.
- Select the option for Show Trigger Time and see if the (assumed) metric locations of the triggers align with the material. A false trigger could cause other triggers downstream to have the wrong locations.
- Consider whether lengthy selections should first be broken down into smaller selections, which could be more easily managed. For example, working in 16- or 8-bar sections might yield much quicker and better results.
- For selections across multiple tracks, consider whether it may be easier to work with them individually, or whether Collection mode may be needed (see “Beat Detective and Collection Mode” on page 294).

**Editing Beat Triggers**

Even though Beat Detective offers a large amount of flexibility in how transients are detected, there may be times when beat triggers must be deleted, moved, or manually inserted.

**Deleting Beat Triggers**

False triggers, which do not represent an actual beat or sub-beat in the source material, may appear when raising the Sensitivity slider to detect low-level material. In these instances you can locate and manually delete the false triggers.

**To delete a beat trigger:**

1 With the Beat Detective window still open, choose the Grabber tool in the Edit window.
2 Locate the false trigger you want to delete. Transients for false triggers usually have smaller peaks than the other trigger points, and typically fall between the sub-beats.

3 Option-click (Macintosh) or Alt-click (Windows) the trigger to delete it.

Promoting Beat Triggers

To ensure that important beat triggers do not disappear when lowering the Sensitivity value, you can promote them. This is useful if a selection has many false triggers (too many to bother deleting) at a Sensitivity level where crucial, necessary triggers appear. If lowering the Sensitivity slider causes the needed triggers to disappear, simply promote them first.

To promote a beat trigger:

1 Raise the Sensitivity slider until the desired transient is detected and a beat trigger appears.

2 Command-click (Macintosh) or Control-click (Windows) the beat trigger to promote it.

3 Lower the Sensitivity slider to a value where the false triggers disappear.

Once beat triggers are promoted, they will only disappear if the Sensitivity value is set to 0%. To demote all beat triggers in the selection—returning them to their original state—you can click the Analyze button.

Inserting Beat Triggers

If an important beat or sub-beat is not detected, because of low level, you can manually insert a beat trigger.

To insert a beat trigger:

1 With the Beat Detective window still open, choose the Grabber tool in the Edit window.

2 Click in the selection where you want to insert the new trigger. After clicking, you can drag left or right to adjust its placement.

If you click too close to an existing trigger, the existing trigger will be moved to the new location.
Redefining a Beat Trigger’s Metric Location

It is important that beat triggers represent the correct metric location, so that Bar|Beat Markers are generated accurately, and so that regions are conformed to the right locations.

If some material is slightly off the beat, Beat Detective may assign it, as well as other transients in the selection, the wrong metric location.

For example, if you have a bass track where a note was intended to be a downbeat, but was played too early, Beat Detective may define its location as occurring a 32nd note before the downbeat. If you then separate and conform the region containing this note, it will move to the wrong place (subsequent regions may end up in the wrong location as well).

If you find that a beat trigger is not assigned the correct metric location, you can redefine it.

To change the metric location of a beat trigger:

1. Double-click the beat trigger you want to edit.

   ![Identify Trigger dialog](image)

2. In the Identify Trigger dialog, enter the correct location for the trigger, then click OK.

Generating Bar|Beat Markers with Beat Detective

Once Beat Detective has accurately detected the peak transients in the audio selection and accurately generated beat triggers, you can convert them to Bar|Beat Markers. This allows you to extract a tempo map from the material and use it for the session.

If beat triggers are accurately represented on the sub-beats, the material’s groove can potentially be imposed on other audio regions and MIDI tracks.

If you want to match the audio material to the session’s existing tempo map, you would not want to generate Bar|Beat Markers from the material. You would instead use Beat Detective to separate and conform the material (see “Separating and Conforming Regions with Beat Detective” on page 291).

To generate Bar|Beat Markers with Beat Detective:

1. In the Beat Detective window, click the tab for Bar|Beat Marker Generation.

2. Define the selection for the audio material (see “Defining the Selection for Beat Detective” on page 286).

3. Configure the Detection options so the selection’s peak transients are accurately detected (see “Detecting Transients with Beat Detective” on page 287).

4. Click the Generate button. Bar|Beat Markers are generated, based on the beat triggers, and appear in the Tempo Ruler.
Capturing a Groove with Sub-Beats

To extract the groove from a selection, set the Resolution to Sub-Beats when detecting transients. This ensures that the inner rhythms within each bar (if they indeed exist) are represented when generating Bar|Beat Markers. These Bar|Beat Markers can then be used to quantize other audio regions or MIDI tracks, thereby imposing the groove from the audio material.

⚠️ When quantizing regions or MIDI notes to Bar|Beat Markers on sub-beats that represent a swing feel, make sure to use a straight quantize value (with the Swing option for Quantize disabled).

Separating and Conforming Regions with Beat Detective

Once beat triggers appear in your selection, they can be used to define start and end points for new regions that can be separated automatically. The new regions can then be conformed to the session's existing tempo map.

To separate regions with Beat Detective:

1. In the Beat Detective window, click the tab for Region Separation.
2. Define the selection for the audio material (see “Defining the Selection for Beat Detective” on page 286).
3. Configure the Detection options so the selection’s peak transients are accurately detected (see “Detecting Transients with Beat Detective” on page 287).
4. Click the Separate button. Regions are separated based on the detected beat triggers.

Trigger Pad

When separating regions, the Beat Detective window displays an option called Trigger Pad. You can enter a value in this field (between 0 and 50 ms) to pad region start points when the separate point (the beat trigger) falls on the attack of the audio material. This results in an amount of space between the region start point and the region sync point, thereby ensuring that the attack portion of the material remains intact.

Sync Points

When separating regions with Beat Detective, sync points are created that correspond to the beat triggers. When conforming regions, the region sync point (not the region start point) determines where the region is placed.

Separating Multiple Tracks

You can use beat triggers from a single track, or subset of tracks, to separate a group of tracks. For example, after analyzing a selection on a kick drum track (with transients detected on beats 1 and 3), you can extend the selection to the hi-hat and snare tracks before performing the Separate.
This results in regions separated from each of the drum tracks at the same location, based on the beat triggers from the kick drum track. The separated regions can then be conformed as a group.

To extend a selection to another track, Shift-click in the desired track, or enable an Edit Group

**Conforming Regions with Beat Detective**

After regions have been separated with Beat Detective, the regions can then be conformed to the session’s tempo map. This is similar to using the Quantize Regions command, but with one important difference. Beat Detective can adjust the position of all regions, whether they have a straight, or swing feel, with a single operation.

Beat Detective will conform any selected region, whether or not it was separated with Beat Detective. However, in order to successfully conform regions with Beat Detective, the region start points must correspond to the start of the material that will align with the session’s bars and beats. This should generally not be a problem if the regions were separated with Beat Detective (as opposed to manually separated or trimmed).

If Beat Detective has successfully captured enough of the sub-beats from a selection before separating, you can conform with the Swing option to change the groove from a “straight” feel to one that is swung.

**To conform regions with Beat Detective:**

1. In the Beat Detective window, click the tab for Region Conform.

2. To affect how strongly the regions are conformed, select the Strength option and specify a percentage value with either the slider or by typing in a value:
   - Lower percentage values preserve the original feel of the regions.
   - Higher percentage values align the regions more tightly to the Grid, with 100% aligning precisely to the Grid.

3. To “tighten up” the original feel, while retaining it, set the Strength option to 85–88%.

4. To affect which regions are conformed, select the Exclude Within option and specify a percentage value with the slider or by typing in a value:
   - Lower percentage values ensure that regions further away from the Grid are conformed, while those closer to the Grid are not.
   - Higher percentage values ensure that regions closer to the Grid, as well as those further away, are conformed.

5. To “tighten up” the original feel, while retaining it, set the Exclude Within option to 10–15%.

4. To achieve a swing feel for the conformed regions, select the Swing option and whether the swing is based on 8th or 16th notes, then specify a percentage value with the slider or by typing in a value:
   - Smaller percentage values yield less swing, with 0% yielding none.
   - Larger percentage values yield more swing, with 100% yielding a triplet, swing feel.
• Percentage values between 100–150 move the regions beyond a triplet, swing feel, toward the next 16th note boundary (provided the Swing note value is set to 8th notes).

5 Click the Conform button to automatically conform all regions in the selection.

Click the Conform button to automatically conform all regions in the selection.

Audition the new conformed regions by clicking Play in the Transport window. If necessary, select Edit > Undo and try a different set of Conform settings.

**Edit Smoothing**

After regions are conformed, there are gaps between the regions. These gaps can cause the material to sound unnatural on playback.

<table>
<thead>
<tr>
<th>Smoothing Options</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fill Gaps</td>
<td>Trims region end points so that the gaps between regions are filled.</td>
</tr>
<tr>
<td>Fill And Crossfade</td>
<td>Trims region end points and automatically adds a pre-fade (in ms) directly before each region start point.</td>
</tr>
</tbody>
</table>

5 Click the Smooth button to smooth the edits for the selected regions.

Audition the new conformed regions by clicking Play in the Transport window. If necessary, select Edit > Undo and adjust the Crossfade Length.

**Edit Smoothing Creates Sync Points**

After smoothing edits with Beat Detective, sync points (corresponding to the material’s start point) are automatically created for the conformed regions. This allows you to later conform the regions to a different tempo map, or with a different set of Conform settings.
Consolidating Regions after Edit Smoothing

The process of separating, conforming, and smoothing with Beat Detective can leave tracks with many regions and many crossfades. If you are working with multiple tracks, the density of these edits may lead to system performance problems.

Once you are satisfied with the results from Beat Detective, it is recommended that you “flatten” the tracks with the Consolidate Selection command, thereby writing contiguous audio files and regions, which are easier to play. See “Consolidate Selection Command” on page 260.

⚠️ Before consolidating a large selection across multiple tracks, make sure there is enough RAM available. See “RAM Requirements for Beat Detective” on page 283.

Beat Detective and Collection Mode

In some instances, it may be difficult for Beat Detective to successfully analyze multiple tracks with the same Detection settings. With Beat Detective’s Collection mode, you can collect a set of beat triggers from different tracks, each with different Detection settings, and use the collection of triggers to generate Bar|Beat Markers or separate new regions.

This method of selectively adding beat triggers from separate analysis passes on different tracks, until you get only the triggers you want, is potentially much more effective than manually deleting, inserting, or adjusting incorrect or false triggers.

Drum Tracks and Collection Mode

Suppose you have drum tracks for kick, snare, toms, and overhead mics. If you analyze a selection across all of the tracks, you may get many false triggers when you raise the Sensitivity slider high enough to capture the hi-hat material (coming mainly from the track for the overhead mics).

However, if you analyze only the track for the overhead mics, the resulting beat triggers are slightly later than the material on the other tracks (since sound travels more slowly to the overhead mics). If you then extend the selection to the other drum tracks and separate, the regions from the kick, snare, and toms tracks will be cut slightly late.

With Collection mode, you can analyze each drum track separately, one at a time, optimizing the Detection settings for each track until you get the desired triggers. The triggers for each track are added successively to the collection, which can then be used to generate Bar|Beat Markers or separate new regions.

Using Collection Mode

Collection mode is accessed by clicking the Collection Mode button from the Bar|Beat Marker Generation or Region Separation page.

Beat Detective, Collection mode options

---

294 Pro Tools Reference Guide
To use Beat Detective’s Collection mode:

1. Define the selection for the first audio track you want to analyze (see “Defining the Selection for Beat Detective” on page 286).

2. Adjust the Detection parameters so the desired beat triggers appear (see “Detecting Transients with Beat Detective” on page 287).

3. Click the Collection Mode button.

4. In the Collection Mode sub-pane, click Add to add the current beat triggers to the collection.

5. Click the Normal Mode button and repeat the previous steps for each track you want to analyze. Make sure to keep the selection range the constant for each track. Each new set of triggers added to the collection appears in a different color.

If successive triggers in the collection are located closely together (because of mic leakage), Beat Detective keeps only the earlier triggers.

6. Once the desired beat triggers have been added to the collection, you can use them to generate Bar|Beat Markers, or separate new regions. This must be done from the Collection Mode sub-pane (when the triggers are displayed in multi-colors).

💡 To separate regions across multiple tracks, make sure to extend the selection to any additional tracks before separating.

⚠️ The Beat Triggers stored in the Collection mode are saved with sessions. Therefore, when you later open a session, the previous collection material is still there (until you clear it).
Part V: MIDI Editing
Chapter 23: MIDI Editing

You can edit individual MIDI notes and controller events with the Pencil, Trimmer, and Grabber. You can also use the various MIDI Operations (Quantize, Transpose, Change Velocity, and Change Duration) to transform groups of MIDI notes to affect pitch, timing, and phrasing. For information on region-specific editing for both MIDI and audio, see Chapter 17, “Working with Regions and Selections.”

Inserting MIDI Notes with the Pencil Tool

In addition to recording and importing MIDI into Pro Tools, you can manually insert MIDI notes with the Pencil tool.

To insert a MIDI note with the Pencil:

1. Set the MIDI track’s Display Format to Notes.
2. Select the Pencil tool and make sure it is set to Freehand.
3. Set the Time Scale to Bars:Beats. In addition, set the Edit mode to Grid and the Grid value to quarter notes (0|1|000).

With these settings, quarter notes will be inserted on the beat.

4. Move the Pencil into the playlist area for the MIDI track. Use the Edit window’s Ruler and the track’s mini-keyboard to locate the desired pitch and location.

When using the Pencil, the Current Cursor display in the upper right of the Edit window provides feedback on its location.

5. When the desired pitch and location are located, click to insert the note.
The velocity for inserted notes is determined by the “Default Note On Velocity” setting in the MIDI Preferences. The duration of the note is determined by the Edit window’s Grid value. If the MIDI Preferences option for “Play MIDI notes with Grabber and Pencil Tools” is enabled, each inserted note will sound.

The Pencil can be dragged after clicking (and before releasing) to adjust the note’s pitch or duration.

Click and drag right to lengthen the note without changing its start point, click and drag left to lengthen the note without changing its end point.

With Grid mode enabled, Command-drag (Macintosh) or Control-drag (Windows) with the Pencil to snap the note’s end point to the nearest Grid boundary.

The Pencil tool shapes (Line, Triangle, Square, and Random) can be used to enter a series of identical pitches with varying velocities. The length and spacing for the inserted notes is determined by the current Grid value. The note velocities are determined by the Pencil shape.

Use the Square shape for alternating velocities of loud and soft. Use the Triangle shape for a ramp up and down of velocities. The Line shape enters notes with identical velocities.

To insert a series of notes with random velocities:

1. Set the MIDI track’s Display Format to Notes.
2. Select the Pencil tool and make sure it is set to Random.

3. Set the Time Scale to Bars:Beats. In addition, set the Edit mode to Grid and the Grid value to quarter notes (0|1|000).

With these settings, the inserted notes will be spaced one quarter note apart.
4. Click at the point where the first note will be inserted and drag to the right.

5. When the desired number of notes are visible, release.
Manually Editing MIDI Notes

All aspects of a MIDI note can be edited from the Edit window, including start and end points, duration, pitch, and velocity. The Grabber and Selector can operate on individual notes or groups of notes.

Selecting MIDI Notes

To select a group of MIDI notes:

- With the Grabber, Shift-click each note.
- or -

- With the Grabber, move the cursor to where there are no notes (the Marquee appears) and click and draw a rectangle around the group of notes.

When using the Grabber, if any portion of the rectangle touches a note (either its start or end point), the note is included in the selection. Selections made with the Grabber do not include underlying controller and automation data.

To select a single pitch for the entire length of a track:

- On the mini-keyboard, Command-Shift-click (Macintosh) or Control-Shift-click (Windows) the note.

To remove one or more notes from a selection:

- With the Grabber, Shift-click the notes so they become deselected.

Transposing Notes with the Grabber

MIDI notes can be transposed by dragging up or down with the Grabber. If several notes are selected before dragging, each is transposed.

To transpose a MIDI note:

1. Set the MIDI track’s Display Format to Notes.
2. Select the Grabber tool.
3. While pressing Shift, drag the note up or down.
The Shift key ensures that the transposed note retains its start point. While dragging, each new note sounds and the Current Cursor display indicates the number of semitones and direction (+/-) for the transpose.

To transpose a copy of the note, leaving the original unchanged, press Option (Macintosh) or Control (Windows) while dragging.

Moving Notes with the Grabber

Like regions, MIDI notes can be dragged left or right with the Grabber to change their start point. If several notes are selected before dragging, each is moved.

To move a MIDI note:

1. Set the MIDI track’s Display Format to Notes.
2. With the Grabber, drag the note left or right (press Shift while dragging to preserve the note’s pitch).

As the note is dragged, the Current Cursor display indicates the new start point.

If the Edit mode is set to Grid, the dragged note snaps to the nearest Grid boundary. If the Edit mode is set to Spot, the Spot dialog opens.

To copy the selected notes, leaving the originals intact, press Option (Macintosh) or Control (Windows) while dragging.

The placement of MIDI notes can also be adjusted with Shift (see “Shift Command” on page 227) or Nudge (see “Nudging” on page 225).

Trimming Note Start and End Times

Like regions, start and end points for MIDI notes can be adjusted with the Trimmer tool. If several notes are selected when performing the trim, each note is changed.

To change the end points for a group of MIDI notes:

1. Set the MIDI track’s Display Format to Notes.
2. Using the Grabber, Shift-click each note you want to trim.
3. Select the Trimmer tool. For TDM systems, make sure the Standard Trimmer is selected in its pop-up menu.
4. Move the cursor near the end of any of the highlighted notes, so the Trim cursor appears. Drag left to shorten the notes, drag right to lengthen them.

If using Grid mode, the dragged start/end point snaps to the nearest Grid boundary. If using Spot mode, the Spot dialog opens, where you can enter the new location for the note’s start or end point.

Notes can also be trimmed with the Trim To Selection command (see “Trim To Selection Command” on page 215) and the Trim To Insertion command (see “Trim To Insertion Command” on page 220).
Manually Editing Note Velocities

When a MIDI track’s Display Format is set to Velocity, each note’s attack velocity is represented with a velocity stalk. The taller the velocity stalk, the higher the velocity value (0-127).

To edit a velocity stalk with the Grabber:

1. Set the MIDI track’s Display Format to Velocity.
2. Select the Grabber tool.
3. Drag the top (diamond) of the velocity stalk up or down.

– or –

If two notes have the same start time (with velocity stalks on top of each other), Command-drag (Macintosh) or Control-drag (Windows) the actual note up or down.

Drag up to increase the velocity value, down to decrease it. While dragging, the diamond turns blue and the associated note becomes selected. The dragged velocity values are reflected in the Current Cursor display.

The velocities for a range of notes can be edited with the Pencil tool, either by Freehand or with any of the Pencil tool shapes.

To draw velocity values that fade in:

1. Set the MIDI track’s Display Format to Velocity.
2. Select the Pencil tool with the shape set to Line.
3. Click at the beginning of the note range, near the bottom of the velocity range, and drag to the right and up.

4. Once the line encompasses the desired range of notes, along with the desired steepness of the fade, release.

You can also use the Trimmer tool to scale the velocities for all selected notes. This is useful if you like the velocity relationship between the notes, but want them to be louder or softer.

To scale velocities with the Trimmer:

1. Set the MIDI track’s Display Format to Velocity.
2. Using either the Selector or Grabber, select the range of notes to be edited.
3. With the Trimmer, click near the range of selected notes and drag up or down. Dragging up boosts the velocities for each note, dragging down reduces them.
Typing in Note Attributes

When an individual note is selected with the Grabber, its attributes are displayed in the Event Edit area.

Pitch is listed by note name and octave number. Attack and release velocities are listed with their MIDI values (0-127). Times for Start, End, and Length are displayed in the Main Time Scale.

To change an attribute for a MIDI note:

1. In the MIDI track’s playlist area, select the note with the Grabber.
2. Click in the Attribute’s text box and do one of the following.
   - Enter the new value on the numeric keypad.
   - Press the Up or Down Arrow to scroll to the new value.
   - While pressing Command (Macintosh) or Control (Windows), drag up or down to scroll to the new value.
   - Play the new note value on your MIDI controller keyboard.

Press the slash key to move between the fields in the Event Edit area.

Multiple Notes and Event Edit Area

When multiple notes are selected, you can enter values in the Event Edit area fields to affect all selected notes.

A new value in the Start field moves the first note in the selection to that location, with all other notes moving with it.

Values entered in the pitch and velocity fields add to or subtract from the values for all selected notes. For example, to transpose all selected notes down an octave, enter a value of –12 for pitch.

Deleting MIDI Notes

In addition to deleting selected notes with the Clear command in the Edit menu, individual notes can also be deleted with the Pencil tool.

To delete a group of MIDI notes with the Clear command:

1. With the Grabber or Selector, select the notes to be deleted. For details, see “Selecting MIDI Notes” on page 301.
2. Choose Edit > Clear to delete the selected notes. The track’s underlying controller data remains intact.

⚠️ When deleting MIDI notes within a time range selection, all underlying controller and automation data is also deleted.
To delete a single MIDI note with the Pencil:
- With the Pencil tool selected, press Option (Macintosh) or Alt (Windows) so the tool changes to an Eraser, then click the note to delete it.

Deleting a note with Pencil

Program change events and sysex events can also be deleted by Option-clicking (Macintosh) or Alt-clicking (Windows) them with the Pencil tool.

Continuous Controller Events

Continuous controller events for MIDI tracks are displayed in the form of a line graph with a series of editable breakpoints. Controller events for MIDI tracks differ somewhat from automation data for audio tracks in that the breakpoints are stepped (instead of vector-based), where each breakpoint represents a single controller event.

MIDI track displaying volume events

Continuous controller events that can be inserted and edited in Pro Tools include:
- volume
- pan
- pitch bend
- aftertouch (mono)
- MIDI controllers, 0–127

Polyphonic aftertouch cannot be viewed in the Edit window. To view polyphonic aftertouch in Pro Tools, use the MIDI Event List (see Chapter 25, “MIDI Event List”).

MIDI controller #7 (volume) and #10 (pan) are treated by Pro Tools as automation data. This means that these controller events (along with Mutes) can be recorded and automated from the Mix window; in addition, each MIDI track’s automation mode affects how these events are played back and recorded.

While a MIDI track’s volume and pan (and mute) events can be suspended, all other controller events in the track always play.

Continuous controller events (including volume and pan) can be recorded from an external MIDI controller (such as a keyboard or control surface), and they can be inserted in a MIDI track’s playlist with the Grabber or Pencil.
Inserting/Editing Controller Events

Continuous controller events can be edited with any of the following methods:

- Individual breakpoints can be dragged with the Grabber to adjust their location or value.
- A group of selected breakpoints can be scaled up or down with the Trimmer.
- New controller events can be drawn in with the Pencil tool to replace existing events. Events can be drawn with the Pencil set to Freehand, or using any of the shapes (Line, Triangle, Square, or Random).
- Controller events can be copied and pasted, nudged, and shifted.

For details on these editing procedures, see Chapter 28, “Automation.”

⚠️ Edits to volume data affect all tracks within an enabled Edit Group. This is not the case, however, for other controller playlists (such as pan). To insert and edit other controller types across all tracks in an Edit Group, press Control (Macintosh) or the Start key (Windows) while performing the edits.

Resolution for Inserted Controller Events

When inserting controller events with the Pencil, the density of the events is determined by the MIDI Preference for “Pencil Tool Resolution When Drawing Controller Data.”

Program Changes

Each MIDI track can have a default program change that is sent each time the track plays. Additional program changes can be inserted at any point within the track.

About Program and Bank Changes

The MIDI protocol lets you choose from a range of 128 programs (0-127). Most MIDI instruments have several banks of 128 programs. To specify which bank you’re selecting from, a bank select message must be sent. Some instruments use Controller 0 to switch the bank while others use Controller 32; some use a combination of the two. The Program Change window in Pro Tools allows you to use either of these bank select messages when inserting a program change event. Check with the manufacturer’s documentation to see which message your device uses.

Bank Changes for Older MIDI Devices

Some older MIDI devices (such as the Kurzweil K1000) use a program change instead of a Bank Select message to switch banks. For these devices you may find it necessary to send two program change messages to access a particular program, where the first sets the bank and the second sets the program.

To set the Pencil tool resolution:

1. Choose Setups > Preferences and click MIDI.
2. Enter a value for “Pencil Tool Resolution When Drawing Controller Data.” The value range is from 1 to 100 milliseconds.
3. Click OK.
OMS Name Manager
(Macintosh Only)

If your MIDI devices are subscribed to OMS patch names, these names will appear in the Program Change window in Pro Tools, and also in the inserted program change events. If not, programs will be selected and viewed by number.

If OMS has a factory names document for any of the MIDI devices in your Studio Setup, these factory names are automatically subscribed and appear in Pro Tools.

You can also open the OMS Names window from Pro Tools and subscribe to names from patch editor/librarian software, or even enter your own custom patch names.

To open the OMS Names window:
- Choose Setups > OMS Names.

OMS Names window
For details on using the OMS Names window, refer to the online OMS Name Manager manual included on the Pro Tools CD-ROM.

How to Customize OMS Names
(Macintosh Only)

To enter your own list of customized names:
1. Choose Setups > OMS Names.

2. Click the Patch Name Document in the Patch Name Document column for the desired OMS device. If there is no document present yet, click the empty space next to the OMS device.

3. Choose Names > View/Edit Patch Names to open the Patch Name window. Note that the Names menu item has changed to Patches.

4. Type your patch names for the corresponding program numbers. If you are using a third party librarian software, or if you have a list of patch names in your word processor, you can quickly copy and paste these names into this window. See below for more information.

5. Click OK to confirm the changes.

6. Click Save in the Save Changes dialog. We recommend always saving patch name files to System Folder/OMS Folder/Factory Names so they will be easier to find.

7. Click OK in the OMS Names dialog. Once the MIDI track’s output has been set to the corresponding OMS device, you should see your patch names instead of numbers for your device in the Pro Tools patch dialog.
To copy names from another application into OMS Names:

1. If you are using a word processor, make sure the names in the list are separated by a carriage-return (Return-key).

   – or –

If you are using a third party patch name librarian software, make sure that it allows you to copy from its list of patch names.

2. Select the desired names, then choose Copy in your word processor or librarian software to copy the list of names to the clipboard.

3. Launch Pro Tools and choose Setups > OMS Names.

4. Click the Patch Name Document in the Patch Name Document column for the desired OMS device. If there is no document present yet, click the empty space next to the OMS device.

5. Choose Names > View/Edit Patch Names to open the Patch Name window. Note that the Names menu item has changed to Patches.

6. Choose Patch > Paste Patch Names to paste your patch names from the clipboard into the Patch Name Document List.

7. Click OK to confirm the changes.

8. Click Save in the Save Changes dialog. We recommend always saving patch name files to System Folder/OMS Folder/Factory Names so they will be easier to find.

9. Click OK in the OMS Names dialog. Once the MIDI track's output has been set to the corresponding OMS device, you should see your patch names instead of numbers for your device in the Pro Tools patch dialog.

For more details on using the OMS Names window, please refer to OMS documentation.

**Default Program Change**

(Using the Program Button)

The default program change for each MIDI track is specified by clicking on the Program button, from either the Edit or Mix window. Once specified, the default program change message is sent to your instrument when playing the track.

To set the default program change for a MIDI track:

1. From the Edit or Mix window, click the Program button.

   Program button, Edit window

The Program button in the Edit window (if the Track Height is set to Medium or Larger) displays the name of the default program, or “none” if one has not yet been specified. The Program button in the Mix window (and in the Edit window when the Track Height is set to Small), is labeled as “P.”

2. In the Program Change window, select a program number.

Program Change window
3 If subscribed to OMS names, choose a bank from the pop-up menu in the upper right of the Program Change window.

4 Click Done.

Once selected, the program number (or name) appears in the Program button in the Edit window. To clear the default program change, select None in the Program Change window.

Unlike recorded and inserted program change events, the default program change does not appear in the track's playlist.

**Inserting/Editing Program Changes**

Program changes can be inserted into a track's playlist with the Pencil tool. Existing program changes can be edited, moved, and copied and pasted.

> **On some instruments, changing programs during playback can interrupt playback. To avoid this, place program change events in the track where there are no notes sounding.**

**To insert a program change with the Pencil:**

1. Set the MIDI track's Display Format to Program.
2. If desired, set the Edit mode to Grid so the inserted event snaps to the Grid.
3. Click with the Pencil in the track's playlist at the point where you want to insert the program change.
4. In the Program Change window, select a program number (or name) and, if necessary, specify a bank change value.
5. Click Done to insert the program change event in the track's playlist.

**To edit a program change event:**

1. With the Grabber, double-click the program change event you want to edit.
2. In the Program Change window, select the new program number (or name) and, if necessary, specify a bank change value.
3. Click Done.

**To move a program change event:**

- With the Grabber, drag the program change event left or right.

If the Edit mode is set to Grid, the dragged event snaps to the nearest Grid boundary. If the Edit mode is set to Spot, the Spot dialog opens.

> **The placement of program changes can also be adjusted with Shift (see "Shift Command" on page 227) or Nudge (see "Nudging" on page 225).**
To delete a program change event:

1. With the track’s Display Format set to Notes, click the program change event with the Grabber to select it.

   – or –

If the region contains other events you want to delete, select the entire region with the Grabber (when the track is displaying regions).

2. Choose Edit > Clear to remove the selected events from the track.

Individual program change events can also be deleted by Option-clicking (Macintosh) or Alt-clicking (Windows) them with the Pencil.

Auditioning Programs

When the Program Change window is open, you can have Pro Tools automatically scroll through the different patches for a track’s assigned MIDI device.

To audition patches from the Program Change window:

1. To audition patches for a MIDI track while it plays, click Play in the Transport window.

2. Open the Program Change window by clicking the Program button in the Mix window, or by inserting or editing a program change event in a MIDI track.

3. Click a program number—the starting point from which you will scroll through the patches.

4. If desired, enter a value for the number of seconds that will elapse between each program change.

5. Select the option for Increment Patch.

After the specified number of seconds, Pro Tools selects the next patch and transmits the program change to the track’s assigned MIDI device. As desired, play your MIDI controller to audition the new patches.

System Exclusive Events

System Exclusive (sysex) events can be recorded to MIDI tracks in Pro Tools (see “Recording System Exclusive Data” on page 160). Once the events are recorded, they appear in the track’s playlist as blocks when the Display Format is set to Sysex.

To move a sysex event:

1. Set the MIDI track’s Display Format to Sysex.

2. With the Grabber, drag the sysex event left or right.

If the Edit mode is set to Grid, the dragged event snaps to the nearest Grid boundary. If the Edit mode is set to Spot, the Spot dialog opens.

The placement of sysex event blocks can also be adjusted with Shift (see “Shift Command” on page 227) or Nudge (see “Nudging” on page 225).
To delete one or more sysex events:

1. With the track’s Display Format set to Sysex, click the sysex event with the Grabber to select it.
   – or –

If the region contains other sysex events you want to delete, select the entire region with the Grabber (when the track is displaying regions).

2. Choose Edit > Clear to remove the selected events from the track.

Individual sysex event blocks can also be deleted by Option-clicking (Macintosh) or Alt-clicking (Windows) them with the Pencil tool.

Note and Controller Chasing

Note Chasing allows long, sustained MIDI notes to be heard when playing from a point after their start time. For example, if a note’s start time is at 1|1|000 and lasts for 8 measures (until 9|1|000), note chasing lets you begin playing from bar 5 and still hear the note that started at 1|1|000 as it continues to sustain until 9|1|000.

Note Chasing is something that can be turned on and off individually for each MIDI track. By default, new MIDI tracks have Note Chasing enabled.

To enable Note Chasing for a MIDI track:

- Click the track’s Playlist Selector and select the option for Note Chasing.

Make sure to disable Note Chasing when working with samplers that are playing loops. If a MIDI track, for example, is triggering a 4-bar drum loop and you begin playing at bar 3, the loop will begin playing at the wrong time and be out of sync with the other tracks.

Controller and Program Chasing

Pro Tools always chases continuous controller events and program changes for MIDI tracks. This ensures that controller values and patches for MIDI devices are always appropriately set.

For example, suppose a MIDI track lasting 32 measures starts with a volume of 127 and in the last bar fades the volume down to 0. If after playing the track in its entirety you attempt to play from bar 8, the initial volume of 127 is chased and sent to the track’s assigned device—otherwise the track would not be heard since the most recent volume event sent would have been 0.

Chasing also occurs for a MIDI track’s default program change, along with any program change events residing within the track. Therefore, if you have chosen a default program change for a track, when playing from any point within the track, the program change event is sent to the track’s assigned device.

Default Controller Values and Chasing

Though new MIDI tracks appear to have default values for continuous controller playlists, this is actually not the case. For example, when viewing a MIDI track’s Mod Wheel playlist, you’ll see that the breakpoint line is set to a default of zero. However, since the modulation wheel on your synth may purposely be set to a different value, the default value in the track is not transmitted when playing.
This can cause some confusion, however, if you insert a fade (for example, from 0–90) in the Mod Wheel playlist towards the end of the track. If you then play from the beginning of the track, or from anywhere before the fade, the Mod Wheel value on your synth will be at 90 until the beginning of the fade data is reached—which is likely not what you want.

To ensure that the default controller value for a playlist is sent (and chased), click the initial breakpoint at the beginning of the track, move it slightly, and set it back to the default value.

### Offsetting MIDI Tracks

Pro Tools can offset MIDI tracks globally or individually.

**Global MIDI Playback Offset**

Pro Tools offers a MIDI offset preference that allows MIDI tracks to play back earlier or later (than audio tracks) by a specified number of samples. The offset affects playback only and does not alter in any way how MIDI data is displayed in the Edit window.

This capability is provided in large part to compensate for the audio monitoring latency in Pro Tools LE. If you are monitoring the output of your MIDI devices with an external mixer or sound system (or headphones), there is no latency. If, however, you are monitoring the output of your MIDI devices through a Digi 001 (or Audiomedia III), your MIDI tracks will appear to play slightly later than your audio tracks. The larger the setting for the H/W Buffer Size (128, 256, 512, or 1024 samples), the larger the latency.

By configuring the Global MIDI Playback Offset, you can get your MIDI tracks to play back slightly earlier (by a specified number of samples), thereby compensating for the latency in monitoring audio within Pro Tools LE.

The metronome click is not affected by MIDI Global Offset.

**To configure the Global MIDI Playback Offset:**

1. Choose Setups > Preferences and click MIDI.
2. For the “Global MIDI Playback Offset” option, enter the number of samples (–10,000 to 10,000) for the offset. A negative value causes the MIDI tracks to play back earlier than the audio tracks, a positive value causes the MIDI tracks to play back later.
3. To allow for monitoring latency in Pro Tools LE, set the offset to a value that is roughly equivalent to the H/W Buffer Size.
4. Click Done.

> The Global MIDI Playback Offset can also be set from the MIDI Track Offsets window.

**Individual MIDI Track Offsets**

You can offset individual MIDI track offsets in Pro Tools to compensate for delays in MIDI devices (the time it takes to trigger events on a sampler or synth).

For example, if you have some kick drums that are being played by an audio track in Pro Tools and want them to be perfectly “in sync” with kick drums that are being played by a MIDI device, you may need to use a MIDI offset. In this example, it will usually take at least 5 ms to trigger the MIDI notes, and it could take even longer, depending on the MIDI device.
You can measure the latency for a MIDI device assigned to a MIDI track by recording its audio output back into Pro Tools. Compare the sample locations for the recorded audio events against the original MIDI notes to calculate the latency.

**To configure a MIDI track offset for a track:**

1. Choose Windows > Show MIDI Track Offsets.

   ![MIDI Track Offsets](image)

   **MIDI Track Offsets**

2. Click in the Sample Offset column for the MIDI track and enter the number of samples (–10,000 to 10,000) for the offset. A negative value causes the MIDI tracks to play back earlier than the audio tracks, a positive value causes the MIDI tracks to play back later.

   The equivalent offset in milliseconds is displayed in the Msec Offset column. The value in this column, indicated in italics, cannot be edited, and updates when a new value is entered in the SMPTE Offset column.

3. Press Return (Macintosh) or Enter (Windows) to accept the entered offset value.

   To reset all offsets for all MIDI tracks, click the Reset button in upper left of the window.

---

**Stuck Notes**

If you encounter stuck notes with any of your MIDI devices, you can silence them with the All Notes Off command.

**To turn off all stuck notes:**

- Choose MIDI > All Notes Off.

An All Notes Off message is sent to each channel for all devices in your setup.
Chapter 24: MIDI Operations

MIDI Operations Window

The MIDI Operations window opens when choosing any of the following commands from the MIDI menu:

- Quantize
- Change Velocity
- Change Duration
- Transpose
- Select Notes
- Split Notes
- Input Quantize

To reconfigure the MIDI Operations window for a different command, select the command from the MIDI menu or from the pop-up menu at the top of the window (see Figure 18).

The MIDI Operations window can be left open as desired, revisiting it as necessary to invoke a command, or to try out different options for a particular command.

To show or hide the MIDI Operations window:
- Choose Windows > Show MIDI Operations.

To invoke the command in the MIDI Operations window:
- Click Apply or press Enter on the numeric keypad. This invokes the command and leaves the window in the foreground.
  – or –
- Press Return (Macintosh) or Enter on the alpha keyboard (Windows). This invokes the command and moves the window to the background.

To undo the command in the MIDI Operations window:
- Choose Edit > Undo.
Using the MIDI Operations Window

Use the following methods to easily configure the various options, which vary from command to command, in the MIDI Operations window:

- To move forward and back through the various fields, press Tab or Shift+Tab.
- Increment or decrement selected fields with the Up/Down Arrows. Press and hold these keys to scroll quickly through the values.
- Command-drag (Macintosh) or Control-drag (Windows) up or down in a selected field to scroll to a new value.
- Press Command (Macintosh) or Control (Windows) while adjusting sliders for finer resolution.
- For selected pitch and velocity fields, play a note on your MIDI controller keyboard to automatically enter it.
- Changing a value for a particular parameter (such as the Swing Percentage in the Quantize window), automatically enables the parameter.

Select Notes

The Select Notes command allows you to further narrow a selection of MIDI notes based on pitch. The command can be used to select a single note or note range for the entire length of a region or track, or to select the upper or lower voices within chords.

Options for the Select Notes command include:

All Notes All notes are selected.

Notes Between Selects a range of notes between the specified upper and lower note. Values for the notes can be entered in pitch (C1–G8) or MIDI note numbers (0–127).

Top Selects the highest note or notes in each chord.

Bottom Selects the lowest note or notes in each chord.

Selecting a Pitch Range of Notes

A common use for Select Notes is to select a single note for the entire length of a region or track. This is especially useful if you want to select a note in a MIDI drum track (hi-hat, for instance), and affect it over the selected time range with the Quantize, Transpose, or Change Duration command.
To select only the hi-hats in a General MIDI drum track:
1. Using the Grabber or Selector, select the range of MIDI notes that contains the note.
2. Choose MIDI > Select Notes.
3. Select the Notes Between option with the note range set to F#1 and F#1.

For a General MIDI drum kit, the closed hi-hat is assigned to F#1 (MIDI note number 42). If the hi-hat for your drumkit is assigned to a different note, make sure to specify it.
4. Click Apply.

Selecting Notes in a Chord

Another use for Select Notes is to select only the upper or lower notes in a chord. Many times you’ll want to affect only the upper or lower notes in a chord—to boost their velocities, or transpose their pitch.

To select only the bass notes in a chord:
1. Using the Grabber or Selector, select the range of MIDI notes that contains the chords.
2. Choose MIDI > Select Notes.
3. Select the Bottom option and leave the number of notes set to 1.
4. Click Apply.

Split Notes

The Split Notes command has the same selection criteria as the Select Notes command, but also lets you automatically cut or copy the selected notes when clicking Apply.

Split Notes window

One use for this command would be if you recorded a track with chords in the left hand and melody in the right. With the Split Notes command, you could cut the melody notes and paste them to another track so you could assign them to play on a different device or channel. Another use is to split the various notes (kick, snare, toms etc.) from a single drum track to separate tracks.

To cut a specific pitch range of notes:
1. Using the Grabber or Selector, select the range of MIDI notes that contains the notes.
2. Choose MIDI > Split Notes.
3. In the Split Notes dialog, select the option for Notes Between and enter the low and high notes for the pitch range.

When either of the Pitch fields are selected, you can play a pitch on your MIDI controller to automatically enter it.
4. Select Cut.

In order for notes to be considered a chord, their start times must be within five ticks of each other.
Click Apply. Notes falling within the specified pitch range are removed from the selection and placed on the Clipboard. The notes can then be pasted or merged to another track.

**Quantize**

The Quantize command adjusts MIDI note locations and durations so that timing is improved, or so that a particular rhythmic “feel” is achieved. Quantize works by aligning notes to a Quantize Grid, the size of which is defined in the Quantize window by a standard note duration.

The Quantize command is not the same as the Quantize Regions command (in the Edit menu). The Quantize Regions command adjusts the start point for a selected region, and its contents are moved along with the region (with rhythmic relationships remaining intact).

The Quantize command, on the other hand, affects MIDI notes individually. Some notes may be moved back in time, others forward; and, some notes will be more drastically affected than others.

![Quantize window](image)

The settings in the Quantize window are saved with each session. To store your favorite settings as the default for use in future sessions, save them as part of a session template (see “Creating Custom Session Templates” on page 48).

**What to Quantize**

The options under “What to Quantize” determine which aspects of the notes are quantized: attacks, releases, or both.

- **Attacks** When selected, note start points are quantized.
- **Releases** When selected, note end points are quantized.
- **Don’t Change Durations** When deselected with the Attacks option selected, note end points are not moved. When deselected with the Releases option selected, note start points are not moved.

If the options for both Attacks and Releases are selected, the Don’t Change Durations option is ignored (and dimmed).
Chapter 24: MIDI Operations

Figure 19 shows how notes are adjusted by the different What To Quantize options.

**Quantize Grid**

The Quantize Grid determines the beat boundaries to which notes are aligned. Any size from whole notes to thirty-second notes (including dotted values) can be selected for the Grid size.

**Tuplet** Select the Tuplet option to quantize irregular note groupings like triplets or quintuplets. The Quantize Grid for tuplets is calculated from the note size selection and the Tuplet value. For instance, if an eighth note equals 480 ticks, tuplet eighth notes with 3 in time of 2 would yield a Grid size of 320 ticks (480 ticks / 3 * 2).

**Offset Grid By** Offsets the Quantize Grid forward or back in time by a specified number of ticks. Use this option to achieve a pushed (positive values) or laid back (negative values) feel.

💡 To Quantize just the backbeats, set the Quantize Grid to half-notes with an Offset of 960 ticks.

**Swing** When selected, every other Grid boundary is shifted by the specified percentage value (0-300) to achieve a “swing” feel. A Swing value of 0% yields no swing, while 100% yields a triplet feel. With Swing set to 300%, every other Grid boundary is moved to the next Grid point.

**Quantize Options**

Additional Quantize options include:

**Include Within** When selected, attacks and releases are only quantized if located within the specified percentage of the Quantize Grid. Use this option to clean up downbeats without affecting notes that are “swung” or wildly off the beat.
Figure 20 shows the Quantize Grid set to quarter notes with the Include Within option set to 50%. Only attacks and releases falling within the shaded area (equivalent to an eight note area around each beat) are quantized.

![Figure 20. Include Within option](image)

**Exclude Within** When selected, attacks and releases are not quantized if located within the specified percentage of the Quantize Grid. Use this option to preserve the feel of notes close to the beat, while correcting others that are drastically away from the beat.

Figure 21 shows the Quantize Grid set to quarter notes with the Exclude Within option set to 25%. Attacks and releases falling within the shaded area (equivalent to a sixteenth note area around each beat) are not quantized.

![Figure 21. Exclude Within option](image)

**Strength** When selected, notes are moved a percentage toward the Quantize Grid. Lower percentages preserve the original feel of the notes, higher percentages align the notes more tightly to the Grid.

**Randomize** When selected, notes are moved randomly forward or back in time (after the Quantize occurs). For instance, with the Quantize Grid set to eighth notes and Randomize set to 50%, notes are placed up to a 32nd note before or after the beat boundary. The Randomize setting also affects note durations (if Releases is selected).

### Quantize Examples

The following examples illustrate some of the more common uses for the Quantize command.

If you intend to loop playback while quantizing, you may want to deselect Operations > Link Edit and Timeline Selection. This ensures that the play range will not change when selected notes are moved in the course of quantizing and undoing.

⚠️ **While you can undo a Quantize operation, the Quantize command is destructive and permanently affects selected data. To preserve existing data, duplicate the playlist before quantizing.**

#### Straight Quantize

**To quantize to a straight sixteenth note feel:**

1. Select the range of MIDI notes to be quantized.
2. Choose MIDI > Quantize.
3. Under What to Quantize, select the Attacks option. To quantize note durations as well, select the Releases option.
4. Set the Quantize Grid to sixteenth notes. Make sure that the other options for Tuplet, Offset Grid By, and Swing are not selected.
5. Leave the remaining Quantize options deselected and click Apply.
Quantizing While Preserving the Original “Feel”

You can quantize less strictly, to preserve the original feel of your recorded MIDI tracks:

**To quantize while preserving the original feel:**
1. Select the range of MIDI notes to be quantized.
2. Choose MIDI > Quantize.
3. Under What to Quantize, select the Attacks option. To quantize note durations as well, select the Releases option.
4. Set the Quantize Grid to the desired note size. Make sure that the other options for Tuplet, Offset Grid By, and Swing are not selected.
5. Select the Exclude Within option with a value of 10-15%.
6. Select the Strength option with a value of 70-80%.
7. Leave the remaining Quantize options deselected and click Apply.

Audition the change and if the desired effect is not achieved, undo the edit and experiment with different values for Exclude Within and Strength.

Quantizing with Swing

If you’re working with hi-hats or bass lines, you may want to apply more of a swing feel to the track.

**To quantize with an eighth note swing feel:**
1. Select the range of MIDI notes to be quantized.
2. Choose MIDI > Quantize.
3. Under What to Quantize, select the Attacks option. To quantize note durations as well, select the Releases option.
4. Set the Quantize Grid to eighth notes.
5. Select the Swing option with the desired Swing percentage:
   - For a light swing, use 12%.
   - For a tighter swing-like groove, use 24%.
   - For a true “triplet-like” swing feel, use 50–75%.
6. Make sure the options for Tuplet, Offset Grid By, and Randomize are not selected. Click Apply.

Audition the change and if the desired effect is not achieved, undo the edit and experiment with a different Swing percentage.

Quantizing with Randomize

You may find that after quantizing, notes sound too mechanical, too “on the beat.” You can use the Randomize option in the Quantize window to make them sound more natural.

**To humanize the rhythmic feel of notes:**
1. Select the range of MIDI notes to be quantized.
2. Choose MIDI > Quantize.
3. Under What to Quantize, select the Attacks option. To quantize note durations as well, select the Releases option.
4. Set the Quantize Grid to the desired note size.
5 Select the Randomize option with a value of 5%.

6 Click Apply.

Audition the change and if the desired effect is not achieved, undo the edit and experiment with a different Randomize percentage.

**Experimenting with Quantize**

When using the Quantize command, you’ll often have to experiment with many of the parameters. In fact, you won’t always get the results you’re expecting. You may have to try different values for Include and Exclude Within, and Strength; these parameters determine which notes are affected and how drastically they are changed. In addition, the Randomize parameter, which adds a percentage of randomness to the quantize, can be used to make tracks feel less mechanical—less perfect.

Although quantize is a wonderful tool for cleaning up tracks and playing with the feel of your music, sometimes the recorded data may not be salvageable. In these instances it is wise not to spend too much time trying to fix something that should probably just be rerecorded.

---

**Change Velocity**

The Change Velocity command automatically adjusts attack and release velocities for selected MIDI notes. Use it to make notes louder or softer, or to create crescendos or decrescendos.

Velocities can also be edited manually with the Pencil and Grabber Tools (see “Manually Editing MIDI Notes” on page 301).

- Velocity values usually affect the loudness of MIDI notes. They may also affect other aspects of an instrument’s sound, such as filter cutoff, envelopes, and modulations.

- The settings in the Change Velocity window are saved with each session. To store your favorite settings as the default for use in future sessions, save them as part of a session template (see “Creating Custom Session Templates” on page 48).

To open the Change Velocity window, choose MIDI > Change Velocity. Options for the Change Velocity are discussed in the following section.
While there are options for adjusting both the attack and release velocities for notes, most MIDI devices ignore release velocity information. To see if your instrument supports release velocities, refer to the manufacturer’s documentation.

**Set All To** Sets all velocities to the specified value (1–127).

**Add** Adds to existing velocity values by the specified amount (1–127).

**Subtract** Subtracts from existing velocity values by the specified amount (1–127).

**Scale By** Scales all velocities by a percentage amount (1–400%).

**Change Smoothly** Allows velocities to change smoothly from one value to another over time.

**Change Smoothly by Percentage** Allows velocities to change smoothly from one percentage value to another over time.

The curve for this change can be adjusted (+/– 99) to affect how gradually the change occurs.

**Limit To** When selected, restricts the Change Velocity command to a minimum and maximum range.

**Randomize** When selected, the Change Velocity command is randomized by the specified percentage value. For instance, using “Set all to” with a value of 64, along with a Randomize value of 50%, yields velocities anywhere between 48 and 80 (+/– 25% of the velocity value).

**Velocity Ranges**

The valid range for MIDI note velocities is 1–127. The Change Velocity command will never result in moving velocities outside this range; 1 will always be the lowest and 127 will always be the highest. This means that you may reach a state where the Change Velocity command has no effect on a particular note.

For instance, if a note with a velocity 64 is scaled by 200%, the new velocity would be 127. Attempting to scale or increase the velocity any further would yield no change.

**Fading Velocities**

An interesting musical effect is when velocities get gradually louder or softer over time. This can be used to make notes fade in or out, or to provide timbral variations in the way that a MIDI instrument sounds.
To change velocities smoothly over time:

1. Select the range of MIDI notes to be edited.
2. Choose MIDI > Change Velocity.
3. Select the Change Smoothly option with the range set from 127 to 0.
4. Click Apply.

To preserve (somewhat) the existing velocity relationships and still achieve velocity fades, use the option for Change Smoothly by Percentage. Figure 22 illustrates the difference between the two Change Smoothly options.

Scaling Velocities

Many times existing note velocities will have the desired relationship between each other, but will either be too soft or too loud as a whole. In these instances, use the Scale By option.

For instance, to make velocities 20% louder:

1. Select the range of MIDI notes to be edited.
2. Choose MIDI > Change Velocity.
3. Select the Scale By option with the percentage value set to 120.
4. Click Apply.

Change Duration

The Change Duration command adjusts durations for selected MIDI notes. Use it to make melodies and phrases more staccato or detached, or more legato.

The settings in the Change Duration window are saved with each session. To store your favorite settings as the default for use in future sessions, save them as part of a session template (see “Creating Custom Session Templates” on page 48).

To open the Change Duration window, choose MIDI > Change Duration. Each of the Change Duration options is discussed in the following section.
Set All To  Sets all durations to a length specified in quarter notes and ticks.
Add   Adds to the durations by a specified number of quarter notes and ticks.
Subtract  Subtracts from the durations by a specified number of quarter notes and ticks.
Scale by  Shortens or lengthens durations based on a percentage value (1–400%).
Move Releases to the Closest Attack  Shortens or lengthens durations so that end times are moved to the closest attack.
Extend Releases to the Next Attack  Lengthens durations so that end times are extended to the next attack. To limit the duration change, select either of the Add No More Than options, using either a percentage value or a number of quarter note and ticks.
Change Smoothly  Allows note lengths to change smoothly from one duration to another over time. Duration values are specified in quarter notes and ticks.
Change Smoothly by Percentage  Allows note lengths to change smoothly from one percentage value to another over time.
The curve for this change can be adjusted (+/− 99) to affect how gradually the change occurs.
Limit Range  When selected, restricts the Change Duration command to a minimum and maximum range (in quarter notes and ticks).
Randomize  When selected, the Change Duration command is randomized by the specified percentage value. For instance, using “Set all to” with a value of 480 ticks, along with a Randomize value of 50%, yields durations anywhere between 360 and 600 (+/− 25% of the duration value).

Change Duration Examples

To make notes more staccato:
1 Select the range of MIDI notes to be edited.
2 Choose MIDI > Change Duration.
3 Select the option for Scale By with a percentage value of 50.
4 Click Apply. The durations for the selected notes are reduced by 50%.

With this option you may have to experiment with the percentage value to achieve the desired effect.

To make notes more legato:
1 Select the range of MIDI notes to be edited.
2 Choose MIDI > Change Duration.
3 Select the option “Extend Release to the Next Attack.”
4 Click Apply. The end points for the selected notes are extended to the start points of the next note, thereby eliminating the space between each note.

To vary this effect, making it more or less legato, select the Add No More Than percentage option. Percentage values larger than 100 extend note end times so that the notes essentially overlap.
**Transpose**

While the Grabber Tool can be used to manually transpose individual MIDI notes, or small groups of notes, the Transpose command can be used for entire MIDI tracks and regions.

To open the Transpose window, choose MIDI > Transpose.

The two options for the Transpose command are:

**Transpose By (Semitones)** Transposes chromatically, up or down, by up to 60 semitones. To transpose down by an octave, for instance, use −12 semitones.

**Transpose (From, To)** Transposes by semitones, as expressed by the difference between the source and destination pitches. Transposing from C4 to C#4, for instance, transposes the notes up by one semitone.

One of the more common uses for Transpose is to change the key for your MIDI tracks. You can define an Edit Group for MIDI tracks that you want to transpose, making sure to exclude any drum tracks from the group so they aren't transposed.

**To transpose MIDI notes to another key:**

1. If you will be transposing a group of tracks, make sure to enable the Edit Group.
2. With the Selector or Grabber, select the range of MIDI notes to be transposed.
3. Choose MIDI > Transpose.
4. Select the option for Transpose (From, To).
5. Set the “From” and “To” values, for instance, to C4 and E4 to transpose from C Major to E Major.

With either of the pitch fields selected, you can play a note on your MIDI controller to automatically enter it as the pitch value.

6. Click Apply.

**It is also common to transpose MIDI tracks up or down by an octave.**

**To transpose a MIDI track up by an octave:**

1. With the Selector, double-click in the track to select all of its notes.
2. Choose MIDI > Transpose.
3. Select the Transpose By option.
4. Enter a value of 12 semitones and then click Apply.
Chapter 25: MIDI Event List

The MIDI Event List

The MIDI Event List displays a detailed list of all events in a single MIDI track. The events are displayed with text and numbers, allowing you to precisely edit their location, length, and event values.

Events in the MIDI Event List can be copied and pasted, selected, or deleted. Any MIDI event (except sysex) can be inserted and edited in the list. Certain MIDI event types can be hidden with the View Filter.

Unlike playlists in the Edit window, you can insert and display polyphonic aftertouch in the MIDI Event List.

Mute data for MIDI tracks is not displayed in the MIDI Event List.

Opening the MIDI Event List

To open the MIDI Event List, do one of the following:

- Choose Windows > Show MIDI Event List.
- Control-double-click (Macintosh) or Start-double-click (Windows) a track name in the Edit or Mix window.
- Press Option+Equal (Macintosh) or Alt+Equal (Windows).

You can also use Option+Equal (Macintosh) or Alt+Equal (Windows) to toggle between the MIDI Event List and the Edit window.

At the top of the MIDI Event List are three pop-up menus:

MIDI Track Selector Indicates the MIDI track currently displayed, and can be used to choose a different MIDI track to be displayed.

Options Menu Contains commands and options for the MIDI Event List (see “MIDI Event List Options” on page 334).

Insert Menu Contains a list of event types that can be inserted.
To the right of these pop-up menus, the number of displayed events is indicated.

**Columns in the MIDI Event List**

Information for the events in the MIDI Event List is displayed in the following three columns:

- **Start Column**: Displays the start location, using the Main Time Scale, for each event. Locations can also be displayed in the Sub Time Scale when the Show Sub Counter option is selected in the Options pop-up.

  The Playback cursor appears as a blue arrow (red, when tracks are record-enabled) in the Start column.

- **Event Column**: Displays the event type, indicated by an icon, and associated event values.

- **Info Column**: Depending on which option is selected in the Options pop-up, displays the end point or length for notes. Also displayed are the names for continuous controller events and program changes.

<table>
<thead>
<tr>
<th>start</th>
<th>event</th>
<th>length/info</th>
</tr>
</thead>
<tbody>
<tr>
<td>11:10:00</td>
<td>F4 46 64</td>
<td>11:01:124</td>
</tr>
<tr>
<td>11:10:00</td>
<td>7 90</td>
<td>volume</td>
</tr>
<tr>
<td>11:10:00</td>
<td>0 - -</td>
<td>C</td>
</tr>
</tbody>
</table>

  *Double-click dimmed locations to edit them*

  When several events reside at the same location, the location is only indicated for the top event, with the others dimmed. The dimmed locations can be edited by double-clicking them.

- **Navigating in the MIDI Event List**

  You can use the Tab and Arrow keys to move through the MIDI Event List. You can also locate to the Edit start point, or any other specified location.

  **To move through the MIDI Event List:**

  - Press Tab or the Down Arrow to move to the next event.
  - Press Option+Tab or the Up Arrow to move to the previous event.

  To keep the last event selected, press Shift while moving to the next or previous event.

  **To go to the Edit start point:**

  - In the MIDI Event List, choose Scroll To Edit Selection from the Options pop-up menu.
To go to a specific location in the MIDI Event List:

1. In the MIDI Event List, choose Go To from the Options pop-up menu.
2. In the Go To dialog, choose a format from the Time Scale pop-up menu.
3. Enter the location you want to go to, then click OK.

The Go To dialog

If using Time Code (TDM systems only), you can select the Use Subframes option.

The following items from the Options menu affect navigating in the MIDI Event List:

- When Page Scroll During Playback is selected, the MIDI Event List scrolls during playback.
- When Scroll During Edit Selection is selected, the MIDI Event List is scrolled automatically when the Edit selection changes in the Edit window.

View Filter for MIDI Event List

You can use the View Filter to specify which event types are displayed in the MIDI Event List. This can help you zero in on only the events you want to affect; it also protects MIDI events from being edited or deleted. Events not displayed in the MIDI Event List still play back.

The View Filter can be set to display “all” messages, “only” the specified messages, or “all except” the specified messages.
Inserting Events in the MIDI Event List

You can insert events in the MIDI Event List by choosing an event type from the Insert menu. Following are several examples of inserting events in the MIDI Event List.

**To insert a note in the MIDI Event List:**

1. Click the Insert button and choose Note from the pop-up menu.
   
   – or –

   Press Command+N (Macintosh) or Control+N (Windows).

2. Enter the location, pitch, attack and release velocities, and length for the new note. To move between the Event Entry fields, use the Left and Right Arrow keys.

   When a field is selected, enter a value with any of the following methods:
   
   • Enter the value on the numeric keypad.
   
   • Press the Up or Down Arrow to scroll to the value.
   
   • While pressing Command (Macintosh) or Control (Windows), drag up or down to scroll to the value.
   
   • Play the note on your MIDI controller keyboard, then press Return (Macintosh) or Enter (Windows) on the alpha keyboard to confirm the value.

   With the Start field selected, you can automatically enter the location of another event already in the track by clicking that event.

3. To insert the note and remain in Event Entry mode, press Enter on the numeric keypad.
   
   – or –

   To insert the note and exit Event Entry mode, press Return (Macintosh) or Enter (Windows) on the alpha keyboard.

   – or –

   To exit Event Entry mode, without inserting the note event, press Escape on the alpha keyboard.

**To insert a controller event in the MIDI Event List:**

1. Click the Insert button and choose Controller from the pop-up menu.

   – or –

   Press Command+L (Macintosh) or Control+L (Windows).
2 Enter the location, controller “type” number, and controller value for the new event. The controller name is displayed in the “length/info” column, to the right of the controller value. To move between the Event Entry fields, use the Left and Right Arrow keys.

Event Entry fields for controller event

When a field is selected, enter a value with any of the following methods:

- Enter the value on the numeric keypad.
- Press the Up or Down Arrow to scroll to the value.
- While pressing Command (Macintosh) or Control (Windows), drag up or down to scroll to the value.
- Play the controller event on your MIDI controller keyboard, then press Return (Macintosh) or Enter (Windows) on the alpha keyboard to confirm the value.

💡 With the Start field selected, you can automatically enter the location of another event already in the track by clicking that event.

3 To insert the controller event and remain in Event Entry mode, press Enter on the numeric keypad.

   – or –

To insert the controller event and exit Event Entry mode, press Return on the alpha keyboard.

   – or –

To exit Event Entry mode, without inserting the controller event, press Escape on the alpha keyboard.

To insert a program change in the MIDI Event List:

1 Click the Insert button and choose Program Change from the pop-up menu.

   – or –

Press Command+P (Macintosh) or Control+P (Windows).

2 Enter the location for the new event.

3 Enter a Program Change number and Bank Select value (if necessary). The program change name is displayed in the Info column.

   – or –

Event Entry fields for program change

You can click in the Info column to open the Program Change window (for details, see “Program Changes” on page 306).

💡 With the Start field selected, you can automatically enter the location of another event already in the track by clicking that event.

4 To insert the program change and remain in Event Entry mode, press Enter on the numeric keypad.

   – or –

To insert the program change and exit Event Entry mode, press Return on the alpha keyboard.

   – or –
To exit Event Entry mode, without inserting the program change, press Escape on the alpha keyboard.

**Inserting Another Event**

After inserting an event, you can easily insert another event of the same type. The event type to be inserted is indicated at the bottom of the Insert menu.

**For example, after inserting a note, to insert another:**
- Click the Insert button and choose Another Note from the pop-up menu.
- or –
- Press Command+M (Macintosh) or Control+M (Windows).

💡 *When the option for Insert At Playback Location is enabled (see “MIDI Event List Options” on page 334), you can use the keyboard shortcuts for inserting “another” event to insert events on the fly.*

**Editing in the MIDI Event List**

Events in the MIDI Event List can be edited, selected, deleted, and copied and pasted.

**To edit an event in the MIDI Event List:**
1. Double-click the event field you want to edit.
   - or –
2. Enter a new value with any of the following methods:
   - Enter the new value on the numeric keypad.
   - While pressing Option (Macintosh) or Alt (Windows), press the Up or Down Arrow to scroll to a new value.
   - While pressing Command (Macintosh) or Control (Windows), drag up or down to scroll to a new value.
   - Play the new note or controller value on your MIDI controller keyboard, then press Return (Macintosh) or Enter (Windows) on the alpha keyboard to confirm the value.
3. To accept the new value, do one of the following:
   - To enter the new event value and move to another field or event, use the arrow keys.
   - To enter the new value and remain in Edit Entry mode, press Enter on the numeric keypad.
   - To enter the new value and exit Edit Entry mode, press Return (Macintosh) or Enter (Windows) on the alpha keypad.
   - or –
4. To exit Edit Entry mode without entering the new value, press Escape on the alpha keyboard.

**Selecting in the MIDI Event List**

**To select a range of events in the MIDI Event List:**
- Click the event at the beginning of the selection and drag to the ending event.
- or –
- Shift-click the event at the beginning of the selection, then Shift-click the ending event.
To select discontiguous events in the MIDI Event List:

- Command-click (Macintosh) or Control-click (Windows) each event.

To remove an event from the selection in the MIDI Event List:

- Command-click (Macintosh) or Control-click (Windows) the selected event.

Notes selected in the MIDI Event List can be modified by any of the commands in the MIDI Operations window. For details, see Chapter 24, “MIDI Operations.”

Deleting in the MIDI Event List

To delete an event in the MIDI Event List:

- Option-click (Macintosh) or Alt-click (Windows) the event you want to delete.

To delete a selection of events in the MIDI Event List:

1. Select the events you want to delete, by either dragging in the Start column, or by Shift-clicking each event.

2. To view only the events you want to delete, use the View Filter (see “View Filter for MIDI Event List” on page 329). Events not displayed cannot be deleted.

3. Choose Edit > Clear to delete all selected events.

- or -

Press Delete (Macintosh) or Backspace (Windows) on the alpha keyboard.

Copy and Paste in the MIDI Event List

To copy and paste in the MIDI Event List:

1. Select the range of events you want to copy by dragging in the MIDI Event List. To select discontiguous events, Shift-click each event you want to copy.

2. Choose Edit > Copy.

3. To paste the material at an existing event’s location, click the event in the MIDI Event List.

- or -

To paste the material at any location, choose Go To from the Options menu in the MIDI Event List, enter the location you want to paste to, and click OK.

4. Choose Edit > Paste. The events from the Clipboard are pasted, replacing any existing events already there.

To paste events without overwriting other events, use the Merge Paste command.

Selecting in the MIDI Event List
MIDI Event List Options

Show Sub Counter When selected, event times are also displayed in the Sub Time Scale.

Go To Opens the Go To dialog, where you can specify a location, based on any of the supported Time Scales, to which the Edit insertion point is moved.

Scroll To Edit Selection Scrolls the MIDI Event List to the Edit start point or Edit insertion point.

Page Scroll During Playback When selected, the MIDI Event List scrolls during playback.

Scroll During Edit Selection When selected, the MIDI Event List is scrolled automatically when the Edit selection changes in the Edit window.

Show Note Length When selected, note lengths, instead of note end times, are displayed in the Info column of the MIDI Event List.

Show Note End Time When selected, note end times, instead of note lengths, are displayed in the Info column of the MIDI Event List.

Insert At Edit Location When selected, the location for inserted events defaults to the Edit start point or Edit insertion point.

Insert At Playback Location When selected, events can be inserted in the MIDI Event List in real time while listening to the session playback.

Insert At Playback Location With Grid When selected, the location for events inserted in real time snap to the grid.

View Filter Opens the View Filter dialog, where you can specify which events are displayed in the MIDI Event List. Events that are not displayed are not affected by Cut, Copy, and Paste operations in the MIDI Event List. Events that are not displayed still play back. For more information, see “View Filter for MIDI Event List” on page 329.
Part VI: Mixing
Chapter 26: Basic Mixing

Although the final mixing process begins when you finish recording and editing, many mixing tasks can occur any time during a recording session. This chapter covers Pro Tools mixing, including audio signal flow, output and bus paths, sends, and signal routing.

Real-time plug-ins and hardware inserts provide effects and signal processing. See Chapter 27, “Plug-In and Hardware Inserts” for more information.

Audio Signal Flow

Pro Tools provides three different types of audio tracks:

- audio tracks
- Auxiliary Inputs
- Master Faders

Mono and stereo audio tracks are available on all Pro Tools systems.

Multichannel audio tracks and surround mixing formats require Pro Tools HD-series or MIX-series systems.
**Audio Tracks**

Audio tracks play audio from disk, record audio to disk, or monitor input signals when record-enabled. Audio signal flow is shown below.

**Auxiliary Inputs**

Auxiliary Inputs provide the same signal routing options as audio tracks, except that their input must come from an internal bus or hardware input.

Auxiliary Inputs are used as inputs for audio from MIDI devices and other sources, as well as to submix internal bus and output paths. They can be fully automated. When using Auxiliary Inputs as inputs for external sources, adjust the source output levels to achieve proper recording levels.
Common Uses for Auxiliary Inputs

By bussing tracks to the Auxiliary Input, you can:

- Apply real-time plug-ins or an external processor to a submix, using the Auxiliary Input as an effects return
- Input MIDI and other audio sources into the mix, to monitor or route to audio tracks for recording to disk
- Consolidate control of any submix under a single fader (see “Submixing for Signal Routing and Effects Processing” on page 353)

To create an Auxiliary Input:

2. Choose the type of Auxiliary Input (mono or stereo, or multichannel) from the pop-up menu.
3. Enter the number of tracks and click Create.

To route an Auxiliary Input:

1. Click the Input Selector of the Auxiliary Input and choose an input.
2. Click the Output Selector of the Auxiliary Input and choose an output or bus path.
3. Adjust the Auxiliary Input fader to set the return volume (it defaults to 0 dB).

Submix examples begin in “Submixing for Signal Routing and Effects Processing” on page 353.

Master Faders

Master Faders control the master output levels of output and bus paths. When assigned to an active output or bus path, they provide post-fader effects processing and master level control for a main mix, headphone and cue mixes, stems, effects sends, and other signal routing applications. Master Faders support all track formats supported on your Pro Tools system.
Unlike inserts on audio tracks and Auxiliary Inputs, Master Fader inserts are post-fader. This lets you insert a dithering plug-in, or similar plug-in, on your master mix.

See “Dither” on page 359 for more information about dithering.

Because of their intended use, Master Faders provide up to five post-fader inserts and no sends.

Common Uses for Master Faders
Master Faders can be used to:
- Control and process output mixes
- Monitor and meter an output (such as a bus or hardware output) to guard against clipping
- Control submix levels
- Control effects sends levels
- Control submaster (bussed tracks) levels
- Apply dither or other inserts to an entire mix

You can use Master Faders freely to control submix levels, send level masters and other outputs because they do not consume any of your system’s audio processing power.

To use Master Faders as a master volume control for all tracks in a session:
2. Choose the type of Master Fader from the pop-up menu.
3. Click Create.
4. Set the outputs of all audio tracks in the session to outputs 1–2 and set the panning of each track.
5. Set the output of the Master Fader to your main output path.

Master Fader Meters
Meters on Master faders always show post-fader levels, regardless of the Pre-Fader Metering setting in the Operations menu.

Master Faders and Paths
Master Faders can be assigned to main and sub-paths. When more than one Master Fader is assigned to the same output or bus path, only one can be active at the same time. If you try to assign a Master Fader to a main or sub-path that is already actively assigned on another Master Fader, the new assignment will be assigned, but be inactive. Master Faders can be assigned to a different sub-paths of the same main path, as long as the sub-paths do not overlap.

Active and Inactive Master Faders
(TDM Systems Only)

When a Master Fader track is inactive, its associated plug-ins, I/O assignments, and their resources are released and available for other uses in the session.

When a Master Fader output assignment (path assignment) is made inactive, the Master Fader no longer controls the master gain of that path.
When you duplicate a Master Fader track, the duplicated track's assignment will be inactive. See “Master Faders and Paths” on page 340 for more information.

**Plug-Ins and Inserts**

Five inserts are available on each audio channel. Each insert can be either a **hardware insert** or a **software plug-in insert**. Plug-ins and hardware inserts route the signal from the track through the effect of your choice, and automatically return it to the same track. Inserts on audio tracks and Auxiliary Inputs are pre-fader. Inserts on Master Faders are post-fader.

On TDM systems, RTAS plug-ins can be inserted on audio tracks, but not on Auxiliary Inputs or Master Faders.

Hardware inserts send and return the signal to corresponding input and output channels of an audio interface.

*See Chapter 27, “Plug-In and Hardware Inserts” for details about using plug-ins and inserts.*

**Track Output Format and Plug-Ins**

Plug-ins provide mono, stereo, multi-mono and multichannel versions (not all versions are supported by all plug-in manufacturers or on all systems).

Because inserts process in series, changing the plug-in format can alter the channel format. For example, inserting a mono-to-stereo plug-in on a mono Auxiliary Input changes the signal path from that plug-in through the rest of the track. This restricts all hardware inserts or plug-ins after the stereo plug-in to be stereo-in/stereo-out plug-ins (or supported multichannel format).

**All Systems** The following three types of plug-ins are supported on all Pro Tools systems:

- mono-in mono-out
- mono-in stereo-out
- stereo-in stereo-out

**Pro Tools HD-series and MIX-series** Pro Tools TDM systems running the Surround mixer support 3–8 channel, multi-mono and multichannel plug-ins.

---

**Viewing I/O, Inserts, and Sends**

Both the Mix and Edit windows can be configured to show or hide the various mixing controls.

**To show or hide I/O, inserts and sends in the Mix and Edit windows:**

1. Choose Display > Mix Window Shows, or Edit Window Shows, or click the View Selector in the Edit window, and choose any or all of the following:
   - Select I/O View to show input and output, volume, and pan controls in each track. Deselect to hide.
   - Select Inserts View to show inserts (software plug-ins and hardware I/O inserts) in each track. Deselect to hide.
Select Sends View to show send assignments in each track. Deselect to hide. See “Configuring Sends View in the Mix and Edit Windows” on page 346 for more information.

Viewing Comments

Comments View shows any text entered as comments in the Track Name dialog. You can also type directly in the Comments area for each track when Comments View is displayed.

To display Comments View:
1. Select Display > Mix Window Shows (or Edit Window Shows) > Comments.

Track Input

Input Selectors determine the source input for audio tracks and Auxiliary Inputs. Track input can be a hardware input, bus, or Soft SampleCell input path. While recording, the Input Monitor mode determines when live input will be monitored through a record-enabled audio track.

The following techniques simplify track input assignment for tracks.

To assign track input:
- Select an input path or sub-path from the track Input Selector.

To assign multiple tracks to the same input:
- Option-select (Macintosh), or Alt-select (Windows) to assign all tracks to the selected input.
- Option-Shift-select (Macintosh), or Alt-Shift-select (Windows) to assign all selected tracks to the selected input.
To assign multiple tracks to unique inputs (ascending, incrementing):

- Command-Shift-click (Macintosh), or Control-Shift-click (Windows) to assign the starting track (top-most in the Edit window, left-most in the Mix window).

This track will be assigned to the selected input path, and each subsequent track will be auto-assigned the next available input path. Availability is determined by the path format, and the active/inactive state of the tracks.

**Track Output**

Track Output Selectors route the post-fader signals to the assigned output or bus paths.

The Output Selector routes the main track output to the chosen main or sub-path. Tracks can be routed directly to hardware outputs, or to internal bus paths for submixing (main or sub-paths).

The track format (mono, stereo, or multichannel) determines the available main and sub-path choices for track output.

When you create new tracks, their default Output assignment is determined by your selection of Default Output Path in I/O Setup. You can change the Default Output Path in I/O Setup to any available path. For more information, see “Default Output Path” on page 73.

*Sends, and Send windows, provide another way to route track audio. See “Sends” on page 345 for more information.*

To assign a track output:

- Select the desired output path or sub-path from the track Output Selector.

![Assigning track output](image)

To assign all tracks to the same output:

- While pressing Option-select (Macintosh) or Alt-select (Windows), assign any track output to also assign all tracks to the same path.

To assign all selected tracks to the same output:

- While pressing Option+Shift (Macintosh), or Alt+Shift (Windows), assign any track to also assign all selected tracks to the same path.

**Output Paths**

When audio tracks, Auxiliary Inputs, and Master Faders are created, their mono, stereo, or multichannel format is defined. This original format determines the track’s minimum insert, send, and output format.

- Mono tracks can be assigned to any available mono, stereo, or other multichannel main and sub-paths.
- Stereo tracks can be assigned to any available stereo or multichannel main and sub-paths.
- Multichannel tracks can be assigned to any equal, or higher, format.

For example, on any “stereo” audio track, Auxiliary Input, or Master Fader, the main track output can be assigned to any available stereo paths or insert, or any multichannel paths of three or more channels (on supported systems).
Output Windows

Output windows provide the essential track mixing controls (such as track panning and volume), as an alternative to Mix and Edit window views. Multichannel Send and Output windows also provide expanded Panner views, and other surround-specific controls. (See Chapter 33, “Surround Panning and Mixing.”)

Output windows are useful in large sessions to leave important tracks in an anchored location, unaffected by Mix and Edit window (or control surface) banking. See “Opening and Managing Output Windows” on page 349.

These windows appear differently for mono, stereo, and multichannel tracks. For multichannel mixing, there is also an X/Y panner Output window available. For more information on using multichannel Output windows, see Chapter 33, “Surround Panning and Mixing.”

Multiple Output Assignments

Pro Tools audio tracks and Auxiliary Inputs can have multiple track and send assignments. Multiple outputs are limited only by the paths and resources available on your system.

Assigning to multiple paths is an efficient way to route an identical mix to other discrete outputs, for simultaneous monitor feeds, headphone mixes, or other situations where a parallel mix is needed. Master Faders can only be assigned to a single path.

You can also define what physical ports are routed to Pro Tools input and output ports in the “Main” page of the Hardware Setup dialog. For more information, see “Hardware Setup” on page 39.

To assign a track to multiple outputs:

1. Assign a main output path by selecting it from the track’s Output Selector.

2. Control-click to select an additional output path in the track’s Output Selector. The newly selected output destination is added as an additional output.

   Option-Control-click to add the assignment to all tracks, or Option-Shift-Control-click to add to all selected tracks.
Display of Multiple Output Assignments

When a track is assigned to multiple output paths, the Output Selector denotes multiple assignment status and active/inactive status with the following indicators:

- A plus sign (+) indicates that the track has multiple output assignments.

- In the Output Selector menu, all currently assigned track outputs are checked to indicate they are active for the current track.

- An asterisk (*) indicates that one or more currently assigned outputs is Inactive.

Inactive Outputs

An output path can be set to Inactive, either globally in the I/O Setup window (affecting all tracks assigned to that path), or locally per assignment (only affecting that output on that audio track or Auxiliary Input).

When opening sessions, outputs will be made inactive automatically if the required hardware or other resources are not available.

Inactive outputs retain all associated automation playlists. Edits made in the session also affect the inactive track’s output automation playlists.

Inactive Outputs and DSP Resources

Setting a track output to Inactive silences the output, while retaining all automation and playlist data. Inactive outputs do not consume resources for TDM mixer connections, but any assigned plug-ins on the track continue to use their required DSP resources. RTAS plug-ins require CPU resources, and TDM plug-ins use the DSP available on Pro Tools audio cards.

You can free up DSP of unused plug-ins by setting its whole track inactive, or by setting just the plug-in inactive.

See “Active and Inactive Items” on page 16, and “Inactive Plug-Ins” on page 364 for more information.

About the “No Output” Option

Track outputs can be set to No Output. Assigning a track output to No Output loses any panning playlists associated with the track.

Tracks assigned to No Output will not be audible, but they do not free their associated DSP resources.

Sends

Pro Tools lets you insert up to five sends on each audio track or Auxiliary Input.

Sends provide the following features:

- Sends can be set as pre- or post-fader.
- Send level and mute can be configured to follow Groups.
- Send level, send mute, and send pan (for stereo and multichannel sends) are fully automatable. See “Automating Sends” on page 385.
- Send controls can be displayed and edited from the Mix or Edit windows, or in their own Output windows.
- Sends can be assigned to available output and bus paths (main or sub-paths), in mono or stereo, or any supported multichannel format.
- Each Send can have multiple assignments (for example, to available output and bus paths).
Sends must be returned to the mix through an Auxiliary Input or audio track. They can be monitored and processed through an Auxiliary Input, recorded to audio tracks, and bounced to disk. (Bouncing and mixdown are explained in Chapter 29, “Mixdown.”)

**Assigning Sends to Tracks**

**To add a send to a track:**

1. Make sure Sends View is enabled in the Mix or Edit window (see “Viewing I/O, Inserts, and Sends” on page 341 for information).
2. Click the Sends button on the track and choose a path from the pop-up menu.

---

**Send Formats**

**Mono and Stereo Sends** On all Pro Tools systems, sends can be either mono or stereo. When you click the Sends button on a track, you can choose from a list of mono or stereo output or bus paths.

**Multichannel Sends** Pro Tools HD-series and MIX-series systems support mono, stereo, and multichannel sends.

**Sends and Path Choices**

The choices available in track Send Selectors include bus and output paths.

**Internal Mix Busses** Pro Tools TDM systems provide 64 busses and Pro Tools LE systems provide 16 busses for routing signals internally. Internal bus paths are useful for submixing and processing with plug-ins. Bus paths are defined in the I/O Setup dialog, and are available in all supported channel formats (mono, stereo, or other multichannel, as supported on your system).

**Hardware Outputs** Hardware sends are often used for headphone cue mixes, or for sending signals to external effects processors. Sends do not automatically return audio as do inserts.

---

You can customize the names, format, and channel mapping of busses and output paths in the I/O Setup dialog. See “Creating and Editing Paths” on page 64.

**Configuring Sends View in the Mix and Edit Windows**

Sends are displayed in the Mix and Edit window according to the Sends View Shows settings. Choices include Assignments View, plus the five Send A–E Views, explained below.
To display the controls for an individual send across all tracks:

1. If sends are not currently visible on your tracks, choose Display > Mix Window Shows > Sends View (or Display > Edit Window Shows > Sends View).

2. Choose Display > Sends View Shows and select the send (A–E).

To show send assignments:

- Choose Display > Sends View Shows > Assignments.
- Or –
- Command-click the Send Selector and select a view, or send (A–E).

**Assignment View**

This is the default Send Display mode, showing the five available sends on all tracks displayed in the Mix and Edit windows.

In Assignment View, send parameters are edited from their Output windows. See “Opening and Managing Output Windows” on page 349.

**Send A–E Views**

The Send A–E Views provide send level, pan, and mute controls.

*Send A View, different types of send assignments*

Parameters for sends can be edited directly using these controls. Sends can also be opened for editing or metering in Send windows. See “Opening and Managing Output Windows” on page 349.

**Editing Sends in the Mix and Edit Windows (Send A–E Views)**

Send A–E View options display all the parameters of an individual send in the sends area of the Mix and Edit windows. These views provide full access to all controls for that send on all tracks.

*Send A View, stereo shown*

Send level and mute can follow Mix groups, to adjust multiple send parameters from a single set of controls. (See “Sends and Groups” on page 353.)
Sends View Meters

When you display the controls for an individual send, you also have the option of displaying send level meters.

Send level meters show peak values and indicate clipping that occurs while the meter is displayed (if a send clips any time before its meter is displayed, this is not shown). If you are using a slower computer, hiding send level meters can improve screen redraw times.

To display send level meters when viewing individual sends:
1. Choose Setups > Preferences and click Display.
2. Select Show Meters in Sends View and click OK.

To clear a send meter’s Clip indicator:
- Click on it. Option-click to clear all.

- In Assignment View, edit sends by opening their Output windows. See “Opening and Managing Output Windows” on page 349.

Send Mute and Window Status Display

When displaying sends in a Send A–E View, Send Mute switch is visible and editable directly in the Mix or Edit windows.

In Assignment View, Send Mute and Output window status are displayed as follows:
- The Send Bypass indicator is lit when the send is muted.
- The Send button is lit whenever a send’s window is open.

Indication of Send Mute and Window status

If you use ProControl, Control|24, or other control surface with Pro Tools, colored outlines around sends, inserts, and Outputs indicate the current controller focus.

Inactive Sends

Sends can be made inactive. Inactive sends free their DSP and mixer resources, while retaining their position in track Sends View, and retain all related automation playlists. Inactive sends do not output audio.

To make a send inactive:
- Command-Control-click (Macintosh), or Control-Start-click (Windows) on the send (its assignment). Use the Option and Option+Shift modifiers to affect that send (A–E, if present) on all or all selected tracks, respectively.

- or -

- Make the Track inactive. See “Making Tracks Inactive” on page 90.

When opening sessions, sends will be made inactive automatically if the required hardware or other resources are not available.
Inactive sends retain all associated automation playlists. In addition, any edits made in the session affect the sends automation playlists.

Output Windows for Tracks and Sends

Track outputs and sends can be opened for display and editing in dedicated windows.

- Track Output windows provide track fader, pan, automation, solo, and mute controls.
- Send windows provide send level, mute, pan, and automation controls.
- Standard Output and Send window controls provide additional routing, assignment, and display settings.

To open an Output window:
- Click the Output icon in the channel strip.

To open a Send window:
- Click the send in the Mix or Edit window.

Opening and Managing Output Windows

Multiple track and Send windows can be displayed simultaneously.

To view a different Output window:
- Click an output icon, or send, in the Mix or Edit window.

If a similar Output window was already open with a highlighted Target icon (red, unlit), the newly selected send will open in its place.
Opening Multiple Output Windows

Multiple track and Send windows can be displayed simultaneously using either of the following methods.

To open additional Output windows:
- Shift-click any output icon or send.

To set a window to remain open:
- Make sure the Target is deselected (gray, unlit).

Arrange multiple windows as needed. For additional information, see “Using the Target” on page 352.

Track Fader, Solo, Mute, and Auto

Output windows provide the associated track’s volume fader, pan controls, solo and mute switches, and Automation Mode Selector. Use these to adjust or automate the parameters of the Output window.

Panner Linking

Stereo outputs provide two panning controls, one for each side of the left/right pair.

The Output window provides controls to unlink (or link) channels for precise panning of stereo and multichannel tracks.

In the default Linked mode, all sides match changes to any other side’s pan control. This is Absolute Link mode.

When unlinked, pan controls are completely independent of each other.

When linked and set to Inverse mode, panning moves are inverted, or reversed, in the other channels. For example, panning the left side of a stereo track from left-to-right results in the right channel panning simultaneously, from right-to-left.

Inverse Linked Panning

Additional inverse linking options are also provided for stereo track panning.

Inverse panning reflects one side’s location and direction in the other side. For example, when enabled for Front Inverse, if you pan one side of a stereo track output from right to left, the other side will exactly mirror that movement and pan left to right.
Front inverse linking is available on all systems. Rear Inverse, and Front/Rear Inverse linking are available on Pro Tools HD-series and MIX-series systems and only appear as options on multi-channel plug-ins and panners/output windows.

To enable inverse linking:

1. Enable the Link icon.
2. Select an Inverse mode.

**Standard Selector Controls in Output Windows**

All Output windows provide standard selectors for path, automation, and other controls in the top area of the window (the Output Editor area).

**Output window standard controls**

**Send window standard controls**

**Standard Controls**

- **Close** Closes the window.
- **Track Selector** Provides access to any audio track, Auxiliary Input, or Master Fader in the session.
- **Output Selector** Provides access to other outputs (track and send) in the track, if any, displaying the selected output in the current window.
- **Send Selector** Provides access to other sends on the track.

**Path Selector** Allows you to assign the Output path for the current track or send.

**Bypass/Mute button** Mutes the currently displayed send.

**Link and Unlink** Allows linking and unlinking of left and right (or other) outputs in stereo (or multichannel). Unlinked mode provides discrete adjustment of individual sides, or channels. When linked, all changes affect all channels. See “Panner Linking” on page 350.

**Target** Identifies the target of plug-in settings commands. Also sets the current window for display of Output windows. See “Using the Target” on page 352.

**Safe** Track and send level, pan, and other controls can be protected from automation over-writes by placing them in Automation Safe mode. See Chapter 28, “Automation” for more information.

**Meter View** The view box in the upper right corner opens the path Meter View. These meters display levels of the selected path (not the output of the current window).
Using the Target

When lit, the next window opened of the same type dynamically replaces the current display (unless it is opened as an additional window with the Shift modifier). When unlit, the current window anchors to its current contents and location on-screen. Opening additional windows does not affect anchored windows.

To set an open Send window as the Target window:

- Click to enable the Target (it is red when enabled, gray when disabled).

Plug-ins have additional features related to the Target.

Target Functionality in Windows, by Type

<table>
<thead>
<tr>
<th>Window Type</th>
<th>When Target Enabled</th>
</tr>
</thead>
<tbody>
<tr>
<td>Plug-Ins</td>
<td>Focus of Settings commands, and Window setting</td>
</tr>
<tr>
<td>Track Outputs</td>
<td>Window setting</td>
</tr>
<tr>
<td>Sends</td>
<td>Window setting</td>
</tr>
<tr>
<td>Inserts</td>
<td>Window setting</td>
</tr>
</tbody>
</table>

Using Output Windows

Output windows provide standard Pro Tools track, send, Target, and other controls.

To move to a different track:

- Click the Track Selector button and choose a track from the pop-up menu.

To reassign output:

- Click the Send Destination Selector button and select a path from the pop-up menu.

Selecting a path from the Sends Editor

To add an additional send to the same track:

- Click the Send Selector button and choose the desired Send from the pop-up menu, then click the Send Selector and choose a destination from the pop-up menu.

To add an additional output assignment to the current track or send:

- Control-select an additional output path from the Send Selector.

To display the controls for a different send on the same track:

- Click the Send Selector button and select the send.

Accessing another send from the Sends Editor

Selecting a track from the Sends Editor
Sends and Groups

Send level and mute can follow Mix groups in each of the five available sends (A–E). Use this to adjust multiple send parameters from a single set of controls.

To configure sends and Mix groups:
1. Choose Setup > Preferences, and open the Automation window.
2. Enable Send Level Follows Groups, or Send Mute Follows Groups, as appropriate.
3. Click OK to set the new Preferences.

Copying Settings to Sends
(TDM Systems Only)

Sometimes you need send settings to match the settings in the track itself—for example, to provide a headphone mix based on the main mix.

You can do this in either of two ways:
• By assigning an additional (multiple) output to all tracks, adding the headphone Output path to the main mix output assignments. (See “Multiple Output Assignments” on page 344).
  – or –
• By copying a track’s volume fader, pan slider, or mute button position to the corresponding controls for a send on that track. (See “Copying Track Automation to Sends” on page 386.)

Submixing for Signal Routing and Effects Processing

The bussing and mixing features in Pro Tools support a nearly infinite number of possibilities for submixing and signal routing, including:
• Create inputs for MIDI devices and other audio sources, to monitor or record in Pro Tools.
• Control and automate any submix from a single fader and channel strip.
• Apply real-time plug-ins or an external processor to the submix, using the Auxiliary Input as an effects return.

Audio Input from MIDI Devices and Other External Source

You can use an Auxiliary Input to bring external audio sources such as MIDI devices, tape, microphone inputs, and instruments, into a Pro Tools mix.

To use Auxiliary Inputs to bring external audio sources into a mix:
1. Connect the audio outputs of your MIDI and other external devices to available inputs on your Pro Tools audio interfaces.
2. If necessary, configure the I/O Setup dialog for the input paths you plan to utilize. The I/O Setup dialog configuration determines the choices available for track sends, inputs, busses, and hardware inserts. (For more information, see Chapter 7, “I/O Setup.”)
3. Choose File > New Track and select the type of Auxiliary Input (mono, stereo, or multichannel on supported systems) from the Track Format Selector, then click Create.
4. Set the input of the Auxiliary Input track to the appropriate input path.
Assign the track output to the appropriate path, or paths. (See “Multiple Output Assignments” on page 344 for more information.)

Adjust the Auxiliary Input fader to control the track, and any assigned post-fader send levels.

**Mixing Audio Input from MIDI Devices and External Sources**

By mixing MIDI and other audio sources through Pro Tools, you can apply mix automation to the volume, pan, mute, send level, send pan, send mute, and plug-in controls of the Auxiliary Input.

Auxiliary Inputs can be routed to audio tracks through internal send busses, or using their track output, to record them to disk.

Using plug-ins, inserts, and sends on Auxiliary Inputs, you can process instruments and other inputs with real-time plug-ins, or external devices. See “Send and Return Submixing for Effects Processing” on page 355.

**Creating a Submix**

Audio is routed to a submix by assigning any combination of sends and track outputs to available bus or output paths.

Auxiliary Inputs serve as effects returns by inserting plug-ins or external effects processors.

For example, if a stereo sampler was connected to Inputs 1–2, a stereo Auxiliary Input assigned to the Input 1–2 path could monitor the sampler through Pro Tools. You can process the track with plug-ins, or send to a bus path for additional processing, or recording. Auxiliary Inputs and Master Faders provide consolidated level control, processing, signal routing, and automation.

**Submixing with Track Outputs or Sends**

You can use both track outputs and sends to route audio for submixing, depending on whether you want a discrete or send and return submix.

**Discrete Submix Output**

Discrete submix output means source audio is routed discretely through the submix. This is preferred for dither or other mastering processing, where you do not want unprocessed audio heard in addition to the processed signals. Use track outputs (not sends) to assign tracks to a bus path for discrete submixing. In this arrangement, the balance of processed and unprocessed signal is controlled by plug-in wet/dry settings.

> For another way to submix effects, see “To create an effects return submix:” on page 355.

**To create a discrete submix:**

1. Set the output of the tracks you want to include in the submix to a stereo bus path.
2. Pan each track.
3. Choose File > New Track and choose Auxiliary Input (stereo) from the pop-up menu.
4. Set the input of the Auxiliary Input to the same bus path to which you assigned all contributing tracks.
5. Set the output of the Auxiliary Input track to your main stereo mix outputs (typically, outputs 1–2).
6. Set the Auxiliary Input Track level.
7. To process the submix, assign a plug-in or hardware insert on the Auxiliary Input.
8. Set the parameters of the plug-in. The plug-in Bypass and Wet/Dry controls (if available) determine the amount of effect heard.
The contributing track faders control the balance within the submix. The Auxiliary Input track controls the output levels of all tracks routed to it.

You can apply mix automation to the volume, pan, mute, and send level, send pan, and send mute controls of the Auxiliary Input.

You can also bounce a submix to disk to free up the voices for use by other tracks. See Chapter 29, “Mixdown” for information.

**Send and Return Submixing for Effects Processing**

When you are submixing for reverb, delay, and similar effects processing, use sends to achieve traditional send/return bussing. You can use a real-time plug-in or a hardware I/O insert as a shared resource for all tracks included in a submix. The wet/dry balance in the mix can be controlled using the track faders (dry level) and Auxiliary Input fader (effect return, or wet, level).

**To create an effects return submix:**

1. Assign a send (mono or stereo) to each source track.
2. Assign each track’s main output to your main mix outputs.
3. Set the send destinations on the source tracks to a mono or stereo bus path. Configure the sends for pre- or post-fader, as needed.
5. Choose one Stereo (or other format) Auxiliary Input, and click Create.
6. Assign a real-time plug-in, or a hardware insert, on the Auxiliary Input.
7. Set the plug-in or external effect to “100% wet,” and configure any other parameters as needed.
8. Click the Input Selector of the Auxiliary Input track and set it to the bus path you assigned to the sends on the source tracks.
9. Click the Output Selector of the Auxiliary Input track and choose an output path (your main mix, or other output).

Adjust the individual track faders to balance the dry (unprocessed) tracks. The amount of effect is controlled by the level of the Auxiliary Input fader.

For convenience, you can configure send levels and send mutes to follow Mix Groups. This can simplify set up with large submixes. See “Sends and Groups” on page 353 for more information.

See Chapter 27, “Plug-In and Hardware Inserts” for more information.
Creating a Master Send Level Control

Master Fader can control the overall level of bus and output paths.

To create a Master send level control:

1. Choose File > New Track and create a Master Fader in the appropriate mono, stereo, or multi-channel format.

2. Do one of the following:
   - Set the output of the Master Fader to the same path that you are using to send to an Auxiliary Input track.
   - Set the output of the Master Fader to match the path that you have chosen for your effects send.

You can then adjust send levels to balance the source tracks, and use the Master Fader as a master level control for the entire submix.

Soloing Tracks in a Submix

When you want to solo any tracks in a submix, you can solo safe the Auxiliary Input track. This solos tracks that are bussed to the Auxiliary Input without having to solo the Auxiliary Input as well.

To solo safe an Auxiliary Input:

- Command-click (Macintosh) or Control-click (Windows) the Solo button on the Auxiliary Input track.

To solo an individual track that is part of a group:

- Control-click (Macintosh) the solo button. Control = group (and automation) clutch.

Generating Stereo Output from a Mono Send/Return

You can use an Auxiliary Return arrangement to generate a stereo output from a mono send. Set the send destination to a mono Auxiliary Input track and place a stereo plug-in on the Auxiliary Input. The output of the Auxiliary Input becomes stereo.
Mixing Concepts

Mixing involves much more than the Pro Tools techniques for signal routing, level balancing, and panning. Mixing is not just a matter of knowing how to do something, it’s knowing what you want, or need, to do.

Many mix decisions are purely aesthetic, meaning you decide how loud things are, where they are panned, what effects are used, and so on. You base your mix decisions on what you are hearing. What you are hearing is determined by the type and number of speakers in your studio, their placement and condition, the size of the room, and many other factors.

While you can control most of these variables in your facility, you cannot control them in all the listening environments in which the project will be heard. This section provides a basic introduction to some of the ways to reduce the variables encountered while mixing.

Monitoring for Compatibility

While mixing, your monitoring system has a very large influence on how your final mix will sound. For example, if your monitors (or room) are overly bright, you will tend to put less high-end in your mixes. When your mix is played on a different system that doesn’t favor the high-end, it will likely sound muddy. Problems like these can be avoided using alternate speakers and reference monitors.

Alternate Speakers and Reference Monitoring

Mixers often listen to their mixes on a variety of different speakers, to gauge how well the mix will translate. Some speakers are designed to emulate the effects of TV broadcast, where others attempt to be completely flat across all frequencies. By listening to a mix through different playback systems, you are attempting to anticipate what the intended audience will hear. The goal is to make sure your mix will sound as good as possible to as many listeners as possible.

Reference Tapes and Discs

To become familiar with a studio and its monitors, engineers often bring along a collection of recordings they are familiar hearing in a variety of environments. In this way, they can get a sense of how the room and monitors “sound” before mixing.

While mixing, tapes and discs of rough mixes let you audition mixes outside the studio in different listening environments.

Format Compatibility Monitoring

In addition, format compatibility is sometimes required. With stereo, mixes must often be mono-compatible.

Mono-Stereo Mix Compatibility Example

An example of mix compatibility is mono-stereo compatibility. Though stereo is the predominant consumer listening format, many televisions and older cars have a single speaker. How a stereo mix sounds through a mono television or radio (AM radio, for example, is mono) can only be verified by checking how the mix sounds when summed to mono.
Most consoles let you fold the mix to mono in order to check mono-compatibility and, if necessary, make adjustments. You can also simply pan your output mix channels to center.

When you start mixing in multichannel surround, these techniques become even more important. See Chapter 30, “Surround Concepts” for more information.

**Metering and Calibration**

Meters provide a visual display of signal levels. They tell whether signal is getting to a channel, and how loud or soft a signal is relative to (above or below) “0.”

By calibrating all your equipment to standard reference levels, a consistent level can be achieved (and metered) among different recording devices in a studio, throughout a facility, or throughout an entire production chain of a feature-length film. For example, a level of, say, –18 dB coming out of a DAT deck should play and meter at –18 dB in Pro Tools.

**Reference Levels**

Reference levels are often tones such as sine waves, at specific frequencies (1k and 10k, for example). By supplying the same tones to each device, you can calibrate your systems for equal input and output attenuation and metering. Beyond your own studio and equipment, reference levels and calibration provide a standard by which different studios, engineers, and systems can achieve a consistent nominal operating level.

Calibrating your Pro Tools audio interface inputs and outputs to tape machines and other audio devices in your studio ensures consistency in levels (and meters) when recording, transferring, overdubbing and mixing.

For audio interfaces that have trims (such as the 192 I/O), see your peripheral’s guide for calibration instructions. The 192 I/O trims are software-adjustable, in the Hardware Setup dialog.

**Using a Control Surface with Pro Tools**

There are several optional control surfaces for Pro Tools:

- TDM-equipped Pro Tools systems can use Digidesign ProControl or Control|24. These control surfaces are dedicated controllers that provide access to Pro Tools recording, mixing, editing, signal routing, plug-in control, and automation features.

- ProControl-equipped Pro Tools systems can use Digidesign’s EditPack. This control surface option provides many mixing and panning features to enhance multichannel mixing for surround sound, as well as providing direct access to many of the most frequently used Pro Tools command and features.

- Pro Tools LE and TDM systems support MIDI control surfaces, including the CM Labs Motor-Mix, Mackie HUI (Human User Interface), JL Cooper CS-10, Peavey PC-1600, and others.
Pro Tools HD-series and MIX-series systems running the Surround mixer can use the JL Cooper MCS3000 Joystick Panner. However, on Pro-Control systems with EditPack enabled, you cannot use the MC3000 Joystick Panner.

For more information on using MIDI control surfaces with Pro Tools, refer to the Pro Tools MIDI Control Surfaces Guide.

### Dither

Dither is a special form of randomized noise used to mask quantization noise in digital audio systems. Digital audio’s poorest distortion performance exists at the lowest end of the dynamic range, where quantization distortion can occur. Dither reduces quantizing errors by introducing very low-level random noise, thereby minimizing distortion artifacts as audio reaches low level. With dither there is a trade-off between signal-to-noise performance and less-apparent distortion. Proper use of dither lets you squeeze better subjective performance out of a 16-bit data format (such as Red Book compact discs).

Pro Tools TDM systems process all audio internally at 24-bit, and Pro Tools LE processes internally at 32-bit, floating. Without Dither to process the 24-bit data to 16-bit, the extra 8 bits are truncated (dropped entirely) when written to media or a device with a 16-bit maximum (such as CD recorders, many DAT machines, and others). Dithering, on the other hand, preserves low-level (quiet) fidelity in a surprising way—by adding a small amount of noise to a signal.

### Dither in Pro Tools

There are several dither options provided in Pro Tools. Each has a specific application within the various operations that could benefit from dithering.

In addition to the TDM, RTAS and AudioSuite dithering plug-ins, Pro Tools has a built-in dither capability.

**Dither Mixer Plug-Ins** Pro Tools|HD provides two Mixer plug-ins that feature dither with noise shaping: Stereo Dithered and Surround Dithered. For more information, see “Surround Dithered and Stereo Dithered Mixers” on page 526. Standard Stereo and Surround Mixers do not have dither and require use of dithering plug-ins.

**Dither on Final Output for Mixdown** You can insert a real-time dither plug-in on a Master Fader to dither your final mix, post-fader, for CD or other 16-bit media. Inserts on Master Fader process post-fader. During Bounce-to-Disk, this form of dithering lets you use dither plug-ins from Digidesign or third-party manufacturers. For more information, see “Dither and Bounce to Disk” on page 404.

**AudioSuite Dither** For AudioSuite plug-in processing, dither is based on the Dither plug-in.
For most AudioSuite plug-ins, dither can be automatically applied in the Pro Tools Preferences dialog, under Processing. The Use AudioSuite Dither checkbox enables a preset, N-shaped dither.

The following AudioSuite plug-ins can automatically apply dither when processing:
- EQ II
- Compressor II
- Limiter II
- Gate II
- Expander/Gate II
- Normalize
- Gain
- DC Offset Removal
- Time Compression/Expansion
- Pitch Shift

_Fades and Crossfades_ In the Fades dialog (Edit > Fades > Create Fades), the Use Dither checkbox enables a preset, noise-shaped dither.

Noise is an integral part of the dithering process. _Noise shaping_ can further improve audio performance and reduce perceived noise inherent in dithering. Noise shaping utilizes digital filtering to move noise from frequencies around 4 kHz. Essentially, noise shaping lessens our perception of the noise inherent in dithering by shifting audible noise components into a less audible range.

Noise Shaping is available in the Dither plug-in.

*For more information about dither during mixdown, see Chapter 29, “Mixdown.”*
Chapter 27: Plug-In and Hardware Inserts

Pro Tools provides up to five unity-gain inserts on each audio track, Auxiliary Input track, or Master Fader. Audio track and Auxiliary Input inserts are pre-fader, and Master Faders inserts are post-fader only.

An insert can be either a software DSP plug-in or a hardware insert. A Pro Tools insert routes the signal from the track to a plug-in or external hardware effect of your choice and automatically returns it to the same track. Inserts do not alter the original audio source files, but process audio in real time, during playback. You can permanently apply real-time effects to tracks by recording or bouncing the effect to disk (see Chapter 29, “Mixdown” for more information).

This chapter explains how to use plug-ins and hardware inserts. Refer to the Digidesign Plug-Ins Guide for details on using specific plug-ins.

Plug-In Inserts

Plug-in inserts are software inserts that process audio material on a track in real time. The EQ, Dynamics, and Mod Delay plug-ins supplied with your Pro Tools system are real-time plug-in inserts.

Additional real-time plug-ins are available from Digidesign and from many third-party developers.

For more information, see the Digidesign Plug-Ins Guide.

Hardware I/O Inserts

Hardware I/O inserts can route audio through an external device connected to the inputs and outputs of your audio interface. You can process the audio material on a track with a hardware insert in real time.

Insert paths require audio interface inputs and outputs, and are determined by the I/O Setup configuration of your system.

For more information, see the Digidesign Plug-Ins Guide.
**General Information**

- When more than one insert is used on a track, they are processed in series. Each effect is added to that of any previous plug-ins or inserts, (flog from top to bottom in the Mix window Inserts View, and left to right in the Edit window Inserts View).

- Inserts on audio tracks and Auxiliary Inputs are pre-fader. You can cause clipping if you boost their gain to extremes, especially on tracks recorded at high amplitude. Watch on-screen metering for indication of clipping. (Inserts on Master Faders are post-fader.)

**How to Use Plug-Ins and Inserts for Effects Processing**

Inserts can be used in two ways:

**On Single Tracks** An insert can be applied to an individual audio track, Auxiliary Input, or Master Fader.

With in-line inserts, you control the amount of effect by adjusting the balance (or, wet/dry) controls of the plug-in or external device.

**As Shared Resources** An insert can be used as a shared resource in a send-and-return arrangement, by bussing signals from several tracks to an Auxiliary Input, and then applying the insert to the Auxiliary Input track. You can then control the send level for each track, and the overall level of the effect can be controlled from the Auxiliary Input track. Using sends and other signal routing features helps maximize your system’s processing power.

For examples of send and return busses and other submixing setups, see “Submixing for Signal Routing and Effects Processing” on page 353.

**Plug-In and Insert Formats**

**Mono Plug-Ins** Are designed for use on mono tracks. Some mono plug-ins (such as Mod Delay) let you generate a stereo output from a mono channel. Inserts that occur on a track after a stereo insert are used in stereo as well.

**Stereo Plug-Ins** Stereo versions of plug-ins become available when you use them on a stereo track. A stereo hardware I/O insert, that sends the signal to an input/output path, can also be created on a stereo track.

**Mono In/Stereo Out Plug-Ins** Are designed to return a stereo effect from a mono source. Certain plug-ins (such as Mod Delay) let you generate stereo output from a mono channel. A track made into stereo in this way has pan controls for each channel of the stereo signal. Any inserts that occur on a track after a stereo insert are automatically used in stereo as well.

**Multi-Mono Plug-Ins** Are designed for use on stereo or greater multichannel tracks when a multichannel version of the plug-in is not available. Parameters for all channels are linked by default so that you can adjust them in tandem. You can unlink parameter controls for independent adjustment using the Master Link button. See “Linking and Unlinking Controls on Multi-Mono Plug-Ins” on page 369.

**Multichannel Plug-Ins** Are designed for use on stereo and greater-than-stereo multichannel tracks. On greater-than-stereo multichannel tracks, the parameters for all channels are generally ganged together.

⚠️ Relinking may cause automation to be lost. See “Linking and Unlinking Controls on Multi-Mono Plug-Ins” on page 369.
TDM and RTAS Plug-Ins

Use the following guidelines for plug-ins supported on your system.

**Pro Tools TDM Systems**  TDM plug-ins can be used on all types of audio tracks. RTAS plug-ins can be used on Auto Voiced audio tracks only. When using RTAS and TDM plug-ins on the same track, RTAS plug-ins must precede TDM plug-ins in the insert signal path.

**Pro Tools LE Systems**  RTAS plug-ins can be used on audio tracks, Auxiliary Inputs, and Master Faders.

For tips on maximizing RTAS performance, see the DigiRack Plug-Ins Guide.

Viewing Plug-Ins and Inserts

Both the Mix and Edit windows can be configured to show or hide inserts. Plug-In windows provide complete access to plug-in parameters.

To show (or hide) inserts in the Mix or Edit windows:

1. Choose Display > Mix Window Shows > Inserts View, or Edit Window Shows > Inserts View.

<table>
<thead>
<tr>
<th>Mix Window Inserts Views</th>
</tr>
</thead>
</table>

Display of Plug-In Bypass, Target, and Window Status

In the Mix and Edit window, the Plug-In button and Selector display bypass state, target status, and window status as follows:

![Indication of bypassed plug-in state](image)

**Hardware Inserts and Bypass**

You cannot bypass hardware inserts from Pro Tools. To monitor playback without a hardware insert, either set it to Inactive, remove it by reassigning it to No Insert, or use a bypass switch on the hardware device itself. See “Inactive Inserts” on page 371 for more information.
Indicating the Controller Target

If you are using a control surface with Pro Tools, only one plug-in can be targeted at a time. The current controller target, if any, is indicated with a color outline around its name:

The controller target

For more information on controller targets, refer to the MIDI Control Surfaces Guide, or the documentation for your Digidesign control surface.

Inactive Plug-Ins

Plug-ins and inserts can be made inactive to free up their resources for other uses. When a plug-in is inactive it retains its assignment, position, all related automation playlists. However, it will not pass audio and does not consume any DSP or TDM resources.

To make a plug-in inactive:

- Command-Control-click the Plug-In button. (Use Option and Option+Shift modifiers to apply to all or all selected, respectively.)
- or -
- Make the track inactive. See “Making Tracks Inactive” on page 90.

When opening sessions, plug-ins will be inactive in any of the following situations:

- The plug-in is not installed.
- The plug-in type is not available (RTAS or TDM). Or, opening the session results in plug-in type substitutions. This can happen if, for example, the type is available but substituting would result in an unsupported condition, such as an RTAS plug-in after TDM plug-ins in a track.

Inactive plug-ins retain all associated automation playlists. In addition, any edits made in the session affect the plug-in automation playlists. You cannot record automation for an inactive plug-in, or edit its controls on-screen.

Display of inactive plug-ins
Inserting Plug-Ins on Tracks

To use a real-time plug-in in a Pro Tools session, insert it on a track.

To insert a plug-in on a track:

1. Make sure the Inserts View is shown in the Mix or Edit window.
2. Click the Insert Selector on the track and select the plug-in that you want to use. (See “TDM and RTAS Plug-Ins” on page 363 for related information.)

To remove an insert from a track:

- Click the Insert Selector and choose No Insert.

Moving and Duplicating Inserts

You can move or duplicate a plug-in insert by dragging it to a different position on the same track or a different track. Inserts that are moved or duplicated retain their original settings and automation. Dragging an insert on top of an existing insert will replace it (and its automation, if any).

To move an insert:

- Drag the insert to the desired location.

To duplicate an insert:

- Option-drag (Macintosh) or Alt-drag (Windows) the insert to the desired location. The duplicated plug-in retains its original settings and automation.
The Plug-In Window

The Plug-In window appears whenever you click the Insert button on a track. This floating window lets you edit the parameters of any real-time plug-in insert in use on a track.

**Settings Menu**
- Lets you copy, paste, save, and import plug-in settings.

**Track Selector**
- Accesses any non-MIDI track in your session.

**Librarian Menu**
- Recalls settings files saved in the plug-in’s root settings folder or in the current session’s Settings folder.

**Insert Position Selector**
- Accesses any insert on the current track.

**Key Input Selector**
- Lets you select audio on a particular input or bus and route it to trigger the plug-in. This menu only appears on plug-ins that feature side-chain processing. Key inputs are monophonic.

**Plug-In Selector**
- Lets you select any real-time plug-in installed in the DAE Plug-Ins folder.

**Compare**
- Toggles between the original saved plug-in setting and any changes you have made to it so you can compare them.

**Effect Bypass**
- Disables the currently displayed plug-in. This lets you compare the track with and without the effect.
Enable Automation Parameters  Lets you enable individual plug-in parameters for automation recording. See “Automating Plug-Ins” on page 386.

Automation Safe  When enabled, prevents existing plug-in automation from being overwritten.

Convert Plug-In  Lets you convert the insert from a TDM plug-in to an RTAS plug-in of the same type (or vice-versa). This feature can only be used on plug-ins that are available in both TDM and RTAS formats.

Target Plug-In  When multiple Plug-In windows are open, clicking this button selects that plug-in as the target for any computer keyboard commands.

Phase Invert  Inverts the phase polarity of the input signal.

Channel Selector  Accesses a specific channel within a multichannel track for plug-in parameter editing. This menu appears only on multi-mono plug-ins inserted on tracks with more than one channel. Shift-clicking this Selector opens a separate Plug-In window for each channel of the multichannel track on which the plug-in is inserted.

Master Link Button  When enabled, links the parameter controls on all channels of a multi-mono plug-in so that they can be adjusted in tandem.

Link Enable Buttons  Lets you selectively link the parameter controls of specific channels of a multi-mono plug-in. Each square represents a speaker channel. The Master Link button must be disabled to use the Link Enable buttons. See “Linking and Unlinking Controls on Multi-Mono Plug-Ins” on page 369.

LFE Enable  Enables plug-in processing of the LFE (low frequency effects) channel on a 5.1, 6.1, and 7.1 multichannel track. To disable LFE processing, deselect this button.

Opening Plug-In Windows

To open a Plug-In window:

- Click the Plug-In button in the Mix or Edit window channel strip.

By default, each plug-in you open will appear in the same location as a currently open plug-in, replacing it in the same window location.

Opening Multiple Plug-In Windows

To reduce screen clutter, Pro Tools normally displays a single Plug-In window from which you can edit the parameters of any plug-in in a session. If you want, however, you can open additional Plug-In windows for specific plug-ins.

Once you begin working with multiple Plug-In windows, you will need to click the Target button on the plug-in whose parameters you want to edit using keyboard commands.

To open additional Plug-In windows:

- In the Mix window, Shift-click the Insert button of the desired plug-in.

To open Plug-In windows for each channel of a multi-mono plug-in:

- Option-click (Macintosh) or Alt-click (Windows) the Channel Selector in the Plug-In window of the desired plug-in.

To close all currently open Plug-In windows:

- Option-click (Macintosh) or Alt-click (Windows) the close box of any currently open Plug-In window.
Using the Plug-In Window

All plug-ins provide standard Pro Tools controls for track and insert selection, bypass, and others, in addition to the EQ, dynamics, and other processor-specific controls.

To select a different plug-in on the same track:
- Click the Insert Selector and choose a plug-in from the pop-up menu.

To choose a different track:
- Click the Track Selector and choose a track from the pop-up menu.

Choosing a plug-in from the Plug-In window

Choosing a track from the Plug-In window

Target Window and Settings Shortcuts

When multiple Plug-In windows are open, a highlighted target indicates the Target window. By default, Pro Tools keeps a single Plug-In Target window. Opening a new plug-in opens it as the new Target window, in the same location.

In addition, the Plug-In Target window is also the focus of keyboard shortcuts for plug-in settings.

Bypassing Plug-Ins

Plug-ins can be bypassed from their Plug-In window, or from the Mix and Edit window Inserts View.

To bypass a plug-in:
- Click the Plug-In window's Bypass button.
- or -
- Command-click (Macintosh) or Control-click (Windows) the plug-in's Insert button in the Mix or Edit window.

💡 When a plug-in insert is bypassed, the Insert Selector in the Mix window changes its color to blue for easy visual reference. If some, but not all channels of an unlinked multi-mono plug-in are bypassed, the Insert Selector appears half blue and half black.
Linking and Unlinking Controls on Multi-Mono Plug-Ins
(TDM Systems Only)

When a multi-mono plug-in is used on a multichannel track of more than two channels, the controls are normally linked. Adjusting the Gain parameter on one channel, for example, will adjust it for all channels.

If necessary, you can unlink plug-in controls on specific channels of a track and edit them independently. You can also selectively link the controls of specific channels.

To unlink controls on a multi-mono plug-in:

1. Deselect the Master Link button.

To access controls for a specific channel:

1. Select the desired channel from the Channel Selector.

To link the controls of specific channels:

1. Deselect the Master Link button if it is not already deselected.
2. Click the Link Enable buttons for the channels whose controls you want to link. For example, to link all channels except the LFE, highlight the icons representing the five full-range speakers in a multi-mono plug-in.

Editing Plug-In Parameters

You can edit plug-in parameters by dragging the parameter’s slider or by typing a value into the parameter’s text box. See the DigiRack Plug-Ins Guide for complete instructions.

To edit a plug-in parameter:

1. Begin audio playback so that you can hear parameter changes in real time.
2. Adjust the parameters of the plug-in for the effect you want.
3. Closing the Plug-In will save the most recent changes.

Keyboard Shortcuts

- For finer adjustments, Command-drag (Macintosh) or Control-drag (Windows) the control.
- To return a control to its default value, Option-click (Macintosh) or Alt-click (Windows) the control.

Keyboard Input for Plug-In Parameters

You can use your computer keyboard to edit plug-in parameters.

If multiple Plug-In windows are open, Tab and keyboard entry remain focussed on the plug-in that is the Target window.

To edit parameters with a keyboard:

- Click in the parameter text field that you want to edit to activate the field. Type the desired value.
- In fields that support values in kilohertz, typing “k” after a number value will multiply the value by 1000. For example, type “8k” to enter a value of 8000.
To increase a value, press the Up Arrow on your keyboard. To decrease a value, press the Down Arrow on your keyboard.

Press Enter on the numeric keyboard after typing a value to input the value (without leaving the selected parameter field).

Press Return (Macintosh) or Enter on the alpha keyboard (Windows) to enter the value and leave keyboard editing mode.

To move downward through the different parameter fields, press the Tab key. To move upwards, press Shift-Tab.

Plug-In Automation and Safe

All real-time plug-ins can be fully automated, and support all Pro Tools automation modes (Write, Touch, and Latch, plus Trim).

The Auto button opens the Enable Automation Parameters dialog, where you can enable individual plug-in parameters for automation recording. See Chapter 28, “Automation” for more information on this feature and shortcuts to enable plug-in parameters.

The Safe button engages Automation Safe mode. When enabled, existing plug-in automation is protected from being overwritten. (See “Automating Plug-Ins” on page 386 for more information.)

Hardware I/O Inserts

You can connect external devices, such as reverb or effects processors, to your Pro Tools system and use them as inserts or make them the destination for effects sends and returns.

Pro Tools inserts utilize hardware input and output channels to send and return the audio. Inserts can be defined, and their channels mapped to audio interface channels, in the I/O Setup dialog.

If you plan to use a device as an insert, be sure to connect the device to matching inputs and outputs on your system. For example, a stereo insert could use outputs 7–8 and inputs 7–8 for the sends and returns, respectively. Routing the physical inputs and outputs of the interface to Pro Tools inputs and outputs can be done in either the Hardware Setup dialog (or I/O Setup dialog). For more information, see “Hardware Setup” on page 39, or “Routing Hardware I/O to Pro Tools I/O” on page 63.

To define hardware inserts:

1. Choose Setups > I/O Setup, then click the Inserts tab.
2. Select an insert path, or click New Path to create a new Insert path.
3. Double-click the Path Name to enter a custom path name for the insert.
4. Make sure the insert path is set to the correct format (mono, stereo, or other).
5. Map inserts in the Channel Grid as needed. Insert and Output paths have special rules regarding channel mapping (see “Overlapping Channels and Valid Paths” on page 69).
Assigning Inserts

To assign a hardware insert to a track:

- Select an insert from the track Insert Selector.

Inactive Inserts

Hardware inserts can be made Inactive. An inactive insert retains its assignment, but does not pass audio and does not consume any DSP resources. In addition, any mixer resources required for the insert are removed.

You can use the inactive feature whenever you need to mute or bypass a hardware insert. Inserts do not provide a standard bypass control.

To make an insert inactive:

- On Macintosh, Command-Control-click the Insert button. On Windows, Ctrl-Logo-click the Insert button. Use the Option and Option+Shift modifiers (Macintosh), or Alt and Alt+Shift modifiers (Windows), to apply to all or all selected tracks, respectively
  - or -

- Make the track inactive (this sets all associated inserts, sends, outputs, and plug-ins inactive).

When opening sessions on a system with insufficient DSP resources, unavailable inserts are automatically set to inactive.

Connecting and Integrating External Devices

Pro Tools TDM and Digi 001 systems can create dedicated connections to external analog or digital devices. The number and type of connections depends on what kind of system you have.

You can also use the inputs and outputs of an Audiomedia III card to connect external devices. You can send and return an analog signal using the analog connectors on the card, and monitor through a DAT machine connected to the digital output. You can also send and return a digital signal to an external device that supports digital I/O (such as a reverb unit), and monitor with the analog outputs.

To connect an external device to a Pro Tools system:

1. Connect an unused output (or pair of outputs for a stereo device) of your Pro Tools system to an input of the external signal processor.

2. Connect the output of the external signal processor to an unused input (or pair of inputs for a stereo device) of your Pro Tools system.

3. Define what physical ports are routed to Pro Tools input and output ports, as appropriate, in either the Hardware Setup dialog or I/O Setup dialog.

4. Define output, input, or insert paths as appropriate in the I/O Setup dialog.
If you plan to use a device as an insert, be sure to connect the device to matching inputs and outputs on your system. For example, a stereo insert could use outputs 7–8 and inputs 7–8 for the sends and returns, respectively.

For additional information on connecting external devices, refer to the Pro Tools Getting Started Guide that came with your system.

Connecting Effects Units Digitally

If you want to use the digital inputs and outputs on your Pro Tools system as effects sends and returns to a digital effects device, Pro Tools should be the clock master in most cases. Set your digital effects device to accept an external digital clock so that it synchronizes to Pro Tools.

To set up a digital send to an external device from a TDM system:

1. Do one of the following:
   - On a 192 I/O of 96 I/O, choose Setups > Hardware Setup, choose the peripheral, and set the channel pair to the digital input.
   - On an 888/24 I/O Interface, choose Setups > Hardware Setup, choose the peripheral, and set Channel 1–2 input to Digital.
   - On an 882/20 I/O or 1622 I/O Interface, choose Setups > Hardware Setup, choose the peripheral, and set Channel 1–2 input to Digital.
2. Choose Internal from the Clock Source popup menu (formerly labeled Sync Mode).
3. Click OK.

To set up a digital send to an external device from a Digi001 system:

1. Choose Setups > Playback Engine and choose the peripheral.
2. Do one of the following:
   - If the external device is connected to the S/PDIF RCA jacks, deselect S/PDIF Mirroring. (When S/PDIF Mirroring is on, digital output at the S/PDIF RCA jacks exactly mirrors the output of analog Channels 1–2.)
   - If the external device is connected to the Optical ports, choose a format (most likely S/PDIF for an effects device) from the Optical Format pop-up menu.
3. Choose Internal from the Sync Mode pop-up menu.
4. Click OK.
5. Optionally, configure the I/O Setup dialog with new path names for effects routing.

To set up a digital send to an external device from an Audiomedia III system:

1. Choose Setups > Playback Engine, choose the peripheral, and deselect S/PDIF Mirroring. (When S/PDIF Mirroring is on, digital output at the S/PDIF RCA jacks exactly mirrors the output of analog Channels 1–2.)
2. Choose Internal from the Sync Mode pop up menu.
3. Click OK.
4. Optionally, configure the I/O Setup dialog with new path names for effects routing.

If you set the Optical Format to S/PDIF, Pro Tools will watch the Optical port for any audio input on the S/PDIF RCA jacks.
Using External Clock Sources

Pro Tools|HD can use the digital inputs on any HD-series interface enabled in the Loop Sync chain as a source for digital master clock. To synchronize to an external clock source, connect the device to an appropriate digital input on any HD I/O.

TDM Systems

Pro Tools can receive external clock through any of the digital inputs on any HD-series I/O (including AES/EBU, SPDIF, and Optical).

If your expanded HD system includes Legacy interfaces (such as the 888|24 I/O), connect to the digital input on Channels 1–2 of the Legacy audio interface in order to clock from them. Legacy I/Os only support 44.1 kHz and 48 kHz.

To select an external clock source for a TDM system:

1. Choose Setups > Hardware Setup.
2. Select the appropriate HD I/O in order to display its settings in the Main page.
3. If necessary, enable the appropriate Digital Format (if you have not already done so, according to instructions in the Getting Started Guide or I/O Guide).
4. Choose the appropriate Clock Source.
5. Configure input routing of the digital source, using the Input and Output pop-ups, if necessary.
6. Click OK to close Hardware Setup.

Digi 001 Systems

Pro Tools can receive external clock from the optical input (on the Digi 001 PCI card) or S/PDIF input (on the Digi 001 I/O box).

To select an external clock source for a Digi 001 system:

1. Choose Setups > Hardware Setup.
2. Set the Sync Mode to match the type of input.
3. If you choose Optical, make sure the Optical Format matches the type of optical input you are sending to your Pro Tools system.

Audiomedia III Systems

Pro Tools can receive external clock from the S/PDIF input on the Audiomedia III card.

To select an external clock source for an Audiomedia III system:

1. Choose Setups > Hardware Setup.
2. Set the Sync Mode to match the type of input.
Chapter 28: Automation

Pro Tools features dynamic automation of volume, pan, and mute controls for audio tracks and sends, MIDI tracks, and real-time plug-in parameters. In Pro Tools, you can write automation moves in real time during playback of your session. You can also edit automation data with the same techniques you use to edit audio and MIDI data.

Automation Accuracy with Control Surfaces

ProControl and Control|24 Digidesign’s ProControl and Control|24 control surfaces support all automation features in Pro Tools.

MIDI Control Surfaces Most MIDI control surfaces have 8-bit resolution, or 128 steps; the Mackie HUI has 9-bit resolution, or 512 steps. Pro Tools interpolates this input to a much higher resolution on playback, resulting in fader automation that is smooth enough to satisfy professional requirements.

Automation Quick Start

Pro Tools provides many options for recording, replacing, and editing automation data.

The basic steps for automation recording are:

- Enable the automation type that you want to record (volume, pan, mute, send level, send pan, send mute, or plug-in automation).
- Put the appropriate tracks in an automation writing mode (Write, Touch, or Latch, or a Trim mode).
- If you are automating a plug-in, enable the individual plug-in parameters to be automated.
- Automation Safe any plug-ins, outputs, or sends that have existing automation data that you want to protect from being overwritten.
- Begin playback to begin automation recording, and adjust controls as needed. Pro Tools remembers all moves performed on enabled parameters.

To edit automation once it has been recorded, you can:

- Repeat the above steps to write new automation over the previous data.
- Graphically edit the automation data in the Edit window.
- Cut, copy, paste, or delete automation data (certain restrictions apply).

For details on using a Digidesign control surface to create mix automation, refer to your Digidesign control surface guide.
Automation Playlists

Each Pro Tools track contains a single automation playlist for each automatable control.

On audio tracks, these controls include:
- Volume
- Pan
- Mute
- Send volume, pan, and mute
- Plug-in parameters

On MIDI tracks, these controls include:
- Volume
- Pan
- Mute

You can display and edit each of these automatable parameters individually from Pro Tools, even during playback.

In addition, you can display and edit other continuous MIDI controller data (such as mod wheel, breath controller, foot controller, or sustain) in a similar manner. For more information on editing MIDI data, see “Continuous Controller Events” on page 305.

Audio Tracks

On audio tracks, automation data resides on a separate playlist from audio data and regions. Each edit playlist on an audio track shares the same automation data.

MIDI Tracks

On MIDI tracks, all controller automation data except for Mute data is stored in the MIDI region that contains it. Each edit playlist on a MIDI track is separate, and represents a distinct performance, complete with controller automation.

⚠️ Mute data is independent of the MIDI data in a MIDI region. This lets you mute playback of individual MIDI tracks in Pro Tools without altering the controller data.

Multiple Edit Playlists and Audio Track Automation

All edit playlists on a single audio track share the same automation data. When you record or edit automation data in an audio track, the automation data is stored in the track automation playlist so it can be edited with, or independently from, its associated audio regions. (MIDI automation data always follows region editing, with the exception of mute. See “MIDI Tracks” on page 376 for more information.)

- When you copy or cut audio data from a track while it is in Waveform View, the underlying automation data is cut or copied with it.
- If you paste audio data from other locations or tracks into an edit playlist, you may change the underlying automation data on the track.
When you trim audio regions with the Trim tool, or cut, copy, paste, or delete audio regions, underlying automation data is also trimmed, cut, copied, pasted, or deleted.

When you use the Trim command, the underlying automation data remains, unchanged.

For more information, see “Editing Automation” on page 391.

Duplicating Tracks for Playlist Editing

The Duplicate Selected Track command provides a convenient way to make a working copy of a track to experiment with routing, plug-ins, and automation. This protects the original track and its automation data from being edited or overwritten.

To copy a track for automation:

1. Select the track and choose File > Duplicate Track. Duplicate Track creates a complete copy of the track, including all routing, plug-ins, and automation.

2. Command-Control-click the Track Type icon, or select that track and choose File > Make Selected Tracks Inactive.

3. Begin editing automation and other parameters on the duplicated track.

Edit and assemble the track regions before applying automation to them.

Automation Modes

Each track provides an Automation Mode Selector. Automation modes control how a track’s automation data is written and played back.

Auto Off

Auto Off mode turns off automation for all automatable controls:

- Volume
- Pan
- Mute
- Send volume, pan, and mute
- Plug-in parameters
- MIDI volume, pan, and mute

In Auto Off mode, automation data for these parameters is ignored during playback. All other MIDI controller data is sent.

Auto Read

Auto Read mode plays the automation that was previously written for a track.

Auto Write

Auto Write mode writes automation from the time playback starts to the time it stops, erasing any previously written automation for the duration of the automation pass.

After an automation pass, Pro Tools automatically switches from Auto Write mode to Auto Touch mode. This prevents you from accidentally overwriting automation data on later playback. On TDM systems, you can turn off this behavior and remain in Auto Write mode. See “Write Switches To Touch After Pass” on page 380 for details.
Auto Touch

Auto Touch mode writes automation only while a fader or switch is touched or clicked with the mouse. When the fader is released, the writing of automation stops and the fader returns to any previously automated position, at a rate determined by the AutoMatch and Touch Timeout settings. See “Automation Preferences” on page 380.

In Auto Touch mode, certain control surfaces start writing automation as soon as you touch them. These include:

- Touch-sensitive motorized fader controllers, such as Digidesign ProControl or Control|24, or the Mackie HUI.
- Continuous-belt controllers, such as the Penny & Giles DC16/MM16.

With other control surfaces in Auto Touch mode, writing of automation does not begin until the fader hits the pass-through point, or the previously automated position. Once you reach the pass-through point with the fader, writing of automation begins and continues until you stop moving the fader.

Auto Latch

Auto Latch mode works in the same way as Auto Touch mode, writing automation only if you touch or move a control. However, unlike Auto Touch, writing of automation continues until you stop playback. This mode is particularly useful for automating pan controls and plug-ins, since it does not time out and revert to its previous position when you release a control.

See also “Writing Automation to the Start, End or All of a Selection” on page 397.

Trim Mode

(TDM Systems Only)

Pro Tools TDM systems can adjust (or trim) existing track volume and send level automation data in real time. Pan and plug-in automation cannot be trimmed in this manner. Trim mode works in combination with the other Automation modes (Auto Read, Auto Touch, Auto Latch, Auto Write) and is useful when you want to preserve all of your volume automation moves, but need to make levels a bit louder or softer to balance a mix.

When editing automation in Trim mode, fader moves write relative rather than absolute values. The existing automation data is changed by the amount of increase or decrease (or the delta value) indicated by the faders. When trimming, a track’s Volume indicator or Send Level indicator shows the delta values being written rather than the absolute value.

When Trim mode is enabled, non-trimmable controls behave in the same manner as in the standard Automation modes, with the exception of Trim/Auto Write mode, where non-trimmable controls operate as in Auto Touch mode.

Trim/Auto Off

Trim/Auto Off mode turns off automation and trimming for a track. All automation moves are ignored during playback.

Trim/Auto Read

In Trim/Auto Read mode, volume and send faders follow the previously written automation. When one of the faders is touched, the trim moves (delta values) are played back, but are not written into the automation data. This lets you audition trim moves without affecting existing automation.
When this mode is enabled, non-trimmable controls (all controls other than track volume and send level) behave as if they are in regular Auto Read mode—no automation data is written.

**Trim/Auto Touch**

In Trim/Auto Touch mode, when playback begins, volume and send faders follow the previously written automation. When one of the faders is touched, real-time trimming begins. Fader moves write delta values (an increase or decrease in existing automation data).

When the fader is released, trimming stops and the fader returns to a zero delta value and continues to follow the previously written automation. The rate of the fader’s return to a zero delta value is determined by the AutoMatch Time specified in the Automation Preferences. See “Automation Preferences” on page 380 for more information.

When this mode is enabled, non-trimmable controls (all controls other than track volume and send level) behave as if they are in regular Auto Touch mode—they follow the previously written automation until touched. When they are touched, their absolute positions are written until playback is stopped.

**Trim/Auto Latch**

In Trim/Auto Latch mode, when playback begins, volume and send faders follow the previously written automation. When one of the faders is touched, real-time trimming begins. Any fader moves after trimming begins increase or decrease existing automation data accordingly. Trimming of the touched control continues until playback stops.

When Trim/Auto Latch mode is enabled, non-trimmable controls (all controls other than track volume and send level) are not in Write mode, but behave as if they are in regular Auto Latch mode (no automation is written unless a control is touched). This is to prevent the controls from overwriting all of their automation data on every pass in Trim mode.

**Trim/Auto Write**

In Trim/Auto Write mode, the volume and send level faders are disengaged from displaying the existing automation data, so you don’t have to chase them during playback. Faders are automatically positioned at 0 dB, where no trimming occurs (they start with a delta value of zero). From this reference point you can then set the initial delta values before initiating playback.

In this mode, as soon as playback begins, delta values are applied to the existing automation data. Trimming continues until playback stops.

When Trim/Auto Write mode is enabled, non-trimmable controls (all controls other than track volume and send level) are not in Write mode, but behave as if they are in regular Auto Touch mode (no automation is written unless a control is touched). This is to prevent the controls from overwriting all of their automation data on every pass in Trim mode.

⚠️ In Trim mode, tracks do not automatically change from Trim/Auto Write to Trim/Auto Touch after an automation pass. Be sure to switch out of Auto Write when you leave Trim mode to avoid overwriting automation data.
Automation Preferences

Pro Tools gives you several options for controlling the writing and playback of automation data.

To display Automation Preferences:
- Choose Setups > Preferences, and click Automation.

Automation Preferences dialog

Faders Move During Playback When selected, on-screen faders move if automation has been written for them. When this option is deselected, automation still operates, but on-screen faders do not move. Turning this option off can help speed up screen redraws and processing if you are using a slower computer.

Smooth and Thin Data After Pass When selected, Pro Tools automatically smooths and then applies the specified amount of thinning to the automation data created in an automation pass. (See also “Degree of Thinning” on page 381, and “About Smoothing” on page 381.)

Write Switches To Touch After Pass (TDM Systems Only) After an automation pass in Auto Write mode, Pro Tools automatically switches to Auto Touch mode. On TDM systems, you can choose to stay in Auto Write mode by deselecting this option.

⚠️ Write Switches to Touch After Pass does not affect Trim mode. In Trim mode, tracks do not automatically change from Trim/Auto Write to Trim/Auto Touch after an automation pass.

Mutes Follow Groups When selected, muting a track that belongs to a group mutes all other members of the group. When this option is deselected, tracks must be muted on an individual basis. You can mute or unmute individual group members by Control-clicking (Macintosh) or Right-clicking (Windows) the Mute button of the track you want to affect individually.

Solos Follow Groups When selected, soloing a track that belongs to a group solos all other members of the group. When this option is deselected, tracks must be soloed on an individual basis. You can solo individual group members by Control-clicking (Macintosh) or Right-clicking (Windows) the Solo button of the track you want to affect individually.

Send Mutes Follow Groups When selected, muting a send on a track that belongs to a group mutes that send (A–E) on all tracks in the group.

Send Levels Follow Groups When selected, adjusting the level of a send on a track that belongs to a group adjusts that send (A–E) on all members of the group.
**LFEs Follow Groups** When selected, adjusting the level of an LFE slider, or editing LFE automation breakpoint data, on a track or send that belongs to a group adjusts the LFE on all tracks of the group. With send-based LFEs, grouping affects only that send (A–E) on other tracks.

**Degree of Thinning** Specifies the amount of thinning performed on automation data when you use the Thin Automation command, or if you have selected the Smooth and Thin Data After Pass option in this dialog. (See also “About Thinning” on page 381.)

**Touch Timeout** If you are writing automation in Auto Touch mode and you stop moving a non-touch sensitive control, Pro Tools continues to write automation for the Touch Timeout value.

After the Touch Timeout period, writing of automation stops and the automation data returns to its previous automation value at the rate specified in the *AutoMatch Time* setting.

**AutoMatch Time** If you are writing automation in Auto Touch mode, when you release a fader or control, writing of automation stops and the automation data returns to its previous automation value. The rate of return to the previous value is the AutoMatch Time. See “About AutoMatch” on page 381.

**Amount of memory to reserve for automation recording** Allocates memory for automation. See “Setting the Automation Buffer Size” on page 382 for details.

**About Smoothing**

When you perform automation moves with a continuous control, Pro Tools records the move as a series of very small steps, resulting in a staircase pattern with many breakpoints. Smoothing intelligently resolves this staircase pattern into a single, smooth ramp from one breakpoint to the next. (Smoothing does not apply to switched controls such as mutes or plug-in bypasses.) With smoothing enabled, the resulting automation is often a more accurate representation of actual automation moves.

**About Thinning**

Thinning automatically reduces the overall number of breakpoints in the automation playlist in order to improve system performance. The amount of thinning applied is determined by the Degree of Thinning setting in the Automation Preferences. When using high amounts of thinning, the resulting automation may differ noticeably from the original automation moves. Thinning only applies to audio tracks, and does not affect MIDI tracks. For instructions, see “Thinning Automation” on page 389.

**About AutoMatch**

When you write automation in Auto Touch mode, if you release a fader during playback, Pro Tools returns to the level of any automation still on the track by ramping up or down over a certain amount of time, called the *AutoMatch Time*. This time value is set in the Automation Preferences.

The AutoMatch feature works with continuous controls (such as Volume or Pan) by ramping their values back to previously automated levels. There are some stepped controls (for example,
the EQ type in the 1-band EQ plug-in) that provide more than two discrete steps over their operational range. AutoMatch has no effect on these controls.

**AutoMatch Indicators**

There are triangular AutoMatch indicators at the bottom left of each channel strip in the Mix window. These indicate the direction you need to move a fader in order to match the original automation level of that fader.

![AutoMatch indicator](image)

**Triangular AutoMatch indicators on a channel strip**

**Setting the Automation Buffer Size**

Pro Tools lets you specify the size of the memory buffer used to write automation. If you are working on a large session or writing a very large number of automation moves, you may want to increase this value.

**To set the Automation Buffer size:**

1. Choose Setups > Preferences and click Automation.

2. For the option “Amount of memory to reserve for automation recording,” enter a value between 200 and 3000K (the default value for a new session is 200K.)

3. Relaunch Pro Tools for this change to take effect.

---

**About Processing Bandwidth**

Meters in the System Usage window indicate how much of your system’s processing power is being used in processing audio, and when writing and playing back automation. In Pro Tools LE, these meters show System Activity and CPU Processing Activity; on Pro Tools TDM systems, they show System Activity, PCI Bus Activity, CPU Processing Activity, and TDM Time Slot usage.

As these meters approach their limits, recording or playback of automation data may be affected. If CPU or PCI Activity are high, a System error may occur. If System Activity is high, Pro Tools may miss playback of some of your automation data during particularly dense periods of activity, such as while using the Bounce to Disk command.

For more information, see “Bounce to Disk” on page 406.
To reduce processing load, try the following:

- Deselect the Faders Move During Playback option in the Automation Preferences.
  - or -
- Reduce the density of automation in places where it shows the most activity. For details, see “Thinning Automation” on page 389.
  - or -
- Turn off Sends View meters, if enabled, in the Preferences > Display window. See “Sends View Meters” on page 348 for more information.

**Automation Safe**

Outputs, sends, and plug-ins can be placed in Auto Safe mode. In Auto Safe mode, any automation associated with an Output window (track or send level, panning, mute, and so on), or plug-in on that track, is protected from being overwritten while automating other items on that track.

Automation Safe enabled in a plug-in

Automation Safe mode suspends automation recording for the selected track output, send, or plug-in in which it is enabled. You can also suspend automation recording and playback session-wide from the Automation Enable window. See “Enabling and Suspending Automation” on page 387.

**Viewing Automation**

Pro Tools creates a separate playlist for each type of automation you write. This data can be viewed and edited in the same way as audio and MIDI data.

**To show automation data:**

- Click the Track View Selector and select from the pop-up menu the automation type you want to view.

Displaying automation data

You can easily toggle between Volume and Waveform View for audio tracks. For more information, see “Toggling Track Views” on page 172.
Writing Automation

You can write automation for all automatable controls by moving those controls during playback.

To write automation on a track:


2. Make sure the automation type is write-enabled.

3. Select an Automation mode for each track you want to automate. For an initial automation pass, select Auto Write.

4. Click Play to begin writing automation. Move the controls you want to automate.

5. When you have finished, click Stop.

- After the first automation pass, you can write additional automation to the track without completely erasing the previous pass by choosing Auto Touch mode or Auto Latch mode. These modes add new automation only when you actually move the control for that parameter. (See "AutomationModes" on page 377.)

To write additional automation to a previous pass:

1. Link the Edit and Timeline.

2. In the Edit window, make a selection or place the cursor in a location where you want to write automation.

3. Choose Auto Touch or Auto Latch mode on the tracks you want to automate.

4. Click Play to begin writing automation. Move the controls you want to automate.

5. When you have finished, click Stop.

If you write automation in Auto Touch mode with Loop Playback enabled, writing of automation will automatically stop at the end of the looped selection. At the beginning of each successive loop, you can then touch or move the control again to write new data.

Storing an Initial Controller Position

When you create a new audio track, Auxiliary Input, or MIDI track, it is automatically placed into Auto Read mode. Even though the track is in Auto Read mode, you can set the initial position of any automatable control, and it is saved with your session.

In this initial state, only a single automation breakpoint appears at the beginning of each automation playlist. If you move the control without writing automation, this breakpoint will move to the new value.
You can permanently store the initial position of an automatable control by doing one of the following:

- Place the track in Auto Write mode and press Play to write a few seconds of automation data to the track
- Manually place a breakpoint on the automation playlist somewhere after the initial breakpoint. (See “Graphical Editing of Automation Data” on page 391 for more information.)

**Automating Switched Controls**

Pro Tools treats switched controls (such as mutes and plug-in bypasses) as touch sensitive controls. Automation data is written for as long as the switch or button for that control is pressed or touched.

For example, if you have just written a series of mute on/off states on a track in quick succession, the manual method for clearing this automation data would require you to move to the Edit window, choose automation playlist for Mute, select the mute automation data, and delete it.

In Pro Tools, you don’t have to perform all of these steps. Instead, you can perform another automation pass on the track and hold down the Mute button when it reaches the state you want to remove. For example, when playback gets to the first muted section, the Mute button become highlighted. At this time, press and hold down the Mute button. As long as you hold down the button, Pro Tools overwrites the underlying mute data on the track with the current state of the switch (on or off) until you stop playback (use the Spacebar to stop playback).

**Automating Sends**

Pro Tools provides dynamic automation of send level, send mute, and send pan (for stereo and multichannel sends only). This makes it easy to control effects levels and placement during mixdown with great precision.

Send level and mute can also be configured to follow groups.

**To automate a send level, mute or pan:**

1. In the Automation Enable window, make sure the automation type is write-enabled (send level, send mute, send pan).
2. Choose an Automation mode for each track you want to automate. For an initial automation pass, choose Auto Write.
3. To display send controls, do any of the following:
   - Select Windows > Mix Window Shows > Sends View, then click the send to open the Output window for the send that you want to automate.
   - Choose Display > Sends View Shows and select the individual send from the submenu.
4. Click Play to begin writing automation. Move the controls you want to automate.
5. When you have finished, click Stop.

**Send mutes and levels can also be configured to follow Mix Groups. See “Automation Preferences” on page 380 for information.**
**Copying Track Automation to Sends**  
*(TDM Systems Only)*

There may be times where you want a track’s send automation to mirror automation in the track itself, for example, when an effect level needs to follow the levels in a main mix. To do this, you can copy the entire automation playlist for the selected control to the corresponding playlist for the send.

**To copy a track’s automation to one of its sends:**

1. Select the tracks you want to edit by clicking on the track names to highlight them.
2. Choose Edit > Copy To Send.

3. In the Copy to Send dialog, select Automation to copy the entire automation playlist for the corresponding controls.
4. Choose the controls you want to copy.
5. Choose the sends to copy the automation to, and click OK.

When overwriting automation, Pro Tools presents a confirmation dialog. To suppress this dialog, press Option (Macintosh) or Alt (Windows) while choosing the command.

You can undo the results of the Copy to Send command by choosing Edit > Undo.

---

**Automating Plug-Ins**

You can create dynamic automation for virtually all parameters of the plug-ins included with your Pro Tools system. Automating a plug-in is slightly different from other automation procedures in that you must enable automation parameters for the plug-in.

**To enable plug-in parameters for automation:**

1. Click the Automation Enable button in the Plug-In window.

2. Select the parameters to automate and click Add. If there are multiple plug-ins on the same track, you can select from among these by clicking their buttons in the Inserts section of this dialog.

As an alternative to using the Plug-In Automation dialog, you can enable individual plug-in parameters directly from the Plug-In window by Command-Control-clicking (Macintosh), or Control-Start-clicking the parameter. See the DigiRack Plug-Ins Guide or Digidesign Plug-Ins Guide for more information.
To automate a plug-in:

1. In the Automation Enable window, make sure the Plug-In parameter is enabled.
2. Select an Automation mode for each track you want to automate. For an initial automation pass, choose Auto Write.
3. Click OK to close the Plug-In Automation dialog.
4. Click Play to begin writing automation. Adjust the plug-in parameters.
5. When you have finished, click Stop.

Plug-In Safe

You can use Automation Safe mode to protect plug-in automation from being overwritten.

To enable Plug-In Safe mode:

1. Open a plug-in.
2. Click to enable the Safe button.

Enabling and Suspending Automation

From the Automation Enable window, you can enable or suspend writing for the following automation parameters across all tracks:

- Volume
- Pan
- Mute
- Plug-in
- Send level
- Send pan
- Send mute

To suspend writing of automation on all tracks:

2. Do one of the following:
   - To suspend writing of all automation on all tracks, click the Auto Suspend button.
   - To suspend writing of a specific type of automation on all tracks, click the button for that automation type (volume, mute, pan, plug-in, send level, send mute, or send pan).
**Suspending Automation Playback**

You can suspend playback of automation parameters for tracks by clicking on the track’s View Selector.

To suspend playback (and writing) of automation on individual tracks:

1. In the Edit window, set the Track View Selector to show the automation parameter you want to suspend.

2. Do one of the following:
   - To suspend writing and playback of only the displayed automation parameter, Command-click (Macintosh) or Control-click (Windows) the parameter name in the Track View Selector.
   - To suspend writing and playback of all automation parameters, Command-Shift-click (Macintosh) or Control-Shift-click (Windows) the name of any automation parameter in the Track View Selector.
   - To suspend writing and playback of an automation parameter on all tracks, Command-Option-click (Macintosh) or Control-Alt-click (Windows) the name of the automation parameter in the Track View Selector.

⚠️ Enabling and suspending automation from the Edit window obeys Edit Groups (except for Pan automation). This grouped behavior can be suppressed by Command-clicking (Macintosh) or Start-clicking (Windows) the parameter name.

**Automation Enable Guidelines**

The following rules determine whether automation is written or played back for a track:

- Although Pro Tools shows a single Automation mode for each track, all controls associated with that track are not necessarily in the same Automation mode.

- If automation is globally suspended in the Automation Enable window, all controls behave as if they were in Auto Off mode, regardless of the track’s current Automation mode.

- If an automation parameter is suspended by Command-clicking (Macintosh) or Control-clicking its name in the Track View Selector, that parameter behaves as if it were in Auto Off mode, regardless of the track’s current Automation mode.

- If an automation parameter is suspended in the Automation Enable window, that parameter behaves as if it is in Auto Read mode when the track is in a recordable Automation mode (Auto Touch, Auto Latch, or Auto Write mode).

**Deleting Automation**

Automation data takes the form of a line graph with editable breakpoints. The easiest way to remove automation in a track or selection is to manually delete breakpoints from the automation playlist.

Removing data in this manner is different from using the Cut command, which creates anchor breakpoints at the boundaries of the remaining data. For details, see “Cutting, Copying, and Pasting Automation” on page 395.
To remove automation data, display the automation parameter you want to edit by selecting it from the Track View Selector, and do one of the following:

**To remove a single breakpoint:**
- With the Grabber or the Pencil Tool, Option-click (Macintosh) or Alt-click (Windows) the breakpoint.

**To remove several breakpoints at once:**
- Use the Selector to select a range that contains the breakpoints, and press Delete (Macintosh) or Backspace (Windows).

**To remove all automation data of the displayed type:**
- Click with the Selector in the track and choose Edit > Select All, then press Delete (Macintosh) or Backspace (Windows).

**To remove all automation for all automation playlists on a track:**
1. Use the Selector to select a range of data to be removed.
2. Press Control+Delete (Macintosh) or Control+Backspace (Windows).

All automation data within the selection is removed for all automation playlists on that track, regardless of whether automation is write-enabled for those parameters.

---

**Thinning Automation**

Pro Tools writes a maximum density of automation data during an automation pass, in the form of breakpoints. Since Pro Tools creates ramps between breakpoints, it may not need all of the captured points to create a sonically accurate representation of the automation moves that you have made. Each breakpoint takes up space in memory allocated for automation, so thinning data can maximize efficiency and CPU performance.

Pro Tools provides two different ways to thin automation data and remove unneeded breakpoints: the Smooth and Thin Data After Pass option and the Thin Automation command.

**Using Smooth and Thin Data After Pass**

When this option is selected in the Automation Preferences, Pro Tools automatically thins the automation breakpoint data after each automation pass.

**The Smooth and Thin Data After Pass Option**

In the default settings for new sessions, the Smooth and Thin Data After Pass option is selected, with the “Some” setting chosen. In most cases, this setting yields optimum performance while providing an accurate reproduction of your automation moves.

If you choose None, Pro Tools writes the maximum possible number of breakpoints. You can still perform thinning at any time with the Thin Automation command. For more information on smoothing automation data, see “About Smoothing” on page 381.
Using the Thin Automation Command

The Thin Automation command lets you selectively thin areas in a track where automation data is too dense. You can use the Undo command to audition the results of thinning (comparing thinning and not thinning) before you apply it permanently.

To use the Thin Automation command:

1. In the Edit window, click the Track View Selector to display the automation type you want to thin.
2. With the Selector, highlight the automation data you want to thin. To thin all automation of the selected type in the track, click the Selector in the track and choose the Select All command.
3. Choose Edit > Thin Automation to thin the selected automation by the amount you have selected in the Automation Preferences.

Drawing Automation

You can use the Pencil tool to create automation events for audio and MIDI tracks by drawing them directly in any automation or MIDI controller playlist.

The Pencil tool can be set to draw a series of automation events with the following shapes:

- **Free Hand** Draws any shape. In audio tracks, the shape has the number of breakpoints needed to smoothly interpolate and reproduce the automation shape. In MIDI tracks, the shape is reproduced as a series of steps, according to the resolution setting in the MIDI preferences.
- **Line** Draws a straight line. In audio tracks, the line has a single breakpoint at either end. In MIDI tracks, the controller value changes in steps according to the resolution setting in the MIDI preferences.
- **Triangle** Draws a sawtooth pattern that repeats at a rate based on the current Grid value. In audio tracks, the pattern has a single breakpoint at each extreme. In MIDI tracks, the controller value changes in steps according to the resolution setting in the MIDI preferences. Amplitude is controlled by vertical movement of the Pencil tool.
- **Square** Draws a square pattern that repeats at a rate based on the current Grid value. Amplitude is controlled by vertical movement of the Pencil tool.
- **Random** Draws a random pattern of levels that change at a rate based on the current Grid value. Amplitude is controlled by vertical movement of the Pencil tool.

Using Pencil Tool Shapes

You can draw automation for audio as well as MIDI tracks. For example, you can use the Triangle pattern to control continuous functions, or the Square pattern to control a switched function such as Mute or Bypass.

Since the pencil draws these shapes using the current Grid value, you can use it to perform panning in tempo with a music track, or on frame scene changes when working in post production.
Resolution of MIDI Controller Data

When using the Pencil tool to draw MIDI automation, the data is drawn as a series of discrete steps. You can control the resolution (or density) of these steps to help manage the amount of MIDI data sent for a given MIDI controller move.

**To set the resolution for the Pencil tool:**

1. Choose Setups > Preferences and click MIDI.
2. Enter a value for “Pencil Tool Resolution When Drawing Controller Data.” The value can range from 1 to 100 milliseconds.

The illustrations below show the same MIDI controller automation drawn with different Pencil Tools resolution settings.

You may want to choose a smaller value for MIDI controls that need higher resolution (such as MIDI volume), and a larger value for controls that may not require such a high resolution (such as Pan).

Editing Automation

Pro Tools provides several ways to edit automation data for any track in your session. You can edit automation data graphically, by adjusting breakpoints on the automation playlist of a track. You can also cut, copy, and paste automation data in the same manner as audio and MIDI data.

Graphical Editing of Automation Data

Automation data takes the form of a line graph with editable breakpoints. By dragging these breakpoints, you can modify the automation data directly in the Edit window. When you drag an automation breakpoint up or down, the change in value is numerically or textually indicated. Dragging an automation breakpoint to the left or right adjusts the timing of the automation event.

Using the Grabber

The Grabber lets you create new breakpoints by clicking on the graph line, or adjust existing breakpoints by dragging them. Option-click (Macintosh) or Alt-click (Windows) breakpoints with the Grabber to remove them.
Using the Pencil Tool
The Pencil tool lets you create new breakpoints by clicking once on the graph line. Option-click (Macintosh) or Alt-click (Windows) breakpoints with the Pencil tool to remove them.

Using the Trimmer
The Trimmer lets you adjust all selected breakpoints up or down by dragging anywhere within that selection.

Editing Automation Types
Each automatable control has its own automation playlist, that can be displayed by choosing it from the Track View Selector. See “” on page 383.

Editing Volume Automation
Drag a breakpoint up or down to change the volume (dB value). Drag a breakpoint to the left or right to adjust the timing of the volume change.

Editing Pan Automation
Drag a breakpoint down to pan right, and up to pan left. Drag a breakpoint to the left or right to adjust the timing of the panning moves.

Editing Mute Automation
Drag the breakpoint down to mute a section. Drag a breakpoint up to unmute the section. Drag a breakpoint to the left or right to adjust the timing of the mute.

Editing Stepped Control Automation
Automation for certain controls, such as MIDI controllers values or plug-in settings, appears as a stepped pattern on the breakpoint line. Drag a breakpoint up or down to a different step to change to a new control value. Drag a breakpoint to the left or right to adjust the timing of the stepped control change.
Editing Automation Breakpoints

To edit automation breakpoints, display the automation parameter you want to edit by selecting it from the Track View Selector, then do one of the following:

To create a new breakpoint:
- Click with the Grabber (or the Pencil) on the line graph.

To edit a breakpoint:
- Click an existing point on the line graph with the Grabber and drag it to a new position.

To edit several breakpoints at once:
- Use the Selector to select a range in the automation playlist that contains the breakpoints, and do one of the following:
  - To move the breakpoints earlier or later in the track, press the Plus key (+) to nudge them later (to the right) or the Minus key (−) to move them earlier (to the left). The breakpoints move by the current Nudge value.
  - To adjust the breakpoint values, click with the Trimmer in the selection and drag the breakpoints up or down.

*When you use the Trimmer to edit a selection containing breakpoints, new anchor breakpoints are created before and after the selected area. To suppress creation of anchor breakpoints, press Option (Macintosh) or Alt (Windows) while using the Trimmer.*

To edit all breakpoint values in a region:
- Click in the region with the Trimmer and drag the breakpoints up or down.

Editing Automation on Stereo and Multichannel Tracks

Stereo and multichannel tracks display a single automation playlist per track. Only one playlist for volume and mute is available for the stereo or multichannel track.

Volume automation display of a stereo track

Volume automation display of a 5.1 track

For multi-mono plug-ins, individual playlists per channel can be displayed and edited when the plug-in is unlinked, and the track is in Expanded Track Display.

Expanded Track View

By default, a single playlist is displayed on stereo and multichannel tracks. The playlist occupies the entire height of the track (similar to mono automation playlists).

Optionally, you can display an expanded view of the track whereby the same automation playlist is displayed across each channel.

Plug-In Automation Playlists on Stereo and Multichannel Tracks

Multichannel plug-ins provide a single set of automatable controls. Multi-mono plug-ins provide similar control when linked, or discrete controls when unlinked.
To view and edit the individual playlists of a multi-mono plug-in:

1. Unlink the plug-in.

2. Select the required playlist from the Track View Selector.

**Examples**

- If you create new automation breakpoints on a grouped track (with the Grabber or Pencil), other members of the group have breakpoints placed relative to that track.

- If you move volume or send automation on a grouped track (with the Trimmer), other members of the group have their volume or send breakpoints trimmed relative to that track. This lets you trim entire sections of a mix.

**Editing Automation on Grouped Tracks**

When you edit automation on an audio track that is a member of an active Edit Group, the same type of automation (with the exception of audio and MIDI Pan controls) is also edited on all tracks that are part of that group. This occurs even if that parameter is not currently displayed on the other grouped tracks.

However, when you edit automation on a MIDI track that is a member of an active Edit Group, grouping is ignored; the same type (with the exception of audio and MIDI Pan controls) are not edited on all tracks that are part of that group.

To edit all members of MIDI group, see the steps below.
To edit all members of a group:

- For audio tracks, do not press Control (Macintosh) or the Start key (Windows) while you perform the edit.
- For MIDI tracks, press Control (Macintosh) or the Start key (Windows) while you perform the edit.

⚠️ When editing automation, audio and MIDI Pan controls work opposite from the way all other controls work.

For audio tracks, when you edit or trim Pan breakpoints, Edit Groups are not obeyed. For grouped behavior, press Control (Macintosh) or the Start key (Windows) while trimming.

For MIDI tracks, when you edit or trim Pan breakpoints, Edit Groups are obeyed. For individual behavior, press Control (Macintosh) or the Start key (Windows) while trimming.

Cutting, Copying, and Pasting Automation

Cutting automation data is different from deleting it, and yields different results. Copying automation leaves the original automation data intact.

You delete automation data by selecting a range of breakpoints and pressing Delete (Macintosh) or Backspace (Windows). See “Deleting Automation” on page 388 for details.

You cut automation data by selecting a range of breakpoints from an automation playlist and selecting the Cut command.

When you cut automation data and when you paste it into a new location, anchor breakpoints are added to the beginning and end points of the data. This is done to preserve the true slope (of continuous controls, such as Volume faders or pans) or state (of switched or stepped controls, such as Mutes) of the automation data both inside and outside the selection.

The following illustrations show the difference between cutting and deleting automation data. In Figure 23, a track is set to display volume automation, and a range of automation data is selected.

![Figure 23. Selecting automation data](image1)

If the Cut command is chosen, anchor breakpoints are created at each end of the selection, and the automation slope on either side of the cut data is preserved, as shown in Figure 24.

![Figure 24. After cutting the automation data](image2)

If the data is deleted by pressing Delete (Macintosh) or Backspace (Windows), the automation data is removed, and automation values span the gap between pre-existing breakpoints, as in Figure 25.

![Figure 25. After deleting the automation data](image3)
In addition, if cut or copied data is pasted elsewhere in a track, breakpoints are created at the end points of the pasted data to preserve its value and slope, as shown in Figure 26.

![Figure 26. After pasting the automation data in another location](image)

**Editing and Track Views**

Audio and MIDI tracks each have a Track View that acts as the main format for purposes of editing. When the main format is displayed, any edits performed on the track apply to all data in the track.

The main view formats are:
- Audio tracks: Waveform and Blocks
- MIDI tracks: Regions, Blocks, and Notes

For example, when an audio track is set to Waveform or Blocks, cutting, copying and pasting affects the audio data and all types of automation data on that track. If the track is set to show Pan automation, only the Pan data is affected.

![Expanded Track Display, Waveform View](image)

When a selection includes multiple tracks, if any of those tracks is in its main view format, all data on all selected tracks is affected.

To edit all automation types on an Auxiliary Input or Master Fader track, do one of the following:
- Make an edit selection that includes at least one audio or MIDI track that is displayed in its main format.
- Press Control while cutting or copying the automation data.

💡 *For additional flexibility, you can use playlists or the Duplicate Track command to work non-destructively on a copy of the edit data.*

**Tips for Cutting, Copying and Pasting**

- On audio tracks, when you are in Waveform View and cut or copy a section of the waveform, any automation data associated with the waveform is also cut or copied.
- On audio tracks, when you are in Waveform View and cut audio data from a track also containing automation data, breakpoints are automatically created at the boundaries of the remaining automation data.
- On audio tracks, pasting waveform data also pastes any associated automation data.
- On Auxiliary Input or Master Fader tracks, only the displayed automation data is cut or copied. To cut or copy all automation data on these types of tracks, press Control while cutting or copying.
- In tracks where an automation playlist contains no data (when there is only a single breakpoint at the very beginning of the track), if you cut data, no new breakpoints are created.
- In cases where regions overlap (such as when moving regions in Slip mode) and an overlapping region is removed, any overlapped automation breakpoints are lost.
If cut or copied data contains a type of automation not currently on the target track, Pro Tools prompts you before allowing you to paste the data.

Cut or copied automation data for plug-ins or sends that do not exist on the target track is ignored when pasted.

**Special Paste Function for Automation Data**

Normally, when you copy and paste automation data, it is pasted in an automation playlist of the exact same type (for example, Left Pan data is pasted into the Left Pan playlist).

However, there may be times when you want to paste from one data type to another (for example, pasting Send 1 level data into the Send 2 level playlist, or track mute data into the send mute playlist).

**To paste data into a different automation playlist:**

- Press Control (Macintosh) or the Start key (Windows) when choosing Edit > Paste.

  For this special paste mode to function, the following must be true:

  - Every track selected for pasting must be currently displayed as automation data.
  - There must be only one automation playlist on the Clipboard for each target track. (The Special Paste function cannot copy multiple automation playlists for each track.)

**You cannot interchange automation data between audio and MIDI tracks, or between continuous controls (such as faders or pans) and switched or stepped controls (such as mute or MIDI controllers).**

---

**Writing Automation to the Start, End or All of a Selection**

*(TDM Systems Only)*

Pro Tools lets you write current automation values from any insertion point forward (or backward) to the end (or beginning) of a selection or track, or to an entire selection or track, while performing an automation pass.

The standard Write to Start/All/End commands do not operate when the Pro Tools transport is stopped. It only affects those automation parameters that are currently write-enabled and currently writing automation data.

Optionally, Write to Start, End, and All can be configured to always be applied automatically. See “Write to Start, End, and All On Stop” on page 399.
Requirements for Write to Start, End, and All

For an automation parameter to write automation data, the associated track must be in one of the following Automation modes and meet the following conditions:

**Latch mode** The automation parameter must be changed (touched) during the automation pass.

**Touch mode** The automation parameter must be changed (touched).

**Write mode** All automation parameters on that track must be in Auto Write mode.

This command can be undone by choosing Edit > Undo.

**To write current automation values to the start, end, or all of a track or selection:**

1. In the Automation Enable window, make sure that the automation type is write-enabled.
2. Click in a track at an insertion point.
3. Click Play to begin playback.
4. When you reach a point in the track/selection that contains the automation data, click Write to Start, Write to All, or Write to End in the Automation Enable window.

The current values of all write-enabled automation at that point are written to the corresponding area of the track/selection.

Trim Mode

Using Trim mode, it is also possible to write trim delta values for track volume and send levels to the start (beginning), end or all of a track.

**To write current trim delta values to the start, end, or all of a track or selection:**

1. In the Automation Enable window, make sure that the automation type (track volume or send level) is write-enabled.
2. Click the Automation Mode Selector on the track. Select Trim from the pop-up menu to enable Trim mode. The track volume and send level faders turn yellow.
3. Click in a track at an insertion point.
   - or -
   Drag with the Selector to select a portion of the track.
4. Click Play to begin playback.
5. When you reach a point in the track/selection that contains the trim setting (delta value) you want to apply, click the Write to Start, Write to All, or Write to End button in the Automation Enable window.

The relative changes to the track volume and send levels at that point are written to the corresponding area of the track/selection.
Write to Start, End, and All On Stop

The Automation Enable window provides options for automatic Write to Start, End, and All On Stop.

To configure Write on Stop:
1. Open the Automation Enable window.
2. Click to enable one of the Write On Stop modes (Start, End, or All).

When any of these options are enabled, automation writing will be performed automatically after a valid automation pass has been performed. See “Requirements for Write to Start, End, and All” on page 398.

Trimming Automation
(TDM Systems Only)

If you have already written automation, you can modify automation data for track volume and send levels in real time by using Trim mode. When a track is trim-enabled, you are not recording absolute fader positions, but relative changes in the existing automation. See “Trim Mode” on page 378 for more information.

To enable Trim mode:
- Click the Automation Mode Selector and choose Trim from the pop-up menu.

Enabling Trim mode

When Trim mode is enabled for a track, its volume and send level faders turn yellow, and its Automation Mode button is outlined in yellow. This outline flashes to indicate that the track is trim-enabled, and appears solid whenever trimming is occurring on the track’s volume or send levels.

To trim track volume or send levels in real time:
1. In the Automation Enable window, make sure the automation type (volume or send level) is write-enabled.
2. Click the Automation Mode Selector on the tracks you want to automate and select Trim from the pop-up menu.
3. Click the Automation Mode Selector a second time and choose an Automation mode:
   - Use Auto Touch or Auto Latch to have the faders follow existing automation, so you can “chase” them during the automation pass.
   - Use Auto Write if you want to disengage the faders from existing automation.
4. Click Play to begin trimming automation, and move the volume or send level faders.
5. When you have finished, click Stop.
Creating Snapshot Automation

(TDM Systems Only)

Pro Tools lets you write automation data values for multiple parameters in a single step. You can write snapshot automation in two ways:

**To a selection** Automation data is written to the Timeline selection (as well as the Edit selection if linked). Anchor breakpoints are placed just before and after the selection so that data outside the selection is not affected.

**To a cursor location** Automation data is written at the insertion point. After the insertion point, the automation ramps to the next breakpoint value, or if no breakpoints exist, remains at the newly written value for the remainder of the session.

For more information on copying automation data within a session, see “Writing Automation to the Start, End or All of a Selection” on page 397.

**To write snapshot automation:**

1. In the Edit window, click the Track View button to show the automation you want to edit.

2. In the Automation Enable window, make sure that the automation parameters you want to edit are write-enabled. Disable any parameters you want to preserve.
   - Select an area in the track’s playlist (or within multiple tracks) where you want to apply the automation.
   - or –
   - Place the cursor at an Edit insertion point.

3. Adjust the controls for the parameters you want to automate.

4. Choose Edit > Write Automation and do one of the following:
   - To write the current value to only the currently displayed automation parameter, choose To Current Parameter.
   - To write the current settings for all automation parameters enabled in the Automation Enable window, choose To All Enabled Parameters.

**Adding Snapshot Automation to Empty Automation Playlists**

When you use the Write Automation command on an automation playlist with no previously written automation data, the selected value is written to the entire playlist and not just the selected area.

This is because a playlist with no automation data contains only a single automation breakpoint that corresponds to the current position of the control. The position of the breakpoint is updated whenever the parameter value is changed.

If you do not want the Write Automation command to write the selected automation value to the entire playlist, you can:

   - Anchor the automation data by placing the cursor at the end of the session (or any other endpoint) and choosing Write Automation To Current Parameter.
   - or –
   - Click with the Grabber on each side of the selection.

This lets the Write Automation command write only to the selected area.
Writing Snapshot Automation over Existing Automation Data

When you move the playback cursor, the automated controls in Pro Tools update on the screen to reflect the automation data that is already on the track. To keep the settings you have made for a snapshot, you can suspend the desired automation parameters to prevent the controls from updating.

To write snapshot automation over existing data:
1. In the Automation Enable window, make sure that the automation parameters you want to edit are write-enabled. Deselect any parameters you want to preserve.
2. Adjust the controls for the parameters you want to automate.
3. Suspend the automation parameters you want to automate by doing any of the following:
   - To suspend an automation parameter on a single track, Command-click (Macintosh) or Control-click (Windows) the name of the automation type in the track’s Track View Selector.
   - To suspend an automation parameter on all tracks, Command-Shift-click (Macintosh) or Control-Alt-click (Windows) the name of the automation type in the Track View Selector for any track.
   - To suspend all automation on a track, Command-Shift-click (Macintosh) or Control-Shift-click (Windows) the name of the automation type in the track’s Track View Selector.
4. With the Selector, select the track range you want to apply the automation.
5. Enable the automation parameters previously suspended.
6. Choose Edit > Write Automation and select one of the following from the submenu:
   - To write the current value to only the automation parameter currently displayed in the Edit window, choose To Current Parameter.
   - To write the current settings for all automation parameters enabled in the Automation Enable window, choose To All Enabled Parameters.

Capturing Automation and Applying it Elsewhere

The Write Automation command can also be used to capture automation states at specific locations in a session and apply them to other locations. This differs from simply copying and pasting automation data in that you can set any selection length for the application of the captured automation data.

To capture and apply automation:
1. In the Automation Enable window, make sure that the automation parameters you want to edit are write-enabled. Disable any parameters you want to preserve.
2. Click with the Selector in the track with the automation you want to capture. All automated controls update to reflect the automation at that location. (If you make a selection, the controls update to reflect the automation at the beginning of the selection.)
3. Suspend the automation parameters you want to automate:
   - For an automation parameter on a single track, Command-click (Macintosh) or Control-click (Windows) the name of the automation type in that track’s Track View Selector.
• For an automation parameter on all tracks, Command-Shift-click (Macintosh) or Control-Alt-click (Windows) the name of the automation type in the Track View Selector for any track.

• To suspend all automation on a track, Command-Shift-click (Macintosh) or Control-Shift-click (Windows) the name of the automation type in that track’s Track View Selector.

4 With the Selector tool, select the location where you want to apply the automation.

5 Enable the automation parameters previously suspended.

6 Choose Edit > Write Automation and select one of the following from the submenu:

• To write the current value to only the automation parameter currently displayed in the Edit window, choose To Current Parameter.

• To write the current settings for all automation parameters enabled in the Automation Enable window, choose To All Enabled Parameters.

To create a snapshot of relative changes in automation data:

1 In the Automation Enable window, make sure that the automation parameters you want to edit are write-enabled. Disable any parameters you want to preserve.

2 Select the area of the track you want to edit. All automated controls update to reflect the automation at the beginning of the selection.

3 Move the controls for the parameter up or down by the amount you want to change the data.

4 Choose Edit > Trim Automation and do one of the following:

• To write the current delta value to only the currently displayed automation parameter, choose To Current Parameter.

• To write the current delta value for all automation parameters enabled in the Automation Enable window, choose To All Enabled Parameters.

Snapshot Automation and Trimming of Automation Data

Pro Tools lets you use trim values as snapshots and apply the relative changes (delta values) to the selected automation by using the Trim Automation command. This works in much the same way as the Write Automation command, except that it writes delta values instead of absolute values to automation data.

You can use trim values in writing snapshot automation to any automatable parameter.
Chapter 29: Mixdown

Pro Tools lets you record and bounce tracks to disk. The Bounce to Disk command lets you write a final mix to disk, create a new loop, print effects, or bounce any submix. You can also submix, route, and record busses and inputs to new tracks.

**Bounce to Disk** This command writes the current session (if no selection), Edit, or Timeline selection as new audio files to disk. Any available output or bus path can be selected as the bounce source. Use Bounce to Disk to write or master any output or bus path directly to disk. Sample rate, bit depth, and other conversion processes can be applied during or after the bounce. The Bounce to Disk command lets you bounce all available voices to disk without holding any in reserve. Though you can hear the bounce being created in real time, you cannot adjust mixer or other controls during a Bounce to Disk.

**Recording to Tracks** This is the process of submixing and recording to new audio tracks, as you would any input signals. This method requires available tracks, voices, and bus paths to accommodate the submix and the new tracks. While recording to tracks, you can adjust mixer or other controls.

**Selecting Audio for Loops, Submixes, and Effects**

Both Bounce to Disk and recording to tracks operate on the current Timeline or Edit selection, if any. This makes it easy to turn multitrack selections into mono, stereo, or multichannel loops. Submixes, stems, and other specialized types of mixes can also be printed to disk using either method, or recorded out to a DAT, MDM, or other recording, transfer, or archiving medium.

Printing effects to disk is the technique of permanently adding real-time effects, such as EQ or reverb, to an audio track by bussing and recording it to new tracks with the effects added. The original audio is preserved, so you can return to the source track at any time. This can be useful when you have a limited number of tracks or effects devices.

*AudioSuite plug-ins provide another option for printing a plug-in effect to disk. See the DigiRack Plug-Ins Guide for details.*

Use Bounce to Disk if you need to convert the bounce files, or if you do not want or need to interact with mixer controls during the bounce.

Record to new tracks if you want to adjust parameters while the files are being written.
Dither and Bounce to Disk

Dithering can significantly improve audio quality. Generally, dithering is necessary when reducing the bit depth for digital audio.

If you use Bounce to Disk, it is important to understand that the Bounce to Disk process does not apply dither.

To dither a bounce file, you should insert one of the included Digidesign Dither plug-ins (such as POW-r Dither), or another dithering plug-in, on a Master Fader assigned to the bounce source path. Master Faders are often preferable to Auxiliary Inputs because Master Fader inserts are post-fader (better for dithering).

If you do not use a dithering plug-in on your bounce source path, and you choose to convert to a lower resolution during or after a Bounce to Disk, the resultant file will be converted by truncation.

When to Use a Dithering Plug-In

You should use a dithering plug-in when mastering to a 16-bit file with the Bounce To Disk command, or when mastering to an external device that records at 16-bit.

This is even necessary when using 16-bit sessions. Even though 16-bit sessions use 16-bit files, they are still being processed internally at a higher bit rate:

- 24-bit for Pro Tool TDM systems
- 32-bit floating for Pro Tools LE systems

For this reason, whether you are using a 16-bit session or a 24-bit session, it is recommended that you use a Dither plug-in when mastering to 16-bits.

When mastering to 24-bits, it is not necessary to use a Dither plug-in.

Using Dither on an Output Mix

Pro Tools includes real-time dithering plug-ins that improve 16-, 18-, or 20-bit performance and reduce quantization noise when mixing or fading low-level signals.

The dithering plug-ins have no user-selectable parameters other than Bit Resolution and Noise Shaping controls.

For more information about dither, see “Dither” on page 359.

To use a dithering plug-in on a submix:

1. Choose File > New Track and choose Master Fader (stereo) from the pop-up menu.
2. Set the output of the Master Fader to the output or bus path you want to bounce.
3. Assign the outputs of all audio tracks in the session to the same path you chose in step 2. The Master Fader now controls the output levels of all tracks routed to it.
4. On the Master Fader, click an Insert button and choose one of the Digidesign dithering plug-ins (such as POW-r Dither).
5. In the dithering plug-in window, choose an output Bit Resolution and Noise Shaping setting.

When you Bounce to Disk you can convert the file to the appropriate resolution. Before being converted by the Bounce to Disk command, the signal will have been dithered to the resolution and noise shaping settings in a dithering plug-in.

For more information about the Digidesign dithering plug-ins, refer to the DigiRack Plug-Ins Guide.
Recording to Tracks

You can create a submix in your Pro Tools session and record it to available tracks in the same session. This technique lets you add live input to the mix, as well as adjust volume, pan, mute, and other controls during the recording process.

Voice Requirements

Recording a submix to new tracks requires an available voice for each track that you want to record. Make sure you have enough voices available to play back all tracks that you want to record and enough voices available to record the destination tracks.

In contrast, the Bounce to Disk command lets you bounce all available voices to disk without holding any in reserve, but you cannot manually change any controls during the bounce. See “Bounce to Disk” on page 406 for more information.

For information about voice management, see “Assigning Voices and Track Priority” on page 85.

To record a submix:

1. Apply any plug-ins or external processors you want to add to your audio tracks or Auxiliary Inputs before you record.

2. Set the main channel output of the tracks you want to include in the submix to a bus path. If you are recording in stereo, set the panning of each track.

3. Choose File > New Track and create one or more mono, stereo, or multichannel audio tracks.

4. If you are recording in stereo, set the panning of the new tracks to full left and right.

5. Set the input of each destination track to match the bus path to which you are recording.

6. Set the output of your new tracks to your main output path.

7. Link the Edit and Timeline (Operation > Link Edit/Timeline).

8. Select audio to record. The start, end, and length of the recording can be based on cursor location or Edit and Timeline selections.

- Selection-based recording automatically punches in and out of recording at the selection start and end. Be sure to include time at the end of a selection for reverb tails, delays, and other effects.

- If you don’t make a selection, recording will begin from the location of the playback cursor. Recording will continue until you press Stop.

9. Record enable the new tracks and click Record in the Transport window.

10. Click Play in the Transport window to begin recording the submix.

11. If recording a selection of audio, recording will stop automatically. If performing an open-ended recording, click Stop, or punch out of recording.
**Bounce to Disk**

The Bounce to Disk command lets you mix down with all available voices on your system. Since it records to separate audio files, you don’t have to reserve any tracks for a bounce.

You can use the Bounce to Disk command to create and automatically import loops, sub-mixes, or any audio into your session. You can use it to create a final mono, stereo, or multi-channel master, in any of several audio file formats. Bounce to Disk provides conversion options for sample rate, bit resolution, and format.

When you bounced a track to disk, the bounced mix includes the following:

**Audible Tracks** All audible tracks are included in the bounce. Any muted tracks do not appear in the bounce. If you solo a track or region, only the soloed elements appear in the bounced mix.

**Automation** All read-enabled automation is played back and incorporated in the bounced mix.

**Inserts and Sends** All active inserts, including real-time plug-ins and hardware inserts, are applied to the bounced mix.

**Selection or Track Length** If you make a selection in a track, the bounced mix will be the length of the selection. If there is no selection in any track, the bounce will be the length of the longest audible track in the session.

**Time Stamp Information** Bounced material is automatically time stamped so that you can drag it into a track and place it at the same location as the original material. For more information about time stamping, see “Time Stamping” on page 494.

Pro Tools bounces are done in real time, so you hear audio playback of your mix during the bounce process (though you can’t adjust it).

**Bounced Files are “Delay-Compensated”**

DAE compensates for any bus delays due to a bounce. Meaning, if a bounce file is imported back into a session, and placed directly in time against the source mix, it is phase accurate with the original source mix.

**To Bounce to Disk:**

1. Choose File > Bounce to Disk.
2. Configure bounce options as needed and perform the bounce (see “Bounce Options” on page 407).

**Bouncing with Mute Frees Assigned Voice (TDM Systems Only)**

When bouncing sessions that include muted tracks, enabling “Mute Frees Assigned Voice” can, in some instances, increase the number of tracks that can be successfully bounced.
Bounce Options

When you use the Bounce to Disk command, you can configure several file options.

Avid Compatibility Mode

When the Avid Compatibility mode is enabled, its additional data is added to the bounced files automatically. See “Avid File Compatibility” on page 111.

Bounce Source

Select any mono, stereo, or multichannel output or bus path as the source for the bounce. All currently active paths as defined in the I/O Setup dialog are available as the Bounce Source.

File Type

Selects the (creator) type for the bounced files.

Sound Designer II

This was the native format for older Macintosh-based Pro Tools systems. Select this to use the bounced audio with any Digidesign application for Macintosh.

Bounce to Disk dialog, with conversion and options enabled

Default Settings

Available options and their default settings are listed in the following table.

<table>
<thead>
<tr>
<th>Bounce Option</th>
<th>Default</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bounce Source</td>
<td>current main output path</td>
</tr>
<tr>
<td>File Type</td>
<td>session default file type</td>
</tr>
<tr>
<td>Format</td>
<td>Auto Stereo Interleaved</td>
</tr>
<tr>
<td>Resolution</td>
<td>session default resolution</td>
</tr>
<tr>
<td>Sample Rate</td>
<td>session default sample rate</td>
</tr>
<tr>
<td>Conversion Quality</td>
<td>Good</td>
</tr>
<tr>
<td>Use Squeezer</td>
<td>deselected</td>
</tr>
<tr>
<td>Convert During Bounce</td>
<td>deselected</td>
</tr>
<tr>
<td>Convert After Bounce</td>
<td>selected</td>
</tr>
<tr>
<td>Import After Bounce</td>
<td>deselected</td>
</tr>
</tbody>
</table>

Select a bounce source

Selecting a file type

Selecting a file type

Selecting a file type
AIFF (Audio Interchange File Format)

Files in this format do not have to be converted to be used in Pro Tools, but you must still import them into a session with the Import Audio command or the Convert and Import Audio command. AIFF waveform overview data cannot be stored in the file, so the overview is recalculated every time the session is opened. The AIFF format is useful if you plan to use bounced audio in applications that do not support the Sound Designer II format.

WAV (Windows Audio File Format)

This is the native format for Windows-based Pro Tools systems. The WAV format is supported by many Windows applications and some Macintosh applications. To use a WAV file on Macintosh-based Pro Tools systems, you must use the Convert and Import Audio command.

SND Resource (Macintosh Only)

This file type is supported by some Macintosh software applications and also by Macintosh System Software. Pro Tools does not directly support this type of file in its sessions. To use a SND file within Pro Tools, use the Convert and Import Audio command. The SND format is useful if you plan to use your audio with other Macintosh applications that do not support Sound Designer II or AIFF formats. To save a bounced file as a System alert sound, save it in this format and then drag it onto the Macintosh System File.

QuickTime (Macintosh Only)

This is Apple’s audio file format for QuickTime-based multimedia. Pro Tools does not directly support this type of file in its sessions. To use a QuickTime audio file within Pro Tools, use the Convert and Import Audio command or Import Audio from Other Movie command. The QuickTime format is popular for attaching to emails, to simplify long-distance project review and approval. Many popular multimedia applications also support QuickTime.

Windows Media (Windows Only)

Windows Media formatted files can contain audio, video, or script data stored in Windows Media Format. A Windows Media Format file may have an .asf, .wma, or .wmv file name extension.

RealAudio G2 (Macintosh Only)

RealAudio G2 is the latest version of the format created by Real Networks for streaming audio over the Internet. The RealAudio encoder file is stored in a folder named Codecs inside the DAE folder.
When you select this format, the Resolution and Sample Rate pop-up menus in the Pro Tools Output Options dialog are unavailable, because resolution and sample rate are set by the encoder.

The RealAudio G2 format lets multiple streams with different bit rates be encoded into a single file. During playback, the RealAudio G2 server and the RealPlayer G2 client continuously adjust the bit rate to make the best use of available bandwidth. The RealPlayer G2 is available on the Real Networks web site, www.real.com.

When you export or bounce to RealAudio G2 format, you can set the following options:

**Media Clip Information** Type the title, author, and copyright information for your RealAudio clip. This information is displayed on the RealPlayer G2 as the clip plays back.

**Copy Protection** These settings determine how the clip is handled by the RealPlayer client.

- To allow RealPlayer Plus users to save your clip using the RealPlayer Plus recording feature, select Allow Recording.
- To allow RealPlayer users to download your clip to their hard drive, select Allow Download.

If you don’t want to allow RealPlayer users to make copies of your clip, deselect both of these options.

**Audio Format** From the pop-up menu, select the setting that best matches the type of audio you are bouncing. A brief explanation of each format is displayed.

**Target Audience** Select the connection speed that most users downloading your clip are likely to have. This setting determines the bit rate at which the audio will be encoded. Depending on the file type you choose (see below), you can choose more than one connection speed.

**File Type** This option determines the compatibility of the output file with different RealAudio servers and clients.

If you select SureStream, you can select more than one connection speed under Target Audience. With this file type, multiple bit rate streams are encoded into a single output file. Files encoded with the SureStream option are larger than Single Rate files, and can only be played back from G2 servers.

Select the “Include RealPlayer 5.0 Compatible Stream” option to include a backward compatible stream that can be played on older version 5.0 RealPlayers. (This backward compatibility is only available for SureStream-encoded files.)

If you select Single Rate, you can only select one connection speed under Target Audience. With this file type, a single stream is encoded into the output file. Files encoded with the Single Rate option can be played back from either a standard web server or a G2 server.

**Auditioning RealAudio Clips**

If you are using Digidesign Sound Drivers and want to use a RealAudio player while running Pro Tools, make sure that Operations > Active in Background is not selected so the player can use the Digidesign hardware.
MPEG Layer 3 (MP3)

The MPEG Layer 3 compression format (MP3) is used for streaming and downloading audio over the Internet, and for playback on portable devices.

The MP3 encoder file is stored in a folder named Codecs inside the DAE folder. This version of the encoder uses the latest technology from the developer of the MP3 format, the Fraunhofer Institute. It features improved processing speed and quality, and supports both constant and variable bit rate encoding.

The MP3 encoder installed with Pro Tools is a fully functional 30-day demo version. To purchase the full version of the MP3 encoder, visit Digidesign’s website.

When you select this format, the Resolution pop-up menu in the Pro Tools Output Options dialog is unavailable. The resolution is set by the encoder.

When you export or bounce to MP3 format, you can set the following options:

**Encoder Settings**

**Encoding Quality** Determines the audio quality of the bounced file. The higher the quality, the longer it will take to process the audio. The three options, in ascending order of quality, are Fastest Encoding, Medium Encoding, and Highest Quality.

The Highest Quality setting can take up to five times longer to process audio than the Fastest Encoding setting, so you should use it only when the highest fidelity is essential and you have a considerable amount of time to devote to the encoding process. You should experiment with the other encoding quality settings, since they can provide acceptable quality with a significantly shorter encoding time.

**Encoding Method** Two encoding methods are available:

- **Constant Bit Rate (CBR)** encodes the file at a single bit rate that you choose from the CBR pop-up menu. Because the bit rate is fixed, the quality of the encoded audio will vary depending on the nature of the material being compressed. This option is best for streaming over the Internet, since it has predictable bandwidth requirements.

- **Variable Bit Rate (VBR)** encodes the file at a varying bit rate to maintain the level of encoding quality you choose from the VBR pop-up menu. The bit rate varies automatically depending on the nature of the material being compressed. This option is best for personal jukebox applications.
ID3 Tag Info Settings

ID3 Tag Type The ID3 tag stores data about the encoded audio file that is used by MP3 players to display information about the file. Pro Tools supports three versions of this tag, in order to provide backward compatibility with older MP3 players:

- ID3 v1.0: Appears at the end of a streaming MP3 file, therefore tag information is only displayed after software streaming is finished.
- ID3 v1.1: Same as version 1.0 but adds track number information to the tag.
- ID3 v2.3: Appears at the front of a streaming MP3 file, therefore tag information is displayed when streaming begins.

While ID3 v2.3 is becoming the standard MP3 format, not all MP3 players currently support ID3 v2.3. Contact the developer of your player software for compatibility information.

Title/Artist/Album/Comment Type the title, artist, and other information for the MP3 file. This information is displayed by many MP3 players.

Genre Choose a genre for the file. This information is displayed by many MP3 players, and can appear in searchable catalogs and databases.

Track Number If you select ID3 tag type v1.1 or v2.3, you can enter a CD track number for the file. This information is displayed by many MP3 players.

Year Enter a year for the file. This information is displayed by many MP3 players.

Advanced Settings

The options listed under Advanced Settings, under normal situations, do not need to be changed from their default values.

Pad To Match Bit Rate Exactly This option determines whether MP3 frames are padded to maintain bit rate very precisely. You should only select this option if you need a file with an exact bit rate, for specific applications (such as synchronous transmission over ISDN line).

Padding of MP3 frames can cause problems with some versions of Internet streaming software. If your files are destined for desktop or Internet delivery, do not select this option.

Allow Intensity Stereo Coding This option determines whether the encoder takes into account the frequency of a signal when encoding its phase characteristics, allowing for more compression at low bit rates. In most cases, you should leave this option selected. However, if you are working with highly phase-dependent material, such as Dolby Surround, you may want to deselect this option.

Write CRC Checksums This option adds error-detection data to the MP3 file. This data is not necessary for most computer and Internet applications, and also takes away from the space available for audio data. Select this option only if you are sure your delivery mode requires error correction.

Copyrighted This option sets a bit in the MP3 data stream to indicate that the audio is copyrighted. Not all MP3 players use this information. Selecting this option does not guarantee that the audio file will not be copied.

Original This option sets a bit in the MP3 data stream to indicate that the audio is the original media for the track, rather than a copy. This setting is not widely used.

Private This option sets a bit in the MP3 data stream that is interpreted differently by various applications. It is not normally used.
Mac File Settings

Mac File Type and Creator If you expect your file to be used on a Macintosh, you can enter the Macintosh file type and creator. This will allow users to double-click the file to open their MP3 player.

Default Button
To restore all settings in this dialog to their default values, click Defaults.

Auditioning MP3 Clips
If you are using Digidesign Sound Drivers and want to use an MP3 player to audition an MP3 file while running Pro Tools, make sure that Operations > Active in Background is not selected. This lets your MP3 player access the Digidesign hardware.

Format
This is the format for the bounced result. Choices are Mono (summed), Multiple mono, and Interleaved.

To set the bounce file format:
- Select a file format from the Format Selector.

Mono (Summed) Creates a single disk file that is a summed mono mix of the current sources being monitored.

When bouncing to mono (summed) files, the output may clip. Avoid clipping by monitoring the meters of your bounce source Auxiliary Input or Master Fader. When bouncing stereo tracks to mono (summed) files, clipping occurs if left and right signals exceed –3 dB below maximum, or full code (0 dBFS).

Multiple mono Creates multiple mono files with the same number of channels as the source path.
- If the source output or bus path is stereo, two mono files will be created, and appended with “.L” and “.R” suffixes on bounce.
- If a multichannel format is used (for example, six-channel, 5.1), individual mono files will be created for each member of the path. Files will be appended with path suffixes according to the path definition in the I/O Setup dialog.

Interleaved Creates a single, interleaved file that contains all of the bounced streams from the chosen output path. In an interleaved stereo bounce, tracks assigned to odd-numbered outputs are sent to the left channel, and tracks assigned to even-numbered outputs are sent to the right channel.

Pro Tools also lets you create multichannel interleaved files of any supported file type. This can simplify file management of mixes and projects for backup and archiving.

Pro Tools does not support interleaved files natively. This means that they must be split into multi-mono files on import (requiring additional disk space).
Resolution

This parameter lets you select between three different bit resolutions for the bounce conversion.

Bounce to Disk does not apply dither when converting during or after a bounce to a lower resolution (including when bouncing to 16-bit). When you need to create a lower resolution bounce file, use a Digidesign Dither plug-in, or similar, on a Master Fader assigned to the bounce source path. This dithers the bounce file, before the Bounce to Disk conversion truncates bits into the final file resolution.

Resolution choices include the following:

- **8-bit** This resolution is often used in multimedia applications. If the material you are working with is relatively simple, you can use the Pro Tools “Squeezer” feature for optimal results. See “Sample Rate Conversion Quality” on page 414 for details.

- **16-bit** This is the Compact Disc standard bit resolution.

- **24-bit** If you plan to use the bounced file with a Pro Tools TDM system, you can take advantage of the greater resolution and headroom afforded by this higher bit rate. You can also archive a master stereo mixdown or bounce audio material at this resolution for future use on a 24-bit system.

To set the bounce file resolution:

- Select a bit depth from the Resolution Selector.

Sample Rate

This option lets you save to any of several sample rates. Choices are dependent on your Pro Tools system and Digidesign audio interfaces.

Sample Rate Conversion Quality

If you choose a sample rate that differs from the original sample rate of the session, the conversion options become available. You can configure the conversion quality, and schedule conversion to occur during, or after, the bounce. See “Sample Rate Conversion Quality” on page 414 for more information.

The following are the more common sample rates, and their application. Higher sampling rates will provide better audio fidelity for recording and playback, and also for processing with dynamics, dither (with noise shaping), and analog emulation plug-ins.

- **192000** This is a supported sample rate for some audio DVDs, and provides the highest quality audio fidelity with compatible audio interfaces (such as the 192 I/O).

- **176400** You may want to work at a sample rate of 176.4 kHz if the final delivery will be at 44.1 kHz (such as compact disc). This will provide a slightly faster sample rate conversion to 44.1 kHz than from 192 kHz.

- **96000** This is a supported sample rate for DVD audio and provides high-quality audio fidelity with compatible audio interfaces (such as the 96 I/O).

- **88200** You may want to work at a sample rate of 88.2 kHz if the final delivery will be at 44.1 kHz (such as compact disc). This will provide a slightly faster sample rate conversion to 44.1 kHz than from 96 kHz.
48000 This is the standard sample rate for DAT and ADAT decks, and DVD video.

44100 This is the standard sample rate for compact discs (CD), and is supported by DAT and ADAT decks.

Custom For a custom sample rate, click in the sample rate window and manually enter in a value.

Pull-up and Pull-down Rates All available sample rates support pull-up and pull-down rates, or other specialized rates.

Sample Rate Conversion Quality
The Conversion Quality option sets the quality of sample rate conversion used to create the converted file. The higher the quality of sample rate conversion, the longer it takes to convert the file after the bounce has taken place. There are five possible settings, ranging from Low to Tweak Head. For most applications, the Better setting yields satisfactory results.

Processing Resources and Conversion Quality
Because the Best and Tweak Head settings take longer than the others, you may want to use them only in cases where the highest fidelity is essential and you are not facing strict time limitations.

Use Squeezer
The Use Squeezer option uses a proprietary DSP algorithm specifically designed for performing 8-bit conversion of simple source files such as voice-overs. It optimizes the dynamics of the audio by preprocessing it using compression, limiting, and gating before conversion to 8-bit resolution. This results in greater apparent loudness in the signal, and improved intelligibility. If you are converting a more complex 16-bit audio file to 8-bit resolution, test this option before converting all of your material.

Convert During or After Bounce
The Bounce dialog can perform any conversion options, including sample rate and bit depth conversion, during a bounce or post-bounce.

Convert After Bounce This option automatically performs file type, sample rate and bit resolution conversion on the newly bounced files. The Convert After Bounce option, though more time and storage consuming, offers the highest level of plug-in automation accuracy possible.

Convert During Bounce This option may take less time than Convert After Bounce, but does so at the expense of plug-in automation playback accuracy.

Import Into Session After Bounce
The Import Into Session After Bounce option automatically imports the newly bounced files into the Audio Regions List so you can place them in tracks. If your newly bounced files are split stereo files, they are listed together in the Audio Regions List.

The Import Into Session After Bounce option is only available if the target bit depth for the bounce is the same or less as the bit depth of the current session, and it is supported by the Digidesign audio interface.

Help
The Help button opens a display-only dialog box that describes the Bounce to Disk features.
Recording a Submix (with Bounce To Disk)

You can create a submix with the Bounce to Disk command by muting tracks or bypassing inserts that are not part of the submix group, and selecting the part of the session you want to bounce.

You can also create a submix by recording to new tracks. For details, see “Recording to Tracks” on page 405.

To bounce a submix to disk and bring it into the session:

1. Configure your submix using sends, Auxiliary Inputs, and Master Faders. (See “Submixing for Signal Routing and Effects Processing” on page 353.)

2. Do one of the following:
   - To bounce the entire session, click Return to Zero in the Transport window to go to the beginning of the session.
   - To bounce a portion of the session, enable Link Edit and Timeline, and make a selection in the Edit window.

3. Choose File > Bounce to Disk.

4. Configure bounce options and parameters.

5. Make sure the bit resolution for the bounced file matches the bit resolution of the session.

6. Make sure the sample rate for the bounced file is supported by the session and the audio interface.

7. Select the Import into Session After Bounce option.

8. Click Bounce.

9. Select a destination for the new audio file, enter a name, and click Save.

Pro Tools bounces are done in real time, so you hear audio playback of your mix during the bounce process. You cannot adjust controls during a Bounce to Disk.

To bring bounced files back into tracks:

1. Do one of the following:
   - If the newly bounced audio was automatically imported into the session, drag the new files from the Audio Regions List to existing tracks in your session.
   - If the bounced files are not available in the Audio Regions List, import them into the session by choosing File > Convert and Import Audio.
   - If you are placing multiple files of a multi-channel track or file, keep channels in phase with each other by Shift-selecting them in the Regions List, and dragging them simultaneously into existing tracks of the right format.

2. When working with stereo tracks, set the pan controls hard left and hard right.

3. Mute or turn off the voices of original source tracks so that you don’t double monitor your audio material.

4. Click Play in the Transport window to hear the results of the bounce.
Final Mixdown (with Bounce To Disk)

In final mixdown, you create a mix that includes all your edits, automation, and effects processing.

To bounce a final mix to disk:
1. Adjust track output levels, finalize any mix automation, and choose an Automation mode for each track in the session.
2. Adjust any real-time plug-in and effects settings and automation for each track in the session.
3. Make sure that all of the tracks you want to include in the bounce are audible (not muted or inactive).
4. Assign the output of each of the tracks you want to include in your bounce to the same output path.
5. Do one of the following:
   - To bounce the entire session, click Return to Zero in the Transport window to go to the beginning of the session.
   - or –
   • To bounce a portion of the session, enable Link Edit and Timeline and make a selection in the Edit window.
6. Choose File > Bounce to Disk.
7. Choose the source path you want to bounce.
8. Configure other Bounce to Disk parameters as appropriate. See “Bounce Options” on page 407.
9. Click Bounce.
10. Select a destination for the new audio file, enter a name, and click Save.

Mastering

In the final mastering process, you might record directly to disk, to a DVD or CD recorder, to a stereo mastering recorder, or directly to a multi-track recorder for surround mixes.

Once you have created a master of your session, you can transfer it to a portable medium for duplication. You can transfer the master file to CD, DAT or 8 mm DDP tape to be used as a master for pressing compact discs.

Mastering to a Digital Recorder

Although it is usually best to master sessions directly to hard disk, Pro Tools also lets you master digitally, direct to any AES/EBU-equipped or S/PDIF-equipped digital recorder such as a DAT deck.

24-Bit Input and Output with Pro Tools TDM Systems

Pro Tools TDM systems are full 24-bit audio recording and mixing environments, supporting record, playback, mixing, and processing of 24-bit audio files. You can record to and from other 24-bit recording systems without any bit-depth conversion.

Mastering and Audio Compression

Although audio compression is often an indispensable tool in analog recording, it can present problems in the digital domain. If you compress an input signal at a very high ratio, you create a signal that contains a much higher overall power level compared to its transients. By recording a number of such signals at the highest possible level on multiple tracks, you create a scenario that is more likely to clip the mixed output signal.
High-power compressed signals, when mixed together, create an extremely high-level output. This output may rise above the full-code level, resulting in clipping.

To avoid this problem, watch the overall level of your program material—use a meter on a Master Fader, or use an external mastering deck’s meters to help avoid clipping. If you are mastering to hard disk, avoid mixing full-code audio signals together at unity or “0” level, as this invariably causes clipping.

**Mastering and Error-Correcting Media**

Random access media (such as hard disks, optical cartridges, Bernoulli cartridges or WORM drives) can produce a true digital copy of your data, because every bit value is maintained. Sequential media (such as DAT tapes) use error correction schemes to fix the occasional bad data that is received in a digital transfer. These corrections are deviations from the actual data, and with successive reproductions, represent a subtle form of generation loss.

You can avoid this loss by creating and maintaining masters on random-access digital media (such as a hard drive) and transferring them to sequential digital media (such as DAT tapes) only as needed.

**To configure Pro Tools for direct digital stereo mastering:**

1. Connect your digital recorder to your system’s digital outputs. If your system has multiple digital outputs, use channel 1 and 2 of the audio interface.

2. In Pro Tools set the appropriate digital format and output from the Hardware Setup dialog or I/O Setup dialog.

3. On your digital recorder, choose the appropriate digital format for the connections.

4. In Pro Tools, set all audio tracks you want to your master outputs 1–2 path.

5. Click Return to Zero in the Transport window to go to the beginning of the session.

6. Press Record on your digital recorder.

7. Start playback of your session.

8. When your session has finished playing, stop the digital recorder.
Part VII: Surround
Chapter 30: Surround Concepts

Pro Tools HD-series and MIX-series systems support multichannel mixing for surround sound.

How to Use These Chapters

This part of the guide describes multichannel mixing for surround sound with Pro Tools. These sections supplement the basic Pro Tools information provided elsewhere in the Pro Tools Reference Guide.

If you are new to surround mixing, read the remaining sections of this chapter for an introduction to surround terminology and concepts.

If you already have experience with surround mixing, mastering, and monitoring, these chapters can be skipped. Operational instructions for Pro Tools surround features begin in Chapter 31, “Pro Tools Setup for Surround.”

Mixing Formats and Surround Formats

When running Pro Tools version 5.1 or later with the SurroundMixer plug-in, Pro Tools HD-series and MIX-series systems let you mix in 3- to 8-channel formats, in addition to standard mono and stereo.

Supported mixing formats include Mono, Stereo, LCR, Quad, LCRS, 5.1, 6.1 and 7.1, letting you mix in any multichannel format needed for most surround formats.

Surround formats include Dolby Surround (Pro-Logic) and Dolby Digital, DTS, and SDDS. Pro Tools does not provide its own surround format processing, and requires appropriate plug-ins (such as Dolby SurroundTools™) or hardware to provide surround encoding and decoding.
**Pro Tools Mixing Formats**

See also “5.1 Track Layouts, Routing, and Metering” on page 436.

**Table 4. Multichannel Mixing and Surround Formats**

<table>
<thead>
<tr>
<th>Speaker Channels</th>
<th>Multichannel Mixing Format</th>
<th>Surround Format</th>
<th>Channels and Track Layout</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Mono</td>
<td></td>
<td>C</td>
</tr>
<tr>
<td>2</td>
<td>Stereo</td>
<td></td>
<td>L R</td>
</tr>
<tr>
<td>3</td>
<td>LCR</td>
<td>Cinema Stereo</td>
<td>L C R</td>
</tr>
<tr>
<td>4</td>
<td>Quad</td>
<td>Quadrephonic</td>
<td>L R Lr Rr</td>
</tr>
<tr>
<td>4</td>
<td>LC RS</td>
<td>Dolby Surround ProLogic (L C R S)</td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>5.1</td>
<td>Film (Pro Tools default), for Dolby Digital</td>
<td>L C R Ls Rs LFE</td>
</tr>
<tr>
<td>6</td>
<td>5.1</td>
<td>SMPTE/ITU (Control/24)</td>
<td>L R C LFE Ls Rs</td>
</tr>
<tr>
<td>6</td>
<td>5.1</td>
<td>DTS (ProControl)</td>
<td>L R Ls Rs C LFE</td>
</tr>
<tr>
<td>7</td>
<td>6.1</td>
<td>Dolby EX</td>
<td>L C R Ls Cs Rs LFE</td>
</tr>
<tr>
<td>8</td>
<td>7.1</td>
<td>SDDS</td>
<td>L Lc C Rc R Ls Rs LFE</td>
</tr>
</tbody>
</table>

Legend: L = Left; R = Right; C = Center, S = surround (mono); Ls = Left Surround; Rs = Right Surround; Lc = Left Center; Rc = Right Center; Cs = Center Surround; Lr = Left Rear; Rr = Right Rear

**Speaker Layouts**

Figure 27 on page 423 illustrates the speaker arrangements of each surround format. Speaker placement in the diagrams is approximate. For proper placement, alignment, and calibration of surround monitoring systems, consult the documentation that came with your speakers and other monitoring equipment. Placement of speakers is crucial to accurate monitoring of any mix, but this is especially true with multichannel mixing for surround sound.
Figure 27. Speaker arrangement of surround formats
Surround Monitoring

In order to monitor your current multichannel mix in a given surround format (DTS, Dolby Digital, or other), encoding and decoding equipment for that format is required. Pro Tools does not provide direct support for surround format processing, but encoding/decoding hardware or software is available from Digidesign and third-party manufacturers. Contact Digidesign or your dealer for information.

With proper speaker placement, and studio calibration, additional surround processors, monitors, and a properly calibrated system can lessen the variables that your mix will be subjected to when the audience eventually hears it in the theater, in their home, or elsewhere.

The Importance of Speaker Placement

It is very important that your surround monitor system be installed and configured correctly. Proper speaker placement, angling, and level calibration are necessities for surround mixing, so consult the manufacturer of your monitor system. Several surround formats (especially all of those from Dolby as well as DTS) have very specific speaker and monitoring recommendations, so take the time to locate this information and adhere to the suggestions they provide.

For an example of one way to set up a 5.1 monitor system, see Figure 28 on page 424.

![Figure 28. One suggested speaker arrangement for 5.1 mixing and monitoring (SMPTE specification). Sub placement is variable, all others should be as close to the suggested angles as possible.](image-url)
Calibrated Surround Monitoring

In any professional applications, one of the most important things you can do is to calibrate not just Pro Tools but also your monitoring system and other equipment.

For example, many post production facilities calibrate their Pro Tools audio interfaces for \(-20 \text{ dB} = 0 \text{ VU}\). Once Pro Tools hardware has been calibrated to unity gain, the monitoring system can be adjusted to account for anomalies in the room acoustics, speaker placement, and other variables.

Calibrating your Pro Tools system involves attenuating the input and output stages of your system. Settings and reference level vary according to the applicable standards of the current project.

Calibrating in Pro Tools is explained in the guide for peripherals that support calibration (such as the 192 I/O).

Calibrating Your Studio The first task for surround mixing should be getting your monitor speakers in proper position, alignment and calibration for accurate listening and mixing.

Speaker position and alignment will vary according to each installation, and is very specific for different speakers, manufacturers, and for each surround format. Instructions for optimal speaker location should have been provided with the speaker and monitor system, so consult the documentation provided by its manufacturer.

Speaker calibration makes sure that your system plays back at accurately balanced levels. This lets you compensate for any variances in speaker position, alignment or performance.

Formats and Terminology

Some multichannel mixing formats are referred to numerically (such as 5.1 and 7.1). These numbers describe the number and type of output (speaker) channels required for that format. Other formats are referred to by their track layout (such as LCRS, and LCR).

Surround formats are referred to by their developer and product name, such as Dolby Surround (or ProLogic), Dolby Digital, DTS, Dolby Surround EX, and others. Each surround format requires you to mix in a compatible mixing format. For example, both Dolby Digital and DTS are “5.1 surround formats.”

The standards for each format include more than just the number of speakers. Formats also may require specific track layout and filtering for the various channels. For example, the surround channel in Dolby Surround is band limited from 100 Hz to 7 kHz.

Surround formats also increase the importance of phase, balance, and sound placement due to the various ways in which multichannel mixes can be encoded, decoded, compressed, or matrixed. Many publications are available on these subjects. For a listing of several sources of surround format information, see “Where to Get More Information on Surround Technology” on page 428.
LCRS for Dolby Surround

Dolby Surround (ProLogic) is a four-channel format that is one of the most widely installed consumer surround formats.

This format, which requires Dolby encoding and decoding technology, provides three full-range front speakers left, center, and right, plus a mono surround channel (often split and monitored through pairs of satellite speakers, but a single “rear” channel nonetheless).

Surround Format Example

The goal of Dolby Surround encoding is to make a four-channel mix (LCRS) more portable, by transforming it into an encoded two-channel mix referred to as Lt/Rt. Lt and Rt represent Left Total and Right Total, respectively. Whenever you see Lt/Rt, it refers specifically to material that has been processed by a Dolby Surround Encoder (such as the Dolby SEU4 or Dolby SurroundTools plug-in).

The Lt/Rt mix can then be transported, transmitted, or played as a stereo mix, making it compatible with most home and theater systems. Alternately, the Lt/Rt pair can be decoded back into an LCRS mix in movie theatres, or in home theater systems where the required decoding hardware is available.

5.1 for Dolby Digital and DTS

Both Dolby Digital and DTS formats are six-channel, 5.1 formats. Both provide five full-range speakers and a sub. These two surround formats use different track layouts, filtering, and compression as part of their specifications.

.1 Formats

The “.1” in any multichannel mix format indicates an LFE (Low Frequency Effects) track in the mix. Whenever a decimal is part of a surround format, it indicates a discrete Sub channel in the surround playback system that is intended for playback through a subwoofer speaker. For example, Dolby Digital is a 5.1 format intended for playback through systems with five full-range speakers and one subwoofer speaker. Dolby Surround EX is a 6.1 format, with six full-range speakers and a sub. SDDS is a 7.1 format, with seven full-range speakers and one sub.

Sub content will include the LFE channel of a “.1” format mix, as well as the effects of any bass management in the playback system. See “LFE” on page 426.

.0 Formats

The “.0” formats (5.0, 6.0, 7.0), while not associated with any specific surround formats, are useful in many mixes as sub-paths. For example, not all tracks will have content that needs to be routed to the LFE channel (the “.1” channel). Assigning such tracks to a 5.0 path provides a 360° panner without LFE controls.

LFE

While mixing in a multichannel format, a decimal indicates an LFE channel. The LFE channel (for Low Frequency Effects, and also known as Low Frequency Enhancement) refers most often to a specific track used in production (not during playback or decoding). LFE is the “.1” component in mix formats such as 5.1 and 7.1.
The reason it's referred to as LFE is that unlike the other five or seven speakers, LFE is not full bandwidth (or, full-range). The LFE signal provides a direct path for low end to the subwoofer, unaffected by bass management (if any). Low frequency effects include such things as thunder, explosions, and other bass effects.

LFE is generally used to enhance sound effects in films. There are no set rules about whether or not you must employ an LFE channel.

**Sub Content**

When surround mixes are played back on systems that include one or more subs, subwoofer content comes from either or both of the following sources:

- All bass from all channels that is below the threshold of the bass management filter cutoff (if any)
  - and -
- Audio in the LFE channel (if any)

A surround format sub will play back all the lowest-frequency sounds from all of the other speaker channels, below a fixed frequency threshold. The threshold varies among different surround formats. See “Where to Get More Information on Surround Technology” on page 428 for a list of surround specification resources.

In addition to the frequency cutoffs and other specifications of each surround format, playback system variables can affect sub content. See “Surround Playback System Variables” on page 429 for more information.

**Divergence**

Divergence is a surround mixing parameter that lets you control panning “width.” Full divergence results in discrete (or narrow) panning. Lower divergence settings result in progressively less discrete (or wider) panning.

With full (100%) Divergence, tracks can be panned exclusively, or discretely, to a single speaker. Sounds panned to a single speaker are only audible in that speaker.

When Divergence is less than 100%, tracks will be audible in neighboring speakers even when panned directly to a single speaker in the grid. Lower divergence settings result in a progressively wider source signal.

**Divergence Example**

To understand divergence, it can be helpful to imagine the inside of a large movie theater. This is a good example because one of the most challenging playback variables one faces in multichannel mixing is the size of the intended listening environment.

Unlike the typical living room, movie theaters are large spaces with speakers placed widely apart. Due to distance, sounds panned discretely to the front right speaker, for example, might be inaudible in the opposite corner. To avoid this problem, variable divergence lets you control the panning width, in order to widen the sound source. This results in signals spreading into adjacent speakers, even when panned 100% to an individual speaker.

*Divergence options in Pro Tools are explained in “Divergence” on page 429.*
Where to Get More Information on Surround Technology

The table below lists several sites that are good starting points for your research into the constantly evolving world of surround sound production.

### Resources for surround specifications and information

<table>
<thead>
<tr>
<th>Surround Format</th>
<th>Web Site</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dolby Surround/ProLogic</td>
<td><a href="http://www.dolby.com">www.dolby.com</a></td>
</tr>
<tr>
<td>Dolby Surround EX</td>
<td><a href="http://www.dolby.com">www.dolby.com</a></td>
</tr>
<tr>
<td>DTS</td>
<td><a href="http://www.dtsonline.com">www.dtsonline.com</a></td>
</tr>
<tr>
<td>SDDS</td>
<td><a href="http://www.sony.com">www.sony.com</a></td>
</tr>
<tr>
<td>THX</td>
<td><a href="http://www.tmhlabs.com">www.tmhlabs.com</a></td>
</tr>
</tbody>
</table>

**Surround Mixing Concepts**

As in stereo mixing and mastering, the goal in surround mixing is to provide the best sounding mix to the greatest number of potential listeners. Doing so for surround mixes requires many of the same techniques used for professional stereo production, plus several unique factors that are introduced in the following sections.

**Surround Format Compatibility**

Pro Tools lets you mix in surround and create multichannel masters, consisting of four, six, or more tracks that comprise an LCR, 5.1, or other format mix.

- Whenever necessary, multichannel mixes can be transferred as discrete, multitrack masters. Track layout requirements vary by format (see “Multichannel Mapping” on page 435 for more information).
- Consumer playback systems don’t necessarily support every format. **Downmixing** occurs when a specific format mix has to be created from another.

To anticipate the effects of surround encode and decode, as well as potential downmixing, professional surround mixes are monitored through appropriate encoding and decoding processors. Monitor controller systems let engineers hear their mix through different speakers and configurations for reference.

**Surround Formats and Delivery Mediums**

Surround mixes are tailored for their specific delivery medium. Most often, this requires format-specific encode and decode processing.
Encoding and Decoding

Virtually all surround formats utilize some form of encoding and decoding to make it practical to deliver, broadcast, and transfer the multiple channels of full-bandwidth audio they require.

- **Encoding** is the process necessary to make multichannel mixes portable and playable. In many cases, this involves taking the four, five, six, or more discrete channels resulting from a multichannel mix and converting them into a two-channel stream for broadcast (still a predominantly 2-channel medium).

- **Decoding** is the process needed to reproduce (or unfold) the discrete surround channels from a 2-channel delivery medium.

Both encoding and decoding, no matter how refined, represent additional processing stages applied to your mix before it reaches its ultimate destination, the audience.

For example, because the Dolby Surround algorithm depends heavily on phase relationships, there is always a significant difference in the decoded LCRS output as compared to the original LCRS mix. To account for these anomalies, engineers mixing for Dolby Surround listen through encode and decode processors for reference.

Professional mixing and mastering engineers use encoders and decoders to precisely audition the effect of the encoding and decoding process, and make any adjustments necessary.

**Surround Processing and Pro Tools**

Pro Tools requires additional software or hardware for surround encoding, decoding, and processing. For example, the Dolby Surround-Tools™ plug-in lets you monitor and process completely within the Pro Tools environment.

SurroundTools and other surround processing solutions are available from Digidesign and third party manufacturers. Contact your Digidesign Dealer for more information.

**Surround Playback System Variables**

Different playback systems for surround sound introduce varying amounts and types of filtering, bass management, and other variables. These include the specifications for certain surround formats, as well as options to fine-tune a system for its particular installation.

In your own studio, you know what speakers you’re listening to, what their qualities are, and what your control room sounds like. What is impossible to know, however, is what speakers are in the living room, theater, or concert hall where your mix will be heard by an audience.

**Bass Management**

Bass management is a function of the playback system. Bass management refers to a number of processes by which a playback system can control what will be heard through the Sub(woofer) and other channels. The purpose of bass management is to optimize low frequency reproduction and overall frequency response for your specific monitoring system. Bass management provides a way to tune bass response for variables, including room size and shape, the presence (or absence) of a subwoofer, and the frequency range of each speaker.
Filtering

In its simplest form, bass management applies high-pass filtering to the full-range speaker. Frequencies below the filter cutoff are summed with the LFE channel (if any) and then routed to the subwoofer. Different systems may offer additional bass management processes, including:

**Bass Redirection** Mutes or unmutes the low-frequency signals filtered out of the full-range channels (that is, all signals that fall below the bass management filter cutoff frequency). This is useful when the full-range speakers are truly full-range, capable of accurately reproducing bass without distorting.

**Bass Extension** Lets the bass (however it is derived) be routed back through the full-range speakers. Though this may seem like a contradiction, its main purpose is to let sub content emanate from all around, rather than just from the subwoofer.
Chapter 31: Pro Tools Setup for Surround

This chapter explains how to set up and configure Pro Tools sessions for multichannel mixing.

Multichannel mixing is supported on Pro Tools HD-series and MIX-series systems only. In this chapter, all references to Pro Tools refer to Pro Tools HD-series and MIX-series systems.

**Before you can use Pro Tools in Surround mode:**

1. Make sure the Surround Mixer plug-in is installed in your Plug-Ins folder. If it is not, it can be installed using your Pro Tools 5.3 Installer CD-ROM.

2. Make sure your audio hardware is connected to your monitor system and other equipment correctly.

3. Make sure you have configured the Pro Tools Playback Engine and Hardware Setup dialog options correctly for your system as described in your Getting Started Guide.

4. Continue reading this chapter to learn how to configure Pro Tools and your sessions for Surround mode.

---

**Pro Tools Audio Connections for 5.1 Mixing**

While all 5.1 mixing formats provide the same speaker arrangement, there are three primary standards in use for the track layout of the individual channels that comprise the 5.1 format multichannel mix.

In the following table, it is assumed that surround channels are mapped to outputs 1–6 of a Pro Tools audio interface. Use channels 7–8 to monitor a stereo mix for a stereo version, or for cue mixes and monitoring.

**Table 5. Track Layouts for 5.1 Formats**

<table>
<thead>
<tr>
<th>Formats</th>
<th>Track Layout</th>
</tr>
</thead>
<tbody>
<tr>
<td>Film (Pro Tools default)</td>
<td>L C R Ls Rs LFE</td>
</tr>
<tr>
<td>SMPTE/ITU for Dolby Digital (AC3) and Control</td>
<td>24</td>
</tr>
<tr>
<td>DTS for ProControl</td>
<td>L R Ls Rs C LFE</td>
</tr>
</tbody>
</table>
To connect your audio interfaces for 5.1 format mixing and monitoring:

1. Determine the 5.1 format and track layout you want to use.

2. Connect the output channels of your audio interface to the corresponding input channels of your monitoring system according to the assignments listed in Table 5 on page 431.

If you use a Digidesign control surface, see its guide for more information.

Configuring Pro Tools for Multichannel Sessions

Configuring Pro Tools and sessions for multichannel mixing can be done in any or all of the following ways:

New Sessions

You can create a new session and choose a surround mix I/O Settings file as the default I/O Setup. (See “New Sessions and I/O Settings” on page 432.)

Remixing Sessions in Surround

By importing a surround mix I/O Settings file into the I/O Setup dialog, multichannel paths can be made available in any stereo (or other format) session. You can then reassign track routing from the original stereo paths to multichannel paths. Inactive and active paths simplify reassignment. (See “Importing Multichannel I/O Setups” on page 434.)

Custom Paths

You can customize and redefine existing paths in the I/O Setup dialog. For more information, see “Custom Multichannel Paths” on page 434.

Importing Tracks

By importing tracks into a session, you can add the tracks and media, plus the associated paths and track assignments. Tracks retain their paths and assignments, which are added to the current session. Active and inactive status is determined by available system resources. After importing tracks, you can use the I/O Setup dialog to configure main and sub-paths for requirements of the session. For more information, see “Importing Tracks from Other Sessions” on page 98.

New Sessions and I/O Settings

When you create a new session, you can specify a surround format that you want to use as your I/O Setup. Default path configurations are provided as I/O Settings files, for stereo and surround mixing.

Once you create the new session, you can create and import tracks, import audio, and assign signal routing to set up your mix.
To create a new session for multichannel mixing:

2. Select one of the available 5.1 settings from the Default I/O Settings menu.

The surround presets preconfigure the I/O Setup dialog with default 5.1 format main and sub-paths for outputs and busses.

Surround Mix Settings Files

The surround mix I/O Settings files provide output and bus paths for three specific track layout standards. (See also “Default Input and Insert Paths with 5.1 Settings” on page 433.)

Settings Files and Track Layouts

<table>
<thead>
<tr>
<th>5.1 Settings</th>
<th>Track Layout</th>
</tr>
</thead>
<tbody>
<tr>
<td>Film (Pro Tools Standard)</td>
<td>L C R Ls Rs LFE</td>
</tr>
<tr>
<td>SMPTE/ITU (Control</td>
<td>24 Monitoring)</td>
</tr>
<tr>
<td>DTS (ProControl Monitoring)</td>
<td>L R Ls Rs C LFE</td>
</tr>
</tbody>
</table>

All three 5.1 format settings files provide the following default output and bus paths:

Default 5.1 Output Paths
- One 5.1 main output path, with sub-paths for center, left/right, LCR, and 5.0 (no LFE).
- Also, one stereo main path with two mono sub-paths.

Default 5.1 Bus Paths
- One 5.1 main bus path, with sub-paths for 5.0 (no LFE), left/right (stereo), LCR, and center (mono).
- Also, one stereo main path with two mono sub-paths.

Default Input and Insert Paths with 5.1 Settings

The 5.1 Mix settings files provide default stereo main and sub-paths for inputs and inserts. If you need multichannel input paths or inserts, you can create them in the I/O Setup dialog (see “Custom Multichannel Paths” on page 434).
Importing Multichannel I/O Setups

The I/O Setup dialog can import and export settings files. Importing I/O Setup settings files is useful when you want to remix a stereo session in surround. You can also use this feature to prepare a session for transfer to a different Pro Tools system, or to simply save and exchange I/O Settings.

To import a multichannel I/O Setup settings file:
1. Choose Setups > I/O Setup.
2. Click Import, then select the settings file to import.

If the current session has existing path definitions that don’t match those in the imported settings file, Pro Tools asks whether you want to delete the existing paths or retain them and add the imported settings to your session.

- Click No to add new paths to your current I/O Setup configuration.
- Click Yes to replace your current I/O Setup configuration with the imported settings.

Exporting I/O Settings

Exporting I/O Setup settings files lets you build a library of multichannel setups for different projects.

To export an I/O Setup settings file:
1. Choose Setups > I/O Setup.
2. Click Export.

Custom Multichannel Paths

The I/O Setup dialog lets you create and customize signal paths for any supported multichannel mixing format.

The I/O Setup dialog and its Channel Grid also let you remap channels. This is especially useful to route channels within a multichannel path, without having to repatch your audio interfaces.

In addition, the I/O Setup dialog, like the Main page of the Hardware Setup dialog, provides controls for routing the physical ports on your I/O peripheral to Pro Tools input and output ports.

For HD-series interfaces, multiple physical outputs can be assigned to a single Pro Tools output. In the Hardware Setup dialog (or I/O Setup dialog), choose one of the outputs in the pop-up menu, and press Control on each desired output destination.

When creating 5.1 format paths, you can specify the default track layout. See “Default Path Order for 5.1 Tracks” on page 436.

Example LCRS Setup

The following example shows one possible way to configure the I/O Setup dialog to mix in 4-channel LCRS format.

For additional I/O Setup information, see “Creating and Editing Paths” on page 64.
To define an LCRS path:

1. Choose Setups > I/O Setup > Output.
2. Click New Path.
3. Select LCRS from the Path Format Selector.
4. Name the path LCRS.
5. In the Channel Grid, click in the box below the first (left-most) audio interface channel for the path. Pro Tools automatically fills up the adjacent units to the right. If you click in the LCRS row under channel 1, the LCRS path will be mapped across channels 1–4.
6. Select the new LCRS path, and click New Sub-Path.
7. Name the new path LCR, and select LCR as the Path format. Click in channel 1 in the LCR row to map the path.
8. Create a stereo sub-path for front Left and front Right.
9. Define mono sub-paths for the Center and Surround channels.

**Multichannel Mapping**

Multichannel paths and sub-paths are mapped to inputs, outputs or internal busses in the Channel Grid. When you select a preset 5.1 I/O Settings file, default layout for the corresponding multichannel format paths you create will match the selected format’s track layout.

**Example Mapping for an LCRS Output Path**

The following diagram shows the I/O Setup dialog configured for a LCRS-format output mix, with a single, 16-channel audio interface.

**Example LCRS output main and sub-paths**

You can remap paths to any required configuration, limited only by your systems resources, and the I/O Setup dialog requirements for channel overlapping and naming (see “Valid Paths and Requirements” on page 68 for more information).

*See also “Example Paths and Signal Routing for a Surround Mix” on page 445.*

**5.1 Tracks, Formats, Mapping and Metering**

Path definitions in I/O Setup determine how audio is routed through, and metered on, your audio interfaces.

Pro Tools internal (on-screen) metering of 5.1 format paths always follows the Film track layout:

```
L C R Ls Rs LFE
```

Pro Tools track layout of 5.1 format audio tracks in the Edit window also conforms to the Film layout (arranged top to bottom). See the illustration “5.1 Track Layouts, Routing, and Metering” on page 436.

In the I/O Setup dialog, you can route these signals out of your audio interfaces according to any track layout (DTS, SMPTE/ITU, or other).
To re-map channels in a path:

- Click and drag a channel to a new valid location in the Grid. Other channel assignments will move (shuffle) to accommodate dragged channels.

**Default Selectors in I/O Setup**

The I/O Setup dialog provides the following default settings for multichannel sessions:

**Meter** Selects the path that will be shown in Digidesign control surface output meters. See “5.1 Tracks, Formats, Mapping and Metering” on page 435 for more information.

**Audition** Selects the monitoring path for previewing audio in the Regions List and Import Audio dialogs. Only outputs on your primary interface can be used as your Audition path.

**Default Output** Selects the default output path for all new tracks, for each supported track format.

**Default Path Order** Selects the default track layout (or, path order) for new 5.1 format (six-channel) paths.

**Default Path Order for 5.1 Tracks**

You can specify the default track layout for all new 5.1 format paths you create.

**5.1 Track Layouts, Routing, and Metering**

**Figure 29. Track layout of different 5.1 formats**
Chapter 32: Multichannel Tracks and Signal Routing

Surround sessions typically include a combination of mono, stereo, and multichannel audio tracks, Auxiliary Inputs, and Master Faders, busses and inserts.

Once the appropriate I/O Setup has been imported or configured, any audio track can be mixed in multichannel for surround using Pro Tools mixing features.

Multichannel I/O and signal routing is determined by the paths defined in the I/O Setup dialog.

Multichannel QuickStart

The following is an overview of how to get started mixing in multichannel for surround in Pro Tools.

**To mix in multichannel:**

1. Open any stereo Pro Tools session to remix it in surround. (You can also create new, empty surround sessions. See “New Sessions and I/O Settings” on page 432.)

2. Configure the I/O Setup dialog with multichannel inputs, outputs, busses, and inserts, as needed. (See “Configuring Pro Tools for Multichannel Sessions” on page 432.)

   For HD-series interfaces, multiple physical outputs can be assigned to a single Pro Tools output. In the Hardware Setup dialog (or I/O Setup dialog), choose one of the outputs in the pop-up menu, and press Control on each desired output destination.

3. Create new tracks and assign track outputs and sends to your multichannel paths. Configure signal routing as needed for submixing, bussing, processing, and monitoring. For tracks that do not need to be panned in 360°, place them in the mix using sub-paths and signal routing. (See “Multichannel Signal Routing” on page 440.)

4. Pan in surround using the multichannel Track and Send windows. (Mixing and panning for surround is explained in Chapter 33, “Surround Panning and Mixing.”)
Multichannel Audio Tracks

Multichannel audio tracks contain multiple individual signals for each signal in the track (one for the left, one for the right, one for center, and so on).

Multichannel audio tracks can be:

- Recorded directly into Pro Tools, using multiple microphones or microphone arrays, or routed to appropriate multichannel Pro Tools Input paths.
- Imported from other Pro Tools sessions.
- Edited, processed, and mixed in combination with mono and stereo tracks.

5.1 format audio files and tracks conform to the Film track layout standard. Regardless of path mapping in the I/O Setup dialog, all 5.1 format audio tracks and meters follow the Film standard track layout:

L C R Ls Rs LFE

Multichannel audio tracks are not required to mix in multichannel formats. Mono, stereo, and all supported track formats can be mixed using Pro Tools track outputs and sends. See “Multichannel Signal Routing” on page 440.

Placing Audio in Multichannel Tracks

You can drag audio files and regions from the Audio Regions List, or from other tracks, to place them in multichannel audio tracks.

To do so, the number of channels being dragged must match the destination track format. For example, you can only drag a stereo pair or two mono regions onto a stereo audio track. Similarly, you can only place audio into an LCR track when you have selected three regions. With 5.1 tracks, you must select six files or regions.

Solo, Mute, and Gain in Multichannel Tracks and Paths

Stereo and multichannel tracks consist of multiple audio signals, linked together. By default, multichannel tracks are linked and are controlled by a single channel fader, solo and mute switch.

For discrete control of signals, multichannel tracks can be converted into individual mono tracks. For discrete level and phase adjustment, you can insert and unlink a multi-mono Trim plug-in. Both of these techniques are explained below.

⚠️ Once converted to mono, multichannel tracks cannot be relinked into their original multichannel format. The only way to reassemble a multichannel track is by dragging the corresponding number of mono files into a multichannel track, which can result in loss of some automation data.

To convert a multichannel track into discrete mono tracks:

1. Select the multichannel track.
2. Choose File > Convert Selected Tracks to Mono.
To have discrete control of gain on individual channels of a multichannel track:

1. Insert a multi-mono Trim plug-in on the multichannel track.
2. Unlink the Trim plug-in by clicking the Link icon so that it is unlit.
3. Use the Channel Selector to display the controls you want to edit, and adjust the gain.

See “Linking and Unlinking Controls on Multi-Mono Plug-Ins” on page 442 for more information.

Track and Output Formats

When you create new tracks, you specify mono, stereo, or a supported multichannel format for the new tracks.

In the Mix and Edit windows, the track format is always visible by the number of track meters contained in its fader strip (a single meter for mono tracks, a pair for stereo tracks, and so on).

Assigning track output determines the format of that output. For example, a mono track always has a single track meter, even when assigned to a stereo output path. If that same mono track is assigned to a 5.1 output path, its output will be split among those six output channels, depending on the position of its panner.

Changing Format

Changing the output format for a given track has several effects:

- The panner that appears in the track will change to reflect the new output format.
- It may be necessary for one or more pan related automation playlists to be created or deleted.

Because changing the output format has these effects, a warning dialog appears whenever you change the output format of a track to a format of fewer channels. Specifically, this will occur whenever automation playlists will have to be deleted.

Multiple Output Assignments and Track Format

When a track is assigned to more than one path of differing formats, the main output for that track will match the format of the assigned path with the greatest number of channels.

Multiple Outputs and Automation Playlists

When a track has multiple output assignments (as configured in the Hardware Setup dialog or I/O Setup dialog), Pro Tools sorts panning data appropriately for each assigned path. For example, if you assign a mono track to a stereo path and a 5.1 path simultaneously, that track will have a 5.1 panner in the Mix or Edit window. When you pan the track, Pro Tools interprets the 5.1 panning moves into stereo panning moves (by ignoring any front-to-rear moves, in this example).

This provides a type of parallel mixing. You can create a variety of mixes of differing formats all at the same time by routing your elements to multiple paths.

Command-Control-click any control in an Output window to show its automation playlist.
Multichannel Signal Routing

To mix in a multichannel format, tracks are assigned to multichannel paths.

Tracks can be mixed in surround using the following two methods:

- By setting a track main output to a multichannel path.
- By assigning a multichannel send to route audio to a multichannel path.

See “Multichannel Sends” on page 440 for more information.

Multichannel Track Outputs

Tracks are routed to output and bus paths using the track Output Selector. This assigns the main track output. Additional output assignments can be added by Control-clicking the Selector and assigning another path. This provides a multichannel panner and meter in the Mix and Edit window I/O View. (See also “Multichannel Sends” on page 440 for details.)

Multichannel Sends

Mono, stereo and all other track formats let you assign one or more multichannel sends. This provides a multichannel panner in the Sends View. Sends are also useful to bus tracks for multichannel plug-in processing.

The following figure shows a mono audio track with a 6-channel send (Sends View Shows > Send A View).
Pro Tools bussing and submixing features are available for all channel formats, from mono/stereo through 8-channel. For examples of multichannel monitoring, effects processing, and bussing, see “Mixing with Paths and Sub-Paths” on page 443. For mono and stereo mix examples, see Chapter 26, “Basic Mixing.”

**Multichannel Auxiliary Inputs and Master Faders**

A multichannel Auxiliary Input or Master Fader is used as a return for the multichannel bus. Sends are useful when you need to create an additional, independent mix simultaneously (perhaps of a distinct format), requiring dedicated fader, mute, solo and automation controls.

You can assign Master Faders to main and sub-paths. Main paths must match the format of the Master Fader, and only one Master Fader can be active and assigned to any single (active) main or sub-path. A Master Fader cannot be assigned to a sub-path if its associated main path is already assigned on another Master Fader. See “Master Faders” on page 339.

**Mono, Multi-Mono and Multichannel Plug-Ins**

Plug-ins can be used in mono, multi-mono, or multichannel formats.

**Plug-in formats**

For information about mono, stereo, and mono-in/stereo-out plug-ins, see Chapter 27, “Plug-In and Hardware Inserts.”

**Multi-Mono Plug-Ins** Are designed for use on greater-than-stereo multichannel tracks. Multi-mono plug-ins are useful, or required, in the following situations:

- When a desired plug-in does not involve multichannel correlated processing (for example, when applying EQ to select sides of a multichannel signal).
- You need to adjust signals within the multichannel track independently.
- When a plug-in does not support multichannel formats.

When a multi-mono plug-in is first inserted on a multichannel track, the plug-in controls are linked. You can unlink them for independent adjustment. See “Linking and Unlinking Controls on Multi-Mono Plug-Ins” on page 442 for more information.

Multi-mono plugs-ins can also be inserted on stereo tracks, to apply unlinked plug-ins on the left and right channels.
Multichannel Plug-Ins are designed for use on stereo and multichannel tracks that require correlated processing, including stereo and multichannel limiting, compression, and similar effects.

Linking and Unlinking Controls on Multi-Mono Plug-Ins

When a multi-mono plug-in is used on a multichannel track of more than two channels, the controls are normally linked. Adjusting the Gain parameter on one channel, for example, will adjust it for all channels.

If necessary, you can unlink plug-in controls on specific channels of a track and edit them independently. You can also selectively link the controls of specific channels.

For example, to apply equal filter cutoffs to the Ls and Rs (surround) channels in a 5.1 mix, you could link enable just those channels in an unlinked, multi-mono EQ plug-in. Adjusting the controls in the Plug-In window for either channel (Ls or Rs) adjusts the other, linked channel as well.

To unlink controls on a multi-mono plug-in:

- Deselect the Master Link button. It is lit when linked, unlit when unlinked.

To access controls for a specific channel:

- Select the desired channel from the Channel Selector.

To open a Plug-In window for all channels of a multi-mono plug-in:

- Option-click the Channel Selector.

To link the controls of specific channels:

1. Deselect the Master Link button if it is not already deselected.

2. Click the Link Enable buttons for the channels whose controls you want to link.

The Trim plug-in is explained in the Digi-Rack Plug-Ins Guide.
Chapter 32: Multichannel Tracks and Signal Routing

Paths in Surround Mixes

Because Pro Tools provides a flexible routing and submixing environment, you can maximize your system’s available resources by first identifying the elements that you want to pan dynamically and those that can be placed in certain channels only. (See “Mixing with Paths and Sub-Paths” on page 443 for an explanation of this concept.)

Once you have identified these elements in your session, you can use a combination of main and sub-path assignments, and multichannel panning. Figure 30 on page 444 shows an example session.

Mixing with Paths and Sub-Paths

It is rare that every track needs to be “flown” (actively panned in between more than a pair of speakers). In most situations, certain elements are placed in certain speakers and remain there, providing the foundation for a mix.

Figure 30 on page 444 illustrates an example of how panning and signal routing can be combined in a multichannel mix. The following sections show you how to organize your session and signal routing to maximize the available resources.

When to Assign Multichannel Outputs

- Assign 5.1 paths only to those tracks that need to be panned to all six channels.

For example, a sound effects track with a jet fly-over should be assigned a 5.1 path to be able to “fly” the sound from front-to-back. In a music mix, fly a solo instrument or make a synth pad swirl around the room as a special effect.

Elements that need to be heard in all speakers simultaneously can also be assigned to the multichannel output, whether or not they need active panning in the sound field.

When to Use Sub-Paths

- To help simplify large sessions, try to use sub-paths to route static (or, stationary) elements directly to the output channel or channels.

For example, film dialog is often mixed to the center channel to anchor this essential sound element to the visual element (the picture). Instead of assigning a six-channel panner to dialog tracks and panning it to the center channel only, you can route the dialog track’s main output to a mono (Center) sub-path. Doing so may be unavoidable in some sessions, such as a scene in which every sound needs to fly or move in the 360° sound field. This is more likely to be the exception, however, because many elements of a mix will not need to be moving between speakers.

See “Extending Stereo Mixing Conventions to Surround Mixing” on page 444 for related information.
Extending Stereo Mixing Conventions to Surround Mixing

Stereo mixing sets the precedent for active and static panning, and surround mixing can benefit from the same basic principles.

Panning a sound back-and-forth between the left and right speakers is best used as a special effect. In a typical music mix, the basic tracks are placed in the stereo sound field and remain there.

Surround mixes can become incoherent if too many elements are continuously moving. For special effects, some tracks can be panned dynamically, bouncing between speakers or sweeping from one side to the other.

Figure 30. Using signal routing and sub-paths to mix in surround
Example Paths and Signal Routing for a Surround Mix

These examples show how Auxiliary Inputs, Master Faders, and other Pro Tools signal routing features can be used for stem mixes, submixes, and similar project needs.

In these examples, music and effects are being mixed for a trailer, in 5.1 surround. Separate stem mixes (for music, and for effects) are to be mastered to 8-track MDM.

Example Multichannel Paths

Signal routing is the key element in any Pro Tools surround session. Signal routing is configured and defined in the I/O Setup dialog.

Example Output Paths

The following diagram shows output paths defined in the I/O Setup dialog of an example session. This example session is shown on a Pro Tools HD system with one 96 I/O.

Example Bus Paths

The following diagram shows example bus paths.

Additional stereo output paths, with mono sub-paths, have also been defined for the remaining channels.

Example Sub-Paths

Sub-paths let you route to selective channels within the multichannel (surround) output. In the pictured example, the FX bus has several sub-paths that show this.

5.0 Sub-Path The 5.0 FX bus is a 5-channel sub-path. With tracks that you are sure you want to keep out of the LFE channel, use this type of sub-path routing to conserve mixing resources.

LFE Path A custom LFE sub-path has been added to provide a discrete mono path to the LFE channel.
Signal Routing Examples

The following show a few possible ways that main and sub-paths can be used, using an example session consisting of a 5.1 main mix, with music and effects stems (or submixes).

The first example shows one possible routing configuration for an effects submix.

Some tracks are routed to stereo sub-paths, while others are assigned to mono, LCR, or other sub-paths. Two tracks (one stereo, one mono) are assigned to multichannel busses, for surround panning. A 5.1 Auxiliary Input assigned to the FX main bus path serves as a sub-mixer.

Music tracks might be routed similar to the following example.

Most of the music tracks in this example are routed to the front left/right channels, using a stereo sub-path. A 5.1 Auxiliary Input controls the bus and stem output.

Main Stems Example

The two Auxiliary Input channels can be multi-assigned to additional 5.1 format paths for a main mix.

Assigning multiple outputs

Multiple output assignments make it possible to configure a number of multi-format mixes. For example, you can assign an additional stereo output to tracks and create a stereo mix at the same time as a 5.1 mix. For more information, see “Multiple Output Assignments” on page 344.

LFE Examples

LFE tracks and other audio can contribute to the LFE output (the “.1” channel in supporting formats) in two ways:

- Using the LFE slider in Output windows. This LFE signal is post-fader.
- or –
- Using a custom sub-path to route channels discretely.
The following shows a channel Output window, sending and metering to the LFE channel.

**LFE contribution from a stereo output**

Using the LFE fader, you can add any amount of any multichannel path to the overall LFE output. In the above example, the track’s Center percentage has been turned off, and the LFE fader has been raised to route it to the LFE channel.

The next diagram shows how a “traditional” LFE track can be routed to only the LFE channel. This example uses a custom-defined LFE sub-path to the FX main bus path.

**Discrete LFE routing**

For instructions on how to create a sub-path, see “Custom Multichannel Paths” on page 434.

**LFE and Filtering**

Pro Tools applies no filtering to LFE signals. Some delivery requirements may specify filtering for the LFE track (such as the Dolby requirement of 120 Hz). See “Mixing Formats and Surround Formats” on page 421 for more information.

* LFE faders can follow Mix and Edit Groups. See “Automation Preferences” on page 380 for more information.

**Multichannel Plug-Ins**

Audio tracks, Auxiliary Inputs, and Master Faders let you assign multi-mono or multichannel plug-ins. This lets you process multichannel outputs as a single entity using multichannel, or linked multi-mono, plug-ins. Unlinked multi-mono plug-ins let you process individual channels of a multichannel path, with linking and unlinking. For more information on multichannel plug-ins, see Chapter 27, “Plug-In and Hardware Inserts.”
Chapter 33: Surround Panning and Mixing

This chapter explains how to pan and mix in surround with Pro Tools.

Before you can pan a track in surround, it must be assigned to an appropriate multichannel output or bus path.

The I/O Setup dialog defines the bussing and output architecture of the Pro Tools multichannel surround mixer. If you have not already done so, it is recommended that you become familiar with main and sub-paths and the I/O Setup dialog before starting multichannel Pro Tools projects.

See Chapter 31, “Pro Tools Setup for Surround” for more information on multichannel configurations and I/O Setup options. For multichannel signal routing, see Chapter 32, “Multichannel Tracks and Signal Routing.”

Introduction to Pro Tools Surround Panning

There are four different track panning methods available:

- In the Edit window, using the reduced-height Panner Grid in the I/O View
- In the Mix window, using the reduced-height Panner Grid
- In the Output window, using the full-size Panner Grid
- Through pan automation editing

Control surfaces provide additional panning options. Refer to the documentation for your control surface for more information.

Mix and Edit Window Panner Grids

In the Mix and Edit window, multichannel Panner Grids are displayed on tracks that have multichannel track or send output assignments.
To pan from the Mix or Edit window:

1. Make sure I/O View is being shown for the Mix or Edit windows (Display > Mix/Edit Window Shows > I/O View).
2. Begin playback.
3. Click and drag on the appropriate multichannel track’s Panner Grid in the Mix or Edit windows.

The green pan cursor follows your movements as long as you hold down the mouse button. Movements are scaled so that, once you click to “grab” the pan cursor, you do not need to limit your movements to the small Track Grid area.

Pan Cursor Color while Automating

The pan cursor is green when the track is in Automation Read mode, red in an Automation Write mode, and yellow in Trim mode.

Output Windows

Output windows provide panning controls for tracks of all mix formats. Some of the features of Output windows include:

- X/Y (joystick-style) panning
- 3-Knob panning
- Full Divergence and Center % control
- LFE feed
- Multichannel meters
- Pro Tools Target window support

This section describes the basic techniques for opening and arranging Output windows. Panning controls and instructions begin in “Surround Panner Controls” on page 452.

Multichannel Panners

Multichannel panners are provided for each multichannel mixing format (from 3-channel LCR thru 8-channel 7.1). See “Surround Panner Controls” on page 452 for more information.

Multiple panners can be opened simultaneously, or a single window can be anchored to always display the current panner.
To open an Output window:

- Click the Output icon in the track in the Mix or Edit window (I/O View).

Opening a multichannel Output window

For instructions on managing multiple Output windows, see “Output Windows for Tracks and Sends” on page 349.

Standard Controls

All Output windows provide standard Pro Tools controls for routing, path assignment and other track features. These controls are located at the top of all Output, Send, Insert, and Plug-In windows. Some controls are specific to the type of window.

Track Fader, Solo, Mute, and Auto

All Output windows provide track volume and mute controls. You can adjust and automate track volume, or mute, directly using these controls. The larger fader and mute button are equivalent to those on the Pro Tools Mix window.
Surround Panner Controls

On surround-capable Pro Tools systems, Output windows, when assigned to tracks or paths with four or more channels, provide an X/Y Grid for surround panning. The speakers associated with the panner’s multichannel format are displayed in their relative positions outside the Panner Grid.

This section identifies all the controls and features found in Pro Tools multichannel panners.

Figure 31. A 5.1-format multichannel panner
The X/Y Grid and Pan Cursor

The X/Y Grid is where multichannel panning information is input and displayed. You can also input pan information using 3-Knob mode, or by entering numeric values in the Position data fields, as described below. (You can also edit pan automation graphically in the Edit window.)

Multichannel panners default to X/Y mode. In X/Y mode, the track’s current pan position is represented by a green dot. This dot is the pan cursor, and its color indicates track automation status using standard Pro Tools colors:

- **Green** The track is in Auto Read mode
- **Red** The track is in Automation Write, Touch or Latch mode
- **Yellow** The track is in Automation Trim or Auto Off mode.

Panning Mode Buttons

Directly below the X/Y Grid are the Panning Mode buttons.

X/Y Mode, Divergence Editing, and 3-Knob Mode buttons

These switches provide access to advanced surround mixing features, and are explained in “Panning Modes” on page 454.

Position Controls

The Position controls include three rotary knobs and their text fields.

- **Front** Displays and controls the current front X-axis position of the panner.
- **Rear** Displays and controls the current rear X-axis position of the panner. In default X/Y Panning mode, Rear is linked to Front position and cannot be controlled independently.
- **Front/Rear** Displays and controls the current Y-axis position of the panner.

Center % Controls

This rotary knob lets you control how much of the signal is routed to the center speaker. This lets you mix a track to the front with a phantom center (0% Center value) or to three-channel (LCR) when panning front.
**Divergence Controls**

Divergence determines the width of the panned signal with respect to neighboring speakers. (See “Divergence” on page 427 for more information.)

**Front, Rear, and F/R Divergence** Provide separate, automatable divergence control over front speakers, rear speakers, and between front/rear, respectively. See “Divergence” on page 457 for more information.

For examples of how divergence settings affect output panning, see “Divergence and Center Percentage” on page 457.

**LFE Fader**

The LFE fader is only available in “.1” formats — 5.1, 6.1 and 7.1.

The LFE fader determines how much of the current track’s signal will be routed to the LFE channel. LFE faders in Track and Send windows can follow groups. The Pro Tools LFE channel is always full-bandwidth. For more information on how to use the LFE fader, see “LFE Faders in Multichannel Panners” on page 456.

**Panning Modes**

Pro Tools supports X/Y and 3-Knob Panning modes. Both can be automated.

**X/Y Mode** Joystick-style panning by dragging the pan cursor within the X/Y Speaker Grid.

**3-Knob Mode** Point-to-point panning, between pairs of speakers. See “3-Knob Panning” on page 455 for more information.

**X/Y Panning**

To pan in X/Y mode:

1. Click the X/Y mode icon.

2. Drag the pan cursor, or click anywhere in the Grid and drag to pan the track. The location of the pan cursor determines the pan position of the signal. For example, to pan something to the left rear speaker, move the pan cursor to the lower-left corner of the Grid.
**Cursor Take-Over**

It is not necessary to click exactly on the pan cursor. Clicking anywhere in the Grid will move the pan cursor relative to where you click or take over with a hardware panner. Panning does not jump to the click position.

**To snap the pan cursor to a location in the Grid:**

- Hold down the Control key and click anywhere in the X/Y Grid.

**Grid Options and Shortcuts**

**Fine-adjust Mode** The Command modifier enables Fine Adjustment mode of all variable Panner controls.

**Constraining to X or Y Movement** Holding the Shift modifier key down when clicking in the Grid will force the movement of the dot to be constrained in either the X or Y direction, depending on which direction you move first.

**Reset to Default** The default position of all position parameters can be recalled by Option-clicking anywhere in the Panner Grid.

**“Snap To” a Speaker in the Grid** To force the panner to the location of one of the valid speakers, click directly on the appropriate speaker icon.

**Display Automation in Edit Window** Command-Control-click on a parameter to display that parameter’s playlist in the Edit window.

> All pan parameters can be automated, including pan position and divergence. See Chapter 28, “Automation” for details.

**3-Knob Panning**

Pro Tools provides 3-Knob mode as an additional way to input pan moves.

3-Knob mode lets you:

- Pan in straight lines, moving the pan cursor using the Position rotary knobs with full movement of front, rear, and front-rear position.
  
  – and –

- Pan discretely between pairs of speakers.

3-Knob mode lets you pan discretely between speakers. For example, when panning front-left to rear-right in 3-Knob mode, audio will be heard from just those two speakers (assuming full divergence is in effect).
By comparison, in X/Y mode a diagonal pan may result in audio being heard in some or all channels.

The difference is that 3-Knob mode pans discretely between the front and rear position of the panning trajectory, while X/Y mode panning takes place in the full 360° Panning Grid. Divergence and Center % are variable in both Panning modes.

**To enable 3-Knob Panning mode:**

- Click the 3-Knob mode icon.

The panner trajectory line appears across the Grid, extending from the front (X-axis) to the rear (Y-axis).

**To pan in 3-Knob mode:**

1. Adjust the Front and Rear Position knobs to set the trajectory line.
2. Rotate the Front/Rear Position knob to pan along the trajectory. The Pan Cursor is constrained to the white trajectory line.

**To change the 3-Knob trajectory angles:**

- Drag either endpoint (Front, or Rear) of the trajectory line.
- Adjust the Front or Rear Position controls.

**To change the current trajectory position (left-to-right) and retain its current angles:**

1. Drag the trajectory line (not its endpoints) to a new position.

---

**LFE Faders in Multichannel Panners**

The LFE fader controls the track’s LFE contribution (or, how much of the track is sent to LFE). LFE faders are only available when a track is assigned to a path whose format supports LFE (5.1, 6.1, or 7.1).

**To mix to the LFE channel:**

1. Adjust the LFE fader in any “.1” format Output window.

   For general information about LFE, sub channels, and related topics, see Chapter 30, “Surround Concepts.”

**LFE and Groups**

Track and send LFE faders can follow Mix and Edit Groups by enabling this feature in the Automation window of the Preferences dialog. See “Automation Preferences” on page 380 for more information.
LFE Enable

Some multichannel plug-ins, including the Di-
giRack multichannel Compressor, provide LFE Enable. This lets you enable (or, bypass) phase-
accurate processing of the LFE channel, when one is present.

To process the LFE channel in a multichannel plug-
in:

1. Click to enable LFE Enable in supporting multichannel plug-ins. LFE Enable is high-
lighted when LFE processing is enabled, and un-
highlighted when LFE processing is bypassed.

Divergence and Center Percentage

The Divergence and Center % controls range from 0 to 100, and can be automated. They are especially useful to ensure audibility and cover-
age in large venues, and to increase clarity of voice.

Front Divergence Controls divergence between front speakers (X-axis only).

Rear Divergence Controls divergence between the rear speakers (X-axis only).

Front/Rear Divergence Controls divergence between front and rear (the Y-axis).

Center % (Percentage) Center % determines whether there is a discrete center image, a completely phantom center image, or some variable amount in between.

Divergence

In the Panner Grid, the current divergence val-
ues are displayed by a purple outline.

Divergence display and controls

By default, Pro Tools surround panners are 100% or fully divergent, meaning that a signal that is panned completely to one speaker will only be audible in that speaker.

Full divergence for discrete panning to front, left (meters show signal only in front, left)
Lower divergence settings result in a progressively wider source signal. When Divergence is less than 100%, tracks will be routed to neighboring speakers to some degree, even when the pan cursor is positioned next to a single speaker.

To adjust divergence:
- Adjust the Front, Rear, and Front/Rear Divergence controls as necessary.

To adjust divergence graphically:
1. Click the Divergence icon below the Grid.
2. Drag to resize the divergence boundaries in the Grid.

**Center % (Percentage)**

Center Percentage controls whether there is a discrete center channel for the track, or a phantom center channel.

**Center % Example**

In film and video production, the center channel often contains dialog. To enhance clarity of essential dialog, it is often beneficial to keep other elements (such as music) out of the center speaker. By reducing the Center % on music tracks (in this example), music panned to the front of the soundfield can be panned to just the left and right speakers, forcing them to have a (variable) phantom center image.
To adjust Center Percentage:

- Adjust the Center % knob as appropriate.

As you reduce the Center % value, the center speaker icon at the top of the Grid becomes less visible. At 0, the center speaker icon is completely invisible, reflecting the setting for fully phantom center.

**Pan Playlists and Automation**

Multichannel panners have several automation playlists associated with them (for each position and divergence control it provides).

**Panning Does Not Follow Groups**

Unlike mute and volume breakpoint editing, pan automation by default does not follow Edit Groups. To force pan automation editing to follow groups, you can hold down the Control key while editing automation breakpoints on a member track. This feature applies to all seven types of pan controls (front, rear, and front/rear pan position, front divergence, rear divergence, front/rear divergence, and center percentage).

---

**SurroundScope Metering Plug-In**

The SurroundScope Metering plug-in provides a 360° meter for multichannel mixing. It provides a method of metering multichannel paths, and is available in all multichannel formats.

**5.1 Format Track Layouts**

All on-screen, 5.1-format meters (including those displayed in the SurroundScope meter, on tracks, and in Output windows and their Meter Views) are always arranged:

L C R Ls Rs LFE

*For a complete explanation of Pro Tools metering, see “5.1 Tracks, Formats, Mapping and Metering” on page 435.*

**To use the SurroundScope Metering Plug-In:**

- On a multichannel Master Fader, click an Insert button and select the multichannel Meter plug-in.

SurroundScope has no adjustable parameters, but displays output levels in both a 360° Grid, and in traditional LED meters.

*Refer to the Digidesign Plug-Ins Guide, for details on SurroundScope.*
Part VIII: Synchronization
Chapter 34: Synchronization Concepts

Since time code and synchronization are complex topics, this section is designed to give you a basic understanding of synchronization as it relates to Pro Tools.

If you are using a device that sends or receives time code, such as a video tape recorder, refer to that device’s documentation for information on how it generates or receives time code and how to configure its options.

Aspects of Synchronization

Synchronization in a digital audio workstation has two concepts that need to be independently considered:

- “Where are we?” This is called the positional reference.
- “How fast are we going?” This is called the clock reference.

To synchronize Pro Tools to another device (such as a tape machine or VTR) accurately over an extended period of time, Pro Tools needs to know where the device is and at what speed it’s running. Some peripherals can provide only one of these references; for example, a black burst generator provides only a clock reference. Some peripherals, like Digidesign’s SYNC I/O, can provide both.

Synchronizing Pro Tools

Pro Tools requires a clock reference, in addition to time code, to maintain synchronization over time (for example, when slaving to another device).

You can resolve Pro Tools to an external clock reference without locking it to a positional reference. For example, you can use any HD-series audio interface (96 I/O or 192 I/O) that provides external clock inputs, to resolve the Pro Tools
sample clock to house sync, without synchronizing Pro Tools to external time code. You should do this if you need all your work in Pro Tools to match the speed of other machines in your facility.

In the following example, Pro Tools uses time code for positional information, and a clock reference to maintain synchronization. Pro Tools is slaved, through the SYNC I/O, to a video tape recorder, with both machines referenced to the same house word clock or house video reference source.

**To slave Pro Tools to a video tape recorder:**

1. When you start the video tape, time code (LTC or VITC) is read off the tape and routed to the SYNC I/O.

2. The SYNC I/O reads the time code position and continuously forwards the positional information down the SYNC I/O serial connection to the Pro Tools card. The SYNC I/O sends word clock (1x) signal to the Pro Tools audio interface’s Word Clock In.

3. Pro Tools takes the first time code address it receives, and calculates the sample location in the session that corresponds to the address. Though you can work with Pro Tools using any standard time code format, it calculates internally in sample numbers. This means that Pro Tools translates a time code frame address to an exact sample number.

4. Assuming that the time code address corresponds to a sample number that is within the Pro Tools session, Pro Tools converts the time code address to a sample number within the session, and begins playing from that point. The point from which playback starts is the trigger point. The clock reference is used by both machines to keep them running at the same speed.

5. At this point, if the video tape is stopped, rewound, and started again, the entire process is repeated, based upon a newly calculated trigger point.

**About Positional References**

Time code is timing information in the form of a data stream that can be recorded on magnetic tape as an audio or video signal. Time code can be used as a positional reference, to synchronize the playback and recording of your Pro Tools system with another machine’s time code signal, such as an analog multitrack tape machine or a video tape recorder (VTR).

**SMPTE and ISO/EBU Time Code**

The “Where are we?” question refers to relative position. To describe position, many professional audio, video, and multimedia devices and programs use SMPTE (Society of Motion Picture & Television Engineers) time code. In Europe, a standard called ISO (International Standards Organization) time code, formerly called EBU (European Broadcasters Union) time code, is generally used. These time code types are almost exactly the same in terms of how they are represented electronically. However, ISO/EBU time code works at a fixed rate of 25 fps (frames per second) and SMPTE includes provisions for several different frame rates. For the purposes of explanation, this chapter will generally refer to frame-measured timing information as “SMPTE time code.” This description should be understood to include ISO/EBU and SMPTE time code.

**SMPTE Time Code Methods**

There are two basic techniques used to record SMPTE time code onto magnetic tape: LTC (Linear Time Code) and VITC (Vertical Interval Time Code). LTC is recorded or generated on an audio channel or a dedicated time code track of the au-
dio or video device. VITC is recorded within the video signal in the video “blanking area” of each video frame. VITC cannot be recorded on audio tracks, so it has no application when working with audio tape recorders, but it does offer powerful features for post production professionals who work with video.

There is also a non-SMPTE form of time code called MIDI Time Code (MTC) that some devices use to send timing information.

**SMPTE Time Code Units**

Time code describes locations in terms of hours, minutes, seconds, frames, and subframes (1/100th of a frame). The frame is used as a unit of time measurement due to SMPTE time code’s origin in film and video applications. Depending on the SMPTE frame rate, one frame is equal to 1/24th, 1/25th, 1/29.97th, or 1/30th of a second. For example, a video tape time code reading of “01:12:27:15” would tell us that we were at a position of one hour, twelve minutes, twenty-seven seconds, and fifteen frames. However, this time address alone does not tell us frame rate information.

Because SMPTE stores an absolute time reference on the tape in the form of time code, any location on that tape can be precisely located by devices that read time code. Once the time code has been recorded or *striped* on a tape, it provides a permanent time reference that allows Pro Tools to link the playback of an event to an exact tape location. For example, with time code synchronization, a gun shot sound effect can be played at the precise instant that the gun’s flash appears on-screen.

**LTC (Linear Time Code)**

LTC is time code that is recorded and played back, or generated, in the form of an analog audio signal. LTC is supported by many audio and video tape recorders.

**LTC Speed Usage**

LTC can be read at high tape shuttle speeds, allowing a machine’s time code reader to communicate with synchronizers at rewind or fast forward speeds exceeding 50 times playback speed (provided the tape recorder is able to reproduce the time code at this speed). However, LTC cannot be read at very slow shuttle speeds (such as when you are “crawling” the tape frame by frame) or when the machine is paused. With LTC, the VTR must be running (usually at a minimum speed of about 1/10th normal playback speed) in order to capture a SMPTE time address.

**VITC (Vertical Interval Time Code)**

VITC is a type of time code that is recorded and played as an invisible part of a video signal. VITC is commonly used in professional video editing and audio-for-picture applications. Because VITC is recorded as part of each video frame, it must be recorded at the same time as the video signal—it cannot be added later as LTC can. Since VITC cannot be recorded on audio tracks, it is never used to synchronize audio-only recorders. Instead, LTC is most often used in audio-only applications.

**VITC Speed Usage**

VITC’s ability to be read when moving a VTR transport at slow speeds or when the VTR is paused makes it more useful in audio post production environments than LTC.
When VITC is used, Pro Tools can capture the current SMPTE time from the VTR when it is paused or in “crawl” mode. However, if you are using additional external transport synchronizers in your setup, most synchronizers cannot read VITC at speeds exceeding approximately 10 times playback speed, preventing slaved machines from maintaining synchronization during rewind and fast forward.

**LTC/VITC Auto-Switching**

Many synchronizers and devices support automatic switching between LTC and VITC, depending on the speed, to get the best of both worlds. For example, VITC might be used when a VTR is paused, or crawling frame-by-frame, while the synchronizer might automatically switch to LTC when fast-forwarding.

**Bi-Phase/Tach**

This electronic pulse stream is used by film mag recorders, film editing stations, and film projectors. You can use this format to synchronize Pro Tools if you have a SYNC I/O. Unlike time code, Bi-Phase/Tach doesn’t actually contain absolute location information. It simply supplies speed (based upon the frequency of the pulses) and direction, and therefore, relative position. Since the SYNC I/O can “count” both the speed and direction of the stream of pulses, it can use a Bi-Phase/Tach source to deduce positional information from a starting “address point.” The difference between Bi-Phase and Tach formats is that Bi-Phase encodes rate and direction on a pair of signals using a format called phase-quadrature, while Tach encodes rate on one signal and direction on the other. For more information on Bi-Phase/Tach, see the SYNC I/O Guide.

---

**SMPTE Frame Formats**

Six different formats of SMPTE time code exist, and Pro Tools can synchronize to any format with a compatible synchronization peripheral. The supported SMPTE frame rates are:

- 30 fps (also called 30 Non-Drop)
- 30 fps Drop frame
- 29.97 fps (also called 29.97 Non-Drop)
- 29.97 fps Drop frame
- 25 fps (also called ISO or EBU)
- 24 fps

When you work with NTSC video (the standard in North America), you will generally work with the NTSC color video standard: either 29.97 fps Non-Drop or 29.97 fps Drop frame. If you are working with PAL, your frame rate is 25 fps.

**30 fps Frame Format**

This is the original SMPTE format developed for monochrome (black & white) video, and is commonly used in audio-only applications. This format is often referred to as 30 Non-Drop frame format.

**30 fps Drop Frame Format**

This format is used for sound recordings done for film-originated programs that are destined for NTSC broadcast.

**29.97 Non-Drop Frame Format**

This format is used with NTSC color video. It runs at a rate of 29.97 fps.
29.97 Drop Frame Format

NTSC color video has an actual frame rate of 29.97 fps, so an hour’s worth of frames (108,000) running at 29.97 fps Non-Drop will take slightly longer than one hour of real time to play. This makes calculating the actual length of a program difficult when using 29.97 Non-Drop time code. A program that spans one hour of 29.97 Non-Drop time code addresses (for example, from 1:00:00:00 to 2:00:00:00) is actually 60 minutes, 3 seconds and 18 frames long.

To make working with 29.97 time code easier for broadcasters, the SMPTE committee created 29.97 Drop Frame time code, which runs at exactly the same speed as 29.97 Non-Drop (non-drop frame) time code, but compensates for the slower speed by “dropping” (omitting) two frames at the top of each minute, with the exception of every 10th minute. For this reason, the time code address of 1:01:00:00 does not exist in drop frame code because it has been skipped.

Note that even though time code addresses are skipped in drop frame format, actual frames of video material are not dropped.

At the end of a program that spans precisely one hour of drop frame time code (for example, 1:00:00:00 to 2:00:00:00), exactly one hour of real time has elapsed.

Although it sounds complicated, drop frame time code allows broadcasters to rely on time code values when calculating the true length of programs, facilitating accurate program scheduling.

25 fps Frame Format

This format is used with the European PAL video standard, which runs at a 25 fps frame rate. This format is also called the EBU (European Broadcast Union) format because it’s used by broadcasters throughout most of Europe.

24 fps Frame Format

This format is used exclusively for film applications. Film is typically photographed and projected at a 24 fps frame rate, so this SMPTE format is useful when one time code frame should equal one film frame.

Working with Film-Originated Material

When you do post production work in Pro Tools, you will usually work with video material. However, it is possible that the video you are working on was shot on film.

Film footage and production sound go through separate conversion processes before they reach video, and the audio post production stage. The film is transferred to video using a process called Telecine, using a method called 3:2 Pulldown. Audio can also be pulled down during the transfer, or you might end up working with audio that has not been adjusted (production sound).

Typically, during the Telecine process, a master digital video tape is created, along with a work copy on 3/4” analog video tape for the picture editor to use. At the same time, a new audio master may be created by slowing down, or “pulling down” by 0.1%, the production sound to compensate for the change in speed from film to NTSC video.
Guide Tracks

In the Video editing process, the audio track produced by the video editor (the “guide track”) is rough and needs to be enhanced and improved by the audio engineer. For this reason, the audio engineer will need to re-assemble the original sound elements in a process known as conforming.

3:2 Pulldown

A film clip that lasts 1000 seconds consists of 24,000 film frames (pictures). If you want to transfer that film to 1000 seconds worth of NTSC color video, you have to “fit” 24,000 film frames into 29,970.02997 video frames.

If we use the black and white NTSC video standard (30 fps) instead of 29.97 fps, the process of converting film frames to video frames is greatly simplified. Now instead of any fractional frames, we have 24,000 film frames going into 30,000 video frames (60,000 video fields). In the Telecine process (for NTSC color video), each odd film frame is copied to two video fields, and each even film frame is copied to three video fields, creating what is called a 3:2 Pulldown. The speed of the film is also “pulled down” to 23.976 fps in order to accommodate the slower speed of NTSC color video compared to NTSC black and white video (29.97 fps compared to 30 fps).

Film Speed Differs from NTSC Video Speed

The new NTSC Telecine master tapes will always run at 29.97 fps during post production, so the original production sound rolls (at 30 fps) will be too fast, and therefore out of sync with the video. Some adjustment of this audio may be required.

When spotting audio to video that was transferred from film to NTSC video, there are two important terms to keep in mind: film speed and video speed.

Film Speed Film speed refers to audio that was recorded and plays back in synchronization with the original film material. This audio often comes from production reels recorded on a Nagra® recorder or a field DAT recorder, and is usually striped with 30 Non-Drop time code. Film must be pulled down .1% when being transferred to 29.97 NTSC. Film must be pulled up by 4.16667% when film is being transferred to PAL.
**Video Speed** Video speed refers to audio that is running at the NTSC color standard of 29.97 fps. Video speed is 0.1% slower than film speed, so audio that is still at film speed will be out of sync with the video. Usually, you will be working at video speed, though Digidesign and Avid do provide several options for film speed (24 fps) support.

**Pull Up and Pull Down**

*Pull Up* and *Pull Down* are terms used to refer to the deliberate recalibration of the audio sample rate clock (speed, or musical pitch) in order to compensate for a speed change. Pro Tools can be used to pull down or pull up audio for use with NTSC video. Currently, Pro Tools does not support 4% pulls required for NTSC/PAL conversions.

Pull Down allows you to play back film-originated material at video speed (–0.1%). Pull Up allows you to play back video speed material at film speed (+0.1%).

Using Pro Tools in Pull Up or Pull Down modes requires a SYNC I/O, or a third party synchronizer.

**When to Pull Up or Pull Down**

There are many ways to get audio into Pro Tools for post production. Consider your source audio and your final destination format carefully. In some cases, audio will already be pulled down for you. In other cases, audio will have to be temporarily pulled down. In still other cases, you may choose to pull down your audio source, like a DAT deck, then use a a D-A-D (digital-to-analog-to-digital) process, or Digidesign’s 192 I/O Sample Rate Conversion option, to record the audio into Pro Tools at the proper sample rate. Or you may choose only to pull Pro Tools up or down on delivery of the audio.

Refer to the online document *FilmSync.pdf* installed with your Pro Tools documentation, for detailed Pull Up and Pull Down workflow information.

**Final Audio Destination: Film**

If your final destination is film, your source audio is at film speed, and your goal is to edit and mix audio in Pro Tools and then lay back to a device that runs at film speed (such as mag or time code DAT), you can temporarily pull down the audio in Pro Tools for NTSC video work, then return the audio back to film speed when you’re finished (by disengaging pull down).

For example, film speed audio from a field audio recorder that is referenced to 30 fps time code is recorded into your Pro Tools system at a sample rate of 44.1 or 48 kHz. Keeping in mind that film speed is faster than video speed, select 30 fps in your Session Setup window in Pro Tools, and record in your audio online and referenced to the time code on the field audio recorder.

Once all the audio has been recorded, and you are locked to a video work print (at video speed), enable Pull Down. If you are using a Digidesign SYNC I/O, select Pull Down in the Session Setup window. If your synchronizer is not a Digidesign product, select Pull Down on the front of your synchronizer, then enable Pull Down in the Pro Tools Session Setup window. At this point, it is highly recommended that you verify whether the video you’re working with is striped with 29.97 Drop Frame or Non-Drop Frame time code. While in Pull Down mode, you can work with your reference video and everything will remain synchronized and run at the proper speed (assuming your system is completely resolved).
Once you are ready to lay back your completed project to an audio device running at film speed, deselect Pull Down in the Session Setup window, and from your synchronizer if it is not a SYNC I/O. Then change your time code frame rate in the Pro Tools session back to 30 fps. Once Pull Down has been deselected, the audio played back from Pro Tools will synchronize perfectly with the edited film.

Alternatively, you can pull down the source audio deck while recording audio into Pro Tools, work at 29.97 fps with no Pull-Down selected in Pro Tools, and then switch to 30 Non-Drop frame format, and select Pull Up during the delivery stage. You will have to perform a sample rate conversion on the audio either digitally or by using an analog stage (D-A-D).

Only the inputs on the Digital I/O of the card (on the 192 I/O) feature real-time sample rate conversion.

💡 You will also need to select the Sample Rate Pull Up/Down option in the Session Setup window.

Final Audio Destination: Video

If you are working with video that was transferred from film, your audio source is at film speed, and the final layback destination is NTSC video (or television), and you would like to provide a digital transfer to your clients, you will need to alter the above recipe slightly. Keep in mind that when you are working in Pull Down mode, your active sample rate is 44.056 kHz (if the audio was recorded at 44.1 kHz) or 47.952 kHz (if the audio was recorded at 48 kHz).

Pull Down the Audio Source

Some professional DAT machines will let you pull down the sample rate to 44.056 kHz (and 47.952 kHz). You can record this audio into Pro Tools using a D-A-D (digital-to-analog-to-digital) process, or Digidesign’s 192 I/O Sample Rate Conversion option. Then your audio will be at the correct speed for the remainder of the project, since the final destination is video, and no Pull Down or Pull Up is necessary.

Pull Up Pro Tools While Recording

If you cannot pull down your source, you can accomplish the same thing by Pulling Up Pro Tools, and setting your SMPTE frame format to 30 fps, before recording in the production sound. First select 30 fps as the frame format in the Session Setup window. Then select Pull Up in the Session Setup window (and on your synchronizer if it isn’t a SYNC I/O) before you record in the production audio. In this case, while the production audio is running at 44.1 or 48 kHz, Pro Tools is running (and recording) at a rate of 44.144 or 48.048 kHz. After all the production audio has been recorded into Pro Tools, deselect Pull Up in the Session Setup window, and on your hardware synchronizer if it is not a SYNC I/O. After you deselect Pull Up, the recorded audio will play back 0.1% slower, synchronized with the video, while achieving a true playback sample rate of 44.1 or 48 kHz. Note that this process is designed for a final destination of video; to bring this audio back up to film speed you would have to pull up Pro Tools and record to a destination that is not Pulled Up.

Note on Sample Rate Conversion

In many cases, you have to perform a sample rate conversion at some point, either digitally, or by recording in audio using an analog stage (D-A-D). The only situation where sample rate
conversion never has to be performed is when you are working with film speed audio and your final destination format is film. Then you can simply pull down Pro Tools while you work with the video, then deselect Pull Down to set the audio back to film speed.

**Using Digital Input**

If you are working with Pull Up or Pull Down, do not synchronize to any digital inputs that are used as audio sources in Pro Tools. This would override the use of the SYNC I/O as the clock reference. Any equipment providing digital audio sources to Pro Tools should be synchronized externally.

The right half of the back panels of 192 I/O and the 96 I/O feature a set of non-removable connectors that are mounted permanently to the enclosure ([Encl.]). These connectors cannot be used for Sample Rate Conversion. Only the inputs on the Digital I/O card on the 192 I/O feature real-time sample rate conversion.

💡 You will also need to select the Sample Rate Pull Up/Down option in the Session Setup window.
Chapter 35: Time Code Synchronization

Synchronization allows one system to output time code and the other device to follow that time code. With synchronization, you can play all devices in synchronization. Pro Tools is synchronized to other devices using SMPTE time code or MIDI Time Code. For a discussion of different SMPTE formats, and other concepts related to time code, refer to Chapter 34, “Synchronization Concepts.”

Pro Tools Synchronization Options

You have four choices for synchronizing Pro Tools to an external source, plus options for using Pro Tools as the master device.

SMPTE Trigger Only
(Pro Tools LE Only)

This solution is useful for short projects if both systems are extremely close in speed, but even the best systems will rarely stay synchronized for longer than a couple of minutes.

SMPTE Trigger with Digidesign SYNC I/O
(TDM Systems Only)

This solution uses the SYNC I/O, and house distributed video reference, or house distributed word clock reference, to control playback and recording speed in Pro Tools. Accurate long-term synchronization can be achieved when all transports within the system are resolved to a common synchronization source.

SMPTE Trigger with an External Peripheral Slaved to Time Code

SMPTE Trigger can be used with the optional SYNC I/O, to resolve Pro Tools recording and playback speed while slaving to LTC. This enables long-term, accurate synchronization by resolving to any variations in incoming time code.
SMPTE Resolved with SYNC I/O  
(TDM Systems Only)

You can use the optional SYNC I/O, or equivalent third-party device, to resolve Pro Tools recording and playback speed with any of the following clock reference sources while slaving Pro Tools to time code:

- Video source
- House video reference
- VITC
- 1x Word Clock
- AES/EBU “null” clock
- Pilot Tone
- Bi-Phase

This enables long-term, high-fidelity synchronization when all transports within the system are resolved to this common synchronization source, or by resolving to any variations in incoming time code while slaving to time code.

Other SYNC I/O Synchronization Options

By adding SYNC I/O to your Pro Tools TDM system, you can use Pro Tools as the master device in your synchronization setup. All other devices are then slaved to Pro Tools.

You can use Pro Tools in conjunction with SYNC I/O to generate SMPTE LTC, MIDI Time Code, or MMC messages. When SYNC I/O is reading incoming SMPTE time code from the SMPTE In connector, it regenerates the time code through the LTC or MTC output connector. This signal can be passed along to other slave devices.

For instructions on connecting an external synchronization peripheral to your Pro Tools system, refer to the Getting Started Guide. If you are using SYNC I/O, refer to the SYNC I/O Guide.

Session Setup Window

The Session Setup window allows you to configure various time code-related parameters on your system. The window also includes various display-only areas.

Sample Rate

This display-only area indicates the sample rate for the current session.

Bit Depth

This display-only area indicates the bit depth for the current session.
Clock Source

This allows you to configure your hardware for “Clock Source” by selecting the appropriate clock source. You can choose from any digital source, or external word clock, or other rate clock sources.

Audio will be audible while you are making changes to Clock Source in the Session Setup window.

Clock Source on HD-Series

Internal Sync Mode In Internal Sync mode, your system will reference your Digidesign card or peripheral’s quartz crystal oscillator and play back at the session’s sample rate.

Changes made to Clock Source in the Session Setup window will be reflected in the Hardware Setup window and vise versa. For more information, see “Hardware Setup Window” on page 477.

External Clock Sources: Depending on your HD-series audio interface, external Clock Source options can include AES/EBU [Encl.], S/PDIF, Optical [Encl.], AES/EBU 1-8, TDIF, ADAT, and Word Clock (optional word clock rates are available at higher frequencies). External sources can be 1x any sample rate or the “base” rate. Base rate equals 44.1 kHz for 88.2 and 174.4 kHz; 48 kHz for 96 and 192 kHz. If an external source is chosen, and no valid sync clock is detected at the External Clock In, the I/O will return to Internal Sync mode.

Once a SYNC I/O has been declared as the synchronization device in the Synchronization tab of the Peripherals dialog, the SYNC I/O will automatically start producing a 1X word clock at the session’s sample rate. To resolve your HD I/Os to this word clock signal, select Word Clock as the Clock Source on your primary 96 I/O or 192 I/O.

For more information on external clock sources, see the HD SYNC Guide.

Clock Source (Sync Mode) on Other Systems

On MIX-series, Pro Tools|24, and Digi 001 systems, Clock Source is labeled Sync Mode in the Session Setup window.

Audio Format

This display-only area indicates the file format for files recorded in the session.

Session Start

This allows you to specify a SMPTE start frame location for your session. See “Setting a SMPTE Session Start Time (Start Frame)” on page 479.

Current Time

This displays incoming time code.

Frame Rate

This allows you to set the SMPTE frame rate for the current session.

Generate Time Code

This allows Pro Tools to output time code using SYNC I/O (communicating directly through a serial port). For more information, see “Generating Time Code” on page 481.

Using Peripheral This option outputs time code from the Device type selected in the Synchronization page of the Peripherals dialog.

MTC to Port This option outputs MIDI Time Code to the MIDI destination selected in the pop-up menu.
**Time Code Freewheel**

This allows Pro Tools to “freewheel,” or continue playback if time code is interrupted or corrupted. Use this to protect against errors that can occur if your SMPTE time code source has “drop outs” or temporary lost signals.

**Frames** This option allows you to freewheel from 1 to 120 frames. This value defaults to 8 frames, which is the recommended setting for most applications.

**Jam Sync** This option allows Pro Tools to trigger synchronization to incoming time code, and continue to play back even if time code input is completely interrupted. It can be useful if time code is damaged, or has been accidentally erased from your source tape.

**Sample Rate Pull Up/Down**

When Pro Tools is used in conjunction with SYNC I/O, or a third-party synchronizer that supports Pull Down sample rates, this option allows you to “pull up” or “pull down” the current sample rate. This is used with film-originated material when working with NTSC-standard SMPTE frame rates only. For a full explanation of film-originated scenarios, see “Working with Film-Originated Material” on page 467.

**Pull Up** This speeds up the current sample rate to 100.1%. A 48 kHz sample rate is sped up to 48.048 kHz. A 44.1 kHz sample rate is sped up to 44.144 kHz.

**Pull Down** This slows down the current sample rate to 99.9%. A 48 kHz sample rate is slowed to 47.952 kHz. A 44.1 kHz sample rate is slowed to 44.056 kHz.

For specific information about pull up or pull down for higher sample rates, see the SYNC I/O Guide.

**Sync Offset**

This field allows you to set a “trigger offset” for incoming MIDI Time Code (anywhere from –100000 to +100000 samples). This allows you to create a permanent offset to fine-tune the point at which Pro Tools synchronizes relative to incoming time code. For example, a value of –50 makes an event in Pro Tools occur –50 samples before the same event in the incoming MIDI Time Code. Use this to compensate for timing differences between various SMPTE-to-MIDI Time Code converters or analog-to-digital/digital-to-analog converters.

**Sync Offset Voice Usage**

For TDM systems, recording with a Sync Offset requires two voices for each record-enabled track. In addition, to simultaneously record on 32 tracks with a Sync Offset on a Pro Tools MIX-series system (which allocates voices to either of two DSP engines, 1–32 or 33–64), the tracks must be evenly distributed between the two DSPs, (for instance, tracks 1–16 assigned to voices 1–16 and tracks 17–32 assigned to voices 33–48).

*If you use Sync Offset concurrently with other functions (such as QuickPunch or Pre- or Post-roll) that also require two voices for each record-enabled track at the same time, you will still only need two voices per record-enabled track.*

---

*Pro Tools Reference Guide*
Variable Speed Override, Clock Reference, and SYNC I/O Reference

Variable Speed Override (VSO) requires a SYNC I/O. When SYNC I/O is connected to Pro Tools, the Session Setup window expands to display additional controls for VSO, clock, and Positional Reference (see Figure 32).

Refer to the SYNC I/O Guide for instructions on using VSO to vari-speed Pro Tools playback.

Hardware Setup Window

Clock Source

In order to record from external digital sources, Pro Tools|HD and the 192 I/O must be configured for the appropriate digital clock format.

To choose a Clock Source:

1. Launch Pro Tools.
2. Choose Setups > Hardware Setup in Pro Tools.
3. Click the Clock Source pop-up menu and select a sync mode.
4. Click OK to close the Hardware Setup dialog when you have finished.

Changes made to Clock Source in the Hardware Setup window will be reflected in the Session Setup window and vice versa. For more information, see “Session Setup Window” on page 474.

Ext. Clock Output

Pro Tools can be used as the master device in your synchronization setup, where all other devices are then slaved to Pro Tools.

To set Ext. Clock Output:

1. Launch Pro Tools.
2. Choose Setups > Hardware Setup in Pro Tools.
3. Click the Ext. Clock Output pop-up menu and select the appropriate clock source to feed to devices attached to your I/O.
4. Click OK to close the Hardware Setup dialog when you have finished.

If you choose a clock source on another HD clock source other than the Loop Master, Pro Tools will automatically designate the new interface the clock master, switch to the digital sync source, and set all other HD I/Os to slave. If you are using a 176.4 kHz or 192 kHz sample rate, the 192 I/O must be the master.

If the Legacy Port is enabled (as opposed to the Expansion Port) then the Ext. Clock Output automatically switches to Slave256x. To reset the Ext. Clock Output, the Port Settings button must be set back to Expansion and the Legacy I/O must be set to No Interface. (To set a Legacy I/O to No Interface, select its name in the Peripherals list, then click on No Interface in the Interface pop-up menu.)
Preparing to Work with SMPTE

The first step when preparing to work with SMPTE is to choose an appropriate SMPTE frame rate.

SMPTE Formats

Pro Tools supports all standard SMPTE frame rates. For a full explanation of these SMPTE frame rates, see “SMPTE Frame Formats” on page 466.

Determining SMPTE Frame Rate

Of course, it's always best to determine the SMPTE frame rate through labeling procedures or communication, but this is not always possible.

If you do not know the frame rate of a tape, SYNC I/O shows incoming frame rate on its front panel LED indicators. These devices cannot distinguish between 29.97 fps and 30 fps, but they can determine whether the incoming frame rate is drop frame or non-drop frame.

With NTSC video, the frame rate is most likely 29.97 fps Drop or 29.97 fps Non-Drop.

Configuring Pro Tools for SMPTE

MachineControl is supported on TDM systems only.

Synchronization and MachineControl™ system parameters are set in the Pro Tools Peripherals dialog box. These parameters, such as synchronization peripheral setups, MIDI Machine Control, MachineControl, and machine pre-roll, are system settings, and remain constant regardless of the particular session you are working on. Configure these settings before opening a session, if you want them to affect that session.

Other parameters, which are configured in the Session Setup window, such as the session frame rate, the session start frame, and time display format, are session-specific parameters. These parameters can only be configured when a session is open.

Selecting a SMPTE Format

To choose a SMPTE format:

1. From a Pro Tools session, choose Windows > Show Session Setup.

2. In the pop-up Frame Rate menu, select the SMPTE frame format appropriate to your session.

3. Enter the Time Code Freewheel frames (if any) in the designated box. See “Time Code Freewheel” on page 476 for more information.
Setting a SMPTE Session Start Time (Start Frame)

The Session Setup window also allows you to set a SMPTE Start Frame for your session. Video work tapes are rarely striped beginning at a SMPTE frame address of 00:00:00:00. You can quickly enter a start time for your session based on an appropriate frame number from your project tape. The Pro Tools SMPTE-related functions (such as Spot mode) will then use this value as their reference for the session’s start point.

Start Time When Striping Tape

If you are generating time code, it is a good practice to stripe your time code beginning at 01:00:00:00 (subtracting time for initial black, bars and tone, logos, and so on). This prevents problems that can occur with some synchronizers when the striped time code crosses from 23:59:59:29 to 00:00:00:00 (commonly referred to as the “midnight” boundary).

To set a SMPTE Start Time for your session:

2. Enable playback of your SMPTE time code source. Any SMPTE-to-MTC converter device you are using should indicate that it is properly receiving time code through its indicators. If Pro Tools is receiving MTC (or proprietary synchronization code via the SYNC I/O), the Current Time counter will update its display (in bold numbers) to match the incoming code.

   Current Time displayed in Session Setup window

   This display is useful for troubleshooting time code problems, and it should update regardless of the current Pro Tools Session Start time.

3. Enter a SMPTE frame number in the Session Start field.
   - or -

   To capture an incoming SMPTE address, press the Equal key. You can then edit the captured address. The session uses the frame number you enter as its SMPTE start frame when online.

4. If there are existing regions on the tracks and you are changing the original SMPTE start frame to a later time (from 00:00:00:00 to 01:00:00:00, for example), all existing regions on tracks will remain in their relative positions, but will start later by the time value added to the start frame.

   If you are changing the session start time in an open session in which tracks already exists, a warning dialog appears after Session Setup window. Choose from one of two options:
   - Click Maintain Time Code to place the additional session time at the start of the session, and keep existing regions in their original time code locations.
   - or -
   - Click Maintain Relative Position to place the additional session time at the start of the session, and maintain the relative position of existing regions to the new start frame. For example, if you change the session start frame from 01:00:00:00 to 00:59:00:00, Pro Tools adds one minute of session time to accommodate the new start frame, and moves all existing regions earlier in time to maintain their relative position to the start frame.
Displaying Time in SMPTE Frames  
(TDM Systems Only)  

In Pro Tools, you can set the Main Time Scale indicator to Time Code (SMPTE). Though Pro Tools will still synchronize to incoming SMPTE time code if the Time Scale is displayed in Bars:Beats, Minutes:Seconds, or Feet:Framess, it is usually more useful to use SMPTE time code as your reference.

To set the Main Time Scale to SMPTE Time Code:

- Choose Display > Time Code.
- or –
- Click the Main Time Scale selector in the Edit window, and select Time Code.

Pro Tools will display time code values in the currently selected SMPTE frame rate.

Sub Time Scale Display

You can also display a Sub Time Scale. For example, if the Main Time Scale is set to Time Code, and you want to compare SMPTE time to “wall clock,” when you are using 29.97 Non-Drop frame rate, you can select Min:Secs as the Sub Time Scale.

Configuring Pull Up and Pull Down  
Using SYNC I/O

If you have a Digidesign SYNC I/O and are working with material that has been pulled up or down, you will need to reconfigure your synchronization settings:

To work with a sample rate that was pulled up or down:

1. Choose Setups > Peripherals and click Synchronization.
2. Make sure you have enabled your peripheral. For more information on enabling SYNC I/O, see the SYNC I/O Guide.

3. Choose the frame rate for your session from the pop-up menu. This frame rate might be 30 fps (Drop or Non-Drop) or 29.97 fps (Drop or Non-Drop) depending on the requirements of your material. See “When to Pull Up or Pull Down” on page 469 for more information.

4. In the Sample Rate Pull Up and Pull Down field, enable the Pull Up or Pull Down option as appropriate.

This procedure will also work with a third-party synchronizer that supports Pull Up/Pull Down, with the following exceptions:

- You have to enable Pull Up or Pull Down in the Session Setup window and on the front of your synchronizer.
**Putting Pro Tools Online**

To trigger playback or recording from an external source, Pro Tools must be placed online. This tells Pro Tools to listen for incoming time code.

**To put Pro Tools online:**
- Choose Operations > Online.

  – or –

- Click the Online button at the far left of the Transport.

The Online button blinks and Pro Tools waits for a SMPTE frame to trigger playback. When time code is received, playback begins and the Online button becomes highlighted. The Location Indicators in the upper right of the Edit window, and the Current Time field in the Session Setup window, display the incoming time-code.

**To take Pro Tools offline:**
- Deselect Operations > Online.

  – or –

- Deselect the Online button in the Transport window.

**Recording Online**

The Operation page of the Preferences dialog (Setups > Preferences) contains two options that affect how Pro Tools initiates recording when online.

- **Record Online At Insertion/Selection** Makes online recording begin wherever you have placed the insertion point in a track. Recording then continues until Pro Tools stops receiving time code. If you make a selection in a track, Pro Tools will record online only for the length of the selection.

- **Record Online at Time Code (or ADAT) Lock** Makes online recording begin as soon as Pro Tools receives and locks to time code or ADAT sync. In this case, you don’t need to make an insertion or selection in a track to designate a start point.

**Generating Time Code**

Using SYNC I/O, Pro Tools can generate SMPTE or MIDI Time Code (MTC). You can then make Pro Tools a master synchronization source with other devices slaved to it.

- **SYNC I/O cannot generate 24 fps time code while locked to video**

  The SYNC I/O cannot generate 24 fps time code while it is locked to a video clock signal. If you set Pro Tools to generate 24 fps time code while the SYNC I/O is locked to a video clock signal, the SYNC I/O will actually generate at the NTSC color standard 29.97 Non-Drop Frame rate. Pro Tools can generate time code at non-NTSC frame rates if you use the internal clock on the SYNC I/O as a synchronization source.
To generate time code using SYNC I/O:

1. Connect the out of the SYNC I/O to the SMPTE in connector on the devices you are slaving. If you are slaving a device that recognizes MTC, connect the MTC OUT connector of the SYNC I/O to the MIDI IN connector of the slaved device (MIDI Interface or other).

2. Make sure your SYNC I/O is powered on.

3. Launch Pro Tools, and make sure you have already enabled the SYNC I/O in the Synchronization page of the Peripherals dialog. See the SYNC I/O Guide for more information.

4. Choose Windows > Show Session Setup, and choose the appropriate frame rate.

5. In the Generate Time Code field, select the “Using SYNC I/O” option.

6. Click on the Clock Reference pop-up menu to show SYNC I/O modes. Select the desired clock reference. (If the selected clock reference is not available, Pro Tools will switch to Internal mode and post a dialog box alerting you that the clock source is unavailable or invalid. Not all clock choices are available at all sample rates. See “External Clock Sources:” on page 475.)

7. Confirm that your chosen parameters have been received by the SYNC I/O. If not, check your connections and the settings in the Peripherals > Synchronization and Session Setup windows.

8. Click the Online button on the Transport, then click Play. Pro Tools generates and outputs time code from the SYNC I/O.

---

Synchronizing a Sequencer to Pro Tools on the Macintosh

A common application for generating time code with Pro Tools is slaving an OMS-compatible sequencer to a Pro Tools session.

Setting the Clock Master

The exact synchronization setup your sequencer requires will vary depending on the software and your OMS setup, but Pro Tools must be the clock master. Since Pro Tools provides the audio sample clock for your system, synchronization errors will occur over time if Pro Tools is not designated as the master.

The following instructions describe the general procedure.

You can use Pro Tools MMC to synchronize with an OMS/MMC-compatible sequencer or an external MMC-compatible device such as an ADAT or DA-88. See “Controling External Devices Using MMC” on page 485.

To slave an OMS-compatible MIDI sequencer to Pro Tools:

- Make sure the OMS IAC Driver is installed in the OMS Folder inside your System Folder. If necessary, run the Pro Tools Installer to install OMS with the OMS IAC driver. Refer to the Getting Started Guide for details.
In OMS Setup:

1. Choose Edit > Preferences, and make sure the “Use Apple Serial DMA driver when available” option is not selected. Click OK.

Always make sure the Apple Serial DMA driver is not being used by OMS. It can prevent proper communication with MIDI devices. You must restart your computer any time you enable or disable the Apple Serial DMA driver.

2. Choose Setups > OMS MIDI Setup, and select the “Run MIDI in background” option.

3. Choose Studio > MIDI Cards & Interfaces, then click Update Setup. If you are using a serial MIDI interface, enable the appropriate port and click Search.

4. Confirm that the OMS IAC driver appears in the OMS Studio Setup window. If it does, save the document and make it your current setup.

5. In the OMS Studio Setup window, define an IAC Bus by double-clicking the IAC Driver icon, and typing IAC1, for example, in the first field (this provides a unique name for this particular IAC bus).

In the Sequencer application:

6. Enable IAC1 (the IAC bus you defined in OMS setup). Different sequencers operate in different ways, so refer to your sequencer’s documentation.

7. Set the sequencer to receive MIDI Time Code (MTC).

8. Set IAC1 as the device from which to receive synchronization information.

9. Select the SMPTE Format (frame rate) that matches Pro Tools (for example, 30 fps or 29.97 Non Drop fps).

10. Set the SMPTE start frame for your session.

11. Set your sequencer to wait for note input from the synchronization device.

12. Start playback in the sequencer. It should indicate that it is waiting for sync.

In Pro Tools:

13. Select Operations > Active in Background.


15. In the Session Setup window, choose an appropriate frame rate.

16. Select the SMPTE Start Frame to match the start frame in your sequencer. If the sequence starts at 00:01:00:00, you could set the Pro Tools Session to start earlier (for example, at 00:59:58:00) to allow some pre-roll.
17 Enable the MTC to Port option in the Output Time Code box. Select IAC1 as the MTC destination.

18 Click Play or press the Spacebar to start playback. Pro Tools will send MIDI Time Code to the sequencer via the IAC port and trigger synchronized playback. Click Stop in the Transport or press the Space bar again to stop playback.

Once synchronized playback is operating correctly, you can record new takes in Pro Tools while listening to MIDI playback from your sequencer. Follow the procedure described above for synchronized playback, then record new material in Pro Tools by following the recording procedures in this guide (“Recording from MIDI Devices” on page 149).

You should also be able to record new MIDI tracks while the sequencer is slaved to Pro Tools. See your sequencer documentation for details on recording while the sequencer is in an external synchronization mode.

---

**Synchronizing a Sequencer to Pro Tools in Windows**

> These instructions require the use of a physical MIDI port. While several “virtual” MIDI cable applications do exist for inter-application MIDI communication in Windows, such software devices have not been qualified to work with Pro Tools.

To synchronize Pro Tools to a Windows sequencer:

1. Make sure your MIDI interface is correctly installed and configured. You must do this before proceeding.

2. Choose one pair of input/output ports on your MIDI interface to use as your synchronization “loop” for application-to-application MIDI communication.

3. Connect a MIDI cable from that port’s output to the same port’s input (for example, port 1 out to port 1 in).

4. In Pro Tools, select the appropriate in and out ports when making your selections for MIDI source or destination ports.
   - If you are slaving your sequencer to Pro Tools, select the appropriate port in the Session Setup window’s MTC to Port pop-up menu.
   - If you are slaving Pro Tools to your sequencer, select the appropriate port in the Pro Tools Peripherals > Synchronization window.

5. In your sequencer, select the appropriate in and out ports for MTC source/destination.
Using MIDI Machine Control

Pro Tools provides the capability to transmit location information to external devices, and to control their transports, using MIDI Machine Control (MMC).

Controlling External Devices Using MMC

Any device that supports MMC (such as an Alesis ADAT or Tascam DA-88) can be controlled directly from within Pro Tools, with either the device or Pro Tools acting as clock master.

The external devices supported by Pro Tools implement “open loop” communications only. Because of this, while Pro Tools is the transport master, any direct operation of the receiving device’s transport will not be communicated back to Pro Tools. Instead, you can use the Transport pop-up to select the external device (MMC in the pop-up) and use the Pro Tools on-screen transport controls to drive the device.

Pro Tools does not support remote track arming of MMC-controlled external devices. You need to manually arm tracks for recording on the external device.

Macintosh

Pro Tools on the Macintosh uses OMS to facilitate MIDI Machine Control. In order to use MMC with Pro Tools you must configure your MMC device to “Receive” and “Send” MIDI Machine Control in OMS. For details, see “Using MMC to Synchronize an ADAT to Pro Tools on the Macintosh” on page 487.

Windows

Pro Tools in Windows uses your Multimedia Setup to determine which MIDI devices are available, and what their properties are. Refer to your device’s installation and usage documentation to properly configure the device.

Enabling MIDI Machine Control in Pro Tools

To enable MIDI Machine Control:

1. Choose Setups > Peripherals, then click Synchronization.

2. Select your synchronization peripheral from the Synchronization/Device pop-up. If you are using a MIDI interface, select “Generic MTC Reader.” If using SYNC I/O, set the Port to Digi-Serial.

3. Select the appropriate port for synchronization information. This is the port to which your synchronization peripheral is attached.
4 Click the Machine Control button at the top of the window to open this page of the Peripherals dialog.

5 In the MIDI Machine Control section, enable MMC.

6 Select your external device from the Send To pop-up. The list of available devices is determined by the OMS devices configured in your OMS Studio Setup (Macintosh), or by your Windows Multimedia Setup.

The port on which this information will be transmitted is set in the “ID” field. MMC commands contain an ID number to identify which machine should respond to the MMC command. There are 128 MMC ID numbers, from 0–127. The default of ID #127 is a special setting that broadcasts to all 128 MMC IDs. With this setting, any device on the specified port will respond to MMC commands.

7 Set a pre-roll time for your MMC device. Pre-roll is needed to provide Pro Tools with sufficient time to lock to the incoming time code. This value will vary depending on the external device. If the pre-roll time is insufficient, Pro Tools may not be ready to lock until after the current time code position has passed.

8 Click OK to close the Peripherals dialog. Pro Tools will now be able to control the selected device’s transport.

Operating the Pro Tools Transport with MMC

You use the Pro Tools Transport window as the remote controller for all your enabled devices (MMC units, ADAT, or a non-linear video deck). To do so, set the enabled devices to listen to the address you enter for MMC. The Transport window will then “drive” Pro Tools transport and any slaved devices.

You can also configure a “Pro Tools master,” which can “drive” other devices (as needed), and to which Pro Tools will chase (slaving Pro Tools).

To control external devices from the Pro Tools Transport Master:

Select either Pro Tools or MMC from the Transport pop-up in the Pro Tools Transport window. The selected item will act as Transport Master.

Choosing a Transport Master

When the Transport Master is set to Pro Tools, the playback position is governed by the on-screen cursor in Pro Tools.

When the Transport Master is set to MMC, the playback position is governed by the external device’s play position.

For more information, see “Recording from MIDI Devices” on page 149.
**Machine Transport Settings**

When using MMC, you can set the following options for machine transport behavior in the Operation page of the Preferences dialog.

**Machine Chases Memory Location** With this option enabled, navigating to a specific location in a session with a Memory Location causes a connected transport to chase to that location.

**Machine Follows Edit Insertion/Scrub** With this option enabled, navigating to a specific location in a session by moving the selection point or by scrubbing a track causes a connected transport to chase to that location.

**Remote Track Arming**

Digidesign's MachineControl™ option for Pro Tools allows you to remotely arm tracks on supported 9-pin (or V-LAN for transport only) decks. Without MachineControl, Pro Tools does not support remote track arming of external devices. MachineControl is a DAE Extension that allows Pro Tools to act as the master or slave to external Sony 9-pin (or V-LAN for transport only) machines, in addition to providing remote track arming from within Pro Tools. Contact your Digidesign Dealer for information about the MachineControl option.

**Setting Minimum Sync Delay**

Lock-up time delay is the amount of time your system’s devices need to achieve synchronization “lock.” This amount varies for each device. Pro Tools lock up delay is set by entering a value for Minimum Sync Delay in the Synchronization window of the Peripherals dialog. The minimum delay is 15 frames. Find the shortest possible lock-up time that your equipment can operate at consistently, and set this as the Minimum Sync Delay. On some machines, enabling the Use Serial time code setting will make machines lock up much faster.

**Configuring Minimum Sync Delay for External MMC Devices Locked to House Sync**

When controlling a house-synced device from Pro Tools via MMC, the device will first lock to the MMC location and then align the color framing. Within house sync code are 4 frames for ensuring color frame lock. If the minimum synchronization setup time is less than the time required to achieve both location and color frame lock, playback will begin before the device has aligned the color frames. In this scenario, you should set the Minimum Sync Delay to be more than the time required for color frame lock. This is not a problem with the SYNC I/O, which will drop out of lock until the color frame is locked.

**Using MMC to Synchronize an ADAT to Pro Tools on the Macintosh**

The following section presents an example of how you can use MMC to slave an ADAT to Pro Tools Mix-series systems on a Macintosh using OMS.

**Setup Description**

**Hardware:** Pro Tools system (Macintosh), Opcode Studio 64X MIDI Interface, JL Cooper DataSync II, Alesis ADAT.

**Software:** Pro Tools, OMS

**Cable Connections:** The Studio 64X’s Mac/Serial port is connected to one of the CPU serial ports (Modem or Printer). MIDI In and MIDI OUT connections are made between the appropriate
ports of the 64X and the MIDI IN and MIDI OUT ports of the JL Cooper DataMaster. Sync (9-pin) In/Out connections are made between the JL Cooper DataMaster and the ADAT.

**In OMS Setup:**

1. Make sure the OMS IAC Driver is installed and configured. See “Synchronizing a Sequencer to Pro Tools on the Macintosh” on page 482 for more information.

2. Define a new device for the JL Cooper DataSync II and the ADAT.

3. Configure the JL Cooper device by double-clicking its icon in the OMS Studio Setup window. For the JL Cooper DataMaster, enable Is Controller, then enable both Sends and Receives MIDI Time Code. (Be sure to leave Is Multitimbral unchecked.) Select channel 1 as the Receive Channel.

4. Configure the ADAT OMS device by double-clicking its icon. Leave both Is Controller and Is Multitimbral unchecked (disabled). Enable both “Sends” and “Receives” MIDI Time Code and MIDI Machine Control. You do not need to have any Receive channels enabled.

5. Save/Make Current and then close the new OMS Studio Setup.

**In Pro Tools**

6. Choose Setups > Peripherals and click Synchronization.

7. Select Generic MTC Reader as the Synchronization device (this represents the 64X), then select the port to which your MIDI Interface is connected to (in this example, the port choice would appear as “Studio64X / Printer”).

8. Open the Machine Control window of the Peripherals dialog. In the MIDI Machine Control section, enable MMC, then select JL Cooper DataMaster as the Send To destination.

9. Set the ID to 127 (this is the “broadcast to all” setting, and the Pro Tools default setting for MMC device ID).


11. In the Session Setup Window, set the frame rate and start frame as appropriate.

12. Enable the MTC to Port option (click in the box so that it is enabled), then select JL Cooper DataMaster in the pop-up next to MTC to Port. This routes MIDI Time Code from Pro Tools to the JL Cooper device, which then sends the data on to the ADAT.

13. Close the Session Setup window.

14. Click Play or press the Spacebar. The ADAT will cue to the play point and begin playing back in sync with Pro Tools. You do not need to put Pro Tools online to control the ADAT.

15. To control the ADAT from the Pro Tools Transport, select MMC from the Transport pop-up (in the Transport window). Pressing Play, Rewind, FFWD, RTZ (Return To Zero), or Go To End will cause the ADAT to respond accordingly.

**External Hardware Configuration**

The above example uses the JL Cooper DataSync II, which must be configured correctly for the above to work. Configure the ADAT as a slave (not master), enable MTC as the synchronization source, and enable MIDI Machine Control. The ADAT must be set to Internal mode. Consult the documentation that came with these devices for more details.

The above example could also be applied to Pro Tools|HD, in that a MIDI interface and JL Cooper DataSync II, or equivalent is required to provide positional reference (time code). If you are using a Digidesign ADAT Bridge I/O with Pro Tools|HD, refer to the Pro Tools|HD Getting Started Guide for additional information.
Synchronizing Pro Tools to an OMS-Compatible Sequencer Using MMC

(Macintosh Only)

You can “lock” a MIDI sequencer to Pro Tools for synchronized operation, using the sequencer as the transport and location master. In this case, Pro Tools is still the system clock master, while the sequencer is the transport/location master.

MMC and OMS Synchronization

When using MIDI Machine Control, you must have the OMS-compatible sequencer configured to synchronize to Pro Tools using the OMS IAC Driver (see “Synchronizing a Sequencer to Pro Tools on the Macintosh” on page 482). When controlled by a sequencer via MMC, Pro Tools serves as clock master for the sequencer.

Pro Tools also serves as a transport and location slave to the sequencer. When starting and stopping playback in the sequencer, the sequencer sends out location information to Pro Tools via MMC commands. Pro Tools then cues to the location, begins playback, and sends MIDI Time Code back to the sequencer. The sequencer then locks to the MIDI Time Code from Pro Tools for synchronized playback.

The following instructions describe the general steps that you should take. The exact synchronization setup your sequencer requires will vary depending on the software and your specific MIDI setup.

To slave the Pro Tools transport to an OMS-compatible MIDI sequencer using MIDI Machine Control:

1. Make sure the OMS IAC Driver is installed in the OMS Folder inside your System Folder. If necessary, run the OMS Installer and choose Custom Install to install the OMS IAC driver.

2. In Pro Tools, choose Setups > OMS Studio Setup to launch the OMS Setup application.

In OMS Setup:

3. Choose Edit > Preferences, make sure the “Use Serial DMA driver when available” option is deselected, and click OK.

4. Choose Edit > OMS MIDI Setup, make sure the “Run MIDI in background” option is selected, and click OK.

5. Choose Studio > MIDI Cards & Interfaces, then click Update Setup. If you are using a serial MIDI interface, enable the appropriate port and click Search.

6. Confirm that the OMS IAC driver appears in the OMS Studio Setup window. Save the setup document and make it your current setup.

7. In the OMS Studio Setup window, define two IAC busses by double-clicking the IAC Driver, then naming the first field “IAC1” and the second field “MMC.”

In your sequencer:

8. Enable IAC1 as a MIDI device.

9. Set your sequencer to receive MTC from IAC1, and enable remote control of the application.

10. Configure the frame rate to match your Pro Tools session. Click OK to close the Sync Options dialog.
11 Set a sequence start time (for example, 01:00:00:00). The Offset at the top of the Sequence window should usually match the Offset in Pro Tools.

12 Set the sequencer to wait for MIDI note information ("wait for note").

13 Start playback in the sequencer. The sequencer should indicate that it is waiting for note information.

In Pro Tools:

14 Choose MIDI > Enable Input Devices. Select the IAC bus transmitting the MMC messages and click OK.

15 Choose Operations > Active in Background.

16 Choose Windows > Show Session Setup, and choose the appropriate frame rate and SMPTE Start Frame to match the start time in your sequencer.

17 In the Output Time Code section of the Session Setup window, enable the MTC to Port option. In the pop-up menu just below the MTC to Port option, choose IAC1. You can now close the Session Setup window, or leave it open (settings are active as soon as they are enabled in the Session Setup window).

18 Next, choose Setups > Peripherals, and open the Synchronization page of the Peripherals dialog.

19 First, select Generic MTC Reader as the synchronization device, and select Any as the port.

20 Next, click to Enable Control of Pro Tools via MMC, and set the ID to 0.

⚠️ If MMC is currently enabled in the Pro Tools Peripherals > Machine Control dialog, you must assign a unique ID number in both of the corresponding MMC ID# fields. If not, an MMC feedback loop will occur. This can also happen if you use the default “broadcast to all” ID number of 127 in both places. If you are only slaving Pro Tools to a sequencer via MMC, without an external device requiring MMC from Pro Tools, you should disable MMC entirely in the Machine Control window.

In the Sequencer:

21 Engage any of the following Transport functions: Play, Stop, Fast Forward, Rewind, Record, or Locate (Cue). The sequencer sends MIDI Machine Control commands to Pro Tools via the IAC bus, and Pro Tools follows.

When starting and stopping playback in the sequencer, the sequencer sends location information to Pro Tools via MIDI Machine Control commands. Pro Tools cues to the location, begins playback, and in turn sends MIDI Time Code back to the sequencer. The sequencer then locks to the MIDI Time Code from Pro Tools for synchronized playback.
MIDI Beat Clock

Some MIDI devices such as drum machines, hardware sequencers, and arpeggiators can only synchronize to MIDI Beat Clock. To synchronize these devices to Pro Tools, you can transmit MIDI Beat Clock to them. Many plug-ins now support MIDI Beat Clock.

To transmit MIDI Beat Clock:

1. Choose MIDI > MIDI Beat Clock.
2. In the MIDI Beat Clock dialog, select the Enable MIDI Beat Clock option.
3. Select the devices you want to receive MIDI Beat Clock. If your MIDI interface does not support transmitting MIDI Beat Clock to separate ports, only the interface appears as a destination.
4. Click OK.

Spotting Regions to SMPTE Frame Locations

(TDM Systems Only)

Spotting is the process of assigning music and sound cues to specific SMPTE frame locations in a film or video. This function can be used to spot:

- Entire regions, selected with the Grabber. Multiple regions can also be selected, and Pro Tools will reference the first region in your selection.
- A specific location within a region, by clicking with the Selector at that location, and choosing Edit > Identify Sync Point.

Spot Mode

In Spot mode, a region in a track can be quickly spotted by simply clicking it with the Grabber.

You can also drag a region from the Regions List to a track while in Spot mode.

The Spot Dialog

The Spot Dialog appears when you drag a region to a track or click a region with the Grabber in Spot mode. The numeric fields function as both data displays and editing controls for the currently selected regions.
Information in these fields is displayed in SMPTE Time Code, Minutes:Seconds, Feet:Frames, Samples, or Bars & Beats, depending on which Time Scale format is selected.

**Use Subframes Option**

A subframe is 1/100th of a frame. The Use Subframes option enables you to use these smaller units for greater accuracy. This command adds an additional time field in the SMPTE hours:minutes:seconds:frames box, which appears as the far right time field when enabled. Use a period to separate subframe values from whole frames.

![Spot dialog](image)

A highlighted numeric field indicates the current active field for numeric entry editing. Entering a value in a field allows you to move a selected parameter to the time location that you enter. The Start, Sync Point and End fields are accessible when the Grabber is active. Only the Start or End (depending on where you click the mouse) and Duration fields are active when the Trimmer is active (see “Using the Trimmer in Spot Mode” on page 494).

To increase or decrease SMPTE values in the Spot dialog by a specific number of frames, press plus or minus on the numeric keypad, enter a number, and press the Enter key.

**Capturing Time Code**

Pro Tools also allows you to easily capture frame locations on the fly in this dialog by pressing the Equal key, or by clicking the Current Time button while valid time code is being received by Pro Tools. With VITC, you can accurately capture a paused or “crawling” VTR’s SMPTE location.

When Time Code is selected for the Time Scale, pressing the Equal key captures the incoming time code. When Bars:Beats is selected for the Time Scale, pressing the Equal key will capture to the nearest measure.

Although the Capture Time Code button works with free-running Linear Time Code (LTC) or VITC, frame numbers of a paused frame can only be captured with VITC.

The SYNC I/O can read VITC. With Machine-Control and SYNC I/O, you can read serial time code.
To spot a region to a specific SMPTE frame:

1. Choose Display > Show Edit Window.
3. Click the Spot button at the top left of the Edit window to put Pro Tools into Spot mode.
4. Identify the SMPTE frame location where you want to trigger playback of your region by pausing your video deck on that frame.
5. With the Grabber, click a region in a track (or drag a region from the Region’s List into a track). The Spot dialog appears.
6. Enter the desired SMPTE frame location.
7. If you are using VITC, you can press the Equal key on the numeric keypad, or click Current Time Code to enter a paused VTR’s current SMPTE location.
8. If you are using LTC, when Time Code is selected for the Time Scale, press the Equal key on the numeric keypad to capture the incoming time code. When Bars:Beats is selected for the Time Scale, press the Equal key to capture the nearest measure.
9. If you recorded the region while online, you can use the Original Time Stamp button to recall and enter the SMPTE frame location at which the region was originally recorded. You can also access a user-defined Time Stamp in the same fashion. See “Time Stamping” on page 133 for more information.
10. Click OK to close this dialog. The region spots to the chosen SMPTE frame location. When the session is online, this frame number will trigger playback of the region.

Auto-Spotting Regions

The Pro Tools Auto-Spot Regions option simplifies the task of spotting regions even further. If you are using VITC with this option enabled, or MachineControl software, you can pause your video at an appropriate SMPTE frame location, click on a region with the Grabber, and the region will be automatically spotted to the current time code location.

You can also use MachineControl’s serial time code ability to auto-spot by enabling MachineControl and enabling serial time code in the peripheral.

To Auto-Spot a region:

2. If you are using VITC, identify the SMPTE frame location where you want to trigger playback of your region by pausing your video deck on that frame.
3. Click the desired region with the Grabber. The region will be automatically spotted to the current time code location (or machine location).

Clicking a region with the Trimmer will allow you to trim the region to the current time code location.

Auto-spotted regions are spotted by their start times, unless you have identified a Sync Point (see “Identifying a Synchronization Point” on page 495). If the region contains a Sync Point, the region is spotted to it.
Using the Trimmer in Spot Mode

You can use the Spot dialog to trim your regions, including start/end/duration times and referencing incoming time code addresses. If you click a region with the Trimmer in Spot mode, the Spot dialog will appear, allowing you to enter a value in the Start or End and Duration fields to specify exactly where you want to trim the region’s beginning or end. Use this to edit the length of a region to correspond to a particular visual “hit point.”

Trimming a region that contains a sync point (see “Identifying a Synchronization Point” on page 495) will not affect the SMPTE location of the sync point, unless the region is trimmed past the sync point.

Time Stamping

Pro Tools time stamps every region recorded online with the original SMPTE time at which audio was recorded. You can recall this original SMPTE time for a region by clicking the Original Time Stamp button in the Spot dialog.

You can also spot a region to a separate user-defined SMPTE time stamp, defined using the Time Stamp Selected command. Once the region is time stamped using this command, you can click the User Time Stamp button to re-spot a region to its user-defined SMPTE location.

The Use Subframes option in the Spot dialog enables you to work with subframe accuracy by adding an additional time field in the SMPTE hours:minutes:seconds:frames box. This additional time field appears as the far right time field when enabled, and allows you to enter subframe values in SMPTE dialogs. Use a period to separate subframe values from whole frames.

Show Original Time Code in Regions

This command displays the original “time stamped” SMPTE times in all regions currently placed in tracks. This SMPTE frame number represents the time at which the region was originally recorded online with Pro Tools, and does not necessarily reflect the region’s current SMPTE location in a track.

To display Original Time Stamps in regions:
- Select Display > Display Time in Regions > Original Time Stamp.

To hide Original Time Stamps:
- Select Display > Display Time in Regions > None.

Creating a User Time Stamp

If you want to create a separate user-defined SMPTE time stamp, you can use the Time Stamp Selected command in the Regions List pop-up menu. This command allows you to select a region (or regions) and redefine its SMPTE time stamp. The Original Time Stamp and the User-Time Stamp are then stored with your session.

When audio is first recorded, the User Time Stamp will match the Original Time Stamp, but you can change the User Time Stamp at any time using the Time Stamp Selected command. This feature is particularly useful in post production situations where the SMPTE time code on video “work prints” often changes from one edit revision to another.
To time stamp a region (or regions) with a new SMPTE frame number:

1. In a track, select the region that you want to time stamp.
2. From the Regions List pop-up menu, choose the Time Stamp Selected command.

3. Enter a new SMPTE time. You can do this in three ways: enter the numbers manually (with the help of the arrow keys); click the Current Time Code button (or press the Equal key), if you want to capture the incoming time code address; or click the Current Selection button if you want to enter the start time of the current on-screen selection.

4. Click OK to close this dialog.

This command can be used in “batch mode” to set new time stamps for several regions at a time. To do this, simply select several regions and choose the Time Stamp Selected command. One after another, a dialog will open for each region, allowing you to quickly enter new values.

Once entered, the user time stamps can be displayed in all regions currently placed in tracks.

To display User Time Stamps in regions:

- Choose Display > Display Time in Regions > User Time Stamp.

To hide User Time Stamps:

- Choose Display > Display Time in Regions > None.

Using a Region with its Time Stamp in Another Session

Pro Tools saves time stamp information for each region as part of a session—not as part of the audio file itself. If you want to use a time-stamped audio file in another session, and keep its time stamps intact, do the following:

1. Open the session that contains the original time-stamped region.
2. Select the desired region in the Audio Regions List.
3. Choose Export Selected from the Regions List pop-up menu. The region can now be used in other sessions with its original time stamp references intact.

Identifying a Synchronization Point

The Pro Tools Identify Sync Point command allows you to identify a specific point within a region for audio spotting purposes.

Imagine the following sound effects spotting scenario: You have a single sound effect that consists of a creaky door slamming shut, followed by a few seconds of ambient reverberation. The slam portion of the effect—which you must precisely match to picture—occurs neither at the very beginning of the audio file nor at the very end. It is somewhere in the middle, making it tough to spot.

In this scenario, use the Identify Sync Point command to create a point in the region and synchronize that point to a SMPTE frame.
When you choose this command, the current SMPTE time is automatically entered as the SMPTE location for the sync point.

To create a sync point in a region:
1. Click with the Selector at the point in the region that you want to synchronize to a SMPTE frame location.
2. Choose Edit > Identify Sync Point. An arrow indicator appears in the audio region indicating the location of this sync point.

Changing a Sync Point

To change the location of a Sync point in a region:
- Click with the Selector in the region and choose Edit > Identify Sync Point. The new location will then be identified as the Sync Point.

Tips for Locating and Spotting to Sync Points
- To place a region's start point at the current edit cursor location, Control-drag (Macintosh) or Start-drag (Windows) the region from the Region List.
- To place a region's sync point at the current edit cursor location, Option-Control-drag (Macintosh) or Alt-Start-drag a region from the Region List.
- To move to the next region boundary or sync point, press Tab.

Removing a Sync Point

To remove a sync point from a region:
1. Select the entire region with the Grabber.
2. Choose Edit > Remove Sync Point.

Troubleshooting Synchronization

Getting SMPTE synchronization to work properly can seem like a formidable task at times. The following suggestions may help you troubleshoot and solve common problems.

Use the Current Time Field in the Session Setup Window as a Reference

The Current Time field in the Session Setup window indicates whether or not Pro Tools is receiving time code. If this field appears to be inactive when inputting time code into your time code reading device, check your hardware device settings, the device's connection to your computer, and your OMS Setup (Macintosh) or Multimedia Setup (Windows).
**Stripe SMPTE Before You Record**

All tapes in your setup (both audio and video) must be striped with SMPTE Time Code before any audio is recorded onto them or to Pro Tools. If tapes aren’t striped, your system may seem to work, but synchronization will never properly occur. The machines and Pro Tools will drift farther and farther apart the longer they run.

The same problem occurs when audio is recorded into Pro Tools without a resolved SMPTE source (for example, if it was recorded before the current session). The audio cannot be accurately synchronized with an analog tape recorder or video tape deck, since the Pro Tools audio was not recorded referenced to the SMPTE time code from the analog tape deck or video tape deck.

**Resolve All Components of Your System**

When striping time code, make sure that the time code generator and the video record deck are resolved to the same crystal reference. For example, when striping 29.97 Drop Frame time code onto a VTR, both the SMPTE generator and the VTR should be resolved to the same “black burst” or house sync generator. During playback, the master deck should be resolved to “black burst” or house sync.

This convention provides compatibility for your tape between the record and playback passes, and when it’s played back in other facilities on different equipment. This also means that when playing back a tape striped with time code, the playback deck should be resolved to the same synchronization rate as the record deck was resolved to at the time of the striping. When you stripe an audio transport with time code, it should be “free-running” and unresolved, but should be resolved with a house sync-referenced synchronizer during playback.

**Know the True Frame Rate on Your Work Tape**

If you get your video tapes from a production company instead of recording them yourself, be absolutely sure that they indicate the SMPTE frame rate used on the tape correctly.

The Digidesign SYNC I/O (and some third-party products) can be used to determine frame rate. See “Determining SMPTE Frame Rate” on page 478.

**29.97 fps Non-Drop Rate Can Cause Problems**

29.97 fps Non-Drop is a slightly slower version of 30 fps Non-Drop time code. When used with color video, each video frame now matches up with each SMPTE frame without having to use a drop-frame coding. This makes any frame number mathematics much simpler, since no frame numbers are dropped.

Unfortunately, some hardware and software devices do not recognize 29.97 Non-Drop as a separate frame rate. For example, any standard SMPTE-to MTC-converter does not explicitly recognize it. The user must tell the convertor to expect 30 fps Non-Drop instead. In fact, many devices that read SMPTE work acceptably by reading 29.97 Non-Drop if they are set to expect 30 fps Non-Drop.

Any SMPTE reader that uses the time code numbers to make real-time calculations (as Pro Tools does when it tries to trigger and synchronize to SMPTE) also needs to know that the frame format is 29.97 and not 30 fps. Since Pro Tools allows this choice of frame rate this does not really pose a problem. The problem exists because many users cannot readily distinguish 29.97 from 30 fps.
More importantly, some production companies will distribute video work prints striped with 29.97 fps but mark them as “30 fps NTSC,” by which they actually mean 29.97 fps Non-Drop. By the time you get the tape, you may have no idea what’s actually on it. Feeding 29.97 Non-Drop to Pro Tools when it’s set for 30 fps Non-Drop will result in timing errors of about 1.8 frames per minute, causing audio playback to trigger out of sync.

**Be Careful When Changing Frame Rates**

If you change time code rates in the middle of a session, many SMPTE-to-MIDI Time Code converters need to be turned off and turned on again to be able to recognize the new frame rate.

**Use a Consistent Clock Source**

When possible, sound files should be played back using the same peripheral it was recorded with, in addition to a house/black burst. This assures the closest match between record and playback sample rates.

**On a Macintosh, Disable AppleTalk, Network Connections, Screen Savers, and Power Saving Features**

These types of software can cause the Macintosh to ignore MIDI data (such as MIDI Time Code) coming into its serial ports. Make sure AppleTalk is inactive in the Chooser, disconnect AppleTalk cables, and remove any network extensions from your System Folder.

**In Windows, Disable Screen Savers and Power Management Features**

These types of software can cause your computer to ignore MIDI data (such as MIDI Time Code).
Chapter 36: Working with QuickTime Movies

You can use Pro Tools to import QuickTime movies and audio (such as MP3s), perform audio post production tasks, and export the finished product as a new QuickTime movie.

⚠ QuickTime movie features in Pro Tools are supported on Macintosh systems only.

About QuickTime

QuickTime is digital video technology designed to produce compact video files for multimedia use.

Using QuickTime Movies in Pro Tools

Pro Tools allows you to import QuickTime movies into your Pro Tools sessions.

Once imported into Pro Tools, a QuickTime movie is displayed in its own Movie track in the Edit window, and in a floating Movie window. This floating window can be viewed on a second monitor with appropriate video hardware. With a QuickTime movie in the session, Pro Tools serves as a fast, random-access visual reference for “sweetening” the movie by adding sound effects, music, foley, dialog, or other audio.

Pro Tools provides precise, frame-accurate audio and video synchronization. This means you can use your Pro Tools system as an off-line audio editing system, leaving the video editing suite free for video editing.

With Pro Tools, you can:

- Import a QuickTime movie into a session
- Import audio from a QuickTime movie (or audio from a CD or a CD-ROM)
- Synchronize audio events to a QuickTime movie, using the Pro Tools editing features to spot and nudge regions to video frames
- Scrub audio elements in tandem with a QuickTime movie
Use the Pro Tools Bounce to Movie command to compile a new “flattened” QuickTime movie file that can be read by any QuickTime-compatible application.

Because Pro Tools has no video editing capabilities of its own, if you want to edit or in any other way modify a movie, return to your video capture and assembly environment (for example, Adobe Premiere) for editing, then import the edited movie into Pro Tools.

**You can capture Avid-compatible video in Pro Tools with A|Voption or A|Voption XL.**

**Video Capture/Playback Cards**

For professional applications where full-screen, 25/30 frames-per-second playback is critical, we recommend that you invest in a Digidesign-approved third-party video capture and playback card. For the most up-to-date information about such products, contact your Digidesign dealer or visit Digidesign’s Web site.

**If You Are New to Audio Post Production**

If you are new to digital video, time code, or audio-for-post production, the following suggestions will help you manage your session’s audio and video requirements. Not all of these may apply to every project.

**Plan Ahead** Think through your entire project before you start capturing your video. For best results when working with SMPTE time code, make sure that time code is burned into a window in the movie. Try to anticipate compatibility and configuration issues that may arise.

**Conform Your Movie** Be sure to conform your captured QuickTime movie to the desired frame rate. Consult your video capture software’s documentation for information on how to ensure frame-accurate captures. We recommend that you do this to all video captures to ensure accurate playback in Pro Tools.

If your destination is a pulled-down Pro Tools session, this pull down affects QuickTime movie playback speed. You should conform your movie to a 30 fps frame rate for use in a pulled-down session.

**Destined for Video or Film?** What is the ultimate destination of your work? Is it for DVD, HD, TV, film, audio CD or CD-ROM? This will determine such things as the best sample rate to use, the correct frame rate, pull-down or pull-up rates, and so on. Double-check the time code frame rate. You must make sure that you know the correct frame rate of the video source.

**Storage** Make sure you have enough disk space on your drive, and optimize your hard drives regularly.

**Video Compatibility** If you are not digitizing the video material yourself (if the material is already on hard disk) check into the type of video capture and playback system that was used and make sure you can accommodate that format’s compression method. Check whether or not time code is “burned into” or superimposed over a small area of the video.
QuickTime Requirements

Pro Tools supports playback of QuickTime videos without additional hardware. However, performance will vary in terms of maximum movie size, frame rate, and smoothness of playback. Capture of 30/25 fps (frames per second), 60/50 fields-per-second video requires a video capture card, and associated software and hardware.

About Frame Length and QuickTime Movies

Not all video capture software can guarantee consistent frame lengths. Consult your video capture software documentation for information on ensuring frame-accurate captures, and on conforming your video to proper frame boundaries.

To take advantage of Pro Tools QuickTime movie playback capabilities, you will need the following:

- The version of Apple’s QuickTime System Extension (included with Pro Tools). To install QuickTime, run the installer included on the Pro Tools Installer CD.
- QuickTime movie playback and editing software (such as Adobe Premiere, AVID VideoShop, Macromedia Director, or Apple MoviePlayer) to edit and compile QuickTime movies.

Optionally, you may also need:

- QuickTime movie capture hardware and software to digitize your own movies from a video tape or video camera source.
- An Apple CD-ROM drive running at 2x speed or faster to take advantage of commercially-available QuickTime movies and sound clips.

Movie Playback Quality Options

Pro Tools supports three options for movie playback performance: Normal Priority Playback, Medium Priority Playback, and Highest Priority Playback. In most cases, you should leave the priority choice set to Normal Priority Playback. If you are running QuickTime Movies natively, that is, without a capture card, you may need to use one of the other playback priority options. If this does not apply to you, leave movie playback priority set to Normal Priority Playback. This is the default setting.

Hard Drive Tips for Best Performance

For best movie playback performance, make sure that the hard drive you are using for video capture and playback is not on the same SCSI bus as your audio files, if possible. This allows the least amount of interference between drives when Pro Tools requests audio and video data. With most capture cards, and moderate data capture rates (800 kilobytes per second or less), this should provide good performance.

The G4 has an internal IDE system drive. For best performance, audio and video should be stored on SCSI drives, connected to the computer with a Digidesign-approved SCSI interface card.

Some Macintosh computers have two SCSI buses, an internal SCSI bus, and a separate external SCSI bus. The internal bus is often a SCSI Fast-compatible bus that can yield better disk performance. The external bus is a narrow SCSI bus, which is slower. For best performance use an internal drive that connects to the internal, fast SCSI bus. Contact your Digidesign dealer or visit the Digidesign Web site for compatibility information.
Importing a QuickTime Movie

Before you import a movie, you should digitize your video material and know the correct frame rate and sample rate when applicable.

If a video card with hardware video compression was used to create the QuickTime movie, Pro Tools cannot play the movie without the compression hardware. Make sure the video card is installed and configured correctly before starting your session.

To import a QuickTime movie into Pro Tools:

1. Launch Pro Tools and create a new session, or open an existing one.

2. Check the time code parameters of the session to make sure they match those of the movie you wish to import, and save the session.

3. Choose Movie > Import Movie.

4. Locate the desired movie. When you select a movie in the Import Movie dialog, you can view a preview frame by enabling the Show Preview check box. The preview corresponds to the first frame of the movie. If you have not yet created a preview, you can do so by selecting the desired movie and clicking Update in this dialog.

5. Select the desired movie and click Open. Pro Tools imports the movie and displays it in its own Movie track in the Edit window as well as in a floating Movie window. The first frame of the movie is automatically synchronized to the start time of your session.

About the Movie Track

Once a movie is imported into Pro Tools it appears in the Edit window in its own Movie track. This picon (picture-icon) track displays a “thumbnail” overview of the frames of the movie it represents. The Movie track will show greater or lesser detail depending on your current zoom level in the Edit window—the closer in you zoom, the greater the number of individual frames that are displayed in the Movie track; the farther out you zoom, the fewer the number of individual frames that are visible.

The Movie track behaves much as a Pro Tools audio or MIDI track in that you can move the movie region with the Grabber or other editing tools. This allows you to offset the movie to any start point. However, you cannot edit the Movie track by trimming it or capturing regions from within it.

Only one QuickTime movie can be associated with a session at a time. If you want to import a different movie into a session, repeat the previous steps. The new movie will replace the original in the session.

A Movie track takes its name from its associated movie file and cannot be independently renamed.
Picon View Performance

When using Picon View to view movie content in the Movie track, your computer may exhibit reduced or sluggish performance. If this happens on your computer, switch the Movie track view to Blocks mode.

Scrubbing the Movie Track

You can use the Scrubber tool to scrub the Movie track with full frame accuracy. If you scrub directly on the Movie track, only the movie will scrub (no audio will play). If you scrub on an audio track, audio and the movie will scrub simultaneously.

To scrub the Movie track:

1 Select the Scrubber tool.
2 Click the Movie track at the desired point and drag the Scrubber.

To scrub with finer precision, press the Command key while scrubbing.

About the Movie Window

The Movie window displays the movie playback or the current frame if playback is paused or stopped. You can drag the Movie window anywhere on your computer screen.

To display the Movie window:

- Choose Window > Show Movie Window. If a movie has already been imported, the Movie window will appear.

Using a 14-inch Monitor for Playback

If you capture 320 x 240 (NTSC) movies and have a second monitor with 640 x 480 resolution (a standard 14-inch monitor), clicking on the Movie window will route movie playback to that monitor. The Movie will “bounce” over to the second monitor, and will be pixel-doubled so that it takes up the whole screen.

Tips for Optimizing Movie Playback

Since Pro Tools uses QuickTime to play movies, the quality of the playback is dependent on the speed of your Macintosh CPU and hard drive, the size (in pixels) of the movie, and the quality of the video hardware used to capture and playback the digitized video. While QuickTime doesn’t produce broadcast-quality playback, it is frame accurate when spotting to picture.

On PCI-based computers, Pro Tools continuously re-syncs the movie. The movie resolves to the audio sample clock. This allows the movie to smoothly track the audio even when your system is varispeeded.

For more consistently smooth movie playback, here are some suggestions:

- Use a Digidesign-approved video capture and playback card for 25/30 frames-per-second full-screen movie playback.
- Display the movie on a separate monitor driven by a video capture and playback card.
If you don’t have a video capture and playback card, set the movie playback priority to Medium Priority Playback or High Priority Playback using one of these commands in Movie menu. This gives priority to movie playback, rather than other screen graphics tasks such as moving faders.

- Use the fastest CPU possible.
- Capture and play QuickTime video from a separate hard drive than your Pro Tools audio drives.
- Remove unneeded System Extensions and Control Panels.
- Disable AppleTalk and other background tasks on the CPU, such as File Sharing, screen savers, Calculate Folder Size and any fax or e-mail software.
- Disable the Automation Preference for Faders Move During Playback.
- Set No Auto Scrolling in Operations > Scroll Options.
- Reduce the size of the Edit window to the smallest possible size.
- Close unnecessary windows.
- Reduce the overall length of the SCSI chain of your computer system for improved throughput.
- Reduce the pixel size of the movie (for example, reduce it from 640 x 480 pixels to 320 x 240 pixels).

---

### Setting the Movie Start Time (Movie Offset)

When you import a movie into your session, the first frame of the movie defaults to the start time of the session. In some cases, however, you may need to offset the movie by some amount forwards or backwards so that you can accurately spot audio to the movie.

Since a movie can be moved inside the Movie track, it is fairly easy to match these two times. In fact, you may not have to move the Movie track at all.

For finer adjustment of a movie’s start time, you can use the Set Movie Sync Offset command to offset the movie in 1/4-frame increments. This is more accurate than dragging the Movie track, and is especially useful in cases where your movie track happens to begin with a partial frame.

To set the movie offset:

1. Double-check that the session’s SMPTE frame rate matches that of the movie.

2. Choose Movie > Set Movie Sync Offset, enter the desired offset value, and click OK.

   *The Movie Sync Offset is always defined in Feet.Frames, regardless of the session time display.*

3. Lock the movie in place by choosing Edit > Lock/Unlock Region.
To spot the movie to a sync point:

1. Double-check that the session's SMPTE frame rate matches that of the movie.
2. In the Edit window, enable Grid mode.
3. Set the session time display to SMPTE.
4. Set the Grid Value to Feet.Frames.
5. With the Selector, click in the Movie track to place the cursor where you want to create a Sync Point. Often, the best spot will be the “2 beep” two seconds before the first action frame (the start of the video). You can use the plus and minus keys on the alpha keyboard to nudge the cursor and the movie one frame at a time.
6. Choose Edit > Identify Sync Point to place a Sync Point at the current cursor location.
7. Put Pro Tools into Spot mode by clicking the Spot button in the Edit window.
8. Click the Movie track with the Grabber. The Move Region To dialog appears.
9. Enter the time code number displayed in the window-burn of the frame you are spotting to (if the movie has a SMPTE time code window burned into it) and click OK to close the Move Region To dialog.

The movie's sync point moves to the SMPTE location you entered.

Spotting Audio to a QuickTime Movie

For accurate spotting, Grid mode provides you with an effective tool for quick and accurate selection of waveforms, and alignment of regions in tracks. When Grid mode is enabled, the Selector will snap to the current Grid Value, and regions selected with the Grabber and dragged to a track will also align up with the Grid Value.

Conforming Your Movie

Before you spot audio to a movie, you should conform the movie file so each frame starts and ends at valid frame boundaries.

For example, Adobe Premiere contains a Conform Movie tool for destructively editing the lengths of each frame to the grid of the current frame rate. You should conform the movie to a frame rate that Pro Tools can work with (30 fps or 29.97 fps).

⚠️ If your destination is a pulled-down Pro Tools session, the pull down affects QuickTime movie playback speed. Conform your movie to a 30 fps frame rate for use in a pulled-down session.

Consult your video capture software documentation for more information.

More Tips for Spotting Audio

- Specify your movie size up front. For purposes of spotting audio, 320 x 240 is usually adequate. If you are displaying the movie on a second monitor with 640 x 480 resolution, with pixel doubling, it will fill the screen.
- Try to work with a window burn in the movie, since it will help you spot material. You can produce your own window burns for the capture using Digidesign’s SYNC I/O.
Use a continuous scrolling option. Pro Tools includes two scrolling options that are particularly useful in post production: Continuous Scroll During Playback, and Continuous Scroll with Playhead. Enable either of these scrolling options by selecting them from the Operations > Scroll Options submenu.

**Using Grid Mode to Spot and Nudge Regions with Frame Accuracy**

*(TDM Systems Only)*

Grid mode allows you to constrain the movement of regions so that they snap to SMPTE-based measurements (minutes, seconds, frames, or subframes).

**To spot audio to a movie:**

1. Click the Grid button at the upper left corner of the Edit window. This ensures that the audio will align to a frame boundary.
2. Set your Grid Value to Time Code using the pop-up menu.
3. Choose a desirable Grid unit setting. Note that you can set the grid units independently of the Main Time Scale.
4. Using the Selector, place the insertion cursor at the desired location in the movie. If you want, use the Nudge Value pop-up to set the nudge units to frames. You can then use the plus and minus keys on the alpha keyboard to nudge the insertion point frame by frame.

5. While pressing the Control key, drag the desired region from the Regions List to the appropriate track. Pro Tools will automatically spot the region to the same time location as the cursor.

To spot elements directly to locations in the movie, use the technique described above. In this scenario, Auto Spot mode is not recommended, since it uses incoming MTC for location information.

**Importing QuickTime Audio (and Other Compressed Video Files)**

Pro Tools allows you to import audio directly from a QuickTime movie. You can import audio from a movie currently loaded into a session, or from a different movie. The procedure is the same for both.

Pro Tools supports the following compressed QuickTime file formats:

- MP3
- QDesign
- uLaw 2:1
- aLaw 2:1
- Intel ADPCM
- Microsoft ADPCM
- IMA 4:1
- 32-bit floating point
- 64-bit floating point
- 16-bit Big Endian
- 16-bit Little Endian
- MACE 6:1
- MACE 3:1
QuickTime files can be imported into sessions using either Import Audio from Other Movie or Import Audio from Current Movie menu commands.

**Sample Rate Conversion Quality**

If you import QuickTime audio that was not originally recorded at the session’s sample rate, the sample rate is converted to match the audio to your session. Pro Tools allows you to choose the quality of the sample rate conversion via the Conversion Quality parameter in the Editing Preferences. The higher the quality of sample rate conversion that you choose, the longer it takes to perform the sample rate conversion.

The five conversion settings range from Low to Tweak Head. The Low setting provides results that are considerably better than the Macintosh’s built-in sample rate conversion. For most applications, the Better setting will yield excellent results.

Because the Best and Tweak Head settings take significantly longer than the others, we recommend that you use these only in cases where the highest fidelity is absolutely essential and you have a considerable amount of time. The Tweak Head setting in particular can take several hours to perform sample rate conversion on moderate-length files.

**To set the sample rate conversion quality:**

1. Choose Setups > Preferences and click Editing.
2. Click the Conversion Quality pop-up menu and select the desired setting.

**Importing Audio from a QuickTime Movie**

This procedure allows you to use the Import Audio From Current Movie and Import Audio From Other Movie commands to import audio tracks either from a QuickTime movie currently in the session, or from other QuickTime movies on your hard disk. You can also use the Import Audio From Other Movie command to import audio files of a different bit resolution or sample rate into your session.

**To import audio tracks from a QuickTime movie:**

1. If you want to import audio from a QuickTime movie that is already in the session, choose Movie > Import Audio From Current Movie.

   – or –

2. If you want to import audio from a QuickTime movie that has not been imported into the session, choose Movie > Import Audio From Other Movie.

3. Select the QuickTime movie from which you want to import audio. The Track Import dialog appears, listing information about the audio tracks.

   **Track Import window showing audio tracks in a QuickTime movie**

4. Select the desired audio tracks by clicking them. To select multiple tracks contiguously in this dialog, Shift-click them. To select discontiguous tracks, Command-click them.
4 Click OK. The audio is converted to the session’s sample rate and bit resolution, and a new region appears in the Audio Regions List for each imported file (2 regions appear for each imported stereo file). The regions are listed in the Audio Regions List with the region name, the number of the originating track, and the number of the region from the track.

5 Drag the imported regions from the Audio Regions List to the desired tracks.

---

**Bouncing to a New Movie**

When you have finished your final mix and synchronized your audio events to the movie, you can use the Pro Tools Bounce to Movie command to compile a new QuickTime movie with the bounced audio embedded in the QuickTime movie file as the soundtrack. As a QuickTime file, the new movie is supported by all software applications that support QuickTime video.

**To create a new QuickTime movie with bounced audio embedded as the soundtrack:**

1 Adjust track output levels and finalize your mix. Any inserts and effects settings that are active on tracks will be permanently written to the bounced tracks. If you don’t want to apply a plug-in to the bounce, click the Bypass button in the Plug-In window.

2 Make sure that all of the tracks you want to include in the bounce are audible (not muted).

3 Assign the output of each of the tracks you want to include in the bounce to the same output pair.

4 If you want to bounce the entire session, press the Return to Zero button on the Transport to go to the beginning of the session. The new movie file will include all the video and audio material in the session, even if the duration of the video material is longer than the audio or vice versa. If you only want to bounce a portion of a session, open the Edit window and select the section that you want to include in the bounce.

5 Choose Movie > Bounce to Movie.

6 Select the file format for the movie audio. Choose Mix-to-Mono to combine the left and right channel output of the session to a mono movie soundtrack. Choose Stereo to retain the stereo mix of the session for the movie audio.

7 Select the resolution for the movie audio. Red Book audio CDs are always 16-bit, while many multimedia presentations and CD-ROMs use 8-bit resolution. You cannot create a QuickTime movie with 24-bit audio; audio from 24-bit sessions is converted to 16-bit or 8-bit audio, depending on what you choose.

8 If you intend to convert the session to 8-bit resolution for use in multimedia, use the Squeezer option (click the Convert after Bounce option, then the Settings button to access this feature) to improve the fidelity of the converted 8-bit audio. This option uses a proprietary DSP algorithm that preprocesses the audio using compression, limiting and gating before converting to 8-bit resolution. This option is recommended for optimal results.

9 Select the Sample Rate for the movie audio (click the Convert after Bounce option, then the Settings button to access this parameter). The default audio sample rate is 44100 (44.1 kHz), which is the standard sample rate for audio CDs. Multimedia presentations and CD-ROMs may use a sample rate of 11025 (11.025 kHz) or 22050 (22.050 kHz).
Click Bounce, name the new movie, and choose where to save it.

The audio tracks are converted to the selected sample rate and bit resolution, and a new flattened movie is created incorporating the audio. You can open and play the flattened movie in any software application that supports QuickTime.

*Pro Tools sample rate and bit resolution conversions use large amounts of processing power. You can save time by selecting a lower sample rate conversion quality in the Editing Preferences.*
Appendix A: DSP-Induced Delays in Mixing (TDM Only)

In all digital systems, signal processing incurs signal delays of varying amounts. These delays can vary from as short as several microseconds to as long as several milliseconds, depending on the type of processing being performed.

**Delay Factors**

In Pro Tools TDM systems, delay is incurred when you perform the following processes:

**Bouncing Tracks**

**Bus-based bounces**  When you bus a track to another track and record the result, the following delays are incurred:

**Bus-based bounce delays for each Pro Tools system**

<table>
<thead>
<tr>
<th>Pro Tools System</th>
<th>Delay</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pro Tools</td>
<td>HD-series (Stereo Mixer)</td>
</tr>
<tr>
<td>Pro Tools</td>
<td>HD-series (Surround Mixer)</td>
</tr>
<tr>
<td>Pro Tools</td>
<td>24 MIX-series</td>
</tr>
<tr>
<td>Pro Tools</td>
<td>24</td>
</tr>
</tbody>
</table>

**Bounce to Disk**  The File > Bounce To Disk command causes no delay on a TDM-equipped system since delay compensation for the bounce function is built in. This form of bouncing may be more desirable than bus-based bouncing.
Using Sends

When you send a track to another track and return it to a track (audio, Auxiliary Input, Master Fader), the following delays are incurred:

Sends delays for Pro Tools | HD systems

<table>
<thead>
<tr>
<th>HD Mixer</th>
<th>Sends</th>
<th>Delay</th>
</tr>
</thead>
<tbody>
<tr>
<td>Stereo Mixer</td>
<td>Pre-fader send to bus</td>
<td>10 samples</td>
</tr>
<tr>
<td></td>
<td>Post-fader send to bus</td>
<td>8 samples</td>
</tr>
<tr>
<td>Surround Mixer</td>
<td>Pre-fader send to bus</td>
<td>8 samples</td>
</tr>
<tr>
<td></td>
<td>Post-fader send to bus</td>
<td>12 samples</td>
</tr>
</tbody>
</table>

Sends delays for Pro Tools MIX-series and Pro Tools | 24 systems

<table>
<thead>
<tr>
<th>System</th>
<th>Sends</th>
<th>Delay</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pro Tools MIX-series or Pro Tools</td>
<td>Pre-fader send to bus</td>
<td>3 samples</td>
</tr>
<tr>
<td></td>
<td>Post-fader send to bus</td>
<td>6 samples</td>
</tr>
</tbody>
</table>

Using hardware sends also results in delays, as described below.

Using Plug-In Inserts

Using plug-in inserts on a track can cause additional delay. Refer to your DigiRack or Digidesign Plug-Ins Guide.

Using Hardware I/O

When an audio interface is used on an insert or (send), there is delay introduced by going through the D/A and A/D converter pair (for analog devices) or digital I/O connection (for digital devices) on the audio interface.

On the 888/24 I/O, the Digital I/O delay incurred when using AES/EBU or S/PDIF is identical.

HD-series I/O characteristics

<table>
<thead>
<tr>
<th>Interface and I/O Port</th>
<th>Surround Mixer</th>
<th>Stereo Mixer</th>
</tr>
</thead>
<tbody>
<tr>
<td>192 I/O</td>
<td>24 samples</td>
<td>22 samples</td>
</tr>
<tr>
<td>192 I/O</td>
<td>105 samples</td>
<td>103 samples</td>
</tr>
<tr>
<td>96 I/O</td>
<td>21 samples</td>
<td>19 samples</td>
</tr>
<tr>
<td>96 I/O</td>
<td>79 samples</td>
<td>77 samples</td>
</tr>
</tbody>
</table>

I/O characteristics for MIX-series audio interfaces connected to HD Legacy Port

<table>
<thead>
<tr>
<th>Interface and I/O Port</th>
<th>Surround Mixer</th>
<th>Stereo Mixer</th>
</tr>
</thead>
<tbody>
<tr>
<td>888</td>
<td>24 AES/EBU</td>
<td>18 samples</td>
</tr>
<tr>
<td>888</td>
<td>24 Analog</td>
<td>82 samples</td>
</tr>
<tr>
<td>888</td>
<td>20 AES/EBU</td>
<td>20 samples</td>
</tr>
<tr>
<td>888</td>
<td>20 Analog</td>
<td>18 samples</td>
</tr>
<tr>
<td>ADAT Bridge Optical</td>
<td>18 samples</td>
<td>16 samples</td>
</tr>
<tr>
<td>ADAT Bridge S/SPDIF</td>
<td>76 samples</td>
<td>74 samples</td>
</tr>
<tr>
<td>1622 Optical</td>
<td>18</td>
<td>16 samples</td>
</tr>
<tr>
<td>1622 S/PDIF</td>
<td>76</td>
<td>74 samples</td>
</tr>
</tbody>
</table>
Compensating for Delays

If you want to compensate for offsets incurred by these delays, there are different methods you can use: apply sample-level delay to tracks with the TimeAdjuster plug-in, physically adjust tracks in the Edit window by the appropriate number of samples, or use the same plug-ins on all tracks.

Using the TimeAdjuster Plug-In

You can use the TimeAdjuster TDM plug-in provided with your Pro Tools system to apply an exact number of samples of delay to the signal path of the tracks you are working with. Up to 2048 samples of delay are available.

Digidesign TDM plug-ins display their delay values in the track delay indicators in the Mix window. TimeAdjuster can be used to match these delay values for tracks that need to remain in phase (such as instruments recorded with multiple microphones or stereo pairs).

In the Mix window, Command-click (Macintosh) or Control-click (Windows) the Track Level Indicator to toggle between Level (which appears on the display as “vol”), Peak (“pk”) and Channel Delay (“dly”) indications. Delay values are shown in samples.

I/O characteristics for MIX-series audio interfaces connected to MIX-series systems

<table>
<thead>
<tr>
<th>Interface</th>
<th>A/D/A delay</th>
<th>Digital I/O</th>
</tr>
</thead>
<tbody>
<tr>
<td>888/24 I/O</td>
<td>81 samples</td>
<td>17 samples</td>
</tr>
<tr>
<td>882/20 I/O</td>
<td>75 samples</td>
<td>17 samples</td>
</tr>
<tr>
<td>1622 I/O</td>
<td>75 samples</td>
<td>17 samples</td>
</tr>
</tbody>
</table>

To use TimeAdjuster to compensate for a time delay:

1. Apply the TimeAdjuster plug-in to the track whose delay you want to increase, and Command-click (Macintosh) or Control-click (Windows) its Track Level indicator until the Channel Delay value is displayed for that track.
2. Change the delay time in TimeAdjuster by moving the Delay slider or entering a value in the Delay field, until the track delay value matches that of the first track.

You can test the delay values by duplicating an audio track and reversing its phase while compensating for delay.

If you are using a plug-in whose delay factor you are not familiar with, you can set the delay by ear using one of two methods:

- If you are working with phase-coherent track pairs, or tracks that had been multi-miked, you can “null out” the delay. Invert the phase of the target track using the TimeAdjuster Phase Invert button, and adjust the plug-in delay time until the signal disappears. (When they are perfectly synchronized, duplicate signals of opposite polarity cancel each other out.) When you are finished, disengage the Phase Invert button.
- You can also change the delay while listening to the signal in phase, adjusting until any comb-filter effects cancel out.
Nudging Audio Tracks

On audio tracks, you can use the Pro Tools Nudge feature to nudge the affected regions in single-sample (or other) increments, to preserve phase coherency. If it is necessary to nudge a region by a large number of samples, you may want to calculate the equivalent value in milliseconds and nudge the Region in millisecond increments. If the value doesn’t divide evenly, you can switch the Nudge value back to samples and use these smaller increments for the remainder.

The disadvantage of using this method is that it only works with disk tracks (not live inputs), and the timing relationship between tracks is permanently altered, which can affect editing.

Sample Rate and How it Affects Delay

The delay in samples caused by TDM processing is the same regardless of the sample rate because a sample is tied to the rate of the sample clock for the entire system. However, when samples are converted into a time value (milliseconds or microseconds), the sample rate (44.1 versus 48 kHz) must be taken into account.
Appendix B: TDM Mixing and DSP Usage

Understand the Benefits of TDM II

Digidesign’s TDM (or time division multiplexing) technology is based on the concept of a single, high-speed data highway, or bus that transmits data between your Pro Tools CPU, Pro Tools cards, and the DSP chips on the cards.

Pro Tools 24, and Pro Tools 24 MIX-series cards feature Digidesign’s original TDM bus design. Pro Tools HD-series cards feature Digidesign’s new and enhanced TDM II architecture. The TDM II architecture provides many advantages over the original TDM architecture in terms of its mixing capacity and flexibility.

With both systems, individual channels from sources such as disk tracks, sends, or busses are sent out from Pro Tools audio cards, and combined together or multiplexed onto the TDM bus so that all signals can travel simultaneously and can be accessed within a single sample period.

At the receiving end, the audio cards can listen to any connection on the bus, and take whatever data they need.

The TDM bus runs fast enough to accommodate many audio signals at the same time. Each separate audio signal or stream, takes up a single time slot on this multiplexed bus.

One of most powerful features of the TDM architecture is that a single time slot can be used to “broadcast” data to many destinations simultaneously. With TDM II, not only can it send data to many destinations simultaneously, but it can also send signals both bi-directionally and “privately” between DSP chips, which effectively provides a much greater number of available time slots. This provides a greater potential number of connections for routing, processing and mixing audio signals within Pro Tools.

The examples that follow illustrate how the original TDM I bus and TDM II differ in their handling of data.
**TDM (or TDM I)**

The TDM I architecture has a single bus where every DSP within the entire TDM system shares a single pool of 256 time slots. See Figure 33.

In practice, this means, for example, that if a disk track has a ReverbOne plug-in insert, one of the 256 time slots is used to connect the engine DSP on one chip to the ReverbOne plug-in DSP on another chip. The TDM time slot used comes from the pool of 256 time slots, and is unavailable for use by the rest of the system.

So, using the same example as above, if a disk track has a ReverbOne plug-in insert, a time slot is used between the Engine DSP (sending out the disk track) and the DSP with the ReverbOne instance. If the ReverbOne insert is handled by a DSP that is physically next to the DSP handling mixing tasks, as shown in the illustration below, this leaves time slot 2 available for use between DSP 3 through DSP 9, and subsequent HD cards.

**TDM II**

With TDM II, there is a separate TDM I/O bus between each DSP chip on the Pro Tools cards, each with up to 512 bi-directional time slots at a session sample rate of 44.1 or 48 kHz (both between DSPs on each card, and between the DSPs that communicate between cards). The DSP chips are arranged serially, with a TDM I/O bus connecting one chip to the next. This means that every TDM II connection need only use time slots between the two DSPs that are being connected. See Figure 34 on page 517.

The maximum consumption of the time slots for a single connection occurs when the audio must be sent between the first and last DSP in the system. In this instance, a time slot between each DSP is used to reach the last DSP in the chain.
Another example of how TDM II is more efficient than TDM I is to imagine a single HD Core card with one Engine chip and two Mixer chips. The DSPs with plug-in instances associated with the first Mixer don’t need to communicate with the second Mixer, therefore the time slot numbers used can be re-used by the second Mixer to communicate with other DSPs loaded with other plug-ins.

DSP Allocation
(TDM Systems Only)

Digital Signal Processing (or DSP) capability is one of the most powerful elements of your system. The DSP chips in your system provide the real-time processing power for your TDM Mixer and plug-ins. There is a limit, depending on your system, to how many functions a single DSP chip can power at once. This section contains some guidelines for getting the most from your available DSP capacity.

**DSP Allocation Basics**

As in the analog world, every send bus or output mix that you use demands that a summing mixer exist for that group. On an analog console, the number of these summing mixers is fixed by the physical layout of the console. In the Pro Tools mix environment, this number is variable, and depends on the number of output mixes or sends that you choose to create. Pro Tools allocates DSP power as it is needed to build the mixers for each session.

We refer to certain mixing or signal processing functions as “using one DSP” or “using two DSPs.” This refers to the fact that there are a certain number of DSP chips on a card, as follows:

**DSP chips on a TDM card**

<table>
<thead>
<tr>
<th>TDM System</th>
<th>Card</th>
<th>Chips</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pro Tools HD-series</td>
<td>HD Core or HD Process</td>
<td>9</td>
</tr>
<tr>
<td>Pro Tools MIX-series</td>
<td>MIX Core, or MIX Card</td>
<td>6</td>
</tr>
<tr>
<td>Pro Tools</td>
<td>24</td>
<td>DSP Farm</td>
</tr>
</tbody>
</table>
Each chip on a card can only power a certain number of processing functions. If you have a single HD card, MIX card or DSP Farm card, and you create a big enough TDM mixer and use enough sends or plug-ins, you will eventually use up or “max out” all DSPs.

Mixing and DSP Usage

Pro Tools builds a TDM mixer every time a session is opened. Note that the term “mixer channel” applies to Audio tracks (total voiceable tracks) and Auxiliary Input tracks, as well as sends and returns that use any of the 64 TDM internal busses. When you go beyond a certain number of mixer channels, Pro Tools will use another DSP to create additional mixer capacity.

Master Faders do not use additional DSP power.

With Pro Tools 24 systems, Pro Tools does not always automatically free up all unused DSP power when you delete unneeded mixer channel. On these systems, to reclaim all DSP power after a change in your session configuration, close your session and reopen it. Pro Tools will rebuild your new mixer configuration to use DSP power with maximum efficiency.

DSP Manager

(Pro Tools HD-series and MIX-series Systems Only)

Pro Tools software (version 4.3 and higher) includes DSP Manager, a software component that optimizes the use of DSP capacity on Pro Tools HD-series and MIX-series systems.

When you have an HD (or MIX) card in your system, if your current DSP usage is approaching the capacity of the card, and you then try to add a mixer channel or assign a plug-in, the DSP Manager will automatically try to make room for the new mixer or plug-in on the HD (or MIX) card. It does this by reallocating the existing TDM mixers and plug-ins to use the available DSP capacity on the HD (or MIX) card as efficiently as possible.

Monitoring DSP Usage

To monitor the usage of DSP resources during a Pro Tools session, choose Windows > Show System Usage.

To display DSP resources in different formats, choose Display > System Usage Window Shows and choose a format from the Display menu.

As you allocate DSP to mixing or processing with plug-ins, the System Usage window indicates when DSP chips are available and when they are in use. Green indicates a chip is free. Red indicates a chip is in use.
Appendix B: TDM Mixing and DSP Usage

The Detailed and Gas Gauge formats show the percentage of each DSP chip in use.

With these indicators as your guide, you can try different mixer setups and different arrangements of plug-ins, sends, and Auxiliary Inputs to maximize your use of available DSP power.

Another feature available for DSP management is Active and Inactive switching. See “Active and Inactive Items” on page 16.

Setting up Sessions to use DSP Efficiently

The dynamically configurable mixing environment in Pro Tools lets you make choices based on the type of setup you want to have—such as how many inputs you want for your mixer, how many plug-ins you want to use, or how many sends you need.

For example, you could allocate all of your DSP power to create a large mixer with dozens of channels—but you wouldn’t be able to use as many busses, sends, or TDM plug-ins. Alternatively, you could create a mixer with a smaller number of mixer channels plus some sends and Auxiliary Inputs for returns, and TDM plug-ins on several tracks.

**RTAS (Real-Time AudioSuite) plug-ins, as well as AudioSuite plug-ins, do not use DSP and are always available. Refer to your DigiRack Plug-Ins Guide for more information.**

You can set up your session by choosing one of the session templates supplied with your system as a starting point, or by building it from scratch. If you are starting from scratch, a good rule of thumb is to start by building your mixer first, since at least one of the DSPs in your system is automatically dedicated to mixing. Start with Audio tracks, then add sends and Auxiliary Inputs, and finally add plug-ins as available DSP allows. Master Faders do not use additional DSP power.

DSP Usage with TDM Mixers

Understanding Mixers

Pro Tools TDM Systems include two mixer plug-in “flavors”: stereo and surround versions. The mixer plug-ins are used by Pro Tools to create “dynamic mixers,” meaning that the mixer size can expand or contract as mix channels are added or deleted in Pro Tools. More channels take up more DSP power from your Pro Tools|HD or Pro Tools|24 MIX hardware. This is different from hardware mixing consoles where hardware (analog or digital) creates “fixed” mix configurations consisting of a unchangeable number of master outputs, busses or sends.

DSP allocation for mixing in a Pro Tools TDM system is based on the concept of DSP summing mixers. Every send bus or output mix that you use requires that a summing mixer exist for
those signals. Every single signal path that is mixed together requires the use of a mixer plug-in (whether a main output that goes to hardware, a bus or a send). This is even true for an individual signal that travels from hard disk to an individual hardware output. These individual dynamic mixers are created using the appropriate TDM mixer plug-in (stereo or surround) that is installed in your Plug-Ins folder.

An “input” can be a disk track, a send, or an internal bus connection. Adding an output or bus path ( mono or multi-channel) adds the requirement for DSP power to mix the signals together.

An HD card has nine DSPs, a MIX card has six DSP chips, and a DSP Farm card has four DSP chips, each of which can power a certain number of signal processing tasks. DSP resources are dynamically allocated as the number of mixers and inputs increases.

The TDM mixer provides basic building blocks by which applications such as Pro Tools can create a wide variety of mixer configurations.

**Mono and Stereo**

Each TDM mono or stereo mixer is of the dimensions “N x 2,” meaning that it mixes a variable number of inputs to an output pair. For example: a session with six tracks routed to Output 1–2 would require a single 6 x 2 mixer. If one of the tracks is assigned to Output 3–4, however, two mixers are required—one 5x2 mixer routed to Output 1–2, and one 1x2 mixer routed to Output 3–4.

**Multichannel Surround**

Each Surround mixer can have a variable number of outputs as well as a variable number of inputs. For example, the 7.1 format requires eight outputs. A single mono track assigned to a 7.1 Output or Bus path would require a 1x8 mixer, while one mono and one stereo track would require a 3x8 mixer.

The important concept here is that every output (whether they are I/O or bus outputs) requires that a mixer exists for that output. This means that creating a send to bus 1 requires that a mixer be created for the bus 1–2 outputs, and that mixer will have one input.

**Mixing with Sends and Busses**

Each send will add an input to the destination output pair. For example, a send to output 1 will add another input to the output 1–2 mixer. If the send destination doesn’t already have a mixer for its output pair, then a new mixer will be created. A send to bus 3 will make a 1x2 mixer for bus 3 if no other bus 3 sources have been created yet.

In addition, adding a new track and assigning its input to a bus source will create a mixer for that bus pair if there isn’t one already. For example, creating a new Auxiliary Input track and setting its input to bus 5 will create a 1x2 mixer for bus 5, even if no sources have been created yet.
Submixing

When the number of channels that must be mixed exceeds the capacity of a single DSP, additional “main” mixers are created automatically, along with summing submixers (which sum together the “main” mixers). The use of submixers allows large mix configurations to be created.

For example, on a Pro Tools|HD system, when a Stereo mixer running at 44.1 kHz needs to grow to more than 68 inputs, a submixer is created along with another “main mixer” that provides “n” number of inputs beyond 68. Both the original 68x2 mixer and the new “N x 2” mixer which provides additional inputs are routed to a submixer, and its outputs are finally sent to the desired destination (such as Output 1–2 on your main audio interface).

Note that any small delays (on the order of a few samples) that are created remain equal between these main mixers because they are summed together via submixers, and are not cascaded.

The total number of voiceable tracks supported by your particular Pro Tools configuration will ultimately determine the maximum number of channels for your TDM mixer.

Mixers and DSP Hardware

Different mixer plug-ins are available, each of which uses DSP power at slightly different rates on the different audio cards (and their DSP chips), as shown in the following tables.

<table>
<thead>
<tr>
<th>HD Card, default Standard mixers</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Mixer</strong></td>
</tr>
<tr>
<td>Stereo</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td>Surround, 5.1</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td>Surround, 7.1</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>HD Card, Dithered mixers</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Mixer</strong></td>
</tr>
<tr>
<td>Stereo Dithered</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td>Surround Dithered, 5.1</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td>Surround Dithered, 7.1</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
</tbody>
</table>

See also “TDM Mixer Plug-Ins” on page 525.
I/O

(Pro Tools MIX-Series and Pro Tools|24 Only)

If the DSP is also being used for I/O processing, then some of the chip’s capacity will be devoted to I/O, yielding slightly lower mixer count (these figures represent maximum numbers when I/O is declared in the Hardware Setup dialog):

**MIX Card**

<table>
<thead>
<tr>
<th>Mixer</th>
<th>Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td>16-bit &amp; 24-bit optimized, mono</td>
<td>59x2 per chip</td>
</tr>
<tr>
<td>16-bit &amp; 24-bit optimized, stereo</td>
<td>29x2 per chip</td>
</tr>
<tr>
<td>Surround, 5.1</td>
<td>17x6 per chip</td>
</tr>
<tr>
<td>Surround, 7.1</td>
<td>12x8 per chip</td>
</tr>
</tbody>
</table>

Usage with other Surround mixer versions varies with the number of channels in each format.

**DSP Farm**

<table>
<thead>
<tr>
<th>Mixer</th>
<th>Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td>16-bit optimized mono</td>
<td>36x2 per chip</td>
</tr>
<tr>
<td>16-bit optimized stereo</td>
<td>18x2 per chip</td>
</tr>
<tr>
<td>24-bit optimized mono</td>
<td>25x2 per chip</td>
</tr>
<tr>
<td>24-bit optimized stereo</td>
<td>12x2 per chip</td>
</tr>
</tbody>
</table>

Note: ALL stereo counts are simply the mono mixer count divided by 2 and rounded down

**MIX Card with one I/O declared**

<table>
<thead>
<tr>
<th>Mixer</th>
<th>Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td>16-bit &amp; 24-bit optimized, mono</td>
<td>51x2 per chip</td>
</tr>
<tr>
<td>16-bit &amp; 24-bit optimized, stereo</td>
<td>25x2 per chip</td>
</tr>
</tbody>
</table>

Note: The Surround mixer cannot run on a MIX card with I/O declared.

**MIX Card with two I/Os declared**

<table>
<thead>
<tr>
<th>Mixer</th>
<th>Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td>16-bit &amp; 24-bit optimized, mono</td>
<td>43x2 per chip</td>
</tr>
<tr>
<td>16-bit &amp; 24-bit optimized, stereo</td>
<td>21x2 per chip</td>
</tr>
</tbody>
</table>

Note: The Surround mixer cannot run on a MIX card with I/O declared.
48-Bit Mixing Precision

The Pro Tools mixer plug-ins use a register area inside of the DSPs on the hardware to hold a full 48-bits of precision when mixing signals together. This allows a fader to be lowered in level without any loss of resolution. (Even if the fader is lowered almost to the bottom, all 24 of the original 24 bits of the signal are preserved.)

Mixer Headroom

Use of 48-bit precision when mixing allows the mixer to be designed to provide a very large amount of headroom, which allows the faders on the Pro Tools mixer to be placed in the “sweet spot” position without clipping. This is similar to working with high-quality professional analog mixing consoles.

Mixer plug-ins provided with Pro Tools|HD systems provide 48-bit precision with 48 dB of headroom. This means that on the “input” side of the bus (where signals are summed together) signals can never clip (even if channel faders are set to a full +6 dB of gain).

However, the “output” side of the summing mixer (where the signal is sent in the 24-bit world of a digital output or onto the TDM bus) can clip. You can use a Master fader (which does not “cost” any DSP) to scale the output level of any mix summing point (a bus or physical output). The master fader’s meters will tell you if you are clipping the mix bus, and the fader can be used to safely scale the level to avoid clipping, with no loss of quality.

Pro Tools MIX systems are supplied with two mixers, a stereo 24-bit Optimized version and a Surround mixer. These mixers are almost identical to those supplied with Pro Tools|HD, but they provide only 30 dB of headroom (while still maintaining 48 bits of precision). Since Pro Tools MIX systems cannot mix as many disk or auxiliary tracks as Pro Tools|HD systems, less headroom is needed to avoid clipping, and this is generally not a cause for concern.

If you are mixing larger numbers of signals together, always use a master fader so that you can monitor levels for the bus (via the master fader meter), and to trim the result to avoid clipping. Since Master faders cost no DSP, there is no reason not to use them.

24-Bit Optimized Mixer

(Pro Tools MIX-Series and Pro Tools|24 Only)

With the 24-bit Optimized Mixer, the Master Fader meters indicate clipping at both the input summing stage and the output level stage at all times. With this mixer, you could lower the Master Fader to reduce your output level, but the Master Fader meters could still indicate clipping at the input stage.

In the unlikely event that this occurs—this mixer’s 30 dB of headroom will allow many signals to be mixed without any input clipping—simply follow the procedure to trim back your faders, as described in “Trimming Input Summing Levels” on page 524.

16-bit Optimized Mixer

(Pro Tools MIX-Series and Pro Tools|24 Only)

With the 16-bit Optimized Mixer, the Master Fader meters indicate clipping only for the output level stage of the mixer. With this mixer, you could lower the Master Fader to reduce your output level, but any clipping at the input stage would not be indicated.

If reducing the output level has no effect on clipping, it could be occurring in one of the following places:
At the input summing stage. To prevent clipping at the input stage, trim the input summing levels.

At an insert on the Master Fader. If you are using a plug-in on the Master Fader, its meters show the levels on the insert. To prevent clipping at the insert, trim levels on any plug-ins or Hardware inserts on the Master Fader.

**Trimming Input Summing Levels**

With many inputs that contain high-level signals, it is possible to clip the input summing stage of a MIX-series mixer plug-in. This could easily happen with the 16-bit Optimized Mixer, but is very much less likely to occur with the 24-bit Optimized Mixer because of its 30dB of headroom.

To reduce the levels going into the input summing stage of the Mixer plug-in, lower the fader levels of all track faders using the All Mix/Edit group. If you are using mix automation, you will need to use Automation Trim mode or the Trim tool to lower the overall volume of all tracks until the levels are low enough to avoid overloading the mixer input. You can see this clearly by using a Master Fader for that mixer sum point, and examining its meter.

Note that clipping the “input” side of a mixer is *not* a concern on Pro Tools|HD systems. It is virtually impossible to clip the input of any HD-series mixer plug-in, because the 48 dB of headroom provided prevents any possibility of overload, even with a maximum number of inputs being fed by full-code signals with fader gains at maximum. While it *is* possible to clip the “output” side of the mixer, you can safely use a Master Fader to trim your mix bus back to avoid clipping (by simply examining the Master Fader meter for clipping, and pulling back the fader until it disappears; make sure that any plug-ins you may have on the Master Fader inserts are not the cause as well). The 48-bit precision of the mixer allows gain adjustment on the Master Fader with no loss of data integrity or audio quality, so there is no need to trim the individual input faders back to avoid clipping.

**Mixer Automation**

Volume automation on all versions of the mixers is near sample-accurate (as is pan automation on the stereo versions). In addition, DAE provides 24-bit interpolated values between mix breakpoints, which provides near “analog-like” resolution. This process of interpolation means that a smooth “data series” is created between any two breakpoints that you specify in Pro Tools. DAE calculates these smooth transitions on the DSP hardware with 24-bit precision, which provides extremely smooth volume changes. In addition, DAE “de-zippers” any “live input” to the mixer so that fast, real-time fader changes that come in from fader movements (on the Pro Tool user interface or control surfaces), do not cause audible artifacts as the mixer tries to “catch up” to fast changes that it receives.

**Stereo and Surround Dithered Mixers**

The Stereo Dithered and Surround Dithered mixer plug-ins provide non-correlated dither in addition to other basic attributes of the mixers described above. Every output summing point (whether to an internal bus or an physical output) is dithered in these mixers. This technique is used to avoid any possibility of audible artifacts caused by truncation of extremely low level data that occurs when signals pass from the 48-bit world of a TDM mixer to the 24-bit
world of a TDM bus connection or a hardware output. Any material that is truncated, lies below –144 dBFs (reflecting 24-bit of dynamic range).

There is dissension in the audio community as to whether or not artifacts that fall within this area are actually audible in some way. (The normal dynamic range of human hearing is generally accepted to fall within a range of around 120 dB, from the threshold of audibility to the threshold of pain.)

Digidesign has developed a mixer that provides all of the benefits of the standard mixer plug-ins, but also provide uncorrelated dither on any summed output. This provides a steady dither “noise floor” at extremely low level, which causes any truncation artifacts to be converted into steady white noise. However, the addition of uncorrelated dither requires more DSP horsepower. As a result, the channel instance count from the dithered versions of the mixers is around 15% lower (or more) than the non-dithered standard versions (this varies with sample rate and mixer type).

For this reason, we offer both types of mixer plug-in. You may wish to use the standard mixer in most applications because of its greater efficiency (allowing you to mix more channels without running out of DSP power), or the dithered mixer because of its theoretical advantages.

A Note About Dithering to 16-Bit and Dither Plug-Ins

The Dithered mixers provide 24-bit dither at their summing points. When creating a final mix that results to 16-bits (for example, for CD mastering), final dithering should still be handled by plug-ins that provide dither (such as the Digidesign standard or POWr Dither Plug-Ins). A plug-in of this type is inserted on the post-fader inserts of a Master fader to properly dither the final mix result. Details about dither and proper usage of the dither plug-ins can be found in the DigiRack Guide.

TDM Mixer Plug-Ins
(TDM Systems Only)


In most cases, the Mixer plug-in that was automatically installed with your system is the best one for all around use. The Mixer plug-in that is installed depends on which Pro Tools system you have:

Pro Tools|HD Systems Only The Stereo and Surround Mixer plug-ins are installed by default. When you run your Pro Tools Installer, a copy of the Stereo Dithered and Surround Dithered mixers are placed in the folder “Plug-Ins (Unused).”

Pro Tools|24 MIX Systems Only The 24-bit Optimized Mixer and Surround Mixer plug-ins are installed by default. When you run your Pro Tools Installer, a copy of the 16-bit Optimized Mixer is placed in the folder “Plug-Ins (Unused).”

Pro Tools|24 Systems Only The 24-bit Optimized Mixer is installed by default. When you run the Pro Tools Installer, a copy of the 16-bit Optimized Mixer is placed in the folder “Plug-Ins (Unused).”
Plug-In Features

Standard Surround and Stereo Mixers
(Pro Tools HD-Series Only)

Both the Surround and Stereo Mixer plug-ins provide the following:

- 24-bit digital output, from an audio interface output or Bounce to Disk. Mix level scaling stores 48-bit results, using a 56-bit accumulator for maximum precision.
- 48 dB of mix headroom.
- Output clip indication.
- Multichannel mixing formats for surround (available with the Surround Mixer).

Surround Dithered and Stereo Dithered Mixers
(Pro Tools HD-Series Only)

Both the Surround and Stereo Mixer plug-ins provide the following:

- The same features as the standard HD Stereo and Surround mixers, with the addition of non-correlated dither to any output or bus send.

Surround and 24-Bit Optimized Mixer
(Pro Tools MIX-Series and Pro Tools|24 Only)

Both the 24-bit Optimized Mixer and the Surround Mixer plug-ins provide the following:

- Optimized performance for recording and mixing 24-bit audio.
- 24-bit digital output, from an audio interface output or Bounce to Disk. Mixing level scaling stores 48-bit results, using a 56-bit accumulator for maximum precision.
- 30 dB of mix headroom.
- Input and Output clip indication: Master Fader meters simultaneously indicate clipping at both the input summing stage and the output level stage.
- Multichannel mixing formats for surround (available with the Surround Mixer on Pro Tools MIX-series systems only).

16-bit Optimized Mixer
(Pro Tools MIX-Series and Pro Tools|24 Only)

The 16-bit Optimized Mixer provides:

- Optimized performance for recording and mixing 16-bit audio.
- 24-bit digital output mix result from an audio interface output, or when bouncing to disk.
- More mixing channels (On TDM systems, 36 x 2 mixing channels can be created per DSP).
- 18 dB of mix headroom.
- Output clip indication: Master Fader meters indicate clipping at the input summing stage only.

Switching TDM Mixer Plug-Ins

To Switch TDM mixer plug-ins:

1. Quit Pro Tools.
2. Open the DAE Folder. The DAE folder is installed at the root level of the System Folder.
3. Open the “Plug-Ins (Unused)” folder, locate the Mixer plug-in that you want to use, and drag it to the Plug-Ins folder.
4. Open the Plug-Ins folder, locate the mixer plug-in version that you no longer wish to use, and drag it to the “Plug-Ins (Unused)” folder.
5. Launch Pro Tools.
Mixer Usage Guidelines

The following conditions apply to mixing with Pro Tools TDM systems.

- One DSP chip is automatically dedicated to mixing in the TDM environment.
- As you reach the basic mixer limits for a single DSP chip, the system will automatically begin allocating DSP resources from another chip (if available), making it unavailable for plug-ins.
- Each bus or send connection requires DSP to mix signals. This means that each send or Auxiliary Input that you create will require DSP power to mix the results.
- On Pro Tools|24 systems, the 16-bit Optimized Mixer can power more channels per DSP chip than the 24-bit Optimized Mixer plug-in. There may be cases where using the 16-bit Optimized mixer will help conserve enough DSP power to allow for additional plug-ins.

On Pro Tools|24 MIX systems, there is no advantage to using the 16-bit Optimized mixer, so you should always use either the Surround mixer, or the 24-bit Optimized mixer.

DSP Usage with TDM Plug-Ins

Some basic guidelines for DSP usage on Pro Tools systems follow:

- TDM-equipped systems running Pro Tools 4.3 or higher software use Digidesign’s MultiShell technology, that lets any MultiShell compatible plug-in share DSP chips on both HD Core and Process cards (in an HD-series system), or both MIX cards and DSP Farm cards (in a MIX-series system). Up to five types of MultiShell compatible plug-ins can share a single DSP chip.

  Refer to the DigiRack Plug-Ins Guide for details on MultiShell plug-ins.

- Stereo DSP plug-ins generally use up twice as much DSP as mono plug-ins.
- Master Faders don’t require additional DSP. Use them freely to control submix levels, send/bus output levels, and the master output level of your session.

The session templates provided with your system include several useful preconfigured session setups that make efficient use of DSP resources.

If your computer has unused slots, you can always increase your available DSP resources by adding additional HD Process cards (to an HD system), or MIX Farm or DSP Farm cards (to a Pro Tools MIX-series system or Pro Tools|24 system).
DSP Usage and I/O Allocation

On TDM-equipped Pro Tools systems with a single audio interface, at least one DSP chip on your HD card (Pro Tools HD systems), MIX card (Pro Tools|24 MIX systems) or DSP Farm (Pro Tools|24) is automatically allocated to mixing and input and output tasks. See “Mixing with Sends and Busses” on page 520 for specifics.

Even though this is only a small portion of the DSP power available on the chip, it effectively dedicates the entire chip to mixing tasks, making it unavailable for plug-ins.

If you have an additional audio interface assigned to an HD Process, MIX Farm, or DSP Farm card, Pro Tools will use a DSP chip on that card for mixing and I/O tasks as well.

If you are not currently using your additional interface, you can free up DSP and use it for additional plug-ins.

To reallocate I/O capacity on an HD Process, MIX Farm, or DSP Farm card:


2. From the Card pop-up menu, select the HD Process, MIX Farm or DSP Farm whose DSP you want to reallocate.

3. From the Interface pop-up, select No Interface.

4. Click OK to close this dialog.

When the session reopens, the DSP that was allocated to I/O is available for mixing or plug-ins.
Appendix C: Troubleshooting

**Backing Up Your Work**

It is highly recommended that you back up your work on a regular basis, and especially before making changes to your system configuration.

**Back Up Your Session Data**

Back up your session and audio data frequently. There are a variety of media that are suited to back up projects of various sizes, from automated tape backup systems to high-capacity optical drives, to desktop CD-R burners.

The best way to back up a session is to use the Save Session Copy In command to save the session file and all of its associated files to a new location.

**Back Up Your System Setup**

- **Macintosh** Back up your System Folder before upgrading your OS.
- **Windows** Create a system recovery disk after you have finished configuring your system and installing software. This is more useful than a recovery disk for an unconfigured system.

**Common Issues**

**Pro Tools Won’t Launch**

**Problem:**

When you double-click the Pro Tools application or a Pro Tools session file, Pro Tools doesn’t launch.

**Possible Solutions:**

- (TDM systems only) Turn off your computer and check to be sure your cables are properly and securely connected to the correct Pro Tools cards and to your audio interfaces.
- (Digi 001 systems only) Turn off your computer and check to be sure your cable is properly and securely connected to the Digi 001 PCI card and to the Digi 001 I/O Box.
- Turn off your computer and check all Pro Tools cards installed in your computer to be sure they are properly seated in their PCI slots, and that any TDM ribbon cables are connected properly.
- Verify that Pro Tools cards are installed in the correct slot order in your computer or Expansion Chassis.
- Check to be sure your computer has the required amount of RAM to launch Pro Tools.
(Macintosh Only) Verify that the DAE application is installed in the proper location. It should be in the DAE Folder inside your System Folder. If DAE is not installed in the proper location, use your Pro Tools Installer disc to install it.

(Macintosh Only) Verify that the DigiSystem INIT file, and other essential files are installed in the Extensions folder, inside the System Folder. If these Pro Tools files are not installed, Pro Tools will either not launch or give an error message. On Pro Tools|HD systems, these include: DSI, DHS.shlb, Digidesign®DSP Manager, Digidesign® Stream Manager, and Digidesign®Direct I/O. If any of these files are not present, use your Pro Tools Installer disc to install them.

(Macintosh Only) Verify that Virtual Memory is turned off. On the Macintosh, open the Memory Control Panel. If Virtual Memory is turned on, turn it off and restart your computer.

Problem:
You get an error message when you try to start the Pro Tools application.

Possible Solutions:
- (Macintosh) Make sure the default set of Mac OS System Extensions is enabled, along with the Open Music System (OMS), DigiSystem Init, Direct I/O, and DSP Manager Extensions.
- Try a complete restart. (Turn off your audio interfaces, computer peripherals and your computer, and then turn them on again in the proper sequence.)
- Use the DigiTest application (installed in the Pro Tools Utilities folder) as a diagnostic tool to verify that your Digidesign cards are operational.

### Audio Interface Isn’t Recognized
(TDM Systems Only)

Problem:
When you launch Pro Tools it does not recognize an audio interface, or a connected audio interface is not available.

Possible Solutions:
- Turn off your computer and check to be sure your cables are properly and securely connected to the correct Pro Tools cards and to your audio interfaces.
- Verify that your Hardware Setup is correct; check to see that you have selected the correct Interfaces for each I/O card.
- If you only have one interface, make sure it is connected to the HD Core card (Pro Tools HD-series system), MIX Core card (Pro Tools MIX-series system), or d24 card (Pro Tools 24).
- Make sure SuperClock or other synchronization connections to your audio interface are correct. Disconnect the SuperClock source from the interface and see if the problem persists.

### Using DigiTest as a Diagnostic Tool

The DigiTest utility performs diagnostic tests on the Pro Tools cards in your system. If DigiTest reports that any of your cards have failed, click the Info button next to that card. Write down the information that appears and report it to your local Digidesign dealer or a Digidesign Technical Support Representative.

Refer to your Getting Started Guide for the specific DigiTest instructions.
Performance Factors

There are several conditions that may adversely affect the performance of Pro Tools. These include:

**Network Connections** Close any network connections unless you are using them for network interchange of audio data.

**Background Applications** Any software utilities that run in the background or generate disk activity, such as virus protection software, disk optimizing, or file savers, should be turned off or removed.

**Screen Savers** Screen saver software should be completely removed from your computer before running Pro Tools.

**Power Saver Features** Some automatic power saver features, such as those that spin down the system hard drive, can affect Pro Tools performance. These features should be turned off.

**Virtual Memory** (Macintosh Only) Pro Tools will not launch if Virtual Memory is active. Deactivate Virtual Memory and restart your Macintosh.

**CD-ROM Extensions/Control Panels** Some CD-ROM and removable media Extensions and Control Panels have been linked to audio quality problems. Deactivate any performance-enhancing Extension or Control Panels for such media, and restart your computer.

Before You Call Digidesign Technical Support

**Register Your System**

As a registered owner of a new Digidesign product under warranty, you are eligible to receive Digidesign Technical Support. Fill out and sign your Registration Form and mail or fax it to the address supplied with the registration materials.

Refer to the registration materials that came with your system for details on warranty coverage and the range of services available.

**Use Digidesign Resources**

In addition to the printed and PDF versions of Pro Tools Guides, your system includes the following sources of information:

**Read Me files** These contain late-breaking information and known issues pertaining to Pro Tools software and hardware configurations. ReadMe files are installed in the *Release Notes and Documentation* folder when you install Pro Tools.

**Answerbase** This is a database of common problems and DAE errors, and their solutions based on the latest information from Digidesign Technical Support. This database is installed in the Digidesign folder when you install Pro Tools. Answerbase is also available on the Digidesign Web site (www.digidesign.com). Go to: Support > Tech Support > Answerbase.

**Web site** The Digidesign Web site includes an area for Technical Support, as well as a Digidesign User Conference (DUC) that includes technical discussions. Visit www.digidesign.com and go to the Support area or the User Conference area: Support > Tech Support > Digidesign User Conference (DUC).
**Gather Important Information**

Digidesign wants to help you resolve problems as quickly and efficiently as possible. If you have the following information handy when you contact Technical Support, it will make the diagnosis of your problem easier. Take a few minutes to collect this basic information in one place.

**System Information**

**Computer**
- Make, Model, processor speed
- Amount of system RAM
- Operating system (version of Mac OS or Windows)
- Any Drivers, Extensions, Control Panels, Disk Utilities, or other system-related applications you may have installed.

**Digidesign Hardware**
- Type of cards, interfaces, or peripherals
- Where the cards are installed
- PCI card order in computer or chassis
- Interfaces connected to each card

**Hard Drives**
- Make, Model
- Drive size (GB)
- Speed (RPM)
- Type of SCSI Connection (narrow, wide)
- Utility used to format the hard drive
- Partitioning

**Digidesign Software**
- Pro Tools software version
- (Macintosh) DAE and DSI versions
- Plug-in versions
- Other Digidesign software

- Additional plug-ins from Digidesign Development Partners

**Other Hardware**

If using additional hardware, refer to the manufacturer's documentation for operational details.

The most common hardware additions include:
- SCSI Accelerators (manufacturer, model, settings)
- Expansion Chassis (manufacturer, model, bridge chip type)
- Video Capture cards (manufacturer, model)

Refer to Digidesign’s compatibility documents, visit www.Digidesign/compato, or contact your Digidesign dealer to verify that the hardware is qualified for use with your Pro Tools system.

**Other Software**

If you are using other audio or video applications, refer to the manufacturer’s documentation for operational details.

Make note of any other software that were running when a problem occurred.

**Diagnostic Information**

**DigiTest**

If you ran DigiTest on your system and it generated any errors, be sure to make a note of any error codes or messages.

**Other Information**

Note any DAE errors or other error codes you encounter. Also make a note of the ability to reproduce the problem under different conditions, such as with another session, or after changing settings such as the DAE Preferred Memory Size (Macintosh) or the Hardware Buffer Size (Pro Tools LE).
Glossary

9-pin (Sony 9-pin; DB-9) Industry standard for serial machine control of professional video and audio transports, made by Sony and other manufacturers. Refers to the DB-9-style physical external control connector found on 9-pin-compatible devices.

A/D conversion Analog-to-digital converters operate at various bit-rate resolutions and sampling rates.

address (time code address) Specific SMPTE/EBU time code reference or reading, in hours:minutes:seconds:frames.

ADAT lightpipe Industry standard term for optical connection of digital audio. Created by Alesis, the lightpipe can simultaneously stream eight channels of digital audio.


AIFF Audio Interchange File Format, an Apple Computer audio file format.

ATR Audio Tape Recorder, of any format, including a Digital Audio Tape (DAT) deck.

audio interface Among most Pro Tools systems, the audio interface is a separate box that is attached with a special cable to the audio card. An audio interface typically has analog and digital audio inputs and outputs, and may be equipped with level meters, level controls, and other features.

audio region A region of an audio file that is defined non-destructively with pointers. See region.

Audiomedia III Digidesign’s entry-level PCI card for Pro Tools, includes S/PDIF and stereo analog inputs and outputs.

AudioSuite plug-in Digidesign’s proprietary file-based, non-real-time plug-in format. AudioSuite processing creates a new audio file with the effect permanently applied.

audition Listening to, or “monitoring,” one or more tracks or audio files. In Pro Tools you can audition files before you load them into the program. There are also various ways to audition takes from the Audio Regions List and from the Takes List pop-up menu.

auto-created region Automatically-created regions are a by-product of editing and punch recording over existing regions.
Automation modes  Function for the recording and playing changes in levels, pan controls, and virtually every adjustable parameter (including plug-in elements) in Pro Tools. There are several different automation modes in which to write automation data in Pro Tools.

aux  See auxiliary I/O.

auxiliary I/O  Input and output channels used for internal or external bussing of signals in ways other than through the standard input and output of a channel strip.

auxiliary send  See send.

AVoption  PCI cards and software that integrates Avid video technology with Pro Tools.

AVoption|XL  PCI card, video interface, and software that integrates Avid video technology with Pro Tools.

.AVI  Movie file format for the Video for Windows component of Microsoft’s Media Player, supported by Pro Tools.

bit depth  One of two main specifications that define digital audio quality (the other is sample rate). Bit-depth defines how precisely a sound’s dynamic range is represented. Also called bit-resolution or bit-rate.

BNC  Coaxial cable connectors used for video and synchronizer signals.

Bounce To Disk  Mixing a segment of audio (on an entire session) internally to disk, without leaving the digital domain. Bit rate, dithering options and other parameters are provided by Pro Tools for bouncing to disk.

breakpoint  Step or level on a track's automation playlist.

bus  Carries signals from several outputs to a single path.

crossfade  Function for fading out from one region as you fade in to another region. Crossfade types and duration are user selectable from within the Edit window. As with fades, portions of audio for which the crossfade function has been applied are stored in the session’s Fade Files folder.

d24  Digidesign’s 24-bit TDM interface card, needs a DSP Farm card to create a Pro Tools|24 TDM system.

DAE (Digidesign Audio Engine)  Digidesign’s real-time operating system that provides the core functionality of hard disk recording, digital signal processing, mix automation, and MIDI required by Pro Tools and other Digidesign products.

DB-9  See 9-pin.
**Digidesign Audio Engine** See DAE.

dither “Noise” added to an audio signal when down-sampling bit rates. Designed to create a smoother transition at lower amplitudes instead of simply “chopping” off lower bits.

drop frame Refers to a variance of SMPTE/EBU time code for NTSC color video (29.97 fps) that omits two frames (frames “0” and “1”) every minute except for every tenth minute.

DSP Digital Signal Processing. In audio terms, DSP refers to manipulation of digital audio—everything from reverberation to changes in level.

DSP Farm PCI card containing DSP chips, the basic building blocks of a Pro Tools|24 TDM system.

Edit cursor Flashing line that appears when you click on a track in the Edit window.

edit decision list (EDL) List of edits, or events, typically with each event’s respective source in and out times, source reel number, and record in and out times.

Edit insertion point Location within a track where you click (without dragging); also location at which a region’s start, end, or synchronization point will be placed.

Edit selection In the Edit window, the actual region highlighted when you make a selection is called the Edit selection, which can be unlinked from Timeline selection. See Timeline selection.

Event List See MIDI Event List.

expansion chassis Expands the capabilities of Pro Tools TDM systems running on Macintosh computers by adding more external PCI slots.

ExpressPro-Tools ATTO’s hard disk utility for the preparation of hard drives for Pro Tools.

fade A selection in which the volume rises or falls, typically from or to $-\infty$. See crossfade.

frames per second (fps) Number of frames that elapse per second, as defined by the four SMPTE/EBU Time Code fps standards. These include:
- 24 fps (for film applications);
- 25 fps (the PAL/SECAM video standard);
- 29.97 fps (the NTSC color video standard) (also see Drop-Frame);
- 30 fps (the NTSC black and white video standard).

Grid mode Used to align regions in tracks to the nearest unit of a user-defined value. When Grid mode is on, the Selector will “snap to” the currently selected grid value, and regions placed in the Edit window will also line up with the selected value.

groups Linked tracks in which an action in the I/O section of one of the tracks is mirrored in all tracks in the group. Groups can be created separately or linked between the Edit and Mix windows.

HD Core PCI card which connects to audio interface and contains the DSP for a basic Pro Tools|HD TDM system.

headroom Amount of remaining gain available for a given signal before the onset of unacceptable distortion.

HD Process PCI card with additional DSP for Pro Tools|HD systems.
**latency** Time delays inherent in internal processing or generation of audio signals within a computer.

**lightpipe** See ADAT Lightpipe.

**Loop Sync** Loop Sync is a dedicated clock loop for synchronizing multiple HD-series interfaces together. Loop Sync uses a word clock signal based on sampling rates of either 44.1 kHz or 48 kHz. As sample rates increase in the system, Loop Sync continues to operate at a base rate of 44.1 kHz or 48 kHz, depending upon the higher rate. Loop Sync should only be used to chain multiple HD-series peripherals together.

**Machine Control** Pro Tools functions to control or be controlled by an external transport, typically a VTR or ATR.

**Marker** Memory Location referenced on a timeline, typically used to store locations to important points in a session. See Memory Location.

**master** “Lead” machine or Pro Tools System in a synchronized machine arrangement. Slaves follow masters. There can only be one master at any given time.

**Master Fader track** Governs the overall output of one or more tracks.

**Memory Location** Pro Tools supports up to 200 Memory Locations, which can include markers, Edit selections, record and play ranges, track settings, and other data. They can be viewed and sorted in the Memory Locations window, from which they can also be accessed.

**MIDI Event List** Pro Tools window that shows the contents of a MIDI track in a column, for easy editing of individual MIDI events.

**MIDI Machine Control** See Machine Control.

**MIDI Time Code** See MTC.

**MIX Core** PCI card which connects to audio interface and contains the DSP for a basic Pro Tools|24 Mix TDM system.

**MIX Farm** PCI card with additional DSP for Pro Tools|24 MIX systems.

**MP3** The MPEG Layer 3 compression format is an adjustable-quality audio compression format, developed by the Fraunhofer Institute. The MP3 encoder file is stored in the Codecs folder in the DAE Folder.

**MTC (MIDI Time Code)** Non-SMPTE form of time code that is used by some devices to send and receive timing information.

**non-drop frame** Time code that is not in drop-frame format. In the United States, the standard format outside of color video production or post production is typically 29.97 fps non-drop frame.

**nondestructive editing** Leaves audio files intact. As you edit audio within Pro Tools, all you are editing are the regions, or “pointers,” to audio files that are stored on the hard drive.

**NTSC** Video standards developed by the National Television Standards Committee. NTSC color video runs at 29.97 frames per second; NTSC black and white video runs at 30 fps. Used primarily in North and South America and Japan.

**OMS** Open Music System, developed by Opcode. OMS is a “MIDI operating system” for Macintosh computers. It handles the exchange of MIDI data between applications, including timing signals such as MTC.

**PFL (pre fade listen)** Sometimes called a “cue,” this is a channel’s level before it is attenuated or boosted by the fader setting. Master faders are PFL in Pro Tools. See pre fader.
**peak indicator** Indicator light designed to warn of the possibility of clipping, which illuminates as a device's input reaches a preset degree of headroom.

**playlist** List of edits and files available in the current session.

**positional reference** Common reference that provides location information that various devices can use to establish synchronization during playback and recording. Most commonly, the information is delivered in the form of SMPTE/EBU Time Code.

**post-fader** Output from a track (typically a send) that is governed by the channel's fader setting.

**preamp** In recording studio terminology, a circuit designed to boost relatively low signal levels, such as a microphone output, up to standard line levels of –10 dBu or +4 dBu. Digi 001 is equipped with two microphone preamps.

**pre-fader** Output from a track (typically a send) that is independent of the channel's fader setting.

**pre-roll** Adjustable time which precedes the playback or recording of a selection, in conjunction with Transport, Audition, Online, and QuickPunch functions.

**Post Up/Post Down** Refers to the deliberate “mis-calibration” of the audio sample rate clock (the audio pitch) in order to compensate for a speed change elsewhere in the production chain. The usual situation in which these rates are encountered is when film footage (at 24 fps) is transferred to color NTSC-standard video tape (at 29.97 fps).

**quantize** To adjust MIDI note locations or durations to the nearest unit or template structure so that particular rhythmic “feel” is achieved.

**QuickTime** Apple's system extension for control of time-based events, such as digitized video movies and digitized sound.

**RealAudio** Audio compression scheme designed for streaming over the internet.

**region** Within Pro Tools, a region is a “pointer” to a particular track selection or file. Regions can be dragged from the Regions List to a track.

**resolving** The process of synchronizing one device to another; more specifically, resolving refers to synchronizing a device's clock to an external clock reference.

**RTAS plug-in** Real-Time AudioSuite plug-ins are Digidesign’s host-based, real-time effects plug-in format.

**sample rate** One of two main specifications that describe digital audio quality (the other is bit rate resolution). Sample rate refers to how frequently incoming audio is sampled per second during conversion from an analog to a digital signal.

**SCSI HBA** Acronym for Small Computer System Interface (SCSI) and Host Bus Adapter (HBA), Digidesign's conformed terminology for SCSI cards. SCSI is a type of data bus allowing for the
high speed transfer of data between a computer and peripheral devices. An HBA is the card that connects the SCSI bus between the computer and peripheral devices such as hard drives.

**send** An adjustable bus from a track, which can be routed to effects processors, auxiliary monitor mixes, and signal grouping.

**session** Work file, much like a word processing document or a graphics program file. A Pro Tools session consists of audio and MIDI files, and related data such as fades, playlists, and selections. Each separate project you work on should be stored as its own session.

**slave** Device that “follows” the master during synchronization.

**Slave Clock** Slave Clock (or Super Clock) is Digidesign’s proprietary hi-speed Word Clock that runs at 256x the sample rate. It is required by Pro Tools|24 MIX and Pro Tools|24 systems to synchronize audio interfaces to a single, highly-accurate clock from SYNC I/O.

**Sound Designer II (SDII) file format** Digidesign’s high-quality digital audio file format.

**S/PDIF** Semi-professional version of the AES/EBU standard. Stands for “Sony/Philips Digital Interface Format.” Most S/PDIF connections utilize RCA in/out connectors, carrying two channels of digital audio at a time.

**Spot mode** Audio post production process of aligning audio events to visual events. Spot is the Edit mode that allows you to spot regions to particular time code events.

**Standard MIDI File** Universal format that can be read by virtually any software that reads MIDI. Type 0 is a single line sequence, type 1 is multi-track.

**submix; subgroup** See groups.

**Super Clock (256x)** Digidesign’s proprietary version of word clock; used as a clock reference. All Digidesign TDM audio interfaces, and several other Digidesign products (including the SYBC I/O, Universal Slave Driver, the ADAT Interface, the SMPTE Slave Driver, and the Video Slave Driver) are equipped with BNC-style Super Clock inputs and outputs.

As with word clock, Super Clock is a clock signal that can be passed between devices independently of the audio signal. Since it runs at 256x sample rate (instead of word clock’s 1x sample rate), Super Clock is inherently more precise than Word Clock.

**synchronization** Process of having two or more audio, video, or other devices run together at exactly the same speed (usually during playback, though sync during record, fast-wind, and “crawls” is possible).

**syssex (System Exclusive)** MIDI data specific to a particular piece of hardware or instrument.

**TDM** Time Division Multiplexing technology employs a networked bus of DSP chips that supply the processing power for Pro Tools TDM systems.

**TDM plug-in** Digidesign’s proprietary real-time, non-destructive plug-in format for Pro Tools TDM systems.

**time code address** See address.

**time code generation** Process of creating “fresh” time code.

**Time Scale** The Main Time Scale is the Timebase Ruler that determines the time format used for Transport functions, and Grid and Nudge values. The Sub Time Scale is the Timebase Ruler that provides additional timing reference.
**Timebase Rulers** Up to five discrete strips measuring different units (samples, feet.frames, minutes:seconds, bars:beats, or time code) displayed across the top of the Edit window.

**Timeline insertion point** Location on the timeline corresponding to the cursor point, and the point from where playback or recording begins.

**Timeline selection** A selection in any Timebase Ruler that determines the playback or record range.

**Universe window** Provides a visual overview of all tracks in a session, and can be used to quickly navigate to any location in a session.

**user-defined region** Explicitly defined regions that are created when recording or importing audio or MIDI; capturing, separating, or consolidating a selection; trimming a whole-file audio region; or renaming an existing region.

**video reference signal** All video signals contain clock information, which can be used as a clock reference.

**voiceable track** Previously known as virtual voicing; total voiceable tracks refers to the maximum number of audio tracks that can share the available voices on your system.

**voices** With a Pro Tools TDM system, this refers to the number of channels that can be played back simultaneously.

**VTR** Video Tape Recorder of any format.

**.WAV** Pronounced “wave”; Microsoft’s Audio File Format. Can be read by Pro Tools on both Macintosh and Windows platforms.

**waveform** Means of visually representing a sound. When sound regions are imported into Pro Tools’s Edit window, they can be viewed in waveform view.

**whole-file audio regions** Created when recording or importing audio, consolidating existing regions, and when processing with an AudioSuite plug-in.

**Word Clock** Many professional digital audio products—including open-reel multitrack tape recorders, digital mixing consoles, and the Tascam DA-88 modular digital multitrack—have Word Clock (1x sample rate) connectors.

Word Clock allows the DA-88 (and other Word Clock-compatible devices) to send or receive external clock information which controls the sample rate, which in turn (where applicable) controls the play and record speed.

**zero crossing** Point at which a wave’s amplitude crosses the center line of the waveform display. Typically a good spot to edit a sound file is at zero crossings, to avoid unwanted artifacts.

**Zoom** Function used to view waveform displays within the Edit window with greater detail.
Index

Symbols
.1 (in surround mixing) 426

Numerics
1622 I/O 6
16-bit
  Bounce to Disk 413
16-bit Optimized Mixer 523
  plug-in features 526
176400 Hz sample rate 413
192 I/O 6
  Hardware Setup 41
  Soft Limit 41
  SR Conversion 41
192000 Hz sample rate 413
  1x 539
  24 FPS 467
  24-bit
    Bounce to Disk 413
    TDM processing 359
24-bit ADAT Bridge I/O 6
24-Bit Optimized Mixer 523
  plug-in capabilities 526
25 FPS (EBU) 467
256x 538
29.97 FPS Drop 467
29.97 FPS Non-Drop 466, 497
3 Second Peak Hold 80
3:2 Pulldown 468
30 FPS Drop 466
30 FPS Non-Drop 466
32-bit, floating 359
3-knob panning 455
3-Second Peak Hold preference 52
44100 Hz sample rate 414
48000 Hz sample rate 414
5.0 paths in 5.1 mixes 445
5.1 formats in Pro Tools 435
882 I/O 6
882|20 I/O 6
88200 Hz sample rate 413
888 I/O 6
888|24 I/O 6
8-bit 413
96 I/O 6
  Hardware Setup 41
  96000 Hz sample rate 413

A
active
  making plug-ins 17, 364
  tracks 90
Active in Background
  for MP3 play 412
active items 16
ADAT Bridge I/O 6
ADAT, synchronizing to 487
adding
  a new playlist 179
  audio tracks 133
  Auxiliary Input tracks 339
  Master Fader tracks 340
  MIDI tracks 153
  Sends 346
AES/EBU
  Hardware Setup 40
AIFF file format 408
All Notes Off command 313
all tracks
  hiding 83
  selecting 205
  selecting all regions in 201
  selecting in Timebase Rulers 205
  showing 83
allocating
  DSP 517, 519
  I/O capacity 528
Amount of Memory for Automation Recording option 56
Amount of Memory to Reserve for Automation Recording option 381
Analog In 41
Analog Out 41
Assignment view
  sends 347
Audio CD Import Options dialog (Macintosh) 103
Audio During Fast Forward/Rewind option 52, 194
audio files
  batch loading with drag & drop 100
  compacting 263
  concepts 12
  default names 123
  formats 407
  importing 95
  locating 109
  mixed file types 47
  mixed formats 96
audio format, for session 475
audio interfaces 8
  input channels 14
audio recording
  undoing a take 134
audio regions 174
  and automation 176
  fitting to an Edit selection 242
  stripping silence from 257
  whole-file 170
Audio Regions Focus 30, 184
Audio Regions List 181
  displaying file info for audio regions 182
  dragging from 216
  finding regions 183
  sorting 182
Audio Regions List menu 494
  Auto Rename Selected command 261
  Clear Selected command 262
  Compact Selected command 263
  Display All command 183
  Export Region Definitions command 102
  Export Selected As Files command 101
  Find command 183
  Rename Selected command 261
  Selected Unused command 262
  Show Disk Names option 182
  Show File Names option 182
  Show Full Pathnames option 182
  Sorting option 182
  Time Stamp Selected command 224
audio tracks
  5.1 format 431
  adding/creating 133
  and Output format 439
  and surround sessions 438
  and tempo changes 267
  bouncing to disk 406
  channel strips 78
  configuring for recording 133
  creating a tempo map for 268
  loop recording 141
  placing audio in multichannel tracks 438
  punch recording 140
  recording multiple 136
  signal flow 338
  Waveform view 171, 174
Audiomedia III 8
  QuickPunch 163
AudioSuite
  Dither 359
  Duplicate plug-in 236
  plug-ins 360
  processing 236
AudioSuite Buffer Size preference 57
AudioSuite Dither preferences 57
audition path 74
auditioning
  fades 247
  pre/post-roll 208
  programs 310
  selection start/end points 208
takes 142
Auto Input Monitoring option 120
Auto Regions Fade In/Out Length option 54, 255
Auto Rename Selected command 261
auto-created regions 170
  hiding 261
  renaming 260
auto-fades 254
AutoMatch Indicators 382
AutoMatch Time option 56, 381
automating
  Plug-Ins 386
  Sends 385
  switched controls 385
  tracks 384
automation 375
  and audio regions 176
  and Duplicate Selected Tracks 377
  and multichannel pan 459
  and multiple output assignments 439
  breakpoints 393
  buffer size 382
  capture & apply 401
cutting, copying, and pasting 395
deleting 388
delta 378
drawing with Pencil 390
inging 391
  editing with Smart Tool 238
  enabling, suspending 387
  for grouped tracks 394
  for hidden tracks 83
  on multichannel tracks 393
On Stop 399
pass-through point 378
playlists 178, 376, 383
plug-in accuracy in bounce 414
relative and absolute 378
safing 383
smoothing 381
snapshot 400
special Paste mode 397
stepped 392
thinning 381, 389
To Current or All Enabled 402
to start, end, or all 397
Trim mode 378
trimming 399
Write Safe button 367
writing 384
Automation Enable window 384, 387
Automation Mode Selector 24, 377
automation modes
  Auto Latch 378
  Auto Off 377
  Auto Read 377
  Auto Touch 378
  Auto Write 377
  Trim/Auto Latch 379
  Trim/Auto Off 378
  Trim/Auto Read 378
  Trim/Auto Touch 379
  Trim/Auto Write 379
Automation Preferences 56
  Amount of Memory to Reserve for Automation
  Recording option 381
  AutoMatch Time option 381
  Degree of Thinning option 381
  Faders Move During Playback option 380
  LFEs Follow Groups option 381
  Memory for Automation Recording option 382
  Mutes Follow Groups 380
  Mutes Follow Mix Groups option 88
  Send Levels Follow Groups option 380
  Send Mutes Follow Groups 380
  Smooth and Thin Data After Pass option 380,
  389
  Solos Follow Groups option 380
  Solos Follow Mix Groups option 89
  Touch Timeout option 381
Automation Safe Button 367
Automation Write Safe button 370
Auto-Name Memory Locations While Playing option
  55, 277
Auto-Name Separated Regions option 55, 214
auto-naming
  and Strip Silence 258
  audio files and regions 123
  playlists 179
  QuickPunch regions 164
  separated regions 214
takes 123
  tracks 122
AutoSave option 53
Auto-Spot Regions command 493
auto-voiced tracks 86
Auxiliary Inputs 353
  adding 339
  and DSP usage 527
  signal flow 338
Auxiliary Send level, and Master Fader 356
Avid Compatibility Mode option 58
  and Bounce to Disk 407

B
  bank select 19, 306
Bar|Beat Markers
  and tempo events 270
  audio with varying tempos 269
  editing 270
  from Identify Beat command 268
  generated with Beat Detective 290
  moving 270
Bars:Beats Time Scale 190
bass
  extension 430
  management 427, 429
  redirection 430
  sub content 427
Batch Fades dialog 255
Beat Detective 283
  beat triggers 288
  Collection Mode 294
  conforming regions 292
  defining the selection 286
  detecting transients 287
  edit smoothing 293
  generating Bar|Beat Markers 290
  separating regions 291
  sync points 291
  system requirements 283
  Trigger Pad 291
  with multiple tracks 291
Beat Detective window 285
  beat triggers, editing 288
Bi-Phase/Tach 466
  bit depth, for session 44, 474
  black burst 497
Blocks view 171

Bounce to Disk 403, 406
  and dither 404
  and time stamps 406
Bounce Options 407
  Convert After Bounce 414
  Convert During Bounce 414
  File Type 407
  Format 412
  format 407
  Help button 414
  Resolution 413
  Sample Rate 413
  sample rate conversion options 413
  Sample Rate Conversion Quality 414
  source path 407
  Use Squeezer option 414
Bounce to Movie command 508
bouncing
  to a stereo mix 416
  to a submix 415
  to QuickTime movies 508
breakpoints 393
Buffer Size
  DAE Playback Buffer 37
  Hardware 121
bussing
  multichannel sends 441
  surround examples 445
Bypass Button
  for real-time plug-ins 366

C
  Calculator mode for numeric entry 204
  Calibration Mode command 118
  Calibration Reference Level preference 54
  cancelling record takes 135, 155
  Capture Region command 213
  capturing time code 492
  CDs, importing audio from 102
  Center % (Percentage) 457
  Center % in Output window 458
  centered crossfade 246
  Change Duration command 324
  Change Meter command 271
  Change Tempo command 265, 266
  Change Velocity command 322, 323
  Channel Delay Indicator 79
channel mapping
  default path order 75
  editing 67
  re-mapping 68
Channel Selector 367
  for multi-mono plug-ins 442
channel strips 14
  audio tracks 78
  MIDI tracks 79
channels inputs 14
chasing
  controller events 311
  MIDI notes 311
  program changes 311
Cinema Stereo 422
Classic Numeric Keypad Mode 31, 53
Clear command 230
Clear Selected command (regions) 262
click 27
  configuring 128
  enabling 129
Click Options command 128
  Click/Countoff Options dialog 128
clicks and pops, avoiding 175
clipping 117
  and 16-bit Optimized Mixer 523
  and 24-bit Optimized Mixer 523
  input sum levels 524
clock source 373
Clock Source pop-up menu 40
Close Session command 50
closing multiple Plug-In windows 367
CM Labs MotorMix 358
Collection Mode, Beat Detective 294
Commands Focus 30
Comments View 80, 342
comments, entering for tracks 81
Compact Selected command 263
Compare button 366
compatibility
  surround formats 428
Compatibility Preferences 57
Compress/Expand Edit To Play command 241
  and multichannel tracks 242
compressed QuickTime file formats 506
Conductor button 28
Conductor Rulers 189
  including in selections 205
configuring
  click options 128
  MMC 485
  Pull Up/Down 480
  SMPTE 478
conforming QuickTime movies 505
connecting
  effects units 372
  external audio devices 371
Consolidate Selection command 260
Continuous Scroll During Playback option 196
  and half-screen 196
Continuous Scroll with Playhead option 196
  and half-screen 196
continuous zoom 187
control surfaces 358
  EditPack 358
  ProControl 358
Control|24 358
controller events 19, 305
  and MIDI regions 178
  chasing 311
  editing 306
  editing with Smart Tool 238
  inserting 306
Conversion Quality option 55, 103, 414, 507
  Tweak-head setting 414
Convert .WAV files to AES31/BroadcastWave
  option 57
Convert Plug-In pop-up 367
Convert WAV files to AES31/BroadcastWave 110
converting session
  audio file format 46
  bit depth 46
  sample rate 46
Copy command 230
Copy Edit Selection to Timeline command 210
Copy Timeline Selection to Edit command 210
Copy To Send command 386
Copy To Send dialog 386
copying
  all automation playlists for a track 232
  MIDI notes with the Split command 317
  selections and regions 230
  track automation to Sends 386
  track control settings to Sends 353
countoff 27, 129
CPU Processing Activity 382
CPU Usage Limit 38
Create Fades command 252, 253
creating
crossfades 252
fade-ins/outs 253
groups 93
Markers and Memory Locations 276
regions 213
sessions 213
tracks 81
Crossfade Preference for Pre/Post-Roll option 55, 251
crossfades 245
and dither 360
creating with Smart Tool 237
equal gain 249
equal power 249, 251
Fades dialog 246
in batches 255
linear 251
overlap 251
pre/post 252
removing 252
trimming 252
types 245
with dither 249
Current Cursor Display 24
location 25
current meter 28, 271
current tempo 28, 265
Current Time 475
custom sample rates 414
Cut command 230
cutting
automation 395
MIDI notes with the Split command 317
selections and regions 230
default
audition path 74
I/O Setup 71
meter 129
output path 73
path order 75
paths 65
program change 308
tempo 130, 268
track names 122
Default Fade Settings 55
Default Note On Velocity option 58, 300
Default Settings preference 57
Default Thru Instrument 151
Degree of Thinning option 56, 381
delay
Channel Delay Indicator 79
MIDI Track Offset 312
Delay plug-ins 361
Delete Fades command 252
Delete Path 67
Delete Selected Groups command 93
Delete Selected Tracks command 82
deleting
automation 388, 395
existing I/O paths 67
groups 93
in MIDI Event List 333
Memory Locations 279
MIDI notes 304
playlists 180
program changes 310
sysex events 311
tracks 82
underlying region data 231
unused regions 262
delta
trimming automation 378
destructive editing
compacting audio files 263
Destructive Record mode 126, 138
destructive recording 138
Digi 001 8
modes and I/O Setup 66
punching with footswitch 161
QuickPunch 163
Digidesign Audio Engine 11
digital clipping 117

D

d24 audio card 6
DAE 11
DAE Playback Buffer Size 37
DAT recorder, recording from 165
Digital Format 40
digital master clock 373
digital mastering 416
digital signal processing (see DSP)
DigiTest 530
Direct I/O 530
discrete signal control 438
Disk Allocation 124
and cross-platform sessions 124
and system volume 125
dialog 123
Display All command 183
Display Auto-Created Regions option 261
Display menu
Bars:Beats Time Scale 190
Display Auto-Created Regions option 261
Display Name In Regions option 174
Display Time In Regions option 174
Edit Window Shows option 21
Feet.Frames Time Scale 190
Minutes:Seconds Time Scale 190
Mix Window Shows option 21
Narrow Mix Window option 90
Ruler View Shows option 189
Samples Time Scale 190
System Usage Window Shows 518
Time Code Time Scale 190
Display Name In Regions option 174
Display Preferences 51
Draw Grids in Edit Window option 186
Draw Waveforms Rectified option 51, 174
drum machine style loop recording 157
DSP 517
active and inactive items 16
allocating 517, 519
and Auxiliary Inputs 527
and I/O capacity 528
and inactive outputs 345
and inactive sends 348
and Master Faders 527
and mixing 518
and no output 345
and overall resources 16
and Send meters 348
and TDM Plug-Ins 527
I/O and Mixer plug-ins 522
monitoring usage 518
reclaiming DSP capacity 518
DSP delays 511
compensating for 513
DSP Farm card 6
DSP Manager 518
DTS 422, 426
Duplicate command 233
Duplicate plug-in 236
Duplicate Selected Tracks for automation 377
Duplicate Selected Tracks command 82
duplicating
MIDI note selections 233
playlists 179
selections and regions 233
dither
and Bounce to Disk 404
and fades 249, 360
AudioSuite 359
on Master Faders 404
preferences 360
resolution and Bounce to Disk 413
Dither Plug-In preference 57
divergence
and width 427
drawing 458
using 457
Dolby Digital 426
Dolby EX 422
Dolby Surround 422
duplicate
all regions 183
all Rulers 189
file info for audio regions 182
Meter Ruler 271
Original Time Stamps 494
region names 174
region times 174
Tempo Ruler 265
User Time Stamps 495
durations, for MIDI notes
  editing with Change Duration command 324
  making more legato 325
  making more staccato 325
  randomizing 325

dynamic voice allocation 87
Dynamics plug-ins 361

E
Edit and Timeline selections, unlinked 199
Edit commands 229
  and Edit mode 230
  clear 230
  cut 230
  paste 231
edit commands
  clear 230
edit cursor 193
  and scrubbing 196
  moving to region boundaries 206
Edit Dither Settings preference 57
Edit Group 93
Edit Groups
  and selections 200
Edit Insertion Follows Scrub/Shuttle option 52, 196
Edit insertion point
  placing regions at 217
  trimming regions to 220
Edit Markers 199
  and selection length 203
Edit menu
  Capture Region command 213
  Clear command 230
  Compress/Expand Edit To Play command 241
  Consolidate Selection command 260
  Copy command 230
  Copy To Send command 386
  Create Fades command 252, 253
  Cut command 230
  Delete Fades command 252
  Duplicate command 233
  Fade To End command 254
  Fade To Start command 254
  Fades command 246
  Heal Separation command 216
  Identify Beat command 268
  Identify Sync Point command 221, 495
Insert Silence command 259
  Lock/Unlock Regions command 228
  Merge Paste command 234
  Mute/Unmute Region command 228
  Paste command 231
  Quantize Regions command 228
  Redo command 180
  Remove Sync Point command 221
  Repeat command 233
  Repeat Paste To Fill Selection command 241
  Select All command 200
  Separate Region command 213
  Shift command 227
  Strip Silence command 257
  Thin Automation command 390
  Trim Automation command 402
  Trim End To Insertion command 220
  Trim Start To Insertion command 220
  Trim To Selection command 215
  Undo command 180
  Write Automation command 400, 401
Edit mode buttons 185
Edit modes 185
  and edit commands 230
  and placing regions 216
  Grid 185
  Shuffle 185
  Slip 185
  Spot 185, 491
edit playlists 178
Edit selections
  auditioning with Playhead enabled 211
  copied from Timeline selection 210
  copied to Timeline selection 210
  sliding in the Ruler 207
edit smoothing, with Beat Detective 293
Edit tools 24
  Grabber 201
  Pencil 236
  Scrubber 196
  Selector 193
  Smart Tool 237
  Trimmer 218
  Zoomer 186
Edit window 23
  half-screen 196
  scrolling from the Ruler 195
Edit Window Color Coding option 52, 91
Edit Window Default Length option 51
Edit Window Follows Bank Selection option 51
Edit Window Shows option 21
editing
across multiple tracks 232
and Edit modes 185
and hidden tracks 83
automation 391
Bar|Beat Markers 270
beat triggers 288
breakpoints 393
controller events 306
during playback 169
Grid mode 185
in MIDI Event List 332
Markers 278
Memory Locations 278
meter events 272
MIDI notes 301
MIDI regions 177
non-destructive 169
non-destructively for audio 176
non-destructively for MIDI 178
note attributes 304
note durations 324
note velocities 303, 322
program changes 309
Shuffle mode 185
Slip mode 185
Spot mode 185
tempo events 266
waveforms 175
Editing Preferences
Auto-Name Memory Locations While Playing option 277
Auto-Name Separated Regions option 214
Conversion Quality option 103
Crossfade Preference for Pre/Post-Roll option 55, 251
QuickPunch Crossfade Length option 161
Region List Selection Follows Track Selection option 182, 207
Separate Region Operates On All Related Takes option 143, 214
Take Region Lengths That Match option 143
Take Region Names That Match Track Names option 143
Track Selection Follows Regions List Selection option 207
EditPack 358
effects, printing to disk 403
Enable Automation Parameters Button 367, 370
Enable Autosave option 53
enabling
automation 387
groups 94
MIDI input devices 150
encoding and decoding 429
Enforce Mac/PC Compatibility option 47
Enforce PC/Mac Compatibility option 47
EQ plug-ins 361
equal gain crossfades 249
equal power crossfades 249, 251
Error
-6031 37
-9123 37
ethernet control surfaces 358
Event Edit Area
note attributes 304
Exit command (Windows) 50
Expanded Track Display 173, 393
Export MIDI command 107
Export Region Definitions command 102
Export Selected As Files command 101
Export Selected dialog 101
Export Session As Text command 104
exporting
a session as text 104
audio 101
audio from regions 101
MIDI tracks 107
region definitions 102, 495
sterro interleaved files 102
Ext. Clock Output 40, 477
extending selections 203
to adjacent tracks 205, 206
to include adjacent regions 204
to Markers and Memory Locations 204
to region boundaries 203
Extensions 531
external clock source 373

F
factory settings 72
Fade To End command 254
Fade To Start command 254
fade-in shapes 250
fade-out shapes 248
Faders Move During Playback option 56, 380
fades 253
and dither options 360
auto-fades 254
creating 253
creating with Smart Tool 237
in batches 255
with dither 249
Fades command 246
Fades dialog 246
In Shape 250
Link option 249
Out Shape 248
Use Dither option 249
Fast Forward
incrementally 194
locating with 194
Fast Forward button 26
Feet, Frames and QuickTime offset 504
Feet, Frames Time Scale 190
file formats (audio) 407
  AIFF 408
  MP3 410
  QuickTime 408
  RealAudio 408
  SND resource 408
  Sound Designer II 407
  WAV 408
file management 109
File menu
  Bounce To Disk command 406
  Close Session command 50
  Delete Selected Tracks command 82
  Duplicate Selected Tracks command 82
  Exit command (Windows) 50
  Export MIDI command 107
  Export Session As Text command 104
  Group Selected Tracks command 93
  Import Audio to Track command 97
  Import MIDI to Track command 106
  Import Tracks command 98
  Make Selected Tracks Inactive command 90
  New Session command 43
  New Track command 133, 153
  Open Session command 44
Quit command (Macintosh) 50
Revert to Saved command 45
Save Session As command 45
Save Session command 45
Save Session Copy In command 48, 112
Split Selected Tracks Into Mono command 235
Film 422
film speed 468
filtering in bass management 430
final mixdown 416
Find command 183
finding regions 183
formats
  supported multichannel 422
  freewheeling time code 476
  Front Divergence 457
  Front/Rear Divergence 457
G
generating time code 475, 481
Global MIDI Playback Offset option 58, 312
Go to End button 26
Grabber tool 201
  editing breakpoints with 391
  Object Grabber 201
  selecting MIDI notes with 301
  Separation Grabber 215
Grid mode 185
  and moving regions 224
  Draw Grids in Edit Window option 186
  Grid Value pop-up menu 186
  Regions/Markers option 186
  setting the Grid value 224
grid panners in Mix and Edit 449
Grid value 224
Group Selected Tracks command 93
  groups
  and automation editing 394
  and hidden tracks 83
  and LFEs 381
  and pan 459
  and selecting tracks 93
  and send level, mute 380
  changing members 93
  creating 93
  deleting 93
  Edit Group 93
<table>
<thead>
<tr>
<th>Term</th>
<th>Page(s)</th>
</tr>
</thead>
<tbody>
<tr>
<td>enabling</td>
<td>94</td>
</tr>
<tr>
<td>linking Edit and Mix Groups</td>
<td>94</td>
</tr>
<tr>
<td>Mix Group</td>
<td>93</td>
</tr>
<tr>
<td>renaming</td>
<td>93</td>
</tr>
<tr>
<td>unlinking Edit and Mix Groups</td>
<td>94</td>
</tr>
<tr>
<td>Groups List</td>
<td>92</td>
</tr>
<tr>
<td>Groups List Focus</td>
<td>30, 94</td>
</tr>
<tr>
<td>Groups pop-up menu</td>
<td>92</td>
</tr>
<tr>
<td>Delete Selected Groups command</td>
<td>93</td>
</tr>
<tr>
<td>Display command</td>
<td>93</td>
</tr>
<tr>
<td>New Group command</td>
<td>92</td>
</tr>
<tr>
<td>Suspend All Groups command</td>
<td>93</td>
</tr>
<tr>
<td>H/W Buffer Size</td>
<td>38, 121</td>
</tr>
<tr>
<td>half-screen</td>
<td>196</td>
</tr>
<tr>
<td>half-speed playback</td>
<td>166</td>
</tr>
<tr>
<td>half-speed recording</td>
<td>166</td>
</tr>
<tr>
<td>hard drives</td>
<td></td>
</tr>
<tr>
<td>and QuickTime movies</td>
<td>501</td>
</tr>
<tr>
<td>recording to system volume</td>
<td>125</td>
</tr>
<tr>
<td>Round Robin Allocation</td>
<td>124</td>
</tr>
<tr>
<td>hardware</td>
<td></td>
</tr>
<tr>
<td>updating I/O Setup after changing</td>
<td>66</td>
</tr>
<tr>
<td>hardware I/O Inserts</td>
<td>361</td>
</tr>
<tr>
<td>hardware I/O Sends</td>
<td>346</td>
</tr>
<tr>
<td>Hardware Setup</td>
<td>39</td>
</tr>
<tr>
<td>Analog In 41</td>
<td></td>
</tr>
<tr>
<td>Analog Out 41</td>
<td></td>
</tr>
<tr>
<td>Clock Source</td>
<td>40</td>
</tr>
<tr>
<td>configuring audio interfaces</td>
<td>40</td>
</tr>
<tr>
<td>Digital Format</td>
<td>40</td>
</tr>
<tr>
<td>Ext. Clock Output</td>
<td>40</td>
</tr>
<tr>
<td>initializing Legacy I/O</td>
<td>41</td>
</tr>
<tr>
<td>Input Channel Selector</td>
<td>40</td>
</tr>
<tr>
<td>Meters pop-up menu fo 96 I/O</td>
<td>40</td>
</tr>
<tr>
<td>Output Channel Selector</td>
<td>40</td>
</tr>
<tr>
<td>selecting multiple outputs</td>
<td>42</td>
</tr>
<tr>
<td>Hardware Setup dialog</td>
<td></td>
</tr>
<tr>
<td>Buffer Size</td>
<td>121</td>
</tr>
<tr>
<td>HD Core card</td>
<td>5</td>
</tr>
<tr>
<td>HD Process card</td>
<td>5</td>
</tr>
<tr>
<td>Heal Separation command</td>
<td>216</td>
</tr>
<tr>
<td>hidden tracks</td>
<td></td>
</tr>
<tr>
<td>and group edits</td>
<td>83</td>
</tr>
<tr>
<td>and groups</td>
<td>83</td>
</tr>
<tr>
<td>and selections</td>
<td>200</td>
</tr>
</tbody>
</table>

**Hiding**

<table>
<thead>
<tr>
<th>Term</th>
<th>Page(s)</th>
</tr>
</thead>
<tbody>
<tr>
<td>all tracks</td>
<td>83</td>
</tr>
<tr>
<td>auto-created regions</td>
<td>261</td>
</tr>
<tr>
<td>tracks</td>
<td>83</td>
</tr>
<tr>
<td>Highest Priority Playback option</td>
<td>501</td>
</tr>
<tr>
<td>Horizontal Zoom buttons</td>
<td>186</td>
</tr>
<tr>
<td>host processing</td>
<td>37</td>
</tr>
</tbody>
</table>

**I/O capacity**

<table>
<thead>
<tr>
<th>Term</th>
<th>Page(s)</th>
</tr>
</thead>
<tbody>
<tr>
<td>allocating</td>
<td>528</td>
</tr>
<tr>
<td>and DSP usage</td>
<td>528</td>
</tr>
<tr>
<td>I/O Labels (see I/O Setup)</td>
<td></td>
</tr>
<tr>
<td>I/O Settings</td>
<td>72</td>
</tr>
<tr>
<td>I/O Settings files</td>
<td></td>
</tr>
<tr>
<td>import and export</td>
<td>72</td>
</tr>
<tr>
<td>I/O Setup</td>
<td>62</td>
</tr>
<tr>
<td>and surround sessions</td>
<td>432</td>
</tr>
<tr>
<td>default settings</td>
<td>71</td>
</tr>
<tr>
<td>displaying unavailable I/O</td>
<td>71</td>
</tr>
<tr>
<td>factory settings files</td>
<td>72</td>
</tr>
<tr>
<td>import and export settings</td>
<td>72</td>
</tr>
<tr>
<td>importing for surround</td>
<td>434</td>
</tr>
<tr>
<td>initializing</td>
<td>68</td>
</tr>
<tr>
<td>last used</td>
<td>72</td>
</tr>
<tr>
<td>reset paths</td>
<td>66</td>
</tr>
<tr>
<td>settings files</td>
<td>71</td>
</tr>
<tr>
<td>Stereo Mix preset</td>
<td>73</td>
</tr>
<tr>
<td>surround mix examples</td>
<td>445</td>
</tr>
<tr>
<td>surround mix settings file</td>
<td>73</td>
</tr>
<tr>
<td>I/O View</td>
<td>79, 341</td>
</tr>
<tr>
<td>Identify Beat command</td>
<td>268, 269</td>
</tr>
<tr>
<td>Identify Sync Point command</td>
<td>221, 495</td>
</tr>
<tr>
<td>Import Audio dialog</td>
<td>97</td>
</tr>
<tr>
<td>Import Audio From Current Movie command</td>
<td>507</td>
</tr>
<tr>
<td>Import Audio From Other Movie command</td>
<td>103</td>
</tr>
<tr>
<td>Import Audio to Track command</td>
<td>97</td>
</tr>
<tr>
<td>Import MIDI command</td>
<td>107</td>
</tr>
<tr>
<td>Import MIDI to Track command</td>
<td>106</td>
</tr>
<tr>
<td>Import Movie command</td>
<td>502</td>
</tr>
<tr>
<td>Import Movie dialog</td>
<td>502</td>
</tr>
<tr>
<td>Import Tracks command</td>
<td>98</td>
</tr>
</tbody>
</table>

**Importing**

<table>
<thead>
<tr>
<th>Term</th>
<th>Page(s)</th>
</tr>
</thead>
<tbody>
<tr>
<td>and converting audio</td>
<td>96</td>
</tr>
<tr>
<td>audio</td>
<td>95</td>
</tr>
<tr>
<td>audio and Conversion Quality</td>
<td>103</td>
</tr>
<tr>
<td>audio from CDs</td>
<td>102</td>
</tr>
</tbody>
</table>
audio from QuickTime movies 507
audio into a session 95
audio with drag & drop 100
MIDI tracks 106
multichannel I/O Settings 434
QuickTime audio 506
QuickTime movies 502
tracks from other sessions 98
inactive
items 16
making plug-ins 17, 364
Master Faders and assignments 340
paths 69
paths, global 69
sends 348
track path assignments 69
tracks 90
Infinite Peak Hold 80
Infinite Peak Hold preference 52
in-place auditioning 74
Input Channel Selector 40
input connections 14, 117
and digital sources 164
Input Devices command 150
Input Filter command 151
  MIDI Input Filter dialog 151, 329
input levels 117
Input Only Monitoring option 120
Input Quantize command 151
  Input Quantize window 152
Input Selector 84
Insert Position Selector 366
Insert Silence command 259
  and Shuffle Mode 259
  and Slip Mode 259
inserting
controller events 306
  in MIDI Event List 330
  meter events 271
  MIDI notes 299
  program changes 309
  tempo events 265
Inserts 361
  as a shared bus 362
  for hardware I/O 361
  for plug-ins 361
labeling 370
  on single tracks 362
  post-fader on Master Faders 339, 362
  shared within a submix 355
Inserts View 341
Interleaved 412
Inverse linked panning 350
J
Jam Sync 476
JL Cooper CS-10 358
JL Cooper MCS3000 359
K
Key Input Selector 366
Keyboard Focus 29
  Audio Regions Focus 30, 184
  Commands Focus 30
  Groups List Focus 30, 94
  MIDI Regions Focus 30, 184
keyboard Input for plug-in parameters 369
keyboard shortcuts 369
  global key commands 29
  numeric entry 204
  recording 134
L
labeling
  Inserts and Sends 370
  paths 65
Last Used 72
Latch Record Enable Buttons option 52, 119
Latch Solo Buttons option 53, 89
latency for recording and monitoring 121
LCRS path examples 435
Legacy I/O 41
length, for selections 202
level faders
  Output windows 344
  sends 345
  tracks 80
Level Indicator 79
level meters
  clearing 80
  for audio tracks 80
  for MIDI tracks 80
Levels of Undo option 55
Levels of Undo preference 181
LFE
- and groups 381
- enable in plug-ins 457
- example sub-path 445
- examples of discrete versus contribution 446
- faders 457
- plug-in enable 367
LFE Enable Button 367
LFEs Follow Groups option 56, 381
Librarian menu 366
Limit To option 54
linear crossfades 251
Link Edit and Timeline Selection option 199
Link Enable buttons 367
- in multi-mono plug-ins 442
Link Mix and Edit Group Enables option 53
Link Record and Play Faders option 120
Link Selection button 199
linking
- inverse panning 350
- multi-mono plug-ins 442
- plug-in controls 369
- stereo panners 350
Local Control 19, 150
locating
- with Fast Forward/Rewind 194
- with Location Indicators 195
Location Indicators 194
- locating with 195
locations, for MIDI notes
- dragging 302
- quantizing 320
- randomizing 320, 321
Lock/Unlock Regions command 228
locking regions 228
Loop Playback option 209
- and Auto Touch mode 384
loop points 144
- and Playback Markers 144
Loop Record mode 126, 141
loop recording
- and pre/post-roll 141
- audio 141
- MIDI 157
  - drum machine style 157
  - multiple takes 158
looping selections 209
loops and reverb, delay 405
Low Latency Monitoring option 122
Lt Rt 426
LTC (Linear Time Code) 465
M
Machine Chases Memory Location option 54, 487
Machine Control 485
Machine Control option 54
Machine Cues Intelligently option 54
Machine Follows Edit Insertion/Scrub option 54, 487
Mackie HUI 358
main paths 61
Main Time Scale 191, 480
Make Selected Tracks Inactive command 90
managing regions 260
Manual Tempo mode 28, 130
mapping paths in I/O Setup 67
Markers 274
- creating 276
- creating on the fly 277
- deleting 279
- editing 278
- extending selections to 204
- moving 279
- sorting 281
- tick-based and sample-based 275
- viewing options 280
Master Faders
- adding 340
- and DSP usage 527
- as master send level control 356
- inactive 340
- inserts 362
- meters pre/post fader 340
- multichannel 441
- paths 344
- post-fader inserts 339
- signal flow 339
Master Link Button 367
- in multi-mono plug-ins 442
master view for tracks 172, 396
mastering
- digitally 416
- to disk 416
Matching Start Time Takes List preference 55
matrix 425
measures
partial 273
renumbering 273
Medium Priority Playback option 501
Memory for Automation Recording option 382
Memory Location dialog 274
Memory Locations 274, 275
creating 276
creating on the fly 277
deleting 279
deleting all 279
editing 278
extending selections to 204
Markers 274
recalling 278
recalling Edit selections 147
renaming 278
Selection Memory Locations 275
storing Edit selections 147
Memory Locations window 280
view filter 281
viewing options for Markers 280
Merge mode (see MIDI Merge mode)
Merge Paste command 234
meter
current 271
default 129
meter events 271
editing 272
inserting 271
Meter Ruler
displaying 271
extending an Edit selection to 272
meters
sends view 348
SurroundScope plug-in 459
MIDI 18
and signal paths 19
audio input to Pro Tools 353
common misconceptions 19
Default Thru Instrument 151
MIDI Beat Clock command 491
MIDI channels 18
assigning 88
MIDI clips and Regions List 182
MIDI control surfaces 18, 358
MIDI controller devices 18, 149
Local Control 19, 150
MIDI Device/Channel Selector 88
MIDI devices 18
MIDI Event List 327
deleting events 333
editing events 332
inserting events 330
navigating in 328
Options menu 334
selecting events 332
View Filter 329
MIDI files (see Standard MIDI Files)
MIDI Input Selector 88, 153
MIDI Machine Control (MMC) 485
configuring in Pro Tools 485
controlling external devices with 485
remote track arming 487
synchronizing to an ADAT 487
syncing to a sequencer with 489
MIDI menu
All Notes Off command 313
Change Duration command 324
Change Meter command 271
Change Tempo command 265
Change Velocity command 322
Click Options command 128
Input Devices command 150
Input Filter command 151
Input Quantize command 151
MIDI Beat Clock command 491
MIDI Thru option 150
Quantize command 318
Renumber Bars command 273
Select Notes command 316
Split Notes command 317
Transpose command 326
MIDI Merge mode 27, 127, 152
MIDI notes
attributes for 304
chasing 311
deleting 304
duplicating selected 233
ingesting 301
durations 324
pitch 301
velocities 303, 322
lengths in ticks 192
Index

moving 302
quantizing 318
selecting 301, 316
splitting 317
transposing 301, 326
trimming start/end points 302
MIDI offsets 312
MIDI Operations window 315
parameter options 316
MIDI Output Selector 153
MIDI Preferences 58
  Default Note On Velocity option 300
  Global MIDI Playback Offset option 312
  Pencil Tool Resolution When Drawing Controller Data option 58, 306, 391
MIDI recording 149
  cancelling takes 155
  enabling input devices 150
  Input Filter 151
  Merge/Replace mode 153
  monitoring with MIDI Thru 150
  quantizing on input 151
  System Exclusive data 160
  undoing a take 155
  Wait for Note 152
MIDI regions 176
  and controller events 178
  and Merge Paste command 234
  and punch recording 157
  guidelines for editing 177
MIDI Regions Focus 30, 184
MIDI Regions List 181
  and MIDI clips 182
  dragging from 216
  finding regions 183
  sorting 182
MIDI Regions List menu
  Auto Rename Selected command 261
  Clear Selected command 262
  Display All command 183
  Find command 183
  Import MIDI command 107
  Rename Selected command 261
  Select Unused command 262
  Sorting option 182
  Time Stamp Selected command 224, 494
MIDI Replace mode 27, 127, 152
MIDI Thru option 150

MIDI tracks
  and MIDI offsets 312
  and tempo changes 267
  assigning to multiple channels 154
  channel strips 79
  configuring for recording 153
  default program change 308
  exporting 107
  loop recording 157
  Merge Paste command 234
  note chasing 311
  Notes view 171, 176
  punch recording 155
  punching on the fly 156
  record enabling 119
  recording 149
  Regions view 171, 177
  selecting a pitch range in 316
  Sysex view 310
  Velocity view 303
Minimum Sync Delay option 487
Minutes:Seconds Time Scale 190
mix busses 346
MIX Core card 6
MIX Farm card 6
Mix Group 93
Mix window 21
  track controls 21
  track width 90
Mix Window Follows Bank Selection option 51
Mix Window Shows option 21
mixed file types 47, 96
mixer channels 14
Mixer plug-ins
  Pro Tools|24 MIX Systems 525
  Pro Tools|24 Systems 525
  Pro Tools|HD Systems 525
mixing 421
  surround formats 422
mixing and DSP usage 518
mixing down to stereo 416
MMC (see MIDI Machine Control)
monitoring
  during punch recording 140
  MIDI recording with MIDI Thru 150
  record and playback levels 120
monitoring latency 121
monitoring modes 119
  Auto Input Monitoring 120
  Input Only Monitoring 120
mono
  Bounce to Disk 412
  format 422
  paths 65
Mono In/Stereo Out 362
Movie menu
  Bounce to Movie command 508
  Highest Priority Playback option 501
  Import Audio From Current Movie command 507
  Import Audio From Other Movie command 103
  Import Movie command 502
  Medium Priority Playback option 501
  Normal Priority Playback option 501
  Set Movie Sync Offset command 504
  Show Movie Window command 503
Movie Tracks 502
  scrubbing 503
  setting sync point 505
Movie window 503
movies (see QuickTime movies)
moving
  Bar|Beat Markers 270
  Markers 279
  MIDI notes 302
  program changes 309
  sysex events 310
MP3 and Digidesign hardware 412
MP3 file format 410
MTC (MIDI Time Code) 465
  outputting 475
multichannel plug-ins 362, 442
multichannel regions 170
multichannel tracks 136
  and automation 393
  dragging regions to 235
  names for 123
  replacing regions in 241
  signal routing 437
  splitting 235
multi-mono
  plug-in Channel Selector 442
  plug-ins 362, 441
Multiple mono 412
multiple outputs
  Hardware Setup 42
multiple tracks
  and Beat Detective 291
  audition takes 143
  editing across 232
  extending selections to 205, 206
  fitting audio regions to Edit selection 242
  nudging regions in 226
  pasting to 232
  selecting 205
  separating regions on 214
  shuffling regions on 222
MultiShell 527
Mute automation 392
Mute button 89
Mute Frees Assigned Voice option 89, 90
Mute/Unmute Region command 228
Mutes Follow Groups option 56, 380
Mutes Follow Mix Groups option 88
muting
  regions 229
  tracks 89

N
Narrow Mix Window option 90
network connections 531
New Group command 92
New Session command 43
  and last used 72
New Track command 133, 153
  New Track dialog 133
No Auto-Scrolling option 195
No Output 345
  by deleting paths 67
No Peak Hold 80
No Peak Hold preference 52
non-contiguous selections 201
non-destructive editing 169
  for audio 176
  for MIDI 178
Non-destructive Record mode 126
non-destructive recording 138
  recording to a new playlist 139
  with QuickPunch 161
Normal Priority Playback option 501
Note Chasing option 311
notes (see MIDI notes)
Notes view 171, 176
  mini-keyboard 176
  scrolling up or down 177
Nudge value 225
  trimming regions by 220
nudging 225
  by next Nudge Value 226
  multiple regions 226
  region contents 227
  selection range 203
  selection start/end points 203
  selections and regions 226
  setting the Nudge value 225
Number of Voices 38
numeric entry
  Calculator mode 204
  shortcuts 204
Numeric Keypad Mode 53
Numeric Keypad modes 31, 53
  Classic 31
  Shuttle 32, 198
  Transport 31

O
Object Grabber 201
  and Edit Groups 202
Object selections 201
offline regions 170
OMS IAC driver 482
OMS MIDI Setup command 483
OMS Names Manager 307
OMS patch names 307
OMS Studio Setup 489
On Stop 399
Online button 25
Online option 53, 481
online recording 481
on-the-fly punch recording
  MIDI tracks 156
  QuickPunch 127, 161
Open Ended Record Allocation option 54, 125
Open Session command 44
opening multiple Plug-In windows 367
Operation Preferences 52
  Audio During Fast Forward/Rewind option 194
  Auto Regions Fade In/Out Length option 255
  Edit Insertion Follows Scrub/Shuttle option 196
  Latch Record Enable Buttons option 119
  Link Record and Play Faders option 120
  Machine Chases Memory Location option 487
  Machine Follows Edit Insertion/Scrubb option 487
  Open Ended Record Allocation option 125
  Record Online option 481
  Use F11 for Wait for Note 152
Operations menu
  Auto Input Monitoring option 120
  Auto-Spot Regions command 493
  Calibration Mode command 118
  Copy Edit Selection to Timeline command 210
  Copy Timeline Selection to Edit command 210
  Destructive Record mode 138
  Input Only Monitoring option 120
  Link Edit and Timeline Selection option 199
  Loop Playback option 209
  Loop Record mode 141
  Low Latency Monitoring option 122
  Mute Frees Assigned Voice option 89, 90
  Online option 481
  Play Edit Selection command 211
  Play Timeline Selection command 211
  Pre/Post Roll Playback command 146
  Pre/Post-Fader Metering option 80
  Pre-Fader Metering 80
  Scroll Options 195
Optical
  ADAT I/O 40
    as Digi 001 clock source 373
Optical (S/PDIF)
  Hardware Setup 40
Original Time Stamp 224, 494
Output Channel Selector 40
Output Options
  Conversion Quality option 414
  Sample Rate 413
Output Selector 85
Output windows 344
outputs
  default 5.1 paths and sub-paths 433
    format and tracks 439
    to multichannel paths 440
  overlap crossfades 251
  overlapping paths 69
Page Scroll During Playback option 195
Pan automation 392
Pan Indicator 79
Pan Slider 79
panning
3-knob 455
and groups 459
automation and groups 394
fine-adjust mode 455
grids 449
guidelines 444
linked stereo 350
multichannel automation playlists 459
take over in grid 455
trajectory 456
X/Y mode 454
parallel mixing 439
partial measures 273
pass-through point 378
Paste command 231
pasting
automation 397
between automation playlists 232
multiple data types 232
selections and regions 231
to multiple tracks 232
with Merge Paste command (MIDI) 234
with Repeat Paste To Fill Selection command 241
paths
active and inactive 69
applying 68
audition 74
creating and editing 64
creating multichannel 434
default mono and stereo 65
default order 75
default output 73
deleting 67
for surround 443
last used 72
main 61
mapping 67
mono versus stereo 65
multichannel example 68
naming 65
overlapping 69
reset using Default 66
Stereo Mix preset 73
sub-path surround examples 445
PCI Bus Activity 382
Peak Hold option 52, 80
Peak Indicator 79
Peavey PC-1600 358
Pencil tool 236
as Eraser 305
drawing automation with 390
editing breakpoints with 392
inserting MIDI notes with 299
repairing waveforms with 236
resolution for inserted controller events 306
shapes 390
Pencil Tool Resolution When Drawing Controller
Data option 58, 306, 391
Phase Invert button 367
pitch, for MIDI notes
transposing with Grabber 301
transposing with Transpose command 326
Play button 25
Play Edit Selection command 211
Play MIDI Notes When Editing option 58
Play Timeline Selection command 211
playback cursor 193
Playback Engine 38, 477
CPU Usage Limit 38
DAE Playback Buffer Size 39
H/W Buffer Size 38
Number of Voices 38
Sample Rate 39
Playback Markers 144, 199
and Edit selections 200
and selection length 203
and Timeline selections 210
Playhead 196
and Edit selections 211
and Timeline selections 211
moving to region boundaries 211
playing
and on-the-fly selections 201
at half-speed 166
Edit selections with Playhead enabled 211
from a track point 193
selections 208
Timeline selections with Playhead enabled 211
tracks 193
Playlist Selector 13
playlists 13, 178
  adding new 179
  and multichannel tracks 393
  and non-destructive MIDI editing 178
  assigning 179
  automation playlists 178, 376, 383
  auto-naming 179
  deleting 180
  duplicating 179
  edit playlists 178
  recalling 179
  recording to new 139
  renaming 179
  setting pre/post-roll in 146
plug-in controls, linking 369
plug-in inserts 361
plug-in parameters
  editing 369
Plug-In Selector
  for real-time plug-ins 366
Plug-In Settings menu 366
Plug-In window
  closing multiple windows 367
  opening multiple windows 367
Plug-Ins
  and surround mixing 441
  automating 386
  automation accuracy in bounce 414
  bypassing from window 368
  Channel Selector for multi-mono 442
  for surround 442
  linking 442
  linking and unlinking 369
  making inactive (and active) 17, 364
  mixers 526
  mono-to-stereo 362
  multichannel 362
  multi-mono 362, 441
  positional reference 464
post crossfades 246, 252
pre crossfades 246, 252
Pre/Post Roll Playback command 146
Pre/Post-Fader Inserts 362
Pre/Post-Fader Metering option 80
  pre/post-roll
  and loop recording 141
  and punch recording 140
auditioning 208
  setting 145
Pre/Post-Roll Flags 147, 199
Pre-Fader Metering 80
Preferences
  AudioSuite Dither
    Bit Depth option 57
Preferences command 51
Pro Tools LE
  file management 109
Pro Tools LE systems 8
  capabilities 9
Pro Tools TDM systems
  24-bit input and output 416
  file management 109
  QuickPunch 162
Pro Tools|24 MIX-series systems 6
Pro Tools|24 systems 6
Pro Tools|HD systems 5
  processing bandwidth 382
Processing Preferences 57
ProControl 358
Program Change window 308
program changes 18, 306
  and bank select 306
  auditioning 310
  chasing 311
  default, for MIDI tracks 308
  deleting 310
  editing 309
  inserting 309
  moving 309
  patch names 307
ProLogic 422
Pull Up/Down 469
  3:2 Pulldown 468
  configuring 480
Punch In Frame Offset preference 54
Punch Out Frame Offset preference 54
punch points 144
  and Playback Markers 144
punch recording
  and monitoring 140
  and pre/post-roll 140
  audio 140
  MIDI 155
  MIDI on the fly 156
Q
Quantize command 318
   experimenting with 322
   Quantize window 318
Quantize Regions command 228
   and Grid value 224
Quantize window 318
   Quantize Options 319
quantizing
   MIDI notes 318
   attacks vs. releases 319
   MIDI on input 151
   regions 228
QuickPunch 127, 161
   crossfades 161
   non-TDM systems 163
   region/take numbering 164
   TDM systems 162
QuickPunch Crossfade Length option 55, 161
QuickTime file format 408
QuickTime file formats 506
QuickTime movies 499
   bouncing to 508
   conforming 500, 505
   frame length 501
   importing 502
   importing audio from 507
   offset in Feet.Frames 504
   offsetting 504
   optimizing for playback 503
   playback quality 501
   requirements 501
   setting start time 504
   spotting 505
Quit command (Macintosh) 50

R
randomizing
   note durations 325
   note locations 320
RealAudio file format 408
real-time editing 169
real-time plug-ins 361
Rear Divergence 457
Recall Original Track Selections preference 55
Recompute Invalid Overviews preference 51
Record button 26, 126
Record Enable button 118
record enabling tracks 118
record modes 125
   and MIDI 127
   Destructive Record mode 126
   Loop Record mode 126
   Non-destructive Record mode 126
   QuickPunch 127
   switching with Record button 126
Record Online at Insertion/Selection preference 53
Record Online at Time Code (or ADAT) Lock preference 53
Record Online option 481
Record Pause mode 137
Record Safe mode 119
recording 136
   a mono audio track 133
   a stereo audio track 135
   a submix to disk 405
   additional takes 138
   at half-speed 166
   bouncing to disk 406
   cancelling takes 135
   destructively 138
   from a digital source 164
   from Record Pause mode 137
   keyboard shortcuts 134
   monitoring latency 121
   multichannel tracks 136
   multiple audio tracks 136
   non-destructively 11, 138
   non-linear 11
   online 481
   stereo tracks 135
   System Exclusive data 160
   to a new playlist 139
   to the system volume 125
   with a countoff 129
   with Round Robin Allocation 124
   with the click 128
Red Book Audio CDs 508
Redo command 180
region boundaries
   extending selections to 203
   moving edit cursor to 206
   moving Playhead to 211
region definitions 102, 495
Region List Selection Follows Track Selection
option 55, 182, 207
regions 13
aligning to region start points 217
auto-created 170
auto-naming parameters 261
auto-spotting 493
capturing 213
clearing 230
conforming with Beat Detective 292
consolidating 260
copying 230
creating 213
crossfading between 252
cutting 230
default names 123
deleting underlying 231
displaying all 183
displaying names 174
displaying times 174
dragging from Regions List 216
dragging to multichannel tracks 235
duplicating 233
exporting as audio files 101
extending selections to include 204
finding 183
healing separations 216
hiding auto-created 261
inserting silence into 259
locking 228
managing 260
moving in Grid mode 225
multichannel 170
muting 229
nudging 226
offline 170
Original Time Stamp 224
pasting 231
placing at Edit insertion point 217
placing in tracks 216
quantizing 228
removing unused 262
renaming 260
repeating 234
replacing 239
selecting 200
selecting all in a track 200
separating 213
separating with Beat Detective 291
separating with Separation Grabber 215
shifting 227
shuffling 221
sliding 221
slipping 222
sorting 182
spotting 223, 493
spotting to movies 506
sync points 221, 495
time stamping 494
trimming by Nudge Value 220
trimming start/end points 219
trimming to Edit insertion point 220
trimming unwanted data from 215
User Time Stamp 224
user-defined 170, 260, 262
whole-file audio regions 170
Regions view 171, 177
related takes 142
and Separate Region command 143
preferences for 143
Remote Mode option 54
remote track arming 487
Remove Sync Point command 221
removing
crossfades 252
Sends 346
csync points 496
Rename Selected command 261
renaming
auto-created regions 260
groups 93
Memory Locations 278
playlists 179
regions 260
tracks 122
Renumber Bars command 273
Repeat command 233
Repeat Paste To Fill Selection command 241
repeating selections and regions 234
Replace mode
Replace Regions command 239
and multichannel tracks 241
Replace Regions dialog 239
reset paths 66
Return to Zero button 25
Revert to Saved command 45
Rewind
  incrementally 194
  locating with 194
Rewind button 25
Round Robin Allocation 124
RTAS
  on Pro Tools LE Systems 37
  on TDM Systems 37
  processing 37
Ruler View Shows option 189
Rulers
  changing display order 189
  Conductor Rulers 189
  displaying all 189
  scrolling in 195
  Timebase Rulers 189

S
S/PDIF
  Hardware Setup 40
  saing automation 383
  sample delays (see DSP delays)
Sample Rate
  Playback Engine 39
Sample Rate Conversion Quality 413
  sample rate conversion quality 103, 507
  sample rate formats 413
    custom 414
Sample Rates
  176.4 kHz 413
  192 kHz 413
  44.1 kHz 414
  48 kHz 414
  88.2 kHz 413
  96 kHz 413
Samples Time Scale 190
Save Session As command 45
Save Session command 45
Save Session Copy in command 46, 48, 112
  saving a copy of a session 46
  scaling note velocities 303, 324
  screen savers 531
Scroll After Playback option 195
Scroll Options 195
  scrolling
    in the Ruler 195
    Notes view up or down 177

Scrub Trimmer 219
Scrubber tool 196
  in Shuttle mode 197
  selecting with 206
scrubbing 196
  a single audio track 197
  and edit cursor 196
  in Shuttle Lock mode 198
  Movie Tracks 503
  on two audio tracks 197
  playback speed and direction 197
  resolution 197
  with Scrub Trimmer 220
  with the Selector 197
SDDS 422
Select All command 200
Select Notes command 316
  Select Notes window 316
Select Unused Regions command 262
selecting
  a pitch range of notes 316
  across multiple tracks 205
  all regions in a track 200
  all regions in all tracks 201
  during playback 201
  in MIDI Event List 332
  MIDI notes 301, 316
  non-contiguous regions 201
  notes in a chord 317
  on all tracks 205
  regions 200
  track material 200
  with Scrubber 206
  with Selection Indicators 204
Selection Indicators 204
  and numeric entry shortcuts 204
  making selections with 204
Selection Memory Location 275
  moving stored selection 279
selections
  and Bounce to Disk 406
  and Edit Groups 200
  and hidden tracks 200
  and Playback Markers 200
  auditioning start/end points 208
  changing length of 202
  clearing 230
  consolidating 260
  copying 230
Index
563

- cutting 230
- duplicating 233
- extending 203
- extending to the Meter Ruler 272
- extending to the Tempo Ruler 267, 280
- including Conductor Rulers 205
- looping 209
- moving to adjacent tracks 206
- moving to the next/previous region 206
- non-contiguous 201
- nudging 203, 226
- nudging start/end points 203
- Object 201
- on-the-fly 201
- pasting 231
- playing 208
- removing a track from 206
- repeating 234
- shifting 227
- storing with Memory Locations 275

Selector tool 193
- scrubbing with 197
- selecting MIDI notes with 301

Send controls 345
Send Levels Follow Groups option 56, 380
Send mute 345
Send Mutes Follow Groups option 56, 380
Send pan 345
Sends 345
- adding 346
- and groups 380
- and multichannel mixing 440
- assignment view 347
- automating 385
- copying track automation to 386
- default level 346
- displaying controls for 347
- for hardware I/O 346
- for mix busses 346
- labeling 370
- mono or stereo 346
- multichannel 440
- removing 346

Sends Default to -INF preference 52
Sends View 342
Sends View Shows 346
Separate Region command 213
- and multiple tracks 214
- and related takes 143

Separate Region Operates On All Related Takes option 55, 143, 214
Separation Grabber 215
Session Setup window 474
- Current TC 496
session templates 48
sessions 12
- audio format 475
- bit depth 44, 474
- closing 50
- creating 43
- creating for surround mixing 432
- default tempo 268
- frame rate 475
- mixed audio formats 47
- opening 44
- sample rate 474
- saving 45
- start frame 475

Set Movie Sync Offset command 504
- setting punch/loop points 144

Setups menu
- Disk Allocation 124
- Feet.Frames Time Scale 190
- Hardware Setup 39
- I/O Setup 62
- OMS MIDI Setup 483
- OMS Names 307
- OMS Studio Setup 489
- Playback Engine 38
- Preferences command 51

Shift command 227
- Shift dialog 227
- shortcuts for keyboard input 369

Show Disk Names option 182
Show File Names option 182
Show Full Pathnames option 182
Show Meters in Sends View option 348
Show Meters in Sends View preference 51
Show MIDI Operations command 315
Show Movie Window command 503
Show System Usage 518
Shuffle mode 185
- and locked regions 228
- and moving regions 221

Shuttle Lock mode 198
Shuttle, Numeric Keypad mode 32, 53, 198
side-chain processing 366
signal flow
  Audio Tracks 338
  Auxiliary Inputs 338
  Master Faders 339
signal routing
  and default path order 75
  basics for surround 440
  example 15
  surround examples 446
sliding regions 221
Slip mode 185
  and moving regions 222
Smart Tool 237
  and audio tracks 237
  and MIDI tracks 238
  and multichannel tracks 238
  creating crossfades with 237
  creating fades with 237
  editing automation with 238
  editing controller events with 238
Smooth and Thin Data After Pass option 56, 380, 389
smoothing automation 381
SMPTE
  configuration 478
  frame formats 466
  start frame for session 475
SMPTE/ITU 422
snapshot automation 400
  adding to empty automation playlists 400
  and trim values 402
  writing over existing automation 401
SNR resource file format 408
Soft Limit 41
Solo button 89
Solo Safe mode 89
sooloing
  tracks 89
  tracks in a submix 356
Solos Follow Groups option 56, 380
Solos Follow Mix Groups option 89
sorting
  Markers 281
  regions 182
  Sorting option 182
  Sound Designer Il file format 407
Source Path 407
speakers
  layouts 422
  suggested 5.1 placement 424
  surround calibration 425
  surround placement 424
Split Notes command 317
  Split Notes dialog 317
Split Selected Tracks Into Mono command 235
splitting stereo and multichannel tracks 235
Spot dialog 223, 492
  Use Subframes option 492, 494
  User Time Stamp button 494
Spot mode 185, 491
  and moving regions 223
  trimming regions in 494
spotting
  auto-spotting 493
  QuickTime movies 505
  regions 223, 491, 493
SR Conversion
  192 I/O 41
Standard MIDI Files 106
  exporting 107
  importing 106
  Type 0 106
  Type 1 106
Standard Trimmer 218
  start frame, for sessions 475
Start, End, and Length display 24
stems
  surround examples 446
stepped control automation 392
stereo format 422
stereo interleaved files, exporting 102
Stereo Mix
  I/O Setup factory preset 73
Stereo Mixer plug-in 526
stereo tracks
  dragging regions to 235
  names for 123
  recording 135
  replacing regions in 241
  splitting 235
Stop button 25
Strip Silence command 257
  and region naming 258
Strip Silence window 257
stuck notes 313
sub
  with bass management 429
Sub Time Scale 191, 480
subframes 492
submixes
  applying an Insert to 355
  bouncing to 415
  bouncing to disk 405
  soloing tracks in 356
sub-paths
  examples for surround 443
Support Background Record Applications preference 52
surround
  and sends 440
  basic signal routing 440
  bass management 429
  center percentage (%) 458
  concepts 421
  configuring Pro Tools and sessions 432
  delivery formats 428
  discrete level, solo, mute 438
  divergence basics 427
  encoding and decoding 429
  example 5.1 format paths 435
  example LCRS-format paths 435
  formats 421
  importing I/O Settings 434
  Lt Rt 426
  mix compatibility 428
  mixer specifications 525
  mixing concepts 428
  mixing formats 422
  pan playlists and automation 459
  panning grids 449
  Pro Tools formats 422
  settings files 432
  speaker arrangements 422
  terminology 425
  using paths 443
  using sub-paths, examples 443
Surround Mixer
  plug-in features 526
  specifications 525
Surround Mixer plug-in 526
SurroundScope 459
Suspend All Groups command 93
suspending automation 387
swing 319, 321
SYNC I/O 463, 466
  and VSO
    generating time code with 482
    resolving with 474
  sync options 474
Sync Mode 475, 477
Sync Offset 476
sync points 495
  for QuickTime movie 505
  for regions 221
  from Beat Detective 293
  identifying 221, 495
  with Beat Detective 291
synchronization 463
  3:2 Pulldown 468
  and film 467
  Bi-Phase/Tach 466
  black burst 497
  film speed vs. video speed 468
  guide tracks 468
  LTC 465
  MIDI Beat Clock 491
  MMC 485
  options 473
  positional reference 464
  Pull Up/Down 469
  resolving 497
  SMPTE frame formats 466
  time code 464
  troubleshooting 496
  VITC 465
synchronizing to a sequencer
  Macintosh 482
  Windows 484
  with MMC 489
synchronizing to an ADAT 487
Sysex view 310
System Activity 382
System Exclusive data 19, 310
  deleting 311
  moving 310
  recording 160
System Usage 382
System Usage window 518
System Usage Window Shows 518
T
Tab to Transients button 207
take over (surround pan) 455
Take Region Lengths That Match option 55, 143
Take Region Names That Match Track Names option 55, 143
takes
  auditioning 142
  auditioning from Takes List 142
default names 123
  numbering for QuickPunch 164
  recording additional 138
Takes List pop-up menu 142
  and multiple tracks 143
tapping in the tempo 131
Target Button 367
Tascam DA30 40
TC/E Plug-In preference 57
TDM
  RTAS Plug-ins 37
  TDM Mixer Plug-Ins 526
    switching 526
  TDM Plug-Ins
    and DSP usage 527
    MultiShell 527
TDM systems 5
  audio interfaces 8
    QuickPunch 162
TDM Time Slot usage 382
technical support
  suggestions 531
tempo
  current 265
  default 130, 268
  effects on Markers and Memory Locations 275
  effects on MIDI and audio 267
  Manual Tempo mode 130
  tapping in 131
tempo events 265
  and Bar|Beat Markers 270
  editing 266
  inserting 265
tempo map
  from Identify Beat command 268
Tempo Ruler
  displaying 265
  extending an Edit selection to 267, 280
test 414
Thin Automation command 390
thinning automation 381, 389
tick-based and sample-based 275
tick-based timing 191
time code 464
  and Jam Sync 476
  capturing 492
  freewheeling 476
  generating 475, 481
Time Code Time Scale 190
Time Scale 190
  Bars:Beats 190
  Feet:Frames 190
  Main 191, 480
  Minutes:Seconds 190
  Samples 190
  Sub 191, 480
  Time Code 190
time stamp 494
Time Stamp Selected command 143, 224, 494
time stamps and Bounce to Disk 406
Time Trimmer 242
TimeAdjuster TDM plug-in 513
Timebase Rulers 189
  and selecting on all tracks 205
  and Timeline selections 209
  Edit Markers 199
  Playback Markers 199
  Pre/Post-Roll Flags 199
  sliding Edit selections 207
  sliding Timeline selections 210
Timeline Insertion Follows Playback option 52
Timeline selections 209
  and Playback Markers 210
  auditioning with Playhead enabled 211
  copied from Edit selection 210
  copied to Edit selection 210
  in Timebase Rulers 209
  sliding in the Ruler 210
  start, end, and length fields 27
To All Enabled Parameters
  writing automation 402
To Current Parameter
  writing automation 402
toggling
  Track View 172
Touch Timeout option 56, 381
track controls
   Edit window 24
   Mix window 24
track data 170
Track Height 172
track layout
   default path order 75
track level faders 80
track level meters 80
Track Name/Comments dialog 81, 122
Track Selection Follows Regions List Selection option 55, 207
Track Selector 366
Track View 170
   Blocks 171
   Expanded Track Display 173, 393
   master view 396
   Notes 171, 176
   Regions 171, 177
   Sysex 310
   toggling 172
   Velocity 303
   Waveform 171, 174
Track View Toggle 172
track width 90
tracks
   5.1 format track layout 438
   adding to selection 205, 206
   and surround 437
   appending new material to end of 139
   color coding 91
   deleting 82
   duplicating 82
   entering comments 81
   grouping 91
   hiding 83
   importing 98
   locating with Fast Forward/Rewind 194
   making inactive/active 90
   master view 172, 396
   moving selections between 206
   muting 89
   names 80, 122
   placing regions in 216
   playback priority 87
   playing 193
   record enabling 118
   removing from a selection 206
   selecting across multiple 205
   selecting all regions in 200
   selecting all regions in all tracks 201
   selecting material in 200
   selecting on all 205
   soloing 89
   Track Height 172
   Track View 170
   transposing 326
   trimming unwanted data from 215
trajectory paning 456
transients
   detecting with Beat Detective 287
   tabbing to 207
Transport Master 486
Transport Numeric Keypad Mode 53
Transport window 25
   MIDI controls 27
   pre/post-roll 26, 146
   start, end, and length fields 27, 145
   transport controls 25
Transport, Numeric Keypad mode 31
Transpose command 326
   Transpose window 326
   transposing 326
      by octave 326
      key 326
      MIDI notes 301
      tracks 326
Trim Automation command 402
Trim End To Insertion command 220
Trim Start To Insertion command 220
Trim To Selection command 215
Trimmer tool 218
   Scrub Trimmer 219
   Time Trimmer 242
trimming
   automation breakpoints 392, 399
   crossfades 252
   input sum levels 524
   note start/end points 302
   region start/end points 219
   regions by Nudge Value 220
   regions to Edit insertion point 220
   regions with Scrub Trimmer 220
   unwanted region and track data 215
Tweak-head setting 414
U
unavailable I/O
  showing 71
Undo and audio recording 134
Undo command 180
Universe window 187
unlinked Edit and Timeline selection 199
unlinking plug-in controls 369, 442
Use All Available Space preference 54
Use AudioSuite Dither preference 57, 360
Use F11 for Wait for Note option 53, 152
Use Squeezer option 414
Use Subframes option 492, 494
User Time Stamp 224, 495
user-defined regions 170, 260, 262

V
Variable Speed Override 477
velocities, for MIDI notes
  default for inserted 300
  dragging velocity stalks 303
  drawing with Pencil 303
  editing 303, 322
  fading 323
  scaling 324
  scaling with Trimmer 303
Velocity view 303
Vertical Zoom buttons 186
video capture/playback cards 500
video speed 469
View Filer command 329
views
  Comments View 80
  I/O View 79
  Inserts View 341
  Sends View 342
Virtual Memory 531
VITC (Vertical Interval Time Code) 465
voice numbers 39
Voice Selector 24, 86
voices
  allocating 87
  and track priority 87
  auto-assignment of ascending 86
  Playback Engine 38
Volume automation 392

VSO (see Variable Speed Override)

W
Wait for Note 27, 152
WAV file format 110, 408
  AES31/Broadcast compliant 110
Waveform view 171, 174
waveforms 174
  and zero-crossing 175
  avoiding clicks and pops 175
  drawn rectified 174
  guidelines for editing 175
  repairing with Pencil tool 236
whole-file audio regions 170
Windows menu
  Show System Usage 518
Word Clock 40
Word clock
  about 539
Write Automation command 400, 401
Write Switches to Touch After Pass preference 56
Write to Start/All/End buttons 397
writing
  automation 384
  automation on stop 399
  automation to start, end, or all 397
  snapshot automation 400

Z
zero-crossing 175
Zoom buttons 186
Zoom Preset buttons 186
Zoomer tool 186
zooming 186
  all the way out 187
  horizontally for all tracks 187
  on a selection 187
  return to the previous zoom level 187
  vertically for all audio tracks 187
  vertically for all MIDI tracks 187
zooming continuously 187