# Contents

## Part I  Introduction

### Chapter 1. Welcome to Pro Tools  
- The Pro Tools Guides ........................................... 3  
- Compatibility Information .................................. 4  
- About www.digidesign.com .................................. 4

### Chapter 2. Pro Tools System Configurations  
- Pro Tools|HD Systems ........................................... 5  
- Pro Tools LE Systems .......................................... 9  
- Pro Tools M-Powered .......................................... 10  
- Pro Tools LE with DV Toolkit 2 and Pro Tools LE or M-Powered with Music Production Toolkit . 11

### Chapter 3. Pro Tools Concepts  
- Hard Disk Audio Recording .................................. 13  
- The Digidesign Audio Engine ................................ 13  
- Pro Tools Sessions ............................................. 14  
- System Resources .............................................. 18  
- MIDI Concepts .................................................. 20

### Chapter 4. Pro Tools Main Windows  
- The Mix Window ................................................. 23  
- The Edit Window ............................................... 23  
- The Transport Window ........................................ 27  
- Menus and Windows ............................................ 32  
- Tool Tips ......................................................... 33

### Chapter 5. Keyboard and Right-Click Mouse Shortcuts  
- Right-Click Mouse Shortcuts .................................. 35  
- Global Key Commands ......................................... 35  
- Keyboard Focus .................................................. 36  
- Numeric Keypad Modes ....................................... 37
Part II               Sessions & Tracks

Chapter 6. Sessions ................................................................. 41
  Starting Up or Shutting Down Your System .................................. 41
  Configuring Pro Tools System Settings (in the Playback Engine) ........ 41
  Configuring Pro Tools Hardware Settings .................................... 46
  Creating a New Session ....................................................... 49
  Session Files and Folders .................................................... 50
  Opening a Session ............................................................ 51
  Saving a Session ............................................................. 53
  Creating Custom Session Templates ......................................... 57
  Closing a Session ............................................................ 58
  Quitting Pro Tools ............................................................. 58
  System Usage ........................................................................ 59
  Preferences ........................................................................... 60

Chapter 7. I/O Setup ............................................................... 75
  The I/O Setup Dialog ......................................................... 78
  Routing Hardware I/O to Pro Tools I/O ....................................... 79
  Creating and Editing Paths .................................................... 81
  I/O Settings Files ............................................................... 88
  I/O Setup Options ............................................................... 90
  H/W Insert Delay Compensation .............................................. 93

Chapter 8. Tracks ................................................................. 95
  Track Types ........................................................................... 95
  Track Channel Strips ............................................................. 97
  Track Controls and Indicators ................................................. 100
  Adjusting Track Width .......................................................... 102
  Creating Tracks ................................................................. 102
  The Track List ..................................................................... 107
  Track Name Right-Click Pop-Up Menus ....................................... 110
  Assigning Inputs and Outputs to Tracks ...................................... 110
  Track Priority and Voice Assignment ......................................... 112
  Setting MIDI Input and Output ................................................. 116
  Soloing and Muting Tracks ..................................................... 118
  Making Tracks Inactive ........................................................ 122
  Color Coding for Tracks, Regions, Markers and Groups .............. 123
  Grouping Tracks .................................................................. 126
  Group Controls .................................................................... 127
  Working with Groups ........................................................... 130
  Setting Group Attributes ....................................................... 133
  Enabling Groups .................................................................. 135
  Grouped Control Offsets ....................................................... 136
## Chapter 9. Importing and Exporting Session Data

- Importing Audio ........................................... 137
- Conversion Quality ........................................ 139
- Importing Audio Files and Regions ...................... 140
- Importing Tracks and Track Attributes .................. 144
- Exporting Audio ........................................... 150
- Exporting Pro Tools Tracks as OMFI or AAF Sequences . 153
- Exporting Sessions as Text ................................ 153
- Send via DigiDelivery ...................................... 155
- Importing MIDI Files ...................................... 156
- Exporting MIDI Files ....................................... 158
- Importing and Exporting Region Group Files .......... 159

## Chapter 10. File and Session Management and Compatibility

- Audio File Management ..................................... 163
- WAV File Compatibility ................................... 165
- Sharing Sessions Created on Different Computer Platforms . 166
- Sharing Sessions Created on Different Pro Tools Systems 170
- Sharing Sessions Created on Different Pro Tools Software Versions . 172
- Multilingual Application Support for Pro Tools Systems . 175

## Part III  Recording

### Chapter 11. Record Setup

- Input Connections and Audio Levels .................... 179
- Record Enabling Tracks ................................... 180
- Record Monitoring Modes .................................. 182
- Monitor Levels for Record and Playback ................ 184
- Monitoring Latency ........................................ 184
- Low Latency Monitoring with Delay Compensation ........ 185
- Default Track Names ....................................... 186
- Disk Allocation ............................................. 187
- Allocating Hard Drive Space for Recording .............. 189
- Monitoring Drive Space .................................... 190
- Record Modes .............................................. 190
- Recording with a Click .................................... 193
- Setting the Default Meter and Tempo .................... 194

### Chapter 12. Basic Audio Recording

- Recording an Audio Track ................................ 197
- Record Shortcuts .......................................... 197
- Record Pause Mode ....................................... 200
- Recording Additional Takes ................................ 201
### Punch Recording Audio

- Punch Recording Audio
- Loop Recording Audio
- Auditioning Different Record Takes in the Timeline
- Setting Punch/Loop Points
- Recording from a Digital Source
- Half-Speed Recording and Playback

### Chapter 13. MIDI Recording

- Recording from MIDI Devices
- Enabling Input Devices
- MIDI Thru
- MIDI Input Filter
- Input Quantize
- Wait for Note
- MIDI Merge/Replace
- Configuring MIDI or Instrument Tracks for Recording
- Recording to MIDI and Instrument Tracks
- Punch Recording MIDI
- Loop Recording MIDI
- MIDI Step Input
- Recording System Exclusive Data

### Chapter 14. Advanced Recording

- QuickPunch Audio Recording
- TrackPunch Audio Recording
- DestructivePunch Audio Recording

### Part IV. Editing

### Chapter 15. Editing Basics

- Pro Tools Editing
- Track Material
- Displaying Region Names, Region Times, and Other Data in Playlists
- Audio Regions and Waveforms
- MIDI Regions and MIDI Data
- Timebase Rulers and Conductor Rulers
- Main Time Scale
- Tick-Based Timing
- Playlists
- Multiple Undo
- The Region List
- Edit Modes
- Edit Tools
Using the Zoomer Tools .............................................. 284
Using the Trim Tools .................................................. 289
Using the Selector Tool .............................................. 293
Using the Grabber Tools ............................................ 293
Using the Smart Tool ............................................... 294
Using the Scrubber Tool ............................................ 296
Using the Pencil Tool ............................................... 299
The Universe Window .............................................. 299

Chapter 16. Playing and Selecting Track Material ................. 301
Playing Tracks .......................................................... 301
Auto-Scrolling Tracks in the Mix and Edit Windows ............... 306
Scrolling Options ..................................................... 307
Linking or Unlinking Timeline and Edit Selections ................. 308
Linking or Unlinking Track and Edit Selections ..................... 310
Selecting Track Material ............................................ 310
Playing Selections .................................................... 320
Timeline Selections ................................................... 322
TCE (Time Compression and Expansion) Edit To Timeline Selection ........................................... 323
Playing Timeline and Edit Selections with the Playhead ......... 324

Chapter 17. Working with Regions and Selections ............... 327
Creating New Regions .............................................. 327
Trimming Commands ................................................. 331
Healing Separated Regions ........................................ 333
Placing Regions in Tracks .......................................... 333
Sync Points ............................................................ 344
Nudging ................................................................. 345
Shift Command ......................................................... 347
Quantizing Regions to Grid ........................................ 348
Locking Regions ....................................................... 348
Muting/Unmuting Regions .......................................... 349
Replacing Audio Regions ......................................... 349
Choosing an Alternate Channel for a Specific Region ......... 352
Edit Commands ........................................................ 353
Duplicate Command ................................................ 358
Repeat Command ...................................................... 359
Editing Stereo and Multichannel Tracks ......................... 360
Processing Audio with AudioSuite Plug-ins .................. 361
Waveform Repair with the Pencil Tool ......................... 361
Region Groups ......................................................... 362
Region Looping ........................................................ 370
## Chapter 18. Fades and Crossfades
- Creating a Crossfade: 381
- Creating Fades at the Beginnings and Ends of Regions: 383
- Using AutoFades: 384
- Creating Fades and Crossfades in Batches: 385
- Moving and Nudging Fades: 386
- Separating Regions That Include Fades: 389
- Trimming Regions That Include Fades: 389
- Fade Boundaries and Shapes in Displayed Automation View: 390

## Chapter 19. Managing Regions
- Stripping Silence from Regions: 391
- Inserting Silence: 394
- Consolidate Command: 395
- Compacting an Audio File: 395
- Naming and Displaying Regions: 396

## Chapter 20. Conductor Tracks and Memory Locations
- Song Start Marker: 399
- Tempo: 400
- Graphic Tempo Editor: 404
- Changing the Linearity Display Mode: 409
- Tempo Operations Window: 410
- Identify Beat Command: 416
- Meter Events: 420
- Time Operations: 422
- Renumbering Bars: 428
- Memory Locations and Markers: 428
- Memory Locations Window: 435

## Chapter 21. Beat Detective
- Beat Detective Requirements: 438
- The Beat Detective Window: 439
- Beat Detective Modes: 439
- Defining a Beat Detective Selection: 440
- Calculating Tempo with Beat Detective: 441
- Generating Beat Triggers: 442
- Generating Bar|Beat Markers with Beat Detective: 447
- DigGroove Templates: 448
- Separating Regions with Beat Detective: 450
- Conforming Regions with Beat Detective: 452
- Edit Smoothing: 454
- Detection (Normal) and Collection Mode: 456
## Part V  MIDI Editing

### Chapter 22. MIDI Editing
- Mirrored MIDI Editing .................................................. 461
- The Pencil Tool ............................................................. 462
- Custom Note Duration .................................................... 463
- Setting the Grid Value ................................................... 464
- Inserting MIDI Notes ..................................................... 464
- Manually Editing MIDI Notes ......................................... 465
- Time Compression/Expansion Trim Tool Functionality on MIDI Regions ........................................... 470
- Continuous Controller Events ......................................... 472
- Patch Select (Program and Bank Changes) ...................... 474
- System Exclusive Events ............................................... 478
- Note and Controller Chasing .......................................... 479
- Offsetting MIDI Tracks .................................................. 480
- Stuck Notes ................................................................. 481
- Remove Duplicate Notes ................................................ 481

### Chapter 23. MIDI Operations
- MIDI Operations Window .............................................. 483
- Grid/Groove Quantize .................................................... 484
- Restore Performance .................................................... 494
- Flatten Performance ..................................................... 495
- Change Velocity .......................................................... 496
- Change Duration ......................................................... 498
- Transpose ................................................................. 500
- Select/Split Notes ....................................................... 501
- Input Quantize ............................................................ 503
- Step Input ................................................................. 503
- MIDI Real-Time Properties ........................................... 506

### Chapter 24. MIDI Event List
- The MIDI Event List ..................................................... 513
- Inserting Events in the MIDI Event List ......................... 516
- Editing in the MIDI Event List ....................................... 518
- MIDI Event List Options ............................................... 520
Creating Snapshot Automation ............................................. 625
Previewing Automation ......................................................... 628
Capturing Automation ......................................................... 630
VCA Master Track Automation .............................................. 632

Chapter 28. Mixdown ............................................................. 635
Recording to Tracks .............................................................. 637
Bounce to Disk ................................................................. 638
Bounce Options ................................................................. 639
Recording a Submix (with Bounce to Disk) .................................. 645
Final Mixdown ................................................................. 646
Mastering ................................................................. 647

Part VII Video, Sync, & Surround

Chapter 29. Working with Video in Pro Tools ................................ 651
Introduction ................................................................. 651
About QuickTime ............................................................. 652
Before Starting Your Project .................................................. 652
Video Tracks ................................................................. 653
Video Track Controls and Indicators ....................................... 654
Locking Video Tracks ......................................................... 656
Setting the Video Engine Rate .................................................. 656
Importing Video into Pro Tools .................................................. 657
Extracting Audio from QuickTime-Compatible Video .................. 660
Video Regions ................................................................. 661
General Video Editing .......................................................... 662
Video Region Groups .......................................................... 665
Using the Video Window ....................................................... 665
Browsing Video in the Video Universe Window ......................... 666
Playback of HD QuickTime Movies .......................................... 668
FireWire Playback of QuickTime DV Movies ............................. 668
Bouncing the Video Track to a QuickTime Movie ......................... 671
<table>
<thead>
<tr>
<th>Chapter 30. Working with Synchronization</th>
<th>673</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pro Tools Synchronization Options</td>
<td>673</td>
</tr>
<tr>
<td>Session Setup Window</td>
<td>675</td>
</tr>
<tr>
<td>Preparing to Work with SMPTE</td>
<td>679</td>
</tr>
<tr>
<td>Configuring Pro Tools for SMPTE</td>
<td>679</td>
</tr>
<tr>
<td>Pull Up and Pull Down</td>
<td>682</td>
</tr>
<tr>
<td>Putting Pro Tools Online</td>
<td>686</td>
</tr>
<tr>
<td>Generating Time Code</td>
<td>686</td>
</tr>
<tr>
<td>Using MIDI Machine Control</td>
<td>687</td>
</tr>
<tr>
<td>Setting Minimum Sync Delay</td>
<td>690</td>
</tr>
<tr>
<td>Remote Track Arming</td>
<td>690</td>
</tr>
<tr>
<td>MIDI Beat Clock</td>
<td>691</td>
</tr>
<tr>
<td>Spotting Regions to SMPTE Frame Locations</td>
<td>691</td>
</tr>
<tr>
<td>Time Stamping</td>
<td>694</td>
</tr>
<tr>
<td>Identifying a Synchronization Point</td>
<td>696</td>
</tr>
<tr>
<td>Troubleshooting Synchronization</td>
<td>696</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Chapter 31. Pro Tools Setup for Surround (Pro Tools HD Only)</th>
<th>699</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pro Tools Audio Connections for 5.1 Mixing</td>
<td>699</td>
</tr>
<tr>
<td>Configuring Pro Tools for Multichannel Sessions</td>
<td>700</td>
</tr>
<tr>
<td>Default I/O Selectors in I/O Setup</td>
<td>703</td>
</tr>
<tr>
<td>5.1 Track Layouts, Routing, and Metering</td>
<td>704</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Chapter 32. Multichannel Tracks and Signal Routing (Pro Tools HD Only)</th>
<th>705</th>
</tr>
</thead>
<tbody>
<tr>
<td>Multichannel Quick Start</td>
<td>705</td>
</tr>
<tr>
<td>Multichannel Audio Tracks</td>
<td>706</td>
</tr>
<tr>
<td>Multichannel Signal Routing</td>
<td>709</td>
</tr>
<tr>
<td>Paths in Surround Mixes</td>
<td>712</td>
</tr>
<tr>
<td>Example Paths and Signal Routing for a Surround Mix</td>
<td>714</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Chapter 33. Surround Panning and Mixing (Pro Tools HD Only)</th>
<th>719</th>
</tr>
</thead>
<tbody>
<tr>
<td>Introduction to Pro Tools Surround Panning</td>
<td>719</td>
</tr>
<tr>
<td>Output Windows</td>
<td>720</td>
</tr>
<tr>
<td>Standard Controls</td>
<td>721</td>
</tr>
<tr>
<td>Surround Panner Controls</td>
<td>722</td>
</tr>
<tr>
<td>Panning Modes</td>
<td>724</td>
</tr>
<tr>
<td>Divergence and Center Percentage</td>
<td>727</td>
</tr>
<tr>
<td>LFE Faders in Multichannel Panners</td>
<td>729</td>
</tr>
<tr>
<td>Pan Playlists</td>
<td>730</td>
</tr>
<tr>
<td>Surround Scope Plug-in</td>
<td>730</td>
</tr>
</tbody>
</table>

| Index                                                                   | 731 |
Part I: Introduction
Welcome to Pro Tools®. Pro Tools integrates powerful multitrack digital audio and MIDI sequencing features, giving you everything you need to record, arrange, edit, mix, and master quality audio for music, video, film, and multimedia.

The Pro Tools Guides

Pro Tools systems include the following guides:

Getting Started Guide Instructions for installing your Pro Tools system and connecting your studio. For Pro Tools LE and M-Powered, these guides also contain specific methods for accomplishing common tasks (such as recording in a Pro Tools session, importing audio from a CD, and creating an audio CD from a Pro Tools session).

Pro Tools Reference Guide Full details on all Pro Tools functionality and operations. (Pro Tools LE and M-Powered systems only include an electronic PDF version of the Reference Guide.)


Pro Tools Keyboard Shortcuts Separate electronic PDF guides for Windows and Mac that list keyboard and Right-click shortcuts, including those shown in Pro Tools menus.

DigiRack Plug-ins Guide Electronic PDF guide with instructions for using the DigiRack plug-ins (included with Pro Tools) for both real-time and file-based audio processing in Pro Tools.

Digidesign Plug-ins Guide Electronic PDF guide with instructions for using optional Digidesign plug-ins for both real-time and file-based audio processing in Pro Tools.

Digibase Guide Full details on using Pro Tools DigiBase databasing and browsers for data and media management. (Pro Tools LE and M-Powered systems only include an electronic PDF version of this guide.)

Expanded Systems Guide (Pro Tools|HD Systems Only) Instructions for expanding a Pro Tools|HD system with optional Digidesign cards or an expansion chassis.

MachineControl™ Guide (Pro Tools|HD Systems Only) Electronic PDF guide for MachineControl option, includes installation and operation instructions for using the MachineControl option for Pro Tools to enable serial communication with remote audio and video transports.

Additional Guides

Additional PDF guides (such as a Glossary) are installed with Pro Tools. Refer to your Pro Tool documentation folder.
Digidesign also provides guides with audio interfaces, dedicated worksurfaces (such as D-Control) and controllers (such as Command|8), and other Digidesign options (such as MIDI I/O, PRE, and SYNC I/O). Refer to the separate guide provided with each Digidesign product.

Conventions Used in These Guides

The Pro Tools guides use the following conventions to indicate menu choices, keyboard commands, and mouse commands:

<table>
<thead>
<tr>
<th>Convention</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>File &gt; Save</td>
<td>Choose Save from the File menu</td>
</tr>
<tr>
<td>Control+N</td>
<td>Hold down the Control key and press the N key</td>
</tr>
<tr>
<td>Control-click</td>
<td>Hold down the Control key and click the mouse button</td>
</tr>
<tr>
<td>Right-click</td>
<td>Click with the right mouse button</td>
</tr>
</tbody>
</table>

The following symbols are used to highlight important information:

💡 User Tips are helpful hints for getting the most from your Pro Tools system.

⚠️ Important Notices include information that could affect your Pro Tools session data or the performance of your Pro Tools system.

🔍 Shortcuts show you useful keyboard or mouse shortcuts.

🔍 Cross References point to related sections in this guide and other Digidesign guides.

Compatibility Information

Digidesign can only assure compatibility and provide support for hardware and software it has tested and approved.

For a list of Digidesign-qualified computers, operating systems, hard drives, and third-party devices, refer to the Digidesign Web site (www.digidesign.com).

About www.digidesign.com

The Digidesign Web site (www.digidesign.com) is your best online source for information to help you get the most out of your Pro Tools system. The following are just a few of the services and features available.

Registration Register your purchase online. See the registration form included with your system for instructions.

Support Contact Digidesign Technical Support or Customer Service; download software updates and the latest online manuals; browse the Compatibility documents for system requirements; search the online Answerbase or join the worldwide Pro Tools community on the Digidesign User Conference.

Training and Education Study on your own using courses available online or find out how you can learn in a classroom setting at a certified Pro Tools training center.

Products and Developers Learn about Digidesign products; download demo software or learn about our Development Partners and their plugins, applications, and hardware.

News and Events Get the latest news from Digidesign or sign up for a Pro Tools demo.
There are three types of Pro Tools systems:

**Pro Tools|HD** These systems include Pro Tools HD® software for Pro Tools|HD system hardware.

**Pro Tools LE** These systems include Pro Tools LE™ software for Digi 002®, Digi 002 Rack™, Mbox® 2, or Mbox® hardware.

**Pro Tools M-Powered™** These systems include Pro Tools M-Powered software for Digidesign-qualified M-Audio® interfaces.

**Optional Systems**

**Pro Tools LE with DV Toolkit 2** Pro Tools LE systems that have been upgraded with the DV Toolkit™ 2 software option.

**Pro Tools LE or M-Powered with Music Production Toolkit** Pro Tools LE or M-Powered systems that have been upgraded with the Music Production Toolkit software option.

**Pro Tools|HD Systems**

Pro Tools|HD systems are available in the configurations shown on page 6. Each system requires at least one Digidesign audio interface (sold separately). Pro Tools|HD systems can be expanded by adding Pro Tools|HD system cards to increase track count, add to the amount of possible plug-in and mixer processing, and connect additional audio interfaces.

⚠️ **Pro Tools system performance depends on factors such as computer processor speed, amount of system memory, and hard drive performance. Contact your Digidesign dealer or visit Digidesign’s Web site for the latest system requirements and compatibility information.**
Pro Tools|HD Systems

Pro Tools|HD 1
Includes:
• HD Core card
• Pro Tools HD software

Pro Tools|HD 2 Accel
Includes:
• HD Core card
• HD Accel card
• Pro Tools HD software

Pro Tools|HD 3 Accel
Includes:
• HD Core card
• Two HD Accel cards
• Pro Tools HD software

Pro Tools|HD 2
Includes:
• HD Core card
• HD Process card
• Pro Tools HD software

Pro Tools|HD 3
Includes:
• HD Core card
• Two HD Process cards
• Pro Tools HD software

Supported Audio Interfaces
(Pro Tools|HD Systems Only)

The following audio interfaces are compatible with Pro Tools|HD systems:
• 192 I/O™
• 192 Digital I/O™
• 96 I/O™
• 96i I/O™

Pro Tools|HD systems require the use of at least one 192 I/O, 192 Digital I/O, 96 I/O, or 96i I/O.

The following “Legacy” Digidesign audio interfaces are supported with Pro Tools|HD systems:
• 888|24 I/O™ and 882|20 I/O™
• 1622 I/O™
• 24-bit ADAT Bridge I/O™

“Legacy” I/Os (such as 888|24 I/O) require the use of at least one 192 I/O, 192 Digital I/O, 96 I/O, or 96i I/O.

HD Accel and HD Process cards can be used in the same system. For more information, refer to the Pro Tools|HD Getting Started Guide.
Pro Tools|HD System Playback, Recording and Voice Limits

The following table lists the audio playback, recording, and voiceable track limits of each type of Pro Tools|HD system. Playback and recording voices refer to the number of unique simultaneous playback and record tracks on your system. Total voiceable tracks refers to the maximum number of audio tracks that can share the available voices on your system. (Mono tracks take up one voice. Stereo and multichannel tracks take up one voice per channel.) Voice limits are dependent on the session sample rate and the number of DSP chips dedicated to the system’s Playback Engine. Pro Tools|HD systems can open sessions with up to 256 audio tracks, but any audio tracks beyond that system’s voiceable track limit will be automatically set to Voice Off.

### Table 3. Pro Tools|HD system audio playback, recording and voice limits

<table>
<thead>
<tr>
<th>Core System Type</th>
<th>Sample Rate (kHz)</th>
<th>Playback Voices (Mono Tracks of Simultaneous Playback)</th>
<th>Recording Voices (Mono Tracks of Simultaneous Recording)</th>
<th>Total Voiceable Tracks</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pro Tools</td>
<td>HD 1</td>
<td>44.1/48</td>
<td>96</td>
<td>96</td>
</tr>
<tr>
<td></td>
<td>88.2/96</td>
<td>48</td>
<td>48</td>
<td>48</td>
</tr>
<tr>
<td></td>
<td>176.4/192</td>
<td>12</td>
<td>12</td>
<td>12</td>
</tr>
<tr>
<td>Pro Tools</td>
<td>HD Accel 2, Pro Tools</td>
<td>HD Accel 3</td>
<td>44.1/48</td>
<td>192</td>
</tr>
<tr>
<td></td>
<td>88.2/96</td>
<td>96</td>
<td>96</td>
<td>120</td>
</tr>
<tr>
<td></td>
<td>176.4/192</td>
<td>36</td>
<td>36</td>
<td>36</td>
</tr>
<tr>
<td>Pro Tools</td>
<td>HD 2, Pro Tools</td>
<td>HD 3, or any expanded Pro Tools</td>
<td>HD system</td>
<td>44.1/48</td>
</tr>
<tr>
<td></td>
<td>88.2/96</td>
<td>64</td>
<td>64</td>
<td>80</td>
</tr>
<tr>
<td></td>
<td>176.4/192</td>
<td>24</td>
<td>24</td>
<td>24</td>
</tr>
</tbody>
</table>

Pro Tools|HD systems provide up to 160 Auxiliary Input tracks and a total of 128 internal mix busses. These systems also provide up to 5 inserts and 10 sends per track (depending on the DSP capacity of your system). In addition, Pro Tools|HD systems support up to 128 Instrument tracks and 256 MIDI tracks.
Audio Interfaces for Pro Tools|HD Systems

Table 4 lists the input and output capabilities of the various audio interfaces for Pro Tools|HD systems.

<table>
<thead>
<tr>
<th>Interface Type</th>
<th>Number of I/O Channels</th>
<th>Sample Rates (kHz)</th>
<th>A/D Conversion</th>
<th>D/A Conversion</th>
<th>Digital I/O</th>
</tr>
</thead>
<tbody>
<tr>
<td>192 I/O</td>
<td>16 in/16 out</td>
<td>44.1, 48, 88.2, 96, 176.4, 192</td>
<td>24-bit</td>
<td>24-bit</td>
<td>24-bit</td>
</tr>
<tr>
<td>192 Digital I/O</td>
<td>16 in/16 out</td>
<td>44.1, 48, 88.2, 96, 176.4, 192</td>
<td>None</td>
<td>None</td>
<td>24-bit</td>
</tr>
<tr>
<td>96 I/O</td>
<td>16 in/16 out</td>
<td>44.1, 48, 88.2, 96</td>
<td>24-bit</td>
<td>24-bit</td>
<td>24-bit</td>
</tr>
<tr>
<td>96i I/O</td>
<td>16 in/2 out</td>
<td>44.1, 48, 88.2, 96</td>
<td>24-bit</td>
<td>24-bit</td>
<td>24-bit</td>
</tr>
<tr>
<td>888</td>
<td>24 I/O</td>
<td>8 in/8 out</td>
<td>44.1, 48</td>
<td>24-bit</td>
<td>24-bit (or 20-bit, on older I/O)</td>
</tr>
<tr>
<td>882</td>
<td>20 I/O</td>
<td>8 in/8 out</td>
<td>44.1, 48</td>
<td>20-bit</td>
<td>20-bit</td>
</tr>
<tr>
<td>1622 I/O</td>
<td>16 in/2 out</td>
<td>44.1, 48</td>
<td>20-bit</td>
<td>24-bit</td>
<td>24-bit</td>
</tr>
<tr>
<td>24-bit ADAT Bridge I/O</td>
<td>16 in/16 out</td>
<td>44.1, 48</td>
<td>None</td>
<td>24-bit</td>
<td>24-bit</td>
</tr>
</tbody>
</table>

You can expand your Pro Tools|HD system by adding Pro Tools|HD cards to your computer, either directly in the computer or using an expansion chassis. Expanding your Pro Tools system will provide an increased track count, add to the amount of possible plug-in and mixer processing, and let you connect additional audio interfaces. For more information, see the Expanded Systems Guide.

⚠ “Legacy” I/Os (such as 888|24 I/O) require the use of at least one 192 I/O, 192 Digital I/O, 96 I/O, or 96i I/O.
Pro Tools LE Systems

Pro Tools LE-based systems are available in the following configurations:

Digi 002
A Digi 002 system includes:
• Digi 002 combined audio and MIDI interface, with a controller
• Pro Tools LE software

Digi 002 Rack
A Digi 002 Rack system includes:
• Digi 002 audio and MIDI interface
• Pro Tools LE software

Mbox 2
An Mbox 2 system includes:
• Mbox 2 audio and MIDI interface
• Pro Tools LE software

Mbox
An Mbox system includes:
• Mbox audio interface
• Pro Tools LE software

Processing Capacity

⚠️ The total processing capacity of a Pro Tools LE system depends on the processing power of your computer. Contact your Digidesign dealer or visit Digidesign’s Web site (www.digidesign.com) for the latest system requirements and compatibility information.
Pro Tools LE System Capabilities

Table 5 lists the playback, recording, and input and output capabilities of each Pro Tools LE system. Mono tracks of simultaneous playback refers to the number of unique simultaneous playback and record tracks on your system. Total voiceable tracks refers to the maximum number of audio tracks that can share the available voices on your system. (Mono tracks take up a single audio track, while stereo tracks take up two tracks.) If you open a Pro Tools session created on a Pro Tools|HD system containing more than the number of tracks supported on the LE-based system, audio tracks beyond the LE system’s voiceable track limit will be automatically set to inactive.

Pro Tools LE systems provide up to 128 Auxiliary Input tracks, a total of 32 internal mix busses, and up to 5 inserts and 10 sends per track (depending on your computer’s processing capacity). In addition, Pro Tools LE systems support up to 32 Instrument tracks and 256 MIDI tracks.

For details on transferring session material between Pro Tools|HD and Pro Tools LE systems, see “Sharing Sessions Created on Different Pro Tools Systems” on page 170.

### Table 5. Pro Tools LE system audio playback, recording, and channel capabilities

<table>
<thead>
<tr>
<th>System Type</th>
<th>Mono Tracks of Simultaneous Playback</th>
<th>Total Voiceable Tracks</th>
<th>Number of I/O Channels</th>
<th>A/D Conversion</th>
<th>D/A Conversion</th>
<th>Digital I/O</th>
</tr>
</thead>
<tbody>
<tr>
<td>Digi 002 or Digi 002 Rack</td>
<td>32</td>
<td>128</td>
<td>up to 18 in/18 out (48 kHz or lower)</td>
<td>24-bit</td>
<td>24-bit</td>
<td>24-bit</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>up to 10 in/10 out (88.2 or 96 kHz)</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Mbox 2 or Mbox</td>
<td>32</td>
<td>128</td>
<td>up to 2 in/2 out</td>
<td>24-bit</td>
<td>24-bit</td>
<td>24-bit</td>
</tr>
</tbody>
</table>

Pro Tools LE systems provide up to 128 Auxiliary Input tracks, a total of 32 internal mix busses, and up to 5 inserts and 10 sends per track (depending on your computer’s processing capacity). In addition, Pro Tools LE systems support up to 32 Instrument tracks and 256 MIDI tracks.

For details on transferring session material between Pro Tools|HD and Pro Tools LE systems, see “Sharing Sessions Created on Different Pro Tools Systems” on page 170.

Pro Tools M-Powered

A Pro Tools M-Powered system includes:

- Pro Tools M-Powered software
- Digidesign-qualified M-Audio interface (not supplied with M-Powered software)

⚠️ References to Pro Tools LE in this guide are usually interchangeable with Pro Tools M-Powered, except as noted in this guide and the Pro Tools M-Powered Getting Started Guide.

⚠️ For the most current list of Digidesign-qualified M-Audio interfaces, see the Digidesign Web site (www.digidesign.com).
Pro Tools LE with DV Toolkit 2 and Pro Tools LE or M-Powered with Music Production Toolkit

In addition to all the regular capabilities provided with Pro Tools LE and Pro Tools M-Powered, Pro Tools LE systems equipped with DV Toolkit 2 and Pro Tools LE and M-Powered systems equipped with Music Production Toolkit provide expanded capabilities.

Support for 48 Mono or Stereo Tracks

Pro Tools LE systems with the DV Toolkit 2 option and Pro Tools LE or M-Powered systems with the Music Production Toolkit option let you play or record up to 48 simultaneous stereo or mono tracks. These higher track counts may require additional drives and faster Digidesign-qualified computers.

Visit the Digidesign Web site for more information (www.digidesign.com).

For more information on track priority and voice assignment, see “Voice Assignment with Toolkit Options” on page 114.

Support for Up to 24 QuickPunch Tracks

With DV Toolkit 2 or Music Production Toolkit, up to 24 mono or stereo audio tracks can be simultaneously recorded with QuickPunch.

The combination of audio tracks and QuickPunch tracks cannot be greater than 48.

DV Toolkit 2 Capabilities

(Pro Tools LE Only)

Pro Tools LE Features

DV Toolkit 2 enables the following features for working with audio, film, video, or digital video in Pro Tools LE:

• Session and track features:
  • Up to 48 audio tracks of simultaneous playback or recording, mono or stereo
  • Ability to use QuickPunch on up to 24 tracks
  • Import Session Data options (Destination Track Names, Time Code Mapping, Find Matching Tracks, Session Data to Import, Track Playlist)
  • MP3 export option (for bounce recording or exporting a region as an MP3 file)
  • DigiBase Pro (including support for Catalog browsers and the ability to search on multiple criteria simultaneously in DigiBase browsers)

• Editing features:
  • Universe window
  • Continuous Scroll
  • Scrub Trim tool
  • Replace Region command
  • TCE Edit to Timeline Selection command

• Mixing and Automation features
  • Snapshot automation for writing or trimming automation data
  • Glide Automation commands

Visit the Digidesign Web site for more information (www.digidesign.com).

For more information on track priority and voice assignment, see “Voice Assignment with Toolkit Options” on page 114.
• Time code and synchronization features:
  • Timebase rulers (Time Code and Feet+Frames)
  • Time Code Rate selector
  • Feet+Frame Rate selector
  • Current Time Code Position command
  • Current Feet+Frames Position command
  • Use Subframes option
  • Audio Rate Pull Up and Pull Down
  • Video Rate Pull Up and Pull Down

Optional Software
DV Toolkit 2 includes the following optional software for working with audio or digital video in Pro Tools LE:

**DINR™ (Digidesign Intelligent Noise Reduction™) LE Plug-in** For reducing noise in audio.

**DigiTranslator™ Software Option** For exchanging audio and video files, and sequences with other AAF and OMFI-compatible applications.

**TL Space Native™ Convolution Reverb Plug-in** For applying convolution reverbs to your audio.

**VocALign Project Plug-in from Synchro Arts Software** For automatically adjusting the timing of one audio signal to match another.

Music Production Toolkit Overview
(Pro Tools LE and Pro Tools M-Powered Only)

Pro Tools Features
Music Production Toolkit enables the following features in Pro Tools LE and M-Powered:

• Session and track features:
  • Up to 48 audio tracks of simultaneous playback or recording, mono or stereo
  • Ability to use QuickPunch on up to 24 tracks
  • MP3 export option (for bounce recording or exporting a region as an MP3 file)

• Beat Detective features:
  • Ability to apply Beat Detective across multiple tracks
  • Collection Mode

Optional Software
Music Production Toolkit includes the following optional software for working with Pro Tools LE and M-Powered:

**DINR™ (Digidesign Intelligent Noise Reduction™) LE Plug-in** For reducing noise in audio.

**Hybrid RTAS Synthesizer Plug-in** For use as a virtual instrument in your Pro Tools sessions.

**Smack!™ LE Compressor Plug-in** For applying compression to your audio.

**SoundReplacer™ Plug-in** For replacing one sound in a track with another (such as replacing only the snares in your drum track with a different one-hit sample)

**TL Space Native™ Convolution Reverb Plug-in** For applying convolution reverbs to your audio.
This chapter explains the principles and concepts that form the foundation of Pro Tools operation and functionality.

**Hard Disk Audio Recording**

Tape-based recording is a *linear* medium—you need to rewind or fast forward a tape to hear a particular spot in a recording. To rearrange or repeat material in a linear system, you need to re-record it, or cut and splice it.

Hard disk recording is a *nonlinear* (or random access) medium—you can go immediately to any spot in a recording without having to rewind or fast forward.

Nonlinear systems have several advantages. You can easily rearrange or repeat parts of a recording by making the hard disk read parts of the recording in a different order and/or multiple times. In addition, this re-arrangement is *non-destructive,* meaning that the original recorded material is not altered.

Pro Tools is a nonlinear recording system that lets you rearrange and mix recorded material nondestructively.

---

**The Digidesign Audio Engine**

DAE (or Digidesign Audio Engine) is Digidesign’s real-time operating system for digital audio recording, playback, and processing. When you install Pro Tools, DAE is automatically installed on your system.

In the same way that a computer’s operating system provides the foundation for programs that run on the computer, DAE provides the foundation for much of the hard disk recording, digital signal processing, and mix automation required by Pro Tools and other products from Digidesign and its Development Partners.

The DAE Playback Buffer Size determines the amount of memory DAE allocates to manage disk buffers.

For information on configuring the DAE Playback Buffer Size, see “DAE Playback Buffer Size” on page 45.

The DAE Playback Buffer Size can be changed in the Playback Engine dialog (see “Playback Engine Dialog” on page 14).
Playback Engine Dialog

Pro Tools takes advantage of your computer’s host processor for certain tasks and optional host-based DSP processing.

Pro Tools LE uses host (CPU) processing to provide audio track recording, playback, mixing, and effects processing. Pro Tools HD can also use host processing to run RTAS plug-ins for effects processing. Performance is determined by your system and its Playback Engine settings.

The Playback Engine dialog lets you set a hardware buffer size and allocate a percentage of CPU resources for these tasks.

On Pro Tools|HD systems, you can select the number of voices and voiceable tracks for your system and its sessions. Voice count choices are based on how much DSP processing you want to allocate for voicing.

For more information, see “Configuring Pro Tools System Settings (in the Playback Engine)” on page 41. See also “System Resources” on page 18.

On Pro Tools|HD systems, the Playback Engine dialog is also where you assign dedicated DSP resources for Delay Compensation.

Pro Tools Sessions

When you start a project in Pro Tools, you create a session. Some basic elements of sessions are explained in this section.

Session File

A session file is the document that Pro Tools creates when you choose File > New Session and configure a new session. Pro Tools can open only one session file at a time. The session file is named with a .ptf (Pro Tools file) extension. Session files contain maps of all elements associated with a project, including audio files, MIDI data, and all your edit and mix information. It is important to realize that a Pro Tools session file does not contain any media files (audio or video). Instead, it references audio, video, MIDI, and other files. You can make changes to a session and save those changes in a new session file. This lets you create multiple versions of a session or back up your editing and mixing work.

Pro Tools HD, Pro Tools LE, and Pro Tools M-Powered have different session file icons.

Session file icons

Although there are different session file icons, the session files may be opened by all three applications (with certain restrictions). See “Opening a Session” on page 51.

When a session is transferred to a different Pro Tools system, its session file icon will change to the icon type of the destination system.
Tracks

Pro Tools tracks are where audio, MIDI, and automation data are recorded and edited. Pro Tools tracks also provide audio channels for routing internal busses, and physical inputs and outputs for audio and MIDI.

Pro Tools provides seven types of tracks: audio tracks, Auxiliary Inputs, Master Faders, VCA Masters, MIDI tracks, Instruments tracks, and video tracks.

Audio, MIDI, and Instrument track data can be edited into regions or repeated in different locations to create loops, re-arrange sections or entire songs, or to assemble tracks using material from multiple takes.

Auxiliary Input tracks can route internal audio busses or physical inputs to internal busses or physical outputs. Auxiliary Inputs are typically used for audio effects busses, audio throughput, and submixing.

Master Fader tracks provide controls for physical audio output channels, including the volume level of your mix, panning, and plug-in inserts.

VCA Masters (Pro Tools HD only) provide control of tracks in a Mix Group that has been assigned to the VCA Master.

Video tracks support both QuickTime movies and Avid video, but an individual video track can play back only one of these types of video at a time.

Audio, Auxiliary Input, Master Fader, VCA Master (Pro Tools HD only), and Instrument tracks can be mono, stereo, or multichannel (Pro Tools HD only). When creating a new track, you can choose from a list of formats supported by your system.

Audio File

When you record audio into a Pro Tools session, audio files are created.

Audio files for each session are stored in a folder named “Audio Files.” Audio files are listed in the Pro Tools Region List and can appear in an audio track. A section of an audio file can be defined as a region. See “Regions” on page 15.

Regions

A region is a segment of audio or MIDI data. A region could be a drum loop, a guitar riff, a verse of a song, a recording take, a sound effect, some dialog, or an entire sound file. A region can also have associated automation data. In Pro Tools, regions are created from audio or MIDI files, and can be arranged in audio and MIDI track playlists. Regions can also be grouped and looped.
Playlist

A playlist is a sequence of regions arranged on an audio or MIDI track. Tracks have edit playlists and automation playlists.

On audio tracks, an edit playlist tells the hard disk which audio regions to play in what order. For example, you can use the same audio region to access the same piece of audio multiple times at different locations and not use additional disk space. Different versions of the same original audio can be used in different places and have different effects applied. On MIDI and Instrument tracks, edit playlists can store multiple MIDI sequences (or performances) on a track.

A playlist can be made up of a single region or many separate regions. It can be made up of similar elements, such as regions from several different takes of a solo, or dissimilar elements, such as several sound effects.

You can create any number of alternate edit playlists for a track. This lets you assemble different versions of performances or edits on a single track and choose between them from a pop-up menu on the track.

Each track also has a single set of automation playlists, for volume, pan, mute, and each automation-enabled control for the insert and send assignments on that track.

Channel

The term channel is used to describe several related components of a Pro Tools system. The first example of channel refers to a physical input or output of your Pro Tools system.

For example, a 96 I/O audio interface (Figure 1) provides up to 16 channels of input and output to a Pro Tools|HD system, while an Mbox 2 audio interface provides up to four inputs and two outputs.

Figure 1. Back view of 96 I/O, with eight analog inputs, eight analog outputs, and eight digital input/output channels (using a lightpipe)
The second use of the term *channel* refers to a channel strip in the Pro Tools Mix window. Each track in a Pro Tools session has a corresponding *channel strip* in the Mix window.

Audio and MIDI channel strips have similar controls, but those controls have slightly different effects. For example, audio and Auxiliary Input channel strip faders control the output gain to the mix bus for that channel, while MIDI channel strip faders send MIDI volume data (MIDI controller 7) to the MIDI instrument. Instrument track channel strips combine a MIDI track and Auxiliary Input into a single channel strip.

**Signal Routing**

Pro Tools provides software-based mixing and signal routing controls. The Mix window is where these controls are located. (Some of these controls can also be accessed from the Edit window.)

A common signal routing task is to submix multiple tracks to a single channel strip (such as an Auxiliary Input or a Master Fader) for shared processing and level control. The following example shows three audio tracks submixed to a stereo Auxiliary Input.

---

**Figure 2. Channel strip in the Mix window (audio track)**

*The term channel also describes a separate aspect of MIDI operation. See “MIDI Concepts” on page 20.*
Signal Routing Options

Signal routing options include the following:

**Track Input and Output (I/O) Controls** The most basic type of signal routing is track input and output. A track needs to have an assigned input path to record audio, and an assigned output path in order to be audible through a hardware output. Signals can also be routed to or from other tracks in Pro Tools (or hardware inputs and outputs) using internal busses.

**Auxiliary Inputs and Master Faders** Auxiliary Inputs are tracks that can be used as returns, submixers, and bus masters. Master Faders are used as bus and output master level controls. Both Auxiliary Inputs and Master Faders can have plug-in and hardware inserts.

**Instrument Tracks** Instrument tracks let you route sound from a plug-in instrument to outputs, sends and busses, or other inserts.

**Sends** Sends route audio from tracks to hardware outputs, or to internal busses that are in turn routed to other tracks within Pro Tools. Master Faders and VCA Masters do not have sends.

**Plug-in and Hardware Inserts** Plug-in processing occurs completely within the Pro Tools system. Hardware inserts utilize audio interface inputs and outputs, for traditional insert routing to and from external effects and other devices.

**Paths** Paths are any routing option in Pro Tools, including internal or external inputs, outputs, busses, and inserts. Pro Tools lets you name these paths, and these path names appear in the Audio Input and Output Path selectors and other menus. See Chapter 7, “I/O Setup” for more information.

Mixing Formats Sessions can include combinations of mono, stereo, and multichannel format tracks, busses, inputs, outputs, and inserts. (Multichannel formats are supported on Pro Tools|HD systems only.)

System Resources

Track count, plug-in processing, signal path and routing options, and voice availability are ultimately limited by the combined resources available from the host computer, and from your Pro Tools hardware.

Pro Tools provides several ways to manage and conserve resources to maximize the performance of your system. As you begin working with Pro Tools sessions and tracks, you can take advantage of the following features to extend the effectiveness of your available DSP and other resources:

- Pro Tools lets you adjust the performance of your system by changing system settings that affect its capacity for processing, playback, and recording. See “Configuring Pro Tools System Settings (in the Playback Engine)” on page 41.

- In order to free up needed DSP resources, Pro Tools allows for certain items (such as tracks and inserts) to be manually made inactive. Inactive elements are viewable, editable, and retained within the session. See “Active and Inactive Items” on page 19.

- All Pro Tools systems provide flexible voice options for audio tracks, to help maximize use of available voices in your system. For more information on voice management and options, see “Voice Borrowing” on page 115.
Active and Inactive Items

Pro Tools lets you make certain items (such as tracks and inserts) inactive, in order to free up DSP resources and mixer connections.

Items in Pro Tools that can be made inactive (or active) include the following:

- Audio, Auxiliary Input, Master Fader, VCA Master, and Instrument tracks
- Track Inputs and Outputs
- Sends
- Side-chain inputs
- Plug-ins
- Hardware inserts
- Paths (session-wide)

In addition to manually setting Active and Inactive modes, Pro Tools automatically makes items inactive if there are insufficient or unavailable resources.

When active, items are fully engaged and operational.

When inactive, items are silent and off, although most associated controls can still be adjusted. Different inactive items affect available system resources in specific ways, as follows:

**Plug-ins**

When a plug-in is inactive on a track, its DSP is made available for other plug-ins and processing. Plug-in assignments can be made inactive manually, or automatically (see “Automatic and Manual Inactive Mode” on page 20).

**Paths and Path Assignments**

When a path or path assignment is inactive, its mixer resources are made available for other signal routing purposes in the session. Paths and assignments can be made inactive manually, or automatically (see “Automatic and Manual Inactive Mode” on page 20).

**Tracks**

When a track is made inactive, its voices become available for another track. Mono inactive tracks free up one voice; stereo and multi-channel tracks free up one voice per channel. Additionally, when an audio, Auxiliary Input, Instrument, or Master Fader track is made inactive, its plug-ins, inserts, sends, and I/O assignments become inactive, and the associated DSP used is freed up for use elsewhere in the session.

Display of Inactive Items

When items are inactive, their names appear in italics, and their background becomes dark grey. When a track is inactive, the entire channel strip is grayed out.
Automatic and Manual Inactive Mode

Active and Inactive modes are powerful options for session transfer and system resource management. Pro Tools provides automatic and manual Inactive mode switching. You can manually make items inactive (or active) to selectively manage system resources while editing and mixing.

Automatically Inactive Items

When opening a session, it is possible that not all signal paths, plug-ins, or audio interfaces used in the session will be available as defined on the current system. When opening a session, sufficient voices may also be unavailable if the session was created on a different Pro Tools system type (for example, opening a session created on a Pro Tools HD system on a Pro Tools LE system).

Whenever this occurs, the session will open as it was last saved. All items that are unavailable, or cannot be loaded due to insufficient resources, are made inactive.

Manual Inactive Switching

You can manually apply Active or Inactive modes to manage system resources. By making an item inactive, its associated resources are made available elsewhere in the session.

The following are basic instructions for manually making items inactive. Throughout the Pro Tools Reference Guide, instructions are provided whenever an item can be made inactive.

To toggle an item active or inactive:
- Control-Start-click (Windows) or Command-Control-click (Mac) the item.

You can apply Active or Inactive modes to all or all selected tracks using standard Pro Tools modifiers (Alt and Alt+Shift in Windows, Option and Option+Shift on the Mac).

Side-chain inputs support direct active and inactive switching, but do not follow switching all or all selected side-chain inputs.

MIDI Concepts

MIDI (Musical Instrument Digital Interface) is a communication protocol for musical instruments. This industry standard enables connections between a variety of devices from different manufacturers. Examples of MIDI-compatible equipment include synthesizers, sound modules, drum machines, patch bays, effects processors, MIDI interfaces, MIDI control surfaces, and sequencers.

MIDI devices are equipped with 5-pin DIN connectors, labeled as either IN, OUT, or THRU. The MIDI OUT port transmits messages. The MIDI IN port receives messages. The MIDI THRU echoes whatever is received from the IN port. MIDI devices are connected with MIDI cables that are available at most music stores.

Not all devices will have all three MIDI ports (IN, OUT, and THRU).
The MIDI protocol provides 16-channels of MIDI per port. A single MIDI cable can transmit a separate set of messages for each of the 16 channels. These 16 channels correspond to separate MIDI devices or to multiple channels within a single device (if the device is multi-timbral). Each channel can control a different instrument sound. For example, bass on channel 1, piano on channel 2, and drums on channel 10. Similar to a multitrack tape recorder, a MIDI sequencer can record complex arrangements—even using a single multi-timbral keyboard.

**MIDI Terms**

The following are some basic MIDI terms:

**MIDI Instrument** A hardware MIDI device or software plug-in (such as a virtual synth or instrument plug-in). In this guide, “instrument” usually refers to soft synths and plug-in instruments.

**MIDI Interface** Hardware that lets computers connect to and communicate with MIDI devices.

**MIDI Device** Any keyboard, sound module, effects device, or other equipment that can send or receive MIDI information.

**MIDI Controller** Any MIDI device that transmits MIDI performance data. These include keyboards, MIDI guitar controllers, MIDI wind instruments, and others. Controllers transmit MIDI from their MIDI OUT ports.

**MIDI Control Surface** Any device (such as the Digidesign Command|8), which uses a MIDI connection to send control messages to a software program, but is not generally used to record MIDI information.

**MIDI Tone Generator (MIDI Sound Source)** Any MIDI device capable of playing back MIDI-triggered sound. Sound sources receive MIDI from their MIDI IN ports.

**Multi-Timbral** The ability of one MIDI device to play several different instrument sounds (such as piano, bass, and drums) simultaneously on separate MIDI channels. This makes it possible for a single multi-timbral MIDI instrument to play back entire arrangements.

**MIDI Channel** Up to 16 channels of MIDI performance data can be transmitted on a single MIDI cable. The channel number separates the different messages so your sound sources can receive the right ones.

**Program Change Event** A MIDI command that tells a sound source which of its sounds (or sound patches) to use. The MIDI protocol lets you choose from a range of 128 patches.

**Bank Select Message** Many devices have more than 128 patches, which are arranged in banks. The Bank Select Message is a MIDI command that specifies the bank of patches from which to choose.

**Local Control** A controller setting found on most MIDI keyboards that lets them play their own sound source. Disabling “local control” ensures that a device’s internal sound source is only played by external MIDI messages (such as those sent from Pro Tools when MIDI in Pro Tools is routed to the MIDI keyboard). When using Pro Tools, “local control” should usually be disabled. When “local control” is off, your keyboard still transmits data to its MIDI OUT port.

**Continuous Controller Events** MIDI instructions that allow real-time changes to notes that are currently sounding. These include pitch bend, modulation, volume, pan, and many others.
**System Exclusive Data** MIDI data commonly used for sending and retrieving patch parameter information for storage purposes.

**Common MIDI Misconceptions**

MIDI is not audio, and by itself makes no sound. MIDI is control information only. It is like the piano roll for a player piano; it provides control information for what note to play when, for how long, and at what volume. For example, when you strike a key on a MIDI keyboard, it sends a message to a MIDI instrument or tone generator to play that particular note at that particular velocity. This could be its internal tone generator, an external MIDI instrument, or an instrument plug-in, which can be contained completely within Pro Tools. In order to create or play a MIDI recording, you must have a MIDI instrument. Audio from your instrument can be sent to an external mixer or monitored through your Pro Tools audio interface.

If you are using an external MIDI instrument, it must be connected to MIDI ports that are recognized by your computer. These ports can be on a Pro Tools interface that has MIDI ports (such as MIDI I/O, Mbox 2, or a Digidesign-qualified M-Audio interface) or some other MIDI interface.

To actually hear an external MIDI instrument, you need to connect its audio outputs to a mixing console or connect it to one of the audio inputs of your Pro Tools audio interface.

Just as each Pro Tools system has unique hardware features, each MIDI device has its own features (and limitations) as to the number of voices and instruments it can play at one time. Consult the device’s documentation for information on its capabilities.

When using MIDI with instrument plug-ins in Pro Tools, virtual MIDI nodes. These nodes act like virtual MIDI ports and provide software MIDI connections between Pro Tools and other MIDI software, such as instrument plug-ins. For example, when you insert Propellerhead’s Reason as a ReWire client on a track, its various MIDI inputs to Reason become available to Pro Tools MIDI and Instrument track MIDI outputs.

![Signal paths for external MIDI instruments](image-url)
Chapter 4: Pro Tools Main Windows

Pro Tools provides two complementary ways of viewing a session: the Mix window and the Edit window. Pro Tools also lets you control the transport and transport-related functions using the Transport window.

To toggle between the Mix and Edit windows, press Control+Equals (=) (Windows), or press Command+Equals (=) (Mac).

For information on the main elements of the Mix window and Edit window, see the page references provided in Figure 3 on page 24, and Figure 4 on page 25.

The Mix Window

In the Mix window, tracks appear as channel strips, with controls for:
- inserts
- sends
- input and output assignments
- volume
- panning
- record enable
- automation mode
- solo/mute
- mic preamps (Pro Tools HD only)

To display the Mix window:
- Choose Window > Mix.

To display all Mix window view options:
- Select View > Mix Window > All.

For information on selecting individual view options, see “Views in the Mix and Edit Windows” on page 532.

The Edit Window

The Edit window provides a timeline display of audio, as well as MIDI data and mixer automation for recording, editing, and arranging tracks. As in the Mix window, each track has controls for record enable, solo, mute, and automation mode.

To display the Edit window:
- Choose Window > Edit.

To display all Edit window view options:
- Select View > Edit Window > All.

For information on selecting individual view options, see “Views in the Mix and Edit Windows” on page 532.
Figure 3. Pro Tools Mix window

24  Pro Tools Reference Guide
Figure 4. Pro Tools Edit window
Track Path Selectors and Controls

- Audio Input Path selector (page 100)
- Audio Output Path selector (page 100)
- Automation Mode selector (page 584)
- Record Enable button (page 180)
- Track Input Monitor button (page 183)
- Mute Button (page 121)
- Solo button (page 119)

Mix window track controls for mono audio track (Wide View)

- Record Enable button (page 180)
- Track Name button (page 103)
- Playlist selector (page 270)
- Solo button (page 119)
- Mute button (page 121)
- Track Height selector (page 258)
- Voice selector (page 114)
- Automation Mode selector (page 584)
- Track View selector (page 255)
- TrackInput Monitor button (page 183)

Timebase selector (page 269)

Edit window track controls for stereo audio track (medium track height)

- Trim tools (page 289)
- Selector tool (page 301)
- Grabber tools (page 312)
- Scrubber tool (page 296)
- Pencil tool (page 462)
- Zoom Toggle (page 284)
- Smart Tool (page 294)
- Custom Note Duration button (page 463)

Edit tools in Edit window

Edit Window Counters and Selection Indicators

Main and Sub Counters

Main and Sub Counters (page 305)

Edit window display showing counters

The Main and Sub Counters can be set for different Time Scale formats (such as Samples, Bars:Beats, or Minutes:Seconds). For more information, see “Main Time Scale” on page 266. These counters are also displayed in the Transport window.

Edit Selection Indicators

Edit Selection indicators (page 305)

Edit Selection indicators in the Edit window

The Edit Selection Start, End, and Length indicators display can be set for different Time Scale formats (such as Samples, Bars:Beats, or Minutes:Seconds). For more information, see “Main Time Scale” on page 266.

Event Edit Area

The Event Edit Area provides time, pitch, and other information for the currently selected audio or MIDI data. It also lets you define selections using the keyboard.

Event Edit Area showing MIDI track information

Note Attributes (page 469)
Chapter 4: Pro Tools Main Windows

Edit Window Bar

The Edit Window bar contain various selectors, commands, indicators, and pop-up menus for working in the Pro Tools Edit window.

View Selectors

- Ruler View selector (page 532)
- Edit window View selector (page 532)

View selectors in the Edit Window bar

Commands

- Linearity Display Mode (page 409)
- Tab to Transients (page 319)
- Commands Keyboard Focus (page 36)
- Link Track and Edit Selection (page 310)
- Link Timeline and Edit Selection (page 308)

Commands in the Edit Window bar

Grid/Nudge Value Indicators and Pop-Up Menus

- Grid Value indicator (page 342)
- Nudge Value indicator (page 345)
- Grid Value pop-up menu (page 342)
- Nudge Value pop-up menu (page 345)

Grid/Nudge Value indicators and pop-up menus in the Edit Window bar

Cursor Location Indicators

- Cursor Location indicator (page 301)
- Cursor Location Value indicator (page 301)

Cursor Location indicators in the Edit Window bar

The Transport Window

The Transport window can be set to show basic transport controls, counters, MIDI controls, and expanded features. The counters in the Transport window mirror the controls and counters at the top of the Edit window.

To display the Transport window:

- Choose Window > Transport.

Basic Transport Controls and Counters

- Return to Zero indicator
- Fast Forward indicator
- Track Record Enable indicator
- Online indicator
- Stop indicator
- Start, End, and Length Selection indicators
- Pre-Roll indicator
- Post-Roll indicator
- Transport Master indicator
- Pre-Roll indicator
- TrackInput Monitor indicator

Transport window showing basic transport controls and counters (Main and Sub Counters and MIDI not shown)
Online Puts Pro Tools online so that playback and recording is triggered by an external time code source.

Return to Zero Locates to the beginning of the session.

Press Enter (Windows) or Return (Mac) to Return to Zero.

Right-clicking the Return to Zero button accesses the Write to Start and Write to All automation commands.

Rewind Rewinds from the current play location. You can also click repeatedly to rewind incrementally, by an amount based on the Main Time Scale, as follows:

<table>
<thead>
<tr>
<th>Main Time Scale Format</th>
<th>Increment Amount</th>
</tr>
</thead>
<tbody>
<tr>
<td>Min:Sec</td>
<td>1 second</td>
</tr>
<tr>
<td>Time Code</td>
<td>1 frame</td>
</tr>
<tr>
<td>(Pro Tools HD or Pro Tools LE with DV Toolkit 2)</td>
<td></td>
</tr>
<tr>
<td>Bars:Beats</td>
<td>1 bar</td>
</tr>
<tr>
<td>Feet+Frame</td>
<td>1 foot</td>
</tr>
<tr>
<td>(Pro Tools HD or Pro Tools LE with DV Toolkit 2)</td>
<td></td>
</tr>
<tr>
<td>Sample</td>
<td>1 second</td>
</tr>
</tbody>
</table>

With the Numeric Keypad mode set to Transport, you can rewind by pressing 1.

Stop Stops playback or recording.

You can also stop the transport by pressing the Spacebar, or with the Numeric Keypad mode set to Transport, pressing 0.

Play Starts playback or (if the Record Enable button was clicked first) recording from the Timeline insertion point.

You can also begin playback by pressing the Spacebar, or with the Numeric Keypad mode set to Transport, pressing 0.

Right-clicking the Play button lets you choose a playback mode from the pop-up menu:

- Half Speed
- Prime for Playback
- Loop Playback

To initiate playback at half-speed, you can also press Shift+Spacebar (Windows or Mac) or Shift-click (Mac) the Play button.

With the Transport stopped, Start-click Play (Windows) or Control-click Play (Mac) to toggle Loop Playback mode. When enabled, a loop symbol appears in the Play button and Pro Tools plays continuously from the beginning of the selection to the end.

For more information on loop playback, see “Looping Playback” on page 321.
**Fast Forward** Fast forwards from the Timeline insertion point. You can also click repeatedly to fast forward incrementally (by an amount based on the Main Time Scale).

**Fast Forward Increments**

<table>
<thead>
<tr>
<th>Main Time Scale Format</th>
<th>Increment Amount</th>
</tr>
</thead>
<tbody>
<tr>
<td>Min:Sec</td>
<td>1 second</td>
</tr>
<tr>
<td>Time Code</td>
<td>1 frame</td>
</tr>
<tr>
<td>(Pro Tools HD or Pro Tools LE with DV Toolkit 2)</td>
<td></td>
</tr>
<tr>
<td>Bars:Beats</td>
<td>1 bar</td>
</tr>
<tr>
<td>Feet+Frame</td>
<td>1 foot</td>
</tr>
<tr>
<td>(Pro Tools HD or Pro Tools LE with DV Toolkit 2)</td>
<td></td>
</tr>
<tr>
<td>Sample</td>
<td>1 second</td>
</tr>
</tbody>
</table>

**Go to End** Locates to the end of the session.

**Record Enable** Arms Pro Tools for recording (the button flashes). Clicking Play then initiates recording on record-enabled tracks only.

**Pre-Roll** During playback or record, specifies the amount that plays before the play (timeline) Cursor location or beginning of the Timeline selection. Pre-roll is particularly useful with punch recording since it provides you with time to “catch the beat” before reaching the punch-in point. To set the pre-roll amount, enter a new value in this field, or drag the Pre-Roll flag in the Main Timebase ruler.

To enable pre-roll:
- Click the Pre-Roll button to the left of the pre-roll field so it becomes highlighted.

**Track Record Enable Indicator** When lit (red), indicates that at least one audio track is currently record-enabled. When off (grey), no tracks are currently record-enabled.

**TrackInput Monitor Indicator** When lit (green), indicates that at least one audio track is currently set to Input Only monitoring (regardless of record enable status). When off (grey), all tracks are in Auto Input monitoring.

**Right-clicking the Record Enable button** lets you choose a record mode from the pop-up menu.

You can also cycle through the Pro Tools record modes with the Transport stopped, by Start-clicking (Windows) or Control-clicking (Mac) the Record Enable button.

The Record Enable button changes to indicate the currently selected mode: blank for Non-destructive, “D” for Destructive, a loop symbol for Loop Record, “P” for QuickPunch, “T” for TrackPunch, and “DP” for DestructivePunch.

With Numeric Keypad mode set to Transport, you can fast forward by pressing 2.

You can press Control+Enter (Windows) or Option+Return (Mac) on the QWERTY keyboard to locate to the end of the session.

You can also Right-click the Go to End button to access automation commands Write to End and Write to All.

To initiate recording at half-speed, you can press Control+Shift+Spacebar (Windows) or Command+Shift+Spacebar (Mac).

You can also begin recording by pressing F12, pressing Control+Spacebar (Windows) or Command+Spacebar (Mac), or with the Numeric Keypad mode set to Transport, pressing 3.
Post-Roll During playback or record, specifies the amount that plays after the end of a Timeline selection. Post-roll is useful in punch recording since playback continues after the punch-out point so you can check for a smooth transition to previously recorded material. To set the post-roll amount, enter a new value in this field, or drag the Post-Roll flag in the Main Timebase ruler.

To enable post-roll:
■ Click the Post-Roll button to the left of the post-roll field so it becomes highlighted.

Start Specifies the beginning of the play or record range. You can set the start point by entering a location in this field, or by dragging the corresponding Playback Marker in the Main Timebase ruler. For more information, see “Playback Markers” on page 208.

End Specifies the end of the play or record range. You can set the end point by entering a location in this field, or by dragging the corresponding Playback Marker in the Main Timebase ruler. For more information, see “Playback Markers” on page 208.

Length Specifies the length for the play or record range. You can set the length by entering a location in this field, or by selecting a range in any Timebase ruler.

When the Timeline and Edit selections are linked, you can drag in a track’s playlist to set the play and record range. See “Linking or Unlinking Timeline and Edit Selections” on page 308

Transport Master Selector Specifies the “master” for transport functions and provides a control to take enabled devices offline.

To set a Transport Master:
■ Click the Transport Master selector, click the Transport pop-up menu, and select a Transport Master: Pro Tools, Machine, MMC (MIDI Machine Control), or Remote.

To take a device offline:
■ Click the Transport Master selector, click the Online pop-up menu, and uncheck the device (MIDI or Machine). Device choices depend on the current Transport Master, and which devices have been set up in Pro Tools.

To bring the device back online, recheck it in the Online pop-up menu.

If you using an MMC device, see Chapter 30, “Working with Synchronization.”

If you are using the Digidesign Machine-Control option, see the MachineControl Guide.
MIDI Controls

To view the MIDI controls in the Transport, do one of the following:

- Select View > Transport > MIDI Controls.

- Control-click (Windows) or Command-click (Mac) the Expand/Collapse “+” button in the Transport window to display the MIDI controls.

Wait for Note

When selected, recording does not begin until a MIDI event is received. This ensures that you begin recording when you’re ready to play, and that the first note, or other MIDI data, is recorded precisely at the beginning of the record range.

You can press F11 to turn on Wait for Note, unless the MIDI preference for “Disable F11 for Wait for Note” is selected.

Metronome Click

When selected, Pro Tools will generate a metronome pulse that can be set to trigger built-in sounds or MIDI instruments during playback and recording.

The Pro Tools metronome is configured in the Click/Countoff Options dialog. Double-click the Metronome Click button to open the Click/Countoff Options dialog.

Countoff

When selected, Pro Tools counts off a specified number of measures (indicated in the button) before playback or recording begins.

Double-click the Countoff button, to open the Click/Countoff Options dialog.

MIDI Merge

When selected (Merge mode), recorded MIDI data is merged with existing track material. When deselected (Replace mode), recorded MIDI data replaces existing track material.

Tempo Ruler Enable (Conductor)

When selected, Pro Tools uses the tempo map defined in the Tempo ruler. When deselected, Pro Tools switches to Manual Tempo mode and ignores the Tempo ruler.

In Manual Tempo mode, you can enter a BPM value in the tempo field, or tap in the tempo by clicking the T key on your QWERTY keyboard.
Tempo Slider When the Tempo Ruler Enable (Conductor) is disabled, Pro Tools ignores the tempo events in the Tempo track and instead plays back the specified Manual Tempo. This tempo can be set with the Tempo slider.

Current Meter Displays the session’s current meter based on the play location. Double-click the Current Meter indicator to open the Change Meter window.

Current Tempo Displays the session’s current tempo based on the play location. In Manual Tempo mode, you can enter a BPM value into this field, or manually tap in a tempo with a computer keyboard or an external MIDI keyboard.

Menus and Windows
Pro Tools menus provide commands and options for configuring and working with Pro Tools, sessions, and session material.

For detailed information on Pro Tools main menus and Region List pop-up menus, see the Pro Tools Menus Guide.

Pro Tools Main Menus
Pro Tools includes the following main menus:

File Provides commands that are used to create and maintain Pro Tools sessions.

Edit Provides commands that are used to edit and manipulate the current selection and affect data in the timeline or the clipboard.

View Provides options and commands to customize what is shown in various windows.

Track Provides commands that are used to create, manage, and edit tracks.

Region Provides commands that are used to manage and edit regions.

Event Provides commands for editing audio and MIDI events.

AudioSuite Provides AudioSuite plug-ins.

Options Provides commands that let you select several editing, recording, monitoring, playback, and display options.

Setup Provides commands to open dialogs and windows or configure various Pro Tools hardware and software parameters.

Window Provides commands to toggle the display of various Pro Tools windows.

Track, Region, and Group List Menus
The Track, Region, and Group Lists provide pop-up menus for managing and working with the contents of each list, as follows.

Track List Pop-Up Menu Provides commands to show and hide tracks in the Mix and Edit windows. The Track List pop-up menu also lets you sort the contents of the Track List.

For a complete list, see “The Track List” on page 107.

Group List Pop-Up Menus (Edit Groups and Mix Groups) Provides commands to create, display, suspend, and delete Mix and Edit Groups.

For a complete list, see “The Group List” on page 127
Region List Pop-Up Menu (Edit Window Only) Provides commands to find, select, sort, clear, rename, time stamp, compact, export, and recalculate waveform overviews of items in the Region List. The pop-up menu also lets you set the drop order for regions dragged from the Region List and dropped in the timeline.

For a complete list, see “The Region List” on page 275.

Track Name and Region Name Right-Click Pop-Up Menus

Track and region names provide pop-up menus for managing and working with tracks or regions, as follows:

Track Name Right-Click Pop-Up Menu Right-clicking a track name in the Edit window, Mix window, or the Track List provides access to various track commands (such as show/hide, make active/inactive, rename, duplicate, and delete tracks).

For a complete list, see “Track Name Right-Click Pop-Up Menus” on page 110.

Region Name Right-Click Pop-Up Menu (Edit Window Only) Right-clicking a region name in the Region List provides commands to clear, rename, time stamp, or replace regions. The pop-up menu also lets you export region definitions or selected regions as files, recalculate waveform overviews, select the parent file of selected regions in the DigiBase Workspace Browser, or select a region as an object in the Edit window.

For a complete list, see “The Region List” on page 275.

Group Name and Track Group ID Indicator Pop-Up Menus

When you click and hold on a group name in the Group List, or click on a Group ID indicator in a track, a pop-up menu provides access to various group commands (such as selecting tracks in a group).

For a complete list, see “Group Name and Track Group ID Indicator Pop-Up Menus” on page 129.

Tool Tips

Pro Tools provides Tool Tips in all main windows. Holding the cursor for a few seconds over an abbreviated name, or unlabeled icon or tool, displays either the function or details of the item (depending on the Tool Tips preferences settings).

To configure Tool Tips for Pro Tools:

1 Choose Setup > Preferences, and click the Display tab.

2 In the Basics section, click the Tool Tips options you want displayed.

Function Shows the functional name of different Pro Tools items (such as specific buttons, indicators, modes, selectors, and Edit tools).

Details Shows abbreviated or hidden Pro Tools names or values for different Pro Tools items (such as insert names, gain levels, settings, and routing assignments).

Leave both options unchecked to turn off Tool Tips.

3 Click OK.
Chapter 5: Keyboard and Right-Click Mouse Shortcuts

This chapter provides an overview of Pro Tools keyboard and mouse shortcuts.

A PDF listing of all shortcuts is available in Pro Tools. Choose Help > Keyboard Shortcuts.

Right-Click Mouse Shortcuts

Pro Tools provides Right-click shortcuts for choosing various Pro Tools commands and menus with any Right-click capable mouse.

For a complete list of Right-click shortcuts, refer to the PDF versions of the Keyboard Shortcuts Guides.

Global Key Commands

This section shows keyboard shortcuts that apply to many functions in Pro Tools.

Track Functions

Pro Tools provides keyboard shortcuts for the following track functions:

- Changing Automation mode
- Enabling playlists
- Adding plug-ins
- Record enabling, soloing, and muting tracks
- Record safining and solo safining tracks
- Assigning inputs, outputs, and sends
- Toggling volume/peak/delay display
- Clearing meters
- Changing track heights

<table>
<thead>
<tr>
<th>Command</th>
<th>Windows</th>
<th>Mac</th>
</tr>
</thead>
<tbody>
<tr>
<td>Apply action to all channel strips/tracks</td>
<td>Alt+ action</td>
<td>Option+ action</td>
</tr>
<tr>
<td>Apply action to selected channel strips/tracks</td>
<td>Alt+ Shift+ action</td>
<td>Option+ Shift+ action</td>
</tr>
</tbody>
</table>
List and Parameter Selection

Pro Tools provides keyboard shortcuts for the following items:

- Selection of tracks in Track List
- Enabling of groups in Group List
- Automation Enable window parameters
- Setting Memory Location parameters

Controls and Editing Tools

Pro Tools provides keyboard shortcuts for moving plug-in controls, faders and sliders, the Scrubber, and automation data.

<table>
<thead>
<tr>
<th>Command</th>
<th>Windows</th>
<th>Mac</th>
</tr>
</thead>
<tbody>
<tr>
<td>Toggle item and set all others to same new state</td>
<td>Alt-click item</td>
<td>Option-click item</td>
</tr>
<tr>
<td>Toggle item and set all others to opposite state</td>
<td>Control-click item</td>
<td>Command-click item</td>
</tr>
</tbody>
</table>

Keyboard Focus

The Keyboard Focus in Pro Tools determines how the alpha keys function. Depending on which Keyboard Focus is enabled, you can use the keys on your QWERTY (alpha) keyboard to select regions in the Region List, enable or disable groups, or perform an edit or play command.

You can only enable one of the three Keyboard Focus modes at a time. Enabling a Keyboard Focus will disable the one previously enabled.

There are three types of Keyboard Focus:

**Commands Keyboard Focus** When selected, this provides a wide range of single key shortcuts from the QWERTY keyboard for editing and playing.

With Commands Keyboard Focus disabled, you can still access any of its key shortcuts by pressing the Start key (Windows) or Control (Mac) along with the key.

**Region List Keyboard Focus** When selected, audio regions, MIDI regions, and Region Groups can be located and selected in the Region List by typing the first few letters of the region’s name.

**Group List Keyboard Focus** When selected, Mix and Edit Groups can be enabled or disabled by typing the Group ID letter (in either the Mix or Edit window).
To set the Keyboard Focus, do one of the following:

- Click the a–z button for the focus you want to enable.
- Or
  - While pressing Control+Alt (Windows) or Command+Option (Mac), press one of the following keys: 1 (Commands), 2 (Region List), or 3 (Group List).

⚠️ Although multiple plug-in windows can have a keyboard focus enabled, only the front-most window will receive any keyboard input.

Numeric Keypad Modes

The Operation preference for Numeric Keypad mode determines how the numeric keypad functions for Transport.

There are two Shuttle Lock modes (Classic and Transport), and one Shuttle mode.

No matter which Numeric Keypad mode is selected, you can always use the numeric keypad to select and enter values in the Event Edit Area, Edit Selection indicators, Main and Sub Counters, and Transport fields.

To set the Numeric Keypad Mode:

1. Choose Setup > Preferences and click the Operation tab.
2. In the Transport section, select a Numeric Keypad mode (Classic, Transport, or Shuttle).
3. Click OK.

⚠️ For more information on each mode, see “Numeric Keypad Mode” on page 63.

Shuttle Lock Modes

With either Shuttle Lock mode (Classic or Transport) you can use the numeric keypad to shuttle forward or backwards at specific speeds.

- 5 is normal speed.
- 6–9 provide increasingly faster fast-forward speeds.
- 1–4 provide progressively faster rewind speeds (4 is the slowest rewind Shuttle Lock speed, 1 is the fastest).
- Press 0 to stop Shuttle Lock, then press the number to resume Shuttle Lock speed.
- Press Escape or Spacebar to exit Shuttle Lock mode.

Custom Shuttle Lock Speed

(Pro Tools HD and Pro Tools LE with DV Toolkit 2 Only)

The highest fast-forward Shuttle Lock speed (key 9) can be customized.

⚠️ For information, see “Custom Shuttle Lock Speed” on page 298.

Classic Mode

This mode emulates the way Pro Tools worked in versions lower than 5.0. With the Numeric Keypad mode set to Classic, you can:

- Play up to two tracks of audio in Shuttle Lock mode. Press the Start key (Windows) or Control (Mac), followed by 1–9 for different play speeds.
- Press Plus or Minus to reverse direction.
- Press 0 to stop Shuttle Lock, then press the number to resume Shuttle Lock speed.
- Press Escape or Spacebar to exit Shuttle Lock mode.
- Recall Memory Locations by typing the Memory Location, followed by a Period (.)
Transport Mode

This mode allows you to set a number of record and play functions, and also operate the Transport from the numeric keypad.

<table>
<thead>
<tr>
<th>Function</th>
<th>Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Click on/off</td>
<td>7</td>
</tr>
<tr>
<td>Countoff on/off</td>
<td>8</td>
</tr>
<tr>
<td>MIDI Merge/Replace mode</td>
<td>9</td>
</tr>
<tr>
<td>Loop Playback mode on/off</td>
<td>4</td>
</tr>
<tr>
<td>Loop Record mode on/off</td>
<td>5</td>
</tr>
<tr>
<td>QuickPunch mode on/off</td>
<td>6</td>
</tr>
<tr>
<td>Rewind</td>
<td>1</td>
</tr>
<tr>
<td>Fast Forward</td>
<td>2</td>
</tr>
<tr>
<td>Record enable</td>
<td>3</td>
</tr>
<tr>
<td>Play/Stop</td>
<td>0</td>
</tr>
</tbody>
</table>

With the Numeric Keypad mode set to Transport, you can also:

- Play up to two tracks of audio in Shuttle Lock mode. Press the Start key (Windows) or Control (Mac), followed by 1–9 for different play speeds.
- Press Plus or Minus to reverse direction.
- Press 0 to stop Shuttle Lock, then press the number to resume Shuttle Lock speed.
- Press Escape or Spacebar to exit Shuttle Lock mode.
- Recall Memory Locations by typing Period (.), the Memory Location number, and Period (.) again.

Shuttle Mode

(Pro Tools HD Only)

Pro Tools offers another form of shuttling, different from that of the two Shuttle Lock modes. With the Numeric Keypad mode set to Shuttle, playback of the current Edit selection is triggered by pressing and holding the keys on the numeric keypad—playback stops once the keys are released. Various playback speeds are available in both forward and reverse. In this mode, pre- and post-roll are ignored.

<table>
<thead>
<tr>
<th>Playback Speeds</th>
<th>Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>1x Forward</td>
<td>6</td>
</tr>
<tr>
<td>1x Rewind</td>
<td>4</td>
</tr>
<tr>
<td>4x Forward</td>
<td>9</td>
</tr>
<tr>
<td>4x Rewind</td>
<td>7</td>
</tr>
<tr>
<td>1/4x Forward</td>
<td>3</td>
</tr>
<tr>
<td>1/4x Rewind</td>
<td>1</td>
</tr>
<tr>
<td>1/2x Forward</td>
<td>5+6</td>
</tr>
<tr>
<td>1/2x Rewind</td>
<td>5+4</td>
</tr>
<tr>
<td>2x Forward</td>
<td>8+9</td>
</tr>
<tr>
<td>2x Rewind</td>
<td>8+7</td>
</tr>
<tr>
<td>1/16x Forward</td>
<td>2+3</td>
</tr>
<tr>
<td>1/16x Rewind</td>
<td>2+1</td>
</tr>
<tr>
<td>Loop Selection (1x)</td>
<td>0</td>
</tr>
</tbody>
</table>

With the Numeric Keypad mode set to Shuttle, you can also:

- Recall Memory Locations by typing Period (.), the Memory Location number, and Period (.) again.

⚠️ Shuttle Lock modes are not available when the Numeric Keypad mode is set to Shuttle.
Part II: Sessions & Tracks
Chapter 6: Sessions

This chapter covers the basics of starting a project in Pro Tools, including how to set up and save a Pro Tools session.

Starting Up or Shutting Down Your System

To ensure that the components of your Pro Tools system communicate properly with each other, you need to start them in a particular order.

**Start up your Pro Tools system in this order:**

1. For Pro Tools|HD systems with an expansion chassis, turn on the chassis.
2. Turn on any external hard drives. Wait approximately ten seconds for them to spin up to speed.
3. Turn on any MIDI interfaces, MIDI devices, or synchronization peripherals.
4. Lower the volume of all output devices in your system.
5. For Pro Tools|HD systems, turn on your Pro Tools audio interfaces. Wait at least fifteen seconds for your system hardware to initialize.
6. Turn on your computer.
7. Launch Pro Tools or any third-party audio or MIDI applications.

**Shut down your Pro Tools system in this order:**

1. Quit Pro Tools and any other running applications.
   - To quit Pro Tools, choose File > Exit (Windows) or Pro Tools > Quit (Mac)
2. Turn off or lower the volume of all output devices in your system.
3. Turn off your computer.
4. For Pro Tools|HD systems, turn off audio interfaces.
5. For Pro Tools|HD systems with an expansion chassis, turn off the chassis.
6. Turn off any MIDI interfaces, MIDI devices, or synchronization peripherals.
7. Turn off any external hard drives.

Configuring Pro Tools System Settings (in the Playback Engine)

Pro Tools allows you to adjust the performance of your system by changing system settings that affect its capacity for processing, playback, and recording.

These system settings are changed in the Playback Engine Dialog (Setup > Playback Engine).
In most cases, the default settings for your system provide optimum performance, but you may want to adjust them to accommodate large or processing-intensive Pro Tools sessions.

**Hardware Buffer Size**

The Hardware Buffer Size (H/W Buffer Size) controls the size of the hardware cache used to handle host-based tasks such as Real-Time Audio-Suite (RTAS) plug-in processing.

- Lower Hardware Buffer Size settings reduce monitoring latency, and are useful when you are recording live input.
- Higher Hardware Buffer Size settings allow for more audio processing and effects, and are useful when you are mixing and using more RTAS plug-ins.

⚠️ In addition to causing slower screen response and monitoring latency, higher Hardware Buffer Size settings can affect the accuracy of plug-in automation, mute data, and timing for MIDI tracks.

To change the Hardware Buffer Size:

2. From the H/W Buffer Size pop-up menu, select the audio buffer size, in samples.
3. Click OK.

**RTAS Processors**

The RTAS Processors setting determines the number of processors in your computer allocated for RTAS (real-time plug-ins) plug-in processing.

With computers that have multiple processors, or that feature multi-core processing or hyper-threading, this setting lets you enable multi-processor support for RTAS processes. Used in combination with the CPU Usage Limit setting, the RTAS Processors setting lets you control the way RTAS processing and other Pro Tools tasks are carried out by the system.

For example:

- For sessions with large numbers of RTAS plug-ins you can allocate 2 or more processors to RTAS and set a high CPU Usage Limit.
- In sessions with few RTAS plug-ins, you can allocate fewer processors to RTAS and set a low CPU Usage Limit to leave more CPU resources available for automation accuracy, screen response, or video.
- Increase or decrease these settings to accommodate TDM/RTAS plug-in conversion. TDM/RTAS conversion can be desirable during recording, depending on the latencies, voicing needs, and record-monitoring capabilities of TDM and RTAS plug-ins.
- Depending on the importance of video and overall screen response, and on the density of automation being employed, different combinations of RTAS Processing and CPU Usage Limit settings may achieve the best results. For example, to improve screen response in a medium-sized session using a moderate number of RTAS plug-ins, try reducing the number of RTAS processors but keep the CPU Usage Limit set to the maximum (99%) on a single processor system.

The System Usage window shows the combined amount of RTAS processing occurring on all enabled processors with a single indicator, regardless of how many CPUs are in the system. If the System Usage Window shows that you are at the limit of available resources, increase the number of RTAS processors and/or the CPU Usage Limit setting. (For more information, see “System Usage” on page 59.)
To set the number of RTAS Processors:


2. From the RTAS Processing pop-up menu, select the number of available processors you want to allocate. The number of processors available varies depending on how many processors are available on your computer:
   - Choose 1 Processor to limit RTAS processing to one CPU in the system.
   - Choose 2 Processors to enable load balancing across two available processors.
   - On systems running four or more processors, choose the desired number of RTAS processors as needed.

3. Click OK.

CPU Usage Limit

The CPU Usage Limit controls the percentage of CPU resources allocated to Pro Tools host processing tasks. Used in combination with the RTAS Processors setting, the CPU Usage Limit setting lets you control the way Pro Tools tasks are carried out by the system:

- Lower CPU Usage Limit settings limit the effect of Pro Tools processing on other CPU-intensive tasks, such as screen redraws, and are useful when you are experiencing slow system response, or when running other applications at the same time as Pro Tools.

- Higher CPU Usage Limit settings allocate more processing power to Pro Tools, and are useful for playing back large sessions or using more real-time plug-ins.

The maximum CPU Usage Limit is 85 percent for single-processor computers (except for Digi 002, which has a limit of 99 percent), and 99 percent for multi-process computers. (The 99 percent setting dedicates one entire processor to Pro Tools.

On multi-processor computers, the maximum CPU Usage Limit is reduced when you use all your processors (as selected in the RTAS Processing pop-up menu). For example, on dual-processors, the limit will be 90%. On four-processor computers, the limit will be 95%.

⚠️ Increasing the CPU Usage Limit may slow down screen responses on slower computers.

To change the CPU Usage Limit:


2. From the CPU Usage Limit pop-up menu, select the percentage of CPU processing you want to allocate to Pro Tools.

3. Click OK.

Number of Voices

(Pro Tools HD Only)

On Pro Tools|HD systems, the Number of Voices setting lets you control the number of available voices and how those voices are allocated to DSPs in your system. For example, the default number of voices on a Pro Tools|HD 1 system is 48 voices, using one DSP (at sample rates of 44.1 kHz or 48 kHz).

⚠️ Changing the number of voices affects DSP usage, the total number of voiceable tracks, and overall system performance.
Depending on the current sample rate and the number of Pro Tools|HD cards in your system, you will have different choices for voice count. For voice limits on different Pro Tools|HD systems, see “Pro Tools|HD System Playback, Recording and Voice Limits” on page 7.

To change the number of voices and DSP to allocate for voicing:


2. Select the number of voices and DSPs to allocate for voicing by selecting a value from the Number of Voices pop-up menu.
   - Select higher voice numbers when your Pro Tools|HD cards are the only PCI cards in your computer, or when you are using an expansion chassis to run higher track counts.
   - Select medium voice numbers when your Pro Tools|HD cards are in an expansion chassis, or when you are using other PCI cards along with Pro Tools|HD cards.
   - Select minimum voice numbers if you are using high-bandwidth PCI cards (such as video capture cards) along with your Pro Tools|HD cards. In addition, to free up DSP for plug-ins and processing, select the minimum number of voices and DSPs needed to play back the current session.

3. Click OK.

**Default Sample Rate**

The Sample Rate setting appears as the default sample rate when you create a new session. (This setting is available only when there is no session open.)

⚠️ With Pro Tools HD, the Sample Rate setting can affect the number of available voices.

To change the default Sample Rate:


2. Select the sample rate from the Sample Rate pop-up menu.

3. Click OK.

⚠️ You can change the sample rate when creating a new Pro Tools session by selecting a different sample rate in the New Session dialog. (See “Creating a New Session” on page 49.)

**Delay Compensation Engine**

(Pro Tools HD Only)

The Delay Compensation Engine lets you manage DSP delays in the Pro Tools mixer.

There are three settings in the Playback Engine dialog for dedicating DSP resources for Delay Compensation:

- **None** Allocates no DSP resources for Delay Compensation.
- **Short** Allocates minimal DSP resources for Delay Compensation for each channel. This is the most efficient setting for Pro Tools|HD Accel systems.
Long Allocates maximum DSP resources for Delay Compensation for each channel. Long Delay Compensation uses the SRAM contained on DSPs needed by DSP-intensive plug-ins.

To configure the Delay Compensation Engine:
2. From the Delay Compensation Engine pop-up menu, select a Delay compensation setting.
3. Click OK.

The Delay Compensation setting is saved as a session and system preference.

For more information, see “Delay Compensation” on page 553.

DAE Playback Buffer Size

The DAE Playback Buffer Size determines the amount of memory DAE allocates for disk buffers. The optimum DAE Playback Buffer Size for most disk operations is Level 2.

- DAE Playback Buffer Size settings lower than Level 2 may improve playback and recording initiation speed, but may make it difficult to play or record tracks reliably with sessions containing a large number of tracks or a high density of edits, or running on slower or heavily fragmented hard drives.

- DAE Playback Buffer Size settings higher than Level 2 will allow for a higher density of edits in a session or a higher track count when using slower hard drives. However, a higher setting can also cause a time lag to occur when starting playback or recording, and result in a longer audible time lag while editing during playback.

Using a larger DAE Playback Buffer Size leaves less system memory for other tasks. The default setting of Level 2 is recommended unless you are encountering -9073 (“Disk too slow or fragmented”) errors.

To change the DAE Playback Buffer Size:
2. From the DAE Playback Buffer pop-up menu, select a buffer size. Memory requirements for each setting are shown at the bottom of the Playback Engine dialog.
3. Click OK.
4. If Pro Tools needs more system memory for the DAE Playback Buffer, it will prompt you to restart your computer.

System Memory Allocation
(Pro Tools HD Only)

When you start your computer, Pro Tools automatically reserves a portion of system memory for the DAE Playback Buffer. This reserved memory is unavailable to other applications, even if Pro Tools is not running.

You can set Pro Tools to reserve only the minimum amount of required memory, so that system memory is available to other applications.
To minimize system memory allocation:

2. Select the “Minimize System Memory Allocation” option.
3. Click OK.
4. Do one of the following:
   • On Windows systems, restart your computer.
   – or –
   • On Mac systems, enter your password when prompted, then restart your computer.

Configuring Pro Tools Hardware Settings

Pro Tools allows you to configure the signal routing, digital I/O format, default sample rate, clock source, and other hardware-based settings depending on your system configuration.

The following section outlines the configuration of a Pro Tools|HD system with one or more Pro Tools|HD interfaces (with one or more Legacy interfaces attached).

To configure a Pro Tools LE system, refer to the Getting Started Guide that came with that system.

Configuring Pro Tools|HD Hardware

On Pro Tools|HD systems, you configure hardware settings for each audio interface connected to your system. For example, Pro Tools|HD systems can have 192 I/O, 192 Digital I/O, 96 I/O, or 96i I/O audio interfaces connected to HD Core and HD Accel or HD Process cards in the system. The 192 I/O, 192 Digital I/O, and 96 I/O can have additional interfaces attached (including older Digidesign audio interfaces, or Legacy I/Os, such as the 888|24 I/O, 882|20 I/O or 1622 I/O). For more information, see Chapter 2, “Pro Tools System Configurations.”

Configuring Hardware Setup

The Main page of the Hardware Setup dialog is where you define which physical inputs and outputs on your audio interface are routed to available inputs and outputs in Pro Tools.

Additional pages are available to configure other controls for each audio interface (such as setting operating levels). For details, refer to the Getting Started Guide for your system, or to the guide for your audio interface.

💡 You can identify audio interface connections at any time by selecting the interface name in the Peripherals list, then clicking Identify. All the LEDs on the interface front panel will illuminate.

To configure audio interfaces on a Pro Tools|HD system:

1. Choose Setup > Hardware.
2. From the Peripherals list, select the Digidesign audio interface connected to the first card in your system. This will be the interface at the top of the list.
3. Click the Main tab.
4 From the Clock Source pop-up menu, select the appropriate clock source for the system. In many cases, you will use Internal. The other choices are for resolving Pro Tools to external clock sources. Depending on your audio interface, Clock Source options can include: AES/EBU [Encl], S/PDIF, Optical [Encl], AES/EBU 1–8, TDIF, ADAT, and Word Clock (optional Word Clock rates are available when operating at higher sample rates).

5 From the Ext. Clock Output pop-up menu, select the appropriate clock output to send to devices attached to your audio interface.

6 Select which digital I/O port on your audio interface enclosure is active under Digital Format. Choices include: AES/EBU, S/PDIF, and Optical (S/PDIF). Selecting Optical (S/PDIF) resets the Optical I/O port (which is, by default, eight channels of ADAT I/O) to two channels of S/PDIF Optical I/O.

7 For S/PDIF compatibility with Tascam DA-30 DAT recorders select the Tascam option under S/PDIF Format.

8 For the 96 I/O, click the Meters pop-up menu and select whether to meter the input or output signal.

9 From the Input and Output pop-up menus, select the physical ports (such as Analog 1–2 or Optical 1–2), that will be routed to the corresponding Pro Tools input and output channels (such as Ch 1–2 or Ch 3–4), listed on the left side of the Main page.

Inputs and outputs of similar format are differentiated in the input and output channel pop-up menus. For example, the AES/EBU inputs and outputs in the 192 I/O enclosure are listed as AES/EBU [Encl], while the AES/EBU inputs and outputs on the factory-installed Digital I/O card are listed (in pairs) as AES/EBU 1–2, AES/EBU 3–4, AES/EBU 5–6, and AES/EBU 7–8.

For 192 I/Os equipped with the optional Digital I/O Card, the additional AES/EBU I/O ports on the optional card are listed as AES/EBU 9–10, AES/EBU 11–12, AES/EBU 13–14, and AES/EBU 15–16.

10 Click other tabs (such as Analog In and Analog Out) for additional configuration options specific to the audio interface. These include:
   - On the 96 I/O, configuring the operating levels of analog inputs and outputs (+4 dBu or –10 dBV).
   - On the 96i I/O, configuring the operating levels of analog inputs and outputs (+4 dBu or –10 dBV).
   - On the 192 I/O analog input, setting the input connector and Soft Limit
   - On the 192 I/O, configuring the two sets of trims for analog inputs and outputs.
   - On the 192 I/O and 192 Digital I/O, configuring real-time Sample Rate Conversion for digital inputs.
   - On the 192 I/O and 192 I/O Digital, configuring inputs and outputs on any optional A/D card, D/A card, or Digital I/O cards installed in the unit.

11 Repeat the above steps for each additional Pro Tools|HD audio interface.

For more information on Hardware Setup controls for each Pro Tools|HD audio interface, refer to the Pro Tools|HD Getting Started Guide or the guide for that audio interface.

Use the Up and Down Arrow keys to scroll through peripherals in the Peripherals list.
Repeat the above steps for any Legacy I/Os connected to the Pro Tools|HD audio interfaces in your system. Before you can configure a Legacy I/O, it must first be initialized in Hardware Setup.


Click OK.

Initializing MIX-Series Legacy Peripherals (on a Pro Tools|HD System)

Before you can configure a Legacy I/O, it must first be initialized in Hardware Setup.

To initialize a Legacy I/O on a Pro Tools|HD system:

1 Start up your Pro Tools system. See “Starting Up or Shutting Down Your System” on page 41.
2 Make sure to lower the volume of your output devices. Very loud digital noise may be emitted before the Legacy I/O is initialized.
3 Turn on your Legacy I/O.
4 From the Peripherals list, choose the primary audio interface (the Pro Tools|HD interface to which your Legacy I/O is connected).
5 In the Main page of the Hardware Setup dialog, select the Legacy I/O option under Port Settings.
6 In the Peripherals list, “No Interface” is listed twice, directly below the primary audio interface. Click the first “No Interface.” An Interface pop-up menu appears in the Hardware Setup dialog, listing supported I/O choices.
7 From the Interface pop-up menu, select the type of Legacy I/O you connected.

The Main page updates with controls that can be configured.

Repeat the above steps for each additional Legacy I/O.

For information on Hardware Setup controls for each Legacy audio interface, refer to the guide that came with the interface.

Configuring I/O Setup

The I/O Setup dialog provides a graphical representation of the signal routing for each connected audio interface, with controls to route physical ports on the audio interface to Pro Tools inputs and outputs. These controls mirror the routing controls found in the Hardware Setup dialog—changes made to physical routing in one dialog are always reflected in the other.

The I/O Setup dialog lets you label and map Pro Tools input, output, insert, and bus signal paths. The I/O Setup dialog also provides important audition, meter, and surround settings. For more information, see Chapter 7, “I/O Setup.”

Routing a Pro Tools Output Pair to Multiple Destinations

Pro Tools channel pairs can be routed to multiple outputs on an audio interface through the Hardware Setup dialog. For example, if you assign both Analog 1–2 and Analog 3–4 interface outputs to Pro Tools Output pair 1–2, when you send a signal to Pro Tools Outputs 1–2, that signal will be routed simultaneously to both pairs of output ports on your audio interface.

This lets you send the same signal (such as a stereo pair, a stem mix, or a multichannel mix) to multiple destinations (such as multiple mastering devices).
To select multiple output ports for a Pro Tools output channel pair:
1. Choose Setup > Hardware.
2. From the Peripherals list, select an interface.
3. Click the Main tab.
4. Select an output port pair from an Output pop-up menu.
5. Start-click (Windows) or Control-click (Mac) the same pop-up menu a second time to choose an additional output port pair.

The output name updates with a plus sign (“+”) before it to indicate that multiple output ports are selected. In the pop-up menu, each physical port pair assigned to that Pro Tools output pair is indicated by a check mark.

6. Repeat the above steps to select additional output destinations. The only limit to output choices is the number of outputs available in your system.

Pro Tools output pairs can also be routed to multiple audio interface outputs in the I/O Setup dialog. For more information, see “Routing Hardware I/O to Pro Tools I/O” on page 79.

Creating a New Session

The first step in beginning a Pro Tools project is creating a new session.

To create a new session:
2. Choose the drive where you want to save the session. The session should be saved on a dedicated audio drive.
3. Select the audio file format for the session. For optimum compatibility between Windows and Mac, set the file type to BWF (.WAV).

Sound Designer II (SD II) files are not supported on Windows systems or at sample rates above 48 kHz.
4. Select the bit depth (16 bit or 24 bit) and the sample rate.
5. Select the I/O Settings to use for the session. Several pre-configured I/O Settings are included with your system, or you can select a custom I/O Setting that you have created. See Chapter 7, “I/O Setup” for more information.
6. Name the Session.
7. Click Save.
Selecting Bit Depth and Sample Rate

When selecting a bit depth or sample rate for your session, consider fidelity, any compatibility issues with others systems, and storage space.

Bit depth and sample rate also have an effect on the amount of mixing power available in a session. Fewer mixer channels are available with 24-bit sessions and with sessions at higher sample rates. (For more information, see the Pro Tools|HD Getting Started Guide.)

It is not possible to combine different bit depths within a single Pro Tools session; files of different bit depths must be converted and imported into the session.

Session Files and Folders

When you create a new session, Pro Tools automatically creates a new folder named for your session. Within this folder is the session file, a WaveCache.wfm file, and several subfolders (an Audio Files folder, a Fade Files folder, a Region Group folder, and a Session File Backups folder).

Audio Files Folder

The Audio Files folder contains all audio recorded or converted during the session.

When you record a new audio track, the track is saved as a new audio file to the Audio Files folder. You can also import other audio files into the session, and work with them as well.

For details on allocating audio tracks to different hard drive locations, including shared media volumes, see “Disk Allocation” on page 187.

Fade Files Folder

The Fade Files folder contains any crossfaded audio data generated by the session.

Region Groups Folder

The Region Groups folder is the default directory for any region groups that you export from your Pro Tools session.

WaveCache File

The WaveCache.wfm file stores all of the waveform display data for the session. If you delete the WaveCache.wfm file, Pro Tools will create a new one the next time you open the session.

By storing waveform data in the WaveCache file, sessions are able to open more quickly. The session WaveCache file can be included whenever a session is transferred to another Pro Tools 7.x system.

Pro Tools also maintains a distinct WaveCache file inside the local Digidesign Databases folder (C:\\Digidesign Databases) which retains waveform data for all files used on the system. Additional WaveCache files are created on each external hard drive attached to your system, and stored in the Digidesign Databases folder on each drive.

Typical session folder contents

Session File

The session file is the document that Pro Tools creates when you start a new project. Pro Tools can open only one session file at a time. The session file is named with a .ptf (Pro Tools file) extension.
Deleting or trashing any of the WaveCache files will not harm the session or your system. Each session will merely need more time to open due to having to recalculate waveform data for associated audio (and store that data in a new WaveCache file).

**Session File Backups Folder**

The Session File Backups folder contains automatically-generated backups of your Pro Tools sessions. These files are created when working on a session and the Operations preference for Enable Session File Auto Backup is enabled. (See “Enable Session File Auto Backup” on page 64.)

**Renamed Audio Files Folder**

This folder includes file names that have been renamed when you open a session that contains audio file names with incompatible characters, or, in certain situations, save a copy of a session to a Pro Tools version that does not support long file names.

For more information, see “Renamed Audio Files and the Renamed Audio Files Folder” on page 164.

---

**Opening a Session**

When you open a session, Pro Tools looks in the session folder for audio and fade files linked to the session.

For more information on opening sessions created on different platforms, Pro Tools systems, or Pro Tools software versions, see Chapter 10, “File and Session Management and Compatibility.”

---

**To open an existing session:**

1. Choose File > Open Session.
2. Locate the session you want to open and click Open.

---

**Opening a Session that Contains Unavailable Files**

The DigiBase feature will prompt you if files are located but reside on Transfer volumes (such as CD or DVD discs), or if any required files cannot be found. See “Locating Audio Files” on page 163 for more details.

**Opening a Session from a Transfer Volume**

When opening a session from a Transfer volume (such as a CD or DVD disc), the DigiBase feature will prompt you to save the session on a Performance volume, and copy and convert any referenced media files. See “Locating Audio Files” on page 163 for more details.
Opening a Session that Contains Unavailable Resources

Pro Tools prompts you when opening a session that contains unavailable voices, I/O paths, DSP resources, or plug-ins. This is common when transferring sessions to systems with different Digidesign hardware.

The Unavailable Resources dialog provides an initial report of the missing session components. To save a text (.txt) file containing a more detailed Notes report, along with the resulting action, click Yes. The Notes report will be named with the session name, followed by Notes.txt. You can choose to save this file in your Session folder, or in another location.

The following will occur when opening a session with unavailable items:

**With all Pro Tools Systems:**
- Inserts assigned to unavailable plug-ins are made inactive.
- Inputs, outputs, and sends that are assigned to unavailable paths are made inactive.

**With Pro Tools HD Only:**
- Any tracks beyond the maximum number of available voices on the current system are made inactive.

**With Pro Tools LE and M-Powered Only:**
- Any tracks beyond the maximum number of available voices on the current system are set to voice off.

Opening a Session with Audio File Names that Contain Illegal Characters

Pro Tools 7.x does not support audio file names that contain the following ASCII characters:

/ (Forward Slash)
\ (Backslash)
: (Colon)
* (Asterisk)
? (Question mark)
“ (Quotation marks)
< (Less-than symbol)
> (Greater-than symbol)
| (vertical line or pipe)

Any “high order” ASCII character (created with a key combination)

When opening sessions that contain audio files with illegal characters, Pro Tools automatically creates a renamed copy of each file (replacing these characters with an underscore “_”). Renamed files are copied to the Renamed Audio Files folder. The original files are left intact in the Audio Files folder.

Before the session opens, you are prompted to save a detailed report of the renamed files and their original file names to a Notes text file. Follow the on-screen instructions. By default, the Notes text file is saved to the Session folder.

Opening a Session that Was Saved with +6 dB Fader Gain

All Pro Tools 7.x sessions have a +12 dB fader gain level. However, when saving a Pro Tools 7.x session to a lower version of Pro Tools that supports +6 dB and +12 dB fader gain, the new session can be saved with either a +6 dB or a +12 dB maximum fader gain.
When saving a +12 dB session as a +6 dB session, Pro Tools alerts you that any automation breakpoints over +6 dB will be lowered to +6 dB. See “Saving a Copy of the Session” on page 54.

In Pro Tools 7.x, when opening a session that was saved with a +6 dB maximum gain level, the session will update to a +12 dB range.

---

**Saving a Session**

You should save regularly while working on your session to ensure that your work is preserved on your hard drive.

**Saving the Session File**

The Save command saves the changes you have made to your session and writes them over the previously saved version of the session file. The Save command cannot be undone.

**To save a session:**

- Choose File > Save.

**Revert to Saved Command**

If you have made changes to a session since you last saved it, you can discard the changes and revert to its previously saved state.

**To revert to the last saved version of a session:**

- Choose File > Revert to Saved.

You can also open up a backup copy of your session, if you have enabled the Operation preference for Auto Backup. This feature lets you specify the total number of incremental backups that are kept and how often the session is saved. See "Auto Backup Section" on page 64.

---

**Saving the Session File with a New Name**

To save a copy of the current session with a new name or to a different hard drive location, you can use the Save As command. Because the Save As command closes the current session and lets you keep working on the renamed copy, it is useful if you are experimenting and want to save successive versions of the session.

By working this way, you can quickly retrace your steps if you want to go back to an earlier version of your session. The Save As command saves a new version of the session file only—not duplicate versions of the audio or fade files.

**To save a session with a new name:**

1. Choose File > Save As.
2. Enter a new name for your session.
3. Pro Tools 7.x lets you name files with as many characters as your operating system supports.
4. Click Save.

The renamed session file is saved in the session folder along with the original session (unless you specify a different destination). Any new audio files that you record in your renamed session will be placed into the same Audio Files folder that was created for your original session.
Saving a Copy of the Session

To save a copy of the current session with or without its audio files and fade files, you can use the Save Copy In command. In addition, you can specify a session file format, audio file format, bit depth, and sample rate for the session copy.

Unlike the Save As command, Save Copy In does not close the original session, so subsequent edits are made to the original session. Session copies can be used to archive important sessions, or as a means to prepare sessions for transfer to another Pro Tools system.

Save Copy In can save only the audio being used in the session. Any audio that was recorded or imported and then later removed from the session will not be included in the new session copy.

Using the Save Copy In command is the only way to change the sample rate of a session.

When you save a copy of the session to a lower bit depth, Dither (and Noise Shaping) are applied. See the following table:

<table>
<thead>
<tr>
<th>Session Bit Depth</th>
<th>Dither</th>
<th>Noise Shaping</th>
</tr>
</thead>
<tbody>
<tr>
<td>24-bit to 24-bit</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>16-bit to 24-bit</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>24-bit to 16-bit</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>16-bit to 16-bit</td>
<td>No</td>
<td>No</td>
</tr>
</tbody>
</table>

The Dither setting used for any conversion is the Digidesign Dither plug-in with Noise Shaping enabled.

To include audio with the session copy, All Audio Files must be selected in the Items to Copy section.

To save a session copy in a new location:

1. Choose File > Save Copy In.
2. In the Save Copy In dialog, choose a destination and enter a name for the new session file.
3. Choose a session file format for the copied session.
4. Set the Audio File Type for the copied session. If the audio files need to be compatible with either Windows or Mac, select BWF (.WAV) or AIFF.
5. Set the session Sample Rate and Bit Depth for the copied session.
6. If applicable, select a Fader Gain level for the copied session.

For information about using Dither, see “Dither” on page 557.

For information on sharing sessions between different platforms, Pro Tools systems, or Pro Tools software versions, see Chapter 10, “File and Session Management and Compatibility.”
7 If applicable, select “Enforce Mac/PC Compatibility” to create session and audio files that can be used on both Windows and Mac Pro Tools systems. See “Saving Copies of Mac Sessions to be Compatible with Windows” on page 168.

8 Select the Items to Copy for the copied session.

⚠️ To include audio with the session copy, All Audio Files must be selected.

9 Click Save.

**Session Format**

You can save the session copy in the following formats, depending on your platform:

**Windows:**
- Pro Tools Session (.ptf); supports Pro Tools 7.x
- Pro Tools 5.1 -> 6.9 Session (.pts);
- Pro Tools 5.0 Session (.pt5)
- Pro Tools 4 24-Bit Session (.p24)
- Pro Tools 4 16-Bit Session (.pt4)

**Mac:**
- Latest; supports Pro Tools 7.x
- Pro Tools 5.1 -> 6.9 Session
- Pro Tools 5.0 Session
- Pro Tools 4 24-Bit Session
- Pro Tools 4 16-Bit Session
- Pro Tools 3.2 Session

When saving sessions to versions lower than 5.1, multichannel tracks (including stereo) and multi-mono plug-ins are lost. In this case, make sure to first separate the tracks and plug-ins to individual mono tracks.

**Session Parameters**

**Audio File Type**

You can save the session to reference BWF (.WAV) or AIFF audio files. On the Mac, you can also save the session to reference SD II audio files (at sample rates up to 48 kHz).

⚠️ SD II sessions are not supported with Pro Tools on Windows, or with sample rates higher than 48 kHz.

**Using Mixed File Types**

A session can use mixed audio file types. If your original session has mixed file types, they are not converted to a different file type unless you specify that they be converted. However, when using mixed file types, audio performance will be reduced (due to additional file handling required for some file formats).

**Bit Depth**

You can save the new session at 16-bit or 24-bit depth. If your session is in a different bit depth, audio files are converted to the new session bit depth, and copied to the location you specify.

⚠️ For information on bouncing to disk and dither, see “Dither and Bounce to Disk” on page 636.

**Sample Rate**

You can save the new session at sample rates of 44.1 kHz or 48 kHz (on Mbox 2 and Mbox) and at sample rates up to 96 kHz (on Digi 002, Digi 002 Rack and Pro Tools|HD systems with a 96 I/O or 96 I/O) or up to 192 kHz (on Pro Tools|HD systems with a 192 I/O or 192 Digital I/O). If your session is at a different sample rate, audio files are converted to the new session sample rate, and copied to the location you specify.
The higher the quality of sample rate conversion you choose, the longer Pro Tools will take to process the audio file.

**Fader Gain**

When saving a Pro Tools 7.x session to a lower version of Pro Tools that supports +6 dB and +12 dB fader gain, you can save the new session with either a +6 dB or a +12 dB maximum fader gain. When saving a +12 dB session as a +6 dB session, Pro Tools alerts you that any automation breakpoints over +6 dB will be lowered to +6 dB.

**Enforce Mac/PC Compatibility**

When saving a Pro Tools 7.x session to a lower version of Pro Tools, this setting forces Windows or Mac versions of Pro Tools to create sessions and audio files that are usable on both platforms.

For more information, see “Saving Copies of Mac Sessions to be Compatible with Windows” on page 168.

**Items to Copy**

**All Audio Files**

When this option is selected, all audio files are copied to the new location.

This setting is automatically selected if you are changing the bit depth or sample rate of the session.

**All “Non-Native” Audio Files**

The name of this option varies depending on the audio file type you select. If you are changing the audio file type of the session, this option ensures that all files in the copied session are converted to the selected file type. Use this option to avoid the reduced performance of a session with mixed file types.

This option is automatically selected if you are changing bit depth or sample rate, or copying a session on the Mac from SD II format to AIFF or BWF (.WAV) format with Enforce Mac/PC Compatibility selected.

**Don’t Copy Fade Files**

When this option is selected, Fade Files are not copied to the new session Fade Files folder.

Pro Tools opens the session with all available media, then shows you how many files are missing (if any) and asks how you want to proceed. You can choose to locate the existing fades, using Manually Find Relink or Automatically Find Relink, or choose to Skip All to let Pro Tools recreate the fades from the session document. You can also select Regenerate Missing Fades to exclude fade files from the relink process and regenerate them instead.

**Session Plug-in Settings Folder**

When this option is selected, the session’s Plug-in Settings folder is copied to the new location. The references to these plug-in settings in the session are redirected to the copied settings files.

**Root Plug-in Settings Folder**

When this option is selected, the contents of the root-level Plug-in Settings Folder are copied into a folder named Place in Root Settings Folder, indicating that these files will need to be moved to
the root level plug-in settings folder on the destination system before you can use them. The references to these settings files in the session are not redirected to point to the copied files.

**Movie/Video Files**

When this option is selected, session movie files (such as Avid or QuickTime video files) are copied to the new location, and session references are updated to point to the copied movie files.

**Preserve Folder Hierarchy (Pro Tools HD Only)** When selected, the relative arrangement of session audio files located across different drives or folders is maintained. The main folder for the session copy will include subfolders for each drive or folder in the original session and the destination subfolders will use the same names as the source drives and folders.

When this option is not selected, the Save Copy In command copies all files of the same type, regardless of their location, into a single destination folder.

**Creating Custom Session Templates**

You can create custom session documents that are pre-configured to the track setups, mixer setups, window arrangements, and zoom level Memory Locations that you use most frequently. Doing this will save you the trouble of having to create your studio setup from scratch every time you start a new session.

**Creating Windows Templates**

In Windows, you can create a session template by making a session file a Read Only document.

**To create a custom session template in Windows:**

1. Create a session and arrange its elements as you want them to appear in the template. You can also define elements such as signal routings, insert and send configurations, Track Views, ruler settings, and Preference settings.
2. Choose File > Save As.
3. Name the session and click Save.
4. Close the session.
5. Locate the session file that you just saved.
6. Right-click the file and choose Properties.
7. Under Attributes, select Read Only.

![Image of a session template in Windows]

**Making a session a Read Only file (Windows)**

8. Click OK.

To use this template, double-click it or open it with the Open Session command. When you first save the session, Pro Tools will ask you to give the session a new name. Your original session template will remain unchanged.

To modify the session template, you will need to reopen its Properties, deselect the Read Only option, make your modifications, then change it back to a Read Only file.
**Creating Mac Templates**

On the Mac, you can create a session template by saving a session file as a *Stationery Pad* document. Once a session is saved as a Stationery Pad, it acts as a template that you can open and then resave as a normal session.

**To create a custom session template on the Mac:**

1. Create a session and arrange its elements as you want them to appear in the template. In addition to track setup, you can also define elements such as signal routings, insert and send configurations, Mix and Edit window views, ruler settings, and Preference settings.

2. Choose File > Save As.

3. Name the session and click Save.

4. Close the session.

5. Locate the session file that you just saved.

6. Click once on the file to select it.


8. If necessary, click the General expand/collapse triangle to display the General information and options.

9. Select the Stationery Pad option.

10. Select the Locked option.

11. Close the information window.

To use this template, double-click it or open it with the Open Session command if you are already running Pro Tools.

When you open a session saved as a Stationery Pad, Pro Tools gives you the option of editing the template or starting a new session using the template settings. If you choose New Session, Pro Tools will create a new folder containing a copy of your session template and Audio and Fades folders.

---

**Closing a Session**

Because Pro Tools lets you work on just one session at a time, you must close the current session if you want to work on another. The Close Session command closes your current Pro Tools session but leaves the Pro Tools application open. You can save your work using the Save or Save As command before closing a session.

**To close a session:**

- Choose File > Close Session.

---

**Quitting Pro Tools**

Although Pro Tools will warn you before allowing you to quit without saving changes, you should generally save your work before quitting.

**To exit Pro Tools in Windows:**

- Choose File > Exit.

**To quit Pro Tools on the Mac:**

- Choose Pro Tools > Quit Pro Tools.
System Usage

About Processing Bandwidth

Meters in the System Usage window indicate how much of your system’s processing power is being used in processing audio, and when writing and playing back automation.

Pro Tools HD, LE, and M-Powered have three common meters, showing PCI bus activity, CPU processing activity, and Disk processing activity.

With Pro Tools HD, there are addition meters, showing TDM Time Slot usage and DSP usage of each Pro Tools|HD system card.

If CPU or PCI Activity are high, a system error may occur. If Disk Activity is high, Pro Tools may miss playback of some of your automation data during particularly dense periods of activity, such as while using the Bounce to Disk command.

To monitor the usage of resources during a Pro Tools session:

- Choose Window > System Usage.

For more information, see “Bounce to Disk” on page 638.

To reduce processing load, try one of the following:

- Reduce the density of automation in places where it shows the most activity. For details, see “Thinning Automation” on page 604.

- Turn off meters in Sends View, if enabled (by disabling Show Meters in Sends View in the Display Preferences page). For details, see “Individual Send Views and Meters” on page 540.

System Usage Views

(Pro Tools HD Only)

With Pro Tools HD, there are five different System Usage Views: Small, Large, Detailed, Gas Gauge, and Activity Only. The Detailed and Gas Gauge formats show the percentage of each DSP chip in use.

To change the System Usage View:

- Choose View > System Usage, and one of the System Usage View formats (such as Small).

For information on using different views to monitor DSP usage, see the Pro Tools|HD Getting Started Guide.
Preferences

The Preferences dialog has several tabbed pages in which you can specify your preferred settings for various session parameters. Each new session will use these preferences.

Display Preferences

Basics Section

Draw Grids in Edit Window Adds grid lines to the Edit window. Grid line resolution is based on the zoom level of the Edit window.

Draw Waveforms Rectified Displays audio waveform data in rectified view. In this view, audio waveforms are displayed so that their positive and negative waveform excursions (the portions that fall above and below the center line) are summed together and viewed as a single positive-value signal. This view allows more waveform detail to be seen in either normal or reduced track height views. It can be particularly useful when editing volume automation data, since it depicts waveform levels as starting at the bottom of the track.

Recompute Invalid Overviews Prompts Pro Tools to look for missing or corrupted overview data (the data used to create waveform displays) when it opens sessions. If Pro Tools finds that overview data is missing or corrupted, it will recreate one or more overviews for the session. This may take some time if there are many tracks in the session. If you suspect that overview data for a session has become corrupted, or if you import audio files which have no overview data into a session, make sure this preference is enabled for the session, save and close the session, then reopen it. Pro Tools will recreate any overviews for the session when it opens.

Track Position Numbers Stay with Hidden Tracks When selected, tracks keep their track numbers even when hidden. When not selected, numbers are only assigned to tracks that are shown. In this case, shown tracks are then numbered sequentially, and hidden tracks are not numbered.

Tool Tips Display Options

Function Configures Tool Tips to show the basic function of the item.

Details Configures Tool Tips to show the complete name of an abbreviated name or item. Details view can also show the hidden or abbreviated value of parameters, as well as input and output assignments.

Edit Window Default Length

This preference sets a default length for the Edit window in hours, minutes, seconds, and frames (Pro Tools HD or Pro Tools LE with DV Toolkit 2 only). This is useful if you want to assemble a session of a particular length or leave extra room to expand the Edit window’s work area in your session. The maximum length is 12 hours and 25 seconds at 48 kHz, and proportionally less at higher sampling rates.
“Organize Plug-in Menus By” Options

These options customize how plug-in menus are organized in the Insert selector or Plug-in selector.

Flat List Organizes plug-ins in a single list, in alphabetical order.

Category Organizes plug-ins by process category (such as EQ, Dynamics, and Delay), with individual plug-ins listed in the category submenus. Plug-ins that do not fit into a standard category (such as the DigiRack Signal Generator), or third-party plug-ins that have not had a category designated by their developers, appear in the Other category. Plug-ins can appear in more than one category.

Manufacturer Organizes plug-ins by their manufacturer (such as Digidesign, Eventide, Line 6, and McDSP), with individual plug-ins listed in the manufacturer submenus. Plug-ins that do not have a Manufacturer defined will appear in the “Other” manufacturer folder.

Most Digidesign-distributed third party plug-ins will be grouped under Digidesign when Manufacturer view is enabled.

Category and Manufacturer Organizes plug-ins in two levels of menus. The top menus display plug-ins by process category (such as EQ, Dynamics, and Delay), with individual plug-ins listed in the category submenus. The bottom menus display plug-ins by manufacturer (such as Digidesign, Eventide, Line 6, or McDSP), with individual plug-ins listed in the manufacturer submenus.

Meters Section

Peak Hold Options

These options determine how long the peak indicators on track meters stay lit after a peak is detected.

3 Second Peak Hold When selected, track meters display the last peak level for three seconds.

Infinite Peak Hold When selected, track meters display the last peak level until you click them to clear them.

No Peak Hold When selected, track meters do not hold the peak level.

Clip Indication Options

These options determine how long the clip indicators on plug-in, send, and track meters stay lit after a clip is detected.

3 Second Clip Hold When selected, meters display the last clip indication for three seconds.

Infinite Clip Hold When selected, meters display the last clip indications until you click them to clear them.

No Clip Hold When selected, meters do not hold the clip indication.

Show Meters in Sends View

When the Sends View is displaying individual send controls, you can select this option to show send level meters. Deselecting this option can help speed up screen redraws and processing.
**Color Coding**

**Always Display Marker Colors** Lets you choose to view Marker colors in the Markers ruler, regardless of the settings you choose for Default Region Color Coding.

**Default Track Color Coding Options**

These color coding options determine the default color coding assignment for tracks in the Edit and Mix windows. Choices are:

- **None** Turns off color assignment for tracks.
- **Tracks and MIDI Channels** Assigns a color to each track in the Mix or Edit window according to its voice assignment or MIDI channel assignment.
- **Tracks and MIDI Devices** Assigns a color to each track in the Mix or Edit window according to its voice assignment or MIDI device assignment.
- **Groups** Assigns a color to each track according to its Group ID. If groups are suspended using the Suspend Groups command, the tracks color bars are not shown.
- **Track Type** Assigns a color to each track according to its type (audio, MIDI, Instrument, Auxiliary or Master Fader).

**Default Region Color Coding Options**

These color coding options determine the default color coding assignment for regions in the track playlist. Choices are:

- **None** Turns off color assignment for regions. Regions are drawn with black waveform or MIDI notes on a light gray background.
- **Tracks and MIDI Channels** Assigns a color to each region in the Edit window according to its voice or MIDI channel assignment.
- **Tracks and MIDI Devices** Assigns a color to each region in the Edit window according to its voice assignment or MIDI device assignment.
- **Groups** Assigns a color to each region according to the Group ID of its track. If groups are suspended using the Suspend Groups command, all regions display black waveforms or MIDI notes on a light gray background.
- **Track Color** Assigns a region color based on the color assigned to the track.
- **Marker Locations** Assigns a color to data across all tracks based on the nearest preceding marker.
- **Region List Color** Assigns a color to each region based on its color in the Region List.
Operation Preferences

Transport Section

Timeline Insertion Follows Playback This option causes the screen's play cursor to update its location to the point where playback stops.

Edit Insertion Follows Scrub/Shuttle When selected, the edit cursor automatically locates to the point where scrubbing stops.

Audio During Fast Forward/Rewind When selected, audio is audible during fast forward or rewind.

Custom Shuttle Lock Speed Sets the highest fast-forward Shuttle Lock speed (key 9) for Shuttle Lock modes (Classic or Transport). The range for this setting is 50–800%.

For more information, see “Custom Shuttle Lock Speed” on page 298.

Back/Forward Amount Sets the default length of Back, Back and Play, Forward and Forward and Play. The timebase of the Back/Forward Amount settings follows the Main Time Scale by default, or you can deselect Follow Main Time Scale and select another timebase format: Bars:Beats, Min:Sec, Time Code, Feet+Frames, or Samples.

Numeric Keypad Mode

Numeric Keypad mode determines how the numeric keypad functions. You can always use the numeric keypad to select and enter values in the Event Edit Area, Edit Selection indicators, Main and Sub Counters, and Transport fields.

Classic Selects a Shuttle Lock mode that emulates the way Pro Tools worked in versions lower than 5.0. With the Numeric Keypad mode set to Classic, you can play up to two tracks of audio in Shuttle Lock mode. Press the Start key (Windows) or Control (Mac), followed by 0–9 for different play speeds. Press Plus (+) or Minus (−) to reverse direction. Recall Memory Locations by typing the Memory Location number, followed by Period (.)

To customize the highest fast-forward Shuttle Lock speed, see “Custom Shuttle Lock Speed” on page 298.

Transport Selects a Shuttle Lock mode that lets you set a number of record and play functions, and also operate the Transport from the numeric keypad. With the Numeric Keypad mode set to Transport, you can play up to two tracks of audio in Shuttle Lock mode. Press the Start key (Windows) or Control (Mac), followed by 0–9 for different play speeds. Press Plus (+) or Minus (−) to reverse direction. Recall Memory Locations by typing Period (.), the Memory Location number, and Period (.) again.

To customize the highest fast-forward Shuttle Lock speed, see “Custom Shuttle Lock Speed” on page 298.

Shuttle (Pro Tools HD Only) Selects a type of shuttling different from that of Shuttle Lock mode. With the Numeric Keypad mode set to Shuttle, playback is triggered by pressing and holding the keys on the numeric keypad—playback stops once the keys are released. Various
playback speeds are available in both forward and reverse. You can also recall Memory Locations by typing Period (.), the Memory Location number, and Period (.) again.

**Video Section**

**QuickTime Playback Priority Options**

**Normal** This is the default setting for QuickTime Movie Playback Priority. It gives no extra priority to movie playback over other screen update tasks such as metering, moving faders, and so on. In most cases you should use this setting.

**Medium** This setting gives QuickTime movie playback a higher priority relative to other Pro Tools screen update tasks. Use this setting if you experience inconsistent QuickTime movie playback with the Normal setting.

**Highest** This setting gives QuickTime movie playback highest priority. In this mode, Pro Tools disables screen activity and requires you to use the Spacebar to stop playback. Use this setting if you require uninterrupted QuickTime movie playback.

**Avid Video Errors Stop Playback**

(Pro Tools HD Only)

When selected, Pro Tools automatically stops playback of audio and video if a single frame of video is dropped.

When not selected, Pro Tools continues playback of audio even if frames are dropped. In most cases, video playback will recover within a few frames and continue playing audio and video in sync.

**Avid Video NTSC Has Setup (NTSC-J)**

(Pro Tools HD Only)

This preference lets you adjust the level of NTSC video black output between 7.5 IRE (standard) or 0 IRE. When this option is selected, output level is 0 IRE.

**Auto Backup Section**

**Enable Session File Auto Backup** When selected, Pro Tools automatically saves backups of your Pro Tools session file while you work. Backups are saved to in the Session Files Backup folder in your session folder.

**Keep** specifies the total number of incremental backups that are kept.

**Backup Every** Specifies how often the session is saved.

**Record Section**

**Latch Record Enable Buttons** When selected, multiple audio tracks can be record-enabled. When not selected, multiple audio tracks cannot be record-enabled. Record-enabling an audio track takes other audio tracks out of record-enabled mode.

**Link Record and Play Faders** When selected, Pro Tools does not remember separate fader levels for tracks when they are record-enabled, allowing you to maintain the same monitoring level for tracks during recording and playback.
Audio Track RecordLock This option configures Pro Tools tracks to either emulate a digital dubber, or to maintain legacy behavior for track record status.

- When selected, the record-enabled audio tracks remain record-enabled when playback or recording stops.
- When not selected, record-enabled audio tracks are taken out of record enable when Pro Tools is stopped. This prevents tracks from remaining armed from pass to pass, emulating track record behavior of a digital dubber.

Transport RecordLock This option lets the Transport Record (the Record Enable button in the Transport controls) be configured to either emulate a digital dubber, or to maintain legacy behavior for the Transport master Record.

- When selected, the Transport Record remains armed when playback or recording stops. This saves having to re-arm the Transport between takes, emulating digital dubber behavior.
- When not selected, the Transport Record disarms when Pro Tools is manually stopped or stops due to a loss of time code. This replicates standard Pro Tools recording behavior.

⚠️ The Transport RecordLock preference is automatically disabled and greyed out when Destructive record mode is enabled.

Disable “Input” When Disarming Track (In “Stop”) For flexibility, TrackInput monitoring can be customized to remain selected regardless of track record status, or to automatically switch to Auto Input monitoring after a recording pass. This lets you optimize monitoring for a typical dubbing workflow (in which you might want tracks to remain in Input Only mode until explicitly switched to Auto Input monitoring) or a typical music tracking workflow (in which leaving a track in Input Only monitoring mode after recording can result in accidental double-monitoring).

- When selected, taking an audio track out of record enable (any mode) takes it out of Input Only mode, regardless of the global monitor mode, and switches it to monitor audio from disk only.
- When not selected, audio tracks remain in Input Only monitoring mode until explicitly switched to Auto Input monitoring.

Mute Record-Armed Tracks While Stopped This setting determines monitor status of record-armed tracks.

- When selected, Pro Tools mutes all record-enabled tracks when the transport is stopped. Input can still be monitored while stopped using the TrackInput Monitor button.
- When not selected, Pro Tools does not mute audio input on record-enabled tracks when the transport is stopped.
PEC/Direct Style Input Monitoring (Pro Tools HD Only) This option changes the way the Track-Input monitoring mode is indicated on-screen (and on supported control surfaces) to emulate “PEC” (playback) and “Direct” (input/bus) indication on some large format consoles.

- When not selected, the TrackInput button shows the letter “I.” The button remains gray to indicate Auto Input mode and lights green to indicate Input Only mode.
- When selected, the TrackInput button remains gray and shows the letter “D” to indicate Input Only mode (“Direct”); it lights green and shows the letter “P” to indicate Auto Input mode (“Pec” or playback).

Online Options

Record Online at Time Code (or ADAT) Lock When selected, online recording begins as soon as Pro Tools receives and locks to incoming time code.

Record Online at Insertion/Selection When selected, online recording begins at the edit cursor location. Recording continues until Pro Tools stops receiving time code. If you make a selection, Pro Tools records online for the length of the selection.

Open Ended Record Allocation

This preference determines how much of your available hard drive space is allocated for recording.

Use All Available Space When selected, the drive’s entire available space is allocated. This can sometimes slow down the recording process for hard drives that use certain file systems, including HFS+ and NTFS.

Limit To Sets the maximum allowable recording duration. This can help reduce the time it takes to begin recording by allocating only a portion of your hard drive. The number of minutes specified is allocated for each record-enabled track. You may want to experiment with this number to achieve the recording performance you want.

DestructivePunch File Length

This preference sets the duration of consolidated audio files when preparing tracks for DestructivePunch mode. The default value for this setting is 25 minutes.

Misc (Miscellaneous) Section

Auto Region Fade In/Out Length Sets a default length for fade-ins and fade-outs automatically applied to region boundaries. Using automatic fade-ins and fade-outs saves you the trouble of editing to zero-crossings or creating numerous rendered fades in order to eliminate clicks or pops in playback. Autofades are not written to disk. Value range is from 0–10 ms for the Auto Region Fade In/Out Length. A value of zero means that no auto-fading will occur. The Auto Fade value is saved with the session, and is automatically applied to all free-standing region boundaries until you change it.

Calibration Reference Level (Pro Tools HD Only)

Sets a default calibration reference level in dB when Pro Tools is in Calibration mode. For audio interfaces that have trims (such as the 192 I/O), see the interface’s guide for calibration instructions.

Delay Compensation Time Mode This option lets you choose whether information in the Delay Manager is displayed in milliseconds or samples. This option is only available when Delay Compensation is enabled (Options > Delay Compensation).
**Editing Preferences**

- **Region List Selection Follows Edit Selection** When selected, selecting a region in a track also selects it in the Region List.

- **Edit Selection Follows Region List Selection** When selected, selecting a region in the Region List causes Pro Tools to highlight that region’s occurrence in a track.

- **Auto-Name Separated Regions** When selected, Pro Tools automatically names newly separated regions by appending a number to the region’s name. Disabling this option can be useful when importing region groups, REX files, or ACID files, because these file types can contain so many separate regions that it becomes difficult to read the Region List.

- **“Matching Start Time” Takes List** When you Control-click (Windows) or Command-click (Mac) a region in a track, Pro Tools displays a list of regions whose time stamp matches the current Cursor location. The following preferences determine which regions, or *takes*, appear in this list:

  - **Includes Take Region Names That Match Track Names** When selected, only regions that share the same root name with the track and playlist appear in the Takes List pop-up menu.

  - **Includes Take Region Lengths That Match** When selected, only regions that match the length of the current selection appear in the Takes List pop-up menu.

  - **“Separate Region” Operates On All Related Takes** When selected, editing a region with the Separate Region command also affects all other related takes (recording passes) with the same User Time Stamp. This option helps you compare different sections from a group of related takes.

- **Memory Locations Section**

  - **Auto-Name Memory Locations When Playing** When selected, Pro Tools gives new Memory Locations default names based on their time location in the session. The time units currently chosen in the View menu determine the units for the names.

  - **Recall Memory Location at Original Track** When selected, Memory Locations that recall a selection also recall the track in which the selection was made.

- **Fades Section**

  - **Crossfade Preview Pre-Roll** This option specifies the amount of pre-roll to be added when you are auditioning crossfades in the Fades dialog.

  - **Crossfade Preview Post-Roll** This option specifies the amount of post-roll to be added when you are auditioning crossfades in the Fades dialog.
QuickPunch/TrackPunch Crossfade Length specifies a default length for crossfades created by QuickPunch or TrackPunch recordings. Crossfades occur before the punch in and after the punch out.

Preserve Fades when Editing This option preserves fade-ins and fade outs, and converts separated crossfades into corresponding fade-ins and fade-outs.

Default Fade Settings

Fade In Selects the default envelope shape for fade-ins.

Crossfade Selects the default envelope shape for crossfades.

Fade Out Selects the default envelope shape for fade-outs.

REX/ACID Selects the default envelope shape for fades and crossfades between regions (“slices”) in imported REX and ACID files.

Automatically Create Fades for Imported REX and ACID files

When selected, this option automatically applies fades between regions (“slices”) within imported REX and ACID files to minimize clicks or pops during playback. If there is overlap between slices, a crossfade is applied. If there is a gap between slices, a fade out is applied to the end of the first region. (The fade shapes applied to REX/ACID files follow the Default Fade Settings for REX/ACID.)

Levels of Undo

This preference sets the maximum number of actions that can be undone with the multiple undo feature. Setting this to a lower number can speed up the performance of slower computers. Pro Tools supports up to 32 Levels of Undo.

Mixing Preferences

Sends Default to –INF When selected, the initial fader level of newly-created sends is set to –\infty (no audible signal level). When not selected, the initial fader level of newly-created sends is set to 0 dB.

Send Pans Default to Follow Main Pan When selected, newly created sends have Follow Main Pan turned on, so the Send Pan controls follow the pan controls of the track. When not selected, newly created sends have Follow Main Pan turned off.

Link Mix and Edit Group Enables When selected, this option links enabling and disabling of Mix and Edit Groups. For example, enabling Group A in the Mix Window automatically enables Group A in the Edit window.

Use Absolute Pan Linking This option affects behavior of grouped pan controls.

• When selected, grouped pan controls do not maintain relative offsets when any of the grouped pan controls is adjusted. All grouped pan controls snap to the absolute value of the adjusted control.

Setup Section
• When not selected, grouped pan controls maintain relative offsets when any of the linked controls is adjusted.

**Default EQ**

This preference lets you choose any installed EQ plug-in as the default, which makes it available for quick assignment, both on-screen and on ICON work surfaces. On-screen, the plug-in appears at the top of the Insert selector pop-up menu. On ICON work surfaces, the plug-in appears first in the list of menu choices on the rotary encoders.

**Default Dynamics**

This preference lets you choose any installed Dynamics plug-in as the default, which makes it available for quick assignment, both on-screen and on ICON work surfaces. On-screen, the plug-in appears at the top of the Insert selector pop-up menu. On ICON work surfaces, the plug-in appears first in the list of menu choices on the rotary encoders.

**Controllers**

**Edit Window Follows Bank Selection** If you are using a supported control surface with Pro Tools, this option scrolls the Edit window to display the selected bank of tracks when you switch banks on the control surface, ensuring that the current bank is viewable on-screen.

**Mix Window Follows Bank Selection** If you are using a supported control surface with Pro Tools, this option scrolls the Mix window to display the selected bank of tracks when you switch banks on the control surface, ensuring that the current bank is viewable on-screen.

**“Scroll to Track” Banks Controllers** When using a control surface (such as D-Control or Pro-Control) you can select this option to bank control surface faders to a numbered track when using the Track > Scroll to Track command.

**Always Fill Channel Strips When Banking** If you are using an ICON worksurface, you can select this option to maximize the number of channels displayed when banking. This setting optimizes the Bank commands to prevent the display of a small number of channels at the extremes of the surface.

**Touch Timeout** If you are writing automation in Touch mode and you stop moving a non-touch sensitive fader or encoder, Pro Tools continues to write automation for the Touch Timeout value. After the Touch Timeout period, writing of automation stops and the automation data returns to its previous automation value at the rate specified in the *AutoMatch Time* setting.

**Automation Section**

**Smooth and Thin Data After Pass** When selected, Pro Tools automatically smooths and then applies the specified amount of thinning to the automation data created in an automation pass.

**Degree of Thinning** Specifies the amount of thinning performed on automation data when you using the Thin Automation command, or if you have selected the Smooth and Thin Data After Pass option.

**Plug-in Controls Default to Auto-Enabled** When selected, all applicable controls of newly added plug-ins are enabled for automation. When not selected, the controls of newly added plug-ins must be manually enabled for automation.
Suppress Automation “Write To” Warnings When selected, Pro Tools suppresses the warnings that appear after invoking any of the Write Automation To Start, Selection, End, or Punch commands and then stopping the transport.

Latch Behavior for Switch Controls in “Touch” This option determines the behavior of switch-type controls (such as mute or plug-in bypass) when writing automation in Touch mode.

- When selected, controls in Touch mode will latch in their current state. If an existing breakpoint is encountered, writing of automation stops. If the transport is stopped while writing, the control will AutoMatch to the underlying value.
- When not selected, controls in Touch mode will not latch.

Allow Latch Prime in Stop When selected and any tracks are in Latch mode, any automation-enabled controls on those tracks can be set to new values while the transport is stopped by touching or moving controls, to prepare for the next automation pass.

Coalesce When Removing Slaves from VCA Group (Pro Tools HD Only) This option determines the behavior when removing slave tracks from a VCA-controlled group.

- When selected, any automation on the VCA Master is automatically coalesced (without confirmation) to its slave tracks when the tracks are removed from the group.
- When not selected, a confirmation dialog lets you choose whether or not to coalesce the VCA Master automation to the slave tracks.

Standard VCA Logic for Group Attributes (Pro Tools HD Only) This option determines which Mix group attributes may be selected in the Group dialog when the group is assigned to a VCA Master.

- When selected, Main Volume, Mute, Solo, Record Enable, and Input Monitoring controls on slave tracks follow the VCA Master only and are not available to be independently linked. (This emulates the behavior of analog console VCA masters.)
- When deselected, Main Volume, Mute, Solo, Record Enable, and Input Monitoring controls follow the VCA Master, but also remain available for independent linking with groups.

Include Sends in Trim Mode This option determines the Trim status of Send faders when a track is put in Trim mode.

- When selected, Send faders go into Trim mode along with the Main Volume fader.
- When deselected, the Main Volume fader goes into Trim mode, but the Send fader stays in the corresponding standard Automation mode.

Include Control Changes in Undo Queue This option determines whether certain mixer control changes, such as moving a fader or pan control, are entered into the Undo queue.

- When selected, mixer control changes appear in the Undo queue, and are undone if any prior operation is undone.
- When deselected, mixer control changes will not appear in the undo queue, allowing you to undo other types of operations without losing the current mixer settings.

⚠️ Any set to default operations that affect mixer controls will be entered into the Undo queue.
**AutoMatch Time** If you are writing automation in Touch mode, when you release a fader or control, writing of automation stops and the automation data returns to its previous value. The rate of return to the previous value is the AutoMatch Time.

**AutoGlide Time (Pro Tools HD Only)** Specifies how quickly Pro Tools transitions (glides) from one automation value to another, when AutoGlide mode is used.

**Amount of Memory to Reserve for Automation Recording** Allocates memory for automation.

**After Write Pass, Switch To (Pro Tools HD Only)** Selects the Automation mode that Pro Tools tracks automatically switch to after an automation pass in Write (or Write Trim) mode. You can choose to switch to Touch or Latch mode, or stay in Write mode by selecting No Change. After an automation pass in Write Trim mode, tracks automatically switch to the Trim version of the specified setting.

**Coalesce Trim Automation Options (Pro Tools HD Only)**

These options determine when Trim automation is committed to the main automation playlist on a track.

**After Every Pass** Sets Trim automation to coalesce when the transport is stopped at the end of each Trim automation pass. No Composite Playlist is indicated.

**On Exiting Trim Mode** Sets Trim Automation to coalesce on a track when the track is taken out of Trim mode. A Composite Playlist can be viewed before committing Trim moves.

**Manually** Trim Automation can be coalesced only with the Coalesce Trim Automation command. A Composite Playlist can be viewed before committing Trim moves.

---

**Processing Preferences**

**AudioSuite Section**

**Buffer Size**

AudioSuite Buffer Size sets the size of the memory buffer used for audio processing and previewing with AudioSuite plug-ins. If AudioSuite preview stutters, set the buffer to Mini or Small.

**Use AudioSuite Dither** When selected, applies a selectable dither plug-in to specific AudioSuite processing tasks (such as Gain and Normalize).

**Plug-in** Specifies the plug-in used for dither processing when the Use AudioSuite Dither option is selected.

**Bit Depth** Lets you select a bit depth for the dithered audio (24-bit, 20-bit, 18-bit, or 16-bit).

**TC/E (Time Compression/Expansion) Section**

**TC/E Plug-in** Lets you choose the plug-in used for Time Compression and Expansion when you edit audio with the Time Compression/Expansion Trim tool. This Trim tool works by using Time Compression/Expansion to match an audio region to the length of another region, a tempo grid, a video scene, or other reference point.
**Default Settings**  Specifies the default settings used by the chosen Time Compression/Expansion plug-in.

**Import Section**

**Convert Imported “WAV” Files To AES31/BroadcastWave** When selected, this option applies to all newly imported WAV files, making them compliant with the AES31/EBU Broadcast standard.

**Automatically Copy Files on Import** When selected, all audio files that are imported by dragging and dropping are copied to the current session’s Audio Files folder, regardless of whether the files need to be converted to the current session’s file type, bit depth or sample rate. Additionally, when selected, the Import Session Data dialog defaults to “Copy from Source Media.” The Automatically Copy Files on Import preference does not affect the Import Audio command.

**Sample Rate Conversion Quality** Lets you select the default sample rate conversion quality. Sample rate conversion is used in a variety of Pro Tools processes including converting and importing audio files of different formats into a session, and bouncing and saving tracks to a different sample rate or bit depth. The higher the quality of sample rate conversion you choose, the longer Pro Tools will take to process the audio file.

**MIDI Preferences**

**Basics Section**

**Play MIDI Notes When Editing** When selected, causes MIDI notes to sound when you insert them with the Pencil tool or drag them with any of the Grabber tools.

**Use MIDI to Tap Tempo** When selected, you can tap a MIDI keyboard to enter a new tempo value into a tempo field.

**Display Events as Modified by Real-Time Properties** When selected, Pro Tools displays the effects of Real-Time Properties in both the Edit window and the MIDI Event List.

**Use F11 Key for Wait for Note** When selected, pressing the F11 Function key puts MIDI recording in Wait for Note mode.

**Default Note On Velocity** Sets the default Note On velocity for MIDI notes inserted in the Edit window and the MIDI Event List.

**Default Thru Instrument** Sets the default MIDI Thru instrument. You can select a predefined device from your available MIDI instruments, or select “First Selected MIDI Track” to use the assigned MIDI output of the first selected MIDI or Instrument track. When multiple MIDI or In-
Instrument tracks are selected, the instrument in the selected track that is closest to the top of the Edit window (or closest to the left edge of the Mix window) will be used.

**Pencil Tool Resolution When Drawing Controller Data** Sets the default resolution for MIDI controller data created with the Pencil tool. Setting this to a lower resolution helps avoid creating controller data that is unnecessarily dense. The value range is from 1 to 100 milliseconds.

**Global MIDI Playback Offset** Sets an offset in samples to compensate for MIDI latency. Entering a value here has the same effect as setting an offset with the MIDI Track Offsets command. Offset values can be positive (later) or negative (earlier).

**Note Display Options**

These options set the reference for middle C as C3, C4, or MIDI note number 60.

**Delay for External Devices Options (Pro Tools HD Only)**

These options let you apply Delay Compensation to Pro Tools-generated MIDI Time Code or MIDI Beat Clock. Generally, this delay should be applied when the external MIDI instrument is mixed externally, and should not be applied when the external MIDI instrument is mixed through the Pro Tools mixer.

These options are only available when a Delay Compensation Engine is chosen in the Playback Engine dialog and Delay Compensation is enabled in Pro Tools.

This option is distinct from the hardware offsets available for hardware inserts (in I/O Setup).

**Synchronization Preferences**

These preferences determine how a connected transport responds to Pro Tools.

**Machine Control Section**

**Machine Chases Memory Location** When selected, navigating to a specific location in a session with a Memory Location causes a connected transport to chase to that location.

**Machine Follows Edit Insertion/Scrub** When selected, navigating to a specific location in a session by moving the selection point or by scrubbing a track will cause a connected transport to chase to that location.

**Machine Cues Intelligently** When selected, if you navigate to a cue point that is more than 10 seconds from the current location, Pro Tools will command a connected transport to fast wind to the new location at full speed to within 10 seconds of the cue point. Cueing will then slow to normal speed until the point is reached. This can significantly speed up tape cueing with certain video transports.
Stop at Shuttle Speed Zero Causes Pro Tools to send a Stop command whenever you stop shuttling. This is useful if you have a machine that requires an explicit stop command to park correctly.

Non-Linear Transport Error Suppression

When Transport = Pro Tools, keeps Pro Tools from sending a Stop command when taken off-line. This prevents Pro Tools from stopping any other 9-pin devices connected to the system.

Delay Before Locking to Time Code Sets the amount of time (in frames) for Pro Tools to wait before attempting to lock to machines that issue servo lock messages. This setting allows time for the servo mechanisms to achieve stable lock.

Remote Mode (9-Pin Deck Emulation) Section

(Pro Tools HD Only)

Ignore Track Arming Sets Pro Tools to ignore incoming track arming (record enable) commands. This is useful if you are using a master controller to arm tracks on other machines, but you do not want to arm tracks in Pro Tools.

Set Servo Lock Bit at Play (Tamura Support) Enable this option when using a Tamura synchronizer to control Pro Tools in Remote mode to minimize lock-up times during recording.

Allow Track Arm Commands in Local Mode

Sets Pro Tools to respond to incoming track arming (record enable) commands even when the system is not in Remote Mode. This is useful if you are using a paddle device to control Pro Tools track arming or punching.

Punch In Frame Offset Sets an offset (in frames) to compensate for punch in timing advances or delays.

Punch Out Frame Offset Sets an offset (in frames) to compensate for punch out timing advances or delays.

Delay After Play Command Sets the amount of time (in frames) for Pro Tools to wait after receiving a Play command before starting the audio engine. This can prevent false starts when locking to synchronizers that are not fully supported by Pro Tools.

Synchronization Section

(Pro Tools HD)

Stable LTC Source When selected, this option suppresses the normal 1-second wait time before Pro Tools attempts to lock to incoming LTC. Enable this option when locking Pro Tools to a stable time code source (such as a non-linear tape machine or LTC generator) and not a linear tape machine.
Chapter 7: I/O Setup

The I/O Setup dialog provides tools to label, format, and map Pro Tools input, output, insert, or bus signal paths for each session.

A signal path is a logical grouping of multiple inputs, outputs or busses that has a single name and (channel) format. In Pro Tools, paths are similar to stems, known to the film and video industries (see “Stems and Stem Mixes” on page 77). The I/O Setup dialog lets you define and name paths according to the needs of each project.

With Pro Tools HD, the I/O Setup dialog provides a graphical representation of the signal routing for each connected audio interface, with controls to route physical ports to Pro Tools inputs and outputs. These controls mirror the routing controls found in the Hardware Setup dialog—changes made to physical routing in one dialog are always reflected in the other.

Each Pro Tools system can have a different I/O Setup configuration, determined by:

- Whether it is a Pro Tools LE, Pro Tools M-Powered, or Pro Tools|HD system
- On Pro Tools|HD systems, the number and types of audio interfaces
- On Pro Tools|HD systems, the Mixer plug-in currently installed (Stereo or Surround)

Each Pro Tools session retains its path configurations as I/O Settings. The I/O Settings saved with the session are loaded automatically when the session is opened. Unavailable items (including hardware, paths, or required resources) remain in the session as inactive items (see “Active and Inactive Paths” on page 86).

When you create a new session, you can specify a default I/O Setup configuration, including presets for stereo or multichannel mixing formats. Multichannel mixing requires a Pro Tools|HD system.

The I/O Setup dialog also lets you save and import I/O Settings files.

Navigating in the I/O Setup Dialog

To resize the I/O Setup dialog:

- Drag the lower-right corner of the window according to standard convention for your operating system (Windows or Mac).

To scroll up or down in the Disk Allocation dialog:

- Press Page Up or Page Down.

To scroll left or right in the I/O Setup dialog:

- Press Alt+Page Up/Down (Windows) or Option+Page Up/Down (Mac).
**Paths in Sessions**

In sessions, audio is routed using the track Input, Output, Insert, Plug-in, and Send selectors. These selectors let you assign tracks to hardware inputs and outputs, internal busses, and other Pro Tools signal paths.

Paths comprise the lists of available signal routing choices in track Input, Output, Insert and Send selectors.

**Paths and I/O Setup**

The signal routing choices available in a session are defined in the I/O Setup dialog.

**Main Paths and Sub-Paths**

Paths in the I/O Setup dialog include main paths and sub-paths.

**Main Paths**

Main paths are logical groupings of inputs, inserts, busses, or outputs. For example, a master stereo output path could be named Main Out. Path names in a stereo path are often appended with “.L” and “.R” for left and right.
Sub-Paths

A sub-path represents a signal path within a main path. For example, a default stereo output path consists of two mono sub-paths, left and right. Mono tracks and sends can be routed to either mono sub-path of the stereo output path.

It is especially useful to define and name sub-paths for complex mixing setups, such as a 5.1 Surround mix.

Default I/O Settings

A default I/O Settings file is installed automatically by Pro Tools, so you have a set of default paths that will get you started, without the need to configure the I/O Setup dialog. You can then customize your I/O Setup configuration at any time, according to the needs of each project (see “The I/O Setup Dialog” on page 78).

Default Settings Files

The default Stereo settings file is available on all Pro Tools systems, and provides stereo main paths, each with its own mono sub-paths.

Multichannel settings files are available on Pro Tools|HD systems. These settings provide specialized path definitions for surround mixing. See “Configuring Pro Tools for Multichannel Sessions” on page 700.

Default Path Names

Default names for input, output, and insert paths are based on the type of system (Pro Tools LE systems) or type and number of interfaces (Pro Tools|HD systems) you are using.

Stems and Stem Mixes

The use of stems and stem mixes originated in the post production industry as a method to organize and manage elements of a mix by type or content.

For example, a film mix often requires a stem mix for Foley, a stem mix for sound effects, a stem mix for dialog, and another for music. In this scenario, the dialog stem would contain all the dialog elements mixed relative to each other. The dialog stem can then be mixed with the other stems during the final mix of the scene or reel. The final mix is simplified by the ability to control the level of each stem, rather than the multitude of individual tracks that comprise a typical film mix.

In Pro Tools, you can work with main and sub-paths as you would stem mixes. These can be assigned as needed, including the ability to assign multiple outputs to individual tracks and sends. For more information, see “Multiple Output Assignments” on page 536.
The I/O Setup Dialog

The I/O Setup dialog defines Pro Tools input, output, insert, and bus paths. Routing I/O ports to Pro Tools inputs and outputs can also be done here.

To open the I/O Setup dialog:

1. Make sure your audio interfaces are enabled and configured properly in the Hardware Setup. See “Configuring Pro Tools Hardware Settings” on page 46.

2. Choose Setup > I/O.

To open the Input, Output, Insert, Bus, Mic Preamps, or H/W Insert Delay page in the I/O Setup dialog:

- Click the corresponding tab at the top of the I/O Setup dialog.

Closing the I/O Setup Dialog

You can click Cancel at any time to close the I/O Setup dialog. When you click OK, Pro Tools checks several settings for routing validity (to prevent feedback loops). If there are any overlapping or invalid settings, you will be required to correct them before the I/O Setup dialog will close. For more information, see “Initializing I/O Setup” on page 85.
I/O Setup Dialog Controls

This section provides an overview of the controls in the I/O Setup dialog.

Path Type Tabs Select the type of I/O control to configure. Choices are Input, Output, Insert, Bus, Mic Preamps, or H/W Insert Delay.

Input and Output Selectors Select the physical ports on your audio interface to route to Pro Tools inputs and outputs. Ports are selectable in channel pairs. Available ports for each displayed interface are based on Hardware Setup settings; for example, if the AES/EBU inputs and outputs of an interface are enabled in Hardware Setup, they are available for routing in I/O Setup. The functionality provided with the Input and Output selector is the same as that provided on the Main page of the Hardware Setup dialog.

Path Name Column Shows paths that are available for selection, including the name of each defined path. Path names can be renamed.

Expand/Collapse Shows or hides the sub-paths associated with a main path.

Active/Inactive Status Shows and changes the active/inactive status of each path.

Path Format Selector Shows and selects the type/format (such as Mono, Stereo, Quad, or 5.1) of each defined path.

Channel Grid Maps paths to specific interfaces and channels.

Compensation for Input and Output Delays Allows automatic compensation for input and output delays caused by Digidesign analog-to-digital and digital-to-analog hardware.

Path Tools Customize the I/O Setup configuration. Buttons include: New Path, New Sub-Path, Delete Path, and Default.

Routing Hardware I/O to Pro Tools I/O

The I/O Setup dialog lets you define which physical ports on your I/O peripheral are routed to available inputs and outputs in Pro Tools. Use the Input and Output selectors in the I/O Setup dialog to serve as a patchbay to route any of the physical inputs or outputs to your Pro Tools mixer.
To configure I/O routing in I/O Setup:

1. Choose Setup > I/O.
2. Click the Input or Output tab to display the corresponding path type.
3. Click the Input or Output selector for the first interface channel pair, located below the first audio interface icon.
4. From the pop-up menu, select a physical port pair (such as Analog 1–2), to route to a Pro Tools channel pair (such as A 1–2) in the Path Name column on the left.
5. Repeat the above step for additional channel pairs.
6. Click OK.

Routing a Pro Tools Output Pair to Multiple Destinations

Pro Tools channel pairs can be routed to multiple outputs on an audio interface through the I/O Setup dialog. For example, if you assign both Analog 1–2 and Analog 3–4 interface outputs to Pro Tools Output pair 1–2, when you send a signal to Pro Tools Outputs 1–2, that signal will be routed simultaneously to both pairs of output ports on your audio interface.

This lets you send the same signal (such as a stereo pair, a stem mix, or a multichannel mix) to multiple destinations (such as multiple mastering devices).

The only limit to output choices is the number of outputs available in your system.

Output path assignments cannot overlap. See “Valid Paths and Requirements” on page 86 for details.
Creating and Editing Paths

The I/O Setup dialog lets you create and customize signal path definitions.

Paths can be:

- Renamed, for easier identification after changing or renaming audio interfaces
- Remapped, to or from different sources or destinations
- Deactivated (or reactivated) to manage unavailable or unnecessary I/O resources
- Deleted

In addition, you can import and export your I/O Setup configurations as I/O Settings files, as well as set default path parameters.

The following table lists the available path attributes for each path type.

Path options by type

<table>
<thead>
<tr>
<th>Path Type</th>
<th>Path Options (Attributes)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Input</td>
<td>Names, formats, and source channel (analog or digital audio interface)</td>
</tr>
<tr>
<td>Output</td>
<td>Names, formats, and destination (audio interface output channel or internal send bus)</td>
</tr>
<tr>
<td>Insert</td>
<td>Names, formats and destination (audio interface channels)</td>
</tr>
<tr>
<td>Bus</td>
<td>Names and formats</td>
</tr>
</tbody>
</table>

Creating a Default Main or Sub-Path

You can set an I/O Setup path type to its default path configuration at any time.

To restore default paths and path names:

1. Choose Setup > I/O.
2. Click the Input, Output, Insert, or Bus tab to display the corresponding path type.
3. Click Default.

Pro Tools creates all possible stereo main paths. Mono sub-paths are also auto-created for every stereo main path. These default path names appear in a session’s track Audio Input and Output Path selectors.

To optimize Pro Tools DSP resources, it is best to create mono sub-paths for Outputs and Busses, rather than mono main paths.
Creating New Paths

You can create new main path and sub-paths with custom names, format, and mapping. Custom path names appear in a session’s track Input, Output, Insert, and Bus selectors.

To create a new path:

1. Choose Setup > I/O.

2. Click the Input, Output, Insert, or Bus tab to display the corresponding path type.

3. Do one of the following:
   - Click New Path, or press Control+N (Windows) or Command+N (Mac).
   - Select a main path and click New Sub-Path.

4. Double-click in the Name field and enter a name for the path.

5. Press Tab to set the new path name and move to the next path’s Name Field, or press Enter (Windows) or Return (Mac) to set the new path name.

6. Choose a format from the Path Format selector (mono, stereo, or multichannel).

7. Repeat the previous steps to configure other path types (Input, Output, Insert, or Bus).

8. Click OK to close the I/O Setup dialog. If there are any overlapping or identically named paths, you will be instructed to correct them before the I/O Setup dialog will close. For more information, see “Initializing I/O Setup” on page 85.

Changing Path Names

Path names can be customized in the I/O Setup dialog.

I/O paths can also be renamed directly from the Edit or Mix window by Right-clicking the Input or Output selector and choosing Rename.

To rename a path in the I/O Setup dialog:

1. Double-click the path name.

2. Enter a new path name.

3. Press Enter (Windows) or Return (Mac).

Changing Interface Names

Audio interface names can be customized in the I/O Setup dialog. With Pro Tools HD only, the I/O Setup dialog then bases default Input and Output path names on the custom names.

To rename an audio interface in the I/O Setup dialog:

1. Double-click the label above an interface.

2. Enter a new interface name.
3 Press Enter (Windows) or Return (Mac).

### Selecting and Arranging Paths

Individual and multiple paths can be selected in the I/O Setup dialog Path Name column. Selected paths and sub-paths can be moved higher or lower in the Path Name column to change their menu order in track Input, Output, Insert, and Bus selectors. Paths can also be deleted. Sub-paths follow their main paths when they are moved in the I/O Setup dialog.

**To select a main path or sub-path:**
- Click the path name.

**To select a range of paths:**

1. Click the path name.
2. Shift-click an additional path name.

All paths that occur between the first path name selected and the additional path name will also be selected.

**To select or deselect non-contiguous paths, do one of the following:**

- Control-click (Windows) or Command-click (Mac) path names that are unhighlighted to select them.
- or –
- Control-click (Windows) or Command-click (Mac) path names that are highlighted to deselect them.

**To select all paths and sub-paths:**
- Alt-click (Windows) or Option-click (Mac) any path name that is unhighlighted.

**To deselect all paths and sub-paths:**
- Alt-click (Windows) or Option-click (Mac) any path name that is highlighted.

**To rearrange paths:**
- Drag one or more path names up or down.

### Resetting to Default Paths

The Default button in the I/O Setup dialog provides two primary functions:

- Creates new default paths up to the capacity of your system’s available audio interfaces and resources. See “Creating a Default Main or Sub-Path” on page 81.
- Resets selected path names to matching or corresponding paths in the current I/O Setup configuration. For example, if you replace an audio interface on a Pro Tools|HD system, you can use the Default switch to update your I/O Setup definitions with the new hardware configuration.

Interface names can be customized. See “Changing Interface Names” on page 82.
To reset path names:

- Click Default.

If there are matching paths available with the new system configuration, existing paths will be updated to include new audio interfaces (Pro Tools|HD systems).

**Resetting Mix Busses**

*(Pro Tools HD Only)*

Pro Tools supports up to 128 mix busses *(Pro Tools HD 7.x and Pro Tools TDM 6.9), 64 mix busses (Pro Tools TDM 6.7.x and lower), or 32 busses (Pro Tools 7.x and 5.0.1 and lower).* When you open a session created with a lower version of Pro Tools, only the number of busses supported on the lower system are initially available. You can reset the number of available busses to match your system’s capabilities.

To make all of your busses available in sessions created with a lower version of Pro Tools:

1. Open the I/O Setup dialog.
2. Click the Bus tab in the upper left.
3. Click Default.

⚠️ Setting busses to the default setting will rename all busses to their default name.

**Deleting Paths**

Path definitions can be deleted from the current session to reflect changes to your hardware setup, or to clean up track selector menus by removing unwanted or unnecessary path definitions. After deleting a path, any tracks or send assignments to that path are reset to No Output.

To delete a main path or sub-path:

1. In the I/O Setup dialog, select the path you want to delete.
2. Click Delete Path.

**To delete all paths:**

1. Alt-click (Windows) or Option-click (Mac) any path name.
2. Click Delete Path.

**Channel Mapping**

Once a path has been created and formatted, it can be mapped to specific audio interface, or bus channels in the Grid.

To map channels:

1. Select a main or sub-path.
2. In the row for the selected path, click in the Grid column under an audio interface and channel. Other channels for the path type, if any, fill to the right.

![Mapping channels]

For example, when mapping a new stereo path, clicking in the path row under output channel 1 fills both channel 1 and 2 (left to 1, right to 2).

⚠️ To remap channels in a path, see “Remapping Channels” on page 85.
Channel Mapping and Surround Mixer
(Pro Tools HD Only)

When mapping multichannel paths, the left channel (L) is mapped first to the clicked Grid box, and remaining channels fill immediately to the right according to the default path order. Because some multichannel mixing formats use unique track layouts, Pro Tools lets you set the default format in the I/O Setup dialog (see “I/O Setup Options” on page 90).

Remapping Channels

You can move the individual assignments to different channels, to reorder the path’s definition (for example, changing a multichannel map to L-R-C-LF-LS-RS).

To remap channels in a path:

- Drag the channel to the new location in the Grid. Other channel assignments will move (shuffle) to accommodate dragged channels.

Channel Shuffling

Moving a signal from right to left results in a shuffle of other signals after the new destination channel. Moving a signal from left to right shuffles any and all signals after the new destination channel and leaves the previous channel empty.

⚠️ Changing a path’s format erases any current channel mapping.

Sub-Paths Follow Main Paths

When a main path is remapped, its sub-paths (if any) will remap automatically to maintain consistent routing. For example, remapping a stereo path to different hardware outputs results in any of its sub-paths moving with it.

Initializing I/O Setup

To set the current I/O Setup configuration:

- Click OK in the I/O Setup dialog.

All paths must be valid before the I/O Setup configuration can be applied.
Valid Paths and Requirements

While configuring the I/O Setup dialog, certain rules apply for path definition and channel mapping.

Though it is possible to set up invalid mappings in the Channel Grid, Pro Tools will not accept an I/O Setup configuration unless all paths meet the path definition and channel mapping requirements, as follows:

Minimum Path Definitions All paths must have a name, be of a specific format, and have a valid I/O mapping.

Overlapping Channels and Valid Paths Channel mapping follows certain rules regarding overlapping paths.

- There can be no partial or complete overlaps between any two main Output paths, any two Insert paths, or any two main Bus paths.
- A newly-created Output or Bus path must either be completely independent of other maps (not mapped to any other available I/O interface/channels), or it must be a sub-path completely contained within a larger path (for example, an LCR sub-path within a larger 5.1 path).
- Output and Insert paths can overlap in I/O Setup, but only one or the other can be used at any given time in a session. (Inputs, however, can be routed to multiple tracks.)

Active and Inactive Paths

Pro Tools paths can be Active (on) or Inactive (off, or unavailable). You can manually switch paths between Active or Inactive on a track-by-track or session-wide basis. In addition, Pro Tools sets paths to Inactive automatically when I/O is unavailable.

Track Path Assignments Track input, output, and bus path assignments can be switched to Inactive using the corresponding selector on the track. This leaves track playlists intact, while disconnecting that particular track from the output or bus path. Use this to remove a track from a signal path.

Session-Wide Path Assignments Paths can be globally activated or deactivated in the I/O Setup dialog. Use this to turn off a signal path on any and all tracks currently assigned to it. Pro Tools also sets unavailable paths to inactive. Paths can be unavailable when hardware or other system resources are unavailable, such as when opening a session saved on a different system.

Track Path Assignments (Mix and Edit Windows)

To toggle a track path assignment to be Active or Inactive:

- In the Mix or Edit window, Control-Start-click (Windows) or Command-Control-click (Mac) the track’s Input, Output, Insert, or Send selector.

Inactive track path assignments are listed in italics and are unhighlighted.

Toggling All or All Selected

The Alt (Windows) and Option (Mac) modifiers apply the path toggle to all tracks. The Alt+Shift (Windows) and Option+Shift (Mac) modifiers apply the path toggle to all selected tracks. However, Pro Tools will only apply the change to identical path assignments, if any, in the current track or tracks. Toggling multiple tracks only affects tracks that have the same path assignment as the one you are explicitly toggling.
**Toggling Multiple Paths**

If a track has only one main output assignment, you can Control-start-click (Windows) or Command-Control-click (Mac) the track’s Output Path selector to toggle the main output to inactive. When there are multiple assignments, the track selector will be displayed for you to specify the input, output, insert, or bus path.

If a Send (A–J) has multiple output assignments and one of those is toggled, then all of the output assignments for that Send (A–J) will be toggled.

**Session-Wide Path Assignments**

*(I/O Setup Dialog)*

Paths can be globally configured for Active or Inactive status in the I/O Setup Dialog.

**Display of Active and Inactive Status**

**Unhighlighted (Italics)** Indicates the path is inactive.

**Highlighted (Non-Italics)** Indicates the path is active.

**Highlighted (Italics)** Indicates the path is active, but there are not enough system resources available.

To globally activate or deactivate a path:

1. Choose Setup > I/O.
2. Select a path type using the tabs at the top of the window.
3. Set the Active/Inactive control for the path.

*Any track path assignment can also be deactivated on a track-by-track basis. See “Track Path Assignments” on page 86.*

Inactive paths are displayed in italics in the track path selectors.

**Hardware Setup and Session Transfer**

Pro Tools sessions store the type and order of audio interfaces connected and active when the session was last saved.

**Unavailable I/O**

When opening a session, Pro Tools checks to see if the hardware configuration has changed since the session was last saved. If the current hardware configuration differs from that saved in the session, paths associated with the unavailable I/O are made inactive.

**Remapping**

Remapping occurs when a session’s original I/O Setup does not match that of the current system and session paths are remapped to current hardware.
Systems of equivalent I/O capability are remapped directly. For example, a session tracked to a Pro Tools|HD system through two 192 I/O audio interfaces would include 32 input paths spread across the two 16-channel interfaces. The session is taken to a second Pro Tools system that has a 96 I/O audio interface (a 16-channel I/O unit) and a 1622 I/O (with its 16 analog inputs) connected to its Legacy Port. When the session is first opened on the second system, Pro Tools will map the 32 input paths to the inputs of the two interfaces.

When hardware is unavailable to a session being opened, assignments can either be replaced using the remap option, or opened as Inactive. Any tracks left assigned to an unavailable path will not be audible. This can be beneficial, however, when you want to reassign tracks into your system’s mix one at a time.

See “Active and Inactive Paths” on page 86 for more information.

Show Original Setup and Show Current Setup

When a session is opened that contains path definitions for unavailable I/O interfaces, the I/O Setup dialog lists those paths in italics.

The Show Original Setup button displays the audio interfaces used in the original session. This temporary display lets you check the original I/O configuration for reference while configuring the session for your system.

Once a session has been opened with unavailable I/O retained, you can then reassign tracks to available I/O paths.

See “Creating and Editing Paths” on page 81.

I/O Settings Files

I/O Settings can be managed when transferring sessions, and when developing I/O Setup configurations over the course of multiple sessions and projects.

Defaults, Settings Files, and Last Used Settings for New Sessions

When creating new sessions, you can set the session’s I/O Setup configuration using the following options:

Default I/O Setups The Pro Tools Installer provides factory presets for stereo and surround I/O Setups (surround mixing is only supported on Pro Tools|HD systems). See “Factory I/O Settings Files” on page 90 for more information.

Custom Presets You can store and recall custom presets using the export and import features of the I/O Setup dialog.

Last Used The most recent (or last used) I/O Setup configuration is saved as a Last Used settings file. See “Last Used I/O Settings” on page 89 for more information.

Default I/O Settings at First Launch

The first time you create a session, you can choose default Stereo Mix or Surround Mix settings, depending on your system and installation choices. See “Factory I/O Settings Files” on page 90.
Importing and Exporting I/O Settings Files

You can export and import I/O Setup configurations as I/O Settings files. This lets you save settings for different projects, import settings for reconfiguring I/O Setup, and manage path definitions and signal routing setups.

Exporting I/O Settings

To export and save an I/O Setup configuration:
1. Click Export Settings.
2. Name and save the settings file.

Importing I/O Settings

I/O Settings can be imported before you open a session, or you can import settings into a session that is already open (see “Default I/O Settings at First Launch” on page 88).

When you import I/O Settings in an existing session, you can choose to delete any unused path definitions before importing the new paths, or leave unused path definitions intact and add the new paths to the current I/O Setup configuration.

To import I/O Settings:
1. Click Import Settings in the I/O Setup dialog.
2. Select an I/O settings file in the Import Settings dialog and click Import.
3. A dialog appears asking whether you want to delete existing paths. Do one of the following:
   - Click Yes to remove any unused paths and add the imported paths to the current I/O Setup configuration. Any I/O assignments and automation data associated with the unused paths are also deleted.
   - or –
   - Click No to add the imported paths to the current I/O Setup configuration.

If the import results in overlapping paths, the new paths will appear in the I/O Setup dialog as Inactive. See “Active and Inactive Paths” on page 86.

After importing I/O Settings, you can then reassign path routing definitions in the I/O Setup dialog by remapping, renaming, and deleting paths. See “Creating and Editing Paths” on page 81.

Last Used I/O Settings

If any changes are made to the I/O Setup dialog during a session, these changes are saved to the Last Used settings file when the I/O Setup dialog is closed (by clicking OK).

Changes to I/O Setup are saved along with the current session. User Presets files will not contain recent changes unless you export an updated settings file.

The Last Used settings are available as a choice when creating or opening sessions, in addition to the factory presets described below.
Factory I/O Settings Files

Pro Tools provides I/O Settings files for Stereo and Surround mixing. These files provide generic main and sub-path definitions for either mixing format.

Stereo Mix Settings File

The Stereo Mix preset consists of all possible stereo and mono paths for your session.

Using the “Stereo Mix” preset has the same effect as clicking Default for every individual tab in I/O Settings. See “Creating and Editing Paths” on page 81 for details.

Specifically, the Stereo Mix preset will create the maximum number of paths of each type, as determined by the available system’s I/O Setup and hardware configuration.

Surround Mix Settings File (Pro Tools HD Only)

The Surround Mix provides additional, surround-specific Output and Bus presets. See “Surround Mix Settings Files” on page 701 for more information.

About Direct Outputs Mode

Direct Outputs mode, as found in older versions of Pro Tools, has been replaced by the default mono sub-paths available through all valid I/O in the I/O Setup dialog.

The Default switch creates main Output paths with appropriate mono sub-paths. These sub-paths provide discrete monophonic routing.

When a session is opened that was saved in Direct Outputs mode, Pro Tools maps all the output assignments to equivalent mono sub-paths (as available). See “Hardware Setup and Session Transfer” on page 87 for more information on remapping.

To convert a session so that it emulates Direct Outs mode, use the Auto Assign Ascending Outputs feature, as follows:

To auto assign track outputs for Direct Out:

1. Make sure that all tracks you want to assign are visible (hidden tracks will not be affected).
2. Select the tracks you want to assign.
3. Control-Alt-click (Windows) or Command-Option-click (Mac) the Output selector of the left-most track and assign it to the sub-path for Output #1. All visible tracks will be auto-assigned to unique mono sub-path outputs in ascending order.

You can identify audio interface connections at any time by selecting the interface name in the Peripherals list of the Hardware Setup dialog, then clicking Identify. All the LEDs on the interface front panel will illuminate.

I/O Setup Options

Pro Tools systems have additional I/O Setup features. These include default signal routing for metering and auditioning, and default track layout for multichannel mix formats.

Controller Meter Path

(D-Control, D-Command, and ProControl Only)

The Controller Meter Path selector determines the path displayed across the Output meters of D-Control, D-Command, or ProControl control surfaces. For more details, refer to your control surface documentation.
Audition Paths

You can specify the output path through which files and regions are auditioned in the Region List or in DigiBase browsers.

Using the Default Audition Path

When you audition a file or region in the Region List, Pro Tools routes the audio output through the Audition Path. Pro Tools assigns a default Audition Path to the first available main Output path of the corresponding format. You can also select a different Audition Path in the I/O Setup dialog.

Auditioning Discrete Signals in Multichannel Items

In the Region List, multichannel regions are auditioned through the current Audition Path. Signals can be auditioned “in-place,” or through all outputs, as described below.

Audition In-Place

When auditioning a mono component of a multichannel region, that mono component will by default be auditioned in-place. That is, it will play from the corresponding speaker channel of its parent multichannel region.

To audition in-place:

1. In the Region List, make sure the stereo or multichannel region is in expanded view (showing .L, .R, and other component channels).
2. Alt-click (Windows) or Option-click (Mac) the region for the channel you want to audition.

Audition to All Outputs

Mono regions can be routed equally to all outputs of the parent region’s Audition Path.

To audition through all channels of the main audition path:

- Shift-Alt-click (Windows) or Shift-Option-click (Mac) on the signal in the Region List.

On Pro Tools|HD systems with more than one audio interface, you can only select the first audio interface as an audition path.

Configuring Audition Paths

You can specify the monitoring outputs for Region List auditioning using the Audition Paths menu.

Audition Paths Main Menu

The main menu consists of all path format choices available on the current system (Mono and Stereo on all systems, and LCR and greater on Pro Tools|HD systems).

Audition Paths Submenus

Each path format choice has a submenu listing Output paths of that given format. (The mono submenu lists Output paths of any format.)

To configure an Audition Path:

- Select a path from the Audition Paths menu or submenus.

To audition regions in the Region List:

- Alt-click (Windows) or Option-click (Mac) the region in the list.
New Track Default Output Path

You can specify the default output path assignment for new tracks, in each available format.

The New Track Default Output can be set to bus paths, as well as output paths.

To specify a default output for new tracks in the I/O Setup dialog:

1. Click the New Track Default Output selector and select a format and Output.

AFL/PFL Path

(Pro Tools HD Only)

Tracks soloed in AFL (After Fader Listen) or PFL (Pre Fader Listen) Solo mode are routed to the current AFL/PFL Path, as set with the AFL/PFL Path selector.

See “Solo Modes” on page 119 for more information on using AFL or PFL Solo modes.

To select the AFL/PFL Path output:

1. Choose Setup > I/O.
2. Click the Output tab to display the Output page.
3. Select a path from the AFL/PFL Path selector.
4. Click OK to close the I/O Setup dialog.

Setting AFL or PFL Path Levels

You can set a separate master AFL/PFL Path level for all AFL solos and all PFL solos.

Tracks do not need to be soloed to have the master AFL/PFL Path level adjusted.

To set the AFL/PFL Path level for AFL or PFL solos:

1. Choose Options > Solo Mode, and select a Solo mode, as follows:
   • If you want to set the level for AFL solos, select AFL.
   – or –
   • If you want to set the level for PFL solos, select PFL.
2. In the Mix or Edit window, Control-click (Windows) or Command-click (Mac) a Solo button on any track.
3. Adjust the AFL/PFL Path fader.
4. Click on the new fader position (or press Esc) to close the fader display.

AFL/PFL Mutes (Output Path) Selector

(Systems without a D-Control or D-Command Control Surface)

If you are not using a D-Control or D-Command control surface, your regular Pro Tools output path can be muted when you send a signal to the AFL/PFL Path. The muted path is set with the AFL/PFL Mutes (Output Path) selector.

Selecting None as the AFL/PFL Path disables AFL and PFL Solo modes. When None is selected, AFL and PFL cannot be used.

To set the AFL/PFL Path level to 0 dB, Control-Start-click (Windows) or Control-Command-click (Mac) any Solo button.

See “Solo Modes” on page 119 for more information on selecting and using AFL or PFL Solo modes.
To set which output path is muted when tracks are soloed in AFL or PFL Solo mode:

1. Choose Setup > I/O.
2. Click the Output tab to display the Output page.
3. Select a path from the AFL/PFL Mutes (Output Path) selector.
4. Click OK to close the I/O Setup dialog.

**Default Path Order**  
(Pro Tools HD Only)

The Default Path Order selector lets you select the default track layout you want Pro Tools to follow when creating and mapping 5.1-format main or sub-paths in the I/O Setup dialog.

This setting does not affect existing path definitions or metering—it only specifies channel mapping in new 5.1-format paths.

To choose a Default Path Order:

- Select the channel mapping from the Default Path Order menu.

**H/W Insert Delay Compensation**  
(Pro Tools HD Only)

You can specify the latency of outboard hardware (such as effects devices) in the H/W Insert Delay page of the I/O Setup dialog. You can enter hardware insert latency, in milliseconds, in a field that corresponds to every input/output pair. These times will be used by the Delay Compensation Engine to time align input paths when a hardware insert is used.

To set an insert delay offset:

- Enter a value, in milliseconds, in the field corresponding with the input where the hardware insert is connected.

⚠️ Insert delay offsets only have an effect when the I/O is used for hardware inserts.

---

For more information about multichannel mixing, see Chapter 31, “Pro Tools Setup for Surround (Pro Tools HD Only).”
Chapter 8: Tracks

This chapter covers basic track management tasks such as creating and deleting tracks, assigning voices and output channels, and grouping tracks.

Track Types

In a Pro Tools session, you can have several different types of tracks. These can include audio tracks, Auxiliary Input tracks, Master Fader tracks, VCA Master tracks, MIDI tracks, Instrument tracks, and video tracks.

Audio Tracks, Auxiliary Input Tracks, Master Fader Tracks, and VCA Master Tracks

Pro Tools provides mono, stereo, and multi-channel format audio tracks, Auxiliary Input tracks, Master Fader tracks, and VCA Master tracks.

Audio Tracks

Audio tracks contain arrangements of recorded (or imported) audio files.

Auxiliary Input Tracks

Auxiliary Input tracks (or Auxiliary Inputs) can be used as effects sends, destinations for submixes, as a bounce destination, as inputs to monitor or process audio (such as audio from MIDI sources), and for many other audio routing tasks.

Master Fader Tracks

Master Fader tracks (or Master Faders) control the overall level of the audio tracks that are routed to the session’s main output paths. For example, you could have 24 tracks in a session with channels 1–8 routed to Analog Output 1–2, channels 9–16 to Analog Output 3–4, and channels 17–24 to Analog Output 5–6. You could then create three master faders, one to control each of these output pairs.

Master Fader tracks have additional uses (such as controlling submix levels). For more information, see “Master Fader Tracks” on page 526.
VCA Master Tracks
(Pro Tools HD Only)

VCA Master tracks (or VCA Masters) emulate the operation of voltage-controlled amplifier channels on analog consoles, where a VCA channel fader would be used to control, group, or offset the signal levels of other channels on the console.

VCA Master tracks do not pass audio, so they do not have inputs, outputs, inserts or sends. A Mix Group is assigned to a VCA Master track, which appears in the VCA track’s Assignment selector. The controls of the tracks in that Mix Group, called the slave tracks, are modified by the controls on the VCA Master.

For more information, see “VCA Master Tracks” on page 528.

MIDI Tracks

MIDI tracks store MIDI note, instrument, and controller data. You cannot select a track format when you create a MIDI track, because audio does not pass through it.

Instrument Tracks

Instrument tracks are a special type of track that provide MIDI and audio capabilities in a single channel strip. Instrument tracks simplify using software and hardware instruments to record MIDI and monitor audio from the instrument.

Track Formats

Mono Tracks

A mono audio, Auxiliary Input, Master Fader, or Instrument track controls volume, and, in some cases, panning, for a single channel of audio. A mono audio track uses a single voice.

Stereo Tracks

A stereo audio, Auxiliary Input, Master Fader, or Instrument track is a single channel strip that plays two channels of audio as a stereo pair. Stereo audio tracks use two voices.

Multichannel Tracks (Pro Tools HD Only)

A multichannel track is a single channel strip that plays multiple channels of audio (from 3–8 channels at a time). This allows Pro Tools to support multichannel mixing formats including LCRS, 5.1, 6.1, and others. Audio, Auxiliary Input, Master Fader, and Instrument tracks can all use any supported multichannel format.

For more information on surround mixing with Pro Tools, see the following chapters:

• Chapter 31, “Pro Tools Setup for Surround (Pro Tools HD Only)”
• Chapter 32, “Multichannel Tracks and Signal Routing (Pro Tools HD Only)”
• Chapter 33, “Surround Panning and Mixing (Pro Tools HD Only)”
Track Channel Strips

Audio Track Channel Strips

Each audio track has its own set of controls for volume, pan, record enable, input monitoring, automation mode, solo, mute, and voice assignment. Audio tracks also have a Comments View to enter and display comments.

Mono audio track channel strip

Auxiliary Input Track Channel Strips

Each Auxiliary Input track has its own set of controls for volume, pan, automation mode, solo, and mute. Auxiliary Input tracks also have a Comments View to enter and display comments.

Stereo Auxiliary Input track channel strip
**Master Fader Track Channel Strips**

Each Master Fader track has its own set of controls for volume and automation mode. Master Fader tracks also have a Comments View to enter and display comments.

![Stereo Master Fader track channel strip](image)

**VCA Master Track Channel Strips**

(Pro Tools HD Only)

Each VCA Master track has its own set of controls for volume, record enable, input monitoring, automation mode, solo, and mute. VCA Master tracks also have a Comments View to enter and display comments.

For more information, see “VCA Master Tracks” on page 528.
MIDI Track Channel Strips

Each MIDI track has its own set of controls for volume, pan, record enable, automation mode, solo, mute, MIDI patch assignment, and MIDI channel assignment. MIDI tracks also have a Comments View to enter and display comments.

Instrument Track Channel Strips

Each Instrument track has its own set of controls for volume, pan, record enable, automation mode, solo, and mute. Instrument tracks have an additional Instruments View that provides controls for MIDI input, output, mute, volume, and pan. Instrument tracks also have a Comments View to enter and display comments.
Track Controls and Indicators

Input/Output Selectors
The I/O View shows Input and Output selectors on audio, Auxiliary Input, Master Fader (output only), MIDI, and Instrument tracks.

Volume/Peak/Channel Delay Indicator
The Volume indicator on an audio track has three display modes: Volume, Peak, and Channel Delay.

To toggle the Volume indicator display:
- Control-click (Windows) or Command-click (Mac) the indicator to toggle it between the following modes:

Volume Indicator (and Pop-Up Slider) Shows the current volume, or input level of a track as set by the track Volume fader. In I/O View (Edit window), click the Volume indicator to display the Volume pop-up slider, which can be used to adjust the volume.

Peak Indicator Functions as a headroom indicator based on the last peak playback level. To reset the peak counter, click anywhere in the meter. Values range from \(-\infty\) (no signal) to 0 dB.

Channel Delay Indicator Shows the total delay, in samples, incurred on the track from the use of any TDM plug-ins on that channel.

Pan Indicator
The Pan indicator displays the current pan setting of a track. Pan values range from \(<100\) (full left) to \(100>\) (full right). Pan controls are only available for stereo tracks or for mono tracks routed to a stereo output.

In I/O View (Edit window), click the Pan indicator to display the Pan pop-up slider, which can be used to adjust panning.

Pan Slider
The Pan slider controls the balance of a track between the assigned output pair. It only appears if you are using stereo tracks or mono tracks routed to a stereo output.

The Pan slider on a MIDI track is effective only if you are controlling a sound module that supports MIDI panning.

Send Pan controls can be linked to the Main Pan controls of a track by enabling the Follow Main Pan button in Send window.
**Volume Fader**

The Volume fader controls the volume of a track when it is in playback, and the monitor level of the track when it is in record. You can link the record and monitor levels by enabling the Operation preference for “Link Record and Play Faders.”

The maximum fader gain for a volume fader is +12 dB.

**MIDI Volume Fader**

If your MIDI sound module supports volume, the volume fader on a MIDI or Instrument track can send a value of 0–127 to the MIDI volume controller.

**Track Level Meter**

On audio tracks, Level meters indicate the level of the signal being recorded or played back from the hard drive. On Auxiliary Input, Master Fader, and Instrument tracks, Level meters indicate the level of the signal being played through the channel output. Green indicates nominal levels; Yellow indicates pre-clipping (~6 dB below full scale); and Red indicates clipping. When an audio track is record-enabled, these meters indicate record levels.

On MIDI tracks, the level meter shows the MIDI velocity of the most recent MIDI event.

**Pre- and Post-Fader Metering**

You can globally set audio track level meters to indicate pre- or post-fader levels. When pre-fader metering is selected, the level meters show levels independent of fader position. With post-fader metering, the level meters respond to fader position.

To toggle track level metering between pre-fader and post-fader metering:

- Select Options > Pre-Fader Metering.

**Peak Hold**

Pro Tools meters provide a Peak Hold feature with three options: 3 Second, Infinite, or None.

To choose a Peak Hold setting:

1. Choose Setup > Preferences and click the Display tab.
2. Select a Peak Hold option.
3. Click OK.

To clear a meter:

- Click anywhere on the meter.

To clear all meters, do one of the following:

- Alt-click (Windows) or Option-click (Mac) any meter.
- Choose Track > Clear All Clip Indicators.
- Press Alt+C (Windows) or Option+C (Mac).

**Clip Indication**

Pro Tools meters provide Clip Indication with three options: 3 Second, Infinite, or None. If clipping occurs, the topmost LED will stay lit (red).

Clip indicators appear in plug-in, send, and track windows.

To choose a Clip Indication setting:

1. Choose Setup > Preferences and click the Display tab.
2. Select a Clip Indication option.
3. Click OK.
To clear a clip indicator:
■ Click anywhere on the meter.

To clear all clip indicators, do one of the following:
■ Alt-click (Windows) or Option-click (Mac) any meter.
■ Choose Track > Clear All Clip Indicators.
■ Press Alt+C (Windows) or Option+C (Mac).

Wide Meters View
Wide Meters View expands the width of the level meters for tracks in both the Mix and Edit windows, to make the track level meters easier to read. Wide Meters View also supports Narrow Mix View.

To enable Wide Meters View:
■ Control-Start-Alt-click (Windows) or Command-Option-Control-click (Mac) the track level meters in either the Mix or Edit window.

To disable Wide Meters View:
■ Control-Start-Alt-click (Windows) or Command-Option-Control-click (Mac) the track level meters a second time in either the Mix or the Edit window.

Adjusting Track Width
Mix Window
The Narrow Mix command lets you view all tracks/channels in the Mix window at a reduced width to conserve screen space in a large session. (See “Track Height” on page 258, to adjust track height in the Edit Window.)

To reduce the width of tracks in the Mix window:
■ Select View > Narrow Mix.

To display tracks at normal width:
■ Deselect View > Narrow Mix.

You can toggle track width by pressing Control+Alt+M (Windows) or Command+Option+M (Mac).

Creating Tracks
On all systems, you can create mono and stereo tracks. In addition, with Pro Tools HD, you can create multichannel tracks.

When new tracks are created, they are given a default name which can be changed at any time.

◆ To insert new tracks next to a specific track in a session, select that track by clicking the track’s name in the Mix or Edit window before opening the New Tracks dialog. The new tracks are added immediately after the selected track.

◆ To insert new tracks after the last tracks in a session, make sure that no track names are selected on-screen before opening the New Tracks dialog.

You can also add tracks to your session by importing them from preexisting sessions. See “Importing Tracks and Track Attributes” on page 144.
To create new tracks:

1. Choose Track > New.

2. Select the type of track you want to add from the Track Type pop-up menu.

3. Select the track format (mono, stereo, or one of the multichannel surround formats) from the Track Format pop-up menu. Surround formats are available on Pro Tools|HD systems only.

4. Select the timebase (samples or ticks) from the Track Timebase pop-up menu.

5. Enter the number of new tracks.

6. Do the following, if desired:
   - To add more tracks, click the Add Row button.
   - To remove the previous track, click the Remove Row button.

7. To reorder tracks, click a Move Row icon and drag it up or down.

8. Click Create.

Naming Tracks

Track names are used to auto-name recorded audio files and regions (see “Default Track Names” on page 186).

To rename a track:

1. Do one of the following:
   - In the Mix or Edit window, double-click the Track Name button for the track you want to rename.
   - In the Track List, or Mix or Edit window, Right-click the track name for the track you want to rename.

2. In the Track Name/Comments dialog, type a new track name.
3 Click Previous or Next to rename other displayed tracks.

To move to the previous or next track in the Track Name/Comments dialog, you can press Control (Windows) or Command (Mac) and use the Up/Down or Left/Right Arrows.

4 Click OK.

**Adding Comments to Tracks**

To enter comments for a track, do one of the following:

- From the track channel strip, click directly in the Comments area, type any comments for the track, and press Enter (Windows) or Return (Mac).

  – or –

- In the Edit or Mix window, double-click the Track Name button for a track. Then click directly in the Comments area, type any comments for the track, and press Enter (Windows) or Return (Mac).

To enter a carriage return in the Comments area, press Shift+Enter (Windows) or Shift+Return (Mac) on the QWERTY keyboard.

**Track Numbering**

With Track Number View enabled, each track is assigned a number corresponding to its position in the Mix and Edit Windows. When tracks are reordered, they are renumbered to maintain positional sequence.

**To enable Track Number View:**

- Choose View > Track Number.

**To navigate directly to any track number:**

1 Do one of the following:

   - Choose Track > Scroll to Track.

   – or –

   - Press Control+Alt+G (Windows) or Command+Option+G (Mac).

**Scroll To Track dialog**

2 In the Scroll To Track dialog, enter the Track Position Number.

3 Click OK.

The track is selected, and the windows scroll as follows:

- The Mix window tracks scroll to bring the selected track as close to the left as possible.
- The Edit window tracks scroll to bring the selected track as close to the top as possible.

**Selecting Tracks**

Tracks need to be selected for operations such as duplicating tracks or adding tracks to a group. One or more tracks can be selected at a time.

**To select a track:**

- Click the name of an unhighlighted track in its track channel strip.

**To select a range of tracks:**

1 Click the name of an unhighlighted track in its track channel strip.

2 Shift-click an additional Track Name button.
All tracks between the first track selected and the additional track will also be selected.

**To select or deselect non-contiguous tracks, do one of the following:**

- Control-click (Windows) or Command-click (Mac) Track Name buttons that are unhighlighted to select them.
- or -
- Control-click (Windows) or Command-click (Mac) Track Name buttons that are highlighted to deselect them.

**To select all tracks:**

- Alt-click (Windows) or Option-click (Mac) any Track Name button that is unhighlighted.

**To deselect all tracks:**

- Alt-click (Windows) or Option-click (Mac) any Track Name button that is highlighted.

### Selecting Tracks when Making Edit Selections

Pro Tools lets you link Track selection with Edit selections. When Track and Edit selections are linked, you can make a selection within a track or across multiple tracks for editing and each associated track is selected (track names automatically highlight).

**To link Track and Edit selections:**

- Select Options > Link Track and Edit Selection.

### Scrolling a Track into View

*(Pro Tools HD Only)*

**To scroll a track into view:**

- In the Track List, or Mix or Edit window, Right-click the track name and select Scroll into View.

The track is selected, and the windows scroll as follows:

- The Mix window tracks scroll to bring the selected track as close to the left as possible.
- The Edit window tracks scroll to bring the selected track as close to the top as possible.

### Deleting Tracks

When you delete tracks, your audio or MIDI region data will remain in the Region List, but your arrangement of the regions on the deleted track (the track’s playlist) will be lost.

If the track contains playlists that are not assigned to any track, you will be prompted to delete or retain them.

*The Delete Track command cannot be undone.*

**To delete a track:**

1. Click the name of the track in its track channel strip to select it.

   - or -

   **To select multiple tracks, Control-click (Windows) or Command-click (Mac) additional Track Names.**

   **To select a range of tracks, Shift-click additional Track Names.**

2. Do one of the following:

   - Choose Track > Delete.
   - or -
   
   - In the Track List, or Mix or Edit window, Right-click the track name and select Duplicate.

3. Click OK to remove the selected tracks from the session.
Duplicating Tracks

The Duplicate Track command lets you duplicate one or more tracks, including their audio or MIDI data, playlists, automation, and other attributes.

When duplicating multiple tracks, you can also choose to have the new tracks follow the last selected track (or have each new track follow its source track).

To duplicate one or more tracks:

1. Select the tracks you want to duplicate.

For information, see “Selecting Tracks” on page 104.

2. Do one of the following:
   - Choose Track > Duplicate.
   - Press Alt+Shift+D (Windows) or Option+Shift+D (Mac).
   - Right-click the name of the track in the Track List, or Mix or Edit window, and select Duplicate.

3. In the Duplicate Tracks dialog, configure the following options as needed:
   - Enter how many copies you want to create by typing into the Number of Duplicates field.
   - To copy the currently active (visible) Edit playlist from the source track, enable Active Playlist.
   - To copy all Edit playlists on the source track, enable Alternate Playlists.
   - To copy all automation from the source track, enable Automation.
   - To copy all plug-in and insert assignments, enable Inserts.
   - To copy all sends and send assignments, enable Sends.
   - To maintain all Mix and Edit Group assignments, enable Group Assignments.

4. If duplicating multiple tracks, do one of the following:
   - If you want all the newly created tracks to follow the last selected source track (to the far-right of the Mix window, and at the bottom of the Edit window), enable the Insert after Last Selected Track option.
   - or –
   - If you want each newly-created track to be inserted directly after its source track, disable the option.

5. Click OK to duplicate tracks according to the settings in the Duplicate Tracks dialog. Click Cancel to close the dialog and not create duplicate tracks.

In the Mix window, each duplicate track is created to the right of its original track. In the Edit window, each duplicate track is created below its original track.
The Track List

The Track List (at the left of both the Mix and Edit windows) lists all tracks in the session. It allows you to show or hide a track in the Mix and Edit windows, by selecting or deselecting its name. Even though a track is hidden, the material on the track will still play as part of the session. Inactive tracks appear in italics in the Track List.

The Track List can also be used to create new tracks while importing media from DigiBase. See the DigiBase Guide.

Show/Hide Track List/Group List View Button

To show (or hide) the Track List (and Group List):

- Click the Show/Hide Track List/Group List View button in the Mix or Edit window.

Track List Pop-Up Menu

The pop-up menu at the top of the Track List provides commands that allow you to show or hide all tracks, tracks currently selected on-screen, or specific types of tracks (audio, Auxiliary Input, Master Fader, MIDI, or Instrument).
The Sort Tracks By command allows you to set the track order according to Name, Type, Edit Group, Mix Group or Voice. The sort order will be reflected in the Track List in the Mix or Edit Window.

When a track that is a member of an active group is hidden from view, editing operations performed on other members of the group in the Edit window will not affect the hidden track. In the Mix window, however, all operations other than record-enable will affect a hidden track that is a member of an active group.

With Pro Tools HD, even if a track is hidden from view, its position relative to other tracks still affects its voiceable track playback priority (see “Voice Borrowing” on page 115 for details).

To show a track that is currently hidden, do one of the following:
- Click the unhighlighted name of the track in the Track List.
- In the Track List, or Mix or Edit window, Right-click the track name and select Show (or Show and Make Active if the track is active and you also want to make it active).

To show all tracks:
- Click the Track List pop-up menu and choose Show All Tracks.

You can also show all tracks by Alt-clicking (Windows) or Option-clicking (Mac) the name of any track that is unhighlighted.

To hide all tracks:
- Click the Track List pop-up menu and choose Hide All Tracks.

You can also hide all tracks by Alt-clicking (Windows) or Option-clicking (Mac) the name of any track that is highlighted, or by clicking on a track symbol to the left of any highlighted track name.

To reorder tracks on-screen, drag the track names to new positions within the Track List or in the Mix or Edit window.

To show a range of tracks:
1. Click the name of an unhighlighted track name in the Track List.
2. Shift-click an additional track name.
All track names that occur between the first track name selected and the additional track name will also be selected.

Tip: You can also select a range of tracks by moving the cursor to the left of the track names, so the Marquee appears, and dragging around the track names you want to select.

To show or hide a range of tracks in the Track List with the Marquee:

1. Press and hold Control (Windows) or Command (Mac).
2. Move the cursor to the left of a track name until the Marquee with a small “+” symbol appears.
   - To show tracks, the Marquee should be to the left of an unhighlighted track name.
   - To hide tracks, the Marquee should be to the left of a highlighted track name.
3. Click on the track name and drag up or down (to show or hide the track and the tracks immediately above or below it).

To show or hide non-contiguous tracks, do one of the following:

- Click track names that are unhighlighted to select them.
  - or -
- Click track names that are highlighted to deselect them.

About Mix/Edit Groups and Hidden Tracks

Even if a track is hidden, if it is a member of an enabled group, all Mix window operations performed on other members of the group will also affect the hidden track—with the exception of audio or MIDI record-enabling. If you solo, mute, or automation write-enable a grouped track, any group members that are hidden will be soloed, muted, or automation write-enabled as well.

In the Edit window, however, editing operations performed on members of an enabled group will not affect hidden tracks that are also members of the enabled group.

About Clipping and the Track List

(Pro Tools HD Only)

When a track, send, or plug-in clips, the Track List displays the track’s name in red. Both shown and hidden tracks display clipping indication.

About Track Numbering and Hidden Tracks

There are two ways to display Track Position Numbers when tracks are hidden.

- Numbers are only assigned to tracks that are shown (when Track Position Numbers Stay with Hidden Tracks is not enabled in the Display Preferences page). In this case, active tracks are then numbered sequentially. Hidden tracks are un-numbered.
  - or -
- Tracks keep their Track Position Numbers even when hidden (when Track Position Numbers Stay With Hidden Tracks is enabled in the Display Preferences page).
Track Name Right-Click Pop-Up Menus

(Edit Window, Mix Window or Track List)

When you Right-click a track name in the Edit window, Mix window, or the Track List, a pop-up menu provides access to the following commands:

- **Hide/Show** Hides (or shows) the track (or selected tracks if any)
- **Hide and Make Inactive** Hides the track and makes it inactive (or selected tracks if any)
- **Make Active/Inactive** Toggles the active status of the track (or selected tracks if any)
- **Scroll Into View** Scrolls the track to the top of the Edit window or the left of the Mix window
- **Locked (Video Track Only)** Toggles the locked/unlocked status of the video track (or selected video tracks if any)
- **Rename** Opens the Track Name dialog
- **Duplicate** Duplicates the track (or selected tracks if any)
- **Delete** Deletes the track (or selected tracks if any)
- **Coalesce VCA Master Automation** Coalesces the VCA automation to the slave tracks of the VCA
- **Coalesce Trim Automation** Coalesces Trim automation on the track (or selected tracks if any)
- **Clear Trim Automation** Clears Trim automation on the track (or selected tracks if any)
- **Split Into Mono (Multichannel Tracks Only)** Splits a multichannel track (or selected multichannel tracks if any) into their mono component tracks

Assigning Inputs and Outputs to Tracks

Inputs for audio tracks and Auxiliary Input tracks can be assigned to audio interface channels or busses. Outputs for audio tracks, Auxiliary Input tracks, and Master Fader tracks can be assigned to audio interface channels or busses.

For stereo and multichannel surround tracks, inputs and outputs appear as stereo pairs and multichannel groups. The available inputs, outputs, and busses are defined as paths in the I/O Setup dialog (see Chapter 7, “I/O Setup”).

### Automatic Input and Output Assignments

When adding tracks to a new session, inputs are automatically assigned in ascending order. For example, if you have an audio interface with eight inputs, creating four new mono audio tracks will automatically add four audio tracks with inputs assigned to the first four paths defined in the I/O Setup dialog. When creating stereo tracks, inputs are automatically assigned to ascending input pairs.

The outputs automatically assigned to new tracks are determined by the New Track Default Output defined in the I/O Setup dialog.
Assigning Audio Track Inputs
(Audio Tracks, Auxiliary Inputs, Instrument Tracks)

⚠️ Instrument tracks set their input automatically to any inserted Instrument plug-in.

To assign an audio track input:
1. In order to assign audio track inputs in the Edit window, select View > Edit Window > I/O.
2. In the Mix or Edit window, click the track’s Input Path selector and choose from the available audio interface channels and busses. Stereo and multichannel surround tracks have inputs available as pairs and multichannel groups.

The Input Path selector allows you to route any audio input or any of the Pro Tools internal busses to an audio track or an Auxiliary Input track. The choices available in this pop-up menu are determined by the I/O Setup configuration. Inputs in use by another track appear as bold in the selector.

To remove an input assignment:
- Select No Input from the Input Path selector.

Assigning Audio Track Outputs
(Audio Tracks, Auxiliary Inputs, Instrument Tracks, Master Faders)

To assign an audio track output:
1. In order to assign audio track outputs in the Edit window, select View > Edit Window > I/O.
2. In the Mix or Edit window, click the track’s Output Path selector and choose from the available audio interface channels and busses. Stereo and multichannel surround tracks have outputs available as pairs and multichannel paths.

The Output Path selector lets you route a track to any configured audio output or internal bus. The choices available in this pop-up menu are determined by the I/O Setup configuration. Outputs in use by another track appear as bold in the selector.

To auto-assign all visible tracks to unique mono sub-path outputs in ascending order:
1. Make sure you have enough mono sub-paths defined in I/O Setup (see Chapter 7, “I/O Setup”).
2. Control-Alt-click (Windows) or Command-Option-click (Mac) the Output Path selector of the left-most track and assign it to the sub-path for Output #1. All visible tracks will be auto-assigned to unique mono sub-path outputs in ascending order.
To remove an output assignment:
- Select No Output from the Output Path selector. Playlists become dimmed for tracks with no output assignment.

⚠ Assigning an audio track, Auxiliary Input, Master Fader, or Instrument track to “No Output” will cause its automation data for pan and plug-in controls to be lost.

Renaming Track Inputs and Outputs from the Edit or Mix Window

I/O path names can be renamed in the Edit or Mix windows, or in the I/O Setup dialog.

To rename an I/O path in the Edit or Mix window:
1. In the Edit or Mix window, Right-click the Input selector or Output selector for a track, and choose Rename from the pop-up menu.
2. In the Rename I/O dialog, enter a name for the I/O Path, and click OK.

Making Track Inputs and Outputs Inactive from the Edit or Mix Window

Inputs and outputs can be made inactive. Making a track input or output inactive silences the input or output, while retaining all automation and playlist data. Inactive inputs and outputs do not consume resources for TDM mixer connections, but any assigned plug-ins on the track continue to use their required DSP resources. RTAS plug-ins require CPU resources, and TDM plug-ins use the DSP available on Pro Tools|HD cards.

You can make track inputs and outputs inactive (or active) directly from the Edit or Mix windows. Inactive I/O paths are grayed out.

To make a track input or output inactive (or active) using the I/O’s selector pop-up menu:
- In the Edit or Mix window, Right-click the Input selector or Output selector for a track, and choose Make Inactive (or Make Active) from the pop-up menu.

To toggle an input or output active/inactive:
- Control-Start-click (Windows) or Command-Control-click (Mac) the Input or Output selector in the Mix or Edit window.

Track Priority and Voice Assignment

Pro Tools LE systems provide up to 32 voices of simultaneous audio playback and recording, depending on the system. For details on LE system capabilities, see Table 5 on page 10.

Pro Tools HD provides a certain number of voices (simultaneous channels of audio playback and recording), depending on the system. For example, a Pro Tools|HD 1 system can provide up to 96 voices of audio playback and recording, at 44.1 or 48 kHz. For details on Pro Tools system capabilities, see Table 3 on page 7.

Pro Tools LE systems with the DV Toolkit 2 option and Pro Tools LE or M-Powered systems with the Music Production Toolkit option let you play or record up to 48 simultaneous stereo or mono tracks. For details on system capabilities with these options, see “Pro Tools LE with DV Toolkit 2 and Pro Tools LE or M-Powered with Music Production Toolkit” on page 11.
Track Priority

While your Pro Tools hardware allows a fixed number of voices, Pro Tools software allows for additional audio tracks beyond that fixed number of voices. While all of these tracks can be recorded to or imported, arranged, and cued for playback, not all of them can be played back simultaneously.

When the number of tracks exceeds the number of available voices, tracks with lower priority may not be heard. For these situations, Pro Tools assigns priorities to tracks that compete for the available voices. Because there can be more tracks than available voices, Pro Tools provides multiple ways of adjusting the playback priority of audio tracks. See “Changing a Track’s Playback Priority” on page 113 and “Freeing up Voices on a Track” on page 113.

With Pro Tools HD, you can also assign specific voices to multiple tracks so that those voices are shared by more than one track. This feature is called voice borrowing. The combination of playback/record tracks and shared voiced tracks comprises the total number of voiceable tracks on a Pro Tools|HD system.

To set multiple tracks to the same voice, see “Setting Voice Assignment” on page 114. For additional information on voice borrowing, see “Voice Borrowing” on page 115.

Changing a Track’s Playback Priority

Tracks with higher positions (leftmost in the Mix window or topmost in the Edit window) have priority over tracks in lower positions in a session.

To increase a track’s priority, do any of the following:

- In the Mix window, drag the Track Name button to the left of other tracks in the session. Tracks at the left of the Mix window have higher priority than those on the right.
- In the Edit window, drag the Track Name button above other tracks in the session. Tracks at the top of the Edit window have higher priority than those below.
- In the Track List, drag the Track Name button to a higher position in the list. Tracks at the top of this list have higher priority than those below.

Freeing up Voices on a Track

You can also adjust the relative priority of tracks by freeing up the voices of individual tracks, making them available to other tracks in the session.

To free up the voice of a track, do one of the following:

- Click the Voice selector of the track and set it to Off. See “Setting Voice Assignment” on page 114.
- Deactivate the track by Control-Start-clicking (Windows) or Command-Control-clicking (Mac) its track type icon in the Mix window.
- Make sure the track does not have an output or send assignment.
- With Pro Tools HD, you can temporarily free a track’s voice during playback by muting it (see “Mute Frees Assigned Voice” on page 122).
Setting Voice Assignment

A track’s voice assignment can be turned off or set to be dynamically allocated, and with Pro Tools HD, can also be assigned to a specific voice number.

On all Pro Tools systems, you can use Dynamically Allocated Voicing to automatically take care of voice management in the background, assigning voices not in use by other tracks.

Pro Tools LE supports Dynamically Allocated Voicing only; it does not support individual voice assignments.

With Pro Tools HD, tracks assigned to a specific voice number take priority over dynamically allocated tracks and support voice borrowing (see “Voice Borrowing” on page 115). To ensure a track is heard, or that it is available for QuickPunch, TrackPunch, or DestructivePunch recording, assign a voice number to that track.

With Pro Tools HD, QuickPunch, TrackPunch, and DestructivePunch require additional voices. For more information, see Chapter 14, “Advanced Recording.”

With Pro Tools HD, the initial insert of an RTAS plug-in uses additional voices in certain situations. See “Voice Usage and Total Latency for RTAS Plug-ins” on page 561.

For stereo and multichannel tracks, voices appear in pairs and multichannel groups. Voices already assigned to another track appear in bold in the Voice selector pop-up menu.

To set the voice assignment for a track:

- Click the Voice selector and set the track to Dyn, Off, or select a voice number (Pro Tools HD only).

Voice selector for stereo audio track (Pro Tools HD shown)

Voice Assignment with Toolkit Options

(Pro Tools LE with DV Toolkit 2 or Pro Tools LE or M-Powered Music Production Toolkit)

Pro Tools LE systems with the DV Toolkit 2 option and Pro Tools LE or M-Powered systems with the Music Production Toolkit option let you play or record up to 48 simultaneous stereo or mono tracks. Higher track counts are only supported with multiple hard drives and faster Digidesign-qualified systems.

The first 48 audio tracks that are active and have their voice assignment set to DYN (Dynamically Allocated Voicing) play back. Tracks which occur after these 48 tracks do not play back and cannot be recorded on. Their Dynamically Allocated Voicing button will be blue to indicate they are unavailable for playback or record.

Tracks do not play back when they are inactive or their voice assignment is set to Off.
When working with more than 48 audio tracks, you can play back audio in tracks 49 and higher by changing the higher track’s priority, as follows:

- Make a lower track inactive (click the Track Name and select Track > Make Inactive).
- Set the voice assignment in a lower track to Off (click the Voice selector and select Off).
- Drag the Track Name button of the higher track to the left (Mix window) or upwards (in the Edit window or Track List) until it is one of the first 48 audio tracks. The previous 48th audio track will become the 49th audio track and its voice assignment will change to Off.

If the original track 49 (or higher) had its voice assignment set to Off, it will automatically be reset to DYN when you do any of the above steps.

**Automatic Assignment of Ascending Voices**

(Pro Tools HD Only)

You can automatically assign all tracks or all selected tracks to successive voices. For example, you may want to select eight audio tracks and reassign them to voices 9–16.

**To assign all audio tracks to successive voices:**

1. While pressing Control+Alt (Windows) or Command+Option (Mac), select the starting voice number from the Voice selector for the left (Mix window) or top (Edit window) selected track.

The voice is assigned to the starting track, with successive voices assigned to currently selected tracks (with the same format) of lower priority.

**Voice Borrowing**

(Pro Tools HD Only)

Pro Tools HD features voice borrowing, which lets you assign more than one track to the same voice. The track with the highest priority takes over that voice, but when a hole opens up in the higher-priority track, its shared voice is temporarily available, and the track with the next highest priority “pops through” and begins to play. When the original track returns, the track that had popped through relinquishes the shared voice to the higher priority track.

**To assign all selected audio tracks to successive voices:**

1. Select the audio tracks by Control-clicking (Windows) or Command-clicking (Mac) their names.

   - To select multiple tracks, Control-click (Windows) or Command-click (Mac) additional Track Names.

   - To select a range of tracks, Shift-click additional Track Names.

2. While pressing Control+Alt+Shift (Windows) or Command+Option+Shift (Mac), select the starting voice number from the Voice selector for the left (Mix window) or top (Edit window) selected track.

The voice is assigned to the starting track, with successive voices assigned to currently selected tracks (with the same format) of lower priority.
The following example demonstrates the concept of voice borrowing:

In the above illustration, the two visible tracks are assigned to the same voice. There is an open area in the top track where no region appears. At this point, the voice is free since it is not being used, and the next highest priority track assigned to that voice (the bottom track) pops through the open area and plays.

By experimenting with track priority, voice assignment, and arranging regions so that they are positioned to “pop through” holes in higher priority tracks, you can find many useful ways to maximize voiceable tracks with Pro Tools HD.

### Setting MIDI Input and Output

MIDI is supported on MIDI tracks and Instrument tracks.

#### Assigning MIDI Track Input

Pro Tools lets you assign specific MIDI ports and channels to a MIDI track input. The default selection of All receives all incoming MIDI data from all ports on all channels. Use the MIDI Input selector to specify a MIDI port and channel for input.

For information on assigning MIDI input to Instrument tracks, see “Assigning MIDI Input and Output for Instrument Tracks” on page 117.

**To assign a MIDI track input:**

- Click the track’s MIDI Input selector and assign a port and channel for MIDI input. Channels already assigned to another track appear in bold.

   In the Edit window, select View > Edit Window > I/O to access any track’s Input selector.
Assigning MIDI Track Output

Pro Tools lets you assign specific MIDI ports and channels to a MIDI track output. The default selection of none sends MIDI data to no port on any channel. Use the MIDI Output selector to specify a MIDI port and channel for output.

⚠️ MIDI tracks in Pro Tools cannot contain multiple channels of MIDI data.

To assign a MIDI track (and all its regions) to a specific MIDI device channel:
- Click the track’s MIDI Output selector and assign a port and channel for MIDI output. Channels already assigned to another track appear in bold.

To assign multiple destinations to a single MIDI track:
- Right-click (Windows) or Control-click (Mac) the MIDI Output selector and select additional channels from any device.

For information on assigning MIDI output to Instrument tracks, see “Assigning MIDI Input and Output for Instrument Tracks” on page 117.

Assigning MIDI Input and Output for Instrument Tracks

Instrument tracks have a specific view for MIDI controls, including MIDI Input and Output selectors.

To view Instrument track MIDI controls, do one of the following:
- Select View > Mix Window > Instruments.
  - or –
- Select View > Edit Window > Instruments.

In the Edit window, select View > Edit Window > I/O to access any track’s Output selector.
**Instrument Track MIDI Input**

Pro Tools lets you assign specific MIDI ports and channels to an Instrument tracks’ MIDI input. The default selection of All receives all incoming MIDI data from all ports on all channels. Use the MIDI Input selector to specify a MIDI port and channel for input.

Channels in use by another track input appear as bold in the MIDI Input Selector pop-up menu.

**To assign an Instrument track MIDI input:**

- Click the track’s MIDI Input selector and assign a port and channel for MIDI input. Channels already assigned to another track appear in bold.

**Instrument Track MIDI Output**

Pro Tools lets you assign specific MIDI ports and channels to an Instrument tracks’ MIDI output. The default selection of none sends MIDI data to no device, port, or node on any channel. Use the MIDI Output selector to specify a MIDI port and channel for output.

Channels in use by another track input appear as bold in the MIDI Input Selector pop-up menu.

**To assign an Instrument track MIDI output:**

- Click the track’s MIDI Output selector and assign a port and channel for MIDI output. Channels already assigned to another track appear in bold.

---

**Inserting Instrument Plug-ins on Instrument Tracks**

To insert an instrument plug-in on an Instrument track:

- Click the Insert Selector on the Instrument track and select the instrument plug-in that you want to use.

A MIDI node (virtual MIDI port) is automatically created and assigned the track’s MIDI output.

---

**Soloing and Muting Tracks**

The Solo and Mute buttons can be engaged at any time during playback. The Solo and Mute buttons affect MIDI as well as audio tracks. It is possible to have more than one track soloed or muted at the same time in a session.

Instrument tracks have separate sets of Solo and Mute buttons for MIDI and audio monitoring.
Track grouping also affects mute and solo behavior. Muting or soloing a track that is a member of an active Mix Group will mute or solo all other tracks that are a member of that active Mix Group as well.

For information on creating and modifying groups for track soloing and muting, see “Grouping Tracks” on page 126.

Solo Button

The Solo button normally mutes other tracks so that the chosen track can be auditioned alone.

With Pro Tools HD, this behavior is selected as a Solo mode, called “Solo In Place.” Additional Solo modes are provided to change how the Solo button works. See “Solo Modes” on page 119.

To solo tracks:

1. Click the Solo button on a track. The button is highlighted and all other tracks are muted.
2. Click the Solo button on another track. The buttons for both tracks are highlighted and all other tracks are muted.

To un-solo tracks:

- Click the Solo button on soloed tracks.

Solo Modes

(Pro Tools HD Only)

With Pro Tools HD, the Solo button can be used to:

- Mute other tracks so that the chosen track can be auditioned alone.
- or -
- Route a chosen track to a separate output.

Solo button behavior is defined by the Solo mode, as follows:

SIP (Solo In Place) The Solo button mutes other tracks. When this mode is enabled, tracks can be solo safed (see “Solo Safe Mode” on page 121).

AFL (After Fader Listen) The Solo button routes the track’s post-fader/post-pan signal to the AFL/PFL Path output. The AFL/PFL Path is configured in the Output page of the I/O Setup dialog (see “AFL/PFL Path” on page 92).

With AFL, the level you hear is dependent on the fader level for that track. Additionally, there is a separate master level setting for AFL that affects the output of any or all tracks you solo in AFL mode (see “AFL/PFL Path” on page 92). This level setting is independent of the PFL level setting.

AFL and PFL Solo modes require the Surround Mixer plug-in (see the Pro Tools|HD Getting Started Guide).

PFL (Pre Fader Listen) The Solo button routes the track’s pre-fader/pre-pan signal to the AFL/PFL Path output. The AFL/PFL Path is configured in the Output page of the I/O Setup dialog (see “AFL/PFL Path” on page 92).

With PFL, the fader level and pan are ignored, and the level you hear is dependent on the signal’s recorded level. Additionally, there is a separate master level setting for PFL that affects the output of any or all tracks you solo in PFL mode (see “AFL/PFL Path” on page 92). This level setting is independent of the AFL level setting.

AFL and PFL Solo modes require the Surround Mixer plug-in.

If Mutes Frees Assigned Voice is enabled, muted tracks will not be audible in PFL mode.
To select a Solo mode:

1. Choose Options > Solo Mode, and select SIP, AFL, or PFL.

The Solo mode for all soloed tracks can be changed “on-the-fly” from any Solo mode to either SIP or AFL. Previously soloed tracks will switch their solo behavior to the new mode.

Switching the Solo mode for all soloed tracks “on-the-fly” to PFL will clear all previously soloed tracks before entering PFL mode. This will prevent potentially large boosts in level.

**DSP Usage when Using AFL or PFL Mode**

AFL and PFL are accomplished by Pro Tools creating a “behind the scenes” mixer to route the signal to the chosen AFL/PFL Path. Depending on the size of your main mixer, Pro Tools will devote a substantial portion of its available DSP when using AFL/PFL mode.

Un-declaring the AFL/PFL Path will free up all DSP resources previously used for AFL/PFL mode.

**Using AFL/PFL on Pro Tools Systems with a D-Control or D-Command**

AFL/PFL is optimized for Pro Tools systems using a D-Control or D-Command control surface, where the XMON automatically switches its monitor source between the main output and the AFL/PFL output from Pro Tools.

**Solo Latch Options**

Solos can be latched (where pressing subsequent buttons adds them to the soloed mix of tracks), unlatched, or temporarily latched (Pro Tools HD only).

**Using AFL/PFL on Pro Tools Systems without D-Control or D-Command**

If you are not using a D-Control or D-Command control surface, your regular Pro Tools output path is not necessarily muted when you send a signal to the AFL/PFL Path. If you need the main signal to automatically mute when an AFL/PFL signal is invoked, you need to do the following:

1. Configure the output path for AFL or PFL soloed tracks.

2. Select the main output path that will mute when you solo a track in AFL or PFL mode (see “AFL/PFL Mutes (Output Path) Selector” on page 92).

3. Set up your hardware to monitor both the main and AFL/PFL paths simultaneously.

When AFL or PFL is selected as a Solo mode and a track is soloed, the main output path will mute and the AFL/PFL signal will appear at the AFL/PFL Path for monitoring.

For more information on using XMON and AFL/PFL, see your control surface guide.
**X–OR (Cancels Previous Solos)** When selected, pressing subsequent Solo buttons cancels previous solos.

![Tip] To override X–OR mode and solo more than one track at a time, press and hold the Solo button on the first track. Subsequently pressed Solo buttons will latch.

**Momentary (Pro Tools HD Only)** When selected, Solo buttons are not sticky. A track is soloed only when its Solo switch is held down.

With a Digidesign-qualified control surface, additional tracks can be soloed by pressing their Solo switches (as long as at least one Solo button is held down). When no Solo switch is held down, all soloed tracks will unsolo.

**Using Momentary Solo Latch (Pro Tools HD Only)**

To temporarily latch solos:
1. Choose Options > Solo Mode > Momentary.
2. Press and hold the Solo button on the first track that will be soloed.
3. While still holding the first Solo button, press additional Solo buttons. Solo buttons will remain soloed as long as one Solo button is held.

![Tip] As long as at least one Solo button is held down, all the solos will remain latched.

**Solo Safe Mode**

Pro Tools lets you solo safe a track. This prevents the track from being muted even if you solo other tracks. This feature is useful for tracks such as Auxiliary Inputs that are being used as a sub-mix of audio tracks, or effects returns, allowing the audio or effects track to remain in a mix even when other tracks are soloed. It is also useful to solo safe MIDI tracks so that their playback is not affected when you solo audio tracks.

![Warning] AFL or PFL soloed tracks (Pro Tools HD only) cannot be solo safed.

**To solo safe a track:**
- Control-click (Windows) or Command-click (Mac) the Solo button on the track. This prevents the track from being muted even if you solo other tracks. The Solo button changes to a transparent color in Solo Safe mode.

**To return a solo safe track to normal:**
- Control-click (Windows) or Command-click (Mac) the Solo button on the track again.

**Mute Button**

The Mute button silences a chosen track. More than one track can be muted at one time. If Options > Mute Frees Assigned Voice (Pro Tools HD only) is enabled, muting a track will allocate its voice to the next highest priority voiceable track (assigned to the same voice).

**To mute a track:**
- Click the Mute button on the track. The track is grayed-out and muted.

**To unmute a track:**
- Click the Mute button again.
Mute Frees Assigned Voice
(Pro Tools HD Only)

Selecting Options > Mute Frees Assigned Voice and muting a track disables playback of that track, and surrenders control of its voice to the next highest priority track with the same voice assignment.

⚠️ Muting a track with Mute Frees Assigned Voice enabled does not free up the voice for QuickPunch, TrackPunch, or Destructive-Punch recording.

With this option enabled, there may be a delay (ranging in length from one to several seconds depending on the processing power of your system) between the time you mute or unmute a track and when you hear the effect on playback.

⚠️ Larger DAE Playback Buffer Sizes can also increase the lag time between the time you click the Mute button and the onset of muting. See “DAE Playback Buffer Size” on page 45.

Making Tracks Inactive

Audio, Auxiliary Input, Master Fader, VCA Master, and Instrument tracks can be made inactive. Inactive tracks use no DSP or voices. Plug-ins, sends, voices, and automation on inactive tracks are all disabled. Tracks may also be automatically made inactive if a session is opened on a system with less DSP power than the system that it was created on.

⚠️ MIDI tracks cannot be made inactive.

To toggle a track active/inactive:
- Control-Start-click (Windows) or Command-Control-click (Mac) the Track Type indicator in the Mix window.

To make one or more tracks inactive:

1. Click the name of the track (in its track channel strip) to select it.

   ⚠️ To select multiple tracks, Control-click (Windows) or Command-click (Mac) additional Track Names.

   To select a range of tracks, Shift-click additional Track Names.

2. Choose Track > Make Inactive.
Color Coding for Tracks, Regions, Markers and Groups

Separate colors can be assigned to audio and MIDI regions, tracks, markers, and groups.

Regions shown in Waveform and Block Views in the Edit window are drawn in color. Tracks shown in the Track List, Group List, and Mix and Edit windows have associated color bars.

Color Bars

Color coding at the track level is displayed using color bars, as follows:

Mix Window Track colors are displayed in horizontal color bars that appear above each channel strip, and below the track name.

Edit Window Track colors are displayed in vertical color bars that appear to the left of each track.

Track List Track colors are displayed in vertical color bars that appear to the left of each track name.

Group List Track colors are displayed in vertical color bars that appear to the left of each Group Name.

Default colors are automatically assigned to tracks, but you can override those colors by choosing from a color palette of 96 possible colors. For more information, see “Color Palette” on page 124.

Display Page Preferences for Color Coding

Color Coding options determine how colors are assigned to the display of tracks and regions.

To change Color Coding options:

1. Choose Setup > Preferences.
2. Click Display.
3. Select a Default Track Color Coding option.
4. Select a Default Region Color Coding option.
5. Select or deselect the Always Display Marker Colors option.
6. Click OK.

Always Display Marker Colors

This setting lets you choose to view Marker colors in the Markers ruler, regardless of the settings you choose for Default Region Color Coding.

Default Track Color Coding

The Default Track Color Coding options determine how colors are assigned to the display of tracks.

Default Region Color Coding options

None Turns off default color assignment for tracks.

Tracks and MIDI Channels Assigns a color to each track in the Mix or Edit window according to its voice assignment or MIDI channel assignment.

Tracks and MIDI Devices Assigns a color to each track in the Mix or Edit window according to its voice assignment or MIDI device assignment.
Groups Assigns a color to each track according to its Mix or Edit Group ID. If groups are suspended using the Suspend Groups command, the tracks color bars are not shown.

Track Type Assigns a color to each track according to its type (audio, Auxiliary Input, Instrument, MIDI, or Master Fader).

Default Region Color Coding

The Default Region Color Coding options determine how colors are assigned to the display of regions.

- None: Turns off default color assignment for regions. Regions are drawn as black waveforms or black MIDI notes on a light gray background.
- Tracks and MIDI Channels: Assigns a color to each region in the Edit window according to its voice or MIDI channel assignment.
- Tracks and MIDI Devices: Assigns a color to each region in the Edit window according to its voice assignment or MIDI device assignment.
- Groups: Assigns a color to each region according to the Group ID of its track. If groups are suspended (using the Suspend Groups command) all regions display black waveforms or MIDI notes on a light gray background.
- Track Color: Assigns a region color based on the color assigned to the track. (See “Color Palette” on page 124.)

Marker Locations Assigns a color to data across all tracks based on the nearest preceding marker.

Region List Color Assigns a color to each region based on its color in the Region List. When this Default Region Color Coding option is enabled, the assigned region color is maintained even if the region is placed in a track set to a different color coding.

Enabling any Default Region Color Coding option other than Region List Color will override Region List Color and reassign the parent track color to copies of the region placed in tracks. Copies of the region in the Region List will retain their unique color, if any.

Color Palette

The Color Palette lets you make color selections for tracks, regions, groups and markers.

The Color Palette supports independent region color coding in the Region List and in tracks.

To apply a color from the Color Palette:

1. Choose Window > Color Palette.
2 Do one of the following:
- In the Apply to Selected pop-up menu, select the destination for color coding: Tracks, Marker, Group, Regions in Tracks, or Regions in Region List.
- or –
- Select a track, marker, group, track region, or Region List region in the appropriate Pro Tools window. The Apply to Selected menu will display the type of item you have selected.

If selecting a marker does not display the Marker option in the Apply to Selected pop-up menu, then the Always Display Marker Colors option in the Display Preferences page is deselected. See “Always Display Marker Colors” on page 123 for more information.

3 Select a color from the palette, or select one of the following:

**Default** Removes any custom coloring and restores the color to the default color orientation. See “Display Page Preferences for Color Coding” on page 123 for more information.

**None** Turns off color assignment. Affected regions are drawn with black waveform or MIDI notes on light gray background. Affected tracks and groups no longer show their color bars.

---

### Using the Hold Button

The Color Palette provides a Hold button to simplify the process of assigning the same colors to multiple items (such as track and regions).

By default, the Hold button is off. When off, the Color Palette automatically highlights the assigned color (if any) of items as you select them.

When the Hold button is enabled, the assigned color selected in the Color Palette persists and does not change when a different track or region is selected.

### To use the Hold button to assign the same color to multiple items:

1. Click the Hold button to enable it. The Hold button becomes white, and the currently selected color is now highlighted with a wider white outline.
2. Select additional tracks or regions to which you want to assign the same color. Because the Hold button is enabled, the Color Palette does not follow item selection; it remains (or “holds”) at the last currently assigned color.
3. Click the assigned color again to assign it to the new selection of tracks or regions. Use the Apply to Selected popup menu to determine which selected elements are affected.
4. To turn off Hold and return the Color Palette to its default mode, click the Hold button until it turns off.
**Grouping Tracks**

Pro Tools provides a relative grouping function for linking tracks and their controls.

Groups are useful for editing several tracks in exactly the same way, or for mixing several tracks (such as a pair of stereo tracks or a submix) while keeping them at the same relative volume level.

Pro Tools provides the following grouping features:

- Up to 104 different groups are available, arranged in 4 banks of 26 Group IDs.
- Groups can be nested (subgroups within groups).
- Grouped faders or controllers preserve their levels relative to each other.
- Groups are assignable to an available VCA Master track.

You can also group regions into region groups. See “Region Groups” on page 362.

---

**Mix Groups, Edit Groups, and Mix/Edit Groups**

Pro Tools includes the following types of groups for affecting track controls and items:

Mix Groups can be set to affect the following parameters on tracks in the Mix or Edit window:

- Main Volume
- Main Mute
- Main Pan
- Main LFE Level
- Record Enable
- Input Monitoring
- Solo
- Automation Mode
- Send Level
- Send Mute
- Send Pan
- Send LFE Level
- Plug-in Controls
- Plug-in Bypass

When the Main Pan attribute is enabled for groups, grouped behavior applies to the Link, Front inverse, Rear inverse and Front/Rear inverse controls in stereo and multichannel panner windows.

**Edit Groups**

Edit Groups affect the following items in the Edit window:

- Track View
- Track Height
- Track Timebase
- Editing functions
Mix/Edit Groups

Mix/Edit Groups link the grouping functions of the Mix Group and the Edit Group.

Grouping Limitations

Grouping does not affect these parameters:
- Voice assignment
- Output assignment
- Inserting plug-ins

Selectable Group Attributes

You can select which parameters, or attributes, are linked in groups by the following methods:
- By making the group an Edit Group, a Mix Group, or both (Mix/Edit Group)
- With Mix and Mix/Edit Groups, by selecting from a list of attributes for the group
- With Mix Groups, by choosing whether the selected attributes apply globally to all groups or to individual groups

Linking Mix and Edit Groupings

The “Link Mix and Edit Group Enables” option links group enabling between the Mix and Edit windows.

To unlink Mix and Edit Groups:
1. Choose Setup > Preferences and click the Mixing tab.
2. Deselect the “Link Mix and Edit Group Enables” option and click OK.

Mix Groups and VCA Masters

An existing Mix Group can be assigned to a VCA Master, or a new Mix Group can be assigned to a VCA Master while it is being created. Only one group can be assigned to a VCA Master at a time. A VCA Master cannot control a group that includes itself.

For information on assigning groups to VCA Masters, see “Assigning Groups to VCA Masters” on page 530.

Group Controls

Menus and commands for creating and modifying groups are accessible in the following:
- Group List
- Group name in the Group List
- Group ID indicator on a track
- Track > Group menu

The Group List

The Pro Tools track grouping functions are located at the left side of the Mix or Edit window in the Group List. This scrolling window contains the names of all the groups in your session, as well as a pop-up menu for accessing grouping commands. From this menu, you can select and enable groups.

By default, every session has a group named All, which includes every track in the session. The All group cannot be edited or deleted.
Show/Hide Track List/Group List View Button

To show the Group List (and Track List):
■ Click the Show/Hide Track List/Group List View button in the Mix or Edit window.

Group Symbols

To the left of each Group ID ("a" through "z") is a symbol indicating whether that group is selected in the current window (either the Mix or Edit window). There are three types of Group symbols, as shown in the following figure:

Filled-in Circle Indicates that all members of the group are currently selected, and no members from outside the group are selected.
Hollow Circle Indicates that only some members of the group are currently selected.
Circle with a Dot Indicates that all members of the group are currently selected, plus additional members outside the group.

Group List Pop-Up Menu

The pop-up menu at the top of the Group List provides the following commands:

New Group Executes Track > Group command
Display Provides commands to show Edit groups only, Mix groups only, or all groups (Edit, Mix, and Mix/Edit)
Suspend All Groups Suspends group behavior for all Mix and Edit groups
Modify Groups Opens Group dialog to modify existing groups only
**Delete Active Groups** Deletes only currently active groups

**Group List pop-up menu**

**Group Name and Track Group ID Indicator Pop-Up Menus**

When you click and hold on a group name in the Group List, or click a Group ID indicator in a track, a pop-up menu provides the following commands:

- **Tracks** Displays track membership in group
- **Attributes** Displays attributes of group
- **Modify** Opens Group dialog to modify existing groups only
- **Duplicate** Opens Group dialog for duplicated group
- **Delete** Deletes a single group
- **Select Tracks in Group** Selects tracks in the group
- **Show/Hide Tracks in Group** Shows or hides tracks in the current group
- **Show Only Tracks in Group** Shows only the tracks in the group and hides all other tracks
- **Show All Tracks** Shows all tracks in the session

**Group Dialog**

Whether you are creating or modifying groups with the Group List, a track's Group ID indicator, or the Track > Group menu command, you will be using the Groups dialog.

The Group dialog lets you create new groups and assign attributes to groups.
The Group dialog has three pages:

**Tracks** Lets you add and remove tracks from the current group

**Attributes** Lets you select which parameters are linked for the current Mix or Mix/Edit Group

**Globals** Lets you select parameters to use as a template that can be applied to individual groups by selecting Follow Globals

---

**Working with Groups**

**Creating Groups**

You can select the tracks you want to add to a group before creating it, as well as add and remove tracks from a group after it has been created.

⚠️ *In previous versions of Pro Tools, to add or remove tracks from a group, you had to select tracks and overwrite the group.*

**To create a group:**

1. Select the tracks you want to include in the group. (If you do not select tracks at this time, you can add tracks later.)

2. Do one of the following:
   - Choose Track > Group.
   - or –
   - Choose New Group from the Group List pop-up menu.

3. Enter a name for the group.

4. Select the type of group to create: Edit Group, Mix Group, or Mix/Edit Group.

5. Choose a Group ID from the ID pop-up menu. Four banks of 26 are available: a–z, 2a–z, 3a–z, 4a–z. (If you do not choose a Group ID, Pro Tools automatically assigns the next available ID to a new group.)

6. Click Tracks in the Group dialog, and do any of the following:
   - To add the tracks that are currently selected in the session to the group, click the Add button at the bottom of the Group dialog.
   - To add tracks to the group, select the track names in the Available track list, and click Add or press A on the computer keyboard.
   - To remove tracks from the group, select the track names in the Currently In Group list, and click Remove or press R on the computer keyboard.
   - Double-click track names in either list to move them to the opposite column.
   - To replace all tracks in the group with the tracks that are currently selected in the session, click the Replace button at the bottom of the Group dialog.
If the group is a Mix Group or a Mix/Edit Group, set the attributes for the group. See “Setting Group Attributes” on page 133.

If the group is a Mix Group or a Mix/Edit Group and you want to assign the group to an available VCA Master track, choose the VCA track from the VCA pop-up menu.

Click OK.

Modifying Groups

To modify a group:

1. Do one of the following:
   - Choose Modify Groups from the Group List pop-up menu.
   - In the Mix window, click the Group ID indicator on a track and choose Modify from the pop-up menu.
   - Right-click the Group name in the Group List and choose Modify from the pop-up menu.

2. In the Groups dialog, choose the group you want to modify from the ID pop-up menu.

3. Change any of the following for the current group:
   - Group name
   - Group type (Edit, Mix or Mix/Edit)
   - VCA status
   - Follows Global status
   - Track membership
   - Attributes

4. Click OK.

Selecting track names to add to a group

In either list, Shift-click to select a range of track names. Control-click (Windows) or Command-click (Mac) to select discontiguous track names.

7. If the group is a Mix Group or a Mix/Edit Group, set the attributes for the group. See “Setting Group Attributes” on page 133.

8. If the group is a Mix Group or a Mix/Edit Group and you want to assign the group to an available VCA Master track, choose the VCA track from the VCA pop-up menu.

9. Click OK.

Choosing a VCA track to control a group
To modify the settings for the “All” group:

1. Right-click the “All” group name in the Group List and choose Modify from the pop-up menu.

2. In the Group dialog, select Edit, Mix, or Mix/Edit to change the settings for the ALL group. If you select Edit only or Mix only, the ALL group will apply only to that Group type.

3. For Mix or Mix/Edit Groups, you can change any of the following:
   - Follows Global status
   - Attributes

4. Click OK.

Deleting Groups

You can delete groups in several ways.

- Deleting a group is not undoable.

To delete a single group, do one of the following:

- In the Mix window, click the Group ID indicator on a track and choose Delete from the pop-up menu.
- or –
- Right-click the Group name in the Group List and choose Delete from the pop-up menu.

To delete all currently active groups:

- Choose Delete Active Groups from the Group List pop-up menu.

Duplicating Groups

You can duplicate a group and modify its settings in order to quickly set up a mix.

To duplicate a group:

1. Do one of the following:
   - Click the Group ID indicator on a track and choose Duplicate from the pop-up menu.
   - or –
   - Right-click the Group name in the Group List and choose Duplicate from the pop-up menu.
Chapter 8: Tracks

2 Change any of the following for the current group:
   • Group name
   • Group type (Edit, Mix, or Mix/Edit)
   • VCA status
   • Follows Global status
   • Track membership
   • Attributes

3 Click OK.

Setting Group Attributes

When creating a Mix Group or a Mix/Edit Group, you can select the Mix window parameters that will be linked for that group. These linked parameters are the attributes of the group.

You can select attributes in the Globals page and then set individual groups to follow the Global settings, or you can select attributes for groups individually.

To select attributes in the Global page:

1 While creating or modifying a group, click Globals in the Group dialog.

2 Select the base set of attributes for groups in your session.

3 Click OK to save the group and the new Globals settings.

For information on selecting attributes, see “Selecting Group Attributes” on page 134.

Globals page of Group dialog

To select attributes for an individual group:

1 While creating or modifying a Mix Group or a Mix/Edit Group, do one of the following:
   • Click Attributes in the Group dialog, and select the attributes you want to link.
   – or –
   • Click Follow Globals to follow the base set of attributes. The Attributes page greys out to indicate that the group is following the selections in the Globals page.

For information on selecting attributes, see “Selecting Group Attributes” on page 134.
2 Click OK to save the settings.

Selecting Group Attributes

The following attributes can be selected for Global settings and for individual groups:

Track controls:
- Main Volume
- Main Mute
- Main Pan
- Main LFE Level
- Record Enable
- Input Monitoring
- Solo
- Automation Mode

Send controls (Sends A–J):
- Send Level
- Send Mute
- Send Pan
- Send LFE Level

Insert controls (Inserts A–E):
- Plug-in Controls
- Insert Bypass

To select the attributes for a group, do any of the following:
- Select individual attributes by clicking their checkboxes.
- To select or deselect all attributes, Alt-Shift-click (Windows) or Option-Shift-click (Mac) any attribute.
- To select or deselect all attributes for a single Send or Insert (across a row), Start-click (Windows) or Control-click (Mac) any attribute in that row.
- To select or deselect attributes for a single control across all Sends, all Inserts, or for the four track controls (down a column), Alt-click (Windows) or Option-click (Mac) any attribute in that column.

Saving Group Attribute Presets

You can define six Group presets that can be recalled on either the Attributes or Globals page whenever you are creating or modifying a Mix or Mix/Edit Group.

To save the current attribute settings as a Group preset:

1 In the Groups dialog, click Save. (Follow Globals must be unchecked to save a setting from the Attributes page.)
2 Choose one of the six preset locations from the Location pop-up menu, and click Save.

To recall a Group preset:
- Click the corresponding Preset button (1–6) in the Groups dialog. (Follow Globals must be unchecked to recall a setting in the Attributes page.)

To enable a group:
- In the Group List, click the name of the group you want to enable. The Group Name is highlighted to indicate that it is enabled.

To enable additional groups, click their names in the Group List.

Moving a fader of a group member will cause all other group members to move relative to it. If a fader belongs to multiple groups, and the groups conflict when faders are moved, the fader will follow the topmost or “parent” group that it belongs to.

To disable a group:
- In the Group List, click the name of the group you want to disable. The Group Name is unhighlighted to indicate that it is not enabled.

Keyboard Selection of Groups

The Group List Keyboard Focus allows you to type a Group ID letter to automatically toggle that group’s enable status.
- In the Mix window, the Group List Keyboard Focus is always enabled.
- In the Edit window, you need to enable the Group List Keyboard Focus to use it.

To enable the Edit Group List Keyboard Focus, do one of the following:
- Click the Keyboard Focus button in upper right of the Edit Group List.
  - or -
- Press Control+Alt+3 (Windows) or Command+Option+3 (Mac).

To save the current attribute settings directly to a preset location, Control-click (Windows) or Command-click (Mac) the preset button.
To enable and disable groups using the Edit and Mix Group List Keyboard Focus:

- With Group List Keyboard Focus enabled, type the Group ID letter (a–z) to automatically enable or disable the corresponding group.

Temporarily Isolating Control of an Item from Group Operation

You can temporarily isolate control of a group item from group operation by Right-clicking on the item.

You can also temporarily suspend group behavior for a track by Right-clicking (Windows) or Control-clicking (Mac) the desired group function.

The following items can be isolated from group operation:

- Channel Volume fader
- Channel Pan slider
- Channel Mute button
- Channel Solo button
- Channel Record Enable button
- Channel TrackInput button
- Send fader
- Send Pan slider

Grouped Control Offsets

When the following controls are grouped with offsets, and moved to their extremes, relative offsets are preserved when the controls are moved back from their extremes:

- Main Volume
- Main Pan
- Send Level
- Send Pan

For example, when a grouped Volume fader is moved to its maximum value, any other faders in that group that had higher values will remember their relative offset whenever the first fader is pulled down again.

In Automation views, this “overflow” is indicated on the automation playlist by blue automation breakpoints at the extremes of the automation playlist.

Setting Group Pan Controls to Ignore Offsets

By default, offsets are preserved for grouped pan controls. In some workflows, it is desirable to have grouped pan controls match absolute values rather than preserve offsets.

To set grouped pan controls to ignore offsets:

1. Choose Setup > Preferences and click Mixing.
2. Select “Use Absolute Pan Linking.”

When this option is enabled, grouped pan controls will snap to the absolute value of the pan control that is being adjusted.
Chapter 9: Importing and Exporting Session Data

Pro Tools lets you import a variety of data into a session, including audio and MIDI files, region groups, video files, track playlists, I/O configurations, and signal routing configurations.

You can import audio and MIDI files into a session, or transfer entire audio or MIDI tracks, along with all of their attributes, from another session. Additionally, with Pro Tools HD, you also have the option of importing any combination of track attributes from another session, such as a track’s audio or MIDI playlists, signal routing, plug-ins, or automation. See “Importing Audio” on page 137 and “Importing Tracks and Track Attributes” on page 144.

To import or export video files, see Chapter 29, “Working with Video in Pro Tools”

Importing Audio

Audio files and regions can be imported to new tracks, or they can be imported into the Region List, where they can be dragged to existing tracks.

Files of types that are not supported in the session must be converted when importing. Files with sample rates that are different from the sample rate of the current session must be converted in order for the files to play back at the correct pitch and speed.

Supported files and regions can be auditioned before they are imported.

If region definitions are present in an audio file, you can convert and import the audio for a region without importing the entire parent audio file.

⚠️ Pro Tools 7.x does not support audio file names that contain certain ASCII characters (see “Opening a Session that Contains Audio File Names with Illegal Characters” on page 165).
Audio files of the following types can be imported into Pro Tools sessions:
- AIFF
- WAV or BWF (.WAV)
- SD II
- SD I
- MP3
- MXF audio
- Sound Resource (AIFL—Mac only)
- WMA (Windows Media—Windows only)
- QuickTime (Mac only)
- AAC audio (including audio with AAC, Mp4, and M4a file extensions)
- ReCycle (REX 1 and 2) files
- ACID files

**Copying, Adding, and Converting Audio**

Depending on the properties of the audio files you are importing, you can add, copy, or convert the files. The following options appear in the Import Audio dialog when they are applicable to the selected audio file.

**Add**

Audio files that are of the same file type and bit depth as a session can be added directly to the session. When you add an audio file, the session references the original audio file in its original location. Use this option when you do not want to use extra hard drive space for audio files that are already of the same bit depth and sample rate as your session.

Pro Tools does allow audio files that are not the session’s native file type to be added to the session. For example, Windows sessions allow AIFF or WAV files to be added to any session, and Mac sessions allow SD II, AIFF, or WAV files to be added to any session. However, sessions with mixed file types will have reduced performance.

Audio files that are of a different bit depth than the session must be converted before they can be imported.

**Copy**

If a file can be added to your session, you will also be given the option to copy it. This option creates a copy of the audio file and places it in a folder you choose. When you copy an audio file, the session references the copied file in its new location.

Pro Tools cannot import protected AAC or MP4 files with the .M4p file extension. These files are protected under the rules of digital rights management.

ACID files without slice data are imported as audio regions.

Sliced ACID files and REX 1 and 2 files are imported as region groups. For more information on Region Groups, see “Importing and Exporting Region Group Files” on page 159.

After importing ACID files and REX 1 and 2 files, you can reduce clutter in the Region List by hiding auto-created regions in the Region List (deselect Show > Auto-Created in the Region List pop-up menu)

Pro Tools can automatically apply real-time crossfades to imported REX and ACID files. See “Automatic Fades for Imported REX and ACID Files” on page 139
Use Copy to move audio from an unsupported or removable drive to an audio drive, or to archive audio files for a session to a specific location.

Convert

Audio files that are not of the same bit depth or sample rate as a session, or audio files that are of an incompatible file type (such as SD II files in Windows) must be converted to be used with the session. When an audio file is converted, a new file with the correct bit depth, file type, and sample rate is created and placed in a folder you choose.

The quality of sample rate conversion used by Pro Tools is determined by the preference for Conversion Quality. For details, see “Conversion Quality” on page 139.

Importing Stereo Files

When using the Import Audio command, interleaved stereo files are automatically imported to stereo tracks.

Split stereo (dual mono) audio files can be automatically imported to stereo tracks. Split stereo audio files must have the channel identifiers “.L” and “.R” in their names (for example, filename.L and filename.R), and the files must be the same length. In Windows, or in Mac/PC Compatibility mode, these files will have a 3-letter file extension appended after the “.L” or “.R” channel identifier.

Pro Tools also lets you import multichannel interleaved files of any supported file type.

Automatic Fades for Imported REX and ACID Files

Pro Tools can automatically apply real-time crossfades to the regions or “slices” in imported REX and ACID format files.

To apply real-time crossfades to REX and ACID files:

1. Choose Setup > Preferences and click Editing.
2. Select the “Automatically Create Fades For Imported REX and ACID files” option.
3. Click REX/ACID and choose the shapes for the crossfades, and click OK.
4. Click OK to close the Preferences dialog.

⚠️ Depending on your edits or tempo changes after importing REX or ACID files, the fades may get deleted and you will have to recreate them yourself.

Conversion Quality

The Conversion Quality preference determines the quality of sample rate conversion used when converting and importing audio into a session. There are five possible settings, ranging from Low (lowest quality) to Tweak Head (highest quality). The higher the quality, and the larger the conversion, the longer it will take.

To set the sample rate conversion quality:

1. Choose Setup > Preferences and click the Processing tab.
2 From the Conversion Quality pop-up menu, select a quality setting.

From the Conversion Quality pop-up menu,
select a quality setting.

For most applications, the Good or Better setting will yield very good results.

3 Click Ok.

Importing Audio Files and Regions

Pro Tools provides several ways to import audio files and regions into an open session.

- “Importing Audio Files and Regions Using Pro Tools Menu Commands” on page 140
- “Importing Audio Files Using the Pro Tools Application Icon or Alias” on page 141
- “Importing Audio Files and Regions with Drag & Drop” on page 142
- “Importing Audio from Audio CDs” on page 142

Importing Audio Files and Regions Using Pro Tools Menu Commands

Pro Tools provides menu commands to import audio files or regions.

- To import entire tracks from other sessions, see “Importing Tracks and Track Attributes” on page 144.

To import audio files or regions into a session from the Pro Tools File menu:

1 Choose File > Import > Audio.

2 In the Import Audio dialog, select an audio file to display its properties and associated regions.

Figure 6. Import Audio dialog

File and Region icons in the Import Audio dialog

On the Mac, Sound Resource files must have the “.SFIL” extension to be imported by Pro Tools.
3 To audition a selected file or region before you import it, click the Play and Stop buttons in the Import Audio dialog.

Adjust playback volume with the vertical slider. To navigate to a particular location in the file, use the horizontal slider under the Play and Stop buttons.

The audition output defaults to channels 1–2. With Pro Tools HD, the audition output channels can be changed in I/O Setup or Hardware Setup.

4 Do any of the following:
   - To place a file or region in the Import list, select the file and click Add or Convert.
   - To import all files and regions in the current directory, click Add All or Convert All.
   - To remove a file or region from the Import list, select it and click Remove.
   - To remove all files and regions, click Remove All.

5 When you have added all audio files and regions to the Import list, click Done.

6 If you are copying or converting files, choose a location for the new files. Choose a folder on a valid audio drive, such as the Audio Files folder for the current session.

7 In the Audio Import Options dialog, choose where the imported files will go in the session:

   **New Track** Each audio file is imported into its own individual track and into the Region List.

When importing audio into a track, you can also choose the location in the track where the audio file will begin (such as Session Start).

   **Region List** Audio files are imported into the Region List without creating a new track. Imported audio files appear in the Region List and can then be dragged into an audio track.

8 If you chose to create a new track, choose a location for the imported file in the track:

   **Session Start** Places the file or region at the start of the session.

   **Song Start** Aligns the beginning of the file or region to the Song Start point.

   **Selection** Aligns the beginning of the file or region to the edit cursor or to the beginning of a selection in the timeline.

   **Spot** Displays the Spot dialog, which lets you spot the file or region to a precise location based on any of the Time Scales.

9 Click OK.

### Importing Audio Files Using the Pro Tools Application Icon or Alias

Audio files can be imported into a session using the Pro Tools application icon or alias.

#### To import audio files into a session, using the Pro Tools application icon or alias:

1 Open or create a new session.
From Windows Explorer or Mac Finder, locate the audio files you want to import.

Audio files must be in WAV, SD II, or AIFF/AIFC format in order to be dropped into Pro Tools.

Audio files will be converted if they are not of the correct bit depth or number of channels. They will be converted to mono files of the default audio file format, with the session’s bit depth and sample rate.

Drag the audio files onto the Pro Tools application icon or alias.

Importing Audio Files and Regions with Drag & Drop

You can drag and drop audio files or regions from a DigiBase browser or from Windows Explorer or Mac Finder to the Timeline, a track, the Track List, or the Region List.

To import audio into the Region List:
  1. Select audio files in a DigiBase browser, Windows Explorer or Mac Finder.
  2. Drag the files onto the Region List of the current session.

To import audio into an existing track:
  1. Select audio files in a DigiBase browser, Windows Explorer or Mac Finder.
  2. Drag the files onto an existing track in the Edit window of the current session.

To import audio into new tracks:
  1. Select audio files in a DigiBase browser, Windows Explorer or Mac Finder.
  2. Do one of the following:
     • Shift-drag the files and drag them anywhere in the Edit window of the current session.
     • Drag the files onto any empty space in the Edit window of the current session.
     • Drag the files to the Track List.

For more information on using DigiBase browsers, refer to the DigiBase Guide.

Importing Audio from Audio CDs

Pro Tools lets you import tracks from audio CDs using the same methods that you use to import audio files, as follows

• Drag and drop CD audio from the CD folder.
• Drag and drop files from DigiBase Browser.
• Use the Import Audio command.

Importing CD audio with either drag and drop method lets you continue working in the session foreground (such as in the Mix or Edit window), while the Task Manager (Window > Task Manager) works in the background (importing and converting the audio until the import is completed).

For more information on the Task Manager, see the DigiBase Guide.

Since the transfer is made in the digital domain, there is no signal loss.

The sample rate for audio CDs is 44.1 kHz. Therefore, if your session’s sample rate is set to 48 kHz or higher, Pro Tools will convert the sample rate for the imported audio. Before importing CD audio, set the Conversion Quality preference accordingly. See “Conversion Quality” on page 139 for details.
Before importing CD audio, make sure your hard drive has enough space for the converted audio files.

**To import a CD audio track using the DigiBase Browser:**

1. Insert the audio CD into your CD/DVD drive.
   
   ![If Autoplay is enabled, stop playback and close the application that is configured for Autoplay.]

2. Choose Window > Workspace.

3. In the DigiBase browser, click on the CD and select the audio track.

4. Do one of the following:
   - Drag the file to the Region List to add it to the session.
   - Drag the file to a track to place (or spot) it in the track.
   - Drag the file to the Track List to add and create a new track.

Pro Tools converts the CD audio track to the session’s audio file format, bit depth, and sample rate, and saves it on your hard drive.

The imported audio file appears in the Region List. From there you can drag the region to a track in your session.

**Importing Multichannel Audio Files from a Field Recorder**

(Pro Tools HD)

Pro Tools lets you use any of the import methods to import monophonic and polyphonic audio files recorded by a field recorder. When you import these types of files, they must be converted to an audio format compatible with Pro Tools.

For more information on importing files from a field recorder, refer to the Field Recorder Workflow Guide.

**Importing Monophonic Audio Files**

A monophonic audio file contains one mono channel and relevant metadata from a single multichannel recording.

When you import monophonic audio files that were recorded simultaneously, they are converted to multichannel regions and displayed together in the Region List. Any metadata is also imported with the files.

**Importing Polyphonic Audio Files**

A polyphonic audio file contains multiple mono channels and relevant metadata recorded simultaneously in a multichannel recording.

When imported into Pro Tools, a polyphonic audio file is divided into individual monophonic audio files written to disk—one file for each channel. Regions for each channel appear in the playlist, and a multichannel region appears in the Region List with the channels expandable underneath. Any metadata is also imported with the files.
Importing Tracks and Track Attributes

You can import entire tracks from other Pro Tools sessions into the current Pro Tools session using the Import Session Data command or drag and drop.

With Pro Tools HD or Pro Tools LE with DV Toolkit 2, you can select specific session data (such as automation and routing) to import. You can also import main playlist options—either replacing existing options or overlaying elements onto existing tracks.

For example, with Pro Tools HD or Pro Tools LE with DV Toolkit 2, you can choose to import only the track’s audio into your current Pro Tools session. This is analogous to “changing the tape reel” in a traditional studio setup with a tape machine and mixing console. Or, you can choose to import all of a track’s mixer settings without its audio, effectively importing a channel strip and using it on a track in your current session. By importing mixer settings for all of the tracks in a session or session template, you can reuse an entire Pro Tools mixer on all the sessions in a project.

To import tracks or their attributes:

1. Open or create a new session.

2. Do one of the following:
   - Choose File > Import > Session Data, select the session to import data from, and click Open.
   - Drag the session file whose tracks or attributes you want to import from a DigiBase browser, Windows Explorer, or Mac Finder into the track playlist area in the current session’s Edit window or to the Track List.
   - If the Fader Gain of the sessions are different, you will be prompted to keep or change Fader Gain before the Session Data dialog opens.
   - In the Source Tracks section, select tracks to import by clicking the pop-up menu to the right of each track name and selecting Import As New Track.

   **To select multiple tracks, Alt-click (Windows) or Opt-click (Mac) on any track pop-up menu and select Import As New Track.**

   **If the current Pro Tools system does not support surround mixing, surround tracks are not displayed in the Source Tracks list.**

3. With Pro Tools HD or Pro Tools LE with DV Toolkit 2, for each track you select, you can choose to import it as a new track, or choose a destination track from the corresponding pop-up menu. Click Match Tracks to automatically match source and destination tracks with the same names.

4. With Pro Tools HD or Pro Tools LE with DV Toolkit 2, select from among the Track Playlist options to choose how you want to import the source tracks.

5. If applicable, choose options for how media files should be imported from the Audio Media Options and the Video Media Options pop-up menus.

6. Choose the Time Code Mapping option for imported data.

7. If the sample rates of the sessions are different, select the sample rate for the source session from the Source Sample Rate pop-up menu.

8. To import the meter and tempo maps from the source session, select the Import Tempo/Meter Map option.
To import Markers and Memory Locations from the source session, select the Import Marker/Memory Locations option.

With Pro Tools HD or Pro Tools LE with DV Toolkit 2, to import any Mix or Edit Groups from the source session, select the Import Mix/Edit Groups option.

With Pro Tools HD, to import any mic pre settings from the source session, select the Import Mic Pre Settings option.

Click OK when you are finished.

If you chose to copy or consolidate media, choose a location to place the media files.

⚠️ Imported tracks are made inactive if their source media is unavailable, or if the current session does not contain an equivalent output path.

**Importing Grouped Playlists from Other Sessions**

You can import tracks that use Grouped Playlists from another Pro Tools session, and the playlist grouping function will remain intact for those imported tracks. There is, however, a restriction for importing from pre-Pro Tools 6.1 sessions: After importing a partial set of grouped playlists (such as tracks 1–7 of a 10-track group), you cannot subsequently import tracks 8–10 and have them “rejoin” the playlist group for tracks 1–7.

**Import Session Data Dialog**

The Import Session Data dialog lets you view the properties of the source session, select which tracks to import, and with Pro Tools HD, choose which attributes of those tracks you want to import into the current session.
Source Properties

The Import Session Data dialog displays properties for the source session. These properties include source session name, session type, start time of the session, audio bit depth, and sample rate. For Pro Tools 5.1 or higher sessions, the program that created the session and the session’s audio file type are listed.

Audio Media Options

Refer to Source Media (Where Possible) This option lets you avoid duplicating audio files by referring to the original files when possible. If the source files do not reside on supported playback media (such as a CDs or DVDs), or if they require bit depth or sample rate conversion, the source files are copied instead. This option allows the current session to refer to files that do not match the current session’s audio file format.

Copy from Source Media This option copies all audio files related to the imported tracks from the source media to a new specified location, and converts the files to the current session’s audio file format, bit depth, and sample rate if necessary. This is useful if you are importing tracks from a source such as CD or DVDs or shared storage, and you want to place the audio files on a different hard drive.

Consolidate from Source Media This option consolidates audio while copying it. This is useful if you want to copy only the regions of the audio files used in the source tracks, without copying unused audio. This option copies and converts consolidated audio to the current session’s audio file format, bit depth, and sample rate if necessary.

When you choose this option, you can also choose the size of the handle (in milliseconds) applied to consolidated audio. Handle is the amount of the original audio file that is preserved before and after each region in case you need to make any edits to the new regions.

Force to Target Session Format This option copies and converts any files that do not match the current session’s file format, bit depth, and sample rate. Files that do match the current session’s file type, bit depth and sample rate are referred to directly and not copied.

Video Media Options

You can either choose to leave video media files in their original locations or copy them to a new location. This is useful if you are importing tracks from a source such as CDs or DVDs or shared storage, and you want to place video files on a different drive.

Time Code Mapping Options

You can specify where the imported tracks are placed in the current session. Times are indicated in time code for Pro Tools|HD and Pro Tools LE with DV Toolkit 2, and minutes:seconds for other Pro Tools LE systems.

Maintain Absolute Time Code Values This option places tracks at the locations where they were located in the source session. For example, if the current session starts at 00:01:00:00, and the session from which you are importing starts at 10:00:00:00, the earliest imported tracks can appear in your session is 9 hours and 59 minutes after the start of the session.
Maintain Relative Time Code Values This option places tracks at the same offset from session start as they had in the source session. For example, if the source session starts at 01:00:00:00 and contains a track that starts at 01:01:00:00, and the current session start is 02:00:00:00, the track will be placed at 02:01:00:00 in the current session.

Map Start Time Code To This option places tracks relative to their original session start time. (With Pro Tools HD or Pro Tools LE with DV Toolkit 2 systems, times are expressed in hh:mm:ss:ff, and on Pro Tools LE systems, times are expressed in hh:mm:ss.) For example, if the current session starts at 00:01:00:00, and the session from which you are importing starts at 10:00:00:00, you can reset the start time code to 00:01:00:00, to avoid placing files 9 hours and 59 minutes from the start of your session.

Track Offset Options
You can specify a track offset in addition to any offset incurred with the Time Code Mapping options. Any imported audio is offset in the current session’s timeline by the specified amount. You can enter values in Minutes:Seconds, Bars|Beats, Samples, Time Code, or Feet/Frames.

Sample Rate Conversion (SRC) Options
You can set options that control how sample rate conversion is applied to imported audio files. If the source session and the current session have the same sample rate, this portion of the dialog is unavailable.

Source Sample Rate For audio files created in any session, no matter what the session sample rate is, you can have the sample rate conversion process treat the files in several ways to compensate for pull-up, pull-down, and NTSC or PAL frame rates. This setting allows you to choose the sample rate from which you want the sample rate conversion process to start.

Destination Sample Rate The destination sample rate is always set to the sample rate of your current session.

Conversion Quality This option lets you set the quality of the sample-rate conversion process. See “Conversion Quality” on page 139.

Source Tracks
This area of the dialog lists the tracks in the source session that can be imported, each with a corresponding pop-up menu.

Operation/Destination Track Pop-Up Menus
For each source track, there is a corresponding pop-up menu that lists options for importing the track and, with Pro Tools HD and Pro Tools LE with DV Toolkit 2, possible destination tracks in the current session. The pop-up menus display the following items:

Do Not Import Neither the source track nor any of its attributes are imported.

Import as New Track The source track and all attributes selected in the Session Data to Import menu are imported into a new track in the current session.

Destination Track Names (Pro Tools HD and Pro Tools LE with DV Toolkit 2 Only) The names of possible destination tracks in the current session are listed at the bottom of the pop-up menu. Imported playlists and all attributes selected in the Session Data to Import will be placed in the destination track you choose.
Only destination tracks that match the track type (audio, Instrument, MIDI, Auxiliary Input, or Master Fader) and the channel format (mono, stereo, or any of the supported multichannel formats) of the source track appear in the pop-up menu.

**Find Matching Tracks**
*(Pro Tools HD and Pro Tools LE with DV Toolkit 2 Only)*

If you are importing playlists from source tracks with the same name as destination tracks in the current session (such as a new cut of a scene), click Find Matching Tracks to automatically match the track names. Tracks must have the same name, track type, and channel format to be automatically matched.

**Session Data to Import**
*(Pro Tools HD and Pro Tools LE with DV Toolkit 2 Only)*

The Session Data to Import menu is where you select which attributes of the selected tracks you want to import into the current session.

Selected attributes are applied to all tracks that you choose to import into the current session.

**Replacing Track Attributes**

When you import an attribute of the source track into an existing track in the current session, it replaces the corresponding attribute in the destination track. If you choose not to import an attribute of the source track, the corresponding attribute in the destination track is retained.

**Replacing Track Path Names**

When you import a track’s input, output, send output or hardware insert assignments, any custom path names and I/O configurations from the source session are not imported. You can import path names and I/O configurations by importing I/O Setup settings. See “I/O Settings Files” on page 88 for more information.

**Selecting Track Attributes to Import**

You can select All, None, or any combination of the listed attributes to import. The following attributes are available to import:

- **All** Imports all of the source track’s playlists, according to the Track Playlist Option setting, and all of the attributes in the Session Data to Import list.
- **None** Imports only the source track’s main playlist, according to the Track Playlist Option setting, and no other attributes of the source track.
- **Alternate Playlists** Imports all of the source track’s alternate playlists. The alternate playlists appear in the destination track’s playlist pop-up menu.
- **Regions and Media** Imports all of the audio files or regions in the source track, and places them in the Region List.
**Volume Automation and Setting** Imports the source track’s Volume fader setting and any automation data on the track’s Volume Automation playlist. The Volume fader setting and any Volume automation data in the destination track are replaced.

**Pan Automation and Setting** Imports the source track’s Pan Slider settings and any automation data on the track’s Pan Automation playlist. The Pan Slider setting and any Pan automation data in the destination track are replaced.

**Mute Automation and Setting** Imports the source track’s Mute setting and any automation data on the track’s Mute Automation playlist. The Mute setting and any Mute automation data in the destination track are replaced.

**Main Output Assignments** Imports the source track’s channel output assignments, including any multiple output assignments. The channel output assignments in the destination track are replaced.

**Send Output Assignments** Imports the source track’s send output assignments. Any Send output assignments in the destination track are replaced.

**Plug-in Assignments** Imports the source track’s plug-in assignments. Any plug-ins in the destination track are removed, and their associated settings and automation are lost.

If the source track uses a plug-in that is not available on the destination system, it appears in the destination track and is made inactive.

**Plug-in Settings and Automation** When the source track’s plug-in assignments are imported, this option imports the track’s plug-in settings and any automation data associated with the plug-ins. If no plug-in assignments are imported, this option has no effect.

**Hardware Insert Assignments** Imports the source track’s hardware insert assignments. Any Insert assignments in the destination track are replaced.

**Voice Assignments** Imports the source track’s voice assignment from the source session. Any voice assignments in the destination track are replaced.

**Input Assignments** Imports the source track’s channel input assignment. The Input assignment in the destination track is replaced.

**Side-Chain Assignments** When the source track’s plug-in assignments are imported, this option imports any side-chain assignments associated with the plug-ins. If no plug-in assignments are imported, this option has no effect.

**I/O Labels (Path Names)** Imports the source track’s path names.

**Track Active State** Imports the active/inactive state of the source track from the source session.

**Track Comments** Imports the track comments associated with the source track. Any comments in the destination track are replaced.

**Record Safe/Solo Safe Settings** Imports the record safe and solo safe settings of the source track from the source session. Any record safe or solo safe settings in the destination track are replaced.

**Track View Settings** Imports the track height and playlist view of the source track from the source session.

**Mix/Edit Groups** Imports track groups from source session.
Track Playlist Options
(Pro Tools HD and Pro Tools LE with DV Toolkit 2 Only)

You can select from the following options to control how the main playlist from each source track is imported to the destination track in the current session.

Import Main Playlists — Replacing Destination Main Playlists Imports the main playlist from the source track. When you import the playlist into an existing track, the main playlist in the destination track is deleted and replaced with the imported playlist.

- If you select the above option and import all of the source track’s attributes, this is equivalent to importing the entire track.
- If you select the above option and do not import any of the source track’s attributes, you replace the audio playlists while keeping your current mixer settings.

Import Main Playlists—Overlaying New with Existing, Trimming Existing Regions Imports the main playlist from the source track. When you import the playlist into an existing track, any existing playlist data that overlaps data imported from the source track is trimmed and replaced with the imported data. Any playlist data in the destination track that does not overlap remains in the destination track.

Do Not Import Main Playlists—Leaving Destination Playlists Intact Does not import the main playlist from the source track. No audio is imported; only the attributes selected in the Session Data to Import list are imported to the selected tracks. When selected, importing all of the source track’s input, output, send, insert and plug-in attributes is equivalent to importing a channel strip.

Import Tempo/Meter Map Imports the meter and tempo maps, as they appear in the Tempo and Meter Conductor rulers, from the source session. Any Tempo or Meter events in the destination session are replaced.

Import Marker/Memory Locations Imports markers and Memory Locations as they appear in the Marker ruler, from the source session. Any markers and Memory Locations in the destination session are retained. Imported marker and Memory Locations are assigned the next available Marker/Memory Location numbers.

Import Pre Settings
(Pro Tools HD Only)

Imports any Pro Tools mic preamplifier settings from the source session. Any mic preamplifier settings in the destination session are replaced.

Exporting Audio

Pro Tools supports exporting regions as audio files, exporting left and right audio files as stereo interleaved files, and exporting region information.

You can also export audio from Pro Tools by bouncing or consolidating audio tracks. For more information, see “Consolidate Command” on page 395 and “Bounce to Disk” on page 638.
Exporting a Region as a New Audio File

You can export regions as audio files with the Export Regions as Files command. Use this command if you intend to use a region in other sessions (or other audio applications) without using its parent source file.

This command also provides a way to convert regions to a different audio format, sample rate, or bit depth.

To export regions as new audio files:
1. In the Region List, select the regions you want to export.
2. From the Region List pop-up menu, choose Export Regions as Files. The Export Selected dialog appears.
3. In the Export Selected dialog, set the file type, format, bit resolution, and sample rate. In addition, specify the Conversion Quality, and choose the destination directory.

When you export regions to a lower bit depth, Dither (with or without Noise Shaping) is applied as shown in Table 10.

Table 10. Dither and Noise Shaping with Export Selected dialog

<table>
<thead>
<tr>
<th>Bit Depth</th>
<th>Dither</th>
<th>Noise Shaping</th>
</tr>
</thead>
<tbody>
<tr>
<td>24-bit to 24-bit</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>16-bit to 24-bit</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>24-bit to 16-bit</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>16-bit to 16-bit</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>24-bit to 8-bit</td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td>16-bit to 8-bit</td>
<td>Yes</td>
<td>No</td>
</tr>
</tbody>
</table>

The Dither setting used for any conversion is the Digidesign Dither plug-in (with or without Noise Shaping enabled, as noted in Table 10).

For more information about using Dither, see “Dither” on page 557.

4. Select an option for how Pro Tools should resolve duplicate file names.

Prompting for Each Duplicate Prompts you for a file name for any file that has the same name as a file in your destination directory.

Auto Renaming Automatically changes the name of any duplicate file by adding a number at the end of the file name (such as file_01).

Replacing with New Files Replaces files with the same name with the new files.
5 Once the Export Options are configured, click Export to export the new audio files.

**Exporting Stereo or Multichannel Interleaved Files**

You can use the Export Regions as Files command to export audio regions to stereo or multichannel interleaved files for use in other applications. (Pro Tools cannot use interleaved files directly in the timeline—these must be converted into multi-mono files.) For example, for this to work with a stereo file, the selected regions must have identical names with ".L" and ".R" suffixes (for instance, vocals_01.L and vocals_01.R). These regions appear as a stereo region in the Region List.

Pro Tools HD also lets you bounce multichannel interleaved files of any supported file type.

**To export regions as a stereo or multichannel interleaved file:**

1. Select the stereo or multichannel audio region in the Region List or in the track playlist. If the regions appear on mono tracks in the session, select the two mono regions.

2. From the Region List pop-up menu, choose Export Regions as Files.

3. In the Export Selected dialog, select “Stereo Interleaved” in the Format pop-up menu. For multichannel regions, the Stereo Interleaved option produces a multichannel interleaved file.

4. Configure any other output settings, then click Export to export the new stereo interleaved file.

---

**Exporting Region Definitions**

Pro Tools stores region definitions for audio files within each session. If you want to use an audio file’s regions in another session, or with another application that supports them, you can export the region information.

> If you plan to transfer Pro Tools session data to another session, you should export region definitions for sessions containing multiple takes created with Loop Record.

The Export Region Definitions command does not export regions as audio files (unlike the Export Regions as Files command). Instead, it stores pointers to the regions within the parent source file.

**To export region definitions for an audio file:**

1. In the Region List, select any regions or region groups for which you want to export definitions. You do not have to select the parent file audio region.

2. Choose Export Region Definitions from the Region List pop-up menu.

3. Click Export.
Exporting Pro Tools Tracks as OMFI or AAF Sequences

With the DigiTranslator Integrated Option (DigiTranslator 2.0 or higher), Pro Tools lets you export individual tracks in OMFI format or AAF format. Use the Export Selected Tracks as OMF/AAF command.

⚠️ Pro Tools with DigiTranslator does not support AAF files with embedded media.

For more information on installing, using, or removing DigiTranslator with Pro Tools, refer to the DigiTranslator Guide.

Exporting Sessions as Text
(Pro Tools HD Only)

You can use the Export Session Info as Text command to create a text file that contains extensive information about your session.

This text file can contain a list of the session’s audio files and regions. The File List provides a list of all the audio files and fades in the session, and their hard drive locations. The Region List displays all audio regions in the session, and the source audio file for each region.

Track EDLs are exported as tab-delimited text—that is, with tabs between each column heading, and tabs between each event parameter. You can use this data in a program for reading EDLs, or you can format the EDL data into tables using a word processor or spreadsheet application.

Export Session Info as Text Options

Include File List/Region List

You can choose to export a list of the session’s audio files and regions. The File List provides a list of all the audio files and fades in the session, and their hard drive locations. The Region List displays all audio regions in the session, and the source audio file for each region.

Export Session Info as Text dialog

Include File List/Region List

You can choose to export a list of the session’s audio files and regions. The File List provides a list of all the audio files and fades in the session, and their hard drive locations. The Region List displays all audio regions in the session, and the source audio file for each region.
Include Track EDLs (Playlists)

You can export track EDLs (playlists). Track EDLs can be used to spot-check region placement and edits, or in a conforming program for post applications. In extreme circumstances the EDL can be used to recreate the entire session.

⚠️ MIDI track EDLs are not exported.

When exporting track EDLs, the following options are available:

Show Subframes This option allows you to export subframe time information with track EDLs, if used in your session.

Include User Timestamps You can include user timestamps with track EDLs. User timestamps indicate a user-defined session location for the region, or the original location of the region when recorded.

Fade Handling For track EDLs, you can choose whether to show crossfades, not to show them, or to combine crossfaded regions. When regions are combined, their durations and locations are listed up to the center of the crossfade (for the leading region) and from the center of the crossfade (for the following region).

Time Format You can select the appropriate time format that exported EDL information is based on. For example, for post work, you might select SMPTE time, but for music creation locked to a grid, you might select Bars & Beats.

File Format

You can choose to export to any of several different text formats. These include standard text formats, and Microsoft Word and Excel formats.

Exported Session Text

Session Information

The session text file starts with basic information about the session. This information includes the session name, sample rate, bit depth, time code format, and number of audio tracks, audio regions, and audio files, as shown in the following example.

<table>
<thead>
<tr>
<th>Session Information example</th>
</tr>
</thead>
<tbody>
<tr>
<td>SESSION NAME: Ripleys II-092700</td>
</tr>
<tr>
<td>SAMPLE RATE: 48000.000000</td>
</tr>
<tr>
<td>BIT DEPTH: 24-bit</td>
</tr>
<tr>
<td>TIME CODE FORMAT: 30 Frame</td>
</tr>
<tr>
<td># OF AUDIO TRACKS: 19</td>
</tr>
<tr>
<td># OF AUDIO REGIONS: 203</td>
</tr>
<tr>
<td># OF AUDIO FILES: 54</td>
</tr>
</tbody>
</table>

File List and Region List

Next, if you choose to include them, are the lists of audio files and regions.

Track EDLs

The final item, if exported, is the list of track EDLs. A track EDL lists the track name, and all edits, including the event number, the region name, region start and end time, and region duration. The region timestamp is also exported, if you select this option. Subframes are shown in each time field if you select this option.
To export a session as text:

1. Choose File > Export > Session Info as Text.
2. Select whether to include the File List, Region List, and track EDLs.
3. If you choose to include track EDLs, select whether to show subframes, and whether to include user timestamps. Also select an option for crossfade handling.
4. If you choose to include track EDLs, select the Time Format for the exported session text from the pop-up menu.
5. Select the File Format for exported text using the pop-up menu.
6. When you have set your options, click OK.
7. Select a location and enter a filename for the exported text file. In Windows, Pro Tools adds the correct 3-letter filename extension, while on the Mac, the file extension “.txt” is added.

Anyone can send and receive files from a DigiDelivery system, even if they do not own a DigiDelivery network appliance, as follows:

- To send a delivery, senders must have an Internet connection, an account on a DigiDelivery network appliance, and the DigiDelivery client application.
- To receive a delivery, recipients only need an Internet connection and the DigiDelivery client application. An account on the network appliance is not needed.

Send via DigiDelivery

DigiDelivery® is Digidesign’s system for efficient and reliable transfer of digital media files over the Internet. Send via DigiDelivery lets you send a Pro Tools session and all of its related files using DigiDelivery from within Pro Tools.

Like the Save Copy In command, DigiDelivery copies all files of the same type, regardless of their location, into a single destination folder.
3 In the Send to DigiDelivery dialog, select which files to include.

![Include in Delivery dialog](image)

Include in Delivery dialog

You have the option to include:

- Audio files
- Fade files
- Video files
- Plug-in settings files
- Timeline files only (files that are referenced in the current session timeline)

4 Click OK. The DigiDelivery client will launch, and the DigiDelivery Send Wizard (Page 1) will open. On this page you can name the delivery and add or remove files.

5 Complete the remaining DigiDelivery Send Wizard pages and send the file, following the instructions that came with the DigiDelivery client software.

---

**Importing MIDI Files**

You can import Standard MIDI Files (SMF) into your Pro Tools sessions.

Pro Tools provides several ways to import MIDI files into an open session.

- “Importing MIDI Files Using Pro Tools Menu Commands” on page 157
- “Importing MIDI Files with Drag & Drop” on page 158

Pro Tools does not import proprietary sequence files. To use sequences from other MIDI applications in a Pro Tools session, you will need to first save them as Standard MIDI Files. Refer to the manufacturer’s documentation for details on saving Standard MIDI Files.

There are two types of Standard MIDI Files, both of which are supported by Pro Tools:

- Type 0 MIDI files store data for all MIDI channels in a single track. When importing these files, Pro Tools separates the data by channel and places each track’s data in separate regions and tracks.
- Type 1 MIDI files, sometimes referred to as multitrack MIDI files, contain multiple tracks of MIDI data. When importing these files, each track’s data is placed on its own new MIDI track in the Pro Tools session.
Importing MIDI Files Using Pro Tools Menu Commands

Pro Tools provides menu commands to import MIDI files.

To import Standard MIDI Files into a session using Pro Tools menus:

1. Choose File > Import > MIDI.

2. In the MIDI Import Options dialog, choose the Import Location (where the imported file will go):
   - **New Track**: Each MIDI file is imported into its own individual new track and into the Region List.
   - **Region List**: MIDI files are imported into the Region List without creating a new track. Imported MIDI files appear in the Region List and can then be dragged into a MIDI track.

3. If you chose to create a new track, choose a location for the imported file in the track:
   - **Session Start**: Places the file or region at the start of the session.
   - **Song Start**: Aligns the beginning of the file to the Song Start point.
   - **Selection**: Aligns the beginning of the file to the edit cursor or to the beginning of a selection in the timeline.
   - **Spot**: Displays the Spot dialog, which lets you spot the file to a precise location based on any of the Time Scales.

4. Select any of the following Import options:
   - **Import Tempo Map From MIDI File**: When selected, overwrites any existing tempo map with tempo information read from the MIDI file.
   - **Remove Existing Instrument Tracks**: When selected, deletes any existing Instrument tracks. Selecting this option does not remove any current MIDI tracks. All existing MIDI regions will be left in the Region List.
   - **Remove Existing MIDI Tracks**: When selected, deletes any existing MIDI tracks. Enabling this option does not remove any current Instrument tracks. All existing MIDI regions will be left in the region bin.
   - **Remove Existing MIDI Regions**: When selected, deletes existing MIDI regions (all data on all MIDI and Instrument tracks) but leaves existing MIDI and Instrument tracks in place.

5. Click OK.
The MIDI file will be imported according to the settings in the Import MIDI Settings dialog.

⚠️ If the Standard MIDI File contains markers, they are only imported if the current session does not contain any markers.

6 In the Mix window, click the MIDI Output selector for each new track and assign a MIDI instrument and channel.

**Importing MIDI Files with Drag & Drop**

You can drag and drop MIDI files from a DigiBase browser or from Windows Explorer or Mac Finder to the Timeline, a track, the Track List, or the Region List.

**To import MIDI into the Region List:**

1. Select MIDI files in a DigiBase browser, Windows Explorer or Mac Finder.
2. Drag the files onto the Region List of the current session.

**To import MIDI into an existing track:**

1. Select MIDI files in a DigiBase browser, Windows Explorer or Mac Finder.
2. Drag the files onto an existing track in the Edit window of the current session.

**To import MIDI into new tracks:**

1. Select MIDI files in a DigiBase browser, Windows Explorer or Mac Finder.
2. Do one of the following:
   - From the DigiBase browser, Shift-drag the files and drag them anywhere in the Edit window of the current session.
   - Drag the files onto any empty space in the Edit window of the current session.
   - Drag the files to the Track List.

For more information on using DigiBase browsers, refer to the DigiBase Guide.

**Exporting MIDI Files**

To export a session’s MIDI tracks for use in another MIDI application, or for playback with an external (hardware) MIDI sequencer, you can export Pro Tools MIDI and Instrument tracks as a Standard MIDI File.

MIDI can be exported from Pro Tools as a merged, single, multichannel track (Type 0), or as multiple tracks (Type 1).

**To export all MIDI and Instrument tracks in the current session:**

1. Make sure to unmute any MIDI tracks in the session that you want included in the exported MIDI file. (Or, conversely, mute any MIDI tracks you do not want included in the exported MIDI file.) For Instrument tracks, enable or disable the MIDI mute button (Instruments View) as desired.
Chapter 9: Importing and Exporting Session Data

2 Choose File > Export > MIDI. The Export MIDI Settings dialog opens.

2 Choose File > Export > MIDI. The Export MIDI Settings dialog opens.

3 From the MIDI File Format pop-up menu, select 1 (multi-track) or 0 (single-track).

4 If the Song Start time is different from the Session Start time, select Session Start or Song Start from the Location Reference pop-up menu.

5 Enable or disable the Apply Real-Time Properties option as desired.

6 Click OK. A Save dialog opens.

7 Specify a folder destination and name for the MIDI file.

8 Click Save.

Pro Tools exports all unmuted MIDI and Instrument tracks in the current session to a Standard MIDI File and writes it to your hard drive. Exported MIDI information includes notes, controller events, program changes, and System Exclusive data, as well as events for tempo, meter, and markers.

The SMPTE start time for the session or the song (depending on the selection from the Location Reference pop-up menu) is also exported. This ensures that the exported tracks, when played from another MIDI application, will align with the correct SMPTE frames, and also synchronize correctly to tape and video devices, or Pro Tools.

Refer to your third-party MIDI sequencer documentation to determine whether it supports importing SMPTE start times from MIDI files.

**Not Exported with MIDI Files**

Mute automation and muted regions do not affect exported MIDI. As long as a MIDI track is not muted by clicking its Mute button, or an Instrument track is not muted by clicking its MIDI mute button (Instruments View), all of its MIDI data is exported.

When exporting MIDI files from Pro Tools, device assignments for tracks are not retained (though channel assignments are). If you export MIDI or Instrument tracks from Pro Tools and later re-import them, you will need to reassign the tracks to devices in your studio.

All playlist information for MIDI and Instrument tracks is lost when exporting. For example, tracks that previously contained dozens of MIDI regions will be flattened and only contain single regions after exporting and re-importing.

---

**Importing and Exporting Region Group Files**

Pro Tools can export and import the region group file format (.rgrp). This lets you do the following:

- Separate region group metadata from audio files to avoid unnecessary file copy operations when exporting audio region groups composed from multiple source files.
- Export MIDI data as part of a region group.
- Create multitrack loops.

---

Chapter 9: Importing and Exporting Session Data 159
Region group files store the following metadata:
- References to all audio files within the region group
- Region names and relative location in tracks
- Fades and crossfades
- Region group names and format (single or multitrack)
- All MIDI data present in the region group (such as notes, controllers, and Sysex)
- Track names

Region group files do not store the following:
- Audio
- Automation
- Plug-ins
- Track routing
- Tempo and Meter map
- Region List information

Pro Tools provides several ways to import Region Groups into an open session.
- “Importing Region Groups with Pro Tools Menu Commands” on page 160
- “Importing Region Groups with Drag & Drop” on page 161

**Importing Region Groups with Pro Tools Menu Commands**

To import a region group with Pro Tools menu commands:

1. Choose File > Import > Region Groups and select the region group you want to import.
2. In the Region Group Import Options dialog, choose where the region group will go:
   - New Track Creates a new track where the region group will be imported.
   - Region List Imports the region group into the Region List, where it will be available to place into tracks.

Region Group Import Options dialog

3. If you chose to create a new track, choose a location for the imported group in the track:
   - Session Start Places the group at the start of the session.
   - Song Start Aligns the beginning of the group to the Song Start point.
   - Selection Aligns the beginning of the group to the edit cursor or to the beginning of a selection in the timeline.
   - Spot Displays the Spot dialog, which lets you spot the group to a precise location based on any of the Time Scales.

4. Select any of the following import options:
   - Import Tempo Map from Region Group File When selected, replaces the session tempo map with the tempo map of the region group. This option is only available when importing the region group to the Session Start.
5. Click OK.
Importing Region Groups with Drag & Drop

You can drag and drop Region Groups from a DigiBase browser or from Windows Explorer or the Mac Finder to the Timeline, a track, the Track List, or the Region List.

To import Region Groups into the Region List:
1. Select one or more Region Groups in a DigiBase browser, Windows Explorer or Mac Finder.
2. Drag the files onto the Region List of the current session.

To import Region Groups into an existing track:
1. Select one or more Region Groups in a DigiBase browser or from Windows Explorer or Mac Finder.
2. Drag the files onto an existing track in the Edit window of the current session.

To import Region Groups into new tracks:
1. Select one or more Region Groups in a DigiBase browser, Windows Explorer or Mac Finder.
2. Do one of the following:
   - From the DigiBase browser, Shift-drag the files and drag them anywhere in the Edit window of the current session.
   - Drag the files onto any empty space in the Edit window of the current session.
   - Drag the files to the Track List.

For more information on using DigiBase browsers, refer to the DigiBase Guide.

Exporting Region Groups

To export a region group:
1. Select one or more region groups in the Region List.
2. From the Region List pop-up menu, choose Export Region Groups. The Export Region Groups dialog opens.

3. The Destination Directory defaults to the auto-created Region Groups folder in the session folder. You can change the Destination Directory by clicking the Choose button, navigating to the desired location, and clicking Choose. Click Reset to reset the Destination Directory to the default location.

4. Enable one of the following options for resolving duplicate region group file names:
   - Prompting for Each Duplicate (default)
   - Auto Renaming
   - Replacing with New Files

5. Click OK.
Exporting Region Groups to Another Hard Drive

Generally, if you are exporting region groups to another hard drive, you should copy any referenced audio files. This way you can move region groups not only from one session to another, but from one system to another.

To export a region group to a different hard drive and include its audio files:

1. Export one or more region groups to the desired drive.
2. Create a new session on the new drive.
3. Choose Setup > Preferences.
4. In the Preferences dialog, click the Processing tab and select Automatically Copy Files on Import.
5. Click OK to close the Preferences dialog.
6. Import all previously exported region groups by dragging and dropping them into the session.

The audio files folder of the new session now contains all files referenced by the region groups.
When you work with Pro Tools, you will encounter several different kinds of computer files. Pro Tools systems require that you keep certain files in specific hard drive locations in order to function properly.

- Pro Tools software files should be located on your Startup drive (the drive that contains your operating system and other system-related files).
- On Pro Tools|HD systems, data files (such as session files, audio files, and fade files) can be located on any compatible drive connected to the internal SCSI bus or the external SCSI bus of your computer, or to a SCSI host bus adapter card in your computer. For maximum performance, SCSI drives are recommended for Pro Tools|HD systems. FireWire and ATA/IDE drives are also supported. See the Digidesign Web site for details (www.digidesign.com).
- On Pro Tools LE systems, data files (such as session files, audio files, and fade files) can be located on any compatible hard drive connected to your computer’s internal or external ATA/IDE, FireWire, or SCSI busses.

Although Pro Tools will let you record to your system drive, this is generally not recommended. You should record to system drives only when necessary—for example, if your computer system has just one hard drive, or if your other hard drives are completely out of space.

### Audio File Management

#### Unique File IDs

Pro Tools tags each audio file in a session with a unique identifier that allows it to distinguish a particular file even if its name or location has changed.

#### Locating Audio Files

With Pro Tools, you manage links to audio and other media files with the Relink window.

Pro Tools classifies storage volumes according to their suitability for performance (recording or playback) or transfer (storage or copying) of audio and other media files. Audio files must be stored on suitable Performance volumes and be properly linked in order to be playable in a Pro Tools session.

For complete information on storage volume classifications, refer to the DigiBase Guide.

When you open a session, if Pro Tools determines that audio files are not located on a Performance volume, or if it is unable to locate audio files contained in the session, you can locate or copy the files in order to play back the session. This process is called relinking.
**Transfer Files**

Transfer files reside on volumes unsuitable for playback, such as CD or DVD discs, or network drives.

**To open a session containing Transfer files:**

1. Open the Pro Tools session. If any files are on a volume unsuitable for playback, Pro Tools posts a warning.
2. Do one of the following:
   - Click Yes to open the Copy and Relink window.
   - or –
   - Click No to open the session with all Transfer files offline.

**To make Transfer files playable in the current session:**

1. Choose Window > Project.
2. Double-click the Audio Files folder to display all of the audio files.
3. Choose Select Transfer Files from the Browser menu.
4. Choose Copy and Relink from the Browser menu.
5. Specify a location for the copied files on a valid Performance volume.
6. Click OK.

**Missing Files**

A file is missing if it is not found in the same location as when the session was last saved.

**To open a session with missing files:**

1. Open the Pro Tools session. If any files are missing, Pro Tools posts a Missing Files warning.
2. Choose one of the following options:
   - **Skip All** Ignores all missing files and fades. The missing files will be offline in the session.
   - **Manually Find and Relink** Opens the Relink window, where you can search, compare, verify, and relink missing files.
   - **Automatically Find and Relink** Searches all Performance volumes for all missing files with matching name, unique file ID, format, and length, and automatically commits links to missing files where possible.
3. To exclude fades from the relinking process, and have them recalculated instead, select Regenerate Missing Fades.
4. Click OK.

**For complete information on relinking missing files, refer to the DigiBase Guide.**

**Renamed Audio Files and the Renamed Audio Files Folder**

Renamed audio files are located in the Renamed Audio Files folder. Files can be renamed when you open a session that references audio file names with incompatible characters. Files can also be renamed in certain situations when saving a copy of a session to a Pro Tools version that does not support long file names.
Opening a Session that Contains Audio File Names with Illegal Characters

Pro Tools 7.x does not support audio file names that contain the following ASCII characters:

/ (Forward Slash)
\ (Backslash)
: (Colon)
* (Asterisk)
? (Question mark)
“ (Quotation marks)
< (Less-than symbol)
> (Greater-than symbol)
| (vertical line or pipe)

Any “high order” ASCII character (created with a key combination)

When opening sessions that contain audio file names with illegal characters, Pro Tools automatically creates a renamed copy of each file that contains illegal characters (replacing these characters with an underscore “_”). Renamed files are copied to the Renamed Audio Files folder. The original files are left intact in the Audio Files folder.

Before the session opens, you are prompted to save a detailed report of the renamed files and their original file names to a Notes text file. Follow the on-screen instructions. By default, the Notes text file is saved to the Session folder.

⚠️ It is possible to have a Pro Tools 7.x session that contains audio file names with illegal characters. In this case, if you Save Copy In the session to Pro Tools 6.9.x or lower with Mac/PC Compatibility on, the tracks will be renamed with legal characters. If you Save Copy In the session to Pro Tools 6.9.x or lower with Mac/PC Compatibility off, the characters are not changed.

Saving a Copy of a Session that Contains Long Audio File Names

When saving files to Pro Tools 6.9.x and lower (using Save Copy In), audio files with file names that exceed the limits of the destination format will be truncated and located in the Session folder, as follows:

• If the new session is saved to the same directory as the original, a Renamed Audio Files folder is created in the session’s original folder, and the renamed audio files are placed in it.

• If the new session is saved to a different directory than the original and the All Audio Files option is not checked, a new Session folder is created, which includes an Audio Files folder and a Renamed Audio Files folder. Renamed audio files will be included in the Audio Files folder.

• If the new session is saved to a different directory than the original and the All Audio Files option is checked, a new Session folder is created, which includes an Audio Files folder. Renamed audio files will be included in the Audio Files folder.

WAV File Compatibility

Convert Imported WAV files to AES31/BroadcastWave

Pro Tools always creates AES31/Broadcast compliant BWF (.WAV) files when the file originates in Pro Tools. This option makes imported WAV files compliant with the AES31/EBU Broadcast standard.

AES31/Broadcast Wave is a variant of the standard audio WAV file type. The AES31 format contains SMPTE time stamps and other information beyond the raw PCM audio data.
This variant complies with standards set by the AES (Audio Engineering Society) and EBU (European Broadcasters Union). Choose this option to ensure compatibility with other workstations that recognize this file type.

To make imported WAV files compliant with the AES31/EBU Broadcast standard:
1. Choose Setup > Preferences and click the Processing tab.
2. Select Convert imported “wav” files to AES31/BroadcastWave, then click OK.

Sharing Sessions Created on Different Computer Platforms

This section includes the following:
- “Working with Mac-Based HFS+ Drives on Windows Computers” on page 166
- “Saving Copies of Mac Sessions to be Compatible with Windows” on page 168

Working with Mac-Based HFS+ Drives on Windows Computers

Moving Sessions on Windows Systems to Mac-Based HFS+ Drives
(From Window-Based NTFS Drives Only)

There are specific steps for transferring session files from Windows-based NTFS drives to Mac-based HFS+ drives.

⚠️ Mac systems can read (but not write to) sessions located on Windows-based Fat 32 formatted drives.

To transfer Pro Tools Windows sessions from NTFS drives to HFS+ drives:
1. Set the MacDrive Options to Backup/File Transfer.
2. Do one of the following:
   - Drag the session folder from the NTFS drive to the HFS+ drive.
   - Open the Windows session on the NTFS drive, choose Save Copy In, and save a copy of the session to the HFS+ drive.

Moving Mac-Based Sessions on HFS+ Drives to Windows Systems
(To Windows-Based NTFS Drives Only)

There are specific steps for transferring files from Mac-based HFS+ drives to Windows-based NTFS drives.

To save (or create) Mac sessions to be compatible on Windows systems, see “Saving Copies of Mac Sessions to be Compatible with Windows” on page 168.

The MacDrive Utility is required to mount HFS+ drives on an NTFS system.

To transfer Pro Tools Mac sessions from HFS+ drives to NTFS drives:
1. Set the MacDrive Options to Normal Use.
2. Do one of the following:
   - Drag the session folder from the HFS+ drive to the NTFS drive.
   - Open the Mac session on the HFS+ drive, and when prompted, choose Save Copy In and save a copy of the session to the HFS+ drive.
If the session previously used SD II files, the files are converted to the new audio file format.

**Recording and Playback from HFS+ Drives**

*(Pro Tools 7.2 Only)*

Windows XP supports recording and playback of sessions directly from Mac-formatted (HFS+) drives using the MacDrive software application.

⚠️ **In previous versions of Pro Tools, Mac-formatted HFS+ drives could only be used as Transfer volumes when connected to Windows XP systems using MacDrive.**

When using MacDrive for recording and playback on a Windows system, the session file and all audio files must be stored on Mac-formatted (HFS+) drives. Recording and playback of a session from a mixture of Windows- and Mac-formatted drives is not supported.

**To record or play back from HFS+ drives with Windows:**

1. In Windows, go to the MacDrive Control Panel.
2. Choose Options > File Names and select the “International Use” option.
3. Delete all options listed under “File Name Maps.”
4. In Pro Tools, choose Window > Workspace and make sure that all Mac-formatted volumes are set to R (record) or P (playback) in the A (Audio) and V (Video) columns.

If the session previously used SD II files, the files are converted to the new audio file format.

⚠️ **When transferring Pro Tools sessions from HFS+ drives to NTFS drives, the Pro Tools sessions are unable to relink to audio files and fades that have Mac characters that are illegal in Windows.**

These characters will automatically be converted to underscore (“_”) characters. These files will be saved to the Renamed Audio Files folder. You will need to manually relink each file by File ID. See “Missing Files” on page 164.

**To save session with no illegal characters,** see “Saving Copies of Mac Sessions to be Compatible with Windows” on page 168.
Saving Copies of Mac Sessions to be Compatible with Windows
(Save Copy In to Pro Tools 6.9.x and Lower Only)

Sessions created and saved as Pro Tools 7.x sessions are always compatible on both Windows and Mac systems.

If you create a Pro Tools 6.9.x or lower session on a Mac system, the session will only be compatible on Windows systems if the Enforce Mac/PC Compatibility option is selected during the Save Copy In. In addition, there are cross-platform limits to consider when completing the Save Copy In.

Cross-Platform Session Limits

When saving (or creating) a copy of a Pro Tools session that you want to be compatible on both Mac and Windows, keep in mind the following limits and how Pro Tools deals with them:

Audio File Types

The recommended file format for cross-platform interoperability is BWF (.WAV). To support optimal session interchange, Pro Tools defaults to BWF format for new sessions.

Pro Tools lets you save, bounce, and export in a variety of file formats. If you attempt to create a session and use the SD II format, however, a warning dialog will appear reminding you of its limitations:

- SD II is not supported on Windows XP.
- The maximum sample rate for SD II files is 48 kHz.

File Name Extensions

For cross-platform compatibility, all files in a session must have a 3-letter file extension added to the file name. Pro Tools 5.1 to 6.9.x session files have the extension “.pts,” and Pro Tools 5 sessions have the extension “.pt5.” Wave files have the “.wav” file extension, and AIFF files have the “.aif” file extension.

Incompatible ASCII Characters

Region names, track names, file names, and plug-in settings cannot use ASCII characters that are incompatible with either system.

When you import files into a session, incompatible characters are converted to underscores (“_”) and the renamed files are placed in the Renamed Files folder.

The following characters cannot be used in Windows sessions:

/ (Forward Slash)
\ (Backslash)
: (Colon)
* (Asterisk)
? (Question mark)
“ (Quotation marks)
< (Less-than symbol)
> (Greater-than symbol)
| (vertical line or pipe)

Any “high order” ASCII character (created with a key combination)
Saving Cross-Platform Sessions

To save an existing session to Pro Tools 6.9.x or lower and maintain Mac and Windows compatibility:

1. Choose File > Save Copy In.
2. In the Save Copy In dialog, choose a destination and enter a name for the new session file.
3. Set the Audio File Type to AIFF or BWF (.WAV). These file formats are compatible with either platform.
4. Set the Sample Rate and Bit Depth for the session.
5. Select “Enforce Mac/PC Compatibility.” This option must be selected to make the session cross-platform compatible.
6. Select the Items to Copy to the new session.
7. Click Save.

If the session previously used SD II files, the files are converted to the new audio file format.

Pro Tools can convert a file created on a Mac and saved without the “Enforce Mac/PC compatibility” option selected to a Windows compatible file. For more information, see “Sharing Sessions Created on Different Computer Platforms” on page 166.
Sharing Sessions Created on Different Pro Tools Systems
(Pro Tools|HD, Pro Tools LE, and Pro Tools M-Powered)

Pro Tools makes it easy to share sessions between Pro Tools|HD systems and Pro Tools LE or M-Powered systems. There are some important differences between the three types of systems that can affect how session material is transferred.

The following table also includes Pro Tools LE systems with the DV Toolkit 2 option, as well as Pro Tools LE or M-Powered systems with the Music Production Toolkit option.

Differences between Pro Tools systems

<table>
<thead>
<tr>
<th>Feature</th>
<th>Pro Tools</th>
<th>HD Systems</th>
<th>Pro Tools LE or M-Powered Systems</th>
<th>Pro Tools LE Systems with DV Toolkit 2</th>
<th>Pro Tools LE or M-Powered Systems with Music Production Toolkit</th>
</tr>
</thead>
<tbody>
<tr>
<td>Maximum number of audio tracks</td>
<td>up to 256 tracks</td>
<td>up to 128 tracks (32 voiceable)</td>
<td>up to 128 tracks (48 voiceable)</td>
<td>up to 128 tracks (48 voiceable)</td>
<td></td>
</tr>
<tr>
<td>Maximum number of Instrument tracks</td>
<td>128</td>
<td>32</td>
<td>32</td>
<td>32</td>
<td></td>
</tr>
<tr>
<td>Maximum number of mix busses</td>
<td>128 busses (Pro Tools 6.9 and higher)</td>
<td>32 busses (Pro Tools 7.x)</td>
<td>32</td>
<td>32</td>
<td></td>
</tr>
<tr>
<td></td>
<td>64 busses (Pro Tools 6.7 and lower)</td>
<td>16 busses (Pro Tools 6.9.x and lower)</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Inserts per track</td>
<td>up to 5 inserts</td>
<td>up to 5 inserts</td>
<td>up to 5 inserts</td>
<td>up to 5 inserts</td>
<td></td>
</tr>
<tr>
<td>Sends per track</td>
<td>up to 10 sends (Pro Tools 7.x)</td>
<td>up to 10 sends (Pro Tools 7.x)</td>
<td>up to 10 sends</td>
<td>up to 10 sends</td>
<td></td>
</tr>
<tr>
<td></td>
<td>up to 5 sends (Pro Tools 6.9.x and lower)</td>
<td>up to 5 sends (Pro Tools 6.9.x and lower)</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

For details on transferring sessions between Windows and Mac systems, see “Sharing Sessions Created on Different Computer Platforms” on page 166.
Opening Pro Tools HD Sessions in Pro Tools LE or M-Powered

A Pro Tools HD 7.2 session that does not contain video tracks or VCA Masters can be opened with Pro Tools LE or M-Powered 7.x, but certain session components will open differently or not at all.

⚠️ Pro Tools HD 7.2 sessions that contain video tracks or VCA Master tracks can only be opened with Pro Tools LE or M-Powered 7.0cs3 and higher.

When opening a Pro Tools HD 7.x session in Pro Tools LE or M-Powered 7.x, the following will occur:

**Tracks**
- Any tracks beyond the first 32, as well any inactive tracks, will be set to voice off.
- Any assignments to busses beyond 32 will be made inactive.
- Any Instrument tracks beyond 32 will be made inactive.
- TDM plug-ins with RTAS equivalents will be converted; those without equivalents are made inactive.
- Multichannel surround tracks will be removed from the session.
- Unavailable input and output paths will be made inactive.
- Any Delay Compensation settings will be removed.
- VCA Master tracks will be removed and any uncoalesced VCA automation will be dropped.

**Groups**
- All groups beyond the first 26 (Bank 1, Groups a–z) will be dropped.
- Mix Groups will keep only Main Volume information.
- Mix/Edit Groups will keep only Main Volume and Automation Mode information.
- Automation overflow information for grouped controls will not be preserved.
- Group behavior of Solos, Mutes, Send Levels, Send Mutes will not be preserved.
- Solo Mode and Solo Latch settings will be dropped.

**Video**
- Only the main video track will be displayed.
- Only the first QuickTime movie in the session will be displayed or played back.
- If the session contains QuickTime movies in the Region List but no video track, the session opens with a new QuickTime Movie track containing the first QuickTime movie from the Region List.
- The Timeline will display and play back only the video playlist that was last active. Alternate video playlists will not be available.
- Video regions and video region groups will not be shown or saved.
Sharing Sessions Created on Different Pro Tools Software Versions

Pro Tools makes it easy to share sessions between different software versions of a particular Pro Tools system (such as sharing sessions between Pro Tools HD 7.x and Pro Tools HD 6.x).

Sharing Pro Tools HD 7.2 Sessions with Lower Versions of Pro Tools HD

Opening Pro Tools HD 7.2 Sessions with Lower Versions of Pro Tools HD 7.x

A Pro Tools HD 7.2 session that does not contain video tracks or VCA Masters can be opened with Pro Tools HD 7.x, but certain session components will open differently or not at all.

A Pro Tools HD 7.2 session that contain video tracks or VCA Masters can only be opened with Pro Tools HD 7.1cs3 and higher.

When opening a Pro Tools HD 7.2 session with a lower version of Pro Tools HD 7.x, the following will occur:

Tracks
- VCA Master tracks will be removed and any uncoalesced VCA automation will be dropped.
- Any uncoalesced Trim automation will be dropped.

Groups
- All groups beyond the first 26 (Bank 1, Groups a–z) will be dropped.
- Mix Groups will keep only Main Volume information.
- Mix/Edit Groups will keep only Main Volume and Automation Mode information.
- Automation overflow information for grouped controls will not be preserved.
- Group behavior of Solos, LFEs, Mutes, Send Levels, Send Mutes will not be preserved.
- Solo Mode and Solo Latch settings will be dropped.

Video
- Only the main video track will be displayed.
- Only the first QuickTime movie in the session will be displayed or played back.
- If the session contains QuickTime movies in the Region List but no video track, the session opens with a new QuickTime Movie track containing the first QuickTime movie from the Region List.
- The Timeline will display and play back only the video playlist that was last active. Alternate video playlists will not be available.
- Video regions and video region groups will not be shown or saved.
**Saving Pro Tools HD 7.2 Sessions to Pro Tools 5.1 -> 6.9 Format**

A Pro Tools 7.2 session cannot be opened with Pro Tools versions 6.9.x through 5.1.

To save a Pro Tools 7.x session so it is compatible with Pro Tools version 6.9.x through 5.1, use the File > Save Copy In command to choose the “Pro Tools 5.1 -> 6.9” session format.

**When saving a Pro Tools HD 7.2 session to Pro Tools HD 5.1 -> 6.9 format, the following will occur:**

**Tracks**
- Instrument tracks will be split into separate Auxiliary Input and MIDI tracks.
- VCA Master tracks will be removed and VCA automation will be coalesced to the corresponding slave tracks.
- Trim automation playlists will be coalesced to their corresponding automation playlists.
- Fader Gain levels and automation breakpoints higher than +6 dB will be changed to +6 dB.
- Long names will be shortened to 31 characters.
- The following attributes will be dropped:
  - Region groups
  - Region loops
  - Sample-based MIDI regions
  - Sample-based MIDI tracks
  - Sends F–J and any associated automation
  - Marker/Memory Locations 201–999

**Groups**
- All groups beyond the first 26 (Bank 1, Groups a–z) will be dropped.
- Mix Groups will keep only Main Volume information.
- Mix/Edit Groups will keep only Main Volume and Automation Mode information.
- Automation overflow information for grouped controls will not be preserved.
- Group behavior of Solos, LFEs, Mutes, Send Levels, Send Mutes will not be preserved.
- Solo Mode and Solo Latch settings will be dropped.

**Video**
- Only the main video track will be displayed.
- Only the first QuickTime movie in the session will be displayed or played back.
- If the session contains QuickTime movies in the Region List but no video track, the session opens with a new QuickTime Movie track containing the first QuickTime movie from the Region List.
- The Timeline will display and play back only the video playlist that was last active. Alternate video playlists will not be available.
- Video regions and video region groups will not be shown or saved.
Saving Pro Tools HD 7.2 Sessions to Pro Tools 5.0 Format

A Pro Tools 7.2 session cannot be opened with Pro Tools version 5.0.

To save a Pro Tools 7.x session so it is compatible with Pro Tools version 5.0, use the File > Save Copy In command to choose the “Pro Tools 5.0” session format.

When saving a Pro Tools HD 7.2 session to Pro Tools 5.0 format, the following will occur:

• All the items that occur when saving a Pro Tools HD 7.2 session to Pro Tools HD 5.1->6.9 format, plus the following:
  • Multichannel surround tracks will be removed from the session.
  • Inactive tracks will be removed from the session.
  • Tracks assigned to “No Output” will be routed to Busses 31 and 32.
  • Tracks or sends assigned to Busses 33–64 will be routed to Busses 31 and 32.
  • Tracks assigned to multichannel paths or subpaths of multichannel paths will be routed to Busses 31 and 32.
  • Sends assigned to multichannel paths or subpaths of multichannel paths will be dropped.
  • Tracks or sends assigned to stereo paths referring to even/odd channels (such as 2–3) will be routed to Busses 31 and 32.
  • Multi-mono plug-in instances will be dropped

Sharing Pro Tools LE 7.x Sessions with Previous Versions of Pro Tools LE

A Pro Tools LE 7.x format session cannot be opened on Pro Tools LE versions 6.9.x or lower, but it can be saved to a lower compatible version. Some session components in the new copy will open differently or not at all.

Saving Pro Tools LE 7.x Sessions to Pro Tools LE 5.1 -> 6.9 Format

To save a Pro Tools 7.x session so it is compatible with Pro Tools version 6.9.x through 5.1, use the File > Save Copy In command to choose the “Pro Tools 5.1 -> 6.9” session format.

When saving a Pro Tools LE session to Pro Tools 5.1 -> 6.9 format, the following occurs:

• Fader Gain levels and automation breakpoints higher than +6 dB will be changed to +6 dB.
• Long names will be shortened to 31 characters.
• Instrument tracks will be split into separate Auxiliary Input and MIDI tracks.
• The following attributes will be dropped.
  • Region groups
  • Region loops
  • Sample-based MIDI regions
  • Sample-based MIDI tracks
  • Sends F–J and any associated automation
  • Marker/Memory Locations 201–999
  • Busses 17–32 (Pro Tools LE and Pro Tools M-Powered)
Saving Pro Tools LE 7.x Sessions to Pro Tools LE 5.0 Format

To save a Pro Tools LE 7.x session so it is compatible with Pro Tools version 5.0, use the File > Save Copy In command to choose the “Pro Tools 5.0” session format.

When saving a Pro Tools LE 7.x session to Pro Tools 5.0 format, the following occurs:

- All the items that occur when saving a Pro Tools LE 7.x session to Pro Tools 5.1–6.9 format, plus the following:
  - Fader Gain levels and automation breakpoints higher than +6 dB will be changed to +6 dB.
  - Multi-mono plug-in instances will be dropped.
  - Sends assigned to multichannel paths or subpaths of multichannel paths will be dropped.
  - Tracks assigned to “No Output” will be routed to Busses 31 and 32.
  - Tracks/sends assigned to Busses 33–64 will be routed to Busses 31 and 32.
  - Tracks assigned to multichannel paths or subpaths of multichannel paths will be routed to Busses 31 and 32.
  - Tracks/sends assigned to stereo paths referring to even/odd channels (such as 2–3) will be routed to Busses 31 and 32.

Multilingual Application Support for Pro Tools Systems

(Localized OS on Mac OS X Only)

An English and localized version of Pro Tools (such as Pro Tools Korean, simplified Chinese, or Japanese) can now be opened on a Digidesign-qualified Mac that can run English and the localized language versions of Mac OS X. Only one language version of Pro Tools can be open at a time.

To change to a different language version of Pro Tools:

1. Close Pro Tools if it is currently open.
2. Launch Apple System Preferences.
3. Double-click International (the “flag” icon).
4. Click the Language tab if the Language page is not the current page.
5. In the Languages column, click the language you want to change to, and drag the language to the top of the list.
6. Close the International window.
7. Do one of the following:
   - If you are changing from a localized language to English, launch Pro Tools.
   - or –
   - If you are changing from one localized language to another (or from English to a localized language), log out and log in from the Apple menu, then launch Pro Tools.

⚠️ If you want your computer to start with the previous language (after working on a different language version) follow the above steps and change the International preference back to the previous language.
Part III: Recording
Chapter 11: Record Setup

Before you start recording, make sure your Pro Tools system is connected and configured properly. For details on connecting Pro Tools to your studio, refer to the Getting Started Guide that came with your system.

While some of the information in this chapter is relevant to recording MIDI, there are more specific setup details for MIDI recording in Chapter 13, “MIDI Recording.”

Input Connections and Audio Levels

Pro Tools|HD audio interfaces operate as line-level devices and offer no pre-amplification. Low-level sources like microphones and electric guitars need to be pre-amplified. You can do this with a quality mixing board or dedicated preamp (such as the Digidesign PRE).

The Digi 002 and Digi 002 Rack have four inputs with preamps, to which you can connect low-level signals, and four additional line-level inputs with switchable gain.

Mbox 2 and Mbox have two inputs with preamps, to which you can connect low-level signals.

For input information on Digidesign-qualified M-Audio units, refer to your M-Audio documentation.

For all systems, volume and pan controls for tracks in Pro Tools only affect monitoring levels—not the recording input gain. The LED meters on Digidesign audio interfaces indicate both full-code (highest level before clipping) and true clipping of Pro Tools output signals. The on-screen meters in Pro Tools indicate only true clipping.

Digital Clipping

Clipping occurs when you feed a signal to a recorder or mixer that is louder or “hotter” than the device allows. On many analog tape decks, a little clipping adds a perceived warmth to the sound due to tape compression. In digital recording, however, clipping causes digital distortion, which is undesirable and should always be avoided.
Set Input Levels High But Not High Enough to Clip

When you feed a signal into any audio recording system, including Pro Tools, make sure to adjust the input level to optimize the dynamic range and signal-to-noise ratio of the recorded file. If the input level is too low, you will not take full advantage of the dynamic range of your Pro Tools system. If the input level is too high, the waveform clips and distorts the recording.

Try to set levels so that they register within the top 6 dB of the input meter without triggering the clipping indicator on your audio interface.

Calibration Mode

(Pro Tools HD Only)

You can use the Calibration mode in Pro Tools to adjust the input and output levels for your audio interface so they match those of your mixing console and other audio devices in your studio.

The 192 I/O has two sets of adjustable trim pots for its inputs, and two sets of adjustable trim pots for its outputs. Additionally, the reference level for the input can be set to +4 dBu or –10 dBV. The 888|24 I/O has adjustable trim pots for its inputs and outputs.

There are no input or output trims on the following audio interfaces: 192 Digital I/O, 96 I/O, 96i I/O, 882|20 I/O, 1622 I/O, and 24-bit ADAT Bridge I/O. Some Digidesign I/Os that do not have output trims (such as the 96i I/O) offer software-controllable input levels, adjustable from Setup > Hardware (refer to the guide for your particular I/O).

Record Enabling Tracks

To record to a track you must first record enable it with the Record Enable button. To record simultaneously to multiple tracks, you can record enable multiple audio, Instrument, or MIDI tracks.

When one or more tracks are record-enabled, click the Record and Play buttons in the Transport window to start recording.

MIDI and Instrument tracks can be record-enabled during playback or record. To record enable audio tracks, the Transport must be stopped, or TrackPunch, QuickPunch, or DestructivePunch must be enabled. For more information on TrackPunch, QuickPunch, and DestructivePunch, see “Record Modes” on page 190.

You can digitize video in Pro Tools if you have an Avid video peripheral (such as a Digidesign AVoption|V10) attached. For more information, see Chapter 29, “Working with Video in Pro Tools” or the Avid Video Peripherals Guide.

For more information on calibrating your audio interface, or using Calibration mode, see the 192 I/O Guide (or Calibration Mode Instructions included with earlier shipments of 192 I/O), or the 888|24 I/O Guide.
To record enable an audio, MIDI, or Instrument track:

- From either the Mix or Edit window, click the track’s Record Enable button to toggle record enable on or off for the track. The Record Enable button is lit when on; also, in the Mix window, the track’s fader is highlighted.

To record enable multiple audio tracks:

- From either the Mix or Edit window, click each audio track’s Record Enable button to toggle record enable on or off for each track.

To record enable multiple MIDI and Instrument tracks:

- From either the Mix or Edit window, Shift-click each MIDI or Instrument track’s Record Enable button to toggle record enable on or off for each track.

To record enable MIDI and Instrument tracks using the Up/Down Arrows:

- While pressing Control (Windows) or Command (Mac), press the Up/Down Arrows to record enable the previous or next MIDI or Instrument track. The previous (or next) record track is no longer record-enabled.

To record enable MIDI and Instrument tracks:

- Alt-click (Windows) or Option-click (Mac) the Record Enable button to toggle record enable on or off for all audio, or Instrument and MIDI tracks.

For record-enable, Pro Tools treats MIDI and Instrument tracks as the same type. Consequently, Alt-clicking (Windows) or Option-clicking (Mac) the Record Enable button on any MIDI or Instrument track will record enable all MIDI and Instrument tracks.

To record enable all selected audio, or MIDI and Instrument tracks:

- Alt-Shift-click (Windows) or Option-Shift-click (Mac) the Record Enable button of one of the tracks to record enable all selected tracks.

To keep the previous track record-enabled while enabling new tracks, press Shift+Control+Up/Down (Windows) or Shift+Command+Up/Down (Mac).

To record enable all audio, or MIDI and Instrument tracks:

- Alt-click (Windows) or Option-click (Mac) the Record Enable button on any selected audio, or MIDI or Instrument track to toggle record enable on or off for all selected audio, or MIDI and Instrument tracks.

While record enabling does not affect audio tracks that are grouped, you can select all tracks in a group by clicking directly to the left of the group’s name in the Group List. Then you can Shift-Alt-click (Windows) or Shift-Option-click (Mac) the Record Enable button of one of the tracks to record enable all selected tracks.
**Latch Record Enable Buttons Preference**

When the Latch Record Enable Buttons preference is selected, you can record enable additional audio tracks by clicking their Record Enable buttons. Previously record-enabled tracks will remain enabled. The Latch Record Enable Buttons preference affects audio tracks only.

When the Latch Record Enable Buttons preference is deselected, record enabling a subsequent audio track makes the previously record-enabled audio track no longer record-enabled.

**To enable the Latch Record Enable Buttons preference:**

1. Choose Setup > Preferences and click the Operations tab.
2. Select Latch Record Enable Buttons.

**Record Safe Mode**

Pro Tools provides a Record Safe mode on a per track basis that prevents tracks from being record-enabled. Use Record Safe mode to protect important track recordings.

**To put an audio or MIDI track in Record Safe mode:**

- Control-click (Windows) or Command-click (Mac) the track’s Record Enable button. The Record Enable button is greyed out.

Control-click (Windows) or Command-click (Mac) again to take the track out of Record Safe mode.

**To put all tracks in Record Safe mode:**

- Control-Alt-click (Windows) or Command-Option-click (Mac) the Record Enable button on any track.

Control-Alt-click (Windows) or Command-Option-click (Mac) again to take all tracks out of Record Safe mode.

To put all currently selected tracks into Record Safe mode:

- Control-Alt-Shift-click (Windows) or Command-Option-Shift-click (Mac) the Record Enable button on any of the selected tracks to toggle them in and out of Record Safe mode.

**Record Monitoring Modes**

Pro Tools offers two modes of input monitoring: Auto Input and Input Only. These monitoring modes determine how input signals are monitored during playback, record, or while the transport is stopped.

**Auto Input Monitoring**

In Auto Input mode, when session playback is stopped, Pro Tools monitors audio input. When playback is started for a punch-in, Pro Tools monitors existing track material up until the punch point. While punched in, the input signal is monitored. On punch-out, monitoring switches back to the existing track material. This is similar to the auto-switching logic found on digital and analog multitrack tape machines.

⚠️ When using Auto Input, the switch back to monitoring track material on punch-out is not instantaneous.

💡 With Pro Tools HD, tracks are in Auto Input mode by default, and a monitoring control (TrackInput button) is provided for each track. See “Selecting Record Monitor Modes with TrackInput Monitoring” on page 183.
Input Only Monitoring

In Input Only mode, when a track is record-enabled, Pro Tools monitors audio input only, regardless of any punch-in/out selection or state.

For Pro Tools LE, the Input Monitor Enabled Status indicator (in the Transport window) lights green when Input Only mode is enabled.

For Pro Tools HD, the indicator lights green when one or more tracks have TrackInput enabled.

Selecting Report Monitor Modes with TrackInput Monitoring

(Pro Tools HD only)

TrackInput monitoring lets you toggle individual audio tracks between Auto Input and Input Only monitoring modes at any time, during playback, recording, stop, and even when a track is not record-enabled. TrackInput monitoring provides the monitoring flexibility needed in overdubbing and mixing, and is similar to the input switching on analog multitrack recorders and similar machines.

When the TrackInput button in a track is enabled (green), the track monitors audio in Input Only mode.

When the TrackInput button in a track is disabled, the track monitors in Auto Input mode.

Selecting a Record Monitor Mode in Pro Tools LE

For record-enabled tracks to use Auto Input Monitoring:

- Select Track > Auto Input Monitoring.

For record-enabled tracks to use Input Only Monitoring:

- Select Tracks > Input Only Monitoring.

To toggle between Auto Input and Input Only monitoring, press Alt+K (Windows) or Option+K (Mac).

Transport window

For Pro Tools HD, the indicator lights green when one or more tracks have TrackInput enabled.

Selecting Record Monitor Modes with TrackInput Monitoring

(Pro Tools HD Only)

TrackInput monitoring lets you toggle individual audio tracks between Auto Input and Input Only monitoring modes at any time, during playback, recording, stop, and even when a track is not record-enabled. TrackInput monitoring provides the monitoring flexibility needed in overdubbing and mixing, and is similar to the input switching on analog multitrack recorders and similar machines.

When the TrackInput button in a track is enabled (green), the track monitors audio in Input Only mode.

When the TrackInput button in a track is disabled, the track monitors in Auto Input mode.
To toggle the TrackInput button states of all record-enabled tracks, do one of the following:

- To change all record-enabled tracks to Auto Input monitoring, select Track > Set Record Tracks to Auto Input.
- To change all record-enabled tracks to Input Only monitoring, select Tracks > Set Record Tracks to Input Only.

To toggle record-enabled tracks between Auto Input and Input Only monitoring, press Alt+K (Windows) or Option+K (Mac).

Disable “Input” When Disarming Track

With this Operation preference checked, Track-Input monitoring will be disabled whenever deselecting a track’s record Enable button. This is useful for certain workflows, such as when you are recording on a series of tracks, one at a time.

Disabling this option allows TrackInput buttons to remain enabled when deselecting the track’s Record Enable button.

Monitor Levels for Record and Playback

Pro Tools remembers two different fader levels for monitoring each audio track: one for when the track is record-enabled, and one for when it is not record-enabled.

Pro Tools keeps track of these two states for fader levels automatically. If you adjust a fader when a track is record-enabled and then turn off record enable for the track, the fader returns to its playback level.

When audio tracks are record-enabled, their volume faders in the Mix window turn red, indicating that the record monitor level is active.

Link Record and Play Faders

When the Operation preference for “Link Record and Play Faders” is selected, Pro Tools does not keep track of record and play levels for audio tracks. In this case, record enabling an audio track has no effect on the fader level for the track. This lets you maintain a consistent mix regardless of whether you’re recording or just listening.

Monitoring Latency

(Pro Tools LE)

Because Pro Tools LE uses the host processor in your computer for all audio processing, playback and recording, there is a small amount of audio delay, or latency, in the system. This latency amount is related to the H/W Buffer Size—the larger the buffer size the larger the latency.

You can reduce the amount of monitoring latency for Pro Tools LE systems by reducing the H/W Buffer Size. However, even at the smallest buffer size, there is still some latency. In addition, reducing the buffer size limits the number of simultaneous audio tracks you can record without encountering performance errors.

While there may be times when you want a larger buffer size, for the sake of higher track counts with more plug-ins, you’ll generally want a smaller buffer size when recording audio that is monitored through your Pro Tools LE system.

If you are monitoring the recording source with an external mixer, before it is routed to Pro Tools, you will not hear any latency.
To set the Hardware Buffer Size:

2. Choose the number of samples from the H/W Buffer Size pop-up menu.
3. Click OK.

⚠️ Computers with slower CPUs may not be able to use the 128 buffer size without encountering performance errors.

Zero Latency Monitoring
(Mbox 2 and Mbox Only)

Mbox 2 and Mbox give you the ability to monitor your analog input signals while recording, without hearing any latency. This zero-latency analog monitoring is controlled by the front panel Mix knob, which you can use to blend and adjust the ratio between the interface’s analog input and Pro Tools playback. For more information, refer to your system’s Basics Guide or its Getting Started Guide.

Low Latency Monitoring
(Digi 002 and Digi 002 Rack Only)

Digi 002 and Digi 002 Rack systems can use the Low Latency Monitoring option to record with an extremely small amount of monitoring latency, to as many tracks as each system supports.

To use Low Latency Monitoring:

1. Record enable audio tracks by clicking their Record Enable buttons. Only tracks with inputs set to an audio interface (not a bus) use Low Latency Monitoring.
2. From the Output Path selector, assign each track to either Output 1 or Output 2. Only tracks assigned to these outputs use Low Latency Monitoring.

3. Select Options > Low Latency Monitoring.

When Low Latency Monitoring is enabled, any plug-ins and sends assigned to record-enabled tracks (routed to Outputs 1–2) are automatically bypassed, and must remain bypassed. Also, these tracks will not register on meters for Master Faders.

Low Latency Monitoring and Bounce To Disk

With Low Latency Monitoring enabled, only audio tracks are included with the Bounce to Disk command—Auxiliary Input and Instrument tracks are ignored. To include Auxiliary Input and Instrument tracks, turn off Low Latency Monitoring before using Bounce to Disk.

⚠️ External input cannot be recorded during a Bounce to Disk. To include external input in your bounce, it must be recorded to new audio tracks before using Bounce to Disk (see “Recording to Tracks” on page 637).

Low Latency Monitoring with Delay Compensation
(Pro Tools HD Only)

If you choose to record with Delay Compensation active, Pro Tools automatically suspends Delay Compensation for tracks that are “punched in” or monitoring input. In either of these cases, no compensating delay is added to the track, and the Track Compensation indicator displays zero.

Delay Compensation should be enabled whenever possible during mixing and playback. In some cases when recording, Delay Compensation should be turned off.
The automatic suspension of Delay Compensation on record-enabled tracks during recording can be defeated on a per-track basis, regardless of record status or input mode.

For information about defeating suspended Delay Compensation, see “Low Latency Monitoring During Recording” on page 355.

Default Track Names

When creating new audio, Auxiliary Input, Master Fader, VCA Master, MIDI, and Instrument tracks, Pro Tools names them as “Audio,” “Aux,” “Master,” “VCA,” “MIDI,” or “Inst” accordingly and numbers them consecutively. For example, when you create two new audio tracks, their default names are “Audio 1” and “Audio 2.” You can rename tracks and also log comments for each track.

Track names define new file and region names when recording to a track. See “Naming Tracks” on page 103.

Default Names for Audio Files and Regions

When recording to an audio track, the resulting file and region names are based on the name of the track. For example, after recording for the first time on a track called “Electric Gtr,” an audio file is created with the name “Electric Gtr_01.” In addition, a region appears in the Region List with the name “Electric Gtr_01.” This region is a whole-file region.

Subsequent record takes on the same track are named identically, but the digits (indicating the take number) are incremented (for example, “Electric Gtr_02”.) A second set of digits (such as used in “Electric Gtr_01-01”) indicates a region auto-created from an edit.

TrackPunch, QuickPunch, Destructive Punch modes use a different method for numbering regions. For details, see “Region and Take Numbering with QuickPunch” on page 326.

When recording MIDI tracks, a similar naming scheme is used, though with only one set of digits. For example, after recording to a track called “Synth 1,” a region is created called “Synth 1-01.” Subsequent regions for that track, generating either from additional record takes or region edits, are numbered sequentially (for example, “Synth 1-02”).

Names for Stereo Audio Tracks

When recording to stereo audio tracks, audio file and region names for the left and right channels are appended with a “.L” and “.R” suffix.
Names for Multichannel Tracks
(Pro Tools HD Only)

When recording to multichannel surround tracks, audio file and region names for each channel are appended with the following suffixes.

<table>
<thead>
<tr>
<th>Multichannel format</th>
<th>File and Region Suffixes</th>
</tr>
</thead>
<tbody>
<tr>
<td>LCR</td>
<td>L, C, R</td>
</tr>
<tr>
<td>Quad</td>
<td>L, R, Ls, Rs</td>
</tr>
<tr>
<td>LCRS</td>
<td>L, C, R, S</td>
</tr>
<tr>
<td>5.0</td>
<td>L, C, R, Ls, Rs</td>
</tr>
<tr>
<td>5.1</td>
<td>L, C, R, Ls, Rs, LFE</td>
</tr>
<tr>
<td>6.0</td>
<td>L, C, R, Ls, Cs, Rs, LFE</td>
</tr>
<tr>
<td>6.1</td>
<td>L, C, R, Ls, Cs, Rs</td>
</tr>
<tr>
<td>7.0</td>
<td>L, Lc, C, R, Rc, Ls, Rs</td>
</tr>
<tr>
<td>7.1</td>
<td>L, Lc, C, R, Rc, Ls, Rs, LFE</td>
</tr>
</tbody>
</table>

Navigating in the Disk Allocation Window

To resize the Disk Allocation window:
- Drag the lower-right corner of the window according to standard convention for your operating system (Windows or Mac).

To scroll up or down in the Disk Allocation window:
- Press Page Up or Page Down.

Allocating Audio Drives in Your System

To allocate the audio drives in your system:
2. In the Disk Allocation window, assign a hard drive for each track by clicking in the Root Media Folder column and selecting a volume from the Disk Allocation pop-up menu.

Only drives designated as R (Play and Record) can be selected in the Disk Allocation window. For more information, see the DigiBase Guide.

Disk Allocation

By default, Pro Tools records audio files to the Audio Files folder inside the session folder. You can use the Disk Allocation window to specify other locations for your audio files for each audio track.

Hard drives that are full do not appear in the Disk Allocation window.

To increase system performance, Pro Tools can record and play each track from a different hard drive. You can also automatically distribute any newly created tracks to multiple audio drives with Round Robin Allocation.
A folder with the session name is created on each hard drive, containing subfolders for audio and fade files.

- To assign a track to a different hard drive, click the track and select a drive name.
- To assign all tracks to the same hard drive, press Alt (Windows) or Option (Mac) while selecting a drive name.
- To make a continuous selection, Shift-click a track name (in the Track column) to extend the selection to include already-selected tracks and all tracks in between.
- To make a non-contiguous selection, Control-click (Windows) or Command-click (Mac) a track name in the Track column to extend the selection to include already-selected tracks without including tracks in between.

3 To save recorded audio files to an existing folder (without creating another session folder), select Customize Allocation Options, then click the Change button and choose the folder. To create subfolders in this folder, select “Create Subfolders for audio, video, and fade files.”

4 To automatically distribute any newly created tracks among the drives connected to your system, select “Use Round Robin Allocation for New Tracks.”

If you are using Round Robin Allocation and want audio to be recorded to your system’s startup drive, do the following:

- Open the Workspace browser (Window > Workspace) and set the Volume Designator for your system volume to R (Record and Playback). See “Workspace Volume Designation” on page 189.

⚠️ Round Robin Allocation is not supported with partitioned hard drives.

If you want to exclude individual, valid, mounted volumes from Round Robin Allocation passes, open the Workspace browser and make the volume safe, by designating it as P (Playback only) or T (Transfer).

5 When you are finished, click OK.

**Saving Disk Allocation Settings**

To save Disk Allocation settings for use with future sessions, save the session as a template. For details, see “Creating Custom Session Templates” on page 57.

**Disk Allocation and Cross-Platform Sessions**

To ensure cross-platform operation, it is required that Mac Pro Tools sessions and their associated audio files be on Mac-formatted (HFS or HFS+) drives. Windows Pro Tools sessions and their associated audio files must be on Windows-formatted (NTFS or FAT32) drives.

See “Saving Copies of Mac Sessions to be Compatible with Windows” on page 168 and “Sharing Sessions Created on Different Computer Platforms” on page 166.

**Reallocation Tracks**

When opening a session where some of the previously assigned hard drives are no longer available (or do not match the current session platform), Pro Tools automatically reassigns tracks to the volume where the session file is stored. In such cases, use Disk Allocation if you need to reallocate tracks to other drives.

 reallocating tracks does not affect the previously recorded audio. reallocating tracks only affects where new audio recording is saved.
Workspace Volume Designation

The Workspace volume designation can alter disk availability, thus affecting Disk Allocation. From the Workspace browser, you can designate volumes as Record, Playback, or Transfer. If you change a drive’s designation, making it read-only (Play Only or Transfer), you also need to check the Disk Allocation for any tracks formerly allocated to that drive. For more information, see the DigiBase Guide.

Recording to the System Volume

Though Pro Tools will let you record to your system volume, this is generally not recommended. Performance for audio recording and playback on system drives is worse than on non-system hard drives.

You should record to system drives only when absolutely necessary—if your computer system has just the one hard drive, or if your other hard drives are completely out of space.

By default, the system volume is not included in Round Robin Allocation (regardless of volume designation in the Workspace browser). To include the System Volume in Round Robin Allocations, see “To allocate the audio drives in your system:” on page 187.

Allocating Hard Drive Space for Recording

The Operation preference for Open Ended Record Allocation determines how much of your available hard drive space is allocated whenever you record into one or more tracks in Pro Tools.

When this allocation preference is set to Use All Available Space, the drive’s entire available space is allocated. This setting lets you record lengthy takes, or longer sessions.

However, when allocating all available space, Pro Tools may take a little longer to begin recording. You can reduce this delay by allocating a specific amount of time for recording.

💡 You can also avoid recording delays by putting Pro Tools in Record Pause mode before beginning to record. See “Record Pause Mode” on page 201.

In general, the Use All Available Space preference makes hard drives work harder. In addition to record and punch lag times, many system see better overall recording performance when the Open Ended Record Allocation is limited.

To allocate a specific amount of time to recording:

1. Choose Setup > Preferences and click the Operation tab.
2. Under the Open Ended Record Allocation option, select Limit To and enter the number of minutes to be allocated.
3. When you are finished, click OK.
Monitoring Drive Space

To monitor available space on your drive during a Pro Tools session:
- Choose Window > Disk Space.

To display available drive space in different view formats:
- Choose View > Disk Space, and select a format (Text View or Gas Gauge).

Record Modes

For recording audio, Pro Tools has the following record modes:
- Nondestructive Record (default)
- Destructive Record
- Loop Record
- QuickPunch
- TrackPunch (Pro Tools HD only)
- DestructivePunch (Pro Tools HD only)

To enable Destructive Record, Loop Record, QuickPunch, TrackPunch, or DestructivePunch, select them from the Options menu. If none of these record modes are selected, Pro Tools is in normal Nondestructive Record mode.

Nondestructive Record Mode

In normal Nondestructive Record mode, Pro Tools records audio nondestructively, which means that if you record over a track’s existing regions, the audio is not erased from your hard drive. Both the new and old audio files remain on your hard drive, available as regions from the Region List.

In Nondestructive Record mode, the record range can be defined by selecting a range in a ruler or in a track’s playlist, or by specifying start and end points in the Transport window. If there is no selection, recording begins from the current Cursor location and continues until the Transport’s Stop button is clicked.

To set a record range by selecting within a track’s playlist, the Timeline and Edit selections must be linked. See “Linking or Unlinking Timeline and Edit Selections” on page 308.

The pre- and post-roll settings allow material to be heard up to and after the start and end points, which is useful when punch recording (see “Punch Recording Audio” on page 203).
Destructive Record Mode

In Destructive Record mode, recording over existing regions replaces the original audio permanently, which allows you to keep disk use to a minimum. However, if you have sufficient drive space, it is usually best to use Pro Tools in Nondestructive Record mode, to avoid losing any previously recorded material.

When defining the record range and setting pre- and post-roll, Destructive Record mode works the same as Nondestructive mode.

Unlike the other record modes, it is not possible to cancel or Undo record takes when using Destructive Record mode (see “Canceling a Record Take” on page 200).

⚠️ In Destructive Record mode, the waveform overview is not redrawn until you stop recording.

Loop Record Mode

Loop Record mode allows you to record take after take (nondestructively) while the same section of audio repeats. This is a convenient technique for quickly recording multiple takes of a part without losing spontaneity.

The time range that is looped and recorded—which must be at least one second in length—is defined by selecting a range in a ruler or in a track’s playlist, or by specifying start and end points in the Transport window. The pre-roll setting, if enabled, is used during the first record pass, but on each successive loop the pre- and post-roll times are ignored.

⚠️ To set a record range by selecting within a track’s playlist, the Timeline and Edit selections must be linked. See “Linking or Unlinking Timeline and Edit Selections” on page 308.

When using Loop Record mode, each successive take appears as a region in the Region List and each is numbered sequentially. The various takes, which are identical in length and start time, are easily auditioned and placed in the track at the correct location with the Matches pop-up menu (see “Auditioning Different Record Takes in the Timeline” on page 205).

⚠️ In Loop Record mode, the waveform overview is not redrawn until you stop recording.

QuickPunch

QuickPunch gives you the ability to manually and instantaneously punch in (initiate recording) and punch out (stop recording) on record-enabled audio tracks during playback by clicking the Transport’s Record Enable button. Recording with QuickPunch is nondestructive.

When using QuickPunch, Pro Tools begins recording a new file when playback begins, automatically generating regions in that file at each punch in/out point. These regions appear in the track’s playlist; and the complete audio file appears in the Region List along with the QuickPunch created regions. Up to 200 of these “running punches” can be performed in a single pass.

Though you can punch record in the other record modes by manually specifying the record range, only QuickPunch provides instantaneous monitor switching on punch-out.

⚠️ For more information on QuickPunch, see “QuickPunch Audio Recording” on page 233.
TrackPunch
(Pro Tools HD Only)

TrackPunch lets individual tracks be punched in, punched out, and taken out of record enable without interrupting online recording and playback.

TrackPunch is a non-destructive recording mode. When a track is TrackPunch-enabled, Pro Tools begins recording a new file when playback begins. During playback, you may record arm or disarm, or punch in or out a combination of any or all TrackPunch enabled tracks.

TrackPunch automatically creates regions in that file at each punch-in and punch-out point. These regions appear in the track’s playlist, and the complete audio file appears in the Region List along with the TrackPunch created regions. Up to 200 of these “running punches” can be performed in a single pass.

For more information on TrackPunch, see “TrackPunch Audio Recording” on page 236.

DestructivePunch
(Pro Tools HD Only)

Destructive Punch is a destructive recording mode that lets you instantaneously punch in (start recording) and punch out (stop recording) on individual audio tracks during playback, while preserving a contiguous audio file on each punched track.

For more information on DestructivePunch, see “DestructivePunch Audio Recording” on page 245.

Record Modes and MIDI

In addition to the various record modes, there is also a MIDI Merge button in the Transport window that determines how MIDI is recorded. When enabled (Merge mode), recording over existing MIDI regions results in the new data being merged with the old. When the MIDI Merge button is disabled (Replace mode), the new material replaces the old.

MIDI recording works the same whether using Nondestructive or Destructive Record mode. In addition, neither QuickPunch nor TrackPunch need to be enabled to punch on-the-fly with MIDI—this capability is available in Nondestructive and Destructive Record modes.

Unlike audio loop recording, the state of the MIDI Merge toggle determines whether existing material is replaced or merged.

Unless MIDI Merge is enabled, MIDI recording is destructive (though you can undo a MIDI record pass), either overwriting or adding to region material. One exception to this rule is when Loop Record mode is enabled; in this mode, existing track regions are replaced with new regions when new material is recorded. The old regions remain intact and available from the Region List, and from the Matches pop-up menu. In Loop Record mode, MIDI Merge has no effect, so its button is dimmed.
Recording with a Click

If you intend to work with MIDI or Instrument tracks in your session, or if the audio you’re working with is bar and beat-oriented, you can record your tracks while listening to a click. This ensures that recorded material, both MIDI and audio, aligns with the session’s bar and beat boundaries.

When your track material lines up with the beats, you can take advantage of some useful editing functions in Pro Tools, such as quantizing MIDI and audio regions, quantizing individual MIDI notes, and copying and pasting measures and song sections in Grid mode.

Material that is recorded without listening to a click can still be aligned to bar and beat boundaries in Pro Tools with Beat Detective (see Chapter 21, “Beat Detective”), or use the Identify Beat command to determine the tempo (see “Identify Beat Command” on page 416).

You can record MIDI with or without a click and manually add Bar|Beat markers or generate a tempo and meter map from it by using Beat Detective. See Chapter 21, “Beat Detective.”

Pro Tools provides a built-in click generator, the DigiRack Click plug-in. Click includes presets with different click sounds, supports accented and unaccented click sounds, and lets you adjust their volumes. Click is integrated directly into Pro Tools, avoiding MIDI time delays. Refer to the DigiRack Plug-ins Guide for details.

Pro Tools also provides options and controls for driving a click using MIDI. The following steps are for configuring and enabling a click using MIDI.

To configure click options:

1. Open the Click/Countoff Options dialog by doing one of the following:
   - Choose Setup > Click.
   - or –
   - Double-click the Metronome Click or Countoff button in the Transport window.

2. In the Click/Countoff Options dialog, do one of the following:
   - If using the DigiRack Click plug-in, select None in the Output pop-up menu. (For information on using the Click plug-in, see the DigiRack Plug-ins Guide.)
   - or –
   - If playing a click using MIDI, select the port number (device) and channel that will play the click from the Output pop-up menu.

   You can record MIDI with or without a click and manually add Bar|Beat markers or generate a tempo and meter map from it by using Beat Detective. See Chapter 21, “Beat Detective.”

   Material that is recorded without listening to a click can still be aligned to bar and beat boundaries in Pro Tools with Beat Detective (see Chapter 21, “Beat Detective”), or use the Identify Beat command to determine the tempo (see “Identify Beat Command” on page 416).

   Pro Tools provides a built-in click generator, the DigiRack Click plug-in. Click includes presets with different click sounds, supports accented and unaccented click sounds, and lets you adjust their volumes. Click is integrated directly into Pro Tools, avoiding MIDI time delays. Refer to the DigiRack Plug-ins Guide for details.

   Pro Tools also provides options and controls for driving a click using MIDI. The following steps are for configuring and enabling a click using MIDI.
4 Select whether the click is heard “During play and record,” or “Only during record,” or “Only during countoff.”

5 If using a countoff, specify the number of Bars to be counted off. To hear the countoff only when recording, select that option.

6 Click OK.

To enable a click from the MIDI menu:

■ Select Options > Click.

To enable a click in the Transport:

1 To view the MIDI controls in the Transport, do one of the following:
   • Select View > Transport > MIDI Controls.
   • Control-click (Windows) or Command-click (Mac) the Expand/Collapse “+” button in the Transport window to display the MIDI controls.
   • Alt-click (Windows) or Option-click (Mac) the Expand/Collapse “+” button in the Transport window to display the MIDI controls and the Counters.

2 In the Transport, click the Metronome Click button so it becomes highlighted.

3 To use a countoff when recording or playing, click the Countoff button in the Transport so it too becomes highlighted.

Hearing the countoff before recording is helpful in getting the feel for the tempo before you begin playing. The Countoff button in the Transport window displays the number of bars to be counted off.

The countoff is ignored when Pro Tools is online and synchronized to SMPTE time code.

Wait for Note and Countoff

Wait for Note and Countoff are mutually exclusive and cannot both be enabled at the same time. If, for instance, Countoff is enabled and you click the Wait for Note button, Countoff is disabled.

Setting the Default Meter and Tempo

Setting the Default Meter

When opening a new session in Pro Tools, the meter defaults to 4/4. If you intend to record with a click and are working with a different meter, make sure to set the default meter accordingly.
If a session’s meter does not match the music you’re recording, the accented clicks will not line up with what you’re playing, and, as a result, the recorded material may not align with the bars and beats in the Edit window.

⚠️ Beat Detective requires identical meters to work with DigiGrooves. For example, if Beat Detective extracts the feel from a bar of 3/4, it can only be applied to another bar of 3/4.

Meter events, which can occur anywhere within a Pro Tools session, are stored in the Meter Track and appear in the Meter ruler. For more information on inserting and editing meter events, see “Meter Events” on page 420.

To set the default meter for a session:
1. Double-click the Current Meter button in the Transport window.
2. Enter the Meter you will use for the session and set the Location to 1|1|000 (so the inserted meter event replaces the default one).
3. Choose a note value for the number of clicks to sound in each measure.
4. Click OK to insert the new meter event.

Setting the Default Tempo

When opening a new session in Pro Tools, the tempo defaults to 120 BPM. If you intend to record with a click and are working with a different tempo, make sure to set the default tempo accordingly. If you know the tempo you will use for the session, you can insert a tempo event at the beginning of the Tempo track.

Tempo events, which can occur anywhere within a Pro Tools session, are stored in the Tempo track and appear in the Tempo ruler. For more information on inserting and editing tempo events, see “Tempo” on page 400.

To insert a default tempo event:
1. Double-click the Song Start Marker in the Edit window.
2. Enter the BPM value you will use for the session and set the Location to 1|1|000 (so the inserted tempo event replaces the default tempo).
3. To base the BPM value on something other than the default quarter-note, select another note value from the Resolution pop-up menu.
4. Click OK to insert the new tempo event.
See “Song Start Marker” on page 399 for more information on the default tempo.

**Using Manual Tempo Mode**

In *Manual Tempo* mode, Pro Tools can ignore the tempo events in the Tempo track and instead play back a Manual Tempo. This tempo can be set with the Tempo slider, or if you are not sure of the actual tempo, by tapping in the tempo.

While you can adjust the Manual Tempo during playback, doing so momentarily interrupts playback.

**To set the Manual Tempo with the Tempo slider:**

1. To view the MIDI controls in the Transport window, select View > Transport > MIDI Controls.
2. In the Transport window, click the Tempo Ruler Enable button (Conductor) button so it becomes unhighlighted. Pro Tools switches to Manual Tempo mode. In this mode, any tempo events in the Tempo track are ignored.
3. To base the BPM value on something other than the default quarter-note, click the Tempo Resolution selector and select a different note value.
4. To enter a new tempo, drag the horizontal Tempo slider in the Transport window.

For finer resolution with the Tempo slider, press Control (Windows) or Command (Mac) while dragging.

**To exit Manual Tempo mode and enable the Tempo track:**

- Click the Tempo Ruler Enable (Conductor) button in the Transport window so it becomes highlighted.

**To set the Manual Tempo by tapping:**

1. To view the MIDI controls in the Transport window, select View > Transport Window > MIDI Controls.
2. In the Transport window, click the Tempo Ruler Enable (Conductor) button so it becomes unhighlighted. Pro Tools switches to Manual Tempo mode. In this mode, any tempo events in the Tempo track are ignored.
3. Do one of the following:
   - Click in the Tempo field so it becomes highlighted and tap the "T" key on your computer keyboard repeatedly at the new tempo.
   - or –
   - Click in the Tempo field so it becomes highlighted and tap in the tempo by playing a note repeatedly at the new tempo on your MIDI keyboard controller.

To compute the new tempo, Pro Tools averages the last eight (or fewer) taps to determine the correct tempo. The computed BPM value appears in the Transport’s Tempo field.

**To lock in the new tempo:**

- Take Pro Tools out of Manual Tempo mode by clicking the Tempo Ruler Enable (Conductor) button, then set the default tempo for the Song Start Marker to the new tempo.
Chapter 12: Basic Audio Recording

Recording an Audio Track

When recording from a mono source, record to a single, mono audio track in Pro Tools. A single, mono audio file is written to disk; the region appears in the playlist and in the Region List.

To record a stereo audio source in Pro Tools, record to a single, stereo audio track. A single, mono audio file is written to disk for each channel of a stereo track; one for the left channel, and one for the right channel; regions appear in the playlists for both channels. In addition, a multichannel (stereo) region appears in the Region List.

Recording multichannel tracks (Pro Tools HD only) is very similar to recording stereo audio tracks. A single, mono audio file is written for each channel in the track, and regions appear in the playlists for each channel. In addition, a multichannel region for each track appears in the Region List.

For more information on multichannel tracks, see “Multichannel Audio Tracks” on page 706.

To configure an audio track for recording:

1. Connect a mono or stereo sound source to the appropriate input of your audio hardware.

2. Make sure to specify the format (analog or digital) of the inputs of the audio interface you will be using. Choose Setup > Hardware, choose the audio interface, and select the format for the channel pair.

Some Digidesign I/O units (such as Mbox 2), have only two channels that can be set for analog or digital.

3. If a track does not already exist, choose Track > New and specify 1 Mono or Stereo Audio Track, then click Create.

4. If desired, rename the track. Track names are used to auto-name recorded audio files and regions. For more information, see “Default Track Names” on page 186.
5 Assign a hardware input by doing one of the following:
   • In the Mix window, use the track’s Input Path selector to assign a hardware input.
   – or –
   • In the Edit window, with I/O View enabled, use the track’s Input Path selector to assign a hardware input.

6 Assign a hardware output by doing one of the following:
   • In the Mix window, click the track’s Output Path selector and assign a hardware output.
   – or –
   • In the Edit window, with I/O View enabled, use the track’s Output Path selector to assign a hardware output.

7 Record enable a track by doing one of the following:
   • In the Mix window, click the audio track’s Record Enable button to record enable the track. The Record Enable button flashes red, while the fader stays solid red, and the Transport Window Record Enable button turns red (indicating at least one track is record-enabled).
   – or –
   • In the Edit window, click the Track Record Enable button to record enable the track.

8 Adjust the output level of your sound source (instrument, mixer, or preamp). Monitor the track’s meter levels in Pro Tools to ensure that you get the highest possible signal without clipping.
Do one of the following:

- In the Mix window, adjust the track's volume and pan faders. These settings are for monitoring purposes only and do not affect the recorded material.

- or -

- In the Output window for the track, adjust the track's Volume fader and Pan sliders. These settings are for monitoring purposes only and do not affect the recorded material. (See “Output Windows for Tracks and Sends” on page 543.)

To record to an audio track:

1. With Pro Tools HD, make sure that Delay Compensation is deselected in the Options menu.

2. In the Options menu, deselect Destructive Record, Loop Record, QuickPunch, TrackPunch, and DestructivePunch.

3. Enable Click and Countoff in the Transport window if you want to use these features. For details, see “Recording with a Click” on page 193.

4. If you are using meter and tempo information, specify the session’s default meter and tempo. For details, see “Setting the Default Meter and Tempo” on page 194.

5. In the Transport window, click Return to Zero so the start and end times are cleared. This ensures that you'll start recording from the beginning of the track.

6. Click Record in the Transport window to enter Record Ready mode. The Record Enable button flashes.

7. When you are ready to begin recording, click Play. If using Countoff, Pro Tools counts off the specified number of measures and then begins recording.

8. When you have finished recording, click Stop in the Transport window.

The newly recorded audio is written to disk and appears as an audio region in the track’s playlist. The new audio region also appears in the Region List.

To play back the audio track:

1. Click the Record Enable button for the audio track so that it is no longer record-enabled. Track volume faders now function as playback level controls.

2. In the Transport window, click Return to Zero to start playback from the beginning of the session.

3. Click Play in the Transport window to start playback. Adjust the track’s volume and pan faders.

Undo or Cancel AudioRecording

Once you’ve recorded an audio track and the transport is stopped, you can undo the previous record take.
To undo an audio recording:

■ Once the Transport has been stopped, choose Edit > Undo Record Audio.

The track’s playlist is restored to its previous state, and the following material is discarded:

- When in normal Record mode, the previous take is discarded.
- When in Loop Record mode, all takes from each record pass are discarded.
- When using QuickPunch, TrackPunch, or DestructivePunch mode, all punches from the last recording pass are discarded.

⚠ If you undo a record pass during recording, Pro Tools will remove any previously undone record pass from the session, and gives you the option of deleting the previous record pass from your hard drive.

If no actions are available to undo, the menu displays a grayed out Can’t Undo.

Canceling a Record Take

While recording, it is possible to discard the current record take. This removes the audio (recorded up to that point) from your hard drive and deletes the region from the track’s playlist. This capability is not available in Destructive Record mode.

To cancel a record take while recording:

■ Press Control+Period (.) (Windows) or Command+Period (.) (Mac) before the Transport is stopped.

When using Loop Record mode, all takes from each record pass are discarded.

Recording Multiple Audio Tracks

Pro Tools can record multiple audio tracks simultaneously, up to the track recording limits of your system. To record to multiple tracks, configure and record enable each track, then record. Follow the same steps as in “Recording an Audio Track” on page 197.

For each record-enabled track, a new audio file is written to disk and a new region is created and appears in the playlist. The new audio regions appear in the Region List.

Record Shortcuts

In addition to clicking the Record Enable button in the Transport window, you can also begin recording with the following keyboard shortcuts:

- Press F12 to start recording immediately.

⚠ On Mac systems, to use F12 for recording, the Mac “Dashboard” feature must be disabled or remapped. See your Getting Started Guide for details.

- Press Control+Spacebar (Windows) or Command+Spacebar (Mac) to start recording.

⚠ On Mac systems, to use Command+Spacebar for recording, the Mac “Spotlight” feature must be disabled or remapped. See your Getting Started Guide for details.

- Press 3 on the numeric keypad (when the Numeric Keypad mode is set to Transport) to start recording.

⚠ To initiate recording at half-speed, press Control+Shift+Spacebar (Windows) or Command+Shift+Spacebar (Mac). For details, see “Half-Speed Recording and Playback” on page 214.
Record Pause Mode

When recording a large number of tracks or channels, or playing back a large number of tracks while recording, Pro Tools may take a little longer to begin recording. To avoid this delay, put Pro Tools in Record Pause mode before beginning to record.

To record from Record Pause mode:

1. Click Record Enable in the Transport window. The Record Enable button flashes.

2. Alt-click (Windows) or Option-click (Mac) Play in the Transport window to put Pro Tools in Record Pause mode. The Play and Record Enable buttons flash.

3. To begin recording instantaneously, click Play. When you have finished recording, click Stop in the Transport window.

Tips: Use Pause mode when recording or playing large numbers of tracks to speed up lock-up time when synchronizing to time code.

Recording Additional Takes

After recording to an audio track, you can record additional takes to the same track. However, if you record these additional takes in Destructive Record mode, the audio residing on your hard drive from the previous takes will be permanently lost.

To keep the audio from previous takes, record the new takes nondestructively in Nondestructive Record mode.

To nondestructively record a new take on the same track:

1. Put Pro Tools in Nondestructive Record mode. In the Options menu, deselect Destructive Record, Loop Record, QuickPunch, TrackPunch, or DestructivePunch if selected.

2. Make sure the track containing the previous take is still record-enabled.

3. Do one of the following:
   - To record from the beginning of the track, click Return to Zero in the Transport window.
   - If Options > Link Timeline and Edit Selection is enabled, click anywhere in the track’s playlist to begin recording from that point.

4. Click Record Enable in the Transport window. When you are ready to begin recording, click Play.

5. When you have finished recording, click Stop in the Transport window.

An audio file for the new take is written to disk and appears as an audio region in the track’s playlist. The new audio region appears in the Region List.

The audio from the original take remains on your hard drive, and is still available as a region in the Region List.

For details on audio file and region names for new takes, see “Default Track Names” on page 186.
To destructively record over a previous take:

1. Select Options > Destructive Record. When using Destructive Record mode, a “D” appears in the Record Enable button.

2. Make sure the track containing the previous take is still record-enabled.

If Options > Link Timeline and Edit Selection is enabled, click anywhere in the track’s playlist to begin recording from that point.

3. Do one of the following:
   - To record from the beginning of the track, click Return to Zero in the Transport window.
   - or -
   - If Options > Link Timeline and Edit Selection is enabled, click anywhere in the track’s playlist to begin recording from that point.

4. Click Record Enable in the Transport window. When you are ready to begin recording, click Play.

5. When you have finished recording, click Stop in the Transport window.

The audio for the new take is written to disk, permanently overwriting the original. The new material replaces the original material within the existing region and the region is not renamed.

Appending New Material to the End of a Track

You can also append new material to the end of a track. To do this, locate to the end of the track with the Go to End button in the Transport window (this will locate the end of the session), or tab to the end point of the last region on the track. From there, begin recording and Pro Tools adds the new material to the end of the track. If using Destructive Record mode, the new audio is appended to the audio file and region from the first take. In Nondestructive Record mode, a new file and region are created.

Recording to a New Playlist

Instead of recording over existing audio regions, there is another way to nondestructively record new takes to the same track. Do this by creating a new playlist for the track, then record just as before.

Tracks can have multiple edit playlists, each of which stores a list of regions strung together in a particular order. Also, since playlists follow groups, duplicating or selecting alternate playlists for a track in an enabled group will affect all tracks in the group.

To record to a new playlist for a track:

1. Click the track’s Playlist selector and choose New.

2. Enter a name for the new playlist and click OK.
When a new playlist is created, its name replaces the track name. With this playlist active, names for new audio files and regions are based on its name.

3 Make sure the track is still record-enabled.

4 In the Transport window, click Return to Zero.

5 Click Record in the Transport window. When you are ready to begin recording, click Play.

6 When you have finished recording, click Stop in the Transport window.

An audio file for the new take is written to disk and appears as an audio region in the track’s playlist. The new audio region appears in the Region List.

7 To audition the new take, click Play in the Transport window.

8 To go back to a previous playlist to compare it to the new take, click the track’s Playlist selector and select the previous playlist.

Selecting a playlist recalls its regions as they previously appeared in the track. At any time, all regions from all playlists are available in the Region List, and can be mixed and matched between playlists and tracks.

To set a record or play range by selecting within a playlist, the Edit and Timeline selections must be linked (select Options > Link Timeline and Edit Selection).

During the recording process, playback begins at the pre-roll time (if enabled) and proceeds to the start time (the punch-in point), where recording begins. When the end time (the punch-out point) is reached, Pro Tools automatically switches out of Record mode and continues playing through the specified amount of post-roll. This automated punch-in/out feature is a powerful and precise way of recording or re-recording a portion of a track.

To punch record on an audio track:

1 Do one of the following:
   - To record nondestructively, make sure that Options > Destructive Record is not selected.
   - or –
   - If you do want to permanently record over the specified record range, select Options > Destructive Record.

2 Make sure the track to which you want to record is record-enabled.

3 Make sure to select Options > Link Timeline and Edit Selection.

Though there are several ways to set record and play ranges (see “Setting Punch/Loop Points” on page 208), perhaps the easiest is to select within the track’s playlist the range for recording.

Punch Recording Audio

To define a record range in the playlist, or replace a portion of a recorded track, you can punch in by specifying the record range before recording.

For more information on playlists and playlist editing, see “Playlists” on page 270.

To manually punch in and out on record-enabled audio tracks during playback, refer to Chapter 14, “Advanced Recording.”

If you are recording in any mode other than Destructive Record mode, punches do not permanently replace the previously recorded material. If you do want to permanently record over the specified record range (and keep only the last, or most recent take), select Options > Destructive Record.
4 With the Selector tool, drag in the track’s playlist until the selection encompasses the punch range. For other methods of setting the record range, see “Setting Punch/Loop Points” on page 208.

5 To hear any existing track material up to the start point, or after the end point, enable and set pre- and post-roll times. For details, see “Setting Pre- and Post-Roll” on page 211.

6 Click Record in the Transport window. When you are ready to begin recording, click Play.

When the punch-in (start) point is reached, Pro Tools begins recording. Recording continues until the punch-out (end) point is reached, unless Stop is clicked in the Transport window. If post-roll is enabled, playback continues for the specified post-roll amount.

If recording nondestructively, a new audio file is written to your hard drive and a new audio region appears in the record track and Region List.

If recording in Destructive Record mode, the new audio overwrites the previous material in the existing audio file and region.

**Monitoring During Punch-Ins**

Pro Tools provides two monitoring modes for recording: Auto Input monitoring and Input Only monitoring.

See “Auto Input Monitoring” on page 182.

**Loop Recording Audio**

Pro Tools provides a loop recording feature that lets you record take after take while the same section of audio repeats over and over. This is a convenient technique for quickly recording multiple takes of a part without losing spontaneity.

When loop recording, you must first specify the start and end points for the loop. Though there are several ways to set record and play ranges (see “Setting Punch/Loop Points” on page 208), perhaps the easiest is to select within the track’s playlist the material to be looped.

To set a record or play range by selecting within a playlist, the Edit and Timeline selections must be linked (select Options > Link Timeline and Edit Selection).

The pre-roll setting, if enabled, is used only during the first record pass, and the post-roll setting, if enabled, is used only on the last pass. Pre- and post-roll times are ignored on each successive loop. To compensate for this, you may want to make the loop range slightly longer. Later, you can trim back the recorded takes to the proper length with the Trim tool (see “Using the Trim Tools” on page 289).

When loop recording audio, Pro Tools creates a single audio file that comprises all takes. Takes appear as individual regions in the Region List and are numbered sequentially. Once you stop recording, you can audition any of the recorded takes.

To use alternate takes created with Loop Record in other sessions (such as when using Import Session Data), export region definitions (see “Exporting Region Definitions” on page 152). If region definitions are not exported, alternate takes created with Loop Record will be inaccessible when imported into another session.
To loop record an audio track:

1. Select Options > Loop Record. When Loop Record mode is enabled, a loop symbol appears in the Record Enable button.

2. Record enable the audio track by clicking its Record Enable button.

3. Make sure to select Options > Link Timeline and Edit Selection.

4. With the Selector tool, drag in the track’s playlist until the selection encompasses the loop range.

   For other methods of setting the record range, see “Setting Punch/Loop Points” on page 208.

5. To hear track material up to the start point of the loop, enable and set the pre-roll time. For details, see “Setting Pre- and Post-Roll” on page 211.

6. Click Record in the Transport window. When you are ready to begin recording, click Play.

   The Record Enable button flashes during the pre-roll. When the start point is reached, Pro Tools begins recording. When the end point is reached, Pro Tools loops back to the start time and continues playing and recording.

7. To cancel all recorded takes while loop recording, press Control+Period (.) (Windows) or Command+Period (.) (Mac).

8. When you have finished recording, click Stop in the Transport window.

   If you stop recording before you reach the midpoint of the loop, Pro Tools discards that take. If you record more than half of the looped take, Pro Tools will leave the take in the track when you stop recording.

   The recorded takes appear as regions in the Region List and are numbered sequentially. The most recently recorded take is left in the record track. For details on auditioning the various takes, see “Auditioning Different Record Takes in the Timeline” on page 205.

Loop Playback and Audio Recording

Pro Tools ignores “loop playback” when recording. The only way to loop while recording is to enable Loop Record mode.

Auditioning Different Record Takes in the Timeline

After recording multiple takes with loop or punch recording, you can replace the take currently residing in the track with previous takes to audition them in the Timeline, within the context of the session. (Takes must have the same start time to be available.) Takes can also be auditioned on their own, from the Region List, or from the Matches pop-up menu.

All takes are numbered sequentially.

Selecting a Different Take from the Region List

To select a take from the Region List:

1. In the Edit window, select the current take with the Time Grabber tool.
2 Control-drag (Windows) or Command-drag (Mac) another take from the Region List into the playlist.

The region replaces the previous take and snaps precisely to the correct location.

3 Repeat the above steps to audition other takes.

Selecting a Different Take from the Matches Pop-Up Menu

Each region resulting from a punch or loop record pass has an identical start time (the User Time Stamp). This allows you to easily select and audition takes from the Matches pop-up menu—even while the session plays or loops.

To select a take from the Matches pop-up menu:

1 Do one of the following:
   • Right-click the region with the Selector or Grabber tools, and select the desired take from the Matches submenu in the pop-up menu.
   • Control-click (Windows) or Command-click (Mac), with the Selector tool at the precise beginning of the loop or punch range.
   • If the take currently residing in the track is selected, Control-click (Windows) or Command-click (Mac) it with the Selector tool.

A pop-up menu appears containing a list of regions that share the same User Time Stamp.

2 Choose a region from the Matches pop-up menu. The region replaces the previous take and snaps precisely to the correct location.

3 Repeat the above steps to audition other takes.

One way to ensure that future takes have the same User Time Stamp (and appear in the Matches pop-up menu) is to store punch and loop record selections as Memory Locations. Then if you later need to record additional takes, simply recall the Memory Location. For more information, see “Memory Locations” on page 210.

To change the User Time Stamp of other regions so that they appear in the Matches pop-up menu for a certain location, use the Time Stamp command in the Region List pop-up menu. For more information, see “Time Stamping” on page 694.

Matches and Multiple Tracks

If you have recorded multiple tracks, and each contains takes with identical User Time Stamps, you can use the Matches pop-up menu to replace all takes simultaneously.
To replace the takes for multiple tracks:

1. Choose Setup > Preferences and click the Editing tab.

2. Enable the following options:
   - Take Region Name(s) That Match Track Names
   - Take Regions Lengths That Match

3. Click OK to close the Preferences dialog.

4. With the Selector tool, select the take range for each track you want to replace.

5. Right-click, or Control-click (Windows) or Command-click (Mac), any of the select takes with the Selector tool.

A pop-up menu appears containing a list of regions that share the same User Time Stamp for that track. (When Right-clicking, this list is available in the Matches submenu.)

6. Choose a region from the Matches pop-up menu. The region replaces the previous take and snaps precisely to the correct location. The same take numbers for the other selected tracks are also automatically selected.

**Editing Preferences for Takes**

In addition to having the same User Time Stamp, regions that appear in the Matches pop-up menu are also restricted according to options in the Preferences dialog.

**To set Editing preferences for takes:**

1. Choose Setup > Preferences and click the Editing tab.

2. Enable or disable the following options in the “Matching Start Time” Take List section:

- **Take Region Name(s) That Match Track Names** When selected, only regions that share the same root name with the track/playlist appear in the Matches pop-up menu. For example, the Matches for a track named “Gtr.L” would show the regions “Gtr.L_01” and “Gtr.L_02-01,” but not “Guitar.L_01.”

- **Take Region Lengths That Match** When selected, only regions that match the length of the current selection (even if it is not an entire region) appear in the Matches pop-up menu. If there is no selection, all takes with the same User Time Stamp are displayed.

- **“Separate Region” Operates On All Related Takes** When selected, editing a region with the Separate Region command also affects all other related takes with the same User Time Stamp.

   This option helps you compare different sections from a group of related takes. For example, you can quickly separate an entire group of related vocal takes into sections, then audition and select the best material from each section independently.

   If this option is selected, make sure the “Take Region Names That Match Track Name(s)” and “Take Region Lengths That Match” options are also selected. If they are not, all regions in the session that have the same User Time Stamp will be affected.

   In most instances, you’ll want to deselect the “Separate Region Operates On All Related Takes” option, to prevent a large number of regions from being created when you use the Separate Region command.
Setting Punch/Loop Points

The start and end points of a record range for
punch and loop recording can be set by the fol-
lowing methods:

• Select a range in a track’s playlist.
• Select a range in a Timebase ruler.
• Drag the Playback Markers in the ruler.
• Enter start and end times in the Transport
window.
• Recall a Memory Location.

To set the record range in a track’s playlist:

1. If you want to constrain the selection to the
current Grid value, set the Edit mode to Grid.
2. Make sure to select Options > Link Timeline
and Edit Selection.
3. Do one of the following:
   • With the Selector tool, drag in a track’s
     playlist until the selection encompasses the
     record range.
     – or –
   • If a region’s start and end points define the
     record range, click the region with the
     Time Grabber tool.

You can also enter a start and end point
during playback. Press the Down Arrow to
set the start point, and press the Up Arrow
to set the end point. Note that when in Grid
mode, entering start and end point in this
manner will not snap to the grid.

To set the record range in a Timebase ruler:

1. If you want to constrain the selection to the
current Grid value, set the Edit mode to Grid.
2. Drag with the Selector tool in any Timebase
ruler until the selection encompasses the record
range.

If the Selector tool is not active, you do not
need to manually select it. Other Edit tools
(such as the Time Grabber tool) automati-
cally turn into the Selector tool when used in
the Timebase ruler.

Playback Markers

When tracks are record-enabled, Playback Mark-
ers for start and end times appear as red
up/down arrows in the Main Timebase ruler. If
no tracks are record-enabled, the Playback
Markers are blue.

The Playback Markers can be moved, either sep-
ately or at the same time, to set record and
play ranges.
To set the record range by dragging the Playback Markers:

1. If you want the dragged Playback Markers to snap to the current Grid value, set the Edit mode to Grid.

2. Drag the first Playback Marker (down arrow) to the start point of the range.

3. Drag the second Playback Marker (up arrow) to the end point of the range.

If the current record range is already the right length and the range needs only to be moved, Alt-drag (Windows) or Option-drag (Mac) either Playback Marker to move both to a new location (while keeping the same length).

Start, End, and Length Fields

In its Expanded View, the Transport window can display start, end, and length times, and pre- and post-roll settings. When setting a record or play range, the range is reflected in these fields.

To set the record range by entering start and end times in the Transport window:

1. To see the start, end, and length times, do one of the following:
   - Select View > Transport > Expanded.
   - or -
   - Shift-click the Expand/Collapse “+” button in the Transport window.

2. Do one of the following:
   - In the Transport window, click in the Start field.
   - or -
   - Press Alt+Forward Slash (/) (Windows) or Option+Forward Slash (/) (Mac) on the numeric keypad to select the start field in the Transport window.

3. Type in the start location and press Alt+Forward Slash (/) (Windows) or Option+Forward Slash (/) (Mac) on the numeric keypad to enter the value and automatically move to the end field.

4. Type in the end location and press Enter to accept the value.

Use the Period (.) or Left/Right Arrow keys to move through the different time fields for Start and End. Use the Up/Down Arrow keys to increase or decrease the numerical values.
Memory Locations

You can store Edit selections as Memory Locations, which can include current pre- and post-roll values.

For more information on Memory Locations, see “Memory Locations and Markers” on page 428.

To save an Edit selection with a Memory Location:
1. Make sure to select Options > Link Timeline and Edit Selection.
2. Set the record range by making a playlist or ruler selection, or by entering start and end times in the Transport window.
3. To save the pre- and post-roll values, enable and set the pre- and post-roll amounts by entering them in the Transport window, or by dragging the Pre- and Post-Roll Flags in the ruler that represents the Main Time Scale. (For details, see “Setting Pre- and Post-Roll” on page 211.)
4. Press Enter on the numeric keypad or click the Add Marker/Memory Location button in the Edit window.
5. In the New Memory Location dialog, set Time Properties to Selection, and if saving pre- and post-roll values, select the General Properties option for Pre/Post Roll Times.
6. Enter a name for the new Memory Location and click OK to save it.

To recall an Edit selection with a Memory Location:
1. Make sure to select Options > Link Timeline and Edit Selection.
2. Choose Windows > Memory Locations.
3. Do one of the following:
   - In the Memory Locations window, click the name or number of the Memory Location.
   - Recall the Memory Location by typing Period (.), the Memory Location number, and Period (.) again on the numeric keypad. (See “Numeric Keypad Modes” on page 37).

The start and end times and pre- and post-roll settings stored with the Memory Location are recalled.
Setting Pre- and Post-Roll

Pre- and post-roll times appear as flags in the ruler that represents the Main Time Scale. When pre- and post-roll are enabled, the flags are green, otherwise they are gray.

**Green Pre- and Post-Roll Flags (enabled) in the Main Timebase ruler**

Pre- and post-roll amounts can be entered in the Transport window, set from a track’s playlist or Timebase ruler, or by recalling a Memory Location.

**Setting Pre- and Post-Roll in the Transport Window**

Pre- and post-roll can be enabled and set from the fields in the Transport window.

**To set and enable the pre- and post-roll times in the Transport window:**

1. Select View > Transport > Expanded.
2. In the Transport window, click in the pre-roll field.
3. Type in the pre-roll amount and press Forward Slash (/) on the numeric keypad to enter the value and automatically move to the post-roll field.
4. Type in the post-roll amount and press Enter to accept the new value.
5. To enable either pre- or post-roll, click the appropriate button so it becomes highlighted.

Tip: Use the Period (.) or Left/Right Arrow keys to move through the different time fields for pre and post-roll. Use the Up/Down Arrow keys to increase or decrease the numerical values.

**Setting Pre- and Post-Roll in a Playlist**

You can use the Selector tool to enable and disable pre- and post-roll by clicking in a track’s playlist.

**To set and enable the pre- and post-roll by clicking in a playlist:**

1. Make sure that Options > Link Timeline and Edit Selection is enabled.
2. With the Selector tool, drag in the track’s playlist until the selection encompasses the record range.
3. With the Selector tool, Alt-click (Windows) or Option-click (Mac) in the track’s playlist before the selection to enable the pre-roll at that location.
4. With the Selector tool, Alt-click (Windows) or Option-click (Mac) in the track’s playlist after the selection to enable the post-roll at that location.

**To disable the pre- and post-roll by clicking in a playlist:**

1. With the Selector tool, Alt-click (Windows) or Option-click (Mac) within a track selection near the start to disable the pre-roll.
2. With the Selector tool, Alt-click (Windows) or Option-click (Mac) within a track selection near the end to disable the post-roll.

Tip: In the timeline, you can reset the pre- and post-roll to zero. First, drag the Pre-Roll Flag to the Playback Marker at the start point of the range, then drag the Post-Roll Flag to the Playback Marker at the end point of the range.

3. Drag the Pre-Roll Flag to the Playback Marker at the start point of the range.
4 Drag the Post-Roll Flag to the Playback Marker at the end point of the range.

**Enabling Pre/Post-Roll from the Options Menu**

Pre- and post-roll (as a pair) can be enabled and disabled from the Options menu.

**To enable both pre/post-roll from the Options menu:**

- Select Options > Pre/Post-Roll.

**Dragging Pre- and Post-Roll Flags in the Timebase ruler**

The Pre- and Post-Roll Flags can be moved in the ruler, either separately or at the same time, to set their location.

**To set the pre- and post-roll amounts by dragging in the ruler:**

1 If you want the dragged flags to snap to the current Grid value, set the Edit mode to Grid.

2 Drag the Pre-Roll Flag to a location in the ruler.

3 Drag the Post-Roll Flag to a location in the Timebase ruler.

To set pre- and post-roll values to the same amount, Alt-drag (Windows) or Option-drag (Mac) either the Pre- or the Post-Roll Flag in the ruler. The deselected flag will immediately reset to the same value, and will adjust accordingly as you drag the selected flag.

---

**Recording from a Digital Source**

If you plan to use a DAT player, digital-output CD recorder, or other digital input and output device with your Pro Tools system, make sure it supports the correct digital format. For example, your interface’s AES/EBU inputs and outputs should only be connected to another AES/EBU device.

For additional information on configuring your particular Pro Tools system for recording from a digital source, see your Getting Started Guide.

**Pro Tools|HD Digital Options**

The 192 I/O, 192 Digital I/O, and 96 I/O include AES/EBU, S/PDIF, and ADAT digital options. Additionally, the 192 I/O and 192 Digital I/O include TDIF digital I/O options. The 96i I/O includes only the S/PDIF digital option.

On a 192 I/O, 192 Digital I/O, or 96 I/O, Pro Tools can receive digital audio from the factory-installed Optical (ADAT) I/O at any time (if it is not set to S/PDIF). However, Pro Tools can only receive digital audio from one of its enclosure [Encl] digital sources—AES, S/PDIF or Optical (S/PDIF) at a time.

Enclosure digital sources come standard with Pro Tools|HD I/Os and are labelled on-screen as [Encl] versions, to differentiate them from digital inputs and outputs available on the 192’s Digital I/O card. For example, the AES/EBU inputs and outputs that come standard in the 192 I/O enclosure are identified as AES/EBU [Encl].
The additional digital ports on the 192 I/O and 192 Digital I/O are TDIF, AES/EBU, and ADAT. Pro Tools can only receive digital audio from one of these ports at a time.

However, inputs on both the 192 I/O enclosure I/O and Digital card can be used simultaneously. For example, on a 192 I/O, it is possible to clock off a source from one of the enclosure inputs and have another digital input from the digital ports doing a sample rate conversion, thus having two digital sources.

**Pro Tools LE Digital Options**

The Digi 002 and Digi 002 Rack include S/PDIF and ADAT digital I/O.

Mbox 2 and Mbox include only the S/PDIF digital option.

All digital outputs are active at all times, so you can actually send digital audio to different digital devices simultaneously at mix time.

**Recording from Digital Sources**

**To record from a digital source with Pro Tools (in this example, from a DAT recorder):**

1. Connect the digital output of the DAT recorder to the appropriate digital input of your audio hardware.

2. If you want to start a new session with a different sample rate, choose File > New Session, and select the sample rate. Click Save.

3. Make sure to specify the format (digital) of the inputs of the audio interface you will be using. Choose Setup > Hardware, choose the audio interface, and select the format for the appropriate channel pair.

Some Digidesign I/O units only have two channels that can be set for analog or digital. For example, Mbox 2 has S/PDIF L–R (Stereo) digital inputs and In 1–2 analog inputs. Mbox 2 can record through analog and digital inputs simultaneously.

Also, if your audio hardware supports different digital formats (such as AES/EBU and S/PDIF), select the digital format you will use.

4. For Pro Tools|HD systems, choose Setup > Hardware and select the appropriate Clock Source connected to the appropriate I/O audio interface; or use the Session Setup window to select the appropriate Clock Source.

5. Click OK to close the Hardware Setup dialog.

6. Choose Track > New and specify 1 Stereo Audio Track, then click Create.

7. Assign the Input Path selector for the track to the appropriate input. Since this is a digital-domain transfer, you do not need to worry about input levels.

8. Assign a stereo hardware output by doing one of the following:
   - In the Mix window, click the track’s Output Path selector and assign a stereo hardware output.
   - or –
   - In the Edit window, with I/O View enabled, use the track’s Output Path selector to assign a hardware output.
9 In the Options menu, deselect Destructive Record, Loop Record, QuickPunch, TrackPunch, and DestructivePunch.

10 In the Transport window, click Return to Zero so the start and end times are cleared. This ensures that you’ll start recording from the beginning of the track.

11 In the Mix or Edit window, record enable the new audio track by clicking its Record Enable button.

12 Click Record in the Transport window. When you are ready to begin recording, click Play.

13 Start playback on the DAT deck.

14 When the material from the DAT has finished, click Stop in the Transport window.

**After a Digital Transfer**

After you have finished recording digitally, set the Clock Source pop-up menu in the Session Setup window back to Internal. Otherwise, Pro Tools will not switch back to its own internal clock and may not record or play audio properly. Failure to switch back to Internal sync typically results in pitch problems (fast or slow playback) clicks and pops, or DAE errors, since a DAT recorder or CD Recorder that is idle can default to a different sample rate or stop outputting a sample rate clock altogether.

---

**Half-Speed Recording and Playback**

Pro Tools lets you play and record at half-speed. This capability is similar to that of a tape deck where you can record material at half-speed and then play it back at normal speed (up an octave) for special effects.

**To record at half-speed:**

1 Press Shift+Control+Spacebar (Windows) or Shift+Command+Spacebar (Mac). Recording begins and all existing track material plays at half-speed.

2 When you have finished recording, click Stop.

When played at normal speed, the material recorded at half-speed plays twice as fast (up an octave).

---

**To play at half-speed**

1 Press Shift+Spacebar. Playback begins and track material plays at half-speed. Audio tracks recorded at normal speed will sound half as fast and an octave lower. Audio tracks recorded at half-speed will sound like they are playing back at normal speed.

---

**Use half-speed playback to learn or transcribe difficult passages in recorded tracks.**
Chapter 13: MIDI Recording

Although recording MIDI in Pro Tools is similar to recording audio, there are some important differences:

- Unlike audio, MIDI recording is almost always destructive. See “Record Modes and MIDI” on page 192 for details.
- Unlike audio tracks, MIDI and Instrument tracks can be record-enabled on-the-fly during playback or recording.
- MIDI and Instrument tracks have an Input selector that determines which port on your MIDI interface (devices) and which MIDI channel is routed and recorded to the track. If the MIDI Input selector is set to All, all channels for all devices are routed to the track.
- Similar to Auxiliary Inputs, Instrument tracks have an audio Input selector. This selector is different than the Instrument track’s selector for MIDI Input.
- It is not necessary to use QuickPunch, TrackPunch, or DestructivePunch to punch in on-the-fly with MIDI or Instrument tracks. This capability is available in normal Nondestructive Record mode, and in Destructive Record mode.

Recording from MIDI Devices

The MIDI Inputs for record-enabled MIDI and Instrument tracks determine which MIDI data is recorded in Pro Tools. MIDI Inputs can be set to a specific device (port) and channel, or they can be set to “All,” where all channels for all devices are merged to the track.

MIDI and Instrument tracks in Pro Tools do not contain multiple channels and always play back on the track’s assigned MIDI output devices and channels. Multiple MIDI channels can be simultaneously recorded to multiple tracks.

The following Pro Tools options determine whether you can record from a MIDI controller device:

- Devices that are assigned as a MIDI Controller in the Peripherals dialog are ignored when MIDI tracks are recorded. This is to avoid recording data from MIDI control surfaces (such as the Digidesign Command|8).
- To record and play MIDI, the device must be enabled in the Input Devices dialog (Mac Only). For more information, see “Enabling Input Devices” on page 216.
In addition, the following options affect how MIDI data is recorded in Pro Tools.

- The MIDI Input Filter can filter out MIDI messages that you may not want to record, such as Polyphonic Aftertouch or System Exclusive data. For more information, see “MIDI Input Filter” on page 218.

- Input Quantize, when enabled, automatically quantizes (time corrects) all MIDI notes that are recorded. For more information, see “Input Quantize” on page 218.

Enabling Input Devices

To record from a MIDI controller in Pro Tools, the device must be enabled in the Input Devices dialog. You can also use this dialog to make sure unwanted notes from certain devices, such as drum machines or arpeggiators, are not recorded.

MIDI Control Surfaces In order to use any MIDI control surfaces (such as the Digidesign Command|8), they must be enabled in the Input Devices dialog.

MMC In order for Pro Tools to sync to MMC, the MMC source must be enabled in the Input Devices dialog.

To enable input devices:

2. In the MIDI Input Enable dialog, select the MIDI devices you will record from. Also, make sure any devices that will be used as a control surface are also selected.

3. Deselect any input devices you want to ignore while recording MIDI.

4. When you are finished, click OK.
MIDI Thru

To monitor MIDI tracks while recording, enable MIDI Thru. When enabled, Pro Tools routes MIDI from your controllers to the device and channels assigned to the MIDI track currently record-enabled.

The MIDI Thru Instrument

In addition to any MIDI tracks that are record-enabled, you can also route MIDI to the Default Thru Instrument. This saves you the trouble of creating a MIDI track and record enabling it to hear a particular MIDI device and channel.

Unlike MIDI tracks, which only listen to the device and channel assigned to its MIDI Input selector, all incoming MIDI data is routed to the Default Thru Instrument.

If the Default Thru Instrument is assigned to a record-enabled MIDI track, Pro Tools only routes to the record-enabled track.

To configure a Default Thru Instrument:

1. Choose Setup > Preferences.
2. Click the MIDI tab.
3. Do one of the following:
   - Select a specific device from the Default Thru Instrument pop-up menu to define a consistent preview sound source.
   - Select “Follows First Selected MIDI Track” to have MIDI preview assignment follow MIDI track selection. When multiple MIDI tracks are selected, previewing will use the top track/left track in the Edit and Mix windows.
   - To disable the Default Thru Instrument, select None.

The Default Thru Follows First Selected MIDI Track Selection also lets you play an instrument without having to create and record-enable a MIDI or Instrument track.

The MIDI preference for Global MIDI Playback Offset and individual MIDI track offsets do not affect MIDI routed with MIDI Thru.

When MIDI Thru is enabled, System Exclusive events are echoed to the MIDI device assigned to the record-enabled track—but only if the SysEx events are smaller than 256 bytes.

To enable MIDI Thru:

- Select Options > MIDI Thru.

When using MIDI Thru, you should disable Local Control, if present, on your MIDI devices. Otherwise, your MIDI device may receive double MIDI notes, which can lead to stuck notes. If you are unsure how to disable Local Control for your instrument, refer to the manufacturer’s documentation.

Chapter 13: MIDI Recording

217
**MIDI Input Filter**

Use the MIDI Input Filter to prevent certain MIDI messages from being recorded. The MIDI Input Filter can be set to record “All” messages, “Only” the specified messages, or “All Except” the specified messages.

**For example, to filter out Polyphonic Aftertouch:**

2. In the MIDI Input Filter dialog, select the All Except option.
3. Select the option for Polyphonic Aftertouch. Leave all other messages deselected.
4. Click OK.

When using the All Except option, the selected MIDI messages will not be recorded. Conversely, when using the Only option, only the MIDI messages that are selected will be recorded.

---

**Input Quantize**

When Input Quantize is enabled, all recorded MIDI notes are quantized automatically. To preserve the original “feel” of your recorded MIDI tracks, make sure to disable this option.

**To enable Input Quantize:**

1. Choose Event > MIDI > Input Quantize.
2. In the Input Quantize page, select Enable Input Quantize.

---

**MIDI Operations window, Input Quantize**

Configure the other options in the Input Quantize page. For details on the various Quantize options, see “Input Quantize” on page 503.

When finished, close the MIDI Operations window.

For drum machine style loop recording, use Input Quantize while loop recording MIDI in Merge mode (see “Loop Recording with Merge Mode” on page 225).
Chapter 13: MIDI Recording

Wait for Note

The Wait for Note button, located in the Transport window, determines how Pro Tools begins recording. When enabled, Pro Tools will not begin recording until a MIDI event is received. This ensures that you begin recording when you’re ready to play, and that the first note, or other MIDI data, is recorded precisely at the beginning of the record range (start time).

Wait for Note can be used when recording normally, when punching in, or when loop recording. If pre-roll is enabled, it occurs after the MIDI event is received and before recording begins.

To enable Wait for Note:

1. To view the MIDI controls in the Transport window, select View > Transport > MIDI Controls.
2. In the Transport window, click the Wait for Note button so it becomes highlighted.

MIDI Merge/Replace

The MIDI Merge button, located in the Transport window, determines how MIDI is recorded when overdubbing or punching in. When MIDI Merge is on (Merge mode), recorded MIDI is merged with existing track material. When MIDI Merge is off (Replace mode), existing data within the punched region is replaced by the newly recorded material.

The MIDI Merge button can be turned on and off while playing or recording. In Loop Record mode, MIDI Merge has no effect, so its button is dimmed.

To enable MIDI Merge:

1. To view the MIDI controls in the Transport window, select View > Transport > MIDI Controls.
2. In the Transport window, click the MIDI Merge button so it becomes highlighted.

With the Operation preference for “Use F11 for Wait for Note” enabled, you can press F11 to turn on Wait for Note. (On Mac systems, the Mac “Desktop” keyboard shortcut must be disabled or remapped.)

You can also paste and merge MIDI notes using Paste Special commands. See “Special Paste Function for Automation Data” on page 613.

To enable MIDI Merge:

1. To view the MIDI controls in the Transport window, select View > Transport > MIDI Controls.
2. In the Transport window, click the MIDI Merge button so it becomes highlighted.
Configuring MIDI or Instrument Tracks for Recording

To configure one or more MIDI or Instrument tracks for recording:

1. If you do not have a MIDI or Instrument track to record to, choose Track > New and specify 1 MIDI Track or 1 Instrument Track, then click Create.

2. For Instrument tracks, be sure that Instruments View is selected (View > Mix Window > Instruments, or View > Edit Window > Instruments).

3. Do one of the following:
   - In the Mix window, click the track's MIDI Input selector and assign the device and channel to be recorded. For Instrument tracks the MIDI Input selector is available in Instruments View.
   - For MIDI tracks in the Edit window, choose View > Edit Window > I/O, then click the track's MIDI Input selector and assign the device and channel to be recorded.
   - For Instrument tracks in the Edit window, choose View > Edit Window > Instrument, then click the track's MIDI input selector and assign the device and channel to be recorded.
4 Do one of the following:
- In the Mix window, click the track’s MIDI Output selector and assign a device and channel from the pop-up menu. For Instrument tracks the MIDI Output selector is available in Instruments View. Channels already assigned to other tracks appear bold in this menu.

5 To assign multiple destinations to a single MIDI or Instrument track, Start-click (Windows) or Control-click (Mac) the MIDI Output selector and select additional channels from any device. When multiple destinations are selected for a single MIDI track, a “*” sign will appear next to the first destination name in the track’s MIDI Output selector.

6 If you want to assign a default program change to the track, click the Patch Select button, make the necessary selections for program and bank select, then click Done. Default program changes are sent whenever the track is played. For more information, see “Patch Select (Program and Bank Changes)” on page 474.

7 If recording to multiple MIDI or Instrument tracks, repeat the above steps for each track, then continue to the next step.

8 If you want to use a click, enable and configure the click, and set a default tempo and meter for the session. For details, see “Recording with a Click” on page 193.
9 Enable Wait for Note or Countoff in the Transport window if you want to use these features.

10 To replace existing track material, disable MIDI Merge in the Transport window.

11 If you want to automatically quantize material as it is recorded, enable Input Quantize (see “Input Quantize” on page 218).

12 In the Transport window, click Return to Zero so the start and end times are cleared. This ensures that you’ll start recording from the beginning of the track.

13 In either the Mix or Edit window, click the MIDI or Instrument track's Record Enable button to record enable the track.

14 Make sure Options > MIDI Thru is selected, then play some notes on your MIDI controller. The MIDI instrument assigned to the track should sound, and the track's meters should register MIDI activity.

You are now ready to record MIDI data to the record-enabled MIDI and Instrument tracks. See “Recording to MIDI and Instrument Tracks” on page 222.

**Recording to MIDI and Instrument Tracks**

In Pro Tools, you can record to one or more MIDI and Instrument tracks. Recording simultaneously to multiple tracks allows you to:

- Record from multiple MIDI devices at the same time, capturing material from several performers
- Record multiple channels from the same device, capturing data from a split keyboard
- Transfer MIDI tracks from an external MIDI sequencer

💡 To take full advantage of the MIDI editing capabilities in Pro Tools, make sure to record with the click enabled. This ensures that recorded data aligns with the session's bar and beat boundaries. You can also record to MIDI tracks without a click and derive the tempo and meter from the performance.

**To record to one or more MIDI or Instrument tracks:**

1 With Pro Tools HD, make sure that Delay Compensation is disabled in the Options menu.

⚠️ Digidesign recommends recording without Delay Compensation in most cases. For more information, see “Delay Compensation” on page 553.

2 Configure a MIDI or Instrument track for recording. Refer to “Configuring MIDI or Instrument Tracks for Recording” on page 220.

3 Record enable the track you want to record by clicking its Record Enable button.

💡 To record enable additional MIDI and Instrument tracks, shift-click their Record Enable buttons.

4 Put Pro Tools in normal Nondestructive Record mode. In the Options menu, deselect Destructive Record, Loop Record, and Quick-Punch.

5 Click Record in the Transport window to enter Record Ready mode. The Record Enable Status indicator lights red.
6 Do one of the following:
- When you are ready to begin recording, click Play. If using Countoff, Pro Tools counts off the specified number of measures and then begins recording.
- or –
- If using Wait for Note, the Play, Record, and Wait for Note buttons flash. Recording begins when a MIDI event is received.

7 When you have finished recording, click Stop in the Transport window.

For each record-enabled track, a new MIDI region is created and appears in the playlist. The new MIDI regions also appear in the Region List.

---

**Undo and MIDI Recording**

You can undo previous MIDI record takes.

**To undo a MIDI recording:**
- Once the Transport has been stopped, choose Edit > Undo MIDI Recording.

The track’s playlist is restored to its previous state. However:
- If you punched in and out several times before stopping the Transport, only the last punch is undone.
- When using Loop Record mode, all takes from each record pass are discarded.

**Canceling a Record Take**

It is also possible to discard the current record take before the Transport is stopped.

**To cancel a record take while recording:**
- Press Control+Period (.) (Windows) or Command+Period (.) (Mac) before the Transport is stopped.

If using Loop Record mode, all takes from each record pass are discarded.

---

**Punch Recording MIDI**

To replace a portion of a MIDI or Instrument track, you can **punch in** by specifying the record range before recording.

**To punch in on a MIDI or Instrument track:**
1. Configure a MIDI or Instrument track for recording. Refer to “Configuring MIDI or Instrument Tracks for Recording” on page 220.
2 Put Pro Tools in normal Nondestructive Record mode. In the Options menu, deselect Destructive Record, Loop Record, and Quick-Punch.

3 In the Transport window, disable Wait for Note and Countoff.

4 Select Options > Link Timeline and Edit Selection.

5 With the Selector tool, drag in the track’s playlist until the selection encompasses the punch range.

For other methods of setting the record range, see “Setting Punch/Loop Points” on page 208.

6 To hear existing track material up to the start point, or after the end point, enable and set pre- and post-roll times. For details, see “Setting Pre- and Post-Roll” on page 211.

7 Record enable the track containing the previous take by clicking its Record Enable button.

8 Click Record in the Transport window to enter Record Ready mode. The Record Enable button flashes.

9 When you are ready to begin recording, click Play.

If pre-roll is enabled, the track material leading up to the punch-in point plays. You can start playing during the pre-roll to get the “feel.” Material is not recorded until the start point is reached.

When the start point is reached, Pro Tools begins recording. Recording continues until the end point is reached, unless Stop is clicked in the Transport window. If post-roll is enabled, playback continues for the specified post-roll amount.

10 When you have finished recording, click Stop in the Transport window.

The newly recorded MIDI data appears in the track.

**Punch Recording During Playback with MIDI**

You do not have to set a record range to punch in on a MIDI or Instrument track. In fact, you can punch in and out on-the-fly at any time during playback. Unlike audio tracks, it is not necessary to enable QuickPunch to perform real-time punch recording.

**To punch record on-the-fly with MIDI:**

1. Configure a MIDI or Instrument track for recording. Refer to “Configuring MIDI or Instrument Tracks for Recording” on page 220.

2. Put Pro Tools in normal Nondestructive Record mode. In the Options menu, deselect Destructive Record, Loop Record, and Quick-Punch.

3. In the Transport window, disable Wait for Note and Countoff.

4. Record enable the track containing the previous take by clicking its Record Enable button.

5. Start playback by clicking Play in the Transport window.

6. When you reach the punch-in point, do one of the following:
   - Click Record in the Transport window.
   - or -
   - For Digi 002 and Digi 002 Rack systems (or Digidesign controllers) with a connected footswitch, press the footswitch at the punch-in point.

The Record Enable button stops flashing and stays lit during recording.
To punch out, click Record again (or press the footswitch).

Pro Tools exits Record mode and continues playing. You can perform additional punches during the same pass.

**Regions and Punch Recording**

Depending on the record range, new regions may be created after punch recording. For example, Figure 7 shows two existing regions before recording. Since the start and end times occur within both of the existing regions, a new region is created to fill the space between them.

However, when selecting an entire region, or a section within a region, before punching, no new regions are created. In this instance, only the material residing within the existing region changes, with no new material recorded outside the region.

Unlike audio recording, MIDI recording in this scenario is destructive. If a region is altered because of a record take, the original material is lost (unless you choose Edit > Undo MIDI Recording), or combined with new material (if MIDI Merge was enabled during recording). If an existing region contains important material, use Duplicate to make a copy of the region (“Duplicate Command” on page 358) or the track’s playlist (see “Working with Playlists” on page 271).

**Loop Recording MIDI**

Loop recording with MIDI is supported by two methods:

- In normal Nondestructive Record mode, enable Loop Playback and MIDI Merge for drum machine style loop recording.

  – or –

- Use Loop Record mode to record multiple takes on each record pass. This is similar to loop recording audio.

**Loop Recording with Merge Mode**

For drum machine style loop recording, use normal Nondestructive Record mode with Loop Playback and MIDI Merge enabled. With this method, MIDI is recorded and merged to the same region with each new record pass—thereby allowing you to, for example, record hi-hats on the first pass and kick and snare on the next.

Make sure that MIDI Merge is enabled in the Transport window, otherwise (in Replace mode) each subsequent take will destructively replace the previous.

You can record enable a different MIDI or Instrument track on-the-fly while loop recording. While pressing Control (Windows) or Command (Mac), use the Up/Down Arrows to record enable the previous or next MIDI or Instrument track.
To loop record with MIDI Merge:

1. Configure a MIDI or Instrument track for recording. Refer to “Configuring MIDI or Instrument Tracks for Recording” on page 220.

2. Put Pro Tools in normal Nondestructive Record mode. In the Options menu, deselect Destructive Record, Loop Record, QuickPunch, TrackPunch, and DestructivePunch.

3. Select Options > Loop Playback. When Loop Playback is enabled, a loop symbol appears in the Play button.

4. Record enable the MIDI or Instrument track by clicking its Record Enable button. Make sure no audio tracks are record-enabled.

5. In the Transport window, click the MIDI Merge button so it is highlighted.


7. Select Options > Link Timeline and Edit Selection.

8. With the Selector tool, drag in the track’s playlist until the selection encompasses the loop range.

For other methods of setting the record range, see “Setting Punch/Loop Points” on page 208.

9. To hear track material up to the start point of the loop, enable and set the pre-roll time. For details, see “Setting Pre- and Post-Roll” on page 211.

10. Click Record in the Transport window. When you are ready to begin recording, click Play. The Record Enable button flashes during the pre-roll. When the start point is reached, Pro Tools begins recording. When the end point is reached, Pro Tools loops back to the start point and continues playing and recording.

11. Play some notes on your MIDI controller. Newly recorded MIDI data appears as a region in the record track. On each successive take, recorded material shows up in the region, without replacing material from previous takes.

12. If you want to switch to a new record track, press Control (Windows) or Command (Mac), and press the Up/Down Arrow keys to record enable the previous or next MIDI or Instrument track.

13. When you have finished recording, click Stop in the Transport window.

The newly recorded MIDI data appears as a MIDI region in the track’s playlist, and in the Region List.

Loop Recording Multiple Takes

When recording MIDI in Loop Record mode, new regions are created each time new material is received during a record pass. This differs somewhat from loop recording audio, where Pro Tools creates a single audio file that comprises all takes, which appear as individual regions in the Region List.

You can use MIDI loop recording to record successive takes without stopping the record process, thereby capturing your creative spontaneity. Another advantage with this method of recording MIDI, which is nondestructive, is that existing and newly recorded regions remain intact (and available in the Region List).
To record MIDI in Loop Record mode:

1. Configure a MIDI or Instrument track for recording. Refer to “Configuring MIDI or Instrument Tracks for Recording” on page 220.

2. Select Options > Loop Record. When Loop Record mode is enabled, a loop symbol appears in the Record Enable button.

3. If you have not done so already, record enable the MIDI or Instrument track by clicking its Record Enable button. Make sure no audio tracks are record-enabled.


5. Select Options > Link Timeline and Edit Selection.

6. With the Selector tool, drag in the track’s playlist until the selection encompasses the loop range.

For other methods of setting the record range, see “Setting Punch/Loop Points” on page 208.

7. To hear track material up to the start point of the loop, enable and set the pre-roll time. For details, see “Setting Pre- and Post-Roll” on page 211.

8. Click Record in the Transport window. When you are ready to begin recording, click Play.

The Record Enable button flashes during the pre-roll. When the start point is reached, Pro Tools begins recording. When the end point is reached, Pro Tools loops back to the start point and continues playing and recording.

9. Play your MIDI controller. A new MIDI region containing the newly recorded material is automatically created and appears in the track’s playlist, replacing the previous region.

Regions are replaced (nondestructively) during subsequent record passes when new MIDI material is received.

10. When you have finished recording, click Stop in the Transport window. The most recently recorded take is left in the record track.

The recorded takes appear as regions in the Region List and are numbered sequentially. The takes, which are the same length and easily interchangeable, can be auditioned from the Matches pop-up menu—even while the session plays or loops.

To audition the various record takes:

1. Do one of the following:
   - Right-click the region with the Selector or Grabber tools, and select the desired take from the Matches submenu in the pop-up menu.
   - Control-click (Windows) or Command-click (Mac) with the Selector tool at the precise beginning of the loop record range.
   - If the take currently residing in the track is selected, Control-click (Windows) or Command-click (Mac) it with the Selector tool.

A pop-up menu appears containing a list of regions that share the same User Time Stamp.
2 Choose a region from the Matches pop-up menu. The region replaces the previous take and snaps precisely to the correct location.

For more information on auditioning and managing takes, see “Auditioning Different Record Takes in the Timeline” on page 205.

MIDI Step Input

Step Input lets you use a MIDI controller to enter notes individually, one step at a time. This gives you precise control over note placement, duration, and velocity. With MIDI Step Input you can also create musical passages that might be difficult to play accurately, or at a fast tempo.

To enter MIDI notes with Step Input (using an external MIDI Instrument):

1 Make certain your external MIDI keyboard is properly connected and working with Pro Tools.
2 Choose Event > MIDI > Step Input.

3 Select the Enable option.

**When Step Input is enabled, each previously record-enabled MIDI track is taken out of record enable, and if a Default Thru Instrument is defined in the MIDI Preferences page, it is disabled.**

4 Choose the MIDI track you wish to record on from the Destination pop-up menu.
5 Choose the note value you wish to enter from the Step Increment section.
6 Play a note or chord on your MIDI instrument. This enters the note and moves to the next step of the insertion point.

To increase a note’s length while using Step Input:

1 Play and hold a note on your MIDI instrument.

2 Choose the note value that you would like to add and press the Increment button.

Release the note on your MIDI keyboard to move to the next step insertion point.

---

228  Pro Tools Reference Guide
**Step Input Controls**

The Step Input page has the following controls:

**Enable** When selected, MIDI events are added to the destination track when you play your external MIDI keyboard. Additionally, each previously record-enabled MIDI track is taken out of record enable.

If a Default Thru Instrument is defined in the MIDI Preferences page, it is disabled when Step Input is enabled, and is re-enabled when Step Input is no longer disabled.

**Destination** Lets you select the destination track for the Step Input from a pop-up list of all the MIDI tracks in your session.

**Step Increment**

The options in the Step Increment section let you set the spacing and duration of MIDI events entered using the Step Input operation. You can select any size from whole notes to sixty-fourth notes (including dotted values).

**Tuplet** Lets you input irregular note groupings (such as triplets or quintuplets). The tuplet length is calculated from the note spacing selection and the Tuplet values. For example, an eighth note equals 480 ticks, so a tuplet eighth notes with 3 in time of 2 would yield a note spacing of 320 ticks (480 ticks / 3 * 2).

**Note Length**

Let you select the note length as a percentage of the spacing value. For example, an eighth note equals 480 ticks, so an eighth note with an 80% duration would be 384 ticks long.

**Options**

**Use Input Velocity** When selected, MIDI notes are recorded using the velocity that you play on your MIDI keyboard.

**Set Velocity To** When selected, MIDI notes are recorded with the velocity that you specify in the Velocity field. This value can be set with the Velocity slider.

**Enable Numeric Keypad Shortcuts** When selected, Step Input options can be selected from the numeric keypad. See “Numeric Keypad Shortcuts” on page 231.
Undo Step, Next Step (or Increment), and Redo Step

Use the Undo Step and Next Step buttons to do the following:

• Move the step insertion point, by either removing the previous note or by advancing the insertion point by the Step Increment value.

• Lengthen and shorten notes that are being held on the MIDI controller, by adding or removing Step Increment values. The Step Increment value can be changed mid-note to create a note with a hybrid note length.

Use the Redo Step button to sequentially redo any previously undone steps.

Undo Step When the previous note has been released from the MIDI keyboard, and the insertion point has moved forward to the next note, Undo Step will remove the entire last note.

When a note is being held on the MIDI keyboard, Undo Step changes to read “Decrement,” and removes the last Step Increment length that was added to the held note.

Next Step (or Increment) When no note is being held on the MIDI keyboard, Next Step moves the insertion point by the Step Increment value, essentially inserting a musical rest.

When a note is being held on the MIDI keyboard, Next Step changes to read “Increment” and adds the Step Increment value to the held note, increasing its length by the Step Increment value.

While the note is being held, the Step Increment value can be changed, allowing you to create notes of any musical length.

Redo Step Reinserts the last note that was removed by the Undo Step operation.

Setting Undo Step, Next Step and Redo Step MIDI Triggers

The Undo Step, Next Step and Redo Step buttons can be set to be triggered by an external MIDI synth, drum pad, or other controller.

To set Undo Step, Next Step and Redo Step MIDI triggers:

1. Choose Event > MIDI > Step Input.
2. Locate the button you want to assign a MIDI event to, and click in the field below the button.

Selecting the Next Step field

3. Play the MIDI event you wish to use as a trigger.

If you use a continuous controller such as Pitch Bend as a trigger, you should make certain to use an extreme controller value to avoid erroneous data input.

Next Step field triggered by pitch bend

4. Press Enter to confirm the MIDI trigger assignment.
**Numeric Keypad Shortcuts**

When Enable Numeric Keypad Shortcuts is selected, you can choose many of the controls in the Step Input page, as well as several selection controls.

<table>
<thead>
<tr>
<th>Step Input Shortcuts</th>
<th>Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Whole note</td>
<td>1</td>
</tr>
<tr>
<td>1/2 note</td>
<td>2</td>
</tr>
<tr>
<td>1/4 note</td>
<td>4</td>
</tr>
<tr>
<td>1/8 note</td>
<td>5</td>
</tr>
<tr>
<td>1/16 note</td>
<td>6</td>
</tr>
<tr>
<td>1/32 note</td>
<td>7</td>
</tr>
<tr>
<td>1/64 note</td>
<td>8</td>
</tr>
<tr>
<td>Dotted note</td>
<td>.</td>
</tr>
<tr>
<td>Toggle Tuplet on/off</td>
<td>3</td>
</tr>
<tr>
<td>Next step</td>
<td>Enter</td>
</tr>
<tr>
<td>Undo step</td>
<td>0</td>
</tr>
<tr>
<td>Nudge forward</td>
<td>+</td>
</tr>
<tr>
<td>Nudge back</td>
<td>-</td>
</tr>
<tr>
<td>Select Main Counter</td>
<td>=</td>
</tr>
<tr>
<td>Edit Selection indicators</td>
<td>/</td>
</tr>
</tbody>
</table>

**Recording System Exclusive Data**

Pro Tools supports recording and playing System Exclusive data (Sysex) with MIDI tracks. This allows you to use MIDI tracks in Pro Tools to store patch and configuration data for your MIDI devices, or to record real-time Sysex changes for a particular parameter of a MIDI device that cannot be controlled by a standard MIDI controller.

**To record a Sysex dump at the beginning of a MIDI track:**

1. Make sure that the MIDI OUT for the device sending the Sysex is connected to your MIDI interface’s MIDI IN.

2. Configure a MIDI track for recording. Refer to “Configuring MIDI or Instrument Tracks for Recording” on page 220.

3. Put Pro Tools in normal Nondestructive Record mode. In the Options menu, deselect Destructive Record, Loop Record, QuickPunch, TrackPunch, and DestructivePunch.

4. In the MIDI Input Filter dialog, enable recording of System Exclusive data.

5. If you have not done so already, record enable the MIDI track by clicking its Record Enable button.


7. In the Transport window, click Return to Zero so the start and end times are cleared. This ensures that you’ll start recording from the beginning of the track.

8. When you are ready to begin recording, click Record in the Transport window.
The Record, Play, and Wait for Note buttons flash, indicating that Pro Tools is waiting for MIDI data.

9 Initiate the Sysex transfer from the MIDI device, according to the instructions in the guide for your MIDI device. When receiving the MIDI data, Pro Tools automatically begins recording.

10 When the transfer is complete (as defined in the guide for your MIDI device), click Stop in the Transport window.

The newly recorded MIDI data appears as a MIDI region in the track’s playlist, and in the Region List. MIDI regions that contain System Exclusive data appear blank when the MIDI Track View is set to Regions.

To see the Sysex event blocks, which indicate the location of the data, set the MIDI Track View to display Sysex (see “Regions View for MIDI and Instrument Tracks” on page 263). For details on moving and copying of Sysex data, see “System Exclusive Events” on page 478.

To resend the Sysex from Pro Tools:

1. For the device receiving the System Exclusive data, make sure its MIDI IN is connected to your MIDI interface’s MIDI OUT. Also, make sure the device is set to receive Sysex. Some devices require that memory protect be off.

2. For the previously recorded track, click its Record Enable button so that it is no longer record-enabled.

3. Click the track’s MIDI Output selector and assign the device from the pop-up menu.

4. In the Transport window, click Return to Zero.

5. Click Play in the Transport window to begin playback. Pro Tools begins playing and transmits the previously recorded Sysex to the assigned MIDI device.
Chapter 14: Advanced Recording

There are three advanced recording methods that differ from basic recording, QuickPunch, TrackPunch, and DestructivePunch.

**QuickPunch** A nondestructive recording mode that lets record-enabled tracks be punched in and punched out during playback by clicking the Transport’s Record Enable button.

**TrackPunch (Pro Tools HD Only)** A nondestructive recording mode that lets individual tracks be punched in, punched out, and taken out of record enable without interrupting online recording and playback.

**DestructivePunch (Pro Tools HD Only)** A destructive recording mode that lets individual tracks be punched in, punched out, and taken out of record enable without interrupting online recording and playback while maintaining a single continuous audio file.

**QuickPunch Audio Recording**

Pro Tools features an on-the-fly punch capability called QuickPunch. QuickPunch lets you instantaneously punch in and out on record-enabled audio tracks during playback by clicking the Record Enable button in the Transport window.

> For Digi 002 and Digi 002 Rack systems, and Digidesign control surfaces, you can use a footswitch to punch in and out when recording with QuickPunch.

When using QuickPunch, Pro Tools begins recording a new file when playback begins, automatically generating regions in that file at each punch-in and punch-out point. These regions appear in the track’s playlist; and the complete audio file appears in the Region List along with the QuickPunch created regions. Up to 200 of these “running punches” can be performed in a single pass. Unlike normal punch recording (see “Punch Recording Audio” on page 203), QuickPunch provides instantaneous monitor switching on punch-out. All QuickPunch recording is nondestructive.

> You do not need to use QuickPunch to punch on-the-fly with MIDI tracks. This capability is available in normal Nondestructive Record mode, and in Destructive Record mode.
QuickPunch/TrackPunch Crossfade Length

Pro Tools can automatically write a crossfade for each punch point when using QuickPunch. The length for these crossfades is set with the QuickPunch Crossfade/TrackPunch Length option in the Editing Preferences page.

To set the QuickPunch Crossfade Length:

1. Choose Setup > Preferences and click the Editing tab.
2. Enter a new value (in msec) for the QuickPunch /TrackPunch CrossFade Length.

A good general-purpose crossfade length for punches is 10 milliseconds. If you set the preference to zero, Pro Tools will not create any crossfades at the punch-in/out points.

3. Click OK.

If a value other than zero is specified for the QuickPunch/TrackPunch Crossfade Length, Pro Tools writes a pre-crossfade at the punch-in point (which occurs up to but not into the punched region boundary), and a post-crossfade at the punch-out point (which occurs after the punched region).

Even if the QuickPunch/TrackPunch Crossfade Length is set to zero, Pro Tools always executes a 4 millisecond “monitor only” crossfade (which is not written to disk) to avoid distracting pops or clicks that might occur as you enter and exit record mode.

QuickPunch crossfades can later be edited in the same manner as standard crossfades. For details, see “Using Crossfades” on page 375.

QuickPunch Guidelines for Pro Tools HD

When using QuickPunch with Pro Tools HD, two voices are required for each record-enabled, mono track. This means that you can record up to half the total number of voices available on your system. For example, a Pro Tools|HD Accel system configured for 192 voices can simultaneously record on up to 96 mono tracks with QuickPunch (or 48 stereo tracks).

If the required number of voices for the record-enabled tracks is not available when switching to QuickPunch mode, you will be prompted to free up the necessary voices.

To free up voices on tracks that are not record-enabled, and do not need to be heard while recording, do one of the following:

- Set voice assignments for tracks to Off.
- Make tracks inactive.
- Group all RTAS plug-ins before TDM plug-ins.

As necessary, voices in use by other tracks, which are not record-enabled, may be “stolen” while recording with QuickPunch. Priority for tracks while recording with QuickPunch are as follows:

- Tracks with assigned voices that are not record-enabled
- Tracks with assigned voices that are record-enabled
- Tracks with Dynamically Allocated Voicing that are not record-enabled
- Tracks with Dynamically Allocated Voicing that are record-enabled
If the session has plenty of available voices, you may have no trouble using QuickPunch with tracks using Dynamically Allocated Voicing. However, if you are running out of voices, and want to ensure that a track will be heard when recording with QuickPunch, assign it a voice.

**QuickPunch and Dynamically Allocated Voicing** 
*(Pro Tools HD Only)*

When using QuickPunch with a Pro Tools|HD system configured for its maximum number of voices, make sure to set the voice assignment for each audio track to Dyn (for Dynamically Allocated Voicing). This ensures that Pro Tools will automatically handle the distribution of voices between each set of voices. For example, for a 192-voice configured Pro Tools|HD Accel system, Dynamically Allocated Voicing distributes voices evenly across four sets of voices (1–48, 49–96, 97–144, and 145–192).

If you do not use Dynamically Allocated Voicing, the voices must be evenly distributed between all DSP engines. For example, to use QuickPunch on 32 tracks without Dynamically Allocated Voicing, tracks 1–16 must be assigned to voices 1–16 and tracks 17–32 must be assigned to voices 33–48.

**QuickPunch Guidelines for Pro Tools LE**

For Pro Tools LE systems, up to 16 mono, or 8 stereo audio tracks can be simultaneously recorded with QuickPunch in addition to the maximum number of mono tracks supported by your Pro Tools LE system (see “Pro Tools LE System Capabilities” on page 10).

For Pro Tools LE with DV Toolkit 2 and Pro Tools LE or M-Powered with Music Production Toolkit, up to 24 mono or stereo audio tracks can be simultaneously recorded with QuickPunch. On these systems, the combination of audio tracks and QuickPunch cannot be greater than 48.

⚠ **QuickPunch uses CPU processing power, and may reduce the number of tracks and plug-ins you can use.**

**Recording with QuickPunch**

**To punch on-the-fly with QuickPunch:**

1. With Pro Tools HD, make sure that Delay Compensation is deselected in the Options menu.

⚠ Digidesign recommends recording without Delay Compensation. For more information, see “Delay Compensation” on page 553.

2. Select Options > QuickPunch. When QuickPunch is enabled, a “P” appears in the Record Enable button.

3. To change the automatic crossfade used by QuickPunch, configure QuickPunch Crossfade Length option in the Editing Preferences page (see “QuickPunch/TrackPunch Crossfade Length” on page 234).

4. Record enable the tracks you want to punch in on. Make sure there are enough available voices on your system.
5 Prepare to record by cueing Pro Tools to an appropriate location. If you want to use pre-roll, enable a pre-roll value in the Transport window.

6 Start playback by clicking Play in the Transport window.

7 Do one of the following:
   - When you reach the punch-in point, click Record in the Transport window.
   - or –
   - For Pro Tools|HD systems using a Digidesign control surface or Digi 002 and Digi 002 Rack systems with a connected footswitch, press the footswitch at the punch-in point.

The Record Enable button stops flashing and stays lit during recording.

8 To punch out, click Record again (or press the footswitch).

As Pro Tools continues playing, you can perform additional punches (up to 100). When recording multiple punches during a single pass, a single audio file is recorded from which Pro Tools creates the appropriate regions.

QuickPunch with an Edit Selection

If you make an Edit selection and use QuickPunch, the following rules apply:
   - If the Transport is not online, recording begins and stops whenever you click the Record Enable button—regardless of the selection’s start or end point.
   - If the Transport is online, punch-in/out behavior is controlled by the Online Options setting in the Operation Preferences page. If you select Record Online at Insertion/Selection, QuickPunch punches in and out only within the selection (or in the case of an insertion point, only after the insertion point). If you select Record Online at Time Code Lock, QuickPunch disregards the selection and punches in and out whenever you want (after Pro Tools has locked to time code).

Region and Take Numbering with QuickPunch

After recording with QuickPunch, the new audio regions appear in the Region List. This includes the whole-file audio region encompassing all punches from the record pass, along with the regions derived for each punch.

Names for the punched regions are numbered consecutively starting with “01.” For example, if QuickPunch is used to punch in twice on a track called “Lead Gtr,” a region for the parent audio file appears and is named “Lead Gtr_01,” and two regions for the punches are named “Lead Gtr_01-01” and “Lead Gtr_01-02.”

If you stop playback and record additional punches with QuickPunch, subsequent regions are named by incrementing the first two digits in the name. For example, on the second pass, the punched regions are named “Lead Gtr_02-01,” “Lead Gtr_02-02,” and so forth.

TrackPunch Audio Recording

(Pro Tools HD Only)

TrackPunch makes Pro Tools more useful as a digital dubber for film re-recording (dubbing) and mixing. Keyboard shortcuts and preference settings for recording and input monitoring provide flexibility that makes TrackPunch equally useful for loading dailies and recording Foley, as well as over-dubbing and tracking in music sessions.
TrackPunch Usage Guidelines

TrackPunch and Dynamically Allocated Voicing

When using TrackPunch with a Pro Tools HD system configured for maximum voices, make sure to set the voice assignment for each audio track to dyn for Dynamically Allocated Voicing (this mode was previously known as Auto Voice mode). This ensures that Pro Tools can automatically manage voices most efficiently.

Audio Files and TrackPunch

After a TrackPunch recording pass, the punched track’s playlist in the Edit window displays the regions created by punching. You can use any of the Trim tools after punch recording to open up the head or tail of TrackPunch (and QuickPunch) recorded regions, or to reveal the parent audio file that was recorded in the background. This lets you compensate for any late or missed punches.

Voice Requirements for TrackPunch Recording

TrackPunch requires two voices for each record-enabled, mono track. This means that you can record up to half the total number of voices available on your system.

When switching to TrackPunch mode, you will be prompted to free up additional voices if not enough are available.

To free up voices on tracks that are not record-enabled, and do not need to be heard while recording, do one of the following:

- Set voice assignments for tracks to Off.
- Make tracks inactive.
- Group all RTAS plug-ins before TDM plug-ins.

As necessary, voices in use by other tracks may be “stolen” while recording with TrackPunch (thus silencing some tracks).

TrackPunch voice playback priority follows the same guidelines as QuickPunch, as follows (from highest to lowest playback priority):

- Tracks with assigned voices that are not record-enabled
- Tracks with assigned voices that are record-enabled
- Tracks with Dynamically Allocated Voicing that are not record-enabled
- Tracks with Dynamically Allocated Voicing that are record-enabled

If the session has plenty of available voices, you may have no trouble using TrackPunch with tracks that use Dynamically Allocated Voicing. However, if you are running out of voices, and want to ensure that a track will be heard when recording with TrackPunch, assign it a voice.

Overview of TrackPunch Recording

Before using TrackPunch, configure Pro Tools and TrackPunch as follows:

To configure Pro Tools and TrackPunch:

1. Configure TrackPunch preference settings as suggested in “TrackPunch Preferences” on page 239.
2. If necessary, configure Pro Tools synchronization settings for online recording and track arming (see “Configuring Synchronization and Track Arming” on page 240).
To use TrackPunch:

1. Make sure Pro Tools is not recording or playing back (the Transport is stopped).
2. Make sure that Delay Compensation is deselected in the Options menu.

⚠️ Digidesign recommends recording without Delay Compensation. For more information about using Delay Compensation, see “Delay Compensation” on page 553.

3. Enable TrackPunch mode (see “Enabling TrackPunch Mode” on page 240).
4. TrackPunch enable all audio tracks that you want to punch during the record pass (see “TrackPunch Enabling Tracks” on page 241).
5. Configure monitoring for record-enabled tracks by selecting the appropriate mode from the Track menu, as appropriate. Choices include:
   - Set Record Tracks to Auto Input
   - Set Record Tracks to Input Only
   Choosing either monitoring mode only affects tracks that are record-enabled.

💡 You can also use the TrackInput buttons to switch the monitor source for record-enabled tracks, as explained below.

7. If you want to compare levels of the input source with audio on disk, click the TrackInput button. When lit (green), the track is monitoring input. When unlit (grey), the track is monitoring from disk. (For more information see “Selecting Record Monitor Modes with TrackInput Monitoring” on page 183.)

8. To punch tracks one at a time, arm the Transport Record and then use the individual Track Record Enable buttons to punch each track in and out on-the-fly.
9. To punch multiple tracks simultaneously, do one of the following:
   - Record enable as many as 16 TrackPunch enabled audio tracks, then use the Transport Record Enable button to punch them in and out simultaneously.
   - or –
   - Arm the Transport Record first, then use Alt+Shift (Win) or Option+Shift (Mac) to simultaneously punch on all currently selected TrackPunch enabled tracks.

💡 Use groups for single-click selection of multiple tracks (click to the left of the Group Name in the Group List).

10. While continuing local or remote playback, do any of the following:
    - Punch in on other TrackPunch enabled tracks individually.
    - After punching out, take tracks out of record enable then record enable different TrackPunch enabled tracks.
    - Repeat as needed to punch other stems, tracks, or takes.
**TrackPunch Preferences**

The following preference settings let you customize TrackPunch performance.

**QuickPunch/TrackPunch Crossfade Length**

Pro Tools can automatically write a crossfade for each punch point when using TrackPunch. The length for these crossfades is set with the QuickPunch Crossfade/TrackPunch Length option in the Editing Preferences page.

**To set the TrackPunch Crossfade Length:**

1. Choose Setup > Preferences and click the Editing tab.
2. Enter a new value (in msec) for the QuickPunch /TrackPunch CrossFade Length.

**Transport and Track Record Settings**

The TrackPunch preferences appear on the Operation Preferences page. These preferences specify how track and Transport record status respond when the Transport is stopped (during playback and recording), and let you optimize Pro Tools for film, video, and music production workflows.

**Transport RecordLock**

This setting lets the Transport Record be configured to either emulate a digital dubber, or to maintain legacy behavior for the Transport master Record.

- When not enabled, the Transport Record disarms when Pro Tools is manually stopped or stops due to a loss of time code. This replicates legacy Pro Tools recording behavior.
- When enabled, the Transport Record remains armed when playback or recording stops. This saves having to re-arm the Transport between takes, emulating digital dubber behavior.

**Destructive Recording and Transport RecordLock**

As a precaution against accidentally recording over previous material, the Transport RecordLock preference is automatically disabled and greyed out when Destructive record mode is enabled.

**Audio Track RecordLock**

This setting lets Pro Tools tracks be configured to either emulate a digital dubber, or to maintain legacy behavior for track record status.

- When the Audio RecordLock preference is enabled, the record-enabled audio tracks remain armed when playback or recording stops.
- When the Audio RecordLock preference is not enabled, record-enabled audio tracks are taken out of record enable when Pro Tools is stopped. This prevents tracks from remaining armed from pass to pass, emulating track record behavior of a digital dubber.
Destructive Recording and Transport
RecordLock

As a precaution against accidentally recording over previous material, the Transport RecordLock preference is automatically disabled and greyed out when Destructive record mode is enabled.

Configuring Synchronization and Track Arming

For online recording and punching, configure the following Peripheral and Session Setup settings. For best lockup times when synchronizing, it is recommended that no more than 16 tracks be TrackPunch-enabled at a time.

To record online using TrackPunch switching:

1. Choose Setup > Peripherals, and make sure the SYNC I/O is the selected synchronization peripheral, and is communicating with Pro Tools.
2. Choose Setup > Session, and do the following:
   - Select a Clock and Positional reference.
   - If you want Pro Tools to be the time code master, enable Using SYNC. This option is located in the Generator controls in the Time Code Settings section of the Session Setup window.
3. If you are controlling Pro Tools using 9-pin protocol, do the following:
   - Click the Machine Control tab to display the Machine Control page of the Peripherals dialog (Setup > Peripherals).
   - Configure Remote 9-pin Deck Emulation mode settings (see the MachineControl Guide for details).
   - Click OK to close the Peripherals dialog.

Consult the manufacturer of your controller for the most recent machine profiles and updates available for Pro Tools support.

Enabling TrackPunch Mode

Before you can enable individual audio tracks for TrackPunch recording, TrackPunch mode must be enabled in the Pro Tools transport.

To enable TrackPunch mode:

1. Make sure Pro Tools is not recording or playing back (the Transport is stopped).
2. Do one of the following:
   - Select Options > TrackPunch.
   - Right-click (Windows) or Control-click (Mac) the Transport Record Enable button to cycle through available Record modes until TrackPunch mode is selected (a “T” indicates TrackPunch mode).
   - Press Control+Shift+T (Windows) or Command+Shift+T (Mac).

Transport Display of TrackPunch Status

Transport Record with TrackPunch mode enabled

TrackPunch and TrackInput Status indicators in the Transport window
Transport Record Enable Button

The Transport Record Enable button indicates TrackPunch and Record status as follows:

When TrackPunch mode is enabled:

◆ A “T” appears in the Transport Record Enable button.
◆ If at least one track is TrackPunch-enabled, the Transport Record Enable button lights solid blue.

When TrackPunch mode is enabled and the transport is armed for recording:

◆ If no tracks are TrackPunch-enabled, the Transport Record Enable button flashes gray and red.
◆ If at least one track is TrackPunch-enabled, the Transport Record Enable button flashes blue and red.
◆ If at least one TrackPunch-enabled track is also record-enabled, the Transport Record Enable button flashes blue and red, and the record LED lights.
◆ Whenever at least one audio track is recording, the Transport Record Enable button lights solid red.

TrackPunch Enabling Tracks

You can TrackPunch enable tracks without record enabling them, which lets you punch in individual tracks after you start playback.

To TrackPunch enable or disable an audio track:

■ Start-click (Windows) or Control-click (Mac) the track’s Record Enable button to toggle the button to solid blue.

To TrackPunch enable or disable all audio tracks:

■ Alt-Start-click (Windows) or Option-Control-click (Mac) a track’s Record Enable button to toggle the all Record Enable buttons to solid blue.

To TrackPunch enable or disable all selected audio tracks:

■ Start-Alt-Shift-click (Windows) or Control-Option-Shift-click (Mac) a track’s Record Enable button to toggle the Record Enable buttons for the selected audio tracks solid blue.

Create track groups for each stem or set of tracks on which you plan to punch. Use the Group List to quickly select all tracks in the group. This makes it easier and faster to take multiple tracks in and out of TrackPunch enable simultaneously.
Track Record Status Display

Each track’s Record Enable button indicates its TrackPunch and record enable status as follows:

- When a track is both TrackPunch-enabled and record-enabled, its Record enable button flashes blue and red.
- When a track is TrackPunch-enabled but not record-enabled, its Record Enable button lights solid blue.
- When a track is record-enabled only, its Record Enable button flashes red.
- While a track is recording (in any mode), its Record Enable button lights solid red.

Punching In on Individual Tracks

To punch in on individual tracks:

1. Put Pro Tools in TrackPunch mode.
2. Start-click (Windows) or Control-click (Mac) the Record Enable button for each track you want to punch in, so that the track is TrackPunch-enabled only. The track’s Record Enable button should light solid blue.
3. Click Record in the Transport window to enter the TrackPunch Record Ready mode. The Record Enable button flashes blue and red.
4. Click Play in the Transport window to begin playback.
5. During playback, punch in and out on individual TrackPunch-enabled tracks by clicking their Record Enable buttons.
6. Stop playback. When you are finished with the record pass, track Record Enable status and transport Record Arm status follow the current TrackPunch preference settings.

Punching In on Multiple Tracks Simultaneously

To punch in on multiple tracks simultaneously:

1. Put Pro Tools in TrackPunch mode.
2. Click the Record Enable button on each track you want to punch in, so that the track is both TrackPunch- and Record-enabled. The track’s Record Enable button should flash blue and red.
3. Click Play in the Transport window to begin playback.
4. During playback, click Record in the Transport window to punch in and out on all TrackPunch-enabled tracks simultaneously.

TrackPunch Recording

After you have put Pro Tools in TrackPunch mode, and enabled tracks for TrackPunch recording, you can record with TrackPunch in several ways.
5 Stop playback. When you are finished with the record pass, track Record Enable status and transport Record Arm status follow the current TrackPunch preference settings.

**Start Recording on All Tracks**

1 Put Pro Tools in TrackPunch mode.

2 Click the Record Enable button on each track you want to punch in, so that the track is both TrackPunch- and Record-enabled. The track’s Record Enable button should flash blue and red.

3 Click Record in the Transport window to enter the TrackPunch Record Ready mode. The Record Enable button flashes blue and red.

4 Click Play in the Transport window to begin playback.

5 During playback, punch out and back in on individual TrackPunch-enabled tracks by clicking their Record Enable buttons.

6 Stop playback. When you are finished with the record pass, track Record Enable status and transport Record Arm status follow the current TrackPunch preference settings.

**Example TrackPunch Workflows**

Pro Tools emulates and enhances the following four “workflows” commonly performed in film, video, and music production:

- Dubbing and mixing film (see “Film Dubbing and Mixing with TrackPunch” on page 243)
- Loading dailies (see “Loading Dailies Using RecordLock” on page 244)
- Recording Foley (see “Foley Recording with TrackPunch” on page 245)
- Tracking and overdubbing in music production and any other recording situation (see “Tracking and Overdubbing Music with TrackPunch” on page 245)

Each of these workflows takes advantage of TrackPunch features and options.

In the following example workflows, it is assumed you already familiar with routing, selecting, and grouping Pro Tools tracks. If you are not, see the appropriate topic in *Pro Tools Reference Guide*.

**Film Dubbing and Mixing with TrackPunch**

By providing all the essential online punch recording and monitor switching capabilities of a digital dubber, TrackPunch optimizes Pro Tools for re-recording and mixing for film.

Film dubbing and mixing features of TrackPunch let you do the following:

- Arm and punch Pro Tools audio tracks remotely from a master synchronizer such as SoundMaster through P2 commands at any time, without having to stop playback and while maintaining time code lock. (Requires Digidesign MachineControl.)
- Toggle Pro Tools audio tracks between input and disk monitoring.
- Use TrackPunch when Pro Tools is the time code master (generating) and when slaving.
- Because Pro Tools can be networked, TrackPunch (and all other) audio files and whole sessions can be available for secure transfer to other systems for review, editing, and archiving.

A typical pre-dub session using TrackPunch includes the following steps:

1 Configure synchronization between Pro Tools and other devices as appropriate.

2 Choose Setup > Preferences and click the Operation tab.
3 Select (enable) Transport RecordLock. This will keep the Transport Record armed after the transport stops.

4 Deselect Audio Track RecordLock. This will cause the audio track record to disarm when the transport stops.

5 Choose Options > TrackPunch to enable TrackPunch mode.

6 Create 32 new tracks, then do the following:
   • Assign their inputs
   • Group them into eight-track groups.

7 Click the record enable buttons in the first eight tracks to TrackPunch enable the first eight tracks (or, the group for the first pre-dub).

8 Assign the console paddles to the first eight-track group in the session.

9 Begin the pre-dub pass. Use the console paddles to arm Pro Tools, and to punch in and out on the first group.

10 When the first pre-dub is over and all tracks are punched out, clear all TrackPunch enabled tracks.

11 Select the next group of tracks and TrackPunch-enable them.

12 Punch in and out on the second group of tracks.

13 Repeat as needed.

Loading Dailies Using RecordLock

In addition to its uses on dub and mix stages, Pro Tools makes it easy to load dailies. Dailies and similar types of transfers are comprised of multiple takes or scenes, each recorded while locked to unique time-of-day time code. In between each take, time code does not continue but stops completely. Because of this, the time code on dailies and similar source material is said to be “discontiguous” or discontinuous (also known as broken time code).

When a session is taken offline while recording due to broken time code, Pro Tools remains armed and waits for time code to resume. Pro Tools begins recording again when lock is re-established with the time code of the next take. Each take is recorded to its own audio file.

To configure RecordLock for loading:

1 Choose Setup > Preferences and click the Operation tab.

2 Select (enable) Transport RecordLock.

3 Select (enable) Audio Track RecordLock.

4 Configure synchronization and other settings as required.

5 Put Pro Tools online, and start the external source player.
Whenever time code drops out or stops, Pro Tools remains online and waits to receive new time code. The Transport and record-enabled tracks remain record-enabled (or TrackPunch enabled). When time code resumes, Pro Tools begins recording to a new audio file (properly time stamped based on the incoming code).

Because Pro Tools has a 13-hour timeline limit, you must use multiple sessions to load dailies if the span is more than 13 hours.

Foley Recording with TrackPunch

Foley recording is one of the more specialized forms of recording in film production with unique monitoring requirements. Between punches and takes, inputs must be muted while Foley artists move themselves and equipment as they progress through a scene.

TrackInput monitoring can be configured to support Foley style TrackPunch recording using the Mute Record-Armed Tracks While Stopped preference.

To configure Pro Tools for Foley-style punch record monitoring:

1. Choose Setup > Preferences and click the Operation tab.
2. Enable Mute Record-Armed Tracks While Stopped.
3. Configure synchronization and other settings for Pro Tools and your other devices, then enable TrackPunch mode and proceed with punch recording. (See “Overview of TrackPunch Recording” on page 237 for the complete steps.)

When recording online and Mute Record-Armed Tracks While Stopped is enabled, record-enabled tracks mute when the Transport is stopped. Input can still be monitored at any time by using the TrackInput switch.

Tracking and Overdubbing Music with TrackPunch

Modern multitrack recording requires the flexibility to “capture the moment” by allowing on-the-fly record enabling and punch recording, as provided by TrackPunch. Features of TrackPunch for all tracking, overdubbing, and punching situations include the following:

- Record enable tracks on-the-fly.
- Punch tracks in and out using on-screen Record Enable buttons, remotely from a synchronizer, from a control surface, or using a foot switch.
- Compare and match levels using TrackInput switching.

DestructivePunch Audio Recording

(Pro Tools HD Only)

DestructivePunch is a destructive recording mode that lets you instantaneously punch in (start recording) and punch out (stop recording) on individual audio tracks during playback, while preserving a contiguous audio file on each punched track. No additional regions are created when recording in DestructivePunch mode.

DestructivePunch is useful for mixing and pre-dubbing workflows where you want the final result to be a single, contiguous file without any edits.
DestructivePunch is essentially a destructive version of TrackPunch mode. Where TrackPunch always records audio to a new file in the background, DestructivePunch destructively records audio directly into the original file, using a fixed 10-millisecond linear crossfade. Up to 200 “running punches” can be performed in a track during a single DestructivePunch pass.

**DestructivePunch and MachineControl**

When using Digidesign MachineControl software in Remote 9-Pin Deck Emulation Mode, DestructivePunch can be controlled via P2 protocol.

**DestructivePunch and Voice Allocation**

As with TrackPunch and QuickPunch, DestructivePunch requires 2 available voices per mono track. When using DestructivePunch with a Pro Tools|HD system configured for maximum voices, make sure to set the voice assignment for each audio track to *dyn* for Dynamically Allocated Voicing. This ensures that Pro Tools can automatically manage voices most efficiently.

**Configuring Pro Tools for DestructivePunch Recording**

Before using DestructivePunch, configure DestructivePunch preferences and related Pro Tools settings as described in this section.

**Transport and Track Record Settings**

The Transport RecordLock and Audio RecordLock preferences specify track and Transport Record Enable behavior when playback or recording are stopped. They function with DestructivePunch as with TrackPunch. For more information, see “TrackPunch Preferences” on page 239.

**Delay Compensation Settings**

When using DestructivePunch to punch into an existing recording, make sure the Delay Compensation settings are the same as when the original file was recorded.

- If Delay Compensation was active when recording the original file, it should be kept active while punching into the original file in DestructivePunch mode.
- If Delay Compensation was inactive when recording the original file, it should be deactivated while punching into the original file in DestructivePunch mode.

To ensure that the Delay Compensation path on record tracks remains consistent while using DestructivePunch, you will need to prevent Pro Tools from using the Low Latency monitoring path when record tracks switch to Input monitoring.

**To ensure that Low-Latency monitoring is disabled for a record track:**

- Start-Control-click (Windows) or Command-Control-click (Mac) the Track Compensation indicator on the track.

**To ensure that Low-Latency monitoring is disabled for all selected record tracks:**

- Start-Control-Shift-click (Windows) or Command-Control-Shift-click (Mac) the Track Compensation indicator on the track.

**To ensure that Low-Latency monitoring is disabled for all record tracks:**

- Start-Control-Alt-Shift-click (Windows) or Command-Control-Option-Shift-click (Mac) the Track Compensation indicator on the track.
Enabling DestructivePunch Mode

Before you can enable individual audio tracks for DestructivePunch recording, you must put Pro Tools in DestructivePunch mode.

To enable DestructivePunch mode:

1. Make sure Pro Tools is not recording or playing back (the Transport is stopped).
2. Do one of the following:
   - Select Options > DestructivePunch.
   - Right-click the Transport Record Enable button and choose DestructivePunch from the pop-up menu.
   - Start-click (Windows) or Control-click (Mac) the Transport Record Enable button to cycle through available Record modes until DestructivePunch mode is indicated by “dp” in the Transport Record Enable button.

Enabling Tracks for DestructivePunch Recording

DestructivePunch Enabling Tracks without Record Enabling Them

You can enable tracks for DestructivePunch without record enabling them. This lets you punch in on individual tracks at any time after starting playback by clicking the Record Enable button.

To DestructivePunch enable an audio track:

- Start-click (Windows) or Control-click (Mac) the track’s Record Enable button to toggle the button to solid blue.

To DestructivePunch enable all audio tracks:

- Alt-Start-click (Windows) or Option-Control-click (Mac) a track’s Record Enable button to toggle all Record Enable buttons to solid blue.

To DestructivePunch enable all selected audio tracks:

- Start-Alt-Shift-click (Windows) or Control-Option-Shift-click (Mac) a track’s Record Enable button to toggle the Record Enable buttons for the selected audio tracks solid blue.

Create a VCA group for each stem or set of tracks on which you plan to punch, and use the VCA Record Enable button to arm all tracks in the group for DestructivePunch.

DestructivePunch Enabling and Record Enabling Tracks Simultaneously

You can simultaneously DestructivePunch enable tracks and record enable them. This starts recording as soon as the transport is record-armed and playback begins.

To simultaneously DestructivePunch enable and record enable an audio track:

- Click the track’s Record Enable button to toggle the track’s Record Enable button to flashing blue and red.

To simultaneously DestructivePunch enable and record enable all audio tracks:

- Alt-click (Windows) or Option-click (Mac) a track’s Record Enable button to toggle all Record Enable buttons to flashing blue and red.

To simultaneously DestructivePunch enable and record enable all selected audio tracks:

- Alt-Shift-click (Windows) or Option-Shift-click (Mac) a track’s Record Enable button to toggle the Record Enable buttons for the selected audio tracks to flashing blue and red.
Display of DestructivePunch Status

Transport Record Enable Button

The Transport Record Enable button indicates DestructivePunch mode and Record status as follows:

When DestructivePunch mode is enabled:
- The letters “dp” appears in the Transport Record Enable button.

When DestructivePunch mode is enabled and the transport is armed for recording:
- If no tracks are DestructivePunch-enabled, the Transport Record Enable button flashes gray and red.
- If at least one track is DestructivePunch-enabled, the Transport Record Enable button flashes blue and red.
- If at least one DestructivePunch-enabled track is also record enabled, the Transport Record Enable button flashes blue and red, and the record LED lights.

Whenever at least one audio track is recording, the Transport Record Enable button lights solid red.

Track Record Status Display

When Pro Tools is in DestructivePunch mode, each track’s Record Enable button indicates its DestructivePunch and record enable status as follows:

- When a track is both DestructivePunch-enabled and record-enabled, its Record Enable button flashes blue and red.
- When a track is DestructivePunch-enabled but not record-enabled, its Record Enable button lights solid blue.
- When a track is record-enabled only, its Record Enable button flashes red.
- While a track is recording (in any mode), its Record Enable button lights solid red.
Record and Input Status LEDs

Record and Input LEDs next to the Transport Record Enable button indicate track Record and Input status as follows, in all recording modes:

**Record Status LED** When lit (red), indicates that at least one audio track is currently record-enabled. When off (grey), no tracks are currently record-enabled.

**Input Status LED** When lit (green), indicates that at least one audio track is currently set to Input Only monitoring (regardless of record enabled status). When off (grey), all tracks are in Auto Input monitoring.

> Track Record Enable buttons also appear in blue to indicate that track is Destructive-Punch-enabled.

Preparing Tracks for DestructivePunch Recording

In order for a track to be enabled for Destructive-Punch recording, the track must contain a contiguous audio file that meets the following requirements:

- The file must start at the beginning (sample 0) of the session.
- The File Length must be equal to or greater than the DestructivePunch File Length setting (see “DestructivePunch File Length” on page 249).

If a track does not contain a file that meets these requirements, you can do any of the following to meet the requirements:

- Move the current file in the track timeline so that its beginning aligns with the session start.
- Select the material in the track and use the Consolidate command to create a continuous file of the required length.
- Change the DestructivePunch File Length setting so that the current file is equal to or greater than the required length.
- Use the Prepare DPE Tracks command to consolidate audio on all DestructivePunch-enabled tracks. (See “Using the Prepare DPE Tracks Command” on page 249.)

DestructivePunch File Length

To use DestructivePunch on an audio track, the track must contain a contiguous audio file of a minimum length, which is set in the Pro Tools Operation preferences page.

To set DestructivePunch File Length:

1. Choose Setup > Preferences and click Operation.
2. Enter a value for DestructivePunch File Length.
3. Click OK.

Using the Prepare DPE Tracks Command

To prepare a track for DestructivePunch recording:

1. Make sure DestructivePunch mode is enabled.
2. Make sure the tracks you want to prepare are DestructivePunch-enabled. See “Destructive-Punch Enabling Tracks without Record Enabling Them” on page 247.
3. Choose Options > Prepare DPE Tracks.
Pro Tools consolidates audio on all Destructive-Punch-enabled tracks from the beginning of the session to the value specified in the Destructive-Punch File Length preference.

**DestructivePunch Recording**

After you have put Pro Tools in Destructive-Punch mode, enabled tracks for Destructive-Punch recording, and prepared tracks if necessary, you can record in several ways.

**Punching In On Single Tracks**

To punch in on single tracks:

1. Put Pro Tools in DestructivePunch mode.
2. Start-click (Windows) or Control-click (Mac) the Record Enable button for each track you want to punch in, so that the track is DestructivePunch-enabled only. The track’s Record Enable button lights solid blue.
3. Click Record in the Transport window to enter Record Ready mode. The Record Enable button flashes blue and red.
4. Click Play in the Transport window to begin playback.
5. During playback, punch in and out on individual DestructivePunch-enabled tracks by clicking their Record Enable buttons.
6. Stop playback. When you are finished with the record pass, track Record Enable status and transport Record Arm status follow the current Audio Track RecordLock and Transport Record-Lock preference settings.

**Punching In on Multiple Tracks**

To punch in on multiple tracks simultaneously:

1. Put Pro Tools in DestructivePunch mode.
2. Start-click (Windows) or Control-click (Mac) the Record Enable button for each track you want to punch in, so that the track is both DestructivePunch- and Record-enabled. Each track’s Record Enable button flashes blue and red.
3. Click in the Transport window to begin playback.
4. During playback, click Record in the Transport window to punch in and out on all Destructive-Punch-enabled tracks simultaneously.
5. Stop playback. When you are finished with the record pass, track Record Enable status and transport Record Arm status follow the current Audio Track RecordLock and Transport Record-Lock preference settings.

**Starting Recording Immediately on Multiple Tracks**

To immediately start recording on multiple tracks:

1. Put Pro Tools in DestructivePunch mode.
2. Start-click (Windows) or Control-click (Mac) the Record Enable button for each track you want to punch in, so that the track is both DestructivePunch- and Record-enabled. Each track’s Record Enable button flashes blue and red.
3. Click Record in the Transport window to enter Record Ready mode. The Record Enable button flashes blue and red.
4. Click Play in the Transport window to begin playback.
5. During playback, punch out and back in on individual DestructivePunch-enabled tracks by clicking their Record Enable buttons.
6. Stop playback. When you are finished with the record pass, track Record Enable status and transport Record Arm status follow the current Audio Track RecordLock and Transport Record-Lock preference settings.
Part IV: Editing
Chapter 15: Editing Basics

Pro Tools Editing

The Edit window in Pro Tools provides a powerful collection of tools for editing and assembling audio and MIDI. Track material can be edited nondestructively and in real time during playback.

The Edit window also lets you graphically edit track automation. For more information on Automation in the Edit window, see Chapter 27, “Automation.”

Nondestructive Editing

The vast majority of audio editing in Pro Tools is nondestructive. Whether cutting, pasting, trimming, separating, or clearing regions, you are only performing these functions on a map of the actual audio data. The source audio files remain untouched. If a particular process or tool works destructively (that is, if it can permanently change audio files on your hard disk), this guide alerts you.

While editing for MIDI tracks is in some instances destructive, with a few precautions you can keep important MIDI tracks and regions safe when performing edits (see “Nondestructive MIDI Editing” on page 264).

Editing During Playback

Pro Tools lets you perform many editing tasks while the session plays. This powerful capability allows you to interactively modify and edit a session, hearing the changes as you make them. You’ll find many instances where you can use this capability to increase your productivity when working with a session.

Following are just a few examples of editing that can be performed while your tracks loop or play:

- Capture, separate, and trim regions
- Place, spot, or rearrange regions
- Add fades or crossfades to audio regions
- Transpose, quantize (including Groove Quantize), and otherwise modify MIDI tracks
- Nudge audio or MIDI regions
- Audition different playlists
- Adjust or scale automation data
- Insert a real-time plug-in
- Process audio with an AudioSuite plug-in
- Automation breakpoint editing

There are a few things that cannot be changed while Pro Tools plays, as noted throughout this guide. These include routing to sends and assigning outputs.
Track Material

Each time you record or import audio and MIDI, Pro Tools creates regions for the new track data, which not only indicate where the material begins and ends, but also provides good feedback on its general shape and content. When you record additional takes, or “punch in” on a specific location within a track, Pro Tools creates additional regions.

Regions are also created by cutting and pasting, resizing, separating, and re-capturing existing regions. Regions in a session are listed in the Region List, where they can be dragged to existing tracks. A track can contain any number of regions, in any arrangement. The order and location of regions in a track define its playlist.

Region Types

There are different types of audio and MIDI regions, based on how they are created:

Whole-File Audio Regions These audio regions are created when recording or importing audio, consolidating existing regions, and when non-destructively processing with an AudioSuite plug-in. Whole-file audio regions reference an entire audio file that resides on your hard drive. Whole-file audio regions are displayed in bold in the Region List (see “The Region List” on page 275). Normal regions often reference only a portion of the parent audio file and are created in the course of editing and, in some instances, when punch recording.

User-Defined Regions These are regions that are explicitly defined, such as when you record or import audio or MIDI; capture, separate, or consolidate a selection; trim a whole-file audio region; and rename an existing region.

Auto-Created Regions These regions are automatically created in the course of editing, and, in some instances, when punch recording over existing regions. Since these regions can accumulate rapidly in a session, you can hide them so they do not appear in the Region List (see “Naming and Displaying Regions” on page 396). Auto-created regions can be turned into user-defined regions by renaming them.

Offline Regions Regions are offline when their parent audio files cannot be located, or are not available, when opening a session or importing a track. Offline regions appear in the Region List as italicized and dimmed; they appear in playlists as light blue regions with italicized names. Offline regions can be edited like other regions, but they cannot be processed with AudioSuite plug-ins.

Multichannel Regions These regions, which are displayed as a single region in the Region List, reference multiple regions and audio files for stereo and surround tracks. Multichannel regions can be expanded (by clicking the triangle next to their name) to see the individual channels, which can be dragged independently to tracks.

Region Groups A region group is a collection of any combination of audio and MIDI regions that looks and acts like a single region. Region groups are essentially containers holding one or more regions. Region groups can be created on a single or on multiple adjacent audio, MIDI, and
Instrument tracks. Region groups let you “nest” multiple regions into “macro” regions for groove and tempo manipulation, editing, and arranging.

For more information on region groups, see “Region Groups” on page 362.

**Track View**

The Track View determines which data is displayed and edited in the track’s playlist area. Track View data can be set to Blocks, Waveform, Volume, Pan, Mute, or an automated control or continuous controller, based on the track type:

**Audio Tracks** These tracks can be set to Blocks, Waveform, Volume, Volume Trim, Pan, Mute, or any plug-in controls that have been automated. Except when editing automation data, audio tracks are by default set to Waveform, where track material is graphically drawn with amplitude waveforms (a time-domain representation of sound). This Track View provides the necessary detail for important region edits.

**Auxiliary Input Tracks** These tracks can be set to Volume, Volume Trim, Pan, Mute, or any plug-in control that has been automated.

**Master Fader Tracks** These tracks can be set to Volume, Volume Trim, or any plug-in control that has been automated.

**VCA Master Tracks (Pro Tools HD Only)** These tracks can be set to Volume, Volume Trim, or Mute.

**MIDI Tracks** These tracks can be set to Blocks, Regions, Notes, Volume, Pan, Mute, Velocity, Pitch Bend, After Touch, Program, Sysex, and any continuous controller type. Except when editing controller data, program changes, or Sysex events, MIDI tracks are commonly set to Notes or Regions, each of which displays notes in a “piano roll” format. Use Notes View for inserting, editing, and copying and pasting MIDI notes; use Regions View to arrange, capture, or consolidate regions.

**Instrument Tracks** These tracks can be set to Blocks, Regions, Notes, Volume, Pan, Mute, Velocity, Pitch Bend, After Touch, Program, Sysex, and any continuous controller type. Except when editing controller data, program changes, or Sysex events, Instrument tracks are commonly set to Notes or Regions, each of which displays notes in a “piano roll” format. Use Notes View for inserting, editing, and copying and pasting MIDI notes; use Regions View to arrange, capture, or consolidate regions.

With the Track View set to Blocks, audio and MIDI regions are displayed as empty blocks bearing the region’s name. This mode is most useful once you have finished capturing and editing regions at the waveform or MIDI event level and are moving and rearranging them. Screen redraws are fastest with this format.

When an audio or Instrument track is displayed as Volume, Pan, or another automated control, or when a MIDI or Instrument track is set to one of the continuous controller types (Volume,
Pitch Bend, After Touch), the data for that track appears in the form of a line graph with a series of editable breakpoints. The breakpoints can be dragged to modify the automation data, and new breakpoints can be inserted with the Pencil tool or a Grabber tool.

Track View set to Pan for audio track

For details on editing automation data for audio tracks, see Chapter 27, “Automation.” For details on inserting and editing controller data for MIDI tracks, see “Continuous Controller Events” on page 472.

To set the Track View:

- Click the Track View selector for the track and choose the format from the pop-up menu.

The track displays the new format. If the track is part of an active Edit Group, all tracks in the group are set to the new format.
Chapter 15: Editing Basics

Changing Track Views

For audio, Auxiliary Input, MIDI, and Instrument tracks, you can change to the next or previous Track View, or toggle between pre-defined common views.

Changing to Previous or Next Track View

When changing to the next or previous Track View, Track View list ordering is maintained as shown in the Track View selector.

⚠️ Track Views at the beginning of the list (such as Blocks for audio or MIDI tracks) cannot be changed to the previous Track View. Tracks Views at the end of the list (such as a MIDI controllers option) cannot be changed to the next Track View.

To change to the previous or next Track View:

1. Click in the track you want to change. To change views on multiple tracks, Shift-click or drag the Selector tool to select additional tracks, or select a group.

2. Do one of the following:
   - To change to the previous or next Track View on all selected tracks, press Control+Start (Windows) or Control+Command (Mac) and the Left or Right Arrow.
   - or –
   - To change to the previous or next Track View on all tracks, press Control+Alt+Start (Windows) or Control+Option+Command (Mac) and the Left or Right Arrow.

Toggling Common Track Views

The most common editing view for audio tracks are Waveform and Volume View. The most common editing views for MIDI and Instrument tracks are Notes and Regions View. Pro Tools provides an easy way to toggle these views.

To toggle Track Views on selected tracks:

1. Click in the track you want to toggle. To toggle multiple tracks, Shift-click or drag the Selector tool to select additional tracks.

2. Do one of the following:
   - Press Start+Minus (Windows) or Control+Minus (Mac) on the QWERTY keyboard.

   To toggle Track Views for all tracks, press Start+Alt+Minus (Windows) or Control+Option+Minus (Mac) on the QWERTY keyboard.

   – or –
   - With Commands Keyboard Focus enabled, press Minus on the QWERTY keyboard.

   To toggle Track Views for all tracks with Command Focus enabled, press Alt+Minus (Windows) or Option+Minus (Mac) on the QWERTY keyboard.

Audio tracks are toggled between Waveform and Volume View. MIDI and Instrument tracks are toggled between Notes and Regions View.

Master Views for Tracks

Audio, MIDI, and Instrument tracks have Track Views that act as “master.” When a track is displayed in its Master View, any edits performed apply to all data in the track. For instance, when an audio track is set to Waveform, copying and pasting affects not just the waveform information, but all of the automation data as well.

The Master View is based on the type of track, as follows:

- Audio tracks: Waveform and Blocks
- MIDI and Instrument tracks: Regions, Blocks, and Notes (when using the Selector tool)
Auxiliary Input, Master Fader, and VCA Master tracks also have a Master View (Volume). When an Auxiliary Input or Master Fader track is displayed in its Master View, any edits performed apply to all automation data in the track.

**Track Height**

Tracks can be viewed in the Edit window at any of six heights: *Mini, Small, Medium, Large, Jumbo*, and *Extreme*. Larger track heights are particularly useful for precise editing, especially for MIDI. Smaller track heights are useful for conserving screen space in a large session.

You can adjust track heights on an individual track basis or set all tracks to the same height. Track heights can be adjusted during playback.

**To set the Track Height, do one of the following:**

- Click the small arrow next to the Track View selector to get the Track Height pop-up menu.

- ▬ or ▬

- Click in the area just to the right of the track controls and choose the height from the pop-up menu.

The track is resized to the new height. If the track is part of an Edit Group, all tracks in the group are set to the new height.

**Expanded Track Display**

Stereo and multichannel tracks share a single playlist for volume and mute. This shared playlist normally occupies the entire height of the track, extending across all channels.

With Expanded Track Display, you can display playlists individually for each channel, thereby allowing for more accurate breakpoint editing. This is also useful for editing pan or multi-mono plug-in data, both of which can be different for each channel.

Expanded Track Display also provides for a larger waveform display (equal to mono tracks), as well as a separate Track View selector and meter for each channel.
To turn on Expanded Track Display:

- From the Track Height selector, click Expanded Track Display.

When the Track Height is set to Large, Jumbo, or Extreme, all track controls are displayed at their full size.

Track Controls and Track Height

The Track Height affects how the various track controls appear in the Edit window. For instance, when a track’s height is set to Small, most of the buttons are reduced in size.

Displaying Region Names, Region Times, and Other Data in Playlists

Region names and times can sometimes get in the way of editing audio waveforms and MIDI data. In these instances you may want to disable their display. In other instances, such as arranging or spotting Foley, displaying region names and times is extremely useful.

To enable or disable the display of region names in playlists:

- Select or deselect View > Region > Name.

To display region times:

- From View > Region, select one of the following options:
  
  No Time Disables display of region times.
  
  Current Time Displays start and end times for regions.
  
  Original Time Stamp Displays the Original Time Stamp for each region. The Original Time Stamp is the original time code location for the region when it was first recorded or created.
**User Time Stamp** Displays the User Time Stamp for each region. The User Time Stamp, which defaults to the Original Time Stamp, can be re-defined with the Time Stamp command.

Region and region group Sync Points can be displayed on regions in playlists (see “Sync Points” on page 344). This is useful when visually spotting to time code or in arranging in Grid mode.

Region Overlaps can be displayed on regions in playlists. This is useful for arranging and when working with tick-based audio tracks (see “Region Overlap and Underlap” on page 330).

Channel Name and Scene And Take information can be displayed in regions in playlists and in the Region List. This is useful for working with multichannel recordings and metadata made by field recorders.

See the Field Recorder Workflow Guide for detailed information on workflows for field recorders.

**Audio Regions and Waveforms**

When the Track View for audio tracks is set to Waveform, Pro Tools draws a waveform diagram of the audio. Audio waveforms tell you several things about the recorded sound.

In Figure 8, the “peaks” represent places in the recording where the attack of the sound causes the volume to increase momentarily. These are followed by “valleys,” where the volume decreases.

Different types of sounds produce different types of waveforms. Drums, for example, generally produce waveforms with sharp transients (peaks of short duration) that are clearly defined. A drum hit has a loud, sharp attack and a rapid decay.

Other sounds, such as vocals or sustained keyboard sounds, produce very different waveforms, ones that have less pronounced peaks and valleys. That’s because these sounds generally have softer attacks and longer decays.

**Draw Waveforms Rectified Preference**

When the Display preference for Draw Waveforms Rectified is selected (in the Display Preferences page), audio waveforms are displayed so that their positive and negative waveform excursions are summed together and viewed as a single positive-value signal. However, even when this preference is enabled, zooming in beyond a certain point will cause the waveforms to be displayed normally.
Rectified mode displays more detailed waveforms when using track heights of Medium or Small, and can be particularly useful when editing volume automation data, since it depicts waveform “levels” as starting at the bottom of the track.

**Guidelines for Editing Waveforms**

With the Selector tool in the Edit window, you can select portions of audio waveforms and divide them into segments called regions, so that you can rearrange and manipulate them in tracks.

While editing, try to create regions that allow you to maintain a consistent beat. If you always define regions so that they contain a whole number of beats, you will be able to string the regions together and maintain a smooth, steady rhythm.

It’s sometimes useful to have a steady, well-defined waveform (such as a drum track) as a guide when selecting and defining other regions. If you have played in time with the beat, it should be easier to create rhythmically accurate regions by referring to the drum waveform.

Some important rules to keep in mind when defining regions:

- Whenever possible, begin a region precisely before a volume peak, and end it immediately before another volume peak.
- Whenever possible, make sure a region starts and ends on exactly the same part of a beat.

- Use the following Pro Tools features to help you edit rhythmic material or audio with clear transients into precise regions:
  - Tab to Transients (see “Tabbing to Transients” on page 319.)
  - Beat Detective (see Chapter 21, “Beat Detective”)
  - Editing to a Grid (see “Grid” on page 282)

**Avoiding Clicks and Pops**

If an edited region begins or ends at a point of high amplitude, you may hear an unpleasant click when Pro Tools plays from one region to another. In order to avoid clicks or pops do any of the following:

- Make sure that the start and end points of your selection are as close as possible to the point where the amplitude of the waveform tapers down to meet the zero-crossing line (the center line of the track’s waveform display). If necessary, use the zooming tools in the Edit window (see “Using the Zoomer Tools” on page 284) to display waveforms in greater detail.

- With Pro Tools HD, use the AutoFade feature to apply real-time fade-ins/outs to all region boundaries that do not touch or overlap other regions. See “Using AutoFades” on page 384 for details.

- Apply a crossfade between regions where a click or pop occurs. See “Creating a Crossfade” on page 381 for details.
Nondestructive Audio Editing

When editing an audio track's playlist in Pro Tools, you’re not actually cutting and moving pieces of sound as you would if you were cutting and splicing analog tape. Instead, Pro Tools creates a map of the audio file on your hard disk, which describes the order in which to play the track portions.

When trimming audio regions with any of the Trim tools, or when editing the placement or order of regions within a track, use multiple playlists to easily return to a track’s previous state. See “Playlists” on page 270 for details.

Audio Regions and Automation Data

Automation data for audio resides in tracks and not in the Region List. This means that when you drag an audio region from the Region List to a new track, no automation data is placed in the track. However, if you drag an audio region from an existing track (that contains automation data) to another track, the automation from the source track is placed in the destination track.

MIDI Regions and MIDI Data

The two most common Track Views you will use for MIDI and Instrument tracks are Notes and Regions.

Use Notes View for inserting and editing individual MIDI notes, and for working with and affecting groups of notes.

Use Regions Views when you need to experiment with the arrangement of regions, or define new ones.

For more information on setting Track View, see “Track View” on page 255.

To toggle the Track View, click in the track you want to toggle and press Start+Minus (Windows) or Control+Minus (Mac) on the QWERTY keyboard.

Notes View for MIDI and Instrument Tracks

When a MIDI or Instrument track’s Track View is set to Notes, MIDI notes are displayed in a “piano roll” format. Each note is displayed as a small rectangle with its vertical placement indicating pitch and its horizontal placement indicating location (and duration).
pitches. Arrows at the top and bottom of the mini-keyboard (not available in the smaller track heights) are used to scroll the Notes display up and down.

In Notes View, the pitch range of MIDI notes that can be displayed depends on the track height, and on the current zoom value. Any time a track's notes do not fit within its current height, notes above or below the viewed area are displayed as single-pixel lines at the very top and bottom of the range (see Figure 9 on page 262).

To scroll the Notes display up or down for a MIDI or Instrument track, do one of the following:

- Click either the up or down arrow of the mini-keyboard.

- With any of the Edit window tools (such as the Time Grabber tool) selected, press Control+Alt+Start (Windows) or Command+Option-Control (Mac) and click and drag up or down on the mini-keyboard.

Using the Edit window tools, notes can be inserted, transposed, trimmed, and moved. For more information, see "Manually Editing MIDI Notes" on page 465.

If you have a mouse with a scroll wheel, you can use it to scroll a MIDI or Instrument track's Notes display. Place the mouse over a MIDI or Instrument track in the Edit window, and Alt-Start-Control-scroll (Windows) or Command-Control-Option-scroll (Mac) the scroll wheel to scroll the Notes display for that track.

Regions View for MIDI and Instrument Tracks

MIDI and Instrument tracks can also be viewed as Regions, which is similar to Waveform View for audio tracks. While a track's notes are visible in Regions View, individual note editing is not available in this view. Instead, all editing occurs across a time range encompassing all track data, including continuous controller events, program changes, and System Exclusive events.

Use Regions View to define regions that represent song sections and clips, or to rearrange or assemble track material.

In Regions View, the vertical Zoom is automatically scaled to fit the entire range of pitches (tessitura) of MIDI notes on a track.

For more information on setting Track View, see “Track View” on page 255.

To toggle Track View between notes and regions, click in the track you want and press Start-Minus (Windows) or Control-Minus (Mac) on the QWERTY keyboard, or press Control-Alt (Windows) or Command-Option (Mac) and use the Left and Right Arrow keys to cycle between Track Views.
There are a few things to consider when selecting, copying and cutting, and trimming MIDI regions:

◆ When cutting or clearing a region or region group selection that includes a note’s start point, the entire note is removed. This is even the case when only a portion of the note (that includes its start point) is selected.

◆ When copying or cutting a region or region group selection that includes a note’s end point (but not its start point), the note remains and overlaps the edge of the region.

◆ Similar rules also apply when MIDI regions or region groups containing MIDI regions are trimmed with any of the Trim tools. If the MIDI region’s start point is moved beyond a note’s start point, the note is removed. If the region’s end point is trimmed so that a note’s start point is within the region but its end point is not, the note remains and overlaps the edge of the region.

When moving and placing MIDI regions with overlapping notes, the notes always move with the regions. When placing MIDI regions with overlapping notes next to or near another region, the overlapping notes extend into the adjacent region.

Nondestructive MIDI Editing

While editing audio regions is usually nondestructive, this is not always the case for MIDI regions. For instance, if a MIDI region resides in just one track at a single location, editing for that region is destructive. This means that altering the pitch, duration, or placement of notes in Notes View permanently alters the region.

However, when editing a MIDI region that appears elsewhere, in the same track (at another location or in a different playlist) or in another track, the editing is nondestructive and creates a new auto-created region. To go back to the previous material, drag the original region from the Region List, or return to a previously saved playlist.

💡 One way to safely return to a track’s previous state is with playlists. Before you edit notes, trim regions, or rearrange the order of regions, make a duplicate of the track’s existing playlist and instead work with it (see “Playlists” on page 270).

💡 To apply edits to all instances of a MIDI region, enable Mirrored MIDI Editing mode (see “Mirrored MIDI Editing” on page 461).
MIDI Regions and Continuous Controller Events

Continuous controller events reside in MIDI regions and not in tracks. This means that when dragging regions that contain controller data from either a track or the Region List, the controller data is written to the destination track.

Unlike continuous controller events, which represent nuances that are part of a MIDI performance, Mute in Pro Tools is an automation playlist that actually mutes the MIDI engine. Mute automation does not correspond to actual MIDI events and is therefore not exported when saving as a Standard MIDI File.

Timebase Rulers and Conductor Rulers

Any or all of the following Timebase rulers can be displayed at the top of the Edit window:
- Bars:Beats
- Minutes:Seconds
- Time Code (Pro Tools HD and Pro Tools LE with DV Toolkit 2 only)
- Feet+Frames (Pro Tools HD and Pro Tools LE with DV Toolkit 2 only)
- Samples

In addition to providing a timing reference for track material, the Timebase rulers are also used to define Edit selections for track material, and Timeline selections for record and play ranges.

With the Selector tool, drag in any Timebase ruler to select material across all tracks in the Edit window. To include the Conductor tracks in the selection, press Alt (Windows) or Option (Mac) while dragging.

Any or all of the following Conductor rulers can be displayed:
- Tempo (and Tempo Editor)
- Meter
- Markers

The Meter and Tempo rulers indicate changes in meter and tempo within the Session. The Markers ruler displays markers to important track locations.

- For more information on Tempo rulers, see “Tempo” on page 400.
- For more information on Meter rulers, see “Meter Events” on page 420.
- For more information on markers, see Chapter 20, “Conductor Tracks and Memory Locations.”

To display all rulers:
- Select View > Rulers > All.

To remove a ruler from the display, do one of the following:
- Option-click the ruler’s name (to the left of the ruler display).
- or
- Choose View > Rulers, and select a ruler option.
To display only the Main Time Scale in the Timebase ruler:
- Select View > Rulers > None. (See “Main Time Scale” on page 266.)

To add a specific ruler to the display, such as the Markers ruler, for instance:
- Select View > Rulers > Marker.

To change the display order for the rulers:
- Click a ruler’s name and drag up or down to the new location.

**Ruler View Selector**

The Timebase and Conductor rulers can also be configured with the Ruler View selector.

The Main Time Scale determines the time format used for:
- The Main Counter in the Transport window
- The Main Counter at the top of the Edit window
- Start, end, and length values
- Pre- and post-roll amounts
- Grid and Nudge values

The Main Time Scale can be set to the following formats:

- **Bars:Beats** Displays the Time Scale in bars and beats. Use this Time Scale if you are working with musical material that must align with bars and beats.

  - To ensure your tracks align with the bars and beats in your session, record with a click (see “Recording with a Click” on page 193). Material that is recorded without listening to the click can still be aligned to bar and beat boundaries in Pro Tools with the Identify Beat command (see “Identify Beat Command” on page 416), or with Beat Detective (see Chapter 21, “Beat Detective”).

- **Minutes:Seconds** Displays the Time Scale in minutes and seconds. As you zoom in farther with the Zoomer tool, the Time Scale begins to display tenths, hundredths, and thousandths of a second.

- **Time Code (Pro Tools HD and Pro Tools LE with DV Toolkit 2 Only)** Displays the Time Scale in SMPTE frames. The Time Code Rate and Session Start time are set from the Session Setup window.

  Pro Tools supports the following frame rates: 23.976, 24, 25, 29.97 Non-Drop, 29.97 Drop, 30 Non-Drop, and 30 Drop frames per second.
Feet+Frames (Pro Tools HD and Pro Tools LE with DV Toolkit 2 Only) Displays the Time Scale in feet and frames for referencing audio-for-film projects. The Feet+Frames time display is based on the 35 millimeter film format.

**Samples** Displays the Time Scale in samples. This format is very useful for high-precision sample editing.

### Setting the Main Time Scale

**To set the Main Time Scale, do one of the following:**

- Click a Main Counter selector (located at the top of the Edit window and also in the Transport window, when it is set to display Counters) and select a Time Scale.
- If a Timebase ruler is displayed, click its name so it becomes highlighted.

**Navigating with the Main Counters**

The Main Counters (at the top of the Edit window and in the Transport window) provide a convenient way to navigate to a specific time location.

1. The Main Counter indicator in the Transport window only displays when the Transport is set to display Counters.

**To navigate with a Main Counter:**

1. Click in a Main Counter.
2. Type in a location.
3. Press Enter on Windows, or Enter or Return on Mac, to automatically locate to a new location.

### Setting the Sub Counter Time Scale

Below each Main Counter is a Sub Counter, which provides an additional timing reference.

**To set the Time Scale for the Sub Counter:**

- Click a Sub Counter selector and select a Time Scale.

**Switching the Main Time Scale**

- Setting the Main Time Scale to the timebase currently displayed in the Sub Counter switches the two Time Scales, setting the Sub Time Scale to the previous timebase of the Main Time Scale.

**Sub Counter selector (in the Edit window)**
Tick-Based Timing

Pro Tools is a sample-based program with an internal MIDI resolution of 960,000 pulses per quarter note (ppq). However, when the Time Scale is set to Bars|Beats, the display resolution in Pro Tools is 960 ppq.

In Bars|Beats, Pro Tools is tick-based (960 ticks to a quarter note), which means that some amount of sample-rounding may occur when placing events at certain locations (see “Sample Rounding and Edit Operations” on page 270).

When working in Bars|Beats, you will often want to specify tick values for a number of operations, including:

- Placing and spotting regions
- Setting lengths for regions or MIDI notes
- Locating and setting play and record ranges (including pre- and post-roll)
- Specifying settings in the Grid/Groove Quantize and Change Duration pages of the MIDI Operations window
- Setting the Grid and Nudge values

The following table lists the number of ticks for each of the main note sizes:

<table>
<thead>
<tr>
<th>Note Value</th>
<th>Normal</th>
<th>Dotted</th>
<th>Triplet</th>
</tr>
</thead>
<tbody>
<tr>
<td>1/2 note</td>
<td>1920</td>
<td>2880</td>
<td>1280</td>
</tr>
<tr>
<td>1/4 note</td>
<td>960</td>
<td>1440</td>
<td>640</td>
</tr>
<tr>
<td>1/8 note</td>
<td>480</td>
<td>720</td>
<td>320</td>
</tr>
<tr>
<td>1/16 note</td>
<td>240</td>
<td>360</td>
<td>160</td>
</tr>
<tr>
<td>1/32 note</td>
<td>120</td>
<td>180</td>
<td>80</td>
</tr>
<tr>
<td>1/64 note</td>
<td>60</td>
<td>90</td>
<td>40</td>
</tr>
</tbody>
</table>

Tick- and Sample-Based Timebases

Pro Tools lets you set any track timebase to either sample-based or tick-based.

Audio in Pro Tools is sample-based by default. This means that if an audio region is located at a particular sample location, it will not move from that location if the tempo changes in the session—though its bar and beat location will change.

MIDI data in Pro Tools is tick-based by default. This means that if a MIDI region is located at a particular bar and beat location, it will not move from that location if the tempo changes in the session—though its sample location will change.

Sample-Based Audio and MIDI

With a sample-based audio track, all audio regions in the track have an absolute location on the timeline. Audio stays fixed to the sample time, regardless of where tempo or meter changes occur in a session.

If you make a MIDI track sample-based, all MIDI events in the track have an absolute location on the timeline. MIDI events stay fixed to the sample time, regardless of where tempo or meter changes occur in a session.

Tick-Based Audio and MIDI

Tick-based audio is fixed to Bars|Beats, and moves relative to the sample timeline when tempo and meter changes occur. However, MIDI events and tick-based audio respond differently to tempo changes in respect to duration. MIDI note events change length when tempo or meter is adjusted, while audio regions do not. Meter and tempo changes affect only the start point (or sync point) for each audio region in a tick-based track.
You can select whether a track is sample-based or tick-based when it is created, or change timebases later.

**Switching Timebases**

All Pro Tools tracks can be switched between being sample-based or tick-based.

Track height affects how various track controls appear in the Edit window. The Timebase selector is only visible in Small or larger track heights.

**To switch the timebase of a track, do one of the following:**

- If the track’s height is set to Small or larger, click the Timebase selector for the track and select the desired timebase. The Timebase selector icon changes to reflect your choice.

- If the track’s height is set to Mini, click the small arrow next to the Track View selector to get the Track Height pop-up menu, and select the desired timebase from the Track Timebase sub-menu.

**Alternate Playlist Timebases**

When you change a track’s timebase, you can choose to apply the timebase change to the active Playlist on that track only, or to that track and all the alternate playlists for that track.

**To configure a timebase change to affect timebases of all playlists in a track:**

- Click the Timebase selector and enable the “Selection Changes Alternate Playlists” option.

**Groups**

When you change the timebase for an audio track that is part of an active group, all the tracks in the group will change to the same timebase.
Audio Region Location

In tick-based audio tracks, the location of an audio region is determined by the region’s start point, unless the region contains a sync point.

If the region contains a sync point, the sync point determines where the audio region is fixed to the grid.

Marker Location

When creating markers and Selection Memory Locations, you can specify whether they have an Absolute (sample-based) or Bar|Beat (tick-based) reference. For more information, see “Bar|Beat and Absolute Reference” on page 429.

Sample Rounding and Edit Operations

When audio material in Pro Tools is sample-based, some amount of sample-rounding may occur with some edits when the Main Time Scale is set to Bars|Beats. This is most evident when you need audio regions to fall cleanly on the beat (as when looping) and notice that the material is sometimes a tick or two off. With a few simple precautions, this can be avoided.

When selecting audio regions to be copied, duplicated, or repeated, make sure to select the material with the Selector tool (enable Grid mode for precise selections), or set the selection range by typing in the start and end points in the Event Edit area. Do not select the material with any of the Grabber tools (or by double-clicking with the Selector tool). This ensures that the selection is precise in terms of the grid (and not based on the length of the material in samples).

Playlists

The ability to create playlists is one of the most powerful features of Pro Tools, and one reason why it is infinitely more versatile than traditional multitrack recorders.

Each track maintains a “main” playlist and any number of “alternate” edit playlists.

Edit playlists let you take a snapshot of a track’s current arrangement of regions, thereby freeing you to experiment with alternate arrangements, returning as necessary to previously saved playlists.

A playlist, which can consist of a single region or many regions, can only be assigned to a track if it is not in use by another track. While you can create an almost unlimited number of edit playlists, which are shared among all tracks, each track has its own set of dedicated automation playlists.

Automation playlists for audio tracks store data for volume, pan, mute, and plug-in controls. Automation playlists for MIDI tracks, however, store only mute information; continuous controller events, program changes, and Sysex events are stored in MIDI regions and therefore reside within edit playlists.

For more information on automation playlists, see Chapter 27, “Automation.”
Working with Playlists

When you create a new track, it contains a single, empty playlist until you record, import, or drag and drop material to it.

Audio material can be dragged and dropped onto a track from the Region List, DigiBase browsers, from Windows Explorer or the Mac Finder.

New playlists can be created that are empty or duplicates of the current playlist. Once created, you can recall, rename, and delete playlists as needed by using the Playlist selector.

Duplicating a Playlist

When you edit a track, you can work with a copy of the track’s playlist and keep the original playlist arrangement intact.

To duplicate a track’s current playlist:

1. Click the track’s Playlist selector and choose Duplicate from the pop-up menu.
2. Enter a name for the new playlist and click OK.

The duplicated playlist appears in the track and the track’s name is changed to the name of the new playlist.

Creating a Playlist

You can create new playlists for recording or importing audio and MIDI. This can be useful for creating alternate takes of audio or MIDI, or for constructing alternate arrangements.

To create a new (empty) playlist:

1. Click the track’s Playlist selector and choose New.
2. Enter a name for the new playlist and click OK. An empty playlist with the specified name appears in the track.

Assigning a Playlist to Another Track

By default, a playlist is typically available only for the track on which it was created. However, using the Other Playlists feature, you can assign an unassigned playlist to any track. When a playlist is reassigned to another track (assigned on any track), it is unavailable to other tracks including the track on which it originated.

An audio playlist’s timebase is saved with the playlist. When assigning an unassigned playlist to any track, the track assumes the saved timebase of the playlist.

New and duplicated playlists are auto-named with the track name, followed by a Period (.) and the playlist number. For example, the first duplicated playlist on a track named “Kick” is auto-named “Kick.01,” subsequent duplicated playlists are auto-named “Kick.02,” “Kick.03,” and so on.
To assign a track playlist:

- Click the track’s Playlist selector and do one of the following:
  - Select one of the track’s playlists.
  - or –
  - Select a playlist from a different track by clicking the Other Playlists submenu, and selecting the desired playlist.

The selected playlist appears in the track and the track’s name is updated to that of the selected playlist.

Renaming a Playlist

You can rename a playlist by renaming the track to which it is assigned.

To rename a track’s assigned playlist:

1. Double-click the track’s name.
2. Enter a new name and click OK. Both the track and playlist names are updated.

Deleting a Playlist

You can delete a playlist from a session entirely. However, since playlists require minimal disk space, you do not need to delete them to conserve storage.

To delete one or more playlists from a track:

1. Click the track’s Playlist selector and choose Delete Unused.
2. Select the unassigned playlists you want to delete. Shift-click to select multiple playlists.
3. Click OK to delete the selected playlists. This operation cannot be undone.

When deleting a track from a session, you have the option of deleting or keeping its playlists, so they can be used on other tracks.

Playlists and Groups

Creating new playlists with grouped tracks automatically increments the suffixes of the playlist names for each track of the active group. This lets you revert back to an earlier take by switching the playlist takes by group.

Using this method, you can add new tracks to the existing group and the suffixes for their playlist names will be synchronized with the original tracks.

“Empty” playlists will be automatically created to keep the playlist takes synchronized when switching back to the earliest playlist takes in the group.
To keep your playlist names and performances synchronized (example workflow):

1. Create new tracks and group them together.

   For more information on grouping tracks, see “Grouping Tracks” on page 126.

2. Make sure the group is enabled.

3. Create a new playlist (by clicking the Playlist selector in one of the tracks in the group and choosing New). The default suffix will now be “.01”—signifying take 1.

4. Record take 1, then create a new playlist. The playlists on all tracks in the group increment to “.02.”

5. Create new tracks (for example, for an additional musician or microphone), then add these tracks to the group (or create a new group with all the tracks).

6. Increment all the playlists by clicking the Playlist selector in one of the tracks in the group and choosing New.

   All the playlists will now have the same suffix appended to them. (Creating additional playlists in any of the group tracks will increment their playlists to keep them synchronized.)

7. If you want to hear the .01 take on the first group of tracks, you can switch any playlist in the group back to playlist .01.

   All tracks in the group have playlists numbered with .01 suffixes (even those tracks that were added to the original group after the earlier takes). Empty playlists are automatically created on these newly-added members so that playlist numbers match across all members of the group.

---

Multiple Undo

Pro Tools can keep track of up to 32 of the last undoable operations, allowing you to return to a previous editing state.

The Undo operations in Pro Tools are stored in a queue, in the order in which they were invoked. When choosing Edit > Undo, the most recent operation is undone. If you choose Undo again, the next operation in the queue is undone. You can also choose Edit > Redo to redo an operation, which moves back through the Undo queue by one step.

When the number of operations in the Undo queue reaches the maximum Level of Undo, performing another undoable operation will remove the oldest operation at the top of the queue.

To undo the last operation, do one of the following:

- Choose Edit > Undo.
  – or –
  - Press Control+Z (Windows) or Command+Z (Mac).

  If no actions are available to undo, the menu displays Can’t Undo.

To redo the last undone operation, do one of the following:

- Choose Edit > Redo.
  – or –
  - Press Shift+Control+Z (Windows) or Shift+Command+Z (Mac).

  If no actions are available to redo, the menu displays Can’t Redo.
Undo History Window

You can use the Undo History window to view the queue of the undoable and redoable operations and return to any previous state. The Undo History can show edit creation times, enabling you to revert to the state a session held at a particular time.

To show (or hide) the Undo History window:
■ Choose Window > Undo History.

To undo operations in the Undo History window:
■ Click the operation (bold) you wish to undo in the list.

All operations in the queue that were performed after the operation you select will also be undone. In the Undo History window, undoable operations are shown in bold and redoable operations (operations that have already been undone) are shown in italics.

To redo operations in the Undo History window:
■ Click the operation (italics) you wish to redo in the list.

The operation you choose, as well as all the operations in the queue before it, will be redone.

To toggle display of creation times in the Undo History window:
■ Click the Options pop-up menu and choose Show Creation Times.

To undo all the operations in the Undo Queue:
■ Click the Options pop-up menu and choose Undo All.

To redo all the operations in the Redo Queue:
■ Click the Options pop-up menu and choose Redo All.

To clear the Undo Queue:
■ Click the Options pop-up menu and choose Clear Undo Queue.

Other operations that will clear the Undo Queue include:
• Deleting a track, or clearing a region from the Region List
• Selecting “Select > Unused,” or “Select > Unused Audio Except Whole Files” in the Region List pop-up menu

When the number of operations in the Undo History reaches the maximum level of Undo, performing another undoable operation will remove the oldest operation at the top of the Undo History queue. When the oldest operation is one operation away from being pushed out of the queue, it is shown in red.

Levels of Undo and Memory

Because Pro Tools needs to keep track of the playlists for all tracks that are edited, the use of multiple Levels of Undo can be memory intensive. You can lower the Levels of Undo in
Pro Tools to reduce the amount of system memory (RAM) used by the Undo queue. If you have plenty of memory available for Pro Tools, you can use higher Levels Of Undo.

Use the Undo History window to view a queue of undo operations and return to a previous state.

To set the Levels of Undo in Pro Tools:

1. Choose Setup > Preferences and click the Editing tab.
2. Click in the Levels of Undo field and enter a value of between 1–32.
3. Click OK to close the Preferences dialog.

The Region List

The Edit Window displays all audio regions, MIDI regions, and region groups in a single, comprehensive Region List.

All regions of all types that are recorded, imported, or created by editing appear in the Region List. Items can be dragged from the list to tracks and arranged in any order. All types of regions can be auditioned from the Region List by Alt-clicking (Windows) or Option-clicking (Mac) them.

At the top of the Region List is the Region List pop-up menu, which provides commands and tools for managing the contents of the list.

Region List Pop-Up Menu

The Region List pop-up menu provides tools to search, select, sort, export, clear, and manage items in the Region List.

To access the Region List pop-up menu:

- In the Edit window, click the Region List pop-up menu.
Displaying Regions in the Region List

In the Region List, whole-file audio regions are displayed in bold, and stereo and multic和平har regions can be expanded to display individual channels.

Because region names can become lengthy, the Region List can be scrolled or resized as necessary (see Figure 10 on page 275).

If the Editing preference for “Region List Selection Follows Edit Selection” is enabled, selecting a region or region group in the Region List selects it on any track where it is present in assigned playlist. Likewise, selecting a region or region group on a track selects it in the Region List.

Use the Region List as a bin for storing your favorite audio loops and MIDI clips. Save the session as a template and the regions are available for future sessions (see “Creating Custom Session Templates” on page 57).

Displaying File Info for Audio Regions

In addition to region names, the Region List can also display information about the region’s color coding, type (audio, MIDI, and region group), timebase, and parent file:

- **Color** Displays the color coding for regions.
- **Icon** Displays the icon for audio and MIDI regions, and region groups.
- **Timebase** Displays the timebase for audio and MIDI regions, and region groups.
- **File Name** Displays the parent file name.
- **Disk Name** Displays the name of the hard drive on which referenced file resides.
- **Full Path** Displays the full directory path of the region’s parent file.

Pro Tools displays only the region name in the Region List by default.

For details on displaying audio file information using DigiBase, see the DigiBase Guide.

When editing, the Region List can become cluttered with auto-created regions. You can hide auto-created regions by choosing Show in the Region List pop-up menu, and deselecting Auto-Created.

Channel Name Displays the channel name for audio files imported from field recorders.

Scene and Take Displays the scene and take for audio files imported from field recorders.
**Sorting and Searching in the Region List**

Most sessions will contain many regions, which can make it challenging to swiftly locate a particular region in the Region List. Pro Tools lets you sort and search regions in the Region List to quickly locate any region you want.

**To sort regions in the Region List:**

1. Click the Region List pop-up menu (at the top of the Region List) and choose Sort By.

2. Select a basis for sorting from the submenu:
   - Region Type (audio regions, region groups, MIDI regions)
   - Name
   - Length
   - Original Time Stamp
   - User Time Stamp
   - Time Base
   - Start in Parent
   - End in Parent
   - File Name
   - File Length
   - File Creation Date
   - File Modification Date
   - Disk Name (audio and region groups only)
   - Track Format/Width
   - By Channel Name
   - By Scene and Take

3. Click the Region List pop-up menu, choose Sort By, and select one of the following to apply additional sort criteria (in other words, to add a secondary sort criteria):
   - Ascending
   - Descending

**Finding Regions**

Use the Find command to display all regions in a list whose names contain a particular word or phrase.

**To find and display regions in the Region List:**

1. Do one of the following:
   - Click the Region List pop-up menu and choose Find.
   - or –
   - Press Control+Shift+F (Windows) or Command+Shift+F (Mac).

2. In the Find Regions dialog, do any of the following:
   - Select By Name and type the name, or any portion of the name, for regions you want to find. The search string appears at the top of the Region List.
   - Select Include Subsequently Added Regions to limit the display to newly added regions. A plus (+) sign appears at the top of the Region List to indicate this option is selected.
   - Select both options to start with a list of named regions and allow display of added regions.
3 Click OK.

Regions of any type whose name match the word or phrase you searched are displayed in the Region List. The search string is displayed at the top of the Region List in brackets.

Text entered into the Find dialog is saved in a Find History, letting you quickly repeat previous searches with a minimum of retyping.

**To repeat a previous search:**

1. Click the Region List pop-up menu, and choose Find.

2. Click the small arrow to the right of the text field in the Find dialog and select a text string from the Find History pop-up menu.

3. Click and hold the double arrow to the right of the text field in the Find dialog and choose Insert Entry from the pop-up menu.

An example of a Find history

The Find History is saved with the session.

In addition to storing each text string previously entered, you can insert multiple entries into the Find History manually (without having to perform each Find in order to store words or phrases).

**To compile a Find History without performing each search:**

1. Click the Region List pop-up menu, and choose Find.

2. Type the name, or any portion of the name, for the regions you want to find.

3. Type another entry and choose Insert Entry again to add additional search strings to the history.

4. Type another entry and choose Insert Entry again to add additional search strings to the history.

**To remove an entry from the history:**

1. Select it from the Find History pop-up menu so it is displayed in the text field.

2. Choose Remove Entry from the Find History pop-up menu.

**To clear the Find History:**

- Choose Remove All Entries from the Find History pop-up menu.

### Selecting Regions in the Region List

In the Region List, you can select regions so they can be dragged to tracks, processed with AudioSuite plug-ins, or exported.

**To select or deselect a region in the Region List, do the following:**

- Click a region name that is unhighlighted to select it.

  - or -

- Click a region name that is highlighted to deselect it.
To select a range of regions in the Region List, do one of the following:

- Move the cursor to the left of the region names, so the Marquee appears, and drag around the regions you want to select.

- Click the name of a region in the Region List, and Shift-click an additional region name. All regions that occur between the first region selected and the additional region will also be selected.

To select or deselect a range of regions with the Marquee:

1. Move the cursor to the left of the region name until the Marquee icon with a small “+” symbol appears:
   - To select regions, the Marquee should be to the left of an unhighlighted region name.
   - To deselect regions, the Marquee should be to the left of a highlighted region name.

2. Click on the region name and drag up or down (to select or deselect regions immediately above or below the region name).

To select or deselect non-contiguous regions, do one of the following:

- Control-click (Windows) or Command-click (Mac) region names that are unhighlighted to select them.

- Control-click (Windows) or Command-click (Mac) region names that are highlighted to deselect them.

**Keyboard Selection of Regions**

If the Region List Keyboard Focus is enabled, you can type the first few letters of a region’s name and Pro Tools will automatically locate and select the region in the Region List.

**To enable and use the Region List Keyboard Focus:**

1. Click the Keyboard Focus button in the upper right of the Region List.

2. Type the first or first few letters of the region to automatically locate and select it. Once a region is located and selected, it can be dragged to a track.

Keyboard selection of audio regions locates regions based on their region name, not on the names for their parent audio files or the volumes on which they reside.
Auditioning Regions in the Region List

In the Region List, you can audition regions by double-clicking on the region name.

Stereo and Multichannel Tracks in the Region List

Stereo and multichannel regions, whether imported or recorded into Pro Tools, are displayed as single items in the Region List. For example, two mono source regions named “Main Piano.L” and “Main Piano.R” are listed as “Main Piano (Stereo).” An expand/collapse triangle indicates stereo and multichannel regions.

Stereo and multichannel regions are displayed in the Region List by default in collapsed view. The individual regions can be displayed by clicking the arrow to the left of the region to expand the name.

To expand or collapse all stereo and multichannel regions:

- Press Alt (Windows) or Option (Mac) while clicking the expand/collapse triangle.

Individual items of an expanded-view stereo or multichannel region can be selected independently of the other associated regions in the Region List.

Rules for Stereo and Multichannel Regions

For stereo and multichannel audio regions to be shown as collective regions, the component regions must be the same length. If an existing stereo or multichannel region has been dragged onto multiple mono tracks and edited such a way that one or more components are no longer the same length, the stereo display is removed and the regions are displayed as individual regions in the Region List.

Edit Modes

Pro Tools has four Edit modes: Shuffle, Spot, Slip, and Grid. Grid mode provides two modes of operation, Relative and Absolute, explained below. The Edit mode is selected by clicking the corresponding button in the upper left of the Edit window.

You can also use F1 (Shuffle), F2 (Slip), F3 (Spot), and F4 (Grid) to set the Edit mode.

The Edit mode affects the movement and placement of audio and MIDI regions (and individual MIDI notes), how commands like Copy and Paste function, and also how the various Edit tools (Trim, Selector, Grabber, and Pencil tools) work.
**Shuffle**

In Shuffle mode, you can move, trim, cut, or paste regions freely within a track or to other tracks, but their movement is constrained by other regions. That is, if you place several regions in a track, they automatically snap to each other. You can then “shuffle” their order, but you cannot separate them from each other and you cannot make them overlap as in Slip mode. However, if there is silence between existing regions, and the regions are shuffled, the silence is maintained, and not removed.

In Shuffle mode, adding another region to the beginning of a track moves all subsequent regions to the right by the length of the region added.

When using any of the Trim tools in Shuffle mode, changing a region’s start or end point automatically moves the adjacent regions as necessary. The placement and insertion of MIDI notes is not affected by Shuffle mode.

**Shuffle Lock**

With certain workflows, it is important to exclude Shuffle mode in order to ensure that regions stay time-aligned while editing. Shuffle Lock prevents you from inadvertently entering Shuffle mode by disabling all key commands and control surface switches for Shuffle mode. You cannot invoke Shuffle Lock while in Shuffle mode.

**To lock out Shuffle Mode:**

- While in any Edit mode other than Shuffle mode, Control-click (Windows) or Command-click (Mac) the Shuffle button on-screen. A lock icon appears in the Shuffle button.

**Slip**

In Slip mode, regions can be moved freely within a track or to other tracks. In this mode, it is possible to place a region so that there is space between it and other regions in a track. When the track is played back, this space is silent. It is also possible to move a region so that it overlaps or completely covers another region.

Use Slip mode when you want the Trim, Selector, Grabber, and Pencil tools to work without any restrictions to placement in time.

**Spot**

Use Spot mode to place regions at precise locations. In Spot mode you can specify a frame location (or a location based on any of the other time formats), capture an incoming Time Code address, or use a region’s time stamps as reference points for spotting. This can be particularly useful when performing post production tasks around SMPTE frame locations.
When Spot mode is enabled, Pro Tools asks you to specify a destination location when a region is dragged from the Region List, or from a supported DigiBase browser.

**Grid**

In Grid mode, regions and MIDI notes that are moved, trimmed or inserted “snap” to the currently selected Grid value, or to precise increments on a user-definable time grid.

**Absolute and Relative Grid**

Grid mode can be applied in Absolute or Relative mode.

- In Absolute Grid mode, moving any region snaps the region start to Grid boundaries. If a region’s start point falls between beats, and the Grid is set to 1/4 notes, dragging the region will snap its start time to the nearest 1/4 note (the current absolute Grid value).

- In Relative Grid mode, regions can be moved by Grid (or Nudge) units. If a region’s start point falls between beats and the Grid is set to 1/4 notes, dragging the region will be constrained to 1/4 notes, preserving the region’s relative position to the nearest beat.

**To select Absolute or Relative Grid mode:**

- Click the Grid mode selector and choose Absolute or Relative.

**Configuring the Grid**

The actual Grid size, chosen from the Grid value pop-up menu can be based on a time value using the Main Time Scale; or, if Follow Main Time Scale is deselected, another time format can be used for the Grid size.

The Grid Value indicator and pop-up menu are located in the Edit window.

The current Grid value is also used for the Quantize to Grid command (see “Quantizing Regions to Grid” on page 348) and Separated Region At Grid command (see “Separated Region Commands” on page 328).
Also available in the Grid Value pop-up is an option for Regions/Markers. When selected, events can be placed freely (as in Slip mode) but will snap to region locations (start, end, and sync points), markers, and Edit selections when placed near them.

MIDI notes inserted with the Pencil tool ignore the Regions/Markers option, and instead snap to the time value selected in the Grid Value pop-up menu.

To display the Grid lines in the Edit window, do one of the following:

- Choose Setup > Preferences and click the Display tab, then Enable Draw Grids in Edit Window.
- or –
- Enable (and disable) Grid lines by clicking the currently selected Timebase ruler name.

Edit Tools

Pro Tools has several Edit tools: the Zoomer, Trim, Selector, Grabber, Scrubber, and Pencil tools, and the multifunctional Smart Tool. Select an Edit tool by clicking it in the Edit window. The Zoom, Trim, Grabber, and Pencil tools have multiple modes, which you can select from a pop-up menu when you click the tool.

Zoom Buttons Use the Zoom buttons to zoom in and out vertically and horizontally on MIDI and audio track material. You can also store and recall five Zoom presets.

Zoomer Tool Use the Zoomer tool to select a zoom view in a track.

Zoom Toggle Use the Zoom Toggle to switch between the current zoom view and a defined zoom view.

Trim Tools Use the Trim tools to trim regions and region groups.

Selector Tool Use the Selector to make selections on tracks.

Grabber Tools Use the Grabber tools to select, separate, or move regions on tracks.

Smart Tool Use the Smart tool to Trim, Select, or Grab regions in tracks.

Scrubber Tool Use the Scrubber tool to scrub through track material.
**Pencil Tool** Use the Pencil tool to draw automation and MIDI data.

Press the Escape key to toggle through the Edit tools.

---

**Using the Zoomer Tools**

Zooming options in Pro Tools include Zoom buttons, the Zoomer tool, the Zoom Preset buttons, and the Zoom Toggle command.

**Zoom Buttons**

Pro Tools include different Zoom buttons for zooming on track data.

**Horizontal Zoom In and Out Buttons**

The Horizontal Zoom In and Out buttons let you zoom in and out horizontally on track data.

To zoom in horizontally for all tracks, do one of the following:

- Click the Horizontal Zoom In button.
- Press Control+[ (Windows) or Command+[ (Mac).
- Click and drag on the Horizontal Zoom In button to zoom in continuously.

To zoom out horizontally for all tracks, do one of the following:

- Click the Horizontal Zoom Out button.
- Press Control+\[ (Windows) or Command+\[ (Mac).
- Click and drag on the Horizontal Zoom Out button to zoom out continuously.

**Audio and MIDI Zoom In and Out Buttons**

The Audio and MIDI Zoom buttons let you zoom in and out vertically on audio and MIDI data respectively.

To zoom in vertically for all audio tracks, do one of the following:

- Click the Audio Zoom In button.
- Press Control+Alt+[ (Windows) or Command+Option+[ (Mac).
- Click and drag on the Audio Zoom In button to zoom in continuously.

To zoom out vertically for all audio tracks, do one of the following:

- Click the Audio Zoom Out button.
- Press Control+Alt+\[ (Windows) or press Command+Option+\[ (Mac).
- Click and drag on the Audio Zoom Out button to zoom out continuously.
To zoom in vertically for all MIDI and Instrument tracks, do one of the following:

- Click the MIDI Zoom In button.
- Press Control+Shift+] (Windows) or Command+Shift+] (Mac).

To zoom out vertically for all MIDI and Instrument tracks, do one of the following:

- Click the MIDI Zoom Out button.
- Press Control+Shift+[ (Windows) or Command+Shift+[ (Mac).

To zoom in or out vertically for a single MIDI or Instrument track:

1. Make sure the Track View is not set to Regions View.
2. Select the Zoomer tool.
3. Hold Start (Windows) or Control (Mac) and click and drag upwards to zoom in, or downward to zoom out.

Additional Zoom Button Features

To return to the previous zoom level, do one of the following:

- Alt-click (Windows) or Option-click (Mac) any of the Horizontal, Audio, or MIDI Zoom buttons.
- Press Control+Alt+E (Windows) or Command+Option+E (Mac).

To zoom in on a selection:

- Press Alt+F (Windows) or Option+F (Mac).

To zoom so that all regions are visible in the Edit window, do one of the following:

- Double-click the Zoomer tool in the toolbar.
- Press Alt+A (Windows) or Option+A (Mac).

Zoomer Tool

Use the Zoomer tool to zoom in and out around a particular area within a track. The Zoomer tool offers two modes: Normal, and Single Zoom mode.

- In Normal Zoom mode, the Zoomer tool remains selected after zooming.
- In Single Zoom mode, the previously selected Edit tool is automatically reselected after zooming.

Normal Zoomer Tool

To zoom around a certain track point:

1. Enable Normal Zoom mode by doing one of the following:
   - Click the Zoomer tool pop-up menu and select Normal Zoom mode.
   - Press the F5 key to toggle to Normal Zoom mode.

To zoom in on a selection:

- Press Alt+F (Windows) or Option+F (Mac).
To zoom back to the previous level, Alt-click (Window) or Option-click (Mac) with the Zoomer tool.

To zoom into a particular track area:

1. Enable Normal Zoom mode by doing one of the following:
   - Click the Zoomer tool pop-up menu and select Normal Zoom mode.
   - Press the F5 key to toggle to Normal Zoom mode.

2. Do any of the following:
   - To zoom horizontally, drag with the Zoomer tool in the track’s playlist.
   - To zoom horizontally and vertically, press Control (Windows) or Command (Mac) while dragging in the track’s playlist.

The zoomed area fills the entire Edit window.

Single Zoom Mode

Single Zoom mode returns you to the previously selected tool after a zoom has been performed.

For example, when using the Smart Tool you can click the Single Zoomer tool, and once the Zoom operation has been performed, Pro Tools automatically switches back to the Smart Tool.

To use Single Zoom mode, do one of the following:

- Click the Zoomer tool pop-up menu and select Single Zoom mode.
- Press the F5 key to toggle to Single Zoom mode.

Single Zoom is identified with an arrow to the right of the Zoomer icon.

Normal Zoom mode does not have the arrow.

Zooming in a Ruler

To zoom horizontally in a ruler:

1. Press Control+Alt (Windows) or Command+Control (Mac) and move the cursor into the ruler area, so the Zoomer tool appears.

The zoomed area fills the entire Edit window.

To zoom horizontally in a particular ruler range:

2. Do one of the following:
   - Click once to zoom in one level around a certain point.
   - Drag to zoom in around a particular ruler range.
Continuous Zoom with the Zoomer Tool

Use the Zoomer tool to zoom in or out continuously.

To use continuous zoom on one track or a group of tracks:

1. Select the Zoomer tool.
2. Hold the Start key (Windows) or Control (Mac) and do one of the following:
   - Drag up to zoom in vertically
   - Drag down to zoom out vertically
   - Drag to the right to zoom in horizontally
   - Drag to the left to zoom out horizontally

For horizontal zoom, all tracks zoom together. Tracks will zoom in or out centered horizontally on the location where you click.

Vertical Zooming In or Out of All Audio Tracks Continuously

The continuous zoom feature usually only affects the track or group of tracks in which you click and drag up or down to zoom out or in. When using continuous zoom on audio tracks, you can choose to have all shown audio tracks zoom as one.

To vertically zoom in or out of all audio tracks using continuous zoom:

1. Select the Zoomer tool.
2. Press Start+Shift (Windows) or Control+Shift (Mac) and drag up or down. When you release the mouse, all shown audio tracks will zoom to the same zoom level.

Zoom Preset Buttons

Pro Tools lets you save up to five horizontal Edit window Zoom presets, which can be recalled by typing a number or by clicking a Zoom Preset button.

To store a view as a Zoom preset:

1. Use the Zoomer tool to configure the Track View as desired.
2. Click and hold one of the Zoom Preset buttons (1–5) and choose Save Zoom Preset from the Zoom Preset pop-up menu. The preset button flashes momentarily, and any previously stored Zoom preset at that number is replaced.

Zoom Preset pop-up menu

To recall a saved Zoom preset, do one of the following:

- Click the appropriate Zoom Preset button (1–5).
  - or -
- Click and hold the Zoom Preset button and choose Recall Zoom Preset from the Zoom Preset pop-up menu.
Zoom Toggle

The Zoom Toggle lets you define and toggle between zoom states directly from the Edit window, with enough flexibility and control to provide separate track views for audio (audio, Auxiliary Input, and Master Fader tracks) and MIDI (MIDI and Instrument tracks).

Zoom Toggle Parameters

The Zoom Toggle stores and recalls the following parameters:

- Track Height
- Edit Window View
- MIDI and Audio Zoom In or Out
- Grid setting

The Zoom Toggle lets you have separate track heights for track views for audio (audio, Auxiliary Input, and Master Fader tracks) and MIDI (MIDI and Instrument tracks).

Using Zoom Toggle

The Zoom Toggle button in the Edit window lets you define a zoom state and toggle between it and the current zoom state. When Zoom Toggle is enabled, the Edit window displays the stored zoom state. Additionally, any changes made to the view while Zoom Toggle is enabled are also stored in the zoom state.

When Zoom Toggle is disabled, the Edit window reverts to the last zoom state.

To store a zoom state using Zoom Toggle:

1. Make an Edit selection.
2. Click the Zoom Toggle button. It will light to indicate that Zoom Toggle is enabled.
3. Adjust Track Height, Vertical Zoom, Track View, and the Grid as desired.
4. Click the lit (enabled) Zoom Toggle button again to revert to the last zoom state.
5. Make another Edit selection and click the Zoom Toggle button to recall the stored zoom state and continue editing.

To modify the stored Zoom Toggle state:

1. Make sure the Zoom Toggle button is lit (enabled).
2. Adjust Track Height, Vertical Zoom, Track View, and the Grid as desired. As you adjust settings they are stored as the new Zoom Toggle state.

To clear the stored Zoom Toggle state:

1. Make sure the Zoom Toggle button is lit (enabled).
2. Alt-click (Windows) or Option-click (Mac) the Zoom Toggle button.
To use Zoom Toggle without changing playlist views:

1. Make a selection on one or more tracks.
2. Do one of the following:
   - Press Alt+Start+E (Windows) or Option+Control+E (Mac).
   - or –
   - With Commands Keyboard Focus enabled, press Alt+E (Windows) or Option+E (Mac).

Zooming with a Scroll Wheel

If you have a mouse with a scroll wheel, you can use the scroll wheel to zoom in and out of tracks, both vertically and horizontally.

To zoom in and out horizontally in the Edit window:

1. Place the mouse over the tracks in the Edit window.
2. Alt-scroll (Windows) or Option-scroll (Mac) the scroll wheel up or down to zoom in or out horizontally.

To zoom in and out vertically in the Edit window:

1. Place the mouse over the tracks in the Edit window.
2. Alt-Shift-scroll (Windows) or Option-Shift-scroll (Mac) the scroll wheel up or down to zoom tracks in or out vertically.

Using the Trim Tools

Trim tools provide region, note, and data trimming functions. The following Trim tools are available:

- Trim tool; also called Standard Trim tool
- Time Compression/Expansion Trim tool; also called TC/E Trim tool
- Scrub Trim tool (Pro Tools HD only)

Trimming tools are constrained by boundary regions, regardless of the current Edit mode, as follows:

- Trimming towards the left is constrained by the adjacent region’s left-most boundary (region start).
- Trimming towards the right is constrained by the region’s right-most boundary (region end).
- The Trim tool provides special functions when used on looped regions and region groups. For more information, see “Region Groups” on page 362 and “Region Looping” on page 370.

Trim Tool

With the Trim tool, you can quickly shorten or expand a region (up to the entire length of the source audio file). The first time you trim a region, Pro Tools automatically adds it to the Region List as a new region (with a name derived from the original) in order to differentiate it from the original.

The Trim tool is a nondestructive tool and doesn’t actually modify the original audio or MIDI data (when working on regions). To return to the length of the original region, drag it from the Region List, or resize the edited region with the Trim tool to its original length.
Use of the Trim tool is affected by the current Edit mode: Shuffle, Slip, Spot, or Grid. See “Edit Modes” on page 280 for more information.

The Trim tool can also be used to lengthen and shorten MIDI notes (see “Trimming Note Start and End Times” on page 467), and also to scale automation and controller data up or down “Drawing Automation” on page 605.

To trim a region with Trim tool:

1. Select the Trim tool. With Pro Tools HD, click the Trim tool pop-up menu and select “Standard.”

2. Move the cursor near the start or end of the region, so the Trim tool appears.

3. Do one of the following:
   - If trimming the end, drag left to shorten the region, right to lengthen.
   - or –
   - If trimming the start, drag right to shorten the region, left to lengthen.

When working with audio, you cannot trim past adjacent regions.

When using Shuffle mode, adjacent regions are slid as necessary to make room for the edited region. If using Grid mode, the dragged start/end times snap to the nearest Grid boundary. If using Spot mode, the Spot dialog opens, where you can enter the new location for the region’s start or end point.

Time Compression/Expansion Trim Tool

The Time Compression/Expansion Trim tool is a convenient tool for matching an audio region to the length of another region, a tempo grid, a video scene, or to practically any other reference point you want.

The Time Compression/Expansion Trim tool works by using the Time Compression/Expansion (TC/E) AudioSuite plug-in (or a third party plug-in) to create a new audio file. You use this tool by dragging the region’s start or end point to expand or compress the region.

With Pro Tools HD or LE with DV Toolkit 2, you can match an Edit selection to the length of a Timeline selection by selecting Edit > TCE Edit to Timeline Selection command (see “TCE (Time Compression and Expansion) Edit To Timeline Selection” on page 323.)
Time Compression/Expansion Plug-in Preferences

You can select settings for the Time Compression/Expansion AudioSuite plug-in by choosing from the Default Settings pop-up list in the Processing Preferences page, under “TC/E.” The settings available are presets included with Pro Tools; in addition, if you save your own presets for the Time Compression/Expansion plug-in, they will also appear here.

Using the Time Compression/Expansion Trim Tool in Grid Mode

The Time Compression/Expansion Trim tool can be used in Grid mode to match a region to the tempo of a session or a section of a session. For example, you might import a one-bar drum loop with a tempo of 90 BPM into a session with a tempo of 120 BPM. In Grid mode, you can use this tool to simply and quickly “time compress” the drum loop to the length of one measure, with minimal loss of audio fidelity.

Trimming regions while in Relative Grid mode will trim the regions in grid increments while maintaining their relative offset (if any) from the grid.

To use the Time Compression/Expansion Trim tool in Grid mode:

1. Set the Edit mode to Grid.
2. Click the Trim tool pop-up menu and select “TCE.”

Time Compression/Expansion Trim tool

3. With the Time Compression/Expansion tool, drag the audio region’s start or end point to compress or expand the region to the Grid (for example, by quarter notes). The audio region is automatically processed using the Time Compression/Expansion AudioSuite plug-in. The new audio region appears in the playlist and in the Region List.

Using the Time Compression/Expansion Tool in Slip Mode

To use the Time Compression/Expansion tool in Slip mode:

1. Set the Edit mode to Slip.
2. Click the Trim tool pop-up menu and select “TEC.”
3. With the Time Compression/Expansion Trim tool, drag the region’s start or end point to compress or expand the region freely. A new region is automatically processed using the Time Compression/Expansion AudioSuite plug-in. The new region appears in the playlist and in the Region List.
Using the Time Compression/Expansion Trim Tool in Spot Mode

In Spot mode, clicking with the Time Compression/Expansion Trim tool in a region opens the Spot Dialog. You can specify the location you want the region to start or end at, or the duration of the region, and the region is automatically compressed or expanded as specified.

To use the Time Compression/Expansion Trim tool in Spot mode:

1. Set the Edit mode to Spot.
2. Click the Trim tool pop-up menu and select “TCE.”
3. Click the region near its start or end point. The Spot Dialog opens. Using any Time Scale, enter a new start or end time (or duration) for the region, then click OK. A new region is automatically processed using the Time Compression/Expansion AudioSuite plug-in. The new region appears in the playlist and in the Region List.

The Scrub Trim Tool
(Pro Tools HD Only)

The Scrub Trim tool is a convenient tool for auditioning material (on up to two tracks) to find a trim point. You can drag in a track to hear the audio information, then trim at a specific location by releasing the mouse button.

This action creates a new region. Note that the Scrub Trim tool changes into a “right trim” or “left trim” shape as it is placed over the right or left side of a region. To reverse the direction of the Scrub Trim tool, press Alt (Windows) or Option (Mac) before you click the region.

Scrub Trim tool over a region

Scrub playback speed and direction vary with controller movement. Scrubbed audio is routed through the track signal path, so you hear any effects in the signal path.

To scrub trim a track:

1. Click the Scrub Trim tool. The tool changes to a speaker with a bracket.
2. Drag within a track to the left or right. Audio from a scrubbed track is routed through the track signal path, including any TDM effects. When you locate the trim point, release the mouse button to trim the region.

To scrub trim two tracks, click with the Scrub Trim tool between two adjacent tracks and drag.

To scrub with finer resolution (without having to zoom in), press Control (Windows) or Command (Mac) while scrubbing.
**Using the Selector Tool**

Use the Selector tool to place the edit cursor in a track or Timebase ruler, or to make Edit selections on tracks. For more information on selecting, see “Selecting Track Material” on page 310.

**Placing the Edit Cursor**

To place the edit cursor with the Selector tool:
1. Select the Selector tool in the Edit window.
2. Click the desired location in a track or on a Timebase ruler.

**Making an Edit Selection with the Selector Tool**

To make a selection with the Selector tool:
1. Select the Selector tool in the Edit window.
2. Click and drag in a track, across multiple tracks, or on Timebase ruler.

To select an entire region with the Selector tool:
1. Select the Selector tool in the Edit window.
2. Double-click the desired region on a track.

To select an entire track with the Selector tool:
1. Select the Selector tool in the Edit window.
2. Triple-click the desired track.

**Using the Grabber Tools**

Use the Grabber tools to select, move, separate, and arrange regions on tracks. There are three modes for the Grabber tool: Time Grabber, Separation Grabber, and Object Grabber.

**Time Grabber**
Selects an entire region on a track with a single click. For more information on selecting, see “Selecting Track Material” on page 310.

**Separation Grabber**
Cuts and pastes an Edit selection from one location to another by clicking and dragging. For more information, see “Separation Grabber Tool” on page 329.

**Object Grabber**
Lets you select multiple, non-adjacent regions. For more information, see “Object Selections” on page 312.
To select one of the Grabber tools:

1. Click and hold the Grabber tool in the Edit window.

2. From the Grabber tool pop-up menu, select the desired Grabber tool.

Using the Smart Tool

With the Smart Tool you can instantly access the Selector, Grabber, and Trim tools, and you can also perform fades and crossfades. The position of the cursor in relation to a region or note, or within an automation playlist, determines how the Smart Tool functions.

Smart Tool in Edit window

To select the Smart Tool, click its icon in the upper left of the Edit window, or press F6+F7 (or F7+F8) simultaneously.

The Smart Tool in Waveform View (or MIDI Track Regions View)

The following capabilities are available with the Smart Tool when working with audio tracks in Waveform or Blocks View, or MIDI tracks in Regions View:

- For the Selector tool, position the cursor over the middle of the region, in the upper half.
- For the Grabber tools, position the cursor over the middle of a region, in the lower half.
- For the Trim tools, position the cursor near the region’s start or end point.
- For a fade-in or fade-out, position the cursor near an audio region’s start or end point, near the top. Once the Fade cursor appears, drag into the region to set the fade length. The fade is created automatically with the Default Fade Settings (in the Editing Preferences page).
- For a crossfade, position the cursor between two adjacent audio regions, near the bottom. Once the Crossfade cursor appears drag left or right to set the crossfade length. The crossfade is created automatically with the Default Fade Settings (in the Editing Preferences page).

To temporarily switch the Smart Tool to the Scrubber, place the cursor over the region so that the Selector tool is enabled, then press the Start key (Windows) or Control (Mac), or Right-click the mouse.
The Smart Tool in Notes View

The following capabilities are available with the Smart Tool when working with MIDI and Instrument tracks in Notes View:

- For the Selector tool, position the cursor so it does not cover any notes. To get the Selector tool while positioning the cursor over notes, press Control (Windows) or Command (Mac).

- For the Grabber tools, position the cursor near the note, near its middle. To get the Marquee so you can select a group of notes, position the cursor so it does not cover any notes and press Control (Windows) or Command (Mac).

- For the Trim tools, position the cursor near the note's start or end point.

The Smart Tool in Automation and Controller Views

The following capabilities are available with the Smart Tool when working in both automation and controller views:

- For the Selector tool, position the cursor anywhere in the bottom 75% of the playlist for the Selector tool. Drag with the Selector tool to select breakpoints.

- For Trim tools, position the cursor in the top 25% of the playlist for the Trim tool. Drag with the Trim tool to trim breakpoints. Press Control (Windows) or Command (Mac) while trimming for fine control.

- For Grabber tools, Control (Windows) or Command (Mac) for the Grabber tool, then click in on the automation line to create breakpoints. To edit existing breakpoints, move the cursor near a breakpoint for the Grabber tool.

To vertically constrain Grabber tool movement, press Shift.

To vertically constrain Grabber tool movement with fine control, press Control+Shift (Windows) or Command+Shift (Mac).

To temporarily switch the Smart Tool to the Eraser, place the cursor over the region so that the Selector tool is enabled, then press Start+Alt (Windows) or Control+Option (Mac).
The Smart Tool with Stereo and Multichannel Tracks

When using the Smart Tool on stereo and multichannel tracks, individual channels cannot be independently edited. All edits affect all channels as a whole.

The tool switching for the Smart Tool in stereo and multichannel tracks is determined by the position within the entire track, and not within individual channels.

Using the Scrubber Tool

The Scrubber tool lets you “scrub” up to two tracks of audio in the Edit Window. Scrubbing is a technique that originated in tape editing, where the tape was rocked back and forth past the playhead at slower than normal speeds to find a particular location (usually for the sake of performing splices).

While viewing an audio waveform in Pro Tools can be helpful in visually finding an edit point, sometimes a waveform display (because of its sonic characteristics) may not reveal the desired spot in the audio material. By scrubbing back and forth over an edit point in Pro Tools, you can listen and zero in on the exact edit point for which you're looking.

When the Operation preference for “Edit Insertion Follows Scrub/Shuttle” is enabled, the edit cursor automatically locates to the point where scrubbing stops.

When the Scrolling option is set to Continuous (Pro Tools HD and LE with DV Toolkit 2 only) or Center Playhead (Pro Tools HD only), clicking with the Scrubber in a track’s playlist centers the Edit window around that point, and moves the Playhead there. With these Scrolling Options, scrubbed material moves past the Playhead, which remains stationary and centered.

Scrubbing is only supported for audio tracks. MIDI and Instrument tracks cannot be scrubbed.

To scrub a single audio track:

1. Select the Scrubber tool.
2. Drag within the track—left for reverse, right for forward.

Scrubbing an audio track with the Scrubber

The distance and speed with which you drag (with either the mouse, or an external MIDI controller wheel) determine the length and speed of the scrubbed audio. Audio from the scrubbed track is routed to its output, along with any effects assigned to the track.

The resolution for the Scrubber is dependent upon the zoom factor for the scrubbed track.

You can temporarily switch the Selector tool to the Scrubber tool by Right-clicking (Windows) or Control-clicking (Mac). For finer resolution, Control-Right-click (Windows) or Command-Control-click (Mac).
To scrub multiple audio tracks, do one of the following:

■ With the Scrubber selected, drag between two adjacent tracks.

— or —

■ Scrub within a selection that contains multiple tracks. Only the first two tracks are heard.

The maximum number of channels scrubbed in Pro Tools is eight, which lets you scrub two stereo tracks (four channels), but not two 5.1 surround tracks (12 channels).

Scrub/Shuttle Mode

When scrubbing normally, you can scrub at normal playback speeds or slower. Scrub/Shuttle mode, however, lets you scrub at several times normal speed, which is helpful in playing through large ranges and locating material.

To scrub in Shuttle mode (at several times normal speed):

1. Select the Scrubber tool.

2. While pressing Alt (Windows) or Option (Mac), drag within the track—left for reverse, right for forward. The Fast Forward and Rewind buttons in the Transport window engage.

The distance and speed dragged determine the speed for the scrubbed audio.

Shuttle Lock Mode

Shuttle Lock mode lets you use the numeric keypad to shuttle up to two tracks forward or backwards at specific speeds: 5 is normal speed, numbers from 6 up to 9 provide increasingly faster fast-forward speeds, and numbers from 4 down to 1 provide progressively faster rewind speeds (4 is the slowest rewind Shuttle Lock speed, 1 is the fastest). If multiple tracks are selected, only the first two tracks are shuttled.

To play one or two tracks with the shuttle lock:

1. With Pro Tools HD, make sure the Operation preference for Numeric Keypad mode is not set to Shuttle (see “Operation Preferences” on page 63).

2. With the Selector tool, click in the track where you want playback to begin. To shuttle on two tracks, Shift-click in a second track.

3. Press the Start key (Windows) or Control (Mac) and a number on the numeric keypad: 0–9 (9 is fastest, 5 is normal speed, and 0 stops shuttling).

Once Shuttle Lock mode is initiated, Fast Forward and Rewind become highlighted in the Transport window.

4. Press additional keys to change the playback speed, or press Plus (+) or Minus (–) to switch the playback direction (plus for forward, minus for backward).

5. To stop playback, press Start+0 (Windows) or Control+0 (Mac).

To exit Shuttle Lock mode, do one of the following:

■ Press Stop in the Transport window.

— or —

■ Press the Spacebar.
Custom Shuttle Lock Speed

Use the Custom Shuttle Lock Speed preference to customize the highest fast-forward Shuttle Lock speed (key 9) to better match your editing and auditioning needs.

To configure Custom Shuttle Lock Speed:
1. In Pro Tools, select Setup > Preferences and click the Operation tab.
2. Be sure that the Numeric Keypad mode is set to Transport or Classic (see “Operation Preferences” on page 63).
3. Enter a desired percentage for the Custom Shuttle Lock Speed setting. The range for this setting is 50–800%. You can use the Up and Down Arrow keys to increase or decrease the setting.
4. Click OK.

The Custom Shuttle Lock Speed will be saved with your Pro Tools preferences (not with the session).

To enable Custom Shuttle Lock Speed:
- Press Start+9 (Windows) or Control+9 (Mac) on the numeric keypad.

Numeric Keypad Set to Shuttle
(Pro Tools HD Only)

Pro Tools offers another form of shuttling, different from that of Shuttle Lock mode. With the Numeric Keypad mode set to Shuttle, playback of the current Edit selection is triggered by pressing and holding the keys on the numeric keypad—playback stops once the keys are released. Various playback speeds are available in both forward and reverse. In this mode, pre- and post-roll are ignored.

To shuttle with the Numeric Keypad mode set to Shuttle:
1. Choose Setup > Preferences and click the Operation tab.
2. Set the Numeric Keypad mode to Shuttle and click OK.
3. With the Selector tool, click in the track where you want playback to begin. To shuttle on two tracks, Shift-click in a second track.
4. Press and hold any of the following keys (or key combinations) on the numeric keypad to trigger playback.

<table>
<thead>
<tr>
<th>Shuttle Speed</th>
<th>Rewind Key</th>
<th>Forward Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 X Speed</td>
<td>4</td>
<td>6</td>
</tr>
<tr>
<td>4 X Speed</td>
<td>7</td>
<td>9</td>
</tr>
<tr>
<td>1/4 X Speed</td>
<td>1</td>
<td>3</td>
</tr>
<tr>
<td>1/2 X Speed</td>
<td>4+5</td>
<td>5+6</td>
</tr>
<tr>
<td>2 X Speed</td>
<td>7+8</td>
<td>8+9</td>
</tr>
</tbody>
</table>

5. Press a different key to switch the playback direction or speed. Release to stop.
Using the Pencil Tool

The Pencil tool lets you draw automation, MIDI data, tempo changes, and audio waveforms (at the sample level).

For information on drawing automation, see “Drawing Automation” on page 605.

For information on drawing MIDI data, see “The Pencil Tool” on page 462.

For information on drawing tempo changes, see “Editing Tempo Events in the Tempo Editor” on page 404.

For information on drawing on the audio waveform, see “Waveform Repair with the Pencil Tool” on page 361.

The Universe Window

(Pro Tools HD and Pro Tools LE with DV Toolkit 2 Only)

The Universe window displays an overview of the entire session, representing audio and MIDI material on all tracks that are not hidden (including tracks that are inactive, or that contain offline regions). The order in which material is displayed in the Universe window corresponds to the track order in the Edit window.

To open the Universe window:

Choose Window > Universe.

Audio material residing in audio tracks is represented by a single, horizontal line in the Universe window. Each channel in a stereo or multichannel track is represented individually.

Since Auxiliary Input, Master Fader, and VCA Master tracks do not contain audio, they are displayed as blank areas in the Universe window.

MIDI tracks containing note material are represented by single, horizontal lines.

Resizing the Universe Window

Even though the Universe window can be resized horizontally and vertically, the length of the entire session is always displayed in the Universe window. If the Universe window is resized so some of the session’s track are not displayed, a vertical scroll bar becomes available.
Highlighted Material in the Universe Window

The highlighted, shaded area in the Universe window represents the material displayed in the Edit window. If you change what’s displayed in the Edit window—by zooming, scrolling horizontally or vertically, hiding or unhiding tracks, or changing track heights—the highlighted area in the Universe window updates.

During playback, if the Edit window is set to scroll, the highlighted area in the Universe window also scrolls.

Scrolling in the Universe Window

By clicking in the Universe window, you can automatically scroll, either horizontally or vertically, the material displayed in the Edit window. This provides a convenient method of locating anywhere in the session, or adjusting which shown tracks are visible in the Edit window.

To move the highlighted area in the Universe window:

1. Choose Window > Universe.

2. Drag the highlighted area to a different position in the Universe window to affect which tracks are displayed in the Edit window.

When all tracks are visible in the Edit window and the session is zoomed all the way out, with all regions visible, the entire Universe window is shaded.

Video Universe Window

The Universe window also provides a pop-up menu for displaying the Video Universe window, which lets you view, navigate, zoom, and select video regions on the main video track.

For information on the Video Universe window, see “Browsing Video in the Video Universe Window” on page 666.
Chapter 16: Playing and Selecting Track Material

Playing Tracks

After recording or importing audio or MIDI to tracks, you will want to listen to the material for editing and mixing.

To set where playback begins, you can click anywhere in a track with the Selector tool (as long as the Timeline and Edit selections are linked). See “Linking or Unlinking Timeline and Edit Selections” on page 308).

Playback Cursor

The playback cursor is a solid unblinking line that moves across the Edit window to indicate the current playback location.

The selected Scrolling Option determines how the Edit window scrolls during playback, and how the playback cursor functions. See “Scrolling Options” on page 307 for details.

Playback Location

The playback location is displayed in the counters at the top of the Edit window and in the Transport window, and in the Big Counter window.

To display the Counters in the Transport window:

■ Choose View > Transport > Counters.

Start-click (Windows) or Control-click (Mac) the Expand/Collapse button in the Transport window to show or hide counters.

Control-click (Windows) or Command-click (Mac) the Expand/Collapse button in the Transport window to show or hide MIDI controls.

Alt-click (Windows) or Option-click (Mac) the Expand/Collapse button in the Transport window to show or hide counters and MIDI controls.
To display the Big Counter:
■ Choose Window > Big Counter.

![Big Counter window]

Edit Cursor
The edit cursor is a flashing line that appears when you click with the Selector tool in a track’s playlist. The blinking edit cursor indicates the start point for any editing tasks performed. If you make a selection and perform an edit, the selection is the target of the edit.

Basic Playback from a Specific Point

To begin playing from a specific point within a track:
1. Make sure that Options > Link Timeline and Edit Selection is enabled.
2. With the Selector tool, click in the track where you want playback to begin.
3. Click Play in the Transport window to begin playback.
4. Click Stop in the Transport window to stop playback.

To jump to a different location and begin playing from there, do one of the following:
■ When playback is stopped, click with the Selector tool at that point and click Play in the Transport window.
  – or –
■ Click the desired location in a Timebase Ruler during playback.

With the Timeline and Edit selections linked, you can click a region or MIDI note with the Time Grabber tool to automatically update the Timeline with the selection’s start time, letting you play from that point.

Page Scrolling During Playback

You can set Pro Tools to scroll the track display while playing, and also have the edit cursor appear wherever playback stops.

To make the track display and the edit cursor follow playback:
1. Select Options > Scrolling > Page.
2. Choose Setup > Preferences and click the Operation tab.
3. Select the option for “Timeline Insertion Follows Playback,” then click OK.

[Pressing Start+N (Windows) or Control+N (Mac) toggles Timeline Insertion Follows Playback.]

4. Make sure to select Options > Link Timeline and Edit Selection.
5. With the Selector tool, click in the track where you want playback to begin.
6. Click Play in the Transport window to begin playback. The playback cursor scrolls across the Edit window, indicating the current playback location.
7. Click Stop in the Transport window to stop playback. The edit cursor appears at the location where playback stops.
Locating and Auditioning with Fast Forward/Rewind

You can use the Fast Forward and Rewind buttons in the Transport window to locate material on tracks. If the Operation preference for “Audio During Fast Forward/Rewind” is selected, the scanned audio is heard (similar to a CD player) when clicking the Fast Forward and Rewind buttons.

You can also fast forward or rewind incrementally by repeatedly clicking the appropriate button. The size of these increments is determined by the Main Time Scale:

- **Bars:Beats**: Moves to the beginning of the previous or next bar.
- **Min:Sec**: Moves back or forward in one-second steps.
- **Time Code**: Moves back or forward in one-second steps (while adjusting for current SMPTE format).
- **Feet+Frames**: Moves back or forward in one-foot steps.
- **Samples**: Moves back or forward in one-second steps.

Locating with Back and Forward Commands

*(Pro Tools HD Only)*

Pro Tools provides four Back/Forward commands (sometimes called “rollback”) for moving the playback location in the Edit window.

You can also move the playback location in multiple increments by repeating the command (See “Repeating Back/Forward Commands” on page 304).

- **Back**: Moves the playback location backward by the Back/Forward Amount.
- **Back and Play**: Moves the current playback location backward by the Back/Forward Amount and automatically begins playback.
- **Forward**: Moves the playback location forward by the Back/Forward Amount.
- **Forward and Play**: Moves the current playback location forward by the Back/Forward Amount and automatically begins playback.

Setting the Back/Forward Amount

The length of the Back/Forward move is determined by the Back/Forward Amount preference in the Operation page (Setup > Preferences).

To configure the Back/Forward Amount:

1. Choose Setup > Preferences and click the Operation tab.

The timebase of the Back/Forward Amount settings follows the Main Time Scale by default, or you can deselect Follow Main Time and select any of the following timebase formats:

- Bars:Beats
- Min:Sec
- Time Code
- Feet+Frames
- Samples

Back/Forward commands also work when controlling a 9-pin device. See the Machine-Control Guide for details.
Do one of the following:
• Select a preset amount in the Back/Forward Amount pop-up menu.
– or –
• In the Back/Forward Amount field, enter a custom amount.

Using Back or Forward Commands

To move the playback location backward by the Back/Forward Amount:
■ Press Control (Windows) or Command (Mac), and click Rewind in the Transport window.

To move the playback location forward by the Back/Forward Amount:
■ Press Control (Windows) or Command (Mac), and click Fast Forward in the Transport window.

To move the playback location backward by the Back/Forward Amount and then begin playback:
■ Press Control+Alt (Windows) or Command+Option (Mac), and click Rewind in the Transport window.

To move the playback location forward by the Back/Forward Amount and then begin playback:
■ Press Control+Alt (Windows) or Command+Option (Mac), and click Fast Forward in the Transport window.

Repeating Back/Forward Commands

All the Back/Forward commands can be repeated in order to increase the amount of the total Back or Forward move.

To repeat Back/Forward moves:
1. Press and hold Control (Windows) or Command (Mac).
2. Click Rewind or Fast Forward the number of times you want to repeat moving the playback location backwards or forwards by the Back/Forward Amount.

Extending Selections with Back or Back and Play Commands

The Back or Back and Play commands can be used to extend a selection backwards by the length of the Back/Forward Amount.

Although you cannot extend a selection with the Forward or Forward and Play commands, you can use the following procedures with Forward or Forward and Play to move the start point of a current selection.

To extend a selection with Back or Back and Play commands:
1. Configure the Back/Forward Amount. (See “Setting the Back/Forward Amount” on page 303.)
2. With the Selector tool, drag within a track to make a selection.
3. Do one of the following:
   • To extend the selection backwards by the Back/Forward Amount, press Shift+Control (Windows) or Shift+Command (Mac) and click Rewind in the Transport window.
   – or –
   • To extend the selection backwards by the Back/Forward Amount and then begin playback, press Shift+Control+Alt (Windows) or Shift+Command+Option (Mac) and click Rewind in the Transport window.
Chapter 16: Playing and Selecting Track Material

Edit Window Counters and Indicators

The counters and indicators at the top of the Edit window display the current playback location and Edit selection. These include the Main and Sub Counters, and the Edit Selection Start, End, and Length indicators.

All Edit window counters and indicators (except the Sub Counter) let you enter a location in their counter display to navigate to a specific time location.

The Main Counter displays the playback location in the time format for the Main Time Scale. The Sub Counter can be set to any of the other Time Scale formats for another timing reference.

The Edit Selection indicators (to the right of the Main and Sub counters) display the Start and End times, and Length of the current Edit selection according to the Main Timebase.

The Main and Sub Counters, as well as the Edit Selection indicators, also appear in the Transport window when it is set to display Counters.

1. Do one of the following:
   - Click in one of the counters.
   - Press asterisk (*) on the numeric keypad to highlight the Main Counter in the Edit window (or the Main Counter in the Transport window or Big Counter window, if either are displayed).

2. Type in the new location. Press Period (.) to cycle through to the different time fields.

3. Press Enter to accept the new value and automatically locate there.

Scrolling in a Timebase Ruler

You can scroll the contents of the Edit window by clicking and dragging in a ruler. While this does not actually update the session’s Current Location, it does let you conveniently shift the display left or right for the sake of finding and editing material.

This method of scrolling is especially useful when using the Continuous Scrolling option (Pro Tools HD and Pro Tools LE with DV Toolkit 2 only), which does not update or follow Timeline selections.

To scroll the entire contents of the Edit window from a ruler:

- While pressing Control+Alt+Start (Windows) or Command+Option+Control (Mac), drag left or right in any of the Timebase rulers.

Scrolling with a Scroll Wheel

If you have a mouse with a scroll wheel, you can use the scroll wheel to scroll vertically or horizontally in any Pro Tools window that has a scroll bar (such as the MIDI Event List).
To scroll a Pro Tools window vertically:

1. Place the mouse over the window you want to scroll (for example, in the Edit window you might want to scroll either the track display or the Region List).
2. Scroll the scroll wheel up or down to scroll the window up or down.

To scroll a Pro Tools window horizontally:

1. Place the mouse over the window you want to scroll (for example, in the Edit window you might want to scroll either the track display or the Region List).
2. Shift-scroll the scroll wheel up or down to scroll the window to the left or right.

Locating the Playback Cursor

Use the Playback Cursor locator to locate the playback cursor when it is off-screen. The Playback Cursor locator will appear on the right edge of the Main Timebase ruler if the playback cursor is located beyond the time visible in the Edit window. If the playback cursor is located before the time visible in the Edit window, the Playback Cursor locator will appear on the left edge of the Main Timebase ruler.

For example, if the Scrolling option is set to None, the playback cursor will move off-screen after it has played past the time currently visible in the Edit window. The Playback Cursor locator will appear on the right edge of the Main Timebase ruler after the playback cursor moves beyond the time visible in the Edit window.

The Playback Cursor locator is red when a track is record-enabled and blue when no track is record-enabled.

To locate the playback cursor when it is off-screen:

- Click the Playback Cursor locator in the Main Timebase ruler.

The Edit window changes to center the playback cursor on-screen.

Auto-Scrolling Tracks in the Mix and Edit Windows

(Pro Tools HD Only)

If you are working with more tracks than can be displayed at one time in the Mix or Edit windows, you can select a track in one window and Pro Tools will automatically scroll to that track in the other window.

To auto-scroll the Mix window to show a selected track in the Edit window:

- In the Edit window, Start-click (Windows) or Control-click (Mac) the track name.

The track becomes selected, and the Mix window scrolls to display the selected track.

To auto-scroll the Edit window to show a selected track in the Mix window:

- In the Mix window, Start-click (Windows) or Control-click (Mac) the track name.

The track becomes selected, and the Edit window scrolls to display the selected track.
Navigating to Tracks Using Track Position Numbers

With Track Number View enabled, each track is assigned a number corresponding to its position in the Mix and Edit Windows. You can scroll directly to any track by its positional number.

💡 When tracks are reordered, Track Position Numbers are reassigned to keep them in numerical sequence.

To navigate directly to any track using Track Position Numbers:

1. Choose View > Track Number.
2. Do one of the following:
   • Choose Track > Scroll to Track.
   – or –
   • Press Control+Alt+F (Windows) or Command+Option+F (Mac).
3. In the Scroll To Track dialog, enter the Track Position Number.
4. Click OK.

The track is selected, and the windows scroll as follows:

- The Edit window tracks scroll to bring the selected track as close to the top as possible.
- The Mix window tracks scroll to bring the selected track as close to the left as possible.

Scrolling Options

You can configure how contents of the Edit window scroll during playback and recording.

To configure Scrolling options:

- Choose Options > Scrolling and select one of the following options:

  **None** The Edit window does not scroll during or after playback. The playback cursor moves across the Edit window, indicating the playback location.

  **After Playback** The playback cursor moves across the Edit window, indicating the playback location. When playback has stopped, the Edit window scrolls to the final playback location.

  **Page** The playback cursor moves across the Edit window, indicating the playback location. When the right edge of the Edit window is reached, its entire contents are scrolled, and the playback cursor continues moving from the left edge of the window.

  **Continuous (Pro Tools HD and Pro Tools LE with DV Toolkit 2 Only)** See “Continuous Scrolling During Playback” on page 308.

  **Center Playhead (Pro Tools HD Only)** See “Center Playhead Scrolling” on page 308.

💡 Making a selection in the Timeline or a playlist, or manually scrolling the Timeline while in Page Scroll or Continuous Scroll mode will suspend page scrolling. To resume page scrolling and jump to the current playback location, click the Playback Cursor locator in the Main Timebase ruler (see “Locating the Playback Cursor” on page 306).
Continuous Scrolling During Playback
(Pro Tools HD and Pro Tools LE with DV Toolkit 2 Only)

This scrolling option causes the Edit window’s contents to scroll continuously past the playback cursor, which remains in the center of the window. With this option, playback is always based on the Timeline selection (unlike the Center Playhead Scrolling option). Continuous Scrolling During Playback uses host processing power, so use this option with Pro Tools LE with DV Toolkit 2 only when absolutely necessary.

Center Playhead Scrolling
(Pro Tools HD Only)

This scrolling option causes the Edit window’s contents to scroll continuously past the Playhead, which is a blue line in the center of the window (red when recording).

The Playhead indicates where playback begins when clicking Play in the Transport window.

With the Playhead enabled, you can jump to and play an Edit or Timeline selection. For details, see “Playing Timeline and Edit Selections with the Playhead” on page 324.

Half-Screen Edit Window

When the Scrolling option is set to Continuous or Center Playhead, a half-screen appears at the far left of the Edit window (before the beginning of the session).

Linking or Unlinking Timeline and Edit Selections

Pro Tools lets you link or unlink the Timeline and Edit selections.

When the Timeline and Edit selections are linked, selecting in a track’s playlist (making an Edit selection) also defines the play and record range (the Timeline selection).

Unlinking Timeline and Edit selections lets you make a selection within a track for editing purposes that is distinct from the selection in the Timeline (which determines the playback and recording range).
To link or unlink the Timeline and Edit selections, do one of the following:

- Select or deselect Options > Link Timeline and Edit Selection.
- Or –

- In the upper left of the Edit window, click the Link Timeline and Edit Selection button so it becomes highlighted (selected) or un-highlighted (not selected).

If you are working on a film or video scene, you may want to unlink the Timeline and Edit selections to find or audition material that is at a different location than the current Timeline selection. Edit selections can be played (choose Edit > Selection > Play Edit) without disrupting the current Timeline selection. Once you find the material, you can then go back to the Timeline selection and place it within the context of the scene.

Figure 11 illustrates another reason you’d want to unlink the Timeline and Edit selections. In this example, the Timeline selection sets a range to be looped on playback, while a MIDI region (residing within the loop) is selected for editing purposes. During playback, the Edit selection can be nudged, quantized, or transposed while the loop plays back completely independent and uninterrupted.

While you could theoretically do this with the Timeline and Edit selections linked, as soon as playback is stopped, the playback range would then be updated to that of the more recent edit range, or to a single note when editing MIDI.

Playback/Edit Markers

Timeline selections are displayed in the Main Timebase ruler with Playback Markers, which appear as blue arrows (red when recording). In addition, there are Pre- and Post-Roll Flags (which are green when enabled) indicating the location for pre- and post-roll.

When the Timeline and Edit selections are unlinked, Edit selections are displayed in the ruler with Edit Markers, which appear as black brackets.

If the Timeline and Edit selections are linked, Edit selections are represented by the blue Playback Markers.

See the following sections for details on working with Timeline and Edit selections:

- “Selecting Track Material” on page 310
- “Timeline Selections” on page 322
- “Setting Punch/Loop Points” on page 208
- “Setting Pre- and Post-Roll” on page 211
Linking or Unlinking Track and Edit Selections

Pro Tools lets you link or unlink Track selection with Edit selections.

When Track and Edit selections are linked, you can make a selection within a track or across multiple tracks for editing and each associated track is selected (track names automatically highlight). This lets you quickly apply track-level commands (such as Track View toggle, change track heights) and have the command apply to all tracks you are working on.

When Track and Edit selections are unlinked, making an Edit selection does not automatically select all associated tracks.

To link or unlink Track and Edit selection, do one of the following:

- Select or deselect Options > Link Track and Edit Selection.
- or –
- In the upper left of the Edit window, click the Link Track and Edit Selection button so it becomes highlighted (selected) or un-highlighted (not selected).

Selecting Track Material

Before audio and MIDI material can be edited, it must first be selected. The Track View determines how the material is viewed and selected.

When you make a selection, it appears as a highlighted area of the tracks, and is also indicated by blue start and end arrows (Playback Markers) in the Main Timebase ruler. If any track (audio or MIDI) in the session is record-enabled, even if it is hidden, these markers appear red.

If the Timeline and Edit selections are unlinked, the Edit selection range is indicated by Edit Markers in the Main Timebase ruler. See “Linking or Unlinking Timeline and Edit Selections” on page 308 for details.

Selections and Edit Groups

When making selections on tracks that are part of an Edit Group, all tracks within the group become selected.

Selections and Hidden Tracks

When editing tracks that are part of an active Edit Group, any tracks within the group that are hidden are not affected by the edits. To edit all members of a group, make sure they are visible by highlighting their names in the Track List.
Selections in Multiple Tracks

To make a selection in multiple tracks:

- With the Selector tool, click and drag horizontally to include adjacent tracks in a selection (drag vertically to define the time range).

Selecting Regions

To select a portion of a region:

- With the Selector tool, drag within a region (left or right) to select the material on a single track. (You can also use the Selector tool across multiple, adjacent tracks to make multitrack selections.)

To select an entire region, do one of the following:

- Click the region with the Time Grabber tool.
- or -
- Double-click the region with the Selector tool.

To select two regions and the time range between them:

1. With the Time Grabber, click the first region.
2. Shift-click the second region. Both regions are selected, along with the time range between them (including any other regions).

To select an entire track, do one of the following:

- Click in the track with the Selector tool and then choose Edit > Select All.
- or -
- Triple-click with the Selector tool in the track.

To select all regions in all tracks:

1. Select the “All” Edit Group in the Group List pop-up menu.
2. Do one of the following:
   - Click in any track with the Selector tool and choose Edit > Select All.
   - or -
   - Triple-click with the Selector tool in any track.

Another way to select all regions in all tracks, without having to select the “All” Edit Group, is to press Enter (Windows) or Return (Mac), then press Control+A (Windows) or Command+A (Mac). The Link Timeline and Edit Selection option must be enabled.

Region List Selection Follows Edit Selection

When the Editing preference for “Region List Selection Follows Edit Selection” is enabled, selecting a region in a track also causes the region to become selected in the Region List.

Conversely, if the Editing preference for “Edit Selection Follows Region List Selection” is enabled, selecting a region in the Region List causes the initial occurrence of that region to become selected within the track.

Selecting All from Timebase Rulers

To select all material in all displayed audio and MIDI tracks:

1. Make sure the Timeline and Edit selections are linked.
2. Double-click in any Timebase ruler. All regions in all displayed audio and MIDI tracks are selected. Tracks that are hidden are not selected.
To select all material in all tracks, along with Conductor events:

1. Make sure the Timeline and Edit selections are linked.
2. While pressing Control (Windows) or Option (Mac), double-click in any Timebase ruler. All regions in all displayed audio and MIDI tracks are selected, along with all events in each of the Conductor tracks.

Making Selections While Playing

Pro Tools lets you make on-the-fly selections with the Up and Down Arrow keys.

To make a selection while playing:

1. Make sure to select Options > Link Timeline and Edit Selection.
2. With the Selector tool, click somewhere near the beginning of the track in which you want to make the selection.
3. Click Play in the Transport window to begin playback.
4. When playback reaches the point where you want the selection to begin, press the Down Arrow key.
5. Press the Up Arrow key at the point where you want the selection to end. The selected range becomes highlighted.
6. To stop playback, click Stop in the Transport window.

To automatically scroll to the beginning of the selection (or to the location of the on-screen cursor), press the Left Arrow key. To scroll to the end of the selection, press the Right Arrow key.

While in Page Scroll or Continuous Scroll mode, making a selection in the Timeline or a playlist during playback as the playback cursor moves off-screen will suspend page scrolling. To resume page scrolling and jump to the current playback location, click the Playback Cursor locator in the Main Timebase ruler (see “Locating the Playback Cursor” on page 306).

Object Selections

You can use the Object Grabber tool to select non-contiguous regions on one or more tracks. Non-contiguous selections must encompass entire regions. If you want a non-contiguous selection to include a portion of a region, first turn the portion into a new region with the Separate Region command (see “Separate Region Commands” on page 328).

⚠️ The Object Grabber is not available when the Edit mode is set to Shuffle or Spot.

To select non-contiguous regions:

1. Make sure the Edit mode is set to either Slip or Grid.
2. Click the Grabber tools pop-up menu and select “Object.”
3 Shift-click each region you want to include in the selection. The regions can even reside on different tracks.

Each clicked region becomes surrounded by a dark border, indicating it is selected.

The Object Grabber tool ignores Edit Groups when making selections. For instance, selecting a region on a grouped track does not cause regions in the other tracks in the group to become selected.

**Object to Time Selection**

You can convert between Time- and Object-based selections. Time selections are made with the Selector and Time Grabber tools. Object selections are made with the Object Grabber tool.

Converting to an Object selection is useful when you are working with large selections, especially across multiple tracks, and you want to remove certain regions from the selection.

Converting to a Time selection is useful if you want to select all regions between a non-contiguous Object selection.

**To change a Time selection to an Object selection:**

1. Drag with the Selector tool in any track to define a selection, or select in a Timebase ruler to select across all tracks.

2. With the Object Grabber tool selected, double-click the Grabber icon in the toolbar. The regions falling within the selection range become selected as objects. Regions that were partially selected become deselected.

To select regions that were partially selected, press the Control key while double-clicking the Grabber icon.

**To change an Object selection to a Time selection:**

1. Select any number of regions with the Object Grabber tool.

2. Double-click the Selector tool in the toolbar. The time range between the first and last region becomes selected.

When using the Object Grabber tool on tracks that belong to an Edit Group, regions in the other grouped tracks are selected if they fall within the range of the selected region.
Changing a Selection Length

The selection range can be shortened or lengthened; this does not affect the material within the selection.

To change the length of a selection, do one of the following:

- With the Selector tool, position the cursor over one end of the current selection and Shift-click or Shift-click and drag left or right.
- In the Main Timebase ruler, drag the Playback Marker for the selection’s start or end point.

To make a long-length selection:

1. With the Selector tool, click at where you want the selection to start.
2. Scroll to the end point and Shift-click at the point where you want the selection to end.

To verify the start and end points of a long selection, press the Left Arrow key to scroll to the beginning of the selection, or press the Right Arrow key to scroll to the end.

Nudging a Selection Range

The selection range (not the material within the selection) can be moved by the Nudge value.

To nudge a selection range:

1. Configure the Nudge value. For details, see “Defining the Nudge Value” on page 345.
2. Make the initial selection with the Selector tool.
3. While pressing Shift, press Plus (+) or Minus (-) on the numeric keypad to move the selection range by the Nudge value.

Nudging Selection Start/End Points

Start and end points for selections can be moved by nudging them.

To move a selection start or end point by the Nudge value:

1. Configure the Nudge value. For details, see “Defining the Nudge Value” on page 345.
2. Make the initial selection with the Selector tool.
3. Do one of the following:
   - While pressing Alt+Shift (Windows) or Option+Shift (Mac), press Plus (+) or Minus (-) on the numeric keypad to move the selection’s start point by the Nudge value.
   - or –
   - While Control+Shift (Windows) or pressing Command+Shift (Mac), press Plus (+) or Minus (-) on the numeric keypad to move the selection’s end point by the Nudge value.
Extending Selections

You can extend selections to region start and end points, to include an adjacent region, or to Markers and Memory Locations.

To extend a selection to a region start or end point:

1. With the Selector tool, select a portion of a region, or click anywhere in the region.

2. Do one of the following:
   - Press Shift+Tab to extend the selection to the region’s end point.
   - or –
   - Press Shift+Control+Tab (Windows) or Shift+Option+Tab (Mac) to extend the selection to the region’s start point.

To extend a selection to include an adjacent region:

1. Select the first region with the Time Grabber tool.

2. Do one of the following:
   - With Tab to Transients disabled, press Shift+Start+Tab (Windows) or Shift+Control+Tab (Mac) to extend the selection to the next region boundary.
   - or –
   - Press Shift+Start+Control+Tab (Windows) or Shift+Control+Option+Tab (Mac) to extend the selection to include the previous region boundary.

To extend a selection to a Marker or Memory Location:

1. Do one of the following:
   - Click in a track with the Selector tool at the desired start or end point.
   - or –
   - Make a selection with the Selector or Time Grabber tool.

2. Do one of the following:
   - Shift-click a Marker in the Markers ruler.
   - or –
   - Shift-click a Memory Location in the Memory Locations window.

The selection is extended from the original Insertion point to the Marker or Memory Location.

Using the Edit Selection Indicators (Start, End, and Length)

The Edit Selection indicators at the top of the Edit window can define precise Edit selections. Time values for the Edit Selection indicators use the time format for the Main Time Scale.

To make a selection with the Edit Selection indicators:

1. Click with the Selector tool in the track you want to select.

2. Click in the Start field at the top of the Edit window.

3. Type in the start point for the selection and press the Forward Slash key (/) to enter the value and automatically move to the end field.
Type in the end point for the selection and press Enter to accept the value.

**Numeric Entry Shortcuts for Selection Indicators**

You can use the following shortcuts for entering values in the Edit Selection indicators:

- Press the Forward Slash (/) key to cycle through the three Edit Selection indicators.
- Use Period (.) or the Left and Right Arrow keys to move through the different time fields in each Edit Selection indicator.
- Press the Up or Down Arrow keys to increase or decrease the numerical values.
- Control-drag (Windows) or Command-drag (Mac) in a field to scroll to a new value.
- Press Plus (+) or Minus (–), along with an accompanying number, to add or subtract from the current field value.

For example, to add 10 to a current field value, cycle to the field, press the Plus (+) key, type “10” and then press Enter.

- Press Escape to exit the Edit Selection indicators without entering any values.

> These shortcuts can also be used to enter start and end values in the Transport window.

**Calculator Entry Mode**

You can perform calculator-style editing of values in the Edit Selection indicators.

**To subtract time values:**

1. In the Edit Selection indicator, highlight the time field you want to change.
2. Press Minus (–) on the numeric keypad.
3. Type the amount you want to subtract from the current time value, then press Enter.
4. Press Enter again to apply the change.

**Selecting Across Multiple Tracks**

To perform edits across multiple tracks or all tracks, you must first select the tracks. Do this by including other tracks in the selection, or by selecting in a Timebase ruler (for all tracks).

**To make a selection in multiple tracks:**

With the Selector tool, click and drag vertically to include adjacent tracks in a selection (drag horizontally to define the time range).

**To extend a selection to another track:**

1. Using the Selector or Time Grabber tool, make a selection in the first track or tracks.
2. Shift-click in additional tracks with the Selector tool. An identical range is selected for each additional track.

To shorten or lengthen the selection across each of the tracks, press Shift while dragging to change the range of the selection.
To select across all tracks, do one of the following:

- Enable the All Edit Group and make a selection in any track.
  - or -
- Drag with the Selector tool in any Timebase ruler (make sure the Timeline and Edit Selections are linked).

These selections include all tracks in the Edit window, but do not include the Conductor tracks (for Tempo, Meter, and Markers).

To select across all tracks, including the Conductor tracks (for Tempo, Meter, and Markers):

- Alt-drag (Windows) or Option-drag (Mac) with the Selector tool in any Timebase ruler.

Moving and Extending Selections Between Tracks

With Commands Keyboard Focus enabled, Edit selections can be moved or extended to adjacent tracks.

To move a selection to an adjacent track:

1. Enable the Commands Keyboard Focus by clicking its button in the upper left of the Edit window.
2. With the Selector or Time Grabber tool, make a selection.
3. Do one of the following:
   - Press P on your computer keyboard to move the selection to the previous track.
   - or -
   - Press semicolon (;) to move the selection to the next track.

In either instance, the original Edit selection becomes deselected.

With Commands Keyboard Focus disabled, press Start+P (Windows) or Control+P (Mac) to move the selection to the previous track, or Start+; (Windows) or Control+; (Mac) to move the selection to the next track.

To extend a selection to an adjacent track:

1. Enable the Commands Keyboard Focus.
2. With the Selector or Time Grabber tool, make a selection.
3. Do one of the following:
   - Press Shift+P to extend the selection to the previous track.
   - or -
   - Press Shift+semicolon to extend the selection to the next track.

In either instance, the original Edit selection remains selected.

With Commands Keyboard Focus disabled, press Shift+Start+P (Windows) or Shift+Control+P (Mac) to move the extend the selection to the previous track, or Shift+Start+; (Windows) or Shift+Control+; (Mac) to move the extend the selection to the next track.
To remove the bottom track from a selection:

■ Press Start+Alt+semicolon (Windows) or Control+Option+semicolon (Mac) to remove the bottom track.

**Other Useful Selection Techniques**

Following are some additional selection techniques.

**To position the edit cursor precisely at a region start, end, or sync point:**

1. Make sure the Tab to Transients button is not enabled. (See “Tabbing to Transients” on page 319.)

2. Click with the Selector tool in the track.

3. Do one of the following:
   • Press Tab to move the cursor to the next region or region group start, end, or sync point.
   – or –
   • Press Control+Tab (Windows) or Option+Tab (Mac) to move the cursor to the previous region or region group start, end, or sync point.

**To make a selection with the Scrubber:**

1. Choose Setup > Preferences and click the Operation tab.

2. Select the option for “Edit Insertion Follows Scrub/Shuttle,” then click OK.

3. Scrub with the Scrubber to find an appropriate start point for the selection, then release.

4. While pressing Shift, scrub to an appropriate end point for the selection, then release. The range between the initial and final scrub becomes selected.

**To move a selection to an adjacent region on the same track:**

1. Select a region with the Time Grabber.

2. Do one of the following:
   • Press Start+Tab (Windows) or Control+Tab (Mac) to move the selection to the next region.
   – or –
   • Press Start+Control+Tab (Windows) or Control+Option+Tab (Mac) to move the selection to the previous region.

In either instance, the original region becomes deselected.

**To slide an Edit selection in the Main Timebase ruler:**

1. With the Selector or Time Grabber tool, make a selection.

2. While pressing Alt (Windows) or Option (Mac), move the cursor over either of the Playback Markers in the ruler (the Time Grabber appears).

3. Drag left or right to move the Edit selection back or forward in time, while preserving its length.

If the Timeline and Edit selections are unlinked, Alt-drag (Windows) or Option-drag (Mac) the Edit Markers instead.
Right-Click Commands and Selection Preservation

You can use Right-click commands with key combinations to perform operations on objects while maintaining selections in the Edit and Mix windows. For example, you can maintain selections in the following areas while carrying out certain commands:

- Region selections in the Timeline
- Region name selections in the Region List
- Track selections

To apply a command to an object while keeping the current selection:

■ Control-Right-click (Windows) or Command-Right-click (Mac) the object and choose a command from the pop-up menu.

Tabbing to Transients

With the Tab to Transients button, you can automatically navigate to transients in audio waveforms, placing the cursor just before the detected transient peak. This allows you to easily define selections and play ranges, as well as start and end points for new regions, without having to zoom in on the waveform.

To set the start and end points of a selection with Tab to Transients:

1. In the upper left of the Edit window, click the Tab to Transients button so it becomes selected.
2. If you will be setting the play range with this selection, enable Options > Link Timeline and Edit Selection.
3. Click in the audio track just before the beginning of the material you want to select.
4. Press Tab repeatedly until the cursor locates to the transient at the start of the selection.
5. Press Shift+Tab until the cursor locates to the end of the material you want to select.

If necessary, you can move to the previous transient by pressing Control+Tab (Windows) or Option+Tab (Mac).

Tab to Transients button enabled

When Tab to Transients is enabled, the Tabbing function also locates the cursor to region start and end points, but not to sync points.

Peak transients are usually visible in the waveform. However, some low-frequency transients may not appear as visible peaks in the waveform.
Playing Selections

Once an Edit selection is made, you can audition it by clicking Play in the Transport window. If enabled, the pre- and post-roll amounts play as well.

To play a selection:

1. Make sure to select Options > Link Timeline and Edit Selection.
2. With the Selector or Time Grabber tool, make a track selection.
3. If you want to use pre- or post-roll, enable and set the pre- and post-roll amounts. For details, see “Setting Pre- and Post-Roll” on page 211.
4. Click Play in the Transport window, or press the Spacebar.

All tracks play for the range of the selection, including pre- and post-roll if enabled.

To play an Edit selection with Link Timeline and Edit Selection disabled, do one of the following:

  - or -
- On Pro Tools LE or Pro Tools M-Powered, choose Edit > Play Edit Selection.

To play a Timeline selection with Link Timeline and Edit Selection disabled (Pro Tools HD only):

- Choose Edit > Selection > Play Timeline.

Auditioning Pre- and Post-Roll

You can audition and play just the pre-roll or post-roll material for a selection.

To play from the pre-roll point to the start of a selection, or to the current Cursor location:

- Press Alt+Left Arrow (Windows) or Option+Left Arrow (Mac).

To play to the post-roll point from the end of a selection, or from the current Cursor location:

- Press Control+Right Arrow (Windows) or Command+Right Arrow (Mac).

Auditioning Start and End Points for Selections

There may be times when you want to audition the start or end of an audio selection without hearing the entire selection. This allows you to check, for instance, whether the beginning or end of a selection includes any unwanted clicks or pops.

![Playback ranges for auditioning start/end points](image-url)
To audition a selection start point:
■ Press Control+Left Arrow (Windows) or Command+Left Arrow (Mac).

When auditioning the beginning of a selection, the selection plays from the start point for a duration equal to the post-roll amount.

To audition a selection start point with pre-roll:
■ Press Control+Alt+Left Arrow (Windows) or Command+Option+Left Arrow (Mac).

To audition a selection end point:
■ Press Alt+Right Arrow (Windows) or Option+Right Arrow (Mac).

When auditioning the end of a selection, playback begins before the end point by the pre-roll amount.

To audition a selection end point with post-roll:
■ Press Control+Alt+Right Arrow (Windows) or Command+Option+Right Arrow (Mac).

Looping Playback

When Loop Playback is enabled, the selected track range repeats on playback. If there is no selection, playback occurs normally from the current Cursor location.

A selection must be at least 500 ms in length for it to loop on playback.

Looping playback is a useful way to check the rhythmic continuity of a selection when working with musical material. If you’re working with one-bar selections, you can loop playback to see if the material loops cleanly. If it seems to skip, you should then adjust the length of the selection until it works “musically” within the context of the playlist and the other tracks.

To loop playback of a selection:
1 Make sure to select Options > Link Timeline and Edit Selection.
2 With the Selector tool, select the track range you want to loop.
3 Enable Loop Playback by doing one of the following:
   • Select Options > Loop Playback.
   • Right-click the Play button in the Transport window and select Loop from the pop-up menu.
   • Start-click (Windows) or Control-click (Mac) the Play button in the Transport window.
   • Press Control+Shift+L (Windows) or Command+Shift+L (Mac).
   • With the Numeric Keypad mode set to Transport, press 4 on the numeric keypad.

When enabled, a loop symbol appears in the Play button in the Transport window.

Loop Playback enabled

4 Click Play in the Transport window.

Playback begins from the pre-roll point (if enabled) and continues to the selection’s end point, where it loops back to the start point.

5 Click Stop in the Transport window to stop playback.

Loop Playback and Audio Recording

When Loop Playback is enabled, Pro Tools will not loop when attempting to record audio tracks with QuickPunch, Destructive Record, or Nondestructive Record mode.
To loop record audio tracks in Pro Tools, you must enable Loop Record mode. (See “Loop Recording Audio” on page 204.)

**Timeline Selections**

With the Link Timeline and Edit Selection option disabled, selections can be made in the Timeline that are distinct and separate from Edit selections.

With the Timeline and Edit selections linked, any Edit selections that are made are mirrored in the Timeline.

Whether the Timeline and Edit selections are linked or not, the range indicated by the Playback Markers always determines the range for playback and recording.

With Pro Tools HD, when the Scrolling option is set to Center Playhead, it determines where playback begins. For details, see “Playing Timeline and Edit Selections with the Playhead” on page 324.

**To make a Timeline selection with the Selector tool:**

1. If you want to constrain the selection to the current Grid value, set the Edit mode to Grid.
2. Drag with the Selector tool in any Timebase ruler.

The Timeline selection is indicated in the Main Timebase ruler by the blue Playback Markers (red if a track is record-enabled). The start, end, and length for the Timeline selection is displayed in the corresponding fields in the Transport window.

- To select all tracks, including Conductor tracks, press Alt (Windows) or Option (Mac) while dragging in a Timebase ruler with the Selector tool.

**To set the Timeline selection by dragging the Playback Markers:**

1. If you want to constrain movement to the current Grid value, set the Edit mode to Grid.
2. With the Time Grabber, drag the first Playback Marker (down arrow) to set the start point.
3. Drag the other Playback Marker (up arrow) to set the end point.

**Making a Timeline selection with the Selector tool**

To select all tracks, including Conductor tracks, press Alt (Windows) or Option (Mac) while dragging in a Timebase ruler with the Selector tool.

**To set the Timeline selection by typing into the Transport window:**

1. If necessary, resize the Transport window to Expanded View so the start and end times are displayed (View > Transport > Expanded).
2. Do one of the following:
   - In the Transport window, click in the start field.
   - or –
   - Press Alt+Forward Slash (/) (Windows) or Option+Forward Slash (/) (Mac) on the numeric keypad to select the start field in the Transport window.
3 Type in the new start location and press Forward Slash (/) to enter the value and automatically move to the end field.

4 Type in the new end location and press Enter to accept the value.

Shortcuts for entering start and end values in the Transport window are listed in “Numeric Entry Shortcuts for Selection Indicators” on page 316.

Sliding a Timeline Selection

Like Edit selections, Timeline selections can be slid in the Main Timebase ruler.

To move a Timeline selection in the Main Timebase ruler:

1. While pressing Alt (Windows) or Option (Mac), move the cursor over either of the Playback Markers (the Time Grabber appears).
2. Drag left or right to move the Timeline selection back or forward in time, while preserving its length.

Timeline Selections to/from Edit Selections

(Pro Tools HD Only)

When the Timeline and Edit selections are unlinked, you can copy selections between them.

To copy the current Edit selection to the Timeline:

■ Choose Edit > Selection > Change Edit to Match Timeline.

To copy the current Timeline selection to an Edit selection:

■ Choose Edit > Selection > Change Timeline to Match Edit.

TCE (Time Compression and Expansion) Edit To Timeline Selection

(Pro Tools HD Only and Pro Tools LE with DV Toolkit 2)

When the Edit and Timeline selections are unlinked, you can compress or expand an audio selection to fit the Timeline selection. This feature works by using a Time Compression/Expansion plug-in to expand or compress the selected audio material.

For information on TCE processing preferences, see “Processing Preferences” on page 71.

To fit an Edit selection to the Timeline:

1. Deselect Options > Link Timeline and Edit Selections.
2. With the Selector tool, select the audio material to be compressed or expanded.
3. In any Timebase ruler, select the time range where you want to fit the audio material.
4. Choose Edit > TCE Edit to Timeline Selection.

The Edit selection is compressed or expanded to the length of the Timeline selection.

TCE Edit to Timeline Selection on Multiple Tracks and Channels

The TCE Edit to Timeline command can be used on multichannel selections, and selections across multiple tracks.

However, all regions are compressed or expanded equally by the same percentage value, based on Edit selection range. This ensures that the rhythmic relationship between the different channels or tracks is retained.
Fitting an Audio Region to an Edit Selection

Regions can be dragged from the Region List to fit within an Edit selection. The dragged region is compressed or expanded to fit within the selection. This feature uses the Time Compression/Expansion plug-in to expand or compress the audio region.

To fit an audio region to an Edit selection:
1. With the Selector tool, select a time range in an audio track.
2. Control-Alt-drag (Windows) or Command-Option-drag (Mac) the region from the Region List to the track with the selection. The start of the region is positioned at the selection start, and the region is compressed or expanded to match the length of the selection.

Fit to Selection on Multiple Tracks and Channels

The Fit to Selection command supports dragging multiple regions from the Region List to multiple tracks, or multichannel tracks.

However, all dragged regions are compressed or expanded equally by the same percentage value, based on length of the region last clicked before dragging.

Playing Timeline and Edit Selections with the Playhead

(Pro Tools HD Only)

When the Scrolling option is set to Center Playhead, selections in the Timeline do not determine when playback begins. The Playhead, itself, denotes where playback begins when clicking Play in the Transport.

The Timeline and Edit selections, however, can still be played when the Playhead is enabled.

To play an Edit selection with the Playhead enabled:
1. Deselect Options > Linked Timeline and Edit Selections.
2. Select Options > Scrolling > Center Playhead.
3. With the Selector or Time Grabber tool, make a track selection.

The Playhead jumps to the Edit selection and plays it from beginning to end, and then stops.

To play a Timeline selection with the Playhead enabled:
1. Deselect Options > Linked Timeline and Edit Selections.
2. Select Options > Scrolling > Center Playhead.
3. Drag with the Selector tool in any Timebase ruler to set the play range.
4. Choose Edit > Selection > Play Timeline.

The Playhead jumps to the Timeline selection and plays it from beginning to end, and then stops.
Moving the Playhead

When the Scrolling option is set to Center Playhead, the Playhead can be moved forward or back to the next region boundary in the selected track.

To move the Playhead through a track’s region boundaries:

1. Make sure the Tab to Transients button is not enabled. (See “Tabbing to Transients” on page 319.)
2. Click in the track with the Selector tool.
3. Do one of the following:
   - Press Tab to move the Playhead forward to the next region boundary.
   - or –
   - Press Control+Tab (Windows) or Option+Tab (Mac) to move the Playhead back to the previous region boundary.
Chapter 17: Working with Regions and Selections

Regions are the basic building blocks for arranging audio and MIDI in Pro Tools. Understanding how regions are created, edited, and arranged is essential to taking full advantage of the editing capabilities of Pro Tools.

This chapter covers basic editing functions as they apply to regions and region groups, and selections, which for the most part apply to both MIDI and audio data.

For editing procedures more specific to MIDI, see Chapter 22, “MIDI Editing.”

Creating New Regions

Pro Tools provides several commands for creating regions and region groups, each of them having a slightly different effect on the selection. When you create a new region or region group, it appears in the Region List and in the track’s playlist. For details on how these new regions are automatically named, see “Auto-Naming Options” on page 397.

When creating a new region from an existing region, the original region remains in the Region List.

Capture Region Command

The Capture Region command defines a selection as a new region and adds it to the Region List. From there, the new region can be dragged to any existing tracks.

To capture a new region:

1. With the Selector tool, click and drag within an existing region to select the material for the new region.

2. Choose Region > Capture.

3. Enter a name for the new region and click OK.

The new region appears in the Region List. The original region remains intact and unchanged.
Separate Region Commands

The Separate Region commands define a selection within an existing region, or a partially selected region, as a new region and separate it from adjacent material.

There are three different Separate Region commands:

At Selection Creates new region boundaries at the selection start and end points. If there is no selection and the edit cursor is placed within the region, the region is split into two new regions at the insertion point.

On Grid Creates new regions according to the current grid resolution.

At Transients Automatically creates region boundaries on detected transients within a selection. This uses the same algorithm for transient detection as the Tab To Transients feature.

To separate one or more regions:

1. Do one of the following:
   - With the Selector tool, drag to select the material for the new region or regions. The selection can reside within a single region, across adjacent regions within the same track, or across multiple tracks.
   - or -
   - With the Selector tool, click at the point within a region, where you want to separate the region.

2. Do one of the following:
   - Choose Edit > Separate Region > At Selection.
   - Press Control+E (Windows) or Command+E (Mac).
   - Right-click near the cursor position or selection and choose Separate from the pop-up menu.

3. If the Editing preference for Auto-Name Separated Regions is disabled, enter a name for the new region when prompted, then click OK.

New regions appear in the tracks in which they are created, separate from the data surrounding them. They also appear in the Region List.

To separate regions according to the current grid resolution:

1. Make the desired Edit selection.

2. Choose Edit > Separate Region > On Grid.

To separate regions at transients:

1. Make the desired Edit selection.

2. Choose Edit > Separate Region > At Transients.

Auto-Name Separated Regions Option

With the Auto-Name Separated Regions option in the Editing Preferences page selected, Pro Tools automatically names separated regions for you. The name is a numbered variation of the original region’s name.

By separating a region, additional regions are auto-created from data on either side of the separation, which have new numbers assigned to their names. The original region remains intact and unchanged on the Region List.

If the Editing preference for “Separate Region Operates On All Related Takes” is selected and you are editing a region that is one of a number of related takes with the same User Time Stamp (for example, as created with loop recording), the Separate Region command affects each take. For details see, “Editing Preferences for Takes” on page 207.
Separating Multiple Tracks

Figure 13 illustrates a separation across three mono audio tracks and one stereo track. For some tracks, the selection resides within a region, while others reside at the start or end of a region.

Once separated, this material can be moved or copied to another location.

Separation Grabber Tool

You can use the Separation Grabber tool to automatically separate an Edit selection and move it to another location or another track.

To separate a selection with the Separation Grabber tool:

1. With the Selector tool, drag to select the material for the new region or regions. The selection can reside within a single region, across adjacent regions within the same track, or across multiple tracks.

2. From the Grabber tools pop-up menu, choose the Separation Grabber tool.

3. Drag the selection to the new location, or to another track.

A new region (or regions) containing the previous selection is created, separate from the original selection. New regions are also created from the material outside the original selection.
To separate a selection without affecting the original regions:

1. With the Selector tool, drag to select the material for the new region or regions. The selection can reside within a single region, across adjacent regions within the same track, or across multiple tracks.

2. From the Grabber tools pop-up menu, choose the Separation Grabber tool.

3. While pressing Alt (Windows) or Option (Mac), drag the selection to the new location, or to another track.

New regions containing the previous selection are created and placed at the new location. The original selection and regions remain intact.

Region Overlap and Underlap

When a tick-based audio track has multiple regions, an increase in tempo can cause neighboring regions to overlap. Audio regions can be set to display a small “dog-ear” corner to indicate overlapping region boundaries.

To toggle the display of overlap and underlap region boundaries:

- Choose View > Region > Overlap.

Changing Region Overlap/Underlap

After tempo changes and other edits, regions may overlap in undesired ways. To correct this, a region can be brought to the front, or sent behind neighboring regions as needed.

To change the region overlap or underlap:

1. In the Edit window, choose the region or regions you want to re-order.

2. Do one of the following:
   - Choose Region > Bring to Front to make the region overlap the neighboring regions.
   - or –
   - Choose Region > Send to Back to make the region underlap the neighboring regions.

If multiple overlapping regions are selected, Pro Tools will apply the command to each region as that region relates to the neighboring region on the right.
Trimming Commands

Pro Tools provides several options for editing region and region group boundaries.

Trim Region to Selection Command

The Trim Region to Selection command removes data before and after a region or MIDI note selection, leaving only the selection. This command lets you quickly remove all data in a region (and in some instances the entire track) except for the current selection.

To trim unwanted data from a region or note:
1. With the Selector tool, select a portion of a region or note (or a range of notes).
2. Choose Edit > Trim Region > To Selection to remove material outside of the selection.

Trim Region to Insertion Commands

You can trim a region or MIDI note by automatically removing the material between the Edit insertion point and the start or end point of the region.

To trim from a start point to insertion:
1. With the Selector tool, click inside the region or note where you want the new start point to be.
2. Choose Edit > Trim Region > Start To Insertion. The region’s start point is automatically trimmed to the insertion point.

To trim from an end point to insertion:
1. With the Selector tool, click inside the region or note where you want the new end point to be.
2. Choose Edit > Trim Region > End To Insertion. The region’s end point is automatically trimmed to the insertion point.

Trim to Fill Selection Commands

The Trim to Fill Selection commands let you automatically reveal underlying material in the gaps between regions, as follow:

To trim from a start point to fill gaps:
1. With the Selector tool, click inside the region or note where you want the new start point to be.
2. Choose Edit > Trim Region > Start to Fill Selection. The region’s start point is automatically trimmed to the insertion point.
The start point of the region behind the gap is automatically trimmed (expanded) to the previous region, or as far as possible if there is not enough underlying material to cover the gap.

To trim from an end point to fill gaps:
1. With the Selector tool, select across at least one gap between regions.
2. Choose Edit > Trim Region > End To Fill Selection.

The end point of the region in front of the gap is automatically trimmed (expanded) to the next region, or as far as possible if there is not enough underlying material to cover the gap.

To trim from a region’s start and end points to fill gaps:
1. With the Selector tool, select across at least one gap between regions.
2. Choose Edit > Trim Region > To Fill Selection.

The start point of the region behind the gap is automatically trimmed (expanded) to the previous region, or as far as possible if there is not enough underlying material to cover the gap; and the end point of the region in front of the gap is automatically trimmed (expanded) to the next region, or as far as possible if there is not enough underlying material to cover the gap.

Trimming with Nudge

You can trim the start and end points of a region by nudging them.

To trim a region’s start or end point by the Nudge value:
1. Configure the Nudge value. For details, see “Defining the Nudge Value” on page 345.
2. With the Time Grabber tool, select the region you want to trim.
3. Do one of the following:
   - While pressing Alt (Windows) or Option (Mac), press Plus (+) or Minus (–) on the numeric keypad to trim the region’s start point by the Nudge value.
   - or –
   - While pressing Control (Windows) or Command (Mac), press Plus (+) or Minus (–) on the numeric keypad to trim the region’s end point by the Nudge value.
Healing Separated Regions

The Heal Separation command returns separated regions to their original state—provided the regions are still next to each other and their relative start/end points haven’t changed since the separation.

If you have trimmed or otherwise changed the start or end points of the two regions, or moved them further away from each other, you won’t be able to repair them with the Heal Separation command. It is not possible to heal two regions created from different audio files.

To heal a separation between two regions:

1. With the Selector tool, make a selection that includes part of the first region, the entire separation between the regions, and part of the second region.

2. Choose Edit > Heal Separation.

If the regions do not heal with Heal Separation, do one of the following to return the separated regions to a single region:

- Delete one of the two separated regions (verify that Slip mode is enabled so the gap doesn’t close) and use the Trim tool to expand the remaining region to its original length. For information on using the Trim tool, see “Using the Trim Tools” on page 289.

- or –

- Delete both of the separated regions and drag the original region from the Region List to the original location. For information on placing regions, see “Placing Regions in Tracks” on page 333.

Placing Regions in Tracks

Once you have created a region, it appears in the Region List. From the Region List you can drag it to a track to add to an existing arrangement of regions, or you can create a new track and start adding regions from scratch. The exact placement of regions in a track depends on whether the Edit mode is set to Shuffle, Slip, Spot, or Grid (see “Edit Modes” on page 280 for details).

For information on locating regions in the Region List by typing the first few letters of their name, see “Keyboard Selection of Regions” on page 279.

To place a region in a track:

1. In the Region List, select the region or regions you want to place.

2. Drag the selected regions from the Region List to a location in a track.

If dragging multiple regions, the regions are placed on adjacent tracks left to right or on multiple tracks from top to bottom depending on the selected Region List Timeline Drop Order (see “Timeline Drop Order” on page 334). If dragging a stereo region, it must be placed in a stereo track or in two mono tracks.
Regions are placed according to the current Edit mode:

- In Shuffle mode, existing track regions are slid as necessary to make room for the new region.
- In Spot mode, you are prompted by the Spot dialog to enter a location for the dragged region (see “Spotting Regions” on page 340).
- In Grid mode, the dragged region snaps to the nearest Grid boundary.
- In Slip mode, the regions are placed exactly where they are dropped in the destination track.

**Timeline Drop Order**

The Timeline Drop Order command in the Region List pop-up menu sets whether tracks dragged from the Region List are dropped sequentially in a single track or spread across multiple tracks, as follows:

**Top to Bottom** When enabled, regions spread across multiple destination (drop) tracks or on new tracks (when dragging to the area below the last track or to the Track List).

**Left to Right** When enabled, regions are placed sequentially in a single destination (drop) track or on a new track (when dragging to the area below the last track or on to the Track List).

**To set the Region List Drop Order:**

- Choose Region List > Timeline Drop Order, and then Top to Bottom or Left to Right.

To drag and drop multiple items from the Region List to multiple new tracks:

1. From the Region List pop-up menu, choose Timeline Drop Order > Top to Bottom.
2. Search and sort the Region List if desired to configure the order in which items will be placed.
3. Select multiple items in the Region List and do one of the following:
   - To create new tracks and place items to a specific location, drop items at the desired location along the area below the last track.
   - To create new tracks and have items placed at the start of the session, drop the items on the Track List.

To place multiple items across multiple existing tracks:

1. From the Region List pop-up menu, choose Timeline Drop Order > Top to Bottom.
2. Select multiple items in the Region List and drop them in the playlist of a compatible track at the desired location. When the cursor is over a compatible destination, the region outlines appear at the location.
To drag and drop multiple items from the Region List to a single track:

1. From the Region List pop-up menu, choose Timeline Drop Order > Left to Right.
2. Search and sort the Region List if desired to configure the order in which items will be placed.
3. Select multiple items in the Region List and do one of the following:
   - To create a new track and spot the first item to a specific location, drop at the desired location in the area below the last track shown in the Edit window.
   - To create a new track and have the first item placed at the start of the session, drop the items on the Track List.
   - To place items in an existing track, drop the items in the Edit playlist for the desired track.

If the selected items include mixed types of regions (such as audio and MIDI, or region groups and MIDI) the appropriate track types will be created and each corresponding item will be placed in them. Similarly, if the selected items include multiple formats (mono, stereo, or other) new tracks of each format will be created and those regions placed in them.

### Placing Regions at the Edit Insertion Point

You can drag a region from the same track, from another track, or from the Region List, and align its start, end, or sync point to the Edit insertion point. This technique is very useful in post production since it lets you set an Edit selection point during playback or while stopped and then quickly place sound effects at the edit insertion point.

💡 With Pro Tools HD, when the Scrolling option is set to Center Playhead, regions snap to the playhead, instead of the Edit insertion point.

**To place the start of a region at the Edit insertion point:**

1. With the Selector tool, click in the track at the time location where you want to place the start of the region.
2. Do one of the following:
   - While pressing the Start key (Windows) or Control (Mac), drag the region from the Region List, or from another track, to the destination track.
   - If the region is already in the track, Start-click (Windows) or Control-click (Mac) the region with the Time Grabber tool.

New tracks created by dropping multiple Region List items with Timeline Drop Order set to Left to Right mode
To place the end of a region at the Edit insertion point:

1. With the Selector tool, click in the track at the time location where you want to place the end of the region.

2. Do one of the following:
   - While pressing Control+Start (Windows) or Command+Control (Mac), drag the region from the Region List, or from another track, to the destination track.
   - or –
   - If the region is already in the track, Control-Start-click (Windows) or Command-Control-click (Mac) the region with the Time Grabber tool.

To place the sync point of a region at the Edit insertion point:

1. With the Selector tool, click in the track at the time location where you want to place the sync point of the region.

2. Do one of the following:
   - While pressing Shift+Start (Windows) or Shift+Control (Mac), drag the region from the Region List, or from another track, to the destination track.
   - or –
   - If the region is already in the track, Shift-Start-click (Windows) or Shift-Control-click (Mac) the region with the Time Grabber tool.

Aligning to Region Start Points

The start, end, and sync point of one region can be aligned to the start of a different region on another track.

With Pro Tools HD, when the Scrolling option is set to Center Playhead, region start, end, and sync points align to the playhead.

To align the start points of regions on different tracks:

1. With the Time Grabber tool, select the region you want to align to by clicking it.

2. If the Scrolling option is set to Center Playhead (Pro Tools HD only), move the playhead to the start of the selected region. For details, see “Moving the Playhead” on page 325.

3. Do one of the following:
   - Start-drag (Windows) or Control-drag (Mac) a region from the Region List to another track.
   - or –
   - If the region is already in the track, Start-click (Windows) or Control-click (Mac) the region you want to move with the Time Grabber tool.

   The start point of the second region is aligned to the start of the first region.

To align the end point of a region to the start of another region (on a different track):

1. With the Time Grabber tool, select the region you want to align to by clicking it.

2. If the Scrolling option is set to Center Playhead (Pro Tools HD only), move the playhead to the start of the selected region. For details, see “Moving the Playhead” on page 325.
3 Do one of the following:
  - Control-Start-drag (Windows) or Command-Control-drag (Mac) a region from the Region List to another track.
  - or –
  - If the region is already in the track, Control-Start-click (Windows) or Command-Control-click (Mac) the region you want to move with the Time Grabber tool.

The end point of the second region is aligned to the start of the first region.

**To align the sync point of a region to the start of another region (on a different track):**

1. With the Time Grabber tool, select the region you want to align to by clicking it.

2. If the Scrolling option is set to Center Playhead (Pro Tools HD only), move the playhead to the start of the selected region. For details, see “Moving the Playhead” on page 325.

3. Do one of the following:
   - Shift-Start-drag (Windows) or Shift-Control-drag (Mac) a region from the Region List to another track.
   - or –
   - If the region is already in the track, Shift-Start-click (Windows) or Shift-Control-click (Mac) the region you want to move with the Time Grabber tool.

The sync point of the second region is aligned to the start of the first region.

---

**Sliding Regions**

A region or group of selected regions (on the same track or on multiple tracks) can be slid with the Time Grabber tool to new locations or to other tracks. This feature is useful in post production applications where the timing of audio events such as sound effects and dialog need to be spotted to music, film, or video.

Sliding regions is affected by whether the current Edit mode is set to Shuffle, Slip, Spot, or Grid. See “Edit Modes” on page 280 for details.

💡 You can slide a copy of a region to another location or track by pressing Alt (Windows) or Option (Mac) while dragging.

💡 To retain a region’s time location when dragging to another track, press the Start key (Windows) or Control (Mac) while dragging.

**Shuffling Regions**

In Shuffle mode, you can move regions freely within a track or onto another track, but their movement is constrained by other regions. That is, if you place several regions in a track, their start and end points automatically snap to each other. You can then “shuffle” their order, but you cannot separate them from each other and you cannot make them overlap as in Slip mode.

In Shuffle mode, adding another region to the beginning of a track moves all subsequent regions to the right by the length of the region added.
To shuffle regions:

1. Set the Edit mode to Shuffle by clicking its button in the upper left of the Edit window.

2. Drag a mono region from the Region List to an empty track. The region snaps to the beginning of the track.

3. Drag a second region from the Region List to the same track, somewhere in the middle. The start point for the second region snaps to the end of the first region.

4. With the Time Grabber tool, drag the second region to the beginning of the track. Pro Tools “shuffles” the position of the two regions. The second region now occurs first, yet the two still cling together.

5. Experiment more with Shuffle mode by dragging additional regions to the track and rearranging them.

Locked regions (see “Locking Regions” on page 348), and all regions occurring after the locked region, are not displaced when other neighboring regions are moved in Shuffle mode. If there is not enough room to place or duplicate a region in front of a locked region, the insertion area is disabled.

If you place a region while in Slip mode and switch to Shuffle mode, Pro Tools preserves the relative timing and position of the slipped region, and any blank space between it and other regions.

With certain workflows, it is important to exclude Shuffle mode in order to ensure that regions stay time-aligned while editing. Shuffle Lock prevents you from inadvertently entering Shuffle mode by disabling all key commands and control surface switches for Shuffle mode. For more information, see “Shuffle Lock” on page 281.

Shuffling Multiple Tracks and Multichannel Regions

Selections across multiple tracks or on multichannel tracks can be shuffled. Unlike shuffling regions on a single track, any partially selected regions will be cut and moved along with the dragged region. This lets you retain only the material that corresponds to the dragged region.

Moving Regions with the Grabber Tools

Use the Grabber tools to move one or more regions, or the Edit selection, to another location. The Grabber tools cut the selection and paste it to the new location.

Hold down Alt (Windows) or Option (Mac) when clicking and dragging the selection with a Grabber tool to copy the selection rather than cut it.

To move one or more regions, or the Edit selection, with one of the Grabber tools:

1. Make a selection.

2. With of the Grabber tools (Time, Separation, or Object), click and drag the selection to the new location.
Time Grabber and Object Grabber

If you are moving audio data, the Time Grabber and Object Grabber tools overlay only the audio data on the destination track.

Separation Grabber

The Separation Grabber replaces the entire selected range on the destination track timeline.

Snapping to the Preceding or Next Region on a Track

A region—or an Edit selection including one or more regions on the same track or on multiple tracks)—can snap to the end of the preceding region or to the beginning of the following region using the Snap To Next or Snap To Previous commands. This is useful for “butt splicing” adjacent regions on a track.

To snap to the preceding region on a track:

1. Do one of the following:
   - With the Time Grabber, select a region.
     - or -
   - With the Selector, select an area in a track that contains whole regions. The regions do not need to be adjacent.

2. Do one of the following:
   - Choose Edit > Snap To > Previous.
     - or -
   - Right-click the region or Edit selection and choose Snap to Previous in the pop-up menu.

The selected region snaps to the preceding region on the track so that the two regions are “butt-spliced.”

To snap to the next region on a track:

1. Do one of the following:
   - With the Time Grabber, select a region.
     - or -
   - With the Selector, select an area in a track that contains whole regions. The regions do not need to be adjacent.
Do one of the following:

- Choose Edit > Snap To > Next.
- Right-click the region or Edit selection and choose Snap to Next in the pop-up menu.

The selected region snaps to the following region on the track so that the two regions are “butt-spliced.”

![Image: Snapping a region to the next region in a track]

You can also use the Snap To commands with an Edit selection that includes multiple regions on one or more tracks.

### Slipping Regions

In Slip mode, regions can be moved with the Time Grabber tool freely within a track, or onto other tracks. In this mode, it is possible to place a region so that there is space between it and other regions in a track. When the track is played back, this space is silent. It is also possible to move a region so that it overlaps or completely covers another region.

### To slip regions:

1. Set the Edit mode to Slip by clicking its button in the upper left of the Edit window.
2. Drag a region from the Region List to an empty track.
3. Drag a second region from the Region List to the same track, somewhere in the middle. The second region is placed wherever you release it. It doesn’t snap to the first region as in Shuffle mode.
4. Drag the regions to different locations within the track to get a feel for moving them in Slip mode. Try placing the second region so that it slightly overlaps the first region. Play back the results.

### Spotting Regions

Spot mode is useful for sessions in which you want to spot regions to precise locations based on any of the Time Scales. This can be particularly useful when performing post production tasks. In Spot mode you can spot a region by specifying a SMPTE frame (Pro Tools HD and Pro Tools LE with DV Toolkit 2 only) or bar and beat location, by capturing an incoming time code address, or by using the region’s time stamps.

1. Set the Edit mode to Spot by clicking its button in the upper left of the Edit window.
2. Choose Edit > Snap To > Snap to Next.
3. Right-click the region or Edit selection and choose Snap to Next in the pop-up menu.

For even quicker spotting, if you are using VITC, use the Auto-Spot Regions command to spot a region to the current SMPTE frame location with the Time Grabber tool. For more information, see “Auto-Spotting Regions” on page 693.

### To spot a region:

1. Set the Edit mode to Spot by clicking its button in the upper left of the Edit window.
Chapter 17: Working with Regions and Selections

2 Do one of the following:
- Drag a region from the Region List, or drag audio files or sessions from a DigiBase browser, to an existing track.
- or –
- Click a region already in a track with the Time Grabber tool.

3 In the Spot dialog, select a time format from the Time Scale pop-up menu.
Each of the fields in the Spot dialog are displayed in the chosen Time Scale.

4 With Pro Tools HD or Pro Tools LE with DV Toolkit 2, if the Time Scale is set to Time Code, select the Use Subframes option to display subframes in the fields for improved accuracy.

5 Do one of the following:
- Click in the field for Start, Sync Point, or End and type in a new location. Changing one of these locate points automatically updates the other locate points.
- Click one of the up arrows next to Original Time Stamp or User Time Stamp to enter the associated values into the currently selected field.
- If you are using an external SMPTE time code source, click the down arrow next to the Current Time Code display—or press Equal (=) on the numeric keypad—to capture an incoming time code address.

6 Click OK. The region is moved to the new location specified for its start, end, or sync point.

If a region does not have a sync point defined, the Sync Point field in the Spot dialog functions the same as the Start field.

To learn more about using SMPTE with Pro Tools, refer to Chapter 30, “Working with Synchronization.”

Right-Click Commands for Spotting Regions
You can use Right-click commands with a key combination to spot regions in a track.

In previous versions of Pro Tools, Right-clicking in a region with the Grabber tool would spot the region to a selection.

To spot a region to a selection:
1. Click or drag with the Selector tool to locate the cursor or make a selection in the track where you want to spot the region.
2. Control-Right-click (Windows) or Command-Right-click (Mac) the region and choose any of the following from the pop-up menu:
   - Move Region Start to Selection Start
   - Move Region Sync to Selection Start
   - Move Region End to Selection Start
Region Time Stamps

When a region is created, it is time stamped relative to the SMPTE start time specified for the session. This Original Time Stamp is permanently stored with the region and cannot be changed. If a region is ever moved, it can easily be placed at its original position from the Spot dialog.

When the Original Time Stamp for a region is initially set, this same location is also used to define the region’s User Time Stamp.

Unlike the Original Time Stamp, the User Time Stamp can be redefined with the Time Stamp command in the Region List pop-up menu. For more information, see “Time Stamping” on page 694.

Time Stamps in DigiBase

Columns are provided in DigiBase browsers for both the Original and User Time Stamps.

Time Stamps and Matches

Regions with identical User Time Stamps appear together in the Matches pop-up menu when auditioning takes. For more information, see “Selecting a Different Take from the Matches Pop-Up Menu” on page 206.

Sliding Regions in Grid Mode

Grid mode provides several useful capabilities for sliding and moving regions in track playlists. This mode is especially useful for lining up regions at precise intervals, as when working with a session that is bar- and beat-based. Grid boundaries, depending on the Main Time Scale, can be based on frames, bar and beat values, minutes or seconds, or a number of samples.

Grid mode also provides two operational modes, Absolute and Relative. These modes control how the Grid is applied. (See “Absolute and Relative Grid Mode” on page 343 for more information.)

To temporarily suspend Grid mode and switch to Slip mode while dragging a region, hold down the Control key (Windows) or Command key (Mac).

Setting Up the Grid

When the Display preference for “Draw Grid in Edit Window” is enabled, vertical Grid lines appear in the Edit window.

Grid lines in the Edit window can also be enabled and disabled by clicking the Timebase ruler name after it becomes highlighted.

Defining the Grid Value

In addition to affecting the placement of regions, the Grid value also constrains Timeline and Edit selections, and determines how the Region > Quantize to Grid command works.

To set the Grid value:

1. Do one of the following:
   - From the View > Main Counter menu, select the Time Scale you will use for the Grid value.
   - or -
   - To keep the Main Time Scale and use a different time format for the Grid, deselect Follow Main Timebase in the Grid value pop-up menu in the Edit window.
Do one of the following:

* From the Grid value pop-up menu in the Edit window, select the time value that will define the Grid boundaries.

– or –

* To define a Grid based on the session’s Markers, selections, and region boundaries, select Regions/Markers from the Grid value pop-up menu.

## Absolute and Relative Grid Mode

Grid mode can be applied in Absolute or Relative mode.

* In Absolute Grid mode, moving any region snaps the region start to Grid boundaries. If a region’s start point falls between beats, and the Grid is set to 1/4 notes, dragging the region will snap its start time to the nearest 1/4 note (the current absolute Grid value).

* In Relative Grid mode, regions can be moved by Grid (or Nudge) units. If a region’s start point falls between beats and the Grid is set to 1/4 notes, dragging the region will be constrained to 1/4 notes, preserving the region’s relative position to the nearest beat.

### To select Absolute or Relative Grid mode:

* Click the Grid mode selector and choose Absolute or Relative.

### To temporarily suspend Grid mode and switch to Slip mode while dragging a region:

Hold down the Control key (Windows) or Command key (Mac).

### To place or move a region while in Grid mode:

1. Configure the Grid value. For details, see “Defining the Grid Value” on page 342.

2. Do one of the following:

   * Drag a region from the Region List to an existing track.

   – or –

   * With the Time Grabber tool, drag a region already in a track to a new location.

The region’s start point snaps to the closest Grid boundary. If the region has a sync point defined, the sync point snaps to the Grid boundary.
Sync Points

The placement of regions in Grid and Spot mode can be based on the definition of a region sync point. Sync points are used when a specific point within a region must be aligned to the Grid or to a particular SMPTE or bar/beat location. This capability is important in placing music and sound effects for film and video work.

For example, suppose you had an audio region for a door slam that included the creak of the door closing, the actual slam, and the reverb of the slam. Using a sync point for the slam lets you spot the slam to a specific time in the session.

To define a region sync point:

1. Set the Edit mode to Slip by clicking its button in the upper left of the Edit window.
2. Do one of the following:
   • With the Selector tool, click at the point in the region where you want to define the sync point.
   – or –
   • Press the Down Arrow key while playing back.
3. Choose Region > Identify Sync Point. A small down arrow appears at the bottom of the region, with a vertical, light grey line indicating the location of the sync point.

To change the location of a sync point:

- With the Selector tool, click at a point in a region and choose Region > Identify Sync Point. The new location is identified as the sync point for the region.

You can also move the location of a sync point by dragging. See “Dragging Sync Points” on page 345.

Removing Sync Points

To remove a sync point, do one of the following:

- Select the entire region and choose Region > Remove Sync Point.
  – or –
- Choose the Time Grabber tool, then Alt-click (Windows) or Option-click (Mac) the sync point to delete it.

Displaying Sync Points

Sync points in audio regions may be displayed or hidden.

To disable the display of sync points in audio regions:

- Deselect View > Region > Sync Point.

To enable the display of sync points in audio regions:

- Choose View > Region > Sync Point.
Dragging Sync Points

You can drag a sync point to another position in the audio region.

To set the sync point by dragging:
1. If you want the sync point to snap to the current Grid value, set the Edit mode to Grid.
2. Select the Time Grabber tool.
3. Click and drag the sync point to a new location.

Scrubbing Sync Points

While viewing an audio waveform can be a good way to set a sync point, a waveform display may not always reveal the desired spot in the audio material. By scrubbing while moving the sync point over an audio waveform, you can listen for the exact location to place the sync point.

Scrubbing a Sync Point

To scrub while dragging the sync point:
1. If you want the sync point to snap to the current Grid value when you finish scrubbing, set the Edit mode to Grid.
2. Select the Scrubber tool.
3. Drag the sync point to a new location. The sync point will scrub the audio as you move it.

Nudging

Pro Tools can nudge regions (or MIDI notes) by precise increments with the Plus (+) and Minus (–) keys on the numeric keypad. The amount of the nudge is determined by the value specified in the Nudge Value pop-up menu. The Nudge function can be used in any of the Edit modes.

Nudging can be invaluable for adjusting the “groove” of a musical phrase or a sound effect relative to other elements in the session. Since Pro Tools can nudge material during playback, you can nudge continuously in real time to adjust the timing relationship between tracks.

Nudge can also be used to adjust the placement of automation breakpoints. For more information, see “Editing Automation” on page 606.

Defining the Nudge Value

The Nudge value determines how far regions and selections are moved when nudging.

Start and end points for selections can also be moved by the Nudge value (see “Nudging Selection Start/End Points” on page 314). In addition, regions can be trimmed by the Nudge value (see “Trimming with Nudge” on page 332).

To set the Nudge value:
1. Do one of the following:
   - From the View > Main Counter menu, select the Time Scale you will use for the Nudge value.
   - or –
   - To keep the Main Time Scale and use a different time format for the Nudge value, deselect Follow Main Timebase in the Nudge Value pop-up menu in the Edit window.
2 From the Nudge value pop-up menu in the Edit window, select the Nudge value.

To specify a Nudge value not listed in the Nudge Value pop-up menu, click the Nudge Value indicator and type in the value.

**Nudging Regions**

**To nudge one or more region:**

1. Configure the Nudge value. For details, see “Defining the Nudge Value” on page 345.
2. With the Time Grabber or Selector tool, select the region, regions, or region groups you want to nudge. The regions can reside on multiple tracks. Only regions that are completely selected are nudged.
3. Do one of the following:
   - On the numeric keypad, press Plus (+) to move the selection forward by the Nudge value.
   - Press Minus (−) to move the selection back by the Nudge value.

The Nudge command works the same regardless of the Edit mode. Adjacent regions are overlapped in Shuffle mode, the Spot dialog does not appear when in Spot mode, and shifted material does not snap to the Grid when in Grid mode.

**Nudging Regions on Multiple Tracks and in Multichannel Tracks**

When nudging a selection of multiple regions within a single track or across multiple tracks, that also contains silence, any automation data residing within the silence is also nudged.

**Nudging by Next Nudge Value**

In addition to nudging by the current Nudge value, you can also nudge by the next, larger value in the Nudge pop-up menu.

For example, if the Nudge value is set to 1 frame and you want to nudge by a larger value, you can nudge by the next, larger Nudge value of 10 frames.

**To nudge forward or back by the next, larger Nudge value:**

1. Enable the Commands Keyboard Focus by clicking the Keyboard Focus button in the upper left of the Edit window.
2. With the Selector or Time Grabber tool, select the regions or notes you want to nudge.
3. Press Forward Slash (/) to nudge the selected material forward by the next Nudge value. Press M to nudge the selection back.

*You can also nudge by the next Nudge value without enabling the Commands Keyboard Focus. While pressing the Start key (Windows) or Control (Mac), press Forward Slash (/) or M.*
Nudging a Region’s Contents

Often a region’s start point will reside at the correct location, perhaps at a SMPTE frame or bar, but the material within the region starts too late or early. You can, in effect, nudge a region’s audio waveform or MIDI notes without displacing the region’s start and end points.

This “sliding” of region contents is only possible if there is material residing outside the region’s start and end points—from the region having been trimmed, or perhaps captured from a larger region.

To nudge the contents of a region without changing the region start and end points:

1. Configure the Nudge value. For details, see “Defining the Nudge Value” on page 345.
2. With the Time Grabber tool, select the region whose contents you want to nudge.
3. While pressing the Start key (Windows) or Control (Mac), press Plus (+) or Minus (–) on the numeric keypad to move the material by the Nudge value.

Shift Command

Use the Shift command to move track material forward or back in time by a specified amount. The Shift command can operate on selections, regions, MIDI notes, MIDI controller data, and automation breakpoints.

To shift a selection or region:

1. With the Selector or Time Grabber tool, select the track material you want to shift. The selected material can reside on multiple tracks.
2. Choose Edit > Shift. In the Shift dialog, select whether the data will be moved Earlier or Later.
3. Click in one of the Timebase fields to specify the amount the material will be shifted. Entering a value in one Timebase field automatically updates the others.
4. If you want to shift material with greater precision, select the Use Subframes option.
5. Click OK. The material is shifted back or forward by the specified amount.

If a portion of a region was selected, new regions are created from the selection and from any material outside of the selection.
The Shift command works the same regardless of the Edit mode. For example, adjacent regions are overlapped in Shuffle mode, the Spot dialog does not appear when in Spot mode, and shifted material does not snap to the Grid when in Grid mode.

### Quantizing Regions to Grid

The Quantize to Grid command adjusts the placement of selected audio and MIDI regions so that their start points (or sync points, if they contain them) precisely align to the nearest Grid boundary.

**To quantize one or more regions:**

1. Configure the Grid value. For details, see “Defining the Grid Value” on page 342.

2. With the Selector or Time Grabber tool, select the region or regions you want to quantize. The regions can be on multiple tracks. Only regions that are entirely selected will be quantized.

3. Choose Region > Quantize to Grid. Region start times (or sync points) are aligned to the nearest boundaries for the defined Grid.

For MIDI regions, all data contained within the regions (such as notes) are moved equally, thereby retaining their rhythmic relationships. To quantize individual MIDI notes, use the Quantize command in the Event > MIDI submenu (see “Input Quantize” on page 503).

### Locking Regions

If you have a region or group of regions that you want to permanently associate with a particular location in a track (a beat, SMPTE frame, or sample location), you can lock it in place so it will not be accidentally moved. Locked regions cannot be moved or deleted.

**To lock a region:**

1. With the Time Grabber, select the region or regions to lock. The regions can even reside on multiple tracks.

2. Choose Region > Lock/Unlock.

A small lock appears in the region, indicating it has been locked and cannot be moved. If you attempt to perform edits that would move a locked region, Pro Tools alerts you.

In Shuffle mode, locked regions, and all regions occurring after the locked region, are not displaced when other neighboring regions are moved.
Muting/Unmuting Regions

Choosing the Mute/Unmute Region command mutes playback of a selected region. Choosing the command a second time unmutes the region. Regions that are muted become dimmed to indicate their status.

To mute a region or regions:

1. With the Time Grabber, select the region or regions you want to mute. The regions can even reside on multiple tracks.

2. Choose Region > Mute/Unmute. The selected regions become dimmed, indicating they are muted.

To unmute a region, select it and choose Region > Mute/Unmute.

Replacing Audio Regions

(Pro Tools HD and Pro Tools LE with DV Toolkit 2 Only)

You can use the Replace Region function to replace multiple instances of an audio region in a playlist with another region. Control-Shift-drag (Windows) or Command-Shift-drag (Mac) from the Region List onto another region on a track.

This is useful in post production if you use a sound effect, room noise, or atmosphere region many times in a session, and later decide to replace one or all of the original regions with a different region.
This is also useful in music production if you want to replace a certain loop or sample (for example, a drum beat) with a new one. You can use this compositionally, if you know the tempo of a section or session, to create a scratch piece with “rough” regions of the correct length, and later replace them with “final” regions of the same length.

The following options are available in the Replace Region dialog:

**Replace: Original Region Only** Replaces only the selected region with the replacement region dragged from the Region List.

**Replace: All Instances of the Original Region** Replaces all instances of the selected region that fit the On criteria with the replacement region from the Region List.

  - On This Track: replaces regions that fit the Match criteria and are on the same track as the original region.
  - On All Tracks: replaces regions that fit the Match criteria for all tracks in the session.
  - On Within the Selection: replaces regions that fit the Match criteria within the current selection.

Region matching uses all specified Match criteria. For example, if you select Start Position and End Position, all regions from the same original audio file as your selection with the same original start and end times will be replaced.

**Replace: All Regions That Match Original Region’s** Replaces all regions that fit the Match criteria and the On criteria with the replacement region from the Region List.

  - Start Position: replaces all regions that have the same original start time as the selected region. This includes regions that may have been auto-created when trimming end points.
  - End Position: replaces all regions that have the same original end time as the selected region. This includes regions that may have been auto-created when trimming start points.
  - Name: replaces all regions that come from the same audio file and have been renamed to the same name
  - On This Track: replaces regions that fit the Match criteria and are on the same track as the original region.
  - On All Tracks: replaces regions that fit the Match criteria for all tracks in the session.
  - On Within the Selection: replaces regions that fit the Match criteria within the current selection.

**Fit Region Using The: Original Region Length** If the replacement region is smaller than the original region, the region is placed in the playlist and any remaining audio from the original region is removed.

If the replacement region is larger than the selection, it is placed in the playlist and trimmed to fit within the length of the original region.
Chapter 17: Working with Regions and Selections

**Fit Region Using The: Original Selection Length**
When the playlist selection extends beyond the original region, the replacement region (if larger than the original region) is trimmed to fit within the selection.

**Fit Region Using The: Replacement Region Length**
The replacement region is placed in its entirety, regardless of the length of the original region or selection.

The Replace Region function only works on a selection that includes a single region on one track. The function is not available when the playlist selection includes the start points for two or more regions. Also, if the selection is across several tracks, only the selection in the first (top) track is used.

**To replace regions:**

1. Select a region in a track's playlist that you want to replace. The selection can extend beyond the region's end point, to include material from the replacement region that is longer than the original region.
2. Control-Shift-drag (Windows) or Command-Shift-drag (Mac) the replacement region from the Region List to the selected region. The Replace Region dialog opens.
3. Do one of the following:
   - If you want to replace only the original region, select Replace Original Region.
   - or –
   - If you want to replace multiple regions, select Replace All Instances of the Original or Replace All Regions That Match Original.
4. If you selected Replace All Regions That Match Original, set the Match criteria (Start Position, End Position, and Name).
5. If you are replacing multiple regions, select whether to apply the replacement to the current track, all tracks, or within the selection.
6. Select whether to fit the replacement regions to the current selection, the entire region, or the entire replacement region regardless of the destination length.
7. When you have set all the options, click OK.

**Replace Regions with Drag and Drop**
Use the key modifiers Control+Shift on Windows, or Command+Shift on Mac, while dragging any region from the Region List to any unselected region on a track to open the Replace Region dialog without having to make a selection first.

**Selecting Regions**
The Replace Regions command is also available in the Region List pop-up menu. To use this command, make sure there is a region selected in a track and a different (replacement) region selected in the Region List, as explained in the following instructions.

> By default, selecting a region in a track selects the same region in the Region List. If this preference is turned off on your system, the following instructions are not necessary.

**To access the Replace Regions dialog:**
1. Select a region in a track. This is the region that will be replaced.
2. Control-click (Windows) or Command-click (Mac) the desired replacement region in the Region List to select it. (The Control key is required if the preference setting Region List Selection Follows Track Selection is at its default, enabled setting).
Choose Replace Regions from the Region List pop-up menu.

**Replace Region and Multichannel Tracks**

The Replace Region command supports dragging multichannel regions from the Region List to multichannel tracks, provided they are the same format.

For example, you can replace a stereo region, selected in a stereo audio track, with another stereo region from the Region List. But you cannot replace it with two mono audio regions.

In addition, replacing regions in multiple mono tracks with multichannel regions is not supported.

**Choosing an Alternate Channel for a Specific Region**

*(Pro Tools HD Only)*

You can replace a mono region (or selected portion of a mono region) with a matching segment of an alternate channel that was recorded simultaneously. Any fades performed on the original region are automatically recalculated against the replacement region, and any pre-existing automation on that track is unchanged.

**To replace a region with a matching alternate channel:**

1. In the Timeline, make a selection that includes or overlaps the region or portion of the region you want to replace.

2. Do one of the following:
   - With any Edit tool, Right-click (Windows or Mac) or Control-click (Mac) the selection you want to replace, then select Matches from the pop-up menu.
   - or –
   - With the Selector tool, Control-click (Windows) or Command-click (Mac) the selection you want to replace.

The Matches pop-up menu appears, displaying matching alternate channels under the Channels header. (This pop-up menu also displays any available alternate takes under the Alternates header.)

3. From the Matches pop-up menu, select the name of the alternate region that you want to use to replace the original region.

4. Repeat this procedure for every region you want to replace on each track.
Conditions for Alternate Channel Availability

An alternate channel is available to replace the original channel (represented by the region or portion of a region selected on the Timeline) if all of the following are true:

• Both channels are part of a multichannel part of a recording made simultaneously on one or more field recorders.
• Certain metadata matches between the original channel and the alternate channel.
• The metadata embedded during shooting and recording has been preserved prior to import into Pro Tools.

With multichannel recordings from one or more field recorders, both channels must overlap at least once between their start time code and end time code positions, and must also meet one of the following conditions:

• Matching Scene and Take
• Matching Shoot Date (applies only if Scene and Take contain any information for both channels)
• Matching Tape name
• Matching Sound Roll name
• Alternate channel Sound Roll name matches current channel Tape name
• Alternate channel Tape name matches current channel Sound Roll name

Edit Commands

Pro Tools provides many standard edit commands—such as cut, copy, and paste—and also many specialized edit commands that are optimized for audio and MIDI production—such as Repeat Paste to Fill.

Cut, Copy, Paste, and Clear

Use the Cut, Copy, Paste, and Clear commands to rearrange and edit track material. Edits can operate on entire regions selected with the Time Grabber tool, or on track ranges selected with the Selector tool. Edits can also work across multiple tracks (see “Editing Across Multiple Tracks” on page 357).

You can cut, copy, and paste discontiguous regions by selecting them with the Object Grabber tool.

Track View and Edit Content

When cutting or copying track material, the Track View determines the type of data placed on the Clipboard. When displaying waveforms for audio tracks, or when viewing MIDI or Instrument tracks in Notes or Regions Views, selections include all underlying automation and controller data. Thus, cutting an audio region also cuts any volume, pan, mute, send, or plug-in automation that is also on the track. This saves you from having to individually cut from each automation playlist on the track.

For detailed information on working with multichannel recordings made with field recorders, see the Field Recorder Workflow Guide.

Audio waveform data
However, when selecting groups of MIDI notes with any of the Grabber tools (by drawing a rectangle around them), only the note data is placed on the Clipboard. When selecting a time range of MIDI notes with the Selector tool, all controller data in the track is selected (similar to selecting with the Selector tool for audio tracks in Waveform View).

When a track is displaying automation data or controller data, only that data is placed on the Clipboard. Also, whenever you cut or copy automation data, bounding breakpoints are created at each end of the selected area, in order to preserve the slope of the automation both inside and outside the selection.

New regions are often auto-created when performing edits. For instance, when clearing a selection from a region, new regions are auto-created from the material residing outside of the selection.

**Cut and Copy Commands**

Use the Cut command to place the selection on the Clipboard while also removing it from the track.

Use the Copy command to place a copy of the selection on the Clipboard so it can be pasted to another track, or to the same track at a different location, while leaving the original intact and in place.

**To cut or copy a selection or region:**

1. If you want to constrain the selection to the current Grid value, set the Edit mode to Grid.

2. Set the Track View for the tracks you want to edit.

When displaying waveforms for audio tracks, or notes or regions for MIDI tracks, selections include underlying automation and controller data. If the track is displaying automation data, only the automation data is affected by the edits.

3. Do one of the following:

   - Drag with the Selector tool in the track to select the material you want to cut or copy.
   - or –
   - Use the Time Grabber tool to select one or more regions (or a group of MIDI notes).
4 Do one of the following:
   • Choose Edit > Cut to remove the selection and place it on the Clipboard.
   – or –
   • Choose Edit > Copy to place the selection on the Clipboard, without removing it.

If a portion of a region was cut or copied, the material on the Clipboard appears as a new region in the Region List. If a portion of a region was cut, new regions are auto-created from the material residing outside of the selection.

When working in Shuffle mode, adjacent regions are slid over, as necessary, to fill blank spaces.

Deleting Underlying Region Data

When removing a region or selection, you can choose to remove or keep the underlying region data.

To delete a region or selection along with the underlying region data:
   ■ Choose Edit > Cut.

To delete a region or selection without removing the underlying region data:
   ■ Choose Edit > Clear.

Paste Command

Use the Paste command to place the Clipboard’s contents at the Edit insertion point, overwriting any material already there.

To paste a selection or region:
   1. If you want to constrain the insertion point or the selection to the current Grid value, set the Edit mode to Grid.

2 Do one of the following:
   • With the Selector tool, click in a track at the point where you want to paste the material. Press Tab to move the insertion point forward to region start and end times; to move back, press Control+Tab (Windows) or Option+Tab (Mac).
   – or –
   • Use the Selector or Time Grabber tool to make a selection where the material will be placed.

3 Choose Edit > Paste.

If pasting at an insertion point in Shuffle mode, material to the right of the paste point is shifted to the right. In Slip mode, the material is overwritten with the paste.

If pasting into a selection in Shuffle mode, the selection is replaced by the Clipboard’s contents with the adjacent material slid left or right as necessary. In Slip mode, the selection is also replaced but with the surrounding material remaining unchanged.

   When working with MIDI, you can merge the contents of the Clipboard with material in the destination track. For details, see “Merge” on page 356.

   With Pro Tools HD, the Fill Paste command can be used to fill a selection with the contents of the Clipboard. For details, see “Repeat To Fill Selection” on page 357.

Clear Command

Use the Clear command to remove a selection from a track without placing it on the Clipboard.
To clear a selection or region:

1. If you want to constrain the selection to the current Grid value, set the Edit mode to Grid.

2. Set the Track View for the tracks you want to edit.

When displaying waveforms for audio tracks, or notes or regions for MIDI tracks, selections include underlying automation and controller data. If the track is displaying automation data, only the automation data is affected by the edits.

3. Do one of the following:
   - Drag with the Selector tool in the track to select the material you want to clear.
   - or –
   - Use the Time Grabber tool to select one or more regions (or a group of MIDI notes).

4. Choose Edit > Clear to remove the selection.

If a portion of a region was cleared, new regions are auto-created from the material residing outside of the selection. If working in Shuffle mode, adjacent regions are slid over, as necessary, to fill the blank space.

Special Cut, Copy, Paste, and Clear Commands

Use the four “special” Edit menu commands (Cut Special, Copy Special, Paste Special, and Clear Special) for editing automation playlists (volume, pan, mute, and plug-in automation) on audio, Auxiliary Input, Master Fader, VCA Master, and Instrument tracks. These commands can also be used for MIDI controller data on MIDI and Instrument tracks.

You cannot paste MIDI controller data to automation data nor automation to MIDI.

Cut Special

The Cut Special commands let you cut just automation data from the current selection (without associated audio, video, or MIDI notes) and place it in memory to paste elsewhere. Choices include:

- **All Automation** Cuts all automation or MIDI controller data whether it is shown or not.
- **Pan Automation** Cuts only pan automation or MIDI pan data whether it is shown or not.
- **Plug-in Automation** Cuts only plug-in automation that is shown.

Copy Special

The Copy Special commands let you copy just automation data from the current selection (without associated audio, video, or MIDI notes) and place a copy of it in memory to paste elsewhere.

- **All Automation** Copies all automation or MIDI controller data whether it is shown or not.
- **Pan Automation** Copies only pan automation or MIDI pan data whether it is shown or not.
- **Plug-in Automation** Copies only the plug-in automation that is shown.

Paste Special

The Paste Special commands let you paste automation data into another region (without affecting associated audio, video, or MIDI notes) in the following ways:

- **Merge** Pastes MIDI controller data from the clipboard to the selection and merges it with any current MIDI controller data in the selection. This can be useful for consolidating MIDI data from several tracks into a single MIDI track.
Repeat to Fill Selection Pastes multiple iterations of audio, video, or MIDI data from the Clipboard to fill the selection. If you select an area that is not an exact multiple of the copied region size, the remaining selection area is filled with a trimmed version of the original selection. This allows you to easily create drum loops and other repetitive effects. Before the data is pasted, Pro Tools prompts you to specify a crossfade to smooth transitions between regions.

To Current Automation Type Pastes the automation or MIDI controller data from the clipboard to the selection as the current type of automation or continuous MIDI data. This lets you copy one type of automation data to another, or one type of continuous MIDI date to another type of contiguous MIDI data.

Clear Special

The Clear Special commands let you clear just automation data from the current region. Choices are:

All Automation Clears all automation or MIDI controller data whether it is shown or not.

Pan Automation Clears only pan automation or MIDI pan data whether it is shown or not.

Plug-in Automation Clears only plug-in automation that is shown.

For more information on working with automation data, see Chapter 27, “Automation.”

Repeat To Fill Selection

The Repeat To Fill Selection command lets you automatically fill a selection with audio or MIDI regions or data without requiring that you manually duplicate the regions. To use Repeat To Fill Selection, cut or copy an audio or MIDI region, then make a selection and use the command to fill the selection. When pasting audio regions, you are prompted to specify a crossfade to be used for the pasted regions.

If you fill an area that is an exact multiple of the copied region size (for example, filling 16 bars with a 4-bar loop), the copied selection is pasted as many times as it takes to fill the selection. If you fill an area that is not an exact multiple of the copied region size (for example, filling 15 seconds of a track with a 2-second atmosphere or room noise region), the remaining selection area is filled with an automatically trimmed version of the original selection.

To fill a selection with Repeat to Fill Selection:

1. Select the audio or MIDI region you want to copy and choose Edit > Copy.
2. Select the area you want to fill using the Selector tool and choose Edit > Paste Special > Repeat to Fill Selection.
3. Do one of the following:
   - If pasting audio regions to larger areas, the Batch Fades dialog opens. Configure the dialog to insert crossfades between each pasted region, then click OK.
   - or –
   - If you do not want crossfades for the pasted audio, click Cancel in the Batch Fades dialog.

Editing Across Multiple Tracks

When working with data from multiple tracks, there are some important points to remember. For instance, if any of the selected tracks are set to their master view (see “Master Views for Tracks” on page 257), edits affect not only audio and MIDI for the selected tracks, but all automation and controller data as well.
If all selected tracks are displayed as automation data, edits only affect the type of automation data displayed in each track. Furthermore, if track 1 displays Pan automation, track 2 displays Volume automation, and track 3 displays Mute automation, the Cut command cuts only pan data from track 1, volume data from track 2, and mute data from track 3.

For details on selecting data on multiple tracks, see “Selecting Across Multiple Tracks” on page 316.

When copying only automation or controller data for selected tracks, press the Start key (Windows) or Control (Mac) to copy all types of automation on all selected tracks.

To paste to multiple tracks, place the insertion point in each of the destination tracks by Shift-clicking in them—or to select all tracks, Alt-Shift-click (Windows) or Option-Shift-click (Mac) in a track, or make a selection in one of the Timebase rulers.

When you paste multiple types of data, whatever data has been copied is pasted into the correct type of playlist. Automation data is pasted into the corresponding automation playlist. Audio or MIDI data is pasted into the audio or MIDI playlist. You do not need to set target tracks to the specific type of data being pasted for the paste to work correctly.

If all destination tracks in a multitrack paste are displayed as automation, the paste replaces any previous data on the target track without shuffling—regardless of whether you are in Slip or Shuffle mode.

### Duplicate Command

The Duplicate command copies a selection and places it immediately after the end of the selection. Though this is similar to using Copy and Paste, Duplicate is more convenient and faster, particularly when working with data on multiple tracks.

To make more than one copy of a selection, use the Repeat command (see “Repeat Command” on page 359).

As with the Copy and Paste commands, certain rules apply when duplicating material on multiple tracks. For details, see “Editing Across Multiple Tracks” on page 357.

**To duplicate a selection or region:**

1. If working with material that is bar- and beat-based, such as loops, set the Main Time Scale to Bars:Beats.

2. If you want to constrain the selection to the current Grid value, set the Edit mode to Grid.

3. Do one of the following:
   - Drag with the Selector tool in the track to select the material you want to duplicate.
   - Click in the track and enter the start and end points for the selection in the Event Edit area.

4. Choose Edit > Duplicate. The material is placed immediately after the selection’s end point.

In Shuffle mode, the duplicated data is placed directly after the end of the selection. Regions occurring after it are slid to accommodate the duplicated material. In Slip mode, the duplicated material overlaps any adjacent data.
When using Duplicate or Repeat with MIDI notes that were selected with the Time Grabber tool, material is always duplicated one measure later, and is merged with existing track material (instead of replacing).

**Duplicating Audio**

When using Duplicate (or Repeat) for audio that must fall cleanly on the beat (such as rhythmic loops), it is important that you select the audio material with the Selector tool, or by typing in the start and end points in the Event Edit area. If you select an audio region with the Time Grabber tool (or by double-clicking it with the Selector tool), the material may drift by several ticks because of sample-rounding.

If, on the other hand, you want to Duplicate (or Repeat) audio that is not bar- and beat-based, set the Time Scale to any format except Bars:Beats. This ensures that the duplicated audio material will have the correct number of samples and will be placed accordingly.

**Duplicating VCA Slave Tracks**

Duplicating a VCA slave track without duplicating its group assignments will coalesce any automation the duplicate track. The coalesced duplicate plays back exactly as if it were in the VCA group.

**Repeat Command**

The Repeat command is similar to Duplicate, but allows you to specify the number of times the selected material is duplicated.

As with the Copy and Paste commands, certain rules apply when repeating material on multiple tracks. For details, see “Editing Across Multiple Tracks” on page 357.

To repeatedly paste copied data until it completely fills a selection, see “Repeat To Fill Selection” on page 357.

**To repeat a selection or region:**

1. If working with material that is bar- and beat-based, such as loops, set the Main Time Scale to Bars:Beats.
2. If you want to constrain the selection to the current Grid value, set the Edit mode to Grid.
3. Do one of the following:
   - Drag with the Selector tool in the track to select the material you want to repeat.
   - or –
   - Click in the track and enter the start and end points for the selection in the Event Edit area.
4. Choose Edit > Repeat. In the Repeat dialog, enter the number of times you want the material to repeat, then click OK.

The material is placed immediately after the selection’s end point, and duplicated by the number of times specified.

In Shuffle mode, the repeated data is placed directly after the end of the selection. Regions occurring after it are slid to accommodate the repeated material. In Slip mode, the repeated material overlaps any adjacent data.
Editing Stereo and Multichannel Tracks

Regions on individual channels within stereo and multichannel tracks cannot be independently selected. All selections for these tracks are time-based, which means that selections made with the Selector or Time Grabber tool extend to each channel in the track.

When regions in multichannel tracks are edited with any of the Trim tools or dragged with the Time Grabber tool, material on all channels is affected equally as a group.

Split Selected Tracks

To edit a specific channel within a stereo or multichannel track without affecting the other channels, you can split the track into separate mono tracks. Once the edits have been made to the separated material, you can then drag or copy it back to the original multichannel track.

To split a stereo or multichannel track:

1. Select the track you want to split by clicking its name in the Mix or Edit window. To split multiple tracks, Shift-click additional tracks.
2. Choose Track > Split into Mono. Regions from the channels on the selected tracks are placed on new, mono audio tracks.

Names for the new tracks are based on the source track name and channel suffix. For example, if a stereo track called “Funkit” is split, two new tracks called “Funkit.L” and “Funkit.R” are created.

Output and send assignments and volume and pan settings are retained in the new tracks. Mono equivalents of stereo and multi-mono plug-in assignments are assigned in the new tracks; multichannel plug-in assignments are not assigned in the new tracks.

Dragging Regions to and from Stereo and Multichannel Tracks

When dragging regions to or from stereo or multichannel tracks, the following rules apply:

- Provided the number of tracks and channels are the same for the source and destination, you can drag regions between multichannel tracks and mono tracks.
- The source and destination for dragged regions can be mixed. For example, you can drag regions from a 5.0 track (containing five channels) to a stereo track and three mono audio tracks.
- When dragging multichannel regions to mono tracks, the destination tracks must be adjacent.
- When dragging regions from mono tracks to a multichannel track, the source tracks need not be adjacent.
Multichannel regions can also be dragged from the Region List, to multichannel tracks of the same format, groups of mono audio tracks, or a combination of both.

Conversely, a collection of single, mono regions can be dragged from the Region List to multichannel tracks—provided the dragged number of regions matches the number of channels in the destination track.

**Processing Audio with AudioSuite Plug-ins**

The AudioSuite plug-ins included with your Pro Tools system can be used to process and modify an audio region or entire audio file. You may do this in order to apply a specific AudioSuite process, such as Normalization or DC Offset Removal, that you know you will always want applied to the audio.

Refer to the DigiRack Plug-ins Guide for more information about AudioSuite plug-ins.

---

**Waveform Repair with the Pencil Tool**

The Pencil tool allows you to destructively “re-draw” waveform data. This tool is most commonly used to repair a pop or click in an audio file. A pop or click appears as a sudden sharp spike in a waveform. This tool only becomes active when the Edit window is zoomed in to the sample level.

*The Pencil tool is a destructive editing tool that permanently modifies the audio file on disk and should be used with caution.*

Although you can Undo a Pencil tool edit, it is recommended that you create a backup copy of the target audio, before using the Pencil tool. You can do this by using the AudioSuite Duplicate plug-in.

**To make a copy of an audio region:**

1. Select the source region in the track’s playlist.
2. Choose AudioSuite > Duplicate.
3. In the AudioSuite dialog, make sure that Playlist is enabled as the processing preference, and that Use In Playlist is enabled.
4. Click the Process button.

The AudioSuite Duplicate plug-in creates a new audio file that is a duplicate of the original. The duplicate replaces the original on the track, and it is automatically named with the region name and the suffix DUPL.
To destructively edit an audio waveform with the Pencil tool:

1. Locate the area you want to edit.

2. Using the Zoomer tool or the Zoom buttons, zoom down to the sample level so the waveform appears as a continuous thin line. Adjust the Track Height, as necessary, to edit the waveform with greater precision. You can also use vertical zoom for greater visual resolution.

   You can recall zoom levels with the Zoom Preset buttons (see “Using the Zoomer Tools” on page 284), or with Memory Locations (see “Memory Locations and Markers” on page 428).

3. Select the Pencil tool.

4. Carefully draw with the Pencil tool by dragging over the area of the waveform.

Do not over-edit or the results may be undesirable. You can use the Undo command to undo your previous edit.

Try to limit editing to smoothing over a very small problem area, and keep the “fixes” in character with the shape of the surrounding waveform.

If you have trouble zooming in far enough to perform Pencil tool editing, check the Edit window (session) length. Shorten the overall Edit window (session) length, if possible, until the Pencil tool becomes usable.

Region Groups

A region group is a collection of any combination of audio and MIDI regions that looks and acts like a single region. Region groups can be created on a single or on multiple adjacent audio, MIDI, and Instrument tracks. Region groups let you “nest” multiple regions into “macro” regions for groove and tempo manipulation, editing, and arranging.

Region groups are essentially containers holding one or more regions. Region groups can be placed on tracks alongside standard regions, and edited using many of the same Pro Tools editing techniques. Certain edits to a region group will apply to all regions contained by the region group, such as Cut or Delete. Other edits only apply to the boundaries of the region group and do not affect the underlining regions, such as Trim.
Region groups are particularly useful for:

- Grouping tick-based audio regions that have been separated into many small regions, such as with individual hits of a drum pattern.
  Many such small regions can easily be created with Beat Detective or the Separate Region At Transients command, or imported as REX or ACID files.
- Grouping parts and sections to facilitate composition and arranging. For example, grouping the regions of a brass section during the chorus to copy it to the next chorus.

⚠️ Region groups are completely independent of Mix and Edit Groups.

**Creating Region Groups**

**To create a region group:**

1. Select one or more regions on one or more tracks. (For more information on multitrack region groups, see “Multitrack Region Groups” on page 364).

   The size of the selection determines the size of the region group. The selection can start and end on any region boundary, empty space, or even in the middle of a region. Selections starting or ending within a region will separate the region at the selection boundary when you create a region group. Region groups created from object-based selections include all regions between the first and last selected region on the track whether they are selected or not.

2. Choose Region > Group.

The region group will appear as one region with the region groups icon in the lower left corner. Region groups also appear in the Region List.

A region group on an audio track and in the Region List

**Region Group Timebase Format**

Region groups are created in the same timebase format (samples or ticks) as the tracks they are on. Multitrack region groups can include both sample-based and tick-based tracks.

A region group on an audio track

A region group on a MIDI track

⚠️ Region groups can be created from empty selections. This can be useful when working in Shuffle mode to preserve the gaps between regions.

⚠️ The Group and Ungroup Region menu commands apply to any Time or Edit selection regardless of the current Track View.
Ungrouping Regions

To ungroup a region group:
1. Select a region group.
2. Choose Region > Ungroup.

The region group disappears, revealing all underlying regions and any nested region groups. When there are multiple nested region groups, the Ungroup command will ungroup the frontmost top-layer region group only, preserving any underlying region groups.

To ungroup a region group (and include all of its nested region groups):
1. Select a region group.
2. Choose Region > Ungroup All.

Regrouping Regions

The Regroup menu command undoes the last Ungroup command and regroups the individual regions back to their former region group state. This lets you ungroup a grouped region, edit its underlying regions in any way desired, and regroup it to continue working on higher-level composition and arranging.

To regroup a region group:
1. Select any region from the ungrouped region group.
2. Choose Region > Regroup.

If you used the Ungroup All command, the Regroup command recreates all previous nested region groups.

3. If you regrouped an ungrouped region group that was used more than once in the session, do one of the following when the Change All dialog opens.
   - Choose Modify to apply your changes to all other instances of the same region group.
   - or –
   - Choose Copy to create a copy and apply your changes only to the copied region group.

Multitrack Region Groups

Multitrack region groups (region groups created across multiple tracks) are useful for grouping parts, such as multi-miked drum tracks, and for composing and arranging. Multitrack region groups can be created across any combination of audio, MIDI, and Instrument tracks, and can include either or both tick-based or sample-based tracks.

Multitrack region groups work much like single-track region groups. Multitrack region groups appear as a single object across adjacent tracks.
To create a multitrack region group:

1. Select regions across multiple adjacent tracks.

2. Choose Region > Group.

Separated Multitrack Region Groups

You can insert, move, hide, or delete tracks in multitrack region groups, but it may break the region group. A separated region group displays a break in the Region Group icon. Separated region groups will continue to function as a single.

⚠️ Multitrack region groups create nested region groups of multiple regions by track before grouping them across tracks.

🌞 The Regroup command supports multitrack region groups.
region group, but the separated icon indicates that the region group displayed is somehow incomplete or separated across nonadjacent tracks.

If you want to delete a track and keep the region group intact, first ungroup the region group, then delete the desired track, and then Regroup the region group. The region group will be recreated intact, but without the deleted track.

Region Groups on Tick-Based Tracks

When changing tempos, region groups on tick-based tracks adjust their length by adjusting the position of all enclosed regions accordingly. This is useful for arranging rhythmic material and for playing back REX and ACID files.

Changing Region Group Timebase

The timebase format of a region group can be changed by:

• Changing the track’s timebase.
• Dragging the region group to a track with a different timebase.

Changing the timebase creates a copy of the original region group. Both region groups (the original and the copy) appear in the Region List, but they have different timebases.

A region group separated by deleting a track

A region group on a tick-based audio track 120 BPM and at 160 BPM
Chapter 17: Working with Regions and Selections

Converting Samples to Ticks

When dragging a region group from a sample-based track to a tick-based track, the length of the region group will not change. This is because region groups are converted from samples to ticks after they are moved into tick-based tracks. The length of the region group will only change with subsequent tempo changes. If possible, change the local tempo on the tick-based track to match the tempo of the sample-based region group before moving a sample-based region group to a tick-based track.

Converting Ticks to Samples

When dragging a region group from a tick-based track to a sample-based track, the length of the region group will not change unless it is moved to another time location with a different tempo. This is because region groups are converted from ticks to samples after they are moved into the sample-based tracks.

Multitrack Region Groups with Sample- and Tick-based Tracks

Multitrack region groups can include both sample-based and tick-based tracks. Changing the tempo will separate the region group between sample-based tracks and tick-based tracks.

Editing Region Groups

Region groups are edited in much the same way as regular regions: They can be named, moved, cut, copied, pasted, trimmed, muted, locked, and so on. However, there are a few significant differences between editing regular regions and region groups.

Editing MIDI Region Groups

If a MIDI region within a region group is modified in any way, a new region copy is created and placed over the region group. For example, if you record, draw in a new note, edit MIDI controller data, or Quantize a Timeline selection, a new region is created over the region group.

Editing Audio Region Groups

Certain audio editing commands create new regions over region groups. To use these commands and maintain the region group, ungroup the region group, perform the edit, and then regroup the region group.

The following edit commands create new regions over region groups:

- AudioSuite processing of a grouped region results in a new region over the region group.
- Consolidating a selection of a grouped region creates a new audio file and region over the region group.
- Recording into a region group creates a new audio file and region over the region group.
- Pencil tool waveform redraw results in a new region over the region group.

A multitrack region group separated across sample-based and tick-based tracks after changing tempo
Tabbing to Transients and Region Boundaries

With Tab to Transients enabled, the Tab key moves the Location Cursor to transients and region boundaries within a region group.

With Tab to Transients disabled, the Tab key move the Location Cursor to region group boundaries only (and the sync point, if present).

For more information, see “Tabbing to Transients” on page 319.

Trimming Region Groups

Trimming region groups works the same way as trimming regular regions, regardless of whether the you are trimming a single-track region group or a multitrack region group. The exception is the TC/E Trim tool.

Trimming a region group does not trim the underlying regions. All underlying regions retain their length and location. This is true for all underlying audio and MIDI regions, and nested region groups. Consequently, if you trim the region group shorter, underlying regions may not be heard on playback because they are outside the region boundaries of the trimmed region group.

The TC/E Trim tool applies only to audio regions, and creates a new region over any region group.

If you Ungroup after trimming a region group in (shorter), audio regions falling outside of the bounds of the current region group are trimmed to fit and removed.

Recording

When recording audio or MIDI, new regions are created over (in front) of region groups instead of being included in the region group. To record into a region group, first ungroup the region group, then record, and then regroup the region group. The region group will be recreated intact with the newly recorded material.

Fades and Crossfades on Region Groups

Region groups can have fades and crossfades just like regular regions. Fades only apply to audio regions. In addition to crossfading between region groups, you can also crossfade between region groups and regular audio regions.

Ungrouping a region group removes any region group level fades or crossfades. Fades and crossfades are restored by the Regroup command.

With region groups on tick-based tracks, when changing tempo you may need to Ungroup, redo or create new fades, and then Regroup in order to maintain the desired fades.
Importing and Exporting Region Group Files

Pro Tools can export and import the new region group file format (.rgrp). You can import and export region group files to do any of the following:

- Separate region group metadata from audio files to avoid unnecessary file copy operations when exporting audio region groups composed from multiple source files
- Export MIDI data as part of a region group
- Create multitrack loops

Region group files store the following metadata:

- References to all audio files within the region group
- Region names and relative location in tracks
- Fades and crossfades
- Region group names and format (single or multitrack)
- All MIDI data present in the region group (such as notes, controllers, Sysex, and so on)
- Track names

Region group files do not store the following:

- Automation
- Plug-ins
- Track routing
- Tempo and Meter map
- Region List information

To export a region group, excluding its audio files:

1. Select one or more region groups in the Region List.

2. From the Region List pop-up menu, choose Export Region Groups. The Export Region Groups dialog opens.

3. The Destination Directory defaults to the auto-created Region Groups folder in the session folder. You can change the Destination Directory by clicking the Choose button, navigating to the desired location, and clicking Choose. Click Reset to reset the Destination Directory to the default location.

4. Enable one of the following options for resolving duplicate region group file names:
   - Prompting for Each Duplicate (default)
   - Auto Renaming
   - Replacing with New Files

5. Click OK.

Exporting Region Groups with Audio Files

Generally, if you are exporting region groups to another hard drive, you should copy any referenced audio files. This way you can move region groups not only from one session to another, but from one system to another.

To export a region group and include its audio files:

1. Export one or more region groups to the desired drive.

2. Create a new session on the new drive.
3 Choose Setup > Preferences.
4 In the Preferences dialog, click the Processing tab and select Automatically Copy Files on Import.
5 Click OK to close the Preferences dialog.
6 Import all previously exported region groups by dragging and dropping them into the session.

The audio files folder of the new session now contains all files referenced by the region groups.

**Importing a Region Group**

**To import a region group:**

- Drag and drop the region group file from a DigiBase browser or from Windows Explorer or Mac Finder to the Timeline, a track, the Track List, or the Region List.

Dropping a region group has the following different results depending on where you drop it:

- When dropping a region group in a track, Pro Tools checks for the matching track format, number of channels, and (in the case of multitrack region groups) if there are enough matching adjacent tracks to import the region group file. If these criteria match, the region group is imported and spotted to the drop location in the track or tracks.
- Dropping a region group on the Timeline or on the Track List creates new tracks for the imported region group.
- Dropping a region group in the Region List adds a new region group in the Region List. All audio and MIDI regions, and even other region groups, contained within the dropped region group also appear in the Region List.

**Region Looping**

Audio regions, MIDI regions, and region groups can all be looped using the Region > Loop and Unloop menu commands. Looping regions is an easy and powerful way to repeat a single region on a track or regions across tracks for composing and arranging. Looping regions provides more flexibility than the traditional Pro Tools Repeat and Duplicate menu commands.

Looped regions repeat the source region as many times as specified in the Region Looping dialog, or enough to fill the specified Loop Length (such as 30 seconds or until the next region on the track). The *source region* is the original region selected for looping. *Loop iterations* are all looped regions following the source region. In cases where a specific number of repetitions has not been indicated, the last loop iteration will be truncated to fill to the end of the selection or specified Loop Length.

Once looped, the looped region can be edited much like a region group. For example, selecting and moving a looped region selects and moves the source region and all its loop iterations together.
Looped regions (all iterations) display a Loop icon in the lower, right corner.

Creating Looped Regions

To loop a region:

1. Select an audio or MIDI region, or region group.

You can also select regions across tracks for looping.

Selecting and looping more than one region on a track will loop only the first region in the selection.

2. Choose Region > Loop. The Region Looping dialog opens.

Looped region

Looping a region does not loop any automation associated with the source region. Use the Copy Special and Paste Special Repeat To Fill Selection commands to copy automation for the source loop to all loop iterations (see “Automation and Looped Regions” on page 374).

Region Looping dialog

3. Do one of the following:

- Select the Number of Loops option and enter the number of times to loop the region.
- Select the Loop Length option and enter the duration according to the main time-base. If the duration is not an exact multiple of the source loop's duration, the last loop iteration will be truncated.
- Select the Loop Until End of Session or Next Region option. The looped region will be repeated until the end of the session, or until the next region on the track. The last loop iteration will be truncated to fit.
4 If desired, select the Enable Crossfade option. This will create a crossfade at the loop point. To edit the loop crossfade, do the following:
• Click the Settings button.
• Configure the Loop Crossfades.
• Click OK.

5 In the Region Looping dialog, click OK.

To rename the looped region name only (or the region name and disk file name):
• Double-click the loop icon with the Grabber.

To unloop a looped region:
1 Select the looped region.
2 Choose Region > Unloop. The Unloop Regions dialog opens.
3 Do one of the following:
   • Click Remove to unloop and remove all loop iterations except the first full loop iteration.
   – or –
   • Click Flatten to unloop and create individual regions from each loop iteration.

Region Ungroup functions on loops the same as using the Unloop command and choosing Flatten.

To unloop and ungroup a selection down to its individual regions:
1 Select a looped region that contains one or more region groups.
2 Choose Region > Ungroup All.

Unlooping and Flattening Loopied Regions with Separate Regions Menu Commands

The Separate Regions commands (At Selection, On Grid, and At Transients) will automatically unloop and flatten looped regions before separating.
Editing Looped Regions

Looped regions can be edited as a group or as individual regions. For example, selecting a looped region with the Grabber tool will select the entire loop (the source region and all its loop iterations), but clicking the Loop icon of one of the loop iterations will select only that one iteration.

Moving a looped region moves the source region and all its looped aliases together as a group. Loop iterations cannot be moved independent of their source region. If you move or paste another shorter region over a looped region the loop is continued after the new region. The parts of a separated looped region can be adjusted independently.

To select a looped region as a group, do one of the following:
- With the Grabber tool or Smart Tool, single-click the looped region.
- With the Selector tool, double-click the looped region.

The source region and all its loop iteration will be selected.

To select an individual source region or loop iteration, do one of the following:
- With the Grabber tool or Smart Tool, single-click the Loop icon of the source region or loop iteration.
- With the Selector tool, single click the Loop Region icon and drag to the left until the region is selected.

Tabbing to Transients and Region Boundaries

Tab to Transients tabs to transients and region boundaries in a looped region. Normal Tab (Tab to Transients disabled) tabs to the start and end boundaries of the entire looped region.

Trimming Looped Regions

Trimming looped regions can be done using the Trim tool, the Loop Trim tool, or one of the Trim Region commands. The Trim tool trims the entire looped region. The Loop Trim tool provides the most unique feature of loop editing and trims the duration of the individual loop iteration while filling the total length of the looped region.

To trim a looped region as a group:
1. Select the Standard or Scrub Trim tool.
2. Trim the start or end of the looped region as desired.

Trimming a looped region with the Standard Trim tool

Hold down the Start key on Windows, or the Control key on Mac, while trimming to trim in loop iteration increments.

Trimming a loop does not trim any underlying Fades.

The TC/E Trim tool unloops and consolidates the looped region.
To trim a looped region using the Loop Trim tool:

1. Select the Standard or Scrub Trim tool.
2. Move the cursor over a Loop icon in the looped region. The cursor changes to the Loop Trim tool icon.
3. Trim the start or end of the loop iteration as desired.

The number of repetitions of the trimmed loop increases or decreases to fill the length of the entire looped region.

To trim a looped region to the selection:

1. Use the Selector tool to make an Edit selection including some or all of the looped region.
2. Choose Edit > Trim Region and one of the Trim Region commands (To Selection, To Fill Selection, Start to Fill Selection, End to Fill Selection).

If the source region is extended to the left using the Trim tool for the total length of the loop, the source region is moved earlier in the Timeline and loop iterations fill in up to the point where the last original loop iteration ended. If the trim to the left is part of the source region’s length, the source region is not moved and a partial loop iteration is created to the left of the source region. This is a powerful feature that lets you make quick changes to your arrangement by using partial loops as upbeats, or by extending looped sound effects or ambience earlier in a film score.

Automation and Looped Regions

Looping an audio region does not loop any automation associated with the source region. This is useful in that automation can be applied across an entire looped region. For example, you may want to have a long fade across part or all of looped region.

You can also repeat automation on individual loops. For looped audio regions, use the Copy Special and Paste Special Repeat to Fill Selection commands to copy and paste any or all automation data from the source region to some or all of its loop iterations.

To copy and paste automation from the source region to loop iterations:

1. Select the source region.
2. Choose Edit > Copy Special and one of the Copy Special commands (All Automation, Pan Automation, Plug-in Automation), depending on what automation you want to copy.
3. Select the looped region.
4. Choose Edit > Paste Special > Repeat to Fill Selection.
Chapter 18: Fades and Crossfades

Using Crossfades

You can quickly and easily crossfade between two adjacent audio regions. Crossfading is the process of fading two regions of audio to prevent pops, clicks, or sudden changes in sound. Crossfades have many applications, from smoothing transitions between regions to creating special audio effects. The crossfade duration, position, and shape are all user-definable.

Crossfades are computed and written to disk. Crossfades that are written to disk are stored in a folder named “Fade Files” within the session folder. When you play back your track, Pro Tools reads and plays back the crossfade file from disk.

Pro Tools does not allow you to replace fade-ins and fade-outs with crossfades. To add a crossfade between regions, any existing fade-ins and fade-outs between the regions must first be deleted.

Pro Tools HD includes an AutoFade feature that provides real-time fades without processing them to disk. See “Using AutoFades” on page 384.

About Crossfades and Curves

To create a crossfade between two regions, use the Selector tool to select across the end point of the first region and the start point of the second. The length of the selection determines the length of the crossfade. Though fades may appear to be discrete regions, they cannot actually be separated from the regions in which they were created. You can, however, create fade-ins and fade-outs for individual regions (see “Creating Fades at the Beginnings and Ends of Regions” on page 383).

You can use the Fades dialog to select, view, and manipulate the curves used to perform the crossfade. Different volume curves can be assigned to the fade-out and fade-in portions of crossfades. The Fades dialog can also render a preview of the fade.

The following examples illustrate common crossfade types, and explain how the type of selection you make determines the character of the crossfade.

Since crossfades are created by fading between overlapping audio material, a crossfade cannot be performed on regions that do not contain audio material beyond their region boundaries.
Standard Crossfade (Centered)

This type of selection creates a crossfade on both sides of the splice point, which affects the volume of region 1 and region 2. It is the most common type of crossfade.

This crossfade type requires that region 1 contain audio material beyond its end point, and region 2 contain audio material before its start point.

Pre Crossfade

This type of selection creates a crossfade before the splice point. This lets you maintain the volume of the very beginning of region 2 instead of fading across it, which is useful if there is a strong attack at the beginning of region 2 that you want to preserve. When making selections for crossfades that occur on the border of two regions, you can use the Tab key to move the cursor to the exact beginning or end of a region.

This crossfade type requires that region 2 contain audio material before its start point.

Post Crossfade

This type of selection creates a crossfade after the splice point. It is useful if you want to maintain the amplitude of region 1 until its very end. When making selections for crossfades that occur on the border of two regions, you can use the Tab key to move the cursor to the exact beginning or end of a region.

This crossfade type requires that region 1 contain audio material beyond its end point.
The Fades Dialog

When choosing the Edit > Fades command you can use the Fades dialog to select, view, and pre-view the crossfade, and to edit the curves used to perform the crossfade.

View Second Track

If you are fading between more than one track this button allows you to view and preview the audio of the second pair of adjacent tracks.

View Both Tracks

Click this button to display the waveforms of the first two adjacent tracks in a multitrack fade.

Fade Curves Only

Click this button to display the specified fade curves without showing the actual audio waveforms. This is the default view when you open the Fades dialog.

Fade Curves and Separate Waveforms

Click this button to display the specified fade curves along with separate views of the fade-in and fade-out waveforms.

Fade Curves and Superimposed Waveforms

Click this button to display the specified fade curves along with superimposed views of the fade-in and fade-out waveforms.

Fade Curves and Summed Waveform

Click this button to display the specified fade curves along with a single waveform representing the summation of the crossfaded audio.
**Zoom In**

Click this button to scale the view of the waveform’s amplitude upwards. Control-click (Windows) or Command-click (Mac) for the default view scale.

**Zoom Out**

Click this button to scale the view of the waveform’s amplitude downwards. Control-click (Windows) or Command-click (Mac) for the default view scale.

**Fade Out Shape Setting**

The Out Shape setting allows you to choose the shape of the fade-out from region 1.

**Standard** Selects a single continuous fade curve. This creates a general-purpose fade that can be edited by dragging the curve itself.

**S-Curve** Selects an S-shaped curve, which inverts its beginning and end characteristics. This makes it possible to fade out faster at the curve’s start and slower at its end, for example. S-shaped curves can be useful with material that is difficult to crossfade effectively. S-curves can be edited by dragging the curve in the curve editor.

**Preset Curves** Seven commonly used preset curves are provided for fast crossfade creation. These can be edited by dragging the end points of the curve in the curve editor portion of this dialog. The seven presets are as follows:

- Preset Curve 1 keeps region 1 at full volume throughout the crossfade, then immediately drops the volume at the end of the crossfade.

- Preset Curve 2 fades out region 1 relatively slowly, keeping the volume fairly high throughout the duration of the fade.

- Preset Curve 3 fades out region 1 slightly faster, keeping the volume slightly lower during the fade.

- Preset Curve 4 fades out region 1 with a linear fade. This is the default curve.

- Preset Curve 5 fades out region 1 quickly at the beginning of the crossfade.
Preset Curve 6 drops the volume of region 1 even more quickly at the beginning of the cross-fade.

Preset Curve 7 silences region 1 at the beginning of the crossfade.

**Link Settings**

The Link setting links the selected fade-out and fade-in curves. If you adjust one curve, the corresponding curve also adjusts. This ensures that the resulting crossfade is an *equal power* or *equal gain* crossfade, depending on which you select.

**Equal Power** Recommended for material that is not phase coherent, as in the case of a crossfade between two completely different types of material. Use this option to avoid the volume drop that can occur with an Equal Gain crossfade. With this fade, you can Alt-click (Windows) or Option-click (Mac) the fade curve to reset it to its default shape.

**Equal Gain** Recommended for material that is phase-coherent or nearly phase-coherent, as in the case of a crossfade between identical regions/instruments (for example, a repeated drum loop). Use this option to avoid clipping that can occur when using an Equal Power crossfade. With this fade, you can Alt-click (Windows) or Option-click (Mac) the fade curve to reset it to its default shape.

**None** Disables linking between the fade-out and fade-in curves, and lets you freely adjust them separately, including start and end points. This option also allows you to create custom crossfade shapes.

When Link is set to Equal Power or Equal Gain, you can edit only the fade-in portion of the curve, by pressing Alt (Windows) or Option (Mac) while dragging. To edit only the fade-out portion of the curve, press Control (Windows) or Command (Mac) while dragging.

**Use Dither**

The Use Dither option turns on a preset, noise-shaped dither function that improves audio performance when fading in or fading out of silence, and crossfading between low amplitude regions. Dithering is usually not necessary when fading between two regions of high amplitude. You can disable Dither while editing your crossfades in the Fades dialog to speed up previews and fade recalculation, then re-enable Dither to create the final crossfade.
**Fade In Shape Settings**

The In Shape setting allows you to choose the shape of the fade-in to region 2.

**Standard** Selects a single continuous fade curve. This creates a general-purpose fade that can be edited by dragging the curve itself.

**S-Curve** Selects an S-shaped curve, which inverts its beginning and end characteristics. This makes it possible to fade in faster at the start of the curve, and slower at the end. S-shaped curves are useful with material that is difficult to crossfade effectively. S-curves can be edited by dragging the curve in the curve editor.

**Preset Curves** Seven commonly used preset curves are provided for fast crossfade creation. These can be edited by dragging the end points of the curve in the curve editor portion of this dialog. The seven presets are as follows:

- Preset Curve 1 fades in region 2 at full volume immediately at the beginning of the crossfade and keeps it there throughout the crossfade.

- Preset Curve 2 fades in region 2 quickly in the beginning, reaching full amplitude fairly early in the crossfade.

- Preset Curve 3 fades in region 2 moderately fast.

- Preset Curve 4 fades in region 2 with a linear fade curve. This is the default curve.

- Preset Curve 5 fades in region 2 slowly at the beginning of the crossfade.

- Preset Curve 6 fades in region 2 even more slowly than the previous curve.

- Preset Curve 7 silences region 2 until the end of the crossfade.
Typical Curve Combinations

Following are the available combinations of fade-out and fade-in curves.

**Linear Crossfade** This is a good general purpose crossfade with a smooth, even transition between region 1 and region 2.

**Equal Power Crossfade** This is a good general purpose crossfade useful in cases where a linear crossfade seems to create a noticeable drop in volume across the splice point.

**Overlap Fade** This combination of curves keeps both regions at full amplitude throughout the crossfade: region 2 “jumps in” at the beginning and region 1 “jumps out” at the end.

Fade and Crossfade Preferences

*(Pro Tools HD Only)*

You can set default fade and crossfade settings. These settings load as your “base” settings when you use the Create Fades command, and the Fade to Start and Fade to End commands.

To set the crossfade preferences:

1. Choose Setup > Preferences and click the Editing tab.
2. Set the Pre-Roll and Post-Roll times for Fade previews.
3. Click Fade In and set the default shape for fade-ins, then click OK.
4. Click Fade Out and set the default shape for fade-outs, then click OK.
5. Click Crossfade and set the default shape for crossfades, then click OK.
6. Click OK.

Creating a Crossfade

To create a crossfade between two regions:

1. With the Selector tool, click at the point where you want the crossfade to begin in the first region and drag to where you want it to end in the second region. Crossfade selections can begin and end anywhere in their respective regions.

2. Do one of the following:
   - Choose Edit > Fades > Create.
   - or –
   - Press Control+F (Windows) or Command+F (Mac).

3. Use the view buttons to adjust the view of the crossfade. It may take a few moments to calculate the waveform display for long selections.
4 Select an Out Shape and an In Shape.
5 Choose a Linking option.
6 Click the Audition button, or play the session, to hear the crossfade. For long crossfades, it may take Pro Tools a few moments to calculate and load the audio into playback RAM.
7 Do one of the following:
   • Adjust the curves by choosing different preset shapes with the Out Shape and In Shape pop-up menus.
   – or –
   • Drag the Fade In/Out curves to a custom shape. By choosing None as the Linking option, you can drag the beginning or end points of a fade curve to adjust its beginning or end point.
8 Click the Audition button, or play the session, to hear the crossfade again.
9 When the crossfade is right, click OK. The fade is calculated and written to disk, but the audio files and regions remain unchanged. Crossfades are stored in the Fades Folder within the session folder.

   Crossfade lengths can later be resized with any of the Trim tools.

To remove a crossfade, do one of the following:
   ■ Select the area of the track containing the crossfades you want to delete and choose Edit > Fades > Delete.
   ■ Select the crossfade with the Time Grabber tool and press Backspace (Windows) or Delete (Mac).
   ■ Right-click the crossfade with any of the edit tools and select Delete Fades from the pop-up menu.

To trim a crossfade:
1 Select the crossfade with the Time Grabber tool, or double-click it with the Selector tool.
2 With any of the Trim tools, trim either side of the crossfade. The crossfade is recalculated to reflect the newly trimmed length.

Crossfades On Tick-Based Audio Tracks
Crossfades are re-rendered after changing tempo in a tick-based audio track. The new crossfade is the same length as the crossfade prior to the tempo change.

If there is not enough audio material to complete the crossfade, or if the new crossfade area falls outside of valid region boundaries, the crossfade is removed.

Pre and Post Crossfade Selections
By making a selection that begins or ends precisely on the border of two regions, you can create “pre” or “post” crossfades. Use the Tab key to place the insertion point at the exact beginning or end of a region.

To create a pre- or post-crossfade:
1 With the Selector tool, click in the track that contains the regions you want to crossfade.
2 Do one of the following:
   • Press Tab to move forward to the next region boundary.
   – or –
   • Press Control+Tab (Windows) or Option+Tab (Mac) to move back to the previous region boundary.
3 Extend the selection as follows:
• Shift-drag to adjust your selection, or press Shift+Tab to extend the selection forward to the next region boundary.
  – or –
• Press Control+Shift+Tab (Windows) or Option+Shift+Tab (Mac) to extend the selection back to the previous region boundary.

4 Do one of the following:
• Choose Edit > Fades > Create.
  – or –
• Press Control+F (Windows) or Command+F (Mac).

5 Choose a fade type and click OK.

Creating Fades at the Beginnings and Ends of Regions

In addition to crossfades between regions, Pro Tools lets you create fade-ins and fade-outs at the beginnings and ends of regions.

With Pro Tools HD, you can also use an automatic fade-in/out option, which applies real time fade-ins/outs to all regions during playback. These fades are not written to disk, but automatically applied during playback. See “Using AutoFades” on page 384.

Creating Fade-Ins and Fade-Outs

Depending on how you make the selection, you can position a fade-in/out at the exact beginning or end of a region, or position it so it extends into a blank area of the track. The length of the selection in the region determines the length of the fade-in/out.

You can also fade to the beginning or end of a region from an insertion point.

Although fades appear to be discrete regions, fades cannot be separated from the regions in which they were created.

When changing tempo in a tick-based audio track, fade-ins and fade-outs remain with their parent regions, and are unaffected by changes in tempo.

To create a fade-in:

1 Select the beginning of the region that you want to fade in. The selection must extend to the exact beginning of the region or a blank area prior to the region in the track.

2 Do one of the following:
   • Choose Edit > Fades > Create.
   – or –
   • Press Control+F (Windows) or Command+F (Mac).

3 Choose the fade-in curve and other settings.

4 Click the Audition button to hear the fade (or press the Spacebar to start and stop playback).
You can adjust the curve by dragging it or by choosing a different shape with the In Shape pop-up menu.

When you are finished, click OK. Pro Tools calculates the fade and writes it to disk. The chosen fade curve appears in the region.

**To create a fade-out:**

1. Select the end of the region that you want to fade out. The selection must extend to the exact end of the region or a blank area after the region in the track.

2. Do one of the following:
   - Choose Edit > Fades > Create.
   - or –
   - Press Control+F (Windows) or Command+F (Mac).

3. Choose the fade-out curve and other settings.

4. Click the Audition button to hear the fade (or press the Spacebar to start and stop playback).

5. You can adjust the curve by dragging it or by choosing a different shape with the Out Shape pop-up menu.

6. When you are finished, click OK. Pro Tools calculates the fade and writes it to disk. The chosen fade curve appears in the region.

   *Fade lengths can later be resized with any of the Trim tools.*

**To fade from the insertion point to a region start point:**

1. Place the cursor at a location in the region.

2. Do one of the following:
   - Choose Edit > Fades > Fade To Start.
   - or –
   - Press Alt+D (Windows) or Control+D (Mac).

The fade is applied based on the Fade In preferences.

**To fade from the insertion point to a region end point:**

1. Place the cursor at a location in the region.

2. Do one of the following:
   - Choose Edit > Fades > Fade To End.
   - or –
   - Press Alt+G (Windows) or Control+G (Mac).

The fade is applied based on the Fade Out preferences.

---

**Using AutoFades**

(Pro Tools HD Only)

With Pro Tools HD, you can choose to have Pro Tools automatically apply real-time fade-ins and fade-outs to all region boundaries in the session. These fade-ins and fade-outs are performed during playback and do not appear in the Edit window, and are not written to disk.

This automatic fade-in/out option also has an effect on Voice borrowing in a session. Whenever a lower-priority virtual track “pops thru” a silence in a higher-priority track on the same voice, a fade-in and fade-out is applied to the transition.
This feature is especially useful in post production situations such as dialogue tracking. For example, you could assign both a dialogue track and a “room tone” track with matching background to the same voice. You could then set the AutoFade option to a moderate length (4 ms or so) so that whenever a silence occurred in the dialog, playback would switch smoothly to and from the background track without clicks or pops.

Using automatic fade-ins/outs saves you the trouble of editing to zero-crossings or creating numerous rendered fades in order to eliminate clicks or pops in playback. However, since these autofades are not written to disk, those clicks or pops still exist in the underlying sound file. Consequently, those anomalies still appear if the Duplicate AudioSuite plug-in or the Export Selected as Sound Files command (from the Region List) are used to duplicate multiple regions as a continuous file. To render these real-time auto fades to disk, choose File > Bounce to > Disk.

**To set the length of automatic fade-ins/outs:**

1. Choose Setup > Preferences and click the Operation tab.

2. Enter a value between 0 and 10 ms for the Auto Region Fade In/Out Length. A value of zero (the default) means that no auto-fading will occur.

3. Click OK. The AutoFade value is saved with the session, and is automatically applied to all free-standing region boundaries until you change it.

---

**Creating Fades and Crossfades in Batches**

In “Batch mode” you can create many fades at once. You select across several regions and use the Create Fades command to create crossfades for each region transition. If your selection includes regions that already have crossfades, this feature allows you to modify them.

**To create crossfades between multiple regions at once:**

1. With the Selector tool, click in the first region in which you want to create a crossfade.

2. Drag to extend the selection to the last region you want to crossfade. Make sure that the selection includes the entire region.

3. Do one of the following:
   - Choose Edit > Fades > Create.
   - Press Control+F (Windows) or Command+F (Mac).

4. Select whether you want to Create New Fades, Create New Fade-Ins & Outs, Adjust Existing Fades, or a combination of these options.

---

*Selected regions for Batch Fades*
If you select to create new fades and new fade-ins and outs, new crossfades are created at each region boundary that is bordered by another selected region, a fade-in is created at the start of the first region, and a fade-out is created at the end of the last region.

5 Choose the placement of your Fades. You can choose Pre-Splice, Centered, or Post-Splice.

6 Enter a crossfade length in milliseconds.

7 Click OK. Pro Tools creates the fades for the selected regions.

Moving and Nudging Fades

Fades can be moved or nudged in tracks, independently of their contributing regions. Moving or nudging fade-ins or fade-outs reveals or hides audio as the fade is moved from the edge of a contributing region. Moving or nudging crossfades changes the overlap point of the contributing regions. Moving or nudging fades is also constrained by underlying region boundaries.

To move or nudge a fade or cross-fade within its contributing regions:

1 Select the fade or crossfade by doing one of the following:
   - Use the Time Grabber tool to select the fade.
   - or –
   - Use the Selector tool to select a range that includes the fade.

2 Move the fade by doing one of the following:
   - Drag the fade with the Time Grabber tool to a new location on the track.
   - or –
   - Nudge the fade by pressing Plus (+) or Minus (–) on the numeric keypad to move the fade forward or backward on the track.

Batch Fades dialog

5 Choose the placement of your Fades. You can choose Pre-Splice, Centered, or Post-Splice.

6 Enter a crossfade length in milliseconds.

7 Click OK. Pro Tools creates the fades for the selected regions.

Fade lengths can later be resized with any of the Trim tools.
Moving and Nudging Regions with Fades

Moving Regions Containing Fades

When you move or nudge a region selection that contains a fade-in, fade-out, or crossfade, the fade moves with the selection. (This is legacy behavior in Pro Tools.)

To move a region selection with a fade:

1. Do one of the following:
   - Click a region with the Time Grabber tool (or double-click with the Selector tool) to select the region along with the fade.
   - or –
   - Select multiple regions that include the fades you want to move.

2. Move the region selection by doing one of the following:
   - Drag the region selection with the Grabber tool to a new location on the track.
   - or –
   - Nudge the region selection by pressing Plus (+) or Minus (–) on the numeric keypad to move the region forward or backward on the track.

Nudging Regions Adjacent to Fade-Ins or Fade Outs

When you nudge a region selection adjacent to a fade in or fade out, but do not select the fade, the adjacent fade stretches or shrinks to maintain the fade start or end point. The amount of change depends on the amount of audio material outside the fade start or end point.

To a nudge region without its fade:

1. Select a region by doing the following:
   - Make sure Tab to Transients is off.
   - Using the Selector tool, press the Tab key to locate the start of the region.
   - Hold Shift and press Tab to the end of the region.

2. Nudge the region by pressing Plus (+) or Minus (–) on the numeric keypad.
Moving Regions Adjacent to Crossfades

When you move either of the regions that contributes to a crossfade, the regions separate. The status of the fade depends on the Preserve Fades when Editing preference.

To separate crossfaded regions and retain the corresponding fades:

1. Choose Setup > Preferences and click Editing.
2. Under Fades, select Preserve Fades when Editing.
3. Click OK to close the Preferences dialog.
4. Use the Time Grabber or Separation Grabber tool to select one of the contributing regions to a crossfade.
5. Drag the selected region with the Grabber.

Nudging Regions Adjacent to Crossfades

When you nudge either of the regions that contributes to a crossfade, the fade stretches to preserve the relative position of the crossfade start and end points. The amount of stretch depends on the amount of overlap between the contributing regions.

If you nudge a region beyond the boundary of available audio for the crossfade, the fade is removed.

To nudge a region and stretch its crossfade:

1. Use the Time Grabber tool to select one of the contributing regions to the crossfade.
2 Nudge the region by pressing Plus (+) or Minus (–) on the numeric keypad.

Separating Regions That Include Fades

You can create regions from track material that overlaps with fades. The fades from the source region are adjusted to the new region.

To separate a region that overlaps with a fade or crossfade:

1. With the Selector tool, drag to select the material for the new region.
2. Do one of the following:
   - Choose Edit > Separate Region > At Selection
   - or –
   - Press Control+E (Windows) or Command+E (Mac).

Where your selection overlaps any fade-ins or fade-outs, the fade is trimmed to fit the selection.

Trimming Regions That Include Fades

You can trim regions that are adjacent to fade boundaries.

To trim a region on a fade boundary:

- With the Trim tool, click the region boundary and drag to trim the region. The fade remains constant and follows the new region boundary.
Trimming to a Selection Across Fades

You can trim regions to selections that include fades or crossfades.

To trim a region to a selection that includes fades, do one of the following:

- Make a selection in the track and choose Edit > Trim Region > To Selection. You can trim across multiple regions and fades. Affected fades are adjusted to the new region boundaries.

- Click with the Selector in the region and choose Edit > Trim Regions > Start to Insertion or End to Insertion. You can trim to region or fade boundary in the track.

Fade Boundaries and Shapes in Displayed Automation View

Fade boundaries and fade shapes are shown and can be edited in Automation views, allowing for more precise viewing and editing of automation data.

For more information on Automation and Automation views, see Chapter 27, "Automation.”
Chapter 19: Managing Regions

Managing the regions in a session lets you keep system and storage requirements to a minimum, and simplify archiving requirements. This chapter describes several tools available to manage files and regions in Pro Tools sessions.

For more information on file management see the DigiBase Guide.

Stripping Silence from Regions

The Strip Silence command analyzes audio selections—across multiple regions or multiple tracks—and removes (or extracts) any areas of silence, dividing the selection into smaller regions and removing the silent areas.

You can use Strip Silence to automatically divide a track into regions, which is useful if you want to quantize audio to musical values, or locate sound effects to SMPTE locations. It is also useful if you want to get rid of silent areas to prepare for compacting audio (see “Compacting an Audio File” on page 395).

The Strip Silence Window

The Strip Silence window contains the following controls that let you set the parameters by which silence will be defined when using the Strip Silence command. Adjusting these controls will cause rectangles to appear in the selection (see Figure 14 on page 392), indicating areas of silence that will be removed.

Strip Threshold Sets the amplitude threshold (from -48 dB to 0 dB) for Strip Silence. Audio falling below this threshold is considered silence and removed. Audio above the threshold is retained and defined as new regions.

Minimum Strip Duration Sets the minimum duration (from 0 to 10,000 ms) that the material below the threshold must last to be considered silence. Use this control to avoid countless small regions that may occur within a selection.

Region Start Pad Specifies a time value to be added to the beginning of each new region created with Strip Silence. This is useful for preserving musical material that falls below the threshold, such as the breath before a vocal phrase, or the finger slide before a guitar chord.

Region End Pad Specifies a time value to be appended to the end of each new region created with Strip Silence, thereby preserving the nuances in the decay of the material.
**Extract** Extracts audio and leaves the silent portions of the track (in other words, an “inverse” strip silence feature that is ideal for generating room tone or ambience to use elsewhere).

**Separate** Separates regions based on the boundaries detected by Strip Silence.

**Auto-Naming for Strip Silence**

The Rename button in the Strip Silence window opens the Rename Selected Regions dialog, which determines how regions are named with the Strip Silence command. The dialog remembers your previous settings, which can be cleared by clicking the Clear button.

![Rename Selected Regions dialog](image)

**Name** Specifies the base name for regions created with Strip Silence.

**Number** Specifies the number at which sequential auto-numbering starts.

**Zeros** Specifies the number of zeroes that occur before the appended auto numbers.

**Suffix** Specifies text appended to the end of the name, after the auto numbering.

For example, if you set these naming options to:
- Name = SFX
- Auto Number Start = 23
- Leading Zeros = 1
- Suffix = .Reel1

The names generated for regions created by Strip Silence would be:
- SFX023.Reel1
- SFX024.Reel1
- SFX025.Reel1
- SFX026.Reel1
- SFX027.Reel1
- SFX028.Reel1

**Using Strip Silence**

**To strip silence from an audio selection:**

1. Select one or more audio regions.
2. Choose Edit > Strip Silence.
3. To set the naming scheme for regions created with Strip Silence, click Rename to open the Renaming dialog. For details, see “Auto-Naming for Strip Silence” on page 392.
4. In the Strip Silence window, adjust the sliders for Strip Threshold and Minimum Strip Duration until the Strip Silence rectangles appear in the selection.

![Strip Silence rectangles](image)

For finer resolution on these sliders, press Control (Windows) or Command (Mac) while adjusting them.
5 To retain material before and after the new regions, adjust the sliders for Region Start Pad and Region End Pad.

6 Once the Strip Silence rectangles encompass the audio that you want to keep, press the Strip button.

The material defined as silence is removed from the selection and new regions are created, which also appear in the Region List.

The Strip Silence command is nondestructive and does not remove audio data from parent audio files. In addition to the Undo command, you can use the Heal Separation command to restore stripped material.

To extract audio from an audio selection using Strip Silence:

1 Make and Edit or Time selection.

2 Choose Edit > Strip Silence.

3 To set the naming scheme for regions created with Strip Silence, click Rename to open the Renaming dialog. For details, see “Auto-Naming for Strip Silence” on page 392.

4 In the Strip Silence window, adjust the sliders for Strip Threshold and Minimum Strip Duration until the Strip Silence rectangles appear in the selection.

5 Click the Extract button.

All audio above the designated threshold is deleted and the “silent” portions of the track are left.

To separate regions using Strip Silence:

1 Make an Edit or Time selection.

2 Choose Edit > Strip Silence.

3 To set the naming scheme for regions created with Strip Silence, click Rename to open the Renaming dialog. For details, see “Auto-Naming for Strip Silence” on page 392.

4 In the Strip Silence window, adjust the sliders for Strip Threshold and Minimum Strip Duration until the Strip Silence rectangles appear in the selection.

5 Click the Separate button.

New regions are created based on the boundaries detected by Strip Silence.
Inserting Silence

The Insert Silence command is a simple and convenient way to insert silence on audio, MIDI, and Instrument tracks. This command lets you make a selection on a track (or tracks) and insert precisely that amount of silence. In Shuffle mode, all data on the track is shuffled later in the track by an amount equal to the selection.

In Grid mode, the Insert Silence command works just like the Clear command.

**Shuffle Mode** When inserting silence on multiple tracks in Shuffle mode, the following conditions apply:

- If any track is displayed as audio or MIDI data, the selected duration of silence is inserted into the audio or MIDI data and all underlying automation data on all selected tracks. All subsequent regions are shuffled by the amount of silence inserted. On MIDI tracks, only notes that are selected from the beginning are affected, so if you have selected the tail of a note and you Insert Silence, the note will remain unchanged.
- If all selected tracks are displayed as automation data, press the Start key (Windows) or Control (Mac) while choosing the Insert Silence command to insert silence on all automation playlists for all selected tracks.

**Slip Mode** When inserting silence on multiple tracks in Slip mode, the following conditions apply:

- If any track is displayed as audio or MIDI data, the selected range is cleared of audio or MIDI data and all underlying automation data on all selected tracks.
- If all selected tracks are displayed as automation data, silence is inserted only into the automation type visible on each track.
- If all selected tracks are displayed as automation data, press the Start key (Windows) or Control (Mac) while choosing the Insert Silence command to insert silence on all automation playlists for all selected tracks.

**To insert silence into a track:**

1. Make a selection in a track or tracks. The length of the selection determines the duration of the silence inserted.
2. Choose Edit > Insert Silence.

For Shuffle mode, Pro Tools inserts the selected amount of silence. In the process, it splits the regions at the beginning of the insertion point, and moves the new regions later in the track by an amount equal to the length of the selection.
Consolidate Command

During the course of normal edit operations, a track may eventually contain many regions. However, once a track or track range (such as a verse or chorus) reaches a satisfactory state, you may want to consolidate its regions into a single region—thus making the material much more easy to work with.

When consolidating an audio track, a new audio file is written that encompasses the selection range, including any blank space.

⚠️ Consolidating an audio track does not consolidate underlying automation data. To create a single file with automation data applied to the audio, use Bounce to Disk (see “Bounce to Disk” on page 638).

To consolidate regions within a track:

1. Do one of the following:
   - Using the Time Grabber or Selector tool, select the regions you want to consolidate.
   - or –
   - To select all regions in a track, triple-click in its playlist with the Selector tool.

2. Choose Edit > Consolidate.

A new, single region is created that replaces the previously selected regions, including any blank space. If working with an audio track, a new audio file is written (with the Audio Suite Duplicate plug-in).

When consolidating audio regions with the Consolidate command, if the selection contains muted regions, the muted regions are treated as silence. Whether or not a track is muted, or contains Mute automation, does not affect the Consolidate command.

Compacting an Audio File

The Compact Selected command deletes unused portions of audio files to conserve disk space, and to prepare for cleaner hard drive back-ups. The Compact Selected command also deletes audio if there are no regions referencing the data.

Because it permanently deletes audio data, the Compact Selected command should be used only after you have completely finished your editing and are sure that you have no further use for the unused audio data.

The Compact Selected command can pad the regions of the compacted file by a user-selectable amount. You may want to do this because Pro Tools requires extra audio data before and after audio regions to create crossfades. So, if your regions have crossfades, or if you want to pad the regions for the sake of any future trimming, you should enter an appropriate amount of padding (in milliseconds) to allow for this.

⚠️ The Compact Selected command is destructive and cannot be undone. It permanently alters the original audio files. There is no way to recover data deleted with this command.

To compact an audio file:

1. From the Region List pop-up menu, choose Select > Unused. All regions that have not been placed in a track in the current session are highlighted in the Region List.

2. To remove all of these unused audio regions, choose Clear Selected from the Region List pop-up menu. When the dialog appears, choose Remove.

3. In the Region List, select the region or regions you want to compact.
4 From the Region List pop-up menu, choose Compact Selected.

5 Enter the amount of padding in milliseconds that you want to leave around each region in the file.

6 Click Compact to compact the file or Cancel to cancel the command.

Once the Compact operation has been completed, the session is automatically saved.

---

**Naming and Displaying Regions**

A typical session can become quite busy with many tracks and dozens of regions. There are a number of things you can do, however, to keep track of and manage a session’s regions, which include:

- Renaming existing regions
- Specifying how auto-created regions are named
- Hiding auto-created regions
- Removing unused regions

**Renaming Regions**

In the course of a session you can rename regions to give them more descriptive names, or merely to shorten or simplify an existing name. When renaming a region that was auto-created from an edit, the region becomes a user-defined region and is displayed in the Region List when auto-created regions are hidden.

Perhaps the easiest way to rename a region, if it resides in a track, is to double-click it with one of the Grabber tools. However, if the region does not yet reside in a track, or if you want to rename several regions, use the Rename command in the Region List.

You can also rename a region in a track using the Rename command in the Region List pop-up menu.

**To rename one or more regions:**

1. If you will be renaming an auto-created region, be sure to choose Show > Auto-Created in the Region List.

2. Select one or more regions to be renamed in the Region List.

   If the Editing preference for “Region List Selection Follows Edit Selection” is enabled, you can highlight a region in the Region List by selecting it in a track.

3. Choose Rename from the Region List pop-up menu.

4. When prompted, enter a new name for the region. If a whole-file audio region was selected, specify whether to rename just the region, or both the region and the disk file.

   Rename Selected dialog

5. Click OK to rename the region. If renaming multiple regions, you are prompted, successively, to rename each region.
Auto-Naming Options

You can specify the auto-naming options for a region when new regions are created from it in the course of editing.

Auto-naming of regions does not affect the names of parent audio files. Instead, it stores pointers to the regions within the parent source file.

To set auto-naming options for a region:

1. Select a region in the Region List.
2. Choose Auto Rename from the Region List pop-up menu.
3. In the Rename Regions dialog, enter the text to be used when naming regions created from the selected region.

<table>
<thead>
<tr>
<th>Rename Regions Selected dialog</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Name</strong></td>
</tr>
<tr>
<td><strong>Number</strong></td>
</tr>
<tr>
<td><strong>Zeros</strong></td>
</tr>
<tr>
<td><strong>Suffix</strong></td>
</tr>
</tbody>
</table>

4. When you are finished, click OK to accept the new naming options.

Hiding and Removing Unwanted Regions

In the course of editing a session, the Region List can fill up quickly with regions—ones you have created purposely and those that are automatically created by cutting, pasting, and separating other regions, or importing REX, ACID, or Region Group files. Pro Tools allows you to hide or remove regions in your session so you do not have to scroll through an unnecessarily long Region List.

Hiding Auto-Created Regions

You can hide regions that were automatically created during the course of editing.

To hide auto-created regions:

- In the Region List, deselect Show > Auto-Created. With this option deselected, only user-defined regions appear in the Region List.

User-defined regions include:
- Whole-file regions
- Regions created during recording
- Imported regions
- Renamed regions
- Regions created as a result of AudioSuite processing
- New regions created with the Region > Capture command or the Edit > Separate Region commands
- Regions created by trimming whole-file audio regions

When auto-created regions are hidden, Pro Tools warns you if the number of auto-created regions exceeds a certain threshold, and gives you the option of deleting them. If you choose to delete them, all auto-created regions are deleted at the same time.
To ensure that you keep a particular auto-created region, turn it into a user-created region by renaming it. For details, see “Renaming Regions” on page 396.

**Removing Unwanted Regions**
In the Region List, you can select unwanted regions and then use the Clear command to remove them from the session, whole-file regions can also be removed permanently from your hard drive.

⚠️ The Clear command cannot be undone.

**To find and remove unused regions in a session:**
1. Do one of the following:
   - For MIDI regions, from the Region List pop-up menu, choose Select > Unused.
   - or –
   - For audio regions, from the Region List, choose Select, then choose one of the following:
     - Unused
     - Unused Except Whole Files
     - Offline
2. After all unused regions are selected, choose Clear from the Region List pop-up menu.
3. Do one of the following:
   - Click Remove to remove the unused regions from the session.
   - or –
   - If clearing a whole-file audio region and you want to permanently remove the audio file from your hard drive, click Delete.

![Clear Selected dialog (audio regions)](image)

When deleting audio files for multiple regions, Pro Tools presents a warning dialog for each audio file.

**To bypass repeated warning dialogs:**
- Alt-click (Windows) or Option-click (Mac) the Delete button in the Clear dialog. This permanently deletes each successive audio file from your hard drive (for each of the unused regions) without any further warnings.

Use this “power delete mode” with caution, since deletion of these files cannot be undone.
Chapter 20: Conductor Tracks and Memory Locations

In Pro Tools, tempo and meter changes reside in Conductor tracks. Tempo and meter events affect the timing of tick-based tracks, and also provide the tempo and meter map for the Bar|Beat grid. You can edit tempo events in the Tempo ruler or Tempo Editor, and meter events in the Meter ruler. Memory locations provide a powerful way to navigate your session while editing and arranging.

**Song Start Marker**

The Song Start Marker defines the initial tempo for Bar|Beat-based material. New sessions open with a default tempo of 120 BPM.

To move the Song Start Marker by dragging:

- In the Tempo ruler, drag the Song Start Marker left or right.

**Dragging the Song Start Marker**

If the Edit mode is set to Grid, the Song Start Marker moves in increments of the current Grid value.

To move the Song Start Marker only, without moving the tick-based data, press Start+Shift (Windows) or Control+Shift (Mac) while dragging. When dragging the Song Start Marker only, dragging is constrained to whole bar increments only.

To edit the initial tempo in the Song Start Marker:

1. In the Tempo ruler, double-click the Song Start Marker.
2. In the Change Tempo dialog, enter a new BPM value.
3. Click OK.

The position of the Song Start Marker can be changed in the Time Operations window. For more information, see “Move Song Start” on page 427.
When a new session is created, the Song Start Marker has no associated meter event. A meter event is added automatically at the Song Start if you add another meter event anywhere else on the Meter ruler.

**Tempo**

The Tempo ruler lets you edit tempo events one at a time. You can edit tempo visually in the Tempo Editor, or make precise changes in tempo in the Tempo Operations window.

- To set the default session tempo, see “Setting the Default Meter and Tempo” on page 194.

- You can use Beat Detective to generate Bar|Beat markers (tempo map). For more information, see “Generating Bar|Beat Markers with Beat Detective” on page 447.

**Tempo Events**

Tempo events can be assigned to the Song Start Marker to replace the default tempo (of 120 BPM), and they can be inserted anywhere else within the session.

- Tempo cannot be modified when you are in Manual Tempo mode.

**To display the Tempo ruler:**

- Select View > Rulers > Tempo.

- When in Manual Tempo mode, the Tempo track is ignored and the session plays at the tempo defined in the Transport window. For details, see “Using Manual Tempo Mode” on page 196.

**Current Tempo**

As tempo events are encountered during playback, the session’s current tempo is displayed in the Transport window.

**Inserting Tempo Events**

**To insert a tempo event:**

1. Click in the Tempo ruler where you want to insert the tempo event.

2. Click the Add Tempo Change button at the left of the Tempo ruler.

3. In the Tempo Change window, enter the Location and BPM value for the tempo change.

**Tempo Change dialog**

Select the Snap To Bar option to place the inserted tempo event cleanly on the first beat of the nearest measure.
4 To base the BPM value on something other than the default quarter note, select a different note value.

5 Click Ok. The new tempo event is inserted and appears in the Tempo ruler.

To base the BPM value on something other than the default quarter note, select a different note value.

To delete a tempo event:

- While pressing Alt (Windows) or Option (Mac), move the cursor over the tempo event (where the cursor changes to a Grabber with a “–”) and click to remove it.

To copy and paste several tempo events:

1 With the Selector tool, click and drag in the Tempo ruler to select the range of measures that includes the tempo events.

2 Choose Edit > Copy.

3 Click in the Tempo ruler at the point where you want to paste the tempo events.

4 Choose Edit > Paste. The contents of the Clipboard are pasted from the insertion point, replacing any existing tempo events.

To extend an Edit selection in a track to the Tempo ruler:

1 With the Selector or Time Grabber tool, select a time range.

2 Shift-click in the Tempo ruler.

To select all tempo events:

- Double-click with the Selector tool in the Tempo ruler.
To clear a range of selected tempo events:

1. If you want to constrain the selection to the current Grid value, set the Edit mode to Grid.
2. Drag with the Selector tool in the Tempo ruler to select the tempo events you want to remove.
3. Choose Edit > Clear to delete the selected tempo events.

**Tap Tempo**

You can manually set the tempo for a Pro Tools session by tapping on your computer keyboard. You can also use a connected MIDI keyboard to tap tempo.

**To set the Manual Tempo by tapping on a computer keyboard:**

1. To view the MIDI controls in the Transport window, select View > Transport > MIDI Controls.
2. In the Transport window, click the Tempo Ruler Enable (Conductor) button so it becomes unhighlighted. Pro Tools switches to Manual Tempo mode. In this mode, any tempo events in the Tempo track are ignored.
3. Click in the Tempo field so it becomes highlighted and tap the “T” key on your computer keyboard repeatedly at the new tempo.

You can apply the new tempo to the entire session by changing the default tempo of the Song Start Marker. See “Song Start Marker” on page 399.

**To set the Manual Tempo by tapping on an external MIDI keyboard:**

1. To view the MIDI controls in the Transport window, select View > Transport > MIDI Controls.
2. Choose Setup > Preferences and click the MIDI tab.
3. Select Use MIDI To Tap Tempo
4. In the Transport window, click the Tempo Ruler Enable (Conductor) button so it becomes unhighlighted. Pro Tools switches to Manual Tempo mode. In this mode, any tempo events in the Tempo track are ignored.
5. Click in the Tempo field so it becomes highlighted and tap in the tempo by playing a note repeatedly at the new tempo on your MIDI keyboard controller.

To compute the new tempo, Pro Tools averages the last eight (or fewer) taps to determine the correct tempo. The computed BPM value appears in the Transport’s Tempo field.
**Tempo Changes and Automation Drift**

When a track is sample-based, the track’s automation playlist is unaffected by changes in tempo. This means that automation is always aligned with the audio on the track with sample accuracy.

When a track is tick-based, however, the automation breakpoints change to match the changes in tempo.

Since the length of each audio region in a track is unaffected by changes in tempo, existing automation data is out of sync with the audio after a tempo change is made to a tick-based audio track.

**Minimizing Automation Drift**

In general, automation drift is more pronounced with larger audio regions. By creating many small audio regions, the effects of automation drift can be minimized, because the start points of each subsequent region changes as the tempo changes. When tempo is decreased, automation expands. When tempo is increased, automation contracts.

To break an audio region into smaller regions, use Beat Detective. For more information, see Chapter 21, “Beat Detective.”

You can also separate regions at transients or based on the current grid resolution. For more information, see “Separate Region Commands” on page 328.
Graphic Tempo Editor

The Tempo Editor, a resizeable window beneath the Tempo ruler in the Edit Window, lets you view and edit tempo information graphically.

Tempo Editor

The Tempo Editor is an expansion of the Tempo ruler, opening in the rulers section of the Edit Window.

To display the Tempo Editor, do one of the following:

- Select View > Rulers > Tempo, then View > Rulers > Tempo > Tempo Editor.
- Click the Tempo Editor expand/collapse triangle.

Editing Tempo Events in the Tempo Editor

Tempo events in the Tempo Editor can be edited with any of the following methods:

- Individual tempo events can be dragged with any of the Grabber tools to adjust their location or value.
- A group of selected tempos can be scaled up or down with the Trim tool.
- New tempo events can be drawn in with the Pencil tool to replace existing ones.
- Tempo events can be copied and pasted, nudged, and shifted.

Drawing Tempo Events

Tempo events can be drawn in the Tempo Editor using the Pencil tool.

These tool shapes are not functional in the Tempo Editor.
Freehand The Freehand shape draws freely according to the movement of the mouse. The shape is reproduced as a series of steps according to the Tempo Edit Density setting. (For more information, see “Selecting Tempo Edit Density” on page 406.)

Line The Line shape draws in a straight line from click to release. Tempo values change in steps according to the Tempo Edit Density and Resolution. (For more information, see “Selecting Tempo Edit Density” on page 406.)

Parabolic The Parabolic shape draws the best possible curve to fit your freehand drawing. The shape is reproduced as a series of steps according to the Tempo Edit Density setting.

S-Curve The S-Curve shape draws a best possible fit of an S-Curve to your freehand drawing. The shape is reproduced as a series of steps according to the Tempo Edit Density setting.

The Triangle, Square, and Random Pencil tool shapes do not apply to tempo events.

Selecting Tempo Resolution (BPM Rate)
The Tempo Editor lets you specify the note value that the BPM rate is based on for all tempo events created when you draw a tempo curve with the Pencil tool. This note value is the Tempo Resolution.

To select the Tempo Resolution (BPM rate) for Pencil tool edits, do one of the following:

- Click the Tempo Resolution selector and select a note value from the pop-up menu. Tempo events created by drawing with the Pencil tool will have their BPM set to the note value you choose.
- Choose Follow Metronome Click. Tempo events created by drawing with the Pencil tool will have their BPM set to mirror the click values set by meter events in the Meter ruler.

A tempo curve can have different BPM values if there are meter click changes within the selected range.

Because it can be unnecessarily complicated to set meter events separately for each Tempo event, Digidesign recommends choosing Follow Metronome Click in most cases.
Selecting Tempo Edit Density

The Tempo Editor lets you specify the density of tempo events created in the Tempo ruler when you draw a tempo curve with the Pencil tool.

To select the Tempo Edit Density for Pencil tool edits:

- Click the Tempo Edit Density selector and select a time value from the pop-up menu. Tempo events created by drawing with the Pencil tool will be placed in the Tempo ruler at the density that you choose.

![Tempo Edit Density selector and pop-up menu]

Pressing Start (Windows) or Control (Mac) before drawing a pencil line conforms already created tempo events to the drawn line rather than creating new tempo events.

Curve Adjustment Mode

Immediately after you draw new tempos using the Pencil tool, a tempo curve appears in blue, outlining the newly created tempo graph. Blue adjustment handles on the curve let you adjust the shape and size of the new tempo graph.

All the new tempo events under the curve will change as you move the Tempo Curve Adjustment Handles. To adjust the curve shape without the track data adjusting immediately, press Start (Windows) or Control (Mac) while adjusting the curve. Tempo events will change to fit the new curve when you release the mouse button.

The blue adjustment handles are only active until a new tool is selected or a new command is executed.
Grabbing Tempo Events

The Grabber tools let you create new tempo settings by dragging tempo events in the Tempo Editor. To remove a tempo event, Alt-click (Windows) or Option-click (Mac) the tempo event with any of the Grabber tools.

Drag a tempo event to the left or right to adjust the location of the tempo change.

Selecting Tempo Events

You can easily select a single tempo event, or an entire tempo curve within the Tempo Editor.

To Select a tempo event in the Tempo Editor:

Using the Selector tool or any Grabber tool, double-click on the horizontal tempo line.

To Select a tempo curve in the Tempo Editor:

Using the Selector tool or any Grabber tool, triple-click on a horizontal tempo line in the curve that you wish to select.

Extending Tempo Selections

You can extend Tempo selections to the next or the previous tempo event.

To extend a tempo selection:

1. Select a portion of a region, or click anywhere in the region.

2. Do one of the following:
   - Press Shift+Tab to extend the selection to the next tempo event.
   - Press Shift+Control+Tab (Windows) or Shift+Option+Tab (Mac) to extend the selection to the previous tempo event.
Using the Trim Tool

The Trim tool lets you scale all the tempo events of the session, or within a time selection. The Trim tool also lets you stretch a region of tempo events to cover a longer or shorter area in the timeline.

To scale all the session’s tempo events with the Trim tool:

1. Open the Tempo Editor.
2. Select the Trim tool.
3. Click above the tempo events and drag up or down. Dragging up increases the tempo values; dragging down decreases them.

To change the rate of tempo change with the Trim tool:

1. Open the Tempo Editor.
2. Using the Selector tool, select the area you wish to edit.
3. Select the Trim tool.
4. Click either the start or end handle for the selected range, and drag up or down.

To stretch or shrink the tempo change range with the Trim tool:

1. Open the Tempo Editor.
2. Using the Selector tool, select the area you wish to edit.
3. Select the Trim tool.
4. Click at the start or end of the selection, and drag horizontally. Tempo events will maintain their relative spacing to each other but will be spaced over a larger or smaller area.
Moving, Cutting, Pasting and Nudging in the Tempo Editor

To move a selected group of tempo events in the Tempo Editor:
1. Open the Tempo Editor.
2. Using the Selector tool, select the area you wish to move.
3. Click on any selected tempo event with any Grabber tool, and drag horizontally to move the tempo events to a new location.

   Press Alt (Windows) or Option (Mac) while dragging to move a copy of the tempo events.

To copy and Paste tempo events in the Tempo Editor:
1. Open the Tempo Editor.
2. Using the Selector tool, select the area you wish to copy.
3. Choose Edit > Copy.
4. Click in the Tempo Editor at the point where you want to paste the tempo events.
5. Choose Edit > Paste. Your copied selection is pasted from the insertion point, replacing any existing tempo events.

To nudge a selection in the Tempo Editor:
1. Open the Tempo Editor.
2. Using the Selector tool, select the area you wish to nudge.
3. Do one of the following:
   - On the numeric keypad, press Plus (+) to move the selected tempo events forward by the Nudge value.
   - or –
   - Press Minus (–) to move the selection back by the Nudge value.

Changing the Linearity Display Mode

You can choose to view the Edit Window in either a Linear Tick (Bars|Beats) scale or a Linear Sample (absolute) Time Scale. MIDI and Instrument tracks, audio tracks, and Tempo curves can appear and function very differently depending on the timebase display settings.

The Linearity Display Mode pop-up menu determines whether the Tempo Editor displays tempo events in an Absolute timebase or Bars|Beats.

When set to Linear Sample Display, the display of tempo events is sample-based and their bar and beat locations can shift after the tempo curve is drawn.

When set to Linear Tick Display, the display of tempo events is tick-based and tempo event Bar|Beat locations remain constant after the tempo curve is drawn—though their relation to audio is scaled, resulting in new sample locations.

⚠️ Drawing tempo events using the Linear Sample Display can cause Bar|Beat based material to move in non-intuitive ways. Digidesign recommends that you use Linear Tick Display when you draw tempo changes.
To change the timebase display:

- Click the Linearity Display Mode selector and select a timebase from pop-up menu.

Tempo Edit Density and Linearity Display Mode

When both the Tempo Edit Density setting (in the Tempo Editor) and the Linearity Display Mode setting are set to either a Bars|Beats Time Scale or to an absolute Time Scale, Tempo edits will appear evenly spaced. When the Tempo Edit Density setting and the Linearity Display Mode setting are set so that one is set to an absolute Time Scale and the other is set to a Bars|Beats Time Scale, the number of Tempo edits will appear to increase or decrease over time.

Tempo Operations Window

The Tempo Operations window lets you define tempo events over a range of time (or measures). The time range is specified in the time format chosen for your Main Time Scale. In addition, the Tempo Operations window lets you:
- Fit a specific number of Bars|Beats into a precise time range.
- Create tempos that speed up or slow down, both linearly and over various curves.
- Scale and stretch existing tempos.

The Tempo Operations window is not available in Manual Tempo mode.

The Tempo Operations window has six pages, one for each type of tempo operation.

Constant Lets you create a constant tempo over a selected range of time.

Linear Lets you create tempos that change evenly over a selected range of time.

Parabolic Lets you create tempos that accelerate or decelerate following a tempo curve that changes the tempo more rapidly or less rapidly over the selection time.

S-Curve Lets you create tempos that accelerate or decelerate following a tempo curve with a definable breakpoint that determines mid-curve times and tempo values.

Scale Lets you scale tempos within the selection by a percentage amount.

Stretch Lets you select a region of tempo events and apply them to a larger or smaller selection area.

To open a specific Tempo Operations window page:

- Choose Event > Tempo, followed by one of the Tempo Operations page commands (such as Constant).

If the Tempo Operations window is already open, you can select any of the pages from the pop-up menu at the top of the window.

To open the last active Tempo Operations window page:

- Choose Event > Tempo > Operations Window.

Press Alt+2 (Windows) or Option+2 (Mac) on the number keypad to open the Tempo Operations window and display the last active Tempo Operations page.
To define tempo events over a range of time:

1. Make a selection in the Timebase or in a track.
2. Choose Event > Tempo > Operations Window.
3. Choose a Tempo Operation page from the pop-up menu at the top of the Tempo Operation window.
4. Change the settings for the page you have chosen, as necessary.
5. Do one of the following:
   - Click Apply.
   - or –
   - Press Enter (Windows) or Return (Mac) to automatically apply the values and close the window.

**Constant**

The Constant page lets you create a constant tempo over a selected range of time.

**Calculate (Advanced Option)** Lets you choose to calculate either the tempo, or the selection end time.

**Selection Start and End** Specifies the start and end point for the tempo change in Bars|Beats. When an Edit selection is made, the Start and End fields will display the selection boundaries.

**End Time (Advanced Option)** Displays the selection end time. When the Main Time Scale is set to Bars|Beats, the end time is displayed in the Sub Time Scale. When the Main Time Scale is set to any absolute timebase, the end time is calculated and displayed in Bars|Beats. Changing the end time value causes the tempo to change.

**Tempo** Specifies the tempo, in beats per minute (BPM), to apply to the selected range.

**Resolution (Advanced Option)** Lets you select the BPM note value for your tempo setting.

**Density (Advanced Option)** Lets you specify the density of the tempo change events written to the Tempo ruler.

**Preserve Tempo after Selection** If selected, the previous tempo setting that was in effect at the selection end point is preserved after the selection. If unselected, the last tempo event created by the tempo operation continues to the end of the session, or until the next tempo event beyond the selected range.

**Constant page (Advanced Option)**

**Advanced** When the Advanced checkbox is selected, the selection range changes to the Main Time Scale format, and additional and modified options become available.
Linear

The Linear page lets you create tempos that change evenly over a selected range of time.

Advanced When the Advanced checkbox is selected, the selection range changes to the Main Time Scale format, and additional and modified options become available.

Calculate (Advanced Option) Lets you choose to calculate either the selection end time, the start tempo, or the end tempo.

Selection Start and End Displays the start and end points for the tempo change in the currently selected Main timebase. When an Edit selection is made, the Start and End fields will display the selection boundaries. Changing start or end values changes the selection range.

End Time (Advanced Option) Displays the absolute time for the selection end. When the Main Time Scale is set to Bars|Beats, the end time is displayed in the Sub Time Scale. When the Main Time Scale is set to any absolute timebase, the end time is calculated and displayed in Bars|Beats. Changing the end time value causes the tempo to change.

Tempo Start and End Displays the tempo, in beats per minute (BPM), for the start and end points of the selected range. Changing the tempo causes the end time value to change.

Resolution (Advanced Option) Lets you select the BPM note value for your tempo setting.

Density (Advanced Option) Lets you specify the density of the tempo change events written to the Tempo ruler.

Preserve Tempo after Selection If selected, the previous tempo setting that was in effect at the selection end point is preserved after the selection. If unselected, the last tempo event created by the tempo operation continues to the end of the session, or until the next tempo event beyond the selected range.

Linear page (Advanced Option)

Selecting “Follow Metronome Click” will set the tempo BPM note value to mirror the click value set in the meter markers.
Chapter 20: Conductor Tracks and Memory Locations

**Parabolic**

The Parabolic page lets you create tempos that accelerate or decelerate by following a tempo curve, which changes the tempo more rapidly or less rapidly over the selection time.

**Advanced** When the Advanced checkbox is selected, the selection range changes to the Main Time Scale format, and additional and modified options become available.

**Calculate (Advanced Option)** Lets you choose to calculate the selection end time, the start tempo, the end tempo, or the curvature of the tempo change.

**Selection Start and End** Displays the start and end points for the tempo change in the currently selected Main timebase. When an Edit selection is made, the Start and End fields will display the selection boundaries. Changing start or end values changes the selection range.

**End Time (Advanced Option)** Displays the absolute time for the selection end. When the Main Time Scale is set to Bars|Beats, the end time is displayed in the Sub Time Scale. When the Main Time Scale is set to any absolute timebase, the end time is calculated and displayed in Bars|Beats. Changing the end time value causes the tempo to change.

**Tempo Start and End** Displays the tempo, in beats per minute (BPM), for the start and end points of the selected range. Changing the tempo causes the end time value to change.

**Curvature** Specifies and displays a numerical and graphic representation of the tempo curve. Negative numbers indicate a more rapid tempo change at the beginning of the time range, and positive numbers indicate a more rapid tempo change at the end of the time range. This value can be set with the Curvature slider.

**Resolution (Advanced Option)** Lets you select the BPM note value for your tempo setting.

**Preserve Tempo after Selection** If selected, the previous tempo setting that was in effect at the selection end point is preserved after the selection. If unselected, the last tempo event created by the tempo operation continues to the end of the session, or until the next tempo event beyond the selected range.

*Selecting “Follow Metronome Click” will set the tempo BPM note value to mirror the click value set in the meter markers.*

**Density (Advanced Option)** Lets you specify the density of the tempo change events written to the Tempo ruler.
S-Curve

The S-Curve page lets you create tempos that accelerate or decelerate by following a tempo curve with a definable breakpoint that determines mid-curve times and tempo values.

**Advanced** When the Advanced checkbox is selected, the selection range changes to the Main Time Scale format, and additional and modified options become available.

**Calculate (Advanced Option)** Lets you choose to calculate either the selection end time, the start tempo, the end tempo or the curvature of the tempo change.

**Selection Start and End** Displays the start and end points for the tempo change in the currently selected Main timebase. When an Edit selection is made, the Start and End fields will display the selection boundaries. Changing start or end values changes the selection range.

**Start and End Time (Advanced Option)** Displays the absolute time for the selection end. When the Main Time Scale is set to Bars|Beats, the end time is displayed in the Sub Time Scale. When the Main Time Scale is set to any absolute time-base, the end time is calculated and displayed in Bars|Beats.

**Tempo Start and End** Displays the tempo, in beats per minute (BPM), for the start and end points of the selected range. Changing the tempo causes the end time value to change.

**Curvature** Specifies and displays a numerical and graphic representation of the tempo curve. Negative numbers indicate a more rapid tempo change at the start and end of the time range, with a low rate of change around the midpoint. Positive numbers indicate a low rate of change near the start and end of the selected range, with rapid tempo change around the midpoint. This value can be set with the Curvature slider.

**Mid Point** Specifies the Main Time Scale location for the curve mid point. This value can be set with the Mid Point slider.

**Mid Tempo** Specifies the tempo at the mid point. This value can be set with the Mid Tempo slider.

**Resolution (Advanced Option)** Lets you select the BPM note value for your tempo setting.

💡 Select “Follow Metronome Click” will set the tempo BPM note value to mirror the click value set in the meter markers.

**Density (Advanced Option)** Lets you specify the density of the tempo change events written to the Tempo ruler.
Preserve Tempo after Selection  If selected, the previous tempo setting that was in effect at the selection end point is preserved after the selection. If unselected, the last tempo event created by the tempo operation continues to the end of the session, or until the next tempo event beyond the selected range.

Scale  The Scale page lets you scale tempos within the selection by a percentage amount.

Advanced  When the Advanced checkbox is selected, the selection range changes to the Main Time Scale format, and additional and modified options become available.

Calculate (Advanced Option)  In combination with settings chosen in the Scale pop-up menu, the Calculate pop-up menu lets you choose to calculate the selection end time, the average tempo, the start tempo, or the end tempo.

Scale (Advanced Option)  In combination with settings chosen in the Calculate pop-up menu, the Scale pop-up menu lets you choose to scale all tempos, the start tempo, or the end tempo.

Scaling all tempos scales each tempo in the selected range equally. Scaling the start tempo scales the tempos unevenly, scaling the first tempo event the most, scaling each consecutive tempo event less until the end tempo which is not scaled. Scaling the end tempo scales the tempos unevenly, scaling the last tempo the most, scaling each previous tempo event less until the start tempo which is not scaled.

Selection Start and End  Displays the start and end points for the tempo operation in the currently selected Main timebase. When an Edit selection is made, the Start and End fields will display the selection boundaries. Changing start or end values changes the selection range.

Start and End Time  Displays the absolute time for the selection start and end points. When the Main Time Scale is set to Bars|Beats, times are displayed in the Sub Time Scale. When the Main Time Scale is set to any absolute timebase, times are calculated and displayed in Bars|Beats.

Average Tempo  Displays the Average Tempo, in beats per minute (BPM), across the selected range. Changing the Average Tempo changes the Scale percentage.
Scale  Displays the percentage by which the tempo is scaled, in beats per minute (BPM), across the selected range. Changing Scale changes Average Tempo.

Preserve Tempo after Selection  If selected, the previous tempo setting that was in effect at the selection end point is preserved after the selection. If unselected, the last tempo event created by the tempo operation continues to the end of the session, or until the next tempo event beyond the selected range.

Stretch

The Stretch page lets you select a region of tempo events and apply them to a larger or smaller selection area.

Stretch To End  Specifies a new end point for the region to which you want to apply the selected tempo events. Changing the end point causes the Stretch percentage to change.

Stretch To Start (Advanced Option)  Specifies a new start point for the region to which you want to apply the selected tempo events. Changing the end point causes the Stretch percentage to change.

Stretch  Specifies the percentage of time for the selected tempo events to cover.

Preserve Tempo after Selection  If selected, the previous tempo setting that was in effect at the selection end point is preserved after the selection. If unselected, the last tempo event created by the tempo operation continues to the end of the session, or until the next tempo event beyond the selected range.

Identify Beat Command

The Identify Beat command lets you establish a tempo/meter map for audio that was recorded without a click, or for imported audio with unknown tempos.

The Identify Beat command analyzes a selection range (usually with a distinct number of beats or measures) and calculates its tempo based on the specified meter. In doing this, Bar|Beat Markers for the calculated tempo are inserted and appear in the Tempo ruler at the beginning and end of the selection; in addition, meter events are inserted into the Meter ruler.

Use Beat Detective to generate Bar|Beat Markers within a selection that includes rhythmic changes on beats or sub-beats. For more information, see Chapter 21, “Beat Detective.”
**Bar|Beat Markers**

Bar|Beat Markers look similar to tempo events, but instead have small blue triangles to indicate their location.

**Choosing Bar|Beat Markers or Tempo Events**

Because tempo events are tick-based, and Bar|Beat Markers are sample-based, they cannot be mixed. If a session contains tempo events and you attempt to insert Bar|Beat Markers, existing tempo events are converted to Bar|Beat Markers (and vice versa).

Tempo events can also be manually converted to Bar|Beat Markers and vice versa.

**To choose to use either tempo events or Bar|Beat Markers:**

1. Press Control (Windows) or Command (Mac) and click the Add Tempo Change button.
2. Choose either Tempo Events or Bar|Beat Markers from the pop-up menu.

**Identifying Beats**

To add Bar|Beat Markers for a one-bar drum loop:

1. Place a one-bar drum loop at the beginning of an audio track.
2. Select View > Rulers > Samples. This ensures that the selected audio material will be sample-accurate.
3. Select the audio region with the Time Grabber tool and choose Event > Identify Beat.
4. In the Bar|Beat Markers dialog, specify the start and end locations for the inserted Bar|Beat Markers. Since this example deals with a one-bar loop, enter 1|1|000 and 2|1|000.

When converting between Tempo events and Bar|Beat Markers, some amount of sample rounding may occur.
6 Click OK to automatically calculate the new tempo and insert the necessary Bar|Beat Markers and meter events. Any existing tempo and meter events residing within the selection are deleted.

Once the tempo has been determined for the audio, you can duplicate the original audio region with the Repeat command.

When working with a selection, the Identify Beat command only calculates a single tempo for the selected range. If the tempo varies from measure to measure, or beat to beat, you'll need to use the Identify Beat command for each tempo variance (making sure to accurately define a precise selection range or beat location for the tempo change).

To accurately define tempos for a range of audio with the Identify Beat command, make certain that the initial selection represents an accurate length of beats or measures. You may want to first loop the selection on playback (see “Looping Playback” on page 321) to see if it plays cleanly without skipping. To avoid drift, and remain sample-accurate, select the audio material with the Time Scale set to Samples rather than Bars|Beats.

When identifying beats, select as large an area as possible. For example, if you have a four bar long audio file you want to identify, select the entire four bars instead of just one bar, in order to minimize rounding errors.

Dragging Bar|Beat Markers

Bar|Beat Markers can be dragged to new locations so they can align with audio regions that have been moved, or so that they can align to a slightly different point within an audio region. This results in neighboring MIDI data being adjusted to align with the new tempo map.

When dragging a tempo event:

- The tempo event is placed at a new bar and beat location. The sample and SMPTE locations for the event are updated as well.
- The BPM value for the dragged tempo event remains constant, as do any other tempo events in the session.
- Neighboring MIDI events and audio regions on tick-based tracks, along with the ruler, shrink or expand as necessary to adjust for the new tempo location.
When dragging a Bar|Beat Marker:

- Its BPM value is recalculated along with the Bar|Beat Marker to its immediate left. Bar|Beat Markers to the right of the dragged marker remain unchanged.
- Its bar and beat location is dragged with the Bar|Beat Marker. If the Bar|Beat Marker was originally placed at 3|1|000, it remains there (unless it is edited).
- Its sample and SMPTE locations change, as calculated for by the new tempo for the Bar|Beat Marker.
- Neighboring MIDI events, along with the Bars:Beats ruler, shrink or expand as necessary to adjust for the new tempo.

Editing Bar|Beat Markers

A Bar|Beat Marker can be edited to redefine its bar and beat location, which also redefines the start or end point of the range being analyzed for tempo. This is different from dragging a Bar|Beat Marker.

To edit a Bar|Beat Marker:

1. In the Tempo ruler, double-click the Bar|Beat Marker.
2. In the Edit Bar|Beat dialog, enter a new Location for the Bar|Beat Marker.
3. Enter a new Time Signature if desired.
4. Click OK.

To delete a Bar|Beat Marker:

While pressing Alt (Windows) or Option (Mac), move the cursor over the Bar|Beat Marker (where the cursor changes to the Grabber with a “−”) and click to remove it.

Inserting Bar|Beat Markers One at a Time

Sample-Based Material with Varying Tempos

You can insert Bar|Beat Markers one at a time by setting an Edit insertion point (instead of making a selection) before using the Identify Beat command. The ability to identify each beat, one at a time, is especially useful when working with sample-based material with varying tempos.

For instance, if you have a measure that accelerates slightly, you could insert a Bar|Beat Marker on each beat (see Figure 15) so the tempo is accurately reflected.

After the Bar|Beat Markers are inserted, further adjustments in the tempo map are possible by dragging each of the Markers, as necessary, to align with the associated beat within the audio.
**Meter Events**

You can change meter in the Meter ruler, or make precise meter changes in the Time Operations window.

Meter events can be inserted at the beginning of a session to replace the default meter (of 4/4), and they can be inserted anywhere within the session for additional meter changes.

**To display the Meter ruler:**

- Select View > Rulers > Meter.

**Current Meter**

As meter events are encountered during playback, the session’s current meter is displayed in the Transport window.

**Inserting Meter Events**

**To insert a meter event:**

1. Do one of the following:
   - Choose Event > Time > Change Meter.
   - Click the Add Meter Change button at the right of the Meter ruler.
   - While pressing the Start key (Windows) or Control (Mac), move the cursor into the Meter ruler (where the cursor changes to the Grabber with a “+”) and click at the location where you want to insert the event.

2. In the Meter Change window, do the following:
   - Enter the Location and Meter for the meter change.
   - If you want the inserted meter event to fall cleanly on the first beat of the nearest measure, select the Snap To Bar option.
3 Select a note value for the number of clicks to sound in each measure. For a dotted-note click value, select the dot (.) option.

For some meters, it may be desirable to use a dotted value for the click. For instance, if using a meter of 6/8, a dotted quarter note click (yielding two clicks per measure) is generally more suitable than a straight eighth note click (six clicks per measure).

4 Click Apply to insert the new meter event. The new meter event is inserted and appears in the Meter ruler.

Inserted meter event

Each meter event has a small yellow triangle next to it that indicates its location. These triangles can be selected for copying and pasting, and they can be double-clicked to edit the meter event.

Editing Meter Events

Existing meter events can be edited, deleted, and copied and pasted.

To edit a meter event:

1 In the Meter ruler, double-click the meter event.

2 In the Meter Change dialog, enter a new Location or Meter for the event.

3 Click OK.

To delete a meter event:

■ While pressing Alt (Windows) or Option (Mac), move the cursor over the meter event (where the cursor changes to the Grabber with a “–”) and click to remove it.

To copy and paste several meter events:

1 If you want to constrain the selection to the current Grid value, set the Edit mode to Grid.

2 Drag in the Meter ruler to select the range that includes the meter events.

To extend an Edit selection in a track to the Meter ruler:

1 Using the Selector tool or any Time Grabber tool, select a track range.

2 Shift-click in the Meter ruler.

Shift-click again in the Meter ruler to remove it from the selection.

To select all meter events:

■ Double-click with the Selector tool in the Meter ruler.
To clear a range of selected meter events:

1. If you want to constrain the selection to the current Grid value, set the Edit mode to Grid.
2. Drag in the Meter ruler to select the meter events you want to remove.
3. Choose Edit > Clear to delete the selected meter events.

**Partial Measures**

As necessary, Pro Tools will create a partial measure to accommodate the inserted meter event. When a meter event is preceded by a partial measure, the meter event is displayed in italics in the Meter ruler.

![Partial measure of 4/4](image)

Press Alt+1 (Windows) or Option+1 (Mac) on the number keypad to open the Time Operations window and display the last active Time Operations window.

---

**Time Operations**

The Time Operations window lets you:

- Change Meter
- Insert Time
- Cut Time
- Move Song Start

To open a specific Time Operations window:

- Choose Event > Time, followed by one of the Time Operations commands (such as Change Meter).

💡 If the Time Operations window is already open, you can select any Time Operation from the pop-up menu at the top of the window.

To open the last active Time Operations window:

- Choose Event > Time > Operations Window.
Change Meter

Change Meter lets you specify complex meter changes for Bar|Beat-based material. You can enter meter changes at a particular bar, make a meter change over a selected area of time, or add meter changes sequentially one bar at a time.

Options for the Change Meter command include:

**New Meter** Lets you specify a new time signature. The first field lets you enter the number of beats (up to 99) in a measure, and the second field lets you enter the note length that counts as one beat.

**Click** Lets you specify the note value that will trigger the metronome click. For example, if an eighth note is chosen, a click is played for every eighth note, regardless of tempo.

**Starting at Bar** Sets the bar where the meter change is added. Meter changes made in the Change Meter page can only be made at the beginning of a bar.

**Apply Change To** Lets you apply the meter change to the selected range, to the end of the session, or until the next bar.

**Change** The Change fields let you specify the number of bars of the new meter that you wish to have replace the selected range.

Pro Tools automatically calculates the nearest whole bar number, or you can specify a number of bars to be affected. Time is inserted or deleted, in whole bar increments, at the end of the selection, as necessary on all affected tracks when you override the calculated range.

**Realign**

The Realign controls let you choose which items to realign after meter changes have been made. You can choose to realign meter events, or choose to realign meter and tempo events, tick-based markers and tracks, and all or none of the sample-based tracks.

**Meter Ruler Only** Applies meter changes to the Meter ruler only. All other rulers and tracks are unaffected.

**Meter and Tempo Rulers, Tick-Based Markers and Tracks, and Sample-based Markers and Tracks** Applies meter changes to all rulers, tick-based tracks, and your choice of sample-based tracks. Time is inserted or deleted as needed at the end of the selection to preserve the alignment of material following the selection.
**Change Meter Examples**

**To change the meter over a range of bars:**

1. Do one of the following:
   - Drag with the Selector tool to select a range of bars to change.
   - or –
   - To have the meter change apply until the next meter event, click where you want the meter change to begin with the Selector tool. The meter change will be made at the beginning of the nearest bar.

2. Choose Event > Time > Change Meter.

3. Specify a new meter and click setting. Pro Tools will automatically set the selection options to fit the new meter to the selected range as closely as possible, adding or subtracting beats as necessary.

4. Select To Selected Range in the Apply Change pop-up menu.

5. Choose which rulers and tracks you wish to realign after meter changes have been made.

6. Click Apply.

**To add a series of meter changes, one measure at a time:**

1. Do one of the following:
   - With the Selector tool, click where you want the meter change to begin. The meter change will be made at the beginning of the nearest bar.
   - or –
   - Enter the first measure number in the Starting At Bar field.

2. Choose Event > Time > Change Meter.

3. Specify a new meter and click setting.

4. Choose “Until the Next Bar” from the Apply Change To pop-up menu.

5. Click Apply to enter the new meter and to move the insertion point to the end of the new measure.

6. Specify a new meter and click setting for the next measure.

7. Repeat steps 5–6 for every additional meter change you wish to insert.

**Insert Time**

Insert Time lets you insert an amount of blank time (silence) into Conductor rulers, MIDI tracks, and audio tracks.

**Insert Time window**

Options for the Insert Time command include:

- **Start, End and Length** Sets the start and end points for the selection, and the selection length.

- **Set Meter** If your Main Time Scale is Bars|Beats, Set Meter lets you specify a new meter for the inserted time. The selection is quantized to the nearest bars, and the previous meter is inserted after the selection.
Chapter 20: Conductor Tracks and Memory Locations

If your Main Time Scale is sample-based, Set Meter is not available.

**Realign**

The Realign controls let you choose which items shift (occur later) when time is inserted, as follows:

- If your Main Time Scale is set to Bars|Beats, you can choose to realign meter events only, or choose to realign a combination of Meter and Tempo rulers, all tick-based markers and tracks, and your choice of sample-based tracks.
- If your Main Time Scale is set to an absolute timebase (such as Min:Secs), you can choose to independently realign conductor events, tick-based markers and tracks, and your choice of sample-based tracks.

**Meter Ruler Only** If your Main Time Scale is Bars|Beats, you have the option to insert time into the Meter ruler only. Meter events after the start point of the selection are shifted past the end point by the length of time selection.

If your Main Time Scale is sample-based, Realign Meter Ruler Only is not available.

**Meter and Tempo Rulers** Lets you insert time into the Meter and Tempo rulers. Meter and Tempo events after the start point of the selection are shifted past the end point by the length of time inserted.

**Tick-Based Markers and Tracks** Lets you shift Bar|Beat-based markers, and insert time into tick-based tracks. Marker events and tick-based tracks after the start point of the selection are shifted past the end point by the length of time inserted.

If the selection includes any audio regions on tick-based tracks, the audio regions are separated at the Start point, and the new region containing the previous selection is shifted to the end point.

**Sample-Based Markers and Tracks** Lets you shift absolute time-based markers, and insert time into sample-based tracks. Marker events and sample-based tracks after the start point of the selection are shifted past the end point by the length of time inserted.

If the selection includes any audio regions on sample-based tracks, the selected portions of the audio regions are separated at the Start point, and the new region containing the previous selection is shifted to the end point.

**Insert Time Example**

To insert four empty measures of 4/4 time into a session:

1. Set the Main Time Scale to Bars|Beats.
2. Choose Event > Time > Insert Time.
3. Enter the measure where you want to insert the measures in the Start field.
4. Enter four measures in the Length field.
5. Select the Realign option to Meter and Tempo Rulers, All Tick-Based Markers & Tracks, and All Sample-Based Markers and Tracks.
6. Click Apply.
**Cut Time**

Cut Time lets you cut a specified amount of time (both Timebase and track data) from Conductor rulers, MIDI tracks, and audio tracks.

**Options for the Cut Time command include:**

**Start, End and Length** Sets the start and end points for the selection, and the selection length.

**Realign**

The Realign controls let you choose which items shift when time is cut, as follows:

- If your Main Time Scale is set to Bars|Beats, you can choose to realign meter events only, or choose to realign a combination of Meter and Tempo rulers together, all tick-based markers and tracks, and your choice of sample-based tracks.
- If your Main Time Scale is set to an absolute timebase (such as Min:Secs), you can choose to independently realign conductor events, tick-based markers and tracks, and your choice of sample-based tracks.

**Meter Ruler Only** If your Main Time Scale is Bars|Beats, you have the option to remove time from the Meter ruler only. Meter events within the selection are removed, and meter events that occur after the end point of the selection are shifted to the selection start point.

If your Main Time Scale is sample-based, Realign Meter Ruler Only is not available.

**Meter and Tempo Rulers** Lets you cut time from the Meter and Tempo rulers. Meter and tempo events within the selection are removed, and the meter and tempo events that occur after the end point of the selection are shifted to the selection start point.

**Tick-Based Markers and Tracks** Lets you shift Bar|Beat-based markers, and delete time from tick-based tracks. Marker events and tick-based tracks within the selection are removed, and the marker events and tick-based tracks that occur after the end point of the selection are shifted forward.

If the time selection includes any tick-based audio regions, the selected area of the audio region is deleted, and the region following the selection is shifted forward.

**Sample-Based Markers and Tracks** Lets you shift absolute time-based markers, and cut time from sample-based tracks. Marker events and sample-based tracks within the selection are removed, and the marker events and sample-based tracks that occur after the end point of the selection are shifted forward.

If the time selection includes any sample-based audio regions, the selected area of the audio region is deleted, and the region following the selection is shifted forward.
Cut Time Example

To cut thirty seconds of time from a session:
1. Set the Main Time Scale to Minutes:Seconds.
2. Choose Event > Time > Cut Time.
3. With the Selector tool, click at the beginning of the area that you want to cut.
4. Enter thirty seconds (0:30.000) in the Length field.
5. Select the options to Realign both Meter and Tempo rulers, all tick-based tracks, and all sample-based markers and tracks.
6. Click Apply.

Move Song Start

Move Song Start lets you redefine the location of the Song Start Marker.

Move Song Start window

Options for the Move Song Start command include:

- **Timebase** Lets you precisely redefine the position of the Song Start Marker measured by any supported timebase.

Move Start To

Sets the location for the Song Start Marker in the chosen timebase.

Renumber Song Start To

When enabled, this lets you set the Song Start Marker to any bar number.

Move

The Move controls let you choose which items shift when the Song Start is moved, as follows:

- **Song Start Only** Moves the Song Start Marker only.
- **Meter and Tempo Rulers, Tick-Based Markers and Tracks, and Sample-based Markers and Tracks** Moves the Song Start Marker, Meter and Tempo rulers, tick-based tracks, and your choice of sample-based tracks.

Move Song Start Example

To move the Song Start Marker to 15 seconds on the timeline:
1. Choose Event > Time > Move Song Start.
2. Select Minutes:Seconds from the Timebase pop-up menu.
3. In the Move Song Start To field, enter “0:15:000” to move the song start forward by 15 seconds.
4. If you wish to renumber the bars so that the Song Start Marker sits at a different bar, select the Renumber Song Start option, and enter the bar number in the Renumber 1st Bar to field.
5. Select whether you want to move all sample-based markers and tracks or none of them.
6. Click Apply.
Renumbering Bars

You can use the Renumber Bars command to renumber all bars in the session, effectively changing the bar locations for all regions, meter and tempo events while leaving their position intact. In doing so, however, the SMPTE and sample locations of the session data are not changed.

To renumber bars:

1. Choose Event > Renumber Bars.
2. Specify the bar you want to renumber, along with the new bar number, then click Renumber.

Memory Locations and Markers

Each session can save up to 999 Memory Locations that can be used to recall:

- Markers to important locations in the session
- Edit selections across one or more tracks
- Record and play ranges, along with pre- and post-roll times
- Track settings that include Show/Hide status, Track Heights, and zoom values
- Edit and Mix Groups enables

Memory Locations are viewed and sorted in the Memory Locations window, where they can be recalled by clicking the Memory Location.

Properties of Memory Locations

When creating a new Memory Location (see “Creating Memory Locations” on page 430) you are prompted to define its Time Properties and General Properties.

Time Properties

Under Time Properties, a Memory Location can be set to Marker, Selection, or None. This determines the type of Memory Location that is created. Each of these three Memory Location types can also save any combination of General Properties.

Marker Recalls a Timeline location whose reference can be either Bar|Beat (tick-based) or Absolute (sample-based). When recalling a Marker Memory Location, the playback cursor moves to the Marker’s location and the start and end times in the Transport window are also updated. If the Timeline and Edit Selections are linked, the edit cursor also moves to the Marker location.
Markers appear in the Markers ruler with a thin yellow line extending down through all tracks in the Edit window (to assist in arranging and aligning track material). You can click a Marker in the Markers ruler to recall its location along with its stored General Properties.

When set to Absolute, the Memory Location is sample-based and its bar and beat location shifts if the tempo is changed—though its sample location remains constant, along with its relation to audio material.

In the Markers ruler, Markers that are Bar|Beat appear as yellow chevrons, and Markers that are Absolute appear as yellow diamonds.

General Properties

All three types of Memory Locations (Marker, Selection, and None) can store and recall any combination of the following General Properties:

- **Zoom Settings**: Recalls the horizontal, audio, and MIDI zoom values for audio, MIDI, and Instrument tracks.
- **Pre- and Post-Roll Times**: Recalls pre- and post-roll times (but not whether they are enabled). This property can be stored with a Selection Memory Location to recall record and play ranges along with pre- and post-roll.
- **Track Show/Hide**: Recalls which tracks are hidden. Use this property to display groups of tracks for editing and mixing.
- **Track Heights**: Recalls all Track Heights. Use this option along with Zoom Settings to recall edit environments that are suited for particular tasks, such as editing down to the sample level or trimming MIDI notes.
- **Group Enables**: Recalls which Edit and Mix Groups are enabled. This option is helpful in recalling groups for particular edit and mixing operations, such as muting all drum tracks or fading a stereo pair.

Only contiguous selections can be saved with Memory Locations. Discontiguous selections, made with the Object Grabber tool, will be recalled as if the selections were made with the Time Grabber tool.
Comments
All three types of Memory Locations (Marker, Selection, and None) can store and recall comments. You can enter a maximum of 255 characters to describe the Memory Location. You can also edit comments previously entered.

See “Creating Memory Locations” on page 430 and “Editing Memory Locations” on page 432 for more information.

Creating Memory Locations
Memory Locations can be created in different ways, based on the type of Memory Location.

When creating Memory Locations, the next available number is assigned to it (1–999). This number is used in recalling the Memory Location from the numeric keypad.

To create a Marker Memory Location:
1. Configure any session settings you will save with the Marker Memory Location, such as zoom settings, pre- and post-roll times, Show/Hide status for tracks, Track Heights, and Edit and Mix Group enables.
2. Make sure to select Options > Link Timeline and Edit Selection.
3. If the Markers ruler is not displayed, select View > Rulers > Markers.
4. Do one of the following:
   • Click with the Selector tool in any track or ruler at the location where you want to place the Marker. To place a Marker at the beginning of a region, select the region with the Time Grabber tool. Click the Add Marker/Memory Location button (or press Enter on the numeric keypad).
   – or –
   • While pressing the Start key (Windows) or Control (Mac), move the cursor into the Markers ruler (where the cursor changes to the Grabber with a “+”) and click at the location where you want to place the Marker.
5. In the New Memory Location dialog, select the Marker option and specify the Reference as either Bar|Beat or Absolute.
6. Enter a name for the new Marker and select any General Properties you want to save with the Marker.
7. Click OK. The Marker is created and appears in the Markers ruler, and in the Memory Locations window.
To create a Selection Memory Location:

1. Configure any session settings you will save with the Selection Memory Location, such as zoom settings, pre- and post-roll times, Show/Hide status for tracks, Track Heights, and Edit and Mix Group enables.
2. Select a range of material in one or more tracks.
3. Do one of the following:
   - Press Enter on the numeric keypad.
   - or –
   - From the pop-up menu in the Memory Locations window (click the Name button), choose Add Memory Location.
4. In the New Memory Location dialog, select the Selection option and specify the Reference as either Bar|Beat or Absolute.
5. Enter a name for the new Memory Location and select any General Properties you want to save with it.
6. Click OK. The Selection Memory Location is created and appears in the Memory Locations window.

To create a General Properties Memory Location:

1. Configure any session settings you will save with the Selection Memory Location, such as zoom settings, pre- and post-roll times, Show/Hide status for tracks, Track Heights, and Edit and Mix Group enables.
2. Press Enter on the numeric keypad.
3. In the Memory Location dialog, select the None option.
4. Enter a name for the new Memory Location and select any General Properties you want to save with it.
5. Click OK. The General Properties Memory Location is created and appears in the Memory Locations window.

In the New Memory Location dialog, you can Alt-click (Windows) or Option-click (Mac) any General Property to enable or disable all properties. You can also Control-click (Windows) or Command-click (Mac) any property to toggle its state and the state of all other General Properties.

Creating Memory Locations On-the-Fly

When the Editing preference for “Auto-Name Memory Locations When Playing” is enabled, Memory Locations can be created during playback, without raising the New Memory Location dialog. This option can also be selected from the pop-up menu in the Memory Locations window.

This capability is useful if you want to mark certain locations while listening during a record pass, or if you want to mark frame locations while viewing a video scene.

To create a Marker during playback:

1. From the pop-up menu in the Memory Locations window, select Default To Marker. This ensures that new Memory Locations default to being Markers.
2. From the pop-up menu in the Memory Locations window, select Auto-Name Memory Locations.
3. For inserted Markers to have a Bar|Beat reference, make sure to set the Main Time Scale to Bars:Beats.
4. Click Play in the Transport window.
5 When the location is reached, press Enter on the numeric keypad. A Marker is automatically created and appears in the Markers ruler.

Auto-created Markers are named with increasing numbers, as in “Marker 1,” “Marker 2,” and “Marker 3.”

When the option for Default To Marker is deselected, new Memory Locations default to whatever type was last created. Therefore, if a Selection Memory Location was created last, it will be the type that is created on-the-fly. In this case, the name for the created Memory Location is based on the start of the Edit selection using the time format for the Main Time Scale (such as “2[2]305” or “0:02.658”).

Recalling Memory Locations

Memory Locations can be recalled from the Memory Locations window and from the numeric keypad. In addition, Marker Memory Selections can be recalled by clicking them in the Markers ruler.

To recall a Memory Location:

1. If the Memory Locations window is not already open, choose Window > Memory Locations to display it.
2. If recalling a Selection Memory Location that will define a record or play range, make sure to select Options > Link Timeline and Edit Selection.
3. Do one of the following:
   • In the Memory Locations window, click the Memory Location to recall it.
   • With the Numeric Keypad mode set to Classic, press the Memory Location number followed by Period (.) again.

When recalling a Memory Location from the numeric keypad, the Memory Locations window does not need to be open.

To recall a Marker from the Markers ruler:

1. If the Markers ruler is not displayed, select View > Rulers > Markers.
2. Click the Marker. The playback cursor locates to the Marker and any General Properties stored with the Marker are recalled.

Even if the Markers ruler is not displayed, Markers can be recalled from the Memory Locations window, or from the numeric keypad.

Editing Memory Locations

Memory Locations can be renamed, edited, deleted, and copied and pasted.

To rename a Memory Location:

1. Do one of the following:
   • In the Memory Locations window, double-click the Memory Location you want to rename.
   • If renaming a Marker Memory Location, double-click the Marker in the Markers ruler.
2. Enter the new name for the Memory Location, and click OK.
To redefine the General Properties stored with a Memory Location:

1. Make changes to the session’s zoom settings, pre- and post-roll times, Show/Hide status of tracks, Track Heights, or Group Enables.

2. Do one of the following:
   - In the Memory Locations window, Right-click (Windows) or Control-click (Mac) the Memory Location you want to redefine.
   - If changing a Marker Memory Location, Right-click (Windows) or Control-click (Mac) the Marker in the Markers ruler.

3. In the Memory Location dialog, select the General Properties you want to save with the Memory Location.

4. Enter a new name for the Memory Location, if desired, and click OK.

To change a Memory Location from one type to another:

1. Do one of the following:
   - In the Memory Locations window, double-click the Memory Location you want to change.
   - If changing a Marker Memory Location, double-click the Marker in the Markers ruler.

2. In the Memory Location dialog, select either Marker, Selection, or None as the Memory Location type.

3. Enter a new name for the Memory Location, if desired, and click OK.

To change the Selection stored with a Memory Location:

1. If the Memory Locations window is not already open, choose Window > Memory Locations to display it.

2. Select a range of material in one or more tracks.

3. In the Memory Locations window, Right-click (Windows) or Control-click (Mac) the Memory Location that you want to redefine.

4. Enter a new name for the Memory Location, if desired, and click OK.

To move a Marker by dragging:

1. In the Markers ruler, drag the Marker left or right.

   Dragging a Marker

   If the Edit mode is set to Grid, the dragged event snaps to the current Grid value. If using Spot mode, the Spot dialog opens.

To align a Marker to a different location:

1. Make sure to select Options > Link Timeline and Edit Selection.

2. Do one of the following:
   - In any of the Timebase rulers, click with the Selector tool at the new location.
   - Click in the playlist for any track. To align the Marker to the start of a region, select the region with the Time Grabber tool.
3 In the Memory Locations window or the Markers ruler, Start-click (Windows) or Control-click (Mac) the Marker Memory Location that you want to redefine.

4 Enter a new name for the Marker, if desired, and click OK.

Deleting Memory Locations

To delete a Memory Location, do one of the following:

- In the Memory Locations window, select the Memory Location and choose Delete Memory Location from the pop-up menu.
- or -
- In the Memory Locations window, Alt-click (Windows) or Option-click (Mac) the Memory Location.

To delete all Memory Locations, do one of the following:

- In the Memory Locations Window, choose Delete All from the pop-up menu.
- or -
- Alt-Shift-click (Windows) or Option-Shift-click (Mac) any Memory Location in the Memory Locations window.

To delete a Marker from the Markers ruler:

- While pressing Alt (Windows) or Option (Mac), move the cursor over the Marker (where the cursor changes to the Grabber with a “-“) and click to remove it.

Copying Marker Memory Locations

To copy and paste a range of Markers:

1. If you want to constrain the selection to the current Grid value, set the Edit mode to Grid.
2. Drag in the Tempo ruler to select the range of measures that includes the Markers.

If the beginning of the selection includes a Marker, press Control (Windows) or Command (Mac) so the Selector tool appears.

💡 Press Alt (Windows) or Option (Mac) while dragging to select across all Conductor tracks.

3. Choose Edit > Copy.
4. Click in the Markers ruler at the point where you want to paste the tempo events.
5. Choose Edit > Paste. The contents of the Clipboard are pasted from the insertion point, replacing any existing Markers.

To extend an Edit selection in a track to the Markers ruler:

1. Using the Selector or Time Grabber tool, select a track range.
2. Shift-click in the Markers ruler.

Shift-click again in the Tempo ruler to remove it from the selection.

To select all Markers in the Markers ruler:

- Double-click with the Selector tool in the Tempo ruler.
Memory Locations Window

Memory Locations are listed, with their name and assigned number, in the Memory Locations window. To recall a Memory Location from this window, simply click it.

You can select viewing and sorting options, along with commands for creating and removing Memory Locations, from the pop-up menu in the Memory Locations window (obtained by clicking the Name button in the upper left).

Memory Locations Commands and Options

Show Markers Only When selected, only Marker Memory Locations are displayed in the Memory Locations window. However, even when Selection Memory Locations and General Property Memory Locations are hidden, they can still be recalled from the numeric keypad.

Show View Filter Icons When selected, the Memory Locations window provides an icon-based “View Filter” that allows you to show or hide Memory Locations based on the properties they contain. To show or hide Memory Locations containing a specific property, click the appropriate icon.

Memory Locations View Filter Icons

If an icon is disabled, all Memory Locations associated with that property are hidden. However, if a Memory Location contains other properties for an icon that is enabled, it is still displayed. When a view icon is enabled, it appears in color. When it is disabled, it appears gray.
In addition, the View Filter provides a handy reference for which properties are stored in each Memory Location (indicated by a row of icons for each Memory Location).

**Show Main/Sub Counter** When selected, a column appears in the Memory Locations window that displays the locations for Markers, and the start times for Selection Memory Locations. General Property Memory Locations display nothing in this column.

<table>
<thead>
<tr>
<th>#</th>
<th>Name</th>
<th>Time</th>
<th>Markers</th>
<th>Selection</th>
<th>General Properties</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Start</td>
<td>0.59</td>
<td>✔️</td>
<td>✔️</td>
<td>✔️</td>
</tr>
<tr>
<td>2</td>
<td>Yield</td>
<td>1.62</td>
<td>✔️</td>
<td>✔️</td>
<td>✔️</td>
</tr>
<tr>
<td>3</td>
<td>End</td>
<td>1.36</td>
<td>✔️</td>
<td>✔️</td>
<td>✔️</td>
</tr>
<tr>
<td>4</td>
<td>Fade Start</td>
<td>5.64</td>
<td>✔️</td>
<td>✔️</td>
<td>✔️</td>
</tr>
<tr>
<td>5</td>
<td>Fade End</td>
<td>2.43</td>
<td>✔️</td>
<td>✔️</td>
<td>✔️</td>
</tr>
<tr>
<td>6</td>
<td>9.26</td>
<td>✔️</td>
<td>✔️</td>
<td>✔️</td>
<td>✔️</td>
</tr>
</tbody>
</table>

**Sort by Time** When selected, Markers are sorted by their order in the Timeline, followed by Selection and General Properties Memory Locations, which are listed in the order in which they were created.

When Sort by Time is deselected, all Memory Locations are listed in the order of their assigned numbers.

**Add Memory Location** Choose this command to create a new Memory Location.

**Remove Memory Location** Deletes the currently selected Memory Location in the Memory Locations window.

**Delete All** Deletes all Memory Locations (Marker, Selection, and General Property) in the session.

**Default To Marker** When selected, new Memory Locations default to Markers, though in the New Memory Location dialog you can still define the new Memory Location as one of the other types.

**Auto-Name Memory Location** When selected, Memory Locations are created automatically without encountering the New Memory Location dialog. If the Default To Marker option is selected, a Marker Memory Location is auto-created. Otherwise, the Memory Location type is determined by whatever type (Marker, Selection, or None) was created last.

![Main/Sub Counters in the Memory Locations window](image)

![Comments in the Memory Locations window](image)
Chapter 21: Beat Detective

Beat Detective is a powerful tool for analyzing, editing, and manipulating audio or MIDI tracks that have an inherent rhythmic character.

Beat Detective analyzes an audio or MIDI selection, identifies its peak transients or accented notes, and generates beat triggers based on the detected peak transients or MIDI notes. From these beat triggers, Beat Detective can:

- Extract tempo and beat information to create Bar|Beat Markers that can be used to define the session’s tempo map. See “Generating Bar|Beat Markers with Beat Detective” on page 447.
- Extract tempo and groove information as groove templates, called DigiGrooves. These templates can be applied to audio or MIDI using Beat Detective or Groove Quantize (see “DigiGroove Templates” on page 448.
- Separate an audio selection into discrete regions, and then conform (or “quantize”) separated regions to the session’s tempo map, or to groove templates. See “Separating Regions with Beat Detective” on page 450 and “Conforming Regions with Beat Detective” on page 452.

Beat Detective and Source Material

Beat Detective is most effective with audio or MIDI that has clear attack transients or accent patterns (including most instruments used in popular music, such as drums, guitar, or bass). Beat Detective will be less successful with audio material with soft attacks, or legato phrasing (such as strings and vocals).

Uses for Beat Detective

Beat Detective can be useful in many situations, including:

Extracting Tempo from Audio Beat Detective can generate Bar|Beat Markers, from which it can extract the tempo—even if the audio contains varying tempos, or material with a swing feel. Additionally, once Bar|Beat Markers have been generated, other audio and MIDI regions can be quantized to them.

Creating DigiGrooves Beat Detective can extract groove templates, called DigiGrooves, from an audio selection. DigiGrooves can be used to apply the groove, or feel of the captured passage to other audio selections (using Groove Conform) or MIDI data (using Groove Quantize).

Conforming Audio Regions Beat Detective can conform (“quantize”) audio with a different tempo, or with varying tempos, to the session’s current tempo map, or to a groove template.
“Tighten Up” Performances Beat Detective can be used to improve the timing of some audio material by calculating and extracting its average tempo, and then conforming its rhythmic components—regions separated with Beat Detective—to the session’s tempo map.

Loop Matching Since Beat Detective can extract tempo and beat information from audio, and conform audio to an existing tempo map or groove template, this makes it very useful for aligning loops with different tempos or grooves. If a loop is at a different tempo than the current session, Beat Detective lets you quickly separate each beat in the loop and conform them to the tempo map (as an alternative to time compressing or expanding the loop, which can alter the pitch and tone of the audio).

Remixes Beat Detective can be used for remixes or creating new rhythms. It can extract tempo from the original drum tracks, or in some instances the original stereo mix. New audio or MIDI tracks can then be conformed to the original material, or the original material can be conformed to new drum tracks, achieving an entirely new feel.

When working with tick-based audio, use Beat Detective’s Region Separation command to quickly separate audio regions into individual “hits” (or slices). You can also create a region group of the separated regions to facilitate editing and arranging.

Smoothing Post Production Edits (Audio Only) Beat Detective’s Edit Smoothing can be used to automatically clean up foley tracks that contain many regions requiring trimming and crossfading, effectively removing the gaps of silence between the regions (thus retaining the room tone throughout the track).

---

**Beat Detective Requirements**

Beat Detective is available with Pro Tools HD, LE, and M-Powered.

⚠️ **Pro Tools LE and M-Powered do not support using Beat Detective across multiple tracks. When Beat Detective is applied to multiple tracks, only the top track is edited.**

**RAM Requirements for Beat Detective**

Beat Detective operations can require a large amount of RAM, especially when working with multiple tracks and lengthy selections.

To avoid low memory situations with Beat Detective, do the following:

- If you begin to experience slower Beat Detective response, add more RAM to your computer.
- If your computer does not have the extra RAM, work with shorter selections, or individual tracks.
- Set the Editing preference for Levels of Undo to a smaller value (see “Levels of Undo and Memory” on page 274). Memory-intensive editing operations, such as Edit Smoothing (audio only) with Beat Detective, can use up a large amount of memory when in the Undo queue.

When working with tick-based audio, use Beat Detective’s Region Separation command to quickly separate audio regions into individual “hits” (or slices). You can also create a region group of the separated regions to facilitate editing and arranging.
The Beat Detective Window

The Beat Detective window appears as shown in Figure 16, below.

To open the Beat Detective window, do one of the following:

- Choose Event > Beat Detective.
- Press Control+8 (Windows) or Command+8 (Mac) on the numeric keypad.

Beat Detective is a floating window that can be left open while working. This lets you adjust the controls in real time during playback, while viewing the beat triggers that appear in your selection in the Edit window.

Beat Detective Modes

The Beat Detective window is divided into three sections: Operation, Selection, and Detection. Depending on the Operation mode, the controls in the Action section change. The Selection options for Beat Detective are available in each of the Operation modes.

The Beat Detective modes include the following:

Operation

- Bar|Beat Marker Generation Generates Bar|Beat Markers corresponding to transients detected in the audio selection.
- Groove Template Extraction Extracts the rhythmic and dynamic information from audio, and saves this information to the Groove Clipboard, or as a DigiGroove template.
- Region Separation (Audio Only) Separates and creates new regions based on transients detected in the audio selection.
- Region Conform (Audio Only) Conforms all separated regions within the selection to the current tempo map. Beat Detective can conform audio regions to groove templates (such as DigiGroove templates) in addition to standard quantization.
- Edit Smoothing (Audio Only) Fills the gaps between conformed regions by automatically trimming them, and if you choose, inserts cross-fades.
Defining a Beat Detective Selection

Whether you will be generating Bar|Beat Markers, extracting a DigiGroove template, or separating regions to be conformed, you must always define the audio or MIDI selection to be analyzed. The Beat Detective window provides tools to define and capture the selection range, time signature, and swing (sub-division) content for the selected audio.

To ensure the best possible results with Beat Detective, make sure the selected passage starts exactly on the attack of the first beat.

For Beat Detective to generate beat triggers that are metrically accurate, the length and meter of the selection must be correctly defined. In addition, the selection should not contain any meter or tempo changes.

Use Loop playback to check the accuracy of your selection.

To define a selection for Beat Detective:

1 In the Edit window, select a range of audio or MIDI material in a single track or in multiple tracks.

Pro Tools LE does not support using Beat Detective across multiple tracks. When Beat Detective is applied to multiple tracks, only the top track is edited.

2 To keep the Edit selection intact while playing or looping from any location, deselect Options > Link Timeline and Edit Selection.

Making an audio selection for Beat Detective

Make sure the selection’s start and end points fall cleanly on the beat. To zero in on an audio region’s start and end points, zoom to the sample level and use the Tab to Transients option (see “Tabbing to Transients” on page 319).

To avoid losing an existing selection, save and recall an Edit selection by saving it as a Memory Location. See “Memory Locations and Markers” on page 428.

2 Choose Event > Beat Detective.

3 You must define or capture the selection every time you make a new selection or change the tempo map. To define the selection range, do one of the following:

- If the tempo and meter of the audio selection do not match the session’s default tempo and meter, enter the Time Signature, and Start Bar|Beat and End Bar|Beat locations. For a four-bar selection that starts on beat 1, enter 1|1 and 5|1.
- If the tempo and meter of the audio selection do not match the session’s default tempo and meter, and you are unsure of the length of the material, enter the Time Signature and the Start Bar|Beat location; then start playback, and click the Tap button repeatedly to automatically calculate the End Bar|Beat. When using Tap with long selections, continue to tap until the End Bar|Beat stabilizes. Once stabilized, you may need to manually adjust the number to the nearest bar boundary.
• If the selection’s tempo and meter match the session tempo and meter (see “Calculating Tempo with Beat Detective” on page 441), and it aligns correctly with the session’s bars and beats, click the Capture Selection button. The correct Time Signature, and Start Bar|Beat and End Bar|Beat values will be filled in automatically.

To improve Beat Detective’s accuracy in analyzing swung notes, select the Contains option that indicates the smallest sub-division of the beat contained in the selection. The Contains option includes quarter-notes, eighth-notes, sixteenth-notes (the default setting), thirty-second-notes, and a triplet modifier. The selected Contains option determines the groove template grid locations for DigiGroove templates.

Calculating Tempo with Beat Detective

If you know the meter, and start and end points of the audio selection, use Beat Detective to calculate its tempo.

To calculate a selection’s tempo with Beat Detective:

1. Make an audio selection in the Edit window and define the selection in the Beat Detective window as described in “Defining a Beat Detective Selection” on page 440.

2. Select Bar|Beat Marker Generation mode.

3. In the Detection section (Normal mode), click Analyze.

4. Set the Sensitivity slider set to 0%

5. Click Generate.

Bar|Beat Markers are automatically generated at the beginning and end of the selection, indicating the material’s tempo and meter.
Generating Beat Triggers

Once you have accurately defined the selection range, Beat Detective can generate beat triggers based on detected MIDI notes or audio peak transients. The range and type of transients found can be adjusted with the Detection settings, allowing you to zero in on the bars, beats, and sub-beats in the material, while avoiding the non-rhythmic content.

To generate beat triggers from an audio selection:

1. In the Edit window, make an audio selection.
2. Select Audio from the operation pop-up menu.
3. In the Beat Detective window, select one of the following modes:
   - Bar|Beat Marker Generation
   - Groove Template Extraction
   - Region Separation (audio only)
4. Define or capture the selection as described in “Defining a Beat Detective Selection” on page 440.
5. From the Analysis pop-up menu, choose one of the following detection algorithms:
   - High Emphasis, works well with high frequency, inharmonic material, such as cymbals and hi-hats, while avoiding low frequency material.
   - Low Emphasis, works well with low frequency material, such as bass guitar and kick drum, as well as with most harmonic material, such as piano or rhythm guitar.
6. Click the Analyze button.
7. Depending on the rhythmic content of the selection, set the Resolution to Bars, Beats, or Sub-Beats.
8. Adjust the Sensitivity slider until beat triggers appear on the beats and sub-beats in the selection.
   Bar triggers are indicated with thick lines, beat triggers with medium lines, and sub-beat triggers with thin lines.
9. You can zoom to the sample level and click the Scroll Next button to scroll to the next trigger within the selection. To scroll to the previous trigger, Alt-click (Windows) or Option-click (Mac) the Scroll Next button (see “Navigating Consecutive Beat Triggers” on page 447). This is useful to confirm that the beat triggers are appearing in the appropriate locations. If false triggers appear between the beats or sub-beats (representing non-rhythmic material) delete them (see “Deleting Beat Triggers” on page 445), or reduce the Sensitivity value.
10. To display the metric locations for the triggers, select the Show Trigger Time option.
11. If you cannot get the beat triggers to appear at the right locations, repeat steps 5–10 trying the other Analysis algorithm (High or Low Emphasis).
To generate beat triggers from a MIDI selection:

1. In the Edit window, set the MIDI track you wish to use to Notes View.

2. Make a selection across a range of MIDI data. Make certain that the selection start and end points are at musically relevant locations, such as barlines.

3. Choose Event > Beat Detective.

4. Select MIDI from the operation pop-up menu.

5. In the Beat Detective window, select one of the following modes:
   - Bar|Beat Marker Generation
   - Groove Template Extraction

6. Define the selection range. If the tempo and meter of the audio selection do not match the session’s default tempo and meter, enter the Time Signature, and Start Bar|Beat and End Bar|Beat locations. For a four-bar selection that starts on beat 1, enter 1|1 and 5|1.

7. If your MIDI track contains chords, choose one of the following MIDI chord recognition algorithms from the Analysis pop-up menu:
   - Last Note
   - First Note
   - Loudest Note
   - Average Location
   - Highest Note
   - Lowest Note

8. Click the Analyze button.

---

### MIDI Chord Recognition

Since MIDI notes in a chord may be played at slightly different moments, Beat Detective interprets notes that are close together (closer than half the time value that is set in the Selection Contains field) as a chord.

#### MIDI chord analysis

Beat Detective will use the criteria you set in the Analysis pop-up menu to interpret the location of the beat in relation to the chord.

- **Last Note** Sets the beat trigger to the start of the last note played in the chord.
- **First Note** Sets the beat trigger to the start of the first note played in the chord.
- **Loudest Note** Sets the beat trigger to the start of the note in the chord played with the highest velocity.
- **Average Location** Sets the beat trigger to a point that represents the average between the start of the first note played in the chord, and the last note played in the chord.
- **Highest Note** Sets the beat trigger to the start of the highest note played in the chord.
- **Lowest Note** Sets the beat trigger to the start of the lowest note played in the chord.
Realign Session

Beat Detective’s Realign Session function lets you generate Bar|Beat markers without tick-based material shifting. This is useful if you want to extrapolate Bar|Beat markers from tick-based material to align the tempo map and Bar|Beat grid to the tick-based material.

You can also switch tick-based material, such as a MIDI performance, to be sample-based and then manually insert Bar|Beat markers.

Generating Bar|Beat markers in sessions with tick-based material, such as MIDI tracks and tick-based audio tracks, can cause the tick-based material to shift in absolute time. This can be useful if you want to align the tick-based material to Bar|Beat markers generated from sample-based material.

When you generate Bar|Beat Markers in a session that contains tick-based audio or MIDI, Beat Detective gives you the option to preserve the position of the session’s tick-based material, or to allow the material to shift.

1 Define or capture the selection as described in “Defining a Beat Detective Selection” on page 440.
2 Set the Detection resolution to Bars or Beats.
3 Click the Generate button.
4 Do one of the following:
   - In the Realign Session dialog, choose Preserve Tick Position if you wish to let the tick-based material shift in absolute time. This option maintains prior Beat Detective functionality.
   – or –
   - Choose Preserve Sample Position if you wish to have the tick-based material maintain its absolute position. This option can be useful when adding a meter and tempo map to a freely played performance.
5 Click OK.

Tips for Getting Useful Beat Triggers

Use the following tips to verify beat triggers:

- To focus on a particular area in the selection, unlink the Timeline and Edit Selections and set the playback range by clicking or dragging in any Timebase ruler.
- Check the thickness of the beat triggers to see if they align properly with the audio material. Thick triggers fall on barlines, medium triggers fall on beats, and thin triggers fall on sub-beats.
- Select the option for Show Trigger Time and see if the (assumed) metric locations of the triggers align with the material. A false trigger should be moved or deleted because it can cause subsequent triggers to appear in the wrong locations (see “Editing Beat Triggers” on page 445).
Consider whether lengthy selections should first be broken down into smaller selections, which could be more easily managed. For example, working in 8- or 4-bar sections might yield better results more quickly.

Beat triggers are preserved when switching between audio and MIDI modes. This allows using MIDI triggers for editing audio, or collecting triggers from combinations of MIDI and audio tracks (Pro Tools HD only).

For selections across multiple tracks, consider whether it may be easier to work with them individually, or in Collection mode (Pro Tools HD and Pro Tools LE with Music Production Toolkit only). See “Detection (Normal) and Collection Mode” on page 456.

Deleting Beat Triggers

False triggers, which do not represent an actual beat or sub-beat in the source material, may appear when raising the Sensitivity slider to detect quiet material. In these instances you can locate and manually delete any false triggers.

To delete a beat trigger:

1. With the Beat Detective window open, select any Grabber tool in the Edit window.
2. Locate the false trigger you want to delete. Transients for false triggers usually have smaller peaks than the other trigger points, and typically fall between the sub-beats.

Moving Beat Triggers

You can adjust the placement of triggers to allow for the attack of their transients, or to compensate for an individual transient that is slightly ahead of or behind the beat.

To move a beat trigger:

1. With the Beat Detective window open, select any Grabber tool in the Edit window.
2. Locate the beat trigger you want to move and drag it left or right.

Beat Detective LE does cannot be used across multiple tracks. When Beat Detective LE is applied to multiple tracks, only the top track is edited.
Inserting Beat Triggers

If an important beat or sub-beat is not detected, because it is too quiet, you can manually insert a beat trigger.

To insert a beat trigger:
1. With the Beat Detective window open, select any Grabber tool in the Edit window.
2. Click in the selection where you want to insert the new trigger. After inserting a beat trigger, you can drag it left or right to adjust its placement (see “Moving Beat Triggers” on page 445).

If you click too close to an existing trigger, the existing trigger will be moved to the new location.

Promoting Beat Triggers

To ensure that important beat triggers do not disappear when lowering the Sensitivity value, you can promote them. This is useful if a selection has numerous false triggers (too many to bother deleting) at a Sensitivity level where crucial, necessary beat triggers are also displayed. If lowering the Sensitivity slider causes the needed triggers to disappear, simply promote them first.

To promote a beat trigger:
1. Raise the Sensitivity slider until the desired transient is detected and a beat trigger appears.
2. Control-click (Windows) or Command-click (Mac) the beat trigger to promote it.
3. If necessary, repeat steps 1–2 to promote additional beat triggers.
4. Lower the Sensitivity slider to a value where the false triggers disappear.

Once beat triggers are promoted, they will only disappear if the Sensitivity value is set to 0%. To demote all beat triggers in the selection—returning them to their original state—click the Analyze button.

Redefining a Beat Trigger’s Metric Location

It is vital that beat triggers are accurately placed at the correct metric location. If a detected transient is slightly off the beat, Beat Detective may assign it, as well as other transients in the selection, to the wrong metric location.

For example, if you have a bass track where a note was intended to be a downbeat, but was played too early, Beat Detective may define its location as occurring a little before the downbeat. If you then separate and conform the region containing this note, it will be moved to the wrong location. Subsequent regions may be moved to the wrong locations as well.

If a beat trigger is not assigned the correct metric location, relocate it using Identify Trigger.

To change the metric location of a beat trigger:
1. Double-click the beat trigger you want to relocate. The Identify Trigger dialog opens.
2. In the Identify Trigger dialog, enter the correct location for the trigger, then click OK.
Navigating Consecutive Beat Triggers

Use the Scroll Next button to move from the currently selected beat trigger to the next beat trigger. To move to the previous beat trigger, Alt-click (Windows) or Option-click (Mac) the Scroll Next button. This is particularly useful for editing consecutive beat triggers when zoomed in at the sample level.

Generating Bar|Beat Markers with Beat Detective

Once Beat Detective has accurately detected the peak transients in the audio selection and accurately generated beat triggers, the triggers can be converted to Bar|Beat Markers. Bar|Beat Markers generated by Beat Detective create a tempo map that can be used throughout the session.

Once a tempo map has been generated, other audio regions and MIDI notes can be conformed to the Bar|Beat Markers generated by Beat Detective.

If you want to match the audio material to the session’s existing tempo map or a groove template, do not generate Bar|Beat Markers from the material. Instead, use Beat Detective to separate and conform the material (see “Separating Regions with Beat Detective” on page 450).

If you are simply aligning a sloppy part to the other tracks, you probably do not need to generate Bar|Beat markers.

To generate Bar|Beat Markers with Beat Detective:

1. In the Edit window, make an audio selection.
2. In the Beat Detective window, select Bar|Beat Marker Generation mode.
3. Define or capture the selection as described in “Defining a Beat Detective Selection” on page 440.
4. Set the Detection resolution to Bars or Beats, and configure the Detection settings so the selection’s peak transients are accurately detected (see “Generating Beat Triggers” on page 442).
5. Click the Generate button.

Bar|Beat Markers are generated, based on the beat triggers, and appear in the Tempo ruler.

Working with Sub-Beats

Tempo is derived from Bar|Beat Markers. Groove, or feel, is derived from Sub-Beats—the deviation of subdivisions of the beat from the strict tempo grid determines the groove or feel.

To extract the groove from a selection, set the Detection Resolution to Sub-Beats. This ensures that the inner rhythms within each bar (if they indeed exist) are represented when generating
Bar|Beat Markers. These Bar|Beat Markers can then be used to quantize other audio regions or MIDI tracks, thereby conforming to the Bar|Beat Markers generated by Beat Detective.

⚠️ When quantizing regions or MIDI notes to Bar|Beat Markers on sub-beats that represent a swing feel, make sure to use a straight quantize value (with the Swing option for Quantize disabled).

### DigiGroove Templates

Beat Detective allows the fine timing nuances of a rhythmic performance to be extracted and saved as a groove template, called a DigiGroove template. DigiGrooves can be saved locally to the Groove Clipboard, or saved to disk as DigiGrooves.

Groove templates can be used to transfer the feel of a particular performance to:

- Selected audio regions using Groove Conform (see “Groove Conform” on page 453).
- Selected MIDI data using Groove Quantize (see “Groove Quantize” on page 489).

Groove templates are “quantization maps” derived from real musical performances. The rhythmic character of each performance is analyzed and stored as a groove template. Beat Detective analyzes an audio selection for transient peaks according to a defined threshold and maps the rhythmic relationships to a 960 parts per quarter note (ppq) template.

When creating DigiGroove templates, Beat Detective also analyzes the dynamics of a performance. MIDI velocity data is saved from MIDI tracks, and accents and peak levels in audio data are incorporated into the groove template as velocity data, which can be applied to change the dynamics of MIDI tracks.

Beat Detective translates the amplitude of signals in audio tracks to MIDI velocity according to a linear scale. For example:

- A 0 dBFS signal equals a MIDI velocity of 127.
- A signal at –6 dBFS equals a MIDI velocity of 64.
- A signal at –12 dBFS equals a MIDI velocity of 32.
- A –48 dBFS equals a MIDI velocity of 1.

Capturing this information is very important to preserving the feel of a performance, and can add life to MIDI tracks that lack dynamics.

⚠️ Beat Detective only captures duration data from MIDI tracks, not from audio tracks.

### To extract a Groove Template:

1. In the Edit window, make an audio or MIDI selection. The selection should consist of one or more complete bars, starting and ending on downbeats.

2. In the Beat Detective window, select Groove Template Extraction mode.

3. Define or capture the selection as described in “Defining a Beat Detective Selection” on page 440.

4. Configure the Detection options so the selection’s peak transients are accurately detected (see “Generating Beat Triggers” on page 442).

5. Click the Extract button.
6 In the Extract Groove Template dialog, enter comments about the groove. You can enter a maximum of 255 characters to describe the groove. Comments can be viewed using the Show Info button in the Beat Detective window.

![Extract Groove Template dialog]

7 Do one of the following:

- To save the extracted template for use in the current session, without writing the template file to disk, click Save To Groove Clipboard. (This template will be lost when you close the current session.)
- To save the extracted template to disk in order to use it in other sessions or share it with other Pro Tools users, click Save To Disk. Enter a name for the template and click Save. (Do not change the location of DigiGroove template files and folders or they will not be available in your sessions.)
- Click Cancel to cancel without saving the template.

Swing Content for Generating Groove Templates

When defining swing content of the selection, select the Contains eighth-note option if the audio selection has a heavily swung eighth-note groove. If the audio selection has relatively straight eighth-notes, use the Contains sixteenth-note option. This lets the resultant DigiGroove template be applied more easily elsewhere. Although a groove might be based upon non-swung eighth-note material, you might want to apply the template to material that contains sixteenth-notes. If a template only has eighth-note resolution, but the material being conformed contains sixteenth-notes, adjacent sixteenth-notes will be mapped to the same eighth-note location.

Groove Extrapolation

Beat Detective's ability to extract tempo data from a wide range of material is enhanced by its powerful “groove extrapolation” logic. Groove extrapolation automatically generates beat triggers for inclusion in groove templates even if a peak transient is not detected. For example, a drum loop might not have a hit on beat 3, consequently no peak transient is detected and no beat trigger is generated. Beat Detective will extrapolate from other beat triggers in the selection and create a trigger for beat 3 in the groove template.

In addition, extrapolated triggers preserve the feel of triggers generated from detected peak transients. For example, if a bar of kick drum detected three beat triggers, all of which were 20 ticks ahead of the beat, any extrapolated beat triggers will also be mapped 20 ticks ahead of the beat.
Separating Regions with Beat Detective

(Audio Only)

Once beat triggers appear in your selection, they can be used to define start and end points for new regions that can be separated automatically. The new regions can then be conformed to the session’s existing tempo map, or to a groove template.

If you want to clean up the timing for the selection, without affecting the tempo, make sure to first calculate the tempo by generating Bar|Beat Markers (see “Calculating Tempo with Beat Detective” on page 441).

To separate regions with Beat Detective:

1. In the Edit window, make an audio selection.
2. In the Beat Detective window, select Region Separation mode.
3. Define or capture the selection as described in “Defining a Beat Detective Selection” on page 440.
4. Configure the Detection options so the selection’s peak transients are accurately detected (see “Generating Beat Triggers” on page 442).
5. Click the Separate button.

Regions are separated based on the detected beat triggers.

Trigger Pad

When separating regions, the Beat Detective window displays an option called Trigger Pad.

Detection settings, Region Separation mode

Enter a value (0–50 ms) in this field to pad region start points—where the point of separation is located in relation to the beat trigger (transient). This creates a space between the region start point and the region sync point, thereby ensuring that the attack portion of the material remains intact.

Separated region with 20 ms Trigger Pad

When conforming separated regions, the region sync point, not the region start point, determines where the region is placed.

For more information on region sync points, see “Sync Points” on page 344.
Separating Multiple Tracks  
(Pro Tools HD and Pro Tools LE with Music Production Toolkit Only)

You can use beat triggers from a single track, or subset of tracks, to separate a group of tracks.

⚠️ **Beat Detective LE cannot be used across multiple tracks without the Music Production Toolkit option. When Beat Detective LE (without the Music Production Toolkit option) is applied to multiple tracks, only the top track is edited.**

In the following example, the defined selection is a drum loop consisting of two bars of 5/4. The kick, snare, hi-hat, and overhead microphones are recorded to separate tracks.

Analyzing the loop’s kick drum track, with Detection Resolution set to Beats, Beat Detective places beat triggers at the transients on beats 1 and 4 (see Figure 17).

Extending the selection to the snare, hi-hat, and overhead microphones tracks, and then performing the separation, results in separated regions in each of the drum tracks at the same location, based on the beat triggers from the kick drum track (see Figure 18).

The separated regions can then be conformed as a group.

You can also utilize Collection mode (Pro Tools HD and Pro Tools LE with Music Production Toolkit only) when working with multiple tracks. Collection mode lets you analyze and detect triggers on tracks individually, and if you choose, add only the unique triggers from the current track to the overall collection. For more information, see “Detection (Normal) and Collection Mode” on page 456.
Conforming Regions with Beat Detective

(Audio Only)

After regions have been separated with Beat Detective, the regions can then be conformed using one of two modes:

**Standard Conform** Uses the session’s current tempo map (Grid)

**Groove Conform** Uses groove templates.

Beat Detective will conform any selected region, whether or not it was separated with Beat Detective. However, in order to successfully conform regions with Beat Detective, the region start points must correspond to the start of the material that will align with the session’s bars and beats. This should generally not be a problem if the regions were separated with Beat Detective (rather than manually separated or trimmed).

**Standard Conform**

This is similar to using the Region > Quantize to Grid command, but with one important difference: With a single operation, Beat Detective can adjust the position of all regions, whether they have a straight or swing feel.

To conform regions using Standard Conform:

1. In the Beat Detective window, select Region Conform mode.
2. Make sure Standard is selected.
3. In the Edit window, if not already selected, select the separated regions you want to conform. Make sure the selection’s start and end points fall cleanly on the beat.
4. In the Beat Detective window, define or recapture the selection as described in “Defining a Beat Detective Selection” on page 440.
5. To affect how strongly the regions are conformed to the Grid (tempo map), select the Strength option and specify a percentage value with either the slider or by typing in a value:
   - Lower percentage values preserve the original feel of the regions.
   - Higher percentage values align the regions more tightly to the tempo map, with 100% aligning precisely to the tempo map.
6. To affect which regions are conformed, select the Exclude Within option and specify a percentage value with the slider or by typing in a value:
   - Lower percentage values ensure that regions further away from the Grid are conformed, while those closer to the Grid are not.
   - Higher percentage values ensure that regions closer to the Grid, as well as those further away, are conformed.

To “tighten up” the original feel, while retaining it, set the Strength option to 85–88%.

To “tighten up” the original feel, while retaining it, set the Exclude Within option to 10–15%.
To achieve a swing feel for the conformed regions, select the Swing option and whether the swing is based on eighth-notes or sixteenth-notes, then specify a percentage value with the slider or by typing in a value:

- Smaller percentage values yield less swing, with 0% yielding none.
- Larger percentage values yield more swing, with 100% yielding a triplet, swing feel.
- Percentage values between 100–150 move the regions beyond a triplet, swing feel, toward the next sixteenth-note boundary (provided the Swing note value is set to eighth-notes).

Click the Conform button to automatically conform all regions in the selection.

Audition the new conformed regions by clicking Play in the Transport window.

Do one of the following:

- If necessary, select Edit > Undo, and repeat steps 4–8 trying a different set of Conform settings.
- or –
- If necessary, apply Edit Smoothing (see “Edit Smoothing” on page 454).

### Groove Conform

Instead of using a grid based on the session’s tempo map, Groove Conform uses a grid based on a groove template, or DigiGroove. DigiGrooves can be used to apply the feel of a captured passage to the selected audio regions. For information about creating DigiGroove templates, see “DigiGroove Templates” on page 448.

To conform regions using Groove Conform:

1. In the Beat Detective window, select Region Conform mode.
2. Select Groove.

### Beat Detective, Groove Conform options

3. In the Edit window, if not already selected, select the separated regions you want to conform. Make sure the selection’s start and end points fall cleanly on the beat.

4. In the Beat Detective window, define or recapture the selection as described in “Defining a Beat Detective Selection” on page 440.

When using Groove Conform, the captured selection must not include Bar|Beat Markers. Otherwise, the accuracy of the Groove Template will be compromised.

5. From the Groove Template pop-up menu, select the Groove Clipboard or a saved groove template (for information on creating groove templates, see “DigiGroove Templates” on page 448).
To see comments about the selected template, click Show Info.

To affect how strongly the regions are conformed to the groove template, select the Timing option and specify a percentage value with either the slider or by typing in a value:
- Lower percentage values preserve the original feel of the regions.
- Higher percentage values align the regions more tightly to the groove templates grid, with 100% aligning precisely to the template grid.
- If the slider is set to 200%, regions move to a location that is twice the difference between the original region location and the position of the referenced template event.

For example, if a note was played at Bar 1|1|060 (a 16th note), and the corresponding template event is at 1|1|073, a slider value of 100% results in the note being shifted to 1|1|073; a slider value of 200% shifts the note to 1|1|086.

If desired, enable the Pre-Process using Standard Conform option. With this option enabled, Beat Detective conforms regions to the current Standard Conform settings before applying the groove template. With material in which the performance was not accurate, Pre-Process using Standard Conform can lead to better results by ensuring that the performance is accurately mapped to the correct bars, beats, and sub-beats before the groove template is applied. Experimentation is the best way to determine when it is appropriate to use this option.

When conforming an audio passage to a heavily swung groove template, enabling Pre-Process using Standard Conform will often yield better results.

Click the Conform button to automatically conform all regions in the selection.

Audition the new conformed regions by clicking Play in the Transport window.

Do one of the following:
- If necessary, select Edit > Undo, and repeat steps 4–9 trying a different groove template or Groove Conform settings.
- If necessary, apply Edit Smoothing (see “Edit Smoothing” on page 454).

**Edit Smoothing**

(Audio Only)

After regions are conformed, there may be gaps between the regions. These gaps can cause the material to sound unnatural on playback.

![Smoothing](image)

**Beat Detective, Smoothing options**

Beat Detective can automatically fill the gaps between regions, and even add crossfades if you choose. This Edit Smoothing option can be used with regions that have been conformed, or with a track that contains many regions that need to be trimmed and crossfaded (such as in a sound effects track). This automated process of smoothing region edits can save many hours of tedious editing.
To use Edit Smoothing on conformed regions:

1. In the Beat Detective window, select Edit Smoothing mode.

2. Select a Smoothing options:
   - **Fill Gaps** Select this option to trim region end points so that the gaps between regions are filled.
   - **Fill And Crossfade** Select this option to trim region end points and automatically add a pre-fade (in ms) directly before each region start point.

3. In the Edit window, if not already selected, select the range of conformed audio regions you want to smooth. Make sure the selection’s start and end points fall cleanly on the beat.

4. Click the Smooth button to smooth the edits for the selected regions.

5. Audition the results by clicking Play in the Transport window.

6. If necessary, select Edit > Undo, and repeat steps 2–5 trying a different Crossfade Length.

---

**Edit Smoothing Creates Sync Points**

After smoothing edits with Beat Detective, sync points (corresponding to the material’s start point) are automatically created for the conformed regions. This allows you to later conform the regions to a different tempo map or groove template, or use different Conform settings. However, sync points are only created as they are needed: If gaps between regions are created during Region Conform, Fill Gaps in Edit Smoothing mode will trim regions to fill the gap and a sync point will be created at each region’s original start point. If there is no gap between regions, no sync point will be created by Edit Smoothing.

For more information on region sync points, see “Sync Points” on page 344.

**Consolidating Regions after Edit Smoothing**

The process of separating, conforming, and smoothing with Beat Detective can leave tracks with many regions and many crossfades. If you are working with multiple tracks, the density of these edits may lead to system performance problems.

*If performance is not an issue, use the Region Group command for easier editing and manipulation of regions. This can be useful for arranging beats that were sliced with Beat Detective, especially if you plan on changing tempos with tick-based audio tracks. For more information on region groups, see “Region Groups” on page 362.*
Once you are satisfied with the results from Beat Detective, it is recommended that you flatten the tracks with the Consolidate command. For all regions selected, Consolidate creates a single, contiguous audio file to reduce the session’s edit density. See “Consolidate Command” on page 395.

⚠️ Before consolidating a large selection across multiple tracks, make sure there is enough RAM available. See “RAM Requirements for Beat Detective” on page 438.

**Detection (Normal) and Collection Mode**

*(Pro Tools HD and Pro Tools LE with Music Production Toolkit Only)*

In some instances, it may be difficult for Beat Detective to successfully analyze multiple tracks with the same Detection settings. With Beat Detective’s Collection mode, you can collect a set of beat triggers from different tracks, each with different Detection settings, and use the collection of triggers to generate Bar|Beat Markers or DigiGroove templates, or separate new regions. Collection mode is the only way to analyze and create beat triggers on one track, and apply them to another track.

This method of selectively adding beat triggers from separate analysis passes on different tracks, until you get only the triggers you want, is potentially much more effective than manually deleting, inserting, or adjusting incorrect or false triggers.

⚠️ Beat Detective LE does not support Collection Mode without the Music Production Toolkit option.

**Drum Tracks and Collection Mode**

Suppose you have drum tracks for kick, snare, hi-hat, and overhead mics. If you analyze a selection across all of the tracks, you may get many false triggers when you raise the Sensitivity slider high enough to capture the hi-hat material (coming mainly from the tracks for the overhead mics).

However, if you analyze only the track for the overhead mics, the resulting beat triggers are slightly later than the material on the other tracks (since it will take more time for the sound to reach the overhead mics). If you then extend the selection to the other drum tracks and separate them, the regions from the kick, snare, and tom tracks will be cut slightly late (see Figure 19 below).

![Figure 19. Overhead mics generate late beat triggers](image)

Using Collection mode, you can analyze each drum track separately, one at a time, optimizing the Detection settings for each track until you get the triggers you want. The triggers for each track can be added successively to the collection, or you can choose to collect only the unique triggers from a track. The collection of triggers that results can then be used to generate Bar|Beat Markers or a DigiGroove template, or separate new regions.
Using Collection Mode

Collection mode is available in Bar|Beat Marker Generation, Groove Template Extraction, or Region Separation mode (audio only), and is accessed by clicking the Collection Mode button in the Detection section.

To use Collection mode:
1. In the Edit window, make an audio selection on a single track. Make sure the selection’s start and end points fall cleanly on the beat.
2. In the Beat Detective window, select one of the following modes:
   - Bar|Beat Marker Generation
   - Groove Template Extraction
   - Region Separation (audio only)
3. Define or capture the selection as described in “Defining a Beat Detective Selection” on page 440.
4. Configure the Detection options so the selection’s peak transients are accurately detected (see “Generating Beat Triggers” on page 442).
5. Click the Collection Mode button.
6. In the Detection (Collection Mode) section, click Add to add all the current beat triggers to the collection.
7. Click the Normal Mode button and move the selection to the next track you want to analyze. Make sure to keep the selection range constant for each track.
   - Press Start+P (Windows) or Control+P (Mac) to move the selection up, or Start+Semi-colon (Windows) or Control+Semi-colon (Mac) to move the selection down.
   - With Commands Keyboard Focus enabled, press “P” to move the selection up, or Semi-colon (;) to move the selection down. Hold down the Shift key to retain and add to the current selection.
8. Configure the Detection options so the selection’s peak transients are accurately detected (see “Generating Beat Triggers” on page 442).
9. Click the Collection Mode button again.
10. Do one of the following:
   - In the Detection (Collection Mode) section, click Add Unique Triggers to add only the unique triggers from the track to the collection.
   - Click Add All to add all triggers to the collection.
   - Click Clear All to clear all triggers from the collection.

Each new set of triggers added to the collection appears in a different color. If successive triggers in the collection are located closely together (for example, because of microphone leakage), Beat Detective keeps only the earlier triggers (see Figure 20 on page 458).

11. Repeat steps 7–10 for each additional track you are analyzing.
The beat triggers stored in the Collection mode are saved with sessions. Therefore, when a session is opened later, the previous collection material is still there (until it is cleared).

Once the desired beat triggers have been added to the collection, you can use them to generate Bar|Beat Markers or groove template, or separate regions. However, this must be done from the Collection Mode section (when the triggers are displayed in multiple colors).

To separate regions across multiple tracks, make sure to extend the selection to any additional tracks before separating.
Part V: MIDI Editing
Chapter 22: MIDI Editing

Pro Tools provides powerful MIDI editing tools. You can create and edit individual MIDI notes and controller events with the Pencil, Trim, and Grabber tools in the Edit window. You can use the various MIDI operations (such as Quantize, Transpose, Change Velocity, and Change Duration) to destructively transform groups of MIDI notes to affect pitch, timing, and phrasing. You can also use Real-Time Properties to non-destructively affect MIDI on playback or playthrough. Pro Tools also provides numerous zoom and view tools that are optimized for MIDI editing.

For information on region-specific editing for both MIDI and audio, see Chapter 17, “Working with Regions and Selections.”

Mirrored MIDI Editing

Mirrored MIDI Editing lets you edit MIDI regions and have your edits apply to every MIDI region of the same name. This can be particularly useful when editing looped MIDI regions.

To enable Mirrored MIDI Editing, do one of the following:
- Select Options > Mirror MIDI Editing.
- Enable the Mirrored MIDI Editing button in the Edit window.

In Mirrored MIDI Editing mode, the Mirrored MIDI Editing button will blink Red once as an edit is made to alert you that your edit is being applied to more than one region.

To disable Mirrored MIDI Editing, do one of the following:
- Deselect Options > Mirror MIDI Editing.
- Disable the Mirrored MIDI Editing button in the Edit window.

⚠️ If Mirrored MIDI Editing mode is disabled, and you edit notes of looped regions in Notes View, the edit flattens the loop. Similarly editing region groups separates the region groups.
The Pencil Tool

The Pencil tool is useful for creating and editing MIDI data. The first five Pencil tool shapes (Freehand, Line, Triangle, Square, and Random) can be used to enter pitches with varying durations and velocities (note velocities are determined by the Pencil tool shape). The various Pencil tool shapes can be particularly useful for drawing and editing different types of MIDI control data—for example, try using Line for volume, Triangle for pan, Freehand for pitch bend, and Square or Random for velocity.

Freehand

When in Notes View, the Freehand shape inserts a single MIDI note whose velocity is defined by the Default Note On Velocity MIDI preference. The pitch, location, and duration of the note are determined by where on the MIDI track you click and release with the mouse.

When editing MIDI velocities or continuous controller data, the Freehand shape draws freely according to the movement of the mouse. The shape is reproduced as a series of steps according to the Pencil Tool Resolution When Drawing Controller Data MIDI preference.

Line

When in Notes View, the Line shape inserts a series of MIDI notes on a single pitch whose velocities are defined by the Default Note On Velocity MIDI preference. The duration of each note is determined by the current Grid value.

When editing MIDI velocities or continuous controller data, the Line shape draws in a straight line from click to release. MIDI continuous controller values change in steps according to the Pencil Tool Resolution When Drawing Controller Data MIDI preference.

Triangle

When in Notes View, the Triangle shape inserts a series of MIDI notes on a single pitch whose velocities oscillate between the defined Default Note On Velocity MIDI preference and 127 according to a triangle pattern. The duration of each note is determined by the current Grid value.
When editing MIDI velocities or continuous controller data, the Triangle shape draws a triangular pattern that changes direction according to the current Grid value. MIDI controller values change in steps according to the Pencil Tool Resolution When Drawing Controller Data MIDI preference.

**Square**

When in Notes View, the Square shape inserts a series of MIDI notes on a single pitch whose velocities alternate between the defined Default Note On Velocity MIDI preference and 127. The duration of each note is determined by the current Grid value.

When editing MIDI velocities or continuous controller data, the Square shape draws a square pattern that repeats at a rate based on the current Grid value.

**Random**

When in Notes View, the Random shape inserts a series of MIDI notes on a single pitch whose velocities change randomly within the range between the defined Default Note On Velocity MIDI preference and 127. The duration of each note is determined by the current Grid value.

When editing MIDI velocities or continuous controller data, the Random shape draws a series of random values that change at a rate based on the current Grid value.

---

**Custom Note Duration**

The Custom Note Duration command lets you define the default note duration for inserting notes manually.

**To select a Custom Note Duration:**

1. Click the Pencil tool icon in the Tool Bar for the Pencil tool shape pop-up menu.
2. Select Custom Note Duration. A note icon (the Custom Note Duration button) will appear below the Pencil tool icon in the Tool Bar.
3. Click the note icon for the Custom Note Duration pop-up menu, and select a note duration. The note icon changes to show the selected note value.

![Custom Note Duration pop-up menu](image)
Setting the Grid Value

When inserting MIDI notes with the Pencil tool, the Grid value determines the duration of each note, or other characteristics, based on the Pencil tool shape (see “The Pencil Tool” on page 462).

To set the Grid value for MIDI editing:

1. Set the Main Time Scale to Bars:Beats (see “Setting the Main Time Scale” on page 267).
2. From the Grid Value pop-up menu, select a note value (such as 1/4, 1/8, or 1/16).
3. Verify the default session meter and tempo (see “Setting the Default Meter” on page 194 and “Setting the Default Tempo” on page 195).

For more information on Grid mode, see “Grid” on page 282.

Inserting MIDI Notes

In addition to recording, step recording, and importing MIDI into Pro Tools, you can manually insert MIDI notes using the Pencil tool.

To insert a MIDI note:

1. Set the MIDI or Instrument track to Notes View.
2. Select the Pencil tool and make sure it is set to Freehand. The cursor will change to the Pencil tool when located over the playlist area of a MIDI or Instrument track in Notes View.
3. To insert quarter notes on the beat, set the Main Time Scale to Bars:Beats, and set the Edit mode to Grid and the Grid value to quarter notes (0|1|000).
4. Move the Pencil tool into the playlist area for the MIDI or Instrument track. Use the Edit window’s ruler and the track’s mini-keyboard to locate the pitch and time location you want.

When using the Pencil tool, the Cursor location and value are displayed in the Options Bar.

With the Smart Tool active (see “Using the Smart Tool” on page 294), Start-click (Windows) or Control-click (Mac) to change the cursor to the Pencil tool and insert MIDI notes; Option-Control-click (Mac) or Alt-Start-click (Mac) to delete notes.

With the Grid mode enabled, the start point of the MIDI note snaps to the nearest Grid boundary by default. Control-click (Windows) or Command-click (Mac) with the Pencil tool to temporarily disable snap to grid.
The velocity for inserted notes is determined by the Default Note On Velocity MIDI preference. When in Grid mode, the duration of the note is determined by the Edit window’s Grid value. The duration of the note can also be determined by the Custom Note Duration value (see “Custom Note Duration” on page 463).

If the Play MIDI Notes when Editing preference is enabled, each inserted note will sound.

The Pencil tool can be dragged after clicking (and before releasing) to adjust the note’s pitch or duration. Click and drag right to lengthen the note without changing its start point. Click and drag left to shorten the note without changing its end point.

The Line, Triangle, Square, and Random Pencil tool shapes can be used to enter a series of identical pitches with varying velocities. The length and spacing for the inserted notes are determined by the current Grid value, or by the Custom Note Duration value. The note velocities are determined by the Pencil tool shape.

Use the Square shape for alternating velocities of loud and soft. Use the Triangle shape for a ramp up and down of velocities. The Line shape enters notes with identical velocities.

To insert a series of notes with random velocities:

1. Set the MIDI or Instrument track to Notes View.
2. Select the Pencil tool and make sure it is set to Random.
3. Set the Main Time Scale to Bars:Beats. In addition, set the Edit mode to Grid and the Grid value to quarter notes (0|1|000).
4. Click at the point where the first note will be inserted and drag to the right until you have the number of notes you want.

Manually Editing MIDI Notes

All aspects of a MIDI note can be edited from the Edit window, including start and end points, duration, pitch, and velocity. The Selector, Grabber, and Pencil tools can operate on individual notes or groups of notes.

Selecting MIDI Notes

MIDI notes must be selected, before they can be edited.
To select MIDI notes, do one of the following:

- With the Pencil tool or any Grabber tool, Shift-click each note.
- With any Grabber tool, move the cursor to where there are no notes (the Marquee appears) and click and draw a rectangle around the group of notes.

When using a Grabber tool, if any portion of the rectangle touches a note (either its start or end point), the note is included in the selection. Selections made with a Grabber tool do not include underlying controller and automation data for the MIDI track.

- With the Selector tool, drag across a range of notes.

To select a single pitch for the entire length of a track:

- Start-click (Windows) or Command-click (Mac) a key on a MIDI or Instrument track’s mini-keyboard. The selected note will playback through the MIDI or Instrument track’s assigned output.

To select a range of notes on a MIDI or Instrument track, do one of the following:

- Start-Shift-click (Windows) or Command-Shift-click (Mac) a bottom key and a top key on a MIDI or Instrument track’s mini-keyboard.
  
  – or –

- Start-click (Windows) or Control-click (Mac) and drag across a range of keys on a MIDI or Instrument track’s mini-keyboard.

To deselect one or more notes from a selection:

- With the Pencil tool or any Grabber tool, Shift-click the notes so they become deselected.

On Windows, Control-Shift-click to play the notes when making a selection on a track’s mini-keyboard.

You can also select notes in the Select/Split Notes window. See “Select/Split Notes” on page 501.
Transposing Notes

MIDI notes can be transposed by dragging up or down with the Pencil tool or any Grabber tool. If several notes are selected before dragging, each is transposed.

To transpose a MIDI note:
1. Set the MIDI or Instrument track to Notes View.
2. Select the Pencil tool or any Grabber tool.
3. While pressing Shift, drag the note up or down.

The Shift key ensures that the transposed note retains its start point. While dragging, each new note sounds and the Cursor Location Value indicator (in the Edit window) indicates the number of semitones and direction (+/−) for the transpose.

Moving Notes

Like regions, MIDI notes can be dragged left or right with the Pencil tool or any Grabber tool to change their start point. If several notes are selected before dragging, each is moved.

To move a MIDI note:
1. Set the MIDI or Instrument track to Notes View.
2. With the Pencil tool or any Grabber tool, drag the note left or right (press Shift while dragging to preserve the note’s pitch).

As the note is dragged, the Cursor Location Value indicator (in the Edit window) displays the new start point.

If the Edit mode is set to Grid, the dragged note snaps to the nearest Grid boundary. If the Edit mode is set to Spot, the Spot dialog opens.

Trimming Note Start and End Times

Like regions, start and end points for MIDI notes can be adjusted with the Trim tool. If several notes are selected when performing the trim, each note is changed.

To change the start or end points for a group of MIDI notes:
1. Set the MIDI or Instrument track to Notes View.
2. Using the Pencil tool or any Grabber tool, Shift-click each note you want to trim.
3 Do one of the following:
   • Select the Trim tool. Click the Trim tool pop-up menu and, if necessary, select “Standard.”

   – or –
   • Use the Pencil tool.

4 Do one of the following:
   • Move the cursor near the beginning of any of the highlighted notes, so the Trim tool appears. Drag right to shorten the notes, or drag left to lengthen them.

   – or –
   • Move the cursor near the end of any of the highlighted notes, so the Trim tool appears. Drag left to shorten the notes, drag right to lengthen them.

If using Grid mode, the dragged start or end point snaps to the nearest Grid boundary. If using Spot mode, the Spot dialog opens, where you can enter the new location for the note’s start or end point.

Notes can also be trimmed with the Trim Region to Selection command (see “Trim Region to Selection Command” on page 331) and the Trim To Insertion command (see “Trimming with Nudge” on page 332).

Manually Editing Note Velocities

When a MIDI or Instrument track is set to Velocity View, each note’s attack velocity is represented with a velocity stalk. The taller the velocity stalk, the higher the velocity value (0–127).

To edit MIDI velocity:

1. Set the MIDI or Instrument track to Velocity View.

2. Select any Grabber tool.

3. Do one of the following:
   • Drag the top (diamond) of the velocity stalk up or down.

   – or –
   • If two notes have the same start time (with velocity stalks on top of each other), Control-drag (Windows) or Command-drag (Mac) the actual note up or down.
Drag up to increase the velocity value, or down to decrease it. While dragging, the diamond turns blue and the associated note becomes selected. The dragged velocity values are reflected in the Cursor Location Value indicator (in the Edit windows).

The velocities for a range of notes can be edited with the Pencil tool, either by Freehand or with any of the Pencil tool shapes.

**To draw velocity values that fade in:**

1. Set the MIDI or Instrument track to Velocity View.
2. Select the Pencil tool with the shape set to Line.
3. Click at the beginning of the note range, near the bottom of the velocity range, and drag to the right and up until the line encompasses the range of notes you want to include in the fade.

You can also use the Trim tool to scale the velocities for all selected notes. This is useful if you like the velocity relationship between the notes, but want them to be louder or softer.

*When in Velocity View, the Trim tool can be used to trim note durations in addition to changing velocities.*

**To scale velocities with the Trim tool:**

1. Set the MIDI or Instrument track to Velocity View.
2. Using the Selector tool or any Grabber tool, select the range of notes to be edited.
3. With the Trim tool, click near the range of selected notes and drag up or down. Dragging up increases the velocities for each note; dragging down decreases them.

**Typing in Note Attributes**

When an individual note is selected with the Pencil tool or any Grabber tool, its attributes are displayed in the Event Edit area.

Pitch is listed by note name and octave number. Attack and release velocities are listed with their MIDI values (0–127). Edit Selection Start, End, and Length times are displayed in the Main Time Scale.

**To change an attribute for a MIDI note:**

1. In the MIDI or Instrument track’s playlist area, select the note with the Pencil tool or any Grabber tool.
2. Click in the Attributes text box and do one of the following:
   - Enter the new value on the numeric keypad.
   - Press the Up or Down Arrow to scroll to the new value.
   - Drag up or down to scroll to the new value.
   - Play the new note value on your MIDI controller keyboard.
Press Forward Slash (/) to move between the fields in the Event Edit area.

You can also change attributes of MIDI notes in the MIDI Event List (see Chapter 24, “MIDI Event List”).

Multiple Notes and Event Edit Area

When multiple notes are selected, you can enter values in the Event Edit area fields to affect all selected notes. A triangle (delta symbol) to the left of the displayed note indicates that multiple notes are selected.

A new value in the Start field moves the first note in the selection to that location, with all other notes moving with it.

Values entered in the pitch and velocity fields add to or subtract from the values for all selected notes. For example, to transpose all selected notes down an octave, enter a value of –12 for pitch.

Deleting MIDI Notes

In addition to deleting selected notes with the Clear command in the Edit menu, individual notes can also be deleted with the Pencil tool.

To delete a group of MIDI notes with the Clear command:

1. Using the Grabber or Selector tool, select the notes to be deleted. For details, see “Selecting MIDI Notes” on page 465.

2. Do one of the following:
   - Choose Edit > Clear to delete the selected notes. The track’s underlying controller data remains intact.
   - or –
   - Press the Backspace (Windows) or Delete (Mac) key.

When deleting MIDI notes within a time range selection, all underlying controller and automation data is also deleted.

To delete a single MIDI note with the Pencil tool:

1. With the Pencil tool selected, press Alt (Windows) or Option (Mac) so the tool changes to an Eraser, then click the note to delete it.

   Program change events and Sysex events can also be deleted by Alt-clicking (Windows) or Option-clicking (Mac) them with the Pencil tool.

Time Compression/Expansion Trim Tool Functionality on MIDI Regions

The Time Compression/Expansion Trim tool is useful for matching a MIDI region to the length of another region, a tempo grid, or any other reference point.
With the Time Compression/Expansion Trim tool, you can move the MIDI region’s start or end point to expand or compress the region, scaling the MIDI data accordingly regardless of the track’s timebase (ticks or samples).

3 Click the Trim tool pop-up menu and select “TCE.”

4 With the Time Compression/Expansion Trim tool, drag the MIDI region’s start or end point to compress or expand the region to the Grid (for example, by quarter notes). A new region is automatically created, and appears both in the playlist and in the Region List.

**Using the Time Compression/Expansion Trim Tool in Slip Mode**

**To use the Time Compression/Expansion Trim tool in Slip mode:**

1 Set the Edit mode to Slip.

2 Set the MIDI or Instrument track to Regions View.

3 Click the Trim tool pop-up menu and select “TCE.”

4 With the Time Compression/Expansion Trim tool, drag the MIDI region’s start or end point to compress or expand the region freely. A new region is automatically created, which appears in the playlist and in the Region List.

**Using the Time Compression/Expansion Trim Tool in Spot Mode**

In Spot mode, clicking with the Time Compression/Expansion Trim tool in a region opens the Spot Dialog. You can specify the location where you want the region to start or end, or the duration of the region, and the region is automatically compressed or expanded as specified.

**To use the Time Compression/Expansion Trim tool in Spot mode:**

1 Set the Edit mode to Spot.

2 Set the MIDI or Instrument track to Regions View.

*Scaling a MIDI region with the Time Compression/Expansion Trim tool*

*Before trimming*

*After trimming*
3 Select “TCE” from the Trim tools pop-up menu.

4 Click the MIDI region near its start or end point. The Spot Dialog opens. Using any Time Scale, enter a new start or end time (or duration) for the region, then click OK. A new region is automatically created, which appears in the playlist and in the Region List.

Using the Time Compression/Expansion Trim Tool in Shuffle Mode

In Shuffle mode, the trimmed region will always begin at the original region’s start point regardless of whether you trim from the front to the rear or from the rear to the front.

To use the Time Compression/Expansion Trim tool in Shuffle mode:

1 Set the Edit mode to Shuffle.

2 Set the MIDI or Instrument track to Regions View.

3 Select “TCE” from the Trim tools pop-up menu.

4 With the Time Compression/Expansion Trim tool, drag the MIDI region’s start or end point to compress or expand the region freely. A new region is automatically created, which appears in the playlist and in the Region List.

Continuous Controller Events

Continuous controller events for MIDI and Instrument tracks are displayed in the form of a line graph with a series of editable breakpoints. Controller events for MIDI and Instrument tracks differ from automation data for audio tracks in that the breakpoints are stepped (instead of vector-based), where each breakpoint represents a single controller event.

Continuous controller events that can be inserted and edited in Pro Tools include:
- volume
- pan
- pitch bend
- aftertouch (mono)
- MIDI controllers, 0–127

Polyphonic aftertouch cannot be viewed in the Edit window. To view polyphonic aftertouch in Pro Tools, use the MIDI Event List (see Chapter 24, “MIDI Event List”).

MIDI controller #7 (volume) and #10 (pan) are treated by Pro Tools as automation data. This means that these controller events (along with Mutes) can be recorded and automated from the Mix window; in addition, each MIDI or Instrument track’s automation mode affects how these events are played back and recorded. While a MIDI track’s volume and pan (and mute) events can be suspended, all other controller events in the track always play. Instrument tracks support both MIDI volume, pan, and mute, and audio volume, pan, and mute.

To avoid overwriting existing MIDI volume and pan automation data, record in MIDI Merge mode. When recording in MIDI Merge mode, existing volume and pan data will play back while recording new MIDI data.

Continuous controller events (including volume and pan) can be recorded from an external MIDI controller (such as a keyboard or control surface), and they can be inserted in a MIDI track’s playlist using the Pencil tool or any Grabber tool.
Inserting and Editing Controller Events

Continuous controller events can be edited with any of the following methods:

◆ Individual breakpoints can be dragged with any Grabber tool to adjust their location or value.
◆ A group of selected breakpoints can be scaled up or down with any of the Trim tools.
◆ New controller events can be drawn in with the Pencil tool to replace existing events. Events can be drawn with the Pencil tool set to Freehand, or using any of the shapes (Line, Triangle, Square, or Random).
◆ Controller events can be copied and pasted, nudged, and shifted.

To copy continuous MIDI controller events and paste to a different MIDI controller, use Special Paste (Edit > Paste Special > To Current Automation Type). For example, you might want to use the same control data for volume and a cut-off filter, or for pan and pitch bend. For more information, see “Special Paste Function for Automation Data” on page 613.

Edits to volume data affect all tracks within an enabled Edit Group. This is not the case, however, for other controller playlists (such as pan). To insert and edit other controller types across all tracks in an Edit Group, press the Start key (Windows) or Control (Mac) while performing the edits.

Resolution for Inserted Controller Events

When inserting controller events with the Pencil tool, the density of the events is determined by the MIDI preference for “Pencil Tool Resolution When Drawing Controller Data.”

To set the Pencil tool resolution:

1. Choose Setup > Preferences, then click the MIDI tab.
2. Enter a value for “Pencil Tool Resolution When Drawing Controller Data.” The value range is from 1 to 100 milliseconds.
3. Click OK.

To edit a continuous controller event with the Pencil tool, the controller first has to be added to the Automated MIDI Controllers list.

The controller is automatically added to the Automated MIDI Controllers list when you record controller information from an external device.
To manually enable a continuous controller for automation:

1. Click the Track View selector for the MIDI or Instrument track you wish to edit, and select Add/Remove Controller from the controllers pop-up.

2. Choose the MIDI controller range for the controller that you wish to automate.

3. Choose the continuous controllers that you wish to automate from the list on the left, and click Add.

4. Click OK to close the Automated MIDI Controller dialog.

When you record continuous controller information from an external MIDI device, the controller is automatically added to the MIDI Controllers list.

---

**Patch Select (Program and Bank Changes)**

Each MIDI and Instrument track can have a default program change that is sent each time the track plays. Additional program changes can be inserted at any point within the track.

**About Program and Bank Changes**

The MIDI protocol lets you choose from a range of 128 programs (0–127). Most MIDI instruments have several banks of 128 programs. To specify a bank, a bank select message must be sent. Some instruments use Controller 0 to switch the bank while others use Controller 32; some use a combination of the two. The Patch Select dialog in Pro Tools lets you use either of these bank select messages when inserting a program change event. Check the manufacturer’s documentation for your MIDI device to see which Controller value it uses.

💡 If you do not know what bank select command your instrument uses, you can record MIDI to Pro Tools while making a bank change from the instrument. Then review the bank select information your instrument has recorded into Pro Tools in the MIDI Event List.

💡 Some older MIDI devices (such as the Kurzweil K1000) use a program change instead of a Bank Select message to switch banks. For these devices you may find it necessary to send two program change messages to access a particular program, where the first sets the bank and the second sets the program.
Default Program Change

The default program change for each MIDI track is specified by clicking on the Patch Select button, from either the Mix or Edit window. Once specified, the default program change message is sent to your instrument when playing the track.

To set the default program change for a MIDI or Instrument track:

1. From the Mix or Edit window, click the Patch Select button.

2. Do one of the following:
   - In the Patch Select dialog, select a program number.
   - If you are using patch name files, choose a bank from the pop-up menu in the upper left of the Patch Select dialog and select a patch name. See “Patch Names” on page 475.

3. Click Done.

Once selected, the program number (or patch name) appears in the Patch Select button in the Edit window.

Unlike recorded and inserted program change events, the default program change does not appear in the track's playlist.

To clear the default program change, select None in the Patch Select dialog.

Patch Names

Pro Tools supports XML (Extensible Markup Language) for storing and importing patch names for external MIDI devices (such as MIDI instruments). Pro Tools installs MIDI patch name files (.midnam) for the factory default patch names of many common MIDI devices. These files reside in directories, sorted by manufacturer, in Program Files\Common Files\Digidesign\MIDI Patch Names\Digidesign (Windows) and /Library/Audio/MIDI Patch Names/Digidesign (Mac).
To import MIDI patch names into Pro Tools:

1. Choose Setup > MIDI > MIDI Studio, and verify the MIDI Device definition in the MIDI Studio Setup window (Windows) or Audio MIDI Setup (Mac).

2. Verify the MIDI track’s output is correctly assigned to the MIDI device.

3. Click the MIDI track’s Patch Select button.

4. In the Patch Select dialog, click the Change button.

5. In the Open dialog, navigate to Program Files\Common Files\Digidesign\MIDI Patch Names\Digidesign\<name of manufacturer> (Windows) or /Library/Audio/MIDI Patch Names/Digidesign/<name of manufacturer> (Mac) and select the MIDI Patch Name file (.midname) for the MIDI device.

6. Click Open.

7. The Patch Select dialog will be populated with patch names and the Patch Name Bank pop-up menu will appear in the upper left hand corner of the window.

See the Getting Started Guide for complete steps on configuring MIDI on Windows and Mac systems.

To clear patch names:

- In the Patch Select dialog, click the Clear button, and click Done.

Pro Tools will not let you import a patch name file that does not match the model and manufacturer information that you have selected in the MIDI Studio Setup window (Windows) or in AMS (Mac).

MIDI patch name files (.midname) can be edited in any text editor, or you can use third party patch librarian and editor software to create your own custom patch names.
**Inserting and Editing Program Changes**

Program changes can be inserted into a track’s playlist with the Pencil tool. Existing program changes can be edited, moved, and copied and pasted.

On some instruments, changing programs during playback can interrupt playback. To avoid this, place program change events in the track where there are no notes sounding.

**To insert a program change with the Pencil tool:**

1. Set the MIDI or Instrument track to Program Change view.
2. If you want the inserted event to snap to a Grid value, set the Edit mode to Grid.
3. Click with the Pencil tool in the track’s playlist at the point where you want to insert the program change.
4. In the Patch Select dialog, select a program number (or name) and, if necessary, specify a bank change value.
5. Click Done to insert the program change event in the track’s playlist.

**To edit a program change event:**

1. With the Pencil tool or any Grabber tool, double-click the program change event you want to edit.
2. In the Patch Select dialog, select the new program number (or name) and, if necessary, specify a bank change value.
3. Click Done.

**To move a program change event:**

- With the Pencil tool or any Grabber tool, drag the program change event left or right.

If the Edit mode is set to Grid, the dragged event snaps to the nearest Grid boundary. If the Edit mode is set to Spot, the Spot dialog opens.

The placement of program changes can also be adjusted with Shift (see “Shift Command” on page 347) or Nudge (see “Nudging” on page 345).

**To delete a program change event:**

1. Do one of the following:
   - With the track set to Program Change View, click the program change event with any Grabber tool to select it.
   - or –
   - If the region contains other events you want to delete, select the entire region with any Grabber tool (when the track is displaying regions).
2. Do one of the following:
   - Choose Edit > Clear to remove the selected events from the track.
   - or –
   - Press the Backspace (Windows) or Delete (Mac) key.

Individual program change events can also be deleted by Alt-clicking (Windows) or Option-clicking (Mac) them with the Pencil tool.

Program change event
Auditioning Programs

When the Patch Select dialog is open, Pro Tools can automatically scroll through the different patches for a track’s assigned MIDI device.

To audition patches:

1. If you want to audition patches for a MIDI track or Instrument during playback, click Play in the Transport window.
2. Open the Patch Select dialog by clicking the Patch Select button, or by inserting or editing a program change event in a MIDI or Instrument track.
3. Click a program number—the starting point from which you will scroll through the patches.
4. Enter a value for the number of seconds that will elapse between each program change.
5. Select the option for Increment Patch.

After the specified number of seconds, Pro Tools selects the next patch and transmits the program change to the track’s assigned MIDI device.

6. When you are finished auditioning settings, click Done to stop incrementing patches, and to close the Patch Select dialog.

System Exclusive Events

System Exclusive (Sysex) events can be recorded to MIDI or Instrument tracks in Pro Tools (see “MIDI Step Input” on page 228). Once the events are recorded, they appear in the track’s playlist as blocks when the Track View is set to Sysex.

While the contents of recorded System Exclusive events cannot be directly edited in Pro Tools, the events can be moved or nudged, copied and pasted, or deleted.

To move a Sysex event:

1. Set the MIDI or Instrument track to Sysex View.
2. With any Grabber tool, drag the Sysex event left or right.

If the Edit mode is set to Grid, the dragged event snaps to the nearest Grid boundary. If the Edit mode is set to Spot, the Spot dialog opens.

The placement of Sysex event blocks can also be adjusted with Shift (see “Shift Command” on page 347) or Nudge (see “Nudging” on page 345).

To delete one or more Sysex events:

1. Do one of the following:
   - With the track to Sysex View, click the Sysex event with any Grabber tool to select it.
   - or –
   - If the region contains other Sysex events you want to delete, select the entire region with any Grabber tool (when the track is displaying regions).
2 Do one of the following:

- Choose Edit > Clear to remove the selected events from the track.
- or –
  
- Press the Backspace (Windows) or Delete (Mac) key.

Note and Controller Chasing

Note Chasing

Note Chasing allows long, sustained MIDI notes to be heard when playing from a point after their start time. For example, if a note’s start time is at 1|1|000 and lasts for 8 measures (until 9|1|000), note chasing lets you begin playing from bar 5 and still hear the note that started at 1|1|000 as it continues to sustain until 9|1|000.

Note Chasing is something that can turned on and off individually for each MIDI or Instrument track. By default, new MIDI and Instrument tracks have Note Chasing enabled.

To enable Note Chasing for a MIDI track:

- Click the track’s Playlist selector and select the option for Note Chasing.

Make sure to disable Note Chasing when working with samplers that are playing loops. If a MIDI track, for example, is triggering a 4-bar drum loop and you begin playing at bar 3, the loop will begin playing at the wrong time and be out of synchronization with the other tracks.

Controller and Program Chasing

Pro Tools always chases continuous controller events and program changes for MIDI tracks. This ensures that controller values and patches for MIDI devices are always appropriately set.

For example, suppose a MIDI track lasting 32 measures starts with a volume of 127 and in the last bar fades the volume down to 0. If after playing the track in its entirety you attempt to play from bar 8, the initial volume of 127 is chased and sent to the track’s assigned device—otherwise the track would not be heard since the most recent volume event sent would have been 0.

Chasing also occurs for a MIDI track’s default program change, along with any program change events residing within the track. Therefore, if you have chosen a default program change for a track, when playing from any point within the track, the program change event is sent to the track’s assigned device.

Default Controller Values and Chasing

Though new MIDI tracks appear to have default values for continuous controller playlists, this is actually not the case. For example, when viewing a MIDI track’s Mod Wheel playlist, you’ll see that the breakpoint line is set to a default of zero. However, since the modulation wheel on your synth may purposely be set to a different value, the default value in the track is not transmitted when playing.
This can cause some confusion, however, if you insert a fade (for example, from 0–90) in the Mod Wheel playlist towards the end of the track. If you then play from the beginning of the track, or from anywhere before the fade, the Mod Wheel value on your synth will be at 90 until the beginning of the fade data is reached—which is likely not what you want.

To ensure that the default controller value for a playlist is sent (and chased), click the initial breakpoint at the beginning of the track, move it slightly, and set it back to the default value.

### Offsetting MIDI Tracks

Pro Tools can offset MIDI tracks globally or individually.

*With Pro Tools HD, when Delay Compensation is active, MIDI and Instrument tracks are automatically delay-compensated to provide low latency monitoring. For more information, see “Delay Compensation for MIDI” on page 556.*

#### Global MIDI Playback Offset

Pro Tools offers a MIDI offset preference that allows MIDI and Instrument tracks to play back earlier or later (than audio tracks) by a specified number of samples. The offset affects playback only and does not alter in any way how MIDI data is displayed in the Edit window.

This capability is provided in large part to compensate for the audio monitoring latency in Pro Tools LE. If you are monitoring the output of external MIDI instruments with an external mixer or sound system (or headphones), there is no latency. If, however, you are monitoring the output of your MIDI devices through a Digi 002, Digi 002 Rack, Mbox 2, or Mbox, your MIDI tracks will appear to play slightly later than your audio tracks. The larger the setting for the H/W Buffer Size (128, 256, 512, or 1024 samples), the larger the latency.

By configuring the Global MIDI Playback Offset, you can get your MIDI tracks to play back slightly earlier (by a specified number of samples), thereby compensating for the latency in monitoring audio within Pro Tools LE.

### To configure the Global MIDI Playback Offset:

1. Choose Setup > Preferences and click the MIDI tab.
2. For the Global MIDI Playback Offset option, enter the number of samples (–10,000 to 10,000) for the offset. A negative value causes the MIDI tracks to play back earlier than the audio tracks; a positive value causes the MIDI tracks to play back later.
3. To allow for monitoring latency in Pro Tools LE, set the offset to a value that is roughly equivalent to the H/W Buffer Size.

#### Individual MIDI and Instrument Track Offsets

You can offset individual MIDI and Instrument track offsets in Pro Tools to compensate for delays in MIDI devices (the time it takes to trigger events on a sampler or synth).

For example, if you have some kick drums that are being played by an audio track in Pro Tools and want them to be exactly synchronized with kick drums that are being played by a MIDI de-
vice, you may need to use a MIDI offset. In this example, it will usually take at least 5 ms to trigger the MIDI notes, and it could take even longer, depending on the MIDI device.

You can measure the latency for a MIDI device assigned to a MIDI track by recording its audio output back into Pro Tools. Compare the sample locations for the recorded audio events against the original MIDI notes to calculate the latency.

To configure a MIDI or Instrument track offset for a track:

1. Choose Event > MIDI Track Offsets.

2. Click in the Sample Offset column for the MIDI track and enter the number of samples (-10,000 to 10,000) for the offset. A negative value causes the MIDI or Instrument tracks to play back earlier than the audio tracks; a positive value causes the MIDI or Instrument tracks to play back later.

   The equivalent offset in milliseconds is displayed in the msec Offset column. This value cannot be edited, but updates when a new value is entered in the SMPTE Offset column.

3. Press Enter (Windows) or Return (Mac) to accept the entered offset value.

To reset all offsets for all MIDI and Instrument tracks, click the Reset button in the upper left of the window.

Stuck Notes

If you encounter stuck notes with any of your MIDI devices, you can silence them with the All MIDI Notes Off command.

To turn off all stuck notes:

- Choose Event > All MIDI Notes Off.

   Press Control+Shift+Period (.) (Windows) or Command+Shift+Period (.) (Mac) for the All MIDI Notes Off command.

Remove Duplicate Notes

The Remove Duplicate Notes command is useful for removing duplicate notes from a MIDI performance. If a note starts within the first 25% of the duration of a note of the same pitch which is already sounding (or within an eighth-note, whichever is shorter), it is considered a duplicate and is combined with the previous note. If it starts later than that, the first note is shortened so that it ends at the same tick at which the new one starts.

To remove duplicate notes:

1. Make an Edit selection including the duplicate notes that you want to remove.

2. Choose Event > Remove Duplicate Notes.
Chapter 23: MIDI Operations

MIDI Operations Window

The MIDI Operations window provides commands to transform groups of MIDI notes to affect pitch, timing, and phrasing.

The MIDI Operations window has nine pages, one for each MIDI Operations command.

- Grid/Groove Quantize
- Restore Performance
- Flatten Performance
- Change Velocity
- Change Duration
- Transpose
- Select/Split Notes
- Input Quantize
- Step Input

The MIDI Operations window can be left open, revisiting it as necessary to apply a command, or to try out different options for a particular command.

- You can also apply quantize, duration, delay, and transpose nondestructively using MIDI Real-Time Properties. See “MIDI Real-Time Properties” on page 506.

- See your system’s Getting Started Guide for complete steps on configuring MIDI on Windows and Mac systems.

To open a specific MIDI Operations window page:

- Choose Event > MIDI, followed by one of the MIDI Operations (such as Grid/Groove Quantize).

If the MIDI Operations window is already open, you can select any of the pages from the pop-up menu at the top of the window.
To open the last active MIDI Operations window page:

- Choose Event > MIDI > Operations Window.

Press Alt+3 (Windows) or Option+3 (Mac) to open the MIDI Operations window and display the last active MIDI Operations page.

To apply the command in the MIDI Operations window, do one of the following:

- Click Apply or press Enter on the numeric keypad. This applies the command and leaves the window in the foreground.

  – or –

- Press Enter on the QWERTY keyboard (Windows) or Return (Mac). This applies the command and closes the window.

To undo the command in the MIDI Operations window:

- Choose Edit > Undo.

Using the MIDI Operations Window

Use the following methods to easily configure the various options, which vary from command to command, in the MIDI Operations window:

- Increment or decrement selected fields with the Up and Down Arrows. Press and hold these keys to scroll quickly through the values.

- Click and drag up or down in a selected field to scroll to a new value.

- Press Control (Windows) or Command (Mac) while adjusting sliders for finer resolution.

- For selected pitch and velocity fields, play a note on your MIDI controller keyboard to automatically enter it.

- Changing a value for a particular control (such as the Swing Percentage in the Quantize window), automatically enables the control.

Grid/Groove Quantize

The Grid/Groove Quantize command adjusts MIDI note locations and durations so that timing is improved, or so that a particular rhythmic “feel” is achieved.

The default Grid/Groove page provides Grid Quantize options, so that you can Quantize works by aligning notes to a Quantize Grid, the size of which is defined in the Quantize Grid pop-up menu by a standard note duration, or you can apply a groove template. The Grid/Groove Quantize window provides slightly different options for Grid Quantize and Groove Quantize.

The Quantize command is not the same as the Quantize to Grid command (in the Region menu). The Quantize to Grid command adjusts the start point for a selected region, and its contents are moved along with the region (with internal rhythmic relationships remaining intact).
The Grid/Groove Quantize MIDI Operation, on the other hand, affects MIDI notes individually. Some notes may be moved back in time, others forward, some will be shortened and some will be lengthened; and, some notes will be more drastically affected than others.

To open the Grid/Groove Quantize window:
- Choose Event > MIDI > Grid/Groove Quantize.
- Press Alt+0 on Windows or Option+0 on Mac to open the Grid/Groove Quantize window.

To select Grid Quantize:
- From the Quantize Grid pop-up menu, select the desired note value.

To select Groove Quantize:
- From the Quantize Grid pop-up menu, select the desired groove template.

Grid Quantize

The Grid/Groove Quantize window can apply Grid Quantize when a specific rhythmic value is selected in the Quantize Grid pop-up menu. When a groove template is selected in the Quantize pop-up menu, Groove Quantize can be applied. For information on Groove Quantize, see “Groove Quantize” on page 489.

What to Quantize

The options under “What to Quantize” determine what aspects of the selected MIDI notes are quantized: attacks, releases, or both.

Attacks When selected, note start points are quantized.

Releases When selected, note end points are quantized.

You can also quantize MIDI input, see “Input Quantize” on page 503.
**Preserve Note Duration**  When selected, note durations are preserved.

When deselected with the Attacks option selected, note end points are not moved.

When deselected with the Releases option selected, note start points are not moved.

If the options for both Attacks and Releases are selected, the Don’t Change Durations option is unavailable.

Figure 21 on page 486 shows how notes are adjusted by the different What To Quantize options.

---

**Quantize Grid**

**Quantize Grid Pop-Up Menu** Determines the beat boundaries to which notes are aligned. Any size from whole notes (1/1) to sixty-fourth notes (1/64), including dotted and triplet values, can be selected for the Grid size.

*Tuplet* Select the Tuplet option to quantize irregular note groupings, such as quintuplets. The Quantize Grid for tuplets is calculated from the note size selection and the Tuplet value. For example, if an sixteenth note equals 240 ticks, quintuplet sixteenth notes with 5 in time of 4 would yield a Grid size of 192 ticks or (240 ticks/5)*4.

**Offset Grid By** Offsets the Quantize Grid forward or back in time by a specified number of ticks. Use this option to achieve a pushed feel (by using positive values) or a laid back feel (by using negative values).

**Relative Grid mode does not affect the Quantize Grid.**

---

**Tuplet** Select the Tuplet option to quantize irregular note groupings, such as quintuplets. The Quantize Grid for tuplets is calculated from the note size selection and the Tuplet value. For example, if an sixteenth note equals 240 ticks, quintuplet sixteenth notes with 5 in time of 4 would yield a Grid size of 192 ticks or (240 ticks/5)*4.

**Offset Grid By** Offsets the Quantize Grid forward or back in time by a specified number of ticks. Use this option to achieve a pushed feel (by using positive values) or a laid back feel (by using negative values).

**Randomize** When selected, notes are moved randomly forward or back in time (after the Quantize occurs). For example, with the Quantize Grid set to eighth notes and Randomize set to 50%, notes are placed up to a 32nd note before or after the beat boundary. The Randomize setting also affects note durations (if Releases is selected).

---

*Relative Grid mode does not affect the Quantize Grid.*

To Quantize just the backbeats, set the Quantize Grid to half-notes with an Offset of 960 ticks. 
Options

Additional Quantize options include:

**Swing** When selected, every other Grid boundary is shifted by the specified percentage value (0–300) to achieve a “swing” feel. A Swing value of 0% yields no swing, while 100% yields a triplet feel. Settings above 100% progressively narrow the swing until the maximum of 300%, at which every other Grid boundary is moved to the next Grid point.

**Include Within** When selected, attacks and releases are only quantized if located within the specified percentage of the Quantize Grid. Use this option to clean up downbeats without affecting notes that are “swung” or wildly off the beat.

Figure 22 shows the Quantize Grid set to quarter notes with the Include Within option set to 50%. Only attacks and releases falling within the shaded area (equivalent to an eight note area around each beat) are quantized.

**Exclude Within** When selected, attacks and releases are not quantized if located within the specified percentage of the Quantize Grid. Use this option to preserve the feel of notes close to the beat, while correcting others that are drastically away from the beat.

Figure 23 shows the Quantize Grid set to quarter notes with the Exclude Within option set to 25%. Attacks and releases falling within the shaded area (equivalent to a sixteenth note area around each beat) are not quantized.

**Strength** When selected, notes are moved a percentage toward the Quantize Grid. Lower percentages preserve the original feel of the notes, higher percentages align the notes more tightly to the Grid.

**Grid Quantize Examples**

The following examples illustrate some of the more common uses for Grid Quantize.

If you intend to loop playback while quantizing, you may want to deselect Options > Link Timeline and Edit Selection. This ensures that the play range will not change when selected notes are moved in the course of quantizing and undoing.

⚠️ *After quantizing, you can use Restore Performance to revert to the original version (see “Restore Performance” on page 494.)*
**Straight Quantize**

To quantize to a straight sixteenth note feel:
1. Select the range of MIDI notes to be quantized.
2. Choose Event > MIDI > Grid/Groove Quantize.
3. Under What to Quantize, select the Attacks option. To quantize note durations as well, select the Releases option.
4. From the Quantize Grid pop-up menu, select sixteenth notes (1/16). Make sure that the other options for Tuplet, Offset Grid By, and Swing are not selected.
5. Leave the remaining Quantize options deselected and click Apply.

**Quantizing While Preserving the Original “Feel”**

You can quantize less strictly, to preserve the original feel of your recorded MIDI tracks.

To quantize while preserving the original feel:
1. Select the range of MIDI notes to be quantized.
2. Choose Event > MIDI > Grid/Groove Quantize.
3. Under What to Quantize, select the Attacks option. To quantize note durations as well, select the Releases option.
4. From the Quantize Grid pop-up menu, select the note value you want to use. Make sure that the other options for Tuplet, Offset Grid By, and Swing are not selected.
5. Select the Exclude Within option with a value of 10–15%.
6. Select the Strength option with a value of 70–80%.
7. Leave the remaining Quantize options deselected and click Apply.

Audition the change and if the desired effect is not achieved, undo the edit and experiment with different values for Exclude Within and Strength.

**Quantizing with Swing**

If you’re working with MIDI hi-hats or bass lines, you may want to apply more of a swing feel to the track.

To quantize with an eighth note swing feel:
1. Select the range of MIDI notes to be quantized.
2. Choose Event > MIDI > Grid/Groove Quantize.
3. Under What to Quantize, select the Attacks option. To quantize note durations as well, select the Releases option.
4. From the Quantize Grid pop-up menu, select eighth notes (1/8).
5. Select the Swing option with the Swing percentage you want:
   - For a light swing, use 12%.
   - For a tighter swing-like groove, use 24%.
   - For a true “triplet-like” swing feel, use 50–75%.
6. Make sure the options for Tuplet, Offset Grid By, and Randomize are not selected. Click Apply.

Audition the change and if the desired effect is not achieved, undo the edit and experiment with a different Swing percentage.
Quantizing with Randomize

If quantized notes sound too mechanical or “on the beat,” use the Randomize option in the Quantize window to make them sound more natural.

To “humanize” the rhythmic feel of notes:
1. Select the range of MIDI notes to be quantized.
2. Choose Event > MIDI > Grid/Groove Quantize.
3. Under What to Quantize, select the Attacks option. To quantize note durations as well, select the Releases option.
4. From the Quantize Grid pop-up menu, select the note value you want to use.
5. Select the Randomize option with a value of 5%.
6. Click Apply.

Audition the change and if the desired effect is not achieved, undo the edit and experiment with a different Randomize percentage.

Experimenting with Quantize

When using the Quantize command, you’ll often have to experiment with many of the controls. You may have to try different values for Include and Exclude Within, and Strength; these controls determine which notes are affected and how drastically they are changed. In addition, the Randomize control, which adds a percentage of randomness to the quantize, can be used to make tracks feel less “mechanical.”

Groove Quantize

The Grid/Groove Quantize window can apply Groove Quantize when a groove template is selected in the Quantize Grid pop-up menu. Groove quantize adjusts MIDI note locations and durations according to a *groove template* rather than a strict quantization grid. Groove templates extract the particular rhythmic feel of a recorded performance so that is can be applied to a MIDI sequence. DigiGroove templates can be generated using Beat Detective.
**Groove Templates**

Groove templates (such as DigiGroove templates) are “quantization maps” derived from real musical performances. The rhythmic character of each performance is analyzed and stored as a groove template. Groove templates can be used to transfer the feel of a particular performance to MIDI data (Timing, Duration, and Velocity).

DigiGroove templates can be created using Beat Detective. Beat Detective analyzes an audio file for transient peaks according to a defined threshold and maps the rhythmic relationships to a 960 parts per quarter note (ppq) template. This template can then be used within Groove Quantize, as well as within Beat Detective.

For information on Beat Detective and creating Groove Templates, see Chapter 21, “Beat Detective.”

Additionally, DigiGroove templates are available from Digidesign and third party manufacturers.

Numerical Sound’s Feel Injector Templates (960 ppq) are supported in Pro Tools, but DNA Groove Templates (192 ppq) are not.

**Quantize Grid**

**Quantize Grid Pop-Up Menu** Determines which groove template to use for quantization. All groove template files in the Grooves folder are available in the Quantize Grid pop-up menu. The directory path for the Grooves folder is: C:\Program Files\Digidesign\Pro Tools\Grooves (Windows), or Applications/Digidesign/Pro Tools/Grooves (Mac). If you organize your groove templates in sub-folders in the Groove folder, they will appear as sub-menus in the pop-up menu. Once you have selected a groove template, specific information about the template’s meter and duration (in bars) is displayed under the pop-up menu.

**Show Comments** The Comments field displays any comments saved with the Groove Template from Beat Detective. The Comments field cannot be edited in the Grid/Groove Quantize page, but can be edited when saving a groove template from the Groove Quantize page.

**Pre-Quantize** Enable to hard quantize the selected MIDI notes to a sixteenth-note grid before applying Groove Quantize.

**Options**

**Timing** Enable to apply Groove Quantize to the selected MIDI notes. Use the slider to change the amount of quantization applied to the selection. If the slider is set to 0%, there is no change in timing. A setting of 100% moves notes to the underlying template locations. If the slider is set to 200%, notes move to a tick location that is twice the difference between the original note location and the position of the referenced template event.

For example, if a note was played at Bar 1|1|060 (a 16th note), and the corresponding template event is at 1|1|073, a slider value of 100% results in the note being shifted to 1|1|073 (a slider value of 200% shifts the note to 1|1|086).

The default value for the Timing slider is 100%.
**Duration** Enable to influence the durations of the selected MIDI notes. At a setting of 100%, durations are changed to match the current groove template. Set to 200%, durations increase and decrease based on the ratio of the original duration of the selected notes and the durations in the template.

The default value for the Duration slider is 100%.

⚠️ *Beat Detective does not currently extract duration information from audio performances. DigiGroove templates created using Beat Detective contain a fixed duration value that is 50% of the selected template resolution* (see “Defining a Beat Detective Selection” on page 440).

**Velocity** Enable to influence the velocities of the selected MIDI notes. If the slider is set to 0% there is no change to the selected velocities, a setting of 100% sets all velocities to match the current groove template. A velocity setting of 200% typically results in over-exaggerated velocities—loud notes increasing and soft notes decreasing in volume.

For example, if two adjacent notes have equal velocities of 80, and the two corresponding template velocities are 70 and 90, setting the slider to 200% changes both to velocities of 60 and 100.

The default value for the Velocity slider is 100%.

---

**Slider Settings**

**To Save the groove template with the current Options Slider Settings:**

1. In the Grid/Groove Quantize window, click the Save button.

2. Enter or edit any comments you want to save with the template.

3. Do one of the following:
   - Click the Save button to save the groove template with the current Options Slider Settings.
   - or –
   - Click the Save As button to make a copy of the groove template with the current Options Slider Settings. In the resulting Save dialog, enter a name for the copy and click Save.

Slider settings may be lost if any of the following operations are performed without saving the settings first:
- Another MIDI Operations window is selected.
- The MIDI Operations window is closed.
- You switch to another groove template.

**Recall With Template**

Restores all Groove Quantize Options to the settings that are saved with the current template.
Applying Groove Templates

Groove templates can be of any length and can be applied to any number of bars. Typically, you will apply groove templates to selections of the same length and meter. However, groove templates can be applied to different meters—for example, a groove template in 6/8 can be applied to a selection in 4/4. Also, it is not necessary to start on the downbeat when making a selection to apply a groove template.

To apply Groove Quantize:

1. With the Grabber or Selector tool, select the MIDI notes you want to Groove Quantize.

2. Choose Event > MIDI > Grid/Groove Quantize.

3. Select a groove template from the Grid Quantize pop-up menu.

4. Enable Timing, Duration, and Velocity as desired, and adjust their sliders to the percentages you want.

5. If desired, enable Pre-Process using Quantize.

6. Click the Apply button.

Figure 24. A DigiGroove template (derived from the audio shown) applied to a series of sixteenth-notes with Timing and Velocity both set to 100%
**Mapping Groove Templates**

Pro Tools applies groove templates relative to the song start. For example, a two-bar groove template repeats starting at every odd-numbered bar in the session (bar 1, 3, 5, 7...).

<table>
<thead>
<tr>
<th>1</th>
<th>2</th>
<th>3</th>
<th>4</th>
<th>5</th>
<th>6</th>
<th>7</th>
<th>8</th>
</tr>
</thead>
<tbody>
<tr>
<td>2-Bar Groove Template</td>
<td>2-Bar Groove Template</td>
<td>2-Bar Groove Template</td>
<td>2-Bar Groove Template</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**2-bar groove template, repeating template grid**

### Template Mapping for Equal Meters And Odd Numbered Bars

If a two-bar groove template is applied to a selection of one bar of the same meter, only the first bar of the template is used. If the selection does not encompass bar boundaries, for example 1|2|000 to 2|1|000, the groove template will only modify the selected notes.

**Applying 2-bar groove template to a 1-bar selection, odd numbered bar**

### Template Mapping for Equal Meters And Even Bars

If a selection starts on an even bar, only the appropriate portion of the groove template will be used. For example, if the selection is two bars long and starts on an even bar, the template will apply bar 2 before bar 1.

**Applying a 2-bar groove template to a 1-bar selection, even numbered bar**

### Template Mapping for Unequal Meters

In cases where the Groove Templates and track selections are based on different meters, the template will be repeated or truncated to match the number of beats in the selection.

For example, if the Groove Template contains fewer beats than the selection, such as a one-bar template in 6/8 being applied to a one-bar selection in 4/4, the template will repeat to make up the difference.

**Applying a 1-bar groove template in 6/8 to a 1-bar selection in 4/4**

If the Groove Template contains more beats than the selection on a track, such as a one-bar template in 6/4 being applied to a two-bar selection in 4/4, only the appropriate number of beats will be used.

**Applying a 1-bar groove template in 6/4 to a 1-bar selection in 4/4**
Behavior for Mixed Meters

If the selection contains mixed meters, the groove template will always be mapped so that the downbeats are aligned. For example, if the Groove Template consists of one-bar of 4/4 and it is being applied to a selection of one-bar of 4/4 followed by a bar of 3/8 and one-bar of 3/4, the downbeat of the Groove Template will be aligned with the downbeats in the selection and only the appropriate number of beats from the Groove Template will be applied.

Restore Performance

The Restore Performance command reverts all selected MIDI notes to their original state (when first recorded or manually inserted), even after the session has been saved, or the Undo queue has been cleared. The following MIDI note attributes can be restored:

- Timing (Quantization)
- Duration
- Velocity
- Pitch

⚠️ The Restore Performance command can be undone.

To restore a note’s original time, duration, velocity, or pitch:

1. With the Grabber or Selector tool, select the MIDI notes you want to restore.
2. Choose Event > MIDI > Restore Performance to open the Restore Performance page.
3. Select the note attributes to restore.
4. Click Apply.
Any changes made through the standard Quantize, Groove Quantize, Change Duration, Change Velocity, or Change Pitch commands will be undone and the original “performance” will be restored. Also, any notes that were recorded with Input Quantize enabled will be restored (see “Input Quantize” on page 503).

⚠️ Restore Performance does not undo cut, copied, pasted, or otherwise manually moved MIDI notes.

Restore Performance also does not undo Duration changes made by trimming the start of a note. Trimming the start of a note is essentially changing the note’s timing, and therefore is treated by Pro Tools as manually moving it.

**Timing (Quantization)** Enable to restore the original start times of the selected notes. This will change the durations of the notes if the Duration option is not enabled.

**Duration** Enable to restore the original durations of the selected notes. If the Timing (Quantization) option is not enabled, the start time of the note will not be restored and the note end time will be affected.

**Velocity** Enable to restore the original velocities of the selected notes.

**Pitch** Enable to restore the original pitches of the selected notes.

### Removing Input Quantize

Restore Performance can be used to remove quantization on input. For example, if you recorded a performance with Input Quantize on, you can still restore the performance as it was actually played.

⚠️ For information on the Input Quantize command, see “Input Quantize” on page 503.

---

### Flatten Performance

The Flatten Performance command “locks in” the current performance for selected notes, creating a new “restore to” state for the specified note attributes when using Restore Performance.

#### To flatten the performance:

1. With the Grabber or Selector tool, select the MIDI notes you want to flatten.

2. Choose Event > MIDI > Flatten Performance to open the Restore Performance page.

3. Select the note attributes to flatten.

4. Click Apply

⚠️ The Flatten Performance command can be undone.
Change Velocity

The Change Velocity command automatically adjusts attack and release velocities for selected MIDI notes. Use it to make notes louder or softer, or to create crescendos or decrescendos.

Velocities can also be edited manually with the Pencil and Grabber tools (see “Manually Editing MIDI Notes” on page 465).

- Velocity values usually affect the loudness of MIDI notes. They may also affect other aspects of an instrument’s sound, such as filter cutoff, envelopes, and modulations.

- The settings in the Change Velocity window are saved with each session. To store your favorite settings as the default for use in future sessions, save them as part of a session template (see “Creating Custom Session Templates” on page 57).

- You can also change velocity nondestructively in real-time using MIDI Real-Time Properties. See “MIDI Real-Time Properties” on page 506.

To open the Change Velocity page:

- Choose Event > MIDI > Change Velocity.

MIDI Operations window, Change Velocity page

- While there are options for adjusting both the attack and release velocities for notes, most MIDI devices ignore release velocity information. To see if your instrument supports release velocities, refer to the manufacturer’s documentation.

Set All To Sets all velocities to the specified value (1–127).

Add Adds to existing velocity values by the specified amount (1–127).

Subtract Subtracts from existing velocity values by the specified amount (1–127).

Scale By Scales all velocities by a percentage amount (1–400%).
Change Smoothly Allows velocities to change smoothly from one value to another over time.

Change Smoothly by Percentage Allows velocities to change smoothly from one percentage value to another over time.

The curve for this change can be adjusted (+/- 99) to affect how gradually the change occurs.

Limit To When selected, restricts the Change Velocity command to a minimum and maximum range.

Randomize When selected, the Change Velocity command is randomized by the specified percentage value. For example, using “Set all to” with a value of 64, along with a Randomize value of 50%, yields velocities anywhere between 48 and 80 (+/- 25% of the velocity value).

Velocity Ranges

The valid range for MIDI note velocities is 1–127. The Change Velocity command will never result in moving velocities outside this range; 1 will always be the lowest and 127 will always be the highest. This means that you may reach a state where the Change Velocity command has no effect on a particular note.

For example, if a note with a velocity 64 is scaled by 200%, the new velocity would be 127. Attempting to scale or increase the velocity any further would yield no change.

Fading Velocities

To change velocities smoothly over time:

1. Select the range of MIDI notes to be edited.
2. Choose Event > MIDI > Change Velocity.
3. Select the Change Smoothly option with the range set from 127 to 0.
4. Click Apply.

To preserve (somewhat) the existing velocity relationships and still achieve velocity fades, use the option for Change Smoothly by Percentage. Figure 25 illustrates the difference between the two Change Smoothly options.

Fading Velocities

Figure 25. Change Smoothly by Percentage
Scaling Velocities

Many times existing note velocities will have the relationship you want, but will either be too soft or too loud overall. In these instances, use the Scale By option.

For example, to make velocities 20% louder:

1. Select the range of MIDI notes to be edited.
2. Choose Event > MIDI > Change Velocity.
3. Select the Scale By option with the percentage value set to 120.
4. Click Apply.

Change Duration

The Change Duration command adjusts durations for selected MIDI notes. Use it to make melodies and phrases more staccato or legato.

💡 The settings in the Change Duration page are saved with each session. To store your favorite settings as the default for use in future sessions, save them as part of a session template (see “Creating Custom Session Templates” on page 57).

⚠️ You can also change note duration nondestructively in real-time using MIDI Real-Time Properties. See “MIDI Real-Time Properties” on page 506.

To open the Change Duration page:

- Choose Event > MIDI > Change Duration.
- Press Alt+P on Windows or Option+P on Mac to open the Change Duration window.

Set/Add/Subtract/Scale Option

Set All To Sets all durations to a length specified in quarter notes and ticks.

Add Adds to the durations by a specified number of quarter notes and ticks.

Subtract Subtracts from the durations by a specified number of quarter notes and ticks.

Scale by Shortens or lengthens durations based on a percentage value (1–400%).

Legato

Enable the legato option to add legato to the MIDI selection. Select Gap or Overlap from the Legato pop-up menu and enter the desired gap or overlap in beats and ticks.
Remove Overlap

The Remove Overlap option removes any note overlap for all notes of the same pitch. This command is different from Legato in that non-overlapping notes of the same or different pitches remain unchanged. To create a gap between previously overlapping notes, enter the desired gap in beats and ticks.

Transform Sustain Pedal To Duration

The Transform Sustain Pedal To Duration option extends the length of all notes which are sounding when the sustain pedal (controller 64) is down (0 to 63) to the point when the sustain pedal goes up (64 to 127). Enable the Delete Sustain Pedal Events option to convert sustain pedal events to note durations. Converting sustain pedal events to note duration can greatly simplify editing while maintaining the desired performance effect. For example, if a sustain pedal down event is deleted while editing, the subsequent MIDI performance looses its legato effect.

Change Continuously Option

The Change Continuously option lets you change the duration of notes continuously in ticks or by percentage. Adjust the Curve slider to modify the shape of the change.

Change Continuously in Ticks Allows note lengths to change smoothly from one duration to another over time. Duration values are specified in quarter notes and ticks.

Change Continuously by Percentage Allows note lengths to change smoothly from one percentage value to another over time.

The curve for this change can be adjusted (+/- 99) to affect how gradually the change occurs.

Limit Range When selected, restricts the Change Duration command to a minimum and maximum range (in quarter notes and ticks).

Randomize When selected, the Change Duration command is randomized by the specified percentage value. For example, using “Set all to” with a value of 480 ticks, along with a Randomize value of 50%, yields durations anywhere between 360 and 600 (+/- 25% of the duration value).

Change Duration Examples

To make notes more staccato:

1. Select the range of MIDI notes to be edited.
2. Choose Event > MIDI > Change Duration.
3. Select the option for Scale By with a percentage value of 50.
4. Click Apply. The durations for the selected notes are reduced by 50%.

With this option you may have to experiment with the percentage value to achieve the desired effect.

To make notes more legato:

1. Select the range of MIDI notes to be edited.
2. Choose Event > MIDI > Change Duration.
3. Select the Legato option.
4. From the Legato pop-up menu, select Overlap.
5. Enter 0|000 for the amount of overlap.
6. Click Apply.

The end points for the selected notes are extended to the start point of the next note, thereby eliminating the space between each note.
Transmirror

While the Grabber tools can be used to manually transpose individual MIDI notes, or small groups of notes, the Transpose command can be used for entire MIDI tracks and regions. One of the more common uses for Transpose is to change the key for your MIDI tracks. You can define an Edit Group for MIDI tracks that you want to transpose, making sure to exclude any drum tracks from the group so they aren’t transposed.

You can also transpose MIDI notes nondestructively in real-time using MIDI Real-Time Properties. See “MIDI Real-Time Properties” on page 506.

To open the Transpose page:
- Choose Event > MIDI > Transpose.
- Press Alt+T (Windows) or Option+T (Mac) to open the Transpose window.

**MIDI Operations window, Transpose**

**Transpose By (Octaves)** Transposes transpose the selected MIDI notes by up to +/- 10 octaves.

**Transpose By (Semitones)** Transposes chromatically, up or down, by up to +/-127 semitones.

**Transpose (From and To)** Transposes by semitones, as expressed by the difference between the source and destination pitches. Transposing from C3 to F#3, for example, transposes the notes up by an augmented fourth (six semitones).

**Transpose All Notes To** Transposes all selected notes to the same pitch. Use the slider or the number entry box to enter the desired pitch to which to transpose all selected notes.

**To transpose MIDI notes to another key:**
1. If you will be transposing a group of tracks, make sure to enable the Edit Group.
2. With the Selector or any Grabber tool, select the range of MIDI notes to be transposed.
3. Choose Event > MIDI > Transpose.
4. Select the option for Transpose (From, To).
5. Set the “From” and “To” values, for example, to C4 and E4 to transpose from C to E.

With either of the pitch fields selected, you can play a note on your MIDI controller to automatically enter it as the pitch value.

6. Click Apply.

It is also common to transpose MIDI tracks up or down by an octave.

**To transpose a MIDI track down by an octave:**
1. With the Selector tool, double-click in the track to select all of its notes.
2. Choose Event > MIDI > Transpose.
3. Select the Transpose By option.
4. Enter a value of –1 octave.
5. Click Apply.
Select/Split Notes

The Select/Split Notes window provides a complete set of tools to select and split notes based on a wide variety of criteria. Additional tools are provided to specify whether selected data is copied to the clipboard or to new tracks, whether the data is split to multiple new tracks or a single destination, and more.

To open the Select/Split Notes page:

- Choose Event > MIDI > Select/Split Notes.

Pitch Criteria

All Notes Selects all notes.

Notes Between Selects a range of notes between the specified upper and lower note. Values for the notes can be entered in pitch (C1–G8) or MIDI note numbers (0–127).

Top Selects the highest note or notes in each chord.

Bottom Selects the lowest note or notes in each chord.

Other Criteria

Velocity Enable the Velocity option to specify a range of velocities for selecting or splitting notes. Enter the desired minimum and maximum velocities.

Duration Enable the Duration option to specify a range of durations (in beats and ticks) for selecting or splitting notes. Enter the desired minimum and maximum durations.

Position Enable the Position option to select or split all notes that fall into a range of relative beat and tick locations within each bar. The minimum value determines the start of the range, the maximum value sets the end of the range.

Action

Select Notes Selects MIDI notes based on the specified criteria.

Split Notes: The ClipboardCopies the selected data to the clipboard only.

Split Notes: A New TrackCopies all selected data to a single, new track. If the selection includes multiple tracks, that same number of tracks will be created. The new tracks will duplicate the original track type (Instrument or MIDI).

Split Notes: A New Track per PitchCopies all selected data to multiple new tracks (one new track for each pitch). New tracks zoom to single-note display. If the selection includes multiple tracks, each track will have its data split separately.

Include MIDI Controller DataIncludes all continuous MIDI data, including pitchbend and aftertouch, on the entire track, without any restriction on time selection.
To select and split notes:

1. Choose Event > MIDI > Select/Split Notes.
2. Configure the Pitch Criteria as desired.
3. Configure the Other Criteria (Velocity, Duration, and Position) as desired.
4. Enable the Select or Split option as desired.
5. From the Split Notes pop-up menu, select Copy or Cut.
6. Select the desired Copy or Cut to destination:
7. If desired, enable the Include MIDI Controller Data option. Enabling this option will include all controller data associated with the split notes in newly created tracks. Leave this option unchecked to split only note data to new tracks.
8. Click Apply.

Any Real-Time Properties associated with the track or regions are copied to new tracks created by Select/Split Notes.

**Selecting a Pitch Range of Notes**

A common use for Select/Split Notes is to select a single note for the entire length of a region or track. This is especially useful if you want to select a note in a MIDI drum track (such as a hi-hat), and affect it over the selected time range with the Quantize, Groove Quantize, Transpose, or Change Duration command.

**To select only the hi-hats in a General MIDI drum track:**

1. With the Grabber or Selector tool, select the range of MIDI notes that contains the note.
2. Choose Event > MIDI > Select/Split Notes.
3. Select the Notes Between option with the note range set to F#1 and F#1 (if the MIDI Note Display preference is set to Standard Pitch).

For a General MIDI drum kit, the closed hi-hat is assigned to MIDI note number 42 (F#1 at Standard Pitch). If the hi-hat for your drum kit is assigned to a different note, make sure to specify it.

4. Click Apply.

**Selecting Notes in a Chord**

Another use for Select/Split Notes is to select only the upper or lower notes in a chord. Many times you’ll want to affect only the upper or lower notes in a chord—to boost their velocities, or transpose their pitch.

**To select only the bass notes in a chord:**

1. Do one of the following:
   - With the Grabber or Selector tool, select the range of MIDI notes that contains the notes.
   - or –
   - To affect all the MIDI notes on a track, click in the track with the Selector tool, so that it contains a blinking edit cursor.
2. Choose Event > MIDI > Select/Split Notes.
3. Select the Bottom option and leave the number of notes set to 1.
4. Click Apply.

💡 In order for notes to be considered a chord, their start times must be within thirty-two ppq ticks of each other.
Input Quantize

When Input Quantize is enabled, all recorded MIDI notes are quantized automatically. To preserve the original “feel” of your recorded MIDI tracks, make sure to disable this option.

To enable Input Quantize:

1. Choose Event > MIDI > Input Quantize.
2. In the Input Quantize page, select Enable Input Quantize.

Configure the other options in the Input Quantize page. For details on the various Quantize options, see “Grid/Groove Quantize” on page 484. When finished, close the MIDI Operations window.

For drum machine style loop recording, use Input Quantize while loop recording MIDI in Merge mode (see “Loop Recording with Merge Mode” on page 225).

Step Input

Step Input lets you use a MIDI controller to enter notes individually, one step at a time. This gives you precise control over note placement, duration, and velocity. With MIDI step input you can also create musical passages that might be difficult to play accurately, or at a fast tempo.

To enter MIDI notes with Step Input (using an external MIDI device):

1. Make certain your external MIDI device is properly connected and working with Pro Tools.
2. Choose Event > MIDI > Step Input.

When Step Input is enabled, each previously record-enabled MIDI or Instrument track is taken out of record enable, and if the Default Thru Instrument preference is defined, it is disabled.
4 Choose the MIDI or Instrument track for step entry from the Destination pop-up menu.

5 Choose the note value you wish to enter from the Step Increment section.

6 Play a note or chord on your MIDI instrument. This enters the note and moves to the next step of the insertion point.

To increase a note’s length while using Step Input:

1 Play and hold a note on your MIDI instrument.

When a note is being held on the MIDI keyboard, Next Step changes to read “Increment.”

2 Choose the note value that you would like to add and press the Increment button.

Release the note on your MIDI keyboard to move to the next step insertion point.

**Step Input Controls**

The Step Input page has the following controls:

**Enable** When selected, MIDI events are added to the destination track when you play your external MIDI keyboard. Additionally, each previously record-enabled MIDI track is taken out of record enable.

If a Default Thru Instrument is defined in the MIDI Preferences page, it is disabled when Step Input is enabled, and is re-enabled when Step Input is no longer disabled.

**Destination** Lets you select the destination track for the Step Input from a pop-up list of all the MIDI tracks in your session.

**Step Increment**

The options in the Step Increment section let you set the spacing and duration of MIDI events entered using the Step Input operation. You can select any size from whole notes to sixty-fourth notes (including dotted values).

**Tuplet** Lets you input irregular note groupings (such as triplets or quintuplets). The tuplet length is calculated from the note spacing selection and the Tuplet values. For example, an eighth note equals 480 ticks, so tuplet eighth notes with 3 in time of 2 would yield a note spacing of 320 ticks (480 ticks / 3 * 2).

**Note Length** Lets you select the note length as a percentage of the spacing value. For example, an eighth note equals 480 ticks, so an eighth note with an 80% duration would be 384 ticks long.

**Options**

**Use Input Velocity** When selected, MIDI notes are recorded using the velocity that you play on your MIDI keyboard.

**Set Velocity To** When selected, MIDI notes are recorded with the velocity that you specify in the Velocity field. This value can be set with the Velocity slider.

**Enable Numeric Keypad Shortcuts** When selected, Step Input options can be selected from the numeric keypad. See “Numeric Keypad Shortcuts” on page 506.
Undo Step, Next Step, and Redo Step

Use the Undo Step and Next Step buttons to do the following:

- Move the step insertion point, by either removing the previous note or by advancing the insertion point by the Step Increment value.
- Lengthen and shorten notes that are being held on the MIDI controller, by adding or removing Step Increment values. The Step Increment value can be changed mid-note to create a note with a hybrid note length.

Use the Redo Step button to sequentially redo any previously undone steps.

**Undo Step** When the previous note has been released from the MIDI keyboard, and the insertion point has moved forward to the next note, Undo Step will remove the entire last note.

When a note is being held on the MIDI keyboard, Undo Step changes to read “Decrement,” and removes the last Step Increment length that was added to the held note.

**Next Step (or Increment)** When no note is being held on the MIDI keyboard, Next Step moves the insertion point by the Step Increment value, essentially inserting a musical rest.

When a note is being held on the MIDI keyboard, Next Step changes to read “Increment” and adds the Step Increment value to the held note, increasing its length by the Step Increment value.

While the note is being held, the Step Increment value can be changed, allowing you to create notes of any musical length.

**Redo Step** Reinserts the last note that was removed by the Undo Step operation.

The Undo Step, Next Step and Redo Step buttons can be set to be triggered by an external MIDI synth, drum pad, or other controller.

**To set Undo Step, Next Step and Redo Step MIDI triggers:**

1. Choose Event > MIDI > Step Input.
2. Locate the button you want to assign a MIDI event to, and click in the field below the button.
3. Play the MIDI event you wish to use as a trigger.

   *If you use a continuous controller such as Pitch Bend as a trigger, you should make certain to use an extreme controller value to avoid erroneous data input.*

4. Press Enter to confirm the MIDI trigger assignment.
### Numeric Keypad Shortcuts

When Enable Numeric Keypad Shortcuts is selected, you can choose many of the controls in the Step Input page, as well as several selection controls.

<table>
<thead>
<tr>
<th>Step Input Shortcuts</th>
<th>Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Whole note</td>
<td>1</td>
</tr>
<tr>
<td>1/2 note</td>
<td>2</td>
</tr>
<tr>
<td>1/4 note</td>
<td>4</td>
</tr>
<tr>
<td>1/8 note</td>
<td>5</td>
</tr>
<tr>
<td>1/16 note</td>
<td>6</td>
</tr>
<tr>
<td>1/32 note</td>
<td>7</td>
</tr>
<tr>
<td>1/64 note</td>
<td>8</td>
</tr>
<tr>
<td>Dotted note</td>
<td>.</td>
</tr>
<tr>
<td>Toggle Tuplet on/off</td>
<td>3</td>
</tr>
<tr>
<td>Next step</td>
<td>Enter</td>
</tr>
<tr>
<td>Undo step</td>
<td>0</td>
</tr>
<tr>
<td>Nudge forward</td>
<td>+</td>
</tr>
<tr>
<td>Nudge back</td>
<td>-</td>
</tr>
<tr>
<td>Select Main Counter</td>
<td>=</td>
</tr>
<tr>
<td>Edit Selection indicators</td>
<td>/</td>
</tr>
</tbody>
</table>

### MIDI Real-Time Properties

MIDI Real-Time Properties let you change some MIDI properties in MIDI and Instrument tracks (or MIDI regions) during playback. There are five types of MIDI Real-Time Properties: Quantize, Duration, Delay, Velocity, and Transpose.

MIDI Real-Time Properties can be adjusted during playback, while you listen for the desired result. Once you have found the desired settings, you can write the settings to the selected tracks or regions. This overwrites the corresponding MIDI properties on selected tracks or regions and resets the Real-Time Properties display.

Real-Time Properties can be adjusted in the Real-Time Properties View in the Edit window, or in the Real-Time Properties window.

### Real-Time Properties View

The Real-Time Properties View in the Edit window only applies to tracks. To apply Real-Time Properties to regions, use the Real-Time Properties window (see “Real-Time Properties Window” on page 507).

**To enable Real-Time Properties View in the Edit window:**

- Select View > Edit Window > Real-Time Properties.
For Mini and Small track heights, the Real-Time Properties column only displays one or two properties, respectively. By default, the first one or two properties which are enabled are displayed automatically.

**To select a different Real-Time Property in Mini or Small track height view:**
- Control-click (Windows) or Command-click (Mac) on a real-time property element to select a different element from the pop-up menu.

**Real-Time Properties Window**

Using the Real-Time Properties window, you can apply Real-Time Properties to selected tracks or regions.

**To open the Real-Time Properties window:**
- Choose Event > MIDI Real-Time Properties.

The Real-Time Properties window can be used to apply either track-based or region-based Real-Time Properties by making an Edit or Time selection and selecting the desired tracks or regions from the Apply To pop-up menu.

**Expanded Real-Time Properties Window**

In the Real-Time Properties window, Quantize, Duration, and Velocity each provide an expand/collapse triangle to show or hide additional settings.

**Enabling Real-Time Properties**

**To enable Real-Time Properties:**

1. Select a track, or make an Edit or Time selection.

   When using Real-Time Properties, enable Link Track and Edit Selection mode to make a track selection from an Edit selection. See “Linking or Unlinking Track and Edit Selections” on page 310.

2. In Real-Time Properties View in the Edit window, or in the Real-Time Properties window, select the desired Real-Time Properties by clicking the property name (Quantize, Duration, Delay, Velocity, or Transpose). Enabled Real-Time Properties are highlighted and display their settings.
3 If you are using the Real-Time Properties window and Link Track and Edit Selection mode is enabled, select the track or region to affect from the Apply To pop-up menu.

4 Configure the Real-Time Properties settings as desired.

Enabled Real-Time Properties will be heard on playback and play through for the selected tracks and regions.

**Real-Time Properties Settings**

**Quantize**

Quantize either can be based on a grid or a groove template. For grid quantize, additional tuplet and grid offset settings are available in addition to the standard MIDI quantize properties. For groove quantize, additional controls are provided to set the extent to which the groove’s duration and velocities are applied. Both grid and groove quantize also let you set a strength amount, an “include” range, and a randomize amount.

**Quantize Pop-Up Menu** Select the desired quantize value, including all standard note rhythm values between whole notes and 64th notes, including dotted and triplet options. This pop-up menu also provides access to all standard and custom grooves.

**Swing Value** Enter the desired amount of swing as a percentage between 0 and 300%.

**Tuplet Value** Enable Tuplet and enter the ratio for the tuplet (1–99), such as 3 to 2 or 5 to 4. Tuplet is only available in the expanded Real-Time Properties window.

**Offset Value** Enable Offset and enter the desired offset value in Ticks between –2000 and 2000. Offset is only available in the expanded Real-Time Properties window.

**Strength Value** Enable Strength and enter the amount as a percentage between 0 and 100%. Strength is only available in the expanded Real-Time Properties window.

**Include** Enable Include and enter the range between 0 and 100%. Include is only available in the expanded Real-Time Properties window.

**Random** Enable Random and enter a percentage between 0 and 100%. Random is only available in the expanded Real-Time Properties window.

**Duration**

Duration can be used to increase or decrease the duration of MIDI notes by a fixed amount or by a percentage. This is useful for creating legato or staccato passages.

![Selecting a Grid Quantize value or a Groove Template](image-url)
Duration Mode Pop-Up Menu

Select one of the following options from the Duration Mode pop-up menu: Set, Add, Subtract, Scale, Legato/Gap, or Legato/Overlap.

**Set**
Select to set notes to the specified duration.

**Add**
Select to add the specified duration to the current duration of each note.

**Subtract**
Select to subtract the specified duration from the current duration of each note.

**Scale**
Select to scale the current duration of each note by a percentage from 1 to 400%.

**Legato/Gap**
Select to extend each note to the following note. The specified duration is the subtracted to create a consistent gap between notes.

**Legato/Overlap**
Select to extend each note to the following note. The specified duration is then added to create a consistent amount of overlap.

**Duration Amount**

If the Ticks or Notes pop-up menu is set to ticks, enter a duration as a number of quarter-notes plus a number of ticks, such as 4|000. If the Ticks or Notes pop-up menu is set to a note size, enter a number to by which to multiply that note size, such as 7 16th-notes.

Ticks or Notes Pop-Up Menus

Selects either Ticks or a note size for Note Durations. There is also a Ticks or Notes pop-up menu for the Minimum and Maximum Durations options.

**Minimum and Maximum Durations**

Enable either or both minimum and maximum durations and enter a value in quarter notes plus ticks or as a multiple of a note size. The Minimum and Maximum Durations options are only available in the expanded Real-Time Properties window.

**Delay**

Delay lets you delay or advance all MIDI data in the selected region or track. Select “+” from the Delay pop-up menu to delay MIDI data, or select “–” to advance MIDI data. Select Ticks or Milliseconds from the Ticks or Milliseconds pop-up menu. Enter the Delay amount in Tick or Millisecond values. Delay is limited to a maximum of value of 2000 ms or 999 ticks.

**Velocity**

Velocity lets you change MIDI velocity by a percentage or by constant value. Enter a percentage value in the Dynamics field to scale velocity around the median velocity of 64. You can also enter an offset by adding (+) or subtracting (–) values between 1 and 127. You can also enter Minimum and Maximum Velocity value limits. The Minimum and Maximum Durations options are only available in the expanded Real-Time Properties window.

Velocity can be applied as a Real-Time Property to MIDI Input and Thru.
Transpose

Transpose lets you transpose MIDI notes up or down by a specified number of octaves and semitones. You can also transpose to a specified pitch. Select By or To from the Transpose pop-up menu to transpose by and interval or to a specific pitch. To transpose by an interval, enter the desired number of octaves and semitones as a positive or negative numbers. To transpose to a specific pitch, enter the desired MIDI note.

Transpose can be applied as a Real-Time Property to MIDI Input and Thru.

Real-Time Properties On Tracks and Regions

Real-Time Properties can be configured to apply to an entire track (all regions on that track), or on a region-by-region basis. Track-level properties also provide real-time MIDI input processing of velocity and transposition.

The presence of track-based Real-Time Properties are indicated by a “T” displayed in the upper right-hand corner of MIDI regions. Region-based Real-Time Properties are indicated by an “R” displayed in the upper right-hand corner of the region. Regions boundaries are indicated in Notes View.

Region-Based Real-Time Properties

Region-based Real-Time Properties can only be applied using the Real-Time Properties window (Event > MIDI Real-Time Properties). Real-Time Properties can be applied to multiple regions. Once Real-Time Properties have been assigned to a region, the region can be moved or copied and pasted and retain its Real-Time Properties.

Track-Based Real-Time Properties

All track-based Real-Time Properties consistently apply to MIDI sequences throughout the entire track. However, regions with region-based Real-Time Properties will take precedence over any track-based Real-Time Properties. You can clear region-based Real-Time Properties by selecting the region and clicking the Clear Region Properties button in the Real-Time Properties window (see “Writing Real-Time Properties to Tracks or Regions” on page 510).

To allow greater flexibility when using Real-Time Properties, whenever Real-Time Properties are assigned on a track basis they are actually contained in a track playlist. This lets you create multiple playlists containing different Real-Time Property settings.

Writing Real-Time Properties to Tracks or Regions

Once you have found the desired settings, you can write Real-Time Properties to the selected tracks or regions using the Real-Time Properties window. Real-Time Properties are applied to the current MIDI data on the track or in a region.

To write Real-Time Properties to tracks:

1. Select one or more tracks to which you want to apply Real-Time Properties.
2 Open the Real-Time Properties window (Event > MIDI Real-Time Properties).

3 If Link Track and Edit Selection mode is enabled, select Tracks from the Real-Time Properties Apply To pop-up menu.

4 Configure the Real-Time Property settings as desired.

5 Do one of the following:
   • Click the Write to Track button in the Real-Time Properties window.
   – or –
   • Choose Track > Write MIDI Real-Time Properties.

To write Real-Time Properties to regions:
1 Select one or more regions to which you want to apply Real-Time Properties.

2 Open the Real-Time Properties window (Event > MIDI Real-Time Properties).

3 If Link Track and Edit Selection mode is enabled, select Regions from the Real-Time Properties Apply To pop-up menu.

4 Configure the Real-Time Property settings as desired.

5 Click the Write to Region button.

To clear Real-Time Properties from a region:
1 Select the region for which you want to clear Real-Time Properties.

2 Open the Real-Time Properties window (Event > MIDI Real-Time Properties).

3 Select Regions from the Real-Time Properties Apply To pop-up menu.

4 Click the Clear Region Properties button.

Real-Time Properties In the MIDI Event List

In the MIDI Event List, the presence of track-based Real-Time Properties are indicated by a “T” displayed to the right of each event. Region-based Real-Time Properties are indicated by an “R.”

Track-based and region-based Real-Time Properties indicated in the MIDI Event List

For more information on the MIDI Event List, see Chapter 24, “MIDI Event List.”
Display of Real-Time Properties Effects

The Display Events as Modified by Real-Time Properties option determines if Pro Tools displays the effects of Real-Time Properties in both the Edit window and the MIDI Event List. The Edit window and the MIDI Event List display the effects of Real-Time Properties when the Display Events as Modified by Real-Time Properties option is enabled. With this option disabled, the effects of Real-Time Properties are heard but not seen—you see the notes and other MIDI events with their original location, pitch, duration, or velocity, but you hear them as they are effected by the Real-Time Properties settings.

To enable or disable the Display Events as Modified by Real-Time Properties option:

1. Choose Setup > Preferences.
2. Click the MIDI Tab.
3. Enable or disable the Display Events as Modified by Real-Time Properties option.
4. Click OK.

Real-Time Properties Effects Displayed in the MIDI Event List

The MIDI Event List takes into account the effect of Real-Time Properties whenever the Display Events as Modified by Real-Time Properties preference is enabled. When editing or inserting an event in a track or region with active Real-Time Properties, Pro Tools takes the properties into account and edits or inserts the event in a different place if necessary to match the effect of the Real-Time Properties.

Real-Time Properties Effects Displayed in the Edit Window

In the Edit window with the Display Events as Modified by Real-Time Properties preference enabled, MIDI events appear where they sound. However, MIDI events are not actually written to their modified locations until you write the Real-Time Properties to the track or region.

When moving MIDI events, the actual locations (pitch or time) move by the amount the events are dragged, but the effect of Real-Time Properties is displayed.

When inserting an event in a track or region with active properties, Pro Tools takes the properties into account and edits or inserts the event in a different place if necessary to match the effect of the Real-Time Properties.
Chapter 24: MIDI Event List

The MIDI Event List

The MIDI Event List displays a detailed list of all events in a single MIDI or Instrument track. The events are displayed with text and numbers, allowing you to precisely edit their location, length, and event values.

Events in the MIDI Event List can be copied and pasted, selected, or deleted. Any MIDI event (except Sysex) can be inserted and edited in the list. Certain MIDI event types can be hidden with the View Filter.

💡 Unlike playlists in the Edit window, you can insert and display polyphonic aftertouch in the MIDI Event List.

⚠️ Mute data for MIDI and Instrument tracks is not displayed in the MIDI Event List.

Opening the MIDI Event List

To open the MIDI Event List, do one of the following:

- Choose Event > MIDI Event List.
- Start-double-click (Windows) or Control-double-click (Mac) a MIDI or Instrument track name in the Mix or Edit window.
- Press Alt+Equal (Windows) or Option+Equal (Mac).

⚠️ You can also use Alt+Equal (Windows) or Option+Equal (Mac) to toggle between the MIDI Event List and the Edit window.
Menus in the MIDI Event List

At the top of the MIDI Event List are three pop-up menus:

Track Selector Indicates the MIDI or Instrument track currently displayed, and can be used to choose a different MIDI or Instrument track to be displayed.

Options Menu Contains commands and options for the MIDI Event List (see “MIDI Event List Options” on page 520).

Insert Menu Contains a list of event types that can be inserted.

To the right of these pop-up menus, the number of displayed events is indicated.

Columns in the MIDI Event List

Information for the events in the MIDI Event List is displayed in the following three columns:

Start Column Displays the start location, using the Main Time Scale, for each event. Locations can also be displayed in the Sub Time Scale when the Show Sub Counter option is selected in the Options pop-up menu.

The playback cursor appears as a blue arrow (red, when tracks are record-enabled) in the Start column.

When several events reside at the same location, the location is only indicated for the top event, with the others dimmed. The dimmed locations can be edited by double-clicking them.

Event Column Displays the event type, indicated by an icon, and associated event values.

Length/Info Column Displays the end point or length for notes, depending on which option is selected in the Options pop-up menu. Also displayed are the names for continuous controller events and program changes.

View Filter for MIDI Event List

You can use the View Filter to specify which event types are displayed in the MIDI Event List. This can help you zero in on only the events you want to affect; it also protects MIDI events from being edited or deleted. Events not displayed in the MIDI Event List still play back.

The View Filter can be set to display “all” messages, “only” the specified messages, or “all except” the specified messages.

⚠️ When inserting an event type that has been filtered from the MIDI Event List, that event type will no longer be filtered.
For example, to filter the display of aftertouch and System Exclusive Messages in the MIDI Event List:

1. In the MIDI Event List, choose View Filter from the Options pop-up menu.
2. In the MIDI Event List View Filter dialog, select the All Except option.
3. Select the options for Mono Aftertouch, Polyphonic Aftertouch, and System Exclusive. Leave all other messages deselected.

When using the All Except option, the selected events are not displayed. Conversely, when using the Only option, only the selected events are displayed.

4. Click OK.

Navigating in the MIDI Event List

You can use the Tab and Arrow keys to move through the MIDI Event List. You can also locate to the Edit start point, or any other specified location.

To move through the MIDI Event List, do any of the following:

- Double-click to edit a value.
- Press Tab or the Down Arrow to move to the next event (with or without the edit field selected).
- Press Control+Tab (Windows) or Option+Tab (Mac) or the Up Arrow to move to the previous event (with or without the edit field selected).
- With an edit field selected, press the Right Arrow to move to the next edit field to the right.
- With an edit field selected, press the Left Arrow to move to the next edit field to the left.

To keep the last event selected, press Shift while moving to the next or previous event.

To go to the Edit start point:

- In the MIDI Event List, choose Scroll To Edit Selection from the Options pop-up menu.

To go to a specific location in the MIDI Event List:

1. In the MIDI Event List, choose Go To from the Options pop-up menu.
2. In the Go To dialog, choose a format from the Time Scale pop-up menu.
If using Time Code (Pro Tools HD and Pro Tools LE with DV Toolkit 2 only), you can select the Use Subframes option.

3 Enter the location you want to go to, then click OK.

The following items from the Options menu affect navigating in the MIDI Event List:

- When the Page Scroll During Playback option is selected, the MIDI Event List scrolls during playback.
- When Scroll During Edit Selection is selected, the MIDI Event List is scrolled automatically when the Edit selection changes in the Edit window.

Inserting Events in the MIDI Event List

You can insert events in the MIDI Event List by choosing an event type from the Insert menu. Following are several examples of inserting events in the MIDI Event List.

To insert a note in the MIDI Event List:

1 Do one of the following:
   - Click the Insert button and choose Note from the pop-up menu.
   - or –
   - Press Control+N (Windows) or Command+N (Mac).

2 Enter the location, pitch, attack and release velocities, and length for the new note. To move between the Event Entry fields, use the Left and Right Arrow keys.

3 Do one of the following:
   - To insert the note and remain in Event Entry mode, press Enter on the numeric keypad.
   - To insert the note and exit Event Entry mode, press Enter (Windows) or Return (Mac) on the QWERTY keyboard.
   - To exit Event Entry mode, without inserting the note event, press Escape on the QWERTY keyboard.

Event Entry fields for note

When a field is selected, enter a value with any of the following methods:

- Enter the value on the numeric keypad.
- Drag up or down to scroll to the value.
- Play the note on your MIDI controller keyboard, then press Enter (Windows) or Return (Mac) on the QWERTY keyboard to confirm the value.

With the Start field selected, you can automatically enter the location of another event already in the track by clicking that event.
To insert a controller event in the MIDI Event List:

1. Do one of the following:
   - Click the Insert button and choose Controller from the pop-up menu.
   - or –
   - Press Control+L (Windows) or Command+L (Mac).

2. Enter the location, controller “type” number, and controller value for the new event. The controller name is displayed in the Length/Info column, to the right of the controller value. To move between the Event Entry fields, use the Left and Right Arrow keys.

   Event Entry fields for controller event

   When a field is selected, enter a value with any of the following methods:
   - Enter the value on the numeric keypad.
   - Press the Up or Down Arrow to scroll to the value.
   - While pressing Control (Windows) or Command (Mac), drag up or down to scroll to the value.
   - Play the controller event on your MIDI controller keyboard, then press Enter (Windows) or Return (Mac) on the QWERTY keyboard to confirm the value.

3. Do one of the following:
   - To insert the controller event and remain in Event Entry mode, press Enter on the numeric keypad.
   - To insert the controller event and exit Event Entry mode, press Return on the QWERTY keyboard.
   - To exit Event Entry mode, without inserting the controller event, press Escape on the QWERTY keyboard.

To insert a program change in the MIDI Event List:

1. Do one of the following:
   - Click the Insert button and choose Program Change from the pop-up menu.
   - or –
   - Press Control+P (Windows) or Command+P (Mac).

2. Enter the location for the new event.

3. Enter a Program Change number and Bank Select value (if necessary). The program change name is displayed in the Info column.

   Event Entry fields for program change

   You can click in the Info column to open the Program Change window (for details, see “Patch Select (Program and Bank Changes)” on page 474).

   With the Start field selected, you can automatically enter the location of another event already in the track by clicking that event.
4 Do one of the following:

- To insert the program change and remain in Event Entry mode, press Enter on the numeric keypad.
- To insert the program change and exit Event Entry mode, press Return on the QWERTY keyboard.
- To exit Event Entry mode, without inserting the program change, press Escape on the QWERTY keyboard.

**Inserting Another Event**

After inserting an event, you can easily insert another event of the same type. The event type to be inserted is indicated at the bottom of the Insert menu.

*For example, after inserting a note, to insert another, do one of the following:*

- Click the Insert button and choose Another Note from the pop-up menu.
  – or –
- Press Control+M (Windows) or Command+M (Mac).

*When the option for Insert At Playback Location is enabled (see “MIDI Event List Options” on page 520), you can use the keyboard shortcuts for inserting “another” event to insert events on-the-fly.*

---

**Editing in the MIDI Event List**

Events in the MIDI Event List can be edited, selected, deleted, and copied and pasted.

**To edit an event in the MIDI Event List:**

1. Do one of the following:
   - Double-click the event field you want to edit.
   – or –
   - To edit a selected event, press Control+Enter (Windows) or Command+Enter (Mac).

2. Enter a new value with any of the following methods:
   - Enter the new value on the numeric keypad.
   - While pressing Alt (Windows) or Option (Mac), press the Up or Down Arrow to scroll to a new value.
   - While pressing Control (Windows) or Command (Mac), drag up or down to scroll to a new value.
   - Play the new note or controller value on your MIDI controller keyboard, then press Enter (Windows) or Return (Mac) on the QWERTY keyboard to confirm.

3. Do one of the following:
   - To enter the new event value and move to another field or event, use the Arrow keys.
   - To enter the new value and remain in Edit Entry mode, press Enter on the numeric keypad.
   - To enter the new value and exit Edit Entry mode, press Enter (Windows) or Return (Mac) on the QWERTY keypad.
   - To exit Edit Entry mode without entering the new value, press Escape on the QWERTY keyboard.
Selecting in the MIDI Event List

To select a range of events in the MIDI Event List, do one of the following:

- Click the event at the beginning of the selection and drag to the ending event.
- or –
- Shift-click the event at the beginning of the selection, then Shift-click the ending event.

To select discontiguous events in the MIDI Event List:

- Control-click (Windows) or Command-click (Mac) each event.

To remove an event from the selection in the MIDI Event List:

- Control-click (Windows) or Command-click (Mac) the selected event.

3 Do one of the following:
- Choose Edit > Clear to delete all selected events.
- or –
- Press Backspace (Windows) or Delete (Mac) on the QWERTY keyboard.

Copy and Paste in the MIDI Event List

To copy and paste in the MIDI Event List:

1. Select the range of events you want to copy by dragging in the MIDI Event List. To select discontiguous events, Control-click (Windows) or Command-click (Mac) each event you want to copy.

2. Choose Edit > Copy.

Deleting in the MIDI Event List

To delete an event in the MIDI Event List:

- Alt-click (Windows) or Option-click (Mac) the event you want to delete.

To delete a selection of events in the MIDI Event List:

1. Select the events you want to delete, by either dragging in the Start column, or by Shift-clicking each event.

2. To view only the events you want to delete, use the View Filter (see “View Filter for MIDI Event List” on page 514). Events not displayed cannot be deleted.

Notes selected in the MIDI Event List can be modified by any of the commands in the MIDI Operations window. For details, see Chapter 23, “MIDI Operations.”
3 Do one of the following:
- To paste the material at an existing event’s location, click the event in the MIDI Event List.
– or –
- To paste the material at any location, choose Go To from the Options menu in the MIDI Event List, enter the location you want to paste to, and click OK.

4 Choose Edit > Paste. The events from the Clipboard are pasted, replacing any existing events already there.

To paste events without overwriting other events, use the Merge Paste Special command.

MIDI Event List Options

The MIDI Event List provides the following options:

**Show Sub Counter** Displays event times in the Sub Time Scale.

**Go To** Opens the Go To dialog, where you can specify a location, based on any of the supported Time Scales, to which the Edit insertion point is moved.

**Scroll To Edit Selection** Scrolls the MIDI Event List to the Edit start point or Edit insertion point.

**Page Scroll During Playback** Scrolls the MIDI Event List during playback.

**Scroll During Edit Selection** Scrolls the MIDI Event List automatically when the Edit selection changes in the Edit window.

**Show Note Length** Displays note lengths, instead of note end times, in the Length/Info column of the MIDI Event List.

**Show Note End Time** Displays note end times, instead of note lengths, in the Length/Info column of the MIDI Event List.

**Insert At Edit Location** Defaults the location for inserted events defaults to the Edit start point or Edit insertion point.

**Insert At Playback Location** Lets you insert events in the MIDI Event List in real time while listening to the session playback.

**Insert At Playback Location With Grid** Snaps the location for events inserted in real time to the grid.

**View Filter** Opens the View Filter dialog, where you can specify which events are displayed in the MIDI Event List. Events that are not displayed are not affected by Cut, Copy, and Paste operations in the MIDI Event List. Events that are not displayed still play back. For more information, see “View Filter for MIDI Event List” on page 514.
Part VI: Mixing
Chapter 25: Basic Mixing

In addition to the final mixdown, mixing tasks can occur any time during a recording session. This chapter covers Pro Tools mixing, including audio signal flow, output and bus paths, sends, and signal routing for submixing and mixdown.

During mixing, real-time plug-ins and hardware inserts provide effects and signal processing (see Chapter 26, “Plug-in and Hardware Inserts”).

Mixing Concepts

Mixing involves making decisions about elements such as volume levels, panning, and effects. These mixing decisions are initially based on what you hear in your studio. While you can control many variables in your studio (such as speakers and room acoustics), you cannot control the listening environment in which your final mix will be heard. The following tips include a few ways to make sure your mix will sound as good as possible to as many listeners as possible:

Alternate Speakers and Reference Monitoring List to your mixes on a variety of different speakers, to gauge how well the mix will translate. By listening to a mix through different playback systems, you are attempting to anticipate what the intended audience will hear.

Reference Mixes Tapes and discs of rough mixes let you audition mixes outside the studio in different listening environments.

Format Compatibility Monitoring Stereo mixes must often be mono-compatible. When you are mixing in multichannel surround, mixes may also need to be compatible with stereo or mono playback systems (see the Pro Tools Sync & Surround Concepts Guide).

Metering and Calibration

Meters provide a visual display of signal levels. They tell whether signal is getting to a channel, and how loud or soft a signal is relative to (above or below) “0.”

By calibrating all your equipment to standard reference levels, a consistent level can be achieved (and metered) among different recording devices in a studio, throughout a facility, or throughout an entire production chain of a feature-length film. For example, a level of –18 dBFS coming out of a DAT deck should play and meter at –18 dBFS in Pro Tools.

Use the Calibration Reference Level option (in the Operations Preferences page) to set a default calibration reference level when Pro Tools is in Calibration mode.

For audio interfaces that have trims (such as the 192 I/O), see the interface’s guide for calibration instructions.
Track Types

Pro Tools provides five different types of audio tracks:

- Audio
- Auxiliary Input
- Master Fader
- Instrument

Mono and stereo audio tracks are available on all Pro Tools systems.

Multichannel audio tracks and surround mixing formats are supported by Pro Tools HD only.

Pro Tools provides two types of MIDI tracks:

- MIDI
- Instrument

Instrument tracks are listed under both audio tracks and MIDI tracks because they are a combination of Auxiliary Input and MIDI tracks.

Pro Tools HD provides VCA Master tracks, which do not pass audio or control MIDI, but do affect controls on other tracks. See “VCA Master Tracks” on page 528.

Tracks can be identified in the Mix window by their Track Type icon.

Audio Tracks

Audio tracks play audio from disk, record audio to disk, or monitor input signals when record-enabled, or in TrackInput monitoring mode. Inserts on audio tracks are pre-fader. Sends can be pre- or post-fader.

Source or Input

Inserts

Sends, pre-fader

Record

Solo/Mute

Volume

Sends, post-fader

Panner

Output

Main Output + Additional Outputs

Audio signal flow, audio tracks

For information on creating tracks, see “Creating Tracks” on page 102.
**Auxiliary Input Tracks**

Auxiliary Inputs provide the same signal routing options as audio tracks, except that their input must come from an internal bus or hardware input. Inserts on Auxiliary Inputs are pre-fader.

**Common Uses for Auxiliary Inputs**

By bussing tracks to the Auxiliary Input, you can:

- Apply real-time plug-ins or an external processor to a submix, using the Auxiliary Input as an effects return (such as reverb or bus line compression)
- Input audio from external MIDI instruments and other audio sources into the mix, to monitor or route to audio tracks for recording to disk (such as from the audio outputs of a MIDI synthesizer)
- Consolidate volume control of any submix under a single fader
- Play back audio from an instrument plug-in (although Instruments tracks are the recommended way to integrate instrument plug-ins, such as Digidesign Synchronic)

**To route an Auxiliary Input:**

1. Click the Input Path selector of the Auxiliary Input and choose an input or bus path.
2. Click the Output Path selector of the Auxiliary Input and choose an output or bus path.
3. Adjust the Auxiliary Input fader to set the return volume (it defaults to $-\infty$ dB).

Submix examples begin in “Submixing for Signal Routing and Effects Processing” on page 548.
Master Fader Tracks

Master Faders control the master output levels of output and bus paths. When assigned to an active output or bus path, they provide post-fader effects processing and master level control for a main mix, headphone and cue mixes, stems, effects sends, and other signal routing applications. Master Faders support all track formats supported on your Pro Tools system.

Unlike inserts on audio tracks and Auxiliary Inputs, Master Fader inserts are post-fader. This lets you insert a dither plug-in, or similar plug-in, on your master mix. For more information about dithering, see “Dither” on page 557.

Master Faders provide up to five post-fader inserts and no sends. Also, Master Fader tracks do not have Pan sliders, or Mute and Solo buttons.

If you absolutely must have a pre-fader insert on your Master Fader signal, set up an Auxiliary Input before the Master Fader.

Common Uses for Master Faders

Master Faders can be used to:

- Control and process output mixes
- Monitor and meter an output (such as a bus or hardware output) to guard against clipping
- Control submix levels
- Control effects sends levels
- Control submaster (bussed tracks) levels
- Apply dither or other inserts to an entire mix

Use Master Faders to control submix levels, send level masters, and other outputs. Master Faders can control either audio interface outputs or internal busses. A Stereo Master Fader controls the level of a pair of outputs. Master Faders do not consume any of your system’s audio processing power.

To use a Master Fader as a stereo master volume control:

1. Create a stereo Master Fader track.
2. Set the outputs of all audio tracks in the session to the main output path (for example, outputs 1–2 of your primary audio interface) and set the panning for each track.
3. Set the output of the Master Fader to the main output path.
**Master Fader Meters**

Meters on Master faders always show post-fader levels, regardless of the Pre-Fader Metering setting in the Options menu.

**Master Faders and Paths**

Master Faders can be assigned to main or sub-paths as defined in the I/O Setup. Multiple Master Faders cannot be assigned to the same path.

**Active and Inactive Master Faders**

When a Master Fader track is inactive, its associated plug-ins, I/O assignments, and their resources are made inactive.

When a Master Fader output assignment (path assignment) is made inactive, the Master Fader no longer controls the master gain of that path.

When you duplicate a Master Fader track, the duplicated track’s assignment will be inactive.

**Instrument Tracks**

Instrument tracks provide the same audio signal routing options as Auxiliary Input tracks, except that their input must come from an instrument plug-in inserted on that Instrument track, or from a bus or hardware input. Instrument tracks provide up to ten pre-fader inserts.

**Audio signal flow, Instrument tracks**

Instrument tracks are used as inputs for instrument plug-ins, and other sources (including internal busses). They can be fully automated.

When using Instrument tracks as inputs for external sources, adjust the source output levels to achieve proper recording levels.
Common Uses for Instrument Tracks

By playing back MIDI from or through an Instrument track you can control and monitor the audio from:

- Instrument plug-ins, such as software synthesizers or samplers.
- External MIDI instruments, such as synthesizers and samplers

To route audio from an external MIDI instrument to an Instrument track:

1. Click the Input Path selector of the Instrument track and choose the corresponding hardware input for your external MIDI instrument.
2. Click the Output Path selector of the Instrument track and choose an output or bus path.
3. In Instruments View, click the MIDI Input selector, and assign a device and channel from the pop-up menu to record and control the external MIDI instrument.
4. In Instruments View, click the MIDI Output selector, and assign the port and channel for the external MIDI instrument from the pop-up menu.
5. Adjust the Instrument fader to set the volume (it defaults to $-\infty$ dB).

For information on assigning MIDI input and output for Instrument tracks, see “Assigning MIDI Input and Output for Instrument Tracks” on page 117

For information inserting Instrument plug-ins on Instrument tracks, see “Inserting Instrument Plug-ins on Instrument Tracks” on page 118

VCA Master Tracks

(Pro Tools HD Only)

VCA Master tracks emulate the operation of voltage-controlled amplifier channels on analog consoles, where a VCA channel fader would be used to control, group, or offset the signal levels of other channels on the console.

VCA Master tracks do not pass audio, so they do not have inputs, outputs, inserts or sends. A Mix group is assigned to a VCA Master track, which appears in the VCA track’s Group Assignment selector.

The controls of the tracks in that Mix group, called the slave tracks, are modified by the controls on the VCA Master.
Creating VCA Master Tracks

To add a VCA Master track to a session:

1. Choose Track > New.

2. In the New Tracks dialog, do the following:
   - Select VCA Master from the Track Type pop-up menu.
   - Select the timebase (Samples or Ticks) from the Track Timebase menu.
   - Enter the number of new tracks.
   - Click Create.

VCA Master Track Controls

The controls on a VCA Master track affect the corresponding controls, listed below, on the slave tracks in its assigned Mix group.

VCA Slave Track Controls and Group Behavior

When a group is assigned to a VCA Master, the controls on its slave tracks, by default, do not follow any grouped behavior that may be set in the Attributes page of the Groups dialog. This is standard behavior for VCA operation. However, slave tracks can be set to follow group behavior. See “Allowing Grouped Behavior of Slave Track Controls” on page 530.

Volume

The VCA Volume fader controls the Volume fader on audio, Auxiliary Input, Instrument, Master Fader, and other VCA Master tracks in a VCA-controlled group. (Volume faders on MIDI tracks are not affected.) Volume faders on slave tracks move to show the composite level, or the level on each track resulting from the contribution of the VCA Master Volume fader.

Mute

The VCA Mute button controls the mute state of audio, Auxiliary Input, Instrument, MIDI, and other VCA Master tracks in a VCA-controlled group. Muting a VCA-controlled group does not change the original mute state of slave tracks. (Mute buttons on slave tracks that were previously unmuted show an implicit mute.)

Solo

The VCA Solo button controls the solo status of audio, Auxiliary Input, Instrument, MIDI, and other VCA Master tracks in a VCA-controlled group.

- Soloing a VCA Master will implicitly mute all tracks except its slave tracks, thereby indirectly soloing the slave tracks.
- Soloing a VCA Master will clear any explicit solos on its slave tracks, leaving them indirectly soloed, and implicitly mute all other tracks.
- Explicitly soloing a slave track while its VCA Master track is soloed will override the VCA Master solo.

Record Enable

The VCA Record Enable button toggles the Record Enable status of only those audio, Instrument, and other VCA tracks that have already been record-enabled individually. You can then toggle record enable on and off for those tracks using the VCA Master Record Enable.

To temporarily force all slave tracks to toggle their record enable status:

- Alt-click (Windows) or Option-click (Mac) the Record Enable button on the VCA Master.
**TrackInput**

The VCA TrackInput button toggles the input monitor status of only those audio tracks in a VCA-controlled group that are record-enabled. You can toggle Input Monitor status for those tracks using the VCA Master TrackInput button.

**To temporarily force all slave tracks to toggle their input monitoring status:**
- Alt-click (Windows) or Option-click (Mac) the VCA Master TrackInput button on the VCA Master.

**Level Meter**

On VCA Master tracks, Level meters indicate the highest level occurring on any of its individual tracks, not a summed level of all slave tracks.

The channel format of Level meters on the VCA Master is set according to the channel formats of its slave tracks, as follows:
- If all slave tracks are the same channel format (mono, stereo or a multichannel format), the number of level meters on the VCA Master track is identical to that of the slave tracks.
- If the slave tracks are different formats, the number of level meters on the VCA Master track is set to one.

**Record Enable, TrackInput and Slave Tracks**

When a slave track is record-enabled (the Record Enable button is lit) or set to Input Only mode (the TrackInput button is lit), its automation is temporarily turned off, and its Volume fader is no longer affected by the VCA Master.

**Allowing Grouped Behavior of Slave Track Controls**

When a track is a VCA slave track, its Volume, Mute, Solo, Record Enable, and Input Monitoring controls follow VCA functions, and normally do not follow grouped behavior.

However, these slave track controls can be set to allow grouped behavior in addition to their VCA functions.

**To allow grouped behavior of VCA-related controls on slave tracks:**
1. Choose Setup > Preferences and click Mixing.
2. In the Automation section, deselect the “Standard VCA Logic for Group Attributes” option.

Volume, Mute, Solo, Record Enable, and Input Monitoring are made available as Mix group attributes in the Group dialog.

**Assigning Groups to VCA Masters**

An existing Mix group can be assigned to a VCA Master, or a new Mix group can be assigned to a VCA Master while it is being created. Only one group can be assigned to a VCA Master at a time. A VCA Master cannot control a group that includes itself.

**To assign an existing group to a VCA Master:**
- Click the Group Assignment selector on the VCA Master track and choose an available group from the pop-up menu.
To assign a new group to a VCA Master:

1. While creating a new group, select Mix or Mix/Edit as the Group type.
2. In the Group dialog, choose an available VCA Master track from the VCA pop-up menu.

Track Membership in Multiple VCA Groups

It is possible for a single slave track to be a member of more than one VCA-controlled group. In this case, the contribution of all VCA Master Volume faders is summed on the slave track. Mute, Solo, Record Enable, and Track Input follow the same rules for enabling or disabling slave tracks.

Inserts

Pro Tools lets you insert up to five inserts on each audio, Auxiliary Input, Master Fader, or Instrument track. Each insert can be either a software plug-in insert or a hardware insert, or an instrument plug-in.

Inserts provide the following features:

- Plug-ins and hardware inserts route the signal from the track through the effect of your choice, and automatically return it to the same track.
- Hardware inserts send and return the signal to corresponding input and output channels of an audio interface, which can be connected to outboard effects.
- Some Instrument plug-ins (such as Virus Indigo) accept audio from the track input (letting you use them as processing plug-ins).
- Inserts on audio, Auxiliary Input, and Instrument tracks are pre-fader.
- Inserts on Master Faders are post-fader.
- Inserts can be bypassed or made inactive.
- Most plug-in controls are fully automatable.

See Chapter 26, “Plug-in and Hardware Inserts” for details about using plug-ins and inserts.

Track Output Format and Plug-ins

Pro Tools supports mono, multi-mono, stereo, and multichannel plug-ins (Pro Tools HD with Surround Mixer only).

Because inserts process in series, changing the plug-in format can alter the channel format. For example, inserting a mono-to-stereo plug-in on a mono Auxiliary Input changes the signal path from that plug-in through the rest of the track. This restricts all hardware inserts or plug-ins after the stereo plug-in to be stereo-in/stereo-out plug-ins (or the supported multichannel format).

Plug-in Formats

Pro Tools supports mono and stereo plug-ins, including the following three types of plug-in paths:

- mono-in/mono-out
- mono-in/stereo-out
- stereo-in/stereo-out

Pro Tools HD sessions running with the Surround mixer also support 3–8 channel multi-mono and multichannel plug-ins.
Views in the Mix and Edit Windows

The Mix and Edit windows can be configured to show or hide various mixing controls, using menu commands or view selectors.

Most of these views are available in both windows, unless noted.

Window View Selectors

Both the Edit window and Mix window provide Window View selectors to configure their views.

Displaying Views

To display all views in the Mix or Edit window, do one of the following:

■ Select View > Mix Window (or Edit Window) > All.
   – or –
■ Click the Mix Window View selector (or Edit Window View selector), and select All.

To display none of the views in the Mix or Edit window, do one of the following:

■ Select View > Mix Window (or Edit Window) > None.
   – or –
■ Click the Mix Window View selector (or Edit Window View selector), and select None.

To show or hide available views in the Mix and Edit windows, do one of the following:

■ Select View > Mix Window (or Edit Window) and one of the view types (such as Comments).
   – or –
■ Click the Mix Window View selector (or Edit Window View selector), and select one of the view types (such as Comments).
Comments View Shows any text entered as comments in the Track Name/Comments dialog. For more information, see “Naming Tracks” on page 103.

Mic Preamps View Shows controls in each track for the Digidesign PRE. Deselect to hide. For detailed information, see the PRE Guide.

Instruments View Shows MIDI controls on Instrument tracks (MIDI Input selector, MIDI Output selector, MIDI volume, MIDI pan, and MIDI mute).

Inserts View Shows inserts (software plug-ins and hardware I/O inserts) in each track. Deselect to hide.

Sends View (Sends A–E and Sends F–J) Shows send assignments in each track. Deselect to hide. For more information, see “Configuring Sends View in the Mix and Edit Windows” on page 538.

I/O View (Edit Window Only) Shows Input and Output selectors, and Volume and Pan indicators in each track. Deselect to hide.
Shift-click (Windows) or Control-click (Mac) on the volume or pan fields in the Edit window I/O View to adjust the volume or pan controls with a pop-up fader.

**Delay Compensation View (Mix Window on Pro Tools HD Only)** The Delay Compensation View displays the total amount of plug-in delay on each track, lets you apply a user offset of track delay, and displays the total amount of delay that Pro Tools applies to each track. The Delay Compensation View can be shown in the Mix Window.

**Delay Compensation View**

Delay values can be specified in either samples or milliseconds, as selected in the Display Preferences page. For more information on Delay Compensation, see “Delay Compensation” on page 553.

**Track Color View** Shows track color in each track. Deselect to hide. For detailed information, see “Color Coding for Tracks, Regions, Markers and Groups” on page 123.

**Transport View (Edit Window Only)** Displays functional transport controls in the top upper–right of the Edit window. These controls are the same as those in the Transport window. For more information, see “The Transport Window” on page 27.

---

534  Pro Tools Reference Guide
**Hiding Views in the Edit Window**

You can quickly hide View columns in the Edit window using a simple keyboard shortcut.

*To hide a View column in the Edit window:*

- Alt-click (Windows) or Option-click (Mac) at the top of the column you want to hide (Mic Pre, Comments, Instrument, Inserts, Sends A–E, Sends F–J, I/O, Real-Time Properties, or Track Color).

**Audio Input and Output Paths**

Pro Tools lets you configure the physical input and outputs of your audio interfaces and also internal bus paths and subpaths in the I/O Setup dialog and the Hardware Setup dialog. These hardware inputs and outputs, and internal bus paths can be assigned as inputs and outputs on audio, Auxiliary Input, Instrument tracks, and Master Faders.

**Input Audio Path**

Input Path selectors determine the source input for audio, Auxiliary Input, and (optionally) Instrument tracks. Track inputs can be set from a hardware input or internal bus paths or subpaths. For detailed information on assigning track inputs, see “Assigning Audio Track Inputs” on page 111.

Hardware input and bus paths can be configured in the I/O Setup. For more information, see Chapter 7, “I/O Setup.”

You can also define what physical ports are routed to Pro Tools input ports in the “Main” page of the Hardware Setup dialog. For more information, see “Configuring Pro Tools System Settings (in the Playback Engine)” on page 41.

**Output Audio Path**

Track Output Path selectors route the post-fader signals to the assigned output or bus paths. The Output Path selector routes the main track output to the chosen main or sub-path. Tracks can be routed directly to hardware output or internal bus paths and subpaths for submixing (main or sub-paths).

The track format (mono, stereo, or multichannel) determines the available main and sub-path choices for track output. For detailed information on assigning track outputs, see “Assigning Audio Track Outputs” on page 111.

When audio, Auxiliary Input, Master Fader, and Instrument tracks are created, their mono, stereo, or greater-than-stereo multichannel format is defined:

- Mono tracks can be assigned to any available mono, stereo, multichannel main and sub-paths.
- Stereo tracks can be assigned to any available mono, stereo, or multichannel main and sub-paths.
- Multichannel tracks can be assigned to any mono path, or path of the same number of channels (for example, an LCRS track can be assigned to a mono or LCRS path).

**Output Windows**

Output windows provide the essential track mixing controls (such as track panning and volume), as an alternative to Mix and Edit window views. Multichannel Output and Send windows also provide expanded Panner views, and other surround-specific controls. See Chapter 33, “Surround Panning and Mixing (Pro Tools HD Only).”
Output windows are useful in large sessions to leave important tracks in an anchored location, unaffected by Mix and Edit window (or control surface) banking. See “Output Windows for Tracks and Sends” on page 543.

Multiple Output Assignments

Pro Tools audio, Auxiliary Input, and Instrument tracks can be assigned to multiple output paths. Assigning to multiple paths is an efficient way to route an identical mix to other discrete outputs, for simultaneous monitor feeds, headphone mixes, or other situations where a parallel mix is needed.

To assign a track to multiple outputs:

1. Assign a main output path by selecting it from the track's Output Path selector.
2. Start-click (Windows) or Control-click (Mac) an additional output path in the track's Output Path selector. The newly selected output destination is added as an additional output.

Display of Multiple Output Assignments

When a track is assigned to multiple output paths, the Output Path selector denotes multiple assignment status and active/inactive status with the following indicators:

- A plus sign (+) indicates that the track has multiple output assignments.
- In the Output Path selector menu, all currently assigned track outputs are checked to indicate they are active for the current track.
- An asterisk (*) indicates that one or more currently assigned outputs is Inactive.

Inactive Outputs

An output path can be made inactive, either globally in the I/O Setup dialog (affecting all tracks assigned to that path), or locally per assignment (only affecting that output on that audio track or Auxiliary Input).

When opening sessions, outputs will be made inactive automatically if the required hardware or other resources are not available.

Inactive outputs retain all associated automation playlists. Edits made in the session also affect the inactive track's output automation playlists.

Inactive Outputs and DSP Resources

Making a track output inactive silences the output, while retaining all automation and playlist data. Inactive outputs do not consume resources for TDM mixer connections, but any assigned plug-ins on the track continue to use their required DSP resources. RTAS plug-ins require CPU resources, and TDM plug-ins use the DSP available on Pro Tools|HD cards.

You can free up DSP of unused plug-ins by making a track inactive, or by just making the plug-in inactive.

See “Making Tracks Inactive” on page 122, and “Making Inserts Inactive” on page 562 for more information.
### About the “No Output” Option

Track outputs can be set to No Output. Assigning a track output to No Output loses any panning automation associated with the track.

Tracks assigned to No Output will not be audible, but they do not free their associated DSP resources.

### Sends

Pro Tools lets you insert up to ten sends (A–E and F–J) on each audio track, Auxiliary Input, or Instrument track.

Sends provide the following features:
- Sends can be set as pre- or post-fader.
- Send level, pan, mute, and LFE controls can be configured to follow Groups.
- Send level, send mute, and send pan (for stereo and multichannel sends) are fully automatable. See “Automating Sends” on page 595.
- Send controls can be displayed and edited from the Mix or Edit windows, or in their own output windows.
- Sends can be assigned to available output and bus paths (main or sub-paths), in mono or stereo, or any of the supported multichannel formats for surround mixing.
- Each send can have multiple assignments (for example, to available output and bus paths).

Sends must be returned to the mix through an Auxiliary Input, audio track, or Instrument track, to be audible in Pro Tools. They can be monitored and processed through an Auxiliary Input (or Instrument track), recorded to audio tracks, and bounced to disk. (Bouncing and mix-down are explained in Chapter 28, “Mix-down.”)

### Assigning Sends to Tracks

To add a send to a track:

1. Make sure Sends View is enabled in the Mix or Edit window (see “Views in the Mix and Edit Windows” on page 532 for information).
2. Click the Send selector on the track and choose a path from the pop-up menu.

The send can be a mono or stereo (or any of the supported multichannel formats for surround mixing) output or bus path.
3 Set the output level of the send in the Send window by doing one of the following:
• Adjust the Send Level fader.
  – or –
• Set the send level to unity gain (0 dB) by Alt-clicking (Windows) or Option-clicking (Mac) the Send Level fader.

When you create a new send, its initial output level depends on the setting of the “Sends Default to –INF” preference.

To change the default setting for sends:
1 Choose Setup > Preferences and click the Operation tab.
2 Do one of the following:
  • Select Sends Default to “–INF.”
    – or –
  • Deselect Sends Default to “–INF” and new sends will default to unity gain (0 dB).

To remove a send from a track:
■ Click the Sends button on the track and choose No Send from the pop-up menu.

**Send Formats**

**Mono and Stereo Sends** When you click the Sends button on a track, you can choose from a list of mono or stereo output or bus paths.

**Multichannel Sends (Pro Tools HD Only)** When you click the Sends button on a track, you can choose from a list of multichannel output or bus paths.

**Send Path Choices**

The choices available in track Send selectors include bus and output paths.

The names, format, and channel mapping of busses and output paths can be customized in the I/O Setup dialog. See “Creating and Editing Paths” on page 81.

**Internal Mix Busses** Pro Tools HD provides 128 busses and Pro Tools LE provides 32 busses for routing signals internally. Internal bus paths are useful for submixing and processing with plug-ins. Bus paths are defined in the I/O Setup dialog, and are available in all supported channel formats (mono, stereo, or multichannel, as supported on your system).

**Hardware Outputs** Hardware sends are often used for headphone cue mixes, or for sending signals to external effects processors. Sends do not automatically return audio as do hardware inserts.

**Configuring Sends View in the Mix and Edit Windows**

Audio tracks, Auxiliary Inputs, and Instrument tracks include two sets of Sends Views: Sends A–E (sends 1–5) and Sends F–J (sends 6–10). The View menu provides separate options for viewing these sends in the Mix and Edit windows.

To display sends in the Mix or Edit window:
■ Select View > Mix Window (or Edit Window) > Sends A–E (or Sends F–J).
Sends View Options

Sends are displayed in the Mix and Edit window according to the Sends A–E View and Sends F–J View options. Each Send View has six view choices: Assignments View and five individual Send Views (A–E or F–J).

Assignments View

This is the default Sends View, showing all five of the Sends A–E or Sends F–J sends on all tracks displayed in the Mix and Edit windows.

To show all send assignments:

1. If sends are not currently visible on your tracks, select View > Mix Window (or Edit Window) > Sends A–E (or Sends F–J).
2. Do one of the following:
   - Select View > Sends A–E > Assignments or View > Sends F–J > Assignments.
   - or –
   - When displaying sends in an individual Send View (such as Send A View), Control-click (Windows) or Command-click (Mac) the Send selector and select Assignments.

Individual Send Views (A–J)

Individual Send Views (such as Send A) provide send level, pan, and mute controls for a single send across all tracks.

Send controls can be adjusted directly from these Send Views. Sends can also be opened for control or metering in Send windows. See “Output Windows for Tracks and Sends” on page 543.
To display the controls for an individual send across all tracks:

1. If sends are not currently visible on your tracks, select View > Mix Window (or Edit Window) > Sends A–E (or Sends F–J).

2. Do one of the following:
   - Select View > Sends A–E (or Sends F–J) and select one of the individual Send Views (such as Send A).
   - Or –
   - In Assignment View, Control-click (Windows) or Command-click (Mac) the Send Assignment selector.

Send level and mute can follow Mix groups, to adjust multiple send controls from a single set of controls.

**Individual Send Views and Meters**

When you display the controls for an individual send, you also have the option of displaying send level meters.

Send level meters show peak values and indicate clipping that occurs while the meter is displayed (if a send clips any time before its meter is displayed, this is not shown). If you are using a slower computer, hiding send level meters can improve screen redraw times.

To display send level meters when viewing individual sends:

1. Choose Setup > Preferences and click the Display tab.

2. Select Show Meters in Sends View and click OK.

To clear a send meter's Clip indicator:

- Click the Clip indicator.

To clear all meters, do one of the following:

- Option-click any Clip indicator.
- Choose Track > Clear All Clip Indicators.
- Press Alt-C (Windows) or Option-C (Mac).

In Assignment View, edit sends by opening their Output windows. See “Output Windows for Tracks and Sends” on page 543.
Send Status Display

When displaying all controls for an individual sends, the Send status is visible directly in the Mix or Edit windows.

In Assignment View, Send status is displayed as follows:

- By default, the Send button is grey, to indicate that it is unmuted.
- The Send button text is red when the send has clipped.
- The Send button is blue when the send is muted.
- The Send button is lit whenever a send’s window is open.

If you use a control surface (such as D-Control or Digi 002) with Pro Tools, colored outlines around sends, inserts, and outputs indicate the current controller focus.

Inactive Sends

Sends can be made inactive. Inactive sends free their DSP and mixer resources, while retaining their position in track Sends View. Inactive sends do not output audio. However, Inactive sends retain all related automation playlists. In addition, edits made to regions on tracks with inactive sends can still affect the sends automation playlists.

When opening sessions, sends will automatically be made inactive if the required hardware or other resources are not available.

To make a send inactive:

- Control-Start-click (Windows) or Command-Control-click (Mac) on the Send assignment.

- or -

- Make the Track inactive. See “Making Tracks Inactive” on page 122.

To toggle sends in the same position (A–J) and assigned to the same path on all tracks active or inactive:

- Control-Start-Alt click (Windows) or Command-Control-Option click (Mac) a send button in the position you want to toggle.

To toggle sends in the same position (A–J) and assigned to the same path on all selected tracks active or inactive:

- Control-Start-Alt-Shift-click (Windows) or Command-Control-Option-Shift-click (Mac) a send button in the position you want to toggle.
Moving or Copying Sends

Sends can be moved or copied to other tracks, or to other positions on the same track using conventional drag and drop. Sends can be dropped to create new sends at the destination, or dropped onto existing send assignments to replace them.

Sends can be moved and copied to tracks with compatible send formats (mono, stereo, or other). Pro Tools alerts you when you try to move or copy a send to an incompatible destination. (For more information, see “Send Format and Track Compatibility” on page 542).

To move a send:

1. Make sure the Transport is stopped.
2. Click the send name and drag it at a new position in the original track or in a different track.

To copy a send:

1. Make sure the Transport is stopped.
2. Alt-drag (Windows) or Option-drag (Mac) the send and drop it at a new position.

Moving or copying a send maintains all routing assignments, automation (if any), level/pan/mute settings, and output format.

Send Format and Track Compatibility

Sends can only be copied to other tracks with a compatible send output format (mono, stereo, or other). In addition, the following conditions apply when moving or copying sends among tracks:

- When copying a stereo send from a mono track to a stereo track, Send pan automation (if any) will be dropped without warning.
- When copying a stereo send from a stereo track to a mono track, the left Send pan automation data is retained and the right side data is dropped. A warning dialog appears for you to confirm or cancel this destructive operation.
- When moving or copying a send and replacing an existing send, all automation on the existing send will be replaced. A warning dialog appears for you to confirm or cancel this destructive operation.

Copying Track Settings to Sends
(Pro Tools HD Only)

Sometimes you need send settings to match the settings in the track itself—for example, to provide a headphone mix based on the main mix.

For more information, see “Copying Track Automation to Sends” on page 595.
Linking Send Pan and Main Pan Controls

You can link pan controls of individual Sends to the Main pan controls of their corresponding tracks, allowing for fast setup of cue mixes or effects processing.

To link a Send’s Pan controls to the Main Pan controls of a track:

1. Click the Send Assignment button for the Send you want to link to open the Send window.
2. In the Send window, click the FMP (Follow Main Pan) button.

Linked Send pan controls appear in light grey.

To change the default FMP (Follows Main Pan) setting for newly created Sends:

1. Choose Setup > Preferences and click Mixing.
2. Under Setup, select or deselect Send Pans Default to Follow Main Pan.

Output Windows for Tracks and Sends

Track outputs and sends can be opened for display and editing in dedicated windows.

- Track Output windows provide track fader, pan, automation, solo, and mute controls.
- Send windows provide send level, pan, automation, and mute controls.
- Standard Output and Send window controls provide additional routing, assignment, and display settings.

To open a track Output window:

- Click the Output Window button in the channel strip.
To open a Send window:
- Click the Send Assignment button in the Mix or Edit window.

To view a different track Output or Send window:
- Click an Output Window button, or Send Assignment button, in the Mix or Edit window.

If a similar Output window was already open with a highlighted Target icon (red, lit), the newly selected send will open in its place.

Opening Multiple Output Windows
Multiple track and Send windows can be displayed simultaneously using either of the following methods.

To open additional Output windows:
- Shift-click any Output Window button or Send Assignment button.

To set a window to remain open when opening additional Output windows:
- Make sure the Target is disabled.

Opening a Send window

To view a different track Output or Send window:
- Click an Output Window button, or Send Assignment button, in the Mix or Edit window.

If a similar Output window was already open with a highlighted Target icon (red, lit), the newly selected send will open in its place.

Multiple Send windows
Arrange multiple windows as desired. For additional information, see “Targeted Windows” on page 547.

Panner Linking
Stereo outputs provide two panning controls, one for each side of the left/right pair. Multichannel outputs provide a multichannel panner.

The Output window provides controls to unlink (or link) channels for precise panning of stereo and multichannel tracks.

In the default Linked mode, all sides match changes to any other side’s Pan control. This is Absolute Link mode. To mirror panning changes, see “Inverse Linked Panning” on page 545.
When unlinked, Pan controls are completely independent of each other.

To enable linking:
- Enable the Link icon.

To unlink an output for independent panning:
- Deselect the Link icon.

**Inverse Linked Panning**

When linked and set to Inverse mode, panning moves are inverted or reversed in the other channels.

Inverse panning reflects one side’s location and direction in the other side. For example, when enabled for Front Inverse, if you pan one side of a stereo track output from right to left, the other side will exactly mirror that movement and pan left to right.

Front Inverse linking is available on all systems. Rear Inverse, and Front/Rear Inverse linking are available on Pro Tools|HD systems only, and only appear as options on multichannel plugins and panners/output windows.

To enable inverse linking:
1. Enable the Link icon.
2. Select an Inverse mode.

**Standard Selector Controls in Output Windows**

All Output windows provide standard selectors for path, automation, and other controls in the top area of the window (the Output Editor area).

**Inverse Pan**

Inverse Pan

**Output Path Selector**

Allows you to assign the Output path for the current track or send.

**Track Selector**

Provides access to any audio track, Auxiliary Input, or Master Fader in the session.

**Output View Selector**

Provides access to other outputs (track and send) in the track, if any, displaying the selected output in the current window.

**Send View Selector (Send Window Only)**

Provides access to other sends on the track.

**Output Path Selector**

Allows you to assign the Output path for the current track or send.
Pre/Post Fader button (Send Window Only) Determines whether the send is pre- or post-fader.

Automation Safe Protects track and send level, pan, and other controls from automation overwrites by placing them in Automation Safe mode. See Chapter 27, “Automation” for more information.

Inverse Pan Reflects one side’s panning location and direction in the other side (for example, left- and right-channel Pan controls).

Link and Unlink Lets you link and unlink left and right (or other) outputs in stereo (or multi-channel). Unlinked mode provides discrete adjustment of individual sides, or channels. When linked, all changes affect all channels. See “Panner Linking” on page 544.

Target Identifies the target of plug-in settings commands. Also sets the current window for display of Output windows. See “Targeted Windows” on page 547.

Path Meter View Opens the path Meter View. These meters display levels of the selected path (not the levels of the track or send).

Path Meter View in a Send window

Track Fader, Pan Controls, and Solo, Mute, and Automation Controls

Output windows provide the associated track’s Volume fader, Pan controls, Solo and Mute switches, and Automation Mode selector. Use these to adjust or automate the controls of the Output window.
**Targeted Windows**

When lit (red), the Target indicates its window is “targeted,” and the next window opened of the same type replaces the current display (unless it is opened as an additional window with the Shift modifier). When unlit, the target is gray, and the current window anchors to its current contents and location on-screen. Opening additional windows does not affect anchored windows.

**To set an open Send window as the target window:**
- Click the Target, so that it is lit (red).

**Plug-in windows have additional features related to the Target (such as Focus of Settings commands).** See “The Plug-in Window” on page 568.

**Using Output Windows**

Output windows provide standard Pro Tools track, send, Target, and other controls.

**To move to a different track:**
- Click the Track selector and choose a track from the pop-up menu.

**To reassign output:**
- Click the Output Path selector and select a path from the pop-up menu.

**To display the controls for a different send on the same track:**
- Click the Send View selector and select the send.

**Accessing another send in the Output window**

**To assign a different send to the same track:**
- Click the Send selector and choose an output or bus path from the pop-up menu.

**To add an additional output assignment to the current send:**
- Press Start (Windows) or Control (Mac) while selecting an additional output path from the Send selector (or Output Path selector).
Submixing for Signal Routing and Effects Processing

The bussing and mixing features in Pro Tools support myriad possibilities for submixing and signal routing, including the ability to:

- Monitor and mix disk tracks with audio inputs or with MIDI input
- Bus submixes for effects processing or monitoring
- Mix submixes with Master Faders

Monitoring Audio with Auxiliary Input Tracks

Use Auxiliary Input tracks to monitor and mix external audio sources—such as MIDI instruments, tape, microphone inputs, and other instruments—in a Pro Tools mix.

To use Auxiliary Inputs to monitor and mix external audio sources:

1. Connect the audio outputs of your audio source (such as a MIDI synthesizer or tape output) to available inputs on your Pro Tools audio interfaces.
2. If necessary, configure the I/O Setup dialog for the input paths you plan to use (see Chapter 7, “I/O Setup.”)
3. Use an existing or create a new Auxiliary Input track with the corresponding number of channels for your audio source (mono, stereo, or multichannel).
4. Set the input of the Auxiliary Input track to the corresponding input path.
5. Assign the track output to the appropriate path or paths for monitoring.
6. Adjust the Auxiliary Input fader to mix the audio input.

Monitoring Audio with Instrument Tracks

Use Instrument tracks to monitor and mix audio from instrument plug-ins or external MIDI instruments in a Pro Tools mix.

To use Instrument tracks to monitor and mix instrument plug-ins:

1. Use an existing or create a new Instrument track.
2. Select an instrument plug-in from the first track Insert selector (such as Digidesign Synchronic).
3 The virtual MIDI node (port) for the instrument plug-in should be automatically selected for the Instrument track’s MIDI Output. If not, select the desired MIDI channel and corresponding port for the instrument plug-in.

4 Assign the track output to the appropriate path or paths for monitoring.

5 Adjust the Instrument track fader to mix the audio input.

6 If you are controlling the instrument plug-in from the Instrument track, you can also mix using the MIDI Volume and Pan controls in the Instrument View.

To use Instrument tracks to monitor and mix audio from external MIDI instruments:

1 Connect the audio outputs of your external MIDI instrument (such as a MIDI synthesizer) to available inputs on your Pro Tools audio interfaces.

2 If necessary, configure the I/O Setup dialog for the input paths you plan to use (see Chapter 7, “I/O Setup.”)

3 Connect the MIDI input and output of your external MIDI instrument to available MIDI input and output ports on your MIDI interface.

4 If necessary, configure the MIDI Studio Setup (Setup > MIDI > MIDI Studio).

5 Use an existing or create a new Instrument track with the corresponding number of channels for your audio source (mono, stereo, or multichannel).

6 Set the audio input of the Instrument track to the corresponding input path.

7 In the Instrument track’s Instrument View, set the MIDI output to the corresponding MIDI port connected to the MIDI input of your external MIDI instrument.

8 Assign the track output to the appropriate path or paths for monitoring.

9 Adjust the Instrument track fader to mix the audio input.

10 If you are controlling the external MIDI instrument from the Instrument track, you can also mix using the MIDI Volume and Pan controls in the Instrument View.
Creating a Submix

A submix is created by routing multiple audio sources to a common bus or output path. This “submixes” the sources to a single path that can be returned to an Auxiliary Input, where the submix can be processed with plug-ins or external effects processors.

Audio is routed to a submix by assigning any combination of sends and track output to available bus or output paths.

Submixing with Track Outputs or Sends

You can use both track outputs and sends to route audio for submixing, depending on whether you want a discrete or send and return submix.

Discrete Submix Output

Pro Tools lets you discretely route source audio through a submix. This is preferred for dither or other mastering processing, where you do not want unprocessed audio heard in addition to the processed signals. Use track outputs (not sends) to assign tracks to a bus path for discrete submixing. In this arrangement, the balance of processed and unprocessed signal is controlled by plug-in wet/dry settings.

To create a discrete submix:

1. Set the output of the tracks you want to include in the submix to a stereo bus path.
2. Pan each track.
3. Choose Track > New.
4. Specify the track type (Aux Input) and format (stereo), then click Create.
5. Set the input of the Auxiliary Input to the same bus path to which you assigned all contributing tracks.
6. Set the output of the Auxiliary Input track to your main stereo mix outputs (typically, outputs 1–2).
7. Set the Auxiliary Input Track level.
8. To process the submix, assign a plug-in or hardware insert on the Auxiliary Input.
9. Set the controls of the plug-in. The plug-in Bypass and Wet/Dry controls (if available) determine the amount of effect heard.

The contributing track faders control the balance within the submix. The Auxiliary Input track controls the output levels of all tracks routed to it.

You can apply mix automation to the volume, pan, mute, and send level, send pan, and send mute controls of the Auxiliary Input.

You can also bounce a submix to disk to free up the voices for use by other tracks. See Chapter 28, “Mixdown” for information.

Send and Return Submixing for Effects Processing

When you are submixing for reverb, delay, and similar effects processing, use sends to achieve traditional send/return bussing. You can use a real-time plug-in or a hardware insert as a shared resource for all tracks included in a submix. The wet/dry balance in the mix can be controlled using the track faders (dry level) and Auxiliary Input fader (effect return, or wet, level).

See Chapter 26, “Plug-in and Hardware Inserts” for more information.
Send and Return with a Plug-in or Hardware Insert

To create an effects return submix with a plug-in or hardware insert:

1. Assign each track’s main output to your main mix outputs.

2. On the source tracks, assign a send (mono or stereo) and select a mono or stereo bus path from the Send selector. Configure the sends for pre- or post-fader, as needed.

3. Choose Track > New.

4. Specify the track type (Aux Input) and format (stereo), then click Create.

5. From the Auxiliary Input track’s Input Path selector, select the send bus path.

6. Assign a plug-in or hardware insert on the Auxiliary Input.

7. Set the effect to “100% wet,” and set any other controls as desired.

8. From the Auxiliary Input track’s Output Path selector, select an output path (main outputs).

Adjust the individual track faders to balance the dry (unprocessed) tracks. With the send set to pre-fader, the amount of effect is controlled by the level of the Send Level fader or the Auxiliary Input Volume fader. If the send is post-fader, the Send Level fader follows volume level.

Send and Return Submixes with External Devices

To create an effects return submix with an external device:

1. Assign each track’s main output to your main mix outputs.

2. Assign a send (mono or stereo) and set the send destinations on the source tracks to the output path connected to the external device. Configure the sends for pre- or post-fader, as needed.

3. Choose Track > New.

4. Specify the track type (Aux Input) and format (stereo or mono), then click Create.
5 From the Auxiliary Input track’s Input Path selector, select the input path connected to the external device.

6 From the Auxiliary Input track’s Output Path selector, select an output path (main outputs).

Adjust the individual track faders to balance the dry (unprocessed) tracks. The amount of effect is controlled by the level of the Send Level fader or the Auxiliary Input Volume fader.

To create a monitor submix:

1. Assign each track’s main output to your main mix outputs.

2. Assign a send (mono or stereo) and set the send destinations on the source tracks to the output path connected to the external device. Configure the sends for pre- or post-fader, as needed.

3. Choose Track > New.

4. Specify the track type (Aux Input) and format (stereo or mono), then click Create.

5. From the Auxiliary Input track’s Output Path selector, select the output path (not the main outputs) for monitoring the mix.

Adjust the Auxiliary Input track fader to control the volume for the monitor mix.

Creating Monitor Submixes

Route track sends to one or more Auxiliary Input tracks to monitor submixes in a studio environment. For example, you may want to provide the bassist with a drum submix for tracking a new bass part.
Creating a Master Send Level Control

A Master Fader can control the overall level of bus and output paths.

To create a Master send level control:

1. Choose Track > New.
2. Specify the track type (Master Fader), and mono, stereo, or any of the supported multi-channel formats for surround mixing.
3. Click Create.
4. Do one of the following:
   • Set the output of the Master Fader to the same path that you are using to send to an Auxiliary Input track.
   • Set the output of the Master Fader to match the path that you have chosen for your effects send.

You can then adjust send levels to balance the source tracks, and use the Master Fader as a master level control for the entire submix.

Soloing Tracks in a Submix

Soloing any tracks implicitly mutes all other tracks, including Auxiliary Inputs. Solo-safing an Auxiliary Input prevents this implicit muting and lets the Auxiliary Input continue to pass audio when its source tracks are in Solo.

To solo safe an Auxiliary Input:

■ Control-click (Windows) or Command-click (Mac) the Solo button on the Auxiliary Input track.

To solo an individual track that is part of a group:

■ Start-click (Windows) or Control-click (Mac) the Solo button.

Generating Stereo Output from a Mono Send/Return

You can use an Auxiliary Input to generate a stereo output from a mono send. Set the send destination to a mono Auxiliary Input track and place a mono to stereo plug-in on the Auxiliary Input. The output of the Auxiliary Input becomes stereo.

To create a “stereo” effect from a mono source, you must use reverb, delay, or other time-domain effects.

Delay Compensation
(Pro Tools HD Only)

Pro Tools provides Delay Compensation for managing DSP delays that occur on audio, Auxiliary Input, Master Fader, or Instrument tracks because of plug-in use and mixer routing. With Delay Compensation enabled, Pro Tools maintains time-alignment between tracks that have plug-ins with differing DSP delays, tracks with different mixing paths, tracks that are split off and recombined within the mixer, and tracks with hardware inserts.

To maintain time alignment, Pro Tools adds the exact amount of delay to each track necessary to make that particular track’s delay equal to the delay of the track that has the longest delay.

Delay Compensation should be enabled during mixing and playback for optimal delay-compensated sound. In some cases when recording, Delay Compensation should be turned off.

To enable Delay Compensation:

■ Choose Options > Delay Compensation.
Delay Compensation Settings

There are three settings in the Playback Engine dialog for dedicating DSP resources for Delay Compensation:

**None** Allocates no DSP resources for Delay Compensation.

**Short** Allocates minimal DSP resources of Delay Compensation for each channel. This is the most efficient setting for Pro Tools|HD Accel systems.

**Long** Allocates maximum DSP resources of Delay Compensation for each mixer channel. Long Delay Compensation uses the same DSP resources used by high DSP overhead plug-ins.

**To configure the Delay Compensation Engine:**

2. From the Delay Compensation Engine pop-up menu, select a Delay Compensation setting.
3. Click OK.

The Delay Compensation status will be saved as a session and system preference.

Delay Compensation View

The Delay Compensation View displays the total amount of plug-in delay on each track, lets you apply a user offset of track delay, and displays the total amount of delay that Pro Tools applies to each track. The Delay Compensation View can be shown in the Mix Window.

To view Delay Compensation information:

- Select View > Mix Window > Delay Compensation.

Delay values can be specified in either samples or milliseconds, as selected in the Display Preferences page.

Plug-in Delay (dly) Indicator

The Plug-in Delay (dly) indicator shows the total plug-in and hardware insert delay on the track. This delay total is used by Pro Tools to calculate the delay applied to other tracks to keep them time-aligned. The track with the highest plug-in and insert delay displays delay information in orange.

Bypassing the track’s reported delay to Pro Tools can be useful if your total plug-in delay on a track exceeds the amount allowed in the Delay Compensation Engine setting. After bypassing the track’s reported delay, you must manually nudge your track earlier by the reported amount to achieve the proper Delay Compensation for that track, while continuing to use Delay Compensation (see “User Offset (+/-) Field” on page 554.)

To bypass reporting plug-in delay to Pro Tools:

- Start-Control-click (Windows) or Command-Control-click (Mac) the Plug-in Delay indicator. The track delay will appear greyed out, and Pro Tools will not use that track’s plug-in delay to calculate Delay Compensation for the other tracks.

User Offset (+/-) Field

This field lets you adjust track delays manually. In addition to the automatic delay, positive or negative delay times can be entered in the user offset (+/-) field.
This is useful for changing the feel of a track or for time-aligning a track in case a plug-in is incorrectly reporting its delay.

**To change track delay using the User Offset field:**

1. In the Delay Compensation View, click in the User Offset edit field.

2. To set your delay value (in samples or milliseconds depending on your current preferences), do one of the following:
   - Enter a positive number (with or without the “+” modifier) or negative number (with the “–” modifier.)
   - Control-drag (Windows) or Command-drag (Mac) in the User Offset field to scroll to a new value.
   - Press the Up and Down Arrow keys to increase or decrease the numerical values.

3. Press Enter.

**To bypass the user delay:**

- Start-Control-click (Windows) or Command-Control-click (Mac) the User Offset field. The user defined delay will appear greyed out, and it will no longer be applied to the track.

**Track Compensation (cmp) Indicator**

This indicator shows the amount of compensation Pro Tools applies to each track.

**Delay that Exceeds the Compensation Limit**

When the total delay on a track exceeds the amount of compensation available, Pro Tools applies the maximum available compensation, and displays the delay information in red (in the Delay Compensation View) for any tracks that cannot be fully compensated. The Delay Compensation indicator in the Edit window also turns red to indicate that the track delay exceeds the Delay Compensation limit. In this case, you need to bypass the track’s reported delay (see “Plug-in Delay (dly) Indicator” on page 554), then manually nudge the track to maintain proper Delay Compensation (see “User Offset (+/–) Field” on page 554).

**Low Latency Monitoring During Recording**

For recording, Pro Tools automatically suspends Delay Compensation to provide a low latency monitor path through the main outputs of the record-enabled tracks. When an audio track is armed for recording (in stop), TrackInput-enabled, DestructivePunch-enabled, or punched in, the track’s Delay Compensation is automatically suspended (and the Track Compensation indicator displays 0).

You can suspend this automatic suppression of Delay Compensation as needed by doing the following:

**To apply Delay Compensation to tracks where Delay Compensation was suspended:**

- Start-Control-click (Windows) or Command-Control-click (Mac) the Track Compensation indicator. Track delay will be applied to the track and the Track Compensation indicator will display in blue.

**Track Compensation on Auxiliary Inputs**

Delay Compensation on Auxiliary Inputs can be bypassed to let you monitor outside sources (such as the audio tracks of a slaved video deck) with minimal latency, while still reporting the track’s delay.
To bypass an Auxiliary Input’s Delay Compensation:

Start-Control-click (Windows) or Command-Control-click (Mac) the Track Compensation indicator. The reported track delay will be zero, and will appear greyed out.

**Delay Compensation for MIDI**

When Delay Compensation is active, a MIDI event that is recorded to sound “in time” with delay-compensated material actually is recorded late by the length of total delay in effect.

To compensate, MIDI events are shifted back in time by the total session delay following each MIDI recording pass.

**Low-Latency Recording with Virtual MIDI Instruments**

When a MIDI or Instrument track that is routing MIDI data to an instrument plug-in is record-enabled, Pro Tools automatically suspends Delay Compensation through the main outputs of the audio track or Auxiliary Input that the instrument plug-in is inserted on. This allows for latency-free monitoring of the instrument plug-in during recording.

Delay Compensation for virtual MIDI instruments works only when all MIDI and audio connections take place inside of Pro Tools. For example, Pro Tools does not suspend Delay Compensation when you are using ReWire to connect software synthesizers and samplers in other ReWire client applications (such as Live and Reason).

**MIDI and Audio Processing Plug-ins**

Some audio processing plug-ins (such as Bruno and Reso) and many instrument plug-ins let you process audio while allowing MIDI data to control processing parameters. When you record enable a MIDI or Instrument track that is controlling an audio processing plug-in, the track the plug-in is inserted on will go into low-latency mode, effectively making the processed audio play early.

To keep audio time-aligned when recording using a MIDI controlled plug-in on an audio track:

- Start-Control-click (Windows) or Command-Control-click (Mac) the Track Compensation indicator for the audio track to apply Delay Compensation.

To keep audio time-aligned when recording using a MIDI controlled plug-in on an Auxiliary Input:

1. Start-Control-click (Windows) or Command-Control-click (Mac) the Track Compensation indicator for the Auxiliary Input to bypass Delay Compensation.

2. Enter the total system delay into the User Offset field.
Dither

Dither is a special form of randomized noise used to mask quantization noise in digital audio systems. Digital audio’s poorest distortion performance exists at the lowest end of the dynamic range, where quantization distortion can occur. Dither reduces quantizing errors by introducing very low-level random noise, thereby minimizing distortion artifacts as audio reaches low level. With dither there is a trade-off between signal-to-noise performance and less-apparent distortion. Proper use of dither lets you squeeze better subjective performance out of a 16-bit data format (such as Red Book compact discs).

Pro Tools HD systems process all audio internally at 24-bit, and Pro Tools LE processes internally at 32-bit, floating. Without dither to process the 24-bit data to 16-bit, the extra 8 bits are truncated (dropped entirely) when written to media or a device with a 16-bit maximum (such as CD recorders, and many DAT machines).

Dithering, on the other hand, preserves low-level (quiet) fidelity in a surprising way—by adding a small amount of noise to a signal.

Dither in Pro Tools

There are several dither options provided in Pro Tools. Each has a specific application within the various operations that could benefit from dithering.

In addition to the TDM, RTAS and AudioSuite dither plug-ins, Pro Tools has a built-in dither capability.

Dither Mixer Plug-ins (Pro Tools HD Only) There are two Mixer plug-ins that feature dither with noise shaping: Stereo Dithered and Surround Dithered. For more information, see the Pro Tools HD Getting Started Guide. Standard Stereo and Surround Mixers do not have dither and require use of dither plug-ins.

Dither on Final Output for Mixdown You can insert a real-time dither plug-in on a Master Fader that controls your output mix, to dither your final mix for CD or other 16-bit media. Inserts on Master Fader process post-fader. This form of dithering lets you use dither plug-ins from Digidesign or third-party manufacturers. When using the Bounce to Disk, see “Dither and Bounce to Disk” on page 636.

AudioSuite Dither For AudioSuite plug-in processing, dither is based on the Dither plug-in.

For most AudioSuite plug-ins, dither can be automatically applied in the Processing Preferences page. The Use AudioSuite Dither checkbox enables a preset, N-shaped dither.
The following AudioSuite plug-ins can automatically apply dither when processing:

- EQ III
- Compressor II
- Limiter II
- Gate II
- Expander/Gate II
- Normalize
- Gain
- DC Offset Removal
- Time Compression/Expansion
- Pitch Shift

Noise Shaping is available in the Dither plug-in.

For more information about AudioSuite Dither, see the Digi-Rack Guide.

Fades and Crossfades In the Fades dialog (Edit > Fades > Create), the Use Dither option enables a preset, noise-shaped dither.

Create Fades dialog

Noise Shaping

Noise is an integral part of the dithering process. Noise shaping can further improve audio performance and reduce perceived noise inherent in dithering. Noise shaping utilizes digital filtering to move noise from frequencies around 4 kHz to near the Nyquist frequency. Essentially, noise shaping lessens our perception of the noise inherent in dithering by shifting audible noise components to a range in which the human ear is less sensitive.

For more information about dither during mixdown, see Chapter 28, “Mixdown.”

Using a Control Surface with Pro Tools

Control surfaces add hands-on control to Pro Tools functions. You can use a control surface to adjust on-screen faders and knobs, activate transport controls, or scrub and shuttle in Pro Tools.

There are several optional Digidesign control surfaces for mixing in Pro Tools:

- Digidesign’s D-Control and D-Command (Pro Tools HD Only) Innovative tactile worksurfaces that employ a familiar, intuitive channel strip/center section console layout.

- Digidesign’s Control|24 (Pro Tools HD and LE Only) Dedicated controller that provides access to most Pro Tools recording, mixing, editing, signal routing, plug-in control, and automation features.

- Digidesign’s Command|8 Low cost USB-based control surface for Pro Tools. Command|8 is a compact, convenient, and flexible control surface for Digidesign-qualified Pro Tools systems.

For more information about audioSuite Dither, see the Digi-Rack Guide.
Chapter 26: Plug-in and Hardware Inserts

Pro Tools provides up to five unity-gain inserts on each audio, Auxiliary Input, Master Fader, and Instrument track. Audio, Auxiliary Input, and Instrument track inserts are pre-fader, and Master Faders inserts are post-fader.

An insert can be either a software DSP plug-in or a hardware insert. A Pro Tools insert routes the signal from the track to a plug-in or external hardware effect of your choice and automatically returns it to the same track. Inserts do not alter the original audio source files, but process audio in real time, during playback. You can permanently apply real-time effects to tracks by recording or bouncing the effect to disk (see Chapter 28, “Mixdown” for more information).

**Plug-in Inserts**
Plug-in inserts are software inserts that process audio material on a track in real time. For example, the DigiRack EQ, compressor, and delay plug-ins supplied with your Pro Tools system can be used as real-time plug-in inserts.

For more information about the plug-ins supplied with your Pro Tools system, see the DigiRack Plug-ins Guide.

Additional real-time plug-ins are available from Digidesign and from many third-party developers.

**Hardware I/O Inserts**
Hardware I/O inserts can route audio through an external device connected to parallel inputs and outputs of an audio interface. You can process the audio material on a track with a hardware insert in real time.

Insert paths require audio interface inputs and outputs, and are determined by the I/O Setup configuration of your system.

**General Information**
When more than one insert is used on a track, they are processed in series. Each effect is added to that of any previous plug-ins or inserts (flowing from top to bottom in the Mix window Inserts View, and left to right in the Edit window Inserts View).
Inserts on audio tracks and Auxiliary Inputs and Instrument tracks are pre-fader. You can cause clipping if you boost their gain to extremes, especially on tracks recorded at high amplitude. Watch on-screen metering for indication of clipping. (Inserts on Master Faders are post-fader.)

### How to Use Inserts for Effects Processing

Inserts can be used in two ways:

**On Single Tracks** An insert can be applied to an individual audio, Auxiliary Input, Master Fader, or Instrument track.

With in-line inserts, you control the amount of effect by adjusting the balance (or, wet/dry) controls of the plug-in or external device.

**As Shared Resources** An insert can be used as a shared resource in a send-and-return arrangement, by bussing signals from several tracks to an Auxiliary Input, and then applying the insert to the Auxiliary Input track. You can then control the send level for each track, and the overall level of the effect can be controlled from the Auxiliary Input track. Using sends and other signal routing features helps maximize your system’s processing power.

For examples of send and return busses and other submixing setups, see “Submixing for Signal Routing and Effects Processing” on page 548.

### Insert Formats

**Mono Inserts** Used on mono tracks. Inserts that occur on a track after a stereo insert are automatically used in stereo as well.

**Stereo Inserts** Used on stereo tracks. A stereo hardware I/O insert sends the signal to an input/output path.

**Mono In/Stereo Out Plug-in Inserts** Used to return a stereo effect from a mono source. Certain plug-ins (such as D-Verb) let you generate stereo output from a mono channel. A track made into stereo in this way has panning controls for each channel of the stereo signal. Any inserts that occur on a track after a stereo insert are automatically used in stereo as well.

**Multi-Mono Plug-in Inserts** Used on stereo or greater-than-stereo multichannel tracks when a multichannel version of the plug-in is not available. Controls for all channels are linked by default so that you can adjust them in tandem. You can unlink controls for independent adjustment using the Master Link button. See “Linking and Unlinking Controls on Multi-Mono Plug-ins” on page 575.

**Multichannel Plug-in Inserts** Used on stereo and greater-than-stereo multichannel tracks. On greater-than-stereo multichannel tracks, the controls for all channels are generally linked together.

Relinking may cause automation to be lost. See “Linking and Unlinking Controls on Multi-Mono Plug-ins” on page 575

### TDM and RTAS Plug-ins

There are three plug-in formats supported by Pro Tools (TDM, RTAS, and AudioSuite), two of which can be used as real-time inserts, as follows:

**TDM Plug-ins** Used with Pro Tools HD systems, these plug-ins rely on the processing power of DSP on Pro Tools|HD system cards.

**RTAS Plug-ins** Similar to their TDM counterparts, but unlike TDM plug-ins, they rely on and are limited by the host processing power of your computer.
AudioSuite Plug-ins  Non-real-time, file-based processing plug-ins for Pro Tools (see the DigiRack Guide).

Depending on your Pro Tools software, plug-ins can be used as follows:

Pro Tools HD

• Both TDM and RTAS plug-ins can be used on audio, Auxiliary Input, Master Fader, and Instrument tracks.

⚠️ With Pro Tools HD, RTAS plug-ins placed on Auxiliary Input, Master Fader, and Instrument tracks will use additional voices and may introduce extra latency based on the HW Buffer Size. For more information, see “Voice Usage and Total Latency for RTAS Plug-ins” on page 561.

Pro Tools LE and M-Powered

• RTAS plug-ins can be used on audio, Auxiliary Input, Master Fader, and Instrument tracks.

⚠️ For tips on maximizing RTAS performance, see the DigiRack Plug-ins Guide.

Voice Usage and Total Latency for RTAS Plug-ins

(Pro Tools HD Only)

With Pro Tools HD, the initial insert of an RTAS plug-in may cause additional latency, and will take up two additional voices per channel (one voice for input and one voice for output) in the following conditions:

• When inserted on an Auxiliary Input or Master Fader track
• When inserted on an Instrument track that does not contain an instrument plug-in
• When inserted after a TDM plug-in on any kind of track

For example, the initial insert of an RTAS plug-in on a mono Auxiliary Input track uses two voices (one channel with two voices), while the initial insert of that plug-in on a stereo Auxiliary Input track uses four voices (two channels with two voices each).

Subsequent RTAS plug-ins on the same track do not take up additional voices unless a TDM plug-in is inserted between other RTAS plug-ins.

⚠️ Avoid inserting TDM plug-ins between RTAS plug-ins on any kind of track—this causes unnecessary voice usage and may cause additional latency.

Furthermore, one additional voice is used for each occurrence of any of the following conditions when using voices for RTAS plug-ins on a track:

• When you use the external key side-chain of an RTAS plug-in on that track
• When you select multiple track outputs for that track (one voice used for each output)
• When you select an AFL/PFL Path output in the Output tab of the I/O Setup dialog (one voice used for each channel)

⚠️ When you use Pro Tools 6.9.x or lower to open a session originally created with Pro Tools 7.0, any RTAS plug-ins inserted on Auxiliary Input or Master Fader tracks—or after TDM plug-ins on any kind of track—will become inactive.
### Viewing Inserts

Both the Mix and Edit windows can be configured to show or hide inserts. Plug-in windows provide complete access to plug-in controls.

**To show (or hide) inserts, do one of the following:**

- In the Mix window (or Edit window), select View > Mix Window (or Edit Window) > Inserts.

- Select Inserts View from the Edit Window or Mix Window View selector.

### Display of Plug-in Window Status

In the Mix and Edit window, the plug-in button and selector display the currently inserted plug-in, its bypass state (see “Bypassing Plug-ins” on page 575), target status, and window status.

### Indicating the Controller Target

If you are using a control surface with Pro Tools, only one plug-in can be targeted at a time. The current controller target, if any, is indicated with a color outline around its name:

### Making Inserts Inactive

Plug-in and hardware inserts can be made inactive to free up their resources for other uses. When a plug-in insert is inactive it retains its assignment, position, and related automation playlists. However, it will not pass audio and does not consume any DSP or TDM resources.

When opening sessions, inserts will automatically be made inactive in any of the following situations:

- The system has insufficient DSP resources.
- A plug-in is not installed.
- A plug-in type is not available (RTAS or TDM).
Chapter 26: Plug-in and Hardware Inserts

• Opening the session results in plug-in type substitutions. This can happen if the type is available but substituting would result in an unsupported condition, such as opening a session containing a TDM plug-in for which an RTAS version is unavailable.

To make an insert inactive, do one of the following:
- Control-Start-click (Windows) or Command-Control-click (Mac) the Insert button.
  – or –
- Make the track inactive. See “Making Tracks Inactive” on page 122.

To toggle inserts in the same position on all tracks active or inactive:
- Control-Start-Alt click (Windows) or Command-Control-Option click (Mac) an Insert button in the position you want to toggle.

To toggle inserts in the same position on all selected tracks active or inactive:
- Control-Start-Alt-Shift-click (Windows) or Command-Control-Option-Shift-click (Mac) an Insert button in the position you want to toggle.

Inactive Plug-in Inserts
Inactive plug-in inserts retain all associated automation playlists. In addition, any edits made in the session affect the plug-in automation playlists. You cannot record automation or adjust the controls for an inactive plug-in.

Display of inactive Plug-in window

Inactive Hardware Inserts
Inactive hardware inserts retain their assignments, but do not pass audio and do not consume any DSP resources.

Hardware inserts do not provide a bypass control. You can use the inactive feature whenever you need to mute or bypass a hardware insert.

Inserting Plug-ins on Tracks
To use a real-time plug-in, insert it on a track.

To insert a plug-in on a track:
1. Make sure the Inserts View is shown in the Mix or Edit window.
2. Click the Insert selector on the track and select the plug-in that you want to use. (See “TDM and RTAS Plug-ins” on page 560 for related information.)

Inserting a TDM plug-in
To remove an insert from a track:

- Click the Insert selector and choose No Insert.

### Ordering RTAS and TDM Plug-ins on Audio Tracks

(Pro Tools HD Only)

With Pro Tools HD, when RTAS and TDM plug-ins are combined on an audio track, Auxiliary Input, or Master Fader, the order in which they are inserted has different results:

**RTAS Plug-ins Grouped Before TDM Plug-ins**

No additional voices will be used, and no processing latency will occur. RTAS plug-ins will be bypassed when Record Enable or TrackInput monitoring is enabled for that track.

**TDM Plug-ins Grouped Before RTAS Plug-ins**

Each initial insert of an RTAS plug-in after a TDM plug-in on a track will cause processing latency, and will use voices as described in “Voice Usage and Total Latency for RTAS Plug-ins” on page 561. RTAS plug-ins will stay active while Record Enable or TrackInput monitoring is enabled for that track.

⚠️ As a rule, always group plug-ins of the same type together, especially if inserting RTAS after TDM plug-ins. Otherwise, additional voices may be unnecessarily used.

### Ordering Recommendations

When combining RTAS and TDM plug-ins on an audio track, use one of the following two strategies based on your recording needs:

- To ensure that RTAS plug-ins stay active when you record enable a track or use TrackInput monitoring, order all TDM plug-ins before RTAS plug-ins.
  - or -
- To conserve voices and minimize processing latency, order all RTAS plug-ins before TDM plug-ins.

### Configuring Plug-ins During Playback and Recording

Playback must be stopped before performing any of the following operations:

- Dragging a plug-in to a different location
- Inserting or removing a plug-in while recording
- Inserting or removing a plug-in that changes a track's format
- Inserting an RTAS plug-in on or removing an RTAS plug-in from an Auxiliary Input or Master Fader track
- Inserting an RTAS plug-in after a TDM plug-in on an audio track
- Removing an RTAS plug-in from an audio track if it comes after a TDM plug-in
- Inserting TDM plug-ins before an RTAS plug-in on an audio track
- Removing a TDM plug-in from an audio track if it comes before an RTAS plug-in.
- Removing a plug-in that contains automation data
- Enabling plug-in controls for automation
- Configuring an external side-chain input
Plug-in Menu Organization

You can customize how plug-in lists (plug-in menus) are organized in the Insert selector and Plug-in selector.

Use the “Organize Plug-in Menus By” pop-up menu in the Pro Tools Display Preferences page to organize plug-in menus in a Flat List (with plug-ins in alphabetical order), or by Category, Manufacturer, or Category and Manufacturer.

Category Organizes plug-ins by process category (such as EQ, Dynamics, and Delay), with individual plug-ins listed in the category submenus. Plug-ins that do not fit into a standard category (such as the DigiRack Signal Generator), or third-party plug-ins that have not had a category designated by their developers, appear in the Other category. Plug-ins can appear in more than one category.

Plug-in categories include:
- EQ
- Dynamics
- Pitch Shift
- Reverb
- Delay
- Modulation
- Harmonic
- Noise Reduction
- Dither
- Sound Field
- Hardware
- Instrument
- Other
- Wrapped Plug-ins
- Effects

The Effects subfolder organizes special effects, multi-effect processors, and other plug-ins. All plug-ins that specify their plug-in category as an “Effects” type will be displayed within the Effects subfolder.

⚠️ If no plug-ins within a certain category are installed on your system, the subfolder named for that category will not appear in the menu.
Manufacturer Organizes plug-ins by their manufacturer (such as Digidesign, Eventide, Line 6, and McDSP), with individual plug-ins listed in the manufacturer submenus. Plug-ins that do not have a Manufacturer defined will appear in the “Other” manufacturer folder.

Most Digidesign-distributed third party plug-ins will be grouped under Digidesign when this option is enabled.

⚠️ If no plug-ins by a certain manufacturer are installed on your system, the subfolder named for that manufacturer will not appear in the menu.

Category and Manufacturer Organizes plug-ins in two levels of menus. The top menus display plug-ins by process category (such as EQ, Dynamics, and Delay), with individual plug-ins listed in the category submenus. The bottom menus display plug-ins by manufacturer (such as Digidesign, Eventide, Line 6, and McDSP), with individual plug-ins listed in the manufacturer submenus.

To select how plug-ins are organized:
1. Open or create a session.
2. Choose Setup > Preferences, and click Display.
3. Click the “Organize Plug-in Menus By” pop-up menu, and select one of the view options.
4. Click OK.

The current “Organize Plug-in Menus By” setting is saved with Pro Tools preferences (it is not saved with the Pro Tools session file).

Control Surface Support

Digidesign control surfaces with multi-color LCDs (such as D-Control) indicate plug-ins as follows:

- Plug-in categories (such as EQ) and plug-in manufacturers (such as Digidesign) are indicated in green text.
- Specific plug-ins located in the plug-in subfolders (such as EQ III in the EQ subfolder) are indicated in yellow (amber) text.

Control surfaces with single-color displays (such as ProControl and Command|8) do not indicate plug-in view choices. They display contents of a plug-in folder as a single list of plug-ins.

Plug-in Favorites

To find a plug-in faster, a plug-in can be designated as a favorite. Favorite plug-ins are shown at the top of the plug-in menu.

When a plug-in becomes a favorite, it is still shown in its plug-in category and its name appears in bold.

To designate a plug-in as a favorite:

- Control-click (Windows) or Command-click (Mac) on a plug-in Insert button, and select a plug-in from a plug-in category to designate it as a favorite.
To change the status of a plug-in favorite:

- Control-click (Windows) or Command-click (Mac) on a plug-in Insert button, and select a plug-in favorite that you no longer want to designate as a favorite.

When selecting the plug-in favorite to change, you can select the plug-in from the list of favorites at the top of the plug-in menu, or in its plug-in category (where the plug-in appears in bold).

Default EQ and Dynamics Plug-ins

You can set a default EQ plug-in and Dynamics plug-in, which places them at the top of the Insert selector pop-up menu on-screen, and first in the list of menu choices when assigning inserts on ICON work surfaces.

To set a default plug-in:

1. Choose Setup > Preferences and click Mixing.
2. Under Setup, choose a plug-in from the Default EQ or Default Dynamics pop-up menu.
3. Click OK to close the Preferences window.

Moving and Duplicating Plug-in and Hardware Inserts

You can move or duplicate an insert by dragging it to a different position on the same track or a different track. Inserts that are moved or duplicated retain their original settings and automation.

⚠️ Plug-ins cannot be moved or duplicated during playback or recording.

To move an insert:

- Drag the insert to a new insert location.

Moving a plug-in

⚠️ Dragging an insert on top of an existing insert will replace it and any automation.

To duplicate an insert:

- Alt-drag (Windows) or Option-drag (Mac) the insert to a new insert location. Duplicated plug-in inserts retain their original settings and automation.

💡 You can also duplicate Sends. See “Moving or Copying Sends” on page 542.
The Plug-in Window

The Plug-in window appears whenever you click a plug-in’s Insert button on a track. This floating window lets you edit the adjust the controls of any real-time plug-in insert in use on a track.

**Insert button and selector on track**

- **Insert selector**
- **Insert button**

**Track Selector** Accesses any non-MIDI track in a session.

**Insert Position Selector** Accesses any insert on the current track.

**Plug-in Selector** Lets you select any real-time plug-in installed in the Plug-ins folder (that is created when you install Pro Tools).

**Effect Bypass Button** Disables the currently displayed plug-in. This lets you compare the track with and without the effect.

**Convert Plug-in Selector** Lets you convert the insert from a TDM plug-in to an RTAS plug-in of the same type (or vice-versa). This feature can only be used on plug-ins that are available in both TDM and RTAS formats.

**Clip LED** Lights red to indicate if any meter in a plug-in has clipped (not available on all plug-ins). The Plug-in Clip LED follows Pro Tools settings for clip indication.

**Settings Menu** Lets you copy, paste, save, and import plug-in settings.

**Librarian Menu** Recalls settings files saved in the plug-in’s root settings folder or in the current session’s Settings folder. See “Using the Librarian” on page 571.

**Next (+) and Previous (–) Setting Buttons** Let you select the next or previous plug-in setting from the Librarian menu.

**Compare** Toggles between the original saved plug-in setting and any changes you have made to it so you can compare them.

**Auto Button** Lets you enable individual plug-in controls for automation recording. See “Automating Plug-ins” on page 596.

**Automation Safe** When enabled, prevents existing plug-in automation from being overwritten.

---

You will lose the current settings if they are not saved before you use the Next and Previous Setting buttons. Always save your settings to the Librarian menu.

---

Plug-ins Settings Select Button Accesses the Plug-in Settings dialog, which lists the settings files for the current plug-in. From this list, you can select a new setting, or audition a series of settings.
**Target Button** When multiple Plug-in windows are open, clicking this button selects that plug-in as the target for any computer keyboard commands. For more information, see “Targeted Windows” on page 547.

**Key Input Selector** Lets you select audio on a particular input or bus and route it to trigger the plug-in. This menu only appears on plug-ins that feature side-chain processing. Key inputs are monophonic.

**MIDI Node Display** Shows MIDI node information for MIDI-enabled plug-ins. MIDI nodes are virtual connections from Pro Tools to software instruments and other MIDI-enabled plug-ins. MIDI nodes are useful for routing multiple MIDI tracks to different channels of a single virtual MIDI device. MIDI node numbers are also displayed in a track’s MIDI Output selector.

**Master Link Button** When enabled, links the controls on all channels of a multi-mono plug-in so that they can be adjusted in tandem.

**LFE Enable** Enables plug-in processing of the LFE (low frequency effects) channel on a multi-channel track formatted for 5.1, 6.1, or 7.1 surround formats on some plug-ins. To disable LFE processing, deselect this button.

**Tempo Sync** Enables compatible plug-ins to automatically synchronize to the session tempo, for rhythmic delay, echo, and similar effects.
Opening Plug-in Windows

To open a plug-in window:

- Click the plug-in button in the Mix or Edit window channel strip.

By default, each plug-in you open will appear in the same location as a currently open plug-in, replacing it in the same window location.

Opening Multiple Plug-in Windows

Pro Tools normally displays a single plug-in window from which you can adjust the controls of any session plug-in. You can also open additional Plug-in windows for specific plug-ins. Once you begin working with multiple plug-in windows, you will need to click the Target button on the plug-in whose controls you want to adjust using keyboard commands.

To open an additional plug-in window:

- In the Mix window, Shift-click the Insert button of a plug-in.

To open plug-in windows for each channel of a multi-mono plug-in:

- Alt-click (Windows) or Option-click (Mac) the Channel selector in the Plug-in window of a plug-in insert.

To close all currently open plug-in windows:

- Alt-click (Windows) or Option-click (Mac) the close box of any currently open plug-in window.

Plug-in Window Controls

All plug-ins provide standard Pro Tools controls for track and insert selection, bypass, and other controls, in addition to the EQ, dynamics, and other processor-specific controls.

To select a different plug-in on the same track:

- Click the Insert selector and select a plug-in from the pop-up menu.

Choosing a plug-in from the Plug-in window

To choose a different track:

- Click the Track selector and choose a track from the pop-up menu.

Choosing a track from the Plug-in window

Target Window and Settings Shortcuts

When multiple plug-in windows are open, a highlighted target indicates the target window. Pro Tools keeps a single plug-in target window. Opening a new plug-in opens it as the new target window, in the same location. In addition, the plug-in target window is also the focus of keyboard shortcuts for plug-in settings.
Using the Librarian

The Settings Librarian makes it easy to create your own library of plug-in settings. Using the Librarian and Settings pop-up menus, you can copy, paste, save, and import these settings from plug-in to plug-in, or from session to session.

Once you create and save settings files to disk (and tell Pro Tools where to find them by assigning their root folder) they will appear in the Librarian menu (and in the Plug-in Settings dialog).

💡 You can also use the Plug-in Settings dialog to select settings or audition them. See “Plug-in Settings Dialog” on page 574.

The Settings Menu

Use the Settings menu commands to save, copy, paste, and manage plug-in settings files.

Settings menu commands include:

**Save Settings** Saves the current settings. This command overwrites any previous version of the settings. The setting then appears in the Librarian menu.

**Save Settings As** Saves the current settings under a different name.

**Copy Settings** Copies the current settings. You can then apply these settings to the same type of plug-in on a different track by choosing the track in the Plug-in window and pasting the settings with the Paste Settings command.

**Paste Settings** Pastes settings copied with the Copy Settings command.

**Import Settings** Imports a settings file from a location other than the Root Settings folder or Session folder.

**Delete Current Settings File** Permanently deletes the current settings file from disk.

**Lock Settings File** Prevents the current settings from being overwritten by the Save command. If you attempt to save control settings, you will be required to save them using a different name or disk location.

**Set As User Default** Defines the current settings as the User Default for a specific plug-in.

**Settings Preferences**

The Settings Preferences sub-menus are for choosing preferences for saving and importing plug-in settings. They include:

**Set Plug-in Default To** Sets the default setting to either Factory Default (the standard default setting for that plug-in) or User Default (your custom setting).
Save Plug-in Settings To Selects the folder where plug-in settings are saved. If you choose Session Folder, the settings are saved in a folder named “Plug-in Settings” within the current Session folder. If you choose Root Settings Folder, the settings are saved in the folder you specified with the Set Root Settings Folder command.

Set Root Settings Folder Selects a location or root folder for saving and importing settings. This root settings folder must be named “Plug-in Settings.” Use this command only if you want to choose a location other than the default Plug-in Settings folder.

The default location for the Root Plug-in Settings folder is as follows:

Windows Program Files\Common Files\Digidesign\DAE\Plug-in Settings

Mac Library/Application Support/ Digidesign/Plug-in Settings

To save plug-in settings to any location other than the default Plug-in Settings folder, you must first create a folder named “Plug-in Settings” in the new location and then save to that folder.

Choosing a Destination for Settings

Before you save plug-in settings, select their destination folder.

To select a destination folder:

From the Settings pop-up menu, choose Settings Preferences > Save Plug-in Settings To, and choose Session Folder or Root Settings Folder.

If you choose Root Settings folder, Pro Tools saves to the default Root Plug-in Settings folder unless you have specified a different location for the Root Settings folder.

To select a different Root Settings folder:

1. From the Settings pop-up menu, choose Settings Preferences > Set Root Settings Folder.
2. Select the folder you want to use as your Root folder and click Select.

Creating Subfolders for Settings

To make it easier to find specific types of settings, you can subdivide settings files by creating subfolders for them.

Creating a settings subfolder:

3. From the Settings pop-up menu, choose Save Settings.
4. Click the New Folder button and type a name for the subfolder.
5. Name the setting and click Save. The setting is saved within the subfolder.

Managing Settings

Use the Settings pop-up menu to manage settings.

Unlinked multi-mono plug-ins have specific rules for settings. See “Linking and Unlinking Controls on Multi-Mono Plug-ins” on page 575.

To save a setting:

1. Choose Save Settings from the Settings pop-up menu.
2 Type a name and click OK. The setting appears in the Librarian menu.

- Press Control+Shift+S (Windows) or Command+Shift+S (Mac) to save plug-in settings.

**To load a previously saved setting:**
- Choose the setting from the Librarian pop-up menu.

**To import a setting:**
1. Choose Import Settings from the Settings pop-up menu.
2. Locate the settings file you want to import and click Open. Pro Tools loads the setting and copies it to the root destination folder.

**To copy a setting:**
- Choose Copy Settings from the Settings pop-up menu.

- Press Control+Shift+C (Windows) or Command+Shift+C (Mac) to copy plug-in settings.

**To paste a setting:**
1. Open the destination plug-in.
2. Choose Paste Settings from the Settings pop-up menu.

- Press Control+Shift+V (Windows) or Command+Shift+V (Mac) to paste plug-in settings.

**To create a custom User Default setting:**
1. Create and save a setting.
2. Choose Set As User Default from the Settings pop-up menu.

**To make a plug-in default to your custom setting:**
- From the Settings pop-up menu, choose Settings Preferences > Set Plug-in Default To > User Setting.

### Changing Settings with the Next (+) and Previous (−) Setting Buttons

These buttons let you select the next or previous setting of the Librarian menu.

**To change plug-in settings using the +/− buttons:**
- Click the Plus (+) or Minus (−) buttons to select the next or previous plug-in settings file. The next (or previous) settings file are enabled, and the Librarian menu changes to reflect the new setting.

⚠️ You will lose the current settings if they are not saved before you use the Next and Previous Setting buttons. Always save your settings to the Librarian menu.

### Editing Settings on Unlinked Multi-Mono Plug-ins

When a multi-mono plug-in is unlinked, importing, copying, pasting, or bypassing settings affects only the currently selected channel.

**To apply an operation to all channels of an unlinked plug-in:**
- Hold down the Alt key (Windows) or Option key (Mac) while performing the command.
Plug-in Settings Dialog

The Plug-in Settings dialog lists the settings files for the current plug-in type. From this list, you can select a new setting, or audition a series of settings. Auditioning plug-in settings is especially useful for selecting patch names for virtual MIDI instrument plug-ins or trying out different effects types applied to your audio.

Use the Folder pop-up menu at the top of the Settings dialog to switch between plug-in settings subfolders, or root and session settings folders.

The Plug-in Settings dialog includes the following:

Folder This pop-up menu lets you switch between settings located in root or session folders (and any available subfolders).

Patch Field This field displays the name of the active (highlighted) setting.

Increment Patch Every X Sec This option lets you audition contiguous plug-in settings on-the-fly by automatically scrolling through them for a specified number of seconds.

To change plug-in settings using the Plug-in Settings dialog:

1. Click the Settings Select button.

2. Do one of the following:
   - From the dialog list, select the desired plug-in setting.
   - or -
   - Use the Arrow keys to scroll through the available settings.

3. Click Done.

Auditioning Plug-in Settings

When the Plug-in Settings dialog is open, you can have Pro Tools automatically scroll through and audition the settings files saved in the plug-in’s root settings folder or in the current session’s settings folder.

To audition plug-in settings:

1. Click the Settings Select button.

2. From the dialog list, click a setting—the starting point from which you will scroll through the settings files.

3. Enter a value for the number of seconds that will elapse between each program change.

4. Select the option for Increment Patch.

After the specified number of seconds, Pro Tools selects the next setting.
When you are finished auditioning settings, do one of the following:

- Click Done to stop incrementing patches, and to close the Plug-in Settings dialog.
- or –
- Select the Increment Patch option to stop incrementing patches and keep the Plug-in Settings dialog open.

**Bypassing Plug-ins**

Plug-ins can be bypassed from their Plug-in window, or from the Mix and Edit window Inserts View.

When a plug-in insert is bypassed, the Insert selector in the Mix window changes its color to blue for easy visual reference. If some, but not all channels of an unlinked multi-mono plug-in are bypassed, the Insert selector appears purple.

**To bypass a plug-in, do one of the following:**

- Click the Plug-in window’s Effect Bypass button.
- or –
- Control-click (Windows) or Command-click (Mac) the plug-in’s Insert button in the Mix or Edit window.

**Linking and Unlinking Controls on Multi-Mono Plug-ins**

When a multi-mono plug-in is used on a stereo track or greater-than-stereo multichannel track (Pro Tools HD only), the controls are linked by default. Adjusting the Gain control on one channel, for example, will adjust it for all channels.

You can unlink multi-mono plug-in controls on specific channels of a track and edit them independently. You can also selectively link the controls of specific channels.

**To unlink controls on a multi-mono plug-in:**

- Deselect the Master Link button.

**To access controls for a specific channel:**

- Select the channel from the Channel selector.

**To link the controls of specific channels:**

1. Deselect the Master Link button if it is not already deselected.

2. Click the Link Enable buttons for the channels whose controls you want to link. For example, on plug-ins that do provide discrete LFE controls from the LFE Enable button, you can link all channels except the LFE by highlighting the icons representing the five full-range speakers in a multi-mono plug-in.
Editing Plug-in Controls

You can adjust plug-in controls by dragging the control’s slider or knob, or by typing a value into the control’s text box. For instructions on editing specific plug-ins, see the plug-in’s documentation (such as the DigiRack Plug-ins Guide and Digidesign Plug-ins Guide).

To adjust a plug-in control:

1. Begin audio playback so that you can hear the control changes in real time.
2. Adjust the controls of the plug-in for the effect you want.
3. Close the Plug-in window to save the most recent changes.

Keyboard Shortcuts

- For finer adjustments, Control-drag (Windows) or Command-drag (Mac) the control.
- To return a control to its default value, Alt-click (Windows) or Option-click (Mac) the control.

Keyboard Shortcuts for Plug-in Controls

You can use your computer keyboard to edit plug-in controls.

If multiple Plug-in windows are open, Tab and keyboard entry remain focused on the plug-in that is the target window.

To adjust controls from a computer keyboard:

- Click or Tab to the control text field that you want to edit to activate the field. Type an appropriate value.
- In fields that support values in kilohertz, typing “k” after a number value will multiply the value by 1,000. For example, type “8k” to enter a value of 8,000.
- To increase a value, press the Up Arrow on your keyboard. To decrease a value, press the Down Arrow on your keyboard.
- Press Enter on the numeric keyboard after typing a value to input the value (without leaving the selected control field).
- Press Enter on the QWERTY keyboard (Windows) or Return (Mac) to enter the value and leave keyboard editing mode.
- To move forward through the different control fields, press the Tab key. To move backward, press Shift+Tab.
- Press Alt-C (Windows) or Option-C (Mac) to clear plug-in clipping.

The plug-in target window is the focus of keyboard shortcuts for plug-in settings. To make a plug-in the target for any computer keyboard commands (including key shortcuts), click the plug-in’s Target button in its Plug-in window.

Plug-in Automation and Safe

All real-time plug-ins can be fully automated, and support all Pro Tools Automation modes (Write, Touch, and Latch, plus Trim).

The Auto button opens the Plug-in Automation dialog, where you can enable individual plug-in controls for automation recording. (See “Automating Plug-ins” on page 596 for more information.)
The Safe button engages Automation Safe mode. When enabled, existing plug-in automation is protected from being overwritten. (See “Record Safing Plug-in Automation” on page 597.)

**Using a Side-Chain Input**

The side-chain input is the split-off signal used by a plug-in’s detector to trigger dynamics processing, and is generally drawn internally from the input signal. However, some plug-ins let you switch between internal and external side-chain processing.

With external side-chain processing, a plug-in’s detector is triggered by an external signal (such as a separate reference track or audio source) known as the key input.

A typical use for external side-chain processing is to control the dynamics of one audio signal using the dynamics of another signal (the key input). For example, a kick drum track could be used to trigger gating of a bass track to tighten it up, or a rhythm guitar track could be used to gate a keyboard pad.

**Side-Chain Filters**

Some plug-ins feature key high-pass and low-pass filters. These controls let you define a specific frequency range in the side-chain signal with which to trigger the plug-in effect. A common production technique is to use these controls to filter a drum track so that only specific high frequency sounds (such as a hi-hat) or low frequency ones (such as a tom or a kick) trigger the effect.

**Using a Key Input for External Side-Chain Processing**

To use a key input for external side-chain processing:

1. Click the plug-in’s Key Input selector and select the input or bus carrying the audio you want to use to trigger the plug-in.

2. Click the External Key to activate external side-chain processing.

3. Press the Spacebar to begin playback. The plug-in uses the input or bus that you chose as a key input to trigger its effect.

4. During playback, do any of the following to fine-tune key input triggering:
   - To hear the audio source you have selected to control the key input, enable Side-Chain Listen or Key Listen (depending on the plug-in). When finished, disable Side-Chain Listen/Key Listen to resume normal plug-in monitoring.
   - To filter the key input so that only specific frequencies trigger the plug-in, use the filtering controls (if available) to select the desired frequency range.

5. Adjust the plug-in’s Threshold control (if available) and other controls as needed.
Using Hardware Inserts

You can connect external devices, such as reverb or effects processors, to your Pro Tools system and use them as hardware inserts on individual tracks or on submixes.

Pro Tools inserts utilize corresponding hardware input and output channels to send and return the audio. Inserts can be defined, and their channels mapped to audio interface channels, in the I/O Setup dialog.

If you plan to use a device as an insert, be sure to connect the device to matching inputs and outputs on your system. For example, a hardware insert being supplied by outputs 7–8 needs to be returned to hardware inputs 7–8.

Delay Compensation can be applied to Hardware Inserts. See “H/W Insert Delay Compensation” on page 93.

To define a hardware insert:
1. Choose Setup > I/O, then click the Inserts tab.
2. Select an insert path, or click New Path to create a new Insert path.
3. Double-click the Path Name to enter a custom path name for the insert.
4. Make sure the insert path is set to the correct format (mono, stereo, or other).
5. Map inserts in the Channel Grid as needed. Insert and Output paths have special rules regarding channel mapping (see “Overlapping Channels and Valid Paths” on page 86).

Assigning Hardware Inserts

To assign an external hardware insert to a track:
- Select an insert from the track Insert selector.

Bypassing Hardware Inserts

Hardware inserts do not provide a bypass control. To monitor playback without a hardware insert, either set it to Inactive, remove it by reassigning it to No Insert, or use a bypass switch on the hardware device itself. (See “Making Inserts Inactive” on page 562 for more information.)
Connecting and Integrating
External Devices

Pro Tools can create dedicated connections to external analog or digital devices. The number and type of connections depends on what kind of system you have.

To connect an external device to a Pro Tools system:

1. Connect an unused output (or pair of outputs for a stereo device) of your Pro Tools system to an input of the external signal processor.

2. Connect the output of the external signal processor to an unused input (or pair of inputs for a stereo device) of your Pro Tools system.

3. Define what physical ports are routed to Pro Tools input and output ports, as appropriate, in either the Hardware Setup dialog or I/O Setup dialog.

4. Define output, input, or insert paths as appropriate in the I/O Setup dialog.

If you plan to use a device as an insert, be sure to connect the device to matching inputs and outputs on your system. For example, to use outputs 7–8, the insert has to use inputs 7–8 also.

For additional information on connecting external devices, refer to your Pro Tools Getting Started Guide.

Connecting Effects Units Digitally

If you want to use the digital inputs and outputs on your Pro Tools system as effects sends and returns to a digital effects device, Pro Tools should be the clock master in most cases. Set your digital effects device to accept an external digital clock so that it synchronizes to Pro Tools.

To set up a digital send to an external device from a Pro Tools|HD system:

1. Do one of the following:
   - On a 192 I/O, 192 Digital I/O, 96 I/O, 96i I/O, or 888|24 I/O, choose Setup > Hardware, choose the peripheral, format, and clock format, and set the channel pair to Digital.
   - On an 882|20 I/O or 1622 I/O, choose Setup > Hardware, choose the peripheral, and set Channel 1–2 input to Digital.

2. Choose Internal from the Clock Source pop-up menu.

3. Click OK.

To set up a digital send to an external device from a Digi 002 or Digi 002 Rack system:

1. Choose Setup > Playback Engine and choose the peripheral.

2. Do one of the following:
   - If the external device is connected to the S/PDIF RCA jacks, deselect S/PDIF Mirroring. (When S/PDIF Mirroring is on, digital output at the S/PDIF RCA jacks exactly mirrors the output of analog Channels 1–2.)
   - If the external device is connected to the Optical ports, choose a format (most likely S/PDIF for an effects device) from the Optical Format pop-up menu.

3. Choose Internal from the Clock Source pop-up menu.

4. Click OK.

5. Optionally, configure the I/O Setup dialog with new path names for effects routing.

If you set the Optical Format to S/PDIF, Pro Tools will watch the Optical port for any audio input, and ignore any audio input on the S/PDIF RCA jacks.
Using External Clock Sources (for Recording and Monitoring)

When recording or monitoring, Pro Tools can synchronize to an external clock source. Options for external clock vary according to the type of Pro Tools system you are using.

Pro Tools|HD Systems

Pro Tools|HD systems can receive external clock through any of the digital inputs on any Pro Tools|HD I/O (including AES/EBU, S/PDIF, and Optical).

With an expanded Pro Tools|HD system that includes Legacy interfaces (such as the 888|24 I/O), connect to the digital input on Channels 1–2 of the Legacy audio interface in order to clock from them. Legacy I/Os only support 44.1 kHz and 48 kHz sample rates.

To select an external clock source for a Pro Tools|HD system:

1. Choose Setup > Hardware.
2. Select the appropriate Pro Tools|HD I/O in order to display its settings in the Main page.
3. If necessary, enable the appropriate Digital Format (if you have not already done so, according to the instructions in your Getting Started Guide or I/O Guide).
4. Set the Clock Source to match the type of input.
5. Configure input routing of the digital source, using the Input and Output pop-up menus, if necessary.
6. Click OK to close the Hardware Setup dialog.

Digi 002 or Digi 002 Rack Systems

Pro Tools can receive external clock from the Optical input or S/PDIF input.

To select an external clock source for a Digi 002 or Digi 002 Rack system:

1. Choose Setup > Hardware.
2. Set the Clock Source to match the type of input.
3. If you choose Optical, make sure the Optical Format matches the type of optical input you are sending to your Pro Tools system.

Mbox 2 and Mbox Systems

Pro Tools can receive external clock from the S/PDIF input on these interfaces.

To select an external clock source for an Mbox 2 or Mbox system:

1. Choose Setup > Hardware.
2. Choose the SPDIF (Windows) or SPDIF/RCA (Mac) from the Clock Source pop-up menu.
3. Click OK.

Your digital input device must be connected and powered on for Pro Tools to synchronize to it. If your input device is not powered on, leave the Clock Source set to Internal.
Chapter 27: Automation

Pro Tools features dynamic automation of mixing controls on each of the track types. You can write automation moves and view them in real time during playback of your session. You can also edit automation data with the same techniques you use to edit audio and MIDI data.

Automation Accuracy with Control Surfaces

Digidesign Control Surfaces Digidesign’s D-Control, D-Command, ProControl, Control|24, and Command|8 control surfaces support the automation features in Pro Tools. Digidesign control surfaces provide 10-bit resolution, or 1,024 steps of fader resolution. Pro Tools interpolates this input to 24-bit resolution on playback, resulting in extremely accurate and smooth fader automation.

MIDI Control Surfaces Most MIDI control surfaces have 7-bit resolution, or 128 steps. Pro Tools interpolates this input to 24-bit resolution on playback, resulting in accurate and smooth fader automation.

Automation Quick Start

Pro Tools provides many options for recording, replacing, and editing automation data.

The basic steps for automation recording are:

- Enable the automation type that you want to record (volume, pan, mute, send level, send pan, send mute, or plug-in automation).
- Put the appropriate tracks in an automation writing mode (Write, Touch, or Latch, or a Trim mode).
- If you are automating a plug-in, enable the individual plug-in controls to be automated.
- Automation Safe any plug-ins, outputs, or sends that have existing automation data that you want to protect from being overwritten.
- Begin playback to begin automation recording, and adjust controls as needed. Pro Tools remembers all moves performed on enabled controls.

To edit automation once it has been recorded, you can:

- Repeat the above steps to write new automation over the previous data.
- Graphically edit the automation data in the Edit window.
- Cut, copy, paste, or delete automation data (certain restrictions apply).

For details on using Digidesign control surfaces to create mix automation, refer to your Digidesign control surface guide.
Automation Playlists

Each Pro Tools track contains a single automation playlist for each automatable parameter.

On audio tracks, these parameters include:
- Volume
- Volume trim
- Pan
- Mute
- Send level
- Send level trim
- Send pan
- Send mute
- Plug-in controls

On Auxiliary Input tracks, these parameters include:
- Volume
- Volume trim
- Mute
- Pan

On Master Faders, these parameters include:
- Volume
- Volume trim

On MIDI tracks, these parameters include:
- Volume (MIDI)
- Pan (MIDI)
- Mute

On Instrument tracks, these parameters include:
- Volume (audio)
- Volume trim (audio)
- Mute (audio)
- Pan (audio)

On VCA Master tracks, these parameters include:
- Volume
- Volume trim
- Mute

You can display and edit each of these automatable playlists individually from Pro Tools, even during playback.

In addition, on MIDI and Instrument tracks you can display and edit other continuous MIDI controller data (such as mod wheel, breath controller, foot controller, or sustain) in a similar manner. For more information on editing MIDI data, see “Continuous Controller Events” on page 472.

Automation Playlists with Audio and MIDI Regions

Pro Tools handles audio regions and their automation playlists differently from MIDI regions and their automation playlists.
Audio Tracks

On audio tracks, automation data resides on a separate playlist from audio data and regions. Each edit playlist on an audio track shares the same automation data.

MIDI and Instrument Tracks

On MIDI tracks and Instrument tracks, all controller automation data except for MIDI Mute data, or audio mute (Instrument tracks only), is stored in the MIDI region that contains it. Each edit playlist on the track is separate, and represents a distinct performance, complete with controller automation.

⚠️ MIDI Mute data is independent of the MIDI data in a MIDI region. This lets you mute playback of individual MIDI or Instrument tracks in Pro Tools without altering the controller data.

Trim Automation Playlists

Separate Trim automation playlists are available for Volume trim and Send Level trim. Volume trim is available on all track types except MIDI tracks. Send Level trim is available on audio tracks only.

Each Trim automation playlist shows the position of the Trim fader with yellow breakpoint automation that can be edited. For more information on Trim playlists, see “Trim Mode” on page 587 and “Viewing Automation” on page 591.

Multiple Edit Playlists and Audio Track Automation

All edit playlists on a single audio track share the same automation data. When you record or edit automation data in an audio track, the automation data is stored in the track’s corresponding automation playlist so it can be edited with, or independently from, its associated audio regions.

⚠️ MIDI continuous controller data always follows region editing, with the exception of mute. See “MIDI and Instrument Tracks” on page 583 for more information.

✦ When you copy or cut audio data from a track while it is in Waveform View, the underlying automation data is cut or copied with it.

✦ If you paste audio data from other locations or tracks into an edit playlist, you may change the underlying automation data on the track.

✦ When you trim regions using Edit > Trim, the underlying automation data remains unchanged.

For more information, see “Editing Automation” on page 606.

Duplicating Tracks for Playlist Editing

The Duplicate Track command provides a convenient way to make a working copy of a track to experiment with routing, plug-ins, and automation. This protects the original track and its automation data from being edited or overwritten.
To copy a track for automation:

1. Select the track and choose Track > Duplicate.

2. In the Duplicate Tracks dialog, do any of the following:
   - Type the number of copies into the Number of Duplicates field.
   - To copy the currently active (visible) Edit playlist from the source track, select Active Playlist.
   - To copy all Edit playlists on the source track, select Alternate Playlists.
   - To copy all automation from the source track, select Automation.
   - To copy all plug-in and insert assignments, select Inserts.
   - To copy all sends and send assignments, select Sends.
   - To maintain all Mix and Edit Group assignments, select Group Assignments.

3. Click OK to duplicate the track according to the settings in the Duplicate Tracks dialog.

4. To temporarily disable the original track, make it inactive by doing one of the following:
   - Control-click (Windows) or Command-click (Mac) the Track Type icon for the track.
   - Select the track and choose Track > Make Inactive.

5. Edit automation on the duplicated track.

**Automation Modes**

Automation modes control how a track’s automation data is written and played back. Each track provides an Automation Mode selector for selecting the track’s Automation mode.

**Off Mode**

Off mode turns off automation for all automatable parameters:
- Volume
- Pan
- Mute
- Send volume, pan, and mute
- Plug-in controls
- MIDI volume, pan, and mute

In Off mode, automation data for these parameters is ignored during playback. All other MIDI controller data is sent.

Automation can be switched from Off to another Automation mode during playback or record.

**Read Mode**

Read mode plays any automation that was previously written for a track.

**Write Mode**

Write mode writes automation from the time playback starts to the time it stops, erasing any previously written automation for the duration of the automation pass.

AutoMatch can be applied to a Write automation pass. See “AutoMatch Time” on page 590.
“After Write Pass, Switch To” Preference

You can set Pro Tools to automatically change to Touch mode or Latch mode, or remain in Write mode after the completion of an automation pass in Write mode.

To set the Automation mode after a Write pass:
1. Choose Setup > Preferences and click Mixing.
2. Under Automation, select an “After Write Pass, Switch To” option (Touch, Latch, or No Change).
3. Click OK to close the Preferences window.

Touch Mode

Touch mode writes automation only while a fader or switch is touched or clicked with the mouse. When the fader is released, the writing of automation stops and the fader returns to any previously automated position, at a rate determined by the AutoMatch and Touch Timeout settings. See “Automation Preferences” on page 589.

In Touch mode, certain control surfaces start writing automation as soon as you touch them. These include touch-sensitive fader controllers, such as Digidesign’s D-Control, D-Command, ProControl, Control|24, Digi 002, Command|8, or the Mackie HUI.

With other control surfaces in Touch mode, writing of automation does not begin until the fader hits the pass-through point, or the previously automated position. Once you reach the pass-through point with the fader, or a non-touch sensitive rotary control, writing of automation begins and continues until you stop moving the fader.

Latch Mode

Latch mode works in the same way as Touch mode, writing automation only if you touch or move a control. However, unlike Touch, writing of automation continues until you stop playback or “punch out” of the automation pass by changing the Automation mode to Read or Touch.

AutoMatch can be applied to a Latch automation pass. See “AutoMatch Time” on page 590.

Latch mode is particularly useful for automating Pan controls and plug-ins on non-touch sensitive rotary controls, since it does not time out and revert to its previous position when you release a control.

See also “Writing Automation to the Start, End, or All of a Track or Selection” on page 617.
AutoJoin with Latch Mode

Pro Tools provides two different methods to resume writing automation on controls that were active at the point where the transport stopped:

**AutoJoin** Lets you automatically resume writing automation in Latch mode.

**Join** Lets you manually resume writing automation in Latch mode. Join is available only with Digidesign-supported control surfaces.

**To enable AutoJoin from Pro Tools:**

1. Choose Window > Automation.
2. Click the AutoJoin button.

See your control surface guide for details on using Join and AutoJoin with a control surface.

AutoJoin Indicator

After a Latch automation pass with AutoJoin enabled, the AutoJoin indicator appears in the Pro Tools Edit window.

*AutoJoin indicator in the Edit window*

The AutoJoin indicator is a vertical line that signifies the point where the last automation pass was stopped, and the point where the “join” will automatically occur on all tracks that were writing during that previous pass. When automation writing is resumed from this point, the line disappears.

⚠️ To use Join or AutoJoin to resume writing on controls that were writing when the transport stopped, restart the transport before the AutoJoin indicator.

Touch/Latch Mode

Touch/Latch Automation mode places a track’s Volume control in Touch mode and all other automatable controls in Latch mode.

In Touch/Latch mode, the Volume control follows Touch behavior, writing automation when touched and returning to previously written levels when released.
All other controls follow Latch behavior, writing automation when touched and continuing until playback stops, or until you punch out of writing automation.

When Trim mode is enabled, non-trimmable controls behave in the same manner as in the standard Automation modes, with the exception of Write/Trim mode, where non-trimmable controls operate as in Touch mode.

**Trim Automation Modes**

When a track is in a Trim automation mode (except for Trim Off) its main Volume faders and all Send level faders are displayed in yellow. When trimming, a track’s Volume indicator or Send Level indicator shows the delta value being written rather than the absolute value.

Behavior of the Trim Automation modes also depends on the Coalesce Trim Automation preference setting. See “Coalescing Trim Automation” on page 616.

**Trim Off**

Trim Off turns off reading and writing of all automation (main and trim) for a track. All automation moves are ignored during playback. Trim faders are temporarily set to zero when a track is set to Trim Off mode.

Depending on the Coalesce Trim Automation preference setting, changing a track to Trim Off can coalesce Trim automation on that track. See “Coalescing Trim Automation” on page 616.

Automation can be switched from Trim Off to another Automation mode during playback or record.

**Read Trim**

In Read Trim mode, Volume and Send level Trim faders are disengaged from the main automation playlist and follow any existing Trim automation. You can move a Trim fader during
playback to audition new trim values, but no automation is written. When the Trim fader is released, it returns to any previously written Trim automation values.

If a track does not contain Trim automation, you can move a Trim fader during playback to audition new trim values, but no automation is written. The Trim fader retains its position until the track is removed from Trim mode, or if you manually coalesce the Trim level.

When this mode is enabled, non-trimmable controls (all controls other than track volume and send level) behave as if they are in regular Read mode—no automation data is written.

**Touch Trim**

In Touch Trim mode, Volume and Send level Trim faders are disengaged from the main automation playlist and follow any existing Trim automation. When a Trim fader is touched, writing of Trim automation begins. When the fader is released, writing stops and the fader returns to any previously written Trim automation values.

The rate of the fader’s return to previous trim values is determined by the AutoMatch Time specified in the Automation Preferences page. See “AutoMatch Time” on page 590 for more information.

When this mode is enabled, non-trimmable controls (all controls other than track volume and send level) behave as if they are in regular Touch mode—they follow the previously written automation until touched. When they are touched, their absolute positions are written until playback is stopped.

**Latch Trim**

In Latch Trim mode, Volume and Send level Trim faders are disengaged from the main automation playlist and follow any existing Trim automation. When a Trim fader is touched, writing of Trim automation begins. Writing of Trim automation continues until playback stops, or until you punch out of writing automation.

When this mode is enabled, non-trimmable controls (all controls other than track volume and send level) behave as if they are in regular Latch mode—they follow the previously written automation until touched. When they are touched, their absolute positions are written until playback is stopped.

**Touch/Latch Trim**

In Touch/Latch Trim mode, Volume and Send level Trim faders are disengaged from the main automation playlist and follow any existing Trim automation. The main Volume Trim fader follows Touch Trim behavior, and Send level Trim faders follow Latch Trim behavior.

**Write Trim**

In Write Trim mode, as soon as playback begins, writing of Trim automation begins for Volume and Send levels, and continues until playback stops, or until you punch out of writing automation.

When Write Trim mode is enabled, non-trimmable controls (all controls other than track volume and send level) are not in Write mode, but behave as if they are in regular Touch mode.
Automation Preferences

Pro Tools gives you several options for controlling the writing and playback of automation data.

To display Automation preferences:
- Choose Setup > Preferences and click Mixing.

Send Levels and Trim Mode

You can set Pro Tools to exclude Send levels from Trim mode, so that only the Main Volume goes into Trim when a track is put into Trim mode. This gives you more flexibility in setting Send levels while in Trim mode.

To exclude Send levels from Trim mode:
1. Choose Setup > Preferences and click Mixing.
3. Click OK.

Smoothing

When you perform automation moves (including Trim moves) with a continuous control, Pro Tools records the move as a series of very small steps, resulting in a staircase pattern with many breakpoints. Smoothing intelligently resolves this staircase pattern into a single, smooth ramp from one breakpoint to the next. (Smoothing does not apply to switched controls such as mutes or plug-in bypasses.) With smoothing enabled, the resulting automation data is often a more accurate representation of actual automation moves.

Thinning

Thinning automatically reduces the overall number of breakpoints in an automation playlist (including Trim playlists) in order to improve system performance. The amount of thinning applied is determined by the Degree of Thinning setting in the Automation Preferences.
page. When using high amounts of thinning, the resulting automation may differ noticeably from the original automation moves. Thinning only applies to audio tracks, and does not affect MIDI tracks. For instructions, see “Thinning Automation” on page 604.

**AutoMatch Time**

AutoMatch Time is the amount of time it takes for a fader to return (by ramping up or down) to the level of automation still on the track as the automation pass ends. This time value is set in the Automation Preferences page (see “Automation Preferences” on page 589).

AutoMatch is automatically applied to all Touch mode passes, and can be applied to Latch or Write passes.

The AutoMatch Time also determines the rate at which delta values written with the Trim will return to 0 dB (delta value of zero).

The AutoMatch feature works with continuous controls (such as Volume or Pan) by ramping their values back to previously automated levels. There are some stepped controls (for example, the EQ type in the 1-band EQ plug-in) that provide more than two discrete steps over their operational range. AutoMatch has no effect on these controls.

**Automation Buffer Size**

Pro Tools lets you specify the size of the memory buffer used to write automation. If you are working on a large session or writing a very large number of automation moves, you may want to increase this value.

**To set the Automation Buffer size:**

1. Choose Setup > Preferences and click Mixing.
2. Under Automation, for the option “Amount of Memory to Reserve for Automation Recording,” enter a value between 200 and 20,000K. The default value for a new session is 200K.
3. Click OK to close the Preferences window.
4. Relaunch Pro Tools for this change to take effect.

**To reduce processing load, try one of the following:**

- Reduce the density of automation in places where it shows the most activity. For details, see “Thinning Automation” on page 604.

- Deselect the “Show Meters in Sends View” option, if selected, in the Display Preferences page. See “Individual Send Views and Meters” on page 540 for more information.

**Automation Follows Edit Option**

When disabled, automation events are not affected by edits to audio or MIDI notes. When enabled, automation events are affected by edits to audio or MIDI notes.

**To disable Automation Follows Edit:**

- Choose Options > Automation Follows Edit.
Automation Safe

Outputs, sends, and plug-ins can be placed in Automation Safe mode. In Automation Safe mode, any automation associated with an Output window (such as track or send level, panning, or mute), or plug-in on that track, is protected from being overwritten while automating other items on that track.

Automation Safe mode suspends automation recording for the selected track output, send, or plug-in that is enabled. You can also suspend automation recording and playback session-wide from the Automation window. See “Enabling and Suspending Automation” on page 601.

Viewing Automation

Pro Tools creates a separate playlist in the Edit window for each type of automation in a track, including a playlist for each type of Trim automation. This data can be viewed and edited in the same way as audio and MIDI data.

To display an automation playlist:

- Click the Track View selector and select from the pop-up menu the automation type you want to view.

Automaton Safe enabled send

Automation Safe enabled send

To display an automation playlist:

- Click the Track View selector and select from the pop-up menu the automation type you want to view.

Displaying Trim automation playlists

You can easily toggle between different Track Views. See “Changing Track Views” on page 257.

Displaying Trim Automation Along with the Main Playlist

The appearance of Trim automation depends on how it is set to be coalesced. See “Coalescing Trim Automation” on page 616.

If automation is not set to coalesce after every automation pass, you can display Trim automation data along with the main Volume or Send level automation data in the same automation view. This Trim automation display cannot be directly edited.
To display the Trim automation playlist along with main automation playlist on tracks:

- Choose View > Automation > Trim Playlist.

Displaying the Composite Automation Playlist

If automation is not set to coalesce after every automation pass, you can display a composite automation playlist that shows the contribution of the Trim automation to the main Volume or Send Level automation data. This composite playlist display cannot be directly edited.

The composite playlist is shown in both the main automation playlist and the Trim automation playlist.

To display the composite playlist:

- Choose View > Automation > Composite Playlist.

AutoMatch Indicators

There are triangular AutoMatch indicators at the bottom left of each channel strip in the Mix window. When lit, these indicate the direction the fader will automatically move when Auto-Matching.

Writing Automation

You can write automation for all automatable controls by moving those controls during playback.

To write automation on tracks:

1. Choose Window > Automation.
2. Make sure the automation type is write-enabled.

Display of Trim automation in a main Volume playlist.

Display of Trim automation and the composite playlist in a main Volume playlist.
3 In the Mix or Edit window, click the Automation Mode selector on each of the tracks you want to automate, and set the Automation mode. For the initial automation pass, choose Write mode.

![Setting the Automation mode of a track](image)

4 Click Play to begin writing automation.

5 Move the controls you want to automate.

6 When you have finished, click Stop.

💡 If you write automation in Touch mode with Loop Playback enabled, writing of automation will automatically stop at the end of the looped selection. At the beginning of each successive loop, you can then touch or move the control again to write new data.

**Storing an Initial Control Position**

When you create a new audio, Auxiliary Input, VCA Master, MIDI, or Instrument track, it is automatically placed in Read mode. Even though the track is in Read mode, you can set the initial position of any automatable control, and it is saved with your session.

In this initial state, only a single automation breakpoint appears at the beginning of each automation playlist. If you move the control without writing automation, this breakpoint will move to the new value.

You can permanently store the initial position of an automatable control by doing any of the following:

- Place the track in Write mode and press Play to write a few seconds of automation data to the track
- Manually place a breakpoint on the automation playlist somewhere after the initial breakpoint. (See “Graphical Editing of Automation Data” on page 606 for more information.)

**To write additional automation to a previous pass:**

1 Enable Options > Link Timeline and Edit Selection.

2 In the Edit window, make a selection or place the cursor in the location where you want to start writing automation.

3 In the Mix or Edit window, click the Automation Mode selector on each of the tracks you want to automate, and set the Automation mode to Touch or Latch mode.

4 Click Play to begin writing automation.

5 Move the controls you want to automate.
Automating Switched Controls

When automating switched controls (such as mutes, plug-in bypasses, or switched controls on plug-ins) Pro Tools treats them as touch sensitive controls. Automation data is written for as long as the switch or button for that control is pressed or touched.

For example, if you have just written a series of mute on/off states on a track in quick succession, the manual method for clearing this automation data would require you to move to the Edit window, choose automation playlist for Mute, select the mute automation data, and delete it. In Pro Tools, this can be done automatically.

To automate a switched control (such as the Mute button):

1. Perform another automation pass on the track.
2. When you reach the location of the mute state you want to remove, press and hold down the switched control (such as the Mute button).
3. As long as the button is held down, Pro Tools overwrites the underlying data on the track with the current state of the switch (on or off) until playback is stopped.

Automating Switched Controls in Touch Mode

When automating switched controls (including mute, plug-in bypass, and any switched control on a plug-in) in Touch mode, these controls will latch in their current state after they are touched.

However, to preserve any automation for that switched control later in the timeline, this latched behavior ends if either of the following occurs:

- If an existing automation breakpoint is encountered, Pro Tools stops writing automation at that point.
- If you stop playback or punch out of writing automation before reaching an existing automation breakpoint, Pro Tools AutoMatches to the underlying automation state.

Setting Switched Controls for Momentary Behavior

In some cases, such as when overwriting or extending Mute automation, you may want to momentarily write automation for a control by holding it down, and not have the control latch.

To set switched controls for momentary behavior:

1. Choose Options > Preferences and click Mixing.
2. Deselect Latching Behavior for Switch Controls in Touch.
3. Click OK to close the Preferences window.
Automating Sends

Pro Tools provides automation of send level, send mute, and send pan (for stereo and multi-channel sends only). This makes it easy to control effect levels and placement during mix-down with great precision.

Send level and mute can also be configured to follow groups.

To automate a send level, mute or pan:

1. In the Automation window, make sure the automation type is write-enabled (send level, send mute, send pan).

2. In the Mix or Edit window, set the Automation mode for each track containing sends you want to automate. For each track, click the Automation Mode selector and set the Automation mode. For the initial automation pass, choose Write mode.

3. If sends are not currently visible on your tracks, select View > Mix Window (or Edit Window) > Sends A–E (or Sends F–J).

4. To display send controls, do one of the following:
   - Click the send to open the Output window for the send that you want to automate.
   - or —
   - Choose View > Sends A–E (or Sends F–J) and select one of the individual views (such as Send A).

5. Click Play to begin writing automation.

6. Move the controls you want to automate.

7. When you have finished, click Stop.

Send level, mute, and pan can also be configured to follow Mix Groups. See “Automation Preferences” on page 589 for information.

Copying Track Automation to Sends (Pro Tools HD Only)

There may be times where you want a track's send automation to mirror automation in the track itself, for example, when an effect level needs to follow the levels in a main mix. To do this, you can copy the entire automation playlist for the selected control to the corresponding playlist for the send.

To copy a track’s automation to one of its sends:

1. Select the tracks you want to edit by clicking on the track names to highlight them.

2. Choose Edit > Automation > Copy to Send.

3. In the Copy to Send dialog, select Automation to copy the entire automation playlist for the corresponding controls.

4. Select the controls you want to copy.

5. Select the sends to which to copy the automation, and click OK.

When overwriting automation, Pro Tools presents a confirmation dialog. To suppress this dialog, press Alt (Windows) or Option (Mac) while clicking OK.

You can undo the results of the Copy to Send command.
Automating Plug-ins

You can automate changes to virtually all plug-in controls. Automating a plug-in is slightly different from other automation procedures, because you must enable individual plug-in controls for automation.

To enable plug-in controls for automation:
1. Open the Plug-in window for the plug-in you want to automate.
2. Do one of the following:
   • Click the Automation Enable button in the Plug-in window.
   – or –
   Control-Alt-Start-click (Windows) or Command-Option-Control-click the Track View selector in the Edit window.
3. In the plug-in automation dialog, choose the controls to automate and click Add. If there are multiple plug-ins on the same track, you can select from among them by clicking their buttons in the Inserts section of this dialog.
4. Click OK to close the Plug-in Automation dialog.

To automate a plug-in:
1. In the Plug-in Automation Enable window, make sure plug-in automation is enabled.
2. In the Mix or Edit window, for each track containing plug-ins you want to automate, click the Automation Mode selector and set the Automation mode. For the initial automation pass, choose Write mode.
3. Click Play to begin writing automation, and move the controls you want to automate.
4. When you have finished, click Stop.

Enabling Automation for Individual Plug-in Parameters

You can enable individual plug-in controls directly from the Plug-in window.

To enable a plug-in parameter from the plug-in window:
1. Make sure the plug-in window is open for the plug-in you want to automate.
2. Control-Alt-Start-click (Windows) or Command-Option-Control-click (Mac) the control for the parameter.
Enabling Automation for All Plug-in Parameters

To enable all plug-in parameters:
1. Make sure the plug-in window is open for the plug-in you want to automate.
2. Control+Alt+Start-click (Windows) or Command+Option+Control-click (Mac) on the Auto button at the top of the plug-in window.

 Automatically Enabling Plug-ins for Automation

You can set Pro Tools to automatically enable all controls of a plug-in for automation when you first add the plug-in to your session.

To automatically enable all plug-in controls for automation:
1. Choose Setup > Preferences and click Mixing.
2. Select “Plug-in Controls Default to Auto-Enabled.”
3. Click OK to close the Preferences window.

Record Safing Plug-in Automation

You can protect plug-in automation from being overwritten by using Automation Safe mode.

To enable plug-in safe mode:
1. Open a plug-in.
2. Click the Safe button so that it is highlighted.

AutoMatching Controls

You can AutoMatch all currently writing controls to their existing automation levels.

To AutoMatch all currently writing controls:
1. Choose Window > Automation.
2. Make sure the automation types you want to AutoMatch are write-enabled.
3. Start playback.
4. When you reach a point in the track where you want to return control to their previously written values, click the AutoMatch button in the Automation window.

All currently writing controls stop writing automation and return to any previously written values according to the AutoMatch Time setting in the Mixing preferences.

AutoMatching Individual Tracks

You can invoke AutoMatch on individual tracks. All controls currently writing automation on the track stop writing and return to existing automation levels.
To AutoMatch all controls on a track:
- Control-click (Windows) or Command-click (Mac) the Automation Mode selector on the track.

**AutoMatching Individual Automation Types**

You can invoke AutoMatch on individual automation types across a session.

To AutoMatch all controls of one automation type:
- In the Automation window, Control-click (Windows) or Command-click (Mac) the button for the automation type (Volume, Pan, Mute, Plug-in, Send level, Send pan, or Send mute).

**AutoMatching Individual Controls**
(D-Control and D-Command Only)

On ICON worksurfaces, you can invoke AutoMatch on individual controls or control types on single channels.

To AutoMatch all controls of a type on a channel:
- Hold Control (Windows) or Command (Mac) and press any of the following in the Channel Strip Mode controls for the track whose controls you want to AutoMatch:
  - Inserts
  - Sends
  - Pan
  - Dyn (D-Control only)
  - EQ (D-Control only)

To AutoMatch a pan control or the controls for an individual insert or send:
1. Press the switch in the Channel Strip Mode controls to display the Pan controls or the top level of Inserts or Sends for the channel.

2. Hold Control (Windows) or Command (Mac) and press the Rotary Encoder Select switch for the control you want to AutoMatch:
   - For Sends, the Send level, pan, and mute will AutoMatch.
   - For Inserts, all automated controls will AutoMatch.
   - For Pan, all pan sliders on the channel will AutoMatch.

**Priming Controls for Writing Automation in Latch Mode**

If a track is in Latch or Touch/Latch automation mode, you can prime individual controls for writing automation while the transport is stopped. This *Latch Prime* capability lets you prepare for an automation pass before starting playback.

To prime controls for writing automation in Latch mode while the transport is stopped:
1. Choose Setup > Preferences and click Mixing.
2. Under Automation, select Allow Latch Prime in Stop.
3. Click OK to close the Preferences window.
4. In the Automation window, make sure the controls you want to automate are write-enabled.
5 Click the Automation Mode selector on the track where you want to write automation and do one of the following:
   - Choose Latch mode to allow priming of all automation-enabled controls on the track.
   - Choose Touch/Latch mode to leave the main Volume fader in Touch mode and allow priming of all other automation-enabled controls.

6 While the transport is stopped, touch or move the controls you want to start writing at the beginning of the automation pass. When at least one control on a track is primed, the Automation Mode selector displays in bold.

7 Start playback. All primed controls begin writing automation at their primed values.

8 Stop playback to finish the automation pass. All tracks are taken out of their Latch Prime state.

Taking Tracks and Controls Out of Latch Prime

You can take individual tracks or automation types out of their Latch Prime state before or during an automation pass.

- When you take a track or automation type out of Latch Prime before starting playback, it stays in Latch mode but the corresponding controls are not primed to write when playback starts.
- When you take a track or automation type out of Latch Prime during an automation pass, the corresponding controls AutoMatch to their currently written values.
- If you AutoMatch a control that is in a Latch Prime state, the control will no longer be primed.

To take a track out of Latch Prime:

- Control-click (Windows) or Command-click (Mac) the Automation Mode selector on the track.

The selector button unbolds to indicate that the track is no longer primed.
To take all tracks out of Latch Prime, do one of the following:

- Alt-Control-click (Windows) or Option-Command-click (Mac) the Automation Mode selector on a track.

  — or —

- Click the AutoMatch button in the Automation window.

To take all selected tracks out of Latch Prime, do one of the following:

- Alt-Control-Shift-click (Windows) or Option-Command-Shift-click (Mac) the Automation Mode selector on a track.

  — or —

- Alt-Shift-click (Windows) Option-Shift-click (Mac) the AutoMatch button in the Automation window.

To take an automation type out of Latch Prime on all tracks, do one of the following:

- In the Automation window, Control-click (Windows) or Command-click (Mac) the button for the automation type (Volume, Pan, Mute, Plug-in, Send level, Send pan, or Send mute).

**Rolling Through Automation Punch Points in Latch Prime**

After you prime controls for writing automation while the transport is stopped, you can set Pro Tools to automatically punch in at that point after issuing a back and play command, or after rolling back and locking to time code.

To set Pro Tools to automatically punch in automation writing on a track:

1. Locate the cursor where you want to punch in automation.

2. Prime controls for writing while the transport is stopped. (See “Priming Controls for Writing Automation in Latch Mode” on page 598.)

3. In the Automation window, click the AutoJoin button.

4. In the Automation window, click the Capture button and then click the Punch Capture button. The AutoJoin marker (a vertical red line) appears on-screen at the punch point.
5 Issue a Back and Play command, roll back the external machine to before the punch in point, or enable pre-roll.

6 Start playback. When the transport reaches the punch-in point, automation writing begins.

---

**Enabling and Suspending Automation**

From the Automation window, you can enable or suspend writing for the following types of automation across all tracks:

- Volume
- Volume trim
- Pan
- Mute
- Plug-in
- Send level
- Send level trim
- Send pan
- Send mute

Automation can be suspended or enabled during playback (without having to stop the Transport).

**Suspending Automation on All Tracks**

**To suspend automation on all tracks:**

1. Choose Window > Automation.
2. Do one of the following:
   - To suspend writing of all automation on all tracks, click the Auto Suspend button.
   - or –
   - To suspend writing of a specific type of automation on all tracks, click the button for that automation type (volume, mute, pan, plug-in, send level, send mute, or send pan).

---

**Suspending Trim automation**

To suspend Trim automation on all tracks:

- In the Automation window, Command-click (Mac) or Control-click (Windows) the Suspend button.

---

**Suspending Automation for Individual Controls**

You can suspend automation for one or more controls. When a control is suspended, its control name is italicized in the Track View selector.

---

**Suspending automation from the Edit window obeys Edit groups. To suppress grouped behavior, hold Start (Windows) or Control (Mac) while suspending a control.**
To suspend automation for individual controls on a track:

1. In the Edit window, set the Track View selector to show the automation playlist for the control you want to suspend.

2. Do one of the following:
   - To suspend writing and playback of automation for only the displayed control, Control-click (Windows) or Command-click (Mac) the control name in the Track View selector.
   - To suspend writing and playback of automation for all controls, Control-Shift-click (Windows) or Command-Shift-click (Mac) the name of any control in the Track View selector.
   - To suspend writing and playback of automation for a specific control on all tracks, Control-Alt-click (Windows) or Command-Option-click (Mac) the name of the control in the Track View selector.

To suspend Trim automation for individual controls on a track:

1. In the Edit window, set the Track View selector to show the automation playlist for the Trim control you want to suspend (Volume Trim or Send level Trim).

2. Do one of the following:
   - To suspend writing and playback of Trim automation for only the displayed Trim control on a single track, Control-click (Windows) or Command-click (Mac) the control name in the Track View selector.
   - or –
   - To suspend the displayed Trim control on all tracks, Control-Alt-click (Windows) or Command-Option-click (Mac) the control name in the Track View selector.

Viewing Automation Enable Status

Track Automation Mode Selectors

- When a track is enabled for automation but not writing automation, the Automation mode selector shows the mode in normal red text.
- When any control on a track is writing automation, the Automation mode selector shows the mode in bold red text.

Automation Window Buttons

- When an automation type is writing automation on any track in the session, the corresponding button in the Automation window displays bold red text.
- When an automation type is enabled but is not writing anywhere in the session, the corresponding button in the Automation window displays normal red text.
Automation Enable Guidelines

The following rules determine whether automation is enabled for a track:

◆ Although Pro Tools shows a single Automation mode for each track, all automatable controls associated with that track are not necessarily in the same Automation mode.

◆ If automation is globally suspended in the Automation window, all automatable controls behave as if they were in Off mode, regardless of the track’s current Automation mode.

◆ If automation for a control is suspended by Control-clicking (Windows) or Command-clicking (Mac) its name in the Track View selector, that control behaves as if it were in Off mode, regardless of the track’s current Automation mode.

◆ If automation for a control is suspended in the Automation window, that control behaves as if it is in Read mode when the track is in a recordable Automation mode (Touch, Latch, or Write mode).

Deleting Automation

Automation data takes the form of a line graph with editable breakpoints. The easiest way to remove automation in a track or selection is to manually delete breakpoints from the automation playlist.

Removing data in this manner is different from using the Cut command, which creates anchor breakpoints at the boundaries of the remaining data. For details, see “Cutting, Copying, and Pasting Automation” on page 610.

To remove automation data, display the automation playlist you want to edit by selecting it from the Track View selector, and do one of the following:

To remove a single breakpoint:

◆ With the Pencil tool or any Grabber tool, Alt-click (Windows) or Option-click (Mac) the breakpoint.

To remove several breakpoints at once:

◆ Use the Selector tool to select a range that contains the breakpoints, and press Backspace (Windows) or Delete (Mac).

To remove all automation data of the displayed type:

◆ Click with the Selector tool in the track and choose Edit > Select All, then press Backspace (Windows) or Delete (Mac).

To remove all automation for all automation playlists on a track:

1 Use the Selector tool to select a range of data to be removed.

2 Press Start+Backspace (Windows) or Control+Delete (Mac).

All automation data within the selection is removed for all automation playlists on that track, regardless of whether automation is write-enabled for those controls.

Clearing Trim Automation

If Trim automation has not been coalesced on a track, you can clear it. When you clear Trim automation, automation breakpoints on all Trim playlists are deleted and all Trim faders are reset to zero.
To clear Trim automation:

1. Select the track where you want to clear the Trim automation.
2. Do one of the following:
   - Choose Track > Clear Trim Automation.
   - or –
   - Right-click the track name and choose Clear Trim Automation from the pop-up menu.

Thinning Automation

Pro Tools writes a maximum density of automation data during an automation pass in the form of breakpoints. Since Pro Tools creates ramps between breakpoints, it may not need all of the captured points to create a sonically accurate representation of the automation moves that you have made. Each breakpoint takes up space in memory allocated for automation, so thinning data can maximize system efficiency and performance.

Pro Tools provides two different ways to thin automation data and remove unneeded breakpoints: the Smooth and Thin Data After Pass option and the Thin Automation command.

Using Smooth and Thin Data After Pass

When this option is selected in the Automation Preferences page, Pro Tools automatically thins the automation breakpoint data after each automation pass.

In the default settings for new sessions, the Smooth and Thin Data After Pass option is selected, with the “Some” setting chosen. In most cases, this setting yields optimum performance while providing an accurate reproduction of your automation moves.

If you choose None, Pro Tools writes the maximum possible number of breakpoints. You can still perform thinning at any time with the Thin command. For more information on smoothing automation data, see “Smoothing” on page 589.

Using the Thin Automation Command

The Thin Automation command lets you selectively thin areas in a track where automation data is too dense. You can use the Undo command to audition the results of thinning (comparing thinning and not thinning) before you apply it permanently.

To use the Thin Automation command:

1. In the Edit window, click the Track View selector to display the automation type you want to thin.
2. With the Selector tool, highlight the automation data you want to thin. To thin all automation of the selected type in the track, click with the Selector tool in the track and choose the Select All command.
3. Choose Edit > Automation > Thin to thin the selected automation by the amount you have selected in the Automation Preferences page.
**Drawing Automation**

Use the Pencil tool to create automation events for audio and MIDI tracks by drawing in any automation or MIDI controller playlist, including Trim automation if it has not been coalesced.

The Pencil tool can be set to draw a series of automation events with the following shapes:

- **Free Hand** Draws freely according to the movement of the mouse. In audio tracks, the shape has the number of breakpoints needed to smoothly interpolate and reproduce the automation shape. In MIDI tracks, the shape is reproduced as a series of steps, according to the resolution setting in the MIDI Preferences page.

- **Line** Draws a straight line. In audio tracks, the line has a single breakpoint at either end. In MIDI tracks, the controller value changes in steps according to the resolution setting in the MIDI Preferences page.

- **Triangle** Draws a sawtooth pattern that repeats at a rate based on the current Grid value. In audio tracks, the pattern has a single breakpoint at each extreme. In MIDI tracks, the controller value changes in steps according to the resolution setting in the MIDI Preferences page. Amplitude is controlled by vertical movement of the Pencil tool.

- **Square** Draws a square pattern that repeats at a rate based on the current Grid value. Amplitude is controlled by vertical movement of the Pencil tool.

- **Random** Draws a random pattern of levels that change at a rate based on the current Grid value. Amplitude is controlled by vertical movement of the Pencil tool.

**Using Pencil Tool Shapes**

You can draw automation for audio as well as MIDI tracks. For example, use the Triangle pattern to control continuous functions, or the Square pattern to control switched functions such as Mute or Bypass.

Since the Pencil tool draws these shapes using the current Grid value, you can use it to perform panning in tempo with a music track, or on frame scene changes when working in post production.

*For more information on MIDI continuous controller data, see “Continuous Controller Events” on page 472.*

**Resolution of MIDI Controller Data**

When using the Pencil tool to draw MIDI automation, the data is drawn as a series of discrete steps. You can control the resolution (or density) of these steps to help manage the amount of MIDI data sent for a given MIDI controller move.
To set the resolution for the Pencil tool:

1. Choose Setup > Preferences and click MIDI.

2. Enter a value for “Pencil Tool Resolution When Drawing Controller Data.” The value can range from 1 to 100 milliseconds.

3. Click OK to close the Preferences window.

The illustrations below show the same MIDI controller automation drawn with different Pencil tool resolution settings.

For better performance, consider selecting a smaller value for MIDI controls that need higher resolution (such as MIDI volume), and a larger value for controls that may not require a high resolution (such as Pan).

Graphical Editing of Automation Data

Automation data takes the form of a line graph with editable breakpoints. By dragging these breakpoints, you can modify the automation data directly in the Edit window. When you drag an automation breakpoint up or down, the change in value is numerically or textually indicated. Dragging an automation breakpoint to the left or right adjusts the timing of the automation event.

Using the Grabber Tools

The Grabber tools lets you create new breakpoints by clicking on the graph line, or adjust existing breakpoints by dragging them. Alt-click (Windows) or Option-click (Mac) breakpoints with a Grabber tool to remove them.

Using the Pencil Tool

The Pencil tool lets you create new breakpoints by clicking once on the graph line. Alt-click (Windows) or Option-click (Mac) breakpoints with the Pencil tool to remove them.
Using the Trim Tools

The Trim tools let you adjust all selected breakpoints up or down by dragging anywhere within that selection.

Editing Automation Types

Each automatable control has its own automation playlist, that can be displayed by choosing it from the Track View selector. “Viewing Automation” on page 591.

Editing Volume Automation

Drag a breakpoint up or down to change the volume (dB value). Drag a breakpoint to the left or right to adjust the timing of the volume change.

Editing Pan Automation

Drag a breakpoint down to pan right, and up to pan left. Drag a breakpoint to the left or right to adjust the timing of the panning moves.

Editing Mute Automation

Drag the breakpoint down to mute a section. Drag a breakpoint up to unmute the section. Drag a breakpoint to the left or right to adjust the timing of the mute.

Editing Stepped Control Automation

Automation for certain controls (such as MIDI controller values or plug-in settings) appears as a stepped pattern on the breakpoint line. Drag a breakpoint up or down to a different step to change to a new control value. Drag a breakpoint to the left or right to adjust the timing of the stepped control change.

Editing Automation Breakpoints

To edit automation breakpoints, display the automation playlist for the control you want to edit by selecting it from the Track View selector, then do one of the following:

To create a new breakpoint:

- Click with the Pencil tool or any Grabber tool on the line graph.

To edit one breakpoint:

- Click an existing point on the line graph with the any Grabber tool and drag it to a new position.
To clear one breakpoint:
- Alt-click (Windows) or Option-click (Mac) with any Grabber tool.

To edit several breakpoints at once:
- Use the Selector tool to select a range in the automation playlist that contains the breakpoints, and do one of the following:
  - To move the breakpoints earlier or later in the track, press the Plus key (+) to nudge them later (to the right) or the Minus key (−) to move them earlier (to the left). The breakpoints move by the current Nudge value.
  - To adjust the breakpoint values, click with any of the Trim tools in the selection and drag the breakpoints up or down.

When you use a Trim tool to edit a selection containing breakpoints, new anchor breakpoints are created before and after the selected area. To suppress creation of anchor breakpoints, press Alt (Windows) or Option (Mac) while using a Trim tool.

To edit all breakpoint values in a region:
- Click in the region with any of the Trim tools and drag the breakpoints up or down.

Constrain New Breakpoints to Next or Previous Automation Value

New automation breakpoints can be constrained and written to the same value as the next or previous breakpoint.

Writing a new breakpoint to the next or previous automation value is accomplished using any Grabber tool, but is not supported with the Smart Tool.

To write a new breakpoint to the next automation value:
- Press and hold Alt+Shift (Windows) or Option+Shift (Mac) while writing a breakpoint (by clicking with any Grabber tool in a track’s automation playlist).

To write a new breakpoint to the previous automation value:
- Press and hold Control+Alt (Windows) or Command+Option (Mac) while writing a breakpoint (by clicking with any Grabber tool in a track’s automation playlist).
Editing Automation on Stereo and Multichannel Tracks

Stereo and multichannel tracks display a single automation playlist per track. Only one playlist for volume and mute is available for the stereo or multichannel track.

For multi-mono plug-ins, automation playlists for each individual channel can be displayed and edited when the plug-in is unlinked, and the track is in Expanded Track Display.

Expanded Track View

By default, a single automation playlist is displayed on stereo and multichannel tracks. The playlist occupies the entire height of the track (similar to mono automation playlists).

Optionally, you can display an expanded view of the track whereby the same automation playlist is displayed across each channel.

Plug-in Automation Playlists on Stereo and Multichannel Tracks

Some multichannel plug-ins provide a single set of automatable controls for all channels in a track. Other multichannel plug-ins and all multi-mono plug-ins provide a single set of controls for all channels when linked, or discrete controls for each channel when unlinked. Refer to your plug-in guide for more information.

To view and edit the individual playlists of a multi-mono plug-in:

1. Unlink the plug-in.
2. Select the required playlist from the Track View selector.

Selecting an automation playlist for an unlinked multi-mono plug-in

Editing Automation on Grouped Tracks

When you edit automation on an audio track that is a member of an active Edit Group, the same type of automation (with the exception of audio and MIDI Pan controls) is also edited on all tracks that are part of that group. This occurs even if the playlist for that type of automation is not currently displayed on the other grouped tracks.

However, when you edit automation on a MIDI track that is a member of an active Edit Group, grouping is ignored; the same type (with the exception of audio and MIDI Pan controls) are not edited on all tracks that are part of that group. To edit all members of a MIDI group, see the steps below.
Examples

- If you create new automation breakpoints on a grouped track (with the Pencil tool or any Grabber tool), other members of the group have breakpoints placed relative to that track.
- If you move volume or send automation on a grouped track (with any of the Trim tools), other members of the group have their volume or send breakpoints trimmed relative to that track. This lets you trim entire sections of a mix.

![Trimming automation on an active grouped track](image)

To individually edit a member of a group without affecting the other members, do one of the following:

- For audio, Auxiliary Input, and Instrument tracks, press the Start key (Windows) or Control (Mac) while you perform the edit.
  - or -
- For MIDI tracks, do not press the Start key (Windows) or Control (Mac) while you perform the edit.

To edit all members of a group, do one of the following:

- For audio, Auxiliary Input, and Instrument tracks, do not press the Start key (Windows) or Control (Mac) while you perform the edit.
  - or -
- For MIDI tracks, press the Start key (Windows) or Control (Mac) while you perform the edit.

⚠️ When editing automation, audio and MIDI Pan controls work opposite from the way all other controls work.

For audio, Auxiliary Input, and Instrument tracks, when you edit or trim Pan breakpoints, Edit Groups are not obeyed. For grouped behavior, press the Start key (Windows) or Control (Mac) while trimming.

For MIDI pan on MIDI and Instrument tracks, when you edit or trim Pan breakpoints, Edit Groups are obeyed. For individual behavior, press the Start key (Windows) or Control (Mac) while trimming.

Cutting, Copying, and Pasting Automation

Cutting automation data is different from deleting it, and yields different results (although both change the existing automation data). Copying automation leaves the original automation data intact.

You delete automation data by selecting a range of breakpoints and pressing Backspace (Windows) or Delete (Mac). See “Deleting Automation” on page 603 for details.

You cut automation data by selecting a range of breakpoints from an automation playlist and selecting the Cut command.

When you cut automation data and when you paste it into a new location, anchor breakpoints are added to the beginning and end points of the data. This is done to preserve the true slope (of continuous controls, such as Volume faders or pans) or state (of switched or stepped controls, such as Mutes) of the automation data both inside and outside the selection.
The following illustrations show the difference between cutting and deleting automation data. In Figure 26, a track is set to display volume automation, and a range of automation data is selected.

If the Cut command is chosen, anchor breakpoints are created at each end of the selection, and the automation slope on either side of the cut data is preserved, as shown in Figure 27.

If the data is deleted by pressing Backspace (Windows) or Delete (Mac), the automation data is removed, and automation values span the gap between pre-existing breakpoints, as in Figure 28.

In addition, if cut or copied data is pasted elsewhere in a track, breakpoints are created at the end points of the pasted data to preserve its “neighboring” (incoming and outgoing) automation value and slope, as shown in Figure 29.

**Editing and Track Views**

Audio and MIDI tracks each have a Track View that acts as the main format for purposes of editing. When the main format is displayed, any edits performed on the track apply to all data in the track.

The main view formats are:
- Audio tracks: Blocks and Waveform
- MIDI tracks: Blocks, Regions, and Notes

For example, when an audio track is set to Waveform or Blocks, cutting, copying and pasting affects the audio data and all types of automation data on that track. If the track is set to show Pan automation, only the Pan data is affected.

When a selection includes multiple tracks, if any of those tracks is in its main view format, all data on all selected tracks is affected.

**To edit all automation types on an Auxiliary Input or Master Fader track, do one of the following:**

- Make an Edit selection that includes at least one audio or MIDI track that is displayed in its main format.
- or -
- Press Control while cutting or copying the automation data.

For additional flexibility, you can use playlists or the Duplicate Track command to work nondestructively on a copy of the edit data.

> Figure 26. Selecting automation data
>
> Figure 27. After cutting the automation data
>
> Figure 28. After deleting the automation data
>
> Figure 29. After pasting the automation data in another location
Tips for Cutting, Copying and Pasting

- On audio tracks, when you are in Waveform View and cut or copy a section of the waveform, any automation data associated with the waveform is also cut or copied.
- On audio tracks, when you are in Waveform View and cut audio data from a track also containing automation data, breakpoints are automatically created at the boundaries of the remaining automation data.
- On audio tracks, pasting waveform data also pastes any associated automation data.
- On Auxiliary Input, Master Fader, or Instrument tracks, only the displayed automation data is cut or copied. To cut or copy all automation data on these types of tracks, press Control while cutting or copying.
- In tracks where an automation playlist contains no data (when there is only a single breakpoint at the very beginning of the track), if you cut data, no new breakpoints are created.
- In cases where regions overlap (such as when moving regions in Slip mode) and an overlapping region is removed, any overlapped automation breakpoints are lost.
- If cut or copied data contains a type of automation not currently on the target track, Pro Tools prompts you before allowing you to paste the data.
- Cut or copied automation data for plug-ins or sends that do not exist on the target track is ignored when pasted.

Cut, Copy, Clear, and Paste Special Commands

The four “special” commands (Cut Special, Copy Special, Paste Special, and Clear Special) simplify the tasks involved with moving or clearing different types of automation data and MIDI controller data between tracks, sends, and plug-ins. These commands let you

- Edit automation and MIDI controller data only (without associated audio or MIDI notes).
- Edit automation and MIDI controller data without having to change Track Views

In addition, the Paste Special command lets you copy one data type to another (for example, Left Pan data into the Right Pan playlist).

⚠ You cannot paste MIDI controller data to automation data nor automation to MIDI.

Cut Special

The Cut Special commands let you cut just automation data from the current selection (without associated audio or MIDI notes) and place it in memory to paste elsewhere, as follows. Choices include:

- All Automation Cuts all automation or MIDI controller data whether it is shown or not.
- Pan Automation Cuts only pan automation or MIDI pan data whether it is shown or not.
- Plug-in Automation Cuts only the plug-in automation that it is shown.

Copy Special

The Copy Special commands let you copy just automation data from the current selection (without associated audio or MIDI notes) and place a copy of it in memory to paste elsewhere, as follows:
All Automation Copies all automation or MIDI controller data whether it is shown or not.

Pan Automation Copies only pan automation or MIDI pan data whether it is shown or not.

Plug-in Automation Copies only the plug-in automation that it is shown.

Paste Special

The Paste Special commands let you paste automation data into another region (without affecting associated audio or MIDI notes) in the following ways:

Merge Lets you add the pasted data to any existing automation data of the same type in the destination selection. This can be useful for consolidating MIDI data from several tracks into a single MIDI track. For example, you like the pitch bend on the synth trombones and want to apply it to the synth guitar.

Repeat to Fill Selection Pastes multiple iterations of the automation data to the entire selection range. If you select an area that is not an exact multiple of the copied region size, the remaining selection area is filled with a trimmed version of the original selection. This lets you easily create drum loops and other repetitive effects. Before the data is pasted, Pro Tools prompts you to specify a crossfade to smooth transitions between regions.

To Current Automation Type Pastes the automation data or MIDI controller data from the clipboard to the selection as current automation type or MIDI controller. This lets you copy automation from any type to any other type. For example, you can copy a Left Pan automation to Plug-in automation. Or, you can copy MIDI volume data and paste it to MIDI pan.

Clear Special

The Clear Special commands let you clear just automation data from the current region, as follows:

All Automation Clears all automation or MIDI controller data whether it is shown or not.

Pan Automation Clears only pan automation or MIDI pan whether it is shown or not.

Plug-in Automation Clears only the plug-in automation that it is shown.

Special Paste Function for Automation Data

Normally, when you copy and paste automation data, it is pasted in an automation playlist of the exact same type (for example, Left Pan data is pasted into the Left Pan playlist).

However, there may be times when you want to paste from one data type to another (for example, Left Pan data into the Right Pan playlist).

The Special Paste function lets you copy one data type to another.

If you want to paste automation or MIDI controller data only (without its associated audio or MIDI notes), use the Paste Special command (see “Paste Special” on page 613).
For this special paste mode to function, the following must be true:

- Every track selected for pasting must be currently displayed as automation data.
- There must be only one automation playlist on the Clipboard for each target track. (The Special Paste function cannot copy multiple automation playlists for each track.)

You cannot interchange automation data between audio and MIDI tracks, or between continuous controls (such as faders or pans) and switched or stepped controls (such as mute or MIDI controllers).

To paste data into a different automation playlist:

- Press the Start key (Windows) or Control (Mac) when choosing Edit > Paste.

### Glide Automation

(Pro Tools HD Only and Pro Tools LE with DV Toolkit 2)

The Glide Automation commands let you manually create an automation transition (or glide) from an existing automation value to a new one, over a selected area.

When gliding multiple parameters at the same time, such as with the Surround Pan-ner or plug-ins, use the Edit > Automation > Glide to All Enabled option.

To apply a Glide Automation to the current automation parameter type:

1. In the Automation window, make sure the automation type is write-enabled.
2. Click the Track View selector to choose the automation type you want to automate.
3. Drag with the Selector tool in the track to select the area you want to write the glide to.
4. Change the automation parameter to the value desired at the end of the selection. For example, to glide automation volume to –Infinity, move the Volume fader to –Infinity.
5. Choose Edit > Automation > Glide to Current.

You can also press Alt+Forward Slash (/) (Windows) or Option+Forward Slash (/) (Mac).

To do a Glide Automation to all current enabled parameters:

1. In the Automation window, make sure the automation types are write-enabled.
2. In each track you want to automate, click the Track View selector and select from the pop-up menu the automation type you want to automate.
3. With the Selector tool, click and drag horizontally to include all the tracks you want to automate in a selection (drag vertically to define the time range).
4. In each track you want to automate, change the automation parameter to the value desired at the end of the selection.
5. Choose Edit > Automation > Glide to All Enabled.

You can also press Alt+Shift+Forward Slash (/) (Windows) or Option+Shift+Forward Slash (/) (Mac).
Glide Automation Considerations

When Glide Automation is applied to automation data, it behaves as follows:

- When a selection is made, automation breakpoints are written at the start and end points of the Glide Automation. The automation value at the start of the selection is the start point of the Glide Automation and the end of the selection is the end point of the Glide Automation. The Glide Automation that is created between the two is based on the length of the selection and the end value that is selected.

- If automation breakpoints follow the selection, they are not changed, but the value selected for the end of the selection is written from the end point up until the next breakpoint.

- If no automation breakpoints follow the selection, the value selected for the end of the selection is written to the end of the track.

- If no selection is made, a breakpoint is written to the current location, and the value selected for the Glide Automation is written to the next breakpoint.

Trimming Automation

(Pro Tools HD Only)

If you have already written automation, you can modify automation data for track volume and send levels in real time by using Trim mode. When a track is trim-enabled, you are not recording absolute fader positions, but relative changes in the existing automation. See “Trim Mode” on page 587 for more information.

To enable Trim mode:

- In the Mix or Edit window, click the Automation Mode selector of the track where you want to trim automation, and select Trim.

To trim track Volume or Send levels:

1 In the Automation window, make sure the automation type (Volume or Send level) is write-enabled.

2 Click the Automation Mode selector of the track where you want to write automation and choose the automation mode (Touch, Latch, Touch/Latch, or Write).

3 Click the Automation Mode selector and choose Trim.

4 Start playback, and adjust the Volume or Send levels.
Stop playback to finish the Trim pass.

Coalescing Trim Automation

You can set Pro Tools to commit, or *coalesce*, Trim automation to the main automation playlist by the following methods:

**After Every Pass** Trim moves are automatically applied when the transport is stopped at the end of an automation pass. Trim automation playlists are cleared, and Trim faders are returned to zero.

**On Exiting Trim Mode** Trim moves are stored separately in the Trim automation playlist until they are coalesced. Trim automation is automatically coalesced on a track only when you take the track out of Trim mode. You can repeat an automation pass, edit Trim automation manually on any of the Trim playlists, or clear Trim automation before coalescing with this method.

> Even when automation is set to coalesce on exiting Trim mode, you can use the Coalesce Trim Automation command to commit Trim moves at any time.

**Manually** Trim moves are stored separately in the Trim automation playlist until they are coalesced. With this setting, the only way to coalesce Trim moves is with the Coalesce Trim Automation command. You can repeat an automation pass, edit Trim automation manually on any of the Trim playlists, or clear Trim automation before coalescing with this method.

To manually coalesce Trim automation on a track:

1. Select the track where you want to coalesce the Trim automation.
2. Do one of the following:
   - Choose Track > Coalesce Trim Automation.
   - or –
   - Right-click the track name and choose Coalesce Trim Automation from the pop-up menu.

The Trim automation is applied to the main automation playlist, Trim automation playlists are cleared, and Trim faders are returned to zero.

To set the method by which Trim Automation is coalesced:

1. Choose Setup > Preferences and click Mixing.
2. Under Coalesce Trim Automation, select one of the following:
   - After Every Pass
   - On Exiting Trim Mode
   - Manually

To coalesce Trim automation on a track when exiting Trim mode:

1. Choose Setup > Preferences and click Mixing.
3. Click OK to close the Preferences window.
4. Make sure the Pro Tools transport is stopped.
5. On the track where you want to coalesce Trim automation, click the Automation Mode selector and deselect Trim.

The Trim automation is applied to the main automation playlist, Trim automation playlists are cleared, and Trim faders are returned to zero.

> If transport is playing and you are writing automation, you cannot directly enter or exit Trim mode. You must AutoMatch before exiting Trim mode. This prevents any abrupt jumps in automation values.
Writing Automation to the Start, End, or All of a Track or Selection

(Pro Tools HD Only)

Pro Tools lets you write current automation values from any insertion point forward (or backward) to the end (or beginning) of a track or Edit selection in a track, or to an entire track or Edit selection, while performing an automation pass.

The standard Write Automation to Start, All, or End commands do not operate when the Pro Tools transport is stopped. It only affects automation for those parameters that are currently write-enabled and currently writing automation data.

Optionally, Write Automation to Start, All, and End can be configured to always be applied automatically. See “Writing Automation to the Start, End or All of a Track or Selection on Stop” on page 618.

Requirements for Standard Write Automation Commands

For automation data to be written for a specific parameter, the associated track must be in one of the following Automation modes and meet the following conditions:

- **Latch Mode** The control for the parameter must be changed (touched) during the automation pass.
- **Touch Mode** The control for the parameter must be changed (touched).
- **Write Mode** All controls on that track must be in Write mode.

This command can be undone.

To write current automation values to the start, end, or all of a track or Edit selection:

1. Choose Window > Automation.
2. Make sure that the automation type is write-enabled.
3. Do one of the following:
   - Click in a track at an insertion point.
   - or –
   - Drag with the Selector tool to select a portion of the track.
4. Click Play to begin playback.
5. Make sure you are actively writing on the appropriate track if you are in Latch or Touch mode.
6. When you reach a point in the track or selection that contains the automation data you want to apply, click the Write Automation to Start, All, or End button in the Automation window.
Stop playback.

The current values of all write-enabled automation at that point are written to the corresponding area of the track/selection.

**Write to Start, End or All and Trim Mode**

While in Trim mode, it is also possible to write trim delta values for track volume and send levels to the start, end or all of a track or Edit selection.

**To write current trim delta values to the start, end, or all of a track or selection:**

1. Choose Window > Automation.
2. Make sure the automation type (track volume or send level) is write-enabled.
3. In the Mix or Edit window, click the Automation Mode selector of the track you want to trim automation, and select Trim. The track Volume and Send Level faders turn yellow.
4. Do one of the following:
   - Click in a track at an insertion point.
   - or –
   - Drag with the Selector tool to select a portion of the track.
5. Click Play to begin playback.
6. When you reach a point in the track or selection that contains the trim setting (delta value) you want to apply, click the Write Automation to Start, All, or End button in the Automation window.
7. Stop playback.

The relative changes to the track volume and send levels at that point are written to the corresponding area of the track/selection.

**Writing Automation to the Start, End or All of a Track or Selection on Stop**

The Automation window provides options for writing automation on any automation playlist (including Trim playlists) after a valid automation pass has been performed.

The Write Automation to Start, End or All modes can be configured to disable or remain enabled after a valid automation pass.

See “Requirements for Standard Write Automation Commands” on page 617.

**Write On Stop controls in the Automation window**

To configure Write On Stop modes to disable after an automation pass:

1. Choose Window > Automation.
2. Click to enable one of the Write On Stop modes (Start, All, End).

The enabled Write On Stop arrow appears in blue.

To configure Write On Stop modes to remain enabled after an automation pass:

1. Choose Window > Automation.
2. Alt-click (Windows) or Option-click (Mac) one of the Write On Stop buttons (Start, All or End) to enable the Write On Stop mode.

The enabled Write On Stop arrow appears in red.
Writing Automation to the Next Breakpoint or to the Punch Point

(Pro Tools HD Only)

While performing an automation pass, Pro Tools lets you write current automation values from the current insertion point forward to the next automation breakpoint, or back to the punch point (the location in the track where automation writing started).

- Write Automation to Next Breakpoint lets you update automation within a track without overwriting automation located earlier or later in the timeline, and without having to define a selection before editing automation.

- Write Automation to Punch Point lets you fill back an automation value within a track after finding the right level or setting during an automation pass, without having to go back and repeat the pass.

Like the standard Write Automation to Start, End and All commands, the Write Automation to Next Breakpoint and Write Automation to Punch Point commands do not operate when the Pro Tools transport is stopped. They only affect automation for those parameters that are currently write-enabled and currently writing automation data.

Optionally, the Write Automation to Next Breakpoint and Write Automation to Punch Point commands can be configured to be applied automatically after a valid automation pass has been performed. See “Writing Automation to the Next Breakpoint or to the Punch Point on Stop” on page 621.

To write current automation values to the next breakpoint:

1. Choose Window > Automation.
2. Make sure that the automation type is write-enabled.
3. Click in a track to define an insertion point.
4. Click Play to begin playback.
5. Make sure you are actively writing on the appropriate track if you are in Touch, Latch, or Touch/Latch mode.
When you reach a point in the track where you want to apply the current settings, click the Write Automation to Next Breakpoint button.

Stop Playback.

The current values of all controls being written at that point are written up to the next breakpoint.

⚠️ Write Automation to Next Breakpoint remains enabled after a valid automation pass. Unlike standard Write Automation commands, it cannot be configured to disable after an automation pass.

To write current automation values back to the automation punch point:

1. Choose Window > Automation.
2. Make sure the automation type is write-enabled.
3. Click in a track to define an insertion point.
4. Click Play to begin playback.
5. Make sure you are actively writing on the appropriate track if you are in Touch, Latch, or Touch/Latch mode.

When you reach a point in the track where you want to apply the current settings, click the Write Automation to Punch Point button.

The current values of all write-enabled parameters are written back to the point where the first control began writing automation.

**Write To Next Breakpoint or Punch Point and Trim Mode**

While in Trim mode, it is also possible to write trim values for track volume and send levels to the next written breakpoint or back to the automation punch-in point.

To write current trim values to the next breakpoint or to the punch point:

1. Choose Window > Automation.
2. Make sure that the automation type (track volume or send level) is write-enabled.
3. In the Mix or Edit window, click the Automation Mode selector and select Trim. The track Volume and Send Level faders turn yellow.
4. Click in a track to define an insertion point.
5 Click Play to begin playback.

6 When you reach a point in the track where you want to apply the current trim values, click the Write Automation to Next Breakpoint button in the Automation window.

**To write current trim values to the punch point:**

1. Choose Window > Automation.
2. Make sure that the automation type (track volume or send level) is write-enabled.
3. In the Mix or Edit window, click the Automation Mode selector and select Trim. The track Volume and Send Level faders turn yellow.
4. Click in a track to define an insertion point.
5. Click Play to begin playback.
6. When you reach a point in the track where you want to apply the current trim values, click the Write Automation to Punch Point button in the Automation window.

**Writing Automation to the Next Breakpoint or to the Punch Point on Stop**

The Automation window provides an option for automatic Write Automation to Next Breakpoint on Stop or Write Automation to Punch Point on Stop.

⚠ **Write Automation to Next Breakpoint remains enabled after a valid automation pass. Unlike standard Write Automation commands, it cannot be configured to disable after an automation pass.**

**To configure Write Automation to Next Breakpoint on Stop:**

1. Choose Window > Automation.
2. Click the Write Automation to Next Breakpoint on Stop button or the Write Automation to Punch Point button.

When this option is enabled, automation writing will be performed automatically forward to the next breakpoint after a valid automation pass has been performed.

**To configure Write Automation to Punch Point on Stop:**

1. Choose Window > Automation.
2. Click the Write Automation to Punch Point on Stop button.

When this option is enabled, automation writing will be performed automatically back to the automation punch-in point after a valid automation pass has been performed.
Guidelines for “Write To” Commands

Using “Write To” Commands During Playback

You can carry out any of the “Write Automation To” commands without stopping the Pro Tools transport. On supported control surfaces, the corresponding “Write To” button flashes until you stop the transport.

While the Pro Tools transport is moving, issuing “Write Automation To” commands affects writing of automation in the following ways:

- Write to Start/Selection Start: Currently writing controls continue writing automation
- Write to All/Selection: Currently writing controls (except controls in Write mode) punch out of writing automation
- Write to End/Selection End: Currently writing controls (except controls in Write mode) punch out of writing automation
- Write to Next Breakpoint: Currently writing controls (except controls in Write mode) punch out of writing automation
- Write to Punch point: Currently writing controls continue writing automation

Applying “Write To” Commands to Selected Tracks

The “Write Automation To” commands normally apply to all tracks currently writing automation. In Pro Tools 7.2, it is possible to apply these commands to only the currently selected tracks.

To apply any of the “Write Automation To” commands to currently selected tracks:

1. Select the tracks where you want to apply the “Write To” commands.
2. Alt-Shift-click (Windows) or Option-Shift-click the corresponding “Write Automation To” button.

Suppressing Warnings when Using “Write To” Commands

When you carry out any of the “Write Automation To” commands (except Write to Next Breakpoint), Pro Tools posts a dialog warning that automation values will be changed in the session. You can suppress these warnings.

To suppress “Write To” warning dialogs:

1. Choose Setup > Preferences and click Mixing.
2. Under Automation, select Suppress Automation “Write To” Warnings.
Overwriting or Extending Mute Automation
(Pro Tools HD Only)

Pro Tools lets you overwrite or extend an existing mute event in real time, without changing the current mute state.

A mute event can be overwritten when the automation pass begins before the first mute event and ends after the second event. In this case, the current on/off state of the mute is maintained.

A mute event can be extended when the automation pass begins before an on or off event and stops before the end of the second event.

To overwrite a mute state on one or more tracks:

1. Choose Window > Automation.
2. Make sure Mute is write-enabled.
3 In the Mix or Edit window, click the Automation Mode selector of the track where you want to overwrite the mute state, and set the Automation mode to Touch or Latch mode.

Tips: To overwrite mute states on multiple tracks, set all tracks to the same Automation mode.

4 In each track you want to automate, click the Track View selector and select mute.

5 Place the cursor before the start of the mute event you want to overwrite.

6 Begin playback.

7 Press Control (Windows) or Command (Mac) and the track Mute button before the start of the mute event you want to overwrite.

Tips: To overwrite mute states on multiple tracks, press Alt+Control (Windows) or Option+Command (Mac) and the Mute button on one of the tracks to be automated.

8 After the end of the second mute event, release the key and the Mute button.

Tips: With Touch mode, you have to hold the Mute button for the duration of the write.

9 When you have finished the automation pass, click Stop.

To extend a mute state on a track:

1. Choose Window > Automation.

2. Make sure mute is write-enabled.

3. In the Mix or Edit window, click the Automation Mode selector of the track you want to automate, and select Touch or Latch mode.

Tips: To extend mute states on multiple tracks, set all the tracks to the same Automation mode.

4. In each track you want to automate, click the Track View selector and select mute.

5. Place the cursor before the start of the mute event you want to extend.

To extend mute states on multiple tracks, set all tracks to the same Automation mode.

Example: Place cursor here, before start of mute event

Example of mute state overwritten

Example: Stop automation pass here, after end of mute event

Stopping automation after the end of a mute event

Example of mute state overwritten

Placing the cursor before the start of a mute event

Placing the cursor before the start of a mute event

Mute on state overwritten
6 Begin playback.

7 Press Control (Windows) or Command (Mac) and the track Mute button before the start of the mute event you want to extend.

To extend mute states on multiple tracks, press Alt+Control (Windows) or Option+Command (Mac) and the Mute button on the track.

8 Before the end of the second mute event, release the key and the Mute button.

If you extend past the subsequent on or off event, the entire event will be changed.

9 When you have finished the automation pass, click Stop.

Creating Snapshot Automation

(Pro Tools HD Only and Pro Tools LE with DV Toolkit 2)

Pro Tools lets you write automation data values for multiple parameters in a single step. You can write snapshot automation in two ways:

To a Selection Automation data is written to the Timeline selection (as well as the Edit selection if linked). Anchor breakpoints are placed just before and after the selection so that data outside the selection is not affected.

To a Cursor Location Automation data is written at the insertion point. After the insertion point, the automation ramps to the next breakpoint value, or if no breakpoints exist, remains at the newly written value for the remainder of the session.

For more information on cutting, copying, and pasting automation data within a session, see “Writing Automation to the Start, End, or All of a Track or Selection” on page 617.

To write snapshot automation:

1 In the Automation window, make sure that the parameters you want to edit are write-enabled. Deselect any parameters whose automation you want to preserve.

2 In the Edit window, click the Track View selector to show the automation you want to edit.
3 Write a breakpoint in the playlist if none currently exists, as follows:
   • Place the cursor in the playlist (or make an Edit selection), then choose Control+Forward Slash (/) (Windows) or Command+Forward Slash (/) (Mac).
   – or –
   • Select the Grabber tool and click anywhere in the playlist.
4 Do one of the following:
   • Select an area in the track’s playlist (or within multiple tracks) where you want to apply the automation.
   – or –
   • Place the cursor at an Edit insertion point.
5 Adjust the controls you want to automate. You can also change a plug-in preset.
6 Choose Edit > Automation and do one of the following:
   • To write the current value to only the currently displayed automation parameter, choose Write to Current.
   – or –
   • To write the current settings for all automation parameters enabled in the Automation window, choose Write to All Enabled.

Adding Snapshot Automation to Empty Automation Playlists

When you use a Write Automation command on an automation playlist with no previously written automation data, the selected value is written to the entire playlist and not just the selected area.

This is because a playlist with no automation data contains only a single automation breakpoint that corresponds to the current position of the control for the parameter. The position of the breakpoint is updated whenever the parameter value is changed.

If you do not want the Write Automation command to write the selected automation value to the entire playlist, you can:
   • Anchor the automation data by placing the cursor at the end of the session (or any other endpoint) and choosing Write to Current.
   – or –
   • Click with any Grabber tool on each side of the selection.

This lets the Write Automation command write only to the selected area.

Writing Snapshot Automation over Existing Automation Data

When you move the playback cursor, the automated controls in Pro Tools update to reflect the automation data that is already on the track. To keep the settings you have made for a snapshot, you can suspend automation parameters to prevent them from updating.

To write snapshot automation over existing data:

1 In the Automation window, make sure that the automation parameters you want to edit are write-enabled. Deselect any parameters whose automation you want to preserve.
2 Adjust the controls for the parameters you want to automate.
3 Click the Automation Mode selector and select Off mode for the tracks where you want to apply the automation.
4 With the Selector, select the range where you want to apply the automation.

5 Choose Edit > Automation and select one of the following from the submenu:
   - To write the current value to only the automation parameter currently displayed in the Edit window, choose Write to Current.
   - or –
   - To write the current settings for all automation parameters enabled in the Automation window, choose Write to All Enabled.

6 Click the Automation Mode selector and select Read mode for the tracks you want to play back with automation.

Capturing Automation and Applying it Elsewhere

The Write Automation commands can also be used to capture automation states at specific locations in a track and apply them to other locations in the track.

To capture and apply automation:

1 In the Automation window, make sure that the automation parameters you want to edit are write-enabled. Deselect any parameters whose automation you want to preserve.

2 Click the Automation Mode selector and select Read mode for the tracks that have automation you want to capture.

3 Make sure to select Options > Link Timeline and Edit Selection.

4 With the Selector tool, select the location where you want to capture automation. All automated controls update to reflect the automation at that location. (If you make a selection, the controls update to reflect the automation at the beginning of the selection.)

5 In each track you want to apply the captured automation, click the track’s Automation Mode selector and set the Automation mode to Off.

6 With the Selector tool, select the location where you want to apply the automation.

7 Enable the automation parameters previously suspended.

8 Choose Edit > Automation and select one of the following from the submenu:
   - To write the current value to only the automation parameter currently displayed in the Edit window, choose Write To Current.
   - or –
   - To write the current settings for all automation parameters enabled in the Automation window, choose Write To All Enabled.

9 Click the Automation Mode selector and select Read mode for the tracks you want to play back with automation.

Snapshot Automation and Trimming of Automation Data

Pro Tools lets you use trim values as snapshots and apply the relative changes (delta values) to the selected automation by using the Trim Automation command. This works in much the same way as the Write Automation command, except that it writes delta values instead of absolute values to automation data.

You can use trim values in writing snapshot automation to any automatable parameter.

To create a snapshot of relative changes in automation data:

1 In the Automation window, make sure that the automation parameters you want to edit are write-enabled. Deselect any parameters whose automation you want to preserve.
2 Select the area of the track you want to edit. All automated controls update to reflect the automation at the beginning of the selection.

3 Move the controls for the parameter up or down by the amount you want to change the data.

4 Choose Edit > Automation and do one of the following:
   • To write the current delta value to only the currently displayed automation parameter, choose Trim to Current.
   – or –
   • To write the current delta value for all automation parameters enabled in the Automation window, choose Trim to All Enabled.

**Previewing Automation**
*(Pro Tools HD Only)*

Automation Preview mode lets you audition changes to a mix and compare them to existing automation values without committing them to the automation playlist.

When you put Pro Tools in Automation Preview mode, you can preview values for automation-enabled controls on any track that is in a writable automation mode.

While in Automation Preview mode, when you touch or move a control, it isolates the control, disengaging it from its automation playlist. The control stops reading or writing automation, allowing you to freely audition changes.

When you have found a level or state that you want to use, you can then commit or punch the previewed value to the automation playlist for the isolated controls.

• If you punch during playback, the automation mode is set to Latch and writing begins at the preview value.
• If you punch while the transport is stopped, the automation mode is set to Latch and the control is primed at the preview value.

> It is not necessary for the Allow Latch Prime in Stop preference to be enabled for Preview to put a control into Latch Prime.

**Previewing New Automation Values**

To preview a new automation value for a control:

1 Make sure the track where you want to preview the value is enabled for automation (Touch, Latch, Touch/Latch or their corresponding Trim modes).

2 Make sure the automation type you want to preview is enabled in the Automation window (Volume, Pan, Mute, Send level, Send pan, Send mute, or Plug-in).

3 Click the Preview button in the Automation window. The button lights green to indicate that Preview mode is active.
4 To isolate a control, touch or move an automation-enabled control. You can isolate controls during playback or while the transport is stopped.

The Automation Mode indicator on the track lights green to indicate that at least one of its controls is isolated, and the Punch Preview button in the Automation window lights to indicate a preview value is available to punch.

5 Start playback and adjust the isolated control to audition the changes.

Taking Controls Out of Isolated State

You can take controls out of their isolated state without leaving Preview mode.

To take all controls on a track out of their isolated state, do one of the following:

■ Control-click (Windows) or Command-click (Mac) the automation mode selector on the track.
  – or –
■ Change the track automation mode to Read or Off.

To take all controls of an automation type out of their isolated state:

■ In the Automation window, disable the automation type.

Isolating Multiple Controls

In some cases, such as when starting a new mix, you may want to isolate multiple controls at the same time.

To isolate all currently write-enabled controls:

■ Alt-click (Windows) or Option-click (Mac) the Preview button.

To isolate all write-enabled controls on all selected tracks:

■ Alt-Shift-click (Windows) or Option-Shift click (Mac) the Preview button.

Suspending Preview Mode

You can temporarily suspend Preview mode, allowing you to toggle between preview values and existing automation.

To suspend Preview mode:

■ Control-click (Windows) or Command-click (Mac) the Preview button.

Punching Preview Values

After you have isolated a control and auditioned a new value, you can punch (write) the value to the automation playlist.

To punch a preview value to the automation playlist:

■ Click the lit Punch Preview button.

Preview Mode and “Write To” Commands

The “Write Automation To” commands work as follows with Preview mode:

Before punching preview values The “Write Automation To” commands (except Write to Next Breakpoint) can be used to extend previewed values. The “Write Automation To” command will only apply to isolated controls. Pro Tools remains in Preview mode.
After punching preview values: The “Write Automation To” commands (except Write to Next Breakpoint) can be used to extend the punched value in the same manner as other automation.

Capturing Automation

(Pro Tools HD Only)

You can capture current automation values at one location in a session and quickly apply them in another location with the Capture and Punch Capture commands. The Capture command temporarily stores the value of all controls currently writing automation, and the Punch Capture commands writes those stored values to all enabled automation types.

- ICON Systems allow for the capture of up to 48 different values, or snapshots.
- All other systems allow for the capture of a single value.

Capturing Automation Values

You can capture the current automation values of actively writing controls.

To capture automation values:

1. Make sure all tracks whose automation values you want to capture are in a write-enabled state (Write, Touch, Latch, Touch/Latch or Latch).

2. Make sure the automation types you want to capture are enabled in the Automation window (Volume, Pan, Mute, Send level, Send pan, Send mute, or Plug-in).

3. Start playback. When you reach a location where you want to capture the current automation states, click the Capture button in the Automation window.

The Punch Capture button in the Automation window lights to indicate a captured value is available to punch.

Punching Captured Automation Values

After automation values are captured, they can be punched (written) to another location in the track. Any tracks set to Read or Off are unaffected.

- If you punch during playback, the automation mode of any track set to Touch is set to Latch and writing begins at the captured value.
- If you punch while the transport is stopped, the automation mode of any track set to Touch is set to Latch and the control is primed at the captured value.

To punch captured automation values:

1. Move to a location where you want to apply the captured automation states. You can do this during playback or while the transport is stopped.

2. Click the Punch Capture button in the Automation window to apply the captured automation states. The captured states are applied to all automation types that are currently enabled in the Automation window.
Capturing Automation Values for All Controls

You can capture the state of all automatable controls (except on tracks with their Automation Mode set to Off) in a session, regardless of whether they are currently writing automation.

To capture the automation values of all controls:
- When you reach a location where you want to capture the current automation states, Alt-click (Windows) or Option-click (Mac) the Capture button.

To capture the automation values of all controls on selected tracks only:
- When you reach a location where you want to capture the current automation states, Alt-Shift-click (Windows) or Option-Shift-click (Mac) the Capture button.

Punching Automation Values for All Controls

You can punch all captured automation values to another location on their corresponding tracks (except those tracks with their Automation Mode set to Off).

To punch the automation values of all controls:
- When you reach a location where you want to apply the captured automation states, Alt-click (Windows) or Option-click (Mac) the Punch Capture button. Any track set to Read or Touch are set to Latch. Any tracks set to Off are unaffected.

To punch the automation values of all controls on selected tracks only:
- When you reach a location where you want to apply the captured automation states, Alt-Shift-click (Windows) or Option-Shift-click (Mac) the Punch Capture button. Any selected tracks set to Read or Touch are set to Latch. Any selected tracks set to Off are unaffected.

Capture and Trim Mode

The Capture and Punch Capture commands work with Trim automation in the same way as regular automation. Pro Tools saves Trim status when capturing, so if you attempt to punch captured Trim values while displaying a non-Trim automation playlist, Pro Tools will automatically apply the values to the corresponding Trim playlist.

Punch Capture and “Write To” Commands

After issuing a Punch Capture command, the affected controls are writing automation (in Latch mode), so any of the “Write Automation To” commands can be used to extend the punched value in the same manner as other automation.

Capture and Preview Mode

Loading Captured Values into Preview

You can preview and modify captured automation values in Preview mode before punching the values to the automation playlist.

To capture an automation value and use it to preview:
1. Make sure the track where you want to preview the value is enabled for automation (Touch, Latch, Touch/Latch or their corresponding Trim modes).
2 Make sure the automation type you want to preview is enabled in the Automation window (Volume, Pan, Mute, Send level, Send pan, Send mute, or Plug-in).

3 Capture an automation value that you want to preview in another location on a track. (See “Capturing Automation Values” on page 630.)

4 Go to a location where you want to preview the captured automation states, and click the Preview button in the Automation window.

5 Click the Punch Capture button.

The affected controls are isolated and updated to the captured values. The Punch Preview button in the Automation window lights to indicate the preview value is available to punch.

6 When you are ready to punch the preview value to the automation playlist, click the lit Punch Preview button.

Capturing Values While in Preview Mode

When you are in Preview mode, you can capture the values of isolated controls and apply them elsewhere on a track. By capturing preview values, you can leave the underlying automation unchanged at the place where you capture.

On ICON systems, you can use preview mode to capture multiple snapshots without changing automation.

To capture a preview value:

1 Activate Preview mode and isolate a control. (See “Previewing New Automation Values” on page 628).

2 Start playback and adjust the isolated control to audition the changes.

3 When you are ready to capture preview value, click the Capture button in the Automation window.

The Punch Capture button in the Automation window lights to indicate a captured value is available to punch.

VCA Master Track Automation

(Pro Tools HD Only)

Displaying Automation on VCA Master Tracks

The following controls on VCA Master tracks can be automated and have separate automation playlists:

- Volume
- Volume trim
- Mute

These automation playlists follow the same behavior as automation playlists on other track types. For more information on Volume trim automation, see “Trimming Automation” on page 615.

Displaying the Composite Automation Playlist on Slave Tracks

When a track is a VCA slave, you can display a composite automation playlist that shows the contribution of the VCA Master to the Volume or Mute automation data on the slave track. This composite playlist reflects the actual position of the Volume fader on the slave track. The composite playlist display cannot be directly edited.
To display the composite playlist on VCA slave tracks:

- Choose View > Automation > Composite Playlist.

Coalescing VCA Automation

There are several ways to commit, or coalesce, the contribution of a selected VCA Master track’s Volume and Mute automation to the automation playlists of its slave tracks.

Clearing the VCA Master

You can use a VCA Master to write grouped automation, coalesce the VCA automation to all of the slave tracks, and clear the automation on the VCA Master. The coalesced tracks will play back exactly as they did when they were in the VCA group.

To coalesce automation from a VCA Master to all of its slave tracks and retain the VCA Master:

1. Select the VCA Master track whose automation you want to coalesce.
2. Do one of the following:
   - Choose Track > Coalesce VCA Master Automation.
   - or –
   - Right-click the VCA Master track name and choose Coalesce VCA Master Automation from the pop-up menu.

The composite Volume level and Mute state are coalesced to each of the slave tracks. The VCA Master Volume fader is reset to zero, the VCA Mute is set to unmuted, and any automation on the VCA Master is cleared.

Deleting the VCA Master

You can temporarily use a VCA Master to write grouped automation, then coalesce the VCA automation to all of the slave tracks by deleting the VCA Master. The coalesced tracks will play back exactly as they did when they were in the VCA group.

To coalesce automation from a VCA Master to all of its slave tracks and delete the VCA Master track:

1. Select the VCA Master track whose automation you want to coalesce.
2. Choose Track > Delete.

The composite Volume level and Mute state are committed to each of the slave tracks.

⚠️ This action cannot be undone.

Removing a Slave Track from a VCA Group

You can remove an individual slave track from a VCA group, which commits the VCA automation to that track, leaving the VCA Master and the other slave tracks untouched. The coalesced slave track plays back exactly as it did when it was in the VCA group.
To coalesce automation from a VCA Master to an individual slave track:

1. Do one of the following:
   - Choose Modify Groups from the Group List pop-up menu.
   - Click the Group ID indicator on the track and choose Modify from the pop-up menu.
   - Right-click the Group name in the Group List and choose Modify from the pop-up menu.

2. In the Groups dialog, select the VCA-controlled group that includes the slave track.

3. In the Groups dialog, click Tracks and remove the slave track from the group.

4. Click OK.

   The slave track is removed from the VCA group, and the composite Volume level and Mute state are coalesced to the track.

Duplicating a Slave Track

When you duplicate a slave track without duplicating its group assignments, the VCA automation is coalesced to the duplicate track. The coalesced duplicate plays back exactly as if it were in the VCA group.

To coalesce automation from a VCA Master to a single slave track by duplicating the track:

1. Select the slave track whose automation you want to coalesce.

2. Choose Track > Duplicate.

3. In the Duplicate Track dialog, deselect Group Assignments.

4. Click OK.

   The composite Volume level and Mute state are coalesced to the duplicate track. The original slave track is preserved, and the VCA group is unchanged.

Coalescing Automation Across an Edit Selection

You can commit VCA automation across an Edit selection in a VCA Master track, without committing the automation on the entire length of the track.

To coalesce automation in an Edit selection on a VCA Master track:

1. Select the VCA Master track whose automation you want to coalesce.

2. Make an Edit selection in the VCA Master track that includes the range of automation you want to coalesce.

3. Do one of the following:
   - Hold Start (Windows) or Control (Mac) and choose Track > Coalesce VCA Master Automation.
   - or –
   - Hold Start (Windows) or Control (Mac) and Right-click the VCA Master track name and choose Coalesce VCA Master Automation from the pop-up menu.

   The composite Volume level and Mute state are committed to each of the slave tracks over the Edit selection. The VCA Master Volume is set to zero, the VCA Mute state is set to unmuted, and any automation on the VCA Master is cleared for the selected area only.
Chapter 28: Mixdown

Pro Tools lets you record and bounce tracks to disk. The Bounce to Disk command lets you write a final mix to disk, create a new loop, print effects, or consolidate any submix. You can also submix, route, and record busses and inputs to new audio tracks.

**Bounce to Disk** This command writes the current session (if no selection), Edit, or Timeline selection as new audio files to disk. Any available output or bus path can be selected as the bounce source. Use Bounce to Disk to write or master any output or bus path directly to disk. Sample rate, bit depth, and other conversion processes can be applied during or after the bounce. The Bounce to Disk command lets you bounce all available voices to disk without holding any in reserve. Though you can hear the bounce being created in real time, you cannot adjust mixer or other controls during a Bounce to Disk.

**Recording to Tracks** This is the process of submixing and recording to new audio tracks, as you would any input signals. This method requires available tracks, voices, and bus paths to accommodate the submix and the new tracks. While recording to tracks, you can adjust mixer or other controls.

**Selecting Audio for Loops, Submixes, and Effects**

Both Bounce to Disk and recording to tracks operate on the current Timeline or Edit selection, if any. This makes it easy to turn multitrack selections into mono, stereo, or multichannel loops. Submixes, stems, and other specialized types of mixes can also be printed to disk using either method, or recorded out to a DAT, MDM, or other recording, transfer, or archiving medium.

Printing effects to disk is the technique of permanently adding real-time effects, such as EQ or reverb, to an audio track by bussing and recording it to new tracks with the effects added. The original audio is preserved, so you can return to the source track at any time. This can be useful when you have a limited number of tracks or effects devices.

AudioSuite plug-ins provide another option for printing a plug-in effect to disk. See the DigiRack Plug-ins Guide for details.

Use Bounce to Disk if you need to convert the bounce files, or if you do not want or need to interact with mixer controls during the bounce.

Record to new tracks if you want to adjust controls while the files are being written.
Dither and Bounce to Disk

Dithering can significantly improve audio quality. Generally, dithering is necessary when reducing the bit depth for digital audio.

If you use Bounce to Disk, it is important to understand that the Bounce to Disk process does not apply dither.

To dither a bounce file, you should insert one of the included Digidesign Dither plug-ins, or another dithering plug-in, on a Master Fader assigned to the bounce source path. Master Faders are often preferable to Auxiliary Inputs because Master Fader inserts are post-fader (better for dithering).

If you do not use a dithering plug-in on your bounce source path, and you choose to convert to a lower resolution during or after a Bounce to Disk, the resultant file will be converted by truncation.

When to Use a Dithering Plug-in

You should use a dithering plug-in in any situation where you are reducing bit depth, for example, when mastering to a 16-bit file with the Bounce to Disk command, or when mastering to an external device that records at 16-bit.

This is even necessary when using 16-bit sessions. Even though 16-bit sessions use 16-bit files, they are still being processed at a higher bit rate:

- 24-bit audio input and output signal paths with internal 48-bit mixing and processing for Pro Tools HD systems
- 24-bit audio input and output signal paths with internal 32-bit floating point processing for Pro Tools LE systems

For this reason, whether you are using a 16-bit session or a 24-bit session, it is recommended that you use a Dither plug-in when mastering to 16-bits.

When mastering to 24-bits, it is not necessary to use a Dither plug-in.

Using Dither on an Output Mix

Pro Tools includes real-time dithering plug-ins that improve 16-, 18-, or 20-bit performance and reduce quantization noise when mixing or fading low-level signals.

The dithering plug-ins have no user-selectable controls other than Bit Resolution and Noise Shaping controls.

For more information about dither, see “Dither” on page 557.

To use a dithering plug-in on a submix:

1. Choose Track > New and select Master Fader (stereo) from the pop-up menu.
2. Set the output of the Master Fader to the output or bus path you want to bounce.
3. Assign the outputs of all audio tracks in the session to the same path you selected in step 2. The Master Fader now controls the output levels of all tracks routed to it.
4. On the Master Fader, click an Insert button and choose one of the Digidesign Dither plug-ins.
In the dithering plug-in window, choose an output Bit Resolution and Noise Shaping setting.

When you Bounce to Disk you can convert the file to the appropriate resolution. Before being converted by the Bounce to Disk command, the signal will have been dithered to the resolution and noise shaping settings in a dithering plug-in.

In contrast, the Bounce to Disk command lets you bounce all available voices to disk without holding any in reserve, but you cannot manually change any controls during the bounce. See “Bounce to Disk” on page 638 for more information.

For more information about the Digidesign dithering plug-ins, refer to the DigiRack Plug-ins Guide.

Recording to Tracks

You can create a submix in your Pro Tools session and record it to available tracks in the same session. This technique lets you add live input to the mix, as well as adjust volume, pan, mute, and other controls during the recording process. You can also use this technique instead of Bounce to Disk to create mixed tracks directly in your Pro Tools session.

Voice Requirements

Recording a submix to new tracks requires an available voice for each track that you want to record. Make sure you have enough voices available to play back all tracks that you want to record and enough voices available to record the destination tracks.

For information about voice management, see “Track Priority and Voice Assignment” on page 112.

With Pro Tools HD, RTAS plug-ins placed on Auxiliary Input, Master Fader, and Instrument tracks will use additional voices and may introduce extra latency based on the HW Buffer Size. For more information, see “Voice Usage and Total Latency for RTAS Plug-ins” on page 561.

To record a submix to a track:

1. Apply any plug-ins or external processors you want to add to your audio tracks or Auxiliary Inputs before you record.

2. Set the main channel output of the tracks you want to include in the submix to a bus path. If you are using stereo or multichannel tracks, set the panning of each track.

3. Choose Track > New and create one or more mono, stereo, or multichannel audio tracks.

4. If you are recording in stereo, pan the new stereo track (or two mono tracks) hard left and right.

5. Set the input of each destination track to match the bus path from which you are recording.

6. Set the output of your new tracks to your main output path.

7. Select Options > Link Timeline and Edit Selection.
Select audio to record. The start, end, and length of the recording can be based on the cursor location or Timeline and Edit selections.

- Selection-based recording automatically punches in and out of recording at the selection start and end. Be sure to include time at the end of a selection for reverb tails, delays, and other effects.
- If you do not make a selection, recording will begin from the location of the playback cursor. Recording will continue until you press Stop.

Record enable the new tracks and click Record in the Transport window.

Click Play in the Transport window to begin recording the submix.

If recording a selection of audio, recording will stop automatically. If performing an open-ended recording, click Stop, or punch out of recording. Make sure Loop Playback is not enabled.

Bounce to Disk

The Bounce to Disk command lets you mix down with all available voices on your system. Since it records to separate audio files, you do not have to reserve any tracks for a bounce.

Pro Tools bounces are done in real time, so you hear audio playback of your mix during the bounce process (though you can’t adjust it).

You can use the Bounce to Disk command to create and automatically import loops, submixes, or any audio into your session. You can use it to create a final mono, stereo, or multi-channel master, in any of several audio file formats. Bounce to Disk provides conversion options for sample rate, bit resolution, and format.

When you bounce a track to disk, the bounced mix includes the following:

Audible Tracks All audible tracks that are routed to the output which is selected as the source of the bounce are included in the bounce. Any muted tracks are not included in the bounce. If you solo one or more tracks, only the soloed tracks are included in the bounced mix.

Automation All read-enabled automation is played back and incorporated in the bounced mix.

Inserts and Sends All active inserts, including real-time plug-ins and hardware inserts, are applied to the bounced mix.

Selection or Track Length If you make a selection in a track, the bounced mix will be the length of the selection. If there is no selection in any track, the bounce will be the length of the longest audible track in the session.

Time Stamp Information Bounced material is automatically time stamped so that you can drag it into a track and place it at the same location as the original material. For more information about time stamping, see “Time Stamping” on page 694.

Bounced Files Are Delay-Compensated

Pro Tools compensates for any bus and plug-in delays due to a bounce. This means that if a bounce file is imported back into a session, and placed directly in time against the source mix, it is time-aligned with the original source mix.

Record-Enabled Tracks and TrackInput-Enabled Tracks Cannot Be Bounced

Pro Tools does not allow you to bounce tracks that are either record-enabled or in Input Only monitoring mode.
To Bounce to Disk:

1. Choose File > Bounce to > Disk.
2. Configure bounce options as needed and perform the bounce (see “Bounce Options” on page 639).

**Bouncing with Mute Frees Assigned Voice (Pro Tools HD Only)**

When bouncing sessions that include muted tracks, enabling “Mute Frees Assigned Voice” can, in some instances, increase the number of tracks that can be successfully bounced. See “Mute Frees Assigned Voice” on page 122.

**Bounce Options**

When you use the Bounce to Disk command, you can configure several file options.

<table>
<thead>
<tr>
<th>Bounce Option</th>
<th>Default</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bounce Source</td>
<td>current main output path</td>
</tr>
<tr>
<td>File Type</td>
<td>session default file type</td>
</tr>
<tr>
<td>Format</td>
<td>Stereo</td>
</tr>
<tr>
<td>Resolution</td>
<td>session default resolution</td>
</tr>
<tr>
<td>Sample Rate</td>
<td>session default sample rate</td>
</tr>
<tr>
<td>Conversion Quality</td>
<td>Good</td>
</tr>
<tr>
<td>Use Squeezer (8-bit only)</td>
<td>deselected</td>
</tr>
<tr>
<td>Convert During Bounce</td>
<td>deselected</td>
</tr>
<tr>
<td>Convert After Bounce</td>
<td>selected</td>
</tr>
<tr>
<td>Import After Bounce</td>
<td>deselected</td>
</tr>
</tbody>
</table>

*Chapter 28: Mixdown* 639
Bounce Source

Select any mono, stereo, or multichannel output or bus path as the source for the bounce. All currently active output or bus paths as defined in the I/O Setup dialog are available as the Bounce Source.

To set the bounce source:
- Select an output or bus path from the Bounce Source selector.

Enforce Avid Compatibility

Creates frame-accurate edits, wraps the files as OMFI (unless File Type is MXF), and limits the sample rate options to 44.1 kHz or 48 kHz. Dithering without noise shaping will be applied to files being exported from 24-bit to 16-bit.

File Type

Selects the (creator) type for the bounced files.

Sound Designer II
(Mac Only)

This was the native format for older Mac-based Pro Tools systems. Select this to use the bounced audio with any Digidesign application for Mac.

BWF (Broadcast .WAV Format)

This was the native format for older Windows-based Pro Tools systems, but is now supported on Windows and Mac. To use a BWF (.WAV) file in Pro Tools, you can drag and drop from the DigiBase Browser, Windows Explorer or Mac Finder, or a folder, or you can use the Import Audio command. Files in this format do not have to be converted to be used in Pro Tools.

AIFF (Audio Interchange File Format)

To use an AIFF file in Pro Tools, you can drag and drop from the DigiBase Browser, Windows Explorer or Mac Finder, or you can use the Import Audio command. Files in this format do not have to be converted to be used in Pro Tools.
**QuickTime**

QuickTime is Apple’s multimedia audio file format. Pro Tools does not directly support this type of file in its sessions. To use a QuickTime audio file within Pro Tools, use the Import Audio command. The QuickTime format is popular for attaching to emails, to simplify long-distance project review and approval. Many popular multimedia applications also support QuickTime.

**Sound Resource**

*(Mac Only)*

This file type is supported by some Mac software applications. Pro Tools does not directly support this type of file in its sessions. To use a SND file within Pro Tools, use the Import Audio command. The SND format is useful if you plan to use your audio with other Mac applications that do not support Sound Designer II or AIFF formats.

**Windows Media**

*(Windows Only)*

Windows Media formatted files can contain audio, video, or script data stored in Windows Media Format. A Windows Media Format file may have an .asf, .wma, or .wmv file name extension.

**MXF (Material Exchange Format)**

*(Pro Tools with DigiTranslator Only)*

MXF is a media file format that includes both video and audio files, and is designed for the interchange of audio-visual material with associated data and metadata. It was designed for improving file-based interoperability between servers, workstations, and other content creation devices.

AAF and OMF sequence format files can refer to MXF media files, or have MXF media files embedded within them. Pro Tools with DigiTranslator supports AAF embedded sequences.

See the DigiTranslator Guide for more information.

**MPEG-1 Layer 3 (MP3)**

The MPEG-1 Layer 3 compression format (MP3) is used for streaming and downloading audio over the Internet, and for playback on portable devices. The MP3 Option is required to use this file type.

💡 The MP3 Export Option is available for purchase from the online DigiStore at the DigiDesign Web site (www.digidesign.com).

The MP3 encoder provided as an install option with Pro Tools is a fully functional 30-day demo version. To purchase the full version of the MP3 encoder, visit Digidesign’s Web site (www.digidesign.com).

When you select this format, the Resolution pop-up menu in the Pro Tools Output Options dialog is unavailable. The resolution is set by the encoder.
The sample rate chosen is given to the codec as a base sample rate for operations. The actual sample rate of the resulting file is determined in the MP3 Encoder Options dialog. For example, if a base sample rate of 48000 Hz is chosen, the MP3 Encoder Options dialog will allow output streams in 48, 24, or 12 kHz, depending on encoding quality.

When you export or bounce to MP3 format, you can set the following options:

**Encoder Settings**

**Encoder Speed** Determines the audio quality of the bounced file. There are two options: Highest Quality and Fastest Encoding Time.

The Highest Quality setting can take up to five times longer to process audio than the Fastest Encoding setting, so you should use it only when the highest fidelity is essential and you have a considerable amount of time to devote to the encoding process.

**Constant Bit Rate (CBR)** Encodes the file at a single bit rate that you choose from the CBR pop-up menu. Because the bit rate is fixed, the quality of the encoded audio will vary depending on the nature of the material being compressed. This option is best for streaming over the Internet, since it has predictable bandwidth requirements.

**ID3 Tag Info Settings**

**ID3 Tag Type** The ID3 tag stores data about the encoded audio file that is used by MP3 players to display information about the file. Pro Tools supports three versions of this tag, in order to provide backward compatibility with older MP3 players:

- ID3 v1.0: Appears at the end of a streaming MP3 file, so that tag information is only displayed after software streaming is finished.
- ID3 v1.1: Same as version 1.0, but adds track number information to the tag.
- ID3 v2.3: Appears at the front of a streaming MP3 file, so that tag information is displayed when streaming begins.

⚠️ While ID3 v2.3 is becoming the standard MP3 format, not all MP3 players currently support ID3 v2.3. Contact the developer of your player software for compatibility information.

**Title/Artist/Album/Comment** Type the title, artist, and other information for the MP3 file. This information is displayed by many MP3 players.

**Genre** Choose a genre for the file. This information is displayed by many MP3 players, and can appear in searchable catalogs and databases.

**Track Number** If you select ID3 tag type v1.1 or v2.3, you can enter a CD track number for the file. This information is displayed by many MP3 players.

**Year** Enter a year for the file. This information is displayed by many MP3 players.

**Mac File Settings**

**Mac File Type and Creator** If you expect your file to be used on a Mac, you can enter the Mac file type and creator. This will allow users to double-click the file to open their MP3 player.

**Default Button**

To restore all settings in this dialog to their default values, click Defaults.
**Format**

This is the format for the bounced result. Choices are Mono (Summed), Multiple Mono, and Stereo Interleaved.

**To set the bounce file format:**

1. Select a file format from the Format selector.

   ![Bounce dialog (file Format type)]

   **Bounce dialog (file Format type)**

**Mono (Summed)** Creates a single disk file that is a summed mono mix of the current sources being monitored.

Before bouncing to disk, make sure your levels are below –3 dB to avoid clipping that occurs when left and right signals exceed –3 dB below maximum, or full code (0 dBFS).

**Multiple Mono** Creates multiple mono files with the same number of channels as the source path.

- If the source output or bus path is stereo, two mono files will be created, and appended with “.L” and “.R” suffixes on bounce.
- If a multichannel format is used (for example, six-channel, 5.1), individual mono files will be created for each member of the path. Files will be appended with path suffixes according to the path definition in the I/O Setup dialog.
- If the source output or bus path is mono, the pop-up menu will switch from multiple mono to mono, and will create one mono file (no summing of multiple sources).

**Stereo Interleaved** Creates a single, interleaved file that contains all of the bounced streams from the chosen output path. In an interleaved stereo bounce, tracks assigned to odd-numbered outputs are sent to the left channel, and tracks assigned to even-numbered outputs are sent to the right channel.

Pro Tools also lets you bounce multichannel interleaved files of any supported file type. This can simplify file management of mixes and projects for backup and archiving.

Pro Tools does not support interleaved files natively. This means that they must be split into multi-mono files on import (requiring additional disk space).

**Resolution**

This option lets you select between three different bit resolutions for the bounce conversion.

Bounce to Disk does not apply dither when converting during or after a bounce to a lower resolution (including when bouncing to 16-bit). When you need to create a lower resolution bounce file, use a Dither plug-in, or similar, on a Master Fader assigned to the bounce source path. This dithers the bounce file, before the Bounce to Disk conversion truncates bits into the final file resolution. (See “Dither and Bounce to Disk” on page 636.)

Resolution choices include the following:

**8-bit** This resolution is often used in multimedia applications. If the material you are working with is relatively simple, you can use the Pro Tools “Squeezer” feature for optimal results. See “Sample Rate Conversion Quality Option” on page 644 for details.

**16-bit** This is the Compact Disc standard bit resolution.
24-bit This setting provides the highest resolution. It is useful when you want to create a final mix without losing any resolution (for example, if you are delivering a final mix that will be ready to master).

If your session is 16-bit, you should still apply Dither, because all Pro Tools sessions process internally at 24-bit.

To set the bounce file resolution:
- Select a bit depth from the Resolution selector.

Sample Rate
This option lets you save to any of several sample rates. Choices are dependent on your Pro Tools system and Digidesign audio interfaces.

Sample Rate Conversion Quality
If you choose a sample rate that differs from the original sample rate of the session, the conversion options become available. You can configure the conversion quality, and schedule conversion to occur during, or after, the bounce. See “Sample Rate Conversion Quality Option” on page 644 for more information.

The following are the more common sample rates, and their applications. Higher sampling rates will provide better audio fidelity for recording and playback, and also for processing with dynamics, dither (with noise shaping), and analog emulation plug-ins.

192000 This is a supported sample rate for some audio DVDs, and provides the highest quality audio fidelity with compatible audio interfaces (such as the 192 I/O).

176400 You may want to work at a sample rate of 176.4 kHz if the final delivery will be at 44.1 kHz (such as compact disc). This will provide a slightly faster sample rate conversion to 44.1 kHz than from 192 kHz.

96000 This is a supported sample rate for DVD audio and provides high-quality audio fidelity with compatible audio interfaces (such as the 192 I/O, 96 I/O, 96i I/O, and Digi 002).

88200 You may want to work at a sample rate of 88.2 kHz if the final delivery will be at 44.1 kHz (such as compact disc). This will provide a slightly faster sample rate conversion to 44.1 kHz than from 96 kHz.

48000 This is a standard sample rate for Professional and DVD video, as well as some broadcast and recording label archiving, and is supported by DA-88/98, DAT, and ADAT decks.

44100 This is the standard sample rate for compact discs (CD), and is supported by DA-88/98, DAT, and ADAT decks.

Custom For a custom sample rate, click in the sample rate window and manually enter in a value.

Pull-Up and Pull-Down Rates All available sample rates support pull-up and pull-down rates, or other specialized rates.

Sample Rate Conversion Quality Option
When you specify a different sample rate for a bounced file (for example, when mixing a session recorded at 96 kHz to 44.1 kHz for release on an audio CD), Pro Tools uses the Conversion Quality option to determine the quality of sample rate conversion used.
There are five possible settings, ranging from Low (lowest quality) to Tweak Head (highest quality). The higher the quality of sample rate conversion, the longer it takes to convert the bounced file.

**Use Squeezer**  
*(8-Bit Resolution Only)*

The Use Squeezer option uses a proprietary DSP algorithm specifically designed for performing 8-bit conversion of simple source files such as voice-overs. It optimizes the dynamics of the audio by preprocessing it using compression, limiting, and gating before conversion to 8-bit resolution. This results in greater apparent loudness in the signal, and improved intelligibility. If you are converting a more complex 16-bit audio file to 8-bit resolution, test this option before converting all of your material.

**Convert During or After Bounce**

The Bounce to Disk dialog can perform any conversion options, including sample rate and bit depth conversion, during a bounce or post-bounce.

The following options are only available when bouncing to a different file type, format, resolution, or sample rate.

**Convert During Bounce** This option may take less time than Convert After Bounce, but does so at the expense of plug-in automation playback accuracy.

**Convert After Bounce** The Convert After Bounce option, though it takes more time, offers the highest level of plug-in automation accuracy possible.

---

**Import Into Session After Bounce**

The Import After Bounce option automatically imports the newly bounced files into the Region List so you can place them in tracks. If your newly bounced files are split stereo files (Multiple Mono), they are listed together in the Region List.

⚠️ The Import After Bounce option is only available if the target file type and sample rate for the bounce is the same as the file type and sample rate of the current session, and the target resolution (bit rate) is the same or lower than the resolution of the session. In addition, tracks bounced to a Stereo Interleaved file cannot be automatically imported after a bounce.

**Help**

The Help button opens a display-only dialog that describes the Bounce to Disk features.

---

**Recording a Submix (with Bounce to Disk)**

You can create a submix with the Bounce to Disk command by muting tracks or bypassing inserts that are not part of the submix, and selecting the part of the session you want to bounce. Or, you could solo only the audio you want to bounce.

You can also create a submix by recording to new tracks. For details, see “Recording to Tracks” on page 637.
To bounce a submix to disk and bring it into the session:

1. Configure your submix using sends, Auxiliary Inputs, and Master Faders. (See “Submixing for Signal Routing and Effects Processing” on page 548.)

2. Do one of the following:
   - To bounce the entire session, click Return to Zero in the Transport window to go to the beginning of the session.
   - or –
   - To bounce a portion of the session, enable Options > Link Timeline and Edit Selection, and make a selection in the Edit window.

3. Choose File > Bounce to > Disk.

4. Configure bounce options and settings.

5. Verify the bit resolution for the bounced file matches the bit resolution of the session.

6. Verify the sample rate for the bounced file is supported by the session and the audio interface.

7. If required, verify the file type and format for the bounced file matches the file type and format of the session.

8. Select the Import After Bounce option.

9. Click Bounce.

10. Select a destination for the new audio file, enter a name, and click Save.

Pro Tools bounces are done in real time, so you hear audio playback of your mix during the bounce process. You cannot adjust controls during a Bounce to Disk.

To bring bounced files back into tracks:

1. Do one of the following:
   - If the newly bounced audio was automatically imported into the session, drag the new files from the Region List to existing tracks in your session.

   If you bounced from a selection point, you can snap the file to the bounce point: Start-drag (Windows) or Control-drag (Mac) the region from the Region List to the destination track.

   - If the bounced files are not available in the Region List, import them into the session with the Import Audio command, or drag and drop the bounced files from a DigiBase browser.

   - If you are placing multiple files, keep channels time-aligned with each other by Shift-selecting them in the Region List, and dragging them simultaneously into existing tracks of the right format.

2. When working with stereo tracks, set the Pan controls hard left and hard right.

3. Solo the track with the bounce on it.

4. Click Play in the Transport window to hear the results of the bounce.

Final Mixdown

In final mixdown, you create a mix that includes all your edits, automation, and effects processing.
To bounce a final mix to disk:

1 Adjust track output levels, and finalize any mix automation for each track in the session.

2 Adjust any real-time plug-in and effects settings and their automation for each track in the session.

3 Make sure that all of the tracks you want to include in the bounce are audible (not muted or inactive).

4 Assign the output of each of the tracks you want to include in your bounce to the same output or bus path.

5 Add dither. See “Dither and Bounce to Disk” on page 636.

6 Do one of the following:
   • To bounce the entire session, click Return to Zero in the Transport window to go to the beginning of the session.
   – or –
   • To bounce a portion of the session, enable Options > Link Timeline and Edit Selection, and make a selection in the Edit window.

By default, the bounce will end at the last audio waveform or MIDI note. To end the bounce sooner, make an Edit or Time selection to define the end (and start) of the bounce.

7 Choose File > Bounce to > Disk.

8 Choose the source path you want to bounce.

9 Configure other Bounce to Disk settings as appropriate. See “Bounce Options” on page 639.

10 Click Bounce.

11 Select a destination for the new audio file, enter a name, and click Save.

Mastering

In the final mastering process, you might record directly to disk, DAT, DVD, CD, stereo mastering recorder, or a multitrack recorder (for surround mixes).

Once you have created a master of your session, you can transfer it to a portable medium for duplication. You can transfer the master file to CD or DAT to be used as a master for pressing compact discs.

Mastering to a Digital Recorder

Although it is usually best to master sessions directly to hard disk, Pro Tools also lets you master digitally, direct to any AES/EBU-equipped or S/PDIF-equipped digital recorder such as a DAT deck.

24-Bit Input and Output

Pro Tools|HD systems support full 24-bit audio input and output signal paths, with 48-bit internal mixing and processing, providing an additional 16 bits of headroom at the top of a channel’s dynamic range, and 8 bits at the bottom. You can exchange files with other 24-bit recording systems without any bit-depth conversion (as long as they are in a compatible file format).

Pro Tools LE systems support 24-bit input and output, and uses 32-bit floating point mixing and processing internally. You can exchange files with other 24-bit recording systems without any bit-depth conversion (as long as they are in a compatible file format).
Mastering and Audio Compression

Although audio compression is often an indispensable tool in analog recording, it can present problems in the digital domain. If you compress an input signal at a very high ratio, you create a signal that contains a much higher overall power level compared to its transients. By recording a number of such signals at the highest possible level on multiple tracks, you create a scenario that is more likely to clip the mixed output signal.

High-power compressed signals, when mixed together, create an extremely high-level output. This output may rise above the full-code level, resulting in clipping.

To avoid this problem, watch the overall level of your program material—use a meter on a Master Fader, or use an external mastering deck’s meters to help identify clipping. If you are mastering to hard disk, avoid mixing full-code audio signals together at unity or “0” level, as this invariably causes clipping.

Mastering and Error-Correcting Media

Random access media (such as hard disks, optical cartridges, Bernoulli cartridges or WORM drives) can produce a true digital copy of your data, because every bit value is maintained. Sequential media (such as DAT tapes) use error correction schemes to fix the occasional bad data that is received in a digital transfer. These corrections are deviations from the actual data, and with successive reproductions, represent a subtle form of generation loss.

You can avoid this loss by creating and maintaining masters on random-access digital media (such as a hard drive) and transferring them to sequential digital media (such as DAT tapes) only as needed.

To configure Pro Tools for direct digital stereo mastering:

1. Connect your digital recorder to your system’s digital outputs. If your system has multiple digital outputs, use channel 1 and 2 of the audio interface.
2. In Pro Tools, set the appropriate digital format and output from the Hardware Setup dialog or I/O Setup dialog. (See “Configuring Pro Tools Hardware Settings” on page 46.)
3. Set the clock on the master device to slave to Pro Tools digital clock, or to provide master clock to Pro Tools. (See “Configuring Pro Tools Hardware Settings” on page 46.)
4. On your digital recorder, choose the appropriate digital format for the connections.
5. In Pro Tools, set all audio tracks you want to your master outputs 1–2 path.
6. Click Return to Zero in the Transport window to go to the beginning of the session.
7. Press Record on your digital recorder.
8. Start playback of your session.
9. When your session has finished playing, stop the digital recorder.
Part VII: Video, Sync, & Surround
Chapter 29: Working with Video in Pro Tools

This chapter covers video features that apply to QuickTime movies only, or to both QuickTime movies and Avid Video.

For detailed information on features that apply specifically to working with Avid video in Pro Tools, see the Avid Video Peripherals Guide.

Introduction

Pro Tools lets you import QuickTime movies and Avid video, perform audio post-production tasks and basic video editing, and export the finished product as a new QuickTime movie.

Most operations that you can perform for audio tracks are also available for video in Pro Tools.

You can do the following with video tracks in Pro Tools:

- Import multiple video files into the Timeline
- Create multiple video tracks with QuickTime movies and Avid video in the Timeline
- Select from multiple video playlists on each video track
- Mix multiple codecs in video tracks
- Lock video tracks
- Import video into Pro Tools using menu commands or drag and drop
- Extract audio from QuickTime movies
- Organize, group, and edit video regions in the Timeline much like audio regions
- Organize, edit, and group video regions with audio regions
- Undo multiple video operations
- Scrub audio in tandem with video
- View video in the Video window or output it through FireWire to an external monitor
- Bounce the video track to a QuickTime movie
About QuickTime

Using QuickTime Movies in Pro Tools

Pro Tools supports the import, playback, and editing of QuickTime movies.

QuickTime Requirements

Pro Tools supports import, playback, and editing of QuickTime movies without additional hardware. To take advantage of the broad range of QuickTime movie capabilities in Pro Tools, QuickTime 7.1.2 is required.

QuickTime Movie Playback Performance Options

The Operation Preferences page provides three options for QuickTime Playback Priority:

Normal This is the default setting for QuickTime Movie Playback Priority. It gives no extra priority to movie playback over other screen update tasks such as metering, moving faders, and so on. In most cases you should use this setting.

Medium This setting gives QuickTime movie playback a higher priority relative to other Pro Tools screen update tasks. Use this setting if you experience inconsistent QuickTime movie playback with the Normal setting.

Highest This setting gives QuickTime movie playback highest priority. In this mode, Pro Tools disables screen activity and requires you to use the Spacebar to stop playback. Use this setting if you require uninterrupted QuickTime movie playback.

See also “FireWire Playback of QuickTime DV Movies” on page 668.

Hard Drive Tips for Best Performance

For best results, always use dedicated video-only and audio-only drives.

For complete information on hard drive requirements, visit the Digidesign Web site.

Applying Pull-Ups to QuickTime Movies

Applying a pull-up to QuickTime movies in a session may have unpredictable effects on the playback of any Avid video in that session. Only use video pull-up feature for sessions that do not contain Avid video.

Before Starting Your Project

Before you start any project that requires working with video, consider the following:

Frame Rate Before receiving video, obtain the frame rate. Use that frame rate when setting the frame rate of your Pro Tools sessions and when capturing video.

Creator Application and Codec Before receiving video as media files, find out the application and codec used to create those files. Then confirm that you can play those files in Pro Tools. It is always a good idea to get a sample file in advance.
QuickTime Movie Time Code Burn-in Before receiving QuickTime movies, request time code display to be “burned in” (superimposed) if possible. This ensures that Pro Tools places the file at the correct time code location in Timeline.

Sufficient Space on Video Drives Ensure sufficient space is available on dedicated video-only drives. Video files take up significantly more space than audio, and must be kept on separate drives from audio files to prevent performance problems.

Video Tracks
You can add multiple video tracks with QuickTime movies or Avid video to the Timeline, but an individual video track cannot hold both types of video at the same time.

To create a new video track:
1. Choose Track > New.

<New Tracks dialog>

2. In the New Tracks dialog, do the following:
   • Select Video Track from the Track Type pop-up menu.
     – and –
   • Enter the number of new video tracks.

3. Click Create.

A new empty video track appears. Video tracks may appear slightly different depending on your system configuration or the type of video added to a video track.

Empty video track

Video tracks support the following:
• Multiple video tracks on the Timeline
• Multiple playlists
• Multiple codecs on an individual video track

Multiple Video Tracks in the Timeline
You can add multiple video tracks to the Timeline, but only one video track can be played back at a time. This track is known as the main video track.

Main Video Track
The main video track is the video track that is currently online, and will be played back with any audio in the session.

When the main video track is offline, you can play back the audio in your session without playing back the video. When the video is offline, the Video Online button changes to grey so you can tell at a glance whether your video is offline or simply playing black fill.
If no video track is currently online, the main video track is the video track that was last online.

See “Video Online Button” on page 655 for information on switching a video track online or offline.

Multiple Video Track Playlists

Playlists provide an easy way of changing back and forth between alternate versions of a video track.

You can perform all of the same operations with video playlists as you can with audio playlists, including:

• Duplicating a playlist
• Creating a playlist
• Assigning a playlist to another video track
• Renaming a playlist
• Deleting a playlist

For more information, see “Playlists” on page 270.

Multiple Codecs on an Individual Video Track

A single video track can contain video regions compressed with different video codecs. However, once the first video file has been added to a session, all additional video files added to the Timeline must have the same video engine rate as the first video file.

Video Track Controls and Indicators

Video Track View

The video track can be viewed in Frames View or in Blocks View, both of which display all video region boundaries and metadata.

To set the view for the video track:

■ On the video track, select Frames or Blocks from the View Options pop-up menu.

When switching from Blocks mode to Frames mode during playback, the video track will not update to displaying frames until playback is stopped.

Frames View

In Frames View, video data is displayed as pictures in the video track. These pictures are computed based on the video image, and scale according to your track zoom and height settings. They allow you to easily find a scene or sequence in the video track.

Frames do not display properly if you change zoom settings during playback. Black frames are drawn until playback is stopped. You should stop playback before changing zoom settings if you want to view frames.

If video pull-up or pull-down is enabled, frames do not change position.
Frames View Performance

When using Frames View to view movie content in the video track, your computer may exhibit reduced or sluggish performance. If this happens on your computer, hide the video track or switch to Blocks View.

💡 You can also hide the video track to further optimize performance, if necessary.

Blocks View

In Blocks View, video frames are replaced by colored blocks.

Video Track Type Icons

A video track displays a QuickTime icon or an Avid icon depending on the type of video added to it.

You can add any supported video to an empty video track, in which case the icon will change and the video track will play back only that type of video.

Differences in Video Tracks with QuickTime Movies and Avid Video

When an Avid video peripheral (such as an AOption|V10) is connected to your system and powered on, the following conditions apply:

- All video tracks display a Video Output selector, but only tracks containing Avid video display a Video Input selector.
- You can add Avid video to an empty video track.
- Only Video tracks contain a Record Enable button.

See the Avid Video Peripherals Guide for detailed information on using the Record Enable button and the controls in the I/O View.

Video Online Button

The Video Online button lets you select the main video track, and switch that track online or offline.

To use the Video Online button:

- Click the Video Online button of any track that is offline (grey) to put it online (blue), making that track the main video track.
- Click the Video Online button of the main video track to take it offline, and Pro Tools will not output video.
Locking Video Tracks

You can lock one or more video tracks to prevent any video regions on those tracks from being edited.

When a video track is locked, Pro Tools restricts all editing operations involving the track (except for locking and unlocking video regions).

To lock a video track:

1. Select the video track or tracks you want to lock.

2. Do one of the following:
   - Start-click (Windows) or Control-click (Mac) the name of any selected video track, and select Locked.
   - or –
   - Right-click the name of any selected video track, and select Locked.

A small lock appears in the video track, indicating it has been locked and cannot be edited. (The lock does not appear if the Track Height of the video track is set to Mini.)

Locking or unlocking a video track does not alter the lock status of individual regions. If a region was locked before you locked the track, the region will still be locked when you unlock the track. However, unlocking a region in a locked track will not allow you to edit that region. It will behave as if the region were locked until you unlock the track.

Setting the Video Engine Rate

The video engine rate represents the number of video frames output by Pro Tools per second, and is determined automatically by the frame rate of the first video file added to a session. Video files subsequently added to the session must have the same video frame rate as the video engine rate.

The video frame rate is displayed for each video file in the DigiBase browsers, and the current video engine rate is displayed in the I/O View of the main video track.

See “Video Engine Rate Indicator” on page 657 for information on the Video Engine Rate indicator in the I/O View.

The video engine rate is independent of the session’s time code rate, which determines the number of frames displayed per second in grids, rulers, and counters. You can set the session time code rate manually with the Time Code Rate pop-up menu in the Session Setup window. In order for the grids and rulers to align with the actual frames of the video files in the Timeline, the session’s Time Code Rate setting should be set to match the video engine rate (the frame rate of the first video clip added).
Video Engine Rate Indicator

The Video Engine Rate indicator displays only in the main video track (whether it is online or offline) and shows the video engine rate, which is the number of video frames per second output by Pro Tools.

The Video Engine Rate indicator is normally black, but turns red if one of the following conditions are present:

- The video engine rate does not match the session’s current Time Code Rate setting.
- A pull-up has been applied to the video, causing the video engine rate to differ from the session Time Code Rate.

Video Frame Rate

The Video Engine Rate indicator is normally black, but turns red if one of the following conditions are present:

- The video engine rate does not match the session’s current Time Code Rate setting.
- A pull-up has been applied to the video, causing the video engine rate to differ from the session Time Code Rate.

In general, audio and video media should be stored on separate dedicated drives. When importing audio and video at the same time, however, Pro Tools copies both to the same drive. If you have difficulty playing back audio or video media, you should either import the audio separately using the Import Audio command, or manually copy the audio files to an audio drive.

When you import MPEG-2 video into Pro Tools, only the video portion of the file is imported and the resulting video regions cannot be edited.

Importing Video into Pro Tools

Pro Tools provides the following methods of importing video files into the Timeline, Region List, and new or existing video tracks:

- Using the Import Video menu command
- Dragging from a DigiBase browser or from Windows Explorer or Mac Finder
- Using the Import Session Data command

The video frame rate of the first video file added to a session determines the session’s video engine rate. Video files subsequently added to the session must have the same video frame rate as the video engine rate.

Importing Video into Pro Tools Using the Import Video Command

The Import Video menu command lets you choose one or more video files to import into Pro Tools.

When you use this method to import video into Pro Tools, the Video Import Options dialog appears. This dialog contains multiple options for customizing how files are imported.

The Time Code Rate is set in the Session Setup window. For more information, see “Session Setup Window” on page 675.
To import video into Pro Tools using the Import Video command:

1. Do one of the following:
   - Choose File > Import > Video.
   - or –
   - Press Alt+Control+Shift+I (Windows) or Command+Control+Shift+I (Mac).

2. In the Select Video File to Import dialog, select one or more video files.

3. Click Open.

4. Configure the Video Import Options dialog as desired, and click OK to import video into Pro Tools.

See “Configuring Video Import Options” on page 658 for detailed instructions.

Importing Video into Pro Tools with Drag and Drop

You can drag and drop video files from a DigiBase browser or from Windows Explorer or Mac Finder to the Timeline, a track, a Track List, or the Region List.

When you use this method to import video into Pro Tools, the Video Import Options dialog appears. This dialog contains multiple options for customizing how files are imported.

To import video into Pro Tools using drag and drop:

1. Drag and drop one or more video files from a DigiBase browser or from Windows Explorer or Mac Finder to the Track List, Timeline, or an existing video track.

2. Configure the Video Import Options dialog as desired, and click OK to import video into Pro Tools.

See “Configuring Video Import Options” on page 658 for detailed instructions.

Importing Video into Pro Tools Using Import Session Data

You can use the Import Session Data command to import video from other Pro Tools sessions or (with DigiTranslator 2.0) from an AAF or OMF sequence. Any video files you import must have the same video frame rate as the video files in the session.

For information on importing session data, see “Importing Tracks and Track Attributes” on page 144. For detailed information on importing AAF or OMF sequences into Pro Tools, see the DigiTranslator Guide.

Configuring Video Import Options

The Video Import Options dialog appears when you import video into Pro Tools by using the Import Video command or dragging video files from a DigiBase browser or from Windows Explorer or Mac Finder.

See “Bypassing the Video Import Options Dialog” on page 660 for details on bypassing the Video Import Options dialog when dragging and dropping video files.
To import video files into Pro Tools using Video Import Options:

1. Do one of the following:
   - Choose File > Import > Video, and select the video files you want to import, then click Open.
   - Drag and drop one or more video files from a DigiBase browser or from Windows Explorer or Mac Finder to the Track List, Timeline, or an existing track.

2. In the Video Import Options dialog, customize Video Import Options as desired.

**Destination Section**

The Destination section of the Video Import Options dialog lets you choose a general destination for imported video in Pro Tools.

- **Main Video Track** The video file is imported directly to the track that is currently online (known as the main video track) and into the Region List. If no track is currently online, the video file will be imported to the last existing video track that was online.
- **New Track** Each video file is imported into its own individual track and into the Region List.
- **Region List** Video files are imported into the Region List without creating a new track. Imported video files appear in the Region List and can then be dragged into an audio track.

**Location Pop-Up Menu**

The Location pop-up menu lets you choose precisely where Pro Tools places the imported video in the Timeline.

- **Session Start** Places the video file at the start of the session.
- **Song Start** Places the video file at the Song Start position.
- **Selection** Places the video file at the edit cursor position or within the selection (if one was made).
- **Spot** Displays the Spot dialog, which lets you spot video to precise locations based on any of the Time Scales.
- **Original Time Stamp (Avid Video Only)** Places Avid video in the Timeline at a time code location that corresponds to the timestamps from the original source tape. With multiple video files, this places all video files in the Timeline at their respective original timestamps.

**Additional Video Import Options**

- **Gaps Between Regions** When you import more than one QuickTime movie or Avid video file into a track, they will be shuffled together by default. This option lets you indicate the number of seconds by which each video clip will be separated when imported into the video track.
- **Import Audio from File (QuickTime Movies Only)**
  When selected, the audio from the QuickTime movie you are importing will be extracted and placed into new mono or stereo audio tracks in the Timeline. (Mono or stereo with a sampling rate of 48 kHz or lower are supported.) When unselected, only the video portion of the QuickTime movie will be imported into Pro Tools.
- **Remove Existing Video Tracks** When selected, all existing video tracks will be deleted before Pro Tools imports video into the session.
- **Remove Existing Video Regions** When selected, all existing video regions will be removed from the Timeline and the Region List before Pro Tools imports video into the session (but
left on disk). This option is useful if you want to import a video file into the session with a video frame rate that does not match the current video engine rate.

See “Setting the Video Engine Rate” on page 656 for more information.

Clear Main Video Track Playlist When selected, all existing video regions in the currently-selected playlist on the main video track will be removed from the track before Pro Tools imports video into the session. No other playlists, video tracks, or video regions will be affected. (This option is only enabled if the main video track is selected as the Destination option.)

3 Click OK.

Bypassing the Video Import Options Dialog

You can bypass the Video Import Options dialog when dragging video files from DigiBase browsers only. Pro Tools adds video files exactly where you drop them in the Timeline following the current Pro Tools editing mode.

To bypass the Video Import Options dialog when importing video into Pro Tools:

- Alt-drag (Windows) or Option-drag (Mac) one or more video files from a DigiBase browser into the Region List or the Timeline.

Importing Video into Pro Tools Using Import Session Data

You can use the Import Session Data command to import video from other Pro Tools sessions or (with DigiTranslator 2.0) from an AAF or OMF sequence. Any video files you import must have the same video frame rate as the video files in the session.

For information on importing session data, see “Importing Tracks and Track Attributes” on page 144. For detailed information on importing AAF or OMF sequences into Pro Tools, see the DigiTranslator Guide.

Extracting Audio from QuickTime-Compatible Video

(QuickTime-Compatible Video Only)

You can extract the following audio file formats from QuickTime-compatible video files without importing the video:

- Qualcomm
- AAC (MPEG-4)
- Digital video audio streams
- MP3
- QDesign
- uLaw 2:1
- aLaw 2:1
- Intel ADPCM
- Microsoft ADPCM
- IMA 4:1
- 32-bit floating point
- 64-bit floating point
- 16-bit Big Endian
- 16-bit Little Endian
- MACE 6:1
- MACE 3:1
To import audio from a QuickTime movie without importing the video, do the following:

1. Choose File > Import > Audio.
2. In the Import Audio dialog, navigate to the QuickTime movie from which you want to import audio, and select it.
3. Under the Region section, click the name of the audio region you want to extract from the QuickTime movie, and click Convert Region or Add Region.
4. Select other audio files as desired, and click Done to import the audio.

The Audio Import Options dialog appears, where you can choose to import the audio into a new track (and the Region List) or the Region List only.

The audio is converted to the session’s sample rate and bit resolution, and a new region appears in the Region List for each imported file. The regions are listed in the Region List with the region name, the number of the originating track, and the number of the region from the track.

Sample Rate Conversion Quality

If you import QuickTime audio that was not originally recorded at the session’s sample rate, the sample rate is converted to match the audio to your session. Pro Tools allows you to choose the quality of the sample rate conversion by means of the Conversion Quality setting in the Editing Preferences page.

There are five possible settings, ranging from Low (lowest quality) to Tweak Head (highest quality). The higher the quality of sample rate conversion, the longer it takes to convert the bounced file.

To set the sample rate conversion quality:

1. Choose Setup > Preferences and click the Processing tab.
2. Click the Conversion Quality pop-up menu and select a conversion setting.

Video Regions

You can create and edit video regions, which function in much the same way as audio regions.

Video region as displayed in Frames View in the Timeline

A video region is a segment of video data, and can be a portion of video or an entire video file. In Pro Tools, video regions are created from QuickTime or Avid files, and can be arranged in corresponding video track playlists. Video regions can also be grouped, looped, and color coded.

You can edit and change viewing options for video regions in the same ways as audio regions. All edits to video regions are nondestructive. (See “General Video Editing” on page 662 for more information.)

Just like audio regions, video regions display in Pro Tools in the Region List or the Timeline.
Video Regions in the Region List

A video region displays in the Region List with a small video icon next to its name.

Showing or Hiding Video Regions in the Region List

The Region List pop-up menu provides commands that let you show or hide video regions in the Region List.

To show or hide video regions in the Region List:

1. In the Edit window, click the Region List pop-up menu, and choose Show.
2. Select the Video option to show or hide video regions.

For information on working with regions in the Region List, see “The Region List” on page 275.

General Video Editing

Most editing operations that are available for audio regions can also be applied to video regions. This section describes all available video editing operations. Unless noted, the procedure for each video editing operation is the same as its audio editing counterpart.

See the appropriate section in this guide for detailed information on performing editing operations.

Basic Video Editing Features

- Nondestructive editing
- Display of region names, region times, and other data in playlists
- Multiple video playlists
- Multiple Undo
- Video regions and video region groups in Region List
- All Edit modes
- All Edit Tools (except for Time Compression Expansion and Pencil tools)

Playing and Selecting Video Track Material

- Selecting within video frame boundaries (see “Selecting within Video Frame Boundaries” on page 664)
- Selecting and editing across multiple Video and audio tracks (see “Selecting and Editing Across Multiple Audio and Video Tracks” on page 664)
- Link or unlink track and Edit selections
- Auto-scroll video tracks
- Loop playback
- Universe window (see “Browsing Video in the Video Universe Window” on page 666)
Working with Regions and Selections

- Capture regions
- Separate regions and Separate Grabber Tool
- Region overlap and underlap
- All trimming commands except for TCE
- Heal separated regions
- Place, align, slide, shuffle, and spot regions
- Sync points
- Nudging
- Shift command
- Quantize region to Grid (rounds to nearest video frame)
- Replace region command
- Cut, Copy, Paste, and Clear commands
- Special Cut, Copy, Paste, and Clear commands
  - Repeat to fill selection
  - Editing across multiple tracks
- Duplicate command
- Repeat command
- Region groups (see “Video Region Groups” on page 665)
- Region looping

Managing Regions

- Insert “silence” (see “Inserting Black” on page 664)
- Compact Selected (nothing happens to the video, and at least one audio track must be selected)
- All naming and displaying of region commands

Editing Caveats

The following caveats apply to video editing in Pro Tools:

- MPEG-2 video in the Timeline cannot be edited.
- If you create and enable a track group containing audio and video tracks—and any audio track has region boundaries that do not line up with video frame boundaries—you cannot tab through those region boundaries.

General Editing Operations Not Applicable to Video Regions

The following editing operations are applicable to audio regions, but are not applicable to video regions:

- Renaming disk files in the Region List or Timeline (see “Renaming Video Disk Files” on page 664)
- Fades
- Mute/unmute regions
- AudioSuite plug-ins
- Waveform Repair with the Pencil tool
- Strip silence
- Consolidate regions
Selecting and Editing Across Multiple Audio and Video Tracks

You can create a selection across multiple audio and video tracks, and cut, copy, or paste audio and video simultaneously.

Audio and video that is selected and cut, copied, or pasted follow the current Edit mode.

Selecting within Video Frame Boundaries

Pro Tools does not let you select, play back, or edit a partial video frame. The following rules apply when selecting or editing video:

- When you make a selection in a video track, the selection boundaries follow the current Grid setting but round to the nearest video frame boundary, as follows:
  - If the selection includes more than half of a video frame, the video frame is included within the selection.
  - If the selection includes less than half of a video frame, it is not included in a video selection.
- When you paste a selection containing video to a video track, the insertion point automatically aligns with the closest video frame boundary.

⚠️ When you paste audio and video simultaneously, this video frame re-alignment may result in the audio not being positioned exactly where you placed it. A warning dialog displays when this occurs.

Renaming Video Disk Files

When renaming audio regions in either the Timeline or the Region List, you have the option of also renaming the audio files on disk. However, this does not apply to video files on disk.

To rename video files on disk, you must rename them in a DigiBase browser or in Windows Explorer or Mac Finder.

Inserting Black

The Insert Silence command lets you insert black into a video track.

This command allows you to make a selection on a track (or tracks) and insert precisely that amount of black. You can also select across audio and video tracks, and use the Insert Silence command to insert audio silence and video black simultaneously.

In Shuffle mode, all video data on the track is shuffled later in the track by an amount equal to the selection.

In Slip, Grid, or Spot mode, the Insert Silence command works just like the Edit > Clear command.

To insert video black into a track:

1. Make a selection in a track or tracks. The length of the selection determines the duration of the black inserted.
2. Choose Edit > Insert Silence.
Video Region Groups

You can include video regions within region groups for the following operations:

- Creating region groups
- Creating multitrack region groups (including audio tracks)
- Editing region groups
- Creating fades and crossfades for audio files in region groups
- Importing and exporting region group files

See “Region Groups” on page 362 for detailed information on working with region groups.

Using the Video Window

Pro Tools provides a Video window that lets you view, display, or scrub video.

Avid video displays in the Video window only when scrubbed with the Scrub tool.

To display the Video window, do one of the following:

- Select Window > Video.
- Press Control+9 (Windows) or Command+9 (Mac).

Changing Video Window Options

The Video window pop-up menu lets you do the following:

- Toggle online status of the main video track.
- Toggle output of QuickTime movies between the Video window and an external monitor via the FireWire port.
- Resize the Video window.

To toggle the online status of the main video track:

- Right-click (Windows or Mac) or Control-click (Mac) the Video window, and select Online.

To toggle output of QuickTime movies between the Video window and FireWire, do one of the following:

- Right-click (Windows or Mac) or Control-click (Mac) the Video window, and select Video Out FireWire.
- Choose Options > Video Out FireWire.

Resizing the Video Window

You can resize the Video window by dragging or using Right-click commands.

To resize the Video window by dragging:

- Place the cursor at the bottom left or bottom right of the Video window, and drag the window to the size you want.
To resize the Video window by Right-clicking (Windows) or Control-clicking (Mac):

- Right-click (Windows or Mac) or Control-click (Mac) the Video window, and choose from the following resize options:
  - Half Size
  - Actual Size
  - Double Size
  - Fit Screen

**Scrubbing the Video Track**

Due to the latency introduced by all FireWire-based video peripherals, the video on an external monitor will not be in sync with the Scrubber tool. To scrub video without latency, you can scrub in the Video window.

If you scrub directly on the video track, only the video will scrub (no audio will play). If you scrub on an audio track, audio and video will scrub simultaneously.

**To scrub a video track:**

1. Ensure that scrubbing in the Video window is enabled by selecting Options > Scrub in Video Window.
2. Select the Scrubber tool.
3. Click in the video track and drag the Scrubber.

   To scrub with finer precision, press the Command key while scrubbing.

---

**Browsing Video in the Video Universe Window**

The Universe window has a pop-up menu for accessing commands to show the Video Universe window and increase or decrease the size of video frames in the Video Universe.

**Video Universe Window**

The Video Universe lets you view, navigate, zoom, and select video regions on the main video track.

**To display the Video Universe window:**

1. Make sure the Video Online button in the main video track is set to an online (blue) status.
2. Choose Window > Universe to display the Universe window.
3. Right-click (Windows or Mac) or Control-click (Mac) anywhere in the Universe window, and choose Video Universe.

The Video Universe window displays the center video frame of each video region in the main video track. Video frames are ordered sequentially according to their order in the Timeline, and the colored strip under each frame represents the color coding for that region.
Increasing or Decreasing the Size of Video Frames

To increase or decrease the size of video frames in the Video Universe window:

- Right-click (Windows or Mac) or Control-click (Mac) anywhere in the Universe, and select Increase or Decrease.

Selecting Zoom Resolutions in the Video Universe

When you move the cursor over the top half of a video frame in the Video Universe, it displays and behaves as a zoom tool. This tool lets you zoom in on one or more video regions to fill the entire Edit window display.

To use the Video Universe window to zoom video regions in the Edit window:

1. Move the cursor over the top half of any video frame until it becomes a zoom tool.
2. Do one of the following:
   - To move the beginning of a video region to the far left of the Timeline while maintaining the current zoom resolution in the Edit window, click the video frame representing the region once.
   - To zoom in on a video region so that it fills the entire Edit window, double-click the video frame representing the region.
   - To zoom a range of selected regions so that they fill the Edit window, click and drag on the video frames that represent the regions.

Selecting Ranges in the Video Universe

When you move the cursor over the bottom half of a video frame in the Video Universe, it displays and behaves as a selector tool. This tool lets you select ranges within one or more video regions in the Edit window.

To use the Video Universe window to select ranges in video regions in the Edit window:

1. Move the cursor over the bottom half of any video frame until it becomes a selector tool.
2. Do one of the following:
   - To place the cursor at the beginning of a video region, click the video frame representing the video region.
   - To select an entire video region from start to end, double-click the video frame representing that region.
   - To select one or more entire regions from start to end, drag the video frames representing the video regions.

💡 If the Edit window does not display the selected video regions, it will automatically scroll to show the beginning of the selection.
Selecting Zoom Resolutions and Ranges Simultaneously in the Video Universe

When you move the cursor over a video frame in the Video Universe while pressing Alt (Windows) or Option (Mac), the cursor appears as a selector tool. This tool lets you zoom and select ranges simultaneously.

To use the Video Universe window to select and zoom simultaneously in the Edit window:
1. Move the cursor over any area of any video frame in the Video Universe window until it becomes a selector or zoom tool.
2. To select a range of video regions while simultaneously zooming to fill the Edit window, Alt-drag (Windows) or Option-drag (Mac) multiple video frames.

Playback of HD QuickTime Movies

Pro Tools 7.2 with QuickTime 7.1.2 lets you import and play back QuickTime High-Definition video files.

When playing HD video through an Avid video peripheral or other device locked to a standard-definition video reference (such as a black burst generator), the display updates at the frame rate of the video reference.

Setting Session Time Code Rate for HD QuickTime Movie Import

When playing back QuickTime movies with frame rates higher than 30 fps, Pro Tools syncs properly only if the Time Code Rate in the Session Setup window is set to half of the video frame rate of the video files.

For example, to properly play back a QuickTime HD movie at 59.94 fps, you would have to change the session’s Time Code Rate to 29.97 frames per second.

To set the session’s Time Code Rate:
1. Choose Setup > Session.
2. In the Session Setup window, select the appropriate time code rate in the Time Code Rate pop-up menu.

FireWire Playback of QuickTime DV Movies

With the addition of an external DV transcoder (decoder), you can play QuickTime DV25 movies out through your computer’s Firewire port. These can include QuickTime movies exported as QuickTime DV from Avid.

When playing DV movies via FireWire on Mac, best performance is achieved by using a dedicated video-only hard drive.

Avid video peripherals support most QuickTime movie formats.

For the latest compatibility information on Firewire transcoders, see the Digidesign Web site (www.digidesign.com).
QuickTime DV25 performance may vary, depending on the specifics of your system and projects.

**Supported QuickTime Movies**

**Referenced and Consolidated Media** QuickTime DV movies can be either complete Quicktime files (where media is copied into a Quicktime file) or Quicktime reference files (where just a small composition is in the Quicktime file which references the original DV files).

**Codec Requirements** When exporting from Avid, always use the Apple DV codec. Do not enable “Use Avid Codec” in the export dialog. If an Avid-codec DV movie is imported into Pro Tools, you will not be able to play it.

**DV Stream Movies** Pro Tools does not support audio from a DV Stream file. DV Stream files contain the entire data stream that’s been transferred or recorded over the FireWire cable from a camera. In this type of file, the audio and video data are stored in an interleaved fashion, as opposed to a QuickTime file where audio and video are stored separately.

See also “Exporting QuickTime DV from Avid” on page 670.

To Play QuickTime DV Movies through the FireWire Port:

1. Import a QuickTime DV movie into a Pro Tools session. (See “Importing Video into Pro Tools” on page 657 for detailed information.)

2. Choose Options > Video Out Firewire.

When this item is enabled, Pro Tools will play DV movies (NTSC or PAL) out the FireWire port to an external DV decoder. This can improve system performance by removing the need for the movie to be decompressed by the CPU and displayed on the computer screen.

If the Video window is open when video is playing out the FireWire port, it will display text indicating that video is playing out the FireWire port.

**Compensating for Video Monitoring Delays**

You can compensate for delays in the video output that may be introduced by external decoders and certain types of displays.

To compensate for delays caused by video monitoring devices:

1. Choose Setup > Video Sync Offset.

2. In the Set Video Sync Offset dialog, enter a value in the QuickTime Video Offset field that is appropriate to compensate for the delay caused by your video monitor chain. The amount of delay introduced varies based on your system and the type of video peripheral you are using. When using an Avid peripheral with QuickTime, 18 quarter-frames is a good starting point, but you will need to verify the precise setting for your system. (Third-party devices are available to help you measure this delay.)
Once this value is set, it should not need to be updated unless you change components in your video monitoring chain (such as projectors or plasma screens).

Exporting QuickTime DV from Avid

The following instructions list export settings for Avid Xpress Pro. These settings are required to create QuickTime DV movies that can be played back in Pro Tools through the Firewire port.

To export a QuickTime DV reference movie for Pro Tools Firewire playback, set the following:

1. Enable the following export options:
   • Flatten video tracks
   • Fill in spaces with black
   • Render all video effects
   • Use Apple DV Codec
   • Enable the Apple DV codec

2. Make sure Use Avid Codec is not enabled.

These export settings can be saved in Avid Xpress Pro as a default, simplifying future media exchange. Refer to your Avid XPress documentation for more information on export settings and defaults.

Tips for Optimizing Movie Playback

When using Pro Tools to play QuickTime movies (without an Avid video peripheral), the quality of the playback is dependent on the speed of your computer and hard drive, the size (in pixels) of the movie, and the quality of the video hardware used to capture and play back the digitized video.

For more consistently smooth movie playback, here are some suggestions:

◆ Use a supported Avid video peripheral.
◆ Use the fastest computer possible.
◆ Disable the Automation preference for Faders Move During Playback.
◆ Set Scrolling option to None (Options > Scrolling > None).
◆ Reduce the size of the Edit window to the smallest possible size.
◆ Close unnecessary windows.
◆ Reduce the overall length of the SCSI chain of your computer system for improved throughput.
◆ Reduce the pixel size of the movie (for example, reduce it from 640 x 480 pixels to 320 x 240 pixels).
◆ Hide the video track when not needed.
Bouncing the Video Track to a QuickTime Movie

When you have finished your final mix and synchronized your audio events to the movie, Pro Tools with QuickTime 7.1.1 or later lets you bounce the main video track (QuickTime or Avid video) and a mono or stereo mixdown of your session to a new QuickTime movie. As a QuickTime file, the new movie is supported by all software applications that support QuickTime video.

You can choose from a variety of standard QuickTime codecs, which are fully compatible with other QuickTime applications.

⚠️ Because all formats and codecs have not been tested, you should verify the QuickTime movie bounced successfully.

⚠️ Pro Tools cannot bounce audio or video to an MPEG-2 video file.

To bounce video and audio in the video track to a QuickTime movie:

1. Finalize your mix.
2. Make sure the video track you want to bounce is currently the main video track. (The track’s Video Online button must be highlighted blue.)
3. Make sure that all of the audio tracks you want to include in the bounce are audible (not muted or inactive).
4. Assign the output of each of the tracks you want to include in your bounce to the same stereo output or bus path.
5. Do one of the following:
   - To bounce the entire session, click Return to Zero in the Transport window to go to the beginning of the session.
   - or –
   - To bounce a portion of the session, enable Options > Link Timeline and Edit Selection, and make a selection in the Edit window.
6. Choose File > Bounce to > QuickTime Movie.
   The Bounce dialog appears (if you are bouncing QuickTime movies) or the Bounce to QuickTime dialog appears (if you are bouncing Avid video to QuickTime movies).
7. Select your mix’s output or bus path from the Bounce Source selector.
8. If you are bouncing Avid to QuickTime and you want to configure QuickTime video settings, click Options.
9. Configure other settings as appropriate.
10. Click Bounce.
11. Select a destination for the new QuickTime movie, enter a new name, and click Save.

Bouncing video may take quite a bit longer than real-time, depending on the format of the source video, the format of the bounced video, and processing speed.
Chapter 30: Working with Synchronization

Synchronization allows one system to output time code and the other device to follow that time code. Pro Tools is synchronized to other devices using SMPTE/EBU time code or MIDI Time Code. For more information on different SMPTE/EBU formats, and other concepts related to time code, refer to the Pro Tools Sync & Surround Concepts Guide.

Pro Tools Synchronization Options

There are several options for synchronizing Pro Tools to an external source or using Pro Tools as the master device. Not all options are available on all Pro Tools systems, as noted.

SMPTE Trigger Only

This solution is useful for short projects if both systems are extremely close in speed, but even the best systems will rarely stay perfectly synchronized for longer than a couple of minutes.

SMPTE Trigger Resolved with SYNC I/O

(Pro Tools HD Only)

You can use the optional SYNC I/O, or an equivalent third-party device to resolve Pro Tools recording and playback speed with any of the following clock reference sources while slaving Pro Tools to time code:
- LTC
- Video source
- House video reference
- VITC
- 1x Word Clock
- AES/EBU “null” clock
- Pilot Tone
- Bi-Phase

This enables long-term, high-fidelity synchronization when all transports within the system are resolved to this common synchronization source, or by resolving to any variations in incoming time code while slaving to time code.

SMPTE Trigger while Locking to an Unresolved Source

SMPTE Trigger can be used with the optional SYNC I/O or equivalent device to resolve Pro Tools recording and playback speed while slaving to LTC. This enables long-term, accurate
synchronization by resolving to any variations in incoming time code. The SYNC I/O also supports VITC and Bi-phase/Tach positional reference.

**Stable LTC Source**

When locking Pro Tools to a stable time code source (such as an LTC generator), enable the Stable LTC Source preference. When selected, this option suppresses the normal 1-second wait time before Pro Tools attempts to lock to incoming LTC. Be sure to disable this option when locking to tape machines.

**SYNC I/O Synchronization Options**

By adding the SYNC I/O to your Pro Tools|HD system, you can use Pro Tools as the master device in your synchronization setup. All other devices are then slaved to Pro Tools.

You can use Pro Tools in conjunction with SYNC I/O to generate LTC, MIDI Time Code, or MMC commands. When SYNC I/O is reading incoming SMPTE time code, it regenerates the time code through the LTC or MTC output connector. This signal can be passed along to other slave devices.

**MachineControl™**

The SYNC I/O also supports Digidesign MachineControl software, which provides many specialized features for post-production synchronization tasks including remote track arming, VTR emulation, serial time code, and other capabilities. (See the MachineControl Guide for more information, or contact your Digidesign dealer.)

*For instructions on connecting an external synchronization peripheral to your Pro Tools system, refer to your Getting Started Guide. If you are using SYNC I/O, refer to your SYNC I/O documentation.*

**Ext. Clock Output**

Pro Tools can be used as the master device in your synchronization setup, where all other devices are then slaved to Pro Tools word clock output.

With Pro Tools|HD systems, clock output can be configured for 1x word clock, or 256x Slave Clock for Digidesign Legacy I/Os (such as 888|24 I/O). See the Pro Tools|HD Getting Started Guide for more information on clock output and Legacy I/Os.

**To set Ext. Clock Output:**

2. Click the Ext. Clock Output pop-up menu and select an available signal.
3. Click OK to close the Hardware Setup dialog when you have finished.

If the Legacy Port is enabled (as opposed to the Expansion Port) then the Ext. Clock Output automatically switches to Slave256x. To reset the Ext. Clock Output, the Port Settings button must be set back to Expansion and the Legacy I/O must be set to No Interface. (To set a Legacy I/O to No Interface, select its name in the Peripherals list, then choose No Interface from the Interface pop-up menu.)
Session Setup Window

The Session Setup window lets you configure various time code-related settings on your system. The window also includes display-only areas for session sample rate, file format, and bit depth.

*Pro Tools LE systems with DV Toolkit 2 support various time code-related settings (such as Time Code and Feet+Frame Timebase rulers). For a complete list, refer to the DV Toolkit 2 for Pro Tools LE Guide.*

To show the Session Setup window:
- From a Pro Tools session, choose Setup > Session.

To expand SYNC Setup & Session Offset section:
- Click the SYNC Setup & Session Offsets expand/collapse triangle.

The controls in this section configure settings of the Digidesign SYNC I/O. Settings are provided for Clock and Positional Reference, Video Format, and Variable Speed Override.

To show Time Code Settings section:
- Click the Time Code Settings expand/collapse triangle.

The controls in this section provide time code generation and freewheel options, and separate pull up and down selectors for audio and video rates.

---

![Session Setup window with SYNC I/O](image-url)

**Figure 30. Session Setup window with SYNC I/O**
**Session Displays and Settings**

**Sample Rate**
This display indicates the sample rate for the current session.

**Bit Depth**
This display indicates the bit depth for the current session.

**Audio Format**
This display indicates the file format for files recorded in the session.

**Mac<>PC**
This display indicates whether Pro Tools is set to create sessions and audio files that are usable on both Windows and Mac.

**Clock Source (Sync Mode)**
Use this menu to configure the system Clock Source. You can choose between a SYNC I/O, an internal clock source from a digidesign card or peripheral, or an external clock source connected to a Pro Tools|HD audio interface.

> Changes made to Clock Source in the Hardware Setup dialog will be reflected in the Session Setup window and vice versa.

**Clock Source Options**

**SYNC I/O** When using a Digidesign SYNC I/O, Pro Tools receives its clock source from the SYNC I/O, and the SYNC I/O can in turn reference an external clock source listed in the SYNC Setup selector.

**Internal Mode** In Internal mode, your system will reference your Digidesign card or peripheral’s quartz crystal oscillator and play back at the session’s sample rate.

**External Clock Sources** Depending on your Pro Tools|HD audio interface, external Clock Source options can include AES/EBU [Encl.], S/PDIF, Optical [Encl.], AES/EBU 1-8, TDIF, ADAT, and Word Clock (optional word clock rates are available at higher frequencies). External sources can be 1x any sample rate or the “base” rate. Base rate equals 44.1 kHz for 88.2 and 176.4 kHz; 48 kHz for 96 and 192 kHz. If an external source is chosen, and no valid sync clock is detected at the External Clock In, the I/O will return to Internal mode.

> If SYNC I/O is enabled in the Peripherals dialog, and is correctly connected in the Loop Sync chain, SYNC I/O can be the Loop Master, and Pro Tools|HD audio interfaces will clock as Loop Sync slaves.

> For more information on external clock sources, see the SYNC I/O Guide.

**System Delay**
This display indicates the total amount of system delay (in samples) caused by plug-ins and mixer routing.

**Fader Gain**
This display indicates the maximum fader gain level for the session.

**Session Start**
Use this field to specify a SMPTE start frame location for your session. See “Setting a SMPTE Session Start Time (Start Frame)” on page 680.
Incoming Time (Current Time)
This display indicates incoming time code.

Time Code Rate
This pop-up menu lets you set the SMPTE time code rate for the current session.

Feet+Frame Rate
Feet+Frame rates for sessions can be set with the Feet+Frame Rate selector. Supported rates are 23.976, 24, and 25 fps.

Set this rate to match the rate of the film projector, or the video if the film projector speed is taken into account. For example, doing a Telecine transfer from a 24 fps film projector to NTSC video would necessitate the projector running at 23.976 fps. This is regardless of whether the session is using pull down audio or not.

SYNC Setup Settings
(Pro Tools HD Only)
The controls in the SYNC Setup section let you configure SYNC I/O settings, including clock reference, positional reference, video format, and VSO.

These controls are grouped in the Synchronization Settings section.

Clock Reference
This menu lets you set the Pro Tools clock reference.

When using a Digidesign SYNC I/O, the Clock Reference selector lists all supported clock types for the Digidesign synchronization interface.

When using Pro Tools|HD systems without a SYNC I/O, choices include any currently-enabled digital format or source available from your Pro Tools|HD I/O (such as AES, S/PDIF, or 1x Word arriving at the Pro Tools|HD interface’s Word Clock In port).

Positional Reference
Use this menu to set the time code source for Pro Tools to use for positional reference.

Video Format
Use this menu to set the session for NTSC or PAL format.

Variable Speed Override (VSO)
Variable Speed Override (VSO) requires a SYNC I/O.

When a SYNC I/O is connected to a Pro Tools|HD system, the VSO controls are located in the SYNC Settings section of the Session Setup window.

These controls are located in the SYNC Setup window.

Locked Indicator
The Locked indicator stays lit when the SYNC I/O is locked to the selected clock reference. The Locked Indicator flashes if the selected clock reference source is missing or out of lockable frequency range.

Refer to the SYNC I/O Guide for instructions on using VSO to varispeed Pro Tools playback.
**Speed Cal Indicator**

This indicator provides the accuracy of the incoming clock reference. The Speed Cal indicator is lit when the output frequency is within 200 ppm (0.02%) of the selected sample rate. The Speed Cal indicator turns off when the output sample rate is not at the expected (or target) rate.

**External Time Code Offsets**

In the External Time Code Offsets section, Pro Tools lets you compensate for devices that are consistently offset by a fixed number of frames (such as some color-corrected video masters), or for material that starts at a different time than the session.

Pro Tools provides three different types of Session Start Time Code Offset settings. These offsets include:

- MMC (MIDI Machine Control)
- 9-Pin (Serial machine control)
- Synchronization peripherals (such as the SYNC I/O, or a MIDI interface that provide MIDI Time Code).

Positive and negative offset values can be entered to offset Pro Tools time code display later or earlier, respectively.

Unique values can be defined for each of these three types offsets, or you can link all three to adjust in unison.

If you are using Digidesign’s MachineControl option, additional options for External Time Code Offsets are available. See the *MachineControl Guide* for more information.

**Time Code Settings**

The Time Code Settings section provides generator, freewheel, and pull up/down options.

These controls are located in the Time Code Settings section of the Session Setup window. Click the Time Code Settings expand/collapse triangle to show or hide these controls.

**Generator**

The Generator lets you enable Pro Tools generation and output of LTC and MTC using the SYNC I/O. For more information, see “Generating Time Code” on page 686.

**Using SYNC** This option outputs time code from the Device type selected in the Synchronization page of the Peripherals dialog.

**MTC to Port** When enabled, outputs MIDI Time Code to the MIDI destination selected in the pop-up menu. In Pro Tools on Windows, choices appear as they are in your MSS (MIDI Studio Setup) profile. In Pro Tools on Mac, choices are based on your AMS (Audio MIDI Setup) profile.

**Freewheel**

The choices in the Freewheel section let you configure how Pro Tools will freewheel, or continue playback if time code is interrupted or corrupted. Use these options to protect against errors that can occur if your SMPTE time code source has “drop outs” or temporary lost signals.

**None** No freewheel is applied.

**Frames** Sets a number of frames to freewheel, from 1 to 120 frames. This value defaults to 8 frames, which is the recommended setting for most applications.
Jam Sync Lets Pro Tools trigger synchronization to incoming time code, and continue to play back even if time code input is completely interrupted. It can be useful if time code is damaged, or has been accidentally erased from your source tape.

Pull Up/Down
When Pro Tools is used in conjunction with a SYNC I/O, or a third party peripheral or synchronizer that supports pulled sample rates, this option allows you to “pull up” or “pull down” the current sample rate.

For general information, see the Pro Tools Sync & Surround Concepts Guide. For more information on applying pull factors in Pro Tools, see “Pull Up and Pull Down” on page 682.

\[ \text{Remember, pull up and pull down are applied differently in different workflows. Make sure you check each project’s specific workflow before you begin your work.} \]

Time Code Reader Offset (Sync Offset)
This field lets you set a trigger offset for incoming MIDI Time Code (anywhere from –100000 to +100000 samples). This allows you to create a permanent offset to fine-tune the point at which Pro Tools synchronizes relative to incoming time code. For example, a value of –50 makes an event in Pro Tools occur 50 samples before the same event in the incoming MIDI Time Code. Use this to compensate for timing differences between various SMPTE-to-MIDI Time Code converters or analog-to-digital/digital-to-analog converters.

Preparing to Work with SMPTE
The first step when preparing to work with SMPTE is to choose an appropriate SMPTE frame rate. Pro Tools supports all standard SMPTE frame rates. If you are working with SMPTE striped tape, it is important to know the frame rate. In some cases, the SYNC I/O can be used to do this (see the SYNC I/O Guide).

For a full explanation of SMPTE frame rates, see the Pro Tools Sync & Surround Concepts Guide.

Configuring Pro Tools for SMPTE
Synchronization and MachineControl system settings are enabled in the Pro Tools Peripherals dialog. These settings are system settings, and remain constant regardless of the particular session you are working on. Configure these settings before opening a session.

\[ \text{MachineControl is supported on Pro Tools|HD systems only.} \]

Other settings are configured in the Session Setup window, such as the session Time Code rate, the Feet+Frames rate, the session start frame, and time display format. These settings are session-specific settings. These settings can only be configured when a session is open.
Selecting a SMPTE Format

To choose a SMPTE format:
1. In Pro Tools, choose Setup > Session.
2. Choose a frame rate (SMPTE format) from the Time Code Rate selector.
3. Enter the Time Code Freewheel frames (if any) in the designated box. See “Freewheel” on page 678 for more information.

Setting a SMPTE Session Start Time (Start Frame)

The Session Setup window also allows you to set a SMPTE Start Frame for your session. Video work tapes are rarely striped beginning at a SMPTE frame address of 00:00:00:00. You can quickly enter a start time for your session based on an appropriate frame number from your project tape. The Pro Tools SMPTE-related functions (such as Spot mode) will then use this value as their reference for the session’s start point.

Start Time When Stripping Tape

If you are generating time code, it is a good practice to stripe your time code beginning at 01:00:00:00 (subtracting time for initial black, bars and tone, or logos). This prevents problems that can occur with some synchronizers when the striped time code crosses from 23:59:59:29 to 00:00:00:00 (commonly referred to as the “midnight” boundary).

To set a SMPTE Start Time for your session:
1. Choose Setup > Session.
2. Enter a SMPTE frame number in the Session Start field.

To capture an incoming SMPTE address as the session start time:
1. Click in the Session Start field.
2. Begin playback of the time code source.
3. At the desired location, press Equal (=) in the numeric keypad.
4. Press Enter to accept the value. You can then edit the captured address. The session uses the frame number you enter as its SMPTE start frame when online.

If there are existing regions on the tracks and you are changing the original SMPTE start frame to a later time (from 00:00:00:00 to 01:00:00:00, for example), all existing regions on tracks will remain in their relative positions, but will start later by the time value added to the start frame.

5. If you are changing the session start time in an open session in which tracks already exist, a warning dialog appears after Session Setup window. Choose from one of two options:

Maintain Time Code Places the additional session time at the start of the session, and keeps existing regions in their original time code locations.

Maintain Relative Position Places the additional session time at the start of the session, and maintains the relative position of existing regions to the new start frame. For example, if you change the session start frame from 01:00:00:00 to 00:59:00:00, Pro Tools adds one minute of session time to accommodate the new start frame, and moves all existing regions earlier in time to maintain their relative position to the start frame.
Redefining a Time Code Position

Use this command to redefine the current time code position and session start time. By creating an insertion point (or selection), and then entering the desired new time code position for that location, the session start time will be recalculated based on the new, relative Time Code location.

To redefine a current Time Code code position:
1. With the Selector tool, click in a track (or make a selection) where you want to redefine the position.

⚠️ If your insertion or selection is not on a grid boundary, it will round to the closest boundary.


3. Enter a new SMPTE frame number in the dialog to correspond to the time code shown in the dialog.

4. Click OK.

Redefining a Feet+Frame Position

(Pro Tools HD and Pro Tools LE with DV Toolkit 2 Only)

Use this command to redefine the current Feet+Frames position. By creating an insertion point (or selection), and then entering the desired new Feet+Frames position for that location, the session start time is recalculated based on the new, relative Feet+Frames location.

Typically, this command is used for integrating test tones, pre-roll, Academy leader, and similar pre-program material into Pro Tools sessions.

To set a relative frame position for a session (Feet+Frames):
1. With the Selector tool, click in a track (or make a selection) where you want to redefine the position.

⚠️ If your insertion or selection is not on a grid boundary, it will round to the closest boundary.


3. Enter a Feet+Frame position to correspond to the time code shown in the dialog.

4. Click OK.
Displaying Time in SMPTE Frames
(Pro Tools HD and Pro Tools LE with DV Toolkit 2 Only)

In Pro Tools, you can set the Main Time Scale to Time Code (SMPTE) and this will be displayed in the Main Counter. Though Pro Tools will still synchronize to incoming SMPTE time code if the Time Scale is displayed in Bars:Beats, Minutes:Seconds, or Feet:Frames, it is usually more useful to use SMPTE time code as your reference.

To set the Main Time Scale to SMPTE Time Code, do one of the following:

- Choose View > Rulers > Time Code.
- or –
- Click the Main Counter selector in the Edit window and select Time Code.

Pro Tools will display time code values in the currently selected SMPTE frame rate.

Sub Counter and Sub Time Scale Display

You can display a Sub Time Scale in the Sub Counter. For example, if the Main Time Scale is set to Time Code, and you want to compare SMPTE time to “wall clock,” when you are using 29.97 Non-Drop frame rate, click the Sub Counter selector and select Min:Secs as the Sub Time Scale.

Pull Up and Pull Down

Pro Tools supports up to 4% pull up and pull down, with support for an additional 0.1% up or down. Separate rates can be set for session audio and video (when video has been imported or captured into the session).

When referring to 4% pull up and pull down, the precise percentages used in pull ups is 4.167%. See Table 31 on page 684.

While the SYNC I/O is not required in order to use the extended pull up and down options provided in Pro Tools, the SYNC I/O is the only device that can be controlled from within Pro Tools, and that recalls and restores pull factors automatically when a session opens. Other synchronization peripherals must be configured manually.

Tip: Pull up and down settings do not affect time code generated by the SYNC I/O.

Configuring Pull Up and Pull Down

To pull up or pull down audio or video:

1. Choose Setup > Session.
2. From the Time Code Settings section of the Session Setup window, select a Pull Up/Down Rate.

Audio Rate Pull Up/Down Controls audio sample rate. See “Audio Sample Rate Pull Up and Down” on page 684.
**Video Rate Pull Up/Down** Controls video rate. See “Video Rate Pull Up and Down” on page 685.

The choices available in these menus are determined by the session frame rate. Combinations can be applied by choosing from both menus.

4% pull factors are not available in 176.4 and 192 kHz sessions.

The choices available in these menus are also determined by the Preferences and Auto Match Pull Factors settings in the Time Code Rate menu. See “Extended Pull Up and Pull Down” on page 683 and “Auto Match Pull Factors” on page 683.

**Extended Pull Up and Pull Down**

### Preference and Session Setup Controls

The Audio Rate Pull Up and Down menu offers all possible combinations of pull ups and pull downs for the audio sample rate, regardless of the session frame rate.

In addition, if there is a QuickTime video clip in the timeline, the video rate can be pulled up or down by 0.1%, regardless of the session frame rate. Though not an approved workflow, earlier versions of Pro Tools also enabled pull down of QuickTime video clips when audio was pulled down, so this option is included in Pro Tools 5.3.1 and higher to maintain compatibility with earlier sessions.

### Auto Match Pull Factors

Auto Match Pull Factors is available from the session Time Code Rate menu in the Session Setup window. When Auto Match Pull Factors is enabled, Pro Tools adjusts audio and video playback rates as needed to match any changes to the current session Time Code Rate. 

Auto Match Pull is applied relative to the current pull up setting. While enabled, if the session frame rate is changed in such a way that the video would have to be pulled by an unsupported amount, the video remains unaffected.

This setting is latching, is not enabled by default, and its state is stored with the session.

**Example of Auto Match Pull Factors**

Auto Match Pull Factors links audio and video pull factors when changing session frame rate.

For example, assume a Pro Tools session is set to a frame rate of 25 fps, the audio and video are both playing with no pull ups, and Auto Match Pull Factors is enabled.

If you then change the session Frame Rate to 24 fps, both the Audio and Video Rate Pull settings would change by –4.0% (the appropriate pull setting required by the change in frame rate).

Auto Match-enabled pull factors are applied to any existing Audio Rate Pull Up/Down or Video Rate Pull Up/Down settings. For example, if audio was already being pulled –0.1% when you changed the session Frame Rate from 29.97 to 24 fps, then the Audio Rate Pull Up/Down menu would switch to None.
Audio Sample Rate Pull Up and Down

The Audio Rate Pull/Down menu applies pull up or down factors to session audio record and playback. All pull rates are available, regardless of session frame rate.

See also “Auto Match Pull Factors” on page 683.

Audio Rates and Pull Up/Down Options

Table 31 lists actual sample rates of each pull up and pull down option and combination (rounded to the nearest whole Hz):

<table>
<thead>
<tr>
<th>Pull Up/Down</th>
<th>Sample Rate</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>44100</td>
</tr>
<tr>
<td>+4.1667%</td>
<td>45983</td>
</tr>
<tr>
<td>and +0.1%</td>
<td></td>
</tr>
<tr>
<td>+4.1667%</td>
<td>45938</td>
</tr>
<tr>
<td>and –0.1%</td>
<td>45892</td>
</tr>
<tr>
<td>+0.1%</td>
<td>44144</td>
</tr>
<tr>
<td>–0.1%</td>
<td>44056</td>
</tr>
<tr>
<td>–4.0% and +0.1%</td>
<td>42378</td>
</tr>
<tr>
<td>–4.0%</td>
<td>42336</td>
</tr>
<tr>
<td>–4.0% and –0.1%</td>
<td>42294</td>
</tr>
</tbody>
</table>
Video Rate Pull Up and Down

The Video Pull Up/Down selector lets you change the frame rate of video playback independently from the audio pull-ups (if any). It is located below the Audio Rate Pull Up/Down menu in the Session Setup window.

![Video Rate Pull Up/Down menu in Session Setup](image)

Video pull rates are saved with the session.

See also “Auto Match Pull Factors” on page 683.

The choices available in the Video Rate Pull Up/Down menu depend on the file format of the video clip, as well as its frame rate. The following table shows the pull ups available for Avid video clips, both interlaced and Progressive Scan.

### Video Frame Rates and Pull Options

<table>
<thead>
<tr>
<th>Format and Video Frame Rate</th>
<th>Available Video Pull Rate</th>
<th>To synchronize with</th>
</tr>
</thead>
<tbody>
<tr>
<td>Avid Video</td>
<td></td>
<td></td>
</tr>
<tr>
<td>24 fps</td>
<td>None</td>
<td></td>
</tr>
<tr>
<td></td>
<td>−0.1%</td>
<td>29.97 NTSC videotape</td>
</tr>
<tr>
<td></td>
<td>+4.167%</td>
<td>25 fps PAL videotape</td>
</tr>
<tr>
<td>25 fps</td>
<td>None</td>
<td></td>
</tr>
<tr>
<td></td>
<td>−4.0%</td>
<td>24 fps</td>
</tr>
<tr>
<td></td>
<td>+4.167%</td>
<td>29.97 NTSC videotape</td>
</tr>
<tr>
<td>29.97</td>
<td>None</td>
<td></td>
</tr>
</tbody>
</table>

No Video Recording with Pull Ups
(Avid Video Peripheral Required)

Video may not be recorded to the timeline if a video pull up is selected. If the video track is record-enabled while video pull ups are enabled, or if you attempt to set a video pull up rate while the video track is record-enabled, Pro Tools will post a dialog and disallow video recording. To proceed with digitization, reset the Video Rate Pull Up menu to None.

What is Pulled Up or Down?

The following sections describe how related Pro Tools features are affected by pull up and down rates.

**Time Code Ruler**

Video pull up and down does not affect the Time Code ruler. Be sure to set the session Frame Rate to the correct frame rate for your project. For example, if working with 24 fps video and you pull the video up by 4%, switch the session Frame Rate to 25 fps to keep the Time Code ruler aligned. Similarly, if working with 24 fps video that is pulled down by 0.1%, switch the frame rate of the session to 29.97.

When working with 25 fps Avid media and the video is set to pull down by 4%, set the session Frame Rate to 24 fps.

**Plug-ins**

For proper operation at larger (4%) pull rates, plug-ins must utilize sample clock instead of an absolute time clock. All Digidesign plug-ins are based on sample clock.

**Higher Sample Rates and Pull Factors**

4% audio pull rates are not available in 176.4 and 192 kHz sample rates sessions.
**Putting Pro Tools Online**

To trigger playback or recording from an external source, the Pro Tools Transport must be placed *online*. This tells Pro Tools to listen for incoming time code.

**To put the Pro Tools Transport online, do one of the following:**
- Choose Options > Transport Online.
- Click the Online button at the far left of the Transport.
- Press Control+J (Windows) or Command+J (Mac).

The Online button flashes while Pro Tools waits for a SMPTE frame to trigger playback. When time code is received, playback begins and the Online button becomes highlighted. The Edit Selection indicators in the Edit window, and the Incoming Time field in the Session Setup window display the incoming time code.

**To take Pro Tools offline, do one of the following:**
- Deselect Options > Transport Online.
- or –
- Deselect the Online button in the Transport window.

**Recording Online**

The Operation Preferences page contains two options that affect how Pro Tools initiates recording when online.

**Record Online at Time Code (or ADAT) Lock** Makes online recording begin as soon as Pro Tools receives and locks to time code or ADAT sync. In this case, you do not need to make an insertion or selection in a track to designate a start point.

**Record Online At Insertion/Selection** Makes online recording begin wherever you have placed the insertion point in a track. Recording then continues until Pro Tools stops receiving time code. If you make a selection in a track, Pro Tools will record online only for the length of the selection.

**Generating Time Code**

Using SYNC I/O, Pro Tools can generate SMPTE and MIDI Time Code (MTC). You can then make Pro Tools a master synchronization source with other devices slaved to it.

**SYNC I/O cannot generate 30 fps, 24 fps, or 23.976 fps time code while locked to video input or video reference**

The SYNC I/O cannot generate 30 fps, 24 fps, or 23.976 fps time code while it is locked to a video clock signal. If you set Pro Tools to generate 30 fps time code while the SYNC I/O is locked to a video clock signal, the SYNC I/O will actually generate at the NTSC color standard 29.97 fps. Pro Tools can generate time code at non-NTSC frame rates if you use the internal clock or external word clock on the SYNC I/O as a synchronization source.

**To generate time code using SYNC I/O:**

1. Connect the SYNC I/O LTC Out to the SMPTE in connector on the devices you are slaving. If you are slaving a device that recognizes MTC, connect the MTC OUT connector of the SYNC I/O to the MIDI IN connector of the slaved device (MIDI Interface or other).
2. Make sure your SYNC I/O is powered on.
3 Launch Pro Tools, and make sure you have already enabled the SYNC I/O in the Synchronization page of the Peripherals dialog. See the SYNC I/O Guide for more information.

4 Choose Setup > Session, and choose the appropriate frame rate from the Time Code Rate selector.

5 Select SYNC I/O from the Generate selector in the Time Code Settings section of the Session Setup window.

6 Choose a clock reference from the Clock Reference selector. Not all clock choices are available at all sample rates. See “External Clock Sources” on page 676.)

7 Click the Online button on the Transport, then click Play. Pro Tools generates and outputs time code from the SYNC I/O.

---

Using MIDI Machine Control

Pro Tools provides the capability to transmit location information to external devices, and to control their transports, using MIDI Machine Control (MMC).

Controlling External Devices Using MMC

Any device that supports MMC (such as an Alesis ADAT or Tascam DA-88) can be controlled directly from within Pro Tools, with either the device or Pro Tools acting as clock master.

The external devices supported by Pro Tools implement “open loop” communications only. Because of this, while Pro Tools is the Transport Master, any direct operation of the receiving device’s transport will not be communicated back to Pro Tools. Instead, you can use the Transport pop-up to select the external device (MMC in the pop-up) and use the Pro Tools on-screen transport controls to drive the device.

Pro Tools does not support remote track arming of MMC-controlled external devices. You need to manually arm tracks for recording on the external device.

Digidesign’s MachineControl option supports remote track arming for Sony 9-pin and V-LAN enabled devices. See “Remote Track Arming” on page 690.

Windows

Pro Tools on Windows uses your Multimedia Setup to determine which MIDI devices are available, and what their properties are. Refer to your device’s installation and usage documentation to properly configure the device.
To enable MIDI Machine Control:

1. Choose Setup > Peripherals, then click the Synchronization tab.

2. Select your synchronization peripheral from the Synchronization/Device pop-up menu. If you are using a MIDI interface, select “Generic MTC Reader.” If using SYNC I/O, set the Port to DigiSerial.

3. Select the appropriate port for synchronization information. This is the port to which your synchronization peripheral is attached.

4. Click the Machine Control tab in the Peripherals dialog.

5. In the MIDI Machine Control section, enable MMC.

6. Select your external device from the Send To pop-up menu.

The port on which this information will be transmitted is set in the “ID” field. MMC commands contain an ID number to identify which machine should respond to the MMC command. There are 128 MMC ID numbers, from 0–127. The default of ID #127 is a special setting that broadcasts to all 128 MMC IDs. With this setting, any device on the specified port will respond to MMC commands.

7. Set a pre-roll time for your MMC device. Pre-roll is needed to provide Pro Tools with sufficient time to lock to the incoming time code. This value will vary depending on the external device. If the pre-roll time is insufficient, Pro Tools may not be ready to lock until after the current time code position has passed.

8. Click OK to close the Peripherals dialog. Pro Tools will now be able to control the selected device’s transport.

Operating the Pro Tools Transport with MMC

You can use the Pro Tools Transport window as the remote controller for all your enabled devices (MMC units, ADAT, or a nonlinear video deck). To do so, set the enabled devices to listen to the address you enter for MMC. The Transport window will then “drive” Pro Tools transport and any slaved devices.

You can also configure a “Pro Tools master,” which can “drive” other devices (as needed), and to which Pro Tools will chase (slaving Pro Tools).
To control external devices from the Pro Tools Transport Master:

- Select either Pro Tools or MMC from the Transport pop-up in the Pro Tools Transport window. The selected item will act as Transport Master.

When the Transport Master is set to Pro Tools, the playback position is governed by the on-screen cursor in Pro Tools.

When the Transport Master is set to MMC, the playback position is governed by the external device's play position.

For more information, see “Recording from MIDI Devices” on page 215.

**MMC Transport Settings**

When using MMC, you can set the following options for machine transport behavior in the Operation Preferences page.

**Machine Chases Memory Location** With this option enabled, navigating to a specific location in a session with a Memory Location causes a connected transport to chase to that location.

**Machine Follows Edit Insertion/Scrub** With this option enabled, navigating to a specific location in a session by moving the selection point or by scrubbing a track causes a connected transport to chase to that location.

**Taking a Device Offline**

Use the Online pop-up menu in the Transport Master selector to take a MIDI (or Machine) device offline.

**To take a device offline:**

1. Click the Transport Master selector.
2. Click on the Online pop-up menu and deselect the device (Machine or MIDI) by clicking on it. Device choices depend on the current Transport Master and which devices have been set up in Pro Tools.

To bring a device back online, click and reselect it in the Online pop-up menu.

**Deselecting a device to take it offline**

The Online pop-up menu will only display devices that have been properly set up in Pro Tools.

*To set up MIDI devices, see “Enabling MIDI Machine Control in Pro Tools” on page 688.*

*To set up machine devices, see the Machine-Control Guide.*
Setting Minimum Sync Delay

Lock-up time delay is the amount of time your system’s devices need to achieve synchronization “lock.” This amount varies for each device. Pro Tools lock up delay is set by entering a value for Minimum Sync Delay in the Synchronization window of the Peripherals dialog. The lowest value available is 15 frames. Find the shortest possible lock-up time that your equipment can operate at consistently, and set this as the Minimum Sync Delay. On systems utilizing Digidesign MachineControl, enabling the Use Serial Time Code setting will make machines lock up much faster. (Serial time code requires both the SYNC I/O and external devices to be locked to house video reference.)

To set a Minimum Sync Delay:

1. Choose Setup > Peripherals, and click the Synchronization tab.
2. Enter a number of frames in the Minimum Sync Delay field.
3. Click OK to close the Peripherals dialog.

Configuring Minimum Sync Delay for External MMC Devices Locked to House Sync

When controlling a house-synced device from Pro Tools through MMC, the device will first lock to the MMC location and then align the color framing. Within house sync code are 4 frames for ensuring color frame lock. If the minimum synchronization setup time is less than the time required to achieve both location and color frame lock, playback will begin before the device has aligned the color frames. In this scenario, you should set the Minimum Sync Delay to be more than the time required for color frame lock. This is not a problem with the SYNC I/O, which will drop out of lock until the color frame is locked.

Remote Track Arming

Digidesign’s MachineControl™ option for Pro Tools allows you to remotely arm tracks on supported 9-pin (or V-LAN for transport only) decks. Without MachineControl, Pro Tools does not support remote track arming of external devices. MachineControl lets Pro Tools act as the master or slave to external Sony 9-pin (or V-LAN for transport only) machines, in addition to providing remote track arming from within Pro Tools.

Use the Setup > Machine Track Arming Profiles command to configure your system, and then use the Window > Machine Track Arming to display the Machine Track Arming window.

For information on remote track arming with MachineControl and using Pro Tools menu commands dedicated for remote track arming, see the MachineControl Guide.
MIDI Beat Clock

Some MIDI devices such as drum machines, hardware sequencers, and arpeggiators can only synchronize to MIDI Beat Clock. To synchronize these devices to Pro Tools, you can transmit MIDI Beat Clock to them. Many plug-ins also support MIDI Beat Clock.

To transmit MIDI Beat Clock:

1. Choose Setup > MIDI > MIDI Beat Clock.
2. In the MIDI Beat Clock dialog, select the Enable MIDI Beat Clock option.
3. Select the devices you want to receive MIDI Beat Clock. If your MIDI interface does not support transmitting MIDI Beat Clock to separate ports, only the interface appears as a destination.
4. Click OK.

Spotting Regions to SMPTE Frame Locations

(Pro Tools HD and Pro Tools LE with DV Toolkit 2 Only)

Spotting is the process of assigning music and sound cues to specific SMPTE frame locations in a film or video. This function can be used to spot:

- Entire regions, selected with the Time Grabber tool. Multiple regions can also be selected, and Pro Tools will reference the first region in your selection.
- A specific location within a region, by clicking with the Selector tool at that location, and choosing Region > Identify Sync Point.
- Sessions or tracks, dragged from a browser to the session Timeline or Region List.

Spot Mode

In Spot mode, a region in a track can be quickly spotted by simply clicking it with the Time Grabber tool.

You can also drag a region from a DigiBase browser, or from the Region List, to a track while in Spot mode.

The Spot Dialog

The Spot Dialog appears when you drag a region to a track or click a region with the Time Grabber tool in Spot mode. The numeric fields function as both data displays and editing controls for the currently selected regions.
Information in these fields is displayed in SMPTE Time Code, Minutes:Seconds, Feet:Frames, Samples, or Bars & Beats, depending on which Time Scale format is selected.

A highlighted numeric field indicates the current active field for numeric entry editing. Entering a value in a field allows you to move a selected element to the time location that you enter. The Start, Sync Point, and End fields are accessible when the Time Grabber tool is active. Only the Start or End (depending on where you click the mouse) and Duration fields are active when one of the Trim tools is active (see “Using the Trim Tools in Spot Mode” on page 694).

To increase or decrease SMPTE values in the Spot dialog by a specific number of frames, press Plus (+) or Minus (−) on the numeric keypad, enter a number, and press the Enter key.

Use Subframes Option

A subframe is 1/100th of a frame. The Use Subframes option enables you to use these smaller units for greater accuracy. This command adds an additional time field in the SMPTE hours:minutes:seconds:frames box, which appears as the far right time field when enabled. Use a Period (.) to separate subframe values from whole frames.

Additional time field with “Use Subframes” enabled

Subframe measurements are not available in the Current Time field.

Capturing Time Code

Pro Tools also allows you to easily capture frame locations on-the-fly in this dialog by pressing the Equal key, or by clicking the Current Time button while valid time code is being received by Pro Tools. With VITC, you can accurately capture a paused or “crawling” VTR’s SMPTE location.

When Time Code is selected for the Time Scale, pressing the Equal key captures the incoming time code. When Bars:Beats is selected for the Time Scale, pressing the Equal key will capture to the nearest measure.

Although the Capture Time Code button works with free-running Linear Time Code (LTC) or VITC, frame numbers of a paused frame can only be captured with VITC.

The SYNC I/O can read VITC. With Machine-Control and SYNC I/O, you can also read serial time code.

To use Remote mode with MachineControl, you will need an approved serial port. For a complete list of currently approved ports, see www.digidesign.com.
To spot a region to a specific SMPTE frame:

1. Choose Window > Edit.
2. Set the Main Time Scale to Time Code. (See “Setting a SMPTE Session Start Time (Start Frame)” on page 680.)
3. Click the Spot button at the top left of the Edit window to put Pro Tools into Spot mode.
4. Identify the SMPTE frame location where you want to trigger playback of your region by pausing your video deck on that frame.
5. With the Time Grabber tool, click a region in a track, or in the Region List, and drag it into a track. The Spot dialog appears.
6. Enter the SMPTE frame location by doing one of the following:
   - If you are using VITC, you can press the Equal (=) key on the numeric keypad, or click Current Time Code to enter a paused VTR’s current SMPTE location.
   - or –
   - If you are using LTC, when Time Code is selected for the Time Scale, press the Equal (=) key on the numeric keypad to capture the incoming time code. When Bars:Beats is selected for the Time Scale, press the Equal key to capture the nearest measure.
7. If you recorded the region while online, you can use the Original Time Stamp button to recall and enter the SMPTE frame location at which the region was originally recorded. You can also access a user-defined Time Stamp in the same fashion. See “Time Stamping” on page 694 for more information.
8. Click OK to close this dialog. The region spots to the chosen SMPTE frame location. When the session is online, this frame number will trigger playback of the region.

Auto-Spotting Regions

The Pro Tools Auto-Spot Regions option simplifies the task of spotting regions even further. If you are using VITC with this option enabled, or MachineControl software, you can pause your video at an appropriate SMPTE frame location, click a region with the Time Grabber tool, and the region will be automatically spotted to the current time code location.

You can also use MachineControl’s serial time code ability to auto-spot by enabling MachineControl and enabling serial time code in the peripheral.

To Auto-Spot a region:

1. Choose Options > Auto-Spot Regions.
2. If you are using VITC, identify the SMPTE frame location where you want to trigger playback of your region by pausing your video deck on that frame.
3. Click the region with the Time Grabber tool. The region will be automatically spotted to the current time code location (or machine location).

Clicking a region with any of the Trim tools will allow you to trim the region to the current time code location.

Auto-spotted regions are spotted by their start times, unless you have identified a Sync Point (see “Identifying a Synchronization Point” on page 696). If the region contains a Sync Point, the region is spotted to it.
Using the Trim Tools in Spot Mode

You can use the Spot dialog to trim your regions, including start/end/duration times and referencing incoming time code addresses. If you click a region with any of the Trim tools in Spot mode, the Spot dialog will appear, allowing you to enter a value in the Start or End and Duration fields to specify exactly where you want to trim the region’s beginning or end. Use this to edit the length of a region to correspond to a particular visual “hit point.”

Trimming a region that contains a sync point (see “Identifying a Synchronization Point” on page 696) does not affect the SMPTE location of the sync point, unless the region is trimmed past the sync point.

Show Original Time Code in Regions

This command displays the original “time stamped” SMPTE times in all regions currently placed in tracks. This SMPTE frame number represents the time at which the region was originally recorded online with Pro Tools, and does not necessarily reflect the region’s current SMPTE location in a track.

To display Original Time Stamps in regions:
■ Select View > Region > Original Time Stamp.

To hide Original Time Stamps:
■ Select View > Region > No Time.

Creating a User Time Stamp

If you want to create a separate user-defined SMPTE time stamp, you can use the Time Stamp command in the Region List pop-up menu. This command lets you select a region (or regions) and redefine its SMPTE time stamp. The Original Time Stamp and the User-Time Stamp are then stored with your session.

When audio is first recorded, the User Time Stamp will match the Original Time Stamp, but you can change the User Time Stamp at any time using the Time Stamp command. This feature is particularly useful in post production situations where the SMPTE time code on video “work prints” often changes from one edit revision to another.

Time Stamping

Pro Tools time stamps every region recorded online with the original SMPTE time at which audio was recorded. You can recall this original SMPTE time for a region by clicking the Original Time Stamp button in the Spot dialog.

You can also spot a region to a separate user-defined SMPTE time stamp, defined using the Time Stamp command in the Region List pop-up menu. Once the region is time stamped using this command, you can click the User Time Stamp button to re-spot a region to its user-defined SMPTE location.
To time stamp a region (or regions) with a new SMPTE frame number:

1. In a track, select the region that you want to time stamp.
2. From the Region List pop-up menu, choose the Time Stamp command.
3. Enter a new SMPTE time by doing one of the following:
   - Enter the numbers manually (with the help of the arrow keys).
   - Click the Current Time Code button (or press the Equal key), if you want to capture the incoming time code address.
   - Click the Current Selection button, if you want to enter the start time of the current on-screen selection.
4. Click OK to close this dialog.

This command can be used in “batch mode” to set new time stamps for several regions at a time. To do this, simply select several regions and choose the Time Stamp Selected command. One after another, a dialog will open for each region, allowing you to quickly enter new values.

Once entered, the user time stamps can be displayed in all regions currently placed in tracks.

To display User Time Stamps in regions:

- Choose View > Region > User Time Stamp.

To hide User Time Stamps:

- Choose View > Region > No Time.

Pro Tools 5.x and Using a Region with User Time Stamp in Another Session

In Pro Tools 5.x, user time stamp information is saved for each region as part of a session—not as part of the audio file itself. Exporting the region as a file will produce a file that has the time stamp information included in it.

To use a Pro Tools 5.x time-stamped region in another session, and keep its time stamps intact:

1. Open the session that contains the original time-stamped region.
2. In the Region List, select the region you want to export.
3. From the Region List pop-up menu, choose Export Regions as Files.
4. From the Export Selected dialog, configure export options.
   - For more information on Export Selected options, see “Exporting a Region as a New Audio File” on page 151.
5. Click Export to export the new audio file.

The region can now be used in other sessions with its original time stamp references intact.
## Identifying a Synchronization Point

The Pro Tools Identify Sync Point command lets you identify a specific point within a region for audio spotting purposes.

Imagine the following sound effects spotting scenario: You have a single sound effect that consists of a creaky door slamming shut, followed by a few seconds of ambient reverberation. The slam portion of the effect—which you must precisely match to picture—occurs neither at the very beginning of the audio file nor at the very end. It is somewhere in the middle, making it tough to spot. In this scenario, use the Identify Sync Point command to create a point in the region and synchronize that point to a SMPTE frame.

> For more information on Sync Points, see “Sync Points” on page 344.

### To create a sync point in a region:

1. Do one of the following:
   - Click with the Selector tool at the point in the region that you want to synchronize to a SMPTE frame location.
   - or –
   - Press the Down Arrow key while playing back.

2. Choose Region > Identify Sync Point. The current SMPTE time is automatically entered as the SMPTE location for the sync point. A small down arrow appears at the bottom of the region, with a vertical, light grey line indicating the location of the sync point.

## Troubleshooting Synchronization

Getting SMPTE synchronization to work properly can seem like a formidable task at times. The following suggestions may help you troubleshoot and solve common problems.

### Use the Incoming/Current Time Field in the Session Setup Window as a Reference

The Current Time field in the Session Setup window indicates whether or not Pro Tools is receiving time code. If this field appears to be inactive when inputting time code into your time code reading device, check your hardware device settings, the device’s connection to your computer, and your Multimedia Setup (Windows) and AMS (Mac).

> When using MachineControl, the Current Time field will display 9pin code, even though the LTC device may not be connected.
Chapter 30: Working with Synchronization

Stripe SMPTE Before You Record

All tapes in your setup (both audio and video) must be striped with SMPTE Time Code before any audio is recorded onto them or to Pro Tools. If tapes aren’t striped, your system may seem to work, but synchronization will never properly occur. The machines and Pro Tools will drift farther and farther apart the longer they run.

The same problem occurs when audio is recorded into Pro Tools without a resolved SMPTE source (for example, if it was recorded before the current session). The audio cannot be accurately synchronized with an analog tape recorder or video tape deck, since the Pro Tools audio was not recorded referenced to the SMPTE time code from the analog tape deck or video tape deck.

Resolve All Components of Your System

When striping time code, make sure that the time code generator and the video record deck are resolved to the same crystal reference. For example, when striping 29.97 Drop Frame time code onto a VTR, both the SMPTE generator and the VTR should be resolved to the same “black burst” or house sync generator. During playback, the master deck should be resolved to “black burst” or house sync.

This convention provides compatibility for your tape between the record and playback passes, and when it’s played back in other facilities on different equipment. This also means that when playing back a tape striped with time code, the playback deck should be resolved to the same synchronization rate as the record deck was resolved to at the time of the striping. When you stripe time code using an audio transport, it should be “free-running” and unresolved, but should be resolved with a house sync-referenced synchronizer during playback.

Know the True Frame Rate on Your Work Tape

If you get your video tapes from a production company instead of recording them yourself, be absolutely sure that they indicate the SMPTE frame rate used on the tape correctly. Several time code formats use the same frame count (such as 23.976 fps and 24 fps) yet they run at slightly different frame rates per second.

The Digidesign SYNC I/O (and some third-party products) can be used to help determine frame rate.

29.97 fps Non-Drop Rate Not Recognized

29.97 fps Non-Drop is a slightly slower version of 30 fps Non-Drop time code. When used with color video, each video frame now matches up with each SMPTE frame without having to use a drop-frame coding. This makes any frame number mathematics much simpler, since no frame numbers are dropped.

Unfortunately, some hardware and software devices do not recognize 29.97 Non-Drop as a separate frame rate. For example, any standard SMPTE-to MTC-converter does not explicitly recognize it. The user must tell the convertor to expect 30 fps Non-Drop instead. In fact, many devices that read SMPTE work acceptably by reading 29.97 Non-Drop if they are set to expect 30 fps Non-Drop.

Any SMPTE reader that uses the time code numbers to make real-time calculations (as Pro Tools does when it tries to trigger and synchronize to SMPTE) also needs to know that the frame format is 29.97 and not 30 fps. Since Pro Tools allows this choice of frame rate this does not really pose a problem. The problem exists because many users cannot readily distinguish 29.97 from 30 fps.
Even though NTSC tapes only use 29.97, some production companies will distribute video work prints striped with 29.97 fps but mark them as “30 fps NTSC,” by which they actually mean 29.97 fps Non-Drop.

By the time you get the tape, you may have no idea what’s actually on it. Feeding 29.97 Non-Drop to Pro Tools when it’s set for 30 fps Non-Drop will result in timing errors of about 1.8 frames per minute, causing audio playback to trigger out of sync.

**Be Careful When Changing Frame Rates**

If you change time code rates in the middle of a session, many SMPTE-to-MIDI Time Code converters need to be turned off and turned on again to be able to recognize the new frame rate.

**Use a Consistent Clock Source**

When possible, sound files should be played back using the same sync reference signal it was recorded with. This assures the closest match between record and playback sample rates.

**Disable Screen Savers and Power Management Features**

These types of software can cause your computer to ignore MIDI data (such as MIDI Time Code).
Chapter 31: Pro Tools Setup for Surround (Pro Tools HD Only)

This chapter explains how to set up and configure Pro Tools sessions for multichannel mixing.

Multichannel mixing is supported on Pro Tools|HD systems only. In this chapter, all references to Pro Tools refer to Pro Tools|HD systems.

For information on fundamental surround concepts, see the Pro Tools Sync & Surround Concepts Guide.

Pro Tools Audio Connections for 5.1 Mixing

While all 5.1 mixing formats provide the same speaker arrangement, there are three primary standards in use for the track layout of the individual channels that comprise the 5.1-format multichannel mix.

In the following table, it is assumed that surround channels are mapped to outputs 1–6 of a Pro Tools audio interface. Use channels 7–8 to monitor a stereo mix for a stereo version, or for cue mixes and monitoring.

Table 32. Track Layouts for 5.1 Formats

<table>
<thead>
<tr>
<th>Formats</th>
<th>Track Layout</th>
</tr>
</thead>
<tbody>
<tr>
<td>Film (Pro Tools default)</td>
<td>L C R Ls Rs LFE</td>
</tr>
<tr>
<td>SMPTE/ITU for Dolby Digital (AC3) and Control</td>
<td>24</td>
</tr>
<tr>
<td>DTS with ProControl</td>
<td>L R Ls Rs C LFE</td>
</tr>
</tbody>
</table>

To connect your audio interfaces for 5.1 format mixing and monitoring:

1. Determine the 5.1 format and track layout you want to use.
2. Connect the output channels of your audio interface to the corresponding input channels of your monitoring system according to the assignments listed in Table 32 on page 699.

If you use a Digidesign control surface, see its guide for more information.
Configuring Pro Tools for Multichannel Sessions

Configuring Pro Tools and sessions for multichannel mixing can be done in any (or all) of the ways described in this section.

New Sessions

You can create a new session and choose a surround mix I/O Settings file as the default I/O Setup. See “New Sessions and I/O Settings” on page 700.

Remixing Sessions in Surround (Importing Multichannel I/O Setups)

By creating or importing a surround mix I/O Settings file in the I/O Setup dialog, multichannel paths can be made available in any stereo (or other format) session. You can then reassign track routing from the original stereo paths to multichannel paths. Inactive and active paths simplify reassignment. See “Importing Multichannel I/O Setups” on page 701.

Custom Multichannel Paths

You can customize and redefine existing paths in the I/O Setup dialog. For more information, see “Custom Multichannel Paths” on page 702.

Importing Session Data

By using the Import Session Data command (File > Import > Session Data), you can import tracks and media from other sessions plus their associated paths and track assignments. After importing session data, you can use the I/O Setup dialog to configure main and subpaths for the requirements of the session. For more information, see Chapter 7, “I/O Setup.”

New Sessions and I/O Settings

When you create a new session, you can specify a surround format that you want to use as your I/O Setup. Default path configurations are provided as I/O Settings files, for stereo and surround mixing.

Once you create the new session, you can create and import tracks, import audio, and assign signal routing to set up your mix.

To create a new session for multichannel mixing:

2. Select one of the available 5.1 settings from the I/O Settings menu (Film, SMPTE/ITU, or DTS/ProControl Monitoring).
3. If needed, change other parameters in the Session Parameters section.
4. Name the session.
5. Click Save.
The surround presets preconfigure the I/O Setup dialog for the new session with default 5.1 format main and sub-paths for outputs and busses.

All three 5.1 format I/O Settings (Film, SMPTE/ITU, or DTS/ProControl Monitoring) provide the following default output and bus paths for the new session:

**Default 5.1 Output Paths**
- One 5.1 main output path, with sub-paths for 5.0 (no LFR), LCR, Left/Right (stereo), and Center (mono).
- And
- One stereo main path with two mono sub-paths.

**Default 5.1 Bus Paths**
- One 5.1 main bus path, with sub-paths for 5.0 (no LFE), left/right (stereo), LCR, and center (mono).
- And
- One stereo main path with two mono sub-paths.

**Default Input and Insert Paths with 5.1 Settings**
The 5.1 Mix settings files provide default stereo main paths and mono sub-paths for inputs and inserts. If you need multichannel input paths or inserts, you can create them in the I/O Setup dialog (see “Custom Multichannel Paths” on page 702).

**Importing Multichannel I/O Setups**
The I/O Setup dialog can import and export settings files. Importing I/O Setup settings files is useful when you want to remix a stereo session in surround. You can also use this feature to prepare a session for transfer to a different Pro Tools system, or to simply save and exchange I/O Settings.
To import a multichannel I/O Setup settings file:

1. Choose Setup > I/O.
2. Click Import Settings.
3. Select the settings file to import and click Open.

If the current session has existing path definitions that do not match those in the imported settings file, Pro Tools asks whether you want to delete the existing paths or retain them and add the imported settings to your session.

- Click No to add new paths to your current I/O Setup configuration.
- Click Yes to replace your current I/O Setup configuration with the imported settings.

Exporting I/O Settings

Exporting I/O Setup settings files lets you build a library of multichannel setups for different projects.

To export an I/O Setup settings file:

1. Choose Setup > I/O.
2. Click Export Settings.
3. Name and Save your current I/O Settings.

Custom Multichannel Paths

The I/O Setup dialog lets you create and customize signal paths for any supported multichannel mixing format.

Multichannel paths and sub-paths are mapped to inputs, outputs or internal busses in the Channel Grid. When you select a preset 5.1 I/O Settings file, default layout for the corresponding multichannel format paths you create will match the selected format’s track layout.

In addition, the I/O Setup dialog, like the Main page of the Hardware Setup dialog, provides controls for routing the physical inputs and outputs on your audio interface to available inputs and outputs in Pro Tools.

💡 When creating 5.1 format paths, you can specify the default track layout. See “Default Path Order for 5.1 Tracks” on page 704.

Remapping Channels

The I/O Setup dialog and its Channel Grid also let you remap channels. This is especially useful to route channels within a multichannel path, without having to repatch your audio interfaces.

You can remap paths to any required configuration, limited only by your systems resources, and the I/O Setup dialog requirements for channel overlapping and naming (see “Valid Paths and Requirements” on page 86 for more information).

💡 See also “Example Paths and Signal Routing for a Surround Mix” on page 714.

Example LCRS Setup

The following example shows one possible way to configure the I/O Setup dialog to mix in 4-channel LCRS format, with a 96 I/O.
To define an LCRS path:
1. Choose Setup > I/O, and click the Output tab.
2. Click New Path.
3. Select LCRS from the Path Format selector.
4. Name the path LCRS.
5. In the Channel Grid, click in the box below the first (left-most) audio interface channel for the path. Pro Tools automatically fills up the adjacent units to the right. If you click in the LCRS row under channel 1, the LCRS path will be mapped across channels 1–4.
6. Select the new LCRS path and click New Sub-Path.
7. Name the new sub-path LCR and select LCR as the Path format. Click in channel 1 in the LCR row to map the path.
8. Select the LCRS path, click New Sub-Path, and create a stereo sub-path for front Left and front Right.
9. Select the LCRS path, click New Sub-Path, and create a mono sub-path for the Center channel.
10. Select the LCRS path, click New Sub-Path, and create a mono sub-path for the Surround channel.

5.1 Tracks, Formats, Mapping, and Metering

Path definitions in I/O Setup determine how audio is routed through, and metered on, your audio interfaces.

Pro Tools track layout of 5.1 format audio tracks in the Edit window also conforms to the Film layout (arranged top to bottom). See the illustration “5.1 Track Layouts, Routing, and Metering” on page 704.

In the I/O Setup dialog, you can route these signals out of your audio interfaces according to any track layout (such as DTS or SMPTE/ITU).

To re-map channels in a path:
- Click and drag a channel to a new valid location in the Grid. Other channel assignments will move (shuffle) to accommodate dragged channels.

Default I/O Selectors in I/O Setup

The Output tab of the I/O Setup dialog provides the following default settings for multichannel sessions:

5.1 Tracks, Formats, Mapping, and Metering

Path definitions in I/O Setup determine how audio is routed through, and metered on, your audio interfaces.

Pro Tools internal (on-screen) metering of 5.1 format paths always follows the Film track layout:

L C R Ls Rs LFE

Default Path Order

Selects the default track layout (or, path order) for new 5.1 format (six-channel) paths.
Controller Meter Path Selects the path that will be shown in Digidesign control surface output meters. See “5.1 Tracks, Formats, Mapping, and Metering” on page 703 for more information.

Audition Paths Selects the monitoring path for previewing audio in the Region List, Import Audio dialogs, and DigiBase. Only outputs on your primary interface can be used as your Audition path.

New Track Default Output Selects the default output path for all new tracks, for each supported track format.

The New Track Default Output can be set to bus paths, as well as output paths.

AFL/PFL Path Selects where tracks are routed to when they are soloed in AFL (After Fader Listen) or PFL (Pre Fader Listen) Solo mode.

AFL/PFL Mutes (Output Path) Selects which output is muted when AFL (After Fader Listen) or PFL (Pre Fader Listen) Solo mode is enabled, and a track is soloed.

Default Path Order for 5.1 Tracks
You can specify the default track layout for all new 5.1 format paths you create.

To choose a new default 5.1-format path order (track layout):
1. Choose Setup > I/O.
2. Use the Default Path Order menu and sub-menus to choose the track layout you want.

5.1 Track Layouts, Routing, and Metering

<table>
<thead>
<tr>
<th>5.1 Format</th>
<th>Tracks</th>
<th>Track Meters</th>
<th>Channel Map in I/O Setup</th>
</tr>
</thead>
<tbody>
<tr>
<td>Film (Pro Tools Standard)</td>
<td>L C R Ls Rs LFE</td>
<td>L C R Ls Rs LFE</td>
<td><img src="image" alt="Default Path Order selector in I/O Setup" /></td>
</tr>
<tr>
<td>SMPTE/ITU (Control</td>
<td>24 Monitoring)</td>
<td>same</td>
<td>相同</td>
</tr>
<tr>
<td></td>
<td>L C R Ls Rs LFE (top to bottom)</td>
<td>same</td>
<td>相同</td>
</tr>
<tr>
<td></td>
<td>L R C LFE Ls Rs (left to right)</td>
<td></td>
<td>相同</td>
</tr>
<tr>
<td>DTS (ProControl Monitoring)</td>
<td>L R Ls Rs C LFE</td>
<td>same</td>
<td>相同</td>
</tr>
<tr>
<td></td>
<td>L C R Ls Rs LFE</td>
<td>same</td>
<td>相同</td>
</tr>
</tbody>
</table>

Figure 31. Track layout of different 5.1 formats
Surround sessions typically include a combination of mono, stereo, and multichannel audio, Auxiliary Input, Master Fader, and Instrument tracks, and inserts and busses.

Once the appropriate I/O Setup has been imported or configured, audio, Auxiliary Input, Master Fader, and Instrument tracks can be mixed in multichannel for surround using Pro Tools mixing features.

Multichannel I/O and signal routing is determined by the paths defined in the I/O Setup dialog.

Multichannel mixing is supported on Pro Tools|HD systems only. In this chapter, all references to Pro Tools refer to Pro Tools|HD systems.

---

**Multichannel Quick Start**

The following is an overview of how to get started mixing in multichannel for surround in Pro Tools.

**To mix in multichannel:**

1. Open any stereo Pro Tools session to remix it in surround. (You can also create new, empty surround sessions. See “New Sessions and I/O Settings” on page 700.)

2. Configure the I/O Setup dialog with multichannel inputs, outputs, busses, and inserts, as needed. (See “Configuring Pro Tools for Multichannel Sessions” on page 700.)
3 Do one of the following:
• Create new tracks, and assign track outputs and sends to your multichannel paths. Configure signal routing as needed for submixing, bussing, processing, and monitoring. For tracks that do not need to be panned in 360°, place them in the mix using sub-paths and signal routing. (See “Multichannel Signal Routing” on page 709.)
• Use the Import Audio command (File > Import > Audio) to import multichannel audio files.
• Use the Import Session Data command (File > Import > Session Data) to import existing 5.1 tracks, busses, and other data. (See “Importing Tracks and Track Attributes” on page 144.)

4 Pan in surround using the multichannel Track Output and Send windows. (For information on mixing and panning for surround, see Chapter 33, “Surround Panning and Mixing (Pro Tools HD Only).”)

### Multichannel Audio Tracks

Multichannel audio tracks contain an individual channel for each signal in the track (for example, a 5.1 track would have six channels for left, center, right, left surround, right surround, and LFE).

Multichannel audio tracks can be:
• Recorded directly into Pro Tools, using multiple microphones or microphone arrays, or routed to appropriate multichannel Pro Tools Input paths
• Imported from other Pro Tools sessions
• Edited, processed, and mixed in combination with mono and stereo tracks

5.1 format audio files and tracks conform to the Film track layout standard. Regardless of path mapping in the I/O Setup dialog, all 5.1 format audio tracks and meters follow the Film standard track layout:

L C R Ls Rs LFE

Multichannel audio tracks are not required to mix in multichannel formats. Mono, stereo, and all supported track formats can be mixed using Pro Tools track outputs and sends. See “Multichannel Signal Routing” on page 709.
Placing Audio in Multichannel Tracks

You can drag audio files and regions from DigiBase browsers, the Region List, Windows Explorer or Mac Finder, or from other tracks, to place them in multichannel audio tracks.

To do so, the number of channels being dragged must match the destination track format. For example, you can only drag a stereo pair or two mono regions onto a stereo audio track. Similarly, you can only place audio into an LCR track when you have selected three regions. With 5.1 tracks, you must select six mono files or regions.

⚠️ When dragged into a multichannel track, audio files are placed from top to bottom in the exact order that they appear in the Region List or playlist from which they came. For this reason, you may want to rename audio files before dragging them, so that they are in a preferred order. Rename them so that sorting them By Region Name in the Region List results in the preferred order. (For example, with a 5.1-format track, you can rename the audio tracks, so that the arrangement of the tracks corresponds to L, C, R, Ls, Rs, and LFE.)

Solo, Mute, and Gain in Multichannel Tracks and Paths

Stereo and multichannel tracks consist of multiple audio signals, linked together. By default, multichannel tracks are linked and are controlled by a single channel fader, and solo and mute switches.

For discrete control of signals, multichannel tracks can be converted into individual mono tracks. For discrete level and phase adjustment, you can insert and unlink a multi-mono Trim plug-in. Both of these techniques are explained below.

⚠️ Once converted to mono, multichannel tracks cannot be relinked into their original multichannel format. However, a multichannel track can be reassembled by dragging the corresponding number of mono files into a multichannel track, although some automation data may be lost. As an alternative, record the submix of the mono tracks to disk on a multichannel track.

To convert a multichannel track into discrete mono tracks:

1. Select the multichannel track.
2. Choose Track > Split into Mono.

To have discrete control of gain on individual channels of a multichannel track:

1. Insert a multi-mono Trim plug-in on the multichannel track.
2. Unlink the Trim plug-in by clicking the Link icon so that it is unlit.
3. Use the Channel selector to display the controls for a channel, and adjust the gain.

⚠️ See “Linking and Unlinking Controls on Multi-Mono Plug-ins” on page 711 for more information.
Track and Output Formats

When you create new tracks, you specify mono, stereo, or a supported multichannel format for the new tracks.

In the Mix and Edit windows, the track format of a track’s output is always visible by the number of track meters contained in its fader strip (for example, a single meter for mono tracks, a pair of meters for stereo tracks, and six meters for 5.1 tracks).

Assigning track output determines the format of that output. For example, a mono track always has a single track meter, even when assigned to a stereo output path. If that same mono track is assigned to a 5.1 output path, its output will be split among those six output channels, depending on the position of its panner.

Changing Format

Changing the output format for a given track has several effects:

- The panner that appears in the track will change to reflect the new output format.
- It may be necessary for one or more pan related automation playlists to be created or deleted.

Because changing the output format has these effects, a warning dialog appears whenever you change the output format of a track to a format of fewer channels. Specifically, this will occur whenever automation playlists will have to be deleted.

Multiple Output Assignments and Track Format

When a track is assigned to more than one path of differing formats, the main output for that track will match the format of the assigned path with the greatest number of channels.

Multiple Outputs and Automation Playlists

When a track has multiple output assignments, Pro Tools sorts panning data appropriately for each assigned path. For example, if you assign a mono track to a stereo path and a 5.1 path simultaneously, that track will have a 5.1 panner in the Mix or Edit window. When you pan the track, Pro Tools interprets the 5.1 panning moves into stereo panning moves.

This provides a type of parallel mixing. You can create a variety of mixes of differing formats all at the same time by routing your elements to multiple paths.

Control-Start-click (Windows) or Command-Control-click (Mac) any control in an Output window to show its automation playlist in the Edit window and view any pan automation.
Multichannel Signal Routing

To mix in a multichannel format, tracks are assigned to multichannel paths.

Tracks can be mixed in surround using the following two methods:

- By setting a track main output to a multichannel path.
- By assigning a multichannel send to route audio to a multichannel path.

Multichannel Send Panner

This channel’s output path is multichannel, so the track provides a multichannel panner.

Two different ways to configure tracks for multichannel mixing

Multichannel Track Outputs

Tracks can be routed to multichannel output or bus paths using the track’s Output Path selector. This provides a multichannel panner and meter in the Mix and Edit window I/O View.

Multichannel Sends

All track formats, including mono and stereo, let you assign one or more multichannel sends. This provides a multichannel panner in the Sends View. Sends are also useful to bus tracks for multichannel plug-in processing.

Figure 32 shows a mono audio track with a 5.1 (6-channel) send (View > Sends A–E > Send A).
Pro Tools bussing and submixing features are available for all channel formats, from mono/stereo through 8-channel. For examples of multichannel monitoring, effects processing, and bussing, see “Mixing with Paths and Sub-Paths” on page 712. For mono and stereo mix examples, see Chapter 25, “Basic Mixing.”

**Multichannel Auxiliary Inputs and Master Faders**

A multichannel Auxiliary Input or Master Fader is used as a return for the multichannel bus. Sends are useful when you need to create an additional, independent mix simultaneously (perhaps of a distinct format), requiring dedicated fader, mute, solo, and automation controls.

You can assign Master Faders to main and sub-paths. Main paths must match the format of the Master Fader, and only one Master Fader can be active and assigned to any single (active) main or sub-path. A Master Fader cannot be assigned to a sub-path if its associated main path is already assigned on another Master Fader. See “Master Fader Tracks” on page 526.

**Multichannel Instrument Tracks**

Multichannel tracks can be used to monitor and route multichannel instrument plug-ins or multichannel external MIDI instruments.

---

**Mono, Multi-Mono and Multichannel Plug-ins**

Plug-ins can be used in mono, multi-mono, or multichannel formats.

![Plug-in formats](image-url)

For information about mono, stereo, and mono-in/stereo-out plug-ins, see Chapter 26, “Plug-in and Hardware Inserts.”

**Multi-Mono Plug-ins** are designed for use on stereo or greater-than-stereo multichannel tracks. Multi-mono plug-ins are useful, or required, in the following situations:

- When a plug-in does not involve multichannel correlated processing (for example, when applying EQ to select sides of a multichannel signal)
- When you need to adjust signals within the multichannel track independently
- When a plug-in does not support multichannel formats

When a multi-mono plug-in is first inserted on a multichannel track, the plug-in controls are linked. You can unlink them for independent adjustment. See “Linking and Unlinking Controls on Multi-Mono Plug-ins” on page 711 for more information.

Multi-mono plug-ins can also be inserted on stereo tracks, to apply unlinked plug-ins on the left and right channels.
Multichannel Plug-ins

Are designed for use on stereo and multichannel tracks that require correlated processing, including stereo and multichannel limiting, compression, and similar effects.

Linking and Unlinking Controls on Multi-Mono Plug-ins

When a multi-mono plug-in is used on a multi-channel track of more than two channels, the controls are normally linked. Adjusting the Gain control on one channel, for example, will adjust it for all channels.

If necessary, you can unlink plug-in controls on specific channels of a track and edit them independently. You can also selectively link the controls of specific channels.

For example, to apply equal filter cutoffs to the Ls and Rs (surround) channels in a 5.1 mix, you could link enable just those channels in an unlinked, multi-mono EQ plug-in. Adjusting the controls in the plug-in window for either channel (Ls or Rs) adjusts the other, linked channel as well.

Channel Selector

Accesses a specific channel within a multichannel track for plug-in parameter editing. This menu appears only on multi-mono plug-ins inserted on tracks with more than two channels.

Master Link Button

When enabled, links the controls on all channels of a multi-mono plug-in so that they can be adjusted in tandem.

Link Enable Buttons

Let you selectively link the controls of specific channels of a multi-mono plug-in. Each square represents a speaker channel. The Master Link button must be disabled to use the Link Enable buttons.

To unlink controls on a multi-mono plug-in:

- Deselect the Master Link button. It is lit when linked, unlit when unlinked.

To access controls for a specific channel:

- Select the channel from the Channel selector.

To open a plug-in window for all channels of a multi-mono plug-in:

- Alt-click (Windows) or Option-click (Mac) the Channel selector.

To link the controls of specific channels:

1. Deselect the Master Link button if it is not already deselected.

2. Click the Link Enable buttons for the channels whose controls you want to link.

For more information on using plug-ins, see the DigiRack Plug-ins Guide.
Paths in Surround Mixes

Because Pro Tools provides a flexible routing and submixing environment, you can maximize your system’s available resources by first identifying the elements that you want to pan dynamically and those that can be placed in certain channels only (see “Mixing with Paths and Sub-Paths” on page 712).

Once you have identified these elements in your session, you can use a combination of main and sub-path assignments, and multichannel panning.

Mixing with Paths and Sub-Paths

It is rare that every track needs to be “flown” (actively panned in between more than a pair of speakers). In most situations, certain elements are placed in certain speakers and remain there, providing the foundation for a mix.

Figure 33 on page 713 illustrates an example of how panning and signal routing can be combined in a multichannel mix. The following sections describe how to organize your session and signal routing to maximize the available resources.

See “Extending Stereo Mixing Conventions to Surround Mixing” on page 713 for related information.

When to Assign Multichannel Outputs

- Assign 5.1 paths only to those tracks that need to be panned to all six channels.

For example, a sound effects track with a jet flyover should be assigned a 5.1 path to be able to fly the sound from front-to-back. In a music mix, you can fly a solo instrument or make a synth pad swirl around the room as a special effect.

Elements that need to be heard in all speakers simultaneously can also be assigned to the multichannel output, whether or not they need active panning in the sound field.

When to Use Sub-Paths

- To help simplify large sessions, use sub-paths to route static (or, stationary) elements directly to the output channel or channels.

For example, film dialog is often mixed to the center channel to anchor this essential sound element to the picture. Instead of assigning a six-channel panner to dialog tracks and panning the tracks to the center speaker only, you can route the dialog track’s main output to a mono (Center) sub-path.
Extending Stereo Mixing Conventions to Surround Mixing

Stereo mixing sets the precedent for active and static panning, and surround mixing can benefit from the same basic principles.

Panning a sound back-and-forth between the left and right speakers is best used as a special effect. In a typical music mix, the basic tracks are placed in the stereo sound field and remain there.

Surround mixes can become incoherent if too many elements are continuously moving. For special effects, some tracks can be panned dynamically, bouncing between speakers or sweeping from one side to the other.

Figure 33. Using signal routing and sub-paths to mix in surround
Example Paths and Signal Routing for a Surround Mix

The examples that follow show how Auxiliary Inputs, Master Faders, and other Pro Tools signal routing features can be used for stem mixes, submixes, and similar project needs.

In these examples, music and effects are being mixed for a trailer, in 5.1 surround. Separate stem mixes (for music and for effects) are to be mastered to 8-track MDM.

Example Multichannel Paths

Signal routing is the key element in any Pro Tools surround session. Signal routing is configured and defined in the I/O Setup dialog.

Example Output Paths

Figure 34 shows output paths defined in the I/O Setup dialog of an example session that was created on a Pro Tools|HD system with one 96 I/O audio interface.

Additional stereo output paths, with mono sub-paths, have also been defined for the remaining channels.

Example Bus Paths

Figure 35 shows example bus paths.

Two 5.1 format main paths have been defined ("Music" and "FX"), each with several sub-paths.

Example Sub-Paths

Sub-paths let you route to selective channels within the multichannel surround output. In Figure 36, the Mix 5.1 bus has several sub-paths that show this.

5.0 Sub-Path The 5.0 FX bus is a 5-channel sub-path. Use this type of sub-path routing to conserve mixing resources with tracks you want to keep out of the LFE channel.

LFE Path A custom LFE sub-path has been added to provide a discrete mono path for the LFE channel.
Signal Routing Examples

The following examples show how main and sub-paths can be used, using an example session consisting of a 5.1 main mix, with music and effects stems (or submixes).

Submix Stem Examples

Figure 37 shows a routing configuration for an effects submix. Some tracks are routed to stereo sub-paths, while others are assigned to mono, LCR, or other sub-paths. Two tracks (one stereo, one mono) are assigned to multichannel busses for surround panning. A 5.1 Auxiliary Input assigned to the FX main bus path serves as a sub-mixer.

Figure 37. FX stem
Figure 38 shows a routing configuration for music tracks.

Most of the music tracks in this example are routed to the front left/right channels, using a stereo sub-path. A 5.1 Auxiliary Input controls the bus and stem output.

**Main Stems Example**

Figure 39 shows two Auxiliary Input channels assigned to additional 5.1 format paths for a main mix.
Multiple output assignments make it possible to configure a number of multi-format mixes. For example, you can assign an additional stereo output to tracks and create a stereo mix at the same time as a 5.1 mix. For more information, see “Multiple Output Assignments” on page 536.

**LFE Examples**

LFE tracks and other audio can contribute to the LFE output in two ways:
- Using the LFE slider in Output windows. This LFE signal is post-fader.
  - or –
- Using a custom sub-path to route channels discretely.

Figure 40 shows a channel Output window, sending and metering to the LFE channel.

Using the LFE fader, you can add any amount of any multichannel path to the overall LFE output. In the above example, the track’s Center percentage has been turned off, and the LFE fader has been raised to route it to the LFE channel.

Figure 41 shows how a “traditional” LFE track can be routed to only the LFE channel. This example uses a custom-defined LFE sub-path to the FX main bus path.

**LFE and Filtering**

Pro Tools applies no filtering to LFE signals. Some delivery requirements may require filtering for the LFE track. See the Pro Tools Sync & Surround Concepts Guide for more information.
Chapter 33: Surround Panning and Mixing (Pro Tools HD Only)

This chapter explains how to pan and mix in surround with Pro Tools.

Multichannel mixing is supported on Pro Tools|HD systems only. In this chapter, all references to Pro Tools refer to Pro Tools|HD systems.

Before you can pan a track in surround, it must be assigned to an appropriate multichannel output or bus path.

The I/O Setup dialog defines the bussing and output architecture of the Pro Tools multichannel surround mixer. If you have not already done so, it is recommended that you become familiar with main and sub-paths and the I/O Setup dialog before starting multichannel Pro Tools projects.

See Chapter 31, “Pro Tools Setup for Surround (Pro Tools HD Only)” for more information on multichannel configurations and I/O Setup options. For multichannel signal routing, see Chapter 32, “Multichannel Tracks and Signal Routing (Pro Tools HD Only).”

Introduction to Pro Tools Surround Panning

There are four different track panning methods available:

- In the Edit window, using the reduced-height Panner Grid in the I/O View
- In the Mix window, using the reduced-height Panner Grid
- In the Output window, using the full-size Panner Grid
- Through pan automation editing

Control surfaces provide additional panning options. Refer to the documentation for your control surface for more information.
Mix and Edit Window Panner Grids

In the Mix and Edit window, multichannel Panner Grids are displayed on tracks that have multichannel track or send output assignments.

To pan from the Mix or Edit window:

1. To pan in the Edit window, make sure I/O View is being shown (View > Edit Window > I/O). Panner Grids are always displayed in Mix window tracks that support panning.
2. Begin playback.
3. Click and drag on the appropriate multichannel track’s Panner Grid in the Mix or Edit windows.

The Pan Location cursor follows your movements as long as you hold down the mouse button. Movements are scaled so that, once you click to “grab” the Pan Location cursor, you do not need to limit your movements to the small Track Grid area.

Pan Location Cursor Color while Automating

The Pan Location cursor is green when the track is in Automation Read mode, red in an Automation Touch, Latch, Touch/Latch, or Write modes, and yellow in Automation Off (or Automation Suspend) mode.

In Trim mode, the Volume fader and LFE fader are yellow.

Output windows provide additional features and controls (and a much larger Grid). For details, see “Output Windows” on page 720.

Output Windows

Output windows provide panning controls (called panners), as well as standard Pro Tools controls, for tracks of all mix formats (from 3-channel LCR through 8-channel 7.1).

For information on Output window standard controls, see “Standard Controls” on page 721.

For information on Output window panning controls, see “Surround Panner Controls” on page 722.

Some of the features of Output windows include:

- X/Y (joystick-style) panning
- 3-Knob panning
- Full Divergence and Center Percentage control
- LFE feed
- Multichannel meters
- Pro Tools target window support

Multiple panners can be opened simultaneously, or a single window can display the current panner.
To open an Output window:

- Click the Output Window button in the track in the Mix or Edit window (I/O View).

For instructions on managing multiple Output windows, see “Output Windows for Tracks and Sends” on page 543.

---

**Standard Controls**

All Output windows provide standard Pro Tools controls for routing, path assignment and other track features. These controls are located at the top of all Output, Send, Insert, and Plug-in windows. Some controls are specific to the type of window.

- **Show meters**
- **Track selector**
- **Path selector**
- **Target icon**
- **Automation Safe**

For details on these standard features, see “Standard Selector Controls in Output Windows” on page 545.

---

**Track Fader, Solo, Mute, and Auto**

All Output windows provide track volume and mute controls. You can adjust and automate track volume, or mute, directly using these controls. The larger fader and Mute button are equivalent to those in the Pro Tools Mix window.
Surround Panner Controls

When assigned to tracks or paths with four or more channels, the Output window provides an X/Y Grid for surround panning. The speakers associated with the panner’s multichannel format are displayed in their relative positions outside the Panner Grid. These speakers are also used as Snap Pan to Speaker controls.

This section identifies all the controls and features found in Pro Tools multichannel panners.
The X/Y Grid and Pan Location Cursor

The X/Y Grid is where multichannel panning information is input and displayed. You can input pan information using X/Y mode, 3-Knob mode, or by entering numeric values in the Position data fields. You can also edit pan automation graphically in the Edit window.

Position Controls

The Position controls let you set the positions of the panner.

Position and Center % controls

Front Displays and controls the current front X-axis (left/right) position of the panner.

Rear Displays and controls the current rear X-axis (left/right) position of the panner. In default X/Y Panning mode, Rear is linked to Front position and cannot be controlled independently.

F/R (Front/Rear) Displays and controls the current Y-axis position of the panner.

Center % Control

Center % controls how much of the signal is routed to the center speaker. This lets you mix a track to the front with a phantom center (0% Center value) or to three-channel (LCR) when panning front.

Divergence Controls

Divergence determines the width of the panned signal with respect to neighboring speakers. (For more information, see the Pro Tools Sync & Surround Concepts Guide) There are three Divergence controls.
Front, Rear, and F/R Divergence  Provide separate, automatable divergence control over front speakers, rear speakers, and between front/rear, respectively.

Snap Pan to Speaker Icons
The Snap Pan to Speaker icons let you force the panner to the speaker’s location. For example, clicking on the upper left speaker moves the Pan Location cursor to the upper left corner of the X/Y Grid.

LFE Fader
The LFE fader is only available in “.1” surround formats (5.1, 6.1, and 7.1).

Panning Modes
The Panning Mode button provides access to four panning modes: X/Y mode, Divergence Editing, 3-Knob mode, and AutoGlide mode. Panning controls can be automated in all four modes.

X/Y Mode  Joystick-style panning by dragging the Pan Location cursor within the X/Y Speaker Grid. See “X/Y Panning” on page 725 for more information.

3-Knob Mode  Point-to-point panning, between pairs of speakers. See “3-Knob Panning” on page 725 for more information.

Divergence Editing  Divergence X/Y Grid can be dragged to resize the divergence boundaries.

AutoGlide Mode  Point-to-point panning from the Pan Location cursor to a new destination over a specified AutoGlide Time. See “AutoGlide Mode” on page 726 for more information.
To enable a Panning Mode:

- Click on the Panning Mode button in the Surround Panner until the desired mode icon is displayed.

**X/Y Panning**

**To pan in X/Y mode:**

1. Click on the Panning Mode button until the X/Y mode icon is displayed.

2. Drag the Pan Location cursor, or click anywhere in the Grid and drag to pan the track. The location of the Pan Location cursor determines the pan position of the signal. For example, to pan something to the left rear speaker, move the Pan Location cursor to the lower-left corner of the Grid.

   *It is not necessary to click exactly on the Pan Location cursor. Clicking anywhere in the Grid will move the Pan Location cursor relative to where you click or take over with a hardware panner. Panning does not jump to the click position.*

**To snap the Pan Location cursor to a location in the Grid:**

- Hold down the Control key and click anywhere in the X/Y Grid.

**Grid Options and Shortcuts**

**Fine-Adjust Mode** Hold down the Control key (Windows) or Command key (Mac) for fine adjustment of all Panner controls.

**Constraining to X or Y Movement** Shift-drag the Pan Location cursor to constrain its movement to the X or Y direction.

**Reset to Default** Alt-click (Windows) or Option-click (Mac) in the Panner Grid to reset all controls to their default position.

**Snap Pan to Speaker** Click one of the Snap Pan to Speaker icons to force the panner to that speaker location.

**Display Automation in Edit Window** Control-Start-click (Windows) or Command-Control-click (Mac) a control to display that control’s playlist in the Edit window.

*All Pan controls can be automated, including pan position and divergence. See Chapter 27, “Automation” for details.*

**3-Knob Panning**

Pro Tools provides 3-Knob mode as an additional way to input pan moves.

3-Knob mode lets you:

- Pan in straight lines, moving the Pan Location cursor using the Position rotary knobs with full movement of front, rear, and front-rear position.
  - and -
- Pan discretely between pairs of speakers.
3-Knob mode lets you pan discretely between speakers. For example, when panning front-left to rear-right in 3-Knob mode, audio will be heard from just those two speakers (assuming full divergence is in effect).

By comparison, in X/Y mode a diagonal pan may result in audio being heard in some or all channels.

To enable 3-Knob Panning mode:

1. Click on the Panning Mode button until the 3-Knob mode icon is displayed.

   ![3-Knob mode icon](image)

   _Panner Mode button set to 3-Knob mode_

The panner trajectory line appears across the Grid, extending from the front (X-axis) to the rear (Y-axis).

To pan in 3-Knob mode:

1. Adjust the Front and Rear Position knobs to set the trajectory line.
2. Rotate the Front/Rear Position knob to pan along the trajectory. The Pan Location cursor is constrained to the white trajectory line.

To change the 3-Knob trajectory angles, do one of the following:

- Drag either endpoint (Front or Rear) of the trajectory line.
  - or -
- Adjust the Front or Rear Position controls.

To change the current trajectory position (left-to-right) and retain its current angles:

1. Drag the trajectory line (not its endpoints) to a new position.

### AutoGlide Mode

AutoGlide mode lets you quickly write Surround Panner automation by clicking new locations in the Surround Panner window, instead of manually moving the Surround Panner controls.

⚠️ _When writing automation in AutoGlide mode, the Pan Location cursor cannot be dragged from its location._
The time it takes to glide from point to point (from the Pan Location cursor to the new destination) is called the AutoGlide Time. This time is set in the Mixing Preferences page and has a range of 10 msec to 10000 msec (10 seconds).

To set the AutoGlide Time

1. Choose Setup > Preferences and click the Mixing tab.
2. Set the AutoGlide Time in the Automation section.

To do an AutoGlide automation pass:

1. Click the Panning Mode button until the AutoGlide mode icon is displayed.

Panning Mode button (AutoGlide mode shown)

The Panning Mode button displays a slanted dotted line that ends with a filled in dot (representing a cursor) at its top right corner.

2. In the Mix or Edit window, click the Automation Mode selector and select an Automation mode for the track you want to automate.

3. Press Play to begin playback.
4. Set a new destination for the cursor by doing one of the following:
   • Click a Snap Pan to Speaker icon to glide to its speaker location.
   – or –
   • Click in the pan window to glide to a specific location in the X/Y Grid.

The Pan Location cursor will begin to move towards the new destination at the time it takes to travel the AutoGlide Time. When the new destination point is reached, a new breakpoint will be written at the new location.

5. Repeat the previous step if you want to write additional panning moves.
6. Stop the transport when finished.

Divergence and Center Percentage

The Divergence and Center Percentage controls range from 0 to 100, and can be automated. They are especially useful for ensuring audibility and coverage in large venues, and to increase clarity of voices.

Front Divergence Controls divergence between front speakers (X-axis only).

Rear Divergence Controls divergence between the rear speakers (X-axis only).

Front/Rear Divergence Controls divergence between front and rear (the Y-axis).
Center % (Percentage) Determines whether there is a discrete center image, a completely phantom center image, or a variable amount in between.

Divergence

In the Panner Grid, the current divergence values are displayed using a purple outline. Lower divergence settings result in a progressively wider source signal. When Divergence is less than 100%, tracks will be routed to neighboring speakers to some degree, even when the Pan Location cursor is positioned next to a single speaker.

To adjust divergence:

- Adjust the Front, Rear, and Front/Rear Divergence controls as necessary.

To adjust divergence graphically:

1. Click on the Panning Mode button until the Divergence Editing icon is displayed.

2. Drag in the Grid to resize the divergence boundaries.

Center % (Percentage)

Center Percentage controls whether there is a discrete center channel for the track or a phantom center channel.
**Center Percentage Example**

In film and video production, the center channel often contains dialog. To enhance the clarity of dialog, it is often beneficial to keep elements such as music out of the center speaker. By reducing the Center Percentage on music tracks, music panned to the front of the soundfield can be panned to only the left and right speakers, forcing them to have a variable phantom center image.

As you reduce the Center Percentage value, the center speaker at the top of the Grid becomes less visible. At 0, the center speaker is completely invisible, reflecting the setting for fully phantom center.

**LFE Faders in Multichannel Panners**

The LFE fader controls how much of the track is sent to LFE. LFE faders are only available when a track is assigned to a path whose format supports LFE (5.1, 6.1, or 7.1).

**To mix to the LFE channel:**

- Adjust the LFE fader in any “.1” surround format Output window.

  For general information about LFE, sub channels, and related topics, see the Pro Tools Sync & Surround Concepts Guide.

**LFE Faders and Groups**

Track and send LFE faders can follow Mix and Edit Groups by being enabled in the Group Attributes page in either the Create Groups or Modify Groups dialog. LFE faders can be assigned to follow groups as a global attribute or on a group by group basis. See “Selecting Group Attributes” on page 134.
LFE Enable

Some multichannel plug-ins, including the multichannel DigiRack Dynamics III Compressor/Limiter, provide LFE Enable. This lets you enable or bypass processing of the LFE channel if present.

To process the LFE channel in a multichannel plug-in:

- Click to enable LFE Enable in supporting multichannel plug-ins. LFE Enable is highlighted when LFE processing is enabled, and unhighlighted when LFE processing is bypassed.

When LFE Enable is unavailable, try using the multi-mono version of the plug-in.

Pan Playlists

Multichannel panners have an automation playlist for each position and divergence control.

Pan automation can be drawn, edited, cut, copied, and pasted from the Edit window. For more information, see Chapter 27, “Automation.”

Surround Scope Plug-in

The Surround Scope plug-in provides a 360° meter for metering multichannel paths during mixing.

5.1 Format Track Layouts

All 5.1-format meters (including those displayed in the Surround Scope meter, on tracks, and in Output windows and their Path Meter Views) are always arranged in the following order:

L C R Ls Rs LFE

For more information on Pro Tools metering, see “5.1 Tracks, Formats, Mapping, and Metering” on page 703.

To use the Surround Scope Plug-in:

- On a multichannel Master Fader, click an Insert button and select Multi-channel TDM plug-in > Sound Field > Surround Scope.

Surround Scope displays output levels in both a 360° Grid, and in traditional LED meters.

For details on Surround Scope, refer to the Digidesign Plug-ins Guide.
Index

Numerics
1622 I/O 6
16-bit
  Bounce to Disk 643
  176.4 kHz
  and pull factors 685
192 Digital I/O 6
192 I/O 6
  Hardware Setup 47
  Soft Limit 47
192 kHz
  and pull factors 685
24-bit
  Bounce to Disk 644
  TDM processing 557
24-bit ADAT Bridge I/O 6
29.97 FPS Non-Drop 697
3 Second Clip Hold option 61
3 Second option
  Add Marker/Memory Location button 430
  Add Meter Change button 420
  Add Tempo Change button 400, 417
  Add Unique Triggers 457
  adding
    a new playlist 271
    audio tracks 197
    Instrument tracks 220
    MIDI tracks 220
    sends 537
  AES/EBU
    Hardware Setup 47
  AFL (After Fader Listen) 119
  AFL/PFL Path
    selecting 92
    setting a level 92
    AFL/PFL Path selector 92
  After Playback Scrolling option 307
  After Write Pass, Switch To option 71
  After Write Pass, Switch To preference 585
  AIFF file format 640
  All MIDI Notes Off command 481
  all tracks
    hiding 108
    selecting all regions in 311
    selecting in Timebase rulers 317
    showing 108
  Allow Latch Prime in Stop option 70
  Allow Track Arm Commands in Local Mode option 74
  alternate channel 352
  Always Display Market Colors option 62
  Always Fill Channel Strips When Banking option 69
  Amount of Memory to Reserve for Automation Recording
    preference 71
  Analog In 47
  Analog Out 47
  Apply Real-Time Properties option 159
  applying to automatically bypassed tracks 555
  archiving
    preparing with Compact Selected 395
  Assignment View
    sends 539
  attributes
    for groups 133
  Attributes Group command 129
Audio 239
Audio During Fast Forward/Rewind option 63, 303
audio files
  compacting 395
  concepts 15
  default names 186
  formats 640
  importing 137
  mixed file types 55
  mixed formats 138
Audio Files folder 50
audio format, for session 676
audio interfaces 8
input channels 16
Audio Media options 146
Audio Pull Up and Pull Down 682
audio regions 260
  and automation 262
  fitting to an Edit selection 324
  stripping silence from 391
  whole-file 254
Audio Track RecordLock option 65, 239
audio tracks 15
  5.1 format 699
  adding 197
  and Output format 708
  and surround sessions 706
  bouncing to disk 638
  channel strips 97
  configuring for recording 197
  creating a tempo map for 416
  loop recording 204
  placing audio in multichannel tracks 707
  punch recording 203
  recording multiple 200
  signal flow 524
  Waveform View 260
Audio Zoom In button 284
Audio Zoom Out button 284
AudioSuite
  Dither 557
  Duplicate plug-in 361
  plug-ins 558
  processing 361
  AudioSuite Buffer Size preference 71
Audition Paths selector 91
auditioning
  fades 377
  pre/post-roll 320
  programs 478
  selection start and end points 320
  takes 205
Auto Backup option 64
Auto button 568
Auto Input Monitoring mode 182, 183
Auto Match Pull Factors 683
Auto Region Fade In/Out Length preference 66
Auto Regions Fade In/Out Length option 385
Auto Rename command 397
auto-created regions 254
  hiding 397
  renaming 396
auto-fades 384
AutoGlide mode 726
AutoGlide Time preference 71, 727
AutoJoin
  indicator 586
  AutoJoin command 586
AutoMatch
  all controls 597
  individual automation types 598
  individual controls 597
  individual controls with ICON 598
AutoMatch button 597
AutoMatch indicators 592
AutoMatch Time option 590
AutoMatch Time preference 71
Automatically Copy Files on Import option 72
Automatically Create Fades for Imported REX and ACID files option 68
Automatically Find and Relink 164
automating
  plug-ins 596, 597
  sends 595
  switched controls 594
  tracks 592
  VCA Masters 632
automation 581
  and audio regions 262
  and multichannel pan 730
  and multiple output assignments 708
  breakpoints 607
  buffer size 590
  capture & apply 627
  capturing and applying 630
  capturing and applying elsewhere 627
  coalescing Trim automation 616
  coalescing VCA automation 633
  creating 596
  cutting, copying, and pasting 356, 610
  deleting 603
  delta 587
  display of fade boundaries and shapes 390
  drawing with Pencil 605
  editing 606
  editing with Smart Tool 295
  enabling, suspending 601
  for grouped tracks 609
  for hidden tracks 109
  on multichannel tracks 609
  On Stop 618
  pass-through point 585
  playlists 270, 582, 591
  plug-in accuracy in bounce 645
  relative and absolute 587
  Safe button 568
  safaxing 591
  smoothing 589
  snapshot 625
  special Paste mode 613
  stepped 607
  suspending 601
  thinning 589, 604
  to next breakpoint 619
  Trim mode 587
  trimming 615
  writing 592
  writing to selection, selection start, or selection end 617
Automation Enable window 592
Automation Mode selector 584

Automation modes
- Latch 585
- Latch Trim 588
- Off 584
- Read 584
- Read Trim 587
- Touch 585
- Touch Trim 588
- Touch/Latch Trim 588
- Trim Off 587
- Write 584
- Write Trim 588

Automation Preferences
- AutoMatch Time option 590
- Memory for Automation Recording option 590
- Smooth and Thin Data After Pass option 604

Automation Preview mode 628
- Punch Preview button 629
- suspending 629
- Write Automation To commands 629

Auto-Name Memory Locations While Playing option 67, 431

Auto-Name Separated Regions option 67, 328

auto-naming
- and Strip Silence 392
- audio files and regions 186
- playlists 271
- QuickPunch regions 236
- separated regions 328
- takes 186

Auto-Spot Regions command 693

Auxiliary Inputs 18, 95
- channel strips 97
- monitoring and mixing 548
- signal flow 525

Avid
- playback in Pro Tools 668

Avid Video Errors Stop Playback option 64

Avid Video NTSC Has Setup option 64

Avid Xpress DV
- codec requirements for export 669

Beat Detective 437, 438
- beat triggers
  - deleting 445
  - generating 442
  - inserting 446
  - moving 445
  - promoting 446
  - Collection Mode 456
  - conforming regions 452
  - defining the selection 440
  - detecting transients 442
  - DigiGroove templates 448
  - edit smoothing 454
  - extrapolation 449
  - generating Bar|Beat Markers 447
  - groove templates
    - extracting 448
  - Scroll Next 447
  - separating regions 450
  - system requirements 438
  - templates 448
  - Trigger Pad 450
  - window 439
  - with multiple tracks 451

Beat Detective command 439

Big Counter window 302

bit depth, for session 50, 676

black burst 697

Blocks View 255

Blocks view
- video track 655

Bounce to Disk
- File Type 640

Bounce to Disk command 635, 638

and dither 636

and time stamps 638

Bounce Options 639

Convert After Bounce 645

Convert During Bounce 645

File Type 640

Format 643

Help 645

recording a submix 646

Resolution 643

sample rate conversion options 644

sample rate conversion quality 644

source path 640

Use Squeezer option 645

bouncing
- to a stereo mix 646
- to a submix 646

breakpoints 607

Avid keyframes 606

Bring to Front command 330

Buffer Size

Hardware 185

bussing
- multichannel sends 710
- sends 537
- signal paths 75

submixing and effects processing 548

surround examples 714

BWF (.WAV) file format 640

Bypass button
- for real-time plug-ins 568

BWF (.WAV) file format 640
Calculator Entry mode (for numeric entry) 316
Calibration Mode command 180
Calibration Reference Level preference 66
canceling record takes 200, 223
Capture Region command 327
capturing time code 692
Center % (Percentage) 728
Center % in Output window 729
Center Playhead Scrolling option 308
centered crossfade 376
Change Duration command 483, 498
Change Edit to Match Timeline command 323
Change Meter command 420, 422, 423
Change Tempo command 400
Change Timeline to Match Edit command 323
Change Velocity command 483, 496
Channel Delay indicator 100
channel mapping
default path order 93
ingesting 84
re-mapping 85
Channel selector 569
for multi-mono plug-ins 711
channel strips 17
audio tracks 97
Auxiliary Inputs 97
Instrument tracks 99
Master Fader tracks 98
MIDI tracks 99
VCA Master tracks 98
channels 16
chasing
controller events 479
MIDI notes 479
program changes 479
Classic Numeric Keypad Mode 37
Classic Numeric Keypad mode 63
Clear All Clip Indicators command 101, 102, 540
Clear command 355
Clear command (regions) 398
Clear Special commands 357, 613
All Automation 357, 613
Pan Automation 357, 613
Plug-In Automation 357, 613
Clear Trim Automation command 604
Clear Trim Automation Track command 110
click
configuring 193
enabling 194
Click plug-in 193
clicks 214
clicks and pops, avoiding 261
Clip Indication options 61
3 Second 101
Infinite 101
None 101
Clip LED 568
clipping 179, 568
clock source 580
Clock Source popup menu 47
Close Session command 58
closing multiple plug-in windows 570
Coalesce Trim Automation options 71
Coalesce Trim Automation Track command 110
Coalesce VCA Master Automation Track command 110
Coalesce When Removing Slaves from VCA Group option 70
coalescing
Trim automation 616
VCA automation 633
Collection Mode, Beat Detective 456
Color Coding options 62, 123
Color Palette window 124
Command|8 558
Commands Keyboard Focus 36
Comments View 104, 533
Compact Selected command 395
Compare button 568
compatibility
information 4
compressed QuickTime audio formats 660
Conductor button 31
Conductor rulers 265
including in selections 317
configuring
click options 193
MMC 688
Pro Tools 41
SMpte 679
connecting
effects units 579
external audio devices 579
Consolidate command 395
Constant Tempo command 411
continuous controller events 21
Continuous Scroll During Playback option and half-screen 308
Continuous Scroll with Playhead option and half-screen 308
Continuous Scrolling option 308
continuous zoom 284
control surfaces
Command|8 558
Control|24 558
D-Command 558
D-Control 558
controller events 21, 472
and MIDI regions 265
chasing 479
editing 473
editing with Smart Tool 295
inserting 473
Controller Meter Path selector 90
Conversion Quality option 139, 644, 861
Tweak Head setting 645, 661
Convert Plug-in selector 568
Convert WAV files to AES31/BroadcastWave option 72, 165
converting session
audio file format 54
bit depth 54
sample rate 54

Copy command 354
Copy Settings command 571
Copy Special commands 356, 612
All Automation 356, 612
Pan Automation 356, 612
Plug-In Automation 356, 612
Plug-in Automation 356
Copy to Send command 595
copying
a plug-in setting 573
all automation playlists for a track 356
MIDI notes with the Split command 501
selections and regions 354
track automation to sends 595
track control settings to sends 542
countoff 194
Countoff button 31
CPU processing activity 59
CPU Usage Limit 43
Create Fades command 381, 383
creating
crossfades 381
fade-ins/outs 383
Mac and PC compatible sessions 168
Markers and Memory Locations 430
region groups 363
regions 327
sessions 49
settings subfolders 572
Crossfade Preference for Pre/Post-Roll option 381
Crossfade preference for Pre/Post-Roll option 67
crossfades 375
and dither 558
creating with Smart Tool 294
equal gain 379
equal power 379, 381
Fades dialog 377
in batches 385
linear 381
overlap 381
pre/post 382
removing 382
trimming 382
types 375
with dither 379
current meter 32, 420
Current Meter button 195
Current Meter indicator 100
Current Time display 677
Cursor
location 26
value 26
Cursor Location display 27
custom session templates 57
Custom Shuttle Lock Speed 298
Custom Shuttle Lock Speed preference 63
Cut command 354
Cut Special commands 356, 612
All Automation 356, 612
Pan Automation 356, 612
Plug-In Automation 356, 612
Plug-in Automation 356
Cut Time command 422, 426
cutting
automation 610
MIDI notes with the Split command 501
selections and regions 354
D
DAE 13
DAE errors 214
DAE Playback Buffer Size 45
DAT recorder, recording from 213
D-Command 558
D-Control 558
default
audition path 91
I/O Setup 88
meter 194
metering path 90
output path 92
path order 93
paths 81
program change 475
sample rate 44
tempo 195
Default Dynamics preference 69, 567
Default EQ preference 69, 567
Default Fade Settings 68
Default Note On Velocity option 465
Default Note On Velocity preference 72
Default Path Order selector 93
Default Region Color Coding options 62
Default Settings, for TC/E plug-in 72
Default Thru Instrument 217
Default Thru Instrument preference 72
Default Track Color Coding options 62
Degree of Thinning preference 69
Delay
Real-Time Properties 509
delay
Channel Delay indicator 100
MIDI Track Offsets 480
Delay After Play Command preference 74
Delay Before Locking to Time Code option 74
Delay Compensation 553, 555
bypassing 555
changing track delay 555
configuring Delay Compensation Engine 554
dedicating DSP resources 44
during recording 185
enabling 553
engine 44
exceeding compensation limit 555
H/W Insert 93
information 554
MIDI Beat Clock 73
MIDI Time Code 73
mode 66
Plug-In Delay (dly) indicator 554
settings 554
User Offset (+/-) field 554
viewing 102, 534
Delay Compensation Engine
configuring 554
Delay Compensation Time Mode option 66
Delay Compensation View 102, 534
E
Edit commands 353
and Edit mode 354
clear 355
copy 354
cut 354
paste 355
edit cursor 302
and scrubbing 296
moving to region boundaries 318
Edit Groups 130
and selections 310
Edit Insertion Follows Scrub/Shuttle option 63, 296
Edit insertion point
placing regions at 335
trimming regions to 331
Edit Markers 309
and selection length 314
Edit menu
Change Edit to Match Timeline command 323
Change Timeline to Match Edit command 323
Clear command 355
Copy command 354
Copy Special commands 356, 612
Copy to Send command 595
Create Fades command 381, 383
Cut command 354
Cut Special commands 356, 612
Delete Fades command 382
Duplicate command 358
Fade To End command 384
Fade To Start command 384
Fades command 377
Heal Separation command 333
Identify Sync Point command 344
Insert Silence command 394
Paste command 355
Paste Special commands 356
Play Edit Selection command 324
Play Timeline Selection command 324
Redo command 273
Repeat command 359
Repeat to Fill Selection command 357
Select All command 311
Separate Region commands 328
Shift command 347
Strip Silence command 391, 392
TCE Edit to Timeline Selection command 323
Thin Automation command 604
Trim Automation to Current command 628
Trim Region End to Fill Selection command 332
Trim Region End to Insertion command 331
Trim Region Start to Fill Selection command 331
Trim Region to Fill Selection command 332
Trim Region to Selection command 331
Undo command 273
Write Automation commands 626, 627
Edit mode buttons 280
Edit modes 280
and edit commands 354
and placing regions 334
Grid 282
Relative Grid 282
Shuffle 281
Shuffle Lock 281
Slip 281
Spot 281, 691
edit playlists 270
Edit Selection Follows Region List Selection option 67, 311
Edit Selection indicators 26, 315
Edit selections
auditioning with Playhead enabled 324
copied from Timeline selection 323
copied to Timeline selection 323
sliding in the Ruler 318
edit smoothing, with Beat Detective 454
Edit tools 26, 283
Grabber 283, 312
Pencil 283, 361
Scrubber 283, 296
Selector 283, 301
Smart Tool 283
Trim 283, 289
Zoomer 283, 284
Edit window 23, 25
All Views option 532
half-screen 308
None Views option 532
scrolling from the Ruler 305
Views option 23
Edit Window Default Length preference 60
Edit Window Follows Bank Selection option 69
Edit Window option 23
Edit Window view options 532
Edit Window View selector 532
editing
across multiple tracks 357
and Edit modes 280
and Grid modes 343
and hidden tracks 109
and Track View 353
automation 606
Bar|Beat Markers 419
breakpoints 607
controller events 473
during playback 253
Grid mode 282
in MIDI Event List 518
Markers 433
Memory Locations 433
meter events 421
MIDI notes 465
MIDI regions 264
nondestructively 253
nondestructively for audio 262
nondestructively for MIDI 264
note attributes 469
note durations 498
note velocities 468, 496
program changes 477
regions as grid 283
Shuffle Lock mode 281
Shuffle mode 281
Index 739

File menu
  Bounce to Disk command 638
  Close Session command 58
  Exit command (Windows) 58
  Export MIDI command 159
  Export Selected Tracks as OMF/AAF command 153
  Export Session Info as Text command 153
  Import Audio to Track command 140
  Import MIDI command 157
  Import Region Groups command 160
  New Session command 49
  New Track command 197, 220
  Open Session command 51
  Revert to Saved command 53
  Save As command 53
  Save command 53
  Save Copy In command 54, 169
  Send via DigiDelivery 155

final mixdown 646
  Find command 277
  Find History 278
  Find Matching Tracks option 148
  Find Regions
    By Name 277
    Include Subsequently Added Regions 277
  finding regions 277
    Find History 278
  FireWire
    QuickTime DV25 playback 668
  First Selected MIDI Track preference 72
  Flatten Performance command 483, 495
  Forward and Play command 303
  Forward command 303
  frame rate
    pull up and pull down 683
  Frames View
    video track 654
  freewheeling time code 678
  Front Divergence 727
  Front/Rear Divergence 727

G
  generating time code 678, 686
  Glide Automation commands 614
  Global MIDI Playback Offset option 480
  Global MIDI Playback Offset preference 73
  Go to End button 29
  Grabber tool 312
    editing breakpoints with 407, 806
    Object Grabber 312
    selecting MIDI notes with 466
    Separation Grabber tool 329
  Grabber tools 283

Grid
  setting for MIDI editing 464
  Grid mode 282, 343
    Absolute 282, 343
    configuring 282
  Draw Grids in Edit Window option 283
  Regions/Markers option 283
  Relative 282, 343
  setting the Grid value 342
  suspending 343
  grid panners in Mix and Edit 720
  Grid value 342, 464
  Grid Value selector 282
  Grid/Groove Quantize command 483, 484
  Groove Quantize 489
  groove templates 448, 490
    applying 492
    mapping 493
  Group 129
  Group Assignment selector 528
  Group ID Indicator pop-up menu 129
  Group List 127
    hiding 128
    Keyboard Focus 36
    showing 128
  Group List pop-up menu 128
  Group Name pop-up menu 129
  Group Track command 130
  groups
    and automation editing 609
    and hidden tracks 109
    attributes 133
    control offsets 136
    creating 130
    deleting 132
    duplicating 132
    Edit Groups 130
    enabling 135
    keyboard selection 135
    linking Mix and Edit Groups 127
    Mix Groups 130
    modifying 131
    renaming 131
    unlinking Mix and Edit Groups 127
  Groups dialog 129

H
  H/W Buffer Size 42, 185
  H/W Insert Delay 93
  half-screen 308
  half-speed playback 214
  half-speed recording 214
  hard drives
    and Compacting Audio 395
    recording to system volume 189
    Round Robin Allocation 188
  hardware
    insert delays 93
    routing to Pro Tools 79
    updating I/O Setup after changing 83
  Hardware Buffer Size 42
  hardware I/O inserts 559
  hardware I/O sends 538

  Index 739

File menu
  Bounce to Disk command 638
  Close Session command 58
  Exit command (Windows) 58
  Export MIDI command 159
  Export Selected Tracks as OMF/AAF command 153
  Export Session Info as Text command 153
  Import Audio to Track command 140
  Import MIDI command 157
  Import Region Groups command 160
  New Session command 49
  New Track command 197, 220
  Open Session command 51
  Revert to Saved command 53
  Save As command 53
  Save command 53
  Save Copy In command 54, 169
  Send via DigiDelivery 155

final mixdown 646
  Find command 277
  Find History 278
  Find Matching Tracks option 148
  Find Regions
    By Name 277
    Include Subsequently Added Regions 277
  finding regions 277
    Find History 278
  FireWire
    QuickTime DV25 playback 668
  First Selected MIDI Track preference 72
  Flatten Performance command 483, 495
  Forward and Play command 303
  Forward command 303
  frame rate
    pull up and pull down 683
  Frames View
    video track 654
  freewheeling time code 678
  Front Divergence 727
  Front/Rear Divergence 727

G
  generating time code 678, 686
  Glide Automation commands 614
  Global MIDI Playback Offset option 480
  Global MIDI Playback Offset preference 73
  Go to End button 29
  Grabber tool 312
    editing breakpoints with 407, 806
    Object Grabber 312
    selecting MIDI notes with 466
    Separation Grabber tool 329
  Grabber tools 283

Grid
  setting for MIDI editing 464
  Grid mode 282, 343
    Absolute 282, 343
    configuring 282
  Draw Grids in Edit Window option 283
  Regions/Markers option 283
  Relative 282, 343
  setting the Grid value 342
  suspending 343
  grid panners in Mix and Edit 720
  Grid value 342, 464
  Grid Value selector 282
  Grid/Groove Quantize command 483, 484
  Groove Quantize 489
  groove templates 448, 490
    applying 492
    mapping 493
  Group 129
  Group Assignment selector 528
  Group ID Indicator pop-up menu 129
  Group List 127
    hiding 128
    Keyboard Focus 36
    showing 128
  Group List pop-up menu 128
  Group Name pop-up menu 129
  Group Track command 130
  groups
    and automation editing 609
    and hidden tracks 109
    attributes 133
    control offsets 136
    creating 130
    deleting 132
    duplicating 132
    Edit Groups 130
    enabling 135
    keyboard selection 135
    linking Mix and Edit Groups 127
    Mix Groups 130
    modifying 131
    renaming 131
    unlinking Mix and Edit Groups 127
  Groups dialog 129

H
  H/W Buffer Size 42, 185
  H/W Insert Delay 93
  half-screen 308
  half-speed playback 214
  half-speed recording 214
  hard drives
    and Compacting Audio 395
    recording to system volume 189
    Round Robin Allocation 188
  hardware
    insert delays 93
    routing to Pro Tools 79
    updating I/O Setup after changing 83
  Hardware Buffer Size 42
  hardware I/O inserts 559
  hardware I/O sends 538

  Index 739
Hardware Setup 46
Analog In 47
Analog Out 47
Buffer Size 185
Clock Source 47
Digital Format 47
Ext. Clock Output 47
initializing Legacy I/O 48
Input Channel Selector 47
Meters pop-up menu for 96 I/O 47
Output Channel Selector 47
selecting multiple outputs 49
HD Accel 6
HD Core card 6
HD Process card 6
Heal Separation command 333
help
Bounce to Disk 645
Tool Tips 33, 60
HFS+ drives
and Windows systems 166
hidden tracks
and group edits 109
and groups 109
and selections 310
Hide and Make Inactive Track command 110
Hide/Show Track command 110
hiding
all tracks 108
auto-created regions 397
tracks 108
Highest QuickTime Playback Priority setting 64, 652
history (Find regions) 278
Horizontal Zoom In button 284
Horizontal Zoom Out button 284

I
I/O Labels (see I/O Setup)
I/O Settings 90
I/O Settings files
import and export 89
I/O Setup
and surround sessions 700
default settings 88
displaying unavailable I/O 88
factory settings files 90
import and export settings 89
importing for surround 701
initializing 85
last used 89
reset paths 83
settings files 88
Stereo Mix preset 90
surround mix examples 714
surround mix settings file 90
I/O Setup dialog 75, 78
resizing the window 75
I/O View 100, 533
Identify Beat command 416, 417
Identify Sync Point command 344, 696
Ignore Track Arming option 74
illegal characters 52, 165
Import Audio dialog 140
Import Audio to Track command 140
Import MIDI 157
Import Region Groups command 160
Import Session Data command 144
Import Settings button (I/O Setup) 89
Import Settings command (plug-ins) 571
importing
and converting audio 138
audio 137
audio and Conversion Quality 139
Markers 158
MIDI tracks 156
multichannel audio files from a field recorder 143
multichannel I/O Settings 701
plug-in settings 573
Pre settings 150
QuickTime audio 660
region groups 160
tempo and meter map 150
tracks for other sessions 144
inactive
inputs 112
items 19
making inserts 562
making plug-ins 20
Master Faders and assignments 527
outputs 112
paths 86
paths, global 86
sends 541
track path assignments 86
tracks 122
Include Control Changes in Undo Queue option 70
Include Sends in Trim Mode option 70
Includes Take Region Lengths That Match preference 67
Includes Take Region Names That Match Track Names preference 67
Incoming Time display 677
Infinite Clip Hold option 61
Infinite option
Clip Indication 101
Peak Hold 101
Infinite Peak Hold option 61
in-place auditioning 91
Input Channel Selector 47
input connections 16, 179
Input Devices command 216
Input Filter command 218
MIDI Event List View Filter dialog 515
MIDI Input Filter dialog 218
input levels 179
Input Only Monitoring mode 183
Input Path selector 100, 111
Input Quantize command 218, 483, 503
Input selectors 111
Insert Position selector 568
Insert Silence command 394
and Shuffle mode 394
and Slip mode 394
Insert Time command 422, 424
inserting
crashed events 473
in MIDI Event List 516
meter events 420
MIDI events 464
plug-ins during playback 564
plug-ins on tracks 563
program changes 477
tempo events 400
inserts 531, 559
as a shared bus 560
duplicating 567
for hardware I/O 559
for plug-ins 559
labeling 578
making inactive (and active) 562
mono 560
moving 567
on single tracks 560
post-fader on Master Faders 526, 560
shared within a submix 550
stereo 560
Inserts View 533
Instrument tracks 96
and surround mixing 710
channel strips 99
MIDI Input selector 118
MIDI Output selector 118
monitoring and mixing 548
Notes View 255
Regions View 255
signal flow 527
Instruments View 533
interlaced 685
Internal mode (Clock Source option) 676
internal side-chain processing 577
Inverse linked panning 545
Items to Copy 56

J
Jam Sync 679
Join command 586

K
key input 577
Key Input selector 569
Keyboard Focus 35
Commands 36
Group List 36
Region List 36, 279
keyboard shortcuts 576
for plug-ins 576
for global key commands 35
numeric entry 316
recording 200

L
labeling
inserts and sends 578
paths 82
Last Used 89
Latch Mode
AutoJoin 586
Join 586
Latch option 120
Latch Record Enable Buttons option 64
Latching Behavior for Switch Controls in “Touch” option 70
latency for recording and monitoring 184
LCRS path examples 703
LE systems 9
capabilities 10
QuickPunch 235
Legacy I/O 46
length, for selections 314
level faders
sends 537
Level meters
for audio tracks 101
for Aux Input, Master Fader, and Instrument tracks 101
for MIDI tracks 101
Levels of Undo preference 68, 275
LFE
enable in plug-ins 730
example sub-path 714
examples of discrete versus contribution 717
faders 730
LFE Enable button 569
Librarian menu 568
Limit To preference 66
linear crossfades 381
Linear Sample Display 409
Linear Tempo command 412
Linear Tick Display 409
Linearity Display Mode 409
Link Enable buttons 569
in multi-mono plug-ins 711
Link Mix and Edit Group Enables option 68
Link Record and Play Faders option 64, 184
Link Selection button 309, 310
Link Timeline and Edit Selection option 309
Link Track and Edit Selection option 105, 310
linking
inverse panning 545
multi-mono plug-ins 711
plug-in controls 575
stereo panners 544
Local Control 21, 217
locating
the playback cursor 306
with Fast Forward/Rewind 303
with Location indicators 305
Location Indicators 305
Location indicators
locating with 305
locations, for MIDI notes
dragging 467
quantizing 487
randomizing 486, 489
Lock Settings File command 571
Lock/Unlock Regions command 348
Locked indicator 677
Locked Track command 110
locking regions 348
Loop Playback option 321
and Touch mode 593
loop points 208
and Playback Markers 208
Loop Record mode 191, 205
loop recording
and pre/post-roll 204
audio 204
MIDI 225
drum machine style 225
multiple takes 226
Loop Trim tool 374
looped regions 370
copying and pasting automation 374
creating 371
editing 373
renaming 372
selecting 373
trimming 373
trimming with Loop Trim tool 374
unlooping 372
looping
playback 321
regions 370
selections 321
loops and reverb, delay 638
low latency monitoring.
Bounce to Disk 185
during recording 185
Low Latency Monitoring option 185

M
Mac sessions
compatibility with Windows 168
Machine Chases Memory Location option 73, 689
Machine Cues Intelligently option 73
Machine Follows Edit Insertion/Scrub option 73, 689
Machine Track Arming window 690
Main Counter selectors 267
Main Counters 267
main paths 76
Main Time Scale 266, 267, 682
Main Timebase ruler 266
Make Active command 122
Make Inactive command 122
managing regions 396
Manual Tempo mode 32, 196
Manually Find and Relink 164
mapping paths in I/O Setup 84
Markers 428
creating 430
creating on the fly 431
deleting 434
editing 433
exporting 159
extending selections to 315
importing 158
moving 433
sorting 436
tick-based and sample-based 429
viewing options 435
Markers ruler 265, 429
Master Faders
as master send level control 553
channel strips 98
inactive 527
inserts 560
meters pre/post fader 527
multichannel 710
post-fader inserts 526
signal flow 526
Master Link button 569
in multi/mono plug-ins 711
Master View for tracks 257, 611
mastering
digitally 647
to disk 646
Matches pop-up menu 206
Matching Start Time Takes List preferences 67
Mbox 9
Mbox 2 9
measures
renumbering 428
Medium QuickTime Playback Priority setting 64, 652
Memory for Automation Recording option 590
Memory Location dialog 428
Memory Locations 428, 429
creating 430
creating on the fly 431
deleting 434
deleting all 434
editing 433
extending selections to 315
Markers 428
recalling 432
recalling Edit selections 210
renaming 432
Selection Memory Locations 429
storing Edit selections 210
Memory Locations window 432
View Filter 435
viewing options for Markers 435
Merge mode (see MIDI Merge mode)
meter
current 420
default 194
display 32
meter events 420
editing 421
inserting 420
meter map
importing 150
Meter Path selector 90
Meter Ruler
displaying 420
extending an Edit selection to 421
meters
and control surfaces 90
pre/post fader levels 101
Sends View 540
SurroundScope plug-in 730
Meters options 61
Metronome Click button 31, 194
Mic Preamps View 533
MIDI 20
   common misconceptions 22
   Default Thru Instrument 217
   patch names 475
   select and split notes 501
   setting the Grid value for editing 464
   signal paths 22
MIDI channels 21
   assigning 117
MIDI clips and Region List 276
MIDI control surfaces 21
MIDI controller devices 21, 215
Local Control 21, 217
MIDI devices 21
MIDI Event List 513
   deleting events 519
   editing events 518
   inserting events 516
   navigating in 515
   Options menu 520
   selecting events 519
   View Filter 514
MIDI File Format pop-up menu 159
MIDI files (see Standard MIDI Files)
MIDI Input selector 100, 116, 220
   Instrument track 118
MIDI interface 21
MIDI Machine Control (MMC) 687
   configuring in Pro Tools 688
   controlling external devices with 687
   remote track arming 690
MIDI Merge 31, 192, 219
   Merge mode 192
MIDI Note Display options 73
MIDI notes
   attributes for 469
   chasing 479
   deleting 470
   duplicating selected 359
   editing 465
   durations 498
   pitch 467
   velocities 468, 496
   inserting 464
   lengths in ticks 268
   moving 467
   quantizing 489
   scrolling 263
   selecting 466
   splitting 501
   transposing 467, 500
   trimming start/end points 467
MIDI offsets 480
MIDI Operations commands 483
   Change Duration command 498
   Change Velocity command 496
   Flatten Performance command 495
   Grid/Groove Quantize command 484
   Input Quantize command 218, 503
   Restore Performance command 494
   Select/Unselect Notes command 502
   Step Input command 228, 503
   Transpose command 500
MIDI Operations window 483, 484
MIDI Output selector 100, 117, 221
   Instrument track 118
MIDI patch name files (.midnam) 475
MIDI Preferences 72
   Default Note On Velocity option 465
   Global MIDI Playback Offset option 480
   Pencil Tool Resolution When Drawing Controller Data
      option 473, 605
   Pencil Tool Resolution When Drawing Controller Data
      preference 73
MIDI Real-Time Properties 506
   on tracks and regions 510
   settings 508
MIDI recording 215
   cancelling takes 223
   enabling input devices 216
   Input Filter 218
   Merge/Replace mode 219
   monitoring with MIDI Thru 217
   quantizing on input 218, 503
   System Exclusive data 231
   undoing a take 223
   Wait for Note 219
MIDI regions 262
   and controller events 265
   and punch recording 225
   guidelines for editing 264
   MIDI Replace mode 31, 192, 219
MIDI Setup commands
   Input Devices command 216
   Input Filter command 218
   MIDI Beat Clock command 691
MIDI sound source 21
MIDI Step Input command 228
MIDI Studio Setup window 476
MIDI Thru command 217
MIDI tone generator 21
MIDI Track Offsets command 480
MIDI tracks
   and MIDI offsets 480
   assigning to multiple channels 221
   channel strips 99
   configuring for recording 220
   default program change 475
   input 116
   loop recording 225
   note chasing 479
   Notes View 265, 262
   output 117
   punch recording 223
   punching on the fly 224
   recording 215
   Regions View 255, 263
   selecting a pitch range in 502
   SysEx View 478
   Velocity View 468
   MIDI Volume fader 101
MIDI Zoom In button 284
MIDI Zoom Out button 284
Minimum Sync Delay option 690
Minutes:Seconds Time Scale 266
Mirror MIDI Editing 461
missing files 164
mix busses 170, 538
resetting 84

Index 743
Mix Groups 130
Mix window 23, 24
   All Views option 23, 532
   None Views option 532
   track controls 23
   track width 102
Mix Window Follows Bank Selection option 69
Mix Window option 23
Mix Window view options 532
Mix Window View selector 532
mixed file types 55, 138
mixing down to stereo 646
Mixing Preferences 68
   AutoMatch Time preference 71
Mixing Preferences page 24
   Touch Timeout option 69
MMC (see MIDI Machine Control)
Modify Group command 129
Modify Groups (Group List) command 128
Momentary Solo Latch option 121
monitoring
during punch recording 204
   indicator 29
   MIDI recording with MIDI Thru 217
   monitoring latency 184
monitoring modes 182
   Auto Input 182
   Input Only 183
mono
   Bounce to Disk 643
   inserts 560
   paths 81
   mono in/stereo out 560
Move Song Start command 422, 427
moving
   Bar|Beat Markers 418
   fades 386
   inserts 567
   Markers 433
   MIDI notes 467
   program changes 477
   regions with fades 387
   sysex events 478
MP3 file format 641
   MP3 Option 138, 641
MPEG-1 Layer 3 641
MTC (MIDI Time Code)
   outputting 678
multichannel plug-ins 560, 711
multichannel regions 254
multichannel tracks 197
   and automation 609
   dragging regions to 360
   names for 187
   replacing regions in 352
   signal routing 705
   splitting 360
multilingual application support 175
multi-mono
   plug-in Channel selector 711
   plug-ins 560, 710
Multiple mono 643
multiple outputs
   Hardware Setup 49
multiple tracks
   and Beat Detective 451
   audition takes 207
   editing across 357
   extending selections to 316, 317
   fitting audio regions to Edit selection 324
   nudging regions in 346
   pasting to 358
   selecting 316
   separating regions on 329
   shuffling regions on 338
multi-timbral 21
Music Production Toolkit 11
Mute Audio Inputs in Auto Input option 245
Mute automation 607
Mute button 121
Mute Frees Assigned Voice option 121, 122
Mute Overwrite/Extend 623
Mute Record-Armed Tracks While Stopped option 65, 245
Mute/Unmute Region command 349
muting
   regions 349
   tracks 121
MXF format 138, 641

N
Narrow Mix view option 102
New Group (Group List) command 128
New Memory Location dialog 210
New Session command 49
   and last used 89
New Track command 103, 197, 220
   New Tracks dialog 197
New Track Default Output selector 92
New Tracks dialog 103
Next Setting button 568
No Clip Hold option 61
no Clip Indication 101
No Output
   by deleting paths 84
   No Output option 537
   No Peak Hold option 61
   no Peak Hold option 101
   no scrolling during playback 307
   non-contiguous selections 312
   nondestructive editing 253
      for audio 262
      for MIDI 264
   Nondestructive Record mode 190
   nondestructive recording 201
      recording to a new playlist 202
      with QuickPunch 233
   nonlinear 13
   Non-Linear Transport Error Suppression option 74
Normal QuickTime Playback Priority setting 64, 652
Normal Zoom mode 285
Note Chasing option 479
notes (see MIDI notes)
Notes report 52
Index

Notes View 255, 262
MIDI and Instrument tracks 262
mini-keyboard 262
scrolling up or down 263
Nudge value 345
nudging 345
trimming regions by 332
by next Nudge value 346
multiple regions 346
region contents 347
regions with fades 387
selection range 314
selection start/end points 314
settings and regions 346
setting the Nudge value 345
Number of Voices 43
numeric entry
shortcuts 316
Numeric Keypad modes 37, 63
Classic 37
Shuttle 38, 298
Transport 38
Object Grabber 312
Object selections 312
offline regions 254
OMFI format 153
On Stop 618
Online button 28
Online options 66
online recording 686
on-the-fly punch recording
 MIDI tracks 224
QuickPunch 191, 233
Open Ended Record Allocation option 189
Open Ended Record Allocation preference 66
Open Session command 51
opening multiple plug-in windows 570
Operation Preferences 63
Audio During Fast Forward/Rewind option 303
Auto Regions Fade In/Out Length option 385
Edit Insertion Follows Scrub/Shuttle option 296
Link Record and Play Faders option 184
Machine Chases Memory Location option 689
Machine Follows Edit Insertion/Scrub option 689
Open Ended Record Allocation option 189
Record Online option 686
Use F11 for Wait for Note 219
Operation/Destination Track pop-up menus 147
Operations menu
Calibration Mode command 180
Link Timeline and Edit Selection option 309
Link Track and Edit Selection 105, 310
Low Latency Monitoring option 185
Optical
ADAT I/O 47
Optical (S/PDIF)
Hardware Setup 47
Options menu
Auto-Spot Regions command 693
Delay Compensation option 553
Destructive Record mode 202
Loop Value 345
Loop Track and Edit Selection option 105, 310
Loop Playback option 321
Loop Record mode 205
MIDI Thru command 217
Mirror MIDI Editing command 461
Mute Frees Assigned Voice option 121, 122
Pre/Post Roll option 212
Pre-Fader Metering option 101
Scrolling options 307
Solo Latch options 120
Transport Online command 686
Video Out FireWire Port command 669
Organize Plug-In Menus By options 61
Organize Plug-In Menus By options 565
Original Time Stamp 342, 694
Other Playlists menu 271
Output Channel Selector 47
Output Options
Conversion Quality option 644
Sample Rate 644
Output Path selector 100, 111
Output selectors 111
Output Window button 721
Output windows 535
outputs
default 5.1 paths and sub-paths 701
format and tracks 708
to multichannel paths 709
overlap crossfades 381
overlapping paths 86
Page Scrolling option 302, 307
Pan automation 607
Pan indicator 100
Pan slider 100
panning
3-knob 725
automation and groups 609
fine-adjust mode 725
grids 720
guidelines 713
linked stereo 544
multichannel automation playlists 730
take over in grid 725
trajectory 726
X/Y mode 725
Use Absolute Pan Linking option 68
Parabolic Tempo command 413
parallel mixing 708
pass-through point 585
Paste command 355
Paste Settings command 571
Paste Special commands
  Merge 356, 613
  Overwrite 613
  Repeat to Fill 613
  Repeat to Fill Selection 356
  To Current Automation Type 356, 613
pasting
  automation 613
  multiple data types 358
  plug-in settings 573
  selections and regions 355
  to multiple tracks 358
  with Repeat to Fill Selection command 357
Patch Select button 475
Patch Select dialog 475
paths
  active and inactive 86
  applying 85
  arranging 83
  audition 91
  creating and editing 81
  creating multichannel 702
  default mono and stereo 81
  default order 93
  default output 92
  for surround 712
  last used 89
  main 76
  mapping 84
  mono versus stereo 81
  multichannel example 85
  naming 82
  overlapping 86
  reset using Default 83
  selecting 83
  Stereo Mix preset 90
  sub-path surround examples 714
PCI bus activity 59
Peak Hold options 61
  3 Second 101
  Infinite 101
  None 101
Peak indicator 100
PEC/Direct Style Input Monitoring option 66
Pencil tool 283, 361, 462
  as Eraser 470
  drawing automation with 605
  editing breakpoints with 606
  Freehand 462
  inserting MIDI notes with 464
  Line 462
  Tempo editing 405
  Random 463
  repairing waveforms with 361
  resolution for inserted controller events 473
  selecting the Pencil tool shape 462
  shapes 462, 605
  Square 463
  Triangle 462
Pencil Tool Resolution When Drawing Controller Data option 473, 605
Pencil Tool Resolution When Drawing Controller Data preference 73
PFL (Pre Fader Listen) 119
Phase Invert button 569
pitch, for MIDI notes
  transposing 467
  transposing with Transpose command 500
Play button 28
Play Edit Selection command 320, 324
Play MIDI Notes When Editing option 72
Play Timeline Selection command 320, 324
playback
  no scrolling 307
  playback cursor 301
Playback Cursor locator 306
Playback Engine 674
  RTAS Processors setting 42
Playback Markers 208, 309
  and Edit selections 310
  and selection length 314
  and Timeline selections 322
Playhead 308
  and Edit selections 324
  and Timeline selections 324
  moving to region boundaries 325
playing
  and on-the-fly selections 312
  at half-speed 214
  Edit selections with Playhead enabled 324
  from a track point 302
  selections 320
  Timeline selections with Playhead enabled 324
  tracks 301
Playlist selector 16, 271
playlists 16, 270
  adding new 271
  and groups 272
  and multichannel tracks 609
  and nondestructive MIDI editing 264
  assigning 272
  automation playlists 270, 582, 591
  auto-naming 271
  changing timebase of 269
  deleting 272
  duplicating 271
  edit playlists 270
  Playlist selector 271
  recalling 272
  recording to new 202
  renaming 272
  setting pre/post-roll in 211
plug-in controls
  adjusting 576
  linking 575
Plug-In Controls Default to Auto-Enabled option 69
Plug-In Delay (dly) indicator 554
plug-in inserts 559
Plug-In selector
  for real-time plug-ins 568
plug-in settings librarian 571
Plug-In Settings menu 568
plug-in window
  closing multiple windows 570
  opening multiple windows 570
Plug-ins

"Organize Plug-in Menus By" 565
and pull rates 685
and surround mixing 710
automating 596
automation accuracy in bounce 645
bypassing from window 575
Category 565
Category and Manufacturer 566
Channel selector for multi-mono 711
creating a default setting 573
enabling automation 576
enabling for automation 596, 597
favorites 566
Flat List 565
for surround 711
inserting during playback 564
inserting on tracks 563
inserting on-the-fly 564
linking 711
linking and unlinking 575
making inactive (and active) 20
Manufacturer 566
mono-to-stereo 560
multichannel 560
multi-mono 560, 710
multi-processors 43
Next Setting button 568
Plug-ins Settings Select button 568
Previous Setting button 568
removing from tracks 564
RTAS Processors setting 42
Plug-ins Settings Select button 568
pops 214
post crossfades 376, 382
Post-Roll button 30
pre crossfades 376, 382
PRE settings
importing 150
Pre/Post Roll option 212
pre/post-fader inserts 560
pre/post-roll
and loop recording 204
and punch recording 203
auditioning 320
setting 211
Pre/Post-Roll Flags 212, 309
Pre-Fader Metering option 101
Preferences
DestructivePunch File Length 249
Mute Audio Inputs in Auto Input 245
Mute Record-Armed Tracks While Stopped 245
Tool Tips Display 33
TrackInput 184
TrackPunch 239
Preferences dialog 60
Prepare DPE Tracks 249
Pre-Process using Standard Conform 454
Pre-Roll button 29
Preserve Fades when Editing option 68
Preserve Folder Hierarchy command
Items To Copy
Preserve Folder Hierarchy 57
Previous Setting button 568

Pro Tools LE
file management 163
systems 9
Pro Tools LE systems 10
Pro Tools M-Powered 10, 11
Pro Tools session file icon 14
Pro Tools|HD Accel systems 6
Pro Tools|HD systems 6
audio capabilities 7
audio interfaces 8
file management 163
I/O capabilities 8
MIDI capabilities 7
QuickPunch 234, 235
TrackPunch 237
Pro Tools
video track
Frames View 654
processing bandwidth 59
Processing Preferences 71
Program Change dialog 475, 476
program changes 21, 474
and bank select 474
auditioning 478
chasing 479
default, for MIDI tracks 475
deleting 477
editing 477
inserting 477
moving 477
Progressive Scan 685
Project browser 164
pull up and pull down
and plug-ins 685
and rulers 685
audio 682
video 683
Punch Capture button 630
Punch In Frame Offset preference 74
Punch Out Frame Offset preference 74
punch points 208
and Playback Markers 208
Punch Preview button 629
punch recording
and monitoring 204
and pre/post-roll 203
audio 203
MIDI 223
MIDI on-the-fly 224
Q
Quantize
Real-Time Properties 508
Quantize command
experimenting with 489
Quantize Regions command
and Grid value 342
Quantize to Grid command 348
Quantize window 487
quantizing
MIDI notes 489
attacks vs. releases 486
MIDI on input 218, 503
QuickPunch 191, 233
crossfades 234, 239
LE systems 235
Pro Tools|HD systems 234
region/take numbering 236
QuickPunch Crossfade Length option 234, 239
QuickPunch Crossfade Length preference 68
QuickTime
and Avid 668
QuickTime audio formats 660
QuickTime file formats 641
QuickTime movies
optimizing for playback 670
playback quality 652
requirements 652
sync 660
QuickTime Playback Priority options
Highest setting 64, 652
Medium setting 64, 652
Normal setting 64, 652
R
randomizing
note durations 499
note locations 486
real-time editing 253
real-time plug-ins 539
Real-Time Properties
clearing 511
Delay 509
Display Events as Modified by Real-Time Properties option 72
displayed in the Edit window 512
displayed in the MIDI Event List 511
Duration 508
enabling 507
on tracks and regions 510
Quantize 508
region-based 510
settings 508
track-based 510
Transpose 510
Velocity 509
View 506
viewing 506
writing to regions 511
writing to tracks 510
Real-Time Properties View 506, 534
Real-Time Properties window 507
Rear Divergence 727
Recall Memory Location Selection at Original Track option 67
Recompute Invalid Overviews option 60
Record Enable button 29, 180, 190, 241
record enabling tracks 180
record modes 190
and MIDI 192
Destructive Record mode 191
Loop Record mode 191
Nondestructive Record mode 190
QuickPunch 191
switching with Transport Record Enable button 190
Record Online at Insertion/Selection option 66
Record Online at Time Code (or ADAT) Lock option 66
Record Online option 686
Record Pause mode 201
Record Safe mode 182
recording 197
a mono audio track 197
a stereo audio track 197
a submix to disk 637
additional takes 201
at half-speed 214
bouncing to disk 638
cancelling takes 200
destructively 202
DestructivePunch mode 250
from a digital source 212
from Record Pause mode 201
indicator 29
keyboard shortcuts 200
monitoring latency 184
multichannel tracks 197
multiple audio tracks 200
nondestructive 13
nondestructively 201
nonlinear 13
online 686
QuickPunch mode 233
status LED 241
System Exclusive data 231
to a new playlist 202
to the system volume 189
TrackPunch mode 236
undoing a take 199
with a countoff 194
with Round Robin Allocation 188
with the click 193
Redo command 273
Regenerate Missing Fades 164
region boundaries
extending selections to 315, 407
moving Playhead to 325
region definitions 152, 695
region group file format (.rgrp) 159, 369
region group files
exporting 369
importing 370
Region groups 254, 362
changing timebase format 366
creating 363
editing 367
exporting to different hard drives 162
fades and crossfades 368
importing 160
importing and exporting 159
mixed 364
multitrack 364
regrouping 364
separated 366
tick-based 366
timebase format 363
trimming 368
ungrouping 364
Region Groups folder 50
Region List 275
and MIDI clips 276
displaying file info for audio regions 276
dragging from 333
Export Regions as Files command 151
Find History 278
finding regions 277
Keyboard Focus 36
repeating a previous search 278
selecting regions 278
Region List Keyboard Focus 279
Region List menu 694
Auto Rename command 397
Clear command 398
Compact Selected command 395
Export Region Definitions command 152
Find command 277
Rename command 396
Selected Unused command 398
Show Auto-Created option 397
Sort By option 277
time stamping 694
Timeline Drop Order command 334
Region List Selection Follows Edit Selection option 67, 276, 311
Region menu
Bring to Front command 330
capture command 327
Identify Sync Point 696
Lock/Unlock command 348
Mute/Unmute command 349
Quantize to Grid command 348
Remove Sync Point command 344
Rename command 396
Send to Back command 330
Ungroup All Regions command 364
Ungroup Regions command 364
Region Name view option 259
Region Time view option 259
regions 15
aligning to region start points 336
auto-created 254
auto-naming options 397
auto-spotting 693
bringing to front 330
capturing 327
clearing 356
clearing Real-Time Properties 511
conforming with Beat Detective 452
consolidating 395
copying 354
creating 327
crossfading between 381
cutting 354
default names 186
displaying names 259
displaying region names 259
displaying times 259
dragging from Region List 333
dragging to multichannel tracks 360
duplicating 358
exporting as audio files 151
extending selections to include 315
finding 277
healing separations 333
inserting silence into 394
locking 348
looping 370
managing 396
moving in Grid mode 343
moving regions with fades 387
multichannel 254
muting 349
nudging 346
nudging regions with fades 387
offline 254
Original Time Stamp 342
pasting 355
placing at Edit insertion point 335
placing in tracks 333
quantizing 348
removing silence from 392
removing unused 398
renaming 396
repeating 359
replacing 349
selecting 311
selecting all in a track 311
sending to back 330
separating 328
separating with Beat Detective 450
separating with Separation Grabber 329
shifting 347
shuffling 338
on multiple tracks 338
sliding 337
slipping 340
snapping to 339
snapping to next 339
sorting 277
spotting 340, 693
sync points 344, 696
time stamping 694
trimming by Nudge value 332
trimming start/end points 290
trimming to Edit insertion point 331
trimming unwanted data from 331
User Time Stamp 342
user-defined 254, 396, 397
whole-file audio regions 254
Regions View 255, 263
related takes 206
and Separate Region command 207
preferences for 207
Relative Grid mode 282, 343
Remote Mode options 74
remote track arming 690
Remove DuplicateNotes command 481
Remove Sync Point command 344
removing
crossfades 382
plugins from tracks 564
sends 538
Rename command (Region List menu) 396
Rename Region command (Region menu) 396
Rename Track command 110
Renamed Audio Files
save copy in 165
renaming
auto-created regions 396
Memory Locations 412
playlists 272
regions 396
Renumber Bars command 428
Repeat command 359
Repeat to Fill Selection command 357
repeating selections and regions 359
Replace mode
Replace Region command 349
and multichannel tracks 352
Replace Region dialog 349
reset paths 83
Restore Performance command 483, 494
Return to Zero button 28
Revert to Saved command 53
Rewind
incrementally 303
locating with 303
Rewind button 28
Root Settings folder 571
specifying 572
Round Robin Allocation 188
RTAS plug-ins 560
additional latency 561
voice usage 561
RTAS Processors setting 42, 43
Ruler View selector 266
rulers
changing display order 266
Conductor rulers 265
displaying all 265
pull up and pull down 685
scrolling in 305
Timebase rulers 265
zooming in 286
Rulers View options 265
Bars:Beats Time Scale 266
Feet:Frames Time Scale 267
Minutes:Seconds Time Scale 266
Samples Time Scale 267
Time Code Time Scale 266

S
S/PDF
Hardware Setup 47
saving automation 591
sample rate 644
Sample Rate Conversion options 147
sample rate conversion quality 139, 644, 661
Sample Rate Conversion Quality preference 72
Sample Rate setting 44, 644
timing 268, 429
Samples Time Scale 267
Save As command 53
Save command 53
Save Copy In command 54, 169
saving a copy of a session 54
saving a session 53
saving plug-ins 572
Save Plugin Settings To command 572
Save Settings As command 571
Save Settings command 571
saving the session file with a new name 53
Scale Tempo command 415
scaling note velocities 469, 498
Scroll into View command 105
Scroll Into View Track command 110
Scroll To Track Banks Controllers option 69
Scroll To Track command 104, 307
scroll wheel
and MIDI track’s Note display 263, 289
zooming in the Edit window 289
Scrolling options 307
After Playback 307
Center Playhead 308
Continuous 308
None 307
Page 302, 307
Scrub Trim tool 292
Scrubber tool 283, 296
in Shuttle mode 297
selecting with 318
scrubbing 296
a single audio track 296
and edit cursor 296
on two audio tracks 297
playback speed and direction 296
resolution 296
video tracks 666
with Scrub Trim tool 292
with the Selector 296
S-Curve command 414
Select All command 311
Select Tracks in Group command 129
Select Unused Regions command 398
Select/Split Notes command 483, 501, 502
Split notes action 501
selecting

- a pitch range of notes 502
- across all tracks 317
- across multiple tracks 316
- all regions in a track 311
- all regions in all tracks 311
- during playback 312
- in MIDI Event List 519
- MIDI notes 466
- non-contiguous regions 312
- notes in a chord 502
- regions 311
- track material 310
- with Edit Selection indicators 315
- with Scrubber 318

Selection Changes Alternate Playlists 269
Selection commands
- Play Edit Selection 320
- Play Timeline 320
Selection Memory Location 429
- moving stored selection 433

selections

- across multiple tracks 311, 316
- and Bounce to Disk 638
- and Edit Groups 310
- and hidden tracks 310
- and Playback Markers 310
- auditioning start and end points 320
- changing length of 314
- clearing 356
- consolidating 395
- copying 354
- cutting 354
- duplicating 358
- extending 315, 407
- extending to the Meter Ruler 421
- extending to the Tempo ruler 401, 434
- including Conductor rulers 317
- looping 321
- moving to adjacent tracks 317
- moving to the next/previous region 318
- non-contiguous 312
- nudging 314, 346
- nudging start/end points 314
- Object 312
- on-the-fly 312
- pasting 355
- playing 320
- removing a track from 318
- repeating 359
- shifting 347
- storing with Memory Locations 429

Selector tool 283, 301
- scrubbing with 296
- selecting MIDI notes with 466

Send controls 537
- Send mute 537
- Send pan 537
- Send Pans Default to Follow Main Pan option 68
- Send to Back command 330
- Send via DigiDelivery command 155
- sends 537
  - adding 537
  - and multichannel mixing 709
- Assignment View 539

automating 595
- changing default setting 538
- copying track automation to 595
- default level 538
- displaying controls for 540
- for hardware I/O 538
- for mix busses 538
- labeling 578
- mono or stereo 538
- multichannel 709
- removing 538
- Sends Default to -INF option 68
- Sends View 533

Separate Region commands
- 328
  - and multiple tracks 329
  - and related takes 207
- At Selection 328
- At Transients 328
- On Grid 328

Separate Region Operates On All Related Takes option 207,
- 328

Separate Region Operates On All Related Takes preference 67
- Separation Grabber 329

session data
- importing 144
- Session Data to Import menu 148
- Session File Backups folder 51
- session files
  - concepts 14
- session parameters 55
- Session Setup window 676
  - Current TC 696

sessions 14
- audio format 676
- backups 51, 64
- bit depth 50, 676
- closing 58
- creating 49
- creating for surround mixing 700
- frame rate 677
- mixed audio formats 55
- opening 51
- opening from a Transfer volume 51
- sample rate 44, 50, 676
- saving 53
- start frame 676
- templates 57

Set As User Default command 571
Set Plug-In Default To command 571
Set Record Tracks to Auto Input command 184
Set Record Tracks to Input Only command 184
Set Root Settings Folder command 572
Set Servo Lock Bit at Play (Tamura Support) option 74
setting punch/loop points 208

settings
- choosing a destination for 572
- copying 573
- creating subfolders 572
- creating User Default 573
- importing 573
- pasting 573
- saving 573
- Settings Preferences command 571
Setup menu
  Click/Countoff Options dialog 193
  Disk Allocation 187
  I/O Setup 78
  MIDI windows 476
  Preferences command 60
  Session Setup 675
  Video Sync Offset command 669
Shift command 347
Shift dialog 347
shortcuts for keyboard input 576
Show All Tracks Group command 129
Show Auto-Created option 397
Show Only Tracks in Group command 129
Show Original Setup button 88
Show/Hide Region List button 275
Show/Hide Track List/Group List View button 107, 128
Show/Hide Tracks in Group command 129
Shuffle Lock mode 281
Shuffle mode 281
  and locked regions 348
  and moving regions 337
shuttle
  fixed mode option 298
Shuttle Numeric Keypad mode 38, 63, 298
Shuttle, Numeric Keypad mode 38
side-chain
  definition 577
  filters 577
  processing 569
signal flow
  audio tracks 524
  Auxiliary Inputs 525
  Instrument tracks 527
  Master Faders 526
signal routing
  and default path order 93
  basics for surround 709
  example 17
  surround examples 715
Single Zoom mode 286
SIP (Solo In Place) 119
Skip All 164
slices 438
sliding regions 337
Slip mode 281
  and moving regions 340
Smart Tool 283, 294
  and audio tracks 294
  and MIDI tracks 295
  and multichannel tracks 296
  creating crossfades with 294
  creating fades with 294
  editing automation with 295
  editing controller events with 295
Smooth and Thin Data After Pass option 69, 604
smoothing automation 589
SMPTE
  configuration 679
  start frame for session 676
Snap Pan to Speaker icons 724
Snap To Bar option 420
Snap To command 339
  snapping to the following or preceding region 339
snapshot automation 625
  adding to empty automation playlists 626
  and trim values 627
  writing over existing automation 626
SND resource file format 641
Soft Limit 47
Solo button 119
Solo Latch options 120
Solo modes 119
  selecting 120
Solo Safe mode 121
sololoing
  tracks 119
  tracks in a submix 553
Song Start Marker 399
  editing tempo 399
Spot dialog 341, 692
  Use Subframes option 692
  User Time Stamp button 694
Spot mode 281, 691
  and moving regions 340
  trimming regions in 694
spotting
  auto-spotting 693
  regions 340, 691, 693
SRC options 147
Stable LTC Source option 74
Standard MIDI Files 156
  exporting 158
  importing 156
  Type 0 156
  Type 1 156
Standard VCA Logic for Group Attributes option 70
start frame, for sessions 676
Start, End, and Length display 26, 209
stems 77
  surround examples 716
Step Input command 228, 483, 503
stepped control automation 607
stereo
  inserts 560
  interleaved files, exporting 152
Stereo Mix
  I/O Setup factory preset 90
  stereo tracks
    dragging regions to 360
    names for 186
    replacing regions in 352
    splitting 360
    Stop at Shuttle Speed Zero option 74
    Stop button 28
    Stretch Tempo command 416
Strip Silence command 391, 392
and region naming 392
Strip Silence window 391
stuck notes 481
Sub Counter selectors 267
Sub Time Scale 267, 682
subfolders, creating for settings 572
subframes 692
submixes
applying an insert to 550
bouncing to 646
bouncing to disk 637
soloing tracks in 553
sub-paths 77
examples for surround 712
Suppress Automation “Write To” Warnings option 70
surround
and sends 709
basic signal routing 709
center percentage (%) 728
configuring Pro Tools and sessions 700
discrete level, solo, mute 707
example 5.1 format paths 703
importing I/O Settings 701
pan playlists and automation 730
panning grids 720
settings files 700
using paths 712
using sub-paths, examples 712
SurroundScope 730
Suspend All Groups (Group List) command 128
suspending automation 601
writing automation 601
swing 487, 488
SYNC I/O
and VSO
generating time code with 686
resolving with 673
sync options 674
Sync Mode field 676
Sync Offset 679
Sync Point View option 344
sync points 696
for regions 344
from Beat Detective 455
identifying 344, 696
synchronization
black burst 697
MIDI Beat Clock 691
MMC 687
options 673
resolving 697
troubleshooting 696
Synchronization Preferences 73
Sysex View 478
system
settings 41
shutting down 41
starting up 41
System Exclusive data 22, 478
deleting 478
moving 478
recording 231
System Memory Allocation 45
system resources 18
System Usage window 59
View options 59
T
Tab to Transients button 319
take over (surround pan) 725
Take Region Lengths That Match option 207
Take Region Names That Match Track Names option 207
takes
auditioning 205
auditioning from Matches List 206
default names 186
numbering for QuickPunch 236
recording additional 201
Takes List pop-up menu
and multiple tracks 207
tapping in the tempo 196
Target button 569
Tascam DA30 47
Task Manager 142
TC/E Plug-In preference 71
tempo
current 400
default 195
display 32
effects on Markers and Memory Locations 429
Manual Tempo mode 196
tapping in 196
Tempo Edit Density pop-up menu 406
tempo events 400
and Bar|Beat Markers 418
editing 401
inserting 400
tempo map
from Identify Beat command 416
importing 150
Tempo Operations commands
Constant command 411
Linear command 412
Parabolic command 413
Scale command 415
S-Curve command 414
Stretch command 416
Tempo Operations window 410
Tempo Resolution selector 405
tempo ruler
displaying 400
extending an Edit selection to 401, 434
Tempo Ruler Enable button 31
Tempo slider 32
Tempo Sync 569
test 645
Thin Automation command 604
thinning automation 589, 604
tick-based timing 268, 429
time code
  and Jam Sync 679
capturing 692
generating 678, 686
Time Code Mapping options 146
Time Code Rate pop-up menu 677
Time Code Time Scale 266
Time Compression/Expansion plug-in 323
Time Compression/Expansion Trim tool 71, 290, 470
Time Grabber tool 313
Time Operations commands 422
  Change Meter command 423
  Cut Time command 426
  Insert Time command 424
  Move Song Start command 427
Time Operations window 420, 422
Time Scale 266
  Bars:Beats 266
  Feet:Frames 267
  Main 267, 682
  Minutes:Seconds 266
  Samples 267
  Sub 267, 682
  Time Code 266
Time Stamp command 206, 694
Time Stamp Selected command 342
time stamps 694
  and Bounce to Disk 638
Timebase rulers 265
  and selecting on all tracks 317
  and Timeline selections 322
  Edit Markers 309
  Playback Markers 309
  Pre/Post-Roll Flags 309
  sliding Edit selections 318
  sliding Timeline selections 323
Timeline and Edit selection, unlocked 308
Timeline Drop Order command 334
Timeline Insertion Follows Playback option 63
Timeline selections 322
  and Playback Markers 322
  auditioning with Playhead enabled 324
  copied from Edit selection 323
  copied to Edit selection 323
  in Timebase rulers 322
  sliding in the Ruler 323
  start, end, and length fields 30
 toggling
  track height 258
  Track View 257
  zoom level 289
Tool Tips 33, 60
Touch Timeout option 69
Track Compensation (cmp) indicator 555
track controls
  Edit window 26
  Mix window 26
track data 254
Track Height 258
  and Zoom Toggle 288
track layout
  default path order 93
  track level meters 101
Track List 107
  hiding 107
  showing 107
Track menu
  Auto Input Monitoring mode 183
  Clear All Clip Indicators command 101, 102, 540
  Delete command 105
  Duplicate command 106, 583
  Group command 130
  Input Only Monitoring mode 183
  Make Active command 122
  Make Inactive command 122
  New Track command 103
  Scroll to Track 104
  Scroll to Track command 307
  Set Record Tracks to Auto Input 184
  Set Record Tracks to Input Only 184
  Split into Mono command 360, 707
  Write MIDI Real-Time Properties command 511
Track Name Right-click pop-up menus 110
Track Name/Comments dialog 103
Track Number command 104, 307
Track Offset options 147
Track Position Numbers Stay with Hidden Tracks option 60
Track Record Enable indicator 29
Track selector 568
Track View 255
  and edit content 353
  Blocks 255
  changing 257
  Expanded Track Display 258, 609
  Master View 611
  Notes 255, 262
  Regions 255, 263
  Sysex 478
  toggling 257
  Velocity 468
Waveform 260
Track View selector 256
Track View Toggle 257
track width 102
TrackInput Monitor button 183
TrackInput Monitor indicator 29
TrackPunch 236
TrackPunch mode 237
TrackPunch preferences 239
tracks
  5.1 format track layout 706
  adding comments 104
  adding to selection 316, 317
  and surround 705
  appending new material to end of 202
  Color Coding options 123
  concepts 15
  converting multichannel tracks into mono tracks 707
  deleting 105
  duplicating 106, 583
  formats 96
  grouping 126
  hiding 108
  locating with Fast Forward/Rewind 303
  making inactive/active 122
  Master View 257, 611
  metering 101
  moving selections between 317

754 Pro Tools Reference Guide
muting 121
names 102, 186
placing regions in 333
playback priority 114
playing 301
record enabling 180
removing from a selection 318
scrolling shortcut 306
selecting across multiple 316
selecting all regions in 311
selecting all regions in all tracks 311
selecting material in 310
soloing 119
Track Height 258
Track View 255, 257
transposing 500
trimming unwanted data from 331
types 95
Tracks Group command 129
trajectory panning 726
Transfer files 164
transients
detecting with Beat Detective 442
tabbing to 319
Transport
Track Record Enable indicator 29
Track Input Monitor 29
Transport Master 689
Transport Master button 30
Transport Numeric Keypad mode 38, 63
Transport Online option 686
Transport Record Lock option 65, 239, 244
Transport view options 31, 209, 211, 301
Transport window 27
MIDI controls 31
pre/post-roll 29, 211
record status display 241
start, end, and length fields 30, 209
transport controls 27
Transpose
Real-Time Properties 510
Transpose command 483, 500
transposing 500
by octave 500
key 500
MIDI notes 467
tracks 500
Trim automation
coalescing 616
Trim Automation commands 628
Trim to All Enabled 628
Trim to Current 628
Trim Region commands
End to Fill Selection 332
End to Insertion 331
Start to Fill Selection 331
Start to Insertion 331
To Fill Selection 332
To Selection 331
Trim tools 283, 285, 408, 607
Scrub Trim tool 292
Time Compression/Expansion Trim tool 71, 290, 470
trimming
automation breakpoints 408, 607, 615
crossfades 382
note start/end points 467
region start/end points 290
regions by Nudge value 332
regions to Edit insertion point 331
regions with Scrub Trim tool 292
unwanted region and track data 331
Tweak Head setting 645, 661
U
unavailable I/O
showing 68
unavailable resources 52
Undo and audio recording 199
Undo command 273
Undo History window 274
Undo Queue 274
Ungroup All Regions command 364
Ungroup Regions command 364
Universe window 299
unlinked Timeline and Edit selection 308
unlinking plug-in controls 575, 711
Unloop Regions command 372
Use Absolute Pan Linking option 68
Use All Available Space preference 66
Use AudioSuite Dither option 71
Use AudioSuite Dither preference 557
Use Fill for Wait for Note option 72, 219
Use MIDI to Tap Tempo option 72
Use Squeezer option 645
Use Subframes option 692
User Default setting, creating 573
User Offset (+/-) field 554
User Time Stamp 342, 695
user-defined regions 254, 396, 397
V
Variable Speed Override 677
VCA Masters
assigning groups 530
channel strips 98
clearing 633
controls 529
creating 529
deleting 633
displaying automation 632
mixing 528
track type 96, 528
velocities, for MIDI notes
default for inserted 465
drawing with Pencil 469
drawing with Tool 468, 496
editing 468, 468
fading 497
scaling 498
scaling with Trim tool 469
Velocity
Real-Time Properties 509
Velocity View 468
video
recording limits with pull 685
Video Media options 146
Video Out FireWire Port command 669
Video Pull Up/Down 683
Video Sync Offset command 669
video track
viewing as blocks 655
video tracks
scrubbing 666
Video Universe window 300
View Filter
Memory Locations window 435
View Filter command 514
View menu
Edit Window view option 23
Edit Window view options 532
Mix Window option 23
Mix Window view options 532
Narrow Mix view option 102
Region Name view option 259
Region Sync Point View option 344
Region Time view options 259
System Usage view options 59
Track Number command 104, 307
Transport view options 31, 209, 211, 301
viewing blocks in the video track 655
views
Delay Compensation 102
I/O View 100
Inserts View 533
Sends View 533
Wide Meters View 102
Voice 24
Voice selector 114
voices
and RTAS 561
and track priority 114
auto-assignment of ascending 115
for TrackPunch 237
Volume automation 607
Volume fader 101
Volume indicator 100
VSO (see Variable Speed Override)

W
Wait for Note 31, 219
WAV file format 165, 640
AES31/Broadcast compliant 165
WaveCache.wfm file 50
Waveform View 260
waveforms 260
and zero-crossing 261
avoiding clicks and pops 261
drawn rectified 260
guidelines for editing 261
repairing with Pencil tool 361
Web site 4
whole-file audio regions 254
Wide Meters View 102
Window menu
Automation Enable command 592
Big Counter command 302
Color Palette 124
Disk Space command 190
Edit command 23
Machine Track Arming command 690
Memory Locations command 432
Mix command 23
Project command 164
System Usage command 59
Task Manager command 142
Transport command 27
Undo History command 274
Universe command 299
Workspace command 188
Windows sessions
compatibility with Mac 168
Word Clock 47
workflows 243
Workspace browser 188, 189
Write Automation command 627
Write Automation commands 626, 627
Write Automation To commands
Automation Preview mode 629
Write Automation to Next Breakpoint command 619
Write Automation to Next Breakpoint on Stop command 621
Write Automation to Selection/Selection Start/Selection End
buttons 617
Write MIDI Real-Time Properties command 511
writing
automation 592
automation on stop 618
automation to next breakpoint 619
automation to selection, selection start, or selection end
617
snapshot automation 625

X
XML (Extensible Markup Language) 475
X-OR (Cancels Previous Solos) Solo Latch option 121

Z
zooming 284
a track area 286
all the way out 285
around a track point 285
continuously 284
horizontally for all tracks 284
in the ruler 286
on a selection 285
recalling zoom levels 287
return to the previous zoom level 285
storing zoom levels 287
to make all regions visible 285
vertically for all audio tracks 284
vertically for all MIDI tracks 285
with a scroll wheel 289
Zoom Toggle 288
zooming without changing playlists 289