Pro Tools
Reference Guide

Version 6.0 for TDM or LE Systems on Macintosh
Version 5.3.x for TDM or LE Systems on Windows or Macintosh
Version 5.1.x for MIX or LE Systems on Macintosh

Digidesign
2001 Junipero Serra Boulevard
Daly City, CA 94014-3886 USA
tel: 650-731-6300
fax: 650-731-6399

Technical Support (USA)
tel: 650-731-6100
fax: 650-731-6384

Product Information (USA)
tel: 650-731-6102
tel: 800-333-2137

International Offices
Visit the Digidesign Web site
for contact information

Web Site
www.digidesign.com
## Contents

### Part I  Introduction

**Chapter 1. Welcome to Pro Tools** ................................................................. 3  
  The Pro Tools Guides ................................................................. 3  
  Compatibility Information ............................................................. 4  
  Digidesign Registration ................................................................. 4

**Chapter 2. Pro Tools System Configurations** ............................................... 5  
  TDM-Equipped Systems ................................................................. 5  
  Pro Tools LE Systems ................................................................. 9

**Chapter 3. Pro Tools Concepts** ............................................................ 11  
  Hard Disk Audio Recording ............................................................ 11  
  The Digidesign Audio Engine ........................................................ 11  
  Pro Tools Sessions ................................................................. 12  
  System Resources ................................................................. 16  
  MIDI Concepts ................................................................. 18

**Chapter 4. Pro Tools Windows** ............................................................. 21  
  The Mix Window ................................................................. 21  
  The Edit Window ................................................................. 21  
  The Transport Window ............................................................ 28

**Chapter 5. Keyboard Shortcuts** .......................................................... 33  
  Global Key Commands ............................................................. 33  
  Keyboard Focus ................................................................. 34  
  Numeric Keypad Modes ............................................................ 35
## Part II Sessions & Tracks

### Chapter 6. Sessions
- Starting Up or Shutting Down Your System .................................................. 39
- Configuring Pro Tools System Settings ............................................................ 39
- Configuring Pro Tools Hardware Settings ...................................................... 43
- Creating a New Session .................................................................................. 46
- Opening a Session ......................................................................................... 48
- Saving a Session ............................................................................................... 49
- Creating Custom Session Templates ............................................................... 52
- Closing a Session ............................................................................................. 54
- Quitting Pro Tools ............................................................................................ 54
- Sharing Sessions Between Pro Tools TDM Systems and Pro Tools LE Systems .................................................. 54
- Preferences ......................................................................................................... 55

### Chapter 7. I/O Setup
- The I/O Setup Dialog ....................................................................................... 68
- Routing Hardware I/O to Pro Tools I/O ............................................................ 69
- Creating and Editing Paths ............................................................................... 71
- I/O Settings Files ............................................................................................... 78
- Default Output, Meter, Audition, and Default Path Order I/O Setup Options .................................................. 80

### Chapter 8. Tracks
- Track Types ........................................................................................................ 83
- Track Controls ..................................................................................................... 86
- Creating Tracks .................................................................................................. 89
- Hiding Tracks ...................................................................................................... 90
- Assigning Inputs and Outputs to Tracks ............................................................ 92
- Track Priority and Voice Assignment ............................................................... 93
- Setting MIDI Input and Output ....................................................................... 96
- Soloing and Muting Tracks ............................................................................. 97
- Making Tracks Inactive ................................................................................... 99
- Adjusting Track Width ..................................................................................... 99
- Color Coding Tracks ....................................................................................... 100
- Grouping Tracks .............................................................................................. 100
Chapter 9. Importing and Exporting Session Data .............................................. 105
  Importing Audio ................................................................. 105
  Importing Tracks ............................................................... 108
  Importing Tracks and Track Attributes ............................................ 111
  Loading Audio Files with Drag & Drop ......................................... 118
  Exporting Audio ................................................................. 118
  Transferring Audio from CD .................................................... 120
  Conversion Quality ............................................................. 121
  Exporting Pro Tools Tracks as OMF Files ...................................... 122
  Exporting Session Text .......................................................... 122
  Importing MIDI Files ............................................................ 124
  Exporting MIDI Files ............................................................ 125

Chapter 10. File Management and Compatibility ............................................. 127
  Audio File Management .......................................................... 127
  WAV File Compatibility .......................................................... 130
  Avid File Compatibility .......................................................... 130
  Creating Mac and PC Compatible Sessions ...................................... 130
  Moving Sessions Between Platforms with MacOpener ......................... 132

Part III  Recording

Chapter 11. Record Setup ......................................................................... 135
  Input Connections and Audio Levels ................................................ 135
  Record Enabling Tracks (Using the Record Enable Button) .................... 136
  Monitoring Modes ....................................................................... 138
  Monitoring Latency ....................................................................... 139
  Default Track Names ..................................................................... 140
  Allocating Hard Drive Space for Recording ...................................... 141
  Allocating Hard Drive Space for Recording ...................................... 141
  Record Modes .............................................................................. 143
  Recording with the Click ................................................................ 146
  Setting the Default Meter ................................................................ 147

Chapter 12. Basic Audio Recording .............................................................. 151
  Recording an Audio Track ............................................................. 151
  Record Shortcuts ........................................................................... 155
  Recording Multiple Audio Tracks ..................................................... 155
  Record Pause Mode ....................................................................... 156
  Recording Additional Takes ............................................................ 156
  Punch Recording Audio .................................................................. 158
  Loop Recording Audio .................................................................... 159
| Chapter 16. Playing and Selecting Track Material | 217 |
| Playing Tracks | 217 |
| Scrolling Options | 220 |
| The Scrubber | 221 |
| Separate Edit and Timeline Selections | 223 |
| Selecting Track Material | 224 |
| Playing Selections | 224 |
| Timeline Selections | 225 |
| Playing Edit and Timeline Selections with the Playhead | 236 |

| Chapter 17. Working with Regions and Selections | 239 |
| Creating New Regions | 239 |
| Healing a Separation | 242 |
| Placing Regions in Tracks | 242 |
| The Trimmer Tool | 245 |
| The Time Trimmer | 246 |
| Sliding Regions | 249 |
| Nudging | 253 |
| Shift Command | 255 |
| Quantizing Regions | 256 |
| Locking Regions | 256 |
| Muting/Unmuting Regions | 257 |
| Edit Commands | 257 |
| Duplicate Command | 260 |
| Repeat Command | 261 |
| Merge Paste Command | 262 |
| Editing Stereo and Multichannel Tracks | 262 |
| Processing Audio with AudioSuite Plug-Ins | 263 |
| Waveform Repair with the Pencil Tool | 264 |
| The Smart Tool | 265 |

| Chapter 18. Advanced Editing | 267 |
| Replacing Regions | 267 |
| Repeat Paste To Fill Selection | 269 |
| Compress/Expand Edit To Play | 269 |

| Chapter 19. Fades and Crossfades | 271 |
| Using Crossfades | 271 |
| Creating a Crossfade | 279 |
| Creating Fades at the Beginnings and Ends of Regions | 279 |
| Using AutoFades | 280 |
| Creating Fades and Crossfades in Batches | 281 |
Chapter 28. Automation ................................................................. 421
  Automation Quick Start .......................................................... 421
  Automation Playlists ............................................................... 422
  Automation Modes ................................................................. 423
  Automation Preferences .......................................................... 426
  Viewing Automation ............................................................... 428
  Writing Automation ............................................................... 429
  Enabling and Suspending Automation ....................................... 432
  Deleting Automation ............................................................. 434
  Thinning Automation ............................................................. 434
  Drawing Automation ............................................................. 435
  Editing Automation ............................................................... 436
  Writing Automation to the Start, End or All of a Selection .......... 442
  Trimming Automation ............................................................ 444
  Creating Snapshot Automation ............................................... 445

Chapter 29. Mixdown ................................................................. 449
  Recording to Tracks ............................................................... 451
  Bounce to Disk ................................................................. 452
  Bounce Options ................................................................. 453
  Recording a Submix (with Bounce To Disk) ............................... 461
  Final Mixdown (with Bounce To Disk) ...................................... 462
  Mastering ................................................................. 463

Part VII                  Surround

Chapter 30. Surround Concepts .................................................. 467
  Mixing Formats and Surround Formats ..................................... 467
  Pro Tools Mixing Formats .................................................... 468
  Speaker Layouts ................................................................. 468
  Surround Monitoring ............................................................ 470
  Formats and Terminology ..................................................... 471
  Surround Mixing Concepts .................................................... 474

Chapter 31. Pro Tools Setup for Surround ..................................... 477
  Pro Tools Audio Connections for 5.1 Mixing ............................. 477
  Configuring Pro Tools for Multichannel Sessions ...................... 478
  Default Selectors in I/O Setup ............................................... 482
  5.1 Track Layouts, Routing, and Metering ............................... 482
Chapter 32. Multichannel Tracks and Signal Routing ........................................ 483
  Multichannel Quickstart ................................................................. 483
  Multichannel Audio Tracks ............................................................. 483
  Multichannel Signal Routing ........................................................... 486
  Paths in Surround Mixes ................................................................. 488
  Example Paths and Signal Routing for a Surround Mix ......................... 491

Chapter 33. Surround Panning and Mixing ................................................. 495
  Introduction to Pro Tools Surround Panning ........................................ 495
  Output Window .............................................................................. 496
  Standard Controls ......................................................................... 497
  Surround Panner Controls ............................................................... 498
  Panning Modes ............................................................................. 500
  LFE Faders in Multichannel Panners ............................................... 503
  Divergence and Center Percentage ................................................... 503
  SurroundScope Metering Plug-In ..................................................... 506

Part VIII       Synchronization

Chapter 34. Synchronization Concepts ..................................................... 509
  Synchronization Requirements ........................................................ 509
  Aspects of Synchronization .............................................................. 509
  Synchronizing Pro Tools ................................................................. 510
  SMPTE Frame Formats .................................................................... 513
  Working with Film-Originated Material ............................................. 514

Chapter 35. Time Code Synchronization ................................................... 519
  Pro Tools Synchronization Options .................................................. 519
  Session Setup Window ................................................................... 520
  Preparing to Work with SMPTE ....................................................... 525
  Configuring Pro Tools for SMPTE .................................................... 526
  4% Pull Up and Pull Down ............................................................ 527
  Configuring Pull Up and Pull Down Using SYNC I/O or USD ............... 533
  Putting Pro Tools Online ............................................................... 533
  Generating Time Code ................................................................. 534
  Using MIDI Machine Control ......................................................... 535
  Synchronizing a Sequencer to Pro Tools on Macintosh OS 9 ............... 537
  Synchronizing a Sequencer to Pro Tools in Windows ......................... 539
  Setting Minimum Sync Delay ......................................................... 539
  Remote Track Arming ................................................................. 540
  Synchronizing Pro Tools to an OMS-Compatible Sequencer Using MMC 540
  MIDI Beat Clock ........................................................................ 542
Part I: Introduction
Welcome to Pro Tools®. Pro Tools integrates powerful multitrack digital audio and MIDI sequencing features, giving you everything you need to record, arrange, edit, mix, and master quality audio for music, video, film, and multimedia.

The Pro Tools Guides

Your Pro Tools System includes the following guides:

**Getting Started Guide** Instructions for installing your Pro Tools system and connecting your studio.

**Pro Tools Reference Guide** Full details on all Pro Tools functionality and operations. (Pro Tools LE systems only include an electronic PDF version of this guide.)


**DigiRack™ Plug-Ins Guide** Instructions for using the DigiRack plug-ins (included with Pro Tools) for both real-time and file-based audio processing in Pro Tools. (Pro Tools LE systems only include an electronic PDF version of this guide.)

**Digidesign Plug-Ins Guide** Electronic PDF guide with instructions for using optional Digidesign plug-ins for both real-time and file-based audio processing in Pro Tools.

**Digidesign and DigiBase Pro Guide** Full details on using Pro Tools DigiBase databasing and browsers for data and media management. (Pro Tools LE systems only include an electronic PDF version of this guide.)

**Pro Tools MIDI Control Surfaces Guide** Electronic PDF guide that includes instructions for operating Pro Tools with various MIDI control surfaces.

**Expanded Systems Guide (TDM Systems Only)** Instructions for expanding a Pro Tools TDM system with optional Digidesign cards, or an expansion chassis.

**MachineControl Guide (TDM Systems Only)** Instructions for using MachineControl software for Pro Tools to enable serial communication with remote audio and video machines.

**Keyboard Shortcut Cards** Separate electronic PDFs for Macintosh and Windows that list the many keyboard shortcuts not shown in the Pro Tools menus.

Digidesign also provides guides with audio interfaces, optional dedicated controllers (such as Control|24 and ProControl) and other Digidesign options, (such as MIDI I/O, PRE, and SYNC I/O). Refer to the separate guide provided with the Digidesign optional product.
Conventions Used in These Guides

The Pro Tools guides use the following conventions to indicate menu choices and key commands:

<table>
<thead>
<tr>
<th>Convention</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>File &gt; Save Session</td>
<td>Choose Save Session from the File menu</td>
</tr>
<tr>
<td>Control+N</td>
<td>Hold down the Control key and press the N key</td>
</tr>
<tr>
<td>Option-click</td>
<td>Hold down the Option key and click the mouse button</td>
</tr>
<tr>
<td>Right-click (Windows)</td>
<td>Click with the right mouse button</td>
</tr>
</tbody>
</table>

The following symbols are used to highlight important information:

💡 User Tips are helpful hints for getting the most from your Pro Tools system.

⚠️ Important Notices include information that could affect your Pro Tools session data or the performance of your Pro Tools system.

🔍 Shortcuts show you useful keyboard or mouse shortcuts.

➡️ Cross References point to related sections in the Pro Tools Guides.

Compatibility Information

Digidesign can only assure compatibility and provide support for hardware and software it has tested and approved. For a list of Digidesign-qualified computers, operating systems, and third-party devices, refer to the latest compatibility information on the Digidesign Web site (www.digidesign.com).

Digidesign Registration

Be sure to complete and return the registration card included with your Pro Tools system. Registered users will receive periodic software update and upgrade notices. Please refer to the registration card for technical support and warranty information.
Chapter 2: Pro Tools System Configurations

There are two types of Pro Tools systems: TDM and LE. These refer to both the Pro Tools software and its hardware interfaces, as follows:

- **TDM** = Pro Tools TDM software for Pro Tools|HD-series, Pro Tools|24 MIX-series, or Pro Tools|24 hardware.
- **LE** = Pro Tools LE software for Digi 002, Digi 001, Mbox, or Toolbox hardware.

### TDM-Equipped Systems

Pro Tools TDM-equipped systems are available in the following configurations. Each system requires at least one Digidesign audio interface (sold separately). TDM systems can be expanded by adding Digidesign cards to increase track count, add to the amount of possible plug-in and mixer processing, and connect additional audio interfaces.

⚠️ *Pro Tools system performance depends on factors such as computer processor speed, amount of system memory, and hard drive performance. Contact your Digidesign dealer or visit Digidesign’s Web site for the latest system requirements and compatibility information.*

#### HD-Series Systems

**Pro Tools|HD 1**

Includes:
- HD Core card
- Pro Tools TDM software

**Pro Tools|HD 2**

Includes:
- HD Core card
- HD Process card
- Pro Tools TDM software

**Pro Tools|HD 3**

Includes:
- HD Core card
- Two HD Process cards
- Pro Tools TDM software
MIX-Series Systems

Pro Tools|24 MIX
Includes:
• MIX Core card
• Pro Tools TDM software

Pro Tools|24 MIXplus
Includes:
• MIX Core card
• MIX Farm card
• Pro Tools TDM software

Pro Tools|24 MIX3
Includes:
• MIX Core card
• Two MIX Farm cards
• Pro Tools TDM software

Pro Tools|24 System

Pro Tools|24
Includes:
• d24 Audio card
• DSP Farm card
• Pro Tools TDM software

Supported Audio Interfaces

HD-Series Only
The following audio interfaces are compatible with Pro Tools|HD-series systems:
• 192 I/O
• 192 Digital I/O
• 96 I/O

⚠️ Pro Tools|HD-series systems require the use of at least one 192 I/O, 192 Digital I/O, or 96 I/O.

HD-Series, MIX-Series and Pro Tools|24
The following Digidesign audio interfaces are supported with Pro Tools|HD-series, Pro Tools|24 MIX-series and Pro Tools|24 systems:
• 888|24 I/O and 882|20 I/O
• 1622 I/O
• 24-bit ADAT Bridge I/O or original ADAT Bridge I/O

⚠️ Audio interfaces that work with HD-series systems require the use of at least one 192 I/O, 192 digital I/O, or 96 I/O.

The original 888 I/O and 882 I/O audio interfaces work with Pro Tools|24 MIX-series and Pro Tools|24 systems only.
Chapter 2: Pro Tools System Configurations

TDM System Playback, Recording and Voice Limits

The following table lists the audio playback, recording, and voiceable track limits of each type of Pro Tools TDM system. Playback and recording voices refer to the number of unique simultaneous playback and record tracks on your system. Total voiceable tracks refers to the maximum number of audio tracks that can share the available voices on your system. Voice limits are dependant on the session sample rate, and the number of DSP chips dedicated to the system’s Playback Engine. Pro Tools HD-series systems can open sessions with up to 256 audio tracks (and Pro Tools|24 MIX-series or Pro Tools|24 systems can open sessions with up to 128 audio tracks), but any audio tracks beyond that system’s voiceable track limit will be automatically set to Voice Off.

Pro Tools|HD-series systems provide up to 128 Auxiliary tracks (Auxiliary Inputs); Pro Tools|24 MIX-series and Pro Tools|24 systems provide up to 64 Auxiliary Inputs.

All TDM-equipped Pro Tools systems provide a total of 64 internal mix busses. All TDM systems also provide 5 inserts and 5 sends per track, up to the DSP capacity of your system.

Table 1. Pro Tools|HD-series, Pro Tools|24 MIX-series, and Pro Tools|24 system audio playback, recording and voice limits

<table>
<thead>
<tr>
<th>Core System Type</th>
<th>Sample Rate (kHz)</th>
<th>Voices (Mono Tracks of Simultaneous Playback)</th>
<th>Mono Tracks of Simultaneous Recording</th>
<th>Total Voiceable Tracks</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pro Tools</td>
<td>HD 1</td>
<td>44.1/48</td>
<td>96</td>
<td>96</td>
</tr>
<tr>
<td></td>
<td>88.2/96</td>
<td>48</td>
<td>48</td>
<td>48</td>
</tr>
<tr>
<td></td>
<td>176.4/192</td>
<td>12</td>
<td>12</td>
<td>12</td>
</tr>
<tr>
<td>Expanded Pro Tools</td>
<td>HD 1, Pro Tools</td>
<td>HD 2, Pro Tools</td>
<td>HD 3</td>
<td>44.1/48</td>
</tr>
<tr>
<td></td>
<td>88.2/96</td>
<td>64</td>
<td>64</td>
<td>80</td>
</tr>
<tr>
<td></td>
<td>176.4/192</td>
<td>24</td>
<td>24</td>
<td>24</td>
</tr>
<tr>
<td>Pro Tools</td>
<td>24 MIX, Expanded Pro Tools</td>
<td>24 MIX, Pro Tools</td>
<td>24 Mixplus, Pro Tools</td>
<td>24 MIX</td>
</tr>
<tr>
<td>Pro Tools</td>
<td>24</td>
<td>44.1/48</td>
<td>32</td>
<td>32</td>
</tr>
<tr>
<td>Expanded Pro Tools</td>
<td>24</td>
<td>44.1/48</td>
<td>64</td>
<td>64</td>
</tr>
</tbody>
</table>
Audio Interfaces for TDM Systems

The following table lists the input and output capabilities of the various audio interfaces for TDM-equipped Pro Tools systems. In expanded Pro Tools|HD systems, audio interfaces can be combined for up to 96 audio inputs and outputs (for example, with one HD Core card, two HD Process cards, and six I/Os). In expanded Pro Tools|24 MIX systems, audio interfaces can be combined for up to 72 audio inputs and outputs (for example, with one MIX card, five MIX Farm cards, and six 1622 I/Os).

Table 2. Pro Tools TDM system audio interface channel capabilities

<table>
<thead>
<tr>
<th>Interface Type</th>
<th>Number of I/O Channels</th>
<th>Sample Rates (kHz)</th>
<th>A/D Conversion</th>
<th>D/A Conversion</th>
<th>Digital I/O</th>
</tr>
</thead>
<tbody>
<tr>
<td>192 I/O</td>
<td>16 in/16 out (Expansion port supports up to 16 channels of additional I/O)</td>
<td>44.1, 48, 88.2, 96, 176.4, 192</td>
<td>24-bit</td>
<td>24-bit</td>
<td>24-bit</td>
</tr>
<tr>
<td>192 Digital I/O</td>
<td>16 in/16 out</td>
<td>44.1, 48, 88.2, 96, 176.4, 192</td>
<td>None</td>
<td>None</td>
<td>24-bit</td>
</tr>
<tr>
<td>96 I/O</td>
<td>16 in/16 out</td>
<td>44.1, 48, 88.2, 96</td>
<td>24-bit</td>
<td>24-bit</td>
<td>24-bit</td>
</tr>
<tr>
<td>888</td>
<td>24 I/O</td>
<td>8 in/8 out</td>
<td>44.1, 48</td>
<td>24-bit</td>
<td>24-bit (or older 20-bit)</td>
</tr>
<tr>
<td>882</td>
<td>20 I/O</td>
<td>8 in/8 out</td>
<td>44.1, 48</td>
<td>20-bit</td>
<td>20-bit</td>
</tr>
<tr>
<td>1622 I/O</td>
<td>16 in/2 out</td>
<td>44.1, 48</td>
<td>20-bit</td>
<td>24-bit</td>
<td>24-bit</td>
</tr>
<tr>
<td>24-bit ADAT Bridge I/O</td>
<td>16 in/16 out</td>
<td>44.1, 48</td>
<td>None</td>
<td>24-bit</td>
<td>24-bit</td>
</tr>
<tr>
<td>Original ADAT Bridge I/O</td>
<td>16 in/16 out</td>
<td>44.1, 48</td>
<td>None</td>
<td>20-bit</td>
<td>24-bit (AES or S/PDIF), or 20-bit (Optical)</td>
</tr>
<tr>
<td>888 I/O</td>
<td>8 in/8 out</td>
<td>44.1, 48</td>
<td>18-bit (or older 16-bit)</td>
<td>18-bit</td>
<td>24-bit</td>
</tr>
<tr>
<td>882 I/O</td>
<td>8 in/8 out</td>
<td>44.1, 48</td>
<td>16-bit</td>
<td>16-bit</td>
<td>24-bit</td>
</tr>
</tbody>
</table>
Pro Tools LE Systems

Pro Tools LE-based systems are available in the following configurations:

**Digi 002**
A Digi 002 system includes:
- Digi 002 combined audio interface and controller
- Pro Tools LE software

**Digi 001**
A Digi 001 system includes:
- Digi 001 PCI card
- Digi 001 I/O interface
- Pro Tools LE software

**Mbox**
An Mbox system includes:
- Mbox audio interface
- Pro Tools LE software

**Digi ToolBox XP**
A Digi ToolBox system includes:
- Audiomedia III PCI card
- Pro Tools LE software

⚠️ The total processing capacity of a Pro Tools LE-based system depends on the processing power of your computer. Contact your Digidesign dealer or visit Digidesign’s Web site for the latest system requirements and compatibility information.
Pro Tools LE System Capabilities

The following table lists the playback, recording, and input and output capabilities of each Pro Tools LE-based system. All Pro Tools LE systems are limited to 32 or 24 mono audio tracks, as noted in Table 3. If you open a Pro Tools session created on a TDM system containing more than the number of tracks supported on the LE-based system, audio tracks beyond that system’s voiceable track limit will be automatically set to Voice Off (Pro Tools 6.0 or higher), or will not open (Pro Tools 5.3.3 or lower). For example, with a Digi 002, when opening a 64 track session created on a TDM system, only the audio tracks assigned to the first 32 voices will open; if you save the session using Pro Tools LE, any audio tracks beyond the available 32 voices will be set to Voice Off (Pro Tools 6.0 or higher) or lost (Pro Tools 5.3.3 and lower).

All Pro Tools LE systems provide a total of 16 internal mix busses. Pro Tools LE also provides up to 5 inserts and 5 sends per track, depending on your computer’s processing capacity.

Table 3. Pro Tools LE system audio playback, recording, and channel capabilities

<table>
<thead>
<tr>
<th>System Type</th>
<th>Mono Tracks of Simultaneous Playback</th>
<th>Number of I/O Channels</th>
<th>A/D Conversion</th>
<th>D/A Conversion</th>
<th>Digital I/O</th>
</tr>
</thead>
<tbody>
<tr>
<td>Digi 002</td>
<td>32</td>
<td>up to 18 in/18 out (at 48 kHz or lower) 10 in/10 out (at 96 kHz)</td>
<td>24-bit</td>
<td>24-bit</td>
<td>24-bit</td>
</tr>
<tr>
<td>Digi 001</td>
<td>32 (Pro Tools 6.0 or higher and Pro Tools 5.3.1 or higher on Windows) 24 (Pro Tools 5.2 or lower)</td>
<td>up to 18 in/18 out</td>
<td>24-bit</td>
<td>24-bit</td>
<td>24-bit</td>
</tr>
<tr>
<td>Mbox</td>
<td>32 (Pro Tools 6.0 or higher and Pro Tools 5.3.3 or higher on Windows) 24 (Pro Tools 5.2)</td>
<td>up to 2 in/2 out</td>
<td>24-bit</td>
<td>24-bit</td>
<td>24-bit</td>
</tr>
<tr>
<td>Audiomedia III</td>
<td>32 (Pro Tools 6.0 or higher and Pro Tools 5.3.1 or higher on Windows) 24 (Pro Tools 5.2 or lower)</td>
<td>up to 4 in/4 out</td>
<td>18-bit</td>
<td>18-bit</td>
<td>24-bit</td>
</tr>
</tbody>
</table>

For details on transferring session material between Pro Tools LE and Pro Tools TDM systems, see “Sharing Sessions Between Pro Tools TDM Systems and Pro Tools LE Systems” on page 54.
Chapter 3: Pro Tools Concepts

Pro Tools is based on simple concepts which are easy to grasp. Many of them you may already be familiar with. This chapter explains the principals and concepts that form the foundation of Pro Tools operation and functionality.

**Hard Disk Audio Recording**

Tape-based recording is a linear medium—you need to rewind or fast forward a tape to hear a particular spot in a recording. To rearrange or repeat material in a linear system, you need to re-record it.

Hard disk recording is a non-linear (or random access) medium—you can go immediately to any spot in a recording without having to rewind or fast forward.

Non-linear systems have several advantages. You can easily rearrange or repeat parts of a recording by making the hard disk read parts of the recording in a different order and/or multiple times. In addition, this re-arrangement is nondestructive, meaning that the original recorded material is not altered.

Pro Tools is a non-linear recording system that lets you rearrange and mix recorded material nondestructively.

**The Digidesign Audio Engine**

DAE (or Digidesign Audio Engine) is Digidesign’s real-time operating system for digital recording systems. When you install Pro Tools, DAE is automatically installed on your system (and can be accessed from within Pro Tools).

In the same way that a computer’s operating system provides the foundation for programs that run on the computer, DAE provides much of the hard disk recording, digital signal processing, mix automation, and MIDI functionality required by Pro Tools and other products from Digidesign and its Development Partners.

The DAE Playback Buffer Size determines the amount of memory allocated within DAE to manage disk buffers, which affects system performance. For more information, see “DAE Playback Buffer Size” on page 41. The DAE Playback Buffer Size can be changed in the Playback Engine dialog, discussed below.

**Playback Engine Dialog**

Pro Tools takes advantage of your computer’s host processor for certain tasks and optional host-based DSP processing.
Pro Tools LE uses host (CPU) processing to provide audio track recording, playback, mixing, and effects processing. Pro Tools TDM can also use host processing to run RTAS plug-ins for effects processing. Performance is determined by your system and its Playback Engine settings.

The Playback Engine dialog lets you set a hardware buffer size and allocate a percentage of CPU resources for these tasks. For more information, see “Configuring Pro Tools System Settings” on page 39.

The Playback Engine dialog is also where you select the number of voices (and voiceable tracks) for your system and its sessions. Voice count choices in the dialog are based on how much DSP processing you wish to allocate for voicing. For more information, see “Configuring Pro Tools System Settings” on page 39.

Session File

A session file is the document that Pro Tools creates when you start a new project. The session file contains maps of all elements associated with a project, including audio files, MIDI data, and all your edit and mix information. You can make changes to a session and save those changes in a new session file. This lets you create multiple versions of a project or back up your editing and mixing work.

Audio File

When you record audio into a Pro Tools session, audio files are created.

Pro Tools Sessions

When you start a project in Pro Tools, you create a session. Some basic elements of sessions are explained in this section.
Tracks

Pro Tools tracks are where audio, MIDI, and automation data are recorded and edited.

A region (or loop) is a piece of audio or MIDI data that may have associated automation data. A region could be a loop, a guitar riff, a verse of a song, a sound effect, a piece of dialog, or an entire sound file. In Pro Tools, regions are created from audio or MIDI files, and can be arranged in audio and MIDI track playlists.

Playlist

A playlist is a group of regions arranged on an audio or MIDI track. Tracks have edit playlists and automation playlists.

On audio tracks, an edit playlist tells the hard disk which audio files to read in what order. For example, you can use the same audio region to access the same piece of audio multiple times at different locations and not use additional disk space. If desired, different versions of the same original audio can be created to modify the length, fade-in, fade-out, and effects applied.

A playlist can be made up of a single region or many separate regions. It can be made up of similar elements, such as regions from several different takes of a solo, or dissimilar elements, such as several sound effects. You can create any number of edit playlists for a track. This lets you assemble different versions of performances or edits on a single audio or MIDI track and choose between them with a pop-up menu on the track.

Each track has a single set of automation playlists, for volume, pan, mute and each automation-enabled parameter for the insert and send assignments on that track.
Channel

The term *channel* is used to describe several related components of a Pro Tools system. The first example of channel refers to a physical input or output of your Pro Tools system.

For example, a 192 I/O audio interface (Figure 1) provides up to 16 channels of input and output to a Pro Tools|HD system. An 888|24 I/O audio interface provides eight channels of analog input and output to a Pro Tools TDM system.

The second use of the term *channel* refers to a mixer strip in the Pro Tools Mix window. The term *channel strip* refers to the mixer strip of any track (audio or MIDI track, Auxiliary Input, or Master Fader) in a session.

Audio and MIDI channel strips have similar controls, but those controls have slightly different effects. For example, audio and Auxiliary Input channel strip faders control the Pro Tools mixer, while MIDI channel strip faders send MIDI volume data (MIDI controller 7).

The term channel also describes a separate aspect of MIDI operation. See “MIDI Concepts” on page 18.
Signal Routing

Pro Tools provides software-based mixing and signal routing controls. The Mix window is where these controls are located. (Some of these controls can also be accessed from the Edit window, if desired.)

Signal Routing Example

A common signal routing task is to submix multiple tracks to a single channel strip (such as an Auxiliary Input or a Master Fader) for shared processing and level control. The following example shows three audio tracks submixed to a stereo Auxiliary Input.

Signal routing options include the following:

Track I/O Controls The most basic type of signal routing is track input and output. A track needs to have an assigned input path to record audio, and an assigned output path in order to be audible through a hardware output. Signals can also be routed to or from other tracks in Pro Tools (or hardware inputs and outputs) using internal busses.

Auxiliary Inputs and Master Faders Auxiliary Inputs are tracks that can be used as returns, submixers and bus masters. Master Faders are used as bus and output master level controls. Both Auxiliary Inputs and Master Faders can have inserts or plug-ins.

Sends Sends route audio to internal busses to send to other tracks in Pro Tools, or to hardware outputs.

Plug-Ins and Inserts Software plug-ins and hardware inserts process the audio on their associated track. Plug-in processing occurs completely within the Pro Tools system. Hardware inserts utilize audio interface inputs and outputs, for traditional insert routing to (and from) external effects and other devices.

Paths Pro Tools lets you define a group of multiple inputs, outputs, or busses that have a single name and (channel) format. These groups comprise the lists of available routing choices in track I/O Selectors and other menus. Paths can be very useful for assigning stereo and multichannel I/O routing or sub-paths within a path. See Chapter 7, “I/O Setup” for more information.

Mixing Formats Sessions can include combinations of mono, stereo, and multichannel format tracks, busses, inputs, outputs, and inserts. (Multichannel formats are supported on Pro Tools HD-series and MIX-series only.)
System Resources

Track count, plug-in processing, signal path and routing options, and voice availability are ultimately limited by the combined resources available from the host computer, and from your Pro Tools hardware.

Pro Tools provides several ways to manage and conserve resources to maximize the performance of your system. As you begin working with Pro Tools sessions and tracks, you can take advantage of the following features to extend the effectiveness of your available DSP and other resources:

- Pro Tools lets you adjust the performance of your system by changing system settings (such as CPU Usage and H/W Buffer Size) that affect its capacity for processing, playback, and recording. See “Configuring Pro Tools System Settings” on page 39.

- Active and inactive switching lets you selectively toggle items (such as tracks and inserts) between active (on) and inactive (off). This lets you precisely allocate DSP and other resources when developing playlists, tracks, and mixes. See “Active and Inactive Items” on page 16.

- Pro Tools TDM systems and Pro Tools LE 6.0 systems provide flexible voice options for disk tracks. For more information on voice management and options, see “Voiceable Tracks and Track Priority” on page 96.

Active and Inactive Items

Pro Tools lets you set certain items (such as audio tracks) as inactive, in order to free up DSP resources and mixer connections.

Items in Pro Tools that can be made inactive (or active) include the following:

- Audio tracks, Auxiliary Inputs, and Master Faders
- Track Inputs and Outputs
- Sends
- Side-chain inputs
- Plug-ins
- Hardware inserts
- Paths (session-wide)

MIDI tracks cannot be made inactive.

In addition to manually setting Active and Inactive modes, Pro Tools will automatically make items inactive if there are insufficient or unavailable resources.

When active, items are fully engaged and operational.

When inactive, items are silent and off, although most associated parameters can still be edited (changed). Different inactive items affect available system resources in specific ways, as follows:

Plug-Ins When a plug-in is inactive on a track, its DSP is made available for other plug-ins and processing. Plug-in assignments can be made inactive manually, or automatically (see “Automatic and Manual Inactive Mode” on page 17).

Paths and Path Assignments When a path or path assignment is inactive, its mixer resources are made available for other signal routing purposes in the session. Paths and assignments can be made inactive manually, or automatically (see “Automatic and Manual Inactive Mode” on page 17).
Tracks  For TDM systems (Pro Tools 5.1 and higher) and Pro Tools LE 6.0 only, when a track is inactive, its voice is made available for another track. Additionally, when an audio track, Auxiliary Input, or Master Fader is made inactive, its plug-ins, inserts, sends, and I/O assignments become inactive.

Display of Inactive Items

When items are inactive, their names appear in italics, and their background becomes dark grey. When a track is inactive (TDM systems only), the entire channel strip darkens.

Automatic and Manual Inactive Mode

Active and Inactive modes are powerful options for session transfer, and system resource management. Pro Tools provides automatic and manual Inactive mode switching. You can manually make items inactive (or active) to selectively manage system resources while editing and mixing.

Automatically Inactive Items

When opening a session, it is possible that not all signal paths, plug-ins, or audio interfaces used in the session will be available as defined on the current system. Whenever this occurs, the session will open as it was last saved. All items that are unavailable, or cannot be loaded due to insufficient resources, are made inactive.

Manual Inactive Switching

You can manually apply Active or Inactive modes to manage system resources. By making an item inactive, its associated resources are made available elsewhere in the session.

The following are basic instructions for manually making items inactive. Throughout the Pro Tools Reference Guide, instructions are provided whenever an item can be made inactive.

To toggle an item active or inactive:

- Command-Control-click (Macintosh) or Control-Start-click (Windows) the item.

You can apply Active or Inactive modes to all or all selected tracks using standard Pro Tools modifiers (Option and Option+Shift on the Macintosh, Alt and Alt+Shift in Windows). Side-chain inputs support direct active and inactive switching, but do not follow switching all or all selected.
MIDI Concepts

MIDI (Musical Instrument Digital Interface) is a communication protocol for musical instruments. This industry standard enables connections between a variety of devices from different manufacturers. Examples of MIDI-compatible equipment include synthesizers, sound modules, drum machines, patch bays, effects processors, MIDI interfaces, and sequencers.

MIDI devices are equipped with 5-pin DIN connectors, labeled as either IN, OUT, or THRU. The MIDI OUT port transmits messages; the MIDI IN port receives messages; and, MIDI THRU echoes whatever is received from the IN port. MIDI devices are connected with MIDI cables that are available at most music stores.

A single MIDI cable can transmit a separate set of messages for each of the 16 channels. These 16 channels correspond to separate MIDI devices or to multiple channels within a single device (if the device is multi-timbral). Each channel represents a discreet instrument sound; for instance, bass on channel 1, piano on channel 2, and drums on channel 10. Similar to a multitrack tape recorder, a MIDI sequencer can record complex arrangements—even using a single multi-timbral keyboard.

MIDI Terms

The following are some basic MIDI terms:

- **MIDI Interface** Hardware that lets computers connect to and communicate with MIDI devices.
- **MIDI Device** Any keyboard, sound module, effects device or other equipment that can send or receive MIDI information.
- **MIDI Controller** Any MIDI device that transmits MIDI performance data. These include keyboards, MIDI guitar controllers, MIDI wind instruments, and others. Controllers transmit MIDI from their MIDI OUT ports.
- **MIDI Control Surface** Any device, such as the Mackie HUI, that uses a MIDI connection to send control messages to a software program, but is not generally used to record MIDI information.
- **MIDI Sound Source** Any MIDI instrument capable of playing back MIDI-triggered sound. Sound sources receive MIDI from their MIDI IN ports.
- **Multi-Timbral** The capability of playing several different instrument sounds (such as piano, bass, and drums) simultaneously on separate channels. This makes it possible for a single MIDI sound source to play back entire arrangements.
- **MIDI Channel** Up to 16 channels of MIDI performance data can be transmitted on a single MIDI cable. The channel number separates the different messages so your sound sources can receive the right ones.
- **Program Change Event** A MIDI command that tells a sound source which of its sounds (or sound patches) to use. The MIDI protocol lets you choose from a range of 128 patches.
Bank Select Message Many devices have more than 128 patches, which are arranged in banks. The Bank Select Message is a MIDI command that specifies the bank of patches from which to choose.

Local Control A controller setting found on most MIDI keyboards that lets them play their own sound source. Disabling “local control” ensures that a device’s internal sound source is only played by external MIDI messages.

When using Pro Tools, “local control” should usually be disabled. When “local control” is off, your keyboard still transmits data to its MIDI OUT port.

Continuous Controller Events MIDI instructions that allow real-time changes to notes that are currently sounding. These include pitch bend, modulation, volume, pan, and many others.

System Exclusive Data MIDI data commonly used for sending and retrieving patch parameter information for storage purposes.

Common Misconceptions about MIDI

MIDI is not audio. The messages that travel down a MIDI cable are only numbers that translate to specific instructions. For instance, when you strike a key on your MIDI keyboard it sends a message to its MIDI OUT port telling another device (if connected and set to the same MIDI channel) to play that particular note.

Signal paths for MIDI instruments

However, to actually hear that second device (sound source) you’ll need to connect its audio outputs to a sound system. Your MIDI instruments have two signal paths, one for audio and another for MIDI.

MIDI does not allow you to use your devices beyond their capabilities. Particular instruments have their own sound generation, polyphony, and multi-timbral limitations.
Chapter 4: Pro Tools Windows

Pro Tools provides two complementary ways of viewing a session: the Mix window and the Edit window. Pro Tools also allows you to control the transport and transport-related functions from the Transport window.

Depending on which version of Pro Tools you have, the Mix window and Edit window will appear differently.

**Pro Tools 6.0**

For more information on the main elements of the Mix window and Edit window, see the page references provided in Figure 3 on page 22, and Figure 4 on page 23.

**Pro Tools 5.3.x and 5.1.x**

For more information on the main elements of the Mix window and Edit window, see the page references provided in Figure 5 on page 24, and Figure 6 on page 25.

---

**The Mix Window**

In the Mix window, tracks appear as mixer strips (or channel strips), with controls for inserts, sends, input and output assignments, volume, panning, record-enable, automation mode, and solo/mute. The following section explains each of these track controls.

To display the Pro Tools input/output controls, inserts, sends, and comments, select Display > Mix Window Shows > All.

To toggle between the Mix and Edit windows: On Macintosh, press Command+Equals (=); on Windows, press Control+Equals (=).

---

**The Edit Window**

The Edit window provides a timeline display of audio, as well as MIDI data and mixer automation for recording, editing and arranging tracks. As in the Mix window, each track has controls for record enable, solo, mute and automation mode.

Systems with the Pro Tools AVoption installed also provide a timeline display of the movie track.

To display the input/output controls, inserts, sends, and comments in the Edit window, select Display > Edit Window Shows > All. You can choose to display all of these items, or some of them.
Figure 3. Pro Tools Mix window (Pro Tools 6.0)
Figure 4. Pro Tools Edit window (Pro Tools 6.0)
Figure 5. Pro Tools Mix window (Pro Tools 5.3.x and 5.1.x)
Figure 6. Pro Tools Edit window (Pro Tools 5.3.x and 5.1.x)
Track Controls

Mix window, controls for audio and MIDI tracks, wide view (Pro Tools 6.0)

Mix window, controls for audio and MIDI tracks, wide view (Pro Tools 5.3.x and 5.1.x)

Edit window track controls, medium track height (Pro Tools 6.0)

Edit window track controls, medium track height (Pro Tools 5.3.x and 5.1.x)

Edit Tools

Edit tools in Edit window (Pro Tools 6.0)

Edit tools in Edit window (Pro Tools 5.3.x and 5.1.x)
**Event Edit Area**

The Event Edit Area provides time, pitch, and other information for the currently selected audio or MIDI data. It also lets you define selections via key entry.

The Start, End, and Length display can be set for a different Time Scale format (such as Bars:Beats, or Minutes:Seconds, and so on). For more information, see “Main Time Scale” on page 213.

**Location Indicators, Grid/Nudge Values, Current Cursor Display**

The Location Indicators, Grid and Nudge values, and timeline Cursor Location display provide navigation and editing options.
The Transport Window

The Transport window can be set to show basic transport controls, counters, and MIDI controls. The counters in the Transport window mirror the Location Indicators at the top of the Edit window.

Basic Transport Controls and Counters

<table>
<thead>
<tr>
<th>Control</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Online</td>
<td>Puts Pro Tools online so that playback and recording is triggered by an external time code source.</td>
</tr>
<tr>
<td>Return to Zero</td>
<td>Locates to the beginning of the session.</td>
</tr>
<tr>
<td>Online</td>
<td>Puts Pro Tools online so that playback and recording is triggered by an external time code source.</td>
</tr>
<tr>
<td>Return to Zero</td>
<td>Locates to the beginning of the session.</td>
</tr>
<tr>
<td>Stop</td>
<td>Stops playback or recording.</td>
</tr>
<tr>
<td>Play</td>
<td>Starts playback or (if the Record button was clicked first) recording from the Timeline insertion point.</td>
</tr>
<tr>
<td>Record</td>
<td>Starts or stops recording.</td>
</tr>
<tr>
<td>Fast Forward</td>
<td>Rewinds from the current play location.</td>
</tr>
<tr>
<td>Fast Forward</td>
<td>Rewinds from the current play location.</td>
</tr>
</tbody>
</table>

Rewind Increments

<table>
<thead>
<tr>
<th>Main Time Scale Format</th>
<th>Increment Amount</th>
</tr>
</thead>
<tbody>
<tr>
<td>Min:Sec</td>
<td>1 second</td>
</tr>
<tr>
<td>Time code</td>
<td>1 frame</td>
</tr>
<tr>
<td>Bars:Beats</td>
<td>1 bar</td>
</tr>
<tr>
<td>Feet:Frame</td>
<td>1 foot</td>
</tr>
<tr>
<td>Sample</td>
<td>1 second</td>
</tr>
</tbody>
</table>

Stop Stops playback or recording.

You can also stop the Transport with the following shortcuts:
- Press the Spacebar.
- With the Numeric Keypad Mode set to Transport, press 0.

Play Starts playback or (if the Record button was clicked first) recording from the Timeline insertion point.

With the Transport stopped, Control-click Play (Macintosh) or Right-click Play (Windows) to toggle Loop Playback mode. When enabled, a loop symbol appears in the Play button.
You can also initiate playback with the following shortcuts:

- Press the Spacebar.
- With the Numeric Keypad Mode set to Transport, press 0.

You can play at half-speed with the following shortcuts:

- Press Shift+Spacebar.
- Shift-click (Macintosh) the Play button.

**Fast Forward** Fast forwards from the Timeline insertion point. You can also click repeatedly to fast forward incrementally (by an amount based on the Main Time Scale).

**Fast Forward Increments**

<table>
<thead>
<tr>
<th>Main Time Scale Format</th>
<th>Increment Amount</th>
</tr>
</thead>
<tbody>
<tr>
<td>Min:Sec</td>
<td>1 second</td>
</tr>
<tr>
<td>Time code</td>
<td>1 frame</td>
</tr>
<tr>
<td>Bars:Beats</td>
<td>1 bar</td>
</tr>
<tr>
<td>Feet:Frame</td>
<td>1 foot</td>
</tr>
<tr>
<td>Sample</td>
<td>1 second</td>
</tr>
</tbody>
</table>

With the Numeric Keypad Mode set to Transport, you can fast forward by pressing 2.

**Go to End** Locates to the end of the session.

You can press Option+Return (Macintosh) or Control+Enter on the alpha keyboard (Windows) to locate to the end of the session.

**Record** Arms Pro Tools for recording (the button flashes). Clicking Play then initiates recording.

With the Transport stopped, Control-click Record (Macintosh) or Right-click Record (Windows) to cycle through the four record modes. The Record button changes to indicate the currently selected mode: blank for Nondestructive, “D” for Destructive, a loop symbol for Loop Record, and “P” for QuickPunch.

You can also begin recording with the following shortcuts:

- Press F12.
- Press Command+Spacebar (Macintosh) or Control+Spacebar (Windows).
- With the Numeric Keypad Mode set to Transport, press 3.

To initiate recording at half-speed, press Command+Shift+Spacebar (Macintosh) or Control+Shift+Spacebar (Windows).

**Pre-Roll** During playback or record, specifies the amount that plays before the play (timeline) cursor location or beginning of the timeline selection. Pre-roll is particularly useful with punch recording since it provides you with time to “catch the beat” before reaching the punch-in point. To set the pre-roll amount, enter a new value in this field, or drag the Pre-Roll flag in the Main Timebase Ruler.

To enable pre-roll, click the Pre-Roll button to the left of the pre-roll field so it becomes highlighted.
**Post-Roll** During playback or record, specifies the amount that plays after the end of a timeline selection. Post-roll is useful in punch recording since playback continues after the punch-out point so you can check for a smooth transition to previously recorded material. To set the post-roll amount, enter a new value in this field, or drag the Post-Roll flag in the Main Timebase Ruler.

To enable post-roll, click the Post-Roll button to the left of the post-roll field so it becomes highlighted.

**Start** Specifies the beginning of the play or record range. You can set the start point by entering a location in this field, or by dragging the corresponding Playback Marker in the Main Timebase Ruler. For more information, see “Playback Markers” on page 163.

**End** Specifies the end of the play or record range. You can set the end point by entering a location in this field, or by dragging the corresponding Playback Marker in the Main Timebase Ruler. For more information, see “Playback Markers” on page 163.

**Length** Specifies the length for the play or record range. You can set the length by entering a location in this field, or by selecting a range in any Timebase Ruler.

💡 When the Edit and Timeline selections are linked, you can drag in a track’s playlist to set the play and record range.

**Transport Master** Specifies the “master” for transport functions. Click this button and choose from the pop-up menu to select the Transport Master, which can be set to Pro Tools, Machine, MMC, or Remote. For information, see Chapter 35, “Time Code Synchronization.”

---

**MIDI Controls**

Wait for Note
Countoff
Click
MIDI Merge
Tempo
Conductor
Meter

Transport window showing MIDI controls (Pro Tools 6.0)

Wait for Note
Countoff
Click
MIDI Merge
Tempo
Conductor
Meter

Transport window showing MIDI controls (Pro Tools 5.3.x and 5.1.x)

**Wait for Note** When selected, recording does not begin until a MIDI event is received. This ensures that you begin recording when you’re ready to play, and that the first note, or other MIDI data, is recorded precisely at the beginning of the record range.

💡 You can press F11 to turn on Wait for Note, unless the Operation Preference for “Disable F11 for Wait for Note” is selected.
**Click** When selected, a metronome sounds during playback and recording (as specified by the settings in the Click/Countoff Options dialog).

Double-click the Click button to open the Click/Countoff Options dialog.

> **With the Numeric Keypad Mode set to Transport, you can press 7 to enable the Click.**

**Countoff** When selected, Pro Tools counts off a specified number of measures (indicated in the button) before playback or recording begins.

Double-click the Countoff button, to open the Click/Countoff Options dialog.

> **With the Numeric Keypad Mode set to Transport, you can press 8 to enable the Countoff.**

**MIDI Merge** When selected (Merge mode), recorded MIDI data is merged with existing track material. When deselected (Replace mode), recorded MIDI data replaces existing track material.

> **With the Numeric Keypad Mode set to Transport, you can press 9 to enable MIDI Merge.**

**Conductor** When selected, Pro Tools uses the tempo map defined in the Tempo Ruler. When deselected, Pro Tools switches to Manual Tempo mode and ignores the Tempo Track.

In Manual Tempo mode, you can enter a BPM value in the tempo field, or tap in the tempo by clicking the Tap button.

**Meter** Displays the session’s current meter based on the play location. Double-click the Meter button to open the Change Meter window.

**Tempo** Displays the session’s current tempo based on the play location. In Manual Tempo mode, you can enter a BPM value into this field. In addition, when the tempo field is selected, you can tap in a tempo from a MIDI controller.
Chapter 5: Keyboard Shortcuts

Global Key Commands
This section shows keyboard shortcuts that apply to many functions in Pro Tools.

Track Functions
- Changing Automation mode
- Enabling playlists
- Adding plug-ins
- Record enabling, soloing, and muting tracks
- Record safin and solo safin tracks
- Assigning inputs, outputs, and sends
- Toggling volume/peak/delay display
- Clearing meters
- Changing track heights

List and Parameter Selection
- Selection of tracks in Show/Hide List
- Enabling of groups in Groups List
- Automation Enable window parameters
- Setting memory location parameters

Controls and Editing Tools
- Use to move plug-in controls, faders and sliders, the Scrubber, and automation data

<table>
<thead>
<tr>
<th>Command</th>
<th>Macintosh</th>
<th>Windows</th>
</tr>
</thead>
<tbody>
<tr>
<td>Toggle item and set all others to same new state</td>
<td>Option-click item</td>
<td>Alt-click item</td>
</tr>
<tr>
<td>Toggle item and set all others to opposite state</td>
<td>Command-click item</td>
<td>Control-click item</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Command</th>
<th>Macintosh</th>
<th>Windows</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fine adjustment of sliders, knobs, and breakpoints</td>
<td>Command-click item</td>
<td>Control-click item</td>
</tr>
</tbody>
</table>
Keyboard Focus

The Keyboard Focus in Pro Tools determines how the alpha keys function. Depending on which Keyboard Focus is enabled, you can use the keys on your alpha keyboard to select regions in the Audio or MIDI Regions List, enable or disable groups, or perform an edit or play command.

You can only enable one Keyboard Focus at a time. Enabling a Keyboard Focus will disable the one previously selected.

To set the Keyboard Focus:

- Click the a–z button for the focus you want to enable.

  – or –

While pressing Command+Option (Macintosh) or Control+Alt (Windows), press one of the following keys: 1 (Commands), 2 (Audio Regions List), 3 (MIDI Regions List), or 4 (Groups List).

Commands Focus (All TDM Systems and Pro Tools LE 6.0 Only)

When selected, this provides a wide range of single key shortcuts from the alpha keyboard for editing and playing.

With the Commands Focus disabled, you can still access any of its key shortcuts by pressing Control (Macintosh) or the Start key (Windows) along with the key.

An electronic PDF listing of keyboard shortcuts is available in Pro Tools. Choose Help > Keyboard Shortcuts.

Audio Regions Focus

When selected, audio regions can be located and selected in the Audio Regions List by typing the first few letters of the region’s name.

MIDI Regions Focus

When selected, MIDI regions can be located and selected in the MIDI Regions List by typing the first few letters of the region’s name.

Groups List Focus

When selected, Edit and Mix Groups can be enabled or disabled by typing the Group ID letter.

Refer to the Keyboard Shortcut Card in Pro Tools: Choose Help > Keyboard Shortcuts.
**Numeric Keypad Modes**

The Operation preference for Numeric Keypad Mode determines how the numeric keypad functions for Transport.

No matter which Numeric Keypad Mode is selected, you can always use the numeric keypad to select and enter values in the Event Edit Area, Location Indicators, and Transport fields.

**To set the Numeric Keypad Mode:**

1. Choose Setups > Preferences and click Operation.

2. Under the option for Numeric Keypad Mode, select a keypad mode (Classic, Transport, or Shuttle), then click Done.

**Classic**

This mode emulates the way Pro Tools worked in versions earlier than 5.0. With the Numeric Keypad Mode set to Classic, you can:

- Play up to two tracks of audio in Shuttle Lock mode. Press Control (Macintosh) or the Start key (Windows), followed by 0–9 for different play speeds. Press Plus or Minus to reverse direction.
- Recall Memory Locations by typing the Memory Location number, followed by a period.

**Transport**

This mode allows you to set a number of record and play functions, and also operate the Transport from the numeric keypad.

<table>
<thead>
<tr>
<th>Function</th>
<th>Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Click on/off</td>
<td>7</td>
</tr>
<tr>
<td>Countoff on/off</td>
<td>8</td>
</tr>
<tr>
<td>MIDI Merge/Replace mode</td>
<td>9</td>
</tr>
<tr>
<td>Loop Playback mode on/off</td>
<td>4</td>
</tr>
<tr>
<td>Loop Record mode on/off</td>
<td>5</td>
</tr>
<tr>
<td>QuickPunch mode on/off</td>
<td>6</td>
</tr>
<tr>
<td>Rewind</td>
<td>1</td>
</tr>
<tr>
<td>Fast Forward</td>
<td>2</td>
</tr>
<tr>
<td>Record</td>
<td>3</td>
</tr>
<tr>
<td>Play/Stop</td>
<td>0</td>
</tr>
</tbody>
</table>

With the Numeric Keypad Mode set to Transport, you can also:

- Play up to two tracks of audio in Shuttle Lock mode. Press Control (Macintosh) or the Start key (Windows), followed by 0–9 for different play speeds. Press Plus or Minus to reverse direction.
- Recall Memory Locations by typing period, the Memory Location number, and period again.
**Shuttle**  
*(TDM Systems Only)*  

Pro Tools offers another form of shuttling, different from that of Shuttle Lock mode. With the Numeric Keypad Mode set to Shuttle, playback of the current Edit selection is triggered by pressing and holding the keys on the numeric keypad—playback stops once the keys are released. Various playback speeds are available in both forward and reverse. In this mode, pre- and post-roll are ignored.

<table>
<thead>
<tr>
<th>Function</th>
<th>Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>1x Forward</td>
<td>6</td>
</tr>
<tr>
<td>1x Rewind</td>
<td>4</td>
</tr>
<tr>
<td>4x Forward</td>
<td>9</td>
</tr>
<tr>
<td>4x Rewind</td>
<td>7</td>
</tr>
<tr>
<td>1/4x Forward</td>
<td>3</td>
</tr>
<tr>
<td>1/4x Rewind</td>
<td>1</td>
</tr>
<tr>
<td>1/2x Forward</td>
<td>5+6</td>
</tr>
<tr>
<td>1/2x Rewind</td>
<td>5+4</td>
</tr>
<tr>
<td>2x Forward</td>
<td>8+9</td>
</tr>
<tr>
<td>2x Rewind</td>
<td>8+7</td>
</tr>
<tr>
<td>1/16x Forward</td>
<td>2+3</td>
</tr>
<tr>
<td>1/16x Rewind</td>
<td>2+1</td>
</tr>
<tr>
<td>Loop Selection (1x)</td>
<td>0</td>
</tr>
</tbody>
</table>

With the Numeric Keypad Mode set to Shuttle, you can also:

- Recall Memory Locations by typing period, the Memory Location number, and period again.

⚠️ *Shuttle Lock mode is not available when the Numeric Keypad Mode is set to Shuttle.*
Part II: Sessions & Tracks
Chapter 6: Sessions

This chapter covers the basics of starting a project in Pro Tools, including how to set up and save a Pro Tools session.

Starting Up or Shutting Down Your System

To ensure that the components of your Pro Tools system communicate properly with each other, you need to start them in a particular order.

Start up your Pro Tools system in this order:

1. For TDM systems with an expansion chassis, turn on the chassis.
2. Turn on any external hard drives. Wait approximately ten seconds for them to spin up to speed.
3. Turn on any MIDI interfaces, MIDI devices, or synchronization peripherals.
4. Lower the volume of all output devices in your system.
5. For TDM systems, turn on your Pro Tools audio interfaces. Wait at least fifteen seconds for your system hardware to initialize.
6. Turn on your computer.
7. Launch Pro Tools or any third-party audio or MIDI applications.

Shut down your Pro Tools system in this order:

1. Quit Pro Tools and any other running applications.
2. Turn off or lower the volume of all output devices in your system.
3. Turn off your computer.
4. For TDM systems, turn off audio interfaces.
5. For TDM systems with an expansion chassis, turn off the chassis.
6. Turn off any MIDI interfaces, MIDI devices, or synchronization peripherals.
7. Turn off any external hard drives.

Configuring Pro Tools System Settings

Pro Tools allows you to adjust the performance of your system by changing system settings that affect its capacity for processing, playback, and recording.

In most cases, the default settings for your system provide optimum performance, but you may want to adjust them to accommodate large or processing-intensive Pro Tools sessions.
Hardware Buffer Size

The Hardware Buffer Size (H/W Buffer Size) controls the size of the hardware cache used to handle host-based tasks such as Real-Time Audio-Suite (RTAS) plug-in processing.

- Lower Hardware Buffer Size settings reduce monitoring latency, and are useful when you are recording live input.
- Higher Hardware Buffer Size settings allow for more audio processing and effects, and are useful when you are mixing and using more RTAS plug-ins.

⚠️ In addition to causing slower screen response and monitoring latency, higher Hardware Buffer Size settings can affect the accuracy of plug-in automation, mute data, and timing for MIDI tracks.

To change the Hardware Buffer Size:
2. From the H/W Buffer Size pop-up menu, select the audio buffer size, in samples.
3. Click OK.

CPU Usage Limit

The CPU Usage Limit controls the percentage of CPU resources allocated to Pro Tools host processing tasks.

With Pro Tools 5.3.3 and earlier, the maximum CPU Usage Limit is 85 percent.

With Pro Tools 6.0, the maximum CPU Usage Limit is 85 percent for single-processor computers, and 99 percent for multi-processor computers. (The 99 percent setting dedicates one entire processor to Pro Tools.)

- Lower CPU Usage Limit settings limit the effect of Pro Tools processing on other CPU-intensive tasks, such as screen redraws, and are useful when you are experiencing slow system response, or when running other applications at the same time as Pro Tools.
- Higher CPU Usage Limit settings allocate more processing power to Pro Tools, and are useful for playing back large sessions or using more real-time plug-ins.

⚠️ Increasing the CPU Usage Limit may slow down screen responses on slower computers.

To change the CPU Usage Limit:
2. From the CPU Usage Limit pop-up menu, select the percentage of CPU processing you want to allocate to Pro Tools.
3. Click OK.

Number of Voices

(TDM Systems Only)

On TDM systems, the Number of Voices setting lets you control the number of available voices and how those voices are allocated to DSPs in your system. For example, the default number of voices on a Pro Tools HD 1 system is 48 voices, using one DSP (at sample rates of 44.1 kHz or 48 kHz).

⚠️ Changing the number of voices affects DSP usage, the total number of voiceable tracks, and overall system performance.

Depending on the current sample rate and the number of TDM cards in your system, you will have different choices for voice count. For voice limits on different HD systems, see “TDM System Playback, Recording and Voice Limits” on page 7.
To change the Voice Count:


2. Select the number of voices and DSPs to allocate for voicing by selecting a value from the Number of Voices pop-up menu (Pro Tools 5.3 and later), or by clicking a value under Playback Engine (Pro Tools 5.1.3).
   - Select higher voice numbers when your Digidesign cards are the only PCI cards in your computer, or when you are using an expansion chassis to run higher track counts.
   - Select medium voice numbers when your Digidesign cards are in an expansion chassis, or when you are using other PCI cards along with Digidesign cards.
   - Select minimum voice numbers if you are using high-bandwidth PCI cards (such as video capture cards) along with your Digidesign cards.

3. Click OK.

Default Sample Rate

The Sample Rate setting appears as the default sample rate when you create a new session. (This setting is available only when there is no session open.)

⚠️ The Sample Rate setting can affect the number of available voices on TDM systems.

To change the default Sample Rate:


2. Select the sample rate from the Sample Rate pop-up menu.

3. Click OK.

You can change the sample rate when creating a new Pro Tools session by selecting a different sample rate in the New Session dialog. (See “Creating a New Session” on page 46.)

DAE Playback Buffer Size

The DAE Playback Buffer Size determines the amount of memory DAE uses to manage disk buffers, which affects system performance.

- Lower DAE Playback Buffer Size settings can improve playback and recording initiation speed. However, a lower setting can make it difficult for slower hard drives to play or record tracks reliably.

- Higher DAE Playback Buffer Size settings can allow for a higher density of edits in a session. However, a higher setting can cause a time lag to occur before playback or recording begins. It can also cause a time lag to occur when you are editing during playback.
To change the DAE Playback Buffer Size (Pro Tools 5.3 and later):


2. From the DAE Playback Buffer pop-up menu, select a buffer size. Memory requirements for each setting are shown at the bottom of the Playback Engine dialog box.

3. Click OK.

4. If Pro Tools needs more system memory for the DAE Playback Buffer, it will prompt you to restart your computer.

To change the DAE Playback Buffer Size (Pro Tools 5.1.3):

1. Launch DAE. If Pro Tools is already running, switch to the DAE application.

2. Choose File > Set Playback Buffer Size.

3. Select a buffer size.

4. Click OK.

5. Quit Pro Tools if it is running, or quit the DAE application. The new buffer setting will take effect when you launch Pro Tools again.

System Memory Allocation (Pro Tools 6.0 TDM Systems Only)

When you start your computer, Pro Tools automatically reserves a portion of system memory for the DAE Playback Buffer. This reserved memory is unavailable to other applications, even if Pro Tools is not running.

You can set Pro Tools to reserve only the minimum amount of required memory, so that system memory is available to other applications.

To minimize system memory allocation:


2. Select the “Minimize System Memory Allocation” option.

3. Click OK.

4. Restart your computer.
Configuring Pro Tools
Hardware Settings

Pro Tools allows you to configure the signal routing, digital I/O format, default sample rate, clock source, and other hardware-based settings depending on your system configuration.

The following section outlines the configuration of a Pro Tools|HD system with one or more HD interfaces (with one or more MIX-series interfaces attached).

To configure a Pro Tools MIX-series, Pro Tools|24, or Pro Tools LE system, refer to the Getting Started Guide that came with that system.

Configuring Pro Tools|HD Hardware

On TDM systems, you configure Hardware settings for each audio interface connected to your system. For example, Pro Tools|HD-series systems can have 192 I/O, 192 Digital I/O, or 96 I/O audio interfaces connected to HD Core and HD Process cards in the system. Those audio interfaces can have additional interfaces attached (including older Digidesign audio interfaces, or Legacy I/Os, such as the 888|24 I/O, 882|20 I/O or 1622 I/O). For more information, see Chapter 2, “Pro Tools System Configurations.”

Configuring Hardware Setup

The Main page of the Hardware Setup dialog is where you define which physical inputs and outputs on your audio interface are routed to available inputs and outputs in Pro Tools.

To configure audio interfaces on an HD system:
1. Choose Setups > Hardware Setup.
2. From the Peripherals list, select the Digidesign audio interface connected to the first card in your system. This will be the interface at the top of the list.
3. Click the Main tab.
4 From the Clock Source pop-up menu, select the appropriate clock source for the system. In most cases, you will use Internal. The other choices are for resolving Pro Tools to external clock sources. Depending on your audio interface, Clock Source options can include: AES/EBU [Encl], S/PDIF, Optical [Encl], AES/EBU 1–8, TDIF, ADAT, and Word Clock (optional Word Clock rates are available when operating at higher sample rates).

5 From the Ext. Clock Output pop-up menu, select the appropriate clock output to send to devices attached to your audio interface.

6 Select which digital I/O port on your audio interface enclosure is active under Digital Format. Choices include: AES/EBU, S/PDIF, and Optical (S/PDIF). Selecting Optical (S/PDIF) resets the Optical I/O port (which is, by default, eight channels of ADAT I/O) to two channels of S/PDIF Optical I/O.

7 For S/PDIF compatibility with Tascam DA-30 DAT recorders select the Tascam option under S/PDIF Format.

8 For the 96 I/O, click the Meters pop-up menu and select whether to meter the input or output signal.

9 From the Input and Output pop-up menus, select the physical ports (such as Analog 1–2 or Optical 1–2), that will be routed to the corresponding Pro Tools input and output channels (such as Ch 1–2 or Ch 3–4), listed on the left side of the Main page.

Inputs and outputs of similar format are differentiated in the input and output channel pop-up menus. For example, the AES/EBU inputs and outputs in the 192 I/O enclosure are listed as AES/EBU [Encl], while the AES/EBU inputs and outputs on the factory-installed Digital I/O card are listed (in pairs) as AES/EBU 1–2, AES/EBU 3–4, AES/EBU 5–6, and AES/EBU 7–8.

For 192 I/Os equipped with the optional Digital I/O Card, the additional AES/EBU I/O ports on the optional card are listed as AES/EBU 9–10, AES/EBU 11–12, AES/EBU 13–14, and AES/EBU 15–16.

10 Click other tabs (such as Analog In and Analog Out) for additional configuration options specific to the audio interface. These include:
   • On the 96 I/O, configuring the operating levels of analog inputs and outputs (+4 dBu or –10 dB).
   • On the 192 I/O analog input, setting the input connector, input trim (A or B), and Soft Limit.
   • On the 192 I/O, configuring the two sets of trims for inputs and outputs.
   • On the 192 I/O, configuring inputs and outputs on any optional A/D card, D/A card, or Digital I/O cards installed in the unit.

11 Repeat the above steps for each additional HD-series audio interface.

12 Repeat the above steps for any Legacy I/Os connected to the HD-series audio interfaces in your system. Before you can configure a Legacy I/O, it must first be initialized in Hardware Setup (See “Initializing MIX-Series Peripherals” on page 45.)

13 Click OK.
Initializing MIX-Series Peripherals

Before you can configure a Legacy I/O, it must first be initialized in Hardware Setup.

To initialize a Legacy I/O on an HD system:

1. Start up your Pro Tools system. See “Starting Up or Shutting Down Your System” on page 39.
2. Make sure to lower the volume of your output devices. Very loud digital noise may be emitted before the Legacy I/O is initialized.
3. Turn on your Legacy I/O.
4. From the Peripherals list, choose the primary audio interface (the interface to which your Legacy I/O is connected).
5. In the Main page of the Hardware Setup dialog, select the Legacy I/O option under Port Settings.
6. In the Peripherals list, “No Interface” is listed twice, directly below the primary audio interface. Click the first “No Interface.” An Interface pop-up menu appears in the Hardware Setup dialog, listing supported I/O choices.
7. From the Interface pop-up menu, select the type of Legacy I/O you connected.
8. Set the External Clock Output on the HD interface to 256x, which is the required clock speed for Legacy I/Os.

After you select an audio interface, the Main page updates with controls that can be configured. Refer to the guide for your audio interface for details on each control.

9. Repeat the above steps for each additional Legacy I/O.

For more information on Hardware Setup controls for each Legacy audio interface, refer to the guide that came with the interface.

Configuring I/O Setup

The I/O Setup dialog provides a graphical representation of the signal routing for each connected audio interface, with controls to route physical ports on the audio interface to Pro Tools inputs and outputs. These controls mirror the routing controls found in the Hardware Setup dialog—changes made to physical routing in one dialog are always reflected in the other. The I/O Setup dialog also lets you label and map Pro Tools input, output, insert, and bus signal paths. For more information on paths, path labeling, and path mapping, see Chapter 7, “I/O Setup.”

Routing a Pro Tools Output Pair to Multiple Destinations

Pro Tools channel pairs can be routed to multiple outputs on an audio interface through the Hardware Setup dialog. For example, if you assign both Analog 1–2 and Analog 3–4 interface outputs to Pro Tools Output pair 1–2, when you send a signal to Pro Tools Outputs 1–2, that signal will be routed simultaneously to both pairs of output ports on your audio interface.

This lets you send the same signal (such as a stereo pair, a stem mix, or a multichannel mix) to multiple destinations (such as multiple mastering devices).

To select multiple output ports for a Pro Tools output channel pair:

1. Choose Setups > Hardware Setup.
2. From the Peripherals list, select an interface.
3. Click the Main tab.
4. Select an output pair from an Output pop-up menu.
Control-click (Macintosh) or Start-click (Windows) the same pop-up menu a second time to choose an additional output pair.

The output name updates with a plus sign (“+”) before it to indicate that multiple output ports are selected. In the pop-up menu, each physical port pair assigned to that Pro Tools output pair is indicated by a check mark.

Repeat the above steps to select additional output destinations. The only limit to output choices is the number of outputs available in your system.

Pro Tools output pairs can also be routed to multiple audio interface outputs in the I/O Setup dialog. For more information, see “Routing Hardware I/O to Pro Tools I/O” on page 69.

Creating a New Session

The first step in beginning a Pro Tools project is creating a new session. When you do this, Pro Tools automatically creates a new folder named for your session. Within this folder is the session file and two subfolders, an Audio Files folder, and a Fade Files folder.

The Audio Files folder contains all audio recorded or converted during the session. The Fade Files folder contains any crossfaded audio data generated by the session.

When you record a new audio track, the track is saved as a new audio file to the Audio Files folder. You can also import other audio files into the session, and work with them as well.

To create a new session:


2. Choose the drive where you want to save the session. The session should be saved on a dedicated audio drive.
3 Select “Enforce Mac/PC Compatibility” (Macintosh) if you want to create session and audio files that can be used in either Macintosh or Windows versions of Pro Tools. See “Creating Mac and PC Compatible Sessions” on page 130 for more information.

To use Japanese or non-ASCII characters in track and region names, or track comments, deselect the option for “Enforce Mac/PC Compatibility” when creating a new session.

If you save a session copy with the “Enforce Mac/PC Compatibility” option enabled, all Japanese and non-ASCII characters will be lost.

4 Select the audio file format for the session.

For optimum compatibility between Windows and Macintosh sessions, set the file type to WAV. Sound Designer II (SD II) files are not supported on Windows systems, and Pro Tools prevents you from choosing SD II as the file type if Enforce Mac/PC Compatibility is selected (or the session is on a PC).

5 Select the bit depth (16 bit or 24 bit) and the sample rate.

6 Select the I/O Settings to use for the session. Several pre-configured I/O Settings are included with your system, or you can select a custom I/O Setting that you have created. See Chapter 7, “I/O Setup” for more information.

7 Name the Session.

8 Click Save.

Choosing Bit Depth and Sample Rate

When choosing a bit depth or sample rate for your session, consider the disk space your selection will require. 24-bit audio files occupy about 50 percent more disk space than 16-bit audio files. 192 kHz audio files occupy about four times the space as 44.1 kHz audio files.

Bit depth and sample rate also have an effect on the amount of mixing power available in a session. On TDM systems, fewer mixer channels are available with 24-bit sessions and with sessions at higher sample rates (see Appendix B, “TDM Mixing and DSP Usage”). On LE systems, 24-bit sessions require more processing power as well.

It is not possible to combine different bit depths within a single Pro Tools session; files of different bit depths must be converted and imported into the session.
Opening a Session

When you open a session, Pro Tools looks in the session folder for audio and fade files linked to the session.

To open an existing session:

1. Choose File > Open Session.
2. Locate the session you want to open and click Open.

Opening a Session that Contains Unavailable Resources

Pro Tools prompts you when opening a session that contains unavailable voices, I/O paths, DSP resources, or plug-ins. This is common when transferring sessions to systems with different Digidesign hardware.

The following will occur when opening a session with unavailable items:

With Pro Tools TDM Systems:

- Any tracks beyond the maximum number of available voices on the current system are made inactive.

With Pro Tools LE 6.0:

- Any tracks beyond the maximum number of available voices on the current system are set to voice off.

With Pro Tools LE 5.3.x and earlier:

- Any tracks beyond the maximum number of available voices on the current system are removed from the session. If the session is saved, the removed tracks are lost.
With all Pro Tools Systems:

- Inserts assigned to unavailable plug-ins are made inactive.
- Inputs, outputs, and sends that are assigned to unavailable paths are made inactive.

Saving a Session

You should save regularly while working on your session to ensure that your work is preserved on your hard drive.

Speeding up Saves by Reducing the Disk Cache Size

(Mac OS 9 Only)

To speed up session saves and disk bounces, it is recommended that you reduce the Cache Size for your Macintosh to 512K (in the Control Panel > Memory dialog).

Saving the Session File

The Save Session command saves the changes you have made to your session and writes them over the previously saved version of the session file. The Save Session command cannot be undone.

To save a session:

- Choose File > Save Session.

Revert to Saved Command

If you have made changes to a session since you last saved it, you can discard the changes and revert to its previously saved state.

To revert to the last saved version of a session:

- Choose File > Revert to Saved.

Saving the Session File with a New Name

To save a copy of the current session with a new name or to a different hard drive location, you can use the Save Session As command. Because the Save Session As command closes the current session and lets you keep working on the renamed copy, it is useful if you are experimenting and want to save successive versions of the session.

By working this way, you can quickly retrace your steps if you want to go back to an earlier version of your session. The Save Session As command saves a new version of the session file only—not duplicate versions of the audio or fade files.

To save a session with a new name:

1. Choose File > Save Session As.
2. Enter a new name for your session.
3. Click Save.

The renamed session file is saved in the session folder along with the original session. Any new audio files that you record in your renamed session will be placed into the same Audio Files folder that was created for your original session.
Saving a Copy of the Session

To save a copy of the current session along with its audio files and fade files, you can use the Save Session Copy In command. In addition, you can specify a session file format, audio file format, bit depth, and sample rate for the session copy.

Unlike the Save Session As command, Save Session Copy In does not close the original session, so subsequent edits are made to the original session. Session copies can be used to archive important sessions, or as a means to prepare sessions for transfer to another Pro Tools system.

Save Session Copy In saves only the audio being used in the session. Any audio that was recorded or imported and then later removed from the session will not be included in the new session copy.

Using the Save Session Copy In command is the only way to change the sample rate of a session.

💡 When you Save Session Copy with a lower bit rate, Dither (and Noise Shaping) may be applied. See the following table:

<table>
<thead>
<tr>
<th>Bit Rate Conversion</th>
<th>Save Session Copy</th>
</tr>
</thead>
<tbody>
<tr>
<td>24-bit to 16-bit (Dither and Noise Shape)</td>
<td>Yes</td>
</tr>
<tr>
<td>24-bit to 8-bit (Noise Shape Only)</td>
<td>No</td>
</tr>
<tr>
<td>16-bit to 8-bit (Noise Shape Only)</td>
<td>No</td>
</tr>
</tbody>
</table>

For more information about using Dither with the Save Session Copy In command, see “Dither” on page 402.

Session Format

You can save the session copy in the following formats:

- Latest (Pro Tools 5.1 or later)
- Pro Tools 5 Session
- Pro Tools 4 24-Bit Session
- Pro Tools 4 16-Bit Session
- Pro Tools 3.2 Session

Use Latest if you are working with Pro Tools software 5.1 or higher.

When saving sessions to versions earlier than 5.1, multichannel tracks and multi-mono plug-ins are lost. In this case, make sure to first separate the tracks and plug-ins to individual mono tracks.
**Session Parameters**

**Audio File Type**

You can save the session to reference WAV or AIFF audio files. On the Macintosh, you can also save the session to reference SD II audio files (at sample rates up to 48 kHz).

⚠️ *SD II sessions are not supported with Pro Tools for Windows, or with sample rates higher than 48 kHz. You cannot set the session audio file type to SD II on the Macintosh if Enforce Mac/PC Compatibility is selected, or if the sample rate of the destination session is greater than 48 kHz.*

**Using Mixed File Types**

A session can use mixed audio file types. If your original session has mixed file types, they are not converted to a different file type unless you specify that they be converted. However, when using mixed file types, audio performance will be reduced (due to additional file handling required for some file formats).

**Bit Depth**

You can save the new session at 16-bit or 24-bit depth. If your session is in a different bit depth, audio files are converted to the new session bit depth, and copied to the location you specify.

**Sample Rate**

You can save the new session at sample rates of 44.1 kHz or 48 kHz (on Mbox, Digi 001 and MIX-series systems) and at sample rates up to 96 kHz (on Digi 002) or 192 kHz (on HD-series systems). If your session is at a different sample rate, audio files are converted to the new session sample rate, and copied to the location you specify.

The higher the quality of sample rate conversion you choose, the longer Pro Tools will take to process the audio file.

**Enforce Mac/PC Compatibility**

This setting forces Macintosh or Windows versions of Pro Tools to create sessions and audio files that are usable on both platforms. For more information, see “Creating Mac and PC Compatible Sessions” on page 130.

**Items to Copy**

**All Audio Files**

When this option is selected, all audio files are copied to the new location.

This setting is automatically selected if you are changing the bit depth or sample rate of the session.

**All (Non-Native) Audio Files**

This name of this option varies depending on the audio file type you select. If you are changing the audio file type of the session, this option ensures that all files in the copied session are converted to the selected file type. Use this option to avoid the reduced performance of a session with mixed file types.

This option is automatically selected if you are changing bit depth or sample rate, or copying a session on the Macintosh from SD II format to AIFF or WAV format with Enforce Mac/PC Compatibility selected.
Don’t Copy Fade Files
When this option is selected, Fade Files are not copied to the new session Fade Files folder. When the session is launched, the Find Files dialog will prompt you to locate Fade Files. You can either locate the existing fades using the find file dialog, or Skip All to let Pro Tools recreate the fades from the session document.

Session Plug-In Settings Folder
When this option is selected, the session’s Plug-In Settings folder is copied to the new location. The references to these plug-in settings in the session are redirected to point to the copied settings files.

Root Plug-In Settings Folder
When this option is selected, the contents of the root-level Plug-In Settings Folder are copied into a folder named Place in Root Settings Folder, indicating that these files will need to be moved to the root level plug-in settings folder on the destination system before you can use them. The references to these settings files in the session are not redirected to point to the copied files.

Movie/Video Files
When this option is selected, session movie files (QuickTime video files or AVOption or AVOption XL video files) are copied to the new location, and session references are updated to point to the copied movie files.

To save a session copy in a new location:

1. Choose File > Save Session Copy In.
2. In the Save Session Copy dialog, choose a destination and enter a name for the new session file.
3. Set the Audio File Type to AIFF, WAV, or SD II. If the audio files need to be compatible with either Macintosh or Windows, select AIFF or WAV.
4. Set the Sample Rate and Bit Depth for the session.
5. Select “Enforce Mac/PC Compatibility” if you want to create session and audio files that can be used in either Macintosh or Windows versions of Pro Tools. See “Creating Mac and PC Compatible Sessions” on page 130 for more information.
6. Select the Items to Copy to the new session.
7. Click Save.

Creating Custom Session Templates
You can create custom session documents that are pre-configured to the track setups, mixer setups, window arrangements, and zoom level memory locations that you use most frequently. Doing this will save you the trouble of having to create your studio setup from scratch every time you start a new session.

Creating Macintosh Templates
On the Macintosh, you can create a session template by saving a session file as a Stationery Pad document. Once a session is saved as a Stationery Pad, it acts as a template that you can open and then resave as a normal session.

To create a custom session template on the Macintosh:
1. Create a session and arrange its elements as desired. In addition to track setup, you can also define parameters such as signal routings, insert and send configurations, Mix and Edit window views, Ruler settings, and Preference settings.
2 Choose File > Save Session As.
3 Name the session and click Save.
4 Close the session.
5 Locate the session file that you just saved.
6 Click once on the file to select it.
7 Choose File > Get Info > General Information.

8 Select the Stationery Pad option to save the file as a template, then close the information window.

To use this template, double-click it or open it with the Open Session command if you are already running Pro Tools. You can create several custom templates for studio setups that you frequently use.

When you open a session saved as a Stationery Pad, Pro Tools gives you the option of editing the template or starting a new session using the template settings. If you choose New Session, Pro Tools will create a new folder containing a copy of your session template and Audio and Fades folders.

Creating Windows Templates

In Windows, you can create a session template by making a session file a Read Only document.

To create a custom session template in Windows:
1 Create a session and arrange Pro Tools as desired. You can also define the parameters within these windows, such as signal routings, insert and send configurations, track views, Ruler settings, and Preference settings.
2 Choose File > Save Session As.
3 Name the session and click Save.
4 Close the session.
5 Locate the session file that you just saved.
6 Right-click the file and choose Properties.
7 Under Attributes, deselect Archive and select Read Only.

8 Click OK.
To use this template, double-click it or open it with the Open Session command. When you first save the session, Pro Tools will ask you to give the session a new name. Your original session template will remain unchanged.

To modify the session template, you will need to reopen its Properties, deselect the Read Only option and select the Archive option, make your modifications, then change it back to a Read Only file.

**Closing a Session**

Because Pro Tools allows you to work on just one session at a time, you must close the current session if you want to work on another. The Close Session command closes your current Pro Tools session but leaves the Pro Tools application open. You can save your work using the Save Session or Save Session As command before closing the current session.

**To close a session:**
- Choose File > Close Session.

**Quitting Pro Tools**

Although Pro Tools will warn you before allowing you to quit without saving changes, you should generally save your work before quitting.

**To quit Pro Tools on the Macintosh:**
- Choose Pro Tools > Quit Pro Tools (Pro Tools 6.0) or File > Quit (Pro Tools 5.3.x and earlier).

**To exit Pro Tools in Windows:**
- Choose File > Exit.

---

### Sharing Sessions Between Pro Tools TDM Systems and Pro Tools LE Systems

Pro Tools makes it easy to share sessions between Pro Tools LE and TDM-equipped systems. There are some important differences between the two types of systems that can affect how session material is transferred.

**Differences between TDM and LE systems**

<table>
<thead>
<tr>
<th>Feature</th>
<th>TDM Systems</th>
<th>LE Systems</th>
</tr>
</thead>
<tbody>
<tr>
<td>Number of Audio Tracks</td>
<td>up to 256 (HD-series)</td>
<td>up to 32 (Pro Tools 6.0 on all systems, Pro Tools 5.3.1 and later on Windows)</td>
</tr>
<tr>
<td></td>
<td>up to 128 (MIX-series)</td>
<td>up to 24 (Pro Tools 5.3.x and earlier on Macintosh, Pro Tools 5.1.x and earlier on Windows)</td>
</tr>
<tr>
<td>Number of Mix Busses</td>
<td>64 busses</td>
<td>16 busses</td>
</tr>
<tr>
<td>Inserts per Track</td>
<td>up to 5 inserts</td>
<td>up to 5 inserts</td>
</tr>
<tr>
<td>Sends per Track</td>
<td>up to 5 sends</td>
<td>up to 5 sends</td>
</tr>
</tbody>
</table>

When opening a TDM session in Pro Tools LE, the following rules apply:

**With Pro Tools LE 6.0 and later (all systems) or Pro Tools 5.3.1 and later (Windows):**
- Any tracks beyond the first 32, as well any inactive tracks, are set to *voice off*.
- Multichannel surround tracks are removed from the session.
◆ Any assignments to busses beyond 16 are made inactive.
◆ Unavailable input and output paths are made inactive.
◆ TDM plug-ins with RTAS equivalents are retained; those without equivalents are made inactive.

With Pro Tools LE 5.3.x and earlier (Macintosh) or Pro Tools LE 5.1.x and earlier (Windows):
◆ Any tracks beyond the first 24, as well any inactive tracks, are removed from the session.
◆ Multichannel surround tracks are removed from the session.
◆ Any assignments to busses beyond 16 are made inactive.
◆ Unavailable input and output paths are made inactive.
◆ TDM plug-ins with RTAS equivalents are retained; those without equivalents are made inactive.

Preferences
The Preferences dialog has several tabbed pages in which you can specify your preferred settings for various session parameters. Each new session will use these preferences.

Display Preferences

Edit Window Follows Bank Selection If you are using a supported control surface with Pro Tools, this option scrolls the Edit window to display the selected bank of tracks when you switch banks on the control surface, ensuring that the current bank is viewable on-screen.

Show Meters in Sends View When the Sends View is displaying individual send controls, you can select this option to show send level meters. Deselecting this option can help speed up screen redraws and processing.

Mix Window Follows Bank Selection If you are using a supported control surface with Pro Tools, this option scrolls the Mix window to display the selected bank of tracks when you switch banks on the control surface, ensuring that the current bank is viewable on-screen.

Draw Grids in Edit Window Adds grid lines to the Edit window. Grid line resolution is based on the zoom level of the Edit window.

Draw Waveforms Rectified Displays audio waveform data in rectified view. In this view, audio waveforms are displayed so that their positive and negative waveform excursions (the portions
that fall above and below the center line) are summed together and viewed as a single positive-value signal. This view allows more waveform detail to be seen in either normal or reduced track height views. It can be particularly useful when editing volume automation data, since it depicts waveform levels as starting at the bottom of the track.

**Recompute Invalid Overviews** Prompts Pro Tools to look for missing or corrupted overview data (the data used to create waveform displays) when it opens sessions. If Pro Tools finds that overview data is missing or corrupted, it will recreate one or more overviews for the session. This may take some time if there are many tracks in the session. If you suspect that overview data for a session has become corrupted, or if you import audio files which have no overview data into a session, make sure this preference is enabled for the session, save and close the session, then reopen it. Pro Tools will recreate any overviews for the session when it opens.

**Edit Window Default Length** This option allows you to set a default length for the Edit window in hours, minutes, seconds, and frames. This is useful if you want to assemble a session of a particular length or leave extra room to expand the Edit window’s work area in your session. There is a 13 hour maximum limit for the length of a Pro Tools session.

**Zoom Toggle Track Height** Sets the default track height when the Zoom Toggle function is used to zoom in on a selection.

**Edit Window Color Coding**

Edit Window Color Coding determines how colors are assigned to the waveform display in the Edit window.

**None** Turns off color assignment to the waveform display of tracks in the Edit window.

**Tracks and MIDI Channels** Assigns a color to the waveform display of each track in the Edit window according to its voice number and MIDI channel assignment.

**Tracks and MIDI Devices** Assigns a color to the waveform display of each track in the Edit window according to its voice number and MIDI device type.

**Groups** Assigns a color to the waveform display of each track in the Edit window according to its group ID. If groups are suspended using the Suspend Groups command, all waveforms will be displayed in black.

**Peak Hold Options**

These options determine how long the peak indicators on track meters stay lit after a peak is detected.

**3-Second Peak Hold** When this option is selected, track meters display the last peak level for three seconds.

**Infinite Peak Hold** When this option is selected, track meters display the last peak level until you click them to clear them.

**No Peak Hold** When this option is selected, track meters do not hold the peak level.
Operation Preferences

Timeline Insertion Follows Playback This option causes the screen’s play cursor to update its location to the point where playback stops.

Edit Insertion Follows Scrub/Shuttle When selected, the edit cursor automatically locates to the point where scrubbing stops.

Support Background Record Applications Allows other audio recording applications to run in the background concurrently with Pro Tools. Files recorded in the background can be imported into Pro Tools, and then trimmed and viewed while recording continues.

Sends Default to –∞ Sets the initial fader level of newly-created Sends to –∞ (no audible signal level).

Audio During Fast Forward/Rewind When selected, audio is audible during fast-forward or rewind.

Limit Pull Ups to NTSC/PAL Film Standards This option, which is selected by default, filters the list of available Pull Up rates that appears in the Session Setup window.

Latch Record Enable Buttons When this option is deselected, it prevents multiple audio tracks from being record-enabled. Record-enabling an audio track takes any other audio track out of record-enabled mode.

Latch Solo Buttons When this option is deselected, it prevents multiple tracks from being soloed. Soloing a track mutes any track that is soloed.

Link Mix and Edit Group Enables When this option is selected, it links enabling and disabling of Mix and Edit groups. For example, enabling Group A in the Edit Window automatically enables Group A in the Mix window.

Use F11 Key for Wait for Note When this option is selected, pressing the F11 Function key puts MIDI recording in Wait for Note mode.

Numeric Keypad Mode
Numeric Keypad Mode determines how the numeric keypad functions. You can always use the numeric keypad to select and enter values in the Event Edit Area, Location Indicators, and Transport fields.

Classic Emulates the way Pro Tools worked in versions earlier than 5.0. With the Numeric Keypad Mode set to Classic, you can play up to two tracks of audio in Shuttle Lock mode. Press Control (Macintosh) or the Start key (Windows), followed by 0–9 for different play speeds. Press Plus (+) or Minus (–) to reverse direction. Recall Memory Locations by typing the Memory Location number, followed by period (.).

Transport Allows you to set a number of record and play functions, and also operate the Transport from the numeric keypad. With the Numeric Keypad Mode set to Transport, you can play up to two tracks of audio in Shuttle Lock mode. Press Control (Macintosh) or the Start key (Windows), followed by 0–9 for different play speeds. Press Plus (+) or Minus (–) to reverse direction. Recall Memory Locations by typing the Memory Location number, followed by period (.)
key (Windows), followed by 0–9 for different play speeds. Press Plus (+) or Minus (–) to reverse direction. Recall Memory Locations by typing period (.), the Memory Location number, and period (.) again.

**Shuttle (TDM Only)** Selects a type of shuttling different from that of Shuttle Lock mode. With the Numeric Keypad Mode set to Shuttle, playback is triggered by pressing and holding the keys on the numeric keypad—playback stops once the keys are released. Various playback speeds are available in both forward and reverse. You can also recall Memory Locations by typing period (.), the Memory Location number, and period (.) again.

**AutoSave**

This preference determines how the AutoSave feature functions.

**Enable Session File Auto Backup** When this option is selected, Pro Tools automatically saves backups of your Pro Tools session file while you work. Use the Keep and Backup Every fields to specify the total number of incremental backups that are kept and how often the session is saved.

**Online Options**

**Record Online at Time Code (or ADAT) Lock** When this option is selected, online recording begins as soon as Pro Tools receives and locks to time code or ADAT sync.

**Record Online at Insertion/Selection** When this option is selected, online recording begins at the Edit cursor location. Recording continues until Pro Tools stops receiving time code. If you make a selection, Pro Tools records online for the length of the selection.

**Open Ended Record Allocation**

This preference determines how much of your available hard drive space is allocated for recording.

**Use All Available Space** When selected, the drive's entire available space is allocated. This can sometimes slow down the recording process for hard drives that use certain file systems, including HFS+ and NTFS.

**Limit To** Sets the maximum allowable recording duration. This can help reduce the time it takes to begin recording by allocating only a portion of your hard drive. The number of minutes specified is allocated for each record-enabled track. You may find it necessary to experiment with this number to achieve the desired performance for recording.

**Machine Control**

These preferences determine how a connected transport responds to Pro Tools.

**Machine Chases Memory Location** When selected, navigating to a specific location in a session with a Memory Location causes a connected transport to chase to that location.

**Machine Follows Edit Insertion/Scrub** When selected, navigating to a specific location in a session by moving the selection point or by scrubbing a track will cause a connected transport to chase to that location.

**Machine Cues Intelligently** When selected, if you navigate to a cue point that is more than 10 seconds from the current location, Pro Tools will command a connected transport to shuttle to the new location at full speed to within 10 seconds of the cue point. Cueing will then slow to normal speed until the point is reached. This significantly speeds up tape cueing.
Stop at Shuttle Speed Zero Causes Pro Tools to send a Stop command whenever you stop shuttling. This is useful if you have a machine that requires an explicit stop command to park correctly.

Remote Mode (9-pin Deck Emulation) (TDM Systems Only)

Punch In Frame Offset Sets an offset (in frames) to compensate for punch in timing advances or delays.

Punch Out Frame Offset Sets an offset (in frames) to compensate for punch out timing advances or delays.

Delay After Play Command Sets an offset (in frames) to compensate for lockup time of external machines.

Ignore Track Arming Sets Pro Tools to ignore incoming track arming (record enable) commands. This is useful if you are using a master controller to arm tracks on other machines, but you don’t want to arm tracks in Pro Tools.

Auto Regions Fade In/Out Length Sets a default length for fade-ins and fade-outs automatically applied to region boundaries. Using automatic fade-ins and fade-outs saves you the trouble of editing to zero-crossings or creating numerous rendered fades in order to eliminate clicks or pops in playback. Autofades are not written to disk. Value range is from 0–10 ms for the Auto Region Fade In/Out Length. A value of zero (the default) means that no auto-fading will occur. The Auto Fade value is saved with the session, and is automatically applied to all free-standing region boundaries until you change it.

Calibration Reference Level Sets a default calibration reference level in dB when Pro Tools is in Calibration mode.

Recall Original Track Selections When this option is selected, Memory Locations that recall a selection also recall the track in which the selection was made.

Auto-Name Memory Locations When Playing When this option is selected, Pro Tools gives new memory locations default names based on their time location in the session. The time units currently chosen in the Display menu determine the units for the names.

Auto-Name Separated Regions When this option is selected, Pro Tools automatically names newly separated regions by appending a number to the region’s name.

Region List Selection Follows Track Selection When this option is selected, selecting a region in a track also selects it in the Regions List.

Track Selection Follows Regions List Selection When this option is selected, selecting a region in the Regions List causes Pro Tools to highlight that region’s occurrence in a track.
Crossfade Preview Pre-Roll
This option specifies the amount of pre-roll to be added when you are auditioning crossfades in the Fades dialog.

Crossfade Preview Post-Roll
This option specifies the amount of post-roll to be added when you are auditioning crossfades in the Fades dialog.

Default Fade Settings

Fade In
Selects the default envelope shape for fade-ins.

Crossfade
Selects the default envelope shape for crossfades.

Fade Out
Selects the default envelope shape for fade-outs.

Conversion Quality
Selects the sample rate conversion quality. Sample rate conversion is used in a variety of Pro Tools processes including converting and importing audio files of different formats into a session, and bouncing and saving tracks to a different sample rate or bit depth. The higher the quality of sample rate conversion you choose, the longer Pro Tools will take to process the audio file.

“Matching Start Time” Takes List
When you Command-click (Macintosh) or Control-click (Windows) a region in a track, Pro Tools displays a list of regions whose time stamp matches the current cursor location. The following preferences determine which regions, or takes, appear in this list:

Take Region Names That Match Track Names
When this option is selected, only regions that share the same root name with the track and playlist appear in the Takes List pop-up menu.

Take Region Lengths That Match
When this option is selected, only regions that match the length of the current selection appear in the Takes List pop-up menu.

“Separate Region” Operates On All Related Takes
When this option is selected, editing a region with the Separate Region command also affects all other related takes with the same User Time Stamp. This option helps you compare different sections from a group of related takes.

QuickPunch Crossfade Length
Specifies a default length for crossfades created by QuickPunch recording. Crossfades occur before the punch in and after the punch out.

Levels Of Undo
Sets the maximum number of actions (up to 16) that can be undone with the multiple undo feature. Setting this to a lower number can speed up the performance of slower computers.
Automation Preferences

Faders Move During Playback When this option is selected, on-screen faders move if automation has been written for them. When this option is deselected, on-screen faders do not move, but automation still functions. Deselecting this option can help speed up screen redraws and processing.

Smooth and Thin Data After Pass When this option is selected, Pro Tools automatically smooths and then applies the specified amount of thinning to the automation data created in an automation pass. (See “Thinning Automation” on page 434.)

Write Switches To Touch After Pass (TDM Systems Only) When this option is selected, after an automation pass in Auto Write mode, Pro Tools automatically switches to Auto Touch mode. On TDM systems, you can choose to stay in Auto Write mode by deselecting this option.

⚠️ Write Switches to Touch After Pass does not affect Trim mode. In Trim mode, tracks do not automatically change from Trim/Auto Write to Trim/Auto Touch after an automation pass.

Mutes Follow Groups When this option is selected, muting a track that belongs to a Mix group mutes all members of the group. When this option is deselected, tracks are muted individually. You can also mute individual group members by Control-clicking (Macintosh) or Right-clicking (Windows) their Mute buttons.

Solos Follow Groups When this option is selected, soloing a track that belongs to a Mix group solos all members of the group. When this option is deselected, tracks are soloed individually. You can also solo individual group members by Control-clicking (Macintosh) or Right-clicking (Windows) their Solo buttons.

Send Mutes Follow Groups When this option is selected, muting a Send on a track that belongs to a Mix group mutes the corresponding Send (A–E) on all members of the group. When this option is deselected, Sends are muted individually. You can also mute individual group members by Control-clicking (Macintosh) or Right-clicking (Windows) their Solo buttons.

Send Levels Follow Groups When this option is selected, adjusting the level of a Send on a track that belongs to a Mix group adjusts the level of the corresponding Send (A–E) on all members of the group. When this option is deselected, Send levels are adjusted individually. You can also adjust individual group members by Control-dragging (Macintosh) or Start-dragging (Windows) their Send level faders.

LFEs Follow Groups When this option is selected, adjusting an LFE control of a track or send that belongs to a Mix group adjusts the LFE controls of all members of the group. When this option is deselected, LFE controls are adjusted individually. You can also adjust individual group members by Control-dragging (Macintosh) or Start-dragging (Windows) their LFE controls. With send-based LFEs, grouping affects only that Send (A–E) on other tracks.
**Degree of Thinning** Specifies the amount of thinning performed on automation data when you use the Thin Automation command, or if you have selected the Smooth and Thin Data After Pass option. (See “Thinning” on page 426.)

**Touch Timeout** If you are writing automation in Auto Touch mode and you stop moving a non-touch sensitive control, Pro Tools continues to write automation for the Touch Timeout value. After the Touch Timeout period, writing of automation stops and the automation data returns to its previous automation value at the rate specified in the **AutoMatch Time** setting.

**AutoMatch Time** If you are writing automation in Auto Touch mode, when you release a fader or control, writing of automation stops and the automation data returns to its previous automation value. The rate of return to the previous value is the AutoMatch Time. See “AutoMatch” on page 426.

**Amount of memory to reserve for automation recording** Allocates memory for automation. See “Setting the Automation Buffer Size” on page 427 for details.

---

**Processing Preferences**

![Processing Preferences](image)

**AudioSuite Dither**

**Use AudioSuite Dither** When selected, applies dither to specific AudioSuite processing tasks, such as Gain and Normalize.

**Dither Plug-In** Specifies the plug-in used for dither processing when the Use AudioSuite Dither option is selected.

**Edit Settings** When a Digidesign dither plug-in is used, allows you to apply either normal or noise-shaping dither.
**Bit Depth**

*16-, 18-, 20-, and 24-Bit* allows you to select a bit depth for the dithered audio.

**AudioSuite Buffer Size**

Audio Suite Buffer Size sets the size of the memory buffer used for audio processing and previewing with AudioSuite plug-ins. Generally, choosing a smaller buffer speeds up AudioSuite audio previewing functions. Choosing a larger buffer speeds up AudioSuite processing functions. Set the buffer according to your current task. Before auditioning an AudioSuite plug-in, set the buffer to Mini or Small. When you process a file, set it to Large or Jumbo.

**TC/E**

**TC/E Plug-In** Allows you to choose the plug-in used for Time Compression and Expansion when you edit audio with the Time Trimmer tool. The Time Trimmer works by using Time Compression/Expansion to match an audio region to the length of another region, a tempo grid, a video scene, or other reference point.

**Default Settings** Specifies the default settings used by the chosen Time Compression/Expansion plug-in.

**Compatibility Preferences**

**Convert All Imported “WAV” Files To AES31/BroadcastWave** When selected, this option applies to all newly imported .WAV files, making them compliant with the AES31/EBU Broadcast standard.

**Avid Compatibility Mode** When selected, ensures that all imported OMF media files are treated as Read-Only and prevents destructive editing processes such as those used by the Pencil and Time Trimmer tools and AudioSuite processing.
MIDI Preferences

**Play MIDI Notes When Editing** When selected, causes MIDI notes to sound when you insert them with the Pencil or drag them with the Grabber.

**Default Note On Velocity** Sets the default Note On velocity for MIDI notes inserted in the Edit window and the MIDI Event List.

**Pencil Tool Resolution** Sets the default resolution for MIDI controller data created with the Pencil. Setting this to a lower resolution helps avoid creating controller data that is unnecessarily dense. The value range is from 1 to 100 milliseconds.

**Global MIDI Playback Offset** Sets an offset in samples to compensate for MIDI latency. Entering a value here has the same effect as setting an offset with the MIDI Track Offset command (Windows > MIDI Track Offset). Offset values can be positive (later) or negative (earlier).

**MIDI Note Display** Sets the reference for middle C as C3, C4, or MIDI note number 60.

**Default Thru Instrument** Sets the default MIDI Thru instrument from your available MIDI instruments.
Chapter 7: I/O Setup

The I/O Setup dialog provides tools to label, format, and map Pro Tools input, output, insert, bus, and SampleCell signal paths for each session. (SampleCell paths are available only on MIX-series systems with TDM-equipped SampleCell cards.)

A signal path is a logical grouping of multiple inputs, outputs or busses that has a single name and (channel) format. In Pro Tools, paths are similar to stems, known to the film and video industries (see “Stems and Stem Mixes” on page 67). The I/O Setup dialog lets you define and name paths according to the needs of each project.

On HD-series systems, the I/O Setup Dialog provides a graphical representation of the signal routing for each connected audio interface, with controls to route physical ports to Pro Tools inputs and outputs. These controls mirror the routing controls found in the Hardware Setup dialog—changes made to physical routing in one dialog are always reflected in the other.

Each Pro Tools system can have a different I/O Setup configuration, determined by:

• Whether it is a Pro Tools LE system or a Pro Tools TDM system
• Whether it is an HD-series, MIX-series, or Pro Tools|24 system
• On TDM systems, the number and types of audio interfaces
• On TDM systems, the mixer plug-in currently installed

Each Pro Tools session retains its path configurations as I/O Settings. The I/O Settings saved with the session are loaded automatically when the session is opened. Unavailable items (including hardware, paths, or required resources) remain in the session as inactive items (see “Active and Inactive Paths” on page 75).

When you create a new session, you can specify a default I/O Setup configuration, including presets for stereo or multichannel mixing formats (multichannel mixing requires an HD-series or MIX-series system).

The I/O Setup dialog also lets you save and import I/O Settings files.
**Paths in Sessions**

In sessions, audio is routed using the track Input, Output, Insert, Plug-in, and Send Selectors. These selectors let you assign tracks to hardware outputs and inputs, internal busses, and other Pro Tools signal paths.

Paths comprise the lists of available signal routing choices in track input, output, insert and send selectors.

**Paths and I/O Setup**

The signal routing choices available in a session are defined in the I/O Setup dialog.
Main Paths and Sub-Paths

Paths in the I/O Setup dialog include main paths and sub-paths.

Main Paths

Main paths are logical groupings of inputs, inserts, busses, or outputs. For example, a master stereo output path could be named Main Out. Path names in a stereo path are often appended with “.L” and “.R” for left and right.

Sub-Paths

A sub-path represents a signal path within a main path. For example, a default stereo output path consists of two mono sub-paths, left and right. Mono tracks and sends can be routed to either mono sub-path of the stereo output path.

Default Settings Files

The default Stereo settings file is available on all Pro Tools systems, and provides stereo main paths, each with its own mono sub-paths.

Multichannel settings files are available for Pro Tools HD-series and MIX-series systems. These settings provide specialized path definitions for surround mixing. See “Configuring Pro Tools for Multichannel Sessions” on page 478.

Default Path Names

Default names for input, output, and insert paths are based on the type of system (LE systems) or the type and number of interfaces (TDM systems) you are using.

Stems and Stem Mixes

The use of stems and stem mixes originated in the post production industry as a method to organize and manage elements of a mix by type or content.

For example, a film mix often requires a stem mix for Foley, a stem mix for sound effects, a stem mix for dialog, and another for music. The dialog stem, for example, would contain all the dialog elements mixed relative to each other. The dialog stem can then be mixed with the other stems during the final mix of the scene or reel. The final mix is simplified by the ability to control the level of each stem, rather than the multitude of individual tracks that comprise a typical film mix.

In Pro Tools, you can work with main and sub-paths as you would stem mixes. These can be assigned as needed, including the ability to assign multiple outputs to individual tracks and sends. For more information, see “Multiple Output Assignments” on page 387.
The I/O Setup Dialog

The I/O Setup dialog defines Pro Tools input, output, insert, and bus paths. Routing I/O ports to Pro Tools inputs and outputs can also be done here.

To open the I/O Setup dialog:

1. Make sure your audio interfaces are enabled and configured properly in the Hardware Setup.
2. Choose Setsups > I/O Setup.

To open the Input, Output, Insert, Bus or SampleCell page in the I/O Setup dialog:

- Click the corresponding tab at the top of the I/O Setup dialog.

Closing the I/O Setup Dialog

You can click Cancel at any time to close the I/O Setup dialog. When you click OK, Pro Tools checks several settings for routing validity (to prevent feedback loops). If there are any overlapping or invalid settings, you will be required to correct them before the I/O Setup dialog will close. For more information, see “Initializing I/O Setup” on page 75.
I/O Setup Dialog Controls

This section provides an overview of the controls in the I/O Setup dialog.

**Path Type Tabs** Select the type of I/O to configure. Choices are Inputs, Outputs, Inserts, Busses, or SampleCell. (SampleCell paths are available only on MIX-series systems with TDM-equipped SampleCell cards.)

**Input and Output Selectors** Select the physical ports on your audio interface to route to Pro Tools inputs and outputs. Ports are selectable in channel pairs. Available ports for each displayed interface are based on Hardware Setup settings; for example, if the AES/EBU inputs and outputs of an interface are enabled in Hardware Setup, they are available for routing in I/O Setup. The functionality provided with the Input and Output Selector is the same as that provided on the Main page of the Hardware Setup dialog.

**Path Name Column** Shows paths that are available for selection, including the name of each defined path.

**Expand/Collapse** Shows or hides the sub-paths associated with a main path.

**Active/Inactive Status** Shows and changes the active/inactive status of each path.

**Path Format Selector** Shows and selects the type/format (such as Mono, Stereo, Quad, or 5.1) of each defined path.

**Channel Grid** Maps paths to specific interfaces and channels.

**Path Tools** Customize the I/O Setup configuration. Buttons include: New Path, New Sub-Path, Delete Path, and Default.

**Show Original Setup** Appears in the I/O Setup dialog in certain session transfer situations. For details on this feature, see “Show Original Setup and Show Current Setup” on page 77.

**Options** Provide pop-up menus to set paths or orders for Meter, Audition (Regions List previewing), Default Output (for new tracks), and Default Path Order. See “Default Output, Meter, Audition, and Default Path Order I/O Setup Options” on page 80.

Routing Hardware I/O to Pro Tools I/O

The I/O Setup dialog lets you define which physical ports on your I/O peripheral are routed to available inputs and outputs in Pro Tools. The Input and Output Selectors in the I/O Setup dialog serve as a patchbay that allows you to route any of the physical inputs or outputs to your Pro Tools mixer.
To configure I/O routing in I/O Setup:

1. Choose Setups > I/O Setup.
2. Click the Input or Output tab to display the corresponding path type.
3. Click the Input or Output Selector for the first interface channel pair, located below the first audio interface icon.
4. From the pop-up menu, select a physical port pair (such as Analog 1–2), to route to a Pro Tools channel pair (such as A 1–2) in the Path Name column on the left.
5. Repeat the above step for additional channel pairs.
6. Click OK.

Routing a Pro Tools Output Pair to Multiple Destinations

Pro Tools channel pairs can be routed to multiple outputs on an audio interface through the I/O Setup dialog. For example, if you assign both Analog 1–2 and Analog 3–4 interface outputs to Pro Tools Output pair 1–2, when you send a signal to Pro Tools Outputs 1–2, that signal will be routed simultaneously to both pairs of output ports on your audio interface.

This lets you send the same signal (such as a stereo pair, a stem mix, or a multichannel mix) to multiple destinations (such as multiple mastering devices).

To route a Pro Tools output channel pair to multiple audio interface output ports:

1. Choose Setups > I/O Setup.
2. Click the Output tab.
3. Click the Output Selector for an interface channel pair, just below an audio interface icon.
4. From the pop-up menu, select a physical port pair (such as Analog 1–2) to route to the corresponding Pro Tools channel pair (such as A 1–2) in the Path Name column on the left.
5. Control-click (Macintosh) or Start-click (Windows) the same Output Selector and select an additional output pair from the same pop-up menu.

The output name updates with a plus sign (“+”) before it to indicate that multiple output ports are selected. In the pop-up menu, each physical port pair assigned to that Pro Tools output pair is indicated by a check mark.

6. Repeat the above steps to select additional output destinations. The only limit to output choices is the number of outputs available in your system.

Output path assignments cannot overlap. See “Valid Paths and Requirements” on page 75 for details.

Pro Tools outputs pairs can also be routed to multiple audio interface outputs in the Hardware Setup dialog. For more information, see “Routing a Pro Tools Output Pair to Multiple Destinations” on page 45.
Creating and Editing Paths

The I/O Setup dialog lets you create and customize signal path definitions.

Paths can be:
- Renamed, for easier identification after changing or renaming audio interfaces
- Remapped, to or from different sources or destinations
- Deactivated (or reactivated) to manage unavailable or unnecessary I/O resources
- Deleted

In addition, you can import and export your I/O Setup configurations as I/O Settings files, as well as set default path parameters.

The following table lists the available path attributes for each path type.

Path Options by Type

<table>
<thead>
<tr>
<th>Path Type</th>
<th>Path Options (Attributes)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Input</td>
<td>Names, formats, and source channel (analog or digital audio interface, or CPU input)</td>
</tr>
<tr>
<td>Output</td>
<td>Names, formats, and destination (audio interface output channel or internal send bus)</td>
</tr>
<tr>
<td>Insert</td>
<td>Names, formats and destination (audio interface channels)</td>
</tr>
<tr>
<td>Bus</td>
<td>Names and formats</td>
</tr>
<tr>
<td>SampleCell (MIX-series only)</td>
<td>Input names</td>
</tr>
</tbody>
</table>

Creating a Default Main or Sub-Path

You can set an I/O Setup path type to its default path configuration at any time.

To restore default paths and pathnames:

1. Choose Setups > I/O Setup.
2. Click the Input, Output, Insert, Bus, or SampleCell tab to display the corresponding path type.
3. Click Default.

Pro Tools creates all possible stereo main paths. Mono sub-paths are also auto-created for every stereo main path. These default path names appear in a session’s track Input and Output Selectors.

Default stereo output paths

To optimize Pro Tools DSP resources, it is best to create mono sub-paths for Outputs and Busses, rather than mono main paths.
Creating New Paths

You can create new main path and sub-paths with custom names, format, and mapping. Custom path names appear in a session’s track Input and Output Selectors.

To create a new path:

1. Choose Setups > I/O Setup.
2. Click the Input, Output, Insert, Bus, or SampleCell tab to display the corresponding path type.
3. Click New Path, or press Command+N (Macintosh) or Control+N (Windows).
   - or -
4. Select a main path and click New Sub-Path.
5. Double-click in the Name field and enter a name for the path. Press Tab to move to the next editable field, or press Return (Macintosh) or Enter (Windows) to set the new path name.
6. Choose a format from the Path Format Selector (mono, stereo, or multichannel).
7. Repeat the previous steps to configure other path types (Input, Output, Insert, Bus, or SampleCell).

Selecting and Arranging Paths

Individual and multiple paths can be selected in the I/O Setup dialog Path Name column. Selected paths and sub-paths can be moved higher or lower in the Path Name column to change their menu order in track Input and Output Selectors. Paths can also be deleted. Sub-paths follow their main paths when they are moved in the I/O Setup dialog.

To select a main path or sub-path:

- Click the path name.

To select multiple main paths or sub-paths:

- Shift-click the path names.

To select all paths and sub-paths:

- Option-click (Macintosh) or Alt-click (Windows) any path name.

To rearrange paths:

- Drag one or more path names up or down.
Chapter 7: I/O Setup

Resetting Paths

The Default button in the I/O Setup dialog provides two primary functions:

- Creates new, default paths up to the capacity of your system's available audio interfaces and resources. See “Creating a Default Main or Sub-Path” on page 71.
- Resets selected path names to matching or corresponding paths in the current I/O Setup configuration. For example, if you change modes on Digi 001, or replace an audio interface on a Pro Tools HD-series or MIX-series system, you can use the Default switch to update your I/O Setup definitions with the new hardware configuration.

On TDM systems, audio interface names can be customized. See “TDM Audio Interface Names” on page 73.

To reset path names:

- Click Default.

If there are matching paths available with the new system configuration, existing paths will be updated to include new audio interfaces (TDM systems), or I/O mode selection (Digi 001 only).

Resetting Mix Busses (TDM Only)

Pro Tools 5.3 and later supports up to 64 mix busses for TDM systems. However, when you open a session created with Pro Tools 5.0.1 or earlier, only 32 busses are initially available.

To make 64 busses available in sessions created with Pro Tools 5.0.1 or earlier:

1. Open the I/O Setup dialog.
2. Click the Bus tab in the upper left.
3. Click Default.

To delete a main path or sub-path:

1. In the I/O Setup dialog, select the path you want to delete.
2. Click Delete Path.

To delete all paths:

1. Option-click (Macintosh) or Alt-click (Windows) any path name.
2. Click Delete Path.

TDM Audio Interface Names

With TDM-equipped Pro Tools systems, audio interface names can be customized in the I/O Setup dialog. The I/O Setup dialog then bases default path names on the custom names.

To rename an audio interface in the I/O Setup dialog:

- Double-click the text above an interface, enter a new interface name, and press Return (Macintosh) or Enter (Windows).

Deleting Paths

Path definitions can be deleted from the current session to reflect changes to your hardware setup, or to clean up track selector menus by removing unwanted or unnecessary path definitions. After deleting a path, any tracks or send assignments to that path are reset to No Output.

To delete a main path or sub-path:

1. In the I/O Setup dialog, select the path you want to delete.
2. Click Delete Path.

To delete all paths:

1. Option-click (Macintosh) or Alt-click (Windows) any path name.
2. Click Delete Path.
Channel Mapping

Once a path has been created and formatted, it can be mapped to specific audio interface, bus, or SampleCell channels in the Grid.

To map channels:

1. Select a main or sub-path.

2. In the row for the selected path, click in the Grid column under an audio interface and channel. Other channels for the path type, if any, fill to the right.

For example, when mapping a new stereo path, clicking in the path row under output channel 1 fills both channel 1 and 2 (left to 1, right to 2).

To remap channels in a path, see “Remapping Channels” on page 74.

Channel Mapping and Surround Mixer
(Pro Tools HD-Series and MIX-Series Systems Only)

When mapping multichannel paths, the left channel (L) is mapped first to the clicked Grid box, and remaining channels fill immediately to the right according to the default path order. Because some multichannel mixing formats use unique track layouts, Pro Tools lets you set the default format in the I/O Setup dialog (see “Default Output, Meter, Audition, and Default Path Order I/O Setup Options” on page 80).

Remapping Channels

You can move the individual assignments to different channels, to reorder the path’s definition (for example, changing a multichannel map to L-R-C-Sub-LS-RS).

To remap channels in a path:

- Drag the channel to the new location in the Grid. Other channel assignments will move (shuffle) to accommodate dragged channels.
Channel Shuffling

Moving a signal from right to left results in a shuffle of other signals after the new destination channel. Moving a signal from left to right shuffles any and all signals after the new destination channel and leave the previous channel empty.

⚠️ Changing a path’s format erases any current channel mapping.

Sub-Paths Follow Main Paths

When a main path is remapped, its sub-paths (if any) will remap automatically to maintain consistent routing. For example, remapping a stereo path to different hardware outputs results in any of its sub-paths moving with it.

Initializing I/O Setup

To set the current I/O Setup configuration:
- Click OK in the I/O Setup dialog.

All paths must be valid before the I/O Setup configuration can be applied.

Valid Paths and Requirements

While configuring the I/O Setup window, certain rules apply for path definition and channel mapping.

Though it is possible to set up invalid mappings in the Channel Grid, Pro Tools will not accept an I/O Setup configuration unless all paths meet the path definition and channel mapping requirements described below.

Minimum Path Definitions

All paths must have a name, be of a specific format, and have a valid I/O mapping.

Overlapping Channels and Valid Paths

Channel mapping follows certain rules regarding overlapping paths.

- There can be no partial or complete overlaps between any two main Output paths, any two Insert paths, or any two main Bus paths.
- A newly-created Output or Bus path must either be completely independent of other maps (not mapped to any other available I/O interface/channels), or it must be a sub-path completely contained within a larger path (for example, an LCR sub-path within a larger 5.1 path).
- Output and Insert paths can overlap in I/O Setup, but only one or the other can be used at any given time in a session. (Inputs and Sample-Cell paths, however, can be routed to multiple tracks.)

Active and Inactive Paths

Pro Tools paths can be Active (on) or Inactive (off, or unavailable). You can manually switch paths between Active or Inactive on a track-by-track or session-wide basis. In addition, Pro Tools sets paths to Inactive automatically when I/O is unavailable.

Track Path Assignments

Track input, output, and bus path assignments can be switched to Inactive using the corresponding selector on the track. This leaves track playlists intact, while disconnecting that particular track from the output or bus path. Use this to remove a track from a signal path.
Session-Wide Path Assignments

Paths can be globally activated or deactivated in the I/O Setup window. Use this to turn off a signal path on any and all tracks currently assigned to it. Pro Tools also sets unavailable paths to inactive. Paths can be unavailable when hardware or other system resources are unavailable, such as when opening a session saved on a different system.

Track Path Assignments

(Mix and Edit Windows)

To toggle a track path assignment to be Active or Inactive:

- In the Mix or Edit window, Command-Control-click (Macintosh) or Control-Start-click (Windows) the track’s Input, Output, Insert, or Send Selector.

Inactive track path assignments are indicated with an asterisk (*) in the track selector menu. (Paths set to globally inactive in the I/O Setup window are listed in italics.)

Toggling All or All Selected

The Option (Macintosh) and Alt (Windows) modifiers apply the path toggle to all tracks. The Option+Shift (Macintosh) or Alt+Shift (Windows) modifiers apply the path toggle to all selected tracks. However, Pro Tools will only apply the change to identical path assignments, if any, in the current track or tracks. Toggling multiple tracks only affects tracks that have the same path assignment as the one you are explicitly toggling.

Toggling Multiple Paths

If a track has only one main output assignment, you can Command-Control-click (Macintosh) or Control-Start-click (Windows) the track’s Output Selector to toggle the main output to inactive. When there are multiple assignments, the track selector will be displayed for you to specify the input, output, insert, or bus path.

If a Send (A–E) has multiple output assignments and one of those is toggled, then all of the output assignments for that Send (A–E) will be toggled.

Session-Wide Path Assignments

(I/O Setup Dialog)

Paths can be globally configured for Active or Inactive status in the I/O Setup Dialog.

Display of Active and Inactive Status

Unhighlighted (Italics) Indicates the path is inactive.

Highlighted (Non-Italics) Indicates the path is active.

Highlighted (Italics) Indicates the path is active, but there are not enough system resources available.

Active and inactive path settings in I/O Setup
To globally activate or deactivate a path:

1 Choose Setup > I/O Setup.

2 Select a path type using the tabs at the top of the window.

3 Set the Active/Inactive control for the path.

Any track path assignment can also be deactivated on a track-by-track basis. See “Active and Inactive Paths” on page 75

Inactive paths are displayed in italics in the track path selectors.

Hardware Setup and Session Transfer

Sessions created in Pro Tools 5.1 and later store the type and order of audio interfaces connected and active when the session was last saved.

Unavailable I/O

When opening a session, Pro Tools checks to see if the hardware configuration has changed since the session was last saved. If the current hardware configuration differs from that saved in the session, paths associated with the unavailable I/O are made inactive.

Remapping

Remapping occurs when a session’s original I/O Setup does not match that of the current system and session paths are remapped to current hardware.

Systems of equivalent I/O capability are remapped directly. For example, a session tracked to a Pro Tools HD-series system through two 192 I/O audio interfaces would include 32 input paths spread across the two 16-channel interfaces. If the session is taken to a different Pro Tools system that has a 96 I/O audio interface (a 16-channel I/O unit) and a 1622 Audio Interface (a 16-channel I/O unit) connected to its Legacy Port. When the session is first opened on the second system, Pro Tools will map the 32 input paths to the inputs of the two interfaces.

When hardware is unavailable to a session being opened, assignments can either be replaced using the remap option, or opened as Inactive. Any tracks left assigned to an unavailable path will not be audible. This can be beneficial, however, when you want to reassign tracks into your system’s mix one at a time.

Show Original Setup and Show Current Setup

When a session is opened that contains path definitions for unavailable I/O modules, the I/O Setup dialog lists those paths in italics.

The Show Original Setup button displays the audio interfaces used in the original session. This temporary display lets you check the original I/O configuration for reference while configuring the session for your system.
Once a session has been opened with unavailable I/O retained, you can then reassign tracks to available I/O paths.

To redefine the paths, see “Creating and Editing Paths” on page 71.

I/O Settings Files

I/O Settings can be managed when transferring sessions, and when developing I/O Setup configurations over the course of multiple sessions and projects.

Defaults, Settings Files, and Last Used Settings for New Sessions

When creating new sessions, you can set the session’s I/O Setup configuration using the following options:

Default I/O Setups The Pro Tools Installer provides factory presets for stereo and surround I/O Setups (surround mixing is only supported on Pro Tools HD-series and MIX-series systems). See “Factory I/O Settings Files” on page 79 for more information.

Custom Presets You can store and recall custom presets using the export and import features of the I/O Setup dialog.

Last Used The most recent (or, last used) I/O Setup configuration is saved as a Last Used settings file. See “Last Used I/O Settings” on page 79 for more information.

Default I/O Settings at First Launch

The first time you create a session, you can choose default Stereo Mix or Surround Mix settings, depending on your system and installation choices. See “Factory I/O Settings Files” on page 79.

Importing and Exporting I/O Settings Files

You can export and import I/O Setup configurations as I/O Settings files. This lets you save settings for different projects, import settings for reconfiguring I/O Setup, and manage path definitions and signal routing setups.

Exporting I/O Settings

To export and save an I/O Setup configuration:

1. Click Export Settings.
2. Name and save the settings file.

To start sessions with a blank or empty I/O Setup dialog, you can create and export an I/O Settings file in which all definitions have been deleted.

Importing I/O Settings

I/O Settings can be imported before you open a session, or you can import settings into a session that is already open. When you import I/O Settings, you can choose to delete any unused path definitions before importing the new paths, or leave unused path definitions intact and add the new paths to the current I/O Setup configuration.

To import I/O Settings:

1. Click Import Settings in the I/O Setup dialog.
2. Select an I/O settings file in the Import Settings dialog and click Import.
3 A dialog appears asking whether you want to delete existing paths. Do one of the following:
   • Click Yes to remove any unused paths and add the imported paths to the current I/O Setup configuration. Any I/O assignments and automation data associated with the unused paths are also deleted.
   • Click No to add the imported paths to the current I/O Setup configuration.

If the import results in overlapping paths, the new paths will appear in the I/O Setup dialog as Inactive. (See “Active and Inactive Paths” on page 75.)

After importing I/O Settings, you can then reassign path routing definitions in the I/O Setup dialog by remapping, renaming, and deleting paths. (See “Creating and Editing Paths” on page 71.)

**Last Used I/O Settings**

If any changes are made to the I/O Setup dialog during a session, these changes are saved to the Last Used settings file when the I/O Setup dialog is closed (by clicking OK).

Changes to I/O Setup are saved along with the current session. User Presets files will not contain recent changes unless you export an updated settings file.

The Last Used settings are available as a choice when creating or opening sessions, in addition to the factory presets described below.

**Factory I/O Settings Files**

Pro Tools provides I/O Settings files for Stereo and Surround mixing. These files provide generic main and sub-path definitions for either mixing format.

**Stereo Mix Settings File**

The Stereo Mix preset consists of all possible stereo and mono paths for your session.

💡 Using the “Stereo Mix” preset has the same effect as clicking Default for every individual tab in I/O Settings. See “Creating and Editing Paths” on page 71 for details.

Specifically, the Stereo Mix preset will create the maximum number paths of each type, as determined by the available system’s I/O Setup and hardware configuration.

**Surround Mix Settings File (TDM Systems Only)**

The Surround Mix provides additional, surround-specific Output and Bus presets. See “Surround Mix Settings Files” on page 479 for more information.

**About Direct Out Mode**

Direct Outputs mode, as found in older versions of Pro Tools, has been replaced by the default mono sub-paths available through all valid I/O in the I/O Setup dialog.

The Default switch creates main Output paths with appropriate mono sub-paths. These sub-paths provide discrete monophonic routing.

When a session is opened that was saved in Direct Outs mode, Pro Tools maps all the output assignments to equivalent mono sub-paths (as available). See “Hardware Setup and Session Transfer” on page 77 for more information on remapping.

To convert a session so that it emulates Direct Outs mode, use the Auto Assign Ascending Outs feature:
To auto assign track outputs for Direct Out:

1. Make sure that all tracks are visible if desired (because the hidden tracks will not be affected).

2. Select all desired tracks (Shift-click each track name).

3. Command-Option-click (Macintosh) or Control-Alt-click (Windows) the Output Selector of the left-most track and assign it to the sub-path for Output #1. All visible tracks will be auto-assigned to unique mono sub-path outputs in ascending order.

Default Output, Meter, Audition, and Default Path Order I/O Setup Options

Pro Tools systems have additional I/O Setup features. These include default signal routing for metering and auditioning, and default track layout for multichannel mix formats.

Default Output Path

You can specify the default Output path assignment for new tracks, in each available format.

To specify a default Output in I/O Setup window:

- Select a format and Output path from the default Output Selector.

Audition Path

The Audition path is the output path through which files and regions are previewed (listened to) in the Regions List.

To audition regions in the Regions List:

- Option-click (Macintosh) or Alt-click (Windows) the region in the list.

Using the Default Audition Path

When you audition a file or region in the Regions List, Pro Tools routes the audio output through the Audition path. Pro Tools assigns a default Audition path to the first available main Output path of the corresponding format. You can also select a different Audition Path in the I/O Setup dialog.

On TDM systems with more than one audio interface, you can only select the first audio interface as an audition path.

Configuring Audition Paths

You can specify the monitoring outputs for Regions List auditioning using the Audition paths menu.

Audition Path Main Menu The main menu consists of all path format choices available on the current system (Mono and Stereo on all systems, LCR and greater on surround-capable systems).

Audition Path Submenus Each path format choice has a submenu listing Output paths of that given format. (The mono submenu lists Output paths of any format.)
To configure Audition Paths:

- Select a path from the Audition path menu or submenus.

Selecting an Audition path

Auditioning Discrete Signals in Multichannel Items

In the Audio Regions List, multichannel regions are auditioned through the current Audition path. Signals can be auditioned “in-place,” or through all outputs, as described below.

Audition In-Place

When auditioning a mono component of a multichannel region, that mono component will by default be auditioned in-place. That is, it will play out the corresponding speaker channel of its parent multichannel region.

To audition in-place:

1. In the Regions List, make sure the stereo or multichannel region is in expanded view (showing .L, .R, and other component channels).
2. Option-click (Macintosh) or Alt-click (Windows) the region for the desired channel.

Audition to All Outputs

Mono regions can be routed equally to all outputs of the parent region’s Audition path.

To audition through all channels of the main audition path:

- Shift-Option-click (Macintosh) or Shift-Alt-click (Windows) on the signal in the Regions List.

Default Path Order

(TDM Systems Only)

The Default Path Order Selector lets you select the default track layout you want Pro Tools to follow when creating and mapping 5.1-format main or sub-paths in the I/O Setup dialog.

This setting does not affect existing path definitions or metering—it only specifies channel mapping in new 5.1-format paths.

To choose a Default Path Order:

- Select the channel mapping from the Default Path Order menu.

Default Path Order Selector

For more information about multichannel mixing, see Chapter 31, “Pro Tools Setup for Surround.”

Meter Path Selector

(ProControl Only)

The Meter Path Selector determines the path displayed across the ProControl Output meters. See the latest ProControl documentation for more details.
Chapter 8: Tracks

This chapter covers basic track management tasks such as creating and deleting tracks, assigning voices and output channels, and grouping tracks.

Track Types

In a Pro Tools session, you can have several different types of tracks. These can include audio tracks, Auxiliary Input tracks, MIDI tracks, and Master Fader tracks, and QuickTime Movie tracks. On Macintosh systems, sessions can have AVOption or AVOption XL Movie tracks.

QuickTime Movie track features are described in Chapter 36, “Working with QuickTime Movies.”

Audio Tracks, Auxiliary Input Tracks, and Master Fader Tracks

Pro Tools provides mono, stereo, and multichannel format audio tracks, Auxiliary Inputs, and Master Faders.

Audio Tracks

Audio tracks contain arrangements of recorded (or imported) audio files. Audio tracks can be mono, stereo, or multichannel format (multichannel tracks are supported on Pro Tools HD-series and MIX-series systems only).

Auxiliary Input Tracks

Auxiliary Input tracks can be used as effects sends, destinations for an alternate mix, as a bounce destination, as inputs to monitor or process audio (such as audio from MIDI sources), and for many other audio routing tasks.
Master Fader Tracks
Master Fader tracks control the overall level of the audio tracks that are routed to the session’s main output paths. For example, you could have 24 tracks in a session with channels 1–8 routed to Analog Output 1–2, channels 9–16 to Analog Output 3–4, and channels 17–24 to Analog Output 5–6. You could then create three master faders, one to control each of these output pairs.

MIDI Tracks
MIDI tracks store MIDI note, instrument, and controller data. You cannot select a track format when you create a MIDI track, because audio does not pass through it.

Track Formats
Mono Tracks
A mono audio track, Auxiliary Input, or Master Fader track controls volume, and, in some cases, panning, for a single channel of audio. A mono track uses a single voice.

Stereo Tracks
A stereo audio track, Auxiliary Input, or Master Fader track is a single channel strip that plays two channels of audio as a stereo pair. Stereo tracks use two voices.

Multichannel Tracks (Pro Tools HD-Series and MIX-Series Systems Only)
A multichannel track is a single channel strip that plays multiple channels of audio (from 3–8 channels at a time). This allows Pro Tools to support multichannel mixing formats including 3+1, 5.1, 6.1, and others.

For more information on surround mixing with Pro Tools, see the following chapters:
• Chapter 31, “Pro Tools Setup for Surround”
• Chapter 32, “Multichannel Tracks and Signal Routing”
• Chapter 33, “Surround Panning and Mixing”

Audio Track/Channel Strip
Each audio track has its own set of controls for volume, pan, output window, record enable, automation mode, solo, mute, comments, and voice assignment.

With slight variations, audio track channel strips in the Mix window look like the tracks shown in the following figures.

Audio tracks can be added to a session with the New Track command.
Chapter 8: Tracks

Stereo audio track channel strip (Pro Tools 6.0)

Mono audio track channel strip (Pro Tools 5.1.3)
MIDI Track/Channel Strip

Each MIDI track has its own set of controls for volume, pan, record enable, automation mode, solo, mute, MIDI patch assignment (program change), and MIDI channel assignment.

MIDI tracks can be added to a session with the New Track command.

Track Controls

Input/Output Selectors

The I/O View shows Input and Output Selectors on audio and MIDI tracks.
To show the I/O View:

- Select Display > Edit Window Shows (or Mix Windows Shows) > I/O View.

In Pro Tools 6.0, channel strips in the Mix window always display Input and Output Selectors as well as volume and pan values, so there is no I/O View display option for the Mix window.

For details on Input and Output Selectors, see “Assigning Inputs and Outputs to Tracks” on page 92.

**Volume/Peak/Channel Delay Indicator**

The Volume indicator on an audio track has three display modes: Volume, Peak, and Channel Delay.

**To toggle the Volume indicator display:**

- Command-click (Macintosh) or Control-click (Windows) the indicator to toggle it between the following modes:

  - **Volume Indicator** Shows the current volume, or input level of a track as set by the track Volume fader.

  - **Peak Indicator** Functions as a headroom indicator based on the last peak playback level. To reset the peak counter, click anywhere in the meter. Values range from +6 dB (highest level signal), to → (no signal).

  - **Channel Delay Indicator** Shows the total delay, in samples, incurred on the track from the use of any TDM plug-ins on that channel.

---

**Pan Indicator**

The Pan Indicator displays the current pan setting of a track. Pan values range from <100> (full left) to 100> (full right). Pan controls are only available for stereo tracks or for mono tracks routed to a stereo output.

**Pan Slider**

The Pan slider controls the balance of a track between the assigned output pair. It only appears if you are using stereo tracks or mono tracks routed to a stereo output.

The Pan slider on a MIDI track is effective only if you are controlling a sound module that supports MIDI panning.

**Volume Fader**

The Volume fader controls the volume of a track when it is in playback, and the monitor level of the track when it is in record. You can link the record and monitor levels by enabling the Operation Preference for “Link Record and Play Faders.”

The volume fader on a MIDI track is effective only if you are controlling a sound module that supports MIDI volume.

**Track Level Meter**

On audio tracks, level meters indicate the level of the signal being recorded or played back from the hard drive. Green indicates nominal levels; Yellow indicates pre-clipping (–6 dB below full scale); and Red indicates clipping. When a track is record-enabled, these meters indicate record levels.

On MIDI tracks, the level meter shows the MIDI velocity of the most recent MIDI event.
Pre- and Post-Fader Metering
You can globally set audio track level meters to indicate pre-or post-fader levels by selecting or de-selecting Operations > Pre-Fader Metering. When pre-fader metering is selected, the level meters show levels independent of fader position. With post-fader metering, the level meters respond to fader position.

Peak Hold
If clipping occurs, the topmost LED will stay lit (red). In addition, Pro Tools meters provide a peak hold feature with three options: 3 Second Peak Hold, Infinite Peak Hold, or No Peak Hold.

To choose a peak hold setting:
■ Choose Setups > Preferences, click Display, and select a Peak Hold option.

To clear a meter:
You can clear a meter’s clipping or peak hold indicator by clicking anywhere on the meter.

To clear all meters:
■ Option-click (Macintosh) or Alt-click (Windows) any meter.

Wide Meters View
(Pro Tools 6.0 Only)
Wide Meters View expands the width of the level meters for tracks in both the Mix and Edit windows. Wide Meters View can make the track level meters easier to read.

To enable Wide Meters View:
■ Command-Option-Control-click the track level meters in either the Mix window or the Edit window.

To disable Wide Meters View:
■ Command-Option-Control-click the track level meters a second time in either the Mix window or the Edit window.

Track Comments View
Comments View shows any comments entered in the Track Name/Comments dialog. You can type directly in the Comments area for each track when it is displayed.

To display the Comments View:
■ Select Display > Mix Window Shows (or Edit Window Shows) > Comments.

For details on adding comments to tracks, see “Naming Tracks” on page 89.
Creating Tracks

On all systems, you can create mono and stereo tracks. In addition, on Pro Tools HD-series and MIX-series systems, you can create multichannel tracks.

When new tracks are created, they are given a default name which can be changed at any time.

- For new tracks to appear next to a specific track in a session, select that track by clicking its name (in its track channel strip). The new tracks are added immediately after the selected track.
- For new tracks to appear as the last tracks in a session, make sure that no track names are selected on-screen.

To create a new track:

2. Select the type of track you want to add from the Track Type pop-up menu. For explanation of track types, see “Track Types” on page 83.
3. Select the track format (mono, stereo, or one of the multichannel surround formats) from the Track Format pop-up menu. Surround formats are available only on Pro Tools HD-series and MIX-series systems.
4. Enter the number of new tracks, then click Create.
5. To configure which track controls appear in the Mix window or Edit window, select from Display > Mix Window Shows and Display > Edit Window Shows.

Naming Tracks

Track names are used to auto-name recorded audio files and regions (see “Default Track Names” on page 140).

To rename a track:

1. In the Edit window or Mix window, double-click the Track Name button for the track you want to rename.
2. In the Track Name/Comments dialog, type a new track name.
3 Click Previous or Next to rename other displayed tracks.

- To move to the previous or next track in the Track Name/Comments dialog, you can press Command (Macintosh) or Control (Windows) and use the Up/Down Arrows.

4 Click OK.

**Adding Comments to Tracks**

**To enter comments for a track:**

1 In the Edit window or Mix window, double-click the Track Name button for a track.

2 Click directly in the Comments area, type any comments for the track, and press Return (Macintosh) or Enter (Windows).

- or -

Double-click the Track Name button for the track, type any comments for the track in the Comments text box, and click OK.

- To enter a carriage return in the Comments text box, type Shift+Return (Macintosh) or Shift+Enter (Windows) on the alpha keyboard.

**Deleting Tracks**

When you delete tracks, your audio or MIDI region data will remain in the Regions List, but your arrangement of the regions on the deleted track (the track’s playlist) will be lost.

- The Delete Selected Tracks command cannot be undone.

**To delete a track:**

1 Click the name of the track in its track channel strip to select it.

- To select multiple tracks, Shift-click additional track names.

2 Choose File > Delete Selected Tracks.

3 Click OK to remove the selected tracks from the session.

**Duplicating Tracks**

The Duplicate Selected Tracks command allows you to duplicate one or more tracks, including their audio or MIDI data, playlists, automation, and other attributes.

**To duplicate a track:**

1 Click the name of the track (in its track channel strip) to select it.

- To select multiple tracks, Shift-click additional track names.

2 Choose File > Duplicate Selected Tracks. Each duplicate track is created to the right of its original track.

**Hiding Tracks**

The Show/Hide Tracks List (at the left of both the Mix and Edit windows) lists all tracks in the session. It allows you to show or hide a track in the Mix and Edit windows, by selecting or deselecting its name. Even though a track is hidden, the material on the track will still play as part of the session. Inactive tracks appear in italics in the Show/Hide Tracks List.
Chapter 8: Tracks

The pop-up menu at the top of the Show/Hide Tracks List provides commands that allow you to show or hide all tracks, tracks currently selected on-screen, or specific types of tracks (audio, MIDI, Auxiliary Input or Master Fader).

The Sort Tracks By command allows you to set the track order according to Name, Type, Edit Group, Mix Group or Voice. The sort order will be reflected in the Show/Hide Tracks List in the Edit Window and the Mix Window.

When a track that is a member of an active group is hidden from view, editing operations performed on other members of the group in the Edit window will not affect the hidden track. In the Mix window, however, all operations other than record-enable will affect a hidden track that is a member of an active group.

⚠️ On TDM systems, even if a track is hidden from view, its position relative to other tracks still affects its voiceable track playback priority (see “Voiceable Tracks and Track Priority” on page 96 for details).

To hide a track:
- Click the highlighted name of the track in the Show/Hide Tracks List.

To show a track that is currently hidden:
- Click the unhighlighted name of the track in the Show/Hide Tracks List.

To show all tracks:
1. Click the Show/Hide button at the top of the Show/Hide Tracks List.
2. From the pop-up menu, choose Show All Tracks.

To hide all tracks:
1. Click the Show/Hide button at the top of the Show/Hide Tracks List.
2. From the pop-up menu, choose Hide All Tracks.

To reorder tracks on-screen, drag the track names to new positions within the Show/Hide Tracks List.
About Groups and Show/Hide Tracks

Even if a track is hidden, if it is a member of an enabled group, all Mix window operations performed on other members of the group will also affect the hidden track—with the exception of audio or MIDI record-enabling. If you solo, mute, or automation write-enable a grouped track, any group members that are hidden will be soloed, muted, or automation write-enabled as well.

In the Edit window, however, editing operations performed on members of an enabled group will not affect hidden tracks that are also members of the enabled group.

Assigning Inputs and Outputs to Tracks

Inputs for audio tracks and Auxiliary Input tracks can be assigned to audio interface channels or busses. Outputs for audio tracks, Auxiliary Input tracks, and Master Fader tracks can be assigned to audio interface channels or busses.

Inputs in use by another track appear as bold in the Input Selector.

Automatic Input and Output Assignments

When adding tracks to a new session, inputs are automatically assigned in ascending order. For example, if you have an audio interface with eight inputs, creating four new mono audio tracks will automatically add four audio tracks with inputs assigned to the first four paths defined in the I/O Setup dialog. When creating stereo tracks, inputs are automatically assigned to ascending input pairs.

The outputs automatically assigned to new tracks are determined by the Default Output defined in the I/O Setup dialog.

Assigning Audio Track Inputs (Audio and Auxiliary Input Tracks)

To assign an audio track input:

1. In the Edit window, select Display > Edit Window Show > I/O View.
2. In the Mix or Edit window, click the track Input Selector and choose from the available audio interface channels and busses. Stereo and multichannel surround tracks have inputs available as pairs and multichannel groups.

The Input Selector allows you to route any audio input or any of the Pro Tools internal busses to an audio track or an Auxiliary Input track. The choices available in this pop-up menu are determined by the I/O Setup configuration. Inputs in use by another track appear as bold in the Input Selector.
To remove an input assignment:
- Select No Input from the Input Selector.

Assigning Audio Track Outputs
(Audio Tracks, Auxiliary Inputs, Master Faders)

To assign an audio track output:
1. To display inputs and outputs in the Edit window, select Display > Edit Window Shows > I/O View.
2. In the Mix or Edit window, click the track Output Selector and choose from the available audio interface channels and busses. Stereo and multichannel surround tracks have outputs available as pairs and multichannel groups.

The Output Selector allows you to route a track to any configured audio output or internal bus. The choices available in this pop-up menu are determined by the I/O Setup configuration. Outputs in use by another track appear as bold in the Input Selector.

If you want to auto-assign all visible tracks to unique mono sub-path outputs in ascending order, Command-Option-click (Macintosh) or Control-Alt-click (Windows) the Output Selector of the left-most track and assign it to the sub-path for Output #1. All visible tracks will be auto-assigned to unique mono sub-path outputs in ascending order.

To remove an output assignment:
- Select No Output from the Output Selector. Playlists become dimmed for tracks with no output assignment.

⚠️ Assigning an audio track, Auxiliary Input, or Master Fader to “No Output” will cause its automation data for pan and plug-in parameters to be lost.

Track Priority and Voice Assignment
(Pro Tools TDM systems and Pro Tools LE 6.0 Only)

Pro Tools TDM systems provide a certain number of voices (simultaneous channels of audio playback and recording), depending on the system. For example, a Pro Tools|HD 1 system can provide up to 96 voices of audio playback and recording, at 44.1 or 48 kHz. For details on TDM system capabilities, see Table 1 on page 7.
Pro Tools LE systems provide up to 32 voices of simultaneous audio playback and recording, depending on the system. For details on LE system capabilities, see Table 3 on page 10.

**Track Priority**

While your Pro Tools hardware allows a fixed number of voices, Pro Tools TDM software (and Pro Tools LE 6.0 software) allow for additional audio tracks beyond that fixed number of voices. While all of these tracks can be recorded or imported, arranged, and cued for playback, not all of them can be played back simultaneously.

On TDM systems, you can also assign specific voices to tracks so that those voices are shared by more than one track. This combination of playback/record tracks and shared voiced tracks comprises the total number of voiceable tracks on a TDM system. See “Voiceable Tracks and Track Priority” on page 96.

When the number of tracks exceeds the number of available voices, tracks with lower priority may not be heard. For these situations, Pro Tools assigns priorities to tracks that compete for the available voices. Because there can be more tracks than available voices, Pro Tools provides multiple ways of adjusting the playback priority of audio tracks.

**Changing a Track’s Playback Priority**

Tracks with higher positions (leftmost in the Mix window or topmost in the Edit window) have priority over tracks in lower positions in a session.

To increase a track’s priority, do any of the following:

- In the Edit window, drag the Track Name button above other tracks in the session. Tracks at the top of the Edit window have higher priority than those below.
- In the Mix window, drag the Track Name button to the left of other tracks in the session. Tracks at the left of the Mix window have higher priority than those on the right.
- In the Show/Hide Tracks List, drag the track name to a higher position in the list. Tracks at the top of this list have higher priority than those below.

You can also adjust the relative priority of tracks by freeing up the voices of individual tracks, making them available to other tracks in the session.

To free up the voice of a track, do one of the following:

- Click the Voice selector of the track and set it to Off.
- Deactivate the track by Command-Control-clicking (Macintosh) or Control-Start-clicking (Windows) it track type icon in the Mix window.
- Make sure the track does not have an output or send assignment.
- On TDM systems, you can temporarily free a track’s voice during playback by muting it (see “Mute Frees Assigned Voice” on page 99).
Voice Assignment

A track’s voice assignment can be set to Auto or Off, and on TDM systems, can be assigned to a specific voice number. When the tracks in a session are set to Auto, Pro Tools automatically takes care of voice management in the background, assigning voices not in use by other tracks.

On TDM systems, tracks assigned to a specific voice number take priority over auto-voiced tracks. To ensure a track is heard, or that it is available for QuickPunch recording, assign a voice number to that track.

⚠️ Pro Tools LE 6.0 supports auto voicing only; it does not support individual voice assignments.

For stereo and multichannel tracks, voices appear in pairs and multichannel groups. Voices already assigned to another track appear in bold in the Voice Selector pop-up menu.

To set the voice assignment for a track:

- Click the Voice Selector and set the track to Auto, Off, or (on TDM systems) select a voice number.

Automatic Assignment of Ascending Voices

(TDM Systems Only)

You can automatically assign all tracks or all selected tracks to successive voices. For example, you may want to select eight audio tracks and reassign them to voices 9–16.

To assign all audio tracks to successive voices:

- While pressing Command+Option (Macintosh) or Control+Alt (Windows), select the starting voice number from the Voice Selector for the track at the top of the Edit window, or at the far left of the Mix window.

The voice is assigned to the first track, with successive voices assigned to tracks (with the same format) of lower priority.

To assign all selected audio tracks to successive voices:

1. Select the audio tracks by Shift-clicking their names.

2. While pressing Command+Option (Macintosh) or Control+Shift (Windows), select the starting voice number from the Voice Selector for the top (Edit window) or left (Mix window) selected track.
The voice is assigned to the starting track, with successive voices assigned to currently selected tracks (with the same format) of lower priority.

**Voiceable Tracks and Track Priority**  
**(TDM Systems Only)**

Pro Tools TDM systems feature *dynamic voice allocation*, which allows you to assign more than one track to the same voice. The track with the highest priority takes over that voice, but when a hole opens up in the higher-priority track, its shared voice is temporarily available, and the track with the next highest priority “pops through” and begins to play. When the original track returns, the track that had popped through relinquishes the shared voice to the higher priority track.

The following example demonstrates the concept of dynamic voice allocation:

In the above illustration, the two visible tracks are assigned to the same voice. There is an open area in the top track where no region appears. At this point, the voice is free since it is not being used, and the next highest priority track assigned to that voice (the bottom track) pops through the open area and plays.

By experimenting with track priority, voice assignment, and arranging regions so that they are positioned to “pop through” holes in higher priority tracks, you can find many useful ways to share voiceable tracks in your TDM system.

---

**Setting MIDI Input and Output**

**Assigning MIDI Track Input**

This MIDI Input Selector allows you to choose which MIDI device and channel a MIDI track is receiving input from. This allows you to set up Pro Tools to record multiple MIDI tracks in the same record pass. Channels in use by another track input appear as bold in the MIDI Input Selector.

**To assign a MIDI track input:**

1. In the Edit window, select Display > Edit Window Show > I/O View.
2. In the Mix window, click on the track’s MIDI Input Selector and assign the device and channel that will be recorded.
Assigning MIDI Track Output

MIDI tracks can be assigned to one or more MIDI device channels with the Device/Channel Selector. When assigned to multiple channels, all material in the track is sent to all assigned channels.

MIDI tracks in Pro Tools cannot contain multiple channels of MIDI data.

To assign a MIDI track (and all its regions) to a specific MIDI device channel:
- Click on the track’s MIDI Device/Channel Selector and assign a device and channel from the pop-up menu. Channels already assigned to another track appear bold in this menu.

To assign multiple destinations to a single MIDI track:
- Control-click (Macintosh) or Right-click (Windows) the MIDI Device/Channel Selector and select additional channels from any device.

Soloing and Muting Tracks

The Solo and Mute buttons can be engaged at any time during playback. The Solo and Mute buttons affect MIDI as well as audio tracks. It is possible to have more than one track soloed or muted at the same time in a session.

Grouping affects mute and solo behavior as well. Normally, muting or soloing a track that is a member of an active mix group will mute or solo all other tracks that are a member of that active mix group as well. However, by changing the Mute and Solo settings in the Pro Tools Preferences dialog, you can disable this behavior.

To disable group muting of tracks:
1. Choose Setups > Preferences, and click Automation.
2. Deselect the Mutes Follow Groups option, and click Done.

With this option deselected, muting a track that is a member of an active group does not affect other members of the group.

💡 You can also mute or solo individual members of a group by holding down the Control key while selecting the track’s Mute or Solo button.

To disable group soloing of tracks:
1. Choose Setups > Preferences, and click Automation.
2. Deselect the Solos Follow Groups option, and click Done.

With this option deselected, soloing a track that is a member of an active group does not affect other members of the group.
Solo Button

The Solo button mutes other tracks so that the chosen track can be auditioned alone. Normally solos are latched, that is, pressing subsequent solo buttons adds them to the soloed mix of tracks. Pro Tools allows you to un latch solos, so that pressing a solo button will mute all tracks except the track you have just soloed.

To solo tracks:
1. Click the Solo button on a track. The button is highlighted and all other tracks are muted.
2. Click the Solo button on another track. The buttons for both tracks are highlighted and all other tracks are muted.

To un-solo tracks:
■ Click the Solo button on soloed tracks.

To unlatch solo buttons:
1. Choose Setups > Preferences and click Operation.
2. Deselect the Latch Solo Buttons option and click Done. With this option disabled, pressing a Solo button mutes all tracks except the track you have just soloed.

Solo Safe Mode

Pro Tools also allows you to solo safe a track. This prevents the track from being muted even if you solo other tracks. This feature is useful for tracks such as Auxiliary Inputs that are being used as a submix of audio tracks, or effects returns, allowing the audio or effects track to remain in a mix even when other tracks are soloed. It is also useful to solo safe MIDI tracks so that their playback is not affected when you solo audio tracks.

To solo safe a track:
■ Command-click (Macintosh) or Control-click (Windows) the Solo button on the track. This prevents the track from being muted even if you solo other tracks. The Solo button changes to a transparent color in Solo Safe mode.

To return a solo safe track to normal:
■ Command-click (Macintosh) or Control-click (Windows) the Solo button on the track again.

Mute Button

The Mute button silences a chosen track. More than one track can be muted at one time. If Operations > Mute Frees Assigned Voice (TDM systems only) is enabled, muting a track will allocate its voice to the next highest priority voiceable track (assigned to the same voice).

To mute a track:
■ Click the Mute button on the track. The track is grayed-out and be muted.

To unmute a track:
■ Click the Mute button again.
**Mute Frees Assigned Voice**  
*(TDM Systems Only)*

Selecting Operations > Mute Frees Assigned Voice and muting a track disables playback of that track, and surrenders control of its voice to the next highest priority track with the same voice assignment.

With this option enabled, there may be a delay (ranging in length from one to several seconds depending on the processing power of your system) between the time you mute or unmute a track and when you hear the effect on playback.

To avoid this delay, make sure that the Mute Frees Assigned Voice option is disabled. Another factor than can cause delays is your DAE Playback Buffer Size setting. Playback Buffer Size is set in the Playback Engine dialog. The larger the playback buffer you choose, the longer the potential lag time between the time you click the Mute button and the onset of muting.

**Muting a track with Mute Frees Assigned Voice enabled does not free up the voice for QuickPunch recording.**

**Making Tracks Inactive**  
*(TDM Systems and Pro Tools LE 6.0 Only)*

Audio, Auxiliary Input, and Master Fader tracks can be made inactive. Inactive tracks use no DSP or voices. Plug-ins, sends, voices, and automation on inactive tracks are all disabled. Tracks may also be automatically made inactive if a session is opened on a system with less DSP power than the system it was created on.

**MIDI tracks cannot be made inactive.**

**Pro Tools LE 5.3.x or earlier does not support inactive tracks.**

**To toggle a track active/inactive:**

- Command-Control-click (Macintosh) or Control-Start-click (Windows) the Track Type Indicator in the Mix window.

Playlists for inactive tracks are dimmed and track controls are grayed out.

**To make one or more tracks inactive:**

1. Click the name of the track (in its track channel strip) to select it.
2. Choose File > Make Selected Tracks Inactive.

**Adjusting Track Width**

**Mix Window**

The Narrow Mix Window command allows you to view all tracks/channels in the Mix window at a reduced width to conserve screen space in a large session. (See “Track Height” on page 192, to adjust track height in the Edit Window.)

**To reduce the width of tracks in the Mix window:**

- Select Display > Narrow Mix Window.

**To display tracks at normal width:**

- Deselect Display > Narrow Mix Window.
Color Coding Tracks

The Display Preference for Edit Window Color Coding determines how colors are assigned to waveforms and MIDI data in the Edit window. Colors can be based on groups, voice assignment for audio tracks, and channels or devices for MIDI tracks.

Color coding of voices is especially useful when working with tracks assigned to the same voice. Since tracks assigned to the same voice share the same color, you can easily identify and arrange regions so that they do not overlap or conflict with other regions on tracks assigned to the same voice.

To configure the Edit Window color coding:

1. Choose Setups > Preferences and click the Display tab.
2. Select one of the following color coding options:
   - **None** Turns off color assignment for tracks in the Edit window.
   - **Tracks and MIDI Channels** Assigns a color to each track in the Edit window according to its voice and MIDI channel assignment.
   - **Tracks and MIDI Devices** Assigns a color to the track in the Edit window according to its voice and MIDI device assignment.
   - **Groups** Assigns a color to each track in the Edit window according to its voice assignment. If groups are suspended using the Suspend Groups command, all waveforms are displayed in black.
3. Click Done to close the Preferences dialog.

Grouping Tracks

Pro Tools provides a relative grouping function for linking tracks and their controls. Groups can be applied to either the Mix or Edit window, or both.

Groups are useful for editing several tracks in exactly the same way, or for mixing several tracks (such as a pair of stereo tracks or a submix) while keeping them at the same relative volume level.

Pro Tools provides the following grouping features:

- Up to 26 different groups
- Nested groups (subgroups within groups)
- Grouped faders or controllers preserve their levels relative to each other

Grouping can affect the following track parameters:

- Volume levels
- Solos
- Mutes
- Automation modes
- Send levels
- Send mutes
- Track view
- Track height
- Editing functions

Grouping does not affect these parameters:

- Record enables
- Panning
- Send panning
- Voice assignment
- Output assignment
- Creating Plug-Ins instances
Using the Groups List

The Pro Tools grouping functions are located at the left side of the Mix or Edit window in the Groups List. This scrolling window contains the names of all the groups in your session, as well as a pop-up menu for accessing grouping commands. From this menu, you can select and enable groups.

By default, every session has a group named All, which includes every track in the session. The All group cannot be edited or deleted.

To the left of each name in the Groups List is a letter denoting its Group ID (“a” through “z”), and to the left of that, a symbol indicating whether that group is selected in the current window (either the Edit or Mix window). These symbols indicate the following:

- The filled-in circle symbol indicates that all members of the group are currently selected, and no members from outside the group are selected.
- The hollow circle symbol indicates that only some members of the group are currently selected.
- The circle with a dot symbol indicates that all members of the group are currently selected, plus additional members outside the group.

The Show/Hide Groups pop-up menu allows you to show or hide the tracks in a group, or show only the tracks in a group. Click and hold directly on the group name to display the pop-up menu, then select the Show/Hide option.

The Groups Pop-up Menu

The Groups pop-up menu contains commands that allow you to create, delete and suspend groups. These commands are as follows:

- **New Group** This command allows you to create a new group. You must first select two or more tracks/channel strips on-screen to do this.
Display: This command allows you to toggle the Groups List display to either Mix Groups or Edit Groups. If all of your groups apply to both Editing and Mixing, the Groups List will be the same for both.

Suspend All Groups: This command allows you to temporarily toggle all active groups off.

Delete Selected Groups: This command allows you to permanently remove a group from the Groups List. You must first select a Group Name in the Groups List to do this.

Creating a Group

To create a group:
1. Shift-click the Track Names for the tracks you want to include in the group to select them.
2. Choose New Group from the Group pop-up menu, or choose File > Group Selected Tracks.
3. Enter a name for the group.
4. Choose the type of group to create: Edit Group, Mix Group, or Edit and Mix Group.
5. Choose a Group ID (“a”–“z”).
6. Click OK to add the new group to the Groups List.

Editing Groups

Changing the Members of a Group
You can add or remove members from a group at any time.

To change the members of a group:
1. Shift-click the Track Names for the tracks you want to include in the group to select them.
2. Choose File > Group Selected Tracks from the Group pop-up menu.
3. In the dialog that appears, select the Group ID that you want to update.
4. Click OK.

Renaming a Group
You can rename a group at any time.

To rename a group:
1. In the Groups List, double-click to the left of the group’s name (in the area with the circular symbols).
2. In the dialog that appears, enter a new name for the group. (You can also change the group’s type.)
3. Click OK.

Deleting a Group
A group can be deleted at any time. You cannot undo this action.

To delete a group:
1. In the Groups List, select the name of the group (or groups) you want to delete.
Click the Group pop-up menu and choose Delete Selected Groups.

**Linking Mix and Edit Groupings**

The “Link Mix and Edit Group Enables” option links group enabling between the Mix and Edit windows.

Pro Tools allows you to create groups that are both Mix and Edit groups, but in some cases you may prefer not to link enabling of Mix and Edit groups. For example, when you are using the Mix window for mixing, you may prefer to work with large, nested groups. However, in the Edit window, you may want to perform editing tasks within a smaller group. You could disable the Link Mix and Edit Group Enables preference. This would allow you to work with different groups in the two windows.

**To unlink mix and edit groups:**

1. Choose Setups > Preferences and click Operation.
2. Deselect the “Link Mix and Edit Group Enables” option and click Done.

**Enabling Groups**

Editing operations are not applied to members of a group that are hidden with the Show/Hide Tracks List. Mix operations (with the exception of record-enabling of tracks) are applied to hidden tracks.

Pro Tools allows you to create separate groups for editing and mixing. You set this option when you use the New Group command. Groups that apply to both editing and mixing can be decoupled.

**To enable a group:**

1. In the Groups List, click the name of the group you want to enable. The group name is highlighted to indicate that it is enabled.

To enable additional groups, click their names in the Groups List. It is not necessary to Shift-click to enable or disable multiple groups.

Moving a fader of a group member will cause all other group members to move relative to it. If a fader belongs to multiple groups, and the groups conflict when faders are moved, the fader will follow the topmost or “parent” group that it belongs to.

**To disable a group:**

1. In the Groups List, click the name of the group you want to disable. The group name is unhighlighted to indicate that it is not enabled.
**Keyboard Selection of Groups**

The Groups List Key Focus allows you to type a Group ID letter to automatically toggle that group’s enable status.

◆ In the Mix window, the Groups List Key Focus is always enabled.
◆ In the Edit window, you need to enable the Groups List Key Focus to use it.

**To enable and use the Edit Groups List Key Focus:**

1. Click the a–z button in upper right of the Edit Groups List.
   - or -
   Press Command+Option+4 (Macintosh) or Control+Alt+4 (Windows).

2. Type the Group ID letter (a–z) to automatically enable or disable the corresponding group.
Chapter 9: Importing and Exporting Session Data

Pro Tools allows you to import a variety of data into a session, including audio and MIDI files, video files, track playlists, I/O configurations, and signal routing configurations.

- With Pro Tools 5.3.x and earlier, you can import audio and MIDI files into a session, or transfer entire audio or MIDI tracks, along with all of their attributes, from another session. See “Importing Audio” on page 105 and “Importing Tracks” on page 108.

- With Pro Tools 6.0, in addition to importing audio files, MIDI files and entire tracks, on TDM systems, you also have the option of importing any combination of track attributes from another session, such as a track’s audio or MIDI playlists, signal routing, plug-ins, or automation. See “Importing Audio” on page 105 and “Importing Tracks and Track Attributes” on page 111.

Importing Audio

Audio files and regions can be imported to new tracks, or they can be imported into the Audio Regions List, where they can be dragged to existing tracks.

Audio files of the following types can be imported into Pro Tools sessions:
- AIFF
- WAV
- SD II
- SD I
- MP3 (with purchase of MP3 Option)
- Sound Resource (AIFL—Macintosh only)
- WMA (Windows Media—Windows only)

Supported files and regions can be auditioned before they are imported.

If region definitions are present in an audio file, you can convert and import the audio for a region without importing the entire parent audio file.
Files of types that are not supported in the session must be converted when importing. Files with sample rates that are different from the sample rate of the current session must be converted in order for the files to play back at the correct pitch and speed.

**Copying, Adding, and Converting Audio**

Depending on the properties of the audio files you are importing, you can add, copy, or convert the files. The following options appear in the Import Audio dialog box when they are applicable to the selected audio file.

**Add**

Audio files that are of the same file type and bit depth as a session can be added directly to the session. When you add an audio file, the session references the original audio file in its original location. Use this option when you don’t want to use extra hard drive space for audio files that are already of the same bit depth and sample rate as your session.

Pro Tools does allow audio files that are not the session’s native file type to be added to the session. For example, Macintosh sessions allow SDII, AIFF, or WAV files to be added to any session, and Windows sessions allow AIFF or WAV files to be added to any session. However, sessions with mixed file types will have reduced performance.

Audio files that are of a different bit depth than the session must be converted before they can be imported.

**Copy**

If a file can be added to your session, you will also be given the option to copy it. This option creates a copy of the audio file and places it in a folder you choose. When you copy an audio file, the session references the copied file in its new location.

Use Copy to move audio from an unsupported or removable drive to an audio drive, or to archive audio files for a session to a specific location.

**Convert**

Audio files that are not of the same bit depth or sample rate as a session, or audio files that are of an incompatible file type (such as SD II files in Windows) must be converted to be used with the session. When an audio file is converted, a new file with the correct bit depth, file type, and sample rate is created and placed in a folder you choose.

The quality of sample rate conversion used by Pro Tools is determined by the Preference for Conversion Quality. For details, see “Conversion Quality” on page 121.

**Importing Stereo Files**

When using the Import Audio to Tracks command, interleaved stereo files are automatically imported to stereo tracks.

Split stereo (dual mono) audio files can be automatically imported to stereo tracks. Split stereo audio files must have the channel identifiers “.L” and “.R” in their names (for example, filename.L and filename.R), and the files must be the same length. In Windows, or in Mac/PC Compatibility mode, these files will have a 3-letter file extension appended after the “.L” or “.R” channel identifier.
Importing Audio Files and Regions

Pro Tools provides several ways to import audio files and regions into an open session. With Pro Tools 6.0, you can import audio directly from a DigiBase browser. See “Importing Audio with Drag & Drop from a DigiBase Browser” on page 108.

To import audio files or regions into a session:

1. Choose File > Import Audio to Track to import audio files and automatically place them in new tracks.

   – or –

Choose Import Audio from the Audio Regions List pop-up menu to import audio into the Audio Regions List without automatically creating new tracks.

To import entire tracks from other sessions, see “Importing Tracks” on page 108.

2. At the top of the Import Audio dialog, select an audio file to display its properties and associated regions.

You can choose to display only a certain file type (AIFF, for example) by selecting the type from the Show pop-up menu. To display all supported file types, select All Documents from the Show pop-up menu.

   On the Macintosh, Sound Resource files must have the ".SFIL" extension to be imported by Pro Tools.

3. To audition a selected file or region before you import it, click the Play and Stop buttons.

Adjust playback volume with the vertical slider. To navigate to a particular location in the file, use the horizontal slider under the Play and Stop buttons.

The audition output defaults to channels 1–2. On TDM systems, the audition output channels can be changed in I/O Setup or Hardware Setup.

4. To place a file or region in the import list (in the lower right of the dialog on a Macintosh, or on the right in Windows), select the file (Shift-click to select multiple files) and click Add or Convert. You can also click Add All or Convert All to import all regions and files in the current directory.

In the import list, audio files are distinguished from regions by their icons.

   Audio File icon

   Audio Region icon

File and Region Icons in the Import Audio dialog

5. To remove a file or region from the import list on the right, select it and click Remove. To remove all regions or files, click Remove All.
6 Once the audio files and regions have been added to the import list, click Done.

7 If you are copying or converting files, you are prompted to choose a location for the new audio files. Choose a folder on a valid audio drive, such as the Audio Files folder for your current session.

If you chose File > Import Audio to Track, the files and regions are imported to new audio tracks, and also appear as regions in the Audio Regions List.

If you chose Import Audio from the Audio Regions List, the files and regions appear as regions in the Audio Regions List.

Importing Audio with Drag & Drop from a DigiBase Browser

Pro Tools 6.0 Only

With Pro Tools 6.0, you can import audio by dragging it directly from a DigiBase browser into the Edit window of the current session.

To import audio into the Audio Regions List:

1 Select audio files in a DigiBase browser.

2 Drag the files onto the Audio Regions List of the current session.

To import audio into an existing track:

1 Select audio files in a DigiBase browser.

2 Drag the files onto an existing track in the Edit window of the current session, and place the audio at the desired location.

To import audio into new tracks:

1 Select audio files in a DigiBase browser.

2 Shift-drag the files and drag them anywhere in the Edit window of the current session.

– or –

Drag the files onto any empty space in the Edit window of the current session.

For complete details on using DigiBase to import audio, refer to the DigiBase Guide.

Importing Tracks

Pro Tools 5.3.x and Earlier

You can import entire tracks from other Pro Tools sessions into the current Pro Tools session using the Import Tracks command. On the Macintosh, you can Import tracks from Pro Tools 3.2 sessions and later. On Windows, you can Import tracks from Pro Tools 4.2.5 sessions or later.

You can import audio tracks, MIDI tracks, Auxiliary Input tracks, and Master Fader tracks. During the import process, you can convert the file type of the imported files to the current session file type, and you can change the bit depth and sample rate.

Import Tracks also lets you set time code location options, sample rate conversion options, and audio and video media translation options.

To import tracks:

1 Open or create a new session.

2 Choose File > Import Tracks.

3 Locate and select the session to import tracks from and click Open. The Import Tracks dialog displays the tracks that can be imported.

If the current Pro Tools system does not support surround mixing, surround tracks are not displayed in the Import Tracks dialog.
4 Select the tracks to import. Shift-click to select multiple contiguous files. Command-click (Macintosh) or Alt-click (Windows) to select multiple non-contiguous files.

5 Choose the time code mapping option for imported audio files.

6 If the sample rates of the sessions are different, choose the sample rate for the source session.

7 If applicable, choose options for how media files should be imported from the Audio Media Options and the Video Media Options pop-up menus.

8 To import the meter and tempo tracks from the source session, select that option.

9 Click OK when you are finished.

10 If you chose to copy or consolidate media, choose a location to place the media files.

⚠️ Imported tracks are made inactive if their source media is unavailable, or if the current session does not contain an equivalent output path.

---

**Import Tracks Dialog**

**Pro Tools 5.3.x and Earlier**

The Import Tracks dialog lets you view the properties of the source session, select which tracks to import, and configure settings that affect the way tracks are imported into the current session.

**Source Properties**

The Import Tracks dialog displays properties for the source session. These properties include source session name, session type, start time of the session, audio bit depth, and sample rate. For Pro Tools 5.1 or later sessions, the program that created the session and the session's audio file type are listed.

**Source Tracks**

You can select source tracks to Import in this area of the dialog. To select multiple contiguous tracks, Shift-click. To select multiple non-contiguous files, Command-click (Macintosh) or Alt-click (Windows).
Time Code Mapping Options

The Time Code Mapping Options let you specify where the imported tracks are placed in the current session. Times are indicated in time code for TDM systems, and minutes:seconds for Pro Tools LE systems.

Maintain Absolute Time Code Values This option places tracks at the locations where they were located in the source session. For example, if the current session starts at 00:01:00:00, and the session from which you are importing starts at 10:00:00:00, the earliest imported tracks can appear in your session 9 hours and 59 minutes after the start of the session.

Maintain Relative Time Code Values This option places tracks at the same offset from session start as they had in the source session. For example, if the source session starts at 01:00:00:00 and a contains a track that starts at 01:01:00:00, and the current session start is 02:00:00:00, the track will be placed at 02:01:00:00 in the current session.

Map Start Time Code to hh:mm:ss:ff This option places tracks relative to their original session start time. For example, if the current session starts at 00:01:00:00, and the session from which you are importing starts at 10:00:00:00, you can reset the start time code to 00:01:00:00, to avoid placing files 9 hours and 59 minutes from the start of your session.

Sample Rate Conversion (SRC) Options

You can set options that control how sample rate conversion is applied to imported audio files. If the source session and the current session have the same sample rate, this portion of the dialog is unavailable.

Source Sample Rate For audio files created in any session, no matter what the session sample rate is, you can have the sample rate conversion process treat the files in several ways to compensate for pull-up, pull-down, and NTSC or PAL frame rates. This setting allows you to choose the sample rate from which you want the sample rate conversion process to start.

Destination Sample Rate The destination sample rate is always set to the sample rate of your current session.

Conversion Quality This option lets you set the quality of the sample-rate conversion process. See “Conversion Quality” on page 121.

Audio Media Options

Format for New Audio

Choose whether you want new media files to be SDII, WAV, or AIFF files.

Import Options

Refer to Source Media (Where Possible) This option lets you avoid duplicating audio files by referring to the original files when possible. If the source files do not reside on supported playback media (such as a CD-ROM), or if they require bit depth or sample rate conversion, the source files are copied instead. This option allows the current session to refer to files that do not match the current session's audio file format.

Copy from Source Media This option copies all audio files related to the imported tracks from the source media to a new specified location, and converts the files to the current session's audio file format, bit depth, and sample rate if necessary. This is useful if you are importing tracks from a source such as CD-ROM or shared storage, and you want to place the audio files on a different hard drive.
**Consolidate from Source Media** This option consolidates audio while copying it. This is useful if you want to copy only the regions of the audio files used in the source tracks, without copying unused audio. This option copies and converts consolidated audio to the current session’s audio file format, bit depth, and sample rate if necessary.

When you choose this option, you can also choose the size of the handle (in milliseconds) applied to consolidated audio. *Handle* is the amount of the original audio file that is preserved before and after each region in case you need to make any edits to the new regions.

**Force Audio Media to New Format** This option converts all imported audio files to the audio file format you select.

**Video Media Options**
You can either choose to leave video media files in their original locations or copy them to a new location. This is useful if you are importing tracks from a source such as CD-ROM or shared storage, and you want to place video files on a different drive.

**Import Tempo/Meter Map**
Select this option to import the meter and tempo tracks from the source session.

---

**Importing Tracks and Track Attributes**

**Pro Tools 6.0 Only**

You can import entire tracks from other Pro Tools sessions into the current Pro Tools session using the Import Session Data command. On TDM systems, you can choose which attributes of those tracks you want to import.

On TDM systems, in addition to importing an entire track with all of its associated settings, you can choose to import only the track’s audio into your current Pro Tools mixer. This is analogous to “changing the tape reel” in a traditional studio setup with a tape machine and mixing console.

You can also choose to import all of a track’s mixer settings without its audio, effectively importing a channel strip and using it on a track in your current session. By importing mixer settings for all of the tracks in a session or session template, you can reuse an entire Pro Tools mixer on all the sessions in a project.

**To import tracks or their attributes:**

1. Open or create a new session.

2. Choose File > Import Session Data, select the session to import data from, and click Open.

   – or –

   Drag the session file whose tracks or attributes you want to import from a DigiBase browser into the track playlist area in the current session’s Edit window.

*For details on using DigiBase to import tracks, refer to the DigiBase Guide.*
3 Select the tracks to import by clicking the track names in the Source Tracks list. (If the current Pro Tools system does not support surround mixing, surround tracks are not displayed in the Source Tracks list.) To select multiple contiguous tracks, Shift-click the track names. To select multiple non-contiguous tracks, Command-click (Macintosh) or Alt-click (Windows) the track names.

4 On TDM systems, for each track you select, you can choose to import it as a new track, or choose a destination track from the corresponding pop-up menu. Click Find Matching Tracks to automatically match source and destination tracks with the same names.

5 On TDM systems, select from among the Track Playlist options to choose how you want to import the source tracks.

6 If applicable, choose options for how media files should be imported from the Audio Media Options and the Video Media Options pop-up menus.

7 Choose the Time Code Mapping option for imported data.

8 If the sample rates of the sessions are different, choose the sample rate for the source session from the Source Sample Rate pop-up menu.

9 To import the meter and tempo maps from the source session, select the Import Tempo/Meter Map option.

10 On TDM systems, to import any mic pre settings from the source session, select the Import Mic Pre Settings option.

11 Click OK when you are finished.

12 If you chose to copy or consolidate media, choose a location to place the media files.

⚠️ Import tracks are made inactive if their source media is unavailable, or if the current session does not contain an equivalent output path.
Import Session Data Dialog
Pro Tools 6.0 Only

The Import Session Data dialog lets you view the properties of the source session, select which tracks to import, and on TDM systems, choose which attributes of those tracks you want to import into the current session.

Source Properties
The Import Session data dialog displays properties for the source session. These properties include source session name, session type, start time of the session, audio bit depth, and sample rate. For Pro Tools 5.1 or later sessions, the program that created the session and the session’s audio file type are listed.

Audio Media Options

Refer to Source Media (Where Possible) This option lets you avoid duplicating audio files by referring to the original files when possible. If the source files do not reside on supported playback media (such as a CD-ROM), or if they require bit depth or sample rate conversion, the source files are copied instead. This option allows the current session to refer to files that do not match the current session’s audio file format.

Copy from Source Media This option copies all audio files related to the imported tracks from the source media to a new specified location, and converts the files to the current session’s audio file format, bit depth, and sample rate if necessary. This is useful if you are importing tracks from a source such as CD-ROM or shared storage, and you want to place the audio files on a different hard drive.

Consolidate from Source Media This option consolidates audio while copying it. This is useful if you want to copy only the regions of the audio files used in the source tracks, without copying unused audio. This option copies and converts consolidated audio to the current session’s audio file format, bit depth, and sample rate if necessary.
When you choose this option, you can also choose the size of the handle (in milliseconds) applied to consolidated audio. Handle is the amount of the original audio file that is preserved before and after each region in case you need to make any edits to the new regions.

**Convert Audio Media to New Session Format**

This option copies and converts any files that do not match the current session’s file format, bit depth, and sample rate. Files that do match the current session’s file type, bit depth and sample rate are referred to directly and not copied.

**Video Media Options**

You can either choose to leave video media files in their original locations or copy them to a new location. This is useful if you are importing tracks from a source such as CD-ROM or shared storage, and you want to place video files on a different drive.

**Time Code Mapping Options**

You can specify where the imported tracks are placed in the current session. Times are indicated in time code for TDM systems, and minutes:seconds for Pro Tools LE systems.

**Maintain Absolute Time Code Values** This option places tracks at the locations where they were located in the source session. For example, if the current session starts at 00:01:00:00, and the session from which you are importing starts at 10:00:00:00, the earliest imported tracks can appear in your session is 9 hours and 59 minutes after the start of the session.

**Maintain Relative Time Code Values** This option places tracks at the same offset from session start as they had in the source session. For example, if the source session starts at 01:00:00:00 and a track contains a track that starts at 01:01:00:00, and the current session start is 02:00:00:00, the track will be placed at 02:01:00:00 in the current session.

**Map Start Time Code to hh:mm:ss:ff** This option places tracks relative to their original session start time. For example, if the current session starts at 00:01:00:00, and the session from which you are importing starts at 10:00:00:00, you can reset the start time code to 00:01:00:00, to avoid placing files 9 hours and 59 minutes from the start of your session.

**Track Offset Options**

You can specify a track offset in addition to any offset incurred with the Time Code Mapping options. Any imported audio is offset in the current session’s timeline by the specified amount. You can enter values in Minutes:Seconds, Bars|Beats, Samples, Time Code, or Feet/Frames.

**Sample Rate Conversion (SRC) Options**

You can set options that control how sample rate conversion is applied to imported audio files. If the source session and the current session have the same sample rate, this portion of the dialog is unavailable.

**Source Sample Rate** For audio files created in any session, no matter what the session sample rate is, you can have the sample rate conversion process treat the files in several ways to compensate for pull-up, pull-down, and NTSC or PAL frame rates. This setting allows you to choose the sample rate from which you want the sample rate conversion process to start.

**Destination Sample Rate** The destination sample rate is always set to the sample rate of your current session.
Chapter 9: Importing and Exporting Session Data

**Conversion Quality**
This option lets you set the quality of the sample-rate conversion process. See “Conversion Quality” on page 121.

**Source Tracks**
This area of the dialog lists the tracks in the source session that can be imported, each with a corresponding pop-up menu.

**Operation/Destination Track Pop-Up Menus**
For each source track, there is a corresponding pop-up menu that lists options for importing the track and, on TDM systems, possible destination tracks in the current session. The pop-up menus display the following items:

- **Do Not Import** Neither the source track nor any of its attributes are imported.
- **Import as New Track** The source track and all attributes selected in the Session Data to Import menu are imported into a new track in the current session.

(Destination Track Names) On TDM systems, the names of possible destination tracks in the current session are listed at the bottom of the pop-up menu. Imported playlists and all attributes selected in the Session Data to Import will be placed in the destination track you choose.

Only destination tracks that match the track type (audio, MIDI, Auxiliary Input, or Master Fader) and the channel format (mono, stereo, or any of the supported multichannel formats) of the source track appear in the pop-up menu.

**Find Matching Tracks**
TDM Systems Only
If you are importing playlists from source tracks with the same name as destination tracks in the current session, click Find Matching Tracks to automatically match the track names. Tracks must have the same name, track type, and channel format to be automatically matched.

**Session Data to Import**
TDM Systems Only
The Session Data to Import menu is where you select which attributes of the selected tracks you want to import into the current session.

![Session Data options in the Import Session Data dialog](image)

The selected attributes are applied to all tracks that you choose to import into the current session.
Replacing Track Attributes

When you import an attribute of the source track into an existing track in the current session, it replaces the corresponding attribute in the destination track. If you choose not to import an attribute of the source track, the corresponding attribute in the destination track is retained.

Replacing Track Path Names

When you import a track’s input, output, send output or hardware insert assignments, any custom path names and I/O configurations from the source session are not imported. You can import path names and I/O configurations by importing I/O Setup settings. See “I/O Settings Files” on page 78 for more information.

Selecting Track Attributes to Import

You can select All, None, or any combination of the listed attributes to import. The following attributes are available to import:

All Imports all of the source track’s playlists, according to Track Playlist Option setting, and all of the attributes in the Session Data to Import list.

None Imports only the source track’s main playlist, according to the Track Playlist Option setting, and no other attributes of the source track.

Alternate Playlists Imports all of the source track’s alternate playlists. The alternate playlists appear in the destination track’s playlist pop-up menu.

Regions and Media Imports all of the audio files and regions in the source track, and places them in the Audio Regions List.

Volume Automation and Setting Imports the source track’s Volume Fader setting and any automation data on the track’s Volume Automation playlist. The Volume Fader setting and any Volume automation data in the destination track are replaced.

Pan Automation and Setting Imports the source track’s Pan Slider settings and any automation data on the track’s Pan Automation playlist. The Pan Slider setting and any Pan automation data in the destination track are replaced.

Mute Automation and Setting Imports the source track’s Mute setting and any automation data on the track’s Mute Automation playlist. The Mute setting and any Mute automation data in the destination track are replaced.

Main Output Assignments Imports the source track’s channel output assignments, including any multiple output assignments. The channel output assignments in the destination track are replaced.

Send Output Assignments Imports the source track’s send output assignments. Any Send output assignments in the destination track are replaced.

Plug-In Assignments Imports the source track’s plug-in assignments. Any plug-ins in the destination track are removed, and their associated settings and automation are lost.

If the source track uses a Plug-In that is not available on the destination system, it appears in the destination track and is made inactive.

Plug-In Settings and Automation When the source track’s plug-in assignments are imported, this option imports the track’s plug-in settings and any automation data associated with the plug-ins. If no plug-in assignments are imported, this option has no effect.
**Hardware Insert Assignments** Imports the source track's hardware Insert assignments. Any Insert assignments in the destination track are replaced.

**Voice Assignments** Imports the source track's voice assignment from the source session. Any voice assignments in the destination track is replaced.

**Input Assignments** Imports the source track's channel input assignment. The Input assignment in the destination track is replaced.

**Sidechain Assignments** When the source track's plug-in assignments are imported, this option imports any sidechain assignments associated with the plug-ins. If no plug-in assignments are imported, this option has no effect.

**Track Active State** Imports the active/inactive state of the source track from the source session.

**Track Comments** Imports the track comments associated with the source track. Any comments in the destination track are replaced.

**Record Safe/Solo Safe Settings** Imports the record safe and solo safe settings of the source track from the source session. Any record safe or solo safe settings in the destination track are replaced.

**Track View Settings** Imports the track height and playlist view of the source track from the source session.

**Track Playlist Options**

**TDM Systems Only**

You can select from the following options to control how the main playlist from each source track is imported to the destination track in the current session.

**Import Main Playlists - Replacing destination main playlists**

Imports the main playlist from the source track. When you import the playlist into an existing track, the main playlist in the destination track is deleted and replaced with the imported playlist.

- If you select the above option and import all of the source track's attributes, this is equivalent to importing the entire track.
- If you select the above option and do not import any of the source track's attributes, you replace the audio playlists while keeping your current mixer settings.

**Import Main Playlists - Overlaying new with existing, trimming existing regions**

Imports the main playlist from the source track. When you import the playlist into an existing track, any existing playlist data that overlaps data imported from the source track is trimmed and replaced with the imported data. Any playlist data in the destination track that does not overlap remains in the destination track.

**Do Not Import Main Playlists - Leaving destination playlists intact**

Does not import the main playlist from the source track. No audio is imported; only the attributes selected in the Session Data to Import list are imported to the selected tracks.

- If you select the above option and import all of the source track's input, output, send, insert and plug-in attributes, this is equivalent to importing a channel strip.
Import Tempo/Meter Map

Imports the meter and tempo maps, as they appear in the Tempo and Meter Conductor rulers, from the source session. Any Tempo or Meter events in the destination session are replaced.

Import Mic Pre Settings

TDM Systems Only

Imports any Pro Tools mic preamplifier settings from the source session. Any mic preamplifier settings in the destination session are replaced.

Loading Audio Files with Drag & Drop

Pro Tools provides you with a convenient method of batch loading audio files into an open session.

To batch load audio files into a session:

1. Open or create a new session.
2. From the desktop, locate the audio files you want to import. Make sure the files match the session’s file type, bit depth, and sample rate.
3. Audio files must be in WAVE, SDII, or AIFF/AIFC format in order to be dropped into Pro Tools.
4. Audio files will be converted if they are not of the correct bit depth or number of channels. They will be converted to mono files of the default audio file format, with the session’s bit depth and sample rate.
5. Drag the audio files onto the Pro Tools icon or alias.

Exporting Audio

Pro Tools supports exporting regions as audio files, exporting left and right audio files as stereo interleaved files, and exporting region information.

You can also export audio from Pro Tools by bouncing or consolidating audio tracks. For more information, see “Bounce to Disk” on page 452.

Exporting a Region as a New Audio File

You can export regions as audio files with the Export Selected As Files command. Use this command if you intend to use a region in other sessions (or other audio applications) without using its parent source file.

This command also provides a way to convert regions to a different audio format, sample rate, or bit depth.

To export regions as new audio files:

1. In the Audio Regions List, select the regions you want to export.
2. From the Audio Regions List pop-up menu, choose Export Selected As Files. The Export Selected dialog appears.
3 In the Export Selected dialog, set the file type, format, bit resolution, and sample rate. In addition, specify the Conversion Quality, and choose the destination directory.

4 Select an option for how Pro Tools should resolve duplicate file names. Prompting for Each Duplicate will prompt you for a file name for any file that has the same name as a file in your destination directory.

Auto Renaming automatically changes the name of any duplicate file by adding a number at the end (such as file-01). Replacing with New Files replaces files with the same name with the new files.

5 Once the Export Options are configured, click Export to export the new audio files.

When you Export Selected (or Save Session Copy) with a lower bit rate, Dither (and Noise Shaping) may be applied. See the following table:

<table>
<thead>
<tr>
<th>Bit Rate Conversion</th>
<th>Export Selected</th>
</tr>
</thead>
<tbody>
<tr>
<td>24-bit to 16-bit (Dither and Noise Shaping)</td>
<td>Yes</td>
</tr>
<tr>
<td>24-bit to 8-bit (Dither Only)</td>
<td>Yes</td>
</tr>
<tr>
<td>16-bit to 8-bit (Dither Only)</td>
<td>Yes</td>
</tr>
</tbody>
</table>

For more information about using Dither with Save, see “Dither” on page 402.

Exporting Stereo Interleaved Files

You can use the Export Selected As Files command to export audio regions to stereo interleaved files for use in other applications. (Pro Tools sessions do not support stereo interleaved files.) For this to work, the selected regions must have identical names with “.L” and “.R” suffixes (for instance, vocals-01.L and vocals-01.R). These regions appear as a stereo region in the Audio Regions List.

To export regions as a stereo interleaved file:

1 Select the stereo audio region in the Audio Regions List or in the track playlist. If the regions appear on mono tracks in the session, select the two mono regions.

2 From the Audio Regions List pop-up menu, choose Export Selected As Files.
3 In the Export Selected dialog, select “Interleaved” in the Format pop-up menu.

4 Configure any other output parameters, then click Export to export the new stereo interleaved file.

**Exporting Region Definitions**

Pro Tools stores region definitions for audio files within each session. If you want to use an audio file’s regions in another session, or with another application that supports them, you can export the region information.

The Export Region Definitions command does not export regions as audio files (unlike the Export Selected As Files command). Instead, it stores pointers to the regions within the parent source file.

**To export region definitions for an audio file:**

1. In the Audio Regions List, select any regions for which you want to export definitions. You do not have to select the parent file audio region.

2. Choose Export Region Definitions from the Audio Regions List pop-up menu.

3. Click Export.

The sample rate for audio CDs is 44.1 kHz. Therefore, if your session’s sample rate is set to 48 kHz or higher, Pro Tools will convert the sample rate for the imported audio. Before importing CD audio, set the Conversion Quality Preference accordingly. See “Conversion Quality” on page 121 for details.

When importing a CD audio track, Pro Tools first imports it as QuickTime movie. The imported movie is then converted to audio files in your session file format. Before importing CD audio, make sure your hard drive has enough space for both the imported movie file and the converted audio files.

**To import a CD audio track (Mac OS X):**

1. Insert the audio CD into your CD-ROM drive.

2. Choose Movie > Import Audio From Other Movie.

3. Locate and select the audio track to be imported, then click Open.

4. In the Track Import Window, click OK.

5. Navigate to a destination for the imported audio, and click Choose.

Pro Tools converts the CD audio track to the session’s audio file format, bit depth, and sample rate, and saves it on your hard drive.

The imported audio file appears in the Audio Regions List. From there you can drag the region to a track in your session.

**To import a CD audio track (Mac OS 9):**

1. Insert the audio CD into your CD-ROM drive.

2. Choose Movie > Import Audio From Other Movie.

3. Locate and select the audio track to be imported, then click Convert.

**Transferring Audio from CD**

*(Macintosh Only)*

Pro Tools allows you to transfer audio tracks from an audio CD with the Import Audio From Other Movie command. Since the transfer is made in the digital domain, there is no signal loss.
4 In the Save dialog, click Options.

5 In the Options dialog, select the sample rate, bit depth, and stereo format for the imported audio.

6 At the bottom of the Options dialog, set the range of the CD track to be imported by adjusting the Start and End times, then click OK.

7 To audition a CD track before you import it, use the Play and Stop buttons.

8 Navigate to a destination for the imported audio, and click Save.

Pro Tools imports the CD audio track as a QuickTime movie and saves it on your hard drive.

9 In the Track Import Window, click OK.

Pro Tools converts the audio track to your session’s audio file format, bit depth, and sample rate.

The imported audio file appears in the Audio Regions List. From there you can drag the regions to tracks in your session.

---

**Conversion Quality**

The Conversion Quality Preference determines the quality of sample rate conversion used when converting and importing audio into a session, and when importing CD audio tracks (Macintosh only). There are five possible settings, ranging from Low to Tweak Head. The higher the quality, and the larger the conversion, the longer it will take.

To set the sample rate conversion quality:

1. Choose Setups > Preferences, and click Editing.

2. From the Conversion Quality pop-up menu, select a quality setting.

For most applications, the Good or Better setting will yield very good results.

3. Click Done.
Exporting Pro Tools Tracks as OMF Files

Pro Tools 5.1.3 and Later

With the DigiTranslator Integrated Option, Pro Tools lets you export individual tracks or an entire Pro Tools session in OMF format. This option requires DigiTranslator 2.0 or later.

For more information on installing and using DigiTranslator with Pro Tools, refer to the DigiTranslator Guide.

Exporting Session Text

TDM Systems Only

You can use the Export Session As Text command to create a text file that contains extensive information about your session.

This text file can contain a list of audio files, audio regions, audio track EDL (edit decision list) information, extended timestamp information, and information about crossfades.

Track EDLs are exported as tab-delimited text—that is, with tabs between each column heading, and tabs between each event parameter. You can use this data in a program for reading EDLs, or you can format the EDL data into tables using a word processor or spreadsheet application.

Export Session Text Options

Include File List/Region List

You can choose to export a list of the session’s audio files and regions. The File List provides a list of all the audio files and fades in the session, and their hard drive locations. The Region List displays all audio regions in the session, and the source audio file for each region.

Include Track EDLs (Playlists)

You can export track EDLs (playlists). Track EDLs can be used to spot-check region placement and edits, or in a conforming program for post applications. In extreme circumstances the EDL can be used to recreate the entire session.

MIDI track EDLs are not exported.

When exporting track EDLs, the following options are available:

Export Session Text dialog

Include File List/Region List

Include Track EDLs (Playlists)
Show Subframes
This option allows you to export subframe time information with track EDLs, if used in your session.

Include User Timestamps
You can include user timestamps with track EDLs. User timestamps indicate a user-defined session location for the region, or the original location of the region when recorded.

Fade Handling
For track EDLs, you can choose whether to show crossfades, not to show them, or to combine crossfaded regions. When regions are combined, their durations and locations are listed up to the center of the crossfade (for the leading region) and from the center of the crossfade (for the following region).

Time Format
You can select the appropriate time format that exported EDL information is based on. For example, for post work, you might select SMPTE time, but for music creation locked to a grid, you might select Bars & Beats.

File Format
You can choose to export to any of several different text formats. These include standard text formats, and Microsoft Word and Excel formats.

The Exported Session Text

Session Information
The session text file starts with basic information about the session. This information includes the session name, sample rate, bit depth, time code format, and number of audio tracks, audio regions, and audio files, as shown in the following example.

<table>
<thead>
<tr>
<th>Session Information</th>
</tr>
</thead>
<tbody>
<tr>
<td>SESSION NAME:</td>
</tr>
<tr>
<td>SAMPLE RATE:</td>
</tr>
<tr>
<td>BIT DEPTH:</td>
</tr>
<tr>
<td>TIME CODE FORMAT:</td>
</tr>
<tr>
<td># OF AUDIO TRACKS:</td>
</tr>
<tr>
<td># OF AUDIO REGIONS:</td>
</tr>
<tr>
<td># OF AUDIO FILES:</td>
</tr>
</tbody>
</table>

File List and Region List
Next, if you choose to include them, are the lists of audio files and regions.

Track EDLs
The final item, if exported, is the list of track EDLs. A track EDL lists the track name, and all edits, including the event number, the region name, region start and end time, and region duration. The region timestamp is also exported, if you select this option. Subframes are shown in each time field if you select this option.

Exporting a session as text:
1. Choose File > Export Session As Text.
2. Select whether to include the File List, Region List, and track EDLs.
If you choose to include track EDLs, select whether to show subframes, and whether to include user timestamps. Also select an option for crossfade handling.

If you choose to include track EDLs, select the Time Format for the exported session text from the pop-up menu.

Select the File Format for exported text using the pop-up menu.

When you have set your options, click OK.

Select a location and enter a filename for the exported text file. In Windows, Pro Tools adds the correct 3-letter filename extension, while on the Macintosh, the file extension ".txt" is added.

**Importing MIDI Files**

You can import Standard MIDI Files into your Pro Tools sessions. Use the Import MIDI to Track command to place the imported MIDI onto new tracks; or use the Import MIDI command in the MIDI Regions List pop-up menu to place the data in the MIDI Regions List, where it can be dragged to existing tracks.

Pro Tools does not import proprietary sequence files. To use sequences from other MIDI applications in a Pro Tools session, you’ll need to first save them as Standard MIDI Files. Refer to the manufacturer’s documentation for details on saving Standard MIDI Files.

There are two types of Standard MIDI Files, both of which are supported by Pro Tools:

- Type 0 MIDI files store data for all MIDI channels in a single track. When importing these files, Pro Tools separates the data by channel and places each track’s data in separate regions and tracks.

- Type 1 MIDI files, sometimes referred to as multitrack MIDI files, contain multiple tracks of MIDI data. When importing these files, each track’s data is placed on its own new MIDI track in the Pro Tools session.

**To import a Standard MIDI File to new tracks:**

1. Choose File > Import MIDI to Track.

2. Select the MIDI file you want to import.

3. To import the MIDI file’s tempo and meter tracks, select the option for Import Tempo From MIDI File.

   This option overwrites existing meter and tempo events in the current session. If you don’t want this, make sure to instead select Use Existing Tempo From Session.

4. Click Import (Macintosh) or Open (Windows). If prompted, specify whether you want to Keep or Discard existing MIDI tracks and regions in the current session.
Chapter 9: Importing and Exporting Session Data

The MIDI data is imported to new MIDI tracks, and also appears as regions in the MIDI Regions List.

⚠️ If the Standard MIDI File contains markers, they are only imported if the current session does not contain any markers.

5 In the Mix window, click on the MIDI Device/Channel Selector for each new track and assign a MIDI instrument and channel, as desired.

To import a Standard MIDI File into the MIDI Regions List:

1 Choose Import MIDI from the MIDI Regions List pop-up menu.
2 Select the MIDI file you want to import.
3 To import the MIDI file’s tempo and meter tracks, select the option for Import Tempo From MIDI File.

This option overwrites existing meter and tempo events in the current session. If you don’t want this, make sure to instead select Use Existing Tempo From Session.

4 Click Import (Mac) or Open (Windows). If prompted, specify whether you want to Keep or Discard existing MIDI tracks and regions residing in the current session.

Pro Tools imports the MIDI data as regions and places them in the MIDI Regions List.

⚠️ If the Standard MIDI File contains markers, they are only imported if the current session does not contain any markers.

5 Drag the new MIDI regions, as desired, to existing MIDI tracks.

Exporting MIDI Files

To export a session’s MIDI tracks for use in another MIDI application, or for playback with an external (hardware) MIDI sequencer, you can save the tracks as a Standard MIDI File.

When exporting, the session tracks can be merged to a single, multichannel track (Type 0), or they can be saved as multiple tracks (Type 1).

To export all MIDI tracks in the current session:

1 Make sure to unmute any MIDI tracks in the session that you want to export.
2 Choose File > Export MIDI.
3 Specify a folder destination and name for the MIDI file.

4 Select whether the Standard MIDI File will be Type 0 (merged, single track) or Type 1 (multi-track).

5 Click Export. Pro Tools exports all MIDI tracks in the current session to a Standard MIDI File and writes it to your hard drive. Exported MIDI information includes notes, controller events, program changes, and System Exclusive data, as well as events for tempo, meter, and markers.
The SMPTE start time for the session is also exported. This ensures that the exported tracks, when played from another MIDI application, will align with the correct SMPTE frames, and also sync correctly to tape and video devices, or Pro Tools.

Refer to your third-party MIDI sequencer documentation to determine whether it supports importing SMPTE start times from MIDI files.

**Not Exported with MIDI Files**

Mute automation and muted regions do not affect exported MIDI. As long as a track is not muted by clicking its Mute button, all of its MIDI data is exported.

When exporting MIDI files from Pro Tools, device assignments for tracks are not retained (though channel assignments are). If you therefore export MIDI tracks from Pro Tools and later re-import them, you’ll need to reassign the tracks to the desired devices.

All playlist information for MIDI tracks is lost when exporting. For example, tracks that previously contained dozens of MIDI regions will be flattened and only contain single regions after exporting and re-importing.
Chapter 10: File Management and Compatibility

When you work with Pro Tools, you will encounter several different kinds of computer files. Pro Tools systems require that you keep certain files in specific hard drive locations in order to function properly.

- Pro Tools software files should be located on your Startup drive (the drive that contains your operating system and other system-related files).
- On Pro Tools TDM systems, data files (session files, audio files and fade files) can be located on any compatible drive connected to the internal SCSI bus or the external SCSI bus of your computer, or to a SCSI host bus adapter card in your computer. For maximum performance, SCSI drives are recommended for Pro Tools TDM systems, also support FireWire and ATA/IDE busses.
- On Pro Tools LE systems, data files can be located on any compatible hard drive connected to your computer’s internal or external ATA/IDE, FireWire, or SCSI busses.

Audio File Management

Unique File IDs

Pro Tools tags each audio file in a session with a unique identifier that allows it to distinguish a particular file even if its name or location has changed.

Locating Audio Files

Pro Tools 5.3.x and Earlier

When you open a session, if Pro Tools is unable to locate audio files contained in the session, it will post a Find File dialog. You can choose to search for replacement files based either on file name or on unique file ID.

In cases where a unique identifier is not present, Pro Tools can identify an audio file using other file attributes, such as sample rate, bit depth, file length, and creation or modification date. Pro Tools will search for files with similar attributes, and list potential matches in the Candidates Files List.
To locate an audio file:

1. In most cases, you can find files created or modified by Pro Tools by selecting Current Folder or Current Volume under “Search In.” To search in all subfolders of the current folder, select Look in Subfolders. If this search does not provide adequate results, you can select All Volumes to search all available drives and partitions.

2. Select whether you want to search for the file by Matching Name or Matching Unique ID. It is faster to search for a file by File Name; however, this search could be less useful if you are searching for a common file name, for example, “Audio-01.”

3. Click Search.

4. If Pro Tools is unable to find the target file, it will list a number of exact matches for the files, as well as candidate files. These are files that have the right file name but do not have the correct Unique File ID.

5. Exact matches in the Find dialog are indicated in the Candidates Files List with a “->” before the file path.

6. To audition a selected audio file, click Play and adjust the Play Position slider to choose the playback location in the file.

7. If checking Candidate Files, and you determine that a file in the Candidates Files List is not the target file, click Skip. To eliminate all files in the list, click Skip All.

8. When you have located the target file, click Open.

If you do not locate the target file, the whole file region and regions based on it appear as offline media in the Audio Regions List and in tracks in the Edit window.

Locating Audio Files

Pro Tools 6.0 Only

With Pro Tools 6.0, you manage links to audio and other media files with the Relink window. In addition, Pro Tools classifies storage volumes according to their suitability for performance (recording or playback) or transfer (storage or copy-
ing) of audio and other media files. Audio files must be stored on suitable Performance volumes and be properly linked in order to be playable in a Pro Tools session.

For complete information on storage volume classifications, refer to the DigiBase Guide.

When you open a session, if Pro Tools determines that audio files are not located on a Performance volume, or if it is unable to locate audio files contained in the session, you can locate or copy the files in order to play back the session. This process is called *relinking*.

**Transfer Files**

Transfer files reside on volumes unsuitable for playback, such as CD-ROMs or network drives.

**To open a session containing Transfer files:**

1. Open the Pro Tools session. If any files are on a volume unsuitable for playback, Pro Tools posts a warning.
2. Do one of the following:
   - Click Yes to open the Copy and Relink dialog.
   - Click No to open the session with all Transfer files offline.

**To make Transfer files playable in the current session:**

1. Choose Windows > Show Project Browser.
2. Double-click the Audio Files folder to display all of the audio files.
3. Choose Select Transfer Files from the Browser menu.
4. Choose Copy and Relink from the Browser menu.

5. Specify a location for the copied files on a valid Performance volume.
6. Click OK.

For complete information on relinking Transfer files, refer to the DigiBase Guide.

**Missing Files**

A file is missing if it is not found in the same location as when the session was last saved.

**To open a session with missing files:**

1. Open the Pro Tools session. If any files are missing, Pro Tools posts a Missing Files warning.
2. Choose one of the following options:
   - **Automatically Find and Relink** Searches all Performance volumes for all missing files with matching name, unique file ID, format, and length, and automatically commits links to missing files where possible.
   - **Manually Find and Relink** Opens the Relink window, where you can search, compare, verify, and relink missing files.
   - **Skip All** Ignores all missing files and fades. The missing files will be offline in the session.
   - **Regenerate Missing Fades** Excludes fades from the relinking process, recalculating them instead.

For complete information on storage volume classifications, refer to the DigiBase Guide.
3 Click OK.

For complete information on relinking missing files, refer to the DigiBase Guide.

---

**WAV File Compatibility**

Convert all imported WAV files to AES31/BroadcastWave

Pro Tools always creates AES31/Broadcast compliant WAV files when the file originates in Pro Tools. This option, accessed by choosing Setups > Preferences > Compatibility, makes imported WAV files compliant with the AES31/EBU Broadcast standard.

AES31/Broadcast Wave is a variant of the standard audio WAV file type. The AES31 format contains information beyond the raw PCM audio data, such as SMPTE time stamps.

This variant complies with standards set by the EBU (European Broadcasters Union), and the AES (Audio Engineering Society). Choose this option to ensure compatibility with other workstations that recognize this file type.

---

**Avid File Compatibility**

When Avid Compatibility mode is enabled, Pro Tools adds metadata when bouncing to disk, or when recording from a bus. This metadata includes the name of session, and the name of the source of the bounce (bus or track output). When the bounced file is opened on an Avid system, the metadata information will help identify the source of the file components.

In addition, when Avid Compatibility mode is enabled, it forces all OMF media to be treated as Read Only within Pro Tools.

---

To enable Avid Compatibility mode:

1. Choose Setups > Preferences > Compatibility.
2. Select Avid Compatibility Mode.
3. Click Done.

---

**Creating Mac and PC Compatible Sessions**

The Enforce Mac/PC Compatibility option allows you to create and save Pro Tools sessions that are compatible on both Macintosh and Windows. These options are available when creating a new session, or when saving a copy of a session, with Pro Tools 5.3 and later.

---

**Cross-Platform Session Limits**

**Audio File Types**

Sound Designer II (SDII) files cannot be read by Windows systems. Therefore, when creating Mac and Windows compatible session files, the audio file type for the session must be either AIFF or WAV.

**File Name Extensions**

For cross-platform compatibility, all files in a session must have a 3-letter file extension added to the file name. Pro Tools 5.1 and later session files have the extension “.pts,” and Pro Tools 5 sessions have the extension “.pt5.” WAV files have the “.wav” file extension, and AIFF files have the “.aif” file extension.

**Incompatible ASCII Characters**

Region names, track names, file names, and plug-in settings cannot use ASCII characters that are incompatible with either system.

---

For complete information on relinking missing files, refer to the DigiBase Guide.
When creating a new name, if an incompatibility is detected when Mac/PC Compatibility mode is enabled, a dialog will appear that prompts you to type a new name. When you import files into a session that is set for Mac/PC compatibility, incompatible characters are converted to underscores ("_").

The following characters cannot be used in PC or in Mac/PC compatible sessions:

/ (slash)
\ (backslash)
: (colon)
* (asterisk)
? (question mark)
" (quotation marks)
< (less-than symbol)
> (greater-than symbol)
| (vertical line or pipe)

Any character typed with the Command key

Creating and Saving Cross-Platform Sessions

To create a session that is compatible with Macintosh and Windows:

2. Choose the drive where you want to save the session. The session should be created on a dedicated audio drive.
3. Enter a name for the session.
4. In the New Session dialog, set the Audio File Type to AIFF or WAV. These file formats are compatible with either platform.
5. Set the Sample Rate and Bit Depth for the session.
6. Select the I/O Settings to use for the session. Several pre-configured I/O Settings are included with your system, or you can choose custom I/O Settings that you have created. See Chapter 7, "I/O Setup" for more information.
7. Select “Enforce Mac/PC Compatibility.” This option must be selected to make the session cross-platform compatible.
8. Click Save.

To save an existing session that is compatible with Macintosh and Windows:

1. Choose File > Save Session Copy In.
2. In the Save Session Copy dialog, choose a destination and enter a name for the new session file.
3. Set the Audio File Type to AIFF or WAV. These file formats are compatible with either platform.
4. Set the Sample Rate and Bit Depth for the session.
5. Select “Enforce Mac/PC Compatibility.” This option must be selected to make the session cross-platform compatible.
6. Select the Items to Copy to the new session.
7. Click Save.

If the session previously used SDII files, the files are converted to the new audio file format.
Moving Sessions Between Platforms with MacOpener

MacOpener lets you record and play audio from HFS/HFS+ hard drives on Windows-based Pro Tools systems. It also allows you to open Pro Tools sessions created on a Macintosh. See “Creating and Saving Cross-Platform Sessions” on page 131.

To share Pro Tools sessions between Macintosh and Windows system, select the “Enforce Mac/PC Compatibility” option when creating the session, or when saving a session copy.

Briefly, while SDII files can be exported or converted on import, they cannot be used within Pro Tools sessions on Windows.

To install and configure the MacOpener demo included with Pro Tools:

1. Insert the Pro Tools Installer CD in your CD-ROM drive.
2. Locate and double-click the MacOpener installer file in the MacOpener Demo folder. Follow the onscreen instructions to install the MacOpener. After installation is complete, restart your computer.
3. Choose Start > Programs > MacOpener > MacOpener Driver Preferences.
4. Verify that the MacOpener Driver is enabled. Under Driver Settings, select “Enable MacOpener Driver.”
5. Under Extension Mapping, select “Do not add the PC extension to the Mac file name.”

All formatting and maintenance of HFS/HFS+ drives should be carried out when the drive is connected to a Macintosh.

MacOpener Performance Limitations

- To open a session from an HFS/HFS+ drive, the session must be created with Pro Tools 5.1.1 or later. In addition, the session must not contain mixed audio file formats. To use mixed-format sessions in Pro Tools, first save a copy of the session and convert its files to a supported file format using the Save Session Copy In command.
- When using the Bounce To Disk command, the bounce destination must be a FAT/FAT32 or NTFS drive. Bouncing to HFS/HFS+ drives is not supported.
- Operations such as opening sessions, initiating playback, drawing waveforms when zoomed, and allocating record files are slower on HFS/HFS+ drives than FAT/FAT32 or NTFS drives.
- Because MacOpener must clear the disk cache after copying between HFS/HFS+ drives and FAT/FAT32 or NTFS drives, Pro Tools will launch very slowly after performing these disk copies.
- For SDII files to appear in the Import Audio dialog, you must set the File Of Type pop-up menu to “All Files.”
- On Pro Tools LE for Windows, if you select all files listed in the Import Audio dialog, and any these files have long names (13 or more characters), no files will be added to the import list when you click Convert All. These files can be added to the list by Shift-clicking their file names individually.
Part III: Recording
Chapter 11: Record Setup

Before you start recording, make sure your Pro Tools system is connected and configured properly. For details on connecting Pro Tools to your studio, refer to the Getting Started Guide that came with your system.

While some of the information in this chapter is relevant to recording MIDI, there are more specific setup details for MIDI recording in Chapter 13, “MIDI Recording.”

Input Connections and Audio Levels

Most Digidesign audio interfaces operate as line-level devices and offer no pre-amplification. You must therefore adjust the level of an input signal to line level before it reaches Pro Tools. Low-level sources like microphones and electric guitars need to be pre-amplified. You can do this with a quality mixing board or dedicated preamp, such as the Digidesign PRE.

The Digi 001, Digi 002, and Mbox are exceptions to this rule. The Digi 002 has four inputs with preamps, to which you can connect low-level signals, and four additional inputs with input gain. The Digi 001 I/O and Mbox have two inputs with preamps, to which you can connect low-level signals; the Digi 001 I/O also has six additional inputs with input gain.

Volume and pan controls for tracks in Pro Tools only affect monitoring levels—not the recording input gain. The LED meters on audio interfaces indicate both full-code (highest level before clipping) and true clipping of Pro Tools output signals. The on-screen meters in Pro Tools indicate only true clipping.

Digital Clipping

Clipping occurs when you feed a signal to a recorder or mixer that is louder or “hotter” than the device allows. On many analog tape decks, a little clipping adds a perceived warmth to the sound due to tape compression. In digital recording, however, clipping causes digital distortion, which is undesirable and should always be avoided.

Set Input Levels High But Don’t Clip

When you feed a signal into any audio recording system, including Pro Tools, you need to adjust the input level to optimize the dynamic range. Adjust the input signal to register as high as possible on your input meter without triggering the clipping indicator. If the input level is too low, you will not take full advantage of the dynamic range of your Pro Tools system. If the input level is too high, however, it will be clipped.
**Calibration Mode**

*(TDM Systems Only)*

You can use the Calibration mode in Pro Tools to adjust the input and output levels for your audio interface so they match those of your mixing console and other audio devices in your studio.

The 192 I/O has +4 dBu and –10 dBV inputs, and +4 dBu outputs, each with their own trim pots for proper calibration. The 888|24 I/O has adjustable trim pots for its inputs and outputs.

There are no input or output trims on the following TDM audio interfaces: 192 Digital I/O, 96 I/O, 882|20 I/O, 1622 I/O, and ADAT Bridge I/O. Some Digidesign I/Os that do not have trim outputs offer software-controllable input level, adjustable from Setups > Hardware Setup (refer to the guide for your particular I/O).

For more information on calibrating your audio interface, or using Calibration mode, see the 888|24 I/O Guide or the 192 I/O Calibration Mode Instructions.

**Record Enabling Tracks (Using the Record Enable Button)**

To record to a track you must first record enable it with the Record Enable button. To record simultaneously to multiple tracks, you can record enable multiple audio or MIDI tracks.

When one or more tracks are record enabled, you can click the Record and Play buttons in the Transport window to start recording.

Unlike audio tracks, MIDI tracks can be record enabled while recording.
To record enable multiple audio or MIDI tracks:
- From either the Edit or Mix window, click each track's Record Enable button to toggle record enable on or off for each track.

If Latch Record mode is not enabled, Shift-click each track's Record Enable button to toggle record enable on or off for each track.

To record enable all audio or MIDI tracks:
- Option-click (Macintosh) or Alt-click (Windows) the Record Enable button to toggle record enable on or off for all audio or MIDI tracks.

To record enable all selected tracks audio or MIDI:
- Option-Shift-click (Macintosh) or Alt-Shift-click (Windows) the Record Enable button on any selected audio or MIDI track to toggle record enable on or off for all selected audio or MIDI tracks.

While record enabling does not affect audio tracks that are grouped, you can select all tracks in a group by clicking directly to the left of the group's name in the Groups List. Then you can Shift-Option-click (Macintosh) or Shift-Alt-click (Windows) to record enable all selected tracks.

To record enable a MIDI track during recording:
- Click the MIDI track's Record Enable button while stopped or while Pro Tools is playing or recording. During recording, when you enable a new track, the previous record track is no longer record enabled.

- or -

While pressing Command (Macintosh) or Control (Windows), press the Up/Down Arrows to record enable the previous or next MIDI track. The previous (or next) record track is no longer record enabled.

To keep the previous track record enabled, press Shift+Command+Up/Down (Macintosh) or Shift+Control+Up/Down (Windows).

Latch Record Mode

When the option for Latch Record Enable Buttons is selected in the Operations Preferences, you can record enable additional audio tracks by clicking their Record Enable buttons. Previously record-enabled tracks remain record enabled. Latch Record Enable buttons are for audio tracks only.

When Latch Record Enable Buttons is deselected, record enabling a subsequent audio track will make the previously record-enabled audio track no longer record enabled.

Record Safe Mode

Pro Tools provides a Record Safe mode that prevents tracks from being record enabled. Use Record Safe mode to protect important track recordings.
To put an audio or MIDI track in Record Safe mode:

- Command-click (Macintosh) or Control-click (Windows) the track’s Record Enable button. The Record Enable button is greyed out.

Command-click (Macintosh) or Control-click (Windows) again to take the track out of Record Safe mode.

To put all tracks in Record Safe mode:

- Command-Option-click (Macintosh) or Control-Alt-click (Windows) the Record Enable button on any track.

Command-Option-click (Macintosh) or Control-Alt-click (Windows) again to take all tracks out of Record Safe mode.

To put all currently selected tracks into Record Safe mode:

- Command-Option-Shift-click (Macintosh) or Control-Alt-Shift-click (Windows) the Record Enable button on any of the selected tracks to toggle them in and out of Record Safe mode.

Monitoring Modes

Pro Tools offers two modes of input monitoring, Auto Input Monitoring or Input Only Monitoring (chosen from the Operations menu), which determine how input signals are monitored while recording audio.

Auto Input Monitoring

In this mode, when session playback is stopped, Pro Tools monitors audio input. When playback is started for a punch-in, Pro Tools monitors existing track material up until the punch point. While punched in, the input signal is monitored. On punch-out, monitoring switches back to the existing track material. This is similar to the auto-switching logic found on digital and analog multitrack tape machines.

When Auto Input Monitoring is enabled, the Record button in the Transport window appears gray.

When using Auto Input Monitoring, the switch back to monitoring track material on punch-out is not instantaneous. To get instantaneous monitor switching on punch-out, use QuickPunch (see “QuickPunch Audio Recording” on page 181).

Input Only Monitoring

In this mode, when a track is record enabled, Pro Tools monitors audio input only, regardless of any punch-in/out selection.

When Input Only Monitoring is enabled, the Record button in the Transport window appears green.

Transport window

Monitor Levels for Record and Playback

Pro Tools remembers two different fader levels for monitoring each audio track: one for when the track is record enabled, and one for when it is not record enabled.

Pro Tools remembers these two states for fader levels automatically. If you adjust a fader when a track is record enabled and then turn off record enable for the track, the fader returns to its playback level.
When audio tracks are record enabled, their volume faders in the Mix window turn red, indicating that the record monitor level is active.

**Link Record and Play Faders**

When the Operation Preference for “Link Record and Play Faders” is selected, Pro Tools does not keep track of record and play levels for audio tracks. In this case, record enabling an audio track has no effect on the fader level for the track. This lets you maintain a consistent mix regardless of whether you're recording or just listening.

**Monitoring Latency**

*(Pro Tools LE Only)*

Because Pro Tools LE uses the host processor in your computer for audio processing, playback, and recording, there is a small amount of audio delay, or latency, in the system. This latency amount is related to the H/W Buffer Size—the larger the buffer size, the larger the latency.

While there may be times when you want a larger buffer size, for the sake of higher track counts with more plug-ins, you’ll generally want a smaller buffer size when recording audio that is monitored through your Pro Tools LE system.

If you are monitoring the recording source with an external mixer, before it is routed to Pro Tools, you will not hear any latency.

To set the Hardware Buffer Size:

2. Choose the number of samples from the H/W Buffer Size pop-up.
3. Click OK.

*Computers with slower CPUs may not be able to use the 128 buffer size without encountering performance errors.*

**Low Latency Monitoring**

*(Pro Tools LE Only)*

You can reduce the amount of monitoring latency for Pro Tools LE systems by reducing the H/W Buffer Size. However, even at the smallest buffer size, there is still some latency. In addition, reducing the buffer size limits the number of simultaneous audio tracks you can record without encountering performance errors.

Digi 002, Digi 001, and Audiomedia III systems can use the Low Latency Monitoring option to record with an extremely small amount of monitoring latency, to as many tracks as each system supports.

To use Low Latency Monitoring:

1. Record enable the desired audio tracks (or Auxiliary Inputs) by clicking their Record Enable buttons. Only tracks with inputs set to an audio interface (not a bus) use Low Latency Monitoring.
2. From the Output Selector, assign each track to either Output 1 or Output 2. Only tracks assigned to these outputs use Low Latency Monitoring.
When Low Latency Monitoring is enabled, any plug-ins and sends assigned to record-enabled tracks (routed to Outputs 1–2) are automatically bypassed, and must remain bypassed. Also, these tracks will not register on meters for Master Faders.

**Low Latency Monitoring and Bounce To Disk**

With Low Latency Monitoring Enabled, only audio tracks are included with the Bounce To Disk command—Auxiliary Input tracks are ignored.

To record Auxiliary Inputs with Low Latency Monitoring enabled, you must record the material in real time.

**Default Track Names**

When creating new audio and MIDI tracks, Pro Tools names them as either “Audio” or “MIDI” and numbers them consecutively. For example, when you create two new audio tracks, their default names are “Audio 1” and “Audio 2.” You can rename tracks and also log comments for each track.

Track names define new file and region names when recording to a track.

See “Naming Tracks” on page 89.

**Default Names for Audio Files and Regions**

When recording to an audio track, the resulting file and region names are based on the name of the track. For example, after recording for the first time on a track called “Electric Gtr,” an audio file is written to your hard drive with the name “Electric Gtr-01.” In addition, a region appears in the Audio Regions List with the name “Electric Gtr-01-00.”

Subsequent record takes on the same track are named identically, but with the first set of digits (indicating the take number) incremented. The second set of digits is only used for region naming and indicate a region auto-created from an edit.

The QuickPunch mode uses a slightly different method for numbering regions. For details, see “Region and Take Numbering with QuickPunch” on page 184.

When recording MIDI tracks, a similar naming scheme is used, though with only one set of digits. For example, after recording to a track called “Synth 1,” a region is created called “Synth 1-01.” Subsequent regions for that track, generating either from additional record takes or region edits, are numbered sequentially (for example, “Synth 1-02”).

**Names for Stereo Audio Tracks**

When recording to stereo audio tracks, audio file and region names for the left and right channels are appended with a “.L” and “.R” suffix.
Names for Multichannel Tracks
(TDM Systems Only)

When recording to multichannel surround tracks, audio file and region names for each channel are appended with the following suffixes.

<table>
<thead>
<tr>
<th>Multichannel Format</th>
<th>File and Region Suffix</th>
</tr>
</thead>
<tbody>
<tr>
<td>LCR</td>
<td>L, C, R</td>
</tr>
<tr>
<td>Quad</td>
<td>L, R, Ls, Rs</td>
</tr>
<tr>
<td>LCRS</td>
<td>L, C, R, S</td>
</tr>
<tr>
<td>5.0</td>
<td>L, C, R, Ls, Rs</td>
</tr>
<tr>
<td>5.1</td>
<td>L, C, R, Ls, Rs, LFE</td>
</tr>
<tr>
<td>6.0</td>
<td>L, C, R, Ls, Cs, Rs, LFE</td>
</tr>
<tr>
<td>6.1</td>
<td>L, C, R, Ls, Cs, Rs</td>
</tr>
<tr>
<td>7.0</td>
<td>L, Lc, C, R, Rc, Ls, Rs</td>
</tr>
<tr>
<td>7.1</td>
<td>L, Lc, C, R, Rc, Ls, Rs, LFE</td>
</tr>
</tbody>
</table>

Disk Allocation

By default, Pro Tools records audio files to the Audio Files folder inside the session folder. You can use the Disk Allocation dialog to specify other locations for your audio files for each audio track.

Hard drives that are full do not appear in the Disk Allocation dialog.

To increase system performance, Pro Tools can record and play each track from a different hard drive. You can also automatically distribute any newly created tracks to multiple audio drives with Round Robin Allocation.

To allocate the audio drives in your system:

1. Choose Setups > Disk Allocation.
2. In the Disk Allocation dialog, assign a hard drive for each track by clicking in the Root Media Folder column and selecting a volume from the Disk Allocation pop-up menu.

A folder with the session name is created on each hard drive, containing subfolders for audio and fade files.

- To assign all tracks to the same hard drive, press Option (Macintosh) or Alt (Windows) while selecting a drive name.
- To make a continuous selection, Shift-click a track name (in the Track column) to extend the selection to include already-selected tracks and all tracks in between.
- To make a non-contiguous selection, Command-click (Macintosh) or Control-click (Windows) a track name in the Track column to extend the selection to include already-selected tracks without including tracks in-between.
3 To save recorded audio files to an existing folder (without creating another session folder), select Customize Allocation Options, then click the Change button and choose the folder. To create subfolders in this folder, select “Create Subfolders for audio, video, and fade files.”

4 To automatically distribute any newly created tracks among the drives connected to your system, select “Use Round Robin Allocation for New Tracks.”

If you are using Round Robin Allocation and want audio to be recorded to your system’s startup drive:
- On Macintosh OS X, open the Workspace browser and set the Volume Designator for your system volume to Record/Playback (see “Workspace Volume Designation” on page 142.
- or –
- On Macintosh OS 9 or Windows, select Include System Volume (see “Recording to the System Volume” on page 143 for details).

⚠️ Round Robin Allocation is not supported with partitioned hard drives.

5 When you are finished, click OK.

### Saving Disk Allocation Settings

To save Disk Allocation settings for use with future sessions, save the session as a template. For details, see “Creating Custom Session Templates” on page 52.

### Disk Allocation and Cross-Platform Sessions

Pro Tools for Windows supports recording and playback of audio from multiple hard drives, but to ensure cross-platform operation, it also requires that Macintosh Pro Tools sessions and their associated audio files be on Macintosh-formatted (HFS or HFS+) drives.

Similarly, Windows sessions and their associated audio files must reside on Windows-formatted (FAT32 or NTFS) drives. If you want to share sessions between Windows and Macintosh platforms, consider these restrictions when allocating tracks to drives.

### Reallocating Tracks

When opening a session where some of the previously assigned hard drives are no longer available (or don’t match the current session platform), Pro Tools automatically reassigns tracks to the volume where the session file is stored. In such cases, use Disk Allocation if you need to reallocate tracks to other drives.

⚠️ Reallocating tracks does not affect the audio that has been previously recorded. Reallocating tracks only affects where new audio recording will be saved.

### Workspace Volume Designation

**Macintosh OS X Only**

The Workspace volume designation can alter disk availability, thus affecting Disk Allocation. From the Workspace browser, designate volumes as Record, Playback, or Transfer. If you change a drive’s designation, making it read-only (Play Only or Transfer), you will need to check the Disk Allocation for any tracks formerly allocated to that drive. For more information, see the *DigiBase and DigiBase Pro Guide*. 
Recording to the System Volume

Though Pro Tools will let you record to your system volume, this is generally not recommended. Performance for audio recording and playback on system drives is worse than on non-system hard drives.

You should record to system drives only when absolutely necessary—if your computer system has just the one hard drive, or if your other hard drives are completely out of space.

Allocating Hard Drive Space for Recording

The Operation Preference for Open Ended Record Allocation determines how much of your available hard drive space is allocated whenever you record into one or more tracks in Pro Tools.

When this preference is set to Use All Available Space, the drive’s entire available space is allocated. This can slow down the recording process for hard drives that use certain file systems, including HFS+ and NTFS.

In such cases, you can reduce the time it takes to begin recording by allocating only a portion of your hard drive.

To allocate a portion of your hard drive for recording:

1. Choose Setups > Preferences and click Operation.
2. Under the Open Ended Record Allocation option, select Limit To and enter a number of minutes to be allocated.

The number of minutes specified is allocated for each record-enabled track. You may find it necessary to experiment with this number to achieve the desired performance for recording.

3. When you are finished, click Done.

Choose Windows > Show Disk Space to check the current available space on your drives.

Record Modes

For recording audio, Pro Tools has four record modes:

- Nondestructive Record (Default)
- Destructive Record
- Loop Record
- QuickPunch

To enable Destructive Record, Loop Record, or QuickPunch, select them from the Operations menu. If none of these record modes are selected, Pro Tools is in normal Nondestructive Record mode.
The record mode can also be switched by Control-clicking (Macintosh) or Right-clicking (Windows and Macintosh OS X) the Record button in the Transport window. This cycles through the four modes with the Record button changing to indicate the currently selected mode: blank for Nondestructive, “D” for Destructive, a loop symbol for Loop Record, and “P” for QuickPunch.

When recording, you can preserve disk space by removing unwanted record takes (see “Removing Unwanted Regions” on page 288) and compacting audio files (see “Compacting an Audio File” on page 289).

**Nondestructive Record Mode**

In normal Nondestructive Record mode, Pro Tools records audio nondestructively, which means that if you record over a track’s existing regions, the audio is not erased from your hard drive. Both the new and old audio files remain on your hard drive, available as regions from the Audio Regions List.

In Nondestructive Record mode, the record range is defined by selecting a range in the Ruler or in a track’s playlist, or by specifying start and end points in the Transport window. If there is no selection, recording begins from the current cursor location and continues until the Transport’s Stop button is clicked.

To set a record range by selecting within a track’s playlist, the Edit and Timeline selections must be linked. See “Separate Edit and Timeline Selections” on page 223.

The pre/post-roll settings allow material to be heard up to and after the start and end points, which is useful when punch recording (see “Punch Recording Audio” on page 158).

**Destructive Record Mode**

In Destructive Record mode, recording over existing regions replaces the original audio permanently, which allows you to keep disk use to a minimum. However, if you have sufficient drive space, it is usually best to use Pro Tools in Nondestructive Record mode, to avoid losing any previously recorded material.

When defining the record range and setting pre- and post-roll, Destructive Record mode works the same as Nondestructive mode.

Unlike the other record modes, it is not possible to cancel record takes when using Destructive Record mode (see “Canceling a Record Take” on page 154).  

**Loop Record Mode**

Loop Record mode allows you to record take after take (nondestructively) while the same section of audio repeats. This is a convenient technique for quickly recording multiple takes of a part without losing spontaneity.

The time range that is looped and recorded—which must be at least one second in length—is defined by selecting a range in the Ruler or in a track’s playlist, or by specifying start and end points in the Transport window. The pre-roll setting, if enabled, is used during the first record pass, but on each successive loop the pre/post-roll times are ignored.

To set a record range by selecting within a track’s playlist, the Edit and Timeline selections must be linked. See “Separate Edit and Timeline Selections” on page 223.
When using Loop Record mode, each successive take appears as a region in the Audio Regions List and each is numbered sequentially. The various takes, which are identical in length and start time, are easily auditioned and placed in the track at the correct location with the Takes List pop-up menu (see “Auditioning Record Takes” on page 160).

**QuickPunch**

QuickPunch gives you the ability to manually and instantaneously punch in (initiate recording) and punch out (stop recording) on record-enabled audio tracks during playback by clicking the Transport’s Record button. Recording with QuickPunch is nondestructive.

When using QuickPunch, Pro Tools begins recording a new file when playback begins, automatically generating regions in that file at each punch in/out point. These regions appear in the track’s playlist; and the complete audio file appears in the Regions List along with the QuickPunch created regions. Up to 100 of these “running punches” can be performed in a single pass.

Though you can punch record in the other record modes by manually specifying the record range, only QuickPunch provides instantaneous monitor switching on punch-out.

**The Record Modes and MIDI**

In addition to the four record modes, there is also a MIDI Merge button in the Transport window that determines how MIDI is recorded. When enabled (Merge mode), recording over existing MIDI regions results in the new data being merged with the old. When the MIDI Merge button is deselected (Replace mode), the new material replaces the old.

MIDI recording works the same whether using Nondestructive or Destructive Record mode. In addition, QuickPunch does not need to be enabled to punch on-the-fly with MIDI—this capability is available in Nondestructive and Destructive Record modes.

Unlike audio, MIDI can be loop recorded when Operations > Loop Playback is enabled. In this mode, the state of the MIDI Merge toggle determines whether existing material is replaced or merged.

Unless MIDI Merge is enabled, MIDI recording is destructive (though you can undo a MIDI record pass), either overwriting or adding to region material. One exception to this rule is when Loop Record mode is enabled; in this mode, existing track regions are replaced with new regions when new material is recorded. The old regions remain intact and available from the MIDI Regions List, and from the Takes List pop-up. In Loop Record mode, MIDI Merge has no effect, so its button is dimmed.
Recording with the Click

If you intend to work with MIDI tracks in your session, or if the audio you’re working with is bar- and beat-oriented, you can record your tracks while listening to the click. This ensures that recorded material, both MIDI and audio, will align with the session’s bar and beat boundaries.

When your track material lines up with the beats, you can take advantage of some useful editing functions in Pro Tools, such as quantizing MIDI and audio regions, quantizing individual MIDI notes, and copying and pasting measures and song sections in Grid mode.

Material that is recorded without listening to the click can still be aligned to bar and beat boundaries in Pro Tools with Beat Detective (see Chapter 22, “Beat Detective”), or use the Identify Beat command to determine the tempo.

To configure the click options:

1. Choose MIDI > Click Options.
   - or -
   Double-click the Click or Countoff button in the Transport window.

2. In the Click/Countoff Options dialog, choose the port number (device) and channel that will play the click from the Output pop-up menu. If using DigiRack Click plug-in, select None. (For information on using the Click plug-in, see the DigiRack Plug-Ins Guide.)

3. For the accented and unaccented notes, specify the note, velocity, and duration with the numeric keypad. If connected, you can also play new note values on your MIDI controller keyboard.

   When listening to the click in your Pro Tools sessions, the accented note sounds on the first beat of each measure and the unaccented note sounds on the remaining beats.

4. Select whether the click is heard “During play and record,” or “Only during record,” or “Only during countoff.”

5. If using a countoff, specify the number of Bars to be counted off. To hear the countoff only when recording, select that option.

6. Click OK.

To enable the click from the MIDI menu:

- Choose MIDI > Click.
To enable the click in the Transport:

1 To view the MIDI controls in the Transport window, select Display > Transport Window Shows > MIDI Controls.

2 In the Transport window, click the Click button so it becomes highlighted.

3 To use a countoff when recording or playing, click the Countoff button in the Transport window so it too becomes highlighted.

Setting the Default Meter

When opening a new session in Pro Tools, the meter defaults to 4/4. If you intend to record with the click and are working with a different meter, make sure to set the default meter accordingly.

If a session’s meter does not match the music you’re recording, the accented clicks will not line up with what you’re playing, and, as a result, the recorded material may not align with the bars and beats in the Edit window.

Meter events, which can occur anywhere within a Pro Tools session, are stored in the Meter Track and appear in the Meter Ruler. Inserting and editing for meter events is discussed in “Meter Events” on page 297.

To set the default meter for a session:

1 Choose Windows > Show Tempo/Meter.
   – or –
   Double-click the Meter button in the Transport window.

Wait for Note and Countoff

Wait for Note and Countoff are mutually exclusive and cannot both be enabled at the same time. If, for instance, Countoff is enabled and you click the Wait for Note button, Countoff is disabled.
2 Enter the Meter you will use for the session and set the Location to 1|1|000 (so the inserted meter event replaces the default one).

3 Choose a note value for the number of clicks to sound in each measure.

4 Click Apply to insert the new meter event.

**Setting the Default Tempo**

When opening a new session in Pro Tools, the tempo defaults to 120 BPM. If you intend to record with the click and are working with a different tempo, make sure to set the default tempo accordingly. If you know the tempo you will use for the session, you can insert a tempo event at the beginning of the Tempo Track.

Tempo events, which can occur anywhere within a Pro Tools session, are stored in the Tempo Track and appear in the Tempo Ruler. Inserting and editing for tempo events is discussed in greater detail in “Tempo Events” on page 291.

**To insert a default tempo event:**

1. Choose Windows > Show Tempo/Meter.
   – or –
2. Double-click the Meter button in the Transport window.
3. At the top of the Tempo/Meter Change window, choose Tempo Change from the pop-up menu.
4. Enter the BPM value you will use for the session and set the Location to 1|1|000 (so the inserted tempo event replaces the default tempo).
5. To base the BPM value on something other than the default quarter-note, select the desired note value.
6. Click Apply to insert the new tempo event.

See “Default Tempo” on page 294 for more information on the default tempo.

**Using Manual Tempo Mode**

In Manual Tempo mode, Pro Tools ignores the tempo events in the Tempo Track and instead plays back at the tempo displayed in the Transport window. The manual tempo can be set with the Tempo slider, or, if you’re not sure of the actual tempo, by tapping in the tempo.
While you can adjust the Manual Tempo during playback, doing so will momentarily interrupt playback.

To set the manual tempo with the Tempo slider:

1. To view the MIDI controls in the Transport window, select Display > Transport Window Shows > MIDI Controls.

2. In the Transport window, click the Conductor button so it becomes unhighlighted. Pro Tools switches to Manual Tempo mode. In this mode, any tempo events in the Tempo Track are ignored.

3. To base the BPM value on something other than the default quarter-note, change the note value in the Beat Value pop-up menu (just to the left of the Tap button).

4. To enter a new tempo, drag the horizontal Tempo slider in the Transport window.

For finer resolution with the Tempo slider, press Command (Macintosh) or Control (Windows) while dragging.

To exit Manual Tempo mode and enable the Tempo Track:

- Click the Conductor button in the Transport window so it becomes highlighted.

To set the manual tempo with the Tap button:

1. To view the MIDI controls in the Transport window, select Display > Transport Window Shows > MIDI Controls.

2. In the Transport window, click the Conductor button so it becomes unhighlighted. Pro Tools switches to Manual Tempo mode. In this mode, any tempo events in the Tempo Track are ignored.

3. Click the Tap button repeatedly at the desired tempo.

- or -

Click in the Tempo field so it becomes highlighted and tap in the tempo by playing a note repeatedly at the desired tempo on your MIDI keyboard controller.

To compute the new tempo, Pro Tools requires at least four taps (each of which is displayed in the Tap area when received). The computed BPM value appears in the Transport’s Tempo field.

To lock in the new tempo:

- Take Pro Tools out of Manual Tempo mode by clicking the Conductor button, then insert a tempo event (with the new tempo) at the beginning of the Tempo Track.
Chapter 12: Basic Audio Recording

Recording an Audio Track

When recording from a mono source, record to a single, mono audio track in Pro Tools. A single, mono audio file is written to disk; the region appears in the playlist and in the Audio Regions List.

To record a stereo audio source in Pro Tools, record to a single, stereo audio track. A single, mono audio file is written to disk for each channel of a stereo track; one for the left channel, and one for the right channel; regions appear in the playlists for both channels. In addition, a multichannel (stereo) region appears in the Audio Regions List.

To configure an audio track for recording:

1. Connect a mono or stereo sound source to the appropriate input of your audio hardware.
2. If you want to start a new session with a different sample rate, choose File > New Session, and select the sample rate. Click Save.
3. Make sure to specify the format (analog or digital) of the inputs of the audio interface you will be using. Choose Setups > Hardware Setup, choose the audio interface, and select the format for the channel pair.

Some Digidesign I/O units, such as Digi 001 or Mbox, only have two channels (Ch 1–2) that can be set for analog or digital.

4. If a track doesn’t already exist, choose File > New Track and specify 1 Mono or Stereo Audio Track, then click Create.

To auto-scroll the Track Type pop-up in the New Track dialog, press Command (Macintosh) or Control (Windows) and use the Up/Down Arrow keys.

5. If desired, rename the track. Track names are used to auto-name recorded audio files and regions. For more information, see “Default Track Names” on page 140.
6 In the Mix window, use the track's Input Selector to assign a hardware input.

- or -

In the Edit window, with I/O view enabled, use the track's Input Selector to assign a hardware input.

7 In the Mix window, click on the track's Output Selector and assign a hardware output.

- or -

In the Edit window, with I/O view enabled, use the track's Output Selector to assign a hardware output.
8 In the Mix window, click the audio track’s Record Enable button to record enable the track. Volume faders for record-enabled tracks turn red.

9 Adjust the output level of your sound source (instrument, mixer, or preamp). Monitor the track’s meter levels in Pro Tools to ensure that you get the highest possible signal without clipping.

10 In the Mix window, adjust the track’s volume and pan faders as desired. These settings are for monitoring purposes only and do not affect the recorded material.

   – or –

In the Output window for the track, adjust the track’s volume fader and pan controls as desired. These settings are for monitoring purposes only and do not affect the recorded material.

**To record to an audio track:**

1 In the Operations menu, deselect Destructive Record, Loop Record, and QuickPunch.

2 If desired, enable Click and Countoff in the Transport window. Also, make sure to specify the session’s default meter and tempo. For details, see “Recording with the Click” on page 146.

3 In the Transport window, click Return to Zero so the start and end times are cleared. This ensures that you’ll start recording from the beginning of the track.

4 Click Record in the Transport window to enter Record Ready mode. The Record button flashes.

5 When you are ready to begin recording, click Play. If using Countoff, Pro Tools counts off the specified number of measures and then begins recording.

6 When you have finished recording, click Stop in the Transport window.
The newly recorded audio is written to disk and appears as an audio region in the track’s playlist. The new audio region also appears in the Audio Regions List.

To play back the audio track:

1. Click the Record Enable button for the audio track so that they are no longer record enabled. Track volume faders now function as playback level controls.

   If Auto Input Monitoring is enabled, you can simply click the Record button in the Transport window to exit Record Ready mode, then press Play, leaving the track record enabled. The track will automatically switch to Playback mode when you press play, then back to Input mode when you stop. See “Auto Input Monitoring” on page 138.

2. In the Transport window, click Return to Zero to start playback from the beginning of the session.

3. Click Play in the Transport window to start playback. Adjust the track’s volume and pan faders as desired.

Undo or Cancel Audio Recording

Once you’ve recorded an audio track and the transport is stopped, you can undo the previous record take.

To undo an audio recording:

- Once the Transport has been stopped, choose Edit > Undo Record Audio.

The track’s playlist is restored to its previous state. However:

- If you punched in and out several times before stopping the Transport, only the last punch is undone.
- When using Loop Record mode, all takes from each record pass are discarded.

⚠️ If you undo a record pass during recording and stop recording, Pro Tools will prompt you with a warning that, “The current record pass will cause a previously undone record pass to be removed from the session. Would you like the files from the previous record pass to be removed from disk?” If you choose “Yes,” those previously recorded files will be deleted.

Canceling a Record Take

While recording, it is possible to discard the current record take. This removes the audio (recorded up to that point) from your hard drive and deletes the region from the track’s playlist. This capability is not available in Destructive Record mode.

To cancel a record take while recording:

- Press Command+period (Macintosh) or Control+period (Windows) before the Transport is stopped.

If using Loop Record mode, all takes from each record pass are discarded.
Recording Multichannel Tracks

(Pro Tools TDM Systems Only)

Recording multichannel tracks is very similar to recording stereo audio tracks. A single, mono audio file is written for each channel in the track, and regions appear in the playlists for each channel. In addition, a multichannel region appears in the Audio Regions List.

For more information on multichannel tracks, see “Multichannel Audio Tracks” on page 483.

Record Shortcuts

In addition to clicking the Record button in the Transport window, you can also begin recording with the following keyboard shortcuts:

- Press F12 to start recording immediately.
- Press Command+Spacebar (Macintosh) or Control+Spacebar (Windows) to start recording.
- Press 3 on the Numeric Keypad (when the Numeric Keypad Mode is set to Transport) to start recording.

As long as the preference for Latch Record Enable Buttons is enabled, you can record enable subsequent tracks by clicking their Record Enable buttons. Other tracks already record enabled will remain so.

To initiate recording at half-speed, press Command-Shift+Spacebar (Macintosh) or Control-Shift+Spacebar (Windows). For details, see “Half-Speed Recording and Playback” on page 186.

To record multiple audio tracks:

1. Connect the outputs from your sound source to the appropriate inputs of your audio hardware.

2. Configure each track for recording. Follow the same steps for creating a new session and new tracks, and assigning inputs and outputs for each track as in “Recording an Audio Track” on page 151.

3. Record enable the audio tracks you want to record by clicking their Record Enable buttons.

4. Adjust the output level of your sound sources (instruments, mixer, or preamp). Monitor the tracks' meter levels in Pro Tools to ensure that you get the highest possible signal without clipping.

5. Adjust the tracks' volume and pan controls as desired. These settings are for monitoring purposes only and do not affect the recorded material.

6. In the Operations menu, deselect Destructive Record, Loop Record, and QuickPunch.

7. If desired, enable the click and countoff in the Transport window. Also, make sure to specify the session’s default meter and tempo. For details, see “Recording with the Click” on page 146.
8 In the Transport window, click Return to Zero so the start and end times are cleared. This ensures that you’ll start recording from the beginning of the track.

9 Click Record in the Transport window. When you are ready to begin recording, click Play.

10 When you have finished recording, click Stop in the Transport window.

For each record-enabled track, a new audio file is written to disk and a new region is created and appears in the playlist. The new audio regions appear in the Audio Regions List.

### Record Pause Mode

When recording a large number of tracks or channels, or playing back a large number of tracks while recording, Pro Tools may take a little longer to begin recording. To avoid this delay, put Pro Tools in Record Pause mode before beginning to record.

To record from Record Pause mode:

1 Click Record in the Transport window. The Record button flashes.

2 Option-click (Macintosh) or Alt-click (Windows) Play in the Transport window to put Pro Tools in Record Pause mode. The Play and Record buttons flash.

3 To begin recording instantaneously, click Play. When you have finished recording, click Stop in the Transport window.

4 Use Pause mode when recording or playing large numbers of tracks to speed up lock-up time when synchronizing to time code.

### Recording Additional Takes

After recording to an audio track, you can record additional takes to the same track. However, if you record these additional takes in Destructive Record mode, the audio residing on your hard drive from the previous takes will be permanently lost.

To keep the audio from previous takes, record the new takes nondestructively in Nondestructive Record mode.

To nondestructively record a new take on the same track:

1 Put Pro Tools in Nondestructive Record mode. In the Operations menu, deselect Destructive Record, Loop Record, and QuickPunch.

2 Make sure the track containing the previous take is still record enabled.

3 To record from the beginning of the track, click Return to Zero in the Transport window.

4 Click Record in the Transport window. When you are ready to begin recording, click Play.

5 When you have finished recording, click Stop in the Transport window.
An audio file for the new take is written to disk and appears as an audio region in the track's playlist. The new audio region appears in the Audio Regions List.

The audio from the original take remains on your hard drive, and is still available as a region in the Audio Regions List.

To destructively record over a previous take:

1. Select Operations > Destructive Record. When using Destructive Record mode, a “D” appears in the Record button.

2. Make sure the track containing the previous take is still record enabled.

   - or -

3. To record from the beginning of the track, click Return to Zero in the Transport window.

   - or -

   If Operations > Link Edit and Timeline Selection is enabled, click anywhere in the track’s playlist to begin recording from that point.

4. Click Record in the Transport window. When you are ready to begin recording, click Play.

5. When you have finished recording, click Stop in the Transport window.

   The audio for the new take is written to disk, permanently overwriting the original. The new material replaces the original material within the existing region and the region is not renamed.

Appending New Material to the End of a Track

You can also append new material to the end of a track. To do this, locate to the end of the track with the Go to End button in the Transport window (this will locate the end of the session), or tab to the end point of the last region on the track. From there, begin recording and Pro Tools will add the new material to the end of the track. If using Destructive Record mode, the new audio is appended to the audio file and region from the first take. In Nondestructive Record mode, a new file and region are created.

Recording to a New Playlist

Instead of recording over existing audio regions, there is another way to nondestructively record new takes to the same track. Do this by creating a new playlist for the track, then record just as before.

Tracks can have multiple edit playlists, each of which stores a list of regions strung together in a particular order. Also, since playlists follow groups, duplicating or selecting alternate playlists for a track in a focused group will affect all tracks in the group.
To record to a new playlist for a track:

1. From the track’s Playlist Selector pop-up, choose New. Enter a name for the new playlist and click OK.

When a new playlist is created, its name replaces the track name. With this playlist active, names for new audio files and regions are based on its name.

2. Make sure the track is still record enabled.

3. In the Transport window, click Return to Zero.

4. Click Record in the Transport window. When you are ready to begin recording, click Play.

5. When you have finished recording, click Stop in the Transport window.

An audio file for the new take is written to disk and appears as an audio region in the track’s playlist. The new audio region appears in the Audio Regions List.

6. To audition the new take, click Play in the Transport window.

7. To go back to a previous playlist to compare it to the new take, select the playlist from the track’s Playlist Selector.

Selecting a playlist recalls its regions as they previously appeared in the track. At any time, all regions from all playlists are available in the Regions List, and can be mixed and matched between playlists and tracks.

For more information on playlists and playlist editing, see “Playlists” on page 199.

Punch Recording Audio

To define a record range in the playlist, or replace a portion of a recorded track, you can punch in by specifying the record range before recording.

To manually punch in and out on record-enabled audio tracks during playback, refer to “QuickPunch Audio Recording” on page 181.

Though there are several ways to set record and play ranges (see “Setting Punch/Loop Points” on page 162), perhaps the easiest is to select within the track’s playlist the range for recording.

To set a record or play range by selecting within a playlist, the Edit and Timeline selections must be linked (select Operations > Link Edit and Timeline Selection).

During the recording process, playback begins at the pre-roll time (if enabled) and proceeds to the start time (the punch-in point), where recording begins. When the end time (the punch-out point) is reached, Pro Tools automatically switches out of Record mode and continues playing through the specified amount of post-roll. This automated punch-in/out feature is a powerful and precise way of recording or re-recording a portion of a track.
To punch record on an audio track:

1. To record nondestructively, make sure that Operations > Destructive Record is not selected.
   – or –
   If you do want to permanently record over the specified record range, select Operations > Destructive Record.

2. Make sure the track to which you want to record is record enabled.

3. Make sure to select Operations > Link Edit and Timeline Selection.

4. With the Selector, drag in the track's playlist until the selection encompasses the desired punch range. For other methods of setting the record range, see “Setting Punch/Loop Points” on page 162.

5. To hear any existing track material up to the start point, or after the end point, enable and set pre/post-roll times. For details, see “Setting Pre/Post-Roll” on page 164.

6. Click Record in the Transport window. When you are ready to begin recording, click Play.

When the punch-in (start) point is reached, Pro Tools begins recording. Recording continues until the punch-out (end) point is reached, unless Stop is clicked in the Transport window. If post-roll is enabled, playback continues for the specified post-roll amount.

If recording nondestructively, a new audio file is written to your hard drive and a new audio region appears in the record track and Audio Regions List.

If recording in Destructive Record mode, the new audio overwrites the previous material in the existing audio file and region.

Monitoring During Punch-Ins

Pro Tools provides two monitoring modes for recording: Auto Input Monitoring and Input Only Monitoring. To monitor during Punch-In recording, enable Operations > Auto Input Monitoring. For details, see “Auto Input Monitoring” on page 138.

You can listen to any existing track material up to and after the punch record range by enabling pre- and post-roll.

Loop Recording Audio

Pro Tools provides a loop recording feature that allows you to record take after take while the same section of audio repeats over and over. This is a convenient technique for quickly recording multiple takes of a part without losing spontaneity.

When loop recording, you must first specify the start and end points for the loop. Though there are several ways to set record and play ranges (see “Setting Punch/Loop Points” on page 162), perhaps the easiest is to select within the track's playlist the material to be looped.

To set a record or play range by selecting within a playlist, the Edit and Timeline selections must be linked (select Operations > Link Edit and Timeline Selection).
You can listen to track material up to and after the loop record range by enabling pre- and post-roll.

The pre-roll setting, if enabled, is used only during the first record pass, and the post-roll setting, if enabled, is used only on the last pass. Pre- and post-roll times are ignored on each successive loop. To compensate for this, you may want to make the loop range slightly longer. Later, you can trim back the recorded takes to the desired length with the Trimmer tool (see “The Trimmer Tool” on page 245).

When loop recording audio, Pro Tools creates a single audio file that comprises all takes. Takes appear as individual regions in the Audio Regions List and are numbered sequentially. Once you stop recording, you can audition any of the recorded takes.

To loop record an audio track:

1. Select Operations > Loop Record. When Loop Record mode is enabled, a loop symbol appears in the Record button.

2. Record enable the audio track by clicking its Record Enable button.

3. Make sure to select Operations > Link Edit and Timeline Selection.

4. With the Selector, drag in the track’s playlist until the selection encompasses the desired loop range.

   For other methods of setting the record range, see “Setting Punch/Loop Points” on page 162.

5. To hear track material up to the start point of the loop, enable and set the pre-roll time. For details, see “Setting Pre/Post-Roll” on page 164.

6. Click Record in the Transport window. When you are ready to begin recording, click Play.

   The Record button flashes during the pre-roll. When the start point is reached, Pro Tools begins recording. When the end point is reached, Pro Tools loops back to the start time and continues playing and recording.

7. To cancel all recorded takes while loop recording, press Command+period (Macintosh) or Control+period (Windows).

8. When you have finished recording, click Stop in the Transport window.

   If you stop recording before you reach the midpoint of the loop, Pro Tools discards that take. If you record more than half of the looped take, Pro Tools will leave the take in the track when you stop recording.

   The recorded takes appear as regions in the Audio Regions List and are numbered sequentially. The most recently recorded take is left in the record track. For details on auditioning the various takes from the Takes List pop-up, see “Auditioning from the Takes List Pop-up Menu” on page 161.

**Loop Playback and Audio Recording**

Pro Tools ignores “loop playback” when recording. The only way to loop while recording is to enable Loop Record mode.

**Auditioning Record Takes**

After recording multiple takes with loop or punch recording, you can replace the take currently residing in the track with previous takes to audition them.

All takes are numbered sequentially.
To place and audition previous takes:

1. In the Edit window, select the current take with the Grabber.

2. Command-drag (Macintosh) or Control-drag (Windows) another take from the Audio Regions List into the playlist. The region replaces the previous take and snaps precisely to the correct location.

3. Repeat the above steps as desired to audition other takes.

Auditioning from the Takes List Pop-up Menu

Each region resulting from a punch or loop record pass has an identical start time (the User Time Stamp). This allows you to easily select and audition takes from the Takes List pop-up menu—even while the session plays or loops.

To select a take from the Takes List pop-up:

1. Command-click (Macintosh) or Control-click (Windows) with the Selector at the precise beginning of the loop or punch range.

   — or —

   If the take currently residing in the track is selected, Command-click (Macintosh) or Control-click (Windows) it with the Selector.

A pop-up menu appears containing a list of regions that share the same User Time Stamp.

2. Choose the desired region from the Takes List pop-up menu. The region replaces the previous take and snaps precisely to the correct location.

3. Repeat the above steps as desired to audition other takes.

One way to ensure that future takes have the same User Time Stamp (and appear in the Takes List pop-up) is to store punch and loop record selections as Memory Locations. Then if you later need to record additional takes, simply recall the Memory Location. For more information, see “Storing and Recalling Edit Selections (with Pre- and Post-Roll Values)” on page 166.

To change the User Time Stamp of other regions so that they appear in the Takes List pop-up for a certain location, use the Time Stamp Selected command in the Regions List pop-up menu. For more information, see “Time Stamping” on page 545.

Takes List and Multiple Tracks

If you have recorded multiple tracks, and each contains takes with identical User Time Stamps, you can use the Takes List pop-up menu to replace all takes simultaneously.

To replace the takes for multiple tracks:

1. Choose Setups > Preferences, click the Editing tab, and enable the following options:
   - Take Region Name(s) That Match Track Names
   - Take Regions Lengths That Match

2. Click Done to close the Preferences dialog.

3. With the Selector, select the take range for each track you want to replace.
4 Command-click (Macintosh) or Control-click (Windows) any of the select takes with the Selector.

A pop-up menu appears containing a list of regions that share the same User Time Stamp for that track.

5 Choose a region from the Takes List pop-up menu. The region replaces the previous take and snaps precisely to the correct location. The same take numbers for the other selected tracks are also automatically selected.

**Editing Preferences and Take Regions**

In addition to having the same User Time Stamp, regions that appear in the Takes List pop-up are also restricted according to the following options in the Editing Preferences:

**Take Region Name(s) That Match Track Names**

When selected, only regions that share the same root name with the track/playlist appear in the Takes List pop-up menu. For example, the Takes List for a track named “Gtr.L” would show the regions “Gtr.L-01” and “Gtr.L-02-01,” but not “Guit.L-01.”

**Take Region Lengths That Match**

When selected, only regions that match the length of the current selection (even if it is not an entire region) appear in the Takes List pop-up menu. If there is no selection, all takes with the same User Time Stamp are displayed.

**“Separate Region” Operates On All Related Takes**

When selected, editing a region with the Separate Region command also affects all other related takes with the same User Time Stamp.

This option helps you compare different sections from a group of related takes. For example, you can quickly separate an entire group of related vocal takes into sections, then audition and select the best material from each section independently.

If this option is selected, make sure the “Take Region Names That Match Track Name(s)” and “Take Region Lengths That Match” options are also selected. If they are not, all regions in the session that have the same User Time Stamp will be affected.

In most instances, you’ll want to deselect the “Separate Region Operates On All Related Takes” option, to prevent a large number of regions from being created when you use the Separate Region command.

**Setting Punch/Loop Points**

The start and end points of a record range for punch and loop recording can be set by the following means:

- Select a range in a track’s playlist
- Select a range in a Timebase Ruler
- Drag the Playback Markers in the Ruler
- Enter start and end times in the Transport window
- Recall a Memory Location

**To set the record range in a track’s playlist:**

1. If desired, set the Edit mode to Grid so the selection is constrained to the current Grid value.
2. Make sure to select Operations > Link Edit and Timeline Selection.
3 With the Selector, drag in a track’s playlist until the selection encompasses the desired record range.

– or –

If a region’s start and end points define the record range, click on the region with the Grabber.

💡 You can also enter start and end point during playback. Press the Down Arrow to set the start point, and press the Up Arrow to set the end point. Note that when in Grid mode, entering start and end point in this manner will not snap to the grid.

To set the record range in a Timebase Ruler:
1 If desired, set the Edit mode to Grid so the selection is constrained to the current Grid value.
2 Drag with the Selector in any Timebase Ruler until the selection encompasses the desired record range.

💡 If the Selector is not active, you do not need to manually select it. Other Edit tools (such as the Grabber) automatically turn into the Selector when used in the Timebase Ruler.

**Playback Markers**

When tracks are record enabled, Playback Markers for start and end times appear as red up/down arrows in the Ruler. If no tracks are record enabled, the Playback Markers are blue.

The Playback Markers can be moved, either separately or at the same time, to set record and play ranges.

**To set the record range by dragging the Playback Markers:**
1 If desired, set the Edit mode to Grid so the dragged Playback Markers snap to the current Grid value.
2 Drag the first Playback Marker (down arrow) to the start point of the range.

If the current record range is already the right length and the range needs only to be moved, Option-drag (Macintosh) or Alt-drag (Windows) either Playback Marker to move both to a new location (while keeping the same length).

**Start and End Fields**

The Transport window can be resized to display start, end, and length times, and pre- and post-roll settings (choose Display Transport Window Shows > Expanded). When setting a record or play range, it is reflected in these fields.
You can enter locations in the start and end fields to set the record or play range. The Playback Markers in the Ruler are updated accordingly.

To set the record range by entering start and end times in the Transport window:


2. In the Transport window, click in the start field.

   – or –

   Press Option+slash (Macintosh) or Alt+slash (Windows) on the numeric keypad to select the start field in the Transport window.

3. Type in the start location and press slash on the numeric keypad to enter the value and automatically move to the end field.

4. Type in the end location and press Enter to accept the value.

   Use the period (.) or Left/Right Arrow keys to move through the different time fields for start/end. Use the Up/Down Arrow keys to increase or decrease the numerical values.

### Setting Pre/Post-Roll

Pre- and post-roll times appear as flags in the Ruler. When pre- and post-roll are enabled, the flags are green, otherwise they are gray.

Pre- and post-roll amounts can be entered in the Transport window, set from a track’s playlist or Timebase Ruler, or by recalling a Memory Location.

⚠️ Pre- and post-roll add significant demand on the system and should be disabled when not strictly needed (especially when using QuickPunch, which also adds load to the system).

### Setting Pre- and Post-Roll in the Transport Window

Pre- and post-roll can be enabled and set from the fields in the Transport window.

To set and enable the pre- and post-roll times in the Transport window:


2. In the Transport window, click in the pre-roll field.

3. Type in the pre-roll amount and press slash on the numeric keypad to enter the value and automatically move to the post-roll field.

4. Type in the post-roll amount and press Enter to accept the new value.

5. To enable either pre- or post-roll, click the appropriate button so it becomes highlighted.

Use the period (.) or Left/Right Arrow keys to move through the different time fields for pre/post. Use the Up/Down Arrow keys to increase or decrease the numerical values.
**Setting Pre- and Post-Roll in a Playlist**

You can use the Selector to enable and disable pre- and post-roll by clicking in a track's playlist.

**To set and enable the pre- and post-roll by clicking in a playlist:**

1. Make sure that Operations > Link Edit and Timeline Selection is enabled.
2. With the Selector, drag in the track's playlist until the selection encompasses the desired record range.
3. With the Selector, Option-click (Macintosh) or Alt-click (Windows) in the track's playlist before the selection to enable the pre-roll at that location.
4. With the Selector, Option-click (Macintosh) or Alt-click (Windows) in the track's playlist after the selection to enable the post-roll at that location.

**To disable the pre- and post-roll by clicking in a playlist:**

1. With the Selector, Option-click (Macintosh) or Alt-click (Windows) within a track selection near the start to disable the pre-roll.
2. With the Selector, Option-click (Macintosh) or Alt-click (Windows) within a track selection near the end to disable the pre-roll.

   ![In the timeline, you can reset the pre- and post-roll to zero. First, drag the Pre-Roll Flag to the Playback Marker at the start point of the range, then drag the Post-Roll Flag to the Playback Marker at the end point of the range](image)

3. Drag the Pre-Roll Flag to the Playback Marker at the start point of the range.
4. Drag the Post-Roll Flag to the Playback Marker at the end point of the range.

**Enabling Pre- and Post-Roll from the Operations Menu**

Pre- and post-roll (as a pair) can be enabled and disabled from the Operations menu.

**To enable both pre- and post-roll from the Operations menu:**

- Select Operations > Pre/Post Roll Playback.

**Dragging Pre- and Post-Roll Flags in the Timebase Ruler**

The Pre- and Post-Roll Flags can be moved in the Ruler, either separately or at the same time, to set their location.

**To set the pre- and post-roll amounts by dragging in the Ruler:**

1. If desired, set the Edit mode to Grid so the dragged flags snap to the current Grid value.
2. Drag the Pre-Roll Flag to the desired location in the Ruler.
3. Drag the Post-Roll Flag to the desired location in the Ruler.

   ![Dragging a Pre-Roll Flag in Ruler](image)

   *To set pre- and post-roll values to the same amount, Option-drag (Macintosh) or Alt-drag (Windows) either the Pre- or the Post-Roll Flag in the Ruler. The deselected flag will immediately reset to the same value, and will adjust accordingly as you drag the selected flag.*
Storing and Recalling Edit Selections (with Pre- and Post-Roll Values)

You can store Edit selections as Memory Locations, which can include current pre- and post-roll values.

For more information on Memory Locations, see “Memory Locations and Markers” on page 300.

To save an Edit selection with a Memory Location:

1. Make sure to select Operations > Link Edit and Timeline Selection.
2. Set the record range by making a playlist or Ruler selection, or by entering start and end times in the Transport window.
3. If desired, enable and set the pre/post-roll amounts in the Transport window, or by dragging the Pre- and Post-Roll Flags in the Ruler.
4. Press Enter on the numeric keypad.
5. In the New Memory Location dialog, set Time Properties to Selection, and, if desired, under General Properties, select the option for Pre/Post Roll Times.
6. Enter a name for the new Memory Location and click OK to save it.

To recall an Edit selection with a Memory Location:

1. Make sure to select Operations > Link Edit and Timeline Selection.
2. Choose Windows > Show Memory Locations.
3. In the Memory Locations window, click the name or number of the Memory Location.
   - or -
   Recall the desired Memory Location by typing period, the Memory Location number, and period again on the Numeric Keypad. (see “Numeric Keypad Modes” on page 35).

The start and end times and pre/post-roll settings stored with the Memory Location are recalled.
Chapter 13: MIDI Recording

Although recording MIDI in Pro Tools is similar to recording audio, there are some important differences:

- Unlike audio, MIDI recording is almost always destructive. See “The Record Modes and MIDI” on page 145 for details.
- Unlike audio tracks, MIDI tracks can be record enabled on the fly while recording.
- Similar to audio tracks, MIDI tracks have an Input Selector that determines which ports on your MIDI interface (devices) and which MIDI channels are routed and recorded to the track. If the Input Selector is set to All, all channels for all devices are routed to the track.
- It is not necessary to use QuickPunch to punch in on the fly with MIDI tracks. This capability is available in normal Nondestructive Record mode, and in Destructive Record mode.

Recording from MIDI Devices

The MIDI Inputs for record-enabled MIDI tracks determine which MIDI data is recorded in Pro Tools. MIDI Inputs can be set to a specific device (port) and channel, or they can be set to “All,” where all channels for all devices are merged to the track.

MIDI tracks in Pro Tools do not contain multiple channels and always play back on the track’s assigned (MIDI output) devices and channels. Multiple MIDI channels can be simultaneously recorded to multiple tracks.

The following Pro Tools options determine whether you can record from a MIDI controller device:

- Devices that are assigned as a MIDI Controller in the Peripherals dialog are ignored when MIDI tracks are recorded. This is to avoid recording data from MIDI control surfaces (such as the Mackie HUI).
- On the Macintosh, to record to a device, it must be enabled in the Input Devices dialog. For more information, see “Enabling Input Devices” on page 168.

In addition, the following options affect how MIDI data is recorded in Pro Tools.

- The MIDI Input Filter can filter out MIDI messages that you may not want to record, such as Polyphonic Aftertouch or System Exclusive data. For more information, see “MIDI Input Filter” on page 169.
- Input Quantize, when enabled, automatically quantizes (time corrects) all MIDI notes that are recorded. For more information, see “Input Quantize” on page 170.
Enabling Input Devices

(Macintosh Only)

To record from a MIDI controller in Pro Tools, the device must be enabled in the Input Devices dialog. You can also use this dialog to make sure unwanted notes from certain devices, such as drum machines or arpeggiators, are not recorded.

MIDI Control Surfaces In order to use any MIDI control surfaces, such as the CM Labs Motor Mix, they must be enabled in the Input Devices dialog.

MMC In order for Pro Tools to sync to MMC, the MMC source must be enabled in the Input Devices dialog.

To enable input devices:
2. In the MIDI Input Enable dialog, select the MIDI devices you will record from. Also, make sure any devices that will be used as a control surface are also selected.
3. Deselect any devices you want to ignore while recording MIDI.
4. When you are finished, click OK.

Pro Tools Inputs
(Pro Tools 6.0 Only)

Pro Tools has four virtual MIDI inputs, called Pro Tools Inputs, that can receive MIDI from other supported software applications. For example, you can use Pro Tools Inputs to synchronize to MIDI Time Code generated from another supported software application, control software synthesizer plug-ins in Pro Tools (such as Bruno and Reso), or record MIDI data from another MIDI sequencer to Pro Tools MIDI tracks.

MIDI Patchbay is a useful application for routing MIDI between applications that support virtual MIDI inputs (such as Pro Tools), and applications that don’t (such as Reason). For more information, see http://pete.yandell.com/software.

MIDI Thru

To monitor MIDI tracks while recording, enable MIDI Thru. When enabled, Pro Tools routes MIDI from your controllers to the device and channels assigned to the MIDI track currently record enabled.

The MIDI Preference for Global MIDI Playback Offset and individual MIDI track offsets do not affect MIDI routed with MIDI Thru.

When MIDI Thru is enabled, System Exclusive events are echoed to the MIDI device assigned to the record-enabled track—but only if the sysex events are smaller than 256 bytes.
To enable MIDI Thru:

- Select MIDI > MIDI Thru.

When using MIDI Thru, you should disable Local Control, if present, on your MIDI devices. Otherwise, your MIDI device may receive double MIDI notes, which can lead to stuck notes. If you are unsure how to disable Local Control for your instrument, refer to the manufacturer’s documentation.

The Default Thru Instrument

In addition to any MIDI tracks that are record enabled, you can also route MIDI to the Default Thru Instrument. This saves you the trouble of creating a MIDI track and record enabling it to hear a particular MIDI device and channel.

Unlike MIDI tracks, which only listen to the device and channel assigned to its Input Selector, all incoming MIDI data is routed to the Default Thru Instrument.

If the Default Thru Instrument is assigned to a record-enabled MIDI track, Pro Tools only routes to the record-enabled track.

To set the Default Thru Instrument:

1. Choose Setups > Preferences, and click the MIDI tab.

2. From the pop-up menu for Default Thru Instrument, select the MIDI device and channel to which MIDI data will be routed. To disable the Default Thru Instrument, select None.

MIDI Input Filter

Use the MIDI Input Filter to prevent certain MIDI messages from being recorded. The MIDI Input Filter can be set to record “All” messages, “Only” the specified messages, or “All Except” the specified messages.

For example, to filter out Polyphonic Aftertouch:

1. Choose MIDI > Input Filter.

2. In the MIDI Input Filter dialog, select the All Except option.

3. Select the option for Polyphonic Aftertouch. Leave all other messages deselected.

4. Click OK.

When using the All Except option, the selected MIDI messages will not be recorded. Conversely, when using the Only option, only the MIDI messages that are selected will be recorded.
**Input Quantize**

When Input Quantize is enabled, all recorded MIDI notes are quantized automatically. To preserve the original “feel” of your recorded MIDI tracks, make sure to disable this option.

**To enable Input Quantize:**

1. Choose MIDI > Input Quantize.
2. In the Input Quantize window, select the Enable Input Quantize option.

Configure the other options in the Input Quantize window as desired. For details on the various Quantize options, see “Quantize” on page 358. When finished, close the Input Quantize window.

For drum machine style loop recording, use Input Quantize while loop recording MIDI in Merge mode (see “Loop Recording with Merge Mode” on page 176).

**Wait for Note**

The Wait for Note button, located in the Transport window, determines how Pro Tools begins recording. When enabled, Pro Tools will not begin recording until a MIDI event is received. This ensures that you begin recording when you’re ready to play, and that the first note, or other MIDI data, is recorded precisely at the beginning of the record range (start time).

Wait for Note can be used when recording normally, when punching in, or when loop recording. If pre-roll is enabled, it occurs after the MIDI event is received and before recording begins.

**To enable Wait for Note:**

1. To view the MIDI controls in the Transport window, select Display > Transport Window Shows > MIDI Controls.
2. In the Transport window, click the Wait for Note button so it becomes highlighted.

With the Operation Preference for “Use F11 for Wait for Note” enabled, you can press F11 to turn on Wait for Note.
MIDI Merge/Replace

The MIDI Merge button, located in the Transport window, determines how MIDI is recorded when overdubbing or punching in. When MIDI Merge is on (Merge mode), recorded MIDI is merged with existing track material. When MIDI Merge is off (Replace mode), existing data within the punched region is replaced by the newly recorded material.

The MIDI Merge button can be turned on and off while playing or recording. In Loop Record mode, MIDI Merge has no effect, so its button is dimmed.

To enable MIDI Merge:

1. To view the MIDI controls in the Transport window, select Display > Transport Window Shows > MIDI Controls.

2. To enable MIDI Merge with a keyboard shortcut, set the Numeric Keypad Mode to Transport, and press the 9 key on the numeric keypad.

To enable MIDI Merge:

1. To view the MIDI controls in the Transport window, select Display > Transport Window Shows > MIDI Controls.

2. In the Transport window, click the MIDI Merge button so it becomes highlighted.

Configuring MIDI Tracks for Recording

Macintosh OS 9 Users: If the IAC bus is enabled as a MIDI input and you attempt to record to a MIDI track assigned to IAC MIDI Channel 2 or higher, Pro Tools will freeze due to a MIDI feedback loop. Disable the IAC bus as an input source in MIDI > Input Devices, or turn off MIDI Thru.

For more information on OMS setup, see the Getting Started Guide.

To configure one or more MIDI tracks for recording:

1. If you do not have a MIDI track to record to, choose File > New Track and specify 1 MIDI Track, then click Create.

2. Rename the MIDI track as desired. Track names are used to auto-name recorded regions. For more information, see “Default Track Names” on page 140.
3 In the Mix window, click on the track’s MIDI Input Selector and assign the device and channel to be recorded.

   ![MIDI Input Selector, Mix window](image1)

   – or –

   In the Edit window, with I/O view enabled, click on the track’s MIDI Input Selector and assign the device and channel to be recorded.

   ![MIDI Input Selector, Edit window](image2)

4 In the Mix window, click on the track’s MIDI Output Selector and assign a device and channel from the pop-up menu. Channels already assigned to other tracks appear bold in this menu.

   ![MIDI Output Selector, Mix window](image3)

   – or –

   In the Edit window, with I/O view enabled, click on the track’s MIDI Output Selector and assign a device and channel from the pop-up menu. Channels already assigned to other tracks appear bold in this menu.

   ![MIDI Output Selector, Edit window](image4)
5 To assign multiple destinations to a single MIDI track, Control-click (Macintosh) or Start-click (Windows) the MIDI Output Selector and select additional channels from any device. When multiple destinations are selected for a single MIDI track, a “*” sign will appear next to the first destination name in the track’s MIDI Output Selector on Macintosh OS X, and a “+” sign will appear next to the first destination name in the track’s MIDI Output Selector on Macintosh OS 9 and Windows.

6 If desired, assign a default program change to the track. Click on the Program button (Prog) and make the necessary selections for program and bank select, then click Done.

Default program changes are sent whenever the track is played. For more information, see “Program Changes” on page 341.

7 If recording to multiple MIDI tracks, repeat the above steps for each track, then continue to the next step.

8 If desired, enable and configure the click, and set a default tempo and meter for the session. For details, see “Recording with the Click” on page 146.

9 If desired, enable Wait for Note or Countoff in the Transport window.

10 To replace existing track material, disable MIDI Merge in the Transport window.

11 If desired, enable Input Quantize to automatically quantize recorded material (see “Input Quantize” on page 170).

12 Make sure MIDI > MIDI Thru is selected, then play some notes on your MIDI controller. The MIDI instrument assigned to the track should sound, and the track’s meters should register MIDI activity.

13 In the Transport window, click Return to Zero so the start and end times are cleared. This ensures that you’ll start recording from the beginning of the track.

14 In either the Mix or Edit window, click the MIDI track’s Record Enable button to record enable the track.

You are now ready to record MIDI data to the record-enabled MIDI tracks. See “Recording to MIDI Tracks” on page 173.

---

**Recording to MIDI Tracks**

In Pro Tools, you can record to one or more MIDI tracks. Recording simultaneously to multiple MIDI tracks allows you to:

- Record from multiple MIDI devices at the same time, capturing material from several performers
- Record multiple channels from the same device, capturing data from a split keyboard
- Transfer MIDI tracks from an external MIDI sequencer

![To take full advantage of the MIDI editing capabilities in Pro Tools, make sure to record with the click enabled. This ensures that recorded data aligns with the session’s bar and beat boundaries.](image)

**To record to one or more MIDI tracks:**

1 Configure a MIDI track for recording. Refer to “Configuring MIDI Tracks for Recording” on page 171.

2 Record enable the MIDI track you want to record by clicking its Record Enable button.

![Shift-click to toggle on record enable for multiple MIDI tracks.](image)
3 Put Pro Tools in normal Nondestructive Record mode. In the Operations menu, deselect Destructive Record, Loop Record, and QuickPunch.

4 Click Record in the Transport window to enter Record Ready mode. The Record button flashes.

5 When you are ready to begin recording, click Play. If using Countoff, Pro Tools counts off the specified number of measures and then begins recording.

– or –

If using Wait for Note, the Play, Record, and Wait for Note buttons flash. Recording begins when a MIDI event is received.

6 When you have finished recording, click Stop in the Transport window.

7 When you have finished recording, click Stop.

For each record-enabled track, a new MIDI region is created and appears in the playlist. The new MIDI regions also appear in the MIDI Regions List.

_undo and MIDI Recording_

You can undo the previous record take.

To undo a MIDI recording:

1. Once the Transport has been stopped, choose Edit > Undo MIDI Recording.

The track’s playlist is restored to its previous state. However:

- If you punched in and out several times before stopping the Transport, only the last punch is undone.
- When using Loop Record mode, all takes from each record pass are discarded.

_Canceling a Record Take_

It is also possible to discard the current record take before the Transport is stopped.

To cancel a record take while recording:

1. Press Command+period (Macintosh) or Control+period (Windows) before the Transport is stopped.

If using Loop Record mode, all takes from each record pass are discarded.

_Punch Recording MIDI_

To replace a portion of a MIDI track, you can punch in by specifying the record range before recording.

To punch in on a MIDI track:

1. Configure a MIDI track for recording. Refer to “Configuring MIDI Tracks for Recording” on page 171.

2. In the Operations menu, deselect Destructive Record, Loop Record, and QuickPunch.
3 In the Transport window, disable Wait for Note and Countoff.

4 Select Operations > Link Edit and Timeline Selection.

5 With the Selector, drag in the track’s playlist until the selection encompasses the desired punch range.

For other methods of setting the record range, see “Setting Punch/Loop Points” on page 162.

6 To hear existing track material up to the start point, or after the end point, enable and set pre/post-roll times. For details, see “Setting Pre/Post-Roll” on page 164.

7 Record enable the track containing the previous take by clicking its Record Enable button.

8 Click Record in the Transport window to enter Record Ready mode. The Record button flashes.

9 When you are ready to begin recording, click Play.

If pre-roll is enabled, the track material leading up to the punch-in point plays. You can start playing during the pre-roll to get the “feel.” Material is not recorded until the start point is reached.

When the start point is reached, Pro Tools begins recording. Recording continues until the end point is reached, unless Stop is clicked in the Transport window. If post-roll is enabled, playback continues for the specified post-roll amount.

10 When you have finished recording, click Stop in the Transport window.

The newly recorded MIDI data appears in the track.

**Punch Recording “On-The-Fly” with MIDI**

You don’t have to set a record range to punch in on a MIDI track. In fact, you can punch in and out freely at any time during playback. Unlike audio tracks, it is not necessary to enable Quick-Punch to perform real-time punch recording.

**To punch record “on-the-fly” with MIDI:**

1 Configure a MIDI track for recording. Refer to “Configuring MIDI Tracks for Recording” on page 171.

2 Put Pro Tools in normal Nondestructive Record mode. In the Operations menu, deselect Destructive Record, Loop Record, and Quick-Punch.

3 Disable Wait for Note and Countoff in the Transport window.

4 Record enable the track containing the previous take by clicking its Record Enable button.

5 Start playback by clicking Play in the Transport window.

6 When you reach the punch-in point, click Record in the Transport window.

   – or –

For Digi 001 and Digi 002 systems (or Digidesign ProControl and Control|24 dedicated controllers) with a connected footswitch, press the footswitch at the punch-in point.

The Record button stops flashing and stays lit during recording.

7 To punch out, click Record again (or press the footswitch).

Pro Tools exits Record mode and continues playing. You can perform additional punches during the same pass.
Regions and Punch Recording

Depending on the record range, new regions may be created after punch recording. For example, Figure 9 shows two existing regions before recording. Since the start and end times occur within both of the existing regions, a new region is created to fill the space between them. However, when selecting an entire region, or a section within a region, before punching, no new regions are created. In this instance, only the material residing within the existing region changes, with no new material recorded outside the region.

Unlike audio recording, MIDI recording in this scenario is destructive. If a region is altered because of a record take, the original material is lost (unless you choose Edit > Undo MIDI Recording), or combined with new material (if MIDI Merge was enabled during recording). If an existing region contains important material, use Duplicate to make a copy of the region (“Duplicate Command” on page 260) or the track’s playlist (see “Working with Playlists” on page 199).

Loop Recording MIDI

Loop recording with MIDI is supported by two methods:

- In normal Nondestructive Record mode, enable Loop Playback and MIDI Merge for drum machine style loop recording.

  – or –

- Use Loop Record mode to record multiple takes on each record pass. This is similar to loop recording audio.

Loop Recording with Merge Mode

For drum machine style loop recording, use normal Nondestructive Record mode with Loop Playback and MIDI Merge enabled. With this method, MIDI is recorded and merged to the same region with each new record pass—thereby allowing you to, for example, record hi-hats on the first pass and kick and snare on the next.

Make sure that MIDI Merge is enabled in the Transport window, otherwise (in Replace mode) each subsequent take will destructively replace the previous.

💡 You can record enable a different MIDI track on the fly while loop recording. While pressing Command (Macintosh) or Control (Windows), use the Up/Down Arrows to record enable the previous or next MIDI track.

To loop record with MIDI Merge:

1. Configure a MIDI track for recording. Refer to “Configuring MIDI Tracks for Recording” on page 171.
2. In the Operations menu, deselect Destructive Record, Loop Record, and QuickPunch.
3 Select Operations > Loop Playback. When Loop Playback is enabled, a loop symbol appears in the Play button.

4 If you have not done so already, record enable the MIDI track by clicking its Record Enable button. Make sure no audio tracks are record enabled.

5 In the Transport window, click the MIDI Merge button so it becomes highlighted.

6 Disable Wait for Note and Countoff in the Transport window.

7 Select Operations > Link Edit and Timeline Selection.

8 With the Selector, drag in the track’s playlist until the selection encompasses the desired loop range.

For other methods of setting the record range, see “Setting Punch/Loop Points” on page 162.

9 To hear track material up to the start point of the loop, enable and set the pre-roll time. For details, see “Setting Pre/Post-Roll” on page 164.

10 Click Record in the Transport window. When you are ready to begin recording, click Play.

The Record button flashes during the pre-roll. When the start point is reached, Pro Tools begins recording. When the end point is reached, Pro Tools loops back to the start point and continues playing and recording.

11 Play some notes on your MIDI controller. Newly recorded MIDI data appears as a region in the record track. On each successive take, recorded material shows up in the region, without replacing material from previous takes.

12 If desired, switch to a new record track. While pressing Command (Macintosh) or Control (Windows), use the Up/Down Arrows to record enable the previous or next MIDI track.

13 When you have finished recording, click Stop in the Transport window.

The newly recorded MIDI data appears as a MIDI region in the track’s playlist, and in the MIDI Regions List.

**Loop Recording Multiple Takes**

When recording MIDI in Loop Record mode, new regions are created each time new material is received during a record pass. This differs somewhat from loop recording audio, where separate audio files and regions are created with each subsequent record pass.

You can use this method of MIDI loop recording to record successive takes without stopping the record process, thereby preserving your creative spontaneity. Another advantage with this method of recording MIDI, which is nondestructive, is that existing and newly recorded regions remain intact (and available in the MIDI Regions List).

**To record MIDI in Loop Record mode:**

1. Configure a MIDI track for recording. Refer to “Configuring MIDI Tracks for Recording” on page 171.

2. Select Operations > Loop Record. When Loop Record mode is enabled, a loop symbol appears in the Record button.
If you have not done so already, record enable the MIDI track by clicking its Record Enable button. Make sure no audio tracks are record enabled.

Disable Wait for Note and Countoff in the Transport window.

Select Operations > Link Edit and Timeline Selection.

With the Selector, drag in the track’s playlist until the selection encompasses the desired loop range.

For other methods of setting the record range, see “Setting Punch/Loop Points” on page 162.

To hear track material up to the start point of the loop, enable and set the pre-roll time. For details, see “Setting Pre/Post-Roll” on page 164.

Click Record in the Transport window. When you are ready to begin recording, click Play.

The Record button flashes during the pre-roll. When the start point is reached, Pro Tools begins recording. When the end point is reached, Pro Tools loops back to the start point and continues playing and recording.

Play your MIDI controller. A new MIDI region containing the newly recorded material is automatically created and appears in the track’s playlist, replacing the previous region.

Regions are replaced (nondestructively) during subsequent record passes when new MIDI material is received.

When you have finished recording, click Stop in the Transport window. The most recently recorded take is left in the record track.

The recorded takes appear as regions in the MIDI Regions List and are numbered sequentially. The takes, which are the same length and easily interchangeable, can be auditioned from the Takes List pop-up menu—even while the session plays or loops.

To audition the various record takes:

1. Command-click (Macintosh) or Control-click (Windows) with the Selector at the precise beginning of the loop record range.
2. Choose a region from the Takes List pop-up menu. The region replaces the previous take and snaps precisely to the correct location.

For more information on auditioning and managing takes, see “Auditioning Record Takes” on page 160.
Recording System Exclusive Data

Pro Tools supports recording and playing System Exclusive data (sysex) with MIDI tracks. This allows you to use MIDI tracks in Pro Tools to store patch and configuration data for your MIDI devices, or to record real-time sysex changes for a particular parameter of a MIDI device that cannot be controlled by a standard MIDI controller.

**To record a sysex dump at the beginning of a MIDI track:**

1. Make sure that the MIDI OUT for the device sending the sysex is connected to your MIDI interface’s MIDI IN.
2. Configure a MIDI track for recording. Refer to “Configuring MIDI Tracks for Recording” on page 171.
3. Put Pro Tools in normal Nondestructive Record mode. In the Operations menu, deselect Destructive Record, Loop Record, and Quick-Punch.
4. In the MIDI Input Filter, enable recording of System Exclusive data.
5. If you have not done so already, record enable the MIDI track by clicking its Record Enable button.
7. In the Transport window, click Return to Zero so the start and end times are cleared. This ensures that you’ll start recording from the beginning of the track.
8. When you are ready to begin recording, click Record in the Transport window.

The Record, Play, and Wait for Note buttons flash, indicating that Pro Tools is waiting for MIDI data.

9. Initiate the sysex transfer from the MIDI device, according to the instructions in the guide for your MIDI device. When receiving the MIDI data, Pro Tools automatically begins recording.

10. When the transfer is complete (as defined in the guide for your MIDI device), click Stop in the Transport window.

The newly recorded MIDI data appears as a MIDI region in the track’s playlist, and in the MIDI Regions List. MIDI regions that contain System Exclusive data appear blank when the track’s Display Format is set to Regions.

To see the sysex event blocks, which indicate the location of the data, set the MIDI Track View to display Sysex (see “Regions View for MIDI Tracks” on page 197). For details on moving and copying of sysex data, see “System Exclusive Events” on page 347.

**To resend the sysex from Pro Tools:**

1. For the device receiving the System Exclusive data, make sure its MIDI IN is connected to your MIDI interface’s MIDI OUT. Also, make sure the device is set to receive sysex. Some devices require that memory protect be off.
2. For the previously recorded track, click its Record Enable button so that it is no longer record enabled.
3. Click on the track’s MIDI Device/Channel Selector and assign the device from the pop-up menu.
4. In the Transport window, click Return to Zero.
5. Click Play in the Transport window to begin playback. Pro Tools begins playing and transmits the previously recorded sysex to the assigned MIDI device.
Chapter 14: Advanced Recording

QuickPunch Audio Recording

Pro Tools features an intelligent on the fly punch capability called QuickPunch. QuickPunch lets you instantaneously punch in and out on record-enabled audio tracks during playback by merely clicking the Record button in the Transport window.

For Digi 001 and Digi 002 systems, and Digidesign control surfaces, you can use a footswitch to punch in and out when recording with QuickPunch.

When using QuickPunch, Pro Tools begins recording a new file when playback begins, automatically generating regions in that file at each punch in/out point. These regions appear in the track’s playlist; and the complete audio file appears in the Regions List along with the QuickPunch created regions. Up to 100 of these “running punches” can be performed in a single pass. Unlike normal punch recording (see “Punch Recording Audio” on page 158), QuickPunch provides instantaneous monitor switching on punch-out. All QuickPunch recording is nondestructive.

You don’t need to use QuickPunch to punch on the fly with MIDI tracks. This capability is available in normal Nondestructive Record mode, and in Destructive Record mode.

QuickPunch Crossfade Length

Pro Tools can automatically write a crossfade for each punch point when using QuickPunch. The length for these crossfades is set with the QuickPunch Crossfade Length option in the Editing Preferences.

To set the QuickPunch Crossfade Length:

1. Choose Setups > Preferences, and select the Editing tab.
2. Enter a value (in msec) for the QuickPunch Crossfade Length.
3. Click Done.

If a value other than zero is specified for the QuickPunch Crossfade Length, QuickPunch writes a pre-crossfade at the punch-in point (which occurs up to but not into the punched region boundary), and a post-crossfade at the punch-out point (which occurs after the punched region).

Even if the QuickPunch Crossfade Length is set to zero, Pro Tools always executes a 4 millisecond “monitor only” crossfade (which is not written to disk) to avoid distracting pops or clicks that might occur as you enter and exit record mode.
QuickPunch crossfades can later be edited in the same manner as standard crossfades. For details, see “Using Crossfades” on page 271.

QuickPunch Guidelines for TDM Systems

When using QuickPunch on TDM systems, two voices are required for each record-enabled, mono track. This means that you can record up to half the total number of voices available on your system. For example, a Pro Tools|HD system configured for 64 voices can simultaneously record on up to 32 mono tracks with QuickPunch (or 16 stereo tracks).

If the required number of voices for the record-enabled tracks is not available when switching to QuickPunch mode, you will be prompted to free up the necessary voices.

To free up voices on tracks that are not record-enabled, and do not need to be heard while recording:

- Set voice assignments for tracks to Off.
- or –
- Make tracks inactive.

As necessary, voices in use by other tracks, which are not record-enabled, may be stolen while recording with QuickPunch. Priority for tracks while recording with QuickPunch are as follows:

- Tracks with assigned voices that are not record-enabled
- Tracks with assigned voices that are record-enabled
- Auto-voiced tracks that are not record-enabled
- Auto-voiced tracks that are record-enabled

If the session has plenty of available voices, you may have no trouble using QuickPunch with auto-voiced tracks. However, if you are running out of voices, and want to ensure that a track will be heard when recording with QuickPunch, assign it a voice.

QuickPunch and Auto Voice
(TDM Systems Only)

When using QuickPunch with a Pro Tools TDM system configured for the maximum 128- or 64-voices, make sure to set the voice assignment for each audio track to Auto. This ensures that Pro Tools will automatically handle the distribution of voices between each set of voices. For example, for a 128-voice configured Pro Tools|HD system, auto-voice distributes voices evenly across four sets of voices (1–32, 33–64, 65–96, and 96–128).

If you do not use auto-voicing, the voices must be evenly distributed between all DSP engines. For example, to use QuickPunch on 32 tracks without auto-voicing, tracks 1–16 must be assigned to voices 1–16 and tracks 17–32 must be assigned to voices 33–48.
QuickPunch Guidelines for Pro Tools LE
(Digi 002, Digi 001, Mbox, and Audiomedia III)

For non-TDM systems, 8 audio tracks can be simultaneously recorded with QuickPunch in addition to the maximum number of mono tracks supported by your specific Pro Tools LE system (see “Pro Tools LE System Capabilities” on page 10).

To simultaneously record more tracks than this with QuickPunch, you'll need to reduce the number of tracks in the session.

⚠️ With Pro Tools LE, QuickPunch uses CPU processing power, and may reduce the number of tracks and plug-ins you can use.

Recording with QuickPunch

To punch on the fly with QuickPunch:

1. Select Operations > QuickPunch. When QuickPunch is enabled, a “P” appears in the Record button.

2. If desired, configure the QuickPunch Crossfade Length option in the Editing Preferences (see “QuickPunch Crossfade Length” on page 181).

3. Record enable the tracks you want to punch in on. Make sure there are enough available voices on your system.

4. Prepare to record by cueing Pro Tools to an appropriate location (if desired, enable a pre-roll value in the Transport window).

5. Start playback by clicking Play in the Transport window.

6. When you reach the punch-in point, click Record in the Transport window.

   - or -

For Digi 001 or Digi 002 systems with a connected footswitch, press the footswitch at the punch-in point.

The Record button stops flashing and stays lit during recording.

7. To punch out, click Record again (or press the footswitch).

As Pro Tools continues playing, you can perform additional punches (up to 100). When recording multiple punches during a single pass, a single audio file is recorded from which Pro Tools creates the appropriate regions.

QuickPunch with an Edit Selection

If you make an Edit selection and use QuickPunch, the following rules apply:

- If the Transport is not online, recording begins and stops whenever you click the Record button—regardless of the selection’s start or end point.

- If the Transport is online, punch-in/out behavior is controlled by the Online Options setting in the Operations Preferences. If you select Record Online at Insertion/Selection, QuickPunch punches in and out only within the selection (or in the case of an insertion point, only after the insertion point). If you select Record Online at Time Code Lock, QuickPunch disregards the selection and punches in and out whenever you want (after Pro Tools has locked to time code).
Region and Take Numbering with QuickPunch

After recording with QuickPunch, the new audio regions appear in the Audio Regions List. This includes the whole-file audio region encompassing all punches from the record pass, along with the regions derived for each punch.

Names for the punched regions are numbered consecutively starting with “01.” For example, if QuickPunch is used to punch in twice on a track called “Lead Gtr,” a region for the parent audio file appears and is named “Lead Gtr-01,” and two regions for the punches are named “Lead Gtr-01-01” and “Lead Gtr-01-02.”

If you stop playback and record additional punches with QuickPunch, subsequent regions are named by incrementing the first two digits in the name. For example, on the second pass, the punched regions are named “Lead Gtr-02-01,” “Lead Gtr-02-02,” and so forth.

Recording from a Digital Source

If you plan to use a DAT player, digital-output CD recorder, or other digital input and output device with your Pro Tools system, make sure it supports the correct digital format. For example, your interface’s AES/EBU inputs and outputs should only be connected to another AES/EBU device.

Pro Tools|HD Systems

The 192 I/O, 192 Digital I/O, and 96 I/O include AES/EBU, S/PDIF, and ADAT digital options. Additionally, the 192 I/O and 192 Digital I/O include TDIF digital I/O options.

On a 192 I/O, 192 Digital I/O, or 96 I/O, Pro Tools can receive digital audio from the factory-installed Optical (ADAT) I/O at any time (if it is not set to S/PDIF). However, Pro Tools can only receive digital audio from one of its enclosure [Enc] digital sources—AES, S/PDIF or Optical (S/PDIF).

Enclosure digital sources come standard with HD I/Os and are labelled on-screen as [Enc] versions, to differentiate them from digital inputs and outputs available on the 192’s Digital I/O card. For example, the AES/EBU inputs and outputs that come standard in the 192 I/O enclosure are identified as AES/EBU [Enc].

The additional digital ports on the 192 I/O and 192 Digital I/O are TDIF, AES/EBU, and ADAT. Pro Tools can only receive digital audio from one of these ports at a time.

However, inputs on both the 192 I/O’s enclosure I/O and Digital card can be used simultaneously. For example, on a 192 I/O, it is possible to clock off a source from one of the enclosure inputs and have another digital input from the digital ports doing a sample rate conversion, thus having two digital sources.

Pro Tools|24 MIX Systems

On the 888|24 I/O, 24-bit ADAT Bridge I/O, and the original ADAT Bridge I/O, both AES/EBU and S/PDIF outputs are active at all times, so you can actually send digital audio to two different digital devices simultaneously at mix time.

However, Pro Tools can only receive digital audio from one digital source (AES or S/PDIF) at a time.

In addition, although the 888|24 I/O has four stereo AES input pairs, only input pair 1–2 on the master audio interface, (the first audio interface connected to your main DSP card), can accept an external digital clock source.
**Pro Tools LE Systems**

The Digi 001 and Digi 002 include S/PDIF and ADAT digital options.

The Mbox and Audiomedia III include only the S/PDIF digital option.

All digital outputs are active at all times, so you can actually send digital audio to different digital devices simultaneously at mix time.

**Recording from DAT**

**To record from a DAT recorder with Pro Tools:**

1. Connect the digital output of the DAT recorder to the appropriate digital input of your audio hardware.

2. If you want to start a new session with a different sample rate, choose File > New Session, and select the sample rate. Click Save.

3. Make sure to specify the format (digital) of the inputs of the audio interface you will be using. Choose Setups > Hardware Setup, choose the audio interface, and select the format for the appropriate channel pair. Some Digidesign I/O units, such as Digi 001, only have two channels (Ch 1–2) that can be set for analog or digital. Also, if your audio hardware supports different digital formats (such as AES/EBU and S/PDIF), select the digital format you will use.

4. For HD systems, choose Setups > Hardware Setup and select the appropriate Clock Source connected to the appropriate I/O audio interface; or use the Session Setup window to select the appropriate Clock Source.

5. Click OK to close the Hardware Setup dialog.

6. Choose File > New Track and specify 1 Stereo Audio Track, then click Create.

7. Assign the Input Selectors for the track to the appropriate inputs. Since this is a digital-domain transfer, you don’t need to worry about input levels.

8. In the Mix window, click on the track’s Output Selector and assign a stereo hardware output.

   – or –

   In the Edit window, with I/O view enabled, use the track’s Output Selector to assign a hardware output.

9. In the Operations menu, deselect Destructive Record, Loop Record, and QuickPunch.

10. In the Transport window, click Return to Zero so the start and end times are cleared. This ensures that you’ll start recording from the beginning of the track.

11. In the Mix window, record enable the new audio track by clicking its Record Enable button.

   – or –

   In the Edit window, click the audio track’s Record Enable button to record enable the track.

12. Click Record in the Transport window. When you are ready to begin recording, click Play.

13. Start playback on the DAT deck.

14. When the material from the DAT has finished, click Stop in the Transport window.

   For more information on configuring your particular Pro Tools system for recording from a digital source, see your Getting Started Guide.
After a Digital Transfer

After you have finished recording digitally, set the Clock Source (Pro Tools 6.0) or Sync Mode (Pro Tools 5.x) pop-up menu in the Session Setup window back to Internal. Otherwise, Pro Tools will not switch back to its own internal clock and will not record or play audio properly. Failure to switch back to Internal sync typically results in pitch problems (fast or slow playback) or DAE errors, since a DAT recorder or CD Recorder that is idle can default to a different sample rate or stop outputting a sample rate clock altogether.

Half-Speed Recording and Playback

Pro Tools lets you play and record at half-speed. This capability is similar to that of a tape deck where you can record material at half-speed and then play it back at normal speed (up an octave) for special effects.

To record at half-speed:

1. Press Command+Spacebar (Macintosh) or Control+Spacebar (Windows). Recording begins and all existing track material plays at half-speed.
2. When you have finished recording, click Stop.

When played at normal speed, the material recorded at half-speed plays twice as fast (up an octave).

To play at half-speed:

1. Press Shift+Spacebar. Playback begins and track material plays at half-speed. Any audio tracks recorded at normal speed will sound half as fast and an octave lower, and any audio tracks playing back that were recorded at half-speed will sound like they are playing back at normal speed.

On Macintosh, you can also play at half-speed by Shift-clicking the Play button.

2. Click Stop in the Transport window to stop playback.

Use half-speed playback to learn or transcribe difficult passages in recorded tracks.

Use half-speed recording to record difficult to play MIDI tracks. This allows you to hear audio tracks while recording. Half-speed recording and playback do not affect how MIDI tracks sound when played.
Part IV: Editing
Chapter 15: Editing Basics

Pro Tools Editing

The Edit window in Pro Tools provides a powerful collection of tools for editing and assembling audio and MIDI tracks. Track material can be edited nondestructively and in real time during playback.

Nondestructive Editing

The vast majority of audio editing in Pro Tools is nondestructive. Whether cutting, pasting, trimming, separating, or clearing regions, you are only performing these functions on a map of the actual audio data. The source audio files remain untouched. If a particular process or tool works destructively (that is, if it can permanently change audio files on your hard disk), this guide alerts you.

While editing for MIDI tracks is in some instances destructive, with a few precautions you can keep important MIDI tracks and regions safe when performing edits (see “Nondestructive MIDI Editing” on page 198).

Editing During Playback

Pro Tools lets you perform many editing tasks while the session plays. This powerful capability allows you to interactively modify and edit a session, hearing the changes as you make them. You’ll find many instances where you can use this capability to increase your productivity when working with a session.

Following are just a few examples of editing that can be performed while your tracks loop or play:

• Capture, separate, and trim regions
• Place, spot, or rearrange regions
• Add fades or crossfades to audio regions
• Transpose, quantize (including Groove Quantize), and otherwise modify MIDI tracks
• Nudge audio or MIDI regions
• Audition different playlists
• Adjust or scale automation data
• Insert a real-time plug-in
• Process audio with an AudioSuite plug-in

There are a few things that cannot be changed while Pro Tools plays. These include routing to sends and assigning outputs.
Track Material

Each time you record or import audio and MIDI, Pro Tools creates regions for the new track data, which not only indicate where the material begins and ends, but also provides good feedback on its general shape and content. When you record additional takes, or “punch in” on a specific location within a track, Pro Tools creates additional regions.

Regions are also created by cutting and pasting, resizing, separating, and re-capturing existing regions. Regions in a session are listed in the Audio Regions List and MIDI Regions List, where they can be dragged to existing tracks. A track can contain any number of regions, in any arrangement. The order and location of regions in a track define its playlist.

Region Types

There are different region types, based on how they are created:

Whole-File Audio Regions These audio regions are created when recording or importing audio, consolidating existing regions, and when non-destructively processing with an AudioSuite plug-in. Whole-file audio regions reference an entire audio file that resides on your hard drive. Whole-file audio regions are displayed in bold in the Audio Regions List (see “The Audio and MIDI Regions Lists” on page 202). Normal regions often reference only a portion of the parent audio file and are created in the course of editing and, in some instances, when punch recording.

User-Defined Regions These are regions that are explicitly defined, such as when you record or import audio or MIDI; capture, separate, or consolidate a selection; trim a whole-file audio region; and rename an existing region.

Auto-Created Regions These regions are automatically created in the course of editing, and, in some instances, when punch recording over existing regions. Since these regions can accumulate rapidly in a session, you can hide them so they don’t appear in the Audio and MIDI Regions List (see “Managing Regions” on page 286). Auto-created regions can be turned into user-defined regions by renaming them.

Offline Regions Regions are offline when their parent audio files cannot be located, or are not available, when opening a session or importing a track. Offline regions appear in the Audio Regions List as italicized and dimmed; they appear in playlists as light blue regions with italicized names. Offline regions can be edited like other regions, but they cannot be processed with AudioSuite plug-ins.

Multichannel Regions These regions, which are displayed as a single region in the Audio Regions List, reference multiple regions and audio files for stereo and surround tracks. Multichannel regions can be expanded (by clicking the triangle next to their name) to see the individual channels, which can be dragged independently to tracks.

Track View

The Track View determines which data is displayed and edited in the track’s playlist area.

Audio Tracks These tracks can be set to Blocks, Waveform, Volume, Pan, Mute, or any plug-in parameters that have been automated. Except when editing automation data, audio tracks are by default set to Waveform, where track mate-
rial is graphically drawn with amplitude waveforms (a time-domain representation of sound). This Track View provides the necessary detail for important region edits.

**Auxiliary Input Tracks** These tracks can be set to *Volume, Pan, Mute,* or any plug-in parameter that has been automated.

**Master Fader Tracks** These tracks can be set to *Volume,* or any plug-in parameter that has been automated.

**MIDI Tracks** These tracks can be set to *Blocks, Regions, Notes, Volume, Pan, Mute, Velocity, Pitch Bend, After Touch, Program, Sysex,* and any continuous controller type. Except when editing controller data, program changes, or sysex events, MIDI tracks are commonly set to *Notes* or *Regions,* each of which displays notes in a “piano roll” format. Use Notes View for inserting, editing, and copying and pasting MIDI notes; use Regions View to arrange, capture, or consolidate regions.

When an audio track is displayed as *Volume,* *Pan,* or another automated parameter, or when a MIDI track is set to one of the continuous controller types (*Volume, Pitch Bend, After Touch,*), the data for that track appears in the form of a line graph with a series of editable breakpoints. The breakpoints can be dragged to modify the automation data, and new breakpoints can be inserted with the Pencil or Grabber.

For details on editing automation data for audio tracks, see “Automation” on page 421. For details on inserting and editing controller data for MIDI tracks, see “Continuous Controller Events” on page 340.

**To set the Track View:**
- Click the Track View Selector for the track and choose the format from the pop-up menu.

With the Track View set to Blocks, audio and MIDI regions are displayed as empty blocks bearing the region’s name. This mode is most useful once you have finished capturing and editing regions at the waveform or MIDI event level and are moving and rearranging them. Screen redraws are fastest with this format.
The track displays the new format. If the track is part of an active Edit Group, all tracks in the group are set to the new format.

**Toggling Track Views**

Most editing of audio tracks occurs in Waveform and Volume View. For MIDI tracks, most editing occurs in Notes and Regions View. Pro Tools provides an easy way to toggle these views for tracks containing an edit selection or the edit cursor.

**To toggle Track Views:**

1. Click in the track you want to toggle. To toggle multiple tracks, Shift-click or drag the Selector to select additional tracks.

2. Press Control+Minus (Macintosh) or Start+Minus (Windows) on the alpha keyboard.

   – or –

   With the Commands Focus enabled, press Minus on the alpha keyboard.

Audio tracks are toggled between Waveform and Volume View. MIDI tracks are toggled between Notes and Regions View.

**The Master View Format**

Audio and MIDI tracks have Track Views that act as “master.” When a track is displayed in its master format, any edits performed apply to all data in the track. For instance, when an audio track is set to Waveform, copying and pasting affects not just the waveform information, but all of the automation data as well.

The Track Views that act as master for audio and MIDI tracks are:

- Audio tracks: Waveform and Blocks
- MIDI tracks: Regions, Blocks, and Notes (when using the Selector)

Auxiliary Input tracks and Master Fader tracks do not have a Master View. This means that any edits made to an Auxiliary Input or Master Fader track affect any automation data in that track.

**Track Height**

Tracks can be viewed in the Edit window at any of six heights: Mini, Small, Medium, Large, Jumbo, and Extreme. Larger track heights are particularly useful for precise editing. Smaller track heights are useful for conserving screen space in a large session.

You can adjust track heights on an individual track basis or set all tracks to the same height. Track heights can be adjusted during playback.

**To set the Track Height:**

- Click in the area just to the right of the track controls and choose the height from the pop-up menu.

- or –

- Click the small arrow next to the Track View Selector to get the Track Height pop-up menu.
The track is resized to the new height. If the track is part of an Edit Group, all tracks in the group are set to the new height.

Press Control (Macintosh) or Start (Windows) + Up/Down Arrow key to increase/decrease track height of any track that contains a selection or in which the edit cursor is currently placed.

**Expanded Track Display**

Stereo and multichannel tracks share a single playlist for volume and mute. This shared playlist normally occupies the entire height of the track, extending across all channels.

With Expanded Track Display, you can display playlists individually for each channel, thereby allowing for more accurate breakpoint editing. This is also useful for editing pan or multi-mono plug-in data, both of which can be different for each channel.

Expanded Track Display also provides for a larger waveform display (equal to that of mono audio tracks), as well as a separate Track View Selector and meter for each channel.

To turn on Expanded Track Display for a stereo or multichannel track:

- From the Track Height pop-up menu, select Expanded Track Display.

**Track Controls and Track Height**

The Track Height affects how the various track controls appear in the Edit window. For instance, when a track’s height is set to Small, most of the buttons are reduced in size, and in Pro Tools 5.x and earlier, the menus for Track Height and Track View are accessed from the same pop-up.

When the Track Height is set to Mini, only controls for Mute and Solo appear, and the menus for Playlist, Track Height, and Track View are accessed from the same pop-up.
When the Track Height is set to Large, Jumbo, or Extreme, all track controls are displayed at their full size.

Displaying Region Names and Times

Region names can sometimes get in the way of editing audio waveforms and MIDI data. In these instances you may want to disable their display.

To disable the display of region names in playlists:
■ Deselect Display > Display Name In Regions.

To enable the display of region names in playlists:
■ Choose Display > Display Name In Regions. This is extremely useful when working with film and video.

To display region times:
■ From Display > Display Time In Regions, select one of the following options:

None Disables display of region times.

Current Time Displays start and end times for regions.

Original Time Stamp Displays the Original Time Stamp for each region. The Original Time Stamp is the original time code location for the region when it was first recorded or created.

User Time Stamp Displays the User Time Stamp for each region. The User Time Stamp, which defaults to the Original Time Stamp, can be redefined with the Time Stamp Selected command.

Audio Regions and Waveforms

When the Track View for audio tracks is set to Waveform, Pro Tools draws a waveform diagram of the audio. Audio waveforms tell you several things about the recorded sound.

Figure 10 shows an audio waveform for a drum track. The “peaks” represent places in the recording (beats) where the attack of the sound causes the volume to increase momentarily. These are followed by “valleys,” where the volume decreases.

Different types of sounds produce different types of waveforms. Drums, for example, generally produce waveforms with sharp transients (peaks of short duration) that are clearly defined. A drum hit has a loud, sharp attack and a rapid decay.
Other sounds, such as vocals or sustained keyboard sounds, produce very different waveforms, ones that have less pronounced peaks and valleys. That’s because these sounds generally have softer attacks and longer decays.

**Draw Waveforms Rectified Preference**

When the Display Preference for Draw Waveforms Rectified is selected (Setups > Preferences > Display), audio waveforms are displayed so that their positive and negative waveform excursions are summed together and viewed as a single positive-value signal. However, even when this preference is enabled, zooming in beyond a certain point will cause the waveforms to be displayed normally.

Rectified mode displays more detailed waveforms when using track heights of Medium or Small, and can be particularly useful when editing volume automation data, since it depicts waveform “levels” as starting at the bottom of the track.

**Guidelines for Editing Waveforms**

With the Selector tool in the Edit window, you can select portions of audio waveforms and divide them into segments called regions, so that you can rearrange and manipulate them in tracks.

While editing, try to create regions that allow you to maintain a consistent beat. If you always define regions so that they contain a whole number of beats, you’ll be able to string the regions together and maintain a smooth, steady rhythm.

It’s sometimes useful to have a steady, well-defined waveform, such as a drum track, as a guide when selecting and defining other regions. If you’ve played in time with the beat, chances are that you can create rhythmically accurate regions by referring to the drum waveform.

Some important rules to keep in mind when defining regions:

- Whenever possible, begin a region precisely before a volume peak, and end it immediately before another volume peak.
- Whenever possible, make sure a region starts and ends on exactly the same part of a beat.

**Avoiding Clicks and Pops**

If an edited region begins or ends at a point of high amplitude, you may hear an unpleasant click when Pro Tools plays from one region to another. In order to avoid clicks or pops do any of the following:

- Make sure that the start and end points of your selection are as close as possible to the point where the amplitude of the waveform tapers down to meet the zero-crossing line (the
center line of the track’s waveform display). If necessary, use the zooming tools in the Edit window (see “Zooming” on page 208) to display waveforms in greater detail.

◆ On Pro Tools TDM systems, use the AutoFade feature to apply real-time fade-ins/outs to all region boundaries that do not touch or overlap other regions. See “Using AutoFades” on page 280 for details.

◆ Apply a crossfade between regions where a click or pop occurs. See “Creating a Crossfade” on page 278 for details.

**Nondestructive Audio Editing**

When editing an audio track’s playlist in Pro Tools, you’re not actually cutting and moving pieces of sound as you would if you were cutting and splicing analog tape. Instead, Pro Tools creates a map of the audio file on your hard disk, which describes the order in which to play the track portions.

When trimming audio regions with the Trimmer tool, or when editing the placement or order of regions within a track, use multiple playlists to easily return to a track’s previous state. See “Playlists” on page 199 for details.

**Audio Regions and Automation Data**

Automation data for audio resides in tracks and **not** regions. This means that when you drag an audio region from the Audio Regions List to a new track, no automation data is placed in the track. However, if you drag an audio region from an existing track (that contains automation data) to another track, the automation from the source track is placed in the destination track.

**MIDI Regions and MIDI Data**

The two most common Track Views you’ll use for MIDI tracks are Notes and Regions. Use Notes View for inserting and editing individual MIDI notes, and for working with and affecting groups of notes.

When you need to experiment with the arrangement of regions, or define new ones, use Regions View.

For more information on setting Track View, see “Track View” on page 190.

*To toggle the track view, click in the track you want to toggle and press Control+Minus (Macintosh) or Start+Minus (Windows) on the alpha keyboard.*
Notes View for MIDI Tracks

When a MIDI track’s Track View is set to Notes, MIDI notes are displayed in a “piano roll” format. Each note is displayed as a small rectangle with its vertical placement indicating pitch and its horizontal placement indicating location (and duration).

![MIDI track displaying notes](image)

To the left of the MIDI track’s playlist is a vertical mini-keyboard, complete with octave numbering, for pitch reference. You can Command-click (Macintosh) or Control-click (Windows) the mini-keyboard to audition pitches. Arrows at the top and bottom of the mini-keyboard (not available in the smaller track heights) are used to scroll the Notes display up and down.

The pitch range of MIDI notes that can be displayed depends on the track height, and on the current zoom value. Any time a track’s notes do not fit within its current height, notes above or below the viewed area are displayed as single-pixel lines at the very top and bottom of the range (see Figure 11).

To scroll the Notes display up or down for a MIDI track:

- Click either the up or down arrow of the mini-keyboard.

![Scrolling notes with the Up arrow on mini-keyboard](image)

- With any of the Edit window tools (such as the Pencil tool) selected, press Command+Option+Control (Macintosh) or Control+Alt+Start (Windows) and drag up or down on the mini-keyboard.

![Scrolling Notes display by dragging](image)

Using the Edit window tools, notes can be inserted, transposed, trimmed, and moved. For more information, see “Manually Editing MIDI Notes” on page 335.

Regions View for MIDI Tracks

MIDI tracks can also be viewed as Regions, which is similar to Waveform View for audio tracks. While a track’s notes are visible in Regions View, individual note editing is not available in this view. Instead, all editing occurs across a time range encompassing all track data, including continuous controller events, program changes, and System Exclusive events.
Use Regions View to define regions that represent song sections and clips, or to rearrange or assemble track material.

For more information on setting the Track View, see “Track View” on page 190.

To toggle the track view, click in the track you want to toggle and press Control+Minus (Macintosh) or Start+Minus (Windows) on the alpha keyboard.

There are, however, a few things to keep in mind when selecting, copying and cutting, and trimming MIDI regions:

- When cutting or clearing a region selection that includes a note’s start point, the entire note is removed. This is even the case when only a portion of the note (that includes its start point) is selected.

- When copying or cutting a region selection that includes a note’s end point (but not its start point), the note remains and overlaps the edge of the region.

- Similar rules also apply when MIDI regions are trimmed with the Trimmer tool. If the MIDI region’s start point is moved beyond a note’s start point, the note is removed. If the region’s end point is trimmed so that a note’s start point is within the region but its end point is not, the note remains and overlaps the edge of the region.

When moving and placing MIDI regions with overlapping notes, the notes always move with the regions. When placing MIDI regions with overlapping notes next to or near another region, the overlapping notes extend into the adjacent region.

**Nondestructive MIDI Editing**

While editing audio regions is usually nondestructive, this is not always the case for MIDI regions. For instance, if a MIDI region resides in just one track at a single location, editing for that region is destructive. This means that altering the pitch, duration, or placement of notes in Notes View permanently alters the region.

However, when editing a MIDI region that occurs elsewhere, in the same track (at another location or in a different playlist) or in another track, the editing is nondestructive and occurs to an auto-created region. To go back to the previous material, drag the original region from the MIDI Regions List, or return to a previously saved playlist.

One way to safely return to a track’s previous state is with playlists. Before you edit notes, trim regions, or rearrange the order of regions, make a duplicate of the track’s existing playlist and instead work with it (see “Playlists” on page 199).
MIDI Regions and Continuous Controller Events

Continuous controller events reside in MIDI regions and not in tracks. This means that when dragging regions that contain controller data from either a track or the MIDI Regions List, the controller data is written to the destination track.

Unlike continuous controller events, which represent nuances that are part of a MIDI performance, Mute in Pro Tools is an automation playlist that actually mutes the MIDI engine. Mute automation does not correspond to actual MIDI events and is therefore not exported when saving as a Standard MIDI File.

Playlists

The ability to create playlists is one of the most powerful features of Pro Tools, and one reason why it is infinitely more versatile than traditional multitrack recorders.

Edit playlists allow you to take a snapshot of a track's current arrangement of regions, thereby freeing you to experiment with alternate arrangements, returning as necessary to previously saved playlists.

A playlist, which can consist of a single region or many regions, can only be assigned to a track if it is not in use by another track. While you can create an almost unlimited number of edit playlists, which are shared among all tracks, each track has its own set of dedicated automation playlists.

Automation playlists for audio tracks store data for volume, pan, mute, and plug-in parameters. Automation playlists for MIDI tracks, however, store only mute information; continuous controller events, program changes, and sysex events are stored in MIDI regions and therefore reside within edit playlists.

Playlists and Groups

Playlist functions affect all tracks within an Edit Group (if the group is active). This is useful when you want to switch to new or existing playlists among several tracks.

Working with Playlists

When you add a new track to a session, its playlist is empty until you record or import material to it, or drag a region to it from the Audio or MIDI Regions List.

Duplicating a Playlist

When you edit a track, you can work with a copy of the track's playlist and keep the original playlist arrangement intact.

To duplicate a track's current playlist:

1. Click the track's Playlist Selector and choose Duplicate from the pop-up menu.
2. Enter a name for the new playlist and click OK.
The duplicated playlist appears in the track and the track’s name is changed to the name of the new playlist.

New and duplicated playlists are auto-named with the track name, followed by a period and the playlist number (such as the first playlist for a “Kick” track being auto-named “Kick.01”). In this example, subsequent playlists would be auto-named “Kick.02,” “Kick.03,” and so on.

Creating a Playlist
You can also create a new playlist and record or drag regions to it.

To create a new (empty) playlist:
1. Click the track’s Playlist Selector and choose New from the pop-up menu.
2. Enter a name for the new playlist and click OK. An empty playlist with the specified name appears in the track.

As long as a playlist is unassigned, it can be recalled and assigned to any track. Only unassigned playlists appear in the Playlist Selector pop-up.

Recalling a Playlist
You can also recall a previously-created playlist.

To recall and assign a playlist:
- Click the track’s Playlist Selector and choose the playlist from the pop-up menu.

The selected playlist appears in the track and the track’s name is updated to that of the selected playlist.

Renaming a Playlist
You can rename a playlist by renaming the track to which it is assigned.

To rename a track’s assigned playlist:
1. Double-click the track’s name.
2. Enter a new name and click OK. Both the track and playlist names are updated.

Deleting a Playlist
You can delete a playlist from a session entirely. However, since playlists take almost no disk space, you don’t need to delete them for space reasons.

To delete one or more playlists from a track:
1. Click the track’s Playlist Selector and choose Delete Unused from the pop-up menu.
2. Select the unassigned playlists you want to delete. Shift-click to select multiple playlists.
3. Click OK to delete the playlists. This operation cannot be undone.

When deleting a track from a session, you have the option of deleting or keeping its playlists, so they can be used on other tracks.

Multiple Undo
Pro Tools can keep track of up to 16 of the last undoable operations, allowing you to return to a previous editing state.

The Undo operations in Pro Tools are stored in a queue, in the order in which they were invoked. When choosing Edit > Undo, the most recent operation is undone. If you choose Undo again, the next operation in the queue is undone. You can also choose Edit > Redo to redo an operation, which moves back through the Undo queue by one step.
For example, suppose the following operations have been performed, with item 1 being the most recent (first in the queue):

1. Region cut from track
2. Region pasted to track
3. Region slid forward
4. Regions shuffled
5. MIDI note trimmed
6. MIDI note inserted with Pencil

In this example, to Undo the region shuffle, you would have to choose Edit > Undo four times, which would also Undo the first three operations in the queue.

If you then choose Edit > Redo, followed by another edit operation, such as a region trim, the Undo queue would then be:

1. Region trimmed
2. Regions shuffled
3. MIDI note trimmed
4. MIDI note inserted with Pencil

To undo the last operation:
- Choose Edit > Undo.
  - or -
  - Press Command+Z (Macintosh) or Control+Z (Windows).

To redo the last undone operation:
- Choose Edit > Redo.
  - or -
  - Press Shift+Command+Z (Macintosh) or Shift+Control+Z (Windows).

**Operations that Clear the Undo Queue**

Pro Tools will *not* warn you of operations that clear the Undo Queue. Operations that clear the Undo Queue include:

- Deleting a track, or clearing a region from the Audio or MIDI Regions List
- Selecting “Select Unused” in the MIDI Regions List pop-up
- Selecting “Select Unused Regions,” or “Select Unused Regions Except Whole Files” in the Audio Regions List pop-up

**Levels of Undo and RAM**

Since Pro Tools needs to keep track of the playlists for all tracks that are edited, the use of multiple Undos can be memory intensive. You can lower the Levels of Undo in Pro Tools to reduce the amount of RAM used by the Undo queue. If on the other hand you have plenty of RAM allocated to Pro Tools, you can set the Levels Of Undo to as high as 16.

**To set the Levels of Undo in Pro Tools:**

1. Choose Setups > Preferences and click the Editing tab.
2. Click in the Levels of Undo field and enter a value of between 1–16.

When the number of operations in the Undo queue reaches this limit, performing another undoable operation will remove the oldest operation at the bottom of the queue.
The Audio and MIDI Regions Lists

All regions that are recorded, imported, or created by editing appear in the Audio and MIDI Regions Lists. Regions can be dragged from either list to tracks and arranged in any order. Regions can also be auditioned from the Regions List by Option-clicking (Macintosh) or Alt-clicking (Windows) them.

In the Audio Regions List, whole-file audio regions are displayed in bold, and stereo and multichannel regions can be expanded to display individual channels.

Because region names can become lengthy, the Regions List can be scrolled or resized as necessary (see Figure 12). In addition, you can use the pop-up menu at the top of either list to sort, search, rename, and clear regions.

If the Editing Preference for “Region List Selection Follows Track Selection” is enabled, clicking a region in the Regions List highlights it in the track that contains it.

Use the MIDI Regions List as a bin for storing your favorite MIDI clips. Save the session as a template and the regions are available for future sessions (see “Creating Custom Session Templates” on page 52). Since MIDI regions are tick-based (unlike audio regions), they scale seamlessly for use with any tempo.

Displaying File Info for Audio Regions

In addition to region names, the Audio Regions List can also display information about the region’s parent audio file:
- Disk name, which represents the name of the hard drive on which it resides
- File name, which represents the audio file from which the region originated
- The full directory Pathname of the region’s location

For details on displaying additional audio file information using DigiBase, see the DigiBase Guide.
Sorting and Searching the Regions Lists

Most sessions will contain many regions, which may make it difficult to locate a particular region in the Regions Lists. The ability to sort regions and search for them will help greatly in keeping track of large numbers of regions.

To sort regions in a Regions List:

1. From the Regions List pop-up menu, choose Sorting and select the basis for sorting from the submenu.

2. From the Regions List pop-up menu, select Ascending or Descending to switch the order of the displayed regions.

Finding Regions

Use the Find command to display all regions in a list whose names contain a particular word or phrase.

To find and display regions that match a word or phrase:

1. Choose Find from the pop-up menu in the Audio or MIDI Regions List.

2. Type the name, or any portion of the name, for the regions you want to find, then click OK.

Pro Tools displays all regions whose names contain the name that was specified. Figure 13 shows regions found when searching on the word “loop.” When displaying regions with the Find command, a small diamond appears at the top of the Audio and MIDI Regions List.

Sort attributes for audio regions

MIDI regions can be sorted by name, length, or timestamp. In addition to these, audio regions can be sorted by region start and end times, various attributes of the source audio file, disk name, and track format.

2. From the Regions List pop-up menu, select Ascending or Descending to switch the order of the displayed regions.

Figure 13. Regions located with Find command

To return the Regions List to displaying all regions:

- Choose Display All from the Regions List pop-up menu.
Selecting in the Region Lists

In the Regions Lists you can select multiple regions so they can be dragged to tracks, or processed with AudioSuite plug-ins.

To select a range of regions in a Regions List:

- Move the cursor to the left of the region names, so the Marquee appears, and drag around the regions you want to select.

- or -

- Shift-click, to the left of the region names, the first and last region you want to select. All regions between become selected.

To select discontiguous regions in the Regions List:

1. Move the cursor to the left of the region names, so the Marquee appears.
2. Command-click each region you want to select.

- or -

1. Move the cursor over the region names.
2. Shift-click each region name you want to select.

Keyboard Selection of Regions

If the Audio Regions Focus or MIDI Regions Focus is enabled, you can type the first few letters of a region’s name and Pro Tools will automatically locate and select the region in the Regions List.

To enable and use the Audio Regions List Key Focus or MIDI Regions List Key Focus:

1. Click the a-z button in upper right of the Audio Regions List or MIDI Regions List.

Keyboard selection of audio regions locates regions based on their region name, not on the names for their parent audio files or the volumes on which they reside.

Stereo and Multichannel Tracks in the Audio Regions List

Stereo and multichannel regions, whether imported or recorded into Pro Tools, are displayed as single items in the Audio Regions List. For example, two mono source regions named “Main Piano.L” and “Main Piano.R” are listed as “Main Piano (Stereo).” A collapse/expand triangle indicates stereo and multichannel regions.
Stereo and multichannel regions are displayed in the Regions List by default in collapsed view. The individual regions can be displayed by clicking the arrow to the left of the region to expand the name.

To expand or collapse all stereo and multichannel regions:
- Press Option (Macintosh) or Alt (Windows) while clicking the triangle.

Individual items of an expanded-view stereo or multichannel region can be selected independently of the other associated regions in the Audio Regions List.

**Rules for Stereo and Multichannel Regions**

For stereo and multichannel regions to be shown as collective regions, the component regions must be the same length. If an existing stereo or multichannel region has been dragged onto multiple mono tracks and edited such that one or more components are no longer the same length, the stereo display is removed and the regions are displayed as individual regions in the Regions List.

**Selecting Files in DigiBase Browsers**

For information on selecting items in DigiBase, see the *DigiBase Guide*.

---

**Edit Modes**

Pro Tools has four Edit modes: Shuffle, Spot, Slip, and Grid. (Grid mode actually provides two modes of operation: Relative and Absolute, explained below). The Edit mode is selected by clicking the desired button in the upper left of the Edit window.

The Edit mode affects the movement and placement of audio and MIDI regions (and individual MIDI notes), how commands like Copy and Paste function, and also how the various edit tools (Trimmer, Selector, Grabber, and Pencil) work.

**Shuffle**

In Shuffle mode, you can move regions freely within a track or to other tracks, but their movement is constrained by other regions. That is, if you place several regions in a track, they automatically snap to each other. You can then “shuffle” their order, but you cannot separate them from each other and you cannot make them overlap as in Slip mode. In Shuffle mode, adding another region to the beginning of a track moves all subsequent regions to the right by the length of the region added.

When using the Trimmer in Shuffle mode, changing a region’s start or end point automatically moves the adjacent regions as necessary. The placement and insertion of MIDI notes is not affected by Shuffle mode.
Slip

In Slip mode, regions can be moved freely within a track or to other tracks. In this mode it is possible to place a region so that there is space between it and other regions in a track. When the track is played back, this space is silent. It is also possible to move a region so that it overlaps or completely covers another region.

Use Slip mode when you want the Trimmer, Selector, Grabber, and Pencil tools to work without any restrictions to placement in time.

Spot

Use Spot mode to place regions at precise locations. In Spot mode you can specify a frame location (or a location based on any of the other time formats), capture an incoming Time Code address, or use a region’s time stamps as reference points for spotting. This can be particularly useful when performing post production tasks around SMPTE frame locations.

When Spot mode is enabled, Pro Tools asks you to specify a destination location when a region is dragged from either of the Regions Lists, or from a supported DigiBase browser.

Grid

In Grid mode, regions and MIDI notes that are moved or inserted “snap” to, or by, a user-definable time grid. Grid mode can be used in two different operating modes:

Absolute Grid Mode Snaps material (or selections) cleanly to the grid.

Relative Grid Mode Moves regions by the current grid unit. Relative mode is best when working with regions that fall between Grid boundaries.

⚠️ Relative Grid mode is only available in Pro Tools 6.0 and later.

To choose a Grid mode:

1. Click the Grid mode button in the Edit window tool bar, and choose Absolute or Relative from the pop-up menu.

⚠️ To temporarily disable Grid mode and switch to Slip mode while dragging a region, hold down the Command key (Macintosh) or Control key (Windows).

For more information on Relative Grid mode, see “Sliding Regions in Grid Mode” on page 252.

Configuring the Grid

The actual Grid size, chosen from the Grid Value pop-up can be based on a time value using the Main Time Scale; or, if Follow Main Time Scale is deselected, another time format can be used for the Grid size.
In Pro Tools 6.0 and higher, the Grid Value selector is located in the Edit window Options bar.

Selecting the Grid Value (Pro Tools 6.0)

In prior versions of Pro Tools, the Grid Value selector is located in the upper right of the Edit window,

Selecting the Grid Value (Pro Tools 5.x)

The current Grid value is also used for the Quantize Regions Command. For information, see “Quantizing Regions” on page 256.

Also available in the Grid Value pop-up is an option for Regions/Markers. When selected, events can be placed freely (as in Slip mode) but will snap to region locations (start, end, and sync points), Markers, and Edit selections when placed near them.

MIDI notes inserted with the Pencil tool ignore the Regions/Markers option, and instead snap to the time value selected in the Grid Value pop-up.

To display the Grid lines in the Edit window:

- Choose Setups > Preferences > Display then enable Draw Grids in Edit Window.

Turning on Grid lines from Edit Window

- or -

- Enable (and disable) Grid lines by Control-clicking (Macintosh) or Alt-clicking (Windows) any Timebase Ruler.

Turning on Grid lines from Ruler (Pro Tools 6.0)

Turning on Grid lines from Ruler (Pro Tools 5.x)

For more information on Grid options, see “Sliding Regions” on page 249.
**Zooming**

Zooming options in Pro Tools include the Horizontal and Vertical Zoom buttons, the Zoomer tool, and the Zoom Preset buttons.

**Horizontal and Vertical Zoom Buttons**

Use the Horizontal and Vertical Zoom buttons to zoom in and out on track data. Unlike the horizontal zoom value, the vertical zoom value for MIDI and audio tracks are independent, and therefore have separate buttons.

**To zoom in horizontally for all tracks:**

- Click the right Horizontal Zoom button. To zoom out, click the other (left) Horizontal Zoom button.
- or –
- Press Command+] (Macintosh) or Control+] (Windows). To zoom out, press Command+ [ (Macintosh) or Control+ [ (Windows).
- or –
- Click and drag on the Horizontal Zoom button to zoom continuously.

**To zoom in vertically for all audio tracks:**

- Click the (top) Vertical Zoom button with the audio waveform. To zoom out, click the bottom Vertical Zoom button.
- or –
- Press Command+Option+] (Macintosh) or Control+Alt+] (Windows). To zoom out, press Command+Option+ [ (Macintosh) or Control+Alt+ [ (Windows).
- or –
- Click and drag on the Vertical Zoom button to zoom continuously.

**To zoom in vertically for all MIDI tracks:**

- Click the (top) Vertical Zoom button with the MIDI notes. To zoom out, click the bottom Vertical Zoom button.
- or –
- Press Command+Shift+] (Macintosh) or Control+Shift+] (Windows). To zoom out, press Command+Shift+ [ (Macintosh) or Control+Shift+ [ (Windows).

**To return to the previous zoom level:**

- Option-click (Macintosh) or Alt-click (Windows) any of the Horizontal or Vertical Zoom buttons.
- or –
- Press Command+Option+E (Macintosh) or Control+Alt+E (Windows).

**To zoom in on a selection:**

- Press Option+F (Macintosh) or Alt+F (Windows).
To zoom so that all regions are visible in the Edit window, do one of the following:

- Double-click the Zoomer tool in the toolbar.
- Press Option+A (Macintosh) or Alt+A (Windows).

**Zoomer Tool**

Use the Zoomer tool to zoom in and out around a particular area within a track. The Zoomer tool offers two modes: Normal, and Single Zoom mode.

- In Normal Zoom mode, the Zoomer tool remains selected after zooming.
- In Single Zoom mode, the previously selected tool is automatically reselected after zooming.

**Normal Zoomer Tool**

To zoom around a certain track point:

1. Select the Zoomer tool.

2. Click once with the Zoomer at the point within the track. All tracks are zoomed in by one level and the Edit window is centered around the zoomed point.

3. To zoom back to the previous level, Option-click (Macintosh) or Alt-click (Windows) with the Zoomer.

**To zoom into a particular track area:**

1. Select the Zoomer tool.

2. To zoom horizontally, drag with the Zoomer in the track’s playlist.

   - or -

   To zoom horizontally and vertically, press Command (Macintosh) or Control (Windows) while dragging in the track’s playlist.

To zoom horizontally with Zoomer tool

The zoomed area fills the entire Edit window.

**Single Zoom Mode**

The Single Zoom mode option returns you to the previously selected tool after a zoom has been performed.

For example, when using the Smart Tool you can click on the Single Zoom Tool mode and once the Zoom operation has been performed, Pro Tools automatically switches back to the Smart Tool.

**To use Single Zoom mode:**

- Click on the Zoom tool to toggle between Normal and Single Zoom modes.

Single Zoom is identified with an arrow to the right of the Zoomer Tool icon.
Normal Zoom mode doesn’t have the arrow.

Zooming in the Ruler

To zoom horizontally in the Ruler:

1. Press Command+Control (Macintosh) or Control+Alt (Windows) and move the cursor into the Ruler area, so the Zoomer appears.

2. Click once to zoom in one level around a certain point.
   – or –

Drag to zoom in around a particular Ruler range.

Zoom Preset Buttons

Pro Tools lets you save up to 5 horizontal Edit window Zoom presets, which can be recalled by typing a number or by clicking a Zoom Preset button.

To store a zoom preset:

1. Using either the Horizontal Zoom buttons or the Zoomer tool, navigate to the zoom level you want to store.

2. While pressing Command (Macintosh) or Control (Windows), click one of the five Zoom Preset buttons.

Zoom Toggle

The Zoom Toggle command lets you zoom in and increase the current track's height and zoom level with one keystroke.

To use Zoom Toggle:

1. Make a selection on one or more tracks.

2. Press Control+E (Macintosh) or Start+E (Windows).
   – or –

With Commands Focus enabled, press E.

The selection is zoomed to fill the Edit window, and the tracks containing the selection are set to a Track Height of Large. MIDI tracks automatically change to Notes view.

- The button flashes, indicating it is being written to, and then becomes selected.

- Horizontal zoom levels for all tracks are recalled.

- Zoom settings can also be stored with Memory Locations. For details, see “Managing Regions” on page 286.
Setting a Default Zoom Toggle Track Height

Zoom Toggle provides single-key toggling between the current track zoom setting and the default (Large) track height. You can change the default height for toggled tracks in the Display preferences.

To set a default Zoom Toggle Track Height:

1. Choose Setups > Preferences.
2. In the Display pane, select a default from the Zoom Toggle Track Height selector.

The Universe Window

(TDM Systems Only)

The Universe window displays an overview of the entire session, representing audio and MIDI material on all tracks that are not hidden (including tracks that are inactive, or that contain offline regions). The order in which material is displayed in the Universe window corresponds to the track order in the Edit window.

To open the Universe window:

- Choose Windows > Show Universe.

Audio material residing in audio tracks is represented by a single, horizontal line in the Universe window. Each channel in a stereo or multichannel track is represented individually.

Since Auxiliary Input and Master Fader tracks do not contain audio, they are displayed as blank areas in the Universe window.

Similar to audio tracks, MIDI tracks containing note material are represented by single, horizontal lines.

Resizing the Universe Window

Even though the Universe window can be resized horizontally and vertically, the length of the entire session is always displayed in the Universe window. If the Universe window is resized so some of the session’s track are not displayed, a vertical scroll bar becomes available.

Highlighted Material in the Universe Window

The highlighted, shaded area in the Universe window represents the material displayed in the Edit window. If you change what’s displayed in the Edit window—by zooming, scrolling horizontally or vertically, hiding or unhiding tracks, or changing track heights—the highlighted area in the Universe window updates.
During playback, if the Edit window is set to scroll, the highlighted area in the Universe window also scrolls.

**Scrolling in the Universe Window**

By clicking in the Universe window, you can automatically scroll, either horizontally or vertically, the material displayed in the Edit window. This provides a convenient method of locating anywhere in the session, or adjusting which shown tracks are visible in the Edit window.

**To move the highlighted area in the Universe window:**

1. Choose Windows > Show Universe.
2. To affect which tracks are displayed in the Edit window, click lower or higher (vertically) in the Universe window.
3. To scroll to a different session location, click later or earlier (horizontally) in the Universe window.

When all tracks are visible in the Edit window and the session is zoomed all the way out, with all regions visible, the entire Universe window is shaded.

**Timebase Rulers**

Any or all of the following Timebase Rulers can be displayed at the top of the Edit window:

- Bars:Beats
- Minutes:Seconds
- Time Code (TDM systems only)
- Feet,Frames (TDM systems only)
- Samples

In addition to providing a timing reference for track material, the Timebase Rulers are also used to define Edit selections for track material, and Timeline selections for record and play ranges.

💡 With the Selector, drag in any Timebase Ruler to select material across all tracks in the Edit window. To include the Conductor Tracks in the selection, press Option (Macintosh) or Alt (Windows) while dragging.
Any or all of the following Conductor Rulers can be displayed:

- Tempo
- Meter
- Markers

The Meter and Tempo Rulers indicate changes in meter and tempo within the Session. The Markers Ruler displays Markers to important track locations.

To display all Rulers:
- Select Display > Ruler View Shows > All.

To remove a Ruler from the display:
- Option-click the Ruler’s name (to the left of the Ruler display).
- Deselect the Ruler in Display > Ruler View Shows.

To display only the Main Time Scale in the Ruler:
- Select Display > Ruler View Shows > None.

(See See “Main Time Scale” on page 213.)

To add a specific Ruler to the display, such as the Markers Ruler, for instance:
- Select Display > Ruler View Shows > Markers.

To change the display order for the Rulers:
- Click a Ruler’s name and drag up or down to the new location.

**Ruler Options Pop-up Menu**

The Ruler display options are also available from a pop-up menu.

**Main Time Scale**

While all Timebase Rulers can simultaneously be displayed in the Edit window, there is only one that represents the **Main Time Scale**. The Main Time Scale determines the time format used for:

- The Transport’s Main Counter
- Start, end, and length values
- Pre- and post-roll amounts
- Grid and Nudge values

The Main Time Scale can be set to the following formats:
**Bars:Beats** Displays the Time Scale in bars and beats. Use this Time Scale if you are working with musical material that must align with bars and beats.

To ensure your tracks align with the bars and beats in your session, make sure to record with the click (see “Recording with the Click” on page 146).

Material that is recorded without listening to the click can still be aligned to bar and beat boundaries in Pro Tools with the Identify Beat command (see “Identify Beat Command” on page 294).

**Minutes:Seconds** Displays the Time Scale in minutes and seconds. As you zoom in farther with the Zoomer, the Time Scale begins to display tenths, hundredths, and thousandths of a second.

**Time Code (TDM Systems Only)** Displays the Time Scale in SMPTE frames. The Frame Rate and Session Start time are set from the Session Setup window. Pro Tools supports the following frame rates: 24, 25, 29.97 Non-Drop, 29.97 Drop, 30 Non-Drop, and 30 Drop frames per second.

**Feet.Frames (TDM Systems Only)** Displays the Time Scale in feet and frames for referencing audio-for-film projects. The Feet.Frames time display is based on the 35 millimeter film format.

With this Time Scale, you can enter a Start Frame based on an appropriate frame location at the beginning of your project tape. The Feet.Frames Ruler will then use this value as its start reference.

---

**Samples** Displays the Time Scale in samples. This format is very useful for high-precision sample editing.

---

**Setting the Main Time Scale**

**To set the Main Time Scale:**

- Select the desired Time Scale at the bottom of the Display menu.
  - or -

- Select from the Main Time Scale pop-up (also available in the Transport window).

---

**Feet.Frames dialog**

**To set a start frame for a session:**

- Choose Setups > Feet.Frames and enter an appropriate start frame and click OK (negative offsets are not supported). This value will become the “zero point” in the Feet.Frames Ruler.
Chapter 15: Editing Basics

Setting the Sub Time Scale

There is also a Sub Location Indicator displayed below the Main Location Indicator, and below the Transport's Main Counter, which provides an additional timing reference.

To set the Time Scale for the Sub Location Indicator:

- Select from the Sub Time Scale pop-up next to the Location Indicator
  - or -
- Select from the Sub Time Scale pop-up in the Transport Window.

Tick-Based Timing

Pro Tools is a sample-based program with an internal MIDI resolution of 960,000 pulses per quarter note (ppq). However, when the Time Scale is set to Bars:Beats, the display resolution in Pro Tools is 960 ppq.

In Bars:Beats, Pro Tools is tick-based (960 ticks to a quarter note), which means that some amount of sample-rounding may occur when placing events at certain locations (see “Sample Rounding and Edit Operations” on page 216).

When working in Bars:Beats, you’ll often want to specify tick values for a number of operations, including:

- Placing and spotting regions
- Setting lengths for regions or MIDI notes
- Locating and setting play and record ranges (including pre/post-roll)
- Specifying parameters in the Quantize and Change Duration windows
- Setting the Grid and Nudge values
The following table lists the number of ticks for each of the main note sizes:

<table>
<thead>
<tr>
<th>Note Value</th>
<th>Normal</th>
<th>Dotted</th>
<th>Triplet</th>
</tr>
</thead>
<tbody>
<tr>
<td>1/2 note</td>
<td>1920</td>
<td>2880</td>
<td>1280</td>
</tr>
<tr>
<td>1/4 note</td>
<td>960</td>
<td>1440</td>
<td>640</td>
</tr>
<tr>
<td>1/8 note</td>
<td>480</td>
<td>720</td>
<td>320</td>
</tr>
<tr>
<td>1/16 note</td>
<td>240</td>
<td>360</td>
<td>160</td>
</tr>
<tr>
<td>1/32 note</td>
<td>120</td>
<td>180</td>
<td>80</td>
</tr>
<tr>
<td>1/64 note</td>
<td>60</td>
<td>90</td>
<td>40</td>
</tr>
</tbody>
</table>

**Ticks vs. Samples**

Audio material in Pro Tools is sample-based. This means that if an audio region is located at a particular sample (or SMPTE) location, it will not move from this location if the tempo changes in the session (though the audio region’s bar and beat location will change).

MIDI data in Pro Tools is tick-based. This means that if a MIDI region is located at a particular bar and beat location, it will not move from that location if the tempo changes in the session—though its sample location will change, thereby adjusting its relationship to audio.

When creating Markers and Selection Memory Locations, you can specify whether they have an Absolute (sample-based) or Bar|Beat (tick-based) reference. For more information, see “Bar|Beat and Absolute Reference” on page 301.

**Sample Rounding and Edit Operations**

Because audio material in Pro Tools is sample-based, some amount of sample-rounding may occur with some edits when the Main Time Scale is set to Bars:Beats. This is most evident when you need audio regions to fall cleanly on the beat (as when looping) and notice that the material is sometimes a tick or two off. With a few simple precautions, this can be avoided.

When selecting audio regions to be copied, duplicated, or repeated, make sure to select the material with the Selector (enable Grid mode for precise selections), or set the selection range by typing in the start and end points in the Event Edit area. Do not select the material with the Grabber (or by double-clicking with the Selector). This ensures that the selection will be precise in terms of bars and beats (and not based on the length of the material in samples).
Playing Tracks

After recording or importing to tracks, you’ll want to listen to the material to find track ranges that require editing, or material that can be turned into regions for use elsewhere.

To set where playback begins, you can click anywhere in a track with the Selector tool (as long as the Edit and Timeline selections are linked, see “Separate Edit and Timeline Selections” on page 223).

Depending on the selected Scrolling Option, the playback cursor, a solid unblinking line, moves across the Edit window to indicate the current playback position. The playback location is displayed in the Counters in the Transport window, in the Big Time window, and also in the Location Indicators.

The edit cursor, on the other hand, is a flashing line that appears when you click with the Selector in a track's playlist. The blinking edit cursor indicates the start point for any editing tasks performed. If you make a selection and perform an edit, the selection is the target of the edit.

To begin playing from a specific point within a track:

1. Select Operations > Scrolling Options > No Auto Scrolling.
2. Make sure to select Operations > Link Edit and Timeline Selection.
3. With the Selector, click in the track where you want playback to begin.
4. Click Play in the Transport window to begin playback.
5. Click Stop in the Transport window to stop playback.

To jump to a different location and begin playing from there, click with the Selector at that point and click Play in the Transport window.
With the Edit and Timeline selections linked, you can click a region or MIDI note with the Grabber to automatically update the Timeline with the selection’s start time, allowing you to easily play from that point.

**Page Scroll During Playback**

You can set Pro Tools to scroll the track display while playing, and also have the edit cursor appear wherever playback stops.

To make the track display and the edit cursor follow playback:

1. Select Operations > Scrolling Options > Page Scroll During Playback.
2. Choose Setups > Preferences. In the Operation page of the Preferences dialog, select the option for “Timeline Insertion Follows Playback,” then click Done.
3. Make sure to select Operations > Link Edit and Timeline Selection.
4. With the Selector, click in the track where you want playback to begin.
5. Click Play in the Transport window to begin playback. The playback cursor scrolls across the Edit window, indicating the current playback position.
6. Click Stop in the Transport window to stop playback. The edit cursor appears at the location where playback stops.

**Locating and Auditioning with Fast Forward/Rewind**

You can use the Fast Forward and Rewind buttons in the Transport window to locate material in your tracks. If the Operation Preference for “Audio During Fast Forward/Rewind” is selected, you’ll actually hear the scanned audio (similar to a CD player) when clicking the Fast Forward and Rewind buttons.

You can also fast forward or rewind incrementally by repeatedly clicking the appropriate button. The size of these increments is determined by the Main Time Scale:
- Bars:Beats: moves to the beginning of the previous or next bar.
- Min:Sec: moves back or forward in one-second steps.
- Time Code: moves back or forward in one-second steps (while adjusting for current SMPTE format).
- Feet.Frames: moves back or forward in one-foot steps.
- Samples: moves back or forward in one-second steps.

**Location Indicators**

The Location Indicators, in the upper portion of the Edit window, display the current playback location, and also provide a convenient way to navigate to a specific time location.
The Main Location Indicator displays the playback location in the time format for the Main Time Scale. The Sub Location Indicator can be set to any of the other Time Scale formats for another timing reference. Both the Main and Sub indicators also appear in the Transport window when it is set to display Counters.

To navigate with the Location Indicators:

1. Click in one of the Location Indicators.
   - or -
2. Press Equal (=) on the numeric keypad to highlight the Main Location Indicator (or the Transport Counters or Big Time window, if either are displayed).
3. Type in the new location. Press period (.) to cycle through to the different time fields.
4. Press Enter to accept the new value and automatically locate there.

Select the time format from the pop-up menus next to the Main and Sub indicators in either the Edit or Transport window.

Scrolling in the Ruler

You can scroll the contents of the Edit window by clicking and dragging in the Ruler. While this doesn’t actually update the session’s Current Location, it does let you conveniently shift the display left or right for the sake of finding and editing material.

This method of scrolling is especially useful when using Continuous Scroll With Playhead (TDM systems only), which does not update or follow Timeline selections.

To scroll the entire contents of the Edit window from the Ruler:

- While pressing Command+Option+Control (Macintosh) or Control+Alt+Start (Windows), drag left or right in any of the Timebase Rulers.

Locating the Playback Cursor

(Pro Tools 6.0 Only)

Pro Tools 6.0 introduces the Playback Cursor Locator for locating the playback cursor when it is off-screen. The Playback Cursor Locator will appear on the right edge of the Main Timebase Ruler if the playback cursor is located beyond the time visible in the Edit window. If the playback cursor is located before the time visible in the Edit window, the Playback Cursor Locator will appear on the left edge of the Main Timebase Ruler.

The Playback Cursor Locator is red when a track is record enabled and blue when no track is record enabled.

For example, if the Scrolling Option is set to No Auto-Scrolling, the playback cursor will move off-screen after it has played past the time currently visible in the Edit window. The Playback Cursor Locator will then indicate the location of the playback cursor.

---

*Chapter 16: Playing and Selecting Track Material*
Cursor Locator will appear on the right edge of the Main Timebase Ruler after the playback cursor moves beyond the time visible in the Edit window.

**To locate the playback cursor when it is off-screen:**

- Click the Playback Cursor Locator in the Main Timebase Ruler.

The Edit window will change to center the playback cursor on-screen.

### Scrolling Options

Pro Tools offers the following options for how it scrolls the contents of the Edit window during playback and recording. Choose Operations > Scroll Options and select one of the following from the submenu:

- **No Auto-Scrolling** With this scrolling option, the Edit window does not scroll during or after playback. The playback cursor moves across the Edit window, indicating the playback location.

- **Scroll After Playback** Causes the Edit window to scroll to the final playback location after playback has stopped. In this mode, the playback cursor moves across the Edit window, indicating the playback location.

- **Page Scroll During Playback** Causes the Edit window to scroll during playback. With this option, the playback cursor moves across the Edit window, indicating the playback location. When the right edge of the Edit window is reached, its entire contents are scrolled, and the playback cursor continues moving from the left edge of the window.

**Continuous Scroll During Playback**

(TDM Systems Only)

This scrolling option causes the Edit window's contents to scroll continuously past the playback cursor, which remains in the center of the window. With this option, playback is always based on the Timeline selection (unlike Continuous Scroll With Playhead).

**Continuous Scroll With Playhead**

(TDM Systems Only)

This scrolling option causes the Edit window's contents to scroll continuously past the **Playhead**, which is a blue line in the center of the window (red when recording).

The Playhead indicates where playback begins when clicking Play in the Transport window.

In Pro Tools 6.0, making a selection or editing with the mouse in the Timeline or a playlist as the playback cursor moves off-screen, or manually scrolling the Timeline while in Page Scroll or Continuous Scroll mode will suspend page scrolling. To resume page scrolling and jump to the current playback location, click the Playback Cursor Locator in the Main Timebase ruler (see “Locating the Playback Cursor” on page 219).
To move the Playhead to a particular location for playback, you can scroll there in the Ruler (see “Scrolling in the Ruler” on page 219), use the Edit window’s horizontal scroll bar, or type the location into one of the Location Indicators or one of the Counters.

Moving the Playhead with these methods does not update the Timeline selection. However, updating the Timeline selection automatically moves the Playhead to the Timeline insertion point.

With the Playhead enabled, you can jump to and play an Edit or Timeline selection. For details, see “Playing Edit and Timeline Selections with the Playhead” on page 236.

**Half-Screen Edit Window**

When either Continuous Scroll During Playback or Continuous Scroll With Playhead is enabled, a half-screen appears at the far left of the Edit window (before the beginning of the session).

While viewing an audio waveform in Pro Tools can be helpful in visually finding an edit point, sometimes a waveform display (because of its sonic characteristics) may not reveal the desired spot in the audio material. By scrubbing back and forth over an edit point in Pro Tools, you can listen and zero in on the exact edit point you’re looking for.

When the Operation Preference for “Edit Insertion Follows Scrub/Shuttle” is enabled, the edit cursor automatically locates to the point where scrubbing stops.

When the Scrolling Option is set to Continuous Scroll During Playback or Continuous Scroll With Playhead, clicking with the Scrubber in a track’s playlist centers the Edit window around that point, and moves the Playhead there. With these Scrolling Options, scrubbed material moves past the Playhead, which remains stationary and centered.

*Scrubbing is only supported for audio tracks. MIDI tracks cannot be scrubbed.*

**To scrub a single audio track:**

1. With the Scrubber selected, drag within the track—left for reverse, right for forward.

### The Scrubber

The Scrubber lets you “scrub” up to two tracks of audio in the Edit Window. Scrubbing is a technique that originated in tape editing, where the tape was rocked back and forth past the playhead at slower than normal speeds to find a particular location (usually for the sake of performing splices).
The resolution for the Scrubber is dependent upon the zoom factor for the scrubbed track. For finer resolutions without zooming, press Command (Macintosh) or Control (Windows) while scrubbing.

⚠️ You can temporarily switch the Selector to the Scrubber by Control-clicking (Macintosh) or Right-clicking (Windows). For finer resolution, Command-Control-click (Macintosh) or Control-Right-click (Windows).

To scrub up to two audio tracks:

- With the Scrubber selected, drag between two adjacent tracks.

  Scrubbing between two audio tracks

  – or –

- Scrub within a selection that contains multiple tracks. Only the first two tracks are heard.

⚠️ The maximum number of channels scrubbed in Pro Tools is eight, which would allow you to scrub two stereo tracks (four channels), but not two 5.1 surround tracks (12 channels).

Scrubb/Shuttle Mode

When scrubbing normally, you can scrub at normal playback speeds or slower. Scrub/Shuttle mode, however, lets you scrub at several times normal speed, which is helpful in playing through large ranges and locating material.

To scrub in Shuttle mode (at several times normal speed):

1. Select the Scrubber tool.

2. While pressing Option (Macintosh) or Alt (Windows), drag within the track—left for reverse, right for forward. The Fast Forward and Rewind buttons in the Transport window engage.

The distance and speed dragged determine the speed for the scrubbed audio.

Shuttle Lock Mode

Shuttle Lock mode lets you trigger playback for up to two tracks at varying speeds, forward and reverse, from the numeric keypad. If multiple tracks are selected, only the first two tracks are shuttled.

To play one or two tracks with the shuttle lock:

1. For TDM systems, make sure the Operation Preference for Numeric Keypad Mode is not set to Shuttle.

2. With the Selector, click in the track where you want playback to begin. To shuttle on two tracks, Shift-click in a second track.

3. Press Control (Macintosh) or the Start key (Windows) and a number on the numeric keypad: 0–9 (9 is fastest, 5 is normal speed, and 0 stops shuttling).

Once Shuttle Lock mode is initiated, Fast Forward and Rewind become highlighted in the Transport window.

4. Press additional keys to change the playback speed, or press Plus (+) and Minus (–) to switch the playback direction (plus for forward, minus for backward).

5. To stop playback, press Control+0 (Macintosh) or Start+0 (Windows).
To exit Shuttle Lock mode:
- Press Stop in the Transport window.
- or –
- Press the spacebar.

**Numeric Keypad Set to Shuttle**
(TDM Systems Only)

Pro Tools offers another form of shuttling, different from that of Shuttle Lock mode. With the Numeric Keypad Mode set to Shuttle, playback of the current Edit selection is triggered by pressing and holding the keys on the numeric keypad—playback stops once the keys are released. Various playback speeds are available in both forward and reverse. In this mode, pre/post-roll are ignored.

**To shuttle with the Numeric Keypad Mode set to Shuttle:**
1. Choose Setups > Preferences and click Operations.
2. Set the Numeric Keypad Mode to Shuttle and click Done.
3. With the Selector, click in the track where you want playback to begin. To shuttle on two tracks, Shift-click in a second track.
4. Press and hold any of the following keys (or key combinations) on the numeric keypad to trigger playback.

<table>
<thead>
<tr>
<th>Shuttle Speed</th>
<th>Rewind Key</th>
<th>Forward Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 X Speed</td>
<td>4</td>
<td>6</td>
</tr>
<tr>
<td>4 X Speed</td>
<td>7</td>
<td>9</td>
</tr>
<tr>
<td>1/4 X Speed</td>
<td>1</td>
<td>3</td>
</tr>
<tr>
<td>1/2 X Speed</td>
<td>4+5</td>
<td>5+6</td>
</tr>
<tr>
<td>2 X Speed</td>
<td>7+8</td>
<td>8+9</td>
</tr>
</tbody>
</table>

5. Press a different key to switch the playback direction or speed. Release to stop.

---

**Separate Edit and Timeline Selections**

Pro Tools lets you unlink the Edit and Timeline selections. In doing so, you can make a selection within a track for editing purposes that is distinct from the selection in the Timeline (which determines the playback and recording range).

By default, the Edit and Timeline selections are linked. In this mode, selecting in a track’s playlist (an Edit selection) also defines the play and record range (the Timeline selection).

**To unlink the Edit and Timeline selections:**
- Deselect Operations > Link Edit and Timeline Selection.
- or –
- In the upper left of the Edit window, click the Link Selection button so it becomes unhighlighted.

---

If you are working with a film or video scene, you may want to unlink the Edit and Timeline selections to work with material that is at a different location than the current play range. The scene you’re working with (defined by the Timeline selection) may require some sound effects and you can go to another location in the session to find and audition them. Edit selections...
can be played (choose Operations > Play Edit Selection) without disrupting the current Timeline selection. Once the desired material is found, you can then go back to the Timeline selection and place them within the context of the scene.

Figure 14 illustrates another reason you’d want to unlink the Edit and Timeline selections. In this example, the Timeline selection sets a range to be looped on playback, while a MIDI region (residing within the loop) is selected for editing purposes. During playback, the Edit selection can be nudged, quantized, or transposed while the loop plays back completely independent and uninterrupted.

While you could theoretically do this with the Edit and Timeline selections linked, as soon as playback is stopped, the playback range would then be updated to that of the more recent edit range.

**Playback/Edit Markers**

Timeline selections are displayed in the Ruler with Playback Markers, which appear as blue arrows (red when recording). In addition, there are Pre- and Post-Roll Flags (which are green when enabled) indicating the location for pre/post-roll.

When the Edit and Timeline selections are unlinked, Edit selections are displayed in the Ruler with Edit Markers, which appear as black brackets.

If the Edit and Timeline selections are linked, Edit selections are represented by the blue Playback Markers.

See the following sections for details on working with Edit and Timeline selections:
- “Selecting Track Material” on page 224
- “Timeline Selections” on page 235
- “Setting Punch/Loop Points” on page 162
- “Setting Pre/Post-Roll” on page 164

**Selecting Track Material**

Before audio and MIDI material can be edited, it must first be selected. A track's Display Format determines how the material is viewed and selected.

When you make a selection, it appears as a highlighted area of the tracks, and is also indicated by blue start and end arrows (Playback Markers) in the Ruler at the top of the Edit window. If any track (audio or MIDI) in the session is record-enabled, even if it is hidden, these markers appear red.

If the Edit and Timeline selections are unlinked, the Edit selection range is indicated by Edit Markers in the Ruler. See “Separate Edit and Timeline Selections” on page 223 for details.
**Selections and Edit Groups**

When making selections on tracks that are part of an Edit Group, all tracks within the group become selected.

**Selections and Hidden Tracks**

When editing tracks that are part of an active Edit Group, any tracks within the group that are hidden are not affected by the edits. To edit all members of a group, make sure they are visible by highlighting their names in the Show/Hide Tracks List.

**Selections in Multiple Tracks**

To make a selection in multiple tracks:

1. With the Selector, click and drag horizontally to include adjacent tracks in a selection (drag vertically to define the time range).

**Selecting Regions**

To select a portion of a region:

1. With the Selector, drag within a region (left or right) to select the material on a single track. (You can also use the Selector across multiple, adjacent tracks to make multitrack selections.)

![Selecting a portion of a region](image)

To select an entire region:

- Click the region with the Grabber.
  - or -
- Double-click the region with the Selector.

To select two regions and the time range between them:

1. With the Grabber, click the first region.
2. Shift-click the second region. Both regions become selected, along with the time range between them (including any other regions).

**To select an entire track:**

- Click in the track with the Selector and then choose Edit > Select All.
  - or -
- Triple-click in the track with the Selector.

**To select all regions in all tracks:**

1. Select the “All” Edit Group in the Groups List.
2. Click in any track with the Selector and choose Edit > Select All.
  - or -
Triple-click with the Selector in any track.

**Selecting All from Timebase Rulers**

To select all material in all displayed audio and MIDI tracks:

1. Make sure the Edit and Timeline selections are linked.
2. Double-click in any Timebase Ruler. All regions in all displayed audio and MIDI tracks are selected. Tracks that are hidden are not selected.

To select all material in all tracks, along with Conductor events:

1. Make sure the Edit and Timeline selections are linked.
2. While pressing Option (Macintosh) or Control (Windows), double-click in any Timebase Ruler. All regions in all displayed audio and MIDI tracks are selected, along with all events in each of the Conductor tracks.

**Making Selections While Playing**

Pro Tools lets you make on-the-fly selections with the arrow keys.

**To make a selection while playing:**

1. Make sure to select Operations > Link Edit and Timeline selection.
2. With the Selector, click somewhere near the beginning of the track in which you want to make the selection.
3. Click Play in the Transport window to begin playback.
4. When playback reaches the point where you want the selection to begin, press the Down Arrow key.
5. Press the Up Arrow key at the point where you want the selection to end. The selected range becomes highlighted.
6. To stop playback, click Stop in the Transport window.

To automatically scroll to the beginning of the selection (or to the location of the on-screen cursor), press the Left Arrow key. To scroll to the end of the selection, press the Right Arrow key.

In Pro Tools 6.0, while in Page Scroll or Continuous Scroll mode, making a selection in the Timeline or a playlist during playback as the playback cursor moves off-screen will suspend page scrolling. To resume page scrolling and jump to the current playback location, click the Playback Cursor Locator in the Main Timebase ruler (see “Locating the Playback Cursor” on page 219).

**Object Selections (TDM Systems Only)**

You can use the Object Grabber to select non-contiguous regions on one or more tracks. Non-contiguous selections must encompass entire regions. If you want a non-contiguous selection to include a portion of a region, first turn the portion into a new region with the Separation Grabber (see “Separation Grabber” on page 241) or the Separate Region command (see “Separate Region Command” on page 239).

*The Object Grabber is not available when the Edit mode is set to Shuffle or Spot.*

**To select non-contiguous regions:**

1. Make sure the Edit mode is set to either Slip or Grid.
2. Choose the Object Grabber from the Grabber tool pop-up menu.

3. Shift-click each region you want to include in the selection. The regions can even reside on different tracks.

In Pro Tools 6.0, while in Page Scroll or Continuous Scroll mode, making a selection in the Timeline or a playlist during playback as the playback cursor moves off-screen will suspend page scrolling. To resume page scrolling and jump to the current playback location, click the Playback Cursor Locator in the Main Timebase ruler (see “Locating the Playback Cursor” on page 219).

**Object Grabber**

Each clicked region becomes surrounded by a dark rectangle, indicating it is selected.
The Object Grabber ignores Edit Groups when making selections. For instance, selecting a region on a grouped track does not cause regions in the other tracks in the group to become selected.

**Object to Time Selection (TDM Systems Only)**

You can convert between Time- and Object-based selections. Time selections are made with the Selector and Time Grabber. Object selections are made with the Object Grabber.

Converting to an Object selection is useful when you are working with large selections, especially across multiple tracks, and you want to remove certain regions from the selection.

Converting to a Time selection is useful if you want to select all regions between a non-contiguous Object selection.

To change a Time selection to an Object selection:

1. Drag with the Selector in any track to define a selection. Select in a Timebase Ruler to select across all tracks.
2. With the Object Grabber selected, double-click the Grabber icon in the toolbar. The regions falling within the selection range become selected as objects. Regions that were partially selected become deselected.

To select regions that were partially selected, press the Control key while double-clicking the Grabber icon.

To change an Object selection to a Time selection:

1. Select any number of regions with the Object Grabber.
2. Double-click the Selector icon in the toolbar. The time range between the first and last region becomes selected.

If using the Object Grabber (TDM systems only), regions on the other tracks in the group are selected if they fall within the range of the selected region.

**Changing a Selection Length**

The selection range can be shortened or lengthened; this does not affect the material within the selection.

To change the length of a selection:

- With the Selector, position the cursor over one end of the current selection and Shift-click or Shift-drag left or right.
- or –
- In the Ruler, drag the Playback Marker for the selection’s start or end point.
If the Edit and Timeline selections are unlinked, drag the Edit Markers (see Figure 15 on page 224) to change the selection length.

**To make a long-length selection:**

1. With the Selector, click at the beginning of the selection.
2. Scroll to the end point of the selection and Shift-click at that point.

To verify the start and end points of a long selection, press the Left Arrow key to scroll to the beginning of the selection, or press the Right Arrow key to scroll to the end.

**Nudging a Selection Range**

The selection range (not the material within the selection) can be moved by the Nudge value.

**To nudge a selection range:**

1. Configure the Nudge value as desired. For details, see “Defining the Nudge Value” on page 253.
2. Make the initial selection with the Selector.
3. While pressing Shift, press Plus (+) or Minus (–) on the numeric keypad to move the selection’s start point by the Nudge value.

   – or –

While pressing Command+Shift (Macintosh) or Control+Shift (Windows), press Plus (+) or Minus (–) on the numeric keypad to move the selection’s end point by the Nudge value.

**Extending Selections**

You can extend selections to region start and end points, to include an adjacent region, or to Markers and Memory Locations.

**To extend a selection to a region start or end point:**

1. With the Selector, select a portion of a region, or click anywhere in the region.
2. Press Shift+Tab to extend the selection to the region’s end point.

   – or –

Press Shift+Option+Tab (Macintosh) or Shift+Control+Tab (Windows) to extend the selection to the region’s start point.

**To extend a selection to include an adjacent region:**

1. Select the first region with the Grabber.
2 Press Shift+Control+Tab (Macintosh) or Shift+Start+Tab (Windows) to extend the selection to include the next region.
   
   – or –

Press Shift+Control+Option+Tab (Macintosh) or Shift+Start+Control+Tab (Windows) to extend the selection to include the previous region.

**To extend a selection to a Marker or Memory Location:**

1 Click in a track with the Selector at the selection’s start or end point.
   
   – or –

Make a selection with the Selector or Grabber.

2 Shift-click a Marker in the Markers Ruler.
   
   – or –

Shift-click a Memory Location in the Memory Locations window.

The selection is extended from the original Insertion point to the Marker or Memory Location.

**Using the Selection Indicators (Start, End, and Length)**

The Selection Indicators at the top of the Edit window can define precise edit selections. Time values for the Selection Indicators use the time format for the Main Time Scale.

![Selection Indicators (Pro Tools 6.0)](image)

**To make a selection with the Selection Indicators:**

1 Click with the Selector in the track you want to select.

2 Click in the Start field at the top of the Edit window.
   
   – or –

Press the slash key to select the Start field.

3 Type in the start point for the selection and press the slash key to enter the value and automatically move to the end field.

4 Type in the end point for the selection and press Enter to accept the value.

**Numeric Entry Shortcuts for Selection Indicators**

You can use the following shortcuts for entering values in the Selection Indicators:

- Press the slash key to cycle through the three Selection Indicators.
- Use period (.) or the Left and Right Arrow keys to move through the different time fields in each Selection Indicator.
- Press the Up or Down Arrow keys to increase or decrease the numerical values.
- Command-drag (Macintosh) or Control-drag (Windows) a selected field to scroll to a new value.
- Press Plus (+) or Minus (–), along with an accompanying number, to add or subtract from the current field value.

For example, to add 10 to a current field value, cycle to the field, press the Plus (+) key, type “10” and then press Enter.

*If using Calculator Entry mode with the Time Scale set to Bars:Beats, see “Calculator Entry Mode” on page 230.*
Press Escape to exit the Selection Indicators without entering any values.

These shortcuts can also be used to enter start and end values in the Transport window.

Calculator Entry Mode

You can perform calculator-style editing of values in the Selection Indicators.

To subtract time values:
1. In the Selection Indicator, highlight the time field you want to change.
2. Press Minus (–) on the numeric keypad.
3. Type the amount you want to subtract from the current time value, then press Enter.
4. Press Enter again to apply the change.

To add time values:
1. In the Selection Indicator, highlight the time field you want to change.
2. Press Plus (+) on the numeric keypad.
3. Type the amount you want to add to the current time value, then press Enter.
4. Press Enter again to apply the change.

Selecting Across Multiple Tracks

To perform edits across multiple tracks or all tracks, you must first select the tracks. Do this by making selections on tracks that are grouped (see “Grouping Tracks” on page 100), by including other tracks in the selection, or by selecting in a Timebase Ruler (for all tracks).

With the Selector, you can drag across multiple tracks to define multitrack selections (click and drag vertically and horizontally). You can also extend a selection to other tracks.

To extend a selection to another track:
1. Using the Selector or Grabber, make a selection in the first track or tracks.
2. Shift-click in additional tracks with the Selector. An identical range is selected for each additional track.

To shorten or lengthen the selection across each of the tracks, press Shift while dragging to change the range of the selection.

To select across all tracks:
1. Enable the All Edit Group and make a selection in any track.
   – or –
2. Drag with the Selector in any Timebase Ruler (make sure the Edit and Timeline Selections are linked).

These selections include all tracks in the Edit window, but do not include the Conductor tracks (for Tempo, Meter, and Markers).

To select across all tracks, including the Conductor tracks (for Tempo, Meter, and Markers):
1. Option-drag (Macintosh) or Alt-drag (Windows) with the Selector in any Timebase Ruler.

Moving and Extending Selections Between Tracks

With Commands Focus enabled, Edit selections can be moved or extended to adjacent tracks.

To move a selection to an adjacent track:
1. Enable the Commands Focus by clicking its button in the upper left of the Edit window.
With the Selector or Grabber, make a track selection.

3 Press P on your computer keyboard to move the selection to the previous track.

– or –
Press semicolon to move the selection to the next track.

In either instance, the original Edit selection becomes deselected.

To extend a selection to an adjacent track:

1 Enable the Commands Focus.

2 With the Selector or Grabber, make a track selection.

3 Press Shift+P to extend the selection to the previous track.

– or –
Press Shift+semicolon to extend the selection to the next track.

In either instance, the original Edit selection remains selected.

To remove the bottom track from a selection:

Press Control+Option+semicolon (Macintosh) or Start+Alt+semicolon (Windows) to remove the bottom track.

Other Useful Selection Techniques

Following are some additional selection techniques.

To position the edit cursor precisely at a region start, end, or sync point:

1 Click with the Selector in the track.

2 Press Tab to move the cursor to the next region start, end, or sync point.

– or –
Press Option+Tab (Macintosh) or Control+Tab (Windows) to move the cursor to the previous region start, end, or sync point.

To make a selection with the Scrubber:

1 Choose Setups > Preferences. In the Operation page of the Preferences dialog, select the option for “Edit Insertion Follows Scrub/Shuttle,” then click Done.

2 Scrub with the Scrubber to find an appropriate start point for the selection, then release.

3 While pressing Shift, scrub to an appropriate end point for the selection, then release. The range between the initial and final scrub becomes selected.

To move a selection to an adjacent region on the same track:

1 Select a region with the Grabber.

2 Press Control+Tab (Macintosh) or Start+Tab (Windows) to move the selection to the next region.

– or –
Press Control+Option+Tab (Macintosh) or Start+Control+Tab (Windows) to move the selection to the previous region.
In either instance, the original region becomes deselected.

**To slide an Edit selection in the Ruler:**

1. With the Selector or Grabber, make a track selection.

2. While pressing Option (Macintosh) or Alt (Windows), move the cursor over either of the Playback Markers in the Ruler (the Grabber appears).

3. Drag left or right to move the Edit selection back or forward in time, while preserving its length.

If the Edit and Timeline selections are unlinked, Option-drag (Macintosh) or Alt-drag (Windows) the Edit Markers instead.

**Tabbing to Transients**

With the Tab to Transients option, you can automatically navigate to transients in audio waveforms, placing the cursor just before the detected transient peak. This allows you to easily define selections and play ranges, as well as start and end points for new regions, without having to zoom in on the waveform.

When Tab to Transients is enabled, the Tabbing function also locates the cursor to region start, end, and sync points.

**To set the start and end points of a selection with Tab to Transients:**

1. In the upper left of the Edit window, click the Tab to Transients button so it becomes selected.

2. If you will be setting the play range with this selection, selection Operations > Link Edit and Timeline Selection.

3. Click in the audio track just before the beginning of the material you want to select.

4. Press Tab repeatedly until the cursor locates to the transient at the start of the selection.

5. Press Shift+Tab until the cursor locates to the end of the selection.

To move the selection end point to the previous transient, press Shift+Option+Tab (Macintosh) or Shift+Control+Tab (Windows).

Once selected, the material can be looped for recording or playback, or it can be turned into a new region with the Separate or Capture command.

> Peak transients are usually visible in the waveform. However, some low-frequency transients may not appear as visible peaks in the waveform.
Region List Selection Follows Track Selection

When the Editing Preference for “Region List Selection Follows Track Selection” is enabled, selecting a region in a track also causes the region to become selected in the Audio or MIDI Regions List.

Conversely, if the Editing Preference for “Track Selection Follows Region List Selection” is enabled, selecting a region in the Audio or MIDI Regions List causes the initial occurrence of that region to become selected within the track.

Playing Selections

Once an Edit selection is made, you can audition the track range by clicking Play in the Transport window. If enabled, the pre- and post-roll amounts play as well.

To play a selection:

1. Make sure to select Operations > Link Edit and Timeline Selection.
2. With the Selector or Grabber, make a track selection.
3. If desired, enable and set the pre- and post-roll amounts. For details, see “Setting Pre/Post-Roll” on page 164.
4. Click Play in the Transport window.

All tracks play for the range of the selection, including pre/post-roll if enabled.

Auditioning Pre- and Post-Roll

You can audition and play just the pre-roll or post-roll material for a selection.

To play from the pre-roll point to the start of a selection, or to the current cursor location:

- Press Option+Left Arrow (Macintosh) or Alt+Left Arrow (Windows).

To play to the post-roll point from the end of a selection, or from the current cursor location:

- Press Command+Right Arrow (Macintosh) or Control+Right Arrow (Windows).

Auditioning Start and End Points for Selections

There may be times when you want to audition the start or end of a selection without hearing the entire selection. This allows you to check, for instance, whether the beginning or end of a selection includes any unwanted clicks or pops.

To audition a selection start point:

- Press Command+Left Arrow (Macintosh) or Control+Left Arrow (Windows).

When auditioning the beginning of a selection, the selection plays from the start point for a duration equal to the post-roll amount.
To audition a selection start point with pre-roll:
  - Press Command+Option+Left Arrow (Macintosh) or Control+Alt+Left Arrow (Windows).

To audition a selection end point:
  - Press Option+Right Arrow (Macintosh) or Alt+Right Arrow (Windows).

When auditioning the end of a selection, playback begins before the end point by the pre-roll amount.

To audition a selection end point with post-roll:
  - Press Command+Option+Right Arrow (Macintosh) or Control+Alt+Right Arrow (Windows).

Looping Playback

When Loop Playback is enabled, the selected track range repeats on playback. If there is no selection, playback occurs normally from the current cursor location.

💡 A selection must be at least 1 second in length for it to loop on playback.

Looping playback is a useful way to check the rhythmic continuity of a selection when working with musical material. If you’re working with one-bar selections, you can loop playback to see if the material loops cleanly. If it seems to skip, you should then adjust the length of the selection until it works “musically” within the context of the playlist and the other tracks.

To loop playback of a selection:

1. Make sure to select Operations > Link Edit and Timeline Selection.
2. With the Selector, select the track range you want to loop.
3. Select Operations > Loop Playback. When enabled, a loop symbol appears in the Play button in the Transport window.

You can also enable Loop Playback by Control-clicking (Macintosh) or Right-clicking (Windows) the Play button in the Transport window. Or, with the Numeric Keypad Mode set to Transport, press 4 on the numeric keypad.

4. Click Play in the Transport window.

Playback begins from the pre-roll point (if enabled) and continues to the selection’s end point, where it loops back to the start point.

5. Click Stop in the Transport window to stop playback.

Loop Playback and Audio Recording

When Loop Playback is enabled, Pro Tools will not loop when attempting to record audio tracks with QuickPunch, Destructive Record, or Nondestructive Record mode.

To loop record audio tracks in Pro Tools, you must enable Loop Record mode.
Timeline Selections

With the Edit and Timeline selections unlinked, selections can be made in the Timeline that are distinct and separate from Edit selections.

With the Edit and Timeline selections linked, any Edit selections that are made are mirrored in the Timeline.

Whether the Edit and Timeline selections are linked or not, the range indicated by the Playback Markers always determines the range for playback and recording.

For TDM systems, when Continuous Scroll With Playhead is enabled, it determines where playback begins. For details, see “Playing Edit and Timeline Selections with the Playhead” on page 236.

To make a Timeline selection with the Selector:

1. If desired, set the Edit mode to Grid to constrain the selection to the current Grid value.
2. Drag with the Selector in any Timebase Ruler.

Making a Timeline selection with the Selector

The Timeline selection is indicated in the Ruler by the blue Playback Markers (red if a track is record-enabled). The start, end, and length for the Timeline selection is displayed in the corresponding fields in the Transport window.

To select all tracks, including Conductor tracks, press Option (Macintosh) or Alt (Windows) while dragging in a Timebase Ruler with the Selector.

To set the Timeline selection by dragging the Playback Markers:

1. If desired, set the Edit mode to Grid to constrain movement to the current Grid value.
2. With the Grabber, drag the first Playback Marker (down arrow) to set the start point.

Dragging a Playback Marker

3. Drag the other Playback Marker (up arrow) to set the end point.

To set the Timeline selection by typing into the Transport window:

1. If necessary, resize the Transport window by clicking in the upper right so the start and end times are displayed.
2. In the Transport window, click in the start field.
   – or –
   Press Option-slash (Macintosh) or Alt-slash (Windows) to select the start field in the Transport window.
3. Type in the new start location and press slash to enter the value and automatically move to the end field.
4. Type in the new end location and press Enter to accept the value.

Shortcuts for entering start and end values in the Transport window are listed in “Numeric Entry Shortcuts for Selection Indicators” on page 229.
Sliding a Timeline Selection

Like Edit selections, Timeline selections can be slid in the Ruler.

To move a Timeline selection in the Ruler:
1. While pressing Option (Macintosh) or Alt (Windows), move the cursor over either of the Playback Markers (the Grabber appears).
2. Drag left or right to move the Timeline selection back or forward in time, while preserving its length.

Timeline Selections to/from Edit Selections

When the Edit and Timeline selections are un-linked, you can copy selections between them.

To copy an Edit selection to the Timeline:
- Choose Operations > Copy Edit Selection to Timeline.

To copy a Timeline selection to an Edit selection:
- Choose Operations > Copy Timeline Selection to Edit.

Playing Edit and Timeline Selections with the Playhead

(TDM Systems Only)

When Continuous Scroll With Playhead is enabled, selections in the Timeline do not determine when playback begins. The Playhead, itself, denotes where playback begins when clicking Play in the Transport.

The Edit and Timeline selections, however, can still be played when the Playhead is enabled.

To play an Edit selection with the Playhead enabled:
1. Deselect Operations > Linked Edit and Timeline Selections.
2. Select Operations > Scroll Options > Continuous Scroll With Playhead.
3. With the Selector or Grabber, make a track selection.

The Playhead jumps to the Edit selection and plays it from beginning to end, and then stops.

To play a Timeline selection with the Playhead enabled:
1. Deselect Operations > Linked Edit and Timeline Selections.
2. Select Operations > Scroll Options > Continuous Scroll With Playhead.
3. Drag with the Selector in any Timebase Ruler to set the play range.

The Playhead jumps to the Timeline selection and plays it from beginning to end, and then stops.
Moving the Playhead

When Continuous Scroll With Playhead is enabled, the Playhead can be moved forward or back to the next region boundary in the selected track.

To move the Playhead through a track's region boundaries:

1. Click in the track with the Selector.
2. Press Tab to move the Playhead forward to the next region boundary.
   – or –
   Press Option+Tab (Macintosh) or Control+Tab (Windows) to move the Playhead back to the previous region boundary.
Chapter 17: Working with Regions and Selections

Because regions are the basic building block of audio and MIDI tracks, understanding how they are created, edited, and arranged is essential to taking full advantage of the editing capabilities of Pro Tools.

This chapter covers basic editing functions as they apply to regions and selections. The material, for the most part, applies to both MIDI and audio data.

For editing procedures more specific to MIDI, see Chapter 23, “MIDI Editing.” For more advanced editing procedures, see Chapter 18, “Advanced Editing.” You should, however, become familiar with the information in this chapter before moving on to the others.

Creating New Regions

Pro Tools provides you with several commands for creating regions, each of them having a slightly different effect on the selection. When you create a new region, it appears in the Regions List and in the track’s playlist. For details on how these new regions are automatically named, see “Auto-Naming Parameters” on page 287.

When creating a new region from an existing region, the original region remains in the Regions List.

Capture Region Command

The Capture Region command defines a selection as a new region and adds it to the Regions List. From there, the new region can be dragged to any existing tracks.

To capture a new region:
1. With the Selector, drag within an existing region to select the material for the new region.
2. Choose Edit > Capture Region.
3. Enter a name for the new region and click OK.

The new region appears in the Regions List. The selected region portion remains intact and unchanged.

Separate Region Command

The Separate Region command defines a selection within an existing region, or a partially selected region, as a new region and separates it from adjacent material. If there is no selection and the Edit cursor is placed within the region, the region is split at the insertion point.
Auto-Name Separated Regions

With the Auto-Name Separated Regions option in the Editing Preferences selected, Pro Tools automatically names separated regions for you. The name is a numbered variation of the original region’s name.

To separate one or more regions:

1. With the Selector, drag to select the material for the new region or regions. The selection can reside within a single region, across adjacent regions within the same track, or across multiple tracks.

   – or –

2. Click with the Selector at the point within a region, where you want to split the region in two. The selection is highlighted blue.

3. Choose Edit > Separate Region.

   If the Editing Preference for “Separate Region Operates On All Related Takes” is selected and you are editing a region that is one of a number of related takes with the same User Time Stamp (for example, as created with loop recording), the Separate Region command affects each take. For details see, “Editing Preferences and Take Regions” on page 162.

Separating Multiple Tracks

Figure 16 illustrates a separation across three mono audio tracks and one stereo track. For some tracks, the selection resides within a region, while others reside at the start or end of a region.

By separating a region, additional regions are auto-created from data on either side of the separation, which have new numbers assigned to their names. The original region remains intact and unchanged on the Regions List.

Figure 16. Separating across multiple tracks

Once separated, this material can be easily moved or copied to another location.
**Separation Grabber**

You can use the Separation Grabber to automatically separate an edit selection and move it to another location or another track.

**To separate a selection with the Separation Grabber:**

1. With the Selector, drag to select the material for the new region or regions. The selection can reside within a single region, across adjacent regions within the same track, or across multiple tracks.

2. From the Grabber pop-up, choose the Separation Grabber.

3. Drag the selection to the new location, or to another track.

A new region (or regions) containing the previous selection is created, separate from the original selection. New regions are also created from the material outside the original selection.

**To separate a selection without affecting the original regions:**

1. With the Selector, drag to select the material for the new region or regions. The selection can reside within a single region, across adjacent regions within the same track, or across multiple tracks.

2. From the Grabber pop-up, choose the Separation Grabber.

3. While pressing Option (Macintosh) or Alt (Windows), drag the selection to the new location, or to another track.

New regions containing the previous selection are created and placed at the new location. The original selection and regions remain intact.

**Trim To Selection Command**

The Trim To Selection command removes data before and after a region or MIDI note selection, leaving only the selection. This command provides a handy means of quickly removing all data in a region (and in some instances the entire track) except for the current selection.

**To trim unwanted data from a region or note:**

1. With the Selector, select a portion of a region or note (or a range of notes).

2. Choose Edit > Trim > To Selection to remove material outside of the selection.
Healing a Separation

The Heal Separation command returns separated regions to their original state—provided the regions are still next to each other and their relative start/end points haven’t changed since the separation.

If you have trimmed or otherwise changed the start or end points of the two regions, or moved them further away from each other, you won’t be able to repair them with the Heal Separation command. It is not possible to heal two regions created from different audio files.

To heal a separation between two regions:

1. With the Selector, make a selection that includes part of the first region, the entire separation between the regions, and part of the second region.
2. Choose Edit > Heal Separation.

If the regions won’t heal, there are other ways to return the separated regions to a single region.

- Delete one of the two separated regions (make sure you’re in Slip mode so the gap doesn’t close) and use the Trimmer to expand the remaining region to its original length. For information on using the Trimmer, see “The Trimmer Tool” on page 245.
  - or -
- Delete both of the separated regions and drag the original region from the Regions List to the original location. For information on placing regions, see “Placing Regions in Tracks” on page 242.

Placing Regions in Tracks

Once you have created a region, it appears in the Audio or MIDI Regions List. From there you can drag it to a track to add to an existing arrangement of regions, or you can create a new track and start adding regions from scratch. The exact placement of regions in a track depends on whether the Edit mode is set to Shuffle, Slip, Spot, or Grid (see “Edit Modes” on page 205 for details).

For information on locating regions in the Regions List by typing the first few letters of their name, see “Keyboard Selection of Regions” on page 204.

For additional information on placing regions using DigiBase, see the DigiBase Guide.

To place a region in a track:

1. In the Audio or MIDI Regions List, select the region or regions you want.
2. Drag the selected regions from the Regions List to a track at the desired point.

If dragging multiple regions, the regions are placed on adjacent tracks. If dragging a stereo region, it must be placed in a stereo track or in two mono tracks.

Regions are placed according to the current Edit mode:

- In Shuffle mode, existing track regions are slid as necessary to make room for the new region.
- In Spot mode, you are prompted by the Spot dialog to enter a location for the dragged region (see “Spotting Regions” on page 250).
• In Grid mode, the dragged region snaps to the nearest Grid boundary.

   In Pro Tools 6.0 and later, you can temporarily disable Grid mode while dragging a region by holding down the Command key (Macintosh) or Control key (Windows).

• In Slip mode, the regions are placed freely anywhere in the destination track.

   Use the Replace Region function to replace all occurrences of a region (in all tracks) with a different region from the Regions List. See “Replacing Regions” on page 267.

**Defining Region Sync Points**

The placement of regions in Grid and Spot mode can be based on the definition of a region sync point. Sync points are used when a point within a region must be aligned to the Grid or to a particular SMPTE or bar/beat location. This capability is important in placing music and sound effects for film and video work.

For example, suppose you had an audio region for a door slam that included the creak of the door closing, the actual slam, and the reverb of the slam. You may want to align the “slam” to other locations within the session.

**To define a region sync point:**

1. Set the Edit mode to Slip by clicking its button in the upper left of the Edit window.

2. With the Selector, click in the region at the point, usually the peak of the waveform, where you want to define the sync point.

3. Choose Edit > Identify Sync Point. A small down arrow appears at the bottom of the region, indicating the location of the sync point.

**To remove a sync point:**

   Select the entire region and choose Edit > Remove Sync Point.

**To change the location of a sync point:**

   Click the Selector at the desired point in the region and choose Edit > Identify Sync Point. The new location is identified as the sync point.

**Placing Regions at the Edit Insertion Point**

You can easily place and align a region’s start, end, or sync point to the Edit insertion point. This technique is useful in post production applications since it allows you to set a reference point and quickly place sound effects while ensuring that their start point remains consistent.

You can drag a region from the same track, from another track, or from the Audio or MIDI Regions List.

   For TDM systems, when Continuous Scroll with Playhead is selected, regions snap to the playhead, instead of the Edit insertion point.
To place the start of a region at the Edit insertion point:

1. Click with the Selector in the track at the desired time location.
2. While pressing Control (Macintosh) or the Start key (Windows), drag the region from the Regions List, or from another track, to the destination track.
   – or –
If the region is already in the track, Control-click (Macintosh) or Start-click (Windows) the region with the Grabber.

To place the end of a region at the Edit insertion point:

1. Click with the Selector in the track at the desired time location.
2. While pressing Command+Control (Macintosh) or Control+Start key (Windows), drag the region from the Regions List, or from another track, to the destination track.
   – or –
If the region is already in the track, Command-Control-click (Macintosh) or Control-Start-click (Windows) the region with the Grabber.

To place the sync point of a region at the Edit insertion point:

1. Click with the Selector in the track at the desired time location.
2. While pressing Shift+Control (Macintosh) or Shift+Start key (Windows), drag the region from the Regions List, or from another track, to the destination track.
   – or –
If the region is already in the track, Shift-Control-click (Macintosh) or Shift-Start-click (Windows) the region with the Grabber.

Aligning to Region Start Points

The start, end, and sync point of one region can be aligned to the start of a different region on another track.

For TDM systems, if Continuous Scroll with Playhead is enabled, region start, end, and sync points align to the playhead.

To align the start points of regions on different tracks:

1. With the Grabber, select the region you want to align to by clicking it.
2. For TDM systems, if Continuous Scroll with Playhead is enabled, move the playhead to the start of the selected region. For details, see “Moving the Playhead” on page 237.
3. With the Grabber, Control-click (Macintosh) or Start-click (Windows) the region you want to move.
   – or –
Control-drag (Macintosh) or Start-drag (Windows) a region from the Regions List to another track.
The start point of the second region is aligned to the start of the first region.

To align the end point of a region to the start of another region (on a different track):

1. With the Grabber, select the region you want to align to by clicking it.
2. For TDM systems, if Continuous Scroll with Playhead is enabled, move the playhead to the start of the selected region. For details, see “Moving the Playhead” on page 237.
3. With the Grabber, Command-Control-click (Macintosh) or Control-Start-click (Windows) the region you want to move.
   – or –
Command-Control-drag (Macintosh) or Control-Start-drag (Windows) a region from the Regions List to another track.

The end point of the second region is aligned to the start of the first region.

**To align the sync point of a region to the start of another region (on a different track):**

1. With the Grabber, select the region you want to align to by clicking it.

2. For TDM systems, if Continuous Scroll with Playhead is enabled, move the playhead to the start of the selected region. For details, see “Moving the Playhead” on page 237.

3. With the Grabber, Shift-Control-click (Macintosh) or Shift-Start-click (Windows) the region you want to move.
   
   – or –

   Shift-Control-drag (Macintosh) or Shift-Start-drag (Windows) a region from the Regions List to another track.

   The sync point of the second region is aligned to the start of the first region.

---

**The Trimmer Tool**

The Trimmer tool provides region, note, and data trimming functions.

Pro Tools TDM systems provide three Trimmers, including the Standard, Time, and Scrub Trimmer. Pro Tools LE provides the Standard and Time Trimmers.

---

### Standard Trimmer

With the Trimmer tool, you can quickly shorten or expand a region (up to the entire length of the source audio file). The first time you trim a region, Pro Tools automatically adds it to the Regions List as a new region (with a name derived from the original) in order to differentiate it from the original.

The Standard Trimmer is a nondestructive tool and doesn’t actually modify the original audio or MIDI data (when working on regions). To return to the length of the original region, drag it from the Regions List, or resize the edited region with the Trimmer to its original length.

Use of the Trimmer is affected by the current Edit mode: Shuffle, Slip, Spot, or Grid. See “Edit Modes” on page 205 for more information.

The Standard Trimmer can also be used to lengthen and shorten MIDI notes (see “Trimming Note Start and End Times” on page 337), and also to scale automation and controller data up or down “Drawing Automation” on page 435.

For TDM systems, the Trimmer has three modes: Standard Trimmer (discussed in this section), Scrub Trimmer (see “The Scrub Trimmer” on page 247), and Time Trimmer (see “The Time Trimmer” on page 246).

**To trim a region with Standard Trimmer:**

1. Select the Trimmer tool. For TDM systems, make sure the Standard Trimmer is selected in the Trimmer pop-up menu.
2 Move the cursor near the start or end of the region, so the Trim cursor appears.

To reverse the direction of the Trim cursor, press Option (Macintosh) or Alt (Windows).

3 If trimming the end, drag left to shorten the region, right to lengthen.

– or –

If trimming the start, drag right to shorten the region, left to lengthen.

When trimming regions in a stereo or multi-channel track, all channels are trimmed.

When using Shuffle mode, adjacent regions are slid as necessary to make room for the edited region. If using Grid mode, the dragged start/end times snap to the nearest Grid boundary. If using Spot mode, the Spot dialog opens, where you can enter the new location for the region’s start or end point.

The Time Trimmer

The Time Trimmer is a convenient tool for matching an audio region to the length of another region, a tempo grid, a video scene, or to practically any other reference point you want.

The Time Trimmer works by using the Time Compression/Expansion AudioSuite plug-in to create a new audio file. You use the Time Trimmer by dragging the region’s start or end point to expand or compress the region.

Time Compression/Expansion Plug-In Preferences

You can select settings for the Time Compression/Expansion AudioSuite plug-in by choosing from the Default Settings pop-up list in the Processing Preferences, under “TC/E.” The settings available are presets included with Pro Tools; in addition, if you save your own presets for the Time Compression/Expansion plug-in, they will also appear here.

Refer to the DigiRack Plug-Ins Guide for more information about AudioSuite plug-ins.

Using the Time Trimmer in Grid Mode

The Time Trimmer can be used in Grid mode to match a region to the tempo of a session or a section of a session. For example, you might import a one-bar drum loop with a tempo of 90 BPM into a session with a tempo of 120 BPM. In Grid mode, you can use the Time Trimmer to simply and quickly “time compress” the drum loop to the length of one measure, with minimal loss of audio fidelity.

In Pro Tools 6.0 and later, trimming regions while in Relative Grid mode will trim the regions in grid increments while maintaining their relative offset (if any) from the grid.

To use the Time Trimmer in Grid mode:

1. Set the Edit mode to Grid.

2. Select “TCE Trimmer” from the Trimmer pop-up menu.
Chapter 17: Working with Regions and Selections

3 With the Time Trimmer, drag the region’s start or end point to compress or expand the region to the Grid (for example, by quarter notes). The region is automatically processed using the Time Compression/Expansion AudioSuite plug-in. The new region appears in the playlist and in the Regions List.

Using the Time Trimmer in Slip Mode

To use the Time Trimmer in Slip mode:
1. Set the Edit mode to Slip.
2. Select “TCE Trimmer” from the Trimmer pop-up menu.
3. With the Time Trimmer, drag the region’s start or end point to compress or expand the region freely. A new region is automatically processed using the Time Compression/Expansion AudioSuite plug-in. The new region appears in the playlist and in the Regions List.

Using the Time Trimmer in Spot Mode

In Spot mode, clicking with the Time trimmer in a region opens the Spot Dialog. You can specify the location you want the region to start or end at, or the duration of the region, and the region is automatically compressed or expanded as specified.

To use the Time Trimmer in Spot mode:
1. Set the Edit mode to Spot.
2. Select “TCE Trimmer” from the Trimmer pop-up menu.
3. Click the region near its start or end point. The Spot Dialog opens. Using any Time Scale, enter a new start or end time (or duration) for the region, then click OK. A new region is automatically processed using the Time Compression/Expansion AudioSuite plug-in. The new region appears in the playlist and in the Regions List.

The Scrub Trimmer
(TDM Systems Only)

The Scrub Trimmer is a convenient tool for auditioning material (on up to two tracks) to find a trim point. You can drag in a track to hear the audio information, then trim at a specific location by releasing the mouse button.

This action creates a new region. Note that the cursor changes into a “right trim” or “left trim” shape as it is placed over the right or left side of a region. To reverse the direction of the Scrub Trimmer, press Option (Macintosh) or Alt (Windows) before you click the region.

Scrub playback speed and direction vary with controller movement. Scrubbed audio is routed through the track signal path, so you hear any effects in the signal path.
To scrub trim a track:

1. Click the Scrub Trimmer tool. The cursor changes to a speaker with a bracket.

2. Drag within a track to the left or right. Audio from a scrubbed track is routed through the track signal path, including any TDM effects. When you locate the desired trim point, release the mouse button to trim the region.

To scrub trim two tracks, click with the Scrub Trimmer between two adjacent tracks and drag.

To scrub with finer resolution (without having to zoom in), press Command (Macintosh) or Control (Windows) while scrubbing.

Trim To Insertion Command

You can trim a region or MIDI note by automatically removing the material between the Edit insertion point and the start or end point.

To trim from a start point to insertion:

1. With the Selector, click inside the region or note where you want the new start point to be.

2. Choose Edit > Trim > Start To Insertion. The region’s start point is automatically trimmed to the insertion point.

To trim from an end point to insertion:

1. With the Selector, click inside the region or note where you want the new end point to be.

2. Choose Edit > Trim > End To Insertion. The region’s end point is automatically trimmed to the insertion point.

Trimming with Nudge

You can trim the start and end points of a region by nudging them.

To trim a region’s start or end point by the Nudge value:

1. Configure the Nudge value as desired. For details, see “Defining the Nudge Value” on page 253.

2. With the Grabber, select the region you want to trim.

3. While pressing Option (Macintosh) or Alt (Windows), press Plus or Minus on the numeric keypad to trim the region’s start point by the Nudge value.

– or –

While pressing Command (Macintosh) or Control (Windows), press Plus or Minus on the numeric keypad to trim the region’s end point by the Nudge value.
Sliding Regions

A region or group of selected regions (on the same track or on multiple tracks) can be slid with the Grabber tool to new locations or to other tracks. This feature is useful in music and post production applications where the timing of audio events such as sound effects and dialog need to be spotted to music, film, or video.

Sliding regions is affected by whether the current Edit mode is set to Shuffle, Slip, Spot, or Grid. See “Edit Modes” on page 205 for details.

You can slide a copy of a region to another location or track by pressing Option (Macintosh) or Alt (Windows) while dragging.

To retain a region’s location when dragging to another track, press Control (Macintosh) or the Start key (Windows) while dragging.

Shuffling Regions

In Shuffle mode, you can move regions freely within a track or onto another track, but their movement is constrained by other regions. That is, if you place several regions in a track, their start and end points automatically snap to each other. You can then “shuffle” their order, but you cannot separate them from each other and you cannot make them overlap as in Slip mode.

In Shuffle mode, adding another region to the beginning of a track moves all subsequent regions to the right by the length of the region added.

To shuffle regions:

1. Set the Edit mode to Shuffle by clicking its button in the upper left of the Edit window.

2. Drag a mono region from the Regions List to an empty track. The region snaps to the beginning of the track.

3. Drag a second region from the Regions List to the same track, somewhere in the middle. The start point for the second region snaps to the end of the first region.

4. With the Grabber, drag the second region to the beginning of the track.

Pro Tools “shuffles” the position of the two regions. The second region now occurs first, yet the two still cling together.

5. Experiment more with Shuffle mode by dragging additional regions to the track and rearranging them.

Locked regions (see “Locking Regions” on page 256), and all regions occurring after the locked region, are not displaced when other neighboring regions are moved in Shuffle mode. If there is not enough room to place or duplicate a region in front of a locked region, the insertion area is disabled.

If you place a region while in Slip mode and switch to Shuffle mode, Pro Tools preserves the relative timing and position of the slipped region, and any blank space between it and other regions.
Shuffling Multiple Tracks and Multichannel Regions

Selections across multiple tracks or on multichannel tracks can be shuffled. Unlike shuffling regions on a single, mono track, any partially selected regions will be cut and moved along with the dragged region. This lets you retain only the material that corresponds to the dragged region, similar to a tape splice and multitrack.

Slipping Regions

In Slip mode, regions can be moved with the Grabber freely within a track, or onto other tracks. In this mode, it is possible to place a region so that there is space between it and other regions in a track. When the track is played back, this space is silent. It is also possible to move a region so that it overlaps or completely covers another region.

Spotting Regions

Spot mode is useful for sessions in which you want to spot regions to precise locations based on any of the Time Scales. This can be particularly useful when performing post production tasks. In Spot mode you can spot a region by specifying a SMPTE frame (TDM systems only) or bar and beat location, by capturing an incoming time code address, or by using the region’s time stamps.

For even quicker spotting, if you are using VITC, use the Auto-Spot Regions command to spot a region to the current SMPTE frame location with the Grabber. For more information, see “Auto-Spotting Regions” on page 545.
To spot a region:

1. Set the Edit mode to Spot by clicking its button in the upper left of the Edit window.

2. Drag a region from the Regions List to an existing track.
   – or –
   Click a region already in a track with the Grabber.

3. In the Spot dialog, select the desired time format from the Time Scale pop-up menu.

   Each of the fields in the Spot dialog are displayed in the chosen Time Scale.

   ![Spot dialog]

4. For TDM systems, if the Time Scale is set to Time Code, select the Use Subframes option to display subframes in the fields for great accuracy.

5. Click in the field for Start, Sync Point, or End and type in a new location. Changing one of these locate points automatically updates the other locate points.
   – or –

   Click one of the up arrows next to Original Time Stamp or User Time Stamp to enter the associated values into the currently selected field.
   – or –

   If you are using an external SMPTE time code source, click the down arrow next to the Current Time Code display—or press Equal (=) on the numeric keypad—to capture an incoming time code address.

6. Click OK. The region is moved to the new location specified for its start or sync point.

   If a region does not have a sync point defined, the Sync Point field in the Spot dialog functions the same as the Start field.

   To learn more about using SMPTE with Pro Tools, refer to Chapter 35, “Time Code Synchro-nization.”

Region Time Stamps

When a region is created, it is time stamped relative to the SMPTE start time specified for the session. This Original Time Stamp is permanently stored with the region and cannot be changed. If a region is ever moved, it can easily be placed at its original position from the Spot dialog.

When the Original Time Stamp for a region is initially set, this same location is also used to define the region’s User Time Stamp.

Unlike the Original Time Stamp, the User Time Stamp can be redefined with the Time Stamp Selected command in the Regions List pop-up menu. For more information, see “Time Stamping” on page 545.

Time Stamps in DigiBase

Columns are provided in DigiBase browsers for both the Original and User Time Stamps.
Time Stamps and the Takes List

Regions with identical User Time Stamps appear together in the Takes List pop-up menu when auditioning takes. For more information, see “Auditioning from the Takes List Pop-up Menu” on page 161.

Sliding Regions in Grid Mode

Grid mode provides several useful capabilities for sliding and moving regions in track playlists. This mode is especially useful for lining up regions at precise intervals, as when working with a session that is bar- and beat-based. Grid boundaries, depending on the Main Time Scale, can be based on frames, bar and beat values, minutes or seconds, or a number of samples.

Grid mode also provides two operational modes, Absolute and Relative. These modes control how the Grid is applied. (See “Absolute and Relative Grid Mode” on page 253 for more information.)

To temporarily suspend Grid mode and switch to Slip mode while dragging a region, hold down the Command key (Macintosh) or Control key (Windows).

Setting Up the Grid

When the Display Preference for “Draw Grid in Edit Window” is enabled, vertical Grid lines appear in the Edit window.

Grid lines in the Edit window can also be enabled and disabled by Control-clicking (Macintosh) or Right-clicking (Windows) the Indicator Dot for any Timebase Ruler.

Defining the Grid Value

In addition to affecting the placement of regions, the Grid value also constrains Edit and Timeline selections, and determines how the Quantize Regions command works.

To set the Grid value:

1. From the Display menu, select the Time Scale you will use for the Grid value.
   – or –
   To keep the Main Time Scale and use a different time format for the Grid, deselect Follow Main Timebase in the Grid Value pop-up menu in the Edit window.

2. From the Grid Value pop-up menu in the Edit window, select the time value that will define the Grid boundaries.
   – or –
   To define a Grid based on the session’s Markers, selections, and region boundaries, select Regions/Markers from the Grid Value pop-up.

Grid Value pop-up menu showing Bars:Beats
   – or –
   To define a Grid based on the session’s Markers, selections, and region boundaries, select Regions/Markers from the Grid Value pop-up.
Absolute and Relative Grid Mode

Grid mode can be applied in Absolute or Relative mode.

- In Absolute Grid mode, moving any region snaps the region start to Grid boundaries. If a region’s start point falls between beats, and the Grid is set to 1/4 notes, dragging the region will snap its start time to the nearest 1/4 note (the current absolute Grid value).
- In Relative Grid mode, regions can be moved by Grid (or Nudge) units. If a region’s start point falls between beats and the Grid is set to 1/4 notes, dragging the region will be constrained to 1/4 notes, preserving the region’s relative position to the nearest beat.

To select Absolute or Relative Grid mode:

- Click the Grid mode selector and choose Absolute or Relative, as desired.

To place or move a region while in Grid mode:

1. Configure the Grid value as desired. For details, see “Defining the Grid Value” on page 252.
2. Drag a region from the Regions List to an existing track.
   - or -
   With the Grabber, drag a region already in a track to a new location.

The region’s start point snaps to the closest Grid boundary. If the region has a sync point defined, the sync point snaps to the Grid boundary.

Nudging

Pro Tools can nudge regions (or MIDI notes) by precise increments with the Plus (-) and Minus (+) keys on the numeric keypad. The amount of the nudge is determined by the value specified in the Nudge pop-up menu. The Nudge function can be used in any of the Edit modes.

Nudging can be invaluable for adjusting the “groove” of a musical phrase or a sound effect relative to other elements in the session. Since Pro Tools can nudge material during playback, you can nudge continuously in real time to adjust the timing relationship between tracks.

Nudge can also be used to adjust the placement of automation breakpoints. For more information, see “Editing Automation” on page 436.

Defining the Nudge Value

The Nudge value determines how far regions and selections are moved when nudging.

Start and end points for selections can also be moved by the Nudge value (see “Nudging Selection Start/End Points” on page 228). In addition, regions can be trimmed by the Nudge value (see “Trimming with Nudge” on page 248).

To set the Nudge value:

1. From the Display menu, select the Time Scale you will use for the Nudge value.
   - or -
   To keep the Main Time Scale and use a different time format for the Nudge value, deselect Follow Main Timebase in the Nudge pop-up menu in the Edit window.
From the Nudge pop-up menu in the Edit window, select the Nudge value.

To specify a Nudge value not listed in the Nudge pop-up, click in the Nudge field and type in the value.

### Nudging Regions

#### To nudge one or more region:

1. Configure the Nudge value as desired. For details, see “Defining the Nudge Value” on page 253.

2. With the Grabber or Selector, select the region or regions you want to nudge. The regions can reside on multiple tracks. Only regions that are entirely selected will be nudged.

3. On the numeric keypad, press Plus (+) to move the selection forward by the Nudge value.
   – or –

   Press Minus (-) to move the selection back by the Nudge value.

The Nudge command works the same regardless of the Edit mode. Adjacent regions are overlapped in Shuffle mode, the Spot dialog does not appear when in Spot mode, and shifted material does not snap to the Grid when in Grid mode.

### Nudging Regions on Multiple Tracks and in Multichannel Tracks

When nudging a selection of multiple regions, within a single track or across multiple tracks, that also contains silence, any automation data residing within the silence is also nudged.

### Nudging by Next Nudge Value

In addition to nudging by the current Nudge value, you can also nudge by the next, larger value in the Nudge pop-up.

For example, if the Nudge value is set to 1 frame and you want to nudge by a larger value, you can nudge by the next, larger Nudge value of 10 frames.

#### To nudge forward or back by the next, larger Nudge value:

1. Enable the Key Commands Focus by clicking the a-z button in the upper left of the Edit window.

2. With the Selector or Grabber, select the regions or notes you want to nudge.

3. Press slash (/) to nudge the selected material forward by the next Nudge value. Press M to nudge the selection back.

   You can also nudge by the next Nudge value without enabling the Commands Focus.

   While pressing Control (Macintosh) or the Start key (Windows), press slash (/) or M.
Nudging a Region’s Contents

Often a region’s start point will reside at the correct location, perhaps at a SMPTE frame or bar, but the material within the region starts too late or early. You can, in effect, nudge a region’s audio waveform or MIDI notes without displacing the region’s start and end points.

This “sliding” of region contents is only possible if there is material residing outside the region’s start and end points—from the region having been trimmed, or perhaps captured from a larger region.

To nudge the contents of a region without changing the region start and end points:

1. Configure the Nudge value as desired. For details, see “Defining the Nudge Value” on page 253.
2. With the Grabber, select the region whose contents you want to nudge.
3. While pressing Control (Macintosh) or the Start key (Windows), press Plus (+) or Minus (–) on the numeric keypad to move the material by the Nudge value.

Shift Command

Use the Shift command to move track material forward or back in time by a specified amount. The Shift command can operate on selections, regions, MIDI notes, MIDI controller data, and automation breakpoints.

To shift a selection or region:

1. Using either the Selector or Grabber, select the track material you want to shift. The selected material can reside on multiple tracks.
2. Choose Edit > Shift. In the Shift dialog, select whether the data will be moved Earlier or Later.
3. Click in one of the Timebase fields to specify the amount the material will be shifted. Entering a value in one Timebase field automatically updates the others.
4. If desired, select the Use Subframes option for greater accuracy.
5. Click OK. The material is shifted back or forward by the specified amount.

If a portion of a region was selected, new regions are created from the selection and from any material outside of the selection.
The Shift command works the same regardless of the Edit mode. Adjacent regions are overlapped in Shuffle mode, the Spot dialog does not appear when in Spot mode, and shifted material does not snap to the Grid when in Grid mode.

---

**Quantizing Regions**

The Quantize Regions command adjusts the placement of selected audio and MIDI regions so that their start points (or sync points, if they contain one) precisely align to the nearest Grid boundary, which can be based on frames, bar and beat values, minutes or seconds, or a number of samples.

**To quantize one or more regions:**

1. Configure the Grid value as desired. For details, see “Defining the Grid Value” on page 252.

2. With the Grabber or Selector, select the region or regions you want to quantize. The regions can be on multiple tracks. Only regions that are entirely selected will be quantized.

3. Choose Edit > Quantize Regions. Region start times (or sync points) are aligned to the boundaries for the defined Grid.

For MIDI regions, all data contained within the regions (such as notes) are moved equally, thereby retaining their rhythmic relationships. To quantize individual MIDI notes, use the Quantize command in the MIDI menu (see “Quantize” on page 358).

---

**Locking Regions**

If you have a region or group of regions that you want to permanently associate with a particular location in a track (a beat, SMPTE frame, or sample location), you can lock it in place so it will not be accidentally moved.

**To lock a region:**

1. With the Grabber, select the region or regions to lock. The regions can even reside on multiple tracks.

2. Choose Edit > Lock/Unlock Region.

A small lock appears in the region, indicating it has been locked and cannot be moved. If you attempt to perform edits that would move a locked region, Pro Tools alerts you.

In Shuffle mode, locked regions, and all regions occurring after the locked region, are not displaced when other neighboring regions are moved. If there is not enough room to place or duplicate a region in front of a locked region, the insertion area is disabled.

⚠️ Locking a region prevents it from being moved or deleted only—operations such as recording and automation editing still affect it.
Muting/Unmuting Regions

Choosing the Mute/Unmute Region command mutes playback of a selected region. Choosing the command a second time unmutes the region. Regions that are muted become dimmed to indicate their status.

To mute a region or regions:

1. With the Grabber, select the region or regions you want to mute. The regions can even reside on multiple tracks.

2. Choose Edit > Mute/Unmute Region. The selected regions become dimmed, indicating they are muted.

To unmute a region, select it and choose Edit > Mute/Unmute Region.

Edit Commands

Cut, Copy, Clear, and Paste

Use the Cut, Copy and Paste commands to rearrange and edit track material. Edits can operate on entire regions selected with the Grabber, or on track ranges selected with the Selector. Edits can also work across multiple tracks (see “Editing Across Multiple Tracks” on page 260).

For TDM systems, you can cut, copy, and paste discontinuous regions selected with the Object Grabber.

Track View and Edit Content

When cutting or copying track material, the Track View determines the type of data placed on the Clipboard. When displaying waveforms for audio tracks, or notes or regions for MIDI tracks, selections include all underlying automation and controller data. Thus, cutting an audio region also cuts any volume, pan, mute, send, or plug-in automation that is also on the track. This saves you from having to individually cut from each automation playlist on the track.

However, when selecting groups of MIDI notes with the Grabber (by drawing a rectangle around them), only the note data is placed on the Clipboard. When selecting a time range of MIDI notes with the Selector, all controller data in the track is selected (similar to selecting with the Selector for audio tracks in Waveform view).

When a track is displaying automation data or controller data, only that data is placed on the Clipboard. Also, whenever you cut or copy automation data, bounding breakpoints are created at each end of the selected area, in order to preserve the slope of the automation both inside and outside the selection.
If tracks are grouped, copying and pasting on any of the tracks affects each of the other tracks in the group. Tracks that are hidden—even if they are part of a group being edited—are not affected by edits.

The current Edit mode affects how material is selected, copied, and pasted:

- In Slip mode, the Cut command leaves an empty space corresponding to the data removed from the track.
- In Shuffle mode, the Cut command leaves no empty space, since the regions to the right of the cut slide over, closing the gap.
- In Slip mode, pasted data can overlap an adjacent region.
- In Shuffle mode, pasted data causes all regions to slide over to make room for the pasted material.

New regions are often auto-created when performing edits. For instance, when clearing a selection from a region, new regions are auto-created from the material residing outside of the selection.

### Copying and Pasting Automation

The following are two special functions for copying and pasting automation data.

- To copy all automation playlists for a track, press Control (Macintosh) or the Start key (Windows) when copying from any of the track's automation playlists. This special function also works across multiple tracks.
- To paste from one type of automation playlist to another similar playlist (for instance, from a volume playlist to a send level playlist), press Control (Macintosh) or the Start key (Windows) when pasting.

For more information on working with automation data, see Chapter 28, “Automation.”

### Clear Command

Use the Clear command to remove a selection from a track without placing it on the Clipboard.

**To clear a selection or region:**

1. If desired, set the Edit mode to Grid to constrain the selection to the current Grid value.
2. Set the Display Format for the tracks you want to edit.
3. When displaying waveforms for audio tracks, or notes or regions for MIDI tracks, selections include underlying automation and controller data. If the track is displaying automation data, only the automation data is affected by the edits.
4. Drag with the Selector in the track to select the material you want to clear.

   – or –

   Use the Grabber to select one or more regions (or a group of MIDI notes).
5. Choose Edit > Clear to remove the selection.

If a portion of a region was cleared, new regions are auto-created from the material residing outside of the selection. If working in Shuffle mode, adjacent regions are slid over, as necessary, to fill the blank space.

### Cut and Copy Commands

Use the Copy command to place a selection on the Clipboard so it can be pasted to another track, or to the same track at a different location.

Use the Cut command to place the selection on the Clipboard while also removing it from the track.
To cut or copy a selection or region:

1. If desired, set the Edit mode to Grid to constrain the selection to the current Grid value.

2. Set the Display Format for the tracks you want to edit.

When displaying waveforms for audio tracks, or notes or regions for MIDI tracks, selections include underlying automation and controller data. If the track is displaying automation data, only the automation data is affected by the edits.

3. Drag with the Selector in the track to select the material you want to cut or copy.

   – or –

   Use the Grabber to select one or more regions (or a group of MIDI notes).

4. Choose Edit > Cut to remove the selection and place it on the Clipboard.

   – or –

   Choose Edit > Copy to place the selection on the Clipboard, without removing it.

If a portion of a region was cut or copied, the material on the Clipboard appears as a new region in the Regions List. If a portion of a region was cut, new regions are auto-created from the material residing outside of the selection.

When working in Shuffle mode, adjacent regions are slid over, as necessary, to fill blank spaces.

Deleting Underlying Region Data

In Slip mode, Regions can be placed so that they overlap or completely cover other regions. When removing a region or selection, you can also remove the underlying region data.

To delete a region or selection along with the underlying region data:

- Choose Edit > Cut.

To delete a region or selection without removing the underlying region data:

- Choose Edit > Clear.

Paste Command

Use the Paste command to place the Clipboard’s contents at the Edit insertion point, overwriting existing material already there.

To paste a selection or region:

1. If desired, set the Edit mode to Grid to constrain the insertion point or selection to the current Grid value.

2. With the Selector, click in a track at the point where you want to paste the material. Press Tab to move the insertion point forward to region start and end times; to move back, press Option+Tab (Macintosh) or Control+Tab (Windows).

   – or –

   Use the Selector or Grabber to make a selection where the material will be placed.

3. Choose Copy > Paste.

If pasting at an insertion point in Shuffle mode, material to the right of the paste point is shifted to the right. In Slip mode, the material is overwritten with the paste.
If pasting into a selection in Shuffle mode, the selection is replaced by the Clipboard's contents with the adjacent material slid left or right as necessary. In Slip mode, the selection is also replaced but with the surrounding material remaining unchanged.

- **When working with MIDI**, you can merge the contents of the Clipboard with material in the destination track. For details, see “Merge Paste Command” on page 262.

- **For TDM systems**, the Fill Paste command can be used to fill a selection with the contents of the Clipboard. For details, see “Repeat Paste To Fill Selection” on page 269.

### Editing Across Multiple Tracks

When working with data from multiple tracks, there are some important points to remember. For instance, if any of the selected tracks are set to their master view (see “The Master View Format” on page 192), edits affect not only audio and MIDI for the selected tracks, but all automation and controller data as well.

If all selected tracks are displayed as automation data, edits only affect the type of automation data displayed in each track. Furthermore, if track 1 displays Pan automation, track 2 displays Volume automation, and track 3 displays Mute automation, the Cut command cuts only pan data from track 1, volume data from track 2, and mute data from track 3.

- **For details on selecting data on multiple tracks**, see “Selecting Across Multiple Tracks” on page 230.

When copying only automation or controller data for selected tracks, press Control (Macintosh) or the Start key (Windows) to copy all types of automation on all selected tracks.

To paste to multiple tracks, place the insertion point in each of the destination tracks by Shift-clicking in them—or to select all tracks, Option-Shift-click (Macintosh) or Alt-Shift-click (Windows) in a track, or make a selection in one of the Timebase Rulers.

When you paste multiple types of data, whatever data has been copied is pasted into the correct type of playlist. Automation data is pasted into the appropriate automation playlist (pan, volume, mute and so on). Audio/MIDI data is pasted into the audio/MIDI playlist. You don’t need to set target tracks to the specific type of data being pasted for the paste to work correctly.

If all destination tracks in a multitrack paste are displayed as automation, the paste replaces any previous data on the target track without shuffling—regardless of whether you are in Slip or Shuffle mode.

### Duplicate Command

The Duplicate command copies a selection and places it immediately after the end of the selection. Though this is similar to using Copy and Paste, Duplicate is more convenient and faster, particularly when working with data on multiple tracks.

To make more than one copy of a selection, use the Repeat command (see “Repeat Command” on page 261).

As with the Copy and Paste commands, certain rules apply when duplicating material on multiple tracks. For details, see “Editing Across Multiple Tracks” on page 260.

- **The Duplicate command does not operate on conductor events.**
To duplicate a selection or region:

1. If working with material that is bar- and beat-based, such as loops, set the Main Time Scale to Bars:Beats.
2. If desired, set the Edit mode to Grid to constrain the selection to the current Grid value.
3. Drag with the Selector in the track to select the material you want to duplicate.
   - or -
   Click in the track and enter the start and end points for the selection in the Event Edit area.
4. Choose Edit > Duplicate. The material is placed immediately after the selection's end point.

In Shuffle mode, the duplicated data is placed directly after the end of the selection. Regions occurring after it are slid to accommodate the duplicated material. In Slip mode, the duplicated material overlaps any adjacent data.

When using Duplicate or Repeat with MIDI notes that were selected with the Grabber, material is always duplicated one measure later, and is merged with existing track material (instead of replacing).

Duplicating Audio

When using Duplicate or Repeat for audio that must fall cleanly on the beat (for loops), it is important that you select the audio material with the Selector, or by typing in the start and end points in the Event Edit area. If you select an audio region with the Grabber (or by double-clicking it with the Selector), the material may drift by several ticks because of sample-rounding.

If, on the other hand, you want to Duplicate or Repeat audio that is not bar- and beat-based, set the Time Scale to any format except Bars:Beats. This ensures that the duplicated audio material will have the correct number of samples and will be placed accordingly.

Repeat Command

The Repeat command is similar to Duplicate, but allows you to specify the number of times the selected material is duplicated.

As with the Copy and Paste commands, certain rules apply when repeating material on multiple tracks. For details, see “Editing Across Multiple Tracks” on page 260.

To repeatedly paste copied data until it completely fills a selection (TDM systems only), see “Repeat Paste To Fill Selection” on page 269.

⚠️ The Repeat command does not operate on conductor events.

To repeat a selection or region:

1. If working with material that is bar- and beat-based, such as loops, set the Main Time Scale to Bars:Beats.
2. If desired, set the Edit mode to Grid to constrain the selection to the current Grid value.
3. Drag with the Selector in the track to select the material you want to repeat.
   - or -
   Click in the track and enter the start and end points for the selection in the Event Edit area.
Choose Edit > Repeat. In the Repeat dialog, enter the number of times you want the material to repeat, then click OK.

The material is placed immediately after the selection’s end point, and duplicated by the number of times specified.

In Shuffle mode, the repeated data is placed directly after the end of the selection. Regions occurring after it are slid to accommodate the repeated material. In Slip mode, the repeated material overlaps any adjacent data.

**Merge Paste Command**

Use the Merge Paste command to merge MIDI notes from the Clipboard with material already residing in the paste destination. To replace track material, use the Paste command instead.

**To merge MIDI data:**

1. If desired, set the Edit mode to Grid to constrain the selection to the current Grid value.
2. Drag with the Selector in the track to select the MIDI notes you want to merge.

– or –

Use the Grabber to select one or more MIDI regions (or a group of MIDI notes).

Choose Edit > Cut to remove the selection and place it on the Clipboard.

– or –

Choose Edit > Copy to place the selection on the Clipboard without removing it.

4. With the Selector, click in a MIDI track at the point where you want to merge the material.

5. Choose Edit > Merge Paste. The Clipboard’s contents are pasted at the insertion point, without removing the existing material already residing there.

If any portion of the material is pasted outside of existing regions, a new region is created for the data.

**Editing Stereo and Multichannel Tracks**

Regions on individual channels within stereo and multichannel tracks cannot be independently selected. All selections for these tracks are time-based, which means that selections made with the Selector and Grabber extend to each channel in the track.

When regions in multichannel tracks are edited with the Trimmer or dragged with the Grabber, material on all channels is affected equally as a group.

**Split Selected Tracks**

To edit a specific channel within a stereo or multichannel track without affecting the other channels, you can split the track into separate mono tracks. Once the desired edits have been made to the separated material, you can then drag or copy it back to the original multichannel track.
To split a stereo or multichannel track:

1. Select the track you want to split by clicking its name in the Edit or Mix window. To split multiple tracks, Shift-click additional tracks.

2. Choose File > Split Selected Tracks Into Mono. Regions from the channels on the selected tracks are placed on new, mono audio tracks.

Names for the new tracks are based on the source track name and channel suffix. For example, if a stereo track called “Funkit” is split, two new tracks called “Funkit.L” and “Funkit.R” are created.

Output and send assignments and volume and pan settings are retained in the new tracks. Mono equivalents of stereo and multi-mono plug-in assignments are assigned in the new tracks; multichannel plug-in assignments are not assigned in the new tracks.

Dragging Regions to and from Stereo and Multichannel Tracks

![Dragging a stereo region to two mono audio tracks](Dragging a stereo region to two mono audio tracks)

When dragging regions to or from stereo or multichannel tracks, the following rules apply:

- Provided the number of tracks and channels are the same for the source and destination, you can drag regions between multichannel tracks and mono tracks.
- The source and destination for dragged regions can be mixed. For example, you can drag regions from a 5.0 track (containing five channels) to a stereo track and three mono audio tracks.
- When dragging multichannel regions to mono tracks, the destination tracks must be adjacent.
- When dragging regions from mono tracks to a multichannel track, the source tracks need not be adjacent.

Multichannel regions can also be dragged from the Audio Regions List, to multichannel tracks of the same format, groups of mono audio tracks, or a combination of both.

Conversely, a collection of single, mono regions can be dragged from the Audio Regions List to multichannel tracks—provided the dragged number of regions matches the number of channels in the destination track.

Processing Audio with AudioSuite Plug-Ins

The AudioSuite plug-ins included with your Pro Tools system can be used to process and modify an audio region or entire audio file. You may do this in order to apply a specific AudioSuite process, such as Normalization or DC Offset Removal, that you know you will always want applied to the audio.

Refer to the DigiRack Plug-Ins Guide for more information about AudioSuite plug-ins.
Waveform Repair with the Pencil Tool

The Pencil tool allows you to destructively “re-draw” waveform data. This tool is most commonly used to repair a pop or click in an audio file. A pop or click appears as a sudden sharp spike in a waveform. This tool only becomes active when the Edit window is zoomed in to the sample level.

⚠️ The Pencil tool is a destructive editing tool that permanently modifies the audio file on disk and should be used with caution.

Although you can Undo a Pencil tool edit, it is recommended that you create a backup copy of the target audio, before using the Pencil tool. You can do this by using the AudioSuite Duplicate plug-in.

To make a copy of an audio region:

1. Select the source region in the track’s playlist.
2. Choose AudioSuite > Duplicate.
3. In the AudioSuite dialog, make sure that Playlist is enabled as the processing preference, and that Use In Playlist is enabled.
4. Click the Process button.

The AudioSuite Duplicate plug-in creates a new audio file that is a duplicate of the original. The duplicate replaces the original on the track, and it is automatically named with the region name and the suffix DUPL.

To destructively edit an audio waveform with the Pencil tool:

1. Locate the area you want to edit.
2. Using the Zoomer tool or the Vertical Zoom buttons, zoom down to the sample level so the waveform appears as a continuous thin line. Adjust the Track Height, as necessary, to edit the waveform with greater precision.

⚠️ You can recall zoom levels with the Zoom Preset buttons (see “Zooming” on page 208), or with Memory Locations (see “Memory Locations and Markers” on page 300).

3. Select the Pencil tool.

4. Carefully draw with the Pencil by dragging over the desired area of the waveform.

Don’t over-edit or the results may be undesirable. You can use the Undo command to undo your previous edit.

Repairing a “pop” with the Pencil tool

Try to limit editing to smoothing over a very small problem area, and keep the “fixes” in character with the shape of the surrounding wave.

⚠️ If you have trouble zooming in far enough to perform Pencil editing, check the Edit window (session) length. Shorten the overall Edit window (session) length, if possible, until the Pencil tool becomes usable.
The Smart Tool

The Smart Tool lets you use the Selector, Grabber, and Trimmer, as well as create fades, without switching tools. Depending on where the cursor is placed in relation to a region or note, the Smart Tool automatically switches to the appropriate tool. For details, see “Using the Smart Tool” on page 265.

To temporarily switch the Smart Tool to the Scrubber, press Control (Macintosh) or the Start key (Windows).

Using the Smart Tool

With the Smart Tool you can instantly access the Selector, Grabber, and Trimmer, and you can also perform fades and crossfades. The position of the cursor in relation to a region or note, or within an automation playlist, determines how the Smart Tool functions.

To select the Smart Tool, click its icon in the upper left of the Edit window, or press F6+F7 (or F7+F8) simultaneously.

Smart Tool in Waveform View (or MIDI Track Regions View)

The following capabilities are available with the Smart Tool when working with audio tracks in Waveform or Blocks View, or MIDI tracks in Regions View:

- For the Selector, position the cursor over the middle of the region, in the upper half.
- For the Grabber, position the cursor over the middle of a region, in the lower half.
- For the Trimmer, position the cursor near the region’s start or end point.
- For a fade-in or fade-out, position the cursor near an audio region’s start or end point, near the top. Once the Fade cursor appears, drag into the region to set the fade length. The fade is created automatically with the Default Fade Settings (in the Editing Preferences).
- For a crossfade, position the cursor between two adjacent audio regions, near the bottom. Once the Crossfade cursor appears drag left or right to set the crossfade length. The crossfade is created automatically with the Default Fade Settings (in the Editing Preferences).

To temporarily switch the Smart Tool to the Scrubber, press Control (Macintosh) or the Start key (Windows). Make sure the Smart Tool is in the Selector position.
The Smart Tool in Notes View

The following capabilities are available with the Smart Tool when working with MIDI tracks in Notes View:

- For the Selector, position the cursor so it doesn't cover any notes.

To get the Selector while positioning the cursor over notes, press Command (Macintosh) or Control (Windows).

- For the Grabber, position the cursor over the note, near its middle.

To get the Marquee so you can select a group of notes, position the cursor so it doesn't cover any notes and press Command (Macintosh) or Control (Windows).

- For the Trimmer, position the cursor near the note's start or end point.

To temporarily switch the Smart Tool to the Pencil, press Control (Macintosh) or the Start key (Windows); for the Eraser, press Control+Option (Macintosh) or Start+Alt (Windows).

The Smart Tool in Automation and Controller Views

The following capabilities are available with the Smart Tool when working in automation and controller Views:

- For the Selector, move the cursor so it is positioned anywhere in the bottom 75% of the playlist.

- For the Grabber, press Command (Macintosh) or Control (Windows) to insert breakpoints. Continue pressing Command (Macintosh) or Control (Windows) after you begin editing for fine control; otherwise, release for coarse control.

Press Command+Shift (Macintosh) or Control+Shift (Windows) to vertically constrain movement.

- To edit existing breakpoints, move the cursor near a breakpoint and the Grabber will appear.

Press Shift to vertically constrain movement.

- For the Trimmer, position the cursor in the top 25% of the playlist to trim breakpoints. Press Command (Macintosh) or Control (Windows) after you begin trimming for fine control.

The Smart Tool with Stereo and Multichannel Tracks

When using the Smart Tool on stereo and multichannel tracks, individual channels cannot be independently edited. All edits affects all channels as a whole.

The tool switching for the Smart Tool in stereo and multichannel tracks is determined by the position within the entire track, and not within individual channels.

To temporarily switch the Smart Tool to the Pencil, press Control (Macintosh) or the Start key (Windows); for the Eraser, press Control+Option (Macintosh) or Start+Alt (Windows).
Chapter 18: Advanced Editing

Replacing Regions
(TDM Systems Only)

You can use the Replace Region function to replace multiple instances of a region in a playlist with another region that you Command-drag (Macintosh) or Control-drag (Windows) from the Regions List.

This is useful in post production if you use a sound effect, room noise, or atmosphere region many times in a session, and later decide to replace one or all of the original regions with a different region.

This is also useful in music production if you want to replace a certain loop or sample (for example, a drum beat) with a new one. You can use this compositionally, if you know the tempo of a section or session, to create a scratch piece with “rough” regions of the correct length, and later replace them with “final” regions of the same length.

The following options are available in the Replace Region dialog:

- **Replace Original Region** Replaces only the selected region with the replacement region dragged from the Regions List.

- **Replace All Regions That Match Original** Replaces all regions that fit the Match criteria and the Find Match On criteria with the replacement region from the Regions List.

- **Match: Start Position** Replaces all regions that have the same original start time as the selected region. This includes regions that may have been auto-created when trimming end points.

- **Match: End Position** Replaces all regions that have the same original end time as the selected region. This includes regions that may have been auto-created when trimming start points.

- **Match: Region Name** Replaces all regions that have the same name as the selected region.
Region matching uses all specified Match criteria. For example, if you select Start Position and End Position, all regions from the same original audio file as your selection with the same original start and end times will be replaced.

**Find Match On: This Track Only** Replaces regions that fit the Match criteria and are on the same track as the original region.

**Find Match On: All Tracks** Replaces regions that fit the Match criteria for all tracks in the session.

**Fit To: Original Region Length** If the replacement region is smaller than the original region, the region is placed in the playlist and any remaining audio from the original region is removed.

If the replacement region is larger than the selection, it is placed in the playlist and trimmed to fit within the length of the original region.

**Fit To: Original Selection Length** When the playlist selection extends beyond the original region, the replacement region (if larger than the original region) is trimmed to fit within the selection.

**Fit To: Replacement Region Length** The replacement region is placed in its entirety, regardless of the length of the original region or selection.

The Replace Region function only works on a selection that includes a single region on one track. The function is not available when the playlist selection includes the start points for two or more regions. Also, if the selection is across several tracks, only the selection in the first (top) track is used.

**To replace regions:**

1. Select a region in a track’s playlist that you want to replace. If desired, the selection can extend beyond the region’s end point, to include material from the replacement region that is longer than the original region.

2. Command-drag (Macintosh) or Control-drag (Windows) the replacement region from the Regions List to the selected region. The Replace Region dialog opens.

3. If you want to replace only the original region, select Replace Original Region.

   – or –

   If you want to replace multiple regions, select Replace All Regions That Match Original, and set the Match criteria.

4. Select whether to apply the replacement to all tracks, or only to the track with the current selection.

5. Select whether to fit the replacement regions to the current selection, the entire region, or the entire replacement region regardless of the destination length.

6. When you have set all the options, click OK.

**Replace Region and Multichannel Tracks**

The Replace Region command supports dragging multichannel regions from the Audio Regions List to multichannel tracks, provided they are the same format.

For example, you can replace a stereo region, selected in a stereo audio track, with another stereo region from the Audio Regions List. But you cannot replace it with two mono audio regions.
In addition, replacing regions in multiple mono tracks with multichannel regions is not supported.

**Repeat Paste To Fill Selection**  
*(TDM Systems Only)*

The Repeat Paste To Fill Selection command allows you to automatically fill a selection with audio or MIDI data without requiring you to duplicate the regions manually. To use Repeat Paste, copy an audio or MIDI region, then make a selection and use the command to fill the selection. When pasting audio regions, you are prompted to specify a crossfade to be used for the pasted regions.

If you fill an area that is an exact multiple of the copied region size (for example, filling 16 bars with a 4-bar loop), the copied selection is pasted in exactly as many times as it takes to fill the selection. If you fill an area that is not an exact multiple of the copied region size (for example, filling 15 seconds of a track with a 2-second atmosphere or room noise region), the remaining selection area is filled with an automatically trimmed version of the original selection.

**To fill a selection with Paste to Fill:**

1. Select the audio or MIDI region you want to copy and choose Edit > Copy.
2. Select the area you want to fill using the Selector and choose Edit > Repeat Paste To Fill Selection.
3. If pasting audio regions to larger areas, the Batch Fades dialog opens. Configure the dialog as desired to insert crossfades between each pasted region, then click OK.
   - or -
   If you do not want crossfades for the pasted audio, click Cancel in the Batch Fades dialog.

**Compress/Expand Edit To Play**  
*(TDM Systems Only)*

When the Edit and Timeline selections are unlinked, you can compress or expand an audio selection to fit the Timeline selection. This feature works by using the Time Compression/Expansion plug-in to expand or compress the selected audio material.

**To fit an Edit selection to the Timeline:**

1. Deselect Operations > Link Edit and Timeline Selection.
2. With the Selector, select the audio material to be compressed or expanded.
3. In any Timebase Ruler, select the time range where you want to fit the audio material.
4. Choose Edit > Compress/Expand Edit To Play. The Edit selection is compressed or expanded to the length of the Timeline selection.
**Compress/Expand Edit to Play on Multiple Tracks and Channels**

The Compress/Expand Edit Play command can be used on multichannel selections, and selections across multiple tracks.

However, all regions are compressed or expanded equally by the same percentage value, based on Edit selection range. This ensures that the rhythmic relationship between the different channels or tracks is retained.

**Fitting an Audio Region to an Edit Selection**

Regions can be dragged from the Audio Regions List to fit within an Edit selection. The dragged region is compressed or expanded to fit within the selection. This feature uses the Time Compression/Expansion plug-in to expand or compress the audio region.

**To fit an audio region to an Edit selection:**

1. With the Selector, select the desired time range in an audio track.

2. Command-Option-drag (Macintosh) or Control-Alt-drag (Windows) the region from the Audio Regions List to the track with the selection. The start of the region is positioned at the selection start, and the region is compressed or expanded to match the length of the selection.

**Fit to Selection on Multiple Tracks and Channels**

The Fit to Selection command supports dragging multiple regions from the Audio Regions List to multiple tracks, or multichannel tracks.

However, all dragged regions are compressed or expanded equally by the same percentage value, based on length of the region last clicked before dragging.
Chapter 19: Fades and Crossfades

Using Crossfades

You can quickly and easily crossfade between two adjacent audio regions. Crossfading is the process of fading two regions of audio to prevent pops, clicks, or sudden changes in sound. Crossfades have many applications, from smoothing transitions between regions to creating special audio effects. The crossfade duration, position, and shape are all user-definable.

Crossfades are computed and written to disk. Crossfades that are written to disk are stored in a folder named “Fade Files” within the session folder. When you play back your track, Pro Tools reads and plays back the crossfade file from disk.

Pro Tools does not allow you to replace fade-ins and fade-outs with crossfades. To add a crossfade between regions, any existing fade-ins and fade-outs between the regions must first be deleted.

Pro Tools TDM systems include an Auto Fade feature that provides real-time fades without processing them to disk. See “Using AutoFades” on page 280.

About Crossfades and Curves

To create a crossfade between two regions, use the Selector to select across the end point of the first region and the start point of the second. The length of the selection determines the length of the crossfade. Though fades may appear to be discrete regions, they cannot actually be separated from the regions in which they were created. You can, however, create fade-ins and fade-outs for individual regions (see “Creating Fades at the Beginnings and Ends of Regions” on page 279).

You can use the Fades dialog to select, view, and manipulate the curves used to perform the crossfade. Different volume curves can be assigned to the fade-out and fade-in portions of crossfades. The Fades dialog can also render a preview of the fade.

The following examples illustrate common crossfade types, and explain how the type of selection you make determines the character of the crossfade.

Since crossfades are created by fading between overlapping audio material, a crossfade cannot be performed on regions that do not contain audio material beyond their region boundaries.
**Standard Crossfade (“Centered”)**

![Diagram of Standard Crossfade]

This type of selection creates a crossfade on both sides of the splice point, which affects the volume of region 1 and region 2. It is the most common type of crossfade.

This crossfade type requires that region 1 contain audio material beyond its end point, and region 2 contain audio material before its start point.

**Pre Crossfade**

![Diagram of Pre Crossfade]

This type of selection creates a crossfade before the splice point. This lets you maintain the volume of the very beginning of region 2 instead of fading across it, which is useful if there is a strong attack at the beginning of region 2 that you want to preserve. When making selections for crossfades that occur on the border of two regions, you can use the Tab key to move the cursor to the exact beginning or end of a region.

This crossfade type requires that region 2 contain audio material before its start point.

**Post Crossfade**

![Diagram of Post Crossfade]

This type of selection creates a crossfade after the splice point. It is useful if you want to maintain the amplitude of region 1 until its very end. When making selections for crossfades that occur on the border of two regions, you can use the Tab key to move the cursor to the exact beginning or end of a region.

This crossfade type requires that region 1 contain audio material beyond its end point.
The Fades Dialog

When choosing the Edit > Fades command you can use the Fades dialog to select, view, and preview the crossfade, and to edit the curves used to perform the crossfade.

The controls in the Fades dialog include:

Audition

Click this button to audition your crossfade. Pro Tools plays the audio in one of two ways, depending on your system:

- Pro Tools TDM and LE systems allow crossfade auditioning directly from your audio interface outputs.

Older Pro Tools systems such as Pro Tools III on Macintosh use Apple’s Sound Manager to audition crossfades. Use the Digidesign Sound Drivers (automatically installed with Pro Tools) to audition via your audio interface outputs. Use the Macintosh Sound Control Panel to set the Output choice to Digidesign Sound Drivers. (If you do not use the Sound Drivers, you will hear crossfades through the Macintosh’s audio output.)

View First Track

If you are fading between more than one track, this button allows you to view and preview the audio of the first pair of adjacent tracks.

View Second Track

If you are fading between more than one track this button allows you to view and preview the audio of the second pair of adjacent tracks.

View Both Tracks

Click this button to display the waveforms of the first two adjacent tracks in a multitrack fade.

Fade Curves Only

Click this button to display the specified fade curves without showing the actual audio waveforms. This is the default view when you open the Fades dialog.

Fade Curves and Separate Waveforms

Click this button to display the specified fade curves along with separate views of the fade-in and fade-out waveforms.
Fade Curves and Superimposed Waveforms

Click this button to display the specified fade curves along with superimposed views of the fade-in and fade-out waveforms.

Fade Curves and Summed Waveform

Click this button to display the specified fade curves along with a single waveform representing the summation of the crossfaded audio.

Zoom In

Click this button to scale the view of the waveform’s amplitude upwards. Command-click (Macintosh) or Control-click (Windows) for the default view scale.

Zoom Out

Click this button to scale the view of the waveform’s amplitude downwards. Command-click (Macintosh) or Control-click (Windows) for the default view scale.

Fade Out Shape Parameter

The Out Shape parameter allows you to choose the shape of the fade-out from region 1.

Standard

Selects a single continuous fade curve. This creates a general-purpose fade that can be edited by dragging the curve itself.

S-Curve

Selects an S-shaped curve, which inverts its beginning and end characteristics. This makes it possible to fade out faster at the curve’s start and slower at its end, for example. S-shaped curves can be useful with material that is difficult to crossfade effectively. S-curves can be edited by dragging the curve in the curve editor.

Preset Curves

Seven commonly used preset curves are provided for fast crossfade creation. These can be edited by dragging the end points of the curve in the curve editor portion of this dialog. The seven presets are as follows:

- Preset Curve 1 keeps region 1 at full volume throughout the crossfade, then immediately drops the volume at the end of the crossfade.

- Preset Curve 2 fades out region 1 relatively slowly, keeping the volume fairly high throughout the duration of the fade.

- Preset Curve 3 fades out region 1 slightly faster, keeping the volume slightly lower during the fade.

- Preset Curve 4 fades out region 1 with a linear fade. This is the default curve.
Chapter 19: Fades and Crossfades

Preset Curve 4

- Preset Curve 5 fades out region 1 quickly at the beginning of the crossfade.

Preset Curve 5

- Preset Curve 6 drops the volume of region 1 even more quickly at the beginning of the crossfade.

Preset Curve 6

- Preset Curve 7 silences region 1 at the beginning of the crossfade.

Preset Curve 7

**Link Parameters**

The Link parameter links the selected fade-out and fade-in curves. If you adjust one curve, the corresponding curve also adjusts. This ensures that the resulting crossfade is an equal power or equal gain crossfade, depending on which you select.

**Equal Power** Recommended for material that is not phase coherent, as in the case of a crossfade between two completely different types of material. Use this option to avoid the volume drop that can occur with an Equal Gain crossfade. With this fade, you can Option-click (Macintosh) or Alt-click (Windows) the fade curve to reset it to its default shape.

**Equal Gain** Recommended for material that is phase-coherent or nearly phase-coherent, as in the case of a crossfade between identical regions/instruments (for example, a repeated drum loop). Use this option to avoid clipping that can occur when using an Equal Power crossfade. With this fade, you can Option-click (Macintosh) or Alt-click (Windows) the fade curve to reset it to its default shape.

**None** Disables linking between the fade-out and fade-in curves, and lets you freely adjust them separately, including start and end points. This option also allows you to create custom crossfade shapes. To edit only the fade-in portion of the curve, press Option (Macintosh) or Alt (Windows) while dragging. To edit only the fade-out portion of the curve, press Command (Macintosh) or Control (Windows) while dragging.

*Adjusting the end point of a fade curve*
Use Dither

Dither option for Fade

The Use Dither option turns on a preset, noise-shaped dither function that improves audio performance when fading in or fading out of silence, and crossfading between low amplitude regions. Dithering is usually not necessary when fading between two regions of high amplitude. You can disable Dither while editing your crossfades in the Fades dialog to speed up previews and fade recalculation, then re-enable Dither to create the final crossfade.

Fade In Shape Parameters

Fade In Shape

The In Shape parameter allows you to choose the shape of the fade-in to region 2.

Standard Selects a single continuous fade curve. This creates a general-purpose fade that can be edited by dragging the curve itself.

S-Curve Selects an S-shaped curve, which inverts its beginning and end characteristics. This makes it possible to fade in faster at the start of the curve, and slower at the end. S-shaped curves are useful with material that is difficult to crossfade effectively. S-curves can be edited by dragging the curve in the curve editor.

Preset Curves Seven commonly used preset curves are provided for fast crossfade creation. These can be edited by dragging the end points of the curve in the curve editor portion of this dialog. The seven presets are as follows:

- Preset Curve 1 fades in region 2 at full volume immediately at the beginning of the crossfade and keeps it there throughout the crossfade.

- Preset Curve 2 fades in region 2 quickly in the beginning, reaching full amplitude fairly early in the crossfade.

- Preset Curve 3 fades in region 2 moderately fast.

- Preset Curve 4 fades in region 2 with a linear fade curve. This is the default curve.

- Preset Curve 5 fades in region 2 slowly at the beginning of the crossfade.

- Preset Curve 6 fades in region 2 even more slowly than the previous curve.
Preset Curve 7 silences region 2 until the end of the crossfade.

Typical Curve Combinations

Following are the available combinations of fade-out and fade-in curves.

**Linear Crossfade** This is a good general purpose crossfade with a smooth, even transition between region 1 and region 2.

**Equal Power Crossfade** This is a good general purpose crossfade useful in cases where a linear crossfade seems to create a noticeable drop in volume across the splice point.

**Overlap Fade** This combination of curves keeps both regions at full amplitude throughout the crossfade: region 2 “jumps in” at the beginning and region 1 “jumps out” at the end.

Fade and Crossfade Preferences

(TDM Systems Only)

You can set default fade and crossfade settings. These settings load as your “base” settings when you use the Create Fades command, and the Fade to Start and Fade to End commands.

To set the crossfade preferences:

1. Choose Setups > Preferences and click Editing.
2. Set the Pre-Roll and Post-Roll times for Fade previews.
3. Click Fade In and set the default shape for fade-ins, then click OK.
4. Click Fade Out and set the default shape for fade-outs, then click OK.
5. Click Crossfade and set the default shape for crossfades, then click OK.
6. Click Done.
Creating a Crossfade

To create a crossfade between two regions:

1. With the Selector, click at the point where you want the crossfade to begin in the first region and drag to where you want it to end in the second region. Crossfade selections can begin and end anywhere in their respective regions.

2. Choose Edit > Fades > Create Fades.

3. Use the view buttons to adjust the view of the crossfade. It may take a few moments to calculate the waveform display for long selections.

4. Select an Out Shape and an In Shape.

5. Choose a Linking option.

6. Click the Audition button, or play the session, to hear the crossfade. For long crossfades, it may take Pro Tools a few moments to calculate and load the audio into playback RAM.

7. Adjust the curves by choosing different preset shapes with the Out Shape and In Shape pop-up menus.

   – or –

   Drag the Fade In/Out curves to the desired shape. By choosing None as the Linking option, you can drag the beginning or end points of a fade curve to adjust its beginning or end point.

8. Click the Audition button, or play the session, to hear the crossfade again.

9. When the crossfade is right, click OK. The fade is calculated and written to disk, but the audio files and regions remain unchanged. Crossfades are stored in the Fades Folder within the session folder.

  💡 Crossfade lengths can later be resized with the Trimmer.

To remove a crossfade:

- Select the area of the track containing the crossfades you want to delete and choose Edit > Fades > Delete Fades.

   – or –

- Select the crossfade with the Grabber and press Delete (Macintosh) or Backspace (Windows).

To trim a crossfade:

1. Select the crossfade with the Grabber, or double-click it with the Selector.

2. With the Trimmer, trim either side of the crossfade. The crossfade is recalculated to reflect the newly trimmed length.

Pre/Post Crossfade Selections

By making a selection that begins or ends precisely on the border of two regions, you can create “pre” or “post” crossfades. Use the Tab key to place the insertion point at the exact beginning or end of a region.

To create a pre- or post-crossfade:

1. With the Selector, click in the track that contains the regions you want to crossfade.

2. Press Tab to move forward to the next region boundary.

   – or –

   Press Option+Tab (Macintosh) or Control+Tab (Windows) to move back to the previous region boundary.

3. Shift-drag to adjust your selection, or press Shift+Tab to extend the selection forward to the next region boundary.

   – or –
Press Option+Shift+Tab (Macintosh) or Control+Shift+Tab (Windows) to extend the selection back to the previous region boundary.

4 Choose Edit > Fades > Create Fades.
5 Choose a fade type and click OK.

Creating Fades at the Beginnings and Ends of Regions

In addition to crossfades between regions, Pro Tools lets you create fade-ins and fade-outs at the beginnings and ends of regions.

On Pro Tools TDM systems, you can also use an automatic fade-in/out option, which applies real time fade-ins/outs to all regions during playback. These fades are not written to disk, but automatically applied during playback. See “Using AutoFades” on page 280.

Creating Fade-Ins and Fade-Outs

Depending on how you make the selection, you can position a fade-in/out at the exact beginning or end of a region, or position it so it extends into a blank area of the track. The length of the selection in the region determines the length of the fade-in/out.

You can also fade to the beginning or end of a region from an insertion point.

To create a fade-in:

1 Select the beginning of the region that you want to fade in. The selection must extend to the exact beginning of the region or a blank area prior to the region in the track.

2 Choose Edit > Fades > Create Fades. Choose your fade-in curve and other parameters.

3 Click the Audition button to hear the fade (or press the Spacebar to start and stop playback).

4 You can adjust the curve by dragging it or by choosing a different shape with the In Shape pop-up menu.

5 When you are finished, click OK. Pro Tools calculates the fade and writes it to disk. The chosen fade curve appears in the region.

To create a fade-out:

1 Select the end of the region that you want to fade out. The selection must extend to the exact end of the region or a blank area after the region in the track.

2 Choose Edit > Fades > Create Fades. Choose your fade-out curve and other parameters.

3 Click the Audition button to hear the fade (or press the Spacebar to start and stop playback).
4 You can adjust the curve by dragging it or by choosing a different shape with the Out Shape pop-up menu.

5 When you are finished, click OK. Pro Tools calculates the fade and writes it to disk. The chosen fade curve appears in the region.

! "Fade lengths can later be resized with the Trimmer."

**To fade from the insertion point to a region start point:**

1. Place the cursor at the desired location in the region.
2. Choose Edit > Fades > Fade To Start.
3. The fade is applied based on the Fade In Preferences.

**To fade from the insertion point to a region end point:**

1. Place the cursor at the desired location in the region.
2. Choose Edit > Fades > Fade To End.
3. The fade is applied based on the Fade Out Preferences.

---

**Using AutoFades**

*(Pro Tools TDM Only)*

On Pro Tools TDM systems, you can choose to have Pro Tools automatically apply real-time fade-ins and fade-outs to all region boundaries in the session. These fade-ins and fade-outs are performed during playback and do not appear in the Edit window, and are not written to disk.

This automatic fade-in/out option also has an effect on virtual track switching in a session. Whenever a lower-priority virtual track “pops thru” a silence in a higher-priority track on the same voice, a fade-in and fade-out is applied to the transition.

This feature is especially useful in post production situations such as dialogue tracking. For example, you could assign both a dialogue track and a “room tone” track with matching background to the same voice. You could then set the Auto-Fade option to a moderate length (4 ms or so) so that whenever a silence occurred in the dialog, playback would switch smoothly to and from the background track without clicks or pops.

Using automatic fade-ins/outs saves you the trouble of editing to zero-crossings or creating numerous rendered fades in order to eliminate clicks or pops in playback. However, since these autofades are not written to disk, those clicks or pops still exist in the underlying sound file. Consequently, those anomalies still appear if the Duplicate AudioSuite plug-in or the Export Selected as Sound Files command (from the Audio Regions List) are used to duplicate multiple regions as a continuous file. To render these real-time auto fades to disk, choose File > Bounce to Disk.
To set the length of automatic fade-ins/outs:

1. Choose Setups > Preferences and click Operation.
2. Enter a value between 0 and 10 ms for the Auto Region Fade In/Out Length. A value of zero (the default) means that no auto-fading will occur.
3. Click Done. The Auto Fade value is saved with the session, and is automatically applied to all free-standing region boundaries until you change it.

Creating Fades and Crossfades in Batches

In “Batch Mode” you can create many fades at once. You select across several regions and use the Create Fades command to create crossfades for each region transition. If your selection includes regions that already have crossfades, this feature allows you to modify them.

To create crossfades between multiple regions at once:

1. With the Selector, click in the first region in which you want to create a crossfade.
2. Drag to extend the selection to the last region you want to crossfade. Make sure that the selection includes the entire region.
3. Choose Edit > Fades > Create Fades.
4. Select whether you want to Create New Fades, Create New Fade-Ins & Outs, Adjust Existing Fades, or a combination of these options.

5. Choose the placement of your Fades. You can choose Pre-Splice, Centered, or Post-Splice.
6. Enter a crossfade length in milliseconds.
7. Click OK. Pro Tools creates the fades for the selected regions.

Batch Fades dialog

Batch Fades dialog

Selected regions for Batch Fades

Fade lengths can later be resized with the Trimmer.
Chapter 20: Managing Regions

Managing the regions in a session lets you keep system and storage requirements to a minimum, and simplify archiving requirements. This chapter describes several tools available to manage files and regions in Pro Tools sessions.

For more information on file management see the DigiBase Guide.

Strip Silence Window

The Strip Silence window contains the following four sliders that allow you to set the parameters by which silence will be defined for this operation. Adjusting these sliders will cause rectangles to appear in the selection (see Figure 17 on page 284), indicating areas of silence that will be removed.

StripThreshold Sets the amplitude threshold (from –48 dB to 0) for Strip Silence. Audio falling below this threshold is considered silence and removed. Audio above the threshold is retained and defined as new regions.

Minimum Strip Duration Sets the minimum duration (from 0 to 10,000 ms) that the material below the threshold must last to be considered silence.

Use this parameter to avoid countless small regions that may occur within a selection.

Region Start Pad Specifies a time value to be added to the beginning of each new region created with Strip Silence. This is useful for preserving musical material that falls below the threshold, such as the breath before a vocal phrase, or the finger slide before a guitar chord.

Region End Pad Specifies a time value to be appended to the end of each new region created with Strip Silence, thereby preserving the nuances in the decay of the material.

Stripping Silence from Regions

The Strip Silence command analyzes audio selections—across multiple regions or multiple tracks—and removes any areas of silence, dividing the selection into smaller regions and removing the silent areas.

You can use Strip Silence to automatically divide a track into regions, which is useful if you want to quantize audio to musical values, or locate sound effects to SMPTE locations. It is also useful if you want to get rid of silent areas to prepare for compacting audio (see “Compacting an Audio File” on page 289).

The Strip Silence window

Strip Silence window
Auto-Naming for Strip Silence

The Rename button in the Strip Silence window opens the following dialog, which determines how regions are named with the Strip Silence command.

<table>
<thead>
<tr>
<th>Rename Selected Regions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name:</td>
</tr>
<tr>
<td>Number:</td>
</tr>
<tr>
<td>Zeros:</td>
</tr>
<tr>
<td>Suffix:</td>
</tr>
<tr>
<td>Cancel</td>
</tr>
</tbody>
</table>

Strip Silence Renaming dialog

**Name** Specifies the base name for regions created with Strip Silence.

**Number** Specifies the number at which sequential auto-numbering starts.

**Zeros** Specifies the number of zeroes that occur before the appended auto numbers.

**Suffix** Specifies text appended to the end of the name, after the auto numbering.

For example, if you set the naming parameters to:

- Name = SFX
- Auto Number Start = 23
- Leading Zeros = 1
- Suffix = .Reel1

The names generated for regions created by Strip Silence would be:

- SFX023.Reel1
- SFX024.Reel1
- SFX025.Reel1
- SFX026.Reel1
- SFX027.Reel1
- SFX028.Reel1

Using Strip Silence

To strip silence from an audio selection:

1. Select one or more audio regions.
2. To select across multiple tracks, Shift-click in additional tracks.
4. To set the naming scheme for regions created with Strip Silence, click Rename to open the Renaming dialog. For details, see “Auto-Naming for Strip Silence” on page 284.
5. In the Strip Silence window, adjust the sliders for Strip Threshold and Minimum Strip Duration until the Strip Silence rectangles appear in the selection.

For finer resolution on these sliders, press Command (Macintosh) or Control (Windows) while adjusting them.

6. To retain material before and after the new regions, adjust the sliders for Region Start Pad and Region End Pad.
Once the Strip Silence rectangles encompass the audio that you want to keep, press the Strip button.

The material defined as silence is removed from the selection and new regions are created, which also appear in the Audio Regions List.

The Strip Silence command is nondestructive and does not remove audio data from parent audio files. In addition to the Undo command, you can use the Heal Separation command to restore stripped material.

Strip Silence works with stereo and multichannel tracks, and keeps their audio regions phase-coherent.

## Inserting Silence

The Insert Silence command is a simple and convenient way to insert silence in sessions. This command allows you to make a selection on a track (or tracks) and insert precisely that amount of silence. In Shuffle mode, all data on the track is shuffled later in the track by an amount equal to the selection.

In Grid mode, the Insert Silence command works just like the Clear command.

**Shuffle Mode** When inserting silence on multiple tracks in Shuffle mode, the following conditions apply:
- If any track is displayed as audio or MIDI data, the selected range is cleared of audio or MIDI data and all underlying automation data on all selected tracks.
- If all selected tracks are displayed as automation data, press Control (Macintosh) or the Start key (Windows) while choosing the Insert Silence command to insert silence on all automation playlists for all selected tracks.

**Slip Mode** When inserting silence on multiple tracks in Slip mode, the following conditions apply:
- If any track is displayed as audio or MIDI data, the selected range is cleared of audio or MIDI data and all underlying automation data on all selected tracks.
- If all selected tracks are displayed as automation data, silence is inserted only into the automation type visible on each track.
- If all selected tracks are displayed as automation data, press Control (Macintosh) or the Start key (Windows) while choosing the Insert Silence command to insert silence on all automation playlists for all selected tracks.

**To insert silence into a track:**
1. Make a selection on the desired tracks. The length of the selection determines the duration of the silence inserted.
2. Choose Edit > Insert Silence.

For Shuffle mode, Pro Tools inserts the selected amount of silence. In the process, it splits the regions at the beginning of the insertion point, and moves the new regions later in the track by an amount equal to the length of the selection.
Consolidate Selection Command

During the course of normal edit operations, a track may eventually contain many regions. However, once a track or track range (such as a verse or chorus) reaches a satisfactory state, you may want to consolidate its regions into a single region—thus making the material much more easy to work with.

When consolidating an audio track, a new audio file is written that encompasses the selection range, including any blank space.

To consolidate regions within a track:

1. Using the Grabber or Selector, select the regions you want to consolidate.
   - or -

   To select all regions in a track, triple-click in its playlist with the Selector.

2. Choose Edit > Consolidate.

A new, single region is created that replaces the previously selected regions, including any blank space. If working with an audio track, a new audio file is written (with the Audio Suite Duplicate plug-in).

When consolidating audio regions with the Consolidate Selection command, if the selection contains muted regions, the muted regions are treated as silence. Whether or not a track is muted, or contains Mute automation, does not affect the Consolidate Selection command.

Managing Regions

A typical session can become quite busy with many tracks and dozens of regions. There are a number of things you can do, however, to keep track of and manage a session’s regions, which include:

- Renaming existing regions
- Specifying how auto-created regions are named
- Hiding auto-created regions
- Removing unused regions

Digibase provides additional file management tools for Pro Tools. Refer to the Digibase Guide for more information.

Renaming Regions

In the course of a session you can rename regions to give them more descriptive names, or merely to shorten or simplify an existing name. When renaming a region that was auto-created from an edit, the region becomes a user-defined region and is displayed in the Regions List when auto-created regions are hidden.
Perhaps the easiest way to rename a region, if it resides in a track, is to double-click it with the Grabber. However, if the region does not yet reside in a track, or if you want to rename several regions, use the Rename Selected command.

**To rename one or more regions:**

1. If you will be renaming an auto-created region, make sure to select Display > Auto-Created Regions.
2. Select one or more region to be renamed in either the Audio or MIDI Regions List.
3. Choose Rename Selected from the Regions List pop-up menu.
4. When prompted, enter a new name for the region. If a whole-file audio region was selected, specify whether to rename just the region, or both the region and the disk file.
5. Click OK to rename the region. If renaming multiple regions, you are prompted, successively, to rename each region.

**Auto-Naming Parameters**

You can specify the auto-naming parameters for a region when new regions are created from it in the course of editing.

**To set auto-naming parameters for a region:**

1. Select a region in the Audio or MIDI Regions List.
2. Choose Auto Rename Selected from the Regions List pop-up menu.
3. In the Rename Regions dialog, enter the text to be used when naming regions created from the selected region.

![Rename Selected dialog](rename-selected-dialog.png)

**Rename Regions Selected dialog**

- **Name** Determines the root name for the auto-created regions.
- **Number** Sets the start number for the sequentially numbered new regions.
- **Zeros** Determines the number of zeros that occur before the auto numbers.
- **Suffix** Specifies text to be appended to the end of the name, following the auto numbering.
4. When you are finished, click OK to accept the new naming parameters.
Hiding and Removing Unwanted Regions

In the course of editing a session, the Audio and MIDI Regions Lists can fill up quickly with regions—ones you’ve created purposely and those that are automatically created by cutting, pasting, and separating other regions. Pro Tools allows you to hide or remove regions in your session so you don’t have to scroll through unnecessarily long Regions Lists.

Hiding Auto-Created Regions

You can hide regions that were automatically created during the course of editing.

To hide auto-created regions:

■ Deselect Display > Display Auto-Created Regions. With this option deselected, only user-created regions appear in the Audio and MIDI Regions List.

User-defined regions include:

• Whole-file regions
• Regions created during recording
• Imported regions
• Renamed regions
• Regions created as a result of AudioSuite processing
• New regions created with Capture Region and Separate Region commands
• Regions created by trimming whole-file audio regions

When auto-created regions are hidden, Pro Tools warns you if the number of auto-created regions exceeds a certain threshold, and gives you the option of deleting them. If you choose to delete them, all auto-created regions are deleted at the same time.

To ensure that you keep a particular auto-created region, turn it into a user-created region by renaming it. For details, see “Renaming Regions” on page 286.

Removing Unwanted Regions

You can locate and remove unused regions in a session with the Clear Selected command.

⚠️ The Clear Selected command cannot be undone.

To find and remove unused regions in a session:

1. For MIDI regions, choose Select Unused from the MIDI Regions List pop-up menu.
2. For audio regions, choose one of the following from the Select Unused submenu in the Audio Regions List pop-up menu:
   • Unused Regions
   • Unused Regions Except Whole Files
   • Offline Regions
3. After all unused regions are selected, choose Clear Selected from the Regions List pop-up menu.
4. Click Remove to remove the unused regions from the session.
   – or –

If clearing a whole-file audio region and you want to permanently remove the audio file from your hard drive, click Delete.

Clear Selected dialog (audio regions)
When deleting audio files for multiple regions, Pro Tools presents a warning dialog for each audio file.

**To bypass repeated warning dialogs:**

- Option-click (Macintosh) or Alt-click (Windows) the Delete button in the Clear Audio dialog. This permanently deletes each successive audio file from your hard drive (for each of the unused regions) without any further warnings.

Use this “power delete mode” with caution, since deletion of these files cannot be undone.

---

**Compact an Audio File**

The Compact Selected command deletes unused portions of audio files to conserve disk space, and to prepare for cleaner hard drive back-ups.

The Compact Selected command deletes audio if there are no regions referencing the data. For this reason you should delete any unused regions before compacting.

Because it permanently deletes audio data, the Compact Selected command should be used only after you have completely finished your editing and are sure that you have no further use for the unused audio data.

The Compact Selected command can pad the regions of the compacted file by a user-selectable amount. You may want to do this because Pro Tools requires extra audio data before and after audio regions to create crossfades. So, if your regions have crossfades, or if you want to pad the regions for the sake of any future trimming, you should enter an appropriate amount of padding (in milliseconds) to allow for this.

**To compact an audio file:**

1. Choose Select Unused > Regions from the Audio Regions List pop-up menu. All regions that have not been placed in a track in the current session are highlighted in the Audio Regions List.

2. To remove all of these unused audio regions, choose Clear Selected from the Audio Regions List pop-up menu. When the dialog appears, choose Remove.

3. In the Audio Regions List, select the region or regions you want to compact.

4. Choose Compact Selected from the Audio Regions List menu.

5. Enter the amount of padding in milliseconds that you want to leave around each region in the file.

6. Click Compact to compact the file or Cancel to cancel the command.

Once the Compact operation has been completed, the session is automatically saved.

*The Compact Selected command is destructive and cannot be undone. It permanently alters the original audio files. There is no way to recover data deleted with this command.*
Chapter 21: Conductor Tracks and Memory Locations

Tempo Events

Tempo events, which are displayed in the Tempo Ruler, can be inserted at the beginning of a session to replace the default tempo (of 120 BPM), and they can be inserted anywhere within the session for additional tempo changes. Tempo events cannot be inserted in Manual Tempo mode.

To display the Tempo Ruler:
- Select Display > Ruler View Shows > Tempo.

When in Manual Tempo mode, the Tempo Track is ignored and the session plays at the tempo defined in the Transport window. For details, see “Using Manual Tempo Mode” on page 148.

Current Tempo

As tempo events are encountered during playback, the session’s current tempo is displayed in the Transport window.

Inserting Tempo Events

To insert a tempo event:
1. Click in the Tempo Ruler where you want to insert the tempo event and then choose MIDI > Change Tempo.
   - or -
Click in the Tempo Ruler where you want to insert the tempo event and then click the Change Tempo button in the far left of the Tempo Ruler.

While pressing Control (Macintosh) or the Start key (Windows), move the cursor into the Tempo Ruler (where the cursor changes to the Grabber with a “+”) and click at the desired location.

Current tempo displayed in Transport window
2 In the Tempo Change window, enter the Location and BPM value for the tempo change.

![Tempo Change window]

Select the Snap To Bar option to place the inserted tempo event cleanly on the first beat of the nearest measure.

3 To base the BPM value on something other than the default quarter note, select a different note value.

4 Click Apply. The new tempo event is inserted and appears in the Tempo Ruler.

![Inserted tempo event]

Each tempo event has a small green triangle next to it that indicates its location. These triangles can be dragged to move the tempo event, and they can be double-clicked to edit the tempo event.

**Editing and Moving Tempo Events**

Existing tempo events can be moved, edited, deleted, and copied and pasted.

**To move a tempo event by dragging:**

- In the Tempo Ruler, drag the triangle for the tempo event left or right.

![Dragging a tempo event]

**To edit a tempo event:**

1 In the Tempo Ruler, double-click the tempo event.

2 In the Change Tempo dialog, enter a new Location or BPM value for the tempo event.

3 Click OK.

**To delete a tempo event:**

- While pressing Option (Macintosh) or Alt (Windows), move the cursor over the tempo event (where the cursor changes to the Grabber with a “−”) and click to remove it.

**To copy and paste several tempo events:**

1 If desired, set the Edit mode to Grid to constrain the selection to the current Grid value.

2 Drag in the Tempo Ruler to select the range of measures that includes the tempo events.
If an existing tempo event is near the beginning of the selection, press Command (Macintosh) or Control (Windows) so the Selector appears.

Press Option (Macintosh) or Alt (Windows) while dragging to select across all Conductor tracks.

3 Choose Edit > Copy.

4 Click in the Tempo Ruler at the point where you want to paste the tempo events.

5 Choose Edit > Paste. The contents of the Clipboard are pasted from the insertion point, replacing any existing tempo events.

To extend an Edit selection in a track to the Tempo Ruler:
1 Using either the Selector or Grabber, select a track range.

2 Shift-click in the Tempo Ruler.

Shift-click again in the Tempo Ruler to remove it from the selection.

To select all tempo events:
- Double-click with the Selector in the Tempo Ruler.

To clear a range of selected tempo events:
1 If desired, set the Edit mode to Grid to constrain the selection to the current Grid value.

2 Drag with the Selector in the Tempo Ruler to select the tempo events you want to remove.

3 Choose Edit > Clear to delete the selected tempo events.

Tempo and MIDI and Audio

When editing or moving tempo events, the Bars:Beats Ruler expands or shrinks, as necessary, to accurately reflect the placement of audio regions (which remain constant in terms of sample location). This, in turn, affects the relative placement of MIDI notes, and ensures that the visual relationship between MIDI and audio is accurate.

Figure 18 illustrates how MIDI notes shift and expand in relation to audio after the tempo is reduced.

Figure 18. Before and after change in tempo

After editing or moving a tempo event:
- Bar and beat locations for audio regions (which are sample-based) are adjusted for the new tempo. The audio region’s sample and SMPTE locations remain unchanged.
- MIDI notes (which are tick-based) remain at the same bar and beat location. In relation to audio, however, the notes shrink or expand based on the new tempo, and result in new sample and SMPTE locations for the note start and end times.
Default Tempo

New sessions open with a default tempo of 120 BPM. This tempo can be changed by inserting a tempo event at 1|1|000. However, this is not the same as inserting normal tempo events at other locations. The tempo event that resides at 1|1|000 is actually a Bar|Beat Marker (notice that it has a blue triangle).

The main distinction is that this Bar|Beat Marker can be dragged to any location within the session (such as to align with a particular SMPTE frame) to redefine where 1|1|000 is.

Identify Beat Command

Bar|Beat Markers

The Identify Beat command lets you establish a tempo/meter map for audio that was recorded without listening to the click, or for imported audio with unknown tempos.

The Identify Beat command analyzes a selection range (usually with a distinct number of beats or measures) and calculates its tempo based on the specified meter. In doing this, Bar|Beat Markers for the calculated tempo are inserted and appear in the Tempo Ruler at the beginning and end of the selection; in addition, meter events are inserted into the Meter Ruler.

Pro Tools TDM systems can use Beat Detective to generate Bar|Beat Markers within a selection that includes rhythmic changes on every beat and sub-beat. For more information, see Chapter 22, “Beat Detective.”

Bar|Beat Markers

Bar|Beat Markers look similar to tempo events, but instead have small blue triangles to indicate their location.

The key to accurately defining tempos for a range of audio with the Identify Beat command is to make sure that the initial selection represents an accurate length of beats or measures. In fact, you may want to first loop the selection on playback (see “Looping Playback” on page 234) to see if it plays cleanly without skipping. To avoid drift, and remain sample-accurate, select the audio material with the Time Scale set to Samples rather than Bars:Beats.

Identifying Beats

To add Bar|Beat Markers for a one-bar drum loop:

1. Place a one-bar drum loop at the beginning of an audio track.
2. Select Display > Samples. This ensures that the selected audio material will be sample-accurate.
3. Select the audio region with the Grabber and choose Edit > Identify Beat.
4 In the Bar|Beat Markers dialog, specify the start and end locations for the inserted Bar|Beat Markers. Since this example deals with a one-bar loop, enter 1|1|000 and 2|1|000.

5 If necessary, specify a time signature for the start and end range.

6 Click OK to automatically calculate the new tempo and insert the necessary Bar|Beat Markers and meter events. Any existing tempo and meter events residing within the selection are deleted.

When working with a selection, the Identify Beat command only calculates a single tempo for the selected range. If the tempo varies from measure to measure, or beat to beat, you’ll need to use the Identify Beat command for each tempo variance (making sure to accurately define a precise selection range or beat location for the tempo change).

**Inserting Bar|Beat Markers One at a Time**

**Audio Material with Varying Tempos**

You can insert Bar|Beat Markers one at a time by setting an Edit insertion point (instead of making a selection) before using the Identify Beat command. The ability to identify each beat, one at a time, is especially useful when working with audio with varying tempos.

For instance, if you have a measure that accelerates slightly, you could insert a Bar|Beat Marker on each beat (see Figure 19) so the tempo is accurately reflected.

After the Bar|Beat Markers are inserted, further adjustments in the tempo map are possible by dragging each of the Markers, as necessary, to align with the associated beat within the audio.
**Dragging Bar|Beat Markers**

Bar|Beat Markers can be dragged to new locations so they can align with audio regions that have been moved, or so that they can align to a slightly different point within an audio region. This results in neighboring MIDI data being adjusted to align with the new tempo map.

**Tempo Events Versus Bar|Beat Markers**

Bar|Beat markers and Tempo Events behave differently when you drag them in the Tempo Ruler.

**When dragging a tempo event:**

- The tempo event is placed at a new bar and beat location. The sample and SMPTE locations for the event are updated as well.
- The BPM value for the dragged tempo event remains constant, as do any other tempo events in the session.
- Neighboring MIDI events, along with the Ruler, shrink or expand as necessary to adjust for the new tempo location.

**When dragging a Bar|Beat Marker:**

- Its BPM value is recalculated along with the Bar|Beat Marker to its immediate left. Bar|Beat Markers to the right of the dragged marker remain unchanged.
- Its bar and beat location is dragged with the Bar|Beat Marker. If the Bar|Beat Marker was originally placed at 3|1|000, it remains there (unless it is edited).
- Its sample and SMPTE locations change, as calculated for by the new tempo for the Bar|Beat Marker.
- Neighboring MIDI events, along with the Bars:Beats Ruler, shrink or expand as necessary to adjust for the new tempo.

**Editing Bar|Beat Markers**

A Bar|Beat Marker can be edited to redefine its bar and beat location, which also redefines the start or end point of the range being analyzed for tempo. This is different from dragging a Bar|Beat Marker.

**To edit a Bar|Beat Marker:**

1. In the Tempo Ruler, double-click the Bar|Beat Marker.
2. In the Identify Beat dialog, enter a new Location for the Bar|Beat Marker.
3. Click OK to recalculate the new tempo.

Like meter and tempo events, Bar|Beat Markers can also be deleted.

**To delete a Bar|Beat Marker:**

- While pressing Option (Macintosh) or Alt (Windows), move the cursor over the Bar|Beat Marker (where the cursor changes to the Grabber with a “−”) and click to remove it.
**Meter Events**

Meter events can be inserted at the beginning of a session to replace the default meter (of 4/4), and they can be inserted anywhere within the session for additional meter changes. Meter events are displayed in the Meter Ruler.

**To display the Meter Ruler:**
- Select Display > Ruler View Shows > Meter.

**Current Meter**

As meter events are encountered during playback, the session’s current meter is displayed in the Transport window.

**Inserting Meter Events**

**To insert a meter event:**

1. Choose MIDI > Change Meter.
   - or –
   Click the Change Meter button in the far left of the Meter Ruler.

2. In the Meter Change window, enter the Location and Meter for the meter change.
   - or –
   Select the Snap To Bar option if you want the inserted meter event to fall cleanly on the first beat of the nearest measure.

3. Select a note value for the number of clicks to sound in each measure. If desired, select the dot (.) option for a dotted click value.

   - For some meters, it may be desirable to use a dotted value for the click. For instance, if using a meter of 6/8, a dotted quarter note click (yielding two clicks per measure) is more suitable than a straight eighth note click (six clicks per measure).

   While pressing Control (Macintosh) or the Start key (Windows), move the cursor into the Meter Ruler (where the cursor changes to the Grabber with a “+”) and click at the desired location.
4 Click Apply to insert the new meter event. The new meter event is inserted and appears in the Meter Ruler.

Each meter event has a small yellow triangle next to it that indicates its location. These triangles can be selected for copying and pasting, and they can be double-clicked to edit the meter event.

**Editing Meter Events**

Existing meter events can be edited, deleted, and copied and pasted.

**To edit a meter event:**

1. In the Meter Ruler, double-click the meter event.
2. In the Change Meter dialog, enter a new Location or Meter for the event.
3. Click OK.

**To delete a meter event:**

- While pressing Option (Macintosh) or Alt (Windows), move the cursor over the meter event (where the cursor changes to the Grabber with a “-”) and click to remove it.

**To copy and paste several meter events:**

1. If desired, set the Edit mode to Grid to constrain the selection to the current Grid value.
2. Drag in the Meter Ruler to select the range that includes the meter events.
3. Choose Edit > Copy.
4. Click in the Meter Ruler at the point where you want to paste the meter events.
5. Choose Edit > Paste. The contents of the Clipboard are pasted from the insertion point, replacing any existing meter events.

**To extend an Edit selection in a track to the Meter Ruler:**

1. Using either the Selector or Grabber, select a track range.
2. Shift-click in the Meter Ruler.

Shift-click again in the Meter Ruler to remove it from the selection.

**To select all meter events:**

- Double-click with the Selector in the Meter Ruler.
To clear a range of selected meter events:

1. If desired, set the Edit mode to Grid to constrain the selection to the current Grid value.
2. Drag in the Meter Ruler to select the meter events you want to remove.
3. Choose Edit > Clear to delete the selected meter events.

Partial Measures

Aligning Beat 1 to a SMPTE Location

When scoring to film or video, you will often need to start a section of music at a precise SMPTE time code location. Since this location will usually not fall cleanly at the beginning of a measure, you can insert a meter event at the time code location where the music needs to start.

As necessary, Pro Tools will create a partial measure to accommodate the inserted meter event. When a meter event is preceded by a partial measure, the meter event is displayed in italics in the Meter Ruler.

Partial measure of 4/4

Partial measures can also occur when pasting meter events to locations other than beat one.

Renumbering Bars

You can use the Renumber Bars command to renumber all bars in the session, effectively changing the bar locations for all regions, meter and tempo events while leaving their position intact. In doing so, however, the SMPTE and sample locations of the session data are not changed.

To renumber bars:

1. Choose MIDI > Renumber Bars.
2. Specify the bar you want to renumber, along with the new bar number, then click Renumber.

Renumbering Bars dialog
Memory Locations and Markers

Each session can save up to 200 Memory Locations that can be used to recall:

- Markers to important locations in the session
- Edit selections across one or more tracks
- Record and play ranges, along with pre/post-roll times
- Track settings that include Show/Hide status, Track Heights, and zoom values
- Edit and Mix Groups enables

Memory Locations are viewed and sorted in the Memory Locations window, where they can be recalled by clicking the Memory Location.

With the Numeric Keypad Mode set to Classic, Memory Locations can be recalled from the numeric keypad by pressing the Memory Location number followed by period (.)

With the Numeric Keypad Mode set to Transport or Shuttle, Memory Locations can be recalled from the numeric keypad by pressing period (.), the Memory Location number, and period (.) again.

Properties of Memory Locations

When creating a new Memory Location (see “Creating Memory Locations” on page 302) you are prompted to define its Time Properties and General Properties.

With the Numeric Keypad Mode set to Classic, Memory Locations can be recalled from the numeric keypad by pressing the Memory Location number followed by period (.)

Time Properties

Under Time Properties, a Memory Location can be set to Marker, Selection, or None. This determines the type of Memory Location that is created. Each of these three Memory Location types can also save any combination of General Properties.

Marker Recalls a Timeline location whose reference can be either Bar|Beat (tick-based) or Absolute (sample-based). When recalling a Marker Memory Location, the playback cursor moves to the Marker’s location and the start and end times in the Transport window are also updated. If the Edit and Timeline Selections are linked, the edit cursor also moves to the Marker location.
Markers appear in the Markers Ruler with a thin yellow line extending down through all tracks in the Edit window (to assist in arranging and aligning track material). You can click on a Marker in the Markers Ruler to recall its location along with its stored General Properties.

**Selection** Recalls an edit selection or edit cursor location whose reference can be either Bar|Beat (tick-based) or Absolute (sample-based). A Selection Memory Location lets you store edit selections, for one or more tracks, that you return to often within a session. If the Edit and Timeline Selections are linked, a Selection Memory Location can recall record and play ranges.

Only contiguous selections can be saved with Memory Locations. Discontiguous selections, made with the Object Grabber, will be recalled as if the selections were made with the Time Grabber.

**None** Recalls no Time Properties and is therefore referred to as a General Properties Memory Location.

**Bar|Beat and Absolute Reference**

The Reference pop-up determines whether the Marker or Selection Memory Location is Bar|Beat or Absolute. When set to Bar|Beat, the Memory Location is tick-based and its bar and beat location remains constant if the tempo is changed—though its relation to audio is scaled, resulting in a new sample location.

When set to Absolute, the Memory Location is sample-based and its bar and beat location shifts if the tempo is changed—though its sample location remains constant, along with its relation to audio material.

In the Markers Ruler, Markers that are Bar|Beat appear as yellow chevrons, and Markers that are Absolute appear as yellow diamonds.

**General Properties**

Any of the three types of Memory Locations (Marker, Selection, and None) can store and recall any combination of the following General Properties:

**Zoom Settings** Recalls the horizontal and vertical zoom values for both audio and MIDI tracks.

**Pre/Post Roll Times** Recalls pre- and post-roll times (but not whether they are enabled). This property can be stored with a Selection Memory Location to recall record and play ranges along with pre/post-roll.

**Track Show/Hide** Recalls which tracks are hidden. Use this property to display groups of tracks for editing and mixing.

**Track Heights** Recalls all Track Heights. Use this option along with the Zoom Settings option to recall edit environments that are suited for particular tasks, such as editing down to the sample level or trimming MIDI notes.

**Group Enables** Recalls which Edit and Mix Groups are enabled. This option is helpful in recalling groups for particular edit and mixing operations, such as muting all drum tracks or fading a stereo pair.
Creating Memory Locations

Memory Locations can be created by pressing Enter on the numeric keypad, by Control-clicking (Macintosh) or Start-clicking (Windows) in the Markers Ruler, or by choosing the Add New Memory Location command from the pop-up menu in the Memory Locations window. The method you use will likely depend on the type of Memory Location you want to create.

When creating Memory Locations, the next available number is assigned to it (1–200). This number is used in recalling the Memory Location from the numeric keypad.

**To create a Marker Memory Location:**

1. Configure any session settings you will save with the Marker Memory Location, such as zoom settings, pre/post-roll times, Show/Hide status for tracks, Track Heights, and Edit and Mix Group enables.
2. Make sure to select Operations > Link Edit and Timeline Selection.
3. If the Markers Ruler is not displayed, select Display > Ruler View Shows > Markers.
4. Click with the Selector at the desired location in any track or Ruler. To place a Marker at the beginning of a region, select the region with the Grabber. Click the Marker Well button to the left of the Markers Ruler (or press Enter on the numeric keypad).

   ![Marker Well button](MarkerWellButton.png)

   **Marker Well button**

   – or –

   While pressing Control (Macintosh) or the Start key (Windows), move the cursor into the Markers Ruler (where the cursor changes to the Grabber with a “+”) and click at the desired location.

5. In the New Memory Location dialog, select the Marker option and specify the Reference as either Bar|Beat or Absolute.
6. If desired, enter a name for the new Marker and select any General Properties you want to save with the Marker.
7. Click OK. The Marker is created and appears in the Markers Ruler, and in the Memory Locations window.
To create a Selection Memory Location:

1. Configure any session settings you will save with the Selection Memory Location, such as zoom settings, pre/post-roll times, Show/Hide status for tracks, Track Heights, and Edit and Mix Group enables.

2. Select a range of material in one or more tracks.

3. Press Enter on the numeric keypad.  
   – or –

   From the pop-up menu in the Memory Locations window (click the Name button), choose Add Memory Location.

4. In the New Memory Location dialog, select the Selection option and specify the Reference as either Bar|Beat or Absolute.

5. If desired, enter a name for the new Memory Location and select any General Properties you want to save with it.

6. Click OK. The Selection Memory Location is created and appears in the Memory Locations window.

To create a General Properties Memory Location:

1. Configure any session settings you will save with the Selection Memory Location, such as zoom settings, pre/post-roll times, Show/Hide status for tracks, Track Heights, and Edit and Mix Group enables.

2. Press Enter on the numeric keypad.

3. In the Memory Location dialog, select the None option.

4. If desired, enter a name for the new Memory Location and select any General Properties you want to save with it.

5. Click OK. The General Properties Memory Location is created and appears in the Memory Locations window.

Creating Memory Locations on the Fly

When the Editing Preference for “Auto-Name Memory Locations When Playing” is enabled, Memory Locations can be created while playing without encountering the New Memory Location dialog. This option can also be selected from the pop-up menu in the Memory Locations window.

This capability is useful if you want to mark certain locations while listening during a record pass, or if you want to mark frame locations while viewing a video scene.

To create a Marker during playback:

1. From the pop-up menu in the Memory Locations window, select Default To Marker. This ensures that new Memory Locations default to being Markers.

2. From the pop-up menu in the Memory Locations window, select Auto-Name Memory Locations.

3. For inserted Markers to have a Bar|Beat reference, make sure to set the Time Scale to Bars:Beats.

4. Click Play in the Transport window.
5 When the location is reached, press Enter on the numeric keypad. A Marker is automatically created and appears in the Markers Ruler.

When auto-creating Markers, they are named and numbered as “Marker 1,” “Marker 2,” “Marker 3,” and so on.

When the option for Default To Marker is deselected, new Memory Locations default to whatever type was last created. Therefore, if a Selection Memory Location was created last, it will be the type that is created on the fly. In this case, the name for the created Memory Location is based on the start of the Edit selection using the time format for the Main Time Scale (such as “2|2|305” or “0:02.658”).

### Recalling Memory Locations

Memory Locations can be recalled from the Memory Locations window and from the numeric keypad. In addition, Marker Memory Selections can be recalled by clicking them in the Markers Ruler.

**To recall a Memory Location:**

1. If the Memory Locations window is not already open, choose Windows > Show Memory Locations to display it.

2. If recalling a Selection Memory Location that will define a record or play range, make sure to select Operations > Link Edit and Timeline Selection.

3. In the Memory Locations window, click the Memory Location to recall it.

   – or –

   With the Numeric Keypad Mode set to Classic, press the Memory Location number followed by period (.)

   – or –

   With the Numeric Keypad Mode set to Transport or Shuttle, press period (.), the Memory Location number, and period (.) again.

   > When recalling a Memory Location from the numeric keypad, the Memory Locations window does not need to be open.

**To recall a Marker from the Markers Ruler:**

1. If the Markers Ruler is not displayed, select Display > Ruler View Shows > Markers.

2. Click on the Marker. The playback cursor locates to the Marker and any General Properties stored with the Marker are recalled.

   > Even if the Markers Ruler is not displayed, Markers can be recalled from the Memory Locations window, or from the numeric keypad.

### Editing Memory Locations

Memory Locations can be renamed, edited, deleted, and copied and pasted.
To rename a Memory Location:

1. In the Memory Locations window, double-click the Memory Location you want to rename.
   – or –

If renaming a Marker Memory Location, double-click the Marker in the Markers Ruler.

2. Enter the new name for the Memory Location, and click OK.

To redefine the General Properties stored with a Memory Location:

1. As desired, make changes to the session’s zoom settings, pre/post-roll times, Show/Hide status of tracks, Track Heights, and Group Enables.

2. In the Memory Locations window, Control-click (Macintosh) or Right-click (Windows) the Memory Location you want to redefine.
   – or –

If changing a Marker Memory Location, Control-click (Macintosh) or Right-click (Windows) the Marker in the Markers Ruler.

3. In the Memory Location dialog, select the General Properties you want to save with the Memory Location.

4. Enter a new name for the Memory Location, if desired, and click OK.

To change a Memory Location from one type to another:

1. In the Memory Locations window, double-click the Memory Location you want to change.
   – or –

If changing a Marker Memory Location, double-click the Marker in the Markers Ruler.

2. In the Memory Location dialog, select either Marker, Selection, or None as the Memory Location type.

3. Enter a new name for the Memory Location, if desired, and click OK.

To change the Selection stored with a Memory Location:

1. If the Memory Locations window is not already open, choose Windows > Show Memory Locations to display it.

2. Select a range of material in one or more tracks.

3. In the Memory Locations window, Control-click (Macintosh) or Right-click (Windows) the Memory Location that you want to redefine.

4. Enter a new name for the Memory Location, if desired, and click OK.

To move a Marker by dragging:

1. In the Markers Ruler, drag the Marker left or right.

   If the Edit mode is set to Grid, the dragged event snaps to the current Grid value. If using Spot mode, the Spot dialog opens.

   **Dragging a Marker**

   If the Edit mode is set to Grid, the dragged event snaps to the current Grid value. If using Spot mode, the Spot dialog opens.
To align a Marker to a different location:

1. Make sure to select Operations > Link Edit and Timeline Selection.
2. In any of the Timebase Rulers, click with the Selector at the new location.
   – or –
   Click in the playlist for any track. To align the Marker to the start of a region, select the region with the Grabber.
3. In the Memory Locations window or the Markers Ruler, Control-click (Macintosh) or Right-click (Windows) the Marker Memory Location that you want to redefine.
4. Enter a new name for the Marker, if desired, and click OK.

Deleting Memory Locations

To delete a Memory Location:

- In the Memory Locations window, select the Memory Location and choose Delete Memory Location from the pop-up menu.
  – or –
- In the Memory Locations window, Option-click (Macintosh) or Alt-click (Windows) the Memory Location.

To delete all Memory Locations:

- In the Memory Locations Window, choose Delete All from the pop-up menu.
  – or –
- Option-Shift-click (Macintosh) or Alt-Shift-click (Windows) any Memory Location in the Memory Locations window.

To delete a Marker from the Markers Ruler:

- While pressing Option (Macintosh) or Alt (Windows), move the cursor over the Marker (where the cursor changes to the Grabber with a “-“) and click to remove it.

Copying Marker Memory Locations

To copy and paste a range of Markers:

1. If desired, set the Edit mode to Grid to constrain the selection to the current Grid value.
2. Drag in the Tempo Ruler to select the range of measures that includes the Markers.
   If the beginning of the selection includes a Marker, press Command (Macintosh) or Control (Windows) so the Selector tool appears.
3. Choose Edit > Copy.
4. Click in the Markers Ruler at the point where you want to paste the tempo events.
5. Choose Edit > Paste. The contents of the Clipboard are pasted from the insertion point, replacing any existing Markers.

To extend an Edit selection in a track to the Markers Ruler:

1. Using either the Selector or Grabber, select a track range.
2. Shift-click in the Markers Ruler.
   Shift-click again in the Tempo Ruler to remove it from the selection.

To select all Markers in the Markers Ruler:

- Double-click with the Selector in the Tempo Ruler.
Memory Locations Window

Memory Locations are listed, with their name and assigned number, in the Memory Locations window. To recall a Memory Location from this window, simply click it.

You can select viewing and sorting options, along with commands for creating and removing Memory Locations, from the pop-up menu in the Memory Locations window (obtained by clicking the Name button in the upper left).

Memory Locations Commands and Options

**Show Markers Only** When selected, only Marker Memory Locations are displayed in the Memory Locations window. However, even when Selection Memory Locations and General Property Memory Locations are hidden, they can still be recalled from the numeric keypad.

**Show View Filter Icons** When selected, the Memory Locations window provides an icon-based “View Filter” that allows you to show or hide Memory Locations based on the properties they contain. To show or hide Memory Locations containing a specific property, click the appropriate icon.

If an icon is disabled, all Memory Locations associated with that property are hidden. However, if a Memory Location contains other properties for an icon that is enabled, it is still displayed. When a view icon is enabled, it appears in color. When it is disabled, it appears gray.
In addition, the View Filter provides a handy reference for which properties are stored in each Memory Location (indicated by a row of icons for each Memory Location).

**Show Main/Sub Counter** When selected, a column appears in the Memory Locations window that displays the locations for Markers, and the start times for Selection Memory Locations. General Property Memory Locations display nothing in this column.

You can click at the top of these columns for a pop-up menu that will let you change the Main and Sub Time Scale.

**Sort by Time** When selected, Markers are sorted by their order in the Timeline, followed by Selection and General Properties Memory Locations, which are listed in the order in which they were created.

When Sort by Time is deselected, all Memory Locations are listed in the order of their assigned numbers.

**Add Memory Location** Choose this command to create a new Memory Location.

**Remove Memory Location** Deletes the currently selected Memory Location in the Memory Locations window.

**Delete All** Deletes all Memory Locations (Marker, Selection, and General Property) in the session.

**Default To Marker** When selected, new Memory Locations default to Markers, though in the New Memory Location dialog you can still define the new Memory Location as one of the other types.

**Auto-Name Memory Location** When selected, Memory Locations are created automatically without encountering the New Memory Location dialog. If the Default To Marker option is selected, a Marker Memory Location is auto-created. Otherwise, the Memory Location type is determined by whatever type (Marker, Selection, or None) was created last.
Chapter 22: Beat Detective

About Beat Detective
Beat Detective (TDM systems only) is a powerful tool for analyzing, editing, and manipulating audio with an inherent rhythmic character.

Beat Detective analyzes an audio selection, identifies its peak transients, and generates beat triggers based on the detected peak transients. From these beat triggers, Beat Detective can:

• Extract tempo and beat information to create Bar|Beat Markers that can be used to define the session’s tempo map. See “Generating Bar|Beat Markers with Beat Detective” on page 317.

• Extract tempo and groove information as groove templates, called DigiGrooves. These templates can be used in Beat Detective to apply to audio (TDM systems only). DigiGroove templates can also be used with Groove Quantize for MIDI data (all Pro Tools systems). See “DigiGroove Templates” on page 318.

• Separate the audio selection into discrete regions, and then conform (or “quantize”) separated regions to the session’s tempo map, or to groove templates (Pro Tools 6.0 only). See “Separating Regions with Beat Detective” on page 320 and “Conforming Regions with Beat Detective” on page 322.

Beat Detective and Source Material
Beat Detective is most effective with rhythmic audio material that has strong percussive attacks (including most instruments used in popular music, such as drums, guitar, or bass). Beat Detective will be less successful with audio material with soft attacks, or legato phrasing (such as strings and vocals).

The Beat Detective analysis will be less successful with audio material (TDM systems only) if:

• The material has soft attacks, or legato phrasing (such as strings and vocals).

• The material deviates too far from the rhythmic grid, or has tempo or meter changes that are too varied, to be useful with Beat Detective.

Uses for Beat Detective
Beat Detective can be useful in many situations, including:

Extracting Tempo from Audio Beat Detective can generate Bar|Beat Markers, from which it can extract the tempo—even if the audio contains varying tempos, or material with a swing feel. Additionally, once Bar|Beat Markers have been generated, other audio and MIDI regions can be quantized to them.
Creating DigiGrooves (Pro Tools 6.0 Only) Beat Detective can extract groove templates, called DigiGrooves, from an audio selection. DigiGrooves can be used to apply the groove, or feel of the captured passage to other audio selections (using Groove Conform) or MIDI data (using Groove Quantize).

Conforming Audio Regions Beat Detective can conform (“quantize”) audio with a different tempo, or with varying tempos, to the session’s current tempo map, or to a groove template (Pro Tools 6.0 only).

“Tighten Up” Performances Beat Detective can be used to improve the timing of some audio material by calculating and extracting its average tempo, and then conforming its rhythmic components—regions separated with Beat Detective—to the session’s tempo map.

Loop Matching Since Beat Detective can extract tempo and beat information from audio, and conform audio to an existing tempo map or groove template, this makes it very useful for aligning loops with different tempos or grooves. If a loop is at a different tempo than the current session, Beat Detective lets you quickly separate each beat in the loop and conform them to the tempo map (as an alternative to time compressing or expanding the loop, which can alter the pitch and tone of the audio).

Remixes Beat Detective can be used for remixes or creating new rhythms. It can extract tempo from the original drum tracks, or in some instances the original stereo mix. New audio or MIDI tracks can then be conformed to the original material, or the original material can be conformed to new drum tracks, achieving an entirely new feel.

Smoothing Post Production Edits Beat Detective’s Edit Smoothing can be used to automatically clean up foley tracks that contain many regions requiring trimming and crossfading, effectively removing the gaps of silence between the regions (thus retaining the room tone throughout the track).

Beat Detective Requirements

Beat Detective is only available on Pro Tools TDM systems.

RAM Requirements for Beat Detective

Beat Detective operations can require a large amount of RAM, especially when working with multiple tracks and lengthy selections.

To avoid low memory situations with Beat Detective, do the following:

- If using Windows or Macintosh OS X and you begin to experience slower Beat Detective response, add more RAM to your computer.
- If using Macintosh OS 9, you should substantially increase the RAM allocated to Pro Tools. For sessions with eight or more tracks with selections of five minutes or longer, you should allocate 100 MB, or even more, to the Pro Tools application. For instructions on allocating additional RAM to Pro Tools, refer to your Getting Started Guide.
- If your computer does not have the extra RAM, work with shorter selections, or individual tracks.
- Set the Editing Preference for Levels of Undo to a smaller value (see “Levels of Undo and RAM” on page 201). Memory-intensive editing operations, such as Edit Smoothing with Beat Detective, can use up a large amount of memory when in the Undo queue.
The Beat Detective Window

The Beat Detective window appears differently in Pro Tools 6.0 from previous versions of Pro Tools, as shown in Figure 20, below.

To open the Beat Detective window:

- Choose Windows > Show Beat Detective.
- or -

- Press Command+8 (Macintosh) or Control+8 (Windows) on the numeric keypad.

Beat Detective is a floating window that can be left open while working. This lets you adjust the parameters in real-time during playback, while viewing the beat triggers that appear in your selection in the Edit window.

Beat Detective Modes

The Beat Detective window is divided into three sections: Mode, Selection, and Detection. Depending on the current mode, the other controls in the window change. The Selection options for Beat Detective are available in each of the modes.

The Beat Detective modes include the following:

**Bar|Beat Marker Generation** Generates Bar|Beat Markers corresponding to transients detected in the audio selection.

**DigiGroove Template Extraction (Pro Tools 6.0 Only)** Extracts the rhythmic and dynamic information from audio, and saves this information to the Groove Clipboard, or as a DigiGroove template.
**Region Separation** Separates and creates new regions based on transients detected in the audio selection.

**Region Conform** Conforms all separated regions within the selection to the current tempo map. In Pro Tools 6.0, Beat Detective can conform audio regions to groove templates (such as DigiGroove templates) in addition to standard quantization.

**Edit Smoothing** Fills the gaps between conformed regions by automatically trimming them, and inserting crossfades if desired.

---

**Defining a Beat Detective Selection**

Whether you will be generating Bar|Beat Markers, extracting a DigiGroove template, or separating regions to be conformed, you must always define the audio selection to be analyzed. The Beat Detective window provides tools to define and capture the selection range, time signature, and swing (sub-division) content for the selected audio.

To ensure the best possible results with Beat Detective, make sure the selected passage starts exactly on the attack of the first beat. Zooming in to the sample level to start the selection will help ensure there is no space before the first beat.

For Beat Detective to generate beat triggers that are metrically accurate, the length and meter of the selection must be correctly defined. In addition, the selection should not contain any meter or tempo changes.

Use Loop playback to check the accuracy of your selection.

---

**To define a selection for Beat Detective:**

1. In the Edit window, select a range of audio material in a single track or in multiple tracks.

   To keep the Edit selection intact while playing or looping from any location, deselect Operations > Link Edit and Timeline Selection.

2. Choose Windows > Show Beat Detective.

3. You must define or capture the selection every time you make a new selection or change the tempo map. To define the selection range, do one of the following:

   - If the tempo and meter of the audio selection do not match the session’s default tempo and meter, enter the Time Signature, and Start Bar|Beat and End Bar|Beat locations. For a four-bar selection that starts on beat 1, enter 1|1 and 5|1.

   Make sure the selection’s start and end points fall cleanly on the beat. To zero in on start and end points, zoom to the sample level and use the Tab to Transients option (see “Tabbing to Transients” on page 232).

   Save and recall an Edit selection by saving it as a Memory Location. See “Memory Locations and Markers” on page 300.
• If the tempo and meter of the audio selection do not match the session’s default tempo and meter, and you are unsure of the length of the material, enter the Time Signature and the Start Bar|Beat location; then start playback, and click the Tap button repeatedly to automatically calculate the End Bar|Beat. When using Tap with long selections, continue to tap until the End Bar|Beat stabilizes. Once stabilized, you may need to manually adjust the number to the nearest bar boundary.

• If the selection’s tempo and meter match the session tempo and meter (see “Calculating Tempo with Beat Detective” on page 313), and it aligns correctly with the session’s bars and beats, click the Capture Selection button. The correct Time Signature, and Start Bar|Beat and End Bar|Beat values will be filled in automatically.

To improve Beat Detective’s accuracy in analyzing swung notes, select the Contains option that indicates the smallest sub-division of the beat contained in the selection. The Contains options include eighth-note, sixteenth-note (the default setting), thirty-second-note, and triplet modifier. In Pro Tools 6.0, the selected Contains option determines the groove template grid locations for DigiGroove templates.

Beat Detective in Pro Tools 5.x only provides the thirty-second-note and triplet modifier.

Calculating Tempo with Beat Detective

If you know the meter, and start and end points of the audio selection, use Beat Detective to calculate its tempo.

To calculate a selection’s tempo with Beat Detective:

1. Make an audio selection in the Edit window and define the selection in the Beat Detective window as described in “Defining a Beat Detective Selection” on page 312.

2. Select Bar|Beat Marker Generation mode.

3. In the Detection section (Normal mode), click Analyze.

4. Set the Sensitivity slider set to 0%.

5. Click Generate.

As long as the audio material is correctly aligned with the session’s tempo map, use Capture Selection each time you make a new selection or make any changes to the tempo map (such as changing tempo or meter).

The Selection definition is not retained when a session is closed and re-opened.
Bar|Beat Markers are automatically generated at the beginning and end of the selection, indicating the material’s tempo and meter.

**Generating Beat Triggers**

Once you’ve accurately defined the selection range, Beat Detective can generate beat triggers based on detected peak transients. The range and type of transients found can be adjusted with the Detection settings, allowing you to zero in on the bars, beats, and sub-beats in the material, while avoiding the non-rhythmic content.

1. In the Edit window, make an audio selection.
2. In the Beat Detective window, select one of the following modes:
   - Bar|Beat Marker Generation
   - Groove Template Extraction (Pro Tools 6.0 only)
   - Region Separation
3. Define or capture the selection as described in “Defining a Beat Detective Selection” on page 312.
4. From the Analysis pop-up menu, choose one of the following detection algorithms:
   - High Emphasis, works well with high frequency, inharmonic material, such as cymbals and hi-hats, while avoiding low frequency material.
   - Low Emphasis, works well with low frequency material, such as bass guitar and kick drum, as well as with most harmonic material, such as piano or rhythm guitar.
5. Click the Analyze button.
6. Depending on the rhythmic content of the selection, set the Resolution to Bars, Beats, or Sub-Beats.
7. Adjust the Sensitivity slider until beat triggers appear on the beats and sub-beats in the selection.

Bar triggers are indicated with thick lines, beat triggers with medium lines, and sub-beat triggers with thin lines.

8. In Pro Tools 6.0, you can zoom to the sample level and click the Scroll Next button to scroll to the next trigger within the selection. To scroll to the previous trigger, Option-click (Macintosh) or Alt-click (Windows) the Scroll Next button (see “Navigating Consecutive Beat Triggers” on page 317). This is useful to confirm that the beat triggers are appearing in the appropriate locations. If false triggers appear between the beats or sub-beats (representing non-rhythmic material) delete them (see “Deleting Beat Triggers” on page 315), or reduce the Sensitivity value.
To display the metric locations for the triggers, select the Show Trigger Time option.

If you cannot get the beat triggers to appear at the right locations, repeat steps 4–9 trying the other Analysis algorithm (High or Low Emphasis). In addition, see the following tips.

**Tips for Getting Useful Beat Triggers**

Use the following tips to verify beat triggers:

- To focus on a particular area in the selection, unlink the Edit and Timeline Selections and set the playback range by clicking or dragging in any Timebase Ruler.
- Check the thickness of the beat triggers to see if they align properly with the audio material. Thick triggers fall on barlines, medium triggers fall on beats, and thin triggers fall on sub-beats.
- Select the option for Show Trigger Time and see if the (assumed) metric locations of the triggers align with the material. A false trigger should be moved or deleted because it can cause subsequent triggers to appear in the wrong locations (see “Editing Beat Triggers” on page 315).
- Consider whether lengthy selections should first be broken down into smaller selections, which could be more easily managed. For example, working in 8- or 4-bar sections might yield better results more quickly.
- For selections across multiple tracks, consider whether it may be easier to work with them individually, or in Collection mode (see “Detection (Normal) and Collection Mode” on page 326).

**Editing Beat Triggers**

Even though Beat Detective offers a great deal of flexibility in how transients are detected, there may be times when beat triggers must be deleted, moved, or manually inserted. Additionally, triggers can be promoted so they are retained at lower sensitivity settings.

**Deleting Beat Triggers**

False triggers, which do not represent an actual beat or sub-beat in the source material, may appear when raising the Sensitivity slider to detect quiet material. In these instances you can locate and manually delete any false triggers.

**To delete a beat trigger:**

1. With the Beat Detective window open, choose the Grabber tool in the Edit window.
2. Locate the false trigger you want to delete. Transients for false triggers usually have smaller peaks than the other trigger points, and typically fall between the sub-beats.
3. Option-click (Macintosh) or Alt-click (Windows) the trigger to delete it.

**Moving Beat Triggers**

You can adjust the placement of triggers to allow for the attack of their transients, or to compensate for an individual transient that is slightly ahead of or behind the beat.
To move a beat trigger:

1. With the Beat Detective window open, choose the Grabber tool in the Edit window.
2. Locate the beat trigger you want to move and drag it left or right.

Promoting Beat Triggers

To ensure that important beat triggers do not disappear when lowering the Sensitivity value, you can promote them. This is useful if a selection has numerous false triggers (too many to bother deleting) at a Sensitivity level where crucial, necessary beat triggers are also displayed. If lowering the Sensitivity slider causes the needed triggers to disappear, simply promote them first.

To promote a beat trigger:

1. Raise the Sensitivity slider until the desired transient is detected and a beat trigger appears.
2. Command-click (Macintosh) or Control-click (Windows) the beat trigger to promote it.
3. If necessary, repeat steps 1–2 to promote additional beat triggers.
4. Lower the Sensitivity slider to a value where the false triggers disappear.

Once beat triggers are promoted, they will only disappear if the Sensitivity value is set to 0%. To demote all beat triggers in the selection—returning them to their original state—click the Analyze button.

Inserting Beat Triggers

If an important beat or sub-beat is not detected, because it is too quiet, you can manually insert a beat trigger.

To insert a beat trigger:

1. With the Beat Detective window open, choose the Grabber tool in the Edit window.
2. Click in the selection where you want to insert the new trigger. After inserting a beat trigger, you can drag it left or right to adjust its placement (see “Moving Beat Triggers” on page 315).

If you click too close to an existing trigger, the existing trigger will be moved to the new location.

Redefining a Beat Trigger’s Metric Location

It is vital that beat triggers are accurately placed at the correct metric location. If a detected transient is slightly off the beat, Beat Detective may assign it, as well as other transients in the selection, to the wrong metric location.

For example, if you have a bass track where a note was intended to be a downbeat, but was played too early, Beat Detective may define its location as occurring a little before the down-
beat. If you then separate and conform the region containing this note, it will be moved to the wrong location. Subsequent regions may be moved to the wrong locations as well.

If a beat trigger is not assigned the correct metric location, relocate it using Identify Trigger.

**To change the metric location of a beat trigger:**

1. Double-click the beat trigger you want to relocate. The Identify Trigger dialog opens.
2. In the Identify Trigger dialog, enter the correct location for the trigger, then click OK.

**Generating Bar|Beat Markers with Beat Detective**

Once Beat Detective has accurately detected the peak transients in the audio selection and accurately generated beat triggers, the triggers can be converted to Bar|Beat Markers. Bar|Beat Markers generated by Beat Detective create a tempo map that can be used throughout the session.

Once beat triggers are accurately represented according to Bars, Beats, and Sub-Beats, other audio regions and MIDI notes can be conformed to the Bar|Beat Markers generated by Beat Detective.

If you want to match the audio material to the session’s existing tempo map or a groove template, do not generate Bar|Beat Markers from the material. Instead, use Beat Detective to separate and conform the material (see “Separating Regions with Beat Detective” on page 320).

**Navigating Consecutive Beat Triggers**

*(Pro Tools 6.0 Only)*

Use the Scroll Next button to move from the currently selected beat trigger to the next beat trigger. To move to the previous beat trigger, Option-click (Macintosh) or Alt-click (Windows) the Scroll Next button. This is particularly useful for editing consecutive beat triggers when zoomed in at the sample level.

**To generate Bar|Beat Markers with Beat Detective:**

1. In the Edit window, make an audio selection.
2. In the Beat Detective window, select Bar|Beat Marker Generation mode.
3. Define or capture the selection as described in “Defining a Beat Detective Selection” on page 312.
4. Set the Detection resolution to Bars or Beats, and configure the Detection settings so the selection’s peak transients are accurately detected (see “Generating Beat Triggers” on page 314).
5. Click the Generate button.
Bar|Beat Markers are generated, based on the beat triggers, and appear in the Tempo Ruler.

Working with Sub-Beats

Tempo is derived from Bar|Beat Markers. Groove, or feel, is derived from Sub-Beats—the deviation of subdivisions of the beat from the strict tempo grid determines the groove or feel.

To extract the groove from a selection, set the Detection Resolution to Sub-Beats. This ensures that the inner rhythms within each bar (if they indeed exist) are represented when generating Bar|Beat Markers. These Bar|Beat Markers can then be used to quantize other audio regions or MIDI tracks, thereby conforming to the Bar|Beat Markers generated by Beat Detective.

⚠️ When quantizing regions or MIDI notes to Bar|Beat Markers on sub-beats that represent a swing feel, make sure to use a straight quantize value (with the Swing option for Quantize disabled).

DigiGroove Templates

(Pro Tools 6.0 Only)

Beat Detective allows the fine timing nuances of a rhythmic performance to be extracted and saved as a groove template, called a DigiGroove template. DigiGrooves can be saved locally to the Groove Clipboard, or saved to disk as DigiGrooves.

Groove templates can be used to transfer the feel of a particular performance to:
- Selected audio regions using Groove Conform (see “Groove Conform” on page 323).
- Selected MIDI data using Groove Quantize (see “Groove Quantize” on page 363).

Groove templates are “quantization maps” derived from real musical performances. The rhythmic character of each performance is analyzed and stored as a groove template. Beat Detective analyzes an audio selection for transient peaks according to a defined threshold and maps the rhythmic relationships to a 960 parts per quarter note (ppq) template.

When create DigiGroove templates, Beat Detective also analyzes the dynamics of a performance. Accents and peak levels are incorporated into the groove template as velocity data, which can be applied to change the dynamics of MIDI tracks. Beat Detective translates amplitude to MIDI velocity according to a linear scale. For example, a 0 dBFS signal equals a MIDI velocity of 127, a signal at –6 dBFS equals a MIDI velocity of 64, a signal at –12 dBFS equals a MIDI velocity of 32, and –48 dBFS equals a MIDI velocity of 1.
Capturing this information is very important to preserving the feel of a performance, and can add life to MIDI tracks that lack dynamics.

⚠️ *Beat Detective does not capture duration data.*

**To extract a Groove Template:**

1. In the Edit window, make an audio selection. The selection should consist of one or more complete bars, starting and ending on downbeats.

⚠️ *When extracting Groove Templates, the captured selection must not include Bar|Beat Markers. Otherwise, the accuracy of the Groove Template will be compromised.*

2. In the Beat Detective window, select Groove Template Extraction mode.

3. Define or capture the selection as described in “Defining a Beat Detective Selection” on page 312.

4. Configure the Detection options so the selection’s peak transients are accurately detected (see “Generating Beat Triggers” on page 314).

5. Click the Extract button.

6. In the Extract Groove Template dialog, enter comments about the groove. You can enter a maximum of 255 characters to describe the groove. Comments can be viewed using the Show Info button in the Beat Detective window.

7. Do one of the following:
   - To save the extracted template for use in the current session, without writing the template file to disk, click Save To Groove Clipboard. (This template will be lost when you close the current session.)
   - To save the extracted template to disk in order to use it in other sessions or share it with other Pro Tools users, click Save To Disk. Enter a name for the template and click Save. (Do not change the location of DigiGroove template files and folders or they will not be available in your sessions.)
   - Click Cancel to cancel without saving the template.

💡 *Use folders and subdirectories to organize DigiGroove templates. However, be sure they are always located in Applications/Digidesign/Pro Tools/Grooves. Groove template files located elsewhere will not be available in either Groove Quantize or Beat Detective.*
Swing Content for Generating Groove Templates

When defining swing content of the selection, select the Contains eighth-note option if the audio selection has a heavily swung eighth-note groove. If the audio selection has relatively straight eighth-notes, use the Contains sixteenth-note option. This lets the resultant DigiGroove template be applied more easily elsewhere. Although a groove might be based upon non-swung eighth-note material, you might want to apply the template to material that contains sixteenth-notes. If a template only has eighth-note resolution, but the material being conformed contains sixteenth-notes, adjacent sixteenth-notes will be mapped to the same eighth-note location.

Groove Extrapolation

Beat Detective’s ability to extract tempo data from a wide range of material is enhanced by its powerful “groove extrapolation” logic. Groove extrapolation automatically generates beat triggers for inclusion in groove templates even if a peak transient is not detected. For example, a drum loop might not have a hit on beat 3, consequently no peak transient is detected and no beat trigger is generated. Beat Detective will extrapolate from other beat triggers in the selection and create a trigger for beat 3 in the groove template.

In addition, extrapolated triggers preserve the feel of triggers generated from detected peak transients. For example, if a bar of kick drum detected three beat triggers, all of which were 20 ticks ahead of the beat, any extrapolated beat triggers will also be mapped 20 ticks ahead of the beat.

Separating Regions with Beat Detective

Once beat triggers appear in your selection, they can be used to define start and end points for new regions that can be separated automatically. The new regions can then be conformed to the session’s existing tempo map, or to a groove template (Pro Tools 6.0 only).

If you want to clean up the timing for the selection, without affecting the tempo, make sure to first calculate the tempo by generating Bar|Beat Markers (see “Calculating Tempo with Beat Detective” on page 313).

To separate regions with Beat Detective:

1. In the Edit window, make an audio selection.
2. In the Beat Detective window, select Region Separation mode.
3. Define or capture the selection as described in “Defining a Beat Detective Selection” on page 312.
4. Configure the Detection options so the selection’s peak transients are accurately detected (see “Generating Beat Triggers” on page 314).
5. Click the Separate button.

Regions are separated based on the detected beat triggers.
Trigger Pad

When separating regions, the Beat Detective window displays an option called Trigger Pad. Enter a value (0–50 ms) in this field to pad region start points—where the point of separation is located in relation to the beat trigger (transient). This creates a space between the region start point and the region sync point, thereby ensuring that the attack portion of the material remains intact.

Separated region with 20 ms Trigger Pad

When conforming separated regions, the region sync point, not the region start point, determines where the region is placed.

Separating Multiple Tracks

You can use beat triggers from a single track, or subset of tracks, to separate a group of tracks.

In the following example, the defined selection is a drum loop consisting of two bars of 5/4. The kick, snare, hi-hat, and overhead microphones are recorded to separate tracks.

Analyzing the loop’s kick drum track, with Detection Resolution set to Beats, Beat Detective places beat triggers at the transients on beats 1 and 4 (see Figure 21).

Extending the selection to the snare, hi-hat, and overhead microphones tracks, and then performing the separation, results in separated regions in each of the drum tracks at the same location, based on the beat triggers from the kick drum track (see Figure 22).

The separated regions can then be conformed as a group.
You can also utilize Collection mode when working with multiple tracks. Collection mode lets you analyze and detect triggers on tracks individually, and if desired add only the unique triggers from the current track to the overall collection. For more information, see “Detection (Normal) and Collection Mode” on page 326.

**Conforming Regions with Beat Detective**

After regions have been separated with Beat Detective, the regions can then be conformed using one of two modes:

**Standard Conform** Uses the session’s current tempo map (Grid)

**Groove Conform (Pro Tools 6.0 only)** Uses groove templates.

Beat Detective will conform any selected region, whether or not it was separated with Beat Detective. However, in order to successfully conform regions with Beat Detective, the region start points must correspond to the start of the material that will align with the session’s bars and beats. This should generally not be a problem if the regions were separated with Beat Detective (rather than manually separated or trimmed).

**Standard Conform**

This is similar to using the Quantize Regions command, but with one important difference: With a single operation, Beat Detective can adjust the position of all regions, whether they have a straight or swing feel.

To conform regions using Standard Conform:

1. In the Beat Detective window, select Region Conform mode.
2. In Pro Tools 6.0, make sure Standard is selected.
3. In the Edit window, if not already selected, select the separated regions you want to conform. Make sure the selection’s start and end points fall cleanly on the beat.
4. In the Beat Detective window, define or recapture the selection as described in “Defining a Beat Detective Selection” on page 312.
5. To affect how strongly the regions are conformed to the Grid (tempo map), select the Strength option and specify a percentage value with either the slider or by typing in a value:
   - Lower percentage values preserve the original feel of the regions.
   - Higher percentage values align the regions more tightly to the tempo map, with 100% aligning precisely to the tempo map.

   To “tighten up” the original feel, while retaining it, set the Strength option to 85–88%.
6 To affect which regions are conformed, select the Exclude Within option and specify a percentage value with the slider or by typing in a value:

- Lower percentage values ensure that regions further away from the Grid are conformed, while those closer to the Grid are not.
- Higher percentage values ensure that regions closer to the Grid, as well as those further away, are conformed.

7 To achieve a swing feel for the conformed regions, select the Swing option and whether the swing is based on eighth-notes or sixteenth-notes, then specify a percentage value with the slider or by typing in a value:

- Smaller percentage values yield less swing, with 0% yielding none.
- Larger percentage values yield more swing, with 100% yielding a triplet, swing feel.
- Percentage values between 100–150 move the regions beyond a triplet, swing feel, toward the next sixteenth-note boundary (provided the Swing note value is set to eighth-notes).

8 Click the Conform button to automatically conform all regions in the selection.

9 Audition the new conformed regions by clicking Play in the Transport window.

10 If necessary, select Edit > Undo, and repeat steps 4–8 trying a different set of Conform settings.

- or -

If necessary, apply Edit Smoothing (see “Edit Smoothing” on page 325).

**Groove Conform**

*(Pro Tools 6.0 Only)*

Instead of using a grid based on the session’s tempo map, Groove Conform uses a grid based on a groove template, or DigiGroove. DigiGrooves can be used to apply the feel of a captured passage to the selected audio regions. For information about creating DigiGroove templates, see “DigiGroove Templates” on page 318.

**To conform regions using Groove Conform:**

1 In the Beat Detective window, select Region Conform mode.

2 Select Groove.

![Beat Detective, Groove Conform options](image)
3 In the Edit window, if not already selected, select the separated regions you want to conform. Make sure the selection’s start and end points fall cleanly on the beat.

4 In the Beat Detective window, define or recap­ture the selection as described in “Defining a Beat Detective Selection” on page 312.

When using Groove Conform, the captured selection must not include Bar|Beat Mark­ers. Otherwise, the accuracy of the Groove Template will be compromised.

5 From the Groove Template pop-up menu, select the Groove Clipboard or a saved groove template (for information on creating groove templates, see “DigiGroove Templates” on page 318).

6 To see comments about the selected template, click Show Info.

7 To affect how strongly the regions are con­formed to the groove template, select the Tim­ing option and specify a percentage value with either the slider or by typing in a value:
   - Lower percentage values preserve the original feel of the regions.
   - Higher percentage values align the regions more tightly to the groove templates grid, with 100% aligning precisely to the template grid.
   - If the slider is set to 200%, regions move to a location that is twice the difference between the original region location and the position of the referenced template event.

For example, if a note was played at Bar 1|1|060 (a 16th note), and the corresponding template event is at 1|1|073, a slider value of 100% results in the note being shifted to 1|1|073; a slider value of 200% shifts the note to 1|1|086.

8 If desired, enable the Pre-Process using Standard Conform option. With this option enabled, Beat Detective conforms regions to the current Standard Conform settings before applying the groove template. With material in which the performance was not accurate, Pre­Process using Standard Conform can lead to better results by ensuring that the performance is accurately mapped to the correct bars, beats, and sub-beats before the groove template is applied. Experimentation is the best way to determine when it is appropriate to use this option.

When conforming an audio passage to a heavily swung groove template, enabling Pre-Process using Standard Conform will often yield better results.

9 Click the Conform button to automatically conform all regions in the selection.

10 Audition the new conformed regions by clicking Play in the Transport window.

11 If necessary, select Edit > Undo, and repeat steps 4–9 trying a different groove template or Groove Conform settings.

   – or –

If necessary, apply Edit Smoothing (see “Edit Smoothing” on page 325).
**Edit Smoothing**

After regions are conformed, there may be gaps between the regions. These gaps can cause the material to sound unnatural on playback.

**Beat Detective, Smoothing options**

Beat Detective can automatically fill the gaps between regions, and even add crossfades if desired. This Edit Smoothing option can be used with regions that have been conformed, or with a track that contains many regions that need to be trimmed and crossfaded (such as in a sound effects track). This automated process of smoothing region edits can save many hours of tedious editing.

**To use Edit Smoothing on conformed regions:**

1. In the Beat Detective window, select Edit Smoothing mode.
2. Select one of the following Smoothing options:
   - Select **Fill Gaps** to trim region end points so that the gaps between regions are filled.
   - Select **Fill And Crossfade** to trim region end points and automatically add a pre-fade (in ms) directly before each region start point.
3. In the Edit window, if not already selected, select the range of conformed audio regions you want to smooth. Make sure the selection’s start and end points fall cleanly on the beat.
4. Click the Smooth button to smooth the edits for the selected regions.
5. Audition the results by clicking Play in the Transport window.
6. If necessary, select Edit > Undo, and repeat steps 2–5 trying a different Crossfade Length.

**Edit Smoothing Creates Sync Points**

After smoothing edits with Beat Detective, sync points (corresponding to the material’s start point) are automatically created for the conformed regions. This allows you to later conform the regions to a different tempo map or groove template, or use different Conform settings. However, sync points are only created as they are needed: If gaps between regions are created during Region Conform, Fill Gaps in Edit Smoothing mode will trim regions to fill the gap and a sync point will be created at the regions’ original start point. If there is no gap between regions, no sync point will be created by Edit Smoothing.

*For more information on region sync points, see “Defining Region Sync Points” on page 243.*
Consolidating Regions after Edit Smoothing

The process of separating, conforming, and smoothing with Beat Detective can leave tracks with many regions and many crossfades. If you are working with multiple tracks, the density of these edits may lead to system performance problems.

Once you are satisfied with the results from Beat Detective, it is recommended that you flatten the tracks with the Consolidate Selection command. For all regions selected, Consolidate Selection creates a single, contiguous audio file to reduce the session's edit density. See “Consolidate Selection Command” on page 286.

⚠️ Before consolidating a large selection across multiple tracks, make sure there is enough RAM available. See “RAM Requirements for Beat Detective” on page 310.

Detection (Normal) and Collection Mode

In some instances, it may be difficult for Beat Detective to successfully analyze multiple tracks with the same Detection settings. With Beat Detective’s Collection mode, you can collect a set of beat triggers from different tracks, each with different Detection settings, and use the collection of triggers to generate Bar|Beat Markers or DigiGroove templates, or separate new regions. Collection mode is the only way to analyze and create beat triggers on one track, and apply them to another track.

This method of selectively adding beat triggers from separate analysis passes on different tracks, until you get only the triggers you want, is potentially much more effective than manually deleting, inserting, or adjusting incorrect or false triggers.

Drum Tracks and Collection Mode

Suppose you have drum tracks for kick, snare, hi-hat, and overhead mics. If you analyze a selection across all of the tracks, you may get many false triggers when you raise the Sensitivity slider high enough to capture the hi-hat material (coming mainly from the tracks for the overhead mics).

However, if you analyze only the track for the overhead mics, the resulting beat triggers are slightly later than the material on the other tracks (since it will take more time for the sound to reach the overhead mics). If you then extend the selection to the other drum tracks and separate them, the regions from the kick, snare, and tom tracks will be cut slightly late (see Figure 23 below).

Using Collection mode, you can analyze each drum track separately, one at a time, optimizing the Detection settings for each track until you get the desired triggers. The triggers for each track can be added successively to the collection, or you can choose to collect only the unique triggers from a track. The collection of triggers that results can then be used to generate Bar|Beat Markers or a DigiGroove template, or separate new regions.

⚠️ Before consolidating a large selection across multiple tracks, make sure there is enough RAM available. See “RAM Requirements for Beat Detective” on page 310.

Figure 23. Overhead mics generate late beat triggers
Using Collection Mode

Collection mode is available in Bar|Beat Marker Generation, Groove Template Extraction, or Region Separation mode, and is accessed by clicking the Collection Mode button in the Detection section.

To use Collection mode:

1. In the Edit window, make an audio selection on a single track. Make sure the selection’s start and end points fall cleanly on the beat.

2. In the Beat Detective window, select one of the following modes:
   - Bar|Beat Marker Generation
   - Groove Template Extraction (Pro Tools 6.0 only)
   - Region Separation

3. Define or capture the selection as described in “Defining a Beat Detective Selection” on page 312.

4. Configure the Detection options so the selection’s peak transients are accurately detected (see “Generating Beat Triggers” on page 314).

5. Click the Collection Mode button.

6. In the Detection (Collection Mode) section, click Add to add all the current beat triggers to the collection.

7. Click the Normal Mode button and move the selection to the next track you want to analyze. Make sure to keep the selection range constant for each track.

   - With Commands Focus enabled, press “P” to move the selection up, or Semi-colon (;) to move the selection down. Hold down the Shift key to retain and add to the current selection.

8. Configure the Detection options so the selection’s peak transients are accurately detected (see “Generating Beat Triggers” on page 314).

9. Click the Collection Mode button again.
In the Detection (Collection Mode) section, click Add Unique Triggers to add only the **unique** triggers from the track to the collection (Pro Tools 6.0 only).

– or –

Click Add All (Pro Tools 6.0) or Add (Pro Tools 5.x) to add **all** triggers to the collection.

– or –

Click Clear All (Pro Tools 6.0) or Clear (Pro Tools 5.x) to clear **all** triggers from the collection.

Each new set of triggers added to the collection appears in a different color. If successive triggers in the collection are located closely together (for example, because of microphone leakage), Beat Detective keeps only the earlier triggers (see Figure 24).

Repeat steps 7–10 for each additional track you are analyzing.

The beat triggers stored in the Collection mode are saved with sessions. Therefore, when a session is opened later, the previous collection material is still there (until it is cleared).

Once the desired beat triggers have been added to the collection, you can use them to generate Bar|Beat Markers or groove template, or separate regions. However, this must be done from the Collection Mode sub-pane (when the triggers are displayed in multiple colors).

To separate regions across multiple tracks, make sure to extend the selection to any additional tracks before separating.
Part V: MIDI Editing
Chapter 23: MIDI Editing

Pro Tools provides powerful MIDI editing tools. You can create and edit individual MIDI notes and controller events with the Pencil, Trimmer, and Grabber in the Edit window. You can also use the various MIDI Operations (such as Quantize, Transpose, Change Velocity, and Change Duration) to transform groups of MIDI notes to affect pitch, timing, and phrasing. For information on region-specific editing for both MIDI and audio, see Chapter 17, “Working with Regions and Selections.”

The Pencil Tool

The Pencil tool is useful for creating and editing MIDI data. The Pencil tool shapes (Freehand, Line, Triangle, Square, and Random) can be used to enter pitches with varying durations and velocities (note velocities are determined by the Pencil shape). The various Pencil tool shapes can be particularly useful for drawing and editing different types of MIDI control data—for example, try using Line for volume, Triangle for pan, Freehand for pitch bend, and Square or Random for velocity.

To select the Pencil tool shape:

1. Click on the Pencil tool icon in the Tool Bar for the Pencil Tool Shape pop-up menu.
2. Select the desired Pencil tool shape.

Freehand

When in Note view, the Freehand shape inserts a single MIDI note whose velocity is defined by the Default Note On Velocity MIDI preference (Setups > Preferences > MIDI). The pitch, location, and duration of the note is determined by where on the MIDI track you click and release with the mouse.
When editing MIDI velocities or continuous controller data, the Freehand shape draws freely according to the movement of the mouse. The shape is reproduced as a series of steps according to the Pencil Tool Resolution When Drawing Controller Data MIDI preference (Setups > Preferences > MIDI).

**Line**

When in Note view, the Line shape inserts a series of MIDI notes on a single pitch whose velocities are defined by the Default Note On Velocity MIDI preference (Setups > Preferences > MIDI). The duration of each note is determined by the current Grid value.

When editing MIDI velocities or continuous controller data, the Line shape draws in a straight line from click to release. MIDI continuous controller values change in steps according to the Pencil Tool Resolution When Drawing Controller Data MIDI preference (Setups > Preferences > MIDI).

**Triangle**

When in Note view, the Triangle shape inserts a series of MIDI notes on a single pitch whose velocities oscillate between the defined Default Note On Velocity MIDI preference and 127 according to a sawtooth pattern. The duration of each note is determined by the current Grid value.

When editing MIDI velocities or continuous controller data, the Triangle shape draws a sawtooth pattern that changes direction according to the current Grid value.

**Square**

When in Note view, the Square shape inserts a series of MIDI notes on a single pitch whose velocities alternate between the defined Default Note On Velocity MIDI preference and 127. The duration of each note is determined by the current Grid value.

When editing MIDI velocities or continuous controller data, the Square shape draws a square pattern that repeats at a rate based on the current Grid value.

**Random**

When in Note view, the Random shape inserts a series of MIDI notes on a single pitch whose velocities change randomly within the range between the defined Default Note On Velocity MIDI preference and 127. The duration of each note is determined by the current Grid value.

When editing MIDI velocities or continuous controller data, the Random shape draws a series of random values that change at a rate based on the current Grid value.

**Custom Note Duration**

*(Pro Tools 6.0 Only)*

The Custom Note Duration command lets you define the default note duration for inserting notes manually.

**To select a Custom Note Duration:**

1. Click on the Pencil tool icon in the Tool Bar for the Pencil Tool Shape pop-up menu.
2. Select Custom Note Duration. A note icon will appear below the Pencil tool icon in the Tool Bar.
3 Click on the note icon for the Custom Note Duration pop-up menu, and select the desired note duration.

The note icon will change to show the selected note value.

---

**Inserting MIDI Notes**

In addition to recording and importing MIDI into Pro Tools, you can manually insert MIDI notes using the Pencil tool.

**To insert a MIDI note:**

1. Set the MIDI track’s Display Format to Notes.
2. Select the Pencil tool and make sure it is set to Freehand. The cursor will change to the Pencil when located over the playlist area of a MIDI track in Note view.
3. If desired, set the Time Scale to Bars:Beats, and set the Edit mode to Grid and the Grid value to quarter notes (0|1|000). With these settings, quarter notes will be inserted on the beat.
4. Move the Pencil into the playlist area for the MIDI track. Use the Edit window’s Ruler and the track’s mini-keyboard to locate the desired pitch and location.

When using the Pencil, the Current Cursor display in the Options Bar provides information about its location.

---

**Setting the Grid Value**

**To set the Grid value for MIDI editing:**

1. Set the Main Time Scale to Bars:Beats (see “Setting the Main Time Scale” on page 214).
2. From the Grid Value selector, select the desired rhythmic value (such as 1/4, 1/8, or 1/16).
3. Verify the default session meter and tempo are set as desired (see “Setting the Default Meter” on page 147 and “Setting the Default Tempo” on page 148).

For more information on Grid mode, see “Grid” on page 206.
When the desired pitch and time are located, click to insert the note.

The velocity for inserted notes is determined by the Default Note On Velocity MIDI preference (Setups > Preferences > MIDI). When in Grid mode, the duration of the note is determined by the Edit window's Grid value. In Pro Tools 6.0, the duration of the note can also be determined by the Custom Note Duration value (see “Custom Note Duration” on page 332).

If the MIDI Preferences option for “Play MIDI notes with Grabber and Pencil Tools” is enabled, each inserted note will sound.

The Pencil can be dragged after clicking (and before releasing) to adjust the note’s pitch or duration. Click and drag right to lengthen the note without changing its start point. Click and drag left to lengthen the note without changing its end point.

In Pro Tools 6.0, with Grid mode enabled, the end point of the MIDI note snaps to the nearest Grid boundary by default. Command-drag (Macintosh) or Control-drag (Windows) with the Pencil to temporarily disable snap to grid.

In Pro Tools 5.x, with Grid mode enabled, Command-drag (Macintosh) or Control-drag (Windows) with the Pencil to snap the note’s end point to the nearest Grid boundary.

The Pencil tool shapes (Line, Triangle, Square, and Random) can be used to enter a series of identical pitches with varying velocities. The length and spacing for the inserted notes are determined by the current Grid value, or by the Custom Note Duration value (Pro Tools 6.0 only). The note velocities are determined by the Pencil shape.

Use the Square shape for alternating velocities of loud and soft. Use the Triangle shape for a ramp up and down of velocities. The Line shape enters notes with identical velocities.
To insert a series of notes with random velocities:

1. Set the MIDI track’s Display Format to Notes.
2. Select the Pencil tool and make sure it is set to Random.

![Pencil tool set to Random](image)

3. Set the Time Scale to Bars:Beats. In addition, set the Edit mode to Grid and the Grid value to quarter notes (0|1|000).

With these settings, the inserted notes will be spaced one quarter note apart.

4. Click at the point where the first note will be inserted and drag to the right; when the desired number of notes are visible, release.

![Inserting a series of notes with the Pencil](image)

### Manually Editing MIDI Notes

All aspects of a MIDI note can be edited from the Edit window, including start and end points, duration, pitch, and velocity. The Grabber and Selector can operate on individual notes or groups of notes.

#### Selecting MIDI Notes

To select a group of MIDI notes:

- With the Grabber or Pencil, Shift-click each note.
  - or -
- With the Grabber, move the cursor to where there are no notes (the Marquee appears) and click and draw a rectangle around the group of notes.

![Selecting notes with the Grabber](image)

When using the Grabber, if any portion of the rectangle touches a note (either its start or end point), the note is included in the selection. Selections made with the Grabber do not include underlying controller and automation data for the MIDI track.

- or -

- With the Selector, drag across a range of notes.

![Selecting notes with the Selector](image)
When using the Selector, a note’s start point must be included in order for it to become selected. When a MIDI track is displaying notes (or regions), selections made with the Selector include underlying controller and automation data.

**To select a single pitch for the entire length of a track:**
- On the mini-keyboard, regardless of the currently selected edit tool, Command-Shift-click (Macintosh) or Control-Shift-click (Windows) the note.

**To deselect one or more notes from a selection:**
- With the Grabber or Pencil, Shift-click the notes so they become deselected.

**Transposing Notes**

MIDI notes can be transposed by dragging up or down with the Grabber or Pencil. If several notes are selected before dragging, each is transposed.

**To transpose a MIDI note:**
1. Set the MIDI track’s Display Format to Notes.
2. Select the Grabber or Pencil.
3. While pressing Shift, drag the note up or down.

   The Shift key ensures that the transposed note retains its start point. While dragging, each new note sounds and the Current Cursor display indicates the number of semitones and direction (+/-) for the transpose.

   ![Transposing with the Grabber](image)

   **To transpose a copy of the note, leaving the original unchanged, press Option (Macintosh) or Control (Windows) while dragging.**

**Moving Notes**

Like regions, MIDI notes can be dragged left or right with the Grabber or Pencil to change their start point. If several notes are selected before dragging, each is moved.

**To move a MIDI note:**
1. Set the MIDI track’s Display Format to Notes.
2. With the Grabber or Pencil, drag the note left or right (press Shift while dragging to preserve the note’s pitch).

   As the note is dragged, the Current Cursor display indicates the new start point.

   If the Edit mode is set to Grid, the dragged note snaps to the nearest Grid boundary. If the Edit mode is set to Spot, the Spot dialog opens.

   ![Moving Notes](image)

   **To copy the selected notes, leaving the originals intact, press Option (Macintosh) or Control (Windows) while dragging.**

   **The placement of MIDI notes can also be adjusted with Shift (see “Shift Command” on page 255) or Nudge (see “Nudging” on page 253).**
Trimming Note Start and End Times

Like regions, start and end points for MIDI notes can be adjusted with the Trimmer tool. If several notes are selected when performing the trim, each note is changed.

In Pro Tools 6.0, the Pencil tool can function like the Trimmer tool for changing the start and end points of MIDI notes.

To change the start or end points for a group of MIDI notes:

1. Set the MIDI track's Display Format to Notes.
2. Using the Grabber or Pencil, Shift-click each note you want to trim.
3. Select the Trimmer. For TDM systems, make sure the Standard Trimmer is selected in the Trimmer Tool pop-up menu.

   – or –

   Use the Pencil tool (Pro Tools 6 only).

4. Move the cursor near the beginning of any of the highlighted notes, so the Trim cursor appears. Drag right to shorten the notes, or drag left to lengthen them.

   – or –

   Move the cursor near the end of any of the highlighted notes, so the Trim cursor appears. Drag left to shorten the notes, drag right to lengthen them.

   \[Image: Changing note end times with the Trimmer\]

If using Grid mode, the dragged start or end point snaps to the nearest Grid boundary. If using Spot mode, the Spot dialog opens, where you can enter the new location for the note’s start or end point.

In Pro Tools 6.0, when in Grid mode, use the Command key (Macintosh) or the Control key (Windows) to temporarily disable Grid mode.

Notes can also be trimmed with the Trim To Selection command (see “Trim To Selection Command” on page 241) and the Trim To Insertion command (see “Trim To Insertion Command” on page 248).

Manually Editing Note Velocities

When a MIDI track’s Display Format is set to Velocity, each note’s attack velocity is represented with a velocity stalk. The taller the velocity stalk, the higher the velocity value (0–127).

To edit MIDI velocity:

1. Set the MIDI track’s Display Format to Velocity.

2. Select the Grabber tool.
3 Drag the top (diamond) of the velocity stalk up or down.

- or -

If two notes have the same start time (with velocity stalks on top of each other), Command-drag (Macintosh) or Control-drag (Windows) the actual note up or down.

The velocities for a range of notes can be edited with the Pencil tool, either by Freehand or with any of the Pencil tool shapes.

To draw velocity values that fade in:

1. Set the MIDI track’s Display Format to Velocity.
2. Select the Pencil tool with the shape set to Line.
3. Click at the beginning of the note range, near the bottom of the velocity range, and drag to the right and up.

4 Once the line encompasses the desired range of notes, along with the desired steepness of the fade, release.

You can also use the Trimmer tool to scale the velocities for all selected notes. This is useful if you like the velocity relationship between the notes, but want them to be louder or softer.

In Pro Tools 6.0, when in Velocity view, the Trimmer tool can be used to trim note durations in addition to changing velocities.

To scale velocities with the Trimmer:

1. Set the MIDI track’s Display Format to Velocity.
2. Using either the Selector or Grabber tool, select the range of notes to be edited.
3. With the Trimmer, click near the range of selected notes and drag up or down. Dragging up boosts the velocities for each note; dragging down reduces them.

In Pro Tools 6.0, click in the upper 25% of the track height to scale velocities. When in Velocity view, clicking in the lower 75% of the track height lets you trim note lengths.
Typing in Note Attributes

When an individual note is selected with the Grabber, its attributes are displayed in the Event Edit area.

Pitch is listed by note name and octave number. Attack and release velocities are listed with their MIDI values (0–127). Times for Start, End, and Length are displayed in the Main Time Scale.

To change an attribute for a MIDI note:

1. In the MIDI track’s playlist area, select the note with the Grabber or the Pencil tool.
2. Click in the Attribute’s text box and do one of the following.
   - Enter the new value on the numeric keypad.
   - Press the Up or Down Arrow to scroll to the new value.
   - In Pro Tools 6.0, drag up or down to scroll to the new value. In Pro Tools 5.x, press Command (Macintosh) or Control (Windows), then drag up or down to scroll to the new value.
   - Play the new note value on your MIDI controller keyboard.

Press the slash key to move between the fields in the Event Edit area.

Multiple Notes and Event Edit Area

When multiple notes are selected, you can enter values in the Event Edit area fields to affect all selected notes.

A new value in the Start field moves the first note in the selection to that location, with all other notes moving with it.

Values entered in the pitch and velocity fields add to or subtract from the values for all selected notes. For example, to transpose all selected notes down an octave, enter a value of –12 for pitch.

Deleting MIDI Notes

In addition to deleting selected notes with the Clear command in the Edit menu, individual notes can also be deleted with the Pencil tool.

To delete a group of MIDI notes with the Clear command:

1. Using the Grabber or Selector tool, select the notes to be deleted. For details, see “Selecting MIDI Notes” on page 335.
2. Choose Edit > Clear to delete the selected notes. The track’s underlying controller data remains intact.

   - or -

Press the Delete (Backspace) key.

⚠️ When deleting MIDI notes within a time range selection, all underlying controller and automation data is also deleted.
To delete a single MIDI note with the Pencil:
- With the Pencil tool selected, press Option (Macintosh) or Alt (Windows) so the tool changes to an Eraser, then click the note to delete.

Continuous controller events for MIDI tracks are displayed in the form of a line graph with a series of editable breakpoints. Controller events for MIDI tracks differ somewhat from automation data for audio tracks in that the breakpoints are stepped (instead of vector-based), where each breakpoint represents a single controller event.

MIDI controller events that can be inserted and edited in Pro Tools include:
- volume
- pan
- pitch bend
- aftertouch (mono)
- MIDI controllers, 0–127

Polyphonic aftertouch cannot be viewed in the Edit window. To view polyphonic aftertouch in Pro Tools, use the MIDI Event List (see Chapter 25, “MIDI Event List”).

MIDI controller #7 (volume) and #10 (pan) are treated by Pro Tools as automation data. This means that these controller events (along with Mutes) can be recorded and automated from the Mix window; in addition, each MIDI track’s automation mode affects how these events are played back and recorded. While a MIDI track’s volume and pan (and mute) events can be suspended, all other controller events in the track always play.

To avoid overwriting existing MIDI volume and pan automation data, record in MIDI Merge mode. In Pro Tools 6.0, when recording in MIDI Merge mode, existing volume and pan data will playback while recording new MIDI data. However, in Pro Tools 5.x, existing volume and pan data will not play back while recording new MIDI data.

Continuous controller events (including volume and pan) can be recorded from an external MIDI controller (such as a keyboard or control surface), and they can be inserted in a MIDI track’s playlist using the Grabber or Pencil tools.
Inserting/Editing Controller Events

Continuous controller events can be edited with any of the following methods:
- Individual breakpoints can be dragged with the Grabber to adjust their location or value.
- A group of selected breakpoints can be scaled up or down with the Trimmer.
- New controller events can be drawn in with the Pencil tool to replace existing events. Events can be drawn with the Pencil set to Freehand, or using any of the shapes (Line, Triangle, Square, or Random).
- Controller events can be copied and pasted, nudged, and shifted.

To copy continuous MIDI controller events and paste to a different MIDI controller, use Special Paste: Command+Control+V (Macintosh) or Control+Start+V (Windows). For example, you might want to use the same control data for volume and a cut-off filter, or for pan and pitch bend.

See “Special Paste Function for Automation Data” on page 442.

For details on these editing procedures, see Chapter 28, “Automation.”

Edits to volume data affect all tracks within an enabled Edit Group. This is not the case, however, for other controller playlists (such as pan). To insert and edit other controller types across all tracks in an Edit Group, press Control (Macintosh) or the Start key (Windows) while performing the edits.

Resolution for Inserted Controller Events

When inserting controller events with the Pencil, the density of the events is determined by the MIDI Preference for “Pencil Tool Resolution When Drawing Controller Data.”

To set the Pencil tool resolution:
1. Choose Setups > Preferences and click the MIDI tab.
2. Enter a value for “Pencil Tool Resolution When Drawing Controller Data.” The value range is from 1 to 100 milliseconds.
3. Click OK.

Program Changes

Each MIDI track can have a default program change that is sent each time the track plays. Additional program changes can be inserted at any point within the track.

About Program and Bank Changes

The MIDI protocol lets you choose from a range of 128 programs (0-127). Most MIDI instruments have several banks of 128 programs. To specify which bank you’re selecting from, a bank select message must be sent. Some instruments use Controller 0 to switch the bank while others use Controller 32; some use a combination of the two. The Program Change dialog in Pro Tools allows you to use either of these bank
select messages when inserting a program change event. Check the manufacturer’s documentation for your MIDI device to see which Controller it uses.

*Some older MIDI devices (such as the Kurzweil K1000) use a program change instead of a Bank Select message to switch banks. For these devices you may find it necessary to send two program change messages to access a particular program, where the first sets the bank and the second sets the program.*

**Default Program Change**

The default program change for each MIDI track is specified by clicking on the Program button, from either the Edit or Mix window. Once specified, the default program change message is sent to your instrument when playing the track.

**To set the default program change for a MIDI track:**

1. From the Edit or Mix window, click the Program button.

2. In the Program Change dialog, select the desired program number.

---

![Program Change dialog](image)

---

If using patch name files (Pro Tools 6.0 only), choose a bank from the pop-up menu in the upper right of the Program Change dialog and select the desired patch name. See “Patch Names” on page 343.

![Choosing a bank in Program Change dialog (Pro Tools 6.0)](image)

---

If subscribed to OMS names (Macintosh OS 9 only), choose a bank from the pop-up menu in the upper right of the Program Change dialog, and select the desired program name. See “OMS Name Manager” on page 344.

![Choosing a bank in Program Change dialog (OMS)](image)

---

3. Click Done.
Once selected, the program number (or patch name) appears in the Program button in the Edit window.

Unlike recorded and inserted program change events, the default program change does not appear in the track's playlist.

To clear the default program change, select None in the Program Change dialog.

Patch Names
(Pro Tools 6.0 Only)

Pro Tools supports XML (Extensible Markup Language) for storing and importing patch names for your external MIDI devices. Pro Tools installs MIDI patch name files (.midnam) for the factory default patch names of many common MIDI devices. These files reside in directories, sorted by manufacturer, in Root/Library/Audio/MIDI Patch Names.

To import MIDI patch names into Pro Tools:

1. Verify the MIDI Device name in Audio MIDI Setup (Setups > Edit MIDI Studio Setup).
2. Verify the MIDI track's output is correctly assigned to the MIDI device.
3. Click the MIDI track's Program button.
4. In the Program Change dialog, click the Change button.
5. In the resulting Open dialog, navigate to /Library/Audio/MIDI Devices/MIDI Patch Names, and select the MIDI Patch Name file (.midnam) for the MIDI device.
6. Click Open.
7. The Program Change dialog will be populated with patch names and the Patch Name Bank pop-up menu will appear in the upper left hand corner of the window.

Once patch names have been imported into Pro Tools, they will be available for that MIDI device in all sessions.

To clear patch names:

- In the Program Change dialog, click the Clear button.

MIDI patch name files (.midnam) can be edited in any text editor (such as TextEdit), so you can create your own custom patch names.
OMS Name Manager
(Macintosh OS 9 Only)

If your MIDI devices are subscribed to OMS patch names, these names will appear in the Program Change dialog in Pro Tools, and also in the inserted program change events. If not, programs will be selected and viewed by number.

If OMS has a factory names document for any of the MIDI devices in your Studio Setup, these factory names are automatically subscribed and appear in Pro Tools.

You can also open the OMS Names window from Pro Tools and subscribe to names from patch editor/librarian software, or even enter your own custom patch names.

To open the OMS Names window:
★ Choose Setups > OMS Names.

OMS Names window

For details on using the OMS Names window, refer to the online OMS Name Manager manual included on the Pro Tools CD-ROM.

Customizing OMS Names

To enter your own list of customized names:

1. Choose Setups > OMS Names.
2. Click the Patch Name Document in the Patch Name Document column for the desired OMS device. If there is no document present yet, click the empty space next to the OMS device.

OMS Name dialog

3. Choose Names > View/Edit Patch Names to open the Patch Name window. Note that the Names menu item has changed to Patches.
4. Type your patch names for the corresponding program numbers. If you are using a third party librarian software, or if you have a list of patch names in your word processor, you can copy and paste these names into this window. See below for more information.
5. Click OK to confirm the changes.
6. Click Save in the Save Changes dialog. Save patch name files to System Folder/OMS Folder/Factory Names so they will be easy to find.
7. Click OK in the OMS Names dialog. Once the MIDI track’s output has been set to the corresponding OMS device, you should see your patch names instead of numbers for your device in the Pro Tools patch dialog.
To copy names from another application into OMS Names:

1. If you are using a word processor, make sure the names in the list are separated by a carriage-return (Return-key).
   
   – or –

   If you are using a third party patch name librarian software, make sure that it allows you to copy the list of patch names.

2. Select the desired names, then choose Copy in your word processor or librarian software to copy the list of names to the clipboard.

3. Launch Pro Tools and choose Setups > OMS Names.

4. Click the Patch Name Document in the Patch Name Document column for the desired OMS device. If there is no document present yet, click the empty space next to the OMS device.

5. Choose Names > View/Edit Patch Names to open the Patch Name window. Note that the Names menu item has changed to Patches.

6. Choose Patch > Paste Patch Names to paste your patch names from the clipboard into the Patch Name Document List.

7. Click OK to confirm the changes.

8. Click Save in the Save Changes dialog. We recommend always saving patch name files to System Folder/OMS Folder/Factory Names so they will be easier to find.

9. Click OK in the OMS Names dialog. Once the MIDI track’s output has been set to the corresponding OMS device, you should see your patch names instead of numbers for your device in the Pro Tools patch dialog.

For more details on using the OMS Names window, please refer to OMS documentation.

Inserting and Editing Program Changes

Program changes can be inserted into a track’s playlist with the Pencil tool. Existing program changes can be edited, moved, and copied and pasted.

On some instruments, changing programs during playback can interrupt playback. To avoid this, place program change events in the track where there are no notes sounding.

To insert a program change with the Pencil:

1. Set the MIDI track’s Display Format to Program.

2. If desired, set the Edit mode to Grid so the inserted event snaps to the Grid.

3. Click with the Pencil in the track’s playlist at the point where you want to insert the program change.

4. In the Program Change dialog, select a program number (or name) and, if necessary, specify a bank change value.

5. Click Done to insert the program change event in the track’s playlist.

To edit a program change event:

1. With the Grabber or Pencil, double-click the program change event you want to edit.

2. In the Program Change dialog, select the new program number (or name) and, if necessary, specify a bank change value.

3. Click Done.
To move a program change event:

- With the Grabber or Pencil, drag the program change event left or right.

If the Edit mode is set to Grid, the dragged event snaps to the nearest Grid boundary. If the Edit mode is set to Spot, the Spot dialog opens.

*The placement of program changes can also be adjusted with Shift (see “Shift Command” on page 255) or Nudge (see “Nudging” on page 253).*

To delete a program change event:

1. With the track’s Display Format set to Notes, click the program change event with the Grabber to select it.
   
   – or –

If the region contains other events you want to delete, select the entire region with the Grabber (when the track is displaying regions).

2. Choose Edit > Clear to remove the selected events from the track.
   
   – or –

Press the Delete (Backspace) key.

*Individual program change events can also be deleted by Option-clicking (Macintosh) or Alt-clicking (Windows) them with the Pencil.*

**Auditioning Programs**

When the Program Change dialog is open, you can have Pro Tools automatically scroll through the different patches for a track’s assigned MIDI device.

To audition patches for a MIDI track during playback:

1. Click Play in the Transport window.

2. Open the Program Change dialog by clicking the Program button in the Mix window, or by inserting or editing a program change event in a MIDI track.

3. Click a program number—the starting point from which you will scroll through the patches.

4. If desired, enter a value for the number of seconds that will elapse between each program change.

5. Select the option for Increment Patch.

After the specified number of seconds, Pro Tools selects the next patch and transmits the program change to the track’s assigned MIDI device.

To audition patches from the Program Change dialog:

1. Open the Program Change dialog by clicking the Program button in the Mix window, or by inserting or editing a program change event in a MIDI track.

2. Click a program number—the starting point from which you will scroll through the patches.

3. If desired, enter a value for the number of seconds that will elapse between each program change.

4. Select the option for Increment Patch. After the specified number of seconds, Pro Tools selects the next patch and transmits the program change to the track’s assigned MIDI device.

5. Play your MIDI controller to audition the new patches.
System Exclusive Events

System Exclusive (sysex) events can be recorded to MIDI tracks in Pro Tools (see “Recording System Exclusive Data” on page 179). Once the events are recorded, they appear in the track’s playlist as blocks when the Display Format is set to Sysex.

While the contents of recorded System Exclusive events cannot be directly edited in Pro Tools, the events can be moved or nudged, copied and pasted, or deleted.

To move a sysex event:

1. Set the MIDI track’s Display Format to Sysex.
2. With the Grabber, drag the sysex event left or right.

If the Edit mode is set to Grid, the dragged event snaps to the nearest Grid boundary. If the Edit mode is set to Spot, the Spot dialog opens.

To delete one or more sysex events:

1. With the track’s Display Format set to Sysex, click the sysex event with the Grabber to select it.
   – or –
2. Choose Edit > Clear to remove the selected events from the track.
   – or –
3. Press the Delete (Backspace) key.

Note and Controller Chasing

Note Chasing

Note Chasing allows long, sustained MIDI notes to be heard when playing from a point after their start time. For example, if a note’s start time is at 1|1|000 and lasts for 8 measures (until 9|1|000), note chasing lets you begin playing from bar 5 and still hear the note that started at 1|1|000 as it continues to sustain until 9|1|000.

Note Chasing is something that can be turned on and off individually for each MIDI track. By default, new MIDI tracks have Note Chasing enabled.
To enable Note Chasing for a MIDI track:

- Click the track’s Playlist Selector and select the option for Note Chasing.

Make sure to disable Note Chasing when working with samplers that are playing loops. If a MIDI track, for example, is triggering a 4-bar drum loop and you begin playing at bar 3, the loop will begin playing at the wrong time and be out of sync with the other tracks.

Controller and Program Chasing

Pro Tools always chases continuous controller events and program changes for MIDI tracks. This ensures that controller values and patches for MIDI devices are always appropriately set.

For example, suppose a MIDI track lasting 32 measures starts with a volume of 127 and in the last bar fades the volume down to 0. If after playing the track in its entirety you attempt to play from bar 8, the initial volume of 127 is chased and sent to the track’s assigned device—otherwise the track would not be heard since the most recent volume event sent would have been 0.

Chasing also occurs for a MIDI track’s default program change, along with any program change events residing within the track. Therefore, if you have chosen a default program change for a track, when playing from any point within the track, the program change event is sent to the track’s assigned device.

Default Controller Values and Chasing

Though new MIDI tracks appear to have default values for continuous controller playlists, this is actually not the case. For example, when viewing a MIDI track’s Mod Wheel playlist, you’ll see that the breakpoint line is set to a default of zero. However, since the modulation wheel on your synth may purposely be set to a different value, the default value in the track is not transmitted when playing.

This can cause some confusion, however, if you insert a fade (for example, from 0–90) in the Mod Wheel playlist towards the end of the track. If you then play from the beginning of the track, or from anywhere before the fade, the Mod Wheel value on your synth will be at 90 until the beginning of the fade data is reached—which is likely not what you want.

To ensure that the default controller value for a playlist is sent (and chased), click the initial breakpoint at the beginning of the track, move it slightly, and set it back to the default value.

Offsetting MIDI Tracks

Pro Tools can offset MIDI tracks globally or individually.

Global MIDI Playback Offset

Pro Tools offers a MIDI offset preference that allows MIDI tracks to play back earlier or later (than audio tracks) by a specified number of samples. The offset affects playback only and does not alter in any way how MIDI data is displayed in the Edit window.

This capability is provided in large part to compensate for the audio monitoring latency in Pro Tools LE. If you are monitoring the output of your MIDI devices with an external mixer or
sound system (or headphones), there is no latency. If, however, you are monitoring the output of your MIDI devices through an Mbox, Digi 002, Digi 001, or Audiomedia III, your MIDI tracks will appear to play slightly later than your audio tracks. The larger the setting for the H/W Buffer Size (128, 256, 512, or 1024 samples), the larger the latency.

By configuring the Global MIDI Playback Offset, you can get your MIDI tracks to play back slightly earlier (by a specified number of samples), thereby compensating for the latency in monitoring audio within Pro Tools LE.

The metronome click is not affected by MIDI Global Offset.

To configure the Global MIDI Playback Offset:

1. Choose Setups > Preferences and click MIDI.
2. For the “Global MIDI Playback Offset” option, enter the number of samples (–10,000 to 10,000) for the offset. A negative value causes the MIDI tracks to play back earlier than the audio tracks, a positive value causes the MIDI tracks to play back later.
3. Click Done.

The Global MIDI Playback Offset can also be set from the MIDI Track Offsets window.

Individual MIDI Track Offsets

You can offset individual MIDI track offsets in Pro Tools to compensate for delays in MIDI devices (the time it takes to trigger events on a sampler or synth).

For example, if you have some kick drums that are being played by an audio track in Pro Tools and want them to be perfectly “in sync” with kick drums that are being played by a MIDI device, you may need to use a MIDI offset. In this example, it will usually take at least 5 ms to trigger the MIDI notes, and it could take even longer, depending on the MIDI device.

You can measure the latency for a MIDI device assigned to a MIDI track by recording its audio output back into Pro Tools. Compare the sample locations for the recorded audio events against the original MIDI notes to calculate the latency.

To configure a MIDI track offset for a track:

1. Choose Windows > Show MIDI Track Offsets.
2. Click in the Sample Offset column for the MIDI track and enter the number of samples (–10,000 to 10,000) for the offset. A negative value causes the MIDI tracks to play back earlier than the audio tracks, a positive value causes the MIDI tracks to play back later.

The equivalent offset in milliseconds is displayed in the Msec Offset column. The value in this column, indicated in italics, cannot be edited, and updates when a new value is entered in the SMPTE Offset column.
3 Press Return (Macintosh) or Enter (Windows) to accept the entered offset value.

To reset all offsets for all MIDI tracks, click the Reset button in upper left of the window.

---

**Stuck Notes**

If you encounter stuck notes with any of your MIDI devices, you can silence them with the All Notes Off command.

**To turn off all stuck notes:**

- Choose MIDI > All Notes Off.

   - Press Command+Shift+Period (Macintosh) or Control+Shift+Period (Windows) for the All Notes Off command.

An All Notes Off message is sent to each channel for all devices in your setup.
Chapter 24: MIDI Operations

MIDI Operations Window

The MIDI Operations window opens when choosing any of the following commands from the MIDI menu:

- Quantize
- Groove Quantize
- Restore Performance
- Flatten Performance
- Change Velocity
- Change Duration
- Transpose
- Select Notes
- Split Notes
- Input Quantize

To reconfigure the MIDI Operations window for a different command, select the command from the MIDI menu or from the pop-up menu at the top of the window.

The MIDI Operations window can be left open as desired, revisiting it as necessary to apply a command, or to try out different options for a particular command.

To show or hide the MIDI Operations window:

- Choose Windows > Show MIDI Operations.

To apply the command in the MIDI Operations window:

- Click Apply or press Enter on the numeric keypad. This applies the command and leaves the window in the foreground.
  - or -
- Press Return (Macintosh) or Enter on the alpha keyboard (Windows). This applies the command and closes the window.
To undo the command in the MIDI Operations window:
- Choose Edit > Undo.

Using the MIDI Operations Window

Use the following methods to easily configure the various options, which vary from command to command, in the MIDI Operations window:
- To move forward and back through the various fields, press Tab or Shift+Tab.
- Increment or decrement selected fields with the Up and Down Arrows. Press and hold these keys to scroll quickly through the values.
- Command-drag (Macintosh) or Control-drag (Windows) up or down in a selected field to scroll to a new value.
- Press Command (Macintosh) or Control (Windows) while adjusting sliders for finer resolution.
- For selected pitch and velocity fields, play a note on your MIDI controller keyboard to automatically enter it.
- Changing a value for a particular parameter (such as the Swing Percentage in the Quantize window), automatically enables the parameter.

Select Notes

The Select Notes command allows you to further narrow a selection of MIDI notes based on pitch. The command can be used to select a single note or note range for the entire length of a region or track, or to select the upper or lower voices within chords.

To open the Select Notes window:
- Choose MIDI > Select Notes.

Select Notes window

Options for the Select Notes command include:

All Notes All notes are selected.

Notes Between Selects a range of notes between the specified upper and lower note. Values for the notes can be entered in pitch (C1–G8) or MIDI note numbers (0–127).

Top Selects the highest note or notes in each chord.

Bottom Selects the lowest note or notes in each chord.

Selecting a Pitch Range of Notes

A common use for Select Notes is to select a single note for the entire length of a region or track. This is especially useful if you want to select a note in a MIDI drum track (such as a hi-hat), and affect it over the selected time range with the Quantize, Groove Quantize, Transpose, or Change Duration command.

To select only the hi-hats in a General MIDI drum track:
1. Using the Grabber or Selector, select the range of MIDI notes that contains the note.
2. Choose MIDI > Select Notes.
3 Select the Notes Between option with the note range set to F#1 and F#1 (if the MIDI Note Display preference is set to Standard Pitch).

For a General MIDI drum kit, the closed hi-hat is assigned to MIDI note number 42 (F#1 at Standard Pitch). If the hi-hat for your drumkit is assigned to a different note, make sure to specify it.

4 Click Apply.

Selecting Notes in a Chord

Another use for Select Notes is to select only the upper or lower notes in a chord. Many times you’ll want to affect only the upper or lower notes in a chord—to boost their velocities, or transpose their pitch.

To select only the bass notes in a chord:

1 Using the Grabber or Selector, select the range of MIDI notes that contains the chords.

2 Choose MIDI > Select Notes.

3 Select the Bottom option and leave the number of notes set to 1.

4 Click Apply.

In order for notes to be considered a chord, their start times must be within five ticks of each other.

Split Notes

The Split Notes command has the same selection criteria as the Select Notes command, but also lets you automatically cut or copy the selected notes when clicking Apply.

To open the Split Notes window:

Choose MIDI > Split Notes.

Split Notes window

One use for this command would be if you recorded a track with chords in the left hand and melody in the right. With the Split Notes command, you could cut the melody notes and paste them to another track so you could assign them to play on a different device or channel. Another use is to split the various notes (such as kick, snare, and toms) from a single drum track to separate tracks.

To cut a specific pitch range of notes:

1 Using the Grabber or Selector, select the range of MIDI notes that contains the notes.

2 Choose MIDI > Split Notes.

3 In the Split Notes dialog, select the option for Notes Between and enter the low and high notes for the pitch range.

When either of the Pitch fields are selected, you can play a pitch on your MIDI controller to automatically enter it.

4 Select Cut.

5 Click Apply. Notes falling within the specified pitch range are removed from the selection and placed on the Clipboard. The notes can then be pasted or merged to another track.
Change Velocity

The Change Velocity command automatically adjusts attack and release velocities for selected MIDI notes. Use it to make notes louder or softer, or to create crescendos or decrescendos.

Velocities can also be edited manually with the Pencil and Grabber Tools (see “Manually Editing MIDI Notes” on page 335).

- Velocity values usually affect the loudness of MIDI notes. They may also affect other aspects of an instrument’s sound, such as filter cutoff, envelopes, and modulations.

- The settings in the Change Velocity window are saved with each session. To store your favorite settings as the default for use in future sessions, save them as part of a session template (see “Creating Custom Session Templates” on page 52).

To open the Change Velocity window:

- Choose MIDI > Change Velocity.

Change Velocity window

- While there are options for adjusting both the attack and release velocities for notes, most MIDI devices ignore release velocity information. To see if your instrument supports release velocities, refer to the manufacturer’s documentation.

Set All To Sets all velocities to the specified value (1–127).

Add Adds to existing velocity values by the specified amount (1–127).

Subtract Subtracts from existing velocity values by the specified amount (1–127).

Scale By Scales all velocities by a percentage amount (1–400%).

Change Smoothly Allows velocities to change smoothly from one value to another over time.
**Change Smoothly by Percentage** Allows velocities to change smoothly from one percentage value to another over time.

The curve for this change can be adjusted (+/- 99) to affect how gradually the change occurs.

**Limit To** When selected, restricts the Change Velocity command to a minimum and maximum range.

**Randomize** When selected, the Change Velocity command is randomized by the specified percentage value. For example, using “Set all to” with a value of 64, along with a Randomize value of 50%, yields velocities anywhere between 48 and 80 (+/- 25% of the velocity value).

**Velocity Ranges**

The valid range for MIDI note velocities is 1–127. The Change Velocity command will never result in moving velocities outside this range; 1 will always be the lowest and 127 will always be the highest. This means that you may reach a state where the Change Velocity command has no effect on a particular note.

For example, if a note with a velocity 64 is scaled by 200%, the new velocity would be 127. Attempting to scale or increase the velocity any further would yield no change.

**Fading Velocities**

To change velocities smoothly over time:

1. Select the range of MIDI notes to be edited.
2. Choose MIDI > Change Velocity.
3. Select the Change Smoothly option with the range set from 127 to 0.
4. Click Apply.

To preserve (somewhat) the existing velocity relationships and still achieve velocity fades, use the option for Change Smoothly by Percentage. Figure 26 illustrates the difference between the two Change Smoothly options.

**Scaling Velocities**

Many times existing note velocities will have the desired relationship between each other, but will either be too soft or too loud as a whole. In these instances, use the Scale By option.

**For example, to make velocities 20% louder:**

1. Select the range of MIDI notes to be edited.
2. Choose MIDI > Change Velocity.
3. Select the Scale By option with the percentage value set to 120.
4. Click Apply.
### Change Duration

The Change Duration command adjusts durations for selected MIDI notes. Use it to make melodies and phrases more staccato or legato.

*The settings in the Change Duration window are saved with each session. To store your favorite settings as the default for use in future sessions, save them as part of a session template (see “Creating Custom Session Templates” on page 52).*

To open the Change Duration window:

- Choose MIDI > Change Duration.

#### Change Duration window

**Set All To** Sets all durations to a length specified in quarter notes and ticks.

**Add** Adds to the durations by a specified number of quarter notes and ticks.

**Subtract** Subtracts from the durations by a specified number of quarter notes and ticks.

**Scale by** Shortens or lengthens durations based on a percentage value (1–400%).

**Move Releases to the Closest Attack** Shortens or lengthens durations so that end times are moved to the closest attack.

**Extend Releases to the Next Attack** Lengthens durations so that end times are extended to the next attack. To limit the duration change, select either of the Add No More Than options, using either a percentage value or a number of quarter note and ticks.

**Change Smoothly** Allows note lengths to change smoothly from one duration to another over time. Duration values are specified in quarter notes and ticks.

**Change Smoothly by Percentage** Allows note lengths to change smoothly from one percentage value to another over time.

The curve for this change can be adjusted (+/– 99) to affect how gradually the change occurs.

**Limit Range** When selected, restricts the Change Duration command to a minimum and maximum range (in quarter notes and ticks).

**Randomize** When selected, the Change Duration command is randomized by the specified percentage value. For example, using “Set all to” with a value of 480 ticks, along with a Randomize value of 50%, yields durations anywhere between 360 and 600 (+/– 25% of the duration value).

### Change Duration Examples

**To make notes more staccato:**

1. Select the range of MIDI notes to be edited.
2. Choose MIDI > Change Duration.
3 Select the option for Scale By with a percentage value of 50.

4 Click Apply. The durations for the selected notes are reduced by 50%.

With this option you may have to experiment with the percentage value to achieve the desired effect.

**To make notes more legato:**

1 Select the range of MIDI notes to be edited.
2 Choose MIDI > Change Duration.
3 Select the “Extend Release to the Next Attack” option.
4 Click Apply. The end points for the selected notes are extended to the start point of the next note, thereby eliminating the space between each note.

To vary this effect, making it more or less legato, select the Add No More Than percentage option. Percentage values larger than 100 extend note end times so that the notes essentially overlap.

---

**Transpose**

While the Grabber Tool can be used to manually transpose individual MIDI notes, or small groups of notes, the Transpose command can be used for entire MIDI tracks and regions.

**To open the Transpose window:**

- Choose MIDI > Transpose.

The two options for the Transpose command are:

**Transpose By (Semitones)** Transposes chromatically, up or down, by up to 60 semitones. To transpose down by an octave, for example, use –12 semitones.

**Transpose (From, To)** Transposes by semitones, as expressed by the difference between the source and destination pitches. Transposing from C3 to F#3, for example, transposes the notes up by an augmented fourth (six semitones).
One of the more common uses for Transpose is to change the key for your MIDI tracks. You can define an Edit Group for MIDI tracks that you want to transpose, making sure to exclude any drum tracks from the group so they aren’t transposed.

**To transpose MIDI notes to another key:**

1. If you will be transposing a group of tracks, make sure to enable the Edit Group.
2. With the Selector or Grabber, select the range of MIDI notes to be transposed.
3. Choose MIDI > Transpose.
4. Select the option for Transpose (From, To).
5. Set the “From” and “To” values, for example, to C4 and E4 to transpose from C to E.

With either of the pitch fields selected, you can play a note on your MIDI controller to automatically enter it as the pitch value.

6. Click Apply.

It is also common to transpose MIDI tracks up or down by an octave.

**To transpose a MIDI track up by an octave:**

1. With the Selector, double-click in the track to select all of its notes.
2. Choose MIDI > Transpose.
3. Select the Transpose By option.
4. Enter a value of 12 semitones and then click Apply.

---

### Quantize

The Quantize command adjusts MIDI note locations and durations so that timing is improved, or so that a particular rhythmic “feel” is achieved. Quantize works by aligning notes to a Quantize Grid, the size of which is defined in the Quantize window by a standard note duration.

The Quantize command is not the same as the Quantize Regions command (in the Edit menu). The Quantize Regions command adjusts the start point for a selected region, and its contents are moved along with the region (with rhythmic relationships remaining intact).

The Quantize command, on the other hand, affects MIDI notes individually. Some notes may be moved back in time, others forward; and, some notes will be more drastically affected than others.

💡 *The settings in the Quantize window are saved with each session. To store your favorite settings as the default for use in future sessions, save them as part of a session template (see “Creating Custom Session Templates” on page 52).*
To open the Quantize window:

- Choose MIDI > Quantize.

**What to Quantize**

The options under “What to Quantize” determine which aspects of the notes are quantized: attacks, releases, or both.

**Attacks** When selected, note start points are quantized.

**Releases** When selected, note end points are quantized.

**Preserve Note Duration** When selected, note durations are preserved.

When deselected with the Attacks option selected, note end points are not moved.

When deselected with the Releases option selected, note start points are not moved.

If the options for both Attacks and Releases are selected, the Don’t Change Durations option is ignored (and dimmed).

![Quantize window](image)

Figure 27 shows how notes are adjusted by the different What To Quantize options.

**Quantize Grid**

The Quantize Grid determines the beat boundaries to which notes are aligned. Any size from whole notes to thirty-second notes (including dotted values) can be selected for the Grid size.

- **Relative Grid mode does not affect the Quantize Grid.**

**Tuplet** Select the Tuplet option to quantize irregular note groupings like triplets or quintuplets. The Quantize Grid for tuplets is calculated from the note size selection and the Tuplet value. For example, if an eighth note equals 480 ticks, tuplet eighth notes with 3 in time of 2 would yield a Grid size of 320 ticks (480 ticks / 3 * 2).
**Offset Grid By** Offsets the Quantize Grid forward or back in time by a specified number of ticks. Use this option to achieve a pushed (positive values) or laid back (negative values) feel.

*To Quantize just the backbeats, set the Quantize Grid to half-notes with an Offset of 960 ticks.*

**Swing** When selected, every other Grid boundary is shifted by the specified percentage value (0–300) to achieve a “swing” feel. A Swing value of 0% yields no swing, while 100% yields a triplet feel. With Swing set to 300%, every other Grid boundary is moved to the next Grid point.

**Options**

Additional Quantize options include:

**Include Within** When selected, attacks and releases are only quantized if located within the specified percentage of the Quantize Grid. Use this option to clean up downbeats without affecting notes that are “swung” or wildly off the beat.

Figure 28 shows the Quantize Grid set to quarter notes with the Include Within option set to 50%. Only attacks and releases falling within the shaded area (equivalent to an eight note area around each beat) are quantized.

**Exclude Within** When selected, attacks and releases are not quantized if located within the specified percentage of the Quantize Grid. Use this option to preserve the feel of notes close to the beat, while correcting others that are drastically away from the beat.

Figure 29 shows the Quantize Grid set to quarter notes with the Exclude Within option set to 25%. Attacks and releases falling within the shaded area (equivalent to a sixteenth note area around each beat) are not quantized.

**Strength** When selected, notes are moved a percentage toward the Quantize Grid. Lower percentages preserve the original feel of the notes, higher percentages align the notes more tightly to the Grid.

**Randomize** When selected, notes are moved randomly forward or back in time (after the Quantize occurs). For example, with the Quantize Grid set to eighth notes and Randomize set to 50%, notes are placed up to a 32nd note before or after the beat boundary. The Randomize setting also affects note durations (if Releases is selected).
Quantize Examples

The following examples illustrate some of the more common uses for the Quantize command.

If you intend to loop playback while quantizing, you may want to deselect Operations > Link Edit and Timeline Selection. This ensures that the play range will not change when selected notes are moved in the course of quantizing and undoing.

⚠️ In Pro Tools 5.x, while you can undo a Quantize operation, the Quantize command is destructive and permanently affects selected data. To preserve existing data, duplicate the playlist before quantizing. In Pro Tools 6.0, you can use Restore Performance to revert to the original version.

Straight Quantize

To quantize to a straight sixteenth note feel:

1. Select the range of MIDI notes to be quantized.
2. Choose MIDI > Quantize.
3. Under What to Quantize, select the Attacks option. To quantize note durations as well, select the Releases option.
4. Set the Quantize Grid to sixteenth notes. Make sure that the other options for Tuplet, Offset Grid By, and Swing are not selected.
5. Leave the remaining Quantize options deselected and click Apply.

Quantizing While Preserving the Original “Feel”

You can quantize less strictly, to preserve the original feel of your recorded MIDI tracks.

To quantize while preserving the original feel:

1. Select the range of MIDI notes to be quantized.
2. Choose MIDI > Quantize.
3. Under What to Quantize, select the Attacks option. To quantize note durations as well, select the Releases option.
4. Set the Quantize Grid to the desired note size. Make sure that the other options for Tuplet, Offset Grid By, and Swing are not selected.
5. Select the Exclude Within option with a value of 10–15%.
6. Select the Strength option with a value of 70–80%.
7. Leave the remaining Quantize options deselected and click Apply.

Audition the change and if the desired effect is not achieved, undo the edit and experiment with different values for Exclude Within and Strength.
Quantizing with Swing

If you’re working with hi-hats or bass lines, you may want to apply more of a swing feel to the track.

To quantize with an eighth note swing feel:
1. Select the range of MIDI notes to be quantized.
2. Choose MIDI > Quantize.
3. Under What to Quantize, select the Attacks option. To quantize note durations as well, select the Releases option.
4. Set the Quantize Grid to eighth notes.
5. Select the Swing option with the desired Swing percentage:
   • For a light swing, use 12%.
   • For a tighter swing-like groove, use 24%.
   • For a true “triplet-like” swing feel, use 50–75%.
6. Make sure the options for Tuplet, Offset Grid By, and Randomize are not selected. Click Apply.

Audition the change and if the desired effect is not achieved, undo the edit and experiment with a different Swing percentage.

Quantizing with Randomize

If quantized notes sound too mechanical or “on the beat,” use the Randomize option in the Quantize window to make them sound more natural.

To “humanize” the rhythmic feel of notes:
1. Select the range of MIDI notes to be quantized.
2. Choose MIDI > Quantize.
3. Under What to Quantize, select the Attacks option. To quantize note durations as well, select the Releases option.
4. Set the Quantize Grid to the desired note size.
5. Select the Randomize option with a value of 5%.
6. Click Apply.

Audition the change and if the desired effect is not achieved, undo the edit and experiment with a different Randomize percentage.

Experimenting with Quantize

When using the Quantize command, you’ll often have to experiment with many of the parameters. In fact, you won’t always get the results you’re expecting. You may have to try different values for Include and Exclude Within, and Strength; these parameters determine which notes are affected and how drastically they are changed. In addition, the Randomize parameter, which adds a percentage of randomness to the quantize, can be used to make tracks feel less mechanical—less perfect.

Although quantize is a wonderful tool for cleaning up tracks and playing with the feel of your music, sometimes the recorded data may not be salvageable. In these instances it is wise not to spend too much time trying to fix something that should probably just be rerecorded.
Groove Quantize

(Pro Tools 6.0 Only)

The Groove Quantize command adjusts MIDI note locations and durations according to a groove template rather than a strict quantization grid. Groove templates extract the particular rhythmic feel of a recorded performance so that it can be applied to a MIDI sequence. DigiGroove templates can be generated using Beat Detective (TDM systems only).

To open the Groove Quantize window, choose MIDI > Groove Quantize.

Groove Template

Groove templates (such as DigiGroove templates) are “quantization maps” derived from real musical performances. The rhythmic character of each performance is analyzed and stored as a groove template. Groove templates can be used to transfer the feel of a particular performance to MIDI data (Timing, Duration, and Velocity).

DigiGroove templates are created using Beat Detective. Beat Detective analyzes an audio file for transient peaks according to a defined threshold and maps the rhythmic relationships to a 960 parts per quarter note (ppq) template. This template can then be used in with Groove Quantize, as well as within Beat Detective.

For information on Beat Detective and creating Groove Templates, see Chapter 22, “Beat Detective.”

Numerical Sound’s Feel Injector Templates (960 ppq) are supported in Pro Tools, but DNA Groove Templates (192 ppq) are not.

Groove Template Pop-Up Menu All groove template files in the Grooves folder (Applications/Digidesign/Pro Tools 6/Grooves/) are available in the Groove Template pop-up menu. If you organize your groove templates in sub-folders in the Groove folder, they will appear as sub-menus in the Groove Template pop-up menu. Once you have selected a groove template, specific information about the template’s meter and duration (in bars) is displayed under the Groove Template pop-up menu.

Comments The Comments field displays any comments saved with the Groove Template from Beat Detective. The Comments field cannot be edited in the Groove Quantize window, but can be edited when saving a groove template from the Groove Quantize window.
Options

Pre-Process Using Quantize Enable to hard quantize the selected MIDI notes according to the Quantize command’s settings before applying Groove Quantize.

The Pre-Process Using Quantize option is only available when the Timing option is enabled.

Timing Enable to apply Groove Quantize to the selected MIDI notes. Use the slider to change the amount of quantization applied to the selection. If the slider is set to 0% there is no change in timing, a setting of 100% moves notes to the underlying template locations. If the slider is set to 200%, notes move to a tick location that is twice the difference between the original note location and the position of the referenced template event.

For example, if a note was played at Bar 1|1|060 (a 16th note), and the corresponding template event is at 1|1|073, a slider value of 100% results in the note being shifted to 1|1|073 (a slider value of 200% shifts the note to 1|1|086).

The default value for the Timing slider is 100%.

Duration Enable to influence the durations of the selected MIDI notes. At a setting of 100%, durations are changed to match the current groove template. Set to 200%, durations increase and decrease based on the ratio of the original duration of the selected notes and the durations in the template.

The default value for the Duration slider is 100%.

⚠️ Beat Detective does not currently extract duration information from audio performances. DigiGroove templates created using Beat Detective contain a fixed duration value that is 50% of the selected template resolution (see “Defining a Beat Detective Selection” on page 312).

Velocity Enable to influence the velocities of the selected MIDI notes. If the slider is set to 0% there is no change to the selected velocities, a setting of 100% sets all velocities to match the current groove template. A velocity setting of 200% typically results in over-exaggerated velocities—loud notes increasing and soft notes decreasing in volume.

For example, if two adjacent notes have equal velocities of 80, and the two corresponding template velocities are 70 and 90, setting the slider to 200% changes both to velocities of 60 and 100.

The default value for the Velocity slider is 100%.

Slider Settings

To Save the groove template with the current Options Slider Settings:

1. In the Groove Quantize window, click the Save button. The Save User Groove Template Setting opens.

Save User Groove Template Settings
2 If desired, enter or edit Comments.

3 Click the Save button to save the groove template with the current Options Slider Settings.

– or –

Click the Save As button to make a copy of the groove template with the current Options Slider Settings. In the resulting Save dialog, enter a name for the copy and click Save.

Slider settings may be lost if any of the following operations are performed without saving the settings first:

• Another MIDI Operations pane is selected.
• The MIDI Operations window is closed.
• You switch to another groove template.

Recall With Template Restores all Groove Quantize Options to the settings that are saved with the current template.

Applying Groove Templates

Groove templates can be of any length and can be applied to any number bars. Typically, you will apply groove templates to selections of the same length and meter. However, groove templates can be applied to different meters—for example, a groove template in 6/8 can be applied to a selection in 4/4. Also, it is not necessary to start on the downbeat when making a selection to apply a groove template.

To apply Groove Quantize:

1 Using the Grabber or Selector, select the MIDI notes you want to Groove Quantize.
2 Choose MIDI > Groove Quantize.
3 Select the desired groove template from the Groove Template pop-up menu.
4 Enable Timing, Duration, and Velocity as desired, and adjust their sliders to the desired percentage.
5 If desired, enable Pre-Process using Quantize.
6 Click the Apply button.

Figure 30. A DigiGroove template (derived from the audio shown) applied to a series of sixteenth-notes with Timing and Velocity both set to 100%
Mapping Groove Templates

Pro Tools applies groove templates relative to the song start. For example, a two-bar groove template repeats starting at every uneven bar in the session (bar 1, 3, 5, 7, and so on).

<table>
<thead>
<tr>
<th>1</th>
<th>2</th>
<th>3</th>
<th>4</th>
<th>5</th>
<th>6</th>
<th>7</th>
<th>8</th>
</tr>
</thead>
<tbody>
<tr>
<td>4/4</td>
<td>2-Bar Groove Template</td>
<td>2-Bar Groove Template</td>
<td>2-Bar Groove Template</td>
<td>2-Bar Groove Template</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

2 bar groove template, repeating template grid

Template Mapping for Equal Meters And Odd Numbered Bars

If a two-bar groove template is applied to a selection of one bar of the same meter, only the first bar of the template is used. If the selection does not encompass bar boundaries, for example 1|2|000 to 2|1|000, the groove template will only modify the selected notes.

Applying 2 bar groove template to a 1 bar selection, odd numbered bar

Template Mapping for Equal Meters And Even Bars

If a selection starts on an even bar, only the appropriate portion of the groove template will be used. If the selection is two bars long and starts on an even bar the template will apply bar 2 before bar 1.

Applying a 2-bar groove template to a 1-bar selection, even numbered bar

Template Mapping for Unequal Meters

In cases where the Groove Templates and track selections are based on different meters, the template will be repeated or truncated to match the number of beats in the selection.

For example, if the Groove Template contains fewer beats than the selection, such as a one-bar template in 6/8 being applied to a one-bar selection in 4/4, the template will repeat to make up the difference.

Applying a 1-bar groove template in 6/8 to a 1-bar selection in 4/4

If the Groove Template contains more beats than the selection on a track, such as a one-bar template in 6/4 being applied to a two-bar selection in 4/4, only the appropriate number of beats will be used.

Applying a 1-bar groove template in 6/4 to a 1-bar selection in 4/4
Behavior for Mixed Meters

If the selection contains mixed meters, the groove template will always be mapped so that the downbeats are aligned. For example, if the Groove Template consists of one-bar of 4/4 and it is being applied to a selection of one-bar of 4/4 followed by a bar of 3/8 and one-bar of 3/4, the downbeat of the Groove Template will be aligned with the downbeats in the selection and only the appropriate number of beats from the Groove Template will be applied.

Restore Performance

(Pro Tools 6 Only)

The Restore Performance command reverts all selected MIDI notes to their original state (when first recorded or manually inserted), even after the session has been saved, or the Undo queue has been cleared. The following MIDI note attributes can be restored:

- Timing (Quantization)
- Duration
- Velocity
- Pitch

To restore a note’s original time, duration or velocity:

1. Using the Grabber or Selector, select the MIDI notes you want to restore.
3. Select the desired note attributes to restore.
4. Click Apply.

⚠️ The Restore Performance command can be undone.
Any changes made through the standard Quantize, Groove Quantize, Change Duration, Change Velocity, or Change Pitch commands will be undone and the original “performance” will be restored. Also, any notes that were recorded with Input Quantize enabled will be restored.

⚠️ *Restore Performance does not undo cut, copied, pasted, or otherwise manually moved MIDI notes.*

**Timing (Quantization)** Enable to restore the original start times of the selected notes. This will change the durations of the notes if the Duration option is not enabled.

**Duration** Enable to restore the original durations of the selected notes. If the Timing (Quantization) option is not enabled, the start time of the note will not be restored and the note end time will be affected.

**Velocity** Enable to restore the original velocities of the selected notes.

**Pitch** Enable to restore the original pitches of the selected notes.

### Removing Input Quantize

Restore Performance can be used to remove quantization on input. For example, if you recorded a performance with Input Quantize on, you can still restore the performance as it was actually played.

---

**Flatten Performance**

*(Pro Tools 6 Only)*

The Flatten Performance command “locks in” the current performance for selected notes, creating a new “restore to” state for the specified note attributes when using Restore Performance.

**To flatten the performance:**

1. Using the Grabber or Selector, select the MIDI notes you want to flatten.
2. Choose MIDI Operations > Flatten Performance to open the Restore Performance window.

![Flatten Performance window](image)

3. Select the desired note attributes to flatten.
4. Click Apply

⚠️ *The Flatten Performance command can be undone.*
Chapter 25: MIDI Event List

The MIDI Event List

The MIDI Event List displays a detailed list of all events in a single MIDI track. The events are displayed with text and numbers, allowing you to precisely edit their location, length, and event values.

Events in the MIDI Event List can be copied and pasted, selected, or deleted. Any MIDI event (except sysex) can be inserted and edited in the list. Certain MIDI event types can be hidden with the View Filter.

⚠️ Unlike playlists in the Edit window, you can insert and display polyphonic aftertouch in the MIDI Event List.

⚠️ Mute data for MIDI tracks is not displayed in the MIDI Event List.

Opening the MIDI Event List

To open the MIDI Event List, do one of the following:

- Choose Windows > Show MIDI Event List.
- Control-double-click (Macintosh) or Start-double-click (Windows) a track name in the Edit or Mix window.
- Press Option+Equal (Macintosh) or Alt+Equal (Windows).

⚠️ You can also use Option+Equal (Macintosh) or Alt+Equal (Windows) to toggle between the MIDI Event List and the Edit window.
At the top of the MIDI Event List are three pop-up menus:

**MIDI Track Selector** Indicates the MIDI track currently displayed, and can be used to choose a different MIDI track to be displayed.

**Options Menu** Contains commands and options for the MIDI Event List (see “MIDI Event List Options” on page 376).

**Insert Menu** Contains a list of event types that can be inserted.

To the right of these pop-up menus, the number of displayed events is indicated.

**Columns in the MIDI Event List**

Information for the events in the MIDI Event List is displayed in the following three columns:

- **Start Column** Displays the start location, using the Main Time Scale, for each event. Locations can also be displayed in the Sub Time Scale when the Show Sub Counter option is selected in the Options pop-up.

  The Playback cursor appears as a blue arrow (red, when tracks are record-enabled) in the Start column.

- **Event Column** Displays the event type, indicated by an icon, and associated event values.

- **Length/Info Column** Depending on which option is selected in the Options pop-up, displays the end point or length for notes. Also displayed are the names for continuous controller events and program changes.

**Navigating in the MIDI Event List**

You can use the Tab and Arrow keys to move through the MIDI Event List. You can also locate to the Edit start point, or any other specified location.

To move through the MIDI Event List, do one of the following:

- Double-click to edit a value.
- Press Tab or the Down Arrow to move to the next event (with or without the edit field selected).
- Press Option+Tab or the Up Arrow to move to the previous event (with or without the edit field selected).
- With an edit field selected, press the Right Arrow to move to the next edit field to the right.
- With an edit field selected, press the Left Arrow to move to the next edit field to the left.

To keep the last event selected, press Shift while moving to the next or previous event.

To go to the Edit start point:

- In the MIDI Event List, choose Scroll To Edit Selection from the Options pop-up menu.
To go to a specific location in the MIDI Event List:

1. In the MIDI Event List, choose Go To from the Options pop-up menu.
2. In the Go To dialog, choose a format from the Time Scale pop-up menu.
3. Enter the location you want to go to, then click OK.

The following items from the Options menu affect navigating in the MIDI Event List:
- When Page Scroll During Playback is selected, the MIDI Event List scrolls during playback.
- When Scroll During Edit Selection is selected, the MIDI Event List is scrolled automatically when the Edit selection changes in the Edit window.

View Filter for MIDI Event List

You can use the View Filter to specify which event types are displayed in the MIDI Event List. This can help you zero in on only the events you want to affect; it also protects MIDI events from being edited or deleted. Events not displayed in the MIDI Event List still play back.

The View Filter can be set to display “all” messages, “only” the specified messages, or “all except” the specified messages.

⚠️ When inserting an event type that has been filtered from the MIDI Event List, that event type will no longer be filtered.

For example, to filter the display of aftertouch and System Exclusive Messages in the MIDI Event List:

1. In the MIDI Event List, choose View Filter from the Options pop-up menu.
2. In the MIDI Event List View Filter dialog, select the All Except option.
3. Select the options for Mono Aftertouch, Polyphonic Aftertouch, and System Exclusive. Leave all other messages deselected.

When using the All Except option, the selected events are not displayed. Conversely, when using the Only option, only the selected events are displayed.

4. Click OK.
Inserting Events in the MIDI Event List

You can insert events in the MIDI Event List by choosing an event type from the Insert menu. Following are several examples of inserting events in the MIDI Event List.

To insert a note in the MIDI Event List:

1. Click the Insert button and choose Note from the pop-up menu.

   – or –

   Press Command+N (Macintosh) or Control+N (Windows).

2. Enter the location, pitch, attack and release velocities, and length for the new note. To move between the Event Entry fields, use the Left and Right Arrow keys.

   When a field is selected, enter a value with any of the following methods:
   - Enter the value on the numeric keypad.
   - Drag up or down to scroll to the value.

   A In Pro Tools 5.x, drag up or down while pressing Command (Macintosh) or Control (Windows) to scroll to the value.

   - Play the note on your MIDI controller keyboard, then press Return (Macintosh) or Enter (Windows) on the alpha keyboard to confirm the value.

   With the Start field selected, you can automatically enter the location of another event already in the track by clicking that event.

3. To insert the note and remain in Event Entry mode, press Enter on the numeric keypad.

   – or –

   To insert the note and exit Event Entry mode, press Return (Macintosh) or Enter (Windows) on the alpha keyboard.

   – or –

   To exit Event Entry mode, without inserting the note event, press Escape on the alpha keyboard.

To insert a controller event in the MIDI Event List:

1. Click the Insert button and choose Controller from the pop-up menu.

   – or –

   Press Command+L (Macintosh) or Control+L (Windows).

Event Entry fields for note
2 Enter the location, controller “type” number, and controller value for the new event. The controller name is displayed in the Length/Info column, to the right of the controller value. To move between the Event Entry fields, use the Left and Right Arrow keys.

Event Entry fields for controller event

When a field is selected, enter a value with any of the following methods:
• Enter the value on the numeric keypad.
• Press the Up or Down Arrow to scroll to the value.
• While pressing Command (Macintosh) or Control (Windows), drag up or down to scroll to the value.
• Play the controller event on your MIDI controller keyboard, then press Return (Macintosh) or Enter (Windows) on the alpha keyboard to confirm the value.

With the Start field selected, you can automatically enter the location of another event already in the track by clicking that event.

3 To insert the controller event and remain in Event Entry mode, press Enter on the numeric keypad.

– or –

To insert the controller event and exit Event Entry mode, press Return on the alpha keyboard.

– or –

To exit Event Entry mode, without inserting the controller event, press Escape on the alpha keyboard.

To insert a program change in the MIDI Event List:

1 Click the Insert button and choose Program Change from the pop-up menu.

– or –

Press Command+P (Macintosh) or Control+P (Windows).

2 Enter the location for the new event.

3 Enter a Program Change number and Bank Select value (if necessary). The program change name is displayed in the Info column.

Event Entry fields for program change

You can click in the Info column to open the Program Change window (for details, see “Program Changes” on page 341).

With the Start field selected, you can automatically enter the location of another event already in the track by clicking that event.
To insert the program change and remain in Event Entry mode, press Enter on the numeric keypad.

– or –

To insert the program change and exit Event Entry mode, press Return on the alpha keyboard.

– or –

To exit Event Entry mode, without inserting the program change, press Escape on the alpha keyboard.

**Inserting Another Event**

After inserting an event, you can easily insert another event of the same type. The event type to be inserted is indicated at the bottom of the Insert menu.

For example, after inserting a note, to insert another:

- Click the Insert button and choose Another Note from the pop-up menu.

– or –

- Press Command+M (Macintosh) or Control+M (Windows).

*When the option for Insert At Playback Location is enabled (see “MIDI Event List Options” on page 376), you can use the keyboard shortcuts for inserting “another” event to insert events on the fly.*

---

**Editing in the MIDI Event List**

Events in the MIDI Event List can be edited, selected, deleted, and copied and pasted.

**To edit an event in the MIDI Event List:**

1. Double-click the event field you want to edit.

– or –

To edit a selected event, press Command+Enter (Macintosh) or Control+Enter (Windows).

2. Enter a new value with any of the following methods:

- Enter the new value on the numeric keypad.
- While pressing Option (Macintosh) or Alt (Windows), press the Up or Down Arrow to scroll to a new value.
- While pressing Command (Macintosh) or Control (Windows), drag up or down to scroll to a new value.
- Play the new note or controller value on your MIDI controller keyboard, then press Return (Macintosh) or Enter (Windows) on the alpha keyboard to confirm the value.

3. To accept the new value, do one of the following:

- To enter the new event value and move to another field or event, use the Arrow keys.
- To enter the new value and remain in Edit Entry mode, press Enter on the numeric keypad.
- To enter the new value and exit Edit Entry mode, press Return (Macintosh) or Enter (Windows) on the alpha keypad.

– or –

4. To exit Edit Entry mode without entering the new value, press Escape on the alpha keyboard.
Selecting in the MIDI Event List

To select a range of events in the MIDI Event List:
■ Click the event at the beginning of the selection and drag to the ending event.
— or —
■ Shift-click the event at the beginning of the selection, then Shift-click the ending event.

To select discontiguous events in the MIDI Event List:
■ Command-click (Macintosh) or Control-click (Windows) each event.

To remove an event from the selection in the MIDI Event List:
■ Command-click (Macintosh) or Control-click (Windows) the selected event.

Notes selected in the MIDI Event List can be modified by any of the commands in the MIDI Operations window. For details, see Chapter 24, “MIDI Operations.”

Deleting in the MIDI Event List

To delete an event in the MIDI Event List:
■ Option-click (Macintosh) or Alt-click (Windows) the event you want to delete.

To delete a selection of events in the MIDI Event List:
1. Select the events you want to delete, by either dragging in the Start column, or by Shift-clicking each event.
2. To view only the events you want to delete, use the View Filter (see “View Filter for MIDI Event List” on page 371). Events not displayed cannot be deleted.
3. Choose Edit > Clear to delete all selected events.
— or —
Press Delete (Macintosh) or Backspace (Windows) on the alpha keyboard.

Copy and Paste in the MIDI Event List

To copy and paste in the MIDI Event List:
1. Select the range of events you want to copy by dragging in the MIDI Event List. To select discontiguous events, Command-click (Macintosh) or Control-click (Windows) each event you want to copy.
2. Choose Edit > Copy.
3. To paste the material at an existing event’s location, click the event in the MIDI Event List.
— or —
To paste the material at any location, choose Go To from the Options menu in the MIDI Event List, enter the location you want to paste to, and click OK.
4 Choose Edit > Paste. The events from the Clipboard are pasted, replacing any existing events already there.

💡 To paste events without overwriting other events, use the Merge Paste command.

### MIDI Event List Options

<table>
<thead>
<tr>
<th>Options menu, MIDI Event List</th>
</tr>
</thead>
</table>

#### Show Sub Counter
Displays event times in the Sub Time Scale.

#### Go To
Opens the Go To dialog, where you can specify a location, based on any of the supported Time Scales, to which the Edit insertion point is moved.

#### Scroll To Edit Selection
Scrolls the MIDI Event List to the Edit start point or Edit insertion point.

#### Page Scroll During Playback
Scrolls the MIDI Event List during playback.

#### Insert At Edit Location
Inserts events at the Edit start point or Edit insertion point.

#### Insert At Playback Location
Inserts events in the MIDI Event List in real time while listening to the session playback.

#### Insert At Playback Location With Grid
Snaps the location for events inserted in real time to the grid.

#### View Filter
Opens the View Filter dialog, where you can specify which events are displayed in the MIDI Event List. Events that are not displayed are not affected by Cut, Copy, and Paste operations in the MIDI Event List. Events that are not displayed still play back. For more information, see “View Filter for MIDI Event List” on page 371.

#### Show Note Length
Displays note lengths, instead of note end times, in the Length/Info column of the MIDI Event List.

#### Show Note End Time
Displays note end times, instead of note lengths, in the Length/Info column of the MIDI Event List.

#### Insert At Edit Location
Defaults the location for inserted events defaults to the Edit start point or Edit insertion point.

#### Insert At Playback Location
Lets you insert events in the MIDI Event List in real time while listening to the session playback.

#### Insert At Playback Location With Grid
Snaps the location for events inserted in real time to the grid.
Part VI: Mixing
Chapter 26: Basic Mixing

In addition to the final mixdown, mixing tasks can occur any time during a recording session. This chapter covers Pro Tools mixing, including audio signal flow, output and bus paths, sends, and signal routing.

During mixing, real-time plug-ins and hardware inserts provide effects and signal processing (see Chapter 27, “Plug-In and Hardware Inserts”).

Mixing Concepts

Mixing involves making decisions about volume levels, panning, effects, and so on. These mixing decisions are initially based on what you hear in your studio. While you can control many variables in your studio (such as speakers and room acoustics), you cannot control the listening environment in which your final mix will be heard. The following tips include a few ways to make sure your mix will sound as good as possible to as many listeners as possible:

Alternate Speakers and Reference Monitoring

Listen to your mixes on a variety of different speakers, to gauge how well the mix will translate. By listening to a mix through different playback systems, you are attempting to anticipate what the intended audience will hear.

Reference Tapes and Discs

Tapes and discs of rough mixes let you audition mixes outside the studio in different listening environments.

Format Compatibility Monitoring

Stereo mixes must often be mono-compatible. When you are mixing in multichannel surround, mixes may also need to be compatible with stereo or mono playback systems (see Chapter 30, “Surround Concepts”).

Metering and Calibration

Meters provide a visual display of signal levels. They tell whether signal is getting to a channel, and how loud or soft a signal is relative to (above or below) “0.”

By calibrating all your equipment to standard reference levels, a consistent level can be achieved (and metered) among different recording devices in a studio, throughout a facility, or throughout an entire production chain of a feature-length film. For example, a level of, say, –18 dBFS coming out of a DAT deck should play and meter at –18 dBFS in Pro Tools.

For more information about calibrating your studio, refer to your Getting Started Guide. For audio interfaces that have trims (such as the 192 I/O), see the interface’s guide for calibration instructions.
Audio Signal Flow

Pro Tools provides three different types of audio tracks:

- audio tracks
- Auxiliary Inputs
- Master Faders

Mono and stereo audio tracks are available on all Pro Tools systems.

Multichannel audio tracks and surround mixing formats require Pro Tools|HD-series or MIX-series systems.

Tracks can be identified in the Mix window by their Track Type icon:

Audio Tracks

Audio tracks play audio from disk, record audio to disk, or monitor input signals when record enabled. Inserts on audio tracks are pre-fader.

Audio, Auxiliary Input, Master Fader, and MIDI tracks

Audio signal flow, audio tracks

To create an audio track


2. In the New Track dialog, specify the number of tracks.

3. From the Track Type pop-up menu, select Audio Track.

4. From the Track Format pop-up menu, select the desired number of channels (for example, Stereo).

5. Click Create.
**Auxiliary Inputs**

Auxiliary Inputs provide the same signal routing options as audio tracks, except that their input must come from an internal bus or hardware input. Inserts on Auxiliary Inputs are pre-fader.

**Audio signal flow, audio tracks**

Auxiliary Inputs are used as inputs for audio from MIDI devices and other sources, as well as to submix internal bus and output paths. They can be fully automated. When using Auxiliary Inputs as inputs for external sources, adjust the source output levels to achieve proper recording levels.

**Common Uses for Auxiliary Inputs**

By bussing tracks to the Auxiliary Input, you can:

- Apply real-time plug-ins or an external processor to a submix, using the Auxiliary Input as an effects return
- Input MIDI and other audio sources into the mix, to monitor or route to audio tracks for recording to disk
- Consolidate control of any submix under a single fader (see “Submixing for Signal Routing and Effects Processing” on page 398)

**To create an Auxiliary Input:**

2. In the New Track dialog, specify the number of tracks.
3. From the Track Type pop-up menu, select Aux Input.
4. From the Track Format pop-up menu, select the desired number of channels (for example, Mono).
5. Click Create.

**To route an Auxiliary Input:**

1. Click the Input Selector of the Auxiliary Input and choose an input or bus path.
2. Click the Output Selector of the Auxiliary Input and choose an output or bus path.
3. Adjust the Auxiliary Input fader to set the return volume (it defaults to 0 dB).

*Submix examples begin in “Submixing for Signal Routing and Effects Processing” on page 398.*
Master Faders

Master Faders control the master output levels of output and bus paths. When assigned to an active output or bus path, they provide post-fader effects processing and master level control for a main mix, headphone and cue mixes, stems, effects sends, and other signal routing applications. Master Faders support all track formats supported on your Pro Tools system.

Master Faders provide up to five post-fader inserts and no sends. Also, Master Fader tracks do not have Pan controls, or Mute and Solo buttons.

Common Uses for Master Faders

Master Faders can be used to:
- Control and process output mixes
- Monitor and meter an output (such as a bus or hardware output) to guard against clipping
- Control submix levels
- Control effects sends levels
- Control submaster (bussed tracks) levels
- Apply dither or other inserts to an entire mix

Use Master Faders to control submix levels, send level masters, and other outputs. Master Faders do not consume any of your system’s audio processing power.

To create a Master Fader:


2. In the New Track dialog, specify the number of tracks.

3. From the Track Type pop-up menu, select Master Fader.

4. From the Track Format pop-up menu, select the desired number of channels (for example, Stereo).

5. Click Create.

6. In the Mix window, click the Master Fader’s Output Selector and choose the output that you want to control. You can choose either audio interface outputs or internal busses. A Stereo Master Fader controls the level of a pair of outputs.

Audio signal flow, Master Faders

Unlike inserts on audio tracks and Auxiliary Inputs, Master Fader inserts are post-fader. This lets you insert a dither plug-in, or similar plug-in, on your master mix. For more information about dithering, see “Dither” on page 402.
To use a Master Fader as a stereo master volume control:

1. Create a stereo Master Fader track (as described above).

2. Set the outputs of all audio tracks in the session to the main output path (for example, outputs 1–2 of your primary audio interface) and set the panning of each track.

3. Set the output of the Master Fader to the main output path.

Master Fader Meters

Meters on Master faders always show post-fader levels, regardless of the Pre-Fader Metering setting in the Operations menu.

Master Faders and Paths

Master Faders can be assigned to main and sub-paths. When more than one Master Fader is assigned to the same output or bus path, only one can be active at the same time. If you try to assign a Master Fader to a main or sub-path that is already actively assigned on another Master Fader, the new assignment will be assigned, but be inactive. Master Faders can be assigned to different sub-paths of the same main path, as long as the sub-paths do not overlap.

Active and Inactive Master Faders

(TDM Systems and Pro Tools LE 6.0 Only)

When a Master Fader track is inactive, its associated plug-ins, I/O assignments, and their resources are made inactive.

When a Master Fader output assignment (path assignment) is made inactive, the Master Fader no longer controls the master gain of that path.

When you duplicate a Master Fader track, the duplicated track’s assignment will be inactive.

Inserts

Pro Tools lets you insert up to five inserts on each audio track, Auxiliary Input, or Master Fader. Each insert can be either a software plug-in insert or a hardware insert.

Inserts provide the following features:

- Plug-ins and hardware inserts route the signal from the track through the effect of your choice, and automatically return it to the same track.
- Hardware inserts send and return the signal to corresponding input and output channels of an audio interface, to which you can connect outboard effects.
- Inserts on audio tracks and Auxiliary Inputs are pre-fader.
- Inserts on Master Faders are post-fader.
- Inserts can be bypassed or made inactive.
- Most plug-in parameters are fully automatable.
- On TDM systems, RTAS plug-ins can be inserted on audio tracks, but not on Auxiliary Inputs or Master Faders.

See Chapter 27, “Plug-In and Hardware Inserts” for details about using plug-ins and inserts.

Track Output Format and Plug-Ins

Pro Tools supports mono, multi-mono, stereo, and (on systems that support surround mixing) multichannel plug-ins.

Because inserts process in series, changing the plug-in format can alter the channel format. For example, inserting a mono-to-stereo plug-in on a mono Auxiliary Input changes the signal path from that plug-in through the rest of the track.
This restricts all hardware inserts or plug-ins after the stereo plug-in to be stereo-in/stereo-out plug-ins (or the supported multichannel format).

**Plug-In Formats**

All Pro Tools TDM and LE systems support mono and stereo plug-ins. The following three types of plug-in paths are supported on all Pro Tools systems:

- mono-in/mono-out
- mono-in/stereo-out
- stereo-in/stereo-out

Pro Tools TDM systems running the Surround mixer also support 3–8 channel, multi-mono and multichannel plug-ins.

**Viewing I/O, Inserts, and Sends**

Both the Mix and Edit windows can be configured to show or hide various mixing controls.

**To show or hide I/O, inserts, and sends in the Mix and Edit windows:**

1. Choose Display > Mix Window Shows or Display > Edit Window Shows.
   - or –
   Click the View Selector in the Edit window.

2. Choose any or all of the following:

   **Comments View** Shows any text entered as comments in the Track Name dialog. For more information, see “Naming Tracks” on page 89.

   **I/O View** Shows input and output, volume, and pan controls in each track. Deselect to hide.

   **Inserts View** Shows inserts (software plug-ins and hardware I/O inserts) in each track. Deselect to hide.
Sends View  Shows send assignments in each track. Deselect to hide. For more information, see “Configuring Sends View in the Mix and Edit Windows” on page 391.

Mic Preamps View  Shows controls in each track for the Digidesign PRE. Deselect to hide. For detailed information, see the PRE Guide.

Track Input

Input Selectors determine the source input for audio tracks and Auxiliary Inputs. Track input can be a hardware input, bus, or DirectConnect input path. While recording, the Input Monitor mode determines when live input will be monitored through a record-enabled audio track.

You can also define what physical ports are routed to Pro Tools input ports in the “Main” page of the Hardware Setup dialog. For more information, see “Configuring Pro Tools System Settings” on page 39.

To assign track input:

- Select an input path or sub-path from the track Input Selector.

To assign multiple tracks to the same input:

- Option-select (Macintosh), or Alt-select (Windows) a track input to assign all tracks to the selected input.
  - or -

- Option-Shift-select (Macintosh), or Alt-Shift-select (Windows) a track input to assign all selected tracks to the selected input.
To assign multiple tracks to unique inputs (ascending, incrementing):

- Command-Option-click (Macintosh), or Control-Alt-click (Windows) a track input to assign it to the desired input path, and auto-assign each subsequent track to the next available input path (moving top-to-bottom in the Edit window, left-to-right in the Mix window).

Availability is determined by the path format, and the active/inactive state of the tracks.

### Track Output

Track Output Selectors route the post-fader signals to the assigned output or bus paths.

The Output Selector routes the main track output to the chosen main or sub-path. Tracks can be routed directly to hardware outputs, or to internal bus paths for submixing (main or sub-paths).

The track format (mono, stereo, or multichannel) determines the available main and sub-path choices for track output.

When you create new tracks, their default Output assignment is determined by your selection of Default Output Path in I/O Setup. You can change the Default Output Path in I/O Setup to any available path. For more information, see “Default Output Path” on page 80.

**Sends, and Send windows, provide another way to route track audio. See “Sends” on page 389 for more information.**

To assign a track output:

- Select the desired output path or sub-path from the track Output Selector.

**Assigning track output, Mix window**

To assign all audio or Auxiliary Input tracks to the same output:

- Option-select (Macintosh), or Alt-select (Windows) a track output to assign all tracks to the same path.

To assign all selected audio or Auxiliary Input tracks to the same output:

- Option+Shift (Macintosh), or Alt+Shift (Windows) a track output, to assign all selected tracks to the same path.

To assign multiple tracks to unique outputs (ascending, incrementing):

- Command-Option-click (Macintosh), or Control-Alt-click (Windows) a track output to assign it to the desired output path, and auto-assign each subsequent track to the next available output path (moving top-to-bottom in the Edit window, left-to-right in the Mix window).
Output Paths
When audio tracks, Auxiliary Inputs, and Master Faders are created, their mono, stereo, or multichannel format is defined.

- Mono tracks can be assigned to any available mono, stereo, or other multichannel main and sub-paths.
- Stereo tracks can be assigned to any available mono, stereo, or multichannel main and sub-paths.
- Multichannel tracks can be assigned to any mono path, or path of the same number of channels (for example, an LCRS track can be assigned to a mono or LCRS path).

Output Windows
Output windows provide the essential track mixing controls (such as track panning and volume), as an alternative to Mix and Edit window views. Multichannel Output and Send windows also provide expanded Panner views, and other surround-specific controls. (See Chapter 33, “Surround Panning and Mixing.”)

Output windows are useful in large sessions to leave important tracks in an anchored location, unaffected by Mix and Edit window (or control surface) banking. See “Output Windows for Tracks and Sends” on page 393.

These windows appear differently for mono, stereo, and multichannel tracks. For multichannel mixing, there is also an X/Y panner Output window available. For more information on using multichannel Output windows, see Chapter 33, “Surround Panning and Mixing.”

Multiple Output Assignments
Pro Tools audio tracks and Auxiliary Inputs can have multiple track output and send assignments. Multiple outputs are limited only by the paths and resources available on your system.

Assigning to multiple paths is an efficient way to route an identical mix to other discrete outputs, for simultaneous monitor feeds, headphone mixes, or other situations where a parallel mix is needed. Master Faders can only be assigned to a single path.

You can also define what physical ports are routed to Pro Tools output ports in the “Main” page of the Hardware Setup dialog. For more information, see “Configuring Pro Tools System Settings” on page 39.
To assign a track to multiple outputs:

1. Assign a main output path by selecting it from the track's Output Selector.

2. Control-click an additional output path in the track's Output Selector. The newly selected output destination is added as an additional output.

Option-Control-click to add the assignment to all tracks, or Option-Shift-Control-click to add to all selected tracks.

Display of Multiple Output Assignments

When a track is assigned to multiple output paths, the Output Selector denotes multiple assignment status and active/inactive status with the following indicators:

- A plus sign (+) indicates that the track has multiple output assignments.

Indication of multiple output assignments

- In the Output Selector menu, all currently assigned track outputs are checked to indicate they are active for the current track.
- An asterisk (*) indicates that one or more currently assigned outputs is Inactive.

Inactive Outputs

(TDM Systems and Pro Tools LE 6.0 Only)

An output path can be made inactive, either globally in the I/O Setup window (affecting all tracks assigned to that path), or locally per assignment (only affecting that output on that audio track or Auxiliary Input).

When opening sessions, outputs will be made inactive automatically if the required hardware or other resources are not available.

Inactive outputs retain all associated automation playlists. Edits made in the session also affect the inactive track's output automation playlists.

See “Making Tracks Inactive” on page 99.

Inactive Outputs and DSP Resources

Making a track output inactive silences the output, while retaining all automation and playlist data. Inactive outputs do not consume resources for TDM mixer connections, but any assigned plug-ins on the track continue to use their required DSP resources. RTAS plug-ins require CPU resources, and TDM plug-ins use the DSP available on Pro Tools audio cards.

You can free up DSP of unused plug-ins by setting a track to inactive, or by setting just the plug-in to inactive.

See “Active and Inactive Items” on page 16, and “Making Inserts Inactive” on page 408 for more information.

About the “No Output” Option

Track outputs can be set to No Output. Assigning a track output to No Output loses any panning automation associated with the track.

Tracks assigned to No Output will not be audible, but they do not free their associated DSP resources.
Sends

Pro Tools lets you insert up to five sends on each audio track or Auxiliary Input.

Sends provide the following features:

- Sends can be set as pre- or post-fader.
- Send level and mute can be configured to follow Groups.
- Send level, send mute, and send pan (for stereo and multichannel sends) are fully automatable. See “Automating Sends” on page 380.
- Send controls can be displayed and edited from the Mix or Edit windows, or in their own output windows.
- Sends can be assigned to available output and bus paths (main or sub-paths), in mono or stereo, or any of the supported multichannel formats for surround mixing.
- Each Send can have multiple assignments (for example, to available output and bus paths).

Sends must be returned to the mix through an Auxiliary Input or audio track to be audible in Pro Tools. They can be monitored and processed through an Auxiliary Input, recorded to audio tracks, and bounced to disk. (Bouncing and mixdown are explained in Chapter 29, “Mixdown.”)

Assigning Sends to Tracks

To add a send to a track:

1. Make sure Sends View is enabled in the Mix or Edit window (see “Viewing I/O, Inserts, and Sends” on page 384 for information).
2. Click the Sends button on the track and choose a path from the pop-up menu.

The send can be a mono or stereo (or any of the supported multichannel formats for surround mixing) output or bus path.
The Send window opens.

To remove a send from a track:
- Click the Sends button on the track and choose No Send from the pop-up menu.

Send Formats

Mono and Stereo Sends Available on all Pro Tools systems. When you click the Sends button on a track, you can choose from a list of mono or stereo output or bus paths.

Multichannel Sends Supported on Pro Tools|HD-series and MIX-series systems only

Send Path Choices

The choices available in track Send Selectors include bus and output paths.

The names, format, and channel mapping of busses and output paths can be customized in the I/O Setup dialog. See “Creating and Editing Paths” on page 71.

Internal Mix Busses Pro Tools TDM systems provide 64 busses and Pro Tools LE systems provide 16 busses for routing signals internally. Internal bus paths are useful for submixing and processing with plug-ins. Bus paths are defined in the I/O Setup dialog, and are available in all supported channel formats (mono, stereo, or multichannel, as supported on your system).

Hardware Outputs Hardware sends are often used for headphone cue mixes, or for sending signals to external effects processors. Sends do not automatically return audio as do hardware inserts.

Send window (mono)

2 Set the output level of the send in the Send window:
- Adjust the send level fader.
  – or –
- Set the send level to unity gain (0 dB) by Option-clicking (Macintosh) or Alt-clicking (Windows) the send fader.

The first time you create a new send, its output level is automatically set to off, displayed on-screen as –INF (–∞).

To change the default setting for sends:
1 Choose Setup > Preferences, and click the Operation tab.
2 Select Sends Default to “–INF”.
  – or –
Deselect Sends Default to “–INF” and new sends will default to unity gain (0 dB).
Configuring Sends View in the Mix and Edit Windows

Sends are displayed in the Mix and Edit window according to the Sends View Shows settings. Choices include Assignments View, plus the five Send A–E Views, explained below.

To display the controls for an individual send across all tracks:

1. If sends are not currently visible on your tracks, choose Display > Mix Window Shows (or Edit Window Shows) > Sends View.

2. Do one of the following:
   - Choose Display > Sends View Shows and select the send (A–E).
   - In Assignment View, Command-click (Macintosh) or Control-click (Windows) the Send Selector.
   - or –
   - When displaying sends in a Send A–E View, select the send (A–E).

To show all send assignments:

- Choose Display > Sends View Shows > Assignments.
  - or –

When displaying sends in a Send A–E View, Command-click (Macintosh) or Control-click (Windows) the Send Selector and select Assignments.

Assignment View

This is the default Send Display mode, showing the five available sends on all tracks displayed in the Mix and Edit windows.

In Assignment View, send parameters are edited from their output windows. See “To view a different track Output or Send window:” on page 394.

Send A–E Views

The Send A–E views provide send level, pan, and mute controls.

Parameters for sends can be edited directly using these controls. Sends can also be opened for editing or metering in Send windows. See “Output Windows for Tracks and Sends” on page 393.
**Editing Sends in the Mix and Edit Windows (Send A–E Views)**

Send A–E Views display all the parameters of an individual send in the sends area of the Mix and Edit windows. These views provide full access to all controls for that send on all tracks.

Send level and mute can follow Mix groups, to adjust multiple send parameters from a single set of controls. (See “Sends and Groups” on page 398.)

**Sends View Meters**

When you display the controls for an individual send, you also have the option of displaying send level meters.

Send level meters show peak values and indicate clipping that occurs while the meter is displayed (if a send clips any time before its meter is displayed, this is not shown). If you are using a slower computer, hiding send level meters can improve screen redraw times.

**To display send level meters when viewing individual sends:**

1. Choose Setups > Preferences and click Display.
2. Select Show Meters in Sends View and click Done.

**Send Mute and Send Window Status Display**

When displaying sends in a Send A–E View, the Send Mute switch is visible directly in the Mix or Edit windows.

In Assignment View, Send Mute and Output window status are displayed as follows:

- The Send Bypass indicator is lit when the send is muted.
- The Send button is lit whenever a send’s window is open.

If you use a control surface (such as ProControl or Control|24) with Pro Tools, colored outlines around sends, inserts, and Outputs indicate the current controller focus.

**To clear a send meter’s Clip indicator:**

- Click on the Clip indicator. Or, Option-click the indicator to clear all.

In Assignment View, edit sends by opening their Output windows. See “To view a different track Output or Send window:” on page 394.
**Inactive Sends**

Sends can be made inactive. Inactive sends free their DSP and mixer resources, while retaining their position in track Sends View. Inactive sends do not output audio. However, Inactive sends retain all associated automation playlists. In addition, any edits made in the session affect the sends automation playlists.

To make a send inactive:

- Command-Control-click (Macintosh), or Control-Start-click (Windows) on the send (its assignment). Use the Option and Option+Shift modifiers to affect that send (A–E, if present) on all or all selected tracks, respectively.

- or –

Make the Track inactive. See “Making Tracks Inactive” on page 99.

When opening sessions, sends will be made inactive automatically if the required hardware or other resources are not available.

---

**Output Windows for Tracks and Sends**

Track outputs and sends can be opened for display and editing in dedicated windows.

- Track Output windows provide track fader, pan, automation, solo, and mute controls.
- Send windows provide send level, mute, pan, and automation controls.
- Standard Output and Send window controls provide additional routing, assignment, and display settings.
To open a track Output window:

■ Click the Output icon in the channel strip.

To open a Send window:

■ Click the send in the Mix or Edit window.

To view a different track Output or Send window:

■ Click an output icon, or send, in the Mix or Edit window.

If a similar Output window was already open with a highlighted Target icon (red, lit), the newly selected send will open in its place.

Opening Multiple Output Windows

Multiple track and Send windows can be displayed simultaneously using either of the following methods.

To open additional Output windows:

■ Shift-click any output icon or send.
**To set a window to remain open:**
- Make sure the Target is disabled.

Arrange multiple windows as needed. For additional information, see “Targeted Windows” on page 397.

**Panner Linking**

Stereo outputs provide two panning controls, one for each side of the left/right pair.

The Output window provides controls to unlink (or link) channels for precise panning of stereo and multichannel tracks.

In the default Linked mode, all sides match changes to any other side’s pan control. This is Absolute Link mode. To mirror panning changes, see “Inverse Linked Panning” on page 395.

When unlinked, pan controls are completely independent of each other.

To enable linking:
- Enable the Link icon.

To unlink an output for independent panning:
- Deselect the Link icon.

**Inverse Linked Panning**

When linked and set to Inverse mode, panning moves are inverted, or reversed, in the other channels.

Inverse panning reflects one side’s location and direction in the other side. For example, when enabled for Front Inverse, if you pan one side of a stereo track output from right to left, the other side will exactly mirror that movement and pan left to right.
Front (stereo: left/right) inverse linking is available on all systems. Rear Inverse, and Front/Rear Inverse linking are available on Pro Tools|HD-series and MiX-series systems only, and only appear as options on multichannel plug-ins and panners/output windows.

To enable inverse linking:
1. Enable the Link icon.
2. Select an Inverse mode.

**Standard Selector Controls in Output Windows**

All Output windows provide standard selectors for path, automation, and other controls in the top area of the window (the Output Editor area).

**Path Selector** Allows you to assign the Output path for the current track or send.

**Pre/Post Fader (Sends Window Only)** Determines whether the send is pre- or post-fader.

**Safe** Protects track and send level, pan, and other controls from automation overwrites by placing them in Automation Safe mode. See Chapter 28, “Automation” for more information.

**Inverse Pan** Reflects one side’s panning location and direction in the other side (for example, left- and right-channel pan controls).

**Link and Unlink** Allows linking and unlinking of left and right (or other) outputs in stereo (or multichannel). Unlinked mode provides discrete adjustment of individual sides, or channels. When linked, all changes affect all channels. See “Panner Linking” on page 395.

**Target** Identifies the target of plug-in settings commands. Also sets the current window for display of Output windows. See “Targeted Windows” on page 397.

**Meter View** opens the path Meter View. These meters display levels of the selected path (not the levels of the track or send).

**Close** Closes the window.

**Track Selector** Provides access to any audio track, Auxiliary Input, or Master Fader in the session.

**Output Selector** Provides access to other outputs (track and send) in the track, if any, displaying the selected output in the current window.

**Send Selector (Send Window Only)** Provides access to other sends on the track.
Track Fader, Solo, Mute, and Auto

Output windows provide the associated track’s volume fader, pan controls, solo and mute switches, and Automation Mode Selector. Use these to adjust or automate the parameters of the Output window.

Targeted Windows

When lit (red), the Target indicates its window is “targeted,” and the next window opened of the same type replaces the current display (unless it is opened as an additional window with the Shift modifier). When unlit, the target is gray, and the current window anchors to its current contents and location on-screen. Opening additional windows does not affect anchored windows.

To set an open Send window as the Target window:
- Click the Target, so that it is lit (red).

Plug-in windows have additional features related to the Target (such as Focus of Settings commands). See “The Plug-In Window” on page 410.

Using Output Windows

Output windows provide standard Pro Tools track, send, Target, and other controls.

To move to a different track:
- Click the Track Selector button and choose a track from the pop-up menu.

To reassign output:
- Click the Path Selector button and select a path from the pop-up menu.
To display the controls for a different send on the same track:

- Click the Send Selector button and select the send.

To add an additional send to the same track:

- Click the Send Selector button and choose the desired output or bus path from the pop-up menu, then click the Send Path Selector and choose a destination from the pop-up menu.

To add an additional output assignment to the current track or send:

- Control-select an additional output path from the Send Selector.

**Sends and Groups**

Send level and mute can follow Mix groups in each of the five available sends (A–E). Use this option to adjust multiple send parameters from a single set of controls.

To configure sends and Mix groups:

1. Choose Setup > Preferences, and click the Automation tab.
2. Enable Send Level Follows Groups, or Send Mute Follows Groups, as desired.
3. Click Done to set the new Preferences.

For more information on groups, see “Grouping Tracks” on page 100.

**Copying Track Settings to Sends (TDM Systems Only)**

Sometimes you need send settings to match the settings in the track itself—for example, to provide a headphone mix based on the main mix.

To copy track settings to sends:

- Assign an additional (multiple) output to all tracks, adding the headphone Output path to the main mix output assignments. (See “Multiple Output Assignments” on page 387).

  – or –

- Copy a track’s volume fader, pan slider, or mute button position to the corresponding controls for a send on that track. (See “Copying Track Automation to Sends” on page 431.)

**Submixing for Signal Routing and Effects Processing**

The bussing and mixing features in Pro Tools support myriad possibilities for submixing and signal routing, including the ability to:

- Create inputs for MIDI devices and other audio sources, to monitor or record in Pro Tools.
- Control and automate any submix from a single fader and channel strip.
- Apply real-time plug-ins or an external processor to the submix, using the Auxiliary Input as an effects return.

**Audio Input from MIDI Devices and Other External Sources**

You can use an Auxiliary Input to bring external audio sources such as MIDI devices, tape, microphone inputs, and instruments, into a Pro Tools mix.
To use Auxiliary Inputs to bring external audio sources into a mix:

1. Connect the audio outputs of your MIDI and other external devices to available inputs on your Pro Tools audio interfaces.

2. If necessary, configure the I/O Setup dialog for the input paths you plan to utilize. The I/O Setup dialog configuration determines the choices available for track sends, inputs, busses, and hardware inserts. (For more information, see Chapter 7, “I/O Setup.”)

3. Specify the track type (Aux Input), and mono, stereo, or any of the supported multichannel formats for surround mixing.

4. Click Create.

5. Set the input of the Auxiliary Input track to the appropriate input path.

6. Assign the track output to the appropriate path, or paths. (See “Multiple Output Assignments” on page 387 for more information.)

7. Adjust the Auxiliary Input fader to control the track, and any assigned post-fader send levels.

Creating a Submix

Audio is routed to a submix by assigning any combination of sends and track outputs to available bus or output paths.

Auxiliary Inputs can serve as effects returns by inserting plug-ins or external effects processors.

Submixing with Track Outputs or Sends

You can use both track outputs and sends to route audio for submixing, depending on whether you want a discrete or send and return submix.

Discrete Submix Output

Pro Tools lets you discretely route source audio through the submix. This is preferred for dither or other mastering processing, where you do not want unprocessed audio heard in addition to the processed signals. Use track outputs (not sends) to assign tracks to a bus path for discrete submixing. In this arrangement, the balance of processed and unprocessed signal is controlled by plug-in wet/dry settings.

For another way to submix effects, see “Send and Return Submixing for Effects Processing” on page 400.

To create a discrete submix:

1. Set the output of the tracks you want to include in the submix to a stereo bus path.

2. Pan each track.


4. Specify the track type (Aux Input) and format (stereo), then click Create.

5. Set the input of the Auxiliary Input to the same bus path to which you assigned all contributing tracks.

Mixing Audio Input from MIDI Devices and External Sources

By mixing MIDI and other audio sources through Pro Tools, you can apply mix automation to the volume, pan, mute, send level, send pan, send mute, and plug-in controls of the Auxiliary Input.

Auxiliary Inputs can be routed to audio tracks through internal send busses, or using their track output, to record them to disk.

Using plug-ins, inserts, and sends on Auxiliary Inputs, you can process instruments and other inputs with real-time plug-ins, or external devices. See “Send and Return Submixing for Effects Processing” on page 400.
6 Set the output of the Auxiliary Input track to your main stereo mix outputs (typically, outputs 1–2).

7 Set the Auxiliary Input Track level.

8 To process the submix, assign a plug-in or hardware insert on the Auxiliary Input.

9 Set the parameters of the plug-in. The plug-in Bypass and Wet/Dry controls (if available) determine the amount of effect heard.

The contributing track faders control the balance within the submix. The Auxiliary Input track controls the output levels of all tracks routed to it.

You can apply mix automation to the volume, pan, mute, and send level, send pan, and send mute controls of the Auxiliary Input.

You can also bounce a submix to disk to free up the voices for use by other tracks. See Chapter 29, “Mixdown” for information.

**Send and Return Submixing for Effects Processing**

When you are submixing for reverb, delay, and similar effects processing, use sends to achieve traditional send/return bussing. You can use a real-time plug-in or a hardware I/O insert as a shared resource for all tracks included in a submix. The wet/dry balance in the mix can be controlled using the track faders (dry level) and Auxiliary Input fader (effect return, or wet, level).

💡 For convenience, you can configure send levels and send mutes to follow Mix Groups. This can simplify setups with large submixes. See “Sends and Groups” on page 398 for more information.

See Chapter 27, “Plug-In and Hardware Inserts” for more information.

**Send and Return with a Plug-In or Hardware Insert**

To create an effects return submix with a plug-in or hardware insert:

1 Assign each track’s main output to your main mix outputs.

2 On the source tracks, assign a send (mono or stereo) and select a mono or stereo bus path from the send’s Output Selector. Configure the sends for pre- or post-fader, as needed.

3 Choose File > New Tracks.

4 Specify the track type (Aux Input) and format (stereo), then click Create.

5 Assign a plug-in or hardware insert on the Auxiliary Input.

6 Set the effect to “100% wet,” and configure any other parameters as needed.

7 From the Auxiliary Input track’s Output Selector, select an output path (main outputs).
Adjust the individual track faders to balance the dry (unprocessed) tracks. The amount of effect is controlled by the level of the Auxiliary Input fader.

**Send and Return with an External Device**

To avoid latency introduced by bussing, you can route the send directly to the interface output path connected to an external effects device.

To create an effects return submix with an external device:

1. Assign each track’s main output to your main mix outputs.
2. Assign a send (mono or stereo) and set the send destinations on the source tracks to the output path connected to the external device. Configure the sends for pre- or post-fader, as needed.
4. Specify the track type (Aux Input) and format (stereo), then click Create.
5 From the Auxiliary Input track’s Input Selector, select the input path connected to the external device.

6 From the Auxiliary Input track’s Output Selector, select an output path (main outputs).

Adjust the individual track faders to balance the dry (unprocessed) tracks. The amount of effect is controlled by the level of the Auxiliary Input fader.

Creating a Master Send Level Control

A Master Fader can control the overall level of bus and output paths.

To create a Master send level control:
1 Choose File > New Track.
2 Specify the track type (Master Fader), and mono, stereo, or any of the supported multichannel formats for surround mixing.
3 Click Create.
4 Do one of the following:
   • Set the output of the Master Fader to the same path that you are using to send to an Auxiliary Input track.
   • Set the output of the Master Fader to match the path that you have chosen for your effects send.

You can then adjust send levels to balance the source tracks, and use the Master Fader as a master level control for the entire submix.

Soloing Tracks in a Submix

When you want to solo any tracks in a submix, you can solo safe the Auxiliary Input track. This solos tracks that are bussed to the Auxiliary Input without having to solo the Auxiliary Input as well.

To solo safe an Auxiliary Input:
- Command-click (Macintosh) or Control-click (Windows) the Solo button on the Auxiliary Input track.

To solo an individual track that is part of a group:
- Control-click (Macintosh) or Start-click (Windows) the Solo button.

Generating Stereo Output from a Mono Send/Return

You can use an Auxiliary Return arrangement to generate a stereo output from a mono send. Set the send destination to a mono Auxiliary Input track and place a stereo plug-in on the Auxiliary Input. The output of the Auxiliary Input becomes stereo.

Dither

Dither is a special form of randomized noise used to mask quantization noise in digital audio systems. Digital audio’s poorest distortion performance exists at the lowest end of the dynamic range, where quantization distortion can occur. Dither reduces quantizing errors by introducing very low-level random noise, thereby minimizing distortion artifacts as audio reaches low level. With dither there is a trade-off between signal-to-noise performance and less-apparent distortion. Proper use of dither lets you squeeze better subjective performance out of a 16-bit data format (such as Red Book compact discs).
Pro Tools TDM systems process all audio internally at 24-bit, and Pro Tools LE processes internally at 32-bit, floating. Without Dither to process the 24-bit data to 16-bit, the extra 8 bits are truncated (dropped entirely) when written to media or a device with a 16-bit maximum (such as CD recorders, and many DAT machines). Dithering, on the other hand, preserves low-level (quiet) fidelity in a surprising way—by adding a small amount of noise to a signal.

**Dither in Pro Tools**

There are several dither options provided in Pro Tools. Each has a specific application within the various operations that could benefit from dithering.

In addition to the TDM, RTAS and AudioSuite dither plug-ins, Pro Tools has a built-in dither capability.

**Dither Mixer Plug-Ins** Pro Tools|HD provides two Mixer plug-ins that feature dither with noise shaping: Stereo Dithered and Surround Dithered. For more information, see “Surround Dithered and Stereo Dithered Mixers” on page 578. Standard Stereo and Surround Mixers do not have dither and require use of dither plug-ins.

**Dither on Final Output for Mixdown** You can insert a real-time dither plug-in on a Master Fader to dither your final mix, post-fader, for CD or other 16-bit media. Inserts on Master Fader process post-fader. During Bounce-to-Disk, this form of dithering lets you use dither plug-ins from Digidesign or third-party manufacturers. For more information, see “Dither and Bounce to Disk” on page 450.

**AudioSuite Dither** For AudioSuite plug-in processing, dither is based on the Dither plug-in.

**Operation Preferences, for AudioSuite dither**

For most AudioSuite plug-ins, dither can be automatically applied in the Pro Tools Preferences dialog, under Processing. The Use AudioSuite Dither checkbox enables a preset, N-shaped dither.

The following AudioSuite plug-ins can automatically apply dither when processing:

- EQ II
- Compressor II
- Limiter II
- Gate II
- Expander/Gate II
- Normalize
- Gain
- DC Offset Removal
- Time Compression/Expansion
- Pitch Shift

*For information about AudioSuite dither, see the Digi-Rack Plug-Ins Guide.*
**Fades and Crossfades** In the Fades dialog (Edit > Fades > Create Fades), the Use Dither checkbox enables a preset, noise-shaped dither.

**Noise Shaping**

Noise is an integral part of the dithering process. Noise shaping can further improve audio performance and reduce perceived noise inherent in dithering. Noise shaping utilizes digital filtering to move noise from frequencies around 4 kHz to near the Nyquist frequency. Essentially, noise shaping lessens our perception of the noise inherent in dithering by shifting audible noise components into a less audible range.

Noise Shaping is available in the Dither plug-in.

For more information about dither during mixdown, see Chapter 29, “Mixdown.”

---

**Using a Control Surface with Pro Tools**

There are several optional control surfaces for mixing in Pro Tools:

- Pro Tools TDM and LE systems can use Digidesign Control|24 or ProControl (TDM systems only). These control surfaces are dedicated controllers that provide access to Pro Tools recording, mixing, editing, signal routing, plug-in control, and automation features.

- ProControl-equipped Pro Tools systems can use Digidesign’s EditPack. This control surface option provides many mixing and panning features to enhance multichannel mixing for surround sound. Additionally, EditPack provides direct access to many of the most frequently used Pro Tools commands and features.

- Pro Tools TDM and LE systems support MIDI control surfaces, including the CM Labs Motor Mix, Mackie HUI (Human User Interface), JL Cooper CS-10, and Peavey PC-1600.

- Pro Tools|HD-series and MIX-series systems running the Surround mixer can use the JL Cooper MCS3000 Joystick Panner. However, on ProControl systems with EditPack enabled, you cannot use the MC3000 Joystick Panner.

For more information on using MIDI control surfaces with Pro Tools, refer to the Pro Tools MIDI Control Surfaces Guide.
Chapter 27: Plug-In and Hardware Inserts

Pro Tools provides up to five unity-gain inserts on each audio track, Auxiliary Input, or Master Fader. Audio track and Auxiliary Input inserts are pre-fader, and Master Faders inserts are post-fader only.

An insert can be either a software DSP plug-in or a hardware insert. A Pro Tools insert routes the signal from the track to a plug-in or external hardware effect of your choice and automatically returns it to the same track. Inserts do not alter the original audio source files, but process audio in real time, during playback. You can permanently apply real-time effects to tracks by recording or bouncing the effect to disk (see Chapter 29, “Mixdown” for more information).

**Plug-In Inserts** Plug-in inserts are software inserts that process audio material on a track in real time. For example, the EQ, Dynamics, and Mod Delay plug-ins supplied with your Pro Tools system are real-time plug-in inserts.

For more information about plug-ins, see the DigiRack Plug-Ins Guide.

Additional real-time plug-ins are available from Digidesign and from many third-party developers.

For more information, see the Digidesign Plug-Ins Guide.

**Hardware I/O Inserts** Hardware I/O inserts can route audio through an external device connected to the inputs and outputs of your audio interface. You can process the audio material on a track with a hardware insert in real time.

Insert paths require audio interface inputs and outputs, and are determined by the I/O Setup configuration of your system.

**General Information**

When more than one insert is used on a track, they are processed in series. Each effect is added to that of any previous plug-ins or inserts, (flow from top to bottom in the Mix window Inserts View, and left to right in the Edit window Inserts View).

Inserts on audio tracks and Auxiliary Inputs are pre-fader. You can cause clipping if you boost their gain to extremes, especially on tracks recorded at high amplitude. Watch on-screen metering for indication of clipping. (Inserts on Master Faders are post-fader.)
How to Use Inserts for Effects Processing

Inserts can be used in two ways:

On Single Tracks An insert can be applied to an individual audio track, Auxiliary Input, or Master Fader.

With in-line inserts, you control the amount of effect by adjusting the balance (or, wet/dry) controls of the plug-in or external device.

As Shared Resources An insert can be used as a shared resource in a send-and-return arrangement, by bussing signals from several tracks to an Auxiliary Input, and then applying the insert to the Auxiliary Input track. You can then control the send level for each track, and the overall level of the effect can be controlled from the Auxiliary Input track. Using sends and other signal routing features helps maximize your system’s processing power.

For examples of send and return busses and other submixing setups, see “Submixing for Signal Routing and Effects Processing” on page 398.

Insert Formats

Mono Inserts Are designed for use on mono tracks. Inserts that occur on a track after a stereo insert are automatically used in stereo as well.

Stereo Inserts Are designed for use on stereo tracks. A stereo hardware I/O insert sends the signal to an input/output path.

Mono In/Stereo Out Plug-In Inserts Are designed to return a stereo effect from a mono source. Certain plug-ins (such as D-Verb) let you generate stereo output from a mono channel. A track made into stereo in this way has pan controls for each channel of the stereo signal. Any inserts that occur on a track after a stereo insert are automatically used in stereo as well.

Multi-Mono Plug-In Inserts Are designed for use on stereo or greater multichannel tracks when a multichannel version of the plug-in is not available. Parameters for all channels are linked by default so that you can adjust them in tandem. You can unlink parameter controls for independent adjustment using the Master Link button. See “Linking and Unlinking Controls on Multi-Mono Plug-Ins” on page 413.

Multichannel Plug-In Inserts Are designed for use on stereo and greater-than-stereo multichannel tracks. On greater-than-stereo multichannel tracks, the parameters for all channels are generally ganged together.

Relinking may cause automation to be lost. See “Linking and Unlinking Controls on Multi-Mono Plug-Ins” on page 413

TDM and RTAS Plug-Ins

There are three formats of plug-ins (TDM, RTAS, and AudioSuite); two of which can be used as real-time inserts:

TDM Plug-Ins Are designed for use on TDM-based Pro Tools systems, and rely on the processing power of Digidesign DSP cards.

RTAS Plug-Ins Provide features and functionality similar to their TDM counterparts, but unlike TDM plug-ins, they rely on and are limited by the host processing power of your computer.
Use the following guidelines for plug-ins supported on your system:

**Pro Tools TDM Systems**
- TDM plug-ins can be used on audio tracks, Auxiliary Inputs, and Master Faders.
- RTAS plug-ins can be used on Auto Voiced audio tracks only.
- When using RTAS and TDM plug-ins on the same track, RTAS plug-ins must precede TDM plug-ins in the insert signal path.

**Pro Tools LE Systems**
- RTAS plug-ins can be used on audio tracks, Auxiliary Inputs, and Master Faders.

For tips on maximizing RTAS performance, see the DigiRack Plug-Ins Guide.

**Viewing Inserts**

Both the Mix and Edit windows can be configured to show or hide inserts. Plug-In windows provide complete access to plug-in parameters.

**To show (or hide) inserts in the Mix or Edit windows:**

1. Choose Display > Mix Window Shows > Inserts View, or Edit Window Shows > Inserts View.

**Mix Window Inserts Views**

**To show or (hide) inserts in the Edit window:**

- Select Inserts View from the View Selector (located next to the Rulers View). See “Configuring Sends View in the Mix and Edit Windows” on page 391 for more information.
Display of Plug-In Window Status

In the Mix and Edit window, the Plug-In button and Selector display bypass state (see “Bypassing Plug-Ins” on page 413), target status, and window status.

Hardware Inserts and Bypass

You cannot bypass hardware inserts from Pro Tools. To monitor playback without a hardware insert, either set it to Inactive, remove it by reassigning it to No Insert, or use a bypass switch on the hardware device itself. See “Inactive Inserts” on page 416 for more information.

Indicating the Controller Target

If you are using a control surface with Pro Tools, only one plug-in can be targeted at a time. The current controller target, if any, is indicated with a color outline around its name:

Making Inserts Inactive

Plug-in and hardware inserts can be made inactive to free up their resources for other uses. When a plug-in insert is inactive it retains its assignment, position, and related automation playlists. However, it will not pass audio and does not consume any DSP or TDM resources.

To make an insert inactive:

- Command-Control-click (Macintosh) or Control-Start-click (Windows) the Insert button. (Use Option and Option+Shift modifiers to apply to all or all selected, respectively.)

- or –

Make the track inactive. See “Making Tracks Inactive” on page 99.

When opening sessions, plug-in inserts will be inactive in any of the following situations:

- The plug-in is not installed.
- The plug-in type is not available (RTAS or TDM). Or, opening the session results in plug-in type substitutions. This can happen if, for example, the type is available but substituting would result in an unsupported condition, such as an RTAS plug-in after TDM plug-ins in a track.

Inactive plug-in inserts retain all associated automation playlists. In addition, any edits made in the session affect the plug-in automation playlists. You cannot record automation for an inactive plug-in, or edit plug-in parameters in the Plug-In window.
Chapter 27: Plug-In and Hardware Inserts

409

Inserting Plug-Ins on Tracks

To use a real-time plug-in in a Pro Tools session, insert it on a track.

To insert a plug-in on a track:

1. Make sure the Inserts View is shown in the Mix or Edit window.
2. Click the Insert Selector on the track and select the plug-in that you want to use. (See “TDM and RTAS Plug-Ins” on page 406 for related information.)

Display of inactive plug-ins (Pro Tools 5.x)

Display of inactive Plug-In window

Inserting Plug-Ins During Playback

On Pro Tools|HD (Pro Tools 6.0 only) and Pro Tools LE systems, plug-ins can be inserted or removed on-the-fly during playback, with the following restrictions:

- Plug-ins cannot be inserted or removed during recording (Pro Tools 6.0 only).
- Plug-ins that change a track’s format (a mono-to-stereo plug-in, for example) cannot be inserted or removed during playback. Stop playback to do this.
- Plug-ins that contain automation cannot be removed during playback. Stop playback to do this.
- Playback must be stopped when enabling plug-in parameters for automation.
- Side chain inputs cannot be created during playback. Stop playback to do this.

⚠️ On Pro Tools 24|MIX systems, plug-ins cannot be inserted on-the-fly.
Moving and Duplicating Plug-In and Hardware Inserts

You can move or duplicate a plug-in insert by dragging it to a different position on the same track or a different track. Inserts that are moved or duplicated retain their original settings and automation. Dragging an insert on top of an existing insert will replace it (and its automation, if any).

To move an insert:
- Drag the insert to the desired location.

To duplicate an insert:
- Option-drag (Macintosh) or Alt-drag (Windows) the insert to the desired location. Duplicated plug-in inserts retain their original settings and automation.

The Plug-In Window

The Plug-In window appears whenever you click a plug-in’s Insert button on a track. This floating window lets you edit the parameters of any real-time plug-in insert in use on a track.
**Settings Menu**  Lets you copy, paste, save, and import plug-in settings.

**Track Selector**  Accesses any non-MIDI track in your session.

**Librarian Menu**  Recalls settings files saved in the plug-in’s root settings folder or in the current session’s Settings folder.

**Insert Position Selector**  Accesses any insert on the current track.

**Key Input Selector**  Lets you select audio on a particular input or bus and route it to trigger the plug-in. This menu only appears on plug-ins that feature side-chain processing. Key inputs are monophonic.

**Plug-In Selector**  Lets you select any real-time plug-in installed in the DAE Plug-Ins folder.

**Compare**  Toggles between the original saved plug-in setting and any changes you have made to it so you can compare them.

**Effect Bypass**  Disables the currently displayed plug-in. This lets you compare the track with and without the effect.

**Enable Automation Parameters**  Lets you enable individual plug-in parameters for automation recording. See “Automating Plug-Ins” on page 431.

**Automation Safe**  When enabled, prevents existing plug-in automation from being overwritten.

**Convert Plug-In**  Lets you convert the insert from a TDM plug-in to an RTAS plug-in of the same type (or vice-versa). This feature can only be used on plug-ins that are available in both TDM and RTAS formats.

**Target Plug-In**  When multiple Plug-In windows are open, clicking this button selects that plug-in as the target for any computer keyboard commands. The Target in the Plug-In window functions the same as the Target in Output and Send windows (see “Targeted Windows” on page 397).

**Phase Invert**  Inverts the phase polarity of the input signal.

**Channel Selector**  Accesses a specific channel within a multichannel track for plug-in parameter editing. This menu appears only on multi-mono plug-ins inserted on tracks with more than one channel. Shift-clicking this Selector opens a separate Plug-In window for each channel of the multichannel track on which the plug-in is inserted.

**Link Enable Buttons**  Lets you selectively link the parameter controls of specific channels of a multi-mono plug-in. Each square represents a speaker channel. The Master Link button must be disabled to use the Link Enable buttons. See “Linking and Unlinking Controls on Multi-Mono Plug-Ins” on page 413.

**LFE Enable**  Enables plug-in processing of the LFE (low frequency effects) channel on a 5.1, 6.1, or 7.1 multichannel track. To disable LFE processing, deselect this button.

**Master Link Button**  When enabled, links the parameter controls on all channels of a multi-mono plug-in so that they can be adjusted in tandem.
Opening Plug-In Windows

To open a Plug-In window:
- Click the Plug-In button in the Mix or Edit window channel strip.

By default, each plug-in you open will appear in the same location as a currently open plug-in, replacing it in the same window location.

Opening Multiple Plug-In Windows

Pro Tools normally displays a single Plug-In window from which you can edit the parameters of any plug-in in a session. You can also open additional Plug-In windows for specific plug-ins. Once you begin working with multiple Plug-In windows, you will need to click the Target button on the plug-in whose parameters you want to edit using keyboard commands.

To open additional Plug-In windows:
- In the Mix window, Shift-click the Insert button of the desired plug-in.

To open Plug-In windows for each channel of a multi-mono plug-in:
- Option-click (Macintosh) or Alt-click (Windows) the Channel Selector in the Plug-In window of the desired plug-in.

To close all currently open Plug-In windows:
- Option-click (Macintosh) or Alt-click (Windows) the close box of any currently open Plug-In window.

Plug-In Window Controls

All plug-ins provide standard Pro Tools controls for track and insert selection, bypass, and other controls, in addition to the EQ, dynamics, and other processor-specific controls.

To select a different plug-in on the same track:
- Click the Plug-In Selector and choose a plug-in from the pop-up menu.

Choosing a plug-in from the Plug-In window

To choose a different track:
- Click the Track Selector and choose a track from the pop-up menu.

Choosing a track from the Plug-In window

Target Window and Settings Shortcuts

When multiple Plug-In windows are open, a highlighted target indicates the Target window. Pro Tools keeps a single Plug-In Target window. Opening a new plug-in opens it as the new Target window, in the same location. In addition, the Plug-In Target window is also the focus of keyboard shortcuts for plug-in settings.
Bypassing Plug-Ins

Plug-ins can be bypassed from their Plug-In window, or from the Mix and Edit window Inserts View.

When a plug-in insert is bypassed, the Insert Selector in the Mix window changes its color to blue for easy visual reference. If some, but not all channels of an unlinked multi-mono plug-in are bypassed, the Insert Selector appears purple (Pro Tools 6.0) or half blue and half black (Pro Tools 5.x).

To bypass a plug-in:

- Click the Plug-In window's Bypass button.
- or – Command-click (Macintosh) or Control-click (Windows) the plug-in's Insert button in the Mix or Edit window.

Indication of bypassed plug-in state (Pro Tools 6)

Indication of bypassed plug-in state (Pro Tools 5.x)

Linking and Unlinking Controls on Multi-Mono Plug-Ins

(TDM Systems Only)

When a multi-mono plug-in is used on a multi-channel track of more than two channels, the controls are normally linked. Adjusting the Gain parameter on one channel, for example, will adjust it for all channels.

You can unlink plug-in controls on specific channels of a track and edit them independently. You can also selectively link the controls of specific channels.

To unlink controls on a multi-mono plug-in:

- Deselect the Master Link button.

To access controls for a specific channel:

- Select the desired channel from the Channel Selector.

To link the controls of specific channels:

1. Deselect the Master Link button if it is not already deselected.

2. Click the Link Enable buttons for the channels whose controls you want to link. For example, to link all channels except the LFE, highlight the icons representing the five full-range speakers in a multi-mono plug-in.

All channels linked except the LFE
**Editing Plug-In Parameters**

You can edit plug-in parameters by dragging the parameter’s slider or by typing a value into the parameter’s text box. See the *DigiRack Plug-Ins Guide* for complete instructions.

**To edit a plug-in parameter:**

1. Begin audio playback so that you can hear parameter changes in real time.
2. Adjust the parameters of the plug-in for the effect you want.
3. Closing the Plug-In will save the most recent changes.

**Keyboard Shortcuts**

- For finer adjustments, Command-drag (Macintosh) or Control-drag (Windows) the control.
- To return a control to its default value, Option-click (Macintosh) or Alt-click (Windows) the control.

**Keyboard Input for Plug-In Parameters**

You can use your computer keyboard to edit plug-in parameters.

If multiple Plug-In windows are open, Tab and keyboard entry remain focussed on the plug-in that is the Target window.

To edit parameters with a keyboard:

- Click in the parameter text field that you want to edit to activate the field. Type the desired value.
- In fields that support values in kilohertz, typing “k” after a number value will multiply the value by 1,000. For example, type “8k” to enter a value of 8,000.
- To increase a value, press the Up Arrow on your keyboard. To decrease a value, press the Down Arrow on your keyboard.
- Press Enter on the numeric keyboard after typing a value to input the value (without leaving the selected parameter field).
- Press Return (Macintosh) or Enter on the alpha keyboard (Windows) to enter the value and leave keyboard editing mode.
- To move downward through the different parameter fields, press the Tab key. To move upwards, press Shift+Tab.

**Plug-In Automation and Safe**

All real-time plug-ins can be fully automated, and support all Pro Tools automation modes (Write, Touch, and Latch, plus Trim).

The Auto button opens the Enable Automation Parameters dialog, where you can enable individual plug-in parameters for automation recording. See Chapter 28, “Automation” for more information on this feature and shortcuts to enable plug-in parameters.

The Safe button engages Automation Safe mode. When enabled, existing plug-in automation is protected from being overwritten. (See “Automating Plug-Ins” on page 431 for more information.)
**Using a Key Input for Side-Chain Processing**

Some plug-ins, such as the Compressor, Limiter, Gate, and Expander/Gate, feature side-chain processing capabilities. Side-chain processing allows you to trigger a plug-in from a separate reference track or external audio source. The source used for triggering is referred to as the *Key Input*. Key inputs are monophonic.

A typical use for this feature is to control the dynamics of one audio signal using the dynamics of another signal (the Key Input). A kick drum track, for example, can be used to trigger gating of a bass track to tighten it up. A rhythm guitar track can be used to gate a keyboard pad, and so on.

⚠️ *RTAS plug-ins do not provide side-chain processing when used on TDM-based systems; use the TDM versions of plug-ins on TDM-based systems if you want to use side-chain processing.*

**Key Input Filters**

Some plug-ins feature key high pass and low pass filters. These controls allow you to define a specific frequency range in the Key Input signal with which to trigger the plug-in effect. A common production technique is to use these controls to filter a drum track so that only specific high frequencies (a hi-hat, for example) or low frequencies (a tom or a kick, for example) trigger the effect.

**Choosing a Key Input**

To use a Key Input for side-chain processing:

1. From the Key Input menu, choose the input/bus carrying the audio you want to use to trigger the plug-in.
2. Click External Key to activate side-chain processing.
3. To hear the audio source you have selected to control side-chain input, click Key Listen.
4. To filter the Key Input so that only specific frequencies trigger the plug-in, use the Key HPF and Key LPF controls (if available) to select the desired frequency range.
5. Begin playback. The plug-in uses the input/bus that you chose as a Key Input to trigger its effect.
6. Adjust the plug-in’s Threshold parameter (if available) to fine tune Key Input triggering.
7. Adjust other parameters to achieve the desired effect.
**Hardware I/O Inserts**

You can connect external devices, such as reverb or effects processors, to your Pro Tools system and use them as inserts or make them the destination for effects sends and returns.

Pro Tools inserts utilize hardware input and output channels to send and return the audio. Inserts can be defined, and their channels mapped to audio interface channels, in the I/O Setup dialog.

If you plan to use a device as an insert, be sure to connect the device to matching inputs and outputs on your system. For example, a stereo insert could use outputs 7–8 and inputs 7–8 for the sends and returns, respectively. Routing the physical inputs and outputs of the interface to Pro Tools inputs and outputs can be done in either the Hardware Setup dialog (or I/O Setup dialog). For more information, see “Configuring Pro Tools System Settings” on page 39, or “Routing Hardware I/O to Pro Tools I/O” on page 69.

**To define hardware inserts:**

1. Choose Setups > I/O Setup, then click the Inserts tab.
2. Select an insert path, or click New Path to create a new Insert path.
3. Double-click the Path Name to enter a custom path name for the insert.
4. Make sure the insert path is set to the correct format (mono, stereo, or other).
5. Map inserts in the Channel Grid as needed. Insert and Output paths have special rules regarding channel mapping (see “Overlapping Channels and Valid Paths” on page 75).

**Assigning Inserts**

**To assign a hardware insert to a track:**

- Select an insert from the track Insert Selector.

**Inactive Inserts**

Hardware inserts can be made Inactive. An inactive insert retains its assignment, but does not pass audio and does not consume any DSP resources.

You can use the inactive feature whenever you need to mute or bypass a hardware insert. Inserts do not provide a standard bypass control.

**To make an insert inactive:**

- Command-Control-click (Macintosh) or Control-Start-click (Windows) the Insert button. Use the Option and Option+Shift modifiers (Macintosh), or Alt and Alt+Shift modifiers (Windows), to apply to all or all selected tracks, respectively
  - or –

Make the track inactive (this sets all associated inserts, sends, outputs, and plug-ins inactive).

When opening sessions on a system with insufficient DSP resources, unavailable inserts are automatically set to inactive.
Connecting and Integrating External Devices

Pro Tools TDM and LE systems can create dedicated connections to external analog or digital devices. The number and type of connections depends on what kind of system you have.

You can also use the inputs and outputs of an Audiomedia III card to connect external devices. You can send and return an analog signal using the analog connectors on the card, and monitor through a DAT machine connected to the digital output. You can also send and return a digital signal to an external device that supports digital I/O (such as a reverb unit), and monitor with the analog outputs.

To connect an external device to a Pro Tools system:

1. Connect an unused output (or pair of outputs for a stereo device) of your Pro Tools system to an input of the external signal processor.
2. Connect the output of the external signal processor to an unused input (or pair of inputs for a stereo device) of your Pro Tools system.
3. Define what physical ports are routed to Pro Tools input and output ports, as appropriate, in either the Hardware Setup dialog or I/O Setup dialog.
4. Define output, input, or insert paths as appropriate in the I/O Setup dialog.

If you plan to use a device as an insert, be sure to connect the device to matching inputs and outputs on your system. For example, a stereo insert could use outputs 7–8 and inputs 7–8 for the sends and returns, respectively.

For additional information on connecting external devices, refer to the Pro Tools Getting Started Guide that came with your system.

Connecting Effects Units Digitally

If you want to use the digital inputs and outputs on your Pro Tools system as effects sends and returns to a digital effects device, Pro Tools should be the clock master in most cases. Set your digital effects device to accept an external digital clock so that it synchronizes to Pro Tools.

To set up a digital send to an external device from a TDM system:

1. Do one of the following:
   • On a 192 I/O or 96 I/O, choose Setups > Hardware Setup, choose the peripheral, and set the channel pair to Digital.
   • On an 888|24 I/O, choose Setups > Hardware Setup, choose the peripheral, and set the channel pair to Digital.
   • On an 882|20 I/O or 1622 I/O, choose Setups > Hardware Setup, choose the peripheral, and set Channel 1–2 input to Digital.
2. Choose Internal from the Clock Source popup menu (formerly labeled Sync Mode).
3. Click OK.
To set up a digital send to an external device from a Digi 002 or Digi 001 system:

1. Choose Setups > Playback Engine and choose the peripheral.

2. Do one of the following:
   - If the external device is connected to the S/PDIF RCA jacks, deselect S/PDIF Mirroring. (When S/PDIF Mirroring is on, digital output at the S/PDIF RCA jacks exactly mirrors the output of analog Channels 1–2.)
   - If the external device is connected to the Optical ports, choose a format (most likely S/PDIF for an effects device) from the Optical Format pop-up menu.

3. Choose Internal from the Sync Mode pop-up menu.

4. Click OK.

5. Optionally, configure the I/O Setup dialog with new path names for effects routing.

   **Warning**: If you set the Optical Format to S/PDIF, Pro Tools will watch the Optical port for any audio input, and ignore any audio input on the S/PDIF RCA jacks.

To set up a digital send to an external device from an Audiomedia III system:

1. Choose Setups > Playback Engine, choose the peripheral, and deselect S/PDIF Mirroring. (When S/PDIF Mirroring is on, digital output at the S/PDIF RCA jacks exactly mirrors the output of analog Channels 1–2.)

2. Choose Internal from the Sync Mode pop-up menu.

3. Click OK.

4. Optionally, configure the I/O Setup dialog with new path names for effects routing.

Using External Clock Sources

Pro Tools|HD can use the digital inputs on any HD-series interface enabled in the Loop Sync chain as a source for digital master clock. To synchronize to an external clock source, connect the device to an appropriate digital input on any HD I/O.

**TDM Systems**

Pro Tools can receive external clock through any of the digital inputs on any HD-series I/O (including AES/EBU, SPDIF, and Optical).

If your expanded HD system includes Legacy interfaces (such as the 888|24 I/O), connect to the digital input on Channels 1–2 of the Legacy audio interface in order to clock from them. Legacy I/Os only support 44.1 kHz and 48 kHz sample rates.

**To determine correct card order and audio interface connections for TDM systems, refer to the Getting Started Guide that came with your system.**

To select an external clock source for a TDM system:

1. Choose Setups > Hardware Setup.

2. Select the appropriate HD I/O in order to display its settings in the Main page.

3. If necessary, enable the appropriate Digital Format (if you have not already done so, according to instructions in the Getting Started Guide or I/O Guide).

4. Choose the appropriate Clock Source.

5. Configure input routing of the digital source, using the Input and Output pop-ups, if necessary.

6. Click OK to close Hardware Setup.
Digi 002 and Digi 001 Systems

Pro Tools can receive external clock from the optical input or S/PDIF input.

To select an external clock source for a Digi 002 or Digi 001 system:
1 Choose Setups > Hardware Setup.
2 Set Clock Source to match the type of input.
   – or –
In Pro Tools 5.2 or earlier, set Sync Mode to match the type of input.
If you choose Optical, make sure the Optical Format matches the type of optical input you are sending to your Pro Tools system.

⚠️ If you set the Optical Format to S/PDIF, Pro Tools will watch the Optical port for external clock, and ignore any clock input on the S/PDIF RCA jacks.

Audiomedia III Systems

Pro Tools can receive external clock from the S/PDIF input on the Audiomedia III card.

To select an external clock source for an Audiomedia III system:
1 Choose Setups > Hardware Setup.
2 Set the Sync Mode to match the type of input.
Chapter 28: Automation

Pro Tools features dynamic automation of volume, pan, and mute controls for audio tracks and sends, MIDI tracks, and real-time plug-in parameters. In Pro Tools, you can write automation moves in real time during playback of your session. You can also edit automation data with the same techniques you use to edit audio and MIDI data.

Automation Accuracy with Control Surfaces

ProControl and Control|24 Digidesign’s ProControl and Control|24 control surfaces support all automation features in Pro Tools. Digidesign control surfaces provide 10-bit resolution, or 1,024 steps. Pro Tools interpolates this input to 24-bit resolution on playback, resulting in extremely accurate and smooth fader automation.

MIDI Control Surfaces Most MIDI control surfaces have 8-bit resolution, or 128 steps. Pro Tools interpolates this input to 24-bit resolution on playback, resulting in extremely accurate and smooth fader automation.

Automation Quick Start

Pro Tools provides many options for recording, replacing, and editing automation data.

The basic steps for automation recording are:

- Enable the automation type that you want to record (volume, pan, mute, send level, send pan, send mute, or plug-in automation).
- Put the appropriate tracks in an automation writing mode (Write, Touch, or Latch, or a Trim mode).
- If you are automating a plug-in, enable the individual plug-in parameters to be automated.
- Automation Safe any plug-ins, outputs, or sends that have existing automation data that you want to protect from being overwritten.
- Begin playback to begin automation recording, and adjust controls as needed. Pro Tools remembers all moves performed on enabled parameters.

To edit automation once it has been recorded, you can:

- Repeat the above steps to write new automation over the previous data.
- Graphically edit the automation data in the Edit window.
- Cut, copy, paste, or delete automation data (certain restrictions apply).
Automation Playlists

Each Pro Tools track contains a single automation playlist for each automatable control.

On audio tracks, these controls include:
- Volume
- Pan
- Mute
- Send volume, pan, and mute
- Plug-in parameters

On MIDI tracks, these controls include:
- Volume
- Pan
- Mute

You can display and edit each of these automatable parameters individually from Pro Tools, even during playback.

In addition, you can display and edit other continuous MIDI controller data (such as mod wheel, breath controller, foot controller, or sustain) in a similar manner. For more information on editing MIDI data, see “Continuous Controller Events” on page 340.

Automation Playlists with Audio and MIDI Regions

Pro Tools handles audio regions and their automation playlists differently from MIDI regions and their automation playlists.

Audio Tracks

On audio tracks, automation data resides on a separate playlist from audio data and regions. Each edit playlist on an audio track shares the same automation data.

MIDI Tracks

On MIDI tracks, all controller automation data except for Mute data is stored in the MIDI region that contains it. Each edit playlist on a MIDI track is separate, and represents a distinct performance, complete with controller automation.

⚠️ Mute data is independent of the MIDI data in a MIDI region. This lets you mute playback of individual MIDI tracks in Pro Tools without altering the controller data.

Multiple Edit Playlists and Audio Track Automation

All edit playlists on a single audio track share the same automation data. When you record or edit automation data in an audio track, the automation data is stored in the track automation playlist so it can be edited with, or independently from, its associated audio regions. (MIDI automation data always follows region editing, with the exception of mute. See “MIDI Tracks” on page 422 for more information.)

- When you copy or cut audio data from a track while it is in Waveform View, the underlying automation data is cut or copied with it.
- If you paste audio data from other locations or tracks into an edit playlist, you may change the underlying automation data on the track.
When you trim audio regions with the Trim tool, or cut, copy, paste, or delete audio regions, underlying automation data is also trimmed, cut, copied, pasted, or deleted.

When you trim regions using Edit > Trim, the underlying automation data remains unchanged.

For more information, see “Editing Automation” on page 436.

Duplicating Tracks for Playlist Editing

The Duplicate Selected Track command provides a convenient way to make a working copy of a track to experiment with routing, plug-ins, and automation. This protects the original track and its automation data from being edited or overwritten.

To copy a track for automation:

1. Select the track and choose File > Duplicate Track. Duplicate Track creates a complete copy of the track, including all routing, plug-ins, and automation.

2. Command-Control-click the Track Type icon, or select that track and choose File > Make Selected Tracks Inactive.

3. Begin editing automation and other parameters on the duplicated track.

Edit and assemble the track regions before applying automation to them.

Automation Modes

Each track provides an Automation Mode Selector. Automation modes control how a track’s automation data is written and played back.

Auto Off

Auto Off mode turns off automation for all automatable controls:

• Volume
• Pan
• Mute
• Send volume, pan, and mute
• Plug-in parameters
• MIDI volume, pan, and mute

In Auto Off mode, automation data for these parameters is ignored during playback. All other MIDI controller data is sent.

Auto Read

Auto Read mode plays the automation that was previously written for a track.

Auto Write

Auto Write mode writes automation from the time playback starts to the time it stops, erasing any previously written automation for the duration of the automation pass.

After an automation pass, Pro Tools automatically switches from Auto Write mode to Auto Touch mode. This prevents you from accidentally overwriting automation data on later playback. On TDM systems, you can turn off this behavior and remain in Auto Write mode. See “Write Switches To Touch After Pass” on page 61 for details.
**Auto Touch**

Auto Touch mode writes automation only while a fader or switch is touched or clicked with the mouse. When the fader is released, the writing of automation stops and the fader returns to any previously automated position, at a rate determined by the AutoMatch and Touch Timeout settings. See “Automation Preferences” on page 426.

In Auto Touch mode, certain control surfaces start writing automation as soon as you touch them. These include:

- Touch-sensitive motorized fader controllers, such as Digidesign ProControl, Control|24, Digi 002, or the Mackie HUI.
- Continuous-belt controllers, such as CM Labs Motor Mix or Penny & Giles DC16/MM16.

With other control surfaces in Auto Touch mode, writing of automation does not begin until the fader hits the pass-through point, or the previously automated position. Once you reach the pass-through point with the fader, writing of automation begins and continues until you stop moving the fader.

**Auto Latch**

Auto Latch mode works in the same way as Auto Touch mode, writing automation only if you touch or move a control. However, unlike Auto Touch, writing of automation continues until you stop playback. This mode is particularly useful for automating pan controls and plug-ins, since it does not time out and revert to its previous position when you release a control.

See also “Writing Automation to the Start, End or All of a Selection” on page 442.

**Trim Mode**

*(TDM Systems Only)*

Pro Tools TDM systems can adjust (or trim) existing track volume and send level automation data in real time. Pan and plug-in automation cannot be trimmed in this manner. Trim mode works in combination with the other Automation modes (Auto Read, Auto Touch, Auto Latch, Auto Write) and is useful when you want to preserve all of your volume automation moves, but need to make levels a bit louder or softer to balance a mix.

When editing automation in Trim mode, fader moves write relative rather than absolute values. The existing automation data is changed by the amount of increase or decrease (or the delta value) indicated by the faders. When trimming, a track’s Volume indicator or Send Level indicator shows the delta values being written rather than the absolute value.

When Trim mode is enabled, non-trimmable controls behave in the same manner as in the standard Automation modes, with the exception of Trim/Auto Write mode, where non-trimmable controls operate as in Auto Touch mode.

**Trim/Auto Off**

Trim/Auto Off mode turns off automation and trimming for a track. All automation moves are ignored during playback.

**Trim/Auto Read**

In Trim/Auto Read mode, volume and send faders follow the previously written automation. When one of the faders is touched, the trim moves (delta values) are played back, but are not written into the automation data. This lets you audition trim moves without affecting existing automation.
Trim/Auto Touch

In Trim/Auto Touch mode, when playback begins, volume and send faders follow the previously written automation. When one of the faders is touched, real-time trimming begins. Fader moves write delta values (an increase or decrease in the form of an offset to existing automation data).

When the fader is released, trimming stops and the fader returns to a zero delta or offset value and continues to follow the previously written automation. The rate of the fader’s return to a zero delta value is determined by the AutoMatch Time specified in the Automation Preferences. See “Automation Preferences” on page 426 for more information.

In Trim mode, tracks do not automatically change from Trim/Auto Write to Trim/Auto Touch after an automation pass. Be sure to switch out of Auto Write when you leave Trim mode to avoid overwriting automation data.

Trim/Auto Write

In Trim/Auto Write mode, the volume and send level faders are disengaged from displaying the existing automation data, so you don’t have to chase them during playback. Faders are automatically positioned at 0 dB, where no trimming occurs (they start with a delta value of zero). From this reference point you can then set the initial delta values before initiating playback.

When Trim/Auto Write mode is enabled, non-trimmable controls (all controls other than track volume and send level) are not in Write mode, but behave as if they are in regular Auto Touch mode (no automation is written unless a control is touched). This is to prevent the controls from overwriting all of their automation data on every pass in Trim mode.

Trim/Auto Latch

In Trim/Auto Latch mode, when playback begins, volume and send faders follow the previously written automation. When one of the faders is touched, real-time trimming begins. Any fader moves after trimming begins increase or decrease existing automation data accordingly. Trimming of the touched control continues until playback stops.

When this mode is enabled, non-trimmable controls (all controls other than track volume and send level) behave as if they are in regular Auto Read mode—no automation data is written.

Trim/Auto Latch mode—they follow the previously written automation until touched. When they are touched, their absolute positions are written until playback is stopped.
Automation Preferences

Pro Tools gives you several options for controlling the writing and playback of automation data.

To display Automation Preferences:
- Choose Setups > Preferences, and click Automation.

Smoothing

When you perform automation moves with a continuous control, Pro Tools records the move as a series of very small steps, resulting in a staircase pattern with many breakpoints. Smoothing intelligently resolves this staircase pattern into a single, smooth ramp from one breakpoint to the next. (Smoothing does not apply to switched controls such as mutes or plug-in bypasses.) With smoothing enabled, the resulting automation is often a more accurate representation of actual automation moves.

Thinning

Thinning automatically reduces the overall number of breakpoints in the automation playlist in order to improve system performance. The amount of thinning applied is determined by the Degree of Thinning setting in the Automation Preferences. When using high amounts of thinning, the resulting automation may differ noticeably from the original automation moves. Thinning only applies to audio tracks, and does not affect MIDI tracks. For instructions, see “Thinning Automation” on page 434.

AutoMatch

When you write automation in Auto Touch mode, if you release a fader during playback, Pro Tools returns to the level of any automation still on the track by ramping up or down over a certain amount of time, called the AutoMatch Time. This time value is set in the Automation Preferences.

The AutoMatch feature works with continuous controls (such as Volume or Pan) by ramping their values back to previously automated levels. There are some stepped controls (for example,
the EQ type in the 1-band EQ plug-in) that provide more than two discrete steps over their operational range. AutoMatch has no effect on these controls.

**AutoMatch Indicators**

There are triangular AutoMatch indicators at the bottom left of each channel strip in the Mix window. These indicate the direction you need to move a fader in order to match the original automation level of that fader.

**Setting the Automation Buffer Size**

Pro Tools lets you specify the size of the memory buffer used to write automation. If you are working on a large session or writing a very large number of automation moves, you may want to increase this value.

**To set the Automation Buffer size:**

1. Choose Setups > Preferences and click Automation.
2. For the option “Amount of memory to reserve for automation recording,” enter a value between 200 and 3000K (the default value for a new session is 200K.)
3. Relaunch Pro Tools for this change to take effect.

**About Processing Bandwidth**

Meters in the System Usage window indicate how much of your system’s processing power is being used in processing audio, and when writing and playing back automation. In Pro Tools LE, these meters show System Activity and CPU Processing Activity; on Pro Tools TDM systems, they show System Activity, PCI Bus Activity, CPU Processing Activity, Disk Activity (Pro Tools 6.0 only), and TDM Time Slot usage.

As these meters approach their limits, recording or playback of automation data may be affected.

If CPU or PCI Activity are high, a System error may occur. If System Activity is high, Pro Tools may miss playback of some of your automation data during particularly dense periods of activity, such as while using the Bounce to Disk command.

*For more information, see “Bounce to Disk” on page 452.*
To reduce processing load, try the following:

- Deselect the Faders Move During Playback option in the Automation Preferences.
  - or -

Reduce the density of automation in places where it shows the most activity. For details, see “Thinning Automation” on page 434.

- or -

Turn off Sends View meters, if enabled, in the Preferences > Display window. See “Sends View Meters” on page 392 for more information.

**Automation Safe**

Outputs, sends, and plug-ins can be placed in Auto Safe mode. In Auto Safe mode, any automation associated with an Output window (track or send level, panning, mute, and so on), or plug-in on that track, is protected from being overwritten while automating other items on that track.

**Viewing Automation**

Pro Tools creates a separate playlist for each type of automation you write. This data can be viewed and edited in the same way as audio and MIDI data.

**To show automation data:**

- Click the Track View Selector and select from the pop-up menu the automation type you want to view.

**Displaying automation data**

You can easily toggle between Volume and Waveform View for audio tracks. For more information, see “Toggling Track Views” on page 192.
Writing Automation

You can write automation for all automatable controls by moving those controls during playback.

To write automation on a track:
2. Make sure the automation type is write-enabled.
3. From the Automation Mode pop-up menu, select the desired Automation mode for each track you want to automate. For the initial automation pass, select Auto Write.
4. Click Play to begin writing automation.
5. Move the controls you want to automate.
6. When you have finished, click Stop.

After the first automation pass, you can write additional automation to the track without completely erasing the previous pass by choosing Auto Touch mode or Auto Latch mode. These modes add new automation only when you actually move the control for that parameter. (See “Automation Modes” on page 423.)

To write additional automation to a previous pass:
1. Enable Operations > Link Edit and Timeline Selection.
2. In the Edit window, make a selection or place the cursor in the location where you want to start writing automation.
3. From the Automation Mode pop-up menu, select Auto Touch or Auto Latch mode for the tracks you want to automate.
4. Click Play to begin writing automation.
5. Move the controls you want to automate.
6. When you have finished, click Stop.

If you write automation in Auto Touch mode with Loop Playback enabled, writing of automation will automatically stop at the end of the looped selection. At the beginning of each successive loop, you can then touch or move the control again to write new data.

Storing an Initial Controller Position

When you create a new audio track, Auxiliary Input, or MIDI track, it is automatically placed into Auto Read mode. Even though the track is in Auto Read mode, you can set the initial position of any automatable control, and it is saved with your session.
In this initial state, only a single automation breakpoint appears at the beginning of each automation playlist. If you move the control without writing automation, this breakpoint will move to the new value.

You can permanently store the initial position of an automatable control by doing one of the following:

- Place the track in Auto Write mode and press Play to write a few seconds of automation data to the track
- Manually place a breakpoint on the automation playlist somewhere after the initial breakpoint. (See “Graphical Editing of Automation Data” on page 436 for more information.)

Automating Switched Controls

Pro Tools treats switched controls (such as mutes and plug-in bypasses) as touch sensitive controls. Automation data is written for as long as the switch or button for that control is pressed or touched.

For example, if you have just written a series of mute on/off states on a track in quick succession, the manual method for clearing this automation data would require you to move to the Edit window, choose automation playlist for Mute, select the mute automation data, and delete it.

In Pro Tools, it is not necessary to perform all of these steps. Instead, perform another automation pass on the track and hold down the Mute button when it reaches the state you want to remove. For example, when playback gets to the first muted section, the Mute button become highlighted. At this time, press and hold down the Mute button. As long as the button is held down, Pro Tools overwrites the underlying mute data on the track with the current state of the switch (on or off) until playback is stopped.

Automating Sends

Pro Tools provides dynamic automation of send level, send mute, and send pan (for stereo and multichannel sends only). This makes it easy to control effects levels and placement during mixdown with great precision.

Send level and mute can also be configured to follow groups.

To automate a send level, mute or pan:

1. In the Automation Enable window, make sure the automation type is write-enabled (send level, send mute, send pan).
2. Choose an Automation mode for each track you want to automate. For the initial automation pass, choose Auto Write.
3. To display send controls, do any of the following:
   - Select Windows > Mix Window Shows > Sends View, then click the send to open the Output window for the send that you want to automate.
   - Choose Display > Sends View Shows and select the individual send from the submenu.
4. Click Play to begin writing automation.
5. Move the controls you want to automate.
6. When you have finished, click Stop.

Send mutes and levels can also be configured to follow Mix Groups. See “Automation Preferences” on page 426 for information.
Copying Track Automation to Sends
(TDM Systems Only)

There may be times where you want a track’s send automation to mirror automation in the track itself, for example, when an effect level needs to follow the levels in a main mix. To do this, you can copy the entire automation playlist for the selected control to the corresponding playlist for the send.

To copy a track’s automation to one of its sends:

1. Select the tracks you want to edit by clicking on the track names to highlight them.
2. Choose Edit > Copy To Send.
3. In the Copy to Send dialog, select Automation to copy the entire automation playlist for the corresponding controls.
4. Select the controls you want to copy.
5. Select the sends to which to copy the automation, and click OK.

When overwriting automation, Pro Tools presents a confirmation dialog. To suppress this dialog, press Option (Macintosh) or Alt (Windows) while choosing the command.

You can undo the results of the Copy to Send command (Edit > Undo).

Automating Plug-Ins

You can create dynamic automation for virtually all parameters of the plug-ins included with your Pro Tools system. Automating a plug-in is slightly different from other automation procedures in that you must enable automation parameters for the plug-in.

To enable plug-in parameters for automation:

1. Click the Automation Enable button in the Plug-In window.
Select the parameters to automate and click Add. If there are multiple plug-ins on the same track, you can select from among these by clicking their buttons in the Inserts section of this dialog.

To automate a plug-in:
1. In the Automation Enable window, make sure the Plug-In parameter is enabled.
2. Select an Automation mode for each track you want to automate. For the initial automation pass, choose Auto Write.
3. Click OK to close the Plug-In Automation dialog.
4. Click Play to begin writing automation.
5. Adjust the plug-in parameters.
6. When you have finished, click Stop.

**Plug-In Safe**

You can use Automation Safe mode to protect plug-in automation from being overwritten.

To enable Plug-In Safe mode:
1. Open a plug-in.
2. Click to enable the Safe button.

**Enabling and Suspending Automation**

From the Automation Enable window, you can enable or suspend writing for the following automation parameters across all tracks:

- Volume
- Pan
- Mute
- Plug-in
- Send level
- Send pan
- Send mute

To suspend writing of automation on all tracks:
2 Do one of the following:
• To suspend writing of all automation on all tracks, click the Auto Suspend button.
• To suspend writing of a specific type of automation on all tracks, click the button for that automation type (volume, mute, pan, plug-in, send level, send mute, or send pan).

Suspending Automation Playback

You can suspend playback of automation parameters for tracks by clicking on the track’s View Selector.

To suspend playback (and writing) of automation on individual tracks:
1 In the Edit window, set the Track View Selector to show the automation parameter you want to suspend.
2 Do one of the following:
• To suspend writing and playback of only the displayed automation parameter, Command-click (Macintosh) or Control-click (Windows) the parameter name in the Track View Selector.
• To suspend writing and playback of all automation parameters, Command-Shift-click (Macintosh) or Control-Shift-click (Windows) the name of any automation parameter in the Track View Selector.

Automation Enable Guidelines

The following rules determine whether automation is written or played back for a track:
• Although Pro Tools shows a single Automation mode for each track, all controls associated with that track are not necessarily in the same Automation mode.
• If automation is globally suspended in the Automation Enable window, all controls behave as if they were in Auto Off mode, regardless of the track’s current Automation mode.
• If an automation parameter is suspended by Command-clicking (Macintosh) or Control-clicking its name in the Track View Selector, that parameter behaves as if it were in Auto Off mode, regardless of the track’s current Automation mode.
• If an automation parameter is suspended in the Automation Enable window, that parameter behaves as if it is in Auto Read mode when the track is in a recordable Automation mode (Auto Touch, Auto Latch, or Auto Write mode).
Deleting Automation

Automation data takes the form of a line graph with editable breakpoints. The easiest way to remove automation in a track or selection is to manually delete breakpoints from the automation playlist.

Removing data in this manner is different from using the Cut command, which creates anchor breakpoints at the boundaries of the remaining data. For details, see “Cutting, Copying, and Pasting Automation” on page 440.

To remove automation data, display the automation parameter you want to edit by selecting it from the Track View Selector, and do one of the following:

To remove a single breakpoint:
- With the Grabber or the Pencil Tool, Option-click (Macintosh) or Alt-click (Windows) the breakpoint.

To remove several breakpoints at once:
- Use the Selector to select a range that contains the breakpoints, and press Delete (Macintosh) or Backspace (Windows).

To remove all automation data of the displayed type:
- Click with the Selector in the track and choose Edit > Select All, then press Delete (Macintosh) or Backspace (Windows).

To remove all automation for all automation playlists on a track:
1. Use the Selector to select a range of data to be removed.
2. Press Control+Delete (Macintosh) or Control+Backspace (Windows).

All automation data within the selection is removed for all automation playlists on that track, regardless of whether automation is write-enabled for those parameters.

Thinning Automation

Pro Tools writes a maximum density of automation data during an automation pass, in the form of breakpoints. Since Pro Tools creates ramps between breakpoints, it may not need all of the captured points to create a sonically accurate representation of the automation moves that you have made. Each breakpoint takes up space in memory allocated for automation, so thinning data can maximize efficiency and CPU performance.

Pro Tools provides two different ways to thin automation data and remove unneeded breakpoints: the Smooth and Thin Data After Pass option and the Thin Automation command.

Using Smooth and Thin Data After Pass

When this option is selected in Setups > Preferences > Automation, Pro Tools automatically thins the automation breakpoint data after each automation pass.
In the default settings for new sessions, the Smooth and Thin Data After Pass option is selected, with the “Some” setting chosen. In most cases, this setting yields optimum performance while providing an accurate reproduction of your automation moves.

If you choose None, Pro Tools writes the maximum possible number of breakpoints. You can still perform thinning at any time with the Thin Automation command (Edit > Thin Automation). For more information on smoothing automation data, see “Smoothing” on page 426.

**Drawing Automation**

Use the Pencil tool to create automation events for audio and MIDI tracks by drawing in any automation or MIDI controller playlist.

The Pencil tool can be set to draw a series of automation events with the following shapes:

1. **Free Hand** Draws freely according to the movement of the mouse. In audio tracks, the shape has the number of breakpoints needed to smoothly interpolate and reproduce the automation shape. In MIDI tracks, the shape is reproduced as a series of steps, according to the resolution setting in the MIDI preferences (Setups > Preferences > MIDI).
2. **Line** Draws a straight line. In audio tracks, the line has a single breakpoint at either end. In MIDI tracks, the controller value changes in steps according to the resolution setting in the MIDI preferences (Setups > Preferences > MIDI).
3. **Triangle** Draws a sawtooth pattern that repeats at a rate based on the current Grid value. In audio tracks, the pattern has a single breakpoint at each extreme. In MIDI tracks, the controller value changes in steps according to the resolution setting in the MIDI preferences. Amplitude is controlled by vertical movement of the Pencil tool.

**Using the Thin Automation Command**

The Thin Automation command lets you selectively thin areas in a track where automation data is too dense. You can use the Undo command to audition the results of thinning (comparing thinning and not thinning) before you apply it permanently.

**To use the Thin Automation command:**

1. In the Edit window, click the Track View Selector to display the automation type you want to thin.
2. With the Selector, highlight the automation data you want to thin. To thin all automation of the selected type in the track, click the Selector in the track and choose the Select All command.
3. Choose Edit > Thin Automation to thin the selected automation by the amount you have selected in the Automation Preferences.
Square Draws a square pattern that repeats at a rate based on the current Grid value. Amplitude is controlled by vertical movement of the Pencil tool.

Random Draws a random pattern of levels that change at a rate based on the current Grid value. Amplitude is controlled by vertical movement of the Pencil tool.

**Using Pencil Tool Shapes**

You can draw automation for audio as well as MIDI tracks. For example, use the Triangle pattern to control continuous functions, or the Square pattern to control switched functions such as Mute or Bypass.

Since the pencil draws these shapes using the current Grid value, you can use it to perform panning in tempo with a music track, or on frame scene changes when working in post production.

For more information on MIDI continuous controller data, see “Continuous Controller Events” on page 340.

**Resolution of MIDI Controller Data**

When using the Pencil tool to draw MIDI automation, the data is drawn as a series of discrete steps. You can control the resolution (or density) of these steps to help manage the amount of MIDI data sent for a given MIDI controller move.

To set the resolution for the Pencil tool:

1. Choose Setups > Preferences and click the MIDI tab.

2. Enter a value for “Pencil Tool Resolution When Drawing Controller Data.” The value can range from 1 to 100 milliseconds.

The illustrations below show the same MIDI controller automation drawn with different Pencil Tools resolution settings.

![MIDI Data drawn with resolution of 10 ms](image1)

![MIDI Data drawn with resolution of 100 ms](image2)

You may want to choose a smaller value for MIDI controls that need higher resolution (such as MIDI volume), and a larger value for controls that may not require a high resolution (such as Pan).

**Editing Automation**

Pro Tools provides several ways to edit automation data for any track in your session. You can edit automation data graphically, by adjusting breakpoints on the automation playlist of a track. You can also cut, copy, and paste automation data in the same manner as audio and MIDI data.

**Graphical Editing of Automation Data**

Automation data takes the form of a line graph with editable breakpoints. By dragging these breakpoints, you can modify the automation data directly in the Edit window. When you
drag an automation breakpoint up or down, the change in value is numerically or textually indicated. Dragging an automation breakpoint to the left or right adjusts the timing of the automation event.

**Using the Grabber**

The Grabber lets you create new breakpoints by clicking on the graph line, or adjust existing breakpoints by dragging them. Option-click (Macintosh) or Alt-click (Windows) breakpoints with the Grabber to remove them.

**Editing Automation Types**

Each automatable control has its own automation playlist, that can be displayed by choosing it from the Track View Selector. See “” on page 428.

**Editing Volume Automation**

Drag a breakpoint up or down to change the volume (dB value). Drag a breakpoint to the left or right to adjust the timing of the volume change.

**Editing Pan Automation**

Drag a breakpoint down to pan right, and up to pan left. Drag a breakpoint to the left or right to adjust the timing of the panning moves.

**Editing Mute Automation**

Drag the breakpoint down to mute a section. Drag a breakpoint up to unmute the section. Drag a breakpoint to the left or right to adjust the timing of the mute.

**Using the Pencil Tool**

The Pencil tool lets you create new breakpoints by clicking once on the graph line. Option-click (Macintosh) or Alt-click (Windows) breakpoints with the Pencil tool to remove them.

**Using the Trimmer**

The Trimmer lets you adjust all selected breakpoints up or down by dragging anywhere within that selection.
Editing Stepped Control Automation

Automation for certain controls, such as MIDI controllers values or plug-in settings, appears as a stepped pattern on the breakpoint line. Drag a breakpoint up or down to a different step to change to a new control value. Drag a breakpoint to the left or right to adjust the timing of the stepped control change.

Editing Automation Breakpoints

To edit automation breakpoints, display the automation parameter you want to edit by selecting it from the Track View Selector, then do one of the following:

To create a new breakpoint:
- Click with the Grabber (or the Pencil) on the line graph.

To edit a breakpoint:
- Click an existing point on the line graph with the Grabber and drag it to a new position.

To edit several breakpoints at once:
- Use the Selector to select a range in the automation playlist that contains the breakpoints, and do one of the following:
  - To move the breakpoints earlier or later in the track, press the Plus key (+) to nudge them later (to the right) or the Minus key (–) to move them earlier (to the left). The breakpoints move by the current Nudge value.
  - To adjust the breakpoint values, click with the Trimmer in the selection and drag the breakpoints up or down.

When you use the Trimmer to edit a selection containing breakpoints, new anchor breakpoints are created before and after the selected area. To suppress creation of anchor breakpoints, press Option (Macintosh) or Alt (Windows) while using the Trimmer.

To edit all breakpoint values in a region:
- Click in the region with the Trimmer and drag the breakpoints up or down.

Editing Automation on Stereo and Multichannel Tracks

Stereo and multichannel tracks display a single automation playlist per track. Only one playlist for volume and mute is available for the stereo or multichannel track.

For multi-mono plug-ins, individual playlists per channel can be displayed and edited when the plug-in is unlinked, and the track is in Expanded Track Display.

Expanded Track View

By default, a single playlist is displayed on stereo and multichannel tracks. The playlist occupies the entire height of the track (similar to mono automation playlists).

Optionally, you can display an expanded view of the track whereby the same automation playlist is displayed across each channel.
Plug-In Automation Playlists on Stereo and Multichannel Tracks

Multichannel plug-ins provide a single set of automatable controls. Multi-mono plug-ins provide similar control when linked, or discrete controls when unlinked.

To view and edit the individual playlists of a multi-mono plug-in:

1. Unlink the plug-in.
2. Select the required playlist from the Track View Selector.

Editing Automation on Grouped Tracks

When you edit automation on an audio track that is a member of an active Edit Group, the same type of automation (with the exception of audio and MIDI Pan controls) is also edited on all tracks that are part of that group. This occurs even if that parameter is not currently displayed on the other grouped tracks.

However, when you edit automation on a MIDI track that is a member of an active Edit Group, grouping is ignored; the same type (with the exception of audio and MIDI Pan controls) are not edited on all tracks that are part of that group. To edit all members of MIDI group, see the steps below.

Examples

- If you create new automation breakpoints on a grouped track (with the Grabber or Pencil), other members of the group have breakpoints placed relative to that track.
- If you move volume or send automation on a grouped track (with the Trimmer), other members of the group have their volume or send breakpoints trimmed relative to that track. This lets you trim entire sections of a mix.

To individually edit a member of a group without affecting the other members:

- For audio tracks, press Control (Macintosh) or the Start key (Windows) while you perform the edit.
- For MIDI tracks, do not press Control (Macintosh) or the Start key (Windows) while you perform the edit.
To edit all members of a group:

- For audio tracks, do not press Control (Macintosh) or the Start key (Windows) while you perform the edit.

- For MIDI tracks, press Control (Macintosh) or the Start key (Windows) while you perform the edit.

⚠️ When editing automation, audio and MIDI Pan controls work opposite from the way all other controls work.

- For audio tracks, when you edit or trim Pan breakpoints, Edit Groups are not obeyed. For grouped behavior, press Control (Macintosh) or the Start key (Windows) while trimming.

- For MIDI tracks, when you edit or trim Pan breakpoints, Edit Groups are obeyed. For individual behavior, press Control (Macintosh) or the Start key (Windows) while trimming.

**Cutting, Copying, and Pasting Automation**

*Cutting* automation data is different from *deleting* it, and yields different results. *Copying* automation leaves the original automation data intact.

You *delete* automation data by selecting a range of breakpoints and pressing Delete (Macintosh) or Backspace (Windows). See “Deleting Automation” on page 434 for details.

You *cut* automation data by selecting a range of breakpoints from an automation playlist and selecting the Cut command.

When you cut automation data and when you paste it into a new location, anchor breakpoints are added to the beginning and end points of the data. This is done to preserve the true slope (of continuous controls, such as Volume faders or pans) or state (of switched or stepped controls, such as Mutes) of the automation data both inside and outside the selection.

The following illustrations show the difference between cutting and deleting automation data. In Figure 31, a track is set to display volume automation, and a range of automation data is selected.

![Figure 31. Selecting automation data](image)

If the Cut command is chosen, anchor breakpoints are created at each end of the selection, and the automation slope on either side of the cut data is preserved, as shown in Figure 32.

![Figure 32. After cutting the automation data](image)

If the data is deleted by pressing Delete (Macintosh) or Backspace (Windows), the automation data is removed, and automation values span the gap between pre-existing breakpoints, as in Figure 33.

![Figure 33. After deleting the automation data](image)
In addition, if cut or copied data is pasted elsewhere in a track, breakpoints are created at the end points of the pasted data to preserve its value and slope, as shown in Figure 34.

![Figure 34. After pasting the automation data in another location](image)

**Editing and Track Views**

Audio and MIDI tracks each have a Track View that acts as the main format for purposes of editing. When the main format is displayed, any edits performed on the track apply to all data in the track.

The main view formats are:
- Audio tracks: Blocks and Waveform
- MIDI tracks: Blocks, Regions, and Notes

For example, when an audio track is set to Waveform or Blocks, cutting, copying and pasting affects the audio data and all types of automation data on that track. If the track is set to show Pan automation, only the Pan data is affected.

When a selection includes multiple tracks, if any of those tracks is in its main view format, all data on all selected tracks is affected.

To edit all automation types on an Auxiliary Input or Master Fader track, do one of the following:
- Make an edit selection that includes at least one audio or MIDI track that is displayed in its main format.
- Press Control while cutting or copying the automation data.

*For additional flexibility, you can use playlists or the Duplicate Track command to work nondestructively on a copy of the edit data.*

**Tips for Cutting, Copying and Pasting**

- On audio tracks, when you are in Waveform View and cut or copy a section of the waveform, any automation data associated with the waveform is also cut or copied.
- On audio tracks, when you are in Waveform View and cut audio data from a track also containing automation data, breakpoints are automatically created at the boundaries of the remaining automation data.
- On audio tracks, pasting waveform data also pastes any associated automation data.
- On Auxiliary Input or Master Fader tracks, only the displayed automation data is cut or copied. To cut or copy all automation data on these types of tracks, press Control while cutting or copying.
- In tracks where an automation playlist contains no data (when there is only a single breakpoint at the very beginning of the track), if you cut data, no new breakpoints are created.
- In cases where regions overlap (such as when moving regions in Slip mode) and an overlapping region is removed, any overlapped automation breakpoints are lost.
- If cut or copied data contains a type of automation not currently on the target track, Pro Tools prompts you before allowing you to paste the data.
- Cut or copied automation data for plug-ins or sends that do not exist on the target track is ignored when pasted.
Special Paste Function for Automation Data

Normally, when you copy and paste automation data, it is pasted in an automation playlist of the exact same type (for example, Left Pan data is pasted into the Left Pan playlist).

However, there may be times when you want to paste from one data type to another (for example, pasting Send 1 level data into the Send 2 level playlist, or track mute data into the send mute playlist).

To paste data into a different automation playlist:

- Press Control (Macintosh) or the Start key (Windows) when choosing Edit > Paste.

For this special paste mode to function, the following must be true:

- Every track selected for pasting must be currently displayed as automation data.
- There must be only one automation playlist on the Clipboard for each target track. (The Special Paste function cannot copy multiple automation playlists for each track.)

⚠️ You cannot interchange automation data between audio and MIDI tracks, or between continuous controls (such as faders or pans) and switched or stepped controls (such as mute or MIDI controllers).

Writing Automation to the Start, End or All of a Selection

(TDM Systems Only)

Pro Tools lets you write current automation values from any insertion point forward (or backward) to the end (or beginning) of a selection or track, or to an entire selection or track, while performing an automation pass.

You cannot interchange automation data between audio and MIDI tracks, or between continuous controls (such as faders or pans) and switched or stepped controls (such as mute or MIDI controllers).
Requirements for Write to Start, End, and All

For an automation parameter to write automation data, the associated track must be in one of the following Automation modes and meet the following conditions:

**Latch Mode** The automation parameter must be changed (touched) during the automation pass.

**Touch Mode** The automation parameter must be changed (touched).

**Write Mode** All automation parameters on that track must be in Auto Write mode.

This command can be undone (Edit > Undo).

To write current automation values to the start, end, or all of a track or selection:

1. In the Automation Enable window, make sure that the automation type is write-enabled.
2. Click in a track at an insertion point.
   - or -
3. Drag with the Selector to select a portion of the track.
4. Click Play to begin playback.
5. When you reach a point in the track/selection that contains the automation data, click Write to Start, Write to All, or Write to End in the Automation Enable window.

The current values of all write-enabled automation at that point are written to the corresponding area of the track/selection.

Trim Mode

Using Trim mode, it is also possible to write trim delta values for track volume and send levels to the start (beginning), end or all of a track.

To write current trim delta values to the start, end, or all of a track or selection:

1. In the Automation Enable window, make sure that the automation type (track volume or send level) is write-enabled.
2. Click the Automation Mode Selector on the track. Select Trim from the pop-up menu to enable Trim mode. The track volume and send level faders turn yellow.
3. Click in a track at an insertion point.
   - or -
4. Drag with the Selector to select a portion of the track.
5. Click Play to begin playback.
6. When you reach a point in the track/selection that contains the trim setting (delta value) you want to apply, click the Write to Start, Write to All, or Write to End button in the Automation Enable window.

The relative changes to the track volume and send levels at that point are written to the corresponding area of the track/selection.
Write to Start, End, and All On Stop

The Automation Enable window provides options for automatic Write to Start, End, and All On Stop.

To configure Write on Stop:

1. Open the Automation Enable window.
2. Click to enable one of the Write On Stop modes (Start, End, or All).

When any of these options are enabled, automation writing will be performed automatically after a valid automation pass has been performed. See “Requirements for Write to Start, End, and All” on page 443.

Trimming Automation

(TDM Systems Only)

If you have already written automation, you can modify automation data for track volume and send levels in real time by using Trim mode. When a track is trim-enabled, you are not recording absolute fader positions, but relative changes in the existing automation. See “Trim Mode” on page 424 for more information.

To enable Trim mode:

- Click the Automation Mode Selector and choose Trim from the pop-up menu.

*Enabling Trim mode*

When Trim mode is enabled for a track, its volume and send level faders turn yellow, and its Automation Mode button is outlined in yellow. This outline flashes to indicate that the track is trim-enabled, and appears solid whenever trimming is occurring on the track’s volume or send levels.

To trim track volume or send levels in real time:

1. In the Automation Enable window, make sure the automation type (volume or send level) is write-enabled.
2. Click the Automation Mode Selector on the tracks you want to automate and select Trim from the pop-up menu.
3. Click the Automation Mode Selector a second time and choose an Automation mode:
   - Use Auto Touch or Auto Latch to have the faders follow existing automation, so you can “chase” them during the automation pass.
   - Use Auto Write if you want to disengage the faders from existing automation.
4. Click Play to begin trimming automation, and move the volume or send level faders.
5. When you have finished, click Stop.
Creating Snapshot Automation

(TDM Systems Only)

Pro Tools lets you write automation data values for multiple parameters in a single step. You can write snapshot automation in two ways:

To a selection Automation data is written to the Timeline selection (as well as the Edit selection if linked). Anchor breakpoints are placed just before and after the selection so that data outside the selection is not affected.

To a cursor location Automation data is written at the insertion point. After the insertion point, the automation ramps to the next breakpoint value, or if no breakpoints exist, remains at the newly written value for the remainder of the session.

For more information on copying automation data within a session, see “Writing Automation to the Start, End or All of a Selection” on page 442.

To write snapshot automation:

1. In the Edit window, click the Track View button to show the automation you want to edit.
2. In the Automation Enable window, make sure that the automation parameters you want to edit are write-enabled. Disable any parameters you want to preserve.
3. Select an area in the track’s playlist (or within multiple tracks) where you want to apply the automation.
   – or –
   Place the cursor at an Edit insertion point.
4. Adjust the controls for the parameters you want to automate.
5. Choose Edit > Write Automation and do one of the following:
   • To write the current value to only the currently displayed automation parameter, choose To Current Parameter.
   • To write the current settings for all automation parameters enabled in the Automation Enable window, choose To All Enabled Parameters.

Adding Snapshot Automation to Empty Automation Playlists

When you use the Write Automation command on an automation playlist with no previously written automation data, the selected value is written to the entire playlist and not just the selected area.

This is because a playlist with no automation data contains only a single automation breakpoint that corresponds to the current position of the control. The position of the breakpoint is updated whenever the parameter value is changed.

If you do not want the Write Automation command to write the selected automation value to the entire playlist, you can:
   • Anchor the automation data by placing the cursor at the end of the session (or any other endpoint) and choosing Write Automation To Current Parameter.
     – or –
   • Click with the Grabber on each side of the selection.

This lets the Write Automation command write only to the selected area.
Writing Snapshot Automation over Existing Automation Data

When you move the playback cursor, the automated controls in Pro Tools update on the screen to reflect the automation data that is already on the track. To keep the settings you have made for a snapshot, you can suspend the desired automation parameters to prevent the controls from updating.

To write snapshot automation over existing data:

1. In the Automation Enable window, make sure that the automation parameters you want to edit are write-enabled. Deselect any parameters you want to preserve.
2. Adjust the controls for the parameters you want to automate.
3. Suspend the automation parameters you want to automate by doing any of the following:
   - To suspend an automation parameter on a single track, Command-click (Macintosh) or Control-click (Windows) the name of the automation type in the track's Track View Selector.
   - To suspend an automation parameter on all tracks, Command-Shift-click (Macintosh) or Control-Alt-click (Windows) the name of the automation type in the Track View Selector for any track.
   - To suspend all automation on a track, Command-Shift-click (Macintosh) or Control-Shift-click (Windows) the name of the automation type in the track's Track View Selector.
4. With the Selector, select the track range you want to apply the automation.
5. Enable the automation parameters previously suspended.
6. Choose Edit > Write Automation and select one of the following from the submenu:
   - To write the current value to only the automation parameter currently displayed in the Edit window, choose To Current Parameter.
   - To write the current settings for all automation parameters enabled in the Automation Enable window, choose To All Enabled Parameters.

Capturing Automation and Applying it Elsewhere

The Write Automation command can also be used to capture automation states at specific locations in a session and apply them to other locations. This differs from simply copying and pasting automation data in that you can set any selection length for the application of the captured automation data.

To capture and apply automation:

1. In the Automation Enable window, make sure that the automation parameters you want to edit are write-enabled. Disable any parameters you want to preserve.
2. Click with the Selector in the track with the automation you want to capture. All automated controls update to reflect the automation at that location. (If you make a selection, the controls update to reflect the automation at the beginning of the selection.)
3 Suspend the automation parameters you want to automate:

- For an automation parameter on a single track, Command-click (Macintosh) or Control-click (Windows) the name of the automation type in that track’s Track View Selector.
- For an automation parameter on all tracks, Command-Shift-click (Macintosh) or Control-Alt-click (Windows) the name of the automation type in the Track View Selector for any track.
- To suspend all automation on a track, Command-Shift-click (Macintosh) or Control-Shift-click (Windows) the name of the automation type in that track’s Track View Selector.

4 With the Selector tool, select the location where you want to apply the automation.

5 Enable the automation parameters previously suspended.

6 Choose Edit > Write Automation and select one of the following from the submenu:

- To write the current value to only the automation parameter currently displayed in the Edit window, choose To Current Parameter.
- To write the current settings for all automation parameters enabled in the Automation Enable window, choose To All Enabled Parameters.

---

**Snapshot Automation and Trimming of Automation Data**

Pro Tools lets you use trim values as snapshots and apply the *relative* changes (delta values) to the selected automation by using the Trim Automation command. This works in much the same way as the Write Automation command, except that it writes delta values instead of absolute values to automation data.

You can use trim values in writing snapshot automation to any automatable parameter.

**To create a snapshot of relative changes in automation data:**

1 In the Automation Enable window, make sure that the automation parameters you want to edit are write-enabled. Disable any parameters you want to preserve.

2 Select the area of the track you want to edit. All automated controls update to reflect the automation at the beginning of the selection.

3 Move the controls for the parameter up or down by the amount you want to change the data.

4 Choose Edit > Trim Automation and do one of the following:

- To write the current delta value to only the currently displayed automation parameter, choose To Current Parameter.
- To write the current delta value for all automation parameters enabled in the Automation Enable window, choose To All Enabled Parameters.
Chapter 29: Mixdown

Pro Tools lets you record and bounce tracks to disk. The Bounce to Disk command lets you write a final mix to disk, create a new loop, print effects, or bounce any submix. You can also submix, route, and record busses and inputs to new audio tracks.

**Bounce to Disk** This command writes the current session (if no selection), Edit, or Timeline selection as new audio files to disk. Any available output or bus path can be selected as the bounce source. Use Bounce to Disk to write or master any output or bus path directly to disk. Sample rate, bit depth, and other conversion processes can be applied during or after the bounce. The Bounce to Disk command lets you bounce all available voices to disk without holding any in reserve. Though you can hear the bounce being created in real time, you cannot adjust mixer or other controls during a Bounce to Disk.

**Recording to Tracks** This is the process of submixing and recording to new audio tracks, as you would any input signals. This method requires available tracks, voices, and bus paths to accommodate the submix and the new tracks. While recording to tracks, you can adjust mixer or other controls.

**Selecting Audio for Loops, Submixes, and Effects**

Both Bounce to Disk and recording to tracks operate on the current Timeline or Edit selection, if any. This makes it easy to turn multitrack selections into mono, stereo, or multichannel loops. Submixes, stems, and other specialized types of mixes can also be printed to disk using either method, or recorded out to a DAT, MDI, or other recording, transfer, or archiving medium.

Printing effects to disk is the technique of permanently adding real-time effects, such as EQ or reverb, to an audio track by bussing and recording it to new tracks with the effects added. The original audio is preserved, so you can return to the source track at any time. This can be useful when you have a limited number of tracks or effects devices.

.AudioSuite plug-ins provide another option for printing a plug-in effect to disk. See the DigiRack Plug-Ins Guide for details.

Use Bounce to Disk if you need to convert the bounce files, or if you do not want or need to interact with mixer controls during the bounce. Record to new tracks if you want to adjust parameters while the files are being written.
Dither and Bounce to Disk

Dithering can significantly improve audio quality. Generally, dithering is necessary when reducing the bit depth for digital audio.

If you use Bounce to Disk, it is important to understand that the Bounce to Disk process does not apply dither.

To dither a bounce file, you should insert one of the included Digidesign Dither plug-ins (such as POW-r Dither), or another dithering plug-in, on a Master Fader assigned to the bounce source path. Master Faders are often preferable to Auxiliary Inputs because Master Fader inserts are post-fader (better for dithering).

If you do not use a dithering plug-in on your bounce source path, and you choose to convert to a lower resolution during or after a Bounce to Disk, the resultant file will be converted by truncation.

When to Use a Dithering Plug-In

You should use a dithering plug-in when mastering to a 16-bit file with the Bounce To Disk command, or when mastering to an external device that records at 16-bit.

This is even necessary when using 16-bit sessions. Even though 16-bit sessions use 16-bit files, they are still being processed internally at a higher bit rate:

- 24-bit for Pro Tool TDM systems
- 32-bit floating for Pro Tools LE systems

For this reason, whether you are using a 16-bit session or a 24-bit session, it is recommended that you use a Dither plug-in when mastering to 16-bits.

When mastering to 24-bits, it is not necessary to use a Dither plug-in.

Using Dither on an Output Mix

Pro Tools includes real-time dithering plug-ins that improve 16-, 18-, or 20-bit performance and reduce quantization noise when mixing or fading low-level signals.

The dithering plug-ins have no user-selectable parameters other than Bit Resolution and Noise Shaping controls.

For more information about dither, see “Dither” on page 402.

To use a dithering plug-in on a submix:

1. Choose File > New Track and select Master Fader (stereo) from the pop-up menu.
2. Set the output of the Master Fader to the output or bus path you want to bounce.
3. Assign the outputs of all audio tracks in the session to the same path you selected in step 2. The Master Fader now controls the output levels of all tracks routed to it.
4. On the Master Fader, click an Insert button and choose one of the Digidesign dithering plug-ins (such as POW-r Dither).
5. In the dithering plug-in window, choose an output Bit Resolution and Noise Shaping setting.

When you Bounce to Disk you can convert the file to the appropriate resolution. Before being converted by the Bounce to Disk command, the signal will have been dithered to the resolution and noise shaping settings in a dithering plug-in.

For more information about the Digidesign dithering plug-ins, refer to the DigiRack Plug-Ins Guide.
Recording to Tracks

You can create a submix in your Pro Tools session and record it to available tracks in the same session. This technique lets you add live input to the mix, as well as adjust volume, pan, mute, and other controls during the recording process.

Voice Requirements

Recording a submix to new tracks requires an available voice for each track that you want to record. Make sure you have enough voices available to play back all tracks that you want to record and enough voices available to record the destination tracks.

In contrast, the Bounce to Disk command lets you bounce all available voices to disk without holding any in reserve, but you cannot manually change any controls during the bounce. See “Bounce to Disk” on page 452 for more information.

For information about voice management, see “Track Priority and Voice Assignment” on page 93.

To record a submix:

1. Apply any plug-ins or external processors you want to add to your audio tracks or Auxiliary Inputs before you record.

2. Set the main channel output of the tracks you want to include in the submix to a bus path. If you are recording in stereo, set the panning of each track.

3. Choose File > New Track and create one or more mono, stereo, or multichannel audio tracks.

4. If you are recording in stereo, pan the new stereo track (or two mono tracks) hard left and right.

5. Set the input of each destination track to match the bus path to which you are recording.

6. Set the output of your new tracks to your main output path.

7. Select Operations > Link Edit and Timeline Selection.

8. Select audio to record. The start, end, and length of the recording can be based on cursor location or Edit and Timeline selections.

   - Selection-based recording automatically punches in and out of recording at the selection start and end. Be sure to include time at the end of a selection for reverb tails, delays, and other effects.

   - If you don’t make a selection, recording will begin from the location of the playback cursor. Recording will continue until you press Stop.

9. Record enable the new tracks and click Record in the Transport window.

10. Click Play in the Transport window to begin recording the submix.

11. If recording a selection of audio, recording will stop automatically. If performing an open-ended recording, click Stop, or punch out of recording.
**Bounce to Disk**

The Bounce to Disk command lets you mix down with all available voices on your system. Since it records to separate audio files, you don’t have to reserve any tracks for a bounce.

You can use the Bounce to Disk command to create and automatically import loops, submixes, or any audio into your session. You can use it to create a final mono, stereo, or multichannel master, in any of several audio file formats. Bounce to Disk provides conversion options for sample rate, bit resolution, and format.

When you bounce a track to disk, the bounced mix includes the following:

**Audible Tracks** All audible tracks are included in the bounce. Any muted tracks are not included in the bounce. If you solo one or more tracks, only the soloed tracks are included in the bounced mix.

**Automation** All read-enabled automation is played back and incorporated in the bounced mix.

**Inserts and Sends** All active inserts, including real-time plug-ins and hardware inserts, are applied to the bounced mix.

**Selection or Track Length** If you make a selection in a track, the bounced mix will be the length of the selection. If there is no selection in any track, the bounce will be the length of the longest audible track in the session.

**Time Stamp Information** Bounced material is automatically time stamped so that you can drag it into a track and place it at the same location as the original material. For more information about time stamping, see “Time Stamping” on page 545.

Pro Tools bounces are done in real time, so you hear audio playback of your mix during the bounce process (though you can’t adjust it).

**Bounced Files are “Delay-Compensated”**

DAE compensates for any bus delays due to a bounce. Meaning, if a bounce file is imported back into a session, and placed directly in time against the source mix, it is phase accurate with the original source mix.

**To Bounce to Disk:**

1. Choose File > Bounce to Disk.
2. Configure bounce options as needed and perform the bounce (see “Bounce Options” on page 453).

**Bouncing with Mute Frees Assigned Voice (TDM Systems Only)**

When bouncing sessions that include muted tracks, enabling “Mute Frees Assigned Voice” can, in some instances, increase the number of tracks that can be successfully bounced.
Bounce Options

When you use the Bounce to Disk command, you can configure several file options.

Bounce to Disk dialog, with conversion and options enabled

Default Settings

Available options and their default settings are listed in the following table.

<table>
<thead>
<tr>
<th>Option</th>
<th>Default</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bounce Source</td>
<td>current main output path</td>
</tr>
<tr>
<td>File Type</td>
<td>session default file type</td>
</tr>
<tr>
<td>Format</td>
<td>Auto Stereo Interleaved</td>
</tr>
<tr>
<td>Resolution</td>
<td>session default resolution</td>
</tr>
<tr>
<td>Sample Rate</td>
<td>session default sample rate</td>
</tr>
<tr>
<td>Conversion Quality</td>
<td>Good</td>
</tr>
<tr>
<td>Use Squeezer (8-bit only)</td>
<td>deselected</td>
</tr>
<tr>
<td>Convert During Bounce</td>
<td>deselected</td>
</tr>
<tr>
<td>Convert After Bounce</td>
<td>selected</td>
</tr>
<tr>
<td>Import After Bounce</td>
<td>deselected</td>
</tr>
</tbody>
</table>

Avid Compatibility Mode

When the Avid Compatibility mode is enabled, its additional data is added to the bounced files automatically. See “Avid File Compatibility” on page 130.

Bounce Source

Select any mono, stereo, or multichannel output or bus path as the source for the bounce. All currently active paths as defined in the I/O Setup dialog are available as the Bounce Source.
To set the bounce source:

- Select an output or bus path from the Source Selector.

**File Type**

Selects the (creator) type for the bounced files.

**Sound Designer II**

This was the native format for older Macintosh-based Pro Tools systems. Select this to use the bounced audio with any Digidesign application for Macintosh.

**AIFF (Audio Interchange File Format)**

Files in this format do not have to be converted to be used in Pro Tools, but you must still import them into a session with the Import Audio command or the Convert and Import Audio command. AIFF waveform overview data cannot be stored in the file, so the overview is recalculated every time the session is opened. The AIFF format is useful if you plan to use bounced audio in applications that do not support the Sound Designer II format.

**BWF (Broadcast .WAV Format)**

WAV is the native format for Windows-based Pro Tools systems. The WAV format is supported by many Windows applications and some Macintosh applications. To use a WAV file on Macintosh-based Pro Tools systems, you must use the Convert and Import Audio command.

**SND Resource**

(Macintosh Only)

This file type is supported by some Macintosh software applications and also by Macintosh System Software. Pro Tools does not directly support this type of file in its sessions. To use a SND file within Pro Tools, use the Import Audio command. The SND format is useful if you plan to use your audio with other Macintosh applications that do not support Sound Designer II or AIFF formats. To save a bounced file as a System alert sound, save it in this format and then drag it onto the Macintosh System File.

**QuickTime**

(Macintosh Only)

This is Apple’s audio file format for QuickTime-based multimedia. Pro Tools does not directly support this type of file in its sessions. To use a QuickTime audio file within Pro Tools, use the Convert and Import Audio command or Import Audio from Other Movie command. The QuickTime format is popular for attaching to emails, to simplify long-distance project review and approval. Many popular multimedia applications also support QuickTime.
Windows Media  
(Windows Only)  
Windows Media formatted files can contain audio, video, or script data stored in Windows Media Format. A Windows Media Format file may have an .asf, .wma, or .wmv file name extension.

RealAudio G2  
(Macintosh OS 9 Only)  
RealAudio G2 is the latest version of the format created by Real Networks for streaming audio over the Internet. The RealAudio encoder file is stored in a folder named Codecs inside the DAE folder.

When you select this format, the Resolution and Sample Rate pop-up menus in the Pro Tools Output Options dialog are unavailable, because resolution and sample rate are set by the encoder.

The RealAudio G2 format lets multiple streams with different bit rates be encoded into a single file. During playback, the RealAudio G2 server and the RealPlayer G2 client continuously adjust the bit rate to make the best use of available bandwidth. The RealPlayer G2 is available on the Real Networks web site, www.real.com.

When you export or bounce to RealAudio G2 format, you can set the following options:

Media Clip Information  Type the title, author, and copyright information for your RealAudio clip. This information is displayed on the RealPlayer G2 as the clip plays back.

Copy Protection  These settings determine how the clip is handled by the RealPlayer client.

- To allow RealPlayer Plus users to save your clip using the RealPlayer Plus recording feature, select Allow Recording.
- To allow RealPlayer users to download your clip to their hard drive, select Allow Download.

If you don’t want to allow RealPlayer users to make copies of your clip, deselect both of these options.

Audio Format  From the pop-up menu, select the setting that best matches the type of audio you are bouncing. A brief explanation of each format is displayed.

Target Audience  Select the connection speed that most users downloading your clip are likely to have. This setting determines the bit rate at which the audio will be encoded. Depending on the file type you choose (see below), you can choose more than one connection speed.
**File Type**
This option determines the compatibility of the output file with different RealAudio servers and clients.

If you select SureStream, you can select more than one connection speed under Target Audience. With this file type, multiple bit rate streams are encoded into a single output file. Files encoded with the SureStream option are larger than Single Rate files, and can only be played back from G2 servers.

Select the “Include RealPlayer 5.0 Compatible Stream” option to include a backward compatible stream that can be played on older version 5.0 RealPlayers. (This backward compatibility is only available for SureStream-encoded files.)

If you select Single Rate, you can only select one connection speed under Target Audience. With this file type, a single stream is encoded into the output file. Files encoded with the Single Rate option can be played back from either a standard web server or a G2 server.

**Auditioning RealAudio Clips**
If you are using Digidesign Sound Drivers and want to use a RealAudio player while running Pro Tools, make sure that Operations > Active in Background is not selected so the player can use the Digidesign hardware.

**MP3 (MPEG Layer 3)**
The MPEG-1 Layer 3 compression format (MP3) is used for streaming and downloading audio over the Internet, and for playback on portable devices. MP3 Option is required.

**MP3 Output Options**
On Windows and Macintosh OS 9, the MP3 encoder file is stored in a folder named Codecs inside the DAE folder; on Macintosh OS X, the MP3 encoder file is stored in Applications/Pro Tools/Codecs/MP3/. This version of the encoder uses the latest technology from the developer of the MP3 format, the Fraunhofer Institute. It features improved processing speed and quality, and supports both constant and variable bit rate encoding.

The MP3 encoder provided as an install option with Pro Tools is a fully functional 30-day demo version. To purchase the full version of the MP3 encoder, visit Digidesign’s Web site (www.digidesign.com).

When you select this format, the Resolution pop-up menu in the Pro Tools Output Options dialog is unavailable. The resolution is set by the encoder.
The sample rate chosen is given to the codec as a “base” sample rate for operations. The actual sample rate of the resulting file is determined in the MP3 Encoder Options dialog. For example, if a base sample rate of 48000 Hz is chosen, the MP3 Encoder Options dialog will allow output streams in 48, 24, or 12 kHz, depending on encoding quality.

When you export or bounce to MP3 format, you can set the following options:

**Encoder Settings**

**Encoding Quality** Determines the audio quality of the bounced file. The higher the quality, the longer it will take to process the audio. The three options, in ascending order of quality, are Fastest Encoding, Medium Encoding, and Highest Quality.

The Highest Quality setting can take up to five times longer to process audio than the Fastest Encoding setting, so you should use it only when the highest fidelity is essential and you have a considerable amount of time to devote to the encoding process. You should experiment with the other encoding quality settings, since they can provide acceptable quality with a significantly shorter encoding time.

**Encoding Method** Two encoding methods are available:

- **Constant Bit Rate (CBR)** encodes the file at a single bit rate that you choose from the CBR pop-up menu. Because the bit rate is fixed, the quality of the encoded audio will vary depending on the nature of the material being compressed. This option is best for streaming over the Internet, since it has predictable bandwidth requirements.

- **Variable Bit Rate (VBR)** encodes the file at a varying bit rate to maintain the level of encoding quality you choose from the VBR pop-up menu. The bit rate varies automatically depending on the nature of the material being compressed. This option is best for personal jukebox applications.

**ID3 Tag Info Settings**

**ID3 Tag Type** The ID3 tag stores data about the encoded audio file that is used by MP3 players to display information about the file. Pro Tools supports three versions of this tag, in order to provide backward compatibility with older MP3 players:

- **ID3 v1.0**: Appears at the end of a streaming MP3 file, therefore tag information is only displayed after software streaming is finished.
- **ID3 v1.1**: Same as version 1.0 but adds track number information to the tag.
- **ID3 v2.3**: Appears at the front of a streaming MP3 file, therefore tag information is displayed when streaming begins.

While ID3 v2.3 is becoming the standard MP3 format, not all MP3 players currently support ID3 v2.3. Contact the developer of your player software for compatibility information.

**Title/Artist/Album/Comment** Type the title, artist, and other information for the MP3 file. This information is displayed by many MP3 players.

**Genre** Choose a genre for the file. This information is displayed by many MP3 players, and can appear in searchable catalogs and databases.

**Track Number** If you select ID3 tag type v1.1 or v2.3, you can enter a CD track number for the file. This information is displayed by many MP3 players.
Year Enter a year for the file. This information is displayed by many MP3 players.

Advanced Settings
The options listed under Advanced Settings, under normal situations, do not need to be changed from their default values.

Pad To Match Bit Rate Exactly This option determines whether MP3 frames are padded to maintain bit rate very precisely. You should only select this option if you need a file with an exact bit rate, for specific applications (such as synchronous transmission over ISDN line).

⚠️ Padding of MP3 frames can cause problems with some versions of Internet streaming software. If your files are destined for desktop or Internet delivery, do not select this option.

Allow Intensity Stereo Coding This option determines whether the encoder takes into account the frequency of a signal when encoding its phase characteristics, allowing for more compression at low bit rates. In most cases, you should leave this option selected. However, if you are working with highly phase-dependent material, such as Dolby Surround, you may want to deselect this option.

Write CRC Checksums This option adds error-detection data to the MP3 file. This data is not necessary for most computer and Internet applications, and also takes away from the space available for audio data. Select this option only if you are sure your delivery mode requires error correction.

Copyrighted This option sets a bit in the MP3 data stream to indicate that the audio is copyrighted. Not all MP3 players use this information. Selecting this option does not guarantee that the audio file will not be copied.

Original This option sets a bit in the MP3 data stream to indicate that the audio is the original media for the track, rather than a copy. This setting is not widely used.

Private This option sets a bit in the MP3 data stream that is interpreted differently by various applications. It is not normally used.

Mac File Settings
Mac File Type and Creator If you expect your file to be used on a Macintosh, you can enter the Macintosh file type and creator. This will allow users to double-click the file to open their MP3 player.

Default Button
To restore all settings in this dialog to their default values, click Defaults.

Auditioning MP3 Clips
If you are using Digidesign Sound Drivers and want to use an MP3 player to audition an MP3 file while running Pro Tools, make sure that Operations > Active in Background is not selected. This lets your MP3 player access the Digidesign hardware.

Format
This is the format for the bounced result. Choices are Mono (summed), Multiple mono, and Interleaved.

To set the bounce file format:
- Select a file format from the Format Selector.

---

![Image](image.png)
Mono (Summed) Creates a single disk file that is a summed mono mix of the current sources being monitored.

When bouncing to mono (summed) files, the output may clip. Avoid clipping by monitoring the meters of your bounce source Auxiliary Input or Master Fader. When bouncing stereo tracks to mono (summed) files, clipping occurs if left and right signals exceed –3 dB below maximum, or full code (0 dBFS).

Multiple mono Creates multiple mono files with the same number of channels as the source path.
• If the source output or bus path is stereo, two mono files will be created, and appended with “.L” and “.R” suffixes on bounce.
• If a multichannel format is used (for example, six-channel, 5.1), individual mono files will be created for each member of the path. Files will be appended with path suffixes according to the path definition in the I/O Setup dialog.

Interleaved Creates a single, interleaved file that contains all of the bounced streams from the chosen output path. In an interleaved stereo bounce, tracks assigned to odd-numbered outputs are sent to the left channel, and tracks assigned to even-numbered outputs are sent to the right channel.

Pro Tools also lets you create multichannel interleaved files of any supported file type. This can simplify file management of mixes and projects for backup and archiving.

Pro Tools does not support interleaved files natively. This means that they must be split into multi-mono files on import (requiring additional disk space).

Resolution
This parameter lets you select between three different bit resolutions for the bounce conversion.

Bounce to Disk does not apply dither when converting during or after a bounce to a lower resolution (including when bouncing to 16-bit). When you need to create a lower resolution bounce file, use a Digidesign Dither plug-in, or similar, on a Master Fader assigned to the bounce source path. This dithers the bounce file, before the Bounce to Disk conversion truncates bits into the final file resolution.

Resolution choices include the following:

8-bit This resolution is often used in multimedia applications. If the material you are working with is relatively simple, you can use the Pro Tools “Squeezer” feature for optimal results. See “Sample Rate Conversion Quality” on page 460 for details.

16-bit This is the Compact Disc standard bit resolution.

24-bit If you plan to use the bounced file with a Pro Tools TDM system, you can take advantage of the greater resolution and headroom afforded by this higher bit rate. You can also archive a master stereo mixdown or bounce audio material at this resolution for future use on a 24-bit system.

To set the bounce file resolution:
• Select a bit depth from the Resolution Selector.
**Sample Rate**

This option lets you save to any of several sample rates. Choices are dependent on your Pro Tools system and Digidesign audio interfaces.

**Sample Rate Conversion Quality**

If you choose a sample rate that differs from the original sample rate of the session, the conversion options become available. You can configure the conversion quality, and schedule conversion to occur during, or after, the bounce. See “Sample Rate Conversion Quality” on page 460 for more information.

The following are the more common sample rates, and their application. Higher sampling rates will provide better audio fidelity for recording and playback, and also for processing with dynamics, dither (with noise shaping), and analog emulation plug-ins.

- **192000** This is a supported sample rate for some audio DVDs, and provides the highest quality audio fidelity with compatible audio interfaces (such as the 192 I/O).
- **176400** You may want to work at a sample rate of 176.4 kHz if the final delivery will be at 44.1 kHz (such as compact disc). This will provide a slightly faster sample rate conversion to 44.1 kHz than from 192 kHz.
- **96000** This is a supported sample rate for DVD audio and provides high-quality audio fidelity with compatible audio interfaces (such as the 96 I/O).
- **88200** You may want to work at a sample rate of 88.2 kHz if the final delivery will be at 44.1 kHz (such as compact disc). This will provide a slightly faster sample rate conversion to 44.1 kHz than from 96 kHz.

**48000** This is the standard sample rate for DAT and ADAT decks, and DVD video.

**44100** This is the standard sample rate for compact discs (CD), and is supported by DAT and ADAT decks.

**Custom** For a custom sample rate, click in the sample rate window and manually enter in a value.

**Pull-up and Pull-down Rates** All available sample rates support pull-up and pull-down rates, or other specialized rates.

**Sample Rate Conversion Quality**

The Conversion Quality option sets the quality of sample rate conversion used to create the converted file. The higher the quality of sample rate conversion, the longer it takes to convert the file after the bounce has taken place. There are five possible settings, ranging from Low to Tweak Head. For most applications, the Better setting yields satisfactory results.

**Processing Resources and Conversion Quality**

Because the Best and Tweak Head settings take longer than the others, you may want to use them only in cases where the highest fidelity is essential and you are not facing strict time limitations.

**Use Squeezer**

The Use Squeezer option uses a proprietary DSP algorithm specifically designed for performing 8-bit conversion of simple source files such as voice-overs. It optimizes the dynamics of the audio by preprocessing it using compression, limiting, and gating before conversion to 8-bit resolution. This results in greater apparent
Chapter 29: Mixdown

461

loudness in the signal, and improved intelligibility. If you are converting a more complex 16-bit audio file to 8-bit resolution, test this option before converting all of your material.

**Convert During or After Bounce**

The Bounce dialog can perform any conversion options, including sample rate and bit depth conversion, during a bounce or post-bounce.

**Convert After Bounce** This option automatically performs file type, sample rate and bit resolution conversion on the newly bounced files. The Convert After Bounce option, though more time and storage consuming, offers the highest level of plug-in automation accuracy possible.

**Convert During Bounce** This option may take less time than Convert After Bounce, but does so at the expense of plug-in automation playback accuracy.

**Import Into Session After Bounce**

The Import Into Session After Bounce option automatically imports the newly bounced files into the Audio Regions List so you can place them in tracks. If your newly bounced files are split stereo files, they are listed together in the Audio Regions List.

The Import Into Session After Bounce option is only available if the target bit depth for the bounce is the same or less as the bit depth of the current session, and it is supported by the Digidesign audio interface.

**Help**

The Help button opens a display-only dialog box that describes the Bounce to Disk features.

**Recording a Submix (with Bounce To Disk)**

You can create a submix with the Bounce to Disk command by muting tracks or bypassing inserts that are not part of the submix group, and selecting the part of the session you want to bounce.

You can also create a submix by recording to new tracks. For details, see “Recording to Tracks” on page 451.

To bounce a submix to disk and bring it into the session:

1. Configure your submix using sends, Auxiliary Inputs, and Master Faders. (See “Submixing for Signal Routing and Effects Processing” on page 398.)
2. Do one of the following:
   - To bounce the entire session, click Return to Zero in the Transport window to go to the beginning of the session.
   - or –
   - To bounce a portion of the session, enable Operations > Link Edit and Timeline Selection, and make a selection in the Edit window.
3. Choose File > Bounce to Disk.
4. Configure bounce options and parameters.
5. Verify the bit resolution for the bounced file matches the bit resolution of the session.
Verify the sample rate for the bounced file is supported by the session and the audio interface.

Select the Import After Bounce option.

Click Bounce.

Select a destination for the new audio file, enter a name, and click Save.

Pro Tools bounces are done in real time, so you hear audio playback of your mix during the bounce process. You cannot adjust controls during a Bounce to Disk.

To bring bounced files back into tracks:

1. Do one of the following:
   - If the newly bounced audio was automatically imported into the session, drag the new files from the Audio Regions List to existing tracks in your session.
   - If the bounced files are not available in the Audio Regions List, import them into the session by choosing File > Convert and Import Audio.
   - If you are placing multiple files of a multi-channel track or file, keep channels in phase with each other by Shift-selecting them in the Regions List, and dragging them simultaneously into existing tracks of the right format.

2. When working with stereo tracks, set the pan controls hard left and hard right.

3. Mute or turn off the voices of original source tracks so that you don’t double monitor your audio material.

4. Click Play in the Transport window to hear the results of the bounce.

---

Final Mixdown (with Bounce To Disk)

In final mixdown, you create a mix that includes all your edits, automation, and effects processing.

To bounce a final mix to disk:

1. Adjust track output levels, finalize any mix automation, and choose an Automation mode for each track in the session.

2. Adjust any real-time plug-in and effects settings and automation for each track in the session.

3. Make sure that all of the tracks you want to include in the bounce are audible (not muted or inactive).

4. Assign the output of each of the tracks you want to include in your bounce to the same output path.

5. Do one of the following:
   - To bounce the entire session, click Return to Zero in the Transport window to go to the beginning of the session.
   - To bounce a portion of the session, enable Operations > Link Edit and Timeline Selection, and make a selection in the Edit window.

6. Choose File > Bounce to Disk.

7. Choose the source path you want to bounce.

8. Configure other Bounce to Disk parameters as appropriate. See “Bounce Options” on page 453.

9. Click Bounce.

10. Select a destination for the new audio file, enter a name, and click Save.
Mastering

In the final mastering process, you might record directly to disk, DAT, DVD, CD, stereo mastering recorder, or a multitrack recorder (for surround mixes).

Once you have created a master of your session, you can transfer it to a portable medium for duplication. You can transfer the master file to CD, DAT or 8 mm DDP tape to be used as a master for pressing compact discs.

Mastering to a Digital Recorder

Although it is usually best to master sessions directly to hard disk, Pro Tools also lets you master digitally, direct to any AES/EBU-equipped or S/PDIF-equipped digital recorder such as a DAT deck.

24-Bit Input and Output with Pro Tools TDM Systems

Pro Tools TDM systems are full 24-bit audio recording and mixing environments, supporting record, playback, mixing, and processing of 24-bit audio files. You can record to and from other 24-bit recording systems without any bit-depth conversion.

Mastering and Audio Compression

Although audio compression is often an indispensable tool in analog recording, it can present problems in the digital domain. If you compress an input signal at a very high ratio, you create a signal that contains a much higher overall power level compared to its transients. By recording a number of such signals at the highest possible level on multiple tracks, you create a scenario that is more likely to clip the mixed output signal.

High-power compressed signals, when mixed together, create an extremely high-level output. This output may rise above the full-code level, resulting in clipping.

To avoid this problem, watch the overall level of your program material—use a meter on a Master Fader, or use an external mastering deck’s meters to help avoid clipping. If you are mastering to hard disk, avoid mixing full-code audio signals together at unity or “0” level, as this invariably causes clipping.

Mastering and Error-Correcting Media

Random access media (such as hard disks, optical cartridges, Bernoulli cartridges or WORM drives) can produce a true digital copy of your data, because every bit value is maintained. Sequential media (such as DAT tapes) use error correction schemes to fix the occasional bad data that is received in a digital transfer. These corrections are deviations from the actual data, and with successive reproductions, represent a subtle form of generation loss.

You can avoid this loss by creating and maintaining masters on random-access digital media (such as a hard drive) and transferring them to sequential digital media (such as DAT tapes) only as needed.

To configure Pro Tools for direct digital stereo mastering:

1. Connect your digital recorder to your system’s digital outputs. If your system has multiple digital outputs, use channel 1 and 2 of the audio interface.

2. In Pro Tools set the appropriate digital format and output from the Hardware Setup dialog or I/O Setup dialog.

3. On your digital recorder, choose the appropriate digital format for the connections.
4 In Pro Tools, set all audio tracks you want to your master outputs 1–2 path.

5 Click Return to Zero in the Transport window to go to the beginning of the session.

6 Press Record on your digital recorder.

7 Start playback of your session.

8 When your session has finished playing, stop the digital recorder.
Part VII: Surround
Chapter 30: Surround Concepts

Pro Tools HD-series and MIX-series systems support multichannel mixing for surround sound.

How to Use These Chapters

This part of the guide describes multichannel mixing for surround sound with Pro Tools. These sections supplement the basic Pro Tools information provided elsewhere in the Pro Tools Reference Guide.

If you are new to surround mixing, read the remaining sections of this chapter for an introduction to surround terminology and concepts.

If you already have experience with surround mixing, mastering, and monitoring, this chapter can be skipped. Operational instructions for Pro Tools surround features begin in Chapter 31, “Pro Tools Setup for Surround.”

Mixing Formats and Surround Formats

When running Pro Tools version 5.1 or later with the SurroundMixer plug-in, Pro Tools HD-series and MIX-series systems let you mix in 3-to 8-channel formats, in addition to standard mono and stereo.

Supported mixing formats include Mono, Stereo, LCR, Quad, LCRS, 5.0, 5.1, 6.0, 6.1, 7.0, and 7.1, letting you mix in any multichannel format needed for most surround formats.

Surround formats include Dolby Surround (Pro Logic), Dolby Digital, DTS, and SDDS. Pro Tools does not provide its own surround format processing, and requires appropriate plugins (such as Dolby Surround Tools™) or hardware to provide Dolby surround encoding and decoding.
Pro Tools Mixing Formats

See also “5.1 Track Layouts, Routing, and Metering” on page 482.

Table 4. Multichannel Mixing and Surround Formats

<table>
<thead>
<tr>
<th>Speaker Channels</th>
<th>Multichannel Mixing Format</th>
<th>Surround Format</th>
<th>Channels and Track Layout</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Mono</td>
<td></td>
<td>C</td>
</tr>
<tr>
<td>2</td>
<td>Stereo</td>
<td></td>
<td>L R</td>
</tr>
<tr>
<td>3</td>
<td>LCR</td>
<td>Cinema Stereo</td>
<td>L C R</td>
</tr>
<tr>
<td>4</td>
<td>Quad</td>
<td>Quadraphonic</td>
<td>L R Lr Rr</td>
</tr>
<tr>
<td>4</td>
<td>LCPS</td>
<td>Dolby Surround (Pro Logic)</td>
<td>L C R S</td>
</tr>
<tr>
<td>6</td>
<td>5.1</td>
<td>Film (Pro Tools default), for Dolby Digital</td>
<td>L C R Ls Rs LFE</td>
</tr>
<tr>
<td>6</td>
<td>5.1</td>
<td>SMPTE/ITU (Control</td>
<td>24)</td>
</tr>
<tr>
<td>6</td>
<td>5.1</td>
<td>DTS (ProControl)</td>
<td>L R Ls Rs C LFE</td>
</tr>
<tr>
<td>7</td>
<td>6.1</td>
<td>Dolby EX</td>
<td>L C R Ls Cs Rs LFE</td>
</tr>
<tr>
<td>8</td>
<td>7.1</td>
<td>SDDS</td>
<td>L Lc C Rc R Ls Rs LFE</td>
</tr>
</tbody>
</table>

Legend: L = Left; R = Right; C = Center, S = surround (mono); Ls = Left Surround; Rs = Right Surround; Lc = Left Center; Rc = Right Center; Cs = Center Surround; Lr = Left Rear; Rr = Right Rear; LFE = Low Frequency Effects (handled by a sub-woofer or bass management systems)

Speaker Layouts

Figure 35 on page 469 illustrates the speaker arrangements of each surround format. Speaker placement in the diagrams is approximate. For proper placement, alignment, and calibration of surround monitoring systems, consult the documentation that came with your speakers and other monitoring equipment. Placement of speakers is crucial to accurate monitoring of any mix, but this is especially true with multichannel mixing for surround sound.
Figure 35. Speaker arrangement of surround formats
Surround Monitoring

In order to monitor your current multichannel mix in a given surround format (DTS, Dolby Digital, or other), encoding and decoding equipment for that format is required. Pro Tools does not provide direct support for surround format processing, but encoding/decoding hardware or software is available from Digidesign and third-party manufacturers. Contact Digidesign or your dealer for information.

Proper speaker placement, studio calibration, additional surround processors, monitors, and a properly calibrated system can lessen the variables that your mix will be subjected to when the audience eventually hears it in the theater, in their home, or elsewhere.

The Importance of Speaker Placement

It is very important that your surround monitor system be installed and configured correctly. Proper speaker placement, angling, and level calibration are necessities for surround mixing, so consult the manufacturer of your monitor system. Several surround formats (especially all of those from Dolby as well as DTS) have very specific speaker and monitoring recommendations, so take the time to locate this information and adhere to the suggestions they provide.

For an example of one way to set up a 5.1 monitor system, see Figure 36 on page 470.

Figure 36. One suggested speaker arrangement for 5.1 mixing and monitoring (SMPTE specification). Sub placement is variable, all others should be as close to the suggested angles as possible.
Calibrated Surround Monitoring

One of the most important things you can do is to calibrate not only Pro Tools, but also your monitoring system and other equipment.

For example, many post production facilities calibrate their Pro Tools audio interfaces for –20 dB = 0 VU. Once Pro Tools hardware has been calibrated to unity gain, the monitoring system can be adjusted to account for anomalies in the room acoustics, speaker placement, and other variables.

Calibrating your Pro Tools system involves attenuating the input and output stages of your system. Settings and reference level vary according to the applicable standards of the current project.

Instructions for calibrating Pro Tools are included with the 192 I/O Audio Interface.

Calibrating Your Studio The first task for surround mixing should be getting your monitor speakers in proper position, alignment and calibration for accurate listening and mixing.

Speaker position and alignment will vary according to each installation, and is very specific for different speakers, manufacturers, and for each surround format. Instructions for optimal speaker location should have been provided with the speaker and monitor system, so consult the documentation provided by its manufacturer.

Proper speaker calibration ensures that your system plays back at accurately balanced levels. This lets you compensate for any variances in speaker position, alignment, or performance.

Formats and Terminology

Some multichannel mixing formats are referred to numerically (such as 5.1 and 7.1). These numbers describe the number and type of output (speaker) channels required for that format. Other formats are referred to by their track layout (such as LCRS and LCR).

Surround formats are referred to by their developer and product name, such as Dolby Surround (or Pro Logic), Dolby Digital, DTS, Dolby Surround EX, and others. Each surround format requires you to mix in a compatible mixing format. For example, both Dolby Digital and DTS are “5.1 surround formats.”

The standards for each format include more than just the number of speakers. Formats also may require specific track layout and filtering for the various channels. For example, the surround channel in Dolby Surround is band limited from 100 Hz to 7 kHz.

Surround formats also increase the importance of phase, balance, and sound placement due to the various ways in which multichannel mixes can be encoded, decoded, compressed, matrixed, or downmixed. Many publications are available on these subjects. For a listing of several sources of surround format information, see “Where to Get More Information on Surround Technology” on page 474.
LCRS for Dolby Surround

Dolby Surround (Pro Logic) is a four-channel format that is one of the most widely installed consumer surround formats.

This format, which requires Dolby encoding and decoding technology, provides three full-range front speakers left, center, and right, plus a mono surround channel (often split and monitored through pairs of satellite speakers, but a single “rear” channel nonetheless).

Surround Format Example

The goal of Dolby Surround encoding is to make a four-channel mix (LCRS) more portable, by transforming it into an encoded two-channel mix referred to as Lt/Rt. Lt and Rt represent Left Total and Right Total, respectively. Whenever you see Lt/Rt, it refers specifically to material that has been processed by a Dolby Surround Encoder (such as the Dolby SEU4 or Dolby Surround Tools plug-in).

The Lt/Rt mix can then be transported, transmitted, or played as a stereo mix, making it compatible with most home and theater systems. Alternately, the Lt/Rt pair can be decoded back into an LCRS mix in home theater systems where the required decoding hardware is available.

For professional results, always use professional-level products such as the Dolby Model SDU4 Decoder, Model DP564 Decoder, or Dolby Surround Tools plug-in when mix monitoring. Pro Logic-equipped consumer products have auto-balancing features which, if used for mix monitoring, may contribute to inappropriate mixing decisions.

5.1 for Dolby Digital and DTS

Both Dolby Digital and DTS formats are six-channel, 5.1 formats. Both provide five full-range speakers and a sub. These two surround formats use different track layouts, filtering, and compression as part of their specifications.

.1 Formats

The “.1” in any multichannel mix format indicates an LFE (Low Frequency Effects) track in the mix. Whenever a decimal is part of a surround format, it indicates a discrete Sub channel in the surround playback system that is intended for playback through a subwoofer speaker. For example, Dolby Digital is a 5.1 format intended for playback through systems with five full-range speakers and one subwoofer speaker. Dolby Surround EX is a 6.1 format, with six full-range speakers and one subwoofer speaker. SDDS is a 7.1 format, with seven full-range speakers and one subwoofer speaker.

Sub content will include the LFE channel of a “.1” format mix, as well as the effects of any bass management in the playback system. See “LFE” on page 473.

.0 Formats

The “.0” formats (5.0, 6.0, 7.0), while not associated with any specific surround formats, are useful in many mixes as sub-paths. For example, not all tracks will have content that needs to be routed to the LFE channel (the “.1” channel). Assigning such tracks to a 5.0 path provides a 360° panner without LFE controls.
LFE

When a decimal such as “.1” is present in the name of a surround format, it indicates the presence of an LFE channel. The LFE channel (for Low Frequency Effects, also known as Low Frequency Enhancement) refers most often to a specific track used in production (not during playback or decoding). LFE is the “.1” component in mix formats such as 5.1 and 7.1.

The reason the LFE component is referred to as “.1” is that unlike the other five or seven speakers, LFE is not full bandwidth (or full-range). The LFE signal provides a discrete path for low end to the subwoofer, unaffected by bass management (if any). Low frequency effects include such things as thunder, explosions, and other bass effects.

LFE is generally used to enhance sound effects in films. There are no set rules about whether or not you must employ an LFE channel.

⚠️  Pro Tools applies no filtering to LFE signals. Some delivery requirements may require filtering for the LFE track (such as the Dolby requirement of 120 Hz). See “Mixing Formats and Surround Formats” on page 467 for more information.

Sub Content

When surround mixes are played back on systems that include one or more subs, subwoofer content comes from either or both of the following sources:

- All bass from all channels that is below the threshold of the bass management filter cutoff (if any)
  - and –
- Audio in the LFE channel (if any)

A surround sub will play back all the lowest-frequency sounds from all of the other speaker channels, below a fixed frequency threshold. The threshold varies among different surround formats. See “Where to Get More Information on Surround Technology” on page 474 for a list of surround specification resources.

In addition to the frequency cutoffs and other specifications of each surround format, playback system variables can affect sub content. See “Surround Playback System Variables” on page 475 for more information.

Divergence

Divergence is a surround mixing parameter that lets you control panning “width.” Full divergence results in discrete (or narrow) panning. Lower divergence settings result in progressively less discrete (or wider) panning.

With full (100%) Divergence, tracks can be panned exclusively, or discretely, to a single speaker. Sounds panned to a single speaker are only audible in that speaker.

When Divergence is less than 100%, tracks will be audible in neighboring speakers even when panned directly to a single speaker in the grid. Lower divergence settings result in a progressively wider source signal.

Divergence Example

To understand divergence, it can be helpful to imagine the inside of a large movie theater. This is a good example because one of the most challenging playback variables one faces in multichannel mixing is the size of the intended listening environment.
Unlike the typical living room, movie theaters are large spaces with speakers placed widely apart. Due to distance, sounds panned discretely to the front right speaker, for example, might be inaudible in the opposite corner. To avoid this problem, variable divergence lets you control the panning width, in order to widen the sound source. This results in signals spreading into adjacent speakers, even when panned 100% to an individual speaker.

_Divergence options in Pro Tools are explained in “Divergence” on page 504._

**Where to Get More Information on Surround Technology**

The table below lists several sites that are good starting points for your research into the constantly evolving world of surround sound production.

_Resources for surround specifications and information_

<table>
<thead>
<tr>
<th>Surround Specifications</th>
<th>Web Site</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dolby Surround/Pro Logic</td>
<td><a href="http://www.dolby.com">www.dolby.com</a></td>
</tr>
<tr>
<td>Dolby Digital</td>
<td><a href="http://www.dolby.com">www.dolby.com</a></td>
</tr>
<tr>
<td>Dolby Surround EX</td>
<td><a href="http://www.dolby.com">www.dolby.com</a></td>
</tr>
<tr>
<td>DTS</td>
<td><a href="http://www.dtsonline.com">www.dtsonline.com</a></td>
</tr>
<tr>
<td>SDDS</td>
<td><a href="http://www.sony.com">www.sony.com</a></td>
</tr>
<tr>
<td>THX</td>
<td><a href="http://www.thx.com">www.thx.com</a></td>
</tr>
</tbody>
</table>

_For further reading on surround sound, try “5.1 Channel Surround Sound: Up and Running” by Tomlinson Holman._

**Surround Mixing Concepts**

As in stereo mixing and mastering, the goal in surround mixing is to provide the best sounding mix to the greatest number of potential listeners. Doing so for surround mixes requires many of the same techniques used for professional stereo production, plus several unique factors that are introduced in the following sections.

**Surround Format Compatibility**

Pro Tools lets you mix in surround and create multichannel masters, consisting of four, six, or more tracks that comprise an LCR, 5.1, or other format mix.

- Whenever necessary, multichannel mixes can be transferred as discrete, unencoded, multitrack masters. Track layout requirements vary by format (see “Importing Multichannel I/O Setups” on page 480 for more information).
- Consumer playback systems don’t necessarily support every format. _Downmixing_ occurs when a specific format mix has to be created from another. (A typical example of this is listening to a DVD’s 5.1 Dolby Digital soundtrack downmixed to stereo.)

To anticipate the effects of surround encode and decode, as well as potential downmixing, professional surround mixes are monitored through appropriate encoding and decoding processors. Monitor controller systems let engineers hear their mix through different speakers and configurations for reference.
**Surround Formats and Delivery Mediums**

Surround mixes are tailored for their specific delivery medium. Most often, this requires format-specific encode and decode processing.

Some delivery media on which surround formats are distributed may have additional audio constraints, which could influence your work flow in Pro Tools. Dolby Digital audio on a DVD-Video disc, for example, requires a 48 kHz sampling rate. If your Pro Tools session isn’t at 48 kHz, you must sample rate convert the audio before encoding it with Dolby Digital for DVD.

**Encoding and Decoding**

Virtually all surround formats utilize some form of encoding and decoding to make it practical to deliver, broadcast, and transfer the multiple channels of full-bandwidth audio they require.

- **Encoding** is the process necessary to make multichannel mixes portable and playable. In many cases, this involves taking the four, five, six, or more discrete channels resulting from a multichannel mix and converting them into a two-channel stream for broadcast (still a predominantly 2-channel medium).
- **Decoding** is the process needed to reproduce (or unfold) the discrete surround channels from a 2-channel delivery medium.

Both encoding and decoding, no matter how refined, represent additional processing stages applied to your mix before it reaches its ultimate destination, the audience.

For example, because the Dolby Surround algorithm depends heavily on phase relationships, there is always a significant difference in a decoded LCRS output as compared to the original LCRS mix. To account for these anomalies, engineers mixing for Dolby Surround listen through encode and decode processors for reference.

Professional mixing and mastering engineers use encoders and decoders to precisely audition the effect of the encoding and decoding process, and make any adjustments necessary.

**Surround Processing and Pro Tools**

Pro Tools requires additional software or hardware for surround encoding, decoding, and processing. For example, the Dolby Surround Tools™ plug-in lets you monitor and process completely within the Pro Tools environment.

Surround Tools and other surround processing solutions are available from Digidesign and third party manufacturers. Contact your Digidesign Dealer for more information.

**Surround Playback System Variables**

Different playback systems for surround sound introduce varying amounts and types of filtering, bass management, and other variables. These include the specifications for certain surround formats, as well as options to fine-tune a system for its particular installation.

In your own studio, you know what speakers you are listening to, what their qualities are, and what your control room sounds like. What is impossible to know, however, is what speakers are in the living room, theater, or concert hall where your mix will be heard by an audience.
**Bass Management**

Bass management is a function of the playback system. Bass management refers to a number of processes by which a playback system can control what will be heard through the Sub(woofer) and other channels. The purpose of bass management is to optimize low frequency reproduction and overall frequency response for your specific monitoring system. Bass management provides a way to tune bass response for variables, including room size and shape, the presence (or absence) of a subwoofer, and the frequency range of each speaker.

**Filtering**

In its simplest form, bass management applies high-pass filtering to the full-range speaker. Frequencies below the filter cutoff are summed with the LFE channel (if present) and then routed to the subwoofer. Different systems may offer additional bass management processes, including:

**Bass Redirection** Mutes or unmutes the low-frequency signals filtered out of the full-range channels (all signals that fall below the bass management filter cutoff frequency). This is useful when the full-range speakers are truly full-range, capable of accurately reproducing bass without distorting.

**Bass Extension** Allows the bass (however it is derived) to be routed back through the full-range speakers. Though this may seem like a contradiction, its main purpose is to let sub content emanate from all around, rather than only from the subwoofer.
Chapter 31: Pro Tools Setup for Surround

This chapter explains how to set up and configure Pro Tools sessions for multichannel mixing.

Multichannel mixing is supported on Pro Tools HD-series and MIX-series systems only. In this chapter, all references to Pro Tools refer to Pro Tools HD-series and MIX-series systems.

Before you can use Pro Tools in Surround mode:

1. Make sure the Surround Mixer plug-in is installed in your Plug-Ins folder. If it is not, it can be installed using your Pro Tools Installer CD-ROM. See your Getting Started Guide for details.

2. Make sure your audio hardware is connected to your monitor system and other equipment correctly.

3. Make sure you have configured the Pro Tools Playback Engine and Hardware Setup dialog options correctly for your system as described in your Getting Started Guide.

4. Continue reading this chapter to learn how to configure Pro Tools and your sessions for surround mode.

### Pro Tools Audio Connections for 5.1 Mixing

While all 5.1 mixing formats provide the same speaker arrangement, there are three primary standards in use for the track layout of the individual channels that comprise the 5.1-format multichannel mix.

In the following table, it is assumed that surround channels are mapped to outputs 1–6 of a Pro Tools audio interface. Use channels 7–8 to monitor a stereo mix for a stereo version, or for cue mixes and monitoring.

<table>
<thead>
<tr>
<th>Formats</th>
<th>Track Layout</th>
</tr>
</thead>
<tbody>
<tr>
<td>Film (Pro Tools default)</td>
<td>L</td>
</tr>
<tr>
<td>SMPTE/ITU for Dolby Digital (AC3) and Control</td>
<td>24</td>
</tr>
<tr>
<td>DTS with ProControl</td>
<td>L</td>
</tr>
</tbody>
</table>
To connect your audio interfaces for 5.1 format mixing and monitoring:

1. Determine the 5.1 format and track layout you want to use.
2. Connect the output channels of your audio interface to the corresponding input channels of your monitoring system according to the assignments listed in Table 5 on page 477.

If you use a Digidesign control surface, see its guide for more information.

Configuring Pro Tools for Multichannel Sessions

Configuring Pro Tools and sessions for multichannel mixing can be done in any or all of the following ways:

New Sessions

You can create a new session and choose a surround mix I/O Settings file as the default I/O Setup. (See “New Sessions and I/O Settings” on page 478.)

Remixing Sessions in Surround

By importing a surround mix I/O Settings file into the I/O Setup dialog, multichannel paths can be made available in any stereo (or other format) session. You can then reassign track routing from the original stereo paths to multichannel paths. Inactive and active paths simplify reassignment. (See “Importing Multichannel I/O Setups” on page 480.)

Custom Paths

You can customize and redefine existing paths in the I/O Setup dialog. For more information, see “Custom Multichannel Paths” on page 480.

Importing Session Data

By using the Import Session Data command (File > Import Session Data), you can import tracks and media from other sessions plus their associated paths and track assignments. After importing session data, you can use the I/O Setup dialog to configure main and sub-paths for the requirements of the session. For more information see “Importing Tracks” on page 108.

New Sessions and I/O Settings

When you create a new session, you can specify a surround format that you want to use as your I/O Setup. Default path configurations are provided as I/O Settings files, for stereo and surround mixing.

Once you create the new session, you can create and import tracks, import audio, and assign signal routing to set up your mix.
To create a new session for multichannel mixing:

2. Select one of the available 5.1 settings from the Default I/O Settings menu.

Surround Mix Settings Files

The surround mix I/O Settings files provide output and bus paths for three specific track layout standards. (See also “Default Input and Insert Paths with 5.1 Settings” on page 479.)

Settings Files and Track Layouts

<table>
<thead>
<tr>
<th>5.1 Settings</th>
<th>Track Layout</th>
</tr>
</thead>
<tbody>
<tr>
<td>Film (Pro Tools Standard)</td>
<td>L C R Ls Rs LFE</td>
</tr>
<tr>
<td>SMPTE/ITU (Control</td>
<td>24 Monitoring)</td>
</tr>
<tr>
<td>DTS (ProControl Monitoring)</td>
<td>L R Ls Rs C LFE</td>
</tr>
</tbody>
</table>

All three 5.1 format settings files provide the following default output and bus paths:

Default 5.1 Output Paths

- One 5.1 main output path, with sub-paths for center, left/right, LCR, and 5.0 (no LFE).
- Also, one stereo main path with two mono sub-paths.

Default 5.1 Bus Paths

- One 5.1 main bus path, with sub-paths for 5.0 (no LFE), left/right (stereo), LCR, and center (mono).
- Also, one stereo main path with two mono sub-paths.

Default Input and Insert Paths with 5.1 Settings

The 5.1 Mix settings files provide default stereo main and sub-paths for inputs and inserts. If you need multichannel input paths or inserts, you can create them in the I/O Setup dialog (see “Custom Multichannel Paths” on page 480).
Importing Multichannel I/O Setups

The I/O Setup dialog can import and export settings files. Importing I/O Setup settings files is useful when you want to remix a stereo session in surround. You can also use this feature to prepare a session for transfer to a different Pro Tools system, or to simply save and exchange I/O Settings.

To import a multichannel I/O Setup settings file:
1. Choose Setups > I/O Setup.
2. Click Import Settings.
3. Select the settings file to import.

If the current session has existing path definitions that don’t match those in the imported settings file, Pro Tools asks whether you want to delete the existing paths or retain them and add the imported settings to your session.

- Click No to add new paths to your current I/O Setup configuration.
- Click Yes to replace your current I/O Setup configuration with the imported settings.

Exporting I/O Settings

Exporting I/O Setup settings files lets you build a library of multichannel setups for different projects.

To export an I/O Setup settings file:
1. Choose Setups > I/O Setup.
2. Click Export Settings.
3. Name and Save your current I/O Settings.

Custom Multichannel Paths

The I/O Setup dialog lets you create and customize signal paths for any supported multichannel mixing format.

Multichannel paths and sub-paths are mapped to inputs, outputs or internal busses in the Channel Grid. When you select a preset 5.1 I/O Settings file, default layout for the corresponding multichannel format paths you create will match the selected format’s track layout.

In addition, the I/O Setup dialog, like the Main page of the Hardware Setup dialog, provides controls for routing the physical ports on your I/O peripheral to Pro Tools input and output ports.

When creating 5.1 format paths, you can specify the default track layout. See “Default Path Order for 5.1 Tracks” on page 482.

Remapping Channels

The I/O Setup dialog and its Channel Grid also let you remap channels. This is especially useful to route channels within a multichannel path, without having to repatch your audio interfaces.
You can remap paths to any required configuration, limited only by your systems resources, and the I/O Setup dialog requirements for channel overlapping and naming (see “Valid Paths and Requirements” on page 75 for more information).

See also “Example Paths and Signal Routing for a Surround Mix” on page 491.

Example LCRS Setup

The following example shows one possible way to configure the I/O Setup dialog to mix in 4-channel LCRS format, with a 96 I/O.

Example LCRS output main and sub-paths

For additional I/O Setup information, see “Creating and Editing Paths” on page 71.

To define an LCRS path:

1. Choose Setups > I/O Setup > Output.
2. Click New Path.
3. Select LCRS from the Path Format Selector.
4. Name the path LCRS.
5. In the Channel Grid, click in the box below the first (left-most) audio interface channel for the path. Pro Tools automatically fills up the adjacent units to the right. If you click in the LCRS row under channel 1, the LCRS path will be mapped across channels 1–4.
6. Select the new LCRS path and click New Sub-Path.
7. Name the new path LCR, and select LCR as the Path format. Click in channel 1 in the LCR row to map the path.
8. Select the LCRS path, click New Sub-Path and create a stereo sub-path for front Left and front Right.
9. Select the LCRS path, click New Sub-Path and create mono sub-paths for the Center and Surround channels.

5.1 Tracks, Formats, Mapping, and Metering

Path definitions in I/O Setup determine how audio is routed through, and metered on, your audio interfaces.

Pro Tools internal (on-screen) metering of 5.1 format paths always follows the Film track layout:

L C R Ls Rs LFE

Pro Tools track layout of 5.1 format audio tracks in the Edit window also conforms to the Film layout (arranged top to bottom). See the illustration “5.1 Track Layouts, Routing, and Metering” on page 482.

In the I/O Setup dialog, you can route these signals out of your audio interfaces according to any track layout (DTS, SMPTE/ITU, or other).

To re-map channels in a path:

- Click and drag a channel to a new valid location in the Grid. Other channel assignments will move (shuffle) to accommodate dragged channels.
Default Selectors in I/O Setup

The Output tab of the I/O Setup dialog provides the following default settings for multichannel sessions:

- **Meter** Selects the path that will be shown in Digidesign control surface output meters. See “5.1 Tracks, Formats, Mapping, and Metering” on page 481 for more information.

- **Audition** Selects the monitoring path for previewing audio in the Regions List and Import Audio dialogs. Only outputs on your primary interface can be used as your Audition path.

- **Default Output** Selects the default output path for all new tracks, for each supported track format.

- **Default Path Order** Selects the default track layout (or, path order) for new 5.1 format (six-channel) paths.

**Default Path Order for 5.1 Tracks**

You can specify the default track layout for all new 5.1 format paths you create.

To choose a new default Pro Tools 5.1-format path order (track layout):

1. Choose Setup > I/O Setup.
2. Use the Default Path Order menu and submenus to choose the track layout you want.

5.1 Track Layouts, Routing, and Metering

<table>
<thead>
<tr>
<th>5.1 Format</th>
<th>Tracks</th>
<th>Track Meters</th>
<th>Channel Map in I/O Setup</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Film</strong> (Pro Tools Standard) L C R Ls Rs LFE</td>
<td>same</td>
<td>same</td>
<td>same</td>
</tr>
<tr>
<td><strong>SMPTE/ITU</strong> (Control 24 Monitoring) L R C LFE Ls Rs</td>
<td>same (top to bottom)</td>
<td>same (left to right)</td>
<td></td>
</tr>
<tr>
<td><strong>DTS</strong> (ProControl Monitoring) L R Ls Rs C LFE</td>
<td>same</td>
<td>same</td>
<td></td>
</tr>
</tbody>
</table>

*Figure 37. Track layout of different 5.1 formats*
Chapter 32: Multichannel Tracks and Signal Routing

Surround sessions typically include a combination of mono, stereo, and multichannel audio tracks, Auxiliary Inputs, and Master Faders, buses and inserts.

Once the appropriate I/O Setup has been imported or configured, any audio track can be mixed in multichannel for surround using Pro Tools mixing features.

Multichannel I/O and signal routing is determined by the paths defined in the I/O Setup dialog.

Multichannel Quickstart

The following is an overview of how to get started mixing in multichannel for surround in Pro Tools.

To mix in multichannel:

1. Open any stereo Pro Tools session to remix it in surround. (You can also create new, empty surround sessions. See “New Sessions and I/O Settings” on page 478.)

2. Configure the I/O Setup dialog with multichannel inputs, outputs, busses, and inserts, as needed. (See “Configuring Pro Tools for Multichannel Sessions” on page 478.)

3. Create new tracks, and assign track outputs and sends to your multichannel paths. Configure signal routing as needed for submixing, bussing, processing, and monitoring. For tracks that do not need to be panned in 360°, place them in the mix using sub-paths and signal routing. (See “Multichannel Signal Routing” on page 486.)

4. Pan in surround using the multichannel Track and Send windows. (Mixing and panning for surround is explained in Chapter 33, “Surround Panning and Mixing.”)

Multichannel Audio Tracks

Multichannel audio tracks contain multiple individual signals for each signal in the track (one for the left, one for the right, one for center, and so on).

Multichannel audio tracks can be:

- Recorded directly into Pro Tools, using multiple microphones or microphone arrays, or routed to appropriate multichannel Pro Tools Input paths.
- Imported from other Pro Tools sessions.
- Edited, processed, and mixed in combination with mono and stereo tracks.
5.1 format audio files and tracks conform to the Film track layout standard. Regardless of path mapping in the I/O Setup dialog, all 5.1 format audio tracks and meters follow the Film standard track layout:

L C R Ls Rs LFE

Multichannel audio tracks are not required to mix in multichannel formats. Mono, stereo, and all supported track formats can be mixed using Pro Tools track outputs and sends. See “Multichannel Signal Routing” on page 486.

Placing Audio in Multichannel Tracks

You can drag audio files and regions from the Audio Regions List, or from other tracks, to place them in multichannel audio tracks.

To do so, the number of channels being dragged must match the destination track format. For example, you can only drag a stereo pair or two mono regions onto a stereo audio track. Similarly, you can only place audio into an LCR track when you have selected three regions. With 5.1 tracks, you must select six mono files or regions.

When dragged into a multichannel track, audio files are placed from top to bottom in the exact order that they appear in the Regions List or playlist from which they came. For this reason, arrange them in the appropriate order in the Regions List before dragging them. (For a 5.1-format track, for example, arrange the tracks so that they correspond to L,C,R, Ls, Rs, and LFE.)

Solo, Mute, and Gain in Multichannel Tracks and Paths

Stereo and multichannel tracks consist of multiple audio signals, linked together. By default, multichannel tracks are linked and are controlled by a single channel fader, solo and mute switch.

For discrete control of signals, multichannel tracks can be converted into individual mono tracks. For discrete level and phase adjustment, you can insert and unlink a multi-mono Trim plug-in. Both of these techniques are explained below.

Once converted to mono, multichannel tracks cannot be relinked into their original multichannel format. However, a multichannel track can be reassembled by dragging the corresponding number of mono files into a multichannel track, although some automation data will be lost. Or, as an alternative, record the submix of the mono tracks to disk on a multichannel track.

To convert a multichannel track into discrete mono tracks:

1. Select the multichannel track.
2. Choose File > Split Selected Tracks to Mono.
To have discrete control of gain on individual channels of a multichannel track:

1. Insert a multi-mono Trim plug-in on the multichannel track.
2. Unlink the Trim plug-in by clicking the Link icon so that it is unlit.
3. Use the Channel Selector to display the controls for the desired channel, and adjust the gain.

See “Linking and Unlinking Controls on Multi-Mono Plug-Ins” on page 487 for more information.

Track and Output Formats

When you create new tracks, you specify mono, stereo, or a supported multichannel format for the new tracks.

In the Mix and Edit windows, the track format of a track’s output is always visible by the number of track meters contained in its fader strip (a single meter for mono tracks, a pair for stereo tracks, and so on).

Assigning track output determines the format of that output. For example, a mono track always has a single track meter, even when assigned to a stereo output path. If that same mono track is assigned to a 5.1 output path, its output will be split among those six output channels, depending on the position of its panner.

Changing Format

Changing the output format for a given track has several effects:

- The panner that appears in the track will change to reflect the new output format.
- It may be necessary for one or more pan related automation playlists to be created or deleted.

Because changing the output format has these effects, a warning dialog appears whenever you change the output format of a track to a format of fewer channels. Specifically, this will occur whenever automation playlists will have to be deleted.

Multiple Output Assignments and Track Format

When a track is assigned to more than one path of differing formats, the main output for that track will match the format of the assigned path with the greatest number of channels.

Multiple Outputs and Automation Playlists

When a track has multiple output assignments (as configured in the Hardware Setup dialog or I/O Setup dialog), Pro Tools sorts panning data appropriately for each assigned path. For example, if you assign a mono track to a stereo path and a 5.1 path simultaneously, that track will have a 5.1 panner in the Mix or Edit window. When you pan the track, Pro Tools interprets the 5.1 panning moves into stereo panning moves (by ignoring any front-to-rear moves, in this example).

This provides a type of parallel mixing. You can create a variety of mixes of differing formats all at the same time by routing your elements to multiple paths.

Command+Control-click (Macintosh) or Control-Start Key-click (Windows) any control in an Output window to show its automation playlist in the Edit window and view any pan automation.
Multichannel Signal Routing

To mix in a multichannel format, tracks are assigned to multichannel paths.

Tracks can be mixed in surround using the following two methods:

- By setting a track main output to a multichannel path.
- By assigning a multichannel send to route audio to a multichannel path.

See “Multichannel Sends” on page 486 for more information.

Multichannel Sends

Mono, stereo and all other track formats let you assign one or more multichannel sends. This provides a multichannel panner in the Sends View. Sends are also useful to bus tracks for multichannel plug-in processing.

The following figure shows a mono audio track with a 6-channel send (Sends View Shows > Send A View).

Multichannel Track Outputs

Tracks are routed to output and bus paths using the track Output Selector. This assigns the main track output. Additional output assignments can be added by Control-clicking (Macintosh) or Start Key-clicking (Windows) the Selector and assigning another path. This provides a multichannel panner and meter in the Mix and Edit window I/O View. (See also “Multichannel Sends” on page 486 for details.)
Pro Tools bussing and submixing features are available for all channel formats, from mono/stereo through 8-channel. For examples of multichannel monitoring, effects processing, and bussing, see “Mixing with Paths and Sub-Paths” on page 489. For mono and stereo mix examples, see Chapter 26, “Basic Mixing.”

**Multichannel Auxiliary Inputs and Master Faders**

A multichannel Auxiliary Input or Master Fader is used as a return for the multichannel bus. Sends are useful when you need to create an additional, independent mix simultaneously (perhaps of a distinct format), requiring dedicated fader, mute, solo, and automation controls.

You can assign Master Faders to main and sub-paths. Main paths must match the format of the Master Fader, and only one Master Fader can be active and assigned to any single (active) main or sub-path. A Master Fader cannot be assigned to a sub-path if its associated main path is already assigned on another Master Fader. See “Master Faders” on page 382.

**Mono, Multi-Mono and Multichannel Plug-Ins**

Plug-ins can be used in mono, multi-mono, or multichannel formats.

<table>
<thead>
<tr>
<th>Insert Type</th>
<th>Format</th>
</tr>
</thead>
<tbody>
<tr>
<td>multi-channel TDM plug-in</td>
<td>multi-channel RTAS plug-in</td>
</tr>
<tr>
<td>multi-mono TDM plug-in</td>
<td>multi-mono RTAS plug-in</td>
</tr>
<tr>
<td>i/o</td>
<td></td>
</tr>
</tbody>
</table>

*Plug-in formats*

For information about mono, stereo, and mono-in/stereo-out plug-ins, see Chapter 27, “Plug-In and Hardware Inserts.”

**Multi-Mono Plug-Ins**

Are designed for use on greater-than-stereo multichannel tracks. Multi-mono plug-ins are useful, or required, in the following situations:

- When a desired plug-in does not involve multichannel correlated processing (for example, when applying EQ to select sides of a multichannel signal).
- You need to adjust signals within the multichannel track independently.
- When a plug-in does not support multichannel formats.

When a multi-mono plug-in is first inserted on a multichannel track, the plug-in controls are linked. You can unlink them for independent adjustment. See “Linking and Unlinking Controls on Multi-Mono Plug-Ins” on page 487 for more information.

Multi-mono plug-ins can also be inserted on stereo tracks, to apply unlinked plug-ins on the left and right channels.

**Multichannel Plug-Ins**

Are designed for use on stereo and multichannel tracks that require correlated processing, including stereo and multichannel limiting, compression, and similar effects.

**Linking and Unlinking Controls on Multi-Mono Plug-Ins**

When a multi-mono plug-in is used on a multichannel track of more than two channels, the controls are normally linked. Adjusting the Gain parameter on one channel, for example, will adjust it for all channels.

If necessary, you can unlink plug-in controls on specific channels of a track and edit them independently. You can also selectively link the controls of specific channels.
For example, to apply equal filter cutoffs to the Ls and Rs (surround) channels in a 5.1 mix, you could link enable just those channels in an unlinked, multi-mono EQ plug-in. Adjusting the controls in the Plug-In window for either channel (Ls or Rs) adjusts the other, linked channel as well.

To open a Plug-In window for all channels of a multi-mono plug-in:
- Option-click (Macintosh) or Alt-click (Windows) the Channel Selector.

To link the controls of specific channels:
1. Deselect the Master Link button if it is not already deselected.
2. Click the Link Enable buttons for the channels whose controls you want to link.

Paths in Surround Mixes

Because Pro Tools provides a flexible routing and submixing environment, you can maximize your system’s available resources by first identifying the elements that you want to pan dynamically and those that can be placed in certain channels only. (See “Mixing with Paths and Sub-Paths” on page 489 for an explanation of this concept.)

Once you have identified these elements in your session, you can use a combination of main and sub-path assignments, and multichannel panning. Figure 38 on page 490 shows an example session.

Channel Selector

Accesses a specific channel within a multichannel track for plug-in parameter editing. This menu appears only on multi-mono plug-ins inserted on tracks with more than two channels.

Master Link Button

When enabled, links the parameter controls on all channels of a multi-mono plug-in so that they can be adjusted in tandem.

Link Enable Buttons

Let you selectively link the parameter controls of specific channels of a multi-mono plug-in. Each square represents a speaker channel. The Master Link button must be disabled to use the Link Enable buttons.

To unlink controls on a multi-mono plug-in:
- Deselect the Master Link button. It is lit when linked, unlit when unlinked.

To access controls for a specific channel:
- Select the desired channel from the Channel Selector.

The Trim plug-in is explained in the Digi-Rack Plug-Ins Guide.
Mixing with Paths and Sub-Paths

It is rare that every track needs to be “flown” (actively panned in between more than a pair of speakers). In most situations, certain elements are placed in certain speakers and remain there, providing the foundation for a mix.

Figure 38 on page 490 illustrates an example of how panning and signal routing can be combined in a multichannel mix. The following sections show you how to organize your session and signal routing to maximize the available resources.

See “Extending Stereo Mixing Conventions to Surround Mixing” on page 490 for related information.

When to Assign Multichannel Outputs

■ Assign 5.1 paths only to those tracks that need to be panned to all six channels.

For example, a sound effects track with a jet fly-over should be assigned a 5.1 path to be able to fly the sound from front-to-back. In a music mix, fly a solo instrument or make a synth pad swirl around the room as a special effect.

Elements that need to be heard in all speakers simultaneously can also be assigned to the multichannel output, whether or not they need active panning in the sound field.

When to Use Sub-Paths

■ To help simplify large sessions, try to use sub-paths to route static (or, stationary) elements directly to the output channel or channels.

For example, film dialog is often mixed to the center channel to anchor this essential sound element to the visual element (the picture). Instead of assigning a six-channel panner to dialog tracks and panning it to the center channel only, you can route the dialog track’s main output to a mono (Center) sub-path. Doing so may be unavoidable in some sessions, as in scenes in which every sound needs to fly or move in the 360° sound field. This is more likely to be the exception, however, since many elements of a mix need not move between speakers.
Extending Stereo Mixing Conventions to Surround Mixing

Stereo mixing sets the precedent for active and static panning, and surround mixing can benefit from the same basic principles.

Panning a sound back-and-forth between the left and right speakers is best used as a special effect. In a typical music mix, the basic tracks are placed in the stereo sound field and remain there.

Surround mixes can become incoherent if too many elements are continuously moving. For special effects, some tracks can be panned dynamically, bouncing between speakers or sweeping from one side to the other.

Figure 38. Using signal routing and sub-paths to mix in surround
Example Paths and Signal Routing for a Surround Mix

The examples that follow show how Auxiliary Inputs, Master Faders, and other Pro Tools signal routing features can be used for stem mixes, submixes, and similar project needs.

In these examples, music and effects are being mixed for a trailer, in 5.1 surround. Separate stem mixes (for music and for effects) are to be mastered to 8-track MDM.

Example Multichannel Paths

Signal routing is the key element in any Pro Tools surround session. Signal routing is configured and defined in the I/O Setup dialog.

Example Output Paths

The following diagram shows output paths defined in the I/O Setup dialog of an example session. This example session is shown on a Pro Tools HD system with one 96 I/O audio interface.

Example Bus Paths

The following diagram shows example bus paths.

Sub-paths have been defined for Mix, Music, and FX main output paths.

Additional stereo output paths, with mono sub-paths, have also been defined for the remaining channels.

Example Sub-Paths

Sub-paths let you route to selective channels within the multichannel surround output. In the pictured example, the FX bus has several sub-paths that show this.

5.0 Sub-Path

The 5.0 FX bus is a 5-channel subpath. Use this type of sub-path routing to conserve mixing resources with tracks you want to keep out of the LFE channel.

LFE Path

A custom LFE sub-path has been added to provide a discrete mono path to the LFE channel.
**Signal Routing Examples**

The following show how main and sub-paths can be used, using an example session consisting of a 5.1 main mix, with music and effects stems (or submixes).

The first example shows a routing configuration for an effects submix.

Some tracks are routed to stereo sub-paths, while others are assigned to mono, LCR, or other sub-paths. Two tracks (one stereo, one mono) are assigned to multichannel busses for surround panning. A 5.1 Auxiliary Input assigned to the FX main bus path serves as a submixer.

Music tracks might be routed similar to the following example.

Most of the music tracks in this example are routed to the front left/right channels, using a stereo sub-path. A 5.1 Auxiliary Input controls the bus and stem output.

**Main Stems Example**

The two Auxiliary Input channels can be multi-assigned to additional 5.1 format paths for a main mix.

Multiple output assignments make it possible to configure a number of multi-format mixes. For example, you can assign an additional stereo output to tracks and create a stereo mix at the same time as a 5.1 mix. For more information, see “Multiple Output Assignments” on page 387.
LFE Examples

LFE tracks and other audio can contribute to the LFE output in two ways:

- Using the LFE slider in Output windows. This LFE signal is post-fader.
- Or
- Using a custom sub-path to route channels discretely.

The following shows a channel Output window, sending and metering to the LFE channel.

Discrete LFE routing

For instructions on how to create a sub-path, see “Custom Multichannel Paths” on page 480.

LFE and Filtering

Pro Tools applies no filtering to LFE signals. Some delivery requirements may require filtering for the LFE track (such as the Dolby requirement of 120 Hz). See “Mixing Formats and Surround Formats” on page 467 for more information.

LFE contribution from a stereo output

Using the LFE fader, you can add any amount of any multichannel path to the overall LFE output. In the above example, the track’s Center percentage has been turned off, and the LFE fader has been raised to route it to the LFE channel.

The next diagram shows how a “traditional” LFE track can be routed to only the LFE channel. This example uses a custom-defined LFE sub-path to the FX main bus path.
This chapter explains how to pan and mix in surround with Pro Tools.

Before you can pan a track in surround, it must be assigned to an appropriate multichannel output or bus path.

The I/O Setup dialog defines the bussing and output architecture of the Pro Tools multichannel surround mixer. If you have not already done so, it is recommended that you become familiar with main and sub-paths and the I/O Setup dialog before starting multichannel Pro Tools projects.

See Chapter 31, “Pro Tools Setup for Surround” for more information on multichannel configurations and I/O Setup options. For multichannel signal routing, see Chapter 32, “Multichannel Tracks and Signal Routing.”

### Introduction to Pro Tools Surround Panning

There are four different track panning methods available:

- In the Edit window, using the reduced-height Panner Grid in the I/O View
- In the Mix window, using the reduced-height Panner Grid
- In the Output window, using the full-size Panner Grid
- Through pan automation editing

Control surfaces provide additional panning options. Refer to the documentation for your control surface for more information.

### Mix and Edit Window Panner Grids

In the Mix and Edit window, multichannel Panner Grids are displayed on tracks that have multichannel track or send output assignments.
To pan from the Mix or Edit window:

1. For Pro Tools 5.x, make sure I/O View is being shown for the Mix or Edit windows (Display > Mix/Edit Window Shows > I/O View).

2. Begin playback.

3. Click and drag on the appropriate multichannel track's Panner Grid in the Mix or Edit windows.

The green pan cursor follows your movements as long as you hold down the mouse button. Movements are scaled so that, once you click to "grab" the pan cursor, you do not need to limit your movements to the small Track Grid area.

Pan Cursor Color while Automating

The pan cursor is green when the track is in Automation Read mode, red in an Automation Write mode, and yellow in Trim mode.

Output windows provide additional features and controls (and a much larger Grid). For details, see "Output Window" on page 496.

Output Window

Output windows provide panning controls for tracks of all mix formats. Some of the features of Output windows include:

- X/Y (joystick-style) panning
- 3-Knob panning
- Full Divergence and Center Percentage control
- LFE feed
- Multichannel meters
- Pro Tools Target window support

This section describes the basic techniques for opening and arranging Output windows. Panning controls and instructions begin in “Surround Panner Controls” on page 498.

Multichannel Panners

Multichannel panners are provided for each multichannel mixing format (from 3-channel LCR thru 8-channel 7.1). See “Surround Panner Controls” on page 498 for more information.

Multiple panners can be opened simultaneously, or a single window can display the current panner.
To open an Output window:

- Click the Output icon in the track in the Mix or Edit window (I/O View).

For instructions on managing multiple Output windows, see “Output Windows for Tracks and Sends” on page 393.

### Standard Controls

All Output windows provide standard Pro Tools controls for routing, path assignment and other track features. These controls are located at the top of all Output, Send, Insert, and Plug-In windows. Some controls are specific to the type of window.

- **Show meters**
- **Track Selector**
- **Path Selector**
- **Target icon**
- **Automation Safe**

For details on these standard features, see “Standard Selector Controls in Output Windows” on page 396.

### Track Fader, Solo, Mute, and Auto

All Output windows provide track volume and mute controls. You can adjust and automate track volume, or mute, directly using these controls. The larger fader and mute button are equivalent to those in the Pro Tools Mix window.
**Surround Panner Controls**

When assigned to tracks or paths with four or more channels, the Output window provides an X/Y Grid for surround panning. The speakers associated with the panner’s multichannel format are displayed in their relative positions outside the Panner Grid.

This section identifies all the controls and features found in Pro Tools multichannel panners.

*Figure 39. Output window with a 5.1-format multichannel panner*
The X/Y Grid and Pan Cursor

The X/Y Grid is where multichannel panning information is input and displayed. You can also input pan information using 3-Knob mode, or by entering numeric values in the Position data fields. You can also edit pan automation graphically in the Edit window.

Multichannel panners default to X/Y mode. In X/Y mode, the track’s current pan position is represented by a green dot. This dot is the pan cursor, and its color indicates track automation status using standard Pro Tools colors:

**Green** The track is in Auto Read mode.

**Red** The track is in Automation Write, Touch or Latch mode.

**Yellow** The track is in Automation Trim or Auto Off mode.

Panning Mode Buttons

Directly below the X/Y Grid are the Panning Mode buttons.

_X/Y Mode, Divergence Editing, and 3-Knob Mode buttons_

These switches provide access to advanced surround mixing features, and are explained in “Panning Modes” on page 500.

Position Controls

The Position controls include three rotary knobs and their text fields.

**Position controls**

**Front** Displays and controls the current front X-axis position of the panner.

**Rear** Displays and controls the current rear X-axis position of the panner. In default X/Y Panning mode, Rear is linked to Front position and cannot be controlled independently.

**F/R (Front/Rear)** Displays and controls the current Y-axis position of the panner.

**Center %** Controls how much of the signal is routed to the center speaker. This lets you mix a track to the front with a phantom center (0% Center value) or to three-channel (LCR) when panning front.
Divergence Controls
Divergence determines the width of the panned signal with respect to neighboring speakers. (See “Divergence” on page 473 for more information.)

Front, Rear, and F/R Divergence
Provide separate, automatable divergence control over front speakers, rear speakers, and between front/rear, respectively. See “Divergence” on page 504 for more information.

For examples of how divergence settings affect output panning, see “Divergence and Center Percentage” on page 503.

LFE Fader
The LFE fader is only available in “.1” surround formats (5.1, 6.1, and 7.1).

The LFE fader determines how much of the current track’s signal will be routed to the LFE channel. LFE faders in Track and Send windows can follow groups. The Pro Tools LFE channel is always full-bandwidth. For more information on how to use the LFE fader, see “LFE Faders in Multichannel Panners” on page 503.

Panning Modes
Pro Tools supports X/Y and 3-Knob Panning modes. Both can be automated.

X/Y Mode
Joystick-style panning by dragging the pan cursor within the X/Y Speaker Grid.

3-Knob Mode
Point-to-point panning, between pairs of speakers. See “3-Knob Panning” on page 502 for more information.

X/Y Panning
To pan in X/Y mode:
1. Click the X/Y mode icon.
Drag the pan cursor, or click anywhere in the Grid and drag to pan the track. The location of the pan cursor determines the pan position of the signal. For example, to pan something to the left rear speaker, move the pan cursor to the lower-left corner of the Grid.

It is not necessary to click exactly on the pan cursor. Clicking anywhere in the Grid will move the pan cursor relative to where you click or take over with a hardware panner. Panning does not jump to the click position.

Grid Options and Shortcuts

**Fine-adjust Mode** Hold down the Command (Macintosh) or Control (Windows) key for fine adjustment of all Panner controls.

**Constraining to X or Y Movement** Shift-drag the pan cursor dot to constrain its movement to the X or Y direction.

**Reset to Default** Option-click (Macintosh) or Alt-click (Windows) in the Panner Grid to reset all parameters to their default position.

**Snap To a Speaker in the Grid** Click on a speaker icon to force the panner to that speaker location. Location of one of the valid speakers, Click on a speaker icon.

**Display Automation in Edit Window** Command-Control-click (Macintosh) or Control+Start Key-click (Windows) on a parameter to display that parameter's playlist in the Edit window.

All pan parameters can be automated, including pan position and divergence. See Chapter 28, “Automation” for details.
3-Knob Panning

Pro Tools provides 3-Knob mode as an additional way to input pan moves.

3-Knob mode lets you:

- Pan in straight lines, moving the pan cursor using the Position rotary knobs with full movement of front, rear, and front-rear position.
- Pan discretely between pairs of speakers.

3-Knob mode lets you pan discretely between speakers. For example, when panning front-left to rear-right in 3-Knob mode, audio will be heard from just those two speakers (assuming full divergence is in effect).

By comparison, in X/Y mode a diagonal pan may result in audio being heard in some or all channels.

The difference is that 3-Knob mode pans discretely between the front and rear position of the panning trajectory, while X/Y mode panning takes place in the full 360° Panning Grid. Divergence and Center Percentage are variable in both Panning modes.

To enable 3-Knob Panning mode:

- Click the 3-Knob mode icon.

The panner trajectory line appears across the Grid, extending from the front (X-axis) to the rear (Y-axis).

To pan in 3-Knob mode:

1. Adjust the Front and Rear Position knobs to set the trajectory line.
2. Rotate the Front/Rear Position knob to pan along the trajectory. The Pan Cursor is constrained to the white trajectory line.
To change the 3-Knob trajectory angles:
■ Drag either endpoint (Front or Rear) of the trajectory line.
  – or –
■ Adjust the Front or Rear Position controls.

To change the current trajectory position (left-to-right) and retain its current angles:
■ Drag the trajectory line (not its endpoints) to a new position.

**LFE Faders in Multichannel Panners**

The LFE fader controls how much of the track is sent to LFE. LFE faders are only available when a track is assigned to a path whose format supports LFE (5.1, 6.1, or 7.1).

**To mix to the LFE channel:**
■ Adjust the LFE fader in any “.1” surround format Output window.

*For general information about LFE, sub channels, and related topics, see Chapter 30, “Surround Concepts.”*

**LFE Enable**

Some multichannel plug-ins, including the Di- giRack multichannel Compressor, provide LFE Enable. This lets you enable or bypass processing of the LFE channel if present.

![LFE Enable in multichannel compressor](image)

**To process the LFE channel in a multichannel plug-in:**
■ Click to enable LFE Enable in supporting multichannel plug-ins. LFE Enable is highlighted when LFE processing is enabled, and unhighlighted when LFE processing is bypassed.

**Divergence and Center Percentage**

The Divergence and Center Percentage controls range from 0 to 100, and can be automated. They are especially useful for ensuring audibility and coverage in large venues, and to increase clarity of voices.

**Front Divergence** Controls divergence between front speakers (X-axis only).

**Rear Divergence** Controls divergence between the rear speakers (X-axis only).

**Front/Rear Divergence** Controls divergence between front and rear (the Y-axis).

**Center % (Percentage)** Determines whether there is a discrete center image, a completely phantom center image, or a variable amount in between.
**Divergence**

In the Panner Grid, the current divergence values are displayed using a purple outline.

By default, Pro Tools surround panners are 100% or fully divergent, meaning that a signal that is panned completely to one speaker will only be audible in that speaker.

Lower divergence settings result in a progressively wider source signal. When Divergence is less than 100%, tracks will be routed to neighboring speakers to some degree, even when the pan cursor is positioned next to a single speaker.

**To adjust divergence:**

- Adjust the Front, Rear, and Front/Rear Divergence controls as necessary.

**To adjust divergence graphically:**

1. Click the Divergence icon.
2. Drag in the Grid to resize the divergence boundaries.

---

*Full divergence for discrete panning to front, left (meters show signal only in front, left)*

*Front Divergence at 0% for widest panning (note meters showing signal in all three front speakers)*
Center % (Percentage)

Center Percentage controls whether there is a discrete center channel for the track or a phantom center channel.

Center Percentage Example

In film and video production, the center channel often contains dialog. To enhance the clarity of dialog, it is often beneficial to keep elements such as music out of the center speaker. By reducing the Center Percentage on music tracks, music panned to the front of the soundfield can be panned to only the left and right speakers, forcing them to have a variable phantom center image.

To adjust Center Percentage:

- Adjust the Center Percentage knob as appropriate.

As you reduce the Center Percentage value, the center speaker icon at the top of the Grid becomes less visible. At 0, the center speaker icon is completely invisible, reflecting the setting for fully phantom center.

Pan Playlists and Automation

Multichannel panners have an automation playlists for each position and divergence control.

Panning Does Not Follow Groups

Unlike mute and volume breakpoint editing, pan automation does not follow Edit Groups by default. To force pan automation editing to follow groups, you can hold down the Control key (Macintosh) or Start Key (Windows) while editing automation breakpoints on a member track. This feature applies to all seven types of pan controls (front, rear, and front/rear pan position, front divergence, rear divergence, front/rear divergence, and center percentage).
**SurroundScope Metering Plug-In**

The SurroundScope Metering plug-in provides a 360° meter for multichannel mixing. It provides a method of metering multichannel paths, and is available in all multichannel formats.

**5.1 Format Track Layouts**

All 5.1-format meters (including those displayed in the SurroundScope meter, on tracks, and in Output windows and their Meter Views) are always arranged in the following order:

L C R Ls Rs LFE

For a complete explanation of Pro Tools metering, see “5.1 Tracks, Formats, Mapping, and Metering” on page 481.

To use the SurroundScope Metering Plug-In:

- On a multichannel Master Fader, click an Insert button and select the SurroundScope multichannel Meter plug-in.

SurroundScope has no adjustable parameters, but displays output levels in both a 360° Grid, and in traditional LED meters.

Refer to the Digidesign Plug-Ins Guide, for details on SurroundScope.
Part VIII: Synchronization
Chapter 34: Synchronization Concepts

Since time code and synchronization are complex topics, this section is designed to give you a basic understanding of synchronization as it relates to Pro Tools.

If you are using a device that sends or receives time code, such as a video tape recorder, refer to that device’s documentation for information on how it generates or receives time code and how to configure its options.

Synchronization Requirements

Synchronization requirements and support vary among different Pro Tools hardware systems. This guide notes whenever a feature requires a synchronization peripheral such as a Digidesign SYNC I/O or USD, or equivalent. In this guide, references to the SYNC I/O also include the USD (differences between the SYNC I/O and USD are noted where applicable). See the guides for these peripherals for details on their installation and configuration.

We strongly recommend that you research what your synchronization requirements are. For example, if you are using Pro Tools to accomplish audio post production work for video, consult with your video engineer or editor to determine what time code format will be used. Also, there may be additional time code issues that affect how you use synchronization. Your Digidesign dealer may also be able to offer suggestions about working with synchronization in your studio.

Synchronization Peripherals

Synchronization peripherals include a wide variety of devices, ranging from MTC-capable MIDI interfaces at the simplest, to high precision time code synchronizers capable of handling many professional time code and clock standards used in the music, television, and film industries.

Though many devices are capable of providing synchronization, only the Digidesign SYNC I/O and USD peripherals deliver frame-edge accuracy when synchronizing Pro Tools TDM systems with one or more machines.

Aspects of Synchronization

Synchronization in a digital audio workstation has two concepts that need to be independently considered:

- “Where are we?” This is called the positional reference.
- “How fast are we going?” This is called the clock reference.
To synchronize Pro Tools to another device (such as a tape machine or VTR) accurately over an extended period of time, Pro Tools needs to know where the device is and at what speed it’s running. Some peripherals can provide only one of these references; for example, a black burst generator provides only a clock reference. Some peripherals, like Digidesign’s SYNC I/O, can provide both.

### Synchronizing Pro Tools

While most systems only require time code to be able to perform basic SMPTE Trigger synchronization, Pro Tools TDM systems require a clock reference, in addition to time code, to maintain correct synchronization. In addition, transfers (recording) between digital devices must be performed to a resolved clock source.

You can resolve Pro Tools to an external clock reference without locking it to a positional reference. For example, you can use any HD-series audio interface to resolve the Pro Tools sample clock to an incoming digital signal (S/PDIF, or word clock, for example) without synchronizing Pro Tools to external time code.

In the following example, Pro Tools uses time code for positional information, and a clock reference to maintain synchronization. Pro Tools is slaved, through the SYNC I/O or USD, to a video tape recorder, with both machines referenced to the same house video reference source.

**When Pro Tools is slaved to a video tape recorder:**

1. When you start the video tape, time code (LTC or VITC) is read off the tape and routed to the SYNC I/O or USD.

2. The SYNC I/O (or USD) reads the time code position and continuously forwards the positional information down the SYNC I/O serial connection to the Pro Tools card. The SYNC I/O provides the master Loop Sync signal to Pro Tools|HD system through your HD-series audio interfaces. The USD (or SYNC I/O) can also output 256x Slave Clock as required on Pro Tools|24 MIX and Pro Tools|24 systems.

3. Pro Tools takes the first time code address it receives, and calculates the sample location in the session that corresponds to the address. Though you can work with Pro Tools using any standard time code format, it calculates internally in sample numbers.

4. Assuming that the time code address corresponds to a sample number that is within the Pro Tools session, Pro Tools converts the time code address to a sample number within the session, and begins playing from that point. The point from which playback starts is the trigger point. The clock reference is used by both machines to keep them running at the same speed.

5. At this point, if the video tape is stopped, rewound, and started again, the entire process is repeated, based upon a newly calculated trigger point.

### About Positional References

Time code is positional information in an analog signal or a digital streaming signal that can be recorded on magnetic video or audio tape. Time code can be used as a positional reference, to synchronize the playback and recording of your Pro Tools system with another machine’s time code signal, such as an analog multitrack tape machine or a video tape recorder (VTR).
**SMPTE and ISO/EBU Time Code**

The “Where are we?” question refers to relative position. To describe position, many professional audio, video, and multimedia devices and programs use SMPTE (Society of Motion Picture & Television Engineers) time code. In Europe, a standard called ISO (International Standards Organization) time code, formerly called EBU (European Broadcasters Union) time code, is generally used. These time code types are almost exactly the same in terms of how they are represented electronically. However, ISO/EBU time code works at a fixed rate of 25 fps (frames per second) and SMPTE includes provisions for several different frame rates. For the purposes of explanation, this chapter will generally refer to frame-measured timing information as “SMPTE time code.” This description should be understood to include ISO/EBU and SMPTE time code.

**SMPTE Time Code Methods**

There are two basic techniques used to record SMPTE time code onto magnetic tape: LTC (Linear Time Code) and VITC (Vertical Interval Time Code). LTC is recorded or generated on an audio channel or a dedicated time code track of the audio or video device. VITC is recorded within the video signal in the video “blanking area” of each video frame. VITC cannot be recorded on audio tracks, so it has no application when working with audio tape recorders, but it does offer powerful features for post production professionals who work with video.

There is also a non-SMPTE form of time code called MIDI Time Code (MTC) that some devices use to send timing information.

**SMPTE Time Code Units**

Time code describes locations in terms of hours, minutes, seconds, frames, and subframes (1/100th of a frame). The frame is used as a unit of time measurement due to SMPTE time code’s origin in film and video applications (see also “Frame Count and Frame Rate” on page 511.) Depending on the SMPTE frame rate, one frame is equal to 1/24th, 1/25th, 1/29.97th, or 1/30th of a second. For example, a video tape time code reading of “01:12:27:15” would tell us that we were at a position of one hour, twelve minutes, twenty-seven seconds, and fifteen frames. However, this time address alone does not tell us frame rate information.

Because SMPTE stores an absolute time reference on the tape in the form of time code, any location on that tape can be precisely located by devices that read time code. Once the time code has been recorded or striped on a tape, it provides a permanent positional reference that allows Pro Tools to link the playback of an event to an exact tape location. For example, with time code synchronization, a gun shot sound effect can be played at the precise instant that the gun’s flash appears on-screen.

**Frame Count and Frame Rate**

It is important to remember the difference between frame count and frame rate.

*Frame count* is the amount of frames that the time code counts before ascending to the next second count. Standard frame counts are:

<table>
<thead>
<tr>
<th>fps</th>
<th>Frame Count</th>
</tr>
</thead>
<tbody>
<tr>
<td>24</td>
<td>frames 0–23</td>
</tr>
<tr>
<td>25</td>
<td>frames 0–24</td>
</tr>
<tr>
<td>30</td>
<td>frames 0–29</td>
</tr>
</tbody>
</table>
“Frame rate” is the rate of speed that the time code is ascending through the frames. For example, when someone refers to a time code of 29.97, they usually are referring to “using a frame count of 30 frames, but counting each frame at the speed of 29.97 frames per second.”

**LTC (Linear Time Code)**

LTC is time code that is recorded and played back, or generated, in the form of an analog audio signal. LTC is supported by many audio and video tape recorders.

**LTC Speed Usage**

LTC can be read at high tape shuttle speeds, allowing a machine’s time code reader to communicate with synchronizers at rewind or fast forward speeds exceeding 50 times playback speed (provided the tape recorder is able to reproduce the time code at this speed). However, LTC cannot be read at very slow shuttle speeds (such as when you are “crawling” the tape frame by frame) or when the machine is paused. With LTC, the VTR must be running (usually at a minimum speed of about 1/10th normal playback speed) in order to capture a SMPTE time address.

**VITC (Vertical Interval Time Code)**

VITC is a type of time code that is recorded and played as an invisible part of a video signal. VITC is commonly used in professional video editing and audio-for-picture applications. Because VITC is recorded as part of each video frame, it must be recorded at the same time as the video signal—it cannot be added later as LTC can. Since VITC cannot be recorded on audio tracks, it is never used to synchronize audio-only recorders. Instead, LTC is most often used in audio-only applications.

**VITC Speed Usage**

VITC’s ability to be read when moving a VTR transport at slow speeds or when the VTR is paused makes it more useful than LTC in these situations. When VITC is used, Pro Tools can capture the current SMPTE time from the VTR when it is paused or in “crawl” mode. However, if you are using additional external transport synchronizers in your setup, most synchronizers cannot read VITC at speeds exceeding approximately 10 times playback speed, preventing slaved machines from maintaining synchronization during rewind and fast forward.

**LTC/VITC Auto-Switching**

Many synchronizers and devices support automatic switching between LTC and VITC, depending on the speed, to get the best of both worlds (both the SYNC I/O and USD support auto-switching). For example, VITC might be used when a VTR is paused, or crawling frame-by-frame, while the synchronizer might automatically switch to LTC when fast-forwarding.

**Bi-Phase/Tach**

This electronic pulse stream is used by film mag recorders, film editing stations, and film projectors. You can use this format to synchronize Pro Tools if you have a SYNC I/O. Unlike time code, Bi-Phase/Tach doesn’t actually contain absolute location information. It simply supplies speed (based upon the frequency of the pulses) and direction, and therefore, relative position. Since the SYNC I/O can “count” both the speed and direction of the stream of pulses, it can use a Bi-Phase/Tach source to deduce positional information from a starting “address point.” The difference between Bi-Phase and Tach formats is that Bi-Phase encodes rate and direction on a pair of signals using a format called phase-
quadrature, while Tach encodes rate on one signal and direction on the other. For more information on Bi-Phase/Tach, see the SYNC I/O Guide.

**SMPTE Frame Formats**

Six different formats of SMPTE time code exist, and Pro Tools can synchronize to any format with a compatible synchronization peripheral. The supported SMPTE frame rates are:

- **30 fps Frame Format**
  This is the original SMPTE format developed for monochrome (black & white) video, and is commonly used in audio-only applications. This format is often referred to as 30 Non-Drop frame format.

- **30 fps Drop Frame Format**
  This format is provided if you need to correct for improperly configured transfers. In normal workflow one should not need to use 30 drop.

- **29.97 Non-Drop Frame Format**
  This format is used with NTSC color video. It runs at a rate of 29.97 fps.

- **29.97 Drop Frame Format**
  NTSC color video has an actual frame rate of 29.97 fps, so an hour’s worth of frames (108,000) running at 29.97 fps Non-Drop will take slightly longer than one hour of real time to play. This makes calculating the actual length of a program difficult when using 29.97 Non-Drop time code. A program that spans one hour of 29.97 Non-Drop time code addresses (for example, from 1:00:00:00 to 2:00:00:00) is actually 60 minutes, 3 seconds and 18 frames long.

To make working with 29.97 time code easier for broadcasters, the SMPTE committee created 29.97 Drop Frame time code, which runs at exactly the same speed as 29.97 Non-Drop (non-drop frame) time code, but compensates for the slower speed by “dropping” (omitting) two frames at the top of each minute, with the exception of every 10th minute. For this reason, the time code address of 1:01:00:00 does not exist in drop frame code because it has been skipped.

- **25 fps Frame Format**
  This format is used with the European PAL video standard, which runs at a 25 fps frame rate. This format is also called the EBU (European Broadcast Union) format because it’s used by broadcasters throughout most of Europe.

When you work with NTSC video (the standard in North America), you will generally work with the NTSC color video standard: either 29.97 fps Non-Drop or 29.97 fps Drop frame. If you are working with PAL, your frame rate is 25 fps.

Note that even though time code addresses are skipped in drop frame format, actual frames of video material are not dropped.

At the end of a program that spans precisely one hour of drop frame time code (for example, 1:00:00:00 to 2:00:00:00), exactly one hour of real time has elapsed.

Although it sounds complicated, drop frame time code allows broadcasters to rely on time code values when calculating the true length of programs, facilitating accurate program scheduling.
24 fps Frame Format

This format is used exclusively for film applications. Film is typically photographed and projected at a 24 fps frame rate, so this SMPTE format is useful when one time code frame should equal one film frame.

Working with Film-Originated Material

When you do post production work in Pro Tools, you will usually work with video material. However, it is possible that the video you are working on was shot on film.

Film footage and production sound go through separate conversion processes before they reach video, and the audio post production stage. The film is transferred to video using a process called Telecine, using a method called 3:2 Pulldown. Audio can also be pulled down during the transfer, or you might end up working with audio that has not been adjusted (production sound).

Typically, during the Telecine process, a master digital video tape is created, along with a work copy on Betacam or 3/4” analog video tape for the picture editor to use. At the same time, a new audio master may be created by slowing down, or “pulling down” by 0.1%, the production sound to compensate for the change in speed from film to NTSC video. (See Figure 40 on page 516.)

Guide Tracks and Conforming

In the Video editing process, the audio track produced by the video editor (the “guide track”) is rough and needs to be enhanced and improved by the audio engineer. For this reason, the audio engineer will need to re-assemble the original sound elements in a process known as conforming.

3:2 Pulldown

A film clip that lasts 1000 seconds consists of 24,000 film frames (pictures). If you want to transfer that film to 1000 seconds worth of NTSC color video, you have to “fit” 24,000 film frames into 29,970.02997 video frames.

If we use the black and white NTSC video standard (30 fps) instead of 29.97 fps, the process of converting film frames to video frames is greatly simplified. Now instead of any fractional frames, we have 24,000 film frames going into 30,000 video frames (60,000 video fields). In the Telecine process (for NTSC color video), each odd film frame is copied to two video fields, and each even film frame is copied to three video fields.
fields, creating what is called a 3:2 Pulldown. The speed of the film is also “pulled down” to 23.976 fps in order to accommodate the slower speed of NTSC color video compared to NTSC black and white video (29.97 fps compared to 30 fps).

**Film Speed Differs from NTSC Video Speed**

When spotting audio to video that was transferred from film to NTSC video, there are two important terms to keep in mind: film speed and video speed.

**Film Speed** Film speed refers to audio that was recorded and plays back in synchronization with the original film material. This audio often comes from production reels recorded on a Nagra® recorder or a field DAT recorder, and is usually striped with 30 Non-Drop time code. Film must be pulled down 0.1% when being transferred to 29.97 NTSC. Film must be pulled up by 4.16667% when film is being transferred to PAL.

**Video Speed** Video speed refers to audio that is running at the NTSC color standard of 29.97 fps. Video speed is 0.1% slower than film speed, so audio that is still at film speed will be out of sync with the video.

In Figure 40, note the following:

- The vertical arrow at the left (“faster” “slower”) represents program speed or rate.
- Telecine is a frame count conversion (for example, 24 to 30).
- The speed you play the result back is a frame rate conversion (for example, 30 to 29.97).

The following table lists the applications for each of the frame rates and counts shown in Figure 40.

**Frame Rates and their Applications**

<table>
<thead>
<tr>
<th>Frame Rate</th>
<th>Applications</th>
</tr>
</thead>
<tbody>
<tr>
<td>25 fps</td>
<td>PAL</td>
</tr>
<tr>
<td>24 fps</td>
<td>Film, and 24P HD</td>
</tr>
<tr>
<td>23.976 fps</td>
<td>24P pull down, for NTSC broadcast</td>
</tr>
<tr>
<td>30 fps</td>
<td>30 frame music production, and 30 frame recording for film</td>
</tr>
<tr>
<td>29.97 fps</td>
<td>Broadcast NTSC video</td>
</tr>
</tbody>
</table>
Frame Rates and Relative Playback Speeds

The following diagram illustrates the relative playback speeds of SMPTE formats.

![Diagram showing frame rates and relative playback speeds]

**Pull Up and Pull Down**

*Pull Up and Pull Down* are terms used to refer to the deliberate recalibration of the audio sample rate clock (speed, or musical pitch) in order to compensate for a speed change. Pro Tools can be used to pull down or pull up audio or video playback rates. Pro Tools 5.3.1 and higher support pull rates known as “4% factors” (4.0% down, or 4.167% up to be exact), applicable to audio and video playback, to support PAL/film/NTSC conversion requirements.

Pull Down allows you to play back film-originated material at video speed (~0.1%). Pull Up allows you to play back video speed material at film speed (+0.1%).

Using Pro Tools in Pull Up or Pull Down modes requires a SYNC I/O, USD, or third party synchronizer.

**When to Pull Up or Pull Down**

There are many ways to get audio into Pro Tools for post production. Consider your source audio and your final destination format carefully. In some cases, audio will already be pulled down for you. In other cases, audio will have to be temporarily pulled down. In still other cases, you may choose to pull down your audio source, like a DAT deck, then use a a D-A-D (digital-to-analog-to-digital) process, or Digidesign’s...
192 I/O Sample Rate Conversion option, to record the audio into Pro Tools at the proper sample rate. Or you may choose only to pull Pro Tools up or down on delivery of the audio.

Because mistakes in pull factors can be expensive, good communication between yourself and other participants in the project is critical. Find out as soon as possible how your task relates to the rest of the project.

Refer to the online document *FilmSync.pdf* installed with your Pro Tools documentation, for detailed Pull Up and Pull Down workflow information.

**Final Audio Destination: Film**

If your final destination is film, your source audio is at film speed, and your goal is to edit and mix audio in Pro Tools and then lay back to a device that runs at film speed (such as mag or time code DAT), you can temporarily pull down the audio in Pro Tools for NTSC video work, then return the audio back to film speed when you're finished (by disengaging pull down).

For example, film speed audio from a field audio recorder that is referenced to 30 fps time code is recorded into your Pro Tools system at a sample rate of 44.1 or 48 kHz. Keeping in mind that film speed is faster than video speed, select 30 fps in your Session Setup window in Pro Tools, and record in your audio online and referenced to the time code on the field audio recorder.

Once all the audio has been recorded, and you are locked to a video work print (at video speed), enable Pull Down. If you are using a Digidesign SYNC I/O, select Pull Down in the Session Setup window. If your synchronizer is not a Digidesign product, select Pull Down on the front of your synchronizer, then enable Pull Down in the Pro Tools Session Setup window. At this point, it is highly recommended that you verify whether the video you’re working with is striped with 29.97 Drop Frame or Non-Drop Frame time code. While in Pull Down mode, you can work with your reference video and everything will remain synchronized and run at the proper speed (assuming your system is completely resolved).

Once you are ready to lay back your completed project to an audio device running at film speed, deselect Pull Down in the Session Setup window, and from your synchronizer if it is not a SYNC I/O. Then change your time code frame rate in the Pro Tools session back to 30 fps. Once Pull Down has been deselected, the audio played back from Pro Tools will synchronize perfectly with the edited film.

Alternatively, you can pull down the source audio deck while recording audio into Pro Tools, work at 29.97 fps with no Pull-Down selected in Pro Tools, and then switch to 30 Non-Drop frame format, and select Pull Up during the delivery stage. You will have to perform a sample rate conversion on the audio either digitally or by using an analog stage (D-A-D).

Only the inputs on the Digital I/O of the card (on the 192 I/O) feature real-time sample rate conversion.

💡 You will also need to select the Audio Rate Pull Up/Down option in the Session Setup window.
Final Audio Destination: Video

If you are working with video that was transferred from film, your audio source is at film speed, and the final layback destination is NTSC video (or television), and you would like to provide a digital transfer to your clients, you will need to alter the above recipe slightly. Keep in mind that when you are working in Pull Down mode, your active sample rate is 44.056 kHz (if the audio was recorded at 44.1 kHz) or 47.952 kHz (if the audio was recorded at 48 kHz).

Pull Down the Audio Source

Some professional DAT machines will let you pull down the sample rate to 44.056 kHz (and 47.952 kHz). You can record this audio into Pro Tools using a D-A-D (digital-to-analog-to-digital) process, or Digidesign's 192 I/O Sample Rate Conversion option. Then your audio will be at the correct speed for the remainder of the project, since the final destination is video, and no Pull Down or Pull Up is necessary.

Pull Up Pro Tools While Recording

If you cannot pull down your source, you can accomplish the same thing by Pulling Up Pro Tools, and setting your SMPTE frame format to 30 fps, before recording in the production sound. First select 30 fps as the frame format in the Session Setup window. Then select an Audio Rate Pull Up option in the Session Setup window (and on your synchronizer if it isn’t a SYNC I/O) before you record in the production audio. In this case, while the production audio is running at 44.1 or 48 kHz, Pro Tools is running (and recording) at a rate of 44.144 or 48.048 kHz. After all the production audio has been recorded into Pro Tools, reset the Audio Rate Pull to none in the Session Setup window, and on your hardware synchronizer if it is not a SYNC I/O. After you deselect Pull Up, the recorded audio will play back 0.1% slower, synchronized with the video, while achieving a true playback sample rate of 44.1 or 48 kHz. Note that this process is designed for a final destination of video; to bring this audio back up to film speed you would have to pull up Pro Tools and record to a destination that is not Pulled Up.

Note on Sample Rate Conversion

In many cases, you have to perform a sample rate conversion at some point, either digitally, or by recording in audio using an analog stage (D-A-D). The only situation where sample rate conversion never has to be performed is when you are working with film speed audio and your final destination format is film. Then you can simply pull down Pro Tools while you work with the video, then deselect Pull Down to set the audio back to film speed.

Using Digital Input

If you are working with Pull Up or Pull Down, do not “resolve” to any digital inputs that are used as audio sources in Pro Tools. This would override the use of the SYNC I/O as the clock reference. Any equipment providing digital audio sources to Pro Tools should be synchronized externally.

The right half of the back panels of 192 I/O and the 96 I/O feature a set of non-removable connectors that are mounted permanently to the enclosure ([Encl.]). These connectors cannot be used for Sample Rate Conversion. Only the inputs on the Digital I/O card on the 192 I/O feature real-time sample rate conversion.

💡 You will also need to select the Audio Rate Pull Up/Down option in the Session Setup window.
Chapter 35: Time Code Synchronization

Synchronization allows one system to output time code and the other device to follow that time code. With synchronization, you can play all devices in synchronization. Pro Tools is synchronized to other devices using SMPTE time code or MIDI Time Code. For a discussion of different SMPTE formats, and other concepts related to time code, refer to Chapter 34, “Synchronization Concepts.”

Pro Tools Synchronization Options

There are several options for synchronizing Pro Tools to an external source or using Pro Tools as the master device. Not all options are available on all Pro Tools systems, as noted.

SMPTE Trigger Only

This solution is useful for short projects if both systems are extremely close in speed, but even the best systems will rarely stay synchronized for longer than a couple of minutes. (SMPTE Trigger is the only synchronization option available in Pro Tools LE.)

SMPTE Trigger with Digidesign SYNC I/O

(TDM Systems Only)

This solution uses the SYNC I/O or USD, and house distributed video reference, or word clock, to control playback and recording speed in Pro Tools. Accurate long-term synchronization can be achieved when all transports within the system are resolved to a common synchronization source.

SMPTE Trigger with an External Peripheral Slaved to Time Code

(TDM Systems Only)

SMPTE Trigger can be used with the optional SYNC I/O or equivalent device to resolve Pro Tools recording and playback speed while slaving to LTC. This enables long-term, accurate synchronization by resolving to any variations in incoming time code. The SYNC I/O and USD also support VITC and Bi-phase/Tach positional reference.
SMPTÉ Resolved with SYNC I/O
(TDM Systems Only)

You can use the optional SYNC I/O, USD, or equivalent third-party device to resolve Pro Tools recording and playback speed with any of the following clock reference sources while slaving Pro Tools to time code:

- LTC
- Video source
- House video reference
- VITC
- 1x Word Clock
- AES/EBU “null” clock
- Pilot Tone
- Bi-Phase

This enables long-term, high-fidelity synchronization when all transports within the system are resolved to this common synchronization source, or by resolving to any variations in incoming time code while slaving to time code.

SYNC I/O Synchronization Options

By adding the SYNC I/O to your Pro Tools TDM system, you can use Pro Tools as the master device in your synchronization setup. All other devices are then slaved to Pro Tools.

You can use Pro Tools in conjunction with SYNC I/O to generate LTC, MIDI Time Code, or MMC commands. When SYNC I/O is reading incoming SMPTE time code, it regenerates the time code through the LTC or MTC output connector. This signal can be passed along to other slave devices.

MachineControl™

The SYNC I/O also supports Digidesign MachineControl software, which provides many specialized features for post-production synchronization tasks including remote track arming, VTR emulation, serial time code, and other capabilities. (See the MachineControl Guide for more information, or contact your Digidesign dealer.)

For instructions on connecting an external synchronization peripheral to your Pro Tools system, refer to the Getting Started Guide. If you are using SYNC I/O, refer to your SYNC I/O documentation.

Session Setup Window

The Session Setup window lets you configure various time code-related parameters on your system. The window also includes display-only areas for session sample rate, file format, and bit depth.

Figure 41 on page 521 shows the Session Setup window in Pro Tools 6 and higher.
Displays and controls are organized into three view sections. The Session displays and controls are always displayed at the top of the Session Setup window. The Synchronization and Session Offsets section, and the Time Code Settings section, can be shown or hidden using their show/hide icons.

**To show SYNC I/O Setup and Session Start Settings**
- Click the SYNC Setup and Session Offsets expand/collapse icon.

The controls in this section configure parameters of the Digidesign SYNC I/O or USD. Settings are provided for Clock and Positional Reference, Video Format, and Variable Speed Override.

**To show Time Code settings:**
- Click the Time Code settings expand/collapse icon.

The controls in this section provide time code generation and freewheel options, and separate pull up and down selectors for audio and video rates.

The following illustration shows the Session Setup window as it appears in prior versions of Pro Tools.
Session Displays and Settings

**Sample Rate**
Indicates the sample rate for the current session.

**Bit Depth**
Indicates the bit depth for the current session.

**Audio Format**
Indicates the file format for files recorded in the session.

**Clock Source**
Configures the system Clock Source. Clock Source is available in Pro Tools 6 only. If using a prior version of Pro Tools, see “Pro Tools|24 MIX and Pro Tools|24 Sync Mode (Clock Source)” on page 522.

Audio will be audible while you are making changes to Clock Source in the Session Setup window.

**Pro Tools|HD Clock Source**

**Internal Mode** In Internal mode, your system will reference your Digidesign card or peripheral’s quartz crystal oscillator and play back at the session’s sample rate.

Changes made to Clock Source in the Session Setup window are reflected in the Hardware Setup window and vise versa. For more information, see “Hardware Setup Window and Clock Source with Pro Tools|HD” on page 523.

**External Clock Sources:** Depending on your HD-series audio interface, external Clock Source options can include AES/EBU [Encl.], S/PDIF, Optical [Encl.], AES/EBU 1-8, TDIF, ADAT, and Word Clock (optional word clock rates are available at higher frequencies). External sources can be 1x any sample rate or the “base” rate. Base rate equals 44.1 kHz for 88.2 and 176.4 kHz; 48 kHz for 96 and 192 kHz. If an external source is chosen, and no valid sync clock is detected at the External Clock In, the I/O will return to Internal mode.

Once a SYNC I/O has been declared as the synchronization device in the Synchronization tab of the Peripherals dialog, the SYNC I/O will automatically start producing a 1X word clock at the session’s sample rate. To resolve your HD I/Os to this word clock signal, select Word Clock as the Clock Source on your primary 96 I/O or 192 I/O.

For more information on external clock sources, see the HD SYNC Guide.

**Pro Tools|24 MIX and Pro Tools|24 Sync Mode (Clock Source)**

On MIX-series, Pro Tools|24, and Digi 001 systems, Clock Source is labeled Sync Mode in the Session Setup window.

**Session Start**
This allows you to specify a SMPTE start frame location for your session. See “Setting a SMPTE Session Start Time (Start Frame)” on page 526.

**Incoming Time (Current Time)**
Displays incoming time code. In Pro Tools 6.0 and higher, this field is labelled Incoming Time. In prior versions of Pro Tools, this field is labelled Current Time.

**Session Start**
Specifies a SMPTE start frame location for your session. See “Setting a SMPTE Session Start Time (Start Frame)” on page 526.
Frame Rate
This allows you to set the SMPTE frame rate for the current session.

SYNC Settings
The controls in the SYNC Settings section let you configure SYNC I/O parameters including clock reference, positional reference, video format, and VSO.

In Pro Tools 6, these controls are grouped in the SYNC Settings section. In prior versions of Pro Tools, SYNC settings are located along the bottom of the Session Setup window.

Clock Reference
Determines the Pro Tools clock reference.

When using a Digidesign SYNC I/O or USD, the Clock Reference selector lists all supported clock references provided by the SYNC I/O.

Positional Reference
Determines the time code source for Pro Tools to use for positional reference.

Format
Sets the session for NTSC or PAL format.

Variable Speed Override (VSO)
Variable Speed Override (VSO) requires a SYNC I/O or USD.

When a SYNC I/O or USD is connected to a Pro Tools|HD system, the VSO controls are located in the SYNC Settings section of the Session Setup window.

Clock Source with Pro Tools|HD
Changes made to Clock Source in the Hardware Setup window will be reflected in the Session Setup window and vise versa. For more information, see “Session Setup Window” on page 520.
Ext. Clock Output

Pro Tools can be used as the master device in your synchronization setup, where all other devices are then slaved to Pro Tools word clock output.

With Pro Tools|HD systems, clock output can be configured for 1x word clock, or 256x Slave Clock for Digidesign legacy I/Os. See the Getting Started with HD guide for more information on clock output and legacy I/Os.

To set Ext. Clock Output:

2. Click the Ext. Clock Output pop-up menu and select an available signal.
3. Click OK to close the Hardware Setup dialog when you have finished.

If the Legacy Port is enabled (as opposed to the Expansion Port) then the Ext. Clock Output automatically switches to Slave256x. To reset the Ext. Clock Output, the Port Settings button must be set back to Expansion and the Legacy I/O must be set to No Interface. (To set a Legacy I/O to No Interface, select its name in the Peripherals list, then click on No Interface in the Interface pop-up menu.)

Time Code Settings

The Time Code Settings section provides generator, freewheel, and pull up/down options.

In Pro Tools 6, these controls are located in the Time Code Settings section of the Session Setup window. Click the Time Code Settings expand/collapse icon to show or hide these controls.

In prior versions of Pro Tools, these controls appear at the bottom of the Session Setup window whenever a SYNC I/O or USD is declared as the current Synchronization peripheral.

Generate Time Code

The Generate checkbox enables Pro Tools generation and output of LTC and MTC using the SYNC I/O (communicating directly through a serial port) or USD. For more information, see “Generating Time Code” on page 534.

Using Peripheral This option outputs time code from the Device type selected in the Synchronization page of the Peripherals dialog.

MTC to Port When enabled, outputs MIDI Time Code to the MIDI destination selected in the pop-up menu. In Pro Tools 6, choices are based on your AMS profile (Audio MIDI Setup). In prior versions of Pro Tools, choices are based on the current OMS Setup.

Freewheel

The choices in the Freewheel section let you configure how Pro Tools will “freewheel,” or continue playback if time code is interrupted or corrupted. Use these options to protect against errors that can occur if your SMPTE time code source has “drop outs” or temporary lost signals.

None No freewheel is applied.

Frames Sets a number of frames to freewheel, from 1 to 120 frames. This value defaults to 8 frames, which is the recommended setting for most applications.
**Jam Sync** Lets Pro Tools trigger synchronization to incoming time code, and continue to play back even if time code input is completely interrupted. It can be useful if time code is damaged, or has been accidentally erased from your source tape.

**Audio and Video Rate Pull Up/Down**

When Pro Tools is used in conjunction with a SYNC I/O, USD, or a third-party synchronizer that supports pulled sample rates, this option allows you to “pull up” or “pull down” the current sample rate.

In Pro Tools 5.3.1 and higher, you can pull audio or video separately, with support for 4% pull factors (or, 4.167% pull factors).

For general information, see “Working with Film-Originated Material” on page 514. For more information on applying pull factors in Pro Tools, see “Configuring Pull Up and Pull Down Using SYNC I/O or USD” on page 533.

**Time Code Reader Offset (Sync Offset)**

**Pro Tools 6** Time Code Reader Offset

**Prior Versions** Sync Offset

This field lets you set a “trigger offset” for incoming MIDI Time Code (anywhere from –100000 to +100000 samples). This allows you to create a permanent offset to fine-tune the point at which Pro Tools synchronizes relative to incoming time code. For example, a value of –50 makes an event in Pro Tools occur –50 samples before the same event in the incoming MIDI Time Code. Use this to compensate for timing differences between various SMPTE-to-MIDI Time Code converters or analog-to-digital/digital-to-analog converters.

**Additional Offsets with MachineControl**

If you are using Digidesign’s MachineControl option, additional Session Start Offsets are available. See the MachineControl Guide for more information.

**Sync Offset Voice Usage**

For TDM systems, recording with a Time Code Reader Offset requires two voices for each record-enabled track. In addition, to simultaneously record on 32 tracks with a Sync Offset on a Pro Tools MIX-series system (which allocates voices to either of two DSP engines, 1–32 or 33–64), the tracks must be evenly distributed between the two DSPs, (for instance, tracks 1–16 assigned to voices 1–16 and tracks 17–32 assigned to voices 33–48).

**Preparing to Work with SMPTE**

The first step when preparing to work with SMPTE is to choose an appropriate SMPTE frame rate. Pro Tools supports all standard SMPTE frame rates. For a full explanation of these SMPTE frame rates, see “SMPTE Frame Formats” on page 513.

**Determining SMPTE Frame Rate**

It’s always best to determine the SMPTE frame rate through labeling procedures or communication, but this is not always possible.

If you do not know the frame rate of a tape, the SYNC I/O and USD show incoming frame rate on its front panel LED indicators. These devices cannot distinguish between 29.97 fps and 30 fps, but they can determine whether the incoming frame rate is drop frame or non-drop frame. With NTSC video, the frame rate is most likely 29.97 fps Drop or 29.97 fps Non-Drop.
Configuring Pro Tools for SMPTE

MachineControl is supported on TDM systems only.

Synchronization and MachineControl™ system parameters are enabled in the Pro Tools Peripherals dialog box. These parameters are system settings, and remain constant regardless of the particular session you are working on. Configure these setting before opening a session.

Other parameters are configured in the Session Setup window, such as the session frame rate, the session start frame, and time display format. These settings are session-specific parameters. These parameters can only be configured when a session is open.

Selecting a SMPTE Format

To choose a SMPTE format:

1. From a Pro Tools session, choose Windows > Show Session Setup.
2. Choose a frame rate (SMPTE format) from the Frame Rate selector.
3. Enter the Time Code Freewheel frames (if any) in the designated box. See “Freewheel” on page 524 for more information.

Setting a SMPTE Session Start Time (Start Frame)

The Session Setup window also allows you to set a SMPTE Start Frame for your session. Video work tapes are rarely striped beginning at a SMPTE frame address of 00:00:00:00. You can quickly enter a start time for your session based on an appropriate frame number from your project tape. The Pro Tools SMPTE-related functions (such as Spot mode) will then use this value as their reference for the session’s start point.

Start Time When Striping Tape

If you are generating time code, it is a good practice to stripe your time code beginning at 01:00:00:00 (subtracting time for initial black, bars and tone, logos, and so on). This prevents problems that can occur with some synchronizers when the striped time code crosses from 23:59:59:29 to 00:00:00:00 (commonly referred to as the “midnight” boundary).

To set a SMPTE Start Time for your session:

2. Enter a SMPTE frame number in the Session Start field.

To capture an incoming SMPTE address as the session start time:

1. Begin playback of the time code source.
2. At the desired location, press Equal in the numeric keypad. You can then edit the captured address. The session uses the frame number you enter as its SMPTE start frame when online.

If there are existing regions on the tracks and you are changing the original SMPTE start frame to a later time (from 00:00:00:00 to 01:00:00:00, for example), all existing regions on tracks will remain in their relative positions, but will start later by the time value added to the start frame.

3. If you are changing the session start time in an open session in which tracks already exists, a warning dialog appears after Session Setup window. Choose from one of two options:
**Maintain Time Code** Places the additional session time at the start of the session, and keeps existing regions in their original time code locations.

**Maintain Relative Position** Places the additional session time at the start of the session, and maintains the relative position of existing regions to the new start frame. For example, if you change the session start frame from 01:00:00:00 to 00:59:00:00, Pro Tools adds one minute of session time to accommodate the new start frame, and moves all existing regions earlier in time to maintain their relative position to the start frame.

**Clock and Positional Reference**

When using a synchronization peripheral, use the Clock and Positional Reference selectors to select the appropriate clock and time code reference signals. The Speed Cal and Locked lights in the Session Setup window indicate synchronization status and will indicate when clock is or is not valid.

**Displaying Time in SMPTE Frames** *(TDM Systems Only)*

In Pro Tools, you can set the Main Time Scale indicator to Time Code (SMPTE). Though Pro Tools will still synchronize to incoming SMPTE time code if the Time Scale is displayed in Bars:Beats, Minutes:Seconds, or Feet:Frames, it is usually more useful to use SMPTE time code as your reference.

**To set the Main Time Scale to SMPTE Time Code:**

- Choose Display > Time Code.
  - or -
- Click the Main Time Scale selector in the Edit window, and select Time Code.

![Selecting a Time Scale format](image)

Pro Tools will display time code values in the currently selected SMPTE frame rate.

**Sub Time Scale Display**

You can also display a Sub Time Scale. For example, if the Main Time Scale is set to Time Code, and you want to compare SMPTE time to “wall clock,” when you are using 29.97 Non-Drop frame rate, you can select Min:Secs as the Sub Time Scale.

**4% Pull Up and Pull Down** *(Pro Tools 5.3.1 or Higher Only)*

Pro Tools 5.3.1 (and higher) supports 4% pull up and pull down, with support for an additional 0.1% up or down. Separate rates can be set for session audio and video (when video has been imported or captured into the session).

When referring to 4% pull up and pull down, the precise percentages used in pull ups is 4.167%. See “Audio Rates and Pull Up/Down Options” on page 531.
SYNC I/O and 4% Pull Factors

While the SYNC I/O is not required in order to use the extended pull up and down options provided in Pro Tools, the SYNC I/O is the only device that can be controlled from within Pro Tools, and that recalls and restore pull factors automatically when a session opens. Other synchronization peripherals must be configured manually.

Pull up and down settings do not affect SYNC I/O generated time code.

To enable extended pull up and pull down:

1. Choose the Operation tab from Setup > Preferences.
2. Deselect Limit Pull Ups to NTSC/PAL Film Standards.

Choosing a Pull Up/Down Rate

In Pro Tools 6, Pull Up and Pull Down controls are located in the Time Code Settings section of the Session Setup window.

In prior versions of Pro Tools these controls are in the main area of the Session Setup Window in prior versions of Pro Tools.

Pull Up/Down menus in the Session Setup window

Audio Rate Pull Up/Down Controls audio sample rate. See “Audio Sample Rate Pull Up and Down” on page 529.

Video Rate Pull Up/Down Controls video rate. See “Video Rate Pull Up and Down” on page 531.

The choices available in these menus are determined by the session frame rate. Combinations can be applied by choosing from both menus.

4% pull factors are not available in 176.4 and 192 kHz sessions.

Enabling Extended Pull Up and Down Options

Preference and Session Setup Controls

The preference Limit Pull Ups to NTSC/PAL Film Standards is enabled by default, which filters the list of pull up and pull down rates to only those which apply to approved NTSC/PAL film standards. See “When Limit Pull Ups is Enabled” on page 530 for a list of available rates at the default, enabled setting.

When this preference is not enabled, the Audio Rate Pull Up and Down menu offers all possible combinations of pull ups and pull downs for the audio sample rate, regardless of the session frame rate.
In addition, if there is a QuickTime video clip in the timeline, turning this preference off enables the video rate to be pulled up or down by 0.1%, regardless of the session frame rate. Though not an approved workflow, earlier versions of Pro Tools also enabled pull down of QuickTime video clips when audio was pulled down, so this option is included in Pro Tools 5.3.1 to maintain compatibility with earlier sessions.

The choice of available pulls for Avid video clips is unaffected by the setting of the Limit Pull Ups to NTSC/PAL Film Standards preference. This preference setting is stored with the session.

**Auto Match Pull Factors**

Auto Match Pull Factors is available from the session Frame Rate menu in the Session Setup window. When Auto Match Pull Factors is enabled, Pro Tools adjusts audio and video playback rates as needed to match any changes to the current session Frame Rate.

**Example of Auto Match Pull Factors**

Auto Match Pull Factors links audio and video pull factors when changing session frame rate.

For example, assume a Pro Tools session is set to a frame rate of 25 fps, the audio and video are both playing with no pull ups, and Auto Match Pull Factors is enabled.

If you then change the session Frame Rate to 24 fps, both the Audio and Video Rate Pull settings would change by –4.0% (the appropriate pull setting required by the change in frame rate).

Auto Match-enabled pull factors are applied to any existing Audio Rate Pull Up/Down or Video Rate Pull Up/Down settings. For example, if audio was already being pulled –0.1% when you changed the session Frame Rate from 29.97 to 24 fps, then the Audio Rate Pull Up/Down menu would switch to “none.”

**Audio Sample Rate Pull Up and Down**

The Audio Rate Pull Up/Down menu applies pull up or down factors to session audio record and playback. Choices are determined by the Limit Pull Up to NTSC/PAL Film Standards preference. See "Enabling Extended Pull Up and Down Options" on page 528.
When Limit Pull Ups is Enabled

When Limit Pull Ups to NTSC/PAL Film Standards is enabled, the following choices are available depending on the current session frame rate. Not all pull up factors are available at all sample rates.

**NTSC/PAL Choices for Pull Up and Pull Down**

<table>
<thead>
<tr>
<th>Session Frame Rate</th>
<th>Audio Rate Pull Up/ Down</th>
</tr>
</thead>
<tbody>
<tr>
<td>24</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>+0.1% (Source=23.98/29.97)</td>
</tr>
<tr>
<td></td>
<td>–4% (Source=25fps)</td>
</tr>
<tr>
<td>25 FPS</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>+4% (Source=23.98/29.97)</td>
</tr>
<tr>
<td></td>
<td>+4% (Source=24/30fps)</td>
</tr>
<tr>
<td>29.97/29.97d</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>–0.1% (Source=24/30fps)</td>
</tr>
<tr>
<td></td>
<td>–4% (Source=25fps)</td>
</tr>
<tr>
<td>30/30d</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>+0.1% (Source=23.98/29.97)</td>
</tr>
<tr>
<td></td>
<td>–4% (Source=25fps)</td>
</tr>
</tbody>
</table>

When Limit Pull Ups is Not Enabled

When Limit Pull Ups to NTSC/PAL Film Standards is not enabled, all pull rates are available, regardless of session frame rate.

See also “Auto Match Pull Factors” on page 529.
Audio Rates and Pull Up/Down Options

The following table lists actual sample rates of each pull up and pull down option and combination (rounded to the nearest whole Hz):

Table 6. Sample Rates at Pull Up and Pull Down Settings

<table>
<thead>
<tr>
<th>Pull Up/Down</th>
<th>Sample Rate</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>44100</td>
</tr>
<tr>
<td>+4.1667% and +0.1%</td>
<td>45983</td>
</tr>
<tr>
<td>+4.1667%</td>
<td>45938</td>
</tr>
<tr>
<td>+4.1667% and –0.1%</td>
<td>45892</td>
</tr>
<tr>
<td>+0.1%</td>
<td>44144</td>
</tr>
<tr>
<td>–0.1%</td>
<td>44056</td>
</tr>
<tr>
<td>–4.0% and +0.1%</td>
<td>42378</td>
</tr>
<tr>
<td>–4.0%</td>
<td>42336</td>
</tr>
<tr>
<td>–4.0% and –0.1%</td>
<td>42294</td>
</tr>
</tbody>
</table>

Video Rate Pull Up and Down

The Video Pull Up/Down selector lets you change the frame rate of video playback independently from the audio pull-ups (if any). It is located below the Audio Rate Pull Up/Down menu in the Session Setup window.

The choices available in the Video Rate Pull Up/Down menu depend on the file format of the video clip, as well as its frame rate. The following table shows the pull ups available for Avid video clips, both interlaced and Progressive Scan.

See also “Auto Match Pull Factors” on page 529.
Video pull rates are saved with the session.

**Pull Ups and QuickTime**

No pull ups are available for Quicktime video clips unless you turn off the preference Limit Pull Ups to NTSC/PAL Film Standards, located in the Operations pane of the Preferences dialog. Turning this preference off allows the video rate to be pulled up or down by 0.1%, regardless of the session frame rate.

**No Video Recording with Pull Ups** *(AVoption|XL Required)*

Video may not be recorded to the timeline if a video pull up is selected. If the video track is record enabled while video pull ups are enabled, or if you attempt to set a video pull up rate while the video track is record enabled, Pro Tools will post a dialog and disallow video recording. To proceed with digitization, reset the Video Rate Pull Up menu to None.

### What is Pulled Up or Down?

The following sections describe how related Pro Tools features are affected by pull up and down rates.

#### Time Code Ruler

Video pull up and down does not affect the Time Code Ruler. Be sure to set the session Frame Rate to the correct frame rate for your project. For example, if working with 24 fps video and you pull the video up by 4%, switch the session Frame Rate to 25 fps to keep the Time Code Ruler aligned. Similarly, if working with 24 fps video that is pulled down by 0.1%, switch the frame rate of the session to 29.97.

When working with 25 fps Avid media and the video is set to pull down by 4%, set the session Frame Rate to 24 fps.

#### Plug-ins

For proper operation at larger (4%) pull rates, plug-ins must utilize sample clock instead of an absolute time clock. All Digidesign plug-ins are based on sample clock.

#### Higher Sample Rates and Pull Factors

4% audio pull rates are not available in 176.4 and 192 kHz sample rates sessions.
Configuring Pull Up and Pull Down Using SYNC I/O or USD

(Pro Tools 5.3.0 and Prior)

If you have a Digidesign SYNC I/O or USD, and are working with material that has been pulled up or down, you will need to reconfigure your synchronization settings. The following instructions explain how to do this if you are using Pro Tools 5.1.1.

To work with a sample rate that was pulled up or down:

1. Choose Setups > Peripherals and click Synchronization.
2. Make sure you have enabled your peripheral. For more information on enabling SYNC I/O, see the SYNC I/O Guide.
4. In the Session Setup window, choose the frame rate for your session from the pop-up menu. This frame rate might be 30 fps (Drop or Non-Drop) or 29.97 fps (Drop or Non-Drop) depending on the requirements of your material. See “When to Pull Up or Pull Down” on page 516 for more information.

5. In the Sample Rate Pull Up and Pull Down field, enable the Pull Up or Pull Down option as appropriate.

This procedure will also work with a third-party synchronizer that supports Pull Up/Pull Down, with the following exceptions:

- You have to enable Pull Up or Pull Down in the Session Setup window and on your synchronizer.
- Only a Digidesign SYNC I/O or USD provide frame-edge accuracy.

Putting Pro Tools Online

To trigger playback or recording from an external source, the Pro Tools Transport must be placed online. This tells Pro Tools to listen for incoming time code.

To put the Pro Tools Transport online, do any of the following:

- Choose Operations > Online.
- Click the Online button at the far left of the Transport.
- Press Command+J (Macintosh) or Control+J (Windows).

The Online button flashes while Pro Tools waits for a SMPTE frame to trigger playback. When time code is received, playback begins and the Online button becomes highlighted. The Location Indicators in the Edit window toolbar, and the Incoming Time field in the Session Setup window display the incoming timecode (in pre-6.0 versions of Pro Tools, this field is labelled Current Time).
To take Pro Tools offline:
- Deselect Operations > Online.
  - or -
- Deselect the Online button in the Transport window.

Recording Online
The Operation page of the Preferences dialog (Setups > Preferences) contains two options that affect how Pro Tools initiates recording when online.

![Online options]

Online recording options

**Record Online At Insertion/Selection** Makes online recording begin wherever you have placed the insertion point in a track. Recording then continues until Pro Tools stops receiving time code. If you make a selection in a track, Pro Tools will record online only for the length of the selection.

**Record Online at Time Code (or ADAT) Lock** Makes online recording begin as soon as Pro Tools receives and locks to time code or ADAT sync. In this case, you don’t need to make an insertion or selection in a track to designate a start point.

---

Generating Time Code

Using SYNC I/O, Pro Tools can generate SMPTE and MIDI Time Code (MTC). You can then make Pro Tools a master synchronization source with other devices slaved to it.

**SYNC I/O cannot generate 24 fps time code while locked to video**

The SYNC I/O cannot generate 24 fps time code while it is locked to a video clock signal. If you set Pro Tools to generate 24 fps time code while the SYNC I/O is locked to a video clock signal, the SYNC I/O will actually generate at the NTSC color standard 29.97 Non-Drop Frame rate.

Pro Tools can generate time code at non-NTSC frame rates if you use the internal clock on the SYNC I/O as a synchronization source.

**To generate time code using SYNC I/O:**

1. Connect the SYNC I/O LTC Out to the SMPTE in connector on the devices you are slaving. If you are slaving a device that recognizes MTC, connect the MTC OUT connector of the SYNC I/O to the MIDI IN connector of the slaved device (MIDI Interface or other).
2. Make sure your SYNC I/O is powered on.
3. Launch Pro Tools, and make sure you have already enabled the SYNC I/O in the Synchronization page of the Peripherals dialog. See the SYNC I/O Guide for more information.
4. Choose Windows > Show Session Setup, and choose the appropriate frame rate.
5. In Pro Tools 6 and higher, select SYNC I/O from the Generate selector in the Time Code Settings section of the Session Setup window. In prior versions of Pro Tools, in the Generate Time Code field, enable the “Using SYNC I/O” option.
Choose a clock reference from the Clock Reference selector. Not all clock choices are available at all sample rates. See “External Clock Sources:” on page 522.)

Click the Online button on the Transport, then click Play. Pro Tools generates and outputs time code from the SYNC I/O.

**Using MIDI Machine Control**

Pro Tools provides the capability to transmit location information to external devices, and to control their transports, using MIDI Machine Control (MMC).

**Controlling External Devices Using MMC**

Any device that supports MMC (such as an Alesis ADAT or Tascam DA-88) can be controlled directly from within Pro Tools, with either the device or Pro Tools acting as clock master.

The external devices supported by Pro Tools implement “open loop” communications only. Because of this, while Pro Tools is the transport master, any direct operation of the receiving device’s transport will not be communicated back to Pro Tools. Instead, you can use the Transport pop-up to select the external device (MMC in the pop-up) and use the Pro Tools on-screen transport controls to drive the device.

Pro Tools does not support remote track arming of MMC-controlled external devices. You need to manually arm tracks for recording on the external device.

Digidesign’s MachineControl option supports remote track arming for Sony 9-pin and V-LAN enabled devices. See “Remote Track Arming” on page 540.

**Macintosh**

Pro Tools 5.x and prior on the Macintosh use OMS to facilitate MIDI Machine Control. In order to use MMC with Pro Tools you must configure your MMC device to “Receive” and “Send” MIDI Machine Control in OMS.

By using the OMS IAC bus, you can also make a MIDI sequencer act as location master. Refer to your OMS and MMC-compatible device documentation for details.

**Windows**

Pro Tools in Windows uses your Multimedia Setup to determine which MIDI devices are available, and what their properties are. Refer to your device’s installation and usage documentation to properly configure the device.

**Enabling MIDI Machine Control in Pro Tools**

To enable MIDI Machine Control:

1. Choose Setups > Peripherals, then click Synchronization.

2. Select your synchronization peripheral from the Synchronization/Device pop-up. If you are using a MIDI interface, select “Generic MTC Reader.” If using SYNC I/O, set the Port to DigiSerial.
3 Select the appropriate port for synchronization information. This is the port to which your synchronization peripheral is attached.

4 Click the Machine Control button at the top of the window to open this page of the Peripherals dialog.

5 In the MIDI Machine Control section, enable MMC.

6 Select your external device from the Send To pop-up. The list of available devices is determined by the OMS devices configured in your OMS Studio Setup (Macintosh), or by your Windows Multimedia Setup.

The port on which this information will be transmitted is set in the “ID” field. MMC commands contain an ID number to identify which machine should respond to the MMC command. There are 128 MMC ID numbers, from 0–127. The default of ID #127 is a special setting that broadcasts to all 128 MMC IDs. With this setting, any device on the specified port will respond to MMC commands.

7 Set a pre-roll time for your MMC device. Pre-roll is needed to provide Pro Tools with sufficient time to lock to the incoming time code. This value will vary depending on the external device. If the pre-roll time is insufficient, Pro Tools may not be ready to lock until after the current time code position has passed.

8 Click OK to close the Peripherals dialog. Pro Tools will now be able to control the selected device’s transport.

Operating the Pro Tools Transport with MMC

You use the Pro Tools Transport window as the remote controller for all your enabled devices (MMC units, ADAT, or a non-linear video deck). To do so, set the enabled devices to listen to the address you enter for MMC. The Transport window will then “drive” Pro Tools transport and any slaved devices.

You can also configure a “Pro Tools master,” which can “drive” other devices (as needed), and to which Pro Tools will chase (slaving Pro Tools).

To control external devices from the Pro Tools Transport Master:

- Select either Pro Tools or MMC from the Transport pop-up in the Pro Tools Transport window. The selected item will act as Transport Master.

Choosing a Transport Master

When the Transport Master is set to Pro Tools, the playback position is governed by the on-screen cursor in Pro Tools.
When the Transport Master is set to MMC, the playback position is governed by the external device’s play position.

For more information, see “Recording from MIDI Devices” on page 167.

**MMC Transport Settings**

When using MMC, you can set the following options for machine transport behavior in the Operation page of the Preferences dialog.

**Machine Chases Memory Location** With this option enabled, navigating to a specific location in a session with a Memory Location causes a connected transport to chase to that location.

**Machine Follows Edit Insertion/Scrub** With this option enabled, navigating to a specific location in a session by moving the selection point or by scrubbing a track causes a connected transport to chase to that location.

---

**Synchronizing a Sequencer to Pro Tools on Macintosh OS 9**

To synchronize Pro Tools 6 to a sequencer application, configure AMS to provide MTC and MMC (if desired). Configure AMS to provide at least two nodes for inter-application communication (in the Pro Tools MIDI Setup window, these nodes are provided and are labelled Pro Tools Inputs 1 through 4).

The following sections explain how to configure prior versions of Pro Tools and sequencers under Macintosh OS 9 with OMS.

A common application for generating time code with Pro Tools is slaving an OMS-compatible sequencer to a Pro Tools session.

**Setting the Clock Master**

The exact synchronization setup your sequencer requires will vary depending on the software and your OMS setup, but Pro Tools must be the clock master. Since Pro Tools provides the audio sample clock for your system, synchronization errors will occur over time if Pro Tools is not designated as the master.

The following instructions describe the general procedure.

You can use Pro Tools MMC to synchronize with an OMS/MMC-compatible sequencer or an external MMC-compatible device such as an ADAT or DA-88. See “Controlling External Devices Using MMC” on page 535.

To slave an OMS-compatible MIDI sequencer to Pro Tools:

- Make sure the OMS IAC Driver is installed in the OMS Folder inside your System Folder. If necessary, run the Pro Tools Installer to install OMS with the OMS IAC driver. Refer to the Getting Started Guide for details.

In OMS Setup:

1. Choose Edit > Preferences, and make sure the “Use Apple Serial DMA driver when available” option is not selected. Click OK.

Always make sure the Apple Serial DMA driver is not being used by OMS. It can prevent proper communication with MIDI devices. You must restart your computer any time you enable or disable the Apple Serial DMA driver.
2 Choose Setups > OMS MIDI Setup, and select the “Run MIDI in background” option.

3 Choose Studio > MIDI Cards & Interfaces, then click Update Setup. If you are using a serial MIDI interface, enable the appropriate port and click Search.

4 Confirm that the OMS IAC driver appears in the OMS Studio Setup window. If it does, save the document and make it your current setup.

5 In the OMS Studio Setup window, define an IAC Bus by double-clicking the IAC Driver icon, and typing IAC1, for example, in the first field (this provides a unique name for this particular IAC bus).

6 In the Sequencer application:
   - Enable IAC1 (the IAC bus you defined in OMS setup). Different sequencers operate in different ways, so refer to your sequencer’s documentation.
   - Set the sequencer to receive MIDI Time Code (MTC).
   - Set IAC1 as the device from which to receive synchronization information.

7 Set the SMPTE Format (frame rate) that matches Pro Tools (for example, 30 fps or 29.97 Non Drop fps).

8 Select the SMPTE start frame for your session.

9 Set your sequencer to wait for note input from the synchronization device.

10 Start playback in the sequencer. It should indicate that it is waiting for sync.

In Pro Tools:

11 Select Operations > Active in Background.

12 Choose Windows > Show Session Setup.

13 In the Session Setup window, choose an appropriate frame rate.

14 Select the SMPTE Start Frame to match the start frame in your sequencer. If the sequence starts at 00:01:00:00, you could set the Pro Tools Session to start earlier (for example, at 00:59:58:00) to allow some pre-roll.

15 Enable the MTC to Port option in the Output Time Code box. Select IAC1 as the MTC destination.

16 Click Play or press the Spacebar to start playback. Pro Tools will send MIDI Time Code to the sequencer via the IAC port and trigger synchronized playback. Click Stop in the Transport or press the Space bar again to stop playback.

17 Once synchronized playback is operating correctly, you can record new takes in Pro Tools while listening to MIDI playback from your sequencer. Follow the procedure described above...
Chapter 35: Time Code Synchronization

for synchronized playback, then record new material in Pro Tools by following the recording procedures in this guide (“Recording from MIDI Devices” on page 167).

You should also be able to record new MIDI tracks while the sequencer is slaved to Pro Tools. See your sequencer documentation for details on recording while the sequencer is in an external synchronization mode.

### Synchronizing a Sequencer to Pro Tools in Windows

This section describes how to configure Pro Tools 5.3 and prior versions for interapplication synchronization on Windows.

These instructions require the use of a physical MIDI port. While several “virtual” MIDI cable applications do exist for interapplication MIDI communication in Windows, such software devices have not been qualified to work with Pro Tools.

**To synchronize Pro Tools to a Windows sequencer:**

1. Make sure your MIDI interface is correctly installed and configured. You must do this before proceeding.

2. Choose one pair of input/output ports on your MIDI interface to use as your synchronization “loop” for application-to-application MIDI communication.

3. Connect a MIDI cable from that port’s output to the same port’s input (for example, port 1 out to port 1 in).

4. In Pro Tools, select the appropriate in and out ports when making your selections for MIDI source or destination ports.

   - If you are slaving your sequencer to Pro Tools, select the appropriate port in the Session Setup window’s MTC to Port pop-up menu.
   - If you are slaving Pro Tools to your sequencer, select the appropriate port in the Pro Tools Peripherals > Synchronization window.

5. In your sequencer, select the appropriate in and out ports for MTC source/destination.

### Setting Minimum Sync Delay

Lock-up time delay is the amount of time your system’s devices need to achieve synchronization “lock.” This amount varies for each device. Pro Tools lock up delay is set by entering a value for Minimum Sync Delay in the Synchronization window of the Peripherals dialog. The lowest value available is 15 frames. Find the shortest possible lock-up time that your equipment can operate at consistently, and set this as the Minimum Sync Delay. On systems utilizing Digidesign MachineControl, enabling the Use Serial Time Code setting will make machines lock up much faster. (Serial time code requires both the SYNC I/O and external devices to be locked to house video reference.)

**To set a Minimum Sync Delay:**

1. Choose Setups > Peripherals, and display the Synchronization pane.

2. Enter a number of frames in the Minimum Sync Delay field.

3. Click OK to close the Peripherals dialog box.
### Configuring Minimum Sync Delay for External MMC Devices Locked to House Sync

When controlling a house-synced device from Pro Tools through MMC, the device will first lock to the MMC location and then align the color framing. Within house sync code are 4 frames for ensuring color frame lock. If the minimum synchronization setup time is less than the time required to achieve both location and color frame lock, playback will begin before the device has aligned the color frames. In this scenario, you should set the Minimum Sync Delay to be more than the time required for color frame lock. This is not a problem with the SYNC I/O, which will drop out of lock until the color frame is locked.

### Remote Track Arming

Digidesign’s MachineControl™ option for Pro Tools allows you to remotely arm tracks on supported 9-pin (or V-LAN for transport only) decks. Without MachineControl, Pro Tools does not support remote track arming of external devices. MachineControl lets Pro Tools act as the master or slave to external Sony 9-pin (or V-LAN for transport only) machines, in addition to providing remote track arming from within Pro Tools. (See the MachineControl Guide for more information.)

### Synchronizing Pro Tools to an OMS-Compatible Sequencer Using MMC

**(Macintosh OS 9 Only)**

You can “lock” a MIDI sequencer to Pro Tools for synchronized operation, using the sequencer as the transport and location master. In this case, Pro Tools is still the system clock master, while the sequencer is the transport/location master.

### MMC and OMS Synchronization

When using MIDI Machine Control, you must have the OMS-compatible sequencer configured to synchronize to Pro Tools using the OMS IAC Driver (see “Synchronizing a Sequencer to Pro Tools on Macintosh OS 9” on page 537). When controlled by a sequencer via MMC, Pro Tools serves as clock master for the sequencer.

Pro Tools also serves as a transport and location slave to the sequencer. When starting and stopping playback in the sequencer, the sequencer sends out location information to Pro Tools via MMC commands. Pro Tools then cues to the location, begins playback, and sends MIDI Time Code back to the sequencer. The sequencer then locks to the MIDI Time Code from Pro Tools for synchronized playback.

The following instructions describe the general steps that you should take. The exact synchronization setup your sequencer requires will vary depending on the software and your specific MIDI setup.
To slave the Pro Tools transport to an OMS-compatible MIDI sequencer using MIDI Machine Control:

1. Make sure the OMS IAC Driver is installed in the OMS Folder inside your System Folder. If necessary, run the OMS Installer and choose Custom Install to install the OMS IAC driver.

2. In Pro Tools, choose Setups > OMS Studio Setup to launch the OMS Setup application.

In OMS Setup:

3. Choose Edit > Preferences, make sure the “Use Serial DMA driver when available” option is deselected, and click OK.

4. Choose Edit > OMS MIDI Setup, make sure the “Run MIDI in background” option is selected, and click OK.

5. Choose Studio > MIDI Cards & Interfaces, then click Update Setup. If you are using a serial MIDI interface, enable the appropriate port and click Search.

6. Confirm that the OMS IAC driver appears in the OMS Studio Setup window. Save the setup document and make it your current setup.

7. In the OMS Studio Setup window, define two IAC busses by double-clicking the IAC Driver, then naming the first field “IAC1” and the second field “MMC.”

In your sequencer:

8. Enable IAC1 as a MIDI device.

9. Set your sequencer to receive MTC from IAC1, and enable remote control of the application.

10. Configure the frame rate to match your Pro Tools session. Click OK to close the Sync Options dialog.

11. Set a sequence start time (for example, 01:00:00:00). The Offset at the top of the Sequence window should usually match the Offset in Pro Tools.

12. Set the sequencer to wait for MIDI note information (“wait for note”).

13. Start playback in the sequencer. The sequencer should indicate that it is waiting for note information.

In Pro Tools:

14. Choose MIDI > Enable Input Devices. Select the IAC bus transmitting the MMC messages and click OK.

15. Choose Operations > Active in Background.

16. Choose Windows > Show Session Setup, and choose the appropriate frame rate and SMPTE Start Frame to match the start time in your sequencer.

17. In the Output Time Code section of the Session Setup window, enable the MTC to Port option. In the pop-up menu just below the MTC to Port option, choose IAC1. You can now close the Session Setup window, or leave it open (settings are active as soon as they are enabled in the Session Setup window).

18. Next, choose Setups > Peripherals, and open the Synchronization page of the Peripherals dialog.

19. First, select Generic MTC Reader as the synchronization device, and select Any as the port.
Next, click to Enable Control of Pro Tools via MMC, and set the ID to 0.

If MMC is currently enabled in the Pro Tools Peripherals > Machine Control dialog, you must assign a unique ID number in both of the corresponding MMC ID# fields. If not, an MMC feedback loop will occur. This can also happen if you use the default “broadcast to all” ID number of 127 in both places. If you are only slaving Pro Tools to a sequencer via MMC, without an external device requiring MMC from Pro Tools, you should disable MMC entirely in the Machine Control window.

In the Sequencer:

Engage any of the following Transport functions: Play, Stop, Fast Forward, Rewind, Record, or Locate (Cue). The sequencer sends MIDI Machine Control commands to Pro Tools via the IAC bus, and Pro Tools follows.

When starting and stopping playback in the sequencer, the sequencer sends location information to Pro Tools via MIDI Machine Control commands. Pro Tools cues to the location, begins playback, and in turn sends MIDI Time Code back to the sequencer. The sequencer then locks to the MIDI Time Code from Pro Tools for synchronized playback.

MIDI Beat Clock

Some MIDI devices such as drum machines, hardware sequencers, and arpeggiators can only synchronize to MIDI Beat Clock. To synchronize these devices to Pro Tools, you can transmit MIDI Beat Clock to them. Many plug-ins now support MIDI Beat Clock.

To transmit MIDI Beat Clock:

1. Choose MIDI > MIDI Beat Clock.
2. In the MIDI Beat Clock dialog, select the Enable MIDI Beat Clock option.
3. Select the devices you want to receive MIDI Beat Clock. If your MIDI interface does not support transmitting MIDI Beat Clock to separate ports, only the interface appears as a destination.
4. Click OK.
Spotting Regions to SMPTE Frame Locations

(TDM Systems Only)

Spotting is the process of assigning music and sound cues to specific SMPTE frame locations in a film or video. This function can be used to spot:

- Entire regions, selected with the Grabber. Multiple regions can also be selected, and Pro Tools will reference the first region in your selection.
- A specific location within a region, by clicking with the Selector at that location, and choosing Edit > Identify Sync Point.
- Sessions and/or tracks, dragged from a browser to the session Timeline or Regions List (requires Pro Tools 6 or higher).

Spot Mode

In Spot mode, a region in a track can be quickly spotted by simply clicking it with the Grabber.

You can also drag a region from a DigiBase browser, or from the Regions List, to a track while in Spot mode.

The Spot Dialog

The Spot Dialog appears when you drag a region to a track or click a region with the Grabber in Spot mode. The numeric fields function as both data displays and editing controls for the currently selected regions.

Information in these fields is displayed in SMPTE Time Code, Minutes:Seconds, Feet:Frames, Samples, or Bars & Beats, depending on which Time Scale format is selected.

```
Spot Dialog

<table>
<thead>
<tr>
<th>Current Time Code:</th>
<th>01:07:25:28</th>
</tr>
</thead>
<tbody>
<tr>
<td>Time Scale:</td>
<td>Time Code</td>
</tr>
<tr>
<td>Start:</td>
<td>01:03:54:11</td>
</tr>
<tr>
<td>Sync Point:</td>
<td>01:03:54:11</td>
</tr>
<tr>
<td>End:</td>
<td>01:04:05:01</td>
</tr>
<tr>
<td>Duration:</td>
<td>00:00:10:20</td>
</tr>
</tbody>
</table>

Check Use Subframes

Original Time Stamp: 01:00:00:00
User Time Stamp: 01:00:00:00

Cancel | OK

Spot dialog

A highlighted numeric field indicates the current active field for numeric entry editing. Entering a value in a field allows you to move a selected parameter to the time location that you enter. The Start, Sync Point and End fields are accessible when the Grabber is active. Only the Start or End (depending on where you click the mouse) and Duration fields are active when the Trimmer is active (see “Using the Trimmer in Spot Mode” on page 545).

- To increase or decrease SMPTE values in the Spot dialog by a specific number of frames, press plus or minus on the numeric keypad, enter a number, and press the Enter key.
```
Use Subframes Option

A subframe is 1/100th of a frame. The Use Subframes option enables you to use these smaller units for greater accuracy. This command adds an additional time field in the SMPTE hours:minutes:seconds:frames box, which appears as the far right time field when enabled. Use a period to separate subframe values from whole frames.

Capturing Time Code

Pro Tools also allows you to easily capture frame locations on the fly in this dialog by pressing the Equal key, or by clicking the Current Time button while valid time code is being received by Pro Tools. With VITC, you can accurately capture a paused or “crawling” VTR’s SMPTE location.

When Time Code is selected for the Time Scale, pressing the Equal key captures the incoming time code. When Bars:Beats is selected for the Time Scale, pressing the Equal key will capture to the nearest measure.

Although the Capture Time Code button works with free-running Linear Time Code (LTC) or VITC, frame numbers of a paused frame can only be captured with VITC.

To use Remote mode with MachineControl, you will need an approved serial port. For a complete list of currently approved ports, see www.Digidesign.com.

To spot a region to a specific SMPTE frame:

1. Choose Display > Show Edit Window.
2. Set the Main Time Scale to time code. (See “Setting a SMPTE Session Start Time (Start Frame)” on page 526.)
3. Click the Spot button at the top left of the Edit window to put Pro Tools into Spot mode.
4. Identify the SMPTE frame location where you want to trigger playback of your region by pausing your video deck on that frame.
5. With the Grabber, click a region in a track, or in the Regions List, and drag it into a track. The Spot dialog appears.
6. Enter the desired SMPTE frame location.
   - If you are using VITC, you can press the Equal key on the numeric keypad, or click Current Time Code to enter a paused VTR’s current SMPTE location.
   - If you are using LTC, when Time Code is selected for the Time Scale, press the Equal key on the numeric keypad to capture the incoming time code. When Bars:Beats is selected for the Time Scale, press the Equal key to capture the nearest measure.
7 If you recorded the region while online, you can use the Original Time Stamp button to recall and enter the SMPTE frame location at which the region was originally recorded. You can also access a user-defined Time Stamp in the same fashion. See “Time Stamping” on page 545 for more information.

8 Click OK to close this dialog. The region spots to the chosen SMPTE frame location. When the session is online, this frame number will trigger playback of the region.

Auto-Spotting Regions

The Pro Tools Auto-Spot Regions option simplifies the task of spotting regions even further. If you are using VITC with this option enabled, or MachineControl software, you can pause your video at an appropriate SMPTE frame location, click on a region with the Grabber, and the region will be automatically spotted to the current time code location.

You can also use MachineControl’s serial time code ability to auto-spot by enabling MachineControl and enabling serial time code in the peripheral.

To Auto-Spot a region:


2. If you are using VITC, identify the SMPTE frame location where you want to trigger playback of your region by pausing your video deck on that frame.

3. Click the desired region with the Grabber. The region will be automatically spotted to the current time code location (or machine location).

Using the Trimmer in Spot Mode

You can use the Spot dialog to trim your regions, including start/end/duration times and referencing incoming time code addresses. If you click a region with the Trimmer in Spot mode, the Spot dialog will appear, allowing you to enter a value in the Start or End and Duration fields to specify exactly where you want to trim the region’s beginning or end. Use this to edit the length of a region to correspond to a particular visual “hit point.”

Trimming a region that contains a sync point (see “Identifying a Synchronization Point” on page 547) will not affect the SMPTE location of the sync point, unless the region is trimmed past the sync point.

Time Stamping

Pro Tools time stamps every region recorded online with the original SMPTE time at which audio was recorded. You can recall this original SMPTE time for a region by clicking the Original Time Stamp button in the Spot dialog.

You can also spot a region to a separate user-defined SMPTE time stamp, defined using the Time Stamp Selected command. Once the region is time stamped using this command, you can click the User Time Stamp button to re-spot a region to its user-defined SMPTE location.
The Use Subframes option in the Spot dialog enables you to work with subframe accuracy by adding an additional time field in the SMPTE hours:minutes:seconds:frames box. This additional time field appears as the far right time field when enabled, and allows you to enter subframe values in SMPTE dialogs. Use a period to separate subframe values from whole frames.

**Show Original Time Code in Regions**

This command displays the original “time stamped” SMPTE times in all regions currently placed in tracks. This SMPTE frame number represents the time at which the region was originally recorded online with Pro Tools, and does not necessarily reflect the region’s current SMPTE location in a track.

**To display Original Time Stamps in regions:**
- Select Display > Display Time in Regions > Original Time Stamp.

**To hide Original Time Stamps:**
- Select Display > Display Time in Regions > None.

**Creating a User Time Stamp**

If you want to create a separate user-defined SMPTE time stamp, you can use the Time Stamp Selected command in the Regions List pop-up menu. This command allows you to select a region (or regions) and redefine its SMPTE time stamp. The Original Time Stamp and the User-Time Stamp are then stored with your session.

When audio is first recorded, the User Time Stamp will match the Original Time Stamp, but you can change the User Time Stamp at any time using the Time Stamp Selected command.

This feature is particularly useful in post production situations where the SMPTE time code on video “work prints” often changes from one edit revision to another.

**To time stamp a region (or regions) with a new SMPTE frame number:**

1. In a track, select the region that you want to time stamp.
2. From the Audio Regions List pop-up menu, choose the Time Stamp Selected command.

![Image](Image)

**Time Stamp Selected command**

3. Enter a new SMPTE time. You can do this in three ways:
   - Enter the numbers manually (with the help of the arrow keys).
   - or –
   - Click the Current Time Code button (or press the Equal key), if you want to capture the incoming time code address.
   - or –
   - Click the Current Selection button, if you want to enter the start time of the current on-screen selection.
4. Click OK to close this dialog.

This command can be used in “batch mode” to set new time stamps for several regions at a time. To do this, simply select several regions and choose the Time Stamp Selected command. One after another, a dialog will open for each region, allowing you to quickly enter new values.
Once entered, the user time stamps can be displayed in all regions currently placed in tracks.

To display User Time Stamps in regions:
- Choose Display > Display Time in Regions > User Time Stamp.

To hide User Time Stamps:
- Choose Display > Display Time in Regions > None.

Using a Region with its Time Stamp in Another Session

Pro Tools saves time stamp information for each region as part of a session—not as part of the audio file itself. If you want to use a time-stamped audio file in another session, and keep its time stamps intact, do the following:

1. Open the session that contains the original time-stamped region.
2. Select the desired region in the Audio Regions List.
3. Choose Export Selected from the Regions List pop-up menu. The region can now be used in other sessions with its original time stamp references intact.

Identifying a Synchronization Point

The Pro Tools Identify Sync Point command allows you to identify a specific point within a region for audio spotting purposes.

Imagine the following sound effects spotting scenario: You have a single sound effect that consists of a creaky door slamming shut, followed by a few seconds of ambient reverbération. The slam portion of the effect—which you must precisely match to picture—occurs neither at the very beginning of the audio file nor at the very end. It is somewhere in the middle, making it tough to spot.

In this scenario, use the Identify Sync Point command to create a point in the region and synchronize that point to a SMPTE frame.

To create a sync point in a region:
1. Click with the Selector at the point in the region that you want to synchronize to a SMPTE frame location.
   - or -
2. To place the edit cursor during standard playback mode (not Continuous, Playhead, or other), press the Down Arrow key while playing back.
3. Choose Edit > Identify Sync Point. The current SMPTE time is automatically entered as the SMPTE location for the sync point. An arrow indicator appears in the audio region indicating the location of this sync point.

For complete instructions on defining, removing, and editing with Sync points, see “Identifying a Synchronization Point” on page 547.
**Troubleshooting Synchronization**

Getting SMPTE synchronization to work properly can seem like a formidable task at times. The following suggestions may help you troubleshoot and solve common problems.

**Use the Incoming/Current Time Field in the Session Setup Window as a Reference**

The Current Time field in the Session Setup window indicates whether or not Pro Tools is receiving time code. If this field appears to be inactive when inputting time code into your time code reading device, check your hardware device settings, the device’s connection to your computer, and your OMS Setup (Macintosh) or Multimedia Setup (Windows).

**Stripe SMPTE Before You Record**

All tapes in your setup (both audio and video) must be striped with SMPTE Time Code before any audio is recorded onto them or to Pro Tools. If tapes aren’t striped, your system may seem to work, but synchronization will never properly occur. The machines and Pro Tools will drift farther and farther apart the longer they run.

The same problem occurs when audio is recorded into Pro Tools without a resolved SMPTE source (for example, if it was recorded before the current session). The audio cannot be accurately synchronized with an analog tape recorder or video tape deck, since the Pro Tools audio was not recorded referenced to the SMPTE time code from the analog tape deck or video tape deck.

**Resolve All Components of Your System**

When striping time code, make sure that the time code generator and the video record deck are resolved to the same crystal reference. For example, when striping 29.97 Drop Frame time code onto a VTR, both the SMPTE generator and the VTR should be resolved to the same “black burst” or house sync generator. During playback, the master deck should be resolved to “black burst” or house sync.

This convention provides compatibility for your tape between the record and playback passes, and when it’s played back in other facilities on different equipment. This also means that when playing back a tape striped with time code, the playback deck should be resolved to the same synchronization rate as the record deck was resolved to at the time of the striping. When you stripe an audio transport with time code, it should be “free-running” and unresolved, but should be resolved with a house sync-referenced synchronizer during playback.

**Know the True Frame Rate on Your Work Tape**

If you get your video tapes from a production company instead of recording them yourself, be absolutely sure that they indicate the SMPTE frame rate used on the tape correctly.

The Digidesign SYNC I/O (and some third-party products) can be used to determine frame rate. See “Determining SMPTE Frame Rate” on page 525.
Chapter 35: Time Code Synchronization

29.97 fps Non-Drop Rate Can Cause Problems

29.97 fps Non-Drop is a slightly slower version of 30 fps Non-Drop time code. When used with color video, each video frame now matches up with each SMPTE frame without having to use a drop-frame coding. This makes any frame number mathematics much simpler, since no frame numbers are dropped.

Unfortunately, some hardware and software devices do not recognize 29.97 Non-Drop as a separate frame rate. For example, any standard SMPTE-to MTC-converter does not explicitly recognize it. The user must tell the convertor to expect 30 fps Non-Drop instead. In fact, many devices that read SMPTE work acceptably by reading 29.97 Non-Drop if they are set to expect 30 fps Non-Drop.

Any SMPTE reader that uses the time code numbers to make real-time calculations (as Pro Tools does when it tries to trigger and synchronize to SMPTE) also needs to know that the frame format is 29.97 and not 30 fps. Since Pro Tools allows this choice of frame rate this does not really pose a problem. The problem exists because many users cannot readily distinguish 29.97 from 30 fps.

More importantly, some production companies will distribute video work prints striped with 29.97 fps but mark them as “30 fps NTSC,” by which they actually mean 29.97 fps Non-Drop. By the time you get the tape, you may have no idea what’s actually on it. Feeding 29.97 Non-Drop to Pro Tools when it’s set for 30 fps Non-Drop will result in timing errors of about 1.8 frames per minute, causing audio playback to trigger out of sync.

Be Careful When Changing Frame Rates

If you change time code rates in the middle of a session, many SMPTE-to-MIDI Time Code converters need to be turned off and turned on again to be able to recognize the new frame rate.

Use a Consistent Clock Source

When possible, sound files should be played back using the same peripheral it was recorded with, in addition to a house/black burst. This assures the closest match between record and playback sample rates.

On a Macintosh, Disable AppleTalk, Network Connections, Screen Savers, and Power Saving Features

These types of software can cause the Macintosh to ignore MIDI data (such as MIDI Time Code) coming into its serial ports. Make sure AppleTalk is inactive in the Chooser, disconnect AppleTalk cables, and remove any network extensions from your System Folder.

In Windows, Disable Screen Savers and Power Management Features

These types of software can cause your computer to ignore MIDI data (such as MIDI Time Code).
Chapter 36: Working with QuickTime Movies

You can use Pro Tools to import QuickTime movies and audio (such as MP3s), perform audio post production tasks, and export the finished product as a new QuickTime movie.

⚠️ QuickTime movie features in Pro Tools are supported on Macintosh systems only.

About QuickTime

QuickTime is digital video technology designed to produce compact video files for multimedia use.

Using QuickTime Movies in Pro Tools

Pro Tools allows you to import QuickTime movies into your Pro Tools sessions.

Once imported into Pro Tools, a QuickTime movie is displayed in its own Movie track in the Edit window, and in a floating Movie window. This floating window can be viewed on a second monitor with appropriate video hardware (including FireWire output of QuickTime DV). With a QuickTime movie in the session, Pro Tools serves as a fast, random-access visual reference for “sweetening” the movie by adding sound effects, music, foley, dialog, or other audio.

Pro Tools provides precise, frame-accurate audio and video synchronization. This means you can use your Pro Tools system as an off-line audio editing system, leaving the video editing suite free for video editing.

With Pro Tools, you can:
- Import a QuickTime movie into a session
- Import audio from a QuickTime movie (or audio from a CD or a CD-ROM)
- Synchronize audio events to a QuickTime movie, using the Pro Tools editing features to spot and nudge regions to video frames
Scrub audio elements in tandem with a Quick-Time movie

Use the Pro Tools Bounce to Movie command to compile a new “flattened” QuickTime movie file that can be read by any QuickTime-compatible application

If you want to edit or in any other way modify a movie, return to your video capture and assembly environment (for example, Adobe Premiere) for editing, then import the edited movie into Pro Tools.

You can capture Avid-compatible video in Pro Tools with AVoption or AVoption XL.

Video Capture/Playback Cards
For professional applications where full-screen, 25/30 frames-per-second playback is critical, we recommend that you invest in a Digidesign-approved third-party video capture and playback card, or an external DV Firewire device. For the most up-to-date information about such products, contact your Digidesign dealer or visit Digidesign’s Web site.

If You Are New to Audio Post Production
If you are new to digital video, time code, or audio-for-post production, the following suggestions will help you manage your session’s audio and video requirements. Not all of these may apply to every project.

Plan Ahead Think through your entire project before you start capturing your video. For best results when working with SMPTE time code, make sure that time code is burned into a window in the movie. Try to anticipate compatibility and configuration issues that may arise.

Conform Your Movie Be sure to conform your captured QuickTime movie to the desired frame rate. Consult your video capture software’s documentation for information on how to ensure frame-accurate captures. We recommend that you do this to all video captures to ensure accurate playback in Pro Tools.

If your destination is a pulled-down Pro Tools session, this pull down affects QuickTime movie playback speed. You should conform your movie to a 30 fps frame rate for use in a pulled-down session.

Destined for Video or Film? What is the ultimate destination of your work? Is it for DVD, HD, TV, film, audio CD or CD-ROM? This will determine such things as the best sample rate to use, the correct frame rate, pull-down or pull-up rates, and so on. Double-check the time code frame rate. You must make sure that you know the correct frame rate of the video source.

Storage Make sure you have enough disk space on your drive, and optimize your hard drives regularly.

Video Compatibility If you are not digitizing the video material yourself (if the material is already on hard disk) check into the type of video capture and playback system that was used and make sure you can accommodate that format’s compression method. Check whether or not time code is “burned into” or superimposed over a small area of the video.
QuickTime Requirements

Pro Tools supports playback of QuickTime videos without additional hardware. However, performance will vary in terms of maximum movie size, frame rate, and smoothness of playback. Capture of 30/25 fps (frames per second), 60/50 fields-per-second video requires a video capture card, and associated software and hardware.

About Frame Length and QuickTime Movies

Not all video capture software can guarantee consistent frame lengths. Consult your video capture software documentation for information on ensuring frame-accurate captures, and on conforming your video to proper frame boundaries.

To take advantage of Pro Tools QuickTime movie playback capabilities, you will need the following:

- The version of Apple's QuickTime System Extension (included with Pro Tools). To install QuickTime, run the installer included on the Pro Tools Installer CD.
- QuickTime movie playback and editing software (such as Avid DV|Xpress) to edit and compile QuickTime movies.

Optionally, you may also need:

- QuickTime movie capture hardware and software to digitize your own movies from a video tape or video camera source.
- A DVD or CD-ROM drive to take advantage of commercially-available QuickTime movies and sound clips.

Movie Playback Quality Options

Pro Tools supports three options for movie playback performance: Normal Priority Playback, Medium Priority Playback, and Highest Priority Playback. In most cases, you should leave the priority choice set to Normal Priority Playback. If you are running QuickTime Movies natively, that is, without a capture card, you may need to use one of the other playback priority options. If this does not apply to you, leave movie playback priority set to Normal Priority Playback. This is the default setting.

See also “Firewire Playback of QuickTime DV Movies” on page 555.

Hard Drive Tips for Best Performance

For best movie playback performance, make sure that the hard drive you are using for video capture and playback is not on the same SCSI bus as your audio files, if possible. This allows the least amount of interference between drives when Pro Tools requests audio and video data. With most capture cards, and moderate data capture rates (800 kilobytes per second or less), this should provide good performance.

The G4 has an internal IDE system drive. For best performance, audio and video should be stored on SCSI drives, connected to the computer with a Digidesign-approved SCSI interface card.

Some older (pre-G4) Macintosh computers have two SCSI busses, an internal SCSI bus, and a separate external SCSI bus. The internal bus is often a SCSI Fast-compatible bus that can yield better disk performance. The external bus is a narrow SCSI bus, which is slower. For best performance...
use an internal drive that connects to the internal, fast SCSI bus. Contact your Digidesign dealer or visit the Digidesign Web site for compatibility information.

**Importing a QuickTime Movie**

Before you import a movie, you should digitize your video material and know the correct frame rate and sample rate when applicable.

⚠️ If a video card with hardware video compression was used to create the QuickTime movie, Pro Tools cannot play the movie without the compression hardware. Make sure the video card is installed and configured correctly before starting your session.

**To import a QuickTime movie into Pro Tools:**

1. Launch Pro Tools and create a new session, or open an existing one.
2. Check the time code parameters of the session to make sure they match those of the movie you wish to import, and save the session.
3. Choose Movie > Import Movie.
4. Locate the desired movie. When you select a movie in the Import Movie dialog, you can view a preview frame by enabling the Show Preview check box. The preview corresponds to the first frame of the movie. If you have not yet created a preview, you can do so by selecting the desired movie and clicking Update in this dialog.
5. Select the desired movie and click Open. Pro Tools imports the movie and displays it in its own Movie track in the Edit window as well as in a floating Movie window. The first frame of the movie is automatically synchronized to the start time of your session.

**About the Movie Track**

Once a movie is imported into Pro Tools it appears in the Edit window in its own Movie track. This picon (picture-icon) track displays a “thumbnail” overview of the frames of the movie it represents. The Movie track will show greater or lesser detail depending on your current zoom level in the Edit window—the closer in you zoom, the greater the number of individual frames that are displayed in the Movie track; the farther out you zoom, the fewer the number of individual frames that are visible.

The Movie track behaves much as a Pro Tools audio or MIDI track in that you can move the movie region with the Grabber or other editing tools. This allows you to offset the movie to any start point. However, you cannot edit the Movie track by trimming it or capturing regions from within it.

Only one QuickTime movie can be associated with a session at a time. If you want to import a different movie into a session, repeat the previous steps. The new movie will replace the original in the session. A Movie track takes its name from its associated movie file and cannot be independently renamed.
Frames View Performance

When using Frames View to view movie content in the Movie track, your computer may exhibit reduced or sluggish performance. If this happens on your computer, switch the Movie track view to Blocks mode.

You can also hide the movie track to further optimize performance, if necessary.

Firewire Playback of QuickTime DV Movies

With the addition of an external DV transcoder (decoder), you can play QuickTime DV Movies out through your computer’s Firewire port. These can include QuickTime movies exported as QuickTime DV from Avid Xpress DV.

TDM Systems Requires Pro Tools 5.3.1 or later.

LE Systems Requires Pro Tools 6.0 or later.

At the time of this writing, Pro Tools supports the Canopus ADVC-100. This transcoder supports both NTSC and PAL rates, and can record audio simultaneously with video.

For the latest compatibility information on Firewire transcoders, see the Digidesign Web site. For specific information about the Canopus Transcoder, check the Canopus Web site (http://www.canopuscorp.com).

QuickTime DV performance may vary, depending on the specifics of your system and projects.

Supported QuickTime Movies

Referenced and Consolidated Media Exported QuickTime DV movies can be either complete Quicktime files (where media is copied into a Quicktime file) or Quicktime reference files (where just a small composition is in the Quicktime file which references the original DV files).

Codec Requirements When exporting from Avid Xpress DV, always use the Apple DV codec. Do not enable “Use Avid Codec” in the export dialog. If an Avid-codec DV movie is imported into Pro Tools, you will not be able to play it.

DV Stream Movies At the time of this writing, Pro Tools does not support audio from a DV Stream file. DV Stream files contain the entire data stream that’s been transferred or recorded over the FireWire cable from a camera. In this type of file, the audio and video data are stored in an interleaved fashion, as opposed to a QuickTime file where audio and video are stored separately.

See also “Exporting QuickTime DV from Avid” on page 556.

To Play DV Movies through the FireWire Port:

1. Import a QuickTime DV movie into a Pro Tools session by choosing Movie > Import Movie.

2. Choose Movie > Play DV Movie Out Firewire Port.

When this item is enabled, Pro Tools will play DV movies (NTSC or PAL) out the FireWire port to an external DV decoder. This can improve system performance by removing the need for the movie to be software decompressed by the CPU and displayed on the computer screen.
If the desktop Movie Window is open when video is playing out the FireWire port, it will display the text “DV Movie Is Playing Out FireWire Port.”

**Delay Between Video & Audio**

There can be a considerable delay between video and audio playback when using this feature.

**To compensate:**

1. Choose Movie > Set Movie Sync Offset.
2. Enter a value appropriate to align the audio with video.

At the time of this writing, Digidesign has qualified the Canopus ADVC-100 Transcoder. The required offset for this particular device is 22 quarter frames for NTSC, and 18 quarter frames for PAL.

Generally, you will need to set this parameter once for each type of DV decoder used.

**Exporting QuickTime DV from Avid**

The following instructions list export settings for Avid XPressDV. These settings are required to create QuickTime DV movies that can be played back in Pro Tools through the Firewire port.

**To export a QuickTime DV reference movie for Pro Tools Firewire playback, set the following:**

1. Enable the following export options:
   - Flatten video tracks
   - Fill in spaces with black
   - Render all video effects
   - Use Apple DV Codec
   - Enable the Apple DV codec
2. Make sure Use Avid Codec is not enabled.

These export settings can be saved in Avid XPressDV3.0 as a default, simplifying future media exchange. Refer to your Avid XPress documentation for more information on export settings and defaults.

**Scrubbing the Movie Track**

You can use the Scrubber tool to scrub the Movie track with full frame accuracy. If you scrub directly on the Movie track, only the movie will scrub (no audio will play). If you scrub on an audio track, audio and the movie will scrub simultaneously.

![Scrubbing a movie (Pro Tools 5.x shown)](image)

**To scrub the Movie track:**

1. Select the Scrubber tool.
Chapter 36: Working with QuickTime Movies

2 Click the Movie track at the desired point and drag the Scrubber.

To scrub with finer precision, press the Command key while scrubbing

About the Movie Window

The Movie window displays the movie playback or the current frame if playback is paused or stopped. You can drag the Movie window anywhere on your computer screen.

To display the Movie window:

- Choose Window > Show Movie Window. If a movie has already been imported, the Movie window will appear.

See also “Firewire Playback of QuickTime DV Movies” on page 555.

Using a 14-inch Monitor for Playback

If you capture 320 x 240 (NTSC) movies and have a second monitor with 640 x 480 resolution (a standard 14-inch monitor), clicking on the Movie window will route movie playback to that monitor. The Movie will “bounce” over to the second monitor, and will be pixel-doubled so that it takes up the whole screen.

Tips for Optimizing Movie Playback

Since Pro Tools uses QuickTime to play movies, the quality of the playback is dependent on the speed of your Macintosh CPU and hard drive, the size (in pixels) of the movie, and the quality of the video hardware used to capture and play back the digitized video. While QuickTime doesn’t produce broadcast-quality playback, it is frame accurate when spotting to picture.

On PCI-based computers, Pro Tools continuously re-syncs the movie. The movie resolves to the audio sample clock. This allows the movie to smoothly track the audio even when your system is varispeeded.

For more consistently smooth movie playback, here are some suggestions:

- Use a Digidesign-approved video capture and playback card for 25/30 frames-per-second full-screen movie playback.
- Display the movie on a separate monitor driven by a video capture and playback card.
- If you don’t have a video capture and playback card, set the movie playback priority to Medium Priority Playback or High Priority Playback using one of these commands in Movie menu. This gives priority to movie playback, rather than other screen graphics tasks such as moving faders.
- Use the fastest CPU possible.
- Capture and play QuickTime video from a separate hard drive than your Pro Tools audio drives.
- Remove unneeded System Extensions and Control Panels.
- Disable AppleTalk and other background tasks on the CPU, such as File Sharing, screen savers, Calculate Folder Size and any fax or e-mail software.
Pro Tools Reference Guide

◆ Disable the Automation Preference for Faders Move During Playback.
◆ Set No Auto Scrolling in Operations > Scroll Options.
◆ Reduce the size of the Edit window to the smallest possible size.
◆ Close unnecessary windows.
◆ Reduce the overall length of the SCSI chain of your computer system for improved throughput.
◆ Reduce the pixel size of the movie (for example, reduce it from 640 x 480 pixels to 320 x 240 pixels).
◆ Hide the video track when not needed.

**Setting the Movie Start Time (Movie Offset)**

When you import a movie into your session, the first frame of the movie defaults to the start time of the session. In some cases, however, you may need to offset the movie by some amount forwards or backwards so that you can accurately spot audio to the movie.

Since a movie can be moved inside the Movie track, it is fairly easy to match these two times. In fact, you may not have to move the Movie track at all.

For finer adjustment of a movie’s start time, you can use the Set Movie Sync Offset command to offset the movie in 1/4-frame increments. This is more accurate than dragging the Movie track, and is especially useful in cases where your movie track happens to begin with a partial frame.

**To set the movie offset:**
1. Double-check that the session’s SMPTE frame rate matches that of the movie.
2. Choose Movie > Set Movie Sync Offset, enter the desired offset value, and click OK.

   The Movie Sync Offset is always defined in Feet.Frames, regardless of the session time display.

3. Lock the movie in place by choosing Edit > Lock/Unlock Region.

**To spot the movie to a sync point:**
1. Double-check that the session’s SMPTE frame rate matches that of the movie.
2. In the Edit window, enable Grid mode.
3. Set the session time display to SMPTE.
4. Set the Grid Value to Time Code.
5. With the Selector, click in the Movie track to place the cursor where you want to create a Sync Point. Often, the best spot will be the “2 beep” two seconds before the first action frame (the start of the video). You can use the plus and minus keys on the alpha keyboard to nudge the cursor and the movie one frame at a time.
6. Choose Edit > Identify Sync Point to place a Sync Point at the current cursor location.
7. Enable Spot mode by clicking the Spot button in the Edit window.
8. Click the Movie track with the Grabber. The Spot dialog appears.
9. Enter the time code number displayed in the window-burn of the frame you are spotting to (if the movie has a SMPTE time code window burned into it) and click OK to close the Spot dialog.
The movie’s sync point moves to the SMPTE location you entered.

**Spotting Audio to a QuickTime Movie**

For accurate spotting, Grid mode provides you with an effective tool for quick and accurate selection of waveforms, and alignment of regions in tracks. When Grid mode is enabled, the Selector will snap to the current Grid Value, and regions selected with the Grabber and dragged to a track will also align up with the Grid Value.

**Conforming Your Movie**

Before you spot audio to a movie, you should conform the movie file so each frame starts and ends at valid frame boundaries. For example, Adobe Premiere contains a Conform Movie tool for destructively editing the lengths of each frame to the grid of the current frame rate. You should conform the movie to a frame rate that Pro Tools can work with (30 fps or 29.97 fps).

⚠️ **If your destination is a pulled-down Pro Tools session, the pull down affects QuickTime movie playback speed. Conform your movie to a 30 fps frame rate for use in a pulled-down session.**

Consult your video capture software documentation for more information.

**More Tips for Spotting Audio**

- Try to work with a window burn in the movie, since it will help you spot material. You can produce your own window burns for the capture using Digidesign's SYNC I/O.
- Use a continuous scrolling option. Pro Tools includes two scrolling options that are particularly useful in post production: Continuous Scroll During Playback, and Continuous Scroll with Playhead. Enable either of these scrolling options by selecting them from the Operations > Scroll Options submenu.

**Using Grid Mode to Spot and Nudge Regions with Frame Accuracy**

*(TDM Systems Only)*

Grid mode allows you to constrain the movement of regions so that they snap to SMPTE-based measurements (minutes, seconds, frames, or subframes).

**To spot audio to a movie:**

1. Click the Grid button at the upper left corner of the Edit window. This ensures that the audio will align to a frame boundary.
2. Set your Grid Value to Time Code using the pop-up menu.
3. Choose a desirable Grid unit setting. Note that you can set the grid units independently of the Main Time Scale.
4. Using the Selector, place the insertion cursor at the desired location in the movie. If you want, use the Nudge Value pop-up to set the nudge units to frames. You can then use the plus and minus keys on the alpha keyboard to nudge the insertion point frame by frame.
While pressing the Control key, drag the desired region from the Regions List to the appropriate track. Pro Tools will automatically spot the region to the same time location as the cursor.

To spot elements directly to locations in the movie, use the technique described above. In this scenario, Auto Spot mode is not recommended, since it uses incoming MTC for location information.

**Importing QuickTime Audio (and Other Compressed Video Files)**

Pro Tools allows you to import audio directly from a QuickTime movie. You can import audio from a movie currently loaded into a session, or from a different movie. The procedure is the same for both.

Pro Tools supports the following compressed QuickTime file formats:

- MP3
- QDesign
- uLaw 2:1
- aLaw 2:1
- Intel ADPCM
- Microsoft ADPCM
- IMA 4:1
- 32-bit floating point
- 64-bit floating point
- 16-bit Big Endian
- 16-bit Little Endian
- MACE 6:1
- MACE 3:1

QuickTime files can be imported into sessions using either Import Audio from Other Movie or Import Audio from Current Movie menu commands.

**Sample Rate Conversion Quality**

If you import QuickTime audio that was not originally recorded at the session’s sample rate, the sample rate is converted to match the audio to your session. Pro Tools allows you to choose the quality of the sample rate conversion via the Conversion Quality parameter in the Editing Preferences. The higher the quality of sample rate conversion that you choose, the longer it takes to perform the sample rate conversion.

The five conversion settings range from Low to Tweak Head. The Low setting provides results that are considerably better than the Macintosh’s built-in sample rate conversion. For most applications, the Better setting will yield excellent results.

Because the Best and Tweak Head settings take significantly longer than the others, we recommend that you use these only in cases where the highest fidelity is absolutely essential and you have a considerable amount of time. The Tweak Head setting in particular can take several hours to perform sample rate conversion on moderate-length files.

**To set the sample rate conversion quality:**

1. Choose Setups > Preferences and click Editing.
2. Click the Conversion Quality pop-up menu and select the desired setting.
**Importing Audio from a QuickTime Movie**

You can use the Import Audio From Current Movie and Import Audio From Other Movie commands to import audio tracks from a QuickTime movie currently in the session. To import audio from other QuickTime movies on your hard disk or on CD (including Red Book audio CDs), you can also drag and drop tracks from that disc’s DigiBase browser.

**To import audio tracks from a QuickTime movie:**

1. If you want to import audio from a QuickTime movie that is already in the session, choose Movie > Import Audio From Current Movie.
   - or -

   If you want to import audio from a QuickTime movie that has not been imported into the session, choose Movie > Import Audio From Other Movie.

2. Select the QuickTime movie from which you want to import audio. The Track Import dialog appears, listing information about the audio tracks.

3. Select the desired audio tracks by clicking them. To select multiple tracks contiguously in this dialog, Shift-click them. To select discontiguous tracks, Command-click them.

4. Click OK. The audio is converted to the session’s sample rate and bit resolution, and a new region appears in the Audio Regions List for each imported file (2 regions appear for each imported stereo file). The regions are listed in the Audio Regions List with the region name, the number of the originating track, and the number of the region from the track.

5. Drag the imported regions from the Audio Regions List to the desired tracks.

* DigiBase offers additional ways to import audio from CDs with drag and drop. See the DigiBase and DigiBase Pro guide for more information.

---

**Bouncing to a New Movie**

When you have finished your final mix and synchronized your audio events to the movie, you can use the Pro Tools Bounce to Movie command to compile a new QuickTime movie with the bounced audio embedded in the QuickTime movie file as the soundtrack. As a QuickTime file, the new movie is supported by all software applications that support QuickTime video.

**To create a new QuickTime movie with bounced audio embedded as the soundtrack:**

1. Adjust track output levels and finalize your mix. Any inserts and effects settings that are active on tracks will be permanently written to the bounced tracks. If you don’t want to apply a plug-in to the bounce, click the Bypass button in the Plug-In window.

2. Make sure that all of the tracks you want to include in the bounce are audible (not muted).

3. Assign the output of each of the tracks you want to include in the bounce to the same output pair.
4 If you want to bounce the entire session, press the Return to Zero button on the Transport to go to the beginning of the session. The new movie file will include all the video and audio material in the session, even if the duration of the video material is longer than the audio or vice versa. If you only want to bounce a portion of a session, open the Edit window and select the section that you want to include in the bounce.

5 Choose Movie > Bounce to Movie.

6 Select the file format for the movie audio. Choose Mix-to-Mono to combine the left and right channel output of the session to a mono movie soundtrack. Choose Stereo to retain the stereo mix of the session for the movie audio.

7 Select the resolution for the movie audio. Red Book audio CDs are always 16-bit, while many multimedia presentations and CD-ROMs use 8-bit resolution. You cannot create a QuickTime movie with 24-bit audio; audio from 24-bit sessions is converted to 16-bit or 8-bit audio, depending on what you choose.

8 If you intend to convert the session to 8-bit resolution for use in multimedia, use the Squeezer option (click the Convert after Bounce option, then the Settings button to access this feature) to improve the fidelity of the converted 8-bit audio. This option uses a proprietary DSP algorithm that pre processes the audio using compression, limiting and gating before converting to 8-bit resolution. This option is recommend for optimal results.

9 Select the Sample Rate for the movie audio (click the Convert after Bounce option, then the Settings button to access this parameter). The default audio sample rate is 44100 (44.1 kHz), which is the standard sample rate for audio CDs. Multimedia presentations and CD-ROMs may use a sample rate of 11025 (11.025 kHz) or 22050 (22.050 kHz).

10 Click Bounce, name the new movie, and choose where to save it.

11 The audio tracks are converted to the selected sample rate and bit resolution, and a new flattened movie is created incorporating the audio. You can open and play the flattened movie in any software application that supports QuickTime.

いますが、Pro Toolsの音声テープレートとビットレートの変換には大量の処理時間を必要とします。ご使用の環境によりますが、音声テープレートとビットレートの変換品質を下げる選択肢を選択することで、処理時間を節約することができます。
Appendix A: DSP-Induced Delays in Mixing (TDM Only)

In all digital systems, signal processing incurs signal delays of varying amounts. These delays can vary from as short as several microseconds to as long as several milliseconds, depending on the type of processing being performed.

**Delay Factors**

In Pro Tools TDM systems, delay is incurred when you perform the following processes:

**Bouncing Tracks**

**Bus-based Bounces** When you bus a track to another track and record the result, the following delays are incurred:

<table>
<thead>
<tr>
<th>Pro Tools System</th>
<th>Delay</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pro Tools</td>
<td>HD-series (Stereo Mixer)</td>
</tr>
<tr>
<td>Pro Tools</td>
<td>HD-series (Surround Mixer)</td>
</tr>
<tr>
<td>Pro Tools</td>
<td>24 MIX-series</td>
</tr>
<tr>
<td>Pro Tools</td>
<td>24</td>
</tr>
</tbody>
</table>

**Bounce to Disk** The File > Bounce To Disk command causes no delay on a TDM-equipped system since delay compensation for the bounce function is built in. This form of bouncing may be more desirable than bus-based bouncing.
Using Sends

When you send a track to another track and return it to a track (audio, Auxiliary Input, or Master Fader), the following delays are incurred:

**Sends delays for Pro Tools|HD systems**

<table>
<thead>
<tr>
<th>HD Mixer</th>
<th>Sends</th>
<th>Delay</th>
</tr>
</thead>
<tbody>
<tr>
<td>Stereo Mixer</td>
<td>Pre-fader send to bus</td>
<td>10 samples</td>
</tr>
<tr>
<td></td>
<td>Post-fader send to bus</td>
<td>8 samples</td>
</tr>
<tr>
<td>Surround Mixer</td>
<td>Pre-fader send to bus</td>
<td>8 samples</td>
</tr>
<tr>
<td></td>
<td>Post-fader send to bus</td>
<td>12 samples</td>
</tr>
</tbody>
</table>

On the 888/24 I/O, the Digital I/O delay incurred when using AES/EBU or S/PDIF is identical.

**HD-series I/O characteristics**

<table>
<thead>
<tr>
<th>Interface and I/O Port</th>
<th>Surround Mixer</th>
<th>Stereo Mixer</th>
</tr>
</thead>
<tbody>
<tr>
<td>192 I/O or 192 Digital I/O AES/EBU</td>
<td>24 samples</td>
<td>22 samples</td>
</tr>
<tr>
<td>192 I/O Analog</td>
<td>105 samples</td>
<td>103 samples</td>
</tr>
<tr>
<td>96 I/O AES/EBU</td>
<td>21 samples</td>
<td>19 samples</td>
</tr>
<tr>
<td>96 I/O Analog</td>
<td>79 samples</td>
<td>77 samples</td>
</tr>
</tbody>
</table>

Using hardware sends also results in delays, as described below.

Using Plug-In Inserts

Using plug-in inserts on a track can cause additional delay. Refer to your Digirack or Digidesign Plug-Ins Guide.

Using Hardware I/O

When an audio interface is used on an insert or (send), there is delay introduced by going through the D/A and A/D converter pair (for analog devices) or digital I/O connection (for digital devices) on the audio interface.

**I/O characteristics for MIX-series audio interfaces connected to HD Legacy Port**

<table>
<thead>
<tr>
<th>Interface and I/O Port</th>
<th>Surround Mixer</th>
<th>Stereo Mixer</th>
</tr>
</thead>
<tbody>
<tr>
<td>888</td>
<td>24 AES/EBU</td>
<td>18 samples</td>
</tr>
<tr>
<td>888</td>
<td>24 Analog</td>
<td>82 samples</td>
</tr>
<tr>
<td>888</td>
<td>20 AES/EBU</td>
<td>20 samples</td>
</tr>
<tr>
<td>888</td>
<td>20 Analog</td>
<td>18 samples</td>
</tr>
<tr>
<td>ADAT Bridge Optical</td>
<td>18 samples</td>
<td>16 samples</td>
</tr>
<tr>
<td>ADAT Bridge S/PDIF</td>
<td>76 samples</td>
<td>74 samples</td>
</tr>
<tr>
<td>1622 Optical</td>
<td>18</td>
<td>16 samples</td>
</tr>
<tr>
<td>1622 S/PDIF</td>
<td>76</td>
<td>74 samples</td>
</tr>
</tbody>
</table>
Compensating for Delays

If you want to compensate for offsets incurred by these delays, there are different methods you can use: Apply sample-level delay to tracks with the TimeAdjuster plug-in, physically adjust tracks in the Edit window by the appropriate number of samples, or use the same plug-ins on all tracks.

Using the TimeAdjuster Plug-In

You can use the TimeAdjuster TDM plug-in provided with your Pro Tools system to apply an exact number of samples of delay to the signal path of the tracks you are working with. Up to 2048 samples of delay are available.

Digidesign TDM plug-ins display their delay values in the track Channel Delay Indicators in the Mix window. TimeAdjuster can be used to match these delay values for tracks that need to remain in phase (such as instruments recorded with multiple microphones or stereo pairs).

In the Mix window, Command-click (Macintosh) or Control-click (Windows) the track’s Level Indicator to toggle between Level (which appears on the display as “vol”), Peak (“pk”) and Channel Delay (“dly”) indications. Delay values are shown in samples.

To use TimeAdjuster to compensate for a time delay:

1. Apply the TimeAdjuster plug-in to the track whose delay you want to increase, and Command-click (Macintosh) or Control-click (Windows) its Level Indicator until the Channel Delay value is displayed for that track.

2. Change the delay time in TimeAdjuster by moving the Delay slider or entering a value in the Delay field, until the track delay value matches that of the first track.

You can test the delay values by duplicating an audio track and reversing its phase while compensating for delay.

If you are using a plug-in whose delay factor you are not familiar with, you can set the delay by ear using one of two methods:

◆ If you are working with phase-coherent track pairs, or tracks that had been multi-miked, you can “null out” the delay. Invert the phase of the target track using the TimeAdjuster Phase Invert button, and adjust the plug-in delay time until the signal disappears. (When they are perfectly synchronized, duplicate signals of opposite polarity cancel each other out.) When you are finished, disengage the Phase Invert button.

◆ You can also change the delay while listening to the signal in phase, adjusting until any comb-filter effects cancel out.

| I/O characteristics for MIX-series audio interfaces connected to MIX-series systems |
|----------------------------------|-----------------|-----------------|
| Interface                        | A/D/A delay     | Digital I/O     |
| 888|24 I/O                          | 81 samples      | 17 samples      |
| 882|20 I/O                          | 75 samples      | 17 samples      |
| 1622 I/O                          | 75 samples      | 17 samples      |
Nudging Audio Tracks

On audio tracks, you can use the Pro Tools Nudge feature to nudge the affected regions in single-sample (or other) increments, to preserve phase coherency. If it is necessary to nudge a region by a large number of samples, you may want to calculate the equivalent value in milliseconds and nudge the Region in millisecond increments. If the value doesn’t divide evenly, you can switch the Nudge value back to samples and use these smaller increments for the remainder.

The disadvantage of using this method is that it only works with disk tracks (not live inputs), and the timing relationship between tracks is permanently altered, which can affect editing.

Sample Rate and How it Affects Delay

The delay in samples caused by TDM processing is the same regardless of the sample rate because a sample is tied to the rate of the sample clock for the entire system. However, when samples are converted into a time value (milliseconds or microseconds), the sample rate (44.1 versus 48 kHz) must be taken into account.
Appendix B: TDM Mixing and DSP Usage

Understand the Benefits of TDM II

Digidesign’s TDM (or time division multiplexing) technology is based on the concept of a single, high-speed data highway, or bus that transmits data between your Pro Tools CPU, Pro Tools cards, and the DSP chips on the cards.

Pro Tools 24, and Pro Tools 24 MIX-series cards feature Digidesign’s original TDM bus design. Pro Tools HD-series cards feature Digidesign’s new and enhanced TDM II architecture. The TDM II architecture provides many advantages over the original TDM architecture in terms of its mixing capacity and flexibility.

With both systems, individual channels from sources such as disk tracks, sends, or busses are sent out from Pro Tools audio cards, and combined together or multiplexed onto the TDM bus so that all signals can travel simultaneously and can be accessed within a single sample period.

At the receiving end, the audio cards can listen to any connection on the bus, and take whatever data they need.

The TDM bus runs fast enough to accommodate many audio signals at the same time. Each separate audio signal or stream, takes up a single time slot on this multiplexed bus.

One of most powerful features of the TDM architecture is that a single time slot can be used to “broadcast” data to many destinations simultaneously. With TDM II, not only can it send data to many destinations simultaneously, but it can also send signals both bi-directionally and “privately” between DSP chips, which effectively provides a much greater number of available time slots. This provides a greater potential number of connections for routing, processing and mixing audio signals within Pro Tools.

The examples that follow illustrate how the original TDM I bus and TDM II differ in their handling of data.
TDM (or TDM I)

The TDM I architecture has a single bus where every DSP within the entire TDM system shares a single pool of 256 time slots. See Figure 43.

In practice, this means, for example, that if a disk track has a ReverbOne plug-in insert, one of the 256 time slots is used to connect the engine DSP on one chip to the ReverbOne plug-in DSP on another chip. The TDM time slot used comes from the pool of 256 time slots, and is unavailable for use by the rest of the system.

TDM II

With TDM II, there is a separate TDM I/O bus between each DSP chip on the Pro Tools cards, each with up to 512 bi-directional time slots at a session sample rate of 44.1 or 48 kHz (both between DSPs on each card, and between the DSPs that communicate between cards). The DSP chips are arranged serially, with a TDM I/O bus connecting one chip to the next. This means that every TDM II connection need only use time slots between the two DSPs that are being connected. See Figure 44 on page 569.

So, using the same example as above, if a disk track has a ReverbOne plug-in insert, a time slot is used between the Engine DSP (sending out the disk track) and the DSP with the ReverbOne instance. If the ReverbOne insert is handled by a DSP that is physically next to the DSP handling mixing tasks, as shown in the illustration below, this leaves time slot 2 available for use between DSP 3 through DSP 9, and subsequent HD cards.
Another example of how TDM II is more efficient than TDM I is to imagine a single HD Core card with one Engine chip and two Mixer chips. The DSPs with plug-in instances associated with the first Mixer don’t need to communicate with the second Mixer, therefore the time slot numbers used can be re-used by the second Mixer to communicate with other DSPs loaded with other plug-ins.

**DSP Allocation**

*(TDM Systems Only)*

Digital Signal Processing (or DSP) capability is one of the most powerful elements of your system. The DSP chips in your system provide the real-time processing power for your TDM Mixer and plug-ins. There is a limit, depending on your system, to how many functions a single DSP chip can power at once. This section contains some guidelines for getting the most from your available DSP capacity.

### DSP Allocation Basics

As in the analog world, every send bus or output mix that you use demands that a summing mixer exist for that group. On an analog console, the number of these summing mixers is fixed by the physical layout of the console. In the Pro Tools mix environment, this number is variable, and depends on the number of output mixes or sends that you choose to create.

Pro Tools allocates DSP power as it is needed to build the mixers for each session.

We refer to certain mixing or signal processing functions as “using one DSP” or “using two DSPs.” This refers to the fact that there are a certain number of DSP chips on a card, as follows:

**DSP chips on a TDM card**

<table>
<thead>
<tr>
<th>TDM System</th>
<th>Card</th>
<th>Chips</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pro Tools HD-series</td>
<td>HD Core or HD Process</td>
<td>9</td>
</tr>
<tr>
<td>Pro Tools MIX-series</td>
<td>MIX Core, or MIX Card</td>
<td>6</td>
</tr>
<tr>
<td>Pro Tools</td>
<td>24</td>
<td>DSP Farm</td>
</tr>
</tbody>
</table>
Each chip on a card can only power a certain number of processing functions. If you have a single HD card, MIX card or DSP Farm card, and you create a big enough TDM mixer and use enough sends or plug-ins, you will eventually use up or “max out” all DSPs.

**Mixing and DSP Usage**

Pro Tools builds a TDM mixer every time a session is opened. Note that the term “mixer channel” applies to audio tracks (total voiceable tracks) and Auxiliary Input tracks, as well as sends and returns that use any of the 64 TDM internal busses. When you go beyond a certain number of mixer channels, Pro Tools will use another DSP to create additional mixer capacity.

Master Faders do not use additional DSP power.

With Pro Tools|24 systems, Pro Tools does not always automatically free up all unused DSP power when you delete an unneeded mixer channel. On these systems, to reclaim all DSP power after a change in your session configuration, close your session and reopen it. Pro Tools will rebuild your new mixer configuration to use DSP power with maximum efficiency.

**DSP Manager**

*(Pro Tools HD-series and MIX-series Systems Only)*

Pro Tools software (version 4.3 and higher) includes DSP Manager, a software component that optimizes the use of DSP capacity on Pro Tools HD-series and MIX-series systems.

When you have an HD (or MIX) card in your system, if your current DSP usage is approaching the capacity of the card, and you then try to add a mixer channel or assign a plug-in, the DSP Manager will automatically try to make room for the new mixer or plug-in on the HD (or MIX) card. It does this by reallocating the existing TDM mixers and plug-ins to use the available DSP capacity on the HD (or MIX) card as efficiently as possible.

**Monitoring DSP Usage**

To monitor the usage of DSP resources during a Pro Tools session, choose Windows > Show System Usage.

To display DSP resources in different formats, choose Display > System Usage Window Shows and choose a format from the Display menu.

As you allocate DSP to mixing or processing with plug-ins, the System Usage window indicates when DSP chips are available and when they are in use. Green indicates a chip is free. Red indicates a chip is in use.
The Detailed and Gas Gauge formats show the percentage of each DSP chip in use.

With these indicators as your guide, you can try different mixer setups and different arrangements of plug-ins, sends, and Auxiliary Inputs to maximize your use of available DSP power.

Another feature available for DSP management is Active and Inactive switching. See “Active and Inactive Items” on page 16.

**Setting up Sessions to use DSP Efficiently**

The dynamically configurable mixing environment in Pro Tools lets you make choices based on the type of setup you want to have—such as how many inputs you want for your mixer, how many plug-ins you want to use, or how many sends you need.

For example, you could allocate all of your DSP power to create a large mixer with dozens of channels—but you wouldn’t be able to use as many busses, sends, or TDM plug-ins. Alternatively, you could create a mixer with a smaller number of mixer channels plus some sends and Auxiliary Inputs for returns, and TDM plug-ins on several tracks.

![System Usage Window showing Gas Gauge format](image)

RTAS (Real-Time AudioSuite) plug-ins, as well as AudioSuite plug-ins, do not use DSP and are always available. Refer to your DigiRack Plug-Ins Guide for more information.

You can set up your session by choosing one of the session templates supplied with your system as a starting point, or by building it from scratch. If you are starting from scratch, a good rule of thumb is to start by building your mixer first, since at least one of the DSPs in your system is automatically dedicated to mixing. Start with audio tracks, then add sends and Auxiliary Inputs, and finally add plug-ins as available DSP allows. Master Faders do not use additional DSP power.

**DSP Usage with TDM Mixers**

**Understanding Mixers**

Pro Tools TDM Systems include two mixer plug-in “flavors”: stereo and surround versions. The mixer plug-ins are used by Pro Tools to create “dynamic mixers,” meaning that the mixer size can expand or contract as mix channels are added or deleted in Pro Tools. More channels take up more DSP power from your Pro Tools HD-series or Pro Tools MIX-series hardware. This is different from hardware mixing consoles where hardware (analog or digital) creates “fixed” mix configurations consisting of a unchangeable number of master outputs, busses or sends.

DSP allocation for mixing in a Pro Tools TDM system is based on the concept of DSP summing mixers. Every send bus or output mix that you use requires that a summing mixer exist for...
those signals. Every single signal path that is mixed together requires the use of a mixer plug-in (whether a main output that goes to hardware, a bus or a send). This is even true for an individual signal that travels from hard disk to an individual hardware output. These individual dynamic mixers are created using the appropriate TDM mixer plug-in (stereo or surround) that is installed in your Plug-Ins folder.

An “input” can be a disk track, a send, or an internal bus connection. Adding an output or bus path (mono or multi-channel) adds the requirement for DSP power to mix the signals together.

An HD card has nine DSPs, a MIX card has six DSP chips, and a DSP Farm card has four DSP chips, each of which can power a certain number of signal processing tasks. DSP resources are dynamically allocated as the number of mixers and inputs increases.

The TDM mixer provides basic building blocks by which applications such as Pro Tools can create a wide variety of mixer configurations.

**Mono and Stereo**

Each TDM mono or stereo mixer is of the dimensions “N x 2,” meaning that it mixes a variable number of inputs to an output pair. For example: a session with six tracks routed to Output 1–2 would require a single 6 x 2 mixer. If one of the tracks is assigned to Output 3–4, however, two mixers are required—one 5x2 mixer routed to Output 1–2, and one 1x2 mixer routed to Output 3–4.

**Multichannel Surround**

Each Surround mixer can have a variable number of outputs as well as a variable number of inputs. For example, the 7.1 format requires eight outputs. A single mono track assigned to a 7.1 Output or Bus path would require a 1x8 mixer, while one mono and one stereo track would require a 3x8 mixer.

The important concept here is that every output (whether they are I/O or bus outputs) requires that a mixer exists for that output. This means that creating a send to bus 1 requires that a mixer be created for the bus 1–2 outputs, and that mixer will have one input.

**Mixing with Sends and Busses**

Each send will add an input to the destination output pair. For example, a send to output 1 will add another input to the output 1–2 mixer. If the send destination doesn’t already have a mixer for its output pair, then a new mixer will be created. A send to bus 3 will make a 1x2 mixer for bus 3 if no other bus 3 sources have been created yet.

In addition, adding a new track and assigning its input to a bus source will create a mixer for that bus pair if there isn’t one already. For example, creating a new Auxiliary Input track and setting its input to bus 5 will create a 1x2 mixer for bus 5, even if no sources have been created yet.
**Submixing**

When the number of channels that must be mixed exceeds the capacity of a single DSP, additional “main” mixers are created automatically, along with summing submixers (which sum together the “main” mixers). The use of submixers allows large mix configurations to be created.

For example, on a Pro Tools HD-series system, when a Stereo mixer running at 44.1 kHz needs to grow to more than 68 inputs, a submixer is created along with another “main mixer” that provides “n” number of inputs beyond 68. Both the original 68x2 mixer and the new “N x 2” mixer which provides additional inputs are routed to a submixer, and its outputs are finally sent to the desired destination (such as Output 1-2 on your main audio interface).

Note that any small delays (on the order of a few samples) that are created remain equal between these main mixers because they are summed together via submixers, and are not cascaded.

The total number of voiceable tracks supported by your particular Pro Tools configuration will ultimately determine the maximum number of channels for your TDM mixer.

**Mixers and DSP Hardware**

Different mixer plug-ins are available, each of which uses DSP power at slightly different rates on the different audio cards (and their DSP chips), as shown in the following tables.

See also “TDM Mixer Plug-Ins” on page 577.

In Pro Tools HD-series systems, additional mixers are available, based on session sample rate.

**HD Card, default Standard mixers**

<table>
<thead>
<tr>
<th>Mixer</th>
<th>Sample Rate (kHz)</th>
<th>Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td>Stereo</td>
<td>44.1, 48</td>
<td>68x2</td>
</tr>
<tr>
<td></td>
<td>88.2, 96</td>
<td>44x2</td>
</tr>
<tr>
<td></td>
<td>176.4, 192</td>
<td>16x2</td>
</tr>
<tr>
<td>Surround, 5.1</td>
<td>44.1, 48</td>
<td>22x6</td>
</tr>
<tr>
<td></td>
<td>88.2, 96</td>
<td>12x6</td>
</tr>
<tr>
<td></td>
<td>176.4, 192</td>
<td>4x6</td>
</tr>
<tr>
<td>Surround, 7.1</td>
<td>44.1, 48</td>
<td>16x8</td>
</tr>
<tr>
<td></td>
<td>88.2, 96</td>
<td>8x8</td>
</tr>
<tr>
<td></td>
<td>176.4, 192</td>
<td>2x8</td>
</tr>
</tbody>
</table>

**HD Card, Dithered mixers**

<table>
<thead>
<tr>
<th>Mixer</th>
<th>Sample Rate (kHz)</th>
<th>Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td>Stereo Dithered</td>
<td>44.1, 48</td>
<td>56x2</td>
</tr>
<tr>
<td></td>
<td>88.2, 96</td>
<td>34x2</td>
</tr>
<tr>
<td></td>
<td>176.4, 192</td>
<td>14x2</td>
</tr>
<tr>
<td>Surround Dithered, 5.1</td>
<td>44.1, 48</td>
<td>19x6</td>
</tr>
<tr>
<td></td>
<td>88.2, 96</td>
<td>10x6</td>
</tr>
<tr>
<td></td>
<td>176.4, 192</td>
<td>1x6</td>
</tr>
<tr>
<td>Surround Dithered, 7.1</td>
<td>44.1, 48</td>
<td>15x8</td>
</tr>
<tr>
<td></td>
<td>88.2, 96</td>
<td>7x8</td>
</tr>
<tr>
<td></td>
<td>176.4, 192</td>
<td>not supported</td>
</tr>
</tbody>
</table>
I/O
(Pro Tools MIX-Series and Pro Tools|24 Only)

If the DSP is also being used for I/O processing, then some of the chip’s capacity will be devoted to I/O, yielding slightly lower mixer count (these figures represent maximum numbers when I/O is declared in the Hardware Setup dialog):

<table>
<thead>
<tr>
<th>Mixer</th>
<th>Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td>16-bit &amp; 24-bit optimized, mono</td>
<td>59x2 per chip</td>
</tr>
<tr>
<td>16-bit &amp; 24-bit optimized, stereo</td>
<td>29x2 per chip</td>
</tr>
<tr>
<td>Surround, 5.1</td>
<td>17x6 per chip</td>
</tr>
<tr>
<td>Surround, 7.1</td>
<td>12x8 per chip</td>
</tr>
</tbody>
</table>

Usage with other Surround mixer versions varies with the number of channels in each format.

DSP Farm with one I/O Declared

<table>
<thead>
<tr>
<th>Mixer</th>
<th>Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td>16-bit optimized mono</td>
<td>30x2 per chip</td>
</tr>
<tr>
<td>16-bit optimized stereo</td>
<td>15x2 per chip</td>
</tr>
<tr>
<td>24-bit optimized mono</td>
<td>20x2 per chip</td>
</tr>
<tr>
<td>24-bit optimized stereo</td>
<td>10x2 per chip</td>
</tr>
</tbody>
</table>

Note: The Surround mixer cannot run on DSP Farms, or any DSP that has I/O declared.

MIX Card

<table>
<thead>
<tr>
<th>Mixer</th>
<th>Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td>16-bit &amp; 24-bit optimized, mono</td>
<td>50x2 per chip</td>
</tr>
<tr>
<td>16-bit &amp; 24-bit optimized, stereo</td>
<td>25x2 per chip</td>
</tr>
</tbody>
</table>

Note: The Surround mixer cannot run on a MIX card with I/O declared.

MIX Card with one I/O declared

<table>
<thead>
<tr>
<th>Mixer</th>
<th>Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td>16-bit &amp; 24-bit optimized, mono</td>
<td>43x2 per chip</td>
</tr>
<tr>
<td>16-bit &amp; 24-bit optimized, stereo</td>
<td>21x2 per chip</td>
</tr>
</tbody>
</table>

Note: The Surround mixer cannot run on a MIX card with I/O declared.

MIX Card with two I/Os declared

<table>
<thead>
<tr>
<th>Mixer</th>
<th>Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td>16-bit &amp; 24-bit optimized, mono</td>
<td>51x2 per chip</td>
</tr>
<tr>
<td>16-bit &amp; 24-bit optimized, stereo</td>
<td>25x2 per chip</td>
</tr>
</tbody>
</table>

Note: The Surround mixer cannot run on a MIX card with I/O declared.

48-Bit Mixing Precision

The Pro Tools mixer plug-ins use a register area inside of the DSPs on the hardware to hold a full 48-bits of precision when mixing signals together. This allows a fader to be lowered in level without any loss of resolution. (Even if the fader is lowered almost to the bottom, all 24 of the original 24 bits of the signal are preserved.)

Mixer Headroom

Use of 48-bit precision when mixing allows the mixer to be designed to provide a very large amount of headroom, which allows the faders on the Pro Tools mixer to be placed in the “sweet spot” position without clipping. This is similar to working with high-quality professional analog mixing consoles.
Mixer plug-ins provided with Pro Tools HD-series systems provide 48-bit precision with 48 dB of headroom. This means that on the “input” side of the bus (where signals are summed together) signals can never clip (even if channel faders are set to a full +6 dB of gain).

However, the “output” side of the summing mixer (where the signal is sent in the 24-bit world of a digital output or onto the TDM bus) can clip. You can use a Master fader (which does not “cost” any DSP) to scale the output level of any mix summing point (a bus or physical output). The master fader’s meters will tell you if you are clipping the mix bus, and the fader can be used to safely scale the level to avoid clipping, with no loss of quality.

Pro Tools MIX-series systems are supplied with two mixers, a stereo 24-bit Optimized version and a Surround mixer. These mixers are almost identical to those supplied with Pro Tools HD-series systems, but they provide only 30 dB of headroom (while still maintaining 48 bits of precision). Since Pro Tools MIX-series systems cannot mix as many disk or auxiliary tracks as Pro Tools HD-series systems, less headroom is needed to avoid clipping, and this is generally not a cause for concern.

24-Bit Optimized Mixer
(Pro Tools MIX-Series and Pro Tools|24 Only)

With the 24-bit Optimized Mixer, the Master Fader meters indicate clipping at both the input summing stage and the output level stage at all times. With this mixer, you could lower the Master Fader to reduce your output level, but the Master Fader meters could still indicate clipping at the input stage.

In the unlikely event that this occurs—this mixer’s 30 dB of headroom will allow many signals to be mixed without any input clipping—simply follow the procedure to trim back your faders, as described in “Trimming Input Summing Levels” on page 576.

16-bit Optimized Mixer
(Pro Tools MIX-Series and Pro Tools|24 Only)

With the 16-bit Optimized Mixer, the Master Fader meters indicate clipping only for the output level stage of the mixer. With this mixer, you could lower the Master Fader to reduce your output level, but any clipping at the input stage would not be indicated.

If reducing the output level has no effect on clipping, it could be occurring in one of the following places:

- At the input summing stage. To prevent clipping at the input stage, trim the input summing levels.
- At an insert on the Master Fader. If you are using a plug-in on the Master Fader, its meters show the levels on the insert. To prevent clipping at the insert, trim levels on any plug-ins or Hardware inserts on the Master Fader.
Trimming Input Summing Levels

With many inputs that contain high-level signals, it is possible to clip the input summing stage of a MIX-series mixer plug-in. This could easily happen with the 16-bit Optimized Mixer, but is very much less likely to occur with the 24-bit Optimized Mixer because of its 30dB of headroom.

To reduce the levels going into the input summing stage of the Mixer plug-in, lower the fader levels of all track faders using the All Mix/Edit group. If you are using mix automation, you will need to use Automation Trim mode or the Trim tool to lower the overall volume of all tracks until the levels are low enough to avoid overloading the mixer input. You can see this clearly by using a Master Fader for that mixer sum point, and examining its meter.

Note that clipping the “input” side of a mixer is not a concern on Pro Tools HD-series systems. It is virtually impossible to clip the input of any HD-series mixer plug-in, because the 48 dB of headroom provided prevents any possibility of overload, even with a maximum number of inputs being fed by full-code signals with fader gains at maximum. While it is possible to clip the “output” side of the mixer, you can safely use a Master Fader to trim your mix bus back to avoid clipping (by simply examining the Master Fader meter for clipping, and pulling back the fader until it disappears; make sure that any plug-ins you may have on the Master Fader inserts are not the cause as well). The 48-bit precision of the mixer allows gain adjustment on the Master Fader with no loss of data integrity or audio quality, so there is no need to trim the individual input faders back to avoid clipping.

Mixer Automation

Volume automation on all versions of the mixers is near sample-accurate (as is pan automation on the stereo versions). In addition, DAE provides 24-bit interpolated values between mix breakpoints, which provides near “analog-like” resolution. This process of interpolation means that a smooth “data series” is created between any two breakpoints that you specify in Pro Tools. DAE calculates these smooth transitions on the DSP hardware with 24-bit precision, which provides extremely smooth volume changes. In addition, DAE “de-zippers” any “live input” to the mixer so that fast, real-time fader changes that come in from fader movements (on the Pro Tool user interface or control surfaces), do not cause audible artifacts as the mixer tries to “catch up” to fast changes that it receives.

Stereo and Surround Dithered Mixers

The Stereo Dithered and Surround Dithered mixer plug-ins provide non-correlated dither in addition to other basic attributes of the mixers described above. Every output summing point (whether to an internal bus or an physical output) is dithered in these mixers. This technique is used to avoid any possibility of audible artifacts caused by truncation of extremely low level data that occurs when signals pass from the 48-bit world of a TDM mixer to the 24-bit world of a TDM bus connection or a hardware output. Any material that is truncated, lies below –144 dBFS (reflecting 24-bit of dynamic range).
There is dissension in the audio community as to whether or not artifacts that fall within this area are actually audible in some way. (The normal dynamic range of human hearing is generally accepted to fall within a range of around 120 dB, from the threshold of audibility to the threshold of pain.)

Digidesign has developed a mixer that provides all of the benefits of the standard mixer plug-ins, but also provide uncorrelated dither on any summed output. This provides a steady dither “noise floor” at extremely low level, which causes any truncation artifacts to be converted into steady white noise. However, the addition of uncorrelated dither requires more DSP horsepower. As a result, the channel instance count from the dithered versions of the mixers is around 15% lower (or more) than the non-dithered standard versions (this varies with sample rate and mixer type).

For this reason, we offer both types of mixer plug-in. You may wish to use the standard mixer in most applications because of its greater efficiency (allowing you to mix more channels without running out of DSP power), or the dithered mixer because of its theoretical advantages.

**A Note About Dithering to 16-Bit and Dither Plug-Ins**

The Dithered mixers provide 24-bit dither at their summing points. When creating a final mix that results to 16-bits (for example, for CD mastering), final dithering should still be handled by plug-ins that provide dither (such as the Digidesign standard or POWr Dither Plug-Ins). A plug-in of this type is inserted on the post-fader inserts of a Master fader to properly dither the final mix result. Details about dither and proper usage of the dither plug-ins can be found in the DigiRack Guide.

**TDM Mixer Plug-Ins**

*(TDM Systems Only)*


In most cases, the Mixer plug-in that was automatically installed with your system is the best one for all around use. The Mixer plug-in that is installed depends on which Pro Tools system you have:

**Pro Tools HD-Series Systems Only** The Stereo and Surround Mixer plug-ins are installed by default. When you run your Pro Tools Installer, a copy of the Stereo Dithered and Surround Dithered mixers are placed in the folder “Plug-Ins (Unused).”

**Pro Tools MIX-Series Systems Only** The 24-bit Optimized Mixer and Surround Mixer plug-ins are installed by default. When you run your Pro Tools Installer, a copy of the 16-bit Optimized Mixer is placed in the folder “Plug-Ins (Unused).”

**Pro Tools|24 Systems Only** The 24-bit Optimized Mixer is installed by default. When you run the Pro Tools Installer, a copy of the 16-bit Optimized Mixer is placed in the folder “Plug-Ins (Unused).”
Plug-In Features

Standard Surround and Stereo Mixers
(Pro Tools HD-Series Only)
Both the Surround and Stereo Mixer plug-ins provide the following:
• 24-bit digital output, from an audio interface output or Bounce to Disk. Mix level scaling stores 48-bit results, using a 56-bit accumulator for maximum precision.
• 48 dB of mix headroom.
• Output clip indication.
• Multichannel mixing formats for surround (available with the Surround Mixer).

Surround Dithered and Stereo Dithered Mixers
(Pro Tools HD-Series Only)
Both the Surround and Stereo Mixer plug-ins provide the following:
• The same features as the standard HD Stereo and Surround mixers, with the addition of non-correlated dither to any output or bus send.

Surround and 24-Bit Optimized Mixer
(Pro Tools MIX-Series and Pro Tools|24 Only)
Both the 24-bit Optimized Mixer and the Surround Mixer plug-ins provide the following:
• Optimized performance for recording and mixing 24-bit audio.
• 24-bit digital output, from an audio interface output or Bounce to Disk. Mixing level scaling stores 48-bit results, using a 56-bit accumulator for maximum precision.
• 30 dB of mix headroom.
• Input and Output clip indication: Master Fader meters simultaneously indicate clipping at both the input summing stage and the output level stage.
• Multichannel mixing formats for surround (available with the Surround Mixer on Pro Tools MIX-series systems only).

16-bit Optimized Mixer
(Pro Tools MIX-Series and Pro Tools|24 Only)
The 16-bit Optimized Mixer provides:
• Optimized performance for recording and mixing 16-bit audio.
• 24-bit digital output mix result from an audio interface output, or when bouncing to disk
• More mixing channels (On TDM systems, 36 x 2 mixing channels can be created per DSP)
• 18 dB of mix headroom.
• Output clip indication: Master Fader meters indicate clipping at the input summing stage only.

Switching TDM Mixer Plug-Ins

To Switch TDM mixer plug-ins:
1. Quit Pro Tools.
2. Open the DAE Folder. The DAE folder is installed at the root level of the System Folder.
3. Open the “Plug-Ins (Unused)” folder, locate the Mixer plug-in that you want to use, and drag it to the Plug-Ins folder.
4. Open the Plug-Ins folder, locate the mixer plug-in version that you no longer wish to use, and drag it to the “Plug-Ins (Unused)” folder.
5. Launch Pro Tools.
**Mixer Usage Guidelines**

The following conditions apply to mixing with Pro Tools TDM systems.

- One DSP chip is automatically dedicated to mixing in the TDM environment.
- As you reach the basic mixer limits for a single DSP chip, the system will automatically begin allocating DSP resources from another chip (if available), making it unavailable for plug-ins.
- Each bus or send connection requires DSP to mix signals. This means that each send or Auxiliary Input that you create will require DSP power to mix the results.
- On Pro Tools|24 systems, the 16-bit Optimized Mixer can power more channels per DSP chip than the 24-bit Optimized Mixer plug-in. There may be cases where using the 16-bit Optimized mixer will help conserve enough DSP power to allow for additional plug-ins.

On Pro Tools|24 MIX systems, there is no advantage to using the 16-bit Optimized mixer, so you should always use either the Surround mixer, or the 24-bit Optimized mixer.

**DSP Usage with TDM Plug-Ins**

Some basic guidelines for DSP usage on Pro Tools systems follow:

- TDM-equipped systems running Pro Tools 4.3 or higher software use Digidesign’s MultiShell technology, that lets any MultiShell compatible plug-in share DSP chips on both HD Core and Process cards (in a Pro Tools HD-series system), or both MIX cards and DSP Farm cards (in a MIX-series system). Up to five types of MultiShell compatible plug-ins can share a single DSP chip.

Refer to the DigiRack Plug-Ins Guide for details on MultiShell plug-ins.

- Stereo DSP plug-ins generally use up twice as much DSP as mono plug-ins.
- Master Faders don’t require additional DSP. Use them freely to control submix levels, send/bus output levels, and the master output level of your session.

The session templates provided with your system include several useful preconfigured session setups that make efficient use of DSP resources.

If your computer has unused slots, you can always increase your available DSP resources by adding additional HD Process cards (to a Pro Tools HD-series system), or MIX Farm or DSP Farm cards (to a Pro Tools MIX-series system or Pro Tools|24 system).
DSP Usage and I/O Allocation

On TDM-equipped Pro Tools systems with a single audio interface, at least one DSP chip on your HD card (Pro Tools HD-series systems), MIX card (Pro Tools|24 MIX systems) or DSP Farm (Pro Tools|24) is automatically allocated to mixing and input and output tasks. See “Mixing with Sends and Busses” on page 572 for specifics.

Even though this is only a small portion of the DSP power available on the chip, it effectively dedicates the entire chip to mixing tasks, making it unavailable for plug-ins.

If you have an additional audio interface assigned to an HD Process, MIX Farm, or DSP Farm card, Pro Tools will use a DSP chip on that card for mixing and I/O tasks as well.

If you are not currently using your additional interface, you can free up DSP and use it for additional plug-ins.

To reallocate I/O capacity on an HD Process, MIX Farm, or DSP Farm card:

2. From the Card pop-up menu, select the HD Process, MIX Farm or DSP Farm whose DSP you want to reallocate.
3. From the Interface pop-up, select No Interface.
4. Click OK to close this dialog.

When the session reopens, the DSP that was allocated to I/O is available for mixing or plug-ins.
Appendix C: Troubleshooting

**Back Up Your Work**

It is highly recommended that you back up your work on a regular basis, and especially before making changes to your system configuration.

**Back Up Your Session Data**

Back up your session and audio data frequently. There are a variety of media that are suited to back up projects of various sizes, from automated tape backup systems to high-capacity optical drives, to desktop CD-R burners.

The best way to back up a session is to use the Save Session Copy In command to save the session file and all of its associated files to a new location.

**Back Up Your System Setup**

- **Macintosh** Back up your System Folder after you install Pro Tools software.
- **Windows** Create a system recovery disk after you have finished configuring your system and installing Pro Tools software. This is more useful than a recovery disk for an unconfigured system.

**Common Issues**

**Pro Tools Won’t Launch**

**Problem**

When you double-click the Pro Tools application or a Pro Tools session file, Pro Tools doesn’t launch, or displays an error message.

**Possible Solutions**

**TDM Systems**

- Verify that Pro Tools cards are installed in the correct slot order in your computer or Expansion Chassis.
- Turn off your computer and check to be sure your cables are properly and securely connected to the correct Pro Tools cards and to your audio interfaces.
- Turn off your computer and check all Pro Tools cards installed in your computer to be sure they are properly seated in their PCI slots, and that any TDM FlexCables (Pro Tools HD-series systems) or TDM ribbon cables (Pro Tools MIX-series systems) are connected properly.
- Use the DigiTest application (installed in the Pro Tools Utilities folder) as a diagnostic tool to verify that your Digidesign cards are operational.
Digi 001 Systems
◆ Turn off your computer and check to be sure your cable is properly and securely connected to the Digi 001 PCI card and to the Digi 001 I/O Box.

All Systems
◆ Check to be sure your computer has the required amount of RAM to launch Pro Tools.
◆ Try a complete restart. Turn off your audio interfaces, computer peripherals and your computer, and then turn them on again in the proper sequence.
◆ (Mac OS 9.x Only) Verify that Virtual Memory is turned off. On the Macintosh, open the Memory Control Panel. If Virtual Memory is turned on, turn it off and restart your computer.
◆ (Mac OS 9.x Only) Make sure the default set of Mac OS System Extensions is enabled, along with the Open Music System (OS 9.x only), DigiSystem Init, Direct I/O, and DSP Manager Extensions.
◆ Resinstall the Pro Tools application, using the Pro Tools Installer CD-ROM.

Audio Interface Isn’t Recognized
(TDM Systems Only)

Problem
When you launch Pro Tools it does not recognize an audio interface, or a connected audio interface is not available.

Possible Solutions
◆ Turn off your computer and check to be sure your cables are properly and securely connected to the correct Pro Tools cards and to your audio interfaces.
◆ Verify that your Hardware Setup is correct; check to see that you have selected the correct Interfaces for each I/O card.
◆ If you only have one interface, make sure it is connected to the HD Core card (Pro Tools HD-series systems), MIX Core card (Pro Tools MIX-series systems), or d24 card (Pro Tools 24 systems).
◆ Make sure Loop Sync, SuperClock or other synchronization connections to your audio interface are correct. Disconnect the clock source from the interface and see if the problem persists.

Using DigiTest as a Diagnostic Tool
(TDM Systems Only)
The DigiTest utility performs diagnostic tests on the Pro Tools cards in your system. If DigiTest reports that any of your cards have failed, click the Info button next to that card. Write down the information that appears and report it to your local Digidesign dealer or to Digidesign Technical Support.
Refer to your Getting Started Guide for specific DigiTest instructions.

Performance Factors
There are several conditions that may adversely affect the performance of Pro Tools. These include:
**Network Connections** Close any network connections unless you are using them for network interchange of audio data.

**Background Applications** Any software utilities that run in the background or generate disk activity, such as virus protection, disk optimization, or file savers, should be turned off or removed.

**Screen Savers** Screen saver software should be completely removed from your computer before running Pro Tools.

**Power Saver Features** Some automatic power saver features, such as those that spin down the system hard drive, can affect Pro Tools performance. These features should be turned off.

**Virtual Memory** (Mac OS 9.x Only) Pro Tools will not launch if Virtual Memory is active. Deactivate Virtual Memory and restart your Macintosh.

**CD-ROM Extensions/Control Panels** Some CD-ROM and removable media Extensions and Control Panels have been linked to audio quality problems. Deactivate any performance-enhancing Extension or Control Panels for such media, and restart your computer.

---

**Before You Call Digidesign Technical Support**

**Register Your System**

As a registered owner of a new Digidesign product under warranty, you are eligible to receive Digidesign Technical Support. Fill out and sign your Registration Form and mail or fax it to the address supplied with the registration materials. Refer to the registration materials that came with your system for details on warranty coverage and the range of services available.

**Use Digidesign Resources**

In addition to the printed and PDF versions of Pro Tools Guides, your system includes the following sources of information:

**Read Me Files** These contain late-breaking information and known issues pertaining to Pro Tools software and hardware configurations. ReadMe files are installed in the *Release Notes and Documentation* folder when you install Pro Tools.

**Answerbase** This is a database of common problems and DAE errors, and their solutions based on the latest information from Digidesign Technical Support. This database is installed in the Digidesign folder when you install Pro Tools. Answerbase is also available on the Digidesign Web site (www.digidesign.com).

**Web Site** The Digidesign Web site includes an area for Technical Support, as well as a Digidesign User Conference (DUC) that includes technical discussions. Visit www.digidesign.com and go to the Support area or the User Conference area: Support > Tech Support > Digidesign User Conference (DUC).

**Gather Important Information**

Digidesign wants to help you resolve problems as quickly and efficiently as possible. If you have the following information handy when you contact Technical Support, it will make the diagnosis of your problem easier. Take a few minutes to collect this basic information in one place.
System Information

Computer
- Make, model, processor speed
- Amount of system RAM
- Operating system (version of Mac OS or Windows)
- Any Drivers, Extensions, Control Panels, Disk Utilities, or other system-related applications you may have installed.

Digidesign Hardware
- Type of cards, interfaces, or peripherals
- Where the cards are installed
- PCI card order in computer or chassis
- Interfaces connected to each card

Hard Drives
- Make, Model
- Drive size (GB)
- Drive speed (RPM)
- Drive type (SCSI, FireWire, IDE/ATA)
- Utility used to format the drive
- Number and size of partitions on the drive

Digidesign Software
- Pro Tools software version
- (Mac OS 9.x Only) DAE and DSI versions
- Plug-in versions
- Other Digidesign software
- Additional plug-ins from Digidesign Development Partners

Other Hardware

If using additional hardware, refer to the manufacturer’s documentation for operational details.

The most common hardware additions include:
- SCSI host bus adapter (HBA) cards (manufacturer, model, settings)
- 1394 (FireWire) cards for Windows systems (manufacturer, model)
- Expansion Chassis (manufacturer, model, bridge chip type)
- Video Capture cards (manufacturer, model)

To verify that your hardware is qualified for use with your Pro Tools system, refer to Digidesign’s Web site (www.digidesign.com), or contact your Digidesign dealer.

Other Software

If you are using other audio or video applications, refer to the manufacturer’s documentation for operational details.

Make note of any other software that was running when a problem occurred.

Diagnostic Information

DigiTest

If you ran DigiTest on your system and it generated any errors, be sure to make a note of any error codes or messages.

Other Information

Note any DAE errors or other error codes you encounter. Also make a note of the ability to reproduce the problem under different conditions, such as with another session, or after changing settings such as the DAE Preferred Memory Size (Macintosh) or the Hardware Buffer Size (Pro Tools LE).
Glossary

9-pin (Sony 9-pin; DB-9) Industry standard for serial machine control of professional video and audio transports, made by Sony and other manufacturers. Refers to the DB-9-style physical external control connector found on 9-pin-compatible devices.

absolute grid mode An editing mode that constrains movement and alignment of regions to precise increments on a user-defined grid. (See also “relative grid.”)

A/D (analog-to-digital) Analog-to-digital converters operate at various bit-rate resolutions and sampling rates, converting analog audio signals to digital audio signals.

address (time code address) Specific SMPTE/EBU time code reference or reading, in hours:minutes:seconds:frames.

ADAT lightpipe Industry standard term for optical connection of digital audio. Created by Alesis, the lightpipe can simultaneously stream eight channels of digital audio.


AIFF Audio Interchange File Format, an Apple Computer audio file format.

AMS (Audio MIDI Setup) Apple Computer’s audio and MIDI operating system, which is part of Mac OS X. For Macintosh users, AMS replaces Opcode Systems’ OMS (Open Music System).

ATR Audio Tape Recorder, of any format, including a Digital Audio Tape (DAT) deck.

audio interface Among most Pro Tools systems, the audio interface is a separate box that is attached with a special cable to the audio card. An audio interface typically has analog and digital audio inputs and outputs, and may be equipped with level meters, level controls, and other features.

audio region A region of an audio file that is defined nondestructively with pointers. See region.

Audiomedia III Digidesign’s entry-level PCI card for Pro Tools, includes S/PDIF and stereo analog inputs and outputs.

AudioSuite plug-in Digidesign’s proprietary file-based, non-real-time plug-in format. AudioSuite processing creates a new audio file with the effect permanently applied.

audition Listening to, or “monitoring,” one or more tracks or audio files. In Pro Tools you can audition files before you load them into the program. There are also various ways to audition takes from the Audio Regions List and from the Takes List pop-up menu.
**auto-created region** Automatically-created regions are a by-product of editing and punch recording over existing regions.

**Automation modes** Function for the recording and playing changes in levels, pan controls, and virtually every adjustable parameter (including plug-in elements) in Pro Tools. There are several different automation modes in which to write automation data in Pro Tools.

**aux** See auxiliary I/O.

**auxiliary I/O** Input and output channels used for internal or external bussing of signals in ways other than through the standard input and output of a channel strip.

**auxiliary send** See send.

**AVoption** PCI cards and software that integrates Avid video technology with Pro Tools.

**AVoption|XL** PCI card, video interface, and software that integrates Avid video technology with Pro Tools.

**.AVI** Movie file format for the Video for Windows component of Microsoft’s Media Player, supported by Pro Tools.

**bit depth** One of two main specifications that define digital audio quality (the other is sample rate). Bit-depth defines how precisely a sound’s dynamic range is represented. Also called bit-resolution or bit-rate.

**black burst** A type of clock reference signal commonly used to synchronize audio or video devices during playback or recording.

**BNC** Coaxial cable connectors used for video and synchronizer signals.

**Bounce To Disk** Mixing a segment of audio (on an entire session) internally to disk, without leaving the digital domain. Bit rate, dithering options and other parameters are provided by Pro Tools for bouncing to disk.

**breakpoint** Step or level on a track’s automation playlist.

**Broadcast WAV file (BWF)** A variation of Microsoft’s .WAV audio file format that contains additional data on the title, origination, date, and creation time of the audio content not included in the standard .WAV file format. An important feature of BWFs is their support of *time stamping*. Time stamping allows files to be moved from one session to another and easily aligned to their original point in time.

**Browser** Where information contained in the databases is displayed and manipulated. Additionally, files can be moved on the volumes and spotted into Pro Tools sessions by drag and drop. Additionally, files can be moved on the volumes and spotted into Pro Tools sessions using drag and drop from browsers.

**bus** Carries signals from several outputs to a single path.

**clipping indicator** LED at the top of each channel meter that indicates a level may have run out of headroom, and is approaching clipping.

**clock reference** Common “speed” reference, which various devices can use to establish synchronization during playback and recording.

**Conductor Ruler** A ruler which can show session data. There are three types of conductor rulers, called Tempo, Meter, and Marker rulers.
**continuous controller data**  MIDI instructions that affect MIDI note parameters, including volume, panning, velocity, pitch bend, and modulation. Also, the main type of instructions sent by MIDI control surfaces.

**Control|24**  Digidesign dedicated controller for TDM-equipped systems. Includes 16 premium microphone preamps, a control room monitoring section, and a line submixer. Ideal front-end for Pro Tools recording, mixing, and editing.

**crossfade**  Function for fading out from one region as you fade in to another region. Crossfade types and duration are user selectable from within the Edit window. As with fades, portions of audio for which the crossfade function has been applied are stored in the session’s Fade Files folder.

**d24**  Digidesign’s 24-bit TDM interface card, needs a DSP Farm card to create a Pro Tools|24 TDM system.

**D/A (digital-to-analog)**  Digital-to-analog converters operate at various bit-rate resolutions and sampling rates, converting digital audio signals to analog audio signals.

**DAE (Digidesign Audio Engine)**  Digidesign’s real-time operating system that provides the core functionality of hard disk recording, digital signal processing, mix automation, and MIDI required by Pro Tools and other Digidesign products.

**database**  Databasing is a convenient way of storing, organizing, searching and displaying information. A database file is a collection of records which hold data. In this guide, the term “database” refers to a database file. Pro Tools creates and stores database files on local volumes as needed.

**DB-9**  See 9-pin.

**Digil 001**  Digidesign’s all-in-one audio interface for entry-level Pro Tools LE systems, comprised of a PCI card and I/O box. Includes two mic preamps, S/PDIF I/O, ADAT lightpipe I/O, and eight channels each of analog input and output.

**Digil 002**  Digidesign’s FireWire-based Pro Tools LE Studio with Integrated Control Surface. Includes 8 touch-sensitive, motorized faders and 8 motion-sensitive rotary encoders, 8 analog inputs and outputs, 4 mic preamps, 8 channels of ADAT optical I/O, 2 channels of S/PDIF I/O, and 24-bit/96 kHz A/D and D/A converters.

**Digidesign Audio Engine**  See DAE.

**dither**  “Noise” added to an audio signal when down-sampling bit rates. Designed to create a smoother transition at lower amplitudes instead of simply “chopping” off lower bits.

**drop frame**  Refers to a variance of SMPTE/EBU time code for NTSC color video (29.97 fps) that omits two frames (frames “0” and “1”) every minute except for every tenth minute.

**DSP**  Digital Signal Processing. In audio terms, DSP refers to manipulation of digital audio—everything from reverberation to changes in level.

**DSP Farm**  PCI card containing DSP chips, the basic building blocks of a Pro Tools|24 TDM system.

**Edit cursor**  Flashing line that appears when you click on a track in the Edit window.

**edit decision list (EDL)**  List of edits, or events, typically with each event’s respective source in and out times, source reel number, and record in and out times.

**Edit insertion point**  Location within a track where you click (without dragging); also location at which a region’s start, end, or synchronization point will be placed.
**Edit selection** In the Edit window, the actual region highlighted when you make a selection is called the Edit selection, which can be unlinked from Timeline selection. See Timeline selection.

**Event List** See MIDI Event List.

**expansion chassis** Expands the capabilities of Pro Tools TDM systems running on Macintosh computers by adding more external PCI slots.

**ExpressPro-Tools** ATTO’s hard disk utility for the preparation of hard drives for Pro Tools. For OS X, a new version of this utility, ExpressStripe, must be used.

**fade** A selection in which the volume rises or falls, typically from or to –∞. See crossfade.

**FireWire** A high-speed peripheral standard capable of transferring data at up to 400 Mb/sec. FireWire is commonly used for digital audio and video devices, as well as external hard drives and other high-speed peripherals.

**frames per second (fps)** Number of frames that elapsed per second, as defined by the four SMPTE/EBU Time Code fps standards. These include:

- 24 fps (for film applications);
- 25 fps (the PAL/SECAM video standard);
- 29.97 fps (the NTSC color video standard) (also see Drop-Frame);
- 30 fps (the NTSC black and white video standard).

**general preference** A preference which affects all sessions for the same user. This differs from a global preference, which is the same for all users. (See also “user preference.”)

**Grid mode** Used to align regions in tracks to the nearest unit of a user-defined value. When Grid mode is on, the Selector will “snap to” the currently selected grid value, and regions placed in the Edit window will also line up with the selected value.

**Groove Template** A template derived from an audio selection using Beat Detective. Groove templates contain information on the timing nuances and dynamics of the selected audio performance. Groove templates can then be used to *conform* or impose these performance characteristics on other audio material using Beat Detective, or on other MIDI material using the Groove Quantize command.

**groups** Linked tracks in which an action in the I/O section of one of the tracks is mirrored in all tracks in the group. Groups can be created separately or linked between the Edit and Mix windows.

**HD Core** PCI card which connects to audio interface and contains the DSP for a basic Pro Tools|HD TDM system.

**headroom** Amount of remaining gain available for a given signal before the onset of unacceptable distortion.

**HD Process** PCI card with additional DSP for Pro Tools|HD systems.

**inactive (tracks, plug-ins, sends)** Items that have been turned off in Pro Tools to free up or conserve DSP. When a track, send or plug-in is inactive, its name appears in italics and the item is silent.

**indexing** Databases use indexing to obtain, and maintain, the data displayed in browsers. Indexing creates and updates a database with the latest metadata information.
item Each database record appears in browser Item Lists as an individual item. Items include Online Volumes, Catalogs, Session files and Media files.

latency Time delays inherent in internal processing or generation of audio signals within a computer.

lightpipe See ADAT Lightpipe.

Loop Sync Loop Sync is a dedicated clock loop for synchronizing multiple HD-series interfaces together. Loop Sync uses a word clock signal based on sampling rates of either 44.1 kHz or 48 kHz. As sample rates increase in the system, Loop Sync continues to operate at a base rate of 44.1 kHz or 48 kHz, depending upon the higher rate. Loop Sync should only be used to chain multiple HD-series peripherals together.

Machine Control Pro Tools functions to control or be controlled by an external transport, typically a VTR or ATR.

Marker Memory Location referenced on a timeline, typically used to store locations to important points in a session. See Memory Location.

master “Lead” machine or Pro Tools System in a synchronized machine arrangement. Slaves follow masters. There can only be one master at any given time.

Master Fader track Governs the overall output of one or more tracks.

media file A file which contains actual audio, video, or graphics data. It also contains a variety of metadata (such file name and format).

Memory Location Pro Tools supports up to 200 Memory Locations, which can include markers, Edit selections, record and play ranges, track settings, and other data. They can be viewed and sorted in the Memory Locations window, from which they can also be accessed.

metadata Media files, session files, and other types of files contain their own sets of metadata, which includes general types of data including file name, creation date, file size, and so on. Metadata varies with file type, format, and kind.

MIDI (Musical Instrument Digital Interface) A communication protocol designed to allow equipped instruments such as synthesizers to intercommunicate for control and playback purposes. Information transmitted over MIDI includes note-ons, note-offs, key velocity, pitch bend, and other performance data. Connections are made using cables equipped with five-pin DIN connectors.

MIDI Event List Pro Tools window that shows the contents of a MIDI track in a column, for easy editing of individual MIDI events.

MIDI Machine Control (MMC) See Machine Control.

MIDI Time Code See MTC.

MIDI I/O Digidesign’s USB-based MIDI interface. Features 10 MIDI inputs and outputs for a total of 160 MIDI channels and supports timestamping for superior timing accuracy and precision.

MIX Core PCI card which connects to audio interface and contains the DSP for a basic Pro Tools|24 Mix TDM system.

MIX Farm PCI card with additional DSP for Pro Tools|24 MIX systems.
**MP3** The MPEG Layer 3 compression format is an adjustable-quality audio compression format, developed by the Fraunhofer Institute. The MP3 encoder file is stored in the Codecs folder in the DAE Folder.

**MTC (MIDI Time Code)** Non-SMPTE form of time code that is used by some devices to send and receive timing information.

**non-drop frame** Time code that is not in drop-frame format. In the United States, the standard format outside of color video production or post production is typically 29.97 fps non-drop frame.

**nondestructive editing** Leaves audio files intact. As you edit audio within Pro Tools, all you are editing are the regions, or “pointers,” to audio files that are stored on the hard drive.

**NTSC** Video standards developed by the National Television Standards Committee. NTSC color video runs at 29.97 frames per second; NTSC black and white video runs at 30 fps. Used primarily in North and South America and Japan.

**Nyquist frequency** The highest audio frequency that can be accurately sampled, equivalent to one-half of the sampling frequency. The Nyquist sampling theorem showed that the sampling rate must be at least twice the highest frequency present in the sample in order to accurately reconstruct the original signal.

**OMS** Open Music System, developed by Opcode. OMS is a “MIDI operating system” for Macintosh computers. It handles the exchange of MIDI data between applications, including timing signals such as MTC. OMS is replaced by AMS (Apple MIDIm System) in Mac OS X.

**offline (synchronization)** Not under the control of another device for synchronized playback or recording.

**offline (media)** Not connected to or directly accessible by a computer.

**online (synchronization)** Controlled by another device for synchronized playback or recording.

**online (media)** Connected to and directly accessible by a computer.

**PFL (pre fade listen)** Sometimes called a “cue,” this is a channel’s level before it is attenuated or boosted by the fader setting. Master faders are PFL in Pro Tools. See pre fader.

**peak indicator** Indicator light designed to warn of the possibility of clipping, which illuminates as a device’s input reaches a preset degree of headroom.

**performance volume** A storage volume that has been designated to record and/or play back media files in a Pro Tools session.

**playlist** List of edits and files available in the current session.

**positional reference** Common reference that provides location information that various devices can use to establish synchronization during playback and recording. Most commonly, the information is delivered in the form of SMPTE/EBU Time Code.

**post-fader** Output from a track (typically a send) that is governed by the channel’s fader setting.

**post-roll** Adjustable time which precedes the playback or recording of a selection, in conjunction with Transport, Audition, Online, and QuickPunch functions.

**PRE** Digidesign’s remote controllable 8-channel microphone preamp. Features 8 discrete, matched transistor hybrid mic-preamp circuits and offers a pristine signal path designed specifically for the Pro Tools|HD environment.
preamp In recording studio terminology, a circuit designed to boost relatively low signal levels, such as a microphone output, up to standard line levels of –10 dBu or +4 dBu. Digi 001 is equipped with two microphone preamps.

pre-fader Output from a track (typically a send) that is independent of the channel’s fader setting.

pre-roll Adjustable time which precedes the playback or recording of a selection, in conjunction with Transport, Audition, Online, and Quick-Punch functions.

ProControl Digidesign dedicated controller that communicates with Pro Tools via ethernet. Touch-sensitive, motorized faders, dedicated effects editing section, and extensive parameter automation control are some of ProControl’s unique features.

Pull Up/Pull Down Refers to the deliberate “miscalibration” of the audio sample rate clock (the audio pitch) in order to compensate for a speed change elsewhere in the production chain. The usual situation in which these rates are encountered is when film footage (at 24 fps) is transferred to color NTSC-standard video tape (at 29.97 fps).

quantize To adjust MIDI note locations or durations to the nearest unit or template structure so that particular rhythmic “feel” is achieved.

QuickTime Apple’s system extension for control of time-based events, such as digitized video movies and digitized sound.

RealAudio Audio compression scheme designed for streaming over the internet.

record Element of a database. A database is a collection of records. Each record represents a particular file (such as a media file or session file). The record contains all of the metadata describing that file, but none of the media. Therefore a record is much smaller than the actual file, and much easier to parse for information.

region Within Pro Tools, a region is a “pointer” to a particular track selection or file. Regions can be dragged from the Regions List to a track.

relative grid mode An editing mode that constrains movement and alignment of regions to precise increments on a user-defined grid while allowing the region to maintain an offset relative to that grid point. (See also “absolute grid mode.”)

resolving The process of synchronizing one device to another; more specifically, resolving refers to synchronizing a device’s clock to an external clock reference.

RTAS plug-in Real-Time AudioSuite plug-ins are Digidesign’s host-based, real-time effects plug-in format.

sample rate One of two main specifications that describe digital audio quality (the other is bit rate resolution). Sample rate refers to how frequently incoming audio is sampled per second during conversion from an analog to a digital signal.

SCSI HBA Acronym for Small Computer System Interface (SCSI) and Host Bus Adapter (HBA), Digidesign’s conformed terminology for SCSI cards. SCSI is a type of data bus allowing for the high speed transfer of data between a computer and peripheral devices. An HBA is the card that connects the SCSI bus between the computer and peripheral devices such as hard drives.
**send** An adjustable bus from a track, which can be routed to effects processors, auxiliary monitor mixes, and signal grouping.

**session file** A work file, much like a word-processing document or a graphics program file. A Pro Tools session file contains data describing how media files are to be played and displayed. It also contains metadata about the files on which it depends (audio and MIDI files, and related data such as fades, playlists, and selections). Each separate project you work on should be stored as its own session.

**session template** A Pro Tools session file whose parameters are preset to a user’s specific preferred state. Any Pro Tools session may be saved as a template using the Save As command for convenience of set up.

**slave** Device that “follows” the master during synchronization.

**Slave Clock** Slave Clock (or Super Clock) is Digidesign’s proprietary hi-speed Word Clock that runs at 256x the sample rate. It is required by Pro Tools|24 MIX and Pro Tools|24 systems to synchronize audio interfaces to a single, highly-accurate clock from SYNC I/O.

**Sound Designer II (SDII) file format** Digidesign’s high-quality digital audio file format.

**S/PDIF** Semi-professional version of the AES/EBU standard. Stands for “Sony/Philips Digital Interface Format.” S/PDIF connections use coaxial (RCA) or Toslink optical in/out connectors. Most S/PDIF connections carry two channels of digital audio at a time.

**Spot mode** Audio post production process of aligning audio events to visual events. Spot is the Edit mode that allows you to spot regions to particular time code events.

**Standard MIDI File** Universal format that can be read by virtually any software that reads MIDI. Type 0 is a single line sequence, type 1 is multi-track.

**submix; subgroup** See groups.

**Super Clock (256x)** Digidesign’s proprietary version of word clock; used as a clock reference. All Digidesign TDM audio interfaces, and several other Digidesign products (including the SYBC I/O, Universal Slave Driver, the ADAT Interface, the SMPTE Slave Driver, and the Video Slave Driver) are equipped with BNC-style Super Clock inputs and outputs.

As with word clock, Super Clock is a clock signal that can be passed between devices independently of the audio signal. Since it runs at 256x sample rate (instead of word clock’s 1x sample rate), Super Clock is inherently more precise than Word Clock.

**SYNC I/O** Digidesign’s multi-format synchronization peripheral for Pro Tools|HD that supports all major industry-standard clock sources and time code formats. SYNC I/O features near sample-accurate lock to time code or bi-phase/tach signals and a 192 kHz capable, high-fidelity, low-jitter Word Clock.

**synchronization** Process of having two or more audio, video, or other devices run together at exactly the same speed (usually during playback, though sync during record, fast-wind, and "crawls" is possible).

**sysex (System Exclusive)** MIDI data specific to a particular piece of hardware or instrument.

**TDM** Time Division Multiplexing technology employs a networked bus of DSP chips that supply the processing power for Pro Tools TDM systems.
TDM plug-in  Digidesign’s proprietary real-time, nondestructive plug-in format for Pro Tools TDM systems.

time code address  See address.

time code generation  Process of creating “fresh” time code.

Time Scale  The Main Time Scale is the Timebase Ruler that determines the time format used for Transport functions, and Grid and Nudge values. The Sub Time Scale is the Timebase Ruler that provides additional timing reference.

Timebase Rulers  Up to five discrete strips measuring different units (samples, feet.frames, minutes:seconds, bars:beats, or time code) displayed across the top of the Edit window.

Timeline insertion point  Location on the timeline corresponding to the cursor point, and the point from where playback or recording begins.

Timeline selection  A selection in any Timebase Ruler that determines the playback or record range.

transfer volume  A storage volume which has been designated as a Transfer Volume will not be used to record or play media in a Pro Tools session. Volumes which are not supported by Pro Tools for audio playback, (such as network share volumes or CD-ROMs) will be designated as transfer volumes by default.

Universe window  Provides a visual overview of all tracks in a session, and can be used to quickly navigate to any location in a session.

USB (Universal Serial Bus)  A high-speed peripheral standard capable of transferring data at up to 12 Mb/sec. USB is used for many audio and video peripheral devices.

user-defined region  Explicitly defined regions that are created when recording or importing audio or MIDI; capturing, separating, or consolidating a selection; trimming a whole-file audio region; or renaming an existing region.

user preference  A user-definable state for a specific Pro Tools parameter or system setup. OS X has the ability to create separate preferences files for each user. For Pro Tools databasing functions, these include browser views, and parameter and search settings (See also “General preference.”)

velocity  MIDI data parameter that describes how fast or hard a key is struck and controls the volume of MIDI note playback.

video reference signal  All video signals contain clock information, which can be used as a clock reference.

voiceable track  Previously known as virtual voicing; total voiceable tracks refers to the maximum number of audio tracks that can share the available voices on your system.

voices  With a Pro Tools TDM system, this refers to the number of channels that can be played back simultaneously.

VTR  Video Tape Recorder of any format.

.WAV  Pronounced “wave”; Microsoft’s Audio File Format. Can be read by Pro Tools on both Macintosh and Windows platforms.

waveform  Means of visually representing a sound. When sound regions are imported into Pro Tools’s Edit window, they can be viewed in waveform view.

whole-file audio regions  Created when recording or importing audio, consolidating existing regions, and when processing with an AudioSuite plug-in.
**Word Clock** Many professional digital audio products—including open-reel multitrack tape recorders, digital mixing consoles, and the Tascam DA-88 modular digital multitrack—have Word Clock (1x sample rate) connectors.

Word Clock allows the DA-88 (and other Word Clock-compatible devices) to send or receive external clock information which controls the sample rate, which in turn (where applicable) controls the play and record speed.

**zero crossing** Point at which a wave’s amplitude crosses the center line of the waveform display. Typically a good spot to edit a sound file is at zero crossings, to avoid unwanted artifacts.

**Zoom** Function used to view waveform displays within the Edit window with greater detail.
Symbols
.1 (in surround mixing) 472

Numerics
1622 I/O 6
16-bit
Bounce to Disk 459
16-bit Optimized Mixer 575
plug-in features 578
176.4 kHz
and pull factors 532
176400 Hz sample rate 460
192 Digital I/O 6
192 I/O 6
Hardware Setup 44
Soft Limit 44
192 kHz
and pull factors 532
192000 Hz sample rate 460
1x 594
24 FPS 514
24-bit
Bounce to Disk 459
TDM processing 403
24-bit ADAT Bridge I/O 6
24-Bit Optimized Mixer 575
plug-in capabilities 578
25 FPS (EBU) 513
256x 592
29.97 FPS Drop 513
29.97 FPS Non-Drop 513, 549
3 Second Peak Hold 88
3:2 Pulldown 514
30 FPS Drop 513
30 FPS Non-Drop 513
32-bit, floating 403
3-knob panning 502
3-Second Peak Hold preference 56
44100 Hz sample rate 460
48000 Hz sample rate 460
5.0 paths in 5.1 mixes 491
5.1 formats in Pro Tools 481
882 I/O 6
882/20 I/O 6
88200 Hz sample rate 460
888 I/O 6
888/24 I/O 6
8-bit 459
96 I/O 6
Hardware Setup 44
96000 Hz sample rate 460
A
active
making inserts 408
making plugins 17
tracks 99
Active in Background
for MPS play 458
active items 16
ADAT Bridge I/O 6
Add Unique Triggers 328
adding
a new playlist 200
audio tracks 151
Auxiliary Input tracks 381
Master Fader tracks 382
MIDI tracks 171
Sends 389
AES/EBU
Hardware Setup 44
AIFF file format 454
All Notes Off command 350
all tracks
hiding 91
selecting 230
selecting all regions in 225
selecting in Timebase Rulers 230
showing 91
allocating
DSP 569, 571
I/O capacity 580
Analog In 44
Analog Out 44
archiving
preparing with Compact Selected 289
Assignment view
sends 391
Audio CD Import Options dialog (Macintosh) 121
Audio During Fast Forward/Rewind option 57, 218
audio files
  batch loading with drag & drop 118
  compacting 289
  concepts 12
  default names 140
  formats 454
  importing 105
  locating 127
  mixed file types 51
  mixed formats 106
audio format, for session 522
audio interfaces 8
  input channels 14
Audio Pull Up and Pull Down 528
audio recording
  undoing a take 154
audio regions 194
  and automation 196
  fitting to an Edit selection 270
  stripping silence from 283
  whole-file 190
Audio Regions Focus 34, 204
Audio Regions List 202
  displaying file info for audio regions 202
  dragging from 242
  finding regions 203
  sorting 203
Audio Regions List menu 546
  Auto Rename Selected command 287
  Clear Selected command 288
  Compact Selected command 289
  Display All command 203
  Export Region Definitions command 120
  Export Selected As Files command 118
  Find command 203
  Rename Selected command 287
  Selected Unused command 288
  Show Disk Names option 202
  Show File Names option 202
  Show Full Pathnames option 202
  Sorting option 203
  Time Stamp Selected command 251
audio tracks
  5.1 format 477
  adding/creating 151
  and Output format 485
  and surround sessions 483
  and tempo changes 293
  bouncing to disk 452
  channel strips 84
  configuring for recording 151
  creating a tempo map for 294
  loop recording 159
  placing audio in multichannel tracks 484
  punch recording 158
  recording multiple 155
  signal flow 380
  Waveform view 190, 194
Audiomedia III 9
  QuickPunch 183
AudioSuite
  Dither 403
  Duplicate plug-in 264
  plugins 403
  processing 263
AudioSuite Buffer Size preference 63
AudioSuite Dither preferences 62
audition path 80
auditioning
  fades 273
  pre/post-roll 233
  programs 346
  selection start/end points 233
  takes 150
Auto Input Monitoring option 138
Auto Match Pull Factors 529
Auto RegionsFade In/Out Length option 59, 281
Auto Rename Selected command 287
auto-created regions 190
  hiding 288
  renaming 286
auto-fades 280
AutoMatch Indicators 427
AutoMatch Time option 62, 426
Automatically Find and Relink 129
automating
  plugins 431
  Sends 430
  switched controls 430
  tracks 429
automation 421
  and audio regions 196
  and Duplicate Selected Tracks 423
  and multichannel pan 505
  and multiple output assignments 485
  breakpoints 438
  buffer size 427
  capture & apply 446
  cutting, copying, and pasting 440
  deleting 434
  delta 424
  drawing with Pencil 435
  editing 436
  editing with Smart Tool 266
  enabling, suspending 432
  for grouped tracks 439
  for hidden tracks 92
  on multichannel tracks 438
  On Stop 444
  pass-through point 424
  playlists 199, 422, 428
  plug-in accuracy in bounce 461
  relative and absolute 424
  rule and Track View 257
  safing 428
  smoothing 426
  snapshot 445
  special Paste mode 442
  stepped 438
  thinning 426, 434
  To Current or All Enabled 447
  to start, end, or all 442
  Trim mode 424
  trimming 444
  what is copied 258
  what is pasted 258
  Write Safe button 411
  writing 429
Automation Enable window 429, 433
Automation Mode Selector 26, 423
automation modes
  Auto Latch 424
  Auto Off 423
  Auto Read 423
  Auto Touch 424
  Auto Write 423
  Trim/Auto Latch 425
  Trim/Auto Off 424
  Trim/Auto Read 424
  Trim/Auto Touch 425
  Trim/Auto Write 425
Automation Preferences 61
  AutoMatch Time option 62, 426
  Memory for Automation Recording option 427
  Mutes Follow Mix Groups option 97
  Smooth and Thin Data After Pass option 434
  Solos Follow Mix Groups option 97
  Touch Timeout option 62
Automation Safe Button 411
Automation Write Safe button 414
Auto-Name Memory Locations While Playing option 59, 303
Auto-Name Separated Regions option 60, 240
auto-naming
  and Strip Silence 284
  audio files and regions 140
  playlists 200
  QuickPunch regions 184
  separated regions 240
  takes 140
AutoSave option 58
Auto-Spot Regions command 545
auto-voiced tracks 95
Auxiliary Inputs 398
  adding 381
  and DSP usage 579
  signal flow 381
Auxiliary Send level, and Master Fader 402
Avid Compatibility Mode option 63
  and Bounce to Disk 453
Avid Xpress DV
  codec requirements for export 555
  playback in Pro Tools 555

B
  bank select 19, 341
Bar|Beat Markers
  and tempo events 296
  audio with varying tempos 295
  editing 296
  from Identify Beat command 294
  generated with Beat Detective 317
  moving 296
Bars:Beats Time Scale 214
bass
  extension 476
  management 473, 476
  redirection 476
  sub content 473
Batch Fades dialog 281
Beat Detective 309
  Collection Mode 326
  conforming regions 322
  defining the selection 312
  detecting transients 314
  DigiGroove Templates 318
  edit smoothing 325
  extrapolation 320
  generating Bar|Beat Markers 317
  Groove Templates, extracting 319
  Scroll Next 317
  separating regions 320
  system requirements 310
  Trigger Pad 321
  with multiple tracks 321
Beat Detective Templates 318
Beat Detective window 311
  beat triggers 315
  deleting 315
  generating 314
  inserting 316
  moving 316
  promoting 316
Bi-Phase/Tach 512
bit depth, for session 47, 522
black burst 548
Blocks view 191
Bounce to Disk 449, 452
  and dither 450
  and time stamps 452
  Bounce Options 453
  Convert After Bounce 461
  Convert During Bounce 461
  File Type 454
  Format 458
  format 454
  Help button 461
  Resolution 459
  Sample Rate 460
  sample rate conversion options 460
  Sample Rate Conversion Quality 460
  source path 453
Use Squeezer option 460
Bounce to Movie command 561
  bouncing
    to a stereo mix 462
    to a submix 461
    to QuickTime movies 561
  breakpoints 438
Browser
  defined 586
Buffer Size
  Hardware 139
bussing
  multichannel sends 487
  surround examples 491
BWF (.WAV) file format 454
Bypass Button
  for real-time plug-ins 411
calculator entry mode 230
Calculator mode for numeric entry 229
calculator-style editing of values 230
Calibration Mode command 136
Calibration Reference Level preference 59
cancelling record takes 154, 174
capture time code 544
centering crossfade 272
Center % (Percentage) 503
Center % in Output window 505
centered crossfade 272
Change Duration command 356
Change Meter command 297
Change Tempo command 291, 292
Change Velocity command 354
Channel Delay Indicator 87
Channel Selector 411
channel mapping
default path order 81
editing 74
re-mapping 74
Channel Selector 411
for multi-mono plug-ins 488
channel strips 14
audio tracks 84
MIDI tracks 86
channels inputs 14
chasing
controller events 348
MIDI notes 347
program changes 348
Clock Source pop-up menu 44
Clock Source pop-up menu 44
Close Session command 54
closing multiple plug-in windows 412
CM Labs Motor Mix 404
Commands Focus 34
Comments View 88, 384
comments, entering for tracks 90
Compact Selected command 289
Compare button 411
compatibility
surround formats 474
Compatibility Preferences 63
Compress/Expand Edit To Play command 269
and multichannel tracks 270
compressed QuickTime file formats 560
Conductor button 31
Conductor Rulers 213
including in selections 230
configuring
click options 146
MMC 535
Pull Up/Down 533
SMPTE 526
conforming QuickTime movies 559
connecting
effects units 417
external audio devices 417
Consolidate Selection command 286
Continuous Scroll During Playback option 220
and half-screen 221
Continuous Scroll with Playhead option 220
and half-screen 221
continuous zoom 208
control surfaces 404
EditPack 404
ProControl 404
Control|24 404
controller events 19, 340
and MIDI regions 199
chasing 348
editing 341
inserting 341
Conversion Quality option 60, 121, 460
Tweak-head setting 460
Convert .WAV files to AES31/BroadcastWave option 63
Convert plug-in pop-up 411
Convert WAV files to AES31/BroadcastWave 130
converting session
audio file format 50
bit depth 50
sample rate 50
Copy command 258
Copy Edit Selection to Timeline command 236
Copy Timeline Selection to Edit command 236
Copy To Send command 431
Copy To Send dialog 431
copying
all automation playlists for a track 258
MIDI notes with the Split command 353
selections and regions 258
track automation to Sends 431
track control settings to Sends 398
countoff 31, 147
CPU Processing Activity 427
Create Fades command 278, 279
creating
crossfades 278
fade-ins/outs 279
groups 102
Markers and Memory Locations 302
regions 239
sessions 46
tracks 89
Crossfade Preference for Pre/Post-Roll option 60, 277
crosstalks 271
creating with Smart Tool 265
equal gain 275
equal power 275, 277
Fades dialog 273
in batches 281
linear 277
overlap 277
pre/post 278
removing 278
trimming 278
types 271
with dither 276
Current Cursor Display 27
location 28
current meter 31, 297
current tempo 31, 291
Current Time 522
custom sample rates 460
Cut command 258
cutting
automation 440
MIDI notes with the Split command 353
selections and regions 259
default audition path 80
I/O Setup 78
meter 147
output path 80
path order 81
paths 71
program change 342
program change 342
tempo 148, 294
Zoom Toggle Track Height 211
Default Fade Settings 60
Default Note On Velocity option 64, 334
Default Settings preference 63
Default Thru Instrument 169
Degree of Thinning option 62
delay
Channel Delay Indicator 87
MIDI Track Offset 349
Delay plug-ins 405
Delete Fades command 278
Delete Path 73
Delete Selected Groups command 102
Delete Selected Tracks command 90
deleting
automation 434, 440
existing I/O paths 73
groups 102
in MIDI Event List 375
Memory Locations 306
MIDI notes 339
playlists 200
program changes 346
sysex events 347
tracks 90
underlying region data 259
unused regions 288
delta
trimming automation 424
destructive editing
compacting audio files 289
Destructive Record mode 144, 157
destructive recording 157
Digi 001 9
modes and I/O Setup 73
punching with footswitch 181
QuickPunch 183
Digi 002 9
Digidesign Audio Engine 11
DigiGroove Templates 318
digital clipping 135
digital master clock 418
digital mastering 463
digital signal processing (see DSP)
DigTest 581
Direct I/O 582
discrete signal control 484
Disk Allocation 141
and cross-platform sessions 142
and system volume 143
dialog 141
Display All command 203
Display Auto-Created Regions option 288
display menu
Bars:Beats Time Scale 214
Display Auto-Created Regions option 288
Display Name In Regions option 194
Display Time In Regions option 194
Edit Window Show option 21
Feet:Frames Time Scale 214
Minutes:Seconds Time Scale 214
Mix Window Show option 21
Narrow Mix Window option 99
Ruler View Show option 213
Samples Time Scale 214
System Usage Window Shows 570
Time Code Time Scale 214
Display Name In Regions option 194
display Preferences 55
Draw Grids in Edit Window option 207
Draw Waveforms Rectified option 195
Edit Window Color Coding option 100
Peak Hold option 88
Show Meters in Sends View option 392
Display Time In Regions option 194
displaying
  all regions 203
  all Rulers 213
  file info for audio regions 202
  Meter Ruler 297
  Original Time Stamps 546
  region names 194
  region times 194
  Tempo Ruler 291
  User Time Stamps 547

dither
  and Bounce to Disk 450
  and fades 276, 404
  AudioSuite 403
  on Master Faders 450
  preferences 403
  resolution and Bounce to Disk 459
  Dither plug-in preference 62
  divergence
    and width 473
    drawing 504
    using 503
  Dolby Digital 472
  Dolby EX 468
  Dolby Surround 468
  Draw Grids in Edit Window option 207
  Draw Waveforms Rectified option 55, 195
  drum machine style loop recording 176
  DSP 569
    active and inactive items 16
    allocating 569, 571
    and Auxiliary Inputs 579
    and I/O capacity 580
    and inactive outputs 388
    and inactive sends 393
    and Master Faders 579
    and mixing 570
    and no output 388
    and overall resources 16
    and Send meters 392
    and TDM plug-ins 579
    I/O and Mixer plug-ins 574
    monitoring usage 570
    reclaiming DSP capacity 570
  DSP delays 563
    compensating for 565
  DSP Farm card 6
  DSP Manager 570
  DTS 468, 472
  Duplicate command 260
  Duplicate plug-in 264
  Duplicate Selected Tracks
    for automation 423
  Duplicate Selected Tracks command 90
  duplicating
    MIDI note selections 261
    playlists 199
    selections and regions 261
  duplicating inserts 410
  durations, for MIDI notes
    editing with Change Duration command 356
    making more legato 357
    making more staccato 356
    randomizing 356
  DTS 468, 472
  Duplicate command 260
  Duplicate plug-in 264
  Duplicate Selected Tracks
    for automation 423
  Duplicate Selected Tracks command 90
  duplicating
    MIDI note selections 261
    playlists 199
    selections and regions 261
  duplicating inserts 410
  durations, for MIDI notes
    editing with Change Duration command 356
    making more legato 357
    making more staccato 356
    randomizing 356
  DV
    and sync offset 556
  DV Movies
    playback through Firewire 555
  DV Stream 555
  dynamic voice allocation 96
  Dynamics plug-ins 405

E
  Edit and Timeline selections, unlinked 223
  Edit commands 257
    and Edit mode 258
    clear 258
    cut 258
    paste 259
    edit commands
      clear 258
      edit cursor 217
      and scrubbing 221
      moving to region boundaries 231
      Edit Dither Settings preference 62
      Edit Group 102
      Edit Groups
        and selections 225
      Edit Insertion Follows Scrub/Shuttle option 57, 221
      Edit insertion point
        placing regions at 243
        trimming regions to 248
      Edit Markers 224
        and selection length 228
  Edit menu
    Capture Region command 239
    Clear command 258
    Compress/Expand Edit To Play command 269
    Consolidate Selection command 286
    Copy command 258
    Copy To Send command 431
    Create Fades command 278, 279
    Cut command 258
    Delete Fades command 278
    Duplicate command 260
    Fade To End command 280
    Fade To Start command 280
    Fades command 273
    Heal Separation command 242
    Identify Beat command 294
    Identify Sync Point command 243, 547
    Insert Silence command 285
    Lock/Unlock Regions command 256
    Merge Paste command 262
    Mute/Unmute Region command 257
    Paste command 259
    Quantize Regions command 256
    Redo command 201
    Remove Sync Point command 243
    Repeat command 261
    Repeat Paste To Fill Selection command 269
    Select All command 225
    Separate Region command 239
    Shift command 255
    Strip Silence command 283
    Thin Automation command 435
    Trim Automation command 447
    Trim End To Insertion command 248
    Trim Start To Insertion command 248

600  Pro Tools Reference Guide
Index

Trim To Selection command 241
Undo command 201
Write Automation command 445, 446
Edit mode buttons 205
Edit modes 205
and edit commands 258
and placing regions 242
Shuffle 205
Slip 206
Spot 206, 543
edit playlists 199
Edit selections
auditioning with Playhead enabled 236
copied from Timeline selection 236
copied to Timeline selection 236
sliding in the Ruler 232
edit smoothing, with Beat Detective 325
Edit tools 26
Grabber 226
Pencil 264
Scrubber 221
Selector 217
Smart Tool 265
Trimmer 245
Zoomer 208
Edit window
half-screen 221
Pro Tools 5.3.x 25
Pro Tools 6.0 23
scrolling from the Ruler 219
Edit Window Color Coding option 56, 100
Edit Window Default Length option 56
Edit Window Follows Bank Selection option 56
Edit Window Shows option 21
editing
across multiple tracks 260
and Edit modes 205
and Grid modes 253
and hidden tracks 92
and track view 257
automation 436
Bar|Beat Markers 296
beat triggers 315
controller events 341
during playback 189
Grid mode 206
in MIDI Event List 374
Markers 305
Memory Locations 305
meter events 298
MIDI notes 335
MIDI regions 198
nondestructive 189
nondestructively for audio 196
nondestructively for MIDI 198
note attributes 339
note durations 356
note velocities 337, 354
regions as grid 207
Shuffle mode 205
Slip mode 206
Spot mode 206
tempo events 292
waveforms 195
Editing Preferences
Auto-Name Memory Locations While Playing option 303
Auto-Name Separated Regions option 240
Crossfade Preference for Pre/Post-Roll option 60, 277
QuickPunch Crossfade Length option 181
Region List Selection Follows Track Selection option 202, 233
Separate Region Operates On All Related Takes option 162, 240
Take Region Lengths That Match option 162
Take Region Names That Match Track Names option 162
Track Selection Follows Regions List Selection option 233
EditPack 404
effects, printing to disk 449
Enable Automation Parameters Button 411, 414
Enable AutoSave option 58
enabling
automation 432
groups 103
MIDI input devices 168
encoding and decoding 475
Enforce Mac/PC Compatibility option 51
Enforce PC/Mac Compatibility option 51
EQ plug-ins 405
equal gain crossfades 275
equal power crossfades 275, 277
ethernet control surfaces 404
Event Edit Area
note attributes 339
Exit command (Windows) 54
Expanded Track Display 193, 438
Export MIDI command 125
Export Region Definitions command 120
Export Selected As Files command 118
Export Selected dialog 119
Export Session As Text command 122
exporting
a session as text 122
audio 118
audio from regions 118
MIDI tracks 125
region definitions 120, 547
stereo interleaved files 119
Ext. Clock Output 44, 524
extending selections 228
to adjacent tracks 230, 231
to include adjacent regions 228
to Markers and Memory Locations 229
to region boundaries 228
Extensions 583
external clock source 418
extrapolation 320
F
factory settings 79
Fade To End command 280
Fade To Start command 280
fade-in shapes 276
fade-out shapes 274
Faders Move During Playback option 61
fades 279
and dither options 404
auto-fades 280
creating 279
creating with Smart Tool 265
in batches 281
regenerating 129
with dither 276
Fades command 273
Fades dialog 273
In Shape 276
Link option 275
Out Shape 274
Use Dither option 276
Fast Forward
incrementally 218
locating with 218
Fast Forward button 29
Feet.Frames and QuickTime offset 558
Feet.Frames Time Scale 214
file formats (audio) 454
AIFF 454
BWF (.WAV) 454
MP3 456
QuickTime 454
RealAudio 455
SNR resource 454
Sound Designer II 454
File menu
Bounce To Disk command 452
Close Session command 54
Delete Selected Tracks command 90
Duplicate Selected Tracks command 90
Exit command (Windows) 54
Export MIDI command 125
Export Session As Text command 122
Group Selected Tracks command 102
Import Audio to Track command 107
Import MIDI to Track command 124
Import Tracks command 108
Make Selected Tracks Inactive command 99
New Session command 46
New Track command 151, 171
Open Session command 48
Quit command (Macintosh) 54
Revert to Saved command 49
Save Session As command 49
Save Session command 49
Save Session Copy In command 52, 131
Split Selected Tracks Into Mono command 263
files
Transfer 129
Film 468
film speed 515
filtering in bass management 476
final mixdown 462
Find command 203
finding regions 203
Firewire
QuickTime DV playback 555
Flatten Performance command
Flatten Performance window 368
Flatten Performance window 368
format (NTSC or PAL) 528
formats
supported multichannel 468
frame rate
pull up and pull down 528
freewheeling time code 524
Front Divergence 503
Front/Rear Divergence 503
G
generating time code 524, 534
Global MIDI Playback Offset option 64, 348
Go to End button 29
Grabber tool 226
editing breakpoints with 437
Object Grabber 226
selecting MIDI notes with 335
Separation Grabber 241
Grid
setting for MIDI editing 333
value selector 206
Grid mode 206
Absolute 253
configuring 206
Draw Grids in Edit Window option 207
enabling 206
Regions and Markers option 207
Relative 253
setting the Grid value 252
grid panners in Mix and Edit 495
Grid value 252
Groove Quantize command 363
Groove Quantize window 363
Groove Templates 318, 319, 363
Group Selected Tracks command 102
groups
and automation editing 439
and hidden tracks 92
and pan 505
and selecting tracks 102
changing members 102
creating 102
deleting 102
Edit Group 102
enabling 103
linking Edit and Mix Groups 103
Mix Group 102
renaming 102
unlinking Edit and Mix Groups 103
Groups List 101
Groups List Focus 34
Groups pop-up menu 101
Delete Selected Groups command 102
Display command 102
New Group command 101
Suspend All Groups command 102
H
H/W Buffer Size 139
half-screen 221
half-speed playback 186
half-speed recording 186
hard drives
  and Compacting Audio 289
  and QuickTime movies 553
  recording to system volume 143
Round Robin Allocation 142
hardware
  updating I/O Setup after changing 73
hardware I/O Inserts 405
hardware I/O Sends 390
Hardware Setup
  Analog In 44
  Analog Out 44
  Clock Source 44
  Digital Format 44
  Ext. Clock Output 44
  initializing Legacy I/O 45
  Input Channel Selector 44
  Meters pop-up menu for 96 I/O 44
  Output Channel Selector 44
  selecting multiple outputs 45
Hardware Setup dialog
  Buffer Size 139
HD Core card 5
HD Process card 5
Heal Separation command 242
hidden tracks
  and group edits 92
  and groups 92
  and selections 225
hiding
  all tracks 91
  auto-created regions 288
  tracks 91
Highest Priority Playback option 553
Horizontal Zoom buttons 208
I
I/O capacity
  allocating 580
  and DSP usage 580
I/O Labels (see I/O Setup)
I/O Settings 79
I/O Settings files
  import and export 78
I/O Setup 68
  and surround sessions 478
  default settings 78
  displaying unavailable I/O 77
  factory settings files 79
  import and export settings 78
  importing for surround 480
  initializing 75
  last used 79
  reset paths 73
  settings files 78
  Stereo Mix preset 79
  surround mix examples 491
  surround mix settings file 79
I/O View 86, 384
Identify Beat command 294, 295
Identify Sync Point command 243, 547
Import Audio dialog 107
Import Audio From Current Movie command 561
Import Audio From Other Movie command 120
Import Audio to Track command 107
Import MIDI command 125
Import MIDI to Track command 124
Import Movie command 554
Import Movie dialog 554
Import Tracks command 108
importing
  and converting audio 106
  audio 105
  audio and Conversion Quality 121
  audio from CDs 120
  audio from QuickTime movies 561
  audio with drag & drop 118
  MIDI tracks 124
  multichannel I/O Settings 480
  QuickTime audio 560
  QuickTime movies 554
  tracks from other sessions 108
inactive
  items 16
  making inserts 408
  making plugins 17
  Master Faders and assignments 383
  paths 75
  paths, global 76
  sends 393
  track path assignments 75
  tracks 99
Indexing
  defined 588
Infinite Peak Hold 88
Infinite Peak Hold preference 56
in-place auditioning 81
Input Channel Selector 44
Input Filter command 169
  MIDI Input Filter dialog 169, 371
  input levels 135
  Input Only Monitoring option 138
  Input Quantize command 170
  Input Quantize window 170
  Input Selector 92
  Insert Position Selector 411
  Insert Silence command 285
  and Shuffle Mode 285
  and Slip Mode 285
inserting
  controller events 341
  in MIDI Event List 372
  meter events 297
  MIDI notes 333
  program changes 345
  tempo events 291
inserting plugins during playback 409
inserting plugins on tracks 409
Inserts 383, 405
   as a shared bus 406
   for hardware I/O 405
   for plug-ins 405
   labeling 416
   making inactive (and active) 408
   mono 406
   on single tracks 406
   post-fader on Master Faders 382, 405
   shared within a submix 400
   stereo 406

inserts
   duplicating 410
   moving 410

Inserts View 384
   interlaced 531
   interleaved 459
   Internal (clock source) 522
   inverse linked panning 395
   Item 589

J
   Jam Sync 525
   JL Cooper CS-10 404
   JL Cooper MCS3000 404

K
   Key Input
      filters 415
   Key Input Selector 411
   Keyboard Focus 33
      Audio Regions Focus 34, 204
      Commands Focus 34
      Groups List Focus 34
      MIDI Regions Focus 34, 204
   keyboard Input for plug-in parameters 414
   keyboard shortcuts 414
   global key commands 33
      numeric entry 229
      recording 155

L
   labeling
      Inserts and Sends 416
      paths 72
   Last Used 79
   Latch Record Enable Buttons option 57, 137
   Latch Solo Buttons option 57, 98
   latency for recording and monitoring 139
   LCRS path examples 481
   Legacy I/O 44
   length, for selections 227
   level faders
      Output windows 387
      sends 389
   level meters
      clearing 88
      for audio tracks 87
      for MIDI tracks 87
   Levels of Undo option 60
   Levels of Undo preference 201

LFE
   enable in plug-ins 503
   example sub-path 491
   examples of discrete versus contribution 493
      faders 503
      plugin enable 411
   LFE Enable Button 411
   LFEs Follow Groups option 61
   Librarian menu 411
   Limit Pull Ups to NTSC/PAL Film Standards 528
      and QuickTime 532
   Limit To option 58
   linear crossfades 277
   Link Edit and Timeline Selection option 223
   Link Enable buttons 411
      in multi-mono plug-ins 488
   Link Mix and Edit Group Enables option 57
   Link Record and Play Faders option 139
   Link Selection button 223
   linking
      inverse panning 395
      multi-mono plug-ins 487
      plug-in controls 413
      stereo panners 395
   Local Control 19, 169
   locating
      with Fast Forward/Rewind 218
      with Location Indicators 219
   locating the playback cursor 219
   Location Indicators 218
      locating with 219
   locations, for MIDI notes
      dragging 336
      quantizing 361
      randomizing 360, 362
   Lock/Unlock Regions command 256
      Lock Regions command 256
   Loop Playback option 234
      and Auto Touch mode 429
   loop points 162
      and Playback Markers 163
   Loop Record mode 144, 160
   loop recording
      and pre/post-roll 160
      audio 159
      MIDI 176
         drum machine style 176
      multiple takes 177
   looping selections 234
   loops and reverb, delay 451
   Low Latency Monitoring option 139
   Lt Rt 472
   LTC (Linear Time Code) 512

M
   Machine Chases Memory Location option 58, 537
   Machine Control 535
   Machine Control option 58
   Machine Cues Intelligently option 58
   Machine Follows Edit Insertion/Scrub option 58, 537
   Mackie HUI 404
   main paths 67
   Main Time Scale 214, 527
   Make Selected Tracks Inactive command 99
   managing regions 286
Manual Tempo mode 31, 148
Manually Find and Relink 129
mapping paths in I/O Setup 74
Markers 300
creating 302
creating on the fly 303
deleting 306
editing 305
extending selections to 229
moving 305
sorting 308
tick-based and sample-based 301
viewing options 307
Master Faders
adding 382
and DSP usage 579
as master send level control 402
inactive 383
inserts 405
meters pre/post fader 383
multichannel 487
paths 387
post-fader inserts 382
signal flow 382
Master Link Button 411
in multi-mono plug-ins 488
master view for tracks 192, 441
mastering
digitally 463
to disk 462
Matching Start Time Takes List preference 60
matrix 471
Mbox 9
measures
partial 299
renumbering 299
media 589
Medium Priority Playback option 553
Memory for Automation Recording option 427
Memory Locations 300, 301
creating 302
creating on the fly 303
deleting 306
deleting all 306
editing 305
extending selections to 229
Markers 300
recalling 304
recalling Edit selections 166
renaming 305
Selection Memory Locations 301
storing Edit selections 166
Memory Locations window
view filter 307
viewing options for Markers 307
Merge mode (see MIDI Merge mode)
Merge Paste command 262
Metadata 589
meter
current 297
default 147
meter events 297
editing 298
inserting 297
Meter Ruler
displaying 297
extending an Edit selection to 298
meters
sends view 392
SurroundScope plug-in 506
Mic Preamps View 385
MIDI 18
and signal paths 19
audio input to Pro Tools 398
common misconceptions 19
Default Thru Instrument 169
patch names 343
MIDI Beat Clock command 542
MIDI channels 18
assigning 97
MIDI clips and Regions List 202
MIDI control surfaces 18, 404
MIDI controller devices 18, 167
Local Control 19, 169
MIDI Device/Channel Selector 97
MIDI devices 18
MIDI editing
setting the Grid value 333
MIDI Event List 369
deleting events 375
editing events 374
inserting events 372
navigating in 370
Options menu 376
selecting events 375
View Filter 371
MIDI files (see Standard MIDI Files)
MIDI Input Selector 96, 172
MIDI Machine Control (MMC) 535
configuring in Pro Tools 535
controlling external devices with 535
remote track arming 540
syncing to a sequencer with 540
MIDI menu
All Notes Off command 350
Change Duration command 356
Change Meter command 297
Change Tempo command 291
Change Velocity command 354
Click Options command 146
Groove Quantize command 363
Input Devices command 168
Input Filter command 169
Input Quantize command 170
MIDI Beat Clock command 542
MIDI Thru option 169
Quantize command 358
Renumber Bars command 299
Select Notes command 352
Split Notes command 353
Transpose command 357
MIDI Merge mode 31, 145, 171
MIDI notes
attributes for 339
chasing 347
deleting 339
 duplicating selected 261
 editing 335
durations 356
pitch 336
velocities 337, 354
inserting 333
lengths in ticks 216
moving 336
quantizing 358, 363
selecting 335, 352
splitting 353
transposing 336, 357
trimming start/end points 337
MIDI offsets 348
MIDI Operations window 351
 parameter options 352
MIDI Output Selector 172
MIDI patch name files (.midnam) 343
MIDI Preferences 64
 Default Note On Velocity option 334
 Global MIDI Playback Offset option 348
 Pencil Tool Resolution When Drawing Controller Data option 64, 341, 436
MIDI recording 167
 cancelling takes 174
 enabing input devices 168
 Input Filter 169
 Merge/Replace mode 171
 monitoring with MIDI Thru 168
 quantizing on input 170
 System Exclusive data 179
 undoing a take 174
 Wait for Note 170
MIDI regions 196
 and controller events 199
 and Merge Paste command 262
 and punch recording 176
 guidelines for editing 198
MIDI Regions Focus 34, 204
MIDI Regions List 202
 and MIDI clips 202
 dragging from 242
 finding regions 203
 sorting 203
MIDI Regions List menu
 Auto Rename Selected command 287
 Clear Selected command 288
 Display All command 203
 Find command 203
 Import MIDI command 125
 Rename Selected command 287
 Select Unused command 288
 Sorting option 203
 Time Stamp Selected command 251, 546
MIDI Replace mode 31, 145, 171
 MIDI Thru option 169
MIDI tracks
 and MIDI offsets 348
 and tempo changes 293
 assigning to multiple channels 173
 channel strips 86
configuring for recording 171
default program change 342
exporting 125
loop recording 176
Merge Paste command 262
note chasing 348
Notes view 191, 197
punch recording 174
punching on the fly 175
record enabling 137
recording 167
Regions view 191, 197
selecting a pitch range in 352
SysEx view 347
Velocity view 337
Minimum Sync Delay option 539
Minutes:Seconds Time Scale 214
missing files
 skipping 129
mix busses 390
MIX Core card 6
MIX Farm card 6
Mix Group 102
Mix window 21
 track controls 21
 track width 99
Mix Window Follows Bank Selection option 55
Mix Window Shows option 21
 mixed file types 51, 106
 mixer channels 14
Mixer plugins
 Pro Tools|24 MIX Systems 577
 Pro Tools|24 Systems 577
 Pro Tools|HD Systems 577
 mixing 467
surround formats 468
mixing and DSP usage 570
mixing down to stereo 462
MMC (see MIDI Machine Control)
monitoring
during punch recording 159
MIDI recording with MIDI Thru 168
record and playback levels 138
monitoring latency 139
monitoring modes 138
 Auto Input Monitoring 138
 Input Only Monitoring 138
 mono
Bounce to Disk 459
format 468
paths 71
Mono In/Stereo Out 406
Mono Inserts 406
Movie
 sync offset 556
Movie menu
 Bounce to Movie command 561
Highest Priority Playback option 553
Import Audio From Current Movie command 561
Import Audio From Other Movie command 120
Import Movie command 554
Medium Priority Playback option 553
Normal Priority Playback option 553
Set Movie Sync Offset command 558
Show Movie Window command 557

606 Pro Tools Reference Guide
Movie Tracks 554
    scrubbing 556
    setting sync point 558
Movie window 557
movies (see QuickTime movies)
moving
    Bar|Beat Markers 296
    Markers 305
    MIDI notes 336
    program changes 346
    sysex events 347
moving inserts 410
MP3 and Digidesign hardware 458
MP3 file format 456
MPEG-1 Layer 3 456
MTC (MIDI Time Code) 511
    outputting 524
multichannel plug-ins 406, 487
multichannel regions 190
multichannel tracks 156
    and automation 438
    dragging regions to 263
    names for 141
    replacing regions in 268
    signal routing 483
    splitting 263
multi-mono
    plug-in Channel Selector 488
    plug-ins 406, 487
Multiple mono 459
multiple outputs
Hardware Setup 45
multiple tracks
    and Beat Detective 321
    audition takes 161
    editing across 260
    extending selections to 230, 231
    fitting audio regions to Edit selection 270
    nudging regions in 254
    pasting to 260
    selecting 230
    separating regions on 240
    shuffling regions on 250
MultiShell 579
Mute automation 437
Mute button 98
Mute Frees Assigned Voice option 98, 99
Mute/Unmute Region command 257
Mutes Follow Groups option 61
Mutes Follow Mix Groups option 97
muting
    regions 257
    tracks 98
N
    Narrow Mix Window option 99
    network connections 583
New Group command 101
New Session command 46
    and last used 79
New Track command 151, 171
    New Track dialog 151
No Auto-Scrolling option 220
No Output 388
    by deleting paths 73
No Peak Hold 88
    No Peak Hold preference 56
non-contiguous selections 226
nondestructive editing 189
    for audio 196
    for MIDI 198
Nondestructive Record mode 144
non-destructive recording 156
    recording to a new playlist 157
    with QuickPunch 181
Normal Priority Playback option 553
Note Chasing option 347
    notes (see MIDI notes)
Notes view 191, 197
    mini-keyboard 197
    scrolling up or down 197
NTSC 528
    speed 515
Nudge value 253
    trimming regions by 248
    nudging 253
    by next Nudge Value 254
    multiple regions 254
    region contents 255
    selection range 228
    selection start/end points 228
    selections and regions 254
    setting the Nudge value 253
numeric entry
    Calculator mode 229
    shortcuts 229
Numeric Keypad Mode 57
Numeric Keypad modes 35, 57
    Classic 35
    Shuttle 36, 223
    Transport 35
Q
    Object Grabber 226
    and Edit Groups 227
    Object selections 226
offline regions 190
    offset (movie sync) 556
OMS IAC driver 537
OMS MIDI Setup command 538
OMS Names Manager 344
OMS patch names 344
OMS Studio Setup 541
    On Stop 444
    Online button 28
    Online option 58, 533
    online recording 534
    on-the-fly punch recording
    MIDI tracks 175
    QuickPunch 145, 181
    Open Ended Record Allocation option 58, 143
    Open Session command 48
    opening multiple plug-in windows 412
Operation Preferences 57
   Audio During Fast Forward/Rewind option 218
   Auto Regions Fade In/Out Length option 281
   Edit Insertion Follows Scrub/Shuttle option 221
   Latch Record Enable Buttons option 137
   Link Record and Play Faders option 139
   Machine Chases Memory Location option 537
   Machine Follows Edit Insertion/Scrub option 537
   Open Ended Record Allocation option 143
   Record Online option 534
   Use F11 for Wait for Note 170

Operations menu
   Auto Input Monitoring option 138
   Auto-Spot Regions command 545
   Calibration Mode command 136
   Copy Edit Selection to Timeline command 236
   Copy Timeline Selection to Edit command 236
   Destructive Record mode 157
   Input Only Monitoring option 138
   Link Edit and Timeline Selection option 223
   Loop Playback option 234
   Loop Record mode 160
   Low Latency Monitoring option 139
   Mute Frees Assigned Voice option 98, 99
   Online option 533
   Play Edit Selection command 236
   Play Timeline Selection command 236
   Pre/Post Roll Playback command 165
   Pre/Post-Fader Metering option 88
   Pre-Fader Metering 88
   Scroll Options 220

Optical
   ADAT I/O 44
   Optical (S/PDIF)

Hardware Setup 44
   Output Channel Selector 44

Output Options
   Conversion Quality option 460
   Sample Rate 460
   Output Selector 93
   Output windows 387
   outputs
      default 5.1 paths and sub-paths 479
      format and tracks 485
      to multichannel paths 486
      overlap crossfades 277
      overlapping paths 75

P
   Page Scroll During Playback option 220
   PAL 528
   Pan automation 437
   Pan Indicator 87
   Pan Slider 87
   panning
      3-knob 502
      and groups 505
      automation and groups 439
      fine-adjust mode 501
      grids 495
      guidelines 490
      linked stereo 395
      multichannel automation playlists 505
      take over in grid 501
      trajectory 503
      X/Y mode 500
   parallel mixing 485
   partial measures 299
   pass-through point 424
   Paste command 259

paths
   active and inactive 75
   applying 75
   audition 80
   creating and editing 71
   creating multichannel 480
   default mono and stereo 71
   default order 81
   default output 80
   deleting 73
   for surround 488
   last used 79
   main 67
   mapping 74
   mono versus stereo 71
   multichannel example 74
   naming 72
   overlapping 75
   reset using Default 73
   Stereo Mix preset 79
   sub-path surround examples 491

PCI Bus Activity 427
   Peak Hold option 56, 88
   Peak Indicator 87
   Peavey PC-1600 404

Pencil Tool
   Freehand 331
   Line 332
   Random 332
   selecting the Pencil tool shape 331
   Square 332
   Triangle 332

Pencil tool 264, 331
   as Eraser 340
   drawing automation with 435
   editing breakpoints with 437
   inserting MIDI notes with 333
   repairing waveforms with 264
   resolution for inserted controller events 341
   shapes 435

Pencil Tool Resolution When Drawing Controller Data option 64, 341, 436

Performance Volume
   defined 590
   Playback 590
   Record 590

Phase Invert button 411
pitch, for MIDI notes
   transposing 336
   transposing with Transpose command 357
Play button 28
Play DV Movie Out FireWire Port 555
Play Edit Selection command 236
Play MIDI Notes When Editing option 64
Play Timeline Selection command 236
playback cursor 217
   locating 219
Playback Cursor Locator 219
Playback Engine 524
Playback Markers 163, 224
   and Edit selections 224
   and selection length 227
   and Timeline selections 235
Playhead 220
   and Edit selections 236
   and Timeline selections 236
   moving to region boundaries 237
playing
   and on-the-fly selections 226
   at half-speed 186
   Edit selections with Playhead enabled 236
   from a track point 217
   selections 233
   Timeline selections with Playhead enabled 236
   tracks 217
Playlist Selector 13
playlists 13, 199
   adding new 200
   and multichannel tracks 438
   and non-destructive MIDI editing 198
   assigning 200
   automation playlists 199, 422, 428
   auto-naming 200
   deleting 200
   duplicating 199
   edit playlists 199
   recalling 200
   recording to new 158
   renaming 200
   setting pre/post-roll in 165
plug-in controls, linking 413
plug-in inserts 405
plug-in parameters
   editing 414
Plug-In Selector
   for real-time plug-ins 411
PlugIn Settings menu 411
Plug-In window
   closing multiple windows 412
   opening multiple windows 412
plug-ins
   and pull rates 532
   and surround mixing 487
   automating 431
   automation accuracy in bounce 461
   bypassing from window 413
   Channel Selector for multi-mono 488
   for surround 487
   inserting during playback 409
   inserting on tracks 409
   inserting on-the-fly 409
   linking 487
linking and unlinking 413
   making inactive (and active) 17
mixers 578
mono-to-stereo 406
multichannel 406
multi-mono 406, 487
removing from tracks 409
positional reference 511
pre crossfades 272, 278
pre/post-roll
   and loop recording 160
   and punch recording 158
   auditioning 233
   setting 164
pre/post-Roll Flags 165, 224
Pre-Fader Metering 88
Preferences
   AudioSuite Dither
     Bit Depth option 63
   general 588
   Limit Pull Ups to NTSC PAL 528
   OS X User 593
   Zoom Toggle Track Height 211
Pre-Process using Standard Conform 324
Pro Tools 5.1.x 25
Pro Tools Inputs 168
Pro Tools LE
   file management 127
Pro Tools LE systems 9
   capabilities 10
Pro Tools TDM systems
   24-bit input and output 463
   file management 127
   QuickPunch 182
Pro Tools|24 MIX-series systems 6
Pro Tools|24 systems 6
Pro Tools|HD systems 5
processing bandwidth 427
Processing Preferences 62
ProControl 404
Program Change dialog 342
program changes 18, 341
   and bank select 341
   auditioning 346
   challenging 348
   default, for MIDI tracks 342
   deleting 348
   editing 345
   inserting 345
   moving 346
   patch names 344
Progressive Scan 531
ProLogic 468
Pull Up and Down
   NTSC and PAL settings 528
pull up and down
   and plug-ins 532
   and rulers 532
pull up and pull down
audio 528
video 528
Pull Up/Down 516
3:2 Pulldown 514
configuring 533
Punch In Frame Offset preference 59
Punch Out Frame Offset preference 59
punch points 162
and Playback Markers 163
punch recording
and monitoring 159
and pre/post-roll 158
audio 158
MIDI 174
MIDI on the fly 175
Q
Quantize command 358
experimenting with 362
Quantize window 359
Quantize Regions command 256
and Grid value 252
Quantize window 359
Quantize Options 360
quantizing
MIDI notes 358, 363
attacks vs. releases 359
MIDI on input 170
QuickPunch 145, 181
crossfades 181
non-TDM systems 183
region/take numbering 184
TDM systems 182
QuickPunch Crossfade Length option 60, 181
QuickTime
and Avid Xpress DV 555
QuickTime file format 454
QuickTime file formats 560
QuickTime movies 551
bouncing to 561
conforming 552, 559
frame length 553
importing 554
importing audio from 561
offset in Feet. Frames 558
offsetting 558
optimizing for playback 557
playback quality 553
requirements 553
setting start time 558
spotting 559
Quit command (Macintosh) 54
R
randomizing
note durations 356
note locations 360
RealAudio file format 455
real-time editing 189
real-time plug-ins 405
Rear Divergence 503
Recall Original Track Selections preference 59
Recompute Invalid Overviews preference 55
record (database) 591
Record button 29, 144
Record Enable button 136
record enabling tracks 136
record modes 143
and MIDI 145
Destructive Record mode 144
Loop Record mode 144
Nondestructive Record mode 144
QuickPunch 145
switching with Record button 144
Record Online at Insertion/Selection preference 58
Record Online at Time Code (or ADAT) Lock preference 58
Record Online option 534
Record Pause mode 156
Record Safe mode 137
recording 155
a mono audio track 151
a stereo audio track 151
a submix to disk 451
additional takes 156
at half-speed 186
bouncing to disk 452
cancelling takes 154
destructively 157
from a digital source 184
from Record Pause mode 156
keyboard shortcuts 155
monitoring latency 139
multichannel tracks 155
multiple audio tracks 155
non-destructively 156
non-destructively 11
online 534
System Exclusive data 179
to a new playlist 158
to the system volume 143
with a countoff 147
with Round Robin Allocation 142
with the click 146
Red Book Audio CDs 562
Redo command 201
Regenerate Missing Fades 129
region boundaries
extending selections to 228
moving edit cursor to 231
moving Playhead to 237
region definitions 120, 547
Region List Selection Follows Track Selection option 60, 202, 233
regions 13:
aligning to region start points 244
auto-created 190
auto-naming parameters 287
auto-spotting 545
capturing 239
clearing 258
conforming with Beat Detective 322
consolidating 286
copying 259
creating 239
crossfading between 278
cutting 259
default names 140
deleting underlying 259
displaying all 203
displaying names 194
displaying times 194
dragging from Regions List 242
dragging to multichannel tracks 263
duplicating 261
exporting as audio files 118
extending selections to include 228
finding 203
healing separations 242
hiding auto-created 288
inserting silence into 285
locking 256
managing 286
moving in Grid mode 253
multichannel 190
muting 257
nudging 254
offline 190
Original Time Stamp 251
pasting 259
placing at Edit insertion point 243
placing in tracks 242
removing unused 288
renaming 287
repeating 261
replacing 267
selecting 225
separating 239
separating with Beat Detective 320
separating with Separation Grabber 241
shifting 255
shuffling 249
sliding 249
slipping 250
spotting 251, 544
spotting to movies 559
sync points 243, 547
time stamping 545
trimming by Nudge Value 248
trimming start/end points 245
trimming to Edit insertion point 248
trimming unwanted data from 241
User Time Stamp 251
user-defined 190, 286, 288
whole-file audio regions 190
Regions view 191, 197
related takes 161
and Separate Region command 162
preferences for 162
Relative Grid mode 253
Remote Mode option 59
remote track arming 540
Remove Sync Point command 243
removing crossfades 278
Sends 390
removing plug-ins from tracks 409
Rename Selected command 287
renaming auto-created regions 286
groups 102
Memory Locations 305
playlists 200
regions 287
Renumber Bars command 299
Repeat command 261
Repeat Paste To Fill Selection command 269
repeating selections and regions 261
Replace mode
Replace Regions command 267
and multichannel tracks 268
Replace Regions dialog 267
reset paths 73
Restore Performance command
Restore Performance window 367
Return to Zero button 28
Rewind
incrementally 218
locating with 218
Rewind button 28
Round Robin Allocation 142
RTAS plug-ins 406
Ruler View Shows option 213
Rulers
changing display order 213
Conductor Rulers 213
displaying all 213
scrolling in 219
Timebase Rulers 212
zooming in 210
rulers pull up and down 532
S
S/PDIF
Hardware Setup 44
safing automation 428
sample delays (see DSP delays)
sample rate
film speed vs. video speed 515
Sample Rate Conversion Quality 460
sample rate conversion quality 121, 560
Sample Rates
custom 460
110.25 kHz 460
117.64 kHz 460
192 kHz 460
44.1 kHz 460
48 kHz 460
88.2 kHz 460
96 kHz 460
Samples Time Scale 214
Save Session As command 49
Save Session command 49
Save Session Copy In command 50, 52, 131
saving a copy of a session 50
scaling note velocities 338, 355
screen savers 583
Scroll Options 220
scrolling in the Ruler 219
Notes view up or down 197
Scrub Trimmer 247
Scrubber tool 221
in Shuttle mode 222
selecting with 231
scrubbing 221
a single audio track 221
and edit cursor 221
in Shuttle Lock mode 222
Movie Tracks 556
on two audio tracks 222
playback speed and direction 221
resolution 222
with Scrub Trimmer 248
with the Selector 222
SDDS 468
Select All command 225
Select Notes 352
Select Unused Regions command 288
selecting
a pitch range of notes 352
across multiple tracks 230
all regions in a track 225
all regions in all tracks 225
during playback 226
in MIDI Event List 375
MIDI notes 335, 352
non-contiguous regions 226
notes in a chord 353
on all tracks 230
regions 225
track material 224
with Scrubber 231
with Selection Indicators 229
Selection Indicators 229
Selection Memory Location 301
moving stored selection 305
selections
and Bounce to Disk 452
and Edit Groups 225
and hidden tracks 225
and Playback Markers 224
auditioning start/end points 233
changing length of 227
clearing 258
consolidating 286
copying 259
cutting 259
duplicating 261
extending 228
extending to the Meter Ruler 298
extending to the Tempo Ruler 293, 306
including Conductor Rulers 230
looping 234
moving to adjacent tracks 230
moving to the next/previous region 231
non-contiguous 226
nudging 228, 254
nudging start/end points 228
Object 226
on-the-fly 226
pasting 259
playing 233
removing a track from 231
repeating 261
shifting 255
storing with Memory Locations 301
Selector tool 217
scrubbing with 222
selecting MIDI notes with 335
Send controls 389
Send Levels Follow Groups option 61
Send mute 389
Send Mutes Follow Groups option 61
Send pan 389
Sends 389
adding 389
and multichannel mixing 486
assignment view 391
automating 430
changing default setting 390
copying track automation to 431
default level 390
displaying controls for 392
for hardware I/O 390
for mix busses 390
labeling 416
mono or stereo 390
multichannel 486
removing 390
Sends Default to INF preference 57
Sends View 385
Sends View Shows 391
Separate Region command 239
and multiple tracks 240
and related takes 162
Separate Region Operates On All Related Takes option 60,
162, 240
Separation Grabber 241
Session Setup window 520
Current Time Code 548
session templates 52
sessions 12
audio format 522
bit depth 47, 522
closing 54
creating 46
creating for surround mixing 478
default tempo 294
frame rate 523
mixed audio formats 51
opening 48
sample rate 522
saving 49
start frame 522
Set Movie Sync Offset 556
Set Movie Sync Offset command 558
setting punch/loop points 162
Setups menu
Disk Allocation 141
I/O Setup 68
OMS MIDI Setup 538
OMS Names 344
OMS Studio Setup 541
Preferences command 55
Shift 255
shortcuts for keyboard input 414
Show Disk Names option 202
Show File Names option 202
Show Full Pathnames option 202
Show Meters in Sends View option 392
Show Meters in Sends View preference 56
Show MIDI Operations command 351
Show Movie Window command 557
Show System Usage 570

612 Pro Tools Reference Guide
Shuffle mode 205
and locked regions 256
and moving regions 249
Shuttle Lock mode 222
Shuttle, Numeric Keypad mode 36, 58, 223
side chain processing 415
side-chain processing 411
signal flow
Audio Tracks 380
Auxiliary Inputs 381
Master Faders 382
signal routing
and default path order 81
basics for surround 486
example 15
surround examples 492
Skip All 129
sliding regions 249
Slip mode 206
and moving regions 250
Smart Tool 265
and audio tracks 265
and MIDI tracks 266
and multichannel tracks 266
creating crossfades with 265
creating fades with 265
editing automation with 266
editing controller events with 266
Smooth and Thin Data After Pass option 61, 434
smoothing automation 426
SMPTE
configuration 526
frame formats 513
start frame for session 522
SMPTE/ITU 468
snapshot automation 445
adding to empty automation playlists 445
and trim values 447
writing over existing automation 446
SND resource file format 454
Soft Limit 44
Solo button 98
Solo Safe mode 98
soloing
tracks 98
tracks in a submix 402
Solos Follow Groups option 61
Solos Follow Mix Groups option 97
sorting
Markers 308
regions 203
Sorting option 203
Sound Designer II file format 454
Source Path 453
speakers
layouts 468
suggested 5.1 placement 470
surround calibration 471
surround placement 470
Split Notes command 353
Split Notes dialog 353
Split Selected Tracks Into Mono command 263
splitting stereo and multichannel tracks 263
Spot dialog 251, 543
Use Subframes option 544, 546
User Time Stamp button 545
Spot mode 206, 543
and moving regions 250
trimming regions in 545
spotting
auto-spotting 545
QuickTime movies 559
regions 251, 543, 544
Standard MIDI Files 124
exporting 125
importing 124
Type 0 124
Type 1 124
Standard Trimmer 245
start frame, for sessions 522
Start, End, and Length display 27
stems
surround examples 492
stepped control automation 438
stereo format 468
Stereo Inserts 406
stereo interleaved files, exporting 119
Stereo Mix
I/O Setup factory preset 79
Stereo Mixer plug-in 578
stereo tracks
dragging regions to 263
names for 140
replacing regions in 268
splitting 263
Stop button 28
Strip Silence 283
and region naming 284
stuck notes 350
sub
with bass management 476
Sub Time Scale 215, 527
subframes 544
submixes
applying an Insert to 400
bouncing to 461
bouncing to disk 452
soloing tracks in 402
sub-paths
elements for surround 489
Support Background Record Applications preference 57
surround
and sends 486
basic signal routing 486
bass management 476
center percentage (%) 505
concepts 467
configuring Pro Tools and sessions 478
delivery formats 475
discrete level, solo, mute 484
divergence basics 473
coding and decoding 475
eexample 5.1 format paths 481
formats 467
importing I/O Settings 480
Lt Rt 472
mix compatibility 474
mixing concepts 474
mixing formats 488
pan playlists and automation 505
panning grids 495
Pro Tools formats 468
settings files 478
speaker arrangements 468
terminology 471
using paths 488
using sub-paths, examples 489
Surround Mixer
plug-in features 578
specifications 577
SurroundScope 506
Suspend All Groups command 102
suspension automation 432
swing 360, 362
SYNC I/O 510, 513
and VSO
generating time code with 534
resolving with 520
sync options 520
Sync Mode 522
Sync Mode (see also Clock Source) 522
Sync Offset 525
sync points 547
for QuickTime movie 558
for regions 243
from Beat Detective 325
identifying 243, 547
synchronization 509
3:2 Pulldown 514
and film 514
Bi-Phase/Tach 512
black burst 548
film speed vs. video speed 515
guide tracks 514
LTC 512
MIDI Beat Clock 542
MMC 535
options 519
positional reference 511
Pull Up/Down 516
resolving 548
SMPTE frame formats 513
time code 511
troubleshooting 548
VITC 512
synchronizing to a sequencer
Macintosh 537
Windows 539
with MMC 541
Sysex view 347
System Activity 427
System Exclusive data 19, 347
deleting 347
moving 347
recording 179
System Usage 427, 570
System Usage Window Shows 570
T
Tab to Transients button 232
take over (surround pan) 501
Take Region Lengths That Match option 60, 162
Take Region Names That Match Track Names option 60, 162
takes
auditioning 160
default names 140
numbering for QuickPunch 184
recording additional 156
Takes List pop-up menu 161
and multiple tracks 161
tapping in the tempo 149
Target Button 411
Tascam DA30 44
TC/E plug-in preference 63
TDM Mixer plug-ins 578
TDM plug-ins 406
and DSP usage 579
MultiShell 579
TDM systems 5
audio interfaces 8
QuickPunch 182
TDM Time Slot usage 427
technical support
suggestions 583
templates
Beat Detective 318
tempo
current 291
default 148, 294
effects on Markers and Memory Locations 301
effects on MIDI and audio 293
Manual Tempo mode 148
tapping in 149
tempo events 291
and Bar/Beat Markers 296
editing 292
inserting 291
tempo map
from Identify Beat command 294
Tempo Ruler
displaying 291
extending an Edit selection to 293, 306
Thin Automation command 435
thinning automation 426, 434
tick-based and sample-based 301
tick-based timing 215
time code 511
 and Jam Sync 525
capturing 544
freewheeling 524
generating 524, 534
Time Code Time Scale 214
Time Scale 213
Bars:Beats 214
Feet:Frames 214
Main 214, 527
Minutes:Seconds 214
Samples 214
Sub 215, 527
Time Code 214
time stamp 545
Time Stamp Selected command 161, 251, 546
time stamps and Bounce to Disk 452
Time Trimmer 246
TimeAdjuster TDM plug-in 565
Timebase Rulers 212
 and selecting on all tracks 230
 and Timeline selections 235
Edit Markers 224
Playback Markers 224
Pre-/Post-Roll Flags 224
sliding Edit selections 232
sliding Timeline selections 236
Timeline Insertion Follows Playback option 57
Timeline selections 235
 and Playback Markers 235
auditioning with Playhead enabled 236
copied from Edit selection 236
copied to Edit selection 236
in Timebase Rulers 235
sliding in the Ruler 236
start, end, and length fields 30
To All Enabled Parameters
 writing automation 447
To Current Parameter
 writing automation 447
toggling
 Track View 192
 zoom level 210
Touch Timeout option 62
track controls
 Edit window 26
 Mix window 26
 track data 190
Track Height 192
 and Zoom Toggle 210
track layout
default path order 81
track level meters 87
Track Name/Comments dialog 89
Track Selection Follows Regions List Selection option 59, 233
Track Selector 411
Track View 190
 and edit content 257
Blocks 191
Expanded Track Display 193, 438
master view 441
Notes 191, 197
Regions 191, 197
Sysex 347
toggling 192
Velocity 337
Waveform 190, 194
Track View Toggle 192
track width 99
tracks
5.1 format track layout 484
adding to selection 230, 231
and surround 483
appending new material to end of 157
color coding 100
deleting 90
duplicating 90
entering comments 90
grouping 100
hiding 91
importing 108
locating with Fast Forward/Rewind 218
making inactive/active 99
master view 192, 441
moving selections between 230
muting 98
names 89
placing regions in 242
playback priority 95
playing 217
record enabling 136
removing from a selection 231
selecting across multiple 230
selecting all regions in 225
selecting all regions in all tracks 225
selecting material in 224
selecting on all 230
soloing 98
Track Height 192
Track View 190
transposing 358
trimming unwanted data from 241
trajectory panning 503
Transfer
 files 129
 Transfer Volume
defined 593
transients
detecting with Beat Detective 314
tabbing to 232
Transport Master 536
Transport Numeric Keypad Mode 57
Transport window 28
MIDI controls 30
pre/post-roll 29, 164
start, end, and length fields 30, 163
transport controls 28
Transport, Numeric Keypad mode 35
Transpose 357
transposing 357
by octave 358
key 358
MIDI notes 336
tracks 358
Trim Automation command 447
Trim End To Insertion command 248
Trim Start To Insertion command 248
Trim To Selection command 241
Trimmer tool 245
Scrub Trimmer 247
Time Trimmer 246
trimming
automation breakpoints 437, 444
crossfades 278
input sum levels 576
note start/end points 337
region start/end points 245
regions by Nudge Value 248
regions to Edit insertion point 248
regions with Scrub Trimmer 248
unwanted region and track data 241
Tweak-head setting 460
U
unavailable I/O
showing 77
Undo and audio recording 154
Undo command 201
Universe window 211
unlinked Edit and Timeline selection 223
unlinking plugin controls 413, 487
Use All Available Space preference 58
Use AudioSuite Dither preference 62, 403
Use F11 for Wait for Note option 57, 170
Use Squeezer option 460
User Time Stamp 251, 547
user-defined regions 190, 286, 288
V
Variable Speed Override (VSO) 523
velocities, for MIDI notes
default for inserted 334
drawing with Pencil 338
editing 337, 354
editing velocity 337
fading 355
scaling 355
scaling with Trimmer 338
Velocity view 337
Vertical Zoom buttons 208
video
recording limits with pull 532
video capture/playback cards 552
Video Pull Up/Down 528
video speed 515
View Filer command 371
views
Comments View 88
I/O View 86
Inserts View 384
Sends View 385
Virtual Memory 583
VITC (Vertical Interval Time Code) 512
Voice Selector 22, 26, 95
voices
allocating 96
and track priority 95
auto-assignment of ascending 95
Volume
types, definitions 590
Volume automation 437
Volume Indicator 87
VSO (see Variable Speed Override)
W
Wait for Note 30, 170
WAV file format 130, 454
AES31/Broadcast compliant 130
Waveform view 190, 194
waveforms 154
and zero-crossing 195
avoiding clicks and pops 195
drawn rectified 195
guidelines for editing 195
repairing with Pencil tool 264
whole-file audio regions 190
Wide Meters View 88
Windows menu
Show System Usage 570
Word Clock 44
Word clock
about 594
Write Automation command 445, 446
Write Switches to Touch After Pass preference 61
Write to Start/All/End buttons 442
writing
automation 429
automation on stop 444
automation to start, end, or all 442
snapshot automation 445
X
XML (Extensible Markup Language) 343
Z
zero-crossing 195
Zoom Presets 208, 210
Zoom Toggle 210
Track Height 211
Zoomer tool 208, 209
zooming 208
a track area 209
all the way out 209
around a track point 209
default toggle height 211
horizontally for all tracks 208
in the Ruler 210
on a selection 208
recalling zoom levels 210
return to the previous zoom level 208
storing zoom levels 210
vertically for all audio tracks 208
vertically for all MIDI tracks 208
Zoom Toggle 210